telos.Ird.AnalogDevices Namespace

Classes
 | Class | Description
Public class | Ad7291 | Analog Devices: AD 7291
Public class | Ad7414 | Analog Devices: AD 7414
Public class | Ad7415 | Analog Devices: AD 7415
Public class | Ad7416 | Analog Devices: AD 7416
Public class | Ad7417 | Analog Devices: AD 7417
Public class | Ad7418 | Analog Devices: AD 7418
Public class | Ad78797889 | Analog Devices: AD 7879 - 1 / AD 7889 - 1
Public class | Add5201 | Analog Devices: ADD 5201
Public class | Add5203 | Analog Devices: ADD 5203
Public class | Adm1021a | Analog Devices: ADM 1021 A
Public class | Adm1022 | Analog Devices: ADM 1022
Public class | Adm1023 | Analog Devices: ADM 1023
Public class | Adm1024 | Analog Devices: ADM 1024
Public class | Adm1025 | Analog Devices: ADM 1025(A)
Public class | Adm1027 | Analog Devices: ADM 1027
Public class | Adm1028 | Analog Devices: ADM 1028
Public class | Adm1029 | Analog Devices: ADM 1029
Public class | Adm1033 | Analog Devices: ADM 1033
Public class | Adp1649 | Analog Devices: ADP 1649
Public class | Adp1650 | Analog Devices: ADP 1650
Public class | Adp1653 | Analog Devices: ADP 1653
Public class | Adp1655 | Analog Devices: ADP 1655
Public class | Adp1660 | Analog Devices: ADP 1660
Public class | Adp5020 | Analog Devices: ADP 5020
Public class | Adp5050 | Analog Devices: ADP 5050
Public class | Adp5061 | Analog Devices: ADP 5061
Public class | Adp5062 | Analog Devices: ADP 5062
Public class | Adp5065 | Analog Devices: ADP 5065
Public class | Adp5501 | Analog Devices: ADP 5501
Public class | Adp5520 | Analog Devices: ADP 5520
Public class | Adp5585 | Analog Devices: ADP 5585
Public class | Adp5587 | Analog Devices: ADP 5587
Public class | Adp5588 | Analog Devices: ADP 5588
Public class | Adp5589 | Analog Devices: ADP 5589
Public class | Adp8870 | Analog Devices: ADP 8870
Public class | Adt7316 | Analog Devices: ADT 7316
Public class | Adt7317 | Analog Devices: ADT 7317
Public class | Adt7318 | Analog Devices: ADT 7318
Public class | Adt7408 | Analog Devices: ADT 7408
Public class | Adt7410 | Analog Devices: ADT 7410
Public class | Adt7411 | Analog Devices: ADT 7411
Public class | Adt7420 | Analog Devices: ADT 7420
Public class | Adt75 | Analog Devices: ADT 75
Public class | Adt7516 | Analog Devices: ADT 7516
Public class | Adt7517 | Analog Devices: ADT 7517
Public class | Adt7518 | Analog Devices: ADT 7518
Public class | Adt7519 | Analog Devices: ADT 7519
Public class | Adxl312 | Analog Devices: ADXL 312
Public class | Adxl343 | Analog Devices: ADXL 343
Public class | Adxl345 | Analog Devices: ADXL 345
Public class | Adxl346 | Analog Devices: ADXL 346
Enumerations
 | Enumeration | Description
Public enumeration | Ad7291TypeAlertStatus |
Public enumeration | Ad7291TypeChannelAddress |
Public enumeration | Ad7291TypeCommandClearAlert |
Public enumeration | Ad7291TypeCommandEnabledDisabled |
Public enumeration | Ad7291TypeCommandExtRef |
Public enumeration | Ad7291TypeCommandPolarityAlertPin |
Public enumeration | Ad7291TypeCommandReset |
Public enumeration | Ad7414TypeConfigurationAlertEn |
Public enumeration | Ad7414TypeConfigurationAlertPolarity |
Public enumeration | Ad7414TypeConfigurationAlertReset |
Public enumeration | Ad7414TypeConfigurationFltr |
Public enumeration | Ad7414TypeConfigurationOneShot |
Public enumeration | Ad7414TypeConfigurationPd |
Public enumeration | Ad7414TypeTHighFlag |
Public enumeration | Ad7414TypeTLowFlag |
Public enumeration | Ad7415TypeConfigurationFltr |
Public enumeration | Ad7415TypeConfigurationOneShot |
Public enumeration | Ad7415TypeConfigurationPd |
Public enumeration | Ad7416TypeConfigurationCmpInt |
Public enumeration | Ad7416TypeConfigurationFaultQueue |
Public enumeration | Ad7416TypeConfigurationOtiPolarity |
Public enumeration | Ad7416TypeConfigurationShutdown |
Public enumeration | Ad7417TypeConfigurationChannelSelection |
Public enumeration | Ad7417TypeConfigurationCmpInt |
Public enumeration | Ad7417TypeConfigurationConversionMode |
Public enumeration | Ad7417TypeConfigurationFaultQueue |
Public enumeration | Ad7417TypeConfigurationOtiPolarity |
Public enumeration | Ad7417TypeConfigurationShutdown |
Public enumeration | Ad7417TypeConfigurationTest1 |
Public enumeration | Ad7418TypeConfigurationChannelSelection |
Public enumeration | Ad7418TypeConfigurationCmpInt |
Public enumeration | Ad7418TypeConfigurationConversionMode |
Public enumeration | Ad7418TypeConfigurationFaultQueue |
Public enumeration | Ad7418TypeConfigurationOtiPolarity |
Public enumeration | Ad7418TypeConfigurationShutdown |
Public enumeration | Ad7418TypeConfigurationTest1 |
Public enumeration | Ad78797889Control1Acq |
Public enumeration | Ad78797889Control1AdcMode |
Public enumeration | Ad78797889Control1ChnlAdd |
Public enumeration | Ad78797889Control1DisablePenirq |
Public enumeration | Ad78797889Control1Tmr |
Public enumeration | Ad78797889Control2Avg |
Public enumeration | Ad78797889Control2Fcd |
Public enumeration | Ad78797889Control2GpioDir |
Public enumeration | Ad78797889Control2GpioEn |
Public enumeration | Ad78797889Control2GpioPol |
Public enumeration | Ad78797889Control2Med |
Public enumeration | Ad78797889Control2Pm |
Public enumeration | Ad78797889Control2SerDfr |
Public enumeration | Ad78797889Control2SwRst |
Public enumeration | Ad78797889Control3IntMode |
Public enumeration | Ad78797889Control3Mask |
Public enumeration | Ad78797889Control3Sequencer |
Public enumeration | Add5201TypeDeviceControlBlCtl |
Public enumeration | Add5201TypeDeviceControlPwmMd |
Public enumeration | Add5201TypeDeviceControlPwmSel |
Public enumeration | Add5201TypeFaultStatus2ChSd1ChSd |
Public enumeration | Add5201TypeFaultStatusBlStat |
Public enumeration | Add5201TypeFaultStatusFault |
Public enumeration | Add5201TypeFaultStatusOvCurr |
Public enumeration | Add5201TypeFaultStatusThrmShdn |
Public enumeration | Add5203TypeDeviceControlBlCtl |
Public enumeration | Add5203TypeDeviceControlPwmMd |
Public enumeration | Add5203TypeDeviceControlPwmSel |
Public enumeration | Add5203TypeFaultStatus2ChSd1ChSd |
Public enumeration | Add5203TypeFaultStatusBlStat |
Public enumeration | Add5203TypeFaultStatusFault |
Public enumeration | Add5203TypeFaultStatusOvCurr |
Public enumeration | Add5203TypeFaultStatusThrmShdn |
Public enumeration | Adm1021aBool |
Public enumeration | Adm1021aConfigMaskType |
Public enumeration | Adm1021aConfigRunType |
Public enumeration | Adm1021aConversionRateType |
Public enumeration | Adm1022Bool |
Public enumeration | Adm1022ConfClearType |
Public enumeration | Adm1022ConfD2Type |
Public enumeration | Adm1022ConfFanType |
Public enumeration | Adm1022ConfInvertType |
Public enumeration | Adm1022ConfLockType |
Public enumeration | Adm1022ConfResetType |
Public enumeration | Adm1022ConfStartType |
Public enumeration | Adm1022EnabledDisabledType |
Public enumeration | Adm1022IrqMaskType |
Public enumeration | Adm1023Bool |
Public enumeration | Adm1023ConfigMaskType |
Public enumeration | Adm1023ConfigRunType |
Public enumeration | Adm1023ConversionRateType |
Public enumeration | Adm1023TempTypeExt |
Public enumeration | Adm1024Channel25Type |
Public enumeration | Adm1024ChannelFan1Type |
Public enumeration | Adm1024ChannelFan2Type |
Public enumeration | Adm1024ChannelIntVccType |
Public enumeration | Adm1024ChannelVidType |
Public enumeration | Adm1024CiClearType |
Public enumeration | Adm1024Conf2LockType |
Public enumeration | Adm1024Conf2ThermIrqMaskType |
Public enumeration | Adm1024Conf2ThermIrqType |
Public enumeration | Adm1024ConfClearType |
Public enumeration | Adm1024ConfInitType |
Public enumeration | Adm1024ConfResetType |
Public enumeration | Adm1024ConfStartType |
Public enumeration | Adm1024EnabledDisabledType |
Public enumeration | Adm1024FanDivisorType |
Public enumeration | Adm1024HighLowExceededType |
Public enumeration | Adm1024IrqMaskType |
Public enumeration | Adm1024IrqStatusChassisType |
Public enumeration | Adm1024IrqStatusDiodeType |
Public enumeration | Adm1024IrqStatusThermType |
Public enumeration | Adm1024TestType |
Public enumeration | Adm1025Conf12Type |
Public enumeration | Adm1025ConfInitType |
Public enumeration | Adm1025ConfResetType |
Public enumeration | Adm1025ConfStartType |
Public enumeration | Adm1025HighLowExceededType |
Public enumeration | Adm1025StatusDiodeFaultType |
Public enumeration | Adm1025TestType |
Public enumeration | Adm1025VidOffsetType |
Public enumeration | Adm1025VidRstType |
Public enumeration | Adm1027AcousticsAcouType |
Public enumeration | Adm1027AcousticsEnType |
Public enumeration | Adm1027AcousticsMinType |
Public enumeration | Adm1027ConfAinType |
Public enumeration | Adm1027ConfAlertType |
Public enumeration | Adm1027ConfAttnType |
Public enumeration | Adm1027ConfAvgType |
Public enumeration | Adm1027ConfConvType |
Public enumeration | Adm1027ConfDcType |
Public enumeration | Adm1027ConfFastType |
Public enumeration | Adm1027ConfFspdisType |
Public enumeration | Adm1027ConfFspdType |
Public enumeration | Adm1027ConfLockType |
Public enumeration | Adm1027ConfPwmBhvrType |
Public enumeration | Adm1027ConfPwmInvType |
Public enumeration | Adm1027ConfPwmSpinType |
Public enumeration | Adm1027ConfReadyType |
Public enumeration | Adm1027ConfStrtType |
Public enumeration | Adm1027ConfTodisType |
Public enumeration | Adm1027ConfVCcType |
Public enumeration | Adm1027ConfViType |
Public enumeration | Adm1027EnableDisableType |
Public enumeration | Adm1027IrqMaskType |
Public enumeration | Adm1027IrqOolType |
Public enumeration | Adm1027StatusDiodeType |
Public enumeration | Adm1027StatusFanType |
Public enumeration | Adm1027StatusHighLowExceededType |
Public enumeration | Adm1027TRangeFreqType |
Public enumeration | Adm1027TRangeRangeType |
Public enumeration | Adm1028BoolType |
Public enumeration | Adm1028ConfFanType |
Public enumeration | Adm1028ConfInvertType |
Public enumeration | Adm1028ConfLockType |
Public enumeration | Adm1028ConfResetType |
Public enumeration | Adm1028ConfStartType |
Public enumeration | Adm1028EnabledDisabledType |
Public enumeration | Adm1028FanSpeedRampRateType |
Public enumeration | Adm1028IrqMaskType |
Public enumeration | Adm1028IrqStatusClearType |
Public enumeration | Adm1028IrqStatusFlagType |
Public enumeration | Adm1028RemoteFctRstType |
Public enumeration | Adm1029AinBehaviourBit0Type |
Public enumeration | Adm1029AinBehaviourBit1Type |
Public enumeration | Adm1029AinBehaviourBit2Type |
Public enumeration | Adm1029AinBehaviourBit3Type |
Public enumeration | Adm1029AinBehaviourBit4Type |
Public enumeration | Adm1029AinBehaviourBit5Type |
Public enumeration | Adm1029AinBehaviourBit6Type |
Public enumeration | Adm1029AinBehaviourBit7Type |
Public enumeration | Adm1029AinEventMaskType |
Public enumeration | Adm1029BoolType |
Public enumeration | Adm1029ConfigAraType |
Public enumeration | Adm1029ConfigForceCfaultType |
Public enumeration | Adm1029ConfigForceIntType |
Public enumeration | Adm1029ConfigFreeWheelType |
Public enumeration | Adm1029ConfigInstallType |
Public enumeration | Adm1029ConfigIntPolarityType |
Public enumeration | Adm1029ConfigIntType |
Public enumeration | Adm1029ConfigStartMonitoringType |
Public enumeration | Adm1029FanConfigOscillatorType |
Public enumeration | Adm1029FanConfigPwmType |
Public enumeration | Adm1029FanEventMask1Type |
Public enumeration | Adm1029FanEventMask2Type |
Public enumeration | Adm1029FanSpeedType |
Public enumeration | Adm1029FanSpinUpDisableType |
Public enumeration | Adm1029FanSpinUpTimeType |
Public enumeration | Adm1029FanStatusFaultType |
Public enumeration | Adm1029FanStatusHotPlugType |
Public enumeration | Adm1029FanStatusMissingType |
Public enumeration | Adm1029FanStatusSleepType |
Public enumeration | Adm1029FaultAction0Type |
Public enumeration | Adm1029FaultAction1Type |
Public enumeration | Adm1029FaultAction2Type |
Public enumeration | Adm1029FaultAction3Type |
Public enumeration | Adm1029FaultAction4Type |
Public enumeration | Adm1029FaultAction5Type |
Public enumeration | Adm1029FaultAction6Type |
Public enumeration | Adm1029FaultAction7Type |
Public enumeration | Adm1029GpioBehaviourDirectionType |
Public enumeration | Adm1029GpioBehaviourPolarityType |
Public enumeration | Adm1029GpioBehaviourSetType |
Public enumeration | Adm1029GpioEventMaskType |
Public enumeration | Adm1029GpioPresent0Type |
Public enumeration | Adm1029GpioPresent1Type |
Public enumeration | Adm1029GpioPresent2Type |
Public enumeration | Adm1029GpioPresent3Type |
Public enumeration | Adm1029GpioPresent4Type |
Public enumeration | Adm1029GpioPresent5Type |
Public enumeration | Adm1029GpioPresent6Type |
Public enumeration | Adm1029InstalledType |
Public enumeration | Adm1029ResetType |
Public enumeration | Adm1029SetAlarmSpeedType |
Public enumeration | Adm1029SetFullSpeedType |
Public enumeration | Adm1029SetHotPlugSpeedType |
Public enumeration | Adm1029SupportedType |
Public enumeration | Adm1029TempCoolingActionType |
Public enumeration | Adm1029TempFaultActionBit0Type |
Public enumeration | Adm1029TempFaultActionBit1Type |
Public enumeration | Adm1029TempFaultActionBit2Type |
Public enumeration | Adm1029TempFaultActionBit3Type |
Public enumeration | Adm1029TempFaultActionBit4Type |
Public enumeration | Adm1029TempFaultActionBit5Type |
Public enumeration | Adm1029TempFaultActionBit6Type |
Public enumeration | Adm1029TempFaultActionBit7Type |
Public enumeration | Adm1029TempTRangeType |
Public enumeration | Adm1029UsedType |
Public enumeration | Adm1033TypeChannelSelector |
Public enumeration | Adm1033TypeConversionRate |
Public enumeration | Adm1033TypeDisabledEnabled |
Public enumeration | Adm1033TypeDiscreteLinear |
Public enumeration | Adm1033TypeDriveBhvr |
Public enumeration | Adm1033TypeFanFaultRef |
Public enumeration | Adm1033TypeFanResponse |
Public enumeration | Adm1033TypeFaultQueue |
Public enumeration | Adm1033TypeIrqMask |
Public enumeration | Adm1033TypeLockBit |
Public enumeration | Adm1033TypeReset |
Public enumeration | Adm1033TypeRoundRobin |
Public enumeration | Adm1033TypeStatus |
Public enumeration | Adm1033TypeSwCon |
Public enumeration | Adm1033TypeThermTimeWindow |
Public enumeration | Adp1649TypeAdditionalModeAdcAdcEn |
Public enumeration | Adp1649TypeAdditionalModeAdcFlVbLo |
Public enumeration | Adp1649TypeAdditionalModeAdModDynOvp |
Public enumeration | Adp1649TypeAdditionalModeAdModIIled |
Public enumeration | Adp1649TypeAdditionalModeAdModIlDc |
Public enumeration | Adp1649TypeAdditionalModeAdModIlDcEn |
Public enumeration | Adp1649TypeAdditionalModeAdModStrPol |
Public enumeration | Adp1649TypeAdditionalModeAdModSwLo |
Public enumeration | Adp1649TypeBatteryLowModeClSoft |
Public enumeration | Adp1649TypeBatteryLowModeIVbLo |
Public enumeration | Adp1649TypeBatteryLowModeVVbLo |
Public enumeration | Adp1649TypeCurrentSetIFl |
Public enumeration | Adp1649TypeCurrentSetITor |
Public enumeration | Adp1649TypeFaultInformationFl |
Public enumeration | Adp1649TypeFaultInformationIdc |
Public enumeration | Adp1649TypeFaultInformationIo2 |
Public enumeration | Adp1649TypeFaultInformationTx1 |
Public enumeration | Adp1649TypeInputControl |
Public enumeration | Adp1649TypeOutputModeFreqFb |
Public enumeration | Adp1649TypeOutputModeIlPeak |
Public enumeration | Adp1649TypeOutputModeLedMode |
Public enumeration | Adp1649TypeOutputModeOutputEn |
Public enumeration | Adp1649TypeOutputModeStrLv |
Public enumeration | Adp1649TypeOutputModeStrMode |
Public enumeration | Adp1649TypeVrefTimerFlTim |
Public enumeration | Adp1649TypeVrefTimerIo1Cfg |
Public enumeration | Adp1649TypeVrefTimerIo2Cfg |
Public enumeration | Adp1650TypeAdditionalModeAdcAdcEn |
Public enumeration | Adp1650TypeAdditionalModeAdcFlVbLo |
Public enumeration | Adp1650TypeAdditionalModeAdModDynOvp |
Public enumeration | Adp1650TypeAdditionalModeAdModIIled |
Public enumeration | Adp1650TypeAdditionalModeAdModIlDc |
Public enumeration | Adp1650TypeAdditionalModeAdModIlDcEn |
Public enumeration | Adp1650TypeAdditionalModeAdModStrPol |
Public enumeration | Adp1650TypeAdditionalModeAdModSwLo |
Public enumeration | Adp1650TypeBatteryLowModeClSoft |
Public enumeration | Adp1650TypeBatteryLowModeIVbLo |
Public enumeration | Adp1650TypeBatteryLowModeVVbLo |
Public enumeration | Adp1650TypeCurrentSetIFl |
Public enumeration | Adp1650TypeCurrentSetITor |
Public enumeration | Adp1650TypeFaultInformationFl |
Public enumeration | Adp1650TypeFaultInformationIdc |
Public enumeration | Adp1650TypeFaultInformationIo2 |
Public enumeration | Adp1650TypeFaultInformationTx1 |
Public enumeration | Adp1650TypeInputControl |
Public enumeration | Adp1650TypeOutputModeFreqFb |
Public enumeration | Adp1650TypeOutputModeIlPeak |
Public enumeration | Adp1650TypeOutputModeLedMode |
Public enumeration | Adp1650TypeOutputModeOutputEn |
Public enumeration | Adp1650TypeOutputModeStrLv |
Public enumeration | Adp1650TypeOutputModeStrMode |
Public enumeration | Adp1650TypeVrefTimerFlTim |
Public enumeration | Adp1650TypeVrefTimerIo1Cfg |
Public enumeration | Adp1650TypeVrefTimerIo2Cfg |
Public enumeration | Adp1655TypeCurrentSetFlash |
Public enumeration | Adp1655TypeCurrentSetTorchAssist |
Public enumeration | Adp1655TypeFaultInformationFault |
Public enumeration | Adp1655TypeFaultInformationLed |
Public enumeration | Adp1655TypeInputControlStrobe |
Public enumeration | Adp1655TypeInputControlTxMask |
Public enumeration | Adp1655TypeOutputModeEdgeLevelSensitive |
Public enumeration | Adp1655TypeOutputModeInductorPeakCurrentLimit |
Public enumeration | Adp1655TypeOutputModeLedOut |
Public enumeration | Adp1655TypeOutputModeLedOutputMode |
Public enumeration | Adp1655TypeOutputModeStrobe |
Public enumeration | Adp1655TypeOutputModeTorch |
Public enumeration | Adp1655TypeVrefTimerRef |
Public enumeration | Adp1655TypeVrefTimerTimer |
Public enumeration | Adp1660TypeAdditionalFeaturesClSoft |
Public enumeration | Adp1660TypeAdditionalFeaturesDynOvp |
Public enumeration | Adp1660TypeAdditionalFeaturesFreqFb |
Public enumeration | Adp1660TypeAdditionalFeaturesIlDc |
Public enumeration | Adp1660TypeAdditionalFeaturesIlDcEn |
Public enumeration | Adp1660TypeAdditionalFeaturesSwLo |
Public enumeration | Adp1660TypeCurrent200 |
Public enumeration | Adp1660TypeCurrent750 |
Public enumeration | Adp1660TypeFaultInformationFault |
Public enumeration | Adp1660TypeFaultInformationTx |
Public enumeration | Adp1660TypeFaultInformationVbLo |
Public enumeration | Adp1660TypeGpioTimerFlTim |
Public enumeration | Adp1660TypeGpioTimerIoCfg |
Public enumeration | Adp1660TypeGpioTimerLedSd |
Public enumeration | Adp1660TypeLedEnableMode |
Public enumeration | Adp1660TypeLowBatteryEnableVBatWindow |
Public enumeration | Adp1660TypeLowBatteryEnableVVbLo |
Public enumeration | Adp1660TypeOutputModeIlPeak |
Public enumeration | Adp1660TypeOutputModeLedMod |
Public enumeration | Adp1660TypeOutputModeStrLv |
Public enumeration | Adp1660TypeOutputModeStrMod |
Public enumeration | Adp1660TypeOutputModeStrPol |
Public enumeration | Adp5020TypeBk1Vsel |
Public enumeration | Adp5020TypeBk2Vsel |
Public enumeration | Adp5020TypeBkLdoEn |
Public enumeration | Adp5020TypeBkLdoXshtdn |
Public enumeration | Adp5020TypeEnoDrv |
Public enumeration | Adp5020TypeEnoHizBar |
Public enumeration | Adp5020TypeForceXs |
Public enumeration | Adp5020TypeLdoVsel |
Public enumeration | Adp5020TypePgood |
Public enumeration | Adp5020TypeSync19p2 |
Public enumeration | Adp5020TypeSync9p6 |
Public enumeration | Adp5020TypeSyncAc |
Public enumeration | Adp5020TypeTsd |
Public enumeration | Adp5050TypeDefaultSet |
Public enumeration | Adp5050TypeDvsCfgInterval |
Public enumeration | Adp5050TypeDvsCfgOn |
Public enumeration | Adp5050TypeHiccupCfgHiccup |
Public enumeration | Adp5050TypeHiccupCfgSyncOut |
Public enumeration | Adp5050TypeIntMaskLvin |
Public enumeration | Adp5050TypeIntMaskPwrg |
Public enumeration | Adp5050TypeIntMaskTemp |
Public enumeration | Adp5050TypeIntStatusLvin |
Public enumeration | Adp5050TypeIntStatusPwrg |
Public enumeration | Adp5050TypeIntStatusTemp |
Public enumeration | Adp5050TypeLchCfgOvp |
Public enumeration | Adp5050TypeLchCfgScp |
Public enumeration | Adp5050TypeLchStatusCh |
Public enumeration | Adp5050TypeLchStatusTsd |
Public enumeration | Adp5050TypeOptCfgDscg |
Public enumeration | Adp5050TypeOptCfgPsm |
Public enumeration | Adp5050TypePctrlChOn |
Public enumeration | Adp5050TypePwrgdMask |
Public enumeration | Adp5050TypeStatusRdPwrg |
Public enumeration | Adp5050TypeSwCfgFreq |
Public enumeration | Adp5050TypeSwCfgPhase |
Public enumeration | Adp5050TypeThCfgLvinTh |
Public enumeration | Adp5050TypeThCfgTempTh |
Public enumeration | Adp5050TypeVid23Vid2 |
Public enumeration | Adp5050TypeVid23Vid3 |
Public enumeration | Adp5050TypeVid4 |
Public enumeration | Adp5061TypeBatteryShortTbatShr |
Public enumeration | Adp5061TypeBatteryShortVbatShr |
Public enumeration | Adp5061TypeChargerStatus1ChargerStatus |
Public enumeration | Adp5061TypeChargerStatus1Chdone |
Public enumeration | Adp5061TypeChargerStatus1ThermLim |
Public enumeration | Adp5061TypeChargerStatus1VinIlim |
Public enumeration | Adp5061TypeChargerStatus1VinOk |
Public enumeration | Adp5061TypeChargerStatus1VinOv |
Public enumeration | Adp5061TypeChargerStatus2BatteryStatus |
Public enumeration | Adp5061TypeChargerStatus2RchLimInfo |
Public enumeration | Adp5061TypeChargerStatus2ThrStatus |
Public enumeration | Adp5061TypeChargingCurrentIchg |
Public enumeration | Adp5061TypeChargingCurrentItrkDead |
Public enumeration | Adp5061TypeFaultBatShr |
Public enumeration | Adp5061TypeFaultOverTemp |
Public enumeration | Adp5061TypeFunctionalSettings1DisIc1 |
Public enumeration | Adp5061TypeFunctionalSettings1DisLdo |
Public enumeration | Adp5061TypeFunctionalSettings1EnBmon |
Public enumeration | Adp5061TypeFunctionalSettings1EnChg |
Public enumeration | Adp5061TypeFunctionalSettings1EnEoc |
Public enumeration | Adp5061TypeFunctionalSettings1EnThr |
Public enumeration | Adp5061TypeFunctionalSettings2EnChgVlim |
Public enumeration | Adp5061TypeFunctionalSettings2EnJeita |
Public enumeration | Adp5061TypeFunctionalSettings2IdealDiode |
Public enumeration | Adp5061TypeFunctionalSettings2JeitaSelect |
Public enumeration | Adp5061TypeFunctionalSettings2Vsystem |
Public enumeration | Adp5061TypeIendC10Eoc |
Public enumeration | Adp5061TypeIendC20Eoc |
Public enumeration | Adp5061TypeIendC5Eoc |
Public enumeration | Adp5061TypeIendIend |
Public enumeration | Adp5061TypeIendSysEnSet |
Public enumeration | Adp5061TypeInterruptActive |
Public enumeration | Adp5061TypeInterruptEnable |
Public enumeration | Adp5061TypeTerminationSettingsChgVlim |
Public enumeration | Adp5061TypeTerminationSettingsVtrm |
Public enumeration | Adp5061TypeTimerSettingsChgTmrPeriod |
Public enumeration | Adp5061TypeTimerSettingsEnChgTimer |
Public enumeration | Adp5061TypeTimerSettingsEnTend |
Public enumeration | Adp5061TypeTimerSettingsEnWd |
Public enumeration | Adp5061TypeTimerSettingsResetWd |
Public enumeration | Adp5061TypeTimerSettingsWdPeriod |
Public enumeration | Adp5061TypeVoltageThresholdsDisRch |
Public enumeration | Adp5061TypeVoltageThresholdsVrch |
Public enumeration | Adp5061TypeVoltageThresholdsVtrkDead |
Public enumeration | Adp5061TypeVoltageThresholdsVweak |
Public enumeration | Adp5061TypeVpinxPinsSettingsIlim |
Public enumeration | Adp5062TypeBatteryShortTbatShr |
Public enumeration | Adp5062TypeBatteryShortVbatShr |
Public enumeration | Adp5062TypeChargerStatus1ChargerStatus |
Public enumeration | Adp5062TypeChargerStatus1Chdone |
Public enumeration | Adp5062TypeChargerStatus1ThermLim |
Public enumeration | Adp5062TypeChargerStatus1VinIlim |
Public enumeration | Adp5062TypeChargerStatus1VinOk |
Public enumeration | Adp5062TypeChargerStatus1VinOv |
Public enumeration | Adp5062TypeChargerStatus2BatteryStatus |
Public enumeration | Adp5062TypeChargerStatus2RchLimInfo |
Public enumeration | Adp5062TypeChargerStatus2ThrStatus |
Public enumeration | Adp5062TypeChargingCurrentIchg |
Public enumeration | Adp5062TypeChargingCurrentItrkDead |
Public enumeration | Adp5062TypeFaultBatShr |
Public enumeration | Adp5062TypeFaultOverTemp |
Public enumeration | Adp5062TypeFunctionalSettings1DisIc1 |
Public enumeration | Adp5062TypeFunctionalSettings1DisLdo |
Public enumeration | Adp5062TypeFunctionalSettings1EnBmon |
Public enumeration | Adp5062TypeFunctionalSettings1EnChg |
Public enumeration | Adp5062TypeFunctionalSettings1EnEoc |
Public enumeration | Adp5062TypeFunctionalSettings1EnThr |
Public enumeration | Adp5062TypeFunctionalSettings2EnChgVlim |
Public enumeration | Adp5062TypeFunctionalSettings2EnJeita |
Public enumeration | Adp5062TypeFunctionalSettings2IdealDiode |
Public enumeration | Adp5062TypeFunctionalSettings2JeitaSelect |
Public enumeration | Adp5062TypeFunctionalSettings2Vsystem |
Public enumeration | Adp5062TypeIendC10Eoc |
Public enumeration | Adp5062TypeIendC20Eoc |
Public enumeration | Adp5062TypeIendC5Eoc |
Public enumeration | Adp5062TypeIendIend |
Public enumeration | Adp5062TypeIendSysEnSet |
Public enumeration | Adp5062TypeInterruptActive |
Public enumeration | Adp5062TypeInterruptEnable |
Public enumeration | Adp5062TypeTerminationSettingsChgVlim |
Public enumeration | Adp5062TypeTerminationSettingsVtrm |
Public enumeration | Adp5062TypeTimerSettingsChgTmrPeriod |
Public enumeration | Adp5062TypeTimerSettingsEnChgTimer |
Public enumeration | Adp5062TypeTimerSettingsEnTend |
Public enumeration | Adp5062TypeTimerSettingsEnWd |
Public enumeration | Adp5062TypeTimerSettingsResetWd |
Public enumeration | Adp5062TypeTimerSettingsWdPeriod |
Public enumeration | Adp5062TypeVoltageThresholdsDisRch |
Public enumeration | Adp5062TypeVoltageThresholdsVrch |
Public enumeration | Adp5062TypeVoltageThresholdsVtrkDead |
Public enumeration | Adp5062TypeVoltageThresholdsVweak |
Public enumeration | Adp5062TypeVpinxPinSettingsIlim |
Public enumeration | Adp5065TypeBatteryShortTbatShr |
Public enumeration | Adp5065TypeBatteryShortVbatShr |
Public enumeration | Adp5065TypeChargerStatus1ChargerStatus |
Public enumeration | Adp5065TypeChargerStatus1Chdone |
Public enumeration | Adp5065TypeChargerStatus1ThermLim |
Public enumeration | Adp5065TypeChargerStatus1VinIlim |
Public enumeration | Adp5065TypeChargerStatus1VinOk |
Public enumeration | Adp5065TypeChargerStatus1VinOv |
Public enumeration | Adp5065TypeChargerStatus2BatteryStatus |
Public enumeration | Adp5065TypeChargerStatus2IpkStat |
Public enumeration | Adp5065TypeChargerStatus2ThrStatus |
Public enumeration | Adp5065TypeChargingCurrentEoc |
Public enumeration | Adp5065TypeChargingCurrentIchg |
Public enumeration | Adp5065TypeChargingCurrentItrkDead |
Public enumeration | Adp5065TypeFaultBatShr |
Public enumeration | Adp5065TypeFaultIndPeakInt |
Public enumeration | Adp5065TypeFaultOverTemp |
Public enumeration | Adp5065TypeFunctionalSettings1DisIpkSd |
Public enumeration | Adp5065TypeFunctionalSettings1EnBmon |
Public enumeration | Adp5065TypeFunctionalSettings1EnChg |
Public enumeration | Adp5065TypeFunctionalSettings1EnEoc |
Public enumeration | Adp5065TypeFunctionalSettings1EnJeita |
Public enumeration | Adp5065TypeFunctionalSettings1EnThr |
Public enumeration | Adp5065TypeFunctionalSettings1EnTrk |
Public enumeration | Adp5065TypeInterruptActive |
Public enumeration | Adp5065TypeInterruptEnable |
Public enumeration | Adp5065TypeTerminationSettingsIend |
Public enumeration | Adp5065TypeTerminationSettingsVtrm |
Public enumeration | Adp5065TypeTimerSettingsChgTmrPeriod |
Public enumeration | Adp5065TypeTimerSettingsEnChgTimer |
Public enumeration | Adp5065TypeTimerSettingsEnTend |
Public enumeration | Adp5065TypeTimerSettingsEnWd |
Public enumeration | Adp5065TypeTimerSettingsResetWd |
Public enumeration | Adp5065TypeTimerSettingsWdPeriod |
Public enumeration | Adp5065TypeVoltageThresholdsVrch |
Public enumeration | Adp5065TypeVoltageThresholdsVtrkDead |
Public enumeration | Adp5065TypeVoltageThresholdsVweak |
Public enumeration | Adp5065TypeVpinxPinsSettingsIlim |
Public enumeration | Adp5501TypeAlsCmprCfgFilt |
Public enumeration | Adp5501TypeAlsCmprCfgForceRd |
Public enumeration | Adp5501TypeAlsCmprCfgL2En |
Public enumeration | Adp5501TypeAlsCmprCfgL2Out |
Public enumeration | Adp5501TypeAlsCmprCfgL3En |
Public enumeration | Adp5501TypeAlsCmprCfgL3Out |
Public enumeration | Adp5501TypeBlControlBlAutoAdj |
Public enumeration | Adp5501TypeBlControlBlLaw |
Public enumeration | Adp5501TypeBlControlBlLvl |
Public enumeration | Adp5501TypeBlControlFovr |
Public enumeration | Adp5501TypeBlControlOvpEn |
Public enumeration | Adp5501TypeBlFade |
Public enumeration | Adp5501TypeBlTime |
Public enumeration | Adp5501TypeInterruptEnableAutoLdEn |
Public enumeration | Adp5501TypeInterruptEnableCmprIen |
Public enumeration | Adp5501TypeInterruptEnableOvpIen |
Public enumeration | Adp5501TypeLedFade |
Public enumeration | Adp5501TypeLedSinkControlLed0En |
Public enumeration | Adp5501TypeLedSinkControlLed1En |
Public enumeration | Adp5501TypeLedSinkControlLed2En |
Public enumeration | Adp5501TypeLedSinkControlLedLaw |
Public enumeration | Adp5501TypeLedTimeLedOfft |
Public enumeration | Adp5501TypeLedTimeLedOnt |
Public enumeration | Adp5501TypeModeStatusBlEn |
Public enumeration | Adp5501TypeModeStatusCmprInt |
Public enumeration | Adp5501TypeModeStatusDimEn |
Public enumeration | Adp5501TypeModeStatusOvpInt |
Public enumeration | Adp5501TypeModeStatusStnby |
Public enumeration | Adp5520TypeAlsCmprCfgFilt |
Public enumeration | Adp5520TypeAlsCmprCfgForceRd |
Public enumeration | Adp5520TypeAlsCmprCfgL2En |
Public enumeration | Adp5520TypeAlsCmprCfgL2Out |
Public enumeration | Adp5520TypeAlsCmprCfgL3En |
Public enumeration | Adp5520TypeAlsCmprCfgL3Out |
Public enumeration | Adp5520TypeBlControlBlAutoAdj |
Public enumeration | Adp5520TypeBlControlBlLaw |
Public enumeration | Adp5520TypeBlControlBlLvl |
Public enumeration | Adp5520TypeBlControlFovr |
Public enumeration | Adp5520TypeBlControlKpBlEn |
Public enumeration | Adp5520TypeBlControlOvpEn |
Public enumeration | Adp5520TypeBlFade |
Public enumeration | Adp5520TypeBlTime |
Public enumeration | Adp5520TypeGpioCfg1C0Config |
Public enumeration | Adp5520TypeGpioCfg1C1Config |
Public enumeration | Adp5520TypeGpioCfg1C2Config |
Public enumeration | Adp5520TypeGpioCfg1C3Config |
Public enumeration | Adp5520TypeGpioCfg1R0Config |
Public enumeration | Adp5520TypeGpioCfg1R1Config |
Public enumeration | Adp5520TypeGpioCfg1R2Config |
Public enumeration | Adp5520TypeGpioCfg1R3Config |
Public enumeration | Adp5520TypeGpioCfg2Dir |
Public enumeration | Adp5520TypeGpioDebounce |
Public enumeration | Adp5520TypeGpioIn |
Public enumeration | Adp5520TypeGpioIntEn |
Public enumeration | Adp5520TypeGpioIntLvl |
Public enumeration | Adp5520TypeGpioIntStat |
Public enumeration | Adp5520TypeGpioOut |
Public enumeration | Adp5520TypeGpioPullup |
Public enumeration | Adp5520TypeInterruptEnableAutoLdEn |
Public enumeration | Adp5520TypeInterruptEnableCmprIen |
Public enumeration | Adp5520TypeInterruptEnableKpIen |
Public enumeration | Adp5520TypeInterruptEnableKrIen |
Public enumeration | Adp5520TypeInterruptEnableOvpIen |
Public enumeration | Adp5520TypeKeyStat |
Public enumeration | Adp5520TypeKpIntStat |
Public enumeration | Adp5520TypeKrIntStat |
Public enumeration | Adp5520TypeLedControlC3Mode |
Public enumeration | Adp5520TypeLedControlLed1En |
Public enumeration | Adp5520TypeLedControlLed2En |
Public enumeration | Adp5520TypeLedControlLed3En |
Public enumeration | Adp5520TypeLedControlLedLaw |
Public enumeration | Adp5520TypeLedControlR3Mode |
Public enumeration | Adp5520TypeLedFade |
Public enumeration | Adp5520TypeLedTimeLedOfft |
Public enumeration | Adp5520TypeLedTimeLedOnt |
Public enumeration | Adp5520TypeModeStatusBlEn |
Public enumeration | Adp5520TypeModeStatusCmprInt |
Public enumeration | Adp5520TypeModeStatusDimEn |
Public enumeration | Adp5520TypeModeStatusGpiInt |
Public enumeration | Adp5520TypeModeStatusKpInt |
Public enumeration | Adp5520TypeModeStatusKrInt |
Public enumeration | Adp5520TypeModeStatusNstnby |
Public enumeration | Adp5520TypeModeStatusOvpInt |
Public enumeration | Adp5585TypeDebounceDis |
Public enumeration | Adp5585TypeFifoEventIdentifier |
Public enumeration | Adp5585TypeGeneralCfgBIntCfg |
Public enumeration | Adp5585TypeGeneralCfgBOscEn |
Public enumeration | Adp5585TypeGeneralCfgBOscFreq |
Public enumeration | Adp5585TypeGeneralCfgBRstCfg |
Public enumeration | Adp5585TypeGpiEventEn |
Public enumeration | Adp5585TypeGpiInterruptEn |
Public enumeration | Adp5585TypeGpiIntLevel |
Public enumeration | Adp5585TypeGpiIntStat |
Public enumeration | Adp5585TypeGpioDirection |
Public enumeration | Adp5585TypeGpiStatus |
Public enumeration | Adp5585TypeGpoDataOut |
Public enumeration | Adp5585TypeGpoOutMode |
Public enumeration | Adp5585TypeIntEn |
Public enumeration | Adp5585TypeIntStatus |
Public enumeration | Adp5585TypeLogicCfgInv |
Public enumeration | Adp5585TypeLogicCfgLogicSel |
Public enumeration | Adp5585TypeLogicFfCfgClr |
Public enumeration | Adp5585TypeLogicFfCfgSet |
Public enumeration | Adp5585TypeLogicIntEventEnLogicEventEn |
Public enumeration | Adp5585TypeLogicIntEventEnLogicIntLevel |
Public enumeration | Adp5585TypeLogicIntEventEnLyDbncDis |
Public enumeration | Adp5585TypePinConfigAR0Config |
Public enumeration | Adp5585TypePinConfigAR1Config |
Public enumeration | Adp5585TypePinConfigAR2Config |
Public enumeration | Adp5585TypePinConfigAR3Config |
Public enumeration | Adp5585TypePinConfigAR4Config |
Public enumeration | Adp5585TypePinConfigAR5Config |
Public enumeration | Adp5585TypePinConfigBC0Config |
Public enumeration | Adp5585TypePinConfigBC1Config |
Public enumeration | Adp5585TypePinConfigBC2Config |
Public enumeration | Adp5585TypePinConfigBC3Config |
Public enumeration | Adp5585TypePinConfigBC4Config |
Public enumeration | Adp5585TypePinConfigCC4ExtendCfg |
Public enumeration | Adp5585TypePinConfigCPullSelect |
Public enumeration | Adp5585TypePinConfigCR0ExtendCfg |
Public enumeration | Adp5585TypePinConfigCR3ExtendCfg |
Public enumeration | Adp5585TypePinConfigCR4ExtendCfg |
Public enumeration | Adp5585TypePollTimeCfgKeyPollTime |
Public enumeration | Adp5585TypePwmCfgPwmEn |
Public enumeration | Adp5585TypePwmCfgPwmInAnd |
Public enumeration | Adp5585TypePwmCfgPwmMode |
Public enumeration | Adp5585TypeResetCfgResetPol |
Public enumeration | Adp5585TypeResetCfgResetPulseWidth |
Public enumeration | Adp5585TypeResetCfgResetTriggerTimer |
Public enumeration | Adp5585TypeResetCfgRstPassthruEn |
Public enumeration | Adp5585TypeRpullConfig |
Public enumeration | Adp5585TypeStatusLogicStat |
Public enumeration | Adp5587TypeCfgAutoInc |
Public enumeration | Adp5587TypeCfgGpiemCfg |
Public enumeration | Adp5587TypeCfgGpiIen |
Public enumeration | Adp5587TypeCfgIntCfg |
Public enumeration | Adp5587TypeCfgKeIen |
Public enumeration | Adp5587TypeCfgKLckM |
Public enumeration | Adp5587TypeCfgOvrFlowIen |
Public enumeration | Adp5587TypeCfgOvrFlowM |
Public enumeration | Adp5587TypeGpiEmReg |
Public enumeration | Adp5587TypeGpioDir |
Public enumeration | Adp5587TypeGpioIntLvl |
Public enumeration | Adp5587TypeGpioPull |
Public enumeration | Adp5587TypeIntStatGpiInt |
Public enumeration | Adp5587TypeIntStatKeInt |
Public enumeration | Adp5587TypeIntStatKLckInt |
Public enumeration | Adp5587TypeIntStatOvrFlowInt |
Public enumeration | Adp5587TypeKeyEventStatus |
Public enumeration | Adp5587TypeKeyLckEcStatKLckEn |
Public enumeration | Adp5587TypeKeyLckEcStatLck2Lck1 |
Public enumeration | Adp5587TypeKpGpio |
Public enumeration | Adp5587TypeKpLckTmrKimt |
Public enumeration | Adp5587TypeKpLckTmrKllt |
Public enumeration | Adp5587TypeUnlock |
Public enumeration | Adp5588TypeCfgAutoInc |
Public enumeration | Adp5588TypeCfgGpiemCfg |
Public enumeration | Adp5588TypeCfgGpiIen |
Public enumeration | Adp5588TypeCfgIntCfg |
Public enumeration | Adp5588TypeCfgKeIen |
Public enumeration | Adp5588TypeCfgKLckM |
Public enumeration | Adp5588TypeCfgOvrFlowIen |
Public enumeration | Adp5588TypeCfgOvrFlowM |
Public enumeration | Adp5588TypeCmpCfgStatCmp1L2Out |
Public enumeration | Adp5588TypeCmpCfgStatCmp1L3Out |
Public enumeration | Adp5588TypeCmpCfgStatCmp2L2Out |
Public enumeration | Adp5588TypeCmpCfgStatCmp2L3Out |
Public enumeration | Adp5588TypeCmpCfgStatCmpEn |
Public enumeration | Adp5588TypeCmpCfgStatCmpIen |
Public enumeration | Adp5588TypeCmpConfgSensForceRd |
Public enumeration | Adp5588TypeCmpConfgSensL2En |
Public enumeration | Adp5588TypeCmpConfgSensL3En |
Public enumeration | Adp5588TypeGpiEmReg |
Public enumeration | Adp5588TypeGpioDir |
Public enumeration | Adp5588TypeGpioIntLvl |
Public enumeration | Adp5588TypeGpioPull |
Public enumeration | Adp5588TypeIntStatCmp1Int |
Public enumeration | Adp5588TypeIntStatCmp2Int |
Public enumeration | Adp5588TypeIntStatGpiInt |
Public enumeration | Adp5588TypeIntStatKeInt |
Public enumeration | Adp5588TypeIntStatKLckInt |
Public enumeration | Adp5588TypeIntStatOvrFlowInt |
Public enumeration | Adp5588TypeKeyEventStatus |
Public enumeration | Adp5588TypeKeyLckEcStatKLckEn |
Public enumeration | Adp5588TypeKeyLckEcStatLck2Lck1 |
Public enumeration | Adp5588TypeKpGpio |
Public enumeration | Adp5588TypeKpLckTmrKimt |
Public enumeration | Adp5588TypeKpLckTmrKllt |
Public enumeration | Adp5588TypeUnlock |
Public enumeration | Adp5589TypeClockDivCfgClkDivEn |
Public enumeration | Adp5589TypeClockDivCfgClkInv |
Public enumeration | Adp5589TypeDebounceDis |
Public enumeration | Adp5589TypeFifoEventIdentifier |
Public enumeration | Adp5589TypeGeneralCfgBCoreFreq |
Public enumeration | Adp5589TypeGeneralCfgBIntCfg |
Public enumeration | Adp5589TypeGeneralCfgBLckTrkGpi |
Public enumeration | Adp5589TypeGeneralCfgBLckTrkLogic |
Public enumeration | Adp5589TypeGeneralCfgBOscEn |
Public enumeration | Adp5589TypeGeneralCfgBRstCfg |
Public enumeration | Adp5589TypeGpiEventEn |
Public enumeration | Adp5589TypeGpiInterruptEn |
Public enumeration | Adp5589TypeGpiIntLevel |
Public enumeration | Adp5589TypeGpiIntStat |
Public enumeration | Adp5589TypeGpioDirection |
Public enumeration | Adp5589TypeGpiStatus |
Public enumeration | Adp5589TypeGpoDataOut |
Public enumeration | Adp5589TypeGpoOutMode |
Public enumeration | Adp5589TypeIntEn |
Public enumeration | Adp5589TypeIntStatus |
Public enumeration | Adp5589TypeLockCfgLockEn |
Public enumeration | Adp5589TypeLogic1CfgLogic1Sel |
Public enumeration | Adp5589TypeLogic2CfgLogic2Sel |
Public enumeration | Adp5589TypeLogic2CfgLy1Cascade |
Public enumeration | Adp5589TypeLogicCfgInv |
Public enumeration | Adp5589TypeLogicFfCfgClr |
Public enumeration | Adp5589TypeLogicFfCfgSet |
Public enumeration | Adp5589TypeLogicIntEventEnLogicEventEn |
Public enumeration | Adp5589TypeLogicIntEventEnLogicIntLevel |
Public enumeration | Adp5589TypeLogicIntEventEnLyDbncDis |
Public enumeration | Adp5589TypePinConfigAR0Config |
Public enumeration | Adp5589TypePinConfigAR1Config |
Public enumeration | Adp5589TypePinConfigAR2Config |
Public enumeration | Adp5589TypePinConfigAR3Config |
Public enumeration | Adp5589TypePinConfigAR4Config |
Public enumeration | Adp5589TypePinConfigAR5Config |
Public enumeration | Adp5589TypePinConfigAR6Config |
Public enumeration | Adp5589TypePinConfigAR7Config |
Public enumeration | Adp5589TypePinConfigBC0Config |
Public enumeration | Adp5589TypePinConfigBC1Config |
Public enumeration | Adp5589TypePinConfigBC2Config |
Public enumeration | Adp5589TypePinConfigBC3Config |
Public enumeration | Adp5589TypePinConfigBC4Config |
Public enumeration | Adp5589TypePinConfigBC5Config |
Public enumeration | Adp5589TypePinConfigBC6Config |
Public enumeration | Adp5589TypePinConfigBC7Config |
Public enumeration | Adp5589TypePinConfigCC10Config |
Public enumeration | Adp5589TypePinConfigCC8Config |
Public enumeration | Adp5589TypePinConfigCC9Config |
Public enumeration | Adp5589TypePinConfigDC4ExtendCfg |
Public enumeration | Adp5589TypePinConfigDC6ExtendCfg |
Public enumeration | Adp5589TypePinConfigDC9ExtendCfg |
Public enumeration | Adp5589TypePinConfigDPullSelect |
Public enumeration | Adp5589TypePinConfigDR0ExtendCfg |
Public enumeration | Adp5589TypePinConfigDR3ExtendCfg |
Public enumeration | Adp5589TypePinConfigDR4ExtendCfg |
Public enumeration | Adp5589TypePollTimeCfgKeyPollTime |
Public enumeration | Adp5589TypePwmCfgPwmEn |
Public enumeration | Adp5589TypePwmCfgPwmInAnd |
Public enumeration | Adp5589TypePwmCfgPwmMode |
Public enumeration | Adp5589TypeResetCfgResetPol |
Public enumeration | Adp5589TypeResetCfgResetPulseWidth |
Public enumeration | Adp5589TypeResetCfgResetTriggerTimer |
Public enumeration | Adp5589TypeResetCfgRstPassthruEn |
Public enumeration | Adp5589TypeRpullConfig |
Public enumeration | Adp5589TypeStatusLockStat |
Public enumeration | Adp5589TypeStatusLogic1Stat |
Public enumeration | Adp5589TypeStatusLogic2Stat |
Public enumeration | Adp5589TypeUnlockTimersIntMaskTimer |
Public enumeration | Adp5589TypeUnlockTimersUnlockTimer |
Public enumeration | Adp8870TypeAlsEn |
Public enumeration | Adp8870TypeBl |
Public enumeration | Adp8870TypeBlfr |
Public enumeration | Adp8870TypeBlsel |
Public enumeration | Adp8870TypeCfgrBlLaw |
Public enumeration | Adp8870TypeCfgrBlv |
Public enumeration | Adp8870TypeCfgrCmp2Sel |
Public enumeration | Adp8870TypeCfgrFovr |
Public enumeration | Adp8870TypeCfgrSelAb |
Public enumeration | Adp8870TypeCmpCtlFilt |
Public enumeration | Adp8870TypeCmpForceRd |
Public enumeration | Adp8870TypeIntEn |
Public enumeration | Adp8870TypeIntStat |
Public enumeration | Adp8870TypeIsc7Scr |
Public enumeration | Adp8870TypeIscc |
Public enumeration | Adp8870TypeIscf |
Public enumeration | Adp8870TypeIsclaw |
Public enumeration | Adp8870TypeIsctScoff |
Public enumeration | Adp8870TypeIsctScon |
Public enumeration | Adp8870TypeModeControlBlEn |
Public enumeration | Adp8870TypeModeControlCmpAutoen |
Public enumeration | Adp8870TypeModeControlD7alsEn |
Public enumeration | Adp8870TypeModeControlDimEn |
Public enumeration | Adp8870TypeModeControlGdwinDis |
Public enumeration | Adp8870TypeModeControlIntCfg |
Public enumeration | Adp8870TypeModeControlNstby |
Public enumeration | Adp8870TypeModeControlSisEn |
Public enumeration | Adp8870TypePwmled |
Public enumeration | Adt7316TypeControlConfiguration1IntOutput |
Public enumeration | Adt7316TypeControlConfiguration1IntOutputPolarity |
Public enumeration | Adt7316TypeControlConfiguration1Monitoring |
Public enumeration | Adt7316TypeControlConfiguration1PowerDown |
Public enumeration | Adt7316TypeControlConfiguration2Averaging |
Public enumeration | Adt7316TypeControlConfiguration2ChannelSelection |
Public enumeration | Adt7316TypeControlConfiguration2Conversion |
Public enumeration | Adt7316TypeControlConfiguration2SoftwareReset |
Public enumeration | Adt7316TypeControlConfiguration2Timeout |
Public enumeration | Adt7316TypeControlConfiguration3DacAOutput |
Public enumeration | Adt7316TypeControlConfiguration3DacBOutput |
Public enumeration | Adt7316TypeControlConfiguration3Resolution |
Public enumeration | Adt7316TypeControlConfiguration3Speed |
Public enumeration | Adt7316TypeControlConfiguration3UpdatingDacOutputs |
Public enumeration | Adt7316TypeDacConfigurationBypass |
Public enumeration | Adt7316TypeDacConfigurationRange |
Public enumeration | Adt7316TypeDacConfigurationUpdate |
Public enumeration | Adt7316TypeInterruptMaskEnableDisable |
Public enumeration | Adt7316TypeInterruptStatus |
Public enumeration | Adt7316TypeLdacConfigurationUpdate |
Public enumeration | Adt7316TypeSpiLockStatus |
Public enumeration | Adt7317TypeControlConfiguration1IntOutput |
Public enumeration | Adt7317TypeControlConfiguration1IntOutputPolarity |
Public enumeration | Adt7317TypeControlConfiguration1Monitoring |
Public enumeration | Adt7317TypeControlConfiguration1PowerDown |
Public enumeration | Adt7317TypeControlConfiguration2Averaging |
Public enumeration | Adt7317TypeControlConfiguration2ChannelSelection |
Public enumeration | Adt7317TypeControlConfiguration2Conversion |
Public enumeration | Adt7317TypeControlConfiguration2SoftwareReset |
Public enumeration | Adt7317TypeControlConfiguration2Timeout |
Public enumeration | Adt7317TypeControlConfiguration3DacAOutput |
Public enumeration | Adt7317TypeControlConfiguration3DacBOutput |
Public enumeration | Adt7317TypeControlConfiguration3Resolution |
Public enumeration | Adt7317TypeControlConfiguration3Speed |
Public enumeration | Adt7317TypeControlConfiguration3UpdatingDacOutputs |
Public enumeration | Adt7317TypeDacConfigurationBypass |
Public enumeration | Adt7317TypeDacConfigurationRange |
Public enumeration | Adt7317TypeDacConfigurationUpdate |
Public enumeration | Adt7317TypeInterruptMaskEnableDisable |
Public enumeration | Adt7317TypeInterruptStatus |
Public enumeration | Adt7317TypeLdacConfigurationUpdate |
Public enumeration | Adt7317TypeSpiLockStatus |
Public enumeration | Adt7318TypeControlConfiguration1IntOutput |
Public enumeration | Adt7318TypeControlConfiguration1IntOutputPolarity |
Public enumeration | Adt7318TypeControlConfiguration1Monitoring |
Public enumeration | Adt7318TypeControlConfiguration1PowerDown |
Public enumeration | Adt7318TypeControlConfiguration2Averaging |
Public enumeration | Adt7318TypeControlConfiguration2ChannelSelection |
Public enumeration | Adt7318TypeControlConfiguration2Conversion |
Public enumeration | Adt7318TypeControlConfiguration2SoftwareReset |
Public enumeration | Adt7318TypeControlConfiguration2Timeout |
Public enumeration | Adt7318TypeControlConfiguration3DacAOutput |
Public enumeration | Adt7318TypeControlConfiguration3DacBOutput |
Public enumeration | Adt7318TypeControlConfiguration3Speed |
Public enumeration | Adt7318TypeControlConfiguration3UpdatingDacOutputs |
Public enumeration | Adt7318TypeDacConfigurationBypass |
Public enumeration | Adt7318TypeDacConfigurationRange |
Public enumeration | Adt7318TypeDacConfigurationUpdate |
Public enumeration | Adt7318TypeInterruptMaskEnableDisable |
Public enumeration | Adt7318TypeInterruptStatus |
Public enumeration | Adt7318TypeLdacConfigurationUpdate |
Public enumeration | Adt7318TypeSpiLockStatus |
Public enumeration | Adt7408TypeCapabilityAccuracy |
Public enumeration | Adt7408TypeCapabilityTemperatureRange |
Public enumeration | Adt7408TypeCapabilityTemperatureResolution |
Public enumeration | Adt7408TypeCapabilityTrips |
Public enumeration | Adt7408TypeConfigurationAlarmWindowLock |
Public enumeration | Adt7408TypeConfigurationClearEvent |
Public enumeration | Adt7408TypeConfigurationCriticalEventOnly |
Public enumeration | Adt7408TypeConfigurationCriticalTripLock |
Public enumeration | Adt7408TypeConfigurationEventMode |
Public enumeration | Adt7408TypeConfigurationEventOutputControl |
Public enumeration | Adt7408TypeConfigurationEventOutputStatus |
Public enumeration | Adt7408TypeConfigurationEventPolarity |
Public enumeration | Adt7408TypeConfigurationHysteresisEnable |
Public enumeration | Adt7408TypeConfigurationShutdownMode |
Public enumeration | Adt7408TypeTemperatureStatus |
Public enumeration | Adt7410TypeConfigurationIntCtMode |
Public enumeration | Adt7410TypeConfigurationIntCtPinPolarity |
Public enumeration | Adt7410TypeConfigurationOperationMode |
Public enumeration | Adt7410TypeConfigurationResolution |
Public enumeration | Adt7410TypeStatus |
Public enumeration | Adt7410TypeTempFlag |
Public enumeration | Adt7411TypeControlConfiguration1AinTdmSelection |
Public enumeration | Adt7411TypeControlConfiguration1IntOutput |
Public enumeration | Adt7411TypeControlConfiguration1IntOutputPolarity |
Public enumeration | Adt7411TypeControlConfiguration1Monitoring |
Public enumeration | Adt7411TypeControlConfiguration1PowerDown |
Public enumeration | Adt7411TypeControlConfiguration2Averaging |
Public enumeration | Adt7411TypeControlConfiguration2ChannelSelection |
Public enumeration | Adt7411TypeControlConfiguration2Conversion |
Public enumeration | Adt7411TypeControlConfiguration2SoftwareReset |
Public enumeration | Adt7411TypeControlConfiguration2Timeout |
Public enumeration | Adt7411TypeControlConfiguration3AdcReference |
Public enumeration | Adt7411TypeControlConfiguration3Speed |
Public enumeration | Adt7411TypeInterruptMaskEnableDisable |
Public enumeration | Adt7411TypeInterruptStatus |
Public enumeration | Adt7411TypeSpiLockStatus |
Public enumeration | Adt7420TypeConfigurationIntCtMode |
Public enumeration | Adt7420TypeConfigurationIntCtPinPolarity |
Public enumeration | Adt7420TypeConfigurationOperationMode |
Public enumeration | Adt7420TypeConfigurationResolution |
Public enumeration | Adt7420TypeStatus |
Public enumeration | Adt7420TypeTempFlag |
Public enumeration | Adt75TypeConfigurationCmpInt |
Public enumeration | Adt75TypeConfigurationFaultQueue |
Public enumeration | Adt75TypeConfigurationOneShot |
Public enumeration | Adt75TypeConfigurationOsAlert |
Public enumeration | Adt75TypeConfigurationOsSmbusAlertMode |
Public enumeration | Adt75TypeConfigurationShutdown |
Public enumeration | Adt7516TypeControlConfiguration1AinTdmSelection |
Public enumeration | Adt7516TypeControlConfiguration1IntOutput |
Public enumeration | Adt7516TypeControlConfiguration1IntOutputPolarity |
Public enumeration | Adt7516TypeControlConfiguration1LdacAin3 |
Public enumeration | Adt7516TypeControlConfiguration1Monitoring |
Public enumeration | Adt7516TypeControlConfiguration1PowerDown |
Public enumeration | Adt7516TypeControlConfiguration2Averaging |
Public enumeration | Adt7516TypeControlConfiguration2ChannelSelection |
Public enumeration | Adt7516TypeControlConfiguration2Conversion |
Public enumeration | Adt7516TypeControlConfiguration2SoftwareReset |
Public enumeration | Adt7516TypeControlConfiguration2Timeout |
Public enumeration | Adt7516TypeControlConfiguration3AdcReference |
Public enumeration | Adt7516TypeControlConfiguration3DacAOutput |
Public enumeration | Adt7516TypeControlConfiguration3DacBOutput |
Public enumeration | Adt7516TypeControlConfiguration3Resolution |
Public enumeration | Adt7516TypeControlConfiguration3Speed |
Public enumeration | Adt7516TypeControlConfiguration3UpdatingDacOutputs |
Public enumeration | Adt7516TypeDacConfigurationRange |
Public enumeration | Adt7516TypeDacConfigurationUpdate |
Public enumeration | Adt7516TypeInterruptMaskEnableDisable |
Public enumeration | Adt7516TypeInterruptStatus |
Public enumeration | Adt7516TypeLdacConfigurationReference |
Public enumeration | Adt7516TypeLdacConfigurationUpdate |
Public enumeration | Adt7516TypeSpiLockStatus |
Public enumeration | Adt7517TypeControlConfiguration1AinTdmSelection |
Public enumeration | Adt7517TypeControlConfiguration1IntOutput |
Public enumeration | Adt7517TypeControlConfiguration1IntOutputPolarity |
Public enumeration | Adt7517TypeControlConfiguration1LdacAin3 |
Public enumeration | Adt7517TypeControlConfiguration1Monitoring |
Public enumeration | Adt7517TypeControlConfiguration1PowerDown |
Public enumeration | Adt7517TypeControlConfiguration2Averaging |
Public enumeration | Adt7517TypeControlConfiguration2ChannelSelection |
Public enumeration | Adt7517TypeControlConfiguration2Conversion |
Public enumeration | Adt7517TypeControlConfiguration2SoftwareReset |
Public enumeration | Adt7517TypeControlConfiguration2Timeout |
Public enumeration | Adt7517TypeControlConfiguration3AdcReference |
Public enumeration | Adt7517TypeControlConfiguration3DacAOutput |
Public enumeration | Adt7517TypeControlConfiguration3DacBOutput |
Public enumeration | Adt7517TypeControlConfiguration3Resolution |
Public enumeration | Adt7517TypeControlConfiguration3Speed |
Public enumeration | Adt7517TypeControlConfiguration3UpdatingDacOutputs |
Public enumeration | Adt7517TypeDacConfigurationRange |
Public enumeration | Adt7517TypeDacConfigurationUpdate |
Public enumeration | Adt7517TypeInterruptMaskEnableDisable |
Public enumeration | Adt7517TypeInterruptStatus |
Public enumeration | Adt7517TypeLdacConfigurationReference |
Public enumeration | Adt7517TypeLdacConfigurationUpdate |
Public enumeration | Adt7517TypeSpiLockStatus |
Public enumeration | Adt7518ControlConfig1C0Type |
Public enumeration | Adt7518ControlConfig1C12Type |
Public enumeration | Adt7518ControlConfig1C3Type |
Public enumeration | Adt7518ControlConfig1C5Type |
Public enumeration | Adt7518ControlConfig1C6Type |
Public enumeration | Adt7518ControlConfig1PdType |
Public enumeration | Adt7518ControlConfig2C02Type |
Public enumeration | Adt7518ControlConfig2C4Type |
Public enumeration | Adt7518ControlConfig2C5Type |
Public enumeration | Adt7518ControlConfig2C6Type |
Public enumeration | Adt7518ControlConfig2C7Type |
Public enumeration | Adt7518ControlConfig3C0Type |
Public enumeration | Adt7518ControlConfig3C3Type |
Public enumeration | Adt7518ControlConfig3C4Type |
Public enumeration | Adt7518ControlConfig3C5Type |
Public enumeration | Adt7518ControlConfig3C6Type |
Public enumeration | Adt7518DacConfigD0Type |
Public enumeration | Adt7518DacConfigD1Type |
Public enumeration | Adt7518DacConfigD2Type |
Public enumeration | Adt7518DacConfigD3Type |
Public enumeration | Adt7518DacConfigD45Type |
Public enumeration | Adt7518IrqMask1D0Type |
Public enumeration | Adt7518IrqMask1D1Type |
Public enumeration | Adt7518IrqMask1D2Type |
Public enumeration | Adt7518IrqMask1D3Type |
Public enumeration | Adt7518IrqMask1D4Type |
Public enumeration | Adt7518IrqMask1D5Type |
Public enumeration | Adt7518IrqMask1D6Type |
Public enumeration | Adt7518IrqMask1D7Type |
Public enumeration | Adt7518IrqMask2D4Type |
Public enumeration | Adt7518IrqStatus1D0Type |
Public enumeration | Adt7518IrqStatus1D1Type |
Public enumeration | Adt7518IrqStatus1D2Type |
Public enumeration | Adt7518IrqStatus1D3Type |
Public enumeration | Adt7518IrqStatus1D4Type |
Public enumeration | Adt7518IrqStatus1D5Type |
Public enumeration | Adt7518IrqStatus1D6Type |
Public enumeration | Adt7518IrqStatus1D7Type |
Public enumeration | Adt7518IrqStatus2D4Type |
Public enumeration | Adt7518LdacConfigD0Type |
Public enumeration | Adt7518LdacConfigD1Type |
Public enumeration | Adt7518LdacConfigD2Type |
Public enumeration | Adt7518LdacConfigD3Type |
Public enumeration | Adt7518LdacConfigD4Type |
Public enumeration | Adt7518LdacConfigD5Type |
Public enumeration | Adt7518SpiLockType |
Public enumeration | Adt7519TypeControlConfiguration1AinTdmSelection |
Public enumeration | Adt7519TypeControlConfiguration1IntOutput |
Public enumeration | Adt7519TypeControlConfiguration1IntOutputPolarity |
Public enumeration | Adt7519TypeControlConfiguration1LdacAin3 |
Public enumeration | Adt7519TypeControlConfiguration1Monitoring |
Public enumeration | Adt7519TypeControlConfiguration1PowerDown |
Public enumeration | Adt7519TypeControlConfiguration2Averaging |
Public enumeration | Adt7519TypeControlConfiguration2ChannelSelection |
Public enumeration | Adt7519TypeControlConfiguration2Conversion |
Public enumeration | Adt7519TypeControlConfiguration2SoftwareReset |
Public enumeration | Adt7519TypeControlConfiguration2Timeout |
Public enumeration | Adt7519TypeControlConfiguration3AdcReference |
Public enumeration | Adt7519TypeControlConfiguration3DacAOutput |
Public enumeration | Adt7519TypeControlConfiguration3DacBOutput |
Public enumeration | Adt7519TypeControlConfiguration3Resolution |
Public enumeration | Adt7519TypeControlConfiguration3Speed |
Public enumeration | Adt7519TypeControlConfiguration3UpdatingDacOutputs |
Public enumeration | Adt7519TypeDacConfigurationRange |
Public enumeration | Adt7519TypeDacConfigurationUpdate |
Public enumeration | Adt7519TypeInterruptMaskEnableDisable |
Public enumeration | Adt7519TypeInterruptStatus |
Public enumeration | Adt7519TypeLdacConfigurationReference |
Public enumeration | Adt7519TypeLdacConfigurationUpdate |
Public enumeration | Adt7519TypeSpiLockStatus |
Public enumeration | Adxl312TypeActInactCtlActAcDc |
Public enumeration | Adxl312TypeActInactCtlActX |
Public enumeration | Adxl312TypeActInactCtlActY |
Public enumeration | Adxl312TypeActInactCtlActZ |
Public enumeration | Adxl312TypeActInactCtlInactAcDc |
Public enumeration | Adxl312TypeActInactCtlInactX |
Public enumeration | Adxl312TypeActInactCtlInactY |
Public enumeration | Adxl312TypeActInactCtlInactZ |
Public enumeration | Adxl312TypeBwRateLowPower |
Public enumeration | Adxl312TypeBwRateRateBits |
Public enumeration | Adxl312TypeDataFormatFullRes |
Public enumeration | Adxl312TypeDataFormatIntInvert |
Public enumeration | Adxl312TypeDataFormatJustify |
Public enumeration | Adxl312TypeDataFormatRange |
Public enumeration | Adxl312TypeDataFormatSelfTest |
Public enumeration | Adxl312TypeDataFormatSpi |
Public enumeration | Adxl312TypeFifoCtlFifoMode |
Public enumeration | Adxl312TypeFifoCtlTrigger |
Public enumeration | Adxl312TypeFifoStatusFifoTrig |
Public enumeration | Adxl312TypeIntEnableActivity |
Public enumeration | Adxl312TypeIntEnableDataReady |
Public enumeration | Adxl312TypeIntEnableInactivity |
Public enumeration | Adxl312TypeIntEnableOverrun |
Public enumeration | Adxl312TypeIntEnableWatermark |
Public enumeration | Adxl312TypeIntMapActivity |
Public enumeration | Adxl312TypeIntMapDataReady |
Public enumeration | Adxl312TypeIntMapInactivity |
Public enumeration | Adxl312TypeIntMapOverrun |
Public enumeration | Adxl312TypeIntMapWatermark |
Public enumeration | Adxl312TypeIntSourceActivity |
Public enumeration | Adxl312TypeIntSourceDataReady |
Public enumeration | Adxl312TypeIntSourceInactivity |
Public enumeration | Adxl312TypeIntSourceOverrun |
Public enumeration | Adxl312TypeIntSourceWatermark |
Public enumeration | Adxl312TypePowerCtlAutoSleep |
Public enumeration | Adxl312TypePowerCtlLink |
Public enumeration | Adxl312TypePowerCtlMeasure |
Public enumeration | Adxl312TypePowerCtlSleep |
Public enumeration | Adxl312TypePowerCtlWakeup |
Public enumeration | Adxl343TypeActInactCtlActAcDc |
Public enumeration | Adxl343TypeActInactCtlActX |
Public enumeration | Adxl343TypeActInactCtlActY |
Public enumeration | Adxl343TypeActInactCtlActZ |
Public enumeration | Adxl343TypeActInactCtlInactAcDc |
Public enumeration | Adxl343TypeActInactCtlInactX |
Public enumeration | Adxl343TypeActInactCtlInactY |
Public enumeration | Adxl343TypeActInactCtlInactZ |
Public enumeration | Adxl343TypeActTapStatusActXSrc |
Public enumeration | Adxl343TypeActTapStatusActYSrc |
Public enumeration | Adxl343TypeActTapStatusActZSrc |
Public enumeration | Adxl343TypeActTapStatusAsleep |
Public enumeration | Adxl343TypeActTapStatusTapXSrc |
Public enumeration | Adxl343TypeActTapStatusTapYSrc |
Public enumeration | Adxl343TypeActTapStatusTapZSrc |
Public enumeration | Adxl343TypeBwRateLowPower |
Public enumeration | Adxl343TypeBwRateRateBits |
Public enumeration | Adxl343TypeDataFormatFullRes |
Public enumeration | Adxl343TypeDataFormatIntInvert |
Public enumeration | Adxl343TypeDataFormatJustify |
Public enumeration | Adxl343TypeDataFormatRange |
Public enumeration | Adxl343TypeDataFormatSelfTest |
Public enumeration | Adxl343TypeDataFormatSpi |
Public enumeration | Adxl343TypeFifoCtlFifoMode |
Public enumeration | Adxl343TypeFifoCtlTrigger |
Public enumeration | Adxl343TypeFifoStatusFifoTrig |
Public enumeration | Adxl343TypeIntEnableActivity |
Public enumeration | Adxl343TypeIntEnableDataReady |
Public enumeration | Adxl343TypeIntEnableDoubleTap |
Public enumeration | Adxl343TypeIntEnableFreeFall |
Public enumeration | Adxl343TypeIntEnableInactivity |
Public enumeration | Adxl343TypeIntEnableOverrun |
Public enumeration | Adxl343TypeIntEnableSingleTap |
Public enumeration | Adxl343TypeIntEnableWatermark |
Public enumeration | Adxl343TypeIntMapActivity |
Public enumeration | Adxl343TypeIntMapDataReady |
Public enumeration | Adxl343TypeIntMapDoubleTap |
Public enumeration | Adxl343TypeIntMapFreeFall |
Public enumeration | Adxl343TypeIntMapInactivity |
Public enumeration | Adxl343TypeIntMapOverrun |
Public enumeration | Adxl343TypeIntMapSingleTap |
Public enumeration | Adxl343TypeIntMapWatermark |
Public enumeration | Adxl343TypeIntSourceActivity |
Public enumeration | Adxl343TypeIntSourceDataReady |
Public enumeration | Adxl343TypeIntSourceDoubleTap |
Public enumeration | Adxl343TypeIntSourceFreeFall |
Public enumeration | Adxl343TypeIntSourceInactivity |
Public enumeration | Adxl343TypeIntSourceOverrun |
Public enumeration | Adxl343TypeIntSourceSingleTap |
Public enumeration | Adxl343TypeIntSourceWatermark |
Public enumeration | Adxl343TypePowerCtlAutoSleep |
Public enumeration | Adxl343TypePowerCtlLink |
Public enumeration | Adxl343TypePowerCtlMeasure |
Public enumeration | Adxl343TypePowerCtlSleep |
Public enumeration | Adxl343TypePowerCtlWakeup |
Public enumeration | Adxl343TypeTapAxesSuppress |
Public enumeration | Adxl343TypeTapAxesTapXEn |
Public enumeration | Adxl343TypeTapAxesTapYEn |
Public enumeration | Adxl343TypeTapAxesTapZEn |
Public enumeration | Adxl345TypeActInactCtlActAcDc |
Public enumeration | Adxl345TypeActInactCtlActX |
Public enumeration | Adxl345TypeActInactCtlActY |
Public enumeration | Adxl345TypeActInactCtlActZ |
Public enumeration | Adxl345TypeActInactCtlInactAcDc |
Public enumeration | Adxl345TypeActInactCtlInactX |
Public enumeration | Adxl345TypeActInactCtlInactY |
Public enumeration | Adxl345TypeActInactCtlInactZ |
Public enumeration | Adxl345TypeActTapStatusActXSrc |
Public enumeration | Adxl345TypeActTapStatusActYSrc |
Public enumeration | Adxl345TypeActTapStatusActZSrc |
Public enumeration | Adxl345TypeActTapStatusAsleep |
Public enumeration | Adxl345TypeActTapStatusTapXSrc |
Public enumeration | Adxl345TypeActTapStatusTapYSrc |
Public enumeration | Adxl345TypeActTapStatusTapZSrc |
Public enumeration | Adxl345TypeBwRateLowPower |
Public enumeration | Adxl345TypeBwRateRateBits |
Public enumeration | Adxl345TypeDataFormatFullRes |
Public enumeration | Adxl345TypeDataFormatIntInvert |
Public enumeration | Adxl345TypeDataFormatJustify |
Public enumeration | Adxl345TypeDataFormatRange |
Public enumeration | Adxl345TypeDataFormatSelfTest |
Public enumeration | Adxl345TypeDataFormatSpi |
Public enumeration | Adxl345TypeFifoCtlFifoMode |
Public enumeration | Adxl345TypeFifoCtlTrigger |
Public enumeration | Adxl345TypeFifoStatusFifoTrig |
Public enumeration | Adxl345TypeIntEnableActivity |
Public enumeration | Adxl345TypeIntEnableDataReady |
Public enumeration | Adxl345TypeIntEnableDoubleTap |
Public enumeration | Adxl345TypeIntEnableFreeFall |
Public enumeration | Adxl345TypeIntEnableInactivity |
Public enumeration | Adxl345TypeIntEnableOverrun |
Public enumeration | Adxl345TypeIntEnableSingleTap |
Public enumeration | Adxl345TypeIntEnableWatermark |
Public enumeration | Adxl345TypeIntMapActivity |
Public enumeration | Adxl345TypeIntMapDataReady |
Public enumeration | Adxl345TypeIntMapDoubleTap |
Public enumeration | Adxl345TypeIntMapFreeFall |
Public enumeration | Adxl345TypeIntMapInactivity |
Public enumeration | Adxl345TypeIntMapOverrun |
Public enumeration | Adxl345TypeIntMapSingleTap |
Public enumeration | Adxl345TypeIntMapWatermark |
Public enumeration | Adxl345TypeIntSourceActivity |
Public enumeration | Adxl345TypeIntSourceDataReady |
Public enumeration | Adxl345TypeIntSourceDoubleTap |
Public enumeration | Adxl345TypeIntSourceFreeFall |
Public enumeration | Adxl345TypeIntSourceInactivity |
Public enumeration | Adxl345TypeIntSourceOverrun |
Public enumeration | Adxl345TypeIntSourceSingleTap |
Public enumeration | Adxl345TypeIntSourceWatermark |
Public enumeration | Adxl345TypePowerCtlAutoSleep |
Public enumeration | Adxl345TypePowerCtlLink |
Public enumeration | Adxl345TypePowerCtlMeasure |
Public enumeration | Adxl345TypePowerCtlSleep |
Public enumeration | Adxl345TypePowerCtlWakeup |
Public enumeration | Adxl345TypeTapAxesSuppress |
Public enumeration | Adxl345TypeTapAxesTapXEn |
Public enumeration | Adxl345TypeTapAxesTapYEn |
Public enumeration | Adxl345TypeTapAxesTapZEn |
Public enumeration | Adxl346TypeActInactCtlActAcDc |
Public enumeration | Adxl346TypeActInactCtlActX |
Public enumeration | Adxl346TypeActInactCtlActY |
Public enumeration | Adxl346TypeActInactCtlActZ |
Public enumeration | Adxl346TypeActInactCtlInactAcDc |
Public enumeration | Adxl346TypeActInactCtlInactX |
Public enumeration | Adxl346TypeActInactCtlInactY |
Public enumeration | Adxl346TypeActInactCtlInactZ |
Public enumeration | Adxl346TypeActTapStatusActXSrc |
Public enumeration | Adxl346TypeActTapStatusActYSrc |
Public enumeration | Adxl346TypeActTapStatusActZSrc |
Public enumeration | Adxl346TypeActTapStatusAsleep |
Public enumeration | Adxl346TypeActTapStatusTapXSrc |
Public enumeration | Adxl346TypeActTapStatusTapYSrc |
Public enumeration | Adxl346TypeActTapStatusTapZSrc |
Public enumeration | Adxl346TypeBwRateLowPower |
Public enumeration | Adxl346TypeBwRateRateBits |
Public enumeration | Adxl346TypeDataFormatFullRes |
Public enumeration | Adxl346TypeDataFormatIntInvert |
Public enumeration | Adxl346TypeDataFormatJustify |
Public enumeration | Adxl346TypeDataFormatRange |
Public enumeration | Adxl346TypeDataFormatSelfTest |
Public enumeration | Adxl346TypeDataFormatSpi |
Public enumeration | Adxl346TypeFifoCtlFifoMode |
Public enumeration | Adxl346TypeFifoCtlTrigger |
Public enumeration | Adxl346TypeFifoStatusFifoTrig |
Public enumeration | Adxl346TypeIntEnableActivity |
Public enumeration | Adxl346TypeIntEnableDataReady |
Public enumeration | Adxl346TypeIntEnableDoubleTap |
Public enumeration | Adxl346TypeIntEnableFreeFall |
Public enumeration | Adxl346TypeIntEnableInactivity |
Public enumeration | Adxl346TypeIntEnableOverrun |
Public enumeration | Adxl346TypeIntEnableSingleTap |
Public enumeration | Adxl346TypeIntEnableWatermark |
Public enumeration | Adxl346TypeIntMapActivity |
Public enumeration | Adxl346TypeIntMapDataReady |
Public enumeration | Adxl346TypeIntMapDoubleTap |
Public enumeration | Adxl346TypeIntMapFreeFall |
Public enumeration | Adxl346TypeIntMapInactivity |
Public enumeration | Adxl346TypeIntMapOverrun |
Public enumeration | Adxl346TypeIntMapSingleTap |
Public enumeration | Adxl346TypeIntMapWatermark |
Public enumeration | Adxl346TypeIntSourceActivity |
Public enumeration | Adxl346TypeIntSourceDataReady |
Public enumeration | Adxl346TypeIntSourceDoubleTap |
Public enumeration | Adxl346TypeIntSourceFreeFall |
Public enumeration | Adxl346TypeIntSourceInactivity |
Public enumeration | Adxl346TypeIntSourceOverrun |
Public enumeration | Adxl346TypeIntSourceSingleTap |
Public enumeration | Adxl346TypeIntSourceWatermark |
Public enumeration | Adxl346TypeOrient2dOrient |
Public enumeration | Adxl346TypeOrient3dOrient |
Public enumeration | Adxl346TypeOrientConfDeadzone |
Public enumeration | Adxl346TypeOrientConfDevisor |
Public enumeration | Adxl346TypeOrientConfInt3d |
Public enumeration | Adxl346TypeOrientConfIntOrient |
Public enumeration | Adxl346TypeOrientV2 |
Public enumeration | Adxl346TypeOrientV3 |
Public enumeration | Adxl346TypePowerCtlAutoSleep |
Public enumeration | Adxl346TypePowerCtlLink |
Public enumeration | Adxl346TypePowerCtlMeasure |
Public enumeration | Adxl346TypePowerCtlSleep |
Public enumeration | Adxl346TypePowerCtlWakeup |
Public enumeration | Adxl346TypeTapAxesImprovedTap |
Public enumeration | Adxl346TypeTapAxesSuppress |
Public enumeration | Adxl346TypeTapAxesTapXEn |
Public enumeration | Adxl346TypeTapAxesTapYEn |
Public enumeration | Adxl346TypeTapAxesTapZEn |
Public enumeration | Adxl346TypeTapSignXsign |
Public enumeration | Adxl346TypeTapSignXtap |
Public enumeration | Adxl346TypeTapSignYsign |
Public enumeration | Adxl346TypeTapSignYtap |
Public enumeration | Adxl346TypeTapSignZsign |
Public enumeration | Adxl346TypeTapSignZtap |
Send comments on this topic to tsupport@telos.de


Ad7291 Class

Analog Devices: AD 7291
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAd7291

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ad7291
Public Class Ad7291
public ref class Ad7291
type Ad7291 =  class end

The Ad7291 type exposes the following members.

Constructors
 | Name | Description
Public method | Ad7291 | Constructor
Top
Properties
 | Name | Description
Public property | AlertStatusACH0HIGH | Alert Status A: CH0_HIGH
Public property | AlertStatusACH0LOW | Alert Status A: CH0_LOW
Public property | AlertStatusACH1HIGH | Alert Status A: CH1_HIGH
Public property | AlertStatusACH1LOW | Alert Status A: CH1_LOW
Public property | AlertStatusACH2HIGH | Alert Status A: CH2_HIGH
Public property | AlertStatusACH2LOW | Alert Status A: CH2_LOW
Public property | AlertStatusACH3HIGH | Alert Status A: CH3_HIGH
Public property | AlertStatusACH3LOW | Alert Status A: CH3_LOW
Public property | AlertStatusACH4HIGH | Alert Status A: CH4_HIGH
Public property | AlertStatusACH4LOW | Alert Status A: CH4_LOW
Public property | AlertStatusACH5HIGH | Alert Status A: CH5_HIGH
Public property | AlertStatusACH5LOW | Alert Status A: CH5_LOW
Public property | AlertStatusACH6HIGH | Alert Status A: CH6_HIGH
Public property | AlertStatusACH6LOW | Alert Status A: CH6_LOW
Public property | AlertStatusACH7HIGH | Alert Status A: CH7_HIGH
Public property | AlertStatusACH7LOW | Alert Status A: CH7_LOW
Public property | AlertStatusBTSENSEAVGHIGH | Alert Status B: TSENSE_AVG_HIGH
Public property | AlertStatusBTSENSEAVGLOW | Alert Status B: TSENSE_AVG_LOW
Public property | AlertStatusBTSENSEHIGH | Alert Status B: TSENSE_HIGH
Public property | AlertStatusBTSENSELOW | Alert Status B: TSENSE_LOW
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CH0DATAHIGH | CH0 DATA_HIGH (unit: °C)
Public property | CH0DATALOW | CH0 DATA_LOW (unit: °C)
Public property | CH0Hysteresis | CH0 Hysteresis
Public property | CH1DATAHIGH | CH1 DATA_HIGH (unit: °C)
Public property | CH1DATALOW | CH1 DATA_LOW (unit: °C)
Public property | CH1Hysteresis | CH1 Hysteresis
Public property | CH2DATAHIGH | CH2 DATA_HIGH (unit: °C)
Public property | CH2DATALOW | CH2 DATA_LOW (unit: °C)
Public property | CH2Hysteresis | CH2 Hysteresis
Public property | CH3DATAHIGH | CH3 DATA_HIGH (unit: °C)
Public property | CH3DATALOW | CH3 DATA_LOW (unit: °C)
Public property | CH3Hysteresis | CH3 Hysteresis
Public property | CH4DATAHIGH | CH4 DATA_HIGH (unit: °C)
Public property | CH4DATALOW | CH4 DATA_LOW (unit: °C)
Public property | CH4Hysteresis | CH4 Hysteresis
Public property | CH5DATAHIGH | CH5 DATA_HIGH (unit: °C)
Public property | CH5DATALOW | CH5 DATA_LOW (unit: °C)
Public property | CH5Hysteresis | CH5 Hysteresis
Public property | CH6DATAHIGH | CH6 DATA_HIGH (unit: °C)
Public property | CH6DATALOW | CH6 DATA_LOW (unit: °C)
Public property | CH6Hysteresis | CH6 Hysteresis
Public property | CH7DATAHIGH | CH7 DATA_HIGH (unit: °C)
Public property | CH7DATALOW | CH7 DATA_LOW (unit: °C)
Public property | CH7Hysteresis | CH7 Hysteresis
Public property | CommandAutocycleMode | Command: Autocycle Mode
Public property | CommandCH0 | Command: CH0
Public property | CommandCH1 | Command: CH1
Public property | CommandCH2 | Command: CH2
Public property | CommandCH3 | Command: CH3
Public property | CommandCH4 | Command: CH4
Public property | CommandCH5 | Command: CH5
Public property | CommandCH6 | Command: CH6
Public property | CommandCH7 | Command: CH7
Public property | CommandClearAlert | Command: Clear Alert
Public property | CommandEXTREF | Command: EXT_REF
Public property | CommandNoiseDelayedTrialAndSampling | Command: Noise Delayed Trial and Sampling
Public property | CommandPolarityALERTPin | Command: Polarity ALERT Pin
Public property | CommandRESET | Command: RESET
Public property | CommandTSENSE | Command: TSENSE
Public property | TSENSEAverageResultChannelAddress | T_SENSE Average Result: Channel Address
Public property | TSENSEAverageResultData | T_SENSE Average Result: Data (unit: °C)
Public property | TSENSEConversionResultChannelAddress | T_SENSE Conversion Result: Channel Address
Public property | TSENSEConversionResultData | T_SENSE Conversion Result: Data (unit: °C)
Public property | VoltageConversionResultChannelAddress | Voltage Conversion Result: Channel Address
Public property | VoltageConversionResultData | Voltage Conversion Result: Data (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
8-Channel, I2C, 12-Bit SAR ADC with Temperature Sensor
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7291 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ad7291(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ad7291

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291 Properties

The Ad7291 type exposes the following members.

Properties
 | Name | Description
Public property | AlertStatusACH0HIGH | Alert Status A: CH0_HIGH
Public property | AlertStatusACH0LOW | Alert Status A: CH0_LOW
Public property | AlertStatusACH1HIGH | Alert Status A: CH1_HIGH
Public property | AlertStatusACH1LOW | Alert Status A: CH1_LOW
Public property | AlertStatusACH2HIGH | Alert Status A: CH2_HIGH
Public property | AlertStatusACH2LOW | Alert Status A: CH2_LOW
Public property | AlertStatusACH3HIGH | Alert Status A: CH3_HIGH
Public property | AlertStatusACH3LOW | Alert Status A: CH3_LOW
Public property | AlertStatusACH4HIGH | Alert Status A: CH4_HIGH
Public property | AlertStatusACH4LOW | Alert Status A: CH4_LOW
Public property | AlertStatusACH5HIGH | Alert Status A: CH5_HIGH
Public property | AlertStatusACH5LOW | Alert Status A: CH5_LOW
Public property | AlertStatusACH6HIGH | Alert Status A: CH6_HIGH
Public property | AlertStatusACH6LOW | Alert Status A: CH6_LOW
Public property | AlertStatusACH7HIGH | Alert Status A: CH7_HIGH
Public property | AlertStatusACH7LOW | Alert Status A: CH7_LOW
Public property | AlertStatusBTSENSEAVGHIGH | Alert Status B: TSENSE_AVG_HIGH
Public property | AlertStatusBTSENSEAVGLOW | Alert Status B: TSENSE_AVG_LOW
Public property | AlertStatusBTSENSEHIGH | Alert Status B: TSENSE_HIGH
Public property | AlertStatusBTSENSELOW | Alert Status B: TSENSE_LOW
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CH0DATAHIGH | CH0 DATA_HIGH (unit: °C)
Public property | CH0DATALOW | CH0 DATA_LOW (unit: °C)
Public property | CH0Hysteresis | CH0 Hysteresis
Public property | CH1DATAHIGH | CH1 DATA_HIGH (unit: °C)
Public property | CH1DATALOW | CH1 DATA_LOW (unit: °C)
Public property | CH1Hysteresis | CH1 Hysteresis
Public property | CH2DATAHIGH | CH2 DATA_HIGH (unit: °C)
Public property | CH2DATALOW | CH2 DATA_LOW (unit: °C)
Public property | CH2Hysteresis | CH2 Hysteresis
Public property | CH3DATAHIGH | CH3 DATA_HIGH (unit: °C)
Public property | CH3DATALOW | CH3 DATA_LOW (unit: °C)
Public property | CH3Hysteresis | CH3 Hysteresis
Public property | CH4DATAHIGH | CH4 DATA_HIGH (unit: °C)
Public property | CH4DATALOW | CH4 DATA_LOW (unit: °C)
Public property | CH4Hysteresis | CH4 Hysteresis
Public property | CH5DATAHIGH | CH5 DATA_HIGH (unit: °C)
Public property | CH5DATALOW | CH5 DATA_LOW (unit: °C)
Public property | CH5Hysteresis | CH5 Hysteresis
Public property | CH6DATAHIGH | CH6 DATA_HIGH (unit: °C)
Public property | CH6DATALOW | CH6 DATA_LOW (unit: °C)
Public property | CH6Hysteresis | CH6 Hysteresis
Public property | CH7DATAHIGH | CH7 DATA_HIGH (unit: °C)
Public property | CH7DATALOW | CH7 DATA_LOW (unit: °C)
Public property | CH7Hysteresis | CH7 Hysteresis
Public property | CommandAutocycleMode | Command: Autocycle Mode
Public property | CommandCH0 | Command: CH0
Public property | CommandCH1 | Command: CH1
Public property | CommandCH2 | Command: CH2
Public property | CommandCH3 | Command: CH3
Public property | CommandCH4 | Command: CH4
Public property | CommandCH5 | Command: CH5
Public property | CommandCH6 | Command: CH6
Public property | CommandCH7 | Command: CH7
Public property | CommandClearAlert | Command: Clear Alert
Public property | CommandEXTREF | Command: EXT_REF
Public property | CommandNoiseDelayedTrialAndSampling | Command: Noise Delayed Trial and Sampling
Public property | CommandPolarityALERTPin | Command: Polarity ALERT Pin
Public property | CommandRESET | Command: RESET
Public property | CommandTSENSE | Command: TSENSE
Public property | TSENSEAverageResultChannelAddress | T_SENSE Average Result: Channel Address
Public property | TSENSEAverageResultData | T_SENSE Average Result: Data (unit: °C)
Public property | TSENSEConversionResultChannelAddress | T_SENSE Conversion Result: Channel Address
Public property | TSENSEConversionResultData | T_SENSE Conversion Result: Data (unit: °C)
Public property | VoltageConversionResultChannelAddress | Voltage Conversion Result: Channel Address
Public property | VoltageConversionResultData | Voltage Conversion Result: Data (unit: °C)
Top
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusACH0HIGH Property

IRD

Ad7291AlertStatusACH0HIGH Property

Alert Status A: CH0_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusACH0HIGH { get; }
Public ReadOnly Property AlertStatusACH0HIGH As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusACH0HIGH {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusACH0HIGH : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusACH0LOW Property

IRD

Ad7291AlertStatusACH0LOW Property

Alert Status A: CH0_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusACH0LOW { get; }
Public ReadOnly Property AlertStatusACH0LOW As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusACH0LOW {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusACH0LOW : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusACH1HIGH Property

IRD

Ad7291AlertStatusACH1HIGH Property

Alert Status A: CH1_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusACH1HIGH { get; }
Public ReadOnly Property AlertStatusACH1HIGH As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusACH1HIGH {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusACH1HIGH : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusACH1LOW Property

IRD

Ad7291AlertStatusACH1LOW Property

Alert Status A: CH1_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusACH1LOW { get; }
Public ReadOnly Property AlertStatusACH1LOW As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusACH1LOW {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusACH1LOW : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusACH2HIGH Property

IRD

Ad7291AlertStatusACH2HIGH Property

Alert Status A: CH2_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusACH2HIGH { get; }
Public ReadOnly Property AlertStatusACH2HIGH As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusACH2HIGH {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusACH2HIGH : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusACH2LOW Property

IRD

Ad7291AlertStatusACH2LOW Property

Alert Status A: CH2_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusACH2LOW { get; }
Public ReadOnly Property AlertStatusACH2LOW As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusACH2LOW {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusACH2LOW : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusACH3HIGH Property

IRD

Ad7291AlertStatusACH3HIGH Property

Alert Status A: CH3_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusACH3HIGH { get; }
Public ReadOnly Property AlertStatusACH3HIGH As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusACH3HIGH {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusACH3HIGH : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusACH3LOW Property

IRD

Ad7291AlertStatusACH3LOW Property

Alert Status A: CH3_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusACH3LOW { get; }
Public ReadOnly Property AlertStatusACH3LOW As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusACH3LOW {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusACH3LOW : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusACH4HIGH Property

IRD

Ad7291AlertStatusACH4HIGH Property

Alert Status A: CH4_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusACH4HIGH { get; }
Public ReadOnly Property AlertStatusACH4HIGH As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusACH4HIGH {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusACH4HIGH : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusACH4LOW Property

IRD

Ad7291AlertStatusACH4LOW Property

Alert Status A: CH4_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusACH4LOW { get; }
Public ReadOnly Property AlertStatusACH4LOW As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusACH4LOW {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusACH4LOW : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusACH5HIGH Property

IRD

Ad7291AlertStatusACH5HIGH Property

Alert Status A: CH5_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusACH5HIGH { get; }
Public ReadOnly Property AlertStatusACH5HIGH As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusACH5HIGH {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusACH5HIGH : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusACH5LOW Property

IRD

Ad7291AlertStatusACH5LOW Property

Alert Status A: CH5_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusACH5LOW { get; }
Public ReadOnly Property AlertStatusACH5LOW As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusACH5LOW {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusACH5LOW : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusACH6HIGH Property

IRD

Ad7291AlertStatusACH6HIGH Property

Alert Status A: CH6_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusACH6HIGH { get; }
Public ReadOnly Property AlertStatusACH6HIGH As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusACH6HIGH {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusACH6HIGH : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusACH6LOW Property

IRD

Ad7291AlertStatusACH6LOW Property

Alert Status A: CH6_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusACH6LOW { get; }
Public ReadOnly Property AlertStatusACH6LOW As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusACH6LOW {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusACH6LOW : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusACH7HIGH Property

IRD

Ad7291AlertStatusACH7HIGH Property

Alert Status A: CH7_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusACH7HIGH { get; }
Public ReadOnly Property AlertStatusACH7HIGH As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusACH7HIGH {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusACH7HIGH : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusACH7LOW Property

IRD

Ad7291AlertStatusACH7LOW Property

Alert Status A: CH7_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusACH7LOW { get; }
Public ReadOnly Property AlertStatusACH7LOW As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusACH7LOW {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusACH7LOW : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusBTSENSEAVGHIGH Property

IRD

Ad7291AlertStatusBTSENSEAVGHIGH Property

Alert Status B: TSENSE_AVG_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusBTSENSEAVGHIGH { get; }
Public ReadOnly Property AlertStatusBTSENSEAVGHIGH As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusBTSENSEAVGHIGH {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusBTSENSEAVGHIGH : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusBTSENSEAVGLOW Property

IRD

Ad7291AlertStatusBTSENSEAVGLOW Property

Alert Status B: TSENSE_AVG_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusBTSENSEAVGLOW { get; }
Public ReadOnly Property AlertStatusBTSENSEAVGLOW As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusBTSENSEAVGLOW {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusBTSENSEAVGLOW : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusBTSENSEHIGH Property

IRD

Ad7291AlertStatusBTSENSEHIGH Property

Alert Status B: TSENSE_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusBTSENSEHIGH { get; }
Public ReadOnly Property AlertStatusBTSENSEHIGH As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusBTSENSEHIGH {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusBTSENSEHIGH : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AlertStatusBTSENSELOW Property

IRD

Ad7291AlertStatusBTSENSELOW Property

Alert Status B: TSENSE_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeAlertStatus AlertStatusBTSENSELOW { get; }
Public ReadOnly Property AlertStatusBTSENSELOW As Ad7291TypeAlertStatus
    Get
public:
property Ad7291TypeAlertStatus AlertStatusBTSENSELOW {
    Ad7291TypeAlertStatus get ();
}
member AlertStatusBTSENSELOW : Ad7291TypeAlertStatus with get

Property Value

Type: Ad7291TypeAlertStatus
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.AutoFlush Property

IRD

Ad7291AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH0DATAHIGH Property

IRD

Ad7291CH0DATAHIGH Property

CH0 DATA_HIGH (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CH0DATAHIGH { get; set; }
Public Property CH0DATAHIGH As Double
    Get
    Set
public:
property double CH0DATAHIGH {
    double get ();
    void set (double value);
}
member CH0DATAHIGH : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH0DATALOW Property

IRD

Ad7291CH0DATALOW Property

CH0 DATA_LOW (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CH0DATALOW { get; set; }
Public Property CH0DATALOW As Double
    Get
    Set
public:
property double CH0DATALOW {
    double get ();
    void set (double value);
}
member CH0DATALOW : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH0Hysteresis Property

IRD

Ad7291CH0Hysteresis Property

CH0 Hysteresis

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort CH0Hysteresis { get; set; }
Public Property CH0Hysteresis As UShort
    Get
    Set
public:
property unsigned short CH0Hysteresis {
    unsigned short get ();
    void set (unsigned short value);
}
member CH0Hysteresis : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH1DATAHIGH Property

IRD

Ad7291CH1DATAHIGH Property

CH1 DATA_HIGH (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CH1DATAHIGH { get; set; }
Public Property CH1DATAHIGH As Double
    Get
    Set
public:
property double CH1DATAHIGH {
    double get ();
    void set (double value);
}
member CH1DATAHIGH : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH1DATALOW Property

IRD

Ad7291CH1DATALOW Property

CH1 DATA_LOW (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CH1DATALOW { get; set; }
Public Property CH1DATALOW As Double
    Get
    Set
public:
property double CH1DATALOW {
    double get ();
    void set (double value);
}
member CH1DATALOW : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH1Hysteresis Property

IRD

Ad7291CH1Hysteresis Property

CH1 Hysteresis

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort CH1Hysteresis { get; set; }
Public Property CH1Hysteresis As UShort
    Get
    Set
public:
property unsigned short CH1Hysteresis {
    unsigned short get ();
    void set (unsigned short value);
}
member CH1Hysteresis : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH2DATAHIGH Property

IRD

Ad7291CH2DATAHIGH Property

CH2 DATA_HIGH (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CH2DATAHIGH { get; set; }
Public Property CH2DATAHIGH As Double
    Get
    Set
public:
property double CH2DATAHIGH {
    double get ();
    void set (double value);
}
member CH2DATAHIGH : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH2DATALOW Property

IRD

Ad7291CH2DATALOW Property

CH2 DATA_LOW (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CH2DATALOW { get; set; }
Public Property CH2DATALOW As Double
    Get
    Set
public:
property double CH2DATALOW {
    double get ();
    void set (double value);
}
member CH2DATALOW : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH2Hysteresis Property

IRD

Ad7291CH2Hysteresis Property

CH2 Hysteresis

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort CH2Hysteresis { get; set; }
Public Property CH2Hysteresis As UShort
    Get
    Set
public:
property unsigned short CH2Hysteresis {
    unsigned short get ();
    void set (unsigned short value);
}
member CH2Hysteresis : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH3DATAHIGH Property

IRD

Ad7291CH3DATAHIGH Property

CH3 DATA_HIGH (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CH3DATAHIGH { get; set; }
Public Property CH3DATAHIGH As Double
    Get
    Set
public:
property double CH3DATAHIGH {
    double get ();
    void set (double value);
}
member CH3DATAHIGH : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH3DATALOW Property

IRD

Ad7291CH3DATALOW Property

CH3 DATA_LOW (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CH3DATALOW { get; set; }
Public Property CH3DATALOW As Double
    Get
    Set
public:
property double CH3DATALOW {
    double get ();
    void set (double value);
}
member CH3DATALOW : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH3Hysteresis Property

IRD

Ad7291CH3Hysteresis Property

CH3 Hysteresis

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort CH3Hysteresis { get; set; }
Public Property CH3Hysteresis As UShort
    Get
    Set
public:
property unsigned short CH3Hysteresis {
    unsigned short get ();
    void set (unsigned short value);
}
member CH3Hysteresis : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH4DATAHIGH Property

IRD

Ad7291CH4DATAHIGH Property

CH4 DATA_HIGH (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CH4DATAHIGH { get; set; }
Public Property CH4DATAHIGH As Double
    Get
    Set
public:
property double CH4DATAHIGH {
    double get ();
    void set (double value);
}
member CH4DATAHIGH : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH4DATALOW Property

IRD

Ad7291CH4DATALOW Property

CH4 DATA_LOW (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CH4DATALOW { get; set; }
Public Property CH4DATALOW As Double
    Get
    Set
public:
property double CH4DATALOW {
    double get ();
    void set (double value);
}
member CH4DATALOW : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH4Hysteresis Property

IRD

Ad7291CH4Hysteresis Property

CH4 Hysteresis

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort CH4Hysteresis { get; set; }
Public Property CH4Hysteresis As UShort
    Get
    Set
public:
property unsigned short CH4Hysteresis {
    unsigned short get ();
    void set (unsigned short value);
}
member CH4Hysteresis : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH5DATAHIGH Property

IRD

Ad7291CH5DATAHIGH Property

CH5 DATA_HIGH (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CH5DATAHIGH { get; set; }
Public Property CH5DATAHIGH As Double
    Get
    Set
public:
property double CH5DATAHIGH {
    double get ();
    void set (double value);
}
member CH5DATAHIGH : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH5DATALOW Property

IRD

Ad7291CH5DATALOW Property

CH5 DATA_LOW (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CH5DATALOW { get; set; }
Public Property CH5DATALOW As Double
    Get
    Set
public:
property double CH5DATALOW {
    double get ();
    void set (double value);
}
member CH5DATALOW : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH5Hysteresis Property

IRD

Ad7291CH5Hysteresis Property

CH5 Hysteresis

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort CH5Hysteresis { get; set; }
Public Property CH5Hysteresis As UShort
    Get
    Set
public:
property unsigned short CH5Hysteresis {
    unsigned short get ();
    void set (unsigned short value);
}
member CH5Hysteresis : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH6DATAHIGH Property

IRD

Ad7291CH6DATAHIGH Property

CH6 DATA_HIGH (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CH6DATAHIGH { get; set; }
Public Property CH6DATAHIGH As Double
    Get
    Set
public:
property double CH6DATAHIGH {
    double get ();
    void set (double value);
}
member CH6DATAHIGH : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH6DATALOW Property

IRD

Ad7291CH6DATALOW Property

CH6 DATA_LOW (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CH6DATALOW { get; set; }
Public Property CH6DATALOW As Double
    Get
    Set
public:
property double CH6DATALOW {
    double get ();
    void set (double value);
}
member CH6DATALOW : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH6Hysteresis Property

IRD

Ad7291CH6Hysteresis Property

CH6 Hysteresis

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort CH6Hysteresis { get; set; }
Public Property CH6Hysteresis As UShort
    Get
    Set
public:
property unsigned short CH6Hysteresis {
    unsigned short get ();
    void set (unsigned short value);
}
member CH6Hysteresis : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH7DATAHIGH Property

IRD

Ad7291CH7DATAHIGH Property

CH7 DATA_HIGH (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CH7DATAHIGH { get; set; }
Public Property CH7DATAHIGH As Double
    Get
    Set
public:
property double CH7DATAHIGH {
    double get ();
    void set (double value);
}
member CH7DATAHIGH : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH7DATALOW Property

IRD

Ad7291CH7DATALOW Property

CH7 DATA_LOW (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CH7DATALOW { get; set; }
Public Property CH7DATALOW As Double
    Get
    Set
public:
property double CH7DATALOW {
    double get ();
    void set (double value);
}
member CH7DATALOW : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CH7Hysteresis Property

IRD

Ad7291CH7Hysteresis Property

CH7 Hysteresis

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort CH7Hysteresis { get; set; }
Public Property CH7Hysteresis As UShort
    Get
    Set
public:
property unsigned short CH7Hysteresis {
    unsigned short get ();
    void set (unsigned short value);
}
member CH7Hysteresis : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CommandAutocycleMode Property

IRD

Ad7291CommandAutocycleMode Property

Command: Autocycle Mode

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeCommandEnabledDisabled CommandAutocycleMode { set; }
Public WriteOnly Property CommandAutocycleMode As Ad7291TypeCommandEnabledDisabled
    Set
public:
property Ad7291TypeCommandEnabledDisabled CommandAutocycleMode {
    void set (Ad7291TypeCommandEnabledDisabled value);
}
member CommandAutocycleMode : Ad7291TypeCommandEnabledDisabled with set

Property Value

Type: Ad7291TypeCommandEnabledDisabled
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CommandCH0 Property

IRD

Ad7291CommandCH0 Property

Command: CH0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeCommandEnabledDisabled CommandCH0 { set; }
Public WriteOnly Property CommandCH0 As Ad7291TypeCommandEnabledDisabled
    Set
public:
property Ad7291TypeCommandEnabledDisabled CommandCH0 {
    void set (Ad7291TypeCommandEnabledDisabled value);
}
member CommandCH0 : Ad7291TypeCommandEnabledDisabled with set

Property Value

Type: Ad7291TypeCommandEnabledDisabled
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CommandCH1 Property

IRD

Ad7291CommandCH1 Property

Command: CH1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeCommandEnabledDisabled CommandCH1 { set; }
Public WriteOnly Property CommandCH1 As Ad7291TypeCommandEnabledDisabled
    Set
public:
property Ad7291TypeCommandEnabledDisabled CommandCH1 {
    void set (Ad7291TypeCommandEnabledDisabled value);
}
member CommandCH1 : Ad7291TypeCommandEnabledDisabled with set

Property Value

Type: Ad7291TypeCommandEnabledDisabled
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CommandCH2 Property

IRD

Ad7291CommandCH2 Property

Command: CH2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeCommandEnabledDisabled CommandCH2 { set; }
Public WriteOnly Property CommandCH2 As Ad7291TypeCommandEnabledDisabled
    Set
public:
property Ad7291TypeCommandEnabledDisabled CommandCH2 {
    void set (Ad7291TypeCommandEnabledDisabled value);
}
member CommandCH2 : Ad7291TypeCommandEnabledDisabled with set

Property Value

Type: Ad7291TypeCommandEnabledDisabled
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CommandCH3 Property

IRD

Ad7291CommandCH3 Property

Command: CH3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeCommandEnabledDisabled CommandCH3 { set; }
Public WriteOnly Property CommandCH3 As Ad7291TypeCommandEnabledDisabled
    Set
public:
property Ad7291TypeCommandEnabledDisabled CommandCH3 {
    void set (Ad7291TypeCommandEnabledDisabled value);
}
member CommandCH3 : Ad7291TypeCommandEnabledDisabled with set

Property Value

Type: Ad7291TypeCommandEnabledDisabled
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CommandCH4 Property

IRD

Ad7291CommandCH4 Property

Command: CH4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeCommandEnabledDisabled CommandCH4 { set; }
Public WriteOnly Property CommandCH4 As Ad7291TypeCommandEnabledDisabled
    Set
public:
property Ad7291TypeCommandEnabledDisabled CommandCH4 {
    void set (Ad7291TypeCommandEnabledDisabled value);
}
member CommandCH4 : Ad7291TypeCommandEnabledDisabled with set

Property Value

Type: Ad7291TypeCommandEnabledDisabled
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CommandCH5 Property

IRD

Ad7291CommandCH5 Property

Command: CH5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeCommandEnabledDisabled CommandCH5 { set; }
Public WriteOnly Property CommandCH5 As Ad7291TypeCommandEnabledDisabled
    Set
public:
property Ad7291TypeCommandEnabledDisabled CommandCH5 {
    void set (Ad7291TypeCommandEnabledDisabled value);
}
member CommandCH5 : Ad7291TypeCommandEnabledDisabled with set

Property Value

Type: Ad7291TypeCommandEnabledDisabled
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CommandCH6 Property

IRD

Ad7291CommandCH6 Property

Command: CH6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeCommandEnabledDisabled CommandCH6 { set; }
Public WriteOnly Property CommandCH6 As Ad7291TypeCommandEnabledDisabled
    Set
public:
property Ad7291TypeCommandEnabledDisabled CommandCH6 {
    void set (Ad7291TypeCommandEnabledDisabled value);
}
member CommandCH6 : Ad7291TypeCommandEnabledDisabled with set

Property Value

Type: Ad7291TypeCommandEnabledDisabled
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CommandCH7 Property

IRD

Ad7291CommandCH7 Property

Command: CH7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeCommandEnabledDisabled CommandCH7 { set; }
Public WriteOnly Property CommandCH7 As Ad7291TypeCommandEnabledDisabled
    Set
public:
property Ad7291TypeCommandEnabledDisabled CommandCH7 {
    void set (Ad7291TypeCommandEnabledDisabled value);
}
member CommandCH7 : Ad7291TypeCommandEnabledDisabled with set

Property Value

Type: Ad7291TypeCommandEnabledDisabled
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CommandClearAlert Property

IRD

Ad7291CommandClearAlert Property

Command: Clear Alert

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeCommandClearAlert CommandClearAlert { set; }
Public WriteOnly Property CommandClearAlert As Ad7291TypeCommandClearAlert
    Set
public:
property Ad7291TypeCommandClearAlert CommandClearAlert {
    void set (Ad7291TypeCommandClearAlert value);
}
member CommandClearAlert : Ad7291TypeCommandClearAlert with set

Property Value

Type: Ad7291TypeCommandClearAlert
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CommandEXTREF Property

IRD

Ad7291CommandEXTREF Property

Command: EXT_REF

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeCommandExtRef CommandEXTREF { set; }
Public WriteOnly Property CommandEXTREF As Ad7291TypeCommandExtRef
    Set
public:
property Ad7291TypeCommandExtRef CommandEXTREF {
    void set (Ad7291TypeCommandExtRef value);
}
member CommandEXTREF : Ad7291TypeCommandExtRef with set

Property Value

Type: Ad7291TypeCommandExtRef
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CommandNoiseDelayedTrialAndSampling Property

IRD

Ad7291CommandNoiseDelayedTrialAndSampling Property

Command: Noise Delayed Trial and Sampling

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeCommandEnabledDisabled CommandNoiseDelayedTrialAndSampling { set; }
Public WriteOnly Property CommandNoiseDelayedTrialAndSampling As Ad7291TypeCommandEnabledDisabled
    Set
public:
property Ad7291TypeCommandEnabledDisabled CommandNoiseDelayedTrialAndSampling {
    void set (Ad7291TypeCommandEnabledDisabled value);
}
member CommandNoiseDelayedTrialAndSampling : Ad7291TypeCommandEnabledDisabled with set

Property Value

Type: Ad7291TypeCommandEnabledDisabled
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CommandPolarityALERTPin Property

IRD

Ad7291CommandPolarityALERTPin Property

Command: Polarity ALERT Pin

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeCommandPolarityAlertPin CommandPolarityALERTPin { set; }
Public WriteOnly Property CommandPolarityALERTPin As Ad7291TypeCommandPolarityAlertPin
    Set
public:
property Ad7291TypeCommandPolarityAlertPin CommandPolarityALERTPin {
    void set (Ad7291TypeCommandPolarityAlertPin value);
}
member CommandPolarityALERTPin : Ad7291TypeCommandPolarityAlertPin with set

Property Value

Type: Ad7291TypeCommandPolarityAlertPin
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CommandRESET Property

IRD

Ad7291CommandRESET Property

Command: RESET

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeCommandReset CommandRESET { set; }
Public WriteOnly Property CommandRESET As Ad7291TypeCommandReset
    Set
public:
property Ad7291TypeCommandReset CommandRESET {
    void set (Ad7291TypeCommandReset value);
}
member CommandRESET : Ad7291TypeCommandReset with set

Property Value

Type: Ad7291TypeCommandReset
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.CommandTSENSE Property

IRD

Ad7291CommandTSENSE Property

Command: TSENSE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeCommandEnabledDisabled CommandTSENSE { set; }
Public WriteOnly Property CommandTSENSE As Ad7291TypeCommandEnabledDisabled
    Set
public:
property Ad7291TypeCommandEnabledDisabled CommandTSENSE {
    void set (Ad7291TypeCommandEnabledDisabled value);
}
member CommandTSENSE : Ad7291TypeCommandEnabledDisabled with set

Property Value

Type: Ad7291TypeCommandEnabledDisabled
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.TSENSEAverageResultChannelAddress Property

IRD

Ad7291TSENSEAverageResultChannelAddress Property

T_SENSE Average Result: Channel Address

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeChannelAddress TSENSEAverageResultChannelAddress { get; }
Public ReadOnly Property TSENSEAverageResultChannelAddress As Ad7291TypeChannelAddress
    Get
public:
property Ad7291TypeChannelAddress TSENSEAverageResultChannelAddress {
    Ad7291TypeChannelAddress get ();
}
member TSENSEAverageResultChannelAddress : Ad7291TypeChannelAddress with get

Property Value

Type: Ad7291TypeChannelAddress
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.TSENSEAverageResultData Property

IRD

Ad7291TSENSEAverageResultData Property

T_SENSE Average Result: Data (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TSENSEAverageResultData { get; }
Public ReadOnly Property TSENSEAverageResultData As Double
    Get
public:
property double TSENSEAverageResultData {
    double get ();
}
member TSENSEAverageResultData : float with get

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.TSENSEConversionResultChannelAddress Property

IRD

Ad7291TSENSEConversionResultChannelAddress Property

T_SENSE Conversion Result: Channel Address

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeChannelAddress TSENSEConversionResultChannelAddress { get; }
Public ReadOnly Property TSENSEConversionResultChannelAddress As Ad7291TypeChannelAddress
    Get
public:
property Ad7291TypeChannelAddress TSENSEConversionResultChannelAddress {
    Ad7291TypeChannelAddress get ();
}
member TSENSEConversionResultChannelAddress : Ad7291TypeChannelAddress with get

Property Value

Type: Ad7291TypeChannelAddress
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.TSENSEConversionResultData Property

IRD

Ad7291TSENSEConversionResultData Property

T_SENSE Conversion Result: Data (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TSENSEConversionResultData { get; }
Public ReadOnly Property TSENSEConversionResultData As Double
    Get
public:
property double TSENSEConversionResultData {
    double get ();
}
member TSENSEConversionResultData : float with get

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.VoltageConversionResultChannelAddress Property

IRD

Ad7291VoltageConversionResultChannelAddress Property

Voltage Conversion Result: Channel Address

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7291TypeChannelAddress VoltageConversionResultChannelAddress { get; }
Public ReadOnly Property VoltageConversionResultChannelAddress As Ad7291TypeChannelAddress
    Get
public:
property Ad7291TypeChannelAddress VoltageConversionResultChannelAddress {
    Ad7291TypeChannelAddress get ();
}
member VoltageConversionResultChannelAddress : Ad7291TypeChannelAddress with get

Property Value

Type: Ad7291TypeChannelAddress
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.VoltageConversionResultData Property

IRD

Ad7291VoltageConversionResultData Property

Voltage Conversion Result: Data (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VoltageConversionResultData { get; }
Public ReadOnly Property VoltageConversionResultData As Double
    Get
public:
property double VoltageConversionResultData {
    double get ();
}
member VoltageConversionResultData : float with get

Property Value

Type: Double
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291 Methods

The Ad7291 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.Flush Method

IRD

Ad7291Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ad7291 Class
telos.Ird.AnalogDevices Namespace


Ad7291.TypeAlertStatus Enumeration

IRD

Ad7291TypeAlertStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlertStatus
Public Enumeration TypeAlertStatus
public enum class TypeAlertStatus
type TypeAlertStatus
Members
Member name | Value | Description
NoAlert | 0 | No Alert
Alert | 1 | Alert
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7291.TypeChannelAddress Enumeration

IRD

Ad7291TypeChannelAddress Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelAddress
Public Enumeration TypeChannelAddress
public enum class TypeChannelAddress
type TypeChannelAddress
Members
Member name | Value | Description
VIN0 | 0 | V_IN0
VIN1 | 1 | V_IN1
VIN2 | 2 | V_IN2
VIN3 | 3 | V_IN3
VIN4 | 4 | V_IN4
VIN5 | 5 | V_IN5
VIN6 | 6 | V_IN6
VIN7 | 7 | V_IN7
TSENSE | 8 | T_SENSE
TSENSEAverageResult | 9 | T_SENSE Average Result
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7291.TypeCommandClearAlert Enumeration

IRD

Ad7291TypeCommandClearAlert Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommandClearAlert
Public Enumeration TypeCommandClearAlert
public enum class TypeCommandClearAlert
type TypeCommandClearAlert
Members
Member name | Value | Description
Default | 0 | Default
ClearAlertStatus | 1 | Clear Alert Status
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7291.TypeCommandEnabledDisabled Enumeration

IRD

Ad7291TypeCommandEnabledDisabled Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommandEnabledDisabled
Public Enumeration TypeCommandEnabledDisabled
public enum class TypeCommandEnabledDisabled
type TypeCommandEnabledDisabled
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7291.TypeCommandExtRef Enumeration

IRD

Ad7291TypeCommandExtRef Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommandExtRef
Public Enumeration TypeCommandExtRef
public enum class TypeCommandExtRef
type TypeCommandExtRef
Members
Member name | Value | Description
InternelReference | 0 | Internel Reference
ExternalReference | 1 | External Reference
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7291.TypeCommandPolarityAlertPin Enumeration

IRD

Ad7291TypeCommandPolarityAlertPin Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommandPolarityAlertPin
Public Enumeration TypeCommandPolarityAlertPin
public enum class TypeCommandPolarityAlertPin
type TypeCommandPolarityAlertPin
Members
Member name | Value | Description
ActiveHigh | 0 | Active High
ActiveLow | 1 | Active Low
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7291.TypeCommandReset Enumeration

IRD

Ad7291TypeCommandReset Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommandReset
Public Enumeration TypeCommandReset
public enum class TypeCommandReset
type TypeCommandReset
Members
Member name | Value | Description
Default | 0 | Default
ResetAllRegisters | 1 | Reset all registers
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7414 Class

Analog Devices: AD 7414
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAd7414

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ad7414
Public Class Ad7414
public ref class Ad7414
type Ad7414 =  class end

The Ad7414 type exposes the following members.

Constructors
 | Name | Description
Public method | Ad7414 | Constructor
Top
Properties
 | Name | Description
Public property | ALERTFlag | ALERT Flag
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationALERTEN | Configuration (ALERT EN)
Public property | ConfigurationALERTPOLARITY | Configuration (ALERT POLARITY)
Public property | ConfigurationALERTRESET | Configuration (ALERT RESET)
Public property | ConfigurationFLTR | Configuration (FLTR)
Public property | ConfigurationONESHOT | Configuration (ONE SHOT)
Public property | ConfigurationPD | Configuration (PD)
Public property | Temperature | Temperature (unit: °C)
Public property | THIGH | T_HIGH (unit: °C)
Public property | THIGHFlag | T_HIGH Flag
Public property | TLOW | T_LOW (unit: °C)
Public property | TLOWFlag | T_LOW Flag
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
±0.5°C Accurate, 10-Bit Digital Temperature Sensors in SOT-23
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7414 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7414(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ad7414(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ad7414

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ad7414 Class
telos.Ird.AnalogDevices Namespace


Ad7414 Properties

The Ad7414 type exposes the following members.

Properties
 | Name | Description
Public property | ALERTFlag | ALERT Flag
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationALERTEN | Configuration (ALERT EN)
Public property | ConfigurationALERTPOLARITY | Configuration (ALERT POLARITY)
Public property | ConfigurationALERTRESET | Configuration (ALERT RESET)
Public property | ConfigurationFLTR | Configuration (FLTR)
Public property | ConfigurationONESHOT | Configuration (ONE SHOT)
Public property | ConfigurationPD | Configuration (PD)
Public property | Temperature | Temperature (unit: °C)
Public property | THIGH | T_HIGH (unit: °C)
Public property | THIGHFlag | T_HIGH Flag
Public property | TLOW | T_LOW (unit: °C)
Public property | TLOWFlag | T_LOW Flag
Top
See Also

Reference

Ad7414 Class
telos.Ird.AnalogDevices Namespace


Ad7414.ALERTFlag Property

IRD

Ad7414ALERTFlag Property

ALERT Flag

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ALERTFlag { get; }
Public ReadOnly Property ALERTFlag As Byte
    Get
public:
property unsigned char ALERTFlag {
    unsigned char get ();
}
member ALERTFlag : byte with get

Property Value

Type: Byte
See Also

Reference

Ad7414 Class
telos.Ird.AnalogDevices Namespace


Ad7414.AutoFlush Property

IRD

Ad7414AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ad7414 Class
telos.Ird.AnalogDevices Namespace


Ad7414.ConfigurationALERTEN Property

IRD

Ad7414ConfigurationALERTEN Property

Configuration (ALERT EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7414TypeConfigurationAlertEn ConfigurationALERTEN { get; set; }
Public Property ConfigurationALERTEN As Ad7414TypeConfigurationAlertEn
    Get
    Set
public:
property Ad7414TypeConfigurationAlertEn ConfigurationALERTEN {
    Ad7414TypeConfigurationAlertEn get ();
    void set (Ad7414TypeConfigurationAlertEn value);
}
member ConfigurationALERTEN : Ad7414TypeConfigurationAlertEn with get, set

Property Value

Type: Ad7414TypeConfigurationAlertEn
See Also

Reference

Ad7414 Class
telos.Ird.AnalogDevices Namespace


Ad7414.ConfigurationALERTPOLARITY Property

IRD

Ad7414ConfigurationALERTPOLARITY Property

Configuration (ALERT POLARITY)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7414TypeConfigurationAlertPolarity ConfigurationALERTPOLARITY { get; set; }
Public Property ConfigurationALERTPOLARITY As Ad7414TypeConfigurationAlertPolarity
    Get
    Set
public:
property Ad7414TypeConfigurationAlertPolarity ConfigurationALERTPOLARITY {
    Ad7414TypeConfigurationAlertPolarity get ();
    void set (Ad7414TypeConfigurationAlertPolarity value);
}
member ConfigurationALERTPOLARITY : Ad7414TypeConfigurationAlertPolarity with get, set

Property Value

Type: Ad7414TypeConfigurationAlertPolarity
See Also

Reference

Ad7414 Class
telos.Ird.AnalogDevices Namespace


Ad7414.ConfigurationALERTRESET Property

IRD

Ad7414ConfigurationALERTRESET Property

Configuration (ALERT RESET)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7414TypeConfigurationAlertReset ConfigurationALERTRESET { set; }
Public WriteOnly Property ConfigurationALERTRESET As Ad7414TypeConfigurationAlertReset
    Set
public:
property Ad7414TypeConfigurationAlertReset ConfigurationALERTRESET {
    void set (Ad7414TypeConfigurationAlertReset value);
}
member ConfigurationALERTRESET : Ad7414TypeConfigurationAlertReset with set

Property Value

Type: Ad7414TypeConfigurationAlertReset
See Also

Reference

Ad7414 Class
telos.Ird.AnalogDevices Namespace


Ad7414.ConfigurationFLTR Property

IRD

Ad7414ConfigurationFLTR Property

Configuration (FLTR)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7414TypeConfigurationFltr ConfigurationFLTR { get; set; }
Public Property ConfigurationFLTR As Ad7414TypeConfigurationFltr
    Get
    Set
public:
property Ad7414TypeConfigurationFltr ConfigurationFLTR {
    Ad7414TypeConfigurationFltr get ();
    void set (Ad7414TypeConfigurationFltr value);
}
member ConfigurationFLTR : Ad7414TypeConfigurationFltr with get, set

Property Value

Type: Ad7414TypeConfigurationFltr
See Also

Reference

Ad7414 Class
telos.Ird.AnalogDevices Namespace


Ad7414.ConfigurationONESHOT Property

IRD

Ad7414ConfigurationONESHOT Property

Configuration (ONE SHOT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7414TypeConfigurationOneShot ConfigurationONESHOT { set; }
Public WriteOnly Property ConfigurationONESHOT As Ad7414TypeConfigurationOneShot
    Set
public:
property Ad7414TypeConfigurationOneShot ConfigurationONESHOT {
    void set (Ad7414TypeConfigurationOneShot value);
}
member ConfigurationONESHOT : Ad7414TypeConfigurationOneShot with set

Property Value

Type: Ad7414TypeConfigurationOneShot
See Also

Reference

Ad7414 Class
telos.Ird.AnalogDevices Namespace


Ad7414.ConfigurationPD Property

IRD

Ad7414ConfigurationPD Property

Configuration (PD)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7414TypeConfigurationPd ConfigurationPD { get; set; }
Public Property ConfigurationPD As Ad7414TypeConfigurationPd
    Get
    Set
public:
property Ad7414TypeConfigurationPd ConfigurationPD {
    Ad7414TypeConfigurationPd get ();
    void set (Ad7414TypeConfigurationPd value);
}
member ConfigurationPD : Ad7414TypeConfigurationPd with get, set

Property Value

Type: Ad7414TypeConfigurationPd
See Also

Reference

Ad7414 Class
telos.Ird.AnalogDevices Namespace


Ad7414.Temperature Property

IRD

Ad7414Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Ad7414 Class
telos.Ird.AnalogDevices Namespace


Ad7414.THIGH Property

IRD

Ad7414THIGH Property

T_HIGH (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte THIGH { get; set; }
Public Property THIGH As SByte
    Get
    Set
public:
property signed char THIGH {
    signed char get ();
    void set (signed char value);
}
member THIGH : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Ad7414 Class
telos.Ird.AnalogDevices Namespace


Ad7414.THIGHFlag Property

IRD

Ad7414THIGHFlag Property

T_HIGH Flag

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7414TypeTHighFlag THIGHFlag { get; }
Public ReadOnly Property THIGHFlag As Ad7414TypeTHighFlag
    Get
public:
property Ad7414TypeTHighFlag THIGHFlag {
    Ad7414TypeTHighFlag get ();
}
member THIGHFlag : Ad7414TypeTHighFlag with get

Property Value

Type: Ad7414TypeTHighFlag
See Also

Reference

Ad7414 Class
telos.Ird.AnalogDevices Namespace


Ad7414.TLOW Property

IRD

Ad7414TLOW Property

T_LOW (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte TLOW { get; set; }
Public Property TLOW As SByte
    Get
    Set
public:
property signed char TLOW {
    signed char get ();
    void set (signed char value);
}
member TLOW : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Ad7414 Class
telos.Ird.AnalogDevices Namespace


Ad7414.TLOWFlag Property

IRD

Ad7414TLOWFlag Property

T_LOW Flag

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7414TypeTLowFlag TLOWFlag { get; }
Public ReadOnly Property TLOWFlag As Ad7414TypeTLowFlag
    Get
public:
property Ad7414TypeTLowFlag TLOWFlag {
    Ad7414TypeTLowFlag get ();
}
member TLOWFlag : Ad7414TypeTLowFlag with get

Property Value

Type: Ad7414TypeTLowFlag
See Also

Reference

Ad7414 Class
telos.Ird.AnalogDevices Namespace


Ad7414 Methods

The Ad7414 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ad7414 Class
telos.Ird.AnalogDevices Namespace


Ad7414.Flush Method

IRD

Ad7414Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ad7414 Class
telos.Ird.AnalogDevices Namespace


Ad7414.TypeConfigurationAlertEn Enumeration

IRD

Ad7414TypeConfigurationAlertEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationAlertEn
Public Enumeration TypeConfigurationAlertEn
public enum class TypeConfigurationAlertEn
type TypeConfigurationAlertEn
Members
Member name | Value | Description
ALERTEnabled | 0 | ALERT: Enabled
ALERTDisabled | 1 | ALERT: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7414.TypeConfigurationAlertPolarity Enumeration

IRD

Ad7414TypeConfigurationAlertPolarity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationAlertPolarity
Public Enumeration TypeConfigurationAlertPolarity
public enum class TypeConfigurationAlertPolarity
type TypeConfigurationAlertPolarity
Members
Member name | Value | Description
ALERTActiveLow | 0 | ALERT: Active Low
ALERTActiveHigh | 1 | ALERT: Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7414.TypeConfigurationAlertReset Enumeration

IRD

Ad7414TypeConfigurationAlertReset Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationAlertReset
Public Enumeration TypeConfigurationAlertReset
public enum class TypeConfigurationAlertReset
type TypeConfigurationAlertReset
Members
Member name | Value | Description
ALERTUnmodified | 0 | ALERT: Unmodified
ALERTReset | 1 | ALERT: Reset
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7414.TypeConfigurationFltr Enumeration

IRD

Ad7414TypeConfigurationFltr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationFltr
Public Enumeration TypeConfigurationFltr
public enum class TypeConfigurationFltr
type TypeConfigurationFltr
Members
Member name | Value | Description
SDASCLFilteringBypassed | 0 | SDA/SCL Filtering: Bypassed
SDASCLFilteringNormal | 1 | SDA/SCL Filtering: Normal
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7414.TypeConfigurationOneShot Enumeration

IRD

Ad7414TypeConfigurationOneShot Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationOneShot
Public Enumeration TypeConfigurationOneShot
public enum class TypeConfigurationOneShot
type TypeConfigurationOneShot
Members
Member name | Value | Description
Unmodified | 0 | Unmodified
TriggerConversion | 1 | Trigger Conversion
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7414.TypeConfigurationPd Enumeration

IRD

Ad7414TypeConfigurationPd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationPd
Public Enumeration TypeConfigurationPd
public enum class TypeConfigurationPd
type TypeConfigurationPd
Members
Member name | Value | Description
PowerOn | 0 | Power-On
FullPowerDown | 1 | Full Power Down
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7414.TypeTHighFlag Enumeration

IRD

Ad7414TypeTHighFlag Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTHighFlag
Public Enumeration TypeTHighFlag
public enum class TypeTHighFlag
type TypeTHighFlag
Members
Member name | Value | Description
TTHIGH | 0 | T <= T_HIGH
TTHIGH__1 | 1 | T > T_HIGH
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7414.TypeTLowFlag Enumeration

IRD

Ad7414TypeTLowFlag Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTLowFlag
Public Enumeration TypeTLowFlag
public enum class TypeTLowFlag
type TypeTLowFlag
Members
Member name | Value | Description
TTLOW | 0 | T >= T_LOW
TTLOW__1 | 1 | T < T_LOW
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7415 Class

Analog Devices: AD 7415
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAd7415

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ad7415
Public Class Ad7415
public ref class Ad7415
type Ad7415 =  class end

The Ad7415 type exposes the following members.

Constructors
 | Name | Description
Public method | Ad7415 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationFLTR | Configuration (FLTR)
Public property | ConfigurationONESHOT | Configuration (ONE SHOT)
Public property | ConfigurationPD | Configuration (PD)
Public property | Temperature | Temperature (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
±0.5°C Accurate, 10-Bit Digital Temperature Sensors in SOT-23
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7415 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7415(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ad7415(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ad7415

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ad7415 Class
telos.Ird.AnalogDevices Namespace


Ad7415 Properties

The Ad7415 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationFLTR | Configuration (FLTR)
Public property | ConfigurationONESHOT | Configuration (ONE SHOT)
Public property | ConfigurationPD | Configuration (PD)
Public property | Temperature | Temperature (unit: °C)
Top
See Also

Reference

Ad7415 Class
telos.Ird.AnalogDevices Namespace


Ad7415.AutoFlush Property

IRD

Ad7415AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ad7415 Class
telos.Ird.AnalogDevices Namespace


Ad7415.ConfigurationFLTR Property

IRD

Ad7415ConfigurationFLTR Property

Configuration (FLTR)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7415TypeConfigurationFltr ConfigurationFLTR { get; set; }
Public Property ConfigurationFLTR As Ad7415TypeConfigurationFltr
    Get
    Set
public:
property Ad7415TypeConfigurationFltr ConfigurationFLTR {
    Ad7415TypeConfigurationFltr get ();
    void set (Ad7415TypeConfigurationFltr value);
}
member ConfigurationFLTR : Ad7415TypeConfigurationFltr with get, set

Property Value

Type: Ad7415TypeConfigurationFltr
See Also

Reference

Ad7415 Class
telos.Ird.AnalogDevices Namespace


Ad7415.ConfigurationONESHOT Property

IRD

Ad7415ConfigurationONESHOT Property

Configuration (ONE SHOT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7415TypeConfigurationOneShot ConfigurationONESHOT { set; }
Public WriteOnly Property ConfigurationONESHOT As Ad7415TypeConfigurationOneShot
    Set
public:
property Ad7415TypeConfigurationOneShot ConfigurationONESHOT {
    void set (Ad7415TypeConfigurationOneShot value);
}
member ConfigurationONESHOT : Ad7415TypeConfigurationOneShot with set

Property Value

Type: Ad7415TypeConfigurationOneShot
See Also

Reference

Ad7415 Class
telos.Ird.AnalogDevices Namespace


Ad7415.ConfigurationPD Property

IRD

Ad7415ConfigurationPD Property

Configuration (PD)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7415TypeConfigurationPd ConfigurationPD { get; set; }
Public Property ConfigurationPD As Ad7415TypeConfigurationPd
    Get
    Set
public:
property Ad7415TypeConfigurationPd ConfigurationPD {
    Ad7415TypeConfigurationPd get ();
    void set (Ad7415TypeConfigurationPd value);
}
member ConfigurationPD : Ad7415TypeConfigurationPd with get, set

Property Value

Type: Ad7415TypeConfigurationPd
See Also

Reference

Ad7415 Class
telos.Ird.AnalogDevices Namespace


Ad7415.Temperature Property

IRD

Ad7415Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Ad7415 Class
telos.Ird.AnalogDevices Namespace


Ad7415 Methods

The Ad7415 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ad7415 Class
telos.Ird.AnalogDevices Namespace


Ad7415.Flush Method

IRD

Ad7415Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ad7415 Class
telos.Ird.AnalogDevices Namespace


Ad7415.TypeConfigurationFltr Enumeration

IRD

Ad7415TypeConfigurationFltr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationFltr
Public Enumeration TypeConfigurationFltr
public enum class TypeConfigurationFltr
type TypeConfigurationFltr
Members
Member name | Value | Description
SDASCLFilteringBypassed | 0 | SDA/SCL Filtering: Bypassed
SDASCLFilteringNormal | 1 | SDA/SCL Filtering: Normal
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7415.TypeConfigurationOneShot Enumeration

IRD

Ad7415TypeConfigurationOneShot Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationOneShot
Public Enumeration TypeConfigurationOneShot
public enum class TypeConfigurationOneShot
type TypeConfigurationOneShot
Members
Member name | Value | Description
Unmodified | 0 | Unmodified
TriggerConversion | 1 | Trigger Conversion
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7415.TypeConfigurationPd Enumeration

IRD

Ad7415TypeConfigurationPd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationPd
Public Enumeration TypeConfigurationPd
public enum class TypeConfigurationPd
type TypeConfigurationPd
Members
Member name | Value | Description
PowerOn | 0 | Power-On
FullPowerDown | 1 | Full Power Down
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7416 Class

Analog Devices: AD 7416
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAd7416

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ad7416
Public Class Ad7416
public ref class Ad7416
type Ad7416 =  class end

The Ad7416 type exposes the following members.

Constructors
 | Name | Description
Public method | Ad7416 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationCmpInt | Configuration (Cmp/Int)
Public property | ConfigurationFaultQueue | Configuration (Fault Queue)
Public property | ConfigurationOTIPolarity | Configuration (OTI Polarity)
Public property | ConfigurationShutdown | Configuration (Shutdown)
Public property | Temperature | Temperature (unit: °C)
Public property | THYST | T_HYST (unit: °C)
Public property | TOTI | T_OTI (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
10-Bit Digital Temperature Sensor
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7416 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7416(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ad7416(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ad7416

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ad7416 Class
telos.Ird.AnalogDevices Namespace


Ad7416 Properties

The Ad7416 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationCmpInt | Configuration (Cmp/Int)
Public property | ConfigurationFaultQueue | Configuration (Fault Queue)
Public property | ConfigurationOTIPolarity | Configuration (OTI Polarity)
Public property | ConfigurationShutdown | Configuration (Shutdown)
Public property | Temperature | Temperature (unit: °C)
Public property | THYST | T_HYST (unit: °C)
Public property | TOTI | T_OTI (unit: °C)
Top
See Also

Reference

Ad7416 Class
telos.Ird.AnalogDevices Namespace


Ad7416.AutoFlush Property

IRD

Ad7416AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ad7416 Class
telos.Ird.AnalogDevices Namespace


Ad7416.ConfigurationCmpInt Property

IRD

Ad7416ConfigurationCmpInt Property

Configuration (Cmp/Int)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7416TypeConfigurationCmpInt ConfigurationCmpInt { get; set; }
Public Property ConfigurationCmpInt As Ad7416TypeConfigurationCmpInt
    Get
    Set
public:
property Ad7416TypeConfigurationCmpInt ConfigurationCmpInt {
    Ad7416TypeConfigurationCmpInt get ();
    void set (Ad7416TypeConfigurationCmpInt value);
}
member ConfigurationCmpInt : Ad7416TypeConfigurationCmpInt with get, set

Property Value

Type: Ad7416TypeConfigurationCmpInt
See Also

Reference

Ad7416 Class
telos.Ird.AnalogDevices Namespace


Ad7416.ConfigurationFaultQueue Property

IRD

Ad7416ConfigurationFaultQueue Property

Configuration (Fault Queue)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7416TypeConfigurationFaultQueue ConfigurationFaultQueue { get; set; }
Public Property ConfigurationFaultQueue As Ad7416TypeConfigurationFaultQueue
    Get
    Set
public:
property Ad7416TypeConfigurationFaultQueue ConfigurationFaultQueue {
    Ad7416TypeConfigurationFaultQueue get ();
    void set (Ad7416TypeConfigurationFaultQueue value);
}
member ConfigurationFaultQueue : Ad7416TypeConfigurationFaultQueue with get, set

Property Value

Type: Ad7416TypeConfigurationFaultQueue
See Also

Reference

Ad7416 Class
telos.Ird.AnalogDevices Namespace


Ad7416.ConfigurationOTIPolarity Property

IRD

Ad7416ConfigurationOTIPolarity Property

Configuration (OTI Polarity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7416TypeConfigurationOtiPolarity ConfigurationOTIPolarity { get; set; }
Public Property ConfigurationOTIPolarity As Ad7416TypeConfigurationOtiPolarity
    Get
    Set
public:
property Ad7416TypeConfigurationOtiPolarity ConfigurationOTIPolarity {
    Ad7416TypeConfigurationOtiPolarity get ();
    void set (Ad7416TypeConfigurationOtiPolarity value);
}
member ConfigurationOTIPolarity : Ad7416TypeConfigurationOtiPolarity with get, set

Property Value

Type: Ad7416TypeConfigurationOtiPolarity
See Also

Reference

Ad7416 Class
telos.Ird.AnalogDevices Namespace


Ad7416.ConfigurationShutdown Property

IRD

Ad7416ConfigurationShutdown Property

Configuration (Shutdown)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7416TypeConfigurationShutdown ConfigurationShutdown { get; set; }
Public Property ConfigurationShutdown As Ad7416TypeConfigurationShutdown
    Get
    Set
public:
property Ad7416TypeConfigurationShutdown ConfigurationShutdown {
    Ad7416TypeConfigurationShutdown get ();
    void set (Ad7416TypeConfigurationShutdown value);
}
member ConfigurationShutdown : Ad7416TypeConfigurationShutdown with get, set

Property Value

Type: Ad7416TypeConfigurationShutdown
See Also

Reference

Ad7416 Class
telos.Ird.AnalogDevices Namespace


Ad7416.Temperature Property

IRD

Ad7416Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Ad7416 Class
telos.Ird.AnalogDevices Namespace


Ad7416.THYST Property

IRD

Ad7416THYST Property

T_HYST (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double THYST { get; set; }
Public Property THYST As Double
    Get
    Set
public:
property double THYST {
    double get ();
    void set (double value);
}
member THYST : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7416 Class
telos.Ird.AnalogDevices Namespace


Ad7416.TOTI Property

IRD

Ad7416TOTI Property

T_OTI (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TOTI { get; set; }
Public Property TOTI As Double
    Get
    Set
public:
property double TOTI {
    double get ();
    void set (double value);
}
member TOTI : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7416 Class
telos.Ird.AnalogDevices Namespace


Ad7416 Methods

The Ad7416 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ad7416 Class
telos.Ird.AnalogDevices Namespace


Ad7416.Flush Method

IRD

Ad7416Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ad7416 Class
telos.Ird.AnalogDevices Namespace


Ad7416.TypeConfigurationCmpInt Enumeration

IRD

Ad7416TypeConfigurationCmpInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationCmpInt
Public Enumeration TypeConfigurationCmpInt
public enum class TypeConfigurationCmpInt
type TypeConfigurationCmpInt
Members
Member name | Value | Description
Comparator | 0 | Comparator
Interrupt | 1 | Interrupt
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7416.TypeConfigurationFaultQueue Enumeration

IRD

Ad7416TypeConfigurationFaultQueue Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationFaultQueue
Public Enumeration TypeConfigurationFaultQueue
public enum class TypeConfigurationFaultQueue
type TypeConfigurationFaultQueue
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_2 | 1 | 2
Value_4 | 2 | 4
Value_6 | 3 | 6
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7416.TypeConfigurationOtiPolarity Enumeration

IRD

Ad7416TypeConfigurationOtiPolarity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationOtiPolarity
Public Enumeration TypeConfigurationOtiPolarity
public enum class TypeConfigurationOtiPolarity
type TypeConfigurationOtiPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7416.TypeConfigurationShutdown Enumeration

IRD

Ad7416TypeConfigurationShutdown Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationShutdown
Public Enumeration TypeConfigurationShutdown
public enum class TypeConfigurationShutdown
type TypeConfigurationShutdown
Members
Member name | Value | Description
Normal | 0 | Normal
Shutdown | 1 | Shutdown
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7417 Class

Analog Devices: AD 7417
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAd7417

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ad7417
Public Class Ad7417
public ref class Ad7417
type Ad7417 =  class end

The Ad7417 type exposes the following members.

Constructors
 | Name | Description
Public method | Ad7417 | Constructor
Top
Properties
 | Name | Description
Public property | ADC | ADC (unit: VREF/1024)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationChannelSelection | Configuration (Channel Selection)
Public property | ConfigurationCmpInt | Configuration (Cmp/Int)
Public property | ConfigurationConversionMode | Configuration (Conversion Mode)
Public property | ConfigurationFaultQueue | Configuration (Fault Queue)
Public property | ConfigurationOTIPolarity | Configuration (OTI Polarity)
Public property | ConfigurationShutdown | Configuration (Shutdown)
Public property | ConfigurationTest1 | Configuration (Test 1)
Public property | Temperature | Temperature (unit: °C)
Public property | THYST | T_HYST (unit: °C)
Public property | TOTI | T_OTI (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
10-Bit Digital Temperature Sensor And Four Single-Channel ADCs
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7417 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7417(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ad7417(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ad7417

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ad7417 Class
telos.Ird.AnalogDevices Namespace


Ad7417 Properties

The Ad7417 type exposes the following members.

Properties
 | Name | Description
Public property | ADC | ADC (unit: VREF/1024)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationChannelSelection | Configuration (Channel Selection)
Public property | ConfigurationCmpInt | Configuration (Cmp/Int)
Public property | ConfigurationConversionMode | Configuration (Conversion Mode)
Public property | ConfigurationFaultQueue | Configuration (Fault Queue)
Public property | ConfigurationOTIPolarity | Configuration (OTI Polarity)
Public property | ConfigurationShutdown | Configuration (Shutdown)
Public property | ConfigurationTest1 | Configuration (Test 1)
Public property | Temperature | Temperature (unit: °C)
Public property | THYST | T_HYST (unit: °C)
Public property | TOTI | T_OTI (unit: °C)
Top
See Also

Reference

Ad7417 Class
telos.Ird.AnalogDevices Namespace


Ad7417.ADC Property

IRD

Ad7417ADC Property

ADC (unit: VREF/1024)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADC { get; }
Public ReadOnly Property ADC As UShort
    Get
public:
property unsigned short ADC {
    unsigned short get ();
}
member ADC : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Ad7417 Class
telos.Ird.AnalogDevices Namespace


Ad7417.AutoFlush Property

IRD

Ad7417AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ad7417 Class
telos.Ird.AnalogDevices Namespace


Ad7417.ConfigurationChannelSelection Property

IRD

Ad7417ConfigurationChannelSelection Property

Configuration (Channel Selection)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7417TypeConfigurationChannelSelection ConfigurationChannelSelection { get; set; }
Public Property ConfigurationChannelSelection As Ad7417TypeConfigurationChannelSelection
    Get
    Set
public:
property Ad7417TypeConfigurationChannelSelection ConfigurationChannelSelection {
    Ad7417TypeConfigurationChannelSelection get ();
    void set (Ad7417TypeConfigurationChannelSelection value);
}
member ConfigurationChannelSelection : Ad7417TypeConfigurationChannelSelection with get, set

Property Value

Type: Ad7417TypeConfigurationChannelSelection
See Also

Reference

Ad7417 Class
telos.Ird.AnalogDevices Namespace


Ad7417.ConfigurationCmpInt Property

IRD

Ad7417ConfigurationCmpInt Property

Configuration (Cmp/Int)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7417TypeConfigurationCmpInt ConfigurationCmpInt { get; set; }
Public Property ConfigurationCmpInt As Ad7417TypeConfigurationCmpInt
    Get
    Set
public:
property Ad7417TypeConfigurationCmpInt ConfigurationCmpInt {
    Ad7417TypeConfigurationCmpInt get ();
    void set (Ad7417TypeConfigurationCmpInt value);
}
member ConfigurationCmpInt : Ad7417TypeConfigurationCmpInt with get, set

Property Value

Type: Ad7417TypeConfigurationCmpInt
See Also

Reference

Ad7417 Class
telos.Ird.AnalogDevices Namespace


Ad7417.ConfigurationConversionMode Property

IRD

Ad7417ConfigurationConversionMode Property

Configuration (Conversion Mode)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7417TypeConfigurationConversionMode ConfigurationConversionMode { get; set; }
Public Property ConfigurationConversionMode As Ad7417TypeConfigurationConversionMode
    Get
    Set
public:
property Ad7417TypeConfigurationConversionMode ConfigurationConversionMode {
    Ad7417TypeConfigurationConversionMode get ();
    void set (Ad7417TypeConfigurationConversionMode value);
}
member ConfigurationConversionMode : Ad7417TypeConfigurationConversionMode with get, set

Property Value

Type: Ad7417TypeConfigurationConversionMode
See Also

Reference

Ad7417 Class
telos.Ird.AnalogDevices Namespace


Ad7417.ConfigurationFaultQueue Property

IRD

Ad7417ConfigurationFaultQueue Property

Configuration (Fault Queue)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7417TypeConfigurationFaultQueue ConfigurationFaultQueue { get; set; }
Public Property ConfigurationFaultQueue As Ad7417TypeConfigurationFaultQueue
    Get
    Set
public:
property Ad7417TypeConfigurationFaultQueue ConfigurationFaultQueue {
    Ad7417TypeConfigurationFaultQueue get ();
    void set (Ad7417TypeConfigurationFaultQueue value);
}
member ConfigurationFaultQueue : Ad7417TypeConfigurationFaultQueue with get, set

Property Value

Type: Ad7417TypeConfigurationFaultQueue
See Also

Reference

Ad7417 Class
telos.Ird.AnalogDevices Namespace


Ad7417.ConfigurationOTIPolarity Property

IRD

Ad7417ConfigurationOTIPolarity Property

Configuration (OTI Polarity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7417TypeConfigurationOtiPolarity ConfigurationOTIPolarity { get; set; }
Public Property ConfigurationOTIPolarity As Ad7417TypeConfigurationOtiPolarity
    Get
    Set
public:
property Ad7417TypeConfigurationOtiPolarity ConfigurationOTIPolarity {
    Ad7417TypeConfigurationOtiPolarity get ();
    void set (Ad7417TypeConfigurationOtiPolarity value);
}
member ConfigurationOTIPolarity : Ad7417TypeConfigurationOtiPolarity with get, set

Property Value

Type: Ad7417TypeConfigurationOtiPolarity
See Also

Reference

Ad7417 Class
telos.Ird.AnalogDevices Namespace


Ad7417.ConfigurationShutdown Property

IRD

Ad7417ConfigurationShutdown Property

Configuration (Shutdown)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7417TypeConfigurationShutdown ConfigurationShutdown { get; set; }
Public Property ConfigurationShutdown As Ad7417TypeConfigurationShutdown
    Get
    Set
public:
property Ad7417TypeConfigurationShutdown ConfigurationShutdown {
    Ad7417TypeConfigurationShutdown get ();
    void set (Ad7417TypeConfigurationShutdown value);
}
member ConfigurationShutdown : Ad7417TypeConfigurationShutdown with get, set

Property Value

Type: Ad7417TypeConfigurationShutdown
See Also

Reference

Ad7417 Class
telos.Ird.AnalogDevices Namespace


Ad7417.ConfigurationTest1 Property

IRD

Ad7417ConfigurationTest1 Property

Configuration (Test 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7417TypeConfigurationTest1 ConfigurationTest1 { get; set; }
Public Property ConfigurationTest1 As Ad7417TypeConfigurationTest1
    Get
    Set
public:
property Ad7417TypeConfigurationTest1 ConfigurationTest1 {
    Ad7417TypeConfigurationTest1 get ();
    void set (Ad7417TypeConfigurationTest1 value);
}
member ConfigurationTest1 : Ad7417TypeConfigurationTest1 with get, set

Property Value

Type: Ad7417TypeConfigurationTest1
See Also

Reference

Ad7417 Class
telos.Ird.AnalogDevices Namespace


Ad7417.Temperature Property

IRD

Ad7417Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Ad7417 Class
telos.Ird.AnalogDevices Namespace


Ad7417.THYST Property

IRD

Ad7417THYST Property

T_HYST (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double THYST { get; set; }
Public Property THYST As Double
    Get
    Set
public:
property double THYST {
    double get ();
    void set (double value);
}
member THYST : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7417 Class
telos.Ird.AnalogDevices Namespace


Ad7417.TOTI Property

IRD

Ad7417TOTI Property

T_OTI (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TOTI { get; set; }
Public Property TOTI As Double
    Get
    Set
public:
property double TOTI {
    double get ();
    void set (double value);
}
member TOTI : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7417 Class
telos.Ird.AnalogDevices Namespace


Ad7417 Methods

The Ad7417 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ad7417 Class
telos.Ird.AnalogDevices Namespace


Ad7417.Flush Method

IRD

Ad7417Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ad7417 Class
telos.Ird.AnalogDevices Namespace


Ad7417.TypeConfigurationChannelSelection Enumeration

IRD

Ad7417TypeConfigurationChannelSelection Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationChannelSelection
Public Enumeration TypeConfigurationChannelSelection
public enum class TypeConfigurationChannelSelection
type TypeConfigurationChannelSelection
Members
Member name | Value | Description
TemperatureSensor | 0 | Temperature Sensor
AIN1 | 1 | AIN1
AIN2 | 2 | AIN2
AIN3 | 3 | AIN3
AIN4 | 4 | AIN4
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7417.TypeConfigurationCmpInt Enumeration

IRD

Ad7417TypeConfigurationCmpInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationCmpInt
Public Enumeration TypeConfigurationCmpInt
public enum class TypeConfigurationCmpInt
type TypeConfigurationCmpInt
Members
Member name | Value | Description
Comparator | 0 | Comparator
Interrupt | 1 | Interrupt
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7417.TypeConfigurationConversionMode Enumeration

IRD

Ad7417TypeConfigurationConversionMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationConversionMode
Public Enumeration TypeConfigurationConversionMode
public enum class TypeConfigurationConversionMode
type TypeConfigurationConversionMode
Members
Member name | Value | Description
DefaultMode | 0 | Default Mode
CONVSTPinMode | 1 | CONVST Pin Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7417.TypeConfigurationFaultQueue Enumeration

IRD

Ad7417TypeConfigurationFaultQueue Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationFaultQueue
Public Enumeration TypeConfigurationFaultQueue
public enum class TypeConfigurationFaultQueue
type TypeConfigurationFaultQueue
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_2 | 1 | 2
Value_4 | 2 | 4
Value_6 | 3 | 6
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7417.TypeConfigurationOtiPolarity Enumeration

IRD

Ad7417TypeConfigurationOtiPolarity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationOtiPolarity
Public Enumeration TypeConfigurationOtiPolarity
public enum class TypeConfigurationOtiPolarity
type TypeConfigurationOtiPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7417.TypeConfigurationShutdown Enumeration

IRD

Ad7417TypeConfigurationShutdown Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationShutdown
Public Enumeration TypeConfigurationShutdown
public enum class TypeConfigurationShutdown
type TypeConfigurationShutdown
Members
Member name | Value | Description
Normal | 0 | Normal
Shutdown | 1 | Shutdown
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7417.TypeConfigurationTest1 Enumeration

IRD

Ad7417TypeConfigurationTest1 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationTest1
Public Enumeration TypeConfigurationTest1
public enum class TypeConfigurationTest1
type TypeConfigurationTest1
Members
Member name | Value | Description
I2CFiltersEnabled | 0 | I2C Filters: Enabled
I2CFiltersDisabled | 1 | I2C Filters: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7418 Class

Analog Devices: AD 7418
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAd7418

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ad7418
Public Class Ad7418
public ref class Ad7418
type Ad7418 =  class end

The Ad7418 type exposes the following members.

Constructors
 | Name | Description
Public method | Ad7418 | Constructor
Top
Properties
 | Name | Description
Public property | ADC | ADC (unit: VREF/1024)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationChannelSelection | Configuration (Channel Selection)
Public property | ConfigurationCmpInt | Configuration (Cmp/Int)
Public property | ConfigurationConversionMode | Configuration (Conversion Mode)
Public property | ConfigurationFaultQueue | Configuration (Fault Queue)
Public property | ConfigurationOTIPolarity | Configuration (OTI Polarity)
Public property | ConfigurationShutdown | Configuration (Shutdown)
Public property | ConfigurationTest1 | Configuration (Test 1)
Public property | Temperature | Temperature (unit: °C)
Public property | THYST | T_HYST (unit: °C)
Public property | TOTI | T_OTI (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
10-Bit Digital Temperature Sensor And Four Single-Channel ADCs
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7418 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7418(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ad7418(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ad7418

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ad7418 Class
telos.Ird.AnalogDevices Namespace


Ad7418 Properties

The Ad7418 type exposes the following members.

Properties
 | Name | Description
Public property | ADC | ADC (unit: VREF/1024)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationChannelSelection | Configuration (Channel Selection)
Public property | ConfigurationCmpInt | Configuration (Cmp/Int)
Public property | ConfigurationConversionMode | Configuration (Conversion Mode)
Public property | ConfigurationFaultQueue | Configuration (Fault Queue)
Public property | ConfigurationOTIPolarity | Configuration (OTI Polarity)
Public property | ConfigurationShutdown | Configuration (Shutdown)
Public property | ConfigurationTest1 | Configuration (Test 1)
Public property | Temperature | Temperature (unit: °C)
Public property | THYST | T_HYST (unit: °C)
Public property | TOTI | T_OTI (unit: °C)
Top
See Also

Reference

Ad7418 Class
telos.Ird.AnalogDevices Namespace


Ad7418.ADC Property

IRD

Ad7418ADC Property

ADC (unit: VREF/1024)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADC { get; }
Public ReadOnly Property ADC As UShort
    Get
public:
property unsigned short ADC {
    unsigned short get ();
}
member ADC : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Ad7418 Class
telos.Ird.AnalogDevices Namespace


Ad7418.AutoFlush Property

IRD

Ad7418AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ad7418 Class
telos.Ird.AnalogDevices Namespace


Ad7418.ConfigurationChannelSelection Property

IRD

Ad7418ConfigurationChannelSelection Property

Configuration (Channel Selection)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7418TypeConfigurationChannelSelection ConfigurationChannelSelection { get; set; }
Public Property ConfigurationChannelSelection As Ad7418TypeConfigurationChannelSelection
    Get
    Set
public:
property Ad7418TypeConfigurationChannelSelection ConfigurationChannelSelection {
    Ad7418TypeConfigurationChannelSelection get ();
    void set (Ad7418TypeConfigurationChannelSelection value);
}
member ConfigurationChannelSelection : Ad7418TypeConfigurationChannelSelection with get, set

Property Value

Type: Ad7418TypeConfigurationChannelSelection
See Also

Reference

Ad7418 Class
telos.Ird.AnalogDevices Namespace


Ad7418.ConfigurationCmpInt Property

IRD

Ad7418ConfigurationCmpInt Property

Configuration (Cmp/Int)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7418TypeConfigurationCmpInt ConfigurationCmpInt { get; set; }
Public Property ConfigurationCmpInt As Ad7418TypeConfigurationCmpInt
    Get
    Set
public:
property Ad7418TypeConfigurationCmpInt ConfigurationCmpInt {
    Ad7418TypeConfigurationCmpInt get ();
    void set (Ad7418TypeConfigurationCmpInt value);
}
member ConfigurationCmpInt : Ad7418TypeConfigurationCmpInt with get, set

Property Value

Type: Ad7418TypeConfigurationCmpInt
See Also

Reference

Ad7418 Class
telos.Ird.AnalogDevices Namespace


Ad7418.ConfigurationConversionMode Property

IRD

Ad7418ConfigurationConversionMode Property

Configuration (Conversion Mode)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7418TypeConfigurationConversionMode ConfigurationConversionMode { get; set; }
Public Property ConfigurationConversionMode As Ad7418TypeConfigurationConversionMode
    Get
    Set
public:
property Ad7418TypeConfigurationConversionMode ConfigurationConversionMode {
    Ad7418TypeConfigurationConversionMode get ();
    void set (Ad7418TypeConfigurationConversionMode value);
}
member ConfigurationConversionMode : Ad7418TypeConfigurationConversionMode with get, set

Property Value

Type: Ad7418TypeConfigurationConversionMode
See Also

Reference

Ad7418 Class
telos.Ird.AnalogDevices Namespace


Ad7418.ConfigurationFaultQueue Property

IRD

Ad7418ConfigurationFaultQueue Property

Configuration (Fault Queue)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7418TypeConfigurationFaultQueue ConfigurationFaultQueue { get; set; }
Public Property ConfigurationFaultQueue As Ad7418TypeConfigurationFaultQueue
    Get
    Set
public:
property Ad7418TypeConfigurationFaultQueue ConfigurationFaultQueue {
    Ad7418TypeConfigurationFaultQueue get ();
    void set (Ad7418TypeConfigurationFaultQueue value);
}
member ConfigurationFaultQueue : Ad7418TypeConfigurationFaultQueue with get, set

Property Value

Type: Ad7418TypeConfigurationFaultQueue
See Also

Reference

Ad7418 Class
telos.Ird.AnalogDevices Namespace


Ad7418.ConfigurationOTIPolarity Property

IRD

Ad7418ConfigurationOTIPolarity Property

Configuration (OTI Polarity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7418TypeConfigurationOtiPolarity ConfigurationOTIPolarity { get; set; }
Public Property ConfigurationOTIPolarity As Ad7418TypeConfigurationOtiPolarity
    Get
    Set
public:
property Ad7418TypeConfigurationOtiPolarity ConfigurationOTIPolarity {
    Ad7418TypeConfigurationOtiPolarity get ();
    void set (Ad7418TypeConfigurationOtiPolarity value);
}
member ConfigurationOTIPolarity : Ad7418TypeConfigurationOtiPolarity with get, set

Property Value

Type: Ad7418TypeConfigurationOtiPolarity
See Also

Reference

Ad7418 Class
telos.Ird.AnalogDevices Namespace


Ad7418.ConfigurationShutdown Property

IRD

Ad7418ConfigurationShutdown Property

Configuration (Shutdown)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7418TypeConfigurationShutdown ConfigurationShutdown { get; set; }
Public Property ConfigurationShutdown As Ad7418TypeConfigurationShutdown
    Get
    Set
public:
property Ad7418TypeConfigurationShutdown ConfigurationShutdown {
    Ad7418TypeConfigurationShutdown get ();
    void set (Ad7418TypeConfigurationShutdown value);
}
member ConfigurationShutdown : Ad7418TypeConfigurationShutdown with get, set

Property Value

Type: Ad7418TypeConfigurationShutdown
See Also

Reference

Ad7418 Class
telos.Ird.AnalogDevices Namespace


Ad7418.ConfigurationTest1 Property

IRD

Ad7418ConfigurationTest1 Property

Configuration (Test 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad7418TypeConfigurationTest1 ConfigurationTest1 { get; set; }
Public Property ConfigurationTest1 As Ad7418TypeConfigurationTest1
    Get
    Set
public:
property Ad7418TypeConfigurationTest1 ConfigurationTest1 {
    Ad7418TypeConfigurationTest1 get ();
    void set (Ad7418TypeConfigurationTest1 value);
}
member ConfigurationTest1 : Ad7418TypeConfigurationTest1 with get, set

Property Value

Type: Ad7418TypeConfigurationTest1
See Also

Reference

Ad7418 Class
telos.Ird.AnalogDevices Namespace


Ad7418.Temperature Property

IRD

Ad7418Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Ad7418 Class
telos.Ird.AnalogDevices Namespace


Ad7418.THYST Property

IRD

Ad7418THYST Property

T_HYST (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double THYST { get; set; }
Public Property THYST As Double
    Get
    Set
public:
property double THYST {
    double get ();
    void set (double value);
}
member THYST : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7418 Class
telos.Ird.AnalogDevices Namespace


Ad7418.TOTI Property

IRD

Ad7418TOTI Property

T_OTI (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TOTI { get; set; }
Public Property TOTI As Double
    Get
    Set
public:
property double TOTI {
    double get ();
    void set (double value);
}
member TOTI : float with get, set

Property Value

Type: Double
See Also

Reference

Ad7418 Class
telos.Ird.AnalogDevices Namespace


Ad7418 Methods

The Ad7418 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ad7418 Class
telos.Ird.AnalogDevices Namespace


Ad7418.Flush Method

IRD

Ad7418Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ad7418 Class
telos.Ird.AnalogDevices Namespace


Ad7418.TypeConfigurationChannelSelection Enumeration

IRD

Ad7418TypeConfigurationChannelSelection Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationChannelSelection
Public Enumeration TypeConfigurationChannelSelection
public enum class TypeConfigurationChannelSelection
type TypeConfigurationChannelSelection
Members
Member name | Value | Description
TemperatureSensor | 0 | Temperature Sensor
AIN | 1 | AIN
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7418.TypeConfigurationCmpInt Enumeration

IRD

Ad7418TypeConfigurationCmpInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationCmpInt
Public Enumeration TypeConfigurationCmpInt
public enum class TypeConfigurationCmpInt
type TypeConfigurationCmpInt
Members
Member name | Value | Description
Comparator | 0 | Comparator
Interrupt | 1 | Interrupt
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7418.TypeConfigurationConversionMode Enumeration

IRD

Ad7418TypeConfigurationConversionMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationConversionMode
Public Enumeration TypeConfigurationConversionMode
public enum class TypeConfigurationConversionMode
type TypeConfigurationConversionMode
Members
Member name | Value | Description
DefaultMode | 0 | Default Mode
CONVSTPinMode | 1 | CONVST Pin Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7418.TypeConfigurationFaultQueue Enumeration

IRD

Ad7418TypeConfigurationFaultQueue Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationFaultQueue
Public Enumeration TypeConfigurationFaultQueue
public enum class TypeConfigurationFaultQueue
type TypeConfigurationFaultQueue
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_2 | 1 | 2
Value_4 | 2 | 4
Value_6 | 3 | 6
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7418.TypeConfigurationOtiPolarity Enumeration

IRD

Ad7418TypeConfigurationOtiPolarity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationOtiPolarity
Public Enumeration TypeConfigurationOtiPolarity
public enum class TypeConfigurationOtiPolarity
type TypeConfigurationOtiPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7418.TypeConfigurationShutdown Enumeration

IRD

Ad7418TypeConfigurationShutdown Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationShutdown
Public Enumeration TypeConfigurationShutdown
public enum class TypeConfigurationShutdown
type TypeConfigurationShutdown
Members
Member name | Value | Description
Normal | 0 | Normal
Shutdown | 1 | Shutdown
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad7418.TypeConfigurationTest1 Enumeration

IRD

Ad7418TypeConfigurationTest1 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationTest1
Public Enumeration TypeConfigurationTest1
public enum class TypeConfigurationTest1
type TypeConfigurationTest1
Members
Member name | Value | Description
I2CFiltersEnabled | 0 | I2C Filters: Enabled
I2CFiltersDisabled | 1 | I2C Filters: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad78797889 Class

Analog Devices: AD 7879 - 1 / AD 7889 - 1
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAd78797889

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ad78797889
Public Class Ad78797889
public ref class Ad78797889
type Ad78797889 =  class end

The Ad78797889 type exposes the following members.

Constructors
 | Name | Description
Public method | Ad78797889 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AUXVBAT | AUX/VBAT
Public property | AUXVBATHighLimit | AUX/VBAT High Limit
Public property | AUXVBATLowLimit | AUX/VBAT Low Limit
Public property | ControlACQ | Control (ACQ)
Public property | ControlADCMODE | Control (ADC MODE)
Public property | ControlAUX | Control (AUX)
Public property | ControlAUXVBATHIGH | Control (AUX/VBAT HIGH)
Public property | ControlAUXVBATLOW | Control (AUX/VBAT LOW)
Public property | ControlAUXVBATMASK | Control (AUX/VBAT MASK)
Public property | ControlAVG | Control (AVG)
Public property | ControlCHNLADD | Control (CHNL ADD)
Public property | ControlDisablePENIRQ | Control (Disable PENIRQ)
Public property | ControlFCD | Control (FCD) (unit: µs)
Public property | ControlGPIOALERT | Control (GPIO ALERT)
Public property | ControlGPIODAT | Control (GPIO DAT)
Public property | ControlGPIODIR | Control (GPIO DIR)
Public property | ControlGPIOEN | Control (GPIO EN)
Public property | ControlGPIOPOL | Control (GPIO POL)
Public property | ControlINTMODE | Control (INT MODE)
Public property | ControlMED | Control (MED)
Public property | ControlPM | Control (PM)
Public property | ControlSERDFR | Control (SER/DFR)
Public property | ControlSWRST | Control (SW/RST)
Public property | ControlTEMP | Control (TEMP)
Public property | ControlTEMPHIGH | Control (TEMP HIGH)
Public property | ControlTEMPLOW | Control (TEMP LOW)
Public property | ControlTEMPMASK | Control (TEMP MASK)
Public property | ControlTMR | Control (TMR) (unit: µs)
Public property | ControlVBAT | Control (VBAT)
Public property | ControlX | Control (X+)
Public property | ControlY | Control (Y+)
Public property | ControlZ1 | Control (Z1)
Public property | ControlZ2 | Control (Z2)
Public property | DeviceID | Device ID
Public property | Revision | Revision
Public property | TEMP | TEMP
Public property | TEMPHighLimit | TEMP High Limit
Public property | TEMPLowLimit | TEMP Low Limit
Public property | X | X+
Public property | XZ1 | X+ (Z1)
Public property | Y | Y+
Public property | YZ2 | Y- (Z2)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low Voltage Controller for Touch Screens
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad78797889 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ad78797889(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ad78797889

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889 Properties

The Ad78797889 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AUXVBAT | AUX/VBAT
Public property | AUXVBATHighLimit | AUX/VBAT High Limit
Public property | AUXVBATLowLimit | AUX/VBAT Low Limit
Public property | ControlACQ | Control (ACQ)
Public property | ControlADCMODE | Control (ADC MODE)
Public property | ControlAUX | Control (AUX)
Public property | ControlAUXVBATHIGH | Control (AUX/VBAT HIGH)
Public property | ControlAUXVBATLOW | Control (AUX/VBAT LOW)
Public property | ControlAUXVBATMASK | Control (AUX/VBAT MASK)
Public property | ControlAVG | Control (AVG)
Public property | ControlCHNLADD | Control (CHNL ADD)
Public property | ControlDisablePENIRQ | Control (Disable PENIRQ)
Public property | ControlFCD | Control (FCD) (unit: µs)
Public property | ControlGPIOALERT | Control (GPIO ALERT)
Public property | ControlGPIODAT | Control (GPIO DAT)
Public property | ControlGPIODIR | Control (GPIO DIR)
Public property | ControlGPIOEN | Control (GPIO EN)
Public property | ControlGPIOPOL | Control (GPIO POL)
Public property | ControlINTMODE | Control (INT MODE)
Public property | ControlMED | Control (MED)
Public property | ControlPM | Control (PM)
Public property | ControlSERDFR | Control (SER/DFR)
Public property | ControlSWRST | Control (SW/RST)
Public property | ControlTEMP | Control (TEMP)
Public property | ControlTEMPHIGH | Control (TEMP HIGH)
Public property | ControlTEMPLOW | Control (TEMP LOW)
Public property | ControlTEMPMASK | Control (TEMP MASK)
Public property | ControlTMR | Control (TMR) (unit: µs)
Public property | ControlVBAT | Control (VBAT)
Public property | ControlX | Control (X+)
Public property | ControlY | Control (Y+)
Public property | ControlZ1 | Control (Z1)
Public property | ControlZ2 | Control (Z2)
Public property | DeviceID | Device ID
Public property | Revision | Revision
Public property | TEMP | TEMP
Public property | TEMPHighLimit | TEMP High Limit
Public property | TEMPLowLimit | TEMP Low Limit
Public property | X | X+
Public property | XZ1 | X+ (Z1)
Public property | Y | Y+
Public property | YZ2 | Y- (Z2)
Top
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.AutoFlush Property

IRD

Ad78797889AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.AUXVBAT Property

IRD

Ad78797889AUXVBAT Property

AUX/VBAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AUXVBAT { get; }
Public ReadOnly Property AUXVBAT As UShort
    Get
public:
property unsigned short AUXVBAT {
    unsigned short get ();
}
member AUXVBAT : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.AUXVBATHighLimit Property

IRD

Ad78797889AUXVBATHighLimit Property

AUX/VBAT High Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AUXVBATHighLimit { get; set; }
Public Property AUXVBATHighLimit As UShort
    Get
    Set
public:
property unsigned short AUXVBATHighLimit {
    unsigned short get ();
    void set (unsigned short value);
}
member AUXVBATHighLimit : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.AUXVBATLowLimit Property

IRD

Ad78797889AUXVBATLowLimit Property

AUX/VBAT Low Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AUXVBATLowLimit { get; set; }
Public Property AUXVBATLowLimit As UShort
    Get
    Set
public:
property unsigned short AUXVBATLowLimit {
    unsigned short get ();
    void set (unsigned short value);
}
member AUXVBATLowLimit : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlACQ Property

IRD

Ad78797889ControlACQ Property

Control (ACQ)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control1Acq ControlACQ { get; set; }
Public Property ControlACQ As Ad78797889Control1Acq
    Get
    Set
public:
property Ad78797889Control1Acq ControlACQ {
    Ad78797889Control1Acq get ();
    void set (Ad78797889Control1Acq value);
}
member ControlACQ : Ad78797889Control1Acq with get, set

Property Value

Type: Ad78797889Control1Acq
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlADCMODE Property

IRD

Ad78797889ControlADCMODE Property

Control (ADC MODE)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control1AdcMode ControlADCMODE { get; set; }
Public Property ControlADCMODE As Ad78797889Control1AdcMode
    Get
    Set
public:
property Ad78797889Control1AdcMode ControlADCMODE {
    Ad78797889Control1AdcMode get ();
    void set (Ad78797889Control1AdcMode value);
}
member ControlADCMODE : Ad78797889Control1AdcMode with get, set

Property Value

Type: Ad78797889Control1AdcMode
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlAUX Property

IRD

Ad78797889ControlAUX Property

Control (AUX)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control3Sequencer ControlAUX { get; set; }
Public Property ControlAUX As Ad78797889Control3Sequencer
    Get
    Set
public:
property Ad78797889Control3Sequencer ControlAUX {
    Ad78797889Control3Sequencer get ();
    void set (Ad78797889Control3Sequencer value);
}
member ControlAUX : Ad78797889Control3Sequencer with get, set

Property Value

Type: Ad78797889Control3Sequencer
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlAUXVBATHIGH Property

IRD

Ad78797889ControlAUXVBATHIGH Property

Control (AUX/VBAT HIGH)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control3Mask ControlAUXVBATHIGH { get; set; }
Public Property ControlAUXVBATHIGH As Ad78797889Control3Mask
    Get
    Set
public:
property Ad78797889Control3Mask ControlAUXVBATHIGH {
    Ad78797889Control3Mask get ();
    void set (Ad78797889Control3Mask value);
}
member ControlAUXVBATHIGH : Ad78797889Control3Mask with get, set

Property Value

Type: Ad78797889Control3Mask
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlAUXVBATLOW Property

IRD

Ad78797889ControlAUXVBATLOW Property

Control (AUX/VBAT LOW)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control3Mask ControlAUXVBATLOW { get; set; }
Public Property ControlAUXVBATLOW As Ad78797889Control3Mask
    Get
    Set
public:
property Ad78797889Control3Mask ControlAUXVBATLOW {
    Ad78797889Control3Mask get ();
    void set (Ad78797889Control3Mask value);
}
member ControlAUXVBATLOW : Ad78797889Control3Mask with get, set

Property Value

Type: Ad78797889Control3Mask
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlAUXVBATMASK Property

IRD

Ad78797889ControlAUXVBATMASK Property

Control (AUX/VBAT MASK)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control3Mask ControlAUXVBATMASK { get; set; }
Public Property ControlAUXVBATMASK As Ad78797889Control3Mask
    Get
    Set
public:
property Ad78797889Control3Mask ControlAUXVBATMASK {
    Ad78797889Control3Mask get ();
    void set (Ad78797889Control3Mask value);
}
member ControlAUXVBATMASK : Ad78797889Control3Mask with get, set

Property Value

Type: Ad78797889Control3Mask
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlAVG Property

IRD

Ad78797889ControlAVG Property

Control (AVG)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control2Avg ControlAVG { get; set; }
Public Property ControlAVG As Ad78797889Control2Avg
    Get
    Set
public:
property Ad78797889Control2Avg ControlAVG {
    Ad78797889Control2Avg get ();
    void set (Ad78797889Control2Avg value);
}
member ControlAVG : Ad78797889Control2Avg with get, set

Property Value

Type: Ad78797889Control2Avg
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlCHNLADD Property

IRD

Ad78797889ControlCHNLADD Property

Control (CHNL ADD)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control1ChnlAdd ControlCHNLADD { get; set; }
Public Property ControlCHNLADD As Ad78797889Control1ChnlAdd
    Get
    Set
public:
property Ad78797889Control1ChnlAdd ControlCHNLADD {
    Ad78797889Control1ChnlAdd get ();
    void set (Ad78797889Control1ChnlAdd value);
}
member ControlCHNLADD : Ad78797889Control1ChnlAdd with get, set

Property Value

Type: Ad78797889Control1ChnlAdd
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlDisablePENIRQ Property

IRD

Ad78797889ControlDisablePENIRQ Property

Control (Disable PENIRQ)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control1DisablePenirq ControlDisablePENIRQ { get; set; }
Public Property ControlDisablePENIRQ As Ad78797889Control1DisablePenirq
    Get
    Set
public:
property Ad78797889Control1DisablePenirq ControlDisablePENIRQ {
    Ad78797889Control1DisablePenirq get ();
    void set (Ad78797889Control1DisablePenirq value);
}
member ControlDisablePENIRQ : Ad78797889Control1DisablePenirq with get, set

Property Value

Type: Ad78797889Control1DisablePenirq
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlFCD Property

IRD

Ad78797889ControlFCD Property

Control (FCD) (unit: µs)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control2Fcd ControlFCD { get; set; }
Public Property ControlFCD As Ad78797889Control2Fcd
    Get
    Set
public:
property Ad78797889Control2Fcd ControlFCD {
    Ad78797889Control2Fcd get ();
    void set (Ad78797889Control2Fcd value);
}
member ControlFCD : Ad78797889Control2Fcd with get, set

Property Value

Type: Ad78797889Control2Fcd
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlGPIOALERT Property

IRD

Ad78797889ControlGPIOALERT Property

Control (GPIO ALERT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control3Mask ControlGPIOALERT { get; set; }
Public Property ControlGPIOALERT As Ad78797889Control3Mask
    Get
    Set
public:
property Ad78797889Control3Mask ControlGPIOALERT {
    Ad78797889Control3Mask get ();
    void set (Ad78797889Control3Mask value);
}
member ControlGPIOALERT : Ad78797889Control3Mask with get, set

Property Value

Type: Ad78797889Control3Mask
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlGPIODAT Property

IRD

Ad78797889ControlGPIODAT Property

Control (GPIO DAT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ControlGPIODAT { get; set; }
Public Property ControlGPIODAT As Byte
    Get
    Set
public:
property unsigned char ControlGPIODAT {
    unsigned char get ();
    void set (unsigned char value);
}
member ControlGPIODAT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlGPIODIR Property

IRD

Ad78797889ControlGPIODIR Property

Control (GPIO DIR)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control2GpioDir ControlGPIODIR { get; set; }
Public Property ControlGPIODIR As Ad78797889Control2GpioDir
    Get
    Set
public:
property Ad78797889Control2GpioDir ControlGPIODIR {
    Ad78797889Control2GpioDir get ();
    void set (Ad78797889Control2GpioDir value);
}
member ControlGPIODIR : Ad78797889Control2GpioDir with get, set

Property Value

Type: Ad78797889Control2GpioDir
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlGPIOEN Property

IRD

Ad78797889ControlGPIOEN Property

Control (GPIO EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control2GpioEn ControlGPIOEN { get; set; }
Public Property ControlGPIOEN As Ad78797889Control2GpioEn
    Get
    Set
public:
property Ad78797889Control2GpioEn ControlGPIOEN {
    Ad78797889Control2GpioEn get ();
    void set (Ad78797889Control2GpioEn value);
}
member ControlGPIOEN : Ad78797889Control2GpioEn with get, set

Property Value

Type: Ad78797889Control2GpioEn
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlGPIOPOL Property

IRD

Ad78797889ControlGPIOPOL Property

Control (GPIO POL)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control2GpioPol ControlGPIOPOL { get; set; }
Public Property ControlGPIOPOL As Ad78797889Control2GpioPol
    Get
    Set
public:
property Ad78797889Control2GpioPol ControlGPIOPOL {
    Ad78797889Control2GpioPol get ();
    void set (Ad78797889Control2GpioPol value);
}
member ControlGPIOPOL : Ad78797889Control2GpioPol with get, set

Property Value

Type: Ad78797889Control2GpioPol
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlINTMODE Property

IRD

Ad78797889ControlINTMODE Property

Control (INT MODE)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control3IntMode ControlINTMODE { get; set; }
Public Property ControlINTMODE As Ad78797889Control3IntMode
    Get
    Set
public:
property Ad78797889Control3IntMode ControlINTMODE {
    Ad78797889Control3IntMode get ();
    void set (Ad78797889Control3IntMode value);
}
member ControlINTMODE : Ad78797889Control3IntMode with get, set

Property Value

Type: Ad78797889Control3IntMode
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlMED Property

IRD

Ad78797889ControlMED Property

Control (MED)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control2Med ControlMED { get; set; }
Public Property ControlMED As Ad78797889Control2Med
    Get
    Set
public:
property Ad78797889Control2Med ControlMED {
    Ad78797889Control2Med get ();
    void set (Ad78797889Control2Med value);
}
member ControlMED : Ad78797889Control2Med with get, set

Property Value

Type: Ad78797889Control2Med
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlPM Property

IRD

Ad78797889ControlPM Property

Control (PM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control2Pm ControlPM { get; set; }
Public Property ControlPM As Ad78797889Control2Pm
    Get
    Set
public:
property Ad78797889Control2Pm ControlPM {
    Ad78797889Control2Pm get ();
    void set (Ad78797889Control2Pm value);
}
member ControlPM : Ad78797889Control2Pm with get, set

Property Value

Type: Ad78797889Control2Pm
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlSERDFR Property

IRD

Ad78797889ControlSERDFR Property

Control (SER/DFR)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control2SerDfr ControlSERDFR { get; set; }
Public Property ControlSERDFR As Ad78797889Control2SerDfr
    Get
    Set
public:
property Ad78797889Control2SerDfr ControlSERDFR {
    Ad78797889Control2SerDfr get ();
    void set (Ad78797889Control2SerDfr value);
}
member ControlSERDFR : Ad78797889Control2SerDfr with get, set

Property Value

Type: Ad78797889Control2SerDfr
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlSWRST Property

IRD

Ad78797889ControlSWRST Property

Control (SW/RST)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control2SwRst ControlSWRST { get; set; }
Public Property ControlSWRST As Ad78797889Control2SwRst
    Get
    Set
public:
property Ad78797889Control2SwRst ControlSWRST {
    Ad78797889Control2SwRst get ();
    void set (Ad78797889Control2SwRst value);
}
member ControlSWRST : Ad78797889Control2SwRst with get, set

Property Value

Type: Ad78797889Control2SwRst
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlTEMP Property

IRD

Ad78797889ControlTEMP Property

Control (TEMP)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control3Sequencer ControlTEMP { get; set; }
Public Property ControlTEMP As Ad78797889Control3Sequencer
    Get
    Set
public:
property Ad78797889Control3Sequencer ControlTEMP {
    Ad78797889Control3Sequencer get ();
    void set (Ad78797889Control3Sequencer value);
}
member ControlTEMP : Ad78797889Control3Sequencer with get, set

Property Value

Type: Ad78797889Control3Sequencer
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlTEMPHIGH Property

IRD

Ad78797889ControlTEMPHIGH Property

Control (TEMP HIGH)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control3Mask ControlTEMPHIGH { get; set; }
Public Property ControlTEMPHIGH As Ad78797889Control3Mask
    Get
    Set
public:
property Ad78797889Control3Mask ControlTEMPHIGH {
    Ad78797889Control3Mask get ();
    void set (Ad78797889Control3Mask value);
}
member ControlTEMPHIGH : Ad78797889Control3Mask with get, set

Property Value

Type: Ad78797889Control3Mask
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlTEMPLOW Property

IRD

Ad78797889ControlTEMPLOW Property

Control (TEMP LOW)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control3Mask ControlTEMPLOW { get; set; }
Public Property ControlTEMPLOW As Ad78797889Control3Mask
    Get
    Set
public:
property Ad78797889Control3Mask ControlTEMPLOW {
    Ad78797889Control3Mask get ();
    void set (Ad78797889Control3Mask value);
}
member ControlTEMPLOW : Ad78797889Control3Mask with get, set

Property Value

Type: Ad78797889Control3Mask
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlTEMPMASK Property

IRD

Ad78797889ControlTEMPMASK Property

Control (TEMP MASK)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control3Mask ControlTEMPMASK { get; set; }
Public Property ControlTEMPMASK As Ad78797889Control3Mask
    Get
    Set
public:
property Ad78797889Control3Mask ControlTEMPMASK {
    Ad78797889Control3Mask get ();
    void set (Ad78797889Control3Mask value);
}
member ControlTEMPMASK : Ad78797889Control3Mask with get, set

Property Value

Type: Ad78797889Control3Mask
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlTMR Property

IRD

Ad78797889ControlTMR Property

Control (TMR) (unit: µs)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control1Tmr ControlTMR { get; set; }
Public Property ControlTMR As Ad78797889Control1Tmr
    Get
    Set
public:
property Ad78797889Control1Tmr ControlTMR {
    Ad78797889Control1Tmr get ();
    void set (Ad78797889Control1Tmr value);
}
member ControlTMR : Ad78797889Control1Tmr with get, set

Property Value

Type: Ad78797889Control1Tmr
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlVBAT Property

IRD

Ad78797889ControlVBAT Property

Control (VBAT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control3Sequencer ControlVBAT { get; set; }
Public Property ControlVBAT As Ad78797889Control3Sequencer
    Get
    Set
public:
property Ad78797889Control3Sequencer ControlVBAT {
    Ad78797889Control3Sequencer get ();
    void set (Ad78797889Control3Sequencer value);
}
member ControlVBAT : Ad78797889Control3Sequencer with get, set

Property Value

Type: Ad78797889Control3Sequencer
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlX Property

IRD

Ad78797889ControlX Property

Control (X+)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control3Sequencer ControlX { get; set; }
Public Property ControlX As Ad78797889Control3Sequencer
    Get
    Set
public:
property Ad78797889Control3Sequencer ControlX {
    Ad78797889Control3Sequencer get ();
    void set (Ad78797889Control3Sequencer value);
}
member ControlX : Ad78797889Control3Sequencer with get, set

Property Value

Type: Ad78797889Control3Sequencer
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlY Property

IRD

Ad78797889ControlY Property

Control (Y+)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control3Sequencer ControlY { get; set; }
Public Property ControlY As Ad78797889Control3Sequencer
    Get
    Set
public:
property Ad78797889Control3Sequencer ControlY {
    Ad78797889Control3Sequencer get ();
    void set (Ad78797889Control3Sequencer value);
}
member ControlY : Ad78797889Control3Sequencer with get, set

Property Value

Type: Ad78797889Control3Sequencer
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlZ1 Property

IRD

Ad78797889ControlZ1 Property

Control (Z1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control3Sequencer ControlZ1 { get; set; }
Public Property ControlZ1 As Ad78797889Control3Sequencer
    Get
    Set
public:
property Ad78797889Control3Sequencer ControlZ1 {
    Ad78797889Control3Sequencer get ();
    void set (Ad78797889Control3Sequencer value);
}
member ControlZ1 : Ad78797889Control3Sequencer with get, set

Property Value

Type: Ad78797889Control3Sequencer
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.ControlZ2 Property

IRD

Ad78797889ControlZ2 Property

Control (Z2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ad78797889Control3Sequencer ControlZ2 { get; set; }
Public Property ControlZ2 As Ad78797889Control3Sequencer
    Get
    Set
public:
property Ad78797889Control3Sequencer ControlZ2 {
    Ad78797889Control3Sequencer get ();
    void set (Ad78797889Control3Sequencer value);
}
member ControlZ2 : Ad78797889Control3Sequencer with get, set

Property Value

Type: Ad78797889Control3Sequencer
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.DeviceID Property

IRD

Ad78797889DeviceID Property

Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.Revision Property

IRD

Ad78797889Revision Property

Revision

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Revision { get; }
Public ReadOnly Property Revision As Byte
    Get
public:
property unsigned char Revision {
    unsigned char get ();
}
member Revision : byte with get

Property Value

Type: Byte
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.TEMP Property

IRD

Ad78797889TEMP Property

TEMP

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TEMP { get; }
Public ReadOnly Property TEMP As UShort
    Get
public:
property unsigned short TEMP {
    unsigned short get ();
}
member TEMP : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.TEMPHighLimit Property

IRD

Ad78797889TEMPHighLimit Property

TEMP High Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TEMPHighLimit { get; set; }
Public Property TEMPHighLimit As UShort
    Get
    Set
public:
property unsigned short TEMPHighLimit {
    unsigned short get ();
    void set (unsigned short value);
}
member TEMPHighLimit : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.TEMPLowLimit Property

IRD

Ad78797889TEMPLowLimit Property

TEMP Low Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TEMPLowLimit { get; set; }
Public Property TEMPLowLimit As UShort
    Get
    Set
public:
property unsigned short TEMPLowLimit {
    unsigned short get ();
    void set (unsigned short value);
}
member TEMPLowLimit : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.X Property

IRD

Ad78797889X Property

X+

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort X { get; }
Public ReadOnly Property X As UShort
    Get
public:
property unsigned short X {
    unsigned short get ();
}
member X : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.XZ1 Property

IRD

Ad78797889XZ1 Property

X+ (Z1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort XZ1 { get; }
Public ReadOnly Property XZ1 As UShort
    Get
public:
property unsigned short XZ1 {
    unsigned short get ();
}
member XZ1 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.Y Property

IRD

Ad78797889Y Property

Y+

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort Y { get; }
Public ReadOnly Property Y As UShort
    Get
public:
property unsigned short Y {
    unsigned short get ();
}
member Y : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.YZ2 Property

IRD

Ad78797889YZ2 Property

Y- (Z2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort YZ2 { get; }
Public ReadOnly Property YZ2 As UShort
    Get
public:
property unsigned short YZ2 {
    unsigned short get ();
}
member YZ2 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889 Methods

The Ad78797889 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.Flush Method

IRD

Ad78797889Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ad78797889 Class
telos.Ird.AnalogDevices Namespace


Ad78797889.Control1Acq Enumeration

IRD

Ad78797889Control1Acq Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Control1Acq
Public Enumeration Control1Acq
public enum class Control1Acq
type Control1Acq
Members
Member name | Value | Description
Value_4ClockPeriods2Us | 0 | 4 Clock Periods (2 µs)
Value_8ClockPeriods4Us | 1 | 8 Clock Periods (4 µs)
Value_16ClockPeriods8Us | 2 | 16 Clock Periods (8 µs)
Value_32ClockPeriods16Us | 3 | 32 Clock Periods (16 µs)
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad78797889.Control1AdcMode Enumeration

IRD

Ad78797889Control1AdcMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Control1AdcMode
Public Enumeration Control1AdcMode
public enum class Control1AdcMode
type Control1AdcMode
Members
Member name | Value | Description
NoConversion | 0 | No Conversion
SingleConversion | 1 | Single Conversion
ConversionSequenceSlaveMode | 2 | Conversion Sequence (Slave Mode)
ConversionSequenceMasterMode | 3 | Conversion Sequence (Master Mode)
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad78797889.Control1ChnlAdd Enumeration

IRD

Ad78797889Control1ChnlAdd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Control1ChnlAdd
Public Enumeration Control1ChnlAdd
public enum class Control1ChnlAdd
type Control1ChnlAdd
Members
Member name | Value | Description
Reserved | 0 | Reserved
TemperatureMeasurement | 1 | Temperature Measurement
VBATInput | 2 | VBAT Input
AUXInput | 3 | AUX Input
YZ2Input | 4 | Y- (Z2) Input
XZ1Input | 5 | X+ (Z1) Input
YInput | 6 | Y+ Input
XInput | 7 | X+ Input
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad78797889.Control1DisablePenirq Enumeration

IRD

Ad78797889Control1DisablePenirq Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Control1DisablePenirq
Public Enumeration Control1DisablePenirq
public enum class Control1DisablePenirq
type Control1DisablePenirq
Members
Member name | Value | Description
PENIRQEnabled | 0 | PENIRQ: Enabled
PENIRQDisabledINTEnabled | 1 | PENIRQ: Disabled / INT: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad78797889.Control1Tmr Enumeration

IRD

Ad78797889Control1Tmr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Control1Tmr
Public Enumeration Control1Tmr
public enum class Control1Tmr
type Control1Tmr
Members
Member name | Value | Description
OneTimeOnly | 0 | One Time Only
Value_550 | 1 | 550
Value_585 | 2 | 585
Value_620 | 3 | 620
Value_655 | 4 | 655
Value_690 | 5 | 690
Value_725 | 6 | 725
Value_760 | 7 | 760
Value_795 | 8 | 795
Value_830 | 9 | 830
Value_865 | 10 | 865
Value_900 | 11 | 900
Value_935 | 12 | 935
Value_970 | 13 | 970
Value_1005 | 14 | 1005
Value_1040 | 15 | 1040
Value_1075 | 16 | 1075
Value_1110 | 17 | 1110
Value_1145 | 18 | 1145
Value_1180 | 19 | 1180
Value_1215 | 20 | 1215
Value_1250 | 21 | 1250
Value_1285 | 22 | 1285
Value_1320 | 23 | 1320
Value_1355 | 24 | 1355
Value_1390 | 25 | 1390
Value_1425 | 26 | 1425
Value_1460 | 27 | 1460
Value_1495 | 28 | 1495
Value_1530 | 29 | 1530
Value_1565 | 30 | 1565
Value_1600 | 31 | 1600
Value_1635 | 32 | 1635
Value_1670 | 33 | 1670
Value_1705 | 34 | 1705
Value_1740 | 35 | 1740
Value_1775 | 36 | 1775
Value_1810 | 37 | 1810
Value_1845 | 38 | 1845
Value_1880 | 39 | 1880
Value_1915 | 40 | 1915
Value_1950 | 41 | 1950
Value_1985 | 42 | 1985
Value_2020 | 43 | 2020
Value_2055 | 44 | 2055
Value_2090 | 45 | 2090
Value_2125 | 46 | 2125
Value_2160 | 47 | 2160
Value_2195 | 48 | 2195
Value_2230 | 49 | 2230
Value_2265 | 50 | 2265
Value_2300 | 51 | 2300
Value_2335 | 52 | 2335
Value_2370 | 53 | 2370
Value_2405 | 54 | 2405
Value_2440 | 55 | 2440
Value_2475 | 56 | 2475
Value_2510 | 57 | 2510
Value_2545 | 58 | 2545
Value_2580 | 59 | 2580
Value_2615 | 60 | 2615
Value_2650 | 61 | 2650
Value_2685 | 62 | 2685
Value_2720 | 63 | 2720
Value_2755 | 64 | 2755
Value_2790 | 65 | 2790
Value_2825 | 66 | 2825
Value_2860 | 67 | 2860
Value_2895 | 68 | 2895
Value_2930 | 69 | 2930
Value_2965 | 70 | 2965
Value_3000 | 71 | 3000
Value_3035 | 72 | 3035
Value_3070 | 73 | 3070
Value_3105 | 74 | 3105
Value_3140 | 75 | 3140
Value_3175 | 76 | 3175
Value_3210 | 77 | 3210
Value_3245 | 78 | 3245
Value_3280 | 79 | 3280
Value_3315 | 80 | 3315
Value_3350 | 81 | 3350
Value_3385 | 82 | 3385
Value_3420 | 83 | 3420
Value_3455 | 84 | 3455
Value_3490 | 85 | 3490
Value_3525 | 86 | 3525
Value_3560 | 87 | 3560
Value_3595 | 88 | 3595
Value_3630 | 89 | 3630
Value_3665 | 90 | 3665
Value_3700 | 91 | 3700
Value_3735 | 92 | 3735
Value_3770 | 93 | 3770
Value_3805 | 94 | 3805
Value_3840 | 95 | 3840
Value_3875 | 96 | 3875
Value_3910 | 97 | 3910
Value_3945 | 98 | 3945
Value_3980 | 99 | 3980
Value_4015 | 100 | 4015
Value_4050 | 101 | 4050
Value_4085 | 102 | 4085
Value_4120 | 103 | 4120
Value_4155 | 104 | 4155
Value_4190 | 105 | 4190
Value_4225 | 106 | 4225
Value_4260 | 107 | 4260
Value_4295 | 108 | 4295
Value_4330 | 109 | 4330
Value_4365 | 110 | 4365
Value_4400 | 111 | 4400
Value_4435 | 112 | 4435
Value_4470 | 113 | 4470
Value_4505 | 114 | 4505
Value_4540 | 115 | 4540
Value_4575 | 116 | 4575
Value_4610 | 117 | 4610
Value_4645 | 118 | 4645
Value_4680 | 119 | 4680
Value_4715 | 120 | 4715
Value_4750 | 121 | 4750
Value_4785 | 122 | 4785
Value_4820 | 123 | 4820
Value_4855 | 124 | 4855
Value_4890 | 125 | 4890
Value_4925 | 126 | 4925
Value_4960 | 127 | 4960
Value_4995 | 128 | 4995
Value_5030 | 129 | 5030
Value_5065 | 130 | 5065
Value_5100 | 131 | 5100
Value_5135 | 132 | 5135
Value_5170 | 133 | 5170
Value_5205 | 134 | 5205
Value_5240 | 135 | 5240
Value_5275 | 136 | 5275
Value_5310 | 137 | 5310
Value_5345 | 138 | 5345
Value_5380 | 139 | 5380
Value_5415 | 140 | 5415
Value_5450 | 141 | 5450
Value_5485 | 142 | 5485
Value_5520 | 143 | 5520
Value_5555 | 144 | 5555
Value_5590 | 145 | 5590
Value_5625 | 146 | 5625
Value_5660 | 147 | 5660
Value_5695 | 148 | 5695
Value_5730 | 149 | 5730
Value_5765 | 150 | 5765
Value_5800 | 151 | 5800
Value_5835 | 152 | 5835
Value_5870 | 153 | 5870
Value_5905 | 154 | 5905
Value_5940 | 155 | 5940
Value_5975 | 156 | 5975
Value_6010 | 157 | 6010
Value_6045 | 158 | 6045
Value_6080 | 159 | 6080
Value_6115 | 160 | 6115
Value_6150 | 161 | 6150
Value_6185 | 162 | 6185
Value_6220 | 163 | 6220
Value_6255 | 164 | 6255
Value_6290 | 165 | 6290
Value_6325 | 166 | 6325
Value_6360 | 167 | 6360
Value_6395 | 168 | 6395
Value_6430 | 169 | 6430
Value_6465 | 170 | 6465
Value_6500 | 171 | 6500
Value_6535 | 172 | 6535
Value_6570 | 173 | 6570
Value_6605 | 174 | 6605
Value_6640 | 175 | 6640
Value_6675 | 176 | 6675
Value_6710 | 177 | 6710
Value_6745 | 178 | 6745
Value_6780 | 179 | 6780
Value_6815 | 180 | 6815
Value_6850 | 181 | 6850
Value_6885 | 182 | 6885
Value_6920 | 183 | 6920
Value_6955 | 184 | 6955
Value_6990 | 185 | 6990
Value_7025 | 186 | 7025
Value_7060 | 187 | 7060
Value_7095 | 188 | 7095
Value_7130 | 189 | 7130
Value_7165 | 190 | 7165
Value_7200 | 191 | 7200
Value_7235 | 192 | 7235
Value_7270 | 193 | 7270
Value_7305 | 194 | 7305
Value_7340 | 195 | 7340
Value_7375 | 196 | 7375
Value_7410 | 197 | 7410
Value_7445 | 198 | 7445
Value_7480 | 199 | 7480
Value_7515 | 200 | 7515
Value_7550 | 201 | 7550
Value_7585 | 202 | 7585
Value_7620 | 203 | 7620
Value_7655 | 204 | 7655
Value_7690 | 205 | 7690
Value_7725 | 206 | 7725
Value_7760 | 207 | 7760
Value_7795 | 208 | 7795
Value_7830 | 209 | 7830
Value_7865 | 210 | 7865
Value_7900 | 211 | 7900
Value_7935 | 212 | 7935
Value_7970 | 213 | 7970
Value_8005 | 214 | 8005
Value_8040 | 215 | 8040
Value_8075 | 216 | 8075
Value_8110 | 217 | 8110
Value_8145 | 218 | 8145
Value_8180 | 219 | 8180
Value_8215 | 220 | 8215
Value_8250 | 221 | 8250
Value_8285 | 222 | 8285
Value_8320 | 223 | 8320
Value_8355 | 224 | 8355
Value_8390 | 225 | 8390
Value_8425 | 226 | 8425
Value_8460 | 227 | 8460
Value_8495 | 228 | 8495
Value_8530 | 229 | 8530
Value_8565 | 230 | 8565
Value_8600 | 231 | 8600
Value_8635 | 232 | 8635
Value_8670 | 233 | 8670
Value_8705 | 234 | 8705
Value_8740 | 235 | 8740
Value_8775 | 236 | 8775
Value_8810 | 237 | 8810
Value_8845 | 238 | 8845
Value_8880 | 239 | 8880
Value_8915 | 240 | 8915
Value_8950 | 241 | 8950
Value_8985 | 242 | 8985
Value_9020 | 243 | 9020
Value_9055 | 244 | 9055
Value_9090 | 245 | 9090
Value_9125 | 246 | 9125
Value_9160 | 247 | 9160
Value_9195 | 248 | 9195
Value_9230 | 249 | 9230
Value_9265 | 250 | 9265
Value_9300 | 251 | 9300
Value_9335 | 252 | 9335
Value_9370 | 253 | 9370
Value_9405 | 254 | 9405
Value_9440 | 255 | 9440
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad78797889.Control2Avg Enumeration

IRD

Ad78797889Control2Avg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Control2Avg
Public Enumeration Control2Avg
public enum class Control2Avg
type Control2Avg
Members
Member name | Value | Description
Value_2MiddleValuesAveraged | 0 | 2 Middle Values Averaged
Value_4MiddleValuesAveraged | 1 | 4 Middle Values Averaged
Value_8MiddleValuesAveraged | 2 | 8 Middle Values Averaged
Value_16MiddleValuesAveraged | 3 | 16 Middle Values Averaged
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad78797889.Control2Fcd Enumeration

IRD

Ad78797889Control2Fcd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Control2Fcd
Public Enumeration Control2Fcd
public enum class Control2Fcd
type Control2Fcd
Members
Member name | Value | Description
Value_128 | 0 | 128
Value_256 | 1 | 256
Value_384 | 2 | 384
Value_512 | 3 | 512
Value_640 | 4 | 640
Value_768 | 5 | 768
Value_896 | 6 | 896
Value_1024 | 7 | 1024
Value_1152 | 8 | 1152
Value_1280 | 9 | 1280
Value_1536 | 10 | 1536
Value_1792 | 11 | 1792
Value_2048 | 12 | 2048
Value_2560 | 13 | 2560
Value_3584 | 14 | 3584
Value_4096 | 15 | 4096
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad78797889.Control2GpioDir Enumeration

IRD

Ad78797889Control2GpioDir Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Control2GpioDir
Public Enumeration Control2GpioDir
public enum class Control2GpioDir
type Control2GpioDir
Members
Member name | Value | Description
Output | 0 | Output
Input | 1 | Input
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad78797889.Control2GpioEn Enumeration

IRD

Ad78797889Control2GpioEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Control2GpioEn
Public Enumeration Control2GpioEn
public enum class Control2GpioEn
type Control2GpioEn
Members
Member name | Value | Description
AUXVBATChannelActive | 0 | AUX/VBAT Channel Active
GPIOEnabledOnAUXVBATGPIOPin | 1 | GPIO Enabled On AUX/VBAT/GPIOPin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad78797889.Control2GpioPol Enumeration

IRD

Ad78797889Control2GpioPol Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Control2GpioPol
Public Enumeration Control2GpioPol
public enum class Control2GpioPol
type Control2GpioPol
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad78797889.Control2Med Enumeration

IRD

Ad78797889Control2Med Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Control2Med
Public Enumeration Control2Med
public enum class Control2Med
type Control2Med
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_4 | 1 | 4
Value_8 | 2 | 8
Value_16 | 3 | 16
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad78797889.Control2Pm Enumeration

IRD

Ad78797889Control2Pm Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Control2Pm
Public Enumeration Control2Pm
public enum class Control2Pm
type Control2Pm
Members
Member name | Value | Description
FullShutdown | 0 | Full Shutdown
PoweredDownDependOnADCMode | 1 | Powered Down Depend On ADC Mode
PoweredUpContinuously | 2 | Powered Up Continuously
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad78797889.Control2SerDfr Enumeration

IRD

Ad78797889Control2SerDfr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Control2SerDfr
Public Enumeration Control2SerDfr
public enum class Control2SerDfr
type Control2SerDfr
Members
Member name | Value | Description
Ratiometric | 0 | Ratiometric
Normal | 1 | Normal
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad78797889.Control2SwRst Enumeration

IRD

Ad78797889Control2SwRst Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Control2SwRst
Public Enumeration Control2SwRst
public enum class Control2SwRst
type Control2SwRst
Members
Member name | Value | Description
Default | 0 | Default
Reset | 1 | Reset
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad78797889.Control3IntMode Enumeration

IRD

Ad78797889Control3IntMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Control3IntMode
Public Enumeration Control3IntMode
public enum class Control3IntMode
type Control3IntMode
Members
Member name | Value | Description
DAV | 0 | DAV
INT | 1 | INT
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad78797889.Control3Mask Enumeration

IRD

Ad78797889Control3Mask Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Control3Mask
Public Enumeration Control3Mask
public enum class Control3Mask
type Control3Mask
Members
Member name | Value | Description
AllowedToCauseInterrupt | 0 | Allowed To Cause Interrupt
NotAllowedToCauseInterrupt | 1 | Not Allowed To Cause Interrupt
See Also

Reference

telos.Ird.AnalogDevices Namespace


Ad78797889.Control3Sequencer Enumeration

IRD

Ad78797889Control3Sequencer Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Control3Sequencer
Public Enumeration Control3Sequencer
public enum class Control3Sequencer
type Control3Sequencer
Members
Member name | Value | Description
NotIncluded | 0 | Not Included
Included | 1 | Included
See Also

Reference

telos.Ird.AnalogDevices Namespace


Add5201 Class

Analog Devices: ADD 5201
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdd5201

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Add5201
Public Class Add5201
public ref class Add5201
type Add5201 =  class end

The Add5201 type exposes the following members.

Constructors
 | Name | Description
Public method | Add5201 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BrightnessControl | Brightness Control
Public property | DeviceControlBLCTL | Device Control: BL_CTL
Public property | DeviceControlPWMMD | Device Control: PWM_MD
Public property | DeviceControlPWMSEL | Device Control: PWM_SEL
Public property | FaultStatus2CHSD1CHSD | Fault/Status: 2_CH_SD, 1_CH_SD
Public property | FaultStatusBLSTAT | Fault/Status: BL_STAT
Public property | FaultStatusFAULT | Fault/Status: FAULT
Public property | FaultStatusOVCURR | Fault/Status: OV_CURR
Public property | FaultStatusTHRMSHDN | Fault/Status: THRM_SHDN
Public property | IdentificationLEDPanel | Identification: LED Panel
Public property | IdentificationMFG | Identification: MFG
Public property | IdentificationREV | Identification: REV
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
High Efficiency, Eight-String, White LED Driver for LCD Backlight Applications
See Also

Reference

telos.Ird.AnalogDevices Namespace


Add5201 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Add5201(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Add5201(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Add5201

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Add5201 Class
telos.Ird.AnalogDevices Namespace


Add5201 Properties

The Add5201 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BrightnessControl | Brightness Control
Public property | DeviceControlBLCTL | Device Control: BL_CTL
Public property | DeviceControlPWMMD | Device Control: PWM_MD
Public property | DeviceControlPWMSEL | Device Control: PWM_SEL
Public property | FaultStatus2CHSD1CHSD | Fault/Status: 2_CH_SD, 1_CH_SD
Public property | FaultStatusBLSTAT | Fault/Status: BL_STAT
Public property | FaultStatusFAULT | Fault/Status: FAULT
Public property | FaultStatusOVCURR | Fault/Status: OV_CURR
Public property | FaultStatusTHRMSHDN | Fault/Status: THRM_SHDN
Public property | IdentificationLEDPanel | Identification: LED Panel
Public property | IdentificationMFG | Identification: MFG
Public property | IdentificationREV | Identification: REV
Top
See Also

Reference

Add5201 Class
telos.Ird.AnalogDevices Namespace


Add5201.AutoFlush Property

IRD

Add5201AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Add5201 Class
telos.Ird.AnalogDevices Namespace


Add5201.BrightnessControl Property

IRD

Add5201BrightnessControl Property

Brightness Control

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte BrightnessControl { get; set; }
Public Property BrightnessControl As Byte
    Get
    Set
public:
property unsigned char BrightnessControl {
    unsigned char get ();
    void set (unsigned char value);
}
member BrightnessControl : byte with get, set

Property Value

Type: Byte
See Also

Reference

Add5201 Class
telos.Ird.AnalogDevices Namespace


Add5201.DeviceControlBLCTL Property

IRD

Add5201DeviceControlBLCTL Property

Device Control: BL_CTL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Add5201TypeDeviceControlBlCtl DeviceControlBLCTL { get; set; }
Public Property DeviceControlBLCTL As Add5201TypeDeviceControlBlCtl
    Get
    Set
public:
property Add5201TypeDeviceControlBlCtl DeviceControlBLCTL {
    Add5201TypeDeviceControlBlCtl get ();
    void set (Add5201TypeDeviceControlBlCtl value);
}
member DeviceControlBLCTL : Add5201TypeDeviceControlBlCtl with get, set

Property Value

Type: Add5201TypeDeviceControlBlCtl
See Also

Reference

Add5201 Class
telos.Ird.AnalogDevices Namespace


Add5201.DeviceControlPWMMD Property

IRD

Add5201DeviceControlPWMMD Property

Device Control: PWM_MD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Add5201TypeDeviceControlPwmMd DeviceControlPWMMD { get; set; }
Public Property DeviceControlPWMMD As Add5201TypeDeviceControlPwmMd
    Get
    Set
public:
property Add5201TypeDeviceControlPwmMd DeviceControlPWMMD {
    Add5201TypeDeviceControlPwmMd get ();
    void set (Add5201TypeDeviceControlPwmMd value);
}
member DeviceControlPWMMD : Add5201TypeDeviceControlPwmMd with get, set

Property Value

Type: Add5201TypeDeviceControlPwmMd
See Also

Reference

Add5201 Class
telos.Ird.AnalogDevices Namespace


Add5201.DeviceControlPWMSEL Property

IRD

Add5201DeviceControlPWMSEL Property

Device Control: PWM_SEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Add5201TypeDeviceControlPwmSel DeviceControlPWMSEL { get; set; }
Public Property DeviceControlPWMSEL As Add5201TypeDeviceControlPwmSel
    Get
    Set
public:
property Add5201TypeDeviceControlPwmSel DeviceControlPWMSEL {
    Add5201TypeDeviceControlPwmSel get ();
    void set (Add5201TypeDeviceControlPwmSel value);
}
member DeviceControlPWMSEL : Add5201TypeDeviceControlPwmSel with get, set

Property Value

Type: Add5201TypeDeviceControlPwmSel
See Also

Reference

Add5201 Class
telos.Ird.AnalogDevices Namespace


Add5201.FaultStatus2CHSD1CHSD Property

IRD

Add5201FaultStatus2CHSD1CHSD Property

Fault/Status: 2_CH_SD, 1_CH_SD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Add5201TypeFaultStatus2ChSd1ChSd FaultStatus2CHSD1CHSD { get; }
Public ReadOnly Property FaultStatus2CHSD1CHSD As Add5201TypeFaultStatus2ChSd1ChSd
    Get
public:
property Add5201TypeFaultStatus2ChSd1ChSd FaultStatus2CHSD1CHSD {
    Add5201TypeFaultStatus2ChSd1ChSd get ();
}
member FaultStatus2CHSD1CHSD : Add5201TypeFaultStatus2ChSd1ChSd with get

Property Value

Type: Add5201TypeFaultStatus2ChSd1ChSd
See Also

Reference

Add5201 Class
telos.Ird.AnalogDevices Namespace


Add5201.FaultStatusBLSTAT Property

IRD

Add5201FaultStatusBLSTAT Property

Fault/Status: BL_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Add5201TypeFaultStatusBlStat FaultStatusBLSTAT { get; }
Public ReadOnly Property FaultStatusBLSTAT As Add5201TypeFaultStatusBlStat
    Get
public:
property Add5201TypeFaultStatusBlStat FaultStatusBLSTAT {
    Add5201TypeFaultStatusBlStat get ();
}
member FaultStatusBLSTAT : Add5201TypeFaultStatusBlStat with get

Property Value

Type: Add5201TypeFaultStatusBlStat
See Also

Reference

Add5201 Class
telos.Ird.AnalogDevices Namespace


Add5201.FaultStatusFAULT Property

IRD

Add5201FaultStatusFAULT Property

Fault/Status: FAULT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Add5201TypeFaultStatusFault FaultStatusFAULT { get; }
Public ReadOnly Property FaultStatusFAULT As Add5201TypeFaultStatusFault
    Get
public:
property Add5201TypeFaultStatusFault FaultStatusFAULT {
    Add5201TypeFaultStatusFault get ();
}
member FaultStatusFAULT : Add5201TypeFaultStatusFault with get

Property Value

Type: Add5201TypeFaultStatusFault
See Also

Reference

Add5201 Class
telos.Ird.AnalogDevices Namespace


Add5201.FaultStatusOVCURR Property

IRD

Add5201FaultStatusOVCURR Property

Fault/Status: OV_CURR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Add5201TypeFaultStatusOvCurr FaultStatusOVCURR { get; }
Public ReadOnly Property FaultStatusOVCURR As Add5201TypeFaultStatusOvCurr
    Get
public:
property Add5201TypeFaultStatusOvCurr FaultStatusOVCURR {
    Add5201TypeFaultStatusOvCurr get ();
}
member FaultStatusOVCURR : Add5201TypeFaultStatusOvCurr with get

Property Value

Type: Add5201TypeFaultStatusOvCurr
See Also

Reference

Add5201 Class
telos.Ird.AnalogDevices Namespace


Add5201.FaultStatusTHRMSHDN Property

IRD

Add5201FaultStatusTHRMSHDN Property

Fault/Status: THRM_SHDN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Add5201TypeFaultStatusThrmShdn FaultStatusTHRMSHDN { get; }
Public ReadOnly Property FaultStatusTHRMSHDN As Add5201TypeFaultStatusThrmShdn
    Get
public:
property Add5201TypeFaultStatusThrmShdn FaultStatusTHRMSHDN {
    Add5201TypeFaultStatusThrmShdn get ();
}
member FaultStatusTHRMSHDN : Add5201TypeFaultStatusThrmShdn with get

Property Value

Type: Add5201TypeFaultStatusThrmShdn
See Also

Reference

Add5201 Class
telos.Ird.AnalogDevices Namespace


Add5201.IdentificationLEDPanel Property

IRD

Add5201IdentificationLEDPanel Property

Identification: LED Panel

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IdentificationLEDPanel { get; }
Public ReadOnly Property IdentificationLEDPanel As Byte
    Get
public:
property unsigned char IdentificationLEDPanel {
    unsigned char get ();
}
member IdentificationLEDPanel : byte with get

Property Value

Type: Byte
See Also

Reference

Add5201 Class
telos.Ird.AnalogDevices Namespace


Add5201.IdentificationMFG Property

IRD

Add5201IdentificationMFG Property

Identification: MFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IdentificationMFG { get; }
Public ReadOnly Property IdentificationMFG As Byte
    Get
public:
property unsigned char IdentificationMFG {
    unsigned char get ();
}
member IdentificationMFG : byte with get

Property Value

Type: Byte
See Also

Reference

Add5201 Class
telos.Ird.AnalogDevices Namespace


Add5201.IdentificationREV Property

IRD

Add5201IdentificationREV Property

Identification: REV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IdentificationREV { get; }
Public ReadOnly Property IdentificationREV As Byte
    Get
public:
property unsigned char IdentificationREV {
    unsigned char get ();
}
member IdentificationREV : byte with get

Property Value

Type: Byte
See Also

Reference

Add5201 Class
telos.Ird.AnalogDevices Namespace


Add5201 Methods

The Add5201 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Add5201 Class
telos.Ird.AnalogDevices Namespace


Add5201.Flush Method

IRD

Add5201Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Add5201 Class
telos.Ird.AnalogDevices Namespace


Add5201.TypeDeviceControlBlCtl Enumeration

IRD

Add5201TypeDeviceControlBlCtl Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeviceControlBlCtl
Public Enumeration TypeDeviceControlBlCtl
public enum class TypeDeviceControlBlCtl
type TypeDeviceControlBlCtl
Members
Member name | Value | Description
On | 1 | On
Off | 0 | Off
See Also

Reference

telos.Ird.AnalogDevices Namespace


Add5201.TypeDeviceControlPwmMd Enumeration

IRD

Add5201TypeDeviceControlPwmMd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeviceControlPwmMd
Public Enumeration TypeDeviceControlPwmMd
public enum class TypeDeviceControlPwmMd
type TypeDeviceControlPwmMd
Members
Member name | Value | Description
AbsoluteBrightness | 1 | Absolute Brightness
PercentChange | 0 | Percent Change
See Also

Reference

telos.Ird.AnalogDevices Namespace


Add5201.TypeDeviceControlPwmSel Enumeration

IRD

Add5201TypeDeviceControlPwmSel Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeviceControlPwmSel
Public Enumeration TypeDeviceControlPwmSel
public enum class TypeDeviceControlPwmSel
type TypeDeviceControlPwmSel
Members
Member name | Value | Description
PWMPin | 1 | PWM Pin
SMBusValue | 0 | SMBus Value
See Also

Reference

telos.Ird.AnalogDevices Namespace


Add5201.TypeFaultStatus2ChSd1ChSd Enumeration

IRD

Add5201TypeFaultStatus2ChSd1ChSd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatus2ChSd1ChSd
Public Enumeration TypeFaultStatus2ChSd1ChSd
public enum class TypeFaultStatus2ChSd1ChSd
type TypeFaultStatus2ChSd1ChSd
Members
Member name | Value | Description
NoFaults | 0 | No Faults
OneStringFault | 1 | One String Fault
TwoOrMoreStringsFaulted | 3 | Two Or More Strings Faulted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Add5201.TypeFaultStatusBlStat Enumeration

IRD

Add5201TypeFaultStatusBlStat Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusBlStat
Public Enumeration TypeFaultStatusBlStat
public enum class TypeFaultStatusBlStat
type TypeFaultStatusBlStat
Members
Member name | Value | Description
BacklightOn | 1 | Backlight On
BacklightOff | 0 | Backlight Off
See Also

Reference

telos.Ird.AnalogDevices Namespace


Add5201.TypeFaultStatusFault Enumeration

IRD

Add5201TypeFaultStatusFault Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusFault
Public Enumeration TypeFaultStatusFault
public enum class TypeFaultStatusFault
type TypeFaultStatusFault
Members
Member name | Value | Description
FaultOccurred | 1 | Fault Occurred
NoFaultOccurred | 0 | No Fault Occurred
See Also

Reference

telos.Ird.AnalogDevices Namespace


Add5201.TypeFaultStatusOvCurr Enumeration

IRD

Add5201TypeFaultStatusOvCurr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusOvCurr
Public Enumeration TypeFaultStatusOvCurr
public enum class TypeFaultStatusOvCurr
type TypeFaultStatusOvCurr
Members
Member name | Value | Description
OvercurrentCondition | 1 | Overcurrent Condition
CurrentOkay | 0 | Current Okay
See Also

Reference

telos.Ird.AnalogDevices Namespace


Add5201.TypeFaultStatusThrmShdn Enumeration

IRD

Add5201TypeFaultStatusThrmShdn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusThrmShdn
Public Enumeration TypeFaultStatusThrmShdn
public enum class TypeFaultStatusThrmShdn
type TypeFaultStatusThrmShdn
Members
Member name | Value | Description
ThermalFault | 1 | Thermal Fault
ThermalOkay | 0 | Thermal Okay
See Also

Reference

telos.Ird.AnalogDevices Namespace


Add5203 Class

Analog Devices: ADD 5203
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdd5203

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Add5203
Public Class Add5203
public ref class Add5203
type Add5203 =  class end

The Add5203 type exposes the following members.

Constructors
 | Name | Description
Public method | Add5203 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BrightnessControl | Brightness Control
Public property | DeviceControlBLCTL | Device Control: BL_CTL
Public property | DeviceControlPWMMD | Device Control: PWM_MD
Public property | DeviceControlPWMSEL | Device Control: PWM_SEL
Public property | FaultStatus2CHSD1CHSD | Fault/Status: 2_CH_SD, 1_CH_SD
Public property | FaultStatusBLSTAT | Fault/Status: BL_STAT
Public property | FaultStatusFAULT | Fault/Status: FAULT
Public property | FaultStatusOVCURR | Fault/Status: OV_CURR
Public property | FaultStatusTHRMSHDN | Fault/Status: THRM_SHDN
Public property | IdentificationLEDPanel | Identification: LED Panel
Public property | IdentificationMFG | Identification: MFG
Public property | IdentificationREV | Identification: REV
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
8-String, White LED Driver with SMBus and PWM Input for LCD Backlight Applications
See Also

Reference

telos.Ird.AnalogDevices Namespace


Add5203 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Add5203(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Add5203(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Add5203

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Add5203 Class
telos.Ird.AnalogDevices Namespace


Add5203 Properties

The Add5203 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BrightnessControl | Brightness Control
Public property | DeviceControlBLCTL | Device Control: BL_CTL
Public property | DeviceControlPWMMD | Device Control: PWM_MD
Public property | DeviceControlPWMSEL | Device Control: PWM_SEL
Public property | FaultStatus2CHSD1CHSD | Fault/Status: 2_CH_SD, 1_CH_SD
Public property | FaultStatusBLSTAT | Fault/Status: BL_STAT
Public property | FaultStatusFAULT | Fault/Status: FAULT
Public property | FaultStatusOVCURR | Fault/Status: OV_CURR
Public property | FaultStatusTHRMSHDN | Fault/Status: THRM_SHDN
Public property | IdentificationLEDPanel | Identification: LED Panel
Public property | IdentificationMFG | Identification: MFG
Public property | IdentificationREV | Identification: REV
Top
See Also

Reference

Add5203 Class
telos.Ird.AnalogDevices Namespace


Add5203.AutoFlush Property

IRD

Add5203AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Add5203 Class
telos.Ird.AnalogDevices Namespace


Add5203.BrightnessControl Property

IRD

Add5203BrightnessControl Property

Brightness Control

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte BrightnessControl { get; set; }
Public Property BrightnessControl As Byte
    Get
    Set
public:
property unsigned char BrightnessControl {
    unsigned char get ();
    void set (unsigned char value);
}
member BrightnessControl : byte with get, set

Property Value

Type: Byte
See Also

Reference

Add5203 Class
telos.Ird.AnalogDevices Namespace


Add5203.DeviceControlBLCTL Property

IRD

Add5203DeviceControlBLCTL Property

Device Control: BL_CTL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Add5203TypeDeviceControlBlCtl DeviceControlBLCTL { get; set; }
Public Property DeviceControlBLCTL As Add5203TypeDeviceControlBlCtl
    Get
    Set
public:
property Add5203TypeDeviceControlBlCtl DeviceControlBLCTL {
    Add5203TypeDeviceControlBlCtl get ();
    void set (Add5203TypeDeviceControlBlCtl value);
}
member DeviceControlBLCTL : Add5203TypeDeviceControlBlCtl with get, set

Property Value

Type: Add5203TypeDeviceControlBlCtl
See Also

Reference

Add5203 Class
telos.Ird.AnalogDevices Namespace


Add5203.DeviceControlPWMMD Property

IRD

Add5203DeviceControlPWMMD Property

Device Control: PWM_MD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Add5203TypeDeviceControlPwmMd DeviceControlPWMMD { get; set; }
Public Property DeviceControlPWMMD As Add5203TypeDeviceControlPwmMd
    Get
    Set
public:
property Add5203TypeDeviceControlPwmMd DeviceControlPWMMD {
    Add5203TypeDeviceControlPwmMd get ();
    void set (Add5203TypeDeviceControlPwmMd value);
}
member DeviceControlPWMMD : Add5203TypeDeviceControlPwmMd with get, set

Property Value

Type: Add5203TypeDeviceControlPwmMd
See Also

Reference

Add5203 Class
telos.Ird.AnalogDevices Namespace


Add5203.DeviceControlPWMSEL Property

IRD

Add5203DeviceControlPWMSEL Property

Device Control: PWM_SEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Add5203TypeDeviceControlPwmSel DeviceControlPWMSEL { get; set; }
Public Property DeviceControlPWMSEL As Add5203TypeDeviceControlPwmSel
    Get
    Set
public:
property Add5203TypeDeviceControlPwmSel DeviceControlPWMSEL {
    Add5203TypeDeviceControlPwmSel get ();
    void set (Add5203TypeDeviceControlPwmSel value);
}
member DeviceControlPWMSEL : Add5203TypeDeviceControlPwmSel with get, set

Property Value

Type: Add5203TypeDeviceControlPwmSel
See Also

Reference

Add5203 Class
telos.Ird.AnalogDevices Namespace


Add5203.FaultStatus2CHSD1CHSD Property

IRD

Add5203FaultStatus2CHSD1CHSD Property

Fault/Status: 2_CH_SD, 1_CH_SD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Add5203TypeFaultStatus2ChSd1ChSd FaultStatus2CHSD1CHSD { get; }
Public ReadOnly Property FaultStatus2CHSD1CHSD As Add5203TypeFaultStatus2ChSd1ChSd
    Get
public:
property Add5203TypeFaultStatus2ChSd1ChSd FaultStatus2CHSD1CHSD {
    Add5203TypeFaultStatus2ChSd1ChSd get ();
}
member FaultStatus2CHSD1CHSD : Add5203TypeFaultStatus2ChSd1ChSd with get

Property Value

Type: Add5203TypeFaultStatus2ChSd1ChSd
See Also

Reference

Add5203 Class
telos.Ird.AnalogDevices Namespace


Add5203.FaultStatusBLSTAT Property

IRD

Add5203FaultStatusBLSTAT Property

Fault/Status: BL_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Add5203TypeFaultStatusBlStat FaultStatusBLSTAT { get; }
Public ReadOnly Property FaultStatusBLSTAT As Add5203TypeFaultStatusBlStat
    Get
public:
property Add5203TypeFaultStatusBlStat FaultStatusBLSTAT {
    Add5203TypeFaultStatusBlStat get ();
}
member FaultStatusBLSTAT : Add5203TypeFaultStatusBlStat with get

Property Value

Type: Add5203TypeFaultStatusBlStat
See Also

Reference

Add5203 Class
telos.Ird.AnalogDevices Namespace


Add5203.FaultStatusFAULT Property

IRD

Add5203FaultStatusFAULT Property

Fault/Status: FAULT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Add5203TypeFaultStatusFault FaultStatusFAULT { get; }
Public ReadOnly Property FaultStatusFAULT As Add5203TypeFaultStatusFault
    Get
public:
property Add5203TypeFaultStatusFault FaultStatusFAULT {
    Add5203TypeFaultStatusFault get ();
}
member FaultStatusFAULT : Add5203TypeFaultStatusFault with get

Property Value

Type: Add5203TypeFaultStatusFault
See Also

Reference

Add5203 Class
telos.Ird.AnalogDevices Namespace


Add5203.FaultStatusOVCURR Property

IRD

Add5203FaultStatusOVCURR Property

Fault/Status: OV_CURR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Add5203TypeFaultStatusOvCurr FaultStatusOVCURR { get; }
Public ReadOnly Property FaultStatusOVCURR As Add5203TypeFaultStatusOvCurr
    Get
public:
property Add5203TypeFaultStatusOvCurr FaultStatusOVCURR {
    Add5203TypeFaultStatusOvCurr get ();
}
member FaultStatusOVCURR : Add5203TypeFaultStatusOvCurr with get

Property Value

Type: Add5203TypeFaultStatusOvCurr
See Also

Reference

Add5203 Class
telos.Ird.AnalogDevices Namespace


Add5203.FaultStatusTHRMSHDN Property

IRD

Add5203FaultStatusTHRMSHDN Property

Fault/Status: THRM_SHDN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Add5203TypeFaultStatusThrmShdn FaultStatusTHRMSHDN { get; }
Public ReadOnly Property FaultStatusTHRMSHDN As Add5203TypeFaultStatusThrmShdn
    Get
public:
property Add5203TypeFaultStatusThrmShdn FaultStatusTHRMSHDN {
    Add5203TypeFaultStatusThrmShdn get ();
}
member FaultStatusTHRMSHDN : Add5203TypeFaultStatusThrmShdn with get

Property Value

Type: Add5203TypeFaultStatusThrmShdn
See Also

Reference

Add5203 Class
telos.Ird.AnalogDevices Namespace


Add5203.IdentificationLEDPanel Property

IRD

Add5203IdentificationLEDPanel Property

Identification: LED Panel

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IdentificationLEDPanel { get; }
Public ReadOnly Property IdentificationLEDPanel As Byte
    Get
public:
property unsigned char IdentificationLEDPanel {
    unsigned char get ();
}
member IdentificationLEDPanel : byte with get

Property Value

Type: Byte
See Also

Reference

Add5203 Class
telos.Ird.AnalogDevices Namespace


Add5203.IdentificationMFG Property

IRD

Add5203IdentificationMFG Property

Identification: MFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IdentificationMFG { get; }
Public ReadOnly Property IdentificationMFG As Byte
    Get
public:
property unsigned char IdentificationMFG {
    unsigned char get ();
}
member IdentificationMFG : byte with get

Property Value

Type: Byte
See Also

Reference

Add5203 Class
telos.Ird.AnalogDevices Namespace


Add5203.IdentificationREV Property

IRD

Add5203IdentificationREV Property

Identification: REV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IdentificationREV { get; }
Public ReadOnly Property IdentificationREV As Byte
    Get
public:
property unsigned char IdentificationREV {
    unsigned char get ();
}
member IdentificationREV : byte with get

Property Value

Type: Byte
See Also

Reference

Add5203 Class
telos.Ird.AnalogDevices Namespace


Add5203 Methods

The Add5203 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Add5203 Class
telos.Ird.AnalogDevices Namespace


Add5203.Flush Method

IRD

Add5203Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Add5203 Class
telos.Ird.AnalogDevices Namespace


Add5203.TypeDeviceControlBlCtl Enumeration

IRD

Add5203TypeDeviceControlBlCtl Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeviceControlBlCtl
Public Enumeration TypeDeviceControlBlCtl
public enum class TypeDeviceControlBlCtl
type TypeDeviceControlBlCtl
Members
Member name | Value | Description
On | 1 | On
Off | 0 | Off
See Also

Reference

telos.Ird.AnalogDevices Namespace


Add5203.TypeDeviceControlPwmMd Enumeration

IRD

Add5203TypeDeviceControlPwmMd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeviceControlPwmMd
Public Enumeration TypeDeviceControlPwmMd
public enum class TypeDeviceControlPwmMd
type TypeDeviceControlPwmMd
Members
Member name | Value | Description
AbsoluteBrightness | 1 | Absolute Brightness
PercentChange | 0 | Percent Change
See Also

Reference

telos.Ird.AnalogDevices Namespace


Add5203.TypeDeviceControlPwmSel Enumeration

IRD

Add5203TypeDeviceControlPwmSel Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeviceControlPwmSel
Public Enumeration TypeDeviceControlPwmSel
public enum class TypeDeviceControlPwmSel
type TypeDeviceControlPwmSel
Members
Member name | Value | Description
ControlByPWM | 1 | Control by PWM
ControlBySMBus | 0 | Control by SMBus
See Also

Reference

telos.Ird.AnalogDevices Namespace


Add5203.TypeFaultStatus2ChSd1ChSd Enumeration

IRD

Add5203TypeFaultStatus2ChSd1ChSd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatus2ChSd1ChSd
Public Enumeration TypeFaultStatus2ChSd1ChSd
public enum class TypeFaultStatus2ChSd1ChSd
type TypeFaultStatus2ChSd1ChSd
Members
Member name | Value | Description
NoFaults | 0 | No Faults
OneStringFault | 1 | One String Fault
TwoOrMoreStringsFaulted | 3 | Two Or More Strings Faulted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Add5203.TypeFaultStatusBlStat Enumeration

IRD

Add5203TypeFaultStatusBlStat Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusBlStat
Public Enumeration TypeFaultStatusBlStat
public enum class TypeFaultStatusBlStat
type TypeFaultStatusBlStat
Members
Member name | Value | Description
BacklightOn | 1 | Backlight On
BacklightOff | 0 | Backlight Off
See Also

Reference

telos.Ird.AnalogDevices Namespace


Add5203.TypeFaultStatusFault Enumeration

IRD

Add5203TypeFaultStatusFault Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusFault
Public Enumeration TypeFaultStatusFault
public enum class TypeFaultStatusFault
type TypeFaultStatusFault
Members
Member name | Value | Description
FaultOccurred | 1 | Fault Occurred
NoFaultOccurred | 0 | No Fault Occurred
See Also

Reference

telos.Ird.AnalogDevices Namespace


Add5203.TypeFaultStatusOvCurr Enumeration

IRD

Add5203TypeFaultStatusOvCurr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusOvCurr
Public Enumeration TypeFaultStatusOvCurr
public enum class TypeFaultStatusOvCurr
type TypeFaultStatusOvCurr
Members
Member name | Value | Description
OvercurrentCondition | 1 | Overcurrent Condition
CurrentOk | 0 | Current Ok
See Also

Reference

telos.Ird.AnalogDevices Namespace


Add5203.TypeFaultStatusThrmShdn Enumeration

IRD

Add5203TypeFaultStatusThrmShdn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusThrmShdn
Public Enumeration TypeFaultStatusThrmShdn
public enum class TypeFaultStatusThrmShdn
type TypeFaultStatusThrmShdn
Members
Member name | Value | Description
ThermalFault | 1 | Thermal Fault
ThermalOk | 0 | Thermal Ok
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1021a Class

Analog Devices: ADM 1021 A
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdm1021a

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adm1021a
Public Class Adm1021a
public ref class Adm1021a
type Adm1021a =  class end

The Adm1021a type exposes the following members.

Constructors
 | Name | Description
Public method | Adm1021a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationMask | Configuration (Mask)
Public property | ConfigurationRunStop | Configuration (Run/Stop)
Public property | ConversionRate | Conversion Rate (unit: Conversion/sec)
Public property | DieRevisionCode | Die Revision Code
Public property | LocalTempHighLimit | Local Temp. High Limit (unit: °C)
Public property | LocalTempLowLimit | Local Temp. Low Limit (unit: °C)
Public property | LocalTempValue | Local Temp. Value (unit: °C)
Public property | ManufacturerDeviceID | Manufacturer Device ID
Public property | RemoteTempHighLimit | Remote Temp. High Limit (unit: °C)
Public property | RemoteTempLowLimit | Remote Temp. Low Limit (unit: °C)
Public property | RemoteTempValue | Remote Temp. Value (unit: °C)
Public property | StatusBusy | Status (Busy)
Public property | StatusLocalHighTempLimitTripped | Status (Local High Temp. Limit Tripped)
Public property | StatusLocalLowTempLimitTripped | Status (Local Low Temp. Limit Tripped)
Public property | StatusRemoteHighTempLimitTripped | Status (Remote High Temp. Limit Tripped)
Public property | StatusRemoteLowTempLimitTripped | Status (Remote Low Temp. Limit Tripped)
Public property | StatusRemoteSensorOpen | Status (Remote Sensor Open)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Temperature Monitor
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1021a Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1021a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adm1021a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adm1021a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a Properties

The Adm1021a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationMask | Configuration (Mask)
Public property | ConfigurationRunStop | Configuration (Run/Stop)
Public property | ConversionRate | Conversion Rate (unit: Conversion/sec)
Public property | DieRevisionCode | Die Revision Code
Public property | LocalTempHighLimit | Local Temp. High Limit (unit: °C)
Public property | LocalTempLowLimit | Local Temp. Low Limit (unit: °C)
Public property | LocalTempValue | Local Temp. Value (unit: °C)
Public property | ManufacturerDeviceID | Manufacturer Device ID
Public property | RemoteTempHighLimit | Remote Temp. High Limit (unit: °C)
Public property | RemoteTempLowLimit | Remote Temp. Low Limit (unit: °C)
Public property | RemoteTempValue | Remote Temp. Value (unit: °C)
Public property | StatusBusy | Status (Busy)
Public property | StatusLocalHighTempLimitTripped | Status (Local High Temp. Limit Tripped)
Public property | StatusLocalLowTempLimitTripped | Status (Local Low Temp. Limit Tripped)
Public property | StatusRemoteHighTempLimitTripped | Status (Remote High Temp. Limit Tripped)
Public property | StatusRemoteLowTempLimitTripped | Status (Remote Low Temp. Limit Tripped)
Public property | StatusRemoteSensorOpen | Status (Remote Sensor Open)
Top
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.AutoFlush Property

IRD

Adm1021aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.ConfigurationMask Property

IRD

Adm1021aConfigurationMask Property

Configuration (Mask)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1021aConfigMaskType ConfigurationMask { get; set; }
Public Property ConfigurationMask As Adm1021aConfigMaskType
    Get
    Set
public:
property Adm1021aConfigMaskType ConfigurationMask {
    Adm1021aConfigMaskType get ();
    void set (Adm1021aConfigMaskType value);
}
member ConfigurationMask : Adm1021aConfigMaskType with get, set

Property Value

Type: Adm1021aConfigMaskType
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.ConfigurationRunStop Property

IRD

Adm1021aConfigurationRunStop Property

Configuration (Run/Stop)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1021aConfigRunType ConfigurationRunStop { get; set; }
Public Property ConfigurationRunStop As Adm1021aConfigRunType
    Get
    Set
public:
property Adm1021aConfigRunType ConfigurationRunStop {
    Adm1021aConfigRunType get ();
    void set (Adm1021aConfigRunType value);
}
member ConfigurationRunStop : Adm1021aConfigRunType with get, set

Property Value

Type: Adm1021aConfigRunType
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.ConversionRate Property

IRD

Adm1021aConversionRate Property

Conversion Rate (unit: Conversion/sec)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1021aConversionRateType ConversionRate { get; set; }
Public Property ConversionRate As Adm1021aConversionRateType
    Get
    Set
public:
property Adm1021aConversionRateType ConversionRate {
    Adm1021aConversionRateType get ();
    void set (Adm1021aConversionRateType value);
}
member ConversionRate : Adm1021aConversionRateType with get, set

Property Value

Type: Adm1021aConversionRateType
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.DieRevisionCode Property

IRD

Adm1021aDieRevisionCode Property

Die Revision Code

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DieRevisionCode { get; }
Public ReadOnly Property DieRevisionCode As Byte
    Get
public:
property unsigned char DieRevisionCode {
    unsigned char get ();
}
member DieRevisionCode : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.LocalTempHighLimit Property

IRD

Adm1021aLocalTempHighLimit Property

Local Temp. High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTempHighLimit { get; set; }
Public Property LocalTempHighLimit As SByte
    Get
    Set
public:
property signed char LocalTempHighLimit {
    signed char get ();
    void set (signed char value);
}
member LocalTempHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.LocalTempLowLimit Property

IRD

Adm1021aLocalTempLowLimit Property

Local Temp. Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTempLowLimit { get; set; }
Public Property LocalTempLowLimit As SByte
    Get
    Set
public:
property signed char LocalTempLowLimit {
    signed char get ();
    void set (signed char value);
}
member LocalTempLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.LocalTempValue Property

IRD

Adm1021aLocalTempValue Property

Local Temp. Value (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTempValue { get; }
Public ReadOnly Property LocalTempValue As SByte
    Get
public:
property signed char LocalTempValue {
    signed char get ();
}
member LocalTempValue : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.ManufacturerDeviceID Property

IRD

Adm1021aManufacturerDeviceID Property

Manufacturer Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerDeviceID { get; }
Public ReadOnly Property ManufacturerDeviceID As Byte
    Get
public:
property unsigned char ManufacturerDeviceID {
    unsigned char get ();
}
member ManufacturerDeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.RemoteTempHighLimit Property

IRD

Adm1021aRemoteTempHighLimit Property

Remote Temp. High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTempHighLimit { get; set; }
Public Property RemoteTempHighLimit As SByte
    Get
    Set
public:
property signed char RemoteTempHighLimit {
    signed char get ();
    void set (signed char value);
}
member RemoteTempHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.RemoteTempLowLimit Property

IRD

Adm1021aRemoteTempLowLimit Property

Remote Temp. Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTempLowLimit { get; set; }
Public Property RemoteTempLowLimit As SByte
    Get
    Set
public:
property signed char RemoteTempLowLimit {
    signed char get ();
    void set (signed char value);
}
member RemoteTempLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.RemoteTempValue Property

IRD

Adm1021aRemoteTempValue Property

Remote Temp. Value (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTempValue { get; }
Public ReadOnly Property RemoteTempValue As SByte
    Get
public:
property signed char RemoteTempValue {
    signed char get ();
}
member RemoteTempValue : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.StatusBusy Property

IRD

Adm1021aStatusBusy Property

Status (Busy)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1021aBool StatusBusy { get; }
Public ReadOnly Property StatusBusy As Adm1021aBool
    Get
public:
property Adm1021aBool StatusBusy {
    Adm1021aBool get ();
}
member StatusBusy : Adm1021aBool with get

Property Value

Type: Adm1021aBool
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.StatusLocalHighTempLimitTripped Property

IRD

Adm1021aStatusLocalHighTempLimitTripped Property

Status (Local High Temp. Limit Tripped)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1021aBool StatusLocalHighTempLimitTripped { get; }
Public ReadOnly Property StatusLocalHighTempLimitTripped As Adm1021aBool
    Get
public:
property Adm1021aBool StatusLocalHighTempLimitTripped {
    Adm1021aBool get ();
}
member StatusLocalHighTempLimitTripped : Adm1021aBool with get

Property Value

Type: Adm1021aBool
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.StatusLocalLowTempLimitTripped Property

IRD

Adm1021aStatusLocalLowTempLimitTripped Property

Status (Local Low Temp. Limit Tripped)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1021aBool StatusLocalLowTempLimitTripped { get; }
Public ReadOnly Property StatusLocalLowTempLimitTripped As Adm1021aBool
    Get
public:
property Adm1021aBool StatusLocalLowTempLimitTripped {
    Adm1021aBool get ();
}
member StatusLocalLowTempLimitTripped : Adm1021aBool with get

Property Value

Type: Adm1021aBool
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.StatusRemoteHighTempLimitTripped Property

IRD

Adm1021aStatusRemoteHighTempLimitTripped Property

Status (Remote High Temp. Limit Tripped)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1021aBool StatusRemoteHighTempLimitTripped { get; }
Public ReadOnly Property StatusRemoteHighTempLimitTripped As Adm1021aBool
    Get
public:
property Adm1021aBool StatusRemoteHighTempLimitTripped {
    Adm1021aBool get ();
}
member StatusRemoteHighTempLimitTripped : Adm1021aBool with get

Property Value

Type: Adm1021aBool
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.StatusRemoteLowTempLimitTripped Property

IRD

Adm1021aStatusRemoteLowTempLimitTripped Property

Status (Remote Low Temp. Limit Tripped)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1021aBool StatusRemoteLowTempLimitTripped { get; }
Public ReadOnly Property StatusRemoteLowTempLimitTripped As Adm1021aBool
    Get
public:
property Adm1021aBool StatusRemoteLowTempLimitTripped {
    Adm1021aBool get ();
}
member StatusRemoteLowTempLimitTripped : Adm1021aBool with get

Property Value

Type: Adm1021aBool
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.StatusRemoteSensorOpen Property

IRD

Adm1021aStatusRemoteSensorOpen Property

Status (Remote Sensor Open)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1021aBool StatusRemoteSensorOpen { get; }
Public ReadOnly Property StatusRemoteSensorOpen As Adm1021aBool
    Get
public:
property Adm1021aBool StatusRemoteSensorOpen {
    Adm1021aBool get ();
}
member StatusRemoteSensorOpen : Adm1021aBool with get

Property Value

Type: Adm1021aBool
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a Methods

The Adm1021a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.Flush Method

IRD

Adm1021aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.OneShot Method

IRD

Adm1021aOneShot Method

One-Shot

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void OneShot()
Public Sub OneShot
public:
void OneShot()
member OneShot : unit -> unit
See Also

Reference

Adm1021a Class
telos.Ird.AnalogDevices Namespace


Adm1021a.Bool Enumeration

IRD

Adm1021aBool Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Bool
Public Enumeration Bool
public enum class Bool
type Bool
Members
Member name | Value | Description
True | 1 | True
False | 0 | False
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1021a.ConfigMaskType Enumeration

IRD

Adm1021aConfigMaskType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigMaskType
Public Enumeration ConfigMaskType
public enum class ConfigMaskType
type ConfigMaskType
Members
Member name | Value | Description
ALERTMasked | 1 | ALERT Masked
ALERTEnabled | 0 | ALERT Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1021a.ConfigRunType Enumeration

IRD

Adm1021aConfigRunType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigRunType
Public Enumeration ConfigRunType
public enum class ConfigRunType
type ConfigRunType
Members
Member name | Value | Description
Standby | 1 | Standby
Run | 0 | Run
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1021a.ConversionRateType Enumeration

IRD

Adm1021aConversionRateType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConversionRateType
Public Enumeration ConversionRateType
public enum class ConversionRateType
type ConversionRateType
Members
Member name | Value | Description
Value_8 | 7 | 8
Value_4 | 6 | 4
Value_2 | 5 | 2
Value_1 | 4 | 1
Value_0_5 | 3 | 0.5
Value_0_25 | 2 | 0.25
Value_0_125 | 1 | 0.125
Value_0_0625 | 0 | 0.0625
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1022 Class

Analog Devices: ADM 1022
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdm1022

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adm1022
Public Class Adm1022
public ref class Adm1022
type Adm1022 =  class end

The Adm1022 type exposes the following members.

Constructors
 | Name | Description
Public method | Adm1022 | Constructor
Top
Properties
 | Name | Description
Public property | AnalogOutputFANSPD | Analog Output / FAN_SPD
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CompanyID | Company ID
Public property | ConfigurationAutomaticTripPointLock | Configuration (Automatic Trip Point Lock)
Public property | ConfigurationD2 | Configuration (D2)
Public property | ConfigurationFANOFF | Configuration (FAN OFF)
Public property | ConfigurationGPIInvert | Configuration (GPI Invert)
Public property | ConfigurationINTClear | Configuration (INT Clear)
Public property | ConfigurationINTEnable | Configuration (INT Enable)
Public property | ConfigurationSoftReset | Configuration (Soft Reset)
Public property | ConfigurationSTART | Configuration (START)
Public property | DefaultLocalTemperatureTripPoint | Default Local Temperature Trip Point (unit: °C)
Public property | DefaultRemoteTemperatureTripPoint | Default Remote Temperature Trip Point (unit: °C)
Public property | ExternalTemperatureDiode1HighLimit | External Temperature Diode 1 High Limit (unit: °C)
Public property | ExternalTemperatureDiode1LowLimit | External Temperature Diode 1 Low Limit (unit: °C)
Public property | ExternalTemperatureDiode2HighLimit | External Temperature Diode 2 High Limit (unit: °C)
Public property | ExternalTemperatureDiode2LowLimit | External Temperature Diode 2 Low Limit (unit: °C)
Public property | ExternalTemperatureValueDiode1 | External Temperature Value Diode 1 (unit: °C)
Public property | ExternalTemperatureValueDiode2 | External Temperature Value Diode 2 (unit: °C)
Public property | InternalTemperatureHighLimit | Internal Temperature High Limit (unit: °C)
Public property | InternalTemperatureLowLimit | Internal Temperature Low Limit (unit: °C)
Public property | InternalTemperatureValue | Internal Temperature Value (unit: °C)
Public property | InterruptMaskDiode1Fault | Interrupt Mask (Diode 1 Fault)
Public property | InterruptMaskDiode2Fault | Interrupt Mask (Diode 2 Fault)
Public property | InterruptMaskExtTemp1Error | Interrupt Mask (Ext. Temp 1 Error)
Public property | InterruptMaskExtTemp2Error | Interrupt Mask (Ext. Temp 2 Error)
Public property | InterruptMaskGPIInput | Interrupt Mask (GPI Input)
Public property | InterruptMaskIntTempError | Interrupt Mask (Int. Temp Error)
Public property | InterruptMaskTHERMInput | Interrupt Mask (THERM Input)
Public property | InterruptStatusDiode1Fault | Interrupt Status (Diode 1 Fault)
Public property | InterruptStatusDiode2Fault | Interrupt Status (Diode 2 Fault)
Public property | InterruptStatusExtTemp1Error | Interrupt Status (Ext. Temp 1 Error)
Public property | InterruptStatusExtTemp2Error | Interrupt Status (Ext. Temp 2 Error)
Public property | InterruptStatusGPIInput | Interrupt Status (GPI Input)
Public property | InterruptStatusIntTempError | Interrupt Status (Int. Temp Error)
Public property | InterruptStatusMirrorDiode1Fault | Interrupt Status Mirror (Diode 1 Fault)
Public property | InterruptStatusMirrorDiode2Fault | Interrupt Status Mirror (Diode 2 Fault)
Public property | InterruptStatusMirrorExtTemp1Error | Interrupt Status Mirror (Ext. Temp 1 Error)
Public property | InterruptStatusMirrorExtTemp2Error | Interrupt Status Mirror (Ext. Temp 2 Error)
Public property | InterruptStatusMirrorGPIInput | Interrupt Status Mirror (GPI Input)
Public property | InterruptStatusMirrorIntTempError | Interrupt Status Mirror (Int. Temp Error)
Public property | InterruptStatusMirrorTHERMInput | Interrupt Status Mirror (THERM Input)
Public property | InterruptStatusTHERMInput | Interrupt Status (THERM Input)
Public property | LocalTemperatureTripPoint | Local Temperature Trip Point (unit: °C)
Public property | RemoteTemperatureTripPoint | Remote Temperature Trip Point (unit: °C)
Public property | Revision | Revision
Public property | Version | Version
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Temperature Monitor and Fan Controller
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1022 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adm1022(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adm1022

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022 Properties

The Adm1022 type exposes the following members.

Properties
 | Name | Description
Public property | AnalogOutputFANSPD | Analog Output / FAN_SPD
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CompanyID | Company ID
Public property | ConfigurationAutomaticTripPointLock | Configuration (Automatic Trip Point Lock)
Public property | ConfigurationD2 | Configuration (D2)
Public property | ConfigurationFANOFF | Configuration (FAN OFF)
Public property | ConfigurationGPIInvert | Configuration (GPI Invert)
Public property | ConfigurationINTClear | Configuration (INT Clear)
Public property | ConfigurationINTEnable | Configuration (INT Enable)
Public property | ConfigurationSoftReset | Configuration (Soft Reset)
Public property | ConfigurationSTART | Configuration (START)
Public property | DefaultLocalTemperatureTripPoint | Default Local Temperature Trip Point (unit: °C)
Public property | DefaultRemoteTemperatureTripPoint | Default Remote Temperature Trip Point (unit: °C)
Public property | ExternalTemperatureDiode1HighLimit | External Temperature Diode 1 High Limit (unit: °C)
Public property | ExternalTemperatureDiode1LowLimit | External Temperature Diode 1 Low Limit (unit: °C)
Public property | ExternalTemperatureDiode2HighLimit | External Temperature Diode 2 High Limit (unit: °C)
Public property | ExternalTemperatureDiode2LowLimit | External Temperature Diode 2 Low Limit (unit: °C)
Public property | ExternalTemperatureValueDiode1 | External Temperature Value Diode 1 (unit: °C)
Public property | ExternalTemperatureValueDiode2 | External Temperature Value Diode 2 (unit: °C)
Public property | InternalTemperatureHighLimit | Internal Temperature High Limit (unit: °C)
Public property | InternalTemperatureLowLimit | Internal Temperature Low Limit (unit: °C)
Public property | InternalTemperatureValue | Internal Temperature Value (unit: °C)
Public property | InterruptMaskDiode1Fault | Interrupt Mask (Diode 1 Fault)
Public property | InterruptMaskDiode2Fault | Interrupt Mask (Diode 2 Fault)
Public property | InterruptMaskExtTemp1Error | Interrupt Mask (Ext. Temp 1 Error)
Public property | InterruptMaskExtTemp2Error | Interrupt Mask (Ext. Temp 2 Error)
Public property | InterruptMaskGPIInput | Interrupt Mask (GPI Input)
Public property | InterruptMaskIntTempError | Interrupt Mask (Int. Temp Error)
Public property | InterruptMaskTHERMInput | Interrupt Mask (THERM Input)
Public property | InterruptStatusDiode1Fault | Interrupt Status (Diode 1 Fault)
Public property | InterruptStatusDiode2Fault | Interrupt Status (Diode 2 Fault)
Public property | InterruptStatusExtTemp1Error | Interrupt Status (Ext. Temp 1 Error)
Public property | InterruptStatusExtTemp2Error | Interrupt Status (Ext. Temp 2 Error)
Public property | InterruptStatusGPIInput | Interrupt Status (GPI Input)
Public property | InterruptStatusIntTempError | Interrupt Status (Int. Temp Error)
Public property | InterruptStatusMirrorDiode1Fault | Interrupt Status Mirror (Diode 1 Fault)
Public property | InterruptStatusMirrorDiode2Fault | Interrupt Status Mirror (Diode 2 Fault)
Public property | InterruptStatusMirrorExtTemp1Error | Interrupt Status Mirror (Ext. Temp 1 Error)
Public property | InterruptStatusMirrorExtTemp2Error | Interrupt Status Mirror (Ext. Temp 2 Error)
Public property | InterruptStatusMirrorGPIInput | Interrupt Status Mirror (GPI Input)
Public property | InterruptStatusMirrorIntTempError | Interrupt Status Mirror (Int. Temp Error)
Public property | InterruptStatusMirrorTHERMInput | Interrupt Status Mirror (THERM Input)
Public property | InterruptStatusTHERMInput | Interrupt Status (THERM Input)
Public property | LocalTemperatureTripPoint | Local Temperature Trip Point (unit: °C)
Public property | RemoteTemperatureTripPoint | Remote Temperature Trip Point (unit: °C)
Public property | Revision | Revision
Public property | Version | Version
Top
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.AnalogOutputFANSPD Property

IRD

Adm1022AnalogOutputFANSPD Property

Analog Output / FAN_SPD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AnalogOutputFANSPD { get; set; }
Public Property AnalogOutputFANSPD As Byte
    Get
    Set
public:
property unsigned char AnalogOutputFANSPD {
    unsigned char get ();
    void set (unsigned char value);
}
member AnalogOutputFANSPD : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.AutoFlush Property

IRD

Adm1022AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.CompanyID Property

IRD

Adm1022CompanyID Property

Company ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CompanyID { get; }
Public ReadOnly Property CompanyID As Byte
    Get
public:
property unsigned char CompanyID {
    unsigned char get ();
}
member CompanyID : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.ConfigurationAutomaticTripPointLock Property

IRD

Adm1022ConfigurationAutomaticTripPointLock Property

Configuration (Automatic Trip Point Lock)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022ConfLockType ConfigurationAutomaticTripPointLock { get; set; }
Public Property ConfigurationAutomaticTripPointLock As Adm1022ConfLockType
    Get
    Set
public:
property Adm1022ConfLockType ConfigurationAutomaticTripPointLock {
    Adm1022ConfLockType get ();
    void set (Adm1022ConfLockType value);
}
member ConfigurationAutomaticTripPointLock : Adm1022ConfLockType with get, set

Property Value

Type: Adm1022ConfLockType
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.ConfigurationD2 Property

IRD

Adm1022ConfigurationD2 Property

Configuration (D2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022ConfD2Type ConfigurationD2 { get; set; }
Public Property ConfigurationD2 As Adm1022ConfD2Type
    Get
    Set
public:
property Adm1022ConfD2Type ConfigurationD2 {
    Adm1022ConfD2Type get ();
    void set (Adm1022ConfD2Type value);
}
member ConfigurationD2 : Adm1022ConfD2Type with get, set

Property Value

Type: Adm1022ConfD2Type
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.ConfigurationFANOFF Property

IRD

Adm1022ConfigurationFANOFF Property

Configuration (FAN OFF)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022ConfFanType ConfigurationFANOFF { get; set; }
Public Property ConfigurationFANOFF As Adm1022ConfFanType
    Get
    Set
public:
property Adm1022ConfFanType ConfigurationFANOFF {
    Adm1022ConfFanType get ();
    void set (Adm1022ConfFanType value);
}
member ConfigurationFANOFF : Adm1022ConfFanType with get, set

Property Value

Type: Adm1022ConfFanType
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.ConfigurationGPIInvert Property

IRD

Adm1022ConfigurationGPIInvert Property

Configuration (GPI Invert)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022ConfInvertType ConfigurationGPIInvert { get; set; }
Public Property ConfigurationGPIInvert As Adm1022ConfInvertType
    Get
    Set
public:
property Adm1022ConfInvertType ConfigurationGPIInvert {
    Adm1022ConfInvertType get ();
    void set (Adm1022ConfInvertType value);
}
member ConfigurationGPIInvert : Adm1022ConfInvertType with get, set

Property Value

Type: Adm1022ConfInvertType
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.ConfigurationINTClear Property

IRD

Adm1022ConfigurationINTClear Property

Configuration (INT Clear)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022ConfClearType ConfigurationINTClear { get; set; }
Public Property ConfigurationINTClear As Adm1022ConfClearType
    Get
    Set
public:
property Adm1022ConfClearType ConfigurationINTClear {
    Adm1022ConfClearType get ();
    void set (Adm1022ConfClearType value);
}
member ConfigurationINTClear : Adm1022ConfClearType with get, set

Property Value

Type: Adm1022ConfClearType
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.ConfigurationINTEnable Property

IRD

Adm1022ConfigurationINTEnable Property

Configuration (INT Enable)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022EnabledDisabledType ConfigurationINTEnable { get; set; }
Public Property ConfigurationINTEnable As Adm1022EnabledDisabledType
    Get
    Set
public:
property Adm1022EnabledDisabledType ConfigurationINTEnable {
    Adm1022EnabledDisabledType get ();
    void set (Adm1022EnabledDisabledType value);
}
member ConfigurationINTEnable : Adm1022EnabledDisabledType with get, set

Property Value

Type: Adm1022EnabledDisabledType
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.ConfigurationSoftReset Property

IRD

Adm1022ConfigurationSoftReset Property

Configuration (Soft Reset)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022ConfResetType ConfigurationSoftReset { get; set; }
Public Property ConfigurationSoftReset As Adm1022ConfResetType
    Get
    Set
public:
property Adm1022ConfResetType ConfigurationSoftReset {
    Adm1022ConfResetType get ();
    void set (Adm1022ConfResetType value);
}
member ConfigurationSoftReset : Adm1022ConfResetType with get, set

Property Value

Type: Adm1022ConfResetType
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.ConfigurationSTART Property

IRD

Adm1022ConfigurationSTART Property

Configuration (START)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022ConfStartType ConfigurationSTART { get; set; }
Public Property ConfigurationSTART As Adm1022ConfStartType
    Get
    Set
public:
property Adm1022ConfStartType ConfigurationSTART {
    Adm1022ConfStartType get ();
    void set (Adm1022ConfStartType value);
}
member ConfigurationSTART : Adm1022ConfStartType with get, set

Property Value

Type: Adm1022ConfStartType
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.DefaultLocalTemperatureTripPoint Property

IRD

Adm1022DefaultLocalTemperatureTripPoint Property

Default Local Temperature Trip Point (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte DefaultLocalTemperatureTripPoint { get; }
Public ReadOnly Property DefaultLocalTemperatureTripPoint As SByte
    Get
public:
property signed char DefaultLocalTemperatureTripPoint {
    signed char get ();
}
member DefaultLocalTemperatureTripPoint : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.DefaultRemoteTemperatureTripPoint Property

IRD

Adm1022DefaultRemoteTemperatureTripPoint Property

Default Remote Temperature Trip Point (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte DefaultRemoteTemperatureTripPoint { get; }
Public ReadOnly Property DefaultRemoteTemperatureTripPoint As SByte
    Get
public:
property signed char DefaultRemoteTemperatureTripPoint {
    signed char get ();
}
member DefaultRemoteTemperatureTripPoint : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.ExternalTemperatureDiode1HighLimit Property

IRD

Adm1022ExternalTemperatureDiode1HighLimit Property

External Temperature Diode 1 High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperatureDiode1HighLimit { get; set; }
Public Property ExternalTemperatureDiode1HighLimit As SByte
    Get
    Set
public:
property signed char ExternalTemperatureDiode1HighLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalTemperatureDiode1HighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.ExternalTemperatureDiode1LowLimit Property

IRD

Adm1022ExternalTemperatureDiode1LowLimit Property

External Temperature Diode 1 Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperatureDiode1LowLimit { get; set; }
Public Property ExternalTemperatureDiode1LowLimit As SByte
    Get
    Set
public:
property signed char ExternalTemperatureDiode1LowLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalTemperatureDiode1LowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.ExternalTemperatureDiode2HighLimit Property

IRD

Adm1022ExternalTemperatureDiode2HighLimit Property

External Temperature Diode 2 High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperatureDiode2HighLimit { get; set; }
Public Property ExternalTemperatureDiode2HighLimit As SByte
    Get
    Set
public:
property signed char ExternalTemperatureDiode2HighLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalTemperatureDiode2HighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.ExternalTemperatureDiode2LowLimit Property

IRD

Adm1022ExternalTemperatureDiode2LowLimit Property

External Temperature Diode 2 Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperatureDiode2LowLimit { get; set; }
Public Property ExternalTemperatureDiode2LowLimit As SByte
    Get
    Set
public:
property signed char ExternalTemperatureDiode2LowLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalTemperatureDiode2LowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.ExternalTemperatureValueDiode1 Property

IRD

Adm1022ExternalTemperatureValueDiode1 Property

External Temperature Value Diode 1 (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperatureValueDiode1 { get; }
Public ReadOnly Property ExternalTemperatureValueDiode1 As SByte
    Get
public:
property signed char ExternalTemperatureValueDiode1 {
    signed char get ();
}
member ExternalTemperatureValueDiode1 : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.ExternalTemperatureValueDiode2 Property

IRD

Adm1022ExternalTemperatureValueDiode2 Property

External Temperature Value Diode 2 (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperatureValueDiode2 { get; }
Public ReadOnly Property ExternalTemperatureValueDiode2 As SByte
    Get
public:
property signed char ExternalTemperatureValueDiode2 {
    signed char get ();
}
member ExternalTemperatureValueDiode2 : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InternalTemperatureHighLimit Property

IRD

Adm1022InternalTemperatureHighLimit Property

Internal Temperature High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureHighLimit { get; set; }
Public Property InternalTemperatureHighLimit As SByte
    Get
    Set
public:
property signed char InternalTemperatureHighLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTemperatureHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InternalTemperatureLowLimit Property

IRD

Adm1022InternalTemperatureLowLimit Property

Internal Temperature Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureLowLimit { get; set; }
Public Property InternalTemperatureLowLimit As SByte
    Get
    Set
public:
property signed char InternalTemperatureLowLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTemperatureLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InternalTemperatureValue Property

IRD

Adm1022InternalTemperatureValue Property

Internal Temperature Value (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureValue { get; }
Public ReadOnly Property InternalTemperatureValue As SByte
    Get
public:
property signed char InternalTemperatureValue {
    signed char get ();
}
member InternalTemperatureValue : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptMaskDiode1Fault Property

IRD

Adm1022InterruptMaskDiode1Fault Property

Interrupt Mask (Diode 1 Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022IrqMaskType InterruptMaskDiode1Fault { get; set; }
Public Property InterruptMaskDiode1Fault As Adm1022IrqMaskType
    Get
    Set
public:
property Adm1022IrqMaskType InterruptMaskDiode1Fault {
    Adm1022IrqMaskType get ();
    void set (Adm1022IrqMaskType value);
}
member InterruptMaskDiode1Fault : Adm1022IrqMaskType with get, set

Property Value

Type: Adm1022IrqMaskType
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptMaskDiode2Fault Property

IRD

Adm1022InterruptMaskDiode2Fault Property

Interrupt Mask (Diode 2 Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022IrqMaskType InterruptMaskDiode2Fault { get; }
Public ReadOnly Property InterruptMaskDiode2Fault As Adm1022IrqMaskType
    Get
public:
property Adm1022IrqMaskType InterruptMaskDiode2Fault {
    Adm1022IrqMaskType get ();
}
member InterruptMaskDiode2Fault : Adm1022IrqMaskType with get

Property Value

Type: Adm1022IrqMaskType
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptMaskExtTemp1Error Property

IRD

Adm1022InterruptMaskExtTemp1Error Property

Interrupt Mask (Ext. Temp 1 Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022IrqMaskType InterruptMaskExtTemp1Error { get; set; }
Public Property InterruptMaskExtTemp1Error As Adm1022IrqMaskType
    Get
    Set
public:
property Adm1022IrqMaskType InterruptMaskExtTemp1Error {
    Adm1022IrqMaskType get ();
    void set (Adm1022IrqMaskType value);
}
member InterruptMaskExtTemp1Error : Adm1022IrqMaskType with get, set

Property Value

Type: Adm1022IrqMaskType
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptMaskExtTemp2Error Property

IRD

Adm1022InterruptMaskExtTemp2Error Property

Interrupt Mask (Ext. Temp 2 Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022IrqMaskType InterruptMaskExtTemp2Error { get; }
Public ReadOnly Property InterruptMaskExtTemp2Error As Adm1022IrqMaskType
    Get
public:
property Adm1022IrqMaskType InterruptMaskExtTemp2Error {
    Adm1022IrqMaskType get ();
}
member InterruptMaskExtTemp2Error : Adm1022IrqMaskType with get

Property Value

Type: Adm1022IrqMaskType
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptMaskGPIInput Property

IRD

Adm1022InterruptMaskGPIInput Property

Interrupt Mask (GPI Input)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022IrqMaskType InterruptMaskGPIInput { get; set; }
Public Property InterruptMaskGPIInput As Adm1022IrqMaskType
    Get
    Set
public:
property Adm1022IrqMaskType InterruptMaskGPIInput {
    Adm1022IrqMaskType get ();
    void set (Adm1022IrqMaskType value);
}
member InterruptMaskGPIInput : Adm1022IrqMaskType with get, set

Property Value

Type: Adm1022IrqMaskType
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptMaskIntTempError Property

IRD

Adm1022InterruptMaskIntTempError Property

Interrupt Mask (Int. Temp Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022IrqMaskType InterruptMaskIntTempError { get; }
Public ReadOnly Property InterruptMaskIntTempError As Adm1022IrqMaskType
    Get
public:
property Adm1022IrqMaskType InterruptMaskIntTempError {
    Adm1022IrqMaskType get ();
}
member InterruptMaskIntTempError : Adm1022IrqMaskType with get

Property Value

Type: Adm1022IrqMaskType
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptMaskTHERMInput Property

IRD

Adm1022InterruptMaskTHERMInput Property

Interrupt Mask (THERM Input)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022IrqMaskType InterruptMaskTHERMInput { get; set; }
Public Property InterruptMaskTHERMInput As Adm1022IrqMaskType
    Get
    Set
public:
property Adm1022IrqMaskType InterruptMaskTHERMInput {
    Adm1022IrqMaskType get ();
    void set (Adm1022IrqMaskType value);
}
member InterruptMaskTHERMInput : Adm1022IrqMaskType with get, set

Property Value

Type: Adm1022IrqMaskType
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptStatusDiode1Fault Property

IRD

Adm1022InterruptStatusDiode1Fault Property

Interrupt Status (Diode 1 Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022Bool InterruptStatusDiode1Fault { get; }
Public ReadOnly Property InterruptStatusDiode1Fault As Adm1022Bool
    Get
public:
property Adm1022Bool InterruptStatusDiode1Fault {
    Adm1022Bool get ();
}
member InterruptStatusDiode1Fault : Adm1022Bool with get

Property Value

Type: Adm1022Bool
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptStatusDiode2Fault Property

IRD

Adm1022InterruptStatusDiode2Fault Property

Interrupt Status (Diode 2 Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022Bool InterruptStatusDiode2Fault { get; }
Public ReadOnly Property InterruptStatusDiode2Fault As Adm1022Bool
    Get
public:
property Adm1022Bool InterruptStatusDiode2Fault {
    Adm1022Bool get ();
}
member InterruptStatusDiode2Fault : Adm1022Bool with get

Property Value

Type: Adm1022Bool
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptStatusExtTemp1Error Property

IRD

Adm1022InterruptStatusExtTemp1Error Property

Interrupt Status (Ext. Temp 1 Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022Bool InterruptStatusExtTemp1Error { get; }
Public ReadOnly Property InterruptStatusExtTemp1Error As Adm1022Bool
    Get
public:
property Adm1022Bool InterruptStatusExtTemp1Error {
    Adm1022Bool get ();
}
member InterruptStatusExtTemp1Error : Adm1022Bool with get

Property Value

Type: Adm1022Bool
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptStatusExtTemp2Error Property

IRD

Adm1022InterruptStatusExtTemp2Error Property

Interrupt Status (Ext. Temp 2 Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022Bool InterruptStatusExtTemp2Error { get; }
Public ReadOnly Property InterruptStatusExtTemp2Error As Adm1022Bool
    Get
public:
property Adm1022Bool InterruptStatusExtTemp2Error {
    Adm1022Bool get ();
}
member InterruptStatusExtTemp2Error : Adm1022Bool with get

Property Value

Type: Adm1022Bool
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptStatusGPIInput Property

IRD

Adm1022InterruptStatusGPIInput Property

Interrupt Status (GPI Input)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022Bool InterruptStatusGPIInput { get; }
Public ReadOnly Property InterruptStatusGPIInput As Adm1022Bool
    Get
public:
property Adm1022Bool InterruptStatusGPIInput {
    Adm1022Bool get ();
}
member InterruptStatusGPIInput : Adm1022Bool with get

Property Value

Type: Adm1022Bool
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptStatusIntTempError Property

IRD

Adm1022InterruptStatusIntTempError Property

Interrupt Status (Int. Temp Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022Bool InterruptStatusIntTempError { get; }
Public ReadOnly Property InterruptStatusIntTempError As Adm1022Bool
    Get
public:
property Adm1022Bool InterruptStatusIntTempError {
    Adm1022Bool get ();
}
member InterruptStatusIntTempError : Adm1022Bool with get

Property Value

Type: Adm1022Bool
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptStatusMirrorDiode1Fault Property

IRD

Adm1022InterruptStatusMirrorDiode1Fault Property

Interrupt Status Mirror (Diode 1 Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022Bool InterruptStatusMirrorDiode1Fault { get; }
Public ReadOnly Property InterruptStatusMirrorDiode1Fault As Adm1022Bool
    Get
public:
property Adm1022Bool InterruptStatusMirrorDiode1Fault {
    Adm1022Bool get ();
}
member InterruptStatusMirrorDiode1Fault : Adm1022Bool with get

Property Value

Type: Adm1022Bool
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptStatusMirrorDiode2Fault Property

IRD

Adm1022InterruptStatusMirrorDiode2Fault Property

Interrupt Status Mirror (Diode 2 Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022Bool InterruptStatusMirrorDiode2Fault { get; }
Public ReadOnly Property InterruptStatusMirrorDiode2Fault As Adm1022Bool
    Get
public:
property Adm1022Bool InterruptStatusMirrorDiode2Fault {
    Adm1022Bool get ();
}
member InterruptStatusMirrorDiode2Fault : Adm1022Bool with get

Property Value

Type: Adm1022Bool
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptStatusMirrorExtTemp1Error Property

IRD

Adm1022InterruptStatusMirrorExtTemp1Error Property

Interrupt Status Mirror (Ext. Temp 1 Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022Bool InterruptStatusMirrorExtTemp1Error { get; }
Public ReadOnly Property InterruptStatusMirrorExtTemp1Error As Adm1022Bool
    Get
public:
property Adm1022Bool InterruptStatusMirrorExtTemp1Error {
    Adm1022Bool get ();
}
member InterruptStatusMirrorExtTemp1Error : Adm1022Bool with get

Property Value

Type: Adm1022Bool
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptStatusMirrorExtTemp2Error Property

IRD

Adm1022InterruptStatusMirrorExtTemp2Error Property

Interrupt Status Mirror (Ext. Temp 2 Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022Bool InterruptStatusMirrorExtTemp2Error { get; }
Public ReadOnly Property InterruptStatusMirrorExtTemp2Error As Adm1022Bool
    Get
public:
property Adm1022Bool InterruptStatusMirrorExtTemp2Error {
    Adm1022Bool get ();
}
member InterruptStatusMirrorExtTemp2Error : Adm1022Bool with get

Property Value

Type: Adm1022Bool
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptStatusMirrorGPIInput Property

IRD

Adm1022InterruptStatusMirrorGPIInput Property

Interrupt Status Mirror (GPI Input)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022Bool InterruptStatusMirrorGPIInput { get; }
Public ReadOnly Property InterruptStatusMirrorGPIInput As Adm1022Bool
    Get
public:
property Adm1022Bool InterruptStatusMirrorGPIInput {
    Adm1022Bool get ();
}
member InterruptStatusMirrorGPIInput : Adm1022Bool with get

Property Value

Type: Adm1022Bool
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptStatusMirrorIntTempError Property

IRD

Adm1022InterruptStatusMirrorIntTempError Property

Interrupt Status Mirror (Int. Temp Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022Bool InterruptStatusMirrorIntTempError { get; }
Public ReadOnly Property InterruptStatusMirrorIntTempError As Adm1022Bool
    Get
public:
property Adm1022Bool InterruptStatusMirrorIntTempError {
    Adm1022Bool get ();
}
member InterruptStatusMirrorIntTempError : Adm1022Bool with get

Property Value

Type: Adm1022Bool
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptStatusMirrorTHERMInput Property

IRD

Adm1022InterruptStatusMirrorTHERMInput Property

Interrupt Status Mirror (THERM Input)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022Bool InterruptStatusMirrorTHERMInput { get; }
Public ReadOnly Property InterruptStatusMirrorTHERMInput As Adm1022Bool
    Get
public:
property Adm1022Bool InterruptStatusMirrorTHERMInput {
    Adm1022Bool get ();
}
member InterruptStatusMirrorTHERMInput : Adm1022Bool with get

Property Value

Type: Adm1022Bool
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.InterruptStatusTHERMInput Property

IRD

Adm1022InterruptStatusTHERMInput Property

Interrupt Status (THERM Input)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1022Bool InterruptStatusTHERMInput { get; }
Public ReadOnly Property InterruptStatusTHERMInput As Adm1022Bool
    Get
public:
property Adm1022Bool InterruptStatusTHERMInput {
    Adm1022Bool get ();
}
member InterruptStatusTHERMInput : Adm1022Bool with get

Property Value

Type: Adm1022Bool
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.LocalTemperatureTripPoint Property

IRD

Adm1022LocalTemperatureTripPoint Property

Local Temperature Trip Point (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTemperatureTripPoint { get; set; }
Public Property LocalTemperatureTripPoint As SByte
    Get
    Set
public:
property signed char LocalTemperatureTripPoint {
    signed char get ();
    void set (signed char value);
}
member LocalTemperatureTripPoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.RemoteTemperatureTripPoint Property

IRD

Adm1022RemoteTemperatureTripPoint Property

Remote Temperature Trip Point (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTemperatureTripPoint { get; set; }
Public Property RemoteTemperatureTripPoint As SByte
    Get
    Set
public:
property signed char RemoteTemperatureTripPoint {
    signed char get ();
    void set (signed char value);
}
member RemoteTemperatureTripPoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.Revision Property

IRD

Adm1022Revision Property

Revision

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Revision { get; }
Public ReadOnly Property Revision As Byte
    Get
public:
property unsigned char Revision {
    unsigned char get ();
}
member Revision : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.Version Property

IRD

Adm1022Version Property

Version

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Version { get; }
Public ReadOnly Property Version As Byte
    Get
public:
property unsigned char Version {
    unsigned char get ();
}
member Version : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022 Methods

The Adm1022 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.Flush Method

IRD

Adm1022Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adm1022 Class
telos.Ird.AnalogDevices Namespace


Adm1022.Bool Enumeration

IRD

Adm1022Bool Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Bool
Public Enumeration Bool
public enum class Bool
type Bool
Members
Member name | Value | Description
True | 1 | True
False | 0 | False
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1022.ConfClearType Enumeration

IRD

Adm1022ConfClearType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfClearType
Public Enumeration ConfClearType
public enum class ConfClearType
type ConfClearType
Members
Member name | Value | Description
Clear | 1 | Clear
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1022.ConfD2Type Enumeration

IRD

Adm1022ConfD2Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfD2Type
Public Enumeration ConfD2Type
public enum class ConfD2Type
type ConfD2Type
Members
Member name | Value | Description
Pin1112DiodeInput | 1 | Pin 11/12: Diode Input
Pin11THERMOutputPin12GPI | 0 | Pin 11: THERM Output / Pin 12: GPI
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1022.ConfFanType Enumeration

IRD

Adm1022ConfFanType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfFanType
Public Enumeration ConfFanType
public enum class ConfFanType
type ConfFanType
Members
Member name | Value | Description
Floating | 1 | Floating
DrivenLow | 0 | Driven Low
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1022.ConfInvertType Enumeration

IRD

Adm1022ConfInvertType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfInvertType
Public Enumeration ConfInvertType
public enum class ConfInvertType
type ConfInvertType
Members
Member name | Value | Description
Invert | 1 | Invert
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1022.ConfLockType Enumeration

IRD

Adm1022ConfLockType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfLockType
Public Enumeration ConfLockType
public enum class ConfLockType
type ConfLockType
Members
Member name | Value | Description
Lock | 1 | Lock
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1022.ConfResetType Enumeration

IRD

Adm1022ConfResetType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfResetType
Public Enumeration ConfResetType
public enum class ConfResetType
type ConfResetType
Members
Member name | Value | Description
Reset | 1 | Reset
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1022.ConfStartType Enumeration

IRD

Adm1022ConfStartType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfStartType
Public Enumeration ConfStartType
public enum class ConfStartType
type ConfStartType
Members
Member name | Value | Description
Startup | 1 | Startup
Standby | 0 | Standby
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1022.EnabledDisabledType Enumeration

IRD

Adm1022EnabledDisabledType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum EnabledDisabledType
Public Enumeration EnabledDisabledType
public enum class EnabledDisabledType
type EnabledDisabledType
Members
Member name | Value | Description
Enabled | 1 | Enabled
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1022.IrqMaskType Enumeration

IRD

Adm1022IrqMaskType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqMaskType
Public Enumeration IrqMaskType
public enum class IrqMaskType
type IrqMaskType
Members
Member name | Value | Description
Disabled | 1 | Disabled
Enabled | 0 | Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1023 Class

Analog Devices: ADM 1023
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdm1023

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adm1023
Public Class Adm1023
public ref class Adm1023
type Adm1023 =  class end

The Adm1023 type exposes the following members.

Constructors
 | Name | Description
Public method | Adm1023 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationMask | Configuration (Mask)
Public property | ConfigurationRunStop | Configuration (Run/Stop)
Public property | ConversionRate | Conversion Rate (unit: Conversion/sec)
Public property | DieRevisionCode | Die Revision Code
Public property | LocalTempHighLimit | Local Temp. High Limit (unit: °C)
Public property | LocalTempLowLimit | Local Temp. Low Limit (unit: °C)
Public property | LocalTempValue | Local Temp. Value (unit: °C)
Public property | ManufacturerDeviceID | Manufacturer Device ID
Public property | RemoteTempHighLimitHighByte | Remote Temp. High Limit High Byte (unit: °C)
Public property | RemoteTempHighLimitLowByte | Remote Temp. High Limit Low Byte (unit: °C)
Public property | RemoteTempLowLimitHighByte | Remote Temp. Low Limit High Byte (unit: °C)
Public property | RemoteTempLowLimitLowByte | Remote Temp. Low Limit Low Byte (unit: °C)
Public property | RemoteTempOffsetHighByte | Remote Temp. Offset High Byte (unit: °C)
Public property | RemoteTempOffsetLowByte | Remote Temp. Offset Low Byte (unit: °C)
Public property | RemoteTempValue | Remote Temp. Value (unit: °C)
Public property | RemoteTempValueLowByte | Remote Temp. Value Low Byte (unit: °C)
Public property | StatusBusy | Status (Busy)
Public property | StatusLocalHighTempLimitTripped | Status (Local High Temp. Limit Tripped)
Public property | StatusLocalLowTempLimitTripped | Status (Local Low Temp. Limit Tripped)
Public property | StatusRemoteHighTempLimitTripped | Status (Remote High Temp. Limit Tripped)
Public property | StatusRemoteLowTempLimitTripped | Status (Remote Low Temp. Limit Tripped)
Public property | StatusRemoteSensorOpen | Status (Remote Sensor Open)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
High Accuracy Temperature Monitor
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1023 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1023(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adm1023(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adm1023

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023 Properties

The Adm1023 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationMask | Configuration (Mask)
Public property | ConfigurationRunStop | Configuration (Run/Stop)
Public property | ConversionRate | Conversion Rate (unit: Conversion/sec)
Public property | DieRevisionCode | Die Revision Code
Public property | LocalTempHighLimit | Local Temp. High Limit (unit: °C)
Public property | LocalTempLowLimit | Local Temp. Low Limit (unit: °C)
Public property | LocalTempValue | Local Temp. Value (unit: °C)
Public property | ManufacturerDeviceID | Manufacturer Device ID
Public property | RemoteTempHighLimitHighByte | Remote Temp. High Limit High Byte (unit: °C)
Public property | RemoteTempHighLimitLowByte | Remote Temp. High Limit Low Byte (unit: °C)
Public property | RemoteTempLowLimitHighByte | Remote Temp. Low Limit High Byte (unit: °C)
Public property | RemoteTempLowLimitLowByte | Remote Temp. Low Limit Low Byte (unit: °C)
Public property | RemoteTempOffsetHighByte | Remote Temp. Offset High Byte (unit: °C)
Public property | RemoteTempOffsetLowByte | Remote Temp. Offset Low Byte (unit: °C)
Public property | RemoteTempValue | Remote Temp. Value (unit: °C)
Public property | RemoteTempValueLowByte | Remote Temp. Value Low Byte (unit: °C)
Public property | StatusBusy | Status (Busy)
Public property | StatusLocalHighTempLimitTripped | Status (Local High Temp. Limit Tripped)
Public property | StatusLocalLowTempLimitTripped | Status (Local Low Temp. Limit Tripped)
Public property | StatusRemoteHighTempLimitTripped | Status (Remote High Temp. Limit Tripped)
Public property | StatusRemoteLowTempLimitTripped | Status (Remote Low Temp. Limit Tripped)
Public property | StatusRemoteSensorOpen | Status (Remote Sensor Open)
Top
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.AutoFlush Property

IRD

Adm1023AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.ConfigurationMask Property

IRD

Adm1023ConfigurationMask Property

Configuration (Mask)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1023ConfigMaskType ConfigurationMask { get; set; }
Public Property ConfigurationMask As Adm1023ConfigMaskType
    Get
    Set
public:
property Adm1023ConfigMaskType ConfigurationMask {
    Adm1023ConfigMaskType get ();
    void set (Adm1023ConfigMaskType value);
}
member ConfigurationMask : Adm1023ConfigMaskType with get, set

Property Value

Type: Adm1023ConfigMaskType
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.ConfigurationRunStop Property

IRD

Adm1023ConfigurationRunStop Property

Configuration (Run/Stop)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1023ConfigRunType ConfigurationRunStop { get; set; }
Public Property ConfigurationRunStop As Adm1023ConfigRunType
    Get
    Set
public:
property Adm1023ConfigRunType ConfigurationRunStop {
    Adm1023ConfigRunType get ();
    void set (Adm1023ConfigRunType value);
}
member ConfigurationRunStop : Adm1023ConfigRunType with get, set

Property Value

Type: Adm1023ConfigRunType
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.ConversionRate Property

IRD

Adm1023ConversionRate Property

Conversion Rate (unit: Conversion/sec)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1023ConversionRateType ConversionRate { get; set; }
Public Property ConversionRate As Adm1023ConversionRateType
    Get
    Set
public:
property Adm1023ConversionRateType ConversionRate {
    Adm1023ConversionRateType get ();
    void set (Adm1023ConversionRateType value);
}
member ConversionRate : Adm1023ConversionRateType with get, set

Property Value

Type: Adm1023ConversionRateType
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.DieRevisionCode Property

IRD

Adm1023DieRevisionCode Property

Die Revision Code

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DieRevisionCode { get; }
Public ReadOnly Property DieRevisionCode As Byte
    Get
public:
property unsigned char DieRevisionCode {
    unsigned char get ();
}
member DieRevisionCode : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.LocalTempHighLimit Property

IRD

Adm1023LocalTempHighLimit Property

Local Temp. High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTempHighLimit { get; set; }
Public Property LocalTempHighLimit As SByte
    Get
    Set
public:
property signed char LocalTempHighLimit {
    signed char get ();
    void set (signed char value);
}
member LocalTempHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.LocalTempLowLimit Property

IRD

Adm1023LocalTempLowLimit Property

Local Temp. Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTempLowLimit { get; set; }
Public Property LocalTempLowLimit As SByte
    Get
    Set
public:
property signed char LocalTempLowLimit {
    signed char get ();
    void set (signed char value);
}
member LocalTempLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.LocalTempValue Property

IRD

Adm1023LocalTempValue Property

Local Temp. Value (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTempValue { get; }
Public ReadOnly Property LocalTempValue As SByte
    Get
public:
property signed char LocalTempValue {
    signed char get ();
}
member LocalTempValue : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.ManufacturerDeviceID Property

IRD

Adm1023ManufacturerDeviceID Property

Manufacturer Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerDeviceID { get; }
Public ReadOnly Property ManufacturerDeviceID As Byte
    Get
public:
property unsigned char ManufacturerDeviceID {
    unsigned char get ();
}
member ManufacturerDeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.RemoteTempHighLimitHighByte Property

IRD

Adm1023RemoteTempHighLimitHighByte Property

Remote Temp. High Limit High Byte (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTempHighLimitHighByte { get; set; }
Public Property RemoteTempHighLimitHighByte As SByte
    Get
    Set
public:
property signed char RemoteTempHighLimitHighByte {
    signed char get ();
    void set (signed char value);
}
member RemoteTempHighLimitHighByte : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.RemoteTempHighLimitLowByte Property

IRD

Adm1023RemoteTempHighLimitLowByte Property

Remote Temp. High Limit Low Byte (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1023TempTypeExt RemoteTempHighLimitLowByte { get; set; }
Public Property RemoteTempHighLimitLowByte As Adm1023TempTypeExt
    Get
    Set
public:
property Adm1023TempTypeExt RemoteTempHighLimitLowByte {
    Adm1023TempTypeExt get ();
    void set (Adm1023TempTypeExt value);
}
member RemoteTempHighLimitLowByte : Adm1023TempTypeExt with get, set

Property Value

Type: Adm1023TempTypeExt
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.RemoteTempLowLimitHighByte Property

IRD

Adm1023RemoteTempLowLimitHighByte Property

Remote Temp. Low Limit High Byte (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTempLowLimitHighByte { get; set; }
Public Property RemoteTempLowLimitHighByte As SByte
    Get
    Set
public:
property signed char RemoteTempLowLimitHighByte {
    signed char get ();
    void set (signed char value);
}
member RemoteTempLowLimitHighByte : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.RemoteTempLowLimitLowByte Property

IRD

Adm1023RemoteTempLowLimitLowByte Property

Remote Temp. Low Limit Low Byte (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1023TempTypeExt RemoteTempLowLimitLowByte { get; set; }
Public Property RemoteTempLowLimitLowByte As Adm1023TempTypeExt
    Get
    Set
public:
property Adm1023TempTypeExt RemoteTempLowLimitLowByte {
    Adm1023TempTypeExt get ();
    void set (Adm1023TempTypeExt value);
}
member RemoteTempLowLimitLowByte : Adm1023TempTypeExt with get, set

Property Value

Type: Adm1023TempTypeExt
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.RemoteTempOffsetHighByte Property

IRD

Adm1023RemoteTempOffsetHighByte Property

Remote Temp. Offset High Byte (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTempOffsetHighByte { get; set; }
Public Property RemoteTempOffsetHighByte As SByte
    Get
    Set
public:
property signed char RemoteTempOffsetHighByte {
    signed char get ();
    void set (signed char value);
}
member RemoteTempOffsetHighByte : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.RemoteTempOffsetLowByte Property

IRD

Adm1023RemoteTempOffsetLowByte Property

Remote Temp. Offset Low Byte (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1023TempTypeExt RemoteTempOffsetLowByte { get; set; }
Public Property RemoteTempOffsetLowByte As Adm1023TempTypeExt
    Get
    Set
public:
property Adm1023TempTypeExt RemoteTempOffsetLowByte {
    Adm1023TempTypeExt get ();
    void set (Adm1023TempTypeExt value);
}
member RemoteTempOffsetLowByte : Adm1023TempTypeExt with get, set

Property Value

Type: Adm1023TempTypeExt
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.RemoteTempValue Property

IRD

Adm1023RemoteTempValue Property

Remote Temp. Value (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTempValue { get; }
Public ReadOnly Property RemoteTempValue As SByte
    Get
public:
property signed char RemoteTempValue {
    signed char get ();
}
member RemoteTempValue : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.RemoteTempValueLowByte Property

IRD

Adm1023RemoteTempValueLowByte Property

Remote Temp. Value Low Byte (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1023TempTypeExt RemoteTempValueLowByte { get; }
Public ReadOnly Property RemoteTempValueLowByte As Adm1023TempTypeExt
    Get
public:
property Adm1023TempTypeExt RemoteTempValueLowByte {
    Adm1023TempTypeExt get ();
}
member RemoteTempValueLowByte : Adm1023TempTypeExt with get

Property Value

Type: Adm1023TempTypeExt
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.StatusBusy Property

IRD

Adm1023StatusBusy Property

Status (Busy)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1023Bool StatusBusy { get; }
Public ReadOnly Property StatusBusy As Adm1023Bool
    Get
public:
property Adm1023Bool StatusBusy {
    Adm1023Bool get ();
}
member StatusBusy : Adm1023Bool with get

Property Value

Type: Adm1023Bool
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.StatusLocalHighTempLimitTripped Property

IRD

Adm1023StatusLocalHighTempLimitTripped Property

Status (Local High Temp. Limit Tripped)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1023Bool StatusLocalHighTempLimitTripped { get; }
Public ReadOnly Property StatusLocalHighTempLimitTripped As Adm1023Bool
    Get
public:
property Adm1023Bool StatusLocalHighTempLimitTripped {
    Adm1023Bool get ();
}
member StatusLocalHighTempLimitTripped : Adm1023Bool with get

Property Value

Type: Adm1023Bool
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.StatusLocalLowTempLimitTripped Property

IRD

Adm1023StatusLocalLowTempLimitTripped Property

Status (Local Low Temp. Limit Tripped)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1023Bool StatusLocalLowTempLimitTripped { get; }
Public ReadOnly Property StatusLocalLowTempLimitTripped As Adm1023Bool
    Get
public:
property Adm1023Bool StatusLocalLowTempLimitTripped {
    Adm1023Bool get ();
}
member StatusLocalLowTempLimitTripped : Adm1023Bool with get

Property Value

Type: Adm1023Bool
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.StatusRemoteHighTempLimitTripped Property

IRD

Adm1023StatusRemoteHighTempLimitTripped Property

Status (Remote High Temp. Limit Tripped)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1023Bool StatusRemoteHighTempLimitTripped { get; }
Public ReadOnly Property StatusRemoteHighTempLimitTripped As Adm1023Bool
    Get
public:
property Adm1023Bool StatusRemoteHighTempLimitTripped {
    Adm1023Bool get ();
}
member StatusRemoteHighTempLimitTripped : Adm1023Bool with get

Property Value

Type: Adm1023Bool
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.StatusRemoteLowTempLimitTripped Property

IRD

Adm1023StatusRemoteLowTempLimitTripped Property

Status (Remote Low Temp. Limit Tripped)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1023Bool StatusRemoteLowTempLimitTripped { get; }
Public ReadOnly Property StatusRemoteLowTempLimitTripped As Adm1023Bool
    Get
public:
property Adm1023Bool StatusRemoteLowTempLimitTripped {
    Adm1023Bool get ();
}
member StatusRemoteLowTempLimitTripped : Adm1023Bool with get

Property Value

Type: Adm1023Bool
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.StatusRemoteSensorOpen Property

IRD

Adm1023StatusRemoteSensorOpen Property

Status (Remote Sensor Open)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1023Bool StatusRemoteSensorOpen { get; }
Public ReadOnly Property StatusRemoteSensorOpen As Adm1023Bool
    Get
public:
property Adm1023Bool StatusRemoteSensorOpen {
    Adm1023Bool get ();
}
member StatusRemoteSensorOpen : Adm1023Bool with get

Property Value

Type: Adm1023Bool
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023 Methods

The Adm1023 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.Flush Method

IRD

Adm1023Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.OneShot Method

IRD

Adm1023OneShot Method

One-Shot

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void OneShot()
Public Sub OneShot
public:
void OneShot()
member OneShot : unit -> unit
See Also

Reference

Adm1023 Class
telos.Ird.AnalogDevices Namespace


Adm1023.Bool Enumeration

IRD

Adm1023Bool Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Bool
Public Enumeration Bool
public enum class Bool
type Bool
Members
Member name | Value | Description
True | 1 | True
False | 0 | False
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1023.ConfigMaskType Enumeration

IRD

Adm1023ConfigMaskType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigMaskType
Public Enumeration ConfigMaskType
public enum class ConfigMaskType
type ConfigMaskType
Members
Member name | Value | Description
ALERTEnabled | 1 | ALERT Enabled
ALERTMasked | 0 | ALERT Masked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1023.ConfigRunType Enumeration

IRD

Adm1023ConfigRunType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigRunType
Public Enumeration ConfigRunType
public enum class ConfigRunType
type ConfigRunType
Members
Member name | Value | Description
Standby | 1 | Standby
Run | 0 | Run
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1023.ConversionRateType Enumeration

IRD

Adm1023ConversionRateType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConversionRateType
Public Enumeration ConversionRateType
public enum class ConversionRateType
type ConversionRateType
Members
Member name | Value | Description
Value_8 | 7 | 8
Value_4 | 6 | 4
Value_2 | 5 | 2
Value_1 | 4 | 1
Value_0_5 | 3 | 0.5
Value_0_25 | 2 | 0.25
Value_0_125 | 1 | 0.125
Value_0_0625 | 0 | 0.0625
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1023.TempTypeExt Enumeration

IRD

Adm1023TempTypeExt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TempTypeExt
Public Enumeration TempTypeExt
public enum class TempTypeExt
type TempTypeExt
Members
Member name | Value | Description
Reserved | 225 | Reserved
Value_0_875 | 224 | 0.875
Reserved__1 | 193 | Reserved
Value_0_750 | 192 | 0.750
Reserved__2 | 161 | Reserved
Value_0_625 | 160 | 0.625
Reserved__3 | 129 | Reserved
Value_0_500 | 128 | 0.500
Reserved__4 | 97 | Reserved
Value_0_375 | 96 | 0.375
Reserved__5 | 65 | Reserved
Value_0_250 | 64 | 0.250
Reserved__6 | 33 | Reserved
Value_0_125 | 32 | 0.125
Reserved__7 | 1 | Reserved
Value_0_000 | 0 | 0.000
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024 Class

Analog Devices: ADM 1024
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdm1024

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adm1024
Public Class Adm1024
public ref class Adm1024
type Adm1024 =  class end

The Adm1024 type exposes the following members.

Constructors
 | Name | Description
Public method | Adm1024 | Constructor
Top
Properties
 | Name | Description
Public property | AIN1LowLimit | AIN1 Low Limit (unit: V)
Public property | AIN2LowLimit | AIN2 Low Limit (unit: V)
Public property | AnalogOutput | Analog Output
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelModeFAN1AIN1 | Channel Mode (FAN1/AIN1)
Public property | ChannelModeFAN2AIN2 | Channel Mode (FAN2/AIN2)
Public property | ChannelModeIntVCC | Channel Mode (Int. V_CC)
Public property | ChannelModeIRQ0EN | Channel Mode (IRQ 0 EN)
Public property | ChannelModeIRQ1EN | Channel Mode (IRQ 1 EN)
Public property | ChannelModeIRQ2EN | Channel Mode (IRQ 2 EN)
Public property | ChannelModeVCPP225VD2 | Channel Mode (V_CPP2, 2.5V / D2)
Public property | ChannelModeVIDIRQ | Channel Mode (VID/IRQ)
Public property | ChassisIntrusionClear | Chassis Intrusion Clear
Public property | CompanyID | Company ID
Public property | Configuration1Initialization | Configuration 1 (Initialization)
Public property | Configuration1INTClear | Configuration 1 (INT Clear)
Public property | Configuration1INTEnable | Configuration 1 (INT Enable)
Public property | Configuration1RESET | Configuration 1 (RESET)
Public property | Configuration1START | Configuration 1 (START)
Public property | Configuration1THERMCLR | Configuration 1 (THERM CLR)
Public property | Configuration1THERMEnable | Configuration 1 (THERM Enable)
Public property | Configuration2AmbientTempFanControl | Configuration 2 (Ambient Temp. Fan Control)
Public property | Configuration2IRQ3EN | Configuration 2 (IRQ3 EN)
Public property | Configuration2IRQ4EN | Configuration 2 (IRQ4 EN)
Public property | Configuration2RemoteTempFanControl | Configuration 2 (Remote Temp. Fan Control)
Public property | Configuration2ThermalINTMask | Configuration 2 (Thermal INT Mask)
Public property | Configuration2THERMInterruptMode | Configuration 2 (THERM Interrupt Mode)
Public property | ExternalTemp1HighLimit | External Temp. 1 High Limit (unit: °C)
Public property | ExternalTemp1LowLimit | External Temp. 1 Low Limit (unit: °C)
Public property | ExternalTemperature1Value | External Temperature 1 Value (unit: °C)
Public property | ExternalTemperatureFixedHardwareTripPoint | External Temperature Fixed Hardware Trip Point (unit: °C)
Public property | ExternalTemperatureHardwareTripPoint | External Temperature Hardware Trip Point (unit: °C)
Public property | FAN1AIN1HighLimit | FAN1/AIN1 High Limit
Public property | FAN1AIN1Value | FAN1/AIN1 Value
Public property | FAN2AIN2HighLimit | FAN2/AIN2 High Limit
Public property | FAN2AIN2Value | FAN2/AIN2 Value
Public property | InternalTemperatureFixedHardwareTripPoint | Internal Temperature Fixed Hardware Trip Point (unit: °C)
Public property | InternalTemperatureHardwareTripPoint | Internal Temperature Hardware Trip Point (unit: °C)
Public property | InternalTemperatureValue | Internal Temperature Value (unit: °C)
Public property | InternalTempHighLimit | Internal Temp. High Limit (unit: °C)
Public property | InternalTempLowLimit | Internal Temp. Low Limit (unit: °C)
Public property | InterruptINTStatus125VExternalTemp2Error | Interrupt INT Status 1 (2.5V / External Temp. 2 Error)
Public property | InterruptINTStatus15VError | Interrupt INT Status 1 (5V Error)
Public property | InterruptINTStatus1ExternalTemp1Error | Interrupt INT Status 1 (External Temp. 1 Error)
Public property | InterruptINTStatus1FAN1AIN1Error | Interrupt INT Status 1 (FAN1/AIN1 Error)
Public property | InterruptINTStatus1FAN2AIN2Error | Interrupt INT Status 1 (FAN2/AIN2 Error)
Public property | InterruptINTStatus1InternalTempError | Interrupt INT Status 1 (Internal Temp. Error)
Public property | InterruptINTStatus1VCCError | Interrupt INT Status 1 (V_CC Error)
Public property | InterruptINTStatus1VCCP1Error | Interrupt INT Status 1 (V_CCP1 Error)
Public property | InterruptINTStatus212VError | Interrupt INT Status 2 (12V Error)
Public property | InterruptINTStatus2ChassisError | Interrupt INT Status 2 (Chassis Error)
Public property | InterruptINTStatus2D1Fault | Interrupt INT Status 2 (D1 Fault)
Public property | InterruptINTStatus2D2Fault | Interrupt INT Status 2 (D2 Fault)
Public property | InterruptINTStatus2THERMInterrupt | Interrupt INT Status 2 (THERM Interrupt)
Public property | InterruptINTStatus2VCCP2Error | Interrupt INT Status 2 (V_CCP2 Error)
Public property | InterruptStatusMirror125VExternalTemp2Error | Interrupt Status Mirror 1 (2.5V / External Temp. 2 Error)
Public property | InterruptStatusMirror15VError | Interrupt Status Mirror 1 (5V Error)
Public property | InterruptStatusMirror1ExternalTemp1Error | Interrupt Status Mirror 1 (External Temp. 1 Error)
Public property | InterruptStatusMirror1FAN1AIN1Error | Interrupt Status Mirror 1 (FAN1/AIN1 Error)
Public property | InterruptStatusMirror1FAN2AIN2Error | Interrupt Status Mirror 1 (FAN2/AIN2 Error)
Public property | InterruptStatusMirror1InternalTempError | Interrupt Status Mirror 1 (Internal Temp. Error)
Public property | InterruptStatusMirror1VCCError | Interrupt Status Mirror 1 (V_CC Error)
Public property | InterruptStatusMirror1VCCP1Error | Interrupt Status Mirror 1 (V_CCP1 Error)
Public property | InterruptStatusMirror212VError | Interrupt Status Mirror 2 (12V Error)
Public property | InterruptStatusMirror2ChassisError | Interrupt Status Mirror 2 (Chassis Error)
Public property | InterruptStatusMirror2D1Fault | Interrupt Status Mirror 2 (D1 Fault)
Public property | InterruptStatusMirror2D2Fault | Interrupt Status Mirror 2 (D2 Fault)
Public property | InterruptStatusMirror2THERMInterrupt | Interrupt Status Mirror 2 (THERM Interrupt)
Public property | InterruptStatusMirror2VCCP2Error | Interrupt Status Mirror 2 (V_CCP2 Error)
Public property | INTMask125VExtTemp2 | INT Mask 1 (2.5V / Ext. Temp. 2)
Public property | INTMask15V | INT Mask 1 (5V)
Public property | INTMask1ExtTemp1 | INT Mask 1 (Ext. Temp. 1)
Public property | INTMask1FAN1AIN1 | INT Mask 1 (FAN1/AIN1)
Public property | INTMask1FAN2AIN2 | INT Mask 1 (FAN2/AIN2)
Public property | INTMask1IntTemp | INT Mask 1 (Int. Temp.)
Public property | INTMask1VCC | INT Mask 1 (V_CC)
Public property | INTMask1VCCP1 | INT Mask 1 (V_CCP1)
Public property | INTMask212V | INT Mask 2 (12V)
Public property | INTMask2CI | INT Mask 2 (CI)
Public property | INTMask2D1Fault | INT Mask 2 (D1 Fault)
Public property | INTMask2D2Fault | INT Mask 2 (D2 Fault)
Public property | INTMask2THERM | INT Mask 2 (THERM)
Public property | INTMask2VCCP2 | INT Mask 2 (V_CCP2)
Public property | Property_12VHighLimit | 12V High Limit (unit: V)
Public property | Property_12VLowLimit | 12V Low Limit (unit: V)
Public property | Property_12VValue | 12V Value (unit: V)
Public property | Property_25VExternalTemp2HighLimit | 2.5V / External Temp. 2 High Limit
Public property | Property_25VExternalTemp2LowLimit | 2.5V / External Temp. 2 Low Limit
Public property | Property_25VValueExternalTemperature2Value | 2.5V Value / External Temperature 2 Value
Public property | Property_5VHighLimit | 5V High Limit (unit: V)
Public property | Property_5VLowLimit | 5V Low Limit (unit: V)
Public property | Property_5VValue | 5V Value (unit: V)
Public property | Revision | Revision
Public property | Test | Test
Public property | VCCHighLimit | V_CC High Limit
Public property | VCCLowLimit | V_CC Low Limit
Public property | VCCP1HighLimit | V_CCP1 High Limit (unit: V)
Public property | VCCP1LowLimit | V_CCP1 Low Limit (unit: V)
Public property | VCCP1Value | V_CCP1 Value (unit: V)
Public property | VCCP2HighLimit | V_CCP2 High Limit (unit: V)
Public property | VCCP2LowLimit | V_CCP2 Low Limit (unit: V)
Public property | VCCP2Value | V_CCP2 Value (unit: V)
Public property | VCCValue | V_CC Value
Public property | VID03FanDivisorFAN1Divisor | VID 0-3 / Fan Divisor (FAN1 Divisor)
Public property | VID03FanDivisorFAN2Divisor | VID 0-3 / Fan Divisor (FAN2 Divisor)
Public property | VID03FanDivisorVID | VID 0-3 / Fan Divisor (VID)
Public property | VID4 | VID 4
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Hardware Monitor
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adm1024(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adm1024

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024 Properties

The Adm1024 type exposes the following members.

Properties
 | Name | Description
Public property | AIN1LowLimit | AIN1 Low Limit (unit: V)
Public property | AIN2LowLimit | AIN2 Low Limit (unit: V)
Public property | AnalogOutput | Analog Output
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelModeFAN1AIN1 | Channel Mode (FAN1/AIN1)
Public property | ChannelModeFAN2AIN2 | Channel Mode (FAN2/AIN2)
Public property | ChannelModeIntVCC | Channel Mode (Int. V_CC)
Public property | ChannelModeIRQ0EN | Channel Mode (IRQ 0 EN)
Public property | ChannelModeIRQ1EN | Channel Mode (IRQ 1 EN)
Public property | ChannelModeIRQ2EN | Channel Mode (IRQ 2 EN)
Public property | ChannelModeVCPP225VD2 | Channel Mode (V_CPP2, 2.5V / D2)
Public property | ChannelModeVIDIRQ | Channel Mode (VID/IRQ)
Public property | ChassisIntrusionClear | Chassis Intrusion Clear
Public property | CompanyID | Company ID
Public property | Configuration1Initialization | Configuration 1 (Initialization)
Public property | Configuration1INTClear | Configuration 1 (INT Clear)
Public property | Configuration1INTEnable | Configuration 1 (INT Enable)
Public property | Configuration1RESET | Configuration 1 (RESET)
Public property | Configuration1START | Configuration 1 (START)
Public property | Configuration1THERMCLR | Configuration 1 (THERM CLR)
Public property | Configuration1THERMEnable | Configuration 1 (THERM Enable)
Public property | Configuration2AmbientTempFanControl | Configuration 2 (Ambient Temp. Fan Control)
Public property | Configuration2IRQ3EN | Configuration 2 (IRQ3 EN)
Public property | Configuration2IRQ4EN | Configuration 2 (IRQ4 EN)
Public property | Configuration2RemoteTempFanControl | Configuration 2 (Remote Temp. Fan Control)
Public property | Configuration2ThermalINTMask | Configuration 2 (Thermal INT Mask)
Public property | Configuration2THERMInterruptMode | Configuration 2 (THERM Interrupt Mode)
Public property | ExternalTemp1HighLimit | External Temp. 1 High Limit (unit: °C)
Public property | ExternalTemp1LowLimit | External Temp. 1 Low Limit (unit: °C)
Public property | ExternalTemperature1Value | External Temperature 1 Value (unit: °C)
Public property | ExternalTemperatureFixedHardwareTripPoint | External Temperature Fixed Hardware Trip Point (unit: °C)
Public property | ExternalTemperatureHardwareTripPoint | External Temperature Hardware Trip Point (unit: °C)
Public property | FAN1AIN1HighLimit | FAN1/AIN1 High Limit
Public property | FAN1AIN1Value | FAN1/AIN1 Value
Public property | FAN2AIN2HighLimit | FAN2/AIN2 High Limit
Public property | FAN2AIN2Value | FAN2/AIN2 Value
Public property | InternalTemperatureFixedHardwareTripPoint | Internal Temperature Fixed Hardware Trip Point (unit: °C)
Public property | InternalTemperatureHardwareTripPoint | Internal Temperature Hardware Trip Point (unit: °C)
Public property | InternalTemperatureValue | Internal Temperature Value (unit: °C)
Public property | InternalTempHighLimit | Internal Temp. High Limit (unit: °C)
Public property | InternalTempLowLimit | Internal Temp. Low Limit (unit: °C)
Public property | InterruptINTStatus125VExternalTemp2Error | Interrupt INT Status 1 (2.5V / External Temp. 2 Error)
Public property | InterruptINTStatus15VError | Interrupt INT Status 1 (5V Error)
Public property | InterruptINTStatus1ExternalTemp1Error | Interrupt INT Status 1 (External Temp. 1 Error)
Public property | InterruptINTStatus1FAN1AIN1Error | Interrupt INT Status 1 (FAN1/AIN1 Error)
Public property | InterruptINTStatus1FAN2AIN2Error | Interrupt INT Status 1 (FAN2/AIN2 Error)
Public property | InterruptINTStatus1InternalTempError | Interrupt INT Status 1 (Internal Temp. Error)
Public property | InterruptINTStatus1VCCError | Interrupt INT Status 1 (V_CC Error)
Public property | InterruptINTStatus1VCCP1Error | Interrupt INT Status 1 (V_CCP1 Error)
Public property | InterruptINTStatus212VError | Interrupt INT Status 2 (12V Error)
Public property | InterruptINTStatus2ChassisError | Interrupt INT Status 2 (Chassis Error)
Public property | InterruptINTStatus2D1Fault | Interrupt INT Status 2 (D1 Fault)
Public property | InterruptINTStatus2D2Fault | Interrupt INT Status 2 (D2 Fault)
Public property | InterruptINTStatus2THERMInterrupt | Interrupt INT Status 2 (THERM Interrupt)
Public property | InterruptINTStatus2VCCP2Error | Interrupt INT Status 2 (V_CCP2 Error)
Public property | InterruptStatusMirror125VExternalTemp2Error | Interrupt Status Mirror 1 (2.5V / External Temp. 2 Error)
Public property | InterruptStatusMirror15VError | Interrupt Status Mirror 1 (5V Error)
Public property | InterruptStatusMirror1ExternalTemp1Error | Interrupt Status Mirror 1 (External Temp. 1 Error)
Public property | InterruptStatusMirror1FAN1AIN1Error | Interrupt Status Mirror 1 (FAN1/AIN1 Error)
Public property | InterruptStatusMirror1FAN2AIN2Error | Interrupt Status Mirror 1 (FAN2/AIN2 Error)
Public property | InterruptStatusMirror1InternalTempError | Interrupt Status Mirror 1 (Internal Temp. Error)
Public property | InterruptStatusMirror1VCCError | Interrupt Status Mirror 1 (V_CC Error)
Public property | InterruptStatusMirror1VCCP1Error | Interrupt Status Mirror 1 (V_CCP1 Error)
Public property | InterruptStatusMirror212VError | Interrupt Status Mirror 2 (12V Error)
Public property | InterruptStatusMirror2ChassisError | Interrupt Status Mirror 2 (Chassis Error)
Public property | InterruptStatusMirror2D1Fault | Interrupt Status Mirror 2 (D1 Fault)
Public property | InterruptStatusMirror2D2Fault | Interrupt Status Mirror 2 (D2 Fault)
Public property | InterruptStatusMirror2THERMInterrupt | Interrupt Status Mirror 2 (THERM Interrupt)
Public property | InterruptStatusMirror2VCCP2Error | Interrupt Status Mirror 2 (V_CCP2 Error)
Public property | INTMask125VExtTemp2 | INT Mask 1 (2.5V / Ext. Temp. 2)
Public property | INTMask15V | INT Mask 1 (5V)
Public property | INTMask1ExtTemp1 | INT Mask 1 (Ext. Temp. 1)
Public property | INTMask1FAN1AIN1 | INT Mask 1 (FAN1/AIN1)
Public property | INTMask1FAN2AIN2 | INT Mask 1 (FAN2/AIN2)
Public property | INTMask1IntTemp | INT Mask 1 (Int. Temp.)
Public property | INTMask1VCC | INT Mask 1 (V_CC)
Public property | INTMask1VCCP1 | INT Mask 1 (V_CCP1)
Public property | INTMask212V | INT Mask 2 (12V)
Public property | INTMask2CI | INT Mask 2 (CI)
Public property | INTMask2D1Fault | INT Mask 2 (D1 Fault)
Public property | INTMask2D2Fault | INT Mask 2 (D2 Fault)
Public property | INTMask2THERM | INT Mask 2 (THERM)
Public property | INTMask2VCCP2 | INT Mask 2 (V_CCP2)
Public property | Property_12VHighLimit | 12V High Limit (unit: V)
Public property | Property_12VLowLimit | 12V Low Limit (unit: V)
Public property | Property_12VValue | 12V Value (unit: V)
Public property | Property_25VExternalTemp2HighLimit | 2.5V / External Temp. 2 High Limit
Public property | Property_25VExternalTemp2LowLimit | 2.5V / External Temp. 2 Low Limit
Public property | Property_25VValueExternalTemperature2Value | 2.5V Value / External Temperature 2 Value
Public property | Property_5VHighLimit | 5V High Limit (unit: V)
Public property | Property_5VLowLimit | 5V Low Limit (unit: V)
Public property | Property_5VValue | 5V Value (unit: V)
Public property | Revision | Revision
Public property | Test | Test
Public property | VCCHighLimit | V_CC High Limit
Public property | VCCLowLimit | V_CC Low Limit
Public property | VCCP1HighLimit | V_CCP1 High Limit (unit: V)
Public property | VCCP1LowLimit | V_CCP1 Low Limit (unit: V)
Public property | VCCP1Value | V_CCP1 Value (unit: V)
Public property | VCCP2HighLimit | V_CCP2 High Limit (unit: V)
Public property | VCCP2LowLimit | V_CCP2 Low Limit (unit: V)
Public property | VCCP2Value | V_CCP2 Value (unit: V)
Public property | VCCValue | V_CC Value
Public property | VID03FanDivisorFAN1Divisor | VID 0-3 / Fan Divisor (FAN1 Divisor)
Public property | VID03FanDivisorFAN2Divisor | VID 0-3 / Fan Divisor (FAN2 Divisor)
Public property | VID03FanDivisorVID | VID 0-3 / Fan Divisor (VID)
Public property | VID4 | VID 4
Top
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.AIN1LowLimit Property

IRD

Adm1024AIN1LowLimit Property

AIN1 Low Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AIN1LowLimit { get; set; }
Public Property AIN1LowLimit As Double
    Get
    Set
public:
property double AIN1LowLimit {
    double get ();
    void set (double value);
}
member AIN1LowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.AIN2LowLimit Property

IRD

Adm1024AIN2LowLimit Property

AIN2 Low Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AIN2LowLimit { get; set; }
Public Property AIN2LowLimit As Double
    Get
    Set
public:
property double AIN2LowLimit {
    double get ();
    void set (double value);
}
member AIN2LowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.AnalogOutput Property

IRD

Adm1024AnalogOutput Property

Analog Output

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AnalogOutput { get; set; }
Public Property AnalogOutput As Byte
    Get
    Set
public:
property unsigned char AnalogOutput {
    unsigned char get ();
    void set (unsigned char value);
}
member AnalogOutput : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.AutoFlush Property

IRD

Adm1024AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.ChannelModeFAN1AIN1 Property

IRD

Adm1024ChannelModeFAN1AIN1 Property

Channel Mode (FAN1/AIN1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024ChannelFan1Type ChannelModeFAN1AIN1 { get; set; }
Public Property ChannelModeFAN1AIN1 As Adm1024ChannelFan1Type
    Get
    Set
public:
property Adm1024ChannelFan1Type ChannelModeFAN1AIN1 {
    Adm1024ChannelFan1Type get ();
    void set (Adm1024ChannelFan1Type value);
}
member ChannelModeFAN1AIN1 : Adm1024ChannelFan1Type with get, set

Property Value

Type: Adm1024ChannelFan1Type
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.ChannelModeFAN2AIN2 Property

IRD

Adm1024ChannelModeFAN2AIN2 Property

Channel Mode (FAN2/AIN2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024ChannelFan2Type ChannelModeFAN2AIN2 { get; set; }
Public Property ChannelModeFAN2AIN2 As Adm1024ChannelFan2Type
    Get
    Set
public:
property Adm1024ChannelFan2Type ChannelModeFAN2AIN2 {
    Adm1024ChannelFan2Type get ();
    void set (Adm1024ChannelFan2Type value);
}
member ChannelModeFAN2AIN2 : Adm1024ChannelFan2Type with get, set

Property Value

Type: Adm1024ChannelFan2Type
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.ChannelModeIntVCC Property

IRD

Adm1024ChannelModeIntVCC Property

Channel Mode (Int. V_CC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024ChannelIntVccType ChannelModeIntVCC { get; set; }
Public Property ChannelModeIntVCC As Adm1024ChannelIntVccType
    Get
    Set
public:
property Adm1024ChannelIntVccType ChannelModeIntVCC {
    Adm1024ChannelIntVccType get ();
    void set (Adm1024ChannelIntVccType value);
}
member ChannelModeIntVCC : Adm1024ChannelIntVccType with get, set

Property Value

Type: Adm1024ChannelIntVccType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.ChannelModeIRQ0EN Property

IRD

Adm1024ChannelModeIRQ0EN Property

Channel Mode (IRQ 0 EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024EnabledDisabledType ChannelModeIRQ0EN { get; set; }
Public Property ChannelModeIRQ0EN As Adm1024EnabledDisabledType
    Get
    Set
public:
property Adm1024EnabledDisabledType ChannelModeIRQ0EN {
    Adm1024EnabledDisabledType get ();
    void set (Adm1024EnabledDisabledType value);
}
member ChannelModeIRQ0EN : Adm1024EnabledDisabledType with get, set

Property Value

Type: Adm1024EnabledDisabledType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.ChannelModeIRQ1EN Property

IRD

Adm1024ChannelModeIRQ1EN Property

Channel Mode (IRQ 1 EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024EnabledDisabledType ChannelModeIRQ1EN { get; set; }
Public Property ChannelModeIRQ1EN As Adm1024EnabledDisabledType
    Get
    Set
public:
property Adm1024EnabledDisabledType ChannelModeIRQ1EN {
    Adm1024EnabledDisabledType get ();
    void set (Adm1024EnabledDisabledType value);
}
member ChannelModeIRQ1EN : Adm1024EnabledDisabledType with get, set

Property Value

Type: Adm1024EnabledDisabledType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.ChannelModeIRQ2EN Property

IRD

Adm1024ChannelModeIRQ2EN Property

Channel Mode (IRQ 2 EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024EnabledDisabledType ChannelModeIRQ2EN { get; set; }
Public Property ChannelModeIRQ2EN As Adm1024EnabledDisabledType
    Get
    Set
public:
property Adm1024EnabledDisabledType ChannelModeIRQ2EN {
    Adm1024EnabledDisabledType get ();
    void set (Adm1024EnabledDisabledType value);
}
member ChannelModeIRQ2EN : Adm1024EnabledDisabledType with get, set

Property Value

Type: Adm1024EnabledDisabledType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.ChannelModeVCPP225VD2 Property

IRD

Adm1024ChannelModeVCPP225VD2 Property

Channel Mode (V_CPP2, 2.5V / D2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024Channel25Type ChannelModeVCPP225VD2 { get; set; }
Public Property ChannelModeVCPP225VD2 As Adm1024Channel25Type
    Get
    Set
public:
property Adm1024Channel25Type ChannelModeVCPP225VD2 {
    Adm1024Channel25Type get ();
    void set (Adm1024Channel25Type value);
}
member ChannelModeVCPP225VD2 : Adm1024Channel25Type with get, set

Property Value

Type: Adm1024Channel25Type
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.ChannelModeVIDIRQ Property

IRD

Adm1024ChannelModeVIDIRQ Property

Channel Mode (VID/IRQ)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024ChannelVidType ChannelModeVIDIRQ { get; set; }
Public Property ChannelModeVIDIRQ As Adm1024ChannelVidType
    Get
    Set
public:
property Adm1024ChannelVidType ChannelModeVIDIRQ {
    Adm1024ChannelVidType get ();
    void set (Adm1024ChannelVidType value);
}
member ChannelModeVIDIRQ : Adm1024ChannelVidType with get, set

Property Value

Type: Adm1024ChannelVidType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.ChassisIntrusionClear Property

IRD

Adm1024ChassisIntrusionClear Property

Chassis Intrusion Clear

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024CiClearType ChassisIntrusionClear { get; set; }
Public Property ChassisIntrusionClear As Adm1024CiClearType
    Get
    Set
public:
property Adm1024CiClearType ChassisIntrusionClear {
    Adm1024CiClearType get ();
    void set (Adm1024CiClearType value);
}
member ChassisIntrusionClear : Adm1024CiClearType with get, set

Property Value

Type: Adm1024CiClearType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.CompanyID Property

IRD

Adm1024CompanyID Property

Company ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CompanyID { get; }
Public ReadOnly Property CompanyID As Byte
    Get
public:
property unsigned char CompanyID {
    unsigned char get ();
}
member CompanyID : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Configuration1Initialization Property

IRD

Adm1024Configuration1Initialization Property

Configuration 1 (Initialization)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024ConfInitType Configuration1Initialization { get; set; }
Public Property Configuration1Initialization As Adm1024ConfInitType
    Get
    Set
public:
property Adm1024ConfInitType Configuration1Initialization {
    Adm1024ConfInitType get ();
    void set (Adm1024ConfInitType value);
}
member Configuration1Initialization : Adm1024ConfInitType with get, set

Property Value

Type: Adm1024ConfInitType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Configuration1INTClear Property

IRD

Adm1024Configuration1INTClear Property

Configuration 1 (INT Clear)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024ConfClearType Configuration1INTClear { get; set; }
Public Property Configuration1INTClear As Adm1024ConfClearType
    Get
    Set
public:
property Adm1024ConfClearType Configuration1INTClear {
    Adm1024ConfClearType get ();
    void set (Adm1024ConfClearType value);
}
member Configuration1INTClear : Adm1024ConfClearType with get, set

Property Value

Type: Adm1024ConfClearType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Configuration1INTEnable Property

IRD

Adm1024Configuration1INTEnable Property

Configuration 1 (INT Enable)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024EnabledDisabledType Configuration1INTEnable { get; set; }
Public Property Configuration1INTEnable As Adm1024EnabledDisabledType
    Get
    Set
public:
property Adm1024EnabledDisabledType Configuration1INTEnable {
    Adm1024EnabledDisabledType get ();
    void set (Adm1024EnabledDisabledType value);
}
member Configuration1INTEnable : Adm1024EnabledDisabledType with get, set

Property Value

Type: Adm1024EnabledDisabledType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Configuration1RESET Property

IRD

Adm1024Configuration1RESET Property

Configuration 1 (RESET)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024ConfResetType Configuration1RESET { get; set; }
Public Property Configuration1RESET As Adm1024ConfResetType
    Get
    Set
public:
property Adm1024ConfResetType Configuration1RESET {
    Adm1024ConfResetType get ();
    void set (Adm1024ConfResetType value);
}
member Configuration1RESET : Adm1024ConfResetType with get, set

Property Value

Type: Adm1024ConfResetType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Configuration1START Property

IRD

Adm1024Configuration1START Property

Configuration 1 (START)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024ConfStartType Configuration1START { get; set; }
Public Property Configuration1START As Adm1024ConfStartType
    Get
    Set
public:
property Adm1024ConfStartType Configuration1START {
    Adm1024ConfStartType get ();
    void set (Adm1024ConfStartType value);
}
member Configuration1START : Adm1024ConfStartType with get, set

Property Value

Type: Adm1024ConfStartType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Configuration1THERMCLR Property

IRD

Adm1024Configuration1THERMCLR Property

Configuration 1 (THERM CLR)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024ConfClearType Configuration1THERMCLR { get; set; }
Public Property Configuration1THERMCLR As Adm1024ConfClearType
    Get
    Set
public:
property Adm1024ConfClearType Configuration1THERMCLR {
    Adm1024ConfClearType get ();
    void set (Adm1024ConfClearType value);
}
member Configuration1THERMCLR : Adm1024ConfClearType with get, set

Property Value

Type: Adm1024ConfClearType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Configuration1THERMEnable Property

IRD

Adm1024Configuration1THERMEnable Property

Configuration 1 (THERM Enable)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024EnabledDisabledType Configuration1THERMEnable { get; set; }
Public Property Configuration1THERMEnable As Adm1024EnabledDisabledType
    Get
    Set
public:
property Adm1024EnabledDisabledType Configuration1THERMEnable {
    Adm1024EnabledDisabledType get ();
    void set (Adm1024EnabledDisabledType value);
}
member Configuration1THERMEnable : Adm1024EnabledDisabledType with get, set

Property Value

Type: Adm1024EnabledDisabledType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Configuration2AmbientTempFanControl Property

IRD

Adm1024Configuration2AmbientTempFanControl Property

Configuration 2 (Ambient Temp. Fan Control)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024Conf2LockType Configuration2AmbientTempFanControl { get; set; }
Public Property Configuration2AmbientTempFanControl As Adm1024Conf2LockType
    Get
    Set
public:
property Adm1024Conf2LockType Configuration2AmbientTempFanControl {
    Adm1024Conf2LockType get ();
    void set (Adm1024Conf2LockType value);
}
member Configuration2AmbientTempFanControl : Adm1024Conf2LockType with get, set

Property Value

Type: Adm1024Conf2LockType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Configuration2IRQ3EN Property

IRD

Adm1024Configuration2IRQ3EN Property

Configuration 2 (IRQ3 EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024EnabledDisabledType Configuration2IRQ3EN { get; set; }
Public Property Configuration2IRQ3EN As Adm1024EnabledDisabledType
    Get
    Set
public:
property Adm1024EnabledDisabledType Configuration2IRQ3EN {
    Adm1024EnabledDisabledType get ();
    void set (Adm1024EnabledDisabledType value);
}
member Configuration2IRQ3EN : Adm1024EnabledDisabledType with get, set

Property Value

Type: Adm1024EnabledDisabledType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Configuration2IRQ4EN Property

IRD

Adm1024Configuration2IRQ4EN Property

Configuration 2 (IRQ4 EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024EnabledDisabledType Configuration2IRQ4EN { get; set; }
Public Property Configuration2IRQ4EN As Adm1024EnabledDisabledType
    Get
    Set
public:
property Adm1024EnabledDisabledType Configuration2IRQ4EN {
    Adm1024EnabledDisabledType get ();
    void set (Adm1024EnabledDisabledType value);
}
member Configuration2IRQ4EN : Adm1024EnabledDisabledType with get, set

Property Value

Type: Adm1024EnabledDisabledType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Configuration2RemoteTempFanControl Property

IRD

Adm1024Configuration2RemoteTempFanControl Property

Configuration 2 (Remote Temp. Fan Control)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024Conf2LockType Configuration2RemoteTempFanControl { get; set; }
Public Property Configuration2RemoteTempFanControl As Adm1024Conf2LockType
    Get
    Set
public:
property Adm1024Conf2LockType Configuration2RemoteTempFanControl {
    Adm1024Conf2LockType get ();
    void set (Adm1024Conf2LockType value);
}
member Configuration2RemoteTempFanControl : Adm1024Conf2LockType with get, set

Property Value

Type: Adm1024Conf2LockType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Configuration2ThermalINTMask Property

IRD

Adm1024Configuration2ThermalINTMask Property

Configuration 2 (Thermal INT Mask)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024Conf2ThermIrqMaskType Configuration2ThermalINTMask { get; set; }
Public Property Configuration2ThermalINTMask As Adm1024Conf2ThermIrqMaskType
    Get
    Set
public:
property Adm1024Conf2ThermIrqMaskType Configuration2ThermalINTMask {
    Adm1024Conf2ThermIrqMaskType get ();
    void set (Adm1024Conf2ThermIrqMaskType value);
}
member Configuration2ThermalINTMask : Adm1024Conf2ThermIrqMaskType with get, set

Property Value

Type: Adm1024Conf2ThermIrqMaskType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Configuration2THERMInterruptMode Property

IRD

Adm1024Configuration2THERMInterruptMode Property

Configuration 2 (THERM Interrupt Mode)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024Conf2ThermIrqType Configuration2THERMInterruptMode { get; set; }
Public Property Configuration2THERMInterruptMode As Adm1024Conf2ThermIrqType
    Get
    Set
public:
property Adm1024Conf2ThermIrqType Configuration2THERMInterruptMode {
    Adm1024Conf2ThermIrqType get ();
    void set (Adm1024Conf2ThermIrqType value);
}
member Configuration2THERMInterruptMode : Adm1024Conf2ThermIrqType with get, set

Property Value

Type: Adm1024Conf2ThermIrqType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.ExternalTemp1HighLimit Property

IRD

Adm1024ExternalTemp1HighLimit Property

External Temp. 1 High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemp1HighLimit { get; set; }
Public Property ExternalTemp1HighLimit As SByte
    Get
    Set
public:
property signed char ExternalTemp1HighLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalTemp1HighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.ExternalTemp1LowLimit Property

IRD

Adm1024ExternalTemp1LowLimit Property

External Temp. 1 Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemp1LowLimit { get; set; }
Public Property ExternalTemp1LowLimit As SByte
    Get
    Set
public:
property signed char ExternalTemp1LowLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalTemp1LowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.ExternalTemperature1Value Property

IRD

Adm1024ExternalTemperature1Value Property

External Temperature 1 Value (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperature1Value { get; }
Public ReadOnly Property ExternalTemperature1Value As SByte
    Get
public:
property signed char ExternalTemperature1Value {
    signed char get ();
}
member ExternalTemperature1Value : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.ExternalTemperatureFixedHardwareTripPoint Property

IRD

Adm1024ExternalTemperatureFixedHardwareTripPoint Property

External Temperature Fixed Hardware Trip Point (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperatureFixedHardwareTripPoint { get; }
Public ReadOnly Property ExternalTemperatureFixedHardwareTripPoint As SByte
    Get
public:
property signed char ExternalTemperatureFixedHardwareTripPoint {
    signed char get ();
}
member ExternalTemperatureFixedHardwareTripPoint : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.ExternalTemperatureHardwareTripPoint Property

IRD

Adm1024ExternalTemperatureHardwareTripPoint Property

External Temperature Hardware Trip Point (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperatureHardwareTripPoint { get; set; }
Public Property ExternalTemperatureHardwareTripPoint As SByte
    Get
    Set
public:
property signed char ExternalTemperatureHardwareTripPoint {
    signed char get ();
    void set (signed char value);
}
member ExternalTemperatureHardwareTripPoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.FAN1AIN1HighLimit Property

IRD

Adm1024FAN1AIN1HighLimit Property

FAN1/AIN1 High Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FAN1AIN1HighLimit { get; set; }
Public Property FAN1AIN1HighLimit As Byte
    Get
    Set
public:
property unsigned char FAN1AIN1HighLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member FAN1AIN1HighLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.FAN1AIN1Value Property

IRD

Adm1024FAN1AIN1Value Property

FAN1/AIN1 Value

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FAN1AIN1Value { get; }
Public ReadOnly Property FAN1AIN1Value As Byte
    Get
public:
property unsigned char FAN1AIN1Value {
    unsigned char get ();
}
member FAN1AIN1Value : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.FAN2AIN2HighLimit Property

IRD

Adm1024FAN2AIN2HighLimit Property

FAN2/AIN2 High Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FAN2AIN2HighLimit { get; set; }
Public Property FAN2AIN2HighLimit As Byte
    Get
    Set
public:
property unsigned char FAN2AIN2HighLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member FAN2AIN2HighLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.FAN2AIN2Value Property

IRD

Adm1024FAN2AIN2Value Property

FAN2/AIN2 Value

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FAN2AIN2Value { get; }
Public ReadOnly Property FAN2AIN2Value As Byte
    Get
public:
property unsigned char FAN2AIN2Value {
    unsigned char get ();
}
member FAN2AIN2Value : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InternalTemperatureFixedHardwareTripPoint Property

IRD

Adm1024InternalTemperatureFixedHardwareTripPoint Property

Internal Temperature Fixed Hardware Trip Point (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureFixedHardwareTripPoint { get; }
Public ReadOnly Property InternalTemperatureFixedHardwareTripPoint As SByte
    Get
public:
property signed char InternalTemperatureFixedHardwareTripPoint {
    signed char get ();
}
member InternalTemperatureFixedHardwareTripPoint : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InternalTemperatureHardwareTripPoint Property

IRD

Adm1024InternalTemperatureHardwareTripPoint Property

Internal Temperature Hardware Trip Point (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureHardwareTripPoint { get; set; }
Public Property InternalTemperatureHardwareTripPoint As SByte
    Get
    Set
public:
property signed char InternalTemperatureHardwareTripPoint {
    signed char get ();
    void set (signed char value);
}
member InternalTemperatureHardwareTripPoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InternalTemperatureValue Property

IRD

Adm1024InternalTemperatureValue Property

Internal Temperature Value (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureValue { get; }
Public ReadOnly Property InternalTemperatureValue As SByte
    Get
public:
property signed char InternalTemperatureValue {
    signed char get ();
}
member InternalTemperatureValue : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InternalTempHighLimit Property

IRD

Adm1024InternalTempHighLimit Property

Internal Temp. High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTempHighLimit { get; set; }
Public Property InternalTempHighLimit As SByte
    Get
    Set
public:
property signed char InternalTempHighLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTempHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InternalTempLowLimit Property

IRD

Adm1024InternalTempLowLimit Property

Internal Temp. Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTempLowLimit { get; set; }
Public Property InternalTempLowLimit As SByte
    Get
    Set
public:
property signed char InternalTempLowLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTempLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptINTStatus125VExternalTemp2Error Property

IRD

Adm1024InterruptINTStatus125VExternalTemp2Error Property

Interrupt INT Status 1 (2.5V / External Temp. 2 Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptINTStatus125VExternalTemp2Error { get; }
Public ReadOnly Property InterruptINTStatus125VExternalTemp2Error As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptINTStatus125VExternalTemp2Error {
    Adm1024HighLowExceededType get ();
}
member InterruptINTStatus125VExternalTemp2Error : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptINTStatus15VError Property

IRD

Adm1024InterruptINTStatus15VError Property

Interrupt INT Status 1 (5V Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptINTStatus15VError { get; }
Public ReadOnly Property InterruptINTStatus15VError As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptINTStatus15VError {
    Adm1024HighLowExceededType get ();
}
member InterruptINTStatus15VError : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptINTStatus1ExternalTemp1Error Property

IRD

Adm1024InterruptINTStatus1ExternalTemp1Error Property

Interrupt INT Status 1 (External Temp. 1 Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptINTStatus1ExternalTemp1Error { get; }
Public ReadOnly Property InterruptINTStatus1ExternalTemp1Error As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptINTStatus1ExternalTemp1Error {
    Adm1024HighLowExceededType get ();
}
member InterruptINTStatus1ExternalTemp1Error : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptINTStatus1FAN1AIN1Error Property

IRD

Adm1024InterruptINTStatus1FAN1AIN1Error Property

Interrupt INT Status 1 (FAN1/AIN1 Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptINTStatus1FAN1AIN1Error { get; }
Public ReadOnly Property InterruptINTStatus1FAN1AIN1Error As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptINTStatus1FAN1AIN1Error {
    Adm1024HighLowExceededType get ();
}
member InterruptINTStatus1FAN1AIN1Error : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptINTStatus1FAN2AIN2Error Property

IRD

Adm1024InterruptINTStatus1FAN2AIN2Error Property

Interrupt INT Status 1 (FAN2/AIN2 Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptINTStatus1FAN2AIN2Error { get; }
Public ReadOnly Property InterruptINTStatus1FAN2AIN2Error As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptINTStatus1FAN2AIN2Error {
    Adm1024HighLowExceededType get ();
}
member InterruptINTStatus1FAN2AIN2Error : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptINTStatus1InternalTempError Property

IRD

Adm1024InterruptINTStatus1InternalTempError Property

Interrupt INT Status 1 (Internal Temp. Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptINTStatus1InternalTempError { get; }
Public ReadOnly Property InterruptINTStatus1InternalTempError As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptINTStatus1InternalTempError {
    Adm1024HighLowExceededType get ();
}
member InterruptINTStatus1InternalTempError : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptINTStatus1VCCError Property

IRD

Adm1024InterruptINTStatus1VCCError Property

Interrupt INT Status 1 (V_CC Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptINTStatus1VCCError { get; }
Public ReadOnly Property InterruptINTStatus1VCCError As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptINTStatus1VCCError {
    Adm1024HighLowExceededType get ();
}
member InterruptINTStatus1VCCError : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptINTStatus1VCCP1Error Property

IRD

Adm1024InterruptINTStatus1VCCP1Error Property

Interrupt INT Status 1 (V_CCP1 Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptINTStatus1VCCP1Error { get; }
Public ReadOnly Property InterruptINTStatus1VCCP1Error As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptINTStatus1VCCP1Error {
    Adm1024HighLowExceededType get ();
}
member InterruptINTStatus1VCCP1Error : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptINTStatus212VError Property

IRD

Adm1024InterruptINTStatus212VError Property

Interrupt INT Status 2 (12V Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptINTStatus212VError { get; }
Public ReadOnly Property InterruptINTStatus212VError As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptINTStatus212VError {
    Adm1024HighLowExceededType get ();
}
member InterruptINTStatus212VError : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptINTStatus2ChassisError Property

IRD

Adm1024InterruptINTStatus2ChassisError Property

Interrupt INT Status 2 (Chassis Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqStatusChassisType InterruptINTStatus2ChassisError { get; }
Public ReadOnly Property InterruptINTStatus2ChassisError As Adm1024IrqStatusChassisType
    Get
public:
property Adm1024IrqStatusChassisType InterruptINTStatus2ChassisError {
    Adm1024IrqStatusChassisType get ();
}
member InterruptINTStatus2ChassisError : Adm1024IrqStatusChassisType with get

Property Value

Type: Adm1024IrqStatusChassisType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptINTStatus2D1Fault Property

IRD

Adm1024InterruptINTStatus2D1Fault Property

Interrupt INT Status 2 (D1 Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqStatusDiodeType InterruptINTStatus2D1Fault { get; }
Public ReadOnly Property InterruptINTStatus2D1Fault As Adm1024IrqStatusDiodeType
    Get
public:
property Adm1024IrqStatusDiodeType InterruptINTStatus2D1Fault {
    Adm1024IrqStatusDiodeType get ();
}
member InterruptINTStatus2D1Fault : Adm1024IrqStatusDiodeType with get

Property Value

Type: Adm1024IrqStatusDiodeType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptINTStatus2D2Fault Property

IRD

Adm1024InterruptINTStatus2D2Fault Property

Interrupt INT Status 2 (D2 Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqStatusDiodeType InterruptINTStatus2D2Fault { get; }
Public ReadOnly Property InterruptINTStatus2D2Fault As Adm1024IrqStatusDiodeType
    Get
public:
property Adm1024IrqStatusDiodeType InterruptINTStatus2D2Fault {
    Adm1024IrqStatusDiodeType get ();
}
member InterruptINTStatus2D2Fault : Adm1024IrqStatusDiodeType with get

Property Value

Type: Adm1024IrqStatusDiodeType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptINTStatus2THERMInterrupt Property

IRD

Adm1024InterruptINTStatus2THERMInterrupt Property

Interrupt INT Status 2 (THERM Interrupt)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqStatusThermType InterruptINTStatus2THERMInterrupt { get; }
Public ReadOnly Property InterruptINTStatus2THERMInterrupt As Adm1024IrqStatusThermType
    Get
public:
property Adm1024IrqStatusThermType InterruptINTStatus2THERMInterrupt {
    Adm1024IrqStatusThermType get ();
}
member InterruptINTStatus2THERMInterrupt : Adm1024IrqStatusThermType with get

Property Value

Type: Adm1024IrqStatusThermType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptINTStatus2VCCP2Error Property

IRD

Adm1024InterruptINTStatus2VCCP2Error Property

Interrupt INT Status 2 (V_CCP2 Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptINTStatus2VCCP2Error { get; }
Public ReadOnly Property InterruptINTStatus2VCCP2Error As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptINTStatus2VCCP2Error {
    Adm1024HighLowExceededType get ();
}
member InterruptINTStatus2VCCP2Error : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptStatusMirror125VExternalTemp2Error Property

IRD

Adm1024InterruptStatusMirror125VExternalTemp2Error Property

Interrupt Status Mirror 1 (2.5V / External Temp. 2 Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptStatusMirror125VExternalTemp2Error { get; }
Public ReadOnly Property InterruptStatusMirror125VExternalTemp2Error As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptStatusMirror125VExternalTemp2Error {
    Adm1024HighLowExceededType get ();
}
member InterruptStatusMirror125VExternalTemp2Error : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptStatusMirror15VError Property

IRD

Adm1024InterruptStatusMirror15VError Property

Interrupt Status Mirror 1 (5V Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptStatusMirror15VError { get; }
Public ReadOnly Property InterruptStatusMirror15VError As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptStatusMirror15VError {
    Adm1024HighLowExceededType get ();
}
member InterruptStatusMirror15VError : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptStatusMirror1ExternalTemp1Error Property

IRD

Adm1024InterruptStatusMirror1ExternalTemp1Error Property

Interrupt Status Mirror 1 (External Temp. 1 Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptStatusMirror1ExternalTemp1Error { get; }
Public ReadOnly Property InterruptStatusMirror1ExternalTemp1Error As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptStatusMirror1ExternalTemp1Error {
    Adm1024HighLowExceededType get ();
}
member InterruptStatusMirror1ExternalTemp1Error : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptStatusMirror1FAN1AIN1Error Property

IRD

Adm1024InterruptStatusMirror1FAN1AIN1Error Property

Interrupt Status Mirror 1 (FAN1/AIN1 Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptStatusMirror1FAN1AIN1Error { get; }
Public ReadOnly Property InterruptStatusMirror1FAN1AIN1Error As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptStatusMirror1FAN1AIN1Error {
    Adm1024HighLowExceededType get ();
}
member InterruptStatusMirror1FAN1AIN1Error : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptStatusMirror1FAN2AIN2Error Property

IRD

Adm1024InterruptStatusMirror1FAN2AIN2Error Property

Interrupt Status Mirror 1 (FAN2/AIN2 Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptStatusMirror1FAN2AIN2Error { get; }
Public ReadOnly Property InterruptStatusMirror1FAN2AIN2Error As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptStatusMirror1FAN2AIN2Error {
    Adm1024HighLowExceededType get ();
}
member InterruptStatusMirror1FAN2AIN2Error : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptStatusMirror1InternalTempError Property

IRD

Adm1024InterruptStatusMirror1InternalTempError Property

Interrupt Status Mirror 1 (Internal Temp. Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptStatusMirror1InternalTempError { get; }
Public ReadOnly Property InterruptStatusMirror1InternalTempError As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptStatusMirror1InternalTempError {
    Adm1024HighLowExceededType get ();
}
member InterruptStatusMirror1InternalTempError : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptStatusMirror1VCCError Property

IRD

Adm1024InterruptStatusMirror1VCCError Property

Interrupt Status Mirror 1 (V_CC Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptStatusMirror1VCCError { get; }
Public ReadOnly Property InterruptStatusMirror1VCCError As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptStatusMirror1VCCError {
    Adm1024HighLowExceededType get ();
}
member InterruptStatusMirror1VCCError : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptStatusMirror1VCCP1Error Property

IRD

Adm1024InterruptStatusMirror1VCCP1Error Property

Interrupt Status Mirror 1 (V_CCP1 Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptStatusMirror1VCCP1Error { get; }
Public ReadOnly Property InterruptStatusMirror1VCCP1Error As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptStatusMirror1VCCP1Error {
    Adm1024HighLowExceededType get ();
}
member InterruptStatusMirror1VCCP1Error : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptStatusMirror212VError Property

IRD

Adm1024InterruptStatusMirror212VError Property

Interrupt Status Mirror 2 (12V Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptStatusMirror212VError { get; }
Public ReadOnly Property InterruptStatusMirror212VError As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptStatusMirror212VError {
    Adm1024HighLowExceededType get ();
}
member InterruptStatusMirror212VError : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptStatusMirror2ChassisError Property

IRD

Adm1024InterruptStatusMirror2ChassisError Property

Interrupt Status Mirror 2 (Chassis Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqStatusChassisType InterruptStatusMirror2ChassisError { get; }
Public ReadOnly Property InterruptStatusMirror2ChassisError As Adm1024IrqStatusChassisType
    Get
public:
property Adm1024IrqStatusChassisType InterruptStatusMirror2ChassisError {
    Adm1024IrqStatusChassisType get ();
}
member InterruptStatusMirror2ChassisError : Adm1024IrqStatusChassisType with get

Property Value

Type: Adm1024IrqStatusChassisType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptStatusMirror2D1Fault Property

IRD

Adm1024InterruptStatusMirror2D1Fault Property

Interrupt Status Mirror 2 (D1 Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqStatusDiodeType InterruptStatusMirror2D1Fault { get; }
Public ReadOnly Property InterruptStatusMirror2D1Fault As Adm1024IrqStatusDiodeType
    Get
public:
property Adm1024IrqStatusDiodeType InterruptStatusMirror2D1Fault {
    Adm1024IrqStatusDiodeType get ();
}
member InterruptStatusMirror2D1Fault : Adm1024IrqStatusDiodeType with get

Property Value

Type: Adm1024IrqStatusDiodeType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptStatusMirror2D2Fault Property

IRD

Adm1024InterruptStatusMirror2D2Fault Property

Interrupt Status Mirror 2 (D2 Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqStatusDiodeType InterruptStatusMirror2D2Fault { get; }
Public ReadOnly Property InterruptStatusMirror2D2Fault As Adm1024IrqStatusDiodeType
    Get
public:
property Adm1024IrqStatusDiodeType InterruptStatusMirror2D2Fault {
    Adm1024IrqStatusDiodeType get ();
}
member InterruptStatusMirror2D2Fault : Adm1024IrqStatusDiodeType with get

Property Value

Type: Adm1024IrqStatusDiodeType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptStatusMirror2THERMInterrupt Property

IRD

Adm1024InterruptStatusMirror2THERMInterrupt Property

Interrupt Status Mirror 2 (THERM Interrupt)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqStatusThermType InterruptStatusMirror2THERMInterrupt { get; }
Public ReadOnly Property InterruptStatusMirror2THERMInterrupt As Adm1024IrqStatusThermType
    Get
public:
property Adm1024IrqStatusThermType InterruptStatusMirror2THERMInterrupt {
    Adm1024IrqStatusThermType get ();
}
member InterruptStatusMirror2THERMInterrupt : Adm1024IrqStatusThermType with get

Property Value

Type: Adm1024IrqStatusThermType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.InterruptStatusMirror2VCCP2Error Property

IRD

Adm1024InterruptStatusMirror2VCCP2Error Property

Interrupt Status Mirror 2 (V_CCP2 Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024HighLowExceededType InterruptStatusMirror2VCCP2Error { get; }
Public ReadOnly Property InterruptStatusMirror2VCCP2Error As Adm1024HighLowExceededType
    Get
public:
property Adm1024HighLowExceededType InterruptStatusMirror2VCCP2Error {
    Adm1024HighLowExceededType get ();
}
member InterruptStatusMirror2VCCP2Error : Adm1024HighLowExceededType with get

Property Value

Type: Adm1024HighLowExceededType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.INTMask125VExtTemp2 Property

IRD

Adm1024INTMask125VExtTemp2 Property

INT Mask 1 (2.5V / Ext. Temp. 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqMaskType INTMask125VExtTemp2 { get; set; }
Public Property INTMask125VExtTemp2 As Adm1024IrqMaskType
    Get
    Set
public:
property Adm1024IrqMaskType INTMask125VExtTemp2 {
    Adm1024IrqMaskType get ();
    void set (Adm1024IrqMaskType value);
}
member INTMask125VExtTemp2 : Adm1024IrqMaskType with get, set

Property Value

Type: Adm1024IrqMaskType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.INTMask15V Property

IRD

Adm1024INTMask15V Property

INT Mask 1 (5V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqMaskType INTMask15V { get; set; }
Public Property INTMask15V As Adm1024IrqMaskType
    Get
    Set
public:
property Adm1024IrqMaskType INTMask15V {
    Adm1024IrqMaskType get ();
    void set (Adm1024IrqMaskType value);
}
member INTMask15V : Adm1024IrqMaskType with get, set

Property Value

Type: Adm1024IrqMaskType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.INTMask1ExtTemp1 Property

IRD

Adm1024INTMask1ExtTemp1 Property

INT Mask 1 (Ext. Temp. 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqMaskType INTMask1ExtTemp1 { get; set; }
Public Property INTMask1ExtTemp1 As Adm1024IrqMaskType
    Get
    Set
public:
property Adm1024IrqMaskType INTMask1ExtTemp1 {
    Adm1024IrqMaskType get ();
    void set (Adm1024IrqMaskType value);
}
member INTMask1ExtTemp1 : Adm1024IrqMaskType with get, set

Property Value

Type: Adm1024IrqMaskType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.INTMask1FAN1AIN1 Property

IRD

Adm1024INTMask1FAN1AIN1 Property

INT Mask 1 (FAN1/AIN1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqMaskType INTMask1FAN1AIN1 { get; set; }
Public Property INTMask1FAN1AIN1 As Adm1024IrqMaskType
    Get
    Set
public:
property Adm1024IrqMaskType INTMask1FAN1AIN1 {
    Adm1024IrqMaskType get ();
    void set (Adm1024IrqMaskType value);
}
member INTMask1FAN1AIN1 : Adm1024IrqMaskType with get, set

Property Value

Type: Adm1024IrqMaskType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.INTMask1FAN2AIN2 Property

IRD

Adm1024INTMask1FAN2AIN2 Property

INT Mask 1 (FAN2/AIN2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqMaskType INTMask1FAN2AIN2 { get; set; }
Public Property INTMask1FAN2AIN2 As Adm1024IrqMaskType
    Get
    Set
public:
property Adm1024IrqMaskType INTMask1FAN2AIN2 {
    Adm1024IrqMaskType get ();
    void set (Adm1024IrqMaskType value);
}
member INTMask1FAN2AIN2 : Adm1024IrqMaskType with get, set

Property Value

Type: Adm1024IrqMaskType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.INTMask1IntTemp Property

IRD

Adm1024INTMask1IntTemp Property

INT Mask 1 (Int. Temp.)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqMaskType INTMask1IntTemp { get; set; }
Public Property INTMask1IntTemp As Adm1024IrqMaskType
    Get
    Set
public:
property Adm1024IrqMaskType INTMask1IntTemp {
    Adm1024IrqMaskType get ();
    void set (Adm1024IrqMaskType value);
}
member INTMask1IntTemp : Adm1024IrqMaskType with get, set

Property Value

Type: Adm1024IrqMaskType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.INTMask1VCC Property

IRD

Adm1024INTMask1VCC Property

INT Mask 1 (V_CC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqMaskType INTMask1VCC { get; set; }
Public Property INTMask1VCC As Adm1024IrqMaskType
    Get
    Set
public:
property Adm1024IrqMaskType INTMask1VCC {
    Adm1024IrqMaskType get ();
    void set (Adm1024IrqMaskType value);
}
member INTMask1VCC : Adm1024IrqMaskType with get, set

Property Value

Type: Adm1024IrqMaskType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.INTMask1VCCP1 Property

IRD

Adm1024INTMask1VCCP1 Property

INT Mask 1 (V_CCP1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqMaskType INTMask1VCCP1 { get; set; }
Public Property INTMask1VCCP1 As Adm1024IrqMaskType
    Get
    Set
public:
property Adm1024IrqMaskType INTMask1VCCP1 {
    Adm1024IrqMaskType get ();
    void set (Adm1024IrqMaskType value);
}
member INTMask1VCCP1 : Adm1024IrqMaskType with get, set

Property Value

Type: Adm1024IrqMaskType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.INTMask212V Property

IRD

Adm1024INTMask212V Property

INT Mask 2 (12V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqMaskType INTMask212V { get; set; }
Public Property INTMask212V As Adm1024IrqMaskType
    Get
    Set
public:
property Adm1024IrqMaskType INTMask212V {
    Adm1024IrqMaskType get ();
    void set (Adm1024IrqMaskType value);
}
member INTMask212V : Adm1024IrqMaskType with get, set

Property Value

Type: Adm1024IrqMaskType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.INTMask2CI Property

IRD

Adm1024INTMask2CI Property

INT Mask 2 (CI)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqMaskType INTMask2CI { get; set; }
Public Property INTMask2CI As Adm1024IrqMaskType
    Get
    Set
public:
property Adm1024IrqMaskType INTMask2CI {
    Adm1024IrqMaskType get ();
    void set (Adm1024IrqMaskType value);
}
member INTMask2CI : Adm1024IrqMaskType with get, set

Property Value

Type: Adm1024IrqMaskType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.INTMask2D1Fault Property

IRD

Adm1024INTMask2D1Fault Property

INT Mask 2 (D1 Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqMaskType INTMask2D1Fault { get; set; }
Public Property INTMask2D1Fault As Adm1024IrqMaskType
    Get
    Set
public:
property Adm1024IrqMaskType INTMask2D1Fault {
    Adm1024IrqMaskType get ();
    void set (Adm1024IrqMaskType value);
}
member INTMask2D1Fault : Adm1024IrqMaskType with get, set

Property Value

Type: Adm1024IrqMaskType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.INTMask2D2Fault Property

IRD

Adm1024INTMask2D2Fault Property

INT Mask 2 (D2 Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqMaskType INTMask2D2Fault { get; set; }
Public Property INTMask2D2Fault As Adm1024IrqMaskType
    Get
    Set
public:
property Adm1024IrqMaskType INTMask2D2Fault {
    Adm1024IrqMaskType get ();
    void set (Adm1024IrqMaskType value);
}
member INTMask2D2Fault : Adm1024IrqMaskType with get, set

Property Value

Type: Adm1024IrqMaskType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.INTMask2THERM Property

IRD

Adm1024INTMask2THERM Property

INT Mask 2 (THERM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqMaskType INTMask2THERM { get; set; }
Public Property INTMask2THERM As Adm1024IrqMaskType
    Get
    Set
public:
property Adm1024IrqMaskType INTMask2THERM {
    Adm1024IrqMaskType get ();
    void set (Adm1024IrqMaskType value);
}
member INTMask2THERM : Adm1024IrqMaskType with get, set

Property Value

Type: Adm1024IrqMaskType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.INTMask2VCCP2 Property

IRD

Adm1024INTMask2VCCP2 Property

INT Mask 2 (V_CCP2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024IrqMaskType INTMask2VCCP2 { get; set; }
Public Property INTMask2VCCP2 As Adm1024IrqMaskType
    Get
    Set
public:
property Adm1024IrqMaskType INTMask2VCCP2 {
    Adm1024IrqMaskType get ();
    void set (Adm1024IrqMaskType value);
}
member INTMask2VCCP2 : Adm1024IrqMaskType with get, set

Property Value

Type: Adm1024IrqMaskType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Property_12VHighLimit Property

IRD

Adm1024Property_12VHighLimit Property

12V High Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_12VHighLimit { get; set; }
Public Property Property_12VHighLimit As Double
    Get
    Set
public:
property double Property_12VHighLimit {
    double get ();
    void set (double value);
}
member Property_12VHighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Property_12VLowLimit Property

IRD

Adm1024Property_12VLowLimit Property

12V Low Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_12VLowLimit { get; set; }
Public Property Property_12VLowLimit As Double
    Get
    Set
public:
property double Property_12VLowLimit {
    double get ();
    void set (double value);
}
member Property_12VLowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Property_12VValue Property

IRD

Adm1024Property_12VValue Property

12V Value (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_12VValue { get; }
Public ReadOnly Property Property_12VValue As Double
    Get
public:
property double Property_12VValue {
    double get ();
}
member Property_12VValue : float with get

Property Value

Type: Double
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Property_25VExternalTemp2HighLimit Property

IRD

Adm1024Property_25VExternalTemp2HighLimit Property

2.5V / External Temp. 2 High Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Property_25VExternalTemp2HighLimit { get; set; }
Public Property Property_25VExternalTemp2HighLimit As Byte
    Get
    Set
public:
property unsigned char Property_25VExternalTemp2HighLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member Property_25VExternalTemp2HighLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Property_25VExternalTemp2LowLimit Property

IRD

Adm1024Property_25VExternalTemp2LowLimit Property

2.5V / External Temp. 2 Low Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Property_25VExternalTemp2LowLimit { get; set; }
Public Property Property_25VExternalTemp2LowLimit As Byte
    Get
    Set
public:
property unsigned char Property_25VExternalTemp2LowLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member Property_25VExternalTemp2LowLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Property_25VValueExternalTemperature2Value Property

IRD

Adm1024Property_25VValueExternalTemperature2Value Property

2.5V Value / External Temperature 2 Value

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Property_25VValueExternalTemperature2Value { get; }
Public ReadOnly Property Property_25VValueExternalTemperature2Value As Byte
    Get
public:
property unsigned char Property_25VValueExternalTemperature2Value {
    unsigned char get ();
}
member Property_25VValueExternalTemperature2Value : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Property_5VHighLimit Property

IRD

Adm1024Property_5VHighLimit Property

5V High Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_5VHighLimit { get; set; }
Public Property Property_5VHighLimit As Double
    Get
    Set
public:
property double Property_5VHighLimit {
    double get ();
    void set (double value);
}
member Property_5VHighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Property_5VLowLimit Property

IRD

Adm1024Property_5VLowLimit Property

5V Low Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_5VLowLimit { get; set; }
Public Property Property_5VLowLimit As Double
    Get
    Set
public:
property double Property_5VLowLimit {
    double get ();
    void set (double value);
}
member Property_5VLowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Property_5VValue Property

IRD

Adm1024Property_5VValue Property

5V Value (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_5VValue { get; }
Public ReadOnly Property Property_5VValue As Double
    Get
public:
property double Property_5VValue {
    double get ();
}
member Property_5VValue : float with get

Property Value

Type: Double
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Revision Property

IRD

Adm1024Revision Property

Revision

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Revision { get; }
Public ReadOnly Property Revision As Byte
    Get
public:
property unsigned char Revision {
    unsigned char get ();
}
member Revision : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Test Property

IRD

Adm1024Test Property

Test

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024TestType Test { get; set; }
Public Property Test As Adm1024TestType
    Get
    Set
public:
property Adm1024TestType Test {
    Adm1024TestType get ();
    void set (Adm1024TestType value);
}
member Test : Adm1024TestType with get, set

Property Value

Type: Adm1024TestType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.VCCHighLimit Property

IRD

Adm1024VCCHighLimit Property

V_CC High Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VCCHighLimit { get; set; }
Public Property VCCHighLimit As Byte
    Get
    Set
public:
property unsigned char VCCHighLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member VCCHighLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.VCCLowLimit Property

IRD

Adm1024VCCLowLimit Property

V_CC Low Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VCCLowLimit { get; set; }
Public Property VCCLowLimit As Byte
    Get
    Set
public:
property unsigned char VCCLowLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member VCCLowLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.VCCP1HighLimit Property

IRD

Adm1024VCCP1HighLimit Property

V_CCP1 High Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCP1HighLimit { get; set; }
Public Property VCCP1HighLimit As Double
    Get
    Set
public:
property double VCCP1HighLimit {
    double get ();
    void set (double value);
}
member VCCP1HighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.VCCP1LowLimit Property

IRD

Adm1024VCCP1LowLimit Property

V_CCP1 Low Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCP1LowLimit { get; set; }
Public Property VCCP1LowLimit As Double
    Get
    Set
public:
property double VCCP1LowLimit {
    double get ();
    void set (double value);
}
member VCCP1LowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.VCCP1Value Property

IRD

Adm1024VCCP1Value Property

V_CCP1 Value (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCP1Value { get; }
Public ReadOnly Property VCCP1Value As Double
    Get
public:
property double VCCP1Value {
    double get ();
}
member VCCP1Value : float with get

Property Value

Type: Double
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.VCCP2HighLimit Property

IRD

Adm1024VCCP2HighLimit Property

V_CCP2 High Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCP2HighLimit { get; set; }
Public Property VCCP2HighLimit As Double
    Get
    Set
public:
property double VCCP2HighLimit {
    double get ();
    void set (double value);
}
member VCCP2HighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.VCCP2LowLimit Property

IRD

Adm1024VCCP2LowLimit Property

V_CCP2 Low Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCP2LowLimit { get; set; }
Public Property VCCP2LowLimit As Double
    Get
    Set
public:
property double VCCP2LowLimit {
    double get ();
    void set (double value);
}
member VCCP2LowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.VCCP2Value Property

IRD

Adm1024VCCP2Value Property

V_CCP2 Value (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCP2Value { get; }
Public ReadOnly Property VCCP2Value As Double
    Get
public:
property double VCCP2Value {
    double get ();
}
member VCCP2Value : float with get

Property Value

Type: Double
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.VCCValue Property

IRD

Adm1024VCCValue Property

V_CC Value

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VCCValue { get; }
Public ReadOnly Property VCCValue As Byte
    Get
public:
property unsigned char VCCValue {
    unsigned char get ();
}
member VCCValue : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.VID03FanDivisorFAN1Divisor Property

IRD

Adm1024VID03FanDivisorFAN1Divisor Property

VID 0-3 / Fan Divisor (FAN1 Divisor)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024FanDivisorType VID03FanDivisorFAN1Divisor { get; set; }
Public Property VID03FanDivisorFAN1Divisor As Adm1024FanDivisorType
    Get
    Set
public:
property Adm1024FanDivisorType VID03FanDivisorFAN1Divisor {
    Adm1024FanDivisorType get ();
    void set (Adm1024FanDivisorType value);
}
member VID03FanDivisorFAN1Divisor : Adm1024FanDivisorType with get, set

Property Value

Type: Adm1024FanDivisorType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.VID03FanDivisorFAN2Divisor Property

IRD

Adm1024VID03FanDivisorFAN2Divisor Property

VID 0-3 / Fan Divisor (FAN2 Divisor)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1024FanDivisorType VID03FanDivisorFAN2Divisor { get; set; }
Public Property VID03FanDivisorFAN2Divisor As Adm1024FanDivisorType
    Get
    Set
public:
property Adm1024FanDivisorType VID03FanDivisorFAN2Divisor {
    Adm1024FanDivisorType get ();
    void set (Adm1024FanDivisorType value);
}
member VID03FanDivisorFAN2Divisor : Adm1024FanDivisorType with get, set

Property Value

Type: Adm1024FanDivisorType
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.VID03FanDivisorVID Property

IRD

Adm1024VID03FanDivisorVID Property

VID 0-3 / Fan Divisor (VID)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VID03FanDivisorVID { get; }
Public ReadOnly Property VID03FanDivisorVID As Byte
    Get
public:
property unsigned char VID03FanDivisorVID {
    unsigned char get ();
}
member VID03FanDivisorVID : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.VID4 Property

IRD

Adm1024VID4 Property

VID 4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VID4 { get; }
Public ReadOnly Property VID4 As Byte
    Get
public:
property unsigned char VID4 {
    unsigned char get ();
}
member VID4 : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024 Methods

The Adm1024 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Flush Method

IRD

Adm1024Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adm1024 Class
telos.Ird.AnalogDevices Namespace


Adm1024.Channel25Type Enumeration

IRD

Adm1024Channel25Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Channel25Type
Public Enumeration Channel25Type
public enum class Channel25Type
type Channel25Type
Members
Member name | Value | Description
Pin1718TemperatureDiode | 1 | Pin 17/18: Temperature Diode
Pin1718VCCP225V | 0 | Pin 17/18: V_CCP2 / 2.5V
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.ChannelFan1Type Enumeration

IRD

Adm1024ChannelFan1Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ChannelFan1Type
Public Enumeration ChannelFan1Type
public enum class ChannelFan1Type
type ChannelFan1Type
Members
Member name | Value | Description
Pin5AIN1 | 1 | Pin 5: AIN1
Pin5FAN1 | 0 | Pin 5: FAN1
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.ChannelFan2Type Enumeration

IRD

Adm1024ChannelFan2Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ChannelFan2Type
Public Enumeration ChannelFan2Type
public enum class ChannelFan2Type
type ChannelFan2Type
Members
Member name | Value | Description
Pin6AIN2 | 1 | Pin 6: AIN2
Pin6FAN2 | 0 | Pin 6: FAN2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.ChannelIntVccType Enumeration

IRD

Adm1024ChannelIntVccType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ChannelIntVccType
Public Enumeration ChannelIntVccType
public enum class ChannelIntVccType
type ChannelIntVccType
Members
Member name | Value | Description
Value_5V | 1 | 5V
Value_33V | 0 | 3.3V
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.ChannelVidType Enumeration

IRD

Adm1024ChannelVidType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ChannelVidType
Public Enumeration ChannelVidType
public enum class ChannelVidType
type ChannelVidType
Members
Member name | Value | Description
Pin2024IRQInputs | 1 | Pin 20-24: IRQ Inputs
Pin2024VIDInputs | 0 | Pin 20-24: VID Inputs
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.CiClearType Enumeration

IRD

Adm1024CiClearType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CiClearType
Public Enumeration CiClearType
public enum class CiClearType
type CiClearType
Members
Member name | Value | Description
Clear | 1 | Clear
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.Conf2LockType Enumeration

IRD

Adm1024Conf2LockType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Conf2LockType
Public Enumeration Conf2LockType
public enum class Conf2LockType
type Conf2LockType
Members
Member name | Value | Description
Lock | 1 | Lock
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.Conf2ThermIrqMaskType Enumeration

IRD

Adm1024Conf2ThermIrqMaskType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Conf2ThermIrqMaskType
Public Enumeration Conf2ThermIrqMaskType
public enum class Conf2ThermIrqMaskType
type Conf2ThermIrqMaskType
Members
Member name | Value | Description
Mask | 1 | Mask
DoNotMask | 0 | Do Not Mask
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.Conf2ThermIrqType Enumeration

IRD

Adm1024Conf2ThermIrqType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Conf2ThermIrqType
Public Enumeration Conf2ThermIrqType
public enum class Conf2ThermIrqType
type Conf2ThermIrqType
Members
Member name | Value | Description
ACPIMode | 1 | ACPI Mode
DefaultMode | 0 | Default Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.ConfClearType Enumeration

IRD

Adm1024ConfClearType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfClearType
Public Enumeration ConfClearType
public enum class ConfClearType
type ConfClearType
Members
Member name | Value | Description
Clear | 1 | Clear
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.ConfInitType Enumeration

IRD

Adm1024ConfInitType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfInitType
Public Enumeration ConfInitType
public enum class ConfInitType
type ConfInitType
Members
Member name | Value | Description
Init | 1 | Init
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.ConfResetType Enumeration

IRD

Adm1024ConfResetType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfResetType
Public Enumeration ConfResetType
public enum class ConfResetType
type ConfResetType
Members
Member name | Value | Description
Reset | 1 | Reset
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.ConfStartType Enumeration

IRD

Adm1024ConfStartType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfStartType
Public Enumeration ConfStartType
public enum class ConfStartType
type ConfStartType
Members
Member name | Value | Description
Startup | 1 | Startup
Standby | 0 | Standby
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.EnabledDisabledType Enumeration

IRD

Adm1024EnabledDisabledType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum EnabledDisabledType
Public Enumeration EnabledDisabledType
public enum class EnabledDisabledType
type EnabledDisabledType
Members
Member name | Value | Description
Enabled | 1 | Enabled
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.FanDivisorType Enumeration

IRD

Adm1024FanDivisorType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FanDivisorType
Public Enumeration FanDivisorType
public enum class FanDivisorType
type FanDivisorType
Members
Member name | Value | Description
Divider8 | 3 | Divider: 8
Divider4 | 2 | Divider: 4
Divider2 | 1 | Divider: 2
Divider1 | 0 | Divider: 1
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.HighLowExceededType Enumeration

IRD

Adm1024HighLowExceededType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum HighLowExceededType
Public Enumeration HighLowExceededType
public enum class HighLowExceededType
type HighLowExceededType
Members
Member name | Value | Description
HighLowExceeded | 1 | High/Low Exceeded
HighLowNotExceeded | 0 | High/Low Not Exceeded
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.IrqMaskType Enumeration

IRD

Adm1024IrqMaskType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqMaskType
Public Enumeration IrqMaskType
public enum class IrqMaskType
type IrqMaskType
Members
Member name | Value | Description
DoNotTriggerINT | 1 | Do Not Trigger INT
TriggerINT | 0 | Trigger INT
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.IrqStatusChassisType Enumeration

IRD

Adm1024IrqStatusChassisType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqStatusChassisType
Public Enumeration IrqStatusChassisType
public enum class IrqStatusChassisType
type IrqStatusChassisType
Members
Member name | Value | Description
ChassisIntrusionHigh | 1 | Chassis Intrusion High
ChassisIntrusionNotHigh | 0 | Chassis Intrusion Not High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.IrqStatusDiodeType Enumeration

IRD

Adm1024IrqStatusDiodeType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqStatusDiodeType
Public Enumeration IrqStatusDiodeType
public enum class IrqStatusDiodeType
type IrqStatusDiodeType
Members
Member name | Value | Description
ShortOrOpenCircuit | 1 | Short or Open-Circuit
NoError | 0 | No Error
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.IrqStatusThermType Enumeration

IRD

Adm1024IrqStatusThermType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqStatusThermType
Public Enumeration IrqStatusThermType
public enum class IrqStatusThermType
type IrqStatusThermType
Members
Member name | Value | Description
THERMPulledLow | 1 | THERM Pulled Low
THERMNotPulledLow | 0 | THERM Not Pulled Low
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1024.TestType Enumeration

IRD

Adm1024TestType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TestType
Public Enumeration TestType
public enum class TestType
type TestType
Members
Member name | Value | Description
Shutdown | 1 | Shutdown
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1025 Class

Analog Devices: ADM 1025(A)
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdm1025

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adm1025
Public Class Adm1025
public ref class Adm1025
type Adm1025 =  class end

The Adm1025 type exposes the following members.

Constructors
 | Name | Description
Public method | Adm1025 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CompanyID | Company ID
Public property | Initialization | Initialization
Public property | LocalTemperatureHighLimit | Local Temperature High Limit (unit: °C)
Public property | LocalTemperatureLowLimit | Local Temperature Low Limit (unit: °C)
Public property | LocalTemperatureReading | Local Temperature Reading (unit: °C)
Public property | LocalTempError | Local Temp Error
Public property | ManufacturersTest | Manufacturers Test
Public property | Offset | Offset
Public property | OffsetConfig | Offset Config
Public property | Property_12VError | +12V Error
Public property | Property_12VHighLimit | 12V High Limit (unit: V)
Public property | Property_12VLowLimit | 12V Low Limit (unit: V)
Public property | Property_12VReading | 12V Reading (unit: V)
Public property | Property_12VVID4Select | +12V/VID4 Select
Public property | Property_25VError | +2.5V Error
Public property | Property_25VHighLimit | 2.5V High Limit (unit: V)
Public property | Property_25VLowLimit | 2.5V Low Limit (unit: V)
Public property | Property_25VReading | 2.5V Reading (unit: V)
Public property | Property_33VError | +3.3V Error
Public property | Property_33VHighLimit | 3.3V High Limit (unit: V)
Public property | Property_33VLowLimit | 3.3V Low Limit (unit: V)
Public property | Property_33VReading | 3.3V Reading (unit: V)
Public property | Property_5VError | +5V Error
Public property | Property_5VHighLimit | 5V High Limit (unit: V)
Public property | Property_5VLowLimit | 5V Low Limit (unit: V)
Public property | Property_5VReading | 5V Reading (unit: V)
Public property | RemoteDiodeFault | Remote Diode Fault
Public property | RemoteDiodeTemperatureReading | Remote Diode Temperature Reading (unit: °C)
Public property | RemoteTemperatureHighLimit | Remote Temperature High Limit (unit: °C)
Public property | RemoteTemperatureLowLimit | Remote Temperature Low Limit (unit: °C)
Public property | RemoteTempError | Remote Temp Error
Public property | RESET | RESET
Public property | RSTENABLE | RST ENABLE
Public property | START | START
Public property | VCCError | V_CC Error
Public property | VCCHighLimit | V_CC High Limit (unit: V)
Public property | VCCLowLimit | V_CC Low Limit (unit: V)
Public property | VCCPError | V_CCP Error
Public property | VCCPHighLimit | V_CCP High Limit (unit: V)
Public property | VCCPLowLimit | V_CCP Low Limit (unit: V)
Public property | VCCPReading | V_CCP Reading (unit: V)
Public property | VCCReading | V_CC Reading (unit: V)
Public property | Version | Version
Public property | VID30 | VID[3:0]
Public property | VID4 | VID4
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Hardware Monitor
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1025 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1025(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adm1025(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adm1025

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025 Properties

The Adm1025 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CompanyID | Company ID
Public property | Initialization | Initialization
Public property | LocalTemperatureHighLimit | Local Temperature High Limit (unit: °C)
Public property | LocalTemperatureLowLimit | Local Temperature Low Limit (unit: °C)
Public property | LocalTemperatureReading | Local Temperature Reading (unit: °C)
Public property | LocalTempError | Local Temp Error
Public property | ManufacturersTest | Manufacturers Test
Public property | Offset | Offset
Public property | OffsetConfig | Offset Config
Public property | Property_12VError | +12V Error
Public property | Property_12VHighLimit | 12V High Limit (unit: V)
Public property | Property_12VLowLimit | 12V Low Limit (unit: V)
Public property | Property_12VReading | 12V Reading (unit: V)
Public property | Property_12VVID4Select | +12V/VID4 Select
Public property | Property_25VError | +2.5V Error
Public property | Property_25VHighLimit | 2.5V High Limit (unit: V)
Public property | Property_25VLowLimit | 2.5V Low Limit (unit: V)
Public property | Property_25VReading | 2.5V Reading (unit: V)
Public property | Property_33VError | +3.3V Error
Public property | Property_33VHighLimit | 3.3V High Limit (unit: V)
Public property | Property_33VLowLimit | 3.3V Low Limit (unit: V)
Public property | Property_33VReading | 3.3V Reading (unit: V)
Public property | Property_5VError | +5V Error
Public property | Property_5VHighLimit | 5V High Limit (unit: V)
Public property | Property_5VLowLimit | 5V Low Limit (unit: V)
Public property | Property_5VReading | 5V Reading (unit: V)
Public property | RemoteDiodeFault | Remote Diode Fault
Public property | RemoteDiodeTemperatureReading | Remote Diode Temperature Reading (unit: °C)
Public property | RemoteTemperatureHighLimit | Remote Temperature High Limit (unit: °C)
Public property | RemoteTemperatureLowLimit | Remote Temperature Low Limit (unit: °C)
Public property | RemoteTempError | Remote Temp Error
Public property | RESET | RESET
Public property | RSTENABLE | RST ENABLE
Public property | START | START
Public property | VCCError | V_CC Error
Public property | VCCHighLimit | V_CC High Limit (unit: V)
Public property | VCCLowLimit | V_CC Low Limit (unit: V)
Public property | VCCPError | V_CCP Error
Public property | VCCPHighLimit | V_CCP High Limit (unit: V)
Public property | VCCPLowLimit | V_CCP Low Limit (unit: V)
Public property | VCCPReading | V_CCP Reading (unit: V)
Public property | VCCReading | V_CC Reading (unit: V)
Public property | Version | Version
Public property | VID30 | VID[3:0]
Public property | VID4 | VID4
Top
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.AutoFlush Property

IRD

Adm1025AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.CompanyID Property

IRD

Adm1025CompanyID Property

Company ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CompanyID { get; }
Public ReadOnly Property CompanyID As Byte
    Get
public:
property unsigned char CompanyID {
    unsigned char get ();
}
member CompanyID : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Initialization Property

IRD

Adm1025Initialization Property

Initialization

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1025ConfInitType Initialization { get; set; }
Public Property Initialization As Adm1025ConfInitType
    Get
    Set
public:
property Adm1025ConfInitType Initialization {
    Adm1025ConfInitType get ();
    void set (Adm1025ConfInitType value);
}
member Initialization : Adm1025ConfInitType with get, set

Property Value

Type: Adm1025ConfInitType
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.LocalTemperatureHighLimit Property

IRD

Adm1025LocalTemperatureHighLimit Property

Local Temperature High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTemperatureHighLimit { get; set; }
Public Property LocalTemperatureHighLimit As SByte
    Get
    Set
public:
property signed char LocalTemperatureHighLimit {
    signed char get ();
    void set (signed char value);
}
member LocalTemperatureHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.LocalTemperatureLowLimit Property

IRD

Adm1025LocalTemperatureLowLimit Property

Local Temperature Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTemperatureLowLimit { get; set; }
Public Property LocalTemperatureLowLimit As SByte
    Get
    Set
public:
property signed char LocalTemperatureLowLimit {
    signed char get ();
    void set (signed char value);
}
member LocalTemperatureLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.LocalTemperatureReading Property

IRD

Adm1025LocalTemperatureReading Property

Local Temperature Reading (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTemperatureReading { get; }
Public ReadOnly Property LocalTemperatureReading As SByte
    Get
public:
property signed char LocalTemperatureReading {
    signed char get ();
}
member LocalTemperatureReading : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.LocalTempError Property

IRD

Adm1025LocalTempError Property

Local Temp Error

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1025HighLowExceededType LocalTempError { get; }
Public ReadOnly Property LocalTempError As Adm1025HighLowExceededType
    Get
public:
property Adm1025HighLowExceededType LocalTempError {
    Adm1025HighLowExceededType get ();
}
member LocalTempError : Adm1025HighLowExceededType with get

Property Value

Type: Adm1025HighLowExceededType
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.ManufacturersTest Property

IRD

Adm1025ManufacturersTest Property

Manufacturers Test

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1025TestType ManufacturersTest { get; set; }
Public Property ManufacturersTest As Adm1025TestType
    Get
    Set
public:
property Adm1025TestType ManufacturersTest {
    Adm1025TestType get ();
    void set (Adm1025TestType value);
}
member ManufacturersTest : Adm1025TestType with get, set

Property Value

Type: Adm1025TestType
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Offset Property

IRD

Adm1025Offset Property

Offset

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Offset { get; set; }
Public Property Offset As Byte
    Get
    Set
public:
property unsigned char Offset {
    unsigned char get ();
    void set (unsigned char value);
}
member Offset : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.OffsetConfig Property

IRD

Adm1025OffsetConfig Property

Offset Config

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1025VidOffsetType OffsetConfig { get; set; }
Public Property OffsetConfig As Adm1025VidOffsetType
    Get
    Set
public:
property Adm1025VidOffsetType OffsetConfig {
    Adm1025VidOffsetType get ();
    void set (Adm1025VidOffsetType value);
}
member OffsetConfig : Adm1025VidOffsetType with get, set

Property Value

Type: Adm1025VidOffsetType
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Property_12VError Property

IRD

Adm1025Property_12VError Property

+12V Error

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1025HighLowExceededType Property_12VError { get; }
Public ReadOnly Property Property_12VError As Adm1025HighLowExceededType
    Get
public:
property Adm1025HighLowExceededType Property_12VError {
    Adm1025HighLowExceededType get ();
}
member Property_12VError : Adm1025HighLowExceededType with get

Property Value

Type: Adm1025HighLowExceededType
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Property_12VHighLimit Property

IRD

Adm1025Property_12VHighLimit Property

12V High Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_12VHighLimit { get; set; }
Public Property Property_12VHighLimit As Double
    Get
    Set
public:
property double Property_12VHighLimit {
    double get ();
    void set (double value);
}
member Property_12VHighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Property_12VLowLimit Property

IRD

Adm1025Property_12VLowLimit Property

12V Low Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_12VLowLimit { get; set; }
Public Property Property_12VLowLimit As Double
    Get
    Set
public:
property double Property_12VLowLimit {
    double get ();
    void set (double value);
}
member Property_12VLowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Property_12VReading Property

IRD

Adm1025Property_12VReading Property

12V Reading (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_12VReading { get; }
Public ReadOnly Property Property_12VReading As Double
    Get
public:
property double Property_12VReading {
    double get ();
}
member Property_12VReading : float with get

Property Value

Type: Double
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Property_12VVID4Select Property

IRD

Adm1025Property_12VVID4Select Property

+12V/VID4 Select

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1025Conf12Type Property_12VVID4Select { get; set; }
Public Property Property_12VVID4Select As Adm1025Conf12Type
    Get
    Set
public:
property Adm1025Conf12Type Property_12VVID4Select {
    Adm1025Conf12Type get ();
    void set (Adm1025Conf12Type value);
}
member Property_12VVID4Select : Adm1025Conf12Type with get, set

Property Value

Type: Adm1025Conf12Type
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Property_25VError Property

IRD

Adm1025Property_25VError Property

+2.5V Error

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1025HighLowExceededType Property_25VError { get; }
Public ReadOnly Property Property_25VError As Adm1025HighLowExceededType
    Get
public:
property Adm1025HighLowExceededType Property_25VError {
    Adm1025HighLowExceededType get ();
}
member Property_25VError : Adm1025HighLowExceededType with get

Property Value

Type: Adm1025HighLowExceededType
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Property_25VHighLimit Property

IRD

Adm1025Property_25VHighLimit Property

2.5V High Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_25VHighLimit { get; set; }
Public Property Property_25VHighLimit As Double
    Get
    Set
public:
property double Property_25VHighLimit {
    double get ();
    void set (double value);
}
member Property_25VHighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Property_25VLowLimit Property

IRD

Adm1025Property_25VLowLimit Property

2.5V Low Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_25VLowLimit { get; set; }
Public Property Property_25VLowLimit As Double
    Get
    Set
public:
property double Property_25VLowLimit {
    double get ();
    void set (double value);
}
member Property_25VLowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Property_25VReading Property

IRD

Adm1025Property_25VReading Property

2.5V Reading (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_25VReading { get; }
Public ReadOnly Property Property_25VReading As Double
    Get
public:
property double Property_25VReading {
    double get ();
}
member Property_25VReading : float with get

Property Value

Type: Double
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Property_33VError Property

IRD

Adm1025Property_33VError Property

+3.3V Error

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1025HighLowExceededType Property_33VError { get; }
Public ReadOnly Property Property_33VError As Adm1025HighLowExceededType
    Get
public:
property Adm1025HighLowExceededType Property_33VError {
    Adm1025HighLowExceededType get ();
}
member Property_33VError : Adm1025HighLowExceededType with get

Property Value

Type: Adm1025HighLowExceededType
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Property_33VHighLimit Property

IRD

Adm1025Property_33VHighLimit Property

3.3V High Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_33VHighLimit { get; set; }
Public Property Property_33VHighLimit As Double
    Get
    Set
public:
property double Property_33VHighLimit {
    double get ();
    void set (double value);
}
member Property_33VHighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Property_33VLowLimit Property

IRD

Adm1025Property_33VLowLimit Property

3.3V Low Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_33VLowLimit { get; set; }
Public Property Property_33VLowLimit As Double
    Get
    Set
public:
property double Property_33VLowLimit {
    double get ();
    void set (double value);
}
member Property_33VLowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Property_33VReading Property

IRD

Adm1025Property_33VReading Property

3.3V Reading (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_33VReading { get; }
Public ReadOnly Property Property_33VReading As Double
    Get
public:
property double Property_33VReading {
    double get ();
}
member Property_33VReading : float with get

Property Value

Type: Double
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Property_5VError Property

IRD

Adm1025Property_5VError Property

+5V Error

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1025HighLowExceededType Property_5VError { get; }
Public ReadOnly Property Property_5VError As Adm1025HighLowExceededType
    Get
public:
property Adm1025HighLowExceededType Property_5VError {
    Adm1025HighLowExceededType get ();
}
member Property_5VError : Adm1025HighLowExceededType with get

Property Value

Type: Adm1025HighLowExceededType
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Property_5VHighLimit Property

IRD

Adm1025Property_5VHighLimit Property

5V High Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_5VHighLimit { get; set; }
Public Property Property_5VHighLimit As Double
    Get
    Set
public:
property double Property_5VHighLimit {
    double get ();
    void set (double value);
}
member Property_5VHighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Property_5VLowLimit Property

IRD

Adm1025Property_5VLowLimit Property

5V Low Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_5VLowLimit { get; set; }
Public Property Property_5VLowLimit As Double
    Get
    Set
public:
property double Property_5VLowLimit {
    double get ();
    void set (double value);
}
member Property_5VLowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Property_5VReading Property

IRD

Adm1025Property_5VReading Property

5V Reading (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_5VReading { get; }
Public ReadOnly Property Property_5VReading As Double
    Get
public:
property double Property_5VReading {
    double get ();
}
member Property_5VReading : float with get

Property Value

Type: Double
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.RemoteDiodeFault Property

IRD

Adm1025RemoteDiodeFault Property

Remote Diode Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1025StatusDiodeFaultType RemoteDiodeFault { get; }
Public ReadOnly Property RemoteDiodeFault As Adm1025StatusDiodeFaultType
    Get
public:
property Adm1025StatusDiodeFaultType RemoteDiodeFault {
    Adm1025StatusDiodeFaultType get ();
}
member RemoteDiodeFault : Adm1025StatusDiodeFaultType with get

Property Value

Type: Adm1025StatusDiodeFaultType
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.RemoteDiodeTemperatureReading Property

IRD

Adm1025RemoteDiodeTemperatureReading Property

Remote Diode Temperature Reading (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteDiodeTemperatureReading { get; }
Public ReadOnly Property RemoteDiodeTemperatureReading As SByte
    Get
public:
property signed char RemoteDiodeTemperatureReading {
    signed char get ();
}
member RemoteDiodeTemperatureReading : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.RemoteTemperatureHighLimit Property

IRD

Adm1025RemoteTemperatureHighLimit Property

Remote Temperature High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTemperatureHighLimit { get; set; }
Public Property RemoteTemperatureHighLimit As SByte
    Get
    Set
public:
property signed char RemoteTemperatureHighLimit {
    signed char get ();
    void set (signed char value);
}
member RemoteTemperatureHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.RemoteTemperatureLowLimit Property

IRD

Adm1025RemoteTemperatureLowLimit Property

Remote Temperature Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTemperatureLowLimit { get; set; }
Public Property RemoteTemperatureLowLimit As SByte
    Get
    Set
public:
property signed char RemoteTemperatureLowLimit {
    signed char get ();
    void set (signed char value);
}
member RemoteTemperatureLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.RemoteTempError Property

IRD

Adm1025RemoteTempError Property

Remote Temp Error

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1025HighLowExceededType RemoteTempError { get; }
Public ReadOnly Property RemoteTempError As Adm1025HighLowExceededType
    Get
public:
property Adm1025HighLowExceededType RemoteTempError {
    Adm1025HighLowExceededType get ();
}
member RemoteTempError : Adm1025HighLowExceededType with get

Property Value

Type: Adm1025HighLowExceededType
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.RESET Property

IRD

Adm1025RESET Property

RESET

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1025ConfResetType RESET { get; set; }
Public Property RESET As Adm1025ConfResetType
    Get
    Set
public:
property Adm1025ConfResetType RESET {
    Adm1025ConfResetType get ();
    void set (Adm1025ConfResetType value);
}
member RESET : Adm1025ConfResetType with get, set

Property Value

Type: Adm1025ConfResetType
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.RSTENABLE Property

IRD

Adm1025RSTENABLE Property

RST ENABLE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1025VidRstType RSTENABLE { get; set; }
Public Property RSTENABLE As Adm1025VidRstType
    Get
    Set
public:
property Adm1025VidRstType RSTENABLE {
    Adm1025VidRstType get ();
    void set (Adm1025VidRstType value);
}
member RSTENABLE : Adm1025VidRstType with get, set

Property Value

Type: Adm1025VidRstType
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.START Property

IRD

Adm1025START Property

START

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1025ConfStartType START { get; set; }
Public Property START As Adm1025ConfStartType
    Get
    Set
public:
property Adm1025ConfStartType START {
    Adm1025ConfStartType get ();
    void set (Adm1025ConfStartType value);
}
member START : Adm1025ConfStartType with get, set

Property Value

Type: Adm1025ConfStartType
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.VCCError Property

IRD

Adm1025VCCError Property

V_CC Error

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1025HighLowExceededType VCCError { get; }
Public ReadOnly Property VCCError As Adm1025HighLowExceededType
    Get
public:
property Adm1025HighLowExceededType VCCError {
    Adm1025HighLowExceededType get ();
}
member VCCError : Adm1025HighLowExceededType with get

Property Value

Type: Adm1025HighLowExceededType
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.VCCHighLimit Property

IRD

Adm1025VCCHighLimit Property

V_CC High Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCHighLimit { get; set; }
Public Property VCCHighLimit As Double
    Get
    Set
public:
property double VCCHighLimit {
    double get ();
    void set (double value);
}
member VCCHighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.VCCLowLimit Property

IRD

Adm1025VCCLowLimit Property

V_CC Low Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCLowLimit { get; set; }
Public Property VCCLowLimit As Double
    Get
    Set
public:
property double VCCLowLimit {
    double get ();
    void set (double value);
}
member VCCLowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.VCCPError Property

IRD

Adm1025VCCPError Property

V_CCP Error

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1025HighLowExceededType VCCPError { get; }
Public ReadOnly Property VCCPError As Adm1025HighLowExceededType
    Get
public:
property Adm1025HighLowExceededType VCCPError {
    Adm1025HighLowExceededType get ();
}
member VCCPError : Adm1025HighLowExceededType with get

Property Value

Type: Adm1025HighLowExceededType
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.VCCPHighLimit Property

IRD

Adm1025VCCPHighLimit Property

V_CCP High Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCPHighLimit { get; set; }
Public Property VCCPHighLimit As Double
    Get
    Set
public:
property double VCCPHighLimit {
    double get ();
    void set (double value);
}
member VCCPHighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.VCCPLowLimit Property

IRD

Adm1025VCCPLowLimit Property

V_CCP Low Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCPLowLimit { get; set; }
Public Property VCCPLowLimit As Double
    Get
    Set
public:
property double VCCPLowLimit {
    double get ();
    void set (double value);
}
member VCCPLowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.VCCPReading Property

IRD

Adm1025VCCPReading Property

V_CCP Reading (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCPReading { get; }
Public ReadOnly Property VCCPReading As Double
    Get
public:
property double VCCPReading {
    double get ();
}
member VCCPReading : float with get

Property Value

Type: Double
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.VCCReading Property

IRD

Adm1025VCCReading Property

V_CC Reading (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCReading { get; }
Public ReadOnly Property VCCReading As Double
    Get
public:
property double VCCReading {
    double get ();
}
member VCCReading : float with get

Property Value

Type: Double
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Version Property

IRD

Adm1025Version Property

Version

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Version { get; }
Public ReadOnly Property Version As Byte
    Get
public:
property unsigned char Version {
    unsigned char get ();
}
member Version : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.VID30 Property

IRD

Adm1025VID30 Property

VID[3:0]

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VID30 { get; }
Public ReadOnly Property VID30 As Byte
    Get
public:
property unsigned char VID30 {
    unsigned char get ();
}
member VID30 : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.VID4 Property

IRD

Adm1025VID4 Property

VID4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VID4 { get; }
Public ReadOnly Property VID4 As Byte
    Get
public:
property unsigned char VID4 {
    unsigned char get ();
}
member VID4 : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025 Methods

The Adm1025 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Flush Method

IRD

Adm1025Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adm1025 Class
telos.Ird.AnalogDevices Namespace


Adm1025.Conf12Type Enumeration

IRD

Adm1025Conf12Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Conf12Type
Public Enumeration Conf12Type
public enum class Conf12Type
type Conf12Type
Members
Member name | Value | Description
Pin11VID4Input | 1 | Pin 11: VID[4] Input
Pin1112VAnalogInput | 0 | Pin 11: 12V Analog Input
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1025.ConfInitType Enumeration

IRD

Adm1025ConfInitType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfInitType
Public Enumeration ConfInitType
public enum class ConfInitType
type ConfInitType
Members
Member name | Value | Description
RestorePowerUpValues | 1 | Restore Power-Up Values
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1025.ConfResetType Enumeration

IRD

Adm1025ConfResetType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfResetType
Public Enumeration ConfResetType
public enum class ConfResetType
type ConfResetType
Members
Member name | Value | Description
LowPulseOnPin16 | 1 | Low Pulse On Pin 16
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1025.ConfStartType Enumeration

IRD

Adm1025ConfStartType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfStartType
Public Enumeration ConfStartType
public enum class ConfStartType
type ConfStartType
Members
Member name | Value | Description
Startup | 1 | Startup
Standby | 0 | Standby
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1025.HighLowExceededType Enumeration

IRD

Adm1025HighLowExceededType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum HighLowExceededType
Public Enumeration HighLowExceededType
public enum class HighLowExceededType
type HighLowExceededType
Members
Member name | Value | Description
HighLowExceeded | 1 | High/Low Exceeded
HighLowNotExceeded | 0 | High/Low Not Exceeded
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1025.StatusDiodeFaultType Enumeration

IRD

Adm1025StatusDiodeFaultType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusDiodeFaultType
Public Enumeration StatusDiodeFaultType
public enum class StatusDiodeFaultType
type StatusDiodeFaultType
Members
Member name | Value | Description
ShortOrOpenCircuit | 1 | Short or Open-Circuit
NoError | 0 | No Error
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1025.TestType Enumeration

IRD

Adm1025TestType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TestType
Public Enumeration TestType
public enum class TestType
type TestType
Members
Member name | Value | Description
InterruptsDisabled | 0 | Interrupts Disabled
ThermalInterruptOnly | 1 | Thermal Interrupt Only
VoltageInterruptOnly | 2 | Voltage Interrupt Only
VoltageAndThermalInterrupts | 3 | Voltage And Thermal Interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1025.VidOffsetType Enumeration

IRD

Adm1025VidOffsetType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum VidOffsetType
Public Enumeration VidOffsetType
public enum class VidOffsetType
type VidOffsetType
Members
Member name | Value | Description
TemperatureChannelInternal | 1 | Temperature Channel: Internal
TemperatureChannelExternal | 0 | Temperature Channel: External
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1025.VidRstType Enumeration

IRD

Adm1025VidRstType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum VidRstType
Public Enumeration VidRstType
public enum class VidRstType
type VidRstType
Members
Member name | Value | Description
RSTOutputOnPin16Enabled | 1 | RST Output On Pin 16: Enabled
RSTOutputOnPin16Disabled | 0 | RST Output On Pin 16: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027 Class

Analog Devices: ADM 1027
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdm1027

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adm1027
Public Class Adm1027
public ref class Adm1027
type Adm1027 =  class end

The Adm1027 type exposes the following members.

Constructors
 | Name | Description
Public method | Adm1027 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CompanyID | Company ID
Public property | Configuration1FSPD | Configuration 1 (FSPD)
Public property | Configuration1FSPDIS | Configuration 1 (FSPDIS)
Public property | Configuration1LOCK | Configuration 1 (LOCK)
Public property | Configuration1RDY | Configuration 1 (RDY)
Public property | Configuration1STRT | Configuration 1 (STRT)
Public property | Configuration1TODIS | Configuration 1 (TODIS)
Public property | Configuration1VCC | Configuration 1 (V_CC)
Public property | Configuration1VXI | Configuration 1 (V x I)
Public property | Configuration2AIN1 | Configuration 2 (AIN1)
Public property | Configuration2AIN2 | Configuration 2 (AIN2)
Public property | Configuration2AIN3 | Configuration 2 (AIN3)
Public property | Configuration2AIN4 | Configuration 2 (AIN4)
Public property | Configuration2ATTN | Configuration 2 (ATTN)
Public property | Configuration2AVG | Configuration 2 (AVG)
Public property | Configuration2CONV | Configuration 2 (CONV)
Public property | Configuration3ALERT | Configuration 3 (ALERT)
Public property | Configuration3DC1 | Configuration 3 (DC1)
Public property | Configuration3DC2 | Configuration 3 (DC2)
Public property | Configuration3DC3 | Configuration 3 (DC3)
Public property | Configuration3DC4 | Configuration 3 (DC4)
Public property | Configuration3FAST | Configuration 3 (FAST)
Public property | DeviceID | Device ID
Public property | EnhanceAcoustics1ACOU | Enhance Acoustics 1 (ACOU)
Public property | EnhanceAcoustics1EN1 | Enhance Acoustics 1 (EN1)
Public property | EnhanceAcoustics1MIN1 | Enhance Acoustics 1 (MIN1)
Public property | EnhanceAcoustics1MIN2 | Enhance Acoustics 1 (MIN2)
Public property | EnhanceAcoustics1MIN3 | Enhance Acoustics 1 (MIN3)
Public property | EnhanceAcoustics2ACOU2 | Enhance Acoustics 2 (ACOU2)
Public property | EnhanceAcoustics2ACOU3 | Enhance Acoustics 2 (ACOU3)
Public property | EnhanceAcoustics2EN2 | Enhance Acoustics 2 (EN2)
Public property | EnhanceAcoustics2EN3 | Enhance Acoustics 2 (EN3)
Public property | FanPulsesPerResolutionFAN1 | Fan Pulses Per Resolution (FAN1)
Public property | FanPulsesPerResolutionFAN2 | Fan Pulses Per Resolution (FAN2)
Public property | FanPulsesPerResolutionFAN3 | Fan Pulses Per Resolution (FAN3)
Public property | FanPulsesPerResolutionFAN4 | Fan Pulses Per Resolution (FAN4)
Public property | InterruptMask125V | Interrupt Mask 1 (2.5V)
Public property | InterruptMask15V | Interrupt Mask 1 (5V)
Public property | InterruptMask1LT | Interrupt Mask 1 (LT)
Public property | InterruptMask1OOL | Interrupt Mask 1 (OOL)
Public property | InterruptMask1R1T | Interrupt Mask 1 (R1T)
Public property | InterruptMask1R2T | Interrupt Mask 1 (R2T)
Public property | InterruptMask1VCC | Interrupt Mask 1 (V_CC)
Public property | InterruptMask1VCCP | Interrupt Mask 1 (V_CCP)
Public property | InterruptMask212V | Interrupt Mask 2 (12V)
Public property | InterruptMask2D1 | Interrupt Mask 2 (D1)
Public property | InterruptMask2D2 | Interrupt Mask 2 (D2)
Public property | InterruptMask2FAN1 | Interrupt Mask 2 (FAN1)
Public property | InterruptMask2FAN2 | Interrupt Mask 2 (FAN2)
Public property | InterruptMask2FAN3 | Interrupt Mask 2 (FAN3)
Public property | InterruptMask2FAN4 | Interrupt Mask 2 (FAN4)
Public property | InterruptMask2OVT | Interrupt Mask 2 (OVT)
Public property | LocalHysteresis | Local Hysteresis (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | LocalTemperatureHighLimit | Local Temperature High Limit (unit: °C)
Public property | LocalTemperatureLowLimit | Local Temperature Low Limit (unit: °C)
Public property | LocalTemperatureOffset | Local Temperature Offset (unit: °C)
Public property | LocalTempTMIN | Local Temp T_MIN (unit: °C)
Public property | LocalTHERMLimit | Local THERM Limit (unit: °C)
Public property | LocalTRANGE | Local T_RANGE
Public property | Property_12VHighLimit | 12V High Limit (unit: V)
Public property | Property_12VLowLimit | 12V Low Limit (unit: V)
Public property | Property_12VReading | 12V Reading (unit: V)
Public property | Property_25VHighLimit | 2.5V High Limit (unit: V)
Public property | Property_25VLowLimit | 2.5V Low Limit (unit: V)
Public property | Property_25VReading | 2.5V Reading (unit: V)
Public property | Property_5VHighLimit | 5V High Limit (unit: V)
Public property | Property_5VLowLimit | 5V Low Limit (unit: V)
Public property | Property_5VReading | 5V Reading (unit: V)
Public property | PWM1ConfigurationBHVR | PWM1 Configuration (BHVR)
Public property | PWM1ConfigurationINV | PWM1 Configuration (INV)
Public property | PWM1ConfigurationSPIN | PWM1 Configuration (SPIN)
Public property | PWM1CurrentDutyCycle | PWM1 Current Duty Cycle (unit: %)
Public property | PWM1Freq | PWM 1 Freq
Public property | PWM1MinDutyCycle | PWM1 Min Duty Cycle (unit: %)
Public property | PWM2ConfigurationBHVR | PWM2 Configuration (BHVR)
Public property | PWM2ConfigurationINV | PWM2 Configuration (INV)
Public property | PWM2ConfigurationSPIN | PWM2 Configuration (SPIN)
Public property | PWM2CurrentDutyCycle | PWM2 Current Duty Cycle (unit: %)
Public property | PWM2Freq | PWM 2 Freq
Public property | PWM2MinDutyCycle | PWM2 Min Duty Cycle (unit: %)
Public property | PWM3ConfigurationBHVR | PWM3 Configuration (BHVR)
Public property | PWM3ConfigurationINV | PWM3 Configuration (INV)
Public property | PWM3ConfigurationSPIN | PWM3 Configuration (SPIN)
Public property | PWM3CurrentDutyCycle | PWM3 Current Duty Cycle (unit: %)
Public property | PWM3Freq | PWM 3 Freq
Public property | PWM3MinDutyCycle | PWM3 Min Duty Cycle (unit: %)
Public property | Remote1Hysteresis | Remote 1 Hysteresis (unit: °C)
Public property | Remote1Temperature | Remote 1 Temperature (unit: °C)
Public property | Remote1TemperatureOffset | Remote 1 Temperature Offset (unit: °C)
Public property | Remote1TempHighLimit | Remote 1 Temp High Limit (unit: °C)
Public property | Remote1TempLowLimit | Remote 1 Temp Low Limit (unit: °C)
Public property | Remote1TempTMIN | Remote 1 Temp T_MIN (unit: °C)
Public property | Remote1THERMLimit | Remote 1 THERM Limit (unit: °C)
Public property | Remote1TRANGE | Remote 1 T_RANGE
Public property | Remote2Temperature | Remote 2 Temperature (unit: °C)
Public property | Remote2TemperatureHysteresis | Remote 2 Temperature Hysteresis (unit: °C)
Public property | Remote2TemperatureOffset | Remote 2 Temperature Offset (unit: °C)
Public property | Remote2TempHighLimit | Remote 2 Temp High Limit (unit: °C)
Public property | Remote2TempLowLimit | Remote 2 Temp Low Limit (unit: °C)
Public property | Remote2TempTMIN | Remote 2 Temp T_MIN (unit: °C)
Public property | Remote2THERMLimit | Remote 2 THERM Limit (unit: °C)
Public property | Remote2TRANGE | Remote 2 T_RANGE
Public property | Status125V | Status 1 (2.5V)
Public property | Status15V | Status 1 (5V)
Public property | Status1LT | Status 1 (LT)
Public property | Status1OOL | Status 1 (OOL)
Public property | Status1R1T | Status 1 (R1T)
Public property | Status1R2T | Status 1 (R2T)
Public property | Status1VCC | Status 1 (V_CC)
Public property | Status1VCCP | Status 1 (V_CCP)
Public property | Status212V | Status 2 (12V)
Public property | Status2D1 | Status 2 (D1)
Public property | Status2D2 | Status 2 (D2)
Public property | Status2FAN1 | Status 2 (FAN1)
Public property | Status2FAN2 | Status 2 (FAN2)
Public property | Status2FAN3 | Status 2 (FAN3)
Public property | Status2FAN4 | Status 2 (FAN4)
Public property | Status2OVT | Status 2 (OVT)
Public property | Stepping | Stepping
Public property | TACH1 | TACH1
Public property | TACH1Minimum | TACH1 Minimum
Public property | TACH2 | TACH2
Public property | TACH2Minimum | TACH2 Minimum
Public property | TACH3 | TACH3
Public property | TACH3Minimum | TACH3 Minimum
Public property | TACH4 | TACH4
Public property | TACH4Minimum | TACH4 Minimum
Public property | VCCHighLimit | V_CC High Limit
Public property | VCCLowLimit | V_CC Low Limit
Public property | VCCPHighLimit | V_CCP High Limit (unit: V)
Public property | VCCPLowLimit | V_CCP Low Limit (unit: V)
Public property | VCCPReading | V_CCP Reading (unit: V)
Public property | VCCReading | V_CC Reading
Public property | Version | Version
Public property | VID40 | VID[4:0]
Public property | XORTreeTestEnableXEN | XOR Tree Test Enable (XEN)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
dbCOOL Remote Thermal Controller And Voltage Monitor
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adm1027(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adm1027

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027 Properties

The Adm1027 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CompanyID | Company ID
Public property | Configuration1FSPD | Configuration 1 (FSPD)
Public property | Configuration1FSPDIS | Configuration 1 (FSPDIS)
Public property | Configuration1LOCK | Configuration 1 (LOCK)
Public property | Configuration1RDY | Configuration 1 (RDY)
Public property | Configuration1STRT | Configuration 1 (STRT)
Public property | Configuration1TODIS | Configuration 1 (TODIS)
Public property | Configuration1VCC | Configuration 1 (V_CC)
Public property | Configuration1VXI | Configuration 1 (V x I)
Public property | Configuration2AIN1 | Configuration 2 (AIN1)
Public property | Configuration2AIN2 | Configuration 2 (AIN2)
Public property | Configuration2AIN3 | Configuration 2 (AIN3)
Public property | Configuration2AIN4 | Configuration 2 (AIN4)
Public property | Configuration2ATTN | Configuration 2 (ATTN)
Public property | Configuration2AVG | Configuration 2 (AVG)
Public property | Configuration2CONV | Configuration 2 (CONV)
Public property | Configuration3ALERT | Configuration 3 (ALERT)
Public property | Configuration3DC1 | Configuration 3 (DC1)
Public property | Configuration3DC2 | Configuration 3 (DC2)
Public property | Configuration3DC3 | Configuration 3 (DC3)
Public property | Configuration3DC4 | Configuration 3 (DC4)
Public property | Configuration3FAST | Configuration 3 (FAST)
Public property | DeviceID | Device ID
Public property | EnhanceAcoustics1ACOU | Enhance Acoustics 1 (ACOU)
Public property | EnhanceAcoustics1EN1 | Enhance Acoustics 1 (EN1)
Public property | EnhanceAcoustics1MIN1 | Enhance Acoustics 1 (MIN1)
Public property | EnhanceAcoustics1MIN2 | Enhance Acoustics 1 (MIN2)
Public property | EnhanceAcoustics1MIN3 | Enhance Acoustics 1 (MIN3)
Public property | EnhanceAcoustics2ACOU2 | Enhance Acoustics 2 (ACOU2)
Public property | EnhanceAcoustics2ACOU3 | Enhance Acoustics 2 (ACOU3)
Public property | EnhanceAcoustics2EN2 | Enhance Acoustics 2 (EN2)
Public property | EnhanceAcoustics2EN3 | Enhance Acoustics 2 (EN3)
Public property | FanPulsesPerResolutionFAN1 | Fan Pulses Per Resolution (FAN1)
Public property | FanPulsesPerResolutionFAN2 | Fan Pulses Per Resolution (FAN2)
Public property | FanPulsesPerResolutionFAN3 | Fan Pulses Per Resolution (FAN3)
Public property | FanPulsesPerResolutionFAN4 | Fan Pulses Per Resolution (FAN4)
Public property | InterruptMask125V | Interrupt Mask 1 (2.5V)
Public property | InterruptMask15V | Interrupt Mask 1 (5V)
Public property | InterruptMask1LT | Interrupt Mask 1 (LT)
Public property | InterruptMask1OOL | Interrupt Mask 1 (OOL)
Public property | InterruptMask1R1T | Interrupt Mask 1 (R1T)
Public property | InterruptMask1R2T | Interrupt Mask 1 (R2T)
Public property | InterruptMask1VCC | Interrupt Mask 1 (V_CC)
Public property | InterruptMask1VCCP | Interrupt Mask 1 (V_CCP)
Public property | InterruptMask212V | Interrupt Mask 2 (12V)
Public property | InterruptMask2D1 | Interrupt Mask 2 (D1)
Public property | InterruptMask2D2 | Interrupt Mask 2 (D2)
Public property | InterruptMask2FAN1 | Interrupt Mask 2 (FAN1)
Public property | InterruptMask2FAN2 | Interrupt Mask 2 (FAN2)
Public property | InterruptMask2FAN3 | Interrupt Mask 2 (FAN3)
Public property | InterruptMask2FAN4 | Interrupt Mask 2 (FAN4)
Public property | InterruptMask2OVT | Interrupt Mask 2 (OVT)
Public property | LocalHysteresis | Local Hysteresis (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | LocalTemperatureHighLimit | Local Temperature High Limit (unit: °C)
Public property | LocalTemperatureLowLimit | Local Temperature Low Limit (unit: °C)
Public property | LocalTemperatureOffset | Local Temperature Offset (unit: °C)
Public property | LocalTempTMIN | Local Temp T_MIN (unit: °C)
Public property | LocalTHERMLimit | Local THERM Limit (unit: °C)
Public property | LocalTRANGE | Local T_RANGE
Public property | Property_12VHighLimit | 12V High Limit (unit: V)
Public property | Property_12VLowLimit | 12V Low Limit (unit: V)
Public property | Property_12VReading | 12V Reading (unit: V)
Public property | Property_25VHighLimit | 2.5V High Limit (unit: V)
Public property | Property_25VLowLimit | 2.5V Low Limit (unit: V)
Public property | Property_25VReading | 2.5V Reading (unit: V)
Public property | Property_5VHighLimit | 5V High Limit (unit: V)
Public property | Property_5VLowLimit | 5V Low Limit (unit: V)
Public property | Property_5VReading | 5V Reading (unit: V)
Public property | PWM1ConfigurationBHVR | PWM1 Configuration (BHVR)
Public property | PWM1ConfigurationINV | PWM1 Configuration (INV)
Public property | PWM1ConfigurationSPIN | PWM1 Configuration (SPIN)
Public property | PWM1CurrentDutyCycle | PWM1 Current Duty Cycle (unit: %)
Public property | PWM1Freq | PWM 1 Freq
Public property | PWM1MinDutyCycle | PWM1 Min Duty Cycle (unit: %)
Public property | PWM2ConfigurationBHVR | PWM2 Configuration (BHVR)
Public property | PWM2ConfigurationINV | PWM2 Configuration (INV)
Public property | PWM2ConfigurationSPIN | PWM2 Configuration (SPIN)
Public property | PWM2CurrentDutyCycle | PWM2 Current Duty Cycle (unit: %)
Public property | PWM2Freq | PWM 2 Freq
Public property | PWM2MinDutyCycle | PWM2 Min Duty Cycle (unit: %)
Public property | PWM3ConfigurationBHVR | PWM3 Configuration (BHVR)
Public property | PWM3ConfigurationINV | PWM3 Configuration (INV)
Public property | PWM3ConfigurationSPIN | PWM3 Configuration (SPIN)
Public property | PWM3CurrentDutyCycle | PWM3 Current Duty Cycle (unit: %)
Public property | PWM3Freq | PWM 3 Freq
Public property | PWM3MinDutyCycle | PWM3 Min Duty Cycle (unit: %)
Public property | Remote1Hysteresis | Remote 1 Hysteresis (unit: °C)
Public property | Remote1Temperature | Remote 1 Temperature (unit: °C)
Public property | Remote1TemperatureOffset | Remote 1 Temperature Offset (unit: °C)
Public property | Remote1TempHighLimit | Remote 1 Temp High Limit (unit: °C)
Public property | Remote1TempLowLimit | Remote 1 Temp Low Limit (unit: °C)
Public property | Remote1TempTMIN | Remote 1 Temp T_MIN (unit: °C)
Public property | Remote1THERMLimit | Remote 1 THERM Limit (unit: °C)
Public property | Remote1TRANGE | Remote 1 T_RANGE
Public property | Remote2Temperature | Remote 2 Temperature (unit: °C)
Public property | Remote2TemperatureHysteresis | Remote 2 Temperature Hysteresis (unit: °C)
Public property | Remote2TemperatureOffset | Remote 2 Temperature Offset (unit: °C)
Public property | Remote2TempHighLimit | Remote 2 Temp High Limit (unit: °C)
Public property | Remote2TempLowLimit | Remote 2 Temp Low Limit (unit: °C)
Public property | Remote2TempTMIN | Remote 2 Temp T_MIN (unit: °C)
Public property | Remote2THERMLimit | Remote 2 THERM Limit (unit: °C)
Public property | Remote2TRANGE | Remote 2 T_RANGE
Public property | Status125V | Status 1 (2.5V)
Public property | Status15V | Status 1 (5V)
Public property | Status1LT | Status 1 (LT)
Public property | Status1OOL | Status 1 (OOL)
Public property | Status1R1T | Status 1 (R1T)
Public property | Status1R2T | Status 1 (R2T)
Public property | Status1VCC | Status 1 (V_CC)
Public property | Status1VCCP | Status 1 (V_CCP)
Public property | Status212V | Status 2 (12V)
Public property | Status2D1 | Status 2 (D1)
Public property | Status2D2 | Status 2 (D2)
Public property | Status2FAN1 | Status 2 (FAN1)
Public property | Status2FAN2 | Status 2 (FAN2)
Public property | Status2FAN3 | Status 2 (FAN3)
Public property | Status2FAN4 | Status 2 (FAN4)
Public property | Status2OVT | Status 2 (OVT)
Public property | Stepping | Stepping
Public property | TACH1 | TACH1
Public property | TACH1Minimum | TACH1 Minimum
Public property | TACH2 | TACH2
Public property | TACH2Minimum | TACH2 Minimum
Public property | TACH3 | TACH3
Public property | TACH3Minimum | TACH3 Minimum
Public property | TACH4 | TACH4
Public property | TACH4Minimum | TACH4 Minimum
Public property | VCCHighLimit | V_CC High Limit
Public property | VCCLowLimit | V_CC Low Limit
Public property | VCCPHighLimit | V_CCP High Limit (unit: V)
Public property | VCCPLowLimit | V_CCP Low Limit (unit: V)
Public property | VCCPReading | V_CCP Reading (unit: V)
Public property | VCCReading | V_CC Reading
Public property | Version | Version
Public property | VID40 | VID[4:0]
Public property | XORTreeTestEnableXEN | XOR Tree Test Enable (XEN)
Top
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.AutoFlush Property

IRD

Adm1027AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.CompanyID Property

IRD

Adm1027CompanyID Property

Company ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CompanyID { get; }
Public ReadOnly Property CompanyID As Byte
    Get
public:
property unsigned char CompanyID {
    unsigned char get ();
}
member CompanyID : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration1FSPD Property

IRD

Adm1027Configuration1FSPD Property

Configuration 1 (FSPD)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfFspdType Configuration1FSPD { get; set; }
Public Property Configuration1FSPD As Adm1027ConfFspdType
    Get
    Set
public:
property Adm1027ConfFspdType Configuration1FSPD {
    Adm1027ConfFspdType get ();
    void set (Adm1027ConfFspdType value);
}
member Configuration1FSPD : Adm1027ConfFspdType with get, set

Property Value

Type: Adm1027ConfFspdType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration1FSPDIS Property

IRD

Adm1027Configuration1FSPDIS Property

Configuration 1 (FSPDIS)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfFspdisType Configuration1FSPDIS { get; set; }
Public Property Configuration1FSPDIS As Adm1027ConfFspdisType
    Get
    Set
public:
property Adm1027ConfFspdisType Configuration1FSPDIS {
    Adm1027ConfFspdisType get ();
    void set (Adm1027ConfFspdisType value);
}
member Configuration1FSPDIS : Adm1027ConfFspdisType with get, set

Property Value

Type: Adm1027ConfFspdisType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration1LOCK Property

IRD

Adm1027Configuration1LOCK Property

Configuration 1 (LOCK)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfLockType Configuration1LOCK { set; }
Public WriteOnly Property Configuration1LOCK As Adm1027ConfLockType
    Set
public:
property Adm1027ConfLockType Configuration1LOCK {
    void set (Adm1027ConfLockType value);
}
member Configuration1LOCK : Adm1027ConfLockType with set

Property Value

Type: Adm1027ConfLockType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration1RDY Property

IRD

Adm1027Configuration1RDY Property

Configuration 1 (RDY)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfReadyType Configuration1RDY { get; }
Public ReadOnly Property Configuration1RDY As Adm1027ConfReadyType
    Get
public:
property Adm1027ConfReadyType Configuration1RDY {
    Adm1027ConfReadyType get ();
}
member Configuration1RDY : Adm1027ConfReadyType with get

Property Value

Type: Adm1027ConfReadyType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration1STRT Property

IRD

Adm1027Configuration1STRT Property

Configuration 1 (STRT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfStrtType Configuration1STRT { get; set; }
Public Property Configuration1STRT As Adm1027ConfStrtType
    Get
    Set
public:
property Adm1027ConfStrtType Configuration1STRT {
    Adm1027ConfStrtType get ();
    void set (Adm1027ConfStrtType value);
}
member Configuration1STRT : Adm1027ConfStrtType with get, set

Property Value

Type: Adm1027ConfStrtType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration1TODIS Property

IRD

Adm1027Configuration1TODIS Property

Configuration 1 (TODIS)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfTodisType Configuration1TODIS { get; set; }
Public Property Configuration1TODIS As Adm1027ConfTodisType
    Get
    Set
public:
property Adm1027ConfTodisType Configuration1TODIS {
    Adm1027ConfTodisType get ();
    void set (Adm1027ConfTodisType value);
}
member Configuration1TODIS : Adm1027ConfTodisType with get, set

Property Value

Type: Adm1027ConfTodisType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration1VCC Property

IRD

Adm1027Configuration1VCC Property

Configuration 1 (V_CC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfVCcType Configuration1VCC { get; set; }
Public Property Configuration1VCC As Adm1027ConfVCcType
    Get
    Set
public:
property Adm1027ConfVCcType Configuration1VCC {
    Adm1027ConfVCcType get ();
    void set (Adm1027ConfVCcType value);
}
member Configuration1VCC : Adm1027ConfVCcType with get, set

Property Value

Type: Adm1027ConfVCcType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration1VXI Property

IRD

Adm1027Configuration1VXI Property

Configuration 1 (V x I)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfViType Configuration1VXI { get; set; }
Public Property Configuration1VXI As Adm1027ConfViType
    Get
    Set
public:
property Adm1027ConfViType Configuration1VXI {
    Adm1027ConfViType get ();
    void set (Adm1027ConfViType value);
}
member Configuration1VXI : Adm1027ConfViType with get, set

Property Value

Type: Adm1027ConfViType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration2AIN1 Property

IRD

Adm1027Configuration2AIN1 Property

Configuration 2 (AIN1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfAinType Configuration2AIN1 { get; set; }
Public Property Configuration2AIN1 As Adm1027ConfAinType
    Get
    Set
public:
property Adm1027ConfAinType Configuration2AIN1 {
    Adm1027ConfAinType get ();
    void set (Adm1027ConfAinType value);
}
member Configuration2AIN1 : Adm1027ConfAinType with get, set

Property Value

Type: Adm1027ConfAinType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration2AIN2 Property

IRD

Adm1027Configuration2AIN2 Property

Configuration 2 (AIN2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfAinType Configuration2AIN2 { get; set; }
Public Property Configuration2AIN2 As Adm1027ConfAinType
    Get
    Set
public:
property Adm1027ConfAinType Configuration2AIN2 {
    Adm1027ConfAinType get ();
    void set (Adm1027ConfAinType value);
}
member Configuration2AIN2 : Adm1027ConfAinType with get, set

Property Value

Type: Adm1027ConfAinType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration2AIN3 Property

IRD

Adm1027Configuration2AIN3 Property

Configuration 2 (AIN3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfAinType Configuration2AIN3 { get; set; }
Public Property Configuration2AIN3 As Adm1027ConfAinType
    Get
    Set
public:
property Adm1027ConfAinType Configuration2AIN3 {
    Adm1027ConfAinType get ();
    void set (Adm1027ConfAinType value);
}
member Configuration2AIN3 : Adm1027ConfAinType with get, set

Property Value

Type: Adm1027ConfAinType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration2AIN4 Property

IRD

Adm1027Configuration2AIN4 Property

Configuration 2 (AIN4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfAinType Configuration2AIN4 { get; set; }
Public Property Configuration2AIN4 As Adm1027ConfAinType
    Get
    Set
public:
property Adm1027ConfAinType Configuration2AIN4 {
    Adm1027ConfAinType get ();
    void set (Adm1027ConfAinType value);
}
member Configuration2AIN4 : Adm1027ConfAinType with get, set

Property Value

Type: Adm1027ConfAinType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration2ATTN Property

IRD

Adm1027Configuration2ATTN Property

Configuration 2 (ATTN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfAttnType Configuration2ATTN { get; set; }
Public Property Configuration2ATTN As Adm1027ConfAttnType
    Get
    Set
public:
property Adm1027ConfAttnType Configuration2ATTN {
    Adm1027ConfAttnType get ();
    void set (Adm1027ConfAttnType value);
}
member Configuration2ATTN : Adm1027ConfAttnType with get, set

Property Value

Type: Adm1027ConfAttnType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration2AVG Property

IRD

Adm1027Configuration2AVG Property

Configuration 2 (AVG)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfAvgType Configuration2AVG { get; set; }
Public Property Configuration2AVG As Adm1027ConfAvgType
    Get
    Set
public:
property Adm1027ConfAvgType Configuration2AVG {
    Adm1027ConfAvgType get ();
    void set (Adm1027ConfAvgType value);
}
member Configuration2AVG : Adm1027ConfAvgType with get, set

Property Value

Type: Adm1027ConfAvgType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration2CONV Property

IRD

Adm1027Configuration2CONV Property

Configuration 2 (CONV)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfConvType Configuration2CONV { get; set; }
Public Property Configuration2CONV As Adm1027ConfConvType
    Get
    Set
public:
property Adm1027ConfConvType Configuration2CONV {
    Adm1027ConfConvType get ();
    void set (Adm1027ConfConvType value);
}
member Configuration2CONV : Adm1027ConfConvType with get, set

Property Value

Type: Adm1027ConfConvType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration3ALERT Property

IRD

Adm1027Configuration3ALERT Property

Configuration 3 (ALERT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfAlertType Configuration3ALERT { get; set; }
Public Property Configuration3ALERT As Adm1027ConfAlertType
    Get
    Set
public:
property Adm1027ConfAlertType Configuration3ALERT {
    Adm1027ConfAlertType get ();
    void set (Adm1027ConfAlertType value);
}
member Configuration3ALERT : Adm1027ConfAlertType with get, set

Property Value

Type: Adm1027ConfAlertType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration3DC1 Property

IRD

Adm1027Configuration3DC1 Property

Configuration 3 (DC1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfDcType Configuration3DC1 { get; set; }
Public Property Configuration3DC1 As Adm1027ConfDcType
    Get
    Set
public:
property Adm1027ConfDcType Configuration3DC1 {
    Adm1027ConfDcType get ();
    void set (Adm1027ConfDcType value);
}
member Configuration3DC1 : Adm1027ConfDcType with get, set

Property Value

Type: Adm1027ConfDcType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration3DC2 Property

IRD

Adm1027Configuration3DC2 Property

Configuration 3 (DC2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfDcType Configuration3DC2 { get; set; }
Public Property Configuration3DC2 As Adm1027ConfDcType
    Get
    Set
public:
property Adm1027ConfDcType Configuration3DC2 {
    Adm1027ConfDcType get ();
    void set (Adm1027ConfDcType value);
}
member Configuration3DC2 : Adm1027ConfDcType with get, set

Property Value

Type: Adm1027ConfDcType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration3DC3 Property

IRD

Adm1027Configuration3DC3 Property

Configuration 3 (DC3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfDcType Configuration3DC3 { get; set; }
Public Property Configuration3DC3 As Adm1027ConfDcType
    Get
    Set
public:
property Adm1027ConfDcType Configuration3DC3 {
    Adm1027ConfDcType get ();
    void set (Adm1027ConfDcType value);
}
member Configuration3DC3 : Adm1027ConfDcType with get, set

Property Value

Type: Adm1027ConfDcType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration3DC4 Property

IRD

Adm1027Configuration3DC4 Property

Configuration 3 (DC4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfDcType Configuration3DC4 { get; set; }
Public Property Configuration3DC4 As Adm1027ConfDcType
    Get
    Set
public:
property Adm1027ConfDcType Configuration3DC4 {
    Adm1027ConfDcType get ();
    void set (Adm1027ConfDcType value);
}
member Configuration3DC4 : Adm1027ConfDcType with get, set

Property Value

Type: Adm1027ConfDcType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Configuration3FAST Property

IRD

Adm1027Configuration3FAST Property

Configuration 3 (FAST)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfFastType Configuration3FAST { get; set; }
Public Property Configuration3FAST As Adm1027ConfFastType
    Get
    Set
public:
property Adm1027ConfFastType Configuration3FAST {
    Adm1027ConfFastType get ();
    void set (Adm1027ConfFastType value);
}
member Configuration3FAST : Adm1027ConfFastType with get, set

Property Value

Type: Adm1027ConfFastType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.DeviceID Property

IRD

Adm1027DeviceID Property

Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.EnhanceAcoustics1ACOU Property

IRD

Adm1027EnhanceAcoustics1ACOU Property

Enhance Acoustics 1 (ACOU)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027AcousticsAcouType EnhanceAcoustics1ACOU { get; }
Public ReadOnly Property EnhanceAcoustics1ACOU As Adm1027AcousticsAcouType
    Get
public:
property Adm1027AcousticsAcouType EnhanceAcoustics1ACOU {
    Adm1027AcousticsAcouType get ();
}
member EnhanceAcoustics1ACOU : Adm1027AcousticsAcouType with get

Property Value

Type: Adm1027AcousticsAcouType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.EnhanceAcoustics1EN1 Property

IRD

Adm1027EnhanceAcoustics1EN1 Property

Enhance Acoustics 1 (EN1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027AcousticsEnType EnhanceAcoustics1EN1 { get; set; }
Public Property EnhanceAcoustics1EN1 As Adm1027AcousticsEnType
    Get
    Set
public:
property Adm1027AcousticsEnType EnhanceAcoustics1EN1 {
    Adm1027AcousticsEnType get ();
    void set (Adm1027AcousticsEnType value);
}
member EnhanceAcoustics1EN1 : Adm1027AcousticsEnType with get, set

Property Value

Type: Adm1027AcousticsEnType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.EnhanceAcoustics1MIN1 Property

IRD

Adm1027EnhanceAcoustics1MIN1 Property

Enhance Acoustics 1 (MIN1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027AcousticsMinType EnhanceAcoustics1MIN1 { get; set; }
Public Property EnhanceAcoustics1MIN1 As Adm1027AcousticsMinType
    Get
    Set
public:
property Adm1027AcousticsMinType EnhanceAcoustics1MIN1 {
    Adm1027AcousticsMinType get ();
    void set (Adm1027AcousticsMinType value);
}
member EnhanceAcoustics1MIN1 : Adm1027AcousticsMinType with get, set

Property Value

Type: Adm1027AcousticsMinType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.EnhanceAcoustics1MIN2 Property

IRD

Adm1027EnhanceAcoustics1MIN2 Property

Enhance Acoustics 1 (MIN2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027AcousticsMinType EnhanceAcoustics1MIN2 { get; set; }
Public Property EnhanceAcoustics1MIN2 As Adm1027AcousticsMinType
    Get
    Set
public:
property Adm1027AcousticsMinType EnhanceAcoustics1MIN2 {
    Adm1027AcousticsMinType get ();
    void set (Adm1027AcousticsMinType value);
}
member EnhanceAcoustics1MIN2 : Adm1027AcousticsMinType with get, set

Property Value

Type: Adm1027AcousticsMinType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.EnhanceAcoustics1MIN3 Property

IRD

Adm1027EnhanceAcoustics1MIN3 Property

Enhance Acoustics 1 (MIN3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027AcousticsMinType EnhanceAcoustics1MIN3 { get; set; }
Public Property EnhanceAcoustics1MIN3 As Adm1027AcousticsMinType
    Get
    Set
public:
property Adm1027AcousticsMinType EnhanceAcoustics1MIN3 {
    Adm1027AcousticsMinType get ();
    void set (Adm1027AcousticsMinType value);
}
member EnhanceAcoustics1MIN3 : Adm1027AcousticsMinType with get, set

Property Value

Type: Adm1027AcousticsMinType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.EnhanceAcoustics2ACOU2 Property

IRD

Adm1027EnhanceAcoustics2ACOU2 Property

Enhance Acoustics 2 (ACOU2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027AcousticsAcouType EnhanceAcoustics2ACOU2 { get; set; }
Public Property EnhanceAcoustics2ACOU2 As Adm1027AcousticsAcouType
    Get
    Set
public:
property Adm1027AcousticsAcouType EnhanceAcoustics2ACOU2 {
    Adm1027AcousticsAcouType get ();
    void set (Adm1027AcousticsAcouType value);
}
member EnhanceAcoustics2ACOU2 : Adm1027AcousticsAcouType with get, set

Property Value

Type: Adm1027AcousticsAcouType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.EnhanceAcoustics2ACOU3 Property

IRD

Adm1027EnhanceAcoustics2ACOU3 Property

Enhance Acoustics 2 (ACOU3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027AcousticsAcouType EnhanceAcoustics2ACOU3 { get; set; }
Public Property EnhanceAcoustics2ACOU3 As Adm1027AcousticsAcouType
    Get
    Set
public:
property Adm1027AcousticsAcouType EnhanceAcoustics2ACOU3 {
    Adm1027AcousticsAcouType get ();
    void set (Adm1027AcousticsAcouType value);
}
member EnhanceAcoustics2ACOU3 : Adm1027AcousticsAcouType with get, set

Property Value

Type: Adm1027AcousticsAcouType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.EnhanceAcoustics2EN2 Property

IRD

Adm1027EnhanceAcoustics2EN2 Property

Enhance Acoustics 2 (EN2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027AcousticsEnType EnhanceAcoustics2EN2 { get; set; }
Public Property EnhanceAcoustics2EN2 As Adm1027AcousticsEnType
    Get
    Set
public:
property Adm1027AcousticsEnType EnhanceAcoustics2EN2 {
    Adm1027AcousticsEnType get ();
    void set (Adm1027AcousticsEnType value);
}
member EnhanceAcoustics2EN2 : Adm1027AcousticsEnType with get, set

Property Value

Type: Adm1027AcousticsEnType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.EnhanceAcoustics2EN3 Property

IRD

Adm1027EnhanceAcoustics2EN3 Property

Enhance Acoustics 2 (EN3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027AcousticsEnType EnhanceAcoustics2EN3 { get; set; }
Public Property EnhanceAcoustics2EN3 As Adm1027AcousticsEnType
    Get
    Set
public:
property Adm1027AcousticsEnType EnhanceAcoustics2EN3 {
    Adm1027AcousticsEnType get ();
    void set (Adm1027AcousticsEnType value);
}
member EnhanceAcoustics2EN3 : Adm1027AcousticsEnType with get, set

Property Value

Type: Adm1027AcousticsEnType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.FanPulsesPerResolutionFAN1 Property

IRD

Adm1027FanPulsesPerResolutionFAN1 Property

Fan Pulses Per Resolution (FAN1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FanPulsesPerResolutionFAN1 { get; set; }
Public Property FanPulsesPerResolutionFAN1 As Byte
    Get
    Set
public:
property unsigned char FanPulsesPerResolutionFAN1 {
    unsigned char get ();
    void set (unsigned char value);
}
member FanPulsesPerResolutionFAN1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.FanPulsesPerResolutionFAN2 Property

IRD

Adm1027FanPulsesPerResolutionFAN2 Property

Fan Pulses Per Resolution (FAN2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FanPulsesPerResolutionFAN2 { get; set; }
Public Property FanPulsesPerResolutionFAN2 As Byte
    Get
    Set
public:
property unsigned char FanPulsesPerResolutionFAN2 {
    unsigned char get ();
    void set (unsigned char value);
}
member FanPulsesPerResolutionFAN2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.FanPulsesPerResolutionFAN3 Property

IRD

Adm1027FanPulsesPerResolutionFAN3 Property

Fan Pulses Per Resolution (FAN3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FanPulsesPerResolutionFAN3 { get; set; }
Public Property FanPulsesPerResolutionFAN3 As Byte
    Get
    Set
public:
property unsigned char FanPulsesPerResolutionFAN3 {
    unsigned char get ();
    void set (unsigned char value);
}
member FanPulsesPerResolutionFAN3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.FanPulsesPerResolutionFAN4 Property

IRD

Adm1027FanPulsesPerResolutionFAN4 Property

Fan Pulses Per Resolution (FAN4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FanPulsesPerResolutionFAN4 { get; set; }
Public Property FanPulsesPerResolutionFAN4 As Byte
    Get
    Set
public:
property unsigned char FanPulsesPerResolutionFAN4 {
    unsigned char get ();
    void set (unsigned char value);
}
member FanPulsesPerResolutionFAN4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.InterruptMask125V Property

IRD

Adm1027InterruptMask125V Property

Interrupt Mask 1 (2.5V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027IrqMaskType InterruptMask125V { get; set; }
Public Property InterruptMask125V As Adm1027IrqMaskType
    Get
    Set
public:
property Adm1027IrqMaskType InterruptMask125V {
    Adm1027IrqMaskType get ();
    void set (Adm1027IrqMaskType value);
}
member InterruptMask125V : Adm1027IrqMaskType with get, set

Property Value

Type: Adm1027IrqMaskType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.InterruptMask15V Property

IRD

Adm1027InterruptMask15V Property

Interrupt Mask 1 (5V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027IrqMaskType InterruptMask15V { get; set; }
Public Property InterruptMask15V As Adm1027IrqMaskType
    Get
    Set
public:
property Adm1027IrqMaskType InterruptMask15V {
    Adm1027IrqMaskType get ();
    void set (Adm1027IrqMaskType value);
}
member InterruptMask15V : Adm1027IrqMaskType with get, set

Property Value

Type: Adm1027IrqMaskType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.InterruptMask1LT Property

IRD

Adm1027InterruptMask1LT Property

Interrupt Mask 1 (LT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027IrqMaskType InterruptMask1LT { get; set; }
Public Property InterruptMask1LT As Adm1027IrqMaskType
    Get
    Set
public:
property Adm1027IrqMaskType InterruptMask1LT {
    Adm1027IrqMaskType get ();
    void set (Adm1027IrqMaskType value);
}
member InterruptMask1LT : Adm1027IrqMaskType with get, set

Property Value

Type: Adm1027IrqMaskType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.InterruptMask1OOL Property

IRD

Adm1027InterruptMask1OOL Property

Interrupt Mask 1 (OOL)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027IrqOolType InterruptMask1OOL { get; set; }
Public Property InterruptMask1OOL As Adm1027IrqOolType
    Get
    Set
public:
property Adm1027IrqOolType InterruptMask1OOL {
    Adm1027IrqOolType get ();
    void set (Adm1027IrqOolType value);
}
member InterruptMask1OOL : Adm1027IrqOolType with get, set

Property Value

Type: Adm1027IrqOolType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.InterruptMask1R1T Property

IRD

Adm1027InterruptMask1R1T Property

Interrupt Mask 1 (R1T)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027IrqMaskType InterruptMask1R1T { get; set; }
Public Property InterruptMask1R1T As Adm1027IrqMaskType
    Get
    Set
public:
property Adm1027IrqMaskType InterruptMask1R1T {
    Adm1027IrqMaskType get ();
    void set (Adm1027IrqMaskType value);
}
member InterruptMask1R1T : Adm1027IrqMaskType with get, set

Property Value

Type: Adm1027IrqMaskType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.InterruptMask1R2T Property

IRD

Adm1027InterruptMask1R2T Property

Interrupt Mask 1 (R2T)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027IrqMaskType InterruptMask1R2T { get; set; }
Public Property InterruptMask1R2T As Adm1027IrqMaskType
    Get
    Set
public:
property Adm1027IrqMaskType InterruptMask1R2T {
    Adm1027IrqMaskType get ();
    void set (Adm1027IrqMaskType value);
}
member InterruptMask1R2T : Adm1027IrqMaskType with get, set

Property Value

Type: Adm1027IrqMaskType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.InterruptMask1VCC Property

IRD

Adm1027InterruptMask1VCC Property

Interrupt Mask 1 (V_CC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027IrqMaskType InterruptMask1VCC { get; set; }
Public Property InterruptMask1VCC As Adm1027IrqMaskType
    Get
    Set
public:
property Adm1027IrqMaskType InterruptMask1VCC {
    Adm1027IrqMaskType get ();
    void set (Adm1027IrqMaskType value);
}
member InterruptMask1VCC : Adm1027IrqMaskType with get, set

Property Value

Type: Adm1027IrqMaskType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.InterruptMask1VCCP Property

IRD

Adm1027InterruptMask1VCCP Property

Interrupt Mask 1 (V_CCP)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027IrqMaskType InterruptMask1VCCP { get; set; }
Public Property InterruptMask1VCCP As Adm1027IrqMaskType
    Get
    Set
public:
property Adm1027IrqMaskType InterruptMask1VCCP {
    Adm1027IrqMaskType get ();
    void set (Adm1027IrqMaskType value);
}
member InterruptMask1VCCP : Adm1027IrqMaskType with get, set

Property Value

Type: Adm1027IrqMaskType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.InterruptMask212V Property

IRD

Adm1027InterruptMask212V Property

Interrupt Mask 2 (12V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027IrqMaskType InterruptMask212V { get; set; }
Public Property InterruptMask212V As Adm1027IrqMaskType
    Get
    Set
public:
property Adm1027IrqMaskType InterruptMask212V {
    Adm1027IrqMaskType get ();
    void set (Adm1027IrqMaskType value);
}
member InterruptMask212V : Adm1027IrqMaskType with get, set

Property Value

Type: Adm1027IrqMaskType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.InterruptMask2D1 Property

IRD

Adm1027InterruptMask2D1 Property

Interrupt Mask 2 (D1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027IrqMaskType InterruptMask2D1 { get; set; }
Public Property InterruptMask2D1 As Adm1027IrqMaskType
    Get
    Set
public:
property Adm1027IrqMaskType InterruptMask2D1 {
    Adm1027IrqMaskType get ();
    void set (Adm1027IrqMaskType value);
}
member InterruptMask2D1 : Adm1027IrqMaskType with get, set

Property Value

Type: Adm1027IrqMaskType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.InterruptMask2D2 Property

IRD

Adm1027InterruptMask2D2 Property

Interrupt Mask 2 (D2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027IrqOolType InterruptMask2D2 { get; set; }
Public Property InterruptMask2D2 As Adm1027IrqOolType
    Get
    Set
public:
property Adm1027IrqOolType InterruptMask2D2 {
    Adm1027IrqOolType get ();
    void set (Adm1027IrqOolType value);
}
member InterruptMask2D2 : Adm1027IrqOolType with get, set

Property Value

Type: Adm1027IrqOolType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.InterruptMask2FAN1 Property

IRD

Adm1027InterruptMask2FAN1 Property

Interrupt Mask 2 (FAN1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027IrqMaskType InterruptMask2FAN1 { get; set; }
Public Property InterruptMask2FAN1 As Adm1027IrqMaskType
    Get
    Set
public:
property Adm1027IrqMaskType InterruptMask2FAN1 {
    Adm1027IrqMaskType get ();
    void set (Adm1027IrqMaskType value);
}
member InterruptMask2FAN1 : Adm1027IrqMaskType with get, set

Property Value

Type: Adm1027IrqMaskType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.InterruptMask2FAN2 Property

IRD

Adm1027InterruptMask2FAN2 Property

Interrupt Mask 2 (FAN2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027IrqMaskType InterruptMask2FAN2 { get; set; }
Public Property InterruptMask2FAN2 As Adm1027IrqMaskType
    Get
    Set
public:
property Adm1027IrqMaskType InterruptMask2FAN2 {
    Adm1027IrqMaskType get ();
    void set (Adm1027IrqMaskType value);
}
member InterruptMask2FAN2 : Adm1027IrqMaskType with get, set

Property Value

Type: Adm1027IrqMaskType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.InterruptMask2FAN3 Property

IRD

Adm1027InterruptMask2FAN3 Property

Interrupt Mask 2 (FAN3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027IrqMaskType InterruptMask2FAN3 { get; set; }
Public Property InterruptMask2FAN3 As Adm1027IrqMaskType
    Get
    Set
public:
property Adm1027IrqMaskType InterruptMask2FAN3 {
    Adm1027IrqMaskType get ();
    void set (Adm1027IrqMaskType value);
}
member InterruptMask2FAN3 : Adm1027IrqMaskType with get, set

Property Value

Type: Adm1027IrqMaskType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.InterruptMask2FAN4 Property

IRD

Adm1027InterruptMask2FAN4 Property

Interrupt Mask 2 (FAN4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027IrqMaskType InterruptMask2FAN4 { get; set; }
Public Property InterruptMask2FAN4 As Adm1027IrqMaskType
    Get
    Set
public:
property Adm1027IrqMaskType InterruptMask2FAN4 {
    Adm1027IrqMaskType get ();
    void set (Adm1027IrqMaskType value);
}
member InterruptMask2FAN4 : Adm1027IrqMaskType with get, set

Property Value

Type: Adm1027IrqMaskType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.InterruptMask2OVT Property

IRD

Adm1027InterruptMask2OVT Property

Interrupt Mask 2 (OVT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027IrqMaskType InterruptMask2OVT { get; }
Public ReadOnly Property InterruptMask2OVT As Adm1027IrqMaskType
    Get
public:
property Adm1027IrqMaskType InterruptMask2OVT {
    Adm1027IrqMaskType get ();
}
member InterruptMask2OVT : Adm1027IrqMaskType with get

Property Value

Type: Adm1027IrqMaskType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.LocalHysteresis Property

IRD

Adm1027LocalHysteresis Property

Local Hysteresis (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalHysteresis { get; set; }
Public Property LocalHysteresis As Byte
    Get
    Set
public:
property unsigned char LocalHysteresis {
    unsigned char get ();
    void set (unsigned char value);
}
member LocalHysteresis : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.LocalTemperature Property

IRD

Adm1027LocalTemperature Property

Local Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LocalTemperature { get; }
Public ReadOnly Property LocalTemperature As Double
    Get
public:
property double LocalTemperature {
    double get ();
}
member LocalTemperature : float with get

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.LocalTemperatureHighLimit Property

IRD

Adm1027LocalTemperatureHighLimit Property

Local Temperature High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTemperatureHighLimit { get; set; }
Public Property LocalTemperatureHighLimit As SByte
    Get
    Set
public:
property signed char LocalTemperatureHighLimit {
    signed char get ();
    void set (signed char value);
}
member LocalTemperatureHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.LocalTemperatureLowLimit Property

IRD

Adm1027LocalTemperatureLowLimit Property

Local Temperature Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTemperatureLowLimit { get; set; }
Public Property LocalTemperatureLowLimit As SByte
    Get
    Set
public:
property signed char LocalTemperatureLowLimit {
    signed char get ();
    void set (signed char value);
}
member LocalTemperatureLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.LocalTemperatureOffset Property

IRD

Adm1027LocalTemperatureOffset Property

Local Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTemperatureOffset { get; set; }
Public Property LocalTemperatureOffset As SByte
    Get
    Set
public:
property signed char LocalTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member LocalTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.LocalTempTMIN Property

IRD

Adm1027LocalTempTMIN Property

Local Temp T_MIN (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTempTMIN { get; set; }
Public Property LocalTempTMIN As SByte
    Get
    Set
public:
property signed char LocalTempTMIN {
    signed char get ();
    void set (signed char value);
}
member LocalTempTMIN : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.LocalTHERMLimit Property

IRD

Adm1027LocalTHERMLimit Property

Local THERM Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTHERMLimit { get; set; }
Public Property LocalTHERMLimit As SByte
    Get
    Set
public:
property signed char LocalTHERMLimit {
    signed char get ();
    void set (signed char value);
}
member LocalTHERMLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.LocalTRANGE Property

IRD

Adm1027LocalTRANGE Property

Local T_RANGE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027TRangeRangeType LocalTRANGE { get; set; }
Public Property LocalTRANGE As Adm1027TRangeRangeType
    Get
    Set
public:
property Adm1027TRangeRangeType LocalTRANGE {
    Adm1027TRangeRangeType get ();
    void set (Adm1027TRangeRangeType value);
}
member LocalTRANGE : Adm1027TRangeRangeType with get, set

Property Value

Type: Adm1027TRangeRangeType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Property_12VHighLimit Property

IRD

Adm1027Property_12VHighLimit Property

12V High Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_12VHighLimit { get; set; }
Public Property Property_12VHighLimit As Double
    Get
    Set
public:
property double Property_12VHighLimit {
    double get ();
    void set (double value);
}
member Property_12VHighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Property_12VLowLimit Property

IRD

Adm1027Property_12VLowLimit Property

12V Low Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_12VLowLimit { get; set; }
Public Property Property_12VLowLimit As Double
    Get
    Set
public:
property double Property_12VLowLimit {
    double get ();
    void set (double value);
}
member Property_12VLowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Property_12VReading Property

IRD

Adm1027Property_12VReading Property

12V Reading (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_12VReading { get; }
Public ReadOnly Property Property_12VReading As Double
    Get
public:
property double Property_12VReading {
    double get ();
}
member Property_12VReading : float with get

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Property_25VHighLimit Property

IRD

Adm1027Property_25VHighLimit Property

2.5V High Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_25VHighLimit { get; set; }
Public Property Property_25VHighLimit As Double
    Get
    Set
public:
property double Property_25VHighLimit {
    double get ();
    void set (double value);
}
member Property_25VHighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Property_25VLowLimit Property

IRD

Adm1027Property_25VLowLimit Property

2.5V Low Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_25VLowLimit { get; set; }
Public Property Property_25VLowLimit As Double
    Get
    Set
public:
property double Property_25VLowLimit {
    double get ();
    void set (double value);
}
member Property_25VLowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Property_25VReading Property

IRD

Adm1027Property_25VReading Property

2.5V Reading (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_25VReading { get; }
Public ReadOnly Property Property_25VReading As Double
    Get
public:
property double Property_25VReading {
    double get ();
}
member Property_25VReading : float with get

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Property_5VHighLimit Property

IRD

Adm1027Property_5VHighLimit Property

5V High Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_5VHighLimit { get; set; }
Public Property Property_5VHighLimit As Double
    Get
    Set
public:
property double Property_5VHighLimit {
    double get ();
    void set (double value);
}
member Property_5VHighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Property_5VLowLimit Property

IRD

Adm1027Property_5VLowLimit Property

5V Low Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_5VLowLimit { get; set; }
Public Property Property_5VLowLimit As Double
    Get
    Set
public:
property double Property_5VLowLimit {
    double get ();
    void set (double value);
}
member Property_5VLowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Property_5VReading Property

IRD

Adm1027Property_5VReading Property

5V Reading (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_5VReading { get; }
Public ReadOnly Property Property_5VReading As Double
    Get
public:
property double Property_5VReading {
    double get ();
}
member Property_5VReading : float with get

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.PWM1ConfigurationBHVR Property

IRD

Adm1027PWM1ConfigurationBHVR Property

PWM1 Configuration (BHVR)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfPwmBhvrType PWM1ConfigurationBHVR { get; set; }
Public Property PWM1ConfigurationBHVR As Adm1027ConfPwmBhvrType
    Get
    Set
public:
property Adm1027ConfPwmBhvrType PWM1ConfigurationBHVR {
    Adm1027ConfPwmBhvrType get ();
    void set (Adm1027ConfPwmBhvrType value);
}
member PWM1ConfigurationBHVR : Adm1027ConfPwmBhvrType with get, set

Property Value

Type: Adm1027ConfPwmBhvrType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.PWM1ConfigurationINV Property

IRD

Adm1027PWM1ConfigurationINV Property

PWM1 Configuration (INV)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfPwmInvType PWM1ConfigurationINV { get; set; }
Public Property PWM1ConfigurationINV As Adm1027ConfPwmInvType
    Get
    Set
public:
property Adm1027ConfPwmInvType PWM1ConfigurationINV {
    Adm1027ConfPwmInvType get ();
    void set (Adm1027ConfPwmInvType value);
}
member PWM1ConfigurationINV : Adm1027ConfPwmInvType with get, set

Property Value

Type: Adm1027ConfPwmInvType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.PWM1ConfigurationSPIN Property

IRD

Adm1027PWM1ConfigurationSPIN Property

PWM1 Configuration (SPIN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfPwmSpinType PWM1ConfigurationSPIN { get; set; }
Public Property PWM1ConfigurationSPIN As Adm1027ConfPwmSpinType
    Get
    Set
public:
property Adm1027ConfPwmSpinType PWM1ConfigurationSPIN {
    Adm1027ConfPwmSpinType get ();
    void set (Adm1027ConfPwmSpinType value);
}
member PWM1ConfigurationSPIN : Adm1027ConfPwmSpinType with get, set

Property Value

Type: Adm1027ConfPwmSpinType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.PWM1CurrentDutyCycle Property

IRD

Adm1027PWM1CurrentDutyCycle Property

PWM1 Current Duty Cycle (unit: %)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double PWM1CurrentDutyCycle { get; set; }
Public Property PWM1CurrentDutyCycle As Double
    Get
    Set
public:
property double PWM1CurrentDutyCycle {
    double get ();
    void set (double value);
}
member PWM1CurrentDutyCycle : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.PWM1Freq Property

IRD

Adm1027PWM1Freq Property

PWM 1 Freq

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027TRangeFreqType PWM1Freq { get; set; }
Public Property PWM1Freq As Adm1027TRangeFreqType
    Get
    Set
public:
property Adm1027TRangeFreqType PWM1Freq {
    Adm1027TRangeFreqType get ();
    void set (Adm1027TRangeFreqType value);
}
member PWM1Freq : Adm1027TRangeFreqType with get, set

Property Value

Type: Adm1027TRangeFreqType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.PWM1MinDutyCycle Property

IRD

Adm1027PWM1MinDutyCycle Property

PWM1 Min Duty Cycle (unit: %)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double PWM1MinDutyCycle { get; set; }
Public Property PWM1MinDutyCycle As Double
    Get
    Set
public:
property double PWM1MinDutyCycle {
    double get ();
    void set (double value);
}
member PWM1MinDutyCycle : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.PWM2ConfigurationBHVR Property

IRD

Adm1027PWM2ConfigurationBHVR Property

PWM2 Configuration (BHVR)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfPwmBhvrType PWM2ConfigurationBHVR { get; set; }
Public Property PWM2ConfigurationBHVR As Adm1027ConfPwmBhvrType
    Get
    Set
public:
property Adm1027ConfPwmBhvrType PWM2ConfigurationBHVR {
    Adm1027ConfPwmBhvrType get ();
    void set (Adm1027ConfPwmBhvrType value);
}
member PWM2ConfigurationBHVR : Adm1027ConfPwmBhvrType with get, set

Property Value

Type: Adm1027ConfPwmBhvrType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.PWM2ConfigurationINV Property

IRD

Adm1027PWM2ConfigurationINV Property

PWM2 Configuration (INV)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfPwmInvType PWM2ConfigurationINV { get; set; }
Public Property PWM2ConfigurationINV As Adm1027ConfPwmInvType
    Get
    Set
public:
property Adm1027ConfPwmInvType PWM2ConfigurationINV {
    Adm1027ConfPwmInvType get ();
    void set (Adm1027ConfPwmInvType value);
}
member PWM2ConfigurationINV : Adm1027ConfPwmInvType with get, set

Property Value

Type: Adm1027ConfPwmInvType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.PWM2ConfigurationSPIN Property

IRD

Adm1027PWM2ConfigurationSPIN Property

PWM2 Configuration (SPIN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfPwmSpinType PWM2ConfigurationSPIN { get; set; }
Public Property PWM2ConfigurationSPIN As Adm1027ConfPwmSpinType
    Get
    Set
public:
property Adm1027ConfPwmSpinType PWM2ConfigurationSPIN {
    Adm1027ConfPwmSpinType get ();
    void set (Adm1027ConfPwmSpinType value);
}
member PWM2ConfigurationSPIN : Adm1027ConfPwmSpinType with get, set

Property Value

Type: Adm1027ConfPwmSpinType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.PWM2CurrentDutyCycle Property

IRD

Adm1027PWM2CurrentDutyCycle Property

PWM2 Current Duty Cycle (unit: %)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double PWM2CurrentDutyCycle { get; set; }
Public Property PWM2CurrentDutyCycle As Double
    Get
    Set
public:
property double PWM2CurrentDutyCycle {
    double get ();
    void set (double value);
}
member PWM2CurrentDutyCycle : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.PWM2Freq Property

IRD

Adm1027PWM2Freq Property

PWM 2 Freq

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027TRangeFreqType PWM2Freq { get; set; }
Public Property PWM2Freq As Adm1027TRangeFreqType
    Get
    Set
public:
property Adm1027TRangeFreqType PWM2Freq {
    Adm1027TRangeFreqType get ();
    void set (Adm1027TRangeFreqType value);
}
member PWM2Freq : Adm1027TRangeFreqType with get, set

Property Value

Type: Adm1027TRangeFreqType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.PWM2MinDutyCycle Property

IRD

Adm1027PWM2MinDutyCycle Property

PWM2 Min Duty Cycle (unit: %)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double PWM2MinDutyCycle { get; set; }
Public Property PWM2MinDutyCycle As Double
    Get
    Set
public:
property double PWM2MinDutyCycle {
    double get ();
    void set (double value);
}
member PWM2MinDutyCycle : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.PWM3ConfigurationBHVR Property

IRD

Adm1027PWM3ConfigurationBHVR Property

PWM3 Configuration (BHVR)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfPwmBhvrType PWM3ConfigurationBHVR { get; set; }
Public Property PWM3ConfigurationBHVR As Adm1027ConfPwmBhvrType
    Get
    Set
public:
property Adm1027ConfPwmBhvrType PWM3ConfigurationBHVR {
    Adm1027ConfPwmBhvrType get ();
    void set (Adm1027ConfPwmBhvrType value);
}
member PWM3ConfigurationBHVR : Adm1027ConfPwmBhvrType with get, set

Property Value

Type: Adm1027ConfPwmBhvrType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.PWM3ConfigurationINV Property

IRD

Adm1027PWM3ConfigurationINV Property

PWM3 Configuration (INV)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfPwmInvType PWM3ConfigurationINV { get; set; }
Public Property PWM3ConfigurationINV As Adm1027ConfPwmInvType
    Get
    Set
public:
property Adm1027ConfPwmInvType PWM3ConfigurationINV {
    Adm1027ConfPwmInvType get ();
    void set (Adm1027ConfPwmInvType value);
}
member PWM3ConfigurationINV : Adm1027ConfPwmInvType with get, set

Property Value

Type: Adm1027ConfPwmInvType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.PWM3ConfigurationSPIN Property

IRD

Adm1027PWM3ConfigurationSPIN Property

PWM3 Configuration (SPIN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027ConfPwmSpinType PWM3ConfigurationSPIN { get; set; }
Public Property PWM3ConfigurationSPIN As Adm1027ConfPwmSpinType
    Get
    Set
public:
property Adm1027ConfPwmSpinType PWM3ConfigurationSPIN {
    Adm1027ConfPwmSpinType get ();
    void set (Adm1027ConfPwmSpinType value);
}
member PWM3ConfigurationSPIN : Adm1027ConfPwmSpinType with get, set

Property Value

Type: Adm1027ConfPwmSpinType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.PWM3CurrentDutyCycle Property

IRD

Adm1027PWM3CurrentDutyCycle Property

PWM3 Current Duty Cycle (unit: %)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double PWM3CurrentDutyCycle { get; set; }
Public Property PWM3CurrentDutyCycle As Double
    Get
    Set
public:
property double PWM3CurrentDutyCycle {
    double get ();
    void set (double value);
}
member PWM3CurrentDutyCycle : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.PWM3Freq Property

IRD

Adm1027PWM3Freq Property

PWM 3 Freq

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027TRangeFreqType PWM3Freq { get; set; }
Public Property PWM3Freq As Adm1027TRangeFreqType
    Get
    Set
public:
property Adm1027TRangeFreqType PWM3Freq {
    Adm1027TRangeFreqType get ();
    void set (Adm1027TRangeFreqType value);
}
member PWM3Freq : Adm1027TRangeFreqType with get, set

Property Value

Type: Adm1027TRangeFreqType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.PWM3MinDutyCycle Property

IRD

Adm1027PWM3MinDutyCycle Property

PWM3 Min Duty Cycle (unit: %)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double PWM3MinDutyCycle { get; set; }
Public Property PWM3MinDutyCycle As Double
    Get
    Set
public:
property double PWM3MinDutyCycle {
    double get ();
    void set (double value);
}
member PWM3MinDutyCycle : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Remote1Hysteresis Property

IRD

Adm1027Remote1Hysteresis Property

Remote 1 Hysteresis (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote1Hysteresis { get; set; }
Public Property Remote1Hysteresis As Byte
    Get
    Set
public:
property unsigned char Remote1Hysteresis {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote1Hysteresis : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Remote1Temperature Property

IRD

Adm1027Remote1Temperature Property

Remote 1 Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote1Temperature { get; }
Public ReadOnly Property Remote1Temperature As Double
    Get
public:
property double Remote1Temperature {
    double get ();
}
member Remote1Temperature : float with get

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Remote1TemperatureOffset Property

IRD

Adm1027Remote1TemperatureOffset Property

Remote 1 Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote1TemperatureOffset { get; set; }
Public Property Remote1TemperatureOffset As SByte
    Get
    Set
public:
property signed char Remote1TemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member Remote1TemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Remote1TempHighLimit Property

IRD

Adm1027Remote1TempHighLimit Property

Remote 1 Temp High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote1TempHighLimit { get; set; }
Public Property Remote1TempHighLimit As SByte
    Get
    Set
public:
property signed char Remote1TempHighLimit {
    signed char get ();
    void set (signed char value);
}
member Remote1TempHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Remote1TempLowLimit Property

IRD

Adm1027Remote1TempLowLimit Property

Remote 1 Temp Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote1TempLowLimit { get; set; }
Public Property Remote1TempLowLimit As SByte
    Get
    Set
public:
property signed char Remote1TempLowLimit {
    signed char get ();
    void set (signed char value);
}
member Remote1TempLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Remote1TempTMIN Property

IRD

Adm1027Remote1TempTMIN Property

Remote 1 Temp T_MIN (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote1TempTMIN { get; set; }
Public Property Remote1TempTMIN As SByte
    Get
    Set
public:
property signed char Remote1TempTMIN {
    signed char get ();
    void set (signed char value);
}
member Remote1TempTMIN : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Remote1THERMLimit Property

IRD

Adm1027Remote1THERMLimit Property

Remote 1 THERM Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote1THERMLimit { get; set; }
Public Property Remote1THERMLimit As SByte
    Get
    Set
public:
property signed char Remote1THERMLimit {
    signed char get ();
    void set (signed char value);
}
member Remote1THERMLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Remote1TRANGE Property

IRD

Adm1027Remote1TRANGE Property

Remote 1 T_RANGE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027TRangeRangeType Remote1TRANGE { get; set; }
Public Property Remote1TRANGE As Adm1027TRangeRangeType
    Get
    Set
public:
property Adm1027TRangeRangeType Remote1TRANGE {
    Adm1027TRangeRangeType get ();
    void set (Adm1027TRangeRangeType value);
}
member Remote1TRANGE : Adm1027TRangeRangeType with get, set

Property Value

Type: Adm1027TRangeRangeType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Remote2Temperature Property

IRD

Adm1027Remote2Temperature Property

Remote 2 Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote2Temperature { get; }
Public ReadOnly Property Remote2Temperature As Double
    Get
public:
property double Remote2Temperature {
    double get ();
}
member Remote2Temperature : float with get

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Remote2TemperatureHysteresis Property

IRD

Adm1027Remote2TemperatureHysteresis Property

Remote 2 Temperature Hysteresis (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote2TemperatureHysteresis { get; set; }
Public Property Remote2TemperatureHysteresis As Byte
    Get
    Set
public:
property unsigned char Remote2TemperatureHysteresis {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote2TemperatureHysteresis : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Remote2TemperatureOffset Property

IRD

Adm1027Remote2TemperatureOffset Property

Remote 2 Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote2TemperatureOffset { get; set; }
Public Property Remote2TemperatureOffset As SByte
    Get
    Set
public:
property signed char Remote2TemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member Remote2TemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Remote2TempHighLimit Property

IRD

Adm1027Remote2TempHighLimit Property

Remote 2 Temp High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote2TempHighLimit { get; set; }
Public Property Remote2TempHighLimit As SByte
    Get
    Set
public:
property signed char Remote2TempHighLimit {
    signed char get ();
    void set (signed char value);
}
member Remote2TempHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Remote2TempLowLimit Property

IRD

Adm1027Remote2TempLowLimit Property

Remote 2 Temp Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote2TempLowLimit { get; set; }
Public Property Remote2TempLowLimit As SByte
    Get
    Set
public:
property signed char Remote2TempLowLimit {
    signed char get ();
    void set (signed char value);
}
member Remote2TempLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Remote2TempTMIN Property

IRD

Adm1027Remote2TempTMIN Property

Remote 2 Temp T_MIN (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote2TempTMIN { get; set; }
Public Property Remote2TempTMIN As SByte
    Get
    Set
public:
property signed char Remote2TempTMIN {
    signed char get ();
    void set (signed char value);
}
member Remote2TempTMIN : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Remote2THERMLimit Property

IRD

Adm1027Remote2THERMLimit Property

Remote 2 THERM Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote2THERMLimit { get; set; }
Public Property Remote2THERMLimit As SByte
    Get
    Set
public:
property signed char Remote2THERMLimit {
    signed char get ();
    void set (signed char value);
}
member Remote2THERMLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Remote2TRANGE Property

IRD

Adm1027Remote2TRANGE Property

Remote 2 T_RANGE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027TRangeRangeType Remote2TRANGE { get; set; }
Public Property Remote2TRANGE As Adm1027TRangeRangeType
    Get
    Set
public:
property Adm1027TRangeRangeType Remote2TRANGE {
    Adm1027TRangeRangeType get ();
    void set (Adm1027TRangeRangeType value);
}
member Remote2TRANGE : Adm1027TRangeRangeType with get, set

Property Value

Type: Adm1027TRangeRangeType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Status125V Property

IRD

Adm1027Status125V Property

Status 1 (2.5V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027StatusHighLowExceededType Status125V { get; }
Public ReadOnly Property Status125V As Adm1027StatusHighLowExceededType
    Get
public:
property Adm1027StatusHighLowExceededType Status125V {
    Adm1027StatusHighLowExceededType get ();
}
member Status125V : Adm1027StatusHighLowExceededType with get

Property Value

Type: Adm1027StatusHighLowExceededType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Status15V Property

IRD

Adm1027Status15V Property

Status 1 (5V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027StatusHighLowExceededType Status15V { get; }
Public ReadOnly Property Status15V As Adm1027StatusHighLowExceededType
    Get
public:
property Adm1027StatusHighLowExceededType Status15V {
    Adm1027StatusHighLowExceededType get ();
}
member Status15V : Adm1027StatusHighLowExceededType with get

Property Value

Type: Adm1027StatusHighLowExceededType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Status1LT Property

IRD

Adm1027Status1LT Property

Status 1 (LT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027StatusHighLowExceededType Status1LT { get; }
Public ReadOnly Property Status1LT As Adm1027StatusHighLowExceededType
    Get
public:
property Adm1027StatusHighLowExceededType Status1LT {
    Adm1027StatusHighLowExceededType get ();
}
member Status1LT : Adm1027StatusHighLowExceededType with get

Property Value

Type: Adm1027StatusHighLowExceededType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Status1OOL Property

IRD

Adm1027Status1OOL Property

Status 1 (OOL)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027StatusHighLowExceededType Status1OOL { get; }
Public ReadOnly Property Status1OOL As Adm1027StatusHighLowExceededType
    Get
public:
property Adm1027StatusHighLowExceededType Status1OOL {
    Adm1027StatusHighLowExceededType get ();
}
member Status1OOL : Adm1027StatusHighLowExceededType with get

Property Value

Type: Adm1027StatusHighLowExceededType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Status1R1T Property

IRD

Adm1027Status1R1T Property

Status 1 (R1T)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027StatusHighLowExceededType Status1R1T { get; }
Public ReadOnly Property Status1R1T As Adm1027StatusHighLowExceededType
    Get
public:
property Adm1027StatusHighLowExceededType Status1R1T {
    Adm1027StatusHighLowExceededType get ();
}
member Status1R1T : Adm1027StatusHighLowExceededType with get

Property Value

Type: Adm1027StatusHighLowExceededType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Status1R2T Property

IRD

Adm1027Status1R2T Property

Status 1 (R2T)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027StatusHighLowExceededType Status1R2T { get; }
Public ReadOnly Property Status1R2T As Adm1027StatusHighLowExceededType
    Get
public:
property Adm1027StatusHighLowExceededType Status1R2T {
    Adm1027StatusHighLowExceededType get ();
}
member Status1R2T : Adm1027StatusHighLowExceededType with get

Property Value

Type: Adm1027StatusHighLowExceededType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Status1VCC Property

IRD

Adm1027Status1VCC Property

Status 1 (V_CC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027StatusHighLowExceededType Status1VCC { get; }
Public ReadOnly Property Status1VCC As Adm1027StatusHighLowExceededType
    Get
public:
property Adm1027StatusHighLowExceededType Status1VCC {
    Adm1027StatusHighLowExceededType get ();
}
member Status1VCC : Adm1027StatusHighLowExceededType with get

Property Value

Type: Adm1027StatusHighLowExceededType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Status1VCCP Property

IRD

Adm1027Status1VCCP Property

Status 1 (V_CCP)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027StatusHighLowExceededType Status1VCCP { get; }
Public ReadOnly Property Status1VCCP As Adm1027StatusHighLowExceededType
    Get
public:
property Adm1027StatusHighLowExceededType Status1VCCP {
    Adm1027StatusHighLowExceededType get ();
}
member Status1VCCP : Adm1027StatusHighLowExceededType with get

Property Value

Type: Adm1027StatusHighLowExceededType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Status212V Property

IRD

Adm1027Status212V Property

Status 2 (12V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027StatusHighLowExceededType Status212V { get; }
Public ReadOnly Property Status212V As Adm1027StatusHighLowExceededType
    Get
public:
property Adm1027StatusHighLowExceededType Status212V {
    Adm1027StatusHighLowExceededType get ();
}
member Status212V : Adm1027StatusHighLowExceededType with get

Property Value

Type: Adm1027StatusHighLowExceededType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Status2D1 Property

IRD

Adm1027Status2D1 Property

Status 2 (D1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027StatusDiodeType Status2D1 { get; }
Public ReadOnly Property Status2D1 As Adm1027StatusDiodeType
    Get
public:
property Adm1027StatusDiodeType Status2D1 {
    Adm1027StatusDiodeType get ();
}
member Status2D1 : Adm1027StatusDiodeType with get

Property Value

Type: Adm1027StatusDiodeType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Status2D2 Property

IRD

Adm1027Status2D2 Property

Status 2 (D2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027StatusDiodeType Status2D2 { get; }
Public ReadOnly Property Status2D2 As Adm1027StatusDiodeType
    Get
public:
property Adm1027StatusDiodeType Status2D2 {
    Adm1027StatusDiodeType get ();
}
member Status2D2 : Adm1027StatusDiodeType with get

Property Value

Type: Adm1027StatusDiodeType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Status2FAN1 Property

IRD

Adm1027Status2FAN1 Property

Status 2 (FAN1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027StatusFanType Status2FAN1 { get; }
Public ReadOnly Property Status2FAN1 As Adm1027StatusFanType
    Get
public:
property Adm1027StatusFanType Status2FAN1 {
    Adm1027StatusFanType get ();
}
member Status2FAN1 : Adm1027StatusFanType with get

Property Value

Type: Adm1027StatusFanType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Status2FAN2 Property

IRD

Adm1027Status2FAN2 Property

Status 2 (FAN2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027StatusFanType Status2FAN2 { get; }
Public ReadOnly Property Status2FAN2 As Adm1027StatusFanType
    Get
public:
property Adm1027StatusFanType Status2FAN2 {
    Adm1027StatusFanType get ();
}
member Status2FAN2 : Adm1027StatusFanType with get

Property Value

Type: Adm1027StatusFanType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Status2FAN3 Property

IRD

Adm1027Status2FAN3 Property

Status 2 (FAN3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027StatusFanType Status2FAN3 { get; }
Public ReadOnly Property Status2FAN3 As Adm1027StatusFanType
    Get
public:
property Adm1027StatusFanType Status2FAN3 {
    Adm1027StatusFanType get ();
}
member Status2FAN3 : Adm1027StatusFanType with get

Property Value

Type: Adm1027StatusFanType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Status2FAN4 Property

IRD

Adm1027Status2FAN4 Property

Status 2 (FAN4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027StatusFanType Status2FAN4 { get; }
Public ReadOnly Property Status2FAN4 As Adm1027StatusFanType
    Get
public:
property Adm1027StatusFanType Status2FAN4 {
    Adm1027StatusFanType get ();
}
member Status2FAN4 : Adm1027StatusFanType with get

Property Value

Type: Adm1027StatusFanType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Status2OVT Property

IRD

Adm1027Status2OVT Property

Status 2 (OVT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027StatusHighLowExceededType Status2OVT { get; }
Public ReadOnly Property Status2OVT As Adm1027StatusHighLowExceededType
    Get
public:
property Adm1027StatusHighLowExceededType Status2OVT {
    Adm1027StatusHighLowExceededType get ();
}
member Status2OVT : Adm1027StatusHighLowExceededType with get

Property Value

Type: Adm1027StatusHighLowExceededType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Stepping Property

IRD

Adm1027Stepping Property

Stepping

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Stepping { get; }
Public ReadOnly Property Stepping As Byte
    Get
public:
property unsigned char Stepping {
    unsigned char get ();
}
member Stepping : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.TACH1 Property

IRD

Adm1027TACH1 Property

TACH1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TACH1 { get; }
Public ReadOnly Property TACH1 As UShort
    Get
public:
property unsigned short TACH1 {
    unsigned short get ();
}
member TACH1 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.TACH1Minimum Property

IRD

Adm1027TACH1Minimum Property

TACH1 Minimum

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TACH1Minimum { get; set; }
Public Property TACH1Minimum As UShort
    Get
    Set
public:
property unsigned short TACH1Minimum {
    unsigned short get ();
    void set (unsigned short value);
}
member TACH1Minimum : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.TACH2 Property

IRD

Adm1027TACH2 Property

TACH2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TACH2 { get; }
Public ReadOnly Property TACH2 As UShort
    Get
public:
property unsigned short TACH2 {
    unsigned short get ();
}
member TACH2 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.TACH2Minimum Property

IRD

Adm1027TACH2Minimum Property

TACH2 Minimum

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TACH2Minimum { get; set; }
Public Property TACH2Minimum As UShort
    Get
    Set
public:
property unsigned short TACH2Minimum {
    unsigned short get ();
    void set (unsigned short value);
}
member TACH2Minimum : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.TACH3 Property

IRD

Adm1027TACH3 Property

TACH3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TACH3 { get; }
Public ReadOnly Property TACH3 As UShort
    Get
public:
property unsigned short TACH3 {
    unsigned short get ();
}
member TACH3 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.TACH3Minimum Property

IRD

Adm1027TACH3Minimum Property

TACH3 Minimum

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TACH3Minimum { get; set; }
Public Property TACH3Minimum As UShort
    Get
    Set
public:
property unsigned short TACH3Minimum {
    unsigned short get ();
    void set (unsigned short value);
}
member TACH3Minimum : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.TACH4 Property

IRD

Adm1027TACH4 Property

TACH4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TACH4 { get; }
Public ReadOnly Property TACH4 As UShort
    Get
public:
property unsigned short TACH4 {
    unsigned short get ();
}
member TACH4 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.TACH4Minimum Property

IRD

Adm1027TACH4Minimum Property

TACH4 Minimum

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TACH4Minimum { get; set; }
Public Property TACH4Minimum As UShort
    Get
    Set
public:
property unsigned short TACH4Minimum {
    unsigned short get ();
    void set (unsigned short value);
}
member TACH4Minimum : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.VCCHighLimit Property

IRD

Adm1027VCCHighLimit Property

V_CC High Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VCCHighLimit { get; set; }
Public Property VCCHighLimit As Byte
    Get
    Set
public:
property unsigned char VCCHighLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member VCCHighLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.VCCLowLimit Property

IRD

Adm1027VCCLowLimit Property

V_CC Low Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VCCLowLimit { get; set; }
Public Property VCCLowLimit As Byte
    Get
    Set
public:
property unsigned char VCCLowLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member VCCLowLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.VCCPHighLimit Property

IRD

Adm1027VCCPHighLimit Property

V_CCP High Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCPHighLimit { get; set; }
Public Property VCCPHighLimit As Double
    Get
    Set
public:
property double VCCPHighLimit {
    double get ();
    void set (double value);
}
member VCCPHighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.VCCPLowLimit Property

IRD

Adm1027VCCPLowLimit Property

V_CCP Low Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCPLowLimit { get; set; }
Public Property VCCPLowLimit As Double
    Get
    Set
public:
property double VCCPLowLimit {
    double get ();
    void set (double value);
}
member VCCPLowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.VCCPReading Property

IRD

Adm1027VCCPReading Property

V_CCP Reading (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCPReading { get; }
Public ReadOnly Property VCCPReading As Double
    Get
public:
property double VCCPReading {
    double get ();
}
member VCCPReading : float with get

Property Value

Type: Double
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.VCCReading Property

IRD

Adm1027VCCReading Property

V_CC Reading

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VCCReading { get; }
Public ReadOnly Property VCCReading As UShort
    Get
public:
property unsigned short VCCReading {
    unsigned short get ();
}
member VCCReading : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Version Property

IRD

Adm1027Version Property

Version

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Version { get; }
Public ReadOnly Property Version As Byte
    Get
public:
property unsigned char Version {
    unsigned char get ();
}
member Version : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.VID40 Property

IRD

Adm1027VID40 Property

VID[4:0]

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VID40 { get; }
Public ReadOnly Property VID40 As Byte
    Get
public:
property unsigned char VID40 {
    unsigned char get ();
}
member VID40 : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.XORTreeTestEnableXEN Property

IRD

Adm1027XORTreeTestEnableXEN Property

XOR Tree Test Enable (XEN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1027EnableDisableType XORTreeTestEnableXEN { get; set; }
Public Property XORTreeTestEnableXEN As Adm1027EnableDisableType
    Get
    Set
public:
property Adm1027EnableDisableType XORTreeTestEnableXEN {
    Adm1027EnableDisableType get ();
    void set (Adm1027EnableDisableType value);
}
member XORTreeTestEnableXEN : Adm1027EnableDisableType with get, set

Property Value

Type: Adm1027EnableDisableType
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027 Methods

The Adm1027 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.Flush Method

IRD

Adm1027Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adm1027 Class
telos.Ird.AnalogDevices Namespace


Adm1027.AcousticsAcouType Enumeration

IRD

Adm1027AcousticsAcouType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AcousticsAcouType
Public Enumeration AcousticsAcouType
public enum class AcousticsAcouType
type AcousticsAcouType
Members
Member name | Value | Description
TimeSlotIncrease1 | 0 | Time Slot Increase: 1
TimeSlotIncrease2 | 1 | Time Slot Increase: 2
TimeSlotIncrease3 | 2 | Time Slot Increase: 3
TimeSlotIncrease5 | 3 | Time Slot Increase: 5
TimeSlotIncrease8 | 4 | Time Slot Increase: 8
TimeSlotIncrease12 | 5 | Time Slot Increase: 12
TimeSlotIncrease24 | 6 | Time Slot Increase: 24
TimeSlotIncrease48 | 7 | Time Slot Increase: 48
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.AcousticsEnType Enumeration

IRD

Adm1027AcousticsEnType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AcousticsEnType
Public Enumeration AcousticsEnType
public enum class AcousticsEnType
type AcousticsEnType
Members
Member name | Value | Description
AcousticEnhancementEnabled | 1 | Acoustic Enhancement: Enabled
AcousticEnhancementDisabled | 0 | Acoustic Enhancement: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.AcousticsMinType Enumeration

IRD

Adm1027AcousticsMinType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AcousticsMinType
Public Enumeration AcousticsMinType
public enum class AcousticsMinType
type AcousticsMinType
Members
Member name | Value | Description
PWMMinimumDutyCycleBelowTMINHysteresis | 1 | PWM Minimum Duty Cycle Below T_MIN Hysteresis
Value_0DutyCycleBelowTMINHysteresis | 0 | 0% Duty Cycle Below T_MIN Hysteresis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.ConfAinType Enumeration

IRD

Adm1027ConfAinType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfAinType
Public Enumeration ConfAinType
public enum class ConfAinType
type ConfAinType
Members
Member name | Value | Description
Value_2WireFan | 1 | 2-Wire Fan
Value_3WireFan | 0 | 3-Wire Fan
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.ConfAlertType Enumeration

IRD

Adm1027ConfAlertType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfAlertType
Public Enumeration ConfAlertType
public enum class ConfAlertType
type ConfAlertType
Members
Member name | Value | Description
Pin10SMBALERT | 1 | Pin 10: SMBALERT
Pin10PWM2 | 0 | Pin 10: PWM2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.ConfAttnType Enumeration

IRD

Adm1027ConfAttnType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfAttnType
Public Enumeration ConfAttnType
public enum class ConfAttnType
type ConfAttnType
Members
Member name | Value | Description
AttenuatorsDisabled | 1 | Attenuators: Disabled
AttenuatorsEnabled | 0 | Attenuators: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.ConfAvgType Enumeration

IRD

Adm1027ConfAvgType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfAvgType
Public Enumeration ConfAvgType
public enum class ConfAvgType
type ConfAvgType
Members
Member name | Value | Description
AveragingOfTemperatureVoltageDisabled | 1 | Averaging Of Temperature / Voltage: Disabled
AveragingOfTemperatureVoltageEnabled | 0 | Averaging Of Temperature / Voltage: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.ConfConvType Enumeration

IRD

Adm1027ConfConvType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfConvType
Public Enumeration ConfConvType
public enum class ConfConvType
type ConfConvType
Members
Member name | Value | Description
ADCSingleChannel | 1 | ADC: Single-Channel
ADCDefault | 0 | ADC: Default
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.ConfDcType Enumeration

IRD

Adm1027ConfDcType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfDcType
Public Enumeration ConfDcType
public enum class ConfDcType
type ConfDcType
Members
Member name | Value | Description
ContinuouslyTACHMeasurementEnabled | 1 | Continuously TACH Measurement: Enabled
ContinuouslyTACHMeasurementDisabled | 0 | Continuously TACH Measurement: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.ConfFastType Enumeration

IRD

Adm1027ConfFastType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfFastType
Public Enumeration ConfFastType
public enum class ConfFastType
type ConfFastType
Members
Member name | Value | Description
TACHMeasurementFast | 1 | TACH Measurement: Fast
TACHMeasurementStandard | 0 | TACH Measurement: Standard
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.ConfFspdisType Enumeration

IRD

Adm1027ConfFspdisType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfFspdisType
Public Enumeration ConfFspdisType
public enum class ConfFspdisType
type ConfFspdisType
Members
Member name | Value | Description
DisableFanSpinUp | 1 | Disable Fan Spin-Up
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.ConfFspdType Enumeration

IRD

Adm1027ConfFspdType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfFspdType
Public Enumeration ConfFspdType
public enum class ConfFspdType
type ConfFspdType
Members
Member name | Value | Description
AllFansFullSpeed | 1 | All Fans Full Speed
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.ConfLockType Enumeration

IRD

Adm1027ConfLockType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfLockType
Public Enumeration ConfLockType
public enum class ConfLockType
type ConfLockType
Members
Member name | Value | Description
Locked | 1 | Locked
NotLocked | 0 | Not Locked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.ConfPwmBhvrType Enumeration

IRD

Adm1027ConfPwmBhvrType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfPwmBhvrType
Public Enumeration ConfPwmBhvrType
public enum class ConfPwmBhvrType
type ConfPwmBhvrType
Members
Member name | Value | Description
Remote1TempControlsPWM | 0 | Remote 1 Temp Controls PWM
LocalTempControlPWM | 1 | Local Temp Control PWM
Remote2TempControlsPWM | 2 | Remote 2 Temp Controls PWM
PWMRunsFullSpeed | 3 | PWM Runs Full Speed
PWMDisabled | 4 | PWM Disabled
LocalRemote2TempControlPWM | 5 | Local / Remote 2 Temp Control PWM
AllThreeTempControlPWM | 6 | All Three Temp Control PWM
ManualMode | 7 | Manual Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.ConfPwmInvType Enumeration

IRD

Adm1027ConfPwmInvType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfPwmInvType
Public Enumeration ConfPwmInvType
public enum class ConfPwmInvType
type ConfPwmInvType
Members
Member name | Value | Description
PWMOutputInverted | 1 | PWM Output: Inverted
PWMOutputNotInverted | 0 | PWM Output: Not Inverted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.ConfPwmSpinType Enumeration

IRD

Adm1027ConfPwmSpinType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfPwmSpinType
Public Enumeration ConfPwmSpinType
public enum class ConfPwmSpinType
type ConfPwmSpinType
Members
Member name | Value | Description
NoStartupTimeout | 0 | No Startup Timeout
Value_100Ms | 1 | 100 ms
Value_250Ms | 2 | 250 ms
Value_400Ms | 3 | 400 ms
Reserved | 4 | Reserved
Value_1Sec | 5 | 1 sec
Value_2Sec | 6 | 2 sec
Value_4Sec | 7 | 4 sec
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.ConfReadyType Enumeration

IRD

Adm1027ConfReadyType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfReadyType
Public Enumeration ConfReadyType
public enum class ConfReadyType
type ConfReadyType
Members
Member name | Value | Description
Ready | 1 | Ready
NotReady | 0 | Not Ready
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.ConfStrtType Enumeration

IRD

Adm1027ConfStrtType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfStrtType
Public Enumeration ConfStrtType
public enum class ConfStrtType
type ConfStrtType
Members
Member name | Value | Description
MonitoringPWMControlOutputsEnabled | 1 | Monitoring / PWM Control Outputs: Enabled
MonitoringPWMControlOutputsDisabled | 0 | Monitoring / PWM Control Outputs: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.ConfTodisType Enumeration

IRD

Adm1027ConfTodisType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfTodisType
Public Enumeration ConfTodisType
public enum class ConfTodisType
type ConfTodisType
Members
Member name | Value | Description
SMBusTimeoutDisabled | 1 | SMBus Timeout: Disabled
SMBusTimeoutEnabled | 0 | SMBus Timeout: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.ConfVCcType Enumeration

IRD

Adm1027ConfVCcType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfVCcType
Public Enumeration ConfVCcType
public enum class ConfVCcType
type ConfVCcType
Members
Member name | Value | Description
VCCPin5V | 1 | V_CC Pin: 5V
VCCPin33V | 0 | V_CC Pin: 3.3V
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.ConfViType Enumeration

IRD

Adm1027ConfViType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfViType
Public Enumeration ConfViType
public enum class ConfViType
type ConfViType
Members
Member name | Value | Description
MeasureCurrent | 1 | Measure Current
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.EnableDisableType Enumeration

IRD

Adm1027EnableDisableType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum EnableDisableType
Public Enumeration EnableDisableType
public enum class EnableDisableType
type EnableDisableType
Members
Member name | Value | Description
Enabled | 1 | Enabled
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.IrqMaskType Enumeration

IRD

Adm1027IrqMaskType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqMaskType
Public Enumeration IrqMaskType
public enum class IrqMaskType
type IrqMaskType
Members
Member name | Value | Description
MaskSMBALERT | 1 | Mask SMBALERT
Default | 0 | Default
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.IrqOolType Enumeration

IRD

Adm1027IrqOolType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqOolType
Public Enumeration IrqOolType
public enum class IrqOolType
type IrqOolType
Members
Member name | Value | Description
InterruptMask2Enabled | 1 | Interrupt Mask 2: Enabled
InterruptMask2Disabled | 0 | Interrupt Mask 2: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.StatusDiodeType Enumeration

IRD

Adm1027StatusDiodeType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusDiodeType
Public Enumeration StatusDiodeType
public enum class StatusDiodeType
type StatusDiodeType
Members
Member name | Value | Description
OpenShortCircuit | 1 | Open / Short Circuit
OK | 0 | OK
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.StatusFanType Enumeration

IRD

Adm1027StatusFanType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusFanType
Public Enumeration StatusFanType
public enum class StatusFanType
type StatusFanType
Members
Member name | Value | Description
DroppedBelowMinimumSpeedStalled | 1 | Dropped Below Minimum Speed / Stalled
OK | 0 | OK
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.StatusHighLowExceededType Enumeration

IRD

Adm1027StatusHighLowExceededType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusHighLowExceededType
Public Enumeration StatusHighLowExceededType
public enum class StatusHighLowExceededType
type StatusHighLowExceededType
Members
Member name | Value | Description
HighLowLimitExceeded | 1 | High/Low Limit Exceeded
HighLowLimitNotExceeded | 0 | High/Low Limit Not Exceeded
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.TRangeFreqType Enumeration

IRD

Adm1027TRangeFreqType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TRangeFreqType
Public Enumeration TRangeFreqType
public enum class TRangeFreqType
type TRangeFreqType
Members
Member name | Value | Description
Value_110Hz | 0 | 11.0 Hz
Value_147Hz | 1 | 14.7 Hz
Value_221Hz | 2 | 22.1 Hz
Value_294Hz | 3 | 29.4 Hz
Value_353Hz | 4 | 35.3 Hz
Value_441Hz | 5 | 44.1 Hz
Value_588Hz | 6 | 58.8 Hz
Value_882Hz | 7 | 88.2 Hz
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1027.TRangeRangeType Enumeration

IRD

Adm1027TRangeRangeType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TRangeRangeType
Public Enumeration TRangeRangeType
public enum class TRangeRangeType
type TRangeRangeType
Members
Member name | Value | Description
Value_2C | 0 | 2 °C
Value_25C | 1 | 2.5 °C
Value_333C | 2 | 3.33 °C
Value_4C | 3 | 4 °C
Value_5C | 4 | 5 °C
Value_667C | 5 | 6.67 °C
Value_8C | 6 | 8 °C
Value_10C | 7 | 10 °C
Value_1333C | 8 | 13.33 °C
Value_16C | 9 | 16 °C
Value_20C | 10 | 20 °C
Value_2667C | 11 | 26.67 °C
Value_32C | 12 | 32 °C
Value_40C | 13 | 40 °C
Value_5333C | 14 | 53.33 °C
Value_80C | 15 | 80 °C
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1028 Class

Analog Devices: ADM 1028
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdm1028

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adm1028
Public Class Adm1028
public ref class Adm1028
type Adm1028 =  class end

The Adm1028 type exposes the following members.

Constructors
 | Name | Description
Public method | Adm1028 | Constructor
Top
Properties
 | Name | Description
Public property | AlertStatusExtTHERMAlert | Alert Status (Ext. THERM Alert)
Public property | AlertStatusGPIAlert | Alert Status (GPI Alert)
Public property | AlertStatusIntTHERMAlert | Alert Status (Int. THERM Alert)
Public property | AnalogOutputFANSPD | Analog Output/FAN SPD (unit: V)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CompanyID | Company ID
Public property | ConfigurationFANOFF | Configuration (FAN OFF)
Public property | ConfigurationGPIInvert | Configuration (GPI Invert)
Public property | ConfigurationINTEnable | Configuration (INT Enable)
Public property | ConfigurationProgrammableThermLimitLock | Configuration (Programmable Therm Limit Lock)
Public property | ConfigurationSoftReset | Configuration (Soft Reset)
Public property | ConfigurationSTART | Configuration (START)
Public property | DefaultInternalTemperatureTripPoint | Default Internal Temperature Trip Point (unit: °C)
Public property | DefaultRemoteTemperatureTripPoint | Default Remote Temperature Trip Point (unit: °C)
Public property | ExternalRemoteTemperatureHighLimit | External/Remote Temperature High Limit (unit: °C)
Public property | ExternalRemoteTemperatureLowLimit | External/Remote Temperature Low Limit (unit: °C)
Public property | ExternalRemoteTemperatureValue | External/Remote Temperature Value (unit: °C)
Public property | FanSpeedRampEnable | Fan Speed Ramp (Enable)
Public property | FanSpeedRampRate | Fan Speed Ramp (Rate)
Public property | InternalTemperatureHighLimit | Internal Temperature High Limit (unit: °C)
Public property | InternalTemperatureLowLimit | Internal Temperature Low Limit (unit: °C)
Public property | InternalTemperatureTripPoint | Internal Temperature Trip Point (unit: °C)
Public property | InternalTemperatureValue | Internal Temperature Value (unit: °C)
Public property | InterruptMaskExtDiodeFault | Interrupt Mask (Ext. Diode Fault)
Public property | InterruptMaskExtTempError | Interrupt Mask (Ext. Temp Error)
Public property | InterruptMaskExtTHERM | Interrupt Mask (Ext. THERM)
Public property | InterruptMaskFlag1 | Interrupt Mask (Flag 1)
Public property | InterruptMaskFlag2 | Interrupt Mask (Flag 2)
Public property | InterruptMaskGPI | Interrupt Mask (GPI)
Public property | InterruptMaskIntTempError | Interrupt Mask (Int. Temp Error)
Public property | InterruptMaskIntTHERM | Interrupt Mask (Int. THERM)
Public property | InterruptStatusExtDiodeFault | Interrupt Status (Ext. Diode Fault)
Public property | InterruptStatusExtDiodeFault__1 | Interrupt Status (Ext. Diode Fault)
Public property | InterruptStatusExtTempError | Interrupt Status (Ext. Temp Error)
Public property | InterruptStatusExtTempError__1 | Interrupt Status (Ext. Temp Error)
Public property | InterruptStatusExtTHERM | Interrupt Status (Ext. THERM)
Public property | InterruptStatusExtTHERM__1 | Interrupt Status (Ext. THERM)
Public property | InterruptStatusFlag1 | Interrupt Status (Flag 1)
Public property | InterruptStatusFlag1__1 | Interrupt Status (Flag 1)
Public property | InterruptStatusFlag2 | Interrupt Status (Flag 2)
Public property | InterruptStatusFlag2__1 | Interrupt Status (Flag 2)
Public property | InterruptStatusGPIInput | Interrupt Status (GPI Input)
Public property | InterruptStatusIntTempError | Interrupt Status (Int. Temp Error)
Public property | InterruptStatusIntTempError__1 | Interrupt Status (Int. Temp Error)
Public property | InterruptStatusIntTHERM | Interrupt Status (Int. THERM)
Public property | InterruptStatusIntTHERM__1 | Interrupt Status (Int. THERM)
Public property | RemoteFunctionROFF | Remote Function (R_OFF)
Public property | RemoteFunctionRRST | Remote Function (R_RST)
Public property | RemoteTemperatureTripPoint | Remote Temperature Trip Point (unit: °C)
Public property | Revision | Revision
Public property | Version | Version
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Remote Thermal Diode Monitor With Linear Fan Control
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1028 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adm1028(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adm1028

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028 Properties

The Adm1028 type exposes the following members.

Properties
 | Name | Description
Public property | AlertStatusExtTHERMAlert | Alert Status (Ext. THERM Alert)
Public property | AlertStatusGPIAlert | Alert Status (GPI Alert)
Public property | AlertStatusIntTHERMAlert | Alert Status (Int. THERM Alert)
Public property | AnalogOutputFANSPD | Analog Output/FAN SPD (unit: V)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CompanyID | Company ID
Public property | ConfigurationFANOFF | Configuration (FAN OFF)
Public property | ConfigurationGPIInvert | Configuration (GPI Invert)
Public property | ConfigurationINTEnable | Configuration (INT Enable)
Public property | ConfigurationProgrammableThermLimitLock | Configuration (Programmable Therm Limit Lock)
Public property | ConfigurationSoftReset | Configuration (Soft Reset)
Public property | ConfigurationSTART | Configuration (START)
Public property | DefaultInternalTemperatureTripPoint | Default Internal Temperature Trip Point (unit: °C)
Public property | DefaultRemoteTemperatureTripPoint | Default Remote Temperature Trip Point (unit: °C)
Public property | ExternalRemoteTemperatureHighLimit | External/Remote Temperature High Limit (unit: °C)
Public property | ExternalRemoteTemperatureLowLimit | External/Remote Temperature Low Limit (unit: °C)
Public property | ExternalRemoteTemperatureValue | External/Remote Temperature Value (unit: °C)
Public property | FanSpeedRampEnable | Fan Speed Ramp (Enable)
Public property | FanSpeedRampRate | Fan Speed Ramp (Rate)
Public property | InternalTemperatureHighLimit | Internal Temperature High Limit (unit: °C)
Public property | InternalTemperatureLowLimit | Internal Temperature Low Limit (unit: °C)
Public property | InternalTemperatureTripPoint | Internal Temperature Trip Point (unit: °C)
Public property | InternalTemperatureValue | Internal Temperature Value (unit: °C)
Public property | InterruptMaskExtDiodeFault | Interrupt Mask (Ext. Diode Fault)
Public property | InterruptMaskExtTempError | Interrupt Mask (Ext. Temp Error)
Public property | InterruptMaskExtTHERM | Interrupt Mask (Ext. THERM)
Public property | InterruptMaskFlag1 | Interrupt Mask (Flag 1)
Public property | InterruptMaskFlag2 | Interrupt Mask (Flag 2)
Public property | InterruptMaskGPI | Interrupt Mask (GPI)
Public property | InterruptMaskIntTempError | Interrupt Mask (Int. Temp Error)
Public property | InterruptMaskIntTHERM | Interrupt Mask (Int. THERM)
Public property | InterruptStatusExtDiodeFault | Interrupt Status (Ext. Diode Fault)
Public property | InterruptStatusExtDiodeFault__1 | Interrupt Status (Ext. Diode Fault)
Public property | InterruptStatusExtTempError | Interrupt Status (Ext. Temp Error)
Public property | InterruptStatusExtTempError__1 | Interrupt Status (Ext. Temp Error)
Public property | InterruptStatusExtTHERM | Interrupt Status (Ext. THERM)
Public property | InterruptStatusExtTHERM__1 | Interrupt Status (Ext. THERM)
Public property | InterruptStatusFlag1 | Interrupt Status (Flag 1)
Public property | InterruptStatusFlag1__1 | Interrupt Status (Flag 1)
Public property | InterruptStatusFlag2 | Interrupt Status (Flag 2)
Public property | InterruptStatusFlag2__1 | Interrupt Status (Flag 2)
Public property | InterruptStatusGPIInput | Interrupt Status (GPI Input)
Public property | InterruptStatusIntTempError | Interrupt Status (Int. Temp Error)
Public property | InterruptStatusIntTempError__1 | Interrupt Status (Int. Temp Error)
Public property | InterruptStatusIntTHERM | Interrupt Status (Int. THERM)
Public property | InterruptStatusIntTHERM__1 | Interrupt Status (Int. THERM)
Public property | RemoteFunctionROFF | Remote Function (R_OFF)
Public property | RemoteFunctionRRST | Remote Function (R_RST)
Public property | RemoteTemperatureTripPoint | Remote Temperature Trip Point (unit: °C)
Public property | Revision | Revision
Public property | Version | Version
Top
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.AlertStatusExtTHERMAlert Property

IRD

Adm1028AlertStatusExtTHERMAlert Property

Alert Status (Ext. THERM Alert)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028BoolType AlertStatusExtTHERMAlert { get; }
Public ReadOnly Property AlertStatusExtTHERMAlert As Adm1028BoolType
    Get
public:
property Adm1028BoolType AlertStatusExtTHERMAlert {
    Adm1028BoolType get ();
}
member AlertStatusExtTHERMAlert : Adm1028BoolType with get

Property Value

Type: Adm1028BoolType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.AlertStatusGPIAlert Property

IRD

Adm1028AlertStatusGPIAlert Property

Alert Status (GPI Alert)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028BoolType AlertStatusGPIAlert { get; }
Public ReadOnly Property AlertStatusGPIAlert As Adm1028BoolType
    Get
public:
property Adm1028BoolType AlertStatusGPIAlert {
    Adm1028BoolType get ();
}
member AlertStatusGPIAlert : Adm1028BoolType with get

Property Value

Type: Adm1028BoolType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.AlertStatusIntTHERMAlert Property

IRD

Adm1028AlertStatusIntTHERMAlert Property

Alert Status (Int. THERM Alert)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028BoolType AlertStatusIntTHERMAlert { get; }
Public ReadOnly Property AlertStatusIntTHERMAlert As Adm1028BoolType
    Get
public:
property Adm1028BoolType AlertStatusIntTHERMAlert {
    Adm1028BoolType get ();
}
member AlertStatusIntTHERMAlert : Adm1028BoolType with get

Property Value

Type: Adm1028BoolType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.AnalogOutputFANSPD Property

IRD

Adm1028AnalogOutputFANSPD Property

Analog Output/FAN SPD (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AnalogOutputFANSPD { get; set; }
Public Property AnalogOutputFANSPD As Double
    Get
    Set
public:
property double AnalogOutputFANSPD {
    double get ();
    void set (double value);
}
member AnalogOutputFANSPD : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.AutoFlush Property

IRD

Adm1028AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.CompanyID Property

IRD

Adm1028CompanyID Property

Company ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CompanyID { get; }
Public ReadOnly Property CompanyID As Byte
    Get
public:
property unsigned char CompanyID {
    unsigned char get ();
}
member CompanyID : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.ConfigurationFANOFF Property

IRD

Adm1028ConfigurationFANOFF Property

Configuration (FAN OFF)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028ConfFanType ConfigurationFANOFF { get; set; }
Public Property ConfigurationFANOFF As Adm1028ConfFanType
    Get
    Set
public:
property Adm1028ConfFanType ConfigurationFANOFF {
    Adm1028ConfFanType get ();
    void set (Adm1028ConfFanType value);
}
member ConfigurationFANOFF : Adm1028ConfFanType with get, set

Property Value

Type: Adm1028ConfFanType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.ConfigurationGPIInvert Property

IRD

Adm1028ConfigurationGPIInvert Property

Configuration (GPI Invert)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028ConfInvertType ConfigurationGPIInvert { get; set; }
Public Property ConfigurationGPIInvert As Adm1028ConfInvertType
    Get
    Set
public:
property Adm1028ConfInvertType ConfigurationGPIInvert {
    Adm1028ConfInvertType get ();
    void set (Adm1028ConfInvertType value);
}
member ConfigurationGPIInvert : Adm1028ConfInvertType with get, set

Property Value

Type: Adm1028ConfInvertType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.ConfigurationINTEnable Property

IRD

Adm1028ConfigurationINTEnable Property

Configuration (INT Enable)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028EnabledDisabledType ConfigurationINTEnable { get; set; }
Public Property ConfigurationINTEnable As Adm1028EnabledDisabledType
    Get
    Set
public:
property Adm1028EnabledDisabledType ConfigurationINTEnable {
    Adm1028EnabledDisabledType get ();
    void set (Adm1028EnabledDisabledType value);
}
member ConfigurationINTEnable : Adm1028EnabledDisabledType with get, set

Property Value

Type: Adm1028EnabledDisabledType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.ConfigurationProgrammableThermLimitLock Property

IRD

Adm1028ConfigurationProgrammableThermLimitLock Property

Configuration (Programmable Therm Limit Lock)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028ConfLockType ConfigurationProgrammableThermLimitLock { get; set; }
Public Property ConfigurationProgrammableThermLimitLock As Adm1028ConfLockType
    Get
    Set
public:
property Adm1028ConfLockType ConfigurationProgrammableThermLimitLock {
    Adm1028ConfLockType get ();
    void set (Adm1028ConfLockType value);
}
member ConfigurationProgrammableThermLimitLock : Adm1028ConfLockType with get, set

Property Value

Type: Adm1028ConfLockType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.ConfigurationSoftReset Property

IRD

Adm1028ConfigurationSoftReset Property

Configuration (Soft Reset)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028ConfResetType ConfigurationSoftReset { get; set; }
Public Property ConfigurationSoftReset As Adm1028ConfResetType
    Get
    Set
public:
property Adm1028ConfResetType ConfigurationSoftReset {
    Adm1028ConfResetType get ();
    void set (Adm1028ConfResetType value);
}
member ConfigurationSoftReset : Adm1028ConfResetType with get, set

Property Value

Type: Adm1028ConfResetType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.ConfigurationSTART Property

IRD

Adm1028ConfigurationSTART Property

Configuration (START)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028ConfStartType ConfigurationSTART { get; set; }
Public Property ConfigurationSTART As Adm1028ConfStartType
    Get
    Set
public:
property Adm1028ConfStartType ConfigurationSTART {
    Adm1028ConfStartType get ();
    void set (Adm1028ConfStartType value);
}
member ConfigurationSTART : Adm1028ConfStartType with get, set

Property Value

Type: Adm1028ConfStartType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.DefaultInternalTemperatureTripPoint Property

IRD

Adm1028DefaultInternalTemperatureTripPoint Property

Default Internal Temperature Trip Point (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte DefaultInternalTemperatureTripPoint { get; }
Public ReadOnly Property DefaultInternalTemperatureTripPoint As SByte
    Get
public:
property signed char DefaultInternalTemperatureTripPoint {
    signed char get ();
}
member DefaultInternalTemperatureTripPoint : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.DefaultRemoteTemperatureTripPoint Property

IRD

Adm1028DefaultRemoteTemperatureTripPoint Property

Default Remote Temperature Trip Point (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte DefaultRemoteTemperatureTripPoint { get; }
Public ReadOnly Property DefaultRemoteTemperatureTripPoint As SByte
    Get
public:
property signed char DefaultRemoteTemperatureTripPoint {
    signed char get ();
}
member DefaultRemoteTemperatureTripPoint : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.ExternalRemoteTemperatureHighLimit Property

IRD

Adm1028ExternalRemoteTemperatureHighLimit Property

External/Remote Temperature High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalRemoteTemperatureHighLimit { get; set; }
Public Property ExternalRemoteTemperatureHighLimit As SByte
    Get
    Set
public:
property signed char ExternalRemoteTemperatureHighLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalRemoteTemperatureHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.ExternalRemoteTemperatureLowLimit Property

IRD

Adm1028ExternalRemoteTemperatureLowLimit Property

External/Remote Temperature Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalRemoteTemperatureLowLimit { get; set; }
Public Property ExternalRemoteTemperatureLowLimit As SByte
    Get
    Set
public:
property signed char ExternalRemoteTemperatureLowLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalRemoteTemperatureLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.ExternalRemoteTemperatureValue Property

IRD

Adm1028ExternalRemoteTemperatureValue Property

External/Remote Temperature Value (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalRemoteTemperatureValue { get; }
Public ReadOnly Property ExternalRemoteTemperatureValue As SByte
    Get
public:
property signed char ExternalRemoteTemperatureValue {
    signed char get ();
}
member ExternalRemoteTemperatureValue : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.FanSpeedRampEnable Property

IRD

Adm1028FanSpeedRampEnable Property

Fan Speed Ramp (Enable)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028EnabledDisabledType FanSpeedRampEnable { get; set; }
Public Property FanSpeedRampEnable As Adm1028EnabledDisabledType
    Get
    Set
public:
property Adm1028EnabledDisabledType FanSpeedRampEnable {
    Adm1028EnabledDisabledType get ();
    void set (Adm1028EnabledDisabledType value);
}
member FanSpeedRampEnable : Adm1028EnabledDisabledType with get, set

Property Value

Type: Adm1028EnabledDisabledType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.FanSpeedRampRate Property

IRD

Adm1028FanSpeedRampRate Property

Fan Speed Ramp (Rate)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028FanSpeedRampRateType FanSpeedRampRate { get; set; }
Public Property FanSpeedRampRate As Adm1028FanSpeedRampRateType
    Get
    Set
public:
property Adm1028FanSpeedRampRateType FanSpeedRampRate {
    Adm1028FanSpeedRampRateType get ();
    void set (Adm1028FanSpeedRampRateType value);
}
member FanSpeedRampRate : Adm1028FanSpeedRampRateType with get, set

Property Value

Type: Adm1028FanSpeedRampRateType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InternalTemperatureHighLimit Property

IRD

Adm1028InternalTemperatureHighLimit Property

Internal Temperature High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureHighLimit { get; set; }
Public Property InternalTemperatureHighLimit As SByte
    Get
    Set
public:
property signed char InternalTemperatureHighLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTemperatureHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InternalTemperatureLowLimit Property

IRD

Adm1028InternalTemperatureLowLimit Property

Internal Temperature Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureLowLimit { get; set; }
Public Property InternalTemperatureLowLimit As SByte
    Get
    Set
public:
property signed char InternalTemperatureLowLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTemperatureLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InternalTemperatureTripPoint Property

IRD

Adm1028InternalTemperatureTripPoint Property

Internal Temperature Trip Point (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureTripPoint { get; set; }
Public Property InternalTemperatureTripPoint As SByte
    Get
    Set
public:
property signed char InternalTemperatureTripPoint {
    signed char get ();
    void set (signed char value);
}
member InternalTemperatureTripPoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InternalTemperatureValue Property

IRD

Adm1028InternalTemperatureValue Property

Internal Temperature Value (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureValue { get; }
Public ReadOnly Property InternalTemperatureValue As SByte
    Get
public:
property signed char InternalTemperatureValue {
    signed char get ();
}
member InternalTemperatureValue : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptMaskExtDiodeFault Property

IRD

Adm1028InterruptMaskExtDiodeFault Property

Interrupt Mask (Ext. Diode Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028IrqMaskType InterruptMaskExtDiodeFault { get; set; }
Public Property InterruptMaskExtDiodeFault As Adm1028IrqMaskType
    Get
    Set
public:
property Adm1028IrqMaskType InterruptMaskExtDiodeFault {
    Adm1028IrqMaskType get ();
    void set (Adm1028IrqMaskType value);
}
member InterruptMaskExtDiodeFault : Adm1028IrqMaskType with get, set

Property Value

Type: Adm1028IrqMaskType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptMaskExtTempError Property

IRD

Adm1028InterruptMaskExtTempError Property

Interrupt Mask (Ext. Temp Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028IrqMaskType InterruptMaskExtTempError { get; set; }
Public Property InterruptMaskExtTempError As Adm1028IrqMaskType
    Get
    Set
public:
property Adm1028IrqMaskType InterruptMaskExtTempError {
    Adm1028IrqMaskType get ();
    void set (Adm1028IrqMaskType value);
}
member InterruptMaskExtTempError : Adm1028IrqMaskType with get, set

Property Value

Type: Adm1028IrqMaskType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptMaskExtTHERM Property

IRD

Adm1028InterruptMaskExtTHERM Property

Interrupt Mask (Ext. THERM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028IrqMaskType InterruptMaskExtTHERM { get; set; }
Public Property InterruptMaskExtTHERM As Adm1028IrqMaskType
    Get
    Set
public:
property Adm1028IrqMaskType InterruptMaskExtTHERM {
    Adm1028IrqMaskType get ();
    void set (Adm1028IrqMaskType value);
}
member InterruptMaskExtTHERM : Adm1028IrqMaskType with get, set

Property Value

Type: Adm1028IrqMaskType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptMaskFlag1 Property

IRD

Adm1028InterruptMaskFlag1 Property

Interrupt Mask (Flag 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028IrqMaskType InterruptMaskFlag1 { get; set; }
Public Property InterruptMaskFlag1 As Adm1028IrqMaskType
    Get
    Set
public:
property Adm1028IrqMaskType InterruptMaskFlag1 {
    Adm1028IrqMaskType get ();
    void set (Adm1028IrqMaskType value);
}
member InterruptMaskFlag1 : Adm1028IrqMaskType with get, set

Property Value

Type: Adm1028IrqMaskType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptMaskFlag2 Property

IRD

Adm1028InterruptMaskFlag2 Property

Interrupt Mask (Flag 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028IrqMaskType InterruptMaskFlag2 { get; set; }
Public Property InterruptMaskFlag2 As Adm1028IrqMaskType
    Get
    Set
public:
property Adm1028IrqMaskType InterruptMaskFlag2 {
    Adm1028IrqMaskType get ();
    void set (Adm1028IrqMaskType value);
}
member InterruptMaskFlag2 : Adm1028IrqMaskType with get, set

Property Value

Type: Adm1028IrqMaskType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptMaskGPI Property

IRD

Adm1028InterruptMaskGPI Property

Interrupt Mask (GPI)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028IrqMaskType InterruptMaskGPI { get; set; }
Public Property InterruptMaskGPI As Adm1028IrqMaskType
    Get
    Set
public:
property Adm1028IrqMaskType InterruptMaskGPI {
    Adm1028IrqMaskType get ();
    void set (Adm1028IrqMaskType value);
}
member InterruptMaskGPI : Adm1028IrqMaskType with get, set

Property Value

Type: Adm1028IrqMaskType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptMaskIntTempError Property

IRD

Adm1028InterruptMaskIntTempError Property

Interrupt Mask (Int. Temp Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028IrqMaskType InterruptMaskIntTempError { get; set; }
Public Property InterruptMaskIntTempError As Adm1028IrqMaskType
    Get
    Set
public:
property Adm1028IrqMaskType InterruptMaskIntTempError {
    Adm1028IrqMaskType get ();
    void set (Adm1028IrqMaskType value);
}
member InterruptMaskIntTempError : Adm1028IrqMaskType with get, set

Property Value

Type: Adm1028IrqMaskType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptMaskIntTHERM Property

IRD

Adm1028InterruptMaskIntTHERM Property

Interrupt Mask (Int. THERM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028IrqMaskType InterruptMaskIntTHERM { get; set; }
Public Property InterruptMaskIntTHERM As Adm1028IrqMaskType
    Get
    Set
public:
property Adm1028IrqMaskType InterruptMaskIntTHERM {
    Adm1028IrqMaskType get ();
    void set (Adm1028IrqMaskType value);
}
member InterruptMaskIntTHERM : Adm1028IrqMaskType with get, set

Property Value

Type: Adm1028IrqMaskType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptStatusExtDiodeFault Property

IRD

Adm1028InterruptStatusExtDiodeFault Property

Interrupt Status (Ext. Diode Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028BoolType InterruptStatusExtDiodeFault { get; }
Public ReadOnly Property InterruptStatusExtDiodeFault As Adm1028BoolType
    Get
public:
property Adm1028BoolType InterruptStatusExtDiodeFault {
    Adm1028BoolType get ();
}
member InterruptStatusExtDiodeFault : Adm1028BoolType with get

Property Value

Type: Adm1028BoolType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptStatusExtDiodeFault__1 Property

IRD

Adm1028InterruptStatusExtDiodeFault__1 Property

Interrupt Status (Ext. Diode Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028IrqStatusClearType InterruptStatusExtDiodeFault__1 { set; }
Public WriteOnly Property InterruptStatusExtDiodeFault__1 As Adm1028IrqStatusClearType
    Set
public:
property Adm1028IrqStatusClearType InterruptStatusExtDiodeFault__1 {
    void set (Adm1028IrqStatusClearType value);
}
member InterruptStatusExtDiodeFault__1 : Adm1028IrqStatusClearType with set

Property Value

Type: Adm1028IrqStatusClearType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptStatusExtTempError Property

IRD

Adm1028InterruptStatusExtTempError Property

Interrupt Status (Ext. Temp Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028BoolType InterruptStatusExtTempError { get; }
Public ReadOnly Property InterruptStatusExtTempError As Adm1028BoolType
    Get
public:
property Adm1028BoolType InterruptStatusExtTempError {
    Adm1028BoolType get ();
}
member InterruptStatusExtTempError : Adm1028BoolType with get

Property Value

Type: Adm1028BoolType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptStatusExtTempError__1 Property

IRD

Adm1028InterruptStatusExtTempError__1 Property

Interrupt Status (Ext. Temp Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028IrqStatusClearType InterruptStatusExtTempError__1 { set; }
Public WriteOnly Property InterruptStatusExtTempError__1 As Adm1028IrqStatusClearType
    Set
public:
property Adm1028IrqStatusClearType InterruptStatusExtTempError__1 {
    void set (Adm1028IrqStatusClearType value);
}
member InterruptStatusExtTempError__1 : Adm1028IrqStatusClearType with set

Property Value

Type: Adm1028IrqStatusClearType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptStatusExtTHERM Property

IRD

Adm1028InterruptStatusExtTHERM Property

Interrupt Status (Ext. THERM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028BoolType InterruptStatusExtTHERM { get; }
Public ReadOnly Property InterruptStatusExtTHERM As Adm1028BoolType
    Get
public:
property Adm1028BoolType InterruptStatusExtTHERM {
    Adm1028BoolType get ();
}
member InterruptStatusExtTHERM : Adm1028BoolType with get

Property Value

Type: Adm1028BoolType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptStatusExtTHERM__1 Property

IRD

Adm1028InterruptStatusExtTHERM__1 Property

Interrupt Status (Ext. THERM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028IrqStatusClearType InterruptStatusExtTHERM__1 { set; }
Public WriteOnly Property InterruptStatusExtTHERM__1 As Adm1028IrqStatusClearType
    Set
public:
property Adm1028IrqStatusClearType InterruptStatusExtTHERM__1 {
    void set (Adm1028IrqStatusClearType value);
}
member InterruptStatusExtTHERM__1 : Adm1028IrqStatusClearType with set

Property Value

Type: Adm1028IrqStatusClearType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptStatusFlag1 Property

IRD

Adm1028InterruptStatusFlag1 Property

Interrupt Status (Flag 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028BoolType InterruptStatusFlag1 { get; }
Public ReadOnly Property InterruptStatusFlag1 As Adm1028BoolType
    Get
public:
property Adm1028BoolType InterruptStatusFlag1 {
    Adm1028BoolType get ();
}
member InterruptStatusFlag1 : Adm1028BoolType with get

Property Value

Type: Adm1028BoolType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptStatusFlag1__1 Property

IRD

Adm1028InterruptStatusFlag1__1 Property

Interrupt Status (Flag 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028IrqStatusFlagType InterruptStatusFlag1__1 { set; }
Public WriteOnly Property InterruptStatusFlag1__1 As Adm1028IrqStatusFlagType
    Set
public:
property Adm1028IrqStatusFlagType InterruptStatusFlag1__1 {
    void set (Adm1028IrqStatusFlagType value);
}
member InterruptStatusFlag1__1 : Adm1028IrqStatusFlagType with set

Property Value

Type: Adm1028IrqStatusFlagType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptStatusFlag2 Property

IRD

Adm1028InterruptStatusFlag2 Property

Interrupt Status (Flag 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028BoolType InterruptStatusFlag2 { get; }
Public ReadOnly Property InterruptStatusFlag2 As Adm1028BoolType
    Get
public:
property Adm1028BoolType InterruptStatusFlag2 {
    Adm1028BoolType get ();
}
member InterruptStatusFlag2 : Adm1028BoolType with get

Property Value

Type: Adm1028BoolType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptStatusFlag2__1 Property

IRD

Adm1028InterruptStatusFlag2__1 Property

Interrupt Status (Flag 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028IrqStatusFlagType InterruptStatusFlag2__1 { set; }
Public WriteOnly Property InterruptStatusFlag2__1 As Adm1028IrqStatusFlagType
    Set
public:
property Adm1028IrqStatusFlagType InterruptStatusFlag2__1 {
    void set (Adm1028IrqStatusFlagType value);
}
member InterruptStatusFlag2__1 : Adm1028IrqStatusFlagType with set

Property Value

Type: Adm1028IrqStatusFlagType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptStatusGPIInput Property

IRD

Adm1028InterruptStatusGPIInput Property

Interrupt Status (GPI Input)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028BoolType InterruptStatusGPIInput { get; }
Public ReadOnly Property InterruptStatusGPIInput As Adm1028BoolType
    Get
public:
property Adm1028BoolType InterruptStatusGPIInput {
    Adm1028BoolType get ();
}
member InterruptStatusGPIInput : Adm1028BoolType with get

Property Value

Type: Adm1028BoolType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptStatusIntTempError Property

IRD

Adm1028InterruptStatusIntTempError Property

Interrupt Status (Int. Temp Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028BoolType InterruptStatusIntTempError { get; }
Public ReadOnly Property InterruptStatusIntTempError As Adm1028BoolType
    Get
public:
property Adm1028BoolType InterruptStatusIntTempError {
    Adm1028BoolType get ();
}
member InterruptStatusIntTempError : Adm1028BoolType with get

Property Value

Type: Adm1028BoolType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptStatusIntTempError__1 Property

IRD

Adm1028InterruptStatusIntTempError__1 Property

Interrupt Status (Int. Temp Error)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028IrqStatusClearType InterruptStatusIntTempError__1 { set; }
Public WriteOnly Property InterruptStatusIntTempError__1 As Adm1028IrqStatusClearType
    Set
public:
property Adm1028IrqStatusClearType InterruptStatusIntTempError__1 {
    void set (Adm1028IrqStatusClearType value);
}
member InterruptStatusIntTempError__1 : Adm1028IrqStatusClearType with set

Property Value

Type: Adm1028IrqStatusClearType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptStatusIntTHERM Property

IRD

Adm1028InterruptStatusIntTHERM Property

Interrupt Status (Int. THERM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028BoolType InterruptStatusIntTHERM { get; }
Public ReadOnly Property InterruptStatusIntTHERM As Adm1028BoolType
    Get
public:
property Adm1028BoolType InterruptStatusIntTHERM {
    Adm1028BoolType get ();
}
member InterruptStatusIntTHERM : Adm1028BoolType with get

Property Value

Type: Adm1028BoolType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.InterruptStatusIntTHERM__1 Property

IRD

Adm1028InterruptStatusIntTHERM__1 Property

Interrupt Status (Int. THERM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028IrqStatusClearType InterruptStatusIntTHERM__1 { set; }
Public WriteOnly Property InterruptStatusIntTHERM__1 As Adm1028IrqStatusClearType
    Set
public:
property Adm1028IrqStatusClearType InterruptStatusIntTHERM__1 {
    void set (Adm1028IrqStatusClearType value);
}
member InterruptStatusIntTHERM__1 : Adm1028IrqStatusClearType with set

Property Value

Type: Adm1028IrqStatusClearType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.RemoteFunctionROFF Property

IRD

Adm1028RemoteFunctionROFF Property

Remote Function (R_OFF)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028EnabledDisabledType RemoteFunctionROFF { get; set; }
Public Property RemoteFunctionROFF As Adm1028EnabledDisabledType
    Get
    Set
public:
property Adm1028EnabledDisabledType RemoteFunctionROFF {
    Adm1028EnabledDisabledType get ();
    void set (Adm1028EnabledDisabledType value);
}
member RemoteFunctionROFF : Adm1028EnabledDisabledType with get, set

Property Value

Type: Adm1028EnabledDisabledType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.RemoteFunctionRRST Property

IRD

Adm1028RemoteFunctionRRST Property

Remote Function (R_RST)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1028RemoteFctRstType RemoteFunctionRRST { get; set; }
Public Property RemoteFunctionRRST As Adm1028RemoteFctRstType
    Get
    Set
public:
property Adm1028RemoteFctRstType RemoteFunctionRRST {
    Adm1028RemoteFctRstType get ();
    void set (Adm1028RemoteFctRstType value);
}
member RemoteFunctionRRST : Adm1028RemoteFctRstType with get, set

Property Value

Type: Adm1028RemoteFctRstType
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.RemoteTemperatureTripPoint Property

IRD

Adm1028RemoteTemperatureTripPoint Property

Remote Temperature Trip Point (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTemperatureTripPoint { get; set; }
Public Property RemoteTemperatureTripPoint As SByte
    Get
    Set
public:
property signed char RemoteTemperatureTripPoint {
    signed char get ();
    void set (signed char value);
}
member RemoteTemperatureTripPoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.Revision Property

IRD

Adm1028Revision Property

Revision

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Revision { get; }
Public ReadOnly Property Revision As Byte
    Get
public:
property unsigned char Revision {
    unsigned char get ();
}
member Revision : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.Version Property

IRD

Adm1028Version Property

Version

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Version { get; }
Public ReadOnly Property Version As Byte
    Get
public:
property unsigned char Version {
    unsigned char get ();
}
member Version : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028 Methods

The Adm1028 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.Flush Method

IRD

Adm1028Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adm1028 Class
telos.Ird.AnalogDevices Namespace


Adm1028.BoolType Enumeration

IRD

Adm1028BoolType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum BoolType
Public Enumeration BoolType
public enum class BoolType
type BoolType
Members
Member name | Value | Description
True | 1 | True
False | 0 | False
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1028.ConfFanType Enumeration

IRD

Adm1028ConfFanType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfFanType
Public Enumeration ConfFanType
public enum class ConfFanType
type ConfFanType
Members
Member name | Value | Description
Floating | 1 | Floating
DrivenLow | 0 | Driven Low
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1028.ConfInvertType Enumeration

IRD

Adm1028ConfInvertType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfInvertType
Public Enumeration ConfInvertType
public enum class ConfInvertType
type ConfInvertType
Members
Member name | Value | Description
Inverted | 1 | Inverted
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1028.ConfLockType Enumeration

IRD

Adm1028ConfLockType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfLockType
Public Enumeration ConfLockType
public enum class ConfLockType
type ConfLockType
Members
Member name | Value | Description
Lock | 1 | Lock
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1028.ConfResetType Enumeration

IRD

Adm1028ConfResetType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfResetType
Public Enumeration ConfResetType
public enum class ConfResetType
type ConfResetType
Members
Member name | Value | Description
Reset | 1 | Reset
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1028.ConfStartType Enumeration

IRD

Adm1028ConfStartType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfStartType
Public Enumeration ConfStartType
public enum class ConfStartType
type ConfStartType
Members
Member name | Value | Description
Startup | 1 | Startup
Standby | 0 | Standby
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1028.EnabledDisabledType Enumeration

IRD

Adm1028EnabledDisabledType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum EnabledDisabledType
Public Enumeration EnabledDisabledType
public enum class EnabledDisabledType
type EnabledDisabledType
Members
Member name | Value | Description
Enabled | 1 | Enabled
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1028.FanSpeedRampRateType Enumeration

IRD

Adm1028FanSpeedRampRateType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FanSpeedRampRateType
Public Enumeration FanSpeedRampRateType
public enum class FanSpeedRampRateType
type FanSpeedRampRateType
Members
Member name | Value | Description
CountRate10S | 0 | Count Rate: 1.0 s
CountRate025S | 1 | Count Rate: 0.25 s
CountRate0125S | 2 | Count Rate: 0.125 s
CountRate00625S | 3 | Count Rate: 0.0625 s
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1028.IrqMaskType Enumeration

IRD

Adm1028IrqMaskType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqMaskType
Public Enumeration IrqMaskType
public enum class IrqMaskType
type IrqMaskType
Members
Member name | Value | Description
Disabled | 1 | Disabled
Enabled | 0 | Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1028.IrqStatusClearType Enumeration

IRD

Adm1028IrqStatusClearType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqStatusClearType
Public Enumeration IrqStatusClearType
public enum class IrqStatusClearType
type IrqStatusClearType
Members
Member name | Value | Description
Clear | 1 | Clear
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1028.IrqStatusFlagType Enumeration

IRD

Adm1028IrqStatusFlagType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqStatusFlagType
Public Enumeration IrqStatusFlagType
public enum class IrqStatusFlagType
type IrqStatusFlagType
Members
Member name | Value | Description
SetTo1 | 1 | Set To 1
SetTo0 | 0 | Set To 0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1028.RemoteFctRstType Enumeration

IRD

Adm1028RemoteFctRstType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum RemoteFctRstType
Public Enumeration RemoteFctRstType
public enum class RemoteFctRstType
type RemoteFctRstType
Members
Member name | Value | Description
RRSTPulsingFor125Us | 1 | R_RST: Pulsing For >= 125 us
RRSTNoPulsing | 0 | R_RST: No Pulsing
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029 Class

Analog Devices: ADM 1029
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdm1029

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adm1029
Public Class Adm1029
public ref class Adm1029
type Adm1029 =  class end

The Adm1029 type exposes the following members.

Constructors
 | Name | Description
Public method | Adm1029 | Constructor
Top
Properties
 | Name | Description
Public property | AIN0BehaviourAlarmBelowLow | AIN0 Behaviour (Alarm Below Low)
Public property | AIN0BehaviourAlarmSpeedOnHILIM | AIN0 Behaviour (Alarm Speed On HI_LIM)
Public property | AIN0BehaviourAlarmSpeedOnLOLIM | AIN0 Behaviour (Alarm Speed On LO_LIM)
Public property | AIN0BehaviourAssertCFAULTOnHILIM | AIN0 Behaviour (Assert CFAULT On HI_LIM)
Public property | AIN0BehaviourAssertCFAULTOnLOLIM | AIN0 Behaviour (Assert CFAULT On LO_LIM)
Public property | AIN0BehaviourINTOnHILIM | AIN0 Behaviour (INT On HI_LIM)
Public property | AIN0BehaviourINTOnLOLIM | AIN0 Behaviour (INT On LO_LIM)
Public property | AIN0BehaviourLatchAINFault | AIN0 Behaviour (Latch AIN Fault)
Public property | AIN0EventMaskFan1 | AIN0 Event Mask (Fan 1)
Public property | AIN0EventMaskFan2 | AIN0 Event Mask (Fan 2)
Public property | AIN0HighLimit | AIN0 High Limit
Public property | AIN0LowLimit | AIN0 Low Limit
Public property | AIN0MeasuredValue | AIN0 Measured Value
Public property | AIN1BehaviourAlarmBelowLow | AIN1 Behaviour (Alarm Below Low)
Public property | AIN1BehaviourAlarmSpeedOnHILIM | AIN1 Behaviour (Alarm Speed On HI_LIM)
Public property | AIN1BehaviourAlarmSpeedOnLOLIM | AIN1 Behaviour (Alarm Speed On LO_LIM)
Public property | AIN1BehaviourAssertCFAULTOnHILIM | AIN1 Behaviour (Assert CFAULT On HI_LIM)
Public property | AIN1BehaviourAssertCFAULTOnLOLIM | AIN1 Behaviour (Assert CFAULT On LO_LIM)
Public property | AIN1BehaviourINTOnHILIM | AIN1 Behaviour (INT On HI_LIM)
Public property | AIN1BehaviourINTOnLOLIM | AIN1 Behaviour (INT On LO_LIM)
Public property | AIN1BehaviourLatchAINFault | AIN1 Behaviour (Latch AIN Fault)
Public property | AIN1EventMaskFan1 | AIN1 Event Mask (Fan 1)
Public property | AIN1EventMaskFan2 | AIN1 Event Mask (Fan 2)
Public property | AIN1HighLimit | AIN1 High Limit
Public property | AIN1LowLimit | AIN1 Low Limit
Public property | AIN1MeasuredValue | AIN1 Measured Value
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigARADisable | Config (ARA Disable)
Public property | ConfigForceCFAULT | Config (Force CFAULT)
Public property | ConfigForceINT | Config (Force INT)
Public property | ConfigGlobalINTMask | Config (Global INT Mask)
Public property | ConfigInstall | Config (Install)
Public property | ConfigINTPolarity | Config (INT Polarity)
Public property | ConfigPerformFreeWheelTest | Config (Perform Free-Wheel Test)
Public property | ConfigStartMonitoring | Config (Start Monitoring)
Public property | Fan1AlarmSpeed | Fan 1 Alarm Speed (unit: %)
Public property | Fan1ConfigurationHotPlugSpeed | Fan 1 Configuration (Hot-Plug Speed) (unit: %)
Public property | Fan1ConfigurationOscillatorFrequency | Fan 1 Configuration (Oscillator Frequency)
Public property | Fan1ConfigurationPWMFrequency | Fan 1 Configuration (PWM Frequency) (unit: Hz)
Public property | Fan1EventMaskFan1 | Fan 1 Event Mask (Fan 1)
Public property | Fan1EventMaskFan2 | Fan 1 Event Mask (Fan 2)
Public property | Fan1FaultActionAlarmOnCFAULT | Fan 1 Fault Action (Alarm On CFAULT)
Public property | Fan1FaultActionAssertCFAULTOnFault | Fan 1 Fault Action (Assert CFAULT On Fault)
Public property | Fan1FaultActionAssertCFAULTOnHotUnplug | Fan 1 Fault Action (Assert CFAULT On Hot Unplug)
Public property | Fan1FaultActionAssertINTOnFault | Fan 1 Fault Action (Assert INT On Fault)
Public property | Fan1FaultActionAssertINTOnHotUnplug | Fan 1 Fault Action (Assert INT On Hot Unplug)
Public property | Fan1FaultActionDriveFaultOnFaultL | Fan 1 Fault Action (Drive Fault On Fault_L)
Public property | Fan1FaultActionHotPlugSpeedOnCFAULTIn | Fan 1 Fault Action (Hot-Plug Speed On CFAULT In)
Public property | Fan1FaultActionThermalOverrideInSleep | Fan 1 Fault Action (Thermal Override In Sleep)
Public property | Fan1MinimumSpeed | Fan 1 Minimum Speed (unit: %)
Public property | Fan1StatusFault | Fan 1 Status (Fault)
Public property | Fan1StatusFaultL | Fan 1 Status (Fault_L)
Public property | Fan1StatusHotPlugL | Fan 1 Status (Hot_Plug_L)
Public property | Fan1StatusHotPlugPriority | Fan 1 Status (Hot Plug Priority)
Public property | Fan1StatusMissing | Fan 1 Status (Missing)
Public property | Fan1StatusMissingL | Fan 1 Status (Missing_L)
Public property | Fan1StatusSleep | Fan 1 Status (Sleep)
Public property | Fan1StatusTachFaultL | Fan 1 Status (Tach_Fault_L)
Public property | Fan1TachHighLimit | Fan 1 Tach High Limit
Public property | Fan1TachValue | Fan 1 Tach Value
Public property | Fan2AlarmSpeed | Fan 2 Alarm Speed (unit: %)
Public property | Fan2ConfigurationHotPlugSpeed | Fan 2 Configuration (Hot-Plug Speed) (unit: %)
Public property | Fan2ConfigurationOscillatorFrequency | Fan 2 Configuration (Oscillator Frequency)
Public property | Fan2ConfigurationPWMFrequency | Fan 2 Configuration (PWM Frequency) (unit: Hz)
Public property | Fan2EventMaskFan1 | Fan 2 Event Mask (Fan 1)
Public property | Fan2EventMaskFan2 | Fan 2 Event Mask (Fan 2)
Public property | Fan2FaultActionAlarmOnCFAULT | Fan 2 Fault Action (Alarm On CFAULT)
Public property | Fan2FaultActionAssertCFAULTOnFault | Fan 2 Fault Action (Assert CFAULT On Fault)
Public property | Fan2FaultActionAssertCFAULTOnHotUnplug | Fan 2 Fault Action (Assert CFAULT On Hot Unplug)
Public property | Fan2FaultActionAssertINTOnFault | Fan 2 Fault Action (Assert INT On Fault)
Public property | Fan2FaultActionAssertINTOnHotUnplug | Fan 2 Fault Action (Assert INT On Hot Unplug)
Public property | Fan2FaultActionDriveFaultOnFaultL | Fan 2 Fault Action (Drive Fault On Fault_L)
Public property | Fan2FaultActionHotPlugSpeedOnCFAULTIn | Fan 2 Fault Action (Hot-Plug Speed On CFAULT In)
Public property | Fan2FaultActionThermalOverrideInSleep | Fan 2 Fault Action (Thermal Override In Sleep)
Public property | Fan2MinimumSpeed | Fan 2 Minimum Speed (unit: %)
Public property | Fan2StatusFault | Fan 2 Status (Fault)
Public property | Fan2StatusFaultL | Fan 2 Status (Fault_L)
Public property | Fan2StatusHotPlugL | Fan 2 Status (Hot_Plug_L)
Public property | Fan2StatusHotPlugPriority | Fan 2 Status (Hot Plug Priority)
Public property | Fan2StatusMissing | Fan 2 Status (Missing)
Public property | Fan2StatusMissingL | Fan 2 Status (Missing_L)
Public property | Fan2StatusSleep | Fan 2 Status (Sleep)
Public property | Fan2StatusTachFaultL | Fan 2 Status (Tach_Fault_L)
Public property | Fan2TachHighLimit | Fan 2 Tach High Limit
Public property | Fan2TachValue | Fan 2 Tach Value
Public property | FanSpinUpDisable | Fan Spin-Up (Disable)
Public property | FanSpinUpTime | Fan Spin-Up (Time)
Public property | FanSupportedByControllerFan1 | Fan Supported By Controller (Fan 1)
Public property | FanSupportedByControllerFan2 | Fan Supported By Controller (Fan 2)
Public property | FanSupportedInSystemFan1 | Fan Supported In System (Fan 1)
Public property | FanSupportedInSystemFan2 | Fan Supported In System (Fan 2)
Public property | GPIO0BehaviourBit2 | GPIO0 Behaviour (Bit 2)
Public property | GPIO0BehaviourBit3 | GPIO0 Behaviour (Bit 3)
Public property | GPIO0BehaviourBit4 | GPIO0 Behaviour (Bit 4)
Public property | GPIO0BehaviourBit5 | GPIO0 Behaviour (Bit 5)
Public property | GPIO0BehaviourBit6 | GPIO0 Behaviour (Bit 6)
Public property | GPIO0BehaviourBit7 | GPIO0 Behaviour (Bit 7)
Public property | GPIO0BehaviourDirection | GPIO0 Behaviour (Direction)
Public property | GPIO0BehaviourPolarity | GPIO0 Behaviour (Polarity)
Public property | GPIO0EventMaskFan1 | GPIO0 Event Mask (Fan 1)
Public property | GPIO0EventMaskFan2 | GPIO0 Event Mask (Fan 2)
Public property | GPIO1BehaviourBit2 | GPIO1 Behaviour (Bit 2)
Public property | GPIO1BehaviourBit3 | GPIO1 Behaviour (Bit 3)
Public property | GPIO1BehaviourBit4 | GPIO1 Behaviour (Bit 4)
Public property | GPIO1BehaviourBit5 | GPIO1 Behaviour (Bit 5)
Public property | GPIO1BehaviourBit6 | GPIO1 Behaviour (Bit 6)
Public property | GPIO1BehaviourBit7 | GPIO1 Behaviour (Bit 7)
Public property | GPIO1BehaviourDirection | GPIO1 Behaviour (Direction)
Public property | GPIO1BehaviourPolarity | GPIO1 Behaviour (Polarity)
Public property | GPIO1EventMaskFan1 | GPIO1 Event Mask (Fan 1)
Public property | GPIO1EventMaskFan2 | GPIO1 Event Mask (Fan 2)
Public property | GPIO2BehaviourBit2 | GPIO2 Behaviour (Bit 2)
Public property | GPIO2BehaviourBit3 | GPIO2 Behaviour (Bit 3)
Public property | GPIO2BehaviourBit4 | GPIO2 Behaviour (Bit 4)
Public property | GPIO2BehaviourBit5 | GPIO2 Behaviour (Bit 5)
Public property | GPIO2BehaviourBit6 | GPIO2 Behaviour (Bit 6)
Public property | GPIO2BehaviourBit7 | GPIO2 Behaviour (Bit 7)
Public property | GPIO2BehaviourDirection | GPIO2 Behaviour (Direction)
Public property | GPIO2BehaviourPolarity | GPIO2 Behaviour (Polarity)
Public property | GPIO2EventMaskFan1 | GPIO2 Event Mask (Fan 1)
Public property | GPIO2EventMaskFan2 | GPIO2 Event Mask (Fan 2)
Public property | GPIO3BehaviourBit2 | GPIO3 Behaviour (Bit 2)
Public property | GPIO3BehaviourBit3 | GPIO3 Behaviour (Bit 3)
Public property | GPIO3BehaviourBit4 | GPIO3 Behaviour (Bit 4)
Public property | GPIO3BehaviourBit5 | GPIO3 Behaviour (Bit 5)
Public property | GPIO3BehaviourBit6 | GPIO3 Behaviour (Bit 6)
Public property | GPIO3BehaviourBit7 | GPIO3 Behaviour (Bit 7)
Public property | GPIO3BehaviourDirection | GPIO3 Behaviour (Direction)
Public property | GPIO3BehaviourPolarity | GPIO3 Behaviour (Polarity)
Public property | GPIO3EventMaskFan1 | GPIO3 Event Mask (Fan 1)
Public property | GPIO3EventMaskFan2 | GPIO3 Event Mask (Fan 2)
Public property | GPIO4BehaviourBit2 | GPIO4 Behaviour (Bit 2)
Public property | GPIO4BehaviourBit3 | GPIO4 Behaviour (Bit 3)
Public property | GPIO4BehaviourBit4 | GPIO4 Behaviour (Bit 4)
Public property | GPIO4BehaviourBit5 | GPIO4 Behaviour (Bit 5)
Public property | GPIO4BehaviourBit6 | GPIO4 Behaviour (Bit 6)
Public property | GPIO4BehaviourBit7 | GPIO4 Behaviour (Bit 7)
Public property | GPIO4BehaviourDirection | GPIO4 Behaviour (Direction)
Public property | GPIO4BehaviourPolarity | GPIO4 Behaviour (Polarity)
Public property | GPIO4EventMaskFan1 | GPIO4 Event Mask (Fan 1)
Public property | GPIO4EventMaskFan2 | GPIO4 Event Mask (Fan 2)
Public property | GPIO5BehaviourBit2 | GPIO5 Behaviour (Bit 2)
Public property | GPIO5BehaviourBit3 | GPIO5 Behaviour (Bit 3)
Public property | GPIO5BehaviourBit4 | GPIO5 Behaviour (Bit 4)
Public property | GPIO5BehaviourBit5 | GPIO5 Behaviour (Bit 5)
Public property | GPIO5BehaviourBit6 | GPIO5 Behaviour (Bit 6)
Public property | GPIO5BehaviourBit7 | GPIO5 Behaviour (Bit 7)
Public property | GPIO5BehaviourDirection | GPIO5 Behaviour (Direction)
Public property | GPIO5BehaviourPolarity | GPIO5 Behaviour (Polarity)
Public property | GPIO5EventMaskFan1 | GPIO5 Event Mask (Fan 1)
Public property | GPIO5EventMaskFan2 | GPIO5 Event Mask (Fan 2)
Public property | GPIO6BehaviourBit2 | GPIO6 Behaviour (Bit 2)
Public property | GPIO6BehaviourBit3 | GPIO6 Behaviour (Bit 3)
Public property | GPIO6BehaviourBit4 | GPIO6 Behaviour (Bit 4)
Public property | GPIO6BehaviourBit5 | GPIO6 Behaviour (Bit 5)
Public property | GPIO6BehaviourBit6 | GPIO6 Behaviour (Bit 6)
Public property | GPIO6BehaviourBit7 | GPIO6 Behaviour (Bit 7)
Public property | GPIO6BehaviourDirection | GPIO6 Behaviour (Direction)
Public property | GPIO6BehaviourPolarity | GPIO6 Behaviour (Polarity)
Public property | GPIO6EventMaskFan1 | GPIO6 Event Mask (Fan 1)
Public property | GPIO6EventMaskFan2 | GPIO6 Event Mask (Fan 2)
Public property | GPIOPresentAINGPIO0 | GPIO Present/AIN (GPIO 0)
Public property | GPIOPresentAINGPIO1 | GPIO Present/AIN (GPIO 1)
Public property | GPIOPresentAINGPIO2 | GPIO Present/AIN (GPIO 2)
Public property | GPIOPresentAINGPIO3 | GPIO Present/AIN (GPIO 3)
Public property | GPIOPresentAINGPIO4 | GPIO Present/AIN (GPIO 4)
Public property | GPIOPresentAINGPIO5 | GPIO Present/AIN (GPIO 5)
Public property | GPIOPresentAINGPIO6 | GPIO Present/AIN (GPIO 6)
Public property | GPIOSupportedByControllerGPIO0 | GPIO Supported By Controller (GPIO 0)
Public property | GPIOSupportedByControllerGPIO1 | GPIO Supported By Controller (GPIO 1)
Public property | GPIOSupportedByControllerGPIO2 | GPIO Supported By Controller (GPIO 2)
Public property | GPIOSupportedByControllerGPIO3 | GPIO Supported By Controller (GPIO 3)
Public property | GPIOSupportedByControllerGPIO4 | GPIO Supported By Controller (GPIO 4)
Public property | GPIOSupportedByControllerGPIO5 | GPIO Supported By Controller (GPIO 5)
Public property | GPIOSupportedByControllerGPIO6 | GPIO Supported By Controller (GPIO 6)
Public property | LocalTempCoolingActionFan1 | Local Temp Cooling Action (Fan 1)
Public property | LocalTempCoolingActionFan2 | Local Temp Cooling Action (Fan 2)
Public property | LocalTemperatureOffset | Local Temperature Offset (unit: °C)
Public property | LocalTempFaultActionAlarmSpeedLow | Local Temp Fault Action (Alarm Speed Low)
Public property | LocalTempFaultActionAlarmSpeedOnOT | Local Temp Fault Action (Alarm Speed On OT)
Public property | LocalTempFaultActionAlarmSpeedOnUT | Local Temp Fault Action (Alarm Speed On UT)
Public property | LocalTempFaultActionAssertCFAULTOnOT | Local Temp Fault Action (Assert CFAULT On OT)
Public property | LocalTempFaultActionAssertCFAULTOnUT | Local Temp Fault Action (Assert CFAULT On UT)
Public property | LocalTempFaultActionINTOnOT | Local Temp Fault Action (INT On OT)
Public property | LocalTempFaultActionINTOnUT | Local Temp Fault Action (INT On UT)
Public property | LocalTempFaultActionLatchTempFault | Local Temp Fault Action (Latch Temp Fault)
Public property | LocalTempHighLimit | Local Temp High Limit (unit: °C)
Public property | LocalTempLowLimit | Local Temp Low Limit (unit: °C)
Public property | LocalTempTHYST | Local Temp T_HYST (unit: °C)
Public property | LocalTempTMIN | Local Temp T_MIN (unit: °C)
Public property | LocalTempTRANGE | Local Temp T_RANGE (unit: °C)
Public property | LocalTempValue | Local Temp Value (unit: °C)
Public property | MajorRevisionCode | Major Revision Code
Public property | ManufacturerID | Manufacturer ID
Public property | MinorRevisionCode | Minor Revision Code
Public property | Remote1TempCoolingActionFan1 | Remote 1 Temp Cooling Action (Fan 1)
Public property | Remote1TempCoolingActionFan2 | Remote 1 Temp Cooling Action (Fan 2)
Public property | Remote1TemperatureOffset | Remote 1 Temperature Offset (unit: °C)
Public property | Remote1TempFaultActionAlarmSpeedLow | Remote 1 Temp Fault Action (Alarm Speed Low)
Public property | Remote1TempFaultActionAlarmSpeedOnOT | Remote 1 Temp Fault Action (Alarm Speed On OT)
Public property | Remote1TempFaultActionAlarmSpeedOnUT | Remote 1 Temp Fault Action (Alarm Speed On UT)
Public property | Remote1TempFaultActionAssertCFAULTOnOT | Remote 1 Temp Fault Action (Assert CFAULT On OT)
Public property | Remote1TempFaultActionAssertCFAULTOnUT | Remote 1 Temp Fault Action (Assert CFAULT On UT)
Public property | Remote1TempFaultActionINTOnOT | Remote 1 Temp Fault Action (INT On OT)
Public property | Remote1TempFaultActionINTOnUT | Remote 1 Temp Fault Action (INT On UT)
Public property | Remote1TempFaultActionLatchTempFault | Remote 1 Temp Fault Action (Latch Temp Fault)
Public property | Remote1TempHighLimit | Remote 1 Temp High Limit (unit: °C)
Public property | Remote1TempLowLimit | Remote 1 Temp Low Limit (unit: °C)
Public property | Remote1TempTHYST | Remote 1 Temp T_HYST (unit: °C)
Public property | Remote1TempTMIN | Remote 1 Temp T_MIN (unit: °C)
Public property | Remote1TempTRANGE | Remote 1 Temp T_RANGE (unit: °C)
Public property | Remote1TempValue | Remote 1 Temp Value (unit: °C)
Public property | Remote2TempCoolingActionFan1 | Remote 2 Temp Cooling Action (Fan 1)
Public property | Remote2TempCoolingActionFan2 | Remote 2 Temp Cooling Action (Fan 2)
Public property | Remote2TemperatureOffset | Remote 2 Temperature Offset (unit: °C)
Public property | Remote2TempFaultActionAlarmSpeedLow | Remote 2 Temp Fault Action (Alarm Speed Low)
Public property | Remote2TempFaultActionAlarmSpeedOnOT | Remote 2 Temp Fault Action (Alarm Speed On OT)
Public property | Remote2TempFaultActionAlarmSpeedOnUT | Remote 2 Temp Fault Action (Alarm Speed On UT)
Public property | Remote2TempFaultActionAssertCFAULTOnOT | Remote 2 Temp Fault Action (Assert CFAULT On OT)
Public property | Remote2TempFaultActionAssertCFAULTOnUT | Remote 2 Temp Fault Action (Assert CFAULT On UT)
Public property | Remote2TempFaultActionINTOnOT | Remote 2 Temp Fault Action (INT On OT)
Public property | Remote2TempFaultActionINTOnUT | Remote 2 Temp Fault Action (INT On UT)
Public property | Remote2TempFaultActionLatchTempFault | Remote 2 Temp Fault Action (Latch Temp Fault)
Public property | Remote2TempHighLimit | Remote 2 Temp High Limit (unit: °C)
Public property | Remote2TempLowLimit | Remote 2 Temp Low Limit (unit: °C)
Public property | Remote2TempTHYST | Remote 2 Temp T_HYST (unit: °C)
Public property | Remote2TempTMIN | Remote 2 Temp T_MIN (unit: °C)
Public property | Remote2TempTRANGE | Remote 2 Temp T_RANGE (unit: °C)
Public property | Remote2TempValue | Remote 2 Temp Value (unit: °C)
Public property | SetFanXAlarmSpeedFan1 | Set Fan x Alarm Speed (Fan 1)
Public property | SetFanXAlarmSpeedFan2 | Set Fan x Alarm Speed (Fan 2)
Public property | SetFanXFullSpeedFan1 | Set Fan x Full Speed (Fan 1)
Public property | SetFanXFullSpeedFan2 | Set Fan x Full Speed (Fan 2)
Public property | SetFanXHotPlugSpeedFan1 | Set Fan x Hot-Plug Speed (Fan 1)
Public property | SetFanXHotPlugSpeedFan2 | Set Fan x Hot-Plug Speed (Fan 2)
Public property | StatusCFAULTIn | Status (CFAULT_in)
Public property | StatusCFAULTOut | Status (CFAULT_out)
Public property | StatusGPIOAINEvent | Status (GPIO/AIN Event)
Public property | StatusHotPlugFanFault | Status (Hot Plug/Fan Fault)
Public property | StatusInAlarmSpeed | Status (In Alarm_speed)
Public property | StatusInHotPlugSpeed | Status (In Hot-Plug Speed)
Public property | StatusINT | Status (INT)
Public property | StatusThermalEvent | Status (Thermal Event)
Public property | SWReset | S/W Reset
Public property | TempDevicesInstalledLocalTemp | Temp Devices Installed (Local Temp)
Public property | TempDevicesInstalledRemote1Temp | Temp Devices Installed (Remote 1 Temp)
Public property | TempDevicesInstalledRemote2Temp | Temp Devices Installed (Remote 2 Temp)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Dual PWM Fan Controller And Temperature Monitor For High Availability Systems
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adm1029(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adm1029

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029 Properties

The Adm1029 type exposes the following members.

Properties
 | Name | Description
Public property | AIN0BehaviourAlarmBelowLow | AIN0 Behaviour (Alarm Below Low)
Public property | AIN0BehaviourAlarmSpeedOnHILIM | AIN0 Behaviour (Alarm Speed On HI_LIM)
Public property | AIN0BehaviourAlarmSpeedOnLOLIM | AIN0 Behaviour (Alarm Speed On LO_LIM)
Public property | AIN0BehaviourAssertCFAULTOnHILIM | AIN0 Behaviour (Assert CFAULT On HI_LIM)
Public property | AIN0BehaviourAssertCFAULTOnLOLIM | AIN0 Behaviour (Assert CFAULT On LO_LIM)
Public property | AIN0BehaviourINTOnHILIM | AIN0 Behaviour (INT On HI_LIM)
Public property | AIN0BehaviourINTOnLOLIM | AIN0 Behaviour (INT On LO_LIM)
Public property | AIN0BehaviourLatchAINFault | AIN0 Behaviour (Latch AIN Fault)
Public property | AIN0EventMaskFan1 | AIN0 Event Mask (Fan 1)
Public property | AIN0EventMaskFan2 | AIN0 Event Mask (Fan 2)
Public property | AIN0HighLimit | AIN0 High Limit
Public property | AIN0LowLimit | AIN0 Low Limit
Public property | AIN0MeasuredValue | AIN0 Measured Value
Public property | AIN1BehaviourAlarmBelowLow | AIN1 Behaviour (Alarm Below Low)
Public property | AIN1BehaviourAlarmSpeedOnHILIM | AIN1 Behaviour (Alarm Speed On HI_LIM)
Public property | AIN1BehaviourAlarmSpeedOnLOLIM | AIN1 Behaviour (Alarm Speed On LO_LIM)
Public property | AIN1BehaviourAssertCFAULTOnHILIM | AIN1 Behaviour (Assert CFAULT On HI_LIM)
Public property | AIN1BehaviourAssertCFAULTOnLOLIM | AIN1 Behaviour (Assert CFAULT On LO_LIM)
Public property | AIN1BehaviourINTOnHILIM | AIN1 Behaviour (INT On HI_LIM)
Public property | AIN1BehaviourINTOnLOLIM | AIN1 Behaviour (INT On LO_LIM)
Public property | AIN1BehaviourLatchAINFault | AIN1 Behaviour (Latch AIN Fault)
Public property | AIN1EventMaskFan1 | AIN1 Event Mask (Fan 1)
Public property | AIN1EventMaskFan2 | AIN1 Event Mask (Fan 2)
Public property | AIN1HighLimit | AIN1 High Limit
Public property | AIN1LowLimit | AIN1 Low Limit
Public property | AIN1MeasuredValue | AIN1 Measured Value
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigARADisable | Config (ARA Disable)
Public property | ConfigForceCFAULT | Config (Force CFAULT)
Public property | ConfigForceINT | Config (Force INT)
Public property | ConfigGlobalINTMask | Config (Global INT Mask)
Public property | ConfigInstall | Config (Install)
Public property | ConfigINTPolarity | Config (INT Polarity)
Public property | ConfigPerformFreeWheelTest | Config (Perform Free-Wheel Test)
Public property | ConfigStartMonitoring | Config (Start Monitoring)
Public property | Fan1AlarmSpeed | Fan 1 Alarm Speed (unit: %)
Public property | Fan1ConfigurationHotPlugSpeed | Fan 1 Configuration (Hot-Plug Speed) (unit: %)
Public property | Fan1ConfigurationOscillatorFrequency | Fan 1 Configuration (Oscillator Frequency)
Public property | Fan1ConfigurationPWMFrequency | Fan 1 Configuration (PWM Frequency) (unit: Hz)
Public property | Fan1EventMaskFan1 | Fan 1 Event Mask (Fan 1)
Public property | Fan1EventMaskFan2 | Fan 1 Event Mask (Fan 2)
Public property | Fan1FaultActionAlarmOnCFAULT | Fan 1 Fault Action (Alarm On CFAULT)
Public property | Fan1FaultActionAssertCFAULTOnFault | Fan 1 Fault Action (Assert CFAULT On Fault)
Public property | Fan1FaultActionAssertCFAULTOnHotUnplug | Fan 1 Fault Action (Assert CFAULT On Hot Unplug)
Public property | Fan1FaultActionAssertINTOnFault | Fan 1 Fault Action (Assert INT On Fault)
Public property | Fan1FaultActionAssertINTOnHotUnplug | Fan 1 Fault Action (Assert INT On Hot Unplug)
Public property | Fan1FaultActionDriveFaultOnFaultL | Fan 1 Fault Action (Drive Fault On Fault_L)
Public property | Fan1FaultActionHotPlugSpeedOnCFAULTIn | Fan 1 Fault Action (Hot-Plug Speed On CFAULT In)
Public property | Fan1FaultActionThermalOverrideInSleep | Fan 1 Fault Action (Thermal Override In Sleep)
Public property | Fan1MinimumSpeed | Fan 1 Minimum Speed (unit: %)
Public property | Fan1StatusFault | Fan 1 Status (Fault)
Public property | Fan1StatusFaultL | Fan 1 Status (Fault_L)
Public property | Fan1StatusHotPlugL | Fan 1 Status (Hot_Plug_L)
Public property | Fan1StatusHotPlugPriority | Fan 1 Status (Hot Plug Priority)
Public property | Fan1StatusMissing | Fan 1 Status (Missing)
Public property | Fan1StatusMissingL | Fan 1 Status (Missing_L)
Public property | Fan1StatusSleep | Fan 1 Status (Sleep)
Public property | Fan1StatusTachFaultL | Fan 1 Status (Tach_Fault_L)
Public property | Fan1TachHighLimit | Fan 1 Tach High Limit
Public property | Fan1TachValue | Fan 1 Tach Value
Public property | Fan2AlarmSpeed | Fan 2 Alarm Speed (unit: %)
Public property | Fan2ConfigurationHotPlugSpeed | Fan 2 Configuration (Hot-Plug Speed) (unit: %)
Public property | Fan2ConfigurationOscillatorFrequency | Fan 2 Configuration (Oscillator Frequency)
Public property | Fan2ConfigurationPWMFrequency | Fan 2 Configuration (PWM Frequency) (unit: Hz)
Public property | Fan2EventMaskFan1 | Fan 2 Event Mask (Fan 1)
Public property | Fan2EventMaskFan2 | Fan 2 Event Mask (Fan 2)
Public property | Fan2FaultActionAlarmOnCFAULT | Fan 2 Fault Action (Alarm On CFAULT)
Public property | Fan2FaultActionAssertCFAULTOnFault | Fan 2 Fault Action (Assert CFAULT On Fault)
Public property | Fan2FaultActionAssertCFAULTOnHotUnplug | Fan 2 Fault Action (Assert CFAULT On Hot Unplug)
Public property | Fan2FaultActionAssertINTOnFault | Fan 2 Fault Action (Assert INT On Fault)
Public property | Fan2FaultActionAssertINTOnHotUnplug | Fan 2 Fault Action (Assert INT On Hot Unplug)
Public property | Fan2FaultActionDriveFaultOnFaultL | Fan 2 Fault Action (Drive Fault On Fault_L)
Public property | Fan2FaultActionHotPlugSpeedOnCFAULTIn | Fan 2 Fault Action (Hot-Plug Speed On CFAULT In)
Public property | Fan2FaultActionThermalOverrideInSleep | Fan 2 Fault Action (Thermal Override In Sleep)
Public property | Fan2MinimumSpeed | Fan 2 Minimum Speed (unit: %)
Public property | Fan2StatusFault | Fan 2 Status (Fault)
Public property | Fan2StatusFaultL | Fan 2 Status (Fault_L)
Public property | Fan2StatusHotPlugL | Fan 2 Status (Hot_Plug_L)
Public property | Fan2StatusHotPlugPriority | Fan 2 Status (Hot Plug Priority)
Public property | Fan2StatusMissing | Fan 2 Status (Missing)
Public property | Fan2StatusMissingL | Fan 2 Status (Missing_L)
Public property | Fan2StatusSleep | Fan 2 Status (Sleep)
Public property | Fan2StatusTachFaultL | Fan 2 Status (Tach_Fault_L)
Public property | Fan2TachHighLimit | Fan 2 Tach High Limit
Public property | Fan2TachValue | Fan 2 Tach Value
Public property | FanSpinUpDisable | Fan Spin-Up (Disable)
Public property | FanSpinUpTime | Fan Spin-Up (Time)
Public property | FanSupportedByControllerFan1 | Fan Supported By Controller (Fan 1)
Public property | FanSupportedByControllerFan2 | Fan Supported By Controller (Fan 2)
Public property | FanSupportedInSystemFan1 | Fan Supported In System (Fan 1)
Public property | FanSupportedInSystemFan2 | Fan Supported In System (Fan 2)
Public property | GPIO0BehaviourBit2 | GPIO0 Behaviour (Bit 2)
Public property | GPIO0BehaviourBit3 | GPIO0 Behaviour (Bit 3)
Public property | GPIO0BehaviourBit4 | GPIO0 Behaviour (Bit 4)
Public property | GPIO0BehaviourBit5 | GPIO0 Behaviour (Bit 5)
Public property | GPIO0BehaviourBit6 | GPIO0 Behaviour (Bit 6)
Public property | GPIO0BehaviourBit7 | GPIO0 Behaviour (Bit 7)
Public property | GPIO0BehaviourDirection | GPIO0 Behaviour (Direction)
Public property | GPIO0BehaviourPolarity | GPIO0 Behaviour (Polarity)
Public property | GPIO0EventMaskFan1 | GPIO0 Event Mask (Fan 1)
Public property | GPIO0EventMaskFan2 | GPIO0 Event Mask (Fan 2)
Public property | GPIO1BehaviourBit2 | GPIO1 Behaviour (Bit 2)
Public property | GPIO1BehaviourBit3 | GPIO1 Behaviour (Bit 3)
Public property | GPIO1BehaviourBit4 | GPIO1 Behaviour (Bit 4)
Public property | GPIO1BehaviourBit5 | GPIO1 Behaviour (Bit 5)
Public property | GPIO1BehaviourBit6 | GPIO1 Behaviour (Bit 6)
Public property | GPIO1BehaviourBit7 | GPIO1 Behaviour (Bit 7)
Public property | GPIO1BehaviourDirection | GPIO1 Behaviour (Direction)
Public property | GPIO1BehaviourPolarity | GPIO1 Behaviour (Polarity)
Public property | GPIO1EventMaskFan1 | GPIO1 Event Mask (Fan 1)
Public property | GPIO1EventMaskFan2 | GPIO1 Event Mask (Fan 2)
Public property | GPIO2BehaviourBit2 | GPIO2 Behaviour (Bit 2)
Public property | GPIO2BehaviourBit3 | GPIO2 Behaviour (Bit 3)
Public property | GPIO2BehaviourBit4 | GPIO2 Behaviour (Bit 4)
Public property | GPIO2BehaviourBit5 | GPIO2 Behaviour (Bit 5)
Public property | GPIO2BehaviourBit6 | GPIO2 Behaviour (Bit 6)
Public property | GPIO2BehaviourBit7 | GPIO2 Behaviour (Bit 7)
Public property | GPIO2BehaviourDirection | GPIO2 Behaviour (Direction)
Public property | GPIO2BehaviourPolarity | GPIO2 Behaviour (Polarity)
Public property | GPIO2EventMaskFan1 | GPIO2 Event Mask (Fan 1)
Public property | GPIO2EventMaskFan2 | GPIO2 Event Mask (Fan 2)
Public property | GPIO3BehaviourBit2 | GPIO3 Behaviour (Bit 2)
Public property | GPIO3BehaviourBit3 | GPIO3 Behaviour (Bit 3)
Public property | GPIO3BehaviourBit4 | GPIO3 Behaviour (Bit 4)
Public property | GPIO3BehaviourBit5 | GPIO3 Behaviour (Bit 5)
Public property | GPIO3BehaviourBit6 | GPIO3 Behaviour (Bit 6)
Public property | GPIO3BehaviourBit7 | GPIO3 Behaviour (Bit 7)
Public property | GPIO3BehaviourDirection | GPIO3 Behaviour (Direction)
Public property | GPIO3BehaviourPolarity | GPIO3 Behaviour (Polarity)
Public property | GPIO3EventMaskFan1 | GPIO3 Event Mask (Fan 1)
Public property | GPIO3EventMaskFan2 | GPIO3 Event Mask (Fan 2)
Public property | GPIO4BehaviourBit2 | GPIO4 Behaviour (Bit 2)
Public property | GPIO4BehaviourBit3 | GPIO4 Behaviour (Bit 3)
Public property | GPIO4BehaviourBit4 | GPIO4 Behaviour (Bit 4)
Public property | GPIO4BehaviourBit5 | GPIO4 Behaviour (Bit 5)
Public property | GPIO4BehaviourBit6 | GPIO4 Behaviour (Bit 6)
Public property | GPIO4BehaviourBit7 | GPIO4 Behaviour (Bit 7)
Public property | GPIO4BehaviourDirection | GPIO4 Behaviour (Direction)
Public property | GPIO4BehaviourPolarity | GPIO4 Behaviour (Polarity)
Public property | GPIO4EventMaskFan1 | GPIO4 Event Mask (Fan 1)
Public property | GPIO4EventMaskFan2 | GPIO4 Event Mask (Fan 2)
Public property | GPIO5BehaviourBit2 | GPIO5 Behaviour (Bit 2)
Public property | GPIO5BehaviourBit3 | GPIO5 Behaviour (Bit 3)
Public property | GPIO5BehaviourBit4 | GPIO5 Behaviour (Bit 4)
Public property | GPIO5BehaviourBit5 | GPIO5 Behaviour (Bit 5)
Public property | GPIO5BehaviourBit6 | GPIO5 Behaviour (Bit 6)
Public property | GPIO5BehaviourBit7 | GPIO5 Behaviour (Bit 7)
Public property | GPIO5BehaviourDirection | GPIO5 Behaviour (Direction)
Public property | GPIO5BehaviourPolarity | GPIO5 Behaviour (Polarity)
Public property | GPIO5EventMaskFan1 | GPIO5 Event Mask (Fan 1)
Public property | GPIO5EventMaskFan2 | GPIO5 Event Mask (Fan 2)
Public property | GPIO6BehaviourBit2 | GPIO6 Behaviour (Bit 2)
Public property | GPIO6BehaviourBit3 | GPIO6 Behaviour (Bit 3)
Public property | GPIO6BehaviourBit4 | GPIO6 Behaviour (Bit 4)
Public property | GPIO6BehaviourBit5 | GPIO6 Behaviour (Bit 5)
Public property | GPIO6BehaviourBit6 | GPIO6 Behaviour (Bit 6)
Public property | GPIO6BehaviourBit7 | GPIO6 Behaviour (Bit 7)
Public property | GPIO6BehaviourDirection | GPIO6 Behaviour (Direction)
Public property | GPIO6BehaviourPolarity | GPIO6 Behaviour (Polarity)
Public property | GPIO6EventMaskFan1 | GPIO6 Event Mask (Fan 1)
Public property | GPIO6EventMaskFan2 | GPIO6 Event Mask (Fan 2)
Public property | GPIOPresentAINGPIO0 | GPIO Present/AIN (GPIO 0)
Public property | GPIOPresentAINGPIO1 | GPIO Present/AIN (GPIO 1)
Public property | GPIOPresentAINGPIO2 | GPIO Present/AIN (GPIO 2)
Public property | GPIOPresentAINGPIO3 | GPIO Present/AIN (GPIO 3)
Public property | GPIOPresentAINGPIO4 | GPIO Present/AIN (GPIO 4)
Public property | GPIOPresentAINGPIO5 | GPIO Present/AIN (GPIO 5)
Public property | GPIOPresentAINGPIO6 | GPIO Present/AIN (GPIO 6)
Public property | GPIOSupportedByControllerGPIO0 | GPIO Supported By Controller (GPIO 0)
Public property | GPIOSupportedByControllerGPIO1 | GPIO Supported By Controller (GPIO 1)
Public property | GPIOSupportedByControllerGPIO2 | GPIO Supported By Controller (GPIO 2)
Public property | GPIOSupportedByControllerGPIO3 | GPIO Supported By Controller (GPIO 3)
Public property | GPIOSupportedByControllerGPIO4 | GPIO Supported By Controller (GPIO 4)
Public property | GPIOSupportedByControllerGPIO5 | GPIO Supported By Controller (GPIO 5)
Public property | GPIOSupportedByControllerGPIO6 | GPIO Supported By Controller (GPIO 6)
Public property | LocalTempCoolingActionFan1 | Local Temp Cooling Action (Fan 1)
Public property | LocalTempCoolingActionFan2 | Local Temp Cooling Action (Fan 2)
Public property | LocalTemperatureOffset | Local Temperature Offset (unit: °C)
Public property | LocalTempFaultActionAlarmSpeedLow | Local Temp Fault Action (Alarm Speed Low)
Public property | LocalTempFaultActionAlarmSpeedOnOT | Local Temp Fault Action (Alarm Speed On OT)
Public property | LocalTempFaultActionAlarmSpeedOnUT | Local Temp Fault Action (Alarm Speed On UT)
Public property | LocalTempFaultActionAssertCFAULTOnOT | Local Temp Fault Action (Assert CFAULT On OT)
Public property | LocalTempFaultActionAssertCFAULTOnUT | Local Temp Fault Action (Assert CFAULT On UT)
Public property | LocalTempFaultActionINTOnOT | Local Temp Fault Action (INT On OT)
Public property | LocalTempFaultActionINTOnUT | Local Temp Fault Action (INT On UT)
Public property | LocalTempFaultActionLatchTempFault | Local Temp Fault Action (Latch Temp Fault)
Public property | LocalTempHighLimit | Local Temp High Limit (unit: °C)
Public property | LocalTempLowLimit | Local Temp Low Limit (unit: °C)
Public property | LocalTempTHYST | Local Temp T_HYST (unit: °C)
Public property | LocalTempTMIN | Local Temp T_MIN (unit: °C)
Public property | LocalTempTRANGE | Local Temp T_RANGE (unit: °C)
Public property | LocalTempValue | Local Temp Value (unit: °C)
Public property | MajorRevisionCode | Major Revision Code
Public property | ManufacturerID | Manufacturer ID
Public property | MinorRevisionCode | Minor Revision Code
Public property | Remote1TempCoolingActionFan1 | Remote 1 Temp Cooling Action (Fan 1)
Public property | Remote1TempCoolingActionFan2 | Remote 1 Temp Cooling Action (Fan 2)
Public property | Remote1TemperatureOffset | Remote 1 Temperature Offset (unit: °C)
Public property | Remote1TempFaultActionAlarmSpeedLow | Remote 1 Temp Fault Action (Alarm Speed Low)
Public property | Remote1TempFaultActionAlarmSpeedOnOT | Remote 1 Temp Fault Action (Alarm Speed On OT)
Public property | Remote1TempFaultActionAlarmSpeedOnUT | Remote 1 Temp Fault Action (Alarm Speed On UT)
Public property | Remote1TempFaultActionAssertCFAULTOnOT | Remote 1 Temp Fault Action (Assert CFAULT On OT)
Public property | Remote1TempFaultActionAssertCFAULTOnUT | Remote 1 Temp Fault Action (Assert CFAULT On UT)
Public property | Remote1TempFaultActionINTOnOT | Remote 1 Temp Fault Action (INT On OT)
Public property | Remote1TempFaultActionINTOnUT | Remote 1 Temp Fault Action (INT On UT)
Public property | Remote1TempFaultActionLatchTempFault | Remote 1 Temp Fault Action (Latch Temp Fault)
Public property | Remote1TempHighLimit | Remote 1 Temp High Limit (unit: °C)
Public property | Remote1TempLowLimit | Remote 1 Temp Low Limit (unit: °C)
Public property | Remote1TempTHYST | Remote 1 Temp T_HYST (unit: °C)
Public property | Remote1TempTMIN | Remote 1 Temp T_MIN (unit: °C)
Public property | Remote1TempTRANGE | Remote 1 Temp T_RANGE (unit: °C)
Public property | Remote1TempValue | Remote 1 Temp Value (unit: °C)
Public property | Remote2TempCoolingActionFan1 | Remote 2 Temp Cooling Action (Fan 1)
Public property | Remote2TempCoolingActionFan2 | Remote 2 Temp Cooling Action (Fan 2)
Public property | Remote2TemperatureOffset | Remote 2 Temperature Offset (unit: °C)
Public property | Remote2TempFaultActionAlarmSpeedLow | Remote 2 Temp Fault Action (Alarm Speed Low)
Public property | Remote2TempFaultActionAlarmSpeedOnOT | Remote 2 Temp Fault Action (Alarm Speed On OT)
Public property | Remote2TempFaultActionAlarmSpeedOnUT | Remote 2 Temp Fault Action (Alarm Speed On UT)
Public property | Remote2TempFaultActionAssertCFAULTOnOT | Remote 2 Temp Fault Action (Assert CFAULT On OT)
Public property | Remote2TempFaultActionAssertCFAULTOnUT | Remote 2 Temp Fault Action (Assert CFAULT On UT)
Public property | Remote2TempFaultActionINTOnOT | Remote 2 Temp Fault Action (INT On OT)
Public property | Remote2TempFaultActionINTOnUT | Remote 2 Temp Fault Action (INT On UT)
Public property | Remote2TempFaultActionLatchTempFault | Remote 2 Temp Fault Action (Latch Temp Fault)
Public property | Remote2TempHighLimit | Remote 2 Temp High Limit (unit: °C)
Public property | Remote2TempLowLimit | Remote 2 Temp Low Limit (unit: °C)
Public property | Remote2TempTHYST | Remote 2 Temp T_HYST (unit: °C)
Public property | Remote2TempTMIN | Remote 2 Temp T_MIN (unit: °C)
Public property | Remote2TempTRANGE | Remote 2 Temp T_RANGE (unit: °C)
Public property | Remote2TempValue | Remote 2 Temp Value (unit: °C)
Public property | SetFanXAlarmSpeedFan1 | Set Fan x Alarm Speed (Fan 1)
Public property | SetFanXAlarmSpeedFan2 | Set Fan x Alarm Speed (Fan 2)
Public property | SetFanXFullSpeedFan1 | Set Fan x Full Speed (Fan 1)
Public property | SetFanXFullSpeedFan2 | Set Fan x Full Speed (Fan 2)
Public property | SetFanXHotPlugSpeedFan1 | Set Fan x Hot-Plug Speed (Fan 1)
Public property | SetFanXHotPlugSpeedFan2 | Set Fan x Hot-Plug Speed (Fan 2)
Public property | StatusCFAULTIn | Status (CFAULT_in)
Public property | StatusCFAULTOut | Status (CFAULT_out)
Public property | StatusGPIOAINEvent | Status (GPIO/AIN Event)
Public property | StatusHotPlugFanFault | Status (Hot Plug/Fan Fault)
Public property | StatusInAlarmSpeed | Status (In Alarm_speed)
Public property | StatusInHotPlugSpeed | Status (In Hot-Plug Speed)
Public property | StatusINT | Status (INT)
Public property | StatusThermalEvent | Status (Thermal Event)
Public property | SWReset | S/W Reset
Public property | TempDevicesInstalledLocalTemp | Temp Devices Installed (Local Temp)
Public property | TempDevicesInstalledRemote1Temp | Temp Devices Installed (Remote 1 Temp)
Public property | TempDevicesInstalledRemote2Temp | Temp Devices Installed (Remote 2 Temp)
Top
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN0BehaviourAlarmBelowLow Property

IRD

Adm1029AIN0BehaviourAlarmBelowLow Property

AIN0 Behaviour (Alarm Below Low)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinBehaviourBit3Type AIN0BehaviourAlarmBelowLow { get; set; }
Public Property AIN0BehaviourAlarmBelowLow As Adm1029AinBehaviourBit3Type
    Get
    Set
public:
property Adm1029AinBehaviourBit3Type AIN0BehaviourAlarmBelowLow {
    Adm1029AinBehaviourBit3Type get ();
    void set (Adm1029AinBehaviourBit3Type value);
}
member AIN0BehaviourAlarmBelowLow : Adm1029AinBehaviourBit3Type with get, set

Property Value

Type: Adm1029AinBehaviourBit3Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN0BehaviourAlarmSpeedOnHILIM Property

IRD

Adm1029AIN0BehaviourAlarmSpeedOnHILIM Property

AIN0 Behaviour (Alarm Speed On HI_LIM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinBehaviourBit1Type AIN0BehaviourAlarmSpeedOnHILIM { get; set; }
Public Property AIN0BehaviourAlarmSpeedOnHILIM As Adm1029AinBehaviourBit1Type
    Get
    Set
public:
property Adm1029AinBehaviourBit1Type AIN0BehaviourAlarmSpeedOnHILIM {
    Adm1029AinBehaviourBit1Type get ();
    void set (Adm1029AinBehaviourBit1Type value);
}
member AIN0BehaviourAlarmSpeedOnHILIM : Adm1029AinBehaviourBit1Type with get, set

Property Value

Type: Adm1029AinBehaviourBit1Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN0BehaviourAlarmSpeedOnLOLIM Property

IRD

Adm1029AIN0BehaviourAlarmSpeedOnLOLIM Property

AIN0 Behaviour (Alarm Speed On LO_LIM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinBehaviourBit5Type AIN0BehaviourAlarmSpeedOnLOLIM { get; set; }
Public Property AIN0BehaviourAlarmSpeedOnLOLIM As Adm1029AinBehaviourBit5Type
    Get
    Set
public:
property Adm1029AinBehaviourBit5Type AIN0BehaviourAlarmSpeedOnLOLIM {
    Adm1029AinBehaviourBit5Type get ();
    void set (Adm1029AinBehaviourBit5Type value);
}
member AIN0BehaviourAlarmSpeedOnLOLIM : Adm1029AinBehaviourBit5Type with get, set

Property Value

Type: Adm1029AinBehaviourBit5Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN0BehaviourAssertCFAULTOnHILIM Property

IRD

Adm1029AIN0BehaviourAssertCFAULTOnHILIM Property

AIN0 Behaviour (Assert CFAULT On HI_LIM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinBehaviourBit0Type AIN0BehaviourAssertCFAULTOnHILIM { get; set; }
Public Property AIN0BehaviourAssertCFAULTOnHILIM As Adm1029AinBehaviourBit0Type
    Get
    Set
public:
property Adm1029AinBehaviourBit0Type AIN0BehaviourAssertCFAULTOnHILIM {
    Adm1029AinBehaviourBit0Type get ();
    void set (Adm1029AinBehaviourBit0Type value);
}
member AIN0BehaviourAssertCFAULTOnHILIM : Adm1029AinBehaviourBit0Type with get, set

Property Value

Type: Adm1029AinBehaviourBit0Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN0BehaviourAssertCFAULTOnLOLIM Property

IRD

Adm1029AIN0BehaviourAssertCFAULTOnLOLIM Property

AIN0 Behaviour (Assert CFAULT On LO_LIM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinBehaviourBit4Type AIN0BehaviourAssertCFAULTOnLOLIM { get; set; }
Public Property AIN0BehaviourAssertCFAULTOnLOLIM As Adm1029AinBehaviourBit4Type
    Get
    Set
public:
property Adm1029AinBehaviourBit4Type AIN0BehaviourAssertCFAULTOnLOLIM {
    Adm1029AinBehaviourBit4Type get ();
    void set (Adm1029AinBehaviourBit4Type value);
}
member AIN0BehaviourAssertCFAULTOnLOLIM : Adm1029AinBehaviourBit4Type with get, set

Property Value

Type: Adm1029AinBehaviourBit4Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN0BehaviourINTOnHILIM Property

IRD

Adm1029AIN0BehaviourINTOnHILIM Property

AIN0 Behaviour (INT On HI_LIM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinBehaviourBit2Type AIN0BehaviourINTOnHILIM { get; set; }
Public Property AIN0BehaviourINTOnHILIM As Adm1029AinBehaviourBit2Type
    Get
    Set
public:
property Adm1029AinBehaviourBit2Type AIN0BehaviourINTOnHILIM {
    Adm1029AinBehaviourBit2Type get ();
    void set (Adm1029AinBehaviourBit2Type value);
}
member AIN0BehaviourINTOnHILIM : Adm1029AinBehaviourBit2Type with get, set

Property Value

Type: Adm1029AinBehaviourBit2Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN0BehaviourINTOnLOLIM Property

IRD

Adm1029AIN0BehaviourINTOnLOLIM Property

AIN0 Behaviour (INT On LO_LIM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinBehaviourBit6Type AIN0BehaviourINTOnLOLIM { get; set; }
Public Property AIN0BehaviourINTOnLOLIM As Adm1029AinBehaviourBit6Type
    Get
    Set
public:
property Adm1029AinBehaviourBit6Type AIN0BehaviourINTOnLOLIM {
    Adm1029AinBehaviourBit6Type get ();
    void set (Adm1029AinBehaviourBit6Type value);
}
member AIN0BehaviourINTOnLOLIM : Adm1029AinBehaviourBit6Type with get, set

Property Value

Type: Adm1029AinBehaviourBit6Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN0BehaviourLatchAINFault Property

IRD

Adm1029AIN0BehaviourLatchAINFault Property

AIN0 Behaviour (Latch AIN Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinBehaviourBit7Type AIN0BehaviourLatchAINFault { get; set; }
Public Property AIN0BehaviourLatchAINFault As Adm1029AinBehaviourBit7Type
    Get
    Set
public:
property Adm1029AinBehaviourBit7Type AIN0BehaviourLatchAINFault {
    Adm1029AinBehaviourBit7Type get ();
    void set (Adm1029AinBehaviourBit7Type value);
}
member AIN0BehaviourLatchAINFault : Adm1029AinBehaviourBit7Type with get, set

Property Value

Type: Adm1029AinBehaviourBit7Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN0EventMaskFan1 Property

IRD

Adm1029AIN0EventMaskFan1 Property

AIN0 Event Mask (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinEventMaskType AIN0EventMaskFan1 { get; set; }
Public Property AIN0EventMaskFan1 As Adm1029AinEventMaskType
    Get
    Set
public:
property Adm1029AinEventMaskType AIN0EventMaskFan1 {
    Adm1029AinEventMaskType get ();
    void set (Adm1029AinEventMaskType value);
}
member AIN0EventMaskFan1 : Adm1029AinEventMaskType with get, set

Property Value

Type: Adm1029AinEventMaskType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN0EventMaskFan2 Property

IRD

Adm1029AIN0EventMaskFan2 Property

AIN0 Event Mask (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinEventMaskType AIN0EventMaskFan2 { get; set; }
Public Property AIN0EventMaskFan2 As Adm1029AinEventMaskType
    Get
    Set
public:
property Adm1029AinEventMaskType AIN0EventMaskFan2 {
    Adm1029AinEventMaskType get ();
    void set (Adm1029AinEventMaskType value);
}
member AIN0EventMaskFan2 : Adm1029AinEventMaskType with get, set

Property Value

Type: Adm1029AinEventMaskType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN0HighLimit Property

IRD

Adm1029AIN0HighLimit Property

AIN0 High Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN0HighLimit { get; set; }
Public Property AIN0HighLimit As Byte
    Get
    Set
public:
property unsigned char AIN0HighLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN0HighLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN0LowLimit Property

IRD

Adm1029AIN0LowLimit Property

AIN0 Low Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN0LowLimit { get; set; }
Public Property AIN0LowLimit As Byte
    Get
    Set
public:
property unsigned char AIN0LowLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN0LowLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN0MeasuredValue Property

IRD

Adm1029AIN0MeasuredValue Property

AIN0 Measured Value

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN0MeasuredValue { get; }
Public ReadOnly Property AIN0MeasuredValue As Byte
    Get
public:
property unsigned char AIN0MeasuredValue {
    unsigned char get ();
}
member AIN0MeasuredValue : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN1BehaviourAlarmBelowLow Property

IRD

Adm1029AIN1BehaviourAlarmBelowLow Property

AIN1 Behaviour (Alarm Below Low)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinBehaviourBit3Type AIN1BehaviourAlarmBelowLow { get; set; }
Public Property AIN1BehaviourAlarmBelowLow As Adm1029AinBehaviourBit3Type
    Get
    Set
public:
property Adm1029AinBehaviourBit3Type AIN1BehaviourAlarmBelowLow {
    Adm1029AinBehaviourBit3Type get ();
    void set (Adm1029AinBehaviourBit3Type value);
}
member AIN1BehaviourAlarmBelowLow : Adm1029AinBehaviourBit3Type with get, set

Property Value

Type: Adm1029AinBehaviourBit3Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN1BehaviourAlarmSpeedOnHILIM Property

IRD

Adm1029AIN1BehaviourAlarmSpeedOnHILIM Property

AIN1 Behaviour (Alarm Speed On HI_LIM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinBehaviourBit1Type AIN1BehaviourAlarmSpeedOnHILIM { get; set; }
Public Property AIN1BehaviourAlarmSpeedOnHILIM As Adm1029AinBehaviourBit1Type
    Get
    Set
public:
property Adm1029AinBehaviourBit1Type AIN1BehaviourAlarmSpeedOnHILIM {
    Adm1029AinBehaviourBit1Type get ();
    void set (Adm1029AinBehaviourBit1Type value);
}
member AIN1BehaviourAlarmSpeedOnHILIM : Adm1029AinBehaviourBit1Type with get, set

Property Value

Type: Adm1029AinBehaviourBit1Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN1BehaviourAlarmSpeedOnLOLIM Property

IRD

Adm1029AIN1BehaviourAlarmSpeedOnLOLIM Property

AIN1 Behaviour (Alarm Speed On LO_LIM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinBehaviourBit5Type AIN1BehaviourAlarmSpeedOnLOLIM { get; set; }
Public Property AIN1BehaviourAlarmSpeedOnLOLIM As Adm1029AinBehaviourBit5Type
    Get
    Set
public:
property Adm1029AinBehaviourBit5Type AIN1BehaviourAlarmSpeedOnLOLIM {
    Adm1029AinBehaviourBit5Type get ();
    void set (Adm1029AinBehaviourBit5Type value);
}
member AIN1BehaviourAlarmSpeedOnLOLIM : Adm1029AinBehaviourBit5Type with get, set

Property Value

Type: Adm1029AinBehaviourBit5Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN1BehaviourAssertCFAULTOnHILIM Property

IRD

Adm1029AIN1BehaviourAssertCFAULTOnHILIM Property

AIN1 Behaviour (Assert CFAULT On HI_LIM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinBehaviourBit0Type AIN1BehaviourAssertCFAULTOnHILIM { get; set; }
Public Property AIN1BehaviourAssertCFAULTOnHILIM As Adm1029AinBehaviourBit0Type
    Get
    Set
public:
property Adm1029AinBehaviourBit0Type AIN1BehaviourAssertCFAULTOnHILIM {
    Adm1029AinBehaviourBit0Type get ();
    void set (Adm1029AinBehaviourBit0Type value);
}
member AIN1BehaviourAssertCFAULTOnHILIM : Adm1029AinBehaviourBit0Type with get, set

Property Value

Type: Adm1029AinBehaviourBit0Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN1BehaviourAssertCFAULTOnLOLIM Property

IRD

Adm1029AIN1BehaviourAssertCFAULTOnLOLIM Property

AIN1 Behaviour (Assert CFAULT On LO_LIM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinBehaviourBit4Type AIN1BehaviourAssertCFAULTOnLOLIM { get; set; }
Public Property AIN1BehaviourAssertCFAULTOnLOLIM As Adm1029AinBehaviourBit4Type
    Get
    Set
public:
property Adm1029AinBehaviourBit4Type AIN1BehaviourAssertCFAULTOnLOLIM {
    Adm1029AinBehaviourBit4Type get ();
    void set (Adm1029AinBehaviourBit4Type value);
}
member AIN1BehaviourAssertCFAULTOnLOLIM : Adm1029AinBehaviourBit4Type with get, set

Property Value

Type: Adm1029AinBehaviourBit4Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN1BehaviourINTOnHILIM Property

IRD

Adm1029AIN1BehaviourINTOnHILIM Property

AIN1 Behaviour (INT On HI_LIM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinBehaviourBit2Type AIN1BehaviourINTOnHILIM { get; set; }
Public Property AIN1BehaviourINTOnHILIM As Adm1029AinBehaviourBit2Type
    Get
    Set
public:
property Adm1029AinBehaviourBit2Type AIN1BehaviourINTOnHILIM {
    Adm1029AinBehaviourBit2Type get ();
    void set (Adm1029AinBehaviourBit2Type value);
}
member AIN1BehaviourINTOnHILIM : Adm1029AinBehaviourBit2Type with get, set

Property Value

Type: Adm1029AinBehaviourBit2Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN1BehaviourINTOnLOLIM Property

IRD

Adm1029AIN1BehaviourINTOnLOLIM Property

AIN1 Behaviour (INT On LO_LIM)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinBehaviourBit6Type AIN1BehaviourINTOnLOLIM { get; set; }
Public Property AIN1BehaviourINTOnLOLIM As Adm1029AinBehaviourBit6Type
    Get
    Set
public:
property Adm1029AinBehaviourBit6Type AIN1BehaviourINTOnLOLIM {
    Adm1029AinBehaviourBit6Type get ();
    void set (Adm1029AinBehaviourBit6Type value);
}
member AIN1BehaviourINTOnLOLIM : Adm1029AinBehaviourBit6Type with get, set

Property Value

Type: Adm1029AinBehaviourBit6Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN1BehaviourLatchAINFault Property

IRD

Adm1029AIN1BehaviourLatchAINFault Property

AIN1 Behaviour (Latch AIN Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinBehaviourBit7Type AIN1BehaviourLatchAINFault { get; set; }
Public Property AIN1BehaviourLatchAINFault As Adm1029AinBehaviourBit7Type
    Get
    Set
public:
property Adm1029AinBehaviourBit7Type AIN1BehaviourLatchAINFault {
    Adm1029AinBehaviourBit7Type get ();
    void set (Adm1029AinBehaviourBit7Type value);
}
member AIN1BehaviourLatchAINFault : Adm1029AinBehaviourBit7Type with get, set

Property Value

Type: Adm1029AinBehaviourBit7Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN1EventMaskFan1 Property

IRD

Adm1029AIN1EventMaskFan1 Property

AIN1 Event Mask (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinEventMaskType AIN1EventMaskFan1 { get; set; }
Public Property AIN1EventMaskFan1 As Adm1029AinEventMaskType
    Get
    Set
public:
property Adm1029AinEventMaskType AIN1EventMaskFan1 {
    Adm1029AinEventMaskType get ();
    void set (Adm1029AinEventMaskType value);
}
member AIN1EventMaskFan1 : Adm1029AinEventMaskType with get, set

Property Value

Type: Adm1029AinEventMaskType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN1EventMaskFan2 Property

IRD

Adm1029AIN1EventMaskFan2 Property

AIN1 Event Mask (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029AinEventMaskType AIN1EventMaskFan2 { get; set; }
Public Property AIN1EventMaskFan2 As Adm1029AinEventMaskType
    Get
    Set
public:
property Adm1029AinEventMaskType AIN1EventMaskFan2 {
    Adm1029AinEventMaskType get ();
    void set (Adm1029AinEventMaskType value);
}
member AIN1EventMaskFan2 : Adm1029AinEventMaskType with get, set

Property Value

Type: Adm1029AinEventMaskType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN1HighLimit Property

IRD

Adm1029AIN1HighLimit Property

AIN1 High Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN1HighLimit { get; set; }
Public Property AIN1HighLimit As Byte
    Get
    Set
public:
property unsigned char AIN1HighLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN1HighLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN1LowLimit Property

IRD

Adm1029AIN1LowLimit Property

AIN1 Low Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN1LowLimit { get; set; }
Public Property AIN1LowLimit As Byte
    Get
    Set
public:
property unsigned char AIN1LowLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN1LowLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AIN1MeasuredValue Property

IRD

Adm1029AIN1MeasuredValue Property

AIN1 Measured Value

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN1MeasuredValue { get; }
Public ReadOnly Property AIN1MeasuredValue As Byte
    Get
public:
property unsigned char AIN1MeasuredValue {
    unsigned char get ();
}
member AIN1MeasuredValue : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AutoFlush Property

IRD

Adm1029AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.ConfigARADisable Property

IRD

Adm1029ConfigARADisable Property

Config (ARA Disable)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029ConfigAraType ConfigARADisable { get; set; }
Public Property ConfigARADisable As Adm1029ConfigAraType
    Get
    Set
public:
property Adm1029ConfigAraType ConfigARADisable {
    Adm1029ConfigAraType get ();
    void set (Adm1029ConfigAraType value);
}
member ConfigARADisable : Adm1029ConfigAraType with get, set

Property Value

Type: Adm1029ConfigAraType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.ConfigForceCFAULT Property

IRD

Adm1029ConfigForceCFAULT Property

Config (Force CFAULT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029ConfigForceCfaultType ConfigForceCFAULT { get; set; }
Public Property ConfigForceCFAULT As Adm1029ConfigForceCfaultType
    Get
    Set
public:
property Adm1029ConfigForceCfaultType ConfigForceCFAULT {
    Adm1029ConfigForceCfaultType get ();
    void set (Adm1029ConfigForceCfaultType value);
}
member ConfigForceCFAULT : Adm1029ConfigForceCfaultType with get, set

Property Value

Type: Adm1029ConfigForceCfaultType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.ConfigForceINT Property

IRD

Adm1029ConfigForceINT Property

Config (Force INT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029ConfigForceIntType ConfigForceINT { get; set; }
Public Property ConfigForceINT As Adm1029ConfigForceIntType
    Get
    Set
public:
property Adm1029ConfigForceIntType ConfigForceINT {
    Adm1029ConfigForceIntType get ();
    void set (Adm1029ConfigForceIntType value);
}
member ConfigForceINT : Adm1029ConfigForceIntType with get, set

Property Value

Type: Adm1029ConfigForceIntType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.ConfigGlobalINTMask Property

IRD

Adm1029ConfigGlobalINTMask Property

Config (Global INT Mask)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029ConfigIntType ConfigGlobalINTMask { get; set; }
Public Property ConfigGlobalINTMask As Adm1029ConfigIntType
    Get
    Set
public:
property Adm1029ConfigIntType ConfigGlobalINTMask {
    Adm1029ConfigIntType get ();
    void set (Adm1029ConfigIntType value);
}
member ConfigGlobalINTMask : Adm1029ConfigIntType with get, set

Property Value

Type: Adm1029ConfigIntType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.ConfigInstall Property

IRD

Adm1029ConfigInstall Property

Config (Install)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029ConfigInstallType ConfigInstall { get; set; }
Public Property ConfigInstall As Adm1029ConfigInstallType
    Get
    Set
public:
property Adm1029ConfigInstallType ConfigInstall {
    Adm1029ConfigInstallType get ();
    void set (Adm1029ConfigInstallType value);
}
member ConfigInstall : Adm1029ConfigInstallType with get, set

Property Value

Type: Adm1029ConfigInstallType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.ConfigINTPolarity Property

IRD

Adm1029ConfigINTPolarity Property

Config (INT Polarity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029ConfigIntPolarityType ConfigINTPolarity { get; set; }
Public Property ConfigINTPolarity As Adm1029ConfigIntPolarityType
    Get
    Set
public:
property Adm1029ConfigIntPolarityType ConfigINTPolarity {
    Adm1029ConfigIntPolarityType get ();
    void set (Adm1029ConfigIntPolarityType value);
}
member ConfigINTPolarity : Adm1029ConfigIntPolarityType with get, set

Property Value

Type: Adm1029ConfigIntPolarityType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.ConfigPerformFreeWheelTest Property

IRD

Adm1029ConfigPerformFreeWheelTest Property

Config (Perform Free-Wheel Test)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029ConfigFreeWheelType ConfigPerformFreeWheelTest { get; set; }
Public Property ConfigPerformFreeWheelTest As Adm1029ConfigFreeWheelType
    Get
    Set
public:
property Adm1029ConfigFreeWheelType ConfigPerformFreeWheelTest {
    Adm1029ConfigFreeWheelType get ();
    void set (Adm1029ConfigFreeWheelType value);
}
member ConfigPerformFreeWheelTest : Adm1029ConfigFreeWheelType with get, set

Property Value

Type: Adm1029ConfigFreeWheelType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.ConfigStartMonitoring Property

IRD

Adm1029ConfigStartMonitoring Property

Config (Start Monitoring)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029ConfigStartMonitoringType ConfigStartMonitoring { get; set; }
Public Property ConfigStartMonitoring As Adm1029ConfigStartMonitoringType
    Get
    Set
public:
property Adm1029ConfigStartMonitoringType ConfigStartMonitoring {
    Adm1029ConfigStartMonitoringType get ();
    void set (Adm1029ConfigStartMonitoringType value);
}
member ConfigStartMonitoring : Adm1029ConfigStartMonitoringType with get, set

Property Value

Type: Adm1029ConfigStartMonitoringType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1AlarmSpeed Property

IRD

Adm1029Fan1AlarmSpeed Property

Fan 1 Alarm Speed (unit: %)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanSpeedType Fan1AlarmSpeed { get; set; }
Public Property Fan1AlarmSpeed As Adm1029FanSpeedType
    Get
    Set
public:
property Adm1029FanSpeedType Fan1AlarmSpeed {
    Adm1029FanSpeedType get ();
    void set (Adm1029FanSpeedType value);
}
member Fan1AlarmSpeed : Adm1029FanSpeedType with get, set

Property Value

Type: Adm1029FanSpeedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1ConfigurationHotPlugSpeed Property

IRD

Adm1029Fan1ConfigurationHotPlugSpeed Property

Fan 1 Configuration (Hot-Plug Speed) (unit: %)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanSpeedType Fan1ConfigurationHotPlugSpeed { get; set; }
Public Property Fan1ConfigurationHotPlugSpeed As Adm1029FanSpeedType
    Get
    Set
public:
property Adm1029FanSpeedType Fan1ConfigurationHotPlugSpeed {
    Adm1029FanSpeedType get ();
    void set (Adm1029FanSpeedType value);
}
member Fan1ConfigurationHotPlugSpeed : Adm1029FanSpeedType with get, set

Property Value

Type: Adm1029FanSpeedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1ConfigurationOscillatorFrequency Property

IRD

Adm1029Fan1ConfigurationOscillatorFrequency Property

Fan 1 Configuration (Oscillator Frequency)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanConfigOscillatorType Fan1ConfigurationOscillatorFrequency { get; set; }
Public Property Fan1ConfigurationOscillatorFrequency As Adm1029FanConfigOscillatorType
    Get
    Set
public:
property Adm1029FanConfigOscillatorType Fan1ConfigurationOscillatorFrequency {
    Adm1029FanConfigOscillatorType get ();
    void set (Adm1029FanConfigOscillatorType value);
}
member Fan1ConfigurationOscillatorFrequency : Adm1029FanConfigOscillatorType with get, set

Property Value

Type: Adm1029FanConfigOscillatorType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1ConfigurationPWMFrequency Property

IRD

Adm1029Fan1ConfigurationPWMFrequency Property

Fan 1 Configuration (PWM Frequency) (unit: Hz)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanConfigPwmType Fan1ConfigurationPWMFrequency { get; set; }
Public Property Fan1ConfigurationPWMFrequency As Adm1029FanConfigPwmType
    Get
    Set
public:
property Adm1029FanConfigPwmType Fan1ConfigurationPWMFrequency {
    Adm1029FanConfigPwmType get ();
    void set (Adm1029FanConfigPwmType value);
}
member Fan1ConfigurationPWMFrequency : Adm1029FanConfigPwmType with get, set

Property Value

Type: Adm1029FanConfigPwmType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1EventMaskFan1 Property

IRD

Adm1029Fan1EventMaskFan1 Property

Fan 1 Event Mask (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanEventMask1Type Fan1EventMaskFan1 { get; set; }
Public Property Fan1EventMaskFan1 As Adm1029FanEventMask1Type
    Get
    Set
public:
property Adm1029FanEventMask1Type Fan1EventMaskFan1 {
    Adm1029FanEventMask1Type get ();
    void set (Adm1029FanEventMask1Type value);
}
member Fan1EventMaskFan1 : Adm1029FanEventMask1Type with get, set

Property Value

Type: Adm1029FanEventMask1Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1EventMaskFan2 Property

IRD

Adm1029Fan1EventMaskFan2 Property

Fan 1 Event Mask (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanEventMask2Type Fan1EventMaskFan2 { get; set; }
Public Property Fan1EventMaskFan2 As Adm1029FanEventMask2Type
    Get
    Set
public:
property Adm1029FanEventMask2Type Fan1EventMaskFan2 {
    Adm1029FanEventMask2Type get ();
    void set (Adm1029FanEventMask2Type value);
}
member Fan1EventMaskFan2 : Adm1029FanEventMask2Type with get, set

Property Value

Type: Adm1029FanEventMask2Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1FaultActionAlarmOnCFAULT Property

IRD

Adm1029Fan1FaultActionAlarmOnCFAULT Property

Fan 1 Fault Action (Alarm On CFAULT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FaultAction7Type Fan1FaultActionAlarmOnCFAULT { get; set; }
Public Property Fan1FaultActionAlarmOnCFAULT As Adm1029FaultAction7Type
    Get
    Set
public:
property Adm1029FaultAction7Type Fan1FaultActionAlarmOnCFAULT {
    Adm1029FaultAction7Type get ();
    void set (Adm1029FaultAction7Type value);
}
member Fan1FaultActionAlarmOnCFAULT : Adm1029FaultAction7Type with get, set

Property Value

Type: Adm1029FaultAction7Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1FaultActionAssertCFAULTOnFault Property

IRD

Adm1029Fan1FaultActionAssertCFAULTOnFault Property

Fan 1 Fault Action (Assert CFAULT On Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FaultAction0Type Fan1FaultActionAssertCFAULTOnFault { get; set; }
Public Property Fan1FaultActionAssertCFAULTOnFault As Adm1029FaultAction0Type
    Get
    Set
public:
property Adm1029FaultAction0Type Fan1FaultActionAssertCFAULTOnFault {
    Adm1029FaultAction0Type get ();
    void set (Adm1029FaultAction0Type value);
}
member Fan1FaultActionAssertCFAULTOnFault : Adm1029FaultAction0Type with get, set

Property Value

Type: Adm1029FaultAction0Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1FaultActionAssertCFAULTOnHotUnplug Property

IRD

Adm1029Fan1FaultActionAssertCFAULTOnHotUnplug Property

Fan 1 Fault Action (Assert CFAULT On Hot Unplug)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FaultAction2Type Fan1FaultActionAssertCFAULTOnHotUnplug { get; set; }
Public Property Fan1FaultActionAssertCFAULTOnHotUnplug As Adm1029FaultAction2Type
    Get
    Set
public:
property Adm1029FaultAction2Type Fan1FaultActionAssertCFAULTOnHotUnplug {
    Adm1029FaultAction2Type get ();
    void set (Adm1029FaultAction2Type value);
}
member Fan1FaultActionAssertCFAULTOnHotUnplug : Adm1029FaultAction2Type with get, set

Property Value

Type: Adm1029FaultAction2Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1FaultActionAssertINTOnFault Property

IRD

Adm1029Fan1FaultActionAssertINTOnFault Property

Fan 1 Fault Action (Assert INT On Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FaultAction1Type Fan1FaultActionAssertINTOnFault { get; set; }
Public Property Fan1FaultActionAssertINTOnFault As Adm1029FaultAction1Type
    Get
    Set
public:
property Adm1029FaultAction1Type Fan1FaultActionAssertINTOnFault {
    Adm1029FaultAction1Type get ();
    void set (Adm1029FaultAction1Type value);
}
member Fan1FaultActionAssertINTOnFault : Adm1029FaultAction1Type with get, set

Property Value

Type: Adm1029FaultAction1Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1FaultActionAssertINTOnHotUnplug Property

IRD

Adm1029Fan1FaultActionAssertINTOnHotUnplug Property

Fan 1 Fault Action (Assert INT On Hot Unplug)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FaultAction3Type Fan1FaultActionAssertINTOnHotUnplug { get; set; }
Public Property Fan1FaultActionAssertINTOnHotUnplug As Adm1029FaultAction3Type
    Get
    Set
public:
property Adm1029FaultAction3Type Fan1FaultActionAssertINTOnHotUnplug {
    Adm1029FaultAction3Type get ();
    void set (Adm1029FaultAction3Type value);
}
member Fan1FaultActionAssertINTOnHotUnplug : Adm1029FaultAction3Type with get, set

Property Value

Type: Adm1029FaultAction3Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1FaultActionDriveFaultOnFaultL Property

IRD

Adm1029Fan1FaultActionDriveFaultOnFaultL Property

Fan 1 Fault Action (Drive Fault On Fault_L)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FaultAction5Type Fan1FaultActionDriveFaultOnFaultL { get; set; }
Public Property Fan1FaultActionDriveFaultOnFaultL As Adm1029FaultAction5Type
    Get
    Set
public:
property Adm1029FaultAction5Type Fan1FaultActionDriveFaultOnFaultL {
    Adm1029FaultAction5Type get ();
    void set (Adm1029FaultAction5Type value);
}
member Fan1FaultActionDriveFaultOnFaultL : Adm1029FaultAction5Type with get, set

Property Value

Type: Adm1029FaultAction5Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1FaultActionHotPlugSpeedOnCFAULTIn Property

IRD

Adm1029Fan1FaultActionHotPlugSpeedOnCFAULTIn Property

Fan 1 Fault Action (Hot-Plug Speed On CFAULT In)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FaultAction6Type Fan1FaultActionHotPlugSpeedOnCFAULTIn { get; set; }
Public Property Fan1FaultActionHotPlugSpeedOnCFAULTIn As Adm1029FaultAction6Type
    Get
    Set
public:
property Adm1029FaultAction6Type Fan1FaultActionHotPlugSpeedOnCFAULTIn {
    Adm1029FaultAction6Type get ();
    void set (Adm1029FaultAction6Type value);
}
member Fan1FaultActionHotPlugSpeedOnCFAULTIn : Adm1029FaultAction6Type with get, set

Property Value

Type: Adm1029FaultAction6Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1FaultActionThermalOverrideInSleep Property

IRD

Adm1029Fan1FaultActionThermalOverrideInSleep Property

Fan 1 Fault Action (Thermal Override In Sleep)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FaultAction4Type Fan1FaultActionThermalOverrideInSleep { get; set; }
Public Property Fan1FaultActionThermalOverrideInSleep As Adm1029FaultAction4Type
    Get
    Set
public:
property Adm1029FaultAction4Type Fan1FaultActionThermalOverrideInSleep {
    Adm1029FaultAction4Type get ();
    void set (Adm1029FaultAction4Type value);
}
member Fan1FaultActionThermalOverrideInSleep : Adm1029FaultAction4Type with get, set

Property Value

Type: Adm1029FaultAction4Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1MinimumSpeed Property

IRD

Adm1029Fan1MinimumSpeed Property

Fan 1 Minimum Speed (unit: %)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanSpeedType Fan1MinimumSpeed { get; set; }
Public Property Fan1MinimumSpeed As Adm1029FanSpeedType
    Get
    Set
public:
property Adm1029FanSpeedType Fan1MinimumSpeed {
    Adm1029FanSpeedType get ();
    void set (Adm1029FanSpeedType value);
}
member Fan1MinimumSpeed : Adm1029FanSpeedType with get, set

Property Value

Type: Adm1029FanSpeedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1StatusFault Property

IRD

Adm1029Fan1StatusFault Property

Fan 1 Status (Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanStatusFaultType Fan1StatusFault { get; }
Public ReadOnly Property Fan1StatusFault As Adm1029FanStatusFaultType
    Get
public:
property Adm1029FanStatusFaultType Fan1StatusFault {
    Adm1029FanStatusFaultType get ();
}
member Fan1StatusFault : Adm1029FanStatusFaultType with get

Property Value

Type: Adm1029FanStatusFaultType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1StatusFaultL Property

IRD

Adm1029Fan1StatusFaultL Property

Fan 1 Status (Fault_L)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Fan1StatusFaultL { get; set; }
Public Property Fan1StatusFaultL As Byte
    Get
    Set
public:
property unsigned char Fan1StatusFaultL {
    unsigned char get ();
    void set (unsigned char value);
}
member Fan1StatusFaultL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1StatusHotPlugL Property

IRD

Adm1029Fan1StatusHotPlugL Property

Fan 1 Status (Hot_Plug_L)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Fan1StatusHotPlugL { get; set; }
Public Property Fan1StatusHotPlugL As Byte
    Get
    Set
public:
property unsigned char Fan1StatusHotPlugL {
    unsigned char get ();
    void set (unsigned char value);
}
member Fan1StatusHotPlugL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1StatusHotPlugPriority Property

IRD

Adm1029Fan1StatusHotPlugPriority Property

Fan 1 Status (Hot Plug Priority)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanStatusHotPlugType Fan1StatusHotPlugPriority { get; set; }
Public Property Fan1StatusHotPlugPriority As Adm1029FanStatusHotPlugType
    Get
    Set
public:
property Adm1029FanStatusHotPlugType Fan1StatusHotPlugPriority {
    Adm1029FanStatusHotPlugType get ();
    void set (Adm1029FanStatusHotPlugType value);
}
member Fan1StatusHotPlugPriority : Adm1029FanStatusHotPlugType with get, set

Property Value

Type: Adm1029FanStatusHotPlugType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1StatusMissing Property

IRD

Adm1029Fan1StatusMissing Property

Fan 1 Status (Missing)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanStatusMissingType Fan1StatusMissing { get; }
Public ReadOnly Property Fan1StatusMissing As Adm1029FanStatusMissingType
    Get
public:
property Adm1029FanStatusMissingType Fan1StatusMissing {
    Adm1029FanStatusMissingType get ();
}
member Fan1StatusMissing : Adm1029FanStatusMissingType with get

Property Value

Type: Adm1029FanStatusMissingType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1StatusMissingL Property

IRD

Adm1029Fan1StatusMissingL Property

Fan 1 Status (Missing_L)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Fan1StatusMissingL { get; set; }
Public Property Fan1StatusMissingL As Byte
    Get
    Set
public:
property unsigned char Fan1StatusMissingL {
    unsigned char get ();
    void set (unsigned char value);
}
member Fan1StatusMissingL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1StatusSleep Property

IRD

Adm1029Fan1StatusSleep Property

Fan 1 Status (Sleep)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanStatusSleepType Fan1StatusSleep { get; set; }
Public Property Fan1StatusSleep As Adm1029FanStatusSleepType
    Get
    Set
public:
property Adm1029FanStatusSleepType Fan1StatusSleep {
    Adm1029FanStatusSleepType get ();
    void set (Adm1029FanStatusSleepType value);
}
member Fan1StatusSleep : Adm1029FanStatusSleepType with get, set

Property Value

Type: Adm1029FanStatusSleepType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1StatusTachFaultL Property

IRD

Adm1029Fan1StatusTachFaultL Property

Fan 1 Status (Tach_Fault_L)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Fan1StatusTachFaultL { get; set; }
Public Property Fan1StatusTachFaultL As Byte
    Get
    Set
public:
property unsigned char Fan1StatusTachFaultL {
    unsigned char get ();
    void set (unsigned char value);
}
member Fan1StatusTachFaultL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1TachHighLimit Property

IRD

Adm1029Fan1TachHighLimit Property

Fan 1 Tach High Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Fan1TachHighLimit { get; set; }
Public Property Fan1TachHighLimit As Byte
    Get
    Set
public:
property unsigned char Fan1TachHighLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member Fan1TachHighLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan1TachValue Property

IRD

Adm1029Fan1TachValue Property

Fan 1 Tach Value

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Fan1TachValue { get; }
Public ReadOnly Property Fan1TachValue As Byte
    Get
public:
property unsigned char Fan1TachValue {
    unsigned char get ();
}
member Fan1TachValue : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2AlarmSpeed Property

IRD

Adm1029Fan2AlarmSpeed Property

Fan 2 Alarm Speed (unit: %)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanSpeedType Fan2AlarmSpeed { get; set; }
Public Property Fan2AlarmSpeed As Adm1029FanSpeedType
    Get
    Set
public:
property Adm1029FanSpeedType Fan2AlarmSpeed {
    Adm1029FanSpeedType get ();
    void set (Adm1029FanSpeedType value);
}
member Fan2AlarmSpeed : Adm1029FanSpeedType with get, set

Property Value

Type: Adm1029FanSpeedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2ConfigurationHotPlugSpeed Property

IRD

Adm1029Fan2ConfigurationHotPlugSpeed Property

Fan 2 Configuration (Hot-Plug Speed) (unit: %)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanSpeedType Fan2ConfigurationHotPlugSpeed { get; set; }
Public Property Fan2ConfigurationHotPlugSpeed As Adm1029FanSpeedType
    Get
    Set
public:
property Adm1029FanSpeedType Fan2ConfigurationHotPlugSpeed {
    Adm1029FanSpeedType get ();
    void set (Adm1029FanSpeedType value);
}
member Fan2ConfigurationHotPlugSpeed : Adm1029FanSpeedType with get, set

Property Value

Type: Adm1029FanSpeedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2ConfigurationOscillatorFrequency Property

IRD

Adm1029Fan2ConfigurationOscillatorFrequency Property

Fan 2 Configuration (Oscillator Frequency)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanConfigOscillatorType Fan2ConfigurationOscillatorFrequency { get; set; }
Public Property Fan2ConfigurationOscillatorFrequency As Adm1029FanConfigOscillatorType
    Get
    Set
public:
property Adm1029FanConfigOscillatorType Fan2ConfigurationOscillatorFrequency {
    Adm1029FanConfigOscillatorType get ();
    void set (Adm1029FanConfigOscillatorType value);
}
member Fan2ConfigurationOscillatorFrequency : Adm1029FanConfigOscillatorType with get, set

Property Value

Type: Adm1029FanConfigOscillatorType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2ConfigurationPWMFrequency Property

IRD

Adm1029Fan2ConfigurationPWMFrequency Property

Fan 2 Configuration (PWM Frequency) (unit: Hz)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanConfigPwmType Fan2ConfigurationPWMFrequency { get; set; }
Public Property Fan2ConfigurationPWMFrequency As Adm1029FanConfigPwmType
    Get
    Set
public:
property Adm1029FanConfigPwmType Fan2ConfigurationPWMFrequency {
    Adm1029FanConfigPwmType get ();
    void set (Adm1029FanConfigPwmType value);
}
member Fan2ConfigurationPWMFrequency : Adm1029FanConfigPwmType with get, set

Property Value

Type: Adm1029FanConfigPwmType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2EventMaskFan1 Property

IRD

Adm1029Fan2EventMaskFan1 Property

Fan 2 Event Mask (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanEventMask1Type Fan2EventMaskFan1 { get; set; }
Public Property Fan2EventMaskFan1 As Adm1029FanEventMask1Type
    Get
    Set
public:
property Adm1029FanEventMask1Type Fan2EventMaskFan1 {
    Adm1029FanEventMask1Type get ();
    void set (Adm1029FanEventMask1Type value);
}
member Fan2EventMaskFan1 : Adm1029FanEventMask1Type with get, set

Property Value

Type: Adm1029FanEventMask1Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2EventMaskFan2 Property

IRD

Adm1029Fan2EventMaskFan2 Property

Fan 2 Event Mask (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanEventMask2Type Fan2EventMaskFan2 { get; set; }
Public Property Fan2EventMaskFan2 As Adm1029FanEventMask2Type
    Get
    Set
public:
property Adm1029FanEventMask2Type Fan2EventMaskFan2 {
    Adm1029FanEventMask2Type get ();
    void set (Adm1029FanEventMask2Type value);
}
member Fan2EventMaskFan2 : Adm1029FanEventMask2Type with get, set

Property Value

Type: Adm1029FanEventMask2Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2FaultActionAlarmOnCFAULT Property

IRD

Adm1029Fan2FaultActionAlarmOnCFAULT Property

Fan 2 Fault Action (Alarm On CFAULT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FaultAction7Type Fan2FaultActionAlarmOnCFAULT { get; set; }
Public Property Fan2FaultActionAlarmOnCFAULT As Adm1029FaultAction7Type
    Get
    Set
public:
property Adm1029FaultAction7Type Fan2FaultActionAlarmOnCFAULT {
    Adm1029FaultAction7Type get ();
    void set (Adm1029FaultAction7Type value);
}
member Fan2FaultActionAlarmOnCFAULT : Adm1029FaultAction7Type with get, set

Property Value

Type: Adm1029FaultAction7Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2FaultActionAssertCFAULTOnFault Property

IRD

Adm1029Fan2FaultActionAssertCFAULTOnFault Property

Fan 2 Fault Action (Assert CFAULT On Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FaultAction0Type Fan2FaultActionAssertCFAULTOnFault { get; set; }
Public Property Fan2FaultActionAssertCFAULTOnFault As Adm1029FaultAction0Type
    Get
    Set
public:
property Adm1029FaultAction0Type Fan2FaultActionAssertCFAULTOnFault {
    Adm1029FaultAction0Type get ();
    void set (Adm1029FaultAction0Type value);
}
member Fan2FaultActionAssertCFAULTOnFault : Adm1029FaultAction0Type with get, set

Property Value

Type: Adm1029FaultAction0Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2FaultActionAssertCFAULTOnHotUnplug Property

IRD

Adm1029Fan2FaultActionAssertCFAULTOnHotUnplug Property

Fan 2 Fault Action (Assert CFAULT On Hot Unplug)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FaultAction2Type Fan2FaultActionAssertCFAULTOnHotUnplug { get; set; }
Public Property Fan2FaultActionAssertCFAULTOnHotUnplug As Adm1029FaultAction2Type
    Get
    Set
public:
property Adm1029FaultAction2Type Fan2FaultActionAssertCFAULTOnHotUnplug {
    Adm1029FaultAction2Type get ();
    void set (Adm1029FaultAction2Type value);
}
member Fan2FaultActionAssertCFAULTOnHotUnplug : Adm1029FaultAction2Type with get, set

Property Value

Type: Adm1029FaultAction2Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2FaultActionAssertINTOnFault Property

IRD

Adm1029Fan2FaultActionAssertINTOnFault Property

Fan 2 Fault Action (Assert INT On Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FaultAction1Type Fan2FaultActionAssertINTOnFault { get; set; }
Public Property Fan2FaultActionAssertINTOnFault As Adm1029FaultAction1Type
    Get
    Set
public:
property Adm1029FaultAction1Type Fan2FaultActionAssertINTOnFault {
    Adm1029FaultAction1Type get ();
    void set (Adm1029FaultAction1Type value);
}
member Fan2FaultActionAssertINTOnFault : Adm1029FaultAction1Type with get, set

Property Value

Type: Adm1029FaultAction1Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2FaultActionAssertINTOnHotUnplug Property

IRD

Adm1029Fan2FaultActionAssertINTOnHotUnplug Property

Fan 2 Fault Action (Assert INT On Hot Unplug)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FaultAction3Type Fan2FaultActionAssertINTOnHotUnplug { get; set; }
Public Property Fan2FaultActionAssertINTOnHotUnplug As Adm1029FaultAction3Type
    Get
    Set
public:
property Adm1029FaultAction3Type Fan2FaultActionAssertINTOnHotUnplug {
    Adm1029FaultAction3Type get ();
    void set (Adm1029FaultAction3Type value);
}
member Fan2FaultActionAssertINTOnHotUnplug : Adm1029FaultAction3Type with get, set

Property Value

Type: Adm1029FaultAction3Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2FaultActionDriveFaultOnFaultL Property

IRD

Adm1029Fan2FaultActionDriveFaultOnFaultL Property

Fan 2 Fault Action (Drive Fault On Fault_L)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FaultAction5Type Fan2FaultActionDriveFaultOnFaultL { get; set; }
Public Property Fan2FaultActionDriveFaultOnFaultL As Adm1029FaultAction5Type
    Get
    Set
public:
property Adm1029FaultAction5Type Fan2FaultActionDriveFaultOnFaultL {
    Adm1029FaultAction5Type get ();
    void set (Adm1029FaultAction5Type value);
}
member Fan2FaultActionDriveFaultOnFaultL : Adm1029FaultAction5Type with get, set

Property Value

Type: Adm1029FaultAction5Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2FaultActionHotPlugSpeedOnCFAULTIn Property

IRD

Adm1029Fan2FaultActionHotPlugSpeedOnCFAULTIn Property

Fan 2 Fault Action (Hot-Plug Speed On CFAULT In)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FaultAction6Type Fan2FaultActionHotPlugSpeedOnCFAULTIn { get; set; }
Public Property Fan2FaultActionHotPlugSpeedOnCFAULTIn As Adm1029FaultAction6Type
    Get
    Set
public:
property Adm1029FaultAction6Type Fan2FaultActionHotPlugSpeedOnCFAULTIn {
    Adm1029FaultAction6Type get ();
    void set (Adm1029FaultAction6Type value);
}
member Fan2FaultActionHotPlugSpeedOnCFAULTIn : Adm1029FaultAction6Type with get, set

Property Value

Type: Adm1029FaultAction6Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2FaultActionThermalOverrideInSleep Property

IRD

Adm1029Fan2FaultActionThermalOverrideInSleep Property

Fan 2 Fault Action (Thermal Override In Sleep)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FaultAction4Type Fan2FaultActionThermalOverrideInSleep { get; set; }
Public Property Fan2FaultActionThermalOverrideInSleep As Adm1029FaultAction4Type
    Get
    Set
public:
property Adm1029FaultAction4Type Fan2FaultActionThermalOverrideInSleep {
    Adm1029FaultAction4Type get ();
    void set (Adm1029FaultAction4Type value);
}
member Fan2FaultActionThermalOverrideInSleep : Adm1029FaultAction4Type with get, set

Property Value

Type: Adm1029FaultAction4Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2MinimumSpeed Property

IRD

Adm1029Fan2MinimumSpeed Property

Fan 2 Minimum Speed (unit: %)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanSpeedType Fan2MinimumSpeed { get; set; }
Public Property Fan2MinimumSpeed As Adm1029FanSpeedType
    Get
    Set
public:
property Adm1029FanSpeedType Fan2MinimumSpeed {
    Adm1029FanSpeedType get ();
    void set (Adm1029FanSpeedType value);
}
member Fan2MinimumSpeed : Adm1029FanSpeedType with get, set

Property Value

Type: Adm1029FanSpeedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2StatusFault Property

IRD

Adm1029Fan2StatusFault Property

Fan 2 Status (Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanStatusFaultType Fan2StatusFault { get; }
Public ReadOnly Property Fan2StatusFault As Adm1029FanStatusFaultType
    Get
public:
property Adm1029FanStatusFaultType Fan2StatusFault {
    Adm1029FanStatusFaultType get ();
}
member Fan2StatusFault : Adm1029FanStatusFaultType with get

Property Value

Type: Adm1029FanStatusFaultType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2StatusFaultL Property

IRD

Adm1029Fan2StatusFaultL Property

Fan 2 Status (Fault_L)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Fan2StatusFaultL { get; set; }
Public Property Fan2StatusFaultL As Byte
    Get
    Set
public:
property unsigned char Fan2StatusFaultL {
    unsigned char get ();
    void set (unsigned char value);
}
member Fan2StatusFaultL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2StatusHotPlugL Property

IRD

Adm1029Fan2StatusHotPlugL Property

Fan 2 Status (Hot_Plug_L)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Fan2StatusHotPlugL { get; set; }
Public Property Fan2StatusHotPlugL As Byte
    Get
    Set
public:
property unsigned char Fan2StatusHotPlugL {
    unsigned char get ();
    void set (unsigned char value);
}
member Fan2StatusHotPlugL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2StatusHotPlugPriority Property

IRD

Adm1029Fan2StatusHotPlugPriority Property

Fan 2 Status (Hot Plug Priority)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanStatusHotPlugType Fan2StatusHotPlugPriority { get; set; }
Public Property Fan2StatusHotPlugPriority As Adm1029FanStatusHotPlugType
    Get
    Set
public:
property Adm1029FanStatusHotPlugType Fan2StatusHotPlugPriority {
    Adm1029FanStatusHotPlugType get ();
    void set (Adm1029FanStatusHotPlugType value);
}
member Fan2StatusHotPlugPriority : Adm1029FanStatusHotPlugType with get, set

Property Value

Type: Adm1029FanStatusHotPlugType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2StatusMissing Property

IRD

Adm1029Fan2StatusMissing Property

Fan 2 Status (Missing)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanStatusMissingType Fan2StatusMissing { get; }
Public ReadOnly Property Fan2StatusMissing As Adm1029FanStatusMissingType
    Get
public:
property Adm1029FanStatusMissingType Fan2StatusMissing {
    Adm1029FanStatusMissingType get ();
}
member Fan2StatusMissing : Adm1029FanStatusMissingType with get

Property Value

Type: Adm1029FanStatusMissingType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2StatusMissingL Property

IRD

Adm1029Fan2StatusMissingL Property

Fan 2 Status (Missing_L)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Fan2StatusMissingL { get; set; }
Public Property Fan2StatusMissingL As Byte
    Get
    Set
public:
property unsigned char Fan2StatusMissingL {
    unsigned char get ();
    void set (unsigned char value);
}
member Fan2StatusMissingL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2StatusSleep Property

IRD

Adm1029Fan2StatusSleep Property

Fan 2 Status (Sleep)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanStatusSleepType Fan2StatusSleep { get; set; }
Public Property Fan2StatusSleep As Adm1029FanStatusSleepType
    Get
    Set
public:
property Adm1029FanStatusSleepType Fan2StatusSleep {
    Adm1029FanStatusSleepType get ();
    void set (Adm1029FanStatusSleepType value);
}
member Fan2StatusSleep : Adm1029FanStatusSleepType with get, set

Property Value

Type: Adm1029FanStatusSleepType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2StatusTachFaultL Property

IRD

Adm1029Fan2StatusTachFaultL Property

Fan 2 Status (Tach_Fault_L)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Fan2StatusTachFaultL { get; set; }
Public Property Fan2StatusTachFaultL As Byte
    Get
    Set
public:
property unsigned char Fan2StatusTachFaultL {
    unsigned char get ();
    void set (unsigned char value);
}
member Fan2StatusTachFaultL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2TachHighLimit Property

IRD

Adm1029Fan2TachHighLimit Property

Fan 2 Tach High Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Fan2TachHighLimit { get; set; }
Public Property Fan2TachHighLimit As Byte
    Get
    Set
public:
property unsigned char Fan2TachHighLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member Fan2TachHighLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Fan2TachValue Property

IRD

Adm1029Fan2TachValue Property

Fan 2 Tach Value

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Fan2TachValue { get; }
Public ReadOnly Property Fan2TachValue As Byte
    Get
public:
property unsigned char Fan2TachValue {
    unsigned char get ();
}
member Fan2TachValue : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.FanSpinUpDisable Property

IRD

Adm1029FanSpinUpDisable Property

Fan Spin-Up (Disable)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanSpinUpDisableType FanSpinUpDisable { get; set; }
Public Property FanSpinUpDisable As Adm1029FanSpinUpDisableType
    Get
    Set
public:
property Adm1029FanSpinUpDisableType FanSpinUpDisable {
    Adm1029FanSpinUpDisableType get ();
    void set (Adm1029FanSpinUpDisableType value);
}
member FanSpinUpDisable : Adm1029FanSpinUpDisableType with get, set

Property Value

Type: Adm1029FanSpinUpDisableType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.FanSpinUpTime Property

IRD

Adm1029FanSpinUpTime Property

Fan Spin-Up (Time)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029FanSpinUpTimeType FanSpinUpTime { get; set; }
Public Property FanSpinUpTime As Adm1029FanSpinUpTimeType
    Get
    Set
public:
property Adm1029FanSpinUpTimeType FanSpinUpTime {
    Adm1029FanSpinUpTimeType get ();
    void set (Adm1029FanSpinUpTimeType value);
}
member FanSpinUpTime : Adm1029FanSpinUpTimeType with get, set

Property Value

Type: Adm1029FanSpinUpTimeType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.FanSupportedByControllerFan1 Property

IRD

Adm1029FanSupportedByControllerFan1 Property

Fan Supported By Controller (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029SupportedType FanSupportedByControllerFan1 { get; }
Public ReadOnly Property FanSupportedByControllerFan1 As Adm1029SupportedType
    Get
public:
property Adm1029SupportedType FanSupportedByControllerFan1 {
    Adm1029SupportedType get ();
}
member FanSupportedByControllerFan1 : Adm1029SupportedType with get

Property Value

Type: Adm1029SupportedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.FanSupportedByControllerFan2 Property

IRD

Adm1029FanSupportedByControllerFan2 Property

Fan Supported By Controller (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029SupportedType FanSupportedByControllerFan2 { get; }
Public ReadOnly Property FanSupportedByControllerFan2 As Adm1029SupportedType
    Get
public:
property Adm1029SupportedType FanSupportedByControllerFan2 {
    Adm1029SupportedType get ();
}
member FanSupportedByControllerFan2 : Adm1029SupportedType with get

Property Value

Type: Adm1029SupportedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.FanSupportedInSystemFan1 Property

IRD

Adm1029FanSupportedInSystemFan1 Property

Fan Supported In System (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029UsedType FanSupportedInSystemFan1 { get; set; }
Public Property FanSupportedInSystemFan1 As Adm1029UsedType
    Get
    Set
public:
property Adm1029UsedType FanSupportedInSystemFan1 {
    Adm1029UsedType get ();
    void set (Adm1029UsedType value);
}
member FanSupportedInSystemFan1 : Adm1029UsedType with get, set

Property Value

Type: Adm1029UsedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.FanSupportedInSystemFan2 Property

IRD

Adm1029FanSupportedInSystemFan2 Property

Fan Supported In System (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029UsedType FanSupportedInSystemFan2 { get; set; }
Public Property FanSupportedInSystemFan2 As Adm1029UsedType
    Get
    Set
public:
property Adm1029UsedType FanSupportedInSystemFan2 {
    Adm1029UsedType get ();
    void set (Adm1029UsedType value);
}
member FanSupportedInSystemFan2 : Adm1029UsedType with get, set

Property Value

Type: Adm1029UsedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO0BehaviourBit2 Property

IRD

Adm1029GPIO0BehaviourBit2 Property

GPIO0 Behaviour (Bit 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO0BehaviourBit2 { get; set; }
Public Property GPIO0BehaviourBit2 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO0BehaviourBit2 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO0BehaviourBit2 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO0BehaviourBit3 Property

IRD

Adm1029GPIO0BehaviourBit3 Property

GPIO0 Behaviour (Bit 3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO0BehaviourBit3 { get; set; }
Public Property GPIO0BehaviourBit3 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO0BehaviourBit3 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO0BehaviourBit3 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO0BehaviourBit4 Property

IRD

Adm1029GPIO0BehaviourBit4 Property

GPIO0 Behaviour (Bit 4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO0BehaviourBit4 { get; set; }
Public Property GPIO0BehaviourBit4 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO0BehaviourBit4 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO0BehaviourBit4 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO0BehaviourBit5 Property

IRD

Adm1029GPIO0BehaviourBit5 Property

GPIO0 Behaviour (Bit 5)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO0BehaviourBit5 { get; set; }
Public Property GPIO0BehaviourBit5 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO0BehaviourBit5 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO0BehaviourBit5 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO0BehaviourBit6 Property

IRD

Adm1029GPIO0BehaviourBit6 Property

GPIO0 Behaviour (Bit 6)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO0BehaviourBit6 { get; set; }
Public Property GPIO0BehaviourBit6 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO0BehaviourBit6 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO0BehaviourBit6 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO0BehaviourBit7 Property

IRD

Adm1029GPIO0BehaviourBit7 Property

GPIO0 Behaviour (Bit 7)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO0BehaviourBit7 { get; set; }
Public Property GPIO0BehaviourBit7 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO0BehaviourBit7 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO0BehaviourBit7 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO0BehaviourDirection Property

IRD

Adm1029GPIO0BehaviourDirection Property

GPIO0 Behaviour (Direction)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourDirectionType GPIO0BehaviourDirection { get; set; }
Public Property GPIO0BehaviourDirection As Adm1029GpioBehaviourDirectionType
    Get
    Set
public:
property Adm1029GpioBehaviourDirectionType GPIO0BehaviourDirection {
    Adm1029GpioBehaviourDirectionType get ();
    void set (Adm1029GpioBehaviourDirectionType value);
}
member GPIO0BehaviourDirection : Adm1029GpioBehaviourDirectionType with get, set

Property Value

Type: Adm1029GpioBehaviourDirectionType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO0BehaviourPolarity Property

IRD

Adm1029GPIO0BehaviourPolarity Property

GPIO0 Behaviour (Polarity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourPolarityType GPIO0BehaviourPolarity { get; set; }
Public Property GPIO0BehaviourPolarity As Adm1029GpioBehaviourPolarityType
    Get
    Set
public:
property Adm1029GpioBehaviourPolarityType GPIO0BehaviourPolarity {
    Adm1029GpioBehaviourPolarityType get ();
    void set (Adm1029GpioBehaviourPolarityType value);
}
member GPIO0BehaviourPolarity : Adm1029GpioBehaviourPolarityType with get, set

Property Value

Type: Adm1029GpioBehaviourPolarityType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO0EventMaskFan1 Property

IRD

Adm1029GPIO0EventMaskFan1 Property

GPIO0 Event Mask (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioEventMaskType GPIO0EventMaskFan1 { get; set; }
Public Property GPIO0EventMaskFan1 As Adm1029GpioEventMaskType
    Get
    Set
public:
property Adm1029GpioEventMaskType GPIO0EventMaskFan1 {
    Adm1029GpioEventMaskType get ();
    void set (Adm1029GpioEventMaskType value);
}
member GPIO0EventMaskFan1 : Adm1029GpioEventMaskType with get, set

Property Value

Type: Adm1029GpioEventMaskType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO0EventMaskFan2 Property

IRD

Adm1029GPIO0EventMaskFan2 Property

GPIO0 Event Mask (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioEventMaskType GPIO0EventMaskFan2 { get; set; }
Public Property GPIO0EventMaskFan2 As Adm1029GpioEventMaskType
    Get
    Set
public:
property Adm1029GpioEventMaskType GPIO0EventMaskFan2 {
    Adm1029GpioEventMaskType get ();
    void set (Adm1029GpioEventMaskType value);
}
member GPIO0EventMaskFan2 : Adm1029GpioEventMaskType with get, set

Property Value

Type: Adm1029GpioEventMaskType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO1BehaviourBit2 Property

IRD

Adm1029GPIO1BehaviourBit2 Property

GPIO1 Behaviour (Bit 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO1BehaviourBit2 { get; set; }
Public Property GPIO1BehaviourBit2 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO1BehaviourBit2 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO1BehaviourBit2 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO1BehaviourBit3 Property

IRD

Adm1029GPIO1BehaviourBit3 Property

GPIO1 Behaviour (Bit 3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO1BehaviourBit3 { get; set; }
Public Property GPIO1BehaviourBit3 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO1BehaviourBit3 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO1BehaviourBit3 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO1BehaviourBit4 Property

IRD

Adm1029GPIO1BehaviourBit4 Property

GPIO1 Behaviour (Bit 4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO1BehaviourBit4 { get; set; }
Public Property GPIO1BehaviourBit4 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO1BehaviourBit4 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO1BehaviourBit4 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO1BehaviourBit5 Property

IRD

Adm1029GPIO1BehaviourBit5 Property

GPIO1 Behaviour (Bit 5)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO1BehaviourBit5 { get; set; }
Public Property GPIO1BehaviourBit5 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO1BehaviourBit5 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO1BehaviourBit5 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO1BehaviourBit6 Property

IRD

Adm1029GPIO1BehaviourBit6 Property

GPIO1 Behaviour (Bit 6)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO1BehaviourBit6 { get; set; }
Public Property GPIO1BehaviourBit6 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO1BehaviourBit6 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO1BehaviourBit6 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO1BehaviourBit7 Property

IRD

Adm1029GPIO1BehaviourBit7 Property

GPIO1 Behaviour (Bit 7)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO1BehaviourBit7 { get; set; }
Public Property GPIO1BehaviourBit7 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO1BehaviourBit7 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO1BehaviourBit7 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO1BehaviourDirection Property

IRD

Adm1029GPIO1BehaviourDirection Property

GPIO1 Behaviour (Direction)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourDirectionType GPIO1BehaviourDirection { get; set; }
Public Property GPIO1BehaviourDirection As Adm1029GpioBehaviourDirectionType
    Get
    Set
public:
property Adm1029GpioBehaviourDirectionType GPIO1BehaviourDirection {
    Adm1029GpioBehaviourDirectionType get ();
    void set (Adm1029GpioBehaviourDirectionType value);
}
member GPIO1BehaviourDirection : Adm1029GpioBehaviourDirectionType with get, set

Property Value

Type: Adm1029GpioBehaviourDirectionType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO1BehaviourPolarity Property

IRD

Adm1029GPIO1BehaviourPolarity Property

GPIO1 Behaviour (Polarity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourPolarityType GPIO1BehaviourPolarity { get; set; }
Public Property GPIO1BehaviourPolarity As Adm1029GpioBehaviourPolarityType
    Get
    Set
public:
property Adm1029GpioBehaviourPolarityType GPIO1BehaviourPolarity {
    Adm1029GpioBehaviourPolarityType get ();
    void set (Adm1029GpioBehaviourPolarityType value);
}
member GPIO1BehaviourPolarity : Adm1029GpioBehaviourPolarityType with get, set

Property Value

Type: Adm1029GpioBehaviourPolarityType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO1EventMaskFan1 Property

IRD

Adm1029GPIO1EventMaskFan1 Property

GPIO1 Event Mask (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioEventMaskType GPIO1EventMaskFan1 { get; set; }
Public Property GPIO1EventMaskFan1 As Adm1029GpioEventMaskType
    Get
    Set
public:
property Adm1029GpioEventMaskType GPIO1EventMaskFan1 {
    Adm1029GpioEventMaskType get ();
    void set (Adm1029GpioEventMaskType value);
}
member GPIO1EventMaskFan1 : Adm1029GpioEventMaskType with get, set

Property Value

Type: Adm1029GpioEventMaskType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO1EventMaskFan2 Property

IRD

Adm1029GPIO1EventMaskFan2 Property

GPIO1 Event Mask (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioEventMaskType GPIO1EventMaskFan2 { get; set; }
Public Property GPIO1EventMaskFan2 As Adm1029GpioEventMaskType
    Get
    Set
public:
property Adm1029GpioEventMaskType GPIO1EventMaskFan2 {
    Adm1029GpioEventMaskType get ();
    void set (Adm1029GpioEventMaskType value);
}
member GPIO1EventMaskFan2 : Adm1029GpioEventMaskType with get, set

Property Value

Type: Adm1029GpioEventMaskType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO2BehaviourBit2 Property

IRD

Adm1029GPIO2BehaviourBit2 Property

GPIO2 Behaviour (Bit 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO2BehaviourBit2 { get; set; }
Public Property GPIO2BehaviourBit2 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO2BehaviourBit2 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO2BehaviourBit2 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO2BehaviourBit3 Property

IRD

Adm1029GPIO2BehaviourBit3 Property

GPIO2 Behaviour (Bit 3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO2BehaviourBit3 { get; set; }
Public Property GPIO2BehaviourBit3 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO2BehaviourBit3 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO2BehaviourBit3 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO2BehaviourBit4 Property

IRD

Adm1029GPIO2BehaviourBit4 Property

GPIO2 Behaviour (Bit 4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO2BehaviourBit4 { get; set; }
Public Property GPIO2BehaviourBit4 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO2BehaviourBit4 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO2BehaviourBit4 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO2BehaviourBit5 Property

IRD

Adm1029GPIO2BehaviourBit5 Property

GPIO2 Behaviour (Bit 5)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO2BehaviourBit5 { get; set; }
Public Property GPIO2BehaviourBit5 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO2BehaviourBit5 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO2BehaviourBit5 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO2BehaviourBit6 Property

IRD

Adm1029GPIO2BehaviourBit6 Property

GPIO2 Behaviour (Bit 6)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO2BehaviourBit6 { get; set; }
Public Property GPIO2BehaviourBit6 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO2BehaviourBit6 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO2BehaviourBit6 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO2BehaviourBit7 Property

IRD

Adm1029GPIO2BehaviourBit7 Property

GPIO2 Behaviour (Bit 7)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO2BehaviourBit7 { get; set; }
Public Property GPIO2BehaviourBit7 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO2BehaviourBit7 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO2BehaviourBit7 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO2BehaviourDirection Property

IRD

Adm1029GPIO2BehaviourDirection Property

GPIO2 Behaviour (Direction)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourDirectionType GPIO2BehaviourDirection { get; set; }
Public Property GPIO2BehaviourDirection As Adm1029GpioBehaviourDirectionType
    Get
    Set
public:
property Adm1029GpioBehaviourDirectionType GPIO2BehaviourDirection {
    Adm1029GpioBehaviourDirectionType get ();
    void set (Adm1029GpioBehaviourDirectionType value);
}
member GPIO2BehaviourDirection : Adm1029GpioBehaviourDirectionType with get, set

Property Value

Type: Adm1029GpioBehaviourDirectionType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO2BehaviourPolarity Property

IRD

Adm1029GPIO2BehaviourPolarity Property

GPIO2 Behaviour (Polarity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourPolarityType GPIO2BehaviourPolarity { get; set; }
Public Property GPIO2BehaviourPolarity As Adm1029GpioBehaviourPolarityType
    Get
    Set
public:
property Adm1029GpioBehaviourPolarityType GPIO2BehaviourPolarity {
    Adm1029GpioBehaviourPolarityType get ();
    void set (Adm1029GpioBehaviourPolarityType value);
}
member GPIO2BehaviourPolarity : Adm1029GpioBehaviourPolarityType with get, set

Property Value

Type: Adm1029GpioBehaviourPolarityType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO2EventMaskFan1 Property

IRD

Adm1029GPIO2EventMaskFan1 Property

GPIO2 Event Mask (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioEventMaskType GPIO2EventMaskFan1 { get; set; }
Public Property GPIO2EventMaskFan1 As Adm1029GpioEventMaskType
    Get
    Set
public:
property Adm1029GpioEventMaskType GPIO2EventMaskFan1 {
    Adm1029GpioEventMaskType get ();
    void set (Adm1029GpioEventMaskType value);
}
member GPIO2EventMaskFan1 : Adm1029GpioEventMaskType with get, set

Property Value

Type: Adm1029GpioEventMaskType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO2EventMaskFan2 Property

IRD

Adm1029GPIO2EventMaskFan2 Property

GPIO2 Event Mask (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioEventMaskType GPIO2EventMaskFan2 { get; set; }
Public Property GPIO2EventMaskFan2 As Adm1029GpioEventMaskType
    Get
    Set
public:
property Adm1029GpioEventMaskType GPIO2EventMaskFan2 {
    Adm1029GpioEventMaskType get ();
    void set (Adm1029GpioEventMaskType value);
}
member GPIO2EventMaskFan2 : Adm1029GpioEventMaskType with get, set

Property Value

Type: Adm1029GpioEventMaskType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO3BehaviourBit2 Property

IRD

Adm1029GPIO3BehaviourBit2 Property

GPIO3 Behaviour (Bit 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO3BehaviourBit2 { get; set; }
Public Property GPIO3BehaviourBit2 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO3BehaviourBit2 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO3BehaviourBit2 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO3BehaviourBit3 Property

IRD

Adm1029GPIO3BehaviourBit3 Property

GPIO3 Behaviour (Bit 3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO3BehaviourBit3 { get; set; }
Public Property GPIO3BehaviourBit3 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO3BehaviourBit3 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO3BehaviourBit3 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO3BehaviourBit4 Property

IRD

Adm1029GPIO3BehaviourBit4 Property

GPIO3 Behaviour (Bit 4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO3BehaviourBit4 { get; set; }
Public Property GPIO3BehaviourBit4 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO3BehaviourBit4 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO3BehaviourBit4 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO3BehaviourBit5 Property

IRD

Adm1029GPIO3BehaviourBit5 Property

GPIO3 Behaviour (Bit 5)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO3BehaviourBit5 { get; set; }
Public Property GPIO3BehaviourBit5 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO3BehaviourBit5 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO3BehaviourBit5 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO3BehaviourBit6 Property

IRD

Adm1029GPIO3BehaviourBit6 Property

GPIO3 Behaviour (Bit 6)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO3BehaviourBit6 { get; set; }
Public Property GPIO3BehaviourBit6 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO3BehaviourBit6 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO3BehaviourBit6 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO3BehaviourBit7 Property

IRD

Adm1029GPIO3BehaviourBit7 Property

GPIO3 Behaviour (Bit 7)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO3BehaviourBit7 { get; set; }
Public Property GPIO3BehaviourBit7 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO3BehaviourBit7 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO3BehaviourBit7 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO3BehaviourDirection Property

IRD

Adm1029GPIO3BehaviourDirection Property

GPIO3 Behaviour (Direction)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourDirectionType GPIO3BehaviourDirection { get; set; }
Public Property GPIO3BehaviourDirection As Adm1029GpioBehaviourDirectionType
    Get
    Set
public:
property Adm1029GpioBehaviourDirectionType GPIO3BehaviourDirection {
    Adm1029GpioBehaviourDirectionType get ();
    void set (Adm1029GpioBehaviourDirectionType value);
}
member GPIO3BehaviourDirection : Adm1029GpioBehaviourDirectionType with get, set

Property Value

Type: Adm1029GpioBehaviourDirectionType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO3BehaviourPolarity Property

IRD

Adm1029GPIO3BehaviourPolarity Property

GPIO3 Behaviour (Polarity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourPolarityType GPIO3BehaviourPolarity { get; set; }
Public Property GPIO3BehaviourPolarity As Adm1029GpioBehaviourPolarityType
    Get
    Set
public:
property Adm1029GpioBehaviourPolarityType GPIO3BehaviourPolarity {
    Adm1029GpioBehaviourPolarityType get ();
    void set (Adm1029GpioBehaviourPolarityType value);
}
member GPIO3BehaviourPolarity : Adm1029GpioBehaviourPolarityType with get, set

Property Value

Type: Adm1029GpioBehaviourPolarityType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO3EventMaskFan1 Property

IRD

Adm1029GPIO3EventMaskFan1 Property

GPIO3 Event Mask (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioEventMaskType GPIO3EventMaskFan1 { get; set; }
Public Property GPIO3EventMaskFan1 As Adm1029GpioEventMaskType
    Get
    Set
public:
property Adm1029GpioEventMaskType GPIO3EventMaskFan1 {
    Adm1029GpioEventMaskType get ();
    void set (Adm1029GpioEventMaskType value);
}
member GPIO3EventMaskFan1 : Adm1029GpioEventMaskType with get, set

Property Value

Type: Adm1029GpioEventMaskType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO3EventMaskFan2 Property

IRD

Adm1029GPIO3EventMaskFan2 Property

GPIO3 Event Mask (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioEventMaskType GPIO3EventMaskFan2 { get; set; }
Public Property GPIO3EventMaskFan2 As Adm1029GpioEventMaskType
    Get
    Set
public:
property Adm1029GpioEventMaskType GPIO3EventMaskFan2 {
    Adm1029GpioEventMaskType get ();
    void set (Adm1029GpioEventMaskType value);
}
member GPIO3EventMaskFan2 : Adm1029GpioEventMaskType with get, set

Property Value

Type: Adm1029GpioEventMaskType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO4BehaviourBit2 Property

IRD

Adm1029GPIO4BehaviourBit2 Property

GPIO4 Behaviour (Bit 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO4BehaviourBit2 { get; set; }
Public Property GPIO4BehaviourBit2 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO4BehaviourBit2 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO4BehaviourBit2 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO4BehaviourBit3 Property

IRD

Adm1029GPIO4BehaviourBit3 Property

GPIO4 Behaviour (Bit 3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO4BehaviourBit3 { get; set; }
Public Property GPIO4BehaviourBit3 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO4BehaviourBit3 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO4BehaviourBit3 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO4BehaviourBit4 Property

IRD

Adm1029GPIO4BehaviourBit4 Property

GPIO4 Behaviour (Bit 4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO4BehaviourBit4 { get; set; }
Public Property GPIO4BehaviourBit4 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO4BehaviourBit4 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO4BehaviourBit4 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO4BehaviourBit5 Property

IRD

Adm1029GPIO4BehaviourBit5 Property

GPIO4 Behaviour (Bit 5)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO4BehaviourBit5 { get; set; }
Public Property GPIO4BehaviourBit5 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO4BehaviourBit5 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO4BehaviourBit5 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO4BehaviourBit6 Property

IRD

Adm1029GPIO4BehaviourBit6 Property

GPIO4 Behaviour (Bit 6)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO4BehaviourBit6 { get; set; }
Public Property GPIO4BehaviourBit6 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO4BehaviourBit6 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO4BehaviourBit6 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO4BehaviourBit7 Property

IRD

Adm1029GPIO4BehaviourBit7 Property

GPIO4 Behaviour (Bit 7)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO4BehaviourBit7 { get; set; }
Public Property GPIO4BehaviourBit7 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO4BehaviourBit7 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO4BehaviourBit7 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO4BehaviourDirection Property

IRD

Adm1029GPIO4BehaviourDirection Property

GPIO4 Behaviour (Direction)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourDirectionType GPIO4BehaviourDirection { get; set; }
Public Property GPIO4BehaviourDirection As Adm1029GpioBehaviourDirectionType
    Get
    Set
public:
property Adm1029GpioBehaviourDirectionType GPIO4BehaviourDirection {
    Adm1029GpioBehaviourDirectionType get ();
    void set (Adm1029GpioBehaviourDirectionType value);
}
member GPIO4BehaviourDirection : Adm1029GpioBehaviourDirectionType with get, set

Property Value

Type: Adm1029GpioBehaviourDirectionType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO4BehaviourPolarity Property

IRD

Adm1029GPIO4BehaviourPolarity Property

GPIO4 Behaviour (Polarity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourPolarityType GPIO4BehaviourPolarity { get; set; }
Public Property GPIO4BehaviourPolarity As Adm1029GpioBehaviourPolarityType
    Get
    Set
public:
property Adm1029GpioBehaviourPolarityType GPIO4BehaviourPolarity {
    Adm1029GpioBehaviourPolarityType get ();
    void set (Adm1029GpioBehaviourPolarityType value);
}
member GPIO4BehaviourPolarity : Adm1029GpioBehaviourPolarityType with get, set

Property Value

Type: Adm1029GpioBehaviourPolarityType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO4EventMaskFan1 Property

IRD

Adm1029GPIO4EventMaskFan1 Property

GPIO4 Event Mask (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioEventMaskType GPIO4EventMaskFan1 { get; set; }
Public Property GPIO4EventMaskFan1 As Adm1029GpioEventMaskType
    Get
    Set
public:
property Adm1029GpioEventMaskType GPIO4EventMaskFan1 {
    Adm1029GpioEventMaskType get ();
    void set (Adm1029GpioEventMaskType value);
}
member GPIO4EventMaskFan1 : Adm1029GpioEventMaskType with get, set

Property Value

Type: Adm1029GpioEventMaskType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO4EventMaskFan2 Property

IRD

Adm1029GPIO4EventMaskFan2 Property

GPIO4 Event Mask (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioEventMaskType GPIO4EventMaskFan2 { get; set; }
Public Property GPIO4EventMaskFan2 As Adm1029GpioEventMaskType
    Get
    Set
public:
property Adm1029GpioEventMaskType GPIO4EventMaskFan2 {
    Adm1029GpioEventMaskType get ();
    void set (Adm1029GpioEventMaskType value);
}
member GPIO4EventMaskFan2 : Adm1029GpioEventMaskType with get, set

Property Value

Type: Adm1029GpioEventMaskType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO5BehaviourBit2 Property

IRD

Adm1029GPIO5BehaviourBit2 Property

GPIO5 Behaviour (Bit 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO5BehaviourBit2 { get; set; }
Public Property GPIO5BehaviourBit2 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO5BehaviourBit2 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO5BehaviourBit2 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO5BehaviourBit3 Property

IRD

Adm1029GPIO5BehaviourBit3 Property

GPIO5 Behaviour (Bit 3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO5BehaviourBit3 { get; set; }
Public Property GPIO5BehaviourBit3 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO5BehaviourBit3 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO5BehaviourBit3 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO5BehaviourBit4 Property

IRD

Adm1029GPIO5BehaviourBit4 Property

GPIO5 Behaviour (Bit 4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO5BehaviourBit4 { get; set; }
Public Property GPIO5BehaviourBit4 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO5BehaviourBit4 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO5BehaviourBit4 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO5BehaviourBit5 Property

IRD

Adm1029GPIO5BehaviourBit5 Property

GPIO5 Behaviour (Bit 5)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO5BehaviourBit5 { get; set; }
Public Property GPIO5BehaviourBit5 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO5BehaviourBit5 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO5BehaviourBit5 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO5BehaviourBit6 Property

IRD

Adm1029GPIO5BehaviourBit6 Property

GPIO5 Behaviour (Bit 6)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO5BehaviourBit6 { get; set; }
Public Property GPIO5BehaviourBit6 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO5BehaviourBit6 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO5BehaviourBit6 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO5BehaviourBit7 Property

IRD

Adm1029GPIO5BehaviourBit7 Property

GPIO5 Behaviour (Bit 7)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO5BehaviourBit7 { get; set; }
Public Property GPIO5BehaviourBit7 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO5BehaviourBit7 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO5BehaviourBit7 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO5BehaviourDirection Property

IRD

Adm1029GPIO5BehaviourDirection Property

GPIO5 Behaviour (Direction)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourDirectionType GPIO5BehaviourDirection { get; set; }
Public Property GPIO5BehaviourDirection As Adm1029GpioBehaviourDirectionType
    Get
    Set
public:
property Adm1029GpioBehaviourDirectionType GPIO5BehaviourDirection {
    Adm1029GpioBehaviourDirectionType get ();
    void set (Adm1029GpioBehaviourDirectionType value);
}
member GPIO5BehaviourDirection : Adm1029GpioBehaviourDirectionType with get, set

Property Value

Type: Adm1029GpioBehaviourDirectionType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO5BehaviourPolarity Property

IRD

Adm1029GPIO5BehaviourPolarity Property

GPIO5 Behaviour (Polarity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourPolarityType GPIO5BehaviourPolarity { get; set; }
Public Property GPIO5BehaviourPolarity As Adm1029GpioBehaviourPolarityType
    Get
    Set
public:
property Adm1029GpioBehaviourPolarityType GPIO5BehaviourPolarity {
    Adm1029GpioBehaviourPolarityType get ();
    void set (Adm1029GpioBehaviourPolarityType value);
}
member GPIO5BehaviourPolarity : Adm1029GpioBehaviourPolarityType with get, set

Property Value

Type: Adm1029GpioBehaviourPolarityType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO5EventMaskFan1 Property

IRD

Adm1029GPIO5EventMaskFan1 Property

GPIO5 Event Mask (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioEventMaskType GPIO5EventMaskFan1 { get; set; }
Public Property GPIO5EventMaskFan1 As Adm1029GpioEventMaskType
    Get
    Set
public:
property Adm1029GpioEventMaskType GPIO5EventMaskFan1 {
    Adm1029GpioEventMaskType get ();
    void set (Adm1029GpioEventMaskType value);
}
member GPIO5EventMaskFan1 : Adm1029GpioEventMaskType with get, set

Property Value

Type: Adm1029GpioEventMaskType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO5EventMaskFan2 Property

IRD

Adm1029GPIO5EventMaskFan2 Property

GPIO5 Event Mask (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioEventMaskType GPIO5EventMaskFan2 { get; set; }
Public Property GPIO5EventMaskFan2 As Adm1029GpioEventMaskType
    Get
    Set
public:
property Adm1029GpioEventMaskType GPIO5EventMaskFan2 {
    Adm1029GpioEventMaskType get ();
    void set (Adm1029GpioEventMaskType value);
}
member GPIO5EventMaskFan2 : Adm1029GpioEventMaskType with get, set

Property Value

Type: Adm1029GpioEventMaskType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO6BehaviourBit2 Property

IRD

Adm1029GPIO6BehaviourBit2 Property

GPIO6 Behaviour (Bit 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO6BehaviourBit2 { get; set; }
Public Property GPIO6BehaviourBit2 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO6BehaviourBit2 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO6BehaviourBit2 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO6BehaviourBit3 Property

IRD

Adm1029GPIO6BehaviourBit3 Property

GPIO6 Behaviour (Bit 3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO6BehaviourBit3 { get; set; }
Public Property GPIO6BehaviourBit3 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO6BehaviourBit3 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO6BehaviourBit3 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO6BehaviourBit4 Property

IRD

Adm1029GPIO6BehaviourBit4 Property

GPIO6 Behaviour (Bit 4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO6BehaviourBit4 { get; set; }
Public Property GPIO6BehaviourBit4 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO6BehaviourBit4 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO6BehaviourBit4 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO6BehaviourBit5 Property

IRD

Adm1029GPIO6BehaviourBit5 Property

GPIO6 Behaviour (Bit 5)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO6BehaviourBit5 { get; set; }
Public Property GPIO6BehaviourBit5 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO6BehaviourBit5 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO6BehaviourBit5 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO6BehaviourBit6 Property

IRD

Adm1029GPIO6BehaviourBit6 Property

GPIO6 Behaviour (Bit 6)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO6BehaviourBit6 { get; set; }
Public Property GPIO6BehaviourBit6 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO6BehaviourBit6 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO6BehaviourBit6 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO6BehaviourBit7 Property

IRD

Adm1029GPIO6BehaviourBit7 Property

GPIO6 Behaviour (Bit 7)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourSetType GPIO6BehaviourBit7 { get; set; }
Public Property GPIO6BehaviourBit7 As Adm1029GpioBehaviourSetType
    Get
    Set
public:
property Adm1029GpioBehaviourSetType GPIO6BehaviourBit7 {
    Adm1029GpioBehaviourSetType get ();
    void set (Adm1029GpioBehaviourSetType value);
}
member GPIO6BehaviourBit7 : Adm1029GpioBehaviourSetType with get, set

Property Value

Type: Adm1029GpioBehaviourSetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO6BehaviourDirection Property

IRD

Adm1029GPIO6BehaviourDirection Property

GPIO6 Behaviour (Direction)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourDirectionType GPIO6BehaviourDirection { get; set; }
Public Property GPIO6BehaviourDirection As Adm1029GpioBehaviourDirectionType
    Get
    Set
public:
property Adm1029GpioBehaviourDirectionType GPIO6BehaviourDirection {
    Adm1029GpioBehaviourDirectionType get ();
    void set (Adm1029GpioBehaviourDirectionType value);
}
member GPIO6BehaviourDirection : Adm1029GpioBehaviourDirectionType with get, set

Property Value

Type: Adm1029GpioBehaviourDirectionType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO6BehaviourPolarity Property

IRD

Adm1029GPIO6BehaviourPolarity Property

GPIO6 Behaviour (Polarity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioBehaviourPolarityType GPIO6BehaviourPolarity { get; set; }
Public Property GPIO6BehaviourPolarity As Adm1029GpioBehaviourPolarityType
    Get
    Set
public:
property Adm1029GpioBehaviourPolarityType GPIO6BehaviourPolarity {
    Adm1029GpioBehaviourPolarityType get ();
    void set (Adm1029GpioBehaviourPolarityType value);
}
member GPIO6BehaviourPolarity : Adm1029GpioBehaviourPolarityType with get, set

Property Value

Type: Adm1029GpioBehaviourPolarityType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO6EventMaskFan1 Property

IRD

Adm1029GPIO6EventMaskFan1 Property

GPIO6 Event Mask (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioEventMaskType GPIO6EventMaskFan1 { get; set; }
Public Property GPIO6EventMaskFan1 As Adm1029GpioEventMaskType
    Get
    Set
public:
property Adm1029GpioEventMaskType GPIO6EventMaskFan1 {
    Adm1029GpioEventMaskType get ();
    void set (Adm1029GpioEventMaskType value);
}
member GPIO6EventMaskFan1 : Adm1029GpioEventMaskType with get, set

Property Value

Type: Adm1029GpioEventMaskType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIO6EventMaskFan2 Property

IRD

Adm1029GPIO6EventMaskFan2 Property

GPIO6 Event Mask (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioEventMaskType GPIO6EventMaskFan2 { get; set; }
Public Property GPIO6EventMaskFan2 As Adm1029GpioEventMaskType
    Get
    Set
public:
property Adm1029GpioEventMaskType GPIO6EventMaskFan2 {
    Adm1029GpioEventMaskType get ();
    void set (Adm1029GpioEventMaskType value);
}
member GPIO6EventMaskFan2 : Adm1029GpioEventMaskType with get, set

Property Value

Type: Adm1029GpioEventMaskType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIOPresentAINGPIO0 Property

IRD

Adm1029GPIOPresentAINGPIO0 Property

GPIO Present/AIN (GPIO 0)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioPresent0Type GPIOPresentAINGPIO0 { get; set; }
Public Property GPIOPresentAINGPIO0 As Adm1029GpioPresent0Type
    Get
    Set
public:
property Adm1029GpioPresent0Type GPIOPresentAINGPIO0 {
    Adm1029GpioPresent0Type get ();
    void set (Adm1029GpioPresent0Type value);
}
member GPIOPresentAINGPIO0 : Adm1029GpioPresent0Type with get, set

Property Value

Type: Adm1029GpioPresent0Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIOPresentAINGPIO1 Property

IRD

Adm1029GPIOPresentAINGPIO1 Property

GPIO Present/AIN (GPIO 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioPresent1Type GPIOPresentAINGPIO1 { get; set; }
Public Property GPIOPresentAINGPIO1 As Adm1029GpioPresent1Type
    Get
    Set
public:
property Adm1029GpioPresent1Type GPIOPresentAINGPIO1 {
    Adm1029GpioPresent1Type get ();
    void set (Adm1029GpioPresent1Type value);
}
member GPIOPresentAINGPIO1 : Adm1029GpioPresent1Type with get, set

Property Value

Type: Adm1029GpioPresent1Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIOPresentAINGPIO2 Property

IRD

Adm1029GPIOPresentAINGPIO2 Property

GPIO Present/AIN (GPIO 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioPresent2Type GPIOPresentAINGPIO2 { get; set; }
Public Property GPIOPresentAINGPIO2 As Adm1029GpioPresent2Type
    Get
    Set
public:
property Adm1029GpioPresent2Type GPIOPresentAINGPIO2 {
    Adm1029GpioPresent2Type get ();
    void set (Adm1029GpioPresent2Type value);
}
member GPIOPresentAINGPIO2 : Adm1029GpioPresent2Type with get, set

Property Value

Type: Adm1029GpioPresent2Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIOPresentAINGPIO3 Property

IRD

Adm1029GPIOPresentAINGPIO3 Property

GPIO Present/AIN (GPIO 3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioPresent3Type GPIOPresentAINGPIO3 { get; set; }
Public Property GPIOPresentAINGPIO3 As Adm1029GpioPresent3Type
    Get
    Set
public:
property Adm1029GpioPresent3Type GPIOPresentAINGPIO3 {
    Adm1029GpioPresent3Type get ();
    void set (Adm1029GpioPresent3Type value);
}
member GPIOPresentAINGPIO3 : Adm1029GpioPresent3Type with get, set

Property Value

Type: Adm1029GpioPresent3Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIOPresentAINGPIO4 Property

IRD

Adm1029GPIOPresentAINGPIO4 Property

GPIO Present/AIN (GPIO 4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioPresent4Type GPIOPresentAINGPIO4 { get; set; }
Public Property GPIOPresentAINGPIO4 As Adm1029GpioPresent4Type
    Get
    Set
public:
property Adm1029GpioPresent4Type GPIOPresentAINGPIO4 {
    Adm1029GpioPresent4Type get ();
    void set (Adm1029GpioPresent4Type value);
}
member GPIOPresentAINGPIO4 : Adm1029GpioPresent4Type with get, set

Property Value

Type: Adm1029GpioPresent4Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIOPresentAINGPIO5 Property

IRD

Adm1029GPIOPresentAINGPIO5 Property

GPIO Present/AIN (GPIO 5)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioPresent5Type GPIOPresentAINGPIO5 { get; set; }
Public Property GPIOPresentAINGPIO5 As Adm1029GpioPresent5Type
    Get
    Set
public:
property Adm1029GpioPresent5Type GPIOPresentAINGPIO5 {
    Adm1029GpioPresent5Type get ();
    void set (Adm1029GpioPresent5Type value);
}
member GPIOPresentAINGPIO5 : Adm1029GpioPresent5Type with get, set

Property Value

Type: Adm1029GpioPresent5Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIOPresentAINGPIO6 Property

IRD

Adm1029GPIOPresentAINGPIO6 Property

GPIO Present/AIN (GPIO 6)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029GpioPresent6Type GPIOPresentAINGPIO6 { get; set; }
Public Property GPIOPresentAINGPIO6 As Adm1029GpioPresent6Type
    Get
    Set
public:
property Adm1029GpioPresent6Type GPIOPresentAINGPIO6 {
    Adm1029GpioPresent6Type get ();
    void set (Adm1029GpioPresent6Type value);
}
member GPIOPresentAINGPIO6 : Adm1029GpioPresent6Type with get, set

Property Value

Type: Adm1029GpioPresent6Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIOSupportedByControllerGPIO0 Property

IRD

Adm1029GPIOSupportedByControllerGPIO0 Property

GPIO Supported By Controller (GPIO 0)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029SupportedType GPIOSupportedByControllerGPIO0 { get; }
Public ReadOnly Property GPIOSupportedByControllerGPIO0 As Adm1029SupportedType
    Get
public:
property Adm1029SupportedType GPIOSupportedByControllerGPIO0 {
    Adm1029SupportedType get ();
}
member GPIOSupportedByControllerGPIO0 : Adm1029SupportedType with get

Property Value

Type: Adm1029SupportedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIOSupportedByControllerGPIO1 Property

IRD

Adm1029GPIOSupportedByControllerGPIO1 Property

GPIO Supported By Controller (GPIO 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029SupportedType GPIOSupportedByControllerGPIO1 { get; }
Public ReadOnly Property GPIOSupportedByControllerGPIO1 As Adm1029SupportedType
    Get
public:
property Adm1029SupportedType GPIOSupportedByControllerGPIO1 {
    Adm1029SupportedType get ();
}
member GPIOSupportedByControllerGPIO1 : Adm1029SupportedType with get

Property Value

Type: Adm1029SupportedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIOSupportedByControllerGPIO2 Property

IRD

Adm1029GPIOSupportedByControllerGPIO2 Property

GPIO Supported By Controller (GPIO 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029SupportedType GPIOSupportedByControllerGPIO2 { get; }
Public ReadOnly Property GPIOSupportedByControllerGPIO2 As Adm1029SupportedType
    Get
public:
property Adm1029SupportedType GPIOSupportedByControllerGPIO2 {
    Adm1029SupportedType get ();
}
member GPIOSupportedByControllerGPIO2 : Adm1029SupportedType with get

Property Value

Type: Adm1029SupportedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIOSupportedByControllerGPIO3 Property

IRD

Adm1029GPIOSupportedByControllerGPIO3 Property

GPIO Supported By Controller (GPIO 3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029SupportedType GPIOSupportedByControllerGPIO3 { get; }
Public ReadOnly Property GPIOSupportedByControllerGPIO3 As Adm1029SupportedType
    Get
public:
property Adm1029SupportedType GPIOSupportedByControllerGPIO3 {
    Adm1029SupportedType get ();
}
member GPIOSupportedByControllerGPIO3 : Adm1029SupportedType with get

Property Value

Type: Adm1029SupportedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIOSupportedByControllerGPIO4 Property

IRD

Adm1029GPIOSupportedByControllerGPIO4 Property

GPIO Supported By Controller (GPIO 4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029SupportedType GPIOSupportedByControllerGPIO4 { get; }
Public ReadOnly Property GPIOSupportedByControllerGPIO4 As Adm1029SupportedType
    Get
public:
property Adm1029SupportedType GPIOSupportedByControllerGPIO4 {
    Adm1029SupportedType get ();
}
member GPIOSupportedByControllerGPIO4 : Adm1029SupportedType with get

Property Value

Type: Adm1029SupportedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIOSupportedByControllerGPIO5 Property

IRD

Adm1029GPIOSupportedByControllerGPIO5 Property

GPIO Supported By Controller (GPIO 5)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029SupportedType GPIOSupportedByControllerGPIO5 { get; }
Public ReadOnly Property GPIOSupportedByControllerGPIO5 As Adm1029SupportedType
    Get
public:
property Adm1029SupportedType GPIOSupportedByControllerGPIO5 {
    Adm1029SupportedType get ();
}
member GPIOSupportedByControllerGPIO5 : Adm1029SupportedType with get

Property Value

Type: Adm1029SupportedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.GPIOSupportedByControllerGPIO6 Property

IRD

Adm1029GPIOSupportedByControllerGPIO6 Property

GPIO Supported By Controller (GPIO 6)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029SupportedType GPIOSupportedByControllerGPIO6 { get; }
Public ReadOnly Property GPIOSupportedByControllerGPIO6 As Adm1029SupportedType
    Get
public:
property Adm1029SupportedType GPIOSupportedByControllerGPIO6 {
    Adm1029SupportedType get ();
}
member GPIOSupportedByControllerGPIO6 : Adm1029SupportedType with get

Property Value

Type: Adm1029SupportedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.LocalTempCoolingActionFan1 Property

IRD

Adm1029LocalTempCoolingActionFan1 Property

Local Temp Cooling Action (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempCoolingActionType LocalTempCoolingActionFan1 { get; set; }
Public Property LocalTempCoolingActionFan1 As Adm1029TempCoolingActionType
    Get
    Set
public:
property Adm1029TempCoolingActionType LocalTempCoolingActionFan1 {
    Adm1029TempCoolingActionType get ();
    void set (Adm1029TempCoolingActionType value);
}
member LocalTempCoolingActionFan1 : Adm1029TempCoolingActionType with get, set

Property Value

Type: Adm1029TempCoolingActionType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.LocalTempCoolingActionFan2 Property

IRD

Adm1029LocalTempCoolingActionFan2 Property

Local Temp Cooling Action (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempCoolingActionType LocalTempCoolingActionFan2 { get; set; }
Public Property LocalTempCoolingActionFan2 As Adm1029TempCoolingActionType
    Get
    Set
public:
property Adm1029TempCoolingActionType LocalTempCoolingActionFan2 {
    Adm1029TempCoolingActionType get ();
    void set (Adm1029TempCoolingActionType value);
}
member LocalTempCoolingActionFan2 : Adm1029TempCoolingActionType with get, set

Property Value

Type: Adm1029TempCoolingActionType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.LocalTemperatureOffset Property

IRD

Adm1029LocalTemperatureOffset Property

Local Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTemperatureOffset { get; set; }
Public Property LocalTemperatureOffset As SByte
    Get
    Set
public:
property signed char LocalTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member LocalTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.LocalTempFaultActionAlarmSpeedLow Property

IRD

Adm1029LocalTempFaultActionAlarmSpeedLow Property

Local Temp Fault Action (Alarm Speed Low)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit3Type LocalTempFaultActionAlarmSpeedLow { get; set; }
Public Property LocalTempFaultActionAlarmSpeedLow As Adm1029TempFaultActionBit3Type
    Get
    Set
public:
property Adm1029TempFaultActionBit3Type LocalTempFaultActionAlarmSpeedLow {
    Adm1029TempFaultActionBit3Type get ();
    void set (Adm1029TempFaultActionBit3Type value);
}
member LocalTempFaultActionAlarmSpeedLow : Adm1029TempFaultActionBit3Type with get, set

Property Value

Type: Adm1029TempFaultActionBit3Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.LocalTempFaultActionAlarmSpeedOnOT Property

IRD

Adm1029LocalTempFaultActionAlarmSpeedOnOT Property

Local Temp Fault Action (Alarm Speed On OT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit1Type LocalTempFaultActionAlarmSpeedOnOT { get; set; }
Public Property LocalTempFaultActionAlarmSpeedOnOT As Adm1029TempFaultActionBit1Type
    Get
    Set
public:
property Adm1029TempFaultActionBit1Type LocalTempFaultActionAlarmSpeedOnOT {
    Adm1029TempFaultActionBit1Type get ();
    void set (Adm1029TempFaultActionBit1Type value);
}
member LocalTempFaultActionAlarmSpeedOnOT : Adm1029TempFaultActionBit1Type with get, set

Property Value

Type: Adm1029TempFaultActionBit1Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.LocalTempFaultActionAlarmSpeedOnUT Property

IRD

Adm1029LocalTempFaultActionAlarmSpeedOnUT Property

Local Temp Fault Action (Alarm Speed On UT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit5Type LocalTempFaultActionAlarmSpeedOnUT { get; set; }
Public Property LocalTempFaultActionAlarmSpeedOnUT As Adm1029TempFaultActionBit5Type
    Get
    Set
public:
property Adm1029TempFaultActionBit5Type LocalTempFaultActionAlarmSpeedOnUT {
    Adm1029TempFaultActionBit5Type get ();
    void set (Adm1029TempFaultActionBit5Type value);
}
member LocalTempFaultActionAlarmSpeedOnUT : Adm1029TempFaultActionBit5Type with get, set

Property Value

Type: Adm1029TempFaultActionBit5Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.LocalTempFaultActionAssertCFAULTOnOT Property

IRD

Adm1029LocalTempFaultActionAssertCFAULTOnOT Property

Local Temp Fault Action (Assert CFAULT On OT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit0Type LocalTempFaultActionAssertCFAULTOnOT { get; set; }
Public Property LocalTempFaultActionAssertCFAULTOnOT As Adm1029TempFaultActionBit0Type
    Get
    Set
public:
property Adm1029TempFaultActionBit0Type LocalTempFaultActionAssertCFAULTOnOT {
    Adm1029TempFaultActionBit0Type get ();
    void set (Adm1029TempFaultActionBit0Type value);
}
member LocalTempFaultActionAssertCFAULTOnOT : Adm1029TempFaultActionBit0Type with get, set

Property Value

Type: Adm1029TempFaultActionBit0Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.LocalTempFaultActionAssertCFAULTOnUT Property

IRD

Adm1029LocalTempFaultActionAssertCFAULTOnUT Property

Local Temp Fault Action (Assert CFAULT On UT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit4Type LocalTempFaultActionAssertCFAULTOnUT { get; set; }
Public Property LocalTempFaultActionAssertCFAULTOnUT As Adm1029TempFaultActionBit4Type
    Get
    Set
public:
property Adm1029TempFaultActionBit4Type LocalTempFaultActionAssertCFAULTOnUT {
    Adm1029TempFaultActionBit4Type get ();
    void set (Adm1029TempFaultActionBit4Type value);
}
member LocalTempFaultActionAssertCFAULTOnUT : Adm1029TempFaultActionBit4Type with get, set

Property Value

Type: Adm1029TempFaultActionBit4Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.LocalTempFaultActionINTOnOT Property

IRD

Adm1029LocalTempFaultActionINTOnOT Property

Local Temp Fault Action (INT On OT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit2Type LocalTempFaultActionINTOnOT { get; set; }
Public Property LocalTempFaultActionINTOnOT As Adm1029TempFaultActionBit2Type
    Get
    Set
public:
property Adm1029TempFaultActionBit2Type LocalTempFaultActionINTOnOT {
    Adm1029TempFaultActionBit2Type get ();
    void set (Adm1029TempFaultActionBit2Type value);
}
member LocalTempFaultActionINTOnOT : Adm1029TempFaultActionBit2Type with get, set

Property Value

Type: Adm1029TempFaultActionBit2Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.LocalTempFaultActionINTOnUT Property

IRD

Adm1029LocalTempFaultActionINTOnUT Property

Local Temp Fault Action (INT On UT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit6Type LocalTempFaultActionINTOnUT { get; set; }
Public Property LocalTempFaultActionINTOnUT As Adm1029TempFaultActionBit6Type
    Get
    Set
public:
property Adm1029TempFaultActionBit6Type LocalTempFaultActionINTOnUT {
    Adm1029TempFaultActionBit6Type get ();
    void set (Adm1029TempFaultActionBit6Type value);
}
member LocalTempFaultActionINTOnUT : Adm1029TempFaultActionBit6Type with get, set

Property Value

Type: Adm1029TempFaultActionBit6Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.LocalTempFaultActionLatchTempFault Property

IRD

Adm1029LocalTempFaultActionLatchTempFault Property

Local Temp Fault Action (Latch Temp Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit7Type LocalTempFaultActionLatchTempFault { get; set; }
Public Property LocalTempFaultActionLatchTempFault As Adm1029TempFaultActionBit7Type
    Get
    Set
public:
property Adm1029TempFaultActionBit7Type LocalTempFaultActionLatchTempFault {
    Adm1029TempFaultActionBit7Type get ();
    void set (Adm1029TempFaultActionBit7Type value);
}
member LocalTempFaultActionLatchTempFault : Adm1029TempFaultActionBit7Type with get, set

Property Value

Type: Adm1029TempFaultActionBit7Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.LocalTempHighLimit Property

IRD

Adm1029LocalTempHighLimit Property

Local Temp High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTempHighLimit { get; set; }
Public Property LocalTempHighLimit As SByte
    Get
    Set
public:
property signed char LocalTempHighLimit {
    signed char get ();
    void set (signed char value);
}
member LocalTempHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.LocalTempLowLimit Property

IRD

Adm1029LocalTempLowLimit Property

Local Temp Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTempLowLimit { get; set; }
Public Property LocalTempLowLimit As SByte
    Get
    Set
public:
property signed char LocalTempLowLimit {
    signed char get ();
    void set (signed char value);
}
member LocalTempLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.LocalTempTHYST Property

IRD

Adm1029LocalTempTHYST Property

Local Temp T_HYST (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalTempTHYST { get; set; }
Public Property LocalTempTHYST As Byte
    Get
    Set
public:
property unsigned char LocalTempTHYST {
    unsigned char get ();
    void set (unsigned char value);
}
member LocalTempTHYST : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.LocalTempTMIN Property

IRD

Adm1029LocalTempTMIN Property

Local Temp T_MIN (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTempTMIN { get; set; }
Public Property LocalTempTMIN As SByte
    Get
    Set
public:
property signed char LocalTempTMIN {
    signed char get ();
    void set (signed char value);
}
member LocalTempTMIN : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.LocalTempTRANGE Property

IRD

Adm1029LocalTempTRANGE Property

Local Temp T_RANGE (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempTRangeType LocalTempTRANGE { get; set; }
Public Property LocalTempTRANGE As Adm1029TempTRangeType
    Get
    Set
public:
property Adm1029TempTRangeType LocalTempTRANGE {
    Adm1029TempTRangeType get ();
    void set (Adm1029TempTRangeType value);
}
member LocalTempTRANGE : Adm1029TempTRangeType with get, set

Property Value

Type: Adm1029TempTRangeType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.LocalTempValue Property

IRD

Adm1029LocalTempValue Property

Local Temp Value (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTempValue { get; }
Public ReadOnly Property LocalTempValue As SByte
    Get
public:
property signed char LocalTempValue {
    signed char get ();
}
member LocalTempValue : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.MajorRevisionCode Property

IRD

Adm1029MajorRevisionCode Property

Major Revision Code

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MajorRevisionCode { get; }
Public ReadOnly Property MajorRevisionCode As Byte
    Get
public:
property unsigned char MajorRevisionCode {
    unsigned char get ();
}
member MajorRevisionCode : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.ManufacturerID Property

IRD

Adm1029ManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As Byte
    Get
public:
property unsigned char ManufacturerID {
    unsigned char get ();
}
member ManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.MinorRevisionCode Property

IRD

Adm1029MinorRevisionCode Property

Minor Revision Code

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MinorRevisionCode { get; }
Public ReadOnly Property MinorRevisionCode As Byte
    Get
public:
property unsigned char MinorRevisionCode {
    unsigned char get ();
}
member MinorRevisionCode : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote1TempCoolingActionFan1 Property

IRD

Adm1029Remote1TempCoolingActionFan1 Property

Remote 1 Temp Cooling Action (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempCoolingActionType Remote1TempCoolingActionFan1 { get; set; }
Public Property Remote1TempCoolingActionFan1 As Adm1029TempCoolingActionType
    Get
    Set
public:
property Adm1029TempCoolingActionType Remote1TempCoolingActionFan1 {
    Adm1029TempCoolingActionType get ();
    void set (Adm1029TempCoolingActionType value);
}
member Remote1TempCoolingActionFan1 : Adm1029TempCoolingActionType with get, set

Property Value

Type: Adm1029TempCoolingActionType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote1TempCoolingActionFan2 Property

IRD

Adm1029Remote1TempCoolingActionFan2 Property

Remote 1 Temp Cooling Action (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempCoolingActionType Remote1TempCoolingActionFan2 { get; set; }
Public Property Remote1TempCoolingActionFan2 As Adm1029TempCoolingActionType
    Get
    Set
public:
property Adm1029TempCoolingActionType Remote1TempCoolingActionFan2 {
    Adm1029TempCoolingActionType get ();
    void set (Adm1029TempCoolingActionType value);
}
member Remote1TempCoolingActionFan2 : Adm1029TempCoolingActionType with get, set

Property Value

Type: Adm1029TempCoolingActionType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote1TemperatureOffset Property

IRD

Adm1029Remote1TemperatureOffset Property

Remote 1 Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote1TemperatureOffset { get; set; }
Public Property Remote1TemperatureOffset As SByte
    Get
    Set
public:
property signed char Remote1TemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member Remote1TemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote1TempFaultActionAlarmSpeedLow Property

IRD

Adm1029Remote1TempFaultActionAlarmSpeedLow Property

Remote 1 Temp Fault Action (Alarm Speed Low)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit3Type Remote1TempFaultActionAlarmSpeedLow { get; set; }
Public Property Remote1TempFaultActionAlarmSpeedLow As Adm1029TempFaultActionBit3Type
    Get
    Set
public:
property Adm1029TempFaultActionBit3Type Remote1TempFaultActionAlarmSpeedLow {
    Adm1029TempFaultActionBit3Type get ();
    void set (Adm1029TempFaultActionBit3Type value);
}
member Remote1TempFaultActionAlarmSpeedLow : Adm1029TempFaultActionBit3Type with get, set

Property Value

Type: Adm1029TempFaultActionBit3Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote1TempFaultActionAlarmSpeedOnOT Property

IRD

Adm1029Remote1TempFaultActionAlarmSpeedOnOT Property

Remote 1 Temp Fault Action (Alarm Speed On OT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit1Type Remote1TempFaultActionAlarmSpeedOnOT { get; set; }
Public Property Remote1TempFaultActionAlarmSpeedOnOT As Adm1029TempFaultActionBit1Type
    Get
    Set
public:
property Adm1029TempFaultActionBit1Type Remote1TempFaultActionAlarmSpeedOnOT {
    Adm1029TempFaultActionBit1Type get ();
    void set (Adm1029TempFaultActionBit1Type value);
}
member Remote1TempFaultActionAlarmSpeedOnOT : Adm1029TempFaultActionBit1Type with get, set

Property Value

Type: Adm1029TempFaultActionBit1Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote1TempFaultActionAlarmSpeedOnUT Property

IRD

Adm1029Remote1TempFaultActionAlarmSpeedOnUT Property

Remote 1 Temp Fault Action (Alarm Speed On UT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit5Type Remote1TempFaultActionAlarmSpeedOnUT { get; set; }
Public Property Remote1TempFaultActionAlarmSpeedOnUT As Adm1029TempFaultActionBit5Type
    Get
    Set
public:
property Adm1029TempFaultActionBit5Type Remote1TempFaultActionAlarmSpeedOnUT {
    Adm1029TempFaultActionBit5Type get ();
    void set (Adm1029TempFaultActionBit5Type value);
}
member Remote1TempFaultActionAlarmSpeedOnUT : Adm1029TempFaultActionBit5Type with get, set

Property Value

Type: Adm1029TempFaultActionBit5Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote1TempFaultActionAssertCFAULTOnOT Property

IRD

Adm1029Remote1TempFaultActionAssertCFAULTOnOT Property

Remote 1 Temp Fault Action (Assert CFAULT On OT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit0Type Remote1TempFaultActionAssertCFAULTOnOT { get; set; }
Public Property Remote1TempFaultActionAssertCFAULTOnOT As Adm1029TempFaultActionBit0Type
    Get
    Set
public:
property Adm1029TempFaultActionBit0Type Remote1TempFaultActionAssertCFAULTOnOT {
    Adm1029TempFaultActionBit0Type get ();
    void set (Adm1029TempFaultActionBit0Type value);
}
member Remote1TempFaultActionAssertCFAULTOnOT : Adm1029TempFaultActionBit0Type with get, set

Property Value

Type: Adm1029TempFaultActionBit0Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote1TempFaultActionAssertCFAULTOnUT Property

IRD

Adm1029Remote1TempFaultActionAssertCFAULTOnUT Property

Remote 1 Temp Fault Action (Assert CFAULT On UT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit4Type Remote1TempFaultActionAssertCFAULTOnUT { get; set; }
Public Property Remote1TempFaultActionAssertCFAULTOnUT As Adm1029TempFaultActionBit4Type
    Get
    Set
public:
property Adm1029TempFaultActionBit4Type Remote1TempFaultActionAssertCFAULTOnUT {
    Adm1029TempFaultActionBit4Type get ();
    void set (Adm1029TempFaultActionBit4Type value);
}
member Remote1TempFaultActionAssertCFAULTOnUT : Adm1029TempFaultActionBit4Type with get, set

Property Value

Type: Adm1029TempFaultActionBit4Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote1TempFaultActionINTOnOT Property

IRD

Adm1029Remote1TempFaultActionINTOnOT Property

Remote 1 Temp Fault Action (INT On OT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit2Type Remote1TempFaultActionINTOnOT { get; set; }
Public Property Remote1TempFaultActionINTOnOT As Adm1029TempFaultActionBit2Type
    Get
    Set
public:
property Adm1029TempFaultActionBit2Type Remote1TempFaultActionINTOnOT {
    Adm1029TempFaultActionBit2Type get ();
    void set (Adm1029TempFaultActionBit2Type value);
}
member Remote1TempFaultActionINTOnOT : Adm1029TempFaultActionBit2Type with get, set

Property Value

Type: Adm1029TempFaultActionBit2Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote1TempFaultActionINTOnUT Property

IRD

Adm1029Remote1TempFaultActionINTOnUT Property

Remote 1 Temp Fault Action (INT On UT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit6Type Remote1TempFaultActionINTOnUT { get; set; }
Public Property Remote1TempFaultActionINTOnUT As Adm1029TempFaultActionBit6Type
    Get
    Set
public:
property Adm1029TempFaultActionBit6Type Remote1TempFaultActionINTOnUT {
    Adm1029TempFaultActionBit6Type get ();
    void set (Adm1029TempFaultActionBit6Type value);
}
member Remote1TempFaultActionINTOnUT : Adm1029TempFaultActionBit6Type with get, set

Property Value

Type: Adm1029TempFaultActionBit6Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote1TempFaultActionLatchTempFault Property

IRD

Adm1029Remote1TempFaultActionLatchTempFault Property

Remote 1 Temp Fault Action (Latch Temp Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit7Type Remote1TempFaultActionLatchTempFault { get; set; }
Public Property Remote1TempFaultActionLatchTempFault As Adm1029TempFaultActionBit7Type
    Get
    Set
public:
property Adm1029TempFaultActionBit7Type Remote1TempFaultActionLatchTempFault {
    Adm1029TempFaultActionBit7Type get ();
    void set (Adm1029TempFaultActionBit7Type value);
}
member Remote1TempFaultActionLatchTempFault : Adm1029TempFaultActionBit7Type with get, set

Property Value

Type: Adm1029TempFaultActionBit7Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote1TempHighLimit Property

IRD

Adm1029Remote1TempHighLimit Property

Remote 1 Temp High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote1TempHighLimit { get; set; }
Public Property Remote1TempHighLimit As SByte
    Get
    Set
public:
property signed char Remote1TempHighLimit {
    signed char get ();
    void set (signed char value);
}
member Remote1TempHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote1TempLowLimit Property

IRD

Adm1029Remote1TempLowLimit Property

Remote 1 Temp Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote1TempLowLimit { get; set; }
Public Property Remote1TempLowLimit As SByte
    Get
    Set
public:
property signed char Remote1TempLowLimit {
    signed char get ();
    void set (signed char value);
}
member Remote1TempLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote1TempTHYST Property

IRD

Adm1029Remote1TempTHYST Property

Remote 1 Temp T_HYST (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote1TempTHYST { get; set; }
Public Property Remote1TempTHYST As Byte
    Get
    Set
public:
property unsigned char Remote1TempTHYST {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote1TempTHYST : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote1TempTMIN Property

IRD

Adm1029Remote1TempTMIN Property

Remote 1 Temp T_MIN (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote1TempTMIN { get; set; }
Public Property Remote1TempTMIN As SByte
    Get
    Set
public:
property signed char Remote1TempTMIN {
    signed char get ();
    void set (signed char value);
}
member Remote1TempTMIN : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote1TempTRANGE Property

IRD

Adm1029Remote1TempTRANGE Property

Remote 1 Temp T_RANGE (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempTRangeType Remote1TempTRANGE { get; set; }
Public Property Remote1TempTRANGE As Adm1029TempTRangeType
    Get
    Set
public:
property Adm1029TempTRangeType Remote1TempTRANGE {
    Adm1029TempTRangeType get ();
    void set (Adm1029TempTRangeType value);
}
member Remote1TempTRANGE : Adm1029TempTRangeType with get, set

Property Value

Type: Adm1029TempTRangeType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote1TempValue Property

IRD

Adm1029Remote1TempValue Property

Remote 1 Temp Value (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote1TempValue { get; }
Public ReadOnly Property Remote1TempValue As SByte
    Get
public:
property signed char Remote1TempValue {
    signed char get ();
}
member Remote1TempValue : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote2TempCoolingActionFan1 Property

IRD

Adm1029Remote2TempCoolingActionFan1 Property

Remote 2 Temp Cooling Action (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempCoolingActionType Remote2TempCoolingActionFan1 { get; set; }
Public Property Remote2TempCoolingActionFan1 As Adm1029TempCoolingActionType
    Get
    Set
public:
property Adm1029TempCoolingActionType Remote2TempCoolingActionFan1 {
    Adm1029TempCoolingActionType get ();
    void set (Adm1029TempCoolingActionType value);
}
member Remote2TempCoolingActionFan1 : Adm1029TempCoolingActionType with get, set

Property Value

Type: Adm1029TempCoolingActionType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote2TempCoolingActionFan2 Property

IRD

Adm1029Remote2TempCoolingActionFan2 Property

Remote 2 Temp Cooling Action (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempCoolingActionType Remote2TempCoolingActionFan2 { get; set; }
Public Property Remote2TempCoolingActionFan2 As Adm1029TempCoolingActionType
    Get
    Set
public:
property Adm1029TempCoolingActionType Remote2TempCoolingActionFan2 {
    Adm1029TempCoolingActionType get ();
    void set (Adm1029TempCoolingActionType value);
}
member Remote2TempCoolingActionFan2 : Adm1029TempCoolingActionType with get, set

Property Value

Type: Adm1029TempCoolingActionType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote2TemperatureOffset Property

IRD

Adm1029Remote2TemperatureOffset Property

Remote 2 Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote2TemperatureOffset { get; set; }
Public Property Remote2TemperatureOffset As SByte
    Get
    Set
public:
property signed char Remote2TemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member Remote2TemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote2TempFaultActionAlarmSpeedLow Property

IRD

Adm1029Remote2TempFaultActionAlarmSpeedLow Property

Remote 2 Temp Fault Action (Alarm Speed Low)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit3Type Remote2TempFaultActionAlarmSpeedLow { get; set; }
Public Property Remote2TempFaultActionAlarmSpeedLow As Adm1029TempFaultActionBit3Type
    Get
    Set
public:
property Adm1029TempFaultActionBit3Type Remote2TempFaultActionAlarmSpeedLow {
    Adm1029TempFaultActionBit3Type get ();
    void set (Adm1029TempFaultActionBit3Type value);
}
member Remote2TempFaultActionAlarmSpeedLow : Adm1029TempFaultActionBit3Type with get, set

Property Value

Type: Adm1029TempFaultActionBit3Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote2TempFaultActionAlarmSpeedOnOT Property

IRD

Adm1029Remote2TempFaultActionAlarmSpeedOnOT Property

Remote 2 Temp Fault Action (Alarm Speed On OT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit1Type Remote2TempFaultActionAlarmSpeedOnOT { get; set; }
Public Property Remote2TempFaultActionAlarmSpeedOnOT As Adm1029TempFaultActionBit1Type
    Get
    Set
public:
property Adm1029TempFaultActionBit1Type Remote2TempFaultActionAlarmSpeedOnOT {
    Adm1029TempFaultActionBit1Type get ();
    void set (Adm1029TempFaultActionBit1Type value);
}
member Remote2TempFaultActionAlarmSpeedOnOT : Adm1029TempFaultActionBit1Type with get, set

Property Value

Type: Adm1029TempFaultActionBit1Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote2TempFaultActionAlarmSpeedOnUT Property

IRD

Adm1029Remote2TempFaultActionAlarmSpeedOnUT Property

Remote 2 Temp Fault Action (Alarm Speed On UT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit5Type Remote2TempFaultActionAlarmSpeedOnUT { get; set; }
Public Property Remote2TempFaultActionAlarmSpeedOnUT As Adm1029TempFaultActionBit5Type
    Get
    Set
public:
property Adm1029TempFaultActionBit5Type Remote2TempFaultActionAlarmSpeedOnUT {
    Adm1029TempFaultActionBit5Type get ();
    void set (Adm1029TempFaultActionBit5Type value);
}
member Remote2TempFaultActionAlarmSpeedOnUT : Adm1029TempFaultActionBit5Type with get, set

Property Value

Type: Adm1029TempFaultActionBit5Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote2TempFaultActionAssertCFAULTOnOT Property

IRD

Adm1029Remote2TempFaultActionAssertCFAULTOnOT Property

Remote 2 Temp Fault Action (Assert CFAULT On OT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit0Type Remote2TempFaultActionAssertCFAULTOnOT { get; set; }
Public Property Remote2TempFaultActionAssertCFAULTOnOT As Adm1029TempFaultActionBit0Type
    Get
    Set
public:
property Adm1029TempFaultActionBit0Type Remote2TempFaultActionAssertCFAULTOnOT {
    Adm1029TempFaultActionBit0Type get ();
    void set (Adm1029TempFaultActionBit0Type value);
}
member Remote2TempFaultActionAssertCFAULTOnOT : Adm1029TempFaultActionBit0Type with get, set

Property Value

Type: Adm1029TempFaultActionBit0Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote2TempFaultActionAssertCFAULTOnUT Property

IRD

Adm1029Remote2TempFaultActionAssertCFAULTOnUT Property

Remote 2 Temp Fault Action (Assert CFAULT On UT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit4Type Remote2TempFaultActionAssertCFAULTOnUT { get; set; }
Public Property Remote2TempFaultActionAssertCFAULTOnUT As Adm1029TempFaultActionBit4Type
    Get
    Set
public:
property Adm1029TempFaultActionBit4Type Remote2TempFaultActionAssertCFAULTOnUT {
    Adm1029TempFaultActionBit4Type get ();
    void set (Adm1029TempFaultActionBit4Type value);
}
member Remote2TempFaultActionAssertCFAULTOnUT : Adm1029TempFaultActionBit4Type with get, set

Property Value

Type: Adm1029TempFaultActionBit4Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote2TempFaultActionINTOnOT Property

IRD

Adm1029Remote2TempFaultActionINTOnOT Property

Remote 2 Temp Fault Action (INT On OT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit2Type Remote2TempFaultActionINTOnOT { get; set; }
Public Property Remote2TempFaultActionINTOnOT As Adm1029TempFaultActionBit2Type
    Get
    Set
public:
property Adm1029TempFaultActionBit2Type Remote2TempFaultActionINTOnOT {
    Adm1029TempFaultActionBit2Type get ();
    void set (Adm1029TempFaultActionBit2Type value);
}
member Remote2TempFaultActionINTOnOT : Adm1029TempFaultActionBit2Type with get, set

Property Value

Type: Adm1029TempFaultActionBit2Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote2TempFaultActionINTOnUT Property

IRD

Adm1029Remote2TempFaultActionINTOnUT Property

Remote 2 Temp Fault Action (INT On UT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit6Type Remote2TempFaultActionINTOnUT { get; set; }
Public Property Remote2TempFaultActionINTOnUT As Adm1029TempFaultActionBit6Type
    Get
    Set
public:
property Adm1029TempFaultActionBit6Type Remote2TempFaultActionINTOnUT {
    Adm1029TempFaultActionBit6Type get ();
    void set (Adm1029TempFaultActionBit6Type value);
}
member Remote2TempFaultActionINTOnUT : Adm1029TempFaultActionBit6Type with get, set

Property Value

Type: Adm1029TempFaultActionBit6Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote2TempFaultActionLatchTempFault Property

IRD

Adm1029Remote2TempFaultActionLatchTempFault Property

Remote 2 Temp Fault Action (Latch Temp Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempFaultActionBit7Type Remote2TempFaultActionLatchTempFault { get; set; }
Public Property Remote2TempFaultActionLatchTempFault As Adm1029TempFaultActionBit7Type
    Get
    Set
public:
property Adm1029TempFaultActionBit7Type Remote2TempFaultActionLatchTempFault {
    Adm1029TempFaultActionBit7Type get ();
    void set (Adm1029TempFaultActionBit7Type value);
}
member Remote2TempFaultActionLatchTempFault : Adm1029TempFaultActionBit7Type with get, set

Property Value

Type: Adm1029TempFaultActionBit7Type
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote2TempHighLimit Property

IRD

Adm1029Remote2TempHighLimit Property

Remote 2 Temp High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote2TempHighLimit { get; set; }
Public Property Remote2TempHighLimit As SByte
    Get
    Set
public:
property signed char Remote2TempHighLimit {
    signed char get ();
    void set (signed char value);
}
member Remote2TempHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote2TempLowLimit Property

IRD

Adm1029Remote2TempLowLimit Property

Remote 2 Temp Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote2TempLowLimit { get; set; }
Public Property Remote2TempLowLimit As SByte
    Get
    Set
public:
property signed char Remote2TempLowLimit {
    signed char get ();
    void set (signed char value);
}
member Remote2TempLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote2TempTHYST Property

IRD

Adm1029Remote2TempTHYST Property

Remote 2 Temp T_HYST (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote2TempTHYST { get; set; }
Public Property Remote2TempTHYST As Byte
    Get
    Set
public:
property unsigned char Remote2TempTHYST {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote2TempTHYST : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote2TempTMIN Property

IRD

Adm1029Remote2TempTMIN Property

Remote 2 Temp T_MIN (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote2TempTMIN { get; set; }
Public Property Remote2TempTMIN As SByte
    Get
    Set
public:
property signed char Remote2TempTMIN {
    signed char get ();
    void set (signed char value);
}
member Remote2TempTMIN : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote2TempTRANGE Property

IRD

Adm1029Remote2TempTRANGE Property

Remote 2 Temp T_RANGE (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029TempTRangeType Remote2TempTRANGE { get; set; }
Public Property Remote2TempTRANGE As Adm1029TempTRangeType
    Get
    Set
public:
property Adm1029TempTRangeType Remote2TempTRANGE {
    Adm1029TempTRangeType get ();
    void set (Adm1029TempTRangeType value);
}
member Remote2TempTRANGE : Adm1029TempTRangeType with get, set

Property Value

Type: Adm1029TempTRangeType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Remote2TempValue Property

IRD

Adm1029Remote2TempValue Property

Remote 2 Temp Value (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Remote2TempValue { get; }
Public ReadOnly Property Remote2TempValue As SByte
    Get
public:
property signed char Remote2TempValue {
    signed char get ();
}
member Remote2TempValue : sbyte with get

Property Value

Type: SByte
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.SetFanXAlarmSpeedFan1 Property

IRD

Adm1029SetFanXAlarmSpeedFan1 Property

Set Fan x Alarm Speed (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029SetAlarmSpeedType SetFanXAlarmSpeedFan1 { get; set; }
Public Property SetFanXAlarmSpeedFan1 As Adm1029SetAlarmSpeedType
    Get
    Set
public:
property Adm1029SetAlarmSpeedType SetFanXAlarmSpeedFan1 {
    Adm1029SetAlarmSpeedType get ();
    void set (Adm1029SetAlarmSpeedType value);
}
member SetFanXAlarmSpeedFan1 : Adm1029SetAlarmSpeedType with get, set

Property Value

Type: Adm1029SetAlarmSpeedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.SetFanXAlarmSpeedFan2 Property

IRD

Adm1029SetFanXAlarmSpeedFan2 Property

Set Fan x Alarm Speed (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029SetAlarmSpeedType SetFanXAlarmSpeedFan2 { get; set; }
Public Property SetFanXAlarmSpeedFan2 As Adm1029SetAlarmSpeedType
    Get
    Set
public:
property Adm1029SetAlarmSpeedType SetFanXAlarmSpeedFan2 {
    Adm1029SetAlarmSpeedType get ();
    void set (Adm1029SetAlarmSpeedType value);
}
member SetFanXAlarmSpeedFan2 : Adm1029SetAlarmSpeedType with get, set

Property Value

Type: Adm1029SetAlarmSpeedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.SetFanXFullSpeedFan1 Property

IRD

Adm1029SetFanXFullSpeedFan1 Property

Set Fan x Full Speed (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029SetFullSpeedType SetFanXFullSpeedFan1 { get; set; }
Public Property SetFanXFullSpeedFan1 As Adm1029SetFullSpeedType
    Get
    Set
public:
property Adm1029SetFullSpeedType SetFanXFullSpeedFan1 {
    Adm1029SetFullSpeedType get ();
    void set (Adm1029SetFullSpeedType value);
}
member SetFanXFullSpeedFan1 : Adm1029SetFullSpeedType with get, set

Property Value

Type: Adm1029SetFullSpeedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.SetFanXFullSpeedFan2 Property

IRD

Adm1029SetFanXFullSpeedFan2 Property

Set Fan x Full Speed (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029SetFullSpeedType SetFanXFullSpeedFan2 { get; set; }
Public Property SetFanXFullSpeedFan2 As Adm1029SetFullSpeedType
    Get
    Set
public:
property Adm1029SetFullSpeedType SetFanXFullSpeedFan2 {
    Adm1029SetFullSpeedType get ();
    void set (Adm1029SetFullSpeedType value);
}
member SetFanXFullSpeedFan2 : Adm1029SetFullSpeedType with get, set

Property Value

Type: Adm1029SetFullSpeedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.SetFanXHotPlugSpeedFan1 Property

IRD

Adm1029SetFanXHotPlugSpeedFan1 Property

Set Fan x Hot-Plug Speed (Fan 1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029SetHotPlugSpeedType SetFanXHotPlugSpeedFan1 { get; set; }
Public Property SetFanXHotPlugSpeedFan1 As Adm1029SetHotPlugSpeedType
    Get
    Set
public:
property Adm1029SetHotPlugSpeedType SetFanXHotPlugSpeedFan1 {
    Adm1029SetHotPlugSpeedType get ();
    void set (Adm1029SetHotPlugSpeedType value);
}
member SetFanXHotPlugSpeedFan1 : Adm1029SetHotPlugSpeedType with get, set

Property Value

Type: Adm1029SetHotPlugSpeedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.SetFanXHotPlugSpeedFan2 Property

IRD

Adm1029SetFanXHotPlugSpeedFan2 Property

Set Fan x Hot-Plug Speed (Fan 2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029SetHotPlugSpeedType SetFanXHotPlugSpeedFan2 { get; set; }
Public Property SetFanXHotPlugSpeedFan2 As Adm1029SetHotPlugSpeedType
    Get
    Set
public:
property Adm1029SetHotPlugSpeedType SetFanXHotPlugSpeedFan2 {
    Adm1029SetHotPlugSpeedType get ();
    void set (Adm1029SetHotPlugSpeedType value);
}
member SetFanXHotPlugSpeedFan2 : Adm1029SetHotPlugSpeedType with get, set

Property Value

Type: Adm1029SetHotPlugSpeedType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.StatusCFAULTIn Property

IRD

Adm1029StatusCFAULTIn Property

Status (CFAULT_in)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029BoolType StatusCFAULTIn { get; }
Public ReadOnly Property StatusCFAULTIn As Adm1029BoolType
    Get
public:
property Adm1029BoolType StatusCFAULTIn {
    Adm1029BoolType get ();
}
member StatusCFAULTIn : Adm1029BoolType with get

Property Value

Type: Adm1029BoolType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.StatusCFAULTOut Property

IRD

Adm1029StatusCFAULTOut Property

Status (CFAULT_out)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029BoolType StatusCFAULTOut { get; }
Public ReadOnly Property StatusCFAULTOut As Adm1029BoolType
    Get
public:
property Adm1029BoolType StatusCFAULTOut {
    Adm1029BoolType get ();
}
member StatusCFAULTOut : Adm1029BoolType with get

Property Value

Type: Adm1029BoolType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.StatusGPIOAINEvent Property

IRD

Adm1029StatusGPIOAINEvent Property

Status (GPIO/AIN Event)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029BoolType StatusGPIOAINEvent { get; }
Public ReadOnly Property StatusGPIOAINEvent As Adm1029BoolType
    Get
public:
property Adm1029BoolType StatusGPIOAINEvent {
    Adm1029BoolType get ();
}
member StatusGPIOAINEvent : Adm1029BoolType with get

Property Value

Type: Adm1029BoolType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.StatusHotPlugFanFault Property

IRD

Adm1029StatusHotPlugFanFault Property

Status (Hot Plug/Fan Fault)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029BoolType StatusHotPlugFanFault { get; }
Public ReadOnly Property StatusHotPlugFanFault As Adm1029BoolType
    Get
public:
property Adm1029BoolType StatusHotPlugFanFault {
    Adm1029BoolType get ();
}
member StatusHotPlugFanFault : Adm1029BoolType with get

Property Value

Type: Adm1029BoolType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.StatusInAlarmSpeed Property

IRD

Adm1029StatusInAlarmSpeed Property

Status (In Alarm_speed)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029BoolType StatusInAlarmSpeed { get; }
Public ReadOnly Property StatusInAlarmSpeed As Adm1029BoolType
    Get
public:
property Adm1029BoolType StatusInAlarmSpeed {
    Adm1029BoolType get ();
}
member StatusInAlarmSpeed : Adm1029BoolType with get

Property Value

Type: Adm1029BoolType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.StatusInHotPlugSpeed Property

IRD

Adm1029StatusInHotPlugSpeed Property

Status (In Hot-Plug Speed)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029BoolType StatusInHotPlugSpeed { get; }
Public ReadOnly Property StatusInHotPlugSpeed As Adm1029BoolType
    Get
public:
property Adm1029BoolType StatusInHotPlugSpeed {
    Adm1029BoolType get ();
}
member StatusInHotPlugSpeed : Adm1029BoolType with get

Property Value

Type: Adm1029BoolType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.StatusINT Property

IRD

Adm1029StatusINT Property

Status (INT)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029BoolType StatusINT { get; }
Public ReadOnly Property StatusINT As Adm1029BoolType
    Get
public:
property Adm1029BoolType StatusINT {
    Adm1029BoolType get ();
}
member StatusINT : Adm1029BoolType with get

Property Value

Type: Adm1029BoolType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.StatusThermalEvent Property

IRD

Adm1029StatusThermalEvent Property

Status (Thermal Event)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029BoolType StatusThermalEvent { get; }
Public ReadOnly Property StatusThermalEvent As Adm1029BoolType
    Get
public:
property Adm1029BoolType StatusThermalEvent {
    Adm1029BoolType get ();
}
member StatusThermalEvent : Adm1029BoolType with get

Property Value

Type: Adm1029BoolType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.SWReset Property

IRD

Adm1029SWReset Property

S/W Reset

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029ResetType SWReset { get; set; }
Public Property SWReset As Adm1029ResetType
    Get
    Set
public:
property Adm1029ResetType SWReset {
    Adm1029ResetType get ();
    void set (Adm1029ResetType value);
}
member SWReset : Adm1029ResetType with get, set

Property Value

Type: Adm1029ResetType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.TempDevicesInstalledLocalTemp Property

IRD

Adm1029TempDevicesInstalledLocalTemp Property

Temp Devices Installed (Local Temp)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029InstalledType TempDevicesInstalledLocalTemp { get; }
Public ReadOnly Property TempDevicesInstalledLocalTemp As Adm1029InstalledType
    Get
public:
property Adm1029InstalledType TempDevicesInstalledLocalTemp {
    Adm1029InstalledType get ();
}
member TempDevicesInstalledLocalTemp : Adm1029InstalledType with get

Property Value

Type: Adm1029InstalledType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.TempDevicesInstalledRemote1Temp Property

IRD

Adm1029TempDevicesInstalledRemote1Temp Property

Temp Devices Installed (Remote 1 Temp)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029InstalledType TempDevicesInstalledRemote1Temp { get; }
Public ReadOnly Property TempDevicesInstalledRemote1Temp As Adm1029InstalledType
    Get
public:
property Adm1029InstalledType TempDevicesInstalledRemote1Temp {
    Adm1029InstalledType get ();
}
member TempDevicesInstalledRemote1Temp : Adm1029InstalledType with get

Property Value

Type: Adm1029InstalledType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.TempDevicesInstalledRemote2Temp Property

IRD

Adm1029TempDevicesInstalledRemote2Temp Property

Temp Devices Installed (Remote 2 Temp)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1029InstalledType TempDevicesInstalledRemote2Temp { get; }
Public ReadOnly Property TempDevicesInstalledRemote2Temp As Adm1029InstalledType
    Get
public:
property Adm1029InstalledType TempDevicesInstalledRemote2Temp {
    Adm1029InstalledType get ();
}
member TempDevicesInstalledRemote2Temp : Adm1029InstalledType with get

Property Value

Type: Adm1029InstalledType
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029 Methods

The Adm1029 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.Flush Method

IRD

Adm1029Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adm1029 Class
telos.Ird.AnalogDevices Namespace


Adm1029.AinBehaviourBit0Type Enumeration

IRD

Adm1029AinBehaviourBit0Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AinBehaviourBit0Type
Public Enumeration AinBehaviourBit0Type
public enum class AinBehaviourBit0Type
type AinBehaviourBit0Type
Members
Member name | Value | Description
AINAINHighLimitCFAULTAsserted | 1 | AIN > AIN High Limit: CFAULT Asserted
AINAINHighLimitCFAULTNotAsserted | 0 | AIN > AIN High Limit: CFAULT Not Asserted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.AinBehaviourBit1Type Enumeration

IRD

Adm1029AinBehaviourBit1Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AinBehaviourBit1Type
Public Enumeration AinBehaviourBit1Type
public enum class AinBehaviourBit1Type
type AinBehaviourBit1Type
Members
Member name | Value | Description
AINAINHighLimitFanSRunAtAlarmSpeed | 1 | AIN > AIN High Limit: Fan(s) Run At Alarm Speed
AINAINHighLimitFanSDoNotRunAtAlarmSpeed | 0 | AIN > AIN High Limit: Fan(s) Do Not Run At Alarm Speed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.AinBehaviourBit2Type Enumeration

IRD

Adm1029AinBehaviourBit2Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AinBehaviourBit2Type
Public Enumeration AinBehaviourBit2Type
public enum class AinBehaviourBit2Type
type AinBehaviourBit2Type
Members
Member name | Value | Description
AINAINHighLimitINTAsserted | 1 | AIN > AIN High Limit: INT Asserted
AINAINHighLimitINTNotAsserted | 0 | AIN > AIN High Limit: INT Not Asserted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.AinBehaviourBit3Type Enumeration

IRD

Adm1029AinBehaviourBit3Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AinBehaviourBit3Type
Public Enumeration AinBehaviourBit3Type
public enum class AinBehaviourBit3Type
type AinBehaviourBit3Type
Members
Member name | Value | Description
AINAboveLowLimitAlarm | 1 | AIN Above Low Limit: Alarm
AINBelowLowLimitAlarm | 0 | AIN Below Low Limit: Alarm
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.AinBehaviourBit4Type Enumeration

IRD

Adm1029AinBehaviourBit4Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AinBehaviourBit4Type
Public Enumeration AinBehaviourBit4Type
public enum class AinBehaviourBit4Type
type AinBehaviourBit4Type
Members
Member name | Value | Description
AINAINHighLimitCFAULTAsserted | 1 | AIN < AIN High Limit: CFAULT Asserted
AINAINHighLimitCFAULTNotAsserted | 0 | AIN < AIN High Limit: CFAULT Not Asserted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.AinBehaviourBit5Type Enumeration

IRD

Adm1029AinBehaviourBit5Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AinBehaviourBit5Type
Public Enumeration AinBehaviourBit5Type
public enum class AinBehaviourBit5Type
type AinBehaviourBit5Type
Members
Member name | Value | Description
AINAINHighLimitFanSRunAtAlarmSpeed | 1 | AIN < AIN High Limit: Fan(s) Run At Alarm Speed
AINAINHighLimitFanSDoNotRunAtAlarmSpeed | 0 | AIN < AIN High Limit: Fan(s) Do Not Run At Alarm Speed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.AinBehaviourBit6Type Enumeration

IRD

Adm1029AinBehaviourBit6Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AinBehaviourBit6Type
Public Enumeration AinBehaviourBit6Type
public enum class AinBehaviourBit6Type
type AinBehaviourBit6Type
Members
Member name | Value | Description
AINAINHighLimitINTAsserted | 1 | AIN < AIN High Limit: INT Asserted
AINAINHighLimitINTNotAsserted | 0 | AIN < AIN High Limit: INT Not Asserted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.AinBehaviourBit7Type Enumeration

IRD

Adm1029AinBehaviourBit7Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AinBehaviourBit7Type
Public Enumeration AinBehaviourBit7Type
public enum class AinBehaviourBit7Type
type AinBehaviourBit7Type
Members
Member name | Value | Description
AINOutOfLimitEvent | 1 | AIN Out-Of-Limit Event
AINInLimit | 0 | AIN In-Limit
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.AinEventMaskType Enumeration

IRD

Adm1029AinEventMaskType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AinEventMaskType
Public Enumeration AinEventMaskType
public enum class AinEventMaskType
type AinEventMaskType
Members
Member name | Value | Description
Enabled | 1 | Enabled
Masked | 0 | Masked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.BoolType Enumeration

IRD

Adm1029BoolType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum BoolType
Public Enumeration BoolType
public enum class BoolType
type BoolType
Members
Member name | Value | Description
True | 1 | True
False | 0 | False
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.ConfigAraType Enumeration

IRD

Adm1029ConfigAraType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigAraType
Public Enumeration ConfigAraType
public enum class ConfigAraType
type ConfigAraType
Members
Member name | Value | Description
SMBusAlertResponseAddressDisabled | 1 | SMBus Alert Response Address: Disabled
SMBusAlterResponseAddressEnabled | 0 | SMBus Alter Response Address: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.ConfigForceCfaultType Enumeration

IRD

Adm1029ConfigForceCfaultType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigForceCfaultType
Public Enumeration ConfigForceCfaultType
public enum class ConfigForceCfaultType
type ConfigForceCfaultType
Members
Member name | Value | Description
CFAULTAsserted | 1 | CFAULT: Asserted
CFAULTNotAsserted | 0 | CFAULT: Not Asserted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.ConfigForceIntType Enumeration

IRD

Adm1029ConfigForceIntType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigForceIntType
Public Enumeration ConfigForceIntType
public enum class ConfigForceIntType
type ConfigForceIntType
Members
Member name | Value | Description
INTAsserted | 1 | INT: Asserted
INTNotAsserted | 0 | INT: Not Asserted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.ConfigFreeWheelType Enumeration

IRD

Adm1029ConfigFreeWheelType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigFreeWheelType
Public Enumeration ConfigFreeWheelType
public enum class ConfigFreeWheelType
type ConfigFreeWheelType
Members
Member name | Value | Description
Running | 1 | Running
Completed | 0 | Completed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.ConfigInstallType Enumeration

IRD

Adm1029ConfigInstallType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigInstallType
Public Enumeration ConfigInstallType
public enum class ConfigInstallType
type ConfigInstallType
Members
Member name | Value | Description
Register0x03Bit11 | 1 | Register 0x03 Bit 1: 1
Register0x03Bit10 | 0 | Register 0x03 Bit 1: 0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.ConfigIntPolarityType Enumeration

IRD

Adm1029ConfigIntPolarityType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigIntPolarityType
Public Enumeration ConfigIntPolarityType
public enum class ConfigIntPolarityType
type ConfigIntPolarityType
Members
Member name | Value | Description
INTPolarityAssertedHigh | 1 | INT Polarity (Asserted): High
INTPolarityAssertedLow | 0 | INT Polarity (Asserted): Low
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.ConfigIntType Enumeration

IRD

Adm1029ConfigIntType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigIntType
Public Enumeration ConfigIntType
public enum class ConfigIntType
type ConfigIntType
Members
Member name | Value | Description
INTOutputDisabled | 1 | INT Output: Disabled
INTOutputEnabled | 0 | INT Output: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.ConfigStartMonitoringType Enumeration

IRD

Adm1029ConfigStartMonitoringType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigStartMonitoringType
Public Enumeration ConfigStartMonitoringType
public enum class ConfigStartMonitoringType
type ConfigStartMonitoringType
Members
Member name | Value | Description
RoundRobinMonitoring | 1 | Round Robin Monitoring
AllFansRunAtAlarmSpeed | 0 | All Fans Run At Alarm Speed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FanConfigOscillatorType Enumeration

IRD

Adm1029FanConfigOscillatorType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FanConfigOscillatorType
Public Enumeration FanConfigOscillatorType
public enum class FanConfigOscillatorType
type FanConfigOscillatorType
Members
Member name | Value | Description
MeasurementDisabled | 0 | Measurement Disabled
Value_470Hz | 1 | 470 Hz
Value_940Hz | 2 | 940 Hz
Value_1880Hz | 3 | 1880 Hz
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FanConfigPwmType Enumeration

IRD

Adm1029FanConfigPwmType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FanConfigPwmType
Public Enumeration FanConfigPwmType
public enum class FanConfigPwmType
type FanConfigPwmType
Members
Member name | Value | Description
Value_15_625 | 0 | 15.625
Value_62_5 | 1 | 62.5
Value_250 | 2 | 250
Value_1000 | 3 | 1000
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FanEventMask1Type Enumeration

IRD

Adm1029FanEventMask1Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FanEventMask1Type
Public Enumeration FanEventMask1Type
public enum class FanEventMask1Type
type FanEventMask1Type
Members
Member name | Value | Description
FaultOnFanFan1AlarmSpeed | 1 | Fault On Fan: Fan 1 Alarm Speed
FaultOnFanDefault | 0 | Fault On Fan: Default
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FanEventMask2Type Enumeration

IRD

Adm1029FanEventMask2Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FanEventMask2Type
Public Enumeration FanEventMask2Type
public enum class FanEventMask2Type
type FanEventMask2Type
Members
Member name | Value | Description
FaultOnFanFan2AlarmSpeed | 1 | Fault On Fan: Fan 2 Alarm Speed
FaultOnFanDefault | 0 | Fault On Fan: Default
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FanSpeedType Enumeration

IRD

Adm1029FanSpeedType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FanSpeedType
Public Enumeration FanSpeedType
public enum class FanSpeedType
type FanSpeedType
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_7 | 1 | 7
Value_14 | 2 | 14
Value_20 | 3 | 20
Value_27 | 4 | 27
Value_33 | 5 | 33
Value_40 | 6 | 40
Value_47 | 7 | 47
Value_53 | 8 | 53
Value_60 | 9 | 60
Value_67 | 10 | 67
Value_73 | 11 | 73
Value_80 | 12 | 80
Value_87 | 13 | 87
Value_93 | 14 | 93
Value_100 | 15 | 100
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FanSpinUpDisableType Enumeration

IRD

Adm1029FanSpinUpDisableType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FanSpinUpDisableType
Public Enumeration FanSpinUpDisableType
public enum class FanSpinUpDisableType
type FanSpinUpDisableType
Members
Member name | Value | Description
FanSpinUpDisabled | 1 | Fan Spin-Up: Disabled
FanSpinUpEnabled | 0 | Fan Spin-Up: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FanSpinUpTimeType Enumeration

IRD

Adm1029FanSpinUpTimeType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FanSpinUpTimeType
Public Enumeration FanSpinUpTimeType
public enum class FanSpinUpTimeType
type FanSpinUpTimeType
Members
Member name | Value | Description
Value_16Seconds | 0 | 16 seconds
Value_8Seconds | 1 | 8 seconds
Value_4Seconds | 2 | 4 seconds
Value_2Seconds | 3 | 2 seconds
Value_1Seconds | 4 | 1 seconds
Value_025Seconds | 5 | 0.25 seconds
Value_116Seconds | 6 | 1/16 seconds
Value_164Seconds | 7 | 1/64 seconds
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FanStatusFaultType Enumeration

IRD

Adm1029FanStatusFaultType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FanStatusFaultType
Public Enumeration FanStatusFaultType
public enum class FanStatusFaultType
type FanStatusFaultType
Members
Member name | Value | Description
FanOK | 1 | Fan: OK
FanFault | 0 | Fan: Fault
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FanStatusHotPlugType Enumeration

IRD

Adm1029FanStatusHotPlugType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FanStatusHotPlugType
Public Enumeration FanStatusHotPlugType
public enum class FanStatusHotPlugType
type FanStatusHotPlugType
Members
Member name | Value | Description
FanHotPlugSpeed | 1 | Fan: Hot-Plug Speed
FanAlarmSpeed | 0 | Fan: Alarm Speed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FanStatusMissingType Enumeration

IRD

Adm1029FanStatusMissingType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FanStatusMissingType
Public Enumeration FanStatusMissingType
public enum class FanStatusMissingType
type FanStatusMissingType
Members
Member name | Value | Description
FanMissing | 1 | Fan: Missing
FanInstalled | 0 | Fan: Installed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FanStatusSleepType Enumeration

IRD

Adm1029FanStatusSleepType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FanStatusSleepType
Public Enumeration FanStatusSleepType
public enum class FanStatusSleepType
type FanStatusSleepType
Members
Member name | Value | Description
FanStopped | 1 | Fan: Stopped
FanDefault | 0 | Fan: Default
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FaultAction0Type Enumeration

IRD

Adm1029FaultAction0Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultAction0Type
Public Enumeration FaultAction0Type
public enum class FaultAction0Type
type FaultAction0Type
Members
Member name | Value | Description
FaultCFAULTAsserted | 1 | Fault: CFAULT Asserted
FaultCFAULTNotAsserted | 0 | Fault: CFAULT Not Asserted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FaultAction1Type Enumeration

IRD

Adm1029FaultAction1Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultAction1Type
Public Enumeration FaultAction1Type
public enum class FaultAction1Type
type FaultAction1Type
Members
Member name | Value | Description
FaultINTAsserted | 1 | Fault: INT Asserted
FaultINTNotAsserted | 0 | Fault: INT Not Asserted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FaultAction2Type Enumeration

IRD

Adm1029FaultAction2Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultAction2Type
Public Enumeration FaultAction2Type
public enum class FaultAction2Type
type FaultAction2Type
Members
Member name | Value | Description
HotUnplugCFAULTAsserted | 1 | Hot Unplug: CFAULT Asserted
HotUnplugCFAULTNotAsserted | 0 | Hot Unplug: CFAULT Not Asserted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FaultAction3Type Enumeration

IRD

Adm1029FaultAction3Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultAction3Type
Public Enumeration FaultAction3Type
public enum class FaultAction3Type
type FaultAction3Type
Members
Member name | Value | Description
HotUnplugINTAsserted | 1 | Hot Unplug: INT Asserted
HotUnplugINTNotAsserted | 0 | Hot Unplug: INT Not Asserted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FaultAction4Type Enumeration

IRD

Adm1029FaultAction4Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultAction4Type
Public Enumeration FaultAction4Type
public enum class FaultAction4Type
type FaultAction4Type
Members
Member name | Value | Description
OvertemperatureOverride | 1 | Overtemperature: Override
OvertemperatureNoOverride | 0 | Overtemperature: No Override
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FaultAction5Type Enumeration

IRD

Adm1029FaultAction5Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultAction5Type
Public Enumeration FaultAction5Type
public enum class FaultAction5Type
type FaultAction5Type
Members
Member name | Value | Description
FaultPin223DrivenLow | 1 | Fault: Pin 2/23 Driven Low
FaultPin223NotDrivenLow | 0 | Fault: Pin 2/23 Not Driven Low
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FaultAction6Type Enumeration

IRD

Adm1029FaultAction6Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultAction6Type
Public Enumeration FaultAction6Type
public enum class FaultAction6Type
type FaultAction6Type
Members
Member name | Value | Description
CFAULTPulledLowExternallyHotPlugSpeed | 1 | CFAULT Pulled Low Externally: Hot-Plug Speed
CFAULTPulledLowExternallyDefault | 0 | CFAULT Pulled Low Externally: Default
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.FaultAction7Type Enumeration

IRD

Adm1029FaultAction7Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultAction7Type
Public Enumeration FaultAction7Type
public enum class FaultAction7Type
type FaultAction7Type
Members
Member name | Value | Description
CFAULTPulledLowExternallyAlarmSpeed | 1 | CFAULT Pulled Low Externally: Alarm Speed
CFAULTPulledLowExternallyDefault | 0 | CFAULT Pulled Low Externally: Default
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.GpioBehaviourDirectionType Enumeration

IRD

Adm1029GpioBehaviourDirectionType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum GpioBehaviourDirectionType
Public Enumeration GpioBehaviourDirectionType
public enum class GpioBehaviourDirectionType
type GpioBehaviourDirectionType
Members
Member name | Value | Description
Input | 1 | Input
Output | 0 | Output
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.GpioBehaviourPolarityType Enumeration

IRD

Adm1029GpioBehaviourPolarityType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum GpioBehaviourPolarityType
Public Enumeration GpioBehaviourPolarityType
public enum class GpioBehaviourPolarityType
type GpioBehaviourPolarityType
Members
Member name | Value | Description
ActiveHigh | 1 | Active High
ActiveLow | 0 | Active Low
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.GpioBehaviourSetType Enumeration

IRD

Adm1029GpioBehaviourSetType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum GpioBehaviourSetType
Public Enumeration GpioBehaviourSetType
public enum class GpioBehaviourSetType
type GpioBehaviourSetType
Members
Member name | Value | Description
Set | 1 | Set
NotSet | 0 | Not Set
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.GpioEventMaskType Enumeration

IRD

Adm1029GpioEventMaskType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum GpioEventMaskType
Public Enumeration GpioEventMaskType
public enum class GpioEventMaskType
type GpioEventMaskType
Members
Member name | Value | Description
Enabled | 1 | Enabled
Masked | 0 | Masked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.GpioPresent0Type Enumeration

IRD

Adm1029GpioPresent0Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum GpioPresent0Type
Public Enumeration GpioPresent0Type
public enum class GpioPresent0Type
type GpioPresent0Type
Members
Member name | Value | Description
GPIO0 | 1 | GPIO0
AIN0 | 0 | AIN0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.GpioPresent1Type Enumeration

IRD

Adm1029GpioPresent1Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum GpioPresent1Type
Public Enumeration GpioPresent1Type
public enum class GpioPresent1Type
type GpioPresent1Type
Members
Member name | Value | Description
GPIO1 | 1 | GPIO1
AIN1 | 0 | AIN1
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.GpioPresent2Type Enumeration

IRD

Adm1029GpioPresent2Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum GpioPresent2Type
Public Enumeration GpioPresent2Type
public enum class GpioPresent2Type
type GpioPresent2Type
Members
Member name | Value | Description
GPIO2 | 1 | GPIO2
NotUsed | 0 | Not Used
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.GpioPresent3Type Enumeration

IRD

Adm1029GpioPresent3Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum GpioPresent3Type
Public Enumeration GpioPresent3Type
public enum class GpioPresent3Type
type GpioPresent3Type
Members
Member name | Value | Description
GPIO3 | 1 | GPIO3
TDM1 | 0 | TDM1
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.GpioPresent4Type Enumeration

IRD

Adm1029GpioPresent4Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum GpioPresent4Type
Public Enumeration GpioPresent4Type
public enum class GpioPresent4Type
type GpioPresent4Type
Members
Member name | Value | Description
GPIO4 | 1 | GPIO4
TDM1 | 0 | TDM1
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.GpioPresent5Type Enumeration

IRD

Adm1029GpioPresent5Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum GpioPresent5Type
Public Enumeration GpioPresent5Type
public enum class GpioPresent5Type
type GpioPresent5Type
Members
Member name | Value | Description
GPIO5 | 1 | GPIO5
TDM2 | 0 | TDM2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.GpioPresent6Type Enumeration

IRD

Adm1029GpioPresent6Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum GpioPresent6Type
Public Enumeration GpioPresent6Type
public enum class GpioPresent6Type
type GpioPresent6Type
Members
Member name | Value | Description
GPIO6 | 1 | GPIO6
TDM2 | 0 | TDM2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.InstalledType Enumeration

IRD

Adm1029InstalledType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum InstalledType
Public Enumeration InstalledType
public enum class InstalledType
type InstalledType
Members
Member name | Value | Description
Installed | 1 | Installed
NotInstalled | 0 | Not Installed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.ResetType Enumeration

IRD

Adm1029ResetType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ResetType
Public Enumeration ResetType
public enum class ResetType
type ResetType
Members
Member name | Value | Description
Reset | 166 | Reset
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.SetAlarmSpeedType Enumeration

IRD

Adm1029SetAlarmSpeedType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SetAlarmSpeedType
Public Enumeration SetAlarmSpeedType
public enum class SetAlarmSpeedType
type SetAlarmSpeedType
Members
Member name | Value | Description
AlarmSpeed | 1 | Alarm Speed
DefaultSpeed | 0 | Default Speed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.SetFullSpeedType Enumeration

IRD

Adm1029SetFullSpeedType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SetFullSpeedType
Public Enumeration SetFullSpeedType
public enum class SetFullSpeedType
type SetFullSpeedType
Members
Member name | Value | Description
FullSpeed | 1 | Full Speed
DefaultSpeed | 0 | Default Speed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.SetHotPlugSpeedType Enumeration

IRD

Adm1029SetHotPlugSpeedType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SetHotPlugSpeedType
Public Enumeration SetHotPlugSpeedType
public enum class SetHotPlugSpeedType
type SetHotPlugSpeedType
Members
Member name | Value | Description
HotPlugSpeed | 1 | Hot-Plug Speed
DefaultSpeed | 0 | Default Speed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.SupportedType Enumeration

IRD

Adm1029SupportedType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SupportedType
Public Enumeration SupportedType
public enum class SupportedType
type SupportedType
Members
Member name | Value | Description
Supported | 1 | Supported
NotSupported | 0 | Not Supported
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.TempCoolingActionType Enumeration

IRD

Adm1029TempCoolingActionType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TempCoolingActionType
Public Enumeration TempCoolingActionType
public enum class TempCoolingActionType
type TempCoolingActionType
Members
Member name | Value | Description
Set | 1 | Set
NotSet | 0 | Not Set
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.TempFaultActionBit0Type Enumeration

IRD

Adm1029TempFaultActionBit0Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TempFaultActionBit0Type
Public Enumeration TempFaultActionBit0Type
public enum class TempFaultActionBit0Type
type TempFaultActionBit0Type
Members
Member name | Value | Description
TempTempHighLimitCFAULTAsserted | 1 | Temp > Temp High Limit: CFAULT Asserted
TempTempHighLimitCFAULTNotAsserted | 0 | Temp > Temp High Limit: CFAULT Not Asserted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.TempFaultActionBit1Type Enumeration

IRD

Adm1029TempFaultActionBit1Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TempFaultActionBit1Type
Public Enumeration TempFaultActionBit1Type
public enum class TempFaultActionBit1Type
type TempFaultActionBit1Type
Members
Member name | Value | Description
TempTempHighLimitFanSRunAtAlarmSpeed | 1 | Temp > Temp High Limit: Fan(s) Run At Alarm Speed
TempTempHighLimitFanSDoNotRunAtAlarmSpeed | 0 | Temp > Temp High Limit: Fan(s) Do Not Run At Alarm Speed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.TempFaultActionBit2Type Enumeration

IRD

Adm1029TempFaultActionBit2Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TempFaultActionBit2Type
Public Enumeration TempFaultActionBit2Type
public enum class TempFaultActionBit2Type
type TempFaultActionBit2Type
Members
Member name | Value | Description
TempTempHighLimitINTAsserted | 1 | Temp > Temp High Limit: INT Asserted
TempTempHighLimitINTNotAsserted | 0 | Temp > Temp High Limit: INT Not Asserted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.TempFaultActionBit3Type Enumeration

IRD

Adm1029TempFaultActionBit3Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TempFaultActionBit3Type
Public Enumeration TempFaultActionBit3Type
public enum class TempFaultActionBit3Type
type TempFaultActionBit3Type
Members
Member name | Value | Description
TempAboveLowLimitAlarm | 1 | Temp Above Low Limit: Alarm
TempBelowLowLimitAlarm | 0 | Temp Below Low Limit: Alarm
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.TempFaultActionBit4Type Enumeration

IRD

Adm1029TempFaultActionBit4Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TempFaultActionBit4Type
Public Enumeration TempFaultActionBit4Type
public enum class TempFaultActionBit4Type
type TempFaultActionBit4Type
Members
Member name | Value | Description
TempTempLowLimitCFAULTAsserted | 1 | Temp < Temp Low Limit: CFAULT Asserted
TempTempLowLimitCFAULTNotAsserted | 0 | Temp < Temp Low Limit: CFAULT Not Asserted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.TempFaultActionBit5Type Enumeration

IRD

Adm1029TempFaultActionBit5Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TempFaultActionBit5Type
Public Enumeration TempFaultActionBit5Type
public enum class TempFaultActionBit5Type
type TempFaultActionBit5Type
Members
Member name | Value | Description
TempTempLowLimitFanSRunAtAlarmSpeed | 1 | Temp < Temp Low Limit: Fan(s) Run At Alarm Speed
TempTempLowLimitFanSDoNotRunAtAlarmSpeed | 0 | Temp < Temp Low Limit: Fan(s) Do Not Run At Alarm Speed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.TempFaultActionBit6Type Enumeration

IRD

Adm1029TempFaultActionBit6Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TempFaultActionBit6Type
Public Enumeration TempFaultActionBit6Type
public enum class TempFaultActionBit6Type
type TempFaultActionBit6Type
Members
Member name | Value | Description
TempTempLowLimitINTAsserted | 1 | Temp < Temp Low Limit: INT Asserted
TempTempLowLimitINTNotAsserted | 0 | Temp < Temp Low Limit: INT Not Asserted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.TempFaultActionBit7Type Enumeration

IRD

Adm1029TempFaultActionBit7Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TempFaultActionBit7Type
Public Enumeration TempFaultActionBit7Type
public enum class TempFaultActionBit7Type
type TempFaultActionBit7Type
Members
Member name | Value | Description
TempOutOfLimitEvent | 1 | Temp Out-Of-Limit Event
TempInLimit | 0 | Temp In-Limit
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.TempTRangeType Enumeration

IRD

Adm1029TempTRangeType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TempTRangeType
Public Enumeration TempTRangeType
public enum class TempTRangeType
type TempTRangeType
Members
Member name | Value | Description
Value_5 | 0 | 5
Value_10 | 1 | 10
Value_20 | 2 | 20
Value_40 | 3 | 40
Value_80 | 4 | 80
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1029.UsedType Enumeration

IRD

Adm1029UsedType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum UsedType
Public Enumeration UsedType
public enum class UsedType
type UsedType
Members
Member name | Value | Description
Used | 1 | Used
NotUsed | 0 | Not Used
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1033 Class

Analog Devices: ADM 1033
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdm1033

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adm1033
Public Class Adm1033
public ref class Adm1033
type Adm1033 =  class end

The Adm1033 type exposes the following members.

Constructors
 | Name | Description
Public method | Adm1033 | Constructor
Top
Properties
 | Name | Description
Public property | ALERTLow | ALERT Low
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AveragingOff | Averaging Off
Public property | BoostDisable | Boost Disable
Public property | ChannelSelector | Channel Selector
Public property | CompanyID | Company ID
Public property | ConversionRate | Conversion Rate (unit: conversions/s)
Public property | DeviceID | Device ID
Public property | DiscreteLinearRPM | Discrete/Linear RPM
Public property | DRIVEBHVR | DRIVE BHVR
Public property | EnableLocalTHERMEvents | Enable Local THERM Events
Public property | EnableRemoteTHERMEvents | Enable Remote THERM Events
Public property | EnableTHERMTimer | Enable THERM Timer
Public property | FanAlarmSpeed | Fan Alarm Speed
Public property | FanAlarmSpeed__1 | Fan Alarm Speed
Public property | FANFAULTREF | FAN_FAULT REF
Public property | FanOff | Fan Off
Public property | FanResponse | Fan Response (unit: updates/s)
Public property | FanStalled | Fan Stalled
Public property | FanStalled__1 | Fan Stalled
Public property | FaultQueue | Fault Queue
Public property | LocalHighLimit | Local High Limit (unit: °C)
Public property | LocalLowLimit | Local Low Limit (unit: °C)
Public property | LocalOffset | Local Offset (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | LocalTempHigh | Local Temp High
Public property | LocalTempHigh__1 | Local Temp High
Public property | LocalTempLow | Local Temp Low
Public property | LocalTempLow__1 | Local Temp Low
Public property | LocalTHERM | Local THERM
Public property | LocalTHERMLimit | Local THERM Limit (unit: °C)
Public property | LockBit | Lock Bit
Public property | LookUpTableFanSpeed1 | Look-Up Table, Fan Speed 1
Public property | LookUpTableFanSpeed2 | Look-Up Table, Fan Speed 2
Public property | LookUpTableFanSpeed3 | Look-Up Table, Fan Speed 3
Public property | LookUpTableFanSpeed4 | Look-Up Table, Fan Speed 4
Public property | LookUpTableFanSpeed5 | Look-Up Table, Fan Speed 5
Public property | LookUpTableFanSpeed6 | Look-Up Table, Fan Speed 6
Public property | LookUpTableFanSpeed7 | Look-Up Table, Fan Speed 7
Public property | LookUpTableFanSpeed8 | Look-Up Table, Fan Speed 8
Public property | LookUpTableT1 | Look-Up Table T1 (unit: °C)
Public property | LookUpTableT2 | Look-Up Table T2 (unit: °C)
Public property | LookUpTableT3 | Look-Up Table T3 (unit: °C)
Public property | LookUpTableT4 | Look-Up Table T4 (unit: °C)
Public property | LookUpTableT5 | Look-Up Table T5 (unit: °C)
Public property | LookUpTableT6 | Look-Up Table T6 (unit: °C)
Public property | LookUpTableT7 | Look-Up Table T7 (unit: °C)
Public property | LookUpTableT8 | Look-Up Table T8 (unit: °C)
Public property | LoopUpTableHysteresis | Loop-Up Table Hysteresis (unit: °C)
Public property | MonitorSTBY | Monitor/STBY
Public property | PolesFan | #Poles Fan
Public property | RemoteDiodeError | Remote Diode Error
Public property | RemoteDiodeError__1 | Remote Diode Error
Public property | RemoteHighLimit | Remote High Limit (unit: °C)
Public property | RemoteLowLimit | Remote Low Limit (unit: °C)
Public property | RemoteOffset | Remote Offset (unit: °C)
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | RemoteTempHigh | Remote Temp High
Public property | RemoteTempHigh__1 | Remote Temp High
Public property | RemoteTempLow | Remote Temp Low
Public property | RemoteTempLow__1 | Remote Temp Low
Public property | RemoteTHERM | Remote THERM
Public property | RemoteTHERMLimit | Remote THERM Limit (unit: °C)
Public property | RevisionID | Revision ID
Public property | RoundRobin | Round Robin
Public property | SCLTimeout | SCL Timeout
Public property | SDATimeout | SDA Timeout
Public property | SWCon | SW Con
Public property | SWReset | SW Reset
Public property | TACHPeriod | TACH Period
Public property | THERM | THERM %
Public property | THERMAssert | THERM Assert
Public property | THERMAsserted | THERM Asserted
Public property | THERMExceeded | THERM % Exceeded
Public property | THERMHysteresis | THERM Hysteresis (unit: °C)
Public property | THERMOnTime | THERM % On-Time (unit: %)
Public property | THERMState | THERM State
Public property | THERMState__1 | THERM State
Public property | THERMTimerLimit | THERM Timer % Limit (unit: %)
Public property | THERMTimeWindow | THERM % Time Window (unit: s)
Public property | XORTest | XOR Test
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Thermal Monitor And Fan Speed Controller
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1033 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adm1033(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adm1033

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033 Properties

The Adm1033 type exposes the following members.

Properties
 | Name | Description
Public property | ALERTLow | ALERT Low
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AveragingOff | Averaging Off
Public property | BoostDisable | Boost Disable
Public property | ChannelSelector | Channel Selector
Public property | CompanyID | Company ID
Public property | ConversionRate | Conversion Rate (unit: conversions/s)
Public property | DeviceID | Device ID
Public property | DiscreteLinearRPM | Discrete/Linear RPM
Public property | DRIVEBHVR | DRIVE BHVR
Public property | EnableLocalTHERMEvents | Enable Local THERM Events
Public property | EnableRemoteTHERMEvents | Enable Remote THERM Events
Public property | EnableTHERMTimer | Enable THERM Timer
Public property | FanAlarmSpeed | Fan Alarm Speed
Public property | FanAlarmSpeed__1 | Fan Alarm Speed
Public property | FANFAULTREF | FAN_FAULT REF
Public property | FanOff | Fan Off
Public property | FanResponse | Fan Response (unit: updates/s)
Public property | FanStalled | Fan Stalled
Public property | FanStalled__1 | Fan Stalled
Public property | FaultQueue | Fault Queue
Public property | LocalHighLimit | Local High Limit (unit: °C)
Public property | LocalLowLimit | Local Low Limit (unit: °C)
Public property | LocalOffset | Local Offset (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | LocalTempHigh | Local Temp High
Public property | LocalTempHigh__1 | Local Temp High
Public property | LocalTempLow | Local Temp Low
Public property | LocalTempLow__1 | Local Temp Low
Public property | LocalTHERM | Local THERM
Public property | LocalTHERMLimit | Local THERM Limit (unit: °C)
Public property | LockBit | Lock Bit
Public property | LookUpTableFanSpeed1 | Look-Up Table, Fan Speed 1
Public property | LookUpTableFanSpeed2 | Look-Up Table, Fan Speed 2
Public property | LookUpTableFanSpeed3 | Look-Up Table, Fan Speed 3
Public property | LookUpTableFanSpeed4 | Look-Up Table, Fan Speed 4
Public property | LookUpTableFanSpeed5 | Look-Up Table, Fan Speed 5
Public property | LookUpTableFanSpeed6 | Look-Up Table, Fan Speed 6
Public property | LookUpTableFanSpeed7 | Look-Up Table, Fan Speed 7
Public property | LookUpTableFanSpeed8 | Look-Up Table, Fan Speed 8
Public property | LookUpTableT1 | Look-Up Table T1 (unit: °C)
Public property | LookUpTableT2 | Look-Up Table T2 (unit: °C)
Public property | LookUpTableT3 | Look-Up Table T3 (unit: °C)
Public property | LookUpTableT4 | Look-Up Table T4 (unit: °C)
Public property | LookUpTableT5 | Look-Up Table T5 (unit: °C)
Public property | LookUpTableT6 | Look-Up Table T6 (unit: °C)
Public property | LookUpTableT7 | Look-Up Table T7 (unit: °C)
Public property | LookUpTableT8 | Look-Up Table T8 (unit: °C)
Public property | LoopUpTableHysteresis | Loop-Up Table Hysteresis (unit: °C)
Public property | MonitorSTBY | Monitor/STBY
Public property | PolesFan | #Poles Fan
Public property | RemoteDiodeError | Remote Diode Error
Public property | RemoteDiodeError__1 | Remote Diode Error
Public property | RemoteHighLimit | Remote High Limit (unit: °C)
Public property | RemoteLowLimit | Remote Low Limit (unit: °C)
Public property | RemoteOffset | Remote Offset (unit: °C)
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | RemoteTempHigh | Remote Temp High
Public property | RemoteTempHigh__1 | Remote Temp High
Public property | RemoteTempLow | Remote Temp Low
Public property | RemoteTempLow__1 | Remote Temp Low
Public property | RemoteTHERM | Remote THERM
Public property | RemoteTHERMLimit | Remote THERM Limit (unit: °C)
Public property | RevisionID | Revision ID
Public property | RoundRobin | Round Robin
Public property | SCLTimeout | SCL Timeout
Public property | SDATimeout | SDA Timeout
Public property | SWCon | SW Con
Public property | SWReset | SW Reset
Public property | TACHPeriod | TACH Period
Public property | THERM | THERM %
Public property | THERMAssert | THERM Assert
Public property | THERMAsserted | THERM Asserted
Public property | THERMExceeded | THERM % Exceeded
Public property | THERMHysteresis | THERM Hysteresis (unit: °C)
Public property | THERMOnTime | THERM % On-Time (unit: %)
Public property | THERMState | THERM State
Public property | THERMState__1 | THERM State
Public property | THERMTimerLimit | THERM Timer % Limit (unit: %)
Public property | THERMTimeWindow | THERM % Time Window (unit: s)
Public property | XORTest | XOR Test
Top
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.ALERTLow Property

IRD

Adm1033ALERTLow Property

ALERT Low

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeStatus ALERTLow { get; }
Public ReadOnly Property ALERTLow As Adm1033TypeStatus
    Get
public:
property Adm1033TypeStatus ALERTLow {
    Adm1033TypeStatus get ();
}
member ALERTLow : Adm1033TypeStatus with get

Property Value

Type: Adm1033TypeStatus
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.AutoFlush Property

IRD

Adm1033AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.AveragingOff Property

IRD

Adm1033AveragingOff Property

Averaging Off

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeDisabledEnabled AveragingOff { get; set; }
Public Property AveragingOff As Adm1033TypeDisabledEnabled
    Get
    Set
public:
property Adm1033TypeDisabledEnabled AveragingOff {
    Adm1033TypeDisabledEnabled get ();
    void set (Adm1033TypeDisabledEnabled value);
}
member AveragingOff : Adm1033TypeDisabledEnabled with get, set

Property Value

Type: Adm1033TypeDisabledEnabled
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.BoostDisable Property

IRD

Adm1033BoostDisable Property

Boost Disable

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeDisabledEnabled BoostDisable { get; set; }
Public Property BoostDisable As Adm1033TypeDisabledEnabled
    Get
    Set
public:
property Adm1033TypeDisabledEnabled BoostDisable {
    Adm1033TypeDisabledEnabled get ();
    void set (Adm1033TypeDisabledEnabled value);
}
member BoostDisable : Adm1033TypeDisabledEnabled with get, set

Property Value

Type: Adm1033TypeDisabledEnabled
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.ChannelSelector Property

IRD

Adm1033ChannelSelector Property

Channel Selector

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeChannelSelector ChannelSelector { get; set; }
Public Property ChannelSelector As Adm1033TypeChannelSelector
    Get
    Set
public:
property Adm1033TypeChannelSelector ChannelSelector {
    Adm1033TypeChannelSelector get ();
    void set (Adm1033TypeChannelSelector value);
}
member ChannelSelector : Adm1033TypeChannelSelector with get, set

Property Value

Type: Adm1033TypeChannelSelector
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.CompanyID Property

IRD

Adm1033CompanyID Property

Company ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CompanyID { get; }
Public ReadOnly Property CompanyID As Byte
    Get
public:
property unsigned char CompanyID {
    unsigned char get ();
}
member CompanyID : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.ConversionRate Property

IRD

Adm1033ConversionRate Property

Conversion Rate (unit: conversions/s)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeConversionRate ConversionRate { get; set; }
Public Property ConversionRate As Adm1033TypeConversionRate
    Get
    Set
public:
property Adm1033TypeConversionRate ConversionRate {
    Adm1033TypeConversionRate get ();
    void set (Adm1033TypeConversionRate value);
}
member ConversionRate : Adm1033TypeConversionRate with get, set

Property Value

Type: Adm1033TypeConversionRate
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.DeviceID Property

IRD

Adm1033DeviceID Property

Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.DiscreteLinearRPM Property

IRD

Adm1033DiscreteLinearRPM Property

Discrete/Linear RPM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeDiscreteLinear DiscreteLinearRPM { get; set; }
Public Property DiscreteLinearRPM As Adm1033TypeDiscreteLinear
    Get
    Set
public:
property Adm1033TypeDiscreteLinear DiscreteLinearRPM {
    Adm1033TypeDiscreteLinear get ();
    void set (Adm1033TypeDiscreteLinear value);
}
member DiscreteLinearRPM : Adm1033TypeDiscreteLinear with get, set

Property Value

Type: Adm1033TypeDiscreteLinear
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.DRIVEBHVR Property

IRD

Adm1033DRIVEBHVR Property

DRIVE BHVR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeDisabledEnabled DRIVEBHVR { get; set; }
Public Property DRIVEBHVR As Adm1033TypeDisabledEnabled
    Get
    Set
public:
property Adm1033TypeDisabledEnabled DRIVEBHVR {
    Adm1033TypeDisabledEnabled get ();
    void set (Adm1033TypeDisabledEnabled value);
}
member DRIVEBHVR : Adm1033TypeDisabledEnabled with get, set

Property Value

Type: Adm1033TypeDisabledEnabled
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.EnableLocalTHERMEvents Property

IRD

Adm1033EnableLocalTHERMEvents Property

Enable Local THERM Events

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeDisabledEnabled EnableLocalTHERMEvents { get; set; }
Public Property EnableLocalTHERMEvents As Adm1033TypeDisabledEnabled
    Get
    Set
public:
property Adm1033TypeDisabledEnabled EnableLocalTHERMEvents {
    Adm1033TypeDisabledEnabled get ();
    void set (Adm1033TypeDisabledEnabled value);
}
member EnableLocalTHERMEvents : Adm1033TypeDisabledEnabled with get, set

Property Value

Type: Adm1033TypeDisabledEnabled
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.EnableRemoteTHERMEvents Property

IRD

Adm1033EnableRemoteTHERMEvents Property

Enable Remote THERM Events

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeDisabledEnabled EnableRemoteTHERMEvents { get; set; }
Public Property EnableRemoteTHERMEvents As Adm1033TypeDisabledEnabled
    Get
    Set
public:
property Adm1033TypeDisabledEnabled EnableRemoteTHERMEvents {
    Adm1033TypeDisabledEnabled get ();
    void set (Adm1033TypeDisabledEnabled value);
}
member EnableRemoteTHERMEvents : Adm1033TypeDisabledEnabled with get, set

Property Value

Type: Adm1033TypeDisabledEnabled
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.EnableTHERMTimer Property

IRD

Adm1033EnableTHERMTimer Property

Enable THERM Timer

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeDisabledEnabled EnableTHERMTimer { get; set; }
Public Property EnableTHERMTimer As Adm1033TypeDisabledEnabled
    Get
    Set
public:
property Adm1033TypeDisabledEnabled EnableTHERMTimer {
    Adm1033TypeDisabledEnabled get ();
    void set (Adm1033TypeDisabledEnabled value);
}
member EnableTHERMTimer : Adm1033TypeDisabledEnabled with get, set

Property Value

Type: Adm1033TypeDisabledEnabled
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.FanAlarmSpeed Property

IRD

Adm1033FanAlarmSpeed Property

Fan Alarm Speed

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeIrqMask FanAlarmSpeed { get; set; }
Public Property FanAlarmSpeed As Adm1033TypeIrqMask
    Get
    Set
public:
property Adm1033TypeIrqMask FanAlarmSpeed {
    Adm1033TypeIrqMask get ();
    void set (Adm1033TypeIrqMask value);
}
member FanAlarmSpeed : Adm1033TypeIrqMask with get, set

Property Value

Type: Adm1033TypeIrqMask
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.FanAlarmSpeed__1 Property

IRD

Adm1033FanAlarmSpeed__1 Property

Fan Alarm Speed

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeStatus FanAlarmSpeed__1 { get; }
Public ReadOnly Property FanAlarmSpeed__1 As Adm1033TypeStatus
    Get
public:
property Adm1033TypeStatus FanAlarmSpeed__1 {
    Adm1033TypeStatus get ();
}
member FanAlarmSpeed__1 : Adm1033TypeStatus with get

Property Value

Type: Adm1033TypeStatus
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.FANFAULTREF Property

IRD

Adm1033FANFAULTREF Property

FAN_FAULT REF

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeFanFaultRef FANFAULTREF { get; set; }
Public Property FANFAULTREF As Adm1033TypeFanFaultRef
    Get
    Set
public:
property Adm1033TypeFanFaultRef FANFAULTREF {
    Adm1033TypeFanFaultRef get ();
    void set (Adm1033TypeFanFaultRef value);
}
member FANFAULTREF : Adm1033TypeFanFaultRef with get, set

Property Value

Type: Adm1033TypeFanFaultRef
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.FanOff Property

IRD

Adm1033FanOff Property

Fan Off

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeDisabledEnabled FanOff { get; set; }
Public Property FanOff As Adm1033TypeDisabledEnabled
    Get
    Set
public:
property Adm1033TypeDisabledEnabled FanOff {
    Adm1033TypeDisabledEnabled get ();
    void set (Adm1033TypeDisabledEnabled value);
}
member FanOff : Adm1033TypeDisabledEnabled with get, set

Property Value

Type: Adm1033TypeDisabledEnabled
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.FanResponse Property

IRD

Adm1033FanResponse Property

Fan Response (unit: updates/s)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeFanResponse FanResponse { get; set; }
Public Property FanResponse As Adm1033TypeFanResponse
    Get
    Set
public:
property Adm1033TypeFanResponse FanResponse {
    Adm1033TypeFanResponse get ();
    void set (Adm1033TypeFanResponse value);
}
member FanResponse : Adm1033TypeFanResponse with get, set

Property Value

Type: Adm1033TypeFanResponse
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.FanStalled Property

IRD

Adm1033FanStalled Property

Fan Stalled

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeIrqMask FanStalled { get; set; }
Public Property FanStalled As Adm1033TypeIrqMask
    Get
    Set
public:
property Adm1033TypeIrqMask FanStalled {
    Adm1033TypeIrqMask get ();
    void set (Adm1033TypeIrqMask value);
}
member FanStalled : Adm1033TypeIrqMask with get, set

Property Value

Type: Adm1033TypeIrqMask
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.FanStalled__1 Property

IRD

Adm1033FanStalled__1 Property

Fan Stalled

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeStatus FanStalled__1 { get; }
Public ReadOnly Property FanStalled__1 As Adm1033TypeStatus
    Get
public:
property Adm1033TypeStatus FanStalled__1 {
    Adm1033TypeStatus get ();
}
member FanStalled__1 : Adm1033TypeStatus with get

Property Value

Type: Adm1033TypeStatus
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.FaultQueue Property

IRD

Adm1033FaultQueue Property

Fault Queue

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeFaultQueue FaultQueue { get; set; }
Public Property FaultQueue As Adm1033TypeFaultQueue
    Get
    Set
public:
property Adm1033TypeFaultQueue FaultQueue {
    Adm1033TypeFaultQueue get ();
    void set (Adm1033TypeFaultQueue value);
}
member FaultQueue : Adm1033TypeFaultQueue with get, set

Property Value

Type: Adm1033TypeFaultQueue
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LocalHighLimit Property

IRD

Adm1033LocalHighLimit Property

Local High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short LocalHighLimit { get; set; }
Public Property LocalHighLimit As Short
    Get
    Set
public:
property short LocalHighLimit {
    short get ();
    void set (short value);
}
member LocalHighLimit : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LocalLowLimit Property

IRD

Adm1033LocalLowLimit Property

Local Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short LocalLowLimit { get; set; }
Public Property LocalLowLimit As Short
    Get
    Set
public:
property short LocalLowLimit {
    short get ();
    void set (short value);
}
member LocalLowLimit : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LocalOffset Property

IRD

Adm1033LocalOffset Property

Local Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LocalOffset { get; set; }
Public Property LocalOffset As Double
    Get
    Set
public:
property double LocalOffset {
    double get ();
    void set (double value);
}
member LocalOffset : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LocalTemperature Property

IRD

Adm1033LocalTemperature Property

Local Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LocalTemperature { get; }
Public ReadOnly Property LocalTemperature As Double
    Get
public:
property double LocalTemperature {
    double get ();
}
member LocalTemperature : float with get

Property Value

Type: Double
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LocalTempHigh Property

IRD

Adm1033LocalTempHigh Property

Local Temp High

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeIrqMask LocalTempHigh { get; set; }
Public Property LocalTempHigh As Adm1033TypeIrqMask
    Get
    Set
public:
property Adm1033TypeIrqMask LocalTempHigh {
    Adm1033TypeIrqMask get ();
    void set (Adm1033TypeIrqMask value);
}
member LocalTempHigh : Adm1033TypeIrqMask with get, set

Property Value

Type: Adm1033TypeIrqMask
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LocalTempHigh__1 Property

IRD

Adm1033LocalTempHigh__1 Property

Local Temp High

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeStatus LocalTempHigh__1 { get; }
Public ReadOnly Property LocalTempHigh__1 As Adm1033TypeStatus
    Get
public:
property Adm1033TypeStatus LocalTempHigh__1 {
    Adm1033TypeStatus get ();
}
member LocalTempHigh__1 : Adm1033TypeStatus with get

Property Value

Type: Adm1033TypeStatus
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LocalTempLow Property

IRD

Adm1033LocalTempLow Property

Local Temp Low

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeIrqMask LocalTempLow { get; set; }
Public Property LocalTempLow As Adm1033TypeIrqMask
    Get
    Set
public:
property Adm1033TypeIrqMask LocalTempLow {
    Adm1033TypeIrqMask get ();
    void set (Adm1033TypeIrqMask value);
}
member LocalTempLow : Adm1033TypeIrqMask with get, set

Property Value

Type: Adm1033TypeIrqMask
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LocalTempLow__1 Property

IRD

Adm1033LocalTempLow__1 Property

Local Temp Low

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeStatus LocalTempLow__1 { get; }
Public ReadOnly Property LocalTempLow__1 As Adm1033TypeStatus
    Get
public:
property Adm1033TypeStatus LocalTempLow__1 {
    Adm1033TypeStatus get ();
}
member LocalTempLow__1 : Adm1033TypeStatus with get

Property Value

Type: Adm1033TypeStatus
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LocalTHERM Property

IRD

Adm1033LocalTHERM Property

Local THERM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeStatus LocalTHERM { get; }
Public ReadOnly Property LocalTHERM As Adm1033TypeStatus
    Get
public:
property Adm1033TypeStatus LocalTHERM {
    Adm1033TypeStatus get ();
}
member LocalTHERM : Adm1033TypeStatus with get

Property Value

Type: Adm1033TypeStatus
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LocalTHERMLimit Property

IRD

Adm1033LocalTHERMLimit Property

Local THERM Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short LocalTHERMLimit { get; set; }
Public Property LocalTHERMLimit As Short
    Get
    Set
public:
property short LocalTHERMLimit {
    short get ();
    void set (short value);
}
member LocalTHERMLimit : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LockBit Property

IRD

Adm1033LockBit Property

Lock Bit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeLockBit LockBit { get; set; }
Public Property LockBit As Adm1033TypeLockBit
    Get
    Set
public:
property Adm1033TypeLockBit LockBit {
    Adm1033TypeLockBit get ();
    void set (Adm1033TypeLockBit value);
}
member LockBit : Adm1033TypeLockBit with get, set

Property Value

Type: Adm1033TypeLockBit
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LookUpTableFanSpeed1 Property

IRD

Adm1033LookUpTableFanSpeed1 Property

Look-Up Table, Fan Speed 1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LookUpTableFanSpeed1 { get; set; }
Public Property LookUpTableFanSpeed1 As UShort
    Get
    Set
public:
property unsigned short LookUpTableFanSpeed1 {
    unsigned short get ();
    void set (unsigned short value);
}
member LookUpTableFanSpeed1 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LookUpTableFanSpeed2 Property

IRD

Adm1033LookUpTableFanSpeed2 Property

Look-Up Table, Fan Speed 2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LookUpTableFanSpeed2 { get; set; }
Public Property LookUpTableFanSpeed2 As UShort
    Get
    Set
public:
property unsigned short LookUpTableFanSpeed2 {
    unsigned short get ();
    void set (unsigned short value);
}
member LookUpTableFanSpeed2 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LookUpTableFanSpeed3 Property

IRD

Adm1033LookUpTableFanSpeed3 Property

Look-Up Table, Fan Speed 3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LookUpTableFanSpeed3 { get; set; }
Public Property LookUpTableFanSpeed3 As UShort
    Get
    Set
public:
property unsigned short LookUpTableFanSpeed3 {
    unsigned short get ();
    void set (unsigned short value);
}
member LookUpTableFanSpeed3 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LookUpTableFanSpeed4 Property

IRD

Adm1033LookUpTableFanSpeed4 Property

Look-Up Table, Fan Speed 4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LookUpTableFanSpeed4 { get; set; }
Public Property LookUpTableFanSpeed4 As UShort
    Get
    Set
public:
property unsigned short LookUpTableFanSpeed4 {
    unsigned short get ();
    void set (unsigned short value);
}
member LookUpTableFanSpeed4 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LookUpTableFanSpeed5 Property

IRD

Adm1033LookUpTableFanSpeed5 Property

Look-Up Table, Fan Speed 5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LookUpTableFanSpeed5 { get; set; }
Public Property LookUpTableFanSpeed5 As UShort
    Get
    Set
public:
property unsigned short LookUpTableFanSpeed5 {
    unsigned short get ();
    void set (unsigned short value);
}
member LookUpTableFanSpeed5 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LookUpTableFanSpeed6 Property

IRD

Adm1033LookUpTableFanSpeed6 Property

Look-Up Table, Fan Speed 6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LookUpTableFanSpeed6 { get; set; }
Public Property LookUpTableFanSpeed6 As UShort
    Get
    Set
public:
property unsigned short LookUpTableFanSpeed6 {
    unsigned short get ();
    void set (unsigned short value);
}
member LookUpTableFanSpeed6 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LookUpTableFanSpeed7 Property

IRD

Adm1033LookUpTableFanSpeed7 Property

Look-Up Table, Fan Speed 7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LookUpTableFanSpeed7 { get; set; }
Public Property LookUpTableFanSpeed7 As UShort
    Get
    Set
public:
property unsigned short LookUpTableFanSpeed7 {
    unsigned short get ();
    void set (unsigned short value);
}
member LookUpTableFanSpeed7 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LookUpTableFanSpeed8 Property

IRD

Adm1033LookUpTableFanSpeed8 Property

Look-Up Table, Fan Speed 8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LookUpTableFanSpeed8 { get; set; }
Public Property LookUpTableFanSpeed8 As UShort
    Get
    Set
public:
property unsigned short LookUpTableFanSpeed8 {
    unsigned short get ();
    void set (unsigned short value);
}
member LookUpTableFanSpeed8 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LookUpTableT1 Property

IRD

Adm1033LookUpTableT1 Property

Look-Up Table T1 (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short LookUpTableT1 { get; set; }
Public Property LookUpTableT1 As Short
    Get
    Set
public:
property short LookUpTableT1 {
    short get ();
    void set (short value);
}
member LookUpTableT1 : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LookUpTableT2 Property

IRD

Adm1033LookUpTableT2 Property

Look-Up Table T2 (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short LookUpTableT2 { get; set; }
Public Property LookUpTableT2 As Short
    Get
    Set
public:
property short LookUpTableT2 {
    short get ();
    void set (short value);
}
member LookUpTableT2 : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LookUpTableT3 Property

IRD

Adm1033LookUpTableT3 Property

Look-Up Table T3 (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short LookUpTableT3 { get; set; }
Public Property LookUpTableT3 As Short
    Get
    Set
public:
property short LookUpTableT3 {
    short get ();
    void set (short value);
}
member LookUpTableT3 : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LookUpTableT4 Property

IRD

Adm1033LookUpTableT4 Property

Look-Up Table T4 (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short LookUpTableT4 { get; set; }
Public Property LookUpTableT4 As Short
    Get
    Set
public:
property short LookUpTableT4 {
    short get ();
    void set (short value);
}
member LookUpTableT4 : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LookUpTableT5 Property

IRD

Adm1033LookUpTableT5 Property

Look-Up Table T5 (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short LookUpTableT5 { get; set; }
Public Property LookUpTableT5 As Short
    Get
    Set
public:
property short LookUpTableT5 {
    short get ();
    void set (short value);
}
member LookUpTableT5 : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LookUpTableT6 Property

IRD

Adm1033LookUpTableT6 Property

Look-Up Table T6 (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short LookUpTableT6 { get; set; }
Public Property LookUpTableT6 As Short
    Get
    Set
public:
property short LookUpTableT6 {
    short get ();
    void set (short value);
}
member LookUpTableT6 : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LookUpTableT7 Property

IRD

Adm1033LookUpTableT7 Property

Look-Up Table T7 (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short LookUpTableT7 { get; set; }
Public Property LookUpTableT7 As Short
    Get
    Set
public:
property short LookUpTableT7 {
    short get ();
    void set (short value);
}
member LookUpTableT7 : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LookUpTableT8 Property

IRD

Adm1033LookUpTableT8 Property

Look-Up Table T8 (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short LookUpTableT8 { get; set; }
Public Property LookUpTableT8 As Short
    Get
    Set
public:
property short LookUpTableT8 {
    short get ();
    void set (short value);
}
member LookUpTableT8 : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.LoopUpTableHysteresis Property

IRD

Adm1033LoopUpTableHysteresis Property

Loop-Up Table Hysteresis (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LoopUpTableHysteresis { get; set; }
Public Property LoopUpTableHysteresis As Byte
    Get
    Set
public:
property unsigned char LoopUpTableHysteresis {
    unsigned char get ();
    void set (unsigned char value);
}
member LoopUpTableHysteresis : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.MonitorSTBY Property

IRD

Adm1033MonitorSTBY Property

Monitor/STBY

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeDisabledEnabled MonitorSTBY { get; set; }
Public Property MonitorSTBY As Adm1033TypeDisabledEnabled
    Get
    Set
public:
property Adm1033TypeDisabledEnabled MonitorSTBY {
    Adm1033TypeDisabledEnabled get ();
    void set (Adm1033TypeDisabledEnabled value);
}
member MonitorSTBY : Adm1033TypeDisabledEnabled with get, set

Property Value

Type: Adm1033TypeDisabledEnabled
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.PolesFan Property

IRD

Adm1033PolesFan Property

#Poles Fan

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PolesFan { get; set; }
Public Property PolesFan As Byte
    Get
    Set
public:
property unsigned char PolesFan {
    unsigned char get ();
    void set (unsigned char value);
}
member PolesFan : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.RemoteDiodeError Property

IRD

Adm1033RemoteDiodeError Property

Remote Diode Error

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeIrqMask RemoteDiodeError { get; }
Public ReadOnly Property RemoteDiodeError As Adm1033TypeIrqMask
    Get
public:
property Adm1033TypeIrqMask RemoteDiodeError {
    Adm1033TypeIrqMask get ();
}
member RemoteDiodeError : Adm1033TypeIrqMask with get

Property Value

Type: Adm1033TypeIrqMask
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.RemoteDiodeError__1 Property

IRD

Adm1033RemoteDiodeError__1 Property

Remote Diode Error

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeStatus RemoteDiodeError__1 { get; }
Public ReadOnly Property RemoteDiodeError__1 As Adm1033TypeStatus
    Get
public:
property Adm1033TypeStatus RemoteDiodeError__1 {
    Adm1033TypeStatus get ();
}
member RemoteDiodeError__1 : Adm1033TypeStatus with get

Property Value

Type: Adm1033TypeStatus
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.RemoteHighLimit Property

IRD

Adm1033RemoteHighLimit Property

Remote High Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short RemoteHighLimit { get; set; }
Public Property RemoteHighLimit As Short
    Get
    Set
public:
property short RemoteHighLimit {
    short get ();
    void set (short value);
}
member RemoteHighLimit : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.RemoteLowLimit Property

IRD

Adm1033RemoteLowLimit Property

Remote Low Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short RemoteLowLimit { get; set; }
Public Property RemoteLowLimit As Short
    Get
    Set
public:
property short RemoteLowLimit {
    short get ();
    void set (short value);
}
member RemoteLowLimit : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.RemoteOffset Property

IRD

Adm1033RemoteOffset Property

Remote Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteOffset { get; set; }
Public Property RemoteOffset As Double
    Get
    Set
public:
property double RemoteOffset {
    double get ();
    void set (double value);
}
member RemoteOffset : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.RemoteTemperature Property

IRD

Adm1033RemoteTemperature Property

Remote Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperature { get; }
Public ReadOnly Property RemoteTemperature As Double
    Get
public:
property double RemoteTemperature {
    double get ();
}
member RemoteTemperature : float with get

Property Value

Type: Double
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.RemoteTempHigh Property

IRD

Adm1033RemoteTempHigh Property

Remote Temp High

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeIrqMask RemoteTempHigh { get; set; }
Public Property RemoteTempHigh As Adm1033TypeIrqMask
    Get
    Set
public:
property Adm1033TypeIrqMask RemoteTempHigh {
    Adm1033TypeIrqMask get ();
    void set (Adm1033TypeIrqMask value);
}
member RemoteTempHigh : Adm1033TypeIrqMask with get, set

Property Value

Type: Adm1033TypeIrqMask
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.RemoteTempHigh__1 Property

IRD

Adm1033RemoteTempHigh__1 Property

Remote Temp High

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeStatus RemoteTempHigh__1 { get; }
Public ReadOnly Property RemoteTempHigh__1 As Adm1033TypeStatus
    Get
public:
property Adm1033TypeStatus RemoteTempHigh__1 {
    Adm1033TypeStatus get ();
}
member RemoteTempHigh__1 : Adm1033TypeStatus with get

Property Value

Type: Adm1033TypeStatus
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.RemoteTempLow Property

IRD

Adm1033RemoteTempLow Property

Remote Temp Low

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeIrqMask RemoteTempLow { get; }
Public ReadOnly Property RemoteTempLow As Adm1033TypeIrqMask
    Get
public:
property Adm1033TypeIrqMask RemoteTempLow {
    Adm1033TypeIrqMask get ();
}
member RemoteTempLow : Adm1033TypeIrqMask with get

Property Value

Type: Adm1033TypeIrqMask
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.RemoteTempLow__1 Property

IRD

Adm1033RemoteTempLow__1 Property

Remote Temp Low

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeStatus RemoteTempLow__1 { get; }
Public ReadOnly Property RemoteTempLow__1 As Adm1033TypeStatus
    Get
public:
property Adm1033TypeStatus RemoteTempLow__1 {
    Adm1033TypeStatus get ();
}
member RemoteTempLow__1 : Adm1033TypeStatus with get

Property Value

Type: Adm1033TypeStatus
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.RemoteTHERM Property

IRD

Adm1033RemoteTHERM Property

Remote THERM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeStatus RemoteTHERM { get; }
Public ReadOnly Property RemoteTHERM As Adm1033TypeStatus
    Get
public:
property Adm1033TypeStatus RemoteTHERM {
    Adm1033TypeStatus get ();
}
member RemoteTHERM : Adm1033TypeStatus with get

Property Value

Type: Adm1033TypeStatus
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.RemoteTHERMLimit Property

IRD

Adm1033RemoteTHERMLimit Property

Remote THERM Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short RemoteTHERMLimit { get; set; }
Public Property RemoteTHERMLimit As Short
    Get
    Set
public:
property short RemoteTHERMLimit {
    short get ();
    void set (short value);
}
member RemoteTHERMLimit : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.RevisionID Property

IRD

Adm1033RevisionID Property

Revision ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionID { get; }
Public ReadOnly Property RevisionID As Byte
    Get
public:
property unsigned char RevisionID {
    unsigned char get ();
}
member RevisionID : byte with get

Property Value

Type: Byte
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.RoundRobin Property

IRD

Adm1033RoundRobin Property

Round Robin

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeRoundRobin RoundRobin { get; set; }
Public Property RoundRobin As Adm1033TypeRoundRobin
    Get
    Set
public:
property Adm1033TypeRoundRobin RoundRobin {
    Adm1033TypeRoundRobin get ();
    void set (Adm1033TypeRoundRobin value);
}
member RoundRobin : Adm1033TypeRoundRobin with get, set

Property Value

Type: Adm1033TypeRoundRobin
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.SCLTimeout Property

IRD

Adm1033SCLTimeout Property

SCL Timeout

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeDisabledEnabled SCLTimeout { get; set; }
Public Property SCLTimeout As Adm1033TypeDisabledEnabled
    Get
    Set
public:
property Adm1033TypeDisabledEnabled SCLTimeout {
    Adm1033TypeDisabledEnabled get ();
    void set (Adm1033TypeDisabledEnabled value);
}
member SCLTimeout : Adm1033TypeDisabledEnabled with get, set

Property Value

Type: Adm1033TypeDisabledEnabled
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.SDATimeout Property

IRD

Adm1033SDATimeout Property

SDA Timeout

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeDisabledEnabled SDATimeout { get; set; }
Public Property SDATimeout As Adm1033TypeDisabledEnabled
    Get
    Set
public:
property Adm1033TypeDisabledEnabled SDATimeout {
    Adm1033TypeDisabledEnabled get ();
    void set (Adm1033TypeDisabledEnabled value);
}
member SDATimeout : Adm1033TypeDisabledEnabled with get, set

Property Value

Type: Adm1033TypeDisabledEnabled
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.SWCon Property

IRD

Adm1033SWCon Property

SW Con

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeSwCon SWCon { get; set; }
Public Property SWCon As Adm1033TypeSwCon
    Get
    Set
public:
property Adm1033TypeSwCon SWCon {
    Adm1033TypeSwCon get ();
    void set (Adm1033TypeSwCon value);
}
member SWCon : Adm1033TypeSwCon with get, set

Property Value

Type: Adm1033TypeSwCon
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.SWReset Property

IRD

Adm1033SWReset Property

SW Reset

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeReset SWReset { get; set; }
Public Property SWReset As Adm1033TypeReset
    Get
    Set
public:
property Adm1033TypeReset SWReset {
    Adm1033TypeReset get ();
    void set (Adm1033TypeReset value);
}
member SWReset : Adm1033TypeReset with get, set

Property Value

Type: Adm1033TypeReset
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.TACHPeriod Property

IRD

Adm1033TACHPeriod Property

TACH Period

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TACHPeriod { get; }
Public ReadOnly Property TACHPeriod As UShort
    Get
public:
property unsigned short TACHPeriod {
    unsigned short get ();
}
member TACHPeriod : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.THERM Property

IRD

Adm1033THERM Property

THERM %

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeIrqMask THERM { get; set; }
Public Property THERM As Adm1033TypeIrqMask
    Get
    Set
public:
property Adm1033TypeIrqMask THERM {
    Adm1033TypeIrqMask get ();
    void set (Adm1033TypeIrqMask value);
}
member THERM : Adm1033TypeIrqMask with get, set

Property Value

Type: Adm1033TypeIrqMask
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.THERMAssert Property

IRD

Adm1033THERMAssert Property

THERM Assert

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeIrqMask THERMAssert { get; set; }
Public Property THERMAssert As Adm1033TypeIrqMask
    Get
    Set
public:
property Adm1033TypeIrqMask THERMAssert {
    Adm1033TypeIrqMask get ();
    void set (Adm1033TypeIrqMask value);
}
member THERMAssert : Adm1033TypeIrqMask with get, set

Property Value

Type: Adm1033TypeIrqMask
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.THERMAsserted Property

IRD

Adm1033THERMAsserted Property

THERM Asserted

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeStatus THERMAsserted { get; }
Public ReadOnly Property THERMAsserted As Adm1033TypeStatus
    Get
public:
property Adm1033TypeStatus THERMAsserted {
    Adm1033TypeStatus get ();
}
member THERMAsserted : Adm1033TypeStatus with get

Property Value

Type: Adm1033TypeStatus
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.THERMExceeded Property

IRD

Adm1033THERMExceeded Property

THERM % Exceeded

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeStatus THERMExceeded { get; }
Public ReadOnly Property THERMExceeded As Adm1033TypeStatus
    Get
public:
property Adm1033TypeStatus THERMExceeded {
    Adm1033TypeStatus get ();
}
member THERMExceeded : Adm1033TypeStatus with get

Property Value

Type: Adm1033TypeStatus
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.THERMHysteresis Property

IRD

Adm1033THERMHysteresis Property

THERM Hysteresis (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte THERMHysteresis { get; set; }
Public Property THERMHysteresis As Byte
    Get
    Set
public:
property unsigned char THERMHysteresis {
    unsigned char get ();
    void set (unsigned char value);
}
member THERMHysteresis : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.THERMOnTime Property

IRD

Adm1033THERMOnTime Property

THERM % On-Time (unit: %)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double THERMOnTime { get; }
Public ReadOnly Property THERMOnTime As Double
    Get
public:
property double THERMOnTime {
    double get ();
}
member THERMOnTime : float with get

Property Value

Type: Double
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.THERMState Property

IRD

Adm1033THERMState Property

THERM State

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeIrqMask THERMState { get; set; }
Public Property THERMState As Adm1033TypeIrqMask
    Get
    Set
public:
property Adm1033TypeIrqMask THERMState {
    Adm1033TypeIrqMask get ();
    void set (Adm1033TypeIrqMask value);
}
member THERMState : Adm1033TypeIrqMask with get, set

Property Value

Type: Adm1033TypeIrqMask
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.THERMState__1 Property

IRD

Adm1033THERMState__1 Property

THERM State

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeStatus THERMState__1 { get; }
Public ReadOnly Property THERMState__1 As Adm1033TypeStatus
    Get
public:
property Adm1033TypeStatus THERMState__1 {
    Adm1033TypeStatus get ();
}
member THERMState__1 : Adm1033TypeStatus with get

Property Value

Type: Adm1033TypeStatus
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.THERMTimerLimit Property

IRD

Adm1033THERMTimerLimit Property

THERM Timer % Limit (unit: %)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double THERMTimerLimit { get; set; }
Public Property THERMTimerLimit As Double
    Get
    Set
public:
property double THERMTimerLimit {
    double get ();
    void set (double value);
}
member THERMTimerLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.THERMTimeWindow Property

IRD

Adm1033THERMTimeWindow Property

THERM % Time Window (unit: s)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeThermTimeWindow THERMTimeWindow { get; set; }
Public Property THERMTimeWindow As Adm1033TypeThermTimeWindow
    Get
    Set
public:
property Adm1033TypeThermTimeWindow THERMTimeWindow {
    Adm1033TypeThermTimeWindow get ();
    void set (Adm1033TypeThermTimeWindow value);
}
member THERMTimeWindow : Adm1033TypeThermTimeWindow with get, set

Property Value

Type: Adm1033TypeThermTimeWindow
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.XORTest Property

IRD

Adm1033XORTest Property

XOR Test

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adm1033TypeDisabledEnabled XORTest { get; set; }
Public Property XORTest As Adm1033TypeDisabledEnabled
    Get
    Set
public:
property Adm1033TypeDisabledEnabled XORTest {
    Adm1033TypeDisabledEnabled get ();
    void set (Adm1033TypeDisabledEnabled value);
}
member XORTest : Adm1033TypeDisabledEnabled with get, set

Property Value

Type: Adm1033TypeDisabledEnabled
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033 Methods

The Adm1033 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.Flush Method

IRD

Adm1033Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adm1033 Class
telos.Ird.AnalogDevices Namespace


Adm1033.TypeChannelSelector Enumeration

IRD

Adm1033TypeChannelSelector Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelSelector
Public Enumeration TypeChannelSelector
public enum class TypeChannelSelector
type TypeChannelSelector
Members
Member name | Value | Description
LocalTemperature | 0 | Local Temperature
RemoteTemperature | 1 | Remote Temperature
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1033.TypeConversionRate Enumeration

IRD

Adm1033TypeConversionRate Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConversionRate
Public Enumeration TypeConversionRate
public enum class TypeConversionRate
type TypeConversionRate
Members
Member name | Value | Description
Value_0_0625 | 0 | 0.0625
Value_0_125 | 1 | 0.125
Value_0_25 | 2 | 0.25
Value_0_5 | 3 | 0.5
Value_1 | 4 | 1
Value_2 | 5 | 2
Value_4 | 6 | 4
Value_8 | 7 | 8
Value_16 | 8 | 16
Value_32 | 9 | 32
Value_64 | 10 | 64
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1033.TypeDisabledEnabled Enumeration

IRD

Adm1033TypeDisabledEnabled Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDisabledEnabled
Public Enumeration TypeDisabledEnabled
public enum class TypeDisabledEnabled
type TypeDisabledEnabled
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1033.TypeDiscreteLinear Enumeration

IRD

Adm1033TypeDiscreteLinear Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDiscreteLinear
Public Enumeration TypeDiscreteLinear
public enum class TypeDiscreteLinear
type TypeDiscreteLinear
Members
Member name | Value | Description
Discrete | 0 | Discrete
Linear | 1 | Linear
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1033.TypeDriveBhvr Enumeration

IRD

Adm1033TypeDriveBhvr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDriveBhvr
Public Enumeration TypeDriveBhvr
public enum class TypeDriveBhvr
type TypeDriveBhvr
Members
Member name | Value | Description
LocalTemperature | 0 | Local Temperature
RemoteTemperature | 1 | Remote Temperature
FullSpeed | 3 | Full Speed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1033.TypeFanFaultRef Enumeration

IRD

Adm1033TypeFanFaultRef Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFanFaultRef
Public Enumeration TypeFanFaultRef
public enum class TypeFanFaultRef
type TypeFanFaultRef
Members
Member name | Value | Description
FANFAULT | 0 | FAN_FAULT
ReferenceInputForTHERM | 1 | Reference Input For THERM
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1033.TypeFanResponse Enumeration

IRD

Adm1033TypeFanResponse Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFanResponse
Public Enumeration TypeFanResponse
public enum class TypeFanResponse
type TypeFanResponse
Members
Member name | Value | Description
Value_1_25 | 0 | 1.25
Value_2_5 | 1 | 2.5
Value_5 | 2 | 5
Value_10 | 3 | 10
Value_20 | 4 | 20
Value_40 | 5 | 40
Value_80 | 6 | 80
Value_160 | 7 | 160
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1033.TypeFaultQueue Enumeration

IRD

Adm1033TypeFaultQueue Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultQueue
Public Enumeration TypeFaultQueue
public enum class TypeFaultQueue
type TypeFaultQueue
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_2 | 2 | 2
Value_3 | 4 | 3
Value_4 | 8 | 4
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1033.TypeIrqMask Enumeration

IRD

Adm1033TypeIrqMask Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIrqMask
Public Enumeration TypeIrqMask
public enum class TypeIrqMask
type TypeIrqMask
Members
Member name | Value | Description
IRQStatusBitCausesIRQOutputTrue | 0 | IRQ Status Bit Causes IRQ Output: True
IRQStatusBitCausesIRQOutputFalse | 1 | IRQ Status Bit Causes IRQ Output: False
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1033.TypeLockBit Enumeration

IRD

Adm1033TypeLockBit Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLockBit
Public Enumeration TypeLockBit
public enum class TypeLockBit
type TypeLockBit
Members
Member name | Value | Description
RegistersUnlocked | 0 | Registers Unlocked
RegistersLocked | 1 | Registers Locked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1033.TypeReset Enumeration

IRD

Adm1033TypeReset Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeReset
Public Enumeration TypeReset
public enum class TypeReset
type TypeReset
Members
Member name | Value | Description
Default | 0 | Default
TriggerReset | 1 | Trigger Reset
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1033.TypeRoundRobin Enumeration

IRD

Adm1033TypeRoundRobin Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRoundRobin
Public Enumeration TypeRoundRobin
public enum class TypeRoundRobin
type TypeRoundRobin
Members
Member name | Value | Description
SingleChannelMode | 0 | Single-Channel Mode
RoundRobinMode | 1 | Round-Robin Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1033.TypeStatus Enumeration

IRD

Adm1033TypeStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus
Public Enumeration TypeStatus
public enum class TypeStatus
type TypeStatus
Members
Member name | Value | Description
NotTripped | 0 | Not Tripped
Tripped | 1 | Tripped
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1033.TypeSwCon Enumeration

IRD

Adm1033TypeSwCon Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSwCon
Public Enumeration TypeSwCon
public enum class TypeSwCon
type TypeSwCon
Members
Member name | Value | Description
LookUpTableControlMode | 0 | Look-Up Table Control Mode
SoftwareManualControlMode | 1 | Software/Manual Control Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adm1033.TypeThermTimeWindow Enumeration

IRD

Adm1033TypeThermTimeWindow Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeThermTimeWindow
Public Enumeration TypeThermTimeWindow
public enum class TypeThermTimeWindow
type TypeThermTimeWindow
Members
Member name | Value | Description
Value_0_25 | 0 | 0.25
Value_0_5 | 1 | 0.5
Value_1 | 2 | 1
Value_2 | 3 | 2
Value_4 | 4 | 4
Value_8 | 5 | 8
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649 Class

Analog Devices: ADP 1649
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdp1649

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adp1649
Public Class Adp1649
public ref class Adp1649
type Adp1649 =  class end

The Adp1649 type exposes the following members.

Constructors
 | Name | Description
Public method | Adp1649 | Constructor
Top
Properties
 | Name | Description
Public property | AdditionalModeADCADCEN | Additional Mode, ADC: ADC_EN
Public property | AdditionalModeADCADCVAL | Additional Mode, ADC: ADC_VAL
Public property | AdditionalModeADCFLVBLO | Additional Mode, ADC: FL_VB_LO
Public property | AdditionalModeADMODDYNOVP | Additional Mode, AD_MOD: DYN_OVP
Public property | AdditionalModeADMODIILED | Additional Mode, AD_MOD: I_ILED (unit: mA)
Public property | AdditionalModeADMODILDC | Additional Mode, AD_MOD: IL_DC (unit: A)
Public property | AdditionalModeADMODILDCEN | Additional Mode, AD_MOD: IL_DC_EN
Public property | AdditionalModeADMODSTRPOL | Additional Mode, AD_MOD: STR_POL
Public property | AdditionalModeADMODSWLO | Additional Mode, AD_MOD: SW_LO
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryLowModeCLSOFT | Battery Low Mode: CL_SOFT
Public property | BatteryLowModeIVBLO | Battery Low Mode: I_VB_LO (unit: mA)
Public property | BatteryLowModeVVBLO | Battery Low Mode: V_VB_LO (unit: V)
Public property | CurrentSetIFL | Current Set: I_FL (unit: mA)
Public property | CurrentSetITOR | Current Set: I_TOR (unit: mA)
Public property | DesignInformationManufacturerInformation | Design Information: Manufacturer Information
Public property | FaultInformationFLIDC | Fault Information: FL_IDC
Public property | FaultInformationFLIL | Fault Information: FL_IL
Public property | FaultInformationFLIO2 | Fault Information: FL_IO2
Public property | FaultInformationFLOT | Fault Information: FL_OT
Public property | FaultInformationFLOVP | Fault Information: FL_OVP
Public property | FaultInformationFLSC | Fault Information: FL_SC
Public property | FaultInformationFLTO | Fault Information: FL_TO
Public property | FaultInformationFLTX1 | Fault Information: FL_TX1
Public property | InputControlITX1 | Input Control: I_TX1 (unit: mA)
Public property | InputControlITX2 | Input Control: I_TX2 (unit: mA)
Public property | OutputModeFREQFB | Output Mode: FREQ_FB
Public property | OutputModeILPEAK | Output Mode: IL_PEAK (unit: A)
Public property | OutputModeLEDMOD | Output Mode: LED_MOD
Public property | OutputModeOUTPUTEN | Output Mode: OUTPUT_EN
Public property | OutputModeSTRLV | Output Mode: STR_LV
Public property | OutputModeSTRMODE | Output Mode: STR_MODE
Public property | VREFAndTimerFLTIM | VREF and Timer: FL_TIM (unit: ms)
Public property | VREFAndTimerIO1CFG | VREF and Timer: IO1_CFG
Public property | VREFAndTimerIO2CFG | VREF and Timer: IO2_CFG
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
1.0 A LED Flash Driver with I2C-Compatible Interface
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adp1649(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adp1649

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649 Properties

The Adp1649 type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalModeADCADCEN | Additional Mode, ADC: ADC_EN
Public property | AdditionalModeADCADCVAL | Additional Mode, ADC: ADC_VAL
Public property | AdditionalModeADCFLVBLO | Additional Mode, ADC: FL_VB_LO
Public property | AdditionalModeADMODDYNOVP | Additional Mode, AD_MOD: DYN_OVP
Public property | AdditionalModeADMODIILED | Additional Mode, AD_MOD: I_ILED (unit: mA)
Public property | AdditionalModeADMODILDC | Additional Mode, AD_MOD: IL_DC (unit: A)
Public property | AdditionalModeADMODILDCEN | Additional Mode, AD_MOD: IL_DC_EN
Public property | AdditionalModeADMODSTRPOL | Additional Mode, AD_MOD: STR_POL
Public property | AdditionalModeADMODSWLO | Additional Mode, AD_MOD: SW_LO
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryLowModeCLSOFT | Battery Low Mode: CL_SOFT
Public property | BatteryLowModeIVBLO | Battery Low Mode: I_VB_LO (unit: mA)
Public property | BatteryLowModeVVBLO | Battery Low Mode: V_VB_LO (unit: V)
Public property | CurrentSetIFL | Current Set: I_FL (unit: mA)
Public property | CurrentSetITOR | Current Set: I_TOR (unit: mA)
Public property | DesignInformationManufacturerInformation | Design Information: Manufacturer Information
Public property | FaultInformationFLIDC | Fault Information: FL_IDC
Public property | FaultInformationFLIL | Fault Information: FL_IL
Public property | FaultInformationFLIO2 | Fault Information: FL_IO2
Public property | FaultInformationFLOT | Fault Information: FL_OT
Public property | FaultInformationFLOVP | Fault Information: FL_OVP
Public property | FaultInformationFLSC | Fault Information: FL_SC
Public property | FaultInformationFLTO | Fault Information: FL_TO
Public property | FaultInformationFLTX1 | Fault Information: FL_TX1
Public property | InputControlITX1 | Input Control: I_TX1 (unit: mA)
Public property | InputControlITX2 | Input Control: I_TX2 (unit: mA)
Public property | OutputModeFREQFB | Output Mode: FREQ_FB
Public property | OutputModeILPEAK | Output Mode: IL_PEAK (unit: A)
Public property | OutputModeLEDMOD | Output Mode: LED_MOD
Public property | OutputModeOUTPUTEN | Output Mode: OUTPUT_EN
Public property | OutputModeSTRLV | Output Mode: STR_LV
Public property | OutputModeSTRMODE | Output Mode: STR_MODE
Public property | VREFAndTimerFLTIM | VREF and Timer: FL_TIM (unit: ms)
Public property | VREFAndTimerIO1CFG | VREF and Timer: IO1_CFG
Public property | VREFAndTimerIO2CFG | VREF and Timer: IO2_CFG
Top
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.AdditionalModeADCADCEN Property

IRD

Adp1649AdditionalModeADCADCEN Property

Additional Mode, ADC: ADC_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeAdditionalModeAdcAdcEn AdditionalModeADCADCEN { get; set; }
Public Property AdditionalModeADCADCEN As Adp1649TypeAdditionalModeAdcAdcEn
    Get
    Set
public:
property Adp1649TypeAdditionalModeAdcAdcEn AdditionalModeADCADCEN {
    Adp1649TypeAdditionalModeAdcAdcEn get ();
    void set (Adp1649TypeAdditionalModeAdcAdcEn value);
}
member AdditionalModeADCADCEN : Adp1649TypeAdditionalModeAdcAdcEn with get, set

Property Value

Type: Adp1649TypeAdditionalModeAdcAdcEn
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.AdditionalModeADCADCVAL Property

IRD

Adp1649AdditionalModeADCADCVAL Property

Additional Mode, ADC: ADC_VAL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AdditionalModeADCADCVAL { get; set; }
Public Property AdditionalModeADCADCVAL As Byte
    Get
    Set
public:
property unsigned char AdditionalModeADCADCVAL {
    unsigned char get ();
    void set (unsigned char value);
}
member AdditionalModeADCADCVAL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.AdditionalModeADCFLVBLO Property

IRD

Adp1649AdditionalModeADCFLVBLO Property

Additional Mode, ADC: FL_VB_LO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeAdditionalModeAdcFlVbLo AdditionalModeADCFLVBLO { get; }
Public ReadOnly Property AdditionalModeADCFLVBLO As Adp1649TypeAdditionalModeAdcFlVbLo
    Get
public:
property Adp1649TypeAdditionalModeAdcFlVbLo AdditionalModeADCFLVBLO {
    Adp1649TypeAdditionalModeAdcFlVbLo get ();
}
member AdditionalModeADCFLVBLO : Adp1649TypeAdditionalModeAdcFlVbLo with get

Property Value

Type: Adp1649TypeAdditionalModeAdcFlVbLo
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.AdditionalModeADMODDYNOVP Property

IRD

Adp1649AdditionalModeADMODDYNOVP Property

Additional Mode, AD_MOD: DYN_OVP

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeAdditionalModeAdModDynOvp AdditionalModeADMODDYNOVP { get; set; }
Public Property AdditionalModeADMODDYNOVP As Adp1649TypeAdditionalModeAdModDynOvp
    Get
    Set
public:
property Adp1649TypeAdditionalModeAdModDynOvp AdditionalModeADMODDYNOVP {
    Adp1649TypeAdditionalModeAdModDynOvp get ();
    void set (Adp1649TypeAdditionalModeAdModDynOvp value);
}
member AdditionalModeADMODDYNOVP : Adp1649TypeAdditionalModeAdModDynOvp with get, set

Property Value

Type: Adp1649TypeAdditionalModeAdModDynOvp
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.AdditionalModeADMODIILED Property

IRD

Adp1649AdditionalModeADMODIILED Property

Additional Mode, AD_MOD: I_ILED (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeAdditionalModeAdModIIled AdditionalModeADMODIILED { get; set; }
Public Property AdditionalModeADMODIILED As Adp1649TypeAdditionalModeAdModIIled
    Get
    Set
public:
property Adp1649TypeAdditionalModeAdModIIled AdditionalModeADMODIILED {
    Adp1649TypeAdditionalModeAdModIIled get ();
    void set (Adp1649TypeAdditionalModeAdModIIled value);
}
member AdditionalModeADMODIILED : Adp1649TypeAdditionalModeAdModIIled with get, set

Property Value

Type: Adp1649TypeAdditionalModeAdModIIled
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.AdditionalModeADMODILDC Property

IRD

Adp1649AdditionalModeADMODILDC Property

Additional Mode, AD_MOD: IL_DC (unit: A)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeAdditionalModeAdModIlDc AdditionalModeADMODILDC { get; set; }
Public Property AdditionalModeADMODILDC As Adp1649TypeAdditionalModeAdModIlDc
    Get
    Set
public:
property Adp1649TypeAdditionalModeAdModIlDc AdditionalModeADMODILDC {
    Adp1649TypeAdditionalModeAdModIlDc get ();
    void set (Adp1649TypeAdditionalModeAdModIlDc value);
}
member AdditionalModeADMODILDC : Adp1649TypeAdditionalModeAdModIlDc with get, set

Property Value

Type: Adp1649TypeAdditionalModeAdModIlDc
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.AdditionalModeADMODILDCEN Property

IRD

Adp1649AdditionalModeADMODILDCEN Property

Additional Mode, AD_MOD: IL_DC_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeAdditionalModeAdModIlDcEn AdditionalModeADMODILDCEN { get; set; }
Public Property AdditionalModeADMODILDCEN As Adp1649TypeAdditionalModeAdModIlDcEn
    Get
    Set
public:
property Adp1649TypeAdditionalModeAdModIlDcEn AdditionalModeADMODILDCEN {
    Adp1649TypeAdditionalModeAdModIlDcEn get ();
    void set (Adp1649TypeAdditionalModeAdModIlDcEn value);
}
member AdditionalModeADMODILDCEN : Adp1649TypeAdditionalModeAdModIlDcEn with get, set

Property Value

Type: Adp1649TypeAdditionalModeAdModIlDcEn
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.AdditionalModeADMODSTRPOL Property

IRD

Adp1649AdditionalModeADMODSTRPOL Property

Additional Mode, AD_MOD: STR_POL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeAdditionalModeAdModStrPol AdditionalModeADMODSTRPOL { get; set; }
Public Property AdditionalModeADMODSTRPOL As Adp1649TypeAdditionalModeAdModStrPol
    Get
    Set
public:
property Adp1649TypeAdditionalModeAdModStrPol AdditionalModeADMODSTRPOL {
    Adp1649TypeAdditionalModeAdModStrPol get ();
    void set (Adp1649TypeAdditionalModeAdModStrPol value);
}
member AdditionalModeADMODSTRPOL : Adp1649TypeAdditionalModeAdModStrPol with get, set

Property Value

Type: Adp1649TypeAdditionalModeAdModStrPol
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.AdditionalModeADMODSWLO Property

IRD

Adp1649AdditionalModeADMODSWLO Property

Additional Mode, AD_MOD: SW_LO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeAdditionalModeAdModSwLo AdditionalModeADMODSWLO { get; set; }
Public Property AdditionalModeADMODSWLO As Adp1649TypeAdditionalModeAdModSwLo
    Get
    Set
public:
property Adp1649TypeAdditionalModeAdModSwLo AdditionalModeADMODSWLO {
    Adp1649TypeAdditionalModeAdModSwLo get ();
    void set (Adp1649TypeAdditionalModeAdModSwLo value);
}
member AdditionalModeADMODSWLO : Adp1649TypeAdditionalModeAdModSwLo with get, set

Property Value

Type: Adp1649TypeAdditionalModeAdModSwLo
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.AutoFlush Property

IRD

Adp1649AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.BatteryLowModeCLSOFT Property

IRD

Adp1649BatteryLowModeCLSOFT Property

Battery Low Mode: CL_SOFT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeBatteryLowModeClSoft BatteryLowModeCLSOFT { get; set; }
Public Property BatteryLowModeCLSOFT As Adp1649TypeBatteryLowModeClSoft
    Get
    Set
public:
property Adp1649TypeBatteryLowModeClSoft BatteryLowModeCLSOFT {
    Adp1649TypeBatteryLowModeClSoft get ();
    void set (Adp1649TypeBatteryLowModeClSoft value);
}
member BatteryLowModeCLSOFT : Adp1649TypeBatteryLowModeClSoft with get, set

Property Value

Type: Adp1649TypeBatteryLowModeClSoft
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.BatteryLowModeIVBLO Property

IRD

Adp1649BatteryLowModeIVBLO Property

Battery Low Mode: I_VB_LO (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeBatteryLowModeIVbLo BatteryLowModeIVBLO { get; }
Public ReadOnly Property BatteryLowModeIVBLO As Adp1649TypeBatteryLowModeIVbLo
    Get
public:
property Adp1649TypeBatteryLowModeIVbLo BatteryLowModeIVBLO {
    Adp1649TypeBatteryLowModeIVbLo get ();
}
member BatteryLowModeIVBLO : Adp1649TypeBatteryLowModeIVbLo with get

Property Value

Type: Adp1649TypeBatteryLowModeIVbLo
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.BatteryLowModeVVBLO Property

IRD

Adp1649BatteryLowModeVVBLO Property

Battery Low Mode: V_VB_LO (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeBatteryLowModeVVbLo BatteryLowModeVVBLO { get; set; }
Public Property BatteryLowModeVVBLO As Adp1649TypeBatteryLowModeVVbLo
    Get
    Set
public:
property Adp1649TypeBatteryLowModeVVbLo BatteryLowModeVVBLO {
    Adp1649TypeBatteryLowModeVVbLo get ();
    void set (Adp1649TypeBatteryLowModeVVbLo value);
}
member BatteryLowModeVVBLO : Adp1649TypeBatteryLowModeVVbLo with get, set

Property Value

Type: Adp1649TypeBatteryLowModeVVbLo
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.CurrentSetIFL Property

IRD

Adp1649CurrentSetIFL Property

Current Set: I_FL (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeCurrentSetIFl CurrentSetIFL { get; set; }
Public Property CurrentSetIFL As Adp1649TypeCurrentSetIFl
    Get
    Set
public:
property Adp1649TypeCurrentSetIFl CurrentSetIFL {
    Adp1649TypeCurrentSetIFl get ();
    void set (Adp1649TypeCurrentSetIFl value);
}
member CurrentSetIFL : Adp1649TypeCurrentSetIFl with get, set

Property Value

Type: Adp1649TypeCurrentSetIFl
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.CurrentSetITOR Property

IRD

Adp1649CurrentSetITOR Property

Current Set: I_TOR (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeCurrentSetITor CurrentSetITOR { get; set; }
Public Property CurrentSetITOR As Adp1649TypeCurrentSetITor
    Get
    Set
public:
property Adp1649TypeCurrentSetITor CurrentSetITOR {
    Adp1649TypeCurrentSetITor get ();
    void set (Adp1649TypeCurrentSetITor value);
}
member CurrentSetITOR : Adp1649TypeCurrentSetITor with get, set

Property Value

Type: Adp1649TypeCurrentSetITor
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.DesignInformationManufacturerInformation Property

IRD

Adp1649DesignInformationManufacturerInformation Property

Design Information: Manufacturer Information

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DesignInformationManufacturerInformation { get; }
Public ReadOnly Property DesignInformationManufacturerInformation As Byte
    Get
public:
property unsigned char DesignInformationManufacturerInformation {
    unsigned char get ();
}
member DesignInformationManufacturerInformation : byte with get

Property Value

Type: Byte
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.FaultInformationFLIDC Property

IRD

Adp1649FaultInformationFLIDC Property

Fault Information: FL_IDC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeFaultInformationIdc FaultInformationFLIDC { get; }
Public ReadOnly Property FaultInformationFLIDC As Adp1649TypeFaultInformationIdc
    Get
public:
property Adp1649TypeFaultInformationIdc FaultInformationFLIDC {
    Adp1649TypeFaultInformationIdc get ();
}
member FaultInformationFLIDC : Adp1649TypeFaultInformationIdc with get

Property Value

Type: Adp1649TypeFaultInformationIdc
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.FaultInformationFLIL Property

IRD

Adp1649FaultInformationFLIL Property

Fault Information: FL_IL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeFaultInformationFl FaultInformationFLIL { get; }
Public ReadOnly Property FaultInformationFLIL As Adp1649TypeFaultInformationFl
    Get
public:
property Adp1649TypeFaultInformationFl FaultInformationFLIL {
    Adp1649TypeFaultInformationFl get ();
}
member FaultInformationFLIL : Adp1649TypeFaultInformationFl with get

Property Value

Type: Adp1649TypeFaultInformationFl
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.FaultInformationFLIO2 Property

IRD

Adp1649FaultInformationFLIO2 Property

Fault Information: FL_IO2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeFaultInformationIo2 FaultInformationFLIO2 { get; }
Public ReadOnly Property FaultInformationFLIO2 As Adp1649TypeFaultInformationIo2
    Get
public:
property Adp1649TypeFaultInformationIo2 FaultInformationFLIO2 {
    Adp1649TypeFaultInformationIo2 get ();
}
member FaultInformationFLIO2 : Adp1649TypeFaultInformationIo2 with get

Property Value

Type: Adp1649TypeFaultInformationIo2
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.FaultInformationFLOT Property

IRD

Adp1649FaultInformationFLOT Property

Fault Information: FL_OT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeFaultInformationFl FaultInformationFLOT { get; }
Public ReadOnly Property FaultInformationFLOT As Adp1649TypeFaultInformationFl
    Get
public:
property Adp1649TypeFaultInformationFl FaultInformationFLOT {
    Adp1649TypeFaultInformationFl get ();
}
member FaultInformationFLOT : Adp1649TypeFaultInformationFl with get

Property Value

Type: Adp1649TypeFaultInformationFl
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.FaultInformationFLOVP Property

IRD

Adp1649FaultInformationFLOVP Property

Fault Information: FL_OVP

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeFaultInformationFl FaultInformationFLOVP { get; }
Public ReadOnly Property FaultInformationFLOVP As Adp1649TypeFaultInformationFl
    Get
public:
property Adp1649TypeFaultInformationFl FaultInformationFLOVP {
    Adp1649TypeFaultInformationFl get ();
}
member FaultInformationFLOVP : Adp1649TypeFaultInformationFl with get

Property Value

Type: Adp1649TypeFaultInformationFl
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.FaultInformationFLSC Property

IRD

Adp1649FaultInformationFLSC Property

Fault Information: FL_SC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeFaultInformationFl FaultInformationFLSC { get; }
Public ReadOnly Property FaultInformationFLSC As Adp1649TypeFaultInformationFl
    Get
public:
property Adp1649TypeFaultInformationFl FaultInformationFLSC {
    Adp1649TypeFaultInformationFl get ();
}
member FaultInformationFLSC : Adp1649TypeFaultInformationFl with get

Property Value

Type: Adp1649TypeFaultInformationFl
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.FaultInformationFLTO Property

IRD

Adp1649FaultInformationFLTO Property

Fault Information: FL_TO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeFaultInformationFl FaultInformationFLTO { get; }
Public ReadOnly Property FaultInformationFLTO As Adp1649TypeFaultInformationFl
    Get
public:
property Adp1649TypeFaultInformationFl FaultInformationFLTO {
    Adp1649TypeFaultInformationFl get ();
}
member FaultInformationFLTO : Adp1649TypeFaultInformationFl with get

Property Value

Type: Adp1649TypeFaultInformationFl
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.FaultInformationFLTX1 Property

IRD

Adp1649FaultInformationFLTX1 Property

Fault Information: FL_TX1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeFaultInformationTx1 FaultInformationFLTX1 { get; }
Public ReadOnly Property FaultInformationFLTX1 As Adp1649TypeFaultInformationTx1
    Get
public:
property Adp1649TypeFaultInformationTx1 FaultInformationFLTX1 {
    Adp1649TypeFaultInformationTx1 get ();
}
member FaultInformationFLTX1 : Adp1649TypeFaultInformationTx1 with get

Property Value

Type: Adp1649TypeFaultInformationTx1
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.InputControlITX1 Property

IRD

Adp1649InputControlITX1 Property

Input Control: I_TX1 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeInputControl InputControlITX1 { get; set; }
Public Property InputControlITX1 As Adp1649TypeInputControl
    Get
    Set
public:
property Adp1649TypeInputControl InputControlITX1 {
    Adp1649TypeInputControl get ();
    void set (Adp1649TypeInputControl value);
}
member InputControlITX1 : Adp1649TypeInputControl with get, set

Property Value

Type: Adp1649TypeInputControl
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.InputControlITX2 Property

IRD

Adp1649InputControlITX2 Property

Input Control: I_TX2 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeInputControl InputControlITX2 { get; set; }
Public Property InputControlITX2 As Adp1649TypeInputControl
    Get
    Set
public:
property Adp1649TypeInputControl InputControlITX2 {
    Adp1649TypeInputControl get ();
    void set (Adp1649TypeInputControl value);
}
member InputControlITX2 : Adp1649TypeInputControl with get, set

Property Value

Type: Adp1649TypeInputControl
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.OutputModeFREQFB Property

IRD

Adp1649OutputModeFREQFB Property

Output Mode: FREQ_FB

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeOutputModeFreqFb OutputModeFREQFB { get; set; }
Public Property OutputModeFREQFB As Adp1649TypeOutputModeFreqFb
    Get
    Set
public:
property Adp1649TypeOutputModeFreqFb OutputModeFREQFB {
    Adp1649TypeOutputModeFreqFb get ();
    void set (Adp1649TypeOutputModeFreqFb value);
}
member OutputModeFREQFB : Adp1649TypeOutputModeFreqFb with get, set

Property Value

Type: Adp1649TypeOutputModeFreqFb
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.OutputModeILPEAK Property

IRD

Adp1649OutputModeILPEAK Property

Output Mode: IL_PEAK (unit: A)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeOutputModeIlPeak OutputModeILPEAK { get; set; }
Public Property OutputModeILPEAK As Adp1649TypeOutputModeIlPeak
    Get
    Set
public:
property Adp1649TypeOutputModeIlPeak OutputModeILPEAK {
    Adp1649TypeOutputModeIlPeak get ();
    void set (Adp1649TypeOutputModeIlPeak value);
}
member OutputModeILPEAK : Adp1649TypeOutputModeIlPeak with get, set

Property Value

Type: Adp1649TypeOutputModeIlPeak
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.OutputModeLEDMOD Property

IRD

Adp1649OutputModeLEDMOD Property

Output Mode: LED_MOD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeOutputModeLedMode OutputModeLEDMOD { get; set; }
Public Property OutputModeLEDMOD As Adp1649TypeOutputModeLedMode
    Get
    Set
public:
property Adp1649TypeOutputModeLedMode OutputModeLEDMOD {
    Adp1649TypeOutputModeLedMode get ();
    void set (Adp1649TypeOutputModeLedMode value);
}
member OutputModeLEDMOD : Adp1649TypeOutputModeLedMode with get, set

Property Value

Type: Adp1649TypeOutputModeLedMode
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.OutputModeOUTPUTEN Property

IRD

Adp1649OutputModeOUTPUTEN Property

Output Mode: OUTPUT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeOutputModeOutputEn OutputModeOUTPUTEN { get; set; }
Public Property OutputModeOUTPUTEN As Adp1649TypeOutputModeOutputEn
    Get
    Set
public:
property Adp1649TypeOutputModeOutputEn OutputModeOUTPUTEN {
    Adp1649TypeOutputModeOutputEn get ();
    void set (Adp1649TypeOutputModeOutputEn value);
}
member OutputModeOUTPUTEN : Adp1649TypeOutputModeOutputEn with get, set

Property Value

Type: Adp1649TypeOutputModeOutputEn
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.OutputModeSTRLV Property

IRD

Adp1649OutputModeSTRLV Property

Output Mode: STR_LV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeOutputModeStrLv OutputModeSTRLV { get; set; }
Public Property OutputModeSTRLV As Adp1649TypeOutputModeStrLv
    Get
    Set
public:
property Adp1649TypeOutputModeStrLv OutputModeSTRLV {
    Adp1649TypeOutputModeStrLv get ();
    void set (Adp1649TypeOutputModeStrLv value);
}
member OutputModeSTRLV : Adp1649TypeOutputModeStrLv with get, set

Property Value

Type: Adp1649TypeOutputModeStrLv
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.OutputModeSTRMODE Property

IRD

Adp1649OutputModeSTRMODE Property

Output Mode: STR_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeOutputModeStrMode OutputModeSTRMODE { get; set; }
Public Property OutputModeSTRMODE As Adp1649TypeOutputModeStrMode
    Get
    Set
public:
property Adp1649TypeOutputModeStrMode OutputModeSTRMODE {
    Adp1649TypeOutputModeStrMode get ();
    void set (Adp1649TypeOutputModeStrMode value);
}
member OutputModeSTRMODE : Adp1649TypeOutputModeStrMode with get, set

Property Value

Type: Adp1649TypeOutputModeStrMode
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.VREFAndTimerFLTIM Property

IRD

Adp1649VREFAndTimerFLTIM Property

VREF and Timer: FL_TIM (unit: ms)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeVrefTimerFlTim VREFAndTimerFLTIM { get; set; }
Public Property VREFAndTimerFLTIM As Adp1649TypeVrefTimerFlTim
    Get
    Set
public:
property Adp1649TypeVrefTimerFlTim VREFAndTimerFLTIM {
    Adp1649TypeVrefTimerFlTim get ();
    void set (Adp1649TypeVrefTimerFlTim value);
}
member VREFAndTimerFLTIM : Adp1649TypeVrefTimerFlTim with get, set

Property Value

Type: Adp1649TypeVrefTimerFlTim
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.VREFAndTimerIO1CFG Property

IRD

Adp1649VREFAndTimerIO1CFG Property

VREF and Timer: IO1_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeVrefTimerIo1Cfg VREFAndTimerIO1CFG { get; set; }
Public Property VREFAndTimerIO1CFG As Adp1649TypeVrefTimerIo1Cfg
    Get
    Set
public:
property Adp1649TypeVrefTimerIo1Cfg VREFAndTimerIO1CFG {
    Adp1649TypeVrefTimerIo1Cfg get ();
    void set (Adp1649TypeVrefTimerIo1Cfg value);
}
member VREFAndTimerIO1CFG : Adp1649TypeVrefTimerIo1Cfg with get, set

Property Value

Type: Adp1649TypeVrefTimerIo1Cfg
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.VREFAndTimerIO2CFG Property

IRD

Adp1649VREFAndTimerIO2CFG Property

VREF and Timer: IO2_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1649TypeVrefTimerIo2Cfg VREFAndTimerIO2CFG { get; set; }
Public Property VREFAndTimerIO2CFG As Adp1649TypeVrefTimerIo2Cfg
    Get
    Set
public:
property Adp1649TypeVrefTimerIo2Cfg VREFAndTimerIO2CFG {
    Adp1649TypeVrefTimerIo2Cfg get ();
    void set (Adp1649TypeVrefTimerIo2Cfg value);
}
member VREFAndTimerIO2CFG : Adp1649TypeVrefTimerIo2Cfg with get, set

Property Value

Type: Adp1649TypeVrefTimerIo2Cfg
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649 Methods

The Adp1649 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.Flush Method

IRD

Adp1649Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adp1649 Class
telos.Ird.AnalogDevices Namespace


Adp1649.TypeAdditionalModeAdcAdcEn Enumeration

IRD

Adp1649TypeAdditionalModeAdcAdcEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalModeAdcAdcEn
Public Enumeration TypeAdditionalModeAdcAdcEn
public enum class TypeAdditionalModeAdcAdcEn
type TypeAdditionalModeAdcAdcEn
Members
Member name | Value | Description
Disabled | 0 | Disabled
LEDVFMeasurement | 1 | LED V_F Measurement
DieTemperatureMeasurement | 2 | Die Temperature Measurement
ExternalVoltageMode | 3 | External Voltage Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeAdditionalModeAdcFlVbLo Enumeration

IRD

Adp1649TypeAdditionalModeAdcFlVbLo Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalModeAdcFlVbLo
Public Enumeration TypeAdditionalModeAdcFlVbLo
public enum class TypeAdditionalModeAdcFlVbLo
type TypeAdditionalModeAdcFlVbLo
Members
Member name | Value | Description
VDDVBATLowThreshold | 0 | V_DD > V_BAT Low Threshold
VDDVBATLowThreshold__1 | 1 | V_DD < V_BAT Low Threshold
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeAdditionalModeAdModDynOvp Enumeration

IRD

Adp1649TypeAdditionalModeAdModDynOvp Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalModeAdModDynOvp
Public Enumeration TypeAdditionalModeAdModDynOvp
public enum class TypeAdditionalModeAdModDynOvp
type TypeAdditionalModeAdModDynOvp
Members
Member name | Value | Description
DOVPOff | 0 | DOVP: Off
DOVPOn | 1 | DOVP: On
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeAdditionalModeAdModIIled Enumeration

IRD

Adp1649TypeAdditionalModeAdModIIled Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalModeAdModIIled
Public Enumeration TypeAdditionalModeAdModIIled
public enum class TypeAdditionalModeAdModIIled
type TypeAdditionalModeAdModIIled
Members
Member name | Value | Description
Value_2_75 | 0 | 2.75
Value_5_5 | 1 | 5.5
Value_8_25 | 2 | 8.25
Value_11 | 3 | 11
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeAdditionalModeAdModIlDc Enumeration

IRD

Adp1649TypeAdditionalModeAdModIlDc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalModeAdModIlDc
Public Enumeration TypeAdditionalModeAdModIlDc
public enum class TypeAdditionalModeAdModIlDc
type TypeAdditionalModeAdModIlDc
Members
Member name | Value | Description
Value_1_5 | 0 | 1.5
Value_1_75 | 1 | 1.75
Value_2_0 | 2 | 2.0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeAdditionalModeAdModIlDcEn Enumeration

IRD

Adp1649TypeAdditionalModeAdModIlDcEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalModeAdModIlDcEn
Public Enumeration TypeAdditionalModeAdModIlDcEn
public enum class TypeAdditionalModeAdModIlDcEn
type TypeAdditionalModeAdModIlDcEn
Members
Member name | Value | Description
InputDCCurrentLimitDisabled | 0 | Input DC Current Limit: Disabled
InputDCCurrentLimitEnabled | 1 | Input DC Current Limit: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeAdditionalModeAdModStrPol Enumeration

IRD

Adp1649TypeAdditionalModeAdModStrPol Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalModeAdModStrPol
Public Enumeration TypeAdditionalModeAdModStrPol
public enum class TypeAdditionalModeAdModStrPol
type TypeAdditionalModeAdModStrPol
Members
Member name | Value | Description
StrobePolarityActiveLow | 0 | Strobe Polarity: Active Low
StrobePolarityActiveHigh | 1 | Strobe Polarity: Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeAdditionalModeAdModSwLo Enumeration

IRD

Adp1649TypeAdditionalModeAdModSwLo Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalModeAdModSwLo
Public Enumeration TypeAdditionalModeAdModSwLo
public enum class TypeAdditionalModeAdModSwLo
type TypeAdditionalModeAdModSwLo
Members
Member name | Value | Description
Force15MHzSwitchingFrequencyDisabled | 0 | Force 1.5 MHz Switching Frequency: Disabled
Force15MHzSwitchingFrequencyEnabled | 1 | Force 1.5 MHz Switching Frequency: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeBatteryLowModeClSoft Enumeration

IRD

Adp1649TypeBatteryLowModeClSoft Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBatteryLowModeClSoft
Public Enumeration TypeBatteryLowModeClSoft
public enum class TypeBatteryLowModeClSoft
type TypeBatteryLowModeClSoft
Members
Member name | Value | Description
SoftInductorPeakCurrentLimitDisabled | 0 | Soft Inductor Peak Current Limit: Disabled
SoftInductorPeakCurrentLimitEnabled | 1 | Soft Inductor Peak Current Limit: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeBatteryLowModeIVbLo Enumeration

IRD

Adp1649TypeBatteryLowModeIVbLo Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBatteryLowModeIVbLo
Public Enumeration TypeBatteryLowModeIVbLo
public enum class TypeBatteryLowModeIVbLo
type TypeBatteryLowModeIVbLo
Members
Member name | Value | Description
Value_300 | 0 | 300
Value_350 | 1 | 350
Value_400 | 2 | 400
Value_450 | 3 | 450
Value_500 | 4 | 500
Value_550 | 5 | 550
Value_600 | 6 | 600
Value_650 | 7 | 650
Value_700 | 8 | 700
Value_750 | 9 | 750
Value_800 | 10 | 800
Value_850 | 11 | 850
Value_900 | 12 | 900
Value_950 | 13 | 950
Value_1000 | 14 | 1000
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeBatteryLowModeVVbLo Enumeration

IRD

Adp1649TypeBatteryLowModeVVbLo Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBatteryLowModeVVbLo
Public Enumeration TypeBatteryLowModeVVbLo
public enum class TypeBatteryLowModeVVbLo
type TypeBatteryLowModeVVbLo
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_3_3 | 1 | 3.3
Value_3_35 | 2 | 3.35
Value_3_4 | 3 | 3.4
Value_3_45 | 4 | 3.45
Value_3_5 | 5 | 3.5
Value_3_55 | 6 | 3.55
Value_3_6 | 7 | 3.6
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeCurrentSetIFl Enumeration

IRD

Adp1649TypeCurrentSetIFl Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCurrentSetIFl
Public Enumeration TypeCurrentSetIFl
public enum class TypeCurrentSetIFl
type TypeCurrentSetIFl
Members
Member name | Value | Description
Value_300 | 0 | 300
Value_350 | 1 | 350
Value_400 | 2 | 400
Value_450 | 3 | 450
Value_500 | 4 | 500
Value_550 | 5 | 550
Value_600 | 6 | 600
Value_650 | 7 | 650
Value_700 | 8 | 700
Value_750 | 9 | 750
Value_800 | 10 | 800
Value_850 | 11 | 850
Value_900 | 12 | 900
Value_950 | 13 | 950
Value_1000 | 14 | 1000
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeCurrentSetITor Enumeration

IRD

Adp1649TypeCurrentSetITor Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCurrentSetITor
Public Enumeration TypeCurrentSetITor
public enum class TypeCurrentSetITor
type TypeCurrentSetITor
Members
Member name | Value | Description
Value_25 | 0 | 25
Value_50 | 1 | 50
Value_75 | 2 | 75
Value_100 | 3 | 100
Value_125 | 4 | 125
Value_150 | 5 | 150
Value_175 | 6 | 175
Value_200 | 7 | 200
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeFaultInformationFl Enumeration

IRD

Adp1649TypeFaultInformationFl Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultInformationFl
Public Enumeration TypeFaultInformationFl
public enum class TypeFaultInformationFl
type TypeFaultInformationFl
Members
Member name | Value | Description
NoFault | 0 | No Fault
Fault | 1 | Fault
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeFaultInformationIdc Enumeration

IRD

Adp1649TypeFaultInformationIdc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultInformationIdc
Public Enumeration TypeFaultInformationIdc
public enum class TypeFaultInformationIdc
type TypeFaultInformationIdc
Members
Member name | Value | Description
DCCurrentLimitNotHit | 0 | DC Current Limit: Not Hit
DCCurrentLimitHit | 1 | DC Current Limit: Hit
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeFaultInformationIo2 Enumeration

IRD

Adp1649TypeFaultInformationIo2 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultInformationIo2
Public Enumeration TypeFaultInformationIo2
public enum class TypeFaultInformationIo2
type TypeFaultInformationIo2
Members
Member name | Value | Description
NoTxMASK2OperationalModeDuringLastFlashNoFault | 0 | No TxMASK2 Operational Mode During Last Flash / No Fault
TxMASK2OperationalModeDuringLastFlashIndicatorLEDFault | 1 | TxMASK2 Operational Mode During Last Flash / Indicator LED Fault
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeFaultInformationTx1 Enumeration

IRD

Adp1649TypeFaultInformationTx1 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultInformationTx1
Public Enumeration TypeFaultInformationTx1
public enum class TypeFaultInformationTx1
type TypeFaultInformationTx1
Members
Member name | Value | Description
NoTxMASK1OperationalModeDuringLastFlash | 0 | No TxMASK1 Operational Mode During Last Flash
TxMASK1OperationalModeDuringLastFlash | 1 | TxMASK1 Operational Mode During Last Flash
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeInputControl Enumeration

IRD

Adp1649TypeInputControl Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInputControl
Public Enumeration TypeInputControl
public enum class TypeInputControl
type TypeInputControl
Members
Member name | Value | Description
Value_100 | 0 | 100
Value_150 | 1 | 150
Value_200 | 2 | 200
Value_250 | 3 | 250
Value_300 | 4 | 300
Value_350 | 5 | 350
Value_400 | 6 | 400
Value_450 | 7 | 450
Value_500 | 8 | 500
Value_550 | 9 | 550
Value_600 | 10 | 600
Value_650 | 11 | 650
Value_700 | 12 | 700
Value_750 | 13 | 750
Value_800 | 14 | 800
Value_850 | 15 | 850
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeOutputModeFreqFb Enumeration

IRD

Adp1649TypeOutputModeFreqFb Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeFreqFb
Public Enumeration TypeOutputModeFreqFb
public enum class TypeOutputModeFreqFb
type TypeOutputModeFreqFb
Members
Member name | Value | Description
FrequencyFoldbackNotAllowed | 0 | Frequency Foldback: Not Allowed
FrequencyFoldbackAllowed | 1 | Frequency Foldback: Allowed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeOutputModeIlPeak Enumeration

IRD

Adp1649TypeOutputModeIlPeak Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeIlPeak
Public Enumeration TypeOutputModeIlPeak
public enum class TypeOutputModeIlPeak
type TypeOutputModeIlPeak
Members
Member name | Value | Description
Value_1_75 | 0 | 1.75
Value_2_25 | 1 | 2.25
Value_2_75 | 2 | 2.75
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeOutputModeLedMode Enumeration

IRD

Adp1649TypeOutputModeLedMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeLedMode
Public Enumeration TypeOutputModeLedMode
public enum class TypeOutputModeLedMode
type TypeOutputModeLedMode
Members
Member name | Value | Description
StandbyMode | 0 | Standby Mode
VoltageOutputModeVOUT5V | 1 | Voltage Output Mode, VOUT = 5V
AssistLightMode | 2 | Assist Light Mode
FlashMode | 3 | Flash Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeOutputModeOutputEn Enumeration

IRD

Adp1649TypeOutputModeOutputEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeOutputEn
Public Enumeration TypeOutputModeOutputEn
public enum class TypeOutputModeOutputEn
type TypeOutputModeOutputEn
Members
Member name | Value | Description
OutputOff | 0 | Output: Off
OutputOn | 1 | Output: On
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeOutputModeStrLv Enumeration

IRD

Adp1649TypeOutputModeStrLv Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeStrLv
Public Enumeration TypeOutputModeStrLv
public enum class TypeOutputModeStrLv
type TypeOutputModeStrLv
Members
Member name | Value | Description
EdgeSensitive | 0 | Edge Sensitive
LevelSensitive | 1 | Level Sensitive
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeOutputModeStrMode Enumeration

IRD

Adp1649TypeOutputModeStrMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeStrMode
Public Enumeration TypeOutputModeStrMode
public enum class TypeOutputModeStrMode
type TypeOutputModeStrMode
Members
Member name | Value | Description
SoftwareStrobeMode | 0 | Software Strobe Mode
HardwareStrobeMode | 1 | Hardware Strobe Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeVrefTimerFlTim Enumeration

IRD

Adp1649TypeVrefTimerFlTim Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVrefTimerFlTim
Public Enumeration TypeVrefTimerFlTim
public enum class TypeVrefTimerFlTim
type TypeVrefTimerFlTim
Members
Member name | Value | Description
Value_100 | 0 | 100
Value_200 | 1 | 200
Value_300 | 2 | 300
Value_400 | 3 | 400
Value_500 | 4 | 500
Value_600 | 5 | 600
Value_700 | 6 | 700
Value_800 | 7 | 800
Value_900 | 8 | 900
Value_1000 | 9 | 1000
Value_1100 | 10 | 1100
Value_1200 | 11 | 1200
Value_1300 | 12 | 1300
Value_1400 | 13 | 1400
Value_1500 | 14 | 1500
Value_1600 | 15 | 1600
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeVrefTimerIo1Cfg Enumeration

IRD

Adp1649TypeVrefTimerIo1Cfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVrefTimerIo1Cfg
Public Enumeration TypeVrefTimerIo1Cfg
public enum class TypeVrefTimerIo1Cfg
type TypeVrefTimerIo1Cfg
Members
Member name | Value | Description
HighImpedance | 0 | High Impedance
Torch | 1 | Torch
TxMASK1OperationMode | 2 | TxMASK1 Operation Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1649.TypeVrefTimerIo2Cfg Enumeration

IRD

Adp1649TypeVrefTimerIo2Cfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVrefTimerIo2Cfg
Public Enumeration TypeVrefTimerIo2Cfg
public enum class TypeVrefTimerIo2Cfg
type TypeVrefTimerIo2Cfg
Members
Member name | Value | Description
HighImpedance | 0 | High Impedance
IndicatorLED | 1 | Indicator LED
TxMASK2OperationMode | 2 | TxMASK2 Operation Mode
AnalogInput | 3 | Analog Input
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650 Class

Analog Devices: ADP 1650
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdp1650

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adp1650
Public Class Adp1650
public ref class Adp1650
type Adp1650 =  class end

The Adp1650 type exposes the following members.

Constructors
 | Name | Description
Public method | Adp1650 | Constructor
Top
Properties
 | Name | Description
Public property | AdditionalModeADCADCEN | Additional Mode, ADC: ADC_EN
Public property | AdditionalModeADCADCVAL | Additional Mode, ADC: ADC_VAL
Public property | AdditionalModeADCFLVBLO | Additional Mode, ADC: FL_VB_LO
Public property | AdditionalModeADMODDYNOVP | Additional Mode, AD_MOD: DYN_OVP
Public property | AdditionalModeADMODIILED | Additional Mode, AD_MOD: I_ILED (unit: mA)
Public property | AdditionalModeADMODILDC | Additional Mode, AD_MOD: IL_DC (unit: A)
Public property | AdditionalModeADMODILDCEN | Additional Mode, AD_MOD: IL_DC_EN
Public property | AdditionalModeADMODSTRPOL | Additional Mode, AD_MOD: STR_POL
Public property | AdditionalModeADMODSWLO | Additional Mode, AD_MOD: SW_LO
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryLowModeCLSOFT | Battery Low Mode: CL_SOFT
Public property | BatteryLowModeIVBLO | Battery Low Mode: I_VB_LO (unit: mA)
Public property | BatteryLowModeVVBLO | Battery Low Mode: V_VB_LO (unit: V)
Public property | CurrentSetIFL | Current Set: I_FL (unit: mA)
Public property | CurrentSetITOR | Current Set: I_TOR (unit: mA)
Public property | DesignInformationManufacturerInformation | Design Information: Manufacturer Information
Public property | FaultInformationFLIDC | Fault Information: FL_IDC
Public property | FaultInformationFLIL | Fault Information: FL_IL
Public property | FaultInformationFLIO2 | Fault Information: FL_IO2
Public property | FaultInformationFLOT | Fault Information: FL_OT
Public property | FaultInformationFLOVP | Fault Information: FL_OVP
Public property | FaultInformationFLSC | Fault Information: FL_SC
Public property | FaultInformationFLTO | Fault Information: FL_TO
Public property | FaultInformationFLTX1 | Fault Information: FL_TX1
Public property | InputControlITX1 | Input Control: I_TX1 (unit: mA)
Public property | InputControlITX2 | Input Control: I_TX2 (unit: mA)
Public property | OutputModeFREQFB | Output Mode: FREQ_FB
Public property | OutputModeILPEAK | Output Mode: IL_PEAK (unit: A)
Public property | OutputModeLEDMOD | Output Mode: LED_MOD
Public property | OutputModeOUTPUTEN | Output Mode: OUTPUT_EN
Public property | OutputModeSTRLV | Output Mode: STR_LV
Public property | OutputModeSTRMODE | Output Mode: STR_MODE
Public property | VREFAndTimerFLTIM | VREF and Timer: FL_TIM (unit: ms)
Public property | VREFAndTimerIO1CFG | VREF and Timer: IO1_CFG
Public property | VREFAndTimerIO2CFG | VREF and Timer: IO2_CFG
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
1.5 A LED Flash Driver with I2C-Compatible Interface
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adp1650(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adp1650

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650 Properties

The Adp1650 type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalModeADCADCEN | Additional Mode, ADC: ADC_EN
Public property | AdditionalModeADCADCVAL | Additional Mode, ADC: ADC_VAL
Public property | AdditionalModeADCFLVBLO | Additional Mode, ADC: FL_VB_LO
Public property | AdditionalModeADMODDYNOVP | Additional Mode, AD_MOD: DYN_OVP
Public property | AdditionalModeADMODIILED | Additional Mode, AD_MOD: I_ILED (unit: mA)
Public property | AdditionalModeADMODILDC | Additional Mode, AD_MOD: IL_DC (unit: A)
Public property | AdditionalModeADMODILDCEN | Additional Mode, AD_MOD: IL_DC_EN
Public property | AdditionalModeADMODSTRPOL | Additional Mode, AD_MOD: STR_POL
Public property | AdditionalModeADMODSWLO | Additional Mode, AD_MOD: SW_LO
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryLowModeCLSOFT | Battery Low Mode: CL_SOFT
Public property | BatteryLowModeIVBLO | Battery Low Mode: I_VB_LO (unit: mA)
Public property | BatteryLowModeVVBLO | Battery Low Mode: V_VB_LO (unit: V)
Public property | CurrentSetIFL | Current Set: I_FL (unit: mA)
Public property | CurrentSetITOR | Current Set: I_TOR (unit: mA)
Public property | DesignInformationManufacturerInformation | Design Information: Manufacturer Information
Public property | FaultInformationFLIDC | Fault Information: FL_IDC
Public property | FaultInformationFLIL | Fault Information: FL_IL
Public property | FaultInformationFLIO2 | Fault Information: FL_IO2
Public property | FaultInformationFLOT | Fault Information: FL_OT
Public property | FaultInformationFLOVP | Fault Information: FL_OVP
Public property | FaultInformationFLSC | Fault Information: FL_SC
Public property | FaultInformationFLTO | Fault Information: FL_TO
Public property | FaultInformationFLTX1 | Fault Information: FL_TX1
Public property | InputControlITX1 | Input Control: I_TX1 (unit: mA)
Public property | InputControlITX2 | Input Control: I_TX2 (unit: mA)
Public property | OutputModeFREQFB | Output Mode: FREQ_FB
Public property | OutputModeILPEAK | Output Mode: IL_PEAK (unit: A)
Public property | OutputModeLEDMOD | Output Mode: LED_MOD
Public property | OutputModeOUTPUTEN | Output Mode: OUTPUT_EN
Public property | OutputModeSTRLV | Output Mode: STR_LV
Public property | OutputModeSTRMODE | Output Mode: STR_MODE
Public property | VREFAndTimerFLTIM | VREF and Timer: FL_TIM (unit: ms)
Public property | VREFAndTimerIO1CFG | VREF and Timer: IO1_CFG
Public property | VREFAndTimerIO2CFG | VREF and Timer: IO2_CFG
Top
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.AdditionalModeADCADCEN Property

IRD

Adp1650AdditionalModeADCADCEN Property

Additional Mode, ADC: ADC_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeAdditionalModeAdcAdcEn AdditionalModeADCADCEN { get; set; }
Public Property AdditionalModeADCADCEN As Adp1650TypeAdditionalModeAdcAdcEn
    Get
    Set
public:
property Adp1650TypeAdditionalModeAdcAdcEn AdditionalModeADCADCEN {
    Adp1650TypeAdditionalModeAdcAdcEn get ();
    void set (Adp1650TypeAdditionalModeAdcAdcEn value);
}
member AdditionalModeADCADCEN : Adp1650TypeAdditionalModeAdcAdcEn with get, set

Property Value

Type: Adp1650TypeAdditionalModeAdcAdcEn
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.AdditionalModeADCADCVAL Property

IRD

Adp1650AdditionalModeADCADCVAL Property

Additional Mode, ADC: ADC_VAL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AdditionalModeADCADCVAL { get; set; }
Public Property AdditionalModeADCADCVAL As Byte
    Get
    Set
public:
property unsigned char AdditionalModeADCADCVAL {
    unsigned char get ();
    void set (unsigned char value);
}
member AdditionalModeADCADCVAL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.AdditionalModeADCFLVBLO Property

IRD

Adp1650AdditionalModeADCFLVBLO Property

Additional Mode, ADC: FL_VB_LO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeAdditionalModeAdcFlVbLo AdditionalModeADCFLVBLO { get; }
Public ReadOnly Property AdditionalModeADCFLVBLO As Adp1650TypeAdditionalModeAdcFlVbLo
    Get
public:
property Adp1650TypeAdditionalModeAdcFlVbLo AdditionalModeADCFLVBLO {
    Adp1650TypeAdditionalModeAdcFlVbLo get ();
}
member AdditionalModeADCFLVBLO : Adp1650TypeAdditionalModeAdcFlVbLo with get

Property Value

Type: Adp1650TypeAdditionalModeAdcFlVbLo
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.AdditionalModeADMODDYNOVP Property

IRD

Adp1650AdditionalModeADMODDYNOVP Property

Additional Mode, AD_MOD: DYN_OVP

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeAdditionalModeAdModDynOvp AdditionalModeADMODDYNOVP { get; set; }
Public Property AdditionalModeADMODDYNOVP As Adp1650TypeAdditionalModeAdModDynOvp
    Get
    Set
public:
property Adp1650TypeAdditionalModeAdModDynOvp AdditionalModeADMODDYNOVP {
    Adp1650TypeAdditionalModeAdModDynOvp get ();
    void set (Adp1650TypeAdditionalModeAdModDynOvp value);
}
member AdditionalModeADMODDYNOVP : Adp1650TypeAdditionalModeAdModDynOvp with get, set

Property Value

Type: Adp1650TypeAdditionalModeAdModDynOvp
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.AdditionalModeADMODIILED Property

IRD

Adp1650AdditionalModeADMODIILED Property

Additional Mode, AD_MOD: I_ILED (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeAdditionalModeAdModIIled AdditionalModeADMODIILED { get; set; }
Public Property AdditionalModeADMODIILED As Adp1650TypeAdditionalModeAdModIIled
    Get
    Set
public:
property Adp1650TypeAdditionalModeAdModIIled AdditionalModeADMODIILED {
    Adp1650TypeAdditionalModeAdModIIled get ();
    void set (Adp1650TypeAdditionalModeAdModIIled value);
}
member AdditionalModeADMODIILED : Adp1650TypeAdditionalModeAdModIIled with get, set

Property Value

Type: Adp1650TypeAdditionalModeAdModIIled
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.AdditionalModeADMODILDC Property

IRD

Adp1650AdditionalModeADMODILDC Property

Additional Mode, AD_MOD: IL_DC (unit: A)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeAdditionalModeAdModIlDc AdditionalModeADMODILDC { get; set; }
Public Property AdditionalModeADMODILDC As Adp1650TypeAdditionalModeAdModIlDc
    Get
    Set
public:
property Adp1650TypeAdditionalModeAdModIlDc AdditionalModeADMODILDC {
    Adp1650TypeAdditionalModeAdModIlDc get ();
    void set (Adp1650TypeAdditionalModeAdModIlDc value);
}
member AdditionalModeADMODILDC : Adp1650TypeAdditionalModeAdModIlDc with get, set

Property Value

Type: Adp1650TypeAdditionalModeAdModIlDc
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.AdditionalModeADMODILDCEN Property

IRD

Adp1650AdditionalModeADMODILDCEN Property

Additional Mode, AD_MOD: IL_DC_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeAdditionalModeAdModIlDcEn AdditionalModeADMODILDCEN { get; set; }
Public Property AdditionalModeADMODILDCEN As Adp1650TypeAdditionalModeAdModIlDcEn
    Get
    Set
public:
property Adp1650TypeAdditionalModeAdModIlDcEn AdditionalModeADMODILDCEN {
    Adp1650TypeAdditionalModeAdModIlDcEn get ();
    void set (Adp1650TypeAdditionalModeAdModIlDcEn value);
}
member AdditionalModeADMODILDCEN : Adp1650TypeAdditionalModeAdModIlDcEn with get, set

Property Value

Type: Adp1650TypeAdditionalModeAdModIlDcEn
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.AdditionalModeADMODSTRPOL Property

IRD

Adp1650AdditionalModeADMODSTRPOL Property

Additional Mode, AD_MOD: STR_POL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeAdditionalModeAdModStrPol AdditionalModeADMODSTRPOL { get; set; }
Public Property AdditionalModeADMODSTRPOL As Adp1650TypeAdditionalModeAdModStrPol
    Get
    Set
public:
property Adp1650TypeAdditionalModeAdModStrPol AdditionalModeADMODSTRPOL {
    Adp1650TypeAdditionalModeAdModStrPol get ();
    void set (Adp1650TypeAdditionalModeAdModStrPol value);
}
member AdditionalModeADMODSTRPOL : Adp1650TypeAdditionalModeAdModStrPol with get, set

Property Value

Type: Adp1650TypeAdditionalModeAdModStrPol
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.AdditionalModeADMODSWLO Property

IRD

Adp1650AdditionalModeADMODSWLO Property

Additional Mode, AD_MOD: SW_LO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeAdditionalModeAdModSwLo AdditionalModeADMODSWLO { get; set; }
Public Property AdditionalModeADMODSWLO As Adp1650TypeAdditionalModeAdModSwLo
    Get
    Set
public:
property Adp1650TypeAdditionalModeAdModSwLo AdditionalModeADMODSWLO {
    Adp1650TypeAdditionalModeAdModSwLo get ();
    void set (Adp1650TypeAdditionalModeAdModSwLo value);
}
member AdditionalModeADMODSWLO : Adp1650TypeAdditionalModeAdModSwLo with get, set

Property Value

Type: Adp1650TypeAdditionalModeAdModSwLo
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.AutoFlush Property

IRD

Adp1650AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.BatteryLowModeCLSOFT Property

IRD

Adp1650BatteryLowModeCLSOFT Property

Battery Low Mode: CL_SOFT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeBatteryLowModeClSoft BatteryLowModeCLSOFT { get; set; }
Public Property BatteryLowModeCLSOFT As Adp1650TypeBatteryLowModeClSoft
    Get
    Set
public:
property Adp1650TypeBatteryLowModeClSoft BatteryLowModeCLSOFT {
    Adp1650TypeBatteryLowModeClSoft get ();
    void set (Adp1650TypeBatteryLowModeClSoft value);
}
member BatteryLowModeCLSOFT : Adp1650TypeBatteryLowModeClSoft with get, set

Property Value

Type: Adp1650TypeBatteryLowModeClSoft
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.BatteryLowModeIVBLO Property

IRD

Adp1650BatteryLowModeIVBLO Property

Battery Low Mode: I_VB_LO (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeBatteryLowModeIVbLo BatteryLowModeIVBLO { get; }
Public ReadOnly Property BatteryLowModeIVBLO As Adp1650TypeBatteryLowModeIVbLo
    Get
public:
property Adp1650TypeBatteryLowModeIVbLo BatteryLowModeIVBLO {
    Adp1650TypeBatteryLowModeIVbLo get ();
}
member BatteryLowModeIVBLO : Adp1650TypeBatteryLowModeIVbLo with get

Property Value

Type: Adp1650TypeBatteryLowModeIVbLo
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.BatteryLowModeVVBLO Property

IRD

Adp1650BatteryLowModeVVBLO Property

Battery Low Mode: V_VB_LO (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeBatteryLowModeVVbLo BatteryLowModeVVBLO { get; set; }
Public Property BatteryLowModeVVBLO As Adp1650TypeBatteryLowModeVVbLo
    Get
    Set
public:
property Adp1650TypeBatteryLowModeVVbLo BatteryLowModeVVBLO {
    Adp1650TypeBatteryLowModeVVbLo get ();
    void set (Adp1650TypeBatteryLowModeVVbLo value);
}
member BatteryLowModeVVBLO : Adp1650TypeBatteryLowModeVVbLo with get, set

Property Value

Type: Adp1650TypeBatteryLowModeVVbLo
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.CurrentSetIFL Property

IRD

Adp1650CurrentSetIFL Property

Current Set: I_FL (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeCurrentSetIFl CurrentSetIFL { get; set; }
Public Property CurrentSetIFL As Adp1650TypeCurrentSetIFl
    Get
    Set
public:
property Adp1650TypeCurrentSetIFl CurrentSetIFL {
    Adp1650TypeCurrentSetIFl get ();
    void set (Adp1650TypeCurrentSetIFl value);
}
member CurrentSetIFL : Adp1650TypeCurrentSetIFl with get, set

Property Value

Type: Adp1650TypeCurrentSetIFl
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.CurrentSetITOR Property

IRD

Adp1650CurrentSetITOR Property

Current Set: I_TOR (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeCurrentSetITor CurrentSetITOR { get; set; }
Public Property CurrentSetITOR As Adp1650TypeCurrentSetITor
    Get
    Set
public:
property Adp1650TypeCurrentSetITor CurrentSetITOR {
    Adp1650TypeCurrentSetITor get ();
    void set (Adp1650TypeCurrentSetITor value);
}
member CurrentSetITOR : Adp1650TypeCurrentSetITor with get, set

Property Value

Type: Adp1650TypeCurrentSetITor
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.DesignInformationManufacturerInformation Property

IRD

Adp1650DesignInformationManufacturerInformation Property

Design Information: Manufacturer Information

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DesignInformationManufacturerInformation { get; }
Public ReadOnly Property DesignInformationManufacturerInformation As Byte
    Get
public:
property unsigned char DesignInformationManufacturerInformation {
    unsigned char get ();
}
member DesignInformationManufacturerInformation : byte with get

Property Value

Type: Byte
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.FaultInformationFLIDC Property

IRD

Adp1650FaultInformationFLIDC Property

Fault Information: FL_IDC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeFaultInformationIdc FaultInformationFLIDC { get; }
Public ReadOnly Property FaultInformationFLIDC As Adp1650TypeFaultInformationIdc
    Get
public:
property Adp1650TypeFaultInformationIdc FaultInformationFLIDC {
    Adp1650TypeFaultInformationIdc get ();
}
member FaultInformationFLIDC : Adp1650TypeFaultInformationIdc with get

Property Value

Type: Adp1650TypeFaultInformationIdc
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.FaultInformationFLIL Property

IRD

Adp1650FaultInformationFLIL Property

Fault Information: FL_IL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeFaultInformationFl FaultInformationFLIL { get; }
Public ReadOnly Property FaultInformationFLIL As Adp1650TypeFaultInformationFl
    Get
public:
property Adp1650TypeFaultInformationFl FaultInformationFLIL {
    Adp1650TypeFaultInformationFl get ();
}
member FaultInformationFLIL : Adp1650TypeFaultInformationFl with get

Property Value

Type: Adp1650TypeFaultInformationFl
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.FaultInformationFLIO2 Property

IRD

Adp1650FaultInformationFLIO2 Property

Fault Information: FL_IO2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeFaultInformationIo2 FaultInformationFLIO2 { get; }
Public ReadOnly Property FaultInformationFLIO2 As Adp1650TypeFaultInformationIo2
    Get
public:
property Adp1650TypeFaultInformationIo2 FaultInformationFLIO2 {
    Adp1650TypeFaultInformationIo2 get ();
}
member FaultInformationFLIO2 : Adp1650TypeFaultInformationIo2 with get

Property Value

Type: Adp1650TypeFaultInformationIo2
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.FaultInformationFLOT Property

IRD

Adp1650FaultInformationFLOT Property

Fault Information: FL_OT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeFaultInformationFl FaultInformationFLOT { get; }
Public ReadOnly Property FaultInformationFLOT As Adp1650TypeFaultInformationFl
    Get
public:
property Adp1650TypeFaultInformationFl FaultInformationFLOT {
    Adp1650TypeFaultInformationFl get ();
}
member FaultInformationFLOT : Adp1650TypeFaultInformationFl with get

Property Value

Type: Adp1650TypeFaultInformationFl
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.FaultInformationFLOVP Property

IRD

Adp1650FaultInformationFLOVP Property

Fault Information: FL_OVP

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeFaultInformationFl FaultInformationFLOVP { get; }
Public ReadOnly Property FaultInformationFLOVP As Adp1650TypeFaultInformationFl
    Get
public:
property Adp1650TypeFaultInformationFl FaultInformationFLOVP {
    Adp1650TypeFaultInformationFl get ();
}
member FaultInformationFLOVP : Adp1650TypeFaultInformationFl with get

Property Value

Type: Adp1650TypeFaultInformationFl
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.FaultInformationFLSC Property

IRD

Adp1650FaultInformationFLSC Property

Fault Information: FL_SC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeFaultInformationFl FaultInformationFLSC { get; }
Public ReadOnly Property FaultInformationFLSC As Adp1650TypeFaultInformationFl
    Get
public:
property Adp1650TypeFaultInformationFl FaultInformationFLSC {
    Adp1650TypeFaultInformationFl get ();
}
member FaultInformationFLSC : Adp1650TypeFaultInformationFl with get

Property Value

Type: Adp1650TypeFaultInformationFl
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.FaultInformationFLTO Property

IRD

Adp1650FaultInformationFLTO Property

Fault Information: FL_TO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeFaultInformationFl FaultInformationFLTO { get; }
Public ReadOnly Property FaultInformationFLTO As Adp1650TypeFaultInformationFl
    Get
public:
property Adp1650TypeFaultInformationFl FaultInformationFLTO {
    Adp1650TypeFaultInformationFl get ();
}
member FaultInformationFLTO : Adp1650TypeFaultInformationFl with get

Property Value

Type: Adp1650TypeFaultInformationFl
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.FaultInformationFLTX1 Property

IRD

Adp1650FaultInformationFLTX1 Property

Fault Information: FL_TX1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeFaultInformationTx1 FaultInformationFLTX1 { get; }
Public ReadOnly Property FaultInformationFLTX1 As Adp1650TypeFaultInformationTx1
    Get
public:
property Adp1650TypeFaultInformationTx1 FaultInformationFLTX1 {
    Adp1650TypeFaultInformationTx1 get ();
}
member FaultInformationFLTX1 : Adp1650TypeFaultInformationTx1 with get

Property Value

Type: Adp1650TypeFaultInformationTx1
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.InputControlITX1 Property

IRD

Adp1650InputControlITX1 Property

Input Control: I_TX1 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeInputControl InputControlITX1 { get; set; }
Public Property InputControlITX1 As Adp1650TypeInputControl
    Get
    Set
public:
property Adp1650TypeInputControl InputControlITX1 {
    Adp1650TypeInputControl get ();
    void set (Adp1650TypeInputControl value);
}
member InputControlITX1 : Adp1650TypeInputControl with get, set

Property Value

Type: Adp1650TypeInputControl
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.InputControlITX2 Property

IRD

Adp1650InputControlITX2 Property

Input Control: I_TX2 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeInputControl InputControlITX2 { get; set; }
Public Property InputControlITX2 As Adp1650TypeInputControl
    Get
    Set
public:
property Adp1650TypeInputControl InputControlITX2 {
    Adp1650TypeInputControl get ();
    void set (Adp1650TypeInputControl value);
}
member InputControlITX2 : Adp1650TypeInputControl with get, set

Property Value

Type: Adp1650TypeInputControl
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.OutputModeFREQFB Property

IRD

Adp1650OutputModeFREQFB Property

Output Mode: FREQ_FB

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeOutputModeFreqFb OutputModeFREQFB { get; set; }
Public Property OutputModeFREQFB As Adp1650TypeOutputModeFreqFb
    Get
    Set
public:
property Adp1650TypeOutputModeFreqFb OutputModeFREQFB {
    Adp1650TypeOutputModeFreqFb get ();
    void set (Adp1650TypeOutputModeFreqFb value);
}
member OutputModeFREQFB : Adp1650TypeOutputModeFreqFb with get, set

Property Value

Type: Adp1650TypeOutputModeFreqFb
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.OutputModeILPEAK Property

IRD

Adp1650OutputModeILPEAK Property

Output Mode: IL_PEAK (unit: A)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeOutputModeIlPeak OutputModeILPEAK { get; set; }
Public Property OutputModeILPEAK As Adp1650TypeOutputModeIlPeak
    Get
    Set
public:
property Adp1650TypeOutputModeIlPeak OutputModeILPEAK {
    Adp1650TypeOutputModeIlPeak get ();
    void set (Adp1650TypeOutputModeIlPeak value);
}
member OutputModeILPEAK : Adp1650TypeOutputModeIlPeak with get, set

Property Value

Type: Adp1650TypeOutputModeIlPeak
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.OutputModeLEDMOD Property

IRD

Adp1650OutputModeLEDMOD Property

Output Mode: LED_MOD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeOutputModeLedMode OutputModeLEDMOD { get; set; }
Public Property OutputModeLEDMOD As Adp1650TypeOutputModeLedMode
    Get
    Set
public:
property Adp1650TypeOutputModeLedMode OutputModeLEDMOD {
    Adp1650TypeOutputModeLedMode get ();
    void set (Adp1650TypeOutputModeLedMode value);
}
member OutputModeLEDMOD : Adp1650TypeOutputModeLedMode with get, set

Property Value

Type: Adp1650TypeOutputModeLedMode
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.OutputModeOUTPUTEN Property

IRD

Adp1650OutputModeOUTPUTEN Property

Output Mode: OUTPUT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeOutputModeOutputEn OutputModeOUTPUTEN { get; set; }
Public Property OutputModeOUTPUTEN As Adp1650TypeOutputModeOutputEn
    Get
    Set
public:
property Adp1650TypeOutputModeOutputEn OutputModeOUTPUTEN {
    Adp1650TypeOutputModeOutputEn get ();
    void set (Adp1650TypeOutputModeOutputEn value);
}
member OutputModeOUTPUTEN : Adp1650TypeOutputModeOutputEn with get, set

Property Value

Type: Adp1650TypeOutputModeOutputEn
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.OutputModeSTRLV Property

IRD

Adp1650OutputModeSTRLV Property

Output Mode: STR_LV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeOutputModeStrLv OutputModeSTRLV { get; set; }
Public Property OutputModeSTRLV As Adp1650TypeOutputModeStrLv
    Get
    Set
public:
property Adp1650TypeOutputModeStrLv OutputModeSTRLV {
    Adp1650TypeOutputModeStrLv get ();
    void set (Adp1650TypeOutputModeStrLv value);
}
member OutputModeSTRLV : Adp1650TypeOutputModeStrLv with get, set

Property Value

Type: Adp1650TypeOutputModeStrLv
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.OutputModeSTRMODE Property

IRD

Adp1650OutputModeSTRMODE Property

Output Mode: STR_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeOutputModeStrMode OutputModeSTRMODE { get; set; }
Public Property OutputModeSTRMODE As Adp1650TypeOutputModeStrMode
    Get
    Set
public:
property Adp1650TypeOutputModeStrMode OutputModeSTRMODE {
    Adp1650TypeOutputModeStrMode get ();
    void set (Adp1650TypeOutputModeStrMode value);
}
member OutputModeSTRMODE : Adp1650TypeOutputModeStrMode with get, set

Property Value

Type: Adp1650TypeOutputModeStrMode
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.VREFAndTimerFLTIM Property

IRD

Adp1650VREFAndTimerFLTIM Property

VREF and Timer: FL_TIM (unit: ms)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeVrefTimerFlTim VREFAndTimerFLTIM { get; set; }
Public Property VREFAndTimerFLTIM As Adp1650TypeVrefTimerFlTim
    Get
    Set
public:
property Adp1650TypeVrefTimerFlTim VREFAndTimerFLTIM {
    Adp1650TypeVrefTimerFlTim get ();
    void set (Adp1650TypeVrefTimerFlTim value);
}
member VREFAndTimerFLTIM : Adp1650TypeVrefTimerFlTim with get, set

Property Value

Type: Adp1650TypeVrefTimerFlTim
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.VREFAndTimerIO1CFG Property

IRD

Adp1650VREFAndTimerIO1CFG Property

VREF and Timer: IO1_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeVrefTimerIo1Cfg VREFAndTimerIO1CFG { get; set; }
Public Property VREFAndTimerIO1CFG As Adp1650TypeVrefTimerIo1Cfg
    Get
    Set
public:
property Adp1650TypeVrefTimerIo1Cfg VREFAndTimerIO1CFG {
    Adp1650TypeVrefTimerIo1Cfg get ();
    void set (Adp1650TypeVrefTimerIo1Cfg value);
}
member VREFAndTimerIO1CFG : Adp1650TypeVrefTimerIo1Cfg with get, set

Property Value

Type: Adp1650TypeVrefTimerIo1Cfg
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.VREFAndTimerIO2CFG Property

IRD

Adp1650VREFAndTimerIO2CFG Property

VREF and Timer: IO2_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1650TypeVrefTimerIo2Cfg VREFAndTimerIO2CFG { get; set; }
Public Property VREFAndTimerIO2CFG As Adp1650TypeVrefTimerIo2Cfg
    Get
    Set
public:
property Adp1650TypeVrefTimerIo2Cfg VREFAndTimerIO2CFG {
    Adp1650TypeVrefTimerIo2Cfg get ();
    void set (Adp1650TypeVrefTimerIo2Cfg value);
}
member VREFAndTimerIO2CFG : Adp1650TypeVrefTimerIo2Cfg with get, set

Property Value

Type: Adp1650TypeVrefTimerIo2Cfg
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650 Methods

The Adp1650 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.Flush Method

IRD

Adp1650Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adp1650 Class
telos.Ird.AnalogDevices Namespace


Adp1650.TypeAdditionalModeAdcAdcEn Enumeration

IRD

Adp1650TypeAdditionalModeAdcAdcEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalModeAdcAdcEn
Public Enumeration TypeAdditionalModeAdcAdcEn
public enum class TypeAdditionalModeAdcAdcEn
type TypeAdditionalModeAdcAdcEn
Members
Member name | Value | Description
Disabled | 0 | Disabled
LEDVFMeasurement | 1 | LED V_F Measurement
DieTemperatureMeasurement | 2 | Die Temperature Measurement
ExternalVoltageMode | 3 | External Voltage Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeAdditionalModeAdcFlVbLo Enumeration

IRD

Adp1650TypeAdditionalModeAdcFlVbLo Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalModeAdcFlVbLo
Public Enumeration TypeAdditionalModeAdcFlVbLo
public enum class TypeAdditionalModeAdcFlVbLo
type TypeAdditionalModeAdcFlVbLo
Members
Member name | Value | Description
VDDVBATLowThreshold | 0 | V_DD > V_BAT Low Threshold
VDDVBATLowThreshold__1 | 1 | V_DD < V_BAT Low Threshold
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeAdditionalModeAdModDynOvp Enumeration

IRD

Adp1650TypeAdditionalModeAdModDynOvp Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalModeAdModDynOvp
Public Enumeration TypeAdditionalModeAdModDynOvp
public enum class TypeAdditionalModeAdModDynOvp
type TypeAdditionalModeAdModDynOvp
Members
Member name | Value | Description
DOVPOff | 0 | DOVP: Off
DOVPOn | 1 | DOVP: On
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeAdditionalModeAdModIIled Enumeration

IRD

Adp1650TypeAdditionalModeAdModIIled Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalModeAdModIIled
Public Enumeration TypeAdditionalModeAdModIIled
public enum class TypeAdditionalModeAdModIIled
type TypeAdditionalModeAdModIIled
Members
Member name | Value | Description
Value_2_75 | 0 | 2.75
Value_5_5 | 1 | 5.5
Value_8_25 | 2 | 8.25
Value_11 | 3 | 11
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeAdditionalModeAdModIlDc Enumeration

IRD

Adp1650TypeAdditionalModeAdModIlDc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalModeAdModIlDc
Public Enumeration TypeAdditionalModeAdModIlDc
public enum class TypeAdditionalModeAdModIlDc
type TypeAdditionalModeAdModIlDc
Members
Member name | Value | Description
Value_1_5 | 0 | 1.5
Value_1_75 | 1 | 1.75
Value_2_0 | 2 | 2.0
Value_2_25 | 3 | 2.25
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeAdditionalModeAdModIlDcEn Enumeration

IRD

Adp1650TypeAdditionalModeAdModIlDcEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalModeAdModIlDcEn
Public Enumeration TypeAdditionalModeAdModIlDcEn
public enum class TypeAdditionalModeAdModIlDcEn
type TypeAdditionalModeAdModIlDcEn
Members
Member name | Value | Description
InputDCCurrentLimitDisabled | 0 | Input DC Current Limit: Disabled
InputDCCurrentLimitEnabled | 1 | Input DC Current Limit: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeAdditionalModeAdModStrPol Enumeration

IRD

Adp1650TypeAdditionalModeAdModStrPol Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalModeAdModStrPol
Public Enumeration TypeAdditionalModeAdModStrPol
public enum class TypeAdditionalModeAdModStrPol
type TypeAdditionalModeAdModStrPol
Members
Member name | Value | Description
StrobePolarityActiveLow | 0 | Strobe Polarity: Active Low
StrobePolarityActiveHigh | 1 | Strobe Polarity: Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeAdditionalModeAdModSwLo Enumeration

IRD

Adp1650TypeAdditionalModeAdModSwLo Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalModeAdModSwLo
Public Enumeration TypeAdditionalModeAdModSwLo
public enum class TypeAdditionalModeAdModSwLo
type TypeAdditionalModeAdModSwLo
Members
Member name | Value | Description
Force15MHzSwitchingFrequencyDisabled | 0 | Force 1.5 MHz Switching Frequency: Disabled
Force15MHzSwitchingFrequencyEnabled | 1 | Force 1.5 MHz Switching Frequency: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeBatteryLowModeClSoft Enumeration

IRD

Adp1650TypeBatteryLowModeClSoft Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBatteryLowModeClSoft
Public Enumeration TypeBatteryLowModeClSoft
public enum class TypeBatteryLowModeClSoft
type TypeBatteryLowModeClSoft
Members
Member name | Value | Description
SoftInductorPeakCurrentLimitDisabled | 0 | Soft Inductor Peak Current Limit: Disabled
SoftInductorPeakCurrentLimitEnabled | 1 | Soft Inductor Peak Current Limit: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeBatteryLowModeIVbLo Enumeration

IRD

Adp1650TypeBatteryLowModeIVbLo Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBatteryLowModeIVbLo
Public Enumeration TypeBatteryLowModeIVbLo
public enum class TypeBatteryLowModeIVbLo
type TypeBatteryLowModeIVbLo
Members
Member name | Value | Description
Value_300 | 0 | 300
Value_350 | 1 | 350
Value_400 | 2 | 400
Value_450 | 3 | 450
Value_500 | 4 | 500
Value_550 | 5 | 550
Value_600 | 6 | 600
Value_650 | 7 | 650
Value_700 | 8 | 700
Value_750 | 9 | 750
Value_800 | 10 | 800
Value_850 | 11 | 850
Value_900 | 12 | 900
Value_950 | 13 | 950
Value_1000 | 14 | 1000
Value_1050 | 15 | 1050
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeBatteryLowModeVVbLo Enumeration

IRD

Adp1650TypeBatteryLowModeVVbLo Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBatteryLowModeVVbLo
Public Enumeration TypeBatteryLowModeVVbLo
public enum class TypeBatteryLowModeVVbLo
type TypeBatteryLowModeVVbLo
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_3_3 | 1 | 3.3
Value_3_35 | 2 | 3.35
Value_3_4 | 3 | 3.4
Value_3_45 | 4 | 3.45
Value_3_5 | 5 | 3.5
Value_3_55 | 6 | 3.55
Value_3_6 | 7 | 3.6
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeCurrentSetIFl Enumeration

IRD

Adp1650TypeCurrentSetIFl Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCurrentSetIFl
Public Enumeration TypeCurrentSetIFl
public enum class TypeCurrentSetIFl
type TypeCurrentSetIFl
Members
Member name | Value | Description
Value_300 | 0 | 300
Value_350 | 1 | 350
Value_400 | 2 | 400
Value_450 | 3 | 450
Value_500 | 4 | 500
Value_550 | 5 | 550
Value_600 | 6 | 600
Value_650 | 7 | 650
Value_700 | 8 | 700
Value_750 | 9 | 750
Value_800 | 10 | 800
Value_850 | 11 | 850
Value_900 | 12 | 900
Value_950 | 13 | 950
Value_1000 | 14 | 1000
Value_1050 | 15 | 1050
Value_1100 | 16 | 1100
Value_1150 | 17 | 1150
Value_1200 | 18 | 1200
Value_1250 | 19 | 1250
Value_1300 | 20 | 1300
Value_1350 | 21 | 1350
Value_1400 | 22 | 1400
Value_1450 | 23 | 1450
Value_1500 | 24 | 1500
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeCurrentSetITor Enumeration

IRD

Adp1650TypeCurrentSetITor Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCurrentSetITor
Public Enumeration TypeCurrentSetITor
public enum class TypeCurrentSetITor
type TypeCurrentSetITor
Members
Member name | Value | Description
Value_25 | 0 | 25
Value_50 | 1 | 50
Value_75 | 2 | 75
Value_100 | 3 | 100
Value_125 | 4 | 125
Value_150 | 5 | 150
Value_175 | 6 | 175
Value_200 | 7 | 200
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeFaultInformationFl Enumeration

IRD

Adp1650TypeFaultInformationFl Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultInformationFl
Public Enumeration TypeFaultInformationFl
public enum class TypeFaultInformationFl
type TypeFaultInformationFl
Members
Member name | Value | Description
NoFault | 0 | No Fault
Fault | 1 | Fault
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeFaultInformationIdc Enumeration

IRD

Adp1650TypeFaultInformationIdc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultInformationIdc
Public Enumeration TypeFaultInformationIdc
public enum class TypeFaultInformationIdc
type TypeFaultInformationIdc
Members
Member name | Value | Description
DCCurrentLimitNotHit | 0 | DC Current Limit: Not Hit
DCCurrentLimitHit | 1 | DC Current Limit: Hit
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeFaultInformationIo2 Enumeration

IRD

Adp1650TypeFaultInformationIo2 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultInformationIo2
Public Enumeration TypeFaultInformationIo2
public enum class TypeFaultInformationIo2
type TypeFaultInformationIo2
Members
Member name | Value | Description
NoTxMASK2OperationalModeDuringLastFlashNoFault | 0 | No TxMASK2 Operational Mode During Last Flash / No Fault
TxMASK2OperationalModeDuringLastFlashIndicatorLEDFault | 1 | TxMASK2 Operational Mode During Last Flash / Indicator LED Fault
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeFaultInformationTx1 Enumeration

IRD

Adp1650TypeFaultInformationTx1 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultInformationTx1
Public Enumeration TypeFaultInformationTx1
public enum class TypeFaultInformationTx1
type TypeFaultInformationTx1
Members
Member name | Value | Description
NoTxMASK1OperationalModeDuringLastFlash | 0 | No TxMASK1 Operational Mode During Last Flash
TxMASK1OperationalModeDuringLastFlash | 1 | TxMASK1 Operational Mode During Last Flash
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeInputControl Enumeration

IRD

Adp1650TypeInputControl Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInputControl
Public Enumeration TypeInputControl
public enum class TypeInputControl
type TypeInputControl
Members
Member name | Value | Description
Value_100 | 0 | 100
Value_150 | 1 | 150
Value_200 | 2 | 200
Value_250 | 3 | 250
Value_300 | 4 | 300
Value_350 | 5 | 350
Value_400 | 6 | 400
Value_450 | 7 | 450
Value_500 | 8 | 500
Value_550 | 9 | 550
Value_600 | 10 | 600
Value_650 | 11 | 650
Value_700 | 12 | 700
Value_750 | 13 | 750
Value_800 | 14 | 800
Value_850 | 15 | 850
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeOutputModeFreqFb Enumeration

IRD

Adp1650TypeOutputModeFreqFb Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeFreqFb
Public Enumeration TypeOutputModeFreqFb
public enum class TypeOutputModeFreqFb
type TypeOutputModeFreqFb
Members
Member name | Value | Description
FrequencyFoldbackNotAllowed | 0 | Frequency Foldback: Not Allowed
FrequencyFoldbackAllowed | 1 | Frequency Foldback: Allowed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeOutputModeIlPeak Enumeration

IRD

Adp1650TypeOutputModeIlPeak Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeIlPeak
Public Enumeration TypeOutputModeIlPeak
public enum class TypeOutputModeIlPeak
type TypeOutputModeIlPeak
Members
Member name | Value | Description
Value_1_75 | 0 | 1.75
Value_2_25 | 1 | 2.25
Value_2_75 | 2 | 2.75
Value_3_0 | 3 | 3.0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeOutputModeLedMode Enumeration

IRD

Adp1650TypeOutputModeLedMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeLedMode
Public Enumeration TypeOutputModeLedMode
public enum class TypeOutputModeLedMode
type TypeOutputModeLedMode
Members
Member name | Value | Description
StandbyMode | 0 | Standby Mode
VoltageOutputModeVOUT5V | 1 | Voltage Output Mode, VOUT = 5V
AssistLightMode | 2 | Assist Light Mode
FlashMode | 3 | Flash Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeOutputModeOutputEn Enumeration

IRD

Adp1650TypeOutputModeOutputEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeOutputEn
Public Enumeration TypeOutputModeOutputEn
public enum class TypeOutputModeOutputEn
type TypeOutputModeOutputEn
Members
Member name | Value | Description
OutputOff | 0 | Output: Off
OutputOn | 1 | Output: On
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeOutputModeStrLv Enumeration

IRD

Adp1650TypeOutputModeStrLv Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeStrLv
Public Enumeration TypeOutputModeStrLv
public enum class TypeOutputModeStrLv
type TypeOutputModeStrLv
Members
Member name | Value | Description
EdgeSensitive | 0 | Edge Sensitive
LevelSensitive | 1 | Level Sensitive
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeOutputModeStrMode Enumeration

IRD

Adp1650TypeOutputModeStrMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeStrMode
Public Enumeration TypeOutputModeStrMode
public enum class TypeOutputModeStrMode
type TypeOutputModeStrMode
Members
Member name | Value | Description
SoftwareStrobeMode | 0 | Software Strobe Mode
HardwareStrobeMode | 1 | Hardware Strobe Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeVrefTimerFlTim Enumeration

IRD

Adp1650TypeVrefTimerFlTim Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVrefTimerFlTim
Public Enumeration TypeVrefTimerFlTim
public enum class TypeVrefTimerFlTim
type TypeVrefTimerFlTim
Members
Member name | Value | Description
Value_100 | 0 | 100
Value_200 | 1 | 200
Value_300 | 2 | 300
Value_400 | 3 | 400
Value_500 | 4 | 500
Value_600 | 5 | 600
Value_700 | 6 | 700
Value_800 | 7 | 800
Value_900 | 8 | 900
Value_1000 | 9 | 1000
Value_1100 | 10 | 1100
Value_1200 | 11 | 1200
Value_1300 | 12 | 1300
Value_1400 | 13 | 1400
Value_1500 | 14 | 1500
Value_1600 | 15 | 1600
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeVrefTimerIo1Cfg Enumeration

IRD

Adp1650TypeVrefTimerIo1Cfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVrefTimerIo1Cfg
Public Enumeration TypeVrefTimerIo1Cfg
public enum class TypeVrefTimerIo1Cfg
type TypeVrefTimerIo1Cfg
Members
Member name | Value | Description
HighImpedance | 0 | High Impedance
Torch | 1 | Torch
TxMASK1OperationMode | 2 | TxMASK1 Operation Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1650.TypeVrefTimerIo2Cfg Enumeration

IRD

Adp1650TypeVrefTimerIo2Cfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVrefTimerIo2Cfg
Public Enumeration TypeVrefTimerIo2Cfg
public enum class TypeVrefTimerIo2Cfg
type TypeVrefTimerIo2Cfg
Members
Member name | Value | Description
HighImpedance | 0 | High Impedance
IndicatorLED | 1 | Indicator LED
TxMASK2OperationMode | 2 | TxMASK2 Operation Mode
AnalogInput | 3 | Analog Input
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1653 Class

Analog Devices: ADP 1653
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdp1653

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adp1653
Public Class Adp1653
public ref class Adp1653
type Adp1653 =  class end

The Adp1653 type exposes the following members.

Constructors
 | Name | Description
Public method | Adp1653 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | HighPowerLEDCurrent | High Power LED Current
Public property | IndicatorLEDCurrent | Indicator LED Current
Public property | OvertemperatureFault | Overtemperature Fault
Public property | OvervoltageFault | Overvoltage Fault
Public property | ShortCircuitFault | Short-Circuit Fault
Public property | SoftwareStrobeEnable | Software Strobe Enable
Public property | TimeoutFault | Timeout Fault
Public property | TimerConfiguration | Timer Configuration
Public property | TimerPeriodSetting | Timer Period Setting
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Compact, High Efficiency, High Power, Flash/Torch LED Driver with Dual Interface
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1653 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1653(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adp1653(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adp1653

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adp1653 Class
telos.Ird.AnalogDevices Namespace


Adp1653 Properties

The Adp1653 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | HighPowerLEDCurrent | High Power LED Current
Public property | IndicatorLEDCurrent | Indicator LED Current
Public property | OvertemperatureFault | Overtemperature Fault
Public property | OvervoltageFault | Overvoltage Fault
Public property | ShortCircuitFault | Short-Circuit Fault
Public property | SoftwareStrobeEnable | Software Strobe Enable
Public property | TimeoutFault | Timeout Fault
Public property | TimerConfiguration | Timer Configuration
Public property | TimerPeriodSetting | Timer Period Setting
Top
See Also

Reference

Adp1653 Class
telos.Ird.AnalogDevices Namespace


Adp1653.AutoFlush Property

IRD

Adp1653AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adp1653 Class
telos.Ird.AnalogDevices Namespace


Adp1653.HighPowerLEDCurrent Property

IRD

Adp1653HighPowerLEDCurrent Property

High Power LED Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte HighPowerLEDCurrent { get; set; }
Public Property HighPowerLEDCurrent As Byte
    Get
    Set
public:
property unsigned char HighPowerLEDCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member HighPowerLEDCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp1653 Class
telos.Ird.AnalogDevices Namespace


Adp1653.IndicatorLEDCurrent Property

IRD

Adp1653IndicatorLEDCurrent Property

Indicator LED Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IndicatorLEDCurrent { get; set; }
Public Property IndicatorLEDCurrent As Byte
    Get
    Set
public:
property unsigned char IndicatorLEDCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member IndicatorLEDCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp1653 Class
telos.Ird.AnalogDevices Namespace


Adp1653.OvertemperatureFault Property

IRD

Adp1653OvertemperatureFault Property

Overtemperature Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OvertemperatureFault { get; set; }
Public Property OvertemperatureFault As Byte
    Get
    Set
public:
property unsigned char OvertemperatureFault {
    unsigned char get ();
    void set (unsigned char value);
}
member OvertemperatureFault : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp1653 Class
telos.Ird.AnalogDevices Namespace


Adp1653.OvervoltageFault Property

IRD

Adp1653OvervoltageFault Property

Overvoltage Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OvervoltageFault { get; set; }
Public Property OvervoltageFault As Byte
    Get
    Set
public:
property unsigned char OvervoltageFault {
    unsigned char get ();
    void set (unsigned char value);
}
member OvervoltageFault : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp1653 Class
telos.Ird.AnalogDevices Namespace


Adp1653.ShortCircuitFault Property

IRD

Adp1653ShortCircuitFault Property

Short-Circuit Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ShortCircuitFault { get; set; }
Public Property ShortCircuitFault As Byte
    Get
    Set
public:
property unsigned char ShortCircuitFault {
    unsigned char get ();
    void set (unsigned char value);
}
member ShortCircuitFault : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp1653 Class
telos.Ird.AnalogDevices Namespace


Adp1653.SoftwareStrobeEnable Property

IRD

Adp1653SoftwareStrobeEnable Property

Software Strobe Enable

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SoftwareStrobeEnable { get; set; }
Public Property SoftwareStrobeEnable As Byte
    Get
    Set
public:
property unsigned char SoftwareStrobeEnable {
    unsigned char get ();
    void set (unsigned char value);
}
member SoftwareStrobeEnable : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp1653 Class
telos.Ird.AnalogDevices Namespace


Adp1653.TimeoutFault Property

IRD

Adp1653TimeoutFault Property

Timeout Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TimeoutFault { get; set; }
Public Property TimeoutFault As Byte
    Get
    Set
public:
property unsigned char TimeoutFault {
    unsigned char get ();
    void set (unsigned char value);
}
member TimeoutFault : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp1653 Class
telos.Ird.AnalogDevices Namespace


Adp1653.TimerConfiguration Property

IRD

Adp1653TimerConfiguration Property

Timer Configuration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TimerConfiguration { get; set; }
Public Property TimerConfiguration As Byte
    Get
    Set
public:
property unsigned char TimerConfiguration {
    unsigned char get ();
    void set (unsigned char value);
}
member TimerConfiguration : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp1653 Class
telos.Ird.AnalogDevices Namespace


Adp1653.TimerPeriodSetting Property

IRD

Adp1653TimerPeriodSetting Property

Timer Period Setting

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TimerPeriodSetting { get; set; }
Public Property TimerPeriodSetting As Byte
    Get
    Set
public:
property unsigned char TimerPeriodSetting {
    unsigned char get ();
    void set (unsigned char value);
}
member TimerPeriodSetting : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp1653 Class
telos.Ird.AnalogDevices Namespace


Adp1653 Methods

The Adp1653 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adp1653 Class
telos.Ird.AnalogDevices Namespace


Adp1653.Flush Method

IRD

Adp1653Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adp1653 Class
telos.Ird.AnalogDevices Namespace


Adp1655 Class

Analog Devices: ADP 1655
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdp1655

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adp1655
Public Class Adp1655
public ref class Adp1655
type Adp1655 =  class end

The Adp1655 type exposes the following members.

Constructors
 | Name | Description
Public method | Adp1655 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CurrentSetFlashCurrentValue | Current Set: Flash Current Value (unit: mA)
Public property | CurrentSetTorchAssistLightCurrentValue | Current Set: Torch & Assist Light Current Value (unit: mA)
Public property | DesignInformation | Design Information
Public property | FaultInformationCurrentLimit | Fault Information: Current Limit
Public property | FaultInformationLEDs | Fault Information: LEDs
Public property | FaultInformationOvertemperature | Fault Information: Overtemperature
Public property | FaultInformationOvervoltageCOUT | Fault Information: Overvoltage / C_OUT
Public property | FaultInformationShortCircuit | Fault Information: Short-Circuit
Public property | FaultInformationTimeout850Ms | Fault Information: Timeout 850 ms
Public property | InputControlStrobe | Input Control: Strobe
Public property | InputControlTXMASK | Input Control: TX_MASK
Public property | OutputModeEdgeLevelSensitive | Output Mode: Edge/Level Sensitive
Public property | OutputModeInductorPeakCurrent | Output Mode: Inductor Peak Current
Public property | OutputModeLEDOUT | Output Mode: LED_OUT
Public property | OutputModeLEDOutputMode | Output Mode: LED Output Mode
Public property | OutputModeSTROBE | Output Mode: STROBE
Public property | OutputModeTorch | Output Mode: Torch
Public property | Version | Version
Public property | VREFAndTimerFlashTimer | VREF and Timer: Flash Timer (unit: ms)
Public property | VREFAndTimerReferenceLevel | VREF and Timer: Reference Level (unit: V)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Dual LED Flash Driver with I2C-Compatible Interface
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1655 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adp1655(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adp1655

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655 Properties

The Adp1655 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CurrentSetFlashCurrentValue | Current Set: Flash Current Value (unit: mA)
Public property | CurrentSetTorchAssistLightCurrentValue | Current Set: Torch & Assist Light Current Value (unit: mA)
Public property | DesignInformation | Design Information
Public property | FaultInformationCurrentLimit | Fault Information: Current Limit
Public property | FaultInformationLEDs | Fault Information: LEDs
Public property | FaultInformationOvertemperature | Fault Information: Overtemperature
Public property | FaultInformationOvervoltageCOUT | Fault Information: Overvoltage / C_OUT
Public property | FaultInformationShortCircuit | Fault Information: Short-Circuit
Public property | FaultInformationTimeout850Ms | Fault Information: Timeout 850 ms
Public property | InputControlStrobe | Input Control: Strobe
Public property | InputControlTXMASK | Input Control: TX_MASK
Public property | OutputModeEdgeLevelSensitive | Output Mode: Edge/Level Sensitive
Public property | OutputModeInductorPeakCurrent | Output Mode: Inductor Peak Current
Public property | OutputModeLEDOUT | Output Mode: LED_OUT
Public property | OutputModeLEDOutputMode | Output Mode: LED Output Mode
Public property | OutputModeSTROBE | Output Mode: STROBE
Public property | OutputModeTorch | Output Mode: Torch
Public property | Version | Version
Public property | VREFAndTimerFlashTimer | VREF and Timer: Flash Timer (unit: ms)
Public property | VREFAndTimerReferenceLevel | VREF and Timer: Reference Level (unit: V)
Top
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.AutoFlush Property

IRD

Adp1655AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.CurrentSetFlashCurrentValue Property

IRD

Adp1655CurrentSetFlashCurrentValue Property

Current Set: Flash Current Value (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655TypeCurrentSetFlash CurrentSetFlashCurrentValue { get; set; }
Public Property CurrentSetFlashCurrentValue As Adp1655TypeCurrentSetFlash
    Get
    Set
public:
property Adp1655TypeCurrentSetFlash CurrentSetFlashCurrentValue {
    Adp1655TypeCurrentSetFlash get ();
    void set (Adp1655TypeCurrentSetFlash value);
}
member CurrentSetFlashCurrentValue : Adp1655TypeCurrentSetFlash with get, set

Property Value

Type: Adp1655TypeCurrentSetFlash
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.CurrentSetTorchAssistLightCurrentValue Property

IRD

Adp1655CurrentSetTorchAssistLightCurrentValue Property

Current Set: Torch & Assist Light Current Value (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655TypeCurrentSetTorchAssist CurrentSetTorchAssistLightCurrentValue { get; set; }
Public Property CurrentSetTorchAssistLightCurrentValue As Adp1655TypeCurrentSetTorchAssist
    Get
    Set
public:
property Adp1655TypeCurrentSetTorchAssist CurrentSetTorchAssistLightCurrentValue {
    Adp1655TypeCurrentSetTorchAssist get ();
    void set (Adp1655TypeCurrentSetTorchAssist value);
}
member CurrentSetTorchAssistLightCurrentValue : Adp1655TypeCurrentSetTorchAssist with get, set

Property Value

Type: Adp1655TypeCurrentSetTorchAssist
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.DesignInformation Property

IRD

Adp1655DesignInformation Property

Design Information

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DesignInformation { get; }
Public ReadOnly Property DesignInformation As Byte
    Get
public:
property unsigned char DesignInformation {
    unsigned char get ();
}
member DesignInformation : byte with get

Property Value

Type: Byte
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.FaultInformationCurrentLimit Property

IRD

Adp1655FaultInformationCurrentLimit Property

Fault Information: Current Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655TypeFaultInformationFault FaultInformationCurrentLimit { get; }
Public ReadOnly Property FaultInformationCurrentLimit As Adp1655TypeFaultInformationFault
    Get
public:
property Adp1655TypeFaultInformationFault FaultInformationCurrentLimit {
    Adp1655TypeFaultInformationFault get ();
}
member FaultInformationCurrentLimit : Adp1655TypeFaultInformationFault with get

Property Value

Type: Adp1655TypeFaultInformationFault
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.FaultInformationLEDs Property

IRD

Adp1655FaultInformationLEDs Property

Fault Information: LEDs

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655TypeFaultInformationLed FaultInformationLEDs { get; set; }
Public Property FaultInformationLEDs As Adp1655TypeFaultInformationLed
    Get
    Set
public:
property Adp1655TypeFaultInformationLed FaultInformationLEDs {
    Adp1655TypeFaultInformationLed get ();
    void set (Adp1655TypeFaultInformationLed value);
}
member FaultInformationLEDs : Adp1655TypeFaultInformationLed with get, set

Property Value

Type: Adp1655TypeFaultInformationLed
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.FaultInformationOvertemperature Property

IRD

Adp1655FaultInformationOvertemperature Property

Fault Information: Overtemperature

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655TypeFaultInformationFault FaultInformationOvertemperature { get; }
Public ReadOnly Property FaultInformationOvertemperature As Adp1655TypeFaultInformationFault
    Get
public:
property Adp1655TypeFaultInformationFault FaultInformationOvertemperature {
    Adp1655TypeFaultInformationFault get ();
}
member FaultInformationOvertemperature : Adp1655TypeFaultInformationFault with get

Property Value

Type: Adp1655TypeFaultInformationFault
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.FaultInformationOvervoltageCOUT Property

IRD

Adp1655FaultInformationOvervoltageCOUT Property

Fault Information: Overvoltage / C_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655TypeFaultInformationFault FaultInformationOvervoltageCOUT { get; }
Public ReadOnly Property FaultInformationOvervoltageCOUT As Adp1655TypeFaultInformationFault
    Get
public:
property Adp1655TypeFaultInformationFault FaultInformationOvervoltageCOUT {
    Adp1655TypeFaultInformationFault get ();
}
member FaultInformationOvervoltageCOUT : Adp1655TypeFaultInformationFault with get

Property Value

Type: Adp1655TypeFaultInformationFault
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.FaultInformationShortCircuit Property

IRD

Adp1655FaultInformationShortCircuit Property

Fault Information: Short-Circuit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655TypeFaultInformationFault FaultInformationShortCircuit { get; }
Public ReadOnly Property FaultInformationShortCircuit As Adp1655TypeFaultInformationFault
    Get
public:
property Adp1655TypeFaultInformationFault FaultInformationShortCircuit {
    Adp1655TypeFaultInformationFault get ();
}
member FaultInformationShortCircuit : Adp1655TypeFaultInformationFault with get

Property Value

Type: Adp1655TypeFaultInformationFault
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.FaultInformationTimeout850Ms Property

IRD

Adp1655FaultInformationTimeout850Ms Property

Fault Information: Timeout 850 ms

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655TypeFaultInformationFault FaultInformationTimeout850Ms { get; }
Public ReadOnly Property FaultInformationTimeout850Ms As Adp1655TypeFaultInformationFault
    Get
public:
property Adp1655TypeFaultInformationFault FaultInformationTimeout850Ms {
    Adp1655TypeFaultInformationFault get ();
}
member FaultInformationTimeout850Ms : Adp1655TypeFaultInformationFault with get

Property Value

Type: Adp1655TypeFaultInformationFault
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.InputControlStrobe Property

IRD

Adp1655InputControlStrobe Property

Input Control: Strobe

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655TypeInputControlStrobe InputControlStrobe { get; set; }
Public Property InputControlStrobe As Adp1655TypeInputControlStrobe
    Get
    Set
public:
property Adp1655TypeInputControlStrobe InputControlStrobe {
    Adp1655TypeInputControlStrobe get ();
    void set (Adp1655TypeInputControlStrobe value);
}
member InputControlStrobe : Adp1655TypeInputControlStrobe with get, set

Property Value

Type: Adp1655TypeInputControlStrobe
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.InputControlTXMASK Property

IRD

Adp1655InputControlTXMASK Property

Input Control: TX_MASK

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655TypeInputControlTxMask InputControlTXMASK { get; set; }
Public Property InputControlTXMASK As Adp1655TypeInputControlTxMask
    Get
    Set
public:
property Adp1655TypeInputControlTxMask InputControlTXMASK {
    Adp1655TypeInputControlTxMask get ();
    void set (Adp1655TypeInputControlTxMask value);
}
member InputControlTXMASK : Adp1655TypeInputControlTxMask with get, set

Property Value

Type: Adp1655TypeInputControlTxMask
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.OutputModeEdgeLevelSensitive Property

IRD

Adp1655OutputModeEdgeLevelSensitive Property

Output Mode: Edge/Level Sensitive

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655TypeOutputModeEdgeLevelSensitive OutputModeEdgeLevelSensitive { get; set; }
Public Property OutputModeEdgeLevelSensitive As Adp1655TypeOutputModeEdgeLevelSensitive
    Get
    Set
public:
property Adp1655TypeOutputModeEdgeLevelSensitive OutputModeEdgeLevelSensitive {
    Adp1655TypeOutputModeEdgeLevelSensitive get ();
    void set (Adp1655TypeOutputModeEdgeLevelSensitive value);
}
member OutputModeEdgeLevelSensitive : Adp1655TypeOutputModeEdgeLevelSensitive with get, set

Property Value

Type: Adp1655TypeOutputModeEdgeLevelSensitive
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.OutputModeInductorPeakCurrent Property

IRD

Adp1655OutputModeInductorPeakCurrent Property

Output Mode: Inductor Peak Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655TypeOutputModeInductorPeakCurrentLimit OutputModeInductorPeakCurrent { get; set; }
Public Property OutputModeInductorPeakCurrent As Adp1655TypeOutputModeInductorPeakCurrentLimit
    Get
    Set
public:
property Adp1655TypeOutputModeInductorPeakCurrentLimit OutputModeInductorPeakCurrent {
    Adp1655TypeOutputModeInductorPeakCurrentLimit get ();
    void set (Adp1655TypeOutputModeInductorPeakCurrentLimit value);
}
member OutputModeInductorPeakCurrent : Adp1655TypeOutputModeInductorPeakCurrentLimit with get, set

Property Value

Type: Adp1655TypeOutputModeInductorPeakCurrentLimit
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.OutputModeLEDOUT Property

IRD

Adp1655OutputModeLEDOUT Property

Output Mode: LED_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655TypeOutputModeLedOut OutputModeLEDOUT { get; set; }
Public Property OutputModeLEDOUT As Adp1655TypeOutputModeLedOut
    Get
    Set
public:
property Adp1655TypeOutputModeLedOut OutputModeLEDOUT {
    Adp1655TypeOutputModeLedOut get ();
    void set (Adp1655TypeOutputModeLedOut value);
}
member OutputModeLEDOUT : Adp1655TypeOutputModeLedOut with get, set

Property Value

Type: Adp1655TypeOutputModeLedOut
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.OutputModeLEDOutputMode Property

IRD

Adp1655OutputModeLEDOutputMode Property

Output Mode: LED Output Mode

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655TypeOutputModeLedOutputMode OutputModeLEDOutputMode { get; set; }
Public Property OutputModeLEDOutputMode As Adp1655TypeOutputModeLedOutputMode
    Get
    Set
public:
property Adp1655TypeOutputModeLedOutputMode OutputModeLEDOutputMode {
    Adp1655TypeOutputModeLedOutputMode get ();
    void set (Adp1655TypeOutputModeLedOutputMode value);
}
member OutputModeLEDOutputMode : Adp1655TypeOutputModeLedOutputMode with get, set

Property Value

Type: Adp1655TypeOutputModeLedOutputMode
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.OutputModeSTROBE Property

IRD

Adp1655OutputModeSTROBE Property

Output Mode: STROBE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655TypeOutputModeStrobe OutputModeSTROBE { get; set; }
Public Property OutputModeSTROBE As Adp1655TypeOutputModeStrobe
    Get
    Set
public:
property Adp1655TypeOutputModeStrobe OutputModeSTROBE {
    Adp1655TypeOutputModeStrobe get ();
    void set (Adp1655TypeOutputModeStrobe value);
}
member OutputModeSTROBE : Adp1655TypeOutputModeStrobe with get, set

Property Value

Type: Adp1655TypeOutputModeStrobe
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.OutputModeTorch Property

IRD

Adp1655OutputModeTorch Property

Output Mode: Torch

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655TypeOutputModeTorch OutputModeTorch { get; set; }
Public Property OutputModeTorch As Adp1655TypeOutputModeTorch
    Get
    Set
public:
property Adp1655TypeOutputModeTorch OutputModeTorch {
    Adp1655TypeOutputModeTorch get ();
    void set (Adp1655TypeOutputModeTorch value);
}
member OutputModeTorch : Adp1655TypeOutputModeTorch with get, set

Property Value

Type: Adp1655TypeOutputModeTorch
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.Version Property

IRD

Adp1655Version Property

Version

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Version { get; }
Public ReadOnly Property Version As Byte
    Get
public:
property unsigned char Version {
    unsigned char get ();
}
member Version : byte with get

Property Value

Type: Byte
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.VREFAndTimerFlashTimer Property

IRD

Adp1655VREFAndTimerFlashTimer Property

VREF and Timer: Flash Timer (unit: ms)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655TypeVrefTimerTimer VREFAndTimerFlashTimer { get; set; }
Public Property VREFAndTimerFlashTimer As Adp1655TypeVrefTimerTimer
    Get
    Set
public:
property Adp1655TypeVrefTimerTimer VREFAndTimerFlashTimer {
    Adp1655TypeVrefTimerTimer get ();
    void set (Adp1655TypeVrefTimerTimer value);
}
member VREFAndTimerFlashTimer : Adp1655TypeVrefTimerTimer with get, set

Property Value

Type: Adp1655TypeVrefTimerTimer
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.VREFAndTimerReferenceLevel Property

IRD

Adp1655VREFAndTimerReferenceLevel Property

VREF and Timer: Reference Level (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1655TypeVrefTimerRef VREFAndTimerReferenceLevel { get; set; }
Public Property VREFAndTimerReferenceLevel As Adp1655TypeVrefTimerRef
    Get
    Set
public:
property Adp1655TypeVrefTimerRef VREFAndTimerReferenceLevel {
    Adp1655TypeVrefTimerRef get ();
    void set (Adp1655TypeVrefTimerRef value);
}
member VREFAndTimerReferenceLevel : Adp1655TypeVrefTimerRef with get, set

Property Value

Type: Adp1655TypeVrefTimerRef
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655 Methods

The Adp1655 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.Flush Method

IRD

Adp1655Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adp1655 Class
telos.Ird.AnalogDevices Namespace


Adp1655.TypeCurrentSetFlash Enumeration

IRD

Adp1655TypeCurrentSetFlash Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCurrentSetFlash
Public Enumeration TypeCurrentSetFlash
public enum class TypeCurrentSetFlash
type TypeCurrentSetFlash
Members
Member name | Value | Description
Value_200 | 0 | 200
Value_220 | 1 | 220
Value_240 | 2 | 240
Value_260 | 3 | 260
Value_280 | 4 | 280
Value_300 | 5 | 300
Value_320 | 6 | 320
Value_340 | 7 | 340
Value_360 | 8 | 360
Value_380 | 9 | 380
Value_400 | 10 | 400
Value_420 | 11 | 420
Value_440 | 12 | 440
Value_460 | 13 | 460
Value_480 | 14 | 480
Value_500 | 15 | 500
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1655.TypeCurrentSetTorchAssist Enumeration

IRD

Adp1655TypeCurrentSetTorchAssist Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCurrentSetTorchAssist
Public Enumeration TypeCurrentSetTorchAssist
public enum class TypeCurrentSetTorchAssist
type TypeCurrentSetTorchAssist
Members
Member name | Value | Description
Value_20 | 0 | 20
Value_40 | 1 | 40
Value_60 | 2 | 60
Value_80 | 3 | 80
Value_100 | 4 | 100
Value_120 | 5 | 120
Value_140 | 6 | 140
Value_160 | 7 | 160
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1655.TypeFaultInformationFault Enumeration

IRD

Adp1655TypeFaultInformationFault Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultInformationFault
Public Enumeration TypeFaultInformationFault
public enum class TypeFaultInformationFault
type TypeFaultInformationFault
Members
Member name | Value | Description
NoFault | 0 | No Fault
Fault | 1 | Fault
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1655.TypeFaultInformationLed Enumeration

IRD

Adp1655TypeFaultInformationLed Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultInformationLed
Public Enumeration TypeFaultInformationLed
public enum class TypeFaultInformationLed
type TypeFaultInformationLed
Members
Member name | Value | Description
OneLED | 0 | One LED
TwoLEDs | 1 | Two LEDs
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1655.TypeInputControlStrobe Enumeration

IRD

Adp1655TypeInputControlStrobe Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInputControlStrobe
Public Enumeration TypeInputControlStrobe
public enum class TypeInputControlStrobe
type TypeInputControlStrobe
Members
Member name | Value | Description
Strobe0TriggersFlashInLevelSensitiveModeStrobe10TriggersFlashInEdgeSensitiveMode | 0 | Strobe 0 triggers flash in level sensitive mode, Strobe 1 > 0 triggers flash in edge sensitive mode
Strobe1TriggersFlashInLevelSensitiveModeStrobe01TriggersFlashInEdgeSensitiveMode | 1 | Strobe 1 triggers flash in level sensitive mode, Strobe 0 > 1 triggers flash in edge sensitive mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1655.TypeInputControlTxMask Enumeration

IRD

Adp1655TypeInputControlTxMask Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInputControlTxMask
Public Enumeration TypeInputControlTxMask
public enum class TypeInputControlTxMask
type TypeInputControlTxMask
Members
Member name | Value | Description
TXMASKDisabled | 0 | TX_MASK: Disabled
TXMASKAllowed | 1 | TX_MASK: Allowed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1655.TypeOutputModeEdgeLevelSensitive Enumeration

IRD

Adp1655TypeOutputModeEdgeLevelSensitive Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeEdgeLevelSensitive
Public Enumeration TypeOutputModeEdgeLevelSensitive
public enum class TypeOutputModeEdgeLevelSensitive
type TypeOutputModeEdgeLevelSensitive
Members
Member name | Value | Description
EdgeSensitive | 0 | Edge Sensitive
LevelSensitive | 1 | Level Sensitive
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1655.TypeOutputModeInductorPeakCurrentLimit Enumeration

IRD

Adp1655TypeOutputModeInductorPeakCurrentLimit Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeInductorPeakCurrentLimit
Public Enumeration TypeOutputModeInductorPeakCurrentLimit
public enum class TypeOutputModeInductorPeakCurrentLimit
type TypeOutputModeInductorPeakCurrentLimit
Members
Member name | Value | Description
Value_1_25 | 0 | 1.25
Value_1_5 | 1 | 1.5
Value_1_75 | 2 | 1.75
Value_2_0 | 3 | 2.0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1655.TypeOutputModeLedOut Enumeration

IRD

Adp1655TypeOutputModeLedOut Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeLedOut
Public Enumeration TypeOutputModeLedOut
public enum class TypeOutputModeLedOut
type TypeOutputModeLedOut
Members
Member name | Value | Description
LEDOUTOff | 0 | LED_OUT: Off
LEDOUTOn | 1 | LED_OUT: On
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1655.TypeOutputModeLedOutputMode Enumeration

IRD

Adp1655TypeOutputModeLedOutputMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeLedOutputMode
Public Enumeration TypeOutputModeLedOutputMode
public enum class TypeOutputModeLedOutputMode
type TypeOutputModeLedOutputMode
Members
Member name | Value | Description
StandbyMode | 0 | Standby Mode
Reserved | 1 | Reserved
AssistLightMode | 2 | Assist Light Mode
FlashMode | 3 | Flash Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1655.TypeOutputModeStrobe Enumeration

IRD

Adp1655TypeOutputModeStrobe Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeStrobe
Public Enumeration TypeOutputModeStrobe
public enum class TypeOutputModeStrobe
type TypeOutputModeStrobe
Members
Member name | Value | Description
STROBEDisabled | 0 | STROBE: Disabled
STROBEEnabled | 1 | STROBE: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1655.TypeOutputModeTorch Enumeration

IRD

Adp1655TypeOutputModeTorch Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeTorch
Public Enumeration TypeOutputModeTorch
public enum class TypeOutputModeTorch
type TypeOutputModeTorch
Members
Member name | Value | Description
TORCHNotAllowed | 0 | TORCH: Not Allowed
TORCHAllowed | 1 | TORCH: Allowed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1655.TypeVrefTimerRef Enumeration

IRD

Adp1655TypeVrefTimerRef Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVrefTimerRef
Public Enumeration TypeVrefTimerRef
public enum class TypeVrefTimerRef
type TypeVrefTimerRef
Members
Member name | Value | Description
Value_4_3 | 0 | 4.3
Value_4_6 | 1 | 4.6
Value_4_0 | 2 | 4.0
Value_4_9 | 3 | 4.9
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1655.TypeVrefTimerTimer Enumeration

IRD

Adp1655TypeVrefTimerTimer Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVrefTimerTimer
Public Enumeration TypeVrefTimerTimer
public enum class TypeVrefTimerTimer
type TypeVrefTimerTimer
Members
Member name | Value | Description
Value_100 | 0 | 100
Value_150 | 1 | 150
Value_200 | 2 | 200
Value_250 | 3 | 250
Value_300 | 4 | 300
Value_350 | 5 | 350
Value_400 | 6 | 400
Value_450 | 7 | 450
Value_500 | 8 | 500
Value_550 | 9 | 550
Value_600 | 10 | 600
Value_650 | 11 | 650
Value_700 | 12 | 700
Value_750 | 13 | 750
Value_800 | 14 | 800
Value_850 | 15 | 850
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660 Class

Analog Devices: ADP 1660
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdp1660

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adp1660
Public Class Adp1660
public ref class Adp1660
type Adp1660 =  class end

The Adp1660 type exposes the following members.

Constructors
 | Name | Description
Public method | Adp1660 | Constructor
Top
Properties
 | Name | Description
Public property | AdditionalFeaturesCLSOFT | Additional Features: CL_SOFT
Public property | AdditionalFeaturesDYNOVP | Additional Features: DYN_OVP
Public property | AdditionalFeaturesFREQFB | Additional Features: FREQ_FB
Public property | AdditionalFeaturesILDC | Additional Features: IL_DC (unit: A)
Public property | AdditionalFeaturesILDCEN | Additional Features: IL_DC_EN
Public property | AdditionalFeaturesSWLO | Additional Features: SW_LO
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DesignInformationDEVICEID | Design Information: DEVICE_ID
Public property | DesignInformationREVID | Design Information: REV_ID
Public property | FaultInformationFLIDC | Fault Information: FL_IDC
Public property | FaultInformationFLIL | Fault Information: FL_IL
Public property | FaultInformationFLOT | Fault Information: FL_OT
Public property | FaultInformationFLOVP | Fault Information: FL_OVP
Public property | FaultInformationFLSC | Fault Information: FL_SC
Public property | FaultInformationFLTO | Fault Information: FL_TO
Public property | FaultInformationFLTX | Fault Information: FL_TX
Public property | FaultInformationFLVBLO | Fault Information: FL_VB_LO
Public property | GPIOAndTimerFLTIM | GPIO and Timer: FL_TIM (unit: ms)
Public property | GPIOAndTimerIOCFG | GPIO and Timer: IO_CFG
Public property | GPIOAndTimerLEDSD | GPIO and Timer: LED_SD
Public property | LED1FlashCurrentFaultReadbackFLIFL1 | LED1 Flash Current Fault Readback: FL_I_FL1 (unit: mA)
Public property | LED1FlashCurrentIFL1 | LED1 Flash Current: I_FL1 (unit: mA)
Public property | LED1TorchAssistCurrentITOR1 | LED1 Torch/Assist Current: I_TOR1 (unit: mA)
Public property | LED1TxMASKITX1 | LED1 TxMASK: I_TX1 (unit: mA)
Public property | LED2FlashCurrentFaultReadbackFLIFL2 | LED2 Flash Current Fault Readback: FL_I_FL2 (unit: mA)
Public property | LED2FlashCurrentIFL2 | LED2 Flash Current: I_FL2 (unit: mA)
Public property | LED2TorchAssistCurrentITOR2 | LED2 Torch/Assist Current: I_TOR2 (unit: mA)
Public property | LED2TxMASKITX2 | LED2 TxMASK: I_TX2 (unit: mA)
Public property | LEDEnableModeLED1EN | LED Enable Mode: LED1_EN
Public property | LEDEnableModeLED2EN | LED Enable Mode: LED2_EN
Public property | LowBatteryCurrentIVBLO | Low Battery Current: I_VB_LO (unit: mA)
Public property | LowBatteryEnableVBATTWINDOW | Low Battery Enable: V_BATT_WINDOW (unit: ms)
Public property | LowBatteryEnableVVBLO | Low Battery Enable: V_VB_LO (unit: V)
Public property | OutputModeILPEAK | Output Mode: IL_PEAK
Public property | OutputModeLEDMOD | Output Mode: LED_MOD
Public property | OutputModeSTRLV | Output Mode: STR_LV
Public property | OutputModeSTRMOD | Output Mode: STR_MOD
Public property | OutputModeSTRPOL | Output Mode: STR_POL
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Dual 750 mA LED Flash Driver with I2C-Compatible Interface
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adp1660(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adp1660

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660 Properties

The Adp1660 type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalFeaturesCLSOFT | Additional Features: CL_SOFT
Public property | AdditionalFeaturesDYNOVP | Additional Features: DYN_OVP
Public property | AdditionalFeaturesFREQFB | Additional Features: FREQ_FB
Public property | AdditionalFeaturesILDC | Additional Features: IL_DC (unit: A)
Public property | AdditionalFeaturesILDCEN | Additional Features: IL_DC_EN
Public property | AdditionalFeaturesSWLO | Additional Features: SW_LO
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DesignInformationDEVICEID | Design Information: DEVICE_ID
Public property | DesignInformationREVID | Design Information: REV_ID
Public property | FaultInformationFLIDC | Fault Information: FL_IDC
Public property | FaultInformationFLIL | Fault Information: FL_IL
Public property | FaultInformationFLOT | Fault Information: FL_OT
Public property | FaultInformationFLOVP | Fault Information: FL_OVP
Public property | FaultInformationFLSC | Fault Information: FL_SC
Public property | FaultInformationFLTO | Fault Information: FL_TO
Public property | FaultInformationFLTX | Fault Information: FL_TX
Public property | FaultInformationFLVBLO | Fault Information: FL_VB_LO
Public property | GPIOAndTimerFLTIM | GPIO and Timer: FL_TIM (unit: ms)
Public property | GPIOAndTimerIOCFG | GPIO and Timer: IO_CFG
Public property | GPIOAndTimerLEDSD | GPIO and Timer: LED_SD
Public property | LED1FlashCurrentFaultReadbackFLIFL1 | LED1 Flash Current Fault Readback: FL_I_FL1 (unit: mA)
Public property | LED1FlashCurrentIFL1 | LED1 Flash Current: I_FL1 (unit: mA)
Public property | LED1TorchAssistCurrentITOR1 | LED1 Torch/Assist Current: I_TOR1 (unit: mA)
Public property | LED1TxMASKITX1 | LED1 TxMASK: I_TX1 (unit: mA)
Public property | LED2FlashCurrentFaultReadbackFLIFL2 | LED2 Flash Current Fault Readback: FL_I_FL2 (unit: mA)
Public property | LED2FlashCurrentIFL2 | LED2 Flash Current: I_FL2 (unit: mA)
Public property | LED2TorchAssistCurrentITOR2 | LED2 Torch/Assist Current: I_TOR2 (unit: mA)
Public property | LED2TxMASKITX2 | LED2 TxMASK: I_TX2 (unit: mA)
Public property | LEDEnableModeLED1EN | LED Enable Mode: LED1_EN
Public property | LEDEnableModeLED2EN | LED Enable Mode: LED2_EN
Public property | LowBatteryCurrentIVBLO | Low Battery Current: I_VB_LO (unit: mA)
Public property | LowBatteryEnableVBATTWINDOW | Low Battery Enable: V_BATT_WINDOW (unit: ms)
Public property | LowBatteryEnableVVBLO | Low Battery Enable: V_VB_LO (unit: V)
Public property | OutputModeILPEAK | Output Mode: IL_PEAK
Public property | OutputModeLEDMOD | Output Mode: LED_MOD
Public property | OutputModeSTRLV | Output Mode: STR_LV
Public property | OutputModeSTRMOD | Output Mode: STR_MOD
Public property | OutputModeSTRPOL | Output Mode: STR_POL
Top
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.AdditionalFeaturesCLSOFT Property

IRD

Adp1660AdditionalFeaturesCLSOFT Property

Additional Features: CL_SOFT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeAdditionalFeaturesClSoft AdditionalFeaturesCLSOFT { get; set; }
Public Property AdditionalFeaturesCLSOFT As Adp1660TypeAdditionalFeaturesClSoft
    Get
    Set
public:
property Adp1660TypeAdditionalFeaturesClSoft AdditionalFeaturesCLSOFT {
    Adp1660TypeAdditionalFeaturesClSoft get ();
    void set (Adp1660TypeAdditionalFeaturesClSoft value);
}
member AdditionalFeaturesCLSOFT : Adp1660TypeAdditionalFeaturesClSoft with get, set

Property Value

Type: Adp1660TypeAdditionalFeaturesClSoft
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.AdditionalFeaturesDYNOVP Property

IRD

Adp1660AdditionalFeaturesDYNOVP Property

Additional Features: DYN_OVP

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeAdditionalFeaturesDynOvp AdditionalFeaturesDYNOVP { get; set; }
Public Property AdditionalFeaturesDYNOVP As Adp1660TypeAdditionalFeaturesDynOvp
    Get
    Set
public:
property Adp1660TypeAdditionalFeaturesDynOvp AdditionalFeaturesDYNOVP {
    Adp1660TypeAdditionalFeaturesDynOvp get ();
    void set (Adp1660TypeAdditionalFeaturesDynOvp value);
}
member AdditionalFeaturesDYNOVP : Adp1660TypeAdditionalFeaturesDynOvp with get, set

Property Value

Type: Adp1660TypeAdditionalFeaturesDynOvp
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.AdditionalFeaturesFREQFB Property

IRD

Adp1660AdditionalFeaturesFREQFB Property

Additional Features: FREQ_FB

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeAdditionalFeaturesFreqFb AdditionalFeaturesFREQFB { get; set; }
Public Property AdditionalFeaturesFREQFB As Adp1660TypeAdditionalFeaturesFreqFb
    Get
    Set
public:
property Adp1660TypeAdditionalFeaturesFreqFb AdditionalFeaturesFREQFB {
    Adp1660TypeAdditionalFeaturesFreqFb get ();
    void set (Adp1660TypeAdditionalFeaturesFreqFb value);
}
member AdditionalFeaturesFREQFB : Adp1660TypeAdditionalFeaturesFreqFb with get, set

Property Value

Type: Adp1660TypeAdditionalFeaturesFreqFb
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.AdditionalFeaturesILDC Property

IRD

Adp1660AdditionalFeaturesILDC Property

Additional Features: IL_DC (unit: A)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeAdditionalFeaturesIlDc AdditionalFeaturesILDC { get; set; }
Public Property AdditionalFeaturesILDC As Adp1660TypeAdditionalFeaturesIlDc
    Get
    Set
public:
property Adp1660TypeAdditionalFeaturesIlDc AdditionalFeaturesILDC {
    Adp1660TypeAdditionalFeaturesIlDc get ();
    void set (Adp1660TypeAdditionalFeaturesIlDc value);
}
member AdditionalFeaturesILDC : Adp1660TypeAdditionalFeaturesIlDc with get, set

Property Value

Type: Adp1660TypeAdditionalFeaturesIlDc
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.AdditionalFeaturesILDCEN Property

IRD

Adp1660AdditionalFeaturesILDCEN Property

Additional Features: IL_DC_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeAdditionalFeaturesIlDcEn AdditionalFeaturesILDCEN { get; set; }
Public Property AdditionalFeaturesILDCEN As Adp1660TypeAdditionalFeaturesIlDcEn
    Get
    Set
public:
property Adp1660TypeAdditionalFeaturesIlDcEn AdditionalFeaturesILDCEN {
    Adp1660TypeAdditionalFeaturesIlDcEn get ();
    void set (Adp1660TypeAdditionalFeaturesIlDcEn value);
}
member AdditionalFeaturesILDCEN : Adp1660TypeAdditionalFeaturesIlDcEn with get, set

Property Value

Type: Adp1660TypeAdditionalFeaturesIlDcEn
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.AdditionalFeaturesSWLO Property

IRD

Adp1660AdditionalFeaturesSWLO Property

Additional Features: SW_LO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeAdditionalFeaturesSwLo AdditionalFeaturesSWLO { get; set; }
Public Property AdditionalFeaturesSWLO As Adp1660TypeAdditionalFeaturesSwLo
    Get
    Set
public:
property Adp1660TypeAdditionalFeaturesSwLo AdditionalFeaturesSWLO {
    Adp1660TypeAdditionalFeaturesSwLo get ();
    void set (Adp1660TypeAdditionalFeaturesSwLo value);
}
member AdditionalFeaturesSWLO : Adp1660TypeAdditionalFeaturesSwLo with get, set

Property Value

Type: Adp1660TypeAdditionalFeaturesSwLo
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.AutoFlush Property

IRD

Adp1660AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.DesignInformationDEVICEID Property

IRD

Adp1660DesignInformationDEVICEID Property

Design Information: DEVICE_ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DesignInformationDEVICEID { get; }
Public ReadOnly Property DesignInformationDEVICEID As Byte
    Get
public:
property unsigned char DesignInformationDEVICEID {
    unsigned char get ();
}
member DesignInformationDEVICEID : byte with get

Property Value

Type: Byte
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.DesignInformationREVID Property

IRD

Adp1660DesignInformationREVID Property

Design Information: REV_ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DesignInformationREVID { get; }
Public ReadOnly Property DesignInformationREVID As Byte
    Get
public:
property unsigned char DesignInformationREVID {
    unsigned char get ();
}
member DesignInformationREVID : byte with get

Property Value

Type: Byte
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.FaultInformationFLIDC Property

IRD

Adp1660FaultInformationFLIDC Property

Fault Information: FL_IDC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeFaultInformationFault FaultInformationFLIDC { get; }
Public ReadOnly Property FaultInformationFLIDC As Adp1660TypeFaultInformationFault
    Get
public:
property Adp1660TypeFaultInformationFault FaultInformationFLIDC {
    Adp1660TypeFaultInformationFault get ();
}
member FaultInformationFLIDC : Adp1660TypeFaultInformationFault with get

Property Value

Type: Adp1660TypeFaultInformationFault
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.FaultInformationFLIL Property

IRD

Adp1660FaultInformationFLIL Property

Fault Information: FL_IL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeFaultInformationFault FaultInformationFLIL { get; }
Public ReadOnly Property FaultInformationFLIL As Adp1660TypeFaultInformationFault
    Get
public:
property Adp1660TypeFaultInformationFault FaultInformationFLIL {
    Adp1660TypeFaultInformationFault get ();
}
member FaultInformationFLIL : Adp1660TypeFaultInformationFault with get

Property Value

Type: Adp1660TypeFaultInformationFault
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.FaultInformationFLOT Property

IRD

Adp1660FaultInformationFLOT Property

Fault Information: FL_OT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeFaultInformationFault FaultInformationFLOT { get; }
Public ReadOnly Property FaultInformationFLOT As Adp1660TypeFaultInformationFault
    Get
public:
property Adp1660TypeFaultInformationFault FaultInformationFLOT {
    Adp1660TypeFaultInformationFault get ();
}
member FaultInformationFLOT : Adp1660TypeFaultInformationFault with get

Property Value

Type: Adp1660TypeFaultInformationFault
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.FaultInformationFLOVP Property

IRD

Adp1660FaultInformationFLOVP Property

Fault Information: FL_OVP

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeFaultInformationFault FaultInformationFLOVP { get; }
Public ReadOnly Property FaultInformationFLOVP As Adp1660TypeFaultInformationFault
    Get
public:
property Adp1660TypeFaultInformationFault FaultInformationFLOVP {
    Adp1660TypeFaultInformationFault get ();
}
member FaultInformationFLOVP : Adp1660TypeFaultInformationFault with get

Property Value

Type: Adp1660TypeFaultInformationFault
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.FaultInformationFLSC Property

IRD

Adp1660FaultInformationFLSC Property

Fault Information: FL_SC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeFaultInformationFault FaultInformationFLSC { get; }
Public ReadOnly Property FaultInformationFLSC As Adp1660TypeFaultInformationFault
    Get
public:
property Adp1660TypeFaultInformationFault FaultInformationFLSC {
    Adp1660TypeFaultInformationFault get ();
}
member FaultInformationFLSC : Adp1660TypeFaultInformationFault with get

Property Value

Type: Adp1660TypeFaultInformationFault
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.FaultInformationFLTO Property

IRD

Adp1660FaultInformationFLTO Property

Fault Information: FL_TO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeFaultInformationFault FaultInformationFLTO { get; }
Public ReadOnly Property FaultInformationFLTO As Adp1660TypeFaultInformationFault
    Get
public:
property Adp1660TypeFaultInformationFault FaultInformationFLTO {
    Adp1660TypeFaultInformationFault get ();
}
member FaultInformationFLTO : Adp1660TypeFaultInformationFault with get

Property Value

Type: Adp1660TypeFaultInformationFault
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.FaultInformationFLTX Property

IRD

Adp1660FaultInformationFLTX Property

Fault Information: FL_TX

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeFaultInformationTx FaultInformationFLTX { get; }
Public ReadOnly Property FaultInformationFLTX As Adp1660TypeFaultInformationTx
    Get
public:
property Adp1660TypeFaultInformationTx FaultInformationFLTX {
    Adp1660TypeFaultInformationTx get ();
}
member FaultInformationFLTX : Adp1660TypeFaultInformationTx with get

Property Value

Type: Adp1660TypeFaultInformationTx
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.FaultInformationFLVBLO Property

IRD

Adp1660FaultInformationFLVBLO Property

Fault Information: FL_VB_LO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeFaultInformationVbLo FaultInformationFLVBLO { get; }
Public ReadOnly Property FaultInformationFLVBLO As Adp1660TypeFaultInformationVbLo
    Get
public:
property Adp1660TypeFaultInformationVbLo FaultInformationFLVBLO {
    Adp1660TypeFaultInformationVbLo get ();
}
member FaultInformationFLVBLO : Adp1660TypeFaultInformationVbLo with get

Property Value

Type: Adp1660TypeFaultInformationVbLo
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.GPIOAndTimerFLTIM Property

IRD

Adp1660GPIOAndTimerFLTIM Property

GPIO and Timer: FL_TIM (unit: ms)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeGpioTimerFlTim GPIOAndTimerFLTIM { get; set; }
Public Property GPIOAndTimerFLTIM As Adp1660TypeGpioTimerFlTim
    Get
    Set
public:
property Adp1660TypeGpioTimerFlTim GPIOAndTimerFLTIM {
    Adp1660TypeGpioTimerFlTim get ();
    void set (Adp1660TypeGpioTimerFlTim value);
}
member GPIOAndTimerFLTIM : Adp1660TypeGpioTimerFlTim with get, set

Property Value

Type: Adp1660TypeGpioTimerFlTim
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.GPIOAndTimerIOCFG Property

IRD

Adp1660GPIOAndTimerIOCFG Property

GPIO and Timer: IO_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeGpioTimerIoCfg GPIOAndTimerIOCFG { get; set; }
Public Property GPIOAndTimerIOCFG As Adp1660TypeGpioTimerIoCfg
    Get
    Set
public:
property Adp1660TypeGpioTimerIoCfg GPIOAndTimerIOCFG {
    Adp1660TypeGpioTimerIoCfg get ();
    void set (Adp1660TypeGpioTimerIoCfg value);
}
member GPIOAndTimerIOCFG : Adp1660TypeGpioTimerIoCfg with get, set

Property Value

Type: Adp1660TypeGpioTimerIoCfg
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.GPIOAndTimerLEDSD Property

IRD

Adp1660GPIOAndTimerLEDSD Property

GPIO and Timer: LED_SD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeGpioTimerLedSd GPIOAndTimerLEDSD { get; set; }
Public Property GPIOAndTimerLEDSD As Adp1660TypeGpioTimerLedSd
    Get
    Set
public:
property Adp1660TypeGpioTimerLedSd GPIOAndTimerLEDSD {
    Adp1660TypeGpioTimerLedSd get ();
    void set (Adp1660TypeGpioTimerLedSd value);
}
member GPIOAndTimerLEDSD : Adp1660TypeGpioTimerLedSd with get, set

Property Value

Type: Adp1660TypeGpioTimerLedSd
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.LED1FlashCurrentFaultReadbackFLIFL1 Property

IRD

Adp1660LED1FlashCurrentFaultReadbackFLIFL1 Property

LED1 Flash Current Fault Readback: FL_I_FL1 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeCurrent750 LED1FlashCurrentFaultReadbackFLIFL1 { get; }
Public ReadOnly Property LED1FlashCurrentFaultReadbackFLIFL1 As Adp1660TypeCurrent750
    Get
public:
property Adp1660TypeCurrent750 LED1FlashCurrentFaultReadbackFLIFL1 {
    Adp1660TypeCurrent750 get ();
}
member LED1FlashCurrentFaultReadbackFLIFL1 : Adp1660TypeCurrent750 with get

Property Value

Type: Adp1660TypeCurrent750
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.LED1FlashCurrentIFL1 Property

IRD

Adp1660LED1FlashCurrentIFL1 Property

LED1 Flash Current: I_FL1 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeCurrent750 LED1FlashCurrentIFL1 { get; set; }
Public Property LED1FlashCurrentIFL1 As Adp1660TypeCurrent750
    Get
    Set
public:
property Adp1660TypeCurrent750 LED1FlashCurrentIFL1 {
    Adp1660TypeCurrent750 get ();
    void set (Adp1660TypeCurrent750 value);
}
member LED1FlashCurrentIFL1 : Adp1660TypeCurrent750 with get, set

Property Value

Type: Adp1660TypeCurrent750
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.LED1TorchAssistCurrentITOR1 Property

IRD

Adp1660LED1TorchAssistCurrentITOR1 Property

LED1 Torch/Assist Current: I_TOR1 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeCurrent200 LED1TorchAssistCurrentITOR1 { get; set; }
Public Property LED1TorchAssistCurrentITOR1 As Adp1660TypeCurrent200
    Get
    Set
public:
property Adp1660TypeCurrent200 LED1TorchAssistCurrentITOR1 {
    Adp1660TypeCurrent200 get ();
    void set (Adp1660TypeCurrent200 value);
}
member LED1TorchAssistCurrentITOR1 : Adp1660TypeCurrent200 with get, set

Property Value

Type: Adp1660TypeCurrent200
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.LED1TxMASKITX1 Property

IRD

Adp1660LED1TxMASKITX1 Property

LED1 TxMASK: I_TX1 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeCurrent750 LED1TxMASKITX1 { get; set; }
Public Property LED1TxMASKITX1 As Adp1660TypeCurrent750
    Get
    Set
public:
property Adp1660TypeCurrent750 LED1TxMASKITX1 {
    Adp1660TypeCurrent750 get ();
    void set (Adp1660TypeCurrent750 value);
}
member LED1TxMASKITX1 : Adp1660TypeCurrent750 with get, set

Property Value

Type: Adp1660TypeCurrent750
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.LED2FlashCurrentFaultReadbackFLIFL2 Property

IRD

Adp1660LED2FlashCurrentFaultReadbackFLIFL2 Property

LED2 Flash Current Fault Readback: FL_I_FL2 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeCurrent750 LED2FlashCurrentFaultReadbackFLIFL2 { get; }
Public ReadOnly Property LED2FlashCurrentFaultReadbackFLIFL2 As Adp1660TypeCurrent750
    Get
public:
property Adp1660TypeCurrent750 LED2FlashCurrentFaultReadbackFLIFL2 {
    Adp1660TypeCurrent750 get ();
}
member LED2FlashCurrentFaultReadbackFLIFL2 : Adp1660TypeCurrent750 with get

Property Value

Type: Adp1660TypeCurrent750
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.LED2FlashCurrentIFL2 Property

IRD

Adp1660LED2FlashCurrentIFL2 Property

LED2 Flash Current: I_FL2 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeCurrent750 LED2FlashCurrentIFL2 { get; set; }
Public Property LED2FlashCurrentIFL2 As Adp1660TypeCurrent750
    Get
    Set
public:
property Adp1660TypeCurrent750 LED2FlashCurrentIFL2 {
    Adp1660TypeCurrent750 get ();
    void set (Adp1660TypeCurrent750 value);
}
member LED2FlashCurrentIFL2 : Adp1660TypeCurrent750 with get, set

Property Value

Type: Adp1660TypeCurrent750
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.LED2TorchAssistCurrentITOR2 Property

IRD

Adp1660LED2TorchAssistCurrentITOR2 Property

LED2 Torch/Assist Current: I_TOR2 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeCurrent200 LED2TorchAssistCurrentITOR2 { get; set; }
Public Property LED2TorchAssistCurrentITOR2 As Adp1660TypeCurrent200
    Get
    Set
public:
property Adp1660TypeCurrent200 LED2TorchAssistCurrentITOR2 {
    Adp1660TypeCurrent200 get ();
    void set (Adp1660TypeCurrent200 value);
}
member LED2TorchAssistCurrentITOR2 : Adp1660TypeCurrent200 with get, set

Property Value

Type: Adp1660TypeCurrent200
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.LED2TxMASKITX2 Property

IRD

Adp1660LED2TxMASKITX2 Property

LED2 TxMASK: I_TX2 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeCurrent750 LED2TxMASKITX2 { get; set; }
Public Property LED2TxMASKITX2 As Adp1660TypeCurrent750
    Get
    Set
public:
property Adp1660TypeCurrent750 LED2TxMASKITX2 {
    Adp1660TypeCurrent750 get ();
    void set (Adp1660TypeCurrent750 value);
}
member LED2TxMASKITX2 : Adp1660TypeCurrent750 with get, set

Property Value

Type: Adp1660TypeCurrent750
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.LEDEnableModeLED1EN Property

IRD

Adp1660LEDEnableModeLED1EN Property

LED Enable Mode: LED1_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeLedEnableMode LEDEnableModeLED1EN { get; set; }
Public Property LEDEnableModeLED1EN As Adp1660TypeLedEnableMode
    Get
    Set
public:
property Adp1660TypeLedEnableMode LEDEnableModeLED1EN {
    Adp1660TypeLedEnableMode get ();
    void set (Adp1660TypeLedEnableMode value);
}
member LEDEnableModeLED1EN : Adp1660TypeLedEnableMode with get, set

Property Value

Type: Adp1660TypeLedEnableMode
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.LEDEnableModeLED2EN Property

IRD

Adp1660LEDEnableModeLED2EN Property

LED Enable Mode: LED2_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeLedEnableMode LEDEnableModeLED2EN { get; set; }
Public Property LEDEnableModeLED2EN As Adp1660TypeLedEnableMode
    Get
    Set
public:
property Adp1660TypeLedEnableMode LEDEnableModeLED2EN {
    Adp1660TypeLedEnableMode get ();
    void set (Adp1660TypeLedEnableMode value);
}
member LEDEnableModeLED2EN : Adp1660TypeLedEnableMode with get, set

Property Value

Type: Adp1660TypeLedEnableMode
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.LowBatteryCurrentIVBLO Property

IRD

Adp1660LowBatteryCurrentIVBLO Property

Low Battery Current: I_VB_LO (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeCurrent750 LowBatteryCurrentIVBLO { get; set; }
Public Property LowBatteryCurrentIVBLO As Adp1660TypeCurrent750
    Get
    Set
public:
property Adp1660TypeCurrent750 LowBatteryCurrentIVBLO {
    Adp1660TypeCurrent750 get ();
    void set (Adp1660TypeCurrent750 value);
}
member LowBatteryCurrentIVBLO : Adp1660TypeCurrent750 with get, set

Property Value

Type: Adp1660TypeCurrent750
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.LowBatteryEnableVBATTWINDOW Property

IRD

Adp1660LowBatteryEnableVBATTWINDOW Property

Low Battery Enable: V_BATT_WINDOW (unit: ms)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeLowBatteryEnableVBatWindow LowBatteryEnableVBATTWINDOW { get; set; }
Public Property LowBatteryEnableVBATTWINDOW As Adp1660TypeLowBatteryEnableVBatWindow
    Get
    Set
public:
property Adp1660TypeLowBatteryEnableVBatWindow LowBatteryEnableVBATTWINDOW {
    Adp1660TypeLowBatteryEnableVBatWindow get ();
    void set (Adp1660TypeLowBatteryEnableVBatWindow value);
}
member LowBatteryEnableVBATTWINDOW : Adp1660TypeLowBatteryEnableVBatWindow with get, set

Property Value

Type: Adp1660TypeLowBatteryEnableVBatWindow
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.LowBatteryEnableVVBLO Property

IRD

Adp1660LowBatteryEnableVVBLO Property

Low Battery Enable: V_VB_LO (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeLowBatteryEnableVVbLo LowBatteryEnableVVBLO { get; set; }
Public Property LowBatteryEnableVVBLO As Adp1660TypeLowBatteryEnableVVbLo
    Get
    Set
public:
property Adp1660TypeLowBatteryEnableVVbLo LowBatteryEnableVVBLO {
    Adp1660TypeLowBatteryEnableVVbLo get ();
    void set (Adp1660TypeLowBatteryEnableVVbLo value);
}
member LowBatteryEnableVVBLO : Adp1660TypeLowBatteryEnableVVbLo with get, set

Property Value

Type: Adp1660TypeLowBatteryEnableVVbLo
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.OutputModeILPEAK Property

IRD

Adp1660OutputModeILPEAK Property

Output Mode: IL_PEAK

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeOutputModeIlPeak OutputModeILPEAK { get; set; }
Public Property OutputModeILPEAK As Adp1660TypeOutputModeIlPeak
    Get
    Set
public:
property Adp1660TypeOutputModeIlPeak OutputModeILPEAK {
    Adp1660TypeOutputModeIlPeak get ();
    void set (Adp1660TypeOutputModeIlPeak value);
}
member OutputModeILPEAK : Adp1660TypeOutputModeIlPeak with get, set

Property Value

Type: Adp1660TypeOutputModeIlPeak
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.OutputModeLEDMOD Property

IRD

Adp1660OutputModeLEDMOD Property

Output Mode: LED_MOD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeOutputModeLedMod OutputModeLEDMOD { get; set; }
Public Property OutputModeLEDMOD As Adp1660TypeOutputModeLedMod
    Get
    Set
public:
property Adp1660TypeOutputModeLedMod OutputModeLEDMOD {
    Adp1660TypeOutputModeLedMod get ();
    void set (Adp1660TypeOutputModeLedMod value);
}
member OutputModeLEDMOD : Adp1660TypeOutputModeLedMod with get, set

Property Value

Type: Adp1660TypeOutputModeLedMod
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.OutputModeSTRLV Property

IRD

Adp1660OutputModeSTRLV Property

Output Mode: STR_LV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeOutputModeStrLv OutputModeSTRLV { get; set; }
Public Property OutputModeSTRLV As Adp1660TypeOutputModeStrLv
    Get
    Set
public:
property Adp1660TypeOutputModeStrLv OutputModeSTRLV {
    Adp1660TypeOutputModeStrLv get ();
    void set (Adp1660TypeOutputModeStrLv value);
}
member OutputModeSTRLV : Adp1660TypeOutputModeStrLv with get, set

Property Value

Type: Adp1660TypeOutputModeStrLv
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.OutputModeSTRMOD Property

IRD

Adp1660OutputModeSTRMOD Property

Output Mode: STR_MOD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeOutputModeStrMod OutputModeSTRMOD { get; set; }
Public Property OutputModeSTRMOD As Adp1660TypeOutputModeStrMod
    Get
    Set
public:
property Adp1660TypeOutputModeStrMod OutputModeSTRMOD {
    Adp1660TypeOutputModeStrMod get ();
    void set (Adp1660TypeOutputModeStrMod value);
}
member OutputModeSTRMOD : Adp1660TypeOutputModeStrMod with get, set

Property Value

Type: Adp1660TypeOutputModeStrMod
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.OutputModeSTRPOL Property

IRD

Adp1660OutputModeSTRPOL Property

Output Mode: STR_POL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp1660TypeOutputModeStrPol OutputModeSTRPOL { get; set; }
Public Property OutputModeSTRPOL As Adp1660TypeOutputModeStrPol
    Get
    Set
public:
property Adp1660TypeOutputModeStrPol OutputModeSTRPOL {
    Adp1660TypeOutputModeStrPol get ();
    void set (Adp1660TypeOutputModeStrPol value);
}
member OutputModeSTRPOL : Adp1660TypeOutputModeStrPol with get, set

Property Value

Type: Adp1660TypeOutputModeStrPol
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660 Methods

The Adp1660 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.Flush Method

IRD

Adp1660Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adp1660 Class
telos.Ird.AnalogDevices Namespace


Adp1660.TypeAdditionalFeaturesClSoft Enumeration

IRD

Adp1660TypeAdditionalFeaturesClSoft Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalFeaturesClSoft
Public Enumeration TypeAdditionalFeaturesClSoft
public enum class TypeAdditionalFeaturesClSoft
type TypeAdditionalFeaturesClSoft
Members
Member name | Value | Description
SoftInductorPeakCurrentLimitEnabled | 0 | Soft Inductor Peak Current Limit: Enabled
SoftInductorPeakCurrentLimitDisabled | 1 | Soft Inductor Peak Current Limit: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeAdditionalFeaturesDynOvp Enumeration

IRD

Adp1660TypeAdditionalFeaturesDynOvp Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalFeaturesDynOvp
Public Enumeration TypeAdditionalFeaturesDynOvp
public enum class TypeAdditionalFeaturesDynOvp
type TypeAdditionalFeaturesDynOvp
Members
Member name | Value | Description
DynamicOVPDisabled | 0 | Dynamic OVP: Disabled
DynamicOVPEnabled | 1 | Dynamic OVP: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeAdditionalFeaturesFreqFb Enumeration

IRD

Adp1660TypeAdditionalFeaturesFreqFb Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalFeaturesFreqFb
Public Enumeration TypeAdditionalFeaturesFreqFb
public enum class TypeAdditionalFeaturesFreqFb
type TypeAdditionalFeaturesFreqFb
Members
Member name | Value | Description
FrequencyFoldbackDisabled | 0 | Frequency Foldback: Disabled
FrequencyFoldbackEnabled | 1 | Frequency Foldback: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeAdditionalFeaturesIlDc Enumeration

IRD

Adp1660TypeAdditionalFeaturesIlDc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalFeaturesIlDc
Public Enumeration TypeAdditionalFeaturesIlDc
public enum class TypeAdditionalFeaturesIlDc
type TypeAdditionalFeaturesIlDc
Members
Member name | Value | Description
Value_1_0 | 0 | 1.0
Value_1_25 | 1 | 1.25
Value_1_5 | 2 | 1.5
Value_1_75 | 3 | 1.75
Value_2_0 | 4 | 2.0
Value_2_25 | 5 | 2.25
Value_2_5 | 6 | 2.5
Value_2_75 | 7 | 2.75
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeAdditionalFeaturesIlDcEn Enumeration

IRD

Adp1660TypeAdditionalFeaturesIlDcEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalFeaturesIlDcEn
Public Enumeration TypeAdditionalFeaturesIlDcEn
public enum class TypeAdditionalFeaturesIlDcEn
type TypeAdditionalFeaturesIlDcEn
Members
Member name | Value | Description
InputDCCurrentLimitDisabled | 0 | Input DC Current Limit: Disabled
InputDCCurrentLimitEnabled | 1 | Input DC Current Limit: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeAdditionalFeaturesSwLo Enumeration

IRD

Adp1660TypeAdditionalFeaturesSwLo Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdditionalFeaturesSwLo
Public Enumeration TypeAdditionalFeaturesSwLo
public enum class TypeAdditionalFeaturesSwLo
type TypeAdditionalFeaturesSwLo
Members
Member name | Value | Description
SwitchingFrequency3MHz | 0 | Switching Frequency: 3 MHz
SwitchingFrequency15MHz | 1 | Switching Frequency: 1.5 MHz
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeCurrent200 Enumeration

IRD

Adp1660TypeCurrent200 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCurrent200
Public Enumeration TypeCurrent200
public enum class TypeCurrent200
type TypeCurrent200
Members
Member name | Value | Description
Value_0_0 | 0 | 0.0
Value_12_5 | 1 | 12.5
Value_25_0 | 2 | 25.0
Value_37_5 | 3 | 37.5
Value_50_0 | 4 | 50.0
Value_62_5 | 5 | 62.5
Value_75_0 | 6 | 75.0
Value_87_5 | 7 | 87.5
Value_100_0 | 8 | 100.0
Value_112_5 | 9 | 112.5
Value_125_0 | 10 | 125.0
Value_137_5 | 11 | 137.5
Value_150_0 | 12 | 150.0
Value_162_5 | 13 | 162.5
Value_175_0 | 14 | 175.0
Value_187_5 | 15 | 187.5
Value_200_0 | 16 | 200.0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeCurrent750 Enumeration

IRD

Adp1660TypeCurrent750 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCurrent750
Public Enumeration TypeCurrent750
public enum class TypeCurrent750
type TypeCurrent750
Members
Member name | Value | Description
Value_0_0 | 0 | 0.0
Value_12_5 | 1 | 12.5
Value_25_0 | 2 | 25.0
Value_37_5 | 3 | 37.5
Value_50_0 | 4 | 50.0
Value_62_5 | 5 | 62.5
Value_75_0 | 6 | 75.0
Value_87_5 | 7 | 87.5
Value_100_0 | 8 | 100.0
Value_112_5 | 9 | 112.5
Value_125_0 | 10 | 125.0
Value_137_5 | 11 | 137.5
Value_150_0 | 12 | 150.0
Value_162_5 | 13 | 162.5
Value_175_0 | 14 | 175.0
Value_187_5 | 15 | 187.5
Value_200_0 | 16 | 200.0
Value_212_5 | 17 | 212.5
Value_225_0 | 18 | 225.0
Value_237_5 | 19 | 237.5
Value_250_0 | 20 | 250.0
Value_262_5 | 21 | 262.5
Value_275_0 | 22 | 275.0
Value_287_5 | 23 | 287.5
Value_300_0 | 24 | 300.0
Value_312_5 | 25 | 312.5
Value_325_0 | 26 | 325.0
Value_337_5 | 27 | 337.5
Value_350_0 | 28 | 350.0
Value_362_5 | 29 | 362.5
Value_375_0 | 30 | 375.0
Value_387_5 | 31 | 387.5
Value_400_0 | 32 | 400.0
Value_412_5 | 33 | 412.5
Value_425_0 | 34 | 425.0
Value_437_5 | 35 | 437.5
Value_450_0 | 36 | 450.0
Value_462_5 | 37 | 462.5
Value_475_0 | 38 | 475.0
Value_487_5 | 39 | 487.5
Value_500_0 | 40 | 500.0
Value_512_5 | 41 | 512.5
Value_525_0 | 42 | 525.0
Value_537_5 | 43 | 537.5
Value_550_0 | 44 | 550.0
Value_562_5 | 45 | 562.5
Value_575_0 | 46 | 575.0
Value_587_5 | 47 | 587.5
Value_600_0 | 48 | 600.0
Value_612_5 | 49 | 612.5
Value_625_0 | 50 | 625.0
Value_637_5 | 51 | 637.5
Value_650_0 | 52 | 650.0
Value_662_5 | 53 | 662.5
Value_675_0 | 54 | 675.0
Value_687_5 | 55 | 687.5
Value_700_0 | 56 | 700.0
Value_712_5 | 57 | 712.5
Value_725_0 | 58 | 725.0
Value_737_5 | 59 | 737.5
Value_750_0 | 60 | 750.0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeFaultInformationFault Enumeration

IRD

Adp1660TypeFaultInformationFault Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultInformationFault
Public Enumeration TypeFaultInformationFault
public enum class TypeFaultInformationFault
type TypeFaultInformationFault
Members
Member name | Value | Description
NoFault | 0 | No Fault
Fault | 1 | Fault
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeFaultInformationTx Enumeration

IRD

Adp1660TypeFaultInformationTx Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultInformationTx
Public Enumeration TypeFaultInformationTx
public enum class TypeFaultInformationTx
type TypeFaultInformationTx
Members
Member name | Value | Description
NoTxMASKOperationModeDuringLastFlash | 0 | No TxMASK Operation Mode During Last Flash
TxMASKOperationModeOccurredDuringLastFlash | 1 | TxMASK Operation Mode Occurred During Last Flash
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeFaultInformationVbLo Enumeration

IRD

Adp1660TypeFaultInformationVbLo Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultInformationVbLo
Public Enumeration TypeFaultInformationVbLo
public enum class TypeFaultInformationVbLo
type TypeFaultInformationVbLo
Members
Member name | Value | Description
VDDLowBatteryThreshold | 0 | V_DD > Low Battery Threshold
VDDLowBatteryThreshold__1 | 1 | V_DD < Low Battery Threshold
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeGpioTimerFlTim Enumeration

IRD

Adp1660TypeGpioTimerFlTim Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioTimerFlTim
Public Enumeration TypeGpioTimerFlTim
public enum class TypeGpioTimerFlTim
type TypeGpioTimerFlTim
Members
Member name | Value | Description
Value_100 | 0 | 100
Value_200 | 1 | 200
Value_300 | 2 | 300
Value_400 | 3 | 400
Value_500 | 4 | 500
Value_600 | 5 | 600
Value_700 | 6 | 700
Value_800 | 7 | 800
Value_900 | 8 | 900
Value_1000 | 9 | 1000
Value_1100 | 10 | 1100
Value_1200 | 11 | 1200
Value_1300 | 12 | 1300
Value_1400 | 13 | 1400
Value_1500 | 14 | 1500
Value_1600 | 15 | 1600
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeGpioTimerIoCfg Enumeration

IRD

Adp1660TypeGpioTimerIoCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioTimerIoCfg
Public Enumeration TypeGpioTimerIoCfg
public enum class TypeGpioTimerIoCfg
type TypeGpioTimerIoCfg
Members
Member name | Value | Description
HighImpedance | 0 | High Impedance
TorchMode | 1 | Torch Mode
TxMASKOperationMode | 2 | TxMASK Operation Mode
TorchModeWithoutThe8MsDeglitchFilter | 3 | Torch Mode Without The 8 ms Deglitch Filter
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeGpioTimerLedSd Enumeration

IRD

Adp1660TypeGpioTimerLedSd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioTimerLedSd
Public Enumeration TypeGpioTimerLedSd
public enum class TypeGpioTimerLedSd
type TypeGpioTimerLedSd
Members
Member name | Value | Description
EnterShutdown | 0 | Enter Shutdown
DoNotEnterShutdown | 1 | Do Not Enter Shutdown
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeLedEnableMode Enumeration

IRD

Adp1660TypeLedEnableMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedEnableMode
Public Enumeration TypeLedEnableMode
public enum class TypeLedEnableMode
type TypeLedEnableMode
Members
Member name | Value | Description
LEDDisabled | 0 | LED Disabled
LEDEnabled | 1 | LED Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeLowBatteryEnableVBatWindow Enumeration

IRD

Adp1660TypeLowBatteryEnableVBatWindow Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLowBatteryEnableVBatWindow
Public Enumeration TypeLowBatteryEnableVBatWindow
public enum class TypeLowBatteryEnableVBatWindow
type TypeLowBatteryEnableVBatWindow
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_1 | 1 | 1
Value_2 | 2 | 2
Value_5 | 3 | 5
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeLowBatteryEnableVVbLo Enumeration

IRD

Adp1660TypeLowBatteryEnableVVbLo Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLowBatteryEnableVVbLo
Public Enumeration TypeLowBatteryEnableVVbLo
public enum class TypeLowBatteryEnableVVbLo
type TypeLowBatteryEnableVVbLo
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_3_3 | 1 | 3.3
Value_3_35 | 2 | 3.35
Value_3_4 | 3 | 3.4
Value_3_45 | 4 | 3.45
Value_3_5 | 5 | 3.5
Value_3_55 | 6 | 3.55
Value_3_6 | 7 | 3.6
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeOutputModeIlPeak Enumeration

IRD

Adp1660TypeOutputModeIlPeak Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeIlPeak
Public Enumeration TypeOutputModeIlPeak
public enum class TypeOutputModeIlPeak
type TypeOutputModeIlPeak
Members
Member name | Value | Description
Value_2_25 | 0 | 2.25
Value_2_75 | 1 | 2.75
Value_3_25 | 2 | 3.25
Value_3_5 | 3 | 3.5
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeOutputModeLedMod Enumeration

IRD

Adp1660TypeOutputModeLedMod Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeLedMod
Public Enumeration TypeOutputModeLedMod
public enum class TypeOutputModeLedMod
type TypeOutputModeLedMod
Members
Member name | Value | Description
StandbyMode | 0 | Standby Mode
Fixed5VOutputMode | 1 | Fixed 5V Output Mode
AssistLightMode | 2 | Assist Light Mode
FlashMode | 3 | Flash Mode
IndependentTriggerModeTimeoutEnabled | 4 | Independent Trigger Mode, Timeout Enabled
IndependentTriggerModeTimeoutDisabled | 5 | Independent Trigger Mode, Timeout Disabled
Fixed5VOutputModeWithTorchMode | 6 | Fixed 5V Output Mode With Torch Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeOutputModeStrLv Enumeration

IRD

Adp1660TypeOutputModeStrLv Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeStrLv
Public Enumeration TypeOutputModeStrLv
public enum class TypeOutputModeStrLv
type TypeOutputModeStrLv
Members
Member name | Value | Description
EdgeSensitive | 0 | Edge Sensitive
LevelSensitive | 1 | Level Sensitive
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeOutputModeStrMod Enumeration

IRD

Adp1660TypeOutputModeStrMod Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeStrMod
Public Enumeration TypeOutputModeStrMod
public enum class TypeOutputModeStrMod
type TypeOutputModeStrMod
Members
Member name | Value | Description
StrobeModeSoftware | 0 | Strobe Mode: Software
StrobeModeHardware | 1 | Strobe Mode: Hardware
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp1660.TypeOutputModeStrPol Enumeration

IRD

Adp1660TypeOutputModeStrPol Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeStrPol
Public Enumeration TypeOutputModeStrPol
public enum class TypeOutputModeStrPol
type TypeOutputModeStrPol
Members
Member name | Value | Description
PolarityActiveLow | 0 | Polarity: Active Low
PolarityActiveHigh | 1 | Polarity: Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5020 Class

Analog Devices: ADP 5020
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdp5020

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adp5020
Public Class Adp5020
public ref class Adp5020
type Adp5020 =  class end

The Adp5020 type exposes the following members.

Constructors
 | Name | Description
Public method | Adp5020 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BUCK1VSELBK1VSEL | BUCK1_VSEL: BK1_VSEL (unit: V)
Public property | BUCK2LDOVSELBK2VSEL | BUCK2_LDO_VSEL: BK2_VSEL (unit: V)
Public property | BUCK2LDOVSELLDOVSEL | BUCK2_LDO_VSEL: LDO_VSEL (unit: V)
Public property | ENCONTROLENODRV | EN_CONTROL: ENO_DRV
Public property | ENCONTROLENOHIZBAR | EN_CONTROL: ENO_HIZ_BAR
Public property | OPERATIONALCONTROLBK1XSHTDN | OPERATIONAL_CONTROL: BK1_XSHTDN
Public property | OPERATIONALCONTROLBK2XSHTDN | OPERATIONAL_CONTROL: BK2_XSHTDN
Public property | OPERATIONALCONTROLLDOXSHTDN | OPERATIONAL_CONTROL: LDO_XSHTDN
Public property | OPERATIONALCONTROLSYNC19P2 | OPERATIONAL_CONTROL: SYNC_19P2
Public property | OPERATIONALCONTROLSYNC9P6 | OPERATIONAL_CONTROL: SYNC_9P6
Public property | OPERATIONALCONTROLSYNCAC | OPERATIONAL_CONTROL: SYNC_AC
Public property | OPERATIONALCONTROLTSD | OPERATIONAL_CONTROL: TSD
Public property | REGCONTROLSTATUSBK1EN | REG_CONTROL_STATUS: BK1_EN
Public property | REGCONTROLSTATUSBK1PGOOD | REG_CONTROL_STATUS: BK1_PGOOD
Public property | REGCONTROLSTATUSBK2EN | REG_CONTROL_STATUS: BK2_EN
Public property | REGCONTROLSTATUSBK2PGOOD | REG_CONTROL_STATUS: BK2_PGOOD
Public property | REGCONTROLSTATUSENALL | REG_CONTROL_STATUS: EN_ALL
Public property | REGCONTROLSTATUSFORCEXS | REG_CONTROL_STATUS: FORCE_XS
Public property | REGCONTROLSTATUSLDOEN | REG_CONTROL_STATUS: LDO_EN
Public property | REGCONTROLSTATUSLDOPGOOD | REG_CONTROL_STATUS: LDO_PGOOD
Public property | RevisionMAJ | Revision: MAJ
Public property | RevisionMIN | Revision: MIN
Public property | RevisionOPT | Revision: OPT
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Power Management Unit for Imaging Modules
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5020 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adp5020(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adp5020

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020 Properties

The Adp5020 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BUCK1VSELBK1VSEL | BUCK1_VSEL: BK1_VSEL (unit: V)
Public property | BUCK2LDOVSELBK2VSEL | BUCK2_LDO_VSEL: BK2_VSEL (unit: V)
Public property | BUCK2LDOVSELLDOVSEL | BUCK2_LDO_VSEL: LDO_VSEL (unit: V)
Public property | ENCONTROLENODRV | EN_CONTROL: ENO_DRV
Public property | ENCONTROLENOHIZBAR | EN_CONTROL: ENO_HIZ_BAR
Public property | OPERATIONALCONTROLBK1XSHTDN | OPERATIONAL_CONTROL: BK1_XSHTDN
Public property | OPERATIONALCONTROLBK2XSHTDN | OPERATIONAL_CONTROL: BK2_XSHTDN
Public property | OPERATIONALCONTROLLDOXSHTDN | OPERATIONAL_CONTROL: LDO_XSHTDN
Public property | OPERATIONALCONTROLSYNC19P2 | OPERATIONAL_CONTROL: SYNC_19P2
Public property | OPERATIONALCONTROLSYNC9P6 | OPERATIONAL_CONTROL: SYNC_9P6
Public property | OPERATIONALCONTROLSYNCAC | OPERATIONAL_CONTROL: SYNC_AC
Public property | OPERATIONALCONTROLTSD | OPERATIONAL_CONTROL: TSD
Public property | REGCONTROLSTATUSBK1EN | REG_CONTROL_STATUS: BK1_EN
Public property | REGCONTROLSTATUSBK1PGOOD | REG_CONTROL_STATUS: BK1_PGOOD
Public property | REGCONTROLSTATUSBK2EN | REG_CONTROL_STATUS: BK2_EN
Public property | REGCONTROLSTATUSBK2PGOOD | REG_CONTROL_STATUS: BK2_PGOOD
Public property | REGCONTROLSTATUSENALL | REG_CONTROL_STATUS: EN_ALL
Public property | REGCONTROLSTATUSFORCEXS | REG_CONTROL_STATUS: FORCE_XS
Public property | REGCONTROLSTATUSLDOEN | REG_CONTROL_STATUS: LDO_EN
Public property | REGCONTROLSTATUSLDOPGOOD | REG_CONTROL_STATUS: LDO_PGOOD
Public property | RevisionMAJ | Revision: MAJ
Public property | RevisionMIN | Revision: MIN
Public property | RevisionOPT | Revision: OPT
Top
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.AutoFlush Property

IRD

Adp5020AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.BUCK1VSELBK1VSEL Property

IRD

Adp5020BUCK1VSELBK1VSEL Property

BUCK1_VSEL: BK1_VSEL (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypeBk1Vsel BUCK1VSELBK1VSEL { get; set; }
Public Property BUCK1VSELBK1VSEL As Adp5020TypeBk1Vsel
    Get
    Set
public:
property Adp5020TypeBk1Vsel BUCK1VSELBK1VSEL {
    Adp5020TypeBk1Vsel get ();
    void set (Adp5020TypeBk1Vsel value);
}
member BUCK1VSELBK1VSEL : Adp5020TypeBk1Vsel with get, set

Property Value

Type: Adp5020TypeBk1Vsel
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.BUCK2LDOVSELBK2VSEL Property

IRD

Adp5020BUCK2LDOVSELBK2VSEL Property

BUCK2_LDO_VSEL: BK2_VSEL (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypeBk2Vsel BUCK2LDOVSELBK2VSEL { get; set; }
Public Property BUCK2LDOVSELBK2VSEL As Adp5020TypeBk2Vsel
    Get
    Set
public:
property Adp5020TypeBk2Vsel BUCK2LDOVSELBK2VSEL {
    Adp5020TypeBk2Vsel get ();
    void set (Adp5020TypeBk2Vsel value);
}
member BUCK2LDOVSELBK2VSEL : Adp5020TypeBk2Vsel with get, set

Property Value

Type: Adp5020TypeBk2Vsel
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.BUCK2LDOVSELLDOVSEL Property

IRD

Adp5020BUCK2LDOVSELLDOVSEL Property

BUCK2_LDO_VSEL: LDO_VSEL (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypeLdoVsel BUCK2LDOVSELLDOVSEL { get; set; }
Public Property BUCK2LDOVSELLDOVSEL As Adp5020TypeLdoVsel
    Get
    Set
public:
property Adp5020TypeLdoVsel BUCK2LDOVSELLDOVSEL {
    Adp5020TypeLdoVsel get ();
    void set (Adp5020TypeLdoVsel value);
}
member BUCK2LDOVSELLDOVSEL : Adp5020TypeLdoVsel with get, set

Property Value

Type: Adp5020TypeLdoVsel
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.ENCONTROLENODRV Property

IRD

Adp5020ENCONTROLENODRV Property

EN_CONTROL: ENO_DRV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypeEnoDrv ENCONTROLENODRV { get; set; }
Public Property ENCONTROLENODRV As Adp5020TypeEnoDrv
    Get
    Set
public:
property Adp5020TypeEnoDrv ENCONTROLENODRV {
    Adp5020TypeEnoDrv get ();
    void set (Adp5020TypeEnoDrv value);
}
member ENCONTROLENODRV : Adp5020TypeEnoDrv with get, set

Property Value

Type: Adp5020TypeEnoDrv
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.ENCONTROLENOHIZBAR Property

IRD

Adp5020ENCONTROLENOHIZBAR Property

EN_CONTROL: ENO_HIZ_BAR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypeEnoHizBar ENCONTROLENOHIZBAR { get; set; }
Public Property ENCONTROLENOHIZBAR As Adp5020TypeEnoHizBar
    Get
    Set
public:
property Adp5020TypeEnoHizBar ENCONTROLENOHIZBAR {
    Adp5020TypeEnoHizBar get ();
    void set (Adp5020TypeEnoHizBar value);
}
member ENCONTROLENOHIZBAR : Adp5020TypeEnoHizBar with get, set

Property Value

Type: Adp5020TypeEnoHizBar
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.OPERATIONALCONTROLBK1XSHTDN Property

IRD

Adp5020OPERATIONALCONTROLBK1XSHTDN Property

OPERATIONAL_CONTROL: BK1_XSHTDN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypeBkLdoXshtdn OPERATIONALCONTROLBK1XSHTDN { get; set; }
Public Property OPERATIONALCONTROLBK1XSHTDN As Adp5020TypeBkLdoXshtdn
    Get
    Set
public:
property Adp5020TypeBkLdoXshtdn OPERATIONALCONTROLBK1XSHTDN {
    Adp5020TypeBkLdoXshtdn get ();
    void set (Adp5020TypeBkLdoXshtdn value);
}
member OPERATIONALCONTROLBK1XSHTDN : Adp5020TypeBkLdoXshtdn with get, set

Property Value

Type: Adp5020TypeBkLdoXshtdn
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.OPERATIONALCONTROLBK2XSHTDN Property

IRD

Adp5020OPERATIONALCONTROLBK2XSHTDN Property

OPERATIONAL_CONTROL: BK2_XSHTDN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypeBkLdoXshtdn OPERATIONALCONTROLBK2XSHTDN { get; set; }
Public Property OPERATIONALCONTROLBK2XSHTDN As Adp5020TypeBkLdoXshtdn
    Get
    Set
public:
property Adp5020TypeBkLdoXshtdn OPERATIONALCONTROLBK2XSHTDN {
    Adp5020TypeBkLdoXshtdn get ();
    void set (Adp5020TypeBkLdoXshtdn value);
}
member OPERATIONALCONTROLBK2XSHTDN : Adp5020TypeBkLdoXshtdn with get, set

Property Value

Type: Adp5020TypeBkLdoXshtdn
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.OPERATIONALCONTROLLDOXSHTDN Property

IRD

Adp5020OPERATIONALCONTROLLDOXSHTDN Property

OPERATIONAL_CONTROL: LDO_XSHTDN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypeBkLdoXshtdn OPERATIONALCONTROLLDOXSHTDN { get; set; }
Public Property OPERATIONALCONTROLLDOXSHTDN As Adp5020TypeBkLdoXshtdn
    Get
    Set
public:
property Adp5020TypeBkLdoXshtdn OPERATIONALCONTROLLDOXSHTDN {
    Adp5020TypeBkLdoXshtdn get ();
    void set (Adp5020TypeBkLdoXshtdn value);
}
member OPERATIONALCONTROLLDOXSHTDN : Adp5020TypeBkLdoXshtdn with get, set

Property Value

Type: Adp5020TypeBkLdoXshtdn
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.OPERATIONALCONTROLSYNC19P2 Property

IRD

Adp5020OPERATIONALCONTROLSYNC19P2 Property

OPERATIONAL_CONTROL: SYNC_19P2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypeSync19p2 OPERATIONALCONTROLSYNC19P2 { get; set; }
Public Property OPERATIONALCONTROLSYNC19P2 As Adp5020TypeSync19p2
    Get
    Set
public:
property Adp5020TypeSync19p2 OPERATIONALCONTROLSYNC19P2 {
    Adp5020TypeSync19p2 get ();
    void set (Adp5020TypeSync19p2 value);
}
member OPERATIONALCONTROLSYNC19P2 : Adp5020TypeSync19p2 with get, set

Property Value

Type: Adp5020TypeSync19p2
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.OPERATIONALCONTROLSYNC9P6 Property

IRD

Adp5020OPERATIONALCONTROLSYNC9P6 Property

OPERATIONAL_CONTROL: SYNC_9P6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypeSync9p6 OPERATIONALCONTROLSYNC9P6 { get; set; }
Public Property OPERATIONALCONTROLSYNC9P6 As Adp5020TypeSync9p6
    Get
    Set
public:
property Adp5020TypeSync9p6 OPERATIONALCONTROLSYNC9P6 {
    Adp5020TypeSync9p6 get ();
    void set (Adp5020TypeSync9p6 value);
}
member OPERATIONALCONTROLSYNC9P6 : Adp5020TypeSync9p6 with get, set

Property Value

Type: Adp5020TypeSync9p6
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.OPERATIONALCONTROLSYNCAC Property

IRD

Adp5020OPERATIONALCONTROLSYNCAC Property

OPERATIONAL_CONTROL: SYNC_AC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypeSyncAc OPERATIONALCONTROLSYNCAC { get; set; }
Public Property OPERATIONALCONTROLSYNCAC As Adp5020TypeSyncAc
    Get
    Set
public:
property Adp5020TypeSyncAc OPERATIONALCONTROLSYNCAC {
    Adp5020TypeSyncAc get ();
    void set (Adp5020TypeSyncAc value);
}
member OPERATIONALCONTROLSYNCAC : Adp5020TypeSyncAc with get, set

Property Value

Type: Adp5020TypeSyncAc
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.OPERATIONALCONTROLTSD Property

IRD

Adp5020OPERATIONALCONTROLTSD Property

OPERATIONAL_CONTROL: TSD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypeTsd OPERATIONALCONTROLTSD { get; set; }
Public Property OPERATIONALCONTROLTSD As Adp5020TypeTsd
    Get
    Set
public:
property Adp5020TypeTsd OPERATIONALCONTROLTSD {
    Adp5020TypeTsd get ();
    void set (Adp5020TypeTsd value);
}
member OPERATIONALCONTROLTSD : Adp5020TypeTsd with get, set

Property Value

Type: Adp5020TypeTsd
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.REGCONTROLSTATUSBK1EN Property

IRD

Adp5020REGCONTROLSTATUSBK1EN Property

REG_CONTROL_STATUS: BK1_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypeBkLdoEn REGCONTROLSTATUSBK1EN { get; set; }
Public Property REGCONTROLSTATUSBK1EN As Adp5020TypeBkLdoEn
    Get
    Set
public:
property Adp5020TypeBkLdoEn REGCONTROLSTATUSBK1EN {
    Adp5020TypeBkLdoEn get ();
    void set (Adp5020TypeBkLdoEn value);
}
member REGCONTROLSTATUSBK1EN : Adp5020TypeBkLdoEn with get, set

Property Value

Type: Adp5020TypeBkLdoEn
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.REGCONTROLSTATUSBK1PGOOD Property

IRD

Adp5020REGCONTROLSTATUSBK1PGOOD Property

REG_CONTROL_STATUS: BK1_PGOOD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypePgood REGCONTROLSTATUSBK1PGOOD { get; }
Public ReadOnly Property REGCONTROLSTATUSBK1PGOOD As Adp5020TypePgood
    Get
public:
property Adp5020TypePgood REGCONTROLSTATUSBK1PGOOD {
    Adp5020TypePgood get ();
}
member REGCONTROLSTATUSBK1PGOOD : Adp5020TypePgood with get

Property Value

Type: Adp5020TypePgood
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.REGCONTROLSTATUSBK2EN Property

IRD

Adp5020REGCONTROLSTATUSBK2EN Property

REG_CONTROL_STATUS: BK2_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypeBkLdoEn REGCONTROLSTATUSBK2EN { get; set; }
Public Property REGCONTROLSTATUSBK2EN As Adp5020TypeBkLdoEn
    Get
    Set
public:
property Adp5020TypeBkLdoEn REGCONTROLSTATUSBK2EN {
    Adp5020TypeBkLdoEn get ();
    void set (Adp5020TypeBkLdoEn value);
}
member REGCONTROLSTATUSBK2EN : Adp5020TypeBkLdoEn with get, set

Property Value

Type: Adp5020TypeBkLdoEn
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.REGCONTROLSTATUSBK2PGOOD Property

IRD

Adp5020REGCONTROLSTATUSBK2PGOOD Property

REG_CONTROL_STATUS: BK2_PGOOD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypePgood REGCONTROLSTATUSBK2PGOOD { get; }
Public ReadOnly Property REGCONTROLSTATUSBK2PGOOD As Adp5020TypePgood
    Get
public:
property Adp5020TypePgood REGCONTROLSTATUSBK2PGOOD {
    Adp5020TypePgood get ();
}
member REGCONTROLSTATUSBK2PGOOD : Adp5020TypePgood with get

Property Value

Type: Adp5020TypePgood
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.REGCONTROLSTATUSENALL Property

IRD

Adp5020REGCONTROLSTATUSENALL Property

REG_CONTROL_STATUS: EN_ALL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypeBkLdoEn REGCONTROLSTATUSENALL { get; set; }
Public Property REGCONTROLSTATUSENALL As Adp5020TypeBkLdoEn
    Get
    Set
public:
property Adp5020TypeBkLdoEn REGCONTROLSTATUSENALL {
    Adp5020TypeBkLdoEn get ();
    void set (Adp5020TypeBkLdoEn value);
}
member REGCONTROLSTATUSENALL : Adp5020TypeBkLdoEn with get, set

Property Value

Type: Adp5020TypeBkLdoEn
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.REGCONTROLSTATUSFORCEXS Property

IRD

Adp5020REGCONTROLSTATUSFORCEXS Property

REG_CONTROL_STATUS: FORCE_XS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypeForceXs REGCONTROLSTATUSFORCEXS { get; set; }
Public Property REGCONTROLSTATUSFORCEXS As Adp5020TypeForceXs
    Get
    Set
public:
property Adp5020TypeForceXs REGCONTROLSTATUSFORCEXS {
    Adp5020TypeForceXs get ();
    void set (Adp5020TypeForceXs value);
}
member REGCONTROLSTATUSFORCEXS : Adp5020TypeForceXs with get, set

Property Value

Type: Adp5020TypeForceXs
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.REGCONTROLSTATUSLDOEN Property

IRD

Adp5020REGCONTROLSTATUSLDOEN Property

REG_CONTROL_STATUS: LDO_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypeBkLdoEn REGCONTROLSTATUSLDOEN { get; set; }
Public Property REGCONTROLSTATUSLDOEN As Adp5020TypeBkLdoEn
    Get
    Set
public:
property Adp5020TypeBkLdoEn REGCONTROLSTATUSLDOEN {
    Adp5020TypeBkLdoEn get ();
    void set (Adp5020TypeBkLdoEn value);
}
member REGCONTROLSTATUSLDOEN : Adp5020TypeBkLdoEn with get, set

Property Value

Type: Adp5020TypeBkLdoEn
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.REGCONTROLSTATUSLDOPGOOD Property

IRD

Adp5020REGCONTROLSTATUSLDOPGOOD Property

REG_CONTROL_STATUS: LDO_PGOOD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5020TypePgood REGCONTROLSTATUSLDOPGOOD { get; }
Public ReadOnly Property REGCONTROLSTATUSLDOPGOOD As Adp5020TypePgood
    Get
public:
property Adp5020TypePgood REGCONTROLSTATUSLDOPGOOD {
    Adp5020TypePgood get ();
}
member REGCONTROLSTATUSLDOPGOOD : Adp5020TypePgood with get

Property Value

Type: Adp5020TypePgood
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.RevisionMAJ Property

IRD

Adp5020RevisionMAJ Property

Revision: MAJ

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionMAJ { get; }
Public ReadOnly Property RevisionMAJ As Byte
    Get
public:
property unsigned char RevisionMAJ {
    unsigned char get ();
}
member RevisionMAJ : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.RevisionMIN Property

IRD

Adp5020RevisionMIN Property

Revision: MIN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionMIN { get; }
Public ReadOnly Property RevisionMIN As Byte
    Get
public:
property unsigned char RevisionMIN {
    unsigned char get ();
}
member RevisionMIN : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.RevisionOPT Property

IRD

Adp5020RevisionOPT Property

Revision: OPT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionOPT { get; }
Public ReadOnly Property RevisionOPT As Byte
    Get
public:
property unsigned char RevisionOPT {
    unsigned char get ();
}
member RevisionOPT : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020 Methods

The Adp5020 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.Flush Method

IRD

Adp5020Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adp5020 Class
telos.Ird.AnalogDevices Namespace


Adp5020.TypeBk1Vsel Enumeration

IRD

Adp5020TypeBk1Vsel Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBk1Vsel
Public Enumeration TypeBk1Vsel
public enum class TypeBk1Vsel
type TypeBk1Vsel
Members
Member name | Value | Description
Value_2_5 | 0 | 2.5
Value_2_8 | 1 | 2.8
Value_2_9 | 2 | 2.9
Value_3_0 | 3 | 3.0
Value_3_2 | 4 | 3.2
Value_3_3 | 5 | 3.3
Value_3_7 | 6 | 3.7
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5020.TypeBk2Vsel Enumeration

IRD

Adp5020TypeBk2Vsel Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBk2Vsel
Public Enumeration TypeBk2Vsel
public enum class TypeBk2Vsel
type TypeBk2Vsel
Members
Member name | Value | Description
Value_1_1 | 0 | 1.1
Value_1_2 | 9 | 1.2
Value_1_3 | 10 | 1.3
Value_1_4 | 11 | 1.4
Value_1_5 | 12 | 1.5
Value_1_6 | 13 | 1.6
Value_1_7 | 14 | 1.7
Value_1_8 | 15 | 1.8
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5020.TypeBkLdoEn Enumeration

IRD

Adp5020TypeBkLdoEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBkLdoEn
Public Enumeration TypeBkLdoEn
public enum class TypeBkLdoEn
type TypeBkLdoEn
Members
Member name | Value | Description
Off | 0 | Off
On | 1 | On
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5020.TypeBkLdoXshtdn Enumeration

IRD

Adp5020TypeBkLdoXshtdn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBkLdoXshtdn
Public Enumeration TypeBkLdoXshtdn
public enum class TypeBkLdoXshtdn
type TypeBkLdoXshtdn
Members
Member name | Value | Description
PowerGoodUsedForXSHTDN | 0 | Power Good: Used For XSHTDN
PowerGoodIgnoredForXSHTDN | 1 | Power Good: Ignored For XSHTDN
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5020.TypeEnoDrv Enumeration

IRD

Adp5020TypeEnoDrv Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeEnoDrv
Public Enumeration TypeEnoDrv
public enum class TypeEnoDrv
type TypeEnoDrv
Members
Member name | Value | Description
GPIOOutputLow | 0 | GPIO Output: Low
GPIOOutputHigh | 1 | GPIO Output: High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5020.TypeEnoHizBar Enumeration

IRD

Adp5020TypeEnoHizBar Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeEnoHizBar
Public Enumeration TypeEnoHizBar
public enum class TypeEnoHizBar
type TypeEnoHizBar
Members
Member name | Value | Description
ENGPIOHighImpedanceENSelected | 0 | EN/GPIO: High Impedance / EN: Selected
GPIOOutputSelectedENIgnored | 1 | GPIO: Output Selected / EN: Ignored
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5020.TypeForceXs Enumeration

IRD

Adp5020TypeForceXs Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeForceXs
Public Enumeration TypeForceXs
public enum class TypeForceXs
type TypeForceXs
Members
Member name | Value | Description
XSHTDNPowerGood | 0 | XSHTDN: Power Good
XSHTDNEN | 1 | XSHTDN: EN
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5020.TypeLdoVsel Enumeration

IRD

Adp5020TypeLdoVsel Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLdoVsel
Public Enumeration TypeLdoVsel
public enum class TypeLdoVsel
type TypeLdoVsel
Members
Member name | Value | Description
Value_1_8 | 0 | 1.8
Value_1_9 | 1 | 1.9
Value_2_0 | 2 | 2.0
Value_2_1 | 3 | 2.1
Value_2_2 | 4 | 2.2
Value_2_3 | 5 | 2.3
Value_2_4 | 6 | 2.4
Value_2_5 | 7 | 2.5
Value_2_6 | 8 | 2.6
Value_2_7 | 9 | 2.7
Value_2_8 | 10 | 2.8
Value_2_9 | 11 | 2.9
Value_3_0 | 12 | 3.0
Value_3_1 | 13 | 3.1
Value_3_2 | 14 | 3.2
Value_3_3 | 15 | 3.3
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5020.TypePgood Enumeration

IRD

Adp5020TypePgood Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePgood
Public Enumeration TypePgood
public enum class TypePgood
type TypePgood
Members
Member name | Value | Description
Fail | 0 | Fail
Good | 1 | Good
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5020.TypeSync19p2 Enumeration

IRD

Adp5020TypeSync19p2 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSync19p2
Public Enumeration TypeSync19p2
public enum class TypeSync19p2
type TypeSync19p2
Members
Member name | Value | Description
Value_192MHzClockNotOnSYNCPin | 0 | 19.2 MHz Clock: Not On SYNC Pin
Value_192MHzClockOnSYNCPin | 1 | 19.2 MHz Clock: On SYNC Pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5020.TypeSync9p6 Enumeration

IRD

Adp5020TypeSync9p6 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSync9p6
Public Enumeration TypeSync9p6
public enum class TypeSync9p6
type TypeSync9p6
Members
Member name | Value | Description
Value_96MHzClockNotOnSYNCPin | 0 | 9.6 MHz Clock: Not On SYNC Pin
Value_96MHzClockOnSYNCPin | 1 | 9.6 MHz Clock: On SYNC Pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5020.TypeSyncAc Enumeration

IRD

Adp5020TypeSyncAc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSyncAc
Public Enumeration TypeSyncAc
public enum class TypeSyncAc
type TypeSyncAc
Members
Member name | Value | Description
SYNCDC | 0 | SYNC: DC
SYNCAC | 1 | SYNC: AC
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5020.TypeTsd Enumeration

IRD

Adp5020TypeTsd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTsd
Public Enumeration TypeTsd
public enum class TypeTsd
type TypeTsd
Members
Member name | Value | Description
TSDNotActive | 0 | TSD: Not Active
TSDActive | 1 | TSD: Active
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050 Class

Analog Devices: ADP 5050
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdp5050

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adp5050
Public Class Adp5050
public ref class Adp5050
type Adp5050 =  class end

The Adp5050 type exposes the following members.

Constructors
 | Name | Description
Public method | Adp5050 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DEFAULTSET | DEFAULT_SET
Public property | DVSCFGDVS1INTERVAL | DVS_CFG: DVS1_INTERVAL (unit: µs)
Public property | DVSCFGDVS1ON | DVS_CFG: DVS1_ON
Public property | DVSCFGDVS4INTERVAL | DVS_CFG: DVS4_INTERVAL (unit: µs)
Public property | DVSCFGDVS4ON | DVS_CFG: DVS4_ON
Public property | HICCUPCFGHICCUP1OFF | HICCUP_CFG: HICCUP1_OFF
Public property | HICCUPCFGHICCUP2OFF | HICCUP_CFG: HICCUP2_OFF
Public property | HICCUPCFGHICCUP3OFF | HICCUP_CFG: HICCUP3_OFF
Public property | HICCUPCFGHICCUP4OFF | HICCUP_CFG: HICCUP4_OFF
Public property | HICCUPCFGSYNCOUT | HICCUP_CFG: SYNC_OUT
Public property | INTMASKMASKLVIN | INT_MASK: MASK_LVIN
Public property | INTMASKMASKPWRG1 | INT_MASK: MASK_PWRG1
Public property | INTMASKMASKPWRG2 | INT_MASK: MASK_PWRG2
Public property | INTMASKMASKPWRG3 | INT_MASK: MASK_PWRG3
Public property | INTMASKMASKPWRG4 | INT_MASK: MASK_PWRG4
Public property | INTMASKMASKTEMP | INT_MASK: MASK_TEMP
Public property | INTSTATUSLVININT | INT_STATUS: LVIN_INT
Public property | INTSTATUSPWRG1INT | INT_STATUS: PWRG1_INT
Public property | INTSTATUSPWRG2INT | INT_STATUS: PWRG2_INT
Public property | INTSTATUSPWRG3INT | INT_STATUS: PWRG3_INT
Public property | INTSTATUSPWRG4INT | INT_STATUS: PWRG4_INT
Public property | INTSTATUSTEMPINT | INT_STATUS: TEMP_INT
Public property | LCHCFGOVP1ON | LCH_CFG: OVP1_ON
Public property | LCHCFGOVP2ON | LCH_CFG: OVP2_ON
Public property | LCHCFGOVP3ON | LCH_CFG: OVP3_ON
Public property | LCHCFGOVP4ON | LCH_CFG: OVP4_ON
Public property | LCHCFGSCP1ON | LCH_CFG: SCP1_ON
Public property | LCHCFGSCP2ON | LCH_CFG: SCP2_ON
Public property | LCHCFGSCP3ON | LCH_CFG: SCP3_ON
Public property | LCHCFGSCP4ON | LCH_CFG: SCP4_ON
Public property | LCHSTATUSCH1LCH | LCH_STATUS: CH1_LCH
Public property | LCHSTATUSCH2LCH | LCH_STATUS: CH2_LCH
Public property | LCHSTATUSCH3LCH | LCH_STATUS: CH3_LCH
Public property | LCHSTATUSCH4LCH | LCH_STATUS: CH4_LCH
Public property | LCHSTATUSTSDLCH | LCH_STATUS: TSD_LCH
Public property | OPTCFGDSCG1ON | OPT_CFG: DSCG1_ON
Public property | OPTCFGDSCG2ON | OPT_CFG: DSCG2_ON
Public property | OPTCFGDSCG3ON | OPT_CFG: DSCG3_ON
Public property | OPTCFGDSCG4ON | OPT_CFG: DSCG4_ON
Public property | OPTCFGPSM1ON | OPT_CFG: PSM1_ON
Public property | OPTCFGPSM2ON | OPT_CFG: PSM2_ON
Public property | OPTCFGPSM3ON | OPT_CFG: PSM3_ON
Public property | OPTCFGPSM4ON | OPT_CFG: PSM4_ON
Public property | PCTRLCH1ON | PCTRL: CH1_ON
Public property | PCTRLCH2ON | PCTRL: CH2_ON
Public property | PCTRLCH3ON | PCTRL: CH3_ON
Public property | PCTRLCH4ON | PCTRL: CH4_ON
Public property | PCTRLCH5ON | PCTRL: CH5_ON
Public property | PWRGDMASKMASKCH1 | PWRGD_MASK: MASK_CH1
Public property | PWRGDMASKMASKCH2 | PWRGD_MASK: MASK_CH2
Public property | PWRGDMASKMASKCH3 | PWRGD_MASK: MASK_CH3
Public property | PWRGDMASKMASKCH4 | PWRGD_MASK: MASK_CH4
Public property | STATUSRDPWRG1 | STATUS_RD: PWRG1
Public property | STATUSRDPWRG2 | STATUS_RD: PWRG2
Public property | STATUSRDPWRG3 | STATUS_RD: PWRG3
Public property | STATUSRDPWRG4 | STATUS_RD: PWRG4
Public property | SWCFGFREQ1 | SW_CFG: FREQ1
Public property | SWCFGFREQ3 | SW_CFG: FREQ3
Public property | SWCFGPHASE2 | SW_CFG: PHASE2 (unit: °)
Public property | SWCFGPHASE3 | SW_CFG: PHASE3 (unit: °)
Public property | SWCFGPHASE4 | SW_CFG: PHASE4 (unit: °)
Public property | THCFGLVINTH | TH_CFG: LVIN_TH (unit: V)
Public property | THCFGTEMPTH | TH_CFG: TEMP_TH (unit: °C)
Public property | VID1 | VID1
Public property | VID23VID2 | VID23: VID2 (unit: V)
Public property | VID23VID3 | VID23: VID3 (unit: V)
Public property | VID4 | VID4 (unit: V)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
5-Channel Integrated Power Solution with Quad Buck Regulators and 200 mA LDO Regulator
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adp5050(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adp5050

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050 Properties

The Adp5050 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DEFAULTSET | DEFAULT_SET
Public property | DVSCFGDVS1INTERVAL | DVS_CFG: DVS1_INTERVAL (unit: µs)
Public property | DVSCFGDVS1ON | DVS_CFG: DVS1_ON
Public property | DVSCFGDVS4INTERVAL | DVS_CFG: DVS4_INTERVAL (unit: µs)
Public property | DVSCFGDVS4ON | DVS_CFG: DVS4_ON
Public property | HICCUPCFGHICCUP1OFF | HICCUP_CFG: HICCUP1_OFF
Public property | HICCUPCFGHICCUP2OFF | HICCUP_CFG: HICCUP2_OFF
Public property | HICCUPCFGHICCUP3OFF | HICCUP_CFG: HICCUP3_OFF
Public property | HICCUPCFGHICCUP4OFF | HICCUP_CFG: HICCUP4_OFF
Public property | HICCUPCFGSYNCOUT | HICCUP_CFG: SYNC_OUT
Public property | INTMASKMASKLVIN | INT_MASK: MASK_LVIN
Public property | INTMASKMASKPWRG1 | INT_MASK: MASK_PWRG1
Public property | INTMASKMASKPWRG2 | INT_MASK: MASK_PWRG2
Public property | INTMASKMASKPWRG3 | INT_MASK: MASK_PWRG3
Public property | INTMASKMASKPWRG4 | INT_MASK: MASK_PWRG4
Public property | INTMASKMASKTEMP | INT_MASK: MASK_TEMP
Public property | INTSTATUSLVININT | INT_STATUS: LVIN_INT
Public property | INTSTATUSPWRG1INT | INT_STATUS: PWRG1_INT
Public property | INTSTATUSPWRG2INT | INT_STATUS: PWRG2_INT
Public property | INTSTATUSPWRG3INT | INT_STATUS: PWRG3_INT
Public property | INTSTATUSPWRG4INT | INT_STATUS: PWRG4_INT
Public property | INTSTATUSTEMPINT | INT_STATUS: TEMP_INT
Public property | LCHCFGOVP1ON | LCH_CFG: OVP1_ON
Public property | LCHCFGOVP2ON | LCH_CFG: OVP2_ON
Public property | LCHCFGOVP3ON | LCH_CFG: OVP3_ON
Public property | LCHCFGOVP4ON | LCH_CFG: OVP4_ON
Public property | LCHCFGSCP1ON | LCH_CFG: SCP1_ON
Public property | LCHCFGSCP2ON | LCH_CFG: SCP2_ON
Public property | LCHCFGSCP3ON | LCH_CFG: SCP3_ON
Public property | LCHCFGSCP4ON | LCH_CFG: SCP4_ON
Public property | LCHSTATUSCH1LCH | LCH_STATUS: CH1_LCH
Public property | LCHSTATUSCH2LCH | LCH_STATUS: CH2_LCH
Public property | LCHSTATUSCH3LCH | LCH_STATUS: CH3_LCH
Public property | LCHSTATUSCH4LCH | LCH_STATUS: CH4_LCH
Public property | LCHSTATUSTSDLCH | LCH_STATUS: TSD_LCH
Public property | OPTCFGDSCG1ON | OPT_CFG: DSCG1_ON
Public property | OPTCFGDSCG2ON | OPT_CFG: DSCG2_ON
Public property | OPTCFGDSCG3ON | OPT_CFG: DSCG3_ON
Public property | OPTCFGDSCG4ON | OPT_CFG: DSCG4_ON
Public property | OPTCFGPSM1ON | OPT_CFG: PSM1_ON
Public property | OPTCFGPSM2ON | OPT_CFG: PSM2_ON
Public property | OPTCFGPSM3ON | OPT_CFG: PSM3_ON
Public property | OPTCFGPSM4ON | OPT_CFG: PSM4_ON
Public property | PCTRLCH1ON | PCTRL: CH1_ON
Public property | PCTRLCH2ON | PCTRL: CH2_ON
Public property | PCTRLCH3ON | PCTRL: CH3_ON
Public property | PCTRLCH4ON | PCTRL: CH4_ON
Public property | PCTRLCH5ON | PCTRL: CH5_ON
Public property | PWRGDMASKMASKCH1 | PWRGD_MASK: MASK_CH1
Public property | PWRGDMASKMASKCH2 | PWRGD_MASK: MASK_CH2
Public property | PWRGDMASKMASKCH3 | PWRGD_MASK: MASK_CH3
Public property | PWRGDMASKMASKCH4 | PWRGD_MASK: MASK_CH4
Public property | STATUSRDPWRG1 | STATUS_RD: PWRG1
Public property | STATUSRDPWRG2 | STATUS_RD: PWRG2
Public property | STATUSRDPWRG3 | STATUS_RD: PWRG3
Public property | STATUSRDPWRG4 | STATUS_RD: PWRG4
Public property | SWCFGFREQ1 | SW_CFG: FREQ1
Public property | SWCFGFREQ3 | SW_CFG: FREQ3
Public property | SWCFGPHASE2 | SW_CFG: PHASE2 (unit: °)
Public property | SWCFGPHASE3 | SW_CFG: PHASE3 (unit: °)
Public property | SWCFGPHASE4 | SW_CFG: PHASE4 (unit: °)
Public property | THCFGLVINTH | TH_CFG: LVIN_TH (unit: V)
Public property | THCFGTEMPTH | TH_CFG: TEMP_TH (unit: °C)
Public property | VID1 | VID1
Public property | VID23VID2 | VID23: VID2 (unit: V)
Public property | VID23VID3 | VID23: VID3 (unit: V)
Public property | VID4 | VID4 (unit: V)
Top
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.AutoFlush Property

IRD

Adp5050AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.DEFAULTSET Property

IRD

Adp5050DEFAULTSET Property

DEFAULT_SET

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeDefaultSet DEFAULTSET { set; }
Public WriteOnly Property DEFAULTSET As Adp5050TypeDefaultSet
    Set
public:
property Adp5050TypeDefaultSet DEFAULTSET {
    void set (Adp5050TypeDefaultSet value);
}
member DEFAULTSET : Adp5050TypeDefaultSet with set

Property Value

Type: Adp5050TypeDefaultSet
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.DVSCFGDVS1INTERVAL Property

IRD

Adp5050DVSCFGDVS1INTERVAL Property

DVS_CFG: DVS1_INTERVAL (unit: µs)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeDvsCfgInterval DVSCFGDVS1INTERVAL { get; set; }
Public Property DVSCFGDVS1INTERVAL As Adp5050TypeDvsCfgInterval
    Get
    Set
public:
property Adp5050TypeDvsCfgInterval DVSCFGDVS1INTERVAL {
    Adp5050TypeDvsCfgInterval get ();
    void set (Adp5050TypeDvsCfgInterval value);
}
member DVSCFGDVS1INTERVAL : Adp5050TypeDvsCfgInterval with get, set

Property Value

Type: Adp5050TypeDvsCfgInterval
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.DVSCFGDVS1ON Property

IRD

Adp5050DVSCFGDVS1ON Property

DVS_CFG: DVS1_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeDvsCfgOn DVSCFGDVS1ON { get; set; }
Public Property DVSCFGDVS1ON As Adp5050TypeDvsCfgOn
    Get
    Set
public:
property Adp5050TypeDvsCfgOn DVSCFGDVS1ON {
    Adp5050TypeDvsCfgOn get ();
    void set (Adp5050TypeDvsCfgOn value);
}
member DVSCFGDVS1ON : Adp5050TypeDvsCfgOn with get, set

Property Value

Type: Adp5050TypeDvsCfgOn
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.DVSCFGDVS4INTERVAL Property

IRD

Adp5050DVSCFGDVS4INTERVAL Property

DVS_CFG: DVS4_INTERVAL (unit: µs)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeDvsCfgInterval DVSCFGDVS4INTERVAL { get; set; }
Public Property DVSCFGDVS4INTERVAL As Adp5050TypeDvsCfgInterval
    Get
    Set
public:
property Adp5050TypeDvsCfgInterval DVSCFGDVS4INTERVAL {
    Adp5050TypeDvsCfgInterval get ();
    void set (Adp5050TypeDvsCfgInterval value);
}
member DVSCFGDVS4INTERVAL : Adp5050TypeDvsCfgInterval with get, set

Property Value

Type: Adp5050TypeDvsCfgInterval
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.DVSCFGDVS4ON Property

IRD

Adp5050DVSCFGDVS4ON Property

DVS_CFG: DVS4_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeDvsCfgOn DVSCFGDVS4ON { get; set; }
Public Property DVSCFGDVS4ON As Adp5050TypeDvsCfgOn
    Get
    Set
public:
property Adp5050TypeDvsCfgOn DVSCFGDVS4ON {
    Adp5050TypeDvsCfgOn get ();
    void set (Adp5050TypeDvsCfgOn value);
}
member DVSCFGDVS4ON : Adp5050TypeDvsCfgOn with get, set

Property Value

Type: Adp5050TypeDvsCfgOn
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.HICCUPCFGHICCUP1OFF Property

IRD

Adp5050HICCUPCFGHICCUP1OFF Property

HICCUP_CFG: HICCUP1_OFF

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeHiccupCfgHiccup HICCUPCFGHICCUP1OFF { get; set; }
Public Property HICCUPCFGHICCUP1OFF As Adp5050TypeHiccupCfgHiccup
    Get
    Set
public:
property Adp5050TypeHiccupCfgHiccup HICCUPCFGHICCUP1OFF {
    Adp5050TypeHiccupCfgHiccup get ();
    void set (Adp5050TypeHiccupCfgHiccup value);
}
member HICCUPCFGHICCUP1OFF : Adp5050TypeHiccupCfgHiccup with get, set

Property Value

Type: Adp5050TypeHiccupCfgHiccup
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.HICCUPCFGHICCUP2OFF Property

IRD

Adp5050HICCUPCFGHICCUP2OFF Property

HICCUP_CFG: HICCUP2_OFF

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeHiccupCfgHiccup HICCUPCFGHICCUP2OFF { get; set; }
Public Property HICCUPCFGHICCUP2OFF As Adp5050TypeHiccupCfgHiccup
    Get
    Set
public:
property Adp5050TypeHiccupCfgHiccup HICCUPCFGHICCUP2OFF {
    Adp5050TypeHiccupCfgHiccup get ();
    void set (Adp5050TypeHiccupCfgHiccup value);
}
member HICCUPCFGHICCUP2OFF : Adp5050TypeHiccupCfgHiccup with get, set

Property Value

Type: Adp5050TypeHiccupCfgHiccup
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.HICCUPCFGHICCUP3OFF Property

IRD

Adp5050HICCUPCFGHICCUP3OFF Property

HICCUP_CFG: HICCUP3_OFF

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeHiccupCfgHiccup HICCUPCFGHICCUP3OFF { get; set; }
Public Property HICCUPCFGHICCUP3OFF As Adp5050TypeHiccupCfgHiccup
    Get
    Set
public:
property Adp5050TypeHiccupCfgHiccup HICCUPCFGHICCUP3OFF {
    Adp5050TypeHiccupCfgHiccup get ();
    void set (Adp5050TypeHiccupCfgHiccup value);
}
member HICCUPCFGHICCUP3OFF : Adp5050TypeHiccupCfgHiccup with get, set

Property Value

Type: Adp5050TypeHiccupCfgHiccup
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.HICCUPCFGHICCUP4OFF Property

IRD

Adp5050HICCUPCFGHICCUP4OFF Property

HICCUP_CFG: HICCUP4_OFF

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeHiccupCfgHiccup HICCUPCFGHICCUP4OFF { get; set; }
Public Property HICCUPCFGHICCUP4OFF As Adp5050TypeHiccupCfgHiccup
    Get
    Set
public:
property Adp5050TypeHiccupCfgHiccup HICCUPCFGHICCUP4OFF {
    Adp5050TypeHiccupCfgHiccup get ();
    void set (Adp5050TypeHiccupCfgHiccup value);
}
member HICCUPCFGHICCUP4OFF : Adp5050TypeHiccupCfgHiccup with get, set

Property Value

Type: Adp5050TypeHiccupCfgHiccup
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.HICCUPCFGSYNCOUT Property

IRD

Adp5050HICCUPCFGSYNCOUT Property

HICCUP_CFG: SYNC_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeHiccupCfgSyncOut HICCUPCFGSYNCOUT { get; set; }
Public Property HICCUPCFGSYNCOUT As Adp5050TypeHiccupCfgSyncOut
    Get
    Set
public:
property Adp5050TypeHiccupCfgSyncOut HICCUPCFGSYNCOUT {
    Adp5050TypeHiccupCfgSyncOut get ();
    void set (Adp5050TypeHiccupCfgSyncOut value);
}
member HICCUPCFGSYNCOUT : Adp5050TypeHiccupCfgSyncOut with get, set

Property Value

Type: Adp5050TypeHiccupCfgSyncOut
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.INTMASKMASKLVIN Property

IRD

Adp5050INTMASKMASKLVIN Property

INT_MASK: MASK_LVIN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeIntMaskLvin INTMASKMASKLVIN { get; set; }
Public Property INTMASKMASKLVIN As Adp5050TypeIntMaskLvin
    Get
    Set
public:
property Adp5050TypeIntMaskLvin INTMASKMASKLVIN {
    Adp5050TypeIntMaskLvin get ();
    void set (Adp5050TypeIntMaskLvin value);
}
member INTMASKMASKLVIN : Adp5050TypeIntMaskLvin with get, set

Property Value

Type: Adp5050TypeIntMaskLvin
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.INTMASKMASKPWRG1 Property

IRD

Adp5050INTMASKMASKPWRG1 Property

INT_MASK: MASK_PWRG1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeIntMaskPwrg INTMASKMASKPWRG1 { get; set; }
Public Property INTMASKMASKPWRG1 As Adp5050TypeIntMaskPwrg
    Get
    Set
public:
property Adp5050TypeIntMaskPwrg INTMASKMASKPWRG1 {
    Adp5050TypeIntMaskPwrg get ();
    void set (Adp5050TypeIntMaskPwrg value);
}
member INTMASKMASKPWRG1 : Adp5050TypeIntMaskPwrg with get, set

Property Value

Type: Adp5050TypeIntMaskPwrg
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.INTMASKMASKPWRG2 Property

IRD

Adp5050INTMASKMASKPWRG2 Property

INT_MASK: MASK_PWRG2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeIntMaskPwrg INTMASKMASKPWRG2 { get; set; }
Public Property INTMASKMASKPWRG2 As Adp5050TypeIntMaskPwrg
    Get
    Set
public:
property Adp5050TypeIntMaskPwrg INTMASKMASKPWRG2 {
    Adp5050TypeIntMaskPwrg get ();
    void set (Adp5050TypeIntMaskPwrg value);
}
member INTMASKMASKPWRG2 : Adp5050TypeIntMaskPwrg with get, set

Property Value

Type: Adp5050TypeIntMaskPwrg
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.INTMASKMASKPWRG3 Property

IRD

Adp5050INTMASKMASKPWRG3 Property

INT_MASK: MASK_PWRG3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeIntMaskPwrg INTMASKMASKPWRG3 { get; set; }
Public Property INTMASKMASKPWRG3 As Adp5050TypeIntMaskPwrg
    Get
    Set
public:
property Adp5050TypeIntMaskPwrg INTMASKMASKPWRG3 {
    Adp5050TypeIntMaskPwrg get ();
    void set (Adp5050TypeIntMaskPwrg value);
}
member INTMASKMASKPWRG3 : Adp5050TypeIntMaskPwrg with get, set

Property Value

Type: Adp5050TypeIntMaskPwrg
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.INTMASKMASKPWRG4 Property

IRD

Adp5050INTMASKMASKPWRG4 Property

INT_MASK: MASK_PWRG4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeIntMaskPwrg INTMASKMASKPWRG4 { get; set; }
Public Property INTMASKMASKPWRG4 As Adp5050TypeIntMaskPwrg
    Get
    Set
public:
property Adp5050TypeIntMaskPwrg INTMASKMASKPWRG4 {
    Adp5050TypeIntMaskPwrg get ();
    void set (Adp5050TypeIntMaskPwrg value);
}
member INTMASKMASKPWRG4 : Adp5050TypeIntMaskPwrg with get, set

Property Value

Type: Adp5050TypeIntMaskPwrg
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.INTMASKMASKTEMP Property

IRD

Adp5050INTMASKMASKTEMP Property

INT_MASK: MASK_TEMP

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeIntMaskTemp INTMASKMASKTEMP { get; set; }
Public Property INTMASKMASKTEMP As Adp5050TypeIntMaskTemp
    Get
    Set
public:
property Adp5050TypeIntMaskTemp INTMASKMASKTEMP {
    Adp5050TypeIntMaskTemp get ();
    void set (Adp5050TypeIntMaskTemp value);
}
member INTMASKMASKTEMP : Adp5050TypeIntMaskTemp with get, set

Property Value

Type: Adp5050TypeIntMaskTemp
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.INTSTATUSLVININT Property

IRD

Adp5050INTSTATUSLVININT Property

INT_STATUS: LVIN_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeIntStatusLvin INTSTATUSLVININT { get; set; }
Public Property INTSTATUSLVININT As Adp5050TypeIntStatusLvin
    Get
    Set
public:
property Adp5050TypeIntStatusLvin INTSTATUSLVININT {
    Adp5050TypeIntStatusLvin get ();
    void set (Adp5050TypeIntStatusLvin value);
}
member INTSTATUSLVININT : Adp5050TypeIntStatusLvin with get, set

Property Value

Type: Adp5050TypeIntStatusLvin
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.INTSTATUSPWRG1INT Property

IRD

Adp5050INTSTATUSPWRG1INT Property

INT_STATUS: PWRG1_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeIntStatusPwrg INTSTATUSPWRG1INT { get; set; }
Public Property INTSTATUSPWRG1INT As Adp5050TypeIntStatusPwrg
    Get
    Set
public:
property Adp5050TypeIntStatusPwrg INTSTATUSPWRG1INT {
    Adp5050TypeIntStatusPwrg get ();
    void set (Adp5050TypeIntStatusPwrg value);
}
member INTSTATUSPWRG1INT : Adp5050TypeIntStatusPwrg with get, set

Property Value

Type: Adp5050TypeIntStatusPwrg
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.INTSTATUSPWRG2INT Property

IRD

Adp5050INTSTATUSPWRG2INT Property

INT_STATUS: PWRG2_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeIntStatusPwrg INTSTATUSPWRG2INT { get; set; }
Public Property INTSTATUSPWRG2INT As Adp5050TypeIntStatusPwrg
    Get
    Set
public:
property Adp5050TypeIntStatusPwrg INTSTATUSPWRG2INT {
    Adp5050TypeIntStatusPwrg get ();
    void set (Adp5050TypeIntStatusPwrg value);
}
member INTSTATUSPWRG2INT : Adp5050TypeIntStatusPwrg with get, set

Property Value

Type: Adp5050TypeIntStatusPwrg
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.INTSTATUSPWRG3INT Property

IRD

Adp5050INTSTATUSPWRG3INT Property

INT_STATUS: PWRG3_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeIntStatusPwrg INTSTATUSPWRG3INT { get; set; }
Public Property INTSTATUSPWRG3INT As Adp5050TypeIntStatusPwrg
    Get
    Set
public:
property Adp5050TypeIntStatusPwrg INTSTATUSPWRG3INT {
    Adp5050TypeIntStatusPwrg get ();
    void set (Adp5050TypeIntStatusPwrg value);
}
member INTSTATUSPWRG3INT : Adp5050TypeIntStatusPwrg with get, set

Property Value

Type: Adp5050TypeIntStatusPwrg
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.INTSTATUSPWRG4INT Property

IRD

Adp5050INTSTATUSPWRG4INT Property

INT_STATUS: PWRG4_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeIntStatusPwrg INTSTATUSPWRG4INT { get; set; }
Public Property INTSTATUSPWRG4INT As Adp5050TypeIntStatusPwrg
    Get
    Set
public:
property Adp5050TypeIntStatusPwrg INTSTATUSPWRG4INT {
    Adp5050TypeIntStatusPwrg get ();
    void set (Adp5050TypeIntStatusPwrg value);
}
member INTSTATUSPWRG4INT : Adp5050TypeIntStatusPwrg with get, set

Property Value

Type: Adp5050TypeIntStatusPwrg
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.INTSTATUSTEMPINT Property

IRD

Adp5050INTSTATUSTEMPINT Property

INT_STATUS: TEMP_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeIntStatusTemp INTSTATUSTEMPINT { get; set; }
Public Property INTSTATUSTEMPINT As Adp5050TypeIntStatusTemp
    Get
    Set
public:
property Adp5050TypeIntStatusTemp INTSTATUSTEMPINT {
    Adp5050TypeIntStatusTemp get ();
    void set (Adp5050TypeIntStatusTemp value);
}
member INTSTATUSTEMPINT : Adp5050TypeIntStatusTemp with get, set

Property Value

Type: Adp5050TypeIntStatusTemp
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.LCHCFGOVP1ON Property

IRD

Adp5050LCHCFGOVP1ON Property

LCH_CFG: OVP1_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeLchCfgOvp LCHCFGOVP1ON { get; set; }
Public Property LCHCFGOVP1ON As Adp5050TypeLchCfgOvp
    Get
    Set
public:
property Adp5050TypeLchCfgOvp LCHCFGOVP1ON {
    Adp5050TypeLchCfgOvp get ();
    void set (Adp5050TypeLchCfgOvp value);
}
member LCHCFGOVP1ON : Adp5050TypeLchCfgOvp with get, set

Property Value

Type: Adp5050TypeLchCfgOvp
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.LCHCFGOVP2ON Property

IRD

Adp5050LCHCFGOVP2ON Property

LCH_CFG: OVP2_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeLchCfgOvp LCHCFGOVP2ON { get; set; }
Public Property LCHCFGOVP2ON As Adp5050TypeLchCfgOvp
    Get
    Set
public:
property Adp5050TypeLchCfgOvp LCHCFGOVP2ON {
    Adp5050TypeLchCfgOvp get ();
    void set (Adp5050TypeLchCfgOvp value);
}
member LCHCFGOVP2ON : Adp5050TypeLchCfgOvp with get, set

Property Value

Type: Adp5050TypeLchCfgOvp
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.LCHCFGOVP3ON Property

IRD

Adp5050LCHCFGOVP3ON Property

LCH_CFG: OVP3_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeLchCfgOvp LCHCFGOVP3ON { get; set; }
Public Property LCHCFGOVP3ON As Adp5050TypeLchCfgOvp
    Get
    Set
public:
property Adp5050TypeLchCfgOvp LCHCFGOVP3ON {
    Adp5050TypeLchCfgOvp get ();
    void set (Adp5050TypeLchCfgOvp value);
}
member LCHCFGOVP3ON : Adp5050TypeLchCfgOvp with get, set

Property Value

Type: Adp5050TypeLchCfgOvp
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.LCHCFGOVP4ON Property

IRD

Adp5050LCHCFGOVP4ON Property

LCH_CFG: OVP4_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeLchCfgOvp LCHCFGOVP4ON { get; set; }
Public Property LCHCFGOVP4ON As Adp5050TypeLchCfgOvp
    Get
    Set
public:
property Adp5050TypeLchCfgOvp LCHCFGOVP4ON {
    Adp5050TypeLchCfgOvp get ();
    void set (Adp5050TypeLchCfgOvp value);
}
member LCHCFGOVP4ON : Adp5050TypeLchCfgOvp with get, set

Property Value

Type: Adp5050TypeLchCfgOvp
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.LCHCFGSCP1ON Property

IRD

Adp5050LCHCFGSCP1ON Property

LCH_CFG: SCP1_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeLchCfgScp LCHCFGSCP1ON { get; set; }
Public Property LCHCFGSCP1ON As Adp5050TypeLchCfgScp
    Get
    Set
public:
property Adp5050TypeLchCfgScp LCHCFGSCP1ON {
    Adp5050TypeLchCfgScp get ();
    void set (Adp5050TypeLchCfgScp value);
}
member LCHCFGSCP1ON : Adp5050TypeLchCfgScp with get, set

Property Value

Type: Adp5050TypeLchCfgScp
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.LCHCFGSCP2ON Property

IRD

Adp5050LCHCFGSCP2ON Property

LCH_CFG: SCP2_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeLchCfgScp LCHCFGSCP2ON { get; set; }
Public Property LCHCFGSCP2ON As Adp5050TypeLchCfgScp
    Get
    Set
public:
property Adp5050TypeLchCfgScp LCHCFGSCP2ON {
    Adp5050TypeLchCfgScp get ();
    void set (Adp5050TypeLchCfgScp value);
}
member LCHCFGSCP2ON : Adp5050TypeLchCfgScp with get, set

Property Value

Type: Adp5050TypeLchCfgScp
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.LCHCFGSCP3ON Property

IRD

Adp5050LCHCFGSCP3ON Property

LCH_CFG: SCP3_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeLchCfgScp LCHCFGSCP3ON { get; set; }
Public Property LCHCFGSCP3ON As Adp5050TypeLchCfgScp
    Get
    Set
public:
property Adp5050TypeLchCfgScp LCHCFGSCP3ON {
    Adp5050TypeLchCfgScp get ();
    void set (Adp5050TypeLchCfgScp value);
}
member LCHCFGSCP3ON : Adp5050TypeLchCfgScp with get, set

Property Value

Type: Adp5050TypeLchCfgScp
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.LCHCFGSCP4ON Property

IRD

Adp5050LCHCFGSCP4ON Property

LCH_CFG: SCP4_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeLchCfgScp LCHCFGSCP4ON { get; set; }
Public Property LCHCFGSCP4ON As Adp5050TypeLchCfgScp
    Get
    Set
public:
property Adp5050TypeLchCfgScp LCHCFGSCP4ON {
    Adp5050TypeLchCfgScp get ();
    void set (Adp5050TypeLchCfgScp value);
}
member LCHCFGSCP4ON : Adp5050TypeLchCfgScp with get, set

Property Value

Type: Adp5050TypeLchCfgScp
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.LCHSTATUSCH1LCH Property

IRD

Adp5050LCHSTATUSCH1LCH Property

LCH_STATUS: CH1_LCH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeLchStatusCh LCHSTATUSCH1LCH { get; set; }
Public Property LCHSTATUSCH1LCH As Adp5050TypeLchStatusCh
    Get
    Set
public:
property Adp5050TypeLchStatusCh LCHSTATUSCH1LCH {
    Adp5050TypeLchStatusCh get ();
    void set (Adp5050TypeLchStatusCh value);
}
member LCHSTATUSCH1LCH : Adp5050TypeLchStatusCh with get, set

Property Value

Type: Adp5050TypeLchStatusCh
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.LCHSTATUSCH2LCH Property

IRD

Adp5050LCHSTATUSCH2LCH Property

LCH_STATUS: CH2_LCH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeLchStatusCh LCHSTATUSCH2LCH { get; set; }
Public Property LCHSTATUSCH2LCH As Adp5050TypeLchStatusCh
    Get
    Set
public:
property Adp5050TypeLchStatusCh LCHSTATUSCH2LCH {
    Adp5050TypeLchStatusCh get ();
    void set (Adp5050TypeLchStatusCh value);
}
member LCHSTATUSCH2LCH : Adp5050TypeLchStatusCh with get, set

Property Value

Type: Adp5050TypeLchStatusCh
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.LCHSTATUSCH3LCH Property

IRD

Adp5050LCHSTATUSCH3LCH Property

LCH_STATUS: CH3_LCH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeLchStatusCh LCHSTATUSCH3LCH { get; set; }
Public Property LCHSTATUSCH3LCH As Adp5050TypeLchStatusCh
    Get
    Set
public:
property Adp5050TypeLchStatusCh LCHSTATUSCH3LCH {
    Adp5050TypeLchStatusCh get ();
    void set (Adp5050TypeLchStatusCh value);
}
member LCHSTATUSCH3LCH : Adp5050TypeLchStatusCh with get, set

Property Value

Type: Adp5050TypeLchStatusCh
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.LCHSTATUSCH4LCH Property

IRD

Adp5050LCHSTATUSCH4LCH Property

LCH_STATUS: CH4_LCH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeLchStatusCh LCHSTATUSCH4LCH { get; set; }
Public Property LCHSTATUSCH4LCH As Adp5050TypeLchStatusCh
    Get
    Set
public:
property Adp5050TypeLchStatusCh LCHSTATUSCH4LCH {
    Adp5050TypeLchStatusCh get ();
    void set (Adp5050TypeLchStatusCh value);
}
member LCHSTATUSCH4LCH : Adp5050TypeLchStatusCh with get, set

Property Value

Type: Adp5050TypeLchStatusCh
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.LCHSTATUSTSDLCH Property

IRD

Adp5050LCHSTATUSTSDLCH Property

LCH_STATUS: TSD_LCH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeLchStatusTsd LCHSTATUSTSDLCH { get; set; }
Public Property LCHSTATUSTSDLCH As Adp5050TypeLchStatusTsd
    Get
    Set
public:
property Adp5050TypeLchStatusTsd LCHSTATUSTSDLCH {
    Adp5050TypeLchStatusTsd get ();
    void set (Adp5050TypeLchStatusTsd value);
}
member LCHSTATUSTSDLCH : Adp5050TypeLchStatusTsd with get, set

Property Value

Type: Adp5050TypeLchStatusTsd
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.OPTCFGDSCG1ON Property

IRD

Adp5050OPTCFGDSCG1ON Property

OPT_CFG: DSCG1_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeOptCfgDscg OPTCFGDSCG1ON { get; set; }
Public Property OPTCFGDSCG1ON As Adp5050TypeOptCfgDscg
    Get
    Set
public:
property Adp5050TypeOptCfgDscg OPTCFGDSCG1ON {
    Adp5050TypeOptCfgDscg get ();
    void set (Adp5050TypeOptCfgDscg value);
}
member OPTCFGDSCG1ON : Adp5050TypeOptCfgDscg with get, set

Property Value

Type: Adp5050TypeOptCfgDscg
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.OPTCFGDSCG2ON Property

IRD

Adp5050OPTCFGDSCG2ON Property

OPT_CFG: DSCG2_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeOptCfgDscg OPTCFGDSCG2ON { get; set; }
Public Property OPTCFGDSCG2ON As Adp5050TypeOptCfgDscg
    Get
    Set
public:
property Adp5050TypeOptCfgDscg OPTCFGDSCG2ON {
    Adp5050TypeOptCfgDscg get ();
    void set (Adp5050TypeOptCfgDscg value);
}
member OPTCFGDSCG2ON : Adp5050TypeOptCfgDscg with get, set

Property Value

Type: Adp5050TypeOptCfgDscg
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.OPTCFGDSCG3ON Property

IRD

Adp5050OPTCFGDSCG3ON Property

OPT_CFG: DSCG3_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeOptCfgDscg OPTCFGDSCG3ON { get; set; }
Public Property OPTCFGDSCG3ON As Adp5050TypeOptCfgDscg
    Get
    Set
public:
property Adp5050TypeOptCfgDscg OPTCFGDSCG3ON {
    Adp5050TypeOptCfgDscg get ();
    void set (Adp5050TypeOptCfgDscg value);
}
member OPTCFGDSCG3ON : Adp5050TypeOptCfgDscg with get, set

Property Value

Type: Adp5050TypeOptCfgDscg
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.OPTCFGDSCG4ON Property

IRD

Adp5050OPTCFGDSCG4ON Property

OPT_CFG: DSCG4_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeOptCfgDscg OPTCFGDSCG4ON { get; set; }
Public Property OPTCFGDSCG4ON As Adp5050TypeOptCfgDscg
    Get
    Set
public:
property Adp5050TypeOptCfgDscg OPTCFGDSCG4ON {
    Adp5050TypeOptCfgDscg get ();
    void set (Adp5050TypeOptCfgDscg value);
}
member OPTCFGDSCG4ON : Adp5050TypeOptCfgDscg with get, set

Property Value

Type: Adp5050TypeOptCfgDscg
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.OPTCFGPSM1ON Property

IRD

Adp5050OPTCFGPSM1ON Property

OPT_CFG: PSM1_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeOptCfgPsm OPTCFGPSM1ON { get; set; }
Public Property OPTCFGPSM1ON As Adp5050TypeOptCfgPsm
    Get
    Set
public:
property Adp5050TypeOptCfgPsm OPTCFGPSM1ON {
    Adp5050TypeOptCfgPsm get ();
    void set (Adp5050TypeOptCfgPsm value);
}
member OPTCFGPSM1ON : Adp5050TypeOptCfgPsm with get, set

Property Value

Type: Adp5050TypeOptCfgPsm
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.OPTCFGPSM2ON Property

IRD

Adp5050OPTCFGPSM2ON Property

OPT_CFG: PSM2_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeOptCfgPsm OPTCFGPSM2ON { get; set; }
Public Property OPTCFGPSM2ON As Adp5050TypeOptCfgPsm
    Get
    Set
public:
property Adp5050TypeOptCfgPsm OPTCFGPSM2ON {
    Adp5050TypeOptCfgPsm get ();
    void set (Adp5050TypeOptCfgPsm value);
}
member OPTCFGPSM2ON : Adp5050TypeOptCfgPsm with get, set

Property Value

Type: Adp5050TypeOptCfgPsm
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.OPTCFGPSM3ON Property

IRD

Adp5050OPTCFGPSM3ON Property

OPT_CFG: PSM3_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeOptCfgPsm OPTCFGPSM3ON { get; set; }
Public Property OPTCFGPSM3ON As Adp5050TypeOptCfgPsm
    Get
    Set
public:
property Adp5050TypeOptCfgPsm OPTCFGPSM3ON {
    Adp5050TypeOptCfgPsm get ();
    void set (Adp5050TypeOptCfgPsm value);
}
member OPTCFGPSM3ON : Adp5050TypeOptCfgPsm with get, set

Property Value

Type: Adp5050TypeOptCfgPsm
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.OPTCFGPSM4ON Property

IRD

Adp5050OPTCFGPSM4ON Property

OPT_CFG: PSM4_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeOptCfgPsm OPTCFGPSM4ON { get; set; }
Public Property OPTCFGPSM4ON As Adp5050TypeOptCfgPsm
    Get
    Set
public:
property Adp5050TypeOptCfgPsm OPTCFGPSM4ON {
    Adp5050TypeOptCfgPsm get ();
    void set (Adp5050TypeOptCfgPsm value);
}
member OPTCFGPSM4ON : Adp5050TypeOptCfgPsm with get, set

Property Value

Type: Adp5050TypeOptCfgPsm
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.PCTRLCH1ON Property

IRD

Adp5050PCTRLCH1ON Property

PCTRL: CH1_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypePctrlChOn PCTRLCH1ON { get; set; }
Public Property PCTRLCH1ON As Adp5050TypePctrlChOn
    Get
    Set
public:
property Adp5050TypePctrlChOn PCTRLCH1ON {
    Adp5050TypePctrlChOn get ();
    void set (Adp5050TypePctrlChOn value);
}
member PCTRLCH1ON : Adp5050TypePctrlChOn with get, set

Property Value

Type: Adp5050TypePctrlChOn
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.PCTRLCH2ON Property

IRD

Adp5050PCTRLCH2ON Property

PCTRL: CH2_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypePctrlChOn PCTRLCH2ON { get; set; }
Public Property PCTRLCH2ON As Adp5050TypePctrlChOn
    Get
    Set
public:
property Adp5050TypePctrlChOn PCTRLCH2ON {
    Adp5050TypePctrlChOn get ();
    void set (Adp5050TypePctrlChOn value);
}
member PCTRLCH2ON : Adp5050TypePctrlChOn with get, set

Property Value

Type: Adp5050TypePctrlChOn
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.PCTRLCH3ON Property

IRD

Adp5050PCTRLCH3ON Property

PCTRL: CH3_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypePctrlChOn PCTRLCH3ON { get; set; }
Public Property PCTRLCH3ON As Adp5050TypePctrlChOn
    Get
    Set
public:
property Adp5050TypePctrlChOn PCTRLCH3ON {
    Adp5050TypePctrlChOn get ();
    void set (Adp5050TypePctrlChOn value);
}
member PCTRLCH3ON : Adp5050TypePctrlChOn with get, set

Property Value

Type: Adp5050TypePctrlChOn
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.PCTRLCH4ON Property

IRD

Adp5050PCTRLCH4ON Property

PCTRL: CH4_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypePctrlChOn PCTRLCH4ON { get; set; }
Public Property PCTRLCH4ON As Adp5050TypePctrlChOn
    Get
    Set
public:
property Adp5050TypePctrlChOn PCTRLCH4ON {
    Adp5050TypePctrlChOn get ();
    void set (Adp5050TypePctrlChOn value);
}
member PCTRLCH4ON : Adp5050TypePctrlChOn with get, set

Property Value

Type: Adp5050TypePctrlChOn
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.PCTRLCH5ON Property

IRD

Adp5050PCTRLCH5ON Property

PCTRL: CH5_ON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypePctrlChOn PCTRLCH5ON { get; set; }
Public Property PCTRLCH5ON As Adp5050TypePctrlChOn
    Get
    Set
public:
property Adp5050TypePctrlChOn PCTRLCH5ON {
    Adp5050TypePctrlChOn get ();
    void set (Adp5050TypePctrlChOn value);
}
member PCTRLCH5ON : Adp5050TypePctrlChOn with get, set

Property Value

Type: Adp5050TypePctrlChOn
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.PWRGDMASKMASKCH1 Property

IRD

Adp5050PWRGDMASKMASKCH1 Property

PWRGD_MASK: MASK_CH1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypePwrgdMask PWRGDMASKMASKCH1 { get; set; }
Public Property PWRGDMASKMASKCH1 As Adp5050TypePwrgdMask
    Get
    Set
public:
property Adp5050TypePwrgdMask PWRGDMASKMASKCH1 {
    Adp5050TypePwrgdMask get ();
    void set (Adp5050TypePwrgdMask value);
}
member PWRGDMASKMASKCH1 : Adp5050TypePwrgdMask with get, set

Property Value

Type: Adp5050TypePwrgdMask
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.PWRGDMASKMASKCH2 Property

IRD

Adp5050PWRGDMASKMASKCH2 Property

PWRGD_MASK: MASK_CH2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypePwrgdMask PWRGDMASKMASKCH2 { get; set; }
Public Property PWRGDMASKMASKCH2 As Adp5050TypePwrgdMask
    Get
    Set
public:
property Adp5050TypePwrgdMask PWRGDMASKMASKCH2 {
    Adp5050TypePwrgdMask get ();
    void set (Adp5050TypePwrgdMask value);
}
member PWRGDMASKMASKCH2 : Adp5050TypePwrgdMask with get, set

Property Value

Type: Adp5050TypePwrgdMask
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.PWRGDMASKMASKCH3 Property

IRD

Adp5050PWRGDMASKMASKCH3 Property

PWRGD_MASK: MASK_CH3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypePwrgdMask PWRGDMASKMASKCH3 { get; set; }
Public Property PWRGDMASKMASKCH3 As Adp5050TypePwrgdMask
    Get
    Set
public:
property Adp5050TypePwrgdMask PWRGDMASKMASKCH3 {
    Adp5050TypePwrgdMask get ();
    void set (Adp5050TypePwrgdMask value);
}
member PWRGDMASKMASKCH3 : Adp5050TypePwrgdMask with get, set

Property Value

Type: Adp5050TypePwrgdMask
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.PWRGDMASKMASKCH4 Property

IRD

Adp5050PWRGDMASKMASKCH4 Property

PWRGD_MASK: MASK_CH4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypePwrgdMask PWRGDMASKMASKCH4 { get; set; }
Public Property PWRGDMASKMASKCH4 As Adp5050TypePwrgdMask
    Get
    Set
public:
property Adp5050TypePwrgdMask PWRGDMASKMASKCH4 {
    Adp5050TypePwrgdMask get ();
    void set (Adp5050TypePwrgdMask value);
}
member PWRGDMASKMASKCH4 : Adp5050TypePwrgdMask with get, set

Property Value

Type: Adp5050TypePwrgdMask
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.STATUSRDPWRG1 Property

IRD

Adp5050STATUSRDPWRG1 Property

STATUS_RD: PWRG1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeStatusRdPwrg STATUSRDPWRG1 { get; }
Public ReadOnly Property STATUSRDPWRG1 As Adp5050TypeStatusRdPwrg
    Get
public:
property Adp5050TypeStatusRdPwrg STATUSRDPWRG1 {
    Adp5050TypeStatusRdPwrg get ();
}
member STATUSRDPWRG1 : Adp5050TypeStatusRdPwrg with get

Property Value

Type: Adp5050TypeStatusRdPwrg
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.STATUSRDPWRG2 Property

IRD

Adp5050STATUSRDPWRG2 Property

STATUS_RD: PWRG2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeStatusRdPwrg STATUSRDPWRG2 { get; }
Public ReadOnly Property STATUSRDPWRG2 As Adp5050TypeStatusRdPwrg
    Get
public:
property Adp5050TypeStatusRdPwrg STATUSRDPWRG2 {
    Adp5050TypeStatusRdPwrg get ();
}
member STATUSRDPWRG2 : Adp5050TypeStatusRdPwrg with get

Property Value

Type: Adp5050TypeStatusRdPwrg
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.STATUSRDPWRG3 Property

IRD

Adp5050STATUSRDPWRG3 Property

STATUS_RD: PWRG3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeStatusRdPwrg STATUSRDPWRG3 { get; }
Public ReadOnly Property STATUSRDPWRG3 As Adp5050TypeStatusRdPwrg
    Get
public:
property Adp5050TypeStatusRdPwrg STATUSRDPWRG3 {
    Adp5050TypeStatusRdPwrg get ();
}
member STATUSRDPWRG3 : Adp5050TypeStatusRdPwrg with get

Property Value

Type: Adp5050TypeStatusRdPwrg
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.STATUSRDPWRG4 Property

IRD

Adp5050STATUSRDPWRG4 Property

STATUS_RD: PWRG4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeStatusRdPwrg STATUSRDPWRG4 { get; }
Public ReadOnly Property STATUSRDPWRG4 As Adp5050TypeStatusRdPwrg
    Get
public:
property Adp5050TypeStatusRdPwrg STATUSRDPWRG4 {
    Adp5050TypeStatusRdPwrg get ();
}
member STATUSRDPWRG4 : Adp5050TypeStatusRdPwrg with get

Property Value

Type: Adp5050TypeStatusRdPwrg
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.SWCFGFREQ1 Property

IRD

Adp5050SWCFGFREQ1 Property

SW_CFG: FREQ1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeSwCfgFreq SWCFGFREQ1 { get; set; }
Public Property SWCFGFREQ1 As Adp5050TypeSwCfgFreq
    Get
    Set
public:
property Adp5050TypeSwCfgFreq SWCFGFREQ1 {
    Adp5050TypeSwCfgFreq get ();
    void set (Adp5050TypeSwCfgFreq value);
}
member SWCFGFREQ1 : Adp5050TypeSwCfgFreq with get, set

Property Value

Type: Adp5050TypeSwCfgFreq
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.SWCFGFREQ3 Property

IRD

Adp5050SWCFGFREQ3 Property

SW_CFG: FREQ3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeSwCfgFreq SWCFGFREQ3 { get; set; }
Public Property SWCFGFREQ3 As Adp5050TypeSwCfgFreq
    Get
    Set
public:
property Adp5050TypeSwCfgFreq SWCFGFREQ3 {
    Adp5050TypeSwCfgFreq get ();
    void set (Adp5050TypeSwCfgFreq value);
}
member SWCFGFREQ3 : Adp5050TypeSwCfgFreq with get, set

Property Value

Type: Adp5050TypeSwCfgFreq
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.SWCFGPHASE2 Property

IRD

Adp5050SWCFGPHASE2 Property

SW_CFG: PHASE2 (unit: °)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeSwCfgPhase SWCFGPHASE2 { get; set; }
Public Property SWCFGPHASE2 As Adp5050TypeSwCfgPhase
    Get
    Set
public:
property Adp5050TypeSwCfgPhase SWCFGPHASE2 {
    Adp5050TypeSwCfgPhase get ();
    void set (Adp5050TypeSwCfgPhase value);
}
member SWCFGPHASE2 : Adp5050TypeSwCfgPhase with get, set

Property Value

Type: Adp5050TypeSwCfgPhase
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.SWCFGPHASE3 Property

IRD

Adp5050SWCFGPHASE3 Property

SW_CFG: PHASE3 (unit: °)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeSwCfgPhase SWCFGPHASE3 { get; set; }
Public Property SWCFGPHASE3 As Adp5050TypeSwCfgPhase
    Get
    Set
public:
property Adp5050TypeSwCfgPhase SWCFGPHASE3 {
    Adp5050TypeSwCfgPhase get ();
    void set (Adp5050TypeSwCfgPhase value);
}
member SWCFGPHASE3 : Adp5050TypeSwCfgPhase with get, set

Property Value

Type: Adp5050TypeSwCfgPhase
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.SWCFGPHASE4 Property

IRD

Adp5050SWCFGPHASE4 Property

SW_CFG: PHASE4 (unit: °)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeSwCfgPhase SWCFGPHASE4 { get; set; }
Public Property SWCFGPHASE4 As Adp5050TypeSwCfgPhase
    Get
    Set
public:
property Adp5050TypeSwCfgPhase SWCFGPHASE4 {
    Adp5050TypeSwCfgPhase get ();
    void set (Adp5050TypeSwCfgPhase value);
}
member SWCFGPHASE4 : Adp5050TypeSwCfgPhase with get, set

Property Value

Type: Adp5050TypeSwCfgPhase
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.THCFGLVINTH Property

IRD

Adp5050THCFGLVINTH Property

TH_CFG: LVIN_TH (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeThCfgLvinTh THCFGLVINTH { get; set; }
Public Property THCFGLVINTH As Adp5050TypeThCfgLvinTh
    Get
    Set
public:
property Adp5050TypeThCfgLvinTh THCFGLVINTH {
    Adp5050TypeThCfgLvinTh get ();
    void set (Adp5050TypeThCfgLvinTh value);
}
member THCFGLVINTH : Adp5050TypeThCfgLvinTh with get, set

Property Value

Type: Adp5050TypeThCfgLvinTh
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.THCFGTEMPTH Property

IRD

Adp5050THCFGTEMPTH Property

TH_CFG: TEMP_TH (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeThCfgTempTh THCFGTEMPTH { get; set; }
Public Property THCFGTEMPTH As Adp5050TypeThCfgTempTh
    Get
    Set
public:
property Adp5050TypeThCfgTempTh THCFGTEMPTH {
    Adp5050TypeThCfgTempTh get ();
    void set (Adp5050TypeThCfgTempTh value);
}
member THCFGTEMPTH : Adp5050TypeThCfgTempTh with get, set

Property Value

Type: Adp5050TypeThCfgTempTh
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.VID1 Property

IRD

Adp5050VID1 Property

VID1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VID1 { get; set; }
Public Property VID1 As Byte
    Get
    Set
public:
property unsigned char VID1 {
    unsigned char get ();
    void set (unsigned char value);
}
member VID1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.VID23VID2 Property

IRD

Adp5050VID23VID2 Property

VID23: VID2 (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeVid23Vid2 VID23VID2 { get; set; }
Public Property VID23VID2 As Adp5050TypeVid23Vid2
    Get
    Set
public:
property Adp5050TypeVid23Vid2 VID23VID2 {
    Adp5050TypeVid23Vid2 get ();
    void set (Adp5050TypeVid23Vid2 value);
}
member VID23VID2 : Adp5050TypeVid23Vid2 with get, set

Property Value

Type: Adp5050TypeVid23Vid2
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.VID23VID3 Property

IRD

Adp5050VID23VID3 Property

VID23: VID3 (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeVid23Vid3 VID23VID3 { get; set; }
Public Property VID23VID3 As Adp5050TypeVid23Vid3
    Get
    Set
public:
property Adp5050TypeVid23Vid3 VID23VID3 {
    Adp5050TypeVid23Vid3 get ();
    void set (Adp5050TypeVid23Vid3 value);
}
member VID23VID3 : Adp5050TypeVid23Vid3 with get, set

Property Value

Type: Adp5050TypeVid23Vid3
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.VID4 Property

IRD

Adp5050VID4 Property

VID4 (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5050TypeVid4 VID4 { get; set; }
Public Property VID4 As Adp5050TypeVid4
    Get
    Set
public:
property Adp5050TypeVid4 VID4 {
    Adp5050TypeVid4 get ();
    void set (Adp5050TypeVid4 value);
}
member VID4 : Adp5050TypeVid4 with get, set

Property Value

Type: Adp5050TypeVid4
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050 Methods

The Adp5050 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.Flush Method

IRD

Adp5050Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adp5050 Class
telos.Ird.AnalogDevices Namespace


Adp5050.TypeDefaultSet Enumeration

IRD

Adp5050TypeDefaultSet Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDefaultSet
Public Enumeration TypeDefaultSet
public enum class TypeDefaultSet
type TypeDefaultSet
Members
Member name | Value | Description
ResetAllRegisters | 127 | Reset All Registers
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeDvsCfgInterval Enumeration

IRD

Adp5050TypeDvsCfgInterval Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDvsCfgInterval
Public Enumeration TypeDvsCfgInterval
public enum class TypeDvsCfgInterval
type TypeDvsCfgInterval
Members
Member name | Value | Description
Value_62_5 | 0 | 62.5
Value_31_2 | 1 | 31.2
Value_15_6 | 2 | 15.6
Value_7_8 | 3 | 7.8
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeDvsCfgOn Enumeration

IRD

Adp5050TypeDvsCfgOn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDvsCfgOn
Public Enumeration TypeDvsCfgOn
public enum class TypeDvsCfgOn
type TypeDvsCfgOn
Members
Member name | Value | Description
DVSForChannelDisabled | 0 | DVS For Channel: Disabled
DVSForChannelEnabled | 1 | DVS For Channel: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeHiccupCfgHiccup Enumeration

IRD

Adp5050TypeHiccupCfgHiccup Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHiccupCfgHiccup
Public Enumeration TypeHiccupCfgHiccup
public enum class TypeHiccupCfgHiccup
type TypeHiccupCfgHiccup
Members
Member name | Value | Description
HiccupProtectionEnabled | 0 | Hiccup Protection: Enabled
HiccupProtectionDisabled | 1 | Hiccup Protection: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeHiccupCfgSyncOut Enumeration

IRD

Adp5050TypeHiccupCfgSyncOut Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHiccupCfgSyncOut
Public Enumeration TypeHiccupCfgSyncOut
public enum class TypeHiccupCfgSyncOut
type TypeHiccupCfgSyncOut
Members
Member name | Value | Description
SYNCMODEPinClockSynchronizationInput | 0 | SYNC/MODE Pin: Clock Synchronization Input
SYNCMODEPinClockSynchronizationOutput | 1 | SYNC/MODE Pin: Clock Synchronization Output
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeIntMaskLvin Enumeration

IRD

Adp5050TypeIntMaskLvin Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMaskLvin
Public Enumeration TypeIntMaskLvin
public enum class TypeIntMaskLvin
type TypeIntMaskLvin
Members
Member name | Value | Description
LowVoltageInputDoesNotTriggerInterruptPin | 0 | Low Voltage Input: Does Not Trigger Interrupt Pin
LowVoltageInputTriggerInterruptPin | 1 | Low Voltage Input: Trigger Interrupt Pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeIntMaskPwrg Enumeration

IRD

Adp5050TypeIntMaskPwrg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMaskPwrg
Public Enumeration TypeIntMaskPwrg
public enum class TypeIntMaskPwrg
type TypeIntMaskPwrg
Members
Member name | Value | Description
PowerGoodDoesNotTriggerInterruptPin | 0 | Power-Good: Does Not Trigger Interrupt Pin
PowerGoodTriggerInterruptPin | 1 | Power-Good: Trigger Interrupt Pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeIntMaskTemp Enumeration

IRD

Adp5050TypeIntMaskTemp Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMaskTemp
Public Enumeration TypeIntMaskTemp
public enum class TypeIntMaskTemp
type TypeIntMaskTemp
Members
Member name | Value | Description
TemperatureOverheatDoesNotTriggerInterruptPin | 0 | Temperature Overheat: Does Not Trigger Interrupt Pin
TemperatureOverheatTriggerInterruptPin | 1 | Temperature Overheat: Trigger Interrupt Pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeIntStatusLvin Enumeration

IRD

Adp5050TypeIntStatusLvin Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntStatusLvin
Public Enumeration TypeIntStatusLvin
public enum class TypeIntStatusLvin
type TypeIntStatusLvin
Members
Member name | Value | Description
LowVoltageInputNotBelowThreshold | 0 | Low Voltage Input: Not Below Threshold
LowVoltageInputBelowThreshold | 1 | Low Voltage Input: Below Threshold
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeIntStatusPwrg Enumeration

IRD

Adp5050TypeIntStatusPwrg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntStatusPwrg
Public Enumeration TypeIntStatusPwrg
public enum class TypeIntStatusPwrg
type TypeIntStatusPwrg
Members
Member name | Value | Description
PowerGoodNoFailure | 0 | Power-Good: No Failure
PowerGoodFailure | 1 | Power-Good: Failure
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeIntStatusTemp Enumeration

IRD

Adp5050TypeIntStatusTemp Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntStatusTemp
Public Enumeration TypeIntStatusTemp
public enum class TypeIntStatusTemp
type TypeIntStatusTemp
Members
Member name | Value | Description
JunctionTemperatureNotExceeded | 0 | Junction Temperature: Not Exceeded
JunctionTemperatureExceeded | 1 | Junction Temperature: Exceeded
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeLchCfgOvp Enumeration

IRD

Adp5050TypeLchCfgOvp Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLchCfgOvp
Public Enumeration TypeLchCfgOvp
public enum class TypeLchCfgOvp
type TypeLchCfgOvp
Members
Member name | Value | Description
OVPLatchOffDisabled | 0 | OVP Latch-Off: Disabled
OVPLatchOffEnabled | 1 | OVP Latch-Off: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeLchCfgScp Enumeration

IRD

Adp5050TypeLchCfgScp Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLchCfgScp
Public Enumeration TypeLchCfgScp
public enum class TypeLchCfgScp
type TypeLchCfgScp
Members
Member name | Value | Description
SCPLatchOffDisabled | 0 | SCP Latch-Off: Disabled
SCPLatchOffEnabled | 1 | SCP Latch-Off: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeLchStatusCh Enumeration

IRD

Adp5050TypeLchStatusCh Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLchStatusCh
Public Enumeration TypeLchStatusCh
public enum class TypeLchStatusCh
type TypeLchStatusCh
Members
Member name | Value | Description
ShortCircuitOvervoltageNotOccurred | 0 | Short-Circuit/Overvoltage: Not Occurred
ShortCircuitOvervoltageOccurred | 1 | Short-Circuit/Overvoltage: Occurred
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeLchStatusTsd Enumeration

IRD

Adp5050TypeLchStatusTsd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLchStatusTsd
Public Enumeration TypeLchStatusTsd
public enum class TypeLchStatusTsd
type TypeLchStatusTsd
Members
Member name | Value | Description
ThermalShutdownNotOccurred | 0 | Thermal Shutdown: Not Occurred
ThermalShutdownOccurred | 1 | Thermal Shutdown: Occurred
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeOptCfgDscg Enumeration

IRD

Adp5050TypeOptCfgDscg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOptCfgDscg
Public Enumeration TypeOptCfgDscg
public enum class TypeOptCfgDscg
type TypeOptCfgDscg
Members
Member name | Value | Description
OutputDischargeDisabled | 0 | Output Discharge: Disabled
OutputDischargeEnabled | 1 | Output Discharge: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeOptCfgPsm Enumeration

IRD

Adp5050TypeOptCfgPsm Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOptCfgPsm
Public Enumeration TypeOptCfgPsm
public enum class TypeOptCfgPsm
type TypeOptCfgPsm
Members
Member name | Value | Description
ForcedPWMMode | 0 | Forced PWM Mode
AutomaticPWMPSMMode | 1 | Automatic PWM/PSM Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypePctrlChOn Enumeration

IRD

Adp5050TypePctrlChOn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePctrlChOn
Public Enumeration TypePctrlChOn
public enum class TypePctrlChOn
type TypePctrlChOn
Members
Member name | Value | Description
ChannelDisabled | 0 | Channel: Disabled
ChannelEnabled | 1 | Channel: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypePwrgdMask Enumeration

IRD

Adp5050TypePwrgdMask Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePwrgdMask
Public Enumeration TypePwrgdMask
public enum class TypePwrgdMask
type TypePwrgdMask
Members
Member name | Value | Description
PowerGoodStatusMasked | 0 | Power-Good Status: Masked
PowerGoodStatusOutput | 1 | Power-Good Status: Output
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeStatusRdPwrg Enumeration

IRD

Adp5050TypeStatusRdPwrg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusRdPwrg
Public Enumeration TypeStatusRdPwrg
public enum class TypeStatusRdPwrg
type TypeStatusRdPwrg
Members
Member name | Value | Description
PowerGoodStatusLow | 0 | Power-Good Status: Low
PowerGoodStatusHigh | 1 | Power-Good Status: High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeSwCfgFreq Enumeration

IRD

Adp5050TypeSwCfgFreq Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSwCfgFreq
Public Enumeration TypeSwCfgFreq
public enum class TypeSwCfgFreq
type TypeSwCfgFreq
Members
Member name | Value | Description
SwitchingFrequencyMasterFrequency | 0 | Switching Frequency: Master Frequency
SwitchingFrequencyHalfTheMasterFrequency | 1 | Switching Frequency: Half The Master Frequency
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeSwCfgPhase Enumeration

IRD

Adp5050TypeSwCfgPhase Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSwCfgPhase
Public Enumeration TypeSwCfgPhase
public enum class TypeSwCfgPhase
type TypeSwCfgPhase
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_90 | 1 | 90
Value_180 | 2 | 180
Value_270 | 3 | 270
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeThCfgLvinTh Enumeration

IRD

Adp5050TypeThCfgLvinTh Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeThCfgLvinTh
Public Enumeration TypeThCfgLvinTh
public enum class TypeThCfgLvinTh
type TypeThCfgLvinTh
Members
Member name | Value | Description
Value_4_2 | 0 | 4.2
Value_4_7 | 1 | 4.7
Value_5_2 | 2 | 5.2
Value_5_7 | 3 | 5.7
Value_6_2 | 4 | 6.2
Value_6_7 | 5 | 6.7
Value_7_2 | 6 | 7.2
Value_7_7 | 7 | 7.7
Value_8_2 | 8 | 8.2
Value_8_7 | 9 | 8.7
Value_9_2 | 10 | 9.2
Value_9_7 | 11 | 9.7
Value_10_2 | 12 | 10.2
Value_10_7 | 13 | 10.7
Value_11_2 | 14 | 11.2
Disabled | 15 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeThCfgTempTh Enumeration

IRD

Adp5050TypeThCfgTempTh Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeThCfgTempTh
Public Enumeration TypeThCfgTempTh
public enum class TypeThCfgTempTh
type TypeThCfgTempTh
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_105 | 1 | 105
Value_115 | 2 | 115
Value_125 | 3 | 125
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeVid23Vid2 Enumeration

IRD

Adp5050TypeVid23Vid2 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVid23Vid2
Public Enumeration TypeVid23Vid2
public enum class TypeVid23Vid2
type TypeVid23Vid2
Members
Member name | Value | Description
Value_0_8 | 0 | 0.8
Value_3_3 | 1 | 3.3
Value_3_6 | 2 | 3.6
Value_3_9 | 3 | 3.9
Value_4_2 | 4 | 4.2
Value_4_5 | 5 | 4.5
Value_4_8 | 6 | 4.8
Value_5_0 | 7 | 5.0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeVid23Vid3 Enumeration

IRD

Adp5050TypeVid23Vid3 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVid23Vid3
Public Enumeration TypeVid23Vid3
public enum class TypeVid23Vid3
type TypeVid23Vid3
Members
Member name | Value | Description
Value_0_8 | 0 | 0.8
Value_1_2 | 1 | 1.2
Value_1_3 | 2 | 1.3
Value_1_4 | 3 | 1.4
Value_1_5 | 4 | 1.5
Value_1_6 | 5 | 1.6
Value_1_7 | 6 | 1.7
Value_1_8 | 7 | 1.8
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5050.TypeVid4 Enumeration

IRD

Adp5050TypeVid4 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVid4
Public Enumeration TypeVid4
public enum class TypeVid4
type TypeVid4
Members
Member name | Value | Description
Value_0_8 | 0 | 0.8
Value_2_5 | 1 | 2.5
Value_2_6 | 2 | 2.6
Value_2_7 | 3 | 2.7
Value_2_8 | 4 | 2.8
Value_2_9 | 5 | 2.9
Value_3_0 | 6 | 3.0
Value_3_1 | 7 | 3.1
Value_3_2 | 8 | 3.2
Value_3_3 | 9 | 3.3
Value_3_4 | 10 | 3.4
Value_3_5 | 11 | 3.5
Value_3_6 | 12 | 3.6
Value_3_7 | 13 | 3.7
Value_3_8 | 14 | 3.8
Value_3_9 | 15 | 3.9
Value_4_0 | 16 | 4.0
Value_4_1 | 17 | 4.1
Value_4_2 | 18 | 4.2
Value_4_3 | 19 | 4.3
Value_4_4 | 20 | 4.4
Value_4_5 | 21 | 4.5
Value_4_6 | 22 | 4.6
Value_4_7 | 23 | 4.7
Value_4_8 | 24 | 4.8
Value_4_9 | 25 | 4.9
Value_5_0 | 26 | 5.0
Value_5_1 | 27 | 5.1
Value_5_2 | 28 | 5.2
Value_5_3 | 29 | 5.3
Value_5_4 | 30 | 5.4
Value_5_5 | 31 | 5.5
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061 Class

Analog Devices: ADP 5061
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdp5061

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adp5061
Public Class Adp5061
public ref class Adp5061
type Adp5061 =  class end

The Adp5061 type exposes the following members.

Constructors
 | Name | Description
Public method | Adp5061 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryShortTBATSHR | Battery Short: TBAT_SHR (unit: sec)
Public property | BatteryShortVBATSHR | Battery Short: VBAT_SHR (unit: V)
Public property | ChargerStatus1CHARGERSTATUS | Charger Status 1: CHARGER_STATUS
Public property | ChargerStatus1CHDONE | Charger Status 1: CHDONE
Public property | ChargerStatus1THERMLIM | Charger Status 1: THERM_LIM
Public property | ChargerStatus1VINILIM | Charger Status 1: VIN_ILIM
Public property | ChargerStatus1VINOK | Charger Status 1: VIN_OK
Public property | ChargerStatus1VINOV | Charger Status 1: VIN_OV
Public property | ChargerStatus2BATTERYSTATUS | Charger Status 2: BATTERY_STATUS
Public property | ChargerStatus2RCHLIMINFO | Charger Status 2: RCH_LIM_INFO
Public property | ChargerStatus2THRSTATUS | Charger Status 2: THR_STATUS
Public property | ChargingCurrentICHG | Charging Current: ICHG (unit: mA)
Public property | ChargingCurrentITRKDEAD | Charging Current: ITRK_DEAD (unit: mA)
Public property | FaultBATSHR | Fault: BAT_SHR
Public property | FaultTSD130C | Fault: TSD 130°C
Public property | FaultTSD140C | Fault: TSD 140°C
Public property | FunctionalSettings1DISIC1 | Functional Settings 1: DIS_IC1
Public property | FunctionalSettings1DISLDO | Functional Settings 1: DIS_LDO
Public property | FunctionalSettings1ENBMON | Functional Settings 1: EN_BMON
Public property | FunctionalSettings1ENCHG | Functional Settings 1: EN_CHG
Public property | FunctionalSettings1ENEOC | Functional Settings 1: EN_EOC
Public property | FunctionalSettings1ENTHR | Functional Settings 1: EN_THR
Public property | FunctionalSettings2ENCHGVLIM | Functional Settings 2: EN_CHG_VLIM
Public property | FunctionalSettings2ENJEITA | Functional Settings 2: EN_JEITA
Public property | FunctionalSettings2IDEALDIODE | Functional Settings 2: IDEAL_DIODE
Public property | FunctionalSettings2JEITASELECT | Functional Settings 2: JEITA_SELECT
Public property | FunctionalSettings2VSYSTEM | Functional Settings 2: VSYSTEM (unit: V)
Public property | IENDC10EOC | IEND: C/10 EOC
Public property | IENDC20EOC | IEND: C/20 EOC
Public property | IENDC5EOC | IEND: C/5 EOC
Public property | IENDIEND | IEND: IEND (unit: mA)
Public property | IENDSYSENSET | IEND: SYS_EN_SET
Public property | InterruptActiveBATINT | Interrupt Active: BAT_INT
Public property | InterruptActiveCHGINT | Interrupt Active: CHG_INT
Public property | InterruptActiveTHERMLIMINT | Interrupt Active: THERM_LIM_INT
Public property | InterruptActiveTHRINT | Interrupt Active: THR_INT
Public property | InterruptActiveTSDINT | Interrupt Active: TSD_INT
Public property | InterruptActiveVININT | Interrupt Active: VIN_INT
Public property | InterruptActiveWDINT | Interrupt Active: WD_INT
Public property | InterruptEnableENBATINT | Interrupt Enable: EN_BAT_INT
Public property | InterruptEnableENCHGINT | Interrupt Enable: EN_CHG_INT
Public property | InterruptEnableENTHERMLIMINT | Interrupt Enable: EN_THERM_LIM_INT
Public property | InterruptEnableENTHRINT | Interrupt Enable: EN_THR_INT
Public property | InterruptEnableENTSDINT | Interrupt Enable: EN_TSD_INT
Public property | InterruptEnableENVININT | Interrupt Enable: EN_VIN_INT
Public property | InterruptEnableENWDINT | Interrupt Enable: EN_WD_INT
Public property | ManufacturerAndModelIDMANUF | Manufacturer and Model ID: MANUF
Public property | ManufacturerAndModelIDMODEL | Manufacturer and Model ID: MODEL
Public property | SiliconRevisionREV | Silicon Revision: REV
Public property | TerminationSettingsCHGVLIM | Termination Settings: CHG_VLIM (unit: V)
Public property | TerminationSettingsVTRM | Termination Settings: VTRM (unit: V)
Public property | TimerSettingsCHGTMRPERIOD | Timer Settings: CHG_TMR_PERIOD
Public property | TimerSettingsENCHGTIMER | Timer Settings: EN_CHG_TIMER
Public property | TimerSettingsENTEND | Timer Settings: EN_TEND
Public property | TimerSettingsENWD | Timer Settings: EN_WD
Public property | TimerSettingsRESETWD | Timer Settings: RESET_WD
Public property | TimerSettingsWDPERIOD | Timer Settings: WD_PERIOD
Public property | VINxPinsSettingsILIM | VINx Pins Settings: ILIM (unit: mA)
Public property | VINxPinsSettingsRFU | VINx Pins Settings: RFU
Public property | VoltageThresholdsDISRCH | Voltage Thresholds: DIS_RCH
Public property | VoltageThresholdsVRCH | Voltage Thresholds: VRCH (unit: mV)
Public property | VoltageThresholdsVTRKDEAD | Voltage Thresholds: VTRK_DEAD (unit: V)
Public property | VoltageThresholdsVWEAK | Voltage Thresholds: VWEAK (unit: V)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Tiny I2C Programmable Linear Battery Charger with Power Path and USB Mode Compatibility
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adp5061(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adp5061

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061 Properties

The Adp5061 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryShortTBATSHR | Battery Short: TBAT_SHR (unit: sec)
Public property | BatteryShortVBATSHR | Battery Short: VBAT_SHR (unit: V)
Public property | ChargerStatus1CHARGERSTATUS | Charger Status 1: CHARGER_STATUS
Public property | ChargerStatus1CHDONE | Charger Status 1: CHDONE
Public property | ChargerStatus1THERMLIM | Charger Status 1: THERM_LIM
Public property | ChargerStatus1VINILIM | Charger Status 1: VIN_ILIM
Public property | ChargerStatus1VINOK | Charger Status 1: VIN_OK
Public property | ChargerStatus1VINOV | Charger Status 1: VIN_OV
Public property | ChargerStatus2BATTERYSTATUS | Charger Status 2: BATTERY_STATUS
Public property | ChargerStatus2RCHLIMINFO | Charger Status 2: RCH_LIM_INFO
Public property | ChargerStatus2THRSTATUS | Charger Status 2: THR_STATUS
Public property | ChargingCurrentICHG | Charging Current: ICHG (unit: mA)
Public property | ChargingCurrentITRKDEAD | Charging Current: ITRK_DEAD (unit: mA)
Public property | FaultBATSHR | Fault: BAT_SHR
Public property | FaultTSD130C | Fault: TSD 130°C
Public property | FaultTSD140C | Fault: TSD 140°C
Public property | FunctionalSettings1DISIC1 | Functional Settings 1: DIS_IC1
Public property | FunctionalSettings1DISLDO | Functional Settings 1: DIS_LDO
Public property | FunctionalSettings1ENBMON | Functional Settings 1: EN_BMON
Public property | FunctionalSettings1ENCHG | Functional Settings 1: EN_CHG
Public property | FunctionalSettings1ENEOC | Functional Settings 1: EN_EOC
Public property | FunctionalSettings1ENTHR | Functional Settings 1: EN_THR
Public property | FunctionalSettings2ENCHGVLIM | Functional Settings 2: EN_CHG_VLIM
Public property | FunctionalSettings2ENJEITA | Functional Settings 2: EN_JEITA
Public property | FunctionalSettings2IDEALDIODE | Functional Settings 2: IDEAL_DIODE
Public property | FunctionalSettings2JEITASELECT | Functional Settings 2: JEITA_SELECT
Public property | FunctionalSettings2VSYSTEM | Functional Settings 2: VSYSTEM (unit: V)
Public property | IENDC10EOC | IEND: C/10 EOC
Public property | IENDC20EOC | IEND: C/20 EOC
Public property | IENDC5EOC | IEND: C/5 EOC
Public property | IENDIEND | IEND: IEND (unit: mA)
Public property | IENDSYSENSET | IEND: SYS_EN_SET
Public property | InterruptActiveBATINT | Interrupt Active: BAT_INT
Public property | InterruptActiveCHGINT | Interrupt Active: CHG_INT
Public property | InterruptActiveTHERMLIMINT | Interrupt Active: THERM_LIM_INT
Public property | InterruptActiveTHRINT | Interrupt Active: THR_INT
Public property | InterruptActiveTSDINT | Interrupt Active: TSD_INT
Public property | InterruptActiveVININT | Interrupt Active: VIN_INT
Public property | InterruptActiveWDINT | Interrupt Active: WD_INT
Public property | InterruptEnableENBATINT | Interrupt Enable: EN_BAT_INT
Public property | InterruptEnableENCHGINT | Interrupt Enable: EN_CHG_INT
Public property | InterruptEnableENTHERMLIMINT | Interrupt Enable: EN_THERM_LIM_INT
Public property | InterruptEnableENTHRINT | Interrupt Enable: EN_THR_INT
Public property | InterruptEnableENTSDINT | Interrupt Enable: EN_TSD_INT
Public property | InterruptEnableENVININT | Interrupt Enable: EN_VIN_INT
Public property | InterruptEnableENWDINT | Interrupt Enable: EN_WD_INT
Public property | ManufacturerAndModelIDMANUF | Manufacturer and Model ID: MANUF
Public property | ManufacturerAndModelIDMODEL | Manufacturer and Model ID: MODEL
Public property | SiliconRevisionREV | Silicon Revision: REV
Public property | TerminationSettingsCHGVLIM | Termination Settings: CHG_VLIM (unit: V)
Public property | TerminationSettingsVTRM | Termination Settings: VTRM (unit: V)
Public property | TimerSettingsCHGTMRPERIOD | Timer Settings: CHG_TMR_PERIOD
Public property | TimerSettingsENCHGTIMER | Timer Settings: EN_CHG_TIMER
Public property | TimerSettingsENTEND | Timer Settings: EN_TEND
Public property | TimerSettingsENWD | Timer Settings: EN_WD
Public property | TimerSettingsRESETWD | Timer Settings: RESET_WD
Public property | TimerSettingsWDPERIOD | Timer Settings: WD_PERIOD
Public property | VINxPinsSettingsILIM | VINx Pins Settings: ILIM (unit: mA)
Public property | VINxPinsSettingsRFU | VINx Pins Settings: RFU
Public property | VoltageThresholdsDISRCH | Voltage Thresholds: DIS_RCH
Public property | VoltageThresholdsVRCH | Voltage Thresholds: VRCH (unit: mV)
Public property | VoltageThresholdsVTRKDEAD | Voltage Thresholds: VTRK_DEAD (unit: V)
Public property | VoltageThresholdsVWEAK | Voltage Thresholds: VWEAK (unit: V)
Top
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.AutoFlush Property

IRD

Adp5061AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.BatteryShortTBATSHR Property

IRD

Adp5061BatteryShortTBATSHR Property

Battery Short: TBAT_SHR (unit: sec)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeBatteryShortTbatShr BatteryShortTBATSHR { get; set; }
Public Property BatteryShortTBATSHR As Adp5061TypeBatteryShortTbatShr
    Get
    Set
public:
property Adp5061TypeBatteryShortTbatShr BatteryShortTBATSHR {
    Adp5061TypeBatteryShortTbatShr get ();
    void set (Adp5061TypeBatteryShortTbatShr value);
}
member BatteryShortTBATSHR : Adp5061TypeBatteryShortTbatShr with get, set

Property Value

Type: Adp5061TypeBatteryShortTbatShr
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.BatteryShortVBATSHR Property

IRD

Adp5061BatteryShortVBATSHR Property

Battery Short: VBAT_SHR (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeBatteryShortVbatShr BatteryShortVBATSHR { get; set; }
Public Property BatteryShortVBATSHR As Adp5061TypeBatteryShortVbatShr
    Get
    Set
public:
property Adp5061TypeBatteryShortVbatShr BatteryShortVBATSHR {
    Adp5061TypeBatteryShortVbatShr get ();
    void set (Adp5061TypeBatteryShortVbatShr value);
}
member BatteryShortVBATSHR : Adp5061TypeBatteryShortVbatShr with get, set

Property Value

Type: Adp5061TypeBatteryShortVbatShr
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.ChargerStatus1CHARGERSTATUS Property

IRD

Adp5061ChargerStatus1CHARGERSTATUS Property

Charger Status 1: CHARGER_STATUS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeChargerStatus1ChargerStatus ChargerStatus1CHARGERSTATUS { get; }
Public ReadOnly Property ChargerStatus1CHARGERSTATUS As Adp5061TypeChargerStatus1ChargerStatus
    Get
public:
property Adp5061TypeChargerStatus1ChargerStatus ChargerStatus1CHARGERSTATUS {
    Adp5061TypeChargerStatus1ChargerStatus get ();
}
member ChargerStatus1CHARGERSTATUS : Adp5061TypeChargerStatus1ChargerStatus with get

Property Value

Type: Adp5061TypeChargerStatus1ChargerStatus
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.ChargerStatus1CHDONE Property

IRD

Adp5061ChargerStatus1CHDONE Property

Charger Status 1: CHDONE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeChargerStatus1Chdone ChargerStatus1CHDONE { get; }
Public ReadOnly Property ChargerStatus1CHDONE As Adp5061TypeChargerStatus1Chdone
    Get
public:
property Adp5061TypeChargerStatus1Chdone ChargerStatus1CHDONE {
    Adp5061TypeChargerStatus1Chdone get ();
}
member ChargerStatus1CHDONE : Adp5061TypeChargerStatus1Chdone with get

Property Value

Type: Adp5061TypeChargerStatus1Chdone
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.ChargerStatus1THERMLIM Property

IRD

Adp5061ChargerStatus1THERMLIM Property

Charger Status 1: THERM_LIM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeChargerStatus1ThermLim ChargerStatus1THERMLIM { get; }
Public ReadOnly Property ChargerStatus1THERMLIM As Adp5061TypeChargerStatus1ThermLim
    Get
public:
property Adp5061TypeChargerStatus1ThermLim ChargerStatus1THERMLIM {
    Adp5061TypeChargerStatus1ThermLim get ();
}
member ChargerStatus1THERMLIM : Adp5061TypeChargerStatus1ThermLim with get

Property Value

Type: Adp5061TypeChargerStatus1ThermLim
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.ChargerStatus1VINILIM Property

IRD

Adp5061ChargerStatus1VINILIM Property

Charger Status 1: VIN_ILIM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeChargerStatus1VinIlim ChargerStatus1VINILIM { get; }
Public ReadOnly Property ChargerStatus1VINILIM As Adp5061TypeChargerStatus1VinIlim
    Get
public:
property Adp5061TypeChargerStatus1VinIlim ChargerStatus1VINILIM {
    Adp5061TypeChargerStatus1VinIlim get ();
}
member ChargerStatus1VINILIM : Adp5061TypeChargerStatus1VinIlim with get

Property Value

Type: Adp5061TypeChargerStatus1VinIlim
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.ChargerStatus1VINOK Property

IRD

Adp5061ChargerStatus1VINOK Property

Charger Status 1: VIN_OK

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeChargerStatus1VinOk ChargerStatus1VINOK { get; }
Public ReadOnly Property ChargerStatus1VINOK As Adp5061TypeChargerStatus1VinOk
    Get
public:
property Adp5061TypeChargerStatus1VinOk ChargerStatus1VINOK {
    Adp5061TypeChargerStatus1VinOk get ();
}
member ChargerStatus1VINOK : Adp5061TypeChargerStatus1VinOk with get

Property Value

Type: Adp5061TypeChargerStatus1VinOk
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.ChargerStatus1VINOV Property

IRD

Adp5061ChargerStatus1VINOV Property

Charger Status 1: VIN_OV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeChargerStatus1VinOv ChargerStatus1VINOV { get; }
Public ReadOnly Property ChargerStatus1VINOV As Adp5061TypeChargerStatus1VinOv
    Get
public:
property Adp5061TypeChargerStatus1VinOv ChargerStatus1VINOV {
    Adp5061TypeChargerStatus1VinOv get ();
}
member ChargerStatus1VINOV : Adp5061TypeChargerStatus1VinOv with get

Property Value

Type: Adp5061TypeChargerStatus1VinOv
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.ChargerStatus2BATTERYSTATUS Property

IRD

Adp5061ChargerStatus2BATTERYSTATUS Property

Charger Status 2: BATTERY_STATUS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeChargerStatus2BatteryStatus ChargerStatus2BATTERYSTATUS { get; }
Public ReadOnly Property ChargerStatus2BATTERYSTATUS As Adp5061TypeChargerStatus2BatteryStatus
    Get
public:
property Adp5061TypeChargerStatus2BatteryStatus ChargerStatus2BATTERYSTATUS {
    Adp5061TypeChargerStatus2BatteryStatus get ();
}
member ChargerStatus2BATTERYSTATUS : Adp5061TypeChargerStatus2BatteryStatus with get

Property Value

Type: Adp5061TypeChargerStatus2BatteryStatus
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.ChargerStatus2RCHLIMINFO Property

IRD

Adp5061ChargerStatus2RCHLIMINFO Property

Charger Status 2: RCH_LIM_INFO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeChargerStatus2RchLimInfo ChargerStatus2RCHLIMINFO { get; }
Public ReadOnly Property ChargerStatus2RCHLIMINFO As Adp5061TypeChargerStatus2RchLimInfo
    Get
public:
property Adp5061TypeChargerStatus2RchLimInfo ChargerStatus2RCHLIMINFO {
    Adp5061TypeChargerStatus2RchLimInfo get ();
}
member ChargerStatus2RCHLIMINFO : Adp5061TypeChargerStatus2RchLimInfo with get

Property Value

Type: Adp5061TypeChargerStatus2RchLimInfo
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.ChargerStatus2THRSTATUS Property

IRD

Adp5061ChargerStatus2THRSTATUS Property

Charger Status 2: THR_STATUS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeChargerStatus2ThrStatus ChargerStatus2THRSTATUS { get; }
Public ReadOnly Property ChargerStatus2THRSTATUS As Adp5061TypeChargerStatus2ThrStatus
    Get
public:
property Adp5061TypeChargerStatus2ThrStatus ChargerStatus2THRSTATUS {
    Adp5061TypeChargerStatus2ThrStatus get ();
}
member ChargerStatus2THRSTATUS : Adp5061TypeChargerStatus2ThrStatus with get

Property Value

Type: Adp5061TypeChargerStatus2ThrStatus
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.ChargingCurrentICHG Property

IRD

Adp5061ChargingCurrentICHG Property

Charging Current: ICHG (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeChargingCurrentIchg ChargingCurrentICHG { get; set; }
Public Property ChargingCurrentICHG As Adp5061TypeChargingCurrentIchg
    Get
    Set
public:
property Adp5061TypeChargingCurrentIchg ChargingCurrentICHG {
    Adp5061TypeChargingCurrentIchg get ();
    void set (Adp5061TypeChargingCurrentIchg value);
}
member ChargingCurrentICHG : Adp5061TypeChargingCurrentIchg with get, set

Property Value

Type: Adp5061TypeChargingCurrentIchg
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.ChargingCurrentITRKDEAD Property

IRD

Adp5061ChargingCurrentITRKDEAD Property

Charging Current: ITRK_DEAD (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeChargingCurrentItrkDead ChargingCurrentITRKDEAD { get; set; }
Public Property ChargingCurrentITRKDEAD As Adp5061TypeChargingCurrentItrkDead
    Get
    Set
public:
property Adp5061TypeChargingCurrentItrkDead ChargingCurrentITRKDEAD {
    Adp5061TypeChargingCurrentItrkDead get ();
    void set (Adp5061TypeChargingCurrentItrkDead value);
}
member ChargingCurrentITRKDEAD : Adp5061TypeChargingCurrentItrkDead with get, set

Property Value

Type: Adp5061TypeChargingCurrentItrkDead
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.FaultBATSHR Property

IRD

Adp5061FaultBATSHR Property

Fault: BAT_SHR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeFaultBatShr FaultBATSHR { get; set; }
Public Property FaultBATSHR As Adp5061TypeFaultBatShr
    Get
    Set
public:
property Adp5061TypeFaultBatShr FaultBATSHR {
    Adp5061TypeFaultBatShr get ();
    void set (Adp5061TypeFaultBatShr value);
}
member FaultBATSHR : Adp5061TypeFaultBatShr with get, set

Property Value

Type: Adp5061TypeFaultBatShr
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.FaultTSD130C Property

IRD

Adp5061FaultTSD130C Property

Fault: TSD 130°C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeFaultOverTemp FaultTSD130C { get; set; }
Public Property FaultTSD130C As Adp5061TypeFaultOverTemp
    Get
    Set
public:
property Adp5061TypeFaultOverTemp FaultTSD130C {
    Adp5061TypeFaultOverTemp get ();
    void set (Adp5061TypeFaultOverTemp value);
}
member FaultTSD130C : Adp5061TypeFaultOverTemp with get, set

Property Value

Type: Adp5061TypeFaultOverTemp
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.FaultTSD140C Property

IRD

Adp5061FaultTSD140C Property

Fault: TSD 140°C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeFaultOverTemp FaultTSD140C { get; set; }
Public Property FaultTSD140C As Adp5061TypeFaultOverTemp
    Get
    Set
public:
property Adp5061TypeFaultOverTemp FaultTSD140C {
    Adp5061TypeFaultOverTemp get ();
    void set (Adp5061TypeFaultOverTemp value);
}
member FaultTSD140C : Adp5061TypeFaultOverTemp with get, set

Property Value

Type: Adp5061TypeFaultOverTemp
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.FunctionalSettings1DISIC1 Property

IRD

Adp5061FunctionalSettings1DISIC1 Property

Functional Settings 1: DIS_IC1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeFunctionalSettings1DisIc1 FunctionalSettings1DISIC1 { get; set; }
Public Property FunctionalSettings1DISIC1 As Adp5061TypeFunctionalSettings1DisIc1
    Get
    Set
public:
property Adp5061TypeFunctionalSettings1DisIc1 FunctionalSettings1DISIC1 {
    Adp5061TypeFunctionalSettings1DisIc1 get ();
    void set (Adp5061TypeFunctionalSettings1DisIc1 value);
}
member FunctionalSettings1DISIC1 : Adp5061TypeFunctionalSettings1DisIc1 with get, set

Property Value

Type: Adp5061TypeFunctionalSettings1DisIc1
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.FunctionalSettings1DISLDO Property

IRD

Adp5061FunctionalSettings1DISLDO Property

Functional Settings 1: DIS_LDO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeFunctionalSettings1DisLdo FunctionalSettings1DISLDO { get; set; }
Public Property FunctionalSettings1DISLDO As Adp5061TypeFunctionalSettings1DisLdo
    Get
    Set
public:
property Adp5061TypeFunctionalSettings1DisLdo FunctionalSettings1DISLDO {
    Adp5061TypeFunctionalSettings1DisLdo get ();
    void set (Adp5061TypeFunctionalSettings1DisLdo value);
}
member FunctionalSettings1DISLDO : Adp5061TypeFunctionalSettings1DisLdo with get, set

Property Value

Type: Adp5061TypeFunctionalSettings1DisLdo
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.FunctionalSettings1ENBMON Property

IRD

Adp5061FunctionalSettings1ENBMON Property

Functional Settings 1: EN_BMON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeFunctionalSettings1EnBmon FunctionalSettings1ENBMON { get; set; }
Public Property FunctionalSettings1ENBMON As Adp5061TypeFunctionalSettings1EnBmon
    Get
    Set
public:
property Adp5061TypeFunctionalSettings1EnBmon FunctionalSettings1ENBMON {
    Adp5061TypeFunctionalSettings1EnBmon get ();
    void set (Adp5061TypeFunctionalSettings1EnBmon value);
}
member FunctionalSettings1ENBMON : Adp5061TypeFunctionalSettings1EnBmon with get, set

Property Value

Type: Adp5061TypeFunctionalSettings1EnBmon
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.FunctionalSettings1ENCHG Property

IRD

Adp5061FunctionalSettings1ENCHG Property

Functional Settings 1: EN_CHG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeFunctionalSettings1EnChg FunctionalSettings1ENCHG { get; set; }
Public Property FunctionalSettings1ENCHG As Adp5061TypeFunctionalSettings1EnChg
    Get
    Set
public:
property Adp5061TypeFunctionalSettings1EnChg FunctionalSettings1ENCHG {
    Adp5061TypeFunctionalSettings1EnChg get ();
    void set (Adp5061TypeFunctionalSettings1EnChg value);
}
member FunctionalSettings1ENCHG : Adp5061TypeFunctionalSettings1EnChg with get, set

Property Value

Type: Adp5061TypeFunctionalSettings1EnChg
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.FunctionalSettings1ENEOC Property

IRD

Adp5061FunctionalSettings1ENEOC Property

Functional Settings 1: EN_EOC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeFunctionalSettings1EnEoc FunctionalSettings1ENEOC { get; set; }
Public Property FunctionalSettings1ENEOC As Adp5061TypeFunctionalSettings1EnEoc
    Get
    Set
public:
property Adp5061TypeFunctionalSettings1EnEoc FunctionalSettings1ENEOC {
    Adp5061TypeFunctionalSettings1EnEoc get ();
    void set (Adp5061TypeFunctionalSettings1EnEoc value);
}
member FunctionalSettings1ENEOC : Adp5061TypeFunctionalSettings1EnEoc with get, set

Property Value

Type: Adp5061TypeFunctionalSettings1EnEoc
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.FunctionalSettings1ENTHR Property

IRD

Adp5061FunctionalSettings1ENTHR Property

Functional Settings 1: EN_THR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeFunctionalSettings1EnThr FunctionalSettings1ENTHR { get; set; }
Public Property FunctionalSettings1ENTHR As Adp5061TypeFunctionalSettings1EnThr
    Get
    Set
public:
property Adp5061TypeFunctionalSettings1EnThr FunctionalSettings1ENTHR {
    Adp5061TypeFunctionalSettings1EnThr get ();
    void set (Adp5061TypeFunctionalSettings1EnThr value);
}
member FunctionalSettings1ENTHR : Adp5061TypeFunctionalSettings1EnThr with get, set

Property Value

Type: Adp5061TypeFunctionalSettings1EnThr
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.FunctionalSettings2ENCHGVLIM Property

IRD

Adp5061FunctionalSettings2ENCHGVLIM Property

Functional Settings 2: EN_CHG_VLIM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeFunctionalSettings2EnChgVlim FunctionalSettings2ENCHGVLIM { get; set; }
Public Property FunctionalSettings2ENCHGVLIM As Adp5061TypeFunctionalSettings2EnChgVlim
    Get
    Set
public:
property Adp5061TypeFunctionalSettings2EnChgVlim FunctionalSettings2ENCHGVLIM {
    Adp5061TypeFunctionalSettings2EnChgVlim get ();
    void set (Adp5061TypeFunctionalSettings2EnChgVlim value);
}
member FunctionalSettings2ENCHGVLIM : Adp5061TypeFunctionalSettings2EnChgVlim with get, set

Property Value

Type: Adp5061TypeFunctionalSettings2EnChgVlim
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.FunctionalSettings2ENJEITA Property

IRD

Adp5061FunctionalSettings2ENJEITA Property

Functional Settings 2: EN_JEITA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeFunctionalSettings2EnJeita FunctionalSettings2ENJEITA { get; set; }
Public Property FunctionalSettings2ENJEITA As Adp5061TypeFunctionalSettings2EnJeita
    Get
    Set
public:
property Adp5061TypeFunctionalSettings2EnJeita FunctionalSettings2ENJEITA {
    Adp5061TypeFunctionalSettings2EnJeita get ();
    void set (Adp5061TypeFunctionalSettings2EnJeita value);
}
member FunctionalSettings2ENJEITA : Adp5061TypeFunctionalSettings2EnJeita with get, set

Property Value

Type: Adp5061TypeFunctionalSettings2EnJeita
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.FunctionalSettings2IDEALDIODE Property

IRD

Adp5061FunctionalSettings2IDEALDIODE Property

Functional Settings 2: IDEAL_DIODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeFunctionalSettings2IdealDiode FunctionalSettings2IDEALDIODE { get; set; }
Public Property FunctionalSettings2IDEALDIODE As Adp5061TypeFunctionalSettings2IdealDiode
    Get
    Set
public:
property Adp5061TypeFunctionalSettings2IdealDiode FunctionalSettings2IDEALDIODE {
    Adp5061TypeFunctionalSettings2IdealDiode get ();
    void set (Adp5061TypeFunctionalSettings2IdealDiode value);
}
member FunctionalSettings2IDEALDIODE : Adp5061TypeFunctionalSettings2IdealDiode with get, set

Property Value

Type: Adp5061TypeFunctionalSettings2IdealDiode
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.FunctionalSettings2JEITASELECT Property

IRD

Adp5061FunctionalSettings2JEITASELECT Property

Functional Settings 2: JEITA_SELECT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeFunctionalSettings2JeitaSelect FunctionalSettings2JEITASELECT { get; set; }
Public Property FunctionalSettings2JEITASELECT As Adp5061TypeFunctionalSettings2JeitaSelect
    Get
    Set
public:
property Adp5061TypeFunctionalSettings2JeitaSelect FunctionalSettings2JEITASELECT {
    Adp5061TypeFunctionalSettings2JeitaSelect get ();
    void set (Adp5061TypeFunctionalSettings2JeitaSelect value);
}
member FunctionalSettings2JEITASELECT : Adp5061TypeFunctionalSettings2JeitaSelect with get, set

Property Value

Type: Adp5061TypeFunctionalSettings2JeitaSelect
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.FunctionalSettings2VSYSTEM Property

IRD

Adp5061FunctionalSettings2VSYSTEM Property

Functional Settings 2: VSYSTEM (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeFunctionalSettings2Vsystem FunctionalSettings2VSYSTEM { get; set; }
Public Property FunctionalSettings2VSYSTEM As Adp5061TypeFunctionalSettings2Vsystem
    Get
    Set
public:
property Adp5061TypeFunctionalSettings2Vsystem FunctionalSettings2VSYSTEM {
    Adp5061TypeFunctionalSettings2Vsystem get ();
    void set (Adp5061TypeFunctionalSettings2Vsystem value);
}
member FunctionalSettings2VSYSTEM : Adp5061TypeFunctionalSettings2Vsystem with get, set

Property Value

Type: Adp5061TypeFunctionalSettings2Vsystem
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.IENDC10EOC Property

IRD

Adp5061IENDC10EOC Property

IEND: C/10 EOC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeIendC10Eoc IENDC10EOC { get; set; }
Public Property IENDC10EOC As Adp5061TypeIendC10Eoc
    Get
    Set
public:
property Adp5061TypeIendC10Eoc IENDC10EOC {
    Adp5061TypeIendC10Eoc get ();
    void set (Adp5061TypeIendC10Eoc value);
}
member IENDC10EOC : Adp5061TypeIendC10Eoc with get, set

Property Value

Type: Adp5061TypeIendC10Eoc
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.IENDC20EOC Property

IRD

Adp5061IENDC20EOC Property

IEND: C/20 EOC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeIendC20Eoc IENDC20EOC { get; set; }
Public Property IENDC20EOC As Adp5061TypeIendC20Eoc
    Get
    Set
public:
property Adp5061TypeIendC20Eoc IENDC20EOC {
    Adp5061TypeIendC20Eoc get ();
    void set (Adp5061TypeIendC20Eoc value);
}
member IENDC20EOC : Adp5061TypeIendC20Eoc with get, set

Property Value

Type: Adp5061TypeIendC20Eoc
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.IENDC5EOC Property

IRD

Adp5061IENDC5EOC Property

IEND: C/5 EOC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeIendC5Eoc IENDC5EOC { get; set; }
Public Property IENDC5EOC As Adp5061TypeIendC5Eoc
    Get
    Set
public:
property Adp5061TypeIendC5Eoc IENDC5EOC {
    Adp5061TypeIendC5Eoc get ();
    void set (Adp5061TypeIendC5Eoc value);
}
member IENDC5EOC : Adp5061TypeIendC5Eoc with get, set

Property Value

Type: Adp5061TypeIendC5Eoc
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.IENDIEND Property

IRD

Adp5061IENDIEND Property

IEND: IEND (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeIendIend IENDIEND { get; set; }
Public Property IENDIEND As Adp5061TypeIendIend
    Get
    Set
public:
property Adp5061TypeIendIend IENDIEND {
    Adp5061TypeIendIend get ();
    void set (Adp5061TypeIendIend value);
}
member IENDIEND : Adp5061TypeIendIend with get, set

Property Value

Type: Adp5061TypeIendIend
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.IENDSYSENSET Property

IRD

Adp5061IENDSYSENSET Property

IEND: SYS_EN_SET

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeIendSysEnSet IENDSYSENSET { get; set; }
Public Property IENDSYSENSET As Adp5061TypeIendSysEnSet
    Get
    Set
public:
property Adp5061TypeIendSysEnSet IENDSYSENSET {
    Adp5061TypeIendSysEnSet get ();
    void set (Adp5061TypeIendSysEnSet value);
}
member IENDSYSENSET : Adp5061TypeIendSysEnSet with get, set

Property Value

Type: Adp5061TypeIendSysEnSet
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.InterruptActiveBATINT Property

IRD

Adp5061InterruptActiveBATINT Property

Interrupt Active: BAT_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeInterruptActive InterruptActiveBATINT { get; }
Public ReadOnly Property InterruptActiveBATINT As Adp5061TypeInterruptActive
    Get
public:
property Adp5061TypeInterruptActive InterruptActiveBATINT {
    Adp5061TypeInterruptActive get ();
}
member InterruptActiveBATINT : Adp5061TypeInterruptActive with get

Property Value

Type: Adp5061TypeInterruptActive
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.InterruptActiveCHGINT Property

IRD

Adp5061InterruptActiveCHGINT Property

Interrupt Active: CHG_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeInterruptActive InterruptActiveCHGINT { get; }
Public ReadOnly Property InterruptActiveCHGINT As Adp5061TypeInterruptActive
    Get
public:
property Adp5061TypeInterruptActive InterruptActiveCHGINT {
    Adp5061TypeInterruptActive get ();
}
member InterruptActiveCHGINT : Adp5061TypeInterruptActive with get

Property Value

Type: Adp5061TypeInterruptActive
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.InterruptActiveTHERMLIMINT Property

IRD

Adp5061InterruptActiveTHERMLIMINT Property

Interrupt Active: THERM_LIM_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeInterruptActive InterruptActiveTHERMLIMINT { get; }
Public ReadOnly Property InterruptActiveTHERMLIMINT As Adp5061TypeInterruptActive
    Get
public:
property Adp5061TypeInterruptActive InterruptActiveTHERMLIMINT {
    Adp5061TypeInterruptActive get ();
}
member InterruptActiveTHERMLIMINT : Adp5061TypeInterruptActive with get

Property Value

Type: Adp5061TypeInterruptActive
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.InterruptActiveTHRINT Property

IRD

Adp5061InterruptActiveTHRINT Property

Interrupt Active: THR_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeInterruptActive InterruptActiveTHRINT { get; }
Public ReadOnly Property InterruptActiveTHRINT As Adp5061TypeInterruptActive
    Get
public:
property Adp5061TypeInterruptActive InterruptActiveTHRINT {
    Adp5061TypeInterruptActive get ();
}
member InterruptActiveTHRINT : Adp5061TypeInterruptActive with get

Property Value

Type: Adp5061TypeInterruptActive
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.InterruptActiveTSDINT Property

IRD

Adp5061InterruptActiveTSDINT Property

Interrupt Active: TSD_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeInterruptActive InterruptActiveTSDINT { get; }
Public ReadOnly Property InterruptActiveTSDINT As Adp5061TypeInterruptActive
    Get
public:
property Adp5061TypeInterruptActive InterruptActiveTSDINT {
    Adp5061TypeInterruptActive get ();
}
member InterruptActiveTSDINT : Adp5061TypeInterruptActive with get

Property Value

Type: Adp5061TypeInterruptActive
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.InterruptActiveVININT Property

IRD

Adp5061InterruptActiveVININT Property

Interrupt Active: VIN_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeInterruptActive InterruptActiveVININT { get; }
Public ReadOnly Property InterruptActiveVININT As Adp5061TypeInterruptActive
    Get
public:
property Adp5061TypeInterruptActive InterruptActiveVININT {
    Adp5061TypeInterruptActive get ();
}
member InterruptActiveVININT : Adp5061TypeInterruptActive with get

Property Value

Type: Adp5061TypeInterruptActive
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.InterruptActiveWDINT Property

IRD

Adp5061InterruptActiveWDINT Property

Interrupt Active: WD_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeInterruptActive InterruptActiveWDINT { get; }
Public ReadOnly Property InterruptActiveWDINT As Adp5061TypeInterruptActive
    Get
public:
property Adp5061TypeInterruptActive InterruptActiveWDINT {
    Adp5061TypeInterruptActive get ();
}
member InterruptActiveWDINT : Adp5061TypeInterruptActive with get

Property Value

Type: Adp5061TypeInterruptActive
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.InterruptEnableENBATINT Property

IRD

Adp5061InterruptEnableENBATINT Property

Interrupt Enable: EN_BAT_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeInterruptEnable InterruptEnableENBATINT { get; set; }
Public Property InterruptEnableENBATINT As Adp5061TypeInterruptEnable
    Get
    Set
public:
property Adp5061TypeInterruptEnable InterruptEnableENBATINT {
    Adp5061TypeInterruptEnable get ();
    void set (Adp5061TypeInterruptEnable value);
}
member InterruptEnableENBATINT : Adp5061TypeInterruptEnable with get, set

Property Value

Type: Adp5061TypeInterruptEnable
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.InterruptEnableENCHGINT Property

IRD

Adp5061InterruptEnableENCHGINT Property

Interrupt Enable: EN_CHG_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeInterruptEnable InterruptEnableENCHGINT { get; set; }
Public Property InterruptEnableENCHGINT As Adp5061TypeInterruptEnable
    Get
    Set
public:
property Adp5061TypeInterruptEnable InterruptEnableENCHGINT {
    Adp5061TypeInterruptEnable get ();
    void set (Adp5061TypeInterruptEnable value);
}
member InterruptEnableENCHGINT : Adp5061TypeInterruptEnable with get, set

Property Value

Type: Adp5061TypeInterruptEnable
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.InterruptEnableENTHERMLIMINT Property

IRD

Adp5061InterruptEnableENTHERMLIMINT Property

Interrupt Enable: EN_THERM_LIM_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeInterruptEnable InterruptEnableENTHERMLIMINT { get; set; }
Public Property InterruptEnableENTHERMLIMINT As Adp5061TypeInterruptEnable
    Get
    Set
public:
property Adp5061TypeInterruptEnable InterruptEnableENTHERMLIMINT {
    Adp5061TypeInterruptEnable get ();
    void set (Adp5061TypeInterruptEnable value);
}
member InterruptEnableENTHERMLIMINT : Adp5061TypeInterruptEnable with get, set

Property Value

Type: Adp5061TypeInterruptEnable
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.InterruptEnableENTHRINT Property

IRD

Adp5061InterruptEnableENTHRINT Property

Interrupt Enable: EN_THR_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeInterruptEnable InterruptEnableENTHRINT { get; set; }
Public Property InterruptEnableENTHRINT As Adp5061TypeInterruptEnable
    Get
    Set
public:
property Adp5061TypeInterruptEnable InterruptEnableENTHRINT {
    Adp5061TypeInterruptEnable get ();
    void set (Adp5061TypeInterruptEnable value);
}
member InterruptEnableENTHRINT : Adp5061TypeInterruptEnable with get, set

Property Value

Type: Adp5061TypeInterruptEnable
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.InterruptEnableENTSDINT Property

IRD

Adp5061InterruptEnableENTSDINT Property

Interrupt Enable: EN_TSD_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeInterruptEnable InterruptEnableENTSDINT { get; set; }
Public Property InterruptEnableENTSDINT As Adp5061TypeInterruptEnable
    Get
    Set
public:
property Adp5061TypeInterruptEnable InterruptEnableENTSDINT {
    Adp5061TypeInterruptEnable get ();
    void set (Adp5061TypeInterruptEnable value);
}
member InterruptEnableENTSDINT : Adp5061TypeInterruptEnable with get, set

Property Value

Type: Adp5061TypeInterruptEnable
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.InterruptEnableENVININT Property

IRD

Adp5061InterruptEnableENVININT Property

Interrupt Enable: EN_VIN_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeInterruptEnable InterruptEnableENVININT { get; set; }
Public Property InterruptEnableENVININT As Adp5061TypeInterruptEnable
    Get
    Set
public:
property Adp5061TypeInterruptEnable InterruptEnableENVININT {
    Adp5061TypeInterruptEnable get ();
    void set (Adp5061TypeInterruptEnable value);
}
member InterruptEnableENVININT : Adp5061TypeInterruptEnable with get, set

Property Value

Type: Adp5061TypeInterruptEnable
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.InterruptEnableENWDINT Property

IRD

Adp5061InterruptEnableENWDINT Property

Interrupt Enable: EN_WD_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeInterruptEnable InterruptEnableENWDINT { get; set; }
Public Property InterruptEnableENWDINT As Adp5061TypeInterruptEnable
    Get
    Set
public:
property Adp5061TypeInterruptEnable InterruptEnableENWDINT {
    Adp5061TypeInterruptEnable get ();
    void set (Adp5061TypeInterruptEnable value);
}
member InterruptEnableENWDINT : Adp5061TypeInterruptEnable with get, set

Property Value

Type: Adp5061TypeInterruptEnable
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.ManufacturerAndModelIDMANUF Property

IRD

Adp5061ManufacturerAndModelIDMANUF Property

Manufacturer and Model ID: MANUF

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerAndModelIDMANUF { get; }
Public ReadOnly Property ManufacturerAndModelIDMANUF As Byte
    Get
public:
property unsigned char ManufacturerAndModelIDMANUF {
    unsigned char get ();
}
member ManufacturerAndModelIDMANUF : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.ManufacturerAndModelIDMODEL Property

IRD

Adp5061ManufacturerAndModelIDMODEL Property

Manufacturer and Model ID: MODEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerAndModelIDMODEL { get; }
Public ReadOnly Property ManufacturerAndModelIDMODEL As Byte
    Get
public:
property unsigned char ManufacturerAndModelIDMODEL {
    unsigned char get ();
}
member ManufacturerAndModelIDMODEL : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.SiliconRevisionREV Property

IRD

Adp5061SiliconRevisionREV Property

Silicon Revision: REV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SiliconRevisionREV { get; }
Public ReadOnly Property SiliconRevisionREV As Byte
    Get
public:
property unsigned char SiliconRevisionREV {
    unsigned char get ();
}
member SiliconRevisionREV : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.TerminationSettingsCHGVLIM Property

IRD

Adp5061TerminationSettingsCHGVLIM Property

Termination Settings: CHG_VLIM (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeTerminationSettingsChgVlim TerminationSettingsCHGVLIM { get; set; }
Public Property TerminationSettingsCHGVLIM As Adp5061TypeTerminationSettingsChgVlim
    Get
    Set
public:
property Adp5061TypeTerminationSettingsChgVlim TerminationSettingsCHGVLIM {
    Adp5061TypeTerminationSettingsChgVlim get ();
    void set (Adp5061TypeTerminationSettingsChgVlim value);
}
member TerminationSettingsCHGVLIM : Adp5061TypeTerminationSettingsChgVlim with get, set

Property Value

Type: Adp5061TypeTerminationSettingsChgVlim
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.TerminationSettingsVTRM Property

IRD

Adp5061TerminationSettingsVTRM Property

Termination Settings: VTRM (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeTerminationSettingsVtrm TerminationSettingsVTRM { get; set; }
Public Property TerminationSettingsVTRM As Adp5061TypeTerminationSettingsVtrm
    Get
    Set
public:
property Adp5061TypeTerminationSettingsVtrm TerminationSettingsVTRM {
    Adp5061TypeTerminationSettingsVtrm get ();
    void set (Adp5061TypeTerminationSettingsVtrm value);
}
member TerminationSettingsVTRM : Adp5061TypeTerminationSettingsVtrm with get, set

Property Value

Type: Adp5061TypeTerminationSettingsVtrm
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.TimerSettingsCHGTMRPERIOD Property

IRD

Adp5061TimerSettingsCHGTMRPERIOD Property

Timer Settings: CHG_TMR_PERIOD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeTimerSettingsChgTmrPeriod TimerSettingsCHGTMRPERIOD { get; set; }
Public Property TimerSettingsCHGTMRPERIOD As Adp5061TypeTimerSettingsChgTmrPeriod
    Get
    Set
public:
property Adp5061TypeTimerSettingsChgTmrPeriod TimerSettingsCHGTMRPERIOD {
    Adp5061TypeTimerSettingsChgTmrPeriod get ();
    void set (Adp5061TypeTimerSettingsChgTmrPeriod value);
}
member TimerSettingsCHGTMRPERIOD : Adp5061TypeTimerSettingsChgTmrPeriod with get, set

Property Value

Type: Adp5061TypeTimerSettingsChgTmrPeriod
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.TimerSettingsENCHGTIMER Property

IRD

Adp5061TimerSettingsENCHGTIMER Property

Timer Settings: EN_CHG_TIMER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeTimerSettingsEnChgTimer TimerSettingsENCHGTIMER { get; set; }
Public Property TimerSettingsENCHGTIMER As Adp5061TypeTimerSettingsEnChgTimer
    Get
    Set
public:
property Adp5061TypeTimerSettingsEnChgTimer TimerSettingsENCHGTIMER {
    Adp5061TypeTimerSettingsEnChgTimer get ();
    void set (Adp5061TypeTimerSettingsEnChgTimer value);
}
member TimerSettingsENCHGTIMER : Adp5061TypeTimerSettingsEnChgTimer with get, set

Property Value

Type: Adp5061TypeTimerSettingsEnChgTimer
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.TimerSettingsENTEND Property

IRD

Adp5061TimerSettingsENTEND Property

Timer Settings: EN_TEND

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeTimerSettingsEnTend TimerSettingsENTEND { get; set; }
Public Property TimerSettingsENTEND As Adp5061TypeTimerSettingsEnTend
    Get
    Set
public:
property Adp5061TypeTimerSettingsEnTend TimerSettingsENTEND {
    Adp5061TypeTimerSettingsEnTend get ();
    void set (Adp5061TypeTimerSettingsEnTend value);
}
member TimerSettingsENTEND : Adp5061TypeTimerSettingsEnTend with get, set

Property Value

Type: Adp5061TypeTimerSettingsEnTend
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.TimerSettingsENWD Property

IRD

Adp5061TimerSettingsENWD Property

Timer Settings: EN_WD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeTimerSettingsEnWd TimerSettingsENWD { get; set; }
Public Property TimerSettingsENWD As Adp5061TypeTimerSettingsEnWd
    Get
    Set
public:
property Adp5061TypeTimerSettingsEnWd TimerSettingsENWD {
    Adp5061TypeTimerSettingsEnWd get ();
    void set (Adp5061TypeTimerSettingsEnWd value);
}
member TimerSettingsENWD : Adp5061TypeTimerSettingsEnWd with get, set

Property Value

Type: Adp5061TypeTimerSettingsEnWd
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.TimerSettingsRESETWD Property

IRD

Adp5061TimerSettingsRESETWD Property

Timer Settings: RESET_WD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeTimerSettingsResetWd TimerSettingsRESETWD { set; }
Public WriteOnly Property TimerSettingsRESETWD As Adp5061TypeTimerSettingsResetWd
    Set
public:
property Adp5061TypeTimerSettingsResetWd TimerSettingsRESETWD {
    void set (Adp5061TypeTimerSettingsResetWd value);
}
member TimerSettingsRESETWD : Adp5061TypeTimerSettingsResetWd with set

Property Value

Type: Adp5061TypeTimerSettingsResetWd
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.TimerSettingsWDPERIOD Property

IRD

Adp5061TimerSettingsWDPERIOD Property

Timer Settings: WD_PERIOD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeTimerSettingsWdPeriod TimerSettingsWDPERIOD { get; set; }
Public Property TimerSettingsWDPERIOD As Adp5061TypeTimerSettingsWdPeriod
    Get
    Set
public:
property Adp5061TypeTimerSettingsWdPeriod TimerSettingsWDPERIOD {
    Adp5061TypeTimerSettingsWdPeriod get ();
    void set (Adp5061TypeTimerSettingsWdPeriod value);
}
member TimerSettingsWDPERIOD : Adp5061TypeTimerSettingsWdPeriod with get, set

Property Value

Type: Adp5061TypeTimerSettingsWdPeriod
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.VINxPinsSettingsILIM Property

IRD

Adp5061VINxPinsSettingsILIM Property

VINx Pins Settings: ILIM (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeVpinxPinsSettingsIlim VINxPinsSettingsILIM { get; set; }
Public Property VINxPinsSettingsILIM As Adp5061TypeVpinxPinsSettingsIlim
    Get
    Set
public:
property Adp5061TypeVpinxPinsSettingsIlim VINxPinsSettingsILIM {
    Adp5061TypeVpinxPinsSettingsIlim get ();
    void set (Adp5061TypeVpinxPinsSettingsIlim value);
}
member VINxPinsSettingsILIM : Adp5061TypeVpinxPinsSettingsIlim with get, set

Property Value

Type: Adp5061TypeVpinxPinsSettingsIlim
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.VINxPinsSettingsRFU Property

IRD

Adp5061VINxPinsSettingsRFU Property

VINx Pins Settings: RFU

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VINxPinsSettingsRFU { get; set; }
Public Property VINxPinsSettingsRFU As Byte
    Get
    Set
public:
property unsigned char VINxPinsSettingsRFU {
    unsigned char get ();
    void set (unsigned char value);
}
member VINxPinsSettingsRFU : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.VoltageThresholdsDISRCH Property

IRD

Adp5061VoltageThresholdsDISRCH Property

Voltage Thresholds: DIS_RCH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeVoltageThresholdsDisRch VoltageThresholdsDISRCH { get; set; }
Public Property VoltageThresholdsDISRCH As Adp5061TypeVoltageThresholdsDisRch
    Get
    Set
public:
property Adp5061TypeVoltageThresholdsDisRch VoltageThresholdsDISRCH {
    Adp5061TypeVoltageThresholdsDisRch get ();
    void set (Adp5061TypeVoltageThresholdsDisRch value);
}
member VoltageThresholdsDISRCH : Adp5061TypeVoltageThresholdsDisRch with get, set

Property Value

Type: Adp5061TypeVoltageThresholdsDisRch
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.VoltageThresholdsVRCH Property

IRD

Adp5061VoltageThresholdsVRCH Property

Voltage Thresholds: VRCH (unit: mV)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeVoltageThresholdsVrch VoltageThresholdsVRCH { get; set; }
Public Property VoltageThresholdsVRCH As Adp5061TypeVoltageThresholdsVrch
    Get
    Set
public:
property Adp5061TypeVoltageThresholdsVrch VoltageThresholdsVRCH {
    Adp5061TypeVoltageThresholdsVrch get ();
    void set (Adp5061TypeVoltageThresholdsVrch value);
}
member VoltageThresholdsVRCH : Adp5061TypeVoltageThresholdsVrch with get, set

Property Value

Type: Adp5061TypeVoltageThresholdsVrch
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.VoltageThresholdsVTRKDEAD Property

IRD

Adp5061VoltageThresholdsVTRKDEAD Property

Voltage Thresholds: VTRK_DEAD (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeVoltageThresholdsVtrkDead VoltageThresholdsVTRKDEAD { get; set; }
Public Property VoltageThresholdsVTRKDEAD As Adp5061TypeVoltageThresholdsVtrkDead
    Get
    Set
public:
property Adp5061TypeVoltageThresholdsVtrkDead VoltageThresholdsVTRKDEAD {
    Adp5061TypeVoltageThresholdsVtrkDead get ();
    void set (Adp5061TypeVoltageThresholdsVtrkDead value);
}
member VoltageThresholdsVTRKDEAD : Adp5061TypeVoltageThresholdsVtrkDead with get, set

Property Value

Type: Adp5061TypeVoltageThresholdsVtrkDead
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.VoltageThresholdsVWEAK Property

IRD

Adp5061VoltageThresholdsVWEAK Property

Voltage Thresholds: VWEAK (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5061TypeVoltageThresholdsVweak VoltageThresholdsVWEAK { get; set; }
Public Property VoltageThresholdsVWEAK As Adp5061TypeVoltageThresholdsVweak
    Get
    Set
public:
property Adp5061TypeVoltageThresholdsVweak VoltageThresholdsVWEAK {
    Adp5061TypeVoltageThresholdsVweak get ();
    void set (Adp5061TypeVoltageThresholdsVweak value);
}
member VoltageThresholdsVWEAK : Adp5061TypeVoltageThresholdsVweak with get, set

Property Value

Type: Adp5061TypeVoltageThresholdsVweak
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061 Methods

The Adp5061 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.Flush Method

IRD

Adp5061Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adp5061 Class
telos.Ird.AnalogDevices Namespace


Adp5061.TypeBatteryShortTbatShr Enumeration

IRD

Adp5061TypeBatteryShortTbatShr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBatteryShortTbatShr
Public Enumeration TypeBatteryShortTbatShr
public enum class TypeBatteryShortTbatShr
type TypeBatteryShortTbatShr
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_2 | 1 | 2
Value_4 | 2 | 4
Value_10 | 3 | 10
Value_30 | 4 | 30
Value_60 | 5 | 60
Value_120 | 6 | 120
Value_180 | 7 | 180
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeBatteryShortVbatShr Enumeration

IRD

Adp5061TypeBatteryShortVbatShr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBatteryShortVbatShr
Public Enumeration TypeBatteryShortVbatShr
public enum class TypeBatteryShortVbatShr
type TypeBatteryShortVbatShr
Members
Member name | Value | Description
Value_2_0 | 0 | 2.0
Value_2_1 | 1 | 2.1
Value_2_2 | 2 | 2.2
Value_2_3 | 3 | 2.3
Value_2_4 | 4 | 2.4
Value_2_5 | 5 | 2.5
Value_2_6 | 6 | 2.6
Value_2_7 | 7 | 2.7
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeChargerStatus1ChargerStatus Enumeration

IRD

Adp5061TypeChargerStatus1ChargerStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus1ChargerStatus
Public Enumeration TypeChargerStatus1ChargerStatus
public enum class TypeChargerStatus1ChargerStatus
type TypeChargerStatus1ChargerStatus
Members
Member name | Value | Description
Off | 0 | Off
TrickleCharge | 1 | Trickle Charge
FastChargeCCMode | 2 | Fast Charge (CC Mode)
FastChargeCVMode | 3 | Fast Charge (CV Mode)
ChargeComplete | 4 | Charge Complete
LDOMode | 5 | LDO Mode
TrickleOrFastChargeTimerExpired | 6 | Trickle Or Fast Charge Timer Expired
BatteryDetection | 7 | Battery Detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeChargerStatus1Chdone Enumeration

IRD

Adp5061TypeChargerStatus1Chdone Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus1Chdone
Public Enumeration TypeChargerStatus1Chdone
public enum class TypeChargerStatus1Chdone
type TypeChargerStatus1Chdone
Members
Member name | Value | Description
EndOfChargeCycleNotReached | 0 | End Of Charge Cycle: Not Reached
EndOfChargeCycleReached | 1 | End Of Charge Cycle: Reached
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeChargerStatus1ThermLim Enumeration

IRD

Adp5061TypeChargerStatus1ThermLim Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus1ThermLim
Public Enumeration TypeChargerStatus1ThermLim
public enum class TypeChargerStatus1ThermLim
type TypeChargerStatus1ThermLim
Members
Member name | Value | Description
NotLimitedByTemperature | 0 | Not Limited By Temperature
LimitedByTemperature | 1 | Limited By Temperature
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeChargerStatus1VinIlim Enumeration

IRD

Adp5061TypeChargerStatus1VinIlim Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus1VinIlim
Public Enumeration TypeChargerStatus1VinIlim
public enum class TypeChargerStatus1VinIlim
type TypeChargerStatus1VinIlim
Members
Member name | Value | Description
VINxCurrentNotLimited | 0 | VINx Current: Not Limited
VINxCurrentLimited | 1 | VINx Current: Limited
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeChargerStatus1VinOk Enumeration

IRD

Adp5061TypeChargerStatus1VinOk Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus1VinOk
Public Enumeration TypeChargerStatus1VinOk
public enum class TypeChargerStatus1VinOk
type TypeChargerStatus1VinOk
Members
Member name | Value | Description
VINxVVINOK | 0 | VINx <= V_VIN_OK
VINxVVINOK__1 | 1 | VINx > V_VIN_OK
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeChargerStatus1VinOv Enumeration

IRD

Adp5061TypeChargerStatus1VinOv Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus1VinOv
Public Enumeration TypeChargerStatus1VinOv
public enum class TypeChargerStatus1VinOv
type TypeChargerStatus1VinOv
Members
Member name | Value | Description
VINxVVINOV | 0 | VINx <= V_VIN_OV
VINxVVINOV__1 | 1 | VINx > V_VIN_OV
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeChargerStatus2BatteryStatus Enumeration

IRD

Adp5061TypeChargerStatus2BatteryStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus2BatteryStatus
Public Enumeration TypeChargerStatus2BatteryStatus
public enum class TypeChargerStatus2BatteryStatus
type TypeChargerStatus2BatteryStatus
Members
Member name | Value | Description
BatteryMonitorOff | 0 | Battery Monitor Off
NoBattery | 1 | No Battery
VBATSNSVTRK | 2 | V_BAT_SNS < V_TRK
VTRKVBATSNSVWEAK | 3 | V_TRK <= V_BAT_SNS < V_WEAK
VBATSNSVWEAK | 4 | V_BAT_SNS >= V_WEAK
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeChargerStatus2RchLimInfo Enumeration

IRD

Adp5061TypeChargerStatus2RchLimInfo Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus2RchLimInfo
Public Enumeration TypeChargerStatus2RchLimInfo
public enum class TypeChargerStatus2RchLimInfo
type TypeChargerStatus2RchLimInfo
Members
Member name | Value | Description
VBATSNSVRCH | 0 | V_BAT_SNS > V_RCH
VBATSNSVRCH__1 | 1 | V_BAT_SNS < V_RCH
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeChargerStatus2ThrStatus Enumeration

IRD

Adp5061TypeChargerStatus2ThrStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus2ThrStatus
Public Enumeration TypeChargerStatus2ThrStatus
public enum class TypeChargerStatus2ThrStatus
type TypeChargerStatus2ThrStatus
Members
Member name | Value | Description
Off | 0 | Off
BatteryCold | 1 | Battery Cold
BatteryCool | 2 | Battery Cool
BatteryWarm | 3 | Battery Warm
BatteryHot | 4 | Battery Hot
ThermistorOK | 7 | Thermistor OK
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeChargingCurrentIchg Enumeration

IRD

Adp5061TypeChargingCurrentIchg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargingCurrentIchg
Public Enumeration TypeChargingCurrentIchg
public enum class TypeChargingCurrentIchg
type TypeChargingCurrentIchg
Members
Member name | Value | Description
Value_50 | 0 | 50
Value_100 | 1 | 100
Value_150 | 2 | 150
Value_200 | 3 | 200
Value_250 | 4 | 250
Value_300 | 5 | 300
Value_350 | 6 | 350
Value_400 | 7 | 400
Value_450 | 8 | 450
Value_500 | 9 | 500
Value_550 | 10 | 550
Value_600 | 11 | 600
Value_650 | 12 | 650
Value_700 | 13 | 700
Value_750 | 14 | 750
Value_800 | 15 | 800
Value_850 | 16 | 850
Value_900 | 17 | 900
Value_950 | 18 | 950
Value_1000 | 19 | 1000
Value_1050 | 20 | 1050
Value_1100 | 21 | 1100
Value_1200 | 22 | 1200
Value_1300 | 23 | 1300
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeChargingCurrentItrkDead Enumeration

IRD

Adp5061TypeChargingCurrentItrkDead Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargingCurrentItrkDead
Public Enumeration TypeChargingCurrentItrkDead
public enum class TypeChargingCurrentItrkDead
type TypeChargingCurrentItrkDead
Members
Member name | Value | Description
Value_5 | 0 | 5
Value_10 | 1 | 10
Value_20 | 2 | 20
Value_80 | 3 | 80
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeFaultBatShr Enumeration

IRD

Adp5061TypeFaultBatShr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultBatShr
Public Enumeration TypeFaultBatShr
public enum class TypeFaultBatShr
type TypeFaultBatShr
Members
Member name | Value | Description
BatteryNotShort | 0 | Battery: Not Short
BatteryShort | 1 | Battery: Short
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeFaultOverTemp Enumeration

IRD

Adp5061TypeFaultOverTemp Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultOverTemp
Public Enumeration TypeFaultOverTemp
public enum class TypeFaultOverTemp
type TypeFaultOverTemp
Members
Member name | Value | Description
NoOvertemperature | 0 | No Overtemperature
Overtemperature | 1 | Overtemperature
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeFunctionalSettings1DisIc1 Enumeration

IRD

Adp5061TypeFunctionalSettings1DisIc1 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1DisIc1
Public Enumeration TypeFunctionalSettings1DisIc1
public enum class TypeFunctionalSettings1DisIc1
type TypeFunctionalSettings1DisIc1
Members
Member name | Value | Description
NormalOperation | 0 | Normal Operation
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeFunctionalSettings1DisLdo Enumeration

IRD

Adp5061TypeFunctionalSettings1DisLdo Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1DisLdo
Public Enumeration TypeFunctionalSettings1DisLdo
public enum class TypeFunctionalSettings1DisLdo
type TypeFunctionalSettings1DisLdo
Members
Member name | Value | Description
LDOEnabled | 0 | LDO: Enabled
LDODisabled | 1 | LDO: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeFunctionalSettings1EnBmon Enumeration

IRD

Adp5061TypeFunctionalSettings1EnBmon Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1EnBmon
Public Enumeration TypeFunctionalSettings1EnBmon
public enum class TypeFunctionalSettings1EnBmon
type TypeFunctionalSettings1EnBmon
Members
Member name | Value | Description
BatteryMonitorVINVINOKDisabled | 0 | Battery Monitor (V_IN < VIN_OK): Disabled
BatteryMonitorVINVINOKEnabled | 1 | Battery Monitor (V_IN < VIN_OK): Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeFunctionalSettings1EnChg Enumeration

IRD

Adp5061TypeFunctionalSettings1EnChg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1EnChg
Public Enumeration TypeFunctionalSettings1EnChg
public enum class TypeFunctionalSettings1EnChg
type TypeFunctionalSettings1EnChg
Members
Member name | Value | Description
BatteryChargingDisabled | 0 | Battery Charging: Disabled
BatteryChargingEnabled | 1 | Battery Charging: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeFunctionalSettings1EnEoc Enumeration

IRD

Adp5061TypeFunctionalSettings1EnEoc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1EnEoc
Public Enumeration TypeFunctionalSettings1EnEoc
public enum class TypeFunctionalSettings1EnEoc
type TypeFunctionalSettings1EnEoc
Members
Member name | Value | Description
EndOfChargeNotAllowed | 0 | End Of Charge: Not Allowed
EndOfChargeAllowed | 1 | End Of Charge: Allowed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeFunctionalSettings1EnThr Enumeration

IRD

Adp5061TypeFunctionalSettings1EnThr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1EnThr
Public Enumeration TypeFunctionalSettings1EnThr
public enum class TypeFunctionalSettings1EnThr
type TypeFunctionalSettings1EnThr
Members
Member name | Value | Description
THRCurrentSourceVINVINOKDisabled | 0 | THR Current Source (V_IN < VIN_OK): Disabled
THRCurrentSourceVINVINOKEnabled | 1 | THR Current Source (V_IN < VIN_OK): Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeFunctionalSettings2EnChgVlim Enumeration

IRD

Adp5061TypeFunctionalSettings2EnChgVlim Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings2EnChgVlim
Public Enumeration TypeFunctionalSettings2EnChgVlim
public enum class TypeFunctionalSettings2EnChgVlim
type TypeFunctionalSettings2EnChgVlim
Members
Member name | Value | Description
VoltageLimitDisabled | 0 | Voltage Limit: Disabled
VoltageLimitEnabled | 1 | Voltage Limit: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeFunctionalSettings2EnJeita Enumeration

IRD

Adp5061TypeFunctionalSettings2EnJeita Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings2EnJeita
Public Enumeration TypeFunctionalSettings2EnJeita
public enum class TypeFunctionalSettings2EnJeita
type TypeFunctionalSettings2EnJeita
Members
Member name | Value | Description
JEITAComplianceDisabled | 0 | JEITA Compliance: Disabled
JEITAComplianceEnabled | 1 | JEITA Compliance: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeFunctionalSettings2IdealDiode Enumeration

IRD

Adp5061TypeFunctionalSettings2IdealDiode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings2IdealDiode
Public Enumeration TypeFunctionalSettings2IdealDiode
public enum class TypeFunctionalSettings2IdealDiode
type TypeFunctionalSettings2IdealDiode
Members
Member name | Value | Description
IdealDiodeOperatesWhenVISOSVISBB | 0 | Ideal Diode: Operates When V_ISO_S < V_ISB_B
IdealDiodeOperatesWhenVISOSVISBBAndVBATSNSVWEAK | 1 | Ideal Diode: Operates When V_ISO_S < V_ISB_B And V_BAT_SNS > V_WEAK
IdealDiodeDisabled | 2 | Ideal Diode: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeFunctionalSettings2JeitaSelect Enumeration

IRD

Adp5061TypeFunctionalSettings2JeitaSelect Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings2JeitaSelect
Public Enumeration TypeFunctionalSettings2JeitaSelect
public enum class TypeFunctionalSettings2JeitaSelect
type TypeFunctionalSettings2JeitaSelect
Members
Member name | Value | Description
JEITA1 | 0 | JEITA1
JEITA2 | 1 | JEITA2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeFunctionalSettings2Vsystem Enumeration

IRD

Adp5061TypeFunctionalSettings2Vsystem Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings2Vsystem
Public Enumeration TypeFunctionalSettings2Vsystem
public enum class TypeFunctionalSettings2Vsystem
type TypeFunctionalSettings2Vsystem
Members
Member name | Value | Description
Value_4_3 | 0 | 4.3
Value_4_4 | 1 | 4.4
Value_4_5 | 2 | 4.5
Value_4_6 | 3 | 4.6
Value_4_7 | 4 | 4.7
Value_4_8 | 5 | 4.8
Value_4_9 | 6 | 4.9
Value_5_0 | 7 | 5.0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeIendC10Eoc Enumeration

IRD

Adp5061TypeIendC10Eoc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIendC10Eoc
Public Enumeration TypeIendC10Eoc
public enum class TypeIendC10Eoc
type TypeIendC10Eoc
Members
Member name | Value | Description
ICHG10NotTerminationCurrent | 0 | ICHG / 10: Not Termination Current
ICHG10TerminationCurrent | 1 | ICHG / 10: Termination Current
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeIendC20Eoc Enumeration

IRD

Adp5061TypeIendC20Eoc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIendC20Eoc
Public Enumeration TypeIendC20Eoc
public enum class TypeIendC20Eoc
type TypeIendC20Eoc
Members
Member name | Value | Description
ICHG20NotTerminationCurrent | 0 | ICHG / 20: Not Termination Current
ICHG20TerminationCurrent | 1 | ICHG / 20: Termination Current
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeIendC5Eoc Enumeration

IRD

Adp5061TypeIendC5Eoc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIendC5Eoc
Public Enumeration TypeIendC5Eoc
public enum class TypeIendC5Eoc
type TypeIendC5Eoc
Members
Member name | Value | Description
ICHG5NotTerminationCurrent | 0 | ICHG / 5: Not Termination Current
ICHG5TerminationCurrent | 1 | ICHG / 5: Termination Current
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeIendIend Enumeration

IRD

Adp5061TypeIendIend Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIendIend
Public Enumeration TypeIendIend
public enum class TypeIendIend
type TypeIendIend
Members
Member name | Value | Description
Value_12_5 | 0 | 12.5
Value_32_5 | 1 | 32.5
Value_52_5 | 2 | 52.5
Value_72_5 | 3 | 72.5
Value_92_5 | 4 | 92.5
Value_117_5 | 5 | 117.5
Value_142_5 | 6 | 142.5
Value_170_0 | 7 | 170.0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeIendSysEnSet Enumeration

IRD

Adp5061TypeIendSysEnSet Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIendSysEnSet
Public Enumeration TypeIendSysEnSet
public enum class TypeIendSysEnSet
type TypeIendSysEnSet
Members
Member name | Value | Description
SYSENIsActivatedWhenLDOIsActiveAndTheSystemVoltageIsAvailable | 0 | SYS_EN is activated when LDO is active and the system voltage is available
SYSENActivatedByISOBxVoltageTheBatteryChargingMode | 1 | SYS_EN activated by ISO_Bx voltage, the battery charging mode.
SYSENIsActivatedAndTheIsolationFETIsDisabledWhenTheBatteryDropsBelowVWEAK | 2 | SYS_EN is activated and the isolation FET is disabled when the battery drops below V_WEAK.
SYSENIsActiveInLDOModeWhenTheChargerIsDisabledSYSENIsActiveInTheChargingModeWhenVISOBVWEAK | 3 | SYS_EN is active in LDO mode when the charger is disabled. SYS_EN is active in the charging mode when V_ISO_B >= V_WEAK.
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeInterruptActive Enumeration

IRD

Adp5061TypeInterruptActive Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptActive
Public Enumeration TypeInterruptActive
public enum class TypeInterruptActive
type TypeInterruptActive
Members
Member name | Value | Description
InterruptNotTriggered | 0 | Interrupt: Not Triggered
InterruptTriggered | 1 | Interrupt: Triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeInterruptEnable Enumeration

IRD

Adp5061TypeInterruptEnable Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnable
Public Enumeration TypeInterruptEnable
public enum class TypeInterruptEnable
type TypeInterruptEnable
Members
Member name | Value | Description
InterruptDisabled | 0 | Interrupt: Disabled
InterruptEnabled | 1 | Interrupt: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeTerminationSettingsChgVlim Enumeration

IRD

Adp5061TypeTerminationSettingsChgVlim Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTerminationSettingsChgVlim
Public Enumeration TypeTerminationSettingsChgVlim
public enum class TypeTerminationSettingsChgVlim
type TypeTerminationSettingsChgVlim
Members
Member name | Value | Description
Value_3_2 | 0 | 3.2
Value_3_4 | 1 | 3.4
Value_3_7 | 2 | 3.7
Value_3_8 | 3 | 3.8
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeTerminationSettingsVtrm Enumeration

IRD

Adp5061TypeTerminationSettingsVtrm Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTerminationSettingsVtrm
Public Enumeration TypeTerminationSettingsVtrm
public enum class TypeTerminationSettingsVtrm
type TypeTerminationSettingsVtrm
Members
Member name | Value | Description
Value_3_80 | 15 | 3.80
Value_3_82 | 16 | 3.82
Value_3_84 | 17 | 3.84
Value_3_86 | 18 | 3.86
Value_3_88 | 19 | 3.88
Value_3_90 | 20 | 3.90
Value_3_92 | 21 | 3.92
Value_3_94 | 22 | 3.94
Value_3_96 | 23 | 3.96
Value_3_98 | 24 | 3.98
Value_4_00 | 25 | 4.00
Value_4_02 | 26 | 4.02
Value_4_04 | 27 | 4.04
Value_4_06 | 28 | 4.06
Value_4_08 | 29 | 4.08
Value_4_10 | 30 | 4.10
Value_4_12 | 31 | 4.12
Value_4_14 | 32 | 4.14
Value_4_16 | 33 | 4.16
Value_4_18 | 34 | 4.18
Value_4_20 | 35 | 4.20
Value_4_22 | 36 | 4.22
Value_4_24 | 37 | 4.24
Value_4_26 | 38 | 4.26
Value_4_28 | 39 | 4.28
Value_4_30 | 40 | 4.30
Value_4_32 | 41 | 4.32
Value_4_34 | 42 | 4.34
Value_4_36 | 43 | 4.36
Value_4_38 | 44 | 4.38
Value_4_40 | 45 | 4.40
Value_4_42 | 46 | 4.42
Value_4_44 | 47 | 4.44
Value_4_44__1 | 48 | 4.44
Value_4_46 | 49 | 4.46
Value_4_48 | 50 | 4.48
Value_4_50 | 51 | 4.50
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeTimerSettingsChgTmrPeriod Enumeration

IRD

Adp5061TypeTimerSettingsChgTmrPeriod Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerSettingsChgTmrPeriod
Public Enumeration TypeTimerSettingsChgTmrPeriod
public enum class TypeTimerSettingsChgTmrPeriod
type TypeTimerSettingsChgTmrPeriod
Members
Member name | Value | Description
Trickle30SecFast300Minutes | 0 | Trickle: 30 sec, Fast: 300 minutes
Trickle60SecFast600Minutes | 1 | Trickle: 60 sec, Fast: 600 minutes
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeTimerSettingsEnChgTimer Enumeration

IRD

Adp5061TypeTimerSettingsEnChgTimer Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerSettingsEnChgTimer
Public Enumeration TypeTimerSettingsEnChgTimer
public enum class TypeTimerSettingsEnChgTimer
type TypeTimerSettingsEnChgTimer
Members
Member name | Value | Description
TrickleFastChargeTimerDisabled | 0 | Trickle/Fast Charge Timer: Disabled
TrickleFastChargeTimerEnabled | 1 | Trickle/Fast Charge Timer: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeTimerSettingsEnTend Enumeration

IRD

Adp5061TypeTimerSettingsEnTend Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerSettingsEnTend
Public Enumeration TypeTimerSettingsEnTend
public enum class TypeTimerSettingsEnTend
type TypeTimerSettingsEnTend
Members
Member name | Value | Description
ChargeCompletedTimerDisabled | 0 | Charge Completed Timer: Disabled
ChargeCompletedTimerEnabled | 1 | Charge Completed Timer: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeTimerSettingsEnWd Enumeration

IRD

Adp5061TypeTimerSettingsEnWd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerSettingsEnWd
Public Enumeration TypeTimerSettingsEnWd
public enum class TypeTimerSettingsEnWd
type TypeTimerSettingsEnWd
Members
Member name | Value | Description
WatchdogDisabled | 0 | Watchdog: Disabled
WatchdogEnabled | 1 | Watchdog: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeTimerSettingsResetWd Enumeration

IRD

Adp5061TypeTimerSettingsResetWd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerSettingsResetWd
Public Enumeration TypeTimerSettingsResetWd
public enum class TypeTimerSettingsResetWd
type TypeTimerSettingsResetWd
Members
Member name | Value | Description
WatchdogTimerNotChanged | 0 | Watchdog Timer: Not Changed
WatchdogTimerReset | 1 | Watchdog Timer: Reset
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeTimerSettingsWdPeriod Enumeration

IRD

Adp5061TypeTimerSettingsWdPeriod Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerSettingsWdPeriod
Public Enumeration TypeTimerSettingsWdPeriod
public enum class TypeTimerSettingsWdPeriod
type TypeTimerSettingsWdPeriod
Members
Member name | Value | Description
Watchdog32SecSafety40Minutes | 0 | Watchdog: 32 sec, Safety: 40 minutes
Watchdog64SecSafety40Minutes | 1 | Watchdog: 64 sec, Safety: 40 minutes
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeVoltageThresholdsDisRch Enumeration

IRD

Adp5061TypeVoltageThresholdsDisRch Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVoltageThresholdsDisRch
Public Enumeration TypeVoltageThresholdsDisRch
public enum class TypeVoltageThresholdsDisRch
type TypeVoltageThresholdsDisRch
Members
Member name | Value | Description
RechargeEnabled | 0 | Recharge Enabled
RechargeDisabled | 1 | Recharge Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeVoltageThresholdsVrch Enumeration

IRD

Adp5061TypeVoltageThresholdsVrch Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVoltageThresholdsVrch
Public Enumeration TypeVoltageThresholdsVrch
public enum class TypeVoltageThresholdsVrch
type TypeVoltageThresholdsVrch
Members
Member name | Value | Description
Value_80 | 0 | 80
Value_140 | 1 | 140
Value_200 | 2 | 200
Value_260 | 3 | 260
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeVoltageThresholdsVtrkDead Enumeration

IRD

Adp5061TypeVoltageThresholdsVtrkDead Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVoltageThresholdsVtrkDead
Public Enumeration TypeVoltageThresholdsVtrkDead
public enum class TypeVoltageThresholdsVtrkDead
type TypeVoltageThresholdsVtrkDead
Members
Member name | Value | Description
Value_2_0 | 0 | 2.0
Value_2_5 | 1 | 2.5
Value_2_6 | 2 | 2.6
Value_2_9 | 3 | 2.9
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeVoltageThresholdsVweak Enumeration

IRD

Adp5061TypeVoltageThresholdsVweak Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVoltageThresholdsVweak
Public Enumeration TypeVoltageThresholdsVweak
public enum class TypeVoltageThresholdsVweak
type TypeVoltageThresholdsVweak
Members
Member name | Value | Description
Value_2_7 | 0 | 2.7
Value_2_8 | 1 | 2.8
Value_2_9 | 2 | 2.9
Value_3_0 | 3 | 3.0
Value_3_1 | 4 | 3.1
Value_3_2 | 5 | 3.2
Value_3_3 | 6 | 3.3
Value_3_4 | 7 | 3.4
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5061.TypeVpinxPinsSettingsIlim Enumeration

IRD

Adp5061TypeVpinxPinsSettingsIlim Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVpinxPinsSettingsIlim
Public Enumeration TypeVpinxPinsSettingsIlim
public enum class TypeVpinxPinsSettingsIlim
type TypeVpinxPinsSettingsIlim
Members
Member name | Value | Description
Value_100 | 0 | 100
Value_150 | 1 | 150
Value_200 | 2 | 200
Value_250 | 3 | 250
Value_300 | 4 | 300
Value_400 | 5 | 400
Value_500 | 6 | 500
Value_600 | 7 | 600
Value_700 | 8 | 700
Value_800 | 9 | 800
Value_900 | 10 | 900
Value_1000 | 11 | 1000
Value_1200 | 12 | 1200
Value_1500 | 13 | 1500
Value_1800 | 14 | 1800
Value_2100 | 15 | 2100
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062 Class

Analog Devices: ADP 5062
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdp5062

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adp5062
Public Class Adp5062
public ref class Adp5062
type Adp5062 =  class end

The Adp5062 type exposes the following members.

Constructors
 | Name | Description
Public method | Adp5062 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryShortTBATSHR | Battery Short: TBAT_SHR (unit: sec)
Public property | BatteryShortVBATSHR | Battery Short: VBAT_SHR (unit: V)
Public property | ChargerStatus1CHARGERSTATUS | Charger Status 1: CHARGER_STATUS
Public property | ChargerStatus1CHDONE | Charger Status 1: CHDONE
Public property | ChargerStatus1THERMLIM | Charger Status 1: THERM_LIM
Public property | ChargerStatus1VINILIM | Charger Status 1: VIN_ILIM
Public property | ChargerStatus1VINOK | Charger Status 1: VIN_OK
Public property | ChargerStatus1VINOV | Charger Status 1: VIN_OV
Public property | ChargerStatus2BATTERYSTATUS | Charger Status 2: BATTERY_STATUS
Public property | ChargerStatus2RCHLIMINFO | Charger Status 2: RCH_LIM_INFO
Public property | ChargerStatus2THRSTATUS | Charger Status 2: THR_STATUS
Public property | ChargingCurrentICHG | Charging Current: ICHG (unit: mA)
Public property | ChargingCurrentITRKDEAD | Charging Current: ITRK_DEAD (unit: mA)
Public property | FaultBATSHR | Fault: BAT_SHR
Public property | FaultTSD130C | Fault: TSD 130°C
Public property | FaultTSD140C | Fault: TSD 140°C
Public property | FunctionalSettings1DISIC1 | Functional Settings 1: DIS_IC1
Public property | FunctionalSettings1DISLDO | Functional Settings 1: DIS_LDO
Public property | FunctionalSettings1ENBMON | Functional Settings 1: EN_BMON
Public property | FunctionalSettings1ENCHG | Functional Settings 1: EN_CHG
Public property | FunctionalSettings1ENEOC | Functional Settings 1: EN_EOC
Public property | FunctionalSettings1ENTHR | Functional Settings 1: EN_THR
Public property | FunctionalSettings2ENCHGVLIM | Functional Settings 2: EN_CHG_VLIM
Public property | FunctionalSettings2ENJEITA | Functional Settings 2: EN_JEITA
Public property | FunctionalSettings2IDEALDIODE | Functional Settings 2: IDEAL_DIODE
Public property | FunctionalSettings2JEITASELECT | Functional Settings 2: JEITA_SELECT
Public property | FunctionalSettings2VSYSTEM | Functional Settings 2: VSYSTEM (unit: V)
Public property | IENDC10EOC | IEND: C/10 EOC
Public property | IENDC20EOC | IEND: C/20 EOC
Public property | IENDC5EOC | IEND: C/5 EOC
Public property | IENDIEND | IEND: IEND (unit: mA)
Public property | IENDSYSENSET | IEND: SYS_EN_SET
Public property | InterruptActiveBATINT | Interrupt Active: BAT_INT
Public property | InterruptActiveCHGINT | Interrupt Active: CHG_INT
Public property | InterruptActiveTHERMLIMINT | Interrupt Active: THERM_LIM_INT
Public property | InterruptActiveTHRINT | Interrupt Active: THR_INT
Public property | InterruptActiveTSDINT | Interrupt Active: TSD_INT
Public property | InterruptActiveVININT | Interrupt Active: VIN_INT
Public property | InterruptActiveWDINT | Interrupt Active: WD_INT
Public property | InterruptEnableENBATINT | Interrupt Enable: EN_BAT_INT
Public property | InterruptEnableENCHGINT | Interrupt Enable: EN_CHG_INT
Public property | InterruptEnableENTHERMLIMINT | Interrupt Enable: EN_THERM_LIM_INT
Public property | InterruptEnableENTHRINT | Interrupt Enable: EN_THR_INT
Public property | InterruptEnableENTSDINT | Interrupt Enable: EN_TSD_INT
Public property | InterruptEnableENVININT | Interrupt Enable: EN_VIN_INT
Public property | InterruptEnableENWDINT | Interrupt Enable: EN_WD_INT
Public property | ManufacturerAndModelIDMANUF | Manufacturer and Model ID: MANUF
Public property | ManufacturerAndModelIDMODEL | Manufacturer and Model ID: MODEL
Public property | SiliconRevisionREV | Silicon Revision: REV
Public property | TerminationSettingsCHGVLIM | Termination Settings: CHG_VLIM (unit: V)
Public property | TerminationSettingsVTRM | Termination Settings: VTRM (unit: V)
Public property | TimerSettingsCHGTMRPERIOD | Timer Settings: CHG_TMR_PERIOD
Public property | TimerSettingsENCHGTIMER | Timer Settings: EN_CHG_TIMER
Public property | TimerSettingsENTEND | Timer Settings: EN_TEND
Public property | TimerSettingsENWD | Timer Settings: EN_WD
Public property | TimerSettingsRESETWD | Timer Settings: RESET_WD
Public property | TimerSettingsWDPERIOD | Timer Settings: WD_PERIOD
Public property | VINxPinSettingsILIM | VINx Pin Settings: ILIM (unit: mA)
Public property | VINxPinSettingsRFU | VINx Pin Settings: RFU
Public property | VoltageThresholdsDISRCH | Voltage Thresholds: DIS_RCH
Public property | VoltageThresholdsVRCH | Voltage Thresholds: VRCH (unit: mV)
Public property | VoltageThresholdsVTRKDEAD | Voltage Thresholds: VTRK_DEAD (unit: V)
Public property | VoltageThresholdsVWEAK | Voltage Thresholds: VWEAK (unit: V)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Linear Li-Ion Battery Charger with Power Path and USB Compatibility
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adp5062(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adp5062

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062 Properties

The Adp5062 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryShortTBATSHR | Battery Short: TBAT_SHR (unit: sec)
Public property | BatteryShortVBATSHR | Battery Short: VBAT_SHR (unit: V)
Public property | ChargerStatus1CHARGERSTATUS | Charger Status 1: CHARGER_STATUS
Public property | ChargerStatus1CHDONE | Charger Status 1: CHDONE
Public property | ChargerStatus1THERMLIM | Charger Status 1: THERM_LIM
Public property | ChargerStatus1VINILIM | Charger Status 1: VIN_ILIM
Public property | ChargerStatus1VINOK | Charger Status 1: VIN_OK
Public property | ChargerStatus1VINOV | Charger Status 1: VIN_OV
Public property | ChargerStatus2BATTERYSTATUS | Charger Status 2: BATTERY_STATUS
Public property | ChargerStatus2RCHLIMINFO | Charger Status 2: RCH_LIM_INFO
Public property | ChargerStatus2THRSTATUS | Charger Status 2: THR_STATUS
Public property | ChargingCurrentICHG | Charging Current: ICHG (unit: mA)
Public property | ChargingCurrentITRKDEAD | Charging Current: ITRK_DEAD (unit: mA)
Public property | FaultBATSHR | Fault: BAT_SHR
Public property | FaultTSD130C | Fault: TSD 130°C
Public property | FaultTSD140C | Fault: TSD 140°C
Public property | FunctionalSettings1DISIC1 | Functional Settings 1: DIS_IC1
Public property | FunctionalSettings1DISLDO | Functional Settings 1: DIS_LDO
Public property | FunctionalSettings1ENBMON | Functional Settings 1: EN_BMON
Public property | FunctionalSettings1ENCHG | Functional Settings 1: EN_CHG
Public property | FunctionalSettings1ENEOC | Functional Settings 1: EN_EOC
Public property | FunctionalSettings1ENTHR | Functional Settings 1: EN_THR
Public property | FunctionalSettings2ENCHGVLIM | Functional Settings 2: EN_CHG_VLIM
Public property | FunctionalSettings2ENJEITA | Functional Settings 2: EN_JEITA
Public property | FunctionalSettings2IDEALDIODE | Functional Settings 2: IDEAL_DIODE
Public property | FunctionalSettings2JEITASELECT | Functional Settings 2: JEITA_SELECT
Public property | FunctionalSettings2VSYSTEM | Functional Settings 2: VSYSTEM (unit: V)
Public property | IENDC10EOC | IEND: C/10 EOC
Public property | IENDC20EOC | IEND: C/20 EOC
Public property | IENDC5EOC | IEND: C/5 EOC
Public property | IENDIEND | IEND: IEND (unit: mA)
Public property | IENDSYSENSET | IEND: SYS_EN_SET
Public property | InterruptActiveBATINT | Interrupt Active: BAT_INT
Public property | InterruptActiveCHGINT | Interrupt Active: CHG_INT
Public property | InterruptActiveTHERMLIMINT | Interrupt Active: THERM_LIM_INT
Public property | InterruptActiveTHRINT | Interrupt Active: THR_INT
Public property | InterruptActiveTSDINT | Interrupt Active: TSD_INT
Public property | InterruptActiveVININT | Interrupt Active: VIN_INT
Public property | InterruptActiveWDINT | Interrupt Active: WD_INT
Public property | InterruptEnableENBATINT | Interrupt Enable: EN_BAT_INT
Public property | InterruptEnableENCHGINT | Interrupt Enable: EN_CHG_INT
Public property | InterruptEnableENTHERMLIMINT | Interrupt Enable: EN_THERM_LIM_INT
Public property | InterruptEnableENTHRINT | Interrupt Enable: EN_THR_INT
Public property | InterruptEnableENTSDINT | Interrupt Enable: EN_TSD_INT
Public property | InterruptEnableENVININT | Interrupt Enable: EN_VIN_INT
Public property | InterruptEnableENWDINT | Interrupt Enable: EN_WD_INT
Public property | ManufacturerAndModelIDMANUF | Manufacturer and Model ID: MANUF
Public property | ManufacturerAndModelIDMODEL | Manufacturer and Model ID: MODEL
Public property | SiliconRevisionREV | Silicon Revision: REV
Public property | TerminationSettingsCHGVLIM | Termination Settings: CHG_VLIM (unit: V)
Public property | TerminationSettingsVTRM | Termination Settings: VTRM (unit: V)
Public property | TimerSettingsCHGTMRPERIOD | Timer Settings: CHG_TMR_PERIOD
Public property | TimerSettingsENCHGTIMER | Timer Settings: EN_CHG_TIMER
Public property | TimerSettingsENTEND | Timer Settings: EN_TEND
Public property | TimerSettingsENWD | Timer Settings: EN_WD
Public property | TimerSettingsRESETWD | Timer Settings: RESET_WD
Public property | TimerSettingsWDPERIOD | Timer Settings: WD_PERIOD
Public property | VINxPinSettingsILIM | VINx Pin Settings: ILIM (unit: mA)
Public property | VINxPinSettingsRFU | VINx Pin Settings: RFU
Public property | VoltageThresholdsDISRCH | Voltage Thresholds: DIS_RCH
Public property | VoltageThresholdsVRCH | Voltage Thresholds: VRCH (unit: mV)
Public property | VoltageThresholdsVTRKDEAD | Voltage Thresholds: VTRK_DEAD (unit: V)
Public property | VoltageThresholdsVWEAK | Voltage Thresholds: VWEAK (unit: V)
Top
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.AutoFlush Property

IRD

Adp5062AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.BatteryShortTBATSHR Property

IRD

Adp5062BatteryShortTBATSHR Property

Battery Short: TBAT_SHR (unit: sec)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeBatteryShortTbatShr BatteryShortTBATSHR { get; set; }
Public Property BatteryShortTBATSHR As Adp5062TypeBatteryShortTbatShr
    Get
    Set
public:
property Adp5062TypeBatteryShortTbatShr BatteryShortTBATSHR {
    Adp5062TypeBatteryShortTbatShr get ();
    void set (Adp5062TypeBatteryShortTbatShr value);
}
member BatteryShortTBATSHR : Adp5062TypeBatteryShortTbatShr with get, set

Property Value

Type: Adp5062TypeBatteryShortTbatShr
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.BatteryShortVBATSHR Property

IRD

Adp5062BatteryShortVBATSHR Property

Battery Short: VBAT_SHR (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeBatteryShortVbatShr BatteryShortVBATSHR { get; set; }
Public Property BatteryShortVBATSHR As Adp5062TypeBatteryShortVbatShr
    Get
    Set
public:
property Adp5062TypeBatteryShortVbatShr BatteryShortVBATSHR {
    Adp5062TypeBatteryShortVbatShr get ();
    void set (Adp5062TypeBatteryShortVbatShr value);
}
member BatteryShortVBATSHR : Adp5062TypeBatteryShortVbatShr with get, set

Property Value

Type: Adp5062TypeBatteryShortVbatShr
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.ChargerStatus1CHARGERSTATUS Property

IRD

Adp5062ChargerStatus1CHARGERSTATUS Property

Charger Status 1: CHARGER_STATUS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeChargerStatus1ChargerStatus ChargerStatus1CHARGERSTATUS { get; }
Public ReadOnly Property ChargerStatus1CHARGERSTATUS As Adp5062TypeChargerStatus1ChargerStatus
    Get
public:
property Adp5062TypeChargerStatus1ChargerStatus ChargerStatus1CHARGERSTATUS {
    Adp5062TypeChargerStatus1ChargerStatus get ();
}
member ChargerStatus1CHARGERSTATUS : Adp5062TypeChargerStatus1ChargerStatus with get

Property Value

Type: Adp5062TypeChargerStatus1ChargerStatus
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.ChargerStatus1CHDONE Property

IRD

Adp5062ChargerStatus1CHDONE Property

Charger Status 1: CHDONE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeChargerStatus1Chdone ChargerStatus1CHDONE { get; }
Public ReadOnly Property ChargerStatus1CHDONE As Adp5062TypeChargerStatus1Chdone
    Get
public:
property Adp5062TypeChargerStatus1Chdone ChargerStatus1CHDONE {
    Adp5062TypeChargerStatus1Chdone get ();
}
member ChargerStatus1CHDONE : Adp5062TypeChargerStatus1Chdone with get

Property Value

Type: Adp5062TypeChargerStatus1Chdone
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.ChargerStatus1THERMLIM Property

IRD

Adp5062ChargerStatus1THERMLIM Property

Charger Status 1: THERM_LIM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeChargerStatus1ThermLim ChargerStatus1THERMLIM { get; }
Public ReadOnly Property ChargerStatus1THERMLIM As Adp5062TypeChargerStatus1ThermLim
    Get
public:
property Adp5062TypeChargerStatus1ThermLim ChargerStatus1THERMLIM {
    Adp5062TypeChargerStatus1ThermLim get ();
}
member ChargerStatus1THERMLIM : Adp5062TypeChargerStatus1ThermLim with get

Property Value

Type: Adp5062TypeChargerStatus1ThermLim
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.ChargerStatus1VINILIM Property

IRD

Adp5062ChargerStatus1VINILIM Property

Charger Status 1: VIN_ILIM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeChargerStatus1VinIlim ChargerStatus1VINILIM { get; }
Public ReadOnly Property ChargerStatus1VINILIM As Adp5062TypeChargerStatus1VinIlim
    Get
public:
property Adp5062TypeChargerStatus1VinIlim ChargerStatus1VINILIM {
    Adp5062TypeChargerStatus1VinIlim get ();
}
member ChargerStatus1VINILIM : Adp5062TypeChargerStatus1VinIlim with get

Property Value

Type: Adp5062TypeChargerStatus1VinIlim
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.ChargerStatus1VINOK Property

IRD

Adp5062ChargerStatus1VINOK Property

Charger Status 1: VIN_OK

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeChargerStatus1VinOk ChargerStatus1VINOK { get; }
Public ReadOnly Property ChargerStatus1VINOK As Adp5062TypeChargerStatus1VinOk
    Get
public:
property Adp5062TypeChargerStatus1VinOk ChargerStatus1VINOK {
    Adp5062TypeChargerStatus1VinOk get ();
}
member ChargerStatus1VINOK : Adp5062TypeChargerStatus1VinOk with get

Property Value

Type: Adp5062TypeChargerStatus1VinOk
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.ChargerStatus1VINOV Property

IRD

Adp5062ChargerStatus1VINOV Property

Charger Status 1: VIN_OV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeChargerStatus1VinOv ChargerStatus1VINOV { get; }
Public ReadOnly Property ChargerStatus1VINOV As Adp5062TypeChargerStatus1VinOv
    Get
public:
property Adp5062TypeChargerStatus1VinOv ChargerStatus1VINOV {
    Adp5062TypeChargerStatus1VinOv get ();
}
member ChargerStatus1VINOV : Adp5062TypeChargerStatus1VinOv with get

Property Value

Type: Adp5062TypeChargerStatus1VinOv
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.ChargerStatus2BATTERYSTATUS Property

IRD

Adp5062ChargerStatus2BATTERYSTATUS Property

Charger Status 2: BATTERY_STATUS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeChargerStatus2BatteryStatus ChargerStatus2BATTERYSTATUS { get; }
Public ReadOnly Property ChargerStatus2BATTERYSTATUS As Adp5062TypeChargerStatus2BatteryStatus
    Get
public:
property Adp5062TypeChargerStatus2BatteryStatus ChargerStatus2BATTERYSTATUS {
    Adp5062TypeChargerStatus2BatteryStatus get ();
}
member ChargerStatus2BATTERYSTATUS : Adp5062TypeChargerStatus2BatteryStatus with get

Property Value

Type: Adp5062TypeChargerStatus2BatteryStatus
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.ChargerStatus2RCHLIMINFO Property

IRD

Adp5062ChargerStatus2RCHLIMINFO Property

Charger Status 2: RCH_LIM_INFO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeChargerStatus2RchLimInfo ChargerStatus2RCHLIMINFO { get; }
Public ReadOnly Property ChargerStatus2RCHLIMINFO As Adp5062TypeChargerStatus2RchLimInfo
    Get
public:
property Adp5062TypeChargerStatus2RchLimInfo ChargerStatus2RCHLIMINFO {
    Adp5062TypeChargerStatus2RchLimInfo get ();
}
member ChargerStatus2RCHLIMINFO : Adp5062TypeChargerStatus2RchLimInfo with get

Property Value

Type: Adp5062TypeChargerStatus2RchLimInfo
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.ChargerStatus2THRSTATUS Property

IRD

Adp5062ChargerStatus2THRSTATUS Property

Charger Status 2: THR_STATUS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeChargerStatus2ThrStatus ChargerStatus2THRSTATUS { get; }
Public ReadOnly Property ChargerStatus2THRSTATUS As Adp5062TypeChargerStatus2ThrStatus
    Get
public:
property Adp5062TypeChargerStatus2ThrStatus ChargerStatus2THRSTATUS {
    Adp5062TypeChargerStatus2ThrStatus get ();
}
member ChargerStatus2THRSTATUS : Adp5062TypeChargerStatus2ThrStatus with get

Property Value

Type: Adp5062TypeChargerStatus2ThrStatus
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.ChargingCurrentICHG Property

IRD

Adp5062ChargingCurrentICHG Property

Charging Current: ICHG (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeChargingCurrentIchg ChargingCurrentICHG { get; set; }
Public Property ChargingCurrentICHG As Adp5062TypeChargingCurrentIchg
    Get
    Set
public:
property Adp5062TypeChargingCurrentIchg ChargingCurrentICHG {
    Adp5062TypeChargingCurrentIchg get ();
    void set (Adp5062TypeChargingCurrentIchg value);
}
member ChargingCurrentICHG : Adp5062TypeChargingCurrentIchg with get, set

Property Value

Type: Adp5062TypeChargingCurrentIchg
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.ChargingCurrentITRKDEAD Property

IRD

Adp5062ChargingCurrentITRKDEAD Property

Charging Current: ITRK_DEAD (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeChargingCurrentItrkDead ChargingCurrentITRKDEAD { get; set; }
Public Property ChargingCurrentITRKDEAD As Adp5062TypeChargingCurrentItrkDead
    Get
    Set
public:
property Adp5062TypeChargingCurrentItrkDead ChargingCurrentITRKDEAD {
    Adp5062TypeChargingCurrentItrkDead get ();
    void set (Adp5062TypeChargingCurrentItrkDead value);
}
member ChargingCurrentITRKDEAD : Adp5062TypeChargingCurrentItrkDead with get, set

Property Value

Type: Adp5062TypeChargingCurrentItrkDead
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.FaultBATSHR Property

IRD

Adp5062FaultBATSHR Property

Fault: BAT_SHR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeFaultBatShr FaultBATSHR { get; set; }
Public Property FaultBATSHR As Adp5062TypeFaultBatShr
    Get
    Set
public:
property Adp5062TypeFaultBatShr FaultBATSHR {
    Adp5062TypeFaultBatShr get ();
    void set (Adp5062TypeFaultBatShr value);
}
member FaultBATSHR : Adp5062TypeFaultBatShr with get, set

Property Value

Type: Adp5062TypeFaultBatShr
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.FaultTSD130C Property

IRD

Adp5062FaultTSD130C Property

Fault: TSD 130°C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeFaultOverTemp FaultTSD130C { get; set; }
Public Property FaultTSD130C As Adp5062TypeFaultOverTemp
    Get
    Set
public:
property Adp5062TypeFaultOverTemp FaultTSD130C {
    Adp5062TypeFaultOverTemp get ();
    void set (Adp5062TypeFaultOverTemp value);
}
member FaultTSD130C : Adp5062TypeFaultOverTemp with get, set

Property Value

Type: Adp5062TypeFaultOverTemp
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.FaultTSD140C Property

IRD

Adp5062FaultTSD140C Property

Fault: TSD 140°C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeFaultOverTemp FaultTSD140C { get; set; }
Public Property FaultTSD140C As Adp5062TypeFaultOverTemp
    Get
    Set
public:
property Adp5062TypeFaultOverTemp FaultTSD140C {
    Adp5062TypeFaultOverTemp get ();
    void set (Adp5062TypeFaultOverTemp value);
}
member FaultTSD140C : Adp5062TypeFaultOverTemp with get, set

Property Value

Type: Adp5062TypeFaultOverTemp
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.FunctionalSettings1DISIC1 Property

IRD

Adp5062FunctionalSettings1DISIC1 Property

Functional Settings 1: DIS_IC1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeFunctionalSettings1DisIc1 FunctionalSettings1DISIC1 { get; set; }
Public Property FunctionalSettings1DISIC1 As Adp5062TypeFunctionalSettings1DisIc1
    Get
    Set
public:
property Adp5062TypeFunctionalSettings1DisIc1 FunctionalSettings1DISIC1 {
    Adp5062TypeFunctionalSettings1DisIc1 get ();
    void set (Adp5062TypeFunctionalSettings1DisIc1 value);
}
member FunctionalSettings1DISIC1 : Adp5062TypeFunctionalSettings1DisIc1 with get, set

Property Value

Type: Adp5062TypeFunctionalSettings1DisIc1
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.FunctionalSettings1DISLDO Property

IRD

Adp5062FunctionalSettings1DISLDO Property

Functional Settings 1: DIS_LDO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeFunctionalSettings1DisLdo FunctionalSettings1DISLDO { get; set; }
Public Property FunctionalSettings1DISLDO As Adp5062TypeFunctionalSettings1DisLdo
    Get
    Set
public:
property Adp5062TypeFunctionalSettings1DisLdo FunctionalSettings1DISLDO {
    Adp5062TypeFunctionalSettings1DisLdo get ();
    void set (Adp5062TypeFunctionalSettings1DisLdo value);
}
member FunctionalSettings1DISLDO : Adp5062TypeFunctionalSettings1DisLdo with get, set

Property Value

Type: Adp5062TypeFunctionalSettings1DisLdo
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.FunctionalSettings1ENBMON Property

IRD

Adp5062FunctionalSettings1ENBMON Property

Functional Settings 1: EN_BMON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeFunctionalSettings1EnBmon FunctionalSettings1ENBMON { get; set; }
Public Property FunctionalSettings1ENBMON As Adp5062TypeFunctionalSettings1EnBmon
    Get
    Set
public:
property Adp5062TypeFunctionalSettings1EnBmon FunctionalSettings1ENBMON {
    Adp5062TypeFunctionalSettings1EnBmon get ();
    void set (Adp5062TypeFunctionalSettings1EnBmon value);
}
member FunctionalSettings1ENBMON : Adp5062TypeFunctionalSettings1EnBmon with get, set

Property Value

Type: Adp5062TypeFunctionalSettings1EnBmon
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.FunctionalSettings1ENCHG Property

IRD

Adp5062FunctionalSettings1ENCHG Property

Functional Settings 1: EN_CHG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeFunctionalSettings1EnChg FunctionalSettings1ENCHG { get; set; }
Public Property FunctionalSettings1ENCHG As Adp5062TypeFunctionalSettings1EnChg
    Get
    Set
public:
property Adp5062TypeFunctionalSettings1EnChg FunctionalSettings1ENCHG {
    Adp5062TypeFunctionalSettings1EnChg get ();
    void set (Adp5062TypeFunctionalSettings1EnChg value);
}
member FunctionalSettings1ENCHG : Adp5062TypeFunctionalSettings1EnChg with get, set

Property Value

Type: Adp5062TypeFunctionalSettings1EnChg
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.FunctionalSettings1ENEOC Property

IRD

Adp5062FunctionalSettings1ENEOC Property

Functional Settings 1: EN_EOC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeFunctionalSettings1EnEoc FunctionalSettings1ENEOC { get; set; }
Public Property FunctionalSettings1ENEOC As Adp5062TypeFunctionalSettings1EnEoc
    Get
    Set
public:
property Adp5062TypeFunctionalSettings1EnEoc FunctionalSettings1ENEOC {
    Adp5062TypeFunctionalSettings1EnEoc get ();
    void set (Adp5062TypeFunctionalSettings1EnEoc value);
}
member FunctionalSettings1ENEOC : Adp5062TypeFunctionalSettings1EnEoc with get, set

Property Value

Type: Adp5062TypeFunctionalSettings1EnEoc
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.FunctionalSettings1ENTHR Property

IRD

Adp5062FunctionalSettings1ENTHR Property

Functional Settings 1: EN_THR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeFunctionalSettings1EnThr FunctionalSettings1ENTHR { get; set; }
Public Property FunctionalSettings1ENTHR As Adp5062TypeFunctionalSettings1EnThr
    Get
    Set
public:
property Adp5062TypeFunctionalSettings1EnThr FunctionalSettings1ENTHR {
    Adp5062TypeFunctionalSettings1EnThr get ();
    void set (Adp5062TypeFunctionalSettings1EnThr value);
}
member FunctionalSettings1ENTHR : Adp5062TypeFunctionalSettings1EnThr with get, set

Property Value

Type: Adp5062TypeFunctionalSettings1EnThr
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.FunctionalSettings2ENCHGVLIM Property

IRD

Adp5062FunctionalSettings2ENCHGVLIM Property

Functional Settings 2: EN_CHG_VLIM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeFunctionalSettings2EnChgVlim FunctionalSettings2ENCHGVLIM { get; set; }
Public Property FunctionalSettings2ENCHGVLIM As Adp5062TypeFunctionalSettings2EnChgVlim
    Get
    Set
public:
property Adp5062TypeFunctionalSettings2EnChgVlim FunctionalSettings2ENCHGVLIM {
    Adp5062TypeFunctionalSettings2EnChgVlim get ();
    void set (Adp5062TypeFunctionalSettings2EnChgVlim value);
}
member FunctionalSettings2ENCHGVLIM : Adp5062TypeFunctionalSettings2EnChgVlim with get, set

Property Value

Type: Adp5062TypeFunctionalSettings2EnChgVlim
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.FunctionalSettings2ENJEITA Property

IRD

Adp5062FunctionalSettings2ENJEITA Property

Functional Settings 2: EN_JEITA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeFunctionalSettings2EnJeita FunctionalSettings2ENJEITA { get; set; }
Public Property FunctionalSettings2ENJEITA As Adp5062TypeFunctionalSettings2EnJeita
    Get
    Set
public:
property Adp5062TypeFunctionalSettings2EnJeita FunctionalSettings2ENJEITA {
    Adp5062TypeFunctionalSettings2EnJeita get ();
    void set (Adp5062TypeFunctionalSettings2EnJeita value);
}
member FunctionalSettings2ENJEITA : Adp5062TypeFunctionalSettings2EnJeita with get, set

Property Value

Type: Adp5062TypeFunctionalSettings2EnJeita
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.FunctionalSettings2IDEALDIODE Property

IRD

Adp5062FunctionalSettings2IDEALDIODE Property

Functional Settings 2: IDEAL_DIODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeFunctionalSettings2IdealDiode FunctionalSettings2IDEALDIODE { get; set; }
Public Property FunctionalSettings2IDEALDIODE As Adp5062TypeFunctionalSettings2IdealDiode
    Get
    Set
public:
property Adp5062TypeFunctionalSettings2IdealDiode FunctionalSettings2IDEALDIODE {
    Adp5062TypeFunctionalSettings2IdealDiode get ();
    void set (Adp5062TypeFunctionalSettings2IdealDiode value);
}
member FunctionalSettings2IDEALDIODE : Adp5062TypeFunctionalSettings2IdealDiode with get, set

Property Value

Type: Adp5062TypeFunctionalSettings2IdealDiode
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.FunctionalSettings2JEITASELECT Property

IRD

Adp5062FunctionalSettings2JEITASELECT Property

Functional Settings 2: JEITA_SELECT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeFunctionalSettings2JeitaSelect FunctionalSettings2JEITASELECT { get; set; }
Public Property FunctionalSettings2JEITASELECT As Adp5062TypeFunctionalSettings2JeitaSelect
    Get
    Set
public:
property Adp5062TypeFunctionalSettings2JeitaSelect FunctionalSettings2JEITASELECT {
    Adp5062TypeFunctionalSettings2JeitaSelect get ();
    void set (Adp5062TypeFunctionalSettings2JeitaSelect value);
}
member FunctionalSettings2JEITASELECT : Adp5062TypeFunctionalSettings2JeitaSelect with get, set

Property Value

Type: Adp5062TypeFunctionalSettings2JeitaSelect
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.FunctionalSettings2VSYSTEM Property

IRD

Adp5062FunctionalSettings2VSYSTEM Property

Functional Settings 2: VSYSTEM (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeFunctionalSettings2Vsystem FunctionalSettings2VSYSTEM { get; set; }
Public Property FunctionalSettings2VSYSTEM As Adp5062TypeFunctionalSettings2Vsystem
    Get
    Set
public:
property Adp5062TypeFunctionalSettings2Vsystem FunctionalSettings2VSYSTEM {
    Adp5062TypeFunctionalSettings2Vsystem get ();
    void set (Adp5062TypeFunctionalSettings2Vsystem value);
}
member FunctionalSettings2VSYSTEM : Adp5062TypeFunctionalSettings2Vsystem with get, set

Property Value

Type: Adp5062TypeFunctionalSettings2Vsystem
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.IENDC10EOC Property

IRD

Adp5062IENDC10EOC Property

IEND: C/10 EOC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeIendC10Eoc IENDC10EOC { get; set; }
Public Property IENDC10EOC As Adp5062TypeIendC10Eoc
    Get
    Set
public:
property Adp5062TypeIendC10Eoc IENDC10EOC {
    Adp5062TypeIendC10Eoc get ();
    void set (Adp5062TypeIendC10Eoc value);
}
member IENDC10EOC : Adp5062TypeIendC10Eoc with get, set

Property Value

Type: Adp5062TypeIendC10Eoc
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.IENDC20EOC Property

IRD

Adp5062IENDC20EOC Property

IEND: C/20 EOC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeIendC20Eoc IENDC20EOC { get; set; }
Public Property IENDC20EOC As Adp5062TypeIendC20Eoc
    Get
    Set
public:
property Adp5062TypeIendC20Eoc IENDC20EOC {
    Adp5062TypeIendC20Eoc get ();
    void set (Adp5062TypeIendC20Eoc value);
}
member IENDC20EOC : Adp5062TypeIendC20Eoc with get, set

Property Value

Type: Adp5062TypeIendC20Eoc
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.IENDC5EOC Property

IRD

Adp5062IENDC5EOC Property

IEND: C/5 EOC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeIendC5Eoc IENDC5EOC { get; set; }
Public Property IENDC5EOC As Adp5062TypeIendC5Eoc
    Get
    Set
public:
property Adp5062TypeIendC5Eoc IENDC5EOC {
    Adp5062TypeIendC5Eoc get ();
    void set (Adp5062TypeIendC5Eoc value);
}
member IENDC5EOC : Adp5062TypeIendC5Eoc with get, set

Property Value

Type: Adp5062TypeIendC5Eoc
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.IENDIEND Property

IRD

Adp5062IENDIEND Property

IEND: IEND (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeIendIend IENDIEND { get; set; }
Public Property IENDIEND As Adp5062TypeIendIend
    Get
    Set
public:
property Adp5062TypeIendIend IENDIEND {
    Adp5062TypeIendIend get ();
    void set (Adp5062TypeIendIend value);
}
member IENDIEND : Adp5062TypeIendIend with get, set

Property Value

Type: Adp5062TypeIendIend
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.IENDSYSENSET Property

IRD

Adp5062IENDSYSENSET Property

IEND: SYS_EN_SET

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeIendSysEnSet IENDSYSENSET { get; set; }
Public Property IENDSYSENSET As Adp5062TypeIendSysEnSet
    Get
    Set
public:
property Adp5062TypeIendSysEnSet IENDSYSENSET {
    Adp5062TypeIendSysEnSet get ();
    void set (Adp5062TypeIendSysEnSet value);
}
member IENDSYSENSET : Adp5062TypeIendSysEnSet with get, set

Property Value

Type: Adp5062TypeIendSysEnSet
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.InterruptActiveBATINT Property

IRD

Adp5062InterruptActiveBATINT Property

Interrupt Active: BAT_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeInterruptActive InterruptActiveBATINT { get; }
Public ReadOnly Property InterruptActiveBATINT As Adp5062TypeInterruptActive
    Get
public:
property Adp5062TypeInterruptActive InterruptActiveBATINT {
    Adp5062TypeInterruptActive get ();
}
member InterruptActiveBATINT : Adp5062TypeInterruptActive with get

Property Value

Type: Adp5062TypeInterruptActive
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.InterruptActiveCHGINT Property

IRD

Adp5062InterruptActiveCHGINT Property

Interrupt Active: CHG_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeInterruptActive InterruptActiveCHGINT { get; }
Public ReadOnly Property InterruptActiveCHGINT As Adp5062TypeInterruptActive
    Get
public:
property Adp5062TypeInterruptActive InterruptActiveCHGINT {
    Adp5062TypeInterruptActive get ();
}
member InterruptActiveCHGINT : Adp5062TypeInterruptActive with get

Property Value

Type: Adp5062TypeInterruptActive
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.InterruptActiveTHERMLIMINT Property

IRD

Adp5062InterruptActiveTHERMLIMINT Property

Interrupt Active: THERM_LIM_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeInterruptActive InterruptActiveTHERMLIMINT { get; }
Public ReadOnly Property InterruptActiveTHERMLIMINT As Adp5062TypeInterruptActive
    Get
public:
property Adp5062TypeInterruptActive InterruptActiveTHERMLIMINT {
    Adp5062TypeInterruptActive get ();
}
member InterruptActiveTHERMLIMINT : Adp5062TypeInterruptActive with get

Property Value

Type: Adp5062TypeInterruptActive
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.InterruptActiveTHRINT Property

IRD

Adp5062InterruptActiveTHRINT Property

Interrupt Active: THR_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeInterruptActive InterruptActiveTHRINT { get; }
Public ReadOnly Property InterruptActiveTHRINT As Adp5062TypeInterruptActive
    Get
public:
property Adp5062TypeInterruptActive InterruptActiveTHRINT {
    Adp5062TypeInterruptActive get ();
}
member InterruptActiveTHRINT : Adp5062TypeInterruptActive with get

Property Value

Type: Adp5062TypeInterruptActive
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.InterruptActiveTSDINT Property

IRD

Adp5062InterruptActiveTSDINT Property

Interrupt Active: TSD_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeInterruptActive InterruptActiveTSDINT { get; }
Public ReadOnly Property InterruptActiveTSDINT As Adp5062TypeInterruptActive
    Get
public:
property Adp5062TypeInterruptActive InterruptActiveTSDINT {
    Adp5062TypeInterruptActive get ();
}
member InterruptActiveTSDINT : Adp5062TypeInterruptActive with get

Property Value

Type: Adp5062TypeInterruptActive
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.InterruptActiveVININT Property

IRD

Adp5062InterruptActiveVININT Property

Interrupt Active: VIN_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeInterruptActive InterruptActiveVININT { get; }
Public ReadOnly Property InterruptActiveVININT As Adp5062TypeInterruptActive
    Get
public:
property Adp5062TypeInterruptActive InterruptActiveVININT {
    Adp5062TypeInterruptActive get ();
}
member InterruptActiveVININT : Adp5062TypeInterruptActive with get

Property Value

Type: Adp5062TypeInterruptActive
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.InterruptActiveWDINT Property

IRD

Adp5062InterruptActiveWDINT Property

Interrupt Active: WD_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeInterruptActive InterruptActiveWDINT { get; }
Public ReadOnly Property InterruptActiveWDINT As Adp5062TypeInterruptActive
    Get
public:
property Adp5062TypeInterruptActive InterruptActiveWDINT {
    Adp5062TypeInterruptActive get ();
}
member InterruptActiveWDINT : Adp5062TypeInterruptActive with get

Property Value

Type: Adp5062TypeInterruptActive
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.InterruptEnableENBATINT Property

IRD

Adp5062InterruptEnableENBATINT Property

Interrupt Enable: EN_BAT_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeInterruptEnable InterruptEnableENBATINT { get; set; }
Public Property InterruptEnableENBATINT As Adp5062TypeInterruptEnable
    Get
    Set
public:
property Adp5062TypeInterruptEnable InterruptEnableENBATINT {
    Adp5062TypeInterruptEnable get ();
    void set (Adp5062TypeInterruptEnable value);
}
member InterruptEnableENBATINT : Adp5062TypeInterruptEnable with get, set

Property Value

Type: Adp5062TypeInterruptEnable
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.InterruptEnableENCHGINT Property

IRD

Adp5062InterruptEnableENCHGINT Property

Interrupt Enable: EN_CHG_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeInterruptEnable InterruptEnableENCHGINT { get; set; }
Public Property InterruptEnableENCHGINT As Adp5062TypeInterruptEnable
    Get
    Set
public:
property Adp5062TypeInterruptEnable InterruptEnableENCHGINT {
    Adp5062TypeInterruptEnable get ();
    void set (Adp5062TypeInterruptEnable value);
}
member InterruptEnableENCHGINT : Adp5062TypeInterruptEnable with get, set

Property Value

Type: Adp5062TypeInterruptEnable
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.InterruptEnableENTHERMLIMINT Property

IRD

Adp5062InterruptEnableENTHERMLIMINT Property

Interrupt Enable: EN_THERM_LIM_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeInterruptEnable InterruptEnableENTHERMLIMINT { get; set; }
Public Property InterruptEnableENTHERMLIMINT As Adp5062TypeInterruptEnable
    Get
    Set
public:
property Adp5062TypeInterruptEnable InterruptEnableENTHERMLIMINT {
    Adp5062TypeInterruptEnable get ();
    void set (Adp5062TypeInterruptEnable value);
}
member InterruptEnableENTHERMLIMINT : Adp5062TypeInterruptEnable with get, set

Property Value

Type: Adp5062TypeInterruptEnable
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.InterruptEnableENTHRINT Property

IRD

Adp5062InterruptEnableENTHRINT Property

Interrupt Enable: EN_THR_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeInterruptEnable InterruptEnableENTHRINT { get; set; }
Public Property InterruptEnableENTHRINT As Adp5062TypeInterruptEnable
    Get
    Set
public:
property Adp5062TypeInterruptEnable InterruptEnableENTHRINT {
    Adp5062TypeInterruptEnable get ();
    void set (Adp5062TypeInterruptEnable value);
}
member InterruptEnableENTHRINT : Adp5062TypeInterruptEnable with get, set

Property Value

Type: Adp5062TypeInterruptEnable
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.InterruptEnableENTSDINT Property

IRD

Adp5062InterruptEnableENTSDINT Property

Interrupt Enable: EN_TSD_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeInterruptEnable InterruptEnableENTSDINT { get; set; }
Public Property InterruptEnableENTSDINT As Adp5062TypeInterruptEnable
    Get
    Set
public:
property Adp5062TypeInterruptEnable InterruptEnableENTSDINT {
    Adp5062TypeInterruptEnable get ();
    void set (Adp5062TypeInterruptEnable value);
}
member InterruptEnableENTSDINT : Adp5062TypeInterruptEnable with get, set

Property Value

Type: Adp5062TypeInterruptEnable
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.InterruptEnableENVININT Property

IRD

Adp5062InterruptEnableENVININT Property

Interrupt Enable: EN_VIN_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeInterruptEnable InterruptEnableENVININT { get; set; }
Public Property InterruptEnableENVININT As Adp5062TypeInterruptEnable
    Get
    Set
public:
property Adp5062TypeInterruptEnable InterruptEnableENVININT {
    Adp5062TypeInterruptEnable get ();
    void set (Adp5062TypeInterruptEnable value);
}
member InterruptEnableENVININT : Adp5062TypeInterruptEnable with get, set

Property Value

Type: Adp5062TypeInterruptEnable
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.InterruptEnableENWDINT Property

IRD

Adp5062InterruptEnableENWDINT Property

Interrupt Enable: EN_WD_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeInterruptEnable InterruptEnableENWDINT { get; set; }
Public Property InterruptEnableENWDINT As Adp5062TypeInterruptEnable
    Get
    Set
public:
property Adp5062TypeInterruptEnable InterruptEnableENWDINT {
    Adp5062TypeInterruptEnable get ();
    void set (Adp5062TypeInterruptEnable value);
}
member InterruptEnableENWDINT : Adp5062TypeInterruptEnable with get, set

Property Value

Type: Adp5062TypeInterruptEnable
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.ManufacturerAndModelIDMANUF Property

IRD

Adp5062ManufacturerAndModelIDMANUF Property

Manufacturer and Model ID: MANUF

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerAndModelIDMANUF { get; }
Public ReadOnly Property ManufacturerAndModelIDMANUF As Byte
    Get
public:
property unsigned char ManufacturerAndModelIDMANUF {
    unsigned char get ();
}
member ManufacturerAndModelIDMANUF : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.ManufacturerAndModelIDMODEL Property

IRD

Adp5062ManufacturerAndModelIDMODEL Property

Manufacturer and Model ID: MODEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerAndModelIDMODEL { get; }
Public ReadOnly Property ManufacturerAndModelIDMODEL As Byte
    Get
public:
property unsigned char ManufacturerAndModelIDMODEL {
    unsigned char get ();
}
member ManufacturerAndModelIDMODEL : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.SiliconRevisionREV Property

IRD

Adp5062SiliconRevisionREV Property

Silicon Revision: REV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SiliconRevisionREV { get; }
Public ReadOnly Property SiliconRevisionREV As Byte
    Get
public:
property unsigned char SiliconRevisionREV {
    unsigned char get ();
}
member SiliconRevisionREV : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.TerminationSettingsCHGVLIM Property

IRD

Adp5062TerminationSettingsCHGVLIM Property

Termination Settings: CHG_VLIM (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeTerminationSettingsChgVlim TerminationSettingsCHGVLIM { get; set; }
Public Property TerminationSettingsCHGVLIM As Adp5062TypeTerminationSettingsChgVlim
    Get
    Set
public:
property Adp5062TypeTerminationSettingsChgVlim TerminationSettingsCHGVLIM {
    Adp5062TypeTerminationSettingsChgVlim get ();
    void set (Adp5062TypeTerminationSettingsChgVlim value);
}
member TerminationSettingsCHGVLIM : Adp5062TypeTerminationSettingsChgVlim with get, set

Property Value

Type: Adp5062TypeTerminationSettingsChgVlim
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.TerminationSettingsVTRM Property

IRD

Adp5062TerminationSettingsVTRM Property

Termination Settings: VTRM (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeTerminationSettingsVtrm TerminationSettingsVTRM { get; set; }
Public Property TerminationSettingsVTRM As Adp5062TypeTerminationSettingsVtrm
    Get
    Set
public:
property Adp5062TypeTerminationSettingsVtrm TerminationSettingsVTRM {
    Adp5062TypeTerminationSettingsVtrm get ();
    void set (Adp5062TypeTerminationSettingsVtrm value);
}
member TerminationSettingsVTRM : Adp5062TypeTerminationSettingsVtrm with get, set

Property Value

Type: Adp5062TypeTerminationSettingsVtrm
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.TimerSettingsCHGTMRPERIOD Property

IRD

Adp5062TimerSettingsCHGTMRPERIOD Property

Timer Settings: CHG_TMR_PERIOD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeTimerSettingsChgTmrPeriod TimerSettingsCHGTMRPERIOD { get; set; }
Public Property TimerSettingsCHGTMRPERIOD As Adp5062TypeTimerSettingsChgTmrPeriod
    Get
    Set
public:
property Adp5062TypeTimerSettingsChgTmrPeriod TimerSettingsCHGTMRPERIOD {
    Adp5062TypeTimerSettingsChgTmrPeriod get ();
    void set (Adp5062TypeTimerSettingsChgTmrPeriod value);
}
member TimerSettingsCHGTMRPERIOD : Adp5062TypeTimerSettingsChgTmrPeriod with get, set

Property Value

Type: Adp5062TypeTimerSettingsChgTmrPeriod
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.TimerSettingsENCHGTIMER Property

IRD

Adp5062TimerSettingsENCHGTIMER Property

Timer Settings: EN_CHG_TIMER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeTimerSettingsEnChgTimer TimerSettingsENCHGTIMER { get; set; }
Public Property TimerSettingsENCHGTIMER As Adp5062TypeTimerSettingsEnChgTimer
    Get
    Set
public:
property Adp5062TypeTimerSettingsEnChgTimer TimerSettingsENCHGTIMER {
    Adp5062TypeTimerSettingsEnChgTimer get ();
    void set (Adp5062TypeTimerSettingsEnChgTimer value);
}
member TimerSettingsENCHGTIMER : Adp5062TypeTimerSettingsEnChgTimer with get, set

Property Value

Type: Adp5062TypeTimerSettingsEnChgTimer
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.TimerSettingsENTEND Property

IRD

Adp5062TimerSettingsENTEND Property

Timer Settings: EN_TEND

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeTimerSettingsEnTend TimerSettingsENTEND { get; set; }
Public Property TimerSettingsENTEND As Adp5062TypeTimerSettingsEnTend
    Get
    Set
public:
property Adp5062TypeTimerSettingsEnTend TimerSettingsENTEND {
    Adp5062TypeTimerSettingsEnTend get ();
    void set (Adp5062TypeTimerSettingsEnTend value);
}
member TimerSettingsENTEND : Adp5062TypeTimerSettingsEnTend with get, set

Property Value

Type: Adp5062TypeTimerSettingsEnTend
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.TimerSettingsENWD Property

IRD

Adp5062TimerSettingsENWD Property

Timer Settings: EN_WD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeTimerSettingsEnWd TimerSettingsENWD { get; set; }
Public Property TimerSettingsENWD As Adp5062TypeTimerSettingsEnWd
    Get
    Set
public:
property Adp5062TypeTimerSettingsEnWd TimerSettingsENWD {
    Adp5062TypeTimerSettingsEnWd get ();
    void set (Adp5062TypeTimerSettingsEnWd value);
}
member TimerSettingsENWD : Adp5062TypeTimerSettingsEnWd with get, set

Property Value

Type: Adp5062TypeTimerSettingsEnWd
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.TimerSettingsRESETWD Property

IRD

Adp5062TimerSettingsRESETWD Property

Timer Settings: RESET_WD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeTimerSettingsResetWd TimerSettingsRESETWD { set; }
Public WriteOnly Property TimerSettingsRESETWD As Adp5062TypeTimerSettingsResetWd
    Set
public:
property Adp5062TypeTimerSettingsResetWd TimerSettingsRESETWD {
    void set (Adp5062TypeTimerSettingsResetWd value);
}
member TimerSettingsRESETWD : Adp5062TypeTimerSettingsResetWd with set

Property Value

Type: Adp5062TypeTimerSettingsResetWd
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.TimerSettingsWDPERIOD Property

IRD

Adp5062TimerSettingsWDPERIOD Property

Timer Settings: WD_PERIOD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeTimerSettingsWdPeriod TimerSettingsWDPERIOD { get; set; }
Public Property TimerSettingsWDPERIOD As Adp5062TypeTimerSettingsWdPeriod
    Get
    Set
public:
property Adp5062TypeTimerSettingsWdPeriod TimerSettingsWDPERIOD {
    Adp5062TypeTimerSettingsWdPeriod get ();
    void set (Adp5062TypeTimerSettingsWdPeriod value);
}
member TimerSettingsWDPERIOD : Adp5062TypeTimerSettingsWdPeriod with get, set

Property Value

Type: Adp5062TypeTimerSettingsWdPeriod
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.VINxPinSettingsILIM Property

IRD

Adp5062VINxPinSettingsILIM Property

VINx Pin Settings: ILIM (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeVpinxPinSettingsIlim VINxPinSettingsILIM { get; set; }
Public Property VINxPinSettingsILIM As Adp5062TypeVpinxPinSettingsIlim
    Get
    Set
public:
property Adp5062TypeVpinxPinSettingsIlim VINxPinSettingsILIM {
    Adp5062TypeVpinxPinSettingsIlim get ();
    void set (Adp5062TypeVpinxPinSettingsIlim value);
}
member VINxPinSettingsILIM : Adp5062TypeVpinxPinSettingsIlim with get, set

Property Value

Type: Adp5062TypeVpinxPinSettingsIlim
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.VINxPinSettingsRFU Property

IRD

Adp5062VINxPinSettingsRFU Property

VINx Pin Settings: RFU

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VINxPinSettingsRFU { get; set; }
Public Property VINxPinSettingsRFU As Byte
    Get
    Set
public:
property unsigned char VINxPinSettingsRFU {
    unsigned char get ();
    void set (unsigned char value);
}
member VINxPinSettingsRFU : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.VoltageThresholdsDISRCH Property

IRD

Adp5062VoltageThresholdsDISRCH Property

Voltage Thresholds: DIS_RCH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeVoltageThresholdsDisRch VoltageThresholdsDISRCH { get; set; }
Public Property VoltageThresholdsDISRCH As Adp5062TypeVoltageThresholdsDisRch
    Get
    Set
public:
property Adp5062TypeVoltageThresholdsDisRch VoltageThresholdsDISRCH {
    Adp5062TypeVoltageThresholdsDisRch get ();
    void set (Adp5062TypeVoltageThresholdsDisRch value);
}
member VoltageThresholdsDISRCH : Adp5062TypeVoltageThresholdsDisRch with get, set

Property Value

Type: Adp5062TypeVoltageThresholdsDisRch
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.VoltageThresholdsVRCH Property

IRD

Adp5062VoltageThresholdsVRCH Property

Voltage Thresholds: VRCH (unit: mV)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeVoltageThresholdsVrch VoltageThresholdsVRCH { get; set; }
Public Property VoltageThresholdsVRCH As Adp5062TypeVoltageThresholdsVrch
    Get
    Set
public:
property Adp5062TypeVoltageThresholdsVrch VoltageThresholdsVRCH {
    Adp5062TypeVoltageThresholdsVrch get ();
    void set (Adp5062TypeVoltageThresholdsVrch value);
}
member VoltageThresholdsVRCH : Adp5062TypeVoltageThresholdsVrch with get, set

Property Value

Type: Adp5062TypeVoltageThresholdsVrch
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.VoltageThresholdsVTRKDEAD Property

IRD

Adp5062VoltageThresholdsVTRKDEAD Property

Voltage Thresholds: VTRK_DEAD (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeVoltageThresholdsVtrkDead VoltageThresholdsVTRKDEAD { get; set; }
Public Property VoltageThresholdsVTRKDEAD As Adp5062TypeVoltageThresholdsVtrkDead
    Get
    Set
public:
property Adp5062TypeVoltageThresholdsVtrkDead VoltageThresholdsVTRKDEAD {
    Adp5062TypeVoltageThresholdsVtrkDead get ();
    void set (Adp5062TypeVoltageThresholdsVtrkDead value);
}
member VoltageThresholdsVTRKDEAD : Adp5062TypeVoltageThresholdsVtrkDead with get, set

Property Value

Type: Adp5062TypeVoltageThresholdsVtrkDead
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.VoltageThresholdsVWEAK Property

IRD

Adp5062VoltageThresholdsVWEAK Property

Voltage Thresholds: VWEAK (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5062TypeVoltageThresholdsVweak VoltageThresholdsVWEAK { get; set; }
Public Property VoltageThresholdsVWEAK As Adp5062TypeVoltageThresholdsVweak
    Get
    Set
public:
property Adp5062TypeVoltageThresholdsVweak VoltageThresholdsVWEAK {
    Adp5062TypeVoltageThresholdsVweak get ();
    void set (Adp5062TypeVoltageThresholdsVweak value);
}
member VoltageThresholdsVWEAK : Adp5062TypeVoltageThresholdsVweak with get, set

Property Value

Type: Adp5062TypeVoltageThresholdsVweak
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062 Methods

The Adp5062 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.Flush Method

IRD

Adp5062Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adp5062 Class
telos.Ird.AnalogDevices Namespace


Adp5062.TypeBatteryShortTbatShr Enumeration

IRD

Adp5062TypeBatteryShortTbatShr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBatteryShortTbatShr
Public Enumeration TypeBatteryShortTbatShr
public enum class TypeBatteryShortTbatShr
type TypeBatteryShortTbatShr
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_2 | 1 | 2
Value_4 | 2 | 4
Value_10 | 3 | 10
Value_30 | 4 | 30
Value_60 | 5 | 60
Value_120 | 6 | 120
Value_180 | 7 | 180
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeBatteryShortVbatShr Enumeration

IRD

Adp5062TypeBatteryShortVbatShr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBatteryShortVbatShr
Public Enumeration TypeBatteryShortVbatShr
public enum class TypeBatteryShortVbatShr
type TypeBatteryShortVbatShr
Members
Member name | Value | Description
Value_2_0 | 0 | 2.0
Value_2_1 | 1 | 2.1
Value_2_2 | 2 | 2.2
Value_2_3 | 3 | 2.3
Value_2_4 | 4 | 2.4
Value_2_5 | 5 | 2.5
Value_2_6 | 6 | 2.6
Value_2_7 | 7 | 2.7
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeChargerStatus1ChargerStatus Enumeration

IRD

Adp5062TypeChargerStatus1ChargerStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus1ChargerStatus
Public Enumeration TypeChargerStatus1ChargerStatus
public enum class TypeChargerStatus1ChargerStatus
type TypeChargerStatus1ChargerStatus
Members
Member name | Value | Description
Off | 0 | Off
TrickleCharge | 1 | Trickle Charge
FastChargeCCMode | 2 | Fast Charge (CC Mode)
FastChargeCVMode | 3 | Fast Charge (CV Mode)
ChargeComplete | 4 | Charge Complete
LDOMode | 5 | LDO Mode
TrickleOrFastChargeTimerExpired | 6 | Trickle Or Fast Charge Timer Expired
BatteryDetection | 7 | Battery Detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeChargerStatus1Chdone Enumeration

IRD

Adp5062TypeChargerStatus1Chdone Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus1Chdone
Public Enumeration TypeChargerStatus1Chdone
public enum class TypeChargerStatus1Chdone
type TypeChargerStatus1Chdone
Members
Member name | Value | Description
EndOfChargeCycleNotReached | 0 | End Of Charge Cycle: Not Reached
EndOfChargeCycleReached | 1 | End Of Charge Cycle: Reached
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeChargerStatus1ThermLim Enumeration

IRD

Adp5062TypeChargerStatus1ThermLim Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus1ThermLim
Public Enumeration TypeChargerStatus1ThermLim
public enum class TypeChargerStatus1ThermLim
type TypeChargerStatus1ThermLim
Members
Member name | Value | Description
NotLimitedByTemperature | 0 | Not Limited By Temperature
LimitedByTemperature | 1 | Limited By Temperature
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeChargerStatus1VinIlim Enumeration

IRD

Adp5062TypeChargerStatus1VinIlim Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus1VinIlim
Public Enumeration TypeChargerStatus1VinIlim
public enum class TypeChargerStatus1VinIlim
type TypeChargerStatus1VinIlim
Members
Member name | Value | Description
VINxCurrentNotLimited | 0 | VINx Current: Not Limited
VINxCurrentLimited | 1 | VINx Current: Limited
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeChargerStatus1VinOk Enumeration

IRD

Adp5062TypeChargerStatus1VinOk Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus1VinOk
Public Enumeration TypeChargerStatus1VinOk
public enum class TypeChargerStatus1VinOk
type TypeChargerStatus1VinOk
Members
Member name | Value | Description
VINxVVINOKRISEVVINOKFALL | 0 | VINx <= V_VIN_OK_RISE, V_VIN_OK_FALL
VINxVVINOKRISEVVINOKFALL__1 | 1 | VINx > V_VIN_OK_RISE, V_VIN_OK_FALL
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeChargerStatus1VinOv Enumeration

IRD

Adp5062TypeChargerStatus1VinOv Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus1VinOv
Public Enumeration TypeChargerStatus1VinOv
public enum class TypeChargerStatus1VinOv
type TypeChargerStatus1VinOv
Members
Member name | Value | Description
VINxVVINOV | 0 | VINx <= V_VIN_OV
VINxVVINOV__1 | 1 | VINx > V_VIN_OV
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeChargerStatus2BatteryStatus Enumeration

IRD

Adp5062TypeChargerStatus2BatteryStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus2BatteryStatus
Public Enumeration TypeChargerStatus2BatteryStatus
public enum class TypeChargerStatus2BatteryStatus
type TypeChargerStatus2BatteryStatus
Members
Member name | Value | Description
BatteryMonitorOff | 0 | Battery Monitor Off
NoBattery | 1 | No Battery
VBATSNSVTRK | 2 | V_BAT_SNS < V_TRK
VTRKDEADVBATSNSVWEAK | 3 | V_TRK_DEAD <= V_BAT_SNS < V_WEAK
VBATSNSVWEAK | 4 | V_BAT_SNS >= V_WEAK
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeChargerStatus2RchLimInfo Enumeration

IRD

Adp5062TypeChargerStatus2RchLimInfo Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus2RchLimInfo
Public Enumeration TypeChargerStatus2RchLimInfo
public enum class TypeChargerStatus2RchLimInfo
type TypeChargerStatus2RchLimInfo
Members
Member name | Value | Description
VBATSNSVRCH | 0 | V_BAT_SNS > V_RCH
VBATSNSVRCH__1 | 1 | V_BAT_SNS < V_RCH
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeChargerStatus2ThrStatus Enumeration

IRD

Adp5062TypeChargerStatus2ThrStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus2ThrStatus
Public Enumeration TypeChargerStatus2ThrStatus
public enum class TypeChargerStatus2ThrStatus
type TypeChargerStatus2ThrStatus
Members
Member name | Value | Description
Off | 0 | Off
BatteryCold | 1 | Battery Cold
BatteryCool | 2 | Battery Cool
BatteryWarm | 3 | Battery Warm
BatteryHot | 4 | Battery Hot
ThermistorOK | 7 | Thermistor OK
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeChargingCurrentIchg Enumeration

IRD

Adp5062TypeChargingCurrentIchg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargingCurrentIchg
Public Enumeration TypeChargingCurrentIchg
public enum class TypeChargingCurrentIchg
type TypeChargingCurrentIchg
Members
Member name | Value | Description
Value_50 | 0 | 50
Value_100 | 1 | 100
Value_150 | 2 | 150
Value_200 | 3 | 200
Value_250 | 4 | 250
Value_300 | 5 | 300
Value_350 | 6 | 350
Value_400 | 7 | 400
Value_450 | 8 | 450
Value_500 | 9 | 500
Value_550 | 10 | 550
Value_600 | 11 | 600
Value_650 | 12 | 650
Value_700 | 13 | 700
Value_750 | 14 | 750
Value_800 | 15 | 800
Value_850 | 16 | 850
Value_900 | 17 | 900
Value_950 | 18 | 950
Value_1000 | 19 | 1000
Value_1050 | 20 | 1050
Value_1100 | 21 | 1100
Value_1200 | 22 | 1200
Value_1300 | 23 | 1300
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeChargingCurrentItrkDead Enumeration

IRD

Adp5062TypeChargingCurrentItrkDead Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargingCurrentItrkDead
Public Enumeration TypeChargingCurrentItrkDead
public enum class TypeChargingCurrentItrkDead
type TypeChargingCurrentItrkDead
Members
Member name | Value | Description
Value_5 | 0 | 5
Value_10 | 1 | 10
Value_20 | 2 | 20
Value_80 | 3 | 80
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeFaultBatShr Enumeration

IRD

Adp5062TypeFaultBatShr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultBatShr
Public Enumeration TypeFaultBatShr
public enum class TypeFaultBatShr
type TypeFaultBatShr
Members
Member name | Value | Description
BatteryNotShort | 0 | Battery: Not Short
BatteryShort | 1 | Battery: Short
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeFaultOverTemp Enumeration

IRD

Adp5062TypeFaultOverTemp Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultOverTemp
Public Enumeration TypeFaultOverTemp
public enum class TypeFaultOverTemp
type TypeFaultOverTemp
Members
Member name | Value | Description
NoOvertemperature | 0 | No Overtemperature
Overtemperature | 1 | Overtemperature
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeFunctionalSettings1DisIc1 Enumeration

IRD

Adp5062TypeFunctionalSettings1DisIc1 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1DisIc1
Public Enumeration TypeFunctionalSettings1DisIc1
public enum class TypeFunctionalSettings1DisIc1
type TypeFunctionalSettings1DisIc1
Members
Member name | Value | Description
NormalOperation | 0 | Normal Operation
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeFunctionalSettings1DisLdo Enumeration

IRD

Adp5062TypeFunctionalSettings1DisLdo Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1DisLdo
Public Enumeration TypeFunctionalSettings1DisLdo
public enum class TypeFunctionalSettings1DisLdo
type TypeFunctionalSettings1DisLdo
Members
Member name | Value | Description
LDOEnabled | 0 | LDO: Enabled
LDODisabled | 1 | LDO: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeFunctionalSettings1EnBmon Enumeration

IRD

Adp5062TypeFunctionalSettings1EnBmon Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1EnBmon
Public Enumeration TypeFunctionalSettings1EnBmon
public enum class TypeFunctionalSettings1EnBmon
type TypeFunctionalSettings1EnBmon
Members
Member name | Value | Description
BatteryMonitorVVINxVVINOKRISEOrVVINOKFALLDisabled | 0 | Battery Monitor (V_VINx < V_VIN_OK_RISE or V_VIN_OK_FALL): Disabled
BatteryMonitorVVINxVVINOKRISEOrVVINOKFALLEnabled | 1 | Battery Monitor (V_VINx < V_VIN_OK_RISE or V_VIN_OK_FALL): Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeFunctionalSettings1EnChg Enumeration

IRD

Adp5062TypeFunctionalSettings1EnChg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1EnChg
Public Enumeration TypeFunctionalSettings1EnChg
public enum class TypeFunctionalSettings1EnChg
type TypeFunctionalSettings1EnChg
Members
Member name | Value | Description
BatteryChargingDisabled | 0 | Battery Charging: Disabled
BatteryChargingEnabled | 1 | Battery Charging: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeFunctionalSettings1EnEoc Enumeration

IRD

Adp5062TypeFunctionalSettings1EnEoc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1EnEoc
Public Enumeration TypeFunctionalSettings1EnEoc
public enum class TypeFunctionalSettings1EnEoc
type TypeFunctionalSettings1EnEoc
Members
Member name | Value | Description
EndOfChargeNotAllowed | 0 | End Of Charge: Not Allowed
EndOfChargeAllowed | 1 | End Of Charge: Allowed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeFunctionalSettings1EnThr Enumeration

IRD

Adp5062TypeFunctionalSettings1EnThr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1EnThr
Public Enumeration TypeFunctionalSettings1EnThr
public enum class TypeFunctionalSettings1EnThr
type TypeFunctionalSettings1EnThr
Members
Member name | Value | Description
THRCurrentSourceVVINxVVINOKRISEOrVVINOKFALLDisabled | 0 | THR Current Source (V_VINx < V_VIN_OK_RISE or V_VIN_OK_FALL): Disabled
THRCurrentSourceVVINxVVINOKRISEOrVVINOKFALLEnabled | 1 | THR Current Source (V_VINx < V_VIN_OK_RISE or V_VIN_OK_FALL): Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeFunctionalSettings2EnChgVlim Enumeration

IRD

Adp5062TypeFunctionalSettings2EnChgVlim Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings2EnChgVlim
Public Enumeration TypeFunctionalSettings2EnChgVlim
public enum class TypeFunctionalSettings2EnChgVlim
type TypeFunctionalSettings2EnChgVlim
Members
Member name | Value | Description
VoltageLimitDisabled | 0 | Voltage Limit: Disabled
VoltageLimitEnabled | 1 | Voltage Limit: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeFunctionalSettings2EnJeita Enumeration

IRD

Adp5062TypeFunctionalSettings2EnJeita Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings2EnJeita
Public Enumeration TypeFunctionalSettings2EnJeita
public enum class TypeFunctionalSettings2EnJeita
type TypeFunctionalSettings2EnJeita
Members
Member name | Value | Description
JEITAComplianceDisabled | 0 | JEITA Compliance: Disabled
JEITAComplianceEnabled | 1 | JEITA Compliance: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeFunctionalSettings2IdealDiode Enumeration

IRD

Adp5062TypeFunctionalSettings2IdealDiode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings2IdealDiode
Public Enumeration TypeFunctionalSettings2IdealDiode
public enum class TypeFunctionalSettings2IdealDiode
type TypeFunctionalSettings2IdealDiode
Members
Member name | Value | Description
IdealDiodeOperatesWhenVISOSxVISBBx | 0 | Ideal Diode: Operates When V_ISO_Sx < V_ISB_Bx
IdealDiodeOperatesWhenVISOSxVISBBxAndVBATSNSVWEAK | 1 | Ideal Diode: Operates When V_ISO_Sx < V_ISB_Bx And V_BAT_SNS > V_WEAK
IdealDiodeDisabled | 2 | Ideal Diode: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeFunctionalSettings2JeitaSelect Enumeration

IRD

Adp5062TypeFunctionalSettings2JeitaSelect Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings2JeitaSelect
Public Enumeration TypeFunctionalSettings2JeitaSelect
public enum class TypeFunctionalSettings2JeitaSelect
type TypeFunctionalSettings2JeitaSelect
Members
Member name | Value | Description
JEITA1 | 0 | JEITA1
JEITA2 | 1 | JEITA2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeFunctionalSettings2Vsystem Enumeration

IRD

Adp5062TypeFunctionalSettings2Vsystem Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings2Vsystem
Public Enumeration TypeFunctionalSettings2Vsystem
public enum class TypeFunctionalSettings2Vsystem
type TypeFunctionalSettings2Vsystem
Members
Member name | Value | Description
Value_4_3 | 0 | 4.3
Value_4_4 | 1 | 4.4
Value_4_5 | 2 | 4.5
Value_4_6 | 3 | 4.6
Value_4_7 | 4 | 4.7
Value_4_8 | 5 | 4.8
Value_4_9 | 6 | 4.9
Value_5_0 | 7 | 5.0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeIendC10Eoc Enumeration

IRD

Adp5062TypeIendC10Eoc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIendC10Eoc
Public Enumeration TypeIendC10Eoc
public enum class TypeIendC10Eoc
type TypeIendC10Eoc
Members
Member name | Value | Description
ICHG10NotTerminationCurrent | 0 | ICHG / 10: Not Termination Current
ICHG10TerminationCurrent | 1 | ICHG / 10: Termination Current
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeIendC20Eoc Enumeration

IRD

Adp5062TypeIendC20Eoc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIendC20Eoc
Public Enumeration TypeIendC20Eoc
public enum class TypeIendC20Eoc
type TypeIendC20Eoc
Members
Member name | Value | Description
ICHG20NotTerminationCurrent | 0 | ICHG / 20: Not Termination Current
ICHG20TerminationCurrent | 1 | ICHG / 20: Termination Current
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeIendC5Eoc Enumeration

IRD

Adp5062TypeIendC5Eoc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIendC5Eoc
Public Enumeration TypeIendC5Eoc
public enum class TypeIendC5Eoc
type TypeIendC5Eoc
Members
Member name | Value | Description
ICHG5NotTerminationCurrent | 0 | ICHG / 5: Not Termination Current
ICHG5TerminationCurrent | 1 | ICHG / 5: Termination Current
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeIendIend Enumeration

IRD

Adp5062TypeIendIend Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIendIend
Public Enumeration TypeIendIend
public enum class TypeIendIend
type TypeIendIend
Members
Member name | Value | Description
Value_12_5 | 0 | 12.5
Value_32_5 | 1 | 32.5
Value_52_5 | 2 | 52.5
Value_72_5 | 3 | 72.5
Value_92_5 | 4 | 92.5
Value_117_5 | 5 | 117.5
Value_142_5 | 6 | 142.5
Value_170_0 | 7 | 170.0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeIendSysEnSet Enumeration

IRD

Adp5062TypeIendSysEnSet Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIendSysEnSet
Public Enumeration TypeIendSysEnSet
public enum class TypeIendSysEnSet
type TypeIendSysEnSet
Members
Member name | Value | Description
SYSENIsActivatedWhenLDOIsActiveAndTheSystemVoltageIsAvailable | 0 | SYS_EN is activated when LDO is active and the system voltage is available
SYSENActivatedByISOBxVoltageTheBatteryChargingMode | 1 | SYS_EN activated by ISO_Bx voltage, the battery charging mode.
SYSENIsActivatedAndTheIsolationFETIsDisabledWhenTheBatteryDropsBelowVWEAK | 2 | SYS_EN is activated and the isolation FET is disabled when the battery drops below V_WEAK.
SYSENIsActiveInLDOModeWhenTheChargerIsDisabledSYSENIsActiveInTheChargingModeWhenVISOBxVWEAK | 3 | SYS_EN is active in LDO mode when the charger is disabled. SYS_EN is active in the charging mode when V_ISO_Bx >= V_WEAK.
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeInterruptActive Enumeration

IRD

Adp5062TypeInterruptActive Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptActive
Public Enumeration TypeInterruptActive
public enum class TypeInterruptActive
type TypeInterruptActive
Members
Member name | Value | Description
InterruptNotTriggered | 0 | Interrupt: Not Triggered
InterruptTriggered | 1 | Interrupt: Triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeInterruptEnable Enumeration

IRD

Adp5062TypeInterruptEnable Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnable
Public Enumeration TypeInterruptEnable
public enum class TypeInterruptEnable
type TypeInterruptEnable
Members
Member name | Value | Description
InterruptDisabled | 0 | Interrupt: Disabled
InterruptEnabled | 1 | Interrupt: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeTerminationSettingsChgVlim Enumeration

IRD

Adp5062TypeTerminationSettingsChgVlim Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTerminationSettingsChgVlim
Public Enumeration TypeTerminationSettingsChgVlim
public enum class TypeTerminationSettingsChgVlim
type TypeTerminationSettingsChgVlim
Members
Member name | Value | Description
Value_3_2 | 0 | 3.2
Value_3_4 | 1 | 3.4
Value_3_7 | 2 | 3.7
Value_3_8 | 3 | 3.8
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeTerminationSettingsVtrm Enumeration

IRD

Adp5062TypeTerminationSettingsVtrm Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTerminationSettingsVtrm
Public Enumeration TypeTerminationSettingsVtrm
public enum class TypeTerminationSettingsVtrm
type TypeTerminationSettingsVtrm
Members
Member name | Value | Description
Value_3_60 | 5 | 3.60
Value_3_62 | 6 | 3.62
Value_3_64 | 7 | 3.64
Value_3_66 | 8 | 3.66
Value_3_68 | 9 | 3.68
Value_3_70 | 10 | 3.70
Value_3_72 | 11 | 3.72
Value_3_74 | 12 | 3.74
Value_3_76 | 13 | 3.76
Value_3_78 | 14 | 3.78
Value_3_80 | 15 | 3.80
Value_3_82 | 16 | 3.82
Value_3_84 | 17 | 3.84
Value_3_86 | 18 | 3.86
Value_3_88 | 19 | 3.88
Value_3_90 | 20 | 3.90
Value_3_92 | 21 | 3.92
Value_3_94 | 22 | 3.94
Value_3_96 | 23 | 3.96
Value_3_98 | 24 | 3.98
Value_4_00 | 25 | 4.00
Value_4_02 | 26 | 4.02
Value_4_04 | 27 | 4.04
Value_4_06 | 28 | 4.06
Value_4_08 | 29 | 4.08
Value_4_10 | 30 | 4.10
Value_4_12 | 31 | 4.12
Value_4_14 | 32 | 4.14
Value_4_16 | 33 | 4.16
Value_4_18 | 34 | 4.18
Value_4_20 | 35 | 4.20
Value_4_22 | 36 | 4.22
Value_4_24 | 37 | 4.24
Value_4_26 | 38 | 4.26
Value_4_28 | 39 | 4.28
Value_4_30 | 40 | 4.30
Value_4_32 | 41 | 4.32
Value_4_34 | 42 | 4.34
Value_4_36 | 43 | 4.36
Value_4_38 | 44 | 4.38
Value_4_40 | 45 | 4.40
Value_4_42 | 46 | 4.42
Value_4_44 | 47 | 4.44
Value_4_44__1 | 48 | 4.44
Value_4_46 | 49 | 4.46
Value_4_48 | 50 | 4.48
Value_4_50 | 51 | 4.50
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeTimerSettingsChgTmrPeriod Enumeration

IRD

Adp5062TypeTimerSettingsChgTmrPeriod Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerSettingsChgTmrPeriod
Public Enumeration TypeTimerSettingsChgTmrPeriod
public enum class TypeTimerSettingsChgTmrPeriod
type TypeTimerSettingsChgTmrPeriod
Members
Member name | Value | Description
Trickle30SecFast300Minutes | 0 | Trickle: 30 sec, Fast: 300 minutes
Trickle60SecFast600Minutes | 1 | Trickle: 60 sec, Fast: 600 minutes
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeTimerSettingsEnChgTimer Enumeration

IRD

Adp5062TypeTimerSettingsEnChgTimer Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerSettingsEnChgTimer
Public Enumeration TypeTimerSettingsEnChgTimer
public enum class TypeTimerSettingsEnChgTimer
type TypeTimerSettingsEnChgTimer
Members
Member name | Value | Description
TrickleFastChargeTimerDisabled | 0 | Trickle/Fast Charge Timer: Disabled
TrickleFastChargeTimerEnabled | 1 | Trickle/Fast Charge Timer: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeTimerSettingsEnTend Enumeration

IRD

Adp5062TypeTimerSettingsEnTend Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerSettingsEnTend
Public Enumeration TypeTimerSettingsEnTend
public enum class TypeTimerSettingsEnTend
type TypeTimerSettingsEnTend
Members
Member name | Value | Description
ChargeCompletedTimerDisabled | 0 | Charge Completed Timer: Disabled
ChargeCompletedTimerEnabled | 1 | Charge Completed Timer: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeTimerSettingsEnWd Enumeration

IRD

Adp5062TypeTimerSettingsEnWd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerSettingsEnWd
Public Enumeration TypeTimerSettingsEnWd
public enum class TypeTimerSettingsEnWd
type TypeTimerSettingsEnWd
Members
Member name | Value | Description
WatchdogDisabled | 0 | Watchdog: Disabled
WatchdogEnabled | 1 | Watchdog: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeTimerSettingsResetWd Enumeration

IRD

Adp5062TypeTimerSettingsResetWd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerSettingsResetWd
Public Enumeration TypeTimerSettingsResetWd
public enum class TypeTimerSettingsResetWd
type TypeTimerSettingsResetWd
Members
Member name | Value | Description
WatchdogTimerNotChanged | 0 | Watchdog Timer: Not Changed
WatchdogTimerReset | 1 | Watchdog Timer: Reset
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeTimerSettingsWdPeriod Enumeration

IRD

Adp5062TypeTimerSettingsWdPeriod Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerSettingsWdPeriod
Public Enumeration TypeTimerSettingsWdPeriod
public enum class TypeTimerSettingsWdPeriod
type TypeTimerSettingsWdPeriod
Members
Member name | Value | Description
Watchdog32SecSafety40Minutes | 0 | Watchdog: 32 sec, Safety: 40 minutes
Watchdog64SecSafety40Minutes | 1 | Watchdog: 64 sec, Safety: 40 minutes
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeVoltageThresholdsDisRch Enumeration

IRD

Adp5062TypeVoltageThresholdsDisRch Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVoltageThresholdsDisRch
Public Enumeration TypeVoltageThresholdsDisRch
public enum class TypeVoltageThresholdsDisRch
type TypeVoltageThresholdsDisRch
Members
Member name | Value | Description
RechargeEnabled | 0 | Recharge Enabled
RechargeDisabled | 1 | Recharge Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeVoltageThresholdsVrch Enumeration

IRD

Adp5062TypeVoltageThresholdsVrch Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVoltageThresholdsVrch
Public Enumeration TypeVoltageThresholdsVrch
public enum class TypeVoltageThresholdsVrch
type TypeVoltageThresholdsVrch
Members
Member name | Value | Description
Value_80 | 0 | 80
Value_140 | 1 | 140
Value_200 | 2 | 200
Value_260 | 3 | 260
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeVoltageThresholdsVtrkDead Enumeration

IRD

Adp5062TypeVoltageThresholdsVtrkDead Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVoltageThresholdsVtrkDead
Public Enumeration TypeVoltageThresholdsVtrkDead
public enum class TypeVoltageThresholdsVtrkDead
type TypeVoltageThresholdsVtrkDead
Members
Member name | Value | Description
Value_2_0 | 0 | 2.0
Value_2_5 | 1 | 2.5
Value_2_6 | 2 | 2.6
Value_2_9 | 3 | 2.9
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeVoltageThresholdsVweak Enumeration

IRD

Adp5062TypeVoltageThresholdsVweak Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVoltageThresholdsVweak
Public Enumeration TypeVoltageThresholdsVweak
public enum class TypeVoltageThresholdsVweak
type TypeVoltageThresholdsVweak
Members
Member name | Value | Description
Value_2_7 | 0 | 2.7
Value_2_8 | 1 | 2.8
Value_2_9 | 2 | 2.9
Value_3_0 | 3 | 3.0
Value_3_1 | 4 | 3.1
Value_3_2 | 5 | 3.2
Value_3_3 | 6 | 3.3
Value_3_4 | 7 | 3.4
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5062.TypeVpinxPinSettingsIlim Enumeration

IRD

Adp5062TypeVpinxPinSettingsIlim Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVpinxPinSettingsIlim
Public Enumeration TypeVpinxPinSettingsIlim
public enum class TypeVpinxPinSettingsIlim
type TypeVpinxPinSettingsIlim
Members
Member name | Value | Description
Value_100 | 0 | 100
Value_150 | 1 | 150
Value_200 | 2 | 200
Value_250 | 3 | 250
Value_300 | 4 | 300
Value_400 | 5 | 400
Value_500 | 6 | 500
Value_600 | 7 | 600
Value_700 | 8 | 700
Value_800 | 9 | 800
Value_900 | 10 | 900
Value_1000 | 11 | 1000
Value_1200 | 12 | 1200
Value_1500 | 13 | 1500
Value_1800 | 14 | 1800
Value_2100 | 15 | 2100
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065 Class

Analog Devices: ADP 5065
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdp5065

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adp5065
Public Class Adp5065
public ref class Adp5065
type Adp5065 =  class end

The Adp5065 type exposes the following members.

Constructors
 | Name | Description
Public method | Adp5065 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryShortTBATSHR | Battery Short: TBAT_SHR (unit: sec)
Public property | BatteryShortVBATSHR | Battery Short: VBAT_SHR (unit: V)
Public property | ChargerStatus1CHARGERSTATUS | Charger Status 1: CHARGER_STATUS
Public property | ChargerStatus1CHDONE | Charger Status 1: CHDONE
Public property | ChargerStatus1THERMLIM | Charger Status 1: THERM_LIM
Public property | ChargerStatus1VINILIM | Charger Status 1: VIN_ILIM
Public property | ChargerStatus1VINOK | Charger Status 1: VIN_OK
Public property | ChargerStatus1VINOV | Charger Status 1: VIN_OV
Public property | ChargerStatus2BATTERYSTATUS | Charger Status 2: BATTERY_STATUS
Public property | ChargerStatus2IPKSTAT | Charger Status 2: IPK_STAT
Public property | ChargerStatus2THRSTATUS | Charger Status 2: THR_STATUS
Public property | ChargingCurrentC10EOC | Charging Current: C/10 EOC
Public property | ChargingCurrentC20EOC | Charging Current: C/20 EOC
Public property | ChargingCurrentICHG | Charging Current: ICHG (unit: mA)
Public property | ChargingCurrentITRKDEAD | Charging Current: ITRK_DEAD (unit: mA)
Public property | FaultBATSHR | Fault: BAT_SHR
Public property | FaultINDPEAKINT | Fault: IND_PEAK_INT
Public property | FaultTSD130C | Fault: TSD 130°C
Public property | FaultTSD140C | Fault: TSD 140°C
Public property | FunctionalSettings1DISIPKSD | Functional Settings 1: DIS_IPK_SD
Public property | FunctionalSettings1ENBMON | Functional Settings 1: EN_BMON
Public property | FunctionalSettings1ENCHG | Functional Settings 1: EN_CHG
Public property | FunctionalSettings1ENEOC | Functional Settings 1: EN_EOC
Public property | FunctionalSettings1ENJEITA | Functional Settings 1: EN_JEITA
Public property | FunctionalSettings1ENTHR | Functional Settings 1: EN_THR
Public property | FunctionalSettings1ENTRK | Functional Settings 1: EN_TRK
Public property | InterruptActiveBATINT | Interrupt Active: BAT_INT
Public property | InterruptActiveCHGINT | Interrupt Active: CHG_INT
Public property | InterruptActiveINDPEAKINT | Interrupt Active: IND_PEAK_INT
Public property | InterruptActiveTHERMLIMINT | Interrupt Active: THERM_LIM_INT
Public property | InterruptActiveTHRINT | Interrupt Active: THR_INT
Public property | InterruptActiveTSDINT | Interrupt Active: TSD_INT
Public property | InterruptActiveVININT | Interrupt Active: VIN_INT
Public property | InterruptActiveWDINT | Interrupt Active: WD_INT
Public property | InterruptEnableENBATINT | Interrupt Enable: EN_BAT_INT
Public property | InterruptEnableENCHGINT | Interrupt Enable: EN_CHG_INT
Public property | InterruptEnableENINDPEAKINT | Interrupt Enable: EN_IND_PEAK_INT
Public property | InterruptEnableENTHERMLIMINT | Interrupt Enable: EN_THERM_LIM_INT
Public property | InterruptEnableENTHRINT | Interrupt Enable: EN_THR_INT
Public property | InterruptEnableENTSDINT | Interrupt Enable: EN_TSD_INT
Public property | InterruptEnableENVININT | Interrupt Enable: EN_VIN_INT
Public property | InterruptEnableENWDINT | Interrupt Enable: EN_WD_INT
Public property | ManufacturerAndModelIDMANUF | Manufacturer and Model ID: MANUF
Public property | ManufacturerAndModelIDMODEL | Manufacturer and Model ID: MODEL
Public property | SiliconRevisionREV | Silicon Revision: REV
Public property | TerminationSettingsIEND | Termination Settings: IEND (unit: mA)
Public property | TerminationSettingsVTRM | Termination Settings: VTRM (unit: V)
Public property | TimerSettingsCHGTMRPERIOD | Timer Settings: CHG_TMR_PERIOD
Public property | TimerSettingsENCHGTIMER | Timer Settings: EN_CHG_TIMER
Public property | TimerSettingsENTEND | Timer Settings: EN_TEND
Public property | TimerSettingsENWD | Timer Settings: EN_WD
Public property | TimerSettingsRESETWD | Timer Settings: RESET_WD
Public property | TimerSettingsWDPERIOD | Timer Settings: WD_PERIOD
Public property | VINxPinsSettingsILIM | VINx Pins Settings: ILIM (unit: mA)
Public property | VINxPinsSettingsRFU | VINx Pins Settings: RFU
Public property | VoltageThresholdsVRCH | Voltage Thresholds: VRCH (unit: mV)
Public property | VoltageThresholdsVTRKDEAD | Voltage Thresholds: VTRK_DEAD (unit: V)
Public property | VoltageThresholdsVWEAK | Voltage Thresholds: VWEAK (unit: V)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Fast Charge Battery Manager with Power Path and USB Compatibility
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adp5065(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adp5065

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065 Properties

The Adp5065 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryShortTBATSHR | Battery Short: TBAT_SHR (unit: sec)
Public property | BatteryShortVBATSHR | Battery Short: VBAT_SHR (unit: V)
Public property | ChargerStatus1CHARGERSTATUS | Charger Status 1: CHARGER_STATUS
Public property | ChargerStatus1CHDONE | Charger Status 1: CHDONE
Public property | ChargerStatus1THERMLIM | Charger Status 1: THERM_LIM
Public property | ChargerStatus1VINILIM | Charger Status 1: VIN_ILIM
Public property | ChargerStatus1VINOK | Charger Status 1: VIN_OK
Public property | ChargerStatus1VINOV | Charger Status 1: VIN_OV
Public property | ChargerStatus2BATTERYSTATUS | Charger Status 2: BATTERY_STATUS
Public property | ChargerStatus2IPKSTAT | Charger Status 2: IPK_STAT
Public property | ChargerStatus2THRSTATUS | Charger Status 2: THR_STATUS
Public property | ChargingCurrentC10EOC | Charging Current: C/10 EOC
Public property | ChargingCurrentC20EOC | Charging Current: C/20 EOC
Public property | ChargingCurrentICHG | Charging Current: ICHG (unit: mA)
Public property | ChargingCurrentITRKDEAD | Charging Current: ITRK_DEAD (unit: mA)
Public property | FaultBATSHR | Fault: BAT_SHR
Public property | FaultINDPEAKINT | Fault: IND_PEAK_INT
Public property | FaultTSD130C | Fault: TSD 130°C
Public property | FaultTSD140C | Fault: TSD 140°C
Public property | FunctionalSettings1DISIPKSD | Functional Settings 1: DIS_IPK_SD
Public property | FunctionalSettings1ENBMON | Functional Settings 1: EN_BMON
Public property | FunctionalSettings1ENCHG | Functional Settings 1: EN_CHG
Public property | FunctionalSettings1ENEOC | Functional Settings 1: EN_EOC
Public property | FunctionalSettings1ENJEITA | Functional Settings 1: EN_JEITA
Public property | FunctionalSettings1ENTHR | Functional Settings 1: EN_THR
Public property | FunctionalSettings1ENTRK | Functional Settings 1: EN_TRK
Public property | InterruptActiveBATINT | Interrupt Active: BAT_INT
Public property | InterruptActiveCHGINT | Interrupt Active: CHG_INT
Public property | InterruptActiveINDPEAKINT | Interrupt Active: IND_PEAK_INT
Public property | InterruptActiveTHERMLIMINT | Interrupt Active: THERM_LIM_INT
Public property | InterruptActiveTHRINT | Interrupt Active: THR_INT
Public property | InterruptActiveTSDINT | Interrupt Active: TSD_INT
Public property | InterruptActiveVININT | Interrupt Active: VIN_INT
Public property | InterruptActiveWDINT | Interrupt Active: WD_INT
Public property | InterruptEnableENBATINT | Interrupt Enable: EN_BAT_INT
Public property | InterruptEnableENCHGINT | Interrupt Enable: EN_CHG_INT
Public property | InterruptEnableENINDPEAKINT | Interrupt Enable: EN_IND_PEAK_INT
Public property | InterruptEnableENTHERMLIMINT | Interrupt Enable: EN_THERM_LIM_INT
Public property | InterruptEnableENTHRINT | Interrupt Enable: EN_THR_INT
Public property | InterruptEnableENTSDINT | Interrupt Enable: EN_TSD_INT
Public property | InterruptEnableENVININT | Interrupt Enable: EN_VIN_INT
Public property | InterruptEnableENWDINT | Interrupt Enable: EN_WD_INT
Public property | ManufacturerAndModelIDMANUF | Manufacturer and Model ID: MANUF
Public property | ManufacturerAndModelIDMODEL | Manufacturer and Model ID: MODEL
Public property | SiliconRevisionREV | Silicon Revision: REV
Public property | TerminationSettingsIEND | Termination Settings: IEND (unit: mA)
Public property | TerminationSettingsVTRM | Termination Settings: VTRM (unit: V)
Public property | TimerSettingsCHGTMRPERIOD | Timer Settings: CHG_TMR_PERIOD
Public property | TimerSettingsENCHGTIMER | Timer Settings: EN_CHG_TIMER
Public property | TimerSettingsENTEND | Timer Settings: EN_TEND
Public property | TimerSettingsENWD | Timer Settings: EN_WD
Public property | TimerSettingsRESETWD | Timer Settings: RESET_WD
Public property | TimerSettingsWDPERIOD | Timer Settings: WD_PERIOD
Public property | VINxPinsSettingsILIM | VINx Pins Settings: ILIM (unit: mA)
Public property | VINxPinsSettingsRFU | VINx Pins Settings: RFU
Public property | VoltageThresholdsVRCH | Voltage Thresholds: VRCH (unit: mV)
Public property | VoltageThresholdsVTRKDEAD | Voltage Thresholds: VTRK_DEAD (unit: V)
Public property | VoltageThresholdsVWEAK | Voltage Thresholds: VWEAK (unit: V)
Top
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.AutoFlush Property

IRD

Adp5065AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.BatteryShortTBATSHR Property

IRD

Adp5065BatteryShortTBATSHR Property

Battery Short: TBAT_SHR (unit: sec)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeBatteryShortTbatShr BatteryShortTBATSHR { get; set; }
Public Property BatteryShortTBATSHR As Adp5065TypeBatteryShortTbatShr
    Get
    Set
public:
property Adp5065TypeBatteryShortTbatShr BatteryShortTBATSHR {
    Adp5065TypeBatteryShortTbatShr get ();
    void set (Adp5065TypeBatteryShortTbatShr value);
}
member BatteryShortTBATSHR : Adp5065TypeBatteryShortTbatShr with get, set

Property Value

Type: Adp5065TypeBatteryShortTbatShr
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.BatteryShortVBATSHR Property

IRD

Adp5065BatteryShortVBATSHR Property

Battery Short: VBAT_SHR (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeBatteryShortVbatShr BatteryShortVBATSHR { get; set; }
Public Property BatteryShortVBATSHR As Adp5065TypeBatteryShortVbatShr
    Get
    Set
public:
property Adp5065TypeBatteryShortVbatShr BatteryShortVBATSHR {
    Adp5065TypeBatteryShortVbatShr get ();
    void set (Adp5065TypeBatteryShortVbatShr value);
}
member BatteryShortVBATSHR : Adp5065TypeBatteryShortVbatShr with get, set

Property Value

Type: Adp5065TypeBatteryShortVbatShr
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.ChargerStatus1CHARGERSTATUS Property

IRD

Adp5065ChargerStatus1CHARGERSTATUS Property

Charger Status 1: CHARGER_STATUS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeChargerStatus1ChargerStatus ChargerStatus1CHARGERSTATUS { get; }
Public ReadOnly Property ChargerStatus1CHARGERSTATUS As Adp5065TypeChargerStatus1ChargerStatus
    Get
public:
property Adp5065TypeChargerStatus1ChargerStatus ChargerStatus1CHARGERSTATUS {
    Adp5065TypeChargerStatus1ChargerStatus get ();
}
member ChargerStatus1CHARGERSTATUS : Adp5065TypeChargerStatus1ChargerStatus with get

Property Value

Type: Adp5065TypeChargerStatus1ChargerStatus
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.ChargerStatus1CHDONE Property

IRD

Adp5065ChargerStatus1CHDONE Property

Charger Status 1: CHDONE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeChargerStatus1Chdone ChargerStatus1CHDONE { get; }
Public ReadOnly Property ChargerStatus1CHDONE As Adp5065TypeChargerStatus1Chdone
    Get
public:
property Adp5065TypeChargerStatus1Chdone ChargerStatus1CHDONE {
    Adp5065TypeChargerStatus1Chdone get ();
}
member ChargerStatus1CHDONE : Adp5065TypeChargerStatus1Chdone with get

Property Value

Type: Adp5065TypeChargerStatus1Chdone
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.ChargerStatus1THERMLIM Property

IRD

Adp5065ChargerStatus1THERMLIM Property

Charger Status 1: THERM_LIM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeChargerStatus1ThermLim ChargerStatus1THERMLIM { get; }
Public ReadOnly Property ChargerStatus1THERMLIM As Adp5065TypeChargerStatus1ThermLim
    Get
public:
property Adp5065TypeChargerStatus1ThermLim ChargerStatus1THERMLIM {
    Adp5065TypeChargerStatus1ThermLim get ();
}
member ChargerStatus1THERMLIM : Adp5065TypeChargerStatus1ThermLim with get

Property Value

Type: Adp5065TypeChargerStatus1ThermLim
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.ChargerStatus1VINILIM Property

IRD

Adp5065ChargerStatus1VINILIM Property

Charger Status 1: VIN_ILIM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeChargerStatus1VinIlim ChargerStatus1VINILIM { get; }
Public ReadOnly Property ChargerStatus1VINILIM As Adp5065TypeChargerStatus1VinIlim
    Get
public:
property Adp5065TypeChargerStatus1VinIlim ChargerStatus1VINILIM {
    Adp5065TypeChargerStatus1VinIlim get ();
}
member ChargerStatus1VINILIM : Adp5065TypeChargerStatus1VinIlim with get

Property Value

Type: Adp5065TypeChargerStatus1VinIlim
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.ChargerStatus1VINOK Property

IRD

Adp5065ChargerStatus1VINOK Property

Charger Status 1: VIN_OK

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeChargerStatus1VinOk ChargerStatus1VINOK { get; }
Public ReadOnly Property ChargerStatus1VINOK As Adp5065TypeChargerStatus1VinOk
    Get
public:
property Adp5065TypeChargerStatus1VinOk ChargerStatus1VINOK {
    Adp5065TypeChargerStatus1VinOk get ();
}
member ChargerStatus1VINOK : Adp5065TypeChargerStatus1VinOk with get

Property Value

Type: Adp5065TypeChargerStatus1VinOk
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.ChargerStatus1VINOV Property

IRD

Adp5065ChargerStatus1VINOV Property

Charger Status 1: VIN_OV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeChargerStatus1VinOv ChargerStatus1VINOV { get; }
Public ReadOnly Property ChargerStatus1VINOV As Adp5065TypeChargerStatus1VinOv
    Get
public:
property Adp5065TypeChargerStatus1VinOv ChargerStatus1VINOV {
    Adp5065TypeChargerStatus1VinOv get ();
}
member ChargerStatus1VINOV : Adp5065TypeChargerStatus1VinOv with get

Property Value

Type: Adp5065TypeChargerStatus1VinOv
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.ChargerStatus2BATTERYSTATUS Property

IRD

Adp5065ChargerStatus2BATTERYSTATUS Property

Charger Status 2: BATTERY_STATUS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeChargerStatus2BatteryStatus ChargerStatus2BATTERYSTATUS { get; }
Public ReadOnly Property ChargerStatus2BATTERYSTATUS As Adp5065TypeChargerStatus2BatteryStatus
    Get
public:
property Adp5065TypeChargerStatus2BatteryStatus ChargerStatus2BATTERYSTATUS {
    Adp5065TypeChargerStatus2BatteryStatus get ();
}
member ChargerStatus2BATTERYSTATUS : Adp5065TypeChargerStatus2BatteryStatus with get

Property Value

Type: Adp5065TypeChargerStatus2BatteryStatus
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.ChargerStatus2IPKSTAT Property

IRD

Adp5065ChargerStatus2IPKSTAT Property

Charger Status 2: IPK_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeChargerStatus2IpkStat ChargerStatus2IPKSTAT { get; }
Public ReadOnly Property ChargerStatus2IPKSTAT As Adp5065TypeChargerStatus2IpkStat
    Get
public:
property Adp5065TypeChargerStatus2IpkStat ChargerStatus2IPKSTAT {
    Adp5065TypeChargerStatus2IpkStat get ();
}
member ChargerStatus2IPKSTAT : Adp5065TypeChargerStatus2IpkStat with get

Property Value

Type: Adp5065TypeChargerStatus2IpkStat
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.ChargerStatus2THRSTATUS Property

IRD

Adp5065ChargerStatus2THRSTATUS Property

Charger Status 2: THR_STATUS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeChargerStatus2ThrStatus ChargerStatus2THRSTATUS { get; }
Public ReadOnly Property ChargerStatus2THRSTATUS As Adp5065TypeChargerStatus2ThrStatus
    Get
public:
property Adp5065TypeChargerStatus2ThrStatus ChargerStatus2THRSTATUS {
    Adp5065TypeChargerStatus2ThrStatus get ();
}
member ChargerStatus2THRSTATUS : Adp5065TypeChargerStatus2ThrStatus with get

Property Value

Type: Adp5065TypeChargerStatus2ThrStatus
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.ChargingCurrentC10EOC Property

IRD

Adp5065ChargingCurrentC10EOC Property

Charging Current: C/10 EOC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeChargingCurrentEoc ChargingCurrentC10EOC { get; set; }
Public Property ChargingCurrentC10EOC As Adp5065TypeChargingCurrentEoc
    Get
    Set
public:
property Adp5065TypeChargingCurrentEoc ChargingCurrentC10EOC {
    Adp5065TypeChargingCurrentEoc get ();
    void set (Adp5065TypeChargingCurrentEoc value);
}
member ChargingCurrentC10EOC : Adp5065TypeChargingCurrentEoc with get, set

Property Value

Type: Adp5065TypeChargingCurrentEoc
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.ChargingCurrentC20EOC Property

IRD

Adp5065ChargingCurrentC20EOC Property

Charging Current: C/20 EOC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeChargingCurrentEoc ChargingCurrentC20EOC { get; set; }
Public Property ChargingCurrentC20EOC As Adp5065TypeChargingCurrentEoc
    Get
    Set
public:
property Adp5065TypeChargingCurrentEoc ChargingCurrentC20EOC {
    Adp5065TypeChargingCurrentEoc get ();
    void set (Adp5065TypeChargingCurrentEoc value);
}
member ChargingCurrentC20EOC : Adp5065TypeChargingCurrentEoc with get, set

Property Value

Type: Adp5065TypeChargingCurrentEoc
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.ChargingCurrentICHG Property

IRD

Adp5065ChargingCurrentICHG Property

Charging Current: ICHG (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeChargingCurrentIchg ChargingCurrentICHG { get; set; }
Public Property ChargingCurrentICHG As Adp5065TypeChargingCurrentIchg
    Get
    Set
public:
property Adp5065TypeChargingCurrentIchg ChargingCurrentICHG {
    Adp5065TypeChargingCurrentIchg get ();
    void set (Adp5065TypeChargingCurrentIchg value);
}
member ChargingCurrentICHG : Adp5065TypeChargingCurrentIchg with get, set

Property Value

Type: Adp5065TypeChargingCurrentIchg
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.ChargingCurrentITRKDEAD Property

IRD

Adp5065ChargingCurrentITRKDEAD Property

Charging Current: ITRK_DEAD (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeChargingCurrentItrkDead ChargingCurrentITRKDEAD { get; set; }
Public Property ChargingCurrentITRKDEAD As Adp5065TypeChargingCurrentItrkDead
    Get
    Set
public:
property Adp5065TypeChargingCurrentItrkDead ChargingCurrentITRKDEAD {
    Adp5065TypeChargingCurrentItrkDead get ();
    void set (Adp5065TypeChargingCurrentItrkDead value);
}
member ChargingCurrentITRKDEAD : Adp5065TypeChargingCurrentItrkDead with get, set

Property Value

Type: Adp5065TypeChargingCurrentItrkDead
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.FaultBATSHR Property

IRD

Adp5065FaultBATSHR Property

Fault: BAT_SHR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeFaultBatShr FaultBATSHR { get; set; }
Public Property FaultBATSHR As Adp5065TypeFaultBatShr
    Get
    Set
public:
property Adp5065TypeFaultBatShr FaultBATSHR {
    Adp5065TypeFaultBatShr get ();
    void set (Adp5065TypeFaultBatShr value);
}
member FaultBATSHR : Adp5065TypeFaultBatShr with get, set

Property Value

Type: Adp5065TypeFaultBatShr
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.FaultINDPEAKINT Property

IRD

Adp5065FaultINDPEAKINT Property

Fault: IND_PEAK_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeFaultIndPeakInt FaultINDPEAKINT { get; set; }
Public Property FaultINDPEAKINT As Adp5065TypeFaultIndPeakInt
    Get
    Set
public:
property Adp5065TypeFaultIndPeakInt FaultINDPEAKINT {
    Adp5065TypeFaultIndPeakInt get ();
    void set (Adp5065TypeFaultIndPeakInt value);
}
member FaultINDPEAKINT : Adp5065TypeFaultIndPeakInt with get, set

Property Value

Type: Adp5065TypeFaultIndPeakInt
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.FaultTSD130C Property

IRD

Adp5065FaultTSD130C Property

Fault: TSD 130°C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeFaultOverTemp FaultTSD130C { get; set; }
Public Property FaultTSD130C As Adp5065TypeFaultOverTemp
    Get
    Set
public:
property Adp5065TypeFaultOverTemp FaultTSD130C {
    Adp5065TypeFaultOverTemp get ();
    void set (Adp5065TypeFaultOverTemp value);
}
member FaultTSD130C : Adp5065TypeFaultOverTemp with get, set

Property Value

Type: Adp5065TypeFaultOverTemp
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.FaultTSD140C Property

IRD

Adp5065FaultTSD140C Property

Fault: TSD 140°C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeFaultOverTemp FaultTSD140C { get; set; }
Public Property FaultTSD140C As Adp5065TypeFaultOverTemp
    Get
    Set
public:
property Adp5065TypeFaultOverTemp FaultTSD140C {
    Adp5065TypeFaultOverTemp get ();
    void set (Adp5065TypeFaultOverTemp value);
}
member FaultTSD140C : Adp5065TypeFaultOverTemp with get, set

Property Value

Type: Adp5065TypeFaultOverTemp
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.FunctionalSettings1DISIPKSD Property

IRD

Adp5065FunctionalSettings1DISIPKSD Property

Functional Settings 1: DIS_IPK_SD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeFunctionalSettings1DisIpkSd FunctionalSettings1DISIPKSD { get; set; }
Public Property FunctionalSettings1DISIPKSD As Adp5065TypeFunctionalSettings1DisIpkSd
    Get
    Set
public:
property Adp5065TypeFunctionalSettings1DisIpkSd FunctionalSettings1DISIPKSD {
    Adp5065TypeFunctionalSettings1DisIpkSd get ();
    void set (Adp5065TypeFunctionalSettings1DisIpkSd value);
}
member FunctionalSettings1DISIPKSD : Adp5065TypeFunctionalSettings1DisIpkSd with get, set

Property Value

Type: Adp5065TypeFunctionalSettings1DisIpkSd
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.FunctionalSettings1ENBMON Property

IRD

Adp5065FunctionalSettings1ENBMON Property

Functional Settings 1: EN_BMON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeFunctionalSettings1EnBmon FunctionalSettings1ENBMON { get; set; }
Public Property FunctionalSettings1ENBMON As Adp5065TypeFunctionalSettings1EnBmon
    Get
    Set
public:
property Adp5065TypeFunctionalSettings1EnBmon FunctionalSettings1ENBMON {
    Adp5065TypeFunctionalSettings1EnBmon get ();
    void set (Adp5065TypeFunctionalSettings1EnBmon value);
}
member FunctionalSettings1ENBMON : Adp5065TypeFunctionalSettings1EnBmon with get, set

Property Value

Type: Adp5065TypeFunctionalSettings1EnBmon
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.FunctionalSettings1ENCHG Property

IRD

Adp5065FunctionalSettings1ENCHG Property

Functional Settings 1: EN_CHG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeFunctionalSettings1EnChg FunctionalSettings1ENCHG { get; set; }
Public Property FunctionalSettings1ENCHG As Adp5065TypeFunctionalSettings1EnChg
    Get
    Set
public:
property Adp5065TypeFunctionalSettings1EnChg FunctionalSettings1ENCHG {
    Adp5065TypeFunctionalSettings1EnChg get ();
    void set (Adp5065TypeFunctionalSettings1EnChg value);
}
member FunctionalSettings1ENCHG : Adp5065TypeFunctionalSettings1EnChg with get, set

Property Value

Type: Adp5065TypeFunctionalSettings1EnChg
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.FunctionalSettings1ENEOC Property

IRD

Adp5065FunctionalSettings1ENEOC Property

Functional Settings 1: EN_EOC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeFunctionalSettings1EnEoc FunctionalSettings1ENEOC { get; set; }
Public Property FunctionalSettings1ENEOC As Adp5065TypeFunctionalSettings1EnEoc
    Get
    Set
public:
property Adp5065TypeFunctionalSettings1EnEoc FunctionalSettings1ENEOC {
    Adp5065TypeFunctionalSettings1EnEoc get ();
    void set (Adp5065TypeFunctionalSettings1EnEoc value);
}
member FunctionalSettings1ENEOC : Adp5065TypeFunctionalSettings1EnEoc with get, set

Property Value

Type: Adp5065TypeFunctionalSettings1EnEoc
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.FunctionalSettings1ENJEITA Property

IRD

Adp5065FunctionalSettings1ENJEITA Property

Functional Settings 1: EN_JEITA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeFunctionalSettings1EnJeita FunctionalSettings1ENJEITA { get; set; }
Public Property FunctionalSettings1ENJEITA As Adp5065TypeFunctionalSettings1EnJeita
    Get
    Set
public:
property Adp5065TypeFunctionalSettings1EnJeita FunctionalSettings1ENJEITA {
    Adp5065TypeFunctionalSettings1EnJeita get ();
    void set (Adp5065TypeFunctionalSettings1EnJeita value);
}
member FunctionalSettings1ENJEITA : Adp5065TypeFunctionalSettings1EnJeita with get, set

Property Value

Type: Adp5065TypeFunctionalSettings1EnJeita
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.FunctionalSettings1ENTHR Property

IRD

Adp5065FunctionalSettings1ENTHR Property

Functional Settings 1: EN_THR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeFunctionalSettings1EnThr FunctionalSettings1ENTHR { get; set; }
Public Property FunctionalSettings1ENTHR As Adp5065TypeFunctionalSettings1EnThr
    Get
    Set
public:
property Adp5065TypeFunctionalSettings1EnThr FunctionalSettings1ENTHR {
    Adp5065TypeFunctionalSettings1EnThr get ();
    void set (Adp5065TypeFunctionalSettings1EnThr value);
}
member FunctionalSettings1ENTHR : Adp5065TypeFunctionalSettings1EnThr with get, set

Property Value

Type: Adp5065TypeFunctionalSettings1EnThr
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.FunctionalSettings1ENTRK Property

IRD

Adp5065FunctionalSettings1ENTRK Property

Functional Settings 1: EN_TRK

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeFunctionalSettings1EnTrk FunctionalSettings1ENTRK { get; set; }
Public Property FunctionalSettings1ENTRK As Adp5065TypeFunctionalSettings1EnTrk
    Get
    Set
public:
property Adp5065TypeFunctionalSettings1EnTrk FunctionalSettings1ENTRK {
    Adp5065TypeFunctionalSettings1EnTrk get ();
    void set (Adp5065TypeFunctionalSettings1EnTrk value);
}
member FunctionalSettings1ENTRK : Adp5065TypeFunctionalSettings1EnTrk with get, set

Property Value

Type: Adp5065TypeFunctionalSettings1EnTrk
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.InterruptActiveBATINT Property

IRD

Adp5065InterruptActiveBATINT Property

Interrupt Active: BAT_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeInterruptActive InterruptActiveBATINT { get; }
Public ReadOnly Property InterruptActiveBATINT As Adp5065TypeInterruptActive
    Get
public:
property Adp5065TypeInterruptActive InterruptActiveBATINT {
    Adp5065TypeInterruptActive get ();
}
member InterruptActiveBATINT : Adp5065TypeInterruptActive with get

Property Value

Type: Adp5065TypeInterruptActive
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.InterruptActiveCHGINT Property

IRD

Adp5065InterruptActiveCHGINT Property

Interrupt Active: CHG_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeInterruptActive InterruptActiveCHGINT { get; }
Public ReadOnly Property InterruptActiveCHGINT As Adp5065TypeInterruptActive
    Get
public:
property Adp5065TypeInterruptActive InterruptActiveCHGINT {
    Adp5065TypeInterruptActive get ();
}
member InterruptActiveCHGINT : Adp5065TypeInterruptActive with get

Property Value

Type: Adp5065TypeInterruptActive
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.InterruptActiveINDPEAKINT Property

IRD

Adp5065InterruptActiveINDPEAKINT Property

Interrupt Active: IND_PEAK_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeInterruptActive InterruptActiveINDPEAKINT { get; }
Public ReadOnly Property InterruptActiveINDPEAKINT As Adp5065TypeInterruptActive
    Get
public:
property Adp5065TypeInterruptActive InterruptActiveINDPEAKINT {
    Adp5065TypeInterruptActive get ();
}
member InterruptActiveINDPEAKINT : Adp5065TypeInterruptActive with get

Property Value

Type: Adp5065TypeInterruptActive
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.InterruptActiveTHERMLIMINT Property

IRD

Adp5065InterruptActiveTHERMLIMINT Property

Interrupt Active: THERM_LIM_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeInterruptActive InterruptActiveTHERMLIMINT { get; }
Public ReadOnly Property InterruptActiveTHERMLIMINT As Adp5065TypeInterruptActive
    Get
public:
property Adp5065TypeInterruptActive InterruptActiveTHERMLIMINT {
    Adp5065TypeInterruptActive get ();
}
member InterruptActiveTHERMLIMINT : Adp5065TypeInterruptActive with get

Property Value

Type: Adp5065TypeInterruptActive
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.InterruptActiveTHRINT Property

IRD

Adp5065InterruptActiveTHRINT Property

Interrupt Active: THR_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeInterruptActive InterruptActiveTHRINT { get; }
Public ReadOnly Property InterruptActiveTHRINT As Adp5065TypeInterruptActive
    Get
public:
property Adp5065TypeInterruptActive InterruptActiveTHRINT {
    Adp5065TypeInterruptActive get ();
}
member InterruptActiveTHRINT : Adp5065TypeInterruptActive with get

Property Value

Type: Adp5065TypeInterruptActive
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.InterruptActiveTSDINT Property

IRD

Adp5065InterruptActiveTSDINT Property

Interrupt Active: TSD_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeInterruptActive InterruptActiveTSDINT { get; }
Public ReadOnly Property InterruptActiveTSDINT As Adp5065TypeInterruptActive
    Get
public:
property Adp5065TypeInterruptActive InterruptActiveTSDINT {
    Adp5065TypeInterruptActive get ();
}
member InterruptActiveTSDINT : Adp5065TypeInterruptActive with get

Property Value

Type: Adp5065TypeInterruptActive
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.InterruptActiveVININT Property

IRD

Adp5065InterruptActiveVININT Property

Interrupt Active: VIN_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeInterruptActive InterruptActiveVININT { get; }
Public ReadOnly Property InterruptActiveVININT As Adp5065TypeInterruptActive
    Get
public:
property Adp5065TypeInterruptActive InterruptActiveVININT {
    Adp5065TypeInterruptActive get ();
}
member InterruptActiveVININT : Adp5065TypeInterruptActive with get

Property Value

Type: Adp5065TypeInterruptActive
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.InterruptActiveWDINT Property

IRD

Adp5065InterruptActiveWDINT Property

Interrupt Active: WD_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeInterruptActive InterruptActiveWDINT { get; }
Public ReadOnly Property InterruptActiveWDINT As Adp5065TypeInterruptActive
    Get
public:
property Adp5065TypeInterruptActive InterruptActiveWDINT {
    Adp5065TypeInterruptActive get ();
}
member InterruptActiveWDINT : Adp5065TypeInterruptActive with get

Property Value

Type: Adp5065TypeInterruptActive
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.InterruptEnableENBATINT Property

IRD

Adp5065InterruptEnableENBATINT Property

Interrupt Enable: EN_BAT_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeInterruptEnable InterruptEnableENBATINT { get; set; }
Public Property InterruptEnableENBATINT As Adp5065TypeInterruptEnable
    Get
    Set
public:
property Adp5065TypeInterruptEnable InterruptEnableENBATINT {
    Adp5065TypeInterruptEnable get ();
    void set (Adp5065TypeInterruptEnable value);
}
member InterruptEnableENBATINT : Adp5065TypeInterruptEnable with get, set

Property Value

Type: Adp5065TypeInterruptEnable
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.InterruptEnableENCHGINT Property

IRD

Adp5065InterruptEnableENCHGINT Property

Interrupt Enable: EN_CHG_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeInterruptEnable InterruptEnableENCHGINT { get; set; }
Public Property InterruptEnableENCHGINT As Adp5065TypeInterruptEnable
    Get
    Set
public:
property Adp5065TypeInterruptEnable InterruptEnableENCHGINT {
    Adp5065TypeInterruptEnable get ();
    void set (Adp5065TypeInterruptEnable value);
}
member InterruptEnableENCHGINT : Adp5065TypeInterruptEnable with get, set

Property Value

Type: Adp5065TypeInterruptEnable
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.InterruptEnableENINDPEAKINT Property

IRD

Adp5065InterruptEnableENINDPEAKINT Property

Interrupt Enable: EN_IND_PEAK_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeInterruptEnable InterruptEnableENINDPEAKINT { get; set; }
Public Property InterruptEnableENINDPEAKINT As Adp5065TypeInterruptEnable
    Get
    Set
public:
property Adp5065TypeInterruptEnable InterruptEnableENINDPEAKINT {
    Adp5065TypeInterruptEnable get ();
    void set (Adp5065TypeInterruptEnable value);
}
member InterruptEnableENINDPEAKINT : Adp5065TypeInterruptEnable with get, set

Property Value

Type: Adp5065TypeInterruptEnable
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.InterruptEnableENTHERMLIMINT Property

IRD

Adp5065InterruptEnableENTHERMLIMINT Property

Interrupt Enable: EN_THERM_LIM_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeInterruptEnable InterruptEnableENTHERMLIMINT { get; set; }
Public Property InterruptEnableENTHERMLIMINT As Adp5065TypeInterruptEnable
    Get
    Set
public:
property Adp5065TypeInterruptEnable InterruptEnableENTHERMLIMINT {
    Adp5065TypeInterruptEnable get ();
    void set (Adp5065TypeInterruptEnable value);
}
member InterruptEnableENTHERMLIMINT : Adp5065TypeInterruptEnable with get, set

Property Value

Type: Adp5065TypeInterruptEnable
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.InterruptEnableENTHRINT Property

IRD

Adp5065InterruptEnableENTHRINT Property

Interrupt Enable: EN_THR_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeInterruptEnable InterruptEnableENTHRINT { get; set; }
Public Property InterruptEnableENTHRINT As Adp5065TypeInterruptEnable
    Get
    Set
public:
property Adp5065TypeInterruptEnable InterruptEnableENTHRINT {
    Adp5065TypeInterruptEnable get ();
    void set (Adp5065TypeInterruptEnable value);
}
member InterruptEnableENTHRINT : Adp5065TypeInterruptEnable with get, set

Property Value

Type: Adp5065TypeInterruptEnable
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.InterruptEnableENTSDINT Property

IRD

Adp5065InterruptEnableENTSDINT Property

Interrupt Enable: EN_TSD_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeInterruptEnable InterruptEnableENTSDINT { get; set; }
Public Property InterruptEnableENTSDINT As Adp5065TypeInterruptEnable
    Get
    Set
public:
property Adp5065TypeInterruptEnable InterruptEnableENTSDINT {
    Adp5065TypeInterruptEnable get ();
    void set (Adp5065TypeInterruptEnable value);
}
member InterruptEnableENTSDINT : Adp5065TypeInterruptEnable with get, set

Property Value

Type: Adp5065TypeInterruptEnable
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.InterruptEnableENVININT Property

IRD

Adp5065InterruptEnableENVININT Property

Interrupt Enable: EN_VIN_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeInterruptEnable InterruptEnableENVININT { get; set; }
Public Property InterruptEnableENVININT As Adp5065TypeInterruptEnable
    Get
    Set
public:
property Adp5065TypeInterruptEnable InterruptEnableENVININT {
    Adp5065TypeInterruptEnable get ();
    void set (Adp5065TypeInterruptEnable value);
}
member InterruptEnableENVININT : Adp5065TypeInterruptEnable with get, set

Property Value

Type: Adp5065TypeInterruptEnable
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.InterruptEnableENWDINT Property

IRD

Adp5065InterruptEnableENWDINT Property

Interrupt Enable: EN_WD_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeInterruptEnable InterruptEnableENWDINT { get; set; }
Public Property InterruptEnableENWDINT As Adp5065TypeInterruptEnable
    Get
    Set
public:
property Adp5065TypeInterruptEnable InterruptEnableENWDINT {
    Adp5065TypeInterruptEnable get ();
    void set (Adp5065TypeInterruptEnable value);
}
member InterruptEnableENWDINT : Adp5065TypeInterruptEnable with get, set

Property Value

Type: Adp5065TypeInterruptEnable
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.ManufacturerAndModelIDMANUF Property

IRD

Adp5065ManufacturerAndModelIDMANUF Property

Manufacturer and Model ID: MANUF

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerAndModelIDMANUF { get; }
Public ReadOnly Property ManufacturerAndModelIDMANUF As Byte
    Get
public:
property unsigned char ManufacturerAndModelIDMANUF {
    unsigned char get ();
}
member ManufacturerAndModelIDMANUF : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.ManufacturerAndModelIDMODEL Property

IRD

Adp5065ManufacturerAndModelIDMODEL Property

Manufacturer and Model ID: MODEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerAndModelIDMODEL { get; }
Public ReadOnly Property ManufacturerAndModelIDMODEL As Byte
    Get
public:
property unsigned char ManufacturerAndModelIDMODEL {
    unsigned char get ();
}
member ManufacturerAndModelIDMODEL : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.SiliconRevisionREV Property

IRD

Adp5065SiliconRevisionREV Property

Silicon Revision: REV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SiliconRevisionREV { get; }
Public ReadOnly Property SiliconRevisionREV As Byte
    Get
public:
property unsigned char SiliconRevisionREV {
    unsigned char get ();
}
member SiliconRevisionREV : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.TerminationSettingsIEND Property

IRD

Adp5065TerminationSettingsIEND Property

Termination Settings: IEND (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeTerminationSettingsIend TerminationSettingsIEND { get; set; }
Public Property TerminationSettingsIEND As Adp5065TypeTerminationSettingsIend
    Get
    Set
public:
property Adp5065TypeTerminationSettingsIend TerminationSettingsIEND {
    Adp5065TypeTerminationSettingsIend get ();
    void set (Adp5065TypeTerminationSettingsIend value);
}
member TerminationSettingsIEND : Adp5065TypeTerminationSettingsIend with get, set

Property Value

Type: Adp5065TypeTerminationSettingsIend
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.TerminationSettingsVTRM Property

IRD

Adp5065TerminationSettingsVTRM Property

Termination Settings: VTRM (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeTerminationSettingsVtrm TerminationSettingsVTRM { get; set; }
Public Property TerminationSettingsVTRM As Adp5065TypeTerminationSettingsVtrm
    Get
    Set
public:
property Adp5065TypeTerminationSettingsVtrm TerminationSettingsVTRM {
    Adp5065TypeTerminationSettingsVtrm get ();
    void set (Adp5065TypeTerminationSettingsVtrm value);
}
member TerminationSettingsVTRM : Adp5065TypeTerminationSettingsVtrm with get, set

Property Value

Type: Adp5065TypeTerminationSettingsVtrm
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.TimerSettingsCHGTMRPERIOD Property

IRD

Adp5065TimerSettingsCHGTMRPERIOD Property

Timer Settings: CHG_TMR_PERIOD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeTimerSettingsChgTmrPeriod TimerSettingsCHGTMRPERIOD { get; set; }
Public Property TimerSettingsCHGTMRPERIOD As Adp5065TypeTimerSettingsChgTmrPeriod
    Get
    Set
public:
property Adp5065TypeTimerSettingsChgTmrPeriod TimerSettingsCHGTMRPERIOD {
    Adp5065TypeTimerSettingsChgTmrPeriod get ();
    void set (Adp5065TypeTimerSettingsChgTmrPeriod value);
}
member TimerSettingsCHGTMRPERIOD : Adp5065TypeTimerSettingsChgTmrPeriod with get, set

Property Value

Type: Adp5065TypeTimerSettingsChgTmrPeriod
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.TimerSettingsENCHGTIMER Property

IRD

Adp5065TimerSettingsENCHGTIMER Property

Timer Settings: EN_CHG_TIMER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeTimerSettingsEnChgTimer TimerSettingsENCHGTIMER { get; set; }
Public Property TimerSettingsENCHGTIMER As Adp5065TypeTimerSettingsEnChgTimer
    Get
    Set
public:
property Adp5065TypeTimerSettingsEnChgTimer TimerSettingsENCHGTIMER {
    Adp5065TypeTimerSettingsEnChgTimer get ();
    void set (Adp5065TypeTimerSettingsEnChgTimer value);
}
member TimerSettingsENCHGTIMER : Adp5065TypeTimerSettingsEnChgTimer with get, set

Property Value

Type: Adp5065TypeTimerSettingsEnChgTimer
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.TimerSettingsENTEND Property

IRD

Adp5065TimerSettingsENTEND Property

Timer Settings: EN_TEND

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeTimerSettingsEnTend TimerSettingsENTEND { get; set; }
Public Property TimerSettingsENTEND As Adp5065TypeTimerSettingsEnTend
    Get
    Set
public:
property Adp5065TypeTimerSettingsEnTend TimerSettingsENTEND {
    Adp5065TypeTimerSettingsEnTend get ();
    void set (Adp5065TypeTimerSettingsEnTend value);
}
member TimerSettingsENTEND : Adp5065TypeTimerSettingsEnTend with get, set

Property Value

Type: Adp5065TypeTimerSettingsEnTend
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.TimerSettingsENWD Property

IRD

Adp5065TimerSettingsENWD Property

Timer Settings: EN_WD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeTimerSettingsEnWd TimerSettingsENWD { get; set; }
Public Property TimerSettingsENWD As Adp5065TypeTimerSettingsEnWd
    Get
    Set
public:
property Adp5065TypeTimerSettingsEnWd TimerSettingsENWD {
    Adp5065TypeTimerSettingsEnWd get ();
    void set (Adp5065TypeTimerSettingsEnWd value);
}
member TimerSettingsENWD : Adp5065TypeTimerSettingsEnWd with get, set

Property Value

Type: Adp5065TypeTimerSettingsEnWd
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.TimerSettingsRESETWD Property

IRD

Adp5065TimerSettingsRESETWD Property

Timer Settings: RESET_WD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeTimerSettingsResetWd TimerSettingsRESETWD { set; }
Public WriteOnly Property TimerSettingsRESETWD As Adp5065TypeTimerSettingsResetWd
    Set
public:
property Adp5065TypeTimerSettingsResetWd TimerSettingsRESETWD {
    void set (Adp5065TypeTimerSettingsResetWd value);
}
member TimerSettingsRESETWD : Adp5065TypeTimerSettingsResetWd with set

Property Value

Type: Adp5065TypeTimerSettingsResetWd
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.TimerSettingsWDPERIOD Property

IRD

Adp5065TimerSettingsWDPERIOD Property

Timer Settings: WD_PERIOD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeTimerSettingsWdPeriod TimerSettingsWDPERIOD { get; set; }
Public Property TimerSettingsWDPERIOD As Adp5065TypeTimerSettingsWdPeriod
    Get
    Set
public:
property Adp5065TypeTimerSettingsWdPeriod TimerSettingsWDPERIOD {
    Adp5065TypeTimerSettingsWdPeriod get ();
    void set (Adp5065TypeTimerSettingsWdPeriod value);
}
member TimerSettingsWDPERIOD : Adp5065TypeTimerSettingsWdPeriod with get, set

Property Value

Type: Adp5065TypeTimerSettingsWdPeriod
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.VINxPinsSettingsILIM Property

IRD

Adp5065VINxPinsSettingsILIM Property

VINx Pins Settings: ILIM (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeVpinxPinsSettingsIlim VINxPinsSettingsILIM { get; set; }
Public Property VINxPinsSettingsILIM As Adp5065TypeVpinxPinsSettingsIlim
    Get
    Set
public:
property Adp5065TypeVpinxPinsSettingsIlim VINxPinsSettingsILIM {
    Adp5065TypeVpinxPinsSettingsIlim get ();
    void set (Adp5065TypeVpinxPinsSettingsIlim value);
}
member VINxPinsSettingsILIM : Adp5065TypeVpinxPinsSettingsIlim with get, set

Property Value

Type: Adp5065TypeVpinxPinsSettingsIlim
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.VINxPinsSettingsRFU Property

IRD

Adp5065VINxPinsSettingsRFU Property

VINx Pins Settings: RFU

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VINxPinsSettingsRFU { get; set; }
Public Property VINxPinsSettingsRFU As Byte
    Get
    Set
public:
property unsigned char VINxPinsSettingsRFU {
    unsigned char get ();
    void set (unsigned char value);
}
member VINxPinsSettingsRFU : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.VoltageThresholdsVRCH Property

IRD

Adp5065VoltageThresholdsVRCH Property

Voltage Thresholds: VRCH (unit: mV)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeVoltageThresholdsVrch VoltageThresholdsVRCH { get; set; }
Public Property VoltageThresholdsVRCH As Adp5065TypeVoltageThresholdsVrch
    Get
    Set
public:
property Adp5065TypeVoltageThresholdsVrch VoltageThresholdsVRCH {
    Adp5065TypeVoltageThresholdsVrch get ();
    void set (Adp5065TypeVoltageThresholdsVrch value);
}
member VoltageThresholdsVRCH : Adp5065TypeVoltageThresholdsVrch with get, set

Property Value

Type: Adp5065TypeVoltageThresholdsVrch
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.VoltageThresholdsVTRKDEAD Property

IRD

Adp5065VoltageThresholdsVTRKDEAD Property

Voltage Thresholds: VTRK_DEAD (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeVoltageThresholdsVtrkDead VoltageThresholdsVTRKDEAD { get; set; }
Public Property VoltageThresholdsVTRKDEAD As Adp5065TypeVoltageThresholdsVtrkDead
    Get
    Set
public:
property Adp5065TypeVoltageThresholdsVtrkDead VoltageThresholdsVTRKDEAD {
    Adp5065TypeVoltageThresholdsVtrkDead get ();
    void set (Adp5065TypeVoltageThresholdsVtrkDead value);
}
member VoltageThresholdsVTRKDEAD : Adp5065TypeVoltageThresholdsVtrkDead with get, set

Property Value

Type: Adp5065TypeVoltageThresholdsVtrkDead
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.VoltageThresholdsVWEAK Property

IRD

Adp5065VoltageThresholdsVWEAK Property

Voltage Thresholds: VWEAK (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5065TypeVoltageThresholdsVweak VoltageThresholdsVWEAK { get; set; }
Public Property VoltageThresholdsVWEAK As Adp5065TypeVoltageThresholdsVweak
    Get
    Set
public:
property Adp5065TypeVoltageThresholdsVweak VoltageThresholdsVWEAK {
    Adp5065TypeVoltageThresholdsVweak get ();
    void set (Adp5065TypeVoltageThresholdsVweak value);
}
member VoltageThresholdsVWEAK : Adp5065TypeVoltageThresholdsVweak with get, set

Property Value

Type: Adp5065TypeVoltageThresholdsVweak
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065 Methods

The Adp5065 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.Flush Method

IRD

Adp5065Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adp5065 Class
telos.Ird.AnalogDevices Namespace


Adp5065.TypeBatteryShortTbatShr Enumeration

IRD

Adp5065TypeBatteryShortTbatShr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBatteryShortTbatShr
Public Enumeration TypeBatteryShortTbatShr
public enum class TypeBatteryShortTbatShr
type TypeBatteryShortTbatShr
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_2 | 1 | 2
Value_4 | 2 | 4
Value_10 | 3 | 10
Value_30 | 4 | 30
Value_60 | 5 | 60
Value_120 | 6 | 120
Value_180 | 7 | 180
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeBatteryShortVbatShr Enumeration

IRD

Adp5065TypeBatteryShortVbatShr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBatteryShortVbatShr
Public Enumeration TypeBatteryShortVbatShr
public enum class TypeBatteryShortVbatShr
type TypeBatteryShortVbatShr
Members
Member name | Value | Description
Value_2_0 | 0 | 2.0
Value_2_1 | 1 | 2.1
Value_2_2 | 2 | 2.2
Value_2_3 | 3 | 2.3
Value_2_4 | 4 | 2.4
Value_2_5 | 5 | 2.5
Value_2_6 | 6 | 2.6
Value_2_7 | 7 | 2.7
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeChargerStatus1ChargerStatus Enumeration

IRD

Adp5065TypeChargerStatus1ChargerStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus1ChargerStatus
Public Enumeration TypeChargerStatus1ChargerStatus
public enum class TypeChargerStatus1ChargerStatus
type TypeChargerStatus1ChargerStatus
Members
Member name | Value | Description
Off | 0 | Off
TrickleCharge | 1 | Trickle Charge
FastChargeCCMode | 2 | Fast Charge (CC Mode)
FastChargeCVMode | 3 | Fast Charge (CV Mode)
ChargeComplete | 4 | Charge Complete
Suspend | 5 | Suspend
TrickleOrFastChargeTimerExpired | 6 | Trickle Or Fast Charge Timer Expired
BatteryDetection | 7 | Battery Detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeChargerStatus1Chdone Enumeration

IRD

Adp5065TypeChargerStatus1Chdone Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus1Chdone
Public Enumeration TypeChargerStatus1Chdone
public enum class TypeChargerStatus1Chdone
type TypeChargerStatus1Chdone
Members
Member name | Value | Description
EndOfChargeCycleNotReached | 0 | End Of Charge Cycle: Not Reached
EndOfChargeCycleReached | 1 | End Of Charge Cycle: Reached
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeChargerStatus1ThermLim Enumeration

IRD

Adp5065TypeChargerStatus1ThermLim Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus1ThermLim
Public Enumeration TypeChargerStatus1ThermLim
public enum class TypeChargerStatus1ThermLim
type TypeChargerStatus1ThermLim
Members
Member name | Value | Description
NotLimitedByTemperature | 0 | Not Limited By Temperature
LimitedByTemperature | 1 | Limited By Temperature
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeChargerStatus1VinIlim Enumeration

IRD

Adp5065TypeChargerStatus1VinIlim Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus1VinIlim
Public Enumeration TypeChargerStatus1VinIlim
public enum class TypeChargerStatus1VinIlim
type TypeChargerStatus1VinIlim
Members
Member name | Value | Description
VINxCurrentNotLimited | 0 | VINx Current: Not Limited
VINxCurrentLimited | 1 | VINx Current: Limited
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeChargerStatus1VinOk Enumeration

IRD

Adp5065TypeChargerStatus1VinOk Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus1VinOk
Public Enumeration TypeChargerStatus1VinOk
public enum class TypeChargerStatus1VinOk
type TypeChargerStatus1VinOk
Members
Member name | Value | Description
VINxVVINOK | 0 | VINx <= V_VIN_OK
VINxVVINOK__1 | 1 | VINx > V_VIN_OK
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeChargerStatus1VinOv Enumeration

IRD

Adp5065TypeChargerStatus1VinOv Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus1VinOv
Public Enumeration TypeChargerStatus1VinOv
public enum class TypeChargerStatus1VinOv
type TypeChargerStatus1VinOv
Members
Member name | Value | Description
VINxVVINOV | 0 | VINx <= V_VIN_OV
VINxVVINOV__1 | 1 | VINx > V_VIN_OV
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeChargerStatus2BatteryStatus Enumeration

IRD

Adp5065TypeChargerStatus2BatteryStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus2BatteryStatus
Public Enumeration TypeChargerStatus2BatteryStatus
public enum class TypeChargerStatus2BatteryStatus
type TypeChargerStatus2BatteryStatus
Members
Member name | Value | Description
BatteryMonitorOff | 0 | Battery Monitor Off
NoBattery | 1 | No Battery
VBATSNSVTRK | 2 | V_BAT_SNS < V_TRK
VTRKVBATSNSVWEAK | 3 | V_TRK <= V_BAT_SNS < V_WEAK
VBATSNSVWEAK | 4 | V_BAT_SNS >= V_WEAK
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeChargerStatus2IpkStat Enumeration

IRD

Adp5065TypeChargerStatus2IpkStat Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus2IpkStat
Public Enumeration TypeChargerStatus2IpkStat
public enum class TypeChargerStatus2IpkStat
type TypeChargerStatus2IpkStat
Members
Member name | Value | Description
PeakCurrentNotReached | 0 | Peak Current: Not Reached
PeakCurrentReached | 1 | Peak Current: Reached
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeChargerStatus2ThrStatus Enumeration

IRD

Adp5065TypeChargerStatus2ThrStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargerStatus2ThrStatus
Public Enumeration TypeChargerStatus2ThrStatus
public enum class TypeChargerStatus2ThrStatus
type TypeChargerStatus2ThrStatus
Members
Member name | Value | Description
Off | 0 | Off
BatteryCold | 1 | Battery Cold
BatteryCool | 2 | Battery Cool
BatteryWarm | 3 | Battery Warm
BatteryHot | 4 | Battery Hot
ThermistorOK | 7 | Thermistor OK
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeChargingCurrentEoc Enumeration

IRD

Adp5065TypeChargingCurrentEoc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargingCurrentEoc
Public Enumeration TypeChargingCurrentEoc
public enum class TypeChargingCurrentEoc
type TypeChargingCurrentEoc
Members
Member name | Value | Description
NotSet | 0 | Not Set
Set | 1 | Set
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeChargingCurrentIchg Enumeration

IRD

Adp5065TypeChargingCurrentIchg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargingCurrentIchg
Public Enumeration TypeChargingCurrentIchg
public enum class TypeChargingCurrentIchg
type TypeChargingCurrentIchg
Members
Member name | Value | Description
Value_550 | 0 | 550
Value_650 | 1 | 650
Value_750 | 2 | 750
Value_850 | 3 | 850
Value_950 | 4 | 950
Value_1050 | 5 | 1050
Value_1150 | 6 | 1150
Value_1250 | 7 | 1250
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeChargingCurrentItrkDead Enumeration

IRD

Adp5065TypeChargingCurrentItrkDead Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargingCurrentItrkDead
Public Enumeration TypeChargingCurrentItrkDead
public enum class TypeChargingCurrentItrkDead
type TypeChargingCurrentItrkDead
Members
Member name | Value | Description
Value_5 | 0 | 5
Value_10 | 1 | 10
Value_20 | 2 | 20
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeFaultBatShr Enumeration

IRD

Adp5065TypeFaultBatShr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultBatShr
Public Enumeration TypeFaultBatShr
public enum class TypeFaultBatShr
type TypeFaultBatShr
Members
Member name | Value | Description
BatteryNotShort | 0 | Battery: Not Short
BatteryShort | 1 | Battery: Short
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeFaultIndPeakInt Enumeration

IRD

Adp5065TypeFaultIndPeakInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultIndPeakInt
Public Enumeration TypeFaultIndPeakInt
public enum class TypeFaultIndPeakInt
type TypeFaultIndPeakInt
Members
Member name | Value | Description
PeakCurrentLimitNotOccurred | 0 | Peak Current Limit: Not Occurred
PeakCurrentLimitOccurred | 1 | Peak Current Limit: Occurred
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeFaultOverTemp Enumeration

IRD

Adp5065TypeFaultOverTemp Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultOverTemp
Public Enumeration TypeFaultOverTemp
public enum class TypeFaultOverTemp
type TypeFaultOverTemp
Members
Member name | Value | Description
NoOvertemperature | 0 | No Overtemperature
Overtemperature | 1 | Overtemperature
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeFunctionalSettings1DisIpkSd Enumeration

IRD

Adp5065TypeFunctionalSettings1DisIpkSd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1DisIpkSd
Public Enumeration TypeFunctionalSettings1DisIpkSd
public enum class TypeFunctionalSettings1DisIpkSd
type TypeFunctionalSettings1DisIpkSd
Members
Member name | Value | Description
AutomaticShutdownEnabled | 0 | Automatic Shutdown: Enabled
AutomaticShutdownDisabled | 1 | Automatic Shutdown: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeFunctionalSettings1EnBmon Enumeration

IRD

Adp5065TypeFunctionalSettings1EnBmon Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1EnBmon
Public Enumeration TypeFunctionalSettings1EnBmon
public enum class TypeFunctionalSettings1EnBmon
type TypeFunctionalSettings1EnBmon
Members
Member name | Value | Description
BatteryMonitorVVINxVVINOKDisabled | 0 | Battery Monitor (V_VINx < V_VIN_OK): Disabled
BatteryMonitorVVINxVVINOKEnabled | 1 | Battery Monitor (V_VINx < V_VIN_OK): Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeFunctionalSettings1EnChg Enumeration

IRD

Adp5065TypeFunctionalSettings1EnChg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1EnChg
Public Enumeration TypeFunctionalSettings1EnChg
public enum class TypeFunctionalSettings1EnChg
type TypeFunctionalSettings1EnChg
Members
Member name | Value | Description
DCToDCConverterDisabled | 0 | DC-to-DC Converter: Disabled
DCToDCConverterEnabled | 1 | DC-to-DC Converter: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeFunctionalSettings1EnEoc Enumeration

IRD

Adp5065TypeFunctionalSettings1EnEoc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1EnEoc
Public Enumeration TypeFunctionalSettings1EnEoc
public enum class TypeFunctionalSettings1EnEoc
type TypeFunctionalSettings1EnEoc
Members
Member name | Value | Description
EndOfChargeNotAllowed | 0 | End Of Charge: Not Allowed
EndOfChargeAllowed | 1 | End Of Charge: Allowed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeFunctionalSettings1EnJeita Enumeration

IRD

Adp5065TypeFunctionalSettings1EnJeita Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1EnJeita
Public Enumeration TypeFunctionalSettings1EnJeita
public enum class TypeFunctionalSettings1EnJeita
type TypeFunctionalSettings1EnJeita
Members
Member name | Value | Description
JEITAComplianceDisabled | 0 | JEITA Compliance: Disabled
JEITAComplianceEnabled | 1 | JEITA Compliance: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeFunctionalSettings1EnThr Enumeration

IRD

Adp5065TypeFunctionalSettings1EnThr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1EnThr
Public Enumeration TypeFunctionalSettings1EnThr
public enum class TypeFunctionalSettings1EnThr
type TypeFunctionalSettings1EnThr
Members
Member name | Value | Description
THRCurrentSourceVVINxVVINOKDisabled | 0 | THR Current Source (V_VINx < V_VIN_OK): Disabled
THRCurrentSourceVVINxVVINOKEnabled | 1 | THR Current Source (V_VINx < V_VIN_OK): Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeFunctionalSettings1EnTrk Enumeration

IRD

Adp5065TypeFunctionalSettings1EnTrk Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFunctionalSettings1EnTrk
Public Enumeration TypeFunctionalSettings1EnTrk
public enum class TypeFunctionalSettings1EnTrk
type TypeFunctionalSettings1EnTrk
Members
Member name | Value | Description
TrickleChargerDisabledDCToDCConverterEnabled | 0 | Trickle Charger: Disabled / DC-to-DC Converter: Enabled
TrickleChargerEnabledDCToDCConverterDisabled | 1 | Trickle Charger: Enabled / DC-to-DC Converter: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeInterruptActive Enumeration

IRD

Adp5065TypeInterruptActive Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptActive
Public Enumeration TypeInterruptActive
public enum class TypeInterruptActive
type TypeInterruptActive
Members
Member name | Value | Description
InterruptNotTriggered | 0 | Interrupt: Not Triggered
InterruptTriggered | 1 | Interrupt: Triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeInterruptEnable Enumeration

IRD

Adp5065TypeInterruptEnable Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnable
Public Enumeration TypeInterruptEnable
public enum class TypeInterruptEnable
type TypeInterruptEnable
Members
Member name | Value | Description
InterruptDisabled | 0 | Interrupt: Disabled
InterruptEnabled | 1 | Interrupt: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeTerminationSettingsIend Enumeration

IRD

Adp5065TypeTerminationSettingsIend Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTerminationSettingsIend
Public Enumeration TypeTerminationSettingsIend
public enum class TypeTerminationSettingsIend
type TypeTerminationSettingsIend
Members
Member name | Value | Description
Value_32_5 | 0 | 32.5
Value_52_5 | 1 | 52.5
Value_72_5 | 2 | 72.5
Value_92_5 | 3 | 92.5
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeTerminationSettingsVtrm Enumeration

IRD

Adp5065TypeTerminationSettingsVtrm Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTerminationSettingsVtrm
Public Enumeration TypeTerminationSettingsVtrm
public enum class TypeTerminationSettingsVtrm
type TypeTerminationSettingsVtrm
Members
Member name | Value | Description
Value_3_50 | 0 | 3.50
Value_3_52 | 1 | 3.52
Value_3_54 | 2 | 3.54
Value_3_56 | 3 | 3.56
Value_3_58 | 4 | 3.58
Value_3_60 | 5 | 3.60
Value_3_62 | 6 | 3.62
Value_3_64 | 7 | 3.64
Value_3_66 | 8 | 3.66
Value_3_68 | 9 | 3.68
Value_3_70 | 10 | 3.70
Value_3_72 | 11 | 3.72
Value_3_74 | 12 | 3.74
Value_3_76 | 13 | 3.76
Value_3_78 | 14 | 3.78
Value_3_80 | 15 | 3.80
Value_3_82 | 16 | 3.82
Value_3_84 | 17 | 3.84
Value_3_86 | 18 | 3.86
Value_3_88 | 19 | 3.88
Value_3_90 | 20 | 3.90
Value_3_92 | 21 | 3.92
Value_3_94 | 22 | 3.94
Value_3_96 | 23 | 3.96
Value_3_98 | 24 | 3.98
Value_4_00 | 25 | 4.00
Value_4_02 | 26 | 4.02
Value_4_04 | 27 | 4.04
Value_4_06 | 28 | 4.06
Value_4_08 | 29 | 4.08
Value_4_10 | 30 | 4.10
Value_4_12 | 31 | 4.12
Value_4_14 | 32 | 4.14
Value_4_16 | 33 | 4.16
Value_4_18 | 34 | 4.18
Value_4_20 | 35 | 4.20
Value_4_22 | 36 | 4.22
Value_4_24 | 37 | 4.24
Value_4_26 | 38 | 4.26
Value_4_28 | 39 | 4.28
Value_4_30 | 40 | 4.30
Value_4_32 | 41 | 4.32
Value_4_34 | 42 | 4.34
Value_4_36 | 43 | 4.36
Value_4_38 | 44 | 4.38
Value_4_40 | 45 | 4.40
Value_4_42 | 46 | 4.42
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeTimerSettingsChgTmrPeriod Enumeration

IRD

Adp5065TypeTimerSettingsChgTmrPeriod Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerSettingsChgTmrPeriod
Public Enumeration TypeTimerSettingsChgTmrPeriod
public enum class TypeTimerSettingsChgTmrPeriod
type TypeTimerSettingsChgTmrPeriod
Members
Member name | Value | Description
Trickle30SecFast300Minutes | 0 | Trickle: 30 sec, Fast: 300 minutes
Trickle60SecFast600Minutes | 1 | Trickle: 60 sec, Fast: 600 minutes
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeTimerSettingsEnChgTimer Enumeration

IRD

Adp5065TypeTimerSettingsEnChgTimer Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerSettingsEnChgTimer
Public Enumeration TypeTimerSettingsEnChgTimer
public enum class TypeTimerSettingsEnChgTimer
type TypeTimerSettingsEnChgTimer
Members
Member name | Value | Description
TrickleFastChargeTimerDisabled | 0 | Trickle/Fast Charge Timer: Disabled
TrickleFastChargeTimerEnabled | 1 | Trickle/Fast Charge Timer: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeTimerSettingsEnTend Enumeration

IRD

Adp5065TypeTimerSettingsEnTend Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerSettingsEnTend
Public Enumeration TypeTimerSettingsEnTend
public enum class TypeTimerSettingsEnTend
type TypeTimerSettingsEnTend
Members
Member name | Value | Description
ChargeCompletedTimerDisabled | 0 | Charge Completed Timer: Disabled
ChargeCompletedTimerEnabled | 1 | Charge Completed Timer: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeTimerSettingsEnWd Enumeration

IRD

Adp5065TypeTimerSettingsEnWd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerSettingsEnWd
Public Enumeration TypeTimerSettingsEnWd
public enum class TypeTimerSettingsEnWd
type TypeTimerSettingsEnWd
Members
Member name | Value | Description
WatchdogDisabled | 0 | Watchdog: Disabled
WatchdogEnabled | 1 | Watchdog: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeTimerSettingsResetWd Enumeration

IRD

Adp5065TypeTimerSettingsResetWd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerSettingsResetWd
Public Enumeration TypeTimerSettingsResetWd
public enum class TypeTimerSettingsResetWd
type TypeTimerSettingsResetWd
Members
Member name | Value | Description
WatchdogTimerNotChanged | 0 | Watchdog Timer: Not Changed
WatchdogTimerReset | 1 | Watchdog Timer: Reset
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeTimerSettingsWdPeriod Enumeration

IRD

Adp5065TypeTimerSettingsWdPeriod Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerSettingsWdPeriod
Public Enumeration TypeTimerSettingsWdPeriod
public enum class TypeTimerSettingsWdPeriod
type TypeTimerSettingsWdPeriod
Members
Member name | Value | Description
Watchdog32SecSafety40Minutes | 0 | Watchdog: 32 sec, Safety: 40 minutes
Watchdog64SecSafety40Minutes | 1 | Watchdog: 64 sec, Safety: 40 minutes
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeVoltageThresholdsVrch Enumeration

IRD

Adp5065TypeVoltageThresholdsVrch Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVoltageThresholdsVrch
Public Enumeration TypeVoltageThresholdsVrch
public enum class TypeVoltageThresholdsVrch
type TypeVoltageThresholdsVrch
Members
Member name | Value | Description
Value_80 | 0 | 80
Value_140 | 1 | 140
Value_200 | 2 | 200
Value_260 | 3 | 260
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeVoltageThresholdsVtrkDead Enumeration

IRD

Adp5065TypeVoltageThresholdsVtrkDead Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVoltageThresholdsVtrkDead
Public Enumeration TypeVoltageThresholdsVtrkDead
public enum class TypeVoltageThresholdsVtrkDead
type TypeVoltageThresholdsVtrkDead
Members
Member name | Value | Description
Value_2_4 | 0 | 2.4
Value_2_5 | 1 | 2.5
Value_2_6 | 2 | 2.6
Value_3_3 | 3 | 3.3
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeVoltageThresholdsVweak Enumeration

IRD

Adp5065TypeVoltageThresholdsVweak Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVoltageThresholdsVweak
Public Enumeration TypeVoltageThresholdsVweak
public enum class TypeVoltageThresholdsVweak
type TypeVoltageThresholdsVweak
Members
Member name | Value | Description
Value_2_7 | 0 | 2.7
Value_2_8 | 1 | 2.8
Value_2_9 | 2 | 2.9
Value_3_0 | 3 | 3.0
Value_3_1 | 4 | 3.1
Value_3_2 | 5 | 3.2
Value_3_3 | 6 | 3.3
Value_3_4 | 7 | 3.4
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5065.TypeVpinxPinsSettingsIlim Enumeration

IRD

Adp5065TypeVpinxPinsSettingsIlim Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVpinxPinsSettingsIlim
Public Enumeration TypeVpinxPinsSettingsIlim
public enum class TypeVpinxPinsSettingsIlim
type TypeVpinxPinsSettingsIlim
Members
Member name | Value | Description
Value_100 | 0 | 100
Value_150 | 1 | 150
Value_200 | 2 | 200
Value_300 | 3 | 300
Value_400 | 4 | 400
Value_500 | 5 | 500
Value_600 | 6 | 600
Value_700 | 7 | 700
Value_800 | 8 | 800
Value_900 | 9 | 900
Value_1000 | 10 | 1000
Value_1100 | 11 | 1100
Value_1200 | 12 | 1200
Value_1300 | 13 | 1300
Value_1400 | 14 | 1400
Value_1500 | 15 | 1500
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501 Class

Analog Devices: ADP 5501
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdp5501

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adp5501
Public Class Adp5501
public ref class Adp5501
type Adp5501 =  class end

The Adp5501 type exposes the following members.

Constructors
 | Name | Description
Public method | Adp5501 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BacklightControlBLAUTOADJ | Backlight Control: BL_AUTO_ADJ
Public property | BacklightControlBLLAW | Backlight Control: BL_LAW
Public property | BacklightControlBLLVL | Backlight Control: BL_LVL
Public property | BacklightControlFOVR | Backlight Control: FOVR
Public property | BacklightControlOVPEN | Backlight Control: OVP_EN
Public property | BacklightCurrentValue | Backlight Current Value
Public property | BacklightFadeInFadeOutTimersBLFI | Backlight Fade-In & Fade-Out Timers: BL_FI
Public property | BacklightFadeInFadeOutTimersBLFO | Backlight Fade-In & Fade-Out Timers: BL_FO
Public property | BacklightOffDimTimersBLDIMT | Backlight Off & Dim Timers: BL_DIMT
Public property | BacklightOffDimTimersBLOFFT | Backlight Off & Dim Timers: BL_OFFT
Public property | DeviceModeStatusBLEN | Device Mode & Status: BL_EN
Public property | DeviceModeStatusCMPRINT | Device Mode & Status: CMPR_INT
Public property | DeviceModeStatusDIMEN | Device Mode & Status: DIM_EN
Public property | DeviceModeStatusOVPINT | Device Mode & Status: OVP_INT
Public property | DeviceModeStatusSTNBY | Device Mode & Status: STNBY
Public property | InterruptEnableAUTOLDEN | Interrupt Enable: AUTO_LD_EN
Public property | InterruptEnableCMPRIEN | Interrupt Enable: CMPR_IEN
Public property | InterruptEnableOVPIEN | Interrupt Enable: OVP_IEN
Public property | LED0SinkCurrent | LED0 Sink Current
Public property | LED1SinkCurrent | LED1 Sink Current
Public property | LED2SinkCurrent | LED2 Sink Current
Public property | LEDFadeInAndFadeOutTimersLEDFI | LED Fade-In and Fade-Out Timers: LED_FI
Public property | LEDFadeInAndFadeOutTimersLEDFO | LED Fade-In and Fade-Out Timers: LED_FO
Public property | LEDOnAndOffTimersLED0OFFT | LED On and Off Timers: LED0_OFFT
Public property | LEDOnAndOffTimersLED1OFFT | LED On and Off Timers: LED1_OFFT
Public property | LEDOnAndOffTimersLED2OFFT | LED On and Off Timers: LED2_OFFT
Public property | LEDOnAndOffTimersLEDONT | LED On and Off Timers: LED_ONT
Public property | LEDSinkControlLED0EN | LED Sink Control: LED0_EN
Public property | LEDSinkControlLED1EN | LED Sink Control: LED1_EN
Public property | LEDSinkControlLED2EN | LED Sink Control: LED2_EN
Public property | LEDSinkControlLEDLAW | LED Sink Control: LED_LAW
Public property | Level1DaylightDimCurrent | Level 1 (Daylight) Dim Current
Public property | Level1DaylightMaximumCurrent | Level 1 (Daylight) Maximum Current
Public property | Level2OfficeComparatorHysteresis | Level 2 (Office) Comparator Hysteresis (unit: µA)
Public property | Level2OfficeComparatorTripPoint | Level 2 (Office) Comparator Trip Point (unit: µA)
Public property | Level2OfficeDimCurrent | Level 2 (Office) Dim Current
Public property | Level2OfficeMaximumCurrent | Level 2 (Office) Maximum Current
Public property | Level3DarkComparatorHysteresis | Level 3 (Dark) Comparator Hysteresis (unit: µA)
Public property | Level3DarkComparatorTripPoint | Level 3 (Dark) Comparator Trip Point (unit: µA)
Public property | Level3DarkDimCurrent | Level 3 (Dark) Dim Current
Public property | Level3DarkMaximumCurrent | Level 3 (Dark) Maximum Current
Public property | LightSensorComparatorConfigurationFILT | Light Sensor Comparator Configuration: FILT
Public property | LightSensorComparatorConfigurationFORCERD | Light Sensor Comparator Configuration: FORCE_RD
Public property | LightSensorComparatorConfigurationL2EN | Light Sensor Comparator Configuration: L2_EN
Public property | LightSensorComparatorConfigurationL2OUT | Light Sensor Comparator Configuration: L2_OUT
Public property | LightSensorComparatorConfigurationL3EN | Light Sensor Comparator Configuration: L3_EN
Public property | LightSensorComparatorConfigurationL3OUT | Light Sensor Comparator Configuration: L3_OUT
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Programmable Current Backlight Driver with Ambient Light Sensor Input
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adp5501(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adp5501

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501 Properties

The Adp5501 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BacklightControlBLAUTOADJ | Backlight Control: BL_AUTO_ADJ
Public property | BacklightControlBLLAW | Backlight Control: BL_LAW
Public property | BacklightControlBLLVL | Backlight Control: BL_LVL
Public property | BacklightControlFOVR | Backlight Control: FOVR
Public property | BacklightControlOVPEN | Backlight Control: OVP_EN
Public property | BacklightCurrentValue | Backlight Current Value
Public property | BacklightFadeInFadeOutTimersBLFI | Backlight Fade-In & Fade-Out Timers: BL_FI
Public property | BacklightFadeInFadeOutTimersBLFO | Backlight Fade-In & Fade-Out Timers: BL_FO
Public property | BacklightOffDimTimersBLDIMT | Backlight Off & Dim Timers: BL_DIMT
Public property | BacklightOffDimTimersBLOFFT | Backlight Off & Dim Timers: BL_OFFT
Public property | DeviceModeStatusBLEN | Device Mode & Status: BL_EN
Public property | DeviceModeStatusCMPRINT | Device Mode & Status: CMPR_INT
Public property | DeviceModeStatusDIMEN | Device Mode & Status: DIM_EN
Public property | DeviceModeStatusOVPINT | Device Mode & Status: OVP_INT
Public property | DeviceModeStatusSTNBY | Device Mode & Status: STNBY
Public property | InterruptEnableAUTOLDEN | Interrupt Enable: AUTO_LD_EN
Public property | InterruptEnableCMPRIEN | Interrupt Enable: CMPR_IEN
Public property | InterruptEnableOVPIEN | Interrupt Enable: OVP_IEN
Public property | LED0SinkCurrent | LED0 Sink Current
Public property | LED1SinkCurrent | LED1 Sink Current
Public property | LED2SinkCurrent | LED2 Sink Current
Public property | LEDFadeInAndFadeOutTimersLEDFI | LED Fade-In and Fade-Out Timers: LED_FI
Public property | LEDFadeInAndFadeOutTimersLEDFO | LED Fade-In and Fade-Out Timers: LED_FO
Public property | LEDOnAndOffTimersLED0OFFT | LED On and Off Timers: LED0_OFFT
Public property | LEDOnAndOffTimersLED1OFFT | LED On and Off Timers: LED1_OFFT
Public property | LEDOnAndOffTimersLED2OFFT | LED On and Off Timers: LED2_OFFT
Public property | LEDOnAndOffTimersLEDONT | LED On and Off Timers: LED_ONT
Public property | LEDSinkControlLED0EN | LED Sink Control: LED0_EN
Public property | LEDSinkControlLED1EN | LED Sink Control: LED1_EN
Public property | LEDSinkControlLED2EN | LED Sink Control: LED2_EN
Public property | LEDSinkControlLEDLAW | LED Sink Control: LED_LAW
Public property | Level1DaylightDimCurrent | Level 1 (Daylight) Dim Current
Public property | Level1DaylightMaximumCurrent | Level 1 (Daylight) Maximum Current
Public property | Level2OfficeComparatorHysteresis | Level 2 (Office) Comparator Hysteresis (unit: µA)
Public property | Level2OfficeComparatorTripPoint | Level 2 (Office) Comparator Trip Point (unit: µA)
Public property | Level2OfficeDimCurrent | Level 2 (Office) Dim Current
Public property | Level2OfficeMaximumCurrent | Level 2 (Office) Maximum Current
Public property | Level3DarkComparatorHysteresis | Level 3 (Dark) Comparator Hysteresis (unit: µA)
Public property | Level3DarkComparatorTripPoint | Level 3 (Dark) Comparator Trip Point (unit: µA)
Public property | Level3DarkDimCurrent | Level 3 (Dark) Dim Current
Public property | Level3DarkMaximumCurrent | Level 3 (Dark) Maximum Current
Public property | LightSensorComparatorConfigurationFILT | Light Sensor Comparator Configuration: FILT
Public property | LightSensorComparatorConfigurationFORCERD | Light Sensor Comparator Configuration: FORCE_RD
Public property | LightSensorComparatorConfigurationL2EN | Light Sensor Comparator Configuration: L2_EN
Public property | LightSensorComparatorConfigurationL2OUT | Light Sensor Comparator Configuration: L2_OUT
Public property | LightSensorComparatorConfigurationL3EN | Light Sensor Comparator Configuration: L3_EN
Public property | LightSensorComparatorConfigurationL3OUT | Light Sensor Comparator Configuration: L3_OUT
Top
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.AutoFlush Property

IRD

Adp5501AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.BacklightControlBLAUTOADJ Property

IRD

Adp5501BacklightControlBLAUTOADJ Property

Backlight Control: BL_AUTO_ADJ

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeBlControlBlAutoAdj BacklightControlBLAUTOADJ { get; set; }
Public Property BacklightControlBLAUTOADJ As Adp5501TypeBlControlBlAutoAdj
    Get
    Set
public:
property Adp5501TypeBlControlBlAutoAdj BacklightControlBLAUTOADJ {
    Adp5501TypeBlControlBlAutoAdj get ();
    void set (Adp5501TypeBlControlBlAutoAdj value);
}
member BacklightControlBLAUTOADJ : Adp5501TypeBlControlBlAutoAdj with get, set

Property Value

Type: Adp5501TypeBlControlBlAutoAdj
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.BacklightControlBLLAW Property

IRD

Adp5501BacklightControlBLLAW Property

Backlight Control: BL_LAW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeBlControlBlLaw BacklightControlBLLAW { get; set; }
Public Property BacklightControlBLLAW As Adp5501TypeBlControlBlLaw
    Get
    Set
public:
property Adp5501TypeBlControlBlLaw BacklightControlBLLAW {
    Adp5501TypeBlControlBlLaw get ();
    void set (Adp5501TypeBlControlBlLaw value);
}
member BacklightControlBLLAW : Adp5501TypeBlControlBlLaw with get, set

Property Value

Type: Adp5501TypeBlControlBlLaw
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.BacklightControlBLLVL Property

IRD

Adp5501BacklightControlBLLVL Property

Backlight Control: BL_LVL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeBlControlBlLvl BacklightControlBLLVL { get; set; }
Public Property BacklightControlBLLVL As Adp5501TypeBlControlBlLvl
    Get
    Set
public:
property Adp5501TypeBlControlBlLvl BacklightControlBLLVL {
    Adp5501TypeBlControlBlLvl get ();
    void set (Adp5501TypeBlControlBlLvl value);
}
member BacklightControlBLLVL : Adp5501TypeBlControlBlLvl with get, set

Property Value

Type: Adp5501TypeBlControlBlLvl
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.BacklightControlFOVR Property

IRD

Adp5501BacklightControlFOVR Property

Backlight Control: FOVR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeBlControlFovr BacklightControlFOVR { get; set; }
Public Property BacklightControlFOVR As Adp5501TypeBlControlFovr
    Get
    Set
public:
property Adp5501TypeBlControlFovr BacklightControlFOVR {
    Adp5501TypeBlControlFovr get ();
    void set (Adp5501TypeBlControlFovr value);
}
member BacklightControlFOVR : Adp5501TypeBlControlFovr with get, set

Property Value

Type: Adp5501TypeBlControlFovr
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.BacklightControlOVPEN Property

IRD

Adp5501BacklightControlOVPEN Property

Backlight Control: OVP_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeBlControlOvpEn BacklightControlOVPEN { get; set; }
Public Property BacklightControlOVPEN As Adp5501TypeBlControlOvpEn
    Get
    Set
public:
property Adp5501TypeBlControlOvpEn BacklightControlOVPEN {
    Adp5501TypeBlControlOvpEn get ();
    void set (Adp5501TypeBlControlOvpEn value);
}
member BacklightControlOVPEN : Adp5501TypeBlControlOvpEn with get, set

Property Value

Type: Adp5501TypeBlControlOvpEn
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.BacklightCurrentValue Property

IRD

Adp5501BacklightCurrentValue Property

Backlight Current Value

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte BacklightCurrentValue { get; }
Public ReadOnly Property BacklightCurrentValue As Byte
    Get
public:
property unsigned char BacklightCurrentValue {
    unsigned char get ();
}
member BacklightCurrentValue : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.BacklightFadeInFadeOutTimersBLFI Property

IRD

Adp5501BacklightFadeInFadeOutTimersBLFI Property

Backlight Fade-In & Fade-Out Timers: BL_FI

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeBlFade BacklightFadeInFadeOutTimersBLFI { get; set; }
Public Property BacklightFadeInFadeOutTimersBLFI As Adp5501TypeBlFade
    Get
    Set
public:
property Adp5501TypeBlFade BacklightFadeInFadeOutTimersBLFI {
    Adp5501TypeBlFade get ();
    void set (Adp5501TypeBlFade value);
}
member BacklightFadeInFadeOutTimersBLFI : Adp5501TypeBlFade with get, set

Property Value

Type: Adp5501TypeBlFade
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.BacklightFadeInFadeOutTimersBLFO Property

IRD

Adp5501BacklightFadeInFadeOutTimersBLFO Property

Backlight Fade-In & Fade-Out Timers: BL_FO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeBlFade BacklightFadeInFadeOutTimersBLFO { get; set; }
Public Property BacklightFadeInFadeOutTimersBLFO As Adp5501TypeBlFade
    Get
    Set
public:
property Adp5501TypeBlFade BacklightFadeInFadeOutTimersBLFO {
    Adp5501TypeBlFade get ();
    void set (Adp5501TypeBlFade value);
}
member BacklightFadeInFadeOutTimersBLFO : Adp5501TypeBlFade with get, set

Property Value

Type: Adp5501TypeBlFade
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.BacklightOffDimTimersBLDIMT Property

IRD

Adp5501BacklightOffDimTimersBLDIMT Property

Backlight Off & Dim Timers: BL_DIMT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeBlTime BacklightOffDimTimersBLDIMT { get; set; }
Public Property BacklightOffDimTimersBLDIMT As Adp5501TypeBlTime
    Get
    Set
public:
property Adp5501TypeBlTime BacklightOffDimTimersBLDIMT {
    Adp5501TypeBlTime get ();
    void set (Adp5501TypeBlTime value);
}
member BacklightOffDimTimersBLDIMT : Adp5501TypeBlTime with get, set

Property Value

Type: Adp5501TypeBlTime
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.BacklightOffDimTimersBLOFFT Property

IRD

Adp5501BacklightOffDimTimersBLOFFT Property

Backlight Off & Dim Timers: BL_OFFT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeBlTime BacklightOffDimTimersBLOFFT { get; set; }
Public Property BacklightOffDimTimersBLOFFT As Adp5501TypeBlTime
    Get
    Set
public:
property Adp5501TypeBlTime BacklightOffDimTimersBLOFFT {
    Adp5501TypeBlTime get ();
    void set (Adp5501TypeBlTime value);
}
member BacklightOffDimTimersBLOFFT : Adp5501TypeBlTime with get, set

Property Value

Type: Adp5501TypeBlTime
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.DeviceModeStatusBLEN Property

IRD

Adp5501DeviceModeStatusBLEN Property

Device Mode & Status: BL_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeModeStatusBlEn DeviceModeStatusBLEN { get; set; }
Public Property DeviceModeStatusBLEN As Adp5501TypeModeStatusBlEn
    Get
    Set
public:
property Adp5501TypeModeStatusBlEn DeviceModeStatusBLEN {
    Adp5501TypeModeStatusBlEn get ();
    void set (Adp5501TypeModeStatusBlEn value);
}
member DeviceModeStatusBLEN : Adp5501TypeModeStatusBlEn with get, set

Property Value

Type: Adp5501TypeModeStatusBlEn
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.DeviceModeStatusCMPRINT Property

IRD

Adp5501DeviceModeStatusCMPRINT Property

Device Mode & Status: CMPR_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeModeStatusCmprInt DeviceModeStatusCMPRINT { get; set; }
Public Property DeviceModeStatusCMPRINT As Adp5501TypeModeStatusCmprInt
    Get
    Set
public:
property Adp5501TypeModeStatusCmprInt DeviceModeStatusCMPRINT {
    Adp5501TypeModeStatusCmprInt get ();
    void set (Adp5501TypeModeStatusCmprInt value);
}
member DeviceModeStatusCMPRINT : Adp5501TypeModeStatusCmprInt with get, set

Property Value

Type: Adp5501TypeModeStatusCmprInt
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.DeviceModeStatusDIMEN Property

IRD

Adp5501DeviceModeStatusDIMEN Property

Device Mode & Status: DIM_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeModeStatusDimEn DeviceModeStatusDIMEN { get; set; }
Public Property DeviceModeStatusDIMEN As Adp5501TypeModeStatusDimEn
    Get
    Set
public:
property Adp5501TypeModeStatusDimEn DeviceModeStatusDIMEN {
    Adp5501TypeModeStatusDimEn get ();
    void set (Adp5501TypeModeStatusDimEn value);
}
member DeviceModeStatusDIMEN : Adp5501TypeModeStatusDimEn with get, set

Property Value

Type: Adp5501TypeModeStatusDimEn
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.DeviceModeStatusOVPINT Property

IRD

Adp5501DeviceModeStatusOVPINT Property

Device Mode & Status: OVP_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeModeStatusOvpInt DeviceModeStatusOVPINT { get; set; }
Public Property DeviceModeStatusOVPINT As Adp5501TypeModeStatusOvpInt
    Get
    Set
public:
property Adp5501TypeModeStatusOvpInt DeviceModeStatusOVPINT {
    Adp5501TypeModeStatusOvpInt get ();
    void set (Adp5501TypeModeStatusOvpInt value);
}
member DeviceModeStatusOVPINT : Adp5501TypeModeStatusOvpInt with get, set

Property Value

Type: Adp5501TypeModeStatusOvpInt
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.DeviceModeStatusSTNBY Property

IRD

Adp5501DeviceModeStatusSTNBY Property

Device Mode & Status: STNBY

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeModeStatusStnby DeviceModeStatusSTNBY { get; set; }
Public Property DeviceModeStatusSTNBY As Adp5501TypeModeStatusStnby
    Get
    Set
public:
property Adp5501TypeModeStatusStnby DeviceModeStatusSTNBY {
    Adp5501TypeModeStatusStnby get ();
    void set (Adp5501TypeModeStatusStnby value);
}
member DeviceModeStatusSTNBY : Adp5501TypeModeStatusStnby with get, set

Property Value

Type: Adp5501TypeModeStatusStnby
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.InterruptEnableAUTOLDEN Property

IRD

Adp5501InterruptEnableAUTOLDEN Property

Interrupt Enable: AUTO_LD_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeInterruptEnableAutoLdEn InterruptEnableAUTOLDEN { get; set; }
Public Property InterruptEnableAUTOLDEN As Adp5501TypeInterruptEnableAutoLdEn
    Get
    Set
public:
property Adp5501TypeInterruptEnableAutoLdEn InterruptEnableAUTOLDEN {
    Adp5501TypeInterruptEnableAutoLdEn get ();
    void set (Adp5501TypeInterruptEnableAutoLdEn value);
}
member InterruptEnableAUTOLDEN : Adp5501TypeInterruptEnableAutoLdEn with get, set

Property Value

Type: Adp5501TypeInterruptEnableAutoLdEn
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.InterruptEnableCMPRIEN Property

IRD

Adp5501InterruptEnableCMPRIEN Property

Interrupt Enable: CMPR_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeInterruptEnableCmprIen InterruptEnableCMPRIEN { get; set; }
Public Property InterruptEnableCMPRIEN As Adp5501TypeInterruptEnableCmprIen
    Get
    Set
public:
property Adp5501TypeInterruptEnableCmprIen InterruptEnableCMPRIEN {
    Adp5501TypeInterruptEnableCmprIen get ();
    void set (Adp5501TypeInterruptEnableCmprIen value);
}
member InterruptEnableCMPRIEN : Adp5501TypeInterruptEnableCmprIen with get, set

Property Value

Type: Adp5501TypeInterruptEnableCmprIen
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.InterruptEnableOVPIEN Property

IRD

Adp5501InterruptEnableOVPIEN Property

Interrupt Enable: OVP_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeInterruptEnableOvpIen InterruptEnableOVPIEN { get; set; }
Public Property InterruptEnableOVPIEN As Adp5501TypeInterruptEnableOvpIen
    Get
    Set
public:
property Adp5501TypeInterruptEnableOvpIen InterruptEnableOVPIEN {
    Adp5501TypeInterruptEnableOvpIen get ();
    void set (Adp5501TypeInterruptEnableOvpIen value);
}
member InterruptEnableOVPIEN : Adp5501TypeInterruptEnableOvpIen with get, set

Property Value

Type: Adp5501TypeInterruptEnableOvpIen
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LED0SinkCurrent Property

IRD

Adp5501LED0SinkCurrent Property

LED0 Sink Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LED0SinkCurrent { get; set; }
Public Property LED0SinkCurrent As Byte
    Get
    Set
public:
property unsigned char LED0SinkCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member LED0SinkCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LED1SinkCurrent Property

IRD

Adp5501LED1SinkCurrent Property

LED1 Sink Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LED1SinkCurrent { get; set; }
Public Property LED1SinkCurrent As Byte
    Get
    Set
public:
property unsigned char LED1SinkCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member LED1SinkCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LED2SinkCurrent Property

IRD

Adp5501LED2SinkCurrent Property

LED2 Sink Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LED2SinkCurrent { get; set; }
Public Property LED2SinkCurrent As Byte
    Get
    Set
public:
property unsigned char LED2SinkCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member LED2SinkCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LEDFadeInAndFadeOutTimersLEDFI Property

IRD

Adp5501LEDFadeInAndFadeOutTimersLEDFI Property

LED Fade-In and Fade-Out Timers: LED_FI

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeLedFade LEDFadeInAndFadeOutTimersLEDFI { get; set; }
Public Property LEDFadeInAndFadeOutTimersLEDFI As Adp5501TypeLedFade
    Get
    Set
public:
property Adp5501TypeLedFade LEDFadeInAndFadeOutTimersLEDFI {
    Adp5501TypeLedFade get ();
    void set (Adp5501TypeLedFade value);
}
member LEDFadeInAndFadeOutTimersLEDFI : Adp5501TypeLedFade with get, set

Property Value

Type: Adp5501TypeLedFade
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LEDFadeInAndFadeOutTimersLEDFO Property

IRD

Adp5501LEDFadeInAndFadeOutTimersLEDFO Property

LED Fade-In and Fade-Out Timers: LED_FO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeLedFade LEDFadeInAndFadeOutTimersLEDFO { get; set; }
Public Property LEDFadeInAndFadeOutTimersLEDFO As Adp5501TypeLedFade
    Get
    Set
public:
property Adp5501TypeLedFade LEDFadeInAndFadeOutTimersLEDFO {
    Adp5501TypeLedFade get ();
    void set (Adp5501TypeLedFade value);
}
member LEDFadeInAndFadeOutTimersLEDFO : Adp5501TypeLedFade with get, set

Property Value

Type: Adp5501TypeLedFade
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LEDOnAndOffTimersLED0OFFT Property

IRD

Adp5501LEDOnAndOffTimersLED0OFFT Property

LED On and Off Timers: LED0_OFFT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeLedTimeLedOfft LEDOnAndOffTimersLED0OFFT { get; set; }
Public Property LEDOnAndOffTimersLED0OFFT As Adp5501TypeLedTimeLedOfft
    Get
    Set
public:
property Adp5501TypeLedTimeLedOfft LEDOnAndOffTimersLED0OFFT {
    Adp5501TypeLedTimeLedOfft get ();
    void set (Adp5501TypeLedTimeLedOfft value);
}
member LEDOnAndOffTimersLED0OFFT : Adp5501TypeLedTimeLedOfft with get, set

Property Value

Type: Adp5501TypeLedTimeLedOfft
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LEDOnAndOffTimersLED1OFFT Property

IRD

Adp5501LEDOnAndOffTimersLED1OFFT Property

LED On and Off Timers: LED1_OFFT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeLedTimeLedOfft LEDOnAndOffTimersLED1OFFT { get; set; }
Public Property LEDOnAndOffTimersLED1OFFT As Adp5501TypeLedTimeLedOfft
    Get
    Set
public:
property Adp5501TypeLedTimeLedOfft LEDOnAndOffTimersLED1OFFT {
    Adp5501TypeLedTimeLedOfft get ();
    void set (Adp5501TypeLedTimeLedOfft value);
}
member LEDOnAndOffTimersLED1OFFT : Adp5501TypeLedTimeLedOfft with get, set

Property Value

Type: Adp5501TypeLedTimeLedOfft
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LEDOnAndOffTimersLED2OFFT Property

IRD

Adp5501LEDOnAndOffTimersLED2OFFT Property

LED On and Off Timers: LED2_OFFT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeLedTimeLedOfft LEDOnAndOffTimersLED2OFFT { get; set; }
Public Property LEDOnAndOffTimersLED2OFFT As Adp5501TypeLedTimeLedOfft
    Get
    Set
public:
property Adp5501TypeLedTimeLedOfft LEDOnAndOffTimersLED2OFFT {
    Adp5501TypeLedTimeLedOfft get ();
    void set (Adp5501TypeLedTimeLedOfft value);
}
member LEDOnAndOffTimersLED2OFFT : Adp5501TypeLedTimeLedOfft with get, set

Property Value

Type: Adp5501TypeLedTimeLedOfft
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LEDOnAndOffTimersLEDONT Property

IRD

Adp5501LEDOnAndOffTimersLEDONT Property

LED On and Off Timers: LED_ONT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeLedTimeLedOnt LEDOnAndOffTimersLEDONT { get; set; }
Public Property LEDOnAndOffTimersLEDONT As Adp5501TypeLedTimeLedOnt
    Get
    Set
public:
property Adp5501TypeLedTimeLedOnt LEDOnAndOffTimersLEDONT {
    Adp5501TypeLedTimeLedOnt get ();
    void set (Adp5501TypeLedTimeLedOnt value);
}
member LEDOnAndOffTimersLEDONT : Adp5501TypeLedTimeLedOnt with get, set

Property Value

Type: Adp5501TypeLedTimeLedOnt
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LEDSinkControlLED0EN Property

IRD

Adp5501LEDSinkControlLED0EN Property

LED Sink Control: LED0_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeLedSinkControlLed0En LEDSinkControlLED0EN { get; set; }
Public Property LEDSinkControlLED0EN As Adp5501TypeLedSinkControlLed0En
    Get
    Set
public:
property Adp5501TypeLedSinkControlLed0En LEDSinkControlLED0EN {
    Adp5501TypeLedSinkControlLed0En get ();
    void set (Adp5501TypeLedSinkControlLed0En value);
}
member LEDSinkControlLED0EN : Adp5501TypeLedSinkControlLed0En with get, set

Property Value

Type: Adp5501TypeLedSinkControlLed0En
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LEDSinkControlLED1EN Property

IRD

Adp5501LEDSinkControlLED1EN Property

LED Sink Control: LED1_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeLedSinkControlLed1En LEDSinkControlLED1EN { get; set; }
Public Property LEDSinkControlLED1EN As Adp5501TypeLedSinkControlLed1En
    Get
    Set
public:
property Adp5501TypeLedSinkControlLed1En LEDSinkControlLED1EN {
    Adp5501TypeLedSinkControlLed1En get ();
    void set (Adp5501TypeLedSinkControlLed1En value);
}
member LEDSinkControlLED1EN : Adp5501TypeLedSinkControlLed1En with get, set

Property Value

Type: Adp5501TypeLedSinkControlLed1En
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LEDSinkControlLED2EN Property

IRD

Adp5501LEDSinkControlLED2EN Property

LED Sink Control: LED2_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeLedSinkControlLed2En LEDSinkControlLED2EN { get; set; }
Public Property LEDSinkControlLED2EN As Adp5501TypeLedSinkControlLed2En
    Get
    Set
public:
property Adp5501TypeLedSinkControlLed2En LEDSinkControlLED2EN {
    Adp5501TypeLedSinkControlLed2En get ();
    void set (Adp5501TypeLedSinkControlLed2En value);
}
member LEDSinkControlLED2EN : Adp5501TypeLedSinkControlLed2En with get, set

Property Value

Type: Adp5501TypeLedSinkControlLed2En
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LEDSinkControlLEDLAW Property

IRD

Adp5501LEDSinkControlLEDLAW Property

LED Sink Control: LED_LAW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeLedSinkControlLedLaw LEDSinkControlLEDLAW { get; set; }
Public Property LEDSinkControlLEDLAW As Adp5501TypeLedSinkControlLedLaw
    Get
    Set
public:
property Adp5501TypeLedSinkControlLedLaw LEDSinkControlLEDLAW {
    Adp5501TypeLedSinkControlLedLaw get ();
    void set (Adp5501TypeLedSinkControlLedLaw value);
}
member LEDSinkControlLEDLAW : Adp5501TypeLedSinkControlLedLaw with get, set

Property Value

Type: Adp5501TypeLedSinkControlLedLaw
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.Level1DaylightDimCurrent Property

IRD

Adp5501Level1DaylightDimCurrent Property

Level 1 (Daylight) Dim Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Level1DaylightDimCurrent { get; set; }
Public Property Level1DaylightDimCurrent As Byte
    Get
    Set
public:
property unsigned char Level1DaylightDimCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member Level1DaylightDimCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.Level1DaylightMaximumCurrent Property

IRD

Adp5501Level1DaylightMaximumCurrent Property

Level 1 (Daylight) Maximum Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Level1DaylightMaximumCurrent { get; set; }
Public Property Level1DaylightMaximumCurrent As Byte
    Get
    Set
public:
property unsigned char Level1DaylightMaximumCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member Level1DaylightMaximumCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.Level2OfficeComparatorHysteresis Property

IRD

Adp5501Level2OfficeComparatorHysteresis Property

Level 2 (Office) Comparator Hysteresis (unit: µA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Level2OfficeComparatorHysteresis { get; set; }
Public Property Level2OfficeComparatorHysteresis As Double
    Get
    Set
public:
property double Level2OfficeComparatorHysteresis {
    double get ();
    void set (double value);
}
member Level2OfficeComparatorHysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.Level2OfficeComparatorTripPoint Property

IRD

Adp5501Level2OfficeComparatorTripPoint Property

Level 2 (Office) Comparator Trip Point (unit: µA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Level2OfficeComparatorTripPoint { get; set; }
Public Property Level2OfficeComparatorTripPoint As Double
    Get
    Set
public:
property double Level2OfficeComparatorTripPoint {
    double get ();
    void set (double value);
}
member Level2OfficeComparatorTripPoint : float with get, set

Property Value

Type: Double
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.Level2OfficeDimCurrent Property

IRD

Adp5501Level2OfficeDimCurrent Property

Level 2 (Office) Dim Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Level2OfficeDimCurrent { get; set; }
Public Property Level2OfficeDimCurrent As Byte
    Get
    Set
public:
property unsigned char Level2OfficeDimCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member Level2OfficeDimCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.Level2OfficeMaximumCurrent Property

IRD

Adp5501Level2OfficeMaximumCurrent Property

Level 2 (Office) Maximum Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Level2OfficeMaximumCurrent { get; set; }
Public Property Level2OfficeMaximumCurrent As Byte
    Get
    Set
public:
property unsigned char Level2OfficeMaximumCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member Level2OfficeMaximumCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.Level3DarkComparatorHysteresis Property

IRD

Adp5501Level3DarkComparatorHysteresis Property

Level 3 (Dark) Comparator Hysteresis (unit: µA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Level3DarkComparatorHysteresis { get; set; }
Public Property Level3DarkComparatorHysteresis As Double
    Get
    Set
public:
property double Level3DarkComparatorHysteresis {
    double get ();
    void set (double value);
}
member Level3DarkComparatorHysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.Level3DarkComparatorTripPoint Property

IRD

Adp5501Level3DarkComparatorTripPoint Property

Level 3 (Dark) Comparator Trip Point (unit: µA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Level3DarkComparatorTripPoint { get; set; }
Public Property Level3DarkComparatorTripPoint As Double
    Get
    Set
public:
property double Level3DarkComparatorTripPoint {
    double get ();
    void set (double value);
}
member Level3DarkComparatorTripPoint : float with get, set

Property Value

Type: Double
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.Level3DarkDimCurrent Property

IRD

Adp5501Level3DarkDimCurrent Property

Level 3 (Dark) Dim Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Level3DarkDimCurrent { get; set; }
Public Property Level3DarkDimCurrent As Byte
    Get
    Set
public:
property unsigned char Level3DarkDimCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member Level3DarkDimCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.Level3DarkMaximumCurrent Property

IRD

Adp5501Level3DarkMaximumCurrent Property

Level 3 (Dark) Maximum Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Level3DarkMaximumCurrent { get; set; }
Public Property Level3DarkMaximumCurrent As Byte
    Get
    Set
public:
property unsigned char Level3DarkMaximumCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member Level3DarkMaximumCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LightSensorComparatorConfigurationFILT Property

IRD

Adp5501LightSensorComparatorConfigurationFILT Property

Light Sensor Comparator Configuration: FILT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeAlsCmprCfgFilt LightSensorComparatorConfigurationFILT { get; set; }
Public Property LightSensorComparatorConfigurationFILT As Adp5501TypeAlsCmprCfgFilt
    Get
    Set
public:
property Adp5501TypeAlsCmprCfgFilt LightSensorComparatorConfigurationFILT {
    Adp5501TypeAlsCmprCfgFilt get ();
    void set (Adp5501TypeAlsCmprCfgFilt value);
}
member LightSensorComparatorConfigurationFILT : Adp5501TypeAlsCmprCfgFilt with get, set

Property Value

Type: Adp5501TypeAlsCmprCfgFilt
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LightSensorComparatorConfigurationFORCERD Property

IRD

Adp5501LightSensorComparatorConfigurationFORCERD Property

Light Sensor Comparator Configuration: FORCE_RD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeAlsCmprCfgForceRd LightSensorComparatorConfigurationFORCERD { get; set; }
Public Property LightSensorComparatorConfigurationFORCERD As Adp5501TypeAlsCmprCfgForceRd
    Get
    Set
public:
property Adp5501TypeAlsCmprCfgForceRd LightSensorComparatorConfigurationFORCERD {
    Adp5501TypeAlsCmprCfgForceRd get ();
    void set (Adp5501TypeAlsCmprCfgForceRd value);
}
member LightSensorComparatorConfigurationFORCERD : Adp5501TypeAlsCmprCfgForceRd with get, set

Property Value

Type: Adp5501TypeAlsCmprCfgForceRd
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LightSensorComparatorConfigurationL2EN Property

IRD

Adp5501LightSensorComparatorConfigurationL2EN Property

Light Sensor Comparator Configuration: L2_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeAlsCmprCfgL2En LightSensorComparatorConfigurationL2EN { get; set; }
Public Property LightSensorComparatorConfigurationL2EN As Adp5501TypeAlsCmprCfgL2En
    Get
    Set
public:
property Adp5501TypeAlsCmprCfgL2En LightSensorComparatorConfigurationL2EN {
    Adp5501TypeAlsCmprCfgL2En get ();
    void set (Adp5501TypeAlsCmprCfgL2En value);
}
member LightSensorComparatorConfigurationL2EN : Adp5501TypeAlsCmprCfgL2En with get, set

Property Value

Type: Adp5501TypeAlsCmprCfgL2En
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LightSensorComparatorConfigurationL2OUT Property

IRD

Adp5501LightSensorComparatorConfigurationL2OUT Property

Light Sensor Comparator Configuration: L2_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeAlsCmprCfgL2Out LightSensorComparatorConfigurationL2OUT { get; set; }
Public Property LightSensorComparatorConfigurationL2OUT As Adp5501TypeAlsCmprCfgL2Out
    Get
    Set
public:
property Adp5501TypeAlsCmprCfgL2Out LightSensorComparatorConfigurationL2OUT {
    Adp5501TypeAlsCmprCfgL2Out get ();
    void set (Adp5501TypeAlsCmprCfgL2Out value);
}
member LightSensorComparatorConfigurationL2OUT : Adp5501TypeAlsCmprCfgL2Out with get, set

Property Value

Type: Adp5501TypeAlsCmprCfgL2Out
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LightSensorComparatorConfigurationL3EN Property

IRD

Adp5501LightSensorComparatorConfigurationL3EN Property

Light Sensor Comparator Configuration: L3_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeAlsCmprCfgL3En LightSensorComparatorConfigurationL3EN { get; set; }
Public Property LightSensorComparatorConfigurationL3EN As Adp5501TypeAlsCmprCfgL3En
    Get
    Set
public:
property Adp5501TypeAlsCmprCfgL3En LightSensorComparatorConfigurationL3EN {
    Adp5501TypeAlsCmprCfgL3En get ();
    void set (Adp5501TypeAlsCmprCfgL3En value);
}
member LightSensorComparatorConfigurationL3EN : Adp5501TypeAlsCmprCfgL3En with get, set

Property Value

Type: Adp5501TypeAlsCmprCfgL3En
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.LightSensorComparatorConfigurationL3OUT Property

IRD

Adp5501LightSensorComparatorConfigurationL3OUT Property

Light Sensor Comparator Configuration: L3_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5501TypeAlsCmprCfgL3Out LightSensorComparatorConfigurationL3OUT { get; set; }
Public Property LightSensorComparatorConfigurationL3OUT As Adp5501TypeAlsCmprCfgL3Out
    Get
    Set
public:
property Adp5501TypeAlsCmprCfgL3Out LightSensorComparatorConfigurationL3OUT {
    Adp5501TypeAlsCmprCfgL3Out get ();
    void set (Adp5501TypeAlsCmprCfgL3Out value);
}
member LightSensorComparatorConfigurationL3OUT : Adp5501TypeAlsCmprCfgL3Out with get, set

Property Value

Type: Adp5501TypeAlsCmprCfgL3Out
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501 Methods

The Adp5501 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.Flush Method

IRD

Adp5501Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adp5501 Class
telos.Ird.AnalogDevices Namespace


Adp5501.TypeAlsCmprCfgFilt Enumeration

IRD

Adp5501TypeAlsCmprCfgFilt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlsCmprCfgFilt
Public Enumeration TypeAlsCmprCfgFilt
public enum class TypeAlsCmprCfgFilt
type TypeAlsCmprCfgFilt
Members
Member name | Value | Description
Value_008S | 0 | 0.08 s
Value_016S | 1 | 0.16 s
Value_032S | 2 | 0.32 s
Value_064S | 3 | 0.64 s
Value_128S | 4 | 1.28 s
Value_256S | 5 | 2.56 s
Value_512S | 6 | 5.12 s
Value_1024S | 7 | 10.24 s
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeAlsCmprCfgForceRd Enumeration

IRD

Adp5501TypeAlsCmprCfgForceRd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlsCmprCfgForceRd
Public Enumeration TypeAlsCmprCfgForceRd
public enum class TypeAlsCmprCfgForceRd
type TypeAlsCmprCfgForceRd
Members
Member name | Value | Description
Default | 0 | Default
ForceSingleConversion | 1 | Force Single Conversion
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeAlsCmprCfgL2En Enumeration

IRD

Adp5501TypeAlsCmprCfgL2En Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlsCmprCfgL2En
Public Enumeration TypeAlsCmprCfgL2En
public enum class TypeAlsCmprCfgL2En
type TypeAlsCmprCfgL2En
Members
Member name | Value | Description
L2CMPRDisabled | 0 | L2_CMPR: Disabled
L2CMPREnabled | 1 | L2_CMPR: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeAlsCmprCfgL2Out Enumeration

IRD

Adp5501TypeAlsCmprCfgL2Out Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlsCmprCfgL2Out
Public Enumeration TypeAlsCmprCfgL2Out
public enum class TypeAlsCmprCfgL2Out
type TypeAlsCmprCfgL2Out
Members
Member name | Value | Description
AmbientLightGreaterThanL2 | 0 | Ambient Light: Greater Than L2
AmbientLightChangeFromL1ToL2 | 1 | Ambient Light: Change from L1 to L2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeAlsCmprCfgL3En Enumeration

IRD

Adp5501TypeAlsCmprCfgL3En Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlsCmprCfgL3En
Public Enumeration TypeAlsCmprCfgL3En
public enum class TypeAlsCmprCfgL3En
type TypeAlsCmprCfgL3En
Members
Member name | Value | Description
L3CMPRDisabled | 0 | L3_CMPR: Disabled
L3CMPREnabled | 1 | L3_CMPR: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeAlsCmprCfgL3Out Enumeration

IRD

Adp5501TypeAlsCmprCfgL3Out Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlsCmprCfgL3Out
Public Enumeration TypeAlsCmprCfgL3Out
public enum class TypeAlsCmprCfgL3Out
type TypeAlsCmprCfgL3Out
Members
Member name | Value | Description
AmbientLightGreaterThanL3 | 0 | Ambient Light: Greater Than L3
AmbientLightChangeFromL2ToL3 | 1 | Ambient Light: Change from L2 to L3
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeBlControlBlAutoAdj Enumeration

IRD

Adp5501TypeBlControlBlAutoAdj Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBlControlBlAutoAdj
Public Enumeration TypeBlControlBlAutoAdj
public enum class TypeBlControlBlAutoAdj
type TypeBlControlBlAutoAdj
Members
Member name | Value | Description
Manual | 0 | Manual
Automatic | 1 | Automatic
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeBlControlBlLaw Enumeration

IRD

Adp5501TypeBlControlBlLaw Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBlControlBlLaw
Public Enumeration TypeBlControlBlLaw
public enum class TypeBlControlBlLaw
type TypeBlControlBlLaw
Members
Member name | Value | Description
Linear | 0 | Linear
Square | 1 | Square
Cubic1 | 2 | Cubic 1
Cubic2 | 3 | Cubic 2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeBlControlBlLvl Enumeration

IRD

Adp5501TypeBlControlBlLvl Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBlControlBlLvl
Public Enumeration TypeBlControlBlLvl
public enum class TypeBlControlBlLvl
type TypeBlControlBlLvl
Members
Member name | Value | Description
DaylightL1 | 0 | Daylight (L1)
OfficeL2 | 1 | Office (L2)
DarkL3 | 2 | Dark (L3)
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeBlControlFovr Enumeration

IRD

Adp5501TypeBlControlFovr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBlControlFovr
Public Enumeration TypeBlControlFovr
public enum class TypeBlControlFovr
type TypeBlControlFovr
Members
Member name | Value | Description
BacklightFadeOverrideDisabled | 0 | Backlight Fade Override: Disabled
BacklightFadeOverrideEnabled | 1 | Backlight Fade Override: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeBlControlOvpEn Enumeration

IRD

Adp5501TypeBlControlOvpEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBlControlOvpEn
Public Enumeration TypeBlControlOvpEn
public enum class TypeBlControlOvpEn
type TypeBlControlOvpEn
Members
Member name | Value | Description
SoftOVPProtectionDisabled | 0 | Soft OVP Protection: Disabled
SoftOVPProtectionEnabled | 1 | Soft OVP Protection: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeBlFade Enumeration

IRD

Adp5501TypeBlFade Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBlFade
Public Enumeration TypeBlFade
public enum class TypeBlFade
type TypeBlFade
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_03S | 1 | 0.3 s
Value_06S | 2 | 0.6 s
Value_09S | 3 | 0.9 s
Value_12S | 4 | 1.2 s
Value_15S | 5 | 1.5 s
Value_18S | 6 | 1.8 s
Value_21S | 7 | 2.1 s
Value_24S | 8 | 2.4 s
Value_27S | 9 | 2.7 s
Value_30S | 10 | 3.0 s
Value_35S | 11 | 3.5 s
Value_40S | 12 | 4.0 s
Value_45S | 13 | 4.5 s
Value_50S | 14 | 5.0 s
Value_55S | 15 | 5.5 s
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeBlTime Enumeration

IRD

Adp5501TypeBlTime Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBlTime
Public Enumeration TypeBlTime
public enum class TypeBlTime
type TypeBlTime
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_10S | 1 | 10 s
Value_15S | 2 | 15 s
Value_20S | 3 | 20 s
Value_25S | 4 | 25 s
Value_30S | 5 | 30 s
Value_35S | 6 | 35 s
Value_40S | 7 | 40 s
Value_50S | 8 | 50 s
Value_60S | 9 | 60 s
Value_70S | 10 | 70 s
Value_80S | 11 | 80 s
Value_90S | 12 | 90 s
Value_100S | 13 | 100 s
Value_110S | 14 | 110 s
Value_120S | 15 | 120 s
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeInterruptEnableAutoLdEn Enumeration

IRD

Adp5501TypeInterruptEnableAutoLdEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableAutoLdEn
Public Enumeration TypeInterruptEnableAutoLdEn
public enum class TypeInterruptEnableAutoLdEn
type TypeInterruptEnableAutoLdEn
Members
Member name | Value | Description
AutoloadDisabled | 0 | Autoload: Disabled
AutoloadEnabled | 1 | Autoload: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeInterruptEnableCmprIen Enumeration

IRD

Adp5501TypeInterruptEnableCmprIen Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableCmprIen
Public Enumeration TypeInterruptEnableCmprIen
public enum class TypeInterruptEnableCmprIen
type TypeInterruptEnableCmprIen
Members
Member name | Value | Description
ComparatorInterruptDisabled | 0 | Comparator Interrupt: Disabled
ComparatorInterruptEnabled | 1 | Comparator Interrupt: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeInterruptEnableOvpIen Enumeration

IRD

Adp5501TypeInterruptEnableOvpIen Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableOvpIen
Public Enumeration TypeInterruptEnableOvpIen
public enum class TypeInterruptEnableOvpIen
type TypeInterruptEnableOvpIen
Members
Member name | Value | Description
OVPInterruptDisabled | 0 | OVP Interrupt: Disabled
OVPInterruptEnabled | 1 | OVP Interrupt: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeLedFade Enumeration

IRD

Adp5501TypeLedFade Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedFade
Public Enumeration TypeLedFade
public enum class TypeLedFade
type TypeLedFade
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_03S | 1 | 0.3 s
Value_06S | 2 | 0.6 s
Value_09S | 3 | 0.9 s
Value_12S | 4 | 1.2 s
Value_15S | 5 | 1.5 s
Value_18S | 6 | 1.8 s
Value_21S | 7 | 2.1 s
Value_24S | 8 | 2.4 s
Value_27S | 9 | 2.7 s
Value_30S | 10 | 3.0 s
Value_35S | 11 | 3.5 s
Value_40S | 12 | 4.0 s
Value_45S | 13 | 4.5 s
Value_50S | 14 | 5.0 s
Value_55S | 15 | 5.5 s
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeLedSinkControlLed0En Enumeration

IRD

Adp5501TypeLedSinkControlLed0En Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedSinkControlLed0En
Public Enumeration TypeLedSinkControlLed0En
public enum class TypeLedSinkControlLed0En
type TypeLedSinkControlLed0En
Members
Member name | Value | Description
LED0SinkDisabled | 0 | LED0 Sink: Disabled
LED0SinkEnabled | 1 | LED0 Sink: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeLedSinkControlLed1En Enumeration

IRD

Adp5501TypeLedSinkControlLed1En Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedSinkControlLed1En
Public Enumeration TypeLedSinkControlLed1En
public enum class TypeLedSinkControlLed1En
type TypeLedSinkControlLed1En
Members
Member name | Value | Description
LED1SinkDisabled | 0 | LED1 Sink: Disabled
LED1SinkEnabled | 1 | LED1 Sink: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeLedSinkControlLed2En Enumeration

IRD

Adp5501TypeLedSinkControlLed2En Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedSinkControlLed2En
Public Enumeration TypeLedSinkControlLed2En
public enum class TypeLedSinkControlLed2En
type TypeLedSinkControlLed2En
Members
Member name | Value | Description
LED2SinkDisabled | 0 | LED2 Sink: Disabled
LED2SinkEnabled | 1 | LED2 Sink: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeLedSinkControlLedLaw Enumeration

IRD

Adp5501TypeLedSinkControlLedLaw Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedSinkControlLedLaw
Public Enumeration TypeLedSinkControlLedLaw
public enum class TypeLedSinkControlLedLaw
type TypeLedSinkControlLedLaw
Members
Member name | Value | Description
Linear | 0 | Linear
Square | 1 | Square
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeLedTimeLedOfft Enumeration

IRD

Adp5501TypeLedTimeLedOfft Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedTimeLedOfft
Public Enumeration TypeLedTimeLedOfft
public enum class TypeLedTimeLedOfft
type TypeLedTimeLedOfft
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_06S | 1 | 0.6 s
Value_08S | 2 | 0.8 s
Value_12S | 3 | 1.2 s
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeLedTimeLedOnt Enumeration

IRD

Adp5501TypeLedTimeLedOnt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedTimeLedOnt
Public Enumeration TypeLedTimeLedOnt
public enum class TypeLedTimeLedOnt
type TypeLedTimeLedOnt
Members
Member name | Value | Description
Value_02S | 0 | 0.2 s
Value_06S | 1 | 0.6 s
Value_08S | 2 | 0.8 s
Value_12S | 3 | 1.2 s
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeModeStatusBlEn Enumeration

IRD

Adp5501TypeModeStatusBlEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeStatusBlEn
Public Enumeration TypeModeStatusBlEn
public enum class TypeModeStatusBlEn
type TypeModeStatusBlEn
Members
Member name | Value | Description
BacklightDriverDisabled | 0 | Backlight Driver: Disabled
BacklightDriverEnabled | 1 | Backlight Driver: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeModeStatusCmprInt Enumeration

IRD

Adp5501TypeModeStatusCmprInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeStatusCmprInt
Public Enumeration TypeModeStatusCmprInt
public enum class TypeModeStatusCmprInt
type TypeModeStatusCmprInt
Members
Member name | Value | Description
ComparatorNotTriggered | 0 | Comparator: Not Triggered
ComparatorTriggered | 1 | Comparator: Triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeModeStatusDimEn Enumeration

IRD

Adp5501TypeModeStatusDimEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeStatusDimEn
Public Enumeration TypeModeStatusDimEn
public enum class TypeModeStatusDimEn
type TypeModeStatusDimEn
Members
Member name | Value | Description
DimModeDisabled | 0 | Dim Mode: Disabled
DimModeEnabled | 1 | Dim Mode: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeModeStatusOvpInt Enumeration

IRD

Adp5501TypeModeStatusOvpInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeStatusOvpInt
Public Enumeration TypeModeStatusOvpInt
public enum class TypeModeStatusOvpInt
type TypeModeStatusOvpInt
Members
Member name | Value | Description
OVPNotDetected | 0 | OVP: Not Detected
OVPDetected | 1 | OVP: Detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5501.TypeModeStatusStnby Enumeration

IRD

Adp5501TypeModeStatusStnby Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeStatusStnby
Public Enumeration TypeModeStatusStnby
public enum class TypeModeStatusStnby
type TypeModeStatusStnby
Members
Member name | Value | Description
StandbyMode | 0 | Standby Mode
OperatingMode | 1 | Operating Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520 Class

Analog Devices: ADP 5520
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdp5520

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adp5520
Public Class Adp5520
public ref class Adp5520
type Adp5520 =  class end

The Adp5520 type exposes the following members.

Constructors
 | Name | Description
Public method | Adp5520 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AuxiliaryLEDOnAndOffTimersLED1OFFT | Auxiliary LED On and Off Timers: LED1_OFFT
Public property | AuxiliaryLEDOnAndOffTimersLED2OFFT | Auxiliary LED On and Off Timers: LED2_OFFT
Public property | AuxiliaryLEDOnAndOffTimersLED3OFFT | Auxiliary LED On and Off Timers: LED3_OFFT
Public property | AuxiliaryLEDOnAndOffTimersLEDONT | Auxiliary LED On and Off Timers: LED_ONT
Public property | BacklightControlBLAUTOADJ | Backlight Control: BL_AUTO_ADJ
Public property | BacklightControlBLLAW | Backlight Control: BL_LAW
Public property | BacklightControlBLLVL | Backlight Control: BL_LVL
Public property | BacklightControlFOVR | Backlight Control: FOVR
Public property | BacklightControlKPBLEN | Backlight Control: KP_BL_EN
Public property | BacklightControlOVPEN | Backlight Control: OVP_EN
Public property | BacklightCurrentValue | Backlight Current Value
Public property | BacklightFadeInFadeOutTimersBLFI | Backlight Fade-In & Fade-Out Timers: BL_FI
Public property | BacklightFadeInFadeOutTimersBLFO | Backlight Fade-In & Fade-Out Timers: BL_FO
Public property | BacklightOffDimTimersBLDIMT | Backlight Off & Dim Timers: BL_DIMT
Public property | BacklightOffDimTimersBLOFFT | Backlight Off & Dim Timers: BL_OFFT
Public property | DeviceModeStatusBLEN | Device Mode & Status: BL_EN
Public property | DeviceModeStatusCMPRINT | Device Mode & Status: CMPR_INT
Public property | DeviceModeStatusDIMEN | Device Mode & Status: DIM_EN
Public property | DeviceModeStatusGPIINT | Device Mode & Status: GPI_INT
Public property | DeviceModeStatusKPINT | Device Mode & Status: KP_INT
Public property | DeviceModeStatusKRINT | Device Mode & Status: KR_INT
Public property | DeviceModeStatusNSTNBY | Device Mode & Status: nSTNBY
Public property | DeviceModeStatusOVPINT | Device Mode & Status: OVP_INT
Public property | GPIOConfiguration1C0CONFIG | GPIO Configuration 1: C0_CONFIG
Public property | GPIOConfiguration1C1CONFIG | GPIO Configuration 1: C1_CONFIG
Public property | GPIOConfiguration1C2CONFIG | GPIO Configuration 1: C2_CONFIG
Public property | GPIOConfiguration1C3CONFIG | GPIO Configuration 1: C3_CONFIG
Public property | GPIOConfiguration1R0CONFIG | GPIO Configuration 1: R0_CONFIG
Public property | GPIOConfiguration1R1CONFIG | GPIO Configuration 1: R1_CONFIG
Public property | GPIOConfiguration1R2CONFIG | GPIO Configuration 1: R2_CONFIG
Public property | GPIOConfiguration1R3CONFIG | GPIO Configuration 1: R3_CONFIG
Public property | GPIOConfiguration2D0DIR | GPIO Configuration 2: D0_DIR
Public property | GPIOConfiguration2D1DIR | GPIO Configuration 2: D1_DIR
Public property | GPIOConfiguration2D2DIR | GPIO Configuration 2: D2_DIR
Public property | GPIOConfiguration2D3DIR | GPIO Configuration 2: D3_DIR
Public property | GPIOConfiguration2D4DIR | GPIO Configuration 2: D4_DIR
Public property | GPIOConfiguration2D5DIR | GPIO Configuration 2: D5_DIR
Public property | GPIOConfiguration2D6DIR | GPIO Configuration 2: D6_DIR
Public property | GPIOConfiguration2D7DIR | GPIO Configuration 2: D7_DIR
Public property | GPIOInputDebounceEnableDisableD0INDBNC | GPIO Input Debounce Enable/Disable: D0_IN_DBNC
Public property | GPIOInputDebounceEnableDisableD1INDBNC | GPIO Input Debounce Enable/Disable: D1_IN_DBNC
Public property | GPIOInputDebounceEnableDisableD2INDBNC | GPIO Input Debounce Enable/Disable: D2_IN_DBNC
Public property | GPIOInputDebounceEnableDisableD3INDBNC | GPIO Input Debounce Enable/Disable: D3_IN_DBNC
Public property | GPIOInputDebounceEnableDisableD4INDBNC | GPIO Input Debounce Enable/Disable: D4_IN_DBNC
Public property | GPIOInputDebounceEnableDisableD5INDBNC | GPIO Input Debounce Enable/Disable: D5_IN_DBNC
Public property | GPIOInputDebounceEnableDisableD6INDBNC | GPIO Input Debounce Enable/Disable: D6_IN_DBNC
Public property | GPIOInputDebounceEnableDisableD7INDBNC | GPIO Input Debounce Enable/Disable: D7_IN_DBNC
Public property | GPIOInputStatusD0IN | GPIO Input Status: D0_IN
Public property | GPIOInputStatusD1IN | GPIO Input Status: D1_IN
Public property | GPIOInputStatusD2IN | GPIO Input Status: D2_IN
Public property | GPIOInputStatusD3IN | GPIO Input Status: D3_IN
Public property | GPIOInputStatusD4IN | GPIO Input Status: D4_IN
Public property | GPIOInputStatusD5IN | GPIO Input Status: D5_IN
Public property | GPIOInputStatusD6IN | GPIO Input Status: D6_IN
Public property | GPIOInputStatusD7IN | GPIO Input Status: D7_IN
Public property | GPIOInterruptEnableD0INIEN | GPIO Interrupt Enable: D0_IN_IEN
Public property | GPIOInterruptEnableD1INIEN | GPIO Interrupt Enable: D1_IN_IEN
Public property | GPIOInterruptEnableD2INIEN | GPIO Interrupt Enable: D2_IN_IEN
Public property | GPIOInterruptEnableD3INIEN | GPIO Interrupt Enable: D3_IN_IEN
Public property | GPIOInterruptEnableD4INIEN | GPIO Interrupt Enable: D4_IN_IEN
Public property | GPIOInterruptEnableD5INIEN | GPIO Interrupt Enable: D5_IN_IEN
Public property | GPIOInterruptEnableD6INIEN | GPIO Interrupt Enable: D6_IN_IEN
Public property | GPIOInterruptEnableD7INIEN | GPIO Interrupt Enable: D7_IN_IEN
Public property | GPIOInterruptLevelConfigurationD0ILVL | GPIO Interrupt Level Configuration: D0_ILVL
Public property | GPIOInterruptLevelConfigurationD1ILVL | GPIO Interrupt Level Configuration: D1_ILVL
Public property | GPIOInterruptLevelConfigurationD2ILVL | GPIO Interrupt Level Configuration: D2_ILVL
Public property | GPIOInterruptLevelConfigurationD3ILVL | GPIO Interrupt Level Configuration: D3_ILVL
Public property | GPIOInterruptLevelConfigurationD4ILVL | GPIO Interrupt Level Configuration: D4_ILVL
Public property | GPIOInterruptLevelConfigurationD5ILVL | GPIO Interrupt Level Configuration: D5_ILVL
Public property | GPIOInterruptLevelConfigurationD6ILVL | GPIO Interrupt Level Configuration: D6_ILVL
Public property | GPIOInterruptLevelConfigurationD7ILVL | GPIO Interrupt Level Configuration: D7_ILVL
Public property | GPIOInterruptStatusD0INISTAT | GPIO Interrupt Status: D0_IN_ISTAT
Public property | GPIOInterruptStatusD1INISTAT | GPIO Interrupt Status: D1_IN_ISTAT
Public property | GPIOInterruptStatusD2INISTAT | GPIO Interrupt Status: D2_IN_ISTAT
Public property | GPIOInterruptStatusD3INISTAT | GPIO Interrupt Status: D3_IN_ISTAT
Public property | GPIOInterruptStatusD4INISTAT | GPIO Interrupt Status: D4_IN_ISTAT
Public property | GPIOInterruptStatusD5INISTAT | GPIO Interrupt Status: D5_IN_ISTAT
Public property | GPIOInterruptStatusD6INISTAT | GPIO Interrupt Status: D6_IN_ISTAT
Public property | GPIOInterruptStatusD7INISTAT | GPIO Interrupt Status: D7_IN_ISTAT
Public property | GPIOOutputStatusD0OUT | GPIO Output Status: D0_OUT
Public property | GPIOOutputStatusD1OUT | GPIO Output Status: D1_OUT
Public property | GPIOOutputStatusD2OUT | GPIO Output Status: D2_OUT
Public property | GPIOOutputStatusD3OUT | GPIO Output Status: D3_OUT
Public property | GPIOOutputStatusD4OUT | GPIO Output Status: D4_OUT
Public property | GPIOOutputStatusD5OUT | GPIO Output Status: D5_OUT
Public property | GPIOOutputStatusD6OUT | GPIO Output Status: D6_OUT
Public property | GPIOOutputStatusD7OUT | GPIO Output Status: D7_OUT
Public property | GPIOPullUpEnableDisableD0PULL | GPIO Pull-Up Enable/Disable: D0_PULL
Public property | GPIOPullUpEnableDisableD1PULL | GPIO Pull-Up Enable/Disable: D1_PULL
Public property | GPIOPullUpEnableDisableD2PULL | GPIO Pull-Up Enable/Disable: D2_PULL
Public property | GPIOPullUpEnableDisableD3PULL | GPIO Pull-Up Enable/Disable: D3_PULL
Public property | GPIOPullUpEnableDisableD4PULL | GPIO Pull-Up Enable/Disable: D4_PULL
Public property | GPIOPullUpEnableDisableD5PULL | GPIO Pull-Up Enable/Disable: D5_PULL
Public property | GPIOPullUpEnableDisableD6PULL | GPIO Pull-Up Enable/Disable: D6_PULL
Public property | GPIOPullUpEnableDisableD7PULL | GPIO Pull-Up Enable/Disable: D7_PULL
Public property | InterruptEnableAUTOLDEN | Interrupt Enable: AUTO_LD_EN
Public property | InterruptEnableCMPRIEN | Interrupt Enable: CMPR_IEN
Public property | InterruptEnableKPIEN | Interrupt Enable: KP_IEN
Public property | InterruptEnableKRIEN | Interrupt Enable: KR_IEN
Public property | InterruptEnableOVPIEN | Interrupt Enable: OVP_IEN
Public property | KeyPressInterruptStatus1KPAISTAT | Key Press Interrupt Status 1: KP_A_ISTAT
Public property | KeyPressInterruptStatus1KPBISTAT | Key Press Interrupt Status 1: KP_B_ISTAT
Public property | KeyPressInterruptStatus1KPCISTAT | Key Press Interrupt Status 1: KP_C_ISTAT
Public property | KeyPressInterruptStatus1KPDISTAT | Key Press Interrupt Status 1: KP_D_ISTAT
Public property | KeyPressInterruptStatus1KPEISTAT | Key Press Interrupt Status 1: KP_E_ISTAT
Public property | KeyPressInterruptStatus1KPFISTAT | Key Press Interrupt Status 1: KP_F_ISTAT
Public property | KeyPressInterruptStatus1KPGISTAT | Key Press Interrupt Status 1: KP_G_ISTAT
Public property | KeyPressInterruptStatus1KPHISTAT | Key Press Interrupt Status 1: KP_H_ISTAT
Public property | KeyPressInterruptStatus2KPIISTAT | Key Press Interrupt Status 2: KP_I_ISTAT
Public property | KeyPressInterruptStatus2KPJISTAT | Key Press Interrupt Status 2: KP_J_ISTAT
Public property | KeyPressInterruptStatus2KPKISTAT | Key Press Interrupt Status 2: KP_K_ISTAT
Public property | KeyPressInterruptStatus2KPLISTAT | Key Press Interrupt Status 2: KP_L_ISTAT
Public property | KeyPressInterruptStatus2KPMISTAT | Key Press Interrupt Status 2: KP_M_ISTAT
Public property | KeyPressInterruptStatus2KPNISTAT | Key Press Interrupt Status 2: KP_N_ISTAT
Public property | KeyPressInterruptStatus2KPOISTAT | Key Press Interrupt Status 2: KP_O_ISTAT
Public property | KeyPressInterruptStatus2KPPISTAT | Key Press Interrupt Status 2: KP_P_ISTAT
Public property | KeyReleaseInterruptStatus1KRAISTAT | Key Release Interrupt Status 1: KR_A_ISTAT
Public property | KeyReleaseInterruptStatus1KRBISTAT | Key Release Interrupt Status 1: KR_B_ISTAT
Public property | KeyReleaseInterruptStatus1KRCISTAT | Key Release Interrupt Status 1: KR_C_ISTAT
Public property | KeyReleaseInterruptStatus1KRDISTAT | Key Release Interrupt Status 1: KR_D_ISTAT
Public property | KeyReleaseInterruptStatus1KREISTAT | Key Release Interrupt Status 1: KR_E_ISTAT
Public property | KeyReleaseInterruptStatus1KRFISTAT | Key Release Interrupt Status 1: KR_F_ISTAT
Public property | KeyReleaseInterruptStatus1KRGISTAT | Key Release Interrupt Status 1: KR_G_ISTAT
Public property | KeyReleaseInterruptStatus1KRHISTAT | Key Release Interrupt Status 1: KR_H_ISTAT
Public property | KeyReleaseInterruptStatus2KRIISTAT | Key Release Interrupt Status 2: KR_I_ISTAT
Public property | KeyReleaseInterruptStatus2KRJISTAT | Key Release Interrupt Status 2: KR_J_ISTAT
Public property | KeyReleaseInterruptStatus2KRKISTAT | Key Release Interrupt Status 2: KR_K_ISTAT
Public property | KeyReleaseInterruptStatus2KRLISTAT | Key Release Interrupt Status 2: KR_L_ISTAT
Public property | KeyReleaseInterruptStatus2KRMISTAT | Key Release Interrupt Status 2: KR_M_ISTAT
Public property | KeyReleaseInterruptStatus2KRNISTAT | Key Release Interrupt Status 2: KR_N_ISTAT
Public property | KeyReleaseInterruptStatus2KROISTAT | Key Release Interrupt Status 2: KR_O_ISTAT
Public property | KeyReleaseInterruptStatus2KRPISTAT | Key Release Interrupt Status 2: KR_P_ISTAT
Public property | KeyStatus1KEYASTAT | Key Status 1: KEY_A_STAT
Public property | KeyStatus1KEYBSTAT | Key Status 1: KEY_B_STAT
Public property | KeyStatus1KEYCSTAT | Key Status 1: KEY_C_STAT
Public property | KeyStatus1KEYDSTAT | Key Status 1: KEY_D_STAT
Public property | KeyStatus1KEYESTAT | Key Status 1: KEY_E_STAT
Public property | KeyStatus1KEYFSTAT | Key Status 1: KEY_F_STAT
Public property | KeyStatus1KEYGSTAT | Key Status 1: KEY_G_STAT
Public property | KeyStatus1KEYHSTAT | Key Status 1: KEY_H_STAT
Public property | KeyStatus2KEYISTAT | Key Status 2: KEY_I_STAT
Public property | KeyStatus2KEYJSTAT | Key Status 2: KEY_J_STAT
Public property | KeyStatus2KEYKSTAT | Key Status 2: KEY_K_STAT
Public property | KeyStatus2KEYLSTAT | Key Status 2: KEY_L_STAT
Public property | KeyStatus2KEYMSTAT | Key Status 2: KEY_M_STAT
Public property | KeyStatus2KEYNSTAT | Key Status 2: KEY_N_STAT
Public property | KeyStatus2KEYOSTAT | Key Status 2: KEY_O_STAT
Public property | KeyStatus2KEYPSTAT | Key Status 2: KEY_P_STAT
Public property | LED1SinkCurrent | LED 1 Sink Current
Public property | LED2SinkCurrent | LED 2 Sink Current
Public property | LED3SinkCurrent | LED 3 Sink Current
Public property | LEDControlC3MODE | LED Control: C3_MODE
Public property | LEDControlLED1EN | LED Control: LED1_EN
Public property | LEDControlLED2EN | LED Control: LED2_EN
Public property | LEDControlLED3EN | LED Control: LED3_EN
Public property | LEDControlLEDLAW | LED Control: LED_LAW
Public property | LEDControlR3MODE | LED Control: R3_MODE
Public property | LEDFadeInAndFadeOutTimersLEDFI | LED Fade-In and Fade-Out Timers: LED_FI
Public property | LEDFadeInAndFadeOutTimersLEDFO | LED Fade-In and Fade-Out Timers: LED_FO
Public property | Level1DaylightDimCurrent | Level 1 (Daylight) Dim Current
Public property | Level1DaylightMaximumCurrent | Level 1 (Daylight) Maximum Current
Public property | Level2OfficeComparatorHysteresis | Level 2 (Office) Comparator Hysteresis (unit: µA)
Public property | Level2OfficeComparatorTripPoint | Level 2 (Office) Comparator Trip Point (unit: µA)
Public property | Level2OfficeDimCurrent | Level 2 (Office) Dim Current
Public property | Level2OfficeMaximumCurrent | Level 2 (Office) Maximum Current
Public property | Level3DarkComparatorHysteresis | Level 3 (Dark) Comparator Hysteresis (unit: µA)
Public property | Level3DarkComparatorTripPoint | Level 3 (Dark) Comparator Trip Point (unit: µA)
Public property | Level3DarkDimCurrent | Level 3 (Dark) Dim Current
Public property | Level3DarkMaximumCurrent | Level 3 (Dark) Maximum Current
Public property | LightSensorComparatorConfigurationFILT | Light Sensor Comparator Configuration: FILT
Public property | LightSensorComparatorConfigurationFORCERD | Light Sensor Comparator Configuration: FORCE_RD
Public property | LightSensorComparatorConfigurationL2EN | Light Sensor Comparator Configuration: L2_EN
Public property | LightSensorComparatorConfigurationL2OUT | Light Sensor Comparator Configuration: L2_OUT
Public property | LightSensorComparatorConfigurationL3EN | Light Sensor Comparator Configuration: L3_EN
Public property | LightSensorComparatorConfigurationL3OUT | Light Sensor Comparator Configuration: L3_OUT
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Backlight Driver with I/O Expander
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adp5520(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adp5520

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520 Properties

The Adp5520 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AuxiliaryLEDOnAndOffTimersLED1OFFT | Auxiliary LED On and Off Timers: LED1_OFFT
Public property | AuxiliaryLEDOnAndOffTimersLED2OFFT | Auxiliary LED On and Off Timers: LED2_OFFT
Public property | AuxiliaryLEDOnAndOffTimersLED3OFFT | Auxiliary LED On and Off Timers: LED3_OFFT
Public property | AuxiliaryLEDOnAndOffTimersLEDONT | Auxiliary LED On and Off Timers: LED_ONT
Public property | BacklightControlBLAUTOADJ | Backlight Control: BL_AUTO_ADJ
Public property | BacklightControlBLLAW | Backlight Control: BL_LAW
Public property | BacklightControlBLLVL | Backlight Control: BL_LVL
Public property | BacklightControlFOVR | Backlight Control: FOVR
Public property | BacklightControlKPBLEN | Backlight Control: KP_BL_EN
Public property | BacklightControlOVPEN | Backlight Control: OVP_EN
Public property | BacklightCurrentValue | Backlight Current Value
Public property | BacklightFadeInFadeOutTimersBLFI | Backlight Fade-In & Fade-Out Timers: BL_FI
Public property | BacklightFadeInFadeOutTimersBLFO | Backlight Fade-In & Fade-Out Timers: BL_FO
Public property | BacklightOffDimTimersBLDIMT | Backlight Off & Dim Timers: BL_DIMT
Public property | BacklightOffDimTimersBLOFFT | Backlight Off & Dim Timers: BL_OFFT
Public property | DeviceModeStatusBLEN | Device Mode & Status: BL_EN
Public property | DeviceModeStatusCMPRINT | Device Mode & Status: CMPR_INT
Public property | DeviceModeStatusDIMEN | Device Mode & Status: DIM_EN
Public property | DeviceModeStatusGPIINT | Device Mode & Status: GPI_INT
Public property | DeviceModeStatusKPINT | Device Mode & Status: KP_INT
Public property | DeviceModeStatusKRINT | Device Mode & Status: KR_INT
Public property | DeviceModeStatusNSTNBY | Device Mode & Status: nSTNBY
Public property | DeviceModeStatusOVPINT | Device Mode & Status: OVP_INT
Public property | GPIOConfiguration1C0CONFIG | GPIO Configuration 1: C0_CONFIG
Public property | GPIOConfiguration1C1CONFIG | GPIO Configuration 1: C1_CONFIG
Public property | GPIOConfiguration1C2CONFIG | GPIO Configuration 1: C2_CONFIG
Public property | GPIOConfiguration1C3CONFIG | GPIO Configuration 1: C3_CONFIG
Public property | GPIOConfiguration1R0CONFIG | GPIO Configuration 1: R0_CONFIG
Public property | GPIOConfiguration1R1CONFIG | GPIO Configuration 1: R1_CONFIG
Public property | GPIOConfiguration1R2CONFIG | GPIO Configuration 1: R2_CONFIG
Public property | GPIOConfiguration1R3CONFIG | GPIO Configuration 1: R3_CONFIG
Public property | GPIOConfiguration2D0DIR | GPIO Configuration 2: D0_DIR
Public property | GPIOConfiguration2D1DIR | GPIO Configuration 2: D1_DIR
Public property | GPIOConfiguration2D2DIR | GPIO Configuration 2: D2_DIR
Public property | GPIOConfiguration2D3DIR | GPIO Configuration 2: D3_DIR
Public property | GPIOConfiguration2D4DIR | GPIO Configuration 2: D4_DIR
Public property | GPIOConfiguration2D5DIR | GPIO Configuration 2: D5_DIR
Public property | GPIOConfiguration2D6DIR | GPIO Configuration 2: D6_DIR
Public property | GPIOConfiguration2D7DIR | GPIO Configuration 2: D7_DIR
Public property | GPIOInputDebounceEnableDisableD0INDBNC | GPIO Input Debounce Enable/Disable: D0_IN_DBNC
Public property | GPIOInputDebounceEnableDisableD1INDBNC | GPIO Input Debounce Enable/Disable: D1_IN_DBNC
Public property | GPIOInputDebounceEnableDisableD2INDBNC | GPIO Input Debounce Enable/Disable: D2_IN_DBNC
Public property | GPIOInputDebounceEnableDisableD3INDBNC | GPIO Input Debounce Enable/Disable: D3_IN_DBNC
Public property | GPIOInputDebounceEnableDisableD4INDBNC | GPIO Input Debounce Enable/Disable: D4_IN_DBNC
Public property | GPIOInputDebounceEnableDisableD5INDBNC | GPIO Input Debounce Enable/Disable: D5_IN_DBNC
Public property | GPIOInputDebounceEnableDisableD6INDBNC | GPIO Input Debounce Enable/Disable: D6_IN_DBNC
Public property | GPIOInputDebounceEnableDisableD7INDBNC | GPIO Input Debounce Enable/Disable: D7_IN_DBNC
Public property | GPIOInputStatusD0IN | GPIO Input Status: D0_IN
Public property | GPIOInputStatusD1IN | GPIO Input Status: D1_IN
Public property | GPIOInputStatusD2IN | GPIO Input Status: D2_IN
Public property | GPIOInputStatusD3IN | GPIO Input Status: D3_IN
Public property | GPIOInputStatusD4IN | GPIO Input Status: D4_IN
Public property | GPIOInputStatusD5IN | GPIO Input Status: D5_IN
Public property | GPIOInputStatusD6IN | GPIO Input Status: D6_IN
Public property | GPIOInputStatusD7IN | GPIO Input Status: D7_IN
Public property | GPIOInterruptEnableD0INIEN | GPIO Interrupt Enable: D0_IN_IEN
Public property | GPIOInterruptEnableD1INIEN | GPIO Interrupt Enable: D1_IN_IEN
Public property | GPIOInterruptEnableD2INIEN | GPIO Interrupt Enable: D2_IN_IEN
Public property | GPIOInterruptEnableD3INIEN | GPIO Interrupt Enable: D3_IN_IEN
Public property | GPIOInterruptEnableD4INIEN | GPIO Interrupt Enable: D4_IN_IEN
Public property | GPIOInterruptEnableD5INIEN | GPIO Interrupt Enable: D5_IN_IEN
Public property | GPIOInterruptEnableD6INIEN | GPIO Interrupt Enable: D6_IN_IEN
Public property | GPIOInterruptEnableD7INIEN | GPIO Interrupt Enable: D7_IN_IEN
Public property | GPIOInterruptLevelConfigurationD0ILVL | GPIO Interrupt Level Configuration: D0_ILVL
Public property | GPIOInterruptLevelConfigurationD1ILVL | GPIO Interrupt Level Configuration: D1_ILVL
Public property | GPIOInterruptLevelConfigurationD2ILVL | GPIO Interrupt Level Configuration: D2_ILVL
Public property | GPIOInterruptLevelConfigurationD3ILVL | GPIO Interrupt Level Configuration: D3_ILVL
Public property | GPIOInterruptLevelConfigurationD4ILVL | GPIO Interrupt Level Configuration: D4_ILVL
Public property | GPIOInterruptLevelConfigurationD5ILVL | GPIO Interrupt Level Configuration: D5_ILVL
Public property | GPIOInterruptLevelConfigurationD6ILVL | GPIO Interrupt Level Configuration: D6_ILVL
Public property | GPIOInterruptLevelConfigurationD7ILVL | GPIO Interrupt Level Configuration: D7_ILVL
Public property | GPIOInterruptStatusD0INISTAT | GPIO Interrupt Status: D0_IN_ISTAT
Public property | GPIOInterruptStatusD1INISTAT | GPIO Interrupt Status: D1_IN_ISTAT
Public property | GPIOInterruptStatusD2INISTAT | GPIO Interrupt Status: D2_IN_ISTAT
Public property | GPIOInterruptStatusD3INISTAT | GPIO Interrupt Status: D3_IN_ISTAT
Public property | GPIOInterruptStatusD4INISTAT | GPIO Interrupt Status: D4_IN_ISTAT
Public property | GPIOInterruptStatusD5INISTAT | GPIO Interrupt Status: D5_IN_ISTAT
Public property | GPIOInterruptStatusD6INISTAT | GPIO Interrupt Status: D6_IN_ISTAT
Public property | GPIOInterruptStatusD7INISTAT | GPIO Interrupt Status: D7_IN_ISTAT
Public property | GPIOOutputStatusD0OUT | GPIO Output Status: D0_OUT
Public property | GPIOOutputStatusD1OUT | GPIO Output Status: D1_OUT
Public property | GPIOOutputStatusD2OUT | GPIO Output Status: D2_OUT
Public property | GPIOOutputStatusD3OUT | GPIO Output Status: D3_OUT
Public property | GPIOOutputStatusD4OUT | GPIO Output Status: D4_OUT
Public property | GPIOOutputStatusD5OUT | GPIO Output Status: D5_OUT
Public property | GPIOOutputStatusD6OUT | GPIO Output Status: D6_OUT
Public property | GPIOOutputStatusD7OUT | GPIO Output Status: D7_OUT
Public property | GPIOPullUpEnableDisableD0PULL | GPIO Pull-Up Enable/Disable: D0_PULL
Public property | GPIOPullUpEnableDisableD1PULL | GPIO Pull-Up Enable/Disable: D1_PULL
Public property | GPIOPullUpEnableDisableD2PULL | GPIO Pull-Up Enable/Disable: D2_PULL
Public property | GPIOPullUpEnableDisableD3PULL | GPIO Pull-Up Enable/Disable: D3_PULL
Public property | GPIOPullUpEnableDisableD4PULL | GPIO Pull-Up Enable/Disable: D4_PULL
Public property | GPIOPullUpEnableDisableD5PULL | GPIO Pull-Up Enable/Disable: D5_PULL
Public property | GPIOPullUpEnableDisableD6PULL | GPIO Pull-Up Enable/Disable: D6_PULL
Public property | GPIOPullUpEnableDisableD7PULL | GPIO Pull-Up Enable/Disable: D7_PULL
Public property | InterruptEnableAUTOLDEN | Interrupt Enable: AUTO_LD_EN
Public property | InterruptEnableCMPRIEN | Interrupt Enable: CMPR_IEN
Public property | InterruptEnableKPIEN | Interrupt Enable: KP_IEN
Public property | InterruptEnableKRIEN | Interrupt Enable: KR_IEN
Public property | InterruptEnableOVPIEN | Interrupt Enable: OVP_IEN
Public property | KeyPressInterruptStatus1KPAISTAT | Key Press Interrupt Status 1: KP_A_ISTAT
Public property | KeyPressInterruptStatus1KPBISTAT | Key Press Interrupt Status 1: KP_B_ISTAT
Public property | KeyPressInterruptStatus1KPCISTAT | Key Press Interrupt Status 1: KP_C_ISTAT
Public property | KeyPressInterruptStatus1KPDISTAT | Key Press Interrupt Status 1: KP_D_ISTAT
Public property | KeyPressInterruptStatus1KPEISTAT | Key Press Interrupt Status 1: KP_E_ISTAT
Public property | KeyPressInterruptStatus1KPFISTAT | Key Press Interrupt Status 1: KP_F_ISTAT
Public property | KeyPressInterruptStatus1KPGISTAT | Key Press Interrupt Status 1: KP_G_ISTAT
Public property | KeyPressInterruptStatus1KPHISTAT | Key Press Interrupt Status 1: KP_H_ISTAT
Public property | KeyPressInterruptStatus2KPIISTAT | Key Press Interrupt Status 2: KP_I_ISTAT
Public property | KeyPressInterruptStatus2KPJISTAT | Key Press Interrupt Status 2: KP_J_ISTAT
Public property | KeyPressInterruptStatus2KPKISTAT | Key Press Interrupt Status 2: KP_K_ISTAT
Public property | KeyPressInterruptStatus2KPLISTAT | Key Press Interrupt Status 2: KP_L_ISTAT
Public property | KeyPressInterruptStatus2KPMISTAT | Key Press Interrupt Status 2: KP_M_ISTAT
Public property | KeyPressInterruptStatus2KPNISTAT | Key Press Interrupt Status 2: KP_N_ISTAT
Public property | KeyPressInterruptStatus2KPOISTAT | Key Press Interrupt Status 2: KP_O_ISTAT
Public property | KeyPressInterruptStatus2KPPISTAT | Key Press Interrupt Status 2: KP_P_ISTAT
Public property | KeyReleaseInterruptStatus1KRAISTAT | Key Release Interrupt Status 1: KR_A_ISTAT
Public property | KeyReleaseInterruptStatus1KRBISTAT | Key Release Interrupt Status 1: KR_B_ISTAT
Public property | KeyReleaseInterruptStatus1KRCISTAT | Key Release Interrupt Status 1: KR_C_ISTAT
Public property | KeyReleaseInterruptStatus1KRDISTAT | Key Release Interrupt Status 1: KR_D_ISTAT
Public property | KeyReleaseInterruptStatus1KREISTAT | Key Release Interrupt Status 1: KR_E_ISTAT
Public property | KeyReleaseInterruptStatus1KRFISTAT | Key Release Interrupt Status 1: KR_F_ISTAT
Public property | KeyReleaseInterruptStatus1KRGISTAT | Key Release Interrupt Status 1: KR_G_ISTAT
Public property | KeyReleaseInterruptStatus1KRHISTAT | Key Release Interrupt Status 1: KR_H_ISTAT
Public property | KeyReleaseInterruptStatus2KRIISTAT | Key Release Interrupt Status 2: KR_I_ISTAT
Public property | KeyReleaseInterruptStatus2KRJISTAT | Key Release Interrupt Status 2: KR_J_ISTAT
Public property | KeyReleaseInterruptStatus2KRKISTAT | Key Release Interrupt Status 2: KR_K_ISTAT
Public property | KeyReleaseInterruptStatus2KRLISTAT | Key Release Interrupt Status 2: KR_L_ISTAT
Public property | KeyReleaseInterruptStatus2KRMISTAT | Key Release Interrupt Status 2: KR_M_ISTAT
Public property | KeyReleaseInterruptStatus2KRNISTAT | Key Release Interrupt Status 2: KR_N_ISTAT
Public property | KeyReleaseInterruptStatus2KROISTAT | Key Release Interrupt Status 2: KR_O_ISTAT
Public property | KeyReleaseInterruptStatus2KRPISTAT | Key Release Interrupt Status 2: KR_P_ISTAT
Public property | KeyStatus1KEYASTAT | Key Status 1: KEY_A_STAT
Public property | KeyStatus1KEYBSTAT | Key Status 1: KEY_B_STAT
Public property | KeyStatus1KEYCSTAT | Key Status 1: KEY_C_STAT
Public property | KeyStatus1KEYDSTAT | Key Status 1: KEY_D_STAT
Public property | KeyStatus1KEYESTAT | Key Status 1: KEY_E_STAT
Public property | KeyStatus1KEYFSTAT | Key Status 1: KEY_F_STAT
Public property | KeyStatus1KEYGSTAT | Key Status 1: KEY_G_STAT
Public property | KeyStatus1KEYHSTAT | Key Status 1: KEY_H_STAT
Public property | KeyStatus2KEYISTAT | Key Status 2: KEY_I_STAT
Public property | KeyStatus2KEYJSTAT | Key Status 2: KEY_J_STAT
Public property | KeyStatus2KEYKSTAT | Key Status 2: KEY_K_STAT
Public property | KeyStatus2KEYLSTAT | Key Status 2: KEY_L_STAT
Public property | KeyStatus2KEYMSTAT | Key Status 2: KEY_M_STAT
Public property | KeyStatus2KEYNSTAT | Key Status 2: KEY_N_STAT
Public property | KeyStatus2KEYOSTAT | Key Status 2: KEY_O_STAT
Public property | KeyStatus2KEYPSTAT | Key Status 2: KEY_P_STAT
Public property | LED1SinkCurrent | LED 1 Sink Current
Public property | LED2SinkCurrent | LED 2 Sink Current
Public property | LED3SinkCurrent | LED 3 Sink Current
Public property | LEDControlC3MODE | LED Control: C3_MODE
Public property | LEDControlLED1EN | LED Control: LED1_EN
Public property | LEDControlLED2EN | LED Control: LED2_EN
Public property | LEDControlLED3EN | LED Control: LED3_EN
Public property | LEDControlLEDLAW | LED Control: LED_LAW
Public property | LEDControlR3MODE | LED Control: R3_MODE
Public property | LEDFadeInAndFadeOutTimersLEDFI | LED Fade-In and Fade-Out Timers: LED_FI
Public property | LEDFadeInAndFadeOutTimersLEDFO | LED Fade-In and Fade-Out Timers: LED_FO
Public property | Level1DaylightDimCurrent | Level 1 (Daylight) Dim Current
Public property | Level1DaylightMaximumCurrent | Level 1 (Daylight) Maximum Current
Public property | Level2OfficeComparatorHysteresis | Level 2 (Office) Comparator Hysteresis (unit: µA)
Public property | Level2OfficeComparatorTripPoint | Level 2 (Office) Comparator Trip Point (unit: µA)
Public property | Level2OfficeDimCurrent | Level 2 (Office) Dim Current
Public property | Level2OfficeMaximumCurrent | Level 2 (Office) Maximum Current
Public property | Level3DarkComparatorHysteresis | Level 3 (Dark) Comparator Hysteresis (unit: µA)
Public property | Level3DarkComparatorTripPoint | Level 3 (Dark) Comparator Trip Point (unit: µA)
Public property | Level3DarkDimCurrent | Level 3 (Dark) Dim Current
Public property | Level3DarkMaximumCurrent | Level 3 (Dark) Maximum Current
Public property | LightSensorComparatorConfigurationFILT | Light Sensor Comparator Configuration: FILT
Public property | LightSensorComparatorConfigurationFORCERD | Light Sensor Comparator Configuration: FORCE_RD
Public property | LightSensorComparatorConfigurationL2EN | Light Sensor Comparator Configuration: L2_EN
Public property | LightSensorComparatorConfigurationL2OUT | Light Sensor Comparator Configuration: L2_OUT
Public property | LightSensorComparatorConfigurationL3EN | Light Sensor Comparator Configuration: L3_EN
Public property | LightSensorComparatorConfigurationL3OUT | Light Sensor Comparator Configuration: L3_OUT
Top
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.AutoFlush Property

IRD

Adp5520AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.AuxiliaryLEDOnAndOffTimersLED1OFFT Property

IRD

Adp5520AuxiliaryLEDOnAndOffTimersLED1OFFT Property

Auxiliary LED On and Off Timers: LED1_OFFT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeLedTimeLedOfft AuxiliaryLEDOnAndOffTimersLED1OFFT { get; set; }
Public Property AuxiliaryLEDOnAndOffTimersLED1OFFT As Adp5520TypeLedTimeLedOfft
    Get
    Set
public:
property Adp5520TypeLedTimeLedOfft AuxiliaryLEDOnAndOffTimersLED1OFFT {
    Adp5520TypeLedTimeLedOfft get ();
    void set (Adp5520TypeLedTimeLedOfft value);
}
member AuxiliaryLEDOnAndOffTimersLED1OFFT : Adp5520TypeLedTimeLedOfft with get, set

Property Value

Type: Adp5520TypeLedTimeLedOfft
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.AuxiliaryLEDOnAndOffTimersLED2OFFT Property

IRD

Adp5520AuxiliaryLEDOnAndOffTimersLED2OFFT Property

Auxiliary LED On and Off Timers: LED2_OFFT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeLedTimeLedOfft AuxiliaryLEDOnAndOffTimersLED2OFFT { get; set; }
Public Property AuxiliaryLEDOnAndOffTimersLED2OFFT As Adp5520TypeLedTimeLedOfft
    Get
    Set
public:
property Adp5520TypeLedTimeLedOfft AuxiliaryLEDOnAndOffTimersLED2OFFT {
    Adp5520TypeLedTimeLedOfft get ();
    void set (Adp5520TypeLedTimeLedOfft value);
}
member AuxiliaryLEDOnAndOffTimersLED2OFFT : Adp5520TypeLedTimeLedOfft with get, set

Property Value

Type: Adp5520TypeLedTimeLedOfft
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.AuxiliaryLEDOnAndOffTimersLED3OFFT Property

IRD

Adp5520AuxiliaryLEDOnAndOffTimersLED3OFFT Property

Auxiliary LED On and Off Timers: LED3_OFFT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeLedTimeLedOfft AuxiliaryLEDOnAndOffTimersLED3OFFT { get; set; }
Public Property AuxiliaryLEDOnAndOffTimersLED3OFFT As Adp5520TypeLedTimeLedOfft
    Get
    Set
public:
property Adp5520TypeLedTimeLedOfft AuxiliaryLEDOnAndOffTimersLED3OFFT {
    Adp5520TypeLedTimeLedOfft get ();
    void set (Adp5520TypeLedTimeLedOfft value);
}
member AuxiliaryLEDOnAndOffTimersLED3OFFT : Adp5520TypeLedTimeLedOfft with get, set

Property Value

Type: Adp5520TypeLedTimeLedOfft
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.AuxiliaryLEDOnAndOffTimersLEDONT Property

IRD

Adp5520AuxiliaryLEDOnAndOffTimersLEDONT Property

Auxiliary LED On and Off Timers: LED_ONT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeLedTimeLedOnt AuxiliaryLEDOnAndOffTimersLEDONT { get; set; }
Public Property AuxiliaryLEDOnAndOffTimersLEDONT As Adp5520TypeLedTimeLedOnt
    Get
    Set
public:
property Adp5520TypeLedTimeLedOnt AuxiliaryLEDOnAndOffTimersLEDONT {
    Adp5520TypeLedTimeLedOnt get ();
    void set (Adp5520TypeLedTimeLedOnt value);
}
member AuxiliaryLEDOnAndOffTimersLEDONT : Adp5520TypeLedTimeLedOnt with get, set

Property Value

Type: Adp5520TypeLedTimeLedOnt
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.BacklightControlBLAUTOADJ Property

IRD

Adp5520BacklightControlBLAUTOADJ Property

Backlight Control: BL_AUTO_ADJ

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeBlControlBlAutoAdj BacklightControlBLAUTOADJ { get; set; }
Public Property BacklightControlBLAUTOADJ As Adp5520TypeBlControlBlAutoAdj
    Get
    Set
public:
property Adp5520TypeBlControlBlAutoAdj BacklightControlBLAUTOADJ {
    Adp5520TypeBlControlBlAutoAdj get ();
    void set (Adp5520TypeBlControlBlAutoAdj value);
}
member BacklightControlBLAUTOADJ : Adp5520TypeBlControlBlAutoAdj with get, set

Property Value

Type: Adp5520TypeBlControlBlAutoAdj
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.BacklightControlBLLAW Property

IRD

Adp5520BacklightControlBLLAW Property

Backlight Control: BL_LAW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeBlControlBlLaw BacklightControlBLLAW { get; set; }
Public Property BacklightControlBLLAW As Adp5520TypeBlControlBlLaw
    Get
    Set
public:
property Adp5520TypeBlControlBlLaw BacklightControlBLLAW {
    Adp5520TypeBlControlBlLaw get ();
    void set (Adp5520TypeBlControlBlLaw value);
}
member BacklightControlBLLAW : Adp5520TypeBlControlBlLaw with get, set

Property Value

Type: Adp5520TypeBlControlBlLaw
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.BacklightControlBLLVL Property

IRD

Adp5520BacklightControlBLLVL Property

Backlight Control: BL_LVL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeBlControlBlLvl BacklightControlBLLVL { get; set; }
Public Property BacklightControlBLLVL As Adp5520TypeBlControlBlLvl
    Get
    Set
public:
property Adp5520TypeBlControlBlLvl BacklightControlBLLVL {
    Adp5520TypeBlControlBlLvl get ();
    void set (Adp5520TypeBlControlBlLvl value);
}
member BacklightControlBLLVL : Adp5520TypeBlControlBlLvl with get, set

Property Value

Type: Adp5520TypeBlControlBlLvl
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.BacklightControlFOVR Property

IRD

Adp5520BacklightControlFOVR Property

Backlight Control: FOVR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeBlControlFovr BacklightControlFOVR { get; set; }
Public Property BacklightControlFOVR As Adp5520TypeBlControlFovr
    Get
    Set
public:
property Adp5520TypeBlControlFovr BacklightControlFOVR {
    Adp5520TypeBlControlFovr get ();
    void set (Adp5520TypeBlControlFovr value);
}
member BacklightControlFOVR : Adp5520TypeBlControlFovr with get, set

Property Value

Type: Adp5520TypeBlControlFovr
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.BacklightControlKPBLEN Property

IRD

Adp5520BacklightControlKPBLEN Property

Backlight Control: KP_BL_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeBlControlKpBlEn BacklightControlKPBLEN { get; set; }
Public Property BacklightControlKPBLEN As Adp5520TypeBlControlKpBlEn
    Get
    Set
public:
property Adp5520TypeBlControlKpBlEn BacklightControlKPBLEN {
    Adp5520TypeBlControlKpBlEn get ();
    void set (Adp5520TypeBlControlKpBlEn value);
}
member BacklightControlKPBLEN : Adp5520TypeBlControlKpBlEn with get, set

Property Value

Type: Adp5520TypeBlControlKpBlEn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.BacklightControlOVPEN Property

IRD

Adp5520BacklightControlOVPEN Property

Backlight Control: OVP_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeBlControlOvpEn BacklightControlOVPEN { get; set; }
Public Property BacklightControlOVPEN As Adp5520TypeBlControlOvpEn
    Get
    Set
public:
property Adp5520TypeBlControlOvpEn BacklightControlOVPEN {
    Adp5520TypeBlControlOvpEn get ();
    void set (Adp5520TypeBlControlOvpEn value);
}
member BacklightControlOVPEN : Adp5520TypeBlControlOvpEn with get, set

Property Value

Type: Adp5520TypeBlControlOvpEn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.BacklightCurrentValue Property

IRD

Adp5520BacklightCurrentValue Property

Backlight Current Value

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte BacklightCurrentValue { get; }
Public ReadOnly Property BacklightCurrentValue As Byte
    Get
public:
property unsigned char BacklightCurrentValue {
    unsigned char get ();
}
member BacklightCurrentValue : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.BacklightFadeInFadeOutTimersBLFI Property

IRD

Adp5520BacklightFadeInFadeOutTimersBLFI Property

Backlight Fade-In & Fade-Out Timers: BL_FI

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeBlFade BacklightFadeInFadeOutTimersBLFI { get; set; }
Public Property BacklightFadeInFadeOutTimersBLFI As Adp5520TypeBlFade
    Get
    Set
public:
property Adp5520TypeBlFade BacklightFadeInFadeOutTimersBLFI {
    Adp5520TypeBlFade get ();
    void set (Adp5520TypeBlFade value);
}
member BacklightFadeInFadeOutTimersBLFI : Adp5520TypeBlFade with get, set

Property Value

Type: Adp5520TypeBlFade
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.BacklightFadeInFadeOutTimersBLFO Property

IRD

Adp5520BacklightFadeInFadeOutTimersBLFO Property

Backlight Fade-In & Fade-Out Timers: BL_FO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeBlFade BacklightFadeInFadeOutTimersBLFO { get; set; }
Public Property BacklightFadeInFadeOutTimersBLFO As Adp5520TypeBlFade
    Get
    Set
public:
property Adp5520TypeBlFade BacklightFadeInFadeOutTimersBLFO {
    Adp5520TypeBlFade get ();
    void set (Adp5520TypeBlFade value);
}
member BacklightFadeInFadeOutTimersBLFO : Adp5520TypeBlFade with get, set

Property Value

Type: Adp5520TypeBlFade
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.BacklightOffDimTimersBLDIMT Property

IRD

Adp5520BacklightOffDimTimersBLDIMT Property

Backlight Off & Dim Timers: BL_DIMT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeBlTime BacklightOffDimTimersBLDIMT { get; set; }
Public Property BacklightOffDimTimersBLDIMT As Adp5520TypeBlTime
    Get
    Set
public:
property Adp5520TypeBlTime BacklightOffDimTimersBLDIMT {
    Adp5520TypeBlTime get ();
    void set (Adp5520TypeBlTime value);
}
member BacklightOffDimTimersBLDIMT : Adp5520TypeBlTime with get, set

Property Value

Type: Adp5520TypeBlTime
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.BacklightOffDimTimersBLOFFT Property

IRD

Adp5520BacklightOffDimTimersBLOFFT Property

Backlight Off & Dim Timers: BL_OFFT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeBlTime BacklightOffDimTimersBLOFFT { get; set; }
Public Property BacklightOffDimTimersBLOFFT As Adp5520TypeBlTime
    Get
    Set
public:
property Adp5520TypeBlTime BacklightOffDimTimersBLOFFT {
    Adp5520TypeBlTime get ();
    void set (Adp5520TypeBlTime value);
}
member BacklightOffDimTimersBLOFFT : Adp5520TypeBlTime with get, set

Property Value

Type: Adp5520TypeBlTime
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.DeviceModeStatusBLEN Property

IRD

Adp5520DeviceModeStatusBLEN Property

Device Mode & Status: BL_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeModeStatusBlEn DeviceModeStatusBLEN { get; set; }
Public Property DeviceModeStatusBLEN As Adp5520TypeModeStatusBlEn
    Get
    Set
public:
property Adp5520TypeModeStatusBlEn DeviceModeStatusBLEN {
    Adp5520TypeModeStatusBlEn get ();
    void set (Adp5520TypeModeStatusBlEn value);
}
member DeviceModeStatusBLEN : Adp5520TypeModeStatusBlEn with get, set

Property Value

Type: Adp5520TypeModeStatusBlEn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.DeviceModeStatusCMPRINT Property

IRD

Adp5520DeviceModeStatusCMPRINT Property

Device Mode & Status: CMPR_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeModeStatusCmprInt DeviceModeStatusCMPRINT { get; set; }
Public Property DeviceModeStatusCMPRINT As Adp5520TypeModeStatusCmprInt
    Get
    Set
public:
property Adp5520TypeModeStatusCmprInt DeviceModeStatusCMPRINT {
    Adp5520TypeModeStatusCmprInt get ();
    void set (Adp5520TypeModeStatusCmprInt value);
}
member DeviceModeStatusCMPRINT : Adp5520TypeModeStatusCmprInt with get, set

Property Value

Type: Adp5520TypeModeStatusCmprInt
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.DeviceModeStatusDIMEN Property

IRD

Adp5520DeviceModeStatusDIMEN Property

Device Mode & Status: DIM_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeModeStatusDimEn DeviceModeStatusDIMEN { get; set; }
Public Property DeviceModeStatusDIMEN As Adp5520TypeModeStatusDimEn
    Get
    Set
public:
property Adp5520TypeModeStatusDimEn DeviceModeStatusDIMEN {
    Adp5520TypeModeStatusDimEn get ();
    void set (Adp5520TypeModeStatusDimEn value);
}
member DeviceModeStatusDIMEN : Adp5520TypeModeStatusDimEn with get, set

Property Value

Type: Adp5520TypeModeStatusDimEn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.DeviceModeStatusGPIINT Property

IRD

Adp5520DeviceModeStatusGPIINT Property

Device Mode & Status: GPI_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeModeStatusGpiInt DeviceModeStatusGPIINT { get; set; }
Public Property DeviceModeStatusGPIINT As Adp5520TypeModeStatusGpiInt
    Get
    Set
public:
property Adp5520TypeModeStatusGpiInt DeviceModeStatusGPIINT {
    Adp5520TypeModeStatusGpiInt get ();
    void set (Adp5520TypeModeStatusGpiInt value);
}
member DeviceModeStatusGPIINT : Adp5520TypeModeStatusGpiInt with get, set

Property Value

Type: Adp5520TypeModeStatusGpiInt
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.DeviceModeStatusKPINT Property

IRD

Adp5520DeviceModeStatusKPINT Property

Device Mode & Status: KP_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeModeStatusKpInt DeviceModeStatusKPINT { get; set; }
Public Property DeviceModeStatusKPINT As Adp5520TypeModeStatusKpInt
    Get
    Set
public:
property Adp5520TypeModeStatusKpInt DeviceModeStatusKPINT {
    Adp5520TypeModeStatusKpInt get ();
    void set (Adp5520TypeModeStatusKpInt value);
}
member DeviceModeStatusKPINT : Adp5520TypeModeStatusKpInt with get, set

Property Value

Type: Adp5520TypeModeStatusKpInt
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.DeviceModeStatusKRINT Property

IRD

Adp5520DeviceModeStatusKRINT Property

Device Mode & Status: KR_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeModeStatusKrInt DeviceModeStatusKRINT { get; set; }
Public Property DeviceModeStatusKRINT As Adp5520TypeModeStatusKrInt
    Get
    Set
public:
property Adp5520TypeModeStatusKrInt DeviceModeStatusKRINT {
    Adp5520TypeModeStatusKrInt get ();
    void set (Adp5520TypeModeStatusKrInt value);
}
member DeviceModeStatusKRINT : Adp5520TypeModeStatusKrInt with get, set

Property Value

Type: Adp5520TypeModeStatusKrInt
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.DeviceModeStatusNSTNBY Property

IRD

Adp5520DeviceModeStatusNSTNBY Property

Device Mode & Status: nSTNBY

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeModeStatusNstnby DeviceModeStatusNSTNBY { get; set; }
Public Property DeviceModeStatusNSTNBY As Adp5520TypeModeStatusNstnby
    Get
    Set
public:
property Adp5520TypeModeStatusNstnby DeviceModeStatusNSTNBY {
    Adp5520TypeModeStatusNstnby get ();
    void set (Adp5520TypeModeStatusNstnby value);
}
member DeviceModeStatusNSTNBY : Adp5520TypeModeStatusNstnby with get, set

Property Value

Type: Adp5520TypeModeStatusNstnby
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.DeviceModeStatusOVPINT Property

IRD

Adp5520DeviceModeStatusOVPINT Property

Device Mode & Status: OVP_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeModeStatusOvpInt DeviceModeStatusOVPINT { get; set; }
Public Property DeviceModeStatusOVPINT As Adp5520TypeModeStatusOvpInt
    Get
    Set
public:
property Adp5520TypeModeStatusOvpInt DeviceModeStatusOVPINT {
    Adp5520TypeModeStatusOvpInt get ();
    void set (Adp5520TypeModeStatusOvpInt value);
}
member DeviceModeStatusOVPINT : Adp5520TypeModeStatusOvpInt with get, set

Property Value

Type: Adp5520TypeModeStatusOvpInt
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOConfiguration1C0CONFIG Property

IRD

Adp5520GPIOConfiguration1C0CONFIG Property

GPIO Configuration 1: C0_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioCfg1C0Config GPIOConfiguration1C0CONFIG { get; set; }
Public Property GPIOConfiguration1C0CONFIG As Adp5520TypeGpioCfg1C0Config
    Get
    Set
public:
property Adp5520TypeGpioCfg1C0Config GPIOConfiguration1C0CONFIG {
    Adp5520TypeGpioCfg1C0Config get ();
    void set (Adp5520TypeGpioCfg1C0Config value);
}
member GPIOConfiguration1C0CONFIG : Adp5520TypeGpioCfg1C0Config with get, set

Property Value

Type: Adp5520TypeGpioCfg1C0Config
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOConfiguration1C1CONFIG Property

IRD

Adp5520GPIOConfiguration1C1CONFIG Property

GPIO Configuration 1: C1_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioCfg1C1Config GPIOConfiguration1C1CONFIG { get; set; }
Public Property GPIOConfiguration1C1CONFIG As Adp5520TypeGpioCfg1C1Config
    Get
    Set
public:
property Adp5520TypeGpioCfg1C1Config GPIOConfiguration1C1CONFIG {
    Adp5520TypeGpioCfg1C1Config get ();
    void set (Adp5520TypeGpioCfg1C1Config value);
}
member GPIOConfiguration1C1CONFIG : Adp5520TypeGpioCfg1C1Config with get, set

Property Value

Type: Adp5520TypeGpioCfg1C1Config
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOConfiguration1C2CONFIG Property

IRD

Adp5520GPIOConfiguration1C2CONFIG Property

GPIO Configuration 1: C2_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioCfg1C2Config GPIOConfiguration1C2CONFIG { get; set; }
Public Property GPIOConfiguration1C2CONFIG As Adp5520TypeGpioCfg1C2Config
    Get
    Set
public:
property Adp5520TypeGpioCfg1C2Config GPIOConfiguration1C2CONFIG {
    Adp5520TypeGpioCfg1C2Config get ();
    void set (Adp5520TypeGpioCfg1C2Config value);
}
member GPIOConfiguration1C2CONFIG : Adp5520TypeGpioCfg1C2Config with get, set

Property Value

Type: Adp5520TypeGpioCfg1C2Config
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOConfiguration1C3CONFIG Property

IRD

Adp5520GPIOConfiguration1C3CONFIG Property

GPIO Configuration 1: C3_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioCfg1C3Config GPIOConfiguration1C3CONFIG { get; set; }
Public Property GPIOConfiguration1C3CONFIG As Adp5520TypeGpioCfg1C3Config
    Get
    Set
public:
property Adp5520TypeGpioCfg1C3Config GPIOConfiguration1C3CONFIG {
    Adp5520TypeGpioCfg1C3Config get ();
    void set (Adp5520TypeGpioCfg1C3Config value);
}
member GPIOConfiguration1C3CONFIG : Adp5520TypeGpioCfg1C3Config with get, set

Property Value

Type: Adp5520TypeGpioCfg1C3Config
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOConfiguration1R0CONFIG Property

IRD

Adp5520GPIOConfiguration1R0CONFIG Property

GPIO Configuration 1: R0_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioCfg1R0Config GPIOConfiguration1R0CONFIG { get; set; }
Public Property GPIOConfiguration1R0CONFIG As Adp5520TypeGpioCfg1R0Config
    Get
    Set
public:
property Adp5520TypeGpioCfg1R0Config GPIOConfiguration1R0CONFIG {
    Adp5520TypeGpioCfg1R0Config get ();
    void set (Adp5520TypeGpioCfg1R0Config value);
}
member GPIOConfiguration1R0CONFIG : Adp5520TypeGpioCfg1R0Config with get, set

Property Value

Type: Adp5520TypeGpioCfg1R0Config
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOConfiguration1R1CONFIG Property

IRD

Adp5520GPIOConfiguration1R1CONFIG Property

GPIO Configuration 1: R1_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioCfg1R1Config GPIOConfiguration1R1CONFIG { get; set; }
Public Property GPIOConfiguration1R1CONFIG As Adp5520TypeGpioCfg1R1Config
    Get
    Set
public:
property Adp5520TypeGpioCfg1R1Config GPIOConfiguration1R1CONFIG {
    Adp5520TypeGpioCfg1R1Config get ();
    void set (Adp5520TypeGpioCfg1R1Config value);
}
member GPIOConfiguration1R1CONFIG : Adp5520TypeGpioCfg1R1Config with get, set

Property Value

Type: Adp5520TypeGpioCfg1R1Config
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOConfiguration1R2CONFIG Property

IRD

Adp5520GPIOConfiguration1R2CONFIG Property

GPIO Configuration 1: R2_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioCfg1R2Config GPIOConfiguration1R2CONFIG { get; set; }
Public Property GPIOConfiguration1R2CONFIG As Adp5520TypeGpioCfg1R2Config
    Get
    Set
public:
property Adp5520TypeGpioCfg1R2Config GPIOConfiguration1R2CONFIG {
    Adp5520TypeGpioCfg1R2Config get ();
    void set (Adp5520TypeGpioCfg1R2Config value);
}
member GPIOConfiguration1R2CONFIG : Adp5520TypeGpioCfg1R2Config with get, set

Property Value

Type: Adp5520TypeGpioCfg1R2Config
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOConfiguration1R3CONFIG Property

IRD

Adp5520GPIOConfiguration1R3CONFIG Property

GPIO Configuration 1: R3_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioCfg1R3Config GPIOConfiguration1R3CONFIG { get; set; }
Public Property GPIOConfiguration1R3CONFIG As Adp5520TypeGpioCfg1R3Config
    Get
    Set
public:
property Adp5520TypeGpioCfg1R3Config GPIOConfiguration1R3CONFIG {
    Adp5520TypeGpioCfg1R3Config get ();
    void set (Adp5520TypeGpioCfg1R3Config value);
}
member GPIOConfiguration1R3CONFIG : Adp5520TypeGpioCfg1R3Config with get, set

Property Value

Type: Adp5520TypeGpioCfg1R3Config
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOConfiguration2D0DIR Property

IRD

Adp5520GPIOConfiguration2D0DIR Property

GPIO Configuration 2: D0_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioCfg2Dir GPIOConfiguration2D0DIR { get; set; }
Public Property GPIOConfiguration2D0DIR As Adp5520TypeGpioCfg2Dir
    Get
    Set
public:
property Adp5520TypeGpioCfg2Dir GPIOConfiguration2D0DIR {
    Adp5520TypeGpioCfg2Dir get ();
    void set (Adp5520TypeGpioCfg2Dir value);
}
member GPIOConfiguration2D0DIR : Adp5520TypeGpioCfg2Dir with get, set

Property Value

Type: Adp5520TypeGpioCfg2Dir
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOConfiguration2D1DIR Property

IRD

Adp5520GPIOConfiguration2D1DIR Property

GPIO Configuration 2: D1_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioCfg2Dir GPIOConfiguration2D1DIR { get; set; }
Public Property GPIOConfiguration2D1DIR As Adp5520TypeGpioCfg2Dir
    Get
    Set
public:
property Adp5520TypeGpioCfg2Dir GPIOConfiguration2D1DIR {
    Adp5520TypeGpioCfg2Dir get ();
    void set (Adp5520TypeGpioCfg2Dir value);
}
member GPIOConfiguration2D1DIR : Adp5520TypeGpioCfg2Dir with get, set

Property Value

Type: Adp5520TypeGpioCfg2Dir
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOConfiguration2D2DIR Property

IRD

Adp5520GPIOConfiguration2D2DIR Property

GPIO Configuration 2: D2_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioCfg2Dir GPIOConfiguration2D2DIR { get; set; }
Public Property GPIOConfiguration2D2DIR As Adp5520TypeGpioCfg2Dir
    Get
    Set
public:
property Adp5520TypeGpioCfg2Dir GPIOConfiguration2D2DIR {
    Adp5520TypeGpioCfg2Dir get ();
    void set (Adp5520TypeGpioCfg2Dir value);
}
member GPIOConfiguration2D2DIR : Adp5520TypeGpioCfg2Dir with get, set

Property Value

Type: Adp5520TypeGpioCfg2Dir
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOConfiguration2D3DIR Property

IRD

Adp5520GPIOConfiguration2D3DIR Property

GPIO Configuration 2: D3_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioCfg2Dir GPIOConfiguration2D3DIR { get; set; }
Public Property GPIOConfiguration2D3DIR As Adp5520TypeGpioCfg2Dir
    Get
    Set
public:
property Adp5520TypeGpioCfg2Dir GPIOConfiguration2D3DIR {
    Adp5520TypeGpioCfg2Dir get ();
    void set (Adp5520TypeGpioCfg2Dir value);
}
member GPIOConfiguration2D3DIR : Adp5520TypeGpioCfg2Dir with get, set

Property Value

Type: Adp5520TypeGpioCfg2Dir
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOConfiguration2D4DIR Property

IRD

Adp5520GPIOConfiguration2D4DIR Property

GPIO Configuration 2: D4_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioCfg2Dir GPIOConfiguration2D4DIR { get; set; }
Public Property GPIOConfiguration2D4DIR As Adp5520TypeGpioCfg2Dir
    Get
    Set
public:
property Adp5520TypeGpioCfg2Dir GPIOConfiguration2D4DIR {
    Adp5520TypeGpioCfg2Dir get ();
    void set (Adp5520TypeGpioCfg2Dir value);
}
member GPIOConfiguration2D4DIR : Adp5520TypeGpioCfg2Dir with get, set

Property Value

Type: Adp5520TypeGpioCfg2Dir
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOConfiguration2D5DIR Property

IRD

Adp5520GPIOConfiguration2D5DIR Property

GPIO Configuration 2: D5_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioCfg2Dir GPIOConfiguration2D5DIR { get; set; }
Public Property GPIOConfiguration2D5DIR As Adp5520TypeGpioCfg2Dir
    Get
    Set
public:
property Adp5520TypeGpioCfg2Dir GPIOConfiguration2D5DIR {
    Adp5520TypeGpioCfg2Dir get ();
    void set (Adp5520TypeGpioCfg2Dir value);
}
member GPIOConfiguration2D5DIR : Adp5520TypeGpioCfg2Dir with get, set

Property Value

Type: Adp5520TypeGpioCfg2Dir
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOConfiguration2D6DIR Property

IRD

Adp5520GPIOConfiguration2D6DIR Property

GPIO Configuration 2: D6_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioCfg2Dir GPIOConfiguration2D6DIR { get; set; }
Public Property GPIOConfiguration2D6DIR As Adp5520TypeGpioCfg2Dir
    Get
    Set
public:
property Adp5520TypeGpioCfg2Dir GPIOConfiguration2D6DIR {
    Adp5520TypeGpioCfg2Dir get ();
    void set (Adp5520TypeGpioCfg2Dir value);
}
member GPIOConfiguration2D6DIR : Adp5520TypeGpioCfg2Dir with get, set

Property Value

Type: Adp5520TypeGpioCfg2Dir
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOConfiguration2D7DIR Property

IRD

Adp5520GPIOConfiguration2D7DIR Property

GPIO Configuration 2: D7_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioCfg2Dir GPIOConfiguration2D7DIR { get; set; }
Public Property GPIOConfiguration2D7DIR As Adp5520TypeGpioCfg2Dir
    Get
    Set
public:
property Adp5520TypeGpioCfg2Dir GPIOConfiguration2D7DIR {
    Adp5520TypeGpioCfg2Dir get ();
    void set (Adp5520TypeGpioCfg2Dir value);
}
member GPIOConfiguration2D7DIR : Adp5520TypeGpioCfg2Dir with get, set

Property Value

Type: Adp5520TypeGpioCfg2Dir
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInputDebounceEnableDisableD0INDBNC Property

IRD

Adp5520GPIOInputDebounceEnableDisableD0INDBNC Property

GPIO Input Debounce Enable/Disable: D0_IN_DBNC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioDebounce GPIOInputDebounceEnableDisableD0INDBNC { get; set; }
Public Property GPIOInputDebounceEnableDisableD0INDBNC As Adp5520TypeGpioDebounce
    Get
    Set
public:
property Adp5520TypeGpioDebounce GPIOInputDebounceEnableDisableD0INDBNC {
    Adp5520TypeGpioDebounce get ();
    void set (Adp5520TypeGpioDebounce value);
}
member GPIOInputDebounceEnableDisableD0INDBNC : Adp5520TypeGpioDebounce with get, set

Property Value

Type: Adp5520TypeGpioDebounce
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInputDebounceEnableDisableD1INDBNC Property

IRD

Adp5520GPIOInputDebounceEnableDisableD1INDBNC Property

GPIO Input Debounce Enable/Disable: D1_IN_DBNC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioDebounce GPIOInputDebounceEnableDisableD1INDBNC { get; set; }
Public Property GPIOInputDebounceEnableDisableD1INDBNC As Adp5520TypeGpioDebounce
    Get
    Set
public:
property Adp5520TypeGpioDebounce GPIOInputDebounceEnableDisableD1INDBNC {
    Adp5520TypeGpioDebounce get ();
    void set (Adp5520TypeGpioDebounce value);
}
member GPIOInputDebounceEnableDisableD1INDBNC : Adp5520TypeGpioDebounce with get, set

Property Value

Type: Adp5520TypeGpioDebounce
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInputDebounceEnableDisableD2INDBNC Property

IRD

Adp5520GPIOInputDebounceEnableDisableD2INDBNC Property

GPIO Input Debounce Enable/Disable: D2_IN_DBNC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioDebounce GPIOInputDebounceEnableDisableD2INDBNC { get; set; }
Public Property GPIOInputDebounceEnableDisableD2INDBNC As Adp5520TypeGpioDebounce
    Get
    Set
public:
property Adp5520TypeGpioDebounce GPIOInputDebounceEnableDisableD2INDBNC {
    Adp5520TypeGpioDebounce get ();
    void set (Adp5520TypeGpioDebounce value);
}
member GPIOInputDebounceEnableDisableD2INDBNC : Adp5520TypeGpioDebounce with get, set

Property Value

Type: Adp5520TypeGpioDebounce
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInputDebounceEnableDisableD3INDBNC Property

IRD

Adp5520GPIOInputDebounceEnableDisableD3INDBNC Property

GPIO Input Debounce Enable/Disable: D3_IN_DBNC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioDebounce GPIOInputDebounceEnableDisableD3INDBNC { get; set; }
Public Property GPIOInputDebounceEnableDisableD3INDBNC As Adp5520TypeGpioDebounce
    Get
    Set
public:
property Adp5520TypeGpioDebounce GPIOInputDebounceEnableDisableD3INDBNC {
    Adp5520TypeGpioDebounce get ();
    void set (Adp5520TypeGpioDebounce value);
}
member GPIOInputDebounceEnableDisableD3INDBNC : Adp5520TypeGpioDebounce with get, set

Property Value

Type: Adp5520TypeGpioDebounce
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInputDebounceEnableDisableD4INDBNC Property

IRD

Adp5520GPIOInputDebounceEnableDisableD4INDBNC Property

GPIO Input Debounce Enable/Disable: D4_IN_DBNC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioDebounce GPIOInputDebounceEnableDisableD4INDBNC { get; set; }
Public Property GPIOInputDebounceEnableDisableD4INDBNC As Adp5520TypeGpioDebounce
    Get
    Set
public:
property Adp5520TypeGpioDebounce GPIOInputDebounceEnableDisableD4INDBNC {
    Adp5520TypeGpioDebounce get ();
    void set (Adp5520TypeGpioDebounce value);
}
member GPIOInputDebounceEnableDisableD4INDBNC : Adp5520TypeGpioDebounce with get, set

Property Value

Type: Adp5520TypeGpioDebounce
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInputDebounceEnableDisableD5INDBNC Property

IRD

Adp5520GPIOInputDebounceEnableDisableD5INDBNC Property

GPIO Input Debounce Enable/Disable: D5_IN_DBNC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioDebounce GPIOInputDebounceEnableDisableD5INDBNC { get; set; }
Public Property GPIOInputDebounceEnableDisableD5INDBNC As Adp5520TypeGpioDebounce
    Get
    Set
public:
property Adp5520TypeGpioDebounce GPIOInputDebounceEnableDisableD5INDBNC {
    Adp5520TypeGpioDebounce get ();
    void set (Adp5520TypeGpioDebounce value);
}
member GPIOInputDebounceEnableDisableD5INDBNC : Adp5520TypeGpioDebounce with get, set

Property Value

Type: Adp5520TypeGpioDebounce
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInputDebounceEnableDisableD6INDBNC Property

IRD

Adp5520GPIOInputDebounceEnableDisableD6INDBNC Property

GPIO Input Debounce Enable/Disable: D6_IN_DBNC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioDebounce GPIOInputDebounceEnableDisableD6INDBNC { get; set; }
Public Property GPIOInputDebounceEnableDisableD6INDBNC As Adp5520TypeGpioDebounce
    Get
    Set
public:
property Adp5520TypeGpioDebounce GPIOInputDebounceEnableDisableD6INDBNC {
    Adp5520TypeGpioDebounce get ();
    void set (Adp5520TypeGpioDebounce value);
}
member GPIOInputDebounceEnableDisableD6INDBNC : Adp5520TypeGpioDebounce with get, set

Property Value

Type: Adp5520TypeGpioDebounce
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInputDebounceEnableDisableD7INDBNC Property

IRD

Adp5520GPIOInputDebounceEnableDisableD7INDBNC Property

GPIO Input Debounce Enable/Disable: D7_IN_DBNC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioDebounce GPIOInputDebounceEnableDisableD7INDBNC { get; set; }
Public Property GPIOInputDebounceEnableDisableD7INDBNC As Adp5520TypeGpioDebounce
    Get
    Set
public:
property Adp5520TypeGpioDebounce GPIOInputDebounceEnableDisableD7INDBNC {
    Adp5520TypeGpioDebounce get ();
    void set (Adp5520TypeGpioDebounce value);
}
member GPIOInputDebounceEnableDisableD7INDBNC : Adp5520TypeGpioDebounce with get, set

Property Value

Type: Adp5520TypeGpioDebounce
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInputStatusD0IN Property

IRD

Adp5520GPIOInputStatusD0IN Property

GPIO Input Status: D0_IN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIn GPIOInputStatusD0IN { get; }
Public ReadOnly Property GPIOInputStatusD0IN As Adp5520TypeGpioIn
    Get
public:
property Adp5520TypeGpioIn GPIOInputStatusD0IN {
    Adp5520TypeGpioIn get ();
}
member GPIOInputStatusD0IN : Adp5520TypeGpioIn with get

Property Value

Type: Adp5520TypeGpioIn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInputStatusD1IN Property

IRD

Adp5520GPIOInputStatusD1IN Property

GPIO Input Status: D1_IN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIn GPIOInputStatusD1IN { get; }
Public ReadOnly Property GPIOInputStatusD1IN As Adp5520TypeGpioIn
    Get
public:
property Adp5520TypeGpioIn GPIOInputStatusD1IN {
    Adp5520TypeGpioIn get ();
}
member GPIOInputStatusD1IN : Adp5520TypeGpioIn with get

Property Value

Type: Adp5520TypeGpioIn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInputStatusD2IN Property

IRD

Adp5520GPIOInputStatusD2IN Property

GPIO Input Status: D2_IN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIn GPIOInputStatusD2IN { get; }
Public ReadOnly Property GPIOInputStatusD2IN As Adp5520TypeGpioIn
    Get
public:
property Adp5520TypeGpioIn GPIOInputStatusD2IN {
    Adp5520TypeGpioIn get ();
}
member GPIOInputStatusD2IN : Adp5520TypeGpioIn with get

Property Value

Type: Adp5520TypeGpioIn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInputStatusD3IN Property

IRD

Adp5520GPIOInputStatusD3IN Property

GPIO Input Status: D3_IN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIn GPIOInputStatusD3IN { get; }
Public ReadOnly Property GPIOInputStatusD3IN As Adp5520TypeGpioIn
    Get
public:
property Adp5520TypeGpioIn GPIOInputStatusD3IN {
    Adp5520TypeGpioIn get ();
}
member GPIOInputStatusD3IN : Adp5520TypeGpioIn with get

Property Value

Type: Adp5520TypeGpioIn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInputStatusD4IN Property

IRD

Adp5520GPIOInputStatusD4IN Property

GPIO Input Status: D4_IN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIn GPIOInputStatusD4IN { get; }
Public ReadOnly Property GPIOInputStatusD4IN As Adp5520TypeGpioIn
    Get
public:
property Adp5520TypeGpioIn GPIOInputStatusD4IN {
    Adp5520TypeGpioIn get ();
}
member GPIOInputStatusD4IN : Adp5520TypeGpioIn with get

Property Value

Type: Adp5520TypeGpioIn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInputStatusD5IN Property

IRD

Adp5520GPIOInputStatusD5IN Property

GPIO Input Status: D5_IN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIn GPIOInputStatusD5IN { get; }
Public ReadOnly Property GPIOInputStatusD5IN As Adp5520TypeGpioIn
    Get
public:
property Adp5520TypeGpioIn GPIOInputStatusD5IN {
    Adp5520TypeGpioIn get ();
}
member GPIOInputStatusD5IN : Adp5520TypeGpioIn with get

Property Value

Type: Adp5520TypeGpioIn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInputStatusD6IN Property

IRD

Adp5520GPIOInputStatusD6IN Property

GPIO Input Status: D6_IN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIn GPIOInputStatusD6IN { get; }
Public ReadOnly Property GPIOInputStatusD6IN As Adp5520TypeGpioIn
    Get
public:
property Adp5520TypeGpioIn GPIOInputStatusD6IN {
    Adp5520TypeGpioIn get ();
}
member GPIOInputStatusD6IN : Adp5520TypeGpioIn with get

Property Value

Type: Adp5520TypeGpioIn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInputStatusD7IN Property

IRD

Adp5520GPIOInputStatusD7IN Property

GPIO Input Status: D7_IN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIn GPIOInputStatusD7IN { get; }
Public ReadOnly Property GPIOInputStatusD7IN As Adp5520TypeGpioIn
    Get
public:
property Adp5520TypeGpioIn GPIOInputStatusD7IN {
    Adp5520TypeGpioIn get ();
}
member GPIOInputStatusD7IN : Adp5520TypeGpioIn with get

Property Value

Type: Adp5520TypeGpioIn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptEnableD0INIEN Property

IRD

Adp5520GPIOInterruptEnableD0INIEN Property

GPIO Interrupt Enable: D0_IN_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntEn GPIOInterruptEnableD0INIEN { get; set; }
Public Property GPIOInterruptEnableD0INIEN As Adp5520TypeGpioIntEn
    Get
    Set
public:
property Adp5520TypeGpioIntEn GPIOInterruptEnableD0INIEN {
    Adp5520TypeGpioIntEn get ();
    void set (Adp5520TypeGpioIntEn value);
}
member GPIOInterruptEnableD0INIEN : Adp5520TypeGpioIntEn with get, set

Property Value

Type: Adp5520TypeGpioIntEn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptEnableD1INIEN Property

IRD

Adp5520GPIOInterruptEnableD1INIEN Property

GPIO Interrupt Enable: D1_IN_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntEn GPIOInterruptEnableD1INIEN { get; set; }
Public Property GPIOInterruptEnableD1INIEN As Adp5520TypeGpioIntEn
    Get
    Set
public:
property Adp5520TypeGpioIntEn GPIOInterruptEnableD1INIEN {
    Adp5520TypeGpioIntEn get ();
    void set (Adp5520TypeGpioIntEn value);
}
member GPIOInterruptEnableD1INIEN : Adp5520TypeGpioIntEn with get, set

Property Value

Type: Adp5520TypeGpioIntEn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptEnableD2INIEN Property

IRD

Adp5520GPIOInterruptEnableD2INIEN Property

GPIO Interrupt Enable: D2_IN_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntEn GPIOInterruptEnableD2INIEN { get; set; }
Public Property GPIOInterruptEnableD2INIEN As Adp5520TypeGpioIntEn
    Get
    Set
public:
property Adp5520TypeGpioIntEn GPIOInterruptEnableD2INIEN {
    Adp5520TypeGpioIntEn get ();
    void set (Adp5520TypeGpioIntEn value);
}
member GPIOInterruptEnableD2INIEN : Adp5520TypeGpioIntEn with get, set

Property Value

Type: Adp5520TypeGpioIntEn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptEnableD3INIEN Property

IRD

Adp5520GPIOInterruptEnableD3INIEN Property

GPIO Interrupt Enable: D3_IN_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntEn GPIOInterruptEnableD3INIEN { get; set; }
Public Property GPIOInterruptEnableD3INIEN As Adp5520TypeGpioIntEn
    Get
    Set
public:
property Adp5520TypeGpioIntEn GPIOInterruptEnableD3INIEN {
    Adp5520TypeGpioIntEn get ();
    void set (Adp5520TypeGpioIntEn value);
}
member GPIOInterruptEnableD3INIEN : Adp5520TypeGpioIntEn with get, set

Property Value

Type: Adp5520TypeGpioIntEn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptEnableD4INIEN Property

IRD

Adp5520GPIOInterruptEnableD4INIEN Property

GPIO Interrupt Enable: D4_IN_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntEn GPIOInterruptEnableD4INIEN { get; set; }
Public Property GPIOInterruptEnableD4INIEN As Adp5520TypeGpioIntEn
    Get
    Set
public:
property Adp5520TypeGpioIntEn GPIOInterruptEnableD4INIEN {
    Adp5520TypeGpioIntEn get ();
    void set (Adp5520TypeGpioIntEn value);
}
member GPIOInterruptEnableD4INIEN : Adp5520TypeGpioIntEn with get, set

Property Value

Type: Adp5520TypeGpioIntEn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptEnableD5INIEN Property

IRD

Adp5520GPIOInterruptEnableD5INIEN Property

GPIO Interrupt Enable: D5_IN_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntEn GPIOInterruptEnableD5INIEN { get; set; }
Public Property GPIOInterruptEnableD5INIEN As Adp5520TypeGpioIntEn
    Get
    Set
public:
property Adp5520TypeGpioIntEn GPIOInterruptEnableD5INIEN {
    Adp5520TypeGpioIntEn get ();
    void set (Adp5520TypeGpioIntEn value);
}
member GPIOInterruptEnableD5INIEN : Adp5520TypeGpioIntEn with get, set

Property Value

Type: Adp5520TypeGpioIntEn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptEnableD6INIEN Property

IRD

Adp5520GPIOInterruptEnableD6INIEN Property

GPIO Interrupt Enable: D6_IN_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntEn GPIOInterruptEnableD6INIEN { get; set; }
Public Property GPIOInterruptEnableD6INIEN As Adp5520TypeGpioIntEn
    Get
    Set
public:
property Adp5520TypeGpioIntEn GPIOInterruptEnableD6INIEN {
    Adp5520TypeGpioIntEn get ();
    void set (Adp5520TypeGpioIntEn value);
}
member GPIOInterruptEnableD6INIEN : Adp5520TypeGpioIntEn with get, set

Property Value

Type: Adp5520TypeGpioIntEn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptEnableD7INIEN Property

IRD

Adp5520GPIOInterruptEnableD7INIEN Property

GPIO Interrupt Enable: D7_IN_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntEn GPIOInterruptEnableD7INIEN { get; set; }
Public Property GPIOInterruptEnableD7INIEN As Adp5520TypeGpioIntEn
    Get
    Set
public:
property Adp5520TypeGpioIntEn GPIOInterruptEnableD7INIEN {
    Adp5520TypeGpioIntEn get ();
    void set (Adp5520TypeGpioIntEn value);
}
member GPIOInterruptEnableD7INIEN : Adp5520TypeGpioIntEn with get, set

Property Value

Type: Adp5520TypeGpioIntEn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptLevelConfigurationD0ILVL Property

IRD

Adp5520GPIOInterruptLevelConfigurationD0ILVL Property

GPIO Interrupt Level Configuration: D0_ILVL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntLvl GPIOInterruptLevelConfigurationD0ILVL { get; set; }
Public Property GPIOInterruptLevelConfigurationD0ILVL As Adp5520TypeGpioIntLvl
    Get
    Set
public:
property Adp5520TypeGpioIntLvl GPIOInterruptLevelConfigurationD0ILVL {
    Adp5520TypeGpioIntLvl get ();
    void set (Adp5520TypeGpioIntLvl value);
}
member GPIOInterruptLevelConfigurationD0ILVL : Adp5520TypeGpioIntLvl with get, set

Property Value

Type: Adp5520TypeGpioIntLvl
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptLevelConfigurationD1ILVL Property

IRD

Adp5520GPIOInterruptLevelConfigurationD1ILVL Property

GPIO Interrupt Level Configuration: D1_ILVL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntLvl GPIOInterruptLevelConfigurationD1ILVL { get; set; }
Public Property GPIOInterruptLevelConfigurationD1ILVL As Adp5520TypeGpioIntLvl
    Get
    Set
public:
property Adp5520TypeGpioIntLvl GPIOInterruptLevelConfigurationD1ILVL {
    Adp5520TypeGpioIntLvl get ();
    void set (Adp5520TypeGpioIntLvl value);
}
member GPIOInterruptLevelConfigurationD1ILVL : Adp5520TypeGpioIntLvl with get, set

Property Value

Type: Adp5520TypeGpioIntLvl
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptLevelConfigurationD2ILVL Property

IRD

Adp5520GPIOInterruptLevelConfigurationD2ILVL Property

GPIO Interrupt Level Configuration: D2_ILVL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntLvl GPIOInterruptLevelConfigurationD2ILVL { get; set; }
Public Property GPIOInterruptLevelConfigurationD2ILVL As Adp5520TypeGpioIntLvl
    Get
    Set
public:
property Adp5520TypeGpioIntLvl GPIOInterruptLevelConfigurationD2ILVL {
    Adp5520TypeGpioIntLvl get ();
    void set (Adp5520TypeGpioIntLvl value);
}
member GPIOInterruptLevelConfigurationD2ILVL : Adp5520TypeGpioIntLvl with get, set

Property Value

Type: Adp5520TypeGpioIntLvl
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptLevelConfigurationD3ILVL Property

IRD

Adp5520GPIOInterruptLevelConfigurationD3ILVL Property

GPIO Interrupt Level Configuration: D3_ILVL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntLvl GPIOInterruptLevelConfigurationD3ILVL { get; set; }
Public Property GPIOInterruptLevelConfigurationD3ILVL As Adp5520TypeGpioIntLvl
    Get
    Set
public:
property Adp5520TypeGpioIntLvl GPIOInterruptLevelConfigurationD3ILVL {
    Adp5520TypeGpioIntLvl get ();
    void set (Adp5520TypeGpioIntLvl value);
}
member GPIOInterruptLevelConfigurationD3ILVL : Adp5520TypeGpioIntLvl with get, set

Property Value

Type: Adp5520TypeGpioIntLvl
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptLevelConfigurationD4ILVL Property

IRD

Adp5520GPIOInterruptLevelConfigurationD4ILVL Property

GPIO Interrupt Level Configuration: D4_ILVL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntLvl GPIOInterruptLevelConfigurationD4ILVL { get; set; }
Public Property GPIOInterruptLevelConfigurationD4ILVL As Adp5520TypeGpioIntLvl
    Get
    Set
public:
property Adp5520TypeGpioIntLvl GPIOInterruptLevelConfigurationD4ILVL {
    Adp5520TypeGpioIntLvl get ();
    void set (Adp5520TypeGpioIntLvl value);
}
member GPIOInterruptLevelConfigurationD4ILVL : Adp5520TypeGpioIntLvl with get, set

Property Value

Type: Adp5520TypeGpioIntLvl
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptLevelConfigurationD5ILVL Property

IRD

Adp5520GPIOInterruptLevelConfigurationD5ILVL Property

GPIO Interrupt Level Configuration: D5_ILVL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntLvl GPIOInterruptLevelConfigurationD5ILVL { get; set; }
Public Property GPIOInterruptLevelConfigurationD5ILVL As Adp5520TypeGpioIntLvl
    Get
    Set
public:
property Adp5520TypeGpioIntLvl GPIOInterruptLevelConfigurationD5ILVL {
    Adp5520TypeGpioIntLvl get ();
    void set (Adp5520TypeGpioIntLvl value);
}
member GPIOInterruptLevelConfigurationD5ILVL : Adp5520TypeGpioIntLvl with get, set

Property Value

Type: Adp5520TypeGpioIntLvl
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptLevelConfigurationD6ILVL Property

IRD

Adp5520GPIOInterruptLevelConfigurationD6ILVL Property

GPIO Interrupt Level Configuration: D6_ILVL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntLvl GPIOInterruptLevelConfigurationD6ILVL { get; set; }
Public Property GPIOInterruptLevelConfigurationD6ILVL As Adp5520TypeGpioIntLvl
    Get
    Set
public:
property Adp5520TypeGpioIntLvl GPIOInterruptLevelConfigurationD6ILVL {
    Adp5520TypeGpioIntLvl get ();
    void set (Adp5520TypeGpioIntLvl value);
}
member GPIOInterruptLevelConfigurationD6ILVL : Adp5520TypeGpioIntLvl with get, set

Property Value

Type: Adp5520TypeGpioIntLvl
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptLevelConfigurationD7ILVL Property

IRD

Adp5520GPIOInterruptLevelConfigurationD7ILVL Property

GPIO Interrupt Level Configuration: D7_ILVL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntLvl GPIOInterruptLevelConfigurationD7ILVL { get; set; }
Public Property GPIOInterruptLevelConfigurationD7ILVL As Adp5520TypeGpioIntLvl
    Get
    Set
public:
property Adp5520TypeGpioIntLvl GPIOInterruptLevelConfigurationD7ILVL {
    Adp5520TypeGpioIntLvl get ();
    void set (Adp5520TypeGpioIntLvl value);
}
member GPIOInterruptLevelConfigurationD7ILVL : Adp5520TypeGpioIntLvl with get, set

Property Value

Type: Adp5520TypeGpioIntLvl
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptStatusD0INISTAT Property

IRD

Adp5520GPIOInterruptStatusD0INISTAT Property

GPIO Interrupt Status: D0_IN_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntStat GPIOInterruptStatusD0INISTAT { get; set; }
Public Property GPIOInterruptStatusD0INISTAT As Adp5520TypeGpioIntStat
    Get
    Set
public:
property Adp5520TypeGpioIntStat GPIOInterruptStatusD0INISTAT {
    Adp5520TypeGpioIntStat get ();
    void set (Adp5520TypeGpioIntStat value);
}
member GPIOInterruptStatusD0INISTAT : Adp5520TypeGpioIntStat with get, set

Property Value

Type: Adp5520TypeGpioIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptStatusD1INISTAT Property

IRD

Adp5520GPIOInterruptStatusD1INISTAT Property

GPIO Interrupt Status: D1_IN_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntStat GPIOInterruptStatusD1INISTAT { get; set; }
Public Property GPIOInterruptStatusD1INISTAT As Adp5520TypeGpioIntStat
    Get
    Set
public:
property Adp5520TypeGpioIntStat GPIOInterruptStatusD1INISTAT {
    Adp5520TypeGpioIntStat get ();
    void set (Adp5520TypeGpioIntStat value);
}
member GPIOInterruptStatusD1INISTAT : Adp5520TypeGpioIntStat with get, set

Property Value

Type: Adp5520TypeGpioIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptStatusD2INISTAT Property

IRD

Adp5520GPIOInterruptStatusD2INISTAT Property

GPIO Interrupt Status: D2_IN_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntStat GPIOInterruptStatusD2INISTAT { get; set; }
Public Property GPIOInterruptStatusD2INISTAT As Adp5520TypeGpioIntStat
    Get
    Set
public:
property Adp5520TypeGpioIntStat GPIOInterruptStatusD2INISTAT {
    Adp5520TypeGpioIntStat get ();
    void set (Adp5520TypeGpioIntStat value);
}
member GPIOInterruptStatusD2INISTAT : Adp5520TypeGpioIntStat with get, set

Property Value

Type: Adp5520TypeGpioIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptStatusD3INISTAT Property

IRD

Adp5520GPIOInterruptStatusD3INISTAT Property

GPIO Interrupt Status: D3_IN_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntStat GPIOInterruptStatusD3INISTAT { get; set; }
Public Property GPIOInterruptStatusD3INISTAT As Adp5520TypeGpioIntStat
    Get
    Set
public:
property Adp5520TypeGpioIntStat GPIOInterruptStatusD3INISTAT {
    Adp5520TypeGpioIntStat get ();
    void set (Adp5520TypeGpioIntStat value);
}
member GPIOInterruptStatusD3INISTAT : Adp5520TypeGpioIntStat with get, set

Property Value

Type: Adp5520TypeGpioIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptStatusD4INISTAT Property

IRD

Adp5520GPIOInterruptStatusD4INISTAT Property

GPIO Interrupt Status: D4_IN_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntStat GPIOInterruptStatusD4INISTAT { get; set; }
Public Property GPIOInterruptStatusD4INISTAT As Adp5520TypeGpioIntStat
    Get
    Set
public:
property Adp5520TypeGpioIntStat GPIOInterruptStatusD4INISTAT {
    Adp5520TypeGpioIntStat get ();
    void set (Adp5520TypeGpioIntStat value);
}
member GPIOInterruptStatusD4INISTAT : Adp5520TypeGpioIntStat with get, set

Property Value

Type: Adp5520TypeGpioIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptStatusD5INISTAT Property

IRD

Adp5520GPIOInterruptStatusD5INISTAT Property

GPIO Interrupt Status: D5_IN_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntStat GPIOInterruptStatusD5INISTAT { get; set; }
Public Property GPIOInterruptStatusD5INISTAT As Adp5520TypeGpioIntStat
    Get
    Set
public:
property Adp5520TypeGpioIntStat GPIOInterruptStatusD5INISTAT {
    Adp5520TypeGpioIntStat get ();
    void set (Adp5520TypeGpioIntStat value);
}
member GPIOInterruptStatusD5INISTAT : Adp5520TypeGpioIntStat with get, set

Property Value

Type: Adp5520TypeGpioIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptStatusD6INISTAT Property

IRD

Adp5520GPIOInterruptStatusD6INISTAT Property

GPIO Interrupt Status: D6_IN_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntStat GPIOInterruptStatusD6INISTAT { get; set; }
Public Property GPIOInterruptStatusD6INISTAT As Adp5520TypeGpioIntStat
    Get
    Set
public:
property Adp5520TypeGpioIntStat GPIOInterruptStatusD6INISTAT {
    Adp5520TypeGpioIntStat get ();
    void set (Adp5520TypeGpioIntStat value);
}
member GPIOInterruptStatusD6INISTAT : Adp5520TypeGpioIntStat with get, set

Property Value

Type: Adp5520TypeGpioIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOInterruptStatusD7INISTAT Property

IRD

Adp5520GPIOInterruptStatusD7INISTAT Property

GPIO Interrupt Status: D7_IN_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioIntStat GPIOInterruptStatusD7INISTAT { get; set; }
Public Property GPIOInterruptStatusD7INISTAT As Adp5520TypeGpioIntStat
    Get
    Set
public:
property Adp5520TypeGpioIntStat GPIOInterruptStatusD7INISTAT {
    Adp5520TypeGpioIntStat get ();
    void set (Adp5520TypeGpioIntStat value);
}
member GPIOInterruptStatusD7INISTAT : Adp5520TypeGpioIntStat with get, set

Property Value

Type: Adp5520TypeGpioIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOOutputStatusD0OUT Property

IRD

Adp5520GPIOOutputStatusD0OUT Property

GPIO Output Status: D0_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioOut GPIOOutputStatusD0OUT { get; set; }
Public Property GPIOOutputStatusD0OUT As Adp5520TypeGpioOut
    Get
    Set
public:
property Adp5520TypeGpioOut GPIOOutputStatusD0OUT {
    Adp5520TypeGpioOut get ();
    void set (Adp5520TypeGpioOut value);
}
member GPIOOutputStatusD0OUT : Adp5520TypeGpioOut with get, set

Property Value

Type: Adp5520TypeGpioOut
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOOutputStatusD1OUT Property

IRD

Adp5520GPIOOutputStatusD1OUT Property

GPIO Output Status: D1_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioOut GPIOOutputStatusD1OUT { get; set; }
Public Property GPIOOutputStatusD1OUT As Adp5520TypeGpioOut
    Get
    Set
public:
property Adp5520TypeGpioOut GPIOOutputStatusD1OUT {
    Adp5520TypeGpioOut get ();
    void set (Adp5520TypeGpioOut value);
}
member GPIOOutputStatusD1OUT : Adp5520TypeGpioOut with get, set

Property Value

Type: Adp5520TypeGpioOut
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOOutputStatusD2OUT Property

IRD

Adp5520GPIOOutputStatusD2OUT Property

GPIO Output Status: D2_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioOut GPIOOutputStatusD2OUT { get; set; }
Public Property GPIOOutputStatusD2OUT As Adp5520TypeGpioOut
    Get
    Set
public:
property Adp5520TypeGpioOut GPIOOutputStatusD2OUT {
    Adp5520TypeGpioOut get ();
    void set (Adp5520TypeGpioOut value);
}
member GPIOOutputStatusD2OUT : Adp5520TypeGpioOut with get, set

Property Value

Type: Adp5520TypeGpioOut
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOOutputStatusD3OUT Property

IRD

Adp5520GPIOOutputStatusD3OUT Property

GPIO Output Status: D3_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioOut GPIOOutputStatusD3OUT { get; set; }
Public Property GPIOOutputStatusD3OUT As Adp5520TypeGpioOut
    Get
    Set
public:
property Adp5520TypeGpioOut GPIOOutputStatusD3OUT {
    Adp5520TypeGpioOut get ();
    void set (Adp5520TypeGpioOut value);
}
member GPIOOutputStatusD3OUT : Adp5520TypeGpioOut with get, set

Property Value

Type: Adp5520TypeGpioOut
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOOutputStatusD4OUT Property

IRD

Adp5520GPIOOutputStatusD4OUT Property

GPIO Output Status: D4_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioOut GPIOOutputStatusD4OUT { get; set; }
Public Property GPIOOutputStatusD4OUT As Adp5520TypeGpioOut
    Get
    Set
public:
property Adp5520TypeGpioOut GPIOOutputStatusD4OUT {
    Adp5520TypeGpioOut get ();
    void set (Adp5520TypeGpioOut value);
}
member GPIOOutputStatusD4OUT : Adp5520TypeGpioOut with get, set

Property Value

Type: Adp5520TypeGpioOut
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOOutputStatusD5OUT Property

IRD

Adp5520GPIOOutputStatusD5OUT Property

GPIO Output Status: D5_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioOut GPIOOutputStatusD5OUT { get; set; }
Public Property GPIOOutputStatusD5OUT As Adp5520TypeGpioOut
    Get
    Set
public:
property Adp5520TypeGpioOut GPIOOutputStatusD5OUT {
    Adp5520TypeGpioOut get ();
    void set (Adp5520TypeGpioOut value);
}
member GPIOOutputStatusD5OUT : Adp5520TypeGpioOut with get, set

Property Value

Type: Adp5520TypeGpioOut
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOOutputStatusD6OUT Property

IRD

Adp5520GPIOOutputStatusD6OUT Property

GPIO Output Status: D6_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioOut GPIOOutputStatusD6OUT { get; set; }
Public Property GPIOOutputStatusD6OUT As Adp5520TypeGpioOut
    Get
    Set
public:
property Adp5520TypeGpioOut GPIOOutputStatusD6OUT {
    Adp5520TypeGpioOut get ();
    void set (Adp5520TypeGpioOut value);
}
member GPIOOutputStatusD6OUT : Adp5520TypeGpioOut with get, set

Property Value

Type: Adp5520TypeGpioOut
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOOutputStatusD7OUT Property

IRD

Adp5520GPIOOutputStatusD7OUT Property

GPIO Output Status: D7_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioOut GPIOOutputStatusD7OUT { get; set; }
Public Property GPIOOutputStatusD7OUT As Adp5520TypeGpioOut
    Get
    Set
public:
property Adp5520TypeGpioOut GPIOOutputStatusD7OUT {
    Adp5520TypeGpioOut get ();
    void set (Adp5520TypeGpioOut value);
}
member GPIOOutputStatusD7OUT : Adp5520TypeGpioOut with get, set

Property Value

Type: Adp5520TypeGpioOut
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOPullUpEnableDisableD0PULL Property

IRD

Adp5520GPIOPullUpEnableDisableD0PULL Property

GPIO Pull-Up Enable/Disable: D0_PULL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioPullup GPIOPullUpEnableDisableD0PULL { get; set; }
Public Property GPIOPullUpEnableDisableD0PULL As Adp5520TypeGpioPullup
    Get
    Set
public:
property Adp5520TypeGpioPullup GPIOPullUpEnableDisableD0PULL {
    Adp5520TypeGpioPullup get ();
    void set (Adp5520TypeGpioPullup value);
}
member GPIOPullUpEnableDisableD0PULL : Adp5520TypeGpioPullup with get, set

Property Value

Type: Adp5520TypeGpioPullup
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOPullUpEnableDisableD1PULL Property

IRD

Adp5520GPIOPullUpEnableDisableD1PULL Property

GPIO Pull-Up Enable/Disable: D1_PULL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioPullup GPIOPullUpEnableDisableD1PULL { get; set; }
Public Property GPIOPullUpEnableDisableD1PULL As Adp5520TypeGpioPullup
    Get
    Set
public:
property Adp5520TypeGpioPullup GPIOPullUpEnableDisableD1PULL {
    Adp5520TypeGpioPullup get ();
    void set (Adp5520TypeGpioPullup value);
}
member GPIOPullUpEnableDisableD1PULL : Adp5520TypeGpioPullup with get, set

Property Value

Type: Adp5520TypeGpioPullup
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOPullUpEnableDisableD2PULL Property

IRD

Adp5520GPIOPullUpEnableDisableD2PULL Property

GPIO Pull-Up Enable/Disable: D2_PULL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioPullup GPIOPullUpEnableDisableD2PULL { get; set; }
Public Property GPIOPullUpEnableDisableD2PULL As Adp5520TypeGpioPullup
    Get
    Set
public:
property Adp5520TypeGpioPullup GPIOPullUpEnableDisableD2PULL {
    Adp5520TypeGpioPullup get ();
    void set (Adp5520TypeGpioPullup value);
}
member GPIOPullUpEnableDisableD2PULL : Adp5520TypeGpioPullup with get, set

Property Value

Type: Adp5520TypeGpioPullup
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOPullUpEnableDisableD3PULL Property

IRD

Adp5520GPIOPullUpEnableDisableD3PULL Property

GPIO Pull-Up Enable/Disable: D3_PULL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioPullup GPIOPullUpEnableDisableD3PULL { get; set; }
Public Property GPIOPullUpEnableDisableD3PULL As Adp5520TypeGpioPullup
    Get
    Set
public:
property Adp5520TypeGpioPullup GPIOPullUpEnableDisableD3PULL {
    Adp5520TypeGpioPullup get ();
    void set (Adp5520TypeGpioPullup value);
}
member GPIOPullUpEnableDisableD3PULL : Adp5520TypeGpioPullup with get, set

Property Value

Type: Adp5520TypeGpioPullup
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOPullUpEnableDisableD4PULL Property

IRD

Adp5520GPIOPullUpEnableDisableD4PULL Property

GPIO Pull-Up Enable/Disable: D4_PULL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioPullup GPIOPullUpEnableDisableD4PULL { get; set; }
Public Property GPIOPullUpEnableDisableD4PULL As Adp5520TypeGpioPullup
    Get
    Set
public:
property Adp5520TypeGpioPullup GPIOPullUpEnableDisableD4PULL {
    Adp5520TypeGpioPullup get ();
    void set (Adp5520TypeGpioPullup value);
}
member GPIOPullUpEnableDisableD4PULL : Adp5520TypeGpioPullup with get, set

Property Value

Type: Adp5520TypeGpioPullup
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOPullUpEnableDisableD5PULL Property

IRD

Adp5520GPIOPullUpEnableDisableD5PULL Property

GPIO Pull-Up Enable/Disable: D5_PULL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioPullup GPIOPullUpEnableDisableD5PULL { get; set; }
Public Property GPIOPullUpEnableDisableD5PULL As Adp5520TypeGpioPullup
    Get
    Set
public:
property Adp5520TypeGpioPullup GPIOPullUpEnableDisableD5PULL {
    Adp5520TypeGpioPullup get ();
    void set (Adp5520TypeGpioPullup value);
}
member GPIOPullUpEnableDisableD5PULL : Adp5520TypeGpioPullup with get, set

Property Value

Type: Adp5520TypeGpioPullup
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOPullUpEnableDisableD6PULL Property

IRD

Adp5520GPIOPullUpEnableDisableD6PULL Property

GPIO Pull-Up Enable/Disable: D6_PULL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioPullup GPIOPullUpEnableDisableD6PULL { get; set; }
Public Property GPIOPullUpEnableDisableD6PULL As Adp5520TypeGpioPullup
    Get
    Set
public:
property Adp5520TypeGpioPullup GPIOPullUpEnableDisableD6PULL {
    Adp5520TypeGpioPullup get ();
    void set (Adp5520TypeGpioPullup value);
}
member GPIOPullUpEnableDisableD6PULL : Adp5520TypeGpioPullup with get, set

Property Value

Type: Adp5520TypeGpioPullup
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.GPIOPullUpEnableDisableD7PULL Property

IRD

Adp5520GPIOPullUpEnableDisableD7PULL Property

GPIO Pull-Up Enable/Disable: D7_PULL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeGpioPullup GPIOPullUpEnableDisableD7PULL { get; set; }
Public Property GPIOPullUpEnableDisableD7PULL As Adp5520TypeGpioPullup
    Get
    Set
public:
property Adp5520TypeGpioPullup GPIOPullUpEnableDisableD7PULL {
    Adp5520TypeGpioPullup get ();
    void set (Adp5520TypeGpioPullup value);
}
member GPIOPullUpEnableDisableD7PULL : Adp5520TypeGpioPullup with get, set

Property Value

Type: Adp5520TypeGpioPullup
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.InterruptEnableAUTOLDEN Property

IRD

Adp5520InterruptEnableAUTOLDEN Property

Interrupt Enable: AUTO_LD_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeInterruptEnableAutoLdEn InterruptEnableAUTOLDEN { get; set; }
Public Property InterruptEnableAUTOLDEN As Adp5520TypeInterruptEnableAutoLdEn
    Get
    Set
public:
property Adp5520TypeInterruptEnableAutoLdEn InterruptEnableAUTOLDEN {
    Adp5520TypeInterruptEnableAutoLdEn get ();
    void set (Adp5520TypeInterruptEnableAutoLdEn value);
}
member InterruptEnableAUTOLDEN : Adp5520TypeInterruptEnableAutoLdEn with get, set

Property Value

Type: Adp5520TypeInterruptEnableAutoLdEn
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.InterruptEnableCMPRIEN Property

IRD

Adp5520InterruptEnableCMPRIEN Property

Interrupt Enable: CMPR_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeInterruptEnableCmprIen InterruptEnableCMPRIEN { get; set; }
Public Property InterruptEnableCMPRIEN As Adp5520TypeInterruptEnableCmprIen
    Get
    Set
public:
property Adp5520TypeInterruptEnableCmprIen InterruptEnableCMPRIEN {
    Adp5520TypeInterruptEnableCmprIen get ();
    void set (Adp5520TypeInterruptEnableCmprIen value);
}
member InterruptEnableCMPRIEN : Adp5520TypeInterruptEnableCmprIen with get, set

Property Value

Type: Adp5520TypeInterruptEnableCmprIen
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.InterruptEnableKPIEN Property

IRD

Adp5520InterruptEnableKPIEN Property

Interrupt Enable: KP_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeInterruptEnableKpIen InterruptEnableKPIEN { get; set; }
Public Property InterruptEnableKPIEN As Adp5520TypeInterruptEnableKpIen
    Get
    Set
public:
property Adp5520TypeInterruptEnableKpIen InterruptEnableKPIEN {
    Adp5520TypeInterruptEnableKpIen get ();
    void set (Adp5520TypeInterruptEnableKpIen value);
}
member InterruptEnableKPIEN : Adp5520TypeInterruptEnableKpIen with get, set

Property Value

Type: Adp5520TypeInterruptEnableKpIen
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.InterruptEnableKRIEN Property

IRD

Adp5520InterruptEnableKRIEN Property

Interrupt Enable: KR_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeInterruptEnableKrIen InterruptEnableKRIEN { get; set; }
Public Property InterruptEnableKRIEN As Adp5520TypeInterruptEnableKrIen
    Get
    Set
public:
property Adp5520TypeInterruptEnableKrIen InterruptEnableKRIEN {
    Adp5520TypeInterruptEnableKrIen get ();
    void set (Adp5520TypeInterruptEnableKrIen value);
}
member InterruptEnableKRIEN : Adp5520TypeInterruptEnableKrIen with get, set

Property Value

Type: Adp5520TypeInterruptEnableKrIen
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.InterruptEnableOVPIEN Property

IRD

Adp5520InterruptEnableOVPIEN Property

Interrupt Enable: OVP_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeInterruptEnableOvpIen InterruptEnableOVPIEN { get; set; }
Public Property InterruptEnableOVPIEN As Adp5520TypeInterruptEnableOvpIen
    Get
    Set
public:
property Adp5520TypeInterruptEnableOvpIen InterruptEnableOVPIEN {
    Adp5520TypeInterruptEnableOvpIen get ();
    void set (Adp5520TypeInterruptEnableOvpIen value);
}
member InterruptEnableOVPIEN : Adp5520TypeInterruptEnableOvpIen with get, set

Property Value

Type: Adp5520TypeInterruptEnableOvpIen
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyPressInterruptStatus1KPAISTAT Property

IRD

Adp5520KeyPressInterruptStatus1KPAISTAT Property

Key Press Interrupt Status 1: KP_A_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKpIntStat KeyPressInterruptStatus1KPAISTAT { get; }
Public ReadOnly Property KeyPressInterruptStatus1KPAISTAT As Adp5520TypeKpIntStat
    Get
public:
property Adp5520TypeKpIntStat KeyPressInterruptStatus1KPAISTAT {
    Adp5520TypeKpIntStat get ();
}
member KeyPressInterruptStatus1KPAISTAT : Adp5520TypeKpIntStat with get

Property Value

Type: Adp5520TypeKpIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyPressInterruptStatus1KPBISTAT Property

IRD

Adp5520KeyPressInterruptStatus1KPBISTAT Property

Key Press Interrupt Status 1: KP_B_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKpIntStat KeyPressInterruptStatus1KPBISTAT { get; }
Public ReadOnly Property KeyPressInterruptStatus1KPBISTAT As Adp5520TypeKpIntStat
    Get
public:
property Adp5520TypeKpIntStat KeyPressInterruptStatus1KPBISTAT {
    Adp5520TypeKpIntStat get ();
}
member KeyPressInterruptStatus1KPBISTAT : Adp5520TypeKpIntStat with get

Property Value

Type: Adp5520TypeKpIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyPressInterruptStatus1KPCISTAT Property

IRD

Adp5520KeyPressInterruptStatus1KPCISTAT Property

Key Press Interrupt Status 1: KP_C_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKpIntStat KeyPressInterruptStatus1KPCISTAT { get; }
Public ReadOnly Property KeyPressInterruptStatus1KPCISTAT As Adp5520TypeKpIntStat
    Get
public:
property Adp5520TypeKpIntStat KeyPressInterruptStatus1KPCISTAT {
    Adp5520TypeKpIntStat get ();
}
member KeyPressInterruptStatus1KPCISTAT : Adp5520TypeKpIntStat with get

Property Value

Type: Adp5520TypeKpIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyPressInterruptStatus1KPDISTAT Property

IRD

Adp5520KeyPressInterruptStatus1KPDISTAT Property

Key Press Interrupt Status 1: KP_D_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKpIntStat KeyPressInterruptStatus1KPDISTAT { get; }
Public ReadOnly Property KeyPressInterruptStatus1KPDISTAT As Adp5520TypeKpIntStat
    Get
public:
property Adp5520TypeKpIntStat KeyPressInterruptStatus1KPDISTAT {
    Adp5520TypeKpIntStat get ();
}
member KeyPressInterruptStatus1KPDISTAT : Adp5520TypeKpIntStat with get

Property Value

Type: Adp5520TypeKpIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyPressInterruptStatus1KPEISTAT Property

IRD

Adp5520KeyPressInterruptStatus1KPEISTAT Property

Key Press Interrupt Status 1: KP_E_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKpIntStat KeyPressInterruptStatus1KPEISTAT { get; }
Public ReadOnly Property KeyPressInterruptStatus1KPEISTAT As Adp5520TypeKpIntStat
    Get
public:
property Adp5520TypeKpIntStat KeyPressInterruptStatus1KPEISTAT {
    Adp5520TypeKpIntStat get ();
}
member KeyPressInterruptStatus1KPEISTAT : Adp5520TypeKpIntStat with get

Property Value

Type: Adp5520TypeKpIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyPressInterruptStatus1KPFISTAT Property

IRD

Adp5520KeyPressInterruptStatus1KPFISTAT Property

Key Press Interrupt Status 1: KP_F_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKpIntStat KeyPressInterruptStatus1KPFISTAT { get; }
Public ReadOnly Property KeyPressInterruptStatus1KPFISTAT As Adp5520TypeKpIntStat
    Get
public:
property Adp5520TypeKpIntStat KeyPressInterruptStatus1KPFISTAT {
    Adp5520TypeKpIntStat get ();
}
member KeyPressInterruptStatus1KPFISTAT : Adp5520TypeKpIntStat with get

Property Value

Type: Adp5520TypeKpIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyPressInterruptStatus1KPGISTAT Property

IRD

Adp5520KeyPressInterruptStatus1KPGISTAT Property

Key Press Interrupt Status 1: KP_G_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKpIntStat KeyPressInterruptStatus1KPGISTAT { get; }
Public ReadOnly Property KeyPressInterruptStatus1KPGISTAT As Adp5520TypeKpIntStat
    Get
public:
property Adp5520TypeKpIntStat KeyPressInterruptStatus1KPGISTAT {
    Adp5520TypeKpIntStat get ();
}
member KeyPressInterruptStatus1KPGISTAT : Adp5520TypeKpIntStat with get

Property Value

Type: Adp5520TypeKpIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyPressInterruptStatus1KPHISTAT Property

IRD

Adp5520KeyPressInterruptStatus1KPHISTAT Property

Key Press Interrupt Status 1: KP_H_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKpIntStat KeyPressInterruptStatus1KPHISTAT { get; }
Public ReadOnly Property KeyPressInterruptStatus1KPHISTAT As Adp5520TypeKpIntStat
    Get
public:
property Adp5520TypeKpIntStat KeyPressInterruptStatus1KPHISTAT {
    Adp5520TypeKpIntStat get ();
}
member KeyPressInterruptStatus1KPHISTAT : Adp5520TypeKpIntStat with get

Property Value

Type: Adp5520TypeKpIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyPressInterruptStatus2KPIISTAT Property

IRD

Adp5520KeyPressInterruptStatus2KPIISTAT Property

Key Press Interrupt Status 2: KP_I_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKpIntStat KeyPressInterruptStatus2KPIISTAT { get; }
Public ReadOnly Property KeyPressInterruptStatus2KPIISTAT As Adp5520TypeKpIntStat
    Get
public:
property Adp5520TypeKpIntStat KeyPressInterruptStatus2KPIISTAT {
    Adp5520TypeKpIntStat get ();
}
member KeyPressInterruptStatus2KPIISTAT : Adp5520TypeKpIntStat with get

Property Value

Type: Adp5520TypeKpIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyPressInterruptStatus2KPJISTAT Property

IRD

Adp5520KeyPressInterruptStatus2KPJISTAT Property

Key Press Interrupt Status 2: KP_J_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKpIntStat KeyPressInterruptStatus2KPJISTAT { get; }
Public ReadOnly Property KeyPressInterruptStatus2KPJISTAT As Adp5520TypeKpIntStat
    Get
public:
property Adp5520TypeKpIntStat KeyPressInterruptStatus2KPJISTAT {
    Adp5520TypeKpIntStat get ();
}
member KeyPressInterruptStatus2KPJISTAT : Adp5520TypeKpIntStat with get

Property Value

Type: Adp5520TypeKpIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyPressInterruptStatus2KPKISTAT Property

IRD

Adp5520KeyPressInterruptStatus2KPKISTAT Property

Key Press Interrupt Status 2: KP_K_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKpIntStat KeyPressInterruptStatus2KPKISTAT { get; }
Public ReadOnly Property KeyPressInterruptStatus2KPKISTAT As Adp5520TypeKpIntStat
    Get
public:
property Adp5520TypeKpIntStat KeyPressInterruptStatus2KPKISTAT {
    Adp5520TypeKpIntStat get ();
}
member KeyPressInterruptStatus2KPKISTAT : Adp5520TypeKpIntStat with get

Property Value

Type: Adp5520TypeKpIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyPressInterruptStatus2KPLISTAT Property

IRD

Adp5520KeyPressInterruptStatus2KPLISTAT Property

Key Press Interrupt Status 2: KP_L_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKpIntStat KeyPressInterruptStatus2KPLISTAT { get; }
Public ReadOnly Property KeyPressInterruptStatus2KPLISTAT As Adp5520TypeKpIntStat
    Get
public:
property Adp5520TypeKpIntStat KeyPressInterruptStatus2KPLISTAT {
    Adp5520TypeKpIntStat get ();
}
member KeyPressInterruptStatus2KPLISTAT : Adp5520TypeKpIntStat with get

Property Value

Type: Adp5520TypeKpIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyPressInterruptStatus2KPMISTAT Property

IRD

Adp5520KeyPressInterruptStatus2KPMISTAT Property

Key Press Interrupt Status 2: KP_M_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKpIntStat KeyPressInterruptStatus2KPMISTAT { get; }
Public ReadOnly Property KeyPressInterruptStatus2KPMISTAT As Adp5520TypeKpIntStat
    Get
public:
property Adp5520TypeKpIntStat KeyPressInterruptStatus2KPMISTAT {
    Adp5520TypeKpIntStat get ();
}
member KeyPressInterruptStatus2KPMISTAT : Adp5520TypeKpIntStat with get

Property Value

Type: Adp5520TypeKpIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyPressInterruptStatus2KPNISTAT Property

IRD

Adp5520KeyPressInterruptStatus2KPNISTAT Property

Key Press Interrupt Status 2: KP_N_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKpIntStat KeyPressInterruptStatus2KPNISTAT { get; }
Public ReadOnly Property KeyPressInterruptStatus2KPNISTAT As Adp5520TypeKpIntStat
    Get
public:
property Adp5520TypeKpIntStat KeyPressInterruptStatus2KPNISTAT {
    Adp5520TypeKpIntStat get ();
}
member KeyPressInterruptStatus2KPNISTAT : Adp5520TypeKpIntStat with get

Property Value

Type: Adp5520TypeKpIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyPressInterruptStatus2KPOISTAT Property

IRD

Adp5520KeyPressInterruptStatus2KPOISTAT Property

Key Press Interrupt Status 2: KP_O_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKpIntStat KeyPressInterruptStatus2KPOISTAT { get; }
Public ReadOnly Property KeyPressInterruptStatus2KPOISTAT As Adp5520TypeKpIntStat
    Get
public:
property Adp5520TypeKpIntStat KeyPressInterruptStatus2KPOISTAT {
    Adp5520TypeKpIntStat get ();
}
member KeyPressInterruptStatus2KPOISTAT : Adp5520TypeKpIntStat with get

Property Value

Type: Adp5520TypeKpIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyPressInterruptStatus2KPPISTAT Property

IRD

Adp5520KeyPressInterruptStatus2KPPISTAT Property

Key Press Interrupt Status 2: KP_P_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKpIntStat KeyPressInterruptStatus2KPPISTAT { get; }
Public ReadOnly Property KeyPressInterruptStatus2KPPISTAT As Adp5520TypeKpIntStat
    Get
public:
property Adp5520TypeKpIntStat KeyPressInterruptStatus2KPPISTAT {
    Adp5520TypeKpIntStat get ();
}
member KeyPressInterruptStatus2KPPISTAT : Adp5520TypeKpIntStat with get

Property Value

Type: Adp5520TypeKpIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyReleaseInterruptStatus1KRAISTAT Property

IRD

Adp5520KeyReleaseInterruptStatus1KRAISTAT Property

Key Release Interrupt Status 1: KR_A_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKrIntStat KeyReleaseInterruptStatus1KRAISTAT { get; }
Public ReadOnly Property KeyReleaseInterruptStatus1KRAISTAT As Adp5520TypeKrIntStat
    Get
public:
property Adp5520TypeKrIntStat KeyReleaseInterruptStatus1KRAISTAT {
    Adp5520TypeKrIntStat get ();
}
member KeyReleaseInterruptStatus1KRAISTAT : Adp5520TypeKrIntStat with get

Property Value

Type: Adp5520TypeKrIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyReleaseInterruptStatus1KRBISTAT Property

IRD

Adp5520KeyReleaseInterruptStatus1KRBISTAT Property

Key Release Interrupt Status 1: KR_B_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKrIntStat KeyReleaseInterruptStatus1KRBISTAT { get; }
Public ReadOnly Property KeyReleaseInterruptStatus1KRBISTAT As Adp5520TypeKrIntStat
    Get
public:
property Adp5520TypeKrIntStat KeyReleaseInterruptStatus1KRBISTAT {
    Adp5520TypeKrIntStat get ();
}
member KeyReleaseInterruptStatus1KRBISTAT : Adp5520TypeKrIntStat with get

Property Value

Type: Adp5520TypeKrIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyReleaseInterruptStatus1KRCISTAT Property

IRD

Adp5520KeyReleaseInterruptStatus1KRCISTAT Property

Key Release Interrupt Status 1: KR_C_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKrIntStat KeyReleaseInterruptStatus1KRCISTAT { get; }
Public ReadOnly Property KeyReleaseInterruptStatus1KRCISTAT As Adp5520TypeKrIntStat
    Get
public:
property Adp5520TypeKrIntStat KeyReleaseInterruptStatus1KRCISTAT {
    Adp5520TypeKrIntStat get ();
}
member KeyReleaseInterruptStatus1KRCISTAT : Adp5520TypeKrIntStat with get

Property Value

Type: Adp5520TypeKrIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyReleaseInterruptStatus1KRDISTAT Property

IRD

Adp5520KeyReleaseInterruptStatus1KRDISTAT Property

Key Release Interrupt Status 1: KR_D_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKrIntStat KeyReleaseInterruptStatus1KRDISTAT { get; }
Public ReadOnly Property KeyReleaseInterruptStatus1KRDISTAT As Adp5520TypeKrIntStat
    Get
public:
property Adp5520TypeKrIntStat KeyReleaseInterruptStatus1KRDISTAT {
    Adp5520TypeKrIntStat get ();
}
member KeyReleaseInterruptStatus1KRDISTAT : Adp5520TypeKrIntStat with get

Property Value

Type: Adp5520TypeKrIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyReleaseInterruptStatus1KREISTAT Property

IRD

Adp5520KeyReleaseInterruptStatus1KREISTAT Property

Key Release Interrupt Status 1: KR_E_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKrIntStat KeyReleaseInterruptStatus1KREISTAT { get; }
Public ReadOnly Property KeyReleaseInterruptStatus1KREISTAT As Adp5520TypeKrIntStat
    Get
public:
property Adp5520TypeKrIntStat KeyReleaseInterruptStatus1KREISTAT {
    Adp5520TypeKrIntStat get ();
}
member KeyReleaseInterruptStatus1KREISTAT : Adp5520TypeKrIntStat with get

Property Value

Type: Adp5520TypeKrIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyReleaseInterruptStatus1KRFISTAT Property

IRD

Adp5520KeyReleaseInterruptStatus1KRFISTAT Property

Key Release Interrupt Status 1: KR_F_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKrIntStat KeyReleaseInterruptStatus1KRFISTAT { get; }
Public ReadOnly Property KeyReleaseInterruptStatus1KRFISTAT As Adp5520TypeKrIntStat
    Get
public:
property Adp5520TypeKrIntStat KeyReleaseInterruptStatus1KRFISTAT {
    Adp5520TypeKrIntStat get ();
}
member KeyReleaseInterruptStatus1KRFISTAT : Adp5520TypeKrIntStat with get

Property Value

Type: Adp5520TypeKrIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyReleaseInterruptStatus1KRGISTAT Property

IRD

Adp5520KeyReleaseInterruptStatus1KRGISTAT Property

Key Release Interrupt Status 1: KR_G_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKrIntStat KeyReleaseInterruptStatus1KRGISTAT { get; }
Public ReadOnly Property KeyReleaseInterruptStatus1KRGISTAT As Adp5520TypeKrIntStat
    Get
public:
property Adp5520TypeKrIntStat KeyReleaseInterruptStatus1KRGISTAT {
    Adp5520TypeKrIntStat get ();
}
member KeyReleaseInterruptStatus1KRGISTAT : Adp5520TypeKrIntStat with get

Property Value

Type: Adp5520TypeKrIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyReleaseInterruptStatus1KRHISTAT Property

IRD

Adp5520KeyReleaseInterruptStatus1KRHISTAT Property

Key Release Interrupt Status 1: KR_H_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKrIntStat KeyReleaseInterruptStatus1KRHISTAT { get; }
Public ReadOnly Property KeyReleaseInterruptStatus1KRHISTAT As Adp5520TypeKrIntStat
    Get
public:
property Adp5520TypeKrIntStat KeyReleaseInterruptStatus1KRHISTAT {
    Adp5520TypeKrIntStat get ();
}
member KeyReleaseInterruptStatus1KRHISTAT : Adp5520TypeKrIntStat with get

Property Value

Type: Adp5520TypeKrIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyReleaseInterruptStatus2KRIISTAT Property

IRD

Adp5520KeyReleaseInterruptStatus2KRIISTAT Property

Key Release Interrupt Status 2: KR_I_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKrIntStat KeyReleaseInterruptStatus2KRIISTAT { get; }
Public ReadOnly Property KeyReleaseInterruptStatus2KRIISTAT As Adp5520TypeKrIntStat
    Get
public:
property Adp5520TypeKrIntStat KeyReleaseInterruptStatus2KRIISTAT {
    Adp5520TypeKrIntStat get ();
}
member KeyReleaseInterruptStatus2KRIISTAT : Adp5520TypeKrIntStat with get

Property Value

Type: Adp5520TypeKrIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyReleaseInterruptStatus2KRJISTAT Property

IRD

Adp5520KeyReleaseInterruptStatus2KRJISTAT Property

Key Release Interrupt Status 2: KR_J_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKrIntStat KeyReleaseInterruptStatus2KRJISTAT { get; }
Public ReadOnly Property KeyReleaseInterruptStatus2KRJISTAT As Adp5520TypeKrIntStat
    Get
public:
property Adp5520TypeKrIntStat KeyReleaseInterruptStatus2KRJISTAT {
    Adp5520TypeKrIntStat get ();
}
member KeyReleaseInterruptStatus2KRJISTAT : Adp5520TypeKrIntStat with get

Property Value

Type: Adp5520TypeKrIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyReleaseInterruptStatus2KRKISTAT Property

IRD

Adp5520KeyReleaseInterruptStatus2KRKISTAT Property

Key Release Interrupt Status 2: KR_K_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKrIntStat KeyReleaseInterruptStatus2KRKISTAT { get; }
Public ReadOnly Property KeyReleaseInterruptStatus2KRKISTAT As Adp5520TypeKrIntStat
    Get
public:
property Adp5520TypeKrIntStat KeyReleaseInterruptStatus2KRKISTAT {
    Adp5520TypeKrIntStat get ();
}
member KeyReleaseInterruptStatus2KRKISTAT : Adp5520TypeKrIntStat with get

Property Value

Type: Adp5520TypeKrIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyReleaseInterruptStatus2KRLISTAT Property

IRD

Adp5520KeyReleaseInterruptStatus2KRLISTAT Property

Key Release Interrupt Status 2: KR_L_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKrIntStat KeyReleaseInterruptStatus2KRLISTAT { get; }
Public ReadOnly Property KeyReleaseInterruptStatus2KRLISTAT As Adp5520TypeKrIntStat
    Get
public:
property Adp5520TypeKrIntStat KeyReleaseInterruptStatus2KRLISTAT {
    Adp5520TypeKrIntStat get ();
}
member KeyReleaseInterruptStatus2KRLISTAT : Adp5520TypeKrIntStat with get

Property Value

Type: Adp5520TypeKrIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyReleaseInterruptStatus2KRMISTAT Property

IRD

Adp5520KeyReleaseInterruptStatus2KRMISTAT Property

Key Release Interrupt Status 2: KR_M_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKrIntStat KeyReleaseInterruptStatus2KRMISTAT { get; }
Public ReadOnly Property KeyReleaseInterruptStatus2KRMISTAT As Adp5520TypeKrIntStat
    Get
public:
property Adp5520TypeKrIntStat KeyReleaseInterruptStatus2KRMISTAT {
    Adp5520TypeKrIntStat get ();
}
member KeyReleaseInterruptStatus2KRMISTAT : Adp5520TypeKrIntStat with get

Property Value

Type: Adp5520TypeKrIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyReleaseInterruptStatus2KRNISTAT Property

IRD

Adp5520KeyReleaseInterruptStatus2KRNISTAT Property

Key Release Interrupt Status 2: KR_N_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKrIntStat KeyReleaseInterruptStatus2KRNISTAT { get; }
Public ReadOnly Property KeyReleaseInterruptStatus2KRNISTAT As Adp5520TypeKrIntStat
    Get
public:
property Adp5520TypeKrIntStat KeyReleaseInterruptStatus2KRNISTAT {
    Adp5520TypeKrIntStat get ();
}
member KeyReleaseInterruptStatus2KRNISTAT : Adp5520TypeKrIntStat with get

Property Value

Type: Adp5520TypeKrIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyReleaseInterruptStatus2KROISTAT Property

IRD

Adp5520KeyReleaseInterruptStatus2KROISTAT Property

Key Release Interrupt Status 2: KR_O_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKrIntStat KeyReleaseInterruptStatus2KROISTAT { get; }
Public ReadOnly Property KeyReleaseInterruptStatus2KROISTAT As Adp5520TypeKrIntStat
    Get
public:
property Adp5520TypeKrIntStat KeyReleaseInterruptStatus2KROISTAT {
    Adp5520TypeKrIntStat get ();
}
member KeyReleaseInterruptStatus2KROISTAT : Adp5520TypeKrIntStat with get

Property Value

Type: Adp5520TypeKrIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyReleaseInterruptStatus2KRPISTAT Property

IRD

Adp5520KeyReleaseInterruptStatus2KRPISTAT Property

Key Release Interrupt Status 2: KR_P_ISTAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKrIntStat KeyReleaseInterruptStatus2KRPISTAT { get; }
Public ReadOnly Property KeyReleaseInterruptStatus2KRPISTAT As Adp5520TypeKrIntStat
    Get
public:
property Adp5520TypeKrIntStat KeyReleaseInterruptStatus2KRPISTAT {
    Adp5520TypeKrIntStat get ();
}
member KeyReleaseInterruptStatus2KRPISTAT : Adp5520TypeKrIntStat with get

Property Value

Type: Adp5520TypeKrIntStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyStatus1KEYASTAT Property

IRD

Adp5520KeyStatus1KEYASTAT Property

Key Status 1: KEY_A_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKeyStat KeyStatus1KEYASTAT { get; }
Public ReadOnly Property KeyStatus1KEYASTAT As Adp5520TypeKeyStat
    Get
public:
property Adp5520TypeKeyStat KeyStatus1KEYASTAT {
    Adp5520TypeKeyStat get ();
}
member KeyStatus1KEYASTAT : Adp5520TypeKeyStat with get

Property Value

Type: Adp5520TypeKeyStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyStatus1KEYBSTAT Property

IRD

Adp5520KeyStatus1KEYBSTAT Property

Key Status 1: KEY_B_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKeyStat KeyStatus1KEYBSTAT { get; }
Public ReadOnly Property KeyStatus1KEYBSTAT As Adp5520TypeKeyStat
    Get
public:
property Adp5520TypeKeyStat KeyStatus1KEYBSTAT {
    Adp5520TypeKeyStat get ();
}
member KeyStatus1KEYBSTAT : Adp5520TypeKeyStat with get

Property Value

Type: Adp5520TypeKeyStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyStatus1KEYCSTAT Property

IRD

Adp5520KeyStatus1KEYCSTAT Property

Key Status 1: KEY_C_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKeyStat KeyStatus1KEYCSTAT { get; }
Public ReadOnly Property KeyStatus1KEYCSTAT As Adp5520TypeKeyStat
    Get
public:
property Adp5520TypeKeyStat KeyStatus1KEYCSTAT {
    Adp5520TypeKeyStat get ();
}
member KeyStatus1KEYCSTAT : Adp5520TypeKeyStat with get

Property Value

Type: Adp5520TypeKeyStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyStatus1KEYDSTAT Property

IRD

Adp5520KeyStatus1KEYDSTAT Property

Key Status 1: KEY_D_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKeyStat KeyStatus1KEYDSTAT { get; }
Public ReadOnly Property KeyStatus1KEYDSTAT As Adp5520TypeKeyStat
    Get
public:
property Adp5520TypeKeyStat KeyStatus1KEYDSTAT {
    Adp5520TypeKeyStat get ();
}
member KeyStatus1KEYDSTAT : Adp5520TypeKeyStat with get

Property Value

Type: Adp5520TypeKeyStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyStatus1KEYESTAT Property

IRD

Adp5520KeyStatus1KEYESTAT Property

Key Status 1: KEY_E_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKeyStat KeyStatus1KEYESTAT { get; }
Public ReadOnly Property KeyStatus1KEYESTAT As Adp5520TypeKeyStat
    Get
public:
property Adp5520TypeKeyStat KeyStatus1KEYESTAT {
    Adp5520TypeKeyStat get ();
}
member KeyStatus1KEYESTAT : Adp5520TypeKeyStat with get

Property Value

Type: Adp5520TypeKeyStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyStatus1KEYFSTAT Property

IRD

Adp5520KeyStatus1KEYFSTAT Property

Key Status 1: KEY_F_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKeyStat KeyStatus1KEYFSTAT { get; }
Public ReadOnly Property KeyStatus1KEYFSTAT As Adp5520TypeKeyStat
    Get
public:
property Adp5520TypeKeyStat KeyStatus1KEYFSTAT {
    Adp5520TypeKeyStat get ();
}
member KeyStatus1KEYFSTAT : Adp5520TypeKeyStat with get

Property Value

Type: Adp5520TypeKeyStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyStatus1KEYGSTAT Property

IRD

Adp5520KeyStatus1KEYGSTAT Property

Key Status 1: KEY_G_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKeyStat KeyStatus1KEYGSTAT { get; }
Public ReadOnly Property KeyStatus1KEYGSTAT As Adp5520TypeKeyStat
    Get
public:
property Adp5520TypeKeyStat KeyStatus1KEYGSTAT {
    Adp5520TypeKeyStat get ();
}
member KeyStatus1KEYGSTAT : Adp5520TypeKeyStat with get

Property Value

Type: Adp5520TypeKeyStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyStatus1KEYHSTAT Property

IRD

Adp5520KeyStatus1KEYHSTAT Property

Key Status 1: KEY_H_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKeyStat KeyStatus1KEYHSTAT { get; }
Public ReadOnly Property KeyStatus1KEYHSTAT As Adp5520TypeKeyStat
    Get
public:
property Adp5520TypeKeyStat KeyStatus1KEYHSTAT {
    Adp5520TypeKeyStat get ();
}
member KeyStatus1KEYHSTAT : Adp5520TypeKeyStat with get

Property Value

Type: Adp5520TypeKeyStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyStatus2KEYISTAT Property

IRD

Adp5520KeyStatus2KEYISTAT Property

Key Status 2: KEY_I_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKeyStat KeyStatus2KEYISTAT { get; }
Public ReadOnly Property KeyStatus2KEYISTAT As Adp5520TypeKeyStat
    Get
public:
property Adp5520TypeKeyStat KeyStatus2KEYISTAT {
    Adp5520TypeKeyStat get ();
}
member KeyStatus2KEYISTAT : Adp5520TypeKeyStat with get

Property Value

Type: Adp5520TypeKeyStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyStatus2KEYJSTAT Property

IRD

Adp5520KeyStatus2KEYJSTAT Property

Key Status 2: KEY_J_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKeyStat KeyStatus2KEYJSTAT { get; }
Public ReadOnly Property KeyStatus2KEYJSTAT As Adp5520TypeKeyStat
    Get
public:
property Adp5520TypeKeyStat KeyStatus2KEYJSTAT {
    Adp5520TypeKeyStat get ();
}
member KeyStatus2KEYJSTAT : Adp5520TypeKeyStat with get

Property Value

Type: Adp5520TypeKeyStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyStatus2KEYKSTAT Property

IRD

Adp5520KeyStatus2KEYKSTAT Property

Key Status 2: KEY_K_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKeyStat KeyStatus2KEYKSTAT { get; }
Public ReadOnly Property KeyStatus2KEYKSTAT As Adp5520TypeKeyStat
    Get
public:
property Adp5520TypeKeyStat KeyStatus2KEYKSTAT {
    Adp5520TypeKeyStat get ();
}
member KeyStatus2KEYKSTAT : Adp5520TypeKeyStat with get

Property Value

Type: Adp5520TypeKeyStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyStatus2KEYLSTAT Property

IRD

Adp5520KeyStatus2KEYLSTAT Property

Key Status 2: KEY_L_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKeyStat KeyStatus2KEYLSTAT { get; }
Public ReadOnly Property KeyStatus2KEYLSTAT As Adp5520TypeKeyStat
    Get
public:
property Adp5520TypeKeyStat KeyStatus2KEYLSTAT {
    Adp5520TypeKeyStat get ();
}
member KeyStatus2KEYLSTAT : Adp5520TypeKeyStat with get

Property Value

Type: Adp5520TypeKeyStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyStatus2KEYMSTAT Property

IRD

Adp5520KeyStatus2KEYMSTAT Property

Key Status 2: KEY_M_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKeyStat KeyStatus2KEYMSTAT { get; }
Public ReadOnly Property KeyStatus2KEYMSTAT As Adp5520TypeKeyStat
    Get
public:
property Adp5520TypeKeyStat KeyStatus2KEYMSTAT {
    Adp5520TypeKeyStat get ();
}
member KeyStatus2KEYMSTAT : Adp5520TypeKeyStat with get

Property Value

Type: Adp5520TypeKeyStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyStatus2KEYNSTAT Property

IRD

Adp5520KeyStatus2KEYNSTAT Property

Key Status 2: KEY_N_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKeyStat KeyStatus2KEYNSTAT { get; }
Public ReadOnly Property KeyStatus2KEYNSTAT As Adp5520TypeKeyStat
    Get
public:
property Adp5520TypeKeyStat KeyStatus2KEYNSTAT {
    Adp5520TypeKeyStat get ();
}
member KeyStatus2KEYNSTAT : Adp5520TypeKeyStat with get

Property Value

Type: Adp5520TypeKeyStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyStatus2KEYOSTAT Property

IRD

Adp5520KeyStatus2KEYOSTAT Property

Key Status 2: KEY_O_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKeyStat KeyStatus2KEYOSTAT { get; }
Public ReadOnly Property KeyStatus2KEYOSTAT As Adp5520TypeKeyStat
    Get
public:
property Adp5520TypeKeyStat KeyStatus2KEYOSTAT {
    Adp5520TypeKeyStat get ();
}
member KeyStatus2KEYOSTAT : Adp5520TypeKeyStat with get

Property Value

Type: Adp5520TypeKeyStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.KeyStatus2KEYPSTAT Property

IRD

Adp5520KeyStatus2KEYPSTAT Property

Key Status 2: KEY_P_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeKeyStat KeyStatus2KEYPSTAT { get; }
Public ReadOnly Property KeyStatus2KEYPSTAT As Adp5520TypeKeyStat
    Get
public:
property Adp5520TypeKeyStat KeyStatus2KEYPSTAT {
    Adp5520TypeKeyStat get ();
}
member KeyStatus2KEYPSTAT : Adp5520TypeKeyStat with get

Property Value

Type: Adp5520TypeKeyStat
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.LED1SinkCurrent Property

IRD

Adp5520LED1SinkCurrent Property

LED 1 Sink Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LED1SinkCurrent { get; set; }
Public Property LED1SinkCurrent As Byte
    Get
    Set
public:
property unsigned char LED1SinkCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member LED1SinkCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.LED2SinkCurrent Property

IRD

Adp5520LED2SinkCurrent Property

LED 2 Sink Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LED2SinkCurrent { get; set; }
Public Property LED2SinkCurrent As Byte
    Get
    Set
public:
property unsigned char LED2SinkCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member LED2SinkCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.LED3SinkCurrent Property

IRD

Adp5520LED3SinkCurrent Property

LED 3 Sink Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LED3SinkCurrent { get; set; }
Public Property LED3SinkCurrent As Byte
    Get
    Set
public:
property unsigned char LED3SinkCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member LED3SinkCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.LEDControlC3MODE Property

IRD

Adp5520LEDControlC3MODE Property

LED Control: C3_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeLedControlC3Mode LEDControlC3MODE { get; set; }
Public Property LEDControlC3MODE As Adp5520TypeLedControlC3Mode
    Get
    Set
public:
property Adp5520TypeLedControlC3Mode LEDControlC3MODE {
    Adp5520TypeLedControlC3Mode get ();
    void set (Adp5520TypeLedControlC3Mode value);
}
member LEDControlC3MODE : Adp5520TypeLedControlC3Mode with get, set

Property Value

Type: Adp5520TypeLedControlC3Mode
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.LEDControlLED1EN Property

IRD

Adp5520LEDControlLED1EN Property

LED Control: LED1_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeLedControlLed1En LEDControlLED1EN { get; set; }
Public Property LEDControlLED1EN As Adp5520TypeLedControlLed1En
    Get
    Set
public:
property Adp5520TypeLedControlLed1En LEDControlLED1EN {
    Adp5520TypeLedControlLed1En get ();
    void set (Adp5520TypeLedControlLed1En value);
}
member LEDControlLED1EN : Adp5520TypeLedControlLed1En with get, set

Property Value

Type: Adp5520TypeLedControlLed1En
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.LEDControlLED2EN Property

IRD

Adp5520LEDControlLED2EN Property

LED Control: LED2_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeLedControlLed2En LEDControlLED2EN { get; set; }
Public Property LEDControlLED2EN As Adp5520TypeLedControlLed2En
    Get
    Set
public:
property Adp5520TypeLedControlLed2En LEDControlLED2EN {
    Adp5520TypeLedControlLed2En get ();
    void set (Adp5520TypeLedControlLed2En value);
}
member LEDControlLED2EN : Adp5520TypeLedControlLed2En with get, set

Property Value

Type: Adp5520TypeLedControlLed2En
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.LEDControlLED3EN Property

IRD

Adp5520LEDControlLED3EN Property

LED Control: LED3_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeLedControlLed3En LEDControlLED3EN { get; set; }
Public Property LEDControlLED3EN As Adp5520TypeLedControlLed3En
    Get
    Set
public:
property Adp5520TypeLedControlLed3En LEDControlLED3EN {
    Adp5520TypeLedControlLed3En get ();
    void set (Adp5520TypeLedControlLed3En value);
}
member LEDControlLED3EN : Adp5520TypeLedControlLed3En with get, set

Property Value

Type: Adp5520TypeLedControlLed3En
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.LEDControlLEDLAW Property

IRD

Adp5520LEDControlLEDLAW Property

LED Control: LED_LAW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeLedControlLedLaw LEDControlLEDLAW { get; set; }
Public Property LEDControlLEDLAW As Adp5520TypeLedControlLedLaw
    Get
    Set
public:
property Adp5520TypeLedControlLedLaw LEDControlLEDLAW {
    Adp5520TypeLedControlLedLaw get ();
    void set (Adp5520TypeLedControlLedLaw value);
}
member LEDControlLEDLAW : Adp5520TypeLedControlLedLaw with get, set

Property Value

Type: Adp5520TypeLedControlLedLaw
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.LEDControlR3MODE Property

IRD

Adp5520LEDControlR3MODE Property

LED Control: R3_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeLedControlR3Mode LEDControlR3MODE { get; set; }
Public Property LEDControlR3MODE As Adp5520TypeLedControlR3Mode
    Get
    Set
public:
property Adp5520TypeLedControlR3Mode LEDControlR3MODE {
    Adp5520TypeLedControlR3Mode get ();
    void set (Adp5520TypeLedControlR3Mode value);
}
member LEDControlR3MODE : Adp5520TypeLedControlR3Mode with get, set

Property Value

Type: Adp5520TypeLedControlR3Mode
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.LEDFadeInAndFadeOutTimersLEDFI Property

IRD

Adp5520LEDFadeInAndFadeOutTimersLEDFI Property

LED Fade-In and Fade-Out Timers: LED_FI

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeLedFade LEDFadeInAndFadeOutTimersLEDFI { get; set; }
Public Property LEDFadeInAndFadeOutTimersLEDFI As Adp5520TypeLedFade
    Get
    Set
public:
property Adp5520TypeLedFade LEDFadeInAndFadeOutTimersLEDFI {
    Adp5520TypeLedFade get ();
    void set (Adp5520TypeLedFade value);
}
member LEDFadeInAndFadeOutTimersLEDFI : Adp5520TypeLedFade with get, set

Property Value

Type: Adp5520TypeLedFade
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.LEDFadeInAndFadeOutTimersLEDFO Property

IRD

Adp5520LEDFadeInAndFadeOutTimersLEDFO Property

LED Fade-In and Fade-Out Timers: LED_FO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeLedFade LEDFadeInAndFadeOutTimersLEDFO { get; set; }
Public Property LEDFadeInAndFadeOutTimersLEDFO As Adp5520TypeLedFade
    Get
    Set
public:
property Adp5520TypeLedFade LEDFadeInAndFadeOutTimersLEDFO {
    Adp5520TypeLedFade get ();
    void set (Adp5520TypeLedFade value);
}
member LEDFadeInAndFadeOutTimersLEDFO : Adp5520TypeLedFade with get, set

Property Value

Type: Adp5520TypeLedFade
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.Level1DaylightDimCurrent Property

IRD

Adp5520Level1DaylightDimCurrent Property

Level 1 (Daylight) Dim Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Level1DaylightDimCurrent { get; set; }
Public Property Level1DaylightDimCurrent As Byte
    Get
    Set
public:
property unsigned char Level1DaylightDimCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member Level1DaylightDimCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.Level1DaylightMaximumCurrent Property

IRD

Adp5520Level1DaylightMaximumCurrent Property

Level 1 (Daylight) Maximum Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Level1DaylightMaximumCurrent { get; set; }
Public Property Level1DaylightMaximumCurrent As Byte
    Get
    Set
public:
property unsigned char Level1DaylightMaximumCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member Level1DaylightMaximumCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.Level2OfficeComparatorHysteresis Property

IRD

Adp5520Level2OfficeComparatorHysteresis Property

Level 2 (Office) Comparator Hysteresis (unit: µA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Level2OfficeComparatorHysteresis { get; set; }
Public Property Level2OfficeComparatorHysteresis As Double
    Get
    Set
public:
property double Level2OfficeComparatorHysteresis {
    double get ();
    void set (double value);
}
member Level2OfficeComparatorHysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.Level2OfficeComparatorTripPoint Property

IRD

Adp5520Level2OfficeComparatorTripPoint Property

Level 2 (Office) Comparator Trip Point (unit: µA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Level2OfficeComparatorTripPoint { get; set; }
Public Property Level2OfficeComparatorTripPoint As Double
    Get
    Set
public:
property double Level2OfficeComparatorTripPoint {
    double get ();
    void set (double value);
}
member Level2OfficeComparatorTripPoint : float with get, set

Property Value

Type: Double
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.Level2OfficeDimCurrent Property

IRD

Adp5520Level2OfficeDimCurrent Property

Level 2 (Office) Dim Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Level2OfficeDimCurrent { get; set; }
Public Property Level2OfficeDimCurrent As Byte
    Get
    Set
public:
property unsigned char Level2OfficeDimCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member Level2OfficeDimCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.Level2OfficeMaximumCurrent Property

IRD

Adp5520Level2OfficeMaximumCurrent Property

Level 2 (Office) Maximum Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Level2OfficeMaximumCurrent { get; set; }
Public Property Level2OfficeMaximumCurrent As Byte
    Get
    Set
public:
property unsigned char Level2OfficeMaximumCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member Level2OfficeMaximumCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.Level3DarkComparatorHysteresis Property

IRD

Adp5520Level3DarkComparatorHysteresis Property

Level 3 (Dark) Comparator Hysteresis (unit: µA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Level3DarkComparatorHysteresis { get; set; }
Public Property Level3DarkComparatorHysteresis As Double
    Get
    Set
public:
property double Level3DarkComparatorHysteresis {
    double get ();
    void set (double value);
}
member Level3DarkComparatorHysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.Level3DarkComparatorTripPoint Property

IRD

Adp5520Level3DarkComparatorTripPoint Property

Level 3 (Dark) Comparator Trip Point (unit: µA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Level3DarkComparatorTripPoint { get; set; }
Public Property Level3DarkComparatorTripPoint As Double
    Get
    Set
public:
property double Level3DarkComparatorTripPoint {
    double get ();
    void set (double value);
}
member Level3DarkComparatorTripPoint : float with get, set

Property Value

Type: Double
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.Level3DarkDimCurrent Property

IRD

Adp5520Level3DarkDimCurrent Property

Level 3 (Dark) Dim Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Level3DarkDimCurrent { get; set; }
Public Property Level3DarkDimCurrent As Byte
    Get
    Set
public:
property unsigned char Level3DarkDimCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member Level3DarkDimCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.Level3DarkMaximumCurrent Property

IRD

Adp5520Level3DarkMaximumCurrent Property

Level 3 (Dark) Maximum Current

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Level3DarkMaximumCurrent { get; set; }
Public Property Level3DarkMaximumCurrent As Byte
    Get
    Set
public:
property unsigned char Level3DarkMaximumCurrent {
    unsigned char get ();
    void set (unsigned char value);
}
member Level3DarkMaximumCurrent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.LightSensorComparatorConfigurationFILT Property

IRD

Adp5520LightSensorComparatorConfigurationFILT Property

Light Sensor Comparator Configuration: FILT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeAlsCmprCfgFilt LightSensorComparatorConfigurationFILT { get; set; }
Public Property LightSensorComparatorConfigurationFILT As Adp5520TypeAlsCmprCfgFilt
    Get
    Set
public:
property Adp5520TypeAlsCmprCfgFilt LightSensorComparatorConfigurationFILT {
    Adp5520TypeAlsCmprCfgFilt get ();
    void set (Adp5520TypeAlsCmprCfgFilt value);
}
member LightSensorComparatorConfigurationFILT : Adp5520TypeAlsCmprCfgFilt with get, set

Property Value

Type: Adp5520TypeAlsCmprCfgFilt
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.LightSensorComparatorConfigurationFORCERD Property

IRD

Adp5520LightSensorComparatorConfigurationFORCERD Property

Light Sensor Comparator Configuration: FORCE_RD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeAlsCmprCfgForceRd LightSensorComparatorConfigurationFORCERD { get; set; }
Public Property LightSensorComparatorConfigurationFORCERD As Adp5520TypeAlsCmprCfgForceRd
    Get
    Set
public:
property Adp5520TypeAlsCmprCfgForceRd LightSensorComparatorConfigurationFORCERD {
    Adp5520TypeAlsCmprCfgForceRd get ();
    void set (Adp5520TypeAlsCmprCfgForceRd value);
}
member LightSensorComparatorConfigurationFORCERD : Adp5520TypeAlsCmprCfgForceRd with get, set

Property Value

Type: Adp5520TypeAlsCmprCfgForceRd
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.LightSensorComparatorConfigurationL2EN Property

IRD

Adp5520LightSensorComparatorConfigurationL2EN Property

Light Sensor Comparator Configuration: L2_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeAlsCmprCfgL2En LightSensorComparatorConfigurationL2EN { get; set; }
Public Property LightSensorComparatorConfigurationL2EN As Adp5520TypeAlsCmprCfgL2En
    Get
    Set
public:
property Adp5520TypeAlsCmprCfgL2En LightSensorComparatorConfigurationL2EN {
    Adp5520TypeAlsCmprCfgL2En get ();
    void set (Adp5520TypeAlsCmprCfgL2En value);
}
member LightSensorComparatorConfigurationL2EN : Adp5520TypeAlsCmprCfgL2En with get, set

Property Value

Type: Adp5520TypeAlsCmprCfgL2En
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.LightSensorComparatorConfigurationL2OUT Property

IRD

Adp5520LightSensorComparatorConfigurationL2OUT Property

Light Sensor Comparator Configuration: L2_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeAlsCmprCfgL2Out LightSensorComparatorConfigurationL2OUT { get; set; }
Public Property LightSensorComparatorConfigurationL2OUT As Adp5520TypeAlsCmprCfgL2Out
    Get
    Set
public:
property Adp5520TypeAlsCmprCfgL2Out LightSensorComparatorConfigurationL2OUT {
    Adp5520TypeAlsCmprCfgL2Out get ();
    void set (Adp5520TypeAlsCmprCfgL2Out value);
}
member LightSensorComparatorConfigurationL2OUT : Adp5520TypeAlsCmprCfgL2Out with get, set

Property Value

Type: Adp5520TypeAlsCmprCfgL2Out
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.LightSensorComparatorConfigurationL3EN Property

IRD

Adp5520LightSensorComparatorConfigurationL3EN Property

Light Sensor Comparator Configuration: L3_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeAlsCmprCfgL3En LightSensorComparatorConfigurationL3EN { get; set; }
Public Property LightSensorComparatorConfigurationL3EN As Adp5520TypeAlsCmprCfgL3En
    Get
    Set
public:
property Adp5520TypeAlsCmprCfgL3En LightSensorComparatorConfigurationL3EN {
    Adp5520TypeAlsCmprCfgL3En get ();
    void set (Adp5520TypeAlsCmprCfgL3En value);
}
member LightSensorComparatorConfigurationL3EN : Adp5520TypeAlsCmprCfgL3En with get, set

Property Value

Type: Adp5520TypeAlsCmprCfgL3En
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.LightSensorComparatorConfigurationL3OUT Property

IRD

Adp5520LightSensorComparatorConfigurationL3OUT Property

Light Sensor Comparator Configuration: L3_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5520TypeAlsCmprCfgL3Out LightSensorComparatorConfigurationL3OUT { get; set; }
Public Property LightSensorComparatorConfigurationL3OUT As Adp5520TypeAlsCmprCfgL3Out
    Get
    Set
public:
property Adp5520TypeAlsCmprCfgL3Out LightSensorComparatorConfigurationL3OUT {
    Adp5520TypeAlsCmprCfgL3Out get ();
    void set (Adp5520TypeAlsCmprCfgL3Out value);
}
member LightSensorComparatorConfigurationL3OUT : Adp5520TypeAlsCmprCfgL3Out with get, set

Property Value

Type: Adp5520TypeAlsCmprCfgL3Out
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520 Methods

The Adp5520 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.Flush Method

IRD

Adp5520Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adp5520 Class
telos.Ird.AnalogDevices Namespace


Adp5520.TypeAlsCmprCfgFilt Enumeration

IRD

Adp5520TypeAlsCmprCfgFilt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlsCmprCfgFilt
Public Enumeration TypeAlsCmprCfgFilt
public enum class TypeAlsCmprCfgFilt
type TypeAlsCmprCfgFilt
Members
Member name | Value | Description
Value_008S | 0 | 0.08 s
Value_016S | 1 | 0.16 s
Value_032S | 2 | 0.32 s
Value_064S | 3 | 0.64 s
Value_128S | 4 | 1.28 s
Value_256S | 5 | 2.56 s
Value_512S | 6 | 5.12 s
Value_1024S | 7 | 10.24 s
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeAlsCmprCfgForceRd Enumeration

IRD

Adp5520TypeAlsCmprCfgForceRd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlsCmprCfgForceRd
Public Enumeration TypeAlsCmprCfgForceRd
public enum class TypeAlsCmprCfgForceRd
type TypeAlsCmprCfgForceRd
Members
Member name | Value | Description
Default | 0 | Default
ForceSingleConversion | 1 | Force Single Conversion
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeAlsCmprCfgL2En Enumeration

IRD

Adp5520TypeAlsCmprCfgL2En Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlsCmprCfgL2En
Public Enumeration TypeAlsCmprCfgL2En
public enum class TypeAlsCmprCfgL2En
type TypeAlsCmprCfgL2En
Members
Member name | Value | Description
L2CMPRDisabled | 0 | L2_CMPR: Disabled
L2CMPREnabled | 1 | L2_CMPR: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeAlsCmprCfgL2Out Enumeration

IRD

Adp5520TypeAlsCmprCfgL2Out Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlsCmprCfgL2Out
Public Enumeration TypeAlsCmprCfgL2Out
public enum class TypeAlsCmprCfgL2Out
type TypeAlsCmprCfgL2Out
Members
Member name | Value | Description
AmbientLightGreaterThanL2 | 0 | Ambient Light: Greater Than L2
AmbientLightChangeFromL1ToL2 | 1 | Ambient Light: Change from L1 to L2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeAlsCmprCfgL3En Enumeration

IRD

Adp5520TypeAlsCmprCfgL3En Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlsCmprCfgL3En
Public Enumeration TypeAlsCmprCfgL3En
public enum class TypeAlsCmprCfgL3En
type TypeAlsCmprCfgL3En
Members
Member name | Value | Description
L3CMPRDisabled | 0 | L3_CMPR: Disabled
L3CMPREnabled | 1 | L3_CMPR: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeAlsCmprCfgL3Out Enumeration

IRD

Adp5520TypeAlsCmprCfgL3Out Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlsCmprCfgL3Out
Public Enumeration TypeAlsCmprCfgL3Out
public enum class TypeAlsCmprCfgL3Out
type TypeAlsCmprCfgL3Out
Members
Member name | Value | Description
AmbientLightGreaterThanL3 | 0 | Ambient Light: Greater Than L3
AmbientLightChangeFromL2ToL3 | 1 | Ambient Light: Change from L2 to L3
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeBlControlBlAutoAdj Enumeration

IRD

Adp5520TypeBlControlBlAutoAdj Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBlControlBlAutoAdj
Public Enumeration TypeBlControlBlAutoAdj
public enum class TypeBlControlBlAutoAdj
type TypeBlControlBlAutoAdj
Members
Member name | Value | Description
Manual | 0 | Manual
Automatic | 1 | Automatic
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeBlControlBlLaw Enumeration

IRD

Adp5520TypeBlControlBlLaw Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBlControlBlLaw
Public Enumeration TypeBlControlBlLaw
public enum class TypeBlControlBlLaw
type TypeBlControlBlLaw
Members
Member name | Value | Description
Linear | 0 | Linear
Square | 1 | Square
Cubic1 | 2 | Cubic 1
Cubic2 | 3 | Cubic 2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeBlControlBlLvl Enumeration

IRD

Adp5520TypeBlControlBlLvl Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBlControlBlLvl
Public Enumeration TypeBlControlBlLvl
public enum class TypeBlControlBlLvl
type TypeBlControlBlLvl
Members
Member name | Value | Description
DaylightL1 | 0 | Daylight (L1)
OfficeL2 | 1 | Office (L2)
DarkL3 | 2 | Dark (L3)
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeBlControlFovr Enumeration

IRD

Adp5520TypeBlControlFovr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBlControlFovr
Public Enumeration TypeBlControlFovr
public enum class TypeBlControlFovr
type TypeBlControlFovr
Members
Member name | Value | Description
BacklightFadeOverrideDisabled | 0 | Backlight Fade Override: Disabled
BacklightFadeOverrideEnabled | 1 | Backlight Fade Override: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeBlControlKpBlEn Enumeration

IRD

Adp5520TypeBlControlKpBlEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBlControlKpBlEn
Public Enumeration TypeBlControlKpBlEn
public enum class TypeBlControlKpBlEn
type TypeBlControlKpBlEn
Members
Member name | Value | Description
KeyPressNotEffect | 0 | Key Press: Not Effect
KeyPressEffect | 1 | Key Press: Effect
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeBlControlOvpEn Enumeration

IRD

Adp5520TypeBlControlOvpEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBlControlOvpEn
Public Enumeration TypeBlControlOvpEn
public enum class TypeBlControlOvpEn
type TypeBlControlOvpEn
Members
Member name | Value | Description
BacklightRampDownDuringOVPDisabled | 0 | Backlight Ramp-Down During OVP: Disabled
BacklightRampDownDuringOVPEnabled | 1 | Backlight Ramp-Down During OVP: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeBlFade Enumeration

IRD

Adp5520TypeBlFade Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBlFade
Public Enumeration TypeBlFade
public enum class TypeBlFade
type TypeBlFade
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_03S | 1 | 0.3 s
Value_06S | 2 | 0.6 s
Value_09S | 3 | 0.9 s
Value_12S | 4 | 1.2 s
Value_15S | 5 | 1.5 s
Value_18S | 6 | 1.8 s
Value_21S | 7 | 2.1 s
Value_24S | 8 | 2.4 s
Value_27S | 9 | 2.7 s
Value_30S | 10 | 3.0 s
Value_35S | 11 | 3.5 s
Value_40S | 12 | 4.0 s
Value_45S | 13 | 4.5 s
Value_50S | 14 | 5.0 s
Value_55S | 15 | 5.5 s
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeBlTime Enumeration

IRD

Adp5520TypeBlTime Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBlTime
Public Enumeration TypeBlTime
public enum class TypeBlTime
type TypeBlTime
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_10S | 1 | 10 s
Value_15S | 2 | 15 s
Value_20S | 3 | 20 s
Value_25S | 4 | 25 s
Value_30S | 5 | 30 s
Value_35S | 6 | 35 s
Value_40S | 7 | 40 s
Value_50S | 8 | 50 s
Value_60S | 9 | 60 s
Value_70S | 10 | 70 s
Value_80S | 11 | 80 s
Value_90S | 12 | 90 s
Value_100S | 13 | 100 s
Value_110S | 14 | 110 s
Value_120S | 15 | 120 s
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeGpioCfg1C0Config Enumeration

IRD

Adp5520TypeGpioCfg1C0Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioCfg1C0Config
Public Enumeration TypeGpioCfg1C0Config
public enum class TypeGpioCfg1C0Config
type TypeGpioCfg1C0Config
Members
Member name | Value | Description
C0GPIOD4 | 0 | C0: GPIO (D4)
C0KeypadColumn | 1 | C0: Keypad Column
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeGpioCfg1C1Config Enumeration

IRD

Adp5520TypeGpioCfg1C1Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioCfg1C1Config
Public Enumeration TypeGpioCfg1C1Config
public enum class TypeGpioCfg1C1Config
type TypeGpioCfg1C1Config
Members
Member name | Value | Description
C1GPIOD5 | 0 | C1: GPIO (D5)
C1KeypadColumn | 1 | C1: Keypad Column
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeGpioCfg1C2Config Enumeration

IRD

Adp5520TypeGpioCfg1C2Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioCfg1C2Config
Public Enumeration TypeGpioCfg1C2Config
public enum class TypeGpioCfg1C2Config
type TypeGpioCfg1C2Config
Members
Member name | Value | Description
C2GPIOD6 | 0 | C2: GPIO (D6)
C2KeypadColumn | 1 | C2: Keypad Column
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeGpioCfg1C3Config Enumeration

IRD

Adp5520TypeGpioCfg1C3Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioCfg1C3Config
Public Enumeration TypeGpioCfg1C3Config
public enum class TypeGpioCfg1C3Config
type TypeGpioCfg1C3Config
Members
Member name | Value | Description
C3GPIOD7 | 0 | C3: GPIO (D7)
C3KeypadColumn | 1 | C3: Keypad Column
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeGpioCfg1R0Config Enumeration

IRD

Adp5520TypeGpioCfg1R0Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioCfg1R0Config
Public Enumeration TypeGpioCfg1R0Config
public enum class TypeGpioCfg1R0Config
type TypeGpioCfg1R0Config
Members
Member name | Value | Description
R0GPIOD0 | 0 | R0: GPIO (D0)
R0KeypadRow | 1 | R0: Keypad Row
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeGpioCfg1R1Config Enumeration

IRD

Adp5520TypeGpioCfg1R1Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioCfg1R1Config
Public Enumeration TypeGpioCfg1R1Config
public enum class TypeGpioCfg1R1Config
type TypeGpioCfg1R1Config
Members
Member name | Value | Description
R1GPIOD1 | 0 | R1: GPIO (D1)
R1KeypadRow | 1 | R1: Keypad Row
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeGpioCfg1R2Config Enumeration

IRD

Adp5520TypeGpioCfg1R2Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioCfg1R2Config
Public Enumeration TypeGpioCfg1R2Config
public enum class TypeGpioCfg1R2Config
type TypeGpioCfg1R2Config
Members
Member name | Value | Description
R2GPIOD2 | 0 | R2: GPIO (D2)
R2KeypadRow | 1 | R2: Keypad Row
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeGpioCfg1R3Config Enumeration

IRD

Adp5520TypeGpioCfg1R3Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioCfg1R3Config
Public Enumeration TypeGpioCfg1R3Config
public enum class TypeGpioCfg1R3Config
type TypeGpioCfg1R3Config
Members
Member name | Value | Description
R3GPIOD3 | 0 | R3: GPIO (D3)
R3KeypadRow | 1 | R3: Keypad Row
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeGpioCfg2Dir Enumeration

IRD

Adp5520TypeGpioCfg2Dir Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioCfg2Dir
Public Enumeration TypeGpioCfg2Dir
public enum class TypeGpioCfg2Dir
type TypeGpioCfg2Dir
Members
Member name | Value | Description
Input | 0 | Input
Output | 1 | Output
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeGpioDebounce Enumeration

IRD

Adp5520TypeGpioDebounce Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioDebounce
Public Enumeration TypeGpioDebounce
public enum class TypeGpioDebounce
type TypeGpioDebounce
Members
Member name | Value | Description
DebounceEnabled | 0 | Debounce: Enabled
DebounceDisabled | 1 | Debounce: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeGpioIn Enumeration

IRD

Adp5520TypeGpioIn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioIn
Public Enumeration TypeGpioIn
public enum class TypeGpioIn
type TypeGpioIn
Members
Member name | Value | Description
Low | 0 | Low
High | 1 | High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeGpioIntEn Enumeration

IRD

Adp5520TypeGpioIntEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioIntEn
Public Enumeration TypeGpioIntEn
public enum class TypeGpioIntEn
type TypeGpioIntEn
Members
Member name | Value | Description
IRQPrevented | 0 | IRQ: Prevented
IRQAllowed | 1 | IRQ: Allowed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeGpioIntLvl Enumeration

IRD

Adp5520TypeGpioIntLvl Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioIntLvl
Public Enumeration TypeGpioIntLvl
public enum class TypeGpioIntLvl
type TypeGpioIntLvl
Members
Member name | Value | Description
Low | 0 | Low
High | 1 | High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeGpioIntStat Enumeration

IRD

Adp5520TypeGpioIntStat Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioIntStat
Public Enumeration TypeGpioIntStat
public enum class TypeGpioIntStat
type TypeGpioIntStat
Members
Member name | Value | Description
NoInterrupt | 0 | No Interrupt
Interrupt | 1 | Interrupt
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeGpioOut Enumeration

IRD

Adp5520TypeGpioOut Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioOut
Public Enumeration TypeGpioOut
public enum class TypeGpioOut
type TypeGpioOut
Members
Member name | Value | Description
Low | 0 | Low
High | 1 | High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeGpioPullup Enumeration

IRD

Adp5520TypeGpioPullup Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioPullup
Public Enumeration TypeGpioPullup
public enum class TypeGpioPullup
type TypeGpioPullup
Members
Member name | Value | Description
PullUpDisabled | 0 | Pull-Up: Disabled
PullUpEnabled | 1 | Pull-Up: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeInterruptEnableAutoLdEn Enumeration

IRD

Adp5520TypeInterruptEnableAutoLdEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableAutoLdEn
Public Enumeration TypeInterruptEnableAutoLdEn
public enum class TypeInterruptEnableAutoLdEn
type TypeInterruptEnableAutoLdEn
Members
Member name | Value | Description
AutoloadDisabled | 0 | Autoload: Disabled
AutoloadEnabled | 1 | Autoload: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeInterruptEnableCmprIen Enumeration

IRD

Adp5520TypeInterruptEnableCmprIen Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableCmprIen
Public Enumeration TypeInterruptEnableCmprIen
public enum class TypeInterruptEnableCmprIen
type TypeInterruptEnableCmprIen
Members
Member name | Value | Description
ComparatorInterruptDisabled | 0 | Comparator Interrupt: Disabled
ComparatorInterruptEnabled | 1 | Comparator Interrupt: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeInterruptEnableKpIen Enumeration

IRD

Adp5520TypeInterruptEnableKpIen Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableKpIen
Public Enumeration TypeInterruptEnableKpIen
public enum class TypeInterruptEnableKpIen
type TypeInterruptEnableKpIen
Members
Member name | Value | Description
KeyPressInterruptDisabled | 0 | Key Press Interrupt: Disabled
KeyPressInterruptEnabled | 1 | Key Press Interrupt: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeInterruptEnableKrIen Enumeration

IRD

Adp5520TypeInterruptEnableKrIen Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableKrIen
Public Enumeration TypeInterruptEnableKrIen
public enum class TypeInterruptEnableKrIen
type TypeInterruptEnableKrIen
Members
Member name | Value | Description
KeyReleaseInterruptDisabled | 0 | Key Release Interrupt: Disabled
KeyReleaseInterruptEnabled | 1 | Key Release Interrupt: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeInterruptEnableOvpIen Enumeration

IRD

Adp5520TypeInterruptEnableOvpIen Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableOvpIen
Public Enumeration TypeInterruptEnableOvpIen
public enum class TypeInterruptEnableOvpIen
type TypeInterruptEnableOvpIen
Members
Member name | Value | Description
OVPInterruptDisabled | 0 | OVP Interrupt: Disabled
OVPInterruptEnabled | 1 | OVP Interrupt: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeKeyStat Enumeration

IRD

Adp5520TypeKeyStat Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeKeyStat
Public Enumeration TypeKeyStat
public enum class TypeKeyStat
type TypeKeyStat
Members
Member name | Value | Description
KeyReleased | 0 | Key: Released
KeyPressed | 1 | Key: Pressed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeKpIntStat Enumeration

IRD

Adp5520TypeKpIntStat Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeKpIntStat
Public Enumeration TypeKpIntStat
public enum class TypeKpIntStat
type TypeKpIntStat
Members
Member name | Value | Description
InterruptNotDetected | 0 | Interrupt: Not Detected
InterruptDetected | 1 | Interrupt: Detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeKrIntStat Enumeration

IRD

Adp5520TypeKrIntStat Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeKrIntStat
Public Enumeration TypeKrIntStat
public enum class TypeKrIntStat
type TypeKrIntStat
Members
Member name | Value | Description
InterruptNotDetected | 0 | Interrupt: Not Detected
InterruptDetected | 1 | Interrupt: Detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeLedControlC3Mode Enumeration

IRD

Adp5520TypeLedControlC3Mode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedControlC3Mode
Public Enumeration TypeLedControlC3Mode
public enum class TypeLedControlC3Mode
type TypeLedControlC3Mode
Members
Member name | Value | Description
C3CurrentSinkLED2 | 0 | C3: Current Sink (LED2)
C3GPIOD7 | 1 | C3: GPIO (D7)
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeLedControlLed1En Enumeration

IRD

Adp5520TypeLedControlLed1En Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedControlLed1En
Public Enumeration TypeLedControlLed1En
public enum class TypeLedControlLed1En
type TypeLedControlLed1En
Members
Member name | Value | Description
LED1Disabled | 0 | LED1: Disabled
LED1Enabled | 1 | LED1: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeLedControlLed2En Enumeration

IRD

Adp5520TypeLedControlLed2En Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedControlLed2En
Public Enumeration TypeLedControlLed2En
public enum class TypeLedControlLed2En
type TypeLedControlLed2En
Members
Member name | Value | Description
LED2Disabled | 0 | LED2: Disabled
LED2Enabled | 1 | LED2: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeLedControlLed3En Enumeration

IRD

Adp5520TypeLedControlLed3En Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedControlLed3En
Public Enumeration TypeLedControlLed3En
public enum class TypeLedControlLed3En
type TypeLedControlLed3En
Members
Member name | Value | Description
LED3Disabled | 0 | LED3: Disabled
LED3Enabled | 1 | LED3: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeLedControlLedLaw Enumeration

IRD

Adp5520TypeLedControlLedLaw Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedControlLedLaw
Public Enumeration TypeLedControlLedLaw
public enum class TypeLedControlLedLaw
type TypeLedControlLedLaw
Members
Member name | Value | Description
Linear | 0 | Linear
Square | 1 | Square
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeLedControlR3Mode Enumeration

IRD

Adp5520TypeLedControlR3Mode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedControlR3Mode
Public Enumeration TypeLedControlR3Mode
public enum class TypeLedControlR3Mode
type TypeLedControlR3Mode
Members
Member name | Value | Description
R3CurrentSinkLED3 | 0 | R3: Current Sink (LED3)
R3GPIOD3 | 1 | R3: GPIO (D3)
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeLedFade Enumeration

IRD

Adp5520TypeLedFade Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedFade
Public Enumeration TypeLedFade
public enum class TypeLedFade
type TypeLedFade
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_03S | 1 | 0.3 s
Value_06S | 2 | 0.6 s
Value_09S | 3 | 0.9 s
Value_12S | 4 | 1.2 s
Value_15S | 5 | 1.5 s
Value_18S | 6 | 1.8 s
Value_21S | 7 | 2.1 s
Value_24S | 8 | 2.4 s
Value_27S | 9 | 2.7 s
Value_30S | 10 | 3.0 s
Value_35S | 11 | 3.5 s
Value_40S | 12 | 4.0 s
Value_45S | 13 | 4.5 s
Value_50S | 14 | 5.0 s
Value_55S | 15 | 5.5 s
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeLedTimeLedOfft Enumeration

IRD

Adp5520TypeLedTimeLedOfft Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedTimeLedOfft
Public Enumeration TypeLedTimeLedOfft
public enum class TypeLedTimeLedOfft
type TypeLedTimeLedOfft
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_06S | 1 | 0.6 s
Value_08S | 2 | 0.8 s
Value_12S | 3 | 1.2 s
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeLedTimeLedOnt Enumeration

IRD

Adp5520TypeLedTimeLedOnt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedTimeLedOnt
Public Enumeration TypeLedTimeLedOnt
public enum class TypeLedTimeLedOnt
type TypeLedTimeLedOnt
Members
Member name | Value | Description
Value_02S | 0 | 0.2 s
Value_06S | 1 | 0.6 s
Value_08S | 2 | 0.8 s
Value_12S | 3 | 1.2 s
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeModeStatusBlEn Enumeration

IRD

Adp5520TypeModeStatusBlEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeStatusBlEn
Public Enumeration TypeModeStatusBlEn
public enum class TypeModeStatusBlEn
type TypeModeStatusBlEn
Members
Member name | Value | Description
BacklightDriverDisabled | 0 | Backlight Driver: Disabled
BacklightDriverEnabled | 1 | Backlight Driver: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeModeStatusCmprInt Enumeration

IRD

Adp5520TypeModeStatusCmprInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeStatusCmprInt
Public Enumeration TypeModeStatusCmprInt
public enum class TypeModeStatusCmprInt
type TypeModeStatusCmprInt
Members
Member name | Value | Description
ComparatorNotTriggered | 0 | Comparator: Not Triggered
ComparatorTriggered | 1 | Comparator: Triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeModeStatusDimEn Enumeration

IRD

Adp5520TypeModeStatusDimEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeStatusDimEn
Public Enumeration TypeModeStatusDimEn
public enum class TypeModeStatusDimEn
type TypeModeStatusDimEn
Members
Member name | Value | Description
DimModeDisabled | 0 | Dim Mode: Disabled
DimModeEnabled | 1 | Dim Mode: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeModeStatusGpiInt Enumeration

IRD

Adp5520TypeModeStatusGpiInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeStatusGpiInt
Public Enumeration TypeModeStatusGpiInt
public enum class TypeModeStatusGpiInt
type TypeModeStatusGpiInt
Members
Member name | Value | Description
GPIOInputInterruptNotDetected | 0 | GPIO Input Interrupt: Not Detected
GPIOInputInterruptDetected | 1 | GPIO Input Interrupt: Detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeModeStatusKpInt Enumeration

IRD

Adp5520TypeModeStatusKpInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeStatusKpInt
Public Enumeration TypeModeStatusKpInt
public enum class TypeModeStatusKpInt
type TypeModeStatusKpInt
Members
Member name | Value | Description
KeyPressInterruptNotPresent | 0 | Key Press Interrupt: Not Present
KeyPressInterruptPresent | 1 | Key Press Interrupt: Present
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeModeStatusKrInt Enumeration

IRD

Adp5520TypeModeStatusKrInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeStatusKrInt
Public Enumeration TypeModeStatusKrInt
public enum class TypeModeStatusKrInt
type TypeModeStatusKrInt
Members
Member name | Value | Description
KeyReleaseInterruptNotPresent | 0 | Key Release Interrupt: Not Present
KeyReleaseInterruptPresent | 1 | Key Release Interrupt: Present
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeModeStatusNstnby Enumeration

IRD

Adp5520TypeModeStatusNstnby Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeStatusNstnby
Public Enumeration TypeModeStatusNstnby
public enum class TypeModeStatusNstnby
type TypeModeStatusNstnby
Members
Member name | Value | Description
StandbyMode | 0 | Standby Mode
OperatingMode | 1 | Operating Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5520.TypeModeStatusOvpInt Enumeration

IRD

Adp5520TypeModeStatusOvpInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeStatusOvpInt
Public Enumeration TypeModeStatusOvpInt
public enum class TypeModeStatusOvpInt
type TypeModeStatusOvpInt
Members
Member name | Value | Description
OVPNotDetected | 0 | OVP: Not Detected
OVPDetected | 1 | OVP: Detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585 Class

Analog Devices: ADP 5585
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdp5585

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adp5585
Public Class Adp5585
public ref class Adp5585
type Adp5585 =  class end

The Adp5585 type exposes the following members.

Constructors
 | Name | Description
Public method | Adp5585 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DEBOUNCEDISAGPI1DEBDIS | DEBOUNCE_DIS_A: GPI_1_DEB_DIS
Public property | DEBOUNCEDISAGPI2DEBDIS | DEBOUNCE_DIS_A: GPI_2_DEB_DIS
Public property | DEBOUNCEDISAGPI3DEBDIS | DEBOUNCE_DIS_A: GPI_3_DEB_DIS
Public property | DEBOUNCEDISAGPI4DEBDIS | DEBOUNCE_DIS_A: GPI_4_DEB_DIS
Public property | DEBOUNCEDISAGPI5DEBDIS | DEBOUNCE_DIS_A: GPI_5_DEB_DIS
Public property | DEBOUNCEDISAGPI6DEBDIS | DEBOUNCE_DIS_A: GPI_6_DEB_DIS
Public property | DEBOUNCEDISBGPI10DEBDIS | DEBOUNCE_DIS_B: GPI_10_DEB_DIS
Public property | DEBOUNCEDISBGPI11DEBDIS | DEBOUNCE_DIS_B: GPI_11_DEB_DIS
Public property | DEBOUNCEDISBGPI7DEBDIS | DEBOUNCE_DIS_B: GPI_7_DEB_DIS
Public property | DEBOUNCEDISBGPI8DEBDIS | DEBOUNCE_DIS_B: GPI_8_DEB_DIS
Public property | DEBOUNCEDISBGPI9DEBDIS | DEBOUNCE_DIS_B: GPI_9_DEB_DIS
Public property | FIFO10EVENT10IDENTIFIER | FIFO_10: EVENT10_IDENTIFIER
Public property | FIFO10EVENT10STATE | FIFO_10: EVENT10_STATE
Public property | FIFO11EVENT11IDENTIFIER | FIFO_11: EVENT11_IDENTIFIER
Public property | FIFO11EVENT11STATE | FIFO_11: EVENT11_STATE
Public property | FIFO12EVENT12IDENTIFIER | FIFO_12: EVENT12_IDENTIFIER
Public property | FIFO12EVENT12STATE | FIFO_12: EVENT12_STATE
Public property | FIFO13EVENT13IDENTIFIER | FIFO_13: EVENT13_IDENTIFIER
Public property | FIFO13EVENT13STATE | FIFO_13: EVENT13_STATE
Public property | FIFO14EVENT14IDENTIFIER | FIFO_14: EVENT14_IDENTIFIER
Public property | FIFO14EVENT14STATE | FIFO_14: EVENT14_STATE
Public property | FIFO15EVENT15IDENTIFIER | FIFO_15: EVENT15_IDENTIFIER
Public property | FIFO15EVENT15STATE | FIFO_15: EVENT15_STATE
Public property | FIFO16EVENT16IDENTIFIER | FIFO_16: EVENT16_IDENTIFIER
Public property | FIFO16EVENT16STATE | FIFO_16: EVENT16_STATE
Public property | FIFO1EVENT1IDENTIFIER | FIFO_1: EVENT1_IDENTIFIER
Public property | FIFO1EVENT1STATE | FIFO_1: EVENT1_STATE
Public property | FIFO2EVENT2IDENTIFIER | FIFO_2: EVENT2_IDENTIFIER
Public property | FIFO2EVENT2STATE | FIFO_2: EVENT2_STATE
Public property | FIFO3EVENT3IDENTIFIER | FIFO_3: EVENT3_IDENTIFIER
Public property | FIFO3EVENT3STATE | FIFO_3: EVENT3_STATE
Public property | FIFO4EVENT4IDENTIFIER | FIFO_4: EVENT4_IDENTIFIER
Public property | FIFO4EVENT4STATE | FIFO_4: EVENT4_STATE
Public property | FIFO5EVENT5IDENTIFIER | FIFO_5: EVENT5_IDENTIFIER
Public property | FIFO5EVENT5STATE | FIFO_5: EVENT5_STATE
Public property | FIFO6EVENT6IDENTIFIER | FIFO_6: EVENT6_IDENTIFIER
Public property | FIFO6EVENT6STATE | FIFO_6: EVENT6_STATE
Public property | FIFO7EVENT7IDENTIFIER | FIFO_7: EVENT7_IDENTIFIER
Public property | FIFO7EVENT7STATE | FIFO_7: EVENT7_STATE
Public property | FIFO8EVENT8IDENTIFIER | FIFO_8: EVENT8_IDENTIFIER
Public property | FIFO8EVENT8STATE | FIFO_8: EVENT8_STATE
Public property | FIFO9EVENT9IDENTIFIER | FIFO_9: EVENT9_IDENTIFIER
Public property | FIFO9EVENT9STATE | FIFO_9: EVENT9_STATE
Public property | GENERALCFGBINTCFG | GENERAL_CFG_B: INT_CFG
Public property | GENERALCFGBOSCEN | GENERAL_CFG_B: OSC_EN
Public property | GENERALCFGBOSCFREQ | GENERAL_CFG_B: OSC_FREQ
Public property | GENERALCFGBRSTCFG | GENERAL_CFG_B: RST_CFG
Public property | GPIEVENTENAGPI1EVENTEN | GPI_EVENT_EN_A: GPI_1_EVENT_EN
Public property | GPIEVENTENAGPI2EVENTEN | GPI_EVENT_EN_A: GPI_2_EVENT_EN
Public property | GPIEVENTENAGPI3EVENTEN | GPI_EVENT_EN_A: GPI_3_EVENT_EN
Public property | GPIEVENTENAGPI4EVENTEN | GPI_EVENT_EN_A: GPI_4_EVENT_EN
Public property | GPIEVENTENAGPI5EVENTEN | GPI_EVENT_EN_A: GPI_5_EVENT_EN
Public property | GPIEVENTENAGPI6EVENTEN | GPI_EVENT_EN_A: GPI_6_EVENT_EN
Public property | GPIEVENTENBGPI10EVENTEN | GPI_EVENT_EN_B: GPI_10_EVENT_EN
Public property | GPIEVENTENBGPI11EVENTEN | GPI_EVENT_EN_B: GPI_11_EVENT_EN
Public property | GPIEVENTENBGPI7EVENTEN | GPI_EVENT_EN_B: GPI_7_EVENT_EN
Public property | GPIEVENTENBGPI8EVENTEN | GPI_EVENT_EN_B: GPI_8_EVENT_EN
Public property | GPIEVENTENBGPI9EVENTEN | GPI_EVENT_EN_B: GPI_9_EVENT_EN
Public property | GPIINTERRUPTENAGPI1INTEN | GPI_INTERRUPT_EN_A: GPI_1_INT_EN
Public property | GPIINTERRUPTENAGPI2INTEN | GPI_INTERRUPT_EN_A: GPI_2_INT_EN
Public property | GPIINTERRUPTENAGPI3INTEN | GPI_INTERRUPT_EN_A: GPI_3_INT_EN
Public property | GPIINTERRUPTENAGPI4INTEN | GPI_INTERRUPT_EN_A: GPI_4_INT_EN
Public property | GPIINTERRUPTENAGPI5INTEN | GPI_INTERRUPT_EN_A: GPI_5_INT_EN
Public property | GPIINTERRUPTENAGPI6INTEN | GPI_INTERRUPT_EN_A: GPI_6_INT_EN
Public property | GPIINTERRUPTENBGPI10INTEN | GPI_INTERRUPT_EN_B: GPI_10_INT_EN
Public property | GPIINTERRUPTENBGPI11INTEN | GPI_INTERRUPT_EN_B: GPI_11_INT_EN
Public property | GPIINTERRUPTENBGPI7INTEN | GPI_INTERRUPT_EN_B: GPI_7_INT_EN
Public property | GPIINTERRUPTENBGPI8INTEN | GPI_INTERRUPT_EN_B: GPI_8_INT_EN
Public property | GPIINTERRUPTENBGPI9INTEN | GPI_INTERRUPT_EN_B: GPI_9_INT_EN
Public property | GPIINTLEVELAGPI1INTLEVEL | GPI_INT_LEVEL_A: GPI_1_INT_LEVEL
Public property | GPIINTLEVELAGPI2INTLEVEL | GPI_INT_LEVEL_A: GPI_2_INT_LEVEL
Public property | GPIINTLEVELAGPI3INTLEVEL | GPI_INT_LEVEL_A: GPI_3_INT_LEVEL
Public property | GPIINTLEVELAGPI4INTLEVEL | GPI_INT_LEVEL_A: GPI_4_INT_LEVEL
Public property | GPIINTLEVELAGPI5INTLEVEL | GPI_INT_LEVEL_A: GPI_5_INT_LEVEL
Public property | GPIINTLEVELAGPI6INTLEVEL | GPI_INT_LEVEL_A: GPI_6_INT_LEVEL
Public property | GPIINTLEVELBGPI10INTLEVEL | GPI_INT_LEVEL_B: GPI_10_INT_LEVEL
Public property | GPIINTLEVELBGPI11INTLEVEL | GPI_INT_LEVEL_B: GPI_11_INT_LEVEL
Public property | GPIINTLEVELBGPI7INTLEVEL | GPI_INT_LEVEL_B: GPI_7_INT_LEVEL
Public property | GPIINTLEVELBGPI8INTLEVEL | GPI_INT_LEVEL_B: GPI_8_INT_LEVEL
Public property | GPIINTLEVELBGPI9INTLEVEL | GPI_INT_LEVEL_B: GPI_9_INT_LEVEL
Public property | GPIINTSTATAGPI1INT | GPI_INT_STAT_A: GPI_1_INT
Public property | GPIINTSTATAGPI2INT | GPI_INT_STAT_A: GPI_2_INT
Public property | GPIINTSTATAGPI3INT | GPI_INT_STAT_A: GPI_3_INT
Public property | GPIINTSTATAGPI4INT | GPI_INT_STAT_A: GPI_4_INT
Public property | GPIINTSTATAGPI5INT | GPI_INT_STAT_A: GPI_5_INT
Public property | GPIINTSTATAGPI6INT | GPI_INT_STAT_A: GPI_6_INT
Public property | GPIINTSTATBGPI10INT | GPI_INT_STAT_B: GPI_10_INT
Public property | GPIINTSTATBGPI11INT | GPI_INT_STAT_B: GPI_11_INT
Public property | GPIINTSTATBGPI7INT | GPI_INT_STAT_B: GPI_7_INT
Public property | GPIINTSTATBGPI8INT | GPI_INT_STAT_B: GPI_8_INT
Public property | GPIINTSTATBGPI9INT | GPI_INT_STAT_B: GPI_9_INT
Public property | GPIODIRECTIONAGPIO1DIR | GPIO_DIRECTION_A: GPIO_1_DIR
Public property | GPIODIRECTIONAGPIO2DIR | GPIO_DIRECTION_A: GPIO_2_DIR
Public property | GPIODIRECTIONAGPIO3DIR | GPIO_DIRECTION_A: GPIO_3_DIR
Public property | GPIODIRECTIONAGPIO4DIR | GPIO_DIRECTION_A: GPIO_4_DIR
Public property | GPIODIRECTIONAGPIO5DIR | GPIO_DIRECTION_A: GPIO_5_DIR
Public property | GPIODIRECTIONAGPIO6DIR | GPIO_DIRECTION_A: GPIO_6_DIR
Public property | GPIODIRECTIONBGPIO10DIR | GPIO_DIRECTION_B: GPIO_10_DIR
Public property | GPIODIRECTIONBGPIO11DIR | GPIO_DIRECTION_B: GPIO_11_DIR
Public property | GPIODIRECTIONBGPIO7DIR | GPIO_DIRECTION_B: GPIO_7_DIR
Public property | GPIODIRECTIONBGPIO8DIR | GPIO_DIRECTION_B: GPIO_8_DIR
Public property | GPIODIRECTIONBGPIO9DIR | GPIO_DIRECTION_B: GPIO_9_DIR
Public property | GPISTATUSAGPI1STAT | GPI_STATUS_A: GPI_1_STAT
Public property | GPISTATUSAGPI2STAT | GPI_STATUS_A: GPI_2_STAT
Public property | GPISTATUSAGPI3STAT | GPI_STATUS_A: GPI_3_STAT
Public property | GPISTATUSAGPI4STAT | GPI_STATUS_A: GPI_4_STAT
Public property | GPISTATUSAGPI5STAT | GPI_STATUS_A: GPI_5_STAT
Public property | GPISTATUSAGPI6STAT | GPI_STATUS_A: GPI_6_STAT
Public property | GPISTATUSBGPI10STAT | GPI_STATUS_B: GPI_10_STAT
Public property | GPISTATUSBGPI11STAT | GPI_STATUS_B: GPI_11_STAT
Public property | GPISTATUSBGPI7STAT | GPI_STATUS_B: GPI_7_STAT
Public property | GPISTATUSBGPI8STAT | GPI_STATUS_B: GPI_8_STAT
Public property | GPISTATUSBGPI9STAT | GPI_STATUS_B: GPI_9_STAT
Public property | GPODATAOUTAGPO1DATA | GPO_DATA_OUT_A: GPO_1_DATA
Public property | GPODATAOUTAGPO2DATA | GPO_DATA_OUT_A: GPO_2_DATA
Public property | GPODATAOUTAGPO3DATA | GPO_DATA_OUT_A: GPO_3_DATA
Public property | GPODATAOUTAGPO4DATA | GPO_DATA_OUT_A: GPO_4_DATA
Public property | GPODATAOUTAGPO5DATA | GPO_DATA_OUT_A: GPO_5_DATA
Public property | GPODATAOUTAGPO6DATA | GPO_DATA_OUT_A: GPO_6_DATA
Public property | GPODATAOUTBGPO10DATA | GPO_DATA_OUT_B: GPO_10_DATA
Public property | GPODATAOUTBGPO11DATA | GPO_DATA_OUT_B: GPO_11_DATA
Public property | GPODATAOUTBGPO7DATA | GPO_DATA_OUT_B: GPO_7_DATA
Public property | GPODATAOUTBGPO8DATA | GPO_DATA_OUT_B: GPO_8_DATA
Public property | GPODATAOUTBGPO9DATA | GPO_DATA_OUT_B: GPO_9_DATA
Public property | GPOOUTMODEAGPO1OUTMODE | GPO_OUT_MODE_A: GPO_1_OUT_MODE
Public property | GPOOUTMODEAGPO2OUTMODE | GPO_OUT_MODE_A: GPO_2_OUT_MODE
Public property | GPOOUTMODEAGPO3OUTMODE | GPO_OUT_MODE_A: GPO_3_OUT_MODE
Public property | GPOOUTMODEAGPO4OUTMODE | GPO_OUT_MODE_A: GPO_4_OUT_MODE
Public property | GPOOUTMODEAGPO5OUTMODE | GPO_OUT_MODE_A: GPO_5_OUT_MODE
Public property | GPOOUTMODEAGPO6OUTMODE | GPO_OUT_MODE_A: GPO_6_OUT_MODE
Public property | GPOOUTMODEBGPO10OUTMODE | GPO_OUT_MODE_B: GPO_10_OUT_MODE
Public property | GPOOUTMODEBGPO11OUTMODE | GPO_OUT_MODE_B: GPO_11_OUT_MODE
Public property | GPOOUTMODEBGPO7OUTMODE | GPO_OUT_MODE_B: GPO_7_OUT_MODE
Public property | GPOOUTMODEBGPO8OUTMODE | GPO_OUT_MODE_B: GPO_8_OUT_MODE
Public property | GPOOUTMODEBGPO9OUTMODE | GPO_OUT_MODE_B: GPO_9_OUT_MODE
Public property | IDMANID | ID: MAN_ID
Public property | IDREVID | ID: REV_ID
Public property | INTENEVENTIEN | INT_EN: EVENT_IEN
Public property | INTENGPIIEN | INT_EN: GPI_IEN
Public property | INTENLOGICEN | INT_EN: LOGIC_EN
Public property | INTENOVRFLOWIEN | INT_EN: OVRFLOW_IEN
Public property | INTSTATUSEVENTINT | INT_STATUS: EVENT_INT
Public property | INTSTATUSGPIINT | INT_STATUS: GPI_INT
Public property | INTSTATUSLOGICINT | INT_STATUS: LOGIC_INT
Public property | INTSTATUSOVRFLOWINT | INT_STATUS: OVRFLOW_INT
Public property | LOGICCFGLAINV | LOGIC_CFG: LA_INV
Public property | LOGICCFGLBINV | LOGIC_CFG: LB_INV
Public property | LOGICCFGLCINV | LOGIC_CFG: LC_INV
Public property | LOGICCFGLOGICSEL | LOGIC_CFG: LOGIC_SEL
Public property | LOGICCFGLYINV | LOGIC_CFG: LY_INV
Public property | LOGICFFCFGFFCLR | LOGIC_FF_CFG: FF_CLR
Public property | LOGICFFCFGFFSET | LOGIC_FF_CFG: FF_SET
Public property | LOGICINTEVENTENLOGICEVENTEN | LOGIC_INT_EVENT_EN: LOGIC_EVENT_EN
Public property | LOGICINTEVENTENLOGICINTLEVEL | LOGIC_INT_EVENT_EN: LOGIC_INT_LEVEL
Public property | LOGICINTEVENTENLYDBNCDIS | LOGIC_INT_EVENT_EN: LY_DBNC_DIS
Public property | PINCONFIGAR0CONFIG | PIN_CONFIG_A: R0_CONFIG
Public property | PINCONFIGAR1CONFIG | PIN_CONFIG_A: R1_CONFIG
Public property | PINCONFIGAR2CONFIG | PIN_CONFIG_A: R2_CONFIG
Public property | PINCONFIGAR3CONFIG | PIN_CONFIG_A: R3_CONFIG
Public property | PINCONFIGAR4CONFIG | PIN_CONFIG_A: R4_CONFIG
Public property | PINCONFIGAR5CONFIG | PIN_CONFIG_A: R5_CONFIG
Public property | PINCONFIGBC0CONFIG | PIN_CONFIG_B: C0_CONFIG
Public property | PINCONFIGBC1CONFIG | PIN_CONFIG_B: C1_CONFIG
Public property | PINCONFIGBC2CONFIG | PIN_CONFIG_B: C2_CONFIG
Public property | PINCONFIGBC3CONFIG | PIN_CONFIG_B: C3_CONFIG
Public property | PINCONFIGBC4CONFIG | PIN_CONFIG_B: C4_CONFIG
Public property | PINCONFIGCC4EXTENDCFG | PIN_CONFIG_C: C4_EXTEND_CFG
Public property | PINCONFIGCPULLSELECT | PIN_CONFIG_C: PULL_SELECT
Public property | PINCONFIGCR0EXTENDCFG | PIN_CONFIG_C: R0_EXTEND_CFG
Public property | PINCONFIGCR3EXTENDCFG | PIN_CONFIG_C: R3_EXTEND_CFG
Public property | PINCONFIGCR4EXTENDCFG | PIN_CONFIG_C: R4_EXTEND_CFG
Public property | POLLTIMECFGKEYPOLLTIME | POLL_TIME_CFG: KEY_POLL_TIME
Public property | PWMCFGPWMEN | PWM_CFG: PWM_EN
Public property | PWMCFGPWMINAND | PWM_CFG: PWM_IN_AND
Public property | PWMCFGPWMMODE | PWM_CFG: PWM_MODE
Public property | PWMOFFT | PWM_OFFT (unit: µs)
Public property | PWMONT | PWM_ONT (unit: µs)
Public property | RESET1EVENTARESET1EVENTA | RESET1_EVENT_A: RESET1_EVENT_A
Public property | RESET1EVENTARESET1EVENTALEVEL | RESET1_EVENT_A: RESET1_EVENT_A_LEVEL
Public property | RESET1EVENTBRESET1EVENTB | RESET1_EVENT_B: RESET1_EVENT_B
Public property | RESET1EVENTBRESET1EVENTBLEVEL | RESET1_EVENT_B: RESET1_EVENT_B_LEVEL
Public property | RESET1EVENTCRESET1EVENTC | RESET1_EVENT_C: RESET1_EVENT_C
Public property | RESET1EVENTCRESET1EVENTCLEVEL | RESET1_EVENT_C: RESET1_EVENT_C_LEVEL
Public property | RESET2EVENTARESET2EVENTA | RESET2_EVENT_A: RESET2_EVENT_A
Public property | RESET2EVENTARESET2EVENTALEVEL | RESET2_EVENT_A: RESET2_EVENT_A_LEVEL
Public property | RESET2EVENTBRESET2EVENTB | RESET2_EVENT_B: RESET2_EVENT_B
Public property | RESET2EVENTBRESET2EVENTBLEVEL | RESET2_EVENT_B: RESET2_EVENT_B_LEVEL
Public property | RESETCFGRESET1POL | RESET_CFG: RESET1_POL
Public property | RESETCFGRESET2POL | RESET_CFG: RESET2_POL
Public property | RESETCFGRESETPULSEWIDTH | RESET_CFG: RESET_PULSE_WIDTH
Public property | RESETCFGRESETTRIGGERTIME | RESET_CFG: RESET_TRIGGER_TIME (unit: s)
Public property | RESETCFGRSTPASSTHRUEN | RESET_CFG: RST_PASSTHRU_EN
Public property | RPULLCONFIGAR0PULLCFG | RPULL_CONFIG_A: R0_PULL_CFG
Public property | RPULLCONFIGAR1PULLCFG | RPULL_CONFIG_A: R1_PULL_CFG
Public property | RPULLCONFIGAR2PULLCFG | RPULL_CONFIG_A: R2_PULL_CFG
Public property | RPULLCONFIGAR3PULLCFG | RPULL_CONFIG_A: R3_PULL_CFG
Public property | RPULLCONFIGBR4PULLCFG | RPULL_CONFIG_B: R4_PULL_CFG
Public property | RPULLCONFIGBR5PULLCFG | RPULL_CONFIG_B: R5_PULL_CFG
Public property | RPULLCONFIGCC0PULLCFG | RPULL_CONFIG_C: C0_PULL_CFG
Public property | RPULLCONFIGCC1PULLCFG | RPULL_CONFIG_C: C1_PULL_CFG
Public property | RPULLCONFIGCC2PULLCFG | RPULL_CONFIG_C: C2_PULL_CFG
Public property | RPULLCONFIGCC3PULLCFG | RPULL_CONFIG_C: C3_PULL_CFG
Public property | RPULLCONFIGDC4PULLCFG | RPULL_CONFIG_D: C4_PULL_CFG
Public property | STATUSEC | STATUS: EC
Public property | STATUSLOGICSTAT | STATUS: LOGIC_STAT
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Keypad Decoder and I/O Expansion
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adp5585(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adp5585

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585 Properties

The Adp5585 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DEBOUNCEDISAGPI1DEBDIS | DEBOUNCE_DIS_A: GPI_1_DEB_DIS
Public property | DEBOUNCEDISAGPI2DEBDIS | DEBOUNCE_DIS_A: GPI_2_DEB_DIS
Public property | DEBOUNCEDISAGPI3DEBDIS | DEBOUNCE_DIS_A: GPI_3_DEB_DIS
Public property | DEBOUNCEDISAGPI4DEBDIS | DEBOUNCE_DIS_A: GPI_4_DEB_DIS
Public property | DEBOUNCEDISAGPI5DEBDIS | DEBOUNCE_DIS_A: GPI_5_DEB_DIS
Public property | DEBOUNCEDISAGPI6DEBDIS | DEBOUNCE_DIS_A: GPI_6_DEB_DIS
Public property | DEBOUNCEDISBGPI10DEBDIS | DEBOUNCE_DIS_B: GPI_10_DEB_DIS
Public property | DEBOUNCEDISBGPI11DEBDIS | DEBOUNCE_DIS_B: GPI_11_DEB_DIS
Public property | DEBOUNCEDISBGPI7DEBDIS | DEBOUNCE_DIS_B: GPI_7_DEB_DIS
Public property | DEBOUNCEDISBGPI8DEBDIS | DEBOUNCE_DIS_B: GPI_8_DEB_DIS
Public property | DEBOUNCEDISBGPI9DEBDIS | DEBOUNCE_DIS_B: GPI_9_DEB_DIS
Public property | FIFO10EVENT10IDENTIFIER | FIFO_10: EVENT10_IDENTIFIER
Public property | FIFO10EVENT10STATE | FIFO_10: EVENT10_STATE
Public property | FIFO11EVENT11IDENTIFIER | FIFO_11: EVENT11_IDENTIFIER
Public property | FIFO11EVENT11STATE | FIFO_11: EVENT11_STATE
Public property | FIFO12EVENT12IDENTIFIER | FIFO_12: EVENT12_IDENTIFIER
Public property | FIFO12EVENT12STATE | FIFO_12: EVENT12_STATE
Public property | FIFO13EVENT13IDENTIFIER | FIFO_13: EVENT13_IDENTIFIER
Public property | FIFO13EVENT13STATE | FIFO_13: EVENT13_STATE
Public property | FIFO14EVENT14IDENTIFIER | FIFO_14: EVENT14_IDENTIFIER
Public property | FIFO14EVENT14STATE | FIFO_14: EVENT14_STATE
Public property | FIFO15EVENT15IDENTIFIER | FIFO_15: EVENT15_IDENTIFIER
Public property | FIFO15EVENT15STATE | FIFO_15: EVENT15_STATE
Public property | FIFO16EVENT16IDENTIFIER | FIFO_16: EVENT16_IDENTIFIER
Public property | FIFO16EVENT16STATE | FIFO_16: EVENT16_STATE
Public property | FIFO1EVENT1IDENTIFIER | FIFO_1: EVENT1_IDENTIFIER
Public property | FIFO1EVENT1STATE | FIFO_1: EVENT1_STATE
Public property | FIFO2EVENT2IDENTIFIER | FIFO_2: EVENT2_IDENTIFIER
Public property | FIFO2EVENT2STATE | FIFO_2: EVENT2_STATE
Public property | FIFO3EVENT3IDENTIFIER | FIFO_3: EVENT3_IDENTIFIER
Public property | FIFO3EVENT3STATE | FIFO_3: EVENT3_STATE
Public property | FIFO4EVENT4IDENTIFIER | FIFO_4: EVENT4_IDENTIFIER
Public property | FIFO4EVENT4STATE | FIFO_4: EVENT4_STATE
Public property | FIFO5EVENT5IDENTIFIER | FIFO_5: EVENT5_IDENTIFIER
Public property | FIFO5EVENT5STATE | FIFO_5: EVENT5_STATE
Public property | FIFO6EVENT6IDENTIFIER | FIFO_6: EVENT6_IDENTIFIER
Public property | FIFO6EVENT6STATE | FIFO_6: EVENT6_STATE
Public property | FIFO7EVENT7IDENTIFIER | FIFO_7: EVENT7_IDENTIFIER
Public property | FIFO7EVENT7STATE | FIFO_7: EVENT7_STATE
Public property | FIFO8EVENT8IDENTIFIER | FIFO_8: EVENT8_IDENTIFIER
Public property | FIFO8EVENT8STATE | FIFO_8: EVENT8_STATE
Public property | FIFO9EVENT9IDENTIFIER | FIFO_9: EVENT9_IDENTIFIER
Public property | FIFO9EVENT9STATE | FIFO_9: EVENT9_STATE
Public property | GENERALCFGBINTCFG | GENERAL_CFG_B: INT_CFG
Public property | GENERALCFGBOSCEN | GENERAL_CFG_B: OSC_EN
Public property | GENERALCFGBOSCFREQ | GENERAL_CFG_B: OSC_FREQ
Public property | GENERALCFGBRSTCFG | GENERAL_CFG_B: RST_CFG
Public property | GPIEVENTENAGPI1EVENTEN | GPI_EVENT_EN_A: GPI_1_EVENT_EN
Public property | GPIEVENTENAGPI2EVENTEN | GPI_EVENT_EN_A: GPI_2_EVENT_EN
Public property | GPIEVENTENAGPI3EVENTEN | GPI_EVENT_EN_A: GPI_3_EVENT_EN
Public property | GPIEVENTENAGPI4EVENTEN | GPI_EVENT_EN_A: GPI_4_EVENT_EN
Public property | GPIEVENTENAGPI5EVENTEN | GPI_EVENT_EN_A: GPI_5_EVENT_EN
Public property | GPIEVENTENAGPI6EVENTEN | GPI_EVENT_EN_A: GPI_6_EVENT_EN
Public property | GPIEVENTENBGPI10EVENTEN | GPI_EVENT_EN_B: GPI_10_EVENT_EN
Public property | GPIEVENTENBGPI11EVENTEN | GPI_EVENT_EN_B: GPI_11_EVENT_EN
Public property | GPIEVENTENBGPI7EVENTEN | GPI_EVENT_EN_B: GPI_7_EVENT_EN
Public property | GPIEVENTENBGPI8EVENTEN | GPI_EVENT_EN_B: GPI_8_EVENT_EN
Public property | GPIEVENTENBGPI9EVENTEN | GPI_EVENT_EN_B: GPI_9_EVENT_EN
Public property | GPIINTERRUPTENAGPI1INTEN | GPI_INTERRUPT_EN_A: GPI_1_INT_EN
Public property | GPIINTERRUPTENAGPI2INTEN | GPI_INTERRUPT_EN_A: GPI_2_INT_EN
Public property | GPIINTERRUPTENAGPI3INTEN | GPI_INTERRUPT_EN_A: GPI_3_INT_EN
Public property | GPIINTERRUPTENAGPI4INTEN | GPI_INTERRUPT_EN_A: GPI_4_INT_EN
Public property | GPIINTERRUPTENAGPI5INTEN | GPI_INTERRUPT_EN_A: GPI_5_INT_EN
Public property | GPIINTERRUPTENAGPI6INTEN | GPI_INTERRUPT_EN_A: GPI_6_INT_EN
Public property | GPIINTERRUPTENBGPI10INTEN | GPI_INTERRUPT_EN_B: GPI_10_INT_EN
Public property | GPIINTERRUPTENBGPI11INTEN | GPI_INTERRUPT_EN_B: GPI_11_INT_EN
Public property | GPIINTERRUPTENBGPI7INTEN | GPI_INTERRUPT_EN_B: GPI_7_INT_EN
Public property | GPIINTERRUPTENBGPI8INTEN | GPI_INTERRUPT_EN_B: GPI_8_INT_EN
Public property | GPIINTERRUPTENBGPI9INTEN | GPI_INTERRUPT_EN_B: GPI_9_INT_EN
Public property | GPIINTLEVELAGPI1INTLEVEL | GPI_INT_LEVEL_A: GPI_1_INT_LEVEL
Public property | GPIINTLEVELAGPI2INTLEVEL | GPI_INT_LEVEL_A: GPI_2_INT_LEVEL
Public property | GPIINTLEVELAGPI3INTLEVEL | GPI_INT_LEVEL_A: GPI_3_INT_LEVEL
Public property | GPIINTLEVELAGPI4INTLEVEL | GPI_INT_LEVEL_A: GPI_4_INT_LEVEL
Public property | GPIINTLEVELAGPI5INTLEVEL | GPI_INT_LEVEL_A: GPI_5_INT_LEVEL
Public property | GPIINTLEVELAGPI6INTLEVEL | GPI_INT_LEVEL_A: GPI_6_INT_LEVEL
Public property | GPIINTLEVELBGPI10INTLEVEL | GPI_INT_LEVEL_B: GPI_10_INT_LEVEL
Public property | GPIINTLEVELBGPI11INTLEVEL | GPI_INT_LEVEL_B: GPI_11_INT_LEVEL
Public property | GPIINTLEVELBGPI7INTLEVEL | GPI_INT_LEVEL_B: GPI_7_INT_LEVEL
Public property | GPIINTLEVELBGPI8INTLEVEL | GPI_INT_LEVEL_B: GPI_8_INT_LEVEL
Public property | GPIINTLEVELBGPI9INTLEVEL | GPI_INT_LEVEL_B: GPI_9_INT_LEVEL
Public property | GPIINTSTATAGPI1INT | GPI_INT_STAT_A: GPI_1_INT
Public property | GPIINTSTATAGPI2INT | GPI_INT_STAT_A: GPI_2_INT
Public property | GPIINTSTATAGPI3INT | GPI_INT_STAT_A: GPI_3_INT
Public property | GPIINTSTATAGPI4INT | GPI_INT_STAT_A: GPI_4_INT
Public property | GPIINTSTATAGPI5INT | GPI_INT_STAT_A: GPI_5_INT
Public property | GPIINTSTATAGPI6INT | GPI_INT_STAT_A: GPI_6_INT
Public property | GPIINTSTATBGPI10INT | GPI_INT_STAT_B: GPI_10_INT
Public property | GPIINTSTATBGPI11INT | GPI_INT_STAT_B: GPI_11_INT
Public property | GPIINTSTATBGPI7INT | GPI_INT_STAT_B: GPI_7_INT
Public property | GPIINTSTATBGPI8INT | GPI_INT_STAT_B: GPI_8_INT
Public property | GPIINTSTATBGPI9INT | GPI_INT_STAT_B: GPI_9_INT
Public property | GPIODIRECTIONAGPIO1DIR | GPIO_DIRECTION_A: GPIO_1_DIR
Public property | GPIODIRECTIONAGPIO2DIR | GPIO_DIRECTION_A: GPIO_2_DIR
Public property | GPIODIRECTIONAGPIO3DIR | GPIO_DIRECTION_A: GPIO_3_DIR
Public property | GPIODIRECTIONAGPIO4DIR | GPIO_DIRECTION_A: GPIO_4_DIR
Public property | GPIODIRECTIONAGPIO5DIR | GPIO_DIRECTION_A: GPIO_5_DIR
Public property | GPIODIRECTIONAGPIO6DIR | GPIO_DIRECTION_A: GPIO_6_DIR
Public property | GPIODIRECTIONBGPIO10DIR | GPIO_DIRECTION_B: GPIO_10_DIR
Public property | GPIODIRECTIONBGPIO11DIR | GPIO_DIRECTION_B: GPIO_11_DIR
Public property | GPIODIRECTIONBGPIO7DIR | GPIO_DIRECTION_B: GPIO_7_DIR
Public property | GPIODIRECTIONBGPIO8DIR | GPIO_DIRECTION_B: GPIO_8_DIR
Public property | GPIODIRECTIONBGPIO9DIR | GPIO_DIRECTION_B: GPIO_9_DIR
Public property | GPISTATUSAGPI1STAT | GPI_STATUS_A: GPI_1_STAT
Public property | GPISTATUSAGPI2STAT | GPI_STATUS_A: GPI_2_STAT
Public property | GPISTATUSAGPI3STAT | GPI_STATUS_A: GPI_3_STAT
Public property | GPISTATUSAGPI4STAT | GPI_STATUS_A: GPI_4_STAT
Public property | GPISTATUSAGPI5STAT | GPI_STATUS_A: GPI_5_STAT
Public property | GPISTATUSAGPI6STAT | GPI_STATUS_A: GPI_6_STAT
Public property | GPISTATUSBGPI10STAT | GPI_STATUS_B: GPI_10_STAT
Public property | GPISTATUSBGPI11STAT | GPI_STATUS_B: GPI_11_STAT
Public property | GPISTATUSBGPI7STAT | GPI_STATUS_B: GPI_7_STAT
Public property | GPISTATUSBGPI8STAT | GPI_STATUS_B: GPI_8_STAT
Public property | GPISTATUSBGPI9STAT | GPI_STATUS_B: GPI_9_STAT
Public property | GPODATAOUTAGPO1DATA | GPO_DATA_OUT_A: GPO_1_DATA
Public property | GPODATAOUTAGPO2DATA | GPO_DATA_OUT_A: GPO_2_DATA
Public property | GPODATAOUTAGPO3DATA | GPO_DATA_OUT_A: GPO_3_DATA
Public property | GPODATAOUTAGPO4DATA | GPO_DATA_OUT_A: GPO_4_DATA
Public property | GPODATAOUTAGPO5DATA | GPO_DATA_OUT_A: GPO_5_DATA
Public property | GPODATAOUTAGPO6DATA | GPO_DATA_OUT_A: GPO_6_DATA
Public property | GPODATAOUTBGPO10DATA | GPO_DATA_OUT_B: GPO_10_DATA
Public property | GPODATAOUTBGPO11DATA | GPO_DATA_OUT_B: GPO_11_DATA
Public property | GPODATAOUTBGPO7DATA | GPO_DATA_OUT_B: GPO_7_DATA
Public property | GPODATAOUTBGPO8DATA | GPO_DATA_OUT_B: GPO_8_DATA
Public property | GPODATAOUTBGPO9DATA | GPO_DATA_OUT_B: GPO_9_DATA
Public property | GPOOUTMODEAGPO1OUTMODE | GPO_OUT_MODE_A: GPO_1_OUT_MODE
Public property | GPOOUTMODEAGPO2OUTMODE | GPO_OUT_MODE_A: GPO_2_OUT_MODE
Public property | GPOOUTMODEAGPO3OUTMODE | GPO_OUT_MODE_A: GPO_3_OUT_MODE
Public property | GPOOUTMODEAGPO4OUTMODE | GPO_OUT_MODE_A: GPO_4_OUT_MODE
Public property | GPOOUTMODEAGPO5OUTMODE | GPO_OUT_MODE_A: GPO_5_OUT_MODE
Public property | GPOOUTMODEAGPO6OUTMODE | GPO_OUT_MODE_A: GPO_6_OUT_MODE
Public property | GPOOUTMODEBGPO10OUTMODE | GPO_OUT_MODE_B: GPO_10_OUT_MODE
Public property | GPOOUTMODEBGPO11OUTMODE | GPO_OUT_MODE_B: GPO_11_OUT_MODE
Public property | GPOOUTMODEBGPO7OUTMODE | GPO_OUT_MODE_B: GPO_7_OUT_MODE
Public property | GPOOUTMODEBGPO8OUTMODE | GPO_OUT_MODE_B: GPO_8_OUT_MODE
Public property | GPOOUTMODEBGPO9OUTMODE | GPO_OUT_MODE_B: GPO_9_OUT_MODE
Public property | IDMANID | ID: MAN_ID
Public property | IDREVID | ID: REV_ID
Public property | INTENEVENTIEN | INT_EN: EVENT_IEN
Public property | INTENGPIIEN | INT_EN: GPI_IEN
Public property | INTENLOGICEN | INT_EN: LOGIC_EN
Public property | INTENOVRFLOWIEN | INT_EN: OVRFLOW_IEN
Public property | INTSTATUSEVENTINT | INT_STATUS: EVENT_INT
Public property | INTSTATUSGPIINT | INT_STATUS: GPI_INT
Public property | INTSTATUSLOGICINT | INT_STATUS: LOGIC_INT
Public property | INTSTATUSOVRFLOWINT | INT_STATUS: OVRFLOW_INT
Public property | LOGICCFGLAINV | LOGIC_CFG: LA_INV
Public property | LOGICCFGLBINV | LOGIC_CFG: LB_INV
Public property | LOGICCFGLCINV | LOGIC_CFG: LC_INV
Public property | LOGICCFGLOGICSEL | LOGIC_CFG: LOGIC_SEL
Public property | LOGICCFGLYINV | LOGIC_CFG: LY_INV
Public property | LOGICFFCFGFFCLR | LOGIC_FF_CFG: FF_CLR
Public property | LOGICFFCFGFFSET | LOGIC_FF_CFG: FF_SET
Public property | LOGICINTEVENTENLOGICEVENTEN | LOGIC_INT_EVENT_EN: LOGIC_EVENT_EN
Public property | LOGICINTEVENTENLOGICINTLEVEL | LOGIC_INT_EVENT_EN: LOGIC_INT_LEVEL
Public property | LOGICINTEVENTENLYDBNCDIS | LOGIC_INT_EVENT_EN: LY_DBNC_DIS
Public property | PINCONFIGAR0CONFIG | PIN_CONFIG_A: R0_CONFIG
Public property | PINCONFIGAR1CONFIG | PIN_CONFIG_A: R1_CONFIG
Public property | PINCONFIGAR2CONFIG | PIN_CONFIG_A: R2_CONFIG
Public property | PINCONFIGAR3CONFIG | PIN_CONFIG_A: R3_CONFIG
Public property | PINCONFIGAR4CONFIG | PIN_CONFIG_A: R4_CONFIG
Public property | PINCONFIGAR5CONFIG | PIN_CONFIG_A: R5_CONFIG
Public property | PINCONFIGBC0CONFIG | PIN_CONFIG_B: C0_CONFIG
Public property | PINCONFIGBC1CONFIG | PIN_CONFIG_B: C1_CONFIG
Public property | PINCONFIGBC2CONFIG | PIN_CONFIG_B: C2_CONFIG
Public property | PINCONFIGBC3CONFIG | PIN_CONFIG_B: C3_CONFIG
Public property | PINCONFIGBC4CONFIG | PIN_CONFIG_B: C4_CONFIG
Public property | PINCONFIGCC4EXTENDCFG | PIN_CONFIG_C: C4_EXTEND_CFG
Public property | PINCONFIGCPULLSELECT | PIN_CONFIG_C: PULL_SELECT
Public property | PINCONFIGCR0EXTENDCFG | PIN_CONFIG_C: R0_EXTEND_CFG
Public property | PINCONFIGCR3EXTENDCFG | PIN_CONFIG_C: R3_EXTEND_CFG
Public property | PINCONFIGCR4EXTENDCFG | PIN_CONFIG_C: R4_EXTEND_CFG
Public property | POLLTIMECFGKEYPOLLTIME | POLL_TIME_CFG: KEY_POLL_TIME
Public property | PWMCFGPWMEN | PWM_CFG: PWM_EN
Public property | PWMCFGPWMINAND | PWM_CFG: PWM_IN_AND
Public property | PWMCFGPWMMODE | PWM_CFG: PWM_MODE
Public property | PWMOFFT | PWM_OFFT (unit: µs)
Public property | PWMONT | PWM_ONT (unit: µs)
Public property | RESET1EVENTARESET1EVENTA | RESET1_EVENT_A: RESET1_EVENT_A
Public property | RESET1EVENTARESET1EVENTALEVEL | RESET1_EVENT_A: RESET1_EVENT_A_LEVEL
Public property | RESET1EVENTBRESET1EVENTB | RESET1_EVENT_B: RESET1_EVENT_B
Public property | RESET1EVENTBRESET1EVENTBLEVEL | RESET1_EVENT_B: RESET1_EVENT_B_LEVEL
Public property | RESET1EVENTCRESET1EVENTC | RESET1_EVENT_C: RESET1_EVENT_C
Public property | RESET1EVENTCRESET1EVENTCLEVEL | RESET1_EVENT_C: RESET1_EVENT_C_LEVEL
Public property | RESET2EVENTARESET2EVENTA | RESET2_EVENT_A: RESET2_EVENT_A
Public property | RESET2EVENTARESET2EVENTALEVEL | RESET2_EVENT_A: RESET2_EVENT_A_LEVEL
Public property | RESET2EVENTBRESET2EVENTB | RESET2_EVENT_B: RESET2_EVENT_B
Public property | RESET2EVENTBRESET2EVENTBLEVEL | RESET2_EVENT_B: RESET2_EVENT_B_LEVEL
Public property | RESETCFGRESET1POL | RESET_CFG: RESET1_POL
Public property | RESETCFGRESET2POL | RESET_CFG: RESET2_POL
Public property | RESETCFGRESETPULSEWIDTH | RESET_CFG: RESET_PULSE_WIDTH
Public property | RESETCFGRESETTRIGGERTIME | RESET_CFG: RESET_TRIGGER_TIME (unit: s)
Public property | RESETCFGRSTPASSTHRUEN | RESET_CFG: RST_PASSTHRU_EN
Public property | RPULLCONFIGAR0PULLCFG | RPULL_CONFIG_A: R0_PULL_CFG
Public property | RPULLCONFIGAR1PULLCFG | RPULL_CONFIG_A: R1_PULL_CFG
Public property | RPULLCONFIGAR2PULLCFG | RPULL_CONFIG_A: R2_PULL_CFG
Public property | RPULLCONFIGAR3PULLCFG | RPULL_CONFIG_A: R3_PULL_CFG
Public property | RPULLCONFIGBR4PULLCFG | RPULL_CONFIG_B: R4_PULL_CFG
Public property | RPULLCONFIGBR5PULLCFG | RPULL_CONFIG_B: R5_PULL_CFG
Public property | RPULLCONFIGCC0PULLCFG | RPULL_CONFIG_C: C0_PULL_CFG
Public property | RPULLCONFIGCC1PULLCFG | RPULL_CONFIG_C: C1_PULL_CFG
Public property | RPULLCONFIGCC2PULLCFG | RPULL_CONFIG_C: C2_PULL_CFG
Public property | RPULLCONFIGCC3PULLCFG | RPULL_CONFIG_C: C3_PULL_CFG
Public property | RPULLCONFIGDC4PULLCFG | RPULL_CONFIG_D: C4_PULL_CFG
Public property | STATUSEC | STATUS: EC
Public property | STATUSLOGICSTAT | STATUS: LOGIC_STAT
Top
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.AutoFlush Property

IRD

Adp5585AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.DEBOUNCEDISAGPI1DEBDIS Property

IRD

Adp5585DEBOUNCEDISAGPI1DEBDIS Property

DEBOUNCE_DIS_A: GPI_1_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeDebounceDis DEBOUNCEDISAGPI1DEBDIS { get; set; }
Public Property DEBOUNCEDISAGPI1DEBDIS As Adp5585TypeDebounceDis
    Get
    Set
public:
property Adp5585TypeDebounceDis DEBOUNCEDISAGPI1DEBDIS {
    Adp5585TypeDebounceDis get ();
    void set (Adp5585TypeDebounceDis value);
}
member DEBOUNCEDISAGPI1DEBDIS : Adp5585TypeDebounceDis with get, set

Property Value

Type: Adp5585TypeDebounceDis
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.DEBOUNCEDISAGPI2DEBDIS Property

IRD

Adp5585DEBOUNCEDISAGPI2DEBDIS Property

DEBOUNCE_DIS_A: GPI_2_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeDebounceDis DEBOUNCEDISAGPI2DEBDIS { get; set; }
Public Property DEBOUNCEDISAGPI2DEBDIS As Adp5585TypeDebounceDis
    Get
    Set
public:
property Adp5585TypeDebounceDis DEBOUNCEDISAGPI2DEBDIS {
    Adp5585TypeDebounceDis get ();
    void set (Adp5585TypeDebounceDis value);
}
member DEBOUNCEDISAGPI2DEBDIS : Adp5585TypeDebounceDis with get, set

Property Value

Type: Adp5585TypeDebounceDis
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.DEBOUNCEDISAGPI3DEBDIS Property

IRD

Adp5585DEBOUNCEDISAGPI3DEBDIS Property

DEBOUNCE_DIS_A: GPI_3_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeDebounceDis DEBOUNCEDISAGPI3DEBDIS { get; set; }
Public Property DEBOUNCEDISAGPI3DEBDIS As Adp5585TypeDebounceDis
    Get
    Set
public:
property Adp5585TypeDebounceDis DEBOUNCEDISAGPI3DEBDIS {
    Adp5585TypeDebounceDis get ();
    void set (Adp5585TypeDebounceDis value);
}
member DEBOUNCEDISAGPI3DEBDIS : Adp5585TypeDebounceDis with get, set

Property Value

Type: Adp5585TypeDebounceDis
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.DEBOUNCEDISAGPI4DEBDIS Property

IRD

Adp5585DEBOUNCEDISAGPI4DEBDIS Property

DEBOUNCE_DIS_A: GPI_4_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeDebounceDis DEBOUNCEDISAGPI4DEBDIS { get; set; }
Public Property DEBOUNCEDISAGPI4DEBDIS As Adp5585TypeDebounceDis
    Get
    Set
public:
property Adp5585TypeDebounceDis DEBOUNCEDISAGPI4DEBDIS {
    Adp5585TypeDebounceDis get ();
    void set (Adp5585TypeDebounceDis value);
}
member DEBOUNCEDISAGPI4DEBDIS : Adp5585TypeDebounceDis with get, set

Property Value

Type: Adp5585TypeDebounceDis
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.DEBOUNCEDISAGPI5DEBDIS Property

IRD

Adp5585DEBOUNCEDISAGPI5DEBDIS Property

DEBOUNCE_DIS_A: GPI_5_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeDebounceDis DEBOUNCEDISAGPI5DEBDIS { get; set; }
Public Property DEBOUNCEDISAGPI5DEBDIS As Adp5585TypeDebounceDis
    Get
    Set
public:
property Adp5585TypeDebounceDis DEBOUNCEDISAGPI5DEBDIS {
    Adp5585TypeDebounceDis get ();
    void set (Adp5585TypeDebounceDis value);
}
member DEBOUNCEDISAGPI5DEBDIS : Adp5585TypeDebounceDis with get, set

Property Value

Type: Adp5585TypeDebounceDis
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.DEBOUNCEDISAGPI6DEBDIS Property

IRD

Adp5585DEBOUNCEDISAGPI6DEBDIS Property

DEBOUNCE_DIS_A: GPI_6_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeDebounceDis DEBOUNCEDISAGPI6DEBDIS { get; set; }
Public Property DEBOUNCEDISAGPI6DEBDIS As Adp5585TypeDebounceDis
    Get
    Set
public:
property Adp5585TypeDebounceDis DEBOUNCEDISAGPI6DEBDIS {
    Adp5585TypeDebounceDis get ();
    void set (Adp5585TypeDebounceDis value);
}
member DEBOUNCEDISAGPI6DEBDIS : Adp5585TypeDebounceDis with get, set

Property Value

Type: Adp5585TypeDebounceDis
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.DEBOUNCEDISBGPI10DEBDIS Property

IRD

Adp5585DEBOUNCEDISBGPI10DEBDIS Property

DEBOUNCE_DIS_B: GPI_10_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeDebounceDis DEBOUNCEDISBGPI10DEBDIS { get; set; }
Public Property DEBOUNCEDISBGPI10DEBDIS As Adp5585TypeDebounceDis
    Get
    Set
public:
property Adp5585TypeDebounceDis DEBOUNCEDISBGPI10DEBDIS {
    Adp5585TypeDebounceDis get ();
    void set (Adp5585TypeDebounceDis value);
}
member DEBOUNCEDISBGPI10DEBDIS : Adp5585TypeDebounceDis with get, set

Property Value

Type: Adp5585TypeDebounceDis
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.DEBOUNCEDISBGPI11DEBDIS Property

IRD

Adp5585DEBOUNCEDISBGPI11DEBDIS Property

DEBOUNCE_DIS_B: GPI_11_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeDebounceDis DEBOUNCEDISBGPI11DEBDIS { get; set; }
Public Property DEBOUNCEDISBGPI11DEBDIS As Adp5585TypeDebounceDis
    Get
    Set
public:
property Adp5585TypeDebounceDis DEBOUNCEDISBGPI11DEBDIS {
    Adp5585TypeDebounceDis get ();
    void set (Adp5585TypeDebounceDis value);
}
member DEBOUNCEDISBGPI11DEBDIS : Adp5585TypeDebounceDis with get, set

Property Value

Type: Adp5585TypeDebounceDis
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.DEBOUNCEDISBGPI7DEBDIS Property

IRD

Adp5585DEBOUNCEDISBGPI7DEBDIS Property

DEBOUNCE_DIS_B: GPI_7_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeDebounceDis DEBOUNCEDISBGPI7DEBDIS { get; set; }
Public Property DEBOUNCEDISBGPI7DEBDIS As Adp5585TypeDebounceDis
    Get
    Set
public:
property Adp5585TypeDebounceDis DEBOUNCEDISBGPI7DEBDIS {
    Adp5585TypeDebounceDis get ();
    void set (Adp5585TypeDebounceDis value);
}
member DEBOUNCEDISBGPI7DEBDIS : Adp5585TypeDebounceDis with get, set

Property Value

Type: Adp5585TypeDebounceDis
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.DEBOUNCEDISBGPI8DEBDIS Property

IRD

Adp5585DEBOUNCEDISBGPI8DEBDIS Property

DEBOUNCE_DIS_B: GPI_8_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeDebounceDis DEBOUNCEDISBGPI8DEBDIS { get; set; }
Public Property DEBOUNCEDISBGPI8DEBDIS As Adp5585TypeDebounceDis
    Get
    Set
public:
property Adp5585TypeDebounceDis DEBOUNCEDISBGPI8DEBDIS {
    Adp5585TypeDebounceDis get ();
    void set (Adp5585TypeDebounceDis value);
}
member DEBOUNCEDISBGPI8DEBDIS : Adp5585TypeDebounceDis with get, set

Property Value

Type: Adp5585TypeDebounceDis
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.DEBOUNCEDISBGPI9DEBDIS Property

IRD

Adp5585DEBOUNCEDISBGPI9DEBDIS Property

DEBOUNCE_DIS_B: GPI_9_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeDebounceDis DEBOUNCEDISBGPI9DEBDIS { get; set; }
Public Property DEBOUNCEDISBGPI9DEBDIS As Adp5585TypeDebounceDis
    Get
    Set
public:
property Adp5585TypeDebounceDis DEBOUNCEDISBGPI9DEBDIS {
    Adp5585TypeDebounceDis get ();
    void set (Adp5585TypeDebounceDis value);
}
member DEBOUNCEDISBGPI9DEBDIS : Adp5585TypeDebounceDis with get, set

Property Value

Type: Adp5585TypeDebounceDis
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO10EVENT10IDENTIFIER Property

IRD

Adp5585FIFO10EVENT10IDENTIFIER Property

FIFO_10: EVENT10_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeFifoEventIdentifier FIFO10EVENT10IDENTIFIER { get; }
Public ReadOnly Property FIFO10EVENT10IDENTIFIER As Adp5585TypeFifoEventIdentifier
    Get
public:
property Adp5585TypeFifoEventIdentifier FIFO10EVENT10IDENTIFIER {
    Adp5585TypeFifoEventIdentifier get ();
}
member FIFO10EVENT10IDENTIFIER : Adp5585TypeFifoEventIdentifier with get

Property Value

Type: Adp5585TypeFifoEventIdentifier
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO10EVENT10STATE Property

IRD

Adp5585FIFO10EVENT10STATE Property

FIFO_10: EVENT10_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO10EVENT10STATE { get; }
Public ReadOnly Property FIFO10EVENT10STATE As Byte
    Get
public:
property unsigned char FIFO10EVENT10STATE {
    unsigned char get ();
}
member FIFO10EVENT10STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO11EVENT11IDENTIFIER Property

IRD

Adp5585FIFO11EVENT11IDENTIFIER Property

FIFO_11: EVENT11_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeFifoEventIdentifier FIFO11EVENT11IDENTIFIER { get; }
Public ReadOnly Property FIFO11EVENT11IDENTIFIER As Adp5585TypeFifoEventIdentifier
    Get
public:
property Adp5585TypeFifoEventIdentifier FIFO11EVENT11IDENTIFIER {
    Adp5585TypeFifoEventIdentifier get ();
}
member FIFO11EVENT11IDENTIFIER : Adp5585TypeFifoEventIdentifier with get

Property Value

Type: Adp5585TypeFifoEventIdentifier
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO11EVENT11STATE Property

IRD

Adp5585FIFO11EVENT11STATE Property

FIFO_11: EVENT11_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO11EVENT11STATE { get; }
Public ReadOnly Property FIFO11EVENT11STATE As Byte
    Get
public:
property unsigned char FIFO11EVENT11STATE {
    unsigned char get ();
}
member FIFO11EVENT11STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO12EVENT12IDENTIFIER Property

IRD

Adp5585FIFO12EVENT12IDENTIFIER Property

FIFO_12: EVENT12_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeFifoEventIdentifier FIFO12EVENT12IDENTIFIER { get; }
Public ReadOnly Property FIFO12EVENT12IDENTIFIER As Adp5585TypeFifoEventIdentifier
    Get
public:
property Adp5585TypeFifoEventIdentifier FIFO12EVENT12IDENTIFIER {
    Adp5585TypeFifoEventIdentifier get ();
}
member FIFO12EVENT12IDENTIFIER : Adp5585TypeFifoEventIdentifier with get

Property Value

Type: Adp5585TypeFifoEventIdentifier
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO12EVENT12STATE Property

IRD

Adp5585FIFO12EVENT12STATE Property

FIFO_12: EVENT12_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO12EVENT12STATE { get; }
Public ReadOnly Property FIFO12EVENT12STATE As Byte
    Get
public:
property unsigned char FIFO12EVENT12STATE {
    unsigned char get ();
}
member FIFO12EVENT12STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO13EVENT13IDENTIFIER Property

IRD

Adp5585FIFO13EVENT13IDENTIFIER Property

FIFO_13: EVENT13_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeFifoEventIdentifier FIFO13EVENT13IDENTIFIER { get; }
Public ReadOnly Property FIFO13EVENT13IDENTIFIER As Adp5585TypeFifoEventIdentifier
    Get
public:
property Adp5585TypeFifoEventIdentifier FIFO13EVENT13IDENTIFIER {
    Adp5585TypeFifoEventIdentifier get ();
}
member FIFO13EVENT13IDENTIFIER : Adp5585TypeFifoEventIdentifier with get

Property Value

Type: Adp5585TypeFifoEventIdentifier
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO13EVENT13STATE Property

IRD

Adp5585FIFO13EVENT13STATE Property

FIFO_13: EVENT13_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO13EVENT13STATE { get; }
Public ReadOnly Property FIFO13EVENT13STATE As Byte
    Get
public:
property unsigned char FIFO13EVENT13STATE {
    unsigned char get ();
}
member FIFO13EVENT13STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO14EVENT14IDENTIFIER Property

IRD

Adp5585FIFO14EVENT14IDENTIFIER Property

FIFO_14: EVENT14_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeFifoEventIdentifier FIFO14EVENT14IDENTIFIER { get; }
Public ReadOnly Property FIFO14EVENT14IDENTIFIER As Adp5585TypeFifoEventIdentifier
    Get
public:
property Adp5585TypeFifoEventIdentifier FIFO14EVENT14IDENTIFIER {
    Adp5585TypeFifoEventIdentifier get ();
}
member FIFO14EVENT14IDENTIFIER : Adp5585TypeFifoEventIdentifier with get

Property Value

Type: Adp5585TypeFifoEventIdentifier
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO14EVENT14STATE Property

IRD

Adp5585FIFO14EVENT14STATE Property

FIFO_14: EVENT14_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO14EVENT14STATE { get; }
Public ReadOnly Property FIFO14EVENT14STATE As Byte
    Get
public:
property unsigned char FIFO14EVENT14STATE {
    unsigned char get ();
}
member FIFO14EVENT14STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO15EVENT15IDENTIFIER Property

IRD

Adp5585FIFO15EVENT15IDENTIFIER Property

FIFO_15: EVENT15_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeFifoEventIdentifier FIFO15EVENT15IDENTIFIER { get; }
Public ReadOnly Property FIFO15EVENT15IDENTIFIER As Adp5585TypeFifoEventIdentifier
    Get
public:
property Adp5585TypeFifoEventIdentifier FIFO15EVENT15IDENTIFIER {
    Adp5585TypeFifoEventIdentifier get ();
}
member FIFO15EVENT15IDENTIFIER : Adp5585TypeFifoEventIdentifier with get

Property Value

Type: Adp5585TypeFifoEventIdentifier
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO15EVENT15STATE Property

IRD

Adp5585FIFO15EVENT15STATE Property

FIFO_15: EVENT15_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO15EVENT15STATE { get; }
Public ReadOnly Property FIFO15EVENT15STATE As Byte
    Get
public:
property unsigned char FIFO15EVENT15STATE {
    unsigned char get ();
}
member FIFO15EVENT15STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO16EVENT16IDENTIFIER Property

IRD

Adp5585FIFO16EVENT16IDENTIFIER Property

FIFO_16: EVENT16_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeFifoEventIdentifier FIFO16EVENT16IDENTIFIER { get; }
Public ReadOnly Property FIFO16EVENT16IDENTIFIER As Adp5585TypeFifoEventIdentifier
    Get
public:
property Adp5585TypeFifoEventIdentifier FIFO16EVENT16IDENTIFIER {
    Adp5585TypeFifoEventIdentifier get ();
}
member FIFO16EVENT16IDENTIFIER : Adp5585TypeFifoEventIdentifier with get

Property Value

Type: Adp5585TypeFifoEventIdentifier
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO16EVENT16STATE Property

IRD

Adp5585FIFO16EVENT16STATE Property

FIFO_16: EVENT16_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO16EVENT16STATE { get; }
Public ReadOnly Property FIFO16EVENT16STATE As Byte
    Get
public:
property unsigned char FIFO16EVENT16STATE {
    unsigned char get ();
}
member FIFO16EVENT16STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO1EVENT1IDENTIFIER Property

IRD

Adp5585FIFO1EVENT1IDENTIFIER Property

FIFO_1: EVENT1_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeFifoEventIdentifier FIFO1EVENT1IDENTIFIER { get; }
Public ReadOnly Property FIFO1EVENT1IDENTIFIER As Adp5585TypeFifoEventIdentifier
    Get
public:
property Adp5585TypeFifoEventIdentifier FIFO1EVENT1IDENTIFIER {
    Adp5585TypeFifoEventIdentifier get ();
}
member FIFO1EVENT1IDENTIFIER : Adp5585TypeFifoEventIdentifier with get

Property Value

Type: Adp5585TypeFifoEventIdentifier
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO1EVENT1STATE Property

IRD

Adp5585FIFO1EVENT1STATE Property

FIFO_1: EVENT1_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO1EVENT1STATE { get; }
Public ReadOnly Property FIFO1EVENT1STATE As Byte
    Get
public:
property unsigned char FIFO1EVENT1STATE {
    unsigned char get ();
}
member FIFO1EVENT1STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO2EVENT2IDENTIFIER Property

IRD

Adp5585FIFO2EVENT2IDENTIFIER Property

FIFO_2: EVENT2_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeFifoEventIdentifier FIFO2EVENT2IDENTIFIER { get; }
Public ReadOnly Property FIFO2EVENT2IDENTIFIER As Adp5585TypeFifoEventIdentifier
    Get
public:
property Adp5585TypeFifoEventIdentifier FIFO2EVENT2IDENTIFIER {
    Adp5585TypeFifoEventIdentifier get ();
}
member FIFO2EVENT2IDENTIFIER : Adp5585TypeFifoEventIdentifier with get

Property Value

Type: Adp5585TypeFifoEventIdentifier
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO2EVENT2STATE Property

IRD

Adp5585FIFO2EVENT2STATE Property

FIFO_2: EVENT2_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO2EVENT2STATE { get; }
Public ReadOnly Property FIFO2EVENT2STATE As Byte
    Get
public:
property unsigned char FIFO2EVENT2STATE {
    unsigned char get ();
}
member FIFO2EVENT2STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO3EVENT3IDENTIFIER Property

IRD

Adp5585FIFO3EVENT3IDENTIFIER Property

FIFO_3: EVENT3_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeFifoEventIdentifier FIFO3EVENT3IDENTIFIER { get; }
Public ReadOnly Property FIFO3EVENT3IDENTIFIER As Adp5585TypeFifoEventIdentifier
    Get
public:
property Adp5585TypeFifoEventIdentifier FIFO3EVENT3IDENTIFIER {
    Adp5585TypeFifoEventIdentifier get ();
}
member FIFO3EVENT3IDENTIFIER : Adp5585TypeFifoEventIdentifier with get

Property Value

Type: Adp5585TypeFifoEventIdentifier
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO3EVENT3STATE Property

IRD

Adp5585FIFO3EVENT3STATE Property

FIFO_3: EVENT3_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO3EVENT3STATE { get; }
Public ReadOnly Property FIFO3EVENT3STATE As Byte
    Get
public:
property unsigned char FIFO3EVENT3STATE {
    unsigned char get ();
}
member FIFO3EVENT3STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO4EVENT4IDENTIFIER Property

IRD

Adp5585FIFO4EVENT4IDENTIFIER Property

FIFO_4: EVENT4_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeFifoEventIdentifier FIFO4EVENT4IDENTIFIER { get; }
Public ReadOnly Property FIFO4EVENT4IDENTIFIER As Adp5585TypeFifoEventIdentifier
    Get
public:
property Adp5585TypeFifoEventIdentifier FIFO4EVENT4IDENTIFIER {
    Adp5585TypeFifoEventIdentifier get ();
}
member FIFO4EVENT4IDENTIFIER : Adp5585TypeFifoEventIdentifier with get

Property Value

Type: Adp5585TypeFifoEventIdentifier
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO4EVENT4STATE Property

IRD

Adp5585FIFO4EVENT4STATE Property

FIFO_4: EVENT4_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO4EVENT4STATE { get; }
Public ReadOnly Property FIFO4EVENT4STATE As Byte
    Get
public:
property unsigned char FIFO4EVENT4STATE {
    unsigned char get ();
}
member FIFO4EVENT4STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO5EVENT5IDENTIFIER Property

IRD

Adp5585FIFO5EVENT5IDENTIFIER Property

FIFO_5: EVENT5_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeFifoEventIdentifier FIFO5EVENT5IDENTIFIER { get; }
Public ReadOnly Property FIFO5EVENT5IDENTIFIER As Adp5585TypeFifoEventIdentifier
    Get
public:
property Adp5585TypeFifoEventIdentifier FIFO5EVENT5IDENTIFIER {
    Adp5585TypeFifoEventIdentifier get ();
}
member FIFO5EVENT5IDENTIFIER : Adp5585TypeFifoEventIdentifier with get

Property Value

Type: Adp5585TypeFifoEventIdentifier
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO5EVENT5STATE Property

IRD

Adp5585FIFO5EVENT5STATE Property

FIFO_5: EVENT5_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO5EVENT5STATE { get; }
Public ReadOnly Property FIFO5EVENT5STATE As Byte
    Get
public:
property unsigned char FIFO5EVENT5STATE {
    unsigned char get ();
}
member FIFO5EVENT5STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO6EVENT6IDENTIFIER Property

IRD

Adp5585FIFO6EVENT6IDENTIFIER Property

FIFO_6: EVENT6_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeFifoEventIdentifier FIFO6EVENT6IDENTIFIER { get; }
Public ReadOnly Property FIFO6EVENT6IDENTIFIER As Adp5585TypeFifoEventIdentifier
    Get
public:
property Adp5585TypeFifoEventIdentifier FIFO6EVENT6IDENTIFIER {
    Adp5585TypeFifoEventIdentifier get ();
}
member FIFO6EVENT6IDENTIFIER : Adp5585TypeFifoEventIdentifier with get

Property Value

Type: Adp5585TypeFifoEventIdentifier
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO6EVENT6STATE Property

IRD

Adp5585FIFO6EVENT6STATE Property

FIFO_6: EVENT6_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO6EVENT6STATE { get; }
Public ReadOnly Property FIFO6EVENT6STATE As Byte
    Get
public:
property unsigned char FIFO6EVENT6STATE {
    unsigned char get ();
}
member FIFO6EVENT6STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO7EVENT7IDENTIFIER Property

IRD

Adp5585FIFO7EVENT7IDENTIFIER Property

FIFO_7: EVENT7_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeFifoEventIdentifier FIFO7EVENT7IDENTIFIER { get; }
Public ReadOnly Property FIFO7EVENT7IDENTIFIER As Adp5585TypeFifoEventIdentifier
    Get
public:
property Adp5585TypeFifoEventIdentifier FIFO7EVENT7IDENTIFIER {
    Adp5585TypeFifoEventIdentifier get ();
}
member FIFO7EVENT7IDENTIFIER : Adp5585TypeFifoEventIdentifier with get

Property Value

Type: Adp5585TypeFifoEventIdentifier
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO7EVENT7STATE Property

IRD

Adp5585FIFO7EVENT7STATE Property

FIFO_7: EVENT7_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO7EVENT7STATE { get; }
Public ReadOnly Property FIFO7EVENT7STATE As Byte
    Get
public:
property unsigned char FIFO7EVENT7STATE {
    unsigned char get ();
}
member FIFO7EVENT7STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO8EVENT8IDENTIFIER Property

IRD

Adp5585FIFO8EVENT8IDENTIFIER Property

FIFO_8: EVENT8_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeFifoEventIdentifier FIFO8EVENT8IDENTIFIER { get; }
Public ReadOnly Property FIFO8EVENT8IDENTIFIER As Adp5585TypeFifoEventIdentifier
    Get
public:
property Adp5585TypeFifoEventIdentifier FIFO8EVENT8IDENTIFIER {
    Adp5585TypeFifoEventIdentifier get ();
}
member FIFO8EVENT8IDENTIFIER : Adp5585TypeFifoEventIdentifier with get

Property Value

Type: Adp5585TypeFifoEventIdentifier
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO8EVENT8STATE Property

IRD

Adp5585FIFO8EVENT8STATE Property

FIFO_8: EVENT8_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO8EVENT8STATE { get; }
Public ReadOnly Property FIFO8EVENT8STATE As Byte
    Get
public:
property unsigned char FIFO8EVENT8STATE {
    unsigned char get ();
}
member FIFO8EVENT8STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO9EVENT9IDENTIFIER Property

IRD

Adp5585FIFO9EVENT9IDENTIFIER Property

FIFO_9: EVENT9_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeFifoEventIdentifier FIFO9EVENT9IDENTIFIER { get; }
Public ReadOnly Property FIFO9EVENT9IDENTIFIER As Adp5585TypeFifoEventIdentifier
    Get
public:
property Adp5585TypeFifoEventIdentifier FIFO9EVENT9IDENTIFIER {
    Adp5585TypeFifoEventIdentifier get ();
}
member FIFO9EVENT9IDENTIFIER : Adp5585TypeFifoEventIdentifier with get

Property Value

Type: Adp5585TypeFifoEventIdentifier
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.FIFO9EVENT9STATE Property

IRD

Adp5585FIFO9EVENT9STATE Property

FIFO_9: EVENT9_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO9EVENT9STATE { get; }
Public ReadOnly Property FIFO9EVENT9STATE As Byte
    Get
public:
property unsigned char FIFO9EVENT9STATE {
    unsigned char get ();
}
member FIFO9EVENT9STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GENERALCFGBINTCFG Property

IRD

Adp5585GENERALCFGBINTCFG Property

GENERAL_CFG_B: INT_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGeneralCfgBIntCfg GENERALCFGBINTCFG { get; set; }
Public Property GENERALCFGBINTCFG As Adp5585TypeGeneralCfgBIntCfg
    Get
    Set
public:
property Adp5585TypeGeneralCfgBIntCfg GENERALCFGBINTCFG {
    Adp5585TypeGeneralCfgBIntCfg get ();
    void set (Adp5585TypeGeneralCfgBIntCfg value);
}
member GENERALCFGBINTCFG : Adp5585TypeGeneralCfgBIntCfg with get, set

Property Value

Type: Adp5585TypeGeneralCfgBIntCfg
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GENERALCFGBOSCEN Property

IRD

Adp5585GENERALCFGBOSCEN Property

GENERAL_CFG_B: OSC_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGeneralCfgBOscEn GENERALCFGBOSCEN { get; set; }
Public Property GENERALCFGBOSCEN As Adp5585TypeGeneralCfgBOscEn
    Get
    Set
public:
property Adp5585TypeGeneralCfgBOscEn GENERALCFGBOSCEN {
    Adp5585TypeGeneralCfgBOscEn get ();
    void set (Adp5585TypeGeneralCfgBOscEn value);
}
member GENERALCFGBOSCEN : Adp5585TypeGeneralCfgBOscEn with get, set

Property Value

Type: Adp5585TypeGeneralCfgBOscEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GENERALCFGBOSCFREQ Property

IRD

Adp5585GENERALCFGBOSCFREQ Property

GENERAL_CFG_B: OSC_FREQ

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGeneralCfgBOscFreq GENERALCFGBOSCFREQ { get; set; }
Public Property GENERALCFGBOSCFREQ As Adp5585TypeGeneralCfgBOscFreq
    Get
    Set
public:
property Adp5585TypeGeneralCfgBOscFreq GENERALCFGBOSCFREQ {
    Adp5585TypeGeneralCfgBOscFreq get ();
    void set (Adp5585TypeGeneralCfgBOscFreq value);
}
member GENERALCFGBOSCFREQ : Adp5585TypeGeneralCfgBOscFreq with get, set

Property Value

Type: Adp5585TypeGeneralCfgBOscFreq
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GENERALCFGBRSTCFG Property

IRD

Adp5585GENERALCFGBRSTCFG Property

GENERAL_CFG_B: RST_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGeneralCfgBRstCfg GENERALCFGBRSTCFG { get; set; }
Public Property GENERALCFGBRSTCFG As Adp5585TypeGeneralCfgBRstCfg
    Get
    Set
public:
property Adp5585TypeGeneralCfgBRstCfg GENERALCFGBRSTCFG {
    Adp5585TypeGeneralCfgBRstCfg get ();
    void set (Adp5585TypeGeneralCfgBRstCfg value);
}
member GENERALCFGBRSTCFG : Adp5585TypeGeneralCfgBRstCfg with get, set

Property Value

Type: Adp5585TypeGeneralCfgBRstCfg
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIEVENTENAGPI1EVENTEN Property

IRD

Adp5585GPIEVENTENAGPI1EVENTEN Property

GPI_EVENT_EN_A: GPI_1_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiEventEn GPIEVENTENAGPI1EVENTEN { get; set; }
Public Property GPIEVENTENAGPI1EVENTEN As Adp5585TypeGpiEventEn
    Get
    Set
public:
property Adp5585TypeGpiEventEn GPIEVENTENAGPI1EVENTEN {
    Adp5585TypeGpiEventEn get ();
    void set (Adp5585TypeGpiEventEn value);
}
member GPIEVENTENAGPI1EVENTEN : Adp5585TypeGpiEventEn with get, set

Property Value

Type: Adp5585TypeGpiEventEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIEVENTENAGPI2EVENTEN Property

IRD

Adp5585GPIEVENTENAGPI2EVENTEN Property

GPI_EVENT_EN_A: GPI_2_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiEventEn GPIEVENTENAGPI2EVENTEN { get; set; }
Public Property GPIEVENTENAGPI2EVENTEN As Adp5585TypeGpiEventEn
    Get
    Set
public:
property Adp5585TypeGpiEventEn GPIEVENTENAGPI2EVENTEN {
    Adp5585TypeGpiEventEn get ();
    void set (Adp5585TypeGpiEventEn value);
}
member GPIEVENTENAGPI2EVENTEN : Adp5585TypeGpiEventEn with get, set

Property Value

Type: Adp5585TypeGpiEventEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIEVENTENAGPI3EVENTEN Property

IRD

Adp5585GPIEVENTENAGPI3EVENTEN Property

GPI_EVENT_EN_A: GPI_3_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiEventEn GPIEVENTENAGPI3EVENTEN { get; set; }
Public Property GPIEVENTENAGPI3EVENTEN As Adp5585TypeGpiEventEn
    Get
    Set
public:
property Adp5585TypeGpiEventEn GPIEVENTENAGPI3EVENTEN {
    Adp5585TypeGpiEventEn get ();
    void set (Adp5585TypeGpiEventEn value);
}
member GPIEVENTENAGPI3EVENTEN : Adp5585TypeGpiEventEn with get, set

Property Value

Type: Adp5585TypeGpiEventEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIEVENTENAGPI4EVENTEN Property

IRD

Adp5585GPIEVENTENAGPI4EVENTEN Property

GPI_EVENT_EN_A: GPI_4_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiEventEn GPIEVENTENAGPI4EVENTEN { get; set; }
Public Property GPIEVENTENAGPI4EVENTEN As Adp5585TypeGpiEventEn
    Get
    Set
public:
property Adp5585TypeGpiEventEn GPIEVENTENAGPI4EVENTEN {
    Adp5585TypeGpiEventEn get ();
    void set (Adp5585TypeGpiEventEn value);
}
member GPIEVENTENAGPI4EVENTEN : Adp5585TypeGpiEventEn with get, set

Property Value

Type: Adp5585TypeGpiEventEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIEVENTENAGPI5EVENTEN Property

IRD

Adp5585GPIEVENTENAGPI5EVENTEN Property

GPI_EVENT_EN_A: GPI_5_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiEventEn GPIEVENTENAGPI5EVENTEN { get; set; }
Public Property GPIEVENTENAGPI5EVENTEN As Adp5585TypeGpiEventEn
    Get
    Set
public:
property Adp5585TypeGpiEventEn GPIEVENTENAGPI5EVENTEN {
    Adp5585TypeGpiEventEn get ();
    void set (Adp5585TypeGpiEventEn value);
}
member GPIEVENTENAGPI5EVENTEN : Adp5585TypeGpiEventEn with get, set

Property Value

Type: Adp5585TypeGpiEventEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIEVENTENAGPI6EVENTEN Property

IRD

Adp5585GPIEVENTENAGPI6EVENTEN Property

GPI_EVENT_EN_A: GPI_6_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiEventEn GPIEVENTENAGPI6EVENTEN { get; set; }
Public Property GPIEVENTENAGPI6EVENTEN As Adp5585TypeGpiEventEn
    Get
    Set
public:
property Adp5585TypeGpiEventEn GPIEVENTENAGPI6EVENTEN {
    Adp5585TypeGpiEventEn get ();
    void set (Adp5585TypeGpiEventEn value);
}
member GPIEVENTENAGPI6EVENTEN : Adp5585TypeGpiEventEn with get, set

Property Value

Type: Adp5585TypeGpiEventEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIEVENTENBGPI10EVENTEN Property

IRD

Adp5585GPIEVENTENBGPI10EVENTEN Property

GPI_EVENT_EN_B: GPI_10_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiEventEn GPIEVENTENBGPI10EVENTEN { get; set; }
Public Property GPIEVENTENBGPI10EVENTEN As Adp5585TypeGpiEventEn
    Get
    Set
public:
property Adp5585TypeGpiEventEn GPIEVENTENBGPI10EVENTEN {
    Adp5585TypeGpiEventEn get ();
    void set (Adp5585TypeGpiEventEn value);
}
member GPIEVENTENBGPI10EVENTEN : Adp5585TypeGpiEventEn with get, set

Property Value

Type: Adp5585TypeGpiEventEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIEVENTENBGPI11EVENTEN Property

IRD

Adp5585GPIEVENTENBGPI11EVENTEN Property

GPI_EVENT_EN_B: GPI_11_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiEventEn GPIEVENTENBGPI11EVENTEN { get; set; }
Public Property GPIEVENTENBGPI11EVENTEN As Adp5585TypeGpiEventEn
    Get
    Set
public:
property Adp5585TypeGpiEventEn GPIEVENTENBGPI11EVENTEN {
    Adp5585TypeGpiEventEn get ();
    void set (Adp5585TypeGpiEventEn value);
}
member GPIEVENTENBGPI11EVENTEN : Adp5585TypeGpiEventEn with get, set

Property Value

Type: Adp5585TypeGpiEventEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIEVENTENBGPI7EVENTEN Property

IRD

Adp5585GPIEVENTENBGPI7EVENTEN Property

GPI_EVENT_EN_B: GPI_7_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiEventEn GPIEVENTENBGPI7EVENTEN { get; set; }
Public Property GPIEVENTENBGPI7EVENTEN As Adp5585TypeGpiEventEn
    Get
    Set
public:
property Adp5585TypeGpiEventEn GPIEVENTENBGPI7EVENTEN {
    Adp5585TypeGpiEventEn get ();
    void set (Adp5585TypeGpiEventEn value);
}
member GPIEVENTENBGPI7EVENTEN : Adp5585TypeGpiEventEn with get, set

Property Value

Type: Adp5585TypeGpiEventEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIEVENTENBGPI8EVENTEN Property

IRD

Adp5585GPIEVENTENBGPI8EVENTEN Property

GPI_EVENT_EN_B: GPI_8_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiEventEn GPIEVENTENBGPI8EVENTEN { get; set; }
Public Property GPIEVENTENBGPI8EVENTEN As Adp5585TypeGpiEventEn
    Get
    Set
public:
property Adp5585TypeGpiEventEn GPIEVENTENBGPI8EVENTEN {
    Adp5585TypeGpiEventEn get ();
    void set (Adp5585TypeGpiEventEn value);
}
member GPIEVENTENBGPI8EVENTEN : Adp5585TypeGpiEventEn with get, set

Property Value

Type: Adp5585TypeGpiEventEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIEVENTENBGPI9EVENTEN Property

IRD

Adp5585GPIEVENTENBGPI9EVENTEN Property

GPI_EVENT_EN_B: GPI_9_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiEventEn GPIEVENTENBGPI9EVENTEN { get; set; }
Public Property GPIEVENTENBGPI9EVENTEN As Adp5585TypeGpiEventEn
    Get
    Set
public:
property Adp5585TypeGpiEventEn GPIEVENTENBGPI9EVENTEN {
    Adp5585TypeGpiEventEn get ();
    void set (Adp5585TypeGpiEventEn value);
}
member GPIEVENTENBGPI9EVENTEN : Adp5585TypeGpiEventEn with get, set

Property Value

Type: Adp5585TypeGpiEventEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTERRUPTENAGPI1INTEN Property

IRD

Adp5585GPIINTERRUPTENAGPI1INTEN Property

GPI_INTERRUPT_EN_A: GPI_1_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiInterruptEn GPIINTERRUPTENAGPI1INTEN { get; set; }
Public Property GPIINTERRUPTENAGPI1INTEN As Adp5585TypeGpiInterruptEn
    Get
    Set
public:
property Adp5585TypeGpiInterruptEn GPIINTERRUPTENAGPI1INTEN {
    Adp5585TypeGpiInterruptEn get ();
    void set (Adp5585TypeGpiInterruptEn value);
}
member GPIINTERRUPTENAGPI1INTEN : Adp5585TypeGpiInterruptEn with get, set

Property Value

Type: Adp5585TypeGpiInterruptEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTERRUPTENAGPI2INTEN Property

IRD

Adp5585GPIINTERRUPTENAGPI2INTEN Property

GPI_INTERRUPT_EN_A: GPI_2_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiInterruptEn GPIINTERRUPTENAGPI2INTEN { get; set; }
Public Property GPIINTERRUPTENAGPI2INTEN As Adp5585TypeGpiInterruptEn
    Get
    Set
public:
property Adp5585TypeGpiInterruptEn GPIINTERRUPTENAGPI2INTEN {
    Adp5585TypeGpiInterruptEn get ();
    void set (Adp5585TypeGpiInterruptEn value);
}
member GPIINTERRUPTENAGPI2INTEN : Adp5585TypeGpiInterruptEn with get, set

Property Value

Type: Adp5585TypeGpiInterruptEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTERRUPTENAGPI3INTEN Property

IRD

Adp5585GPIINTERRUPTENAGPI3INTEN Property

GPI_INTERRUPT_EN_A: GPI_3_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiInterruptEn GPIINTERRUPTENAGPI3INTEN { get; set; }
Public Property GPIINTERRUPTENAGPI3INTEN As Adp5585TypeGpiInterruptEn
    Get
    Set
public:
property Adp5585TypeGpiInterruptEn GPIINTERRUPTENAGPI3INTEN {
    Adp5585TypeGpiInterruptEn get ();
    void set (Adp5585TypeGpiInterruptEn value);
}
member GPIINTERRUPTENAGPI3INTEN : Adp5585TypeGpiInterruptEn with get, set

Property Value

Type: Adp5585TypeGpiInterruptEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTERRUPTENAGPI4INTEN Property

IRD

Adp5585GPIINTERRUPTENAGPI4INTEN Property

GPI_INTERRUPT_EN_A: GPI_4_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiInterruptEn GPIINTERRUPTENAGPI4INTEN { get; set; }
Public Property GPIINTERRUPTENAGPI4INTEN As Adp5585TypeGpiInterruptEn
    Get
    Set
public:
property Adp5585TypeGpiInterruptEn GPIINTERRUPTENAGPI4INTEN {
    Adp5585TypeGpiInterruptEn get ();
    void set (Adp5585TypeGpiInterruptEn value);
}
member GPIINTERRUPTENAGPI4INTEN : Adp5585TypeGpiInterruptEn with get, set

Property Value

Type: Adp5585TypeGpiInterruptEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTERRUPTENAGPI5INTEN Property

IRD

Adp5585GPIINTERRUPTENAGPI5INTEN Property

GPI_INTERRUPT_EN_A: GPI_5_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiInterruptEn GPIINTERRUPTENAGPI5INTEN { get; set; }
Public Property GPIINTERRUPTENAGPI5INTEN As Adp5585TypeGpiInterruptEn
    Get
    Set
public:
property Adp5585TypeGpiInterruptEn GPIINTERRUPTENAGPI5INTEN {
    Adp5585TypeGpiInterruptEn get ();
    void set (Adp5585TypeGpiInterruptEn value);
}
member GPIINTERRUPTENAGPI5INTEN : Adp5585TypeGpiInterruptEn with get, set

Property Value

Type: Adp5585TypeGpiInterruptEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTERRUPTENAGPI6INTEN Property

IRD

Adp5585GPIINTERRUPTENAGPI6INTEN Property

GPI_INTERRUPT_EN_A: GPI_6_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiInterruptEn GPIINTERRUPTENAGPI6INTEN { get; set; }
Public Property GPIINTERRUPTENAGPI6INTEN As Adp5585TypeGpiInterruptEn
    Get
    Set
public:
property Adp5585TypeGpiInterruptEn GPIINTERRUPTENAGPI6INTEN {
    Adp5585TypeGpiInterruptEn get ();
    void set (Adp5585TypeGpiInterruptEn value);
}
member GPIINTERRUPTENAGPI6INTEN : Adp5585TypeGpiInterruptEn with get, set

Property Value

Type: Adp5585TypeGpiInterruptEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTERRUPTENBGPI10INTEN Property

IRD

Adp5585GPIINTERRUPTENBGPI10INTEN Property

GPI_INTERRUPT_EN_B: GPI_10_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiInterruptEn GPIINTERRUPTENBGPI10INTEN { get; set; }
Public Property GPIINTERRUPTENBGPI10INTEN As Adp5585TypeGpiInterruptEn
    Get
    Set
public:
property Adp5585TypeGpiInterruptEn GPIINTERRUPTENBGPI10INTEN {
    Adp5585TypeGpiInterruptEn get ();
    void set (Adp5585TypeGpiInterruptEn value);
}
member GPIINTERRUPTENBGPI10INTEN : Adp5585TypeGpiInterruptEn with get, set

Property Value

Type: Adp5585TypeGpiInterruptEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTERRUPTENBGPI11INTEN Property

IRD

Adp5585GPIINTERRUPTENBGPI11INTEN Property

GPI_INTERRUPT_EN_B: GPI_11_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiInterruptEn GPIINTERRUPTENBGPI11INTEN { get; set; }
Public Property GPIINTERRUPTENBGPI11INTEN As Adp5585TypeGpiInterruptEn
    Get
    Set
public:
property Adp5585TypeGpiInterruptEn GPIINTERRUPTENBGPI11INTEN {
    Adp5585TypeGpiInterruptEn get ();
    void set (Adp5585TypeGpiInterruptEn value);
}
member GPIINTERRUPTENBGPI11INTEN : Adp5585TypeGpiInterruptEn with get, set

Property Value

Type: Adp5585TypeGpiInterruptEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTERRUPTENBGPI7INTEN Property

IRD

Adp5585GPIINTERRUPTENBGPI7INTEN Property

GPI_INTERRUPT_EN_B: GPI_7_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiInterruptEn GPIINTERRUPTENBGPI7INTEN { get; set; }
Public Property GPIINTERRUPTENBGPI7INTEN As Adp5585TypeGpiInterruptEn
    Get
    Set
public:
property Adp5585TypeGpiInterruptEn GPIINTERRUPTENBGPI7INTEN {
    Adp5585TypeGpiInterruptEn get ();
    void set (Adp5585TypeGpiInterruptEn value);
}
member GPIINTERRUPTENBGPI7INTEN : Adp5585TypeGpiInterruptEn with get, set

Property Value

Type: Adp5585TypeGpiInterruptEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTERRUPTENBGPI8INTEN Property

IRD

Adp5585GPIINTERRUPTENBGPI8INTEN Property

GPI_INTERRUPT_EN_B: GPI_8_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiInterruptEn GPIINTERRUPTENBGPI8INTEN { get; set; }
Public Property GPIINTERRUPTENBGPI8INTEN As Adp5585TypeGpiInterruptEn
    Get
    Set
public:
property Adp5585TypeGpiInterruptEn GPIINTERRUPTENBGPI8INTEN {
    Adp5585TypeGpiInterruptEn get ();
    void set (Adp5585TypeGpiInterruptEn value);
}
member GPIINTERRUPTENBGPI8INTEN : Adp5585TypeGpiInterruptEn with get, set

Property Value

Type: Adp5585TypeGpiInterruptEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTERRUPTENBGPI9INTEN Property

IRD

Adp5585GPIINTERRUPTENBGPI9INTEN Property

GPI_INTERRUPT_EN_B: GPI_9_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiInterruptEn GPIINTERRUPTENBGPI9INTEN { get; set; }
Public Property GPIINTERRUPTENBGPI9INTEN As Adp5585TypeGpiInterruptEn
    Get
    Set
public:
property Adp5585TypeGpiInterruptEn GPIINTERRUPTENBGPI9INTEN {
    Adp5585TypeGpiInterruptEn get ();
    void set (Adp5585TypeGpiInterruptEn value);
}
member GPIINTERRUPTENBGPI9INTEN : Adp5585TypeGpiInterruptEn with get, set

Property Value

Type: Adp5585TypeGpiInterruptEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTLEVELAGPI1INTLEVEL Property

IRD

Adp5585GPIINTLEVELAGPI1INTLEVEL Property

GPI_INT_LEVEL_A: GPI_1_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntLevel GPIINTLEVELAGPI1INTLEVEL { get; set; }
Public Property GPIINTLEVELAGPI1INTLEVEL As Adp5585TypeGpiIntLevel
    Get
    Set
public:
property Adp5585TypeGpiIntLevel GPIINTLEVELAGPI1INTLEVEL {
    Adp5585TypeGpiIntLevel get ();
    void set (Adp5585TypeGpiIntLevel value);
}
member GPIINTLEVELAGPI1INTLEVEL : Adp5585TypeGpiIntLevel with get, set

Property Value

Type: Adp5585TypeGpiIntLevel
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTLEVELAGPI2INTLEVEL Property

IRD

Adp5585GPIINTLEVELAGPI2INTLEVEL Property

GPI_INT_LEVEL_A: GPI_2_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntLevel GPIINTLEVELAGPI2INTLEVEL { get; set; }
Public Property GPIINTLEVELAGPI2INTLEVEL As Adp5585TypeGpiIntLevel
    Get
    Set
public:
property Adp5585TypeGpiIntLevel GPIINTLEVELAGPI2INTLEVEL {
    Adp5585TypeGpiIntLevel get ();
    void set (Adp5585TypeGpiIntLevel value);
}
member GPIINTLEVELAGPI2INTLEVEL : Adp5585TypeGpiIntLevel with get, set

Property Value

Type: Adp5585TypeGpiIntLevel
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTLEVELAGPI3INTLEVEL Property

IRD

Adp5585GPIINTLEVELAGPI3INTLEVEL Property

GPI_INT_LEVEL_A: GPI_3_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntLevel GPIINTLEVELAGPI3INTLEVEL { get; set; }
Public Property GPIINTLEVELAGPI3INTLEVEL As Adp5585TypeGpiIntLevel
    Get
    Set
public:
property Adp5585TypeGpiIntLevel GPIINTLEVELAGPI3INTLEVEL {
    Adp5585TypeGpiIntLevel get ();
    void set (Adp5585TypeGpiIntLevel value);
}
member GPIINTLEVELAGPI3INTLEVEL : Adp5585TypeGpiIntLevel with get, set

Property Value

Type: Adp5585TypeGpiIntLevel
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTLEVELAGPI4INTLEVEL Property

IRD

Adp5585GPIINTLEVELAGPI4INTLEVEL Property

GPI_INT_LEVEL_A: GPI_4_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntLevel GPIINTLEVELAGPI4INTLEVEL { get; set; }
Public Property GPIINTLEVELAGPI4INTLEVEL As Adp5585TypeGpiIntLevel
    Get
    Set
public:
property Adp5585TypeGpiIntLevel GPIINTLEVELAGPI4INTLEVEL {
    Adp5585TypeGpiIntLevel get ();
    void set (Adp5585TypeGpiIntLevel value);
}
member GPIINTLEVELAGPI4INTLEVEL : Adp5585TypeGpiIntLevel with get, set

Property Value

Type: Adp5585TypeGpiIntLevel
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTLEVELAGPI5INTLEVEL Property

IRD

Adp5585GPIINTLEVELAGPI5INTLEVEL Property

GPI_INT_LEVEL_A: GPI_5_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntLevel GPIINTLEVELAGPI5INTLEVEL { get; set; }
Public Property GPIINTLEVELAGPI5INTLEVEL As Adp5585TypeGpiIntLevel
    Get
    Set
public:
property Adp5585TypeGpiIntLevel GPIINTLEVELAGPI5INTLEVEL {
    Adp5585TypeGpiIntLevel get ();
    void set (Adp5585TypeGpiIntLevel value);
}
member GPIINTLEVELAGPI5INTLEVEL : Adp5585TypeGpiIntLevel with get, set

Property Value

Type: Adp5585TypeGpiIntLevel
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTLEVELAGPI6INTLEVEL Property

IRD

Adp5585GPIINTLEVELAGPI6INTLEVEL Property

GPI_INT_LEVEL_A: GPI_6_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntLevel GPIINTLEVELAGPI6INTLEVEL { get; set; }
Public Property GPIINTLEVELAGPI6INTLEVEL As Adp5585TypeGpiIntLevel
    Get
    Set
public:
property Adp5585TypeGpiIntLevel GPIINTLEVELAGPI6INTLEVEL {
    Adp5585TypeGpiIntLevel get ();
    void set (Adp5585TypeGpiIntLevel value);
}
member GPIINTLEVELAGPI6INTLEVEL : Adp5585TypeGpiIntLevel with get, set

Property Value

Type: Adp5585TypeGpiIntLevel
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTLEVELBGPI10INTLEVEL Property

IRD

Adp5585GPIINTLEVELBGPI10INTLEVEL Property

GPI_INT_LEVEL_B: GPI_10_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntLevel GPIINTLEVELBGPI10INTLEVEL { get; set; }
Public Property GPIINTLEVELBGPI10INTLEVEL As Adp5585TypeGpiIntLevel
    Get
    Set
public:
property Adp5585TypeGpiIntLevel GPIINTLEVELBGPI10INTLEVEL {
    Adp5585TypeGpiIntLevel get ();
    void set (Adp5585TypeGpiIntLevel value);
}
member GPIINTLEVELBGPI10INTLEVEL : Adp5585TypeGpiIntLevel with get, set

Property Value

Type: Adp5585TypeGpiIntLevel
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTLEVELBGPI11INTLEVEL Property

IRD

Adp5585GPIINTLEVELBGPI11INTLEVEL Property

GPI_INT_LEVEL_B: GPI_11_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntLevel GPIINTLEVELBGPI11INTLEVEL { get; set; }
Public Property GPIINTLEVELBGPI11INTLEVEL As Adp5585TypeGpiIntLevel
    Get
    Set
public:
property Adp5585TypeGpiIntLevel GPIINTLEVELBGPI11INTLEVEL {
    Adp5585TypeGpiIntLevel get ();
    void set (Adp5585TypeGpiIntLevel value);
}
member GPIINTLEVELBGPI11INTLEVEL : Adp5585TypeGpiIntLevel with get, set

Property Value

Type: Adp5585TypeGpiIntLevel
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTLEVELBGPI7INTLEVEL Property

IRD

Adp5585GPIINTLEVELBGPI7INTLEVEL Property

GPI_INT_LEVEL_B: GPI_7_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntLevel GPIINTLEVELBGPI7INTLEVEL { get; set; }
Public Property GPIINTLEVELBGPI7INTLEVEL As Adp5585TypeGpiIntLevel
    Get
    Set
public:
property Adp5585TypeGpiIntLevel GPIINTLEVELBGPI7INTLEVEL {
    Adp5585TypeGpiIntLevel get ();
    void set (Adp5585TypeGpiIntLevel value);
}
member GPIINTLEVELBGPI7INTLEVEL : Adp5585TypeGpiIntLevel with get, set

Property Value

Type: Adp5585TypeGpiIntLevel
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTLEVELBGPI8INTLEVEL Property

IRD

Adp5585GPIINTLEVELBGPI8INTLEVEL Property

GPI_INT_LEVEL_B: GPI_8_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntLevel GPIINTLEVELBGPI8INTLEVEL { get; set; }
Public Property GPIINTLEVELBGPI8INTLEVEL As Adp5585TypeGpiIntLevel
    Get
    Set
public:
property Adp5585TypeGpiIntLevel GPIINTLEVELBGPI8INTLEVEL {
    Adp5585TypeGpiIntLevel get ();
    void set (Adp5585TypeGpiIntLevel value);
}
member GPIINTLEVELBGPI8INTLEVEL : Adp5585TypeGpiIntLevel with get, set

Property Value

Type: Adp5585TypeGpiIntLevel
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTLEVELBGPI9INTLEVEL Property

IRD

Adp5585GPIINTLEVELBGPI9INTLEVEL Property

GPI_INT_LEVEL_B: GPI_9_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntLevel GPIINTLEVELBGPI9INTLEVEL { get; set; }
Public Property GPIINTLEVELBGPI9INTLEVEL As Adp5585TypeGpiIntLevel
    Get
    Set
public:
property Adp5585TypeGpiIntLevel GPIINTLEVELBGPI9INTLEVEL {
    Adp5585TypeGpiIntLevel get ();
    void set (Adp5585TypeGpiIntLevel value);
}
member GPIINTLEVELBGPI9INTLEVEL : Adp5585TypeGpiIntLevel with get, set

Property Value

Type: Adp5585TypeGpiIntLevel
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTSTATAGPI1INT Property

IRD

Adp5585GPIINTSTATAGPI1INT Property

GPI_INT_STAT_A: GPI_1_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntStat GPIINTSTATAGPI1INT { get; }
Public ReadOnly Property GPIINTSTATAGPI1INT As Adp5585TypeGpiIntStat
    Get
public:
property Adp5585TypeGpiIntStat GPIINTSTATAGPI1INT {
    Adp5585TypeGpiIntStat get ();
}
member GPIINTSTATAGPI1INT : Adp5585TypeGpiIntStat with get

Property Value

Type: Adp5585TypeGpiIntStat
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTSTATAGPI2INT Property

IRD

Adp5585GPIINTSTATAGPI2INT Property

GPI_INT_STAT_A: GPI_2_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntStat GPIINTSTATAGPI2INT { get; }
Public ReadOnly Property GPIINTSTATAGPI2INT As Adp5585TypeGpiIntStat
    Get
public:
property Adp5585TypeGpiIntStat GPIINTSTATAGPI2INT {
    Adp5585TypeGpiIntStat get ();
}
member GPIINTSTATAGPI2INT : Adp5585TypeGpiIntStat with get

Property Value

Type: Adp5585TypeGpiIntStat
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTSTATAGPI3INT Property

IRD

Adp5585GPIINTSTATAGPI3INT Property

GPI_INT_STAT_A: GPI_3_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntStat GPIINTSTATAGPI3INT { get; }
Public ReadOnly Property GPIINTSTATAGPI3INT As Adp5585TypeGpiIntStat
    Get
public:
property Adp5585TypeGpiIntStat GPIINTSTATAGPI3INT {
    Adp5585TypeGpiIntStat get ();
}
member GPIINTSTATAGPI3INT : Adp5585TypeGpiIntStat with get

Property Value

Type: Adp5585TypeGpiIntStat
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTSTATAGPI4INT Property

IRD

Adp5585GPIINTSTATAGPI4INT Property

GPI_INT_STAT_A: GPI_4_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntStat GPIINTSTATAGPI4INT { get; }
Public ReadOnly Property GPIINTSTATAGPI4INT As Adp5585TypeGpiIntStat
    Get
public:
property Adp5585TypeGpiIntStat GPIINTSTATAGPI4INT {
    Adp5585TypeGpiIntStat get ();
}
member GPIINTSTATAGPI4INT : Adp5585TypeGpiIntStat with get

Property Value

Type: Adp5585TypeGpiIntStat
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTSTATAGPI5INT Property

IRD

Adp5585GPIINTSTATAGPI5INT Property

GPI_INT_STAT_A: GPI_5_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntStat GPIINTSTATAGPI5INT { get; }
Public ReadOnly Property GPIINTSTATAGPI5INT As Adp5585TypeGpiIntStat
    Get
public:
property Adp5585TypeGpiIntStat GPIINTSTATAGPI5INT {
    Adp5585TypeGpiIntStat get ();
}
member GPIINTSTATAGPI5INT : Adp5585TypeGpiIntStat with get

Property Value

Type: Adp5585TypeGpiIntStat
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTSTATAGPI6INT Property

IRD

Adp5585GPIINTSTATAGPI6INT Property

GPI_INT_STAT_A: GPI_6_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntStat GPIINTSTATAGPI6INT { get; }
Public ReadOnly Property GPIINTSTATAGPI6INT As Adp5585TypeGpiIntStat
    Get
public:
property Adp5585TypeGpiIntStat GPIINTSTATAGPI6INT {
    Adp5585TypeGpiIntStat get ();
}
member GPIINTSTATAGPI6INT : Adp5585TypeGpiIntStat with get

Property Value

Type: Adp5585TypeGpiIntStat
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTSTATBGPI10INT Property

IRD

Adp5585GPIINTSTATBGPI10INT Property

GPI_INT_STAT_B: GPI_10_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntStat GPIINTSTATBGPI10INT { get; }
Public ReadOnly Property GPIINTSTATBGPI10INT As Adp5585TypeGpiIntStat
    Get
public:
property Adp5585TypeGpiIntStat GPIINTSTATBGPI10INT {
    Adp5585TypeGpiIntStat get ();
}
member GPIINTSTATBGPI10INT : Adp5585TypeGpiIntStat with get

Property Value

Type: Adp5585TypeGpiIntStat
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTSTATBGPI11INT Property

IRD

Adp5585GPIINTSTATBGPI11INT Property

GPI_INT_STAT_B: GPI_11_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntStat GPIINTSTATBGPI11INT { get; }
Public ReadOnly Property GPIINTSTATBGPI11INT As Adp5585TypeGpiIntStat
    Get
public:
property Adp5585TypeGpiIntStat GPIINTSTATBGPI11INT {
    Adp5585TypeGpiIntStat get ();
}
member GPIINTSTATBGPI11INT : Adp5585TypeGpiIntStat with get

Property Value

Type: Adp5585TypeGpiIntStat
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTSTATBGPI7INT Property

IRD

Adp5585GPIINTSTATBGPI7INT Property

GPI_INT_STAT_B: GPI_7_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntStat GPIINTSTATBGPI7INT { get; }
Public ReadOnly Property GPIINTSTATBGPI7INT As Adp5585TypeGpiIntStat
    Get
public:
property Adp5585TypeGpiIntStat GPIINTSTATBGPI7INT {
    Adp5585TypeGpiIntStat get ();
}
member GPIINTSTATBGPI7INT : Adp5585TypeGpiIntStat with get

Property Value

Type: Adp5585TypeGpiIntStat
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTSTATBGPI8INT Property

IRD

Adp5585GPIINTSTATBGPI8INT Property

GPI_INT_STAT_B: GPI_8_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntStat GPIINTSTATBGPI8INT { get; }
Public ReadOnly Property GPIINTSTATBGPI8INT As Adp5585TypeGpiIntStat
    Get
public:
property Adp5585TypeGpiIntStat GPIINTSTATBGPI8INT {
    Adp5585TypeGpiIntStat get ();
}
member GPIINTSTATBGPI8INT : Adp5585TypeGpiIntStat with get

Property Value

Type: Adp5585TypeGpiIntStat
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIINTSTATBGPI9INT Property

IRD

Adp5585GPIINTSTATBGPI9INT Property

GPI_INT_STAT_B: GPI_9_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiIntStat GPIINTSTATBGPI9INT { get; }
Public ReadOnly Property GPIINTSTATBGPI9INT As Adp5585TypeGpiIntStat
    Get
public:
property Adp5585TypeGpiIntStat GPIINTSTATBGPI9INT {
    Adp5585TypeGpiIntStat get ();
}
member GPIINTSTATBGPI9INT : Adp5585TypeGpiIntStat with get

Property Value

Type: Adp5585TypeGpiIntStat
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIODIRECTIONAGPIO1DIR Property

IRD

Adp5585GPIODIRECTIONAGPIO1DIR Property

GPIO_DIRECTION_A: GPIO_1_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpioDirection GPIODIRECTIONAGPIO1DIR { get; set; }
Public Property GPIODIRECTIONAGPIO1DIR As Adp5585TypeGpioDirection
    Get
    Set
public:
property Adp5585TypeGpioDirection GPIODIRECTIONAGPIO1DIR {
    Adp5585TypeGpioDirection get ();
    void set (Adp5585TypeGpioDirection value);
}
member GPIODIRECTIONAGPIO1DIR : Adp5585TypeGpioDirection with get, set

Property Value

Type: Adp5585TypeGpioDirection
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIODIRECTIONAGPIO2DIR Property

IRD

Adp5585GPIODIRECTIONAGPIO2DIR Property

GPIO_DIRECTION_A: GPIO_2_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpioDirection GPIODIRECTIONAGPIO2DIR { get; set; }
Public Property GPIODIRECTIONAGPIO2DIR As Adp5585TypeGpioDirection
    Get
    Set
public:
property Adp5585TypeGpioDirection GPIODIRECTIONAGPIO2DIR {
    Adp5585TypeGpioDirection get ();
    void set (Adp5585TypeGpioDirection value);
}
member GPIODIRECTIONAGPIO2DIR : Adp5585TypeGpioDirection with get, set

Property Value

Type: Adp5585TypeGpioDirection
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIODIRECTIONAGPIO3DIR Property

IRD

Adp5585GPIODIRECTIONAGPIO3DIR Property

GPIO_DIRECTION_A: GPIO_3_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpioDirection GPIODIRECTIONAGPIO3DIR { get; set; }
Public Property GPIODIRECTIONAGPIO3DIR As Adp5585TypeGpioDirection
    Get
    Set
public:
property Adp5585TypeGpioDirection GPIODIRECTIONAGPIO3DIR {
    Adp5585TypeGpioDirection get ();
    void set (Adp5585TypeGpioDirection value);
}
member GPIODIRECTIONAGPIO3DIR : Adp5585TypeGpioDirection with get, set

Property Value

Type: Adp5585TypeGpioDirection
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIODIRECTIONAGPIO4DIR Property

IRD

Adp5585GPIODIRECTIONAGPIO4DIR Property

GPIO_DIRECTION_A: GPIO_4_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpioDirection GPIODIRECTIONAGPIO4DIR { get; set; }
Public Property GPIODIRECTIONAGPIO4DIR As Adp5585TypeGpioDirection
    Get
    Set
public:
property Adp5585TypeGpioDirection GPIODIRECTIONAGPIO4DIR {
    Adp5585TypeGpioDirection get ();
    void set (Adp5585TypeGpioDirection value);
}
member GPIODIRECTIONAGPIO4DIR : Adp5585TypeGpioDirection with get, set

Property Value

Type: Adp5585TypeGpioDirection
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIODIRECTIONAGPIO5DIR Property

IRD

Adp5585GPIODIRECTIONAGPIO5DIR Property

GPIO_DIRECTION_A: GPIO_5_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpioDirection GPIODIRECTIONAGPIO5DIR { get; set; }
Public Property GPIODIRECTIONAGPIO5DIR As Adp5585TypeGpioDirection
    Get
    Set
public:
property Adp5585TypeGpioDirection GPIODIRECTIONAGPIO5DIR {
    Adp5585TypeGpioDirection get ();
    void set (Adp5585TypeGpioDirection value);
}
member GPIODIRECTIONAGPIO5DIR : Adp5585TypeGpioDirection with get, set

Property Value

Type: Adp5585TypeGpioDirection
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIODIRECTIONAGPIO6DIR Property

IRD

Adp5585GPIODIRECTIONAGPIO6DIR Property

GPIO_DIRECTION_A: GPIO_6_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpioDirection GPIODIRECTIONAGPIO6DIR { get; set; }
Public Property GPIODIRECTIONAGPIO6DIR As Adp5585TypeGpioDirection
    Get
    Set
public:
property Adp5585TypeGpioDirection GPIODIRECTIONAGPIO6DIR {
    Adp5585TypeGpioDirection get ();
    void set (Adp5585TypeGpioDirection value);
}
member GPIODIRECTIONAGPIO6DIR : Adp5585TypeGpioDirection with get, set

Property Value

Type: Adp5585TypeGpioDirection
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIODIRECTIONBGPIO10DIR Property

IRD

Adp5585GPIODIRECTIONBGPIO10DIR Property

GPIO_DIRECTION_B: GPIO_10_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpioDirection GPIODIRECTIONBGPIO10DIR { get; set; }
Public Property GPIODIRECTIONBGPIO10DIR As Adp5585TypeGpioDirection
    Get
    Set
public:
property Adp5585TypeGpioDirection GPIODIRECTIONBGPIO10DIR {
    Adp5585TypeGpioDirection get ();
    void set (Adp5585TypeGpioDirection value);
}
member GPIODIRECTIONBGPIO10DIR : Adp5585TypeGpioDirection with get, set

Property Value

Type: Adp5585TypeGpioDirection
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIODIRECTIONBGPIO11DIR Property

IRD

Adp5585GPIODIRECTIONBGPIO11DIR Property

GPIO_DIRECTION_B: GPIO_11_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpioDirection GPIODIRECTIONBGPIO11DIR { get; set; }
Public Property GPIODIRECTIONBGPIO11DIR As Adp5585TypeGpioDirection
    Get
    Set
public:
property Adp5585TypeGpioDirection GPIODIRECTIONBGPIO11DIR {
    Adp5585TypeGpioDirection get ();
    void set (Adp5585TypeGpioDirection value);
}
member GPIODIRECTIONBGPIO11DIR : Adp5585TypeGpioDirection with get, set

Property Value

Type: Adp5585TypeGpioDirection
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIODIRECTIONBGPIO7DIR Property

IRD

Adp5585GPIODIRECTIONBGPIO7DIR Property

GPIO_DIRECTION_B: GPIO_7_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpioDirection GPIODIRECTIONBGPIO7DIR { get; set; }
Public Property GPIODIRECTIONBGPIO7DIR As Adp5585TypeGpioDirection
    Get
    Set
public:
property Adp5585TypeGpioDirection GPIODIRECTIONBGPIO7DIR {
    Adp5585TypeGpioDirection get ();
    void set (Adp5585TypeGpioDirection value);
}
member GPIODIRECTIONBGPIO7DIR : Adp5585TypeGpioDirection with get, set

Property Value

Type: Adp5585TypeGpioDirection
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIODIRECTIONBGPIO8DIR Property

IRD

Adp5585GPIODIRECTIONBGPIO8DIR Property

GPIO_DIRECTION_B: GPIO_8_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpioDirection GPIODIRECTIONBGPIO8DIR { get; set; }
Public Property GPIODIRECTIONBGPIO8DIR As Adp5585TypeGpioDirection
    Get
    Set
public:
property Adp5585TypeGpioDirection GPIODIRECTIONBGPIO8DIR {
    Adp5585TypeGpioDirection get ();
    void set (Adp5585TypeGpioDirection value);
}
member GPIODIRECTIONBGPIO8DIR : Adp5585TypeGpioDirection with get, set

Property Value

Type: Adp5585TypeGpioDirection
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPIODIRECTIONBGPIO9DIR Property

IRD

Adp5585GPIODIRECTIONBGPIO9DIR Property

GPIO_DIRECTION_B: GPIO_9_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpioDirection GPIODIRECTIONBGPIO9DIR { get; set; }
Public Property GPIODIRECTIONBGPIO9DIR As Adp5585TypeGpioDirection
    Get
    Set
public:
property Adp5585TypeGpioDirection GPIODIRECTIONBGPIO9DIR {
    Adp5585TypeGpioDirection get ();
    void set (Adp5585TypeGpioDirection value);
}
member GPIODIRECTIONBGPIO9DIR : Adp5585TypeGpioDirection with get, set

Property Value

Type: Adp5585TypeGpioDirection
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPISTATUSAGPI1STAT Property

IRD

Adp5585GPISTATUSAGPI1STAT Property

GPI_STATUS_A: GPI_1_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiStatus GPISTATUSAGPI1STAT { get; }
Public ReadOnly Property GPISTATUSAGPI1STAT As Adp5585TypeGpiStatus
    Get
public:
property Adp5585TypeGpiStatus GPISTATUSAGPI1STAT {
    Adp5585TypeGpiStatus get ();
}
member GPISTATUSAGPI1STAT : Adp5585TypeGpiStatus with get

Property Value

Type: Adp5585TypeGpiStatus
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPISTATUSAGPI2STAT Property

IRD

Adp5585GPISTATUSAGPI2STAT Property

GPI_STATUS_A: GPI_2_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiStatus GPISTATUSAGPI2STAT { get; }
Public ReadOnly Property GPISTATUSAGPI2STAT As Adp5585TypeGpiStatus
    Get
public:
property Adp5585TypeGpiStatus GPISTATUSAGPI2STAT {
    Adp5585TypeGpiStatus get ();
}
member GPISTATUSAGPI2STAT : Adp5585TypeGpiStatus with get

Property Value

Type: Adp5585TypeGpiStatus
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPISTATUSAGPI3STAT Property

IRD

Adp5585GPISTATUSAGPI3STAT Property

GPI_STATUS_A: GPI_3_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiStatus GPISTATUSAGPI3STAT { get; }
Public ReadOnly Property GPISTATUSAGPI3STAT As Adp5585TypeGpiStatus
    Get
public:
property Adp5585TypeGpiStatus GPISTATUSAGPI3STAT {
    Adp5585TypeGpiStatus get ();
}
member GPISTATUSAGPI3STAT : Adp5585TypeGpiStatus with get

Property Value

Type: Adp5585TypeGpiStatus
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPISTATUSAGPI4STAT Property

IRD

Adp5585GPISTATUSAGPI4STAT Property

GPI_STATUS_A: GPI_4_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiStatus GPISTATUSAGPI4STAT { get; }
Public ReadOnly Property GPISTATUSAGPI4STAT As Adp5585TypeGpiStatus
    Get
public:
property Adp5585TypeGpiStatus GPISTATUSAGPI4STAT {
    Adp5585TypeGpiStatus get ();
}
member GPISTATUSAGPI4STAT : Adp5585TypeGpiStatus with get

Property Value

Type: Adp5585TypeGpiStatus
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPISTATUSAGPI5STAT Property

IRD

Adp5585GPISTATUSAGPI5STAT Property

GPI_STATUS_A: GPI_5_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiStatus GPISTATUSAGPI5STAT { get; }
Public ReadOnly Property GPISTATUSAGPI5STAT As Adp5585TypeGpiStatus
    Get
public:
property Adp5585TypeGpiStatus GPISTATUSAGPI5STAT {
    Adp5585TypeGpiStatus get ();
}
member GPISTATUSAGPI5STAT : Adp5585TypeGpiStatus with get

Property Value

Type: Adp5585TypeGpiStatus
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPISTATUSAGPI6STAT Property

IRD

Adp5585GPISTATUSAGPI6STAT Property

GPI_STATUS_A: GPI_6_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiStatus GPISTATUSAGPI6STAT { get; }
Public ReadOnly Property GPISTATUSAGPI6STAT As Adp5585TypeGpiStatus
    Get
public:
property Adp5585TypeGpiStatus GPISTATUSAGPI6STAT {
    Adp5585TypeGpiStatus get ();
}
member GPISTATUSAGPI6STAT : Adp5585TypeGpiStatus with get

Property Value

Type: Adp5585TypeGpiStatus
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPISTATUSBGPI10STAT Property

IRD

Adp5585GPISTATUSBGPI10STAT Property

GPI_STATUS_B: GPI_10_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiStatus GPISTATUSBGPI10STAT { get; }
Public ReadOnly Property GPISTATUSBGPI10STAT As Adp5585TypeGpiStatus
    Get
public:
property Adp5585TypeGpiStatus GPISTATUSBGPI10STAT {
    Adp5585TypeGpiStatus get ();
}
member GPISTATUSBGPI10STAT : Adp5585TypeGpiStatus with get

Property Value

Type: Adp5585TypeGpiStatus
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPISTATUSBGPI11STAT Property

IRD

Adp5585GPISTATUSBGPI11STAT Property

GPI_STATUS_B: GPI_11_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiStatus GPISTATUSBGPI11STAT { get; }
Public ReadOnly Property GPISTATUSBGPI11STAT As Adp5585TypeGpiStatus
    Get
public:
property Adp5585TypeGpiStatus GPISTATUSBGPI11STAT {
    Adp5585TypeGpiStatus get ();
}
member GPISTATUSBGPI11STAT : Adp5585TypeGpiStatus with get

Property Value

Type: Adp5585TypeGpiStatus
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPISTATUSBGPI7STAT Property

IRD

Adp5585GPISTATUSBGPI7STAT Property

GPI_STATUS_B: GPI_7_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiStatus GPISTATUSBGPI7STAT { get; }
Public ReadOnly Property GPISTATUSBGPI7STAT As Adp5585TypeGpiStatus
    Get
public:
property Adp5585TypeGpiStatus GPISTATUSBGPI7STAT {
    Adp5585TypeGpiStatus get ();
}
member GPISTATUSBGPI7STAT : Adp5585TypeGpiStatus with get

Property Value

Type: Adp5585TypeGpiStatus
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPISTATUSBGPI8STAT Property

IRD

Adp5585GPISTATUSBGPI8STAT Property

GPI_STATUS_B: GPI_8_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiStatus GPISTATUSBGPI8STAT { get; }
Public ReadOnly Property GPISTATUSBGPI8STAT As Adp5585TypeGpiStatus
    Get
public:
property Adp5585TypeGpiStatus GPISTATUSBGPI8STAT {
    Adp5585TypeGpiStatus get ();
}
member GPISTATUSBGPI8STAT : Adp5585TypeGpiStatus with get

Property Value

Type: Adp5585TypeGpiStatus
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPISTATUSBGPI9STAT Property

IRD

Adp5585GPISTATUSBGPI9STAT Property

GPI_STATUS_B: GPI_9_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpiStatus GPISTATUSBGPI9STAT { get; }
Public ReadOnly Property GPISTATUSBGPI9STAT As Adp5585TypeGpiStatus
    Get
public:
property Adp5585TypeGpiStatus GPISTATUSBGPI9STAT {
    Adp5585TypeGpiStatus get ();
}
member GPISTATUSBGPI9STAT : Adp5585TypeGpiStatus with get

Property Value

Type: Adp5585TypeGpiStatus
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPODATAOUTAGPO1DATA Property

IRD

Adp5585GPODATAOUTAGPO1DATA Property

GPO_DATA_OUT_A: GPO_1_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoDataOut GPODATAOUTAGPO1DATA { get; set; }
Public Property GPODATAOUTAGPO1DATA As Adp5585TypeGpoDataOut
    Get
    Set
public:
property Adp5585TypeGpoDataOut GPODATAOUTAGPO1DATA {
    Adp5585TypeGpoDataOut get ();
    void set (Adp5585TypeGpoDataOut value);
}
member GPODATAOUTAGPO1DATA : Adp5585TypeGpoDataOut with get, set

Property Value

Type: Adp5585TypeGpoDataOut
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPODATAOUTAGPO2DATA Property

IRD

Adp5585GPODATAOUTAGPO2DATA Property

GPO_DATA_OUT_A: GPO_2_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoDataOut GPODATAOUTAGPO2DATA { get; set; }
Public Property GPODATAOUTAGPO2DATA As Adp5585TypeGpoDataOut
    Get
    Set
public:
property Adp5585TypeGpoDataOut GPODATAOUTAGPO2DATA {
    Adp5585TypeGpoDataOut get ();
    void set (Adp5585TypeGpoDataOut value);
}
member GPODATAOUTAGPO2DATA : Adp5585TypeGpoDataOut with get, set

Property Value

Type: Adp5585TypeGpoDataOut
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPODATAOUTAGPO3DATA Property

IRD

Adp5585GPODATAOUTAGPO3DATA Property

GPO_DATA_OUT_A: GPO_3_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoDataOut GPODATAOUTAGPO3DATA { get; set; }
Public Property GPODATAOUTAGPO3DATA As Adp5585TypeGpoDataOut
    Get
    Set
public:
property Adp5585TypeGpoDataOut GPODATAOUTAGPO3DATA {
    Adp5585TypeGpoDataOut get ();
    void set (Adp5585TypeGpoDataOut value);
}
member GPODATAOUTAGPO3DATA : Adp5585TypeGpoDataOut with get, set

Property Value

Type: Adp5585TypeGpoDataOut
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPODATAOUTAGPO4DATA Property

IRD

Adp5585GPODATAOUTAGPO4DATA Property

GPO_DATA_OUT_A: GPO_4_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoDataOut GPODATAOUTAGPO4DATA { get; set; }
Public Property GPODATAOUTAGPO4DATA As Adp5585TypeGpoDataOut
    Get
    Set
public:
property Adp5585TypeGpoDataOut GPODATAOUTAGPO4DATA {
    Adp5585TypeGpoDataOut get ();
    void set (Adp5585TypeGpoDataOut value);
}
member GPODATAOUTAGPO4DATA : Adp5585TypeGpoDataOut with get, set

Property Value

Type: Adp5585TypeGpoDataOut
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPODATAOUTAGPO5DATA Property

IRD

Adp5585GPODATAOUTAGPO5DATA Property

GPO_DATA_OUT_A: GPO_5_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoDataOut GPODATAOUTAGPO5DATA { get; set; }
Public Property GPODATAOUTAGPO5DATA As Adp5585TypeGpoDataOut
    Get
    Set
public:
property Adp5585TypeGpoDataOut GPODATAOUTAGPO5DATA {
    Adp5585TypeGpoDataOut get ();
    void set (Adp5585TypeGpoDataOut value);
}
member GPODATAOUTAGPO5DATA : Adp5585TypeGpoDataOut with get, set

Property Value

Type: Adp5585TypeGpoDataOut
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPODATAOUTAGPO6DATA Property

IRD

Adp5585GPODATAOUTAGPO6DATA Property

GPO_DATA_OUT_A: GPO_6_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoDataOut GPODATAOUTAGPO6DATA { get; set; }
Public Property GPODATAOUTAGPO6DATA As Adp5585TypeGpoDataOut
    Get
    Set
public:
property Adp5585TypeGpoDataOut GPODATAOUTAGPO6DATA {
    Adp5585TypeGpoDataOut get ();
    void set (Adp5585TypeGpoDataOut value);
}
member GPODATAOUTAGPO6DATA : Adp5585TypeGpoDataOut with get, set

Property Value

Type: Adp5585TypeGpoDataOut
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPODATAOUTBGPO10DATA Property

IRD

Adp5585GPODATAOUTBGPO10DATA Property

GPO_DATA_OUT_B: GPO_10_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoDataOut GPODATAOUTBGPO10DATA { get; set; }
Public Property GPODATAOUTBGPO10DATA As Adp5585TypeGpoDataOut
    Get
    Set
public:
property Adp5585TypeGpoDataOut GPODATAOUTBGPO10DATA {
    Adp5585TypeGpoDataOut get ();
    void set (Adp5585TypeGpoDataOut value);
}
member GPODATAOUTBGPO10DATA : Adp5585TypeGpoDataOut with get, set

Property Value

Type: Adp5585TypeGpoDataOut
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPODATAOUTBGPO11DATA Property

IRD

Adp5585GPODATAOUTBGPO11DATA Property

GPO_DATA_OUT_B: GPO_11_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoDataOut GPODATAOUTBGPO11DATA { get; set; }
Public Property GPODATAOUTBGPO11DATA As Adp5585TypeGpoDataOut
    Get
    Set
public:
property Adp5585TypeGpoDataOut GPODATAOUTBGPO11DATA {
    Adp5585TypeGpoDataOut get ();
    void set (Adp5585TypeGpoDataOut value);
}
member GPODATAOUTBGPO11DATA : Adp5585TypeGpoDataOut with get, set

Property Value

Type: Adp5585TypeGpoDataOut
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPODATAOUTBGPO7DATA Property

IRD

Adp5585GPODATAOUTBGPO7DATA Property

GPO_DATA_OUT_B: GPO_7_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoDataOut GPODATAOUTBGPO7DATA { get; set; }
Public Property GPODATAOUTBGPO7DATA As Adp5585TypeGpoDataOut
    Get
    Set
public:
property Adp5585TypeGpoDataOut GPODATAOUTBGPO7DATA {
    Adp5585TypeGpoDataOut get ();
    void set (Adp5585TypeGpoDataOut value);
}
member GPODATAOUTBGPO7DATA : Adp5585TypeGpoDataOut with get, set

Property Value

Type: Adp5585TypeGpoDataOut
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPODATAOUTBGPO8DATA Property

IRD

Adp5585GPODATAOUTBGPO8DATA Property

GPO_DATA_OUT_B: GPO_8_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoDataOut GPODATAOUTBGPO8DATA { get; set; }
Public Property GPODATAOUTBGPO8DATA As Adp5585TypeGpoDataOut
    Get
    Set
public:
property Adp5585TypeGpoDataOut GPODATAOUTBGPO8DATA {
    Adp5585TypeGpoDataOut get ();
    void set (Adp5585TypeGpoDataOut value);
}
member GPODATAOUTBGPO8DATA : Adp5585TypeGpoDataOut with get, set

Property Value

Type: Adp5585TypeGpoDataOut
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPODATAOUTBGPO9DATA Property

IRD

Adp5585GPODATAOUTBGPO9DATA Property

GPO_DATA_OUT_B: GPO_9_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoDataOut GPODATAOUTBGPO9DATA { get; set; }
Public Property GPODATAOUTBGPO9DATA As Adp5585TypeGpoDataOut
    Get
    Set
public:
property Adp5585TypeGpoDataOut GPODATAOUTBGPO9DATA {
    Adp5585TypeGpoDataOut get ();
    void set (Adp5585TypeGpoDataOut value);
}
member GPODATAOUTBGPO9DATA : Adp5585TypeGpoDataOut with get, set

Property Value

Type: Adp5585TypeGpoDataOut
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPOOUTMODEAGPO1OUTMODE Property

IRD

Adp5585GPOOUTMODEAGPO1OUTMODE Property

GPO_OUT_MODE_A: GPO_1_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoOutMode GPOOUTMODEAGPO1OUTMODE { get; set; }
Public Property GPOOUTMODEAGPO1OUTMODE As Adp5585TypeGpoOutMode
    Get
    Set
public:
property Adp5585TypeGpoOutMode GPOOUTMODEAGPO1OUTMODE {
    Adp5585TypeGpoOutMode get ();
    void set (Adp5585TypeGpoOutMode value);
}
member GPOOUTMODEAGPO1OUTMODE : Adp5585TypeGpoOutMode with get, set

Property Value

Type: Adp5585TypeGpoOutMode
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPOOUTMODEAGPO2OUTMODE Property

IRD

Adp5585GPOOUTMODEAGPO2OUTMODE Property

GPO_OUT_MODE_A: GPO_2_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoOutMode GPOOUTMODEAGPO2OUTMODE { get; set; }
Public Property GPOOUTMODEAGPO2OUTMODE As Adp5585TypeGpoOutMode
    Get
    Set
public:
property Adp5585TypeGpoOutMode GPOOUTMODEAGPO2OUTMODE {
    Adp5585TypeGpoOutMode get ();
    void set (Adp5585TypeGpoOutMode value);
}
member GPOOUTMODEAGPO2OUTMODE : Adp5585TypeGpoOutMode with get, set

Property Value

Type: Adp5585TypeGpoOutMode
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPOOUTMODEAGPO3OUTMODE Property

IRD

Adp5585GPOOUTMODEAGPO3OUTMODE Property

GPO_OUT_MODE_A: GPO_3_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoOutMode GPOOUTMODEAGPO3OUTMODE { get; set; }
Public Property GPOOUTMODEAGPO3OUTMODE As Adp5585TypeGpoOutMode
    Get
    Set
public:
property Adp5585TypeGpoOutMode GPOOUTMODEAGPO3OUTMODE {
    Adp5585TypeGpoOutMode get ();
    void set (Adp5585TypeGpoOutMode value);
}
member GPOOUTMODEAGPO3OUTMODE : Adp5585TypeGpoOutMode with get, set

Property Value

Type: Adp5585TypeGpoOutMode
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPOOUTMODEAGPO4OUTMODE Property

IRD

Adp5585GPOOUTMODEAGPO4OUTMODE Property

GPO_OUT_MODE_A: GPO_4_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoOutMode GPOOUTMODEAGPO4OUTMODE { get; set; }
Public Property GPOOUTMODEAGPO4OUTMODE As Adp5585TypeGpoOutMode
    Get
    Set
public:
property Adp5585TypeGpoOutMode GPOOUTMODEAGPO4OUTMODE {
    Adp5585TypeGpoOutMode get ();
    void set (Adp5585TypeGpoOutMode value);
}
member GPOOUTMODEAGPO4OUTMODE : Adp5585TypeGpoOutMode with get, set

Property Value

Type: Adp5585TypeGpoOutMode
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPOOUTMODEAGPO5OUTMODE Property

IRD

Adp5585GPOOUTMODEAGPO5OUTMODE Property

GPO_OUT_MODE_A: GPO_5_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoOutMode GPOOUTMODEAGPO5OUTMODE { get; set; }
Public Property GPOOUTMODEAGPO5OUTMODE As Adp5585TypeGpoOutMode
    Get
    Set
public:
property Adp5585TypeGpoOutMode GPOOUTMODEAGPO5OUTMODE {
    Adp5585TypeGpoOutMode get ();
    void set (Adp5585TypeGpoOutMode value);
}
member GPOOUTMODEAGPO5OUTMODE : Adp5585TypeGpoOutMode with get, set

Property Value

Type: Adp5585TypeGpoOutMode
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPOOUTMODEAGPO6OUTMODE Property

IRD

Adp5585GPOOUTMODEAGPO6OUTMODE Property

GPO_OUT_MODE_A: GPO_6_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoOutMode GPOOUTMODEAGPO6OUTMODE { get; set; }
Public Property GPOOUTMODEAGPO6OUTMODE As Adp5585TypeGpoOutMode
    Get
    Set
public:
property Adp5585TypeGpoOutMode GPOOUTMODEAGPO6OUTMODE {
    Adp5585TypeGpoOutMode get ();
    void set (Adp5585TypeGpoOutMode value);
}
member GPOOUTMODEAGPO6OUTMODE : Adp5585TypeGpoOutMode with get, set

Property Value

Type: Adp5585TypeGpoOutMode
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPOOUTMODEBGPO10OUTMODE Property

IRD

Adp5585GPOOUTMODEBGPO10OUTMODE Property

GPO_OUT_MODE_B: GPO_10_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoOutMode GPOOUTMODEBGPO10OUTMODE { get; set; }
Public Property GPOOUTMODEBGPO10OUTMODE As Adp5585TypeGpoOutMode
    Get
    Set
public:
property Adp5585TypeGpoOutMode GPOOUTMODEBGPO10OUTMODE {
    Adp5585TypeGpoOutMode get ();
    void set (Adp5585TypeGpoOutMode value);
}
member GPOOUTMODEBGPO10OUTMODE : Adp5585TypeGpoOutMode with get, set

Property Value

Type: Adp5585TypeGpoOutMode
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPOOUTMODEBGPO11OUTMODE Property

IRD

Adp5585GPOOUTMODEBGPO11OUTMODE Property

GPO_OUT_MODE_B: GPO_11_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoOutMode GPOOUTMODEBGPO11OUTMODE { get; set; }
Public Property GPOOUTMODEBGPO11OUTMODE As Adp5585TypeGpoOutMode
    Get
    Set
public:
property Adp5585TypeGpoOutMode GPOOUTMODEBGPO11OUTMODE {
    Adp5585TypeGpoOutMode get ();
    void set (Adp5585TypeGpoOutMode value);
}
member GPOOUTMODEBGPO11OUTMODE : Adp5585TypeGpoOutMode with get, set

Property Value

Type: Adp5585TypeGpoOutMode
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPOOUTMODEBGPO7OUTMODE Property

IRD

Adp5585GPOOUTMODEBGPO7OUTMODE Property

GPO_OUT_MODE_B: GPO_7_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoOutMode GPOOUTMODEBGPO7OUTMODE { get; set; }
Public Property GPOOUTMODEBGPO7OUTMODE As Adp5585TypeGpoOutMode
    Get
    Set
public:
property Adp5585TypeGpoOutMode GPOOUTMODEBGPO7OUTMODE {
    Adp5585TypeGpoOutMode get ();
    void set (Adp5585TypeGpoOutMode value);
}
member GPOOUTMODEBGPO7OUTMODE : Adp5585TypeGpoOutMode with get, set

Property Value

Type: Adp5585TypeGpoOutMode
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPOOUTMODEBGPO8OUTMODE Property

IRD

Adp5585GPOOUTMODEBGPO8OUTMODE Property

GPO_OUT_MODE_B: GPO_8_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoOutMode GPOOUTMODEBGPO8OUTMODE { get; set; }
Public Property GPOOUTMODEBGPO8OUTMODE As Adp5585TypeGpoOutMode
    Get
    Set
public:
property Adp5585TypeGpoOutMode GPOOUTMODEBGPO8OUTMODE {
    Adp5585TypeGpoOutMode get ();
    void set (Adp5585TypeGpoOutMode value);
}
member GPOOUTMODEBGPO8OUTMODE : Adp5585TypeGpoOutMode with get, set

Property Value

Type: Adp5585TypeGpoOutMode
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.GPOOUTMODEBGPO9OUTMODE Property

IRD

Adp5585GPOOUTMODEBGPO9OUTMODE Property

GPO_OUT_MODE_B: GPO_9_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeGpoOutMode GPOOUTMODEBGPO9OUTMODE { get; set; }
Public Property GPOOUTMODEBGPO9OUTMODE As Adp5585TypeGpoOutMode
    Get
    Set
public:
property Adp5585TypeGpoOutMode GPOOUTMODEBGPO9OUTMODE {
    Adp5585TypeGpoOutMode get ();
    void set (Adp5585TypeGpoOutMode value);
}
member GPOOUTMODEBGPO9OUTMODE : Adp5585TypeGpoOutMode with get, set

Property Value

Type: Adp5585TypeGpoOutMode
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.IDMANID Property

IRD

Adp5585IDMANID Property

ID: MAN_ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IDMANID { get; }
Public ReadOnly Property IDMANID As Byte
    Get
public:
property unsigned char IDMANID {
    unsigned char get ();
}
member IDMANID : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.IDREVID Property

IRD

Adp5585IDREVID Property

ID: REV_ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IDREVID { get; }
Public ReadOnly Property IDREVID As Byte
    Get
public:
property unsigned char IDREVID {
    unsigned char get ();
}
member IDREVID : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.INTENEVENTIEN Property

IRD

Adp5585INTENEVENTIEN Property

INT_EN: EVENT_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeIntEn INTENEVENTIEN { get; set; }
Public Property INTENEVENTIEN As Adp5585TypeIntEn
    Get
    Set
public:
property Adp5585TypeIntEn INTENEVENTIEN {
    Adp5585TypeIntEn get ();
    void set (Adp5585TypeIntEn value);
}
member INTENEVENTIEN : Adp5585TypeIntEn with get, set

Property Value

Type: Adp5585TypeIntEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.INTENGPIIEN Property

IRD

Adp5585INTENGPIIEN Property

INT_EN: GPI_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeIntEn INTENGPIIEN { get; set; }
Public Property INTENGPIIEN As Adp5585TypeIntEn
    Get
    Set
public:
property Adp5585TypeIntEn INTENGPIIEN {
    Adp5585TypeIntEn get ();
    void set (Adp5585TypeIntEn value);
}
member INTENGPIIEN : Adp5585TypeIntEn with get, set

Property Value

Type: Adp5585TypeIntEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.INTENLOGICEN Property

IRD

Adp5585INTENLOGICEN Property

INT_EN: LOGIC_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeIntEn INTENLOGICEN { get; set; }
Public Property INTENLOGICEN As Adp5585TypeIntEn
    Get
    Set
public:
property Adp5585TypeIntEn INTENLOGICEN {
    Adp5585TypeIntEn get ();
    void set (Adp5585TypeIntEn value);
}
member INTENLOGICEN : Adp5585TypeIntEn with get, set

Property Value

Type: Adp5585TypeIntEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.INTENOVRFLOWIEN Property

IRD

Adp5585INTENOVRFLOWIEN Property

INT_EN: OVRFLOW_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeIntEn INTENOVRFLOWIEN { get; set; }
Public Property INTENOVRFLOWIEN As Adp5585TypeIntEn
    Get
    Set
public:
property Adp5585TypeIntEn INTENOVRFLOWIEN {
    Adp5585TypeIntEn get ();
    void set (Adp5585TypeIntEn value);
}
member INTENOVRFLOWIEN : Adp5585TypeIntEn with get, set

Property Value

Type: Adp5585TypeIntEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.INTSTATUSEVENTINT Property

IRD

Adp5585INTSTATUSEVENTINT Property

INT_STATUS: EVENT_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeIntStatus INTSTATUSEVENTINT { get; set; }
Public Property INTSTATUSEVENTINT As Adp5585TypeIntStatus
    Get
    Set
public:
property Adp5585TypeIntStatus INTSTATUSEVENTINT {
    Adp5585TypeIntStatus get ();
    void set (Adp5585TypeIntStatus value);
}
member INTSTATUSEVENTINT : Adp5585TypeIntStatus with get, set

Property Value

Type: Adp5585TypeIntStatus
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.INTSTATUSGPIINT Property

IRD

Adp5585INTSTATUSGPIINT Property

INT_STATUS: GPI_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeIntStatus INTSTATUSGPIINT { get; set; }
Public Property INTSTATUSGPIINT As Adp5585TypeIntStatus
    Get
    Set
public:
property Adp5585TypeIntStatus INTSTATUSGPIINT {
    Adp5585TypeIntStatus get ();
    void set (Adp5585TypeIntStatus value);
}
member INTSTATUSGPIINT : Adp5585TypeIntStatus with get, set

Property Value

Type: Adp5585TypeIntStatus
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.INTSTATUSLOGICINT Property

IRD

Adp5585INTSTATUSLOGICINT Property

INT_STATUS: LOGIC_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeIntStatus INTSTATUSLOGICINT { get; set; }
Public Property INTSTATUSLOGICINT As Adp5585TypeIntStatus
    Get
    Set
public:
property Adp5585TypeIntStatus INTSTATUSLOGICINT {
    Adp5585TypeIntStatus get ();
    void set (Adp5585TypeIntStatus value);
}
member INTSTATUSLOGICINT : Adp5585TypeIntStatus with get, set

Property Value

Type: Adp5585TypeIntStatus
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.INTSTATUSOVRFLOWINT Property

IRD

Adp5585INTSTATUSOVRFLOWINT Property

INT_STATUS: OVRFLOW_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeIntStatus INTSTATUSOVRFLOWINT { get; set; }
Public Property INTSTATUSOVRFLOWINT As Adp5585TypeIntStatus
    Get
    Set
public:
property Adp5585TypeIntStatus INTSTATUSOVRFLOWINT {
    Adp5585TypeIntStatus get ();
    void set (Adp5585TypeIntStatus value);
}
member INTSTATUSOVRFLOWINT : Adp5585TypeIntStatus with get, set

Property Value

Type: Adp5585TypeIntStatus
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.LOGICCFGLAINV Property

IRD

Adp5585LOGICCFGLAINV Property

LOGIC_CFG: LA_INV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeLogicCfgInv LOGICCFGLAINV { get; set; }
Public Property LOGICCFGLAINV As Adp5585TypeLogicCfgInv
    Get
    Set
public:
property Adp5585TypeLogicCfgInv LOGICCFGLAINV {
    Adp5585TypeLogicCfgInv get ();
    void set (Adp5585TypeLogicCfgInv value);
}
member LOGICCFGLAINV : Adp5585TypeLogicCfgInv with get, set

Property Value

Type: Adp5585TypeLogicCfgInv
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.LOGICCFGLBINV Property

IRD

Adp5585LOGICCFGLBINV Property

LOGIC_CFG: LB_INV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeLogicCfgInv LOGICCFGLBINV { get; set; }
Public Property LOGICCFGLBINV As Adp5585TypeLogicCfgInv
    Get
    Set
public:
property Adp5585TypeLogicCfgInv LOGICCFGLBINV {
    Adp5585TypeLogicCfgInv get ();
    void set (Adp5585TypeLogicCfgInv value);
}
member LOGICCFGLBINV : Adp5585TypeLogicCfgInv with get, set

Property Value

Type: Adp5585TypeLogicCfgInv
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.LOGICCFGLCINV Property

IRD

Adp5585LOGICCFGLCINV Property

LOGIC_CFG: LC_INV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeLogicCfgInv LOGICCFGLCINV { get; set; }
Public Property LOGICCFGLCINV As Adp5585TypeLogicCfgInv
    Get
    Set
public:
property Adp5585TypeLogicCfgInv LOGICCFGLCINV {
    Adp5585TypeLogicCfgInv get ();
    void set (Adp5585TypeLogicCfgInv value);
}
member LOGICCFGLCINV : Adp5585TypeLogicCfgInv with get, set

Property Value

Type: Adp5585TypeLogicCfgInv
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.LOGICCFGLOGICSEL Property

IRD

Adp5585LOGICCFGLOGICSEL Property

LOGIC_CFG: LOGIC_SEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeLogicCfgLogicSel LOGICCFGLOGICSEL { get; set; }
Public Property LOGICCFGLOGICSEL As Adp5585TypeLogicCfgLogicSel
    Get
    Set
public:
property Adp5585TypeLogicCfgLogicSel LOGICCFGLOGICSEL {
    Adp5585TypeLogicCfgLogicSel get ();
    void set (Adp5585TypeLogicCfgLogicSel value);
}
member LOGICCFGLOGICSEL : Adp5585TypeLogicCfgLogicSel with get, set

Property Value

Type: Adp5585TypeLogicCfgLogicSel
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.LOGICCFGLYINV Property

IRD

Adp5585LOGICCFGLYINV Property

LOGIC_CFG: LY_INV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeLogicCfgInv LOGICCFGLYINV { get; set; }
Public Property LOGICCFGLYINV As Adp5585TypeLogicCfgInv
    Get
    Set
public:
property Adp5585TypeLogicCfgInv LOGICCFGLYINV {
    Adp5585TypeLogicCfgInv get ();
    void set (Adp5585TypeLogicCfgInv value);
}
member LOGICCFGLYINV : Adp5585TypeLogicCfgInv with get, set

Property Value

Type: Adp5585TypeLogicCfgInv
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.LOGICFFCFGFFCLR Property

IRD

Adp5585LOGICFFCFGFFCLR Property

LOGIC_FF_CFG: FF_CLR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeLogicFfCfgClr LOGICFFCFGFFCLR { get; set; }
Public Property LOGICFFCFGFFCLR As Adp5585TypeLogicFfCfgClr
    Get
    Set
public:
property Adp5585TypeLogicFfCfgClr LOGICFFCFGFFCLR {
    Adp5585TypeLogicFfCfgClr get ();
    void set (Adp5585TypeLogicFfCfgClr value);
}
member LOGICFFCFGFFCLR : Adp5585TypeLogicFfCfgClr with get, set

Property Value

Type: Adp5585TypeLogicFfCfgClr
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.LOGICFFCFGFFSET Property

IRD

Adp5585LOGICFFCFGFFSET Property

LOGIC_FF_CFG: FF_SET

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeLogicFfCfgSet LOGICFFCFGFFSET { get; set; }
Public Property LOGICFFCFGFFSET As Adp5585TypeLogicFfCfgSet
    Get
    Set
public:
property Adp5585TypeLogicFfCfgSet LOGICFFCFGFFSET {
    Adp5585TypeLogicFfCfgSet get ();
    void set (Adp5585TypeLogicFfCfgSet value);
}
member LOGICFFCFGFFSET : Adp5585TypeLogicFfCfgSet with get, set

Property Value

Type: Adp5585TypeLogicFfCfgSet
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.LOGICINTEVENTENLOGICEVENTEN Property

IRD

Adp5585LOGICINTEVENTENLOGICEVENTEN Property

LOGIC_INT_EVENT_EN: LOGIC_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeLogicIntEventEnLogicEventEn LOGICINTEVENTENLOGICEVENTEN { get; set; }
Public Property LOGICINTEVENTENLOGICEVENTEN As Adp5585TypeLogicIntEventEnLogicEventEn
    Get
    Set
public:
property Adp5585TypeLogicIntEventEnLogicEventEn LOGICINTEVENTENLOGICEVENTEN {
    Adp5585TypeLogicIntEventEnLogicEventEn get ();
    void set (Adp5585TypeLogicIntEventEnLogicEventEn value);
}
member LOGICINTEVENTENLOGICEVENTEN : Adp5585TypeLogicIntEventEnLogicEventEn with get, set

Property Value

Type: Adp5585TypeLogicIntEventEnLogicEventEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.LOGICINTEVENTENLOGICINTLEVEL Property

IRD

Adp5585LOGICINTEVENTENLOGICINTLEVEL Property

LOGIC_INT_EVENT_EN: LOGIC_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeLogicIntEventEnLogicIntLevel LOGICINTEVENTENLOGICINTLEVEL { get; set; }
Public Property LOGICINTEVENTENLOGICINTLEVEL As Adp5585TypeLogicIntEventEnLogicIntLevel
    Get
    Set
public:
property Adp5585TypeLogicIntEventEnLogicIntLevel LOGICINTEVENTENLOGICINTLEVEL {
    Adp5585TypeLogicIntEventEnLogicIntLevel get ();
    void set (Adp5585TypeLogicIntEventEnLogicIntLevel value);
}
member LOGICINTEVENTENLOGICINTLEVEL : Adp5585TypeLogicIntEventEnLogicIntLevel with get, set

Property Value

Type: Adp5585TypeLogicIntEventEnLogicIntLevel
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.LOGICINTEVENTENLYDBNCDIS Property

IRD

Adp5585LOGICINTEVENTENLYDBNCDIS Property

LOGIC_INT_EVENT_EN: LY_DBNC_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeLogicIntEventEnLyDbncDis LOGICINTEVENTENLYDBNCDIS { get; set; }
Public Property LOGICINTEVENTENLYDBNCDIS As Adp5585TypeLogicIntEventEnLyDbncDis
    Get
    Set
public:
property Adp5585TypeLogicIntEventEnLyDbncDis LOGICINTEVENTENLYDBNCDIS {
    Adp5585TypeLogicIntEventEnLyDbncDis get ();
    void set (Adp5585TypeLogicIntEventEnLyDbncDis value);
}
member LOGICINTEVENTENLYDBNCDIS : Adp5585TypeLogicIntEventEnLyDbncDis with get, set

Property Value

Type: Adp5585TypeLogicIntEventEnLyDbncDis
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PINCONFIGAR0CONFIG Property

IRD

Adp5585PINCONFIGAR0CONFIG Property

PIN_CONFIG_A: R0_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePinConfigAR0Config PINCONFIGAR0CONFIG { get; set; }
Public Property PINCONFIGAR0CONFIG As Adp5585TypePinConfigAR0Config
    Get
    Set
public:
property Adp5585TypePinConfigAR0Config PINCONFIGAR0CONFIG {
    Adp5585TypePinConfigAR0Config get ();
    void set (Adp5585TypePinConfigAR0Config value);
}
member PINCONFIGAR0CONFIG : Adp5585TypePinConfigAR0Config with get, set

Property Value

Type: Adp5585TypePinConfigAR0Config
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PINCONFIGAR1CONFIG Property

IRD

Adp5585PINCONFIGAR1CONFIG Property

PIN_CONFIG_A: R1_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePinConfigAR1Config PINCONFIGAR1CONFIG { get; set; }
Public Property PINCONFIGAR1CONFIG As Adp5585TypePinConfigAR1Config
    Get
    Set
public:
property Adp5585TypePinConfigAR1Config PINCONFIGAR1CONFIG {
    Adp5585TypePinConfigAR1Config get ();
    void set (Adp5585TypePinConfigAR1Config value);
}
member PINCONFIGAR1CONFIG : Adp5585TypePinConfigAR1Config with get, set

Property Value

Type: Adp5585TypePinConfigAR1Config
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PINCONFIGAR2CONFIG Property

IRD

Adp5585PINCONFIGAR2CONFIG Property

PIN_CONFIG_A: R2_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePinConfigAR2Config PINCONFIGAR2CONFIG { get; set; }
Public Property PINCONFIGAR2CONFIG As Adp5585TypePinConfigAR2Config
    Get
    Set
public:
property Adp5585TypePinConfigAR2Config PINCONFIGAR2CONFIG {
    Adp5585TypePinConfigAR2Config get ();
    void set (Adp5585TypePinConfigAR2Config value);
}
member PINCONFIGAR2CONFIG : Adp5585TypePinConfigAR2Config with get, set

Property Value

Type: Adp5585TypePinConfigAR2Config
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PINCONFIGAR3CONFIG Property

IRD

Adp5585PINCONFIGAR3CONFIG Property

PIN_CONFIG_A: R3_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePinConfigAR3Config PINCONFIGAR3CONFIG { get; set; }
Public Property PINCONFIGAR3CONFIG As Adp5585TypePinConfigAR3Config
    Get
    Set
public:
property Adp5585TypePinConfigAR3Config PINCONFIGAR3CONFIG {
    Adp5585TypePinConfigAR3Config get ();
    void set (Adp5585TypePinConfigAR3Config value);
}
member PINCONFIGAR3CONFIG : Adp5585TypePinConfigAR3Config with get, set

Property Value

Type: Adp5585TypePinConfigAR3Config
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PINCONFIGAR4CONFIG Property

IRD

Adp5585PINCONFIGAR4CONFIG Property

PIN_CONFIG_A: R4_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePinConfigAR4Config PINCONFIGAR4CONFIG { get; set; }
Public Property PINCONFIGAR4CONFIG As Adp5585TypePinConfigAR4Config
    Get
    Set
public:
property Adp5585TypePinConfigAR4Config PINCONFIGAR4CONFIG {
    Adp5585TypePinConfigAR4Config get ();
    void set (Adp5585TypePinConfigAR4Config value);
}
member PINCONFIGAR4CONFIG : Adp5585TypePinConfigAR4Config with get, set

Property Value

Type: Adp5585TypePinConfigAR4Config
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PINCONFIGAR5CONFIG Property

IRD

Adp5585PINCONFIGAR5CONFIG Property

PIN_CONFIG_A: R5_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePinConfigAR5Config PINCONFIGAR5CONFIG { get; set; }
Public Property PINCONFIGAR5CONFIG As Adp5585TypePinConfigAR5Config
    Get
    Set
public:
property Adp5585TypePinConfigAR5Config PINCONFIGAR5CONFIG {
    Adp5585TypePinConfigAR5Config get ();
    void set (Adp5585TypePinConfigAR5Config value);
}
member PINCONFIGAR5CONFIG : Adp5585TypePinConfigAR5Config with get, set

Property Value

Type: Adp5585TypePinConfigAR5Config
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PINCONFIGBC0CONFIG Property

IRD

Adp5585PINCONFIGBC0CONFIG Property

PIN_CONFIG_B: C0_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePinConfigBC0Config PINCONFIGBC0CONFIG { get; set; }
Public Property PINCONFIGBC0CONFIG As Adp5585TypePinConfigBC0Config
    Get
    Set
public:
property Adp5585TypePinConfigBC0Config PINCONFIGBC0CONFIG {
    Adp5585TypePinConfigBC0Config get ();
    void set (Adp5585TypePinConfigBC0Config value);
}
member PINCONFIGBC0CONFIG : Adp5585TypePinConfigBC0Config with get, set

Property Value

Type: Adp5585TypePinConfigBC0Config
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PINCONFIGBC1CONFIG Property

IRD

Adp5585PINCONFIGBC1CONFIG Property

PIN_CONFIG_B: C1_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePinConfigBC1Config PINCONFIGBC1CONFIG { get; set; }
Public Property PINCONFIGBC1CONFIG As Adp5585TypePinConfigBC1Config
    Get
    Set
public:
property Adp5585TypePinConfigBC1Config PINCONFIGBC1CONFIG {
    Adp5585TypePinConfigBC1Config get ();
    void set (Adp5585TypePinConfigBC1Config value);
}
member PINCONFIGBC1CONFIG : Adp5585TypePinConfigBC1Config with get, set

Property Value

Type: Adp5585TypePinConfigBC1Config
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PINCONFIGBC2CONFIG Property

IRD

Adp5585PINCONFIGBC2CONFIG Property

PIN_CONFIG_B: C2_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePinConfigBC2Config PINCONFIGBC2CONFIG { get; set; }
Public Property PINCONFIGBC2CONFIG As Adp5585TypePinConfigBC2Config
    Get
    Set
public:
property Adp5585TypePinConfigBC2Config PINCONFIGBC2CONFIG {
    Adp5585TypePinConfigBC2Config get ();
    void set (Adp5585TypePinConfigBC2Config value);
}
member PINCONFIGBC2CONFIG : Adp5585TypePinConfigBC2Config with get, set

Property Value

Type: Adp5585TypePinConfigBC2Config
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PINCONFIGBC3CONFIG Property

IRD

Adp5585PINCONFIGBC3CONFIG Property

PIN_CONFIG_B: C3_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePinConfigBC3Config PINCONFIGBC3CONFIG { get; set; }
Public Property PINCONFIGBC3CONFIG As Adp5585TypePinConfigBC3Config
    Get
    Set
public:
property Adp5585TypePinConfigBC3Config PINCONFIGBC3CONFIG {
    Adp5585TypePinConfigBC3Config get ();
    void set (Adp5585TypePinConfigBC3Config value);
}
member PINCONFIGBC3CONFIG : Adp5585TypePinConfigBC3Config with get, set

Property Value

Type: Adp5585TypePinConfigBC3Config
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PINCONFIGBC4CONFIG Property

IRD

Adp5585PINCONFIGBC4CONFIG Property

PIN_CONFIG_B: C4_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePinConfigBC4Config PINCONFIGBC4CONFIG { get; set; }
Public Property PINCONFIGBC4CONFIG As Adp5585TypePinConfigBC4Config
    Get
    Set
public:
property Adp5585TypePinConfigBC4Config PINCONFIGBC4CONFIG {
    Adp5585TypePinConfigBC4Config get ();
    void set (Adp5585TypePinConfigBC4Config value);
}
member PINCONFIGBC4CONFIG : Adp5585TypePinConfigBC4Config with get, set

Property Value

Type: Adp5585TypePinConfigBC4Config
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PINCONFIGCC4EXTENDCFG Property

IRD

Adp5585PINCONFIGCC4EXTENDCFG Property

PIN_CONFIG_C: C4_EXTEND_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePinConfigCC4ExtendCfg PINCONFIGCC4EXTENDCFG { get; set; }
Public Property PINCONFIGCC4EXTENDCFG As Adp5585TypePinConfigCC4ExtendCfg
    Get
    Set
public:
property Adp5585TypePinConfigCC4ExtendCfg PINCONFIGCC4EXTENDCFG {
    Adp5585TypePinConfigCC4ExtendCfg get ();
    void set (Adp5585TypePinConfigCC4ExtendCfg value);
}
member PINCONFIGCC4EXTENDCFG : Adp5585TypePinConfigCC4ExtendCfg with get, set

Property Value

Type: Adp5585TypePinConfigCC4ExtendCfg
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PINCONFIGCPULLSELECT Property

IRD

Adp5585PINCONFIGCPULLSELECT Property

PIN_CONFIG_C: PULL_SELECT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePinConfigCPullSelect PINCONFIGCPULLSELECT { get; set; }
Public Property PINCONFIGCPULLSELECT As Adp5585TypePinConfigCPullSelect
    Get
    Set
public:
property Adp5585TypePinConfigCPullSelect PINCONFIGCPULLSELECT {
    Adp5585TypePinConfigCPullSelect get ();
    void set (Adp5585TypePinConfigCPullSelect value);
}
member PINCONFIGCPULLSELECT : Adp5585TypePinConfigCPullSelect with get, set

Property Value

Type: Adp5585TypePinConfigCPullSelect
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PINCONFIGCR0EXTENDCFG Property

IRD

Adp5585PINCONFIGCR0EXTENDCFG Property

PIN_CONFIG_C: R0_EXTEND_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePinConfigCR0ExtendCfg PINCONFIGCR0EXTENDCFG { get; set; }
Public Property PINCONFIGCR0EXTENDCFG As Adp5585TypePinConfigCR0ExtendCfg
    Get
    Set
public:
property Adp5585TypePinConfigCR0ExtendCfg PINCONFIGCR0EXTENDCFG {
    Adp5585TypePinConfigCR0ExtendCfg get ();
    void set (Adp5585TypePinConfigCR0ExtendCfg value);
}
member PINCONFIGCR0EXTENDCFG : Adp5585TypePinConfigCR0ExtendCfg with get, set

Property Value

Type: Adp5585TypePinConfigCR0ExtendCfg
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PINCONFIGCR3EXTENDCFG Property

IRD

Adp5585PINCONFIGCR3EXTENDCFG Property

PIN_CONFIG_C: R3_EXTEND_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePinConfigCR3ExtendCfg PINCONFIGCR3EXTENDCFG { get; set; }
Public Property PINCONFIGCR3EXTENDCFG As Adp5585TypePinConfigCR3ExtendCfg
    Get
    Set
public:
property Adp5585TypePinConfigCR3ExtendCfg PINCONFIGCR3EXTENDCFG {
    Adp5585TypePinConfigCR3ExtendCfg get ();
    void set (Adp5585TypePinConfigCR3ExtendCfg value);
}
member PINCONFIGCR3EXTENDCFG : Adp5585TypePinConfigCR3ExtendCfg with get, set

Property Value

Type: Adp5585TypePinConfigCR3ExtendCfg
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PINCONFIGCR4EXTENDCFG Property

IRD

Adp5585PINCONFIGCR4EXTENDCFG Property

PIN_CONFIG_C: R4_EXTEND_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePinConfigCR4ExtendCfg PINCONFIGCR4EXTENDCFG { get; set; }
Public Property PINCONFIGCR4EXTENDCFG As Adp5585TypePinConfigCR4ExtendCfg
    Get
    Set
public:
property Adp5585TypePinConfigCR4ExtendCfg PINCONFIGCR4EXTENDCFG {
    Adp5585TypePinConfigCR4ExtendCfg get ();
    void set (Adp5585TypePinConfigCR4ExtendCfg value);
}
member PINCONFIGCR4EXTENDCFG : Adp5585TypePinConfigCR4ExtendCfg with get, set

Property Value

Type: Adp5585TypePinConfigCR4ExtendCfg
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.POLLTIMECFGKEYPOLLTIME Property

IRD

Adp5585POLLTIMECFGKEYPOLLTIME Property

POLL_TIME_CFG: KEY_POLL_TIME

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePollTimeCfgKeyPollTime POLLTIMECFGKEYPOLLTIME { get; set; }
Public Property POLLTIMECFGKEYPOLLTIME As Adp5585TypePollTimeCfgKeyPollTime
    Get
    Set
public:
property Adp5585TypePollTimeCfgKeyPollTime POLLTIMECFGKEYPOLLTIME {
    Adp5585TypePollTimeCfgKeyPollTime get ();
    void set (Adp5585TypePollTimeCfgKeyPollTime value);
}
member POLLTIMECFGKEYPOLLTIME : Adp5585TypePollTimeCfgKeyPollTime with get, set

Property Value

Type: Adp5585TypePollTimeCfgKeyPollTime
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PWMCFGPWMEN Property

IRD

Adp5585PWMCFGPWMEN Property

PWM_CFG: PWM_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePwmCfgPwmEn PWMCFGPWMEN { get; set; }
Public Property PWMCFGPWMEN As Adp5585TypePwmCfgPwmEn
    Get
    Set
public:
property Adp5585TypePwmCfgPwmEn PWMCFGPWMEN {
    Adp5585TypePwmCfgPwmEn get ();
    void set (Adp5585TypePwmCfgPwmEn value);
}
member PWMCFGPWMEN : Adp5585TypePwmCfgPwmEn with get, set

Property Value

Type: Adp5585TypePwmCfgPwmEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PWMCFGPWMINAND Property

IRD

Adp5585PWMCFGPWMINAND Property

PWM_CFG: PWM_IN_AND

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePwmCfgPwmInAnd PWMCFGPWMINAND { get; set; }
Public Property PWMCFGPWMINAND As Adp5585TypePwmCfgPwmInAnd
    Get
    Set
public:
property Adp5585TypePwmCfgPwmInAnd PWMCFGPWMINAND {
    Adp5585TypePwmCfgPwmInAnd get ();
    void set (Adp5585TypePwmCfgPwmInAnd value);
}
member PWMCFGPWMINAND : Adp5585TypePwmCfgPwmInAnd with get, set

Property Value

Type: Adp5585TypePwmCfgPwmInAnd
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PWMCFGPWMMODE Property

IRD

Adp5585PWMCFGPWMMODE Property

PWM_CFG: PWM_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypePwmCfgPwmMode PWMCFGPWMMODE { get; set; }
Public Property PWMCFGPWMMODE As Adp5585TypePwmCfgPwmMode
    Get
    Set
public:
property Adp5585TypePwmCfgPwmMode PWMCFGPWMMODE {
    Adp5585TypePwmCfgPwmMode get ();
    void set (Adp5585TypePwmCfgPwmMode value);
}
member PWMCFGPWMMODE : Adp5585TypePwmCfgPwmMode with get, set

Property Value

Type: Adp5585TypePwmCfgPwmMode
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PWMOFFT Property

IRD

Adp5585PWMOFFT Property

PWM_OFFT (unit: µs)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double PWMOFFT { get; set; }
Public Property PWMOFFT As Double
    Get
    Set
public:
property double PWMOFFT {
    double get ();
    void set (double value);
}
member PWMOFFT : float with get, set

Property Value

Type: Double
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.PWMONT Property

IRD

Adp5585PWMONT Property

PWM_ONT (unit: µs)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double PWMONT { get; set; }
Public Property PWMONT As Double
    Get
    Set
public:
property double PWMONT {
    double get ();
    void set (double value);
}
member PWMONT : float with get, set

Property Value

Type: Double
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RESET1EVENTARESET1EVENTA Property

IRD

Adp5585RESET1EVENTARESET1EVENTA Property

RESET1_EVENT_A: RESET1_EVENT_A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET1EVENTARESET1EVENTA { get; set; }
Public Property RESET1EVENTARESET1EVENTA As Byte
    Get
    Set
public:
property unsigned char RESET1EVENTARESET1EVENTA {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET1EVENTARESET1EVENTA : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RESET1EVENTARESET1EVENTALEVEL Property

IRD

Adp5585RESET1EVENTARESET1EVENTALEVEL Property

RESET1_EVENT_A: RESET1_EVENT_A_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET1EVENTARESET1EVENTALEVEL { get; set; }
Public Property RESET1EVENTARESET1EVENTALEVEL As Byte
    Get
    Set
public:
property unsigned char RESET1EVENTARESET1EVENTALEVEL {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET1EVENTARESET1EVENTALEVEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RESET1EVENTBRESET1EVENTB Property

IRD

Adp5585RESET1EVENTBRESET1EVENTB Property

RESET1_EVENT_B: RESET1_EVENT_B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET1EVENTBRESET1EVENTB { get; set; }
Public Property RESET1EVENTBRESET1EVENTB As Byte
    Get
    Set
public:
property unsigned char RESET1EVENTBRESET1EVENTB {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET1EVENTBRESET1EVENTB : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RESET1EVENTBRESET1EVENTBLEVEL Property

IRD

Adp5585RESET1EVENTBRESET1EVENTBLEVEL Property

RESET1_EVENT_B: RESET1_EVENT_B_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET1EVENTBRESET1EVENTBLEVEL { get; set; }
Public Property RESET1EVENTBRESET1EVENTBLEVEL As Byte
    Get
    Set
public:
property unsigned char RESET1EVENTBRESET1EVENTBLEVEL {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET1EVENTBRESET1EVENTBLEVEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RESET1EVENTCRESET1EVENTC Property

IRD

Adp5585RESET1EVENTCRESET1EVENTC Property

RESET1_EVENT_C: RESET1_EVENT_C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET1EVENTCRESET1EVENTC { get; set; }
Public Property RESET1EVENTCRESET1EVENTC As Byte
    Get
    Set
public:
property unsigned char RESET1EVENTCRESET1EVENTC {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET1EVENTCRESET1EVENTC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RESET1EVENTCRESET1EVENTCLEVEL Property

IRD

Adp5585RESET1EVENTCRESET1EVENTCLEVEL Property

RESET1_EVENT_C: RESET1_EVENT_C_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET1EVENTCRESET1EVENTCLEVEL { get; set; }
Public Property RESET1EVENTCRESET1EVENTCLEVEL As Byte
    Get
    Set
public:
property unsigned char RESET1EVENTCRESET1EVENTCLEVEL {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET1EVENTCRESET1EVENTCLEVEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RESET2EVENTARESET2EVENTA Property

IRD

Adp5585RESET2EVENTARESET2EVENTA Property

RESET2_EVENT_A: RESET2_EVENT_A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET2EVENTARESET2EVENTA { get; set; }
Public Property RESET2EVENTARESET2EVENTA As Byte
    Get
    Set
public:
property unsigned char RESET2EVENTARESET2EVENTA {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET2EVENTARESET2EVENTA : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RESET2EVENTARESET2EVENTALEVEL Property

IRD

Adp5585RESET2EVENTARESET2EVENTALEVEL Property

RESET2_EVENT_A: RESET2_EVENT_A_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET2EVENTARESET2EVENTALEVEL { get; set; }
Public Property RESET2EVENTARESET2EVENTALEVEL As Byte
    Get
    Set
public:
property unsigned char RESET2EVENTARESET2EVENTALEVEL {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET2EVENTARESET2EVENTALEVEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RESET2EVENTBRESET2EVENTB Property

IRD

Adp5585RESET2EVENTBRESET2EVENTB Property

RESET2_EVENT_B: RESET2_EVENT_B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET2EVENTBRESET2EVENTB { get; set; }
Public Property RESET2EVENTBRESET2EVENTB As Byte
    Get
    Set
public:
property unsigned char RESET2EVENTBRESET2EVENTB {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET2EVENTBRESET2EVENTB : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RESET2EVENTBRESET2EVENTBLEVEL Property

IRD

Adp5585RESET2EVENTBRESET2EVENTBLEVEL Property

RESET2_EVENT_B: RESET2_EVENT_B_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET2EVENTBRESET2EVENTBLEVEL { get; set; }
Public Property RESET2EVENTBRESET2EVENTBLEVEL As Byte
    Get
    Set
public:
property unsigned char RESET2EVENTBRESET2EVENTBLEVEL {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET2EVENTBRESET2EVENTBLEVEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RESETCFGRESET1POL Property

IRD

Adp5585RESETCFGRESET1POL Property

RESET_CFG: RESET1_POL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeResetCfgResetPol RESETCFGRESET1POL { get; set; }
Public Property RESETCFGRESET1POL As Adp5585TypeResetCfgResetPol
    Get
    Set
public:
property Adp5585TypeResetCfgResetPol RESETCFGRESET1POL {
    Adp5585TypeResetCfgResetPol get ();
    void set (Adp5585TypeResetCfgResetPol value);
}
member RESETCFGRESET1POL : Adp5585TypeResetCfgResetPol with get, set

Property Value

Type: Adp5585TypeResetCfgResetPol
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RESETCFGRESET2POL Property

IRD

Adp5585RESETCFGRESET2POL Property

RESET_CFG: RESET2_POL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeResetCfgResetPol RESETCFGRESET2POL { get; set; }
Public Property RESETCFGRESET2POL As Adp5585TypeResetCfgResetPol
    Get
    Set
public:
property Adp5585TypeResetCfgResetPol RESETCFGRESET2POL {
    Adp5585TypeResetCfgResetPol get ();
    void set (Adp5585TypeResetCfgResetPol value);
}
member RESETCFGRESET2POL : Adp5585TypeResetCfgResetPol with get, set

Property Value

Type: Adp5585TypeResetCfgResetPol
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RESETCFGRESETPULSEWIDTH Property

IRD

Adp5585RESETCFGRESETPULSEWIDTH Property

RESET_CFG: RESET_PULSE_WIDTH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeResetCfgResetPulseWidth RESETCFGRESETPULSEWIDTH { get; set; }
Public Property RESETCFGRESETPULSEWIDTH As Adp5585TypeResetCfgResetPulseWidth
    Get
    Set
public:
property Adp5585TypeResetCfgResetPulseWidth RESETCFGRESETPULSEWIDTH {
    Adp5585TypeResetCfgResetPulseWidth get ();
    void set (Adp5585TypeResetCfgResetPulseWidth value);
}
member RESETCFGRESETPULSEWIDTH : Adp5585TypeResetCfgResetPulseWidth with get, set

Property Value

Type: Adp5585TypeResetCfgResetPulseWidth
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RESETCFGRESETTRIGGERTIME Property

IRD

Adp5585RESETCFGRESETTRIGGERTIME Property

RESET_CFG: RESET_TRIGGER_TIME (unit: s)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeResetCfgResetTriggerTimer RESETCFGRESETTRIGGERTIME { get; set; }
Public Property RESETCFGRESETTRIGGERTIME As Adp5585TypeResetCfgResetTriggerTimer
    Get
    Set
public:
property Adp5585TypeResetCfgResetTriggerTimer RESETCFGRESETTRIGGERTIME {
    Adp5585TypeResetCfgResetTriggerTimer get ();
    void set (Adp5585TypeResetCfgResetTriggerTimer value);
}
member RESETCFGRESETTRIGGERTIME : Adp5585TypeResetCfgResetTriggerTimer with get, set

Property Value

Type: Adp5585TypeResetCfgResetTriggerTimer
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RESETCFGRSTPASSTHRUEN Property

IRD

Adp5585RESETCFGRSTPASSTHRUEN Property

RESET_CFG: RST_PASSTHRU_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeResetCfgRstPassthruEn RESETCFGRSTPASSTHRUEN { get; set; }
Public Property RESETCFGRSTPASSTHRUEN As Adp5585TypeResetCfgRstPassthruEn
    Get
    Set
public:
property Adp5585TypeResetCfgRstPassthruEn RESETCFGRSTPASSTHRUEN {
    Adp5585TypeResetCfgRstPassthruEn get ();
    void set (Adp5585TypeResetCfgRstPassthruEn value);
}
member RESETCFGRSTPASSTHRUEN : Adp5585TypeResetCfgRstPassthruEn with get, set

Property Value

Type: Adp5585TypeResetCfgRstPassthruEn
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RPULLCONFIGAR0PULLCFG Property

IRD

Adp5585RPULLCONFIGAR0PULLCFG Property

RPULL_CONFIG_A: R0_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeRpullConfig RPULLCONFIGAR0PULLCFG { get; set; }
Public Property RPULLCONFIGAR0PULLCFG As Adp5585TypeRpullConfig
    Get
    Set
public:
property Adp5585TypeRpullConfig RPULLCONFIGAR0PULLCFG {
    Adp5585TypeRpullConfig get ();
    void set (Adp5585TypeRpullConfig value);
}
member RPULLCONFIGAR0PULLCFG : Adp5585TypeRpullConfig with get, set

Property Value

Type: Adp5585TypeRpullConfig
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RPULLCONFIGAR1PULLCFG Property

IRD

Adp5585RPULLCONFIGAR1PULLCFG Property

RPULL_CONFIG_A: R1_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeRpullConfig RPULLCONFIGAR1PULLCFG { get; set; }
Public Property RPULLCONFIGAR1PULLCFG As Adp5585TypeRpullConfig
    Get
    Set
public:
property Adp5585TypeRpullConfig RPULLCONFIGAR1PULLCFG {
    Adp5585TypeRpullConfig get ();
    void set (Adp5585TypeRpullConfig value);
}
member RPULLCONFIGAR1PULLCFG : Adp5585TypeRpullConfig with get, set

Property Value

Type: Adp5585TypeRpullConfig
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RPULLCONFIGAR2PULLCFG Property

IRD

Adp5585RPULLCONFIGAR2PULLCFG Property

RPULL_CONFIG_A: R2_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeRpullConfig RPULLCONFIGAR2PULLCFG { get; set; }
Public Property RPULLCONFIGAR2PULLCFG As Adp5585TypeRpullConfig
    Get
    Set
public:
property Adp5585TypeRpullConfig RPULLCONFIGAR2PULLCFG {
    Adp5585TypeRpullConfig get ();
    void set (Adp5585TypeRpullConfig value);
}
member RPULLCONFIGAR2PULLCFG : Adp5585TypeRpullConfig with get, set

Property Value

Type: Adp5585TypeRpullConfig
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RPULLCONFIGAR3PULLCFG Property

IRD

Adp5585RPULLCONFIGAR3PULLCFG Property

RPULL_CONFIG_A: R3_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeRpullConfig RPULLCONFIGAR3PULLCFG { get; set; }
Public Property RPULLCONFIGAR3PULLCFG As Adp5585TypeRpullConfig
    Get
    Set
public:
property Adp5585TypeRpullConfig RPULLCONFIGAR3PULLCFG {
    Adp5585TypeRpullConfig get ();
    void set (Adp5585TypeRpullConfig value);
}
member RPULLCONFIGAR3PULLCFG : Adp5585TypeRpullConfig with get, set

Property Value

Type: Adp5585TypeRpullConfig
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RPULLCONFIGBR4PULLCFG Property

IRD

Adp5585RPULLCONFIGBR4PULLCFG Property

RPULL_CONFIG_B: R4_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeRpullConfig RPULLCONFIGBR4PULLCFG { get; set; }
Public Property RPULLCONFIGBR4PULLCFG As Adp5585TypeRpullConfig
    Get
    Set
public:
property Adp5585TypeRpullConfig RPULLCONFIGBR4PULLCFG {
    Adp5585TypeRpullConfig get ();
    void set (Adp5585TypeRpullConfig value);
}
member RPULLCONFIGBR4PULLCFG : Adp5585TypeRpullConfig with get, set

Property Value

Type: Adp5585TypeRpullConfig
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RPULLCONFIGBR5PULLCFG Property

IRD

Adp5585RPULLCONFIGBR5PULLCFG Property

RPULL_CONFIG_B: R5_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeRpullConfig RPULLCONFIGBR5PULLCFG { get; set; }
Public Property RPULLCONFIGBR5PULLCFG As Adp5585TypeRpullConfig
    Get
    Set
public:
property Adp5585TypeRpullConfig RPULLCONFIGBR5PULLCFG {
    Adp5585TypeRpullConfig get ();
    void set (Adp5585TypeRpullConfig value);
}
member RPULLCONFIGBR5PULLCFG : Adp5585TypeRpullConfig with get, set

Property Value

Type: Adp5585TypeRpullConfig
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RPULLCONFIGCC0PULLCFG Property

IRD

Adp5585RPULLCONFIGCC0PULLCFG Property

RPULL_CONFIG_C: C0_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeRpullConfig RPULLCONFIGCC0PULLCFG { get; set; }
Public Property RPULLCONFIGCC0PULLCFG As Adp5585TypeRpullConfig
    Get
    Set
public:
property Adp5585TypeRpullConfig RPULLCONFIGCC0PULLCFG {
    Adp5585TypeRpullConfig get ();
    void set (Adp5585TypeRpullConfig value);
}
member RPULLCONFIGCC0PULLCFG : Adp5585TypeRpullConfig with get, set

Property Value

Type: Adp5585TypeRpullConfig
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RPULLCONFIGCC1PULLCFG Property

IRD

Adp5585RPULLCONFIGCC1PULLCFG Property

RPULL_CONFIG_C: C1_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeRpullConfig RPULLCONFIGCC1PULLCFG { get; set; }
Public Property RPULLCONFIGCC1PULLCFG As Adp5585TypeRpullConfig
    Get
    Set
public:
property Adp5585TypeRpullConfig RPULLCONFIGCC1PULLCFG {
    Adp5585TypeRpullConfig get ();
    void set (Adp5585TypeRpullConfig value);
}
member RPULLCONFIGCC1PULLCFG : Adp5585TypeRpullConfig with get, set

Property Value

Type: Adp5585TypeRpullConfig
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RPULLCONFIGCC2PULLCFG Property

IRD

Adp5585RPULLCONFIGCC2PULLCFG Property

RPULL_CONFIG_C: C2_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeRpullConfig RPULLCONFIGCC2PULLCFG { get; set; }
Public Property RPULLCONFIGCC2PULLCFG As Adp5585TypeRpullConfig
    Get
    Set
public:
property Adp5585TypeRpullConfig RPULLCONFIGCC2PULLCFG {
    Adp5585TypeRpullConfig get ();
    void set (Adp5585TypeRpullConfig value);
}
member RPULLCONFIGCC2PULLCFG : Adp5585TypeRpullConfig with get, set

Property Value

Type: Adp5585TypeRpullConfig
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RPULLCONFIGCC3PULLCFG Property

IRD

Adp5585RPULLCONFIGCC3PULLCFG Property

RPULL_CONFIG_C: C3_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeRpullConfig RPULLCONFIGCC3PULLCFG { get; set; }
Public Property RPULLCONFIGCC3PULLCFG As Adp5585TypeRpullConfig
    Get
    Set
public:
property Adp5585TypeRpullConfig RPULLCONFIGCC3PULLCFG {
    Adp5585TypeRpullConfig get ();
    void set (Adp5585TypeRpullConfig value);
}
member RPULLCONFIGCC3PULLCFG : Adp5585TypeRpullConfig with get, set

Property Value

Type: Adp5585TypeRpullConfig
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.RPULLCONFIGDC4PULLCFG Property

IRD

Adp5585RPULLCONFIGDC4PULLCFG Property

RPULL_CONFIG_D: C4_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeRpullConfig RPULLCONFIGDC4PULLCFG { get; set; }
Public Property RPULLCONFIGDC4PULLCFG As Adp5585TypeRpullConfig
    Get
    Set
public:
property Adp5585TypeRpullConfig RPULLCONFIGDC4PULLCFG {
    Adp5585TypeRpullConfig get ();
    void set (Adp5585TypeRpullConfig value);
}
member RPULLCONFIGDC4PULLCFG : Adp5585TypeRpullConfig with get, set

Property Value

Type: Adp5585TypeRpullConfig
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.STATUSEC Property

IRD

Adp5585STATUSEC Property

STATUS: EC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STATUSEC { get; }
Public ReadOnly Property STATUSEC As Byte
    Get
public:
property unsigned char STATUSEC {
    unsigned char get ();
}
member STATUSEC : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.STATUSLOGICSTAT Property

IRD

Adp5585STATUSLOGICSTAT Property

STATUS: LOGIC_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5585TypeStatusLogicStat STATUSLOGICSTAT { get; }
Public ReadOnly Property STATUSLOGICSTAT As Adp5585TypeStatusLogicStat
    Get
public:
property Adp5585TypeStatusLogicStat STATUSLOGICSTAT {
    Adp5585TypeStatusLogicStat get ();
}
member STATUSLOGICSTAT : Adp5585TypeStatusLogicStat with get

Property Value

Type: Adp5585TypeStatusLogicStat
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585 Methods

The Adp5585 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.Flush Method

IRD

Adp5585Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adp5585 Class
telos.Ird.AnalogDevices Namespace


Adp5585.TypeDebounceDis Enumeration

IRD

Adp5585TypeDebounceDis Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDebounceDis
Public Enumeration TypeDebounceDis
public enum class TypeDebounceDis
type TypeDebounceDis
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeFifoEventIdentifier Enumeration

IRD

Adp5585TypeFifoEventIdentifier Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFifoEventIdentifier
Public Enumeration TypeFifoEventIdentifier
public enum class TypeFifoEventIdentifier
type TypeFifoEventIdentifier
Members
Member name | Value | Description
NoEvent | 0 | No Event
Key1R0C0 | 1 | Key 1 (R0, C0)
Key2R0C1 | 2 | Key 2 (R0, C1)
Key3R0C2 | 3 | Key 3 (R0, C2)
Key4R0C3 | 4 | Key 4 (R0, C3)
Key5R0C4 | 5 | Key 5 (R0, C4)
Key6R1C0 | 6 | Key 6 (R1, C0)
Key7R1C1 | 7 | Key 7 (R1, C1)
Key8R1C2 | 8 | Key 8 (R1, C2)
Key9R1C3 | 9 | Key 9 (R1, C3)
Key10R1C4 | 10 | Key 10 (R1, C4)
Key11R2C0 | 11 | Key 11 (R2, C0)
Key12R2C1 | 12 | Key 12 (R2, C1)
Key13R2C2 | 13 | Key 13 (R2, C2)
Key14R2C3 | 14 | Key 14 (R2, C3)
Key15R2C4 | 15 | Key 15 (R2, C4)
Key16R3C0 | 16 | Key 16 (R3, C0)
Key17R3C1 | 17 | Key 17 (R3, C1)
Key18R3C2 | 18 | Key 18 (R3, C2)
Key19R3C3 | 19 | Key 19 (R3, C3)
Key20R3C4 | 20 | Key 20 (R3, C4)
Key21R4C0 | 21 | Key 21 (R4, C0)
Key22R4C1 | 22 | Key 22 (R4, C1)
Key23R4C2 | 23 | Key 23 (R4, C2)
Key24R4C3 | 24 | Key 24 (R4, C3)
Key25R4C4 | 25 | Key 25 (R4, C4)
Key26R5C0 | 26 | Key 26 (R5, C0)
Key27R5C1 | 27 | Key 27 (R5, C1)
Key28R5C2 | 28 | Key 28 (R5, C2)
Key29R5C3 | 29 | Key 29 (R5, C3)
Key30R5C4 | 30 | Key 30 (R5, C4)
Key31R0GND | 31 | Key 31 (R0, GND)
Key32R1GND | 32 | Key 32 (R1, GND)
Key33R2GND | 33 | Key 33 (R2, GND)
Key34R3GND | 34 | Key 34 (R3, GND)
Key35R4GND | 35 | Key 35 (R4, GND)
Key36R5GND | 36 | Key 36 (R5, GND)
GPI1R0 | 37 | GPI 1 (R0)
GPI2R1 | 38 | GPI 2 (R1)
GPI3R2 | 39 | GPI 3 (R2)
GPI4R3 | 40 | GPI 4 (R3)
GPI5R4 | 41 | GPI 5 (R4)
GPI6R5 | 42 | GPI 6 (R5)
GPI7C0 | 43 | GPI 7 (C0)
GPI8C1 | 44 | GPI 8 (C1)
GPI9C2 | 45 | GPI 9 (C2)
GPI10C3 | 46 | GPI 10 (C3)
GPI11C4 | 47 | GPI 11 (C4)
Logic | 48 | Logic
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeGeneralCfgBIntCfg Enumeration

IRD

Adp5585TypeGeneralCfgBIntCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralCfgBIntCfg
Public Enumeration TypeGeneralCfgBIntCfg
public enum class TypeGeneralCfgBIntCfg
type TypeGeneralCfgBIntCfg
Members
Member name | Value | Description
INTPinRemainsAsserted | 0 | INT Pin: Remains Asserted
INTPinDeassertedFor50Us | 1 | INT Pin: Deasserted for 50 µs
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeGeneralCfgBOscEn Enumeration

IRD

Adp5585TypeGeneralCfgBOscEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralCfgBOscEn
Public Enumeration TypeGeneralCfgBOscEn
public enum class TypeGeneralCfgBOscEn
type TypeGeneralCfgBOscEn
Members
Member name | Value | Description
Value_1MHzOscillatorDisabled | 0 | 1 MHz Oscillator: Disabled
Value_1MHzOscillatorEnabled | 1 | 1 MHz Oscillator: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeGeneralCfgBOscFreq Enumeration

IRD

Adp5585TypeGeneralCfgBOscFreq Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralCfgBOscFreq
Public Enumeration TypeGeneralCfgBOscFreq
public enum class TypeGeneralCfgBOscFreq
type TypeGeneralCfgBOscFreq
Members
Member name | Value | Description
Value_50KHz | 0 | 50 kHz
Value_100KHz | 1 | 100 kHz
Value_200KHz | 2 | 200 kHz
Value_500KHz | 3 | 500 kHz
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeGeneralCfgBRstCfg Enumeration

IRD

Adp5585TypeGeneralCfgBRstCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralCfgBRstCfg
Public Enumeration TypeGeneralCfgBRstCfg
public enum class TypeGeneralCfgBRstCfg
type TypeGeneralCfgBRstCfg
Members
Member name | Value | Description
RSTLowADP5585Resets | 0 | RST Low: ADP5585 Resets
RSTLowADP5585DoesNotReset | 1 | RST Low: ADP5585 Does Not Reset
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeGpiEventEn Enumeration

IRD

Adp5585TypeGpiEventEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpiEventEn
Public Enumeration TypeGpiEventEn
public enum class TypeGpiEventEn
type TypeGpiEventEn
Members
Member name | Value | Description
GPIEventsDisabled | 0 | GPI Events: Disabled
GPIEventsEnabled | 1 | GPI Events: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeGpiInterruptEn Enumeration

IRD

Adp5585TypeGpiInterruptEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpiInterruptEn
Public Enumeration TypeGpiInterruptEn
public enum class TypeGpiInterruptEn
type TypeGpiInterruptEn
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeGpiIntLevel Enumeration

IRD

Adp5585TypeGpiIntLevel Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpiIntLevel
Public Enumeration TypeGpiIntLevel
public enum class TypeGpiIntLevel
type TypeGpiIntLevel
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeGpiIntStat Enumeration

IRD

Adp5585TypeGpiIntStat Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpiIntStat
Public Enumeration TypeGpiIntStat
public enum class TypeGpiIntStat
type TypeGpiIntStat
Members
Member name | Value | Description
NoInterrupt | 0 | No Interrupt
Interrupt | 1 | Interrupt
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeGpioDirection Enumeration

IRD

Adp5585TypeGpioDirection Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioDirection
Public Enumeration TypeGpioDirection
public enum class TypeGpioDirection
type TypeGpioDirection
Members
Member name | Value | Description
Input | 0 | Input
Output | 1 | Output
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeGpiStatus Enumeration

IRD

Adp5585TypeGpiStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpiStatus
Public Enumeration TypeGpiStatus
public enum class TypeGpiStatus
type TypeGpiStatus
Members
Member name | Value | Description
Low | 0 | Low
High | 1 | High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeGpoDataOut Enumeration

IRD

Adp5585TypeGpoDataOut Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpoDataOut
Public Enumeration TypeGpoDataOut
public enum class TypeGpoDataOut
type TypeGpoDataOut
Members
Member name | Value | Description
Low | 0 | Low
High | 1 | High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeGpoOutMode Enumeration

IRD

Adp5585TypeGpoOutMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpoOutMode
Public Enumeration TypeGpoOutMode
public enum class TypeGpoOutMode
type TypeGpoOutMode
Members
Member name | Value | Description
PushPull | 0 | Push/Pull
OpenDrain | 1 | Open Drain
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeIntEn Enumeration

IRD

Adp5585TypeIntEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEn
Public Enumeration TypeIntEn
public enum class TypeIntEn
type TypeIntEn
Members
Member name | Value | Description
InterruptDisabled | 0 | Interrupt: Disabled
InterruptEnabled | 1 | Interrupt: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeIntStatus Enumeration

IRD

Adp5585TypeIntStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntStatus
Public Enumeration TypeIntStatus
public enum class TypeIntStatus
type TypeIntStatus
Members
Member name | Value | Description
NoInterrupt | 0 | No interrupt
Interrupt | 1 | Interrupt
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeLogicCfgInv Enumeration

IRD

Adp5585TypeLogicCfgInv Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLogicCfgInv
Public Enumeration TypeLogicCfgInv
public enum class TypeLogicCfgInv
type TypeLogicCfgInv
Members
Member name | Value | Description
NotInverted | 0 | Not Inverted
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeLogicCfgLogicSel Enumeration

IRD

Adp5585TypeLogicCfgLogicSel Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLogicCfgLogicSel
Public Enumeration TypeLogicCfgLogicSel
public enum class TypeLogicCfgLogicSel
type TypeLogicCfgLogicSel
Members
Member name | Value | Description
OffDisabled | 0 | Off/Disabled
AND | 1 | AND
OR | 2 | OR
XOR | 3 | XOR
FF | 4 | FF
INLA | 5 | IN_LA
INLB | 6 | IN_LB
INLC | 7 | IN_LC
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeLogicFfCfgClr Enumeration

IRD

Adp5585TypeLogicFfCfgClr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLogicFfCfgClr
Public Enumeration TypeLogicFfCfgClr
public enum class TypeLogicFfCfgClr
type TypeLogicFfCfgClr
Members
Member name | Value | Description
NotCleared | 0 | Not Cleared
Cleared | 1 | Cleared
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeLogicFfCfgSet Enumeration

IRD

Adp5585TypeLogicFfCfgSet Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLogicFfCfgSet
Public Enumeration TypeLogicFfCfgSet
public enum class TypeLogicFfCfgSet
type TypeLogicFfCfgSet
Members
Member name | Value | Description
NotSet | 0 | Not Set
Set | 1 | Set
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeLogicIntEventEnLogicEventEn Enumeration

IRD

Adp5585TypeLogicIntEventEnLogicEventEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLogicIntEventEnLogicEventEn
Public Enumeration TypeLogicIntEventEnLogicEventEn
public enum class TypeLogicIntEventEnLogicEventEn
type TypeLogicIntEventEnLogicEventEn
Members
Member name | Value | Description
InterruptNotGenerated | 0 | Interrupt: Not Generated
InterruptGenerated | 1 | Interrupt: Generated
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeLogicIntEventEnLogicIntLevel Enumeration

IRD

Adp5585TypeLogicIntEventEnLogicIntLevel Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLogicIntEventEnLogicIntLevel
Public Enumeration TypeLogicIntEventEnLogicIntLevel
public enum class TypeLogicIntEventEnLogicIntLevel
type TypeLogicIntEventEnLogicIntLevel
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeLogicIntEventEnLyDbncDis Enumeration

IRD

Adp5585TypeLogicIntEventEnLyDbncDis Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLogicIntEventEnLyDbncDis
Public Enumeration TypeLogicIntEventEnLyDbncDis
public enum class TypeLogicIntEventEnLyDbncDis
type TypeLogicIntEventEnLyDbncDis
Members
Member name | Value | Description
Debounced | 0 | Debounced
NotDebounced | 1 | Not Debounced
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePinConfigAR0Config Enumeration

IRD

Adp5585TypePinConfigAR0Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigAR0Config
Public Enumeration TypePinConfigAR0Config
public enum class TypePinConfigAR0Config
type TypePinConfigAR0Config
Members
Member name | Value | Description
GPIO1 | 0 | GPIO 1
Row0 | 1 | Row 0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePinConfigAR1Config Enumeration

IRD

Adp5585TypePinConfigAR1Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigAR1Config
Public Enumeration TypePinConfigAR1Config
public enum class TypePinConfigAR1Config
type TypePinConfigAR1Config
Members
Member name | Value | Description
GPIO2 | 0 | GPIO 2
Row1 | 1 | Row 1
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePinConfigAR2Config Enumeration

IRD

Adp5585TypePinConfigAR2Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigAR2Config
Public Enumeration TypePinConfigAR2Config
public enum class TypePinConfigAR2Config
type TypePinConfigAR2Config
Members
Member name | Value | Description
GPIO3 | 0 | GPIO 3
Row2 | 1 | Row 2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePinConfigAR3Config Enumeration

IRD

Adp5585TypePinConfigAR3Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigAR3Config
Public Enumeration TypePinConfigAR3Config
public enum class TypePinConfigAR3Config
type TypePinConfigAR3Config
Members
Member name | Value | Description
GPIO4 | 0 | GPIO 4
Row3 | 1 | Row 3
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePinConfigAR4Config Enumeration

IRD

Adp5585TypePinConfigAR4Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigAR4Config
Public Enumeration TypePinConfigAR4Config
public enum class TypePinConfigAR4Config
type TypePinConfigAR4Config
Members
Member name | Value | Description
GPIO5 | 0 | GPIO 5
Row4 | 1 | Row 4
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePinConfigAR5Config Enumeration

IRD

Adp5585TypePinConfigAR5Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigAR5Config
Public Enumeration TypePinConfigAR5Config
public enum class TypePinConfigAR5Config
type TypePinConfigAR5Config
Members
Member name | Value | Description
GPIO6 | 0 | GPIO 6
Row5 | 1 | Row 5
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePinConfigBC0Config Enumeration

IRD

Adp5585TypePinConfigBC0Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigBC0Config
Public Enumeration TypePinConfigBC0Config
public enum class TypePinConfigBC0Config
type TypePinConfigBC0Config
Members
Member name | Value | Description
GPIO7 | 0 | GPIO 7
Column0 | 1 | Column 0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePinConfigBC1Config Enumeration

IRD

Adp5585TypePinConfigBC1Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigBC1Config
Public Enumeration TypePinConfigBC1Config
public enum class TypePinConfigBC1Config
type TypePinConfigBC1Config
Members
Member name | Value | Description
GPIO8 | 0 | GPIO 8
Column1 | 1 | Column 1
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePinConfigBC2Config Enumeration

IRD

Adp5585TypePinConfigBC2Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigBC2Config
Public Enumeration TypePinConfigBC2Config
public enum class TypePinConfigBC2Config
type TypePinConfigBC2Config
Members
Member name | Value | Description
GPIO9 | 0 | GPIO 9
Column2 | 1 | Column 2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePinConfigBC3Config Enumeration

IRD

Adp5585TypePinConfigBC3Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigBC3Config
Public Enumeration TypePinConfigBC3Config
public enum class TypePinConfigBC3Config
type TypePinConfigBC3Config
Members
Member name | Value | Description
GPIO10 | 0 | GPIO 10
Column3 | 1 | Column 3
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePinConfigBC4Config Enumeration

IRD

Adp5585TypePinConfigBC4Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigBC4Config
Public Enumeration TypePinConfigBC4Config
public enum class TypePinConfigBC4Config
type TypePinConfigBC4Config
Members
Member name | Value | Description
GPIO11 | 0 | GPIO 11
Column4 | 1 | Column 4
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePinConfigCC4ExtendCfg Enumeration

IRD

Adp5585TypePinConfigCC4ExtendCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigCC4ExtendCfg
Public Enumeration TypePinConfigCC4ExtendCfg
public enum class TypePinConfigCC4ExtendCfg
type TypePinConfigCC4ExtendCfg
Members
Member name | Value | Description
C4GPIO11 | 0 | C4: GPIO 11
C4RESET2 | 1 | C4: RESET2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePinConfigCPullSelect Enumeration

IRD

Adp5585TypePinConfigCPullSelect Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigCPullSelect
Public Enumeration TypePinConfigCPullSelect
public enum class TypePinConfigCPullSelect
type TypePinConfigCPullSelect
Members
Member name | Value | Description
Value_300KΩ | 0 | 300 kΩ
Value_100KΩ | 1 | 100 kΩ
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePinConfigCR0ExtendCfg Enumeration

IRD

Adp5585TypePinConfigCR0ExtendCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigCR0ExtendCfg
Public Enumeration TypePinConfigCR0ExtendCfg
public enum class TypePinConfigCR0ExtendCfg
type TypePinConfigCR0ExtendCfg
Members
Member name | Value | Description
R0GPIO1 | 0 | R0: GPIO 1
R0LY | 1 | R0: LY
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePinConfigCR3ExtendCfg Enumeration

IRD

Adp5585TypePinConfigCR3ExtendCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigCR3ExtendCfg
Public Enumeration TypePinConfigCR3ExtendCfg
public enum class TypePinConfigCR3ExtendCfg
type TypePinConfigCR3ExtendCfg
Members
Member name | Value | Description
R3GPIO4 | 0 | R3: GPIO 4
R3LC | 1 | R3: LC
R3PWMOUT | 2 | R3: PWM_OUT
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePinConfigCR4ExtendCfg Enumeration

IRD

Adp5585TypePinConfigCR4ExtendCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigCR4ExtendCfg
Public Enumeration TypePinConfigCR4ExtendCfg
public enum class TypePinConfigCR4ExtendCfg
type TypePinConfigCR4ExtendCfg
Members
Member name | Value | Description
R4GPIO5 | 0 | R4: GPIO 5
R4RESET1 | 1 | R4: RESET1
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePollTimeCfgKeyPollTime Enumeration

IRD

Adp5585TypePollTimeCfgKeyPollTime Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePollTimeCfgKeyPollTime
Public Enumeration TypePollTimeCfgKeyPollTime
public enum class TypePollTimeCfgKeyPollTime
type TypePollTimeCfgKeyPollTime
Members
Member name | Value | Description
Value_10 | 0 | 10
Value_20 | 1 | 20
Value_30 | 2 | 30
Value_40 | 3 | 40
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePwmCfgPwmEn Enumeration

IRD

Adp5585TypePwmCfgPwmEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePwmCfgPwmEn
Public Enumeration TypePwmCfgPwmEn
public enum class TypePwmCfgPwmEn
type TypePwmCfgPwmEn
Members
Member name | Value | Description
PWMDisabled | 0 | PWM: Disabled
PWMEnabled | 1 | PWM: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePwmCfgPwmInAnd Enumeration

IRD

Adp5585TypePwmCfgPwmInAnd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePwmCfgPwmInAnd
Public Enumeration TypePwmCfgPwmInAnd
public enum class TypePwmCfgPwmInAnd
type TypePwmCfgPwmInAnd
Members
Member name | Value | Description
ExternalANDIngDisabled | 0 | External AND'ing: Disabled
ExternalANDIngEnabled | 1 | External AND'ing: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypePwmCfgPwmMode Enumeration

IRD

Adp5585TypePwmCfgPwmMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePwmCfgPwmMode
Public Enumeration TypePwmCfgPwmMode
public enum class TypePwmCfgPwmMode
type TypePwmCfgPwmMode
Members
Member name | Value | Description
Continuous | 0 | Continuous
OnePWMPeriod | 1 | One PWM Period
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeResetCfgResetPol Enumeration

IRD

Adp5585TypeResetCfgResetPol Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeResetCfgResetPol
Public Enumeration TypeResetCfgResetPol
public enum class TypeResetCfgResetPol
type TypeResetCfgResetPol
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeResetCfgResetPulseWidth Enumeration

IRD

Adp5585TypeResetCfgResetPulseWidth Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeResetCfgResetPulseWidth
Public Enumeration TypeResetCfgResetPulseWidth
public enum class TypeResetCfgResetPulseWidth
type TypeResetCfgResetPulseWidth
Members
Member name | Value | Description
Value_500Us | 0 | 500 µs
Value_1Ms | 1 | 1 ms
Value_2Ms | 2 | 2 ms
Value_10Ms | 3 | 10 ms
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeResetCfgResetTriggerTimer Enumeration

IRD

Adp5585TypeResetCfgResetTriggerTimer Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeResetCfgResetTriggerTimer
Public Enumeration TypeResetCfgResetTriggerTimer
public enum class TypeResetCfgResetTriggerTimer
type TypeResetCfgResetTriggerTimer
Members
Member name | Value | Description
Immediate | 0 | Immediate
Value_1_0 | 1 | 1.0
Value_1_5 | 2 | 1.5
Value_2_0 | 3 | 2.0
Value_2_5 | 4 | 2.5
Value_3_0 | 5 | 3.0
Value_3_5 | 6 | 3.5
Value_4_0 | 7 | 4.0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeResetCfgRstPassthruEn Enumeration

IRD

Adp5585TypeResetCfgRstPassthruEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeResetCfgRstPassthruEn
Public Enumeration TypeResetCfgRstPassthruEn
public enum class TypeResetCfgRstPassthruEn
type TypeResetCfgRstPassthruEn
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeRpullConfig Enumeration

IRD

Adp5585TypeRpullConfig Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRpullConfig
Public Enumeration TypeRpullConfig
public enum class TypeRpullConfig
type TypeRpullConfig
Members
Member name | Value | Description
Value_300KΩPullUp | 0 | 300 kΩ Pull-Up
Value_300KΩPullDown | 1 | 300 kΩ Pull-Down
Value_100KΩPullUp | 2 | 100 kΩ Pull-Up
Disabled | 3 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5585.TypeStatusLogicStat Enumeration

IRD

Adp5585TypeStatusLogicStat Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusLogicStat
Public Enumeration TypeStatusLogicStat
public enum class TypeStatusLogicStat
type TypeStatusLogicStat
Members
Member name | Value | Description
OutputLogicBlockLYLow | 0 | Output Logic Block (LY): Low
OutputLogicBlockLYHigh | 1 | Output Logic Block (LY): High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587 Class

Analog Devices: ADP 5587
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdp5587

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adp5587
Public Class Adp5587
public ref class Adp5587
type Adp5587 =  class end

The Adp5587 type exposes the following members.

Constructors
 | Name | Description
Public method | Adp5587 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationAUTOINC | Configuration: AUTO_INC
Public property | ConfigurationGPIEMCFG | Configuration: GPIEM_CFG
Public property | ConfigurationGPIIEN | Configuration: GPI_IEN
Public property | ConfigurationINTCFG | Configuration: INT_CFG
Public property | ConfigurationKEIEN | Configuration: KE_IEN
Public property | ConfigurationKLCKIM | Configuration: K_LCK_IM
Public property | ConfigurationOVRFLOWIEN | Configuration: OVR_FLOW_IEN
Public property | ConfigurationOVRFLOWM | Configuration: OVR_FLOW_M
Public property | DebounceDisable1R0 | Debounce Disable 1: R0
Public property | DebounceDisable1R1 | Debounce Disable 1: R1
Public property | DebounceDisable1R2 | Debounce Disable 1: R2
Public property | DebounceDisable1R3 | Debounce Disable 1: R3
Public property | DebounceDisable1R4 | Debounce Disable 1: R4
Public property | DebounceDisable1R5 | Debounce Disable 1: R5
Public property | DebounceDisable1R6 | Debounce Disable 1: R6
Public property | DebounceDisable1R7 | Debounce Disable 1: R7
Public property | DebounceDisable2C0 | Debounce Disable 2: C0
Public property | DebounceDisable2C1 | Debounce Disable 2: C1
Public property | DebounceDisable2C2 | Debounce Disable 2: C2
Public property | DebounceDisable2C3 | Debounce Disable 2: C3
Public property | DebounceDisable2C4 | Debounce Disable 2: C4
Public property | DebounceDisable2C5 | Debounce Disable 2: C5
Public property | DebounceDisable2C6 | Debounce Disable 2: C6
Public property | DebounceDisable2C7 | Debounce Disable 2: C7
Public property | DebounceDisable3C8 | Debounce Disable 3: C8
Public property | DebounceDisable3C9 | Debounce Disable 3: C9
Public property | DeviceIDDeviceID | Device ID: Device ID
Public property | DeviceIDMFGID | Device ID: MFG ID
Public property | GPIEventMode1R0 | GPI Event Mode 1: R0
Public property | GPIEventMode1R1 | GPI Event Mode 1: R1
Public property | GPIEventMode1R2 | GPI Event Mode 1: R2
Public property | GPIEventMode1R3 | GPI Event Mode 1: R3
Public property | GPIEventMode1R4 | GPI Event Mode 1: R4
Public property | GPIEventMode1R5 | GPI Event Mode 1: R5
Public property | GPIEventMode1R6 | GPI Event Mode 1: R6
Public property | GPIEventMode1R7 | GPI Event Mode 1: R7
Public property | GPIEventMode2C0 | GPI Event Mode 2: C0
Public property | GPIEventMode2C1 | GPI Event Mode 2: C1
Public property | GPIEventMode2C2 | GPI Event Mode 2: C2
Public property | GPIEventMode2C3 | GPI Event Mode 2: C3
Public property | GPIEventMode2C4 | GPI Event Mode 2: C4
Public property | GPIEventMode2C5 | GPI Event Mode 2: C5
Public property | GPIEventMode2C6 | GPI Event Mode 2: C6
Public property | GPIEventMode2C7 | GPI Event Mode 2: C7
Public property | GPIEventMode3C8 | GPI Event Mode 3: C8
Public property | GPIEventMode3C9 | GPI Event Mode 3: C9
Public property | GPIODataDirection1R0 | GPIO Data Direction 1: R0
Public property | GPIODataDirection1R1 | GPIO Data Direction 1: R1
Public property | GPIODataDirection1R2 | GPIO Data Direction 1: R2
Public property | GPIODataDirection1R3 | GPIO Data Direction 1: R3
Public property | GPIODataDirection1R4 | GPIO Data Direction 1: R4
Public property | GPIODataDirection1R5 | GPIO Data Direction 1: R5
Public property | GPIODataDirection1R6 | GPIO Data Direction 1: R6
Public property | GPIODataDirection1R7 | GPIO Data Direction 1: R7
Public property | GPIODataDirection2C0 | GPIO Data Direction 2: C0
Public property | GPIODataDirection2C1 | GPIO Data Direction 2: C1
Public property | GPIODataDirection2C2 | GPIO Data Direction 2: C2
Public property | GPIODataDirection2C3 | GPIO Data Direction 2: C3
Public property | GPIODataDirection2C4 | GPIO Data Direction 2: C4
Public property | GPIODataDirection2C5 | GPIO Data Direction 2: C5
Public property | GPIODataDirection2C6 | GPIO Data Direction 2: C6
Public property | GPIODataDirection2C7 | GPIO Data Direction 2: C7
Public property | GPIODataDirection3C8 | GPIO Data Direction 3: C8
Public property | GPIODataDirection3C9 | GPIO Data Direction 3: C9
Public property | GPIODataOut1R0 | GPIO Data Out 1: R0
Public property | GPIODataOut1R1 | GPIO Data Out 1: R1
Public property | GPIODataOut1R2 | GPIO Data Out 1: R2
Public property | GPIODataOut1R3 | GPIO Data Out 1: R3
Public property | GPIODataOut1R4 | GPIO Data Out 1: R4
Public property | GPIODataOut1R5 | GPIO Data Out 1: R5
Public property | GPIODataOut1R6 | GPIO Data Out 1: R6
Public property | GPIODataOut1R7 | GPIO Data Out 1: R7
Public property | GPIODataOut2C0 | GPIO Data Out 2: C0
Public property | GPIODataOut2C1 | GPIO Data Out 2: C1
Public property | GPIODataOut2C2 | GPIO Data Out 2: C2
Public property | GPIODataOut2C3 | GPIO Data Out 2: C3
Public property | GPIODataOut2C4 | GPIO Data Out 2: C4
Public property | GPIODataOut2C5 | GPIO Data Out 2: C5
Public property | GPIODataOut2C6 | GPIO Data Out 2: C6
Public property | GPIODataOut2C7 | GPIO Data Out 2: C7
Public property | GPIODataOut3C8 | GPIO Data Out 3: C8
Public property | GPIODataOut3C9 | GPIO Data Out 3: C9
Public property | GPIODataStatus1R0 | GPIO Data Status 1: R0
Public property | GPIODataStatus1R1 | GPIO Data Status 1: R1
Public property | GPIODataStatus1R2 | GPIO Data Status 1: R2
Public property | GPIODataStatus1R3 | GPIO Data Status 1: R3
Public property | GPIODataStatus1R4 | GPIO Data Status 1: R4
Public property | GPIODataStatus1R5 | GPIO Data Status 1: R5
Public property | GPIODataStatus1R6 | GPIO Data Status 1: R6
Public property | GPIODataStatus1R7 | GPIO Data Status 1: R7
Public property | GPIODataStatus2C0 | GPIO Data Status 2: C0
Public property | GPIODataStatus2C1 | GPIO Data Status 2: C1
Public property | GPIODataStatus2C2 | GPIO Data Status 2: C2
Public property | GPIODataStatus2C3 | GPIO Data Status 2: C3
Public property | GPIODataStatus2C4 | GPIO Data Status 2: C4
Public property | GPIODataStatus2C5 | GPIO Data Status 2: C5
Public property | GPIODataStatus2C6 | GPIO Data Status 2: C6
Public property | GPIODataStatus2C7 | GPIO Data Status 2: C7
Public property | GPIODataStatus3C8 | GPIO Data Status 3: C8
Public property | GPIODataStatus3C9 | GPIO Data Status 3: C9
Public property | GPIOInterruptEnable1R0 | GPIO Interrupt Enable 1: R0
Public property | GPIOInterruptEnable1R1 | GPIO Interrupt Enable 1: R1
Public property | GPIOInterruptEnable1R2 | GPIO Interrupt Enable 1: R2
Public property | GPIOInterruptEnable1R3 | GPIO Interrupt Enable 1: R3
Public property | GPIOInterruptEnable1R4 | GPIO Interrupt Enable 1: R4
Public property | GPIOInterruptEnable1R5 | GPIO Interrupt Enable 1: R5
Public property | GPIOInterruptEnable1R6 | GPIO Interrupt Enable 1: R6
Public property | GPIOInterruptEnable1R7 | GPIO Interrupt Enable 1: R7
Public property | GPIOInterruptEnable2C0 | GPIO Interrupt Enable 2: C0
Public property | GPIOInterruptEnable2C1 | GPIO Interrupt Enable 2: C1
Public property | GPIOInterruptEnable2C2 | GPIO Interrupt Enable 2: C2
Public property | GPIOInterruptEnable2C3 | GPIO Interrupt Enable 2: C3
Public property | GPIOInterruptEnable2C4 | GPIO Interrupt Enable 2: C4
Public property | GPIOInterruptEnable2C5 | GPIO Interrupt Enable 2: C5
Public property | GPIOInterruptEnable2C6 | GPIO Interrupt Enable 2: C6
Public property | GPIOInterruptEnable2C7 | GPIO Interrupt Enable 2: C7
Public property | GPIOInterruptEnable3C8 | GPIO Interrupt Enable 3: C8
Public property | GPIOInterruptEnable3C9 | GPIO Interrupt Enable 3: C9
Public property | GPIOInterruptStatus1R0 | GPIO Interrupt Status 1: R0
Public property | GPIOInterruptStatus1R1 | GPIO Interrupt Status 1: R1
Public property | GPIOInterruptStatus1R2 | GPIO Interrupt Status 1: R2
Public property | GPIOInterruptStatus1R3 | GPIO Interrupt Status 1: R3
Public property | GPIOInterruptStatus1R4 | GPIO Interrupt Status 1: R4
Public property | GPIOInterruptStatus1R5 | GPIO Interrupt Status 1: R5
Public property | GPIOInterruptStatus1R6 | GPIO Interrupt Status 1: R6
Public property | GPIOInterruptStatus1R7 | GPIO Interrupt Status 1: R7
Public property | GPIOInterruptStatus2C0 | GPIO Interrupt Status 2: C0
Public property | GPIOInterruptStatus2C1 | GPIO Interrupt Status 2: C1
Public property | GPIOInterruptStatus2C2 | GPIO Interrupt Status 2: C2
Public property | GPIOInterruptStatus2C3 | GPIO Interrupt Status 2: C3
Public property | GPIOInterruptStatus2C4 | GPIO Interrupt Status 2: C4
Public property | GPIOInterruptStatus2C5 | GPIO Interrupt Status 2: C5
Public property | GPIOInterruptStatus2C6 | GPIO Interrupt Status 2: C6
Public property | GPIOInterruptStatus2C7 | GPIO Interrupt Status 2: C7
Public property | GPIOInterruptStatus3C8 | GPIO Interrupt Status 3: C8
Public property | GPIOInterruptStatus3C9 | GPIO Interrupt Status 3: C9
Public property | GPIOLevelDetect1R0 | GPIO Level Detect 1: R0
Public property | GPIOLevelDetect1R1 | GPIO Level Detect 1: R1
Public property | GPIOLevelDetect1R2 | GPIO Level Detect 1: R2
Public property | GPIOLevelDetect1R3 | GPIO Level Detect 1: R3
Public property | GPIOLevelDetect1R4 | GPIO Level Detect 1: R4
Public property | GPIOLevelDetect1R5 | GPIO Level Detect 1: R5
Public property | GPIOLevelDetect1R6 | GPIO Level Detect 1: R6
Public property | GPIOLevelDetect1R7 | GPIO Level Detect 1: R7
Public property | GPIOLevelDetect2C0 | GPIO Level Detect 2: C0
Public property | GPIOLevelDetect2C1 | GPIO Level Detect 2: C1
Public property | GPIOLevelDetect2C2 | GPIO Level Detect 2: C2
Public property | GPIOLevelDetect2C3 | GPIO Level Detect 2: C3
Public property | GPIOLevelDetect2C4 | GPIO Level Detect 2: C4
Public property | GPIOLevelDetect2C5 | GPIO Level Detect 2: C5
Public property | GPIOLevelDetect2C6 | GPIO Level Detect 2: C6
Public property | GPIOLevelDetect2C7 | GPIO Level Detect 2: C7
Public property | GPIOLevelDetect3C8 | GPIO Level Detect 3: C8
Public property | GPIOLevelDetect3C9 | GPIO Level Detect 3: C9
Public property | GPIOPullDisable1R0 | GPIO Pull Disable 1: R0
Public property | GPIOPullDisable1R1 | GPIO Pull Disable 1: R1
Public property | GPIOPullDisable1R2 | GPIO Pull Disable 1: R2
Public property | GPIOPullDisable1R3 | GPIO Pull Disable 1: R3
Public property | GPIOPullDisable1R4 | GPIO Pull Disable 1: R4
Public property | GPIOPullDisable1R5 | GPIO Pull Disable 1: R5
Public property | GPIOPullDisable1R6 | GPIO Pull Disable 1: R6
Public property | GPIOPullDisable1R7 | GPIO Pull Disable 1: R7
Public property | GPIOPullDisable2C0 | GPIO Pull Disable 2: C0
Public property | GPIOPullDisable2C1 | GPIO Pull Disable 2: C1
Public property | GPIOPullDisable2C2 | GPIO Pull Disable 2: C2
Public property | GPIOPullDisable2C3 | GPIO Pull Disable 2: C3
Public property | GPIOPullDisable2C4 | GPIO Pull Disable 2: C4
Public property | GPIOPullDisable2C5 | GPIO Pull Disable 2: C5
Public property | GPIOPullDisable2C6 | GPIO Pull Disable 2: C6
Public property | GPIOPullDisable2C7 | GPIO Pull Disable 2: C7
Public property | GPIOPullDisable3C8 | GPIO Pull Disable 3: C8
Public property | GPIOPullDisable3C9 | GPIO Pull Disable 3: C9
Public property | InterruptStatusGPIINT | Interrupt Status: GPI_INT
Public property | InterruptStatusKEINT | Interrupt Status: KE_INT
Public property | InterruptStatusKLCKINT | Interrupt Status: K_LCK_INT
Public property | InterruptStatusOVRFLOWINT | Interrupt Status: OVR_FLOW_INT
Public property | KeyEventAKeyNumber | Key Event A: Key Number
Public property | KeyEventAStatus | Key Event A: Status
Public property | KeyEventBKeyNumber | Key Event B: Key Number
Public property | KeyEventBStatus | Key Event B: Status
Public property | KeyEventCKeyNumber | Key Event C: Key Number
Public property | KeyEventCStatus | Key Event C: Status
Public property | KeyEventDKeyNumber | Key Event D: Key Number
Public property | KeyEventDStatus | Key Event D: Status
Public property | KeyEventEKeyNumber | Key Event E: Key Number
Public property | KeyEventEStatus | Key Event E: Status
Public property | KeyEventFKeyNumber | Key Event F: Key Number
Public property | KeyEventFStatus | Key Event F: Status
Public property | KeyEventGKeyNumber | Key Event G: Key Number
Public property | KeyEventGStatus | Key Event G: Status
Public property | KeyEventHKeyNumber | Key Event H: Key Number
Public property | KeyEventHStatus | Key Event H: Status
Public property | KeyEventIKeyNumber | Key Event I: Key Number
Public property | KeyEventIStatus | Key Event I: Status
Public property | KeyEventJKeyNumber | Key Event J: Key Number
Public property | KeyEventJStatus | Key Event J: Status
Public property | KeylockEventCounterKEC | Keylock & Event Counter: KEC
Public property | KeylockEventCounterKLCKEN | Keylock & Event Counter: K_LCK_EN
Public property | KeylockEventCounterLCK2LCK1 | Keylock & Event Counter: LCK2, LCK1
Public property | KeypadLockInterruptMaskTimer | Keypad Lock Interrupt Mask Timer (unit: s)
Public property | KeypadOrGPIOSelection1R0 | Keypad or GPIO Selection 1: R0
Public property | KeypadOrGPIOSelection1R1 | Keypad or GPIO Selection 1: R1
Public property | KeypadOrGPIOSelection1R2 | Keypad or GPIO Selection 1: R2
Public property | KeypadOrGPIOSelection1R3 | Keypad or GPIO Selection 1: R3
Public property | KeypadOrGPIOSelection1R4 | Keypad or GPIO Selection 1: R4
Public property | KeypadOrGPIOSelection1R5 | Keypad or GPIO Selection 1: R5
Public property | KeypadOrGPIOSelection1R6 | Keypad or GPIO Selection 1: R6
Public property | KeypadOrGPIOSelection1R7 | Keypad or GPIO Selection 1: R7
Public property | KeypadOrGPIOSelection2C0 | Keypad or GPIO Selection 2: C0
Public property | KeypadOrGPIOSelection2C1 | Keypad or GPIO Selection 2: C1
Public property | KeypadOrGPIOSelection2C2 | Keypad or GPIO Selection 2: C2
Public property | KeypadOrGPIOSelection2C3 | Keypad or GPIO Selection 2: C3
Public property | KeypadOrGPIOSelection2C4 | Keypad or GPIO Selection 2: C4
Public property | KeypadOrGPIOSelection2C5 | Keypad or GPIO Selection 2: C5
Public property | KeypadOrGPIOSelection2C6 | Keypad or GPIO Selection 2: C6
Public property | KeypadOrGPIOSelection2C7 | Keypad or GPIO Selection 2: C7
Public property | KeypadOrGPIOSelection3C8 | Keypad or GPIO Selection 3: C8
Public property | KeypadOrGPIOSelection3C9 | Keypad or GPIO Selection 3: C9
Public property | KeypadUnlock1TimerToKeypadUnlock2Timer | Keypad Unlock 1 Timer to Keypad Unlock 2 Timer (unit: s)
Public property | UnlockKey1 | Unlock Key 1
Public property | UnlockKey2 | Unlock Key 2
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Mobile I/O Expander and QWERTY Keypad Controller
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adp5587(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adp5587

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587 Properties

The Adp5587 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationAUTOINC | Configuration: AUTO_INC
Public property | ConfigurationGPIEMCFG | Configuration: GPIEM_CFG
Public property | ConfigurationGPIIEN | Configuration: GPI_IEN
Public property | ConfigurationINTCFG | Configuration: INT_CFG
Public property | ConfigurationKEIEN | Configuration: KE_IEN
Public property | ConfigurationKLCKIM | Configuration: K_LCK_IM
Public property | ConfigurationOVRFLOWIEN | Configuration: OVR_FLOW_IEN
Public property | ConfigurationOVRFLOWM | Configuration: OVR_FLOW_M
Public property | DebounceDisable1R0 | Debounce Disable 1: R0
Public property | DebounceDisable1R1 | Debounce Disable 1: R1
Public property | DebounceDisable1R2 | Debounce Disable 1: R2
Public property | DebounceDisable1R3 | Debounce Disable 1: R3
Public property | DebounceDisable1R4 | Debounce Disable 1: R4
Public property | DebounceDisable1R5 | Debounce Disable 1: R5
Public property | DebounceDisable1R6 | Debounce Disable 1: R6
Public property | DebounceDisable1R7 | Debounce Disable 1: R7
Public property | DebounceDisable2C0 | Debounce Disable 2: C0
Public property | DebounceDisable2C1 | Debounce Disable 2: C1
Public property | DebounceDisable2C2 | Debounce Disable 2: C2
Public property | DebounceDisable2C3 | Debounce Disable 2: C3
Public property | DebounceDisable2C4 | Debounce Disable 2: C4
Public property | DebounceDisable2C5 | Debounce Disable 2: C5
Public property | DebounceDisable2C6 | Debounce Disable 2: C6
Public property | DebounceDisable2C7 | Debounce Disable 2: C7
Public property | DebounceDisable3C8 | Debounce Disable 3: C8
Public property | DebounceDisable3C9 | Debounce Disable 3: C9
Public property | DeviceIDDeviceID | Device ID: Device ID
Public property | DeviceIDMFGID | Device ID: MFG ID
Public property | GPIEventMode1R0 | GPI Event Mode 1: R0
Public property | GPIEventMode1R1 | GPI Event Mode 1: R1
Public property | GPIEventMode1R2 | GPI Event Mode 1: R2
Public property | GPIEventMode1R3 | GPI Event Mode 1: R3
Public property | GPIEventMode1R4 | GPI Event Mode 1: R4
Public property | GPIEventMode1R5 | GPI Event Mode 1: R5
Public property | GPIEventMode1R6 | GPI Event Mode 1: R6
Public property | GPIEventMode1R7 | GPI Event Mode 1: R7
Public property | GPIEventMode2C0 | GPI Event Mode 2: C0
Public property | GPIEventMode2C1 | GPI Event Mode 2: C1
Public property | GPIEventMode2C2 | GPI Event Mode 2: C2
Public property | GPIEventMode2C3 | GPI Event Mode 2: C3
Public property | GPIEventMode2C4 | GPI Event Mode 2: C4
Public property | GPIEventMode2C5 | GPI Event Mode 2: C5
Public property | GPIEventMode2C6 | GPI Event Mode 2: C6
Public property | GPIEventMode2C7 | GPI Event Mode 2: C7
Public property | GPIEventMode3C8 | GPI Event Mode 3: C8
Public property | GPIEventMode3C9 | GPI Event Mode 3: C9
Public property | GPIODataDirection1R0 | GPIO Data Direction 1: R0
Public property | GPIODataDirection1R1 | GPIO Data Direction 1: R1
Public property | GPIODataDirection1R2 | GPIO Data Direction 1: R2
Public property | GPIODataDirection1R3 | GPIO Data Direction 1: R3
Public property | GPIODataDirection1R4 | GPIO Data Direction 1: R4
Public property | GPIODataDirection1R5 | GPIO Data Direction 1: R5
Public property | GPIODataDirection1R6 | GPIO Data Direction 1: R6
Public property | GPIODataDirection1R7 | GPIO Data Direction 1: R7
Public property | GPIODataDirection2C0 | GPIO Data Direction 2: C0
Public property | GPIODataDirection2C1 | GPIO Data Direction 2: C1
Public property | GPIODataDirection2C2 | GPIO Data Direction 2: C2
Public property | GPIODataDirection2C3 | GPIO Data Direction 2: C3
Public property | GPIODataDirection2C4 | GPIO Data Direction 2: C4
Public property | GPIODataDirection2C5 | GPIO Data Direction 2: C5
Public property | GPIODataDirection2C6 | GPIO Data Direction 2: C6
Public property | GPIODataDirection2C7 | GPIO Data Direction 2: C7
Public property | GPIODataDirection3C8 | GPIO Data Direction 3: C8
Public property | GPIODataDirection3C9 | GPIO Data Direction 3: C9
Public property | GPIODataOut1R0 | GPIO Data Out 1: R0
Public property | GPIODataOut1R1 | GPIO Data Out 1: R1
Public property | GPIODataOut1R2 | GPIO Data Out 1: R2
Public property | GPIODataOut1R3 | GPIO Data Out 1: R3
Public property | GPIODataOut1R4 | GPIO Data Out 1: R4
Public property | GPIODataOut1R5 | GPIO Data Out 1: R5
Public property | GPIODataOut1R6 | GPIO Data Out 1: R6
Public property | GPIODataOut1R7 | GPIO Data Out 1: R7
Public property | GPIODataOut2C0 | GPIO Data Out 2: C0
Public property | GPIODataOut2C1 | GPIO Data Out 2: C1
Public property | GPIODataOut2C2 | GPIO Data Out 2: C2
Public property | GPIODataOut2C3 | GPIO Data Out 2: C3
Public property | GPIODataOut2C4 | GPIO Data Out 2: C4
Public property | GPIODataOut2C5 | GPIO Data Out 2: C5
Public property | GPIODataOut2C6 | GPIO Data Out 2: C6
Public property | GPIODataOut2C7 | GPIO Data Out 2: C7
Public property | GPIODataOut3C8 | GPIO Data Out 3: C8
Public property | GPIODataOut3C9 | GPIO Data Out 3: C9
Public property | GPIODataStatus1R0 | GPIO Data Status 1: R0
Public property | GPIODataStatus1R1 | GPIO Data Status 1: R1
Public property | GPIODataStatus1R2 | GPIO Data Status 1: R2
Public property | GPIODataStatus1R3 | GPIO Data Status 1: R3
Public property | GPIODataStatus1R4 | GPIO Data Status 1: R4
Public property | GPIODataStatus1R5 | GPIO Data Status 1: R5
Public property | GPIODataStatus1R6 | GPIO Data Status 1: R6
Public property | GPIODataStatus1R7 | GPIO Data Status 1: R7
Public property | GPIODataStatus2C0 | GPIO Data Status 2: C0
Public property | GPIODataStatus2C1 | GPIO Data Status 2: C1
Public property | GPIODataStatus2C2 | GPIO Data Status 2: C2
Public property | GPIODataStatus2C3 | GPIO Data Status 2: C3
Public property | GPIODataStatus2C4 | GPIO Data Status 2: C4
Public property | GPIODataStatus2C5 | GPIO Data Status 2: C5
Public property | GPIODataStatus2C6 | GPIO Data Status 2: C6
Public property | GPIODataStatus2C7 | GPIO Data Status 2: C7
Public property | GPIODataStatus3C8 | GPIO Data Status 3: C8
Public property | GPIODataStatus3C9 | GPIO Data Status 3: C9
Public property | GPIOInterruptEnable1R0 | GPIO Interrupt Enable 1: R0
Public property | GPIOInterruptEnable1R1 | GPIO Interrupt Enable 1: R1
Public property | GPIOInterruptEnable1R2 | GPIO Interrupt Enable 1: R2
Public property | GPIOInterruptEnable1R3 | GPIO Interrupt Enable 1: R3
Public property | GPIOInterruptEnable1R4 | GPIO Interrupt Enable 1: R4
Public property | GPIOInterruptEnable1R5 | GPIO Interrupt Enable 1: R5
Public property | GPIOInterruptEnable1R6 | GPIO Interrupt Enable 1: R6
Public property | GPIOInterruptEnable1R7 | GPIO Interrupt Enable 1: R7
Public property | GPIOInterruptEnable2C0 | GPIO Interrupt Enable 2: C0
Public property | GPIOInterruptEnable2C1 | GPIO Interrupt Enable 2: C1
Public property | GPIOInterruptEnable2C2 | GPIO Interrupt Enable 2: C2
Public property | GPIOInterruptEnable2C3 | GPIO Interrupt Enable 2: C3
Public property | GPIOInterruptEnable2C4 | GPIO Interrupt Enable 2: C4
Public property | GPIOInterruptEnable2C5 | GPIO Interrupt Enable 2: C5
Public property | GPIOInterruptEnable2C6 | GPIO Interrupt Enable 2: C6
Public property | GPIOInterruptEnable2C7 | GPIO Interrupt Enable 2: C7
Public property | GPIOInterruptEnable3C8 | GPIO Interrupt Enable 3: C8
Public property | GPIOInterruptEnable3C9 | GPIO Interrupt Enable 3: C9
Public property | GPIOInterruptStatus1R0 | GPIO Interrupt Status 1: R0
Public property | GPIOInterruptStatus1R1 | GPIO Interrupt Status 1: R1
Public property | GPIOInterruptStatus1R2 | GPIO Interrupt Status 1: R2
Public property | GPIOInterruptStatus1R3 | GPIO Interrupt Status 1: R3
Public property | GPIOInterruptStatus1R4 | GPIO Interrupt Status 1: R4
Public property | GPIOInterruptStatus1R5 | GPIO Interrupt Status 1: R5
Public property | GPIOInterruptStatus1R6 | GPIO Interrupt Status 1: R6
Public property | GPIOInterruptStatus1R7 | GPIO Interrupt Status 1: R7
Public property | GPIOInterruptStatus2C0 | GPIO Interrupt Status 2: C0
Public property | GPIOInterruptStatus2C1 | GPIO Interrupt Status 2: C1
Public property | GPIOInterruptStatus2C2 | GPIO Interrupt Status 2: C2
Public property | GPIOInterruptStatus2C3 | GPIO Interrupt Status 2: C3
Public property | GPIOInterruptStatus2C4 | GPIO Interrupt Status 2: C4
Public property | GPIOInterruptStatus2C5 | GPIO Interrupt Status 2: C5
Public property | GPIOInterruptStatus2C6 | GPIO Interrupt Status 2: C6
Public property | GPIOInterruptStatus2C7 | GPIO Interrupt Status 2: C7
Public property | GPIOInterruptStatus3C8 | GPIO Interrupt Status 3: C8
Public property | GPIOInterruptStatus3C9 | GPIO Interrupt Status 3: C9
Public property | GPIOLevelDetect1R0 | GPIO Level Detect 1: R0
Public property | GPIOLevelDetect1R1 | GPIO Level Detect 1: R1
Public property | GPIOLevelDetect1R2 | GPIO Level Detect 1: R2
Public property | GPIOLevelDetect1R3 | GPIO Level Detect 1: R3
Public property | GPIOLevelDetect1R4 | GPIO Level Detect 1: R4
Public property | GPIOLevelDetect1R5 | GPIO Level Detect 1: R5
Public property | GPIOLevelDetect1R6 | GPIO Level Detect 1: R6
Public property | GPIOLevelDetect1R7 | GPIO Level Detect 1: R7
Public property | GPIOLevelDetect2C0 | GPIO Level Detect 2: C0
Public property | GPIOLevelDetect2C1 | GPIO Level Detect 2: C1
Public property | GPIOLevelDetect2C2 | GPIO Level Detect 2: C2
Public property | GPIOLevelDetect2C3 | GPIO Level Detect 2: C3
Public property | GPIOLevelDetect2C4 | GPIO Level Detect 2: C4
Public property | GPIOLevelDetect2C5 | GPIO Level Detect 2: C5
Public property | GPIOLevelDetect2C6 | GPIO Level Detect 2: C6
Public property | GPIOLevelDetect2C7 | GPIO Level Detect 2: C7
Public property | GPIOLevelDetect3C8 | GPIO Level Detect 3: C8
Public property | GPIOLevelDetect3C9 | GPIO Level Detect 3: C9
Public property | GPIOPullDisable1R0 | GPIO Pull Disable 1: R0
Public property | GPIOPullDisable1R1 | GPIO Pull Disable 1: R1
Public property | GPIOPullDisable1R2 | GPIO Pull Disable 1: R2
Public property | GPIOPullDisable1R3 | GPIO Pull Disable 1: R3
Public property | GPIOPullDisable1R4 | GPIO Pull Disable 1: R4
Public property | GPIOPullDisable1R5 | GPIO Pull Disable 1: R5
Public property | GPIOPullDisable1R6 | GPIO Pull Disable 1: R6
Public property | GPIOPullDisable1R7 | GPIO Pull Disable 1: R7
Public property | GPIOPullDisable2C0 | GPIO Pull Disable 2: C0
Public property | GPIOPullDisable2C1 | GPIO Pull Disable 2: C1
Public property | GPIOPullDisable2C2 | GPIO Pull Disable 2: C2
Public property | GPIOPullDisable2C3 | GPIO Pull Disable 2: C3
Public property | GPIOPullDisable2C4 | GPIO Pull Disable 2: C4
Public property | GPIOPullDisable2C5 | GPIO Pull Disable 2: C5
Public property | GPIOPullDisable2C6 | GPIO Pull Disable 2: C6
Public property | GPIOPullDisable2C7 | GPIO Pull Disable 2: C7
Public property | GPIOPullDisable3C8 | GPIO Pull Disable 3: C8
Public property | GPIOPullDisable3C9 | GPIO Pull Disable 3: C9
Public property | InterruptStatusGPIINT | Interrupt Status: GPI_INT
Public property | InterruptStatusKEINT | Interrupt Status: KE_INT
Public property | InterruptStatusKLCKINT | Interrupt Status: K_LCK_INT
Public property | InterruptStatusOVRFLOWINT | Interrupt Status: OVR_FLOW_INT
Public property | KeyEventAKeyNumber | Key Event A: Key Number
Public property | KeyEventAStatus | Key Event A: Status
Public property | KeyEventBKeyNumber | Key Event B: Key Number
Public property | KeyEventBStatus | Key Event B: Status
Public property | KeyEventCKeyNumber | Key Event C: Key Number
Public property | KeyEventCStatus | Key Event C: Status
Public property | KeyEventDKeyNumber | Key Event D: Key Number
Public property | KeyEventDStatus | Key Event D: Status
Public property | KeyEventEKeyNumber | Key Event E: Key Number
Public property | KeyEventEStatus | Key Event E: Status
Public property | KeyEventFKeyNumber | Key Event F: Key Number
Public property | KeyEventFStatus | Key Event F: Status
Public property | KeyEventGKeyNumber | Key Event G: Key Number
Public property | KeyEventGStatus | Key Event G: Status
Public property | KeyEventHKeyNumber | Key Event H: Key Number
Public property | KeyEventHStatus | Key Event H: Status
Public property | KeyEventIKeyNumber | Key Event I: Key Number
Public property | KeyEventIStatus | Key Event I: Status
Public property | KeyEventJKeyNumber | Key Event J: Key Number
Public property | KeyEventJStatus | Key Event J: Status
Public property | KeylockEventCounterKEC | Keylock & Event Counter: KEC
Public property | KeylockEventCounterKLCKEN | Keylock & Event Counter: K_LCK_EN
Public property | KeylockEventCounterLCK2LCK1 | Keylock & Event Counter: LCK2, LCK1
Public property | KeypadLockInterruptMaskTimer | Keypad Lock Interrupt Mask Timer (unit: s)
Public property | KeypadOrGPIOSelection1R0 | Keypad or GPIO Selection 1: R0
Public property | KeypadOrGPIOSelection1R1 | Keypad or GPIO Selection 1: R1
Public property | KeypadOrGPIOSelection1R2 | Keypad or GPIO Selection 1: R2
Public property | KeypadOrGPIOSelection1R3 | Keypad or GPIO Selection 1: R3
Public property | KeypadOrGPIOSelection1R4 | Keypad or GPIO Selection 1: R4
Public property | KeypadOrGPIOSelection1R5 | Keypad or GPIO Selection 1: R5
Public property | KeypadOrGPIOSelection1R6 | Keypad or GPIO Selection 1: R6
Public property | KeypadOrGPIOSelection1R7 | Keypad or GPIO Selection 1: R7
Public property | KeypadOrGPIOSelection2C0 | Keypad or GPIO Selection 2: C0
Public property | KeypadOrGPIOSelection2C1 | Keypad or GPIO Selection 2: C1
Public property | KeypadOrGPIOSelection2C2 | Keypad or GPIO Selection 2: C2
Public property | KeypadOrGPIOSelection2C3 | Keypad or GPIO Selection 2: C3
Public property | KeypadOrGPIOSelection2C4 | Keypad or GPIO Selection 2: C4
Public property | KeypadOrGPIOSelection2C5 | Keypad or GPIO Selection 2: C5
Public property | KeypadOrGPIOSelection2C6 | Keypad or GPIO Selection 2: C6
Public property | KeypadOrGPIOSelection2C7 | Keypad or GPIO Selection 2: C7
Public property | KeypadOrGPIOSelection3C8 | Keypad or GPIO Selection 3: C8
Public property | KeypadOrGPIOSelection3C9 | Keypad or GPIO Selection 3: C9
Public property | KeypadUnlock1TimerToKeypadUnlock2Timer | Keypad Unlock 1 Timer to Keypad Unlock 2 Timer (unit: s)
Public property | UnlockKey1 | Unlock Key 1
Public property | UnlockKey2 | Unlock Key 2
Top
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.AutoFlush Property

IRD

Adp5587AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.ConfigurationAUTOINC Property

IRD

Adp5587ConfigurationAUTOINC Property

Configuration: AUTO_INC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeCfgAutoInc ConfigurationAUTOINC { get; set; }
Public Property ConfigurationAUTOINC As Adp5587TypeCfgAutoInc
    Get
    Set
public:
property Adp5587TypeCfgAutoInc ConfigurationAUTOINC {
    Adp5587TypeCfgAutoInc get ();
    void set (Adp5587TypeCfgAutoInc value);
}
member ConfigurationAUTOINC : Adp5587TypeCfgAutoInc with get, set

Property Value

Type: Adp5587TypeCfgAutoInc
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.ConfigurationGPIEMCFG Property

IRD

Adp5587ConfigurationGPIEMCFG Property

Configuration: GPIEM_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeCfgGpiemCfg ConfigurationGPIEMCFG { get; set; }
Public Property ConfigurationGPIEMCFG As Adp5587TypeCfgGpiemCfg
    Get
    Set
public:
property Adp5587TypeCfgGpiemCfg ConfigurationGPIEMCFG {
    Adp5587TypeCfgGpiemCfg get ();
    void set (Adp5587TypeCfgGpiemCfg value);
}
member ConfigurationGPIEMCFG : Adp5587TypeCfgGpiemCfg with get, set

Property Value

Type: Adp5587TypeCfgGpiemCfg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.ConfigurationGPIIEN Property

IRD

Adp5587ConfigurationGPIIEN Property

Configuration: GPI_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeCfgGpiIen ConfigurationGPIIEN { get; set; }
Public Property ConfigurationGPIIEN As Adp5587TypeCfgGpiIen
    Get
    Set
public:
property Adp5587TypeCfgGpiIen ConfigurationGPIIEN {
    Adp5587TypeCfgGpiIen get ();
    void set (Adp5587TypeCfgGpiIen value);
}
member ConfigurationGPIIEN : Adp5587TypeCfgGpiIen with get, set

Property Value

Type: Adp5587TypeCfgGpiIen
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.ConfigurationINTCFG Property

IRD

Adp5587ConfigurationINTCFG Property

Configuration: INT_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeCfgIntCfg ConfigurationINTCFG { get; set; }
Public Property ConfigurationINTCFG As Adp5587TypeCfgIntCfg
    Get
    Set
public:
property Adp5587TypeCfgIntCfg ConfigurationINTCFG {
    Adp5587TypeCfgIntCfg get ();
    void set (Adp5587TypeCfgIntCfg value);
}
member ConfigurationINTCFG : Adp5587TypeCfgIntCfg with get, set

Property Value

Type: Adp5587TypeCfgIntCfg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.ConfigurationKEIEN Property

IRD

Adp5587ConfigurationKEIEN Property

Configuration: KE_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeCfgKeIen ConfigurationKEIEN { get; set; }
Public Property ConfigurationKEIEN As Adp5587TypeCfgKeIen
    Get
    Set
public:
property Adp5587TypeCfgKeIen ConfigurationKEIEN {
    Adp5587TypeCfgKeIen get ();
    void set (Adp5587TypeCfgKeIen value);
}
member ConfigurationKEIEN : Adp5587TypeCfgKeIen with get, set

Property Value

Type: Adp5587TypeCfgKeIen
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.ConfigurationKLCKIM Property

IRD

Adp5587ConfigurationKLCKIM Property

Configuration: K_LCK_IM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeCfgKLckM ConfigurationKLCKIM { get; set; }
Public Property ConfigurationKLCKIM As Adp5587TypeCfgKLckM
    Get
    Set
public:
property Adp5587TypeCfgKLckM ConfigurationKLCKIM {
    Adp5587TypeCfgKLckM get ();
    void set (Adp5587TypeCfgKLckM value);
}
member ConfigurationKLCKIM : Adp5587TypeCfgKLckM with get, set

Property Value

Type: Adp5587TypeCfgKLckM
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.ConfigurationOVRFLOWIEN Property

IRD

Adp5587ConfigurationOVRFLOWIEN Property

Configuration: OVR_FLOW_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeCfgOvrFlowIen ConfigurationOVRFLOWIEN { get; set; }
Public Property ConfigurationOVRFLOWIEN As Adp5587TypeCfgOvrFlowIen
    Get
    Set
public:
property Adp5587TypeCfgOvrFlowIen ConfigurationOVRFLOWIEN {
    Adp5587TypeCfgOvrFlowIen get ();
    void set (Adp5587TypeCfgOvrFlowIen value);
}
member ConfigurationOVRFLOWIEN : Adp5587TypeCfgOvrFlowIen with get, set

Property Value

Type: Adp5587TypeCfgOvrFlowIen
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.ConfigurationOVRFLOWM Property

IRD

Adp5587ConfigurationOVRFLOWM Property

Configuration: OVR_FLOW_M

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeCfgOvrFlowM ConfigurationOVRFLOWM { get; set; }
Public Property ConfigurationOVRFLOWM As Adp5587TypeCfgOvrFlowM
    Get
    Set
public:
property Adp5587TypeCfgOvrFlowM ConfigurationOVRFLOWM {
    Adp5587TypeCfgOvrFlowM get ();
    void set (Adp5587TypeCfgOvrFlowM value);
}
member ConfigurationOVRFLOWM : Adp5587TypeCfgOvrFlowM with get, set

Property Value

Type: Adp5587TypeCfgOvrFlowM
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DebounceDisable1R0 Property

IRD

Adp5587DebounceDisable1R0 Property

Debounce Disable 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable1R0 { get; set; }
Public Property DebounceDisable1R0 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable1R0 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable1R0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DebounceDisable1R1 Property

IRD

Adp5587DebounceDisable1R1 Property

Debounce Disable 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable1R1 { get; set; }
Public Property DebounceDisable1R1 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable1R1 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable1R1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DebounceDisable1R2 Property

IRD

Adp5587DebounceDisable1R2 Property

Debounce Disable 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable1R2 { get; set; }
Public Property DebounceDisable1R2 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable1R2 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable1R2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DebounceDisable1R3 Property

IRD

Adp5587DebounceDisable1R3 Property

Debounce Disable 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable1R3 { get; set; }
Public Property DebounceDisable1R3 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable1R3 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable1R3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DebounceDisable1R4 Property

IRD

Adp5587DebounceDisable1R4 Property

Debounce Disable 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable1R4 { get; set; }
Public Property DebounceDisable1R4 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable1R4 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable1R4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DebounceDisable1R5 Property

IRD

Adp5587DebounceDisable1R5 Property

Debounce Disable 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable1R5 { get; set; }
Public Property DebounceDisable1R5 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable1R5 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable1R5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DebounceDisable1R6 Property

IRD

Adp5587DebounceDisable1R6 Property

Debounce Disable 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable1R6 { get; set; }
Public Property DebounceDisable1R6 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable1R6 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable1R6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DebounceDisable1R7 Property

IRD

Adp5587DebounceDisable1R7 Property

Debounce Disable 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable1R7 { get; set; }
Public Property DebounceDisable1R7 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable1R7 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable1R7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DebounceDisable2C0 Property

IRD

Adp5587DebounceDisable2C0 Property

Debounce Disable 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable2C0 { get; set; }
Public Property DebounceDisable2C0 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable2C0 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable2C0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DebounceDisable2C1 Property

IRD

Adp5587DebounceDisable2C1 Property

Debounce Disable 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable2C1 { get; set; }
Public Property DebounceDisable2C1 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable2C1 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable2C1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DebounceDisable2C2 Property

IRD

Adp5587DebounceDisable2C2 Property

Debounce Disable 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable2C2 { get; set; }
Public Property DebounceDisable2C2 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable2C2 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable2C2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DebounceDisable2C3 Property

IRD

Adp5587DebounceDisable2C3 Property

Debounce Disable 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable2C3 { get; set; }
Public Property DebounceDisable2C3 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable2C3 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable2C3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DebounceDisable2C4 Property

IRD

Adp5587DebounceDisable2C4 Property

Debounce Disable 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable2C4 { get; set; }
Public Property DebounceDisable2C4 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable2C4 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable2C4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DebounceDisable2C5 Property

IRD

Adp5587DebounceDisable2C5 Property

Debounce Disable 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable2C5 { get; set; }
Public Property DebounceDisable2C5 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable2C5 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable2C5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DebounceDisable2C6 Property

IRD

Adp5587DebounceDisable2C6 Property

Debounce Disable 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable2C6 { get; set; }
Public Property DebounceDisable2C6 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable2C6 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable2C6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DebounceDisable2C7 Property

IRD

Adp5587DebounceDisable2C7 Property

Debounce Disable 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable2C7 { get; set; }
Public Property DebounceDisable2C7 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable2C7 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable2C7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DebounceDisable3C8 Property

IRD

Adp5587DebounceDisable3C8 Property

Debounce Disable 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable3C8 { get; set; }
Public Property DebounceDisable3C8 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable3C8 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable3C8 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DebounceDisable3C9 Property

IRD

Adp5587DebounceDisable3C9 Property

Debounce Disable 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable3C9 { get; set; }
Public Property DebounceDisable3C9 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable3C9 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable3C9 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DeviceIDDeviceID Property

IRD

Adp5587DeviceIDDeviceID Property

Device ID: Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceIDDeviceID { get; set; }
Public Property DeviceIDDeviceID As Byte
    Get
    Set
public:
property unsigned char DeviceIDDeviceID {
    unsigned char get ();
    void set (unsigned char value);
}
member DeviceIDDeviceID : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.DeviceIDMFGID Property

IRD

Adp5587DeviceIDMFGID Property

Device ID: MFG ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceIDMFGID { get; set; }
Public Property DeviceIDMFGID As Byte
    Get
    Set
public:
property unsigned char DeviceIDMFGID {
    unsigned char get ();
    void set (unsigned char value);
}
member DeviceIDMFGID : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIEventMode1R0 Property

IRD

Adp5587GPIEventMode1R0 Property

GPI Event Mode 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpiEmReg GPIEventMode1R0 { get; set; }
Public Property GPIEventMode1R0 As Adp5587TypeGpiEmReg
    Get
    Set
public:
property Adp5587TypeGpiEmReg GPIEventMode1R0 {
    Adp5587TypeGpiEmReg get ();
    void set (Adp5587TypeGpiEmReg value);
}
member GPIEventMode1R0 : Adp5587TypeGpiEmReg with get, set

Property Value

Type: Adp5587TypeGpiEmReg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIEventMode1R1 Property

IRD

Adp5587GPIEventMode1R1 Property

GPI Event Mode 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpiEmReg GPIEventMode1R1 { get; set; }
Public Property GPIEventMode1R1 As Adp5587TypeGpiEmReg
    Get
    Set
public:
property Adp5587TypeGpiEmReg GPIEventMode1R1 {
    Adp5587TypeGpiEmReg get ();
    void set (Adp5587TypeGpiEmReg value);
}
member GPIEventMode1R1 : Adp5587TypeGpiEmReg with get, set

Property Value

Type: Adp5587TypeGpiEmReg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIEventMode1R2 Property

IRD

Adp5587GPIEventMode1R2 Property

GPI Event Mode 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpiEmReg GPIEventMode1R2 { get; set; }
Public Property GPIEventMode1R2 As Adp5587TypeGpiEmReg
    Get
    Set
public:
property Adp5587TypeGpiEmReg GPIEventMode1R2 {
    Adp5587TypeGpiEmReg get ();
    void set (Adp5587TypeGpiEmReg value);
}
member GPIEventMode1R2 : Adp5587TypeGpiEmReg with get, set

Property Value

Type: Adp5587TypeGpiEmReg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIEventMode1R3 Property

IRD

Adp5587GPIEventMode1R3 Property

GPI Event Mode 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpiEmReg GPIEventMode1R3 { get; set; }
Public Property GPIEventMode1R3 As Adp5587TypeGpiEmReg
    Get
    Set
public:
property Adp5587TypeGpiEmReg GPIEventMode1R3 {
    Adp5587TypeGpiEmReg get ();
    void set (Adp5587TypeGpiEmReg value);
}
member GPIEventMode1R3 : Adp5587TypeGpiEmReg with get, set

Property Value

Type: Adp5587TypeGpiEmReg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIEventMode1R4 Property

IRD

Adp5587GPIEventMode1R4 Property

GPI Event Mode 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpiEmReg GPIEventMode1R4 { get; set; }
Public Property GPIEventMode1R4 As Adp5587TypeGpiEmReg
    Get
    Set
public:
property Adp5587TypeGpiEmReg GPIEventMode1R4 {
    Adp5587TypeGpiEmReg get ();
    void set (Adp5587TypeGpiEmReg value);
}
member GPIEventMode1R4 : Adp5587TypeGpiEmReg with get, set

Property Value

Type: Adp5587TypeGpiEmReg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIEventMode1R5 Property

IRD

Adp5587GPIEventMode1R5 Property

GPI Event Mode 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpiEmReg GPIEventMode1R5 { get; set; }
Public Property GPIEventMode1R5 As Adp5587TypeGpiEmReg
    Get
    Set
public:
property Adp5587TypeGpiEmReg GPIEventMode1R5 {
    Adp5587TypeGpiEmReg get ();
    void set (Adp5587TypeGpiEmReg value);
}
member GPIEventMode1R5 : Adp5587TypeGpiEmReg with get, set

Property Value

Type: Adp5587TypeGpiEmReg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIEventMode1R6 Property

IRD

Adp5587GPIEventMode1R6 Property

GPI Event Mode 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpiEmReg GPIEventMode1R6 { get; set; }
Public Property GPIEventMode1R6 As Adp5587TypeGpiEmReg
    Get
    Set
public:
property Adp5587TypeGpiEmReg GPIEventMode1R6 {
    Adp5587TypeGpiEmReg get ();
    void set (Adp5587TypeGpiEmReg value);
}
member GPIEventMode1R6 : Adp5587TypeGpiEmReg with get, set

Property Value

Type: Adp5587TypeGpiEmReg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIEventMode1R7 Property

IRD

Adp5587GPIEventMode1R7 Property

GPI Event Mode 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpiEmReg GPIEventMode1R7 { get; set; }
Public Property GPIEventMode1R7 As Adp5587TypeGpiEmReg
    Get
    Set
public:
property Adp5587TypeGpiEmReg GPIEventMode1R7 {
    Adp5587TypeGpiEmReg get ();
    void set (Adp5587TypeGpiEmReg value);
}
member GPIEventMode1R7 : Adp5587TypeGpiEmReg with get, set

Property Value

Type: Adp5587TypeGpiEmReg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIEventMode2C0 Property

IRD

Adp5587GPIEventMode2C0 Property

GPI Event Mode 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpiEmReg GPIEventMode2C0 { get; set; }
Public Property GPIEventMode2C0 As Adp5587TypeGpiEmReg
    Get
    Set
public:
property Adp5587TypeGpiEmReg GPIEventMode2C0 {
    Adp5587TypeGpiEmReg get ();
    void set (Adp5587TypeGpiEmReg value);
}
member GPIEventMode2C0 : Adp5587TypeGpiEmReg with get, set

Property Value

Type: Adp5587TypeGpiEmReg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIEventMode2C1 Property

IRD

Adp5587GPIEventMode2C1 Property

GPI Event Mode 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpiEmReg GPIEventMode2C1 { get; set; }
Public Property GPIEventMode2C1 As Adp5587TypeGpiEmReg
    Get
    Set
public:
property Adp5587TypeGpiEmReg GPIEventMode2C1 {
    Adp5587TypeGpiEmReg get ();
    void set (Adp5587TypeGpiEmReg value);
}
member GPIEventMode2C1 : Adp5587TypeGpiEmReg with get, set

Property Value

Type: Adp5587TypeGpiEmReg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIEventMode2C2 Property

IRD

Adp5587GPIEventMode2C2 Property

GPI Event Mode 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpiEmReg GPIEventMode2C2 { get; set; }
Public Property GPIEventMode2C2 As Adp5587TypeGpiEmReg
    Get
    Set
public:
property Adp5587TypeGpiEmReg GPIEventMode2C2 {
    Adp5587TypeGpiEmReg get ();
    void set (Adp5587TypeGpiEmReg value);
}
member GPIEventMode2C2 : Adp5587TypeGpiEmReg with get, set

Property Value

Type: Adp5587TypeGpiEmReg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIEventMode2C3 Property

IRD

Adp5587GPIEventMode2C3 Property

GPI Event Mode 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpiEmReg GPIEventMode2C3 { get; set; }
Public Property GPIEventMode2C3 As Adp5587TypeGpiEmReg
    Get
    Set
public:
property Adp5587TypeGpiEmReg GPIEventMode2C3 {
    Adp5587TypeGpiEmReg get ();
    void set (Adp5587TypeGpiEmReg value);
}
member GPIEventMode2C3 : Adp5587TypeGpiEmReg with get, set

Property Value

Type: Adp5587TypeGpiEmReg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIEventMode2C4 Property

IRD

Adp5587GPIEventMode2C4 Property

GPI Event Mode 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpiEmReg GPIEventMode2C4 { get; set; }
Public Property GPIEventMode2C4 As Adp5587TypeGpiEmReg
    Get
    Set
public:
property Adp5587TypeGpiEmReg GPIEventMode2C4 {
    Adp5587TypeGpiEmReg get ();
    void set (Adp5587TypeGpiEmReg value);
}
member GPIEventMode2C4 : Adp5587TypeGpiEmReg with get, set

Property Value

Type: Adp5587TypeGpiEmReg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIEventMode2C5 Property

IRD

Adp5587GPIEventMode2C5 Property

GPI Event Mode 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpiEmReg GPIEventMode2C5 { get; set; }
Public Property GPIEventMode2C5 As Adp5587TypeGpiEmReg
    Get
    Set
public:
property Adp5587TypeGpiEmReg GPIEventMode2C5 {
    Adp5587TypeGpiEmReg get ();
    void set (Adp5587TypeGpiEmReg value);
}
member GPIEventMode2C5 : Adp5587TypeGpiEmReg with get, set

Property Value

Type: Adp5587TypeGpiEmReg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIEventMode2C6 Property

IRD

Adp5587GPIEventMode2C6 Property

GPI Event Mode 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpiEmReg GPIEventMode2C6 { get; set; }
Public Property GPIEventMode2C6 As Adp5587TypeGpiEmReg
    Get
    Set
public:
property Adp5587TypeGpiEmReg GPIEventMode2C6 {
    Adp5587TypeGpiEmReg get ();
    void set (Adp5587TypeGpiEmReg value);
}
member GPIEventMode2C6 : Adp5587TypeGpiEmReg with get, set

Property Value

Type: Adp5587TypeGpiEmReg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIEventMode2C7 Property

IRD

Adp5587GPIEventMode2C7 Property

GPI Event Mode 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpiEmReg GPIEventMode2C7 { get; set; }
Public Property GPIEventMode2C7 As Adp5587TypeGpiEmReg
    Get
    Set
public:
property Adp5587TypeGpiEmReg GPIEventMode2C7 {
    Adp5587TypeGpiEmReg get ();
    void set (Adp5587TypeGpiEmReg value);
}
member GPIEventMode2C7 : Adp5587TypeGpiEmReg with get, set

Property Value

Type: Adp5587TypeGpiEmReg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIEventMode3C8 Property

IRD

Adp5587GPIEventMode3C8 Property

GPI Event Mode 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpiEmReg GPIEventMode3C8 { get; set; }
Public Property GPIEventMode3C8 As Adp5587TypeGpiEmReg
    Get
    Set
public:
property Adp5587TypeGpiEmReg GPIEventMode3C8 {
    Adp5587TypeGpiEmReg get ();
    void set (Adp5587TypeGpiEmReg value);
}
member GPIEventMode3C8 : Adp5587TypeGpiEmReg with get, set

Property Value

Type: Adp5587TypeGpiEmReg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIEventMode3C9 Property

IRD

Adp5587GPIEventMode3C9 Property

GPI Event Mode 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpiEmReg GPIEventMode3C9 { get; set; }
Public Property GPIEventMode3C9 As Adp5587TypeGpiEmReg
    Get
    Set
public:
property Adp5587TypeGpiEmReg GPIEventMode3C9 {
    Adp5587TypeGpiEmReg get ();
    void set (Adp5587TypeGpiEmReg value);
}
member GPIEventMode3C9 : Adp5587TypeGpiEmReg with get, set

Property Value

Type: Adp5587TypeGpiEmReg
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataDirection1R0 Property

IRD

Adp5587GPIODataDirection1R0 Property

GPIO Data Direction 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioDir GPIODataDirection1R0 { get; set; }
Public Property GPIODataDirection1R0 As Adp5587TypeGpioDir
    Get
    Set
public:
property Adp5587TypeGpioDir GPIODataDirection1R0 {
    Adp5587TypeGpioDir get ();
    void set (Adp5587TypeGpioDir value);
}
member GPIODataDirection1R0 : Adp5587TypeGpioDir with get, set

Property Value

Type: Adp5587TypeGpioDir
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataDirection1R1 Property

IRD

Adp5587GPIODataDirection1R1 Property

GPIO Data Direction 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioDir GPIODataDirection1R1 { get; set; }
Public Property GPIODataDirection1R1 As Adp5587TypeGpioDir
    Get
    Set
public:
property Adp5587TypeGpioDir GPIODataDirection1R1 {
    Adp5587TypeGpioDir get ();
    void set (Adp5587TypeGpioDir value);
}
member GPIODataDirection1R1 : Adp5587TypeGpioDir with get, set

Property Value

Type: Adp5587TypeGpioDir
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataDirection1R2 Property

IRD

Adp5587GPIODataDirection1R2 Property

GPIO Data Direction 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioDir GPIODataDirection1R2 { get; set; }
Public Property GPIODataDirection1R2 As Adp5587TypeGpioDir
    Get
    Set
public:
property Adp5587TypeGpioDir GPIODataDirection1R2 {
    Adp5587TypeGpioDir get ();
    void set (Adp5587TypeGpioDir value);
}
member GPIODataDirection1R2 : Adp5587TypeGpioDir with get, set

Property Value

Type: Adp5587TypeGpioDir
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataDirection1R3 Property

IRD

Adp5587GPIODataDirection1R3 Property

GPIO Data Direction 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioDir GPIODataDirection1R3 { get; set; }
Public Property GPIODataDirection1R3 As Adp5587TypeGpioDir
    Get
    Set
public:
property Adp5587TypeGpioDir GPIODataDirection1R3 {
    Adp5587TypeGpioDir get ();
    void set (Adp5587TypeGpioDir value);
}
member GPIODataDirection1R3 : Adp5587TypeGpioDir with get, set

Property Value

Type: Adp5587TypeGpioDir
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataDirection1R4 Property

IRD

Adp5587GPIODataDirection1R4 Property

GPIO Data Direction 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioDir GPIODataDirection1R4 { get; set; }
Public Property GPIODataDirection1R4 As Adp5587TypeGpioDir
    Get
    Set
public:
property Adp5587TypeGpioDir GPIODataDirection1R4 {
    Adp5587TypeGpioDir get ();
    void set (Adp5587TypeGpioDir value);
}
member GPIODataDirection1R4 : Adp5587TypeGpioDir with get, set

Property Value

Type: Adp5587TypeGpioDir
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataDirection1R5 Property

IRD

Adp5587GPIODataDirection1R5 Property

GPIO Data Direction 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioDir GPIODataDirection1R5 { get; set; }
Public Property GPIODataDirection1R5 As Adp5587TypeGpioDir
    Get
    Set
public:
property Adp5587TypeGpioDir GPIODataDirection1R5 {
    Adp5587TypeGpioDir get ();
    void set (Adp5587TypeGpioDir value);
}
member GPIODataDirection1R5 : Adp5587TypeGpioDir with get, set

Property Value

Type: Adp5587TypeGpioDir
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataDirection1R6 Property

IRD

Adp5587GPIODataDirection1R6 Property

GPIO Data Direction 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioDir GPIODataDirection1R6 { get; set; }
Public Property GPIODataDirection1R6 As Adp5587TypeGpioDir
    Get
    Set
public:
property Adp5587TypeGpioDir GPIODataDirection1R6 {
    Adp5587TypeGpioDir get ();
    void set (Adp5587TypeGpioDir value);
}
member GPIODataDirection1R6 : Adp5587TypeGpioDir with get, set

Property Value

Type: Adp5587TypeGpioDir
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataDirection1R7 Property

IRD

Adp5587GPIODataDirection1R7 Property

GPIO Data Direction 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioDir GPIODataDirection1R7 { get; set; }
Public Property GPIODataDirection1R7 As Adp5587TypeGpioDir
    Get
    Set
public:
property Adp5587TypeGpioDir GPIODataDirection1R7 {
    Adp5587TypeGpioDir get ();
    void set (Adp5587TypeGpioDir value);
}
member GPIODataDirection1R7 : Adp5587TypeGpioDir with get, set

Property Value

Type: Adp5587TypeGpioDir
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataDirection2C0 Property

IRD

Adp5587GPIODataDirection2C0 Property

GPIO Data Direction 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioDir GPIODataDirection2C0 { get; set; }
Public Property GPIODataDirection2C0 As Adp5587TypeGpioDir
    Get
    Set
public:
property Adp5587TypeGpioDir GPIODataDirection2C0 {
    Adp5587TypeGpioDir get ();
    void set (Adp5587TypeGpioDir value);
}
member GPIODataDirection2C0 : Adp5587TypeGpioDir with get, set

Property Value

Type: Adp5587TypeGpioDir
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataDirection2C1 Property

IRD

Adp5587GPIODataDirection2C1 Property

GPIO Data Direction 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioDir GPIODataDirection2C1 { get; set; }
Public Property GPIODataDirection2C1 As Adp5587TypeGpioDir
    Get
    Set
public:
property Adp5587TypeGpioDir GPIODataDirection2C1 {
    Adp5587TypeGpioDir get ();
    void set (Adp5587TypeGpioDir value);
}
member GPIODataDirection2C1 : Adp5587TypeGpioDir with get, set

Property Value

Type: Adp5587TypeGpioDir
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataDirection2C2 Property

IRD

Adp5587GPIODataDirection2C2 Property

GPIO Data Direction 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioDir GPIODataDirection2C2 { get; set; }
Public Property GPIODataDirection2C2 As Adp5587TypeGpioDir
    Get
    Set
public:
property Adp5587TypeGpioDir GPIODataDirection2C2 {
    Adp5587TypeGpioDir get ();
    void set (Adp5587TypeGpioDir value);
}
member GPIODataDirection2C2 : Adp5587TypeGpioDir with get, set

Property Value

Type: Adp5587TypeGpioDir
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataDirection2C3 Property

IRD

Adp5587GPIODataDirection2C3 Property

GPIO Data Direction 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioDir GPIODataDirection2C3 { get; set; }
Public Property GPIODataDirection2C3 As Adp5587TypeGpioDir
    Get
    Set
public:
property Adp5587TypeGpioDir GPIODataDirection2C3 {
    Adp5587TypeGpioDir get ();
    void set (Adp5587TypeGpioDir value);
}
member GPIODataDirection2C3 : Adp5587TypeGpioDir with get, set

Property Value

Type: Adp5587TypeGpioDir
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataDirection2C4 Property

IRD

Adp5587GPIODataDirection2C4 Property

GPIO Data Direction 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioDir GPIODataDirection2C4 { get; set; }
Public Property GPIODataDirection2C4 As Adp5587TypeGpioDir
    Get
    Set
public:
property Adp5587TypeGpioDir GPIODataDirection2C4 {
    Adp5587TypeGpioDir get ();
    void set (Adp5587TypeGpioDir value);
}
member GPIODataDirection2C4 : Adp5587TypeGpioDir with get, set

Property Value

Type: Adp5587TypeGpioDir
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataDirection2C5 Property

IRD

Adp5587GPIODataDirection2C5 Property

GPIO Data Direction 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioDir GPIODataDirection2C5 { get; set; }
Public Property GPIODataDirection2C5 As Adp5587TypeGpioDir
    Get
    Set
public:
property Adp5587TypeGpioDir GPIODataDirection2C5 {
    Adp5587TypeGpioDir get ();
    void set (Adp5587TypeGpioDir value);
}
member GPIODataDirection2C5 : Adp5587TypeGpioDir with get, set

Property Value

Type: Adp5587TypeGpioDir
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataDirection2C6 Property

IRD

Adp5587GPIODataDirection2C6 Property

GPIO Data Direction 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioDir GPIODataDirection2C6 { get; set; }
Public Property GPIODataDirection2C6 As Adp5587TypeGpioDir
    Get
    Set
public:
property Adp5587TypeGpioDir GPIODataDirection2C6 {
    Adp5587TypeGpioDir get ();
    void set (Adp5587TypeGpioDir value);
}
member GPIODataDirection2C6 : Adp5587TypeGpioDir with get, set

Property Value

Type: Adp5587TypeGpioDir
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataDirection2C7 Property

IRD

Adp5587GPIODataDirection2C7 Property

GPIO Data Direction 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioDir GPIODataDirection2C7 { get; set; }
Public Property GPIODataDirection2C7 As Adp5587TypeGpioDir
    Get
    Set
public:
property Adp5587TypeGpioDir GPIODataDirection2C7 {
    Adp5587TypeGpioDir get ();
    void set (Adp5587TypeGpioDir value);
}
member GPIODataDirection2C7 : Adp5587TypeGpioDir with get, set

Property Value

Type: Adp5587TypeGpioDir
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataDirection3C8 Property

IRD

Adp5587GPIODataDirection3C8 Property

GPIO Data Direction 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioDir GPIODataDirection3C8 { get; set; }
Public Property GPIODataDirection3C8 As Adp5587TypeGpioDir
    Get
    Set
public:
property Adp5587TypeGpioDir GPIODataDirection3C8 {
    Adp5587TypeGpioDir get ();
    void set (Adp5587TypeGpioDir value);
}
member GPIODataDirection3C8 : Adp5587TypeGpioDir with get, set

Property Value

Type: Adp5587TypeGpioDir
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataDirection3C9 Property

IRD

Adp5587GPIODataDirection3C9 Property

GPIO Data Direction 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioDir GPIODataDirection3C9 { get; set; }
Public Property GPIODataDirection3C9 As Adp5587TypeGpioDir
    Get
    Set
public:
property Adp5587TypeGpioDir GPIODataDirection3C9 {
    Adp5587TypeGpioDir get ();
    void set (Adp5587TypeGpioDir value);
}
member GPIODataDirection3C9 : Adp5587TypeGpioDir with get, set

Property Value

Type: Adp5587TypeGpioDir
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataOut1R0 Property

IRD

Adp5587GPIODataOut1R0 Property

GPIO Data Out 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut1R0 { get; set; }
Public Property GPIODataOut1R0 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut1R0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut1R0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataOut1R1 Property

IRD

Adp5587GPIODataOut1R1 Property

GPIO Data Out 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut1R1 { get; set; }
Public Property GPIODataOut1R1 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut1R1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut1R1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataOut1R2 Property

IRD

Adp5587GPIODataOut1R2 Property

GPIO Data Out 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut1R2 { get; set; }
Public Property GPIODataOut1R2 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut1R2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut1R2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataOut1R3 Property

IRD

Adp5587GPIODataOut1R3 Property

GPIO Data Out 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut1R3 { get; set; }
Public Property GPIODataOut1R3 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut1R3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut1R3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataOut1R4 Property

IRD

Adp5587GPIODataOut1R4 Property

GPIO Data Out 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut1R4 { get; set; }
Public Property GPIODataOut1R4 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut1R4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut1R4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataOut1R5 Property

IRD

Adp5587GPIODataOut1R5 Property

GPIO Data Out 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut1R5 { get; set; }
Public Property GPIODataOut1R5 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut1R5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut1R5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataOut1R6 Property

IRD

Adp5587GPIODataOut1R6 Property

GPIO Data Out 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut1R6 { get; set; }
Public Property GPIODataOut1R6 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut1R6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut1R6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataOut1R7 Property

IRD

Adp5587GPIODataOut1R7 Property

GPIO Data Out 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut1R7 { get; set; }
Public Property GPIODataOut1R7 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut1R7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut1R7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataOut2C0 Property

IRD

Adp5587GPIODataOut2C0 Property

GPIO Data Out 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut2C0 { get; set; }
Public Property GPIODataOut2C0 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut2C0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut2C0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataOut2C1 Property

IRD

Adp5587GPIODataOut2C1 Property

GPIO Data Out 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut2C1 { get; set; }
Public Property GPIODataOut2C1 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut2C1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut2C1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataOut2C2 Property

IRD

Adp5587GPIODataOut2C2 Property

GPIO Data Out 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut2C2 { get; set; }
Public Property GPIODataOut2C2 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut2C2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut2C2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataOut2C3 Property

IRD

Adp5587GPIODataOut2C3 Property

GPIO Data Out 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut2C3 { get; set; }
Public Property GPIODataOut2C3 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut2C3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut2C3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataOut2C4 Property

IRD

Adp5587GPIODataOut2C4 Property

GPIO Data Out 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut2C4 { get; set; }
Public Property GPIODataOut2C4 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut2C4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut2C4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataOut2C5 Property

IRD

Adp5587GPIODataOut2C5 Property

GPIO Data Out 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut2C5 { get; set; }
Public Property GPIODataOut2C5 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut2C5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut2C5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataOut2C6 Property

IRD

Adp5587GPIODataOut2C6 Property

GPIO Data Out 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut2C6 { get; set; }
Public Property GPIODataOut2C6 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut2C6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut2C6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataOut2C7 Property

IRD

Adp5587GPIODataOut2C7 Property

GPIO Data Out 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut2C7 { get; set; }
Public Property GPIODataOut2C7 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut2C7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut2C7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataOut3C8 Property

IRD

Adp5587GPIODataOut3C8 Property

GPIO Data Out 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut3C8 { get; set; }
Public Property GPIODataOut3C8 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut3C8 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut3C8 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataOut3C9 Property

IRD

Adp5587GPIODataOut3C9 Property

GPIO Data Out 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut3C9 { get; set; }
Public Property GPIODataOut3C9 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut3C9 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut3C9 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataStatus1R0 Property

IRD

Adp5587GPIODataStatus1R0 Property

GPIO Data Status 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus1R0 { get; set; }
Public Property GPIODataStatus1R0 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus1R0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus1R0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataStatus1R1 Property

IRD

Adp5587GPIODataStatus1R1 Property

GPIO Data Status 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus1R1 { get; set; }
Public Property GPIODataStatus1R1 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus1R1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus1R1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataStatus1R2 Property

IRD

Adp5587GPIODataStatus1R2 Property

GPIO Data Status 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus1R2 { get; set; }
Public Property GPIODataStatus1R2 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus1R2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus1R2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataStatus1R3 Property

IRD

Adp5587GPIODataStatus1R3 Property

GPIO Data Status 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus1R3 { get; set; }
Public Property GPIODataStatus1R3 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus1R3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus1R3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataStatus1R4 Property

IRD

Adp5587GPIODataStatus1R4 Property

GPIO Data Status 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus1R4 { get; set; }
Public Property GPIODataStatus1R4 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus1R4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus1R4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataStatus1R5 Property

IRD

Adp5587GPIODataStatus1R5 Property

GPIO Data Status 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus1R5 { get; set; }
Public Property GPIODataStatus1R5 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus1R5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus1R5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataStatus1R6 Property

IRD

Adp5587GPIODataStatus1R6 Property

GPIO Data Status 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus1R6 { get; set; }
Public Property GPIODataStatus1R6 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus1R6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus1R6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataStatus1R7 Property

IRD

Adp5587GPIODataStatus1R7 Property

GPIO Data Status 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus1R7 { get; set; }
Public Property GPIODataStatus1R7 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus1R7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus1R7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataStatus2C0 Property

IRD

Adp5587GPIODataStatus2C0 Property

GPIO Data Status 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus2C0 { get; set; }
Public Property GPIODataStatus2C0 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus2C0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus2C0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataStatus2C1 Property

IRD

Adp5587GPIODataStatus2C1 Property

GPIO Data Status 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus2C1 { get; set; }
Public Property GPIODataStatus2C1 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus2C1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus2C1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataStatus2C2 Property

IRD

Adp5587GPIODataStatus2C2 Property

GPIO Data Status 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus2C2 { get; set; }
Public Property GPIODataStatus2C2 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus2C2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus2C2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataStatus2C3 Property

IRD

Adp5587GPIODataStatus2C3 Property

GPIO Data Status 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus2C3 { get; set; }
Public Property GPIODataStatus2C3 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus2C3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus2C3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataStatus2C4 Property

IRD

Adp5587GPIODataStatus2C4 Property

GPIO Data Status 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus2C4 { get; set; }
Public Property GPIODataStatus2C4 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus2C4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus2C4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataStatus2C5 Property

IRD

Adp5587GPIODataStatus2C5 Property

GPIO Data Status 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus2C5 { get; set; }
Public Property GPIODataStatus2C5 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus2C5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus2C5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataStatus2C6 Property

IRD

Adp5587GPIODataStatus2C6 Property

GPIO Data Status 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus2C6 { get; set; }
Public Property GPIODataStatus2C6 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus2C6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus2C6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataStatus2C7 Property

IRD

Adp5587GPIODataStatus2C7 Property

GPIO Data Status 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus2C7 { get; set; }
Public Property GPIODataStatus2C7 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus2C7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus2C7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataStatus3C8 Property

IRD

Adp5587GPIODataStatus3C8 Property

GPIO Data Status 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus3C8 { get; set; }
Public Property GPIODataStatus3C8 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus3C8 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus3C8 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIODataStatus3C9 Property

IRD

Adp5587GPIODataStatus3C9 Property

GPIO Data Status 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus3C9 { get; set; }
Public Property GPIODataStatus3C9 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus3C9 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus3C9 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptEnable1R0 Property

IRD

Adp5587GPIOInterruptEnable1R0 Property

GPIO Interrupt Enable 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable1R0 { get; set; }
Public Property GPIOInterruptEnable1R0 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable1R0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable1R0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptEnable1R1 Property

IRD

Adp5587GPIOInterruptEnable1R1 Property

GPIO Interrupt Enable 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable1R1 { get; set; }
Public Property GPIOInterruptEnable1R1 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable1R1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable1R1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptEnable1R2 Property

IRD

Adp5587GPIOInterruptEnable1R2 Property

GPIO Interrupt Enable 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable1R2 { get; set; }
Public Property GPIOInterruptEnable1R2 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable1R2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable1R2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptEnable1R3 Property

IRD

Adp5587GPIOInterruptEnable1R3 Property

GPIO Interrupt Enable 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable1R3 { get; set; }
Public Property GPIOInterruptEnable1R3 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable1R3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable1R3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptEnable1R4 Property

IRD

Adp5587GPIOInterruptEnable1R4 Property

GPIO Interrupt Enable 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable1R4 { get; set; }
Public Property GPIOInterruptEnable1R4 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable1R4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable1R4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptEnable1R5 Property

IRD

Adp5587GPIOInterruptEnable1R5 Property

GPIO Interrupt Enable 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable1R5 { get; set; }
Public Property GPIOInterruptEnable1R5 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable1R5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable1R5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptEnable1R6 Property

IRD

Adp5587GPIOInterruptEnable1R6 Property

GPIO Interrupt Enable 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable1R6 { get; set; }
Public Property GPIOInterruptEnable1R6 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable1R6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable1R6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptEnable1R7 Property

IRD

Adp5587GPIOInterruptEnable1R7 Property

GPIO Interrupt Enable 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable1R7 { get; set; }
Public Property GPIOInterruptEnable1R7 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable1R7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable1R7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptEnable2C0 Property

IRD

Adp5587GPIOInterruptEnable2C0 Property

GPIO Interrupt Enable 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable2C0 { get; set; }
Public Property GPIOInterruptEnable2C0 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable2C0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable2C0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptEnable2C1 Property

IRD

Adp5587GPIOInterruptEnable2C1 Property

GPIO Interrupt Enable 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable2C1 { get; set; }
Public Property GPIOInterruptEnable2C1 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable2C1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable2C1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptEnable2C2 Property

IRD

Adp5587GPIOInterruptEnable2C2 Property

GPIO Interrupt Enable 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable2C2 { get; set; }
Public Property GPIOInterruptEnable2C2 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable2C2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable2C2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptEnable2C3 Property

IRD

Adp5587GPIOInterruptEnable2C3 Property

GPIO Interrupt Enable 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable2C3 { get; set; }
Public Property GPIOInterruptEnable2C3 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable2C3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable2C3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptEnable2C4 Property

IRD

Adp5587GPIOInterruptEnable2C4 Property

GPIO Interrupt Enable 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable2C4 { get; set; }
Public Property GPIOInterruptEnable2C4 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable2C4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable2C4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptEnable2C5 Property

IRD

Adp5587GPIOInterruptEnable2C5 Property

GPIO Interrupt Enable 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable2C5 { get; set; }
Public Property GPIOInterruptEnable2C5 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable2C5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable2C5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptEnable2C6 Property

IRD

Adp5587GPIOInterruptEnable2C6 Property

GPIO Interrupt Enable 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable2C6 { get; set; }
Public Property GPIOInterruptEnable2C6 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable2C6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable2C6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptEnable2C7 Property

IRD

Adp5587GPIOInterruptEnable2C7 Property

GPIO Interrupt Enable 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable2C7 { get; set; }
Public Property GPIOInterruptEnable2C7 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable2C7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable2C7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptEnable3C8 Property

IRD

Adp5587GPIOInterruptEnable3C8 Property

GPIO Interrupt Enable 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable3C8 { get; set; }
Public Property GPIOInterruptEnable3C8 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable3C8 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable3C8 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptEnable3C9 Property

IRD

Adp5587GPIOInterruptEnable3C9 Property

GPIO Interrupt Enable 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable3C9 { get; set; }
Public Property GPIOInterruptEnable3C9 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable3C9 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable3C9 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptStatus1R0 Property

IRD

Adp5587GPIOInterruptStatus1R0 Property

GPIO Interrupt Status 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus1R0 { get; set; }
Public Property GPIOInterruptStatus1R0 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus1R0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus1R0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptStatus1R1 Property

IRD

Adp5587GPIOInterruptStatus1R1 Property

GPIO Interrupt Status 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus1R1 { get; set; }
Public Property GPIOInterruptStatus1R1 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus1R1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus1R1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptStatus1R2 Property

IRD

Adp5587GPIOInterruptStatus1R2 Property

GPIO Interrupt Status 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus1R2 { get; set; }
Public Property GPIOInterruptStatus1R2 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus1R2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus1R2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptStatus1R3 Property

IRD

Adp5587GPIOInterruptStatus1R3 Property

GPIO Interrupt Status 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus1R3 { get; set; }
Public Property GPIOInterruptStatus1R3 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus1R3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus1R3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptStatus1R4 Property

IRD

Adp5587GPIOInterruptStatus1R4 Property

GPIO Interrupt Status 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus1R4 { get; set; }
Public Property GPIOInterruptStatus1R4 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus1R4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus1R4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptStatus1R5 Property

IRD

Adp5587GPIOInterruptStatus1R5 Property

GPIO Interrupt Status 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus1R5 { get; set; }
Public Property GPIOInterruptStatus1R5 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus1R5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus1R5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptStatus1R6 Property

IRD

Adp5587GPIOInterruptStatus1R6 Property

GPIO Interrupt Status 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus1R6 { get; set; }
Public Property GPIOInterruptStatus1R6 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus1R6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus1R6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptStatus1R7 Property

IRD

Adp5587GPIOInterruptStatus1R7 Property

GPIO Interrupt Status 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus1R7 { get; set; }
Public Property GPIOInterruptStatus1R7 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus1R7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus1R7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptStatus2C0 Property

IRD

Adp5587GPIOInterruptStatus2C0 Property

GPIO Interrupt Status 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus2C0 { get; set; }
Public Property GPIOInterruptStatus2C0 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus2C0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus2C0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptStatus2C1 Property

IRD

Adp5587GPIOInterruptStatus2C1 Property

GPIO Interrupt Status 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus2C1 { get; set; }
Public Property GPIOInterruptStatus2C1 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus2C1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus2C1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptStatus2C2 Property

IRD

Adp5587GPIOInterruptStatus2C2 Property

GPIO Interrupt Status 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus2C2 { get; set; }
Public Property GPIOInterruptStatus2C2 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus2C2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus2C2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptStatus2C3 Property

IRD

Adp5587GPIOInterruptStatus2C3 Property

GPIO Interrupt Status 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus2C3 { get; set; }
Public Property GPIOInterruptStatus2C3 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus2C3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus2C3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptStatus2C4 Property

IRD

Adp5587GPIOInterruptStatus2C4 Property

GPIO Interrupt Status 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus2C4 { get; set; }
Public Property GPIOInterruptStatus2C4 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus2C4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus2C4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptStatus2C5 Property

IRD

Adp5587GPIOInterruptStatus2C5 Property

GPIO Interrupt Status 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus2C5 { get; set; }
Public Property GPIOInterruptStatus2C5 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus2C5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus2C5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptStatus2C6 Property

IRD

Adp5587GPIOInterruptStatus2C6 Property

GPIO Interrupt Status 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus2C6 { get; set; }
Public Property GPIOInterruptStatus2C6 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus2C6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus2C6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptStatus2C7 Property

IRD

Adp5587GPIOInterruptStatus2C7 Property

GPIO Interrupt Status 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus2C7 { get; set; }
Public Property GPIOInterruptStatus2C7 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus2C7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus2C7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptStatus3C8 Property

IRD

Adp5587GPIOInterruptStatus3C8 Property

GPIO Interrupt Status 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus3C8 { get; set; }
Public Property GPIOInterruptStatus3C8 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus3C8 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus3C8 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOInterruptStatus3C9 Property

IRD

Adp5587GPIOInterruptStatus3C9 Property

GPIO Interrupt Status 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus3C9 { get; set; }
Public Property GPIOInterruptStatus3C9 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus3C9 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus3C9 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOLevelDetect1R0 Property

IRD

Adp5587GPIOLevelDetect1R0 Property

GPIO Level Detect 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioIntLvl GPIOLevelDetect1R0 { get; set; }
Public Property GPIOLevelDetect1R0 As Adp5587TypeGpioIntLvl
    Get
    Set
public:
property Adp5587TypeGpioIntLvl GPIOLevelDetect1R0 {
    Adp5587TypeGpioIntLvl get ();
    void set (Adp5587TypeGpioIntLvl value);
}
member GPIOLevelDetect1R0 : Adp5587TypeGpioIntLvl with get, set

Property Value

Type: Adp5587TypeGpioIntLvl
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOLevelDetect1R1 Property

IRD

Adp5587GPIOLevelDetect1R1 Property

GPIO Level Detect 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioIntLvl GPIOLevelDetect1R1 { get; set; }
Public Property GPIOLevelDetect1R1 As Adp5587TypeGpioIntLvl
    Get
    Set
public:
property Adp5587TypeGpioIntLvl GPIOLevelDetect1R1 {
    Adp5587TypeGpioIntLvl get ();
    void set (Adp5587TypeGpioIntLvl value);
}
member GPIOLevelDetect1R1 : Adp5587TypeGpioIntLvl with get, set

Property Value

Type: Adp5587TypeGpioIntLvl
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOLevelDetect1R2 Property

IRD

Adp5587GPIOLevelDetect1R2 Property

GPIO Level Detect 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioIntLvl GPIOLevelDetect1R2 { get; set; }
Public Property GPIOLevelDetect1R2 As Adp5587TypeGpioIntLvl
    Get
    Set
public:
property Adp5587TypeGpioIntLvl GPIOLevelDetect1R2 {
    Adp5587TypeGpioIntLvl get ();
    void set (Adp5587TypeGpioIntLvl value);
}
member GPIOLevelDetect1R2 : Adp5587TypeGpioIntLvl with get, set

Property Value

Type: Adp5587TypeGpioIntLvl
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOLevelDetect1R3 Property

IRD

Adp5587GPIOLevelDetect1R3 Property

GPIO Level Detect 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioIntLvl GPIOLevelDetect1R3 { get; set; }
Public Property GPIOLevelDetect1R3 As Adp5587TypeGpioIntLvl
    Get
    Set
public:
property Adp5587TypeGpioIntLvl GPIOLevelDetect1R3 {
    Adp5587TypeGpioIntLvl get ();
    void set (Adp5587TypeGpioIntLvl value);
}
member GPIOLevelDetect1R3 : Adp5587TypeGpioIntLvl with get, set

Property Value

Type: Adp5587TypeGpioIntLvl
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOLevelDetect1R4 Property

IRD

Adp5587GPIOLevelDetect1R4 Property

GPIO Level Detect 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioIntLvl GPIOLevelDetect1R4 { get; set; }
Public Property GPIOLevelDetect1R4 As Adp5587TypeGpioIntLvl
    Get
    Set
public:
property Adp5587TypeGpioIntLvl GPIOLevelDetect1R4 {
    Adp5587TypeGpioIntLvl get ();
    void set (Adp5587TypeGpioIntLvl value);
}
member GPIOLevelDetect1R4 : Adp5587TypeGpioIntLvl with get, set

Property Value

Type: Adp5587TypeGpioIntLvl
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOLevelDetect1R5 Property

IRD

Adp5587GPIOLevelDetect1R5 Property

GPIO Level Detect 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioIntLvl GPIOLevelDetect1R5 { get; set; }
Public Property GPIOLevelDetect1R5 As Adp5587TypeGpioIntLvl
    Get
    Set
public:
property Adp5587TypeGpioIntLvl GPIOLevelDetect1R5 {
    Adp5587TypeGpioIntLvl get ();
    void set (Adp5587TypeGpioIntLvl value);
}
member GPIOLevelDetect1R5 : Adp5587TypeGpioIntLvl with get, set

Property Value

Type: Adp5587TypeGpioIntLvl
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOLevelDetect1R6 Property

IRD

Adp5587GPIOLevelDetect1R6 Property

GPIO Level Detect 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioIntLvl GPIOLevelDetect1R6 { get; set; }
Public Property GPIOLevelDetect1R6 As Adp5587TypeGpioIntLvl
    Get
    Set
public:
property Adp5587TypeGpioIntLvl GPIOLevelDetect1R6 {
    Adp5587TypeGpioIntLvl get ();
    void set (Adp5587TypeGpioIntLvl value);
}
member GPIOLevelDetect1R6 : Adp5587TypeGpioIntLvl with get, set

Property Value

Type: Adp5587TypeGpioIntLvl
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOLevelDetect1R7 Property

IRD

Adp5587GPIOLevelDetect1R7 Property

GPIO Level Detect 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioIntLvl GPIOLevelDetect1R7 { get; set; }
Public Property GPIOLevelDetect1R7 As Adp5587TypeGpioIntLvl
    Get
    Set
public:
property Adp5587TypeGpioIntLvl GPIOLevelDetect1R7 {
    Adp5587TypeGpioIntLvl get ();
    void set (Adp5587TypeGpioIntLvl value);
}
member GPIOLevelDetect1R7 : Adp5587TypeGpioIntLvl with get, set

Property Value

Type: Adp5587TypeGpioIntLvl
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOLevelDetect2C0 Property

IRD

Adp5587GPIOLevelDetect2C0 Property

GPIO Level Detect 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioIntLvl GPIOLevelDetect2C0 { get; set; }
Public Property GPIOLevelDetect2C0 As Adp5587TypeGpioIntLvl
    Get
    Set
public:
property Adp5587TypeGpioIntLvl GPIOLevelDetect2C0 {
    Adp5587TypeGpioIntLvl get ();
    void set (Adp5587TypeGpioIntLvl value);
}
member GPIOLevelDetect2C0 : Adp5587TypeGpioIntLvl with get, set

Property Value

Type: Adp5587TypeGpioIntLvl
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOLevelDetect2C1 Property

IRD

Adp5587GPIOLevelDetect2C1 Property

GPIO Level Detect 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioIntLvl GPIOLevelDetect2C1 { get; set; }
Public Property GPIOLevelDetect2C1 As Adp5587TypeGpioIntLvl
    Get
    Set
public:
property Adp5587TypeGpioIntLvl GPIOLevelDetect2C1 {
    Adp5587TypeGpioIntLvl get ();
    void set (Adp5587TypeGpioIntLvl value);
}
member GPIOLevelDetect2C1 : Adp5587TypeGpioIntLvl with get, set

Property Value

Type: Adp5587TypeGpioIntLvl
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOLevelDetect2C2 Property

IRD

Adp5587GPIOLevelDetect2C2 Property

GPIO Level Detect 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioIntLvl GPIOLevelDetect2C2 { get; set; }
Public Property GPIOLevelDetect2C2 As Adp5587TypeGpioIntLvl
    Get
    Set
public:
property Adp5587TypeGpioIntLvl GPIOLevelDetect2C2 {
    Adp5587TypeGpioIntLvl get ();
    void set (Adp5587TypeGpioIntLvl value);
}
member GPIOLevelDetect2C2 : Adp5587TypeGpioIntLvl with get, set

Property Value

Type: Adp5587TypeGpioIntLvl
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOLevelDetect2C3 Property

IRD

Adp5587GPIOLevelDetect2C3 Property

GPIO Level Detect 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioIntLvl GPIOLevelDetect2C3 { get; set; }
Public Property GPIOLevelDetect2C3 As Adp5587TypeGpioIntLvl
    Get
    Set
public:
property Adp5587TypeGpioIntLvl GPIOLevelDetect2C3 {
    Adp5587TypeGpioIntLvl get ();
    void set (Adp5587TypeGpioIntLvl value);
}
member GPIOLevelDetect2C3 : Adp5587TypeGpioIntLvl with get, set

Property Value

Type: Adp5587TypeGpioIntLvl
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOLevelDetect2C4 Property

IRD

Adp5587GPIOLevelDetect2C4 Property

GPIO Level Detect 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioIntLvl GPIOLevelDetect2C4 { get; set; }
Public Property GPIOLevelDetect2C4 As Adp5587TypeGpioIntLvl
    Get
    Set
public:
property Adp5587TypeGpioIntLvl GPIOLevelDetect2C4 {
    Adp5587TypeGpioIntLvl get ();
    void set (Adp5587TypeGpioIntLvl value);
}
member GPIOLevelDetect2C4 : Adp5587TypeGpioIntLvl with get, set

Property Value

Type: Adp5587TypeGpioIntLvl
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOLevelDetect2C5 Property

IRD

Adp5587GPIOLevelDetect2C5 Property

GPIO Level Detect 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioIntLvl GPIOLevelDetect2C5 { get; set; }
Public Property GPIOLevelDetect2C5 As Adp5587TypeGpioIntLvl
    Get
    Set
public:
property Adp5587TypeGpioIntLvl GPIOLevelDetect2C5 {
    Adp5587TypeGpioIntLvl get ();
    void set (Adp5587TypeGpioIntLvl value);
}
member GPIOLevelDetect2C5 : Adp5587TypeGpioIntLvl with get, set

Property Value

Type: Adp5587TypeGpioIntLvl
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOLevelDetect2C6 Property

IRD

Adp5587GPIOLevelDetect2C6 Property

GPIO Level Detect 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioIntLvl GPIOLevelDetect2C6 { get; set; }
Public Property GPIOLevelDetect2C6 As Adp5587TypeGpioIntLvl
    Get
    Set
public:
property Adp5587TypeGpioIntLvl GPIOLevelDetect2C6 {
    Adp5587TypeGpioIntLvl get ();
    void set (Adp5587TypeGpioIntLvl value);
}
member GPIOLevelDetect2C6 : Adp5587TypeGpioIntLvl with get, set

Property Value

Type: Adp5587TypeGpioIntLvl
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOLevelDetect2C7 Property

IRD

Adp5587GPIOLevelDetect2C7 Property

GPIO Level Detect 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioIntLvl GPIOLevelDetect2C7 { get; set; }
Public Property GPIOLevelDetect2C7 As Adp5587TypeGpioIntLvl
    Get
    Set
public:
property Adp5587TypeGpioIntLvl GPIOLevelDetect2C7 {
    Adp5587TypeGpioIntLvl get ();
    void set (Adp5587TypeGpioIntLvl value);
}
member GPIOLevelDetect2C7 : Adp5587TypeGpioIntLvl with get, set

Property Value

Type: Adp5587TypeGpioIntLvl
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOLevelDetect3C8 Property

IRD

Adp5587GPIOLevelDetect3C8 Property

GPIO Level Detect 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioIntLvl GPIOLevelDetect3C8 { get; set; }
Public Property GPIOLevelDetect3C8 As Adp5587TypeGpioIntLvl
    Get
    Set
public:
property Adp5587TypeGpioIntLvl GPIOLevelDetect3C8 {
    Adp5587TypeGpioIntLvl get ();
    void set (Adp5587TypeGpioIntLvl value);
}
member GPIOLevelDetect3C8 : Adp5587TypeGpioIntLvl with get, set

Property Value

Type: Adp5587TypeGpioIntLvl
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOLevelDetect3C9 Property

IRD

Adp5587GPIOLevelDetect3C9 Property

GPIO Level Detect 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioIntLvl GPIOLevelDetect3C9 { get; set; }
Public Property GPIOLevelDetect3C9 As Adp5587TypeGpioIntLvl
    Get
    Set
public:
property Adp5587TypeGpioIntLvl GPIOLevelDetect3C9 {
    Adp5587TypeGpioIntLvl get ();
    void set (Adp5587TypeGpioIntLvl value);
}
member GPIOLevelDetect3C9 : Adp5587TypeGpioIntLvl with get, set

Property Value

Type: Adp5587TypeGpioIntLvl
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOPullDisable1R0 Property

IRD

Adp5587GPIOPullDisable1R0 Property

GPIO Pull Disable 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioPull GPIOPullDisable1R0 { get; set; }
Public Property GPIOPullDisable1R0 As Adp5587TypeGpioPull
    Get
    Set
public:
property Adp5587TypeGpioPull GPIOPullDisable1R0 {
    Adp5587TypeGpioPull get ();
    void set (Adp5587TypeGpioPull value);
}
member GPIOPullDisable1R0 : Adp5587TypeGpioPull with get, set

Property Value

Type: Adp5587TypeGpioPull
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOPullDisable1R1 Property

IRD

Adp5587GPIOPullDisable1R1 Property

GPIO Pull Disable 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioPull GPIOPullDisable1R1 { get; set; }
Public Property GPIOPullDisable1R1 As Adp5587TypeGpioPull
    Get
    Set
public:
property Adp5587TypeGpioPull GPIOPullDisable1R1 {
    Adp5587TypeGpioPull get ();
    void set (Adp5587TypeGpioPull value);
}
member GPIOPullDisable1R1 : Adp5587TypeGpioPull with get, set

Property Value

Type: Adp5587TypeGpioPull
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOPullDisable1R2 Property

IRD

Adp5587GPIOPullDisable1R2 Property

GPIO Pull Disable 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioPull GPIOPullDisable1R2 { get; set; }
Public Property GPIOPullDisable1R2 As Adp5587TypeGpioPull
    Get
    Set
public:
property Adp5587TypeGpioPull GPIOPullDisable1R2 {
    Adp5587TypeGpioPull get ();
    void set (Adp5587TypeGpioPull value);
}
member GPIOPullDisable1R2 : Adp5587TypeGpioPull with get, set

Property Value

Type: Adp5587TypeGpioPull
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOPullDisable1R3 Property

IRD

Adp5587GPIOPullDisable1R3 Property

GPIO Pull Disable 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioPull GPIOPullDisable1R3 { get; set; }
Public Property GPIOPullDisable1R3 As Adp5587TypeGpioPull
    Get
    Set
public:
property Adp5587TypeGpioPull GPIOPullDisable1R3 {
    Adp5587TypeGpioPull get ();
    void set (Adp5587TypeGpioPull value);
}
member GPIOPullDisable1R3 : Adp5587TypeGpioPull with get, set

Property Value

Type: Adp5587TypeGpioPull
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOPullDisable1R4 Property

IRD

Adp5587GPIOPullDisable1R4 Property

GPIO Pull Disable 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioPull GPIOPullDisable1R4 { get; set; }
Public Property GPIOPullDisable1R4 As Adp5587TypeGpioPull
    Get
    Set
public:
property Adp5587TypeGpioPull GPIOPullDisable1R4 {
    Adp5587TypeGpioPull get ();
    void set (Adp5587TypeGpioPull value);
}
member GPIOPullDisable1R4 : Adp5587TypeGpioPull with get, set

Property Value

Type: Adp5587TypeGpioPull
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOPullDisable1R5 Property

IRD

Adp5587GPIOPullDisable1R5 Property

GPIO Pull Disable 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioPull GPIOPullDisable1R5 { get; set; }
Public Property GPIOPullDisable1R5 As Adp5587TypeGpioPull
    Get
    Set
public:
property Adp5587TypeGpioPull GPIOPullDisable1R5 {
    Adp5587TypeGpioPull get ();
    void set (Adp5587TypeGpioPull value);
}
member GPIOPullDisable1R5 : Adp5587TypeGpioPull with get, set

Property Value

Type: Adp5587TypeGpioPull
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOPullDisable1R6 Property

IRD

Adp5587GPIOPullDisable1R6 Property

GPIO Pull Disable 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioPull GPIOPullDisable1R6 { get; set; }
Public Property GPIOPullDisable1R6 As Adp5587TypeGpioPull
    Get
    Set
public:
property Adp5587TypeGpioPull GPIOPullDisable1R6 {
    Adp5587TypeGpioPull get ();
    void set (Adp5587TypeGpioPull value);
}
member GPIOPullDisable1R6 : Adp5587TypeGpioPull with get, set

Property Value

Type: Adp5587TypeGpioPull
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOPullDisable1R7 Property

IRD

Adp5587GPIOPullDisable1R7 Property

GPIO Pull Disable 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioPull GPIOPullDisable1R7 { get; set; }
Public Property GPIOPullDisable1R7 As Adp5587TypeGpioPull
    Get
    Set
public:
property Adp5587TypeGpioPull GPIOPullDisable1R7 {
    Adp5587TypeGpioPull get ();
    void set (Adp5587TypeGpioPull value);
}
member GPIOPullDisable1R7 : Adp5587TypeGpioPull with get, set

Property Value

Type: Adp5587TypeGpioPull
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOPullDisable2C0 Property

IRD

Adp5587GPIOPullDisable2C0 Property

GPIO Pull Disable 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioPull GPIOPullDisable2C0 { get; set; }
Public Property GPIOPullDisable2C0 As Adp5587TypeGpioPull
    Get
    Set
public:
property Adp5587TypeGpioPull GPIOPullDisable2C0 {
    Adp5587TypeGpioPull get ();
    void set (Adp5587TypeGpioPull value);
}
member GPIOPullDisable2C0 : Adp5587TypeGpioPull with get, set

Property Value

Type: Adp5587TypeGpioPull
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOPullDisable2C1 Property

IRD

Adp5587GPIOPullDisable2C1 Property

GPIO Pull Disable 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioPull GPIOPullDisable2C1 { get; set; }
Public Property GPIOPullDisable2C1 As Adp5587TypeGpioPull
    Get
    Set
public:
property Adp5587TypeGpioPull GPIOPullDisable2C1 {
    Adp5587TypeGpioPull get ();
    void set (Adp5587TypeGpioPull value);
}
member GPIOPullDisable2C1 : Adp5587TypeGpioPull with get, set

Property Value

Type: Adp5587TypeGpioPull
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOPullDisable2C2 Property

IRD

Adp5587GPIOPullDisable2C2 Property

GPIO Pull Disable 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioPull GPIOPullDisable2C2 { get; set; }
Public Property GPIOPullDisable2C2 As Adp5587TypeGpioPull
    Get
    Set
public:
property Adp5587TypeGpioPull GPIOPullDisable2C2 {
    Adp5587TypeGpioPull get ();
    void set (Adp5587TypeGpioPull value);
}
member GPIOPullDisable2C2 : Adp5587TypeGpioPull with get, set

Property Value

Type: Adp5587TypeGpioPull
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOPullDisable2C3 Property

IRD

Adp5587GPIOPullDisable2C3 Property

GPIO Pull Disable 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioPull GPIOPullDisable2C3 { get; set; }
Public Property GPIOPullDisable2C3 As Adp5587TypeGpioPull
    Get
    Set
public:
property Adp5587TypeGpioPull GPIOPullDisable2C3 {
    Adp5587TypeGpioPull get ();
    void set (Adp5587TypeGpioPull value);
}
member GPIOPullDisable2C3 : Adp5587TypeGpioPull with get, set

Property Value

Type: Adp5587TypeGpioPull
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOPullDisable2C4 Property

IRD

Adp5587GPIOPullDisable2C4 Property

GPIO Pull Disable 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioPull GPIOPullDisable2C4 { get; set; }
Public Property GPIOPullDisable2C4 As Adp5587TypeGpioPull
    Get
    Set
public:
property Adp5587TypeGpioPull GPIOPullDisable2C4 {
    Adp5587TypeGpioPull get ();
    void set (Adp5587TypeGpioPull value);
}
member GPIOPullDisable2C4 : Adp5587TypeGpioPull with get, set

Property Value

Type: Adp5587TypeGpioPull
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOPullDisable2C5 Property

IRD

Adp5587GPIOPullDisable2C5 Property

GPIO Pull Disable 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioPull GPIOPullDisable2C5 { get; set; }
Public Property GPIOPullDisable2C5 As Adp5587TypeGpioPull
    Get
    Set
public:
property Adp5587TypeGpioPull GPIOPullDisable2C5 {
    Adp5587TypeGpioPull get ();
    void set (Adp5587TypeGpioPull value);
}
member GPIOPullDisable2C5 : Adp5587TypeGpioPull with get, set

Property Value

Type: Adp5587TypeGpioPull
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOPullDisable2C6 Property

IRD

Adp5587GPIOPullDisable2C6 Property

GPIO Pull Disable 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioPull GPIOPullDisable2C6 { get; set; }
Public Property GPIOPullDisable2C6 As Adp5587TypeGpioPull
    Get
    Set
public:
property Adp5587TypeGpioPull GPIOPullDisable2C6 {
    Adp5587TypeGpioPull get ();
    void set (Adp5587TypeGpioPull value);
}
member GPIOPullDisable2C6 : Adp5587TypeGpioPull with get, set

Property Value

Type: Adp5587TypeGpioPull
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOPullDisable2C7 Property

IRD

Adp5587GPIOPullDisable2C7 Property

GPIO Pull Disable 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioPull GPIOPullDisable2C7 { get; set; }
Public Property GPIOPullDisable2C7 As Adp5587TypeGpioPull
    Get
    Set
public:
property Adp5587TypeGpioPull GPIOPullDisable2C7 {
    Adp5587TypeGpioPull get ();
    void set (Adp5587TypeGpioPull value);
}
member GPIOPullDisable2C7 : Adp5587TypeGpioPull with get, set

Property Value

Type: Adp5587TypeGpioPull
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOPullDisable3C8 Property

IRD

Adp5587GPIOPullDisable3C8 Property

GPIO Pull Disable 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioPull GPIOPullDisable3C8 { get; set; }
Public Property GPIOPullDisable3C8 As Adp5587TypeGpioPull
    Get
    Set
public:
property Adp5587TypeGpioPull GPIOPullDisable3C8 {
    Adp5587TypeGpioPull get ();
    void set (Adp5587TypeGpioPull value);
}
member GPIOPullDisable3C8 : Adp5587TypeGpioPull with get, set

Property Value

Type: Adp5587TypeGpioPull
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.GPIOPullDisable3C9 Property

IRD

Adp5587GPIOPullDisable3C9 Property

GPIO Pull Disable 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeGpioPull GPIOPullDisable3C9 { get; set; }
Public Property GPIOPullDisable3C9 As Adp5587TypeGpioPull
    Get
    Set
public:
property Adp5587TypeGpioPull GPIOPullDisable3C9 {
    Adp5587TypeGpioPull get ();
    void set (Adp5587TypeGpioPull value);
}
member GPIOPullDisable3C9 : Adp5587TypeGpioPull with get, set

Property Value

Type: Adp5587TypeGpioPull
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.InterruptStatusGPIINT Property

IRD

Adp5587InterruptStatusGPIINT Property

Interrupt Status: GPI_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeIntStatGpiInt InterruptStatusGPIINT { get; set; }
Public Property InterruptStatusGPIINT As Adp5587TypeIntStatGpiInt
    Get
    Set
public:
property Adp5587TypeIntStatGpiInt InterruptStatusGPIINT {
    Adp5587TypeIntStatGpiInt get ();
    void set (Adp5587TypeIntStatGpiInt value);
}
member InterruptStatusGPIINT : Adp5587TypeIntStatGpiInt with get, set

Property Value

Type: Adp5587TypeIntStatGpiInt
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.InterruptStatusKEINT Property

IRD

Adp5587InterruptStatusKEINT Property

Interrupt Status: KE_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeIntStatKeInt InterruptStatusKEINT { get; set; }
Public Property InterruptStatusKEINT As Adp5587TypeIntStatKeInt
    Get
    Set
public:
property Adp5587TypeIntStatKeInt InterruptStatusKEINT {
    Adp5587TypeIntStatKeInt get ();
    void set (Adp5587TypeIntStatKeInt value);
}
member InterruptStatusKEINT : Adp5587TypeIntStatKeInt with get, set

Property Value

Type: Adp5587TypeIntStatKeInt
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.InterruptStatusKLCKINT Property

IRD

Adp5587InterruptStatusKLCKINT Property

Interrupt Status: K_LCK_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeIntStatKLckInt InterruptStatusKLCKINT { get; set; }
Public Property InterruptStatusKLCKINT As Adp5587TypeIntStatKLckInt
    Get
    Set
public:
property Adp5587TypeIntStatKLckInt InterruptStatusKLCKINT {
    Adp5587TypeIntStatKLckInt get ();
    void set (Adp5587TypeIntStatKLckInt value);
}
member InterruptStatusKLCKINT : Adp5587TypeIntStatKLckInt with get, set

Property Value

Type: Adp5587TypeIntStatKLckInt
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.InterruptStatusOVRFLOWINT Property

IRD

Adp5587InterruptStatusOVRFLOWINT Property

Interrupt Status: OVR_FLOW_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeIntStatOvrFlowInt InterruptStatusOVRFLOWINT { get; set; }
Public Property InterruptStatusOVRFLOWINT As Adp5587TypeIntStatOvrFlowInt
    Get
    Set
public:
property Adp5587TypeIntStatOvrFlowInt InterruptStatusOVRFLOWINT {
    Adp5587TypeIntStatOvrFlowInt get ();
    void set (Adp5587TypeIntStatOvrFlowInt value);
}
member InterruptStatusOVRFLOWINT : Adp5587TypeIntStatOvrFlowInt with get, set

Property Value

Type: Adp5587TypeIntStatOvrFlowInt
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventAKeyNumber Property

IRD

Adp5587KeyEventAKeyNumber Property

Key Event A: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventAKeyNumber { get; set; }
Public Property KeyEventAKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventAKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventAKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventAStatus Property

IRD

Adp5587KeyEventAStatus Property

Key Event A: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKeyEventStatus KeyEventAStatus { get; set; }
Public Property KeyEventAStatus As Adp5587TypeKeyEventStatus
    Get
    Set
public:
property Adp5587TypeKeyEventStatus KeyEventAStatus {
    Adp5587TypeKeyEventStatus get ();
    void set (Adp5587TypeKeyEventStatus value);
}
member KeyEventAStatus : Adp5587TypeKeyEventStatus with get, set

Property Value

Type: Adp5587TypeKeyEventStatus
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventBKeyNumber Property

IRD

Adp5587KeyEventBKeyNumber Property

Key Event B: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventBKeyNumber { get; set; }
Public Property KeyEventBKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventBKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventBKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventBStatus Property

IRD

Adp5587KeyEventBStatus Property

Key Event B: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKeyEventStatus KeyEventBStatus { get; set; }
Public Property KeyEventBStatus As Adp5587TypeKeyEventStatus
    Get
    Set
public:
property Adp5587TypeKeyEventStatus KeyEventBStatus {
    Adp5587TypeKeyEventStatus get ();
    void set (Adp5587TypeKeyEventStatus value);
}
member KeyEventBStatus : Adp5587TypeKeyEventStatus with get, set

Property Value

Type: Adp5587TypeKeyEventStatus
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventCKeyNumber Property

IRD

Adp5587KeyEventCKeyNumber Property

Key Event C: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventCKeyNumber { get; set; }
Public Property KeyEventCKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventCKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventCKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventCStatus Property

IRD

Adp5587KeyEventCStatus Property

Key Event C: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKeyEventStatus KeyEventCStatus { get; set; }
Public Property KeyEventCStatus As Adp5587TypeKeyEventStatus
    Get
    Set
public:
property Adp5587TypeKeyEventStatus KeyEventCStatus {
    Adp5587TypeKeyEventStatus get ();
    void set (Adp5587TypeKeyEventStatus value);
}
member KeyEventCStatus : Adp5587TypeKeyEventStatus with get, set

Property Value

Type: Adp5587TypeKeyEventStatus
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventDKeyNumber Property

IRD

Adp5587KeyEventDKeyNumber Property

Key Event D: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventDKeyNumber { get; set; }
Public Property KeyEventDKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventDKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventDKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventDStatus Property

IRD

Adp5587KeyEventDStatus Property

Key Event D: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKeyEventStatus KeyEventDStatus { get; set; }
Public Property KeyEventDStatus As Adp5587TypeKeyEventStatus
    Get
    Set
public:
property Adp5587TypeKeyEventStatus KeyEventDStatus {
    Adp5587TypeKeyEventStatus get ();
    void set (Adp5587TypeKeyEventStatus value);
}
member KeyEventDStatus : Adp5587TypeKeyEventStatus with get, set

Property Value

Type: Adp5587TypeKeyEventStatus
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventEKeyNumber Property

IRD

Adp5587KeyEventEKeyNumber Property

Key Event E: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventEKeyNumber { get; set; }
Public Property KeyEventEKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventEKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventEKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventEStatus Property

IRD

Adp5587KeyEventEStatus Property

Key Event E: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKeyEventStatus KeyEventEStatus { get; set; }
Public Property KeyEventEStatus As Adp5587TypeKeyEventStatus
    Get
    Set
public:
property Adp5587TypeKeyEventStatus KeyEventEStatus {
    Adp5587TypeKeyEventStatus get ();
    void set (Adp5587TypeKeyEventStatus value);
}
member KeyEventEStatus : Adp5587TypeKeyEventStatus with get, set

Property Value

Type: Adp5587TypeKeyEventStatus
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventFKeyNumber Property

IRD

Adp5587KeyEventFKeyNumber Property

Key Event F: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventFKeyNumber { get; set; }
Public Property KeyEventFKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventFKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventFKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventFStatus Property

IRD

Adp5587KeyEventFStatus Property

Key Event F: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKeyEventStatus KeyEventFStatus { get; set; }
Public Property KeyEventFStatus As Adp5587TypeKeyEventStatus
    Get
    Set
public:
property Adp5587TypeKeyEventStatus KeyEventFStatus {
    Adp5587TypeKeyEventStatus get ();
    void set (Adp5587TypeKeyEventStatus value);
}
member KeyEventFStatus : Adp5587TypeKeyEventStatus with get, set

Property Value

Type: Adp5587TypeKeyEventStatus
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventGKeyNumber Property

IRD

Adp5587KeyEventGKeyNumber Property

Key Event G: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventGKeyNumber { get; set; }
Public Property KeyEventGKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventGKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventGKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventGStatus Property

IRD

Adp5587KeyEventGStatus Property

Key Event G: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKeyEventStatus KeyEventGStatus { get; set; }
Public Property KeyEventGStatus As Adp5587TypeKeyEventStatus
    Get
    Set
public:
property Adp5587TypeKeyEventStatus KeyEventGStatus {
    Adp5587TypeKeyEventStatus get ();
    void set (Adp5587TypeKeyEventStatus value);
}
member KeyEventGStatus : Adp5587TypeKeyEventStatus with get, set

Property Value

Type: Adp5587TypeKeyEventStatus
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventHKeyNumber Property

IRD

Adp5587KeyEventHKeyNumber Property

Key Event H: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventHKeyNumber { get; set; }
Public Property KeyEventHKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventHKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventHKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventHStatus Property

IRD

Adp5587KeyEventHStatus Property

Key Event H: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKeyEventStatus KeyEventHStatus { get; set; }
Public Property KeyEventHStatus As Adp5587TypeKeyEventStatus
    Get
    Set
public:
property Adp5587TypeKeyEventStatus KeyEventHStatus {
    Adp5587TypeKeyEventStatus get ();
    void set (Adp5587TypeKeyEventStatus value);
}
member KeyEventHStatus : Adp5587TypeKeyEventStatus with get, set

Property Value

Type: Adp5587TypeKeyEventStatus
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventIKeyNumber Property

IRD

Adp5587KeyEventIKeyNumber Property

Key Event I: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventIKeyNumber { get; set; }
Public Property KeyEventIKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventIKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventIKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventIStatus Property

IRD

Adp5587KeyEventIStatus Property

Key Event I: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKeyEventStatus KeyEventIStatus { get; set; }
Public Property KeyEventIStatus As Adp5587TypeKeyEventStatus
    Get
    Set
public:
property Adp5587TypeKeyEventStatus KeyEventIStatus {
    Adp5587TypeKeyEventStatus get ();
    void set (Adp5587TypeKeyEventStatus value);
}
member KeyEventIStatus : Adp5587TypeKeyEventStatus with get, set

Property Value

Type: Adp5587TypeKeyEventStatus
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventJKeyNumber Property

IRD

Adp5587KeyEventJKeyNumber Property

Key Event J: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventJKeyNumber { get; set; }
Public Property KeyEventJKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventJKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventJKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeyEventJStatus Property

IRD

Adp5587KeyEventJStatus Property

Key Event J: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKeyEventStatus KeyEventJStatus { get; set; }
Public Property KeyEventJStatus As Adp5587TypeKeyEventStatus
    Get
    Set
public:
property Adp5587TypeKeyEventStatus KeyEventJStatus {
    Adp5587TypeKeyEventStatus get ();
    void set (Adp5587TypeKeyEventStatus value);
}
member KeyEventJStatus : Adp5587TypeKeyEventStatus with get, set

Property Value

Type: Adp5587TypeKeyEventStatus
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeylockEventCounterKEC Property

IRD

Adp5587KeylockEventCounterKEC Property

Keylock & Event Counter: KEC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeylockEventCounterKEC { get; set; }
Public Property KeylockEventCounterKEC As Byte
    Get
    Set
public:
property unsigned char KeylockEventCounterKEC {
    unsigned char get ();
    void set (unsigned char value);
}
member KeylockEventCounterKEC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeylockEventCounterKLCKEN Property

IRD

Adp5587KeylockEventCounterKLCKEN Property

Keylock & Event Counter: K_LCK_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKeyLckEcStatKLckEn KeylockEventCounterKLCKEN { get; set; }
Public Property KeylockEventCounterKLCKEN As Adp5587TypeKeyLckEcStatKLckEn
    Get
    Set
public:
property Adp5587TypeKeyLckEcStatKLckEn KeylockEventCounterKLCKEN {
    Adp5587TypeKeyLckEcStatKLckEn get ();
    void set (Adp5587TypeKeyLckEcStatKLckEn value);
}
member KeylockEventCounterKLCKEN : Adp5587TypeKeyLckEcStatKLckEn with get, set

Property Value

Type: Adp5587TypeKeyLckEcStatKLckEn
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeylockEventCounterLCK2LCK1 Property

IRD

Adp5587KeylockEventCounterLCK2LCK1 Property

Keylock & Event Counter: LCK2, LCK1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKeyLckEcStatLck2Lck1 KeylockEventCounterLCK2LCK1 { get; }
Public ReadOnly Property KeylockEventCounterLCK2LCK1 As Adp5587TypeKeyLckEcStatLck2Lck1
    Get
public:
property Adp5587TypeKeyLckEcStatLck2Lck1 KeylockEventCounterLCK2LCK1 {
    Adp5587TypeKeyLckEcStatLck2Lck1 get ();
}
member KeylockEventCounterLCK2LCK1 : Adp5587TypeKeyLckEcStatLck2Lck1 with get

Property Value

Type: Adp5587TypeKeyLckEcStatLck2Lck1
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadLockInterruptMaskTimer Property

IRD

Adp5587KeypadLockInterruptMaskTimer Property

Keypad Lock Interrupt Mask Timer (unit: s)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpLckTmrKllt KeypadLockInterruptMaskTimer { get; set; }
Public Property KeypadLockInterruptMaskTimer As Adp5587TypeKpLckTmrKllt
    Get
    Set
public:
property Adp5587TypeKpLckTmrKllt KeypadLockInterruptMaskTimer {
    Adp5587TypeKpLckTmrKllt get ();
    void set (Adp5587TypeKpLckTmrKllt value);
}
member KeypadLockInterruptMaskTimer : Adp5587TypeKpLckTmrKllt with get, set

Property Value

Type: Adp5587TypeKpLckTmrKllt
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadOrGPIOSelection1R0 Property

IRD

Adp5587KeypadOrGPIOSelection1R0 Property

Keypad or GPIO Selection 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpGpio KeypadOrGPIOSelection1R0 { get; set; }
Public Property KeypadOrGPIOSelection1R0 As Adp5587TypeKpGpio
    Get
    Set
public:
property Adp5587TypeKpGpio KeypadOrGPIOSelection1R0 {
    Adp5587TypeKpGpio get ();
    void set (Adp5587TypeKpGpio value);
}
member KeypadOrGPIOSelection1R0 : Adp5587TypeKpGpio with get, set

Property Value

Type: Adp5587TypeKpGpio
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadOrGPIOSelection1R1 Property

IRD

Adp5587KeypadOrGPIOSelection1R1 Property

Keypad or GPIO Selection 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpGpio KeypadOrGPIOSelection1R1 { get; set; }
Public Property KeypadOrGPIOSelection1R1 As Adp5587TypeKpGpio
    Get
    Set
public:
property Adp5587TypeKpGpio KeypadOrGPIOSelection1R1 {
    Adp5587TypeKpGpio get ();
    void set (Adp5587TypeKpGpio value);
}
member KeypadOrGPIOSelection1R1 : Adp5587TypeKpGpio with get, set

Property Value

Type: Adp5587TypeKpGpio
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadOrGPIOSelection1R2 Property

IRD

Adp5587KeypadOrGPIOSelection1R2 Property

Keypad or GPIO Selection 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpGpio KeypadOrGPIOSelection1R2 { get; set; }
Public Property KeypadOrGPIOSelection1R2 As Adp5587TypeKpGpio
    Get
    Set
public:
property Adp5587TypeKpGpio KeypadOrGPIOSelection1R2 {
    Adp5587TypeKpGpio get ();
    void set (Adp5587TypeKpGpio value);
}
member KeypadOrGPIOSelection1R2 : Adp5587TypeKpGpio with get, set

Property Value

Type: Adp5587TypeKpGpio
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadOrGPIOSelection1R3 Property

IRD

Adp5587KeypadOrGPIOSelection1R3 Property

Keypad or GPIO Selection 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpGpio KeypadOrGPIOSelection1R3 { get; set; }
Public Property KeypadOrGPIOSelection1R3 As Adp5587TypeKpGpio
    Get
    Set
public:
property Adp5587TypeKpGpio KeypadOrGPIOSelection1R3 {
    Adp5587TypeKpGpio get ();
    void set (Adp5587TypeKpGpio value);
}
member KeypadOrGPIOSelection1R3 : Adp5587TypeKpGpio with get, set

Property Value

Type: Adp5587TypeKpGpio
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadOrGPIOSelection1R4 Property

IRD

Adp5587KeypadOrGPIOSelection1R4 Property

Keypad or GPIO Selection 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpGpio KeypadOrGPIOSelection1R4 { get; set; }
Public Property KeypadOrGPIOSelection1R4 As Adp5587TypeKpGpio
    Get
    Set
public:
property Adp5587TypeKpGpio KeypadOrGPIOSelection1R4 {
    Adp5587TypeKpGpio get ();
    void set (Adp5587TypeKpGpio value);
}
member KeypadOrGPIOSelection1R4 : Adp5587TypeKpGpio with get, set

Property Value

Type: Adp5587TypeKpGpio
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadOrGPIOSelection1R5 Property

IRD

Adp5587KeypadOrGPIOSelection1R5 Property

Keypad or GPIO Selection 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpGpio KeypadOrGPIOSelection1R5 { get; set; }
Public Property KeypadOrGPIOSelection1R5 As Adp5587TypeKpGpio
    Get
    Set
public:
property Adp5587TypeKpGpio KeypadOrGPIOSelection1R5 {
    Adp5587TypeKpGpio get ();
    void set (Adp5587TypeKpGpio value);
}
member KeypadOrGPIOSelection1R5 : Adp5587TypeKpGpio with get, set

Property Value

Type: Adp5587TypeKpGpio
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadOrGPIOSelection1R6 Property

IRD

Adp5587KeypadOrGPIOSelection1R6 Property

Keypad or GPIO Selection 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpGpio KeypadOrGPIOSelection1R6 { get; set; }
Public Property KeypadOrGPIOSelection1R6 As Adp5587TypeKpGpio
    Get
    Set
public:
property Adp5587TypeKpGpio KeypadOrGPIOSelection1R6 {
    Adp5587TypeKpGpio get ();
    void set (Adp5587TypeKpGpio value);
}
member KeypadOrGPIOSelection1R6 : Adp5587TypeKpGpio with get, set

Property Value

Type: Adp5587TypeKpGpio
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadOrGPIOSelection1R7 Property

IRD

Adp5587KeypadOrGPIOSelection1R7 Property

Keypad or GPIO Selection 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpGpio KeypadOrGPIOSelection1R7 { get; set; }
Public Property KeypadOrGPIOSelection1R7 As Adp5587TypeKpGpio
    Get
    Set
public:
property Adp5587TypeKpGpio KeypadOrGPIOSelection1R7 {
    Adp5587TypeKpGpio get ();
    void set (Adp5587TypeKpGpio value);
}
member KeypadOrGPIOSelection1R7 : Adp5587TypeKpGpio with get, set

Property Value

Type: Adp5587TypeKpGpio
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadOrGPIOSelection2C0 Property

IRD

Adp5587KeypadOrGPIOSelection2C0 Property

Keypad or GPIO Selection 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpGpio KeypadOrGPIOSelection2C0 { get; set; }
Public Property KeypadOrGPIOSelection2C0 As Adp5587TypeKpGpio
    Get
    Set
public:
property Adp5587TypeKpGpio KeypadOrGPIOSelection2C0 {
    Adp5587TypeKpGpio get ();
    void set (Adp5587TypeKpGpio value);
}
member KeypadOrGPIOSelection2C0 : Adp5587TypeKpGpio with get, set

Property Value

Type: Adp5587TypeKpGpio
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadOrGPIOSelection2C1 Property

IRD

Adp5587KeypadOrGPIOSelection2C1 Property

Keypad or GPIO Selection 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpGpio KeypadOrGPIOSelection2C1 { get; set; }
Public Property KeypadOrGPIOSelection2C1 As Adp5587TypeKpGpio
    Get
    Set
public:
property Adp5587TypeKpGpio KeypadOrGPIOSelection2C1 {
    Adp5587TypeKpGpio get ();
    void set (Adp5587TypeKpGpio value);
}
member KeypadOrGPIOSelection2C1 : Adp5587TypeKpGpio with get, set

Property Value

Type: Adp5587TypeKpGpio
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadOrGPIOSelection2C2 Property

IRD

Adp5587KeypadOrGPIOSelection2C2 Property

Keypad or GPIO Selection 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpGpio KeypadOrGPIOSelection2C2 { get; set; }
Public Property KeypadOrGPIOSelection2C2 As Adp5587TypeKpGpio
    Get
    Set
public:
property Adp5587TypeKpGpio KeypadOrGPIOSelection2C2 {
    Adp5587TypeKpGpio get ();
    void set (Adp5587TypeKpGpio value);
}
member KeypadOrGPIOSelection2C2 : Adp5587TypeKpGpio with get, set

Property Value

Type: Adp5587TypeKpGpio
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadOrGPIOSelection2C3 Property

IRD

Adp5587KeypadOrGPIOSelection2C3 Property

Keypad or GPIO Selection 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpGpio KeypadOrGPIOSelection2C3 { get; set; }
Public Property KeypadOrGPIOSelection2C3 As Adp5587TypeKpGpio
    Get
    Set
public:
property Adp5587TypeKpGpio KeypadOrGPIOSelection2C3 {
    Adp5587TypeKpGpio get ();
    void set (Adp5587TypeKpGpio value);
}
member KeypadOrGPIOSelection2C3 : Adp5587TypeKpGpio with get, set

Property Value

Type: Adp5587TypeKpGpio
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadOrGPIOSelection2C4 Property

IRD

Adp5587KeypadOrGPIOSelection2C4 Property

Keypad or GPIO Selection 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpGpio KeypadOrGPIOSelection2C4 { get; set; }
Public Property KeypadOrGPIOSelection2C4 As Adp5587TypeKpGpio
    Get
    Set
public:
property Adp5587TypeKpGpio KeypadOrGPIOSelection2C4 {
    Adp5587TypeKpGpio get ();
    void set (Adp5587TypeKpGpio value);
}
member KeypadOrGPIOSelection2C4 : Adp5587TypeKpGpio with get, set

Property Value

Type: Adp5587TypeKpGpio
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadOrGPIOSelection2C5 Property

IRD

Adp5587KeypadOrGPIOSelection2C5 Property

Keypad or GPIO Selection 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpGpio KeypadOrGPIOSelection2C5 { get; set; }
Public Property KeypadOrGPIOSelection2C5 As Adp5587TypeKpGpio
    Get
    Set
public:
property Adp5587TypeKpGpio KeypadOrGPIOSelection2C5 {
    Adp5587TypeKpGpio get ();
    void set (Adp5587TypeKpGpio value);
}
member KeypadOrGPIOSelection2C5 : Adp5587TypeKpGpio with get, set

Property Value

Type: Adp5587TypeKpGpio
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadOrGPIOSelection2C6 Property

IRD

Adp5587KeypadOrGPIOSelection2C6 Property

Keypad or GPIO Selection 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpGpio KeypadOrGPIOSelection2C6 { get; set; }
Public Property KeypadOrGPIOSelection2C6 As Adp5587TypeKpGpio
    Get
    Set
public:
property Adp5587TypeKpGpio KeypadOrGPIOSelection2C6 {
    Adp5587TypeKpGpio get ();
    void set (Adp5587TypeKpGpio value);
}
member KeypadOrGPIOSelection2C6 : Adp5587TypeKpGpio with get, set

Property Value

Type: Adp5587TypeKpGpio
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadOrGPIOSelection2C7 Property

IRD

Adp5587KeypadOrGPIOSelection2C7 Property

Keypad or GPIO Selection 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpGpio KeypadOrGPIOSelection2C7 { get; set; }
Public Property KeypadOrGPIOSelection2C7 As Adp5587TypeKpGpio
    Get
    Set
public:
property Adp5587TypeKpGpio KeypadOrGPIOSelection2C7 {
    Adp5587TypeKpGpio get ();
    void set (Adp5587TypeKpGpio value);
}
member KeypadOrGPIOSelection2C7 : Adp5587TypeKpGpio with get, set

Property Value

Type: Adp5587TypeKpGpio
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadOrGPIOSelection3C8 Property

IRD

Adp5587KeypadOrGPIOSelection3C8 Property

Keypad or GPIO Selection 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpGpio KeypadOrGPIOSelection3C8 { get; set; }
Public Property KeypadOrGPIOSelection3C8 As Adp5587TypeKpGpio
    Get
    Set
public:
property Adp5587TypeKpGpio KeypadOrGPIOSelection3C8 {
    Adp5587TypeKpGpio get ();
    void set (Adp5587TypeKpGpio value);
}
member KeypadOrGPIOSelection3C8 : Adp5587TypeKpGpio with get, set

Property Value

Type: Adp5587TypeKpGpio
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadOrGPIOSelection3C9 Property

IRD

Adp5587KeypadOrGPIOSelection3C9 Property

Keypad or GPIO Selection 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpGpio KeypadOrGPIOSelection3C9 { get; set; }
Public Property KeypadOrGPIOSelection3C9 As Adp5587TypeKpGpio
    Get
    Set
public:
property Adp5587TypeKpGpio KeypadOrGPIOSelection3C9 {
    Adp5587TypeKpGpio get ();
    void set (Adp5587TypeKpGpio value);
}
member KeypadOrGPIOSelection3C9 : Adp5587TypeKpGpio with get, set

Property Value

Type: Adp5587TypeKpGpio
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.KeypadUnlock1TimerToKeypadUnlock2Timer Property

IRD

Adp5587KeypadUnlock1TimerToKeypadUnlock2Timer Property

Keypad Unlock 1 Timer to Keypad Unlock 2 Timer (unit: s)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeKpLckTmrKimt KeypadUnlock1TimerToKeypadUnlock2Timer { get; set; }
Public Property KeypadUnlock1TimerToKeypadUnlock2Timer As Adp5587TypeKpLckTmrKimt
    Get
    Set
public:
property Adp5587TypeKpLckTmrKimt KeypadUnlock1TimerToKeypadUnlock2Timer {
    Adp5587TypeKpLckTmrKimt get ();
    void set (Adp5587TypeKpLckTmrKimt value);
}
member KeypadUnlock1TimerToKeypadUnlock2Timer : Adp5587TypeKpLckTmrKimt with get, set

Property Value

Type: Adp5587TypeKpLckTmrKimt
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.UnlockKey1 Property

IRD

Adp5587UnlockKey1 Property

Unlock Key 1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeUnlock UnlockKey1 { get; set; }
Public Property UnlockKey1 As Adp5587TypeUnlock
    Get
    Set
public:
property Adp5587TypeUnlock UnlockKey1 {
    Adp5587TypeUnlock get ();
    void set (Adp5587TypeUnlock value);
}
member UnlockKey1 : Adp5587TypeUnlock with get, set

Property Value

Type: Adp5587TypeUnlock
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.UnlockKey2 Property

IRD

Adp5587UnlockKey2 Property

Unlock Key 2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5587TypeUnlock UnlockKey2 { get; set; }
Public Property UnlockKey2 As Adp5587TypeUnlock
    Get
    Set
public:
property Adp5587TypeUnlock UnlockKey2 {
    Adp5587TypeUnlock get ();
    void set (Adp5587TypeUnlock value);
}
member UnlockKey2 : Adp5587TypeUnlock with get, set

Property Value

Type: Adp5587TypeUnlock
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587 Methods

The Adp5587 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.Flush Method

IRD

Adp5587Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adp5587 Class
telos.Ird.AnalogDevices Namespace


Adp5587.TypeCfgAutoInc Enumeration

IRD

Adp5587TypeCfgAutoInc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgAutoInc
Public Enumeration TypeCfgAutoInc
public enum class TypeCfgAutoInc
type TypeCfgAutoInc
Members
Member name | Value | Description
I2CAutoIncrementOn | 1 | I2C auto-increment: on
I2CAutoIncrementOff | 0 | I2C auto-increment: off
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeCfgGpiemCfg Enumeration

IRD

Adp5587TypeCfgGpiemCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgGpiemCfg
Public Enumeration TypeCfgGpiemCfg
public enum class TypeCfgGpiemCfg
type TypeCfgGpiemCfg
Members
Member name | Value | Description
GPIEventsNotTracked | 1 | GPI events: not tracked
GPIEventsTracked | 0 | GPI events: tracked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeCfgGpiIen Enumeration

IRD

Adp5587TypeCfgGpiIen Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgGpiIen
Public Enumeration TypeCfgGpiIen
public enum class TypeCfgGpiIen
type TypeCfgGpiIen
Members
Member name | Value | Description
GPIInterruptEnabled | 1 | GPI interrupt: enabled
GPIInterruptDisabled | 0 | GPI interrupt: disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeCfgIntCfg Enumeration

IRD

Adp5587TypeCfgIntCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgIntCfg
Public Enumeration TypeCfgIntCfg
public enum class TypeCfgIntCfg
type TypeCfgIntCfg
Members
Member name | Value | Description
ProcessorInterruptDeassertedFor275us | 1 | Processor interrupt: deasserted for 275µs
ProcessorInterruptRemainsAsserted | 0 | Processor interrupt: remains asserted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeCfgKeIen Enumeration

IRD

Adp5587TypeCfgKeIen Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgKeIen
Public Enumeration TypeCfgKeIen
public enum class TypeCfgKeIen
type TypeCfgKeIen
Members
Member name | Value | Description
KeyEventsInterruptEnabled | 1 | Key events interrupt: enabled
KeyEventsInterruptDisabled | 0 | Key events interrupt: disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeCfgKLckM Enumeration

IRD

Adp5587TypeCfgKLckM Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgKLckM
Public Enumeration TypeCfgKLckM
public enum class TypeCfgKLckM
type TypeCfgKLckM
Members
Member name | Value | Description
KeypadLockEnabled | 1 | Keypad lock: enabled
KeypadLockDisabled | 0 | Keypad lock: disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeCfgOvrFlowIen Enumeration

IRD

Adp5587TypeCfgOvrFlowIen Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgOvrFlowIen
Public Enumeration TypeCfgOvrFlowIen
public enum class TypeCfgOvrFlowIen
type TypeCfgOvrFlowIen
Members
Member name | Value | Description
OverflowInterruptEnabled | 1 | Overflow interrupt: enabled
OverflowInterruptDisabled | 0 | Overflow interrupt: disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeCfgOvrFlowM Enumeration

IRD

Adp5587TypeCfgOvrFlowM Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgOvrFlowM
Public Enumeration TypeCfgOvrFlowM
public enum class TypeCfgOvrFlowM
type TypeCfgOvrFlowM
Members
Member name | Value | Description
OverflowModeOn | 1 | Overflow mode: on
OverflowModeOff | 0 | Overflow mode: off
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeGpiEmReg Enumeration

IRD

Adp5587TypeGpiEmReg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpiEmReg
Public Enumeration TypeGpiEmReg
public enum class TypeGpiEmReg
type TypeGpiEmReg
Members
Member name | Value | Description
GPINotPartOfEventFIFO | 0 | GPI: Not part of event FIFO
GPIPartOfEventFIFO | 1 | GPI: Part of event FIFO
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeGpioDir Enumeration

IRD

Adp5587TypeGpioDir Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioDir
Public Enumeration TypeGpioDir
public enum class TypeGpioDir
type TypeGpioDir
Members
Member name | Value | Description
Input | 0 | Input
Output | 1 | Output
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeGpioIntLvl Enumeration

IRD

Adp5587TypeGpioIntLvl Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioIntLvl
Public Enumeration TypeGpioIntLvl
public enum class TypeGpioIntLvl
type TypeGpioIntLvl
Members
Member name | Value | Description
Low | 0 | Low
High | 1 | High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeGpioPull Enumeration

IRD

Adp5587TypeGpioPull Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioPull
Public Enumeration TypeGpioPull
public enum class TypeGpioPull
type TypeGpioPull
Members
Member name | Value | Description
PullEnabled | 0 | Pull: enabled
PullDisabled | 1 | Pull: disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeIntStatGpiInt Enumeration

IRD

Adp5587TypeIntStatGpiInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntStatGpiInt
Public Enumeration TypeIntStatGpiInt
public enum class TypeIntStatGpiInt
type TypeIntStatGpiInt
Members
Member name | Value | Description
GPIInterruptDetected | 1 | GPI interrupt: detected
GPIInterruptNotDetected | 0 | GPI interrupt: not detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeIntStatKeInt Enumeration

IRD

Adp5587TypeIntStatKeInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntStatKeInt
Public Enumeration TypeIntStatKeInt
public enum class TypeIntStatKeInt
type TypeIntStatKeInt
Members
Member name | Value | Description
KeyEventsInterruptDetected | 1 | Key events interrupt: detected
KeyEventsInterruptNotDetected | 0 | Key events interrupt: not detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeIntStatKLckInt Enumeration

IRD

Adp5587TypeIntStatKLckInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntStatKLckInt
Public Enumeration TypeIntStatKLckInt
public enum class TypeIntStatKLckInt
type TypeIntStatKLckInt
Members
Member name | Value | Description
KeylockInterruptDetected | 1 | Keylock interrupt: detected
KeylockInterruptNotDetected | 0 | Keylock interrupt: not detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeIntStatOvrFlowInt Enumeration

IRD

Adp5587TypeIntStatOvrFlowInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntStatOvrFlowInt
Public Enumeration TypeIntStatOvrFlowInt
public enum class TypeIntStatOvrFlowInt
type TypeIntStatOvrFlowInt
Members
Member name | Value | Description
OverflowInterruptDetected | 1 | Overflow interrupt: detected
OverflowInterruptNotDetected | 0 | Overflow interrupt: not detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeKeyEventStatus Enumeration

IRD

Adp5587TypeKeyEventStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeKeyEventStatus
Public Enumeration TypeKeyEventStatus
public enum class TypeKeyEventStatus
type TypeKeyEventStatus
Members
Member name | Value | Description
Released | 0 | Released
Pressed | 1 | Pressed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeKeyLckEcStatKLckEn Enumeration

IRD

Adp5587TypeKeyLckEcStatKLckEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeKeyLckEcStatKLckEn
Public Enumeration TypeKeyLckEcStatKLckEn
public enum class TypeKeyLckEcStatKLckEn
type TypeKeyLckEcStatKLckEn
Members
Member name | Value | Description
LockFeatureDisabled | 0 | Lock feature: disabled
LockFeatureEnabled | 1 | Lock feature: enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeKeyLckEcStatLck2Lck1 Enumeration

IRD

Adp5587TypeKeyLckEcStatLck2Lck1 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeKeyLckEcStatLck2Lck1
Public Enumeration TypeKeyLckEcStatLck2Lck1
public enum class TypeKeyLckEcStatLck2Lck1
type TypeKeyLckEcStatLck2Lck1
Members
Member name | Value | Description
KeypadLockStatusUnlocked | 0 | Keypad lock status: unlocked
KeypadLockStatusLocked | 3 | Keypad lock status: locked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeKpGpio Enumeration

IRD

Adp5587TypeKpGpio Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeKpGpio
Public Enumeration TypeKpGpio
public enum class TypeKpGpio
type TypeKpGpio
Members
Member name | Value | Description
GPIO | 0 | GPIO
KPMatrix | 1 | KP matrix
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeKpLckTmrKimt Enumeration

IRD

Adp5587TypeKpLckTmrKimt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeKpLckTmrKimt
Public Enumeration TypeKpLckTmrKimt
public enum class TypeKpLckTmrKimt
type TypeKpLckTmrKimt
Members
Member name | Value | Description
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeKpLckTmrKllt Enumeration

IRD

Adp5587TypeKpLckTmrKllt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeKpLckTmrKllt
Public Enumeration TypeKpLckTmrKllt
public enum class TypeKpLckTmrKllt
type TypeKpLckTmrKllt
Members
Member name | Value | Description
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5587.TypeUnlock Enumeration

IRD

Adp5587TypeUnlock Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeUnlock
Public Enumeration TypeUnlock
public enum class TypeUnlock
type TypeUnlock
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588 Class

Analog Devices: ADP 5588
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdp5588

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adp5588
Public Class Adp5588
public ref class Adp5588
type Adp5588 =  class end

The Adp5588 type exposes the following members.

Constructors
 | Name | Description
Public method | Adp5588 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Comparator1ADCData | Comparator 1 ADC Data
Public property | Comparator2ADCData | Comparator 2 ADC Data
Public property | ComparatorConfigurationStatusCMP1EN | Comparator Configuration & Status: CMP1_EN
Public property | ComparatorConfigurationStatusCMP1IEN | Comparator Configuration & Status: CMP1_IEN
Public property | ComparatorConfigurationStatusCMP1L2OUT | Comparator Configuration & Status: CMP1_L2_OUT
Public property | ComparatorConfigurationStatusCMP1L3OUT | Comparator Configuration & Status: CMP1_L3_OUT
Public property | ComparatorConfigurationStatusCMP2EN | Comparator Configuration & Status: CMP2_EN
Public property | ComparatorConfigurationStatusCMP2IEN | Comparator Configuration & Status: CMP2_IEN
Public property | ComparatorConfigurationStatusCMP2L2OUT | Comparator Configuration & Status: CMP2_L2_OUT
Public property | ComparatorConfigurationStatusCMP2L3OUT | Comparator Configuration & Status: CMP2_L3_OUT
Public property | ConfigurationAUTOINC | Configuration: AUTO_INC
Public property | ConfigurationGPIEMCFG | Configuration: GPIEM_CFG
Public property | ConfigurationGPIIEN | Configuration: GPI_IEN
Public property | ConfigurationINTCFG | Configuration: INT_CFG
Public property | ConfigurationKEIEN | Configuration: KE_IEN
Public property | ConfigurationKLCKIM | Configuration: K_LCK_IM
Public property | ConfigurationOVRFLOWIEN | Configuration: OVR_FLOW_IEN
Public property | ConfigurationOVRFLOWM | Configuration: OVR_FLOW_M
Public property | DebounceDisable1R0 | Debounce Disable 1: R0
Public property | DebounceDisable1R1 | Debounce Disable 1: R1
Public property | DebounceDisable1R2 | Debounce Disable 1: R2
Public property | DebounceDisable1R3 | Debounce Disable 1: R3
Public property | DebounceDisable1R4 | Debounce Disable 1: R4
Public property | DebounceDisable1R5 | Debounce Disable 1: R5
Public property | DebounceDisable1R6 | Debounce Disable 1: R6
Public property | DebounceDisable1R7 | Debounce Disable 1: R7
Public property | DebounceDisable2C0 | Debounce Disable 2: C0
Public property | DebounceDisable2C1 | Debounce Disable 2: C1
Public property | DebounceDisable2C2 | Debounce Disable 2: C2
Public property | DebounceDisable2C3 | Debounce Disable 2: C3
Public property | DebounceDisable2C4 | Debounce Disable 2: C4
Public property | DebounceDisable2C5 | Debounce Disable 2: C5
Public property | DebounceDisable2C6 | Debounce Disable 2: C6
Public property | DebounceDisable2C7 | Debounce Disable 2: C7
Public property | DebounceDisable3C8 | Debounce Disable 3: C8
Public property | DebounceDisable3C9 | Debounce Disable 3: C9
Public property | DeviceIDDeviceID | Device ID: Device ID
Public property | DeviceIDMFGID | Device ID: MFG ID
Public property | GPIEventMode1R0 | GPI Event Mode 1: R0
Public property | GPIEventMode1R1 | GPI Event Mode 1: R1
Public property | GPIEventMode1R2 | GPI Event Mode 1: R2
Public property | GPIEventMode1R3 | GPI Event Mode 1: R3
Public property | GPIEventMode1R4 | GPI Event Mode 1: R4
Public property | GPIEventMode1R5 | GPI Event Mode 1: R5
Public property | GPIEventMode1R6 | GPI Event Mode 1: R6
Public property | GPIEventMode1R7 | GPI Event Mode 1: R7
Public property | GPIEventMode2C0 | GPI Event Mode 2: C0
Public property | GPIEventMode2C1 | GPI Event Mode 2: C1
Public property | GPIEventMode2C2 | GPI Event Mode 2: C2
Public property | GPIEventMode2C3 | GPI Event Mode 2: C3
Public property | GPIEventMode2C4 | GPI Event Mode 2: C4
Public property | GPIEventMode2C5 | GPI Event Mode 2: C5
Public property | GPIEventMode2C6 | GPI Event Mode 2: C6
Public property | GPIEventMode2C7 | GPI Event Mode 2: C7
Public property | GPIEventMode3C8 | GPI Event Mode 3: C8
Public property | GPIEventMode3C9 | GPI Event Mode 3: C9
Public property | GPIODataDirection1R0 | GPIO Data Direction 1: R0
Public property | GPIODataDirection1R1 | GPIO Data Direction 1: R1
Public property | GPIODataDirection1R2 | GPIO Data Direction 1: R2
Public property | GPIODataDirection1R3 | GPIO Data Direction 1: R3
Public property | GPIODataDirection1R4 | GPIO Data Direction 1: R4
Public property | GPIODataDirection1R5 | GPIO Data Direction 1: R5
Public property | GPIODataDirection1R6 | GPIO Data Direction 1: R6
Public property | GPIODataDirection1R7 | GPIO Data Direction 1: R7
Public property | GPIODataDirection2C0 | GPIO Data Direction 2: C0
Public property | GPIODataDirection2C1 | GPIO Data Direction 2: C1
Public property | GPIODataDirection2C2 | GPIO Data Direction 2: C2
Public property | GPIODataDirection2C3 | GPIO Data Direction 2: C3
Public property | GPIODataDirection2C4 | GPIO Data Direction 2: C4
Public property | GPIODataDirection2C5 | GPIO Data Direction 2: C5
Public property | GPIODataDirection2C6 | GPIO Data Direction 2: C6
Public property | GPIODataDirection2C7 | GPIO Data Direction 2: C7
Public property | GPIODataDirection3C8 | GPIO Data Direction 3: C8
Public property | GPIODataDirection3C9 | GPIO Data Direction 3: C9
Public property | GPIODataOut1R0 | GPIO Data Out 1: R0
Public property | GPIODataOut1R1 | GPIO Data Out 1: R1
Public property | GPIODataOut1R2 | GPIO Data Out 1: R2
Public property | GPIODataOut1R3 | GPIO Data Out 1: R3
Public property | GPIODataOut1R4 | GPIO Data Out 1: R4
Public property | GPIODataOut1R5 | GPIO Data Out 1: R5
Public property | GPIODataOut1R6 | GPIO Data Out 1: R6
Public property | GPIODataOut1R7 | GPIO Data Out 1: R7
Public property | GPIODataOut2C0 | GPIO Data Out 2: C0
Public property | GPIODataOut2C1 | GPIO Data Out 2: C1
Public property | GPIODataOut2C2 | GPIO Data Out 2: C2
Public property | GPIODataOut2C3 | GPIO Data Out 2: C3
Public property | GPIODataOut2C4 | GPIO Data Out 2: C4
Public property | GPIODataOut2C5 | GPIO Data Out 2: C5
Public property | GPIODataOut2C6 | GPIO Data Out 2: C6
Public property | GPIODataOut2C7 | GPIO Data Out 2: C7
Public property | GPIODataOut3C8 | GPIO Data Out 3: C8
Public property | GPIODataOut3C9 | GPIO Data Out 3: C9
Public property | GPIODataStatus1R0 | GPIO Data Status 1: R0
Public property | GPIODataStatus1R1 | GPIO Data Status 1: R1
Public property | GPIODataStatus1R2 | GPIO Data Status 1: R2
Public property | GPIODataStatus1R3 | GPIO Data Status 1: R3
Public property | GPIODataStatus1R4 | GPIO Data Status 1: R4
Public property | GPIODataStatus1R5 | GPIO Data Status 1: R5
Public property | GPIODataStatus1R6 | GPIO Data Status 1: R6
Public property | GPIODataStatus1R7 | GPIO Data Status 1: R7
Public property | GPIODataStatus2C0 | GPIO Data Status 2: C0
Public property | GPIODataStatus2C1 | GPIO Data Status 2: C1
Public property | GPIODataStatus2C2 | GPIO Data Status 2: C2
Public property | GPIODataStatus2C3 | GPIO Data Status 2: C3
Public property | GPIODataStatus2C4 | GPIO Data Status 2: C4
Public property | GPIODataStatus2C5 | GPIO Data Status 2: C5
Public property | GPIODataStatus2C6 | GPIO Data Status 2: C6
Public property | GPIODataStatus2C7 | GPIO Data Status 2: C7
Public property | GPIODataStatus3C8 | GPIO Data Status 3: C8
Public property | GPIODataStatus3C9 | GPIO Data Status 3: C9
Public property | GPIOInterruptEnable1R0 | GPIO Interrupt Enable 1: R0
Public property | GPIOInterruptEnable1R1 | GPIO Interrupt Enable 1: R1
Public property | GPIOInterruptEnable1R2 | GPIO Interrupt Enable 1: R2
Public property | GPIOInterruptEnable1R3 | GPIO Interrupt Enable 1: R3
Public property | GPIOInterruptEnable1R4 | GPIO Interrupt Enable 1: R4
Public property | GPIOInterruptEnable1R5 | GPIO Interrupt Enable 1: R5
Public property | GPIOInterruptEnable1R6 | GPIO Interrupt Enable 1: R6
Public property | GPIOInterruptEnable1R7 | GPIO Interrupt Enable 1: R7
Public property | GPIOInterruptEnable2C0 | GPIO Interrupt Enable 2: C0
Public property | GPIOInterruptEnable2C1 | GPIO Interrupt Enable 2: C1
Public property | GPIOInterruptEnable2C2 | GPIO Interrupt Enable 2: C2
Public property | GPIOInterruptEnable2C3 | GPIO Interrupt Enable 2: C3
Public property | GPIOInterruptEnable2C4 | GPIO Interrupt Enable 2: C4
Public property | GPIOInterruptEnable2C5 | GPIO Interrupt Enable 2: C5
Public property | GPIOInterruptEnable2C6 | GPIO Interrupt Enable 2: C6
Public property | GPIOInterruptEnable2C7 | GPIO Interrupt Enable 2: C7
Public property | GPIOInterruptEnable3C8 | GPIO Interrupt Enable 3: C8
Public property | GPIOInterruptEnable3C9 | GPIO Interrupt Enable 3: C9
Public property | GPIOInterruptStatus1R0 | GPIO Interrupt Status 1: R0
Public property | GPIOInterruptStatus1R1 | GPIO Interrupt Status 1: R1
Public property | GPIOInterruptStatus1R2 | GPIO Interrupt Status 1: R2
Public property | GPIOInterruptStatus1R3 | GPIO Interrupt Status 1: R3
Public property | GPIOInterruptStatus1R4 | GPIO Interrupt Status 1: R4
Public property | GPIOInterruptStatus1R5 | GPIO Interrupt Status 1: R5
Public property | GPIOInterruptStatus1R6 | GPIO Interrupt Status 1: R6
Public property | GPIOInterruptStatus1R7 | GPIO Interrupt Status 1: R7
Public property | GPIOInterruptStatus2C0 | GPIO Interrupt Status 2: C0
Public property | GPIOInterruptStatus2C1 | GPIO Interrupt Status 2: C1
Public property | GPIOInterruptStatus2C2 | GPIO Interrupt Status 2: C2
Public property | GPIOInterruptStatus2C3 | GPIO Interrupt Status 2: C3
Public property | GPIOInterruptStatus2C4 | GPIO Interrupt Status 2: C4
Public property | GPIOInterruptStatus2C5 | GPIO Interrupt Status 2: C5
Public property | GPIOInterruptStatus2C6 | GPIO Interrupt Status 2: C6
Public property | GPIOInterruptStatus2C7 | GPIO Interrupt Status 2: C7
Public property | GPIOInterruptStatus3C8 | GPIO Interrupt Status 3: C8
Public property | GPIOInterruptStatus3C9 | GPIO Interrupt Status 3: C9
Public property | GPIOLevelDetect1R0 | GPIO Level Detect 1: R0
Public property | GPIOLevelDetect1R1 | GPIO Level Detect 1: R1
Public property | GPIOLevelDetect1R2 | GPIO Level Detect 1: R2
Public property | GPIOLevelDetect1R3 | GPIO Level Detect 1: R3
Public property | GPIOLevelDetect1R4 | GPIO Level Detect 1: R4
Public property | GPIOLevelDetect1R5 | GPIO Level Detect 1: R5
Public property | GPIOLevelDetect1R6 | GPIO Level Detect 1: R6
Public property | GPIOLevelDetect1R7 | GPIO Level Detect 1: R7
Public property | GPIOLevelDetect2C0 | GPIO Level Detect 2: C0
Public property | GPIOLevelDetect2C1 | GPIO Level Detect 2: C1
Public property | GPIOLevelDetect2C2 | GPIO Level Detect 2: C2
Public property | GPIOLevelDetect2C3 | GPIO Level Detect 2: C3
Public property | GPIOLevelDetect2C4 | GPIO Level Detect 2: C4
Public property | GPIOLevelDetect2C5 | GPIO Level Detect 2: C5
Public property | GPIOLevelDetect2C6 | GPIO Level Detect 2: C6
Public property | GPIOLevelDetect2C7 | GPIO Level Detect 2: C7
Public property | GPIOLevelDetect3C8 | GPIO Level Detect 3: C8
Public property | GPIOLevelDetect3C9 | GPIO Level Detect 3: C9
Public property | GPIOPullDisable1R0 | GPIO Pull Disable 1: R0
Public property | GPIOPullDisable1R1 | GPIO Pull Disable 1: R1
Public property | GPIOPullDisable1R2 | GPIO Pull Disable 1: R2
Public property | GPIOPullDisable1R3 | GPIO Pull Disable 1: R3
Public property | GPIOPullDisable1R4 | GPIO Pull Disable 1: R4
Public property | GPIOPullDisable1R5 | GPIO Pull Disable 1: R5
Public property | GPIOPullDisable1R6 | GPIO Pull Disable 1: R6
Public property | GPIOPullDisable1R7 | GPIO Pull Disable 1: R7
Public property | GPIOPullDisable2C0 | GPIO Pull Disable 2: C0
Public property | GPIOPullDisable2C1 | GPIO Pull Disable 2: C1
Public property | GPIOPullDisable2C2 | GPIO Pull Disable 2: C2
Public property | GPIOPullDisable2C3 | GPIO Pull Disable 2: C3
Public property | GPIOPullDisable2C4 | GPIO Pull Disable 2: C4
Public property | GPIOPullDisable2C5 | GPIO Pull Disable 2: C5
Public property | GPIOPullDisable2C6 | GPIO Pull Disable 2: C6
Public property | GPIOPullDisable2C7 | GPIO Pull Disable 2: C7
Public property | GPIOPullDisable3C8 | GPIO Pull Disable 3: C8
Public property | GPIOPullDisable3C9 | GPIO Pull Disable 3: C9
Public property | InterruptStatusCMP1INT | Interrupt Status: CMP1_INT
Public property | InterruptStatusCMP2INT | Interrupt Status: CMP2_INT
Public property | InterruptStatusGPIINT | Interrupt Status: GPI_INT
Public property | InterruptStatusKEINT | Interrupt Status: KE_INT
Public property | InterruptStatusKLCKINT | Interrupt Status: K_LCK_INT
Public property | InterruptStatusOVRFLOWINT | Interrupt Status: OVR_FLOW_INT
Public property | KeyEventAKeyNumber | Key Event A: Key Number
Public property | KeyEventAStatus | Key Event A: Status
Public property | KeyEventBKeyNumber | Key Event B: Key Number
Public property | KeyEventBStatus | Key Event B: Status
Public property | KeyEventCKeyNumber | Key Event C: Key Number
Public property | KeyEventCStatus | Key Event C: Status
Public property | KeyEventDKeyNumber | Key Event D: Key Number
Public property | KeyEventDStatus | Key Event D: Status
Public property | KeyEventEKeyNumber | Key Event E: Key Number
Public property | KeyEventEStatus | Key Event E: Status
Public property | KeyEventFKeyNumber | Key Event F: Key Number
Public property | KeyEventFStatus | Key Event F: Status
Public property | KeyEventGKeyNumber | Key Event G: Key Number
Public property | KeyEventGStatus | Key Event G: Status
Public property | KeyEventHKeyNumber | Key Event H: Key Number
Public property | KeyEventHStatus | Key Event H: Status
Public property | KeyEventIKeyNumber | Key Event I: Key Number
Public property | KeyEventIStatus | Key Event I: Status
Public property | KeyEventJKeyNumber | Key Event J: Key Number
Public property | KeyEventJStatus | Key Event J: Status
Public property | KeylockEventCounterKEC | Keylock & Event Counter: KEC
Public property | KeylockEventCounterKLCKEN | Keylock & Event Counter: K_LCK_EN
Public property | KeylockEventCounterLCK2LCK1 | Keylock & Event Counter: LCK2, LCK1
Public property | KeypadLockInterruptMaskTimer | Keypad Lock Interrupt Mask Timer (unit: s)
Public property | KeypadOrGPIOSelection1R0 | Keypad or GPIO Selection 1: R0
Public property | KeypadOrGPIOSelection1R1 | Keypad or GPIO Selection 1: R1
Public property | KeypadOrGPIOSelection1R2 | Keypad or GPIO Selection 1: R2
Public property | KeypadOrGPIOSelection1R3 | Keypad or GPIO Selection 1: R3
Public property | KeypadOrGPIOSelection1R4 | Keypad or GPIO Selection 1: R4
Public property | KeypadOrGPIOSelection1R5 | Keypad or GPIO Selection 1: R5
Public property | KeypadOrGPIOSelection1R6 | Keypad or GPIO Selection 1: R6
Public property | KeypadOrGPIOSelection1R7 | Keypad or GPIO Selection 1: R7
Public property | KeypadOrGPIOSelection2C0 | Keypad or GPIO Selection 2: C0
Public property | KeypadOrGPIOSelection2C1 | Keypad or GPIO Selection 2: C1
Public property | KeypadOrGPIOSelection2C2 | Keypad or GPIO Selection 2: C2
Public property | KeypadOrGPIOSelection2C3 | Keypad or GPIO Selection 2: C3
Public property | KeypadOrGPIOSelection2C4 | Keypad or GPIO Selection 2: C4
Public property | KeypadOrGPIOSelection2C5 | Keypad or GPIO Selection 2: C5
Public property | KeypadOrGPIOSelection2C6 | Keypad or GPIO Selection 2: C6
Public property | KeypadOrGPIOSelection2C7 | Keypad or GPIO Selection 2: C7
Public property | KeypadOrGPIOSelection3C8 | Keypad or GPIO Selection 3: C8
Public property | KeypadOrGPIOSelection3C9 | Keypad or GPIO Selection 3: C9
Public property | KeypadUnlock1TimerToKeypadUnlock2Timer | Keypad Unlock 1 Timer to Keypad Unlock 2 Timer (unit: s)
Public property | Sensor1ComparatorConfigurationFILT | Sensor 1 Comparator Configuration: FILT
Public property | Sensor1ComparatorConfigurationFORCERD | Sensor 1 Comparator Configuration: FORCE_RD
Public property | Sensor1ComparatorConfigurationL2EN | Sensor 1 Comparator Configuration: L2_EN
Public property | Sensor1ComparatorConfigurationL3EN | Sensor 1 Comparator Configuration: L3_EN
Public property | Sensor1ComparatorLevel2Hysteresis | Sensor 1 Comparator Level 2 Hysteresis (unit: μA)
Public property | Sensor1ComparatorLevel2Reference | Sensor 1 Comparator Level 2 Reference (unit: μA)
Public property | Sensor1ComparatorLevel3Hysteresis | Sensor 1 Comparator Level 3 Hysteresis (unit: μA)
Public property | Sensor1ComparatorLevel3Reference | Sensor 1 Comparator Level 3 Reference (unit: μA)
Public property | Sensor2ComparatorConfigurationFILT | Sensor 2 Comparator Configuration: FILT
Public property | Sensor2ComparatorConfigurationFORCERD | Sensor 2 Comparator Configuration: FORCE_RD
Public property | Sensor2ComparatorConfigurationL2EN | Sensor 2 Comparator Configuration: L2_EN
Public property | Sensor2ComparatorConfigurationL3EN | Sensor 2 Comparator Configuration: L3_EN
Public property | Sensor2ComparatorLevel2Hysteresis | Sensor 2 Comparator Level 2 Hysteresis (unit: μA)
Public property | Sensor2ComparatorLevel2Reference | Sensor 2 Comparator Level 2 Reference (unit: μA)
Public property | Sensor2ComparatorLevel3Hysteresis | Sensor 2 Comparator Level 3 Hysteresis (unit: μA)
Public property | Sensor2ComparatorLevel3Reference | Sensor 2 Comparator Level 3 Reference (unit: μA)
Public property | UnlockKey1 | Unlock Key 1
Public property | UnlockKey2 | Unlock Key 2
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Mobile I/O Expander and QWERTY Keypad Controller
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adp5588(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adp5588

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588 Properties

The Adp5588 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Comparator1ADCData | Comparator 1 ADC Data
Public property | Comparator2ADCData | Comparator 2 ADC Data
Public property | ComparatorConfigurationStatusCMP1EN | Comparator Configuration & Status: CMP1_EN
Public property | ComparatorConfigurationStatusCMP1IEN | Comparator Configuration & Status: CMP1_IEN
Public property | ComparatorConfigurationStatusCMP1L2OUT | Comparator Configuration & Status: CMP1_L2_OUT
Public property | ComparatorConfigurationStatusCMP1L3OUT | Comparator Configuration & Status: CMP1_L3_OUT
Public property | ComparatorConfigurationStatusCMP2EN | Comparator Configuration & Status: CMP2_EN
Public property | ComparatorConfigurationStatusCMP2IEN | Comparator Configuration & Status: CMP2_IEN
Public property | ComparatorConfigurationStatusCMP2L2OUT | Comparator Configuration & Status: CMP2_L2_OUT
Public property | ComparatorConfigurationStatusCMP2L3OUT | Comparator Configuration & Status: CMP2_L3_OUT
Public property | ConfigurationAUTOINC | Configuration: AUTO_INC
Public property | ConfigurationGPIEMCFG | Configuration: GPIEM_CFG
Public property | ConfigurationGPIIEN | Configuration: GPI_IEN
Public property | ConfigurationINTCFG | Configuration: INT_CFG
Public property | ConfigurationKEIEN | Configuration: KE_IEN
Public property | ConfigurationKLCKIM | Configuration: K_LCK_IM
Public property | ConfigurationOVRFLOWIEN | Configuration: OVR_FLOW_IEN
Public property | ConfigurationOVRFLOWM | Configuration: OVR_FLOW_M
Public property | DebounceDisable1R0 | Debounce Disable 1: R0
Public property | DebounceDisable1R1 | Debounce Disable 1: R1
Public property | DebounceDisable1R2 | Debounce Disable 1: R2
Public property | DebounceDisable1R3 | Debounce Disable 1: R3
Public property | DebounceDisable1R4 | Debounce Disable 1: R4
Public property | DebounceDisable1R5 | Debounce Disable 1: R5
Public property | DebounceDisable1R6 | Debounce Disable 1: R6
Public property | DebounceDisable1R7 | Debounce Disable 1: R7
Public property | DebounceDisable2C0 | Debounce Disable 2: C0
Public property | DebounceDisable2C1 | Debounce Disable 2: C1
Public property | DebounceDisable2C2 | Debounce Disable 2: C2
Public property | DebounceDisable2C3 | Debounce Disable 2: C3
Public property | DebounceDisable2C4 | Debounce Disable 2: C4
Public property | DebounceDisable2C5 | Debounce Disable 2: C5
Public property | DebounceDisable2C6 | Debounce Disable 2: C6
Public property | DebounceDisable2C7 | Debounce Disable 2: C7
Public property | DebounceDisable3C8 | Debounce Disable 3: C8
Public property | DebounceDisable3C9 | Debounce Disable 3: C9
Public property | DeviceIDDeviceID | Device ID: Device ID
Public property | DeviceIDMFGID | Device ID: MFG ID
Public property | GPIEventMode1R0 | GPI Event Mode 1: R0
Public property | GPIEventMode1R1 | GPI Event Mode 1: R1
Public property | GPIEventMode1R2 | GPI Event Mode 1: R2
Public property | GPIEventMode1R3 | GPI Event Mode 1: R3
Public property | GPIEventMode1R4 | GPI Event Mode 1: R4
Public property | GPIEventMode1R5 | GPI Event Mode 1: R5
Public property | GPIEventMode1R6 | GPI Event Mode 1: R6
Public property | GPIEventMode1R7 | GPI Event Mode 1: R7
Public property | GPIEventMode2C0 | GPI Event Mode 2: C0
Public property | GPIEventMode2C1 | GPI Event Mode 2: C1
Public property | GPIEventMode2C2 | GPI Event Mode 2: C2
Public property | GPIEventMode2C3 | GPI Event Mode 2: C3
Public property | GPIEventMode2C4 | GPI Event Mode 2: C4
Public property | GPIEventMode2C5 | GPI Event Mode 2: C5
Public property | GPIEventMode2C6 | GPI Event Mode 2: C6
Public property | GPIEventMode2C7 | GPI Event Mode 2: C7
Public property | GPIEventMode3C8 | GPI Event Mode 3: C8
Public property | GPIEventMode3C9 | GPI Event Mode 3: C9
Public property | GPIODataDirection1R0 | GPIO Data Direction 1: R0
Public property | GPIODataDirection1R1 | GPIO Data Direction 1: R1
Public property | GPIODataDirection1R2 | GPIO Data Direction 1: R2
Public property | GPIODataDirection1R3 | GPIO Data Direction 1: R3
Public property | GPIODataDirection1R4 | GPIO Data Direction 1: R4
Public property | GPIODataDirection1R5 | GPIO Data Direction 1: R5
Public property | GPIODataDirection1R6 | GPIO Data Direction 1: R6
Public property | GPIODataDirection1R7 | GPIO Data Direction 1: R7
Public property | GPIODataDirection2C0 | GPIO Data Direction 2: C0
Public property | GPIODataDirection2C1 | GPIO Data Direction 2: C1
Public property | GPIODataDirection2C2 | GPIO Data Direction 2: C2
Public property | GPIODataDirection2C3 | GPIO Data Direction 2: C3
Public property | GPIODataDirection2C4 | GPIO Data Direction 2: C4
Public property | GPIODataDirection2C5 | GPIO Data Direction 2: C5
Public property | GPIODataDirection2C6 | GPIO Data Direction 2: C6
Public property | GPIODataDirection2C7 | GPIO Data Direction 2: C7
Public property | GPIODataDirection3C8 | GPIO Data Direction 3: C8
Public property | GPIODataDirection3C9 | GPIO Data Direction 3: C9
Public property | GPIODataOut1R0 | GPIO Data Out 1: R0
Public property | GPIODataOut1R1 | GPIO Data Out 1: R1
Public property | GPIODataOut1R2 | GPIO Data Out 1: R2
Public property | GPIODataOut1R3 | GPIO Data Out 1: R3
Public property | GPIODataOut1R4 | GPIO Data Out 1: R4
Public property | GPIODataOut1R5 | GPIO Data Out 1: R5
Public property | GPIODataOut1R6 | GPIO Data Out 1: R6
Public property | GPIODataOut1R7 | GPIO Data Out 1: R7
Public property | GPIODataOut2C0 | GPIO Data Out 2: C0
Public property | GPIODataOut2C1 | GPIO Data Out 2: C1
Public property | GPIODataOut2C2 | GPIO Data Out 2: C2
Public property | GPIODataOut2C3 | GPIO Data Out 2: C3
Public property | GPIODataOut2C4 | GPIO Data Out 2: C4
Public property | GPIODataOut2C5 | GPIO Data Out 2: C5
Public property | GPIODataOut2C6 | GPIO Data Out 2: C6
Public property | GPIODataOut2C7 | GPIO Data Out 2: C7
Public property | GPIODataOut3C8 | GPIO Data Out 3: C8
Public property | GPIODataOut3C9 | GPIO Data Out 3: C9
Public property | GPIODataStatus1R0 | GPIO Data Status 1: R0
Public property | GPIODataStatus1R1 | GPIO Data Status 1: R1
Public property | GPIODataStatus1R2 | GPIO Data Status 1: R2
Public property | GPIODataStatus1R3 | GPIO Data Status 1: R3
Public property | GPIODataStatus1R4 | GPIO Data Status 1: R4
Public property | GPIODataStatus1R5 | GPIO Data Status 1: R5
Public property | GPIODataStatus1R6 | GPIO Data Status 1: R6
Public property | GPIODataStatus1R7 | GPIO Data Status 1: R7
Public property | GPIODataStatus2C0 | GPIO Data Status 2: C0
Public property | GPIODataStatus2C1 | GPIO Data Status 2: C1
Public property | GPIODataStatus2C2 | GPIO Data Status 2: C2
Public property | GPIODataStatus2C3 | GPIO Data Status 2: C3
Public property | GPIODataStatus2C4 | GPIO Data Status 2: C4
Public property | GPIODataStatus2C5 | GPIO Data Status 2: C5
Public property | GPIODataStatus2C6 | GPIO Data Status 2: C6
Public property | GPIODataStatus2C7 | GPIO Data Status 2: C7
Public property | GPIODataStatus3C8 | GPIO Data Status 3: C8
Public property | GPIODataStatus3C9 | GPIO Data Status 3: C9
Public property | GPIOInterruptEnable1R0 | GPIO Interrupt Enable 1: R0
Public property | GPIOInterruptEnable1R1 | GPIO Interrupt Enable 1: R1
Public property | GPIOInterruptEnable1R2 | GPIO Interrupt Enable 1: R2
Public property | GPIOInterruptEnable1R3 | GPIO Interrupt Enable 1: R3
Public property | GPIOInterruptEnable1R4 | GPIO Interrupt Enable 1: R4
Public property | GPIOInterruptEnable1R5 | GPIO Interrupt Enable 1: R5
Public property | GPIOInterruptEnable1R6 | GPIO Interrupt Enable 1: R6
Public property | GPIOInterruptEnable1R7 | GPIO Interrupt Enable 1: R7
Public property | GPIOInterruptEnable2C0 | GPIO Interrupt Enable 2: C0
Public property | GPIOInterruptEnable2C1 | GPIO Interrupt Enable 2: C1
Public property | GPIOInterruptEnable2C2 | GPIO Interrupt Enable 2: C2
Public property | GPIOInterruptEnable2C3 | GPIO Interrupt Enable 2: C3
Public property | GPIOInterruptEnable2C4 | GPIO Interrupt Enable 2: C4
Public property | GPIOInterruptEnable2C5 | GPIO Interrupt Enable 2: C5
Public property | GPIOInterruptEnable2C6 | GPIO Interrupt Enable 2: C6
Public property | GPIOInterruptEnable2C7 | GPIO Interrupt Enable 2: C7
Public property | GPIOInterruptEnable3C8 | GPIO Interrupt Enable 3: C8
Public property | GPIOInterruptEnable3C9 | GPIO Interrupt Enable 3: C9
Public property | GPIOInterruptStatus1R0 | GPIO Interrupt Status 1: R0
Public property | GPIOInterruptStatus1R1 | GPIO Interrupt Status 1: R1
Public property | GPIOInterruptStatus1R2 | GPIO Interrupt Status 1: R2
Public property | GPIOInterruptStatus1R3 | GPIO Interrupt Status 1: R3
Public property | GPIOInterruptStatus1R4 | GPIO Interrupt Status 1: R4
Public property | GPIOInterruptStatus1R5 | GPIO Interrupt Status 1: R5
Public property | GPIOInterruptStatus1R6 | GPIO Interrupt Status 1: R6
Public property | GPIOInterruptStatus1R7 | GPIO Interrupt Status 1: R7
Public property | GPIOInterruptStatus2C0 | GPIO Interrupt Status 2: C0
Public property | GPIOInterruptStatus2C1 | GPIO Interrupt Status 2: C1
Public property | GPIOInterruptStatus2C2 | GPIO Interrupt Status 2: C2
Public property | GPIOInterruptStatus2C3 | GPIO Interrupt Status 2: C3
Public property | GPIOInterruptStatus2C4 | GPIO Interrupt Status 2: C4
Public property | GPIOInterruptStatus2C5 | GPIO Interrupt Status 2: C5
Public property | GPIOInterruptStatus2C6 | GPIO Interrupt Status 2: C6
Public property | GPIOInterruptStatus2C7 | GPIO Interrupt Status 2: C7
Public property | GPIOInterruptStatus3C8 | GPIO Interrupt Status 3: C8
Public property | GPIOInterruptStatus3C9 | GPIO Interrupt Status 3: C9
Public property | GPIOLevelDetect1R0 | GPIO Level Detect 1: R0
Public property | GPIOLevelDetect1R1 | GPIO Level Detect 1: R1
Public property | GPIOLevelDetect1R2 | GPIO Level Detect 1: R2
Public property | GPIOLevelDetect1R3 | GPIO Level Detect 1: R3
Public property | GPIOLevelDetect1R4 | GPIO Level Detect 1: R4
Public property | GPIOLevelDetect1R5 | GPIO Level Detect 1: R5
Public property | GPIOLevelDetect1R6 | GPIO Level Detect 1: R6
Public property | GPIOLevelDetect1R7 | GPIO Level Detect 1: R7
Public property | GPIOLevelDetect2C0 | GPIO Level Detect 2: C0
Public property | GPIOLevelDetect2C1 | GPIO Level Detect 2: C1
Public property | GPIOLevelDetect2C2 | GPIO Level Detect 2: C2
Public property | GPIOLevelDetect2C3 | GPIO Level Detect 2: C3
Public property | GPIOLevelDetect2C4 | GPIO Level Detect 2: C4
Public property | GPIOLevelDetect2C5 | GPIO Level Detect 2: C5
Public property | GPIOLevelDetect2C6 | GPIO Level Detect 2: C6
Public property | GPIOLevelDetect2C7 | GPIO Level Detect 2: C7
Public property | GPIOLevelDetect3C8 | GPIO Level Detect 3: C8
Public property | GPIOLevelDetect3C9 | GPIO Level Detect 3: C9
Public property | GPIOPullDisable1R0 | GPIO Pull Disable 1: R0
Public property | GPIOPullDisable1R1 | GPIO Pull Disable 1: R1
Public property | GPIOPullDisable1R2 | GPIO Pull Disable 1: R2
Public property | GPIOPullDisable1R3 | GPIO Pull Disable 1: R3
Public property | GPIOPullDisable1R4 | GPIO Pull Disable 1: R4
Public property | GPIOPullDisable1R5 | GPIO Pull Disable 1: R5
Public property | GPIOPullDisable1R6 | GPIO Pull Disable 1: R6
Public property | GPIOPullDisable1R7 | GPIO Pull Disable 1: R7
Public property | GPIOPullDisable2C0 | GPIO Pull Disable 2: C0
Public property | GPIOPullDisable2C1 | GPIO Pull Disable 2: C1
Public property | GPIOPullDisable2C2 | GPIO Pull Disable 2: C2
Public property | GPIOPullDisable2C3 | GPIO Pull Disable 2: C3
Public property | GPIOPullDisable2C4 | GPIO Pull Disable 2: C4
Public property | GPIOPullDisable2C5 | GPIO Pull Disable 2: C5
Public property | GPIOPullDisable2C6 | GPIO Pull Disable 2: C6
Public property | GPIOPullDisable2C7 | GPIO Pull Disable 2: C7
Public property | GPIOPullDisable3C8 | GPIO Pull Disable 3: C8
Public property | GPIOPullDisable3C9 | GPIO Pull Disable 3: C9
Public property | InterruptStatusCMP1INT | Interrupt Status: CMP1_INT
Public property | InterruptStatusCMP2INT | Interrupt Status: CMP2_INT
Public property | InterruptStatusGPIINT | Interrupt Status: GPI_INT
Public property | InterruptStatusKEINT | Interrupt Status: KE_INT
Public property | InterruptStatusKLCKINT | Interrupt Status: K_LCK_INT
Public property | InterruptStatusOVRFLOWINT | Interrupt Status: OVR_FLOW_INT
Public property | KeyEventAKeyNumber | Key Event A: Key Number
Public property | KeyEventAStatus | Key Event A: Status
Public property | KeyEventBKeyNumber | Key Event B: Key Number
Public property | KeyEventBStatus | Key Event B: Status
Public property | KeyEventCKeyNumber | Key Event C: Key Number
Public property | KeyEventCStatus | Key Event C: Status
Public property | KeyEventDKeyNumber | Key Event D: Key Number
Public property | KeyEventDStatus | Key Event D: Status
Public property | KeyEventEKeyNumber | Key Event E: Key Number
Public property | KeyEventEStatus | Key Event E: Status
Public property | KeyEventFKeyNumber | Key Event F: Key Number
Public property | KeyEventFStatus | Key Event F: Status
Public property | KeyEventGKeyNumber | Key Event G: Key Number
Public property | KeyEventGStatus | Key Event G: Status
Public property | KeyEventHKeyNumber | Key Event H: Key Number
Public property | KeyEventHStatus | Key Event H: Status
Public property | KeyEventIKeyNumber | Key Event I: Key Number
Public property | KeyEventIStatus | Key Event I: Status
Public property | KeyEventJKeyNumber | Key Event J: Key Number
Public property | KeyEventJStatus | Key Event J: Status
Public property | KeylockEventCounterKEC | Keylock & Event Counter: KEC
Public property | KeylockEventCounterKLCKEN | Keylock & Event Counter: K_LCK_EN
Public property | KeylockEventCounterLCK2LCK1 | Keylock & Event Counter: LCK2, LCK1
Public property | KeypadLockInterruptMaskTimer | Keypad Lock Interrupt Mask Timer (unit: s)
Public property | KeypadOrGPIOSelection1R0 | Keypad or GPIO Selection 1: R0
Public property | KeypadOrGPIOSelection1R1 | Keypad or GPIO Selection 1: R1
Public property | KeypadOrGPIOSelection1R2 | Keypad or GPIO Selection 1: R2
Public property | KeypadOrGPIOSelection1R3 | Keypad or GPIO Selection 1: R3
Public property | KeypadOrGPIOSelection1R4 | Keypad or GPIO Selection 1: R4
Public property | KeypadOrGPIOSelection1R5 | Keypad or GPIO Selection 1: R5
Public property | KeypadOrGPIOSelection1R6 | Keypad or GPIO Selection 1: R6
Public property | KeypadOrGPIOSelection1R7 | Keypad or GPIO Selection 1: R7
Public property | KeypadOrGPIOSelection2C0 | Keypad or GPIO Selection 2: C0
Public property | KeypadOrGPIOSelection2C1 | Keypad or GPIO Selection 2: C1
Public property | KeypadOrGPIOSelection2C2 | Keypad or GPIO Selection 2: C2
Public property | KeypadOrGPIOSelection2C3 | Keypad or GPIO Selection 2: C3
Public property | KeypadOrGPIOSelection2C4 | Keypad or GPIO Selection 2: C4
Public property | KeypadOrGPIOSelection2C5 | Keypad or GPIO Selection 2: C5
Public property | KeypadOrGPIOSelection2C6 | Keypad or GPIO Selection 2: C6
Public property | KeypadOrGPIOSelection2C7 | Keypad or GPIO Selection 2: C7
Public property | KeypadOrGPIOSelection3C8 | Keypad or GPIO Selection 3: C8
Public property | KeypadOrGPIOSelection3C9 | Keypad or GPIO Selection 3: C9
Public property | KeypadUnlock1TimerToKeypadUnlock2Timer | Keypad Unlock 1 Timer to Keypad Unlock 2 Timer (unit: s)
Public property | Sensor1ComparatorConfigurationFILT | Sensor 1 Comparator Configuration: FILT
Public property | Sensor1ComparatorConfigurationFORCERD | Sensor 1 Comparator Configuration: FORCE_RD
Public property | Sensor1ComparatorConfigurationL2EN | Sensor 1 Comparator Configuration: L2_EN
Public property | Sensor1ComparatorConfigurationL3EN | Sensor 1 Comparator Configuration: L3_EN
Public property | Sensor1ComparatorLevel2Hysteresis | Sensor 1 Comparator Level 2 Hysteresis (unit: μA)
Public property | Sensor1ComparatorLevel2Reference | Sensor 1 Comparator Level 2 Reference (unit: μA)
Public property | Sensor1ComparatorLevel3Hysteresis | Sensor 1 Comparator Level 3 Hysteresis (unit: μA)
Public property | Sensor1ComparatorLevel3Reference | Sensor 1 Comparator Level 3 Reference (unit: μA)
Public property | Sensor2ComparatorConfigurationFILT | Sensor 2 Comparator Configuration: FILT
Public property | Sensor2ComparatorConfigurationFORCERD | Sensor 2 Comparator Configuration: FORCE_RD
Public property | Sensor2ComparatorConfigurationL2EN | Sensor 2 Comparator Configuration: L2_EN
Public property | Sensor2ComparatorConfigurationL3EN | Sensor 2 Comparator Configuration: L3_EN
Public property | Sensor2ComparatorLevel2Hysteresis | Sensor 2 Comparator Level 2 Hysteresis (unit: μA)
Public property | Sensor2ComparatorLevel2Reference | Sensor 2 Comparator Level 2 Reference (unit: μA)
Public property | Sensor2ComparatorLevel3Hysteresis | Sensor 2 Comparator Level 3 Hysteresis (unit: μA)
Public property | Sensor2ComparatorLevel3Reference | Sensor 2 Comparator Level 3 Reference (unit: μA)
Public property | UnlockKey1 | Unlock Key 1
Public property | UnlockKey2 | Unlock Key 2
Top
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.AutoFlush Property

IRD

Adp5588AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Comparator1ADCData Property

IRD

Adp5588Comparator1ADCData Property

Comparator 1 ADC Data

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort Comparator1ADCData { get; }
Public ReadOnly Property Comparator1ADCData As UShort
    Get
public:
property unsigned short Comparator1ADCData {
    unsigned short get ();
}
member Comparator1ADCData : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Comparator2ADCData Property

IRD

Adp5588Comparator2ADCData Property

Comparator 2 ADC Data

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort Comparator2ADCData { get; }
Public ReadOnly Property Comparator2ADCData As UShort
    Get
public:
property unsigned short Comparator2ADCData {
    unsigned short get ();
}
member Comparator2ADCData : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.ComparatorConfigurationStatusCMP1EN Property

IRD

Adp5588ComparatorConfigurationStatusCMP1EN Property

Comparator Configuration & Status: CMP1_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCmpCfgStatCmpEn ComparatorConfigurationStatusCMP1EN { get; set; }
Public Property ComparatorConfigurationStatusCMP1EN As Adp5588TypeCmpCfgStatCmpEn
    Get
    Set
public:
property Adp5588TypeCmpCfgStatCmpEn ComparatorConfigurationStatusCMP1EN {
    Adp5588TypeCmpCfgStatCmpEn get ();
    void set (Adp5588TypeCmpCfgStatCmpEn value);
}
member ComparatorConfigurationStatusCMP1EN : Adp5588TypeCmpCfgStatCmpEn with get, set

Property Value

Type: Adp5588TypeCmpCfgStatCmpEn
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.ComparatorConfigurationStatusCMP1IEN Property

IRD

Adp5588ComparatorConfigurationStatusCMP1IEN Property

Comparator Configuration & Status: CMP1_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCmpCfgStatCmpIen ComparatorConfigurationStatusCMP1IEN { get; set; }
Public Property ComparatorConfigurationStatusCMP1IEN As Adp5588TypeCmpCfgStatCmpIen
    Get
    Set
public:
property Adp5588TypeCmpCfgStatCmpIen ComparatorConfigurationStatusCMP1IEN {
    Adp5588TypeCmpCfgStatCmpIen get ();
    void set (Adp5588TypeCmpCfgStatCmpIen value);
}
member ComparatorConfigurationStatusCMP1IEN : Adp5588TypeCmpCfgStatCmpIen with get, set

Property Value

Type: Adp5588TypeCmpCfgStatCmpIen
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.ComparatorConfigurationStatusCMP1L2OUT Property

IRD

Adp5588ComparatorConfigurationStatusCMP1L2OUT Property

Comparator Configuration & Status: CMP1_L2_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCmpCfgStatCmp1L2Out ComparatorConfigurationStatusCMP1L2OUT { get; set; }
Public Property ComparatorConfigurationStatusCMP1L2OUT As Adp5588TypeCmpCfgStatCmp1L2Out
    Get
    Set
public:
property Adp5588TypeCmpCfgStatCmp1L2Out ComparatorConfigurationStatusCMP1L2OUT {
    Adp5588TypeCmpCfgStatCmp1L2Out get ();
    void set (Adp5588TypeCmpCfgStatCmp1L2Out value);
}
member ComparatorConfigurationStatusCMP1L2OUT : Adp5588TypeCmpCfgStatCmp1L2Out with get, set

Property Value

Type: Adp5588TypeCmpCfgStatCmp1L2Out
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.ComparatorConfigurationStatusCMP1L3OUT Property

IRD

Adp5588ComparatorConfigurationStatusCMP1L3OUT Property

Comparator Configuration & Status: CMP1_L3_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCmpCfgStatCmp1L3Out ComparatorConfigurationStatusCMP1L3OUT { get; set; }
Public Property ComparatorConfigurationStatusCMP1L3OUT As Adp5588TypeCmpCfgStatCmp1L3Out
    Get
    Set
public:
property Adp5588TypeCmpCfgStatCmp1L3Out ComparatorConfigurationStatusCMP1L3OUT {
    Adp5588TypeCmpCfgStatCmp1L3Out get ();
    void set (Adp5588TypeCmpCfgStatCmp1L3Out value);
}
member ComparatorConfigurationStatusCMP1L3OUT : Adp5588TypeCmpCfgStatCmp1L3Out with get, set

Property Value

Type: Adp5588TypeCmpCfgStatCmp1L3Out
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.ComparatorConfigurationStatusCMP2EN Property

IRD

Adp5588ComparatorConfigurationStatusCMP2EN Property

Comparator Configuration & Status: CMP2_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCmpCfgStatCmpEn ComparatorConfigurationStatusCMP2EN { get; set; }
Public Property ComparatorConfigurationStatusCMP2EN As Adp5588TypeCmpCfgStatCmpEn
    Get
    Set
public:
property Adp5588TypeCmpCfgStatCmpEn ComparatorConfigurationStatusCMP2EN {
    Adp5588TypeCmpCfgStatCmpEn get ();
    void set (Adp5588TypeCmpCfgStatCmpEn value);
}
member ComparatorConfigurationStatusCMP2EN : Adp5588TypeCmpCfgStatCmpEn with get, set

Property Value

Type: Adp5588TypeCmpCfgStatCmpEn
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.ComparatorConfigurationStatusCMP2IEN Property

IRD

Adp5588ComparatorConfigurationStatusCMP2IEN Property

Comparator Configuration & Status: CMP2_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCmpCfgStatCmpIen ComparatorConfigurationStatusCMP2IEN { get; set; }
Public Property ComparatorConfigurationStatusCMP2IEN As Adp5588TypeCmpCfgStatCmpIen
    Get
    Set
public:
property Adp5588TypeCmpCfgStatCmpIen ComparatorConfigurationStatusCMP2IEN {
    Adp5588TypeCmpCfgStatCmpIen get ();
    void set (Adp5588TypeCmpCfgStatCmpIen value);
}
member ComparatorConfigurationStatusCMP2IEN : Adp5588TypeCmpCfgStatCmpIen with get, set

Property Value

Type: Adp5588TypeCmpCfgStatCmpIen
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.ComparatorConfigurationStatusCMP2L2OUT Property

IRD

Adp5588ComparatorConfigurationStatusCMP2L2OUT Property

Comparator Configuration & Status: CMP2_L2_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCmpCfgStatCmp2L2Out ComparatorConfigurationStatusCMP2L2OUT { get; set; }
Public Property ComparatorConfigurationStatusCMP2L2OUT As Adp5588TypeCmpCfgStatCmp2L2Out
    Get
    Set
public:
property Adp5588TypeCmpCfgStatCmp2L2Out ComparatorConfigurationStatusCMP2L2OUT {
    Adp5588TypeCmpCfgStatCmp2L2Out get ();
    void set (Adp5588TypeCmpCfgStatCmp2L2Out value);
}
member ComparatorConfigurationStatusCMP2L2OUT : Adp5588TypeCmpCfgStatCmp2L2Out with get, set

Property Value

Type: Adp5588TypeCmpCfgStatCmp2L2Out
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.ComparatorConfigurationStatusCMP2L3OUT Property

IRD

Adp5588ComparatorConfigurationStatusCMP2L3OUT Property

Comparator Configuration & Status: CMP2_L3_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCmpCfgStatCmp2L3Out ComparatorConfigurationStatusCMP2L3OUT { get; set; }
Public Property ComparatorConfigurationStatusCMP2L3OUT As Adp5588TypeCmpCfgStatCmp2L3Out
    Get
    Set
public:
property Adp5588TypeCmpCfgStatCmp2L3Out ComparatorConfigurationStatusCMP2L3OUT {
    Adp5588TypeCmpCfgStatCmp2L3Out get ();
    void set (Adp5588TypeCmpCfgStatCmp2L3Out value);
}
member ComparatorConfigurationStatusCMP2L3OUT : Adp5588TypeCmpCfgStatCmp2L3Out with get, set

Property Value

Type: Adp5588TypeCmpCfgStatCmp2L3Out
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.ConfigurationAUTOINC Property

IRD

Adp5588ConfigurationAUTOINC Property

Configuration: AUTO_INC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCfgAutoInc ConfigurationAUTOINC { get; set; }
Public Property ConfigurationAUTOINC As Adp5588TypeCfgAutoInc
    Get
    Set
public:
property Adp5588TypeCfgAutoInc ConfigurationAUTOINC {
    Adp5588TypeCfgAutoInc get ();
    void set (Adp5588TypeCfgAutoInc value);
}
member ConfigurationAUTOINC : Adp5588TypeCfgAutoInc with get, set

Property Value

Type: Adp5588TypeCfgAutoInc
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.ConfigurationGPIEMCFG Property

IRD

Adp5588ConfigurationGPIEMCFG Property

Configuration: GPIEM_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCfgGpiemCfg ConfigurationGPIEMCFG { get; set; }
Public Property ConfigurationGPIEMCFG As Adp5588TypeCfgGpiemCfg
    Get
    Set
public:
property Adp5588TypeCfgGpiemCfg ConfigurationGPIEMCFG {
    Adp5588TypeCfgGpiemCfg get ();
    void set (Adp5588TypeCfgGpiemCfg value);
}
member ConfigurationGPIEMCFG : Adp5588TypeCfgGpiemCfg with get, set

Property Value

Type: Adp5588TypeCfgGpiemCfg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.ConfigurationGPIIEN Property

IRD

Adp5588ConfigurationGPIIEN Property

Configuration: GPI_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCfgGpiIen ConfigurationGPIIEN { get; set; }
Public Property ConfigurationGPIIEN As Adp5588TypeCfgGpiIen
    Get
    Set
public:
property Adp5588TypeCfgGpiIen ConfigurationGPIIEN {
    Adp5588TypeCfgGpiIen get ();
    void set (Adp5588TypeCfgGpiIen value);
}
member ConfigurationGPIIEN : Adp5588TypeCfgGpiIen with get, set

Property Value

Type: Adp5588TypeCfgGpiIen
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.ConfigurationINTCFG Property

IRD

Adp5588ConfigurationINTCFG Property

Configuration: INT_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCfgIntCfg ConfigurationINTCFG { get; set; }
Public Property ConfigurationINTCFG As Adp5588TypeCfgIntCfg
    Get
    Set
public:
property Adp5588TypeCfgIntCfg ConfigurationINTCFG {
    Adp5588TypeCfgIntCfg get ();
    void set (Adp5588TypeCfgIntCfg value);
}
member ConfigurationINTCFG : Adp5588TypeCfgIntCfg with get, set

Property Value

Type: Adp5588TypeCfgIntCfg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.ConfigurationKEIEN Property

IRD

Adp5588ConfigurationKEIEN Property

Configuration: KE_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCfgKeIen ConfigurationKEIEN { get; set; }
Public Property ConfigurationKEIEN As Adp5588TypeCfgKeIen
    Get
    Set
public:
property Adp5588TypeCfgKeIen ConfigurationKEIEN {
    Adp5588TypeCfgKeIen get ();
    void set (Adp5588TypeCfgKeIen value);
}
member ConfigurationKEIEN : Adp5588TypeCfgKeIen with get, set

Property Value

Type: Adp5588TypeCfgKeIen
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.ConfigurationKLCKIM Property

IRD

Adp5588ConfigurationKLCKIM Property

Configuration: K_LCK_IM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCfgKLckM ConfigurationKLCKIM { get; set; }
Public Property ConfigurationKLCKIM As Adp5588TypeCfgKLckM
    Get
    Set
public:
property Adp5588TypeCfgKLckM ConfigurationKLCKIM {
    Adp5588TypeCfgKLckM get ();
    void set (Adp5588TypeCfgKLckM value);
}
member ConfigurationKLCKIM : Adp5588TypeCfgKLckM with get, set

Property Value

Type: Adp5588TypeCfgKLckM
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.ConfigurationOVRFLOWIEN Property

IRD

Adp5588ConfigurationOVRFLOWIEN Property

Configuration: OVR_FLOW_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCfgOvrFlowIen ConfigurationOVRFLOWIEN { get; set; }
Public Property ConfigurationOVRFLOWIEN As Adp5588TypeCfgOvrFlowIen
    Get
    Set
public:
property Adp5588TypeCfgOvrFlowIen ConfigurationOVRFLOWIEN {
    Adp5588TypeCfgOvrFlowIen get ();
    void set (Adp5588TypeCfgOvrFlowIen value);
}
member ConfigurationOVRFLOWIEN : Adp5588TypeCfgOvrFlowIen with get, set

Property Value

Type: Adp5588TypeCfgOvrFlowIen
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.ConfigurationOVRFLOWM Property

IRD

Adp5588ConfigurationOVRFLOWM Property

Configuration: OVR_FLOW_M

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCfgOvrFlowM ConfigurationOVRFLOWM { get; set; }
Public Property ConfigurationOVRFLOWM As Adp5588TypeCfgOvrFlowM
    Get
    Set
public:
property Adp5588TypeCfgOvrFlowM ConfigurationOVRFLOWM {
    Adp5588TypeCfgOvrFlowM get ();
    void set (Adp5588TypeCfgOvrFlowM value);
}
member ConfigurationOVRFLOWM : Adp5588TypeCfgOvrFlowM with get, set

Property Value

Type: Adp5588TypeCfgOvrFlowM
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DebounceDisable1R0 Property

IRD

Adp5588DebounceDisable1R0 Property

Debounce Disable 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable1R0 { get; set; }
Public Property DebounceDisable1R0 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable1R0 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable1R0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DebounceDisable1R1 Property

IRD

Adp5588DebounceDisable1R1 Property

Debounce Disable 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable1R1 { get; set; }
Public Property DebounceDisable1R1 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable1R1 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable1R1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DebounceDisable1R2 Property

IRD

Adp5588DebounceDisable1R2 Property

Debounce Disable 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable1R2 { get; set; }
Public Property DebounceDisable1R2 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable1R2 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable1R2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DebounceDisable1R3 Property

IRD

Adp5588DebounceDisable1R3 Property

Debounce Disable 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable1R3 { get; set; }
Public Property DebounceDisable1R3 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable1R3 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable1R3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DebounceDisable1R4 Property

IRD

Adp5588DebounceDisable1R4 Property

Debounce Disable 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable1R4 { get; set; }
Public Property DebounceDisable1R4 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable1R4 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable1R4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DebounceDisable1R5 Property

IRD

Adp5588DebounceDisable1R5 Property

Debounce Disable 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable1R5 { get; set; }
Public Property DebounceDisable1R5 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable1R5 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable1R5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DebounceDisable1R6 Property

IRD

Adp5588DebounceDisable1R6 Property

Debounce Disable 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable1R6 { get; set; }
Public Property DebounceDisable1R6 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable1R6 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable1R6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DebounceDisable1R7 Property

IRD

Adp5588DebounceDisable1R7 Property

Debounce Disable 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable1R7 { get; set; }
Public Property DebounceDisable1R7 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable1R7 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable1R7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DebounceDisable2C0 Property

IRD

Adp5588DebounceDisable2C0 Property

Debounce Disable 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable2C0 { get; set; }
Public Property DebounceDisable2C0 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable2C0 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable2C0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DebounceDisable2C1 Property

IRD

Adp5588DebounceDisable2C1 Property

Debounce Disable 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable2C1 { get; set; }
Public Property DebounceDisable2C1 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable2C1 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable2C1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DebounceDisable2C2 Property

IRD

Adp5588DebounceDisable2C2 Property

Debounce Disable 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable2C2 { get; set; }
Public Property DebounceDisable2C2 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable2C2 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable2C2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DebounceDisable2C3 Property

IRD

Adp5588DebounceDisable2C3 Property

Debounce Disable 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable2C3 { get; set; }
Public Property DebounceDisable2C3 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable2C3 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable2C3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DebounceDisable2C4 Property

IRD

Adp5588DebounceDisable2C4 Property

Debounce Disable 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable2C4 { get; set; }
Public Property DebounceDisable2C4 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable2C4 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable2C4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DebounceDisable2C5 Property

IRD

Adp5588DebounceDisable2C5 Property

Debounce Disable 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable2C5 { get; set; }
Public Property DebounceDisable2C5 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable2C5 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable2C5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DebounceDisable2C6 Property

IRD

Adp5588DebounceDisable2C6 Property

Debounce Disable 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable2C6 { get; set; }
Public Property DebounceDisable2C6 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable2C6 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable2C6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DebounceDisable2C7 Property

IRD

Adp5588DebounceDisable2C7 Property

Debounce Disable 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable2C7 { get; set; }
Public Property DebounceDisable2C7 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable2C7 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable2C7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DebounceDisable3C8 Property

IRD

Adp5588DebounceDisable3C8 Property

Debounce Disable 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable3C8 { get; set; }
Public Property DebounceDisable3C8 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable3C8 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable3C8 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DebounceDisable3C9 Property

IRD

Adp5588DebounceDisable3C9 Property

Debounce Disable 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DebounceDisable3C9 { get; set; }
Public Property DebounceDisable3C9 As Byte
    Get
    Set
public:
property unsigned char DebounceDisable3C9 {
    unsigned char get ();
    void set (unsigned char value);
}
member DebounceDisable3C9 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DeviceIDDeviceID Property

IRD

Adp5588DeviceIDDeviceID Property

Device ID: Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceIDDeviceID { get; set; }
Public Property DeviceIDDeviceID As Byte
    Get
    Set
public:
property unsigned char DeviceIDDeviceID {
    unsigned char get ();
    void set (unsigned char value);
}
member DeviceIDDeviceID : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.DeviceIDMFGID Property

IRD

Adp5588DeviceIDMFGID Property

Device ID: MFG ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceIDMFGID { get; set; }
Public Property DeviceIDMFGID As Byte
    Get
    Set
public:
property unsigned char DeviceIDMFGID {
    unsigned char get ();
    void set (unsigned char value);
}
member DeviceIDMFGID : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIEventMode1R0 Property

IRD

Adp5588GPIEventMode1R0 Property

GPI Event Mode 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpiEmReg GPIEventMode1R0 { get; set; }
Public Property GPIEventMode1R0 As Adp5588TypeGpiEmReg
    Get
    Set
public:
property Adp5588TypeGpiEmReg GPIEventMode1R0 {
    Adp5588TypeGpiEmReg get ();
    void set (Adp5588TypeGpiEmReg value);
}
member GPIEventMode1R0 : Adp5588TypeGpiEmReg with get, set

Property Value

Type: Adp5588TypeGpiEmReg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIEventMode1R1 Property

IRD

Adp5588GPIEventMode1R1 Property

GPI Event Mode 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpiEmReg GPIEventMode1R1 { get; set; }
Public Property GPIEventMode1R1 As Adp5588TypeGpiEmReg
    Get
    Set
public:
property Adp5588TypeGpiEmReg GPIEventMode1R1 {
    Adp5588TypeGpiEmReg get ();
    void set (Adp5588TypeGpiEmReg value);
}
member GPIEventMode1R1 : Adp5588TypeGpiEmReg with get, set

Property Value

Type: Adp5588TypeGpiEmReg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIEventMode1R2 Property

IRD

Adp5588GPIEventMode1R2 Property

GPI Event Mode 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpiEmReg GPIEventMode1R2 { get; set; }
Public Property GPIEventMode1R2 As Adp5588TypeGpiEmReg
    Get
    Set
public:
property Adp5588TypeGpiEmReg GPIEventMode1R2 {
    Adp5588TypeGpiEmReg get ();
    void set (Adp5588TypeGpiEmReg value);
}
member GPIEventMode1R2 : Adp5588TypeGpiEmReg with get, set

Property Value

Type: Adp5588TypeGpiEmReg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIEventMode1R3 Property

IRD

Adp5588GPIEventMode1R3 Property

GPI Event Mode 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpiEmReg GPIEventMode1R3 { get; set; }
Public Property GPIEventMode1R3 As Adp5588TypeGpiEmReg
    Get
    Set
public:
property Adp5588TypeGpiEmReg GPIEventMode1R3 {
    Adp5588TypeGpiEmReg get ();
    void set (Adp5588TypeGpiEmReg value);
}
member GPIEventMode1R3 : Adp5588TypeGpiEmReg with get, set

Property Value

Type: Adp5588TypeGpiEmReg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIEventMode1R4 Property

IRD

Adp5588GPIEventMode1R4 Property

GPI Event Mode 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpiEmReg GPIEventMode1R4 { get; set; }
Public Property GPIEventMode1R4 As Adp5588TypeGpiEmReg
    Get
    Set
public:
property Adp5588TypeGpiEmReg GPIEventMode1R4 {
    Adp5588TypeGpiEmReg get ();
    void set (Adp5588TypeGpiEmReg value);
}
member GPIEventMode1R4 : Adp5588TypeGpiEmReg with get, set

Property Value

Type: Adp5588TypeGpiEmReg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIEventMode1R5 Property

IRD

Adp5588GPIEventMode1R5 Property

GPI Event Mode 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpiEmReg GPIEventMode1R5 { get; set; }
Public Property GPIEventMode1R5 As Adp5588TypeGpiEmReg
    Get
    Set
public:
property Adp5588TypeGpiEmReg GPIEventMode1R5 {
    Adp5588TypeGpiEmReg get ();
    void set (Adp5588TypeGpiEmReg value);
}
member GPIEventMode1R5 : Adp5588TypeGpiEmReg with get, set

Property Value

Type: Adp5588TypeGpiEmReg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIEventMode1R6 Property

IRD

Adp5588GPIEventMode1R6 Property

GPI Event Mode 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpiEmReg GPIEventMode1R6 { get; set; }
Public Property GPIEventMode1R6 As Adp5588TypeGpiEmReg
    Get
    Set
public:
property Adp5588TypeGpiEmReg GPIEventMode1R6 {
    Adp5588TypeGpiEmReg get ();
    void set (Adp5588TypeGpiEmReg value);
}
member GPIEventMode1R6 : Adp5588TypeGpiEmReg with get, set

Property Value

Type: Adp5588TypeGpiEmReg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIEventMode1R7 Property

IRD

Adp5588GPIEventMode1R7 Property

GPI Event Mode 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpiEmReg GPIEventMode1R7 { get; set; }
Public Property GPIEventMode1R7 As Adp5588TypeGpiEmReg
    Get
    Set
public:
property Adp5588TypeGpiEmReg GPIEventMode1R7 {
    Adp5588TypeGpiEmReg get ();
    void set (Adp5588TypeGpiEmReg value);
}
member GPIEventMode1R7 : Adp5588TypeGpiEmReg with get, set

Property Value

Type: Adp5588TypeGpiEmReg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIEventMode2C0 Property

IRD

Adp5588GPIEventMode2C0 Property

GPI Event Mode 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpiEmReg GPIEventMode2C0 { get; set; }
Public Property GPIEventMode2C0 As Adp5588TypeGpiEmReg
    Get
    Set
public:
property Adp5588TypeGpiEmReg GPIEventMode2C0 {
    Adp5588TypeGpiEmReg get ();
    void set (Adp5588TypeGpiEmReg value);
}
member GPIEventMode2C0 : Adp5588TypeGpiEmReg with get, set

Property Value

Type: Adp5588TypeGpiEmReg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIEventMode2C1 Property

IRD

Adp5588GPIEventMode2C1 Property

GPI Event Mode 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpiEmReg GPIEventMode2C1 { get; set; }
Public Property GPIEventMode2C1 As Adp5588TypeGpiEmReg
    Get
    Set
public:
property Adp5588TypeGpiEmReg GPIEventMode2C1 {
    Adp5588TypeGpiEmReg get ();
    void set (Adp5588TypeGpiEmReg value);
}
member GPIEventMode2C1 : Adp5588TypeGpiEmReg with get, set

Property Value

Type: Adp5588TypeGpiEmReg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIEventMode2C2 Property

IRD

Adp5588GPIEventMode2C2 Property

GPI Event Mode 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpiEmReg GPIEventMode2C2 { get; set; }
Public Property GPIEventMode2C2 As Adp5588TypeGpiEmReg
    Get
    Set
public:
property Adp5588TypeGpiEmReg GPIEventMode2C2 {
    Adp5588TypeGpiEmReg get ();
    void set (Adp5588TypeGpiEmReg value);
}
member GPIEventMode2C2 : Adp5588TypeGpiEmReg with get, set

Property Value

Type: Adp5588TypeGpiEmReg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIEventMode2C3 Property

IRD

Adp5588GPIEventMode2C3 Property

GPI Event Mode 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpiEmReg GPIEventMode2C3 { get; set; }
Public Property GPIEventMode2C3 As Adp5588TypeGpiEmReg
    Get
    Set
public:
property Adp5588TypeGpiEmReg GPIEventMode2C3 {
    Adp5588TypeGpiEmReg get ();
    void set (Adp5588TypeGpiEmReg value);
}
member GPIEventMode2C3 : Adp5588TypeGpiEmReg with get, set

Property Value

Type: Adp5588TypeGpiEmReg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIEventMode2C4 Property

IRD

Adp5588GPIEventMode2C4 Property

GPI Event Mode 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpiEmReg GPIEventMode2C4 { get; set; }
Public Property GPIEventMode2C4 As Adp5588TypeGpiEmReg
    Get
    Set
public:
property Adp5588TypeGpiEmReg GPIEventMode2C4 {
    Adp5588TypeGpiEmReg get ();
    void set (Adp5588TypeGpiEmReg value);
}
member GPIEventMode2C4 : Adp5588TypeGpiEmReg with get, set

Property Value

Type: Adp5588TypeGpiEmReg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIEventMode2C5 Property

IRD

Adp5588GPIEventMode2C5 Property

GPI Event Mode 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpiEmReg GPIEventMode2C5 { get; set; }
Public Property GPIEventMode2C5 As Adp5588TypeGpiEmReg
    Get
    Set
public:
property Adp5588TypeGpiEmReg GPIEventMode2C5 {
    Adp5588TypeGpiEmReg get ();
    void set (Adp5588TypeGpiEmReg value);
}
member GPIEventMode2C5 : Adp5588TypeGpiEmReg with get, set

Property Value

Type: Adp5588TypeGpiEmReg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIEventMode2C6 Property

IRD

Adp5588GPIEventMode2C6 Property

GPI Event Mode 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpiEmReg GPIEventMode2C6 { get; set; }
Public Property GPIEventMode2C6 As Adp5588TypeGpiEmReg
    Get
    Set
public:
property Adp5588TypeGpiEmReg GPIEventMode2C6 {
    Adp5588TypeGpiEmReg get ();
    void set (Adp5588TypeGpiEmReg value);
}
member GPIEventMode2C6 : Adp5588TypeGpiEmReg with get, set

Property Value

Type: Adp5588TypeGpiEmReg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIEventMode2C7 Property

IRD

Adp5588GPIEventMode2C7 Property

GPI Event Mode 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpiEmReg GPIEventMode2C7 { get; set; }
Public Property GPIEventMode2C7 As Adp5588TypeGpiEmReg
    Get
    Set
public:
property Adp5588TypeGpiEmReg GPIEventMode2C7 {
    Adp5588TypeGpiEmReg get ();
    void set (Adp5588TypeGpiEmReg value);
}
member GPIEventMode2C7 : Adp5588TypeGpiEmReg with get, set

Property Value

Type: Adp5588TypeGpiEmReg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIEventMode3C8 Property

IRD

Adp5588GPIEventMode3C8 Property

GPI Event Mode 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpiEmReg GPIEventMode3C8 { get; set; }
Public Property GPIEventMode3C8 As Adp5588TypeGpiEmReg
    Get
    Set
public:
property Adp5588TypeGpiEmReg GPIEventMode3C8 {
    Adp5588TypeGpiEmReg get ();
    void set (Adp5588TypeGpiEmReg value);
}
member GPIEventMode3C8 : Adp5588TypeGpiEmReg with get, set

Property Value

Type: Adp5588TypeGpiEmReg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIEventMode3C9 Property

IRD

Adp5588GPIEventMode3C9 Property

GPI Event Mode 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpiEmReg GPIEventMode3C9 { get; set; }
Public Property GPIEventMode3C9 As Adp5588TypeGpiEmReg
    Get
    Set
public:
property Adp5588TypeGpiEmReg GPIEventMode3C9 {
    Adp5588TypeGpiEmReg get ();
    void set (Adp5588TypeGpiEmReg value);
}
member GPIEventMode3C9 : Adp5588TypeGpiEmReg with get, set

Property Value

Type: Adp5588TypeGpiEmReg
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataDirection1R0 Property

IRD

Adp5588GPIODataDirection1R0 Property

GPIO Data Direction 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioDir GPIODataDirection1R0 { get; set; }
Public Property GPIODataDirection1R0 As Adp5588TypeGpioDir
    Get
    Set
public:
property Adp5588TypeGpioDir GPIODataDirection1R0 {
    Adp5588TypeGpioDir get ();
    void set (Adp5588TypeGpioDir value);
}
member GPIODataDirection1R0 : Adp5588TypeGpioDir with get, set

Property Value

Type: Adp5588TypeGpioDir
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataDirection1R1 Property

IRD

Adp5588GPIODataDirection1R1 Property

GPIO Data Direction 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioDir GPIODataDirection1R1 { get; set; }
Public Property GPIODataDirection1R1 As Adp5588TypeGpioDir
    Get
    Set
public:
property Adp5588TypeGpioDir GPIODataDirection1R1 {
    Adp5588TypeGpioDir get ();
    void set (Adp5588TypeGpioDir value);
}
member GPIODataDirection1R1 : Adp5588TypeGpioDir with get, set

Property Value

Type: Adp5588TypeGpioDir
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataDirection1R2 Property

IRD

Adp5588GPIODataDirection1R2 Property

GPIO Data Direction 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioDir GPIODataDirection1R2 { get; set; }
Public Property GPIODataDirection1R2 As Adp5588TypeGpioDir
    Get
    Set
public:
property Adp5588TypeGpioDir GPIODataDirection1R2 {
    Adp5588TypeGpioDir get ();
    void set (Adp5588TypeGpioDir value);
}
member GPIODataDirection1R2 : Adp5588TypeGpioDir with get, set

Property Value

Type: Adp5588TypeGpioDir
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataDirection1R3 Property

IRD

Adp5588GPIODataDirection1R3 Property

GPIO Data Direction 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioDir GPIODataDirection1R3 { get; set; }
Public Property GPIODataDirection1R3 As Adp5588TypeGpioDir
    Get
    Set
public:
property Adp5588TypeGpioDir GPIODataDirection1R3 {
    Adp5588TypeGpioDir get ();
    void set (Adp5588TypeGpioDir value);
}
member GPIODataDirection1R3 : Adp5588TypeGpioDir with get, set

Property Value

Type: Adp5588TypeGpioDir
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataDirection1R4 Property

IRD

Adp5588GPIODataDirection1R4 Property

GPIO Data Direction 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioDir GPIODataDirection1R4 { get; set; }
Public Property GPIODataDirection1R4 As Adp5588TypeGpioDir
    Get
    Set
public:
property Adp5588TypeGpioDir GPIODataDirection1R4 {
    Adp5588TypeGpioDir get ();
    void set (Adp5588TypeGpioDir value);
}
member GPIODataDirection1R4 : Adp5588TypeGpioDir with get, set

Property Value

Type: Adp5588TypeGpioDir
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataDirection1R5 Property

IRD

Adp5588GPIODataDirection1R5 Property

GPIO Data Direction 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioDir GPIODataDirection1R5 { get; set; }
Public Property GPIODataDirection1R5 As Adp5588TypeGpioDir
    Get
    Set
public:
property Adp5588TypeGpioDir GPIODataDirection1R5 {
    Adp5588TypeGpioDir get ();
    void set (Adp5588TypeGpioDir value);
}
member GPIODataDirection1R5 : Adp5588TypeGpioDir with get, set

Property Value

Type: Adp5588TypeGpioDir
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataDirection1R6 Property

IRD

Adp5588GPIODataDirection1R6 Property

GPIO Data Direction 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioDir GPIODataDirection1R6 { get; set; }
Public Property GPIODataDirection1R6 As Adp5588TypeGpioDir
    Get
    Set
public:
property Adp5588TypeGpioDir GPIODataDirection1R6 {
    Adp5588TypeGpioDir get ();
    void set (Adp5588TypeGpioDir value);
}
member GPIODataDirection1R6 : Adp5588TypeGpioDir with get, set

Property Value

Type: Adp5588TypeGpioDir
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataDirection1R7 Property

IRD

Adp5588GPIODataDirection1R7 Property

GPIO Data Direction 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioDir GPIODataDirection1R7 { get; set; }
Public Property GPIODataDirection1R7 As Adp5588TypeGpioDir
    Get
    Set
public:
property Adp5588TypeGpioDir GPIODataDirection1R7 {
    Adp5588TypeGpioDir get ();
    void set (Adp5588TypeGpioDir value);
}
member GPIODataDirection1R7 : Adp5588TypeGpioDir with get, set

Property Value

Type: Adp5588TypeGpioDir
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataDirection2C0 Property

IRD

Adp5588GPIODataDirection2C0 Property

GPIO Data Direction 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioDir GPIODataDirection2C0 { get; set; }
Public Property GPIODataDirection2C0 As Adp5588TypeGpioDir
    Get
    Set
public:
property Adp5588TypeGpioDir GPIODataDirection2C0 {
    Adp5588TypeGpioDir get ();
    void set (Adp5588TypeGpioDir value);
}
member GPIODataDirection2C0 : Adp5588TypeGpioDir with get, set

Property Value

Type: Adp5588TypeGpioDir
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataDirection2C1 Property

IRD

Adp5588GPIODataDirection2C1 Property

GPIO Data Direction 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioDir GPIODataDirection2C1 { get; set; }
Public Property GPIODataDirection2C1 As Adp5588TypeGpioDir
    Get
    Set
public:
property Adp5588TypeGpioDir GPIODataDirection2C1 {
    Adp5588TypeGpioDir get ();
    void set (Adp5588TypeGpioDir value);
}
member GPIODataDirection2C1 : Adp5588TypeGpioDir with get, set

Property Value

Type: Adp5588TypeGpioDir
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataDirection2C2 Property

IRD

Adp5588GPIODataDirection2C2 Property

GPIO Data Direction 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioDir GPIODataDirection2C2 { get; set; }
Public Property GPIODataDirection2C2 As Adp5588TypeGpioDir
    Get
    Set
public:
property Adp5588TypeGpioDir GPIODataDirection2C2 {
    Adp5588TypeGpioDir get ();
    void set (Adp5588TypeGpioDir value);
}
member GPIODataDirection2C2 : Adp5588TypeGpioDir with get, set

Property Value

Type: Adp5588TypeGpioDir
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataDirection2C3 Property

IRD

Adp5588GPIODataDirection2C3 Property

GPIO Data Direction 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioDir GPIODataDirection2C3 { get; set; }
Public Property GPIODataDirection2C3 As Adp5588TypeGpioDir
    Get
    Set
public:
property Adp5588TypeGpioDir GPIODataDirection2C3 {
    Adp5588TypeGpioDir get ();
    void set (Adp5588TypeGpioDir value);
}
member GPIODataDirection2C3 : Adp5588TypeGpioDir with get, set

Property Value

Type: Adp5588TypeGpioDir
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataDirection2C4 Property

IRD

Adp5588GPIODataDirection2C4 Property

GPIO Data Direction 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioDir GPIODataDirection2C4 { get; set; }
Public Property GPIODataDirection2C4 As Adp5588TypeGpioDir
    Get
    Set
public:
property Adp5588TypeGpioDir GPIODataDirection2C4 {
    Adp5588TypeGpioDir get ();
    void set (Adp5588TypeGpioDir value);
}
member GPIODataDirection2C4 : Adp5588TypeGpioDir with get, set

Property Value

Type: Adp5588TypeGpioDir
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataDirection2C5 Property

IRD

Adp5588GPIODataDirection2C5 Property

GPIO Data Direction 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioDir GPIODataDirection2C5 { get; set; }
Public Property GPIODataDirection2C5 As Adp5588TypeGpioDir
    Get
    Set
public:
property Adp5588TypeGpioDir GPIODataDirection2C5 {
    Adp5588TypeGpioDir get ();
    void set (Adp5588TypeGpioDir value);
}
member GPIODataDirection2C5 : Adp5588TypeGpioDir with get, set

Property Value

Type: Adp5588TypeGpioDir
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataDirection2C6 Property

IRD

Adp5588GPIODataDirection2C6 Property

GPIO Data Direction 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioDir GPIODataDirection2C6 { get; set; }
Public Property GPIODataDirection2C6 As Adp5588TypeGpioDir
    Get
    Set
public:
property Adp5588TypeGpioDir GPIODataDirection2C6 {
    Adp5588TypeGpioDir get ();
    void set (Adp5588TypeGpioDir value);
}
member GPIODataDirection2C6 : Adp5588TypeGpioDir with get, set

Property Value

Type: Adp5588TypeGpioDir
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataDirection2C7 Property

IRD

Adp5588GPIODataDirection2C7 Property

GPIO Data Direction 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioDir GPIODataDirection2C7 { get; set; }
Public Property GPIODataDirection2C7 As Adp5588TypeGpioDir
    Get
    Set
public:
property Adp5588TypeGpioDir GPIODataDirection2C7 {
    Adp5588TypeGpioDir get ();
    void set (Adp5588TypeGpioDir value);
}
member GPIODataDirection2C7 : Adp5588TypeGpioDir with get, set

Property Value

Type: Adp5588TypeGpioDir
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataDirection3C8 Property

IRD

Adp5588GPIODataDirection3C8 Property

GPIO Data Direction 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioDir GPIODataDirection3C8 { get; set; }
Public Property GPIODataDirection3C8 As Adp5588TypeGpioDir
    Get
    Set
public:
property Adp5588TypeGpioDir GPIODataDirection3C8 {
    Adp5588TypeGpioDir get ();
    void set (Adp5588TypeGpioDir value);
}
member GPIODataDirection3C8 : Adp5588TypeGpioDir with get, set

Property Value

Type: Adp5588TypeGpioDir
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataDirection3C9 Property

IRD

Adp5588GPIODataDirection3C9 Property

GPIO Data Direction 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioDir GPIODataDirection3C9 { get; set; }
Public Property GPIODataDirection3C9 As Adp5588TypeGpioDir
    Get
    Set
public:
property Adp5588TypeGpioDir GPIODataDirection3C9 {
    Adp5588TypeGpioDir get ();
    void set (Adp5588TypeGpioDir value);
}
member GPIODataDirection3C9 : Adp5588TypeGpioDir with get, set

Property Value

Type: Adp5588TypeGpioDir
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataOut1R0 Property

IRD

Adp5588GPIODataOut1R0 Property

GPIO Data Out 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut1R0 { get; set; }
Public Property GPIODataOut1R0 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut1R0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut1R0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataOut1R1 Property

IRD

Adp5588GPIODataOut1R1 Property

GPIO Data Out 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut1R1 { get; set; }
Public Property GPIODataOut1R1 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut1R1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut1R1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataOut1R2 Property

IRD

Adp5588GPIODataOut1R2 Property

GPIO Data Out 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut1R2 { get; set; }
Public Property GPIODataOut1R2 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut1R2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut1R2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataOut1R3 Property

IRD

Adp5588GPIODataOut1R3 Property

GPIO Data Out 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut1R3 { get; set; }
Public Property GPIODataOut1R3 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut1R3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut1R3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataOut1R4 Property

IRD

Adp5588GPIODataOut1R4 Property

GPIO Data Out 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut1R4 { get; set; }
Public Property GPIODataOut1R4 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut1R4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut1R4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataOut1R5 Property

IRD

Adp5588GPIODataOut1R5 Property

GPIO Data Out 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut1R5 { get; set; }
Public Property GPIODataOut1R5 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut1R5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut1R5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataOut1R6 Property

IRD

Adp5588GPIODataOut1R6 Property

GPIO Data Out 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut1R6 { get; set; }
Public Property GPIODataOut1R6 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut1R6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut1R6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataOut1R7 Property

IRD

Adp5588GPIODataOut1R7 Property

GPIO Data Out 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut1R7 { get; set; }
Public Property GPIODataOut1R7 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut1R7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut1R7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataOut2C0 Property

IRD

Adp5588GPIODataOut2C0 Property

GPIO Data Out 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut2C0 { get; set; }
Public Property GPIODataOut2C0 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut2C0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut2C0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataOut2C1 Property

IRD

Adp5588GPIODataOut2C1 Property

GPIO Data Out 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut2C1 { get; set; }
Public Property GPIODataOut2C1 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut2C1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut2C1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataOut2C2 Property

IRD

Adp5588GPIODataOut2C2 Property

GPIO Data Out 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut2C2 { get; set; }
Public Property GPIODataOut2C2 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut2C2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut2C2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataOut2C3 Property

IRD

Adp5588GPIODataOut2C3 Property

GPIO Data Out 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut2C3 { get; set; }
Public Property GPIODataOut2C3 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut2C3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut2C3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataOut2C4 Property

IRD

Adp5588GPIODataOut2C4 Property

GPIO Data Out 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut2C4 { get; set; }
Public Property GPIODataOut2C4 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut2C4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut2C4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataOut2C5 Property

IRD

Adp5588GPIODataOut2C5 Property

GPIO Data Out 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut2C5 { get; set; }
Public Property GPIODataOut2C5 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut2C5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut2C5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataOut2C6 Property

IRD

Adp5588GPIODataOut2C6 Property

GPIO Data Out 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut2C6 { get; set; }
Public Property GPIODataOut2C6 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut2C6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut2C6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataOut2C7 Property

IRD

Adp5588GPIODataOut2C7 Property

GPIO Data Out 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut2C7 { get; set; }
Public Property GPIODataOut2C7 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut2C7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut2C7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataOut3C8 Property

IRD

Adp5588GPIODataOut3C8 Property

GPIO Data Out 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut3C8 { get; set; }
Public Property GPIODataOut3C8 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut3C8 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut3C8 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataOut3C9 Property

IRD

Adp5588GPIODataOut3C9 Property

GPIO Data Out 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataOut3C9 { get; set; }
Public Property GPIODataOut3C9 As Byte
    Get
    Set
public:
property unsigned char GPIODataOut3C9 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataOut3C9 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataStatus1R0 Property

IRD

Adp5588GPIODataStatus1R0 Property

GPIO Data Status 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus1R0 { get; set; }
Public Property GPIODataStatus1R0 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus1R0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus1R0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataStatus1R1 Property

IRD

Adp5588GPIODataStatus1R1 Property

GPIO Data Status 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus1R1 { get; set; }
Public Property GPIODataStatus1R1 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus1R1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus1R1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataStatus1R2 Property

IRD

Adp5588GPIODataStatus1R2 Property

GPIO Data Status 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus1R2 { get; set; }
Public Property GPIODataStatus1R2 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus1R2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus1R2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataStatus1R3 Property

IRD

Adp5588GPIODataStatus1R3 Property

GPIO Data Status 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus1R3 { get; set; }
Public Property GPIODataStatus1R3 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus1R3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus1R3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataStatus1R4 Property

IRD

Adp5588GPIODataStatus1R4 Property

GPIO Data Status 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus1R4 { get; set; }
Public Property GPIODataStatus1R4 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus1R4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus1R4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataStatus1R5 Property

IRD

Adp5588GPIODataStatus1R5 Property

GPIO Data Status 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus1R5 { get; set; }
Public Property GPIODataStatus1R5 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus1R5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus1R5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataStatus1R6 Property

IRD

Adp5588GPIODataStatus1R6 Property

GPIO Data Status 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus1R6 { get; set; }
Public Property GPIODataStatus1R6 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus1R6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus1R6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataStatus1R7 Property

IRD

Adp5588GPIODataStatus1R7 Property

GPIO Data Status 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus1R7 { get; set; }
Public Property GPIODataStatus1R7 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus1R7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus1R7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataStatus2C0 Property

IRD

Adp5588GPIODataStatus2C0 Property

GPIO Data Status 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus2C0 { get; set; }
Public Property GPIODataStatus2C0 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus2C0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus2C0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataStatus2C1 Property

IRD

Adp5588GPIODataStatus2C1 Property

GPIO Data Status 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus2C1 { get; set; }
Public Property GPIODataStatus2C1 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus2C1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus2C1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataStatus2C2 Property

IRD

Adp5588GPIODataStatus2C2 Property

GPIO Data Status 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus2C2 { get; set; }
Public Property GPIODataStatus2C2 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus2C2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus2C2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataStatus2C3 Property

IRD

Adp5588GPIODataStatus2C3 Property

GPIO Data Status 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus2C3 { get; set; }
Public Property GPIODataStatus2C3 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus2C3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus2C3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataStatus2C4 Property

IRD

Adp5588GPIODataStatus2C4 Property

GPIO Data Status 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus2C4 { get; set; }
Public Property GPIODataStatus2C4 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus2C4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus2C4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataStatus2C5 Property

IRD

Adp5588GPIODataStatus2C5 Property

GPIO Data Status 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus2C5 { get; set; }
Public Property GPIODataStatus2C5 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus2C5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus2C5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataStatus2C6 Property

IRD

Adp5588GPIODataStatus2C6 Property

GPIO Data Status 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus2C6 { get; set; }
Public Property GPIODataStatus2C6 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus2C6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus2C6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataStatus2C7 Property

IRD

Adp5588GPIODataStatus2C7 Property

GPIO Data Status 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus2C7 { get; set; }
Public Property GPIODataStatus2C7 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus2C7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus2C7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataStatus3C8 Property

IRD

Adp5588GPIODataStatus3C8 Property

GPIO Data Status 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus3C8 { get; set; }
Public Property GPIODataStatus3C8 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus3C8 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus3C8 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIODataStatus3C9 Property

IRD

Adp5588GPIODataStatus3C9 Property

GPIO Data Status 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODataStatus3C9 { get; set; }
Public Property GPIODataStatus3C9 As Byte
    Get
    Set
public:
property unsigned char GPIODataStatus3C9 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODataStatus3C9 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptEnable1R0 Property

IRD

Adp5588GPIOInterruptEnable1R0 Property

GPIO Interrupt Enable 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable1R0 { get; set; }
Public Property GPIOInterruptEnable1R0 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable1R0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable1R0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptEnable1R1 Property

IRD

Adp5588GPIOInterruptEnable1R1 Property

GPIO Interrupt Enable 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable1R1 { get; set; }
Public Property GPIOInterruptEnable1R1 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable1R1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable1R1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptEnable1R2 Property

IRD

Adp5588GPIOInterruptEnable1R2 Property

GPIO Interrupt Enable 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable1R2 { get; set; }
Public Property GPIOInterruptEnable1R2 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable1R2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable1R2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptEnable1R3 Property

IRD

Adp5588GPIOInterruptEnable1R3 Property

GPIO Interrupt Enable 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable1R3 { get; set; }
Public Property GPIOInterruptEnable1R3 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable1R3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable1R3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptEnable1R4 Property

IRD

Adp5588GPIOInterruptEnable1R4 Property

GPIO Interrupt Enable 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable1R4 { get; set; }
Public Property GPIOInterruptEnable1R4 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable1R4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable1R4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptEnable1R5 Property

IRD

Adp5588GPIOInterruptEnable1R5 Property

GPIO Interrupt Enable 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable1R5 { get; set; }
Public Property GPIOInterruptEnable1R5 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable1R5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable1R5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptEnable1R6 Property

IRD

Adp5588GPIOInterruptEnable1R6 Property

GPIO Interrupt Enable 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable1R6 { get; set; }
Public Property GPIOInterruptEnable1R6 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable1R6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable1R6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptEnable1R7 Property

IRD

Adp5588GPIOInterruptEnable1R7 Property

GPIO Interrupt Enable 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable1R7 { get; set; }
Public Property GPIOInterruptEnable1R7 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable1R7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable1R7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptEnable2C0 Property

IRD

Adp5588GPIOInterruptEnable2C0 Property

GPIO Interrupt Enable 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable2C0 { get; set; }
Public Property GPIOInterruptEnable2C0 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable2C0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable2C0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptEnable2C1 Property

IRD

Adp5588GPIOInterruptEnable2C1 Property

GPIO Interrupt Enable 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable2C1 { get; set; }
Public Property GPIOInterruptEnable2C1 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable2C1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable2C1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptEnable2C2 Property

IRD

Adp5588GPIOInterruptEnable2C2 Property

GPIO Interrupt Enable 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable2C2 { get; set; }
Public Property GPIOInterruptEnable2C2 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable2C2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable2C2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptEnable2C3 Property

IRD

Adp5588GPIOInterruptEnable2C3 Property

GPIO Interrupt Enable 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable2C3 { get; set; }
Public Property GPIOInterruptEnable2C3 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable2C3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable2C3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptEnable2C4 Property

IRD

Adp5588GPIOInterruptEnable2C4 Property

GPIO Interrupt Enable 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable2C4 { get; set; }
Public Property GPIOInterruptEnable2C4 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable2C4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable2C4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptEnable2C5 Property

IRD

Adp5588GPIOInterruptEnable2C5 Property

GPIO Interrupt Enable 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable2C5 { get; set; }
Public Property GPIOInterruptEnable2C5 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable2C5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable2C5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptEnable2C6 Property

IRD

Adp5588GPIOInterruptEnable2C6 Property

GPIO Interrupt Enable 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable2C6 { get; set; }
Public Property GPIOInterruptEnable2C6 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable2C6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable2C6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptEnable2C7 Property

IRD

Adp5588GPIOInterruptEnable2C7 Property

GPIO Interrupt Enable 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable2C7 { get; set; }
Public Property GPIOInterruptEnable2C7 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable2C7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable2C7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptEnable3C8 Property

IRD

Adp5588GPIOInterruptEnable3C8 Property

GPIO Interrupt Enable 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable3C8 { get; set; }
Public Property GPIOInterruptEnable3C8 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable3C8 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable3C8 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptEnable3C9 Property

IRD

Adp5588GPIOInterruptEnable3C9 Property

GPIO Interrupt Enable 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptEnable3C9 { get; set; }
Public Property GPIOInterruptEnable3C9 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptEnable3C9 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptEnable3C9 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptStatus1R0 Property

IRD

Adp5588GPIOInterruptStatus1R0 Property

GPIO Interrupt Status 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus1R0 { get; set; }
Public Property GPIOInterruptStatus1R0 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus1R0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus1R0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptStatus1R1 Property

IRD

Adp5588GPIOInterruptStatus1R1 Property

GPIO Interrupt Status 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus1R1 { get; set; }
Public Property GPIOInterruptStatus1R1 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus1R1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus1R1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptStatus1R2 Property

IRD

Adp5588GPIOInterruptStatus1R2 Property

GPIO Interrupt Status 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus1R2 { get; set; }
Public Property GPIOInterruptStatus1R2 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus1R2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus1R2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptStatus1R3 Property

IRD

Adp5588GPIOInterruptStatus1R3 Property

GPIO Interrupt Status 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus1R3 { get; set; }
Public Property GPIOInterruptStatus1R3 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus1R3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus1R3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptStatus1R4 Property

IRD

Adp5588GPIOInterruptStatus1R4 Property

GPIO Interrupt Status 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus1R4 { get; set; }
Public Property GPIOInterruptStatus1R4 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus1R4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus1R4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptStatus1R5 Property

IRD

Adp5588GPIOInterruptStatus1R5 Property

GPIO Interrupt Status 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus1R5 { get; set; }
Public Property GPIOInterruptStatus1R5 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus1R5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus1R5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptStatus1R6 Property

IRD

Adp5588GPIOInterruptStatus1R6 Property

GPIO Interrupt Status 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus1R6 { get; set; }
Public Property GPIOInterruptStatus1R6 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus1R6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus1R6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptStatus1R7 Property

IRD

Adp5588GPIOInterruptStatus1R7 Property

GPIO Interrupt Status 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus1R7 { get; set; }
Public Property GPIOInterruptStatus1R7 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus1R7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus1R7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptStatus2C0 Property

IRD

Adp5588GPIOInterruptStatus2C0 Property

GPIO Interrupt Status 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus2C0 { get; set; }
Public Property GPIOInterruptStatus2C0 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus2C0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus2C0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptStatus2C1 Property

IRD

Adp5588GPIOInterruptStatus2C1 Property

GPIO Interrupt Status 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus2C1 { get; set; }
Public Property GPIOInterruptStatus2C1 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus2C1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus2C1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptStatus2C2 Property

IRD

Adp5588GPIOInterruptStatus2C2 Property

GPIO Interrupt Status 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus2C2 { get; set; }
Public Property GPIOInterruptStatus2C2 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus2C2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus2C2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptStatus2C3 Property

IRD

Adp5588GPIOInterruptStatus2C3 Property

GPIO Interrupt Status 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus2C3 { get; set; }
Public Property GPIOInterruptStatus2C3 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus2C3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus2C3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptStatus2C4 Property

IRD

Adp5588GPIOInterruptStatus2C4 Property

GPIO Interrupt Status 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus2C4 { get; set; }
Public Property GPIOInterruptStatus2C4 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus2C4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus2C4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptStatus2C5 Property

IRD

Adp5588GPIOInterruptStatus2C5 Property

GPIO Interrupt Status 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus2C5 { get; set; }
Public Property GPIOInterruptStatus2C5 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus2C5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus2C5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptStatus2C6 Property

IRD

Adp5588GPIOInterruptStatus2C6 Property

GPIO Interrupt Status 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus2C6 { get; set; }
Public Property GPIOInterruptStatus2C6 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus2C6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus2C6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptStatus2C7 Property

IRD

Adp5588GPIOInterruptStatus2C7 Property

GPIO Interrupt Status 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus2C7 { get; set; }
Public Property GPIOInterruptStatus2C7 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus2C7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus2C7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptStatus3C8 Property

IRD

Adp5588GPIOInterruptStatus3C8 Property

GPIO Interrupt Status 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus3C8 { get; set; }
Public Property GPIOInterruptStatus3C8 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus3C8 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus3C8 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOInterruptStatus3C9 Property

IRD

Adp5588GPIOInterruptStatus3C9 Property

GPIO Interrupt Status 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOInterruptStatus3C9 { get; set; }
Public Property GPIOInterruptStatus3C9 As Byte
    Get
    Set
public:
property unsigned char GPIOInterruptStatus3C9 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOInterruptStatus3C9 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOLevelDetect1R0 Property

IRD

Adp5588GPIOLevelDetect1R0 Property

GPIO Level Detect 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioIntLvl GPIOLevelDetect1R0 { get; set; }
Public Property GPIOLevelDetect1R0 As Adp5588TypeGpioIntLvl
    Get
    Set
public:
property Adp5588TypeGpioIntLvl GPIOLevelDetect1R0 {
    Adp5588TypeGpioIntLvl get ();
    void set (Adp5588TypeGpioIntLvl value);
}
member GPIOLevelDetect1R0 : Adp5588TypeGpioIntLvl with get, set

Property Value

Type: Adp5588TypeGpioIntLvl
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOLevelDetect1R1 Property

IRD

Adp5588GPIOLevelDetect1R1 Property

GPIO Level Detect 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioIntLvl GPIOLevelDetect1R1 { get; set; }
Public Property GPIOLevelDetect1R1 As Adp5588TypeGpioIntLvl
    Get
    Set
public:
property Adp5588TypeGpioIntLvl GPIOLevelDetect1R1 {
    Adp5588TypeGpioIntLvl get ();
    void set (Adp5588TypeGpioIntLvl value);
}
member GPIOLevelDetect1R1 : Adp5588TypeGpioIntLvl with get, set

Property Value

Type: Adp5588TypeGpioIntLvl
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOLevelDetect1R2 Property

IRD

Adp5588GPIOLevelDetect1R2 Property

GPIO Level Detect 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioIntLvl GPIOLevelDetect1R2 { get; set; }
Public Property GPIOLevelDetect1R2 As Adp5588TypeGpioIntLvl
    Get
    Set
public:
property Adp5588TypeGpioIntLvl GPIOLevelDetect1R2 {
    Adp5588TypeGpioIntLvl get ();
    void set (Adp5588TypeGpioIntLvl value);
}
member GPIOLevelDetect1R2 : Adp5588TypeGpioIntLvl with get, set

Property Value

Type: Adp5588TypeGpioIntLvl
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOLevelDetect1R3 Property

IRD

Adp5588GPIOLevelDetect1R3 Property

GPIO Level Detect 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioIntLvl GPIOLevelDetect1R3 { get; set; }
Public Property GPIOLevelDetect1R3 As Adp5588TypeGpioIntLvl
    Get
    Set
public:
property Adp5588TypeGpioIntLvl GPIOLevelDetect1R3 {
    Adp5588TypeGpioIntLvl get ();
    void set (Adp5588TypeGpioIntLvl value);
}
member GPIOLevelDetect1R3 : Adp5588TypeGpioIntLvl with get, set

Property Value

Type: Adp5588TypeGpioIntLvl
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOLevelDetect1R4 Property

IRD

Adp5588GPIOLevelDetect1R4 Property

GPIO Level Detect 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioIntLvl GPIOLevelDetect1R4 { get; set; }
Public Property GPIOLevelDetect1R4 As Adp5588TypeGpioIntLvl
    Get
    Set
public:
property Adp5588TypeGpioIntLvl GPIOLevelDetect1R4 {
    Adp5588TypeGpioIntLvl get ();
    void set (Adp5588TypeGpioIntLvl value);
}
member GPIOLevelDetect1R4 : Adp5588TypeGpioIntLvl with get, set

Property Value

Type: Adp5588TypeGpioIntLvl
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOLevelDetect1R5 Property

IRD

Adp5588GPIOLevelDetect1R5 Property

GPIO Level Detect 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioIntLvl GPIOLevelDetect1R5 { get; set; }
Public Property GPIOLevelDetect1R5 As Adp5588TypeGpioIntLvl
    Get
    Set
public:
property Adp5588TypeGpioIntLvl GPIOLevelDetect1R5 {
    Adp5588TypeGpioIntLvl get ();
    void set (Adp5588TypeGpioIntLvl value);
}
member GPIOLevelDetect1R5 : Adp5588TypeGpioIntLvl with get, set

Property Value

Type: Adp5588TypeGpioIntLvl
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOLevelDetect1R6 Property

IRD

Adp5588GPIOLevelDetect1R6 Property

GPIO Level Detect 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioIntLvl GPIOLevelDetect1R6 { get; set; }
Public Property GPIOLevelDetect1R6 As Adp5588TypeGpioIntLvl
    Get
    Set
public:
property Adp5588TypeGpioIntLvl GPIOLevelDetect1R6 {
    Adp5588TypeGpioIntLvl get ();
    void set (Adp5588TypeGpioIntLvl value);
}
member GPIOLevelDetect1R6 : Adp5588TypeGpioIntLvl with get, set

Property Value

Type: Adp5588TypeGpioIntLvl
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOLevelDetect1R7 Property

IRD

Adp5588GPIOLevelDetect1R7 Property

GPIO Level Detect 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioIntLvl GPIOLevelDetect1R7 { get; set; }
Public Property GPIOLevelDetect1R7 As Adp5588TypeGpioIntLvl
    Get
    Set
public:
property Adp5588TypeGpioIntLvl GPIOLevelDetect1R7 {
    Adp5588TypeGpioIntLvl get ();
    void set (Adp5588TypeGpioIntLvl value);
}
member GPIOLevelDetect1R7 : Adp5588TypeGpioIntLvl with get, set

Property Value

Type: Adp5588TypeGpioIntLvl
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOLevelDetect2C0 Property

IRD

Adp5588GPIOLevelDetect2C0 Property

GPIO Level Detect 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioIntLvl GPIOLevelDetect2C0 { get; set; }
Public Property GPIOLevelDetect2C0 As Adp5588TypeGpioIntLvl
    Get
    Set
public:
property Adp5588TypeGpioIntLvl GPIOLevelDetect2C0 {
    Adp5588TypeGpioIntLvl get ();
    void set (Adp5588TypeGpioIntLvl value);
}
member GPIOLevelDetect2C0 : Adp5588TypeGpioIntLvl with get, set

Property Value

Type: Adp5588TypeGpioIntLvl
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOLevelDetect2C1 Property

IRD

Adp5588GPIOLevelDetect2C1 Property

GPIO Level Detect 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioIntLvl GPIOLevelDetect2C1 { get; set; }
Public Property GPIOLevelDetect2C1 As Adp5588TypeGpioIntLvl
    Get
    Set
public:
property Adp5588TypeGpioIntLvl GPIOLevelDetect2C1 {
    Adp5588TypeGpioIntLvl get ();
    void set (Adp5588TypeGpioIntLvl value);
}
member GPIOLevelDetect2C1 : Adp5588TypeGpioIntLvl with get, set

Property Value

Type: Adp5588TypeGpioIntLvl
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOLevelDetect2C2 Property

IRD

Adp5588GPIOLevelDetect2C2 Property

GPIO Level Detect 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioIntLvl GPIOLevelDetect2C2 { get; set; }
Public Property GPIOLevelDetect2C2 As Adp5588TypeGpioIntLvl
    Get
    Set
public:
property Adp5588TypeGpioIntLvl GPIOLevelDetect2C2 {
    Adp5588TypeGpioIntLvl get ();
    void set (Adp5588TypeGpioIntLvl value);
}
member GPIOLevelDetect2C2 : Adp5588TypeGpioIntLvl with get, set

Property Value

Type: Adp5588TypeGpioIntLvl
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOLevelDetect2C3 Property

IRD

Adp5588GPIOLevelDetect2C3 Property

GPIO Level Detect 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioIntLvl GPIOLevelDetect2C3 { get; set; }
Public Property GPIOLevelDetect2C3 As Adp5588TypeGpioIntLvl
    Get
    Set
public:
property Adp5588TypeGpioIntLvl GPIOLevelDetect2C3 {
    Adp5588TypeGpioIntLvl get ();
    void set (Adp5588TypeGpioIntLvl value);
}
member GPIOLevelDetect2C3 : Adp5588TypeGpioIntLvl with get, set

Property Value

Type: Adp5588TypeGpioIntLvl
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOLevelDetect2C4 Property

IRD

Adp5588GPIOLevelDetect2C4 Property

GPIO Level Detect 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioIntLvl GPIOLevelDetect2C4 { get; set; }
Public Property GPIOLevelDetect2C4 As Adp5588TypeGpioIntLvl
    Get
    Set
public:
property Adp5588TypeGpioIntLvl GPIOLevelDetect2C4 {
    Adp5588TypeGpioIntLvl get ();
    void set (Adp5588TypeGpioIntLvl value);
}
member GPIOLevelDetect2C4 : Adp5588TypeGpioIntLvl with get, set

Property Value

Type: Adp5588TypeGpioIntLvl
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOLevelDetect2C5 Property

IRD

Adp5588GPIOLevelDetect2C5 Property

GPIO Level Detect 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioIntLvl GPIOLevelDetect2C5 { get; set; }
Public Property GPIOLevelDetect2C5 As Adp5588TypeGpioIntLvl
    Get
    Set
public:
property Adp5588TypeGpioIntLvl GPIOLevelDetect2C5 {
    Adp5588TypeGpioIntLvl get ();
    void set (Adp5588TypeGpioIntLvl value);
}
member GPIOLevelDetect2C5 : Adp5588TypeGpioIntLvl with get, set

Property Value

Type: Adp5588TypeGpioIntLvl
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOLevelDetect2C6 Property

IRD

Adp5588GPIOLevelDetect2C6 Property

GPIO Level Detect 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioIntLvl GPIOLevelDetect2C6 { get; set; }
Public Property GPIOLevelDetect2C6 As Adp5588TypeGpioIntLvl
    Get
    Set
public:
property Adp5588TypeGpioIntLvl GPIOLevelDetect2C6 {
    Adp5588TypeGpioIntLvl get ();
    void set (Adp5588TypeGpioIntLvl value);
}
member GPIOLevelDetect2C6 : Adp5588TypeGpioIntLvl with get, set

Property Value

Type: Adp5588TypeGpioIntLvl
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOLevelDetect2C7 Property

IRD

Adp5588GPIOLevelDetect2C7 Property

GPIO Level Detect 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioIntLvl GPIOLevelDetect2C7 { get; set; }
Public Property GPIOLevelDetect2C7 As Adp5588TypeGpioIntLvl
    Get
    Set
public:
property Adp5588TypeGpioIntLvl GPIOLevelDetect2C7 {
    Adp5588TypeGpioIntLvl get ();
    void set (Adp5588TypeGpioIntLvl value);
}
member GPIOLevelDetect2C7 : Adp5588TypeGpioIntLvl with get, set

Property Value

Type: Adp5588TypeGpioIntLvl
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOLevelDetect3C8 Property

IRD

Adp5588GPIOLevelDetect3C8 Property

GPIO Level Detect 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioIntLvl GPIOLevelDetect3C8 { get; set; }
Public Property GPIOLevelDetect3C8 As Adp5588TypeGpioIntLvl
    Get
    Set
public:
property Adp5588TypeGpioIntLvl GPIOLevelDetect3C8 {
    Adp5588TypeGpioIntLvl get ();
    void set (Adp5588TypeGpioIntLvl value);
}
member GPIOLevelDetect3C8 : Adp5588TypeGpioIntLvl with get, set

Property Value

Type: Adp5588TypeGpioIntLvl
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOLevelDetect3C9 Property

IRD

Adp5588GPIOLevelDetect3C9 Property

GPIO Level Detect 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioIntLvl GPIOLevelDetect3C9 { get; set; }
Public Property GPIOLevelDetect3C9 As Adp5588TypeGpioIntLvl
    Get
    Set
public:
property Adp5588TypeGpioIntLvl GPIOLevelDetect3C9 {
    Adp5588TypeGpioIntLvl get ();
    void set (Adp5588TypeGpioIntLvl value);
}
member GPIOLevelDetect3C9 : Adp5588TypeGpioIntLvl with get, set

Property Value

Type: Adp5588TypeGpioIntLvl
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOPullDisable1R0 Property

IRD

Adp5588GPIOPullDisable1R0 Property

GPIO Pull Disable 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioPull GPIOPullDisable1R0 { get; set; }
Public Property GPIOPullDisable1R0 As Adp5588TypeGpioPull
    Get
    Set
public:
property Adp5588TypeGpioPull GPIOPullDisable1R0 {
    Adp5588TypeGpioPull get ();
    void set (Adp5588TypeGpioPull value);
}
member GPIOPullDisable1R0 : Adp5588TypeGpioPull with get, set

Property Value

Type: Adp5588TypeGpioPull
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOPullDisable1R1 Property

IRD

Adp5588GPIOPullDisable1R1 Property

GPIO Pull Disable 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioPull GPIOPullDisable1R1 { get; set; }
Public Property GPIOPullDisable1R1 As Adp5588TypeGpioPull
    Get
    Set
public:
property Adp5588TypeGpioPull GPIOPullDisable1R1 {
    Adp5588TypeGpioPull get ();
    void set (Adp5588TypeGpioPull value);
}
member GPIOPullDisable1R1 : Adp5588TypeGpioPull with get, set

Property Value

Type: Adp5588TypeGpioPull
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOPullDisable1R2 Property

IRD

Adp5588GPIOPullDisable1R2 Property

GPIO Pull Disable 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioPull GPIOPullDisable1R2 { get; set; }
Public Property GPIOPullDisable1R2 As Adp5588TypeGpioPull
    Get
    Set
public:
property Adp5588TypeGpioPull GPIOPullDisable1R2 {
    Adp5588TypeGpioPull get ();
    void set (Adp5588TypeGpioPull value);
}
member GPIOPullDisable1R2 : Adp5588TypeGpioPull with get, set

Property Value

Type: Adp5588TypeGpioPull
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOPullDisable1R3 Property

IRD

Adp5588GPIOPullDisable1R3 Property

GPIO Pull Disable 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioPull GPIOPullDisable1R3 { get; set; }
Public Property GPIOPullDisable1R3 As Adp5588TypeGpioPull
    Get
    Set
public:
property Adp5588TypeGpioPull GPIOPullDisable1R3 {
    Adp5588TypeGpioPull get ();
    void set (Adp5588TypeGpioPull value);
}
member GPIOPullDisable1R3 : Adp5588TypeGpioPull with get, set

Property Value

Type: Adp5588TypeGpioPull
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOPullDisable1R4 Property

IRD

Adp5588GPIOPullDisable1R4 Property

GPIO Pull Disable 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioPull GPIOPullDisable1R4 { get; set; }
Public Property GPIOPullDisable1R4 As Adp5588TypeGpioPull
    Get
    Set
public:
property Adp5588TypeGpioPull GPIOPullDisable1R4 {
    Adp5588TypeGpioPull get ();
    void set (Adp5588TypeGpioPull value);
}
member GPIOPullDisable1R4 : Adp5588TypeGpioPull with get, set

Property Value

Type: Adp5588TypeGpioPull
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOPullDisable1R5 Property

IRD

Adp5588GPIOPullDisable1R5 Property

GPIO Pull Disable 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioPull GPIOPullDisable1R5 { get; set; }
Public Property GPIOPullDisable1R5 As Adp5588TypeGpioPull
    Get
    Set
public:
property Adp5588TypeGpioPull GPIOPullDisable1R5 {
    Adp5588TypeGpioPull get ();
    void set (Adp5588TypeGpioPull value);
}
member GPIOPullDisable1R5 : Adp5588TypeGpioPull with get, set

Property Value

Type: Adp5588TypeGpioPull
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOPullDisable1R6 Property

IRD

Adp5588GPIOPullDisable1R6 Property

GPIO Pull Disable 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioPull GPIOPullDisable1R6 { get; set; }
Public Property GPIOPullDisable1R6 As Adp5588TypeGpioPull
    Get
    Set
public:
property Adp5588TypeGpioPull GPIOPullDisable1R6 {
    Adp5588TypeGpioPull get ();
    void set (Adp5588TypeGpioPull value);
}
member GPIOPullDisable1R6 : Adp5588TypeGpioPull with get, set

Property Value

Type: Adp5588TypeGpioPull
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOPullDisable1R7 Property

IRD

Adp5588GPIOPullDisable1R7 Property

GPIO Pull Disable 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioPull GPIOPullDisable1R7 { get; set; }
Public Property GPIOPullDisable1R7 As Adp5588TypeGpioPull
    Get
    Set
public:
property Adp5588TypeGpioPull GPIOPullDisable1R7 {
    Adp5588TypeGpioPull get ();
    void set (Adp5588TypeGpioPull value);
}
member GPIOPullDisable1R7 : Adp5588TypeGpioPull with get, set

Property Value

Type: Adp5588TypeGpioPull
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOPullDisable2C0 Property

IRD

Adp5588GPIOPullDisable2C0 Property

GPIO Pull Disable 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioPull GPIOPullDisable2C0 { get; set; }
Public Property GPIOPullDisable2C0 As Adp5588TypeGpioPull
    Get
    Set
public:
property Adp5588TypeGpioPull GPIOPullDisable2C0 {
    Adp5588TypeGpioPull get ();
    void set (Adp5588TypeGpioPull value);
}
member GPIOPullDisable2C0 : Adp5588TypeGpioPull with get, set

Property Value

Type: Adp5588TypeGpioPull
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOPullDisable2C1 Property

IRD

Adp5588GPIOPullDisable2C1 Property

GPIO Pull Disable 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioPull GPIOPullDisable2C1 { get; set; }
Public Property GPIOPullDisable2C1 As Adp5588TypeGpioPull
    Get
    Set
public:
property Adp5588TypeGpioPull GPIOPullDisable2C1 {
    Adp5588TypeGpioPull get ();
    void set (Adp5588TypeGpioPull value);
}
member GPIOPullDisable2C1 : Adp5588TypeGpioPull with get, set

Property Value

Type: Adp5588TypeGpioPull
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOPullDisable2C2 Property

IRD

Adp5588GPIOPullDisable2C2 Property

GPIO Pull Disable 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioPull GPIOPullDisable2C2 { get; set; }
Public Property GPIOPullDisable2C2 As Adp5588TypeGpioPull
    Get
    Set
public:
property Adp5588TypeGpioPull GPIOPullDisable2C2 {
    Adp5588TypeGpioPull get ();
    void set (Adp5588TypeGpioPull value);
}
member GPIOPullDisable2C2 : Adp5588TypeGpioPull with get, set

Property Value

Type: Adp5588TypeGpioPull
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOPullDisable2C3 Property

IRD

Adp5588GPIOPullDisable2C3 Property

GPIO Pull Disable 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioPull GPIOPullDisable2C3 { get; set; }
Public Property GPIOPullDisable2C3 As Adp5588TypeGpioPull
    Get
    Set
public:
property Adp5588TypeGpioPull GPIOPullDisable2C3 {
    Adp5588TypeGpioPull get ();
    void set (Adp5588TypeGpioPull value);
}
member GPIOPullDisable2C3 : Adp5588TypeGpioPull with get, set

Property Value

Type: Adp5588TypeGpioPull
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOPullDisable2C4 Property

IRD

Adp5588GPIOPullDisable2C4 Property

GPIO Pull Disable 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioPull GPIOPullDisable2C4 { get; set; }
Public Property GPIOPullDisable2C4 As Adp5588TypeGpioPull
    Get
    Set
public:
property Adp5588TypeGpioPull GPIOPullDisable2C4 {
    Adp5588TypeGpioPull get ();
    void set (Adp5588TypeGpioPull value);
}
member GPIOPullDisable2C4 : Adp5588TypeGpioPull with get, set

Property Value

Type: Adp5588TypeGpioPull
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOPullDisable2C5 Property

IRD

Adp5588GPIOPullDisable2C5 Property

GPIO Pull Disable 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioPull GPIOPullDisable2C5 { get; set; }
Public Property GPIOPullDisable2C5 As Adp5588TypeGpioPull
    Get
    Set
public:
property Adp5588TypeGpioPull GPIOPullDisable2C5 {
    Adp5588TypeGpioPull get ();
    void set (Adp5588TypeGpioPull value);
}
member GPIOPullDisable2C5 : Adp5588TypeGpioPull with get, set

Property Value

Type: Adp5588TypeGpioPull
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOPullDisable2C6 Property

IRD

Adp5588GPIOPullDisable2C6 Property

GPIO Pull Disable 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioPull GPIOPullDisable2C6 { get; set; }
Public Property GPIOPullDisable2C6 As Adp5588TypeGpioPull
    Get
    Set
public:
property Adp5588TypeGpioPull GPIOPullDisable2C6 {
    Adp5588TypeGpioPull get ();
    void set (Adp5588TypeGpioPull value);
}
member GPIOPullDisable2C6 : Adp5588TypeGpioPull with get, set

Property Value

Type: Adp5588TypeGpioPull
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOPullDisable2C7 Property

IRD

Adp5588GPIOPullDisable2C7 Property

GPIO Pull Disable 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioPull GPIOPullDisable2C7 { get; set; }
Public Property GPIOPullDisable2C7 As Adp5588TypeGpioPull
    Get
    Set
public:
property Adp5588TypeGpioPull GPIOPullDisable2C7 {
    Adp5588TypeGpioPull get ();
    void set (Adp5588TypeGpioPull value);
}
member GPIOPullDisable2C7 : Adp5588TypeGpioPull with get, set

Property Value

Type: Adp5588TypeGpioPull
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOPullDisable3C8 Property

IRD

Adp5588GPIOPullDisable3C8 Property

GPIO Pull Disable 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioPull GPIOPullDisable3C8 { get; set; }
Public Property GPIOPullDisable3C8 As Adp5588TypeGpioPull
    Get
    Set
public:
property Adp5588TypeGpioPull GPIOPullDisable3C8 {
    Adp5588TypeGpioPull get ();
    void set (Adp5588TypeGpioPull value);
}
member GPIOPullDisable3C8 : Adp5588TypeGpioPull with get, set

Property Value

Type: Adp5588TypeGpioPull
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.GPIOPullDisable3C9 Property

IRD

Adp5588GPIOPullDisable3C9 Property

GPIO Pull Disable 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeGpioPull GPIOPullDisable3C9 { get; set; }
Public Property GPIOPullDisable3C9 As Adp5588TypeGpioPull
    Get
    Set
public:
property Adp5588TypeGpioPull GPIOPullDisable3C9 {
    Adp5588TypeGpioPull get ();
    void set (Adp5588TypeGpioPull value);
}
member GPIOPullDisable3C9 : Adp5588TypeGpioPull with get, set

Property Value

Type: Adp5588TypeGpioPull
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.InterruptStatusCMP1INT Property

IRD

Adp5588InterruptStatusCMP1INT Property

Interrupt Status: CMP1_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeIntStatCmp1Int InterruptStatusCMP1INT { get; set; }
Public Property InterruptStatusCMP1INT As Adp5588TypeIntStatCmp1Int
    Get
    Set
public:
property Adp5588TypeIntStatCmp1Int InterruptStatusCMP1INT {
    Adp5588TypeIntStatCmp1Int get ();
    void set (Adp5588TypeIntStatCmp1Int value);
}
member InterruptStatusCMP1INT : Adp5588TypeIntStatCmp1Int with get, set

Property Value

Type: Adp5588TypeIntStatCmp1Int
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.InterruptStatusCMP2INT Property

IRD

Adp5588InterruptStatusCMP2INT Property

Interrupt Status: CMP2_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeIntStatCmp2Int InterruptStatusCMP2INT { get; set; }
Public Property InterruptStatusCMP2INT As Adp5588TypeIntStatCmp2Int
    Get
    Set
public:
property Adp5588TypeIntStatCmp2Int InterruptStatusCMP2INT {
    Adp5588TypeIntStatCmp2Int get ();
    void set (Adp5588TypeIntStatCmp2Int value);
}
member InterruptStatusCMP2INT : Adp5588TypeIntStatCmp2Int with get, set

Property Value

Type: Adp5588TypeIntStatCmp2Int
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.InterruptStatusGPIINT Property

IRD

Adp5588InterruptStatusGPIINT Property

Interrupt Status: GPI_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeIntStatGpiInt InterruptStatusGPIINT { get; set; }
Public Property InterruptStatusGPIINT As Adp5588TypeIntStatGpiInt
    Get
    Set
public:
property Adp5588TypeIntStatGpiInt InterruptStatusGPIINT {
    Adp5588TypeIntStatGpiInt get ();
    void set (Adp5588TypeIntStatGpiInt value);
}
member InterruptStatusGPIINT : Adp5588TypeIntStatGpiInt with get, set

Property Value

Type: Adp5588TypeIntStatGpiInt
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.InterruptStatusKEINT Property

IRD

Adp5588InterruptStatusKEINT Property

Interrupt Status: KE_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeIntStatKeInt InterruptStatusKEINT { get; set; }
Public Property InterruptStatusKEINT As Adp5588TypeIntStatKeInt
    Get
    Set
public:
property Adp5588TypeIntStatKeInt InterruptStatusKEINT {
    Adp5588TypeIntStatKeInt get ();
    void set (Adp5588TypeIntStatKeInt value);
}
member InterruptStatusKEINT : Adp5588TypeIntStatKeInt with get, set

Property Value

Type: Adp5588TypeIntStatKeInt
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.InterruptStatusKLCKINT Property

IRD

Adp5588InterruptStatusKLCKINT Property

Interrupt Status: K_LCK_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeIntStatKLckInt InterruptStatusKLCKINT { get; set; }
Public Property InterruptStatusKLCKINT As Adp5588TypeIntStatKLckInt
    Get
    Set
public:
property Adp5588TypeIntStatKLckInt InterruptStatusKLCKINT {
    Adp5588TypeIntStatKLckInt get ();
    void set (Adp5588TypeIntStatKLckInt value);
}
member InterruptStatusKLCKINT : Adp5588TypeIntStatKLckInt with get, set

Property Value

Type: Adp5588TypeIntStatKLckInt
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.InterruptStatusOVRFLOWINT Property

IRD

Adp5588InterruptStatusOVRFLOWINT Property

Interrupt Status: OVR_FLOW_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeIntStatOvrFlowInt InterruptStatusOVRFLOWINT { get; set; }
Public Property InterruptStatusOVRFLOWINT As Adp5588TypeIntStatOvrFlowInt
    Get
    Set
public:
property Adp5588TypeIntStatOvrFlowInt InterruptStatusOVRFLOWINT {
    Adp5588TypeIntStatOvrFlowInt get ();
    void set (Adp5588TypeIntStatOvrFlowInt value);
}
member InterruptStatusOVRFLOWINT : Adp5588TypeIntStatOvrFlowInt with get, set

Property Value

Type: Adp5588TypeIntStatOvrFlowInt
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventAKeyNumber Property

IRD

Adp5588KeyEventAKeyNumber Property

Key Event A: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventAKeyNumber { get; set; }
Public Property KeyEventAKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventAKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventAKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventAStatus Property

IRD

Adp5588KeyEventAStatus Property

Key Event A: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKeyEventStatus KeyEventAStatus { get; set; }
Public Property KeyEventAStatus As Adp5588TypeKeyEventStatus
    Get
    Set
public:
property Adp5588TypeKeyEventStatus KeyEventAStatus {
    Adp5588TypeKeyEventStatus get ();
    void set (Adp5588TypeKeyEventStatus value);
}
member KeyEventAStatus : Adp5588TypeKeyEventStatus with get, set

Property Value

Type: Adp5588TypeKeyEventStatus
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventBKeyNumber Property

IRD

Adp5588KeyEventBKeyNumber Property

Key Event B: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventBKeyNumber { get; set; }
Public Property KeyEventBKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventBKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventBKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventBStatus Property

IRD

Adp5588KeyEventBStatus Property

Key Event B: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKeyEventStatus KeyEventBStatus { get; set; }
Public Property KeyEventBStatus As Adp5588TypeKeyEventStatus
    Get
    Set
public:
property Adp5588TypeKeyEventStatus KeyEventBStatus {
    Adp5588TypeKeyEventStatus get ();
    void set (Adp5588TypeKeyEventStatus value);
}
member KeyEventBStatus : Adp5588TypeKeyEventStatus with get, set

Property Value

Type: Adp5588TypeKeyEventStatus
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventCKeyNumber Property

IRD

Adp5588KeyEventCKeyNumber Property

Key Event C: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventCKeyNumber { get; set; }
Public Property KeyEventCKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventCKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventCKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventCStatus Property

IRD

Adp5588KeyEventCStatus Property

Key Event C: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKeyEventStatus KeyEventCStatus { get; set; }
Public Property KeyEventCStatus As Adp5588TypeKeyEventStatus
    Get
    Set
public:
property Adp5588TypeKeyEventStatus KeyEventCStatus {
    Adp5588TypeKeyEventStatus get ();
    void set (Adp5588TypeKeyEventStatus value);
}
member KeyEventCStatus : Adp5588TypeKeyEventStatus with get, set

Property Value

Type: Adp5588TypeKeyEventStatus
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventDKeyNumber Property

IRD

Adp5588KeyEventDKeyNumber Property

Key Event D: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventDKeyNumber { get; set; }
Public Property KeyEventDKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventDKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventDKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventDStatus Property

IRD

Adp5588KeyEventDStatus Property

Key Event D: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKeyEventStatus KeyEventDStatus { get; set; }
Public Property KeyEventDStatus As Adp5588TypeKeyEventStatus
    Get
    Set
public:
property Adp5588TypeKeyEventStatus KeyEventDStatus {
    Adp5588TypeKeyEventStatus get ();
    void set (Adp5588TypeKeyEventStatus value);
}
member KeyEventDStatus : Adp5588TypeKeyEventStatus with get, set

Property Value

Type: Adp5588TypeKeyEventStatus
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventEKeyNumber Property

IRD

Adp5588KeyEventEKeyNumber Property

Key Event E: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventEKeyNumber { get; set; }
Public Property KeyEventEKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventEKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventEKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventEStatus Property

IRD

Adp5588KeyEventEStatus Property

Key Event E: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKeyEventStatus KeyEventEStatus { get; set; }
Public Property KeyEventEStatus As Adp5588TypeKeyEventStatus
    Get
    Set
public:
property Adp5588TypeKeyEventStatus KeyEventEStatus {
    Adp5588TypeKeyEventStatus get ();
    void set (Adp5588TypeKeyEventStatus value);
}
member KeyEventEStatus : Adp5588TypeKeyEventStatus with get, set

Property Value

Type: Adp5588TypeKeyEventStatus
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventFKeyNumber Property

IRD

Adp5588KeyEventFKeyNumber Property

Key Event F: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventFKeyNumber { get; set; }
Public Property KeyEventFKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventFKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventFKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventFStatus Property

IRD

Adp5588KeyEventFStatus Property

Key Event F: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKeyEventStatus KeyEventFStatus { get; set; }
Public Property KeyEventFStatus As Adp5588TypeKeyEventStatus
    Get
    Set
public:
property Adp5588TypeKeyEventStatus KeyEventFStatus {
    Adp5588TypeKeyEventStatus get ();
    void set (Adp5588TypeKeyEventStatus value);
}
member KeyEventFStatus : Adp5588TypeKeyEventStatus with get, set

Property Value

Type: Adp5588TypeKeyEventStatus
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventGKeyNumber Property

IRD

Adp5588KeyEventGKeyNumber Property

Key Event G: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventGKeyNumber { get; set; }
Public Property KeyEventGKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventGKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventGKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventGStatus Property

IRD

Adp5588KeyEventGStatus Property

Key Event G: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKeyEventStatus KeyEventGStatus { get; set; }
Public Property KeyEventGStatus As Adp5588TypeKeyEventStatus
    Get
    Set
public:
property Adp5588TypeKeyEventStatus KeyEventGStatus {
    Adp5588TypeKeyEventStatus get ();
    void set (Adp5588TypeKeyEventStatus value);
}
member KeyEventGStatus : Adp5588TypeKeyEventStatus with get, set

Property Value

Type: Adp5588TypeKeyEventStatus
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventHKeyNumber Property

IRD

Adp5588KeyEventHKeyNumber Property

Key Event H: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventHKeyNumber { get; set; }
Public Property KeyEventHKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventHKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventHKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventHStatus Property

IRD

Adp5588KeyEventHStatus Property

Key Event H: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKeyEventStatus KeyEventHStatus { get; set; }
Public Property KeyEventHStatus As Adp5588TypeKeyEventStatus
    Get
    Set
public:
property Adp5588TypeKeyEventStatus KeyEventHStatus {
    Adp5588TypeKeyEventStatus get ();
    void set (Adp5588TypeKeyEventStatus value);
}
member KeyEventHStatus : Adp5588TypeKeyEventStatus with get, set

Property Value

Type: Adp5588TypeKeyEventStatus
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventIKeyNumber Property

IRD

Adp5588KeyEventIKeyNumber Property

Key Event I: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventIKeyNumber { get; set; }
Public Property KeyEventIKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventIKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventIKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventIStatus Property

IRD

Adp5588KeyEventIStatus Property

Key Event I: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKeyEventStatus KeyEventIStatus { get; set; }
Public Property KeyEventIStatus As Adp5588TypeKeyEventStatus
    Get
    Set
public:
property Adp5588TypeKeyEventStatus KeyEventIStatus {
    Adp5588TypeKeyEventStatus get ();
    void set (Adp5588TypeKeyEventStatus value);
}
member KeyEventIStatus : Adp5588TypeKeyEventStatus with get, set

Property Value

Type: Adp5588TypeKeyEventStatus
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventJKeyNumber Property

IRD

Adp5588KeyEventJKeyNumber Property

Key Event J: Key Number

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeyEventJKeyNumber { get; set; }
Public Property KeyEventJKeyNumber As Byte
    Get
    Set
public:
property unsigned char KeyEventJKeyNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member KeyEventJKeyNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeyEventJStatus Property

IRD

Adp5588KeyEventJStatus Property

Key Event J: Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKeyEventStatus KeyEventJStatus { get; set; }
Public Property KeyEventJStatus As Adp5588TypeKeyEventStatus
    Get
    Set
public:
property Adp5588TypeKeyEventStatus KeyEventJStatus {
    Adp5588TypeKeyEventStatus get ();
    void set (Adp5588TypeKeyEventStatus value);
}
member KeyEventJStatus : Adp5588TypeKeyEventStatus with get, set

Property Value

Type: Adp5588TypeKeyEventStatus
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeylockEventCounterKEC Property

IRD

Adp5588KeylockEventCounterKEC Property

Keylock & Event Counter: KEC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte KeylockEventCounterKEC { get; set; }
Public Property KeylockEventCounterKEC As Byte
    Get
    Set
public:
property unsigned char KeylockEventCounterKEC {
    unsigned char get ();
    void set (unsigned char value);
}
member KeylockEventCounterKEC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeylockEventCounterKLCKEN Property

IRD

Adp5588KeylockEventCounterKLCKEN Property

Keylock & Event Counter: K_LCK_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKeyLckEcStatKLckEn KeylockEventCounterKLCKEN { get; set; }
Public Property KeylockEventCounterKLCKEN As Adp5588TypeKeyLckEcStatKLckEn
    Get
    Set
public:
property Adp5588TypeKeyLckEcStatKLckEn KeylockEventCounterKLCKEN {
    Adp5588TypeKeyLckEcStatKLckEn get ();
    void set (Adp5588TypeKeyLckEcStatKLckEn value);
}
member KeylockEventCounterKLCKEN : Adp5588TypeKeyLckEcStatKLckEn with get, set

Property Value

Type: Adp5588TypeKeyLckEcStatKLckEn
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeylockEventCounterLCK2LCK1 Property

IRD

Adp5588KeylockEventCounterLCK2LCK1 Property

Keylock & Event Counter: LCK2, LCK1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKeyLckEcStatLck2Lck1 KeylockEventCounterLCK2LCK1 { get; }
Public ReadOnly Property KeylockEventCounterLCK2LCK1 As Adp5588TypeKeyLckEcStatLck2Lck1
    Get
public:
property Adp5588TypeKeyLckEcStatLck2Lck1 KeylockEventCounterLCK2LCK1 {
    Adp5588TypeKeyLckEcStatLck2Lck1 get ();
}
member KeylockEventCounterLCK2LCK1 : Adp5588TypeKeyLckEcStatLck2Lck1 with get

Property Value

Type: Adp5588TypeKeyLckEcStatLck2Lck1
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadLockInterruptMaskTimer Property

IRD

Adp5588KeypadLockInterruptMaskTimer Property

Keypad Lock Interrupt Mask Timer (unit: s)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpLckTmrKllt KeypadLockInterruptMaskTimer { get; set; }
Public Property KeypadLockInterruptMaskTimer As Adp5588TypeKpLckTmrKllt
    Get
    Set
public:
property Adp5588TypeKpLckTmrKllt KeypadLockInterruptMaskTimer {
    Adp5588TypeKpLckTmrKllt get ();
    void set (Adp5588TypeKpLckTmrKllt value);
}
member KeypadLockInterruptMaskTimer : Adp5588TypeKpLckTmrKllt with get, set

Property Value

Type: Adp5588TypeKpLckTmrKllt
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadOrGPIOSelection1R0 Property

IRD

Adp5588KeypadOrGPIOSelection1R0 Property

Keypad or GPIO Selection 1: R0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpGpio KeypadOrGPIOSelection1R0 { get; set; }
Public Property KeypadOrGPIOSelection1R0 As Adp5588TypeKpGpio
    Get
    Set
public:
property Adp5588TypeKpGpio KeypadOrGPIOSelection1R0 {
    Adp5588TypeKpGpio get ();
    void set (Adp5588TypeKpGpio value);
}
member KeypadOrGPIOSelection1R0 : Adp5588TypeKpGpio with get, set

Property Value

Type: Adp5588TypeKpGpio
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadOrGPIOSelection1R1 Property

IRD

Adp5588KeypadOrGPIOSelection1R1 Property

Keypad or GPIO Selection 1: R1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpGpio KeypadOrGPIOSelection1R1 { get; set; }
Public Property KeypadOrGPIOSelection1R1 As Adp5588TypeKpGpio
    Get
    Set
public:
property Adp5588TypeKpGpio KeypadOrGPIOSelection1R1 {
    Adp5588TypeKpGpio get ();
    void set (Adp5588TypeKpGpio value);
}
member KeypadOrGPIOSelection1R1 : Adp5588TypeKpGpio with get, set

Property Value

Type: Adp5588TypeKpGpio
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadOrGPIOSelection1R2 Property

IRD

Adp5588KeypadOrGPIOSelection1R2 Property

Keypad or GPIO Selection 1: R2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpGpio KeypadOrGPIOSelection1R2 { get; set; }
Public Property KeypadOrGPIOSelection1R2 As Adp5588TypeKpGpio
    Get
    Set
public:
property Adp5588TypeKpGpio KeypadOrGPIOSelection1R2 {
    Adp5588TypeKpGpio get ();
    void set (Adp5588TypeKpGpio value);
}
member KeypadOrGPIOSelection1R2 : Adp5588TypeKpGpio with get, set

Property Value

Type: Adp5588TypeKpGpio
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadOrGPIOSelection1R3 Property

IRD

Adp5588KeypadOrGPIOSelection1R3 Property

Keypad or GPIO Selection 1: R3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpGpio KeypadOrGPIOSelection1R3 { get; set; }
Public Property KeypadOrGPIOSelection1R3 As Adp5588TypeKpGpio
    Get
    Set
public:
property Adp5588TypeKpGpio KeypadOrGPIOSelection1R3 {
    Adp5588TypeKpGpio get ();
    void set (Adp5588TypeKpGpio value);
}
member KeypadOrGPIOSelection1R3 : Adp5588TypeKpGpio with get, set

Property Value

Type: Adp5588TypeKpGpio
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadOrGPIOSelection1R4 Property

IRD

Adp5588KeypadOrGPIOSelection1R4 Property

Keypad or GPIO Selection 1: R4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpGpio KeypadOrGPIOSelection1R4 { get; set; }
Public Property KeypadOrGPIOSelection1R4 As Adp5588TypeKpGpio
    Get
    Set
public:
property Adp5588TypeKpGpio KeypadOrGPIOSelection1R4 {
    Adp5588TypeKpGpio get ();
    void set (Adp5588TypeKpGpio value);
}
member KeypadOrGPIOSelection1R4 : Adp5588TypeKpGpio with get, set

Property Value

Type: Adp5588TypeKpGpio
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadOrGPIOSelection1R5 Property

IRD

Adp5588KeypadOrGPIOSelection1R5 Property

Keypad or GPIO Selection 1: R5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpGpio KeypadOrGPIOSelection1R5 { get; set; }
Public Property KeypadOrGPIOSelection1R5 As Adp5588TypeKpGpio
    Get
    Set
public:
property Adp5588TypeKpGpio KeypadOrGPIOSelection1R5 {
    Adp5588TypeKpGpio get ();
    void set (Adp5588TypeKpGpio value);
}
member KeypadOrGPIOSelection1R5 : Adp5588TypeKpGpio with get, set

Property Value

Type: Adp5588TypeKpGpio
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadOrGPIOSelection1R6 Property

IRD

Adp5588KeypadOrGPIOSelection1R6 Property

Keypad or GPIO Selection 1: R6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpGpio KeypadOrGPIOSelection1R6 { get; set; }
Public Property KeypadOrGPIOSelection1R6 As Adp5588TypeKpGpio
    Get
    Set
public:
property Adp5588TypeKpGpio KeypadOrGPIOSelection1R6 {
    Adp5588TypeKpGpio get ();
    void set (Adp5588TypeKpGpio value);
}
member KeypadOrGPIOSelection1R6 : Adp5588TypeKpGpio with get, set

Property Value

Type: Adp5588TypeKpGpio
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadOrGPIOSelection1R7 Property

IRD

Adp5588KeypadOrGPIOSelection1R7 Property

Keypad or GPIO Selection 1: R7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpGpio KeypadOrGPIOSelection1R7 { get; set; }
Public Property KeypadOrGPIOSelection1R7 As Adp5588TypeKpGpio
    Get
    Set
public:
property Adp5588TypeKpGpio KeypadOrGPIOSelection1R7 {
    Adp5588TypeKpGpio get ();
    void set (Adp5588TypeKpGpio value);
}
member KeypadOrGPIOSelection1R7 : Adp5588TypeKpGpio with get, set

Property Value

Type: Adp5588TypeKpGpio
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadOrGPIOSelection2C0 Property

IRD

Adp5588KeypadOrGPIOSelection2C0 Property

Keypad or GPIO Selection 2: C0

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpGpio KeypadOrGPIOSelection2C0 { get; set; }
Public Property KeypadOrGPIOSelection2C0 As Adp5588TypeKpGpio
    Get
    Set
public:
property Adp5588TypeKpGpio KeypadOrGPIOSelection2C0 {
    Adp5588TypeKpGpio get ();
    void set (Adp5588TypeKpGpio value);
}
member KeypadOrGPIOSelection2C0 : Adp5588TypeKpGpio with get, set

Property Value

Type: Adp5588TypeKpGpio
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadOrGPIOSelection2C1 Property

IRD

Adp5588KeypadOrGPIOSelection2C1 Property

Keypad or GPIO Selection 2: C1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpGpio KeypadOrGPIOSelection2C1 { get; set; }
Public Property KeypadOrGPIOSelection2C1 As Adp5588TypeKpGpio
    Get
    Set
public:
property Adp5588TypeKpGpio KeypadOrGPIOSelection2C1 {
    Adp5588TypeKpGpio get ();
    void set (Adp5588TypeKpGpio value);
}
member KeypadOrGPIOSelection2C1 : Adp5588TypeKpGpio with get, set

Property Value

Type: Adp5588TypeKpGpio
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadOrGPIOSelection2C2 Property

IRD

Adp5588KeypadOrGPIOSelection2C2 Property

Keypad or GPIO Selection 2: C2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpGpio KeypadOrGPIOSelection2C2 { get; set; }
Public Property KeypadOrGPIOSelection2C2 As Adp5588TypeKpGpio
    Get
    Set
public:
property Adp5588TypeKpGpio KeypadOrGPIOSelection2C2 {
    Adp5588TypeKpGpio get ();
    void set (Adp5588TypeKpGpio value);
}
member KeypadOrGPIOSelection2C2 : Adp5588TypeKpGpio with get, set

Property Value

Type: Adp5588TypeKpGpio
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadOrGPIOSelection2C3 Property

IRD

Adp5588KeypadOrGPIOSelection2C3 Property

Keypad or GPIO Selection 2: C3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpGpio KeypadOrGPIOSelection2C3 { get; set; }
Public Property KeypadOrGPIOSelection2C3 As Adp5588TypeKpGpio
    Get
    Set
public:
property Adp5588TypeKpGpio KeypadOrGPIOSelection2C3 {
    Adp5588TypeKpGpio get ();
    void set (Adp5588TypeKpGpio value);
}
member KeypadOrGPIOSelection2C3 : Adp5588TypeKpGpio with get, set

Property Value

Type: Adp5588TypeKpGpio
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadOrGPIOSelection2C4 Property

IRD

Adp5588KeypadOrGPIOSelection2C4 Property

Keypad or GPIO Selection 2: C4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpGpio KeypadOrGPIOSelection2C4 { get; set; }
Public Property KeypadOrGPIOSelection2C4 As Adp5588TypeKpGpio
    Get
    Set
public:
property Adp5588TypeKpGpio KeypadOrGPIOSelection2C4 {
    Adp5588TypeKpGpio get ();
    void set (Adp5588TypeKpGpio value);
}
member KeypadOrGPIOSelection2C4 : Adp5588TypeKpGpio with get, set

Property Value

Type: Adp5588TypeKpGpio
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadOrGPIOSelection2C5 Property

IRD

Adp5588KeypadOrGPIOSelection2C5 Property

Keypad or GPIO Selection 2: C5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpGpio KeypadOrGPIOSelection2C5 { get; set; }
Public Property KeypadOrGPIOSelection2C5 As Adp5588TypeKpGpio
    Get
    Set
public:
property Adp5588TypeKpGpio KeypadOrGPIOSelection2C5 {
    Adp5588TypeKpGpio get ();
    void set (Adp5588TypeKpGpio value);
}
member KeypadOrGPIOSelection2C5 : Adp5588TypeKpGpio with get, set

Property Value

Type: Adp5588TypeKpGpio
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadOrGPIOSelection2C6 Property

IRD

Adp5588KeypadOrGPIOSelection2C6 Property

Keypad or GPIO Selection 2: C6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpGpio KeypadOrGPIOSelection2C6 { get; set; }
Public Property KeypadOrGPIOSelection2C6 As Adp5588TypeKpGpio
    Get
    Set
public:
property Adp5588TypeKpGpio KeypadOrGPIOSelection2C6 {
    Adp5588TypeKpGpio get ();
    void set (Adp5588TypeKpGpio value);
}
member KeypadOrGPIOSelection2C6 : Adp5588TypeKpGpio with get, set

Property Value

Type: Adp5588TypeKpGpio
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadOrGPIOSelection2C7 Property

IRD

Adp5588KeypadOrGPIOSelection2C7 Property

Keypad or GPIO Selection 2: C7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpGpio KeypadOrGPIOSelection2C7 { get; set; }
Public Property KeypadOrGPIOSelection2C7 As Adp5588TypeKpGpio
    Get
    Set
public:
property Adp5588TypeKpGpio KeypadOrGPIOSelection2C7 {
    Adp5588TypeKpGpio get ();
    void set (Adp5588TypeKpGpio value);
}
member KeypadOrGPIOSelection2C7 : Adp5588TypeKpGpio with get, set

Property Value

Type: Adp5588TypeKpGpio
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadOrGPIOSelection3C8 Property

IRD

Adp5588KeypadOrGPIOSelection3C8 Property

Keypad or GPIO Selection 3: C8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpGpio KeypadOrGPIOSelection3C8 { get; set; }
Public Property KeypadOrGPIOSelection3C8 As Adp5588TypeKpGpio
    Get
    Set
public:
property Adp5588TypeKpGpio KeypadOrGPIOSelection3C8 {
    Adp5588TypeKpGpio get ();
    void set (Adp5588TypeKpGpio value);
}
member KeypadOrGPIOSelection3C8 : Adp5588TypeKpGpio with get, set

Property Value

Type: Adp5588TypeKpGpio
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadOrGPIOSelection3C9 Property

IRD

Adp5588KeypadOrGPIOSelection3C9 Property

Keypad or GPIO Selection 3: C9

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpGpio KeypadOrGPIOSelection3C9 { get; set; }
Public Property KeypadOrGPIOSelection3C9 As Adp5588TypeKpGpio
    Get
    Set
public:
property Adp5588TypeKpGpio KeypadOrGPIOSelection3C9 {
    Adp5588TypeKpGpio get ();
    void set (Adp5588TypeKpGpio value);
}
member KeypadOrGPIOSelection3C9 : Adp5588TypeKpGpio with get, set

Property Value

Type: Adp5588TypeKpGpio
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.KeypadUnlock1TimerToKeypadUnlock2Timer Property

IRD

Adp5588KeypadUnlock1TimerToKeypadUnlock2Timer Property

Keypad Unlock 1 Timer to Keypad Unlock 2 Timer (unit: s)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeKpLckTmrKimt KeypadUnlock1TimerToKeypadUnlock2Timer { get; set; }
Public Property KeypadUnlock1TimerToKeypadUnlock2Timer As Adp5588TypeKpLckTmrKimt
    Get
    Set
public:
property Adp5588TypeKpLckTmrKimt KeypadUnlock1TimerToKeypadUnlock2Timer {
    Adp5588TypeKpLckTmrKimt get ();
    void set (Adp5588TypeKpLckTmrKimt value);
}
member KeypadUnlock1TimerToKeypadUnlock2Timer : Adp5588TypeKpLckTmrKimt with get, set

Property Value

Type: Adp5588TypeKpLckTmrKimt
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Sensor1ComparatorConfigurationFILT Property

IRD

Adp5588Sensor1ComparatorConfigurationFILT Property

Sensor 1 Comparator Configuration: FILT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Sensor1ComparatorConfigurationFILT { get; set; }
Public Property Sensor1ComparatorConfigurationFILT As Byte
    Get
    Set
public:
property unsigned char Sensor1ComparatorConfigurationFILT {
    unsigned char get ();
    void set (unsigned char value);
}
member Sensor1ComparatorConfigurationFILT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Sensor1ComparatorConfigurationFORCERD Property

IRD

Adp5588Sensor1ComparatorConfigurationFORCERD Property

Sensor 1 Comparator Configuration: FORCE_RD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCmpConfgSensForceRd Sensor1ComparatorConfigurationFORCERD { get; set; }
Public Property Sensor1ComparatorConfigurationFORCERD As Adp5588TypeCmpConfgSensForceRd
    Get
    Set
public:
property Adp5588TypeCmpConfgSensForceRd Sensor1ComparatorConfigurationFORCERD {
    Adp5588TypeCmpConfgSensForceRd get ();
    void set (Adp5588TypeCmpConfgSensForceRd value);
}
member Sensor1ComparatorConfigurationFORCERD : Adp5588TypeCmpConfgSensForceRd with get, set

Property Value

Type: Adp5588TypeCmpConfgSensForceRd
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Sensor1ComparatorConfigurationL2EN Property

IRD

Adp5588Sensor1ComparatorConfigurationL2EN Property

Sensor 1 Comparator Configuration: L2_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCmpConfgSensL2En Sensor1ComparatorConfigurationL2EN { get; set; }
Public Property Sensor1ComparatorConfigurationL2EN As Adp5588TypeCmpConfgSensL2En
    Get
    Set
public:
property Adp5588TypeCmpConfgSensL2En Sensor1ComparatorConfigurationL2EN {
    Adp5588TypeCmpConfgSensL2En get ();
    void set (Adp5588TypeCmpConfgSensL2En value);
}
member Sensor1ComparatorConfigurationL2EN : Adp5588TypeCmpConfgSensL2En with get, set

Property Value

Type: Adp5588TypeCmpConfgSensL2En
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Sensor1ComparatorConfigurationL3EN Property

IRD

Adp5588Sensor1ComparatorConfigurationL3EN Property

Sensor 1 Comparator Configuration: L3_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCmpConfgSensL3En Sensor1ComparatorConfigurationL3EN { get; set; }
Public Property Sensor1ComparatorConfigurationL3EN As Adp5588TypeCmpConfgSensL3En
    Get
    Set
public:
property Adp5588TypeCmpConfgSensL3En Sensor1ComparatorConfigurationL3EN {
    Adp5588TypeCmpConfgSensL3En get ();
    void set (Adp5588TypeCmpConfgSensL3En value);
}
member Sensor1ComparatorConfigurationL3EN : Adp5588TypeCmpConfgSensL3En with get, set

Property Value

Type: Adp5588TypeCmpConfgSensL3En
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Sensor1ComparatorLevel2Hysteresis Property

IRD

Adp5588Sensor1ComparatorLevel2Hysteresis Property

Sensor 1 Comparator Level 2 Hysteresis (unit: μA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Sensor1ComparatorLevel2Hysteresis { get; set; }
Public Property Sensor1ComparatorLevel2Hysteresis As Double
    Get
    Set
public:
property double Sensor1ComparatorLevel2Hysteresis {
    double get ();
    void set (double value);
}
member Sensor1ComparatorLevel2Hysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Sensor1ComparatorLevel2Reference Property

IRD

Adp5588Sensor1ComparatorLevel2Reference Property

Sensor 1 Comparator Level 2 Reference (unit: μA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Sensor1ComparatorLevel2Reference { get; set; }
Public Property Sensor1ComparatorLevel2Reference As Double
    Get
    Set
public:
property double Sensor1ComparatorLevel2Reference {
    double get ();
    void set (double value);
}
member Sensor1ComparatorLevel2Reference : float with get, set

Property Value

Type: Double
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Sensor1ComparatorLevel3Hysteresis Property

IRD

Adp5588Sensor1ComparatorLevel3Hysteresis Property

Sensor 1 Comparator Level 3 Hysteresis (unit: μA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Sensor1ComparatorLevel3Hysteresis { get; set; }
Public Property Sensor1ComparatorLevel3Hysteresis As Double
    Get
    Set
public:
property double Sensor1ComparatorLevel3Hysteresis {
    double get ();
    void set (double value);
}
member Sensor1ComparatorLevel3Hysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Sensor1ComparatorLevel3Reference Property

IRD

Adp5588Sensor1ComparatorLevel3Reference Property

Sensor 1 Comparator Level 3 Reference (unit: μA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Sensor1ComparatorLevel3Reference { get; set; }
Public Property Sensor1ComparatorLevel3Reference As Double
    Get
    Set
public:
property double Sensor1ComparatorLevel3Reference {
    double get ();
    void set (double value);
}
member Sensor1ComparatorLevel3Reference : float with get, set

Property Value

Type: Double
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Sensor2ComparatorConfigurationFILT Property

IRD

Adp5588Sensor2ComparatorConfigurationFILT Property

Sensor 2 Comparator Configuration: FILT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Sensor2ComparatorConfigurationFILT { get; set; }
Public Property Sensor2ComparatorConfigurationFILT As Byte
    Get
    Set
public:
property unsigned char Sensor2ComparatorConfigurationFILT {
    unsigned char get ();
    void set (unsigned char value);
}
member Sensor2ComparatorConfigurationFILT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Sensor2ComparatorConfigurationFORCERD Property

IRD

Adp5588Sensor2ComparatorConfigurationFORCERD Property

Sensor 2 Comparator Configuration: FORCE_RD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCmpConfgSensForceRd Sensor2ComparatorConfigurationFORCERD { get; set; }
Public Property Sensor2ComparatorConfigurationFORCERD As Adp5588TypeCmpConfgSensForceRd
    Get
    Set
public:
property Adp5588TypeCmpConfgSensForceRd Sensor2ComparatorConfigurationFORCERD {
    Adp5588TypeCmpConfgSensForceRd get ();
    void set (Adp5588TypeCmpConfgSensForceRd value);
}
member Sensor2ComparatorConfigurationFORCERD : Adp5588TypeCmpConfgSensForceRd with get, set

Property Value

Type: Adp5588TypeCmpConfgSensForceRd
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Sensor2ComparatorConfigurationL2EN Property

IRD

Adp5588Sensor2ComparatorConfigurationL2EN Property

Sensor 2 Comparator Configuration: L2_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCmpConfgSensL2En Sensor2ComparatorConfigurationL2EN { get; set; }
Public Property Sensor2ComparatorConfigurationL2EN As Adp5588TypeCmpConfgSensL2En
    Get
    Set
public:
property Adp5588TypeCmpConfgSensL2En Sensor2ComparatorConfigurationL2EN {
    Adp5588TypeCmpConfgSensL2En get ();
    void set (Adp5588TypeCmpConfgSensL2En value);
}
member Sensor2ComparatorConfigurationL2EN : Adp5588TypeCmpConfgSensL2En with get, set

Property Value

Type: Adp5588TypeCmpConfgSensL2En
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Sensor2ComparatorConfigurationL3EN Property

IRD

Adp5588Sensor2ComparatorConfigurationL3EN Property

Sensor 2 Comparator Configuration: L3_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeCmpConfgSensL3En Sensor2ComparatorConfigurationL3EN { get; set; }
Public Property Sensor2ComparatorConfigurationL3EN As Adp5588TypeCmpConfgSensL3En
    Get
    Set
public:
property Adp5588TypeCmpConfgSensL3En Sensor2ComparatorConfigurationL3EN {
    Adp5588TypeCmpConfgSensL3En get ();
    void set (Adp5588TypeCmpConfgSensL3En value);
}
member Sensor2ComparatorConfigurationL3EN : Adp5588TypeCmpConfgSensL3En with get, set

Property Value

Type: Adp5588TypeCmpConfgSensL3En
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Sensor2ComparatorLevel2Hysteresis Property

IRD

Adp5588Sensor2ComparatorLevel2Hysteresis Property

Sensor 2 Comparator Level 2 Hysteresis (unit: μA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Sensor2ComparatorLevel2Hysteresis { get; set; }
Public Property Sensor2ComparatorLevel2Hysteresis As Double
    Get
    Set
public:
property double Sensor2ComparatorLevel2Hysteresis {
    double get ();
    void set (double value);
}
member Sensor2ComparatorLevel2Hysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Sensor2ComparatorLevel2Reference Property

IRD

Adp5588Sensor2ComparatorLevel2Reference Property

Sensor 2 Comparator Level 2 Reference (unit: μA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Sensor2ComparatorLevel2Reference { get; set; }
Public Property Sensor2ComparatorLevel2Reference As Double
    Get
    Set
public:
property double Sensor2ComparatorLevel2Reference {
    double get ();
    void set (double value);
}
member Sensor2ComparatorLevel2Reference : float with get, set

Property Value

Type: Double
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Sensor2ComparatorLevel3Hysteresis Property

IRD

Adp5588Sensor2ComparatorLevel3Hysteresis Property

Sensor 2 Comparator Level 3 Hysteresis (unit: μA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Sensor2ComparatorLevel3Hysteresis { get; set; }
Public Property Sensor2ComparatorLevel3Hysteresis As Double
    Get
    Set
public:
property double Sensor2ComparatorLevel3Hysteresis {
    double get ();
    void set (double value);
}
member Sensor2ComparatorLevel3Hysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Sensor2ComparatorLevel3Reference Property

IRD

Adp5588Sensor2ComparatorLevel3Reference Property

Sensor 2 Comparator Level 3 Reference (unit: μA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Sensor2ComparatorLevel3Reference { get; set; }
Public Property Sensor2ComparatorLevel3Reference As Double
    Get
    Set
public:
property double Sensor2ComparatorLevel3Reference {
    double get ();
    void set (double value);
}
member Sensor2ComparatorLevel3Reference : float with get, set

Property Value

Type: Double
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.UnlockKey1 Property

IRD

Adp5588UnlockKey1 Property

Unlock Key 1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeUnlock UnlockKey1 { get; set; }
Public Property UnlockKey1 As Adp5588TypeUnlock
    Get
    Set
public:
property Adp5588TypeUnlock UnlockKey1 {
    Adp5588TypeUnlock get ();
    void set (Adp5588TypeUnlock value);
}
member UnlockKey1 : Adp5588TypeUnlock with get, set

Property Value

Type: Adp5588TypeUnlock
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.UnlockKey2 Property

IRD

Adp5588UnlockKey2 Property

Unlock Key 2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5588TypeUnlock UnlockKey2 { get; set; }
Public Property UnlockKey2 As Adp5588TypeUnlock
    Get
    Set
public:
property Adp5588TypeUnlock UnlockKey2 {
    Adp5588TypeUnlock get ();
    void set (Adp5588TypeUnlock value);
}
member UnlockKey2 : Adp5588TypeUnlock with get, set

Property Value

Type: Adp5588TypeUnlock
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588 Methods

The Adp5588 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.Flush Method

IRD

Adp5588Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adp5588 Class
telos.Ird.AnalogDevices Namespace


Adp5588.TypeCfgAutoInc Enumeration

IRD

Adp5588TypeCfgAutoInc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgAutoInc
Public Enumeration TypeCfgAutoInc
public enum class TypeCfgAutoInc
type TypeCfgAutoInc
Members
Member name | Value | Description
I2CAutoIncrementOn | 1 | I2C auto-increment: on
I2CAutoIncrementOff | 0 | I2C auto-increment: off
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeCfgGpiemCfg Enumeration

IRD

Adp5588TypeCfgGpiemCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgGpiemCfg
Public Enumeration TypeCfgGpiemCfg
public enum class TypeCfgGpiemCfg
type TypeCfgGpiemCfg
Members
Member name | Value | Description
GPIEventsNotTracked | 1 | GPI events: not tracked
GPIEventsTracked | 0 | GPI events: tracked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeCfgGpiIen Enumeration

IRD

Adp5588TypeCfgGpiIen Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgGpiIen
Public Enumeration TypeCfgGpiIen
public enum class TypeCfgGpiIen
type TypeCfgGpiIen
Members
Member name | Value | Description
GPIInterruptEnabled | 1 | GPI interrupt: enabled
GPIInterruptDisabled | 0 | GPI interrupt: disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeCfgIntCfg Enumeration

IRD

Adp5588TypeCfgIntCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgIntCfg
Public Enumeration TypeCfgIntCfg
public enum class TypeCfgIntCfg
type TypeCfgIntCfg
Members
Member name | Value | Description
ProcessorInterruptDeassertedFor275us | 1 | Processor interrupt: deasserted for 275µs
ProcessorInterruptRemainsAsserted | 0 | Processor interrupt: remains asserted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeCfgKeIen Enumeration

IRD

Adp5588TypeCfgKeIen Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgKeIen
Public Enumeration TypeCfgKeIen
public enum class TypeCfgKeIen
type TypeCfgKeIen
Members
Member name | Value | Description
KeyEventsInterruptEnabled | 1 | Key events interrupt: enabled
KeyEventsInterruptDisabled | 0 | Key events interrupt: disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeCfgKLckM Enumeration

IRD

Adp5588TypeCfgKLckM Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgKLckM
Public Enumeration TypeCfgKLckM
public enum class TypeCfgKLckM
type TypeCfgKLckM
Members
Member name | Value | Description
KeypadLockEnabled | 1 | Keypad lock: enabled
KeypadLockDisabled | 0 | Keypad lock: disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeCfgOvrFlowIen Enumeration

IRD

Adp5588TypeCfgOvrFlowIen Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgOvrFlowIen
Public Enumeration TypeCfgOvrFlowIen
public enum class TypeCfgOvrFlowIen
type TypeCfgOvrFlowIen
Members
Member name | Value | Description
OverflowInterruptEnabled | 1 | Overflow interrupt: enabled
OverflowInterruptDisabled | 0 | Overflow interrupt: disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeCfgOvrFlowM Enumeration

IRD

Adp5588TypeCfgOvrFlowM Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgOvrFlowM
Public Enumeration TypeCfgOvrFlowM
public enum class TypeCfgOvrFlowM
type TypeCfgOvrFlowM
Members
Member name | Value | Description
OverflowModeOn | 1 | Overflow mode: on
OverflowModeOff | 0 | Overflow mode: off
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeCmpCfgStatCmp1L2Out Enumeration

IRD

Adp5588TypeCmpCfgStatCmp1L2Out Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCmpCfgStatCmp1L2Out
Public Enumeration TypeCmpCfgStatCmp1L2Out
public enum class TypeCmpCfgStatCmp1L2Out
type TypeCmpCfgStatCmp1L2Out
Members
Member name | Value | Description
Sensor1GreatedThanL2 | 0 | Sensor 1: greated than L2
Sensor1ChangeFromL1ToL2 | 1 | Sensor 1: change from L1 to L2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeCmpCfgStatCmp1L3Out Enumeration

IRD

Adp5588TypeCmpCfgStatCmp1L3Out Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCmpCfgStatCmp1L3Out
Public Enumeration TypeCmpCfgStatCmp1L3Out
public enum class TypeCmpCfgStatCmp1L3Out
type TypeCmpCfgStatCmp1L3Out
Members
Member name | Value | Description
Sensor1GreatedThanL3 | 0 | Sensor 1: greated than L3
Sensor1ChangeFromL2ToL3 | 1 | Sensor 1: change from L2 to L3
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeCmpCfgStatCmp2L2Out Enumeration

IRD

Adp5588TypeCmpCfgStatCmp2L2Out Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCmpCfgStatCmp2L2Out
Public Enumeration TypeCmpCfgStatCmp2L2Out
public enum class TypeCmpCfgStatCmp2L2Out
type TypeCmpCfgStatCmp2L2Out
Members
Member name | Value | Description
Sensor2GreatedThanL2 | 0 | Sensor 2: greated than L2
Sensor2ChangeFromL1ToL2 | 1 | Sensor 2: change from L1 to L2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeCmpCfgStatCmp2L3Out Enumeration

IRD

Adp5588TypeCmpCfgStatCmp2L3Out Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCmpCfgStatCmp2L3Out
Public Enumeration TypeCmpCfgStatCmp2L3Out
public enum class TypeCmpCfgStatCmp2L3Out
type TypeCmpCfgStatCmp2L3Out
Members
Member name | Value | Description
Sensor2GreatedThanL3 | 0 | Sensor 2: greated than L3
Sensor2ChangeFromL2ToL3 | 1 | Sensor 2: change from L2 to L3
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeCmpCfgStatCmpEn Enumeration

IRD

Adp5588TypeCmpCfgStatCmpEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCmpCfgStatCmpEn
Public Enumeration TypeCmpCfgStatCmpEn
public enum class TypeCmpCfgStatCmpEn
type TypeCmpCfgStatCmpEn
Members
Member name | Value | Description
InputDisabled | 0 | Input: disabled
InputEnabled | 1 | Input: enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeCmpCfgStatCmpIen Enumeration

IRD

Adp5588TypeCmpCfgStatCmpIen Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCmpCfgStatCmpIen
Public Enumeration TypeCmpCfgStatCmpIen
public enum class TypeCmpCfgStatCmpIen
type TypeCmpCfgStatCmpIen
Members
Member name | Value | Description
InterruptDisabled | 0 | Interrupt: disabled
InterruptEnabled | 1 | Interrupt: enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeCmpConfgSensForceRd Enumeration

IRD

Adp5588TypeCmpConfgSensForceRd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCmpConfgSensForceRd
Public Enumeration TypeCmpConfgSensForceRd
public enum class TypeCmpConfgSensForceRd
type TypeCmpConfgSensForceRd
Members
Member name | Value | Description
ReadLightSensor | 1 | Read light sensor
Default | 0 | Default
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeCmpConfgSensL2En Enumeration

IRD

Adp5588TypeCmpConfgSensL2En Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCmpConfgSensL2En
Public Enumeration TypeCmpConfgSensL2En
public enum class TypeCmpConfgSensL2En
type TypeCmpConfgSensL2En
Members
Member name | Value | Description
L2ComparatorEnabled | 1 | L2 comparator: enabled
L2ComparatorDisabled | 0 | L2 comparator: disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeCmpConfgSensL3En Enumeration

IRD

Adp5588TypeCmpConfgSensL3En Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCmpConfgSensL3En
Public Enumeration TypeCmpConfgSensL3En
public enum class TypeCmpConfgSensL3En
type TypeCmpConfgSensL3En
Members
Member name | Value | Description
L3ComparatorEnabled | 1 | L3 comparator: enabled
L3ComparatorDisabled | 0 | L3 comparator: disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeGpiEmReg Enumeration

IRD

Adp5588TypeGpiEmReg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpiEmReg
Public Enumeration TypeGpiEmReg
public enum class TypeGpiEmReg
type TypeGpiEmReg
Members
Member name | Value | Description
GPINotPartOfEventFIFO | 0 | GPI: Not part of event FIFO
GPIPartOfEventFIFO | 1 | GPI: Part of event FIFO
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeGpioDir Enumeration

IRD

Adp5588TypeGpioDir Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioDir
Public Enumeration TypeGpioDir
public enum class TypeGpioDir
type TypeGpioDir
Members
Member name | Value | Description
Input | 0 | Input
Output | 1 | Output
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeGpioIntLvl Enumeration

IRD

Adp5588TypeGpioIntLvl Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioIntLvl
Public Enumeration TypeGpioIntLvl
public enum class TypeGpioIntLvl
type TypeGpioIntLvl
Members
Member name | Value | Description
Low | 0 | Low
High | 1 | High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeGpioPull Enumeration

IRD

Adp5588TypeGpioPull Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioPull
Public Enumeration TypeGpioPull
public enum class TypeGpioPull
type TypeGpioPull
Members
Member name | Value | Description
PullEnabled | 0 | Pull: enabled
PullDisabled | 1 | Pull: disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeIntStatCmp1Int Enumeration

IRD

Adp5588TypeIntStatCmp1Int Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntStatCmp1Int
Public Enumeration TypeIntStatCmp1Int
public enum class TypeIntStatCmp1Int
type TypeIntStatCmp1Int
Members
Member name | Value | Description
Comparator1InterruptDetected | 1 | Comparator 1 interrupt: detected
Comparator1InterruptNotDetected | 0 | Comparator 1 interrupt: not detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeIntStatCmp2Int Enumeration

IRD

Adp5588TypeIntStatCmp2Int Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntStatCmp2Int
Public Enumeration TypeIntStatCmp2Int
public enum class TypeIntStatCmp2Int
type TypeIntStatCmp2Int
Members
Member name | Value | Description
Comparator2InterruptDetected | 1 | Comparator 2 interrupt: detected
Comparator2InterruptNotDetected | 0 | Comparator 2 interrupt: not detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeIntStatGpiInt Enumeration

IRD

Adp5588TypeIntStatGpiInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntStatGpiInt
Public Enumeration TypeIntStatGpiInt
public enum class TypeIntStatGpiInt
type TypeIntStatGpiInt
Members
Member name | Value | Description
GPIInterruptDetected | 1 | GPI interrupt: detected
GPIInterruptNotDetected | 0 | GPI interrupt: not detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeIntStatKeInt Enumeration

IRD

Adp5588TypeIntStatKeInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntStatKeInt
Public Enumeration TypeIntStatKeInt
public enum class TypeIntStatKeInt
type TypeIntStatKeInt
Members
Member name | Value | Description
KeyEventsInterruptDetected | 1 | Key events interrupt: detected
KeyEventsInterruptNotDetected | 0 | Key events interrupt: not detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeIntStatKLckInt Enumeration

IRD

Adp5588TypeIntStatKLckInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntStatKLckInt
Public Enumeration TypeIntStatKLckInt
public enum class TypeIntStatKLckInt
type TypeIntStatKLckInt
Members
Member name | Value | Description
KeylockInterruptDetected | 1 | Keylock interrupt: detected
KeylockInterruptNotDetected | 0 | Keylock interrupt: not detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeIntStatOvrFlowInt Enumeration

IRD

Adp5588TypeIntStatOvrFlowInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntStatOvrFlowInt
Public Enumeration TypeIntStatOvrFlowInt
public enum class TypeIntStatOvrFlowInt
type TypeIntStatOvrFlowInt
Members
Member name | Value | Description
OverflowInterruptDetected | 1 | Overflow interrupt: detected
OverflowInterruptNotDetected | 0 | Overflow interrupt: not detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeKeyEventStatus Enumeration

IRD

Adp5588TypeKeyEventStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeKeyEventStatus
Public Enumeration TypeKeyEventStatus
public enum class TypeKeyEventStatus
type TypeKeyEventStatus
Members
Member name | Value | Description
Released | 0 | Released
Pressed | 1 | Pressed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeKeyLckEcStatKLckEn Enumeration

IRD

Adp5588TypeKeyLckEcStatKLckEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeKeyLckEcStatKLckEn
Public Enumeration TypeKeyLckEcStatKLckEn
public enum class TypeKeyLckEcStatKLckEn
type TypeKeyLckEcStatKLckEn
Members
Member name | Value | Description
LockFeatureDisabled | 0 | Lock feature: disabled
LockFeatureEnabled | 1 | Lock feature: enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeKeyLckEcStatLck2Lck1 Enumeration

IRD

Adp5588TypeKeyLckEcStatLck2Lck1 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeKeyLckEcStatLck2Lck1
Public Enumeration TypeKeyLckEcStatLck2Lck1
public enum class TypeKeyLckEcStatLck2Lck1
type TypeKeyLckEcStatLck2Lck1
Members
Member name | Value | Description
KeypadLockStatusUnlocked | 0 | Keypad lock status: unlocked
KeypadLockStatusLocked | 3 | Keypad lock status: locked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeKpGpio Enumeration

IRD

Adp5588TypeKpGpio Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeKpGpio
Public Enumeration TypeKpGpio
public enum class TypeKpGpio
type TypeKpGpio
Members
Member name | Value | Description
GPIO | 0 | GPIO
KPMatrix | 1 | KP matrix
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeKpLckTmrKimt Enumeration

IRD

Adp5588TypeKpLckTmrKimt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeKpLckTmrKimt
Public Enumeration TypeKpLckTmrKimt
public enum class TypeKpLckTmrKimt
type TypeKpLckTmrKimt
Members
Member name | Value | Description
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeKpLckTmrKllt Enumeration

IRD

Adp5588TypeKpLckTmrKllt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeKpLckTmrKllt
Public Enumeration TypeKpLckTmrKllt
public enum class TypeKpLckTmrKllt
type TypeKpLckTmrKllt
Members
Member name | Value | Description
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5588.TypeUnlock Enumeration

IRD

Adp5588TypeUnlock Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeUnlock
Public Enumeration TypeUnlock
public enum class TypeUnlock
type TypeUnlock
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589 Class

Analog Devices: ADP 5589
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdp5589

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adp5589
Public Class Adp5589
public ref class Adp5589
type Adp5589 =  class end

The Adp5589 type exposes the following members.

Constructors
 | Name | Description
Public method | Adp5589 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CLOCKDIVCFGCLKDIV | CLOCK_DIV_CFG: CLK_DIV
Public property | CLOCKDIVCFGCLKDIVEN | CLOCK_DIV_CFG: CLK_DIV_EN
Public property | CLOCKDIVCFGCLKINV | CLOCK_DIV_CFG: CLK_INV
Public property | DEBOUNCEDISAGPI1DEBDIS | DEBOUNCE_DIS_A: GPI_1_DEB_DIS
Public property | DEBOUNCEDISAGPI2DEBDIS | DEBOUNCE_DIS_A: GPI_2_DEB_DIS
Public property | DEBOUNCEDISAGPI3DEBDIS | DEBOUNCE_DIS_A: GPI_3_DEB_DIS
Public property | DEBOUNCEDISAGPI4DEBDIS | DEBOUNCE_DIS_A: GPI_4_DEB_DIS
Public property | DEBOUNCEDISAGPI5DEBDIS | DEBOUNCE_DIS_A: GPI_5_DEB_DIS
Public property | DEBOUNCEDISAGPI6DEBDIS | DEBOUNCE_DIS_A: GPI_6_DEB_DIS
Public property | DEBOUNCEDISAGPI7DEBDIS | DEBOUNCE_DIS_A: GPI_7_DEB_DIS
Public property | DEBOUNCEDISAGPI8DEBDIS | DEBOUNCE_DIS_A: GPI_8_DEB_DIS
Public property | DEBOUNCEDISBGPI10DEBDIS | DEBOUNCE_DIS_B: GPI_10_DEB_DIS
Public property | DEBOUNCEDISBGPI11DEBDIS | DEBOUNCE_DIS_B: GPI_11_DEB_DIS
Public property | DEBOUNCEDISBGPI12DEBDIS | DEBOUNCE_DIS_B: GPI_12_DEB_DIS
Public property | DEBOUNCEDISBGPI13DEBDIS | DEBOUNCE_DIS_B: GPI_13_DEB_DIS
Public property | DEBOUNCEDISBGPI14DEBDIS | DEBOUNCE_DIS_B: GPI_14_DEB_DIS
Public property | DEBOUNCEDISBGPI15DEBDIS | DEBOUNCE_DIS_B: GPI_15_DEB_DIS
Public property | DEBOUNCEDISBGPI16DEBDIS | DEBOUNCE_DIS_B: GPI_16_DEB_DIS
Public property | DEBOUNCEDISBGPI9DEBDIS | DEBOUNCE_DIS_B: GPI_9_DEB_DIS
Public property | DEBOUNCEDISCGPI17DEBDIS | DEBOUNCE_DIS_C: GPI_17_DEB_DIS
Public property | DEBOUNCEDISCGPI18DEBDIS | DEBOUNCE_DIS_C: GPI_18_DEB_DIS
Public property | DEBOUNCEDISCGPI19DEBDIS | DEBOUNCE_DIS_C: GPI_19_DEB_DIS
Public property | EXTLOCKEVENTEXTLOCKEVENT | EXT_LOCK_EVENT: EXT_LOCK_EVENT
Public property | EXTLOCKEVENTEXTLOCKSTATE | EXT_LOCK_EVENT: EXT_LOCK_STATE
Public property | FIFO10EVENT10IDENTIFIER | FIFO_10: EVENT10_IDENTIFIER
Public property | FIFO10EVENT10STATE | FIFO_10: EVENT10_STATE
Public property | FIFO11EVENT11IDENTIFIER | FIFO_11: EVENT11_IDENTIFIER
Public property | FIFO11EVENT11STATE | FIFO_11: EVENT11_STATE
Public property | FIFO12EVENT12IDENTIFIER | FIFO_12: EVENT12_IDENTIFIER
Public property | FIFO12EVENT12STATE | FIFO_12: EVENT12_STATE
Public property | FIFO13EVENT13IDENTIFIER | FIFO_13: EVENT13_IDENTIFIER
Public property | FIFO13EVENT13STATE | FIFO_13: EVENT13_STATE
Public property | FIFO14EVENT14IDENTIFIER | FIFO_14: EVENT14_IDENTIFIER
Public property | FIFO14EVENT14STATE | FIFO_14: EVENT14_STATE
Public property | FIFO15EVENT15IDENTIFIER | FIFO_15: EVENT15_IDENTIFIER
Public property | FIFO15EVENT15STATE | FIFO_15: EVENT15_STATE
Public property | FIFO16EVENT16IDENTIFIER | FIFO_16: EVENT16_IDENTIFIER
Public property | FIFO16EVENT16STATE | FIFO_16: EVENT16_STATE
Public property | FIFO1EVENT1IDENTIFIER | FIFO_1: EVENT1_IDENTIFIER
Public property | FIFO1EVENT1STATE | FIFO_1: EVENT1_STATE
Public property | FIFO2EVENT2IDENTIFIER | FIFO_2: EVENT2_IDENTIFIER
Public property | FIFO2EVENT2STATE | FIFO_2: EVENT2_STATE
Public property | FIFO3EVENT3IDENTIFIER | FIFO_3: EVENT3_IDENTIFIER
Public property | FIFO3EVENT3STATE | FIFO_3: EVENT3_STATE
Public property | FIFO4EVENT4IDENTIFIER | FIFO_4: EVENT4_IDENTIFIER
Public property | FIFO4EVENT4STATE | FIFO_4: EVENT4_STATE
Public property | FIFO5EVENT5IDENTIFIER | FIFO_5: EVENT5_IDENTIFIER
Public property | FIFO5EVENT5STATE | FIFO_5: EVENT5_STATE
Public property | FIFO6EVENT6IDENTIFIER | FIFO_6: EVENT6_IDENTIFIER
Public property | FIFO6EVENT6STATE | FIFO_6: EVENT6_STATE
Public property | FIFO7EVENT7IDENTIFIER | FIFO_7: EVENT7_IDENTIFIER
Public property | FIFO7EVENT7STATE | FIFO_7: EVENT7_STATE
Public property | FIFO8EVENT8IDENTIFIER | FIFO_8: EVENT8_IDENTIFIER
Public property | FIFO8EVENT8STATE | FIFO_8: EVENT8_STATE
Public property | FIFO9EVENT9IDENTIFIER | FIFO_9: EVENT9_IDENTIFIER
Public property | FIFO9EVENT9STATE | FIFO_9: EVENT9_STATE
Public property | GENERALCFGBCOREFREQ | GENERAL_CFG_B: CORE_FREQ
Public property | GENERALCFGBINTCFG | GENERAL_CFG_B: INT_CFG
Public property | GENERALCFGBLCKTRKGPI | GENERAL_CFG_B: LCK_TRK_GPI
Public property | GENERALCFGBLCKTRKLOGIC | GENERAL_CFG_B: LCK_TRK_LOGIC
Public property | GENERALCFGBOSCEN | GENERAL_CFG_B: OSC_EN
Public property | GENERALCFGBRSTCFG | GENERAL_CFG_B: RST_CFG
Public property | GPIEVENTENAGPI1EVENTEN | GPI_EVENT_EN_A: GPI_1_EVENT_EN
Public property | GPIEVENTENAGPI2EVENTEN | GPI_EVENT_EN_A: GPI_2_EVENT_EN
Public property | GPIEVENTENAGPI3EVENTEN | GPI_EVENT_EN_A: GPI_3_EVENT_EN
Public property | GPIEVENTENAGPI4EVENTEN | GPI_EVENT_EN_A: GPI_4_EVENT_EN
Public property | GPIEVENTENAGPI5EVENTEN | GPI_EVENT_EN_A: GPI_5_EVENT_EN
Public property | GPIEVENTENAGPI6EVENTEN | GPI_EVENT_EN_A: GPI_6_EVENT_EN
Public property | GPIEVENTENAGPI7EVENTEN | GPI_EVENT_EN_A: GPI_7_EVENT_EN
Public property | GPIEVENTENAGPI8EVENTEN | GPI_EVENT_EN_A: GPI_8_EVENT_EN
Public property | GPIEVENTENBGPI10EVENTEN | GPI_EVENT_EN_B: GPI_10_EVENT_EN
Public property | GPIEVENTENBGPI11EVENTEN | GPI_EVENT_EN_B: GPI_11_EVENT_EN
Public property | GPIEVENTENBGPI12EVENTEN | GPI_EVENT_EN_B: GPI_12_EVENT_EN
Public property | GPIEVENTENBGPI13EVENTEN | GPI_EVENT_EN_B: GPI_13_EVENT_EN
Public property | GPIEVENTENBGPI14EVENTEN | GPI_EVENT_EN_B: GPI_14_EVENT_EN
Public property | GPIEVENTENBGPI15EVENTEN | GPI_EVENT_EN_B: GPI_15_EVENT_EN
Public property | GPIEVENTENBGPI16EVENTEN | GPI_EVENT_EN_B: GPI_16_EVENT_EN
Public property | GPIEVENTENBGPI9EVENTEN | GPI_EVENT_EN_B: GPI_9_EVENT_EN
Public property | GPIEVENTENCGPI17EVENTEN | GPI_EVENT_EN_C: GPI_17_EVENT_EN
Public property | GPIEVENTENCGPI18EVENTEN | GPI_EVENT_EN_C: GPI_18_EVENT_EN
Public property | GPIEVENTENCGPI19EVENTEN | GPI_EVENT_EN_C: GPI_19_EVENT_EN
Public property | GPIINTERRUPTENAGPI1INTEN | GPI_INTERRUPT_EN_A: GPI_1_INT_EN
Public property | GPIINTERRUPTENAGPI2INTEN | GPI_INTERRUPT_EN_A: GPI_2_INT_EN
Public property | GPIINTERRUPTENAGPI3INTEN | GPI_INTERRUPT_EN_A: GPI_3_INT_EN
Public property | GPIINTERRUPTENAGPI4INTEN | GPI_INTERRUPT_EN_A: GPI_4_INT_EN
Public property | GPIINTERRUPTENAGPI5INTEN | GPI_INTERRUPT_EN_A: GPI_5_INT_EN
Public property | GPIINTERRUPTENAGPI6INTEN | GPI_INTERRUPT_EN_A: GPI_6_INT_EN
Public property | GPIINTERRUPTENAGPI7INTEN | GPI_INTERRUPT_EN_A: GPI_7_INT_EN
Public property | GPIINTERRUPTENAGPI8INTEN | GPI_INTERRUPT_EN_A: GPI_8_INT_EN
Public property | GPIINTERRUPTENBGPI10INTEN | GPI_INTERRUPT_EN_B: GPI_10_INT_EN
Public property | GPIINTERRUPTENBGPI11INTEN | GPI_INTERRUPT_EN_B: GPI_11_INT_EN
Public property | GPIINTERRUPTENBGPI12INTEN | GPI_INTERRUPT_EN_B: GPI_12_INT_EN
Public property | GPIINTERRUPTENBGPI13INTEN | GPI_INTERRUPT_EN_B: GPI_13_INT_EN
Public property | GPIINTERRUPTENBGPI14INTEN | GPI_INTERRUPT_EN_B: GPI_14_INT_EN
Public property | GPIINTERRUPTENBGPI15INTEN | GPI_INTERRUPT_EN_B: GPI_15_INT_EN
Public property | GPIINTERRUPTENBGPI16INTEN | GPI_INTERRUPT_EN_B: GPI_16_INT_EN
Public property | GPIINTERRUPTENBGPI9INTEN | GPI_INTERRUPT_EN_B: GPI_9_INT_EN
Public property | GPIINTERRUPTENCGPI17INTEN | GPI_INTERRUPT_EN_C: GPI_17_INT_EN
Public property | GPIINTERRUPTENCGPI18INTEN | GPI_INTERRUPT_EN_C: GPI_18_INT_EN
Public property | GPIINTERRUPTENCGPI19INTEN | GPI_INTERRUPT_EN_C: GPI_19_INT_EN
Public property | GPIINTLEVELAGPI1INTLEVEL | GPI_INT_LEVEL_A: GPI_1_INT_LEVEL
Public property | GPIINTLEVELAGPI2INTLEVEL | GPI_INT_LEVEL_A: GPI_2_INT_LEVEL
Public property | GPIINTLEVELAGPI3INTLEVEL | GPI_INT_LEVEL_A: GPI_3_INT_LEVEL
Public property | GPIINTLEVELAGPI4INTLEVEL | GPI_INT_LEVEL_A: GPI_4_INT_LEVEL
Public property | GPIINTLEVELAGPI5INTLEVEL | GPI_INT_LEVEL_A: GPI_5_INT_LEVEL
Public property | GPIINTLEVELAGPI6INTLEVEL | GPI_INT_LEVEL_A: GPI_6_INT_LEVEL
Public property | GPIINTLEVELAGPI7INTLEVEL | GPI_INT_LEVEL_A: GPI_7_INT_LEVEL
Public property | GPIINTLEVELAGPI8INTLEVEL | GPI_INT_LEVEL_A: GPI_8_INT_LEVEL
Public property | GPIINTLEVELBGPI10INTLEVEL | GPI_INT_LEVEL_B: GPI_10_INT_LEVEL
Public property | GPIINTLEVELBGPI11INTLEVEL | GPI_INT_LEVEL_B: GPI_11_INT_LEVEL
Public property | GPIINTLEVELBGPI12INTLEVEL | GPI_INT_LEVEL_B: GPI_12_INT_LEVEL
Public property | GPIINTLEVELBGPI13INTLEVEL | GPI_INT_LEVEL_B: GPI_13_INT_LEVEL
Public property | GPIINTLEVELBGPI14INTLEVEL | GPI_INT_LEVEL_B: GPI_14_INT_LEVEL
Public property | GPIINTLEVELBGPI15INTLEVEL | GPI_INT_LEVEL_B: GPI_15_INT_LEVEL
Public property | GPIINTLEVELBGPI16INTLEVEL | GPI_INT_LEVEL_B: GPI_16_INT_LEVEL
Public property | GPIINTLEVELBGPI9INTLEVEL | GPI_INT_LEVEL_B: GPI_9_INT_LEVEL
Public property | GPIINTLEVELCGPI17INTLEVEL | GPI_INT_LEVEL_C: GPI_17_INT_LEVEL
Public property | GPIINTLEVELCGPI18INTLEVEL | GPI_INT_LEVEL_C: GPI_18_INT_LEVEL
Public property | GPIINTLEVELCGPI19INTLEVEL | GPI_INT_LEVEL_C: GPI_19_INT_LEVEL
Public property | GPIINTSTATAGPI1INT | GPI_INT_STAT_A: GPI_1_INT
Public property | GPIINTSTATAGPI2INT | GPI_INT_STAT_A: GPI_2_INT
Public property | GPIINTSTATAGPI3INT | GPI_INT_STAT_A: GPI_3_INT
Public property | GPIINTSTATAGPI4INT | GPI_INT_STAT_A: GPI_4_INT
Public property | GPIINTSTATAGPI5INT | GPI_INT_STAT_A: GPI_5_INT
Public property | GPIINTSTATAGPI6INT | GPI_INT_STAT_A: GPI_6_INT
Public property | GPIINTSTATAGPI7INT | GPI_INT_STAT_A: GPI_7_INT
Public property | GPIINTSTATAGPI8INT | GPI_INT_STAT_A: GPI_8_INT
Public property | GPIINTSTATBGPI10INT | GPI_INT_STAT_B: GPI_10_INT
Public property | GPIINTSTATBGPI11INT | GPI_INT_STAT_B: GPI_11_INT
Public property | GPIINTSTATBGPI12INT | GPI_INT_STAT_B: GPI_12_INT
Public property | GPIINTSTATBGPI13INT | GPI_INT_STAT_B: GPI_13_INT
Public property | GPIINTSTATBGPI14INT | GPI_INT_STAT_B: GPI_14_INT
Public property | GPIINTSTATBGPI15INT | GPI_INT_STAT_B: GPI_15_INT
Public property | GPIINTSTATBGPI16INT | GPI_INT_STAT_B: GPI_16_INT
Public property | GPIINTSTATBGPI9INT | GPI_INT_STAT_B: GPI_9_INT
Public property | GPIINTSTATCGPI17INT | GPI_INT_STAT_C: GPI_17_INT
Public property | GPIINTSTATCGPI18INT | GPI_INT_STAT_C: GPI_18_INT
Public property | GPIINTSTATCGPI19INT | GPI_INT_STAT_C: GPI_19_INT
Public property | GPIODIRECTIONAGPIO1DIR | GPIO_DIRECTION_A: GPIO_1_DIR
Public property | GPIODIRECTIONAGPIO2DIR | GPIO_DIRECTION_A: GPIO_2_DIR
Public property | GPIODIRECTIONAGPIO3DIR | GPIO_DIRECTION_A: GPIO_3_DIR
Public property | GPIODIRECTIONAGPIO4DIR | GPIO_DIRECTION_A: GPIO_4_DIR
Public property | GPIODIRECTIONAGPIO5DIR | GPIO_DIRECTION_A: GPIO_5_DIR
Public property | GPIODIRECTIONAGPIO6DIR | GPIO_DIRECTION_A: GPIO_6_DIR
Public property | GPIODIRECTIONAGPIO7DIR | GPIO_DIRECTION_A: GPIO_7_DIR
Public property | GPIODIRECTIONAGPIO8DIR | GPIO_DIRECTION_A: GPIO_8_DIR
Public property | GPIODIRECTIONBGPIO10DIR | GPIO_DIRECTION_B: GPIO_10_DIR
Public property | GPIODIRECTIONBGPIO11DIR | GPIO_DIRECTION_B: GPIO_11_DIR
Public property | GPIODIRECTIONBGPIO12DIR | GPIO_DIRECTION_B: GPIO_12_DIR
Public property | GPIODIRECTIONBGPIO13DIR | GPIO_DIRECTION_B: GPIO_13_DIR
Public property | GPIODIRECTIONBGPIO14DIR | GPIO_DIRECTION_B: GPIO_14_DIR
Public property | GPIODIRECTIONBGPIO15DIR | GPIO_DIRECTION_B: GPIO_15_DIR
Public property | GPIODIRECTIONBGPIO16DIR | GPIO_DIRECTION_B: GPIO_16_DIR
Public property | GPIODIRECTIONBGPIO9DIR | GPIO_DIRECTION_B: GPIO_9_DIR
Public property | GPIODIRECTIONCGPIO17DIR | GPIO_DIRECTION_C: GPIO_17_DIR
Public property | GPIODIRECTIONCGPIO18DIR | GPIO_DIRECTION_C: GPIO_18_DIR
Public property | GPIODIRECTIONCGPIO19DIR | GPIO_DIRECTION_C: GPIO_19_DIR
Public property | GPISTATUSAGPI1STAT | GPI_STATUS_A: GPI_1_STAT
Public property | GPISTATUSAGPI2STAT | GPI_STATUS_A: GPI_2_STAT
Public property | GPISTATUSAGPI3STAT | GPI_STATUS_A: GPI_3_STAT
Public property | GPISTATUSAGPI4STAT | GPI_STATUS_A: GPI_4_STAT
Public property | GPISTATUSAGPI5STAT | GPI_STATUS_A: GPI_5_STAT
Public property | GPISTATUSAGPI6STAT | GPI_STATUS_A: GPI_6_STAT
Public property | GPISTATUSAGPI7STAT | GPI_STATUS_A: GPI_7_STAT
Public property | GPISTATUSAGPI8STAT | GPI_STATUS_A: GPI_8_STAT
Public property | GPISTATUSBGPI10STAT | GPI_STATUS_B: GPI_10_STAT
Public property | GPISTATUSBGPI11STAT | GPI_STATUS_B: GPI_11_STAT
Public property | GPISTATUSBGPI12STAT | GPI_STATUS_B: GPI_12_STAT
Public property | GPISTATUSBGPI13STAT | GPI_STATUS_B: GPI_13_STAT
Public property | GPISTATUSBGPI14STAT | GPI_STATUS_B: GPI_14_STAT
Public property | GPISTATUSBGPI15STAT | GPI_STATUS_B: GPI_15_STAT
Public property | GPISTATUSBGPI16STAT | GPI_STATUS_B: GPI_16_STAT
Public property | GPISTATUSBGPI9STAT | GPI_STATUS_B: GPI_9_STAT
Public property | GPISTATUSCGPI17STAT | GPI_STATUS_C: GPI_17_STAT
Public property | GPISTATUSCGPI18STAT | GPI_STATUS_C: GPI_18_STAT
Public property | GPISTATUSCGPI19STAT | GPI_STATUS_C: GPI_19_STAT
Public property | GPODATAOUTAGPO1DATA | GPO_DATA_OUT_A: GPO_1_DATA
Public property | GPODATAOUTAGPO2DATA | GPO_DATA_OUT_A: GPO_2_DATA
Public property | GPODATAOUTAGPO3DATA | GPO_DATA_OUT_A: GPO_3_DATA
Public property | GPODATAOUTAGPO4DATA | GPO_DATA_OUT_A: GPO_4_DATA
Public property | GPODATAOUTAGPO5DATA | GPO_DATA_OUT_A: GPO_5_DATA
Public property | GPODATAOUTAGPO6DATA | GPO_DATA_OUT_A: GPO_6_DATA
Public property | GPODATAOUTAGPO7DATA | GPO_DATA_OUT_A: GPO_7_DATA
Public property | GPODATAOUTAGPO8DATA | GPO_DATA_OUT_A: GPO_8_DATA
Public property | GPODATAOUTBGPO10DATA | GPO_DATA_OUT_B: GPO_10_DATA
Public property | GPODATAOUTBGPO11DATA | GPO_DATA_OUT_B: GPO_11_DATA
Public property | GPODATAOUTBGPO12DATA | GPO_DATA_OUT_B: GPO_12_DATA
Public property | GPODATAOUTBGPO13DATA | GPO_DATA_OUT_B: GPO_13_DATA
Public property | GPODATAOUTBGPO14DATA | GPO_DATA_OUT_B: GPO_14_DATA
Public property | GPODATAOUTBGPO15DATA | GPO_DATA_OUT_B: GPO_15_DATA
Public property | GPODATAOUTBGPO16DATA | GPO_DATA_OUT_B: GPO_16_DATA
Public property | GPODATAOUTBGPO9DATA | GPO_DATA_OUT_B: GPO_9_DATA
Public property | GPODATAOUTCGPO17DATA | GPO_DATA_OUT_C: GPO_17_DATA
Public property | GPODATAOUTCGPO18DATA | GPO_DATA_OUT_C: GPO_18_DATA
Public property | GPODATAOUTCGPO19DATA | GPO_DATA_OUT_C: GPO_19_DATA
Public property | GPOOUTMODEAGPO1OUTMODE | GPO_OUT_MODE_A: GPO_1_OUT_MODE
Public property | GPOOUTMODEAGPO2OUTMODE | GPO_OUT_MODE_A: GPO_2_OUT_MODE
Public property | GPOOUTMODEAGPO3OUTMODE | GPO_OUT_MODE_A: GPO_3_OUT_MODE
Public property | GPOOUTMODEAGPO4OUTMODE | GPO_OUT_MODE_A: GPO_4_OUT_MODE
Public property | GPOOUTMODEAGPO5OUTMODE | GPO_OUT_MODE_A: GPO_5_OUT_MODE
Public property | GPOOUTMODEAGPO6OUTMODE | GPO_OUT_MODE_A: GPO_6_OUT_MODE
Public property | GPOOUTMODEAGPO7OUTMODE | GPO_OUT_MODE_A: GPO_7_OUT_MODE
Public property | GPOOUTMODEAGPO8OUTMODE | GPO_OUT_MODE_A: GPO_8_OUT_MODE
Public property | GPOOUTMODEBGPO10OUTMODE | GPO_OUT_MODE_B: GPO_10_OUT_MODE
Public property | GPOOUTMODEBGPO11OUTMODE | GPO_OUT_MODE_B: GPO_11_OUT_MODE
Public property | GPOOUTMODEBGPO12OUTMODE | GPO_OUT_MODE_B: GPO_12_OUT_MODE
Public property | GPOOUTMODEBGPO13OUTMODE | GPO_OUT_MODE_B: GPO_13_OUT_MODE
Public property | GPOOUTMODEBGPO14OUTMODE | GPO_OUT_MODE_B: GPO_14_OUT_MODE
Public property | GPOOUTMODEBGPO15OUTMODE | GPO_OUT_MODE_B: GPO_15_OUT_MODE
Public property | GPOOUTMODEBGPO16OUTMODE | GPO_OUT_MODE_B: GPO_16_OUT_MODE
Public property | GPOOUTMODEBGPO9OUTMODE | GPO_OUT_MODE_B: GPO_9_OUT_MODE
Public property | GPOOUTMODECGPO17OUTMODE | GPO_OUT_MODE_C: GPO_17_OUT_MODE
Public property | GPOOUTMODECGPO18OUTMODE | GPO_OUT_MODE_C: GPO_18_OUT_MODE
Public property | GPOOUTMODECGPO19OUTMODE | GPO_OUT_MODE_C: GPO_19_OUT_MODE
Public property | IDMANID | ID: MAN_ID
Public property | IDREVID | ID: REV_ID
Public property | INTENEVENTIEN | INT_EN: EVENT_IEN
Public property | INTENGPIIEN | INT_EN: GPI_IEN
Public property | INTENLOCKEN | INT_EN: LOCK_EN
Public property | INTENLOGIC1EN | INT_EN: LOGIC1_EN
Public property | INTENLOGIC2EN | INT_EN: LOGIC2_EN
Public property | INTENOVRFLOWIEN | INT_EN: OVRFLOW_IEN
Public property | INTSTATUSEVENTINT | INT_STATUS: EVENT_INT
Public property | INTSTATUSGPIINT | INT_STATUS: GPI_INT
Public property | INTSTATUSLOCKINT | INT_STATUS: LOCK_INT
Public property | INTSTATUSLOGIC1INT | INT_STATUS: LOGIC1_INT
Public property | INTSTATUSLOGIC2INT | INT_STATUS: LOGIC2_INT
Public property | INTSTATUSOVRFLOWINT | INT_STATUS: OVRFLOW_INT
Public property | LOCKCFGLOCKEN | LOCK_CFG: LOCK_EN
Public property | LOGIC1CFGLA1INV | LOGIC_1_CFG: LA1_INV
Public property | LOGIC1CFGLB1INV | LOGIC_1_CFG: LB1_INV
Public property | LOGIC1CFGLC1INV | LOGIC_1_CFG: LC1_INV
Public property | LOGIC1CFGLOGIC1SEL | LOGIC_1_CFG: LOGIC1_SEL
Public property | LOGIC1CFGLY1INV | LOGIC_1_CFG: LY1_INV
Public property | LOGIC2CFGLA2INV | LOGIC_2_CFG: LA2_INV
Public property | LOGIC2CFGLB2INV | LOGIC_2_CFG: LB2_INV
Public property | LOGIC2CFGLC2INV | LOGIC_2_CFG: LC2_INV
Public property | LOGIC2CFGLOGIC2SEL | LOGIC_2_CFG: LOGIC2_SEL
Public property | LOGIC2CFGLY1CASCADE | LOGIC_2_CFG: LY1_CASCADE
Public property | LOGIC2CFGLY2INV | LOGIC_2_CFG: LY2_INV
Public property | LOGICFFCFGFF1CLR | LOGIC_FF_CFG: FF1_CLR
Public property | LOGICFFCFGFF1SET | LOGIC_FF_CFG: FF1_SET
Public property | LOGICFFCFGFF2CLR | LOGIC_FF_CFG: FF2_CLR
Public property | LOGICFFCFGFF2SET | LOGIC_FF_CFG: FF2_SET
Public property | LOGICINTEVENTENLOGIC1EVENTEN | LOGIC_INT_EVENT_EN: LOGIC1_EVENT_EN
Public property | LOGICINTEVENTENLOGIC1INTLEVEL | LOGIC_INT_EVENT_EN: LOGIC1_INT_LEVEL
Public property | LOGICINTEVENTENLOGIC2EVENTEN | LOGIC_INT_EVENT_EN: LOGIC2_EVENT_EN
Public property | LOGICINTEVENTENLOGIC2INTLEVEL | LOGIC_INT_EVENT_EN: LOGIC2_INT_LEVEL
Public property | LOGICINTEVENTENLY1DBNCDIS | LOGIC_INT_EVENT_EN: LY1_DBNC_DIS
Public property | LOGICINTEVENTENLY2DBNCDIS | LOGIC_INT_EVENT_EN: LY2_DBNC_DIS
Public property | PINCONFIGAR0CONFIG | PIN_CONFIG_A: R0_CONFIG
Public property | PINCONFIGAR1CONFIG | PIN_CONFIG_A: R1_CONFIG
Public property | PINCONFIGAR2CONFIG | PIN_CONFIG_A: R2_CONFIG
Public property | PINCONFIGAR3CONFIG | PIN_CONFIG_A: R3_CONFIG
Public property | PINCONFIGAR4CONFIG | PIN_CONFIG_A: R4_CONFIG
Public property | PINCONFIGAR5CONFIG | PIN_CONFIG_A: R5_CONFIG
Public property | PINCONFIGAR6CONFIG | PIN_CONFIG_A: R6_CONFIG
Public property | PINCONFIGAR7CONFIG | PIN_CONFIG_A: R7_CONFIG
Public property | PINCONFIGBC0CONFIG | PIN_CONFIG_B: C0_CONFIG
Public property | PINCONFIGBC1CONFIG | PIN_CONFIG_B: C1_CONFIG
Public property | PINCONFIGBC2CONFIG | PIN_CONFIG_B: C2_CONFIG
Public property | PINCONFIGBC3CONFIG | PIN_CONFIG_B: C3_CONFIG
Public property | PINCONFIGBC4CONFIG | PIN_CONFIG_B: C4_CONFIG
Public property | PINCONFIGBC5CONFIG | PIN_CONFIG_B: C5_CONFIG
Public property | PINCONFIGBC6CONFIG | PIN_CONFIG_B: C6_CONFIG
Public property | PINCONFIGBC7CONFIG | PIN_CONFIG_B: C7_CONFIG
Public property | PINCONFIGCC10CONFIG | PIN_CONFIG_C: C10_CONFIG
Public property | PINCONFIGCC8CONFIG | PIN_CONFIG_C: C8_CONFIG
Public property | PINCONFIGCC9CONFIG | PIN_CONFIG_C: C9_CONFIG
Public property | PINCONFIGDC4EXTENDCFG | PIN_CONFIG_D: C4_EXTEND_CFG
Public property | PINCONFIGDC6EXTENDCFG | PIN_CONFIG_D: C6_EXTEND_CFG
Public property | PINCONFIGDC9EXTENDCFG | PIN_CONFIG_D: C9_EXTEND_CFG
Public property | PINCONFIGDPULLSELECT | PIN_CONFIG_D: PULL_SELECT
Public property | PINCONFIGDR0EXTENDCFG | PIN_CONFIG_D: R0_EXTEND_CFG
Public property | PINCONFIGDR3EXTENDCFG | PIN_CONFIG_D: R3_EXTEND_CFG
Public property | PINCONFIGDR4EXTENDCFG | PIN_CONFIG_D: R4_EXTEND_CFG
Public property | POLLTIMECFGKEYPOLLTIME | POLL_TIME_CFG: KEY_POLL_TIME
Public property | PWMCFGPWMEN | PWM_CFG: PWM_EN
Public property | PWMCFGPWMINAND | PWM_CFG: PWM_IN_AND
Public property | PWMCFGPWMMODE | PWM_CFG: PWM_MODE
Public property | PWMOFFT | PWM_OFFT (unit: µs)
Public property | PWMONT | PWM_ONT (unit: µs)
Public property | RESET1EVENTARESET1EVENTA | RESET1_EVENT_A: RESET1_EVENT_A
Public property | RESET1EVENTARESET1EVENTALEVEL | RESET1_EVENT_A: RESET1_EVENT_A_LEVEL
Public property | RESET1EVENTBRESET1EVENTB | RESET1_EVENT_B: RESET1_EVENT_B
Public property | RESET1EVENTBRESET1EVENTBLEVEL | RESET1_EVENT_B: RESET1_EVENT_B_LEVEL
Public property | RESET1EVENTCRESET1EVENTC | RESET1_EVENT_C: RESET1_EVENT_C
Public property | RESET1EVENTCRESET1EVENTCLEVEL | RESET1_EVENT_C: RESET1_EVENT_C_LEVEL
Public property | RESET2EVENTARESET2EVENTA | RESET2_EVENT_A: RESET2_EVENT_A
Public property | RESET2EVENTARESET2EVENTALEVEL | RESET2_EVENT_A: RESET2_EVENT_A_LEVEL
Public property | RESET2EVENTBRESET2EVENTB | RESET2_EVENT_B: RESET2_EVENT_B
Public property | RESET2EVENTBRESET2EVENTBLEVEL | RESET2_EVENT_B: RESET2_EVENT_B_LEVEL
Public property | RESETCFGRESET1POL | RESET_CFG: RESET1_POL
Public property | RESETCFGRESET2POL | RESET_CFG: RESET2_POL
Public property | RESETCFGRESETPULSEWIDTH | RESET_CFG: RESET_PULSE_WIDTH
Public property | RESETCFGRESETTRIGGERTIME | RESET_CFG: RESET_TRIGGER_TIME (unit: s)
Public property | RESETCFGRSTPASSTHRUEN | RESET_CFG: RST_PASSTHRU_EN
Public property | RPULLCONFIGAR0PULLCFG | RPULL_CONFIG_A: R0_PULL_CFG
Public property | RPULLCONFIGAR1PULLCFG | RPULL_CONFIG_A: R1_PULL_CFG
Public property | RPULLCONFIGAR2PULLCFG | RPULL_CONFIG_A: R2_PULL_CFG
Public property | RPULLCONFIGAR3PULLCFG | RPULL_CONFIG_A: R3_PULL_CFG
Public property | RPULLCONFIGBR4PULLCFG | RPULL_CONFIG_B: R4_PULL_CFG
Public property | RPULLCONFIGBR5PULLCFG | RPULL_CONFIG_B: R5_PULL_CFG
Public property | RPULLCONFIGBR6PULLCFG | RPULL_CONFIG_B: R6_PULL_CFG
Public property | RPULLCONFIGBR7PULLCFG | RPULL_CONFIG_B: R7_PULL_CFG
Public property | RPULLCONFIGCC0PULLCFG | RPULL_CONFIG_C: C0_PULL_CFG
Public property | RPULLCONFIGCC1PULLCFG | RPULL_CONFIG_C: C1_PULL_CFG
Public property | RPULLCONFIGCC2PULLCFG | RPULL_CONFIG_C: C2_PULL_CFG
Public property | RPULLCONFIGCC3PULLCFG | RPULL_CONFIG_C: C3_PULL_CFG
Public property | RPULLCONFIGDC4PULLCFG | RPULL_CONFIG_D: C4_PULL_CFG
Public property | RPULLCONFIGDC5PULLCFG | RPULL_CONFIG_D: C5_PULL_CFG
Public property | RPULLCONFIGDC6PULLCFG | RPULL_CONFIG_D: C6_PULL_CFG
Public property | RPULLCONFIGDC7PULLCFG | RPULL_CONFIG_D: C7_PULL_CFG
Public property | RPULLCONFIGEC10PULLCFG | RPULL_CONFIG_E: C10_PULL_CFG
Public property | RPULLCONFIGEC8PULLCFG | RPULL_CONFIG_E: C8_PULL_CFG
Public property | RPULLCONFIGEC9PULLCFG | RPULL_CONFIG_E: C9_PULL_CFG
Public property | STATUSEC | STATUS: EC
Public property | STATUSLOCKSTAT | STATUS: LOCK_STAT
Public property | STATUSLOGIC1STAT | STATUS: LOGIC1_STAT
Public property | STATUSLOGIC2STAT | STATUS: LOGIC2_STAT
Public property | UNLOCK1UNLOCK1 | UNLOCK1: UNLOCK1
Public property | UNLOCK1UNLOCK1STATE | UNLOCK1: UNLOCK1_STATE
Public property | UNLOCK2UNLOCK2 | UNLOCK2: UNLOCK2
Public property | UNLOCK2UNLOCK2STATE | UNLOCK2: UNLOCK2_STATE
Public property | UNLOCKTIMERSINTMASKTIMER | UNLOCK_TIMERS: INT_MASK_TIMER (unit: s)
Public property | UNLOCKTIMERSUNLOCKTIMER | UNLOCK_TIMERS: UNLOCK_TIMER (unit: s)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Keypad Decoder and I/O Expansion
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adp5589(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adp5589

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589 Properties

The Adp5589 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CLOCKDIVCFGCLKDIV | CLOCK_DIV_CFG: CLK_DIV
Public property | CLOCKDIVCFGCLKDIVEN | CLOCK_DIV_CFG: CLK_DIV_EN
Public property | CLOCKDIVCFGCLKINV | CLOCK_DIV_CFG: CLK_INV
Public property | DEBOUNCEDISAGPI1DEBDIS | DEBOUNCE_DIS_A: GPI_1_DEB_DIS
Public property | DEBOUNCEDISAGPI2DEBDIS | DEBOUNCE_DIS_A: GPI_2_DEB_DIS
Public property | DEBOUNCEDISAGPI3DEBDIS | DEBOUNCE_DIS_A: GPI_3_DEB_DIS
Public property | DEBOUNCEDISAGPI4DEBDIS | DEBOUNCE_DIS_A: GPI_4_DEB_DIS
Public property | DEBOUNCEDISAGPI5DEBDIS | DEBOUNCE_DIS_A: GPI_5_DEB_DIS
Public property | DEBOUNCEDISAGPI6DEBDIS | DEBOUNCE_DIS_A: GPI_6_DEB_DIS
Public property | DEBOUNCEDISAGPI7DEBDIS | DEBOUNCE_DIS_A: GPI_7_DEB_DIS
Public property | DEBOUNCEDISAGPI8DEBDIS | DEBOUNCE_DIS_A: GPI_8_DEB_DIS
Public property | DEBOUNCEDISBGPI10DEBDIS | DEBOUNCE_DIS_B: GPI_10_DEB_DIS
Public property | DEBOUNCEDISBGPI11DEBDIS | DEBOUNCE_DIS_B: GPI_11_DEB_DIS
Public property | DEBOUNCEDISBGPI12DEBDIS | DEBOUNCE_DIS_B: GPI_12_DEB_DIS
Public property | DEBOUNCEDISBGPI13DEBDIS | DEBOUNCE_DIS_B: GPI_13_DEB_DIS
Public property | DEBOUNCEDISBGPI14DEBDIS | DEBOUNCE_DIS_B: GPI_14_DEB_DIS
Public property | DEBOUNCEDISBGPI15DEBDIS | DEBOUNCE_DIS_B: GPI_15_DEB_DIS
Public property | DEBOUNCEDISBGPI16DEBDIS | DEBOUNCE_DIS_B: GPI_16_DEB_DIS
Public property | DEBOUNCEDISBGPI9DEBDIS | DEBOUNCE_DIS_B: GPI_9_DEB_DIS
Public property | DEBOUNCEDISCGPI17DEBDIS | DEBOUNCE_DIS_C: GPI_17_DEB_DIS
Public property | DEBOUNCEDISCGPI18DEBDIS | DEBOUNCE_DIS_C: GPI_18_DEB_DIS
Public property | DEBOUNCEDISCGPI19DEBDIS | DEBOUNCE_DIS_C: GPI_19_DEB_DIS
Public property | EXTLOCKEVENTEXTLOCKEVENT | EXT_LOCK_EVENT: EXT_LOCK_EVENT
Public property | EXTLOCKEVENTEXTLOCKSTATE | EXT_LOCK_EVENT: EXT_LOCK_STATE
Public property | FIFO10EVENT10IDENTIFIER | FIFO_10: EVENT10_IDENTIFIER
Public property | FIFO10EVENT10STATE | FIFO_10: EVENT10_STATE
Public property | FIFO11EVENT11IDENTIFIER | FIFO_11: EVENT11_IDENTIFIER
Public property | FIFO11EVENT11STATE | FIFO_11: EVENT11_STATE
Public property | FIFO12EVENT12IDENTIFIER | FIFO_12: EVENT12_IDENTIFIER
Public property | FIFO12EVENT12STATE | FIFO_12: EVENT12_STATE
Public property | FIFO13EVENT13IDENTIFIER | FIFO_13: EVENT13_IDENTIFIER
Public property | FIFO13EVENT13STATE | FIFO_13: EVENT13_STATE
Public property | FIFO14EVENT14IDENTIFIER | FIFO_14: EVENT14_IDENTIFIER
Public property | FIFO14EVENT14STATE | FIFO_14: EVENT14_STATE
Public property | FIFO15EVENT15IDENTIFIER | FIFO_15: EVENT15_IDENTIFIER
Public property | FIFO15EVENT15STATE | FIFO_15: EVENT15_STATE
Public property | FIFO16EVENT16IDENTIFIER | FIFO_16: EVENT16_IDENTIFIER
Public property | FIFO16EVENT16STATE | FIFO_16: EVENT16_STATE
Public property | FIFO1EVENT1IDENTIFIER | FIFO_1: EVENT1_IDENTIFIER
Public property | FIFO1EVENT1STATE | FIFO_1: EVENT1_STATE
Public property | FIFO2EVENT2IDENTIFIER | FIFO_2: EVENT2_IDENTIFIER
Public property | FIFO2EVENT2STATE | FIFO_2: EVENT2_STATE
Public property | FIFO3EVENT3IDENTIFIER | FIFO_3: EVENT3_IDENTIFIER
Public property | FIFO3EVENT3STATE | FIFO_3: EVENT3_STATE
Public property | FIFO4EVENT4IDENTIFIER | FIFO_4: EVENT4_IDENTIFIER
Public property | FIFO4EVENT4STATE | FIFO_4: EVENT4_STATE
Public property | FIFO5EVENT5IDENTIFIER | FIFO_5: EVENT5_IDENTIFIER
Public property | FIFO5EVENT5STATE | FIFO_5: EVENT5_STATE
Public property | FIFO6EVENT6IDENTIFIER | FIFO_6: EVENT6_IDENTIFIER
Public property | FIFO6EVENT6STATE | FIFO_6: EVENT6_STATE
Public property | FIFO7EVENT7IDENTIFIER | FIFO_7: EVENT7_IDENTIFIER
Public property | FIFO7EVENT7STATE | FIFO_7: EVENT7_STATE
Public property | FIFO8EVENT8IDENTIFIER | FIFO_8: EVENT8_IDENTIFIER
Public property | FIFO8EVENT8STATE | FIFO_8: EVENT8_STATE
Public property | FIFO9EVENT9IDENTIFIER | FIFO_9: EVENT9_IDENTIFIER
Public property | FIFO9EVENT9STATE | FIFO_9: EVENT9_STATE
Public property | GENERALCFGBCOREFREQ | GENERAL_CFG_B: CORE_FREQ
Public property | GENERALCFGBINTCFG | GENERAL_CFG_B: INT_CFG
Public property | GENERALCFGBLCKTRKGPI | GENERAL_CFG_B: LCK_TRK_GPI
Public property | GENERALCFGBLCKTRKLOGIC | GENERAL_CFG_B: LCK_TRK_LOGIC
Public property | GENERALCFGBOSCEN | GENERAL_CFG_B: OSC_EN
Public property | GENERALCFGBRSTCFG | GENERAL_CFG_B: RST_CFG
Public property | GPIEVENTENAGPI1EVENTEN | GPI_EVENT_EN_A: GPI_1_EVENT_EN
Public property | GPIEVENTENAGPI2EVENTEN | GPI_EVENT_EN_A: GPI_2_EVENT_EN
Public property | GPIEVENTENAGPI3EVENTEN | GPI_EVENT_EN_A: GPI_3_EVENT_EN
Public property | GPIEVENTENAGPI4EVENTEN | GPI_EVENT_EN_A: GPI_4_EVENT_EN
Public property | GPIEVENTENAGPI5EVENTEN | GPI_EVENT_EN_A: GPI_5_EVENT_EN
Public property | GPIEVENTENAGPI6EVENTEN | GPI_EVENT_EN_A: GPI_6_EVENT_EN
Public property | GPIEVENTENAGPI7EVENTEN | GPI_EVENT_EN_A: GPI_7_EVENT_EN
Public property | GPIEVENTENAGPI8EVENTEN | GPI_EVENT_EN_A: GPI_8_EVENT_EN
Public property | GPIEVENTENBGPI10EVENTEN | GPI_EVENT_EN_B: GPI_10_EVENT_EN
Public property | GPIEVENTENBGPI11EVENTEN | GPI_EVENT_EN_B: GPI_11_EVENT_EN
Public property | GPIEVENTENBGPI12EVENTEN | GPI_EVENT_EN_B: GPI_12_EVENT_EN
Public property | GPIEVENTENBGPI13EVENTEN | GPI_EVENT_EN_B: GPI_13_EVENT_EN
Public property | GPIEVENTENBGPI14EVENTEN | GPI_EVENT_EN_B: GPI_14_EVENT_EN
Public property | GPIEVENTENBGPI15EVENTEN | GPI_EVENT_EN_B: GPI_15_EVENT_EN
Public property | GPIEVENTENBGPI16EVENTEN | GPI_EVENT_EN_B: GPI_16_EVENT_EN
Public property | GPIEVENTENBGPI9EVENTEN | GPI_EVENT_EN_B: GPI_9_EVENT_EN
Public property | GPIEVENTENCGPI17EVENTEN | GPI_EVENT_EN_C: GPI_17_EVENT_EN
Public property | GPIEVENTENCGPI18EVENTEN | GPI_EVENT_EN_C: GPI_18_EVENT_EN
Public property | GPIEVENTENCGPI19EVENTEN | GPI_EVENT_EN_C: GPI_19_EVENT_EN
Public property | GPIINTERRUPTENAGPI1INTEN | GPI_INTERRUPT_EN_A: GPI_1_INT_EN
Public property | GPIINTERRUPTENAGPI2INTEN | GPI_INTERRUPT_EN_A: GPI_2_INT_EN
Public property | GPIINTERRUPTENAGPI3INTEN | GPI_INTERRUPT_EN_A: GPI_3_INT_EN
Public property | GPIINTERRUPTENAGPI4INTEN | GPI_INTERRUPT_EN_A: GPI_4_INT_EN
Public property | GPIINTERRUPTENAGPI5INTEN | GPI_INTERRUPT_EN_A: GPI_5_INT_EN
Public property | GPIINTERRUPTENAGPI6INTEN | GPI_INTERRUPT_EN_A: GPI_6_INT_EN
Public property | GPIINTERRUPTENAGPI7INTEN | GPI_INTERRUPT_EN_A: GPI_7_INT_EN
Public property | GPIINTERRUPTENAGPI8INTEN | GPI_INTERRUPT_EN_A: GPI_8_INT_EN
Public property | GPIINTERRUPTENBGPI10INTEN | GPI_INTERRUPT_EN_B: GPI_10_INT_EN
Public property | GPIINTERRUPTENBGPI11INTEN | GPI_INTERRUPT_EN_B: GPI_11_INT_EN
Public property | GPIINTERRUPTENBGPI12INTEN | GPI_INTERRUPT_EN_B: GPI_12_INT_EN
Public property | GPIINTERRUPTENBGPI13INTEN | GPI_INTERRUPT_EN_B: GPI_13_INT_EN
Public property | GPIINTERRUPTENBGPI14INTEN | GPI_INTERRUPT_EN_B: GPI_14_INT_EN
Public property | GPIINTERRUPTENBGPI15INTEN | GPI_INTERRUPT_EN_B: GPI_15_INT_EN
Public property | GPIINTERRUPTENBGPI16INTEN | GPI_INTERRUPT_EN_B: GPI_16_INT_EN
Public property | GPIINTERRUPTENBGPI9INTEN | GPI_INTERRUPT_EN_B: GPI_9_INT_EN
Public property | GPIINTERRUPTENCGPI17INTEN | GPI_INTERRUPT_EN_C: GPI_17_INT_EN
Public property | GPIINTERRUPTENCGPI18INTEN | GPI_INTERRUPT_EN_C: GPI_18_INT_EN
Public property | GPIINTERRUPTENCGPI19INTEN | GPI_INTERRUPT_EN_C: GPI_19_INT_EN
Public property | GPIINTLEVELAGPI1INTLEVEL | GPI_INT_LEVEL_A: GPI_1_INT_LEVEL
Public property | GPIINTLEVELAGPI2INTLEVEL | GPI_INT_LEVEL_A: GPI_2_INT_LEVEL
Public property | GPIINTLEVELAGPI3INTLEVEL | GPI_INT_LEVEL_A: GPI_3_INT_LEVEL
Public property | GPIINTLEVELAGPI4INTLEVEL | GPI_INT_LEVEL_A: GPI_4_INT_LEVEL
Public property | GPIINTLEVELAGPI5INTLEVEL | GPI_INT_LEVEL_A: GPI_5_INT_LEVEL
Public property | GPIINTLEVELAGPI6INTLEVEL | GPI_INT_LEVEL_A: GPI_6_INT_LEVEL
Public property | GPIINTLEVELAGPI7INTLEVEL | GPI_INT_LEVEL_A: GPI_7_INT_LEVEL
Public property | GPIINTLEVELAGPI8INTLEVEL | GPI_INT_LEVEL_A: GPI_8_INT_LEVEL
Public property | GPIINTLEVELBGPI10INTLEVEL | GPI_INT_LEVEL_B: GPI_10_INT_LEVEL
Public property | GPIINTLEVELBGPI11INTLEVEL | GPI_INT_LEVEL_B: GPI_11_INT_LEVEL
Public property | GPIINTLEVELBGPI12INTLEVEL | GPI_INT_LEVEL_B: GPI_12_INT_LEVEL
Public property | GPIINTLEVELBGPI13INTLEVEL | GPI_INT_LEVEL_B: GPI_13_INT_LEVEL
Public property | GPIINTLEVELBGPI14INTLEVEL | GPI_INT_LEVEL_B: GPI_14_INT_LEVEL
Public property | GPIINTLEVELBGPI15INTLEVEL | GPI_INT_LEVEL_B: GPI_15_INT_LEVEL
Public property | GPIINTLEVELBGPI16INTLEVEL | GPI_INT_LEVEL_B: GPI_16_INT_LEVEL
Public property | GPIINTLEVELBGPI9INTLEVEL | GPI_INT_LEVEL_B: GPI_9_INT_LEVEL
Public property | GPIINTLEVELCGPI17INTLEVEL | GPI_INT_LEVEL_C: GPI_17_INT_LEVEL
Public property | GPIINTLEVELCGPI18INTLEVEL | GPI_INT_LEVEL_C: GPI_18_INT_LEVEL
Public property | GPIINTLEVELCGPI19INTLEVEL | GPI_INT_LEVEL_C: GPI_19_INT_LEVEL
Public property | GPIINTSTATAGPI1INT | GPI_INT_STAT_A: GPI_1_INT
Public property | GPIINTSTATAGPI2INT | GPI_INT_STAT_A: GPI_2_INT
Public property | GPIINTSTATAGPI3INT | GPI_INT_STAT_A: GPI_3_INT
Public property | GPIINTSTATAGPI4INT | GPI_INT_STAT_A: GPI_4_INT
Public property | GPIINTSTATAGPI5INT | GPI_INT_STAT_A: GPI_5_INT
Public property | GPIINTSTATAGPI6INT | GPI_INT_STAT_A: GPI_6_INT
Public property | GPIINTSTATAGPI7INT | GPI_INT_STAT_A: GPI_7_INT
Public property | GPIINTSTATAGPI8INT | GPI_INT_STAT_A: GPI_8_INT
Public property | GPIINTSTATBGPI10INT | GPI_INT_STAT_B: GPI_10_INT
Public property | GPIINTSTATBGPI11INT | GPI_INT_STAT_B: GPI_11_INT
Public property | GPIINTSTATBGPI12INT | GPI_INT_STAT_B: GPI_12_INT
Public property | GPIINTSTATBGPI13INT | GPI_INT_STAT_B: GPI_13_INT
Public property | GPIINTSTATBGPI14INT | GPI_INT_STAT_B: GPI_14_INT
Public property | GPIINTSTATBGPI15INT | GPI_INT_STAT_B: GPI_15_INT
Public property | GPIINTSTATBGPI16INT | GPI_INT_STAT_B: GPI_16_INT
Public property | GPIINTSTATBGPI9INT | GPI_INT_STAT_B: GPI_9_INT
Public property | GPIINTSTATCGPI17INT | GPI_INT_STAT_C: GPI_17_INT
Public property | GPIINTSTATCGPI18INT | GPI_INT_STAT_C: GPI_18_INT
Public property | GPIINTSTATCGPI19INT | GPI_INT_STAT_C: GPI_19_INT
Public property | GPIODIRECTIONAGPIO1DIR | GPIO_DIRECTION_A: GPIO_1_DIR
Public property | GPIODIRECTIONAGPIO2DIR | GPIO_DIRECTION_A: GPIO_2_DIR
Public property | GPIODIRECTIONAGPIO3DIR | GPIO_DIRECTION_A: GPIO_3_DIR
Public property | GPIODIRECTIONAGPIO4DIR | GPIO_DIRECTION_A: GPIO_4_DIR
Public property | GPIODIRECTIONAGPIO5DIR | GPIO_DIRECTION_A: GPIO_5_DIR
Public property | GPIODIRECTIONAGPIO6DIR | GPIO_DIRECTION_A: GPIO_6_DIR
Public property | GPIODIRECTIONAGPIO7DIR | GPIO_DIRECTION_A: GPIO_7_DIR
Public property | GPIODIRECTIONAGPIO8DIR | GPIO_DIRECTION_A: GPIO_8_DIR
Public property | GPIODIRECTIONBGPIO10DIR | GPIO_DIRECTION_B: GPIO_10_DIR
Public property | GPIODIRECTIONBGPIO11DIR | GPIO_DIRECTION_B: GPIO_11_DIR
Public property | GPIODIRECTIONBGPIO12DIR | GPIO_DIRECTION_B: GPIO_12_DIR
Public property | GPIODIRECTIONBGPIO13DIR | GPIO_DIRECTION_B: GPIO_13_DIR
Public property | GPIODIRECTIONBGPIO14DIR | GPIO_DIRECTION_B: GPIO_14_DIR
Public property | GPIODIRECTIONBGPIO15DIR | GPIO_DIRECTION_B: GPIO_15_DIR
Public property | GPIODIRECTIONBGPIO16DIR | GPIO_DIRECTION_B: GPIO_16_DIR
Public property | GPIODIRECTIONBGPIO9DIR | GPIO_DIRECTION_B: GPIO_9_DIR
Public property | GPIODIRECTIONCGPIO17DIR | GPIO_DIRECTION_C: GPIO_17_DIR
Public property | GPIODIRECTIONCGPIO18DIR | GPIO_DIRECTION_C: GPIO_18_DIR
Public property | GPIODIRECTIONCGPIO19DIR | GPIO_DIRECTION_C: GPIO_19_DIR
Public property | GPISTATUSAGPI1STAT | GPI_STATUS_A: GPI_1_STAT
Public property | GPISTATUSAGPI2STAT | GPI_STATUS_A: GPI_2_STAT
Public property | GPISTATUSAGPI3STAT | GPI_STATUS_A: GPI_3_STAT
Public property | GPISTATUSAGPI4STAT | GPI_STATUS_A: GPI_4_STAT
Public property | GPISTATUSAGPI5STAT | GPI_STATUS_A: GPI_5_STAT
Public property | GPISTATUSAGPI6STAT | GPI_STATUS_A: GPI_6_STAT
Public property | GPISTATUSAGPI7STAT | GPI_STATUS_A: GPI_7_STAT
Public property | GPISTATUSAGPI8STAT | GPI_STATUS_A: GPI_8_STAT
Public property | GPISTATUSBGPI10STAT | GPI_STATUS_B: GPI_10_STAT
Public property | GPISTATUSBGPI11STAT | GPI_STATUS_B: GPI_11_STAT
Public property | GPISTATUSBGPI12STAT | GPI_STATUS_B: GPI_12_STAT
Public property | GPISTATUSBGPI13STAT | GPI_STATUS_B: GPI_13_STAT
Public property | GPISTATUSBGPI14STAT | GPI_STATUS_B: GPI_14_STAT
Public property | GPISTATUSBGPI15STAT | GPI_STATUS_B: GPI_15_STAT
Public property | GPISTATUSBGPI16STAT | GPI_STATUS_B: GPI_16_STAT
Public property | GPISTATUSBGPI9STAT | GPI_STATUS_B: GPI_9_STAT
Public property | GPISTATUSCGPI17STAT | GPI_STATUS_C: GPI_17_STAT
Public property | GPISTATUSCGPI18STAT | GPI_STATUS_C: GPI_18_STAT
Public property | GPISTATUSCGPI19STAT | GPI_STATUS_C: GPI_19_STAT
Public property | GPODATAOUTAGPO1DATA | GPO_DATA_OUT_A: GPO_1_DATA
Public property | GPODATAOUTAGPO2DATA | GPO_DATA_OUT_A: GPO_2_DATA
Public property | GPODATAOUTAGPO3DATA | GPO_DATA_OUT_A: GPO_3_DATA
Public property | GPODATAOUTAGPO4DATA | GPO_DATA_OUT_A: GPO_4_DATA
Public property | GPODATAOUTAGPO5DATA | GPO_DATA_OUT_A: GPO_5_DATA
Public property | GPODATAOUTAGPO6DATA | GPO_DATA_OUT_A: GPO_6_DATA
Public property | GPODATAOUTAGPO7DATA | GPO_DATA_OUT_A: GPO_7_DATA
Public property | GPODATAOUTAGPO8DATA | GPO_DATA_OUT_A: GPO_8_DATA
Public property | GPODATAOUTBGPO10DATA | GPO_DATA_OUT_B: GPO_10_DATA
Public property | GPODATAOUTBGPO11DATA | GPO_DATA_OUT_B: GPO_11_DATA
Public property | GPODATAOUTBGPO12DATA | GPO_DATA_OUT_B: GPO_12_DATA
Public property | GPODATAOUTBGPO13DATA | GPO_DATA_OUT_B: GPO_13_DATA
Public property | GPODATAOUTBGPO14DATA | GPO_DATA_OUT_B: GPO_14_DATA
Public property | GPODATAOUTBGPO15DATA | GPO_DATA_OUT_B: GPO_15_DATA
Public property | GPODATAOUTBGPO16DATA | GPO_DATA_OUT_B: GPO_16_DATA
Public property | GPODATAOUTBGPO9DATA | GPO_DATA_OUT_B: GPO_9_DATA
Public property | GPODATAOUTCGPO17DATA | GPO_DATA_OUT_C: GPO_17_DATA
Public property | GPODATAOUTCGPO18DATA | GPO_DATA_OUT_C: GPO_18_DATA
Public property | GPODATAOUTCGPO19DATA | GPO_DATA_OUT_C: GPO_19_DATA
Public property | GPOOUTMODEAGPO1OUTMODE | GPO_OUT_MODE_A: GPO_1_OUT_MODE
Public property | GPOOUTMODEAGPO2OUTMODE | GPO_OUT_MODE_A: GPO_2_OUT_MODE
Public property | GPOOUTMODEAGPO3OUTMODE | GPO_OUT_MODE_A: GPO_3_OUT_MODE
Public property | GPOOUTMODEAGPO4OUTMODE | GPO_OUT_MODE_A: GPO_4_OUT_MODE
Public property | GPOOUTMODEAGPO5OUTMODE | GPO_OUT_MODE_A: GPO_5_OUT_MODE
Public property | GPOOUTMODEAGPO6OUTMODE | GPO_OUT_MODE_A: GPO_6_OUT_MODE
Public property | GPOOUTMODEAGPO7OUTMODE | GPO_OUT_MODE_A: GPO_7_OUT_MODE
Public property | GPOOUTMODEAGPO8OUTMODE | GPO_OUT_MODE_A: GPO_8_OUT_MODE
Public property | GPOOUTMODEBGPO10OUTMODE | GPO_OUT_MODE_B: GPO_10_OUT_MODE
Public property | GPOOUTMODEBGPO11OUTMODE | GPO_OUT_MODE_B: GPO_11_OUT_MODE
Public property | GPOOUTMODEBGPO12OUTMODE | GPO_OUT_MODE_B: GPO_12_OUT_MODE
Public property | GPOOUTMODEBGPO13OUTMODE | GPO_OUT_MODE_B: GPO_13_OUT_MODE
Public property | GPOOUTMODEBGPO14OUTMODE | GPO_OUT_MODE_B: GPO_14_OUT_MODE
Public property | GPOOUTMODEBGPO15OUTMODE | GPO_OUT_MODE_B: GPO_15_OUT_MODE
Public property | GPOOUTMODEBGPO16OUTMODE | GPO_OUT_MODE_B: GPO_16_OUT_MODE
Public property | GPOOUTMODEBGPO9OUTMODE | GPO_OUT_MODE_B: GPO_9_OUT_MODE
Public property | GPOOUTMODECGPO17OUTMODE | GPO_OUT_MODE_C: GPO_17_OUT_MODE
Public property | GPOOUTMODECGPO18OUTMODE | GPO_OUT_MODE_C: GPO_18_OUT_MODE
Public property | GPOOUTMODECGPO19OUTMODE | GPO_OUT_MODE_C: GPO_19_OUT_MODE
Public property | IDMANID | ID: MAN_ID
Public property | IDREVID | ID: REV_ID
Public property | INTENEVENTIEN | INT_EN: EVENT_IEN
Public property | INTENGPIIEN | INT_EN: GPI_IEN
Public property | INTENLOCKEN | INT_EN: LOCK_EN
Public property | INTENLOGIC1EN | INT_EN: LOGIC1_EN
Public property | INTENLOGIC2EN | INT_EN: LOGIC2_EN
Public property | INTENOVRFLOWIEN | INT_EN: OVRFLOW_IEN
Public property | INTSTATUSEVENTINT | INT_STATUS: EVENT_INT
Public property | INTSTATUSGPIINT | INT_STATUS: GPI_INT
Public property | INTSTATUSLOCKINT | INT_STATUS: LOCK_INT
Public property | INTSTATUSLOGIC1INT | INT_STATUS: LOGIC1_INT
Public property | INTSTATUSLOGIC2INT | INT_STATUS: LOGIC2_INT
Public property | INTSTATUSOVRFLOWINT | INT_STATUS: OVRFLOW_INT
Public property | LOCKCFGLOCKEN | LOCK_CFG: LOCK_EN
Public property | LOGIC1CFGLA1INV | LOGIC_1_CFG: LA1_INV
Public property | LOGIC1CFGLB1INV | LOGIC_1_CFG: LB1_INV
Public property | LOGIC1CFGLC1INV | LOGIC_1_CFG: LC1_INV
Public property | LOGIC1CFGLOGIC1SEL | LOGIC_1_CFG: LOGIC1_SEL
Public property | LOGIC1CFGLY1INV | LOGIC_1_CFG: LY1_INV
Public property | LOGIC2CFGLA2INV | LOGIC_2_CFG: LA2_INV
Public property | LOGIC2CFGLB2INV | LOGIC_2_CFG: LB2_INV
Public property | LOGIC2CFGLC2INV | LOGIC_2_CFG: LC2_INV
Public property | LOGIC2CFGLOGIC2SEL | LOGIC_2_CFG: LOGIC2_SEL
Public property | LOGIC2CFGLY1CASCADE | LOGIC_2_CFG: LY1_CASCADE
Public property | LOGIC2CFGLY2INV | LOGIC_2_CFG: LY2_INV
Public property | LOGICFFCFGFF1CLR | LOGIC_FF_CFG: FF1_CLR
Public property | LOGICFFCFGFF1SET | LOGIC_FF_CFG: FF1_SET
Public property | LOGICFFCFGFF2CLR | LOGIC_FF_CFG: FF2_CLR
Public property | LOGICFFCFGFF2SET | LOGIC_FF_CFG: FF2_SET
Public property | LOGICINTEVENTENLOGIC1EVENTEN | LOGIC_INT_EVENT_EN: LOGIC1_EVENT_EN
Public property | LOGICINTEVENTENLOGIC1INTLEVEL | LOGIC_INT_EVENT_EN: LOGIC1_INT_LEVEL
Public property | LOGICINTEVENTENLOGIC2EVENTEN | LOGIC_INT_EVENT_EN: LOGIC2_EVENT_EN
Public property | LOGICINTEVENTENLOGIC2INTLEVEL | LOGIC_INT_EVENT_EN: LOGIC2_INT_LEVEL
Public property | LOGICINTEVENTENLY1DBNCDIS | LOGIC_INT_EVENT_EN: LY1_DBNC_DIS
Public property | LOGICINTEVENTENLY2DBNCDIS | LOGIC_INT_EVENT_EN: LY2_DBNC_DIS
Public property | PINCONFIGAR0CONFIG | PIN_CONFIG_A: R0_CONFIG
Public property | PINCONFIGAR1CONFIG | PIN_CONFIG_A: R1_CONFIG
Public property | PINCONFIGAR2CONFIG | PIN_CONFIG_A: R2_CONFIG
Public property | PINCONFIGAR3CONFIG | PIN_CONFIG_A: R3_CONFIG
Public property | PINCONFIGAR4CONFIG | PIN_CONFIG_A: R4_CONFIG
Public property | PINCONFIGAR5CONFIG | PIN_CONFIG_A: R5_CONFIG
Public property | PINCONFIGAR6CONFIG | PIN_CONFIG_A: R6_CONFIG
Public property | PINCONFIGAR7CONFIG | PIN_CONFIG_A: R7_CONFIG
Public property | PINCONFIGBC0CONFIG | PIN_CONFIG_B: C0_CONFIG
Public property | PINCONFIGBC1CONFIG | PIN_CONFIG_B: C1_CONFIG
Public property | PINCONFIGBC2CONFIG | PIN_CONFIG_B: C2_CONFIG
Public property | PINCONFIGBC3CONFIG | PIN_CONFIG_B: C3_CONFIG
Public property | PINCONFIGBC4CONFIG | PIN_CONFIG_B: C4_CONFIG
Public property | PINCONFIGBC5CONFIG | PIN_CONFIG_B: C5_CONFIG
Public property | PINCONFIGBC6CONFIG | PIN_CONFIG_B: C6_CONFIG
Public property | PINCONFIGBC7CONFIG | PIN_CONFIG_B: C7_CONFIG
Public property | PINCONFIGCC10CONFIG | PIN_CONFIG_C: C10_CONFIG
Public property | PINCONFIGCC8CONFIG | PIN_CONFIG_C: C8_CONFIG
Public property | PINCONFIGCC9CONFIG | PIN_CONFIG_C: C9_CONFIG
Public property | PINCONFIGDC4EXTENDCFG | PIN_CONFIG_D: C4_EXTEND_CFG
Public property | PINCONFIGDC6EXTENDCFG | PIN_CONFIG_D: C6_EXTEND_CFG
Public property | PINCONFIGDC9EXTENDCFG | PIN_CONFIG_D: C9_EXTEND_CFG
Public property | PINCONFIGDPULLSELECT | PIN_CONFIG_D: PULL_SELECT
Public property | PINCONFIGDR0EXTENDCFG | PIN_CONFIG_D: R0_EXTEND_CFG
Public property | PINCONFIGDR3EXTENDCFG | PIN_CONFIG_D: R3_EXTEND_CFG
Public property | PINCONFIGDR4EXTENDCFG | PIN_CONFIG_D: R4_EXTEND_CFG
Public property | POLLTIMECFGKEYPOLLTIME | POLL_TIME_CFG: KEY_POLL_TIME
Public property | PWMCFGPWMEN | PWM_CFG: PWM_EN
Public property | PWMCFGPWMINAND | PWM_CFG: PWM_IN_AND
Public property | PWMCFGPWMMODE | PWM_CFG: PWM_MODE
Public property | PWMOFFT | PWM_OFFT (unit: µs)
Public property | PWMONT | PWM_ONT (unit: µs)
Public property | RESET1EVENTARESET1EVENTA | RESET1_EVENT_A: RESET1_EVENT_A
Public property | RESET1EVENTARESET1EVENTALEVEL | RESET1_EVENT_A: RESET1_EVENT_A_LEVEL
Public property | RESET1EVENTBRESET1EVENTB | RESET1_EVENT_B: RESET1_EVENT_B
Public property | RESET1EVENTBRESET1EVENTBLEVEL | RESET1_EVENT_B: RESET1_EVENT_B_LEVEL
Public property | RESET1EVENTCRESET1EVENTC | RESET1_EVENT_C: RESET1_EVENT_C
Public property | RESET1EVENTCRESET1EVENTCLEVEL | RESET1_EVENT_C: RESET1_EVENT_C_LEVEL
Public property | RESET2EVENTARESET2EVENTA | RESET2_EVENT_A: RESET2_EVENT_A
Public property | RESET2EVENTARESET2EVENTALEVEL | RESET2_EVENT_A: RESET2_EVENT_A_LEVEL
Public property | RESET2EVENTBRESET2EVENTB | RESET2_EVENT_B: RESET2_EVENT_B
Public property | RESET2EVENTBRESET2EVENTBLEVEL | RESET2_EVENT_B: RESET2_EVENT_B_LEVEL
Public property | RESETCFGRESET1POL | RESET_CFG: RESET1_POL
Public property | RESETCFGRESET2POL | RESET_CFG: RESET2_POL
Public property | RESETCFGRESETPULSEWIDTH | RESET_CFG: RESET_PULSE_WIDTH
Public property | RESETCFGRESETTRIGGERTIME | RESET_CFG: RESET_TRIGGER_TIME (unit: s)
Public property | RESETCFGRSTPASSTHRUEN | RESET_CFG: RST_PASSTHRU_EN
Public property | RPULLCONFIGAR0PULLCFG | RPULL_CONFIG_A: R0_PULL_CFG
Public property | RPULLCONFIGAR1PULLCFG | RPULL_CONFIG_A: R1_PULL_CFG
Public property | RPULLCONFIGAR2PULLCFG | RPULL_CONFIG_A: R2_PULL_CFG
Public property | RPULLCONFIGAR3PULLCFG | RPULL_CONFIG_A: R3_PULL_CFG
Public property | RPULLCONFIGBR4PULLCFG | RPULL_CONFIG_B: R4_PULL_CFG
Public property | RPULLCONFIGBR5PULLCFG | RPULL_CONFIG_B: R5_PULL_CFG
Public property | RPULLCONFIGBR6PULLCFG | RPULL_CONFIG_B: R6_PULL_CFG
Public property | RPULLCONFIGBR7PULLCFG | RPULL_CONFIG_B: R7_PULL_CFG
Public property | RPULLCONFIGCC0PULLCFG | RPULL_CONFIG_C: C0_PULL_CFG
Public property | RPULLCONFIGCC1PULLCFG | RPULL_CONFIG_C: C1_PULL_CFG
Public property | RPULLCONFIGCC2PULLCFG | RPULL_CONFIG_C: C2_PULL_CFG
Public property | RPULLCONFIGCC3PULLCFG | RPULL_CONFIG_C: C3_PULL_CFG
Public property | RPULLCONFIGDC4PULLCFG | RPULL_CONFIG_D: C4_PULL_CFG
Public property | RPULLCONFIGDC5PULLCFG | RPULL_CONFIG_D: C5_PULL_CFG
Public property | RPULLCONFIGDC6PULLCFG | RPULL_CONFIG_D: C6_PULL_CFG
Public property | RPULLCONFIGDC7PULLCFG | RPULL_CONFIG_D: C7_PULL_CFG
Public property | RPULLCONFIGEC10PULLCFG | RPULL_CONFIG_E: C10_PULL_CFG
Public property | RPULLCONFIGEC8PULLCFG | RPULL_CONFIG_E: C8_PULL_CFG
Public property | RPULLCONFIGEC9PULLCFG | RPULL_CONFIG_E: C9_PULL_CFG
Public property | STATUSEC | STATUS: EC
Public property | STATUSLOCKSTAT | STATUS: LOCK_STAT
Public property | STATUSLOGIC1STAT | STATUS: LOGIC1_STAT
Public property | STATUSLOGIC2STAT | STATUS: LOGIC2_STAT
Public property | UNLOCK1UNLOCK1 | UNLOCK1: UNLOCK1
Public property | UNLOCK1UNLOCK1STATE | UNLOCK1: UNLOCK1_STATE
Public property | UNLOCK2UNLOCK2 | UNLOCK2: UNLOCK2
Public property | UNLOCK2UNLOCK2STATE | UNLOCK2: UNLOCK2_STATE
Public property | UNLOCKTIMERSINTMASKTIMER | UNLOCK_TIMERS: INT_MASK_TIMER (unit: s)
Public property | UNLOCKTIMERSUNLOCKTIMER | UNLOCK_TIMERS: UNLOCK_TIMER (unit: s)
Top
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.AutoFlush Property

IRD

Adp5589AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.CLOCKDIVCFGCLKDIV Property

IRD

Adp5589CLOCKDIVCFGCLKDIV Property

CLOCK_DIV_CFG: CLK_DIV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CLOCKDIVCFGCLKDIV { get; set; }
Public Property CLOCKDIVCFGCLKDIV As Byte
    Get
    Set
public:
property unsigned char CLOCKDIVCFGCLKDIV {
    unsigned char get ();
    void set (unsigned char value);
}
member CLOCKDIVCFGCLKDIV : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.CLOCKDIVCFGCLKDIVEN Property

IRD

Adp5589CLOCKDIVCFGCLKDIVEN Property

CLOCK_DIV_CFG: CLK_DIV_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeClockDivCfgClkDivEn CLOCKDIVCFGCLKDIVEN { get; set; }
Public Property CLOCKDIVCFGCLKDIVEN As Adp5589TypeClockDivCfgClkDivEn
    Get
    Set
public:
property Adp5589TypeClockDivCfgClkDivEn CLOCKDIVCFGCLKDIVEN {
    Adp5589TypeClockDivCfgClkDivEn get ();
    void set (Adp5589TypeClockDivCfgClkDivEn value);
}
member CLOCKDIVCFGCLKDIVEN : Adp5589TypeClockDivCfgClkDivEn with get, set

Property Value

Type: Adp5589TypeClockDivCfgClkDivEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.CLOCKDIVCFGCLKINV Property

IRD

Adp5589CLOCKDIVCFGCLKINV Property

CLOCK_DIV_CFG: CLK_INV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeClockDivCfgClkInv CLOCKDIVCFGCLKINV { get; set; }
Public Property CLOCKDIVCFGCLKINV As Adp5589TypeClockDivCfgClkInv
    Get
    Set
public:
property Adp5589TypeClockDivCfgClkInv CLOCKDIVCFGCLKINV {
    Adp5589TypeClockDivCfgClkInv get ();
    void set (Adp5589TypeClockDivCfgClkInv value);
}
member CLOCKDIVCFGCLKINV : Adp5589TypeClockDivCfgClkInv with get, set

Property Value

Type: Adp5589TypeClockDivCfgClkInv
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISAGPI1DEBDIS Property

IRD

Adp5589DEBOUNCEDISAGPI1DEBDIS Property

DEBOUNCE_DIS_A: GPI_1_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISAGPI1DEBDIS { get; set; }
Public Property DEBOUNCEDISAGPI1DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISAGPI1DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISAGPI1DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISAGPI2DEBDIS Property

IRD

Adp5589DEBOUNCEDISAGPI2DEBDIS Property

DEBOUNCE_DIS_A: GPI_2_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISAGPI2DEBDIS { get; set; }
Public Property DEBOUNCEDISAGPI2DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISAGPI2DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISAGPI2DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISAGPI3DEBDIS Property

IRD

Adp5589DEBOUNCEDISAGPI3DEBDIS Property

DEBOUNCE_DIS_A: GPI_3_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISAGPI3DEBDIS { get; set; }
Public Property DEBOUNCEDISAGPI3DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISAGPI3DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISAGPI3DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISAGPI4DEBDIS Property

IRD

Adp5589DEBOUNCEDISAGPI4DEBDIS Property

DEBOUNCE_DIS_A: GPI_4_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISAGPI4DEBDIS { get; set; }
Public Property DEBOUNCEDISAGPI4DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISAGPI4DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISAGPI4DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISAGPI5DEBDIS Property

IRD

Adp5589DEBOUNCEDISAGPI5DEBDIS Property

DEBOUNCE_DIS_A: GPI_5_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISAGPI5DEBDIS { get; set; }
Public Property DEBOUNCEDISAGPI5DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISAGPI5DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISAGPI5DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISAGPI6DEBDIS Property

IRD

Adp5589DEBOUNCEDISAGPI6DEBDIS Property

DEBOUNCE_DIS_A: GPI_6_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISAGPI6DEBDIS { get; set; }
Public Property DEBOUNCEDISAGPI6DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISAGPI6DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISAGPI6DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISAGPI7DEBDIS Property

IRD

Adp5589DEBOUNCEDISAGPI7DEBDIS Property

DEBOUNCE_DIS_A: GPI_7_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISAGPI7DEBDIS { get; set; }
Public Property DEBOUNCEDISAGPI7DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISAGPI7DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISAGPI7DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISAGPI8DEBDIS Property

IRD

Adp5589DEBOUNCEDISAGPI8DEBDIS Property

DEBOUNCE_DIS_A: GPI_8_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISAGPI8DEBDIS { get; set; }
Public Property DEBOUNCEDISAGPI8DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISAGPI8DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISAGPI8DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISBGPI10DEBDIS Property

IRD

Adp5589DEBOUNCEDISBGPI10DEBDIS Property

DEBOUNCE_DIS_B: GPI_10_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISBGPI10DEBDIS { get; set; }
Public Property DEBOUNCEDISBGPI10DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISBGPI10DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISBGPI10DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISBGPI11DEBDIS Property

IRD

Adp5589DEBOUNCEDISBGPI11DEBDIS Property

DEBOUNCE_DIS_B: GPI_11_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISBGPI11DEBDIS { get; set; }
Public Property DEBOUNCEDISBGPI11DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISBGPI11DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISBGPI11DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISBGPI12DEBDIS Property

IRD

Adp5589DEBOUNCEDISBGPI12DEBDIS Property

DEBOUNCE_DIS_B: GPI_12_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISBGPI12DEBDIS { get; set; }
Public Property DEBOUNCEDISBGPI12DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISBGPI12DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISBGPI12DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISBGPI13DEBDIS Property

IRD

Adp5589DEBOUNCEDISBGPI13DEBDIS Property

DEBOUNCE_DIS_B: GPI_13_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISBGPI13DEBDIS { get; set; }
Public Property DEBOUNCEDISBGPI13DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISBGPI13DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISBGPI13DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISBGPI14DEBDIS Property

IRD

Adp5589DEBOUNCEDISBGPI14DEBDIS Property

DEBOUNCE_DIS_B: GPI_14_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISBGPI14DEBDIS { get; set; }
Public Property DEBOUNCEDISBGPI14DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISBGPI14DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISBGPI14DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISBGPI15DEBDIS Property

IRD

Adp5589DEBOUNCEDISBGPI15DEBDIS Property

DEBOUNCE_DIS_B: GPI_15_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISBGPI15DEBDIS { get; set; }
Public Property DEBOUNCEDISBGPI15DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISBGPI15DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISBGPI15DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISBGPI16DEBDIS Property

IRD

Adp5589DEBOUNCEDISBGPI16DEBDIS Property

DEBOUNCE_DIS_B: GPI_16_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISBGPI16DEBDIS { get; set; }
Public Property DEBOUNCEDISBGPI16DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISBGPI16DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISBGPI16DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISBGPI9DEBDIS Property

IRD

Adp5589DEBOUNCEDISBGPI9DEBDIS Property

DEBOUNCE_DIS_B: GPI_9_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISBGPI9DEBDIS { get; set; }
Public Property DEBOUNCEDISBGPI9DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISBGPI9DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISBGPI9DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISCGPI17DEBDIS Property

IRD

Adp5589DEBOUNCEDISCGPI17DEBDIS Property

DEBOUNCE_DIS_C: GPI_17_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISCGPI17DEBDIS { get; set; }
Public Property DEBOUNCEDISCGPI17DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISCGPI17DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISCGPI17DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISCGPI18DEBDIS Property

IRD

Adp5589DEBOUNCEDISCGPI18DEBDIS Property

DEBOUNCE_DIS_C: GPI_18_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISCGPI18DEBDIS { get; set; }
Public Property DEBOUNCEDISCGPI18DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISCGPI18DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISCGPI18DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.DEBOUNCEDISCGPI19DEBDIS Property

IRD

Adp5589DEBOUNCEDISCGPI19DEBDIS Property

DEBOUNCE_DIS_C: GPI_19_DEB_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeDebounceDis DEBOUNCEDISCGPI19DEBDIS { get; set; }
Public Property DEBOUNCEDISCGPI19DEBDIS As Adp5589TypeDebounceDis
    Get
    Set
public:
property Adp5589TypeDebounceDis DEBOUNCEDISCGPI19DEBDIS {
    Adp5589TypeDebounceDis get ();
    void set (Adp5589TypeDebounceDis value);
}
member DEBOUNCEDISCGPI19DEBDIS : Adp5589TypeDebounceDis with get, set

Property Value

Type: Adp5589TypeDebounceDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.EXTLOCKEVENTEXTLOCKEVENT Property

IRD

Adp5589EXTLOCKEVENTEXTLOCKEVENT Property

EXT_LOCK_EVENT: EXT_LOCK_EVENT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EXTLOCKEVENTEXTLOCKEVENT { get; set; }
Public Property EXTLOCKEVENTEXTLOCKEVENT As Byte
    Get
    Set
public:
property unsigned char EXTLOCKEVENTEXTLOCKEVENT {
    unsigned char get ();
    void set (unsigned char value);
}
member EXTLOCKEVENTEXTLOCKEVENT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.EXTLOCKEVENTEXTLOCKSTATE Property

IRD

Adp5589EXTLOCKEVENTEXTLOCKSTATE Property

EXT_LOCK_EVENT: EXT_LOCK_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EXTLOCKEVENTEXTLOCKSTATE { get; set; }
Public Property EXTLOCKEVENTEXTLOCKSTATE As Byte
    Get
    Set
public:
property unsigned char EXTLOCKEVENTEXTLOCKSTATE {
    unsigned char get ();
    void set (unsigned char value);
}
member EXTLOCKEVENTEXTLOCKSTATE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO10EVENT10IDENTIFIER Property

IRD

Adp5589FIFO10EVENT10IDENTIFIER Property

FIFO_10: EVENT10_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeFifoEventIdentifier FIFO10EVENT10IDENTIFIER { get; }
Public ReadOnly Property FIFO10EVENT10IDENTIFIER As Adp5589TypeFifoEventIdentifier
    Get
public:
property Adp5589TypeFifoEventIdentifier FIFO10EVENT10IDENTIFIER {
    Adp5589TypeFifoEventIdentifier get ();
}
member FIFO10EVENT10IDENTIFIER : Adp5589TypeFifoEventIdentifier with get

Property Value

Type: Adp5589TypeFifoEventIdentifier
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO10EVENT10STATE Property

IRD

Adp5589FIFO10EVENT10STATE Property

FIFO_10: EVENT10_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO10EVENT10STATE { get; }
Public ReadOnly Property FIFO10EVENT10STATE As Byte
    Get
public:
property unsigned char FIFO10EVENT10STATE {
    unsigned char get ();
}
member FIFO10EVENT10STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO11EVENT11IDENTIFIER Property

IRD

Adp5589FIFO11EVENT11IDENTIFIER Property

FIFO_11: EVENT11_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeFifoEventIdentifier FIFO11EVENT11IDENTIFIER { get; }
Public ReadOnly Property FIFO11EVENT11IDENTIFIER As Adp5589TypeFifoEventIdentifier
    Get
public:
property Adp5589TypeFifoEventIdentifier FIFO11EVENT11IDENTIFIER {
    Adp5589TypeFifoEventIdentifier get ();
}
member FIFO11EVENT11IDENTIFIER : Adp5589TypeFifoEventIdentifier with get

Property Value

Type: Adp5589TypeFifoEventIdentifier
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO11EVENT11STATE Property

IRD

Adp5589FIFO11EVENT11STATE Property

FIFO_11: EVENT11_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO11EVENT11STATE { get; }
Public ReadOnly Property FIFO11EVENT11STATE As Byte
    Get
public:
property unsigned char FIFO11EVENT11STATE {
    unsigned char get ();
}
member FIFO11EVENT11STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO12EVENT12IDENTIFIER Property

IRD

Adp5589FIFO12EVENT12IDENTIFIER Property

FIFO_12: EVENT12_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeFifoEventIdentifier FIFO12EVENT12IDENTIFIER { get; }
Public ReadOnly Property FIFO12EVENT12IDENTIFIER As Adp5589TypeFifoEventIdentifier
    Get
public:
property Adp5589TypeFifoEventIdentifier FIFO12EVENT12IDENTIFIER {
    Adp5589TypeFifoEventIdentifier get ();
}
member FIFO12EVENT12IDENTIFIER : Adp5589TypeFifoEventIdentifier with get

Property Value

Type: Adp5589TypeFifoEventIdentifier
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO12EVENT12STATE Property

IRD

Adp5589FIFO12EVENT12STATE Property

FIFO_12: EVENT12_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO12EVENT12STATE { get; }
Public ReadOnly Property FIFO12EVENT12STATE As Byte
    Get
public:
property unsigned char FIFO12EVENT12STATE {
    unsigned char get ();
}
member FIFO12EVENT12STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO13EVENT13IDENTIFIER Property

IRD

Adp5589FIFO13EVENT13IDENTIFIER Property

FIFO_13: EVENT13_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeFifoEventIdentifier FIFO13EVENT13IDENTIFIER { get; }
Public ReadOnly Property FIFO13EVENT13IDENTIFIER As Adp5589TypeFifoEventIdentifier
    Get
public:
property Adp5589TypeFifoEventIdentifier FIFO13EVENT13IDENTIFIER {
    Adp5589TypeFifoEventIdentifier get ();
}
member FIFO13EVENT13IDENTIFIER : Adp5589TypeFifoEventIdentifier with get

Property Value

Type: Adp5589TypeFifoEventIdentifier
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO13EVENT13STATE Property

IRD

Adp5589FIFO13EVENT13STATE Property

FIFO_13: EVENT13_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO13EVENT13STATE { get; }
Public ReadOnly Property FIFO13EVENT13STATE As Byte
    Get
public:
property unsigned char FIFO13EVENT13STATE {
    unsigned char get ();
}
member FIFO13EVENT13STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO14EVENT14IDENTIFIER Property

IRD

Adp5589FIFO14EVENT14IDENTIFIER Property

FIFO_14: EVENT14_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeFifoEventIdentifier FIFO14EVENT14IDENTIFIER { get; }
Public ReadOnly Property FIFO14EVENT14IDENTIFIER As Adp5589TypeFifoEventIdentifier
    Get
public:
property Adp5589TypeFifoEventIdentifier FIFO14EVENT14IDENTIFIER {
    Adp5589TypeFifoEventIdentifier get ();
}
member FIFO14EVENT14IDENTIFIER : Adp5589TypeFifoEventIdentifier with get

Property Value

Type: Adp5589TypeFifoEventIdentifier
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO14EVENT14STATE Property

IRD

Adp5589FIFO14EVENT14STATE Property

FIFO_14: EVENT14_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO14EVENT14STATE { get; }
Public ReadOnly Property FIFO14EVENT14STATE As Byte
    Get
public:
property unsigned char FIFO14EVENT14STATE {
    unsigned char get ();
}
member FIFO14EVENT14STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO15EVENT15IDENTIFIER Property

IRD

Adp5589FIFO15EVENT15IDENTIFIER Property

FIFO_15: EVENT15_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeFifoEventIdentifier FIFO15EVENT15IDENTIFIER { get; }
Public ReadOnly Property FIFO15EVENT15IDENTIFIER As Adp5589TypeFifoEventIdentifier
    Get
public:
property Adp5589TypeFifoEventIdentifier FIFO15EVENT15IDENTIFIER {
    Adp5589TypeFifoEventIdentifier get ();
}
member FIFO15EVENT15IDENTIFIER : Adp5589TypeFifoEventIdentifier with get

Property Value

Type: Adp5589TypeFifoEventIdentifier
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO15EVENT15STATE Property

IRD

Adp5589FIFO15EVENT15STATE Property

FIFO_15: EVENT15_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO15EVENT15STATE { get; }
Public ReadOnly Property FIFO15EVENT15STATE As Byte
    Get
public:
property unsigned char FIFO15EVENT15STATE {
    unsigned char get ();
}
member FIFO15EVENT15STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO16EVENT16IDENTIFIER Property

IRD

Adp5589FIFO16EVENT16IDENTIFIER Property

FIFO_16: EVENT16_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeFifoEventIdentifier FIFO16EVENT16IDENTIFIER { get; }
Public ReadOnly Property FIFO16EVENT16IDENTIFIER As Adp5589TypeFifoEventIdentifier
    Get
public:
property Adp5589TypeFifoEventIdentifier FIFO16EVENT16IDENTIFIER {
    Adp5589TypeFifoEventIdentifier get ();
}
member FIFO16EVENT16IDENTIFIER : Adp5589TypeFifoEventIdentifier with get

Property Value

Type: Adp5589TypeFifoEventIdentifier
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO16EVENT16STATE Property

IRD

Adp5589FIFO16EVENT16STATE Property

FIFO_16: EVENT16_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO16EVENT16STATE { get; }
Public ReadOnly Property FIFO16EVENT16STATE As Byte
    Get
public:
property unsigned char FIFO16EVENT16STATE {
    unsigned char get ();
}
member FIFO16EVENT16STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO1EVENT1IDENTIFIER Property

IRD

Adp5589FIFO1EVENT1IDENTIFIER Property

FIFO_1: EVENT1_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeFifoEventIdentifier FIFO1EVENT1IDENTIFIER { get; }
Public ReadOnly Property FIFO1EVENT1IDENTIFIER As Adp5589TypeFifoEventIdentifier
    Get
public:
property Adp5589TypeFifoEventIdentifier FIFO1EVENT1IDENTIFIER {
    Adp5589TypeFifoEventIdentifier get ();
}
member FIFO1EVENT1IDENTIFIER : Adp5589TypeFifoEventIdentifier with get

Property Value

Type: Adp5589TypeFifoEventIdentifier
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO1EVENT1STATE Property

IRD

Adp5589FIFO1EVENT1STATE Property

FIFO_1: EVENT1_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO1EVENT1STATE { get; }
Public ReadOnly Property FIFO1EVENT1STATE As Byte
    Get
public:
property unsigned char FIFO1EVENT1STATE {
    unsigned char get ();
}
member FIFO1EVENT1STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO2EVENT2IDENTIFIER Property

IRD

Adp5589FIFO2EVENT2IDENTIFIER Property

FIFO_2: EVENT2_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeFifoEventIdentifier FIFO2EVENT2IDENTIFIER { get; }
Public ReadOnly Property FIFO2EVENT2IDENTIFIER As Adp5589TypeFifoEventIdentifier
    Get
public:
property Adp5589TypeFifoEventIdentifier FIFO2EVENT2IDENTIFIER {
    Adp5589TypeFifoEventIdentifier get ();
}
member FIFO2EVENT2IDENTIFIER : Adp5589TypeFifoEventIdentifier with get

Property Value

Type: Adp5589TypeFifoEventIdentifier
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO2EVENT2STATE Property

IRD

Adp5589FIFO2EVENT2STATE Property

FIFO_2: EVENT2_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO2EVENT2STATE { get; }
Public ReadOnly Property FIFO2EVENT2STATE As Byte
    Get
public:
property unsigned char FIFO2EVENT2STATE {
    unsigned char get ();
}
member FIFO2EVENT2STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO3EVENT3IDENTIFIER Property

IRD

Adp5589FIFO3EVENT3IDENTIFIER Property

FIFO_3: EVENT3_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeFifoEventIdentifier FIFO3EVENT3IDENTIFIER { get; }
Public ReadOnly Property FIFO3EVENT3IDENTIFIER As Adp5589TypeFifoEventIdentifier
    Get
public:
property Adp5589TypeFifoEventIdentifier FIFO3EVENT3IDENTIFIER {
    Adp5589TypeFifoEventIdentifier get ();
}
member FIFO3EVENT3IDENTIFIER : Adp5589TypeFifoEventIdentifier with get

Property Value

Type: Adp5589TypeFifoEventIdentifier
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO3EVENT3STATE Property

IRD

Adp5589FIFO3EVENT3STATE Property

FIFO_3: EVENT3_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO3EVENT3STATE { get; }
Public ReadOnly Property FIFO3EVENT3STATE As Byte
    Get
public:
property unsigned char FIFO3EVENT3STATE {
    unsigned char get ();
}
member FIFO3EVENT3STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO4EVENT4IDENTIFIER Property

IRD

Adp5589FIFO4EVENT4IDENTIFIER Property

FIFO_4: EVENT4_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeFifoEventIdentifier FIFO4EVENT4IDENTIFIER { get; }
Public ReadOnly Property FIFO4EVENT4IDENTIFIER As Adp5589TypeFifoEventIdentifier
    Get
public:
property Adp5589TypeFifoEventIdentifier FIFO4EVENT4IDENTIFIER {
    Adp5589TypeFifoEventIdentifier get ();
}
member FIFO4EVENT4IDENTIFIER : Adp5589TypeFifoEventIdentifier with get

Property Value

Type: Adp5589TypeFifoEventIdentifier
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO4EVENT4STATE Property

IRD

Adp5589FIFO4EVENT4STATE Property

FIFO_4: EVENT4_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO4EVENT4STATE { get; }
Public ReadOnly Property FIFO4EVENT4STATE As Byte
    Get
public:
property unsigned char FIFO4EVENT4STATE {
    unsigned char get ();
}
member FIFO4EVENT4STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO5EVENT5IDENTIFIER Property

IRD

Adp5589FIFO5EVENT5IDENTIFIER Property

FIFO_5: EVENT5_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeFifoEventIdentifier FIFO5EVENT5IDENTIFIER { get; }
Public ReadOnly Property FIFO5EVENT5IDENTIFIER As Adp5589TypeFifoEventIdentifier
    Get
public:
property Adp5589TypeFifoEventIdentifier FIFO5EVENT5IDENTIFIER {
    Adp5589TypeFifoEventIdentifier get ();
}
member FIFO5EVENT5IDENTIFIER : Adp5589TypeFifoEventIdentifier with get

Property Value

Type: Adp5589TypeFifoEventIdentifier
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO5EVENT5STATE Property

IRD

Adp5589FIFO5EVENT5STATE Property

FIFO_5: EVENT5_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO5EVENT5STATE { get; }
Public ReadOnly Property FIFO5EVENT5STATE As Byte
    Get
public:
property unsigned char FIFO5EVENT5STATE {
    unsigned char get ();
}
member FIFO5EVENT5STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO6EVENT6IDENTIFIER Property

IRD

Adp5589FIFO6EVENT6IDENTIFIER Property

FIFO_6: EVENT6_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeFifoEventIdentifier FIFO6EVENT6IDENTIFIER { get; }
Public ReadOnly Property FIFO6EVENT6IDENTIFIER As Adp5589TypeFifoEventIdentifier
    Get
public:
property Adp5589TypeFifoEventIdentifier FIFO6EVENT6IDENTIFIER {
    Adp5589TypeFifoEventIdentifier get ();
}
member FIFO6EVENT6IDENTIFIER : Adp5589TypeFifoEventIdentifier with get

Property Value

Type: Adp5589TypeFifoEventIdentifier
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO6EVENT6STATE Property

IRD

Adp5589FIFO6EVENT6STATE Property

FIFO_6: EVENT6_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO6EVENT6STATE { get; }
Public ReadOnly Property FIFO6EVENT6STATE As Byte
    Get
public:
property unsigned char FIFO6EVENT6STATE {
    unsigned char get ();
}
member FIFO6EVENT6STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO7EVENT7IDENTIFIER Property

IRD

Adp5589FIFO7EVENT7IDENTIFIER Property

FIFO_7: EVENT7_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeFifoEventIdentifier FIFO7EVENT7IDENTIFIER { get; }
Public ReadOnly Property FIFO7EVENT7IDENTIFIER As Adp5589TypeFifoEventIdentifier
    Get
public:
property Adp5589TypeFifoEventIdentifier FIFO7EVENT7IDENTIFIER {
    Adp5589TypeFifoEventIdentifier get ();
}
member FIFO7EVENT7IDENTIFIER : Adp5589TypeFifoEventIdentifier with get

Property Value

Type: Adp5589TypeFifoEventIdentifier
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO7EVENT7STATE Property

IRD

Adp5589FIFO7EVENT7STATE Property

FIFO_7: EVENT7_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO7EVENT7STATE { get; }
Public ReadOnly Property FIFO7EVENT7STATE As Byte
    Get
public:
property unsigned char FIFO7EVENT7STATE {
    unsigned char get ();
}
member FIFO7EVENT7STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO8EVENT8IDENTIFIER Property

IRD

Adp5589FIFO8EVENT8IDENTIFIER Property

FIFO_8: EVENT8_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeFifoEventIdentifier FIFO8EVENT8IDENTIFIER { get; }
Public ReadOnly Property FIFO8EVENT8IDENTIFIER As Adp5589TypeFifoEventIdentifier
    Get
public:
property Adp5589TypeFifoEventIdentifier FIFO8EVENT8IDENTIFIER {
    Adp5589TypeFifoEventIdentifier get ();
}
member FIFO8EVENT8IDENTIFIER : Adp5589TypeFifoEventIdentifier with get

Property Value

Type: Adp5589TypeFifoEventIdentifier
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO8EVENT8STATE Property

IRD

Adp5589FIFO8EVENT8STATE Property

FIFO_8: EVENT8_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO8EVENT8STATE { get; }
Public ReadOnly Property FIFO8EVENT8STATE As Byte
    Get
public:
property unsigned char FIFO8EVENT8STATE {
    unsigned char get ();
}
member FIFO8EVENT8STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO9EVENT9IDENTIFIER Property

IRD

Adp5589FIFO9EVENT9IDENTIFIER Property

FIFO_9: EVENT9_IDENTIFIER

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeFifoEventIdentifier FIFO9EVENT9IDENTIFIER { get; }
Public ReadOnly Property FIFO9EVENT9IDENTIFIER As Adp5589TypeFifoEventIdentifier
    Get
public:
property Adp5589TypeFifoEventIdentifier FIFO9EVENT9IDENTIFIER {
    Adp5589TypeFifoEventIdentifier get ();
}
member FIFO9EVENT9IDENTIFIER : Adp5589TypeFifoEventIdentifier with get

Property Value

Type: Adp5589TypeFifoEventIdentifier
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.FIFO9EVENT9STATE Property

IRD

Adp5589FIFO9EVENT9STATE Property

FIFO_9: EVENT9_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFO9EVENT9STATE { get; }
Public ReadOnly Property FIFO9EVENT9STATE As Byte
    Get
public:
property unsigned char FIFO9EVENT9STATE {
    unsigned char get ();
}
member FIFO9EVENT9STATE : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GENERALCFGBCOREFREQ Property

IRD

Adp5589GENERALCFGBCOREFREQ Property

GENERAL_CFG_B: CORE_FREQ

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGeneralCfgBCoreFreq GENERALCFGBCOREFREQ { get; set; }
Public Property GENERALCFGBCOREFREQ As Adp5589TypeGeneralCfgBCoreFreq
    Get
    Set
public:
property Adp5589TypeGeneralCfgBCoreFreq GENERALCFGBCOREFREQ {
    Adp5589TypeGeneralCfgBCoreFreq get ();
    void set (Adp5589TypeGeneralCfgBCoreFreq value);
}
member GENERALCFGBCOREFREQ : Adp5589TypeGeneralCfgBCoreFreq with get, set

Property Value

Type: Adp5589TypeGeneralCfgBCoreFreq
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GENERALCFGBINTCFG Property

IRD

Adp5589GENERALCFGBINTCFG Property

GENERAL_CFG_B: INT_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGeneralCfgBIntCfg GENERALCFGBINTCFG { get; set; }
Public Property GENERALCFGBINTCFG As Adp5589TypeGeneralCfgBIntCfg
    Get
    Set
public:
property Adp5589TypeGeneralCfgBIntCfg GENERALCFGBINTCFG {
    Adp5589TypeGeneralCfgBIntCfg get ();
    void set (Adp5589TypeGeneralCfgBIntCfg value);
}
member GENERALCFGBINTCFG : Adp5589TypeGeneralCfgBIntCfg with get, set

Property Value

Type: Adp5589TypeGeneralCfgBIntCfg
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GENERALCFGBLCKTRKGPI Property

IRD

Adp5589GENERALCFGBLCKTRKGPI Property

GENERAL_CFG_B: LCK_TRK_GPI

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGeneralCfgBLckTrkGpi GENERALCFGBLCKTRKGPI { get; set; }
Public Property GENERALCFGBLCKTRKGPI As Adp5589TypeGeneralCfgBLckTrkGpi
    Get
    Set
public:
property Adp5589TypeGeneralCfgBLckTrkGpi GENERALCFGBLCKTRKGPI {
    Adp5589TypeGeneralCfgBLckTrkGpi get ();
    void set (Adp5589TypeGeneralCfgBLckTrkGpi value);
}
member GENERALCFGBLCKTRKGPI : Adp5589TypeGeneralCfgBLckTrkGpi with get, set

Property Value

Type: Adp5589TypeGeneralCfgBLckTrkGpi
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GENERALCFGBLCKTRKLOGIC Property

IRD

Adp5589GENERALCFGBLCKTRKLOGIC Property

GENERAL_CFG_B: LCK_TRK_LOGIC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGeneralCfgBLckTrkLogic GENERALCFGBLCKTRKLOGIC { get; set; }
Public Property GENERALCFGBLCKTRKLOGIC As Adp5589TypeGeneralCfgBLckTrkLogic
    Get
    Set
public:
property Adp5589TypeGeneralCfgBLckTrkLogic GENERALCFGBLCKTRKLOGIC {
    Adp5589TypeGeneralCfgBLckTrkLogic get ();
    void set (Adp5589TypeGeneralCfgBLckTrkLogic value);
}
member GENERALCFGBLCKTRKLOGIC : Adp5589TypeGeneralCfgBLckTrkLogic with get, set

Property Value

Type: Adp5589TypeGeneralCfgBLckTrkLogic
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GENERALCFGBOSCEN Property

IRD

Adp5589GENERALCFGBOSCEN Property

GENERAL_CFG_B: OSC_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGeneralCfgBOscEn GENERALCFGBOSCEN { get; set; }
Public Property GENERALCFGBOSCEN As Adp5589TypeGeneralCfgBOscEn
    Get
    Set
public:
property Adp5589TypeGeneralCfgBOscEn GENERALCFGBOSCEN {
    Adp5589TypeGeneralCfgBOscEn get ();
    void set (Adp5589TypeGeneralCfgBOscEn value);
}
member GENERALCFGBOSCEN : Adp5589TypeGeneralCfgBOscEn with get, set

Property Value

Type: Adp5589TypeGeneralCfgBOscEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GENERALCFGBRSTCFG Property

IRD

Adp5589GENERALCFGBRSTCFG Property

GENERAL_CFG_B: RST_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGeneralCfgBRstCfg GENERALCFGBRSTCFG { get; set; }
Public Property GENERALCFGBRSTCFG As Adp5589TypeGeneralCfgBRstCfg
    Get
    Set
public:
property Adp5589TypeGeneralCfgBRstCfg GENERALCFGBRSTCFG {
    Adp5589TypeGeneralCfgBRstCfg get ();
    void set (Adp5589TypeGeneralCfgBRstCfg value);
}
member GENERALCFGBRSTCFG : Adp5589TypeGeneralCfgBRstCfg with get, set

Property Value

Type: Adp5589TypeGeneralCfgBRstCfg
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENAGPI1EVENTEN Property

IRD

Adp5589GPIEVENTENAGPI1EVENTEN Property

GPI_EVENT_EN_A: GPI_1_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENAGPI1EVENTEN { get; set; }
Public Property GPIEVENTENAGPI1EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENAGPI1EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENAGPI1EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENAGPI2EVENTEN Property

IRD

Adp5589GPIEVENTENAGPI2EVENTEN Property

GPI_EVENT_EN_A: GPI_2_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENAGPI2EVENTEN { get; set; }
Public Property GPIEVENTENAGPI2EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENAGPI2EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENAGPI2EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENAGPI3EVENTEN Property

IRD

Adp5589GPIEVENTENAGPI3EVENTEN Property

GPI_EVENT_EN_A: GPI_3_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENAGPI3EVENTEN { get; set; }
Public Property GPIEVENTENAGPI3EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENAGPI3EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENAGPI3EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENAGPI4EVENTEN Property

IRD

Adp5589GPIEVENTENAGPI4EVENTEN Property

GPI_EVENT_EN_A: GPI_4_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENAGPI4EVENTEN { get; set; }
Public Property GPIEVENTENAGPI4EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENAGPI4EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENAGPI4EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENAGPI5EVENTEN Property

IRD

Adp5589GPIEVENTENAGPI5EVENTEN Property

GPI_EVENT_EN_A: GPI_5_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENAGPI5EVENTEN { get; set; }
Public Property GPIEVENTENAGPI5EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENAGPI5EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENAGPI5EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENAGPI6EVENTEN Property

IRD

Adp5589GPIEVENTENAGPI6EVENTEN Property

GPI_EVENT_EN_A: GPI_6_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENAGPI6EVENTEN { get; set; }
Public Property GPIEVENTENAGPI6EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENAGPI6EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENAGPI6EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENAGPI7EVENTEN Property

IRD

Adp5589GPIEVENTENAGPI7EVENTEN Property

GPI_EVENT_EN_A: GPI_7_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENAGPI7EVENTEN { get; set; }
Public Property GPIEVENTENAGPI7EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENAGPI7EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENAGPI7EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENAGPI8EVENTEN Property

IRD

Adp5589GPIEVENTENAGPI8EVENTEN Property

GPI_EVENT_EN_A: GPI_8_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENAGPI8EVENTEN { get; set; }
Public Property GPIEVENTENAGPI8EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENAGPI8EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENAGPI8EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENBGPI10EVENTEN Property

IRD

Adp5589GPIEVENTENBGPI10EVENTEN Property

GPI_EVENT_EN_B: GPI_10_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENBGPI10EVENTEN { get; set; }
Public Property GPIEVENTENBGPI10EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENBGPI10EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENBGPI10EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENBGPI11EVENTEN Property

IRD

Adp5589GPIEVENTENBGPI11EVENTEN Property

GPI_EVENT_EN_B: GPI_11_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENBGPI11EVENTEN { get; set; }
Public Property GPIEVENTENBGPI11EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENBGPI11EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENBGPI11EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENBGPI12EVENTEN Property

IRD

Adp5589GPIEVENTENBGPI12EVENTEN Property

GPI_EVENT_EN_B: GPI_12_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENBGPI12EVENTEN { get; set; }
Public Property GPIEVENTENBGPI12EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENBGPI12EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENBGPI12EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENBGPI13EVENTEN Property

IRD

Adp5589GPIEVENTENBGPI13EVENTEN Property

GPI_EVENT_EN_B: GPI_13_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENBGPI13EVENTEN { get; set; }
Public Property GPIEVENTENBGPI13EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENBGPI13EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENBGPI13EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENBGPI14EVENTEN Property

IRD

Adp5589GPIEVENTENBGPI14EVENTEN Property

GPI_EVENT_EN_B: GPI_14_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENBGPI14EVENTEN { get; set; }
Public Property GPIEVENTENBGPI14EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENBGPI14EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENBGPI14EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENBGPI15EVENTEN Property

IRD

Adp5589GPIEVENTENBGPI15EVENTEN Property

GPI_EVENT_EN_B: GPI_15_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENBGPI15EVENTEN { get; set; }
Public Property GPIEVENTENBGPI15EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENBGPI15EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENBGPI15EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENBGPI16EVENTEN Property

IRD

Adp5589GPIEVENTENBGPI16EVENTEN Property

GPI_EVENT_EN_B: GPI_16_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENBGPI16EVENTEN { get; set; }
Public Property GPIEVENTENBGPI16EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENBGPI16EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENBGPI16EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENBGPI9EVENTEN Property

IRD

Adp5589GPIEVENTENBGPI9EVENTEN Property

GPI_EVENT_EN_B: GPI_9_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENBGPI9EVENTEN { get; set; }
Public Property GPIEVENTENBGPI9EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENBGPI9EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENBGPI9EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENCGPI17EVENTEN Property

IRD

Adp5589GPIEVENTENCGPI17EVENTEN Property

GPI_EVENT_EN_C: GPI_17_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENCGPI17EVENTEN { get; set; }
Public Property GPIEVENTENCGPI17EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENCGPI17EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENCGPI17EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENCGPI18EVENTEN Property

IRD

Adp5589GPIEVENTENCGPI18EVENTEN Property

GPI_EVENT_EN_C: GPI_18_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENCGPI18EVENTEN { get; set; }
Public Property GPIEVENTENCGPI18EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENCGPI18EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENCGPI18EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIEVENTENCGPI19EVENTEN Property

IRD

Adp5589GPIEVENTENCGPI19EVENTEN Property

GPI_EVENT_EN_C: GPI_19_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiEventEn GPIEVENTENCGPI19EVENTEN { get; set; }
Public Property GPIEVENTENCGPI19EVENTEN As Adp5589TypeGpiEventEn
    Get
    Set
public:
property Adp5589TypeGpiEventEn GPIEVENTENCGPI19EVENTEN {
    Adp5589TypeGpiEventEn get ();
    void set (Adp5589TypeGpiEventEn value);
}
member GPIEVENTENCGPI19EVENTEN : Adp5589TypeGpiEventEn with get, set

Property Value

Type: Adp5589TypeGpiEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENAGPI1INTEN Property

IRD

Adp5589GPIINTERRUPTENAGPI1INTEN Property

GPI_INTERRUPT_EN_A: GPI_1_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENAGPI1INTEN { get; set; }
Public Property GPIINTERRUPTENAGPI1INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENAGPI1INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENAGPI1INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENAGPI2INTEN Property

IRD

Adp5589GPIINTERRUPTENAGPI2INTEN Property

GPI_INTERRUPT_EN_A: GPI_2_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENAGPI2INTEN { get; set; }
Public Property GPIINTERRUPTENAGPI2INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENAGPI2INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENAGPI2INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENAGPI3INTEN Property

IRD

Adp5589GPIINTERRUPTENAGPI3INTEN Property

GPI_INTERRUPT_EN_A: GPI_3_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENAGPI3INTEN { get; set; }
Public Property GPIINTERRUPTENAGPI3INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENAGPI3INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENAGPI3INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENAGPI4INTEN Property

IRD

Adp5589GPIINTERRUPTENAGPI4INTEN Property

GPI_INTERRUPT_EN_A: GPI_4_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENAGPI4INTEN { get; set; }
Public Property GPIINTERRUPTENAGPI4INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENAGPI4INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENAGPI4INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENAGPI5INTEN Property

IRD

Adp5589GPIINTERRUPTENAGPI5INTEN Property

GPI_INTERRUPT_EN_A: GPI_5_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENAGPI5INTEN { get; set; }
Public Property GPIINTERRUPTENAGPI5INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENAGPI5INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENAGPI5INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENAGPI6INTEN Property

IRD

Adp5589GPIINTERRUPTENAGPI6INTEN Property

GPI_INTERRUPT_EN_A: GPI_6_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENAGPI6INTEN { get; set; }
Public Property GPIINTERRUPTENAGPI6INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENAGPI6INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENAGPI6INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENAGPI7INTEN Property

IRD

Adp5589GPIINTERRUPTENAGPI7INTEN Property

GPI_INTERRUPT_EN_A: GPI_7_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENAGPI7INTEN { get; set; }
Public Property GPIINTERRUPTENAGPI7INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENAGPI7INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENAGPI7INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENAGPI8INTEN Property

IRD

Adp5589GPIINTERRUPTENAGPI8INTEN Property

GPI_INTERRUPT_EN_A: GPI_8_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENAGPI8INTEN { get; set; }
Public Property GPIINTERRUPTENAGPI8INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENAGPI8INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENAGPI8INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENBGPI10INTEN Property

IRD

Adp5589GPIINTERRUPTENBGPI10INTEN Property

GPI_INTERRUPT_EN_B: GPI_10_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENBGPI10INTEN { get; set; }
Public Property GPIINTERRUPTENBGPI10INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENBGPI10INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENBGPI10INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENBGPI11INTEN Property

IRD

Adp5589GPIINTERRUPTENBGPI11INTEN Property

GPI_INTERRUPT_EN_B: GPI_11_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENBGPI11INTEN { get; set; }
Public Property GPIINTERRUPTENBGPI11INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENBGPI11INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENBGPI11INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENBGPI12INTEN Property

IRD

Adp5589GPIINTERRUPTENBGPI12INTEN Property

GPI_INTERRUPT_EN_B: GPI_12_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENBGPI12INTEN { get; set; }
Public Property GPIINTERRUPTENBGPI12INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENBGPI12INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENBGPI12INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENBGPI13INTEN Property

IRD

Adp5589GPIINTERRUPTENBGPI13INTEN Property

GPI_INTERRUPT_EN_B: GPI_13_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENBGPI13INTEN { get; set; }
Public Property GPIINTERRUPTENBGPI13INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENBGPI13INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENBGPI13INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENBGPI14INTEN Property

IRD

Adp5589GPIINTERRUPTENBGPI14INTEN Property

GPI_INTERRUPT_EN_B: GPI_14_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENBGPI14INTEN { get; set; }
Public Property GPIINTERRUPTENBGPI14INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENBGPI14INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENBGPI14INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENBGPI15INTEN Property

IRD

Adp5589GPIINTERRUPTENBGPI15INTEN Property

GPI_INTERRUPT_EN_B: GPI_15_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENBGPI15INTEN { get; set; }
Public Property GPIINTERRUPTENBGPI15INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENBGPI15INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENBGPI15INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENBGPI16INTEN Property

IRD

Adp5589GPIINTERRUPTENBGPI16INTEN Property

GPI_INTERRUPT_EN_B: GPI_16_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENBGPI16INTEN { get; set; }
Public Property GPIINTERRUPTENBGPI16INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENBGPI16INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENBGPI16INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENBGPI9INTEN Property

IRD

Adp5589GPIINTERRUPTENBGPI9INTEN Property

GPI_INTERRUPT_EN_B: GPI_9_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENBGPI9INTEN { get; set; }
Public Property GPIINTERRUPTENBGPI9INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENBGPI9INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENBGPI9INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENCGPI17INTEN Property

IRD

Adp5589GPIINTERRUPTENCGPI17INTEN Property

GPI_INTERRUPT_EN_C: GPI_17_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENCGPI17INTEN { get; set; }
Public Property GPIINTERRUPTENCGPI17INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENCGPI17INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENCGPI17INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENCGPI18INTEN Property

IRD

Adp5589GPIINTERRUPTENCGPI18INTEN Property

GPI_INTERRUPT_EN_C: GPI_18_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENCGPI18INTEN { get; set; }
Public Property GPIINTERRUPTENCGPI18INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENCGPI18INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENCGPI18INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTERRUPTENCGPI19INTEN Property

IRD

Adp5589GPIINTERRUPTENCGPI19INTEN Property

GPI_INTERRUPT_EN_C: GPI_19_INT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiInterruptEn GPIINTERRUPTENCGPI19INTEN { get; set; }
Public Property GPIINTERRUPTENCGPI19INTEN As Adp5589TypeGpiInterruptEn
    Get
    Set
public:
property Adp5589TypeGpiInterruptEn GPIINTERRUPTENCGPI19INTEN {
    Adp5589TypeGpiInterruptEn get ();
    void set (Adp5589TypeGpiInterruptEn value);
}
member GPIINTERRUPTENCGPI19INTEN : Adp5589TypeGpiInterruptEn with get, set

Property Value

Type: Adp5589TypeGpiInterruptEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELAGPI1INTLEVEL Property

IRD

Adp5589GPIINTLEVELAGPI1INTLEVEL Property

GPI_INT_LEVEL_A: GPI_1_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELAGPI1INTLEVEL { get; set; }
Public Property GPIINTLEVELAGPI1INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELAGPI1INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELAGPI1INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELAGPI2INTLEVEL Property

IRD

Adp5589GPIINTLEVELAGPI2INTLEVEL Property

GPI_INT_LEVEL_A: GPI_2_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELAGPI2INTLEVEL { get; set; }
Public Property GPIINTLEVELAGPI2INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELAGPI2INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELAGPI2INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELAGPI3INTLEVEL Property

IRD

Adp5589GPIINTLEVELAGPI3INTLEVEL Property

GPI_INT_LEVEL_A: GPI_3_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELAGPI3INTLEVEL { get; set; }
Public Property GPIINTLEVELAGPI3INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELAGPI3INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELAGPI3INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELAGPI4INTLEVEL Property

IRD

Adp5589GPIINTLEVELAGPI4INTLEVEL Property

GPI_INT_LEVEL_A: GPI_4_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELAGPI4INTLEVEL { get; set; }
Public Property GPIINTLEVELAGPI4INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELAGPI4INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELAGPI4INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELAGPI5INTLEVEL Property

IRD

Adp5589GPIINTLEVELAGPI5INTLEVEL Property

GPI_INT_LEVEL_A: GPI_5_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELAGPI5INTLEVEL { get; set; }
Public Property GPIINTLEVELAGPI5INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELAGPI5INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELAGPI5INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELAGPI6INTLEVEL Property

IRD

Adp5589GPIINTLEVELAGPI6INTLEVEL Property

GPI_INT_LEVEL_A: GPI_6_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELAGPI6INTLEVEL { get; set; }
Public Property GPIINTLEVELAGPI6INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELAGPI6INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELAGPI6INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELAGPI7INTLEVEL Property

IRD

Adp5589GPIINTLEVELAGPI7INTLEVEL Property

GPI_INT_LEVEL_A: GPI_7_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELAGPI7INTLEVEL { get; set; }
Public Property GPIINTLEVELAGPI7INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELAGPI7INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELAGPI7INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELAGPI8INTLEVEL Property

IRD

Adp5589GPIINTLEVELAGPI8INTLEVEL Property

GPI_INT_LEVEL_A: GPI_8_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELAGPI8INTLEVEL { get; set; }
Public Property GPIINTLEVELAGPI8INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELAGPI8INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELAGPI8INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELBGPI10INTLEVEL Property

IRD

Adp5589GPIINTLEVELBGPI10INTLEVEL Property

GPI_INT_LEVEL_B: GPI_10_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELBGPI10INTLEVEL { get; set; }
Public Property GPIINTLEVELBGPI10INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELBGPI10INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELBGPI10INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELBGPI11INTLEVEL Property

IRD

Adp5589GPIINTLEVELBGPI11INTLEVEL Property

GPI_INT_LEVEL_B: GPI_11_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELBGPI11INTLEVEL { get; set; }
Public Property GPIINTLEVELBGPI11INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELBGPI11INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELBGPI11INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELBGPI12INTLEVEL Property

IRD

Adp5589GPIINTLEVELBGPI12INTLEVEL Property

GPI_INT_LEVEL_B: GPI_12_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELBGPI12INTLEVEL { get; set; }
Public Property GPIINTLEVELBGPI12INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELBGPI12INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELBGPI12INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELBGPI13INTLEVEL Property

IRD

Adp5589GPIINTLEVELBGPI13INTLEVEL Property

GPI_INT_LEVEL_B: GPI_13_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELBGPI13INTLEVEL { get; set; }
Public Property GPIINTLEVELBGPI13INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELBGPI13INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELBGPI13INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELBGPI14INTLEVEL Property

IRD

Adp5589GPIINTLEVELBGPI14INTLEVEL Property

GPI_INT_LEVEL_B: GPI_14_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELBGPI14INTLEVEL { get; set; }
Public Property GPIINTLEVELBGPI14INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELBGPI14INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELBGPI14INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELBGPI15INTLEVEL Property

IRD

Adp5589GPIINTLEVELBGPI15INTLEVEL Property

GPI_INT_LEVEL_B: GPI_15_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELBGPI15INTLEVEL { get; set; }
Public Property GPIINTLEVELBGPI15INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELBGPI15INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELBGPI15INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELBGPI16INTLEVEL Property

IRD

Adp5589GPIINTLEVELBGPI16INTLEVEL Property

GPI_INT_LEVEL_B: GPI_16_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELBGPI16INTLEVEL { get; set; }
Public Property GPIINTLEVELBGPI16INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELBGPI16INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELBGPI16INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELBGPI9INTLEVEL Property

IRD

Adp5589GPIINTLEVELBGPI9INTLEVEL Property

GPI_INT_LEVEL_B: GPI_9_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELBGPI9INTLEVEL { get; set; }
Public Property GPIINTLEVELBGPI9INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELBGPI9INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELBGPI9INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELCGPI17INTLEVEL Property

IRD

Adp5589GPIINTLEVELCGPI17INTLEVEL Property

GPI_INT_LEVEL_C: GPI_17_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELCGPI17INTLEVEL { get; set; }
Public Property GPIINTLEVELCGPI17INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELCGPI17INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELCGPI17INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELCGPI18INTLEVEL Property

IRD

Adp5589GPIINTLEVELCGPI18INTLEVEL Property

GPI_INT_LEVEL_C: GPI_18_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELCGPI18INTLEVEL { get; set; }
Public Property GPIINTLEVELCGPI18INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELCGPI18INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELCGPI18INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTLEVELCGPI19INTLEVEL Property

IRD

Adp5589GPIINTLEVELCGPI19INTLEVEL Property

GPI_INT_LEVEL_C: GPI_19_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntLevel GPIINTLEVELCGPI19INTLEVEL { get; set; }
Public Property GPIINTLEVELCGPI19INTLEVEL As Adp5589TypeGpiIntLevel
    Get
    Set
public:
property Adp5589TypeGpiIntLevel GPIINTLEVELCGPI19INTLEVEL {
    Adp5589TypeGpiIntLevel get ();
    void set (Adp5589TypeGpiIntLevel value);
}
member GPIINTLEVELCGPI19INTLEVEL : Adp5589TypeGpiIntLevel with get, set

Property Value

Type: Adp5589TypeGpiIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATAGPI1INT Property

IRD

Adp5589GPIINTSTATAGPI1INT Property

GPI_INT_STAT_A: GPI_1_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATAGPI1INT { get; }
Public ReadOnly Property GPIINTSTATAGPI1INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATAGPI1INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATAGPI1INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATAGPI2INT Property

IRD

Adp5589GPIINTSTATAGPI2INT Property

GPI_INT_STAT_A: GPI_2_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATAGPI2INT { get; }
Public ReadOnly Property GPIINTSTATAGPI2INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATAGPI2INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATAGPI2INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATAGPI3INT Property

IRD

Adp5589GPIINTSTATAGPI3INT Property

GPI_INT_STAT_A: GPI_3_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATAGPI3INT { get; }
Public ReadOnly Property GPIINTSTATAGPI3INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATAGPI3INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATAGPI3INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATAGPI4INT Property

IRD

Adp5589GPIINTSTATAGPI4INT Property

GPI_INT_STAT_A: GPI_4_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATAGPI4INT { get; }
Public ReadOnly Property GPIINTSTATAGPI4INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATAGPI4INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATAGPI4INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATAGPI5INT Property

IRD

Adp5589GPIINTSTATAGPI5INT Property

GPI_INT_STAT_A: GPI_5_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATAGPI5INT { get; }
Public ReadOnly Property GPIINTSTATAGPI5INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATAGPI5INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATAGPI5INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATAGPI6INT Property

IRD

Adp5589GPIINTSTATAGPI6INT Property

GPI_INT_STAT_A: GPI_6_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATAGPI6INT { get; }
Public ReadOnly Property GPIINTSTATAGPI6INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATAGPI6INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATAGPI6INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATAGPI7INT Property

IRD

Adp5589GPIINTSTATAGPI7INT Property

GPI_INT_STAT_A: GPI_7_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATAGPI7INT { get; }
Public ReadOnly Property GPIINTSTATAGPI7INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATAGPI7INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATAGPI7INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATAGPI8INT Property

IRD

Adp5589GPIINTSTATAGPI8INT Property

GPI_INT_STAT_A: GPI_8_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATAGPI8INT { get; }
Public ReadOnly Property GPIINTSTATAGPI8INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATAGPI8INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATAGPI8INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATBGPI10INT Property

IRD

Adp5589GPIINTSTATBGPI10INT Property

GPI_INT_STAT_B: GPI_10_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATBGPI10INT { get; }
Public ReadOnly Property GPIINTSTATBGPI10INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATBGPI10INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATBGPI10INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATBGPI11INT Property

IRD

Adp5589GPIINTSTATBGPI11INT Property

GPI_INT_STAT_B: GPI_11_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATBGPI11INT { get; }
Public ReadOnly Property GPIINTSTATBGPI11INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATBGPI11INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATBGPI11INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATBGPI12INT Property

IRD

Adp5589GPIINTSTATBGPI12INT Property

GPI_INT_STAT_B: GPI_12_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATBGPI12INT { get; }
Public ReadOnly Property GPIINTSTATBGPI12INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATBGPI12INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATBGPI12INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATBGPI13INT Property

IRD

Adp5589GPIINTSTATBGPI13INT Property

GPI_INT_STAT_B: GPI_13_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATBGPI13INT { get; }
Public ReadOnly Property GPIINTSTATBGPI13INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATBGPI13INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATBGPI13INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATBGPI14INT Property

IRD

Adp5589GPIINTSTATBGPI14INT Property

GPI_INT_STAT_B: GPI_14_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATBGPI14INT { get; }
Public ReadOnly Property GPIINTSTATBGPI14INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATBGPI14INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATBGPI14INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATBGPI15INT Property

IRD

Adp5589GPIINTSTATBGPI15INT Property

GPI_INT_STAT_B: GPI_15_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATBGPI15INT { get; }
Public ReadOnly Property GPIINTSTATBGPI15INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATBGPI15INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATBGPI15INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATBGPI16INT Property

IRD

Adp5589GPIINTSTATBGPI16INT Property

GPI_INT_STAT_B: GPI_16_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATBGPI16INT { get; }
Public ReadOnly Property GPIINTSTATBGPI16INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATBGPI16INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATBGPI16INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATBGPI9INT Property

IRD

Adp5589GPIINTSTATBGPI9INT Property

GPI_INT_STAT_B: GPI_9_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATBGPI9INT { get; }
Public ReadOnly Property GPIINTSTATBGPI9INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATBGPI9INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATBGPI9INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATCGPI17INT Property

IRD

Adp5589GPIINTSTATCGPI17INT Property

GPI_INT_STAT_C: GPI_17_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATCGPI17INT { get; }
Public ReadOnly Property GPIINTSTATCGPI17INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATCGPI17INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATCGPI17INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATCGPI18INT Property

IRD

Adp5589GPIINTSTATCGPI18INT Property

GPI_INT_STAT_C: GPI_18_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATCGPI18INT { get; }
Public ReadOnly Property GPIINTSTATCGPI18INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATCGPI18INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATCGPI18INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIINTSTATCGPI19INT Property

IRD

Adp5589GPIINTSTATCGPI19INT Property

GPI_INT_STAT_C: GPI_19_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiIntStat GPIINTSTATCGPI19INT { get; }
Public ReadOnly Property GPIINTSTATCGPI19INT As Adp5589TypeGpiIntStat
    Get
public:
property Adp5589TypeGpiIntStat GPIINTSTATCGPI19INT {
    Adp5589TypeGpiIntStat get ();
}
member GPIINTSTATCGPI19INT : Adp5589TypeGpiIntStat with get

Property Value

Type: Adp5589TypeGpiIntStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONAGPIO1DIR Property

IRD

Adp5589GPIODIRECTIONAGPIO1DIR Property

GPIO_DIRECTION_A: GPIO_1_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONAGPIO1DIR { get; set; }
Public Property GPIODIRECTIONAGPIO1DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONAGPIO1DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONAGPIO1DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONAGPIO2DIR Property

IRD

Adp5589GPIODIRECTIONAGPIO2DIR Property

GPIO_DIRECTION_A: GPIO_2_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONAGPIO2DIR { get; set; }
Public Property GPIODIRECTIONAGPIO2DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONAGPIO2DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONAGPIO2DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONAGPIO3DIR Property

IRD

Adp5589GPIODIRECTIONAGPIO3DIR Property

GPIO_DIRECTION_A: GPIO_3_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONAGPIO3DIR { get; set; }
Public Property GPIODIRECTIONAGPIO3DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONAGPIO3DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONAGPIO3DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONAGPIO4DIR Property

IRD

Adp5589GPIODIRECTIONAGPIO4DIR Property

GPIO_DIRECTION_A: GPIO_4_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONAGPIO4DIR { get; set; }
Public Property GPIODIRECTIONAGPIO4DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONAGPIO4DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONAGPIO4DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONAGPIO5DIR Property

IRD

Adp5589GPIODIRECTIONAGPIO5DIR Property

GPIO_DIRECTION_A: GPIO_5_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONAGPIO5DIR { get; set; }
Public Property GPIODIRECTIONAGPIO5DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONAGPIO5DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONAGPIO5DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONAGPIO6DIR Property

IRD

Adp5589GPIODIRECTIONAGPIO6DIR Property

GPIO_DIRECTION_A: GPIO_6_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONAGPIO6DIR { get; set; }
Public Property GPIODIRECTIONAGPIO6DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONAGPIO6DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONAGPIO6DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONAGPIO7DIR Property

IRD

Adp5589GPIODIRECTIONAGPIO7DIR Property

GPIO_DIRECTION_A: GPIO_7_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONAGPIO7DIR { get; set; }
Public Property GPIODIRECTIONAGPIO7DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONAGPIO7DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONAGPIO7DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONAGPIO8DIR Property

IRD

Adp5589GPIODIRECTIONAGPIO8DIR Property

GPIO_DIRECTION_A: GPIO_8_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONAGPIO8DIR { get; set; }
Public Property GPIODIRECTIONAGPIO8DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONAGPIO8DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONAGPIO8DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONBGPIO10DIR Property

IRD

Adp5589GPIODIRECTIONBGPIO10DIR Property

GPIO_DIRECTION_B: GPIO_10_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONBGPIO10DIR { get; set; }
Public Property GPIODIRECTIONBGPIO10DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONBGPIO10DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONBGPIO10DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONBGPIO11DIR Property

IRD

Adp5589GPIODIRECTIONBGPIO11DIR Property

GPIO_DIRECTION_B: GPIO_11_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONBGPIO11DIR { get; set; }
Public Property GPIODIRECTIONBGPIO11DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONBGPIO11DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONBGPIO11DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONBGPIO12DIR Property

IRD

Adp5589GPIODIRECTIONBGPIO12DIR Property

GPIO_DIRECTION_B: GPIO_12_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONBGPIO12DIR { get; set; }
Public Property GPIODIRECTIONBGPIO12DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONBGPIO12DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONBGPIO12DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONBGPIO13DIR Property

IRD

Adp5589GPIODIRECTIONBGPIO13DIR Property

GPIO_DIRECTION_B: GPIO_13_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONBGPIO13DIR { get; set; }
Public Property GPIODIRECTIONBGPIO13DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONBGPIO13DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONBGPIO13DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONBGPIO14DIR Property

IRD

Adp5589GPIODIRECTIONBGPIO14DIR Property

GPIO_DIRECTION_B: GPIO_14_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONBGPIO14DIR { get; set; }
Public Property GPIODIRECTIONBGPIO14DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONBGPIO14DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONBGPIO14DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONBGPIO15DIR Property

IRD

Adp5589GPIODIRECTIONBGPIO15DIR Property

GPIO_DIRECTION_B: GPIO_15_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONBGPIO15DIR { get; set; }
Public Property GPIODIRECTIONBGPIO15DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONBGPIO15DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONBGPIO15DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONBGPIO16DIR Property

IRD

Adp5589GPIODIRECTIONBGPIO16DIR Property

GPIO_DIRECTION_B: GPIO_16_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONBGPIO16DIR { get; set; }
Public Property GPIODIRECTIONBGPIO16DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONBGPIO16DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONBGPIO16DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONBGPIO9DIR Property

IRD

Adp5589GPIODIRECTIONBGPIO9DIR Property

GPIO_DIRECTION_B: GPIO_9_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONBGPIO9DIR { get; set; }
Public Property GPIODIRECTIONBGPIO9DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONBGPIO9DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONBGPIO9DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONCGPIO17DIR Property

IRD

Adp5589GPIODIRECTIONCGPIO17DIR Property

GPIO_DIRECTION_C: GPIO_17_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONCGPIO17DIR { get; set; }
Public Property GPIODIRECTIONCGPIO17DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONCGPIO17DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONCGPIO17DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONCGPIO18DIR Property

IRD

Adp5589GPIODIRECTIONCGPIO18DIR Property

GPIO_DIRECTION_C: GPIO_18_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONCGPIO18DIR { get; set; }
Public Property GPIODIRECTIONCGPIO18DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONCGPIO18DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONCGPIO18DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPIODIRECTIONCGPIO19DIR Property

IRD

Adp5589GPIODIRECTIONCGPIO19DIR Property

GPIO_DIRECTION_C: GPIO_19_DIR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpioDirection GPIODIRECTIONCGPIO19DIR { get; set; }
Public Property GPIODIRECTIONCGPIO19DIR As Adp5589TypeGpioDirection
    Get
    Set
public:
property Adp5589TypeGpioDirection GPIODIRECTIONCGPIO19DIR {
    Adp5589TypeGpioDirection get ();
    void set (Adp5589TypeGpioDirection value);
}
member GPIODIRECTIONCGPIO19DIR : Adp5589TypeGpioDirection with get, set

Property Value

Type: Adp5589TypeGpioDirection
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSAGPI1STAT Property

IRD

Adp5589GPISTATUSAGPI1STAT Property

GPI_STATUS_A: GPI_1_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSAGPI1STAT { get; }
Public ReadOnly Property GPISTATUSAGPI1STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSAGPI1STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSAGPI1STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSAGPI2STAT Property

IRD

Adp5589GPISTATUSAGPI2STAT Property

GPI_STATUS_A: GPI_2_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSAGPI2STAT { get; }
Public ReadOnly Property GPISTATUSAGPI2STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSAGPI2STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSAGPI2STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSAGPI3STAT Property

IRD

Adp5589GPISTATUSAGPI3STAT Property

GPI_STATUS_A: GPI_3_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSAGPI3STAT { get; }
Public ReadOnly Property GPISTATUSAGPI3STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSAGPI3STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSAGPI3STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSAGPI4STAT Property

IRD

Adp5589GPISTATUSAGPI4STAT Property

GPI_STATUS_A: GPI_4_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSAGPI4STAT { get; }
Public ReadOnly Property GPISTATUSAGPI4STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSAGPI4STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSAGPI4STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSAGPI5STAT Property

IRD

Adp5589GPISTATUSAGPI5STAT Property

GPI_STATUS_A: GPI_5_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSAGPI5STAT { get; }
Public ReadOnly Property GPISTATUSAGPI5STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSAGPI5STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSAGPI5STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSAGPI6STAT Property

IRD

Adp5589GPISTATUSAGPI6STAT Property

GPI_STATUS_A: GPI_6_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSAGPI6STAT { get; }
Public ReadOnly Property GPISTATUSAGPI6STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSAGPI6STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSAGPI6STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSAGPI7STAT Property

IRD

Adp5589GPISTATUSAGPI7STAT Property

GPI_STATUS_A: GPI_7_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSAGPI7STAT { get; }
Public ReadOnly Property GPISTATUSAGPI7STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSAGPI7STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSAGPI7STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSAGPI8STAT Property

IRD

Adp5589GPISTATUSAGPI8STAT Property

GPI_STATUS_A: GPI_8_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSAGPI8STAT { get; }
Public ReadOnly Property GPISTATUSAGPI8STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSAGPI8STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSAGPI8STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSBGPI10STAT Property

IRD

Adp5589GPISTATUSBGPI10STAT Property

GPI_STATUS_B: GPI_10_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSBGPI10STAT { get; }
Public ReadOnly Property GPISTATUSBGPI10STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSBGPI10STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSBGPI10STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSBGPI11STAT Property

IRD

Adp5589GPISTATUSBGPI11STAT Property

GPI_STATUS_B: GPI_11_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSBGPI11STAT { get; }
Public ReadOnly Property GPISTATUSBGPI11STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSBGPI11STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSBGPI11STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSBGPI12STAT Property

IRD

Adp5589GPISTATUSBGPI12STAT Property

GPI_STATUS_B: GPI_12_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSBGPI12STAT { get; }
Public ReadOnly Property GPISTATUSBGPI12STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSBGPI12STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSBGPI12STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSBGPI13STAT Property

IRD

Adp5589GPISTATUSBGPI13STAT Property

GPI_STATUS_B: GPI_13_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSBGPI13STAT { get; }
Public ReadOnly Property GPISTATUSBGPI13STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSBGPI13STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSBGPI13STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSBGPI14STAT Property

IRD

Adp5589GPISTATUSBGPI14STAT Property

GPI_STATUS_B: GPI_14_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSBGPI14STAT { get; }
Public ReadOnly Property GPISTATUSBGPI14STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSBGPI14STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSBGPI14STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSBGPI15STAT Property

IRD

Adp5589GPISTATUSBGPI15STAT Property

GPI_STATUS_B: GPI_15_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSBGPI15STAT { get; }
Public ReadOnly Property GPISTATUSBGPI15STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSBGPI15STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSBGPI15STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSBGPI16STAT Property

IRD

Adp5589GPISTATUSBGPI16STAT Property

GPI_STATUS_B: GPI_16_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSBGPI16STAT { get; }
Public ReadOnly Property GPISTATUSBGPI16STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSBGPI16STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSBGPI16STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSBGPI9STAT Property

IRD

Adp5589GPISTATUSBGPI9STAT Property

GPI_STATUS_B: GPI_9_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSBGPI9STAT { get; }
Public ReadOnly Property GPISTATUSBGPI9STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSBGPI9STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSBGPI9STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSCGPI17STAT Property

IRD

Adp5589GPISTATUSCGPI17STAT Property

GPI_STATUS_C: GPI_17_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSCGPI17STAT { get; }
Public ReadOnly Property GPISTATUSCGPI17STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSCGPI17STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSCGPI17STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSCGPI18STAT Property

IRD

Adp5589GPISTATUSCGPI18STAT Property

GPI_STATUS_C: GPI_18_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSCGPI18STAT { get; }
Public ReadOnly Property GPISTATUSCGPI18STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSCGPI18STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSCGPI18STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPISTATUSCGPI19STAT Property

IRD

Adp5589GPISTATUSCGPI19STAT Property

GPI_STATUS_C: GPI_19_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpiStatus GPISTATUSCGPI19STAT { get; }
Public ReadOnly Property GPISTATUSCGPI19STAT As Adp5589TypeGpiStatus
    Get
public:
property Adp5589TypeGpiStatus GPISTATUSCGPI19STAT {
    Adp5589TypeGpiStatus get ();
}
member GPISTATUSCGPI19STAT : Adp5589TypeGpiStatus with get

Property Value

Type: Adp5589TypeGpiStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTAGPO1DATA Property

IRD

Adp5589GPODATAOUTAGPO1DATA Property

GPO_DATA_OUT_A: GPO_1_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTAGPO1DATA { get; set; }
Public Property GPODATAOUTAGPO1DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTAGPO1DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTAGPO1DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTAGPO2DATA Property

IRD

Adp5589GPODATAOUTAGPO2DATA Property

GPO_DATA_OUT_A: GPO_2_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTAGPO2DATA { get; set; }
Public Property GPODATAOUTAGPO2DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTAGPO2DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTAGPO2DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTAGPO3DATA Property

IRD

Adp5589GPODATAOUTAGPO3DATA Property

GPO_DATA_OUT_A: GPO_3_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTAGPO3DATA { get; set; }
Public Property GPODATAOUTAGPO3DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTAGPO3DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTAGPO3DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTAGPO4DATA Property

IRD

Adp5589GPODATAOUTAGPO4DATA Property

GPO_DATA_OUT_A: GPO_4_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTAGPO4DATA { get; set; }
Public Property GPODATAOUTAGPO4DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTAGPO4DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTAGPO4DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTAGPO5DATA Property

IRD

Adp5589GPODATAOUTAGPO5DATA Property

GPO_DATA_OUT_A: GPO_5_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTAGPO5DATA { get; set; }
Public Property GPODATAOUTAGPO5DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTAGPO5DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTAGPO5DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTAGPO6DATA Property

IRD

Adp5589GPODATAOUTAGPO6DATA Property

GPO_DATA_OUT_A: GPO_6_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTAGPO6DATA { get; set; }
Public Property GPODATAOUTAGPO6DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTAGPO6DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTAGPO6DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTAGPO7DATA Property

IRD

Adp5589GPODATAOUTAGPO7DATA Property

GPO_DATA_OUT_A: GPO_7_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTAGPO7DATA { get; set; }
Public Property GPODATAOUTAGPO7DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTAGPO7DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTAGPO7DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTAGPO8DATA Property

IRD

Adp5589GPODATAOUTAGPO8DATA Property

GPO_DATA_OUT_A: GPO_8_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTAGPO8DATA { get; set; }
Public Property GPODATAOUTAGPO8DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTAGPO8DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTAGPO8DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTBGPO10DATA Property

IRD

Adp5589GPODATAOUTBGPO10DATA Property

GPO_DATA_OUT_B: GPO_10_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTBGPO10DATA { get; set; }
Public Property GPODATAOUTBGPO10DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTBGPO10DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTBGPO10DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTBGPO11DATA Property

IRD

Adp5589GPODATAOUTBGPO11DATA Property

GPO_DATA_OUT_B: GPO_11_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTBGPO11DATA { get; set; }
Public Property GPODATAOUTBGPO11DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTBGPO11DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTBGPO11DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTBGPO12DATA Property

IRD

Adp5589GPODATAOUTBGPO12DATA Property

GPO_DATA_OUT_B: GPO_12_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTBGPO12DATA { get; set; }
Public Property GPODATAOUTBGPO12DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTBGPO12DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTBGPO12DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTBGPO13DATA Property

IRD

Adp5589GPODATAOUTBGPO13DATA Property

GPO_DATA_OUT_B: GPO_13_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTBGPO13DATA { get; set; }
Public Property GPODATAOUTBGPO13DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTBGPO13DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTBGPO13DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTBGPO14DATA Property

IRD

Adp5589GPODATAOUTBGPO14DATA Property

GPO_DATA_OUT_B: GPO_14_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTBGPO14DATA { get; set; }
Public Property GPODATAOUTBGPO14DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTBGPO14DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTBGPO14DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTBGPO15DATA Property

IRD

Adp5589GPODATAOUTBGPO15DATA Property

GPO_DATA_OUT_B: GPO_15_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTBGPO15DATA { get; set; }
Public Property GPODATAOUTBGPO15DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTBGPO15DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTBGPO15DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTBGPO16DATA Property

IRD

Adp5589GPODATAOUTBGPO16DATA Property

GPO_DATA_OUT_B: GPO_16_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTBGPO16DATA { get; set; }
Public Property GPODATAOUTBGPO16DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTBGPO16DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTBGPO16DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTBGPO9DATA Property

IRD

Adp5589GPODATAOUTBGPO9DATA Property

GPO_DATA_OUT_B: GPO_9_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTBGPO9DATA { get; set; }
Public Property GPODATAOUTBGPO9DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTBGPO9DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTBGPO9DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTCGPO17DATA Property

IRD

Adp5589GPODATAOUTCGPO17DATA Property

GPO_DATA_OUT_C: GPO_17_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTCGPO17DATA { get; set; }
Public Property GPODATAOUTCGPO17DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTCGPO17DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTCGPO17DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTCGPO18DATA Property

IRD

Adp5589GPODATAOUTCGPO18DATA Property

GPO_DATA_OUT_C: GPO_18_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTCGPO18DATA { get; set; }
Public Property GPODATAOUTCGPO18DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTCGPO18DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTCGPO18DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPODATAOUTCGPO19DATA Property

IRD

Adp5589GPODATAOUTCGPO19DATA Property

GPO_DATA_OUT_C: GPO_19_DATA

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoDataOut GPODATAOUTCGPO19DATA { get; set; }
Public Property GPODATAOUTCGPO19DATA As Adp5589TypeGpoDataOut
    Get
    Set
public:
property Adp5589TypeGpoDataOut GPODATAOUTCGPO19DATA {
    Adp5589TypeGpoDataOut get ();
    void set (Adp5589TypeGpoDataOut value);
}
member GPODATAOUTCGPO19DATA : Adp5589TypeGpoDataOut with get, set

Property Value

Type: Adp5589TypeGpoDataOut
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODEAGPO1OUTMODE Property

IRD

Adp5589GPOOUTMODEAGPO1OUTMODE Property

GPO_OUT_MODE_A: GPO_1_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODEAGPO1OUTMODE { get; set; }
Public Property GPOOUTMODEAGPO1OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODEAGPO1OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODEAGPO1OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODEAGPO2OUTMODE Property

IRD

Adp5589GPOOUTMODEAGPO2OUTMODE Property

GPO_OUT_MODE_A: GPO_2_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODEAGPO2OUTMODE { get; set; }
Public Property GPOOUTMODEAGPO2OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODEAGPO2OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODEAGPO2OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODEAGPO3OUTMODE Property

IRD

Adp5589GPOOUTMODEAGPO3OUTMODE Property

GPO_OUT_MODE_A: GPO_3_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODEAGPO3OUTMODE { get; set; }
Public Property GPOOUTMODEAGPO3OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODEAGPO3OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODEAGPO3OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODEAGPO4OUTMODE Property

IRD

Adp5589GPOOUTMODEAGPO4OUTMODE Property

GPO_OUT_MODE_A: GPO_4_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODEAGPO4OUTMODE { get; set; }
Public Property GPOOUTMODEAGPO4OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODEAGPO4OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODEAGPO4OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODEAGPO5OUTMODE Property

IRD

Adp5589GPOOUTMODEAGPO5OUTMODE Property

GPO_OUT_MODE_A: GPO_5_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODEAGPO5OUTMODE { get; set; }
Public Property GPOOUTMODEAGPO5OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODEAGPO5OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODEAGPO5OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODEAGPO6OUTMODE Property

IRD

Adp5589GPOOUTMODEAGPO6OUTMODE Property

GPO_OUT_MODE_A: GPO_6_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODEAGPO6OUTMODE { get; set; }
Public Property GPOOUTMODEAGPO6OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODEAGPO6OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODEAGPO6OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODEAGPO7OUTMODE Property

IRD

Adp5589GPOOUTMODEAGPO7OUTMODE Property

GPO_OUT_MODE_A: GPO_7_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODEAGPO7OUTMODE { get; set; }
Public Property GPOOUTMODEAGPO7OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODEAGPO7OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODEAGPO7OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODEAGPO8OUTMODE Property

IRD

Adp5589GPOOUTMODEAGPO8OUTMODE Property

GPO_OUT_MODE_A: GPO_8_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODEAGPO8OUTMODE { get; set; }
Public Property GPOOUTMODEAGPO8OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODEAGPO8OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODEAGPO8OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODEBGPO10OUTMODE Property

IRD

Adp5589GPOOUTMODEBGPO10OUTMODE Property

GPO_OUT_MODE_B: GPO_10_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODEBGPO10OUTMODE { get; set; }
Public Property GPOOUTMODEBGPO10OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODEBGPO10OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODEBGPO10OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODEBGPO11OUTMODE Property

IRD

Adp5589GPOOUTMODEBGPO11OUTMODE Property

GPO_OUT_MODE_B: GPO_11_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODEBGPO11OUTMODE { get; set; }
Public Property GPOOUTMODEBGPO11OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODEBGPO11OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODEBGPO11OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODEBGPO12OUTMODE Property

IRD

Adp5589GPOOUTMODEBGPO12OUTMODE Property

GPO_OUT_MODE_B: GPO_12_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODEBGPO12OUTMODE { get; set; }
Public Property GPOOUTMODEBGPO12OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODEBGPO12OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODEBGPO12OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODEBGPO13OUTMODE Property

IRD

Adp5589GPOOUTMODEBGPO13OUTMODE Property

GPO_OUT_MODE_B: GPO_13_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODEBGPO13OUTMODE { get; set; }
Public Property GPOOUTMODEBGPO13OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODEBGPO13OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODEBGPO13OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODEBGPO14OUTMODE Property

IRD

Adp5589GPOOUTMODEBGPO14OUTMODE Property

GPO_OUT_MODE_B: GPO_14_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODEBGPO14OUTMODE { get; set; }
Public Property GPOOUTMODEBGPO14OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODEBGPO14OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODEBGPO14OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODEBGPO15OUTMODE Property

IRD

Adp5589GPOOUTMODEBGPO15OUTMODE Property

GPO_OUT_MODE_B: GPO_15_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODEBGPO15OUTMODE { get; set; }
Public Property GPOOUTMODEBGPO15OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODEBGPO15OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODEBGPO15OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODEBGPO16OUTMODE Property

IRD

Adp5589GPOOUTMODEBGPO16OUTMODE Property

GPO_OUT_MODE_B: GPO_16_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODEBGPO16OUTMODE { get; set; }
Public Property GPOOUTMODEBGPO16OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODEBGPO16OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODEBGPO16OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODEBGPO9OUTMODE Property

IRD

Adp5589GPOOUTMODEBGPO9OUTMODE Property

GPO_OUT_MODE_B: GPO_9_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODEBGPO9OUTMODE { get; set; }
Public Property GPOOUTMODEBGPO9OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODEBGPO9OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODEBGPO9OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODECGPO17OUTMODE Property

IRD

Adp5589GPOOUTMODECGPO17OUTMODE Property

GPO_OUT_MODE_C: GPO_17_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODECGPO17OUTMODE { get; set; }
Public Property GPOOUTMODECGPO17OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODECGPO17OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODECGPO17OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODECGPO18OUTMODE Property

IRD

Adp5589GPOOUTMODECGPO18OUTMODE Property

GPO_OUT_MODE_C: GPO_18_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODECGPO18OUTMODE { get; set; }
Public Property GPOOUTMODECGPO18OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODECGPO18OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODECGPO18OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.GPOOUTMODECGPO19OUTMODE Property

IRD

Adp5589GPOOUTMODECGPO19OUTMODE Property

GPO_OUT_MODE_C: GPO_19_OUT_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeGpoOutMode GPOOUTMODECGPO19OUTMODE { get; set; }
Public Property GPOOUTMODECGPO19OUTMODE As Adp5589TypeGpoOutMode
    Get
    Set
public:
property Adp5589TypeGpoOutMode GPOOUTMODECGPO19OUTMODE {
    Adp5589TypeGpoOutMode get ();
    void set (Adp5589TypeGpoOutMode value);
}
member GPOOUTMODECGPO19OUTMODE : Adp5589TypeGpoOutMode with get, set

Property Value

Type: Adp5589TypeGpoOutMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.IDMANID Property

IRD

Adp5589IDMANID Property

ID: MAN_ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IDMANID { get; }
Public ReadOnly Property IDMANID As Byte
    Get
public:
property unsigned char IDMANID {
    unsigned char get ();
}
member IDMANID : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.IDREVID Property

IRD

Adp5589IDREVID Property

ID: REV_ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IDREVID { get; }
Public ReadOnly Property IDREVID As Byte
    Get
public:
property unsigned char IDREVID {
    unsigned char get ();
}
member IDREVID : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.INTENEVENTIEN Property

IRD

Adp5589INTENEVENTIEN Property

INT_EN: EVENT_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeIntEn INTENEVENTIEN { get; set; }
Public Property INTENEVENTIEN As Adp5589TypeIntEn
    Get
    Set
public:
property Adp5589TypeIntEn INTENEVENTIEN {
    Adp5589TypeIntEn get ();
    void set (Adp5589TypeIntEn value);
}
member INTENEVENTIEN : Adp5589TypeIntEn with get, set

Property Value

Type: Adp5589TypeIntEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.INTENGPIIEN Property

IRD

Adp5589INTENGPIIEN Property

INT_EN: GPI_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeIntEn INTENGPIIEN { get; set; }
Public Property INTENGPIIEN As Adp5589TypeIntEn
    Get
    Set
public:
property Adp5589TypeIntEn INTENGPIIEN {
    Adp5589TypeIntEn get ();
    void set (Adp5589TypeIntEn value);
}
member INTENGPIIEN : Adp5589TypeIntEn with get, set

Property Value

Type: Adp5589TypeIntEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.INTENLOCKEN Property

IRD

Adp5589INTENLOCKEN Property

INT_EN: LOCK_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeIntEn INTENLOCKEN { get; set; }
Public Property INTENLOCKEN As Adp5589TypeIntEn
    Get
    Set
public:
property Adp5589TypeIntEn INTENLOCKEN {
    Adp5589TypeIntEn get ();
    void set (Adp5589TypeIntEn value);
}
member INTENLOCKEN : Adp5589TypeIntEn with get, set

Property Value

Type: Adp5589TypeIntEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.INTENLOGIC1EN Property

IRD

Adp5589INTENLOGIC1EN Property

INT_EN: LOGIC1_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeIntEn INTENLOGIC1EN { get; set; }
Public Property INTENLOGIC1EN As Adp5589TypeIntEn
    Get
    Set
public:
property Adp5589TypeIntEn INTENLOGIC1EN {
    Adp5589TypeIntEn get ();
    void set (Adp5589TypeIntEn value);
}
member INTENLOGIC1EN : Adp5589TypeIntEn with get, set

Property Value

Type: Adp5589TypeIntEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.INTENLOGIC2EN Property

IRD

Adp5589INTENLOGIC2EN Property

INT_EN: LOGIC2_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeIntEn INTENLOGIC2EN { get; set; }
Public Property INTENLOGIC2EN As Adp5589TypeIntEn
    Get
    Set
public:
property Adp5589TypeIntEn INTENLOGIC2EN {
    Adp5589TypeIntEn get ();
    void set (Adp5589TypeIntEn value);
}
member INTENLOGIC2EN : Adp5589TypeIntEn with get, set

Property Value

Type: Adp5589TypeIntEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.INTENOVRFLOWIEN Property

IRD

Adp5589INTENOVRFLOWIEN Property

INT_EN: OVRFLOW_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeIntEn INTENOVRFLOWIEN { get; set; }
Public Property INTENOVRFLOWIEN As Adp5589TypeIntEn
    Get
    Set
public:
property Adp5589TypeIntEn INTENOVRFLOWIEN {
    Adp5589TypeIntEn get ();
    void set (Adp5589TypeIntEn value);
}
member INTENOVRFLOWIEN : Adp5589TypeIntEn with get, set

Property Value

Type: Adp5589TypeIntEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.INTSTATUSEVENTINT Property

IRD

Adp5589INTSTATUSEVENTINT Property

INT_STATUS: EVENT_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeIntStatus INTSTATUSEVENTINT { get; set; }
Public Property INTSTATUSEVENTINT As Adp5589TypeIntStatus
    Get
    Set
public:
property Adp5589TypeIntStatus INTSTATUSEVENTINT {
    Adp5589TypeIntStatus get ();
    void set (Adp5589TypeIntStatus value);
}
member INTSTATUSEVENTINT : Adp5589TypeIntStatus with get, set

Property Value

Type: Adp5589TypeIntStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.INTSTATUSGPIINT Property

IRD

Adp5589INTSTATUSGPIINT Property

INT_STATUS: GPI_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeIntStatus INTSTATUSGPIINT { get; set; }
Public Property INTSTATUSGPIINT As Adp5589TypeIntStatus
    Get
    Set
public:
property Adp5589TypeIntStatus INTSTATUSGPIINT {
    Adp5589TypeIntStatus get ();
    void set (Adp5589TypeIntStatus value);
}
member INTSTATUSGPIINT : Adp5589TypeIntStatus with get, set

Property Value

Type: Adp5589TypeIntStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.INTSTATUSLOCKINT Property

IRD

Adp5589INTSTATUSLOCKINT Property

INT_STATUS: LOCK_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeIntStatus INTSTATUSLOCKINT { get; set; }
Public Property INTSTATUSLOCKINT As Adp5589TypeIntStatus
    Get
    Set
public:
property Adp5589TypeIntStatus INTSTATUSLOCKINT {
    Adp5589TypeIntStatus get ();
    void set (Adp5589TypeIntStatus value);
}
member INTSTATUSLOCKINT : Adp5589TypeIntStatus with get, set

Property Value

Type: Adp5589TypeIntStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.INTSTATUSLOGIC1INT Property

IRD

Adp5589INTSTATUSLOGIC1INT Property

INT_STATUS: LOGIC1_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeIntStatus INTSTATUSLOGIC1INT { get; set; }
Public Property INTSTATUSLOGIC1INT As Adp5589TypeIntStatus
    Get
    Set
public:
property Adp5589TypeIntStatus INTSTATUSLOGIC1INT {
    Adp5589TypeIntStatus get ();
    void set (Adp5589TypeIntStatus value);
}
member INTSTATUSLOGIC1INT : Adp5589TypeIntStatus with get, set

Property Value

Type: Adp5589TypeIntStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.INTSTATUSLOGIC2INT Property

IRD

Adp5589INTSTATUSLOGIC2INT Property

INT_STATUS: LOGIC2_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeIntStatus INTSTATUSLOGIC2INT { get; set; }
Public Property INTSTATUSLOGIC2INT As Adp5589TypeIntStatus
    Get
    Set
public:
property Adp5589TypeIntStatus INTSTATUSLOGIC2INT {
    Adp5589TypeIntStatus get ();
    void set (Adp5589TypeIntStatus value);
}
member INTSTATUSLOGIC2INT : Adp5589TypeIntStatus with get, set

Property Value

Type: Adp5589TypeIntStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.INTSTATUSOVRFLOWINT Property

IRD

Adp5589INTSTATUSOVRFLOWINT Property

INT_STATUS: OVRFLOW_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeIntStatus INTSTATUSOVRFLOWINT { get; set; }
Public Property INTSTATUSOVRFLOWINT As Adp5589TypeIntStatus
    Get
    Set
public:
property Adp5589TypeIntStatus INTSTATUSOVRFLOWINT {
    Adp5589TypeIntStatus get ();
    void set (Adp5589TypeIntStatus value);
}
member INTSTATUSOVRFLOWINT : Adp5589TypeIntStatus with get, set

Property Value

Type: Adp5589TypeIntStatus
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOCKCFGLOCKEN Property

IRD

Adp5589LOCKCFGLOCKEN Property

LOCK_CFG: LOCK_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLockCfgLockEn LOCKCFGLOCKEN { get; set; }
Public Property LOCKCFGLOCKEN As Adp5589TypeLockCfgLockEn
    Get
    Set
public:
property Adp5589TypeLockCfgLockEn LOCKCFGLOCKEN {
    Adp5589TypeLockCfgLockEn get ();
    void set (Adp5589TypeLockCfgLockEn value);
}
member LOCKCFGLOCKEN : Adp5589TypeLockCfgLockEn with get, set

Property Value

Type: Adp5589TypeLockCfgLockEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGIC1CFGLA1INV Property

IRD

Adp5589LOGIC1CFGLA1INV Property

LOGIC_1_CFG: LA1_INV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogicCfgInv LOGIC1CFGLA1INV { get; set; }
Public Property LOGIC1CFGLA1INV As Adp5589TypeLogicCfgInv
    Get
    Set
public:
property Adp5589TypeLogicCfgInv LOGIC1CFGLA1INV {
    Adp5589TypeLogicCfgInv get ();
    void set (Adp5589TypeLogicCfgInv value);
}
member LOGIC1CFGLA1INV : Adp5589TypeLogicCfgInv with get, set

Property Value

Type: Adp5589TypeLogicCfgInv
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGIC1CFGLB1INV Property

IRD

Adp5589LOGIC1CFGLB1INV Property

LOGIC_1_CFG: LB1_INV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogicCfgInv LOGIC1CFGLB1INV { get; set; }
Public Property LOGIC1CFGLB1INV As Adp5589TypeLogicCfgInv
    Get
    Set
public:
property Adp5589TypeLogicCfgInv LOGIC1CFGLB1INV {
    Adp5589TypeLogicCfgInv get ();
    void set (Adp5589TypeLogicCfgInv value);
}
member LOGIC1CFGLB1INV : Adp5589TypeLogicCfgInv with get, set

Property Value

Type: Adp5589TypeLogicCfgInv
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGIC1CFGLC1INV Property

IRD

Adp5589LOGIC1CFGLC1INV Property

LOGIC_1_CFG: LC1_INV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogicCfgInv LOGIC1CFGLC1INV { get; set; }
Public Property LOGIC1CFGLC1INV As Adp5589TypeLogicCfgInv
    Get
    Set
public:
property Adp5589TypeLogicCfgInv LOGIC1CFGLC1INV {
    Adp5589TypeLogicCfgInv get ();
    void set (Adp5589TypeLogicCfgInv value);
}
member LOGIC1CFGLC1INV : Adp5589TypeLogicCfgInv with get, set

Property Value

Type: Adp5589TypeLogicCfgInv
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGIC1CFGLOGIC1SEL Property

IRD

Adp5589LOGIC1CFGLOGIC1SEL Property

LOGIC_1_CFG: LOGIC1_SEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogic1CfgLogic1Sel LOGIC1CFGLOGIC1SEL { get; set; }
Public Property LOGIC1CFGLOGIC1SEL As Adp5589TypeLogic1CfgLogic1Sel
    Get
    Set
public:
property Adp5589TypeLogic1CfgLogic1Sel LOGIC1CFGLOGIC1SEL {
    Adp5589TypeLogic1CfgLogic1Sel get ();
    void set (Adp5589TypeLogic1CfgLogic1Sel value);
}
member LOGIC1CFGLOGIC1SEL : Adp5589TypeLogic1CfgLogic1Sel with get, set

Property Value

Type: Adp5589TypeLogic1CfgLogic1Sel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGIC1CFGLY1INV Property

IRD

Adp5589LOGIC1CFGLY1INV Property

LOGIC_1_CFG: LY1_INV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogicCfgInv LOGIC1CFGLY1INV { get; set; }
Public Property LOGIC1CFGLY1INV As Adp5589TypeLogicCfgInv
    Get
    Set
public:
property Adp5589TypeLogicCfgInv LOGIC1CFGLY1INV {
    Adp5589TypeLogicCfgInv get ();
    void set (Adp5589TypeLogicCfgInv value);
}
member LOGIC1CFGLY1INV : Adp5589TypeLogicCfgInv with get, set

Property Value

Type: Adp5589TypeLogicCfgInv
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGIC2CFGLA2INV Property

IRD

Adp5589LOGIC2CFGLA2INV Property

LOGIC_2_CFG: LA2_INV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogicCfgInv LOGIC2CFGLA2INV { get; set; }
Public Property LOGIC2CFGLA2INV As Adp5589TypeLogicCfgInv
    Get
    Set
public:
property Adp5589TypeLogicCfgInv LOGIC2CFGLA2INV {
    Adp5589TypeLogicCfgInv get ();
    void set (Adp5589TypeLogicCfgInv value);
}
member LOGIC2CFGLA2INV : Adp5589TypeLogicCfgInv with get, set

Property Value

Type: Adp5589TypeLogicCfgInv
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGIC2CFGLB2INV Property

IRD

Adp5589LOGIC2CFGLB2INV Property

LOGIC_2_CFG: LB2_INV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogicCfgInv LOGIC2CFGLB2INV { get; set; }
Public Property LOGIC2CFGLB2INV As Adp5589TypeLogicCfgInv
    Get
    Set
public:
property Adp5589TypeLogicCfgInv LOGIC2CFGLB2INV {
    Adp5589TypeLogicCfgInv get ();
    void set (Adp5589TypeLogicCfgInv value);
}
member LOGIC2CFGLB2INV : Adp5589TypeLogicCfgInv with get, set

Property Value

Type: Adp5589TypeLogicCfgInv
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGIC2CFGLC2INV Property

IRD

Adp5589LOGIC2CFGLC2INV Property

LOGIC_2_CFG: LC2_INV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogicCfgInv LOGIC2CFGLC2INV { get; set; }
Public Property LOGIC2CFGLC2INV As Adp5589TypeLogicCfgInv
    Get
    Set
public:
property Adp5589TypeLogicCfgInv LOGIC2CFGLC2INV {
    Adp5589TypeLogicCfgInv get ();
    void set (Adp5589TypeLogicCfgInv value);
}
member LOGIC2CFGLC2INV : Adp5589TypeLogicCfgInv with get, set

Property Value

Type: Adp5589TypeLogicCfgInv
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGIC2CFGLOGIC2SEL Property

IRD

Adp5589LOGIC2CFGLOGIC2SEL Property

LOGIC_2_CFG: LOGIC2_SEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogic2CfgLogic2Sel LOGIC2CFGLOGIC2SEL { get; set; }
Public Property LOGIC2CFGLOGIC2SEL As Adp5589TypeLogic2CfgLogic2Sel
    Get
    Set
public:
property Adp5589TypeLogic2CfgLogic2Sel LOGIC2CFGLOGIC2SEL {
    Adp5589TypeLogic2CfgLogic2Sel get ();
    void set (Adp5589TypeLogic2CfgLogic2Sel value);
}
member LOGIC2CFGLOGIC2SEL : Adp5589TypeLogic2CfgLogic2Sel with get, set

Property Value

Type: Adp5589TypeLogic2CfgLogic2Sel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGIC2CFGLY1CASCADE Property

IRD

Adp5589LOGIC2CFGLY1CASCADE Property

LOGIC_2_CFG: LY1_CASCADE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogic2CfgLy1Cascade LOGIC2CFGLY1CASCADE { get; set; }
Public Property LOGIC2CFGLY1CASCADE As Adp5589TypeLogic2CfgLy1Cascade
    Get
    Set
public:
property Adp5589TypeLogic2CfgLy1Cascade LOGIC2CFGLY1CASCADE {
    Adp5589TypeLogic2CfgLy1Cascade get ();
    void set (Adp5589TypeLogic2CfgLy1Cascade value);
}
member LOGIC2CFGLY1CASCADE : Adp5589TypeLogic2CfgLy1Cascade with get, set

Property Value

Type: Adp5589TypeLogic2CfgLy1Cascade
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGIC2CFGLY2INV Property

IRD

Adp5589LOGIC2CFGLY2INV Property

LOGIC_2_CFG: LY2_INV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogicCfgInv LOGIC2CFGLY2INV { get; set; }
Public Property LOGIC2CFGLY2INV As Adp5589TypeLogicCfgInv
    Get
    Set
public:
property Adp5589TypeLogicCfgInv LOGIC2CFGLY2INV {
    Adp5589TypeLogicCfgInv get ();
    void set (Adp5589TypeLogicCfgInv value);
}
member LOGIC2CFGLY2INV : Adp5589TypeLogicCfgInv with get, set

Property Value

Type: Adp5589TypeLogicCfgInv
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGICFFCFGFF1CLR Property

IRD

Adp5589LOGICFFCFGFF1CLR Property

LOGIC_FF_CFG: FF1_CLR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogicFfCfgClr LOGICFFCFGFF1CLR { get; set; }
Public Property LOGICFFCFGFF1CLR As Adp5589TypeLogicFfCfgClr
    Get
    Set
public:
property Adp5589TypeLogicFfCfgClr LOGICFFCFGFF1CLR {
    Adp5589TypeLogicFfCfgClr get ();
    void set (Adp5589TypeLogicFfCfgClr value);
}
member LOGICFFCFGFF1CLR : Adp5589TypeLogicFfCfgClr with get, set

Property Value

Type: Adp5589TypeLogicFfCfgClr
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGICFFCFGFF1SET Property

IRD

Adp5589LOGICFFCFGFF1SET Property

LOGIC_FF_CFG: FF1_SET

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogicFfCfgSet LOGICFFCFGFF1SET { get; set; }
Public Property LOGICFFCFGFF1SET As Adp5589TypeLogicFfCfgSet
    Get
    Set
public:
property Adp5589TypeLogicFfCfgSet LOGICFFCFGFF1SET {
    Adp5589TypeLogicFfCfgSet get ();
    void set (Adp5589TypeLogicFfCfgSet value);
}
member LOGICFFCFGFF1SET : Adp5589TypeLogicFfCfgSet with get, set

Property Value

Type: Adp5589TypeLogicFfCfgSet
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGICFFCFGFF2CLR Property

IRD

Adp5589LOGICFFCFGFF2CLR Property

LOGIC_FF_CFG: FF2_CLR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogicFfCfgClr LOGICFFCFGFF2CLR { get; set; }
Public Property LOGICFFCFGFF2CLR As Adp5589TypeLogicFfCfgClr
    Get
    Set
public:
property Adp5589TypeLogicFfCfgClr LOGICFFCFGFF2CLR {
    Adp5589TypeLogicFfCfgClr get ();
    void set (Adp5589TypeLogicFfCfgClr value);
}
member LOGICFFCFGFF2CLR : Adp5589TypeLogicFfCfgClr with get, set

Property Value

Type: Adp5589TypeLogicFfCfgClr
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGICFFCFGFF2SET Property

IRD

Adp5589LOGICFFCFGFF2SET Property

LOGIC_FF_CFG: FF2_SET

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogicFfCfgSet LOGICFFCFGFF2SET { get; set; }
Public Property LOGICFFCFGFF2SET As Adp5589TypeLogicFfCfgSet
    Get
    Set
public:
property Adp5589TypeLogicFfCfgSet LOGICFFCFGFF2SET {
    Adp5589TypeLogicFfCfgSet get ();
    void set (Adp5589TypeLogicFfCfgSet value);
}
member LOGICFFCFGFF2SET : Adp5589TypeLogicFfCfgSet with get, set

Property Value

Type: Adp5589TypeLogicFfCfgSet
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGICINTEVENTENLOGIC1EVENTEN Property

IRD

Adp5589LOGICINTEVENTENLOGIC1EVENTEN Property

LOGIC_INT_EVENT_EN: LOGIC1_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogicIntEventEnLogicEventEn LOGICINTEVENTENLOGIC1EVENTEN { get; set; }
Public Property LOGICINTEVENTENLOGIC1EVENTEN As Adp5589TypeLogicIntEventEnLogicEventEn
    Get
    Set
public:
property Adp5589TypeLogicIntEventEnLogicEventEn LOGICINTEVENTENLOGIC1EVENTEN {
    Adp5589TypeLogicIntEventEnLogicEventEn get ();
    void set (Adp5589TypeLogicIntEventEnLogicEventEn value);
}
member LOGICINTEVENTENLOGIC1EVENTEN : Adp5589TypeLogicIntEventEnLogicEventEn with get, set

Property Value

Type: Adp5589TypeLogicIntEventEnLogicEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGICINTEVENTENLOGIC1INTLEVEL Property

IRD

Adp5589LOGICINTEVENTENLOGIC1INTLEVEL Property

LOGIC_INT_EVENT_EN: LOGIC1_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogicIntEventEnLogicIntLevel LOGICINTEVENTENLOGIC1INTLEVEL { get; set; }
Public Property LOGICINTEVENTENLOGIC1INTLEVEL As Adp5589TypeLogicIntEventEnLogicIntLevel
    Get
    Set
public:
property Adp5589TypeLogicIntEventEnLogicIntLevel LOGICINTEVENTENLOGIC1INTLEVEL {
    Adp5589TypeLogicIntEventEnLogicIntLevel get ();
    void set (Adp5589TypeLogicIntEventEnLogicIntLevel value);
}
member LOGICINTEVENTENLOGIC1INTLEVEL : Adp5589TypeLogicIntEventEnLogicIntLevel with get, set

Property Value

Type: Adp5589TypeLogicIntEventEnLogicIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGICINTEVENTENLOGIC2EVENTEN Property

IRD

Adp5589LOGICINTEVENTENLOGIC2EVENTEN Property

LOGIC_INT_EVENT_EN: LOGIC2_EVENT_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogicIntEventEnLogicEventEn LOGICINTEVENTENLOGIC2EVENTEN { get; set; }
Public Property LOGICINTEVENTENLOGIC2EVENTEN As Adp5589TypeLogicIntEventEnLogicEventEn
    Get
    Set
public:
property Adp5589TypeLogicIntEventEnLogicEventEn LOGICINTEVENTENLOGIC2EVENTEN {
    Adp5589TypeLogicIntEventEnLogicEventEn get ();
    void set (Adp5589TypeLogicIntEventEnLogicEventEn value);
}
member LOGICINTEVENTENLOGIC2EVENTEN : Adp5589TypeLogicIntEventEnLogicEventEn with get, set

Property Value

Type: Adp5589TypeLogicIntEventEnLogicEventEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGICINTEVENTENLOGIC2INTLEVEL Property

IRD

Adp5589LOGICINTEVENTENLOGIC2INTLEVEL Property

LOGIC_INT_EVENT_EN: LOGIC2_INT_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogicIntEventEnLogicIntLevel LOGICINTEVENTENLOGIC2INTLEVEL { get; set; }
Public Property LOGICINTEVENTENLOGIC2INTLEVEL As Adp5589TypeLogicIntEventEnLogicIntLevel
    Get
    Set
public:
property Adp5589TypeLogicIntEventEnLogicIntLevel LOGICINTEVENTENLOGIC2INTLEVEL {
    Adp5589TypeLogicIntEventEnLogicIntLevel get ();
    void set (Adp5589TypeLogicIntEventEnLogicIntLevel value);
}
member LOGICINTEVENTENLOGIC2INTLEVEL : Adp5589TypeLogicIntEventEnLogicIntLevel with get, set

Property Value

Type: Adp5589TypeLogicIntEventEnLogicIntLevel
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGICINTEVENTENLY1DBNCDIS Property

IRD

Adp5589LOGICINTEVENTENLY1DBNCDIS Property

LOGIC_INT_EVENT_EN: LY1_DBNC_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogicIntEventEnLyDbncDis LOGICINTEVENTENLY1DBNCDIS { get; set; }
Public Property LOGICINTEVENTENLY1DBNCDIS As Adp5589TypeLogicIntEventEnLyDbncDis
    Get
    Set
public:
property Adp5589TypeLogicIntEventEnLyDbncDis LOGICINTEVENTENLY1DBNCDIS {
    Adp5589TypeLogicIntEventEnLyDbncDis get ();
    void set (Adp5589TypeLogicIntEventEnLyDbncDis value);
}
member LOGICINTEVENTENLY1DBNCDIS : Adp5589TypeLogicIntEventEnLyDbncDis with get, set

Property Value

Type: Adp5589TypeLogicIntEventEnLyDbncDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.LOGICINTEVENTENLY2DBNCDIS Property

IRD

Adp5589LOGICINTEVENTENLY2DBNCDIS Property

LOGIC_INT_EVENT_EN: LY2_DBNC_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeLogicIntEventEnLyDbncDis LOGICINTEVENTENLY2DBNCDIS { get; set; }
Public Property LOGICINTEVENTENLY2DBNCDIS As Adp5589TypeLogicIntEventEnLyDbncDis
    Get
    Set
public:
property Adp5589TypeLogicIntEventEnLyDbncDis LOGICINTEVENTENLY2DBNCDIS {
    Adp5589TypeLogicIntEventEnLyDbncDis get ();
    void set (Adp5589TypeLogicIntEventEnLyDbncDis value);
}
member LOGICINTEVENTENLY2DBNCDIS : Adp5589TypeLogicIntEventEnLyDbncDis with get, set

Property Value

Type: Adp5589TypeLogicIntEventEnLyDbncDis
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGAR0CONFIG Property

IRD

Adp5589PINCONFIGAR0CONFIG Property

PIN_CONFIG_A: R0_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigAR0Config PINCONFIGAR0CONFIG { get; set; }
Public Property PINCONFIGAR0CONFIG As Adp5589TypePinConfigAR0Config
    Get
    Set
public:
property Adp5589TypePinConfigAR0Config PINCONFIGAR0CONFIG {
    Adp5589TypePinConfigAR0Config get ();
    void set (Adp5589TypePinConfigAR0Config value);
}
member PINCONFIGAR0CONFIG : Adp5589TypePinConfigAR0Config with get, set

Property Value

Type: Adp5589TypePinConfigAR0Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGAR1CONFIG Property

IRD

Adp5589PINCONFIGAR1CONFIG Property

PIN_CONFIG_A: R1_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigAR1Config PINCONFIGAR1CONFIG { get; set; }
Public Property PINCONFIGAR1CONFIG As Adp5589TypePinConfigAR1Config
    Get
    Set
public:
property Adp5589TypePinConfigAR1Config PINCONFIGAR1CONFIG {
    Adp5589TypePinConfigAR1Config get ();
    void set (Adp5589TypePinConfigAR1Config value);
}
member PINCONFIGAR1CONFIG : Adp5589TypePinConfigAR1Config with get, set

Property Value

Type: Adp5589TypePinConfigAR1Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGAR2CONFIG Property

IRD

Adp5589PINCONFIGAR2CONFIG Property

PIN_CONFIG_A: R2_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigAR2Config PINCONFIGAR2CONFIG { get; set; }
Public Property PINCONFIGAR2CONFIG As Adp5589TypePinConfigAR2Config
    Get
    Set
public:
property Adp5589TypePinConfigAR2Config PINCONFIGAR2CONFIG {
    Adp5589TypePinConfigAR2Config get ();
    void set (Adp5589TypePinConfigAR2Config value);
}
member PINCONFIGAR2CONFIG : Adp5589TypePinConfigAR2Config with get, set

Property Value

Type: Adp5589TypePinConfigAR2Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGAR3CONFIG Property

IRD

Adp5589PINCONFIGAR3CONFIG Property

PIN_CONFIG_A: R3_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigAR3Config PINCONFIGAR3CONFIG { get; set; }
Public Property PINCONFIGAR3CONFIG As Adp5589TypePinConfigAR3Config
    Get
    Set
public:
property Adp5589TypePinConfigAR3Config PINCONFIGAR3CONFIG {
    Adp5589TypePinConfigAR3Config get ();
    void set (Adp5589TypePinConfigAR3Config value);
}
member PINCONFIGAR3CONFIG : Adp5589TypePinConfigAR3Config with get, set

Property Value

Type: Adp5589TypePinConfigAR3Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGAR4CONFIG Property

IRD

Adp5589PINCONFIGAR4CONFIG Property

PIN_CONFIG_A: R4_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigAR4Config PINCONFIGAR4CONFIG { get; set; }
Public Property PINCONFIGAR4CONFIG As Adp5589TypePinConfigAR4Config
    Get
    Set
public:
property Adp5589TypePinConfigAR4Config PINCONFIGAR4CONFIG {
    Adp5589TypePinConfigAR4Config get ();
    void set (Adp5589TypePinConfigAR4Config value);
}
member PINCONFIGAR4CONFIG : Adp5589TypePinConfigAR4Config with get, set

Property Value

Type: Adp5589TypePinConfigAR4Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGAR5CONFIG Property

IRD

Adp5589PINCONFIGAR5CONFIG Property

PIN_CONFIG_A: R5_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigAR5Config PINCONFIGAR5CONFIG { get; set; }
Public Property PINCONFIGAR5CONFIG As Adp5589TypePinConfigAR5Config
    Get
    Set
public:
property Adp5589TypePinConfigAR5Config PINCONFIGAR5CONFIG {
    Adp5589TypePinConfigAR5Config get ();
    void set (Adp5589TypePinConfigAR5Config value);
}
member PINCONFIGAR5CONFIG : Adp5589TypePinConfigAR5Config with get, set

Property Value

Type: Adp5589TypePinConfigAR5Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGAR6CONFIG Property

IRD

Adp5589PINCONFIGAR6CONFIG Property

PIN_CONFIG_A: R6_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigAR6Config PINCONFIGAR6CONFIG { get; set; }
Public Property PINCONFIGAR6CONFIG As Adp5589TypePinConfigAR6Config
    Get
    Set
public:
property Adp5589TypePinConfigAR6Config PINCONFIGAR6CONFIG {
    Adp5589TypePinConfigAR6Config get ();
    void set (Adp5589TypePinConfigAR6Config value);
}
member PINCONFIGAR6CONFIG : Adp5589TypePinConfigAR6Config with get, set

Property Value

Type: Adp5589TypePinConfigAR6Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGAR7CONFIG Property

IRD

Adp5589PINCONFIGAR7CONFIG Property

PIN_CONFIG_A: R7_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigAR7Config PINCONFIGAR7CONFIG { get; set; }
Public Property PINCONFIGAR7CONFIG As Adp5589TypePinConfigAR7Config
    Get
    Set
public:
property Adp5589TypePinConfigAR7Config PINCONFIGAR7CONFIG {
    Adp5589TypePinConfigAR7Config get ();
    void set (Adp5589TypePinConfigAR7Config value);
}
member PINCONFIGAR7CONFIG : Adp5589TypePinConfigAR7Config with get, set

Property Value

Type: Adp5589TypePinConfigAR7Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGBC0CONFIG Property

IRD

Adp5589PINCONFIGBC0CONFIG Property

PIN_CONFIG_B: C0_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigBC0Config PINCONFIGBC0CONFIG { get; set; }
Public Property PINCONFIGBC0CONFIG As Adp5589TypePinConfigBC0Config
    Get
    Set
public:
property Adp5589TypePinConfigBC0Config PINCONFIGBC0CONFIG {
    Adp5589TypePinConfigBC0Config get ();
    void set (Adp5589TypePinConfigBC0Config value);
}
member PINCONFIGBC0CONFIG : Adp5589TypePinConfigBC0Config with get, set

Property Value

Type: Adp5589TypePinConfigBC0Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGBC1CONFIG Property

IRD

Adp5589PINCONFIGBC1CONFIG Property

PIN_CONFIG_B: C1_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigBC1Config PINCONFIGBC1CONFIG { get; set; }
Public Property PINCONFIGBC1CONFIG As Adp5589TypePinConfigBC1Config
    Get
    Set
public:
property Adp5589TypePinConfigBC1Config PINCONFIGBC1CONFIG {
    Adp5589TypePinConfigBC1Config get ();
    void set (Adp5589TypePinConfigBC1Config value);
}
member PINCONFIGBC1CONFIG : Adp5589TypePinConfigBC1Config with get, set

Property Value

Type: Adp5589TypePinConfigBC1Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGBC2CONFIG Property

IRD

Adp5589PINCONFIGBC2CONFIG Property

PIN_CONFIG_B: C2_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigBC2Config PINCONFIGBC2CONFIG { get; set; }
Public Property PINCONFIGBC2CONFIG As Adp5589TypePinConfigBC2Config
    Get
    Set
public:
property Adp5589TypePinConfigBC2Config PINCONFIGBC2CONFIG {
    Adp5589TypePinConfigBC2Config get ();
    void set (Adp5589TypePinConfigBC2Config value);
}
member PINCONFIGBC2CONFIG : Adp5589TypePinConfigBC2Config with get, set

Property Value

Type: Adp5589TypePinConfigBC2Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGBC3CONFIG Property

IRD

Adp5589PINCONFIGBC3CONFIG Property

PIN_CONFIG_B: C3_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigBC3Config PINCONFIGBC3CONFIG { get; set; }
Public Property PINCONFIGBC3CONFIG As Adp5589TypePinConfigBC3Config
    Get
    Set
public:
property Adp5589TypePinConfigBC3Config PINCONFIGBC3CONFIG {
    Adp5589TypePinConfigBC3Config get ();
    void set (Adp5589TypePinConfigBC3Config value);
}
member PINCONFIGBC3CONFIG : Adp5589TypePinConfigBC3Config with get, set

Property Value

Type: Adp5589TypePinConfigBC3Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGBC4CONFIG Property

IRD

Adp5589PINCONFIGBC4CONFIG Property

PIN_CONFIG_B: C4_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigBC4Config PINCONFIGBC4CONFIG { get; set; }
Public Property PINCONFIGBC4CONFIG As Adp5589TypePinConfigBC4Config
    Get
    Set
public:
property Adp5589TypePinConfigBC4Config PINCONFIGBC4CONFIG {
    Adp5589TypePinConfigBC4Config get ();
    void set (Adp5589TypePinConfigBC4Config value);
}
member PINCONFIGBC4CONFIG : Adp5589TypePinConfigBC4Config with get, set

Property Value

Type: Adp5589TypePinConfigBC4Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGBC5CONFIG Property

IRD

Adp5589PINCONFIGBC5CONFIG Property

PIN_CONFIG_B: C5_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigBC5Config PINCONFIGBC5CONFIG { get; set; }
Public Property PINCONFIGBC5CONFIG As Adp5589TypePinConfigBC5Config
    Get
    Set
public:
property Adp5589TypePinConfigBC5Config PINCONFIGBC5CONFIG {
    Adp5589TypePinConfigBC5Config get ();
    void set (Adp5589TypePinConfigBC5Config value);
}
member PINCONFIGBC5CONFIG : Adp5589TypePinConfigBC5Config with get, set

Property Value

Type: Adp5589TypePinConfigBC5Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGBC6CONFIG Property

IRD

Adp5589PINCONFIGBC6CONFIG Property

PIN_CONFIG_B: C6_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigBC6Config PINCONFIGBC6CONFIG { get; set; }
Public Property PINCONFIGBC6CONFIG As Adp5589TypePinConfigBC6Config
    Get
    Set
public:
property Adp5589TypePinConfigBC6Config PINCONFIGBC6CONFIG {
    Adp5589TypePinConfigBC6Config get ();
    void set (Adp5589TypePinConfigBC6Config value);
}
member PINCONFIGBC6CONFIG : Adp5589TypePinConfigBC6Config with get, set

Property Value

Type: Adp5589TypePinConfigBC6Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGBC7CONFIG Property

IRD

Adp5589PINCONFIGBC7CONFIG Property

PIN_CONFIG_B: C7_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigBC7Config PINCONFIGBC7CONFIG { get; set; }
Public Property PINCONFIGBC7CONFIG As Adp5589TypePinConfigBC7Config
    Get
    Set
public:
property Adp5589TypePinConfigBC7Config PINCONFIGBC7CONFIG {
    Adp5589TypePinConfigBC7Config get ();
    void set (Adp5589TypePinConfigBC7Config value);
}
member PINCONFIGBC7CONFIG : Adp5589TypePinConfigBC7Config with get, set

Property Value

Type: Adp5589TypePinConfigBC7Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGCC10CONFIG Property

IRD

Adp5589PINCONFIGCC10CONFIG Property

PIN_CONFIG_C: C10_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigCC10Config PINCONFIGCC10CONFIG { get; set; }
Public Property PINCONFIGCC10CONFIG As Adp5589TypePinConfigCC10Config
    Get
    Set
public:
property Adp5589TypePinConfigCC10Config PINCONFIGCC10CONFIG {
    Adp5589TypePinConfigCC10Config get ();
    void set (Adp5589TypePinConfigCC10Config value);
}
member PINCONFIGCC10CONFIG : Adp5589TypePinConfigCC10Config with get, set

Property Value

Type: Adp5589TypePinConfigCC10Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGCC8CONFIG Property

IRD

Adp5589PINCONFIGCC8CONFIG Property

PIN_CONFIG_C: C8_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigCC8Config PINCONFIGCC8CONFIG { get; set; }
Public Property PINCONFIGCC8CONFIG As Adp5589TypePinConfigCC8Config
    Get
    Set
public:
property Adp5589TypePinConfigCC8Config PINCONFIGCC8CONFIG {
    Adp5589TypePinConfigCC8Config get ();
    void set (Adp5589TypePinConfigCC8Config value);
}
member PINCONFIGCC8CONFIG : Adp5589TypePinConfigCC8Config with get, set

Property Value

Type: Adp5589TypePinConfigCC8Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGCC9CONFIG Property

IRD

Adp5589PINCONFIGCC9CONFIG Property

PIN_CONFIG_C: C9_CONFIG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigCC9Config PINCONFIGCC9CONFIG { get; set; }
Public Property PINCONFIGCC9CONFIG As Adp5589TypePinConfigCC9Config
    Get
    Set
public:
property Adp5589TypePinConfigCC9Config PINCONFIGCC9CONFIG {
    Adp5589TypePinConfigCC9Config get ();
    void set (Adp5589TypePinConfigCC9Config value);
}
member PINCONFIGCC9CONFIG : Adp5589TypePinConfigCC9Config with get, set

Property Value

Type: Adp5589TypePinConfigCC9Config
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGDC4EXTENDCFG Property

IRD

Adp5589PINCONFIGDC4EXTENDCFG Property

PIN_CONFIG_D: C4_EXTEND_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigDC4ExtendCfg PINCONFIGDC4EXTENDCFG { get; set; }
Public Property PINCONFIGDC4EXTENDCFG As Adp5589TypePinConfigDC4ExtendCfg
    Get
    Set
public:
property Adp5589TypePinConfigDC4ExtendCfg PINCONFIGDC4EXTENDCFG {
    Adp5589TypePinConfigDC4ExtendCfg get ();
    void set (Adp5589TypePinConfigDC4ExtendCfg value);
}
member PINCONFIGDC4EXTENDCFG : Adp5589TypePinConfigDC4ExtendCfg with get, set

Property Value

Type: Adp5589TypePinConfigDC4ExtendCfg
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGDC6EXTENDCFG Property

IRD

Adp5589PINCONFIGDC6EXTENDCFG Property

PIN_CONFIG_D: C6_EXTEND_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigDC6ExtendCfg PINCONFIGDC6EXTENDCFG { get; set; }
Public Property PINCONFIGDC6EXTENDCFG As Adp5589TypePinConfigDC6ExtendCfg
    Get
    Set
public:
property Adp5589TypePinConfigDC6ExtendCfg PINCONFIGDC6EXTENDCFG {
    Adp5589TypePinConfigDC6ExtendCfg get ();
    void set (Adp5589TypePinConfigDC6ExtendCfg value);
}
member PINCONFIGDC6EXTENDCFG : Adp5589TypePinConfigDC6ExtendCfg with get, set

Property Value

Type: Adp5589TypePinConfigDC6ExtendCfg
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGDC9EXTENDCFG Property

IRD

Adp5589PINCONFIGDC9EXTENDCFG Property

PIN_CONFIG_D: C9_EXTEND_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigDC9ExtendCfg PINCONFIGDC9EXTENDCFG { get; set; }
Public Property PINCONFIGDC9EXTENDCFG As Adp5589TypePinConfigDC9ExtendCfg
    Get
    Set
public:
property Adp5589TypePinConfigDC9ExtendCfg PINCONFIGDC9EXTENDCFG {
    Adp5589TypePinConfigDC9ExtendCfg get ();
    void set (Adp5589TypePinConfigDC9ExtendCfg value);
}
member PINCONFIGDC9EXTENDCFG : Adp5589TypePinConfigDC9ExtendCfg with get, set

Property Value

Type: Adp5589TypePinConfigDC9ExtendCfg
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGDPULLSELECT Property

IRD

Adp5589PINCONFIGDPULLSELECT Property

PIN_CONFIG_D: PULL_SELECT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigDPullSelect PINCONFIGDPULLSELECT { get; set; }
Public Property PINCONFIGDPULLSELECT As Adp5589TypePinConfigDPullSelect
    Get
    Set
public:
property Adp5589TypePinConfigDPullSelect PINCONFIGDPULLSELECT {
    Adp5589TypePinConfigDPullSelect get ();
    void set (Adp5589TypePinConfigDPullSelect value);
}
member PINCONFIGDPULLSELECT : Adp5589TypePinConfigDPullSelect with get, set

Property Value

Type: Adp5589TypePinConfigDPullSelect
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGDR0EXTENDCFG Property

IRD

Adp5589PINCONFIGDR0EXTENDCFG Property

PIN_CONFIG_D: R0_EXTEND_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigDR0ExtendCfg PINCONFIGDR0EXTENDCFG { get; set; }
Public Property PINCONFIGDR0EXTENDCFG As Adp5589TypePinConfigDR0ExtendCfg
    Get
    Set
public:
property Adp5589TypePinConfigDR0ExtendCfg PINCONFIGDR0EXTENDCFG {
    Adp5589TypePinConfigDR0ExtendCfg get ();
    void set (Adp5589TypePinConfigDR0ExtendCfg value);
}
member PINCONFIGDR0EXTENDCFG : Adp5589TypePinConfigDR0ExtendCfg with get, set

Property Value

Type: Adp5589TypePinConfigDR0ExtendCfg
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGDR3EXTENDCFG Property

IRD

Adp5589PINCONFIGDR3EXTENDCFG Property

PIN_CONFIG_D: R3_EXTEND_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigDR3ExtendCfg PINCONFIGDR3EXTENDCFG { get; set; }
Public Property PINCONFIGDR3EXTENDCFG As Adp5589TypePinConfigDR3ExtendCfg
    Get
    Set
public:
property Adp5589TypePinConfigDR3ExtendCfg PINCONFIGDR3EXTENDCFG {
    Adp5589TypePinConfigDR3ExtendCfg get ();
    void set (Adp5589TypePinConfigDR3ExtendCfg value);
}
member PINCONFIGDR3EXTENDCFG : Adp5589TypePinConfigDR3ExtendCfg with get, set

Property Value

Type: Adp5589TypePinConfigDR3ExtendCfg
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PINCONFIGDR4EXTENDCFG Property

IRD

Adp5589PINCONFIGDR4EXTENDCFG Property

PIN_CONFIG_D: R4_EXTEND_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePinConfigDR4ExtendCfg PINCONFIGDR4EXTENDCFG { get; set; }
Public Property PINCONFIGDR4EXTENDCFG As Adp5589TypePinConfigDR4ExtendCfg
    Get
    Set
public:
property Adp5589TypePinConfigDR4ExtendCfg PINCONFIGDR4EXTENDCFG {
    Adp5589TypePinConfigDR4ExtendCfg get ();
    void set (Adp5589TypePinConfigDR4ExtendCfg value);
}
member PINCONFIGDR4EXTENDCFG : Adp5589TypePinConfigDR4ExtendCfg with get, set

Property Value

Type: Adp5589TypePinConfigDR4ExtendCfg
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.POLLTIMECFGKEYPOLLTIME Property

IRD

Adp5589POLLTIMECFGKEYPOLLTIME Property

POLL_TIME_CFG: KEY_POLL_TIME

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePollTimeCfgKeyPollTime POLLTIMECFGKEYPOLLTIME { get; set; }
Public Property POLLTIMECFGKEYPOLLTIME As Adp5589TypePollTimeCfgKeyPollTime
    Get
    Set
public:
property Adp5589TypePollTimeCfgKeyPollTime POLLTIMECFGKEYPOLLTIME {
    Adp5589TypePollTimeCfgKeyPollTime get ();
    void set (Adp5589TypePollTimeCfgKeyPollTime value);
}
member POLLTIMECFGKEYPOLLTIME : Adp5589TypePollTimeCfgKeyPollTime with get, set

Property Value

Type: Adp5589TypePollTimeCfgKeyPollTime
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PWMCFGPWMEN Property

IRD

Adp5589PWMCFGPWMEN Property

PWM_CFG: PWM_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePwmCfgPwmEn PWMCFGPWMEN { get; set; }
Public Property PWMCFGPWMEN As Adp5589TypePwmCfgPwmEn
    Get
    Set
public:
property Adp5589TypePwmCfgPwmEn PWMCFGPWMEN {
    Adp5589TypePwmCfgPwmEn get ();
    void set (Adp5589TypePwmCfgPwmEn value);
}
member PWMCFGPWMEN : Adp5589TypePwmCfgPwmEn with get, set

Property Value

Type: Adp5589TypePwmCfgPwmEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PWMCFGPWMINAND Property

IRD

Adp5589PWMCFGPWMINAND Property

PWM_CFG: PWM_IN_AND

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePwmCfgPwmInAnd PWMCFGPWMINAND { get; set; }
Public Property PWMCFGPWMINAND As Adp5589TypePwmCfgPwmInAnd
    Get
    Set
public:
property Adp5589TypePwmCfgPwmInAnd PWMCFGPWMINAND {
    Adp5589TypePwmCfgPwmInAnd get ();
    void set (Adp5589TypePwmCfgPwmInAnd value);
}
member PWMCFGPWMINAND : Adp5589TypePwmCfgPwmInAnd with get, set

Property Value

Type: Adp5589TypePwmCfgPwmInAnd
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PWMCFGPWMMODE Property

IRD

Adp5589PWMCFGPWMMODE Property

PWM_CFG: PWM_MODE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypePwmCfgPwmMode PWMCFGPWMMODE { get; set; }
Public Property PWMCFGPWMMODE As Adp5589TypePwmCfgPwmMode
    Get
    Set
public:
property Adp5589TypePwmCfgPwmMode PWMCFGPWMMODE {
    Adp5589TypePwmCfgPwmMode get ();
    void set (Adp5589TypePwmCfgPwmMode value);
}
member PWMCFGPWMMODE : Adp5589TypePwmCfgPwmMode with get, set

Property Value

Type: Adp5589TypePwmCfgPwmMode
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PWMOFFT Property

IRD

Adp5589PWMOFFT Property

PWM_OFFT (unit: µs)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort PWMOFFT { get; set; }
Public Property PWMOFFT As UShort
    Get
    Set
public:
property unsigned short PWMOFFT {
    unsigned short get ();
    void set (unsigned short value);
}
member PWMOFFT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.PWMONT Property

IRD

Adp5589PWMONT Property

PWM_ONT (unit: µs)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort PWMONT { get; set; }
Public Property PWMONT As UShort
    Get
    Set
public:
property unsigned short PWMONT {
    unsigned short get ();
    void set (unsigned short value);
}
member PWMONT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RESET1EVENTARESET1EVENTA Property

IRD

Adp5589RESET1EVENTARESET1EVENTA Property

RESET1_EVENT_A: RESET1_EVENT_A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET1EVENTARESET1EVENTA { get; set; }
Public Property RESET1EVENTARESET1EVENTA As Byte
    Get
    Set
public:
property unsigned char RESET1EVENTARESET1EVENTA {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET1EVENTARESET1EVENTA : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RESET1EVENTARESET1EVENTALEVEL Property

IRD

Adp5589RESET1EVENTARESET1EVENTALEVEL Property

RESET1_EVENT_A: RESET1_EVENT_A_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET1EVENTARESET1EVENTALEVEL { get; set; }
Public Property RESET1EVENTARESET1EVENTALEVEL As Byte
    Get
    Set
public:
property unsigned char RESET1EVENTARESET1EVENTALEVEL {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET1EVENTARESET1EVENTALEVEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RESET1EVENTBRESET1EVENTB Property

IRD

Adp5589RESET1EVENTBRESET1EVENTB Property

RESET1_EVENT_B: RESET1_EVENT_B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET1EVENTBRESET1EVENTB { get; set; }
Public Property RESET1EVENTBRESET1EVENTB As Byte
    Get
    Set
public:
property unsigned char RESET1EVENTBRESET1EVENTB {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET1EVENTBRESET1EVENTB : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RESET1EVENTBRESET1EVENTBLEVEL Property

IRD

Adp5589RESET1EVENTBRESET1EVENTBLEVEL Property

RESET1_EVENT_B: RESET1_EVENT_B_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET1EVENTBRESET1EVENTBLEVEL { get; set; }
Public Property RESET1EVENTBRESET1EVENTBLEVEL As Byte
    Get
    Set
public:
property unsigned char RESET1EVENTBRESET1EVENTBLEVEL {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET1EVENTBRESET1EVENTBLEVEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RESET1EVENTCRESET1EVENTC Property

IRD

Adp5589RESET1EVENTCRESET1EVENTC Property

RESET1_EVENT_C: RESET1_EVENT_C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET1EVENTCRESET1EVENTC { get; set; }
Public Property RESET1EVENTCRESET1EVENTC As Byte
    Get
    Set
public:
property unsigned char RESET1EVENTCRESET1EVENTC {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET1EVENTCRESET1EVENTC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RESET1EVENTCRESET1EVENTCLEVEL Property

IRD

Adp5589RESET1EVENTCRESET1EVENTCLEVEL Property

RESET1_EVENT_C: RESET1_EVENT_C_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET1EVENTCRESET1EVENTCLEVEL { get; set; }
Public Property RESET1EVENTCRESET1EVENTCLEVEL As Byte
    Get
    Set
public:
property unsigned char RESET1EVENTCRESET1EVENTCLEVEL {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET1EVENTCRESET1EVENTCLEVEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RESET2EVENTARESET2EVENTA Property

IRD

Adp5589RESET2EVENTARESET2EVENTA Property

RESET2_EVENT_A: RESET2_EVENT_A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET2EVENTARESET2EVENTA { get; set; }
Public Property RESET2EVENTARESET2EVENTA As Byte
    Get
    Set
public:
property unsigned char RESET2EVENTARESET2EVENTA {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET2EVENTARESET2EVENTA : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RESET2EVENTARESET2EVENTALEVEL Property

IRD

Adp5589RESET2EVENTARESET2EVENTALEVEL Property

RESET2_EVENT_A: RESET2_EVENT_A_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET2EVENTARESET2EVENTALEVEL { get; set; }
Public Property RESET2EVENTARESET2EVENTALEVEL As Byte
    Get
    Set
public:
property unsigned char RESET2EVENTARESET2EVENTALEVEL {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET2EVENTARESET2EVENTALEVEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RESET2EVENTBRESET2EVENTB Property

IRD

Adp5589RESET2EVENTBRESET2EVENTB Property

RESET2_EVENT_B: RESET2_EVENT_B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET2EVENTBRESET2EVENTB { get; set; }
Public Property RESET2EVENTBRESET2EVENTB As Byte
    Get
    Set
public:
property unsigned char RESET2EVENTBRESET2EVENTB {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET2EVENTBRESET2EVENTB : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RESET2EVENTBRESET2EVENTBLEVEL Property

IRD

Adp5589RESET2EVENTBRESET2EVENTBLEVEL Property

RESET2_EVENT_B: RESET2_EVENT_B_LEVEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESET2EVENTBRESET2EVENTBLEVEL { get; set; }
Public Property RESET2EVENTBRESET2EVENTBLEVEL As Byte
    Get
    Set
public:
property unsigned char RESET2EVENTBRESET2EVENTBLEVEL {
    unsigned char get ();
    void set (unsigned char value);
}
member RESET2EVENTBRESET2EVENTBLEVEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RESETCFGRESET1POL Property

IRD

Adp5589RESETCFGRESET1POL Property

RESET_CFG: RESET1_POL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeResetCfgResetPol RESETCFGRESET1POL { get; set; }
Public Property RESETCFGRESET1POL As Adp5589TypeResetCfgResetPol
    Get
    Set
public:
property Adp5589TypeResetCfgResetPol RESETCFGRESET1POL {
    Adp5589TypeResetCfgResetPol get ();
    void set (Adp5589TypeResetCfgResetPol value);
}
member RESETCFGRESET1POL : Adp5589TypeResetCfgResetPol with get, set

Property Value

Type: Adp5589TypeResetCfgResetPol
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RESETCFGRESET2POL Property

IRD

Adp5589RESETCFGRESET2POL Property

RESET_CFG: RESET2_POL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeResetCfgResetPol RESETCFGRESET2POL { get; set; }
Public Property RESETCFGRESET2POL As Adp5589TypeResetCfgResetPol
    Get
    Set
public:
property Adp5589TypeResetCfgResetPol RESETCFGRESET2POL {
    Adp5589TypeResetCfgResetPol get ();
    void set (Adp5589TypeResetCfgResetPol value);
}
member RESETCFGRESET2POL : Adp5589TypeResetCfgResetPol with get, set

Property Value

Type: Adp5589TypeResetCfgResetPol
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RESETCFGRESETPULSEWIDTH Property

IRD

Adp5589RESETCFGRESETPULSEWIDTH Property

RESET_CFG: RESET_PULSE_WIDTH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeResetCfgResetPulseWidth RESETCFGRESETPULSEWIDTH { get; set; }
Public Property RESETCFGRESETPULSEWIDTH As Adp5589TypeResetCfgResetPulseWidth
    Get
    Set
public:
property Adp5589TypeResetCfgResetPulseWidth RESETCFGRESETPULSEWIDTH {
    Adp5589TypeResetCfgResetPulseWidth get ();
    void set (Adp5589TypeResetCfgResetPulseWidth value);
}
member RESETCFGRESETPULSEWIDTH : Adp5589TypeResetCfgResetPulseWidth with get, set

Property Value

Type: Adp5589TypeResetCfgResetPulseWidth
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RESETCFGRESETTRIGGERTIME Property

IRD

Adp5589RESETCFGRESETTRIGGERTIME Property

RESET_CFG: RESET_TRIGGER_TIME (unit: s)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeResetCfgResetTriggerTimer RESETCFGRESETTRIGGERTIME { get; set; }
Public Property RESETCFGRESETTRIGGERTIME As Adp5589TypeResetCfgResetTriggerTimer
    Get
    Set
public:
property Adp5589TypeResetCfgResetTriggerTimer RESETCFGRESETTRIGGERTIME {
    Adp5589TypeResetCfgResetTriggerTimer get ();
    void set (Adp5589TypeResetCfgResetTriggerTimer value);
}
member RESETCFGRESETTRIGGERTIME : Adp5589TypeResetCfgResetTriggerTimer with get, set

Property Value

Type: Adp5589TypeResetCfgResetTriggerTimer
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RESETCFGRSTPASSTHRUEN Property

IRD

Adp5589RESETCFGRSTPASSTHRUEN Property

RESET_CFG: RST_PASSTHRU_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeResetCfgRstPassthruEn RESETCFGRSTPASSTHRUEN { get; set; }
Public Property RESETCFGRSTPASSTHRUEN As Adp5589TypeResetCfgRstPassthruEn
    Get
    Set
public:
property Adp5589TypeResetCfgRstPassthruEn RESETCFGRSTPASSTHRUEN {
    Adp5589TypeResetCfgRstPassthruEn get ();
    void set (Adp5589TypeResetCfgRstPassthruEn value);
}
member RESETCFGRSTPASSTHRUEN : Adp5589TypeResetCfgRstPassthruEn with get, set

Property Value

Type: Adp5589TypeResetCfgRstPassthruEn
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGAR0PULLCFG Property

IRD

Adp5589RPULLCONFIGAR0PULLCFG Property

RPULL_CONFIG_A: R0_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGAR0PULLCFG { get; set; }
Public Property RPULLCONFIGAR0PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGAR0PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGAR0PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGAR1PULLCFG Property

IRD

Adp5589RPULLCONFIGAR1PULLCFG Property

RPULL_CONFIG_A: R1_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGAR1PULLCFG { get; set; }
Public Property RPULLCONFIGAR1PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGAR1PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGAR1PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGAR2PULLCFG Property

IRD

Adp5589RPULLCONFIGAR2PULLCFG Property

RPULL_CONFIG_A: R2_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGAR2PULLCFG { get; set; }
Public Property RPULLCONFIGAR2PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGAR2PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGAR2PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGAR3PULLCFG Property

IRD

Adp5589RPULLCONFIGAR3PULLCFG Property

RPULL_CONFIG_A: R3_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGAR3PULLCFG { get; set; }
Public Property RPULLCONFIGAR3PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGAR3PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGAR3PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGBR4PULLCFG Property

IRD

Adp5589RPULLCONFIGBR4PULLCFG Property

RPULL_CONFIG_B: R4_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGBR4PULLCFG { get; set; }
Public Property RPULLCONFIGBR4PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGBR4PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGBR4PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGBR5PULLCFG Property

IRD

Adp5589RPULLCONFIGBR5PULLCFG Property

RPULL_CONFIG_B: R5_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGBR5PULLCFG { get; set; }
Public Property RPULLCONFIGBR5PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGBR5PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGBR5PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGBR6PULLCFG Property

IRD

Adp5589RPULLCONFIGBR6PULLCFG Property

RPULL_CONFIG_B: R6_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGBR6PULLCFG { get; set; }
Public Property RPULLCONFIGBR6PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGBR6PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGBR6PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGBR7PULLCFG Property

IRD

Adp5589RPULLCONFIGBR7PULLCFG Property

RPULL_CONFIG_B: R7_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGBR7PULLCFG { get; set; }
Public Property RPULLCONFIGBR7PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGBR7PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGBR7PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGCC0PULLCFG Property

IRD

Adp5589RPULLCONFIGCC0PULLCFG Property

RPULL_CONFIG_C: C0_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGCC0PULLCFG { get; set; }
Public Property RPULLCONFIGCC0PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGCC0PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGCC0PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGCC1PULLCFG Property

IRD

Adp5589RPULLCONFIGCC1PULLCFG Property

RPULL_CONFIG_C: C1_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGCC1PULLCFG { get; set; }
Public Property RPULLCONFIGCC1PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGCC1PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGCC1PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGCC2PULLCFG Property

IRD

Adp5589RPULLCONFIGCC2PULLCFG Property

RPULL_CONFIG_C: C2_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGCC2PULLCFG { get; set; }
Public Property RPULLCONFIGCC2PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGCC2PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGCC2PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGCC3PULLCFG Property

IRD

Adp5589RPULLCONFIGCC3PULLCFG Property

RPULL_CONFIG_C: C3_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGCC3PULLCFG { get; set; }
Public Property RPULLCONFIGCC3PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGCC3PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGCC3PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGDC4PULLCFG Property

IRD

Adp5589RPULLCONFIGDC4PULLCFG Property

RPULL_CONFIG_D: C4_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGDC4PULLCFG { get; set; }
Public Property RPULLCONFIGDC4PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGDC4PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGDC4PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGDC5PULLCFG Property

IRD

Adp5589RPULLCONFIGDC5PULLCFG Property

RPULL_CONFIG_D: C5_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGDC5PULLCFG { get; set; }
Public Property RPULLCONFIGDC5PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGDC5PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGDC5PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGDC6PULLCFG Property

IRD

Adp5589RPULLCONFIGDC6PULLCFG Property

RPULL_CONFIG_D: C6_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGDC6PULLCFG { get; set; }
Public Property RPULLCONFIGDC6PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGDC6PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGDC6PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGDC7PULLCFG Property

IRD

Adp5589RPULLCONFIGDC7PULLCFG Property

RPULL_CONFIG_D: C7_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGDC7PULLCFG { get; set; }
Public Property RPULLCONFIGDC7PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGDC7PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGDC7PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGEC10PULLCFG Property

IRD

Adp5589RPULLCONFIGEC10PULLCFG Property

RPULL_CONFIG_E: C10_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGEC10PULLCFG { get; set; }
Public Property RPULLCONFIGEC10PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGEC10PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGEC10PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGEC8PULLCFG Property

IRD

Adp5589RPULLCONFIGEC8PULLCFG Property

RPULL_CONFIG_E: C8_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGEC8PULLCFG { get; set; }
Public Property RPULLCONFIGEC8PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGEC8PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGEC8PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.RPULLCONFIGEC9PULLCFG Property

IRD

Adp5589RPULLCONFIGEC9PULLCFG Property

RPULL_CONFIG_E: C9_PULL_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeRpullConfig RPULLCONFIGEC9PULLCFG { get; set; }
Public Property RPULLCONFIGEC9PULLCFG As Adp5589TypeRpullConfig
    Get
    Set
public:
property Adp5589TypeRpullConfig RPULLCONFIGEC9PULLCFG {
    Adp5589TypeRpullConfig get ();
    void set (Adp5589TypeRpullConfig value);
}
member RPULLCONFIGEC9PULLCFG : Adp5589TypeRpullConfig with get, set

Property Value

Type: Adp5589TypeRpullConfig
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.STATUSEC Property

IRD

Adp5589STATUSEC Property

STATUS: EC

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STATUSEC { get; }
Public ReadOnly Property STATUSEC As Byte
    Get
public:
property unsigned char STATUSEC {
    unsigned char get ();
}
member STATUSEC : byte with get

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.STATUSLOCKSTAT Property

IRD

Adp5589STATUSLOCKSTAT Property

STATUS: LOCK_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeStatusLockStat STATUSLOCKSTAT { get; }
Public ReadOnly Property STATUSLOCKSTAT As Adp5589TypeStatusLockStat
    Get
public:
property Adp5589TypeStatusLockStat STATUSLOCKSTAT {
    Adp5589TypeStatusLockStat get ();
}
member STATUSLOCKSTAT : Adp5589TypeStatusLockStat with get

Property Value

Type: Adp5589TypeStatusLockStat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.STATUSLOGIC1STAT Property

IRD

Adp5589STATUSLOGIC1STAT Property

STATUS: LOGIC1_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeStatusLogic1Stat STATUSLOGIC1STAT { get; }
Public ReadOnly Property STATUSLOGIC1STAT As Adp5589TypeStatusLogic1Stat
    Get
public:
property Adp5589TypeStatusLogic1Stat STATUSLOGIC1STAT {
    Adp5589TypeStatusLogic1Stat get ();
}
member STATUSLOGIC1STAT : Adp5589TypeStatusLogic1Stat with get

Property Value

Type: Adp5589TypeStatusLogic1Stat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.STATUSLOGIC2STAT Property

IRD

Adp5589STATUSLOGIC2STAT Property

STATUS: LOGIC2_STAT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeStatusLogic2Stat STATUSLOGIC2STAT { get; }
Public ReadOnly Property STATUSLOGIC2STAT As Adp5589TypeStatusLogic2Stat
    Get
public:
property Adp5589TypeStatusLogic2Stat STATUSLOGIC2STAT {
    Adp5589TypeStatusLogic2Stat get ();
}
member STATUSLOGIC2STAT : Adp5589TypeStatusLogic2Stat with get

Property Value

Type: Adp5589TypeStatusLogic2Stat
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.UNLOCK1UNLOCK1 Property

IRD

Adp5589UNLOCK1UNLOCK1 Property

UNLOCK1: UNLOCK1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte UNLOCK1UNLOCK1 { get; set; }
Public Property UNLOCK1UNLOCK1 As Byte
    Get
    Set
public:
property unsigned char UNLOCK1UNLOCK1 {
    unsigned char get ();
    void set (unsigned char value);
}
member UNLOCK1UNLOCK1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.UNLOCK1UNLOCK1STATE Property

IRD

Adp5589UNLOCK1UNLOCK1STATE Property

UNLOCK1: UNLOCK1_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte UNLOCK1UNLOCK1STATE { get; set; }
Public Property UNLOCK1UNLOCK1STATE As Byte
    Get
    Set
public:
property unsigned char UNLOCK1UNLOCK1STATE {
    unsigned char get ();
    void set (unsigned char value);
}
member UNLOCK1UNLOCK1STATE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.UNLOCK2UNLOCK2 Property

IRD

Adp5589UNLOCK2UNLOCK2 Property

UNLOCK2: UNLOCK2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte UNLOCK2UNLOCK2 { get; set; }
Public Property UNLOCK2UNLOCK2 As Byte
    Get
    Set
public:
property unsigned char UNLOCK2UNLOCK2 {
    unsigned char get ();
    void set (unsigned char value);
}
member UNLOCK2UNLOCK2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.UNLOCK2UNLOCK2STATE Property

IRD

Adp5589UNLOCK2UNLOCK2STATE Property

UNLOCK2: UNLOCK2_STATE

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte UNLOCK2UNLOCK2STATE { get; set; }
Public Property UNLOCK2UNLOCK2STATE As Byte
    Get
    Set
public:
property unsigned char UNLOCK2UNLOCK2STATE {
    unsigned char get ();
    void set (unsigned char value);
}
member UNLOCK2UNLOCK2STATE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.UNLOCKTIMERSINTMASKTIMER Property

IRD

Adp5589UNLOCKTIMERSINTMASKTIMER Property

UNLOCK_TIMERS: INT_MASK_TIMER (unit: s)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeUnlockTimersIntMaskTimer UNLOCKTIMERSINTMASKTIMER { get; set; }
Public Property UNLOCKTIMERSINTMASKTIMER As Adp5589TypeUnlockTimersIntMaskTimer
    Get
    Set
public:
property Adp5589TypeUnlockTimersIntMaskTimer UNLOCKTIMERSINTMASKTIMER {
    Adp5589TypeUnlockTimersIntMaskTimer get ();
    void set (Adp5589TypeUnlockTimersIntMaskTimer value);
}
member UNLOCKTIMERSINTMASKTIMER : Adp5589TypeUnlockTimersIntMaskTimer with get, set

Property Value

Type: Adp5589TypeUnlockTimersIntMaskTimer
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.UNLOCKTIMERSUNLOCKTIMER Property

IRD

Adp5589UNLOCKTIMERSUNLOCKTIMER Property

UNLOCK_TIMERS: UNLOCK_TIMER (unit: s)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp5589TypeUnlockTimersUnlockTimer UNLOCKTIMERSUNLOCKTIMER { get; set; }
Public Property UNLOCKTIMERSUNLOCKTIMER As Adp5589TypeUnlockTimersUnlockTimer
    Get
    Set
public:
property Adp5589TypeUnlockTimersUnlockTimer UNLOCKTIMERSUNLOCKTIMER {
    Adp5589TypeUnlockTimersUnlockTimer get ();
    void set (Adp5589TypeUnlockTimersUnlockTimer value);
}
member UNLOCKTIMERSUNLOCKTIMER : Adp5589TypeUnlockTimersUnlockTimer with get, set

Property Value

Type: Adp5589TypeUnlockTimersUnlockTimer
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589 Methods

The Adp5589 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.Flush Method

IRD

Adp5589Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adp5589 Class
telos.Ird.AnalogDevices Namespace


Adp5589.TypeClockDivCfgClkDivEn Enumeration

IRD

Adp5589TypeClockDivCfgClkDivEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockDivCfgClkDivEn
Public Enumeration TypeClockDivCfgClkDivEn
public enum class TypeClockDivCfgClkDivEn
type TypeClockDivCfgClkDivEn
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeClockDivCfgClkInv Enumeration

IRD

Adp5589TypeClockDivCfgClkInv Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockDivCfgClkInv
Public Enumeration TypeClockDivCfgClkInv
public enum class TypeClockDivCfgClkInv
type TypeClockDivCfgClkInv
Members
Member name | Value | Description
NotInverted | 0 | Not Inverted
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeDebounceDis Enumeration

IRD

Adp5589TypeDebounceDis Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDebounceDis
Public Enumeration TypeDebounceDis
public enum class TypeDebounceDis
type TypeDebounceDis
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeFifoEventIdentifier Enumeration

IRD

Adp5589TypeFifoEventIdentifier Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFifoEventIdentifier
Public Enumeration TypeFifoEventIdentifier
public enum class TypeFifoEventIdentifier
type TypeFifoEventIdentifier
Members
Member name | Value | Description
NoEvent | 0 | No Event
Key1R0C0 | 1 | Key 1 (R0, C0)
Key2R0C1 | 2 | Key 2 (R0, C1)
Key3R0C2 | 3 | Key 3 (R0, C2)
Key4R0C3 | 4 | Key 4 (R0, C3)
Key5R0C4 | 5 | Key 5 (R0, C4)
Key6R0C5 | 6 | Key 6 (R0, C5)
Key7R0C6 | 7 | Key 7 (R0, C6)
Key8R0C7 | 8 | Key 8 (R0, C7)
Key9R0C8 | 9 | Key 9 (R0, C8)
Key10R0C9 | 10 | Key 10 (R0, C9)
Key11R0C10 | 11 | Key 11 (R0, C10)
Key12R1C0 | 12 | Key 12 (R1, C0)
Key13R1C1 | 13 | Key 13 (R1, C1)
Key14R1C2 | 14 | Key 14 (R1, C2)
Key15R1C3 | 15 | Key 15 (R1, C3)
Key16R1C4 | 16 | Key 16 (R1, C4)
Key17R1C5 | 17 | Key 17 (R1, C5)
Key18R1C6 | 18 | Key 18 (R1, C6)
Key19R1C7 | 19 | Key 19 (R1, C7)
Key20R1C8 | 20 | Key 20 (R1, C8)
Key21R1C9 | 21 | Key 21 (R1, C9)
Key22R1C10 | 22 | Key 22 (R1, C10)
Key23R2C0 | 23 | Key 23 (R2, C0)
Key24R2C1 | 24 | Key 24 (R2, C1)
Key25R2C2 | 25 | Key 25 (R2, C2)
Key26R2C3 | 26 | Key 26 (R2, C3)
Key27R2C4 | 27 | Key 27 (R2, C4)
Key28R2C5 | 28 | Key 28 (R2, C5)
Key29R2C6 | 29 | Key 29 (R2, C6)
Key30R2C7 | 30 | Key 30 (R2, C7)
Key31R2C8 | 31 | Key 31 (R2, C8)
Key32R2C9 | 32 | Key 32 (R2, C9)
Key33R2C10 | 33 | Key 33 (R2, C10)
Key34R3C0 | 34 | Key 34 (R3, C0)
Key35R3C1 | 35 | Key 35 (R3, C1)
Key36R3C2 | 36 | Key 36 (R3, C2)
Key37R3C3 | 37 | Key 37 (R3, C3)
Key38R3C4 | 38 | Key 38 (R3, C4)
Key39R3C5 | 39 | Key 39 (R3, C5)
Key40R3C6 | 40 | Key 40 (R3, C6)
Key41R3C7 | 41 | Key 41 (R3, C7)
Key42R3C8 | 42 | Key 42 (R3, C8)
Key43R3C9 | 43 | Key 43 (R3, C9)
Key44R3C10 | 44 | Key 44 (R3, C10)
Key45R4C0 | 45 | Key 45 (R4, C0)
Key46R4C1 | 46 | Key 46 (R4, C1)
Key47R4C2 | 47 | Key 47 (R4, C2)
Key48R4C3 | 48 | Key 48 (R4, C3)
Key49R4C4 | 49 | Key 49 (R4, C4)
Key50R4C5 | 50 | Key 50 (R4, C5)
Key51R4C6 | 51 | Key 51 (R4, C6)
Key52R4C7 | 52 | Key 52 (R4, C7)
Key53R4C8 | 53 | Key 53 (R4, C8)
Key54R4C9 | 54 | Key 54 (R4, C9)
Key55R4C10 | 55 | Key 55 (R4, C10)
Key56R5C0 | 56 | Key 56 (R5, C0)
Key57R5C1 | 57 | Key 57 (R5, C1)
Key58R5C2 | 58 | Key 58 (R5, C2)
Key59R5C3 | 59 | Key 59 (R5, C3)
Key60R5C4 | 60 | Key 60 (R5, C4)
Key61R5C5 | 61 | Key 61 (R5, C5)
Key62R5C6 | 62 | Key 62 (R5, C6)
Key63R5C7 | 63 | Key 63 (R5, C7)
Key64R5C8 | 64 | Key 64 (R5, C8)
Key65R5C9 | 65 | Key 65 (R5, C9)
Key66R5C10 | 66 | Key 66 (R5, C10)
Key67R6C0 | 67 | Key 67 (R6, C0)
Key68R6C1 | 68 | Key 68 (R6, C1)
Key69R6C2 | 69 | Key 69 (R6, C2)
Key70R6C3 | 70 | Key 70 (R6, C3)
Key71R6C4 | 71 | Key 71 (R6, C4)
Key72R6C5 | 72 | Key 72 (R6, C5)
Key73R6C6 | 73 | Key 73 (R6, C6)
Key74R6C7 | 74 | Key 74 (R6, C7)
Key75R6C8 | 75 | Key 75 (R6, C8)
Key76R6C9 | 76 | Key 76 (R6, C9)
Key77R6C10 | 77 | Key 77 (R6, C10)
Key78R7C0 | 78 | Key 78 (R7, C0)
Key79R7C1 | 79 | Key 79 (R7, C1)
Key80R7C2 | 80 | Key 80 (R7, C2)
Key81R7C3 | 81 | Key 81 (R7, C3)
Key82R7C4 | 82 | Key 82 (R7, C4)
Key83R7C5 | 83 | Key 83 (R7, C5)
Key84R7C6 | 84 | Key 84 (R7, C6)
Key85R7C7 | 85 | Key 85 (R7, C7)
Key86R7C8 | 86 | Key 86 (R7, C8)
Key87R7C9 | 87 | Key 87 (R7, C9)
Key88R7C10 | 88 | Key 88 (R7, C10)
Key89R0GND | 89 | Key 89 (R0, GND)
Key90R1GND | 90 | Key 90 (R1, GND)
Key91R2GND | 91 | Key 91 (R2, GND)
Key92R3GND | 92 | Key 92 (R3, GND)
Key93R4GND | 93 | Key 93 (R4, GND)
Key94R5GND | 94 | Key 94 (R5, GND)
Key95R6GND | 95 | Key 95 (R6, GND)
Key96R7GND | 96 | Key 96 (R7, GND)
GPI1R0 | 97 | GPI 1 (R0)
GPI2R1 | 98 | GPI 2 (R1)
GPI3R2 | 99 | GPI 3 (R2)
GPI4R3 | 100 | GPI 4 (R3)
GPI5R4 | 101 | GPI 5 (R4)
GPI6R5 | 102 | GPI 6 (R5)
GPI7R6 | 103 | GPI 7 (R6)
GPI8R7 | 104 | GPI 8 (R7)
GPI9C0 | 105 | GPI 9 (C0)
GPI10C1 | 106 | GPI 10 (C1)
GPI11C2 | 107 | GPI 11 (C2)
GPI12C3 | 108 | GPI 12 (C3)
GPI13C4 | 109 | GPI 13 (C4)
GPI14C5 | 110 | GPI 14 (C5)
GPI15C6 | 111 | GPI 15 (C6)
GPI16C7 | 112 | GPI 16 (C7)
GPI17C8 | 113 | GPI 17 (C8)
GPI18C9 | 114 | GPI 18 (C9)
GPI19C10 | 115 | GPI 19 (C10)
Logic1 | 116 | Logic 1
Logic2 | 117 | Logic 2
WildcardForUnlock | 127 | Wildcard For Unlock
Unused | 118 | Unused
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeGeneralCfgBCoreFreq Enumeration

IRD

Adp5589TypeGeneralCfgBCoreFreq Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralCfgBCoreFreq
Public Enumeration TypeGeneralCfgBCoreFreq
public enum class TypeGeneralCfgBCoreFreq
type TypeGeneralCfgBCoreFreq
Members
Member name | Value | Description
Value_50KHz | 0 | 50 kHz
Value_100KHz | 1 | 100 kHz
Value_200KHz | 2 | 200 kHz
Value_500KHz | 3 | 500 kHz
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeGeneralCfgBIntCfg Enumeration

IRD

Adp5589TypeGeneralCfgBIntCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralCfgBIntCfg
Public Enumeration TypeGeneralCfgBIntCfg
public enum class TypeGeneralCfgBIntCfg
type TypeGeneralCfgBIntCfg
Members
Member name | Value | Description
INTPinRemainsAsserted | 0 | INT Pin: Remains Asserted
INTPinDeassertedFor50Us | 1 | INT Pin: Deasserted for 50 µs
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeGeneralCfgBLckTrkGpi Enumeration

IRD

Adp5589TypeGeneralCfgBLckTrkGpi Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralCfgBLckTrkGpi
Public Enumeration TypeGeneralCfgBLckTrkGpi
public enum class TypeGeneralCfgBLckTrkGpi
type TypeGeneralCfgBLckTrkGpi
Members
Member name | Value | Description
GPIsTracked | 0 | GPIs: Tracked
GPIsNotTracked | 1 | GPIs: Not Tracked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeGeneralCfgBLckTrkLogic Enumeration

IRD

Adp5589TypeGeneralCfgBLckTrkLogic Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralCfgBLckTrkLogic
Public Enumeration TypeGeneralCfgBLckTrkLogic
public enum class TypeGeneralCfgBLckTrkLogic
type TypeGeneralCfgBLckTrkLogic
Members
Member name | Value | Description
LogicOutputsTracked | 0 | Logic Outputs: Tracked
LogicOutputsNotTracked | 1 | Logic Outputs: Not Tracked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeGeneralCfgBOscEn Enumeration

IRD

Adp5589TypeGeneralCfgBOscEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralCfgBOscEn
Public Enumeration TypeGeneralCfgBOscEn
public enum class TypeGeneralCfgBOscEn
type TypeGeneralCfgBOscEn
Members
Member name | Value | Description
Value_1MHzOscillatorDisabled | 0 | 1 MHz Oscillator: Disabled
Value_1MHzOscillatorEnabled | 1 | 1 MHz Oscillator: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeGeneralCfgBRstCfg Enumeration

IRD

Adp5589TypeGeneralCfgBRstCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralCfgBRstCfg
Public Enumeration TypeGeneralCfgBRstCfg
public enum class TypeGeneralCfgBRstCfg
type TypeGeneralCfgBRstCfg
Members
Member name | Value | Description
RSTLowADP5589Resets | 0 | RST Low: ADP5589 Resets
RSTLowADP5589DoesNotReset | 1 | RST Low: ADP5589 Does Not Reset
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeGpiEventEn Enumeration

IRD

Adp5589TypeGpiEventEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpiEventEn
Public Enumeration TypeGpiEventEn
public enum class TypeGpiEventEn
type TypeGpiEventEn
Members
Member name | Value | Description
GPIEventsDisabled | 0 | GPI Events: Disabled
GPIEventsEnabled | 1 | GPI Events: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeGpiInterruptEn Enumeration

IRD

Adp5589TypeGpiInterruptEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpiInterruptEn
Public Enumeration TypeGpiInterruptEn
public enum class TypeGpiInterruptEn
type TypeGpiInterruptEn
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeGpiIntLevel Enumeration

IRD

Adp5589TypeGpiIntLevel Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpiIntLevel
Public Enumeration TypeGpiIntLevel
public enum class TypeGpiIntLevel
type TypeGpiIntLevel
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeGpiIntStat Enumeration

IRD

Adp5589TypeGpiIntStat Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpiIntStat
Public Enumeration TypeGpiIntStat
public enum class TypeGpiIntStat
type TypeGpiIntStat
Members
Member name | Value | Description
NoInterrupt | 0 | No Interrupt
Interrupt | 1 | Interrupt
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeGpioDirection Enumeration

IRD

Adp5589TypeGpioDirection Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioDirection
Public Enumeration TypeGpioDirection
public enum class TypeGpioDirection
type TypeGpioDirection
Members
Member name | Value | Description
Input | 0 | Input
Output | 1 | Output
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeGpiStatus Enumeration

IRD

Adp5589TypeGpiStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpiStatus
Public Enumeration TypeGpiStatus
public enum class TypeGpiStatus
type TypeGpiStatus
Members
Member name | Value | Description
Low | 0 | Low
High | 1 | High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeGpoDataOut Enumeration

IRD

Adp5589TypeGpoDataOut Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpoDataOut
Public Enumeration TypeGpoDataOut
public enum class TypeGpoDataOut
type TypeGpoDataOut
Members
Member name | Value | Description
Low | 0 | Low
High | 1 | High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeGpoOutMode Enumeration

IRD

Adp5589TypeGpoOutMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpoOutMode
Public Enumeration TypeGpoOutMode
public enum class TypeGpoOutMode
type TypeGpoOutMode
Members
Member name | Value | Description
PushPull | 0 | Push/Pull
OpenDrain | 1 | Open Drain
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeIntEn Enumeration

IRD

Adp5589TypeIntEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEn
Public Enumeration TypeIntEn
public enum class TypeIntEn
type TypeIntEn
Members
Member name | Value | Description
InterruptDisabled | 0 | Interrupt: Disabled
InterruptEnabled | 1 | Interrupt: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeIntStatus Enumeration

IRD

Adp5589TypeIntStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntStatus
Public Enumeration TypeIntStatus
public enum class TypeIntStatus
type TypeIntStatus
Members
Member name | Value | Description
NoInterrupt | 0 | No interrupt
Interrupt | 1 | Interrupt
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeLockCfgLockEn Enumeration

IRD

Adp5589TypeLockCfgLockEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLockCfgLockEn
Public Enumeration TypeLockCfgLockEn
public enum class TypeLockCfgLockEn
type TypeLockCfgLockEn
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeLogic1CfgLogic1Sel Enumeration

IRD

Adp5589TypeLogic1CfgLogic1Sel Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLogic1CfgLogic1Sel
Public Enumeration TypeLogic1CfgLogic1Sel
public enum class TypeLogic1CfgLogic1Sel
type TypeLogic1CfgLogic1Sel
Members
Member name | Value | Description
OffDisabled | 0 | Off/Disabled
AND1 | 1 | AND1
OR1 | 2 | OR1
XOR1 | 3 | XOR1
FF1 | 4 | FF1
INLA1 | 5 | IN_LA1
INLB1 | 6 | IN_LB1
INLC1 | 7 | IN_LC1
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeLogic2CfgLogic2Sel Enumeration

IRD

Adp5589TypeLogic2CfgLogic2Sel Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLogic2CfgLogic2Sel
Public Enumeration TypeLogic2CfgLogic2Sel
public enum class TypeLogic2CfgLogic2Sel
type TypeLogic2CfgLogic2Sel
Members
Member name | Value | Description
OffDisable | 0 | Off/Disable
AND2 | 1 | AND2
OR2 | 2 | OR2
XOR2 | 3 | XOR2
FF2 | 4 | FF2
INLA2 | 5 | IN_LA2
INLB2 | 6 | IN_LB2
INLC2 | 7 | IN_LC2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeLogic2CfgLy1Cascade Enumeration

IRD

Adp5589TypeLogic2CfgLy1Cascade Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLogic2CfgLy1Cascade
Public Enumeration TypeLogic2CfgLy1Cascade
public enum class TypeLogic2CfgLy1Cascade
type TypeLogic2CfgLy1Cascade
Members
Member name | Value | Description
InputLA2 | 0 | Input LA2
OutputLY1 | 1 | Output LY1
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeLogicCfgInv Enumeration

IRD

Adp5589TypeLogicCfgInv Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLogicCfgInv
Public Enumeration TypeLogicCfgInv
public enum class TypeLogicCfgInv
type TypeLogicCfgInv
Members
Member name | Value | Description
NotInverted | 0 | Not Inverted
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeLogicFfCfgClr Enumeration

IRD

Adp5589TypeLogicFfCfgClr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLogicFfCfgClr
Public Enumeration TypeLogicFfCfgClr
public enum class TypeLogicFfCfgClr
type TypeLogicFfCfgClr
Members
Member name | Value | Description
NotCleared | 0 | Not Cleared
Cleared | 1 | Cleared
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeLogicFfCfgSet Enumeration

IRD

Adp5589TypeLogicFfCfgSet Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLogicFfCfgSet
Public Enumeration TypeLogicFfCfgSet
public enum class TypeLogicFfCfgSet
type TypeLogicFfCfgSet
Members
Member name | Value | Description
NotSet | 0 | Not Set
Set | 1 | Set
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeLogicIntEventEnLogicEventEn Enumeration

IRD

Adp5589TypeLogicIntEventEnLogicEventEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLogicIntEventEnLogicEventEn
Public Enumeration TypeLogicIntEventEnLogicEventEn
public enum class TypeLogicIntEventEnLogicEventEn
type TypeLogicIntEventEnLogicEventEn
Members
Member name | Value | Description
InterruptNotGenerated | 0 | Interrupt: Not Generated
InterruptGenerated | 1 | Interrupt: Generated
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeLogicIntEventEnLogicIntLevel Enumeration

IRD

Adp5589TypeLogicIntEventEnLogicIntLevel Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLogicIntEventEnLogicIntLevel
Public Enumeration TypeLogicIntEventEnLogicIntLevel
public enum class TypeLogicIntEventEnLogicIntLevel
type TypeLogicIntEventEnLogicIntLevel
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeLogicIntEventEnLyDbncDis Enumeration

IRD

Adp5589TypeLogicIntEventEnLyDbncDis Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLogicIntEventEnLyDbncDis
Public Enumeration TypeLogicIntEventEnLyDbncDis
public enum class TypeLogicIntEventEnLyDbncDis
type TypeLogicIntEventEnLyDbncDis
Members
Member name | Value | Description
Debounced | 0 | Debounced
NotDebounced | 1 | Not Debounced
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigAR0Config Enumeration

IRD

Adp5589TypePinConfigAR0Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigAR0Config
Public Enumeration TypePinConfigAR0Config
public enum class TypePinConfigAR0Config
type TypePinConfigAR0Config
Members
Member name | Value | Description
GPIO1 | 0 | GPIO 1
Row0 | 1 | Row 0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigAR1Config Enumeration

IRD

Adp5589TypePinConfigAR1Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigAR1Config
Public Enumeration TypePinConfigAR1Config
public enum class TypePinConfigAR1Config
type TypePinConfigAR1Config
Members
Member name | Value | Description
GPIO2 | 0 | GPIO 2
Row1 | 1 | Row 1
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigAR2Config Enumeration

IRD

Adp5589TypePinConfigAR2Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigAR2Config
Public Enumeration TypePinConfigAR2Config
public enum class TypePinConfigAR2Config
type TypePinConfigAR2Config
Members
Member name | Value | Description
GPIO3 | 0 | GPIO 3
Row2 | 1 | Row 2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigAR3Config Enumeration

IRD

Adp5589TypePinConfigAR3Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigAR3Config
Public Enumeration TypePinConfigAR3Config
public enum class TypePinConfigAR3Config
type TypePinConfigAR3Config
Members
Member name | Value | Description
GPIO4 | 0 | GPIO 4
Row3 | 1 | Row 3
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigAR4Config Enumeration

IRD

Adp5589TypePinConfigAR4Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigAR4Config
Public Enumeration TypePinConfigAR4Config
public enum class TypePinConfigAR4Config
type TypePinConfigAR4Config
Members
Member name | Value | Description
GPIO5 | 0 | GPIO 5
Row4 | 1 | Row 4
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigAR5Config Enumeration

IRD

Adp5589TypePinConfigAR5Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigAR5Config
Public Enumeration TypePinConfigAR5Config
public enum class TypePinConfigAR5Config
type TypePinConfigAR5Config
Members
Member name | Value | Description
GPIO6 | 0 | GPIO 6
Row5 | 1 | Row 5
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigAR6Config Enumeration

IRD

Adp5589TypePinConfigAR6Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigAR6Config
Public Enumeration TypePinConfigAR6Config
public enum class TypePinConfigAR6Config
type TypePinConfigAR6Config
Members
Member name | Value | Description
GPIO7 | 0 | GPIO 7
Row6 | 1 | Row 6
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigAR7Config Enumeration

IRD

Adp5589TypePinConfigAR7Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigAR7Config
Public Enumeration TypePinConfigAR7Config
public enum class TypePinConfigAR7Config
type TypePinConfigAR7Config
Members
Member name | Value | Description
GPIO8 | 0 | GPIO 8
Row7 | 1 | Row 7
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigBC0Config Enumeration

IRD

Adp5589TypePinConfigBC0Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigBC0Config
Public Enumeration TypePinConfigBC0Config
public enum class TypePinConfigBC0Config
type TypePinConfigBC0Config
Members
Member name | Value | Description
GPIO9 | 0 | GPIO 9
Column0 | 1 | Column 0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigBC1Config Enumeration

IRD

Adp5589TypePinConfigBC1Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigBC1Config
Public Enumeration TypePinConfigBC1Config
public enum class TypePinConfigBC1Config
type TypePinConfigBC1Config
Members
Member name | Value | Description
GPIO10 | 0 | GPIO 10
Column1 | 1 | Column 1
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigBC2Config Enumeration

IRD

Adp5589TypePinConfigBC2Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigBC2Config
Public Enumeration TypePinConfigBC2Config
public enum class TypePinConfigBC2Config
type TypePinConfigBC2Config
Members
Member name | Value | Description
GPIO11 | 0 | GPIO 11
Column2 | 1 | Column 2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigBC3Config Enumeration

IRD

Adp5589TypePinConfigBC3Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigBC3Config
Public Enumeration TypePinConfigBC3Config
public enum class TypePinConfigBC3Config
type TypePinConfigBC3Config
Members
Member name | Value | Description
GPIO12 | 0 | GPIO 12
Column3 | 1 | Column 3
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigBC4Config Enumeration

IRD

Adp5589TypePinConfigBC4Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigBC4Config
Public Enumeration TypePinConfigBC4Config
public enum class TypePinConfigBC4Config
type TypePinConfigBC4Config
Members
Member name | Value | Description
GPIO13 | 0 | GPIO 13
Column4 | 1 | Column 4
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigBC5Config Enumeration

IRD

Adp5589TypePinConfigBC5Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigBC5Config
Public Enumeration TypePinConfigBC5Config
public enum class TypePinConfigBC5Config
type TypePinConfigBC5Config
Members
Member name | Value | Description
GPIO14 | 0 | GPIO 14
Column5 | 1 | Column 5
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigBC6Config Enumeration

IRD

Adp5589TypePinConfigBC6Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigBC6Config
Public Enumeration TypePinConfigBC6Config
public enum class TypePinConfigBC6Config
type TypePinConfigBC6Config
Members
Member name | Value | Description
GPIO15 | 0 | GPIO 15
Column6 | 1 | Column 6
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigBC7Config Enumeration

IRD

Adp5589TypePinConfigBC7Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigBC7Config
Public Enumeration TypePinConfigBC7Config
public enum class TypePinConfigBC7Config
type TypePinConfigBC7Config
Members
Member name | Value | Description
GPIO16 | 0 | GPIO 16
Column7 | 1 | Column 7
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigCC10Config Enumeration

IRD

Adp5589TypePinConfigCC10Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigCC10Config
Public Enumeration TypePinConfigCC10Config
public enum class TypePinConfigCC10Config
type TypePinConfigCC10Config
Members
Member name | Value | Description
GPIO19 | 0 | GPIO 19
Column10 | 1 | Column 10
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigCC8Config Enumeration

IRD

Adp5589TypePinConfigCC8Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigCC8Config
Public Enumeration TypePinConfigCC8Config
public enum class TypePinConfigCC8Config
type TypePinConfigCC8Config
Members
Member name | Value | Description
GPIO17 | 0 | GPIO 17
Column8 | 1 | Column 8
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigCC9Config Enumeration

IRD

Adp5589TypePinConfigCC9Config Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigCC9Config
Public Enumeration TypePinConfigCC9Config
public enum class TypePinConfigCC9Config
type TypePinConfigCC9Config
Members
Member name | Value | Description
GPIO18 | 0 | GPIO 18
Column9 | 1 | Column 9
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigDC4ExtendCfg Enumeration

IRD

Adp5589TypePinConfigDC4ExtendCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigDC4ExtendCfg
Public Enumeration TypePinConfigDC4ExtendCfg
public enum class TypePinConfigDC4ExtendCfg
type TypePinConfigDC4ExtendCfg
Members
Member name | Value | Description
C4GPIO13 | 0 | C4: GPIO 13
C4RESET2 | 1 | C4: RESET2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigDC6ExtendCfg Enumeration

IRD

Adp5589TypePinConfigDC6ExtendCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigDC6ExtendCfg
Public Enumeration TypePinConfigDC6ExtendCfg
public enum class TypePinConfigDC6ExtendCfg
type TypePinConfigDC6ExtendCfg
Members
Member name | Value | Description
C6GPIO15 | 0 | C6: GPIO 15
C6LC2 | 1 | C6: LC2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigDC9ExtendCfg Enumeration

IRD

Adp5589TypePinConfigDC9ExtendCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigDC9ExtendCfg
Public Enumeration TypePinConfigDC9ExtendCfg
public enum class TypePinConfigDC9ExtendCfg
type TypePinConfigDC9ExtendCfg
Members
Member name | Value | Description
C9GPIO18 | 0 | C9: GPIO 18
C9LY2 | 1 | C9: LY2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigDPullSelect Enumeration

IRD

Adp5589TypePinConfigDPullSelect Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigDPullSelect
Public Enumeration TypePinConfigDPullSelect
public enum class TypePinConfigDPullSelect
type TypePinConfigDPullSelect
Members
Member name | Value | Description
Value_300KΩ | 0 | 300 kΩ
Value_100KΩ | 1 | 100 kΩ
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigDR0ExtendCfg Enumeration

IRD

Adp5589TypePinConfigDR0ExtendCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigDR0ExtendCfg
Public Enumeration TypePinConfigDR0ExtendCfg
public enum class TypePinConfigDR0ExtendCfg
type TypePinConfigDR0ExtendCfg
Members
Member name | Value | Description
R0GPIO1 | 0 | R0: GPIO 1
R0LY1 | 1 | R0: LY1
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigDR3ExtendCfg Enumeration

IRD

Adp5589TypePinConfigDR3ExtendCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigDR3ExtendCfg
Public Enumeration TypePinConfigDR3ExtendCfg
public enum class TypePinConfigDR3ExtendCfg
type TypePinConfigDR3ExtendCfg
Members
Member name | Value | Description
R3GPIO4 | 0 | R3: GPIO 4
R3LC1 | 1 | R3: LC1
R3PWMOUTCLKOUT | 2 | R3: PWM_OUT/CLK_OUT
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePinConfigDR4ExtendCfg Enumeration

IRD

Adp5589TypePinConfigDR4ExtendCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePinConfigDR4ExtendCfg
Public Enumeration TypePinConfigDR4ExtendCfg
public enum class TypePinConfigDR4ExtendCfg
type TypePinConfigDR4ExtendCfg
Members
Member name | Value | Description
R4GPIO5 | 0 | R4: GPIO 5
R4RESET1 | 1 | R4: RESET1
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePollTimeCfgKeyPollTime Enumeration

IRD

Adp5589TypePollTimeCfgKeyPollTime Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePollTimeCfgKeyPollTime
Public Enumeration TypePollTimeCfgKeyPollTime
public enum class TypePollTimeCfgKeyPollTime
type TypePollTimeCfgKeyPollTime
Members
Member name | Value | Description
Value_10 | 0 | 10
Value_20 | 1 | 20
Value_30 | 2 | 30
Value_40 | 3 | 40
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePwmCfgPwmEn Enumeration

IRD

Adp5589TypePwmCfgPwmEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePwmCfgPwmEn
Public Enumeration TypePwmCfgPwmEn
public enum class TypePwmCfgPwmEn
type TypePwmCfgPwmEn
Members
Member name | Value | Description
PWMDisabled | 0 | PWM: Disabled
PWMEnabled | 1 | PWM: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePwmCfgPwmInAnd Enumeration

IRD

Adp5589TypePwmCfgPwmInAnd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePwmCfgPwmInAnd
Public Enumeration TypePwmCfgPwmInAnd
public enum class TypePwmCfgPwmInAnd
type TypePwmCfgPwmInAnd
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypePwmCfgPwmMode Enumeration

IRD

Adp5589TypePwmCfgPwmMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePwmCfgPwmMode
Public Enumeration TypePwmCfgPwmMode
public enum class TypePwmCfgPwmMode
type TypePwmCfgPwmMode
Members
Member name | Value | Description
Continuous | 0 | Continuous
OneShot | 1 | One Shot
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeResetCfgResetPol Enumeration

IRD

Adp5589TypeResetCfgResetPol Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeResetCfgResetPol
Public Enumeration TypeResetCfgResetPol
public enum class TypeResetCfgResetPol
type TypeResetCfgResetPol
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeResetCfgResetPulseWidth Enumeration

IRD

Adp5589TypeResetCfgResetPulseWidth Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeResetCfgResetPulseWidth
Public Enumeration TypeResetCfgResetPulseWidth
public enum class TypeResetCfgResetPulseWidth
type TypeResetCfgResetPulseWidth
Members
Member name | Value | Description
Value_500Us | 0 | 500 µs
Value_1Ms | 1 | 1 ms
Value_2Ms | 2 | 2 ms
Value_10Ms | 3 | 10 ms
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeResetCfgResetTriggerTimer Enumeration

IRD

Adp5589TypeResetCfgResetTriggerTimer Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeResetCfgResetTriggerTimer
Public Enumeration TypeResetCfgResetTriggerTimer
public enum class TypeResetCfgResetTriggerTimer
type TypeResetCfgResetTriggerTimer
Members
Member name | Value | Description
Immediate | 0 | Immediate
Value_1_0 | 1 | 1.0
Value_1_5 | 2 | 1.5
Value_2_0 | 3 | 2.0
Value_2_5 | 4 | 2.5
Value_3_0 | 5 | 3.0
Value_3_5 | 6 | 3.5
Value_4_0 | 7 | 4.0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeResetCfgRstPassthruEn Enumeration

IRD

Adp5589TypeResetCfgRstPassthruEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeResetCfgRstPassthruEn
Public Enumeration TypeResetCfgRstPassthruEn
public enum class TypeResetCfgRstPassthruEn
type TypeResetCfgRstPassthruEn
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeRpullConfig Enumeration

IRD

Adp5589TypeRpullConfig Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRpullConfig
Public Enumeration TypeRpullConfig
public enum class TypeRpullConfig
type TypeRpullConfig
Members
Member name | Value | Description
Value_300KΩPullUp | 0 | 300 kΩ Pull-Up
Value_300KΩPullDown | 1 | 300 kΩ Pull-Down
Value_100KΩPullUp | 2 | 100 kΩ Pull-Up
Disabled | 3 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeStatusLockStat Enumeration

IRD

Adp5589TypeStatusLockStat Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusLockStat
Public Enumeration TypeStatusLockStat
public enum class TypeStatusLockStat
type TypeStatusLockStat
Members
Member name | Value | Description
Unlocked | 0 | Unlocked
Locked | 1 | Locked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeStatusLogic1Stat Enumeration

IRD

Adp5589TypeStatusLogic1Stat Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusLogic1Stat
Public Enumeration TypeStatusLogic1Stat
public enum class TypeStatusLogic1Stat
type TypeStatusLogic1Stat
Members
Member name | Value | Description
OutputLogicBlock1Low | 0 | Output Logic Block 1: Low
OutputLogicBlock1High | 1 | Output Logic Block 1: High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeStatusLogic2Stat Enumeration

IRD

Adp5589TypeStatusLogic2Stat Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusLogic2Stat
Public Enumeration TypeStatusLogic2Stat
public enum class TypeStatusLogic2Stat
type TypeStatusLogic2Stat
Members
Member name | Value | Description
OutputLogicBlock2Low | 0 | Output Logic Block 2: Low
OutputLogicBlock2High | 1 | Output Logic Block 2: High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeUnlockTimersIntMaskTimer Enumeration

IRD

Adp5589TypeUnlockTimersIntMaskTimer Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeUnlockTimersIntMaskTimer
Public Enumeration TypeUnlockTimersIntMaskTimer
public enum class TypeUnlockTimersIntMaskTimer
type TypeUnlockTimersIntMaskTimer
Members
Member name | Value | Description
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp5589.TypeUnlockTimersUnlockTimer Enumeration

IRD

Adp5589TypeUnlockTimersUnlockTimer Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeUnlockTimersUnlockTimer
Public Enumeration TypeUnlockTimersUnlockTimer
public enum class TypeUnlockTimersUnlockTimer
type TypeUnlockTimersUnlockTimer
Members
Member name | Value | Description
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870 Class

Analog Devices: ADP 8870
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdp8870

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adp8870
Public Class Adp8870
public ref class Adp8870
type Adp8870 =  class end

The Adp8870 type exposes the following members.

Constructors
 | Name | Description
Public method | Adp8870 | Constructor
Top
Properties
 | Name | Description
Public property | ALSComparatorControlFILT | ALS Comparator Control: FILT
Public property | ALSComparatorControlFILT2 | ALS Comparator Control: FILT2
Public property | ALSComparatorControlFORCERD | ALS Comparator Control: FORCE_RD
Public property | ALSComparatorControlFORCERD2 | ALS Comparator Control: FORCE_RD2
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BacklightDimTimeoutDIMT | Backlight Dim Timeout: DIMT (unit: sec)
Public property | BacklightFadeBLFI | Backlight Fade: BL_FI
Public property | BacklightFadeBLFO | Backlight Fade: BL_FO
Public property | BacklightLevel1DaylightDimCurrentBL1DC | Backlight Level 1 (Daylight) Dim Current: BL1_DC (unit: mA)
Public property | BacklightLevel1DaylightMaximumCurrentBL1MC | Backlight Level 1 (Daylight) Maximum Current: BL1_MC (unit: mA)
Public property | BacklightLevel2BrightDimCurrentBL2DC | Backlight Level 2 (Bright) Dim Current: BL2_DC (unit: mA)
Public property | BacklightLevel2BrightMaximumCurrentBL2MC | Backlight Level 2 (Bright) Maximum Current: BL2_MC (unit: mA)
Public property | BacklightLevel3OfficeDimCurrentBL3DC | Backlight Level 3 (Office) Dim Current: BL3_DC (unit: mA)
Public property | BacklightLevel3OfficeMaximumCurrentBL3MC | Backlight Level 3 (Office) Maximum Current: BL3_MC (unit: mA)
Public property | BacklightLevel4IndoorDimCurrentBL4DC | Backlight Level 4 (Indoor) Dim Current: BL4_DC (unit: mA)
Public property | BacklightLevel4IndoorMaximumCurrentBL4MC | Backlight Level 4 (Indoor) Maximum Current: BL4_MC (unit: mA)
Public property | BacklightLevel5DarkDimCurrentBL5DC | Backlight Level 5 (Dark) Dim Current: BL5_DC (unit: mA)
Public property | BacklightLevel5DarkMaximumCurrentBL5MC | Backlight Level 5 (Dark) Maximum Current: BL5_MC (unit: mA)
Public property | BacklightOffTimeoutBLOFF | Backlight Off Timeout: BLOFF (unit: sec)
Public property | BacklightSelectionD1SEL | Backlight Selection: D1SEL
Public property | BacklightSelectionD2SEL | Backlight Selection: D2SEL
Public property | BacklightSelectionD3SEL | Backlight Selection: D3SEL
Public property | BacklightSelectionD4SEL | Backlight Selection: D4SEL
Public property | BacklightSelectionD5SEL | Backlight Selection: D5SEL
Public property | BacklightSelectionD6SEL | Backlight Selection: D6SEL
Public property | BacklightSelectionD7SEL | Backlight Selection: D7SEL
Public property | ComparatorLevel2HysteresisL2HYS | Comparator Level 2 Hysteresis: L2_HYS (unit: µA)
Public property | ComparatorLevel2ThresholdL2TRP | Comparator Level 2 Threshold: L2_TRP (unit: µA)
Public property | ComparatorLevel3HysteresisL3HYS | Comparator Level 3 Hysteresis: L3_HYS (unit: µA)
Public property | ComparatorLevel3ThresholdL3TRP | Comparator Level 3 Threshold: L3_TRP (unit: µA)
Public property | ComparatorLevel4HysteresisL4HYS | Comparator Level 4 Hysteresis: L4_HYS (unit: µA)
Public property | ComparatorLevel4ThresholdL4TRP | Comparator Level 4 Threshold: L4_TRP (unit: µA)
Public property | ComparatorLevel5HysteresisL5HYS | Comparator Level 5 Hysteresis: L5_HYS (unit: µA)
Public property | ComparatorLevel5ThresholdL5TRP | Comparator Level 5 Threshold: L5_TRP (unit: µA)
Public property | ConfigurationBLLAW | Configuration: BL_LAW
Public property | ConfigurationBLV | Configuration: BLV
Public property | ConfigurationCMP2SEL | Configuration: CMP2_SEL
Public property | ConfigurationFOVR | Configuration: FOVR
Public property | ConfigurationSELAB | Configuration: SEL_AB
Public property | FirstPhototransistorPH1LEV | First Phototransistor: PH1LEV
Public property | IndependentSinkCurrentControlSC1EN | Independent Sink Current Control: SC1_EN
Public property | IndependentSinkCurrentControlSC2EN | Independent Sink Current Control: SC2_EN
Public property | IndependentSinkCurrentControlSC3EN | Independent Sink Current Control: SC3_EN
Public property | IndependentSinkCurrentControlSC4EN | Independent Sink Current Control: SC4_EN
Public property | IndependentSinkCurrentControlSC5EN | Independent Sink Current Control: SC5_EN
Public property | IndependentSinkCurrentControlSC6EN | Independent Sink Current Control: SC6_EN
Public property | IndependentSinkCurrentControlSC7EN | Independent Sink Current Control: SC7_EN
Public property | IndependentSinkCurrentFadeLawSCLAW | Independent Sink Current Fade Law: SC_LAW
Public property | IndependentSinkCurrentFadeSCFI | Independent Sink Current Fade: SCFI
Public property | IndependentSinkCurrentFadeSCFO | Independent Sink Current Fade: SCFO
Public property | IndependentSinkCurrentTimeSC1OFF | Independent Sink Current Time: SC1OFF
Public property | IndependentSinkCurrentTimeSC2OFF | Independent Sink Current Time: SC2OFF
Public property | IndependentSinkCurrentTimeSC3OFF | Independent Sink Current Time: SC3OFF
Public property | IndependentSinkCurrentTimeSC4OFF | Independent Sink Current Time: SC4OFF
Public property | IndependentSinkCurrentTimeSC5OFF | Independent Sink Current Time: SC5OFF
Public property | IndependentSinkCurrentTimeSC6OFF | Independent Sink Current Time: SC6OFF
Public property | IndependentSinkCurrentTimeSC7OFF | Independent Sink Current Time: SC7OFF
Public property | IndependentSinkCurrentTimeSCON | Independent Sink Current Time: SCON
Public property | InterruptEnableBLOFFIEN | Interrupt Enable: BLOFF_IEN
Public property | InterruptEnableCMP2IEN | Interrupt Enable: CMP2_IEN
Public property | InterruptEnableCMPIEN | Interrupt Enable: CMP_IEN
Public property | InterruptEnableOVPIEN | Interrupt Enable: OVP_IEN
Public property | InterruptEnableSHORTIEN | Interrupt Enable: SHORT_IEN
Public property | InterruptEnableTSDIEN | Interrupt Enable: TSD_IEN
Public property | InterruptStatusBLOFFINT | Interrupt Status: BLOFF_INT
Public property | InterruptStatusCMP2INT | Interrupt Status: CMP2_INT
Public property | InterruptStatusCMPINT | Interrupt Status: CMP_INT
Public property | InterruptStatusOVPINT | Interrupt Status: OVP_INT
Public property | InterruptStatusSHORTINT | Interrupt Status: SHORT_INT
Public property | InterruptStatusTSDINT | Interrupt Status: TSD_INT
Public property | MainALSComparatorLevelEnableL2EN | Main ALS Comparator Level Enable: L2_EN
Public property | MainALSComparatorLevelEnableL3EN | Main ALS Comparator Level Enable: L3_EN
Public property | MainALSComparatorLevelEnableL4EN | Main ALS Comparator Level Enable: L4_EN
Public property | MainALSComparatorLevelEnableL5EN | Main ALS Comparator Level Enable: L5_EN
Public property | MainALSComparatorStatusCMP1L2OUT | Main ALS Comparator Status: CMP1_L2_OUT
Public property | MainALSComparatorStatusCMP1L3OUT | Main ALS Comparator Status: CMP1_L3_OUT
Public property | MainALSComparatorStatusCMP1L4OUT | Main ALS Comparator Status: CMP1_L4_OUT
Public property | MainALSComparatorStatusCMP1L5OUT | Main ALS Comparator Status: CMP1_L5_OUT
Public property | ManufacturerDeviceIDDeviceID | Manufacturer & Device ID: Device ID
Public property | ManufacturerDeviceIDManufacturerID | Manufacturer & Device ID: Manufacturer ID
Public property | ModeControlBLEN | Mode Control: BL_EN
Public property | ModeControlCMPAUTOEN | Mode Control: CMP_AUTOEN
Public property | ModeControlD7ALSEN | Mode Control: D7ALS_EN
Public property | ModeControlDIMEN | Mode Control: DIM_EN
Public property | ModeControlGDWINDIS | Mode Control: GDWIN_DIS
Public property | ModeControlINTCFG | Mode Control: INT_CFG
Public property | ModeControlNSTBY | Mode Control: nSTBY
Public property | ModeControlSISEN | Mode Control: SIS_EN
Public property | PWMEnableSelectionD1ENPWM | PWM Enable Selection: D1ENPWM
Public property | PWMEnableSelectionD2ENPWM | PWM Enable Selection: D2ENPWM
Public property | PWMEnableSelectionD3ENPWM | PWM Enable Selection: D3ENPWM
Public property | PWMEnableSelectionD4ENPWM | PWM Enable Selection: D4ENPWM
Public property | PWMEnableSelectionD5ENPWM | PWM Enable Selection: D5ENPWM
Public property | PWMEnableSelectionD6ENPWM | PWM Enable Selection: D6ENPWM
Public property | PWMEnableSelectionD7ENPWM | PWM Enable Selection: D7ENPWM
Public property | SecondALSComparatorStatusCMP2L2OUT | Second ALS Comparator Status: CMP2_L2_OUT
Public property | SecondALSComparatorStatusCMP2L3OUT | Second ALS Comparator Status: CMP2_L3_OUT
Public property | SecondALSComparatorStatusCMP2L4OUT | Second ALS Comparator Status: CMP2_L4_OUT
Public property | SecondALSComparatorStatusCMP2L5OUT | Second ALS Comparator Status: CMP2_L5_OUT
Public property | SecondaryALSComparatorLevelEnableL2EN2 | Secondary ALS Comparator Level Enable: L2_EN2
Public property | SecondaryALSComparatorLevelEnableL3EN2 | Secondary ALS Comparator Level Enable: L3_EN2
Public property | SecondaryALSComparatorLevelEnableL4EN2 | Secondary ALS Comparator Level Enable: L4_EN2
Public property | SecondaryALSComparatorLevelEnableL5EN2 | Secondary ALS Comparator Level Enable: L5_EN2
Public property | SecondPhototransistorPH2LEV | Second Phototransistor: PH2LEV
Public property | SinkCurrentLED1SCD1 | Sink Current LED 1: SCD1 (unit: mA)
Public property | SinkCurrentLED2SCD2 | Sink Current LED 2: SCD2 (unit: mA)
Public property | SinkCurrentLED3SCD3 | Sink Current LED 3: SCD3 (unit: mA)
Public property | SinkCurrentLED4SCD4 | Sink Current LED 4: SCD4 (unit: mA)
Public property | SinkCurrentLED5SCD5 | Sink Current LED 5: SCD5 (unit: mA)
Public property | SinkCurrentLED6SCD6 | Sink Current LED 6: SCD6 (unit: mA)
Public property | SinkCurrentLED7BrightnessLevel2SCD7L2 | Sink Current LED 7 Brightness Level 2: SCD7_L2 (unit: mA)
Public property | SinkCurrentLED7BrightnessLevel2SCD7L3 | Sink Current LED 7 Brightness Level 2: SCD7_L3 (unit: mA)
Public property | SinkCurrentLED7BrightnessLevel2SCD7L4 | Sink Current LED 7 Brightness Level 2: SCD7_L4 (unit: mA)
Public property | SinkCurrentLED7BrightnessLevel2SCD7L5 | Sink Current LED 7 Brightness Level 2: SCD7_L5 (unit: mA)
Public property | SinkCurrentLED7SCD7 | Sink Current LED 7: SCD7 (unit: mA)
Public property | SinkCurrentLED7SCR | Sink Current LED 7: SCR
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Charge-Pump, Parallel Backlight Driver with Image Content PWM Input
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adp8870(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adp8870

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870 Properties

The Adp8870 type exposes the following members.

Properties
 | Name | Description
Public property | ALSComparatorControlFILT | ALS Comparator Control: FILT
Public property | ALSComparatorControlFILT2 | ALS Comparator Control: FILT2
Public property | ALSComparatorControlFORCERD | ALS Comparator Control: FORCE_RD
Public property | ALSComparatorControlFORCERD2 | ALS Comparator Control: FORCE_RD2
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BacklightDimTimeoutDIMT | Backlight Dim Timeout: DIMT (unit: sec)
Public property | BacklightFadeBLFI | Backlight Fade: BL_FI
Public property | BacklightFadeBLFO | Backlight Fade: BL_FO
Public property | BacklightLevel1DaylightDimCurrentBL1DC | Backlight Level 1 (Daylight) Dim Current: BL1_DC (unit: mA)
Public property | BacklightLevel1DaylightMaximumCurrentBL1MC | Backlight Level 1 (Daylight) Maximum Current: BL1_MC (unit: mA)
Public property | BacklightLevel2BrightDimCurrentBL2DC | Backlight Level 2 (Bright) Dim Current: BL2_DC (unit: mA)
Public property | BacklightLevel2BrightMaximumCurrentBL2MC | Backlight Level 2 (Bright) Maximum Current: BL2_MC (unit: mA)
Public property | BacklightLevel3OfficeDimCurrentBL3DC | Backlight Level 3 (Office) Dim Current: BL3_DC (unit: mA)
Public property | BacklightLevel3OfficeMaximumCurrentBL3MC | Backlight Level 3 (Office) Maximum Current: BL3_MC (unit: mA)
Public property | BacklightLevel4IndoorDimCurrentBL4DC | Backlight Level 4 (Indoor) Dim Current: BL4_DC (unit: mA)
Public property | BacklightLevel4IndoorMaximumCurrentBL4MC | Backlight Level 4 (Indoor) Maximum Current: BL4_MC (unit: mA)
Public property | BacklightLevel5DarkDimCurrentBL5DC | Backlight Level 5 (Dark) Dim Current: BL5_DC (unit: mA)
Public property | BacklightLevel5DarkMaximumCurrentBL5MC | Backlight Level 5 (Dark) Maximum Current: BL5_MC (unit: mA)
Public property | BacklightOffTimeoutBLOFF | Backlight Off Timeout: BLOFF (unit: sec)
Public property | BacklightSelectionD1SEL | Backlight Selection: D1SEL
Public property | BacklightSelectionD2SEL | Backlight Selection: D2SEL
Public property | BacklightSelectionD3SEL | Backlight Selection: D3SEL
Public property | BacklightSelectionD4SEL | Backlight Selection: D4SEL
Public property | BacklightSelectionD5SEL | Backlight Selection: D5SEL
Public property | BacklightSelectionD6SEL | Backlight Selection: D6SEL
Public property | BacklightSelectionD7SEL | Backlight Selection: D7SEL
Public property | ComparatorLevel2HysteresisL2HYS | Comparator Level 2 Hysteresis: L2_HYS (unit: µA)
Public property | ComparatorLevel2ThresholdL2TRP | Comparator Level 2 Threshold: L2_TRP (unit: µA)
Public property | ComparatorLevel3HysteresisL3HYS | Comparator Level 3 Hysteresis: L3_HYS (unit: µA)
Public property | ComparatorLevel3ThresholdL3TRP | Comparator Level 3 Threshold: L3_TRP (unit: µA)
Public property | ComparatorLevel4HysteresisL4HYS | Comparator Level 4 Hysteresis: L4_HYS (unit: µA)
Public property | ComparatorLevel4ThresholdL4TRP | Comparator Level 4 Threshold: L4_TRP (unit: µA)
Public property | ComparatorLevel5HysteresisL5HYS | Comparator Level 5 Hysteresis: L5_HYS (unit: µA)
Public property | ComparatorLevel5ThresholdL5TRP | Comparator Level 5 Threshold: L5_TRP (unit: µA)
Public property | ConfigurationBLLAW | Configuration: BL_LAW
Public property | ConfigurationBLV | Configuration: BLV
Public property | ConfigurationCMP2SEL | Configuration: CMP2_SEL
Public property | ConfigurationFOVR | Configuration: FOVR
Public property | ConfigurationSELAB | Configuration: SEL_AB
Public property | FirstPhototransistorPH1LEV | First Phototransistor: PH1LEV
Public property | IndependentSinkCurrentControlSC1EN | Independent Sink Current Control: SC1_EN
Public property | IndependentSinkCurrentControlSC2EN | Independent Sink Current Control: SC2_EN
Public property | IndependentSinkCurrentControlSC3EN | Independent Sink Current Control: SC3_EN
Public property | IndependentSinkCurrentControlSC4EN | Independent Sink Current Control: SC4_EN
Public property | IndependentSinkCurrentControlSC5EN | Independent Sink Current Control: SC5_EN
Public property | IndependentSinkCurrentControlSC6EN | Independent Sink Current Control: SC6_EN
Public property | IndependentSinkCurrentControlSC7EN | Independent Sink Current Control: SC7_EN
Public property | IndependentSinkCurrentFadeLawSCLAW | Independent Sink Current Fade Law: SC_LAW
Public property | IndependentSinkCurrentFadeSCFI | Independent Sink Current Fade: SCFI
Public property | IndependentSinkCurrentFadeSCFO | Independent Sink Current Fade: SCFO
Public property | IndependentSinkCurrentTimeSC1OFF | Independent Sink Current Time: SC1OFF
Public property | IndependentSinkCurrentTimeSC2OFF | Independent Sink Current Time: SC2OFF
Public property | IndependentSinkCurrentTimeSC3OFF | Independent Sink Current Time: SC3OFF
Public property | IndependentSinkCurrentTimeSC4OFF | Independent Sink Current Time: SC4OFF
Public property | IndependentSinkCurrentTimeSC5OFF | Independent Sink Current Time: SC5OFF
Public property | IndependentSinkCurrentTimeSC6OFF | Independent Sink Current Time: SC6OFF
Public property | IndependentSinkCurrentTimeSC7OFF | Independent Sink Current Time: SC7OFF
Public property | IndependentSinkCurrentTimeSCON | Independent Sink Current Time: SCON
Public property | InterruptEnableBLOFFIEN | Interrupt Enable: BLOFF_IEN
Public property | InterruptEnableCMP2IEN | Interrupt Enable: CMP2_IEN
Public property | InterruptEnableCMPIEN | Interrupt Enable: CMP_IEN
Public property | InterruptEnableOVPIEN | Interrupt Enable: OVP_IEN
Public property | InterruptEnableSHORTIEN | Interrupt Enable: SHORT_IEN
Public property | InterruptEnableTSDIEN | Interrupt Enable: TSD_IEN
Public property | InterruptStatusBLOFFINT | Interrupt Status: BLOFF_INT
Public property | InterruptStatusCMP2INT | Interrupt Status: CMP2_INT
Public property | InterruptStatusCMPINT | Interrupt Status: CMP_INT
Public property | InterruptStatusOVPINT | Interrupt Status: OVP_INT
Public property | InterruptStatusSHORTINT | Interrupt Status: SHORT_INT
Public property | InterruptStatusTSDINT | Interrupt Status: TSD_INT
Public property | MainALSComparatorLevelEnableL2EN | Main ALS Comparator Level Enable: L2_EN
Public property | MainALSComparatorLevelEnableL3EN | Main ALS Comparator Level Enable: L3_EN
Public property | MainALSComparatorLevelEnableL4EN | Main ALS Comparator Level Enable: L4_EN
Public property | MainALSComparatorLevelEnableL5EN | Main ALS Comparator Level Enable: L5_EN
Public property | MainALSComparatorStatusCMP1L2OUT | Main ALS Comparator Status: CMP1_L2_OUT
Public property | MainALSComparatorStatusCMP1L3OUT | Main ALS Comparator Status: CMP1_L3_OUT
Public property | MainALSComparatorStatusCMP1L4OUT | Main ALS Comparator Status: CMP1_L4_OUT
Public property | MainALSComparatorStatusCMP1L5OUT | Main ALS Comparator Status: CMP1_L5_OUT
Public property | ManufacturerDeviceIDDeviceID | Manufacturer & Device ID: Device ID
Public property | ManufacturerDeviceIDManufacturerID | Manufacturer & Device ID: Manufacturer ID
Public property | ModeControlBLEN | Mode Control: BL_EN
Public property | ModeControlCMPAUTOEN | Mode Control: CMP_AUTOEN
Public property | ModeControlD7ALSEN | Mode Control: D7ALS_EN
Public property | ModeControlDIMEN | Mode Control: DIM_EN
Public property | ModeControlGDWINDIS | Mode Control: GDWIN_DIS
Public property | ModeControlINTCFG | Mode Control: INT_CFG
Public property | ModeControlNSTBY | Mode Control: nSTBY
Public property | ModeControlSISEN | Mode Control: SIS_EN
Public property | PWMEnableSelectionD1ENPWM | PWM Enable Selection: D1ENPWM
Public property | PWMEnableSelectionD2ENPWM | PWM Enable Selection: D2ENPWM
Public property | PWMEnableSelectionD3ENPWM | PWM Enable Selection: D3ENPWM
Public property | PWMEnableSelectionD4ENPWM | PWM Enable Selection: D4ENPWM
Public property | PWMEnableSelectionD5ENPWM | PWM Enable Selection: D5ENPWM
Public property | PWMEnableSelectionD6ENPWM | PWM Enable Selection: D6ENPWM
Public property | PWMEnableSelectionD7ENPWM | PWM Enable Selection: D7ENPWM
Public property | SecondALSComparatorStatusCMP2L2OUT | Second ALS Comparator Status: CMP2_L2_OUT
Public property | SecondALSComparatorStatusCMP2L3OUT | Second ALS Comparator Status: CMP2_L3_OUT
Public property | SecondALSComparatorStatusCMP2L4OUT | Second ALS Comparator Status: CMP2_L4_OUT
Public property | SecondALSComparatorStatusCMP2L5OUT | Second ALS Comparator Status: CMP2_L5_OUT
Public property | SecondaryALSComparatorLevelEnableL2EN2 | Secondary ALS Comparator Level Enable: L2_EN2
Public property | SecondaryALSComparatorLevelEnableL3EN2 | Secondary ALS Comparator Level Enable: L3_EN2
Public property | SecondaryALSComparatorLevelEnableL4EN2 | Secondary ALS Comparator Level Enable: L4_EN2
Public property | SecondaryALSComparatorLevelEnableL5EN2 | Secondary ALS Comparator Level Enable: L5_EN2
Public property | SecondPhototransistorPH2LEV | Second Phototransistor: PH2LEV
Public property | SinkCurrentLED1SCD1 | Sink Current LED 1: SCD1 (unit: mA)
Public property | SinkCurrentLED2SCD2 | Sink Current LED 2: SCD2 (unit: mA)
Public property | SinkCurrentLED3SCD3 | Sink Current LED 3: SCD3 (unit: mA)
Public property | SinkCurrentLED4SCD4 | Sink Current LED 4: SCD4 (unit: mA)
Public property | SinkCurrentLED5SCD5 | Sink Current LED 5: SCD5 (unit: mA)
Public property | SinkCurrentLED6SCD6 | Sink Current LED 6: SCD6 (unit: mA)
Public property | SinkCurrentLED7BrightnessLevel2SCD7L2 | Sink Current LED 7 Brightness Level 2: SCD7_L2 (unit: mA)
Public property | SinkCurrentLED7BrightnessLevel2SCD7L3 | Sink Current LED 7 Brightness Level 2: SCD7_L3 (unit: mA)
Public property | SinkCurrentLED7BrightnessLevel2SCD7L4 | Sink Current LED 7 Brightness Level 2: SCD7_L4 (unit: mA)
Public property | SinkCurrentLED7BrightnessLevel2SCD7L5 | Sink Current LED 7 Brightness Level 2: SCD7_L5 (unit: mA)
Public property | SinkCurrentLED7SCD7 | Sink Current LED 7: SCD7 (unit: mA)
Public property | SinkCurrentLED7SCR | Sink Current LED 7: SCR
Top
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ALSComparatorControlFILT Property

IRD

Adp8870ALSComparatorControlFILT Property

ALS Comparator Control: FILT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeCmpCtlFilt ALSComparatorControlFILT { get; set; }
Public Property ALSComparatorControlFILT As Adp8870TypeCmpCtlFilt
    Get
    Set
public:
property Adp8870TypeCmpCtlFilt ALSComparatorControlFILT {
    Adp8870TypeCmpCtlFilt get ();
    void set (Adp8870TypeCmpCtlFilt value);
}
member ALSComparatorControlFILT : Adp8870TypeCmpCtlFilt with get, set

Property Value

Type: Adp8870TypeCmpCtlFilt
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ALSComparatorControlFILT2 Property

IRD

Adp8870ALSComparatorControlFILT2 Property

ALS Comparator Control: FILT2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeCmpCtlFilt ALSComparatorControlFILT2 { get; set; }
Public Property ALSComparatorControlFILT2 As Adp8870TypeCmpCtlFilt
    Get
    Set
public:
property Adp8870TypeCmpCtlFilt ALSComparatorControlFILT2 {
    Adp8870TypeCmpCtlFilt get ();
    void set (Adp8870TypeCmpCtlFilt value);
}
member ALSComparatorControlFILT2 : Adp8870TypeCmpCtlFilt with get, set

Property Value

Type: Adp8870TypeCmpCtlFilt
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ALSComparatorControlFORCERD Property

IRD

Adp8870ALSComparatorControlFORCERD Property

ALS Comparator Control: FORCE_RD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeCmpForceRd ALSComparatorControlFORCERD { get; set; }
Public Property ALSComparatorControlFORCERD As Adp8870TypeCmpForceRd
    Get
    Set
public:
property Adp8870TypeCmpForceRd ALSComparatorControlFORCERD {
    Adp8870TypeCmpForceRd get ();
    void set (Adp8870TypeCmpForceRd value);
}
member ALSComparatorControlFORCERD : Adp8870TypeCmpForceRd with get, set

Property Value

Type: Adp8870TypeCmpForceRd
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ALSComparatorControlFORCERD2 Property

IRD

Adp8870ALSComparatorControlFORCERD2 Property

ALS Comparator Control: FORCE_RD2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeCmpForceRd ALSComparatorControlFORCERD2 { get; set; }
Public Property ALSComparatorControlFORCERD2 As Adp8870TypeCmpForceRd
    Get
    Set
public:
property Adp8870TypeCmpForceRd ALSComparatorControlFORCERD2 {
    Adp8870TypeCmpForceRd get ();
    void set (Adp8870TypeCmpForceRd value);
}
member ALSComparatorControlFORCERD2 : Adp8870TypeCmpForceRd with get, set

Property Value

Type: Adp8870TypeCmpForceRd
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.AutoFlush Property

IRD

Adp8870AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightDimTimeoutDIMT Property

IRD

Adp8870BacklightDimTimeoutDIMT Property

Backlight Dim Timeout: DIMT (unit: sec)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte BacklightDimTimeoutDIMT { get; set; }
Public Property BacklightDimTimeoutDIMT As Byte
    Get
    Set
public:
property unsigned char BacklightDimTimeoutDIMT {
    unsigned char get ();
    void set (unsigned char value);
}
member BacklightDimTimeoutDIMT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightFadeBLFI Property

IRD

Adp8870BacklightFadeBLFI Property

Backlight Fade: BL_FI

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBlfr BacklightFadeBLFI { get; set; }
Public Property BacklightFadeBLFI As Adp8870TypeBlfr
    Get
    Set
public:
property Adp8870TypeBlfr BacklightFadeBLFI {
    Adp8870TypeBlfr get ();
    void set (Adp8870TypeBlfr value);
}
member BacklightFadeBLFI : Adp8870TypeBlfr with get, set

Property Value

Type: Adp8870TypeBlfr
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightFadeBLFO Property

IRD

Adp8870BacklightFadeBLFO Property

Backlight Fade: BL_FO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBlfr BacklightFadeBLFO { get; set; }
Public Property BacklightFadeBLFO As Adp8870TypeBlfr
    Get
    Set
public:
property Adp8870TypeBlfr BacklightFadeBLFO {
    Adp8870TypeBlfr get ();
    void set (Adp8870TypeBlfr value);
}
member BacklightFadeBLFO : Adp8870TypeBlfr with get, set

Property Value

Type: Adp8870TypeBlfr
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightLevel1DaylightDimCurrentBL1DC Property

IRD

Adp8870BacklightLevel1DaylightDimCurrentBL1DC Property

Backlight Level 1 (Daylight) Dim Current: BL1_DC (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl BacklightLevel1DaylightDimCurrentBL1DC { get; set; }
Public Property BacklightLevel1DaylightDimCurrentBL1DC As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl BacklightLevel1DaylightDimCurrentBL1DC {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member BacklightLevel1DaylightDimCurrentBL1DC : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightLevel1DaylightMaximumCurrentBL1MC Property

IRD

Adp8870BacklightLevel1DaylightMaximumCurrentBL1MC Property

Backlight Level 1 (Daylight) Maximum Current: BL1_MC (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl BacklightLevel1DaylightMaximumCurrentBL1MC { get; set; }
Public Property BacklightLevel1DaylightMaximumCurrentBL1MC As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl BacklightLevel1DaylightMaximumCurrentBL1MC {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member BacklightLevel1DaylightMaximumCurrentBL1MC : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightLevel2BrightDimCurrentBL2DC Property

IRD

Adp8870BacklightLevel2BrightDimCurrentBL2DC Property

Backlight Level 2 (Bright) Dim Current: BL2_DC (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl BacklightLevel2BrightDimCurrentBL2DC { get; set; }
Public Property BacklightLevel2BrightDimCurrentBL2DC As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl BacklightLevel2BrightDimCurrentBL2DC {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member BacklightLevel2BrightDimCurrentBL2DC : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightLevel2BrightMaximumCurrentBL2MC Property

IRD

Adp8870BacklightLevel2BrightMaximumCurrentBL2MC Property

Backlight Level 2 (Bright) Maximum Current: BL2_MC (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl BacklightLevel2BrightMaximumCurrentBL2MC { get; set; }
Public Property BacklightLevel2BrightMaximumCurrentBL2MC As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl BacklightLevel2BrightMaximumCurrentBL2MC {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member BacklightLevel2BrightMaximumCurrentBL2MC : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightLevel3OfficeDimCurrentBL3DC Property

IRD

Adp8870BacklightLevel3OfficeDimCurrentBL3DC Property

Backlight Level 3 (Office) Dim Current: BL3_DC (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl BacklightLevel3OfficeDimCurrentBL3DC { get; set; }
Public Property BacklightLevel3OfficeDimCurrentBL3DC As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl BacklightLevel3OfficeDimCurrentBL3DC {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member BacklightLevel3OfficeDimCurrentBL3DC : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightLevel3OfficeMaximumCurrentBL3MC Property

IRD

Adp8870BacklightLevel3OfficeMaximumCurrentBL3MC Property

Backlight Level 3 (Office) Maximum Current: BL3_MC (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl BacklightLevel3OfficeMaximumCurrentBL3MC { get; set; }
Public Property BacklightLevel3OfficeMaximumCurrentBL3MC As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl BacklightLevel3OfficeMaximumCurrentBL3MC {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member BacklightLevel3OfficeMaximumCurrentBL3MC : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightLevel4IndoorDimCurrentBL4DC Property

IRD

Adp8870BacklightLevel4IndoorDimCurrentBL4DC Property

Backlight Level 4 (Indoor) Dim Current: BL4_DC (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl BacklightLevel4IndoorDimCurrentBL4DC { get; set; }
Public Property BacklightLevel4IndoorDimCurrentBL4DC As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl BacklightLevel4IndoorDimCurrentBL4DC {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member BacklightLevel4IndoorDimCurrentBL4DC : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightLevel4IndoorMaximumCurrentBL4MC Property

IRD

Adp8870BacklightLevel4IndoorMaximumCurrentBL4MC Property

Backlight Level 4 (Indoor) Maximum Current: BL4_MC (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl BacklightLevel4IndoorMaximumCurrentBL4MC { get; set; }
Public Property BacklightLevel4IndoorMaximumCurrentBL4MC As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl BacklightLevel4IndoorMaximumCurrentBL4MC {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member BacklightLevel4IndoorMaximumCurrentBL4MC : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightLevel5DarkDimCurrentBL5DC Property

IRD

Adp8870BacklightLevel5DarkDimCurrentBL5DC Property

Backlight Level 5 (Dark) Dim Current: BL5_DC (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl BacklightLevel5DarkDimCurrentBL5DC { get; set; }
Public Property BacklightLevel5DarkDimCurrentBL5DC As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl BacklightLevel5DarkDimCurrentBL5DC {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member BacklightLevel5DarkDimCurrentBL5DC : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightLevel5DarkMaximumCurrentBL5MC Property

IRD

Adp8870BacklightLevel5DarkMaximumCurrentBL5MC Property

Backlight Level 5 (Dark) Maximum Current: BL5_MC (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl BacklightLevel5DarkMaximumCurrentBL5MC { get; set; }
Public Property BacklightLevel5DarkMaximumCurrentBL5MC As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl BacklightLevel5DarkMaximumCurrentBL5MC {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member BacklightLevel5DarkMaximumCurrentBL5MC : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightOffTimeoutBLOFF Property

IRD

Adp8870BacklightOffTimeoutBLOFF Property

Backlight Off Timeout: BLOFF (unit: sec)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte BacklightOffTimeoutBLOFF { get; set; }
Public Property BacklightOffTimeoutBLOFF As Byte
    Get
    Set
public:
property unsigned char BacklightOffTimeoutBLOFF {
    unsigned char get ();
    void set (unsigned char value);
}
member BacklightOffTimeoutBLOFF : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightSelectionD1SEL Property

IRD

Adp8870BacklightSelectionD1SEL Property

Backlight Selection: D1SEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBlsel BacklightSelectionD1SEL { get; set; }
Public Property BacklightSelectionD1SEL As Adp8870TypeBlsel
    Get
    Set
public:
property Adp8870TypeBlsel BacklightSelectionD1SEL {
    Adp8870TypeBlsel get ();
    void set (Adp8870TypeBlsel value);
}
member BacklightSelectionD1SEL : Adp8870TypeBlsel with get, set

Property Value

Type: Adp8870TypeBlsel
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightSelectionD2SEL Property

IRD

Adp8870BacklightSelectionD2SEL Property

Backlight Selection: D2SEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBlsel BacklightSelectionD2SEL { get; set; }
Public Property BacklightSelectionD2SEL As Adp8870TypeBlsel
    Get
    Set
public:
property Adp8870TypeBlsel BacklightSelectionD2SEL {
    Adp8870TypeBlsel get ();
    void set (Adp8870TypeBlsel value);
}
member BacklightSelectionD2SEL : Adp8870TypeBlsel with get, set

Property Value

Type: Adp8870TypeBlsel
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightSelectionD3SEL Property

IRD

Adp8870BacklightSelectionD3SEL Property

Backlight Selection: D3SEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBlsel BacklightSelectionD3SEL { get; set; }
Public Property BacklightSelectionD3SEL As Adp8870TypeBlsel
    Get
    Set
public:
property Adp8870TypeBlsel BacklightSelectionD3SEL {
    Adp8870TypeBlsel get ();
    void set (Adp8870TypeBlsel value);
}
member BacklightSelectionD3SEL : Adp8870TypeBlsel with get, set

Property Value

Type: Adp8870TypeBlsel
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightSelectionD4SEL Property

IRD

Adp8870BacklightSelectionD4SEL Property

Backlight Selection: D4SEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBlsel BacklightSelectionD4SEL { get; set; }
Public Property BacklightSelectionD4SEL As Adp8870TypeBlsel
    Get
    Set
public:
property Adp8870TypeBlsel BacklightSelectionD4SEL {
    Adp8870TypeBlsel get ();
    void set (Adp8870TypeBlsel value);
}
member BacklightSelectionD4SEL : Adp8870TypeBlsel with get, set

Property Value

Type: Adp8870TypeBlsel
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightSelectionD5SEL Property

IRD

Adp8870BacklightSelectionD5SEL Property

Backlight Selection: D5SEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBlsel BacklightSelectionD5SEL { get; set; }
Public Property BacklightSelectionD5SEL As Adp8870TypeBlsel
    Get
    Set
public:
property Adp8870TypeBlsel BacklightSelectionD5SEL {
    Adp8870TypeBlsel get ();
    void set (Adp8870TypeBlsel value);
}
member BacklightSelectionD5SEL : Adp8870TypeBlsel with get, set

Property Value

Type: Adp8870TypeBlsel
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightSelectionD6SEL Property

IRD

Adp8870BacklightSelectionD6SEL Property

Backlight Selection: D6SEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBlsel BacklightSelectionD6SEL { get; set; }
Public Property BacklightSelectionD6SEL As Adp8870TypeBlsel
    Get
    Set
public:
property Adp8870TypeBlsel BacklightSelectionD6SEL {
    Adp8870TypeBlsel get ();
    void set (Adp8870TypeBlsel value);
}
member BacklightSelectionD6SEL : Adp8870TypeBlsel with get, set

Property Value

Type: Adp8870TypeBlsel
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.BacklightSelectionD7SEL Property

IRD

Adp8870BacklightSelectionD7SEL Property

Backlight Selection: D7SEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBlsel BacklightSelectionD7SEL { get; set; }
Public Property BacklightSelectionD7SEL As Adp8870TypeBlsel
    Get
    Set
public:
property Adp8870TypeBlsel BacklightSelectionD7SEL {
    Adp8870TypeBlsel get ();
    void set (Adp8870TypeBlsel value);
}
member BacklightSelectionD7SEL : Adp8870TypeBlsel with get, set

Property Value

Type: Adp8870TypeBlsel
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ComparatorLevel2HysteresisL2HYS Property

IRD

Adp8870ComparatorLevel2HysteresisL2HYS Property

Comparator Level 2 Hysteresis: L2_HYS (unit: µA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ComparatorLevel2HysteresisL2HYS { get; set; }
Public Property ComparatorLevel2HysteresisL2HYS As Double
    Get
    Set
public:
property double ComparatorLevel2HysteresisL2HYS {
    double get ();
    void set (double value);
}
member ComparatorLevel2HysteresisL2HYS : float with get, set

Property Value

Type: Double
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ComparatorLevel2ThresholdL2TRP Property

IRD

Adp8870ComparatorLevel2ThresholdL2TRP Property

Comparator Level 2 Threshold: L2_TRP (unit: µA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ComparatorLevel2ThresholdL2TRP { get; set; }
Public Property ComparatorLevel2ThresholdL2TRP As Double
    Get
    Set
public:
property double ComparatorLevel2ThresholdL2TRP {
    double get ();
    void set (double value);
}
member ComparatorLevel2ThresholdL2TRP : float with get, set

Property Value

Type: Double
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ComparatorLevel3HysteresisL3HYS Property

IRD

Adp8870ComparatorLevel3HysteresisL3HYS Property

Comparator Level 3 Hysteresis: L3_HYS (unit: µA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ComparatorLevel3HysteresisL3HYS { get; set; }
Public Property ComparatorLevel3HysteresisL3HYS As Double
    Get
    Set
public:
property double ComparatorLevel3HysteresisL3HYS {
    double get ();
    void set (double value);
}
member ComparatorLevel3HysteresisL3HYS : float with get, set

Property Value

Type: Double
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ComparatorLevel3ThresholdL3TRP Property

IRD

Adp8870ComparatorLevel3ThresholdL3TRP Property

Comparator Level 3 Threshold: L3_TRP (unit: µA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ComparatorLevel3ThresholdL3TRP { get; set; }
Public Property ComparatorLevel3ThresholdL3TRP As Double
    Get
    Set
public:
property double ComparatorLevel3ThresholdL3TRP {
    double get ();
    void set (double value);
}
member ComparatorLevel3ThresholdL3TRP : float with get, set

Property Value

Type: Double
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ComparatorLevel4HysteresisL4HYS Property

IRD

Adp8870ComparatorLevel4HysteresisL4HYS Property

Comparator Level 4 Hysteresis: L4_HYS (unit: µA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ComparatorLevel4HysteresisL4HYS { get; set; }
Public Property ComparatorLevel4HysteresisL4HYS As Double
    Get
    Set
public:
property double ComparatorLevel4HysteresisL4HYS {
    double get ();
    void set (double value);
}
member ComparatorLevel4HysteresisL4HYS : float with get, set

Property Value

Type: Double
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ComparatorLevel4ThresholdL4TRP Property

IRD

Adp8870ComparatorLevel4ThresholdL4TRP Property

Comparator Level 4 Threshold: L4_TRP (unit: µA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ComparatorLevel4ThresholdL4TRP { get; set; }
Public Property ComparatorLevel4ThresholdL4TRP As Double
    Get
    Set
public:
property double ComparatorLevel4ThresholdL4TRP {
    double get ();
    void set (double value);
}
member ComparatorLevel4ThresholdL4TRP : float with get, set

Property Value

Type: Double
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ComparatorLevel5HysteresisL5HYS Property

IRD

Adp8870ComparatorLevel5HysteresisL5HYS Property

Comparator Level 5 Hysteresis: L5_HYS (unit: µA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ComparatorLevel5HysteresisL5HYS { get; set; }
Public Property ComparatorLevel5HysteresisL5HYS As Double
    Get
    Set
public:
property double ComparatorLevel5HysteresisL5HYS {
    double get ();
    void set (double value);
}
member ComparatorLevel5HysteresisL5HYS : float with get, set

Property Value

Type: Double
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ComparatorLevel5ThresholdL5TRP Property

IRD

Adp8870ComparatorLevel5ThresholdL5TRP Property

Comparator Level 5 Threshold: L5_TRP (unit: µA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ComparatorLevel5ThresholdL5TRP { get; set; }
Public Property ComparatorLevel5ThresholdL5TRP As Double
    Get
    Set
public:
property double ComparatorLevel5ThresholdL5TRP {
    double get ();
    void set (double value);
}
member ComparatorLevel5ThresholdL5TRP : float with get, set

Property Value

Type: Double
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ConfigurationBLLAW Property

IRD

Adp8870ConfigurationBLLAW Property

Configuration: BL_LAW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeCfgrBlLaw ConfigurationBLLAW { get; set; }
Public Property ConfigurationBLLAW As Adp8870TypeCfgrBlLaw
    Get
    Set
public:
property Adp8870TypeCfgrBlLaw ConfigurationBLLAW {
    Adp8870TypeCfgrBlLaw get ();
    void set (Adp8870TypeCfgrBlLaw value);
}
member ConfigurationBLLAW : Adp8870TypeCfgrBlLaw with get, set

Property Value

Type: Adp8870TypeCfgrBlLaw
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ConfigurationBLV Property

IRD

Adp8870ConfigurationBLV Property

Configuration: BLV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeCfgrBlv ConfigurationBLV { get; set; }
Public Property ConfigurationBLV As Adp8870TypeCfgrBlv
    Get
    Set
public:
property Adp8870TypeCfgrBlv ConfigurationBLV {
    Adp8870TypeCfgrBlv get ();
    void set (Adp8870TypeCfgrBlv value);
}
member ConfigurationBLV : Adp8870TypeCfgrBlv with get, set

Property Value

Type: Adp8870TypeCfgrBlv
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ConfigurationCMP2SEL Property

IRD

Adp8870ConfigurationCMP2SEL Property

Configuration: CMP2_SEL

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeCfgrCmp2Sel ConfigurationCMP2SEL { get; set; }
Public Property ConfigurationCMP2SEL As Adp8870TypeCfgrCmp2Sel
    Get
    Set
public:
property Adp8870TypeCfgrCmp2Sel ConfigurationCMP2SEL {
    Adp8870TypeCfgrCmp2Sel get ();
    void set (Adp8870TypeCfgrCmp2Sel value);
}
member ConfigurationCMP2SEL : Adp8870TypeCfgrCmp2Sel with get, set

Property Value

Type: Adp8870TypeCfgrCmp2Sel
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ConfigurationFOVR Property

IRD

Adp8870ConfigurationFOVR Property

Configuration: FOVR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeCfgrFovr ConfigurationFOVR { get; set; }
Public Property ConfigurationFOVR As Adp8870TypeCfgrFovr
    Get
    Set
public:
property Adp8870TypeCfgrFovr ConfigurationFOVR {
    Adp8870TypeCfgrFovr get ();
    void set (Adp8870TypeCfgrFovr value);
}
member ConfigurationFOVR : Adp8870TypeCfgrFovr with get, set

Property Value

Type: Adp8870TypeCfgrFovr
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ConfigurationSELAB Property

IRD

Adp8870ConfigurationSELAB Property

Configuration: SEL_AB

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeCfgrSelAb ConfigurationSELAB { get; set; }
Public Property ConfigurationSELAB As Adp8870TypeCfgrSelAb
    Get
    Set
public:
property Adp8870TypeCfgrSelAb ConfigurationSELAB {
    Adp8870TypeCfgrSelAb get ();
    void set (Adp8870TypeCfgrSelAb value);
}
member ConfigurationSELAB : Adp8870TypeCfgrSelAb with get, set

Property Value

Type: Adp8870TypeCfgrSelAb
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.FirstPhototransistorPH1LEV Property

IRD

Adp8870FirstPhototransistorPH1LEV Property

First Phototransistor: PH1LEV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort FirstPhototransistorPH1LEV { get; }
Public ReadOnly Property FirstPhototransistorPH1LEV As UShort
    Get
public:
property unsigned short FirstPhototransistorPH1LEV {
    unsigned short get ();
}
member FirstPhototransistorPH1LEV : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.IndependentSinkCurrentControlSC1EN Property

IRD

Adp8870IndependentSinkCurrentControlSC1EN Property

Independent Sink Current Control: SC1_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIscc IndependentSinkCurrentControlSC1EN { get; set; }
Public Property IndependentSinkCurrentControlSC1EN As Adp8870TypeIscc
    Get
    Set
public:
property Adp8870TypeIscc IndependentSinkCurrentControlSC1EN {
    Adp8870TypeIscc get ();
    void set (Adp8870TypeIscc value);
}
member IndependentSinkCurrentControlSC1EN : Adp8870TypeIscc with get, set

Property Value

Type: Adp8870TypeIscc
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.IndependentSinkCurrentControlSC2EN Property

IRD

Adp8870IndependentSinkCurrentControlSC2EN Property

Independent Sink Current Control: SC2_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIscc IndependentSinkCurrentControlSC2EN { get; set; }
Public Property IndependentSinkCurrentControlSC2EN As Adp8870TypeIscc
    Get
    Set
public:
property Adp8870TypeIscc IndependentSinkCurrentControlSC2EN {
    Adp8870TypeIscc get ();
    void set (Adp8870TypeIscc value);
}
member IndependentSinkCurrentControlSC2EN : Adp8870TypeIscc with get, set

Property Value

Type: Adp8870TypeIscc
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.IndependentSinkCurrentControlSC3EN Property

IRD

Adp8870IndependentSinkCurrentControlSC3EN Property

Independent Sink Current Control: SC3_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIscc IndependentSinkCurrentControlSC3EN { get; set; }
Public Property IndependentSinkCurrentControlSC3EN As Adp8870TypeIscc
    Get
    Set
public:
property Adp8870TypeIscc IndependentSinkCurrentControlSC3EN {
    Adp8870TypeIscc get ();
    void set (Adp8870TypeIscc value);
}
member IndependentSinkCurrentControlSC3EN : Adp8870TypeIscc with get, set

Property Value

Type: Adp8870TypeIscc
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.IndependentSinkCurrentControlSC4EN Property

IRD

Adp8870IndependentSinkCurrentControlSC4EN Property

Independent Sink Current Control: SC4_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIscc IndependentSinkCurrentControlSC4EN { get; set; }
Public Property IndependentSinkCurrentControlSC4EN As Adp8870TypeIscc
    Get
    Set
public:
property Adp8870TypeIscc IndependentSinkCurrentControlSC4EN {
    Adp8870TypeIscc get ();
    void set (Adp8870TypeIscc value);
}
member IndependentSinkCurrentControlSC4EN : Adp8870TypeIscc with get, set

Property Value

Type: Adp8870TypeIscc
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.IndependentSinkCurrentControlSC5EN Property

IRD

Adp8870IndependentSinkCurrentControlSC5EN Property

Independent Sink Current Control: SC5_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIscc IndependentSinkCurrentControlSC5EN { get; set; }
Public Property IndependentSinkCurrentControlSC5EN As Adp8870TypeIscc
    Get
    Set
public:
property Adp8870TypeIscc IndependentSinkCurrentControlSC5EN {
    Adp8870TypeIscc get ();
    void set (Adp8870TypeIscc value);
}
member IndependentSinkCurrentControlSC5EN : Adp8870TypeIscc with get, set

Property Value

Type: Adp8870TypeIscc
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.IndependentSinkCurrentControlSC6EN Property

IRD

Adp8870IndependentSinkCurrentControlSC6EN Property

Independent Sink Current Control: SC6_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIscc IndependentSinkCurrentControlSC6EN { get; set; }
Public Property IndependentSinkCurrentControlSC6EN As Adp8870TypeIscc
    Get
    Set
public:
property Adp8870TypeIscc IndependentSinkCurrentControlSC6EN {
    Adp8870TypeIscc get ();
    void set (Adp8870TypeIscc value);
}
member IndependentSinkCurrentControlSC6EN : Adp8870TypeIscc with get, set

Property Value

Type: Adp8870TypeIscc
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.IndependentSinkCurrentControlSC7EN Property

IRD

Adp8870IndependentSinkCurrentControlSC7EN Property

Independent Sink Current Control: SC7_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIscc IndependentSinkCurrentControlSC7EN { get; set; }
Public Property IndependentSinkCurrentControlSC7EN As Adp8870TypeIscc
    Get
    Set
public:
property Adp8870TypeIscc IndependentSinkCurrentControlSC7EN {
    Adp8870TypeIscc get ();
    void set (Adp8870TypeIscc value);
}
member IndependentSinkCurrentControlSC7EN : Adp8870TypeIscc with get, set

Property Value

Type: Adp8870TypeIscc
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.IndependentSinkCurrentFadeLawSCLAW Property

IRD

Adp8870IndependentSinkCurrentFadeLawSCLAW Property

Independent Sink Current Fade Law: SC_LAW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIsclaw IndependentSinkCurrentFadeLawSCLAW { get; set; }
Public Property IndependentSinkCurrentFadeLawSCLAW As Adp8870TypeIsclaw
    Get
    Set
public:
property Adp8870TypeIsclaw IndependentSinkCurrentFadeLawSCLAW {
    Adp8870TypeIsclaw get ();
    void set (Adp8870TypeIsclaw value);
}
member IndependentSinkCurrentFadeLawSCLAW : Adp8870TypeIsclaw with get, set

Property Value

Type: Adp8870TypeIsclaw
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.IndependentSinkCurrentFadeSCFI Property

IRD

Adp8870IndependentSinkCurrentFadeSCFI Property

Independent Sink Current Fade: SCFI

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIscf IndependentSinkCurrentFadeSCFI { get; set; }
Public Property IndependentSinkCurrentFadeSCFI As Adp8870TypeIscf
    Get
    Set
public:
property Adp8870TypeIscf IndependentSinkCurrentFadeSCFI {
    Adp8870TypeIscf get ();
    void set (Adp8870TypeIscf value);
}
member IndependentSinkCurrentFadeSCFI : Adp8870TypeIscf with get, set

Property Value

Type: Adp8870TypeIscf
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.IndependentSinkCurrentFadeSCFO Property

IRD

Adp8870IndependentSinkCurrentFadeSCFO Property

Independent Sink Current Fade: SCFO

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIscf IndependentSinkCurrentFadeSCFO { get; set; }
Public Property IndependentSinkCurrentFadeSCFO As Adp8870TypeIscf
    Get
    Set
public:
property Adp8870TypeIscf IndependentSinkCurrentFadeSCFO {
    Adp8870TypeIscf get ();
    void set (Adp8870TypeIscf value);
}
member IndependentSinkCurrentFadeSCFO : Adp8870TypeIscf with get, set

Property Value

Type: Adp8870TypeIscf
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.IndependentSinkCurrentTimeSC1OFF Property

IRD

Adp8870IndependentSinkCurrentTimeSC1OFF Property

Independent Sink Current Time: SC1OFF

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIsctScoff IndependentSinkCurrentTimeSC1OFF { get; set; }
Public Property IndependentSinkCurrentTimeSC1OFF As Adp8870TypeIsctScoff
    Get
    Set
public:
property Adp8870TypeIsctScoff IndependentSinkCurrentTimeSC1OFF {
    Adp8870TypeIsctScoff get ();
    void set (Adp8870TypeIsctScoff value);
}
member IndependentSinkCurrentTimeSC1OFF : Adp8870TypeIsctScoff with get, set

Property Value

Type: Adp8870TypeIsctScoff
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.IndependentSinkCurrentTimeSC2OFF Property

IRD

Adp8870IndependentSinkCurrentTimeSC2OFF Property

Independent Sink Current Time: SC2OFF

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIsctScoff IndependentSinkCurrentTimeSC2OFF { get; set; }
Public Property IndependentSinkCurrentTimeSC2OFF As Adp8870TypeIsctScoff
    Get
    Set
public:
property Adp8870TypeIsctScoff IndependentSinkCurrentTimeSC2OFF {
    Adp8870TypeIsctScoff get ();
    void set (Adp8870TypeIsctScoff value);
}
member IndependentSinkCurrentTimeSC2OFF : Adp8870TypeIsctScoff with get, set

Property Value

Type: Adp8870TypeIsctScoff
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.IndependentSinkCurrentTimeSC3OFF Property

IRD

Adp8870IndependentSinkCurrentTimeSC3OFF Property

Independent Sink Current Time: SC3OFF

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIsctScoff IndependentSinkCurrentTimeSC3OFF { get; set; }
Public Property IndependentSinkCurrentTimeSC3OFF As Adp8870TypeIsctScoff
    Get
    Set
public:
property Adp8870TypeIsctScoff IndependentSinkCurrentTimeSC3OFF {
    Adp8870TypeIsctScoff get ();
    void set (Adp8870TypeIsctScoff value);
}
member IndependentSinkCurrentTimeSC3OFF : Adp8870TypeIsctScoff with get, set

Property Value

Type: Adp8870TypeIsctScoff
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.IndependentSinkCurrentTimeSC4OFF Property

IRD

Adp8870IndependentSinkCurrentTimeSC4OFF Property

Independent Sink Current Time: SC4OFF

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIsctScoff IndependentSinkCurrentTimeSC4OFF { get; set; }
Public Property IndependentSinkCurrentTimeSC4OFF As Adp8870TypeIsctScoff
    Get
    Set
public:
property Adp8870TypeIsctScoff IndependentSinkCurrentTimeSC4OFF {
    Adp8870TypeIsctScoff get ();
    void set (Adp8870TypeIsctScoff value);
}
member IndependentSinkCurrentTimeSC4OFF : Adp8870TypeIsctScoff with get, set

Property Value

Type: Adp8870TypeIsctScoff
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.IndependentSinkCurrentTimeSC5OFF Property

IRD

Adp8870IndependentSinkCurrentTimeSC5OFF Property

Independent Sink Current Time: SC5OFF

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIsctScoff IndependentSinkCurrentTimeSC5OFF { get; set; }
Public Property IndependentSinkCurrentTimeSC5OFF As Adp8870TypeIsctScoff
    Get
    Set
public:
property Adp8870TypeIsctScoff IndependentSinkCurrentTimeSC5OFF {
    Adp8870TypeIsctScoff get ();
    void set (Adp8870TypeIsctScoff value);
}
member IndependentSinkCurrentTimeSC5OFF : Adp8870TypeIsctScoff with get, set

Property Value

Type: Adp8870TypeIsctScoff
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.IndependentSinkCurrentTimeSC6OFF Property

IRD

Adp8870IndependentSinkCurrentTimeSC6OFF Property

Independent Sink Current Time: SC6OFF

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIsctScoff IndependentSinkCurrentTimeSC6OFF { get; set; }
Public Property IndependentSinkCurrentTimeSC6OFF As Adp8870TypeIsctScoff
    Get
    Set
public:
property Adp8870TypeIsctScoff IndependentSinkCurrentTimeSC6OFF {
    Adp8870TypeIsctScoff get ();
    void set (Adp8870TypeIsctScoff value);
}
member IndependentSinkCurrentTimeSC6OFF : Adp8870TypeIsctScoff with get, set

Property Value

Type: Adp8870TypeIsctScoff
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.IndependentSinkCurrentTimeSC7OFF Property

IRD

Adp8870IndependentSinkCurrentTimeSC7OFF Property

Independent Sink Current Time: SC7OFF

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIsctScoff IndependentSinkCurrentTimeSC7OFF { get; set; }
Public Property IndependentSinkCurrentTimeSC7OFF As Adp8870TypeIsctScoff
    Get
    Set
public:
property Adp8870TypeIsctScoff IndependentSinkCurrentTimeSC7OFF {
    Adp8870TypeIsctScoff get ();
    void set (Adp8870TypeIsctScoff value);
}
member IndependentSinkCurrentTimeSC7OFF : Adp8870TypeIsctScoff with get, set

Property Value

Type: Adp8870TypeIsctScoff
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.IndependentSinkCurrentTimeSCON Property

IRD

Adp8870IndependentSinkCurrentTimeSCON Property

Independent Sink Current Time: SCON

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIsctScon IndependentSinkCurrentTimeSCON { get; set; }
Public Property IndependentSinkCurrentTimeSCON As Adp8870TypeIsctScon
    Get
    Set
public:
property Adp8870TypeIsctScon IndependentSinkCurrentTimeSCON {
    Adp8870TypeIsctScon get ();
    void set (Adp8870TypeIsctScon value);
}
member IndependentSinkCurrentTimeSCON : Adp8870TypeIsctScon with get, set

Property Value

Type: Adp8870TypeIsctScon
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.InterruptEnableBLOFFIEN Property

IRD

Adp8870InterruptEnableBLOFFIEN Property

Interrupt Enable: BLOFF_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIntEn InterruptEnableBLOFFIEN { get; set; }
Public Property InterruptEnableBLOFFIEN As Adp8870TypeIntEn
    Get
    Set
public:
property Adp8870TypeIntEn InterruptEnableBLOFFIEN {
    Adp8870TypeIntEn get ();
    void set (Adp8870TypeIntEn value);
}
member InterruptEnableBLOFFIEN : Adp8870TypeIntEn with get, set

Property Value

Type: Adp8870TypeIntEn
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.InterruptEnableCMP2IEN Property

IRD

Adp8870InterruptEnableCMP2IEN Property

Interrupt Enable: CMP2_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIntEn InterruptEnableCMP2IEN { get; set; }
Public Property InterruptEnableCMP2IEN As Adp8870TypeIntEn
    Get
    Set
public:
property Adp8870TypeIntEn InterruptEnableCMP2IEN {
    Adp8870TypeIntEn get ();
    void set (Adp8870TypeIntEn value);
}
member InterruptEnableCMP2IEN : Adp8870TypeIntEn with get, set

Property Value

Type: Adp8870TypeIntEn
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.InterruptEnableCMPIEN Property

IRD

Adp8870InterruptEnableCMPIEN Property

Interrupt Enable: CMP_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIntEn InterruptEnableCMPIEN { get; set; }
Public Property InterruptEnableCMPIEN As Adp8870TypeIntEn
    Get
    Set
public:
property Adp8870TypeIntEn InterruptEnableCMPIEN {
    Adp8870TypeIntEn get ();
    void set (Adp8870TypeIntEn value);
}
member InterruptEnableCMPIEN : Adp8870TypeIntEn with get, set

Property Value

Type: Adp8870TypeIntEn
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.InterruptEnableOVPIEN Property

IRD

Adp8870InterruptEnableOVPIEN Property

Interrupt Enable: OVP_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIntEn InterruptEnableOVPIEN { get; set; }
Public Property InterruptEnableOVPIEN As Adp8870TypeIntEn
    Get
    Set
public:
property Adp8870TypeIntEn InterruptEnableOVPIEN {
    Adp8870TypeIntEn get ();
    void set (Adp8870TypeIntEn value);
}
member InterruptEnableOVPIEN : Adp8870TypeIntEn with get, set

Property Value

Type: Adp8870TypeIntEn
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.InterruptEnableSHORTIEN Property

IRD

Adp8870InterruptEnableSHORTIEN Property

Interrupt Enable: SHORT_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIntEn InterruptEnableSHORTIEN { get; set; }
Public Property InterruptEnableSHORTIEN As Adp8870TypeIntEn
    Get
    Set
public:
property Adp8870TypeIntEn InterruptEnableSHORTIEN {
    Adp8870TypeIntEn get ();
    void set (Adp8870TypeIntEn value);
}
member InterruptEnableSHORTIEN : Adp8870TypeIntEn with get, set

Property Value

Type: Adp8870TypeIntEn
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.InterruptEnableTSDIEN Property

IRD

Adp8870InterruptEnableTSDIEN Property

Interrupt Enable: TSD_IEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIntEn InterruptEnableTSDIEN { get; set; }
Public Property InterruptEnableTSDIEN As Adp8870TypeIntEn
    Get
    Set
public:
property Adp8870TypeIntEn InterruptEnableTSDIEN {
    Adp8870TypeIntEn get ();
    void set (Adp8870TypeIntEn value);
}
member InterruptEnableTSDIEN : Adp8870TypeIntEn with get, set

Property Value

Type: Adp8870TypeIntEn
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.InterruptStatusBLOFFINT Property

IRD

Adp8870InterruptStatusBLOFFINT Property

Interrupt Status: BLOFF_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIntStat InterruptStatusBLOFFINT { get; set; }
Public Property InterruptStatusBLOFFINT As Adp8870TypeIntStat
    Get
    Set
public:
property Adp8870TypeIntStat InterruptStatusBLOFFINT {
    Adp8870TypeIntStat get ();
    void set (Adp8870TypeIntStat value);
}
member InterruptStatusBLOFFINT : Adp8870TypeIntStat with get, set

Property Value

Type: Adp8870TypeIntStat
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.InterruptStatusCMP2INT Property

IRD

Adp8870InterruptStatusCMP2INT Property

Interrupt Status: CMP2_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIntStat InterruptStatusCMP2INT { get; set; }
Public Property InterruptStatusCMP2INT As Adp8870TypeIntStat
    Get
    Set
public:
property Adp8870TypeIntStat InterruptStatusCMP2INT {
    Adp8870TypeIntStat get ();
    void set (Adp8870TypeIntStat value);
}
member InterruptStatusCMP2INT : Adp8870TypeIntStat with get, set

Property Value

Type: Adp8870TypeIntStat
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.InterruptStatusCMPINT Property

IRD

Adp8870InterruptStatusCMPINT Property

Interrupt Status: CMP_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIntStat InterruptStatusCMPINT { get; set; }
Public Property InterruptStatusCMPINT As Adp8870TypeIntStat
    Get
    Set
public:
property Adp8870TypeIntStat InterruptStatusCMPINT {
    Adp8870TypeIntStat get ();
    void set (Adp8870TypeIntStat value);
}
member InterruptStatusCMPINT : Adp8870TypeIntStat with get, set

Property Value

Type: Adp8870TypeIntStat
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.InterruptStatusOVPINT Property

IRD

Adp8870InterruptStatusOVPINT Property

Interrupt Status: OVP_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIntStat InterruptStatusOVPINT { get; set; }
Public Property InterruptStatusOVPINT As Adp8870TypeIntStat
    Get
    Set
public:
property Adp8870TypeIntStat InterruptStatusOVPINT {
    Adp8870TypeIntStat get ();
    void set (Adp8870TypeIntStat value);
}
member InterruptStatusOVPINT : Adp8870TypeIntStat with get, set

Property Value

Type: Adp8870TypeIntStat
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.InterruptStatusSHORTINT Property

IRD

Adp8870InterruptStatusSHORTINT Property

Interrupt Status: SHORT_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIntStat InterruptStatusSHORTINT { get; set; }
Public Property InterruptStatusSHORTINT As Adp8870TypeIntStat
    Get
    Set
public:
property Adp8870TypeIntStat InterruptStatusSHORTINT {
    Adp8870TypeIntStat get ();
    void set (Adp8870TypeIntStat value);
}
member InterruptStatusSHORTINT : Adp8870TypeIntStat with get, set

Property Value

Type: Adp8870TypeIntStat
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.InterruptStatusTSDINT Property

IRD

Adp8870InterruptStatusTSDINT Property

Interrupt Status: TSD_INT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIntStat InterruptStatusTSDINT { get; set; }
Public Property InterruptStatusTSDINT As Adp8870TypeIntStat
    Get
    Set
public:
property Adp8870TypeIntStat InterruptStatusTSDINT {
    Adp8870TypeIntStat get ();
    void set (Adp8870TypeIntStat value);
}
member InterruptStatusTSDINT : Adp8870TypeIntStat with get, set

Property Value

Type: Adp8870TypeIntStat
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.MainALSComparatorLevelEnableL2EN Property

IRD

Adp8870MainALSComparatorLevelEnableL2EN Property

Main ALS Comparator Level Enable: L2_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeAlsEn MainALSComparatorLevelEnableL2EN { get; set; }
Public Property MainALSComparatorLevelEnableL2EN As Adp8870TypeAlsEn
    Get
    Set
public:
property Adp8870TypeAlsEn MainALSComparatorLevelEnableL2EN {
    Adp8870TypeAlsEn get ();
    void set (Adp8870TypeAlsEn value);
}
member MainALSComparatorLevelEnableL2EN : Adp8870TypeAlsEn with get, set

Property Value

Type: Adp8870TypeAlsEn
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.MainALSComparatorLevelEnableL3EN Property

IRD

Adp8870MainALSComparatorLevelEnableL3EN Property

Main ALS Comparator Level Enable: L3_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeAlsEn MainALSComparatorLevelEnableL3EN { get; set; }
Public Property MainALSComparatorLevelEnableL3EN As Adp8870TypeAlsEn
    Get
    Set
public:
property Adp8870TypeAlsEn MainALSComparatorLevelEnableL3EN {
    Adp8870TypeAlsEn get ();
    void set (Adp8870TypeAlsEn value);
}
member MainALSComparatorLevelEnableL3EN : Adp8870TypeAlsEn with get, set

Property Value

Type: Adp8870TypeAlsEn
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.MainALSComparatorLevelEnableL4EN Property

IRD

Adp8870MainALSComparatorLevelEnableL4EN Property

Main ALS Comparator Level Enable: L4_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeAlsEn MainALSComparatorLevelEnableL4EN { get; set; }
Public Property MainALSComparatorLevelEnableL4EN As Adp8870TypeAlsEn
    Get
    Set
public:
property Adp8870TypeAlsEn MainALSComparatorLevelEnableL4EN {
    Adp8870TypeAlsEn get ();
    void set (Adp8870TypeAlsEn value);
}
member MainALSComparatorLevelEnableL4EN : Adp8870TypeAlsEn with get, set

Property Value

Type: Adp8870TypeAlsEn
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.MainALSComparatorLevelEnableL5EN Property

IRD

Adp8870MainALSComparatorLevelEnableL5EN Property

Main ALS Comparator Level Enable: L5_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeAlsEn MainALSComparatorLevelEnableL5EN { get; set; }
Public Property MainALSComparatorLevelEnableL5EN As Adp8870TypeAlsEn
    Get
    Set
public:
property Adp8870TypeAlsEn MainALSComparatorLevelEnableL5EN {
    Adp8870TypeAlsEn get ();
    void set (Adp8870TypeAlsEn value);
}
member MainALSComparatorLevelEnableL5EN : Adp8870TypeAlsEn with get, set

Property Value

Type: Adp8870TypeAlsEn
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.MainALSComparatorStatusCMP1L2OUT Property

IRD

Adp8870MainALSComparatorStatusCMP1L2OUT Property

Main ALS Comparator Status: CMP1_L2_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MainALSComparatorStatusCMP1L2OUT { get; set; }
Public Property MainALSComparatorStatusCMP1L2OUT As Byte
    Get
    Set
public:
property unsigned char MainALSComparatorStatusCMP1L2OUT {
    unsigned char get ();
    void set (unsigned char value);
}
member MainALSComparatorStatusCMP1L2OUT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.MainALSComparatorStatusCMP1L3OUT Property

IRD

Adp8870MainALSComparatorStatusCMP1L3OUT Property

Main ALS Comparator Status: CMP1_L3_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MainALSComparatorStatusCMP1L3OUT { get; set; }
Public Property MainALSComparatorStatusCMP1L3OUT As Byte
    Get
    Set
public:
property unsigned char MainALSComparatorStatusCMP1L3OUT {
    unsigned char get ();
    void set (unsigned char value);
}
member MainALSComparatorStatusCMP1L3OUT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.MainALSComparatorStatusCMP1L4OUT Property

IRD

Adp8870MainALSComparatorStatusCMP1L4OUT Property

Main ALS Comparator Status: CMP1_L4_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MainALSComparatorStatusCMP1L4OUT { get; set; }
Public Property MainALSComparatorStatusCMP1L4OUT As Byte
    Get
    Set
public:
property unsigned char MainALSComparatorStatusCMP1L4OUT {
    unsigned char get ();
    void set (unsigned char value);
}
member MainALSComparatorStatusCMP1L4OUT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.MainALSComparatorStatusCMP1L5OUT Property

IRD

Adp8870MainALSComparatorStatusCMP1L5OUT Property

Main ALS Comparator Status: CMP1_L5_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MainALSComparatorStatusCMP1L5OUT { get; set; }
Public Property MainALSComparatorStatusCMP1L5OUT As Byte
    Get
    Set
public:
property unsigned char MainALSComparatorStatusCMP1L5OUT {
    unsigned char get ();
    void set (unsigned char value);
}
member MainALSComparatorStatusCMP1L5OUT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ManufacturerDeviceIDDeviceID Property

IRD

Adp8870ManufacturerDeviceIDDeviceID Property

Manufacturer & Device ID: Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerDeviceIDDeviceID { get; }
Public ReadOnly Property ManufacturerDeviceIDDeviceID As Byte
    Get
public:
property unsigned char ManufacturerDeviceIDDeviceID {
    unsigned char get ();
}
member ManufacturerDeviceIDDeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ManufacturerDeviceIDManufacturerID Property

IRD

Adp8870ManufacturerDeviceIDManufacturerID Property

Manufacturer & Device ID: Manufacturer ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerDeviceIDManufacturerID { get; }
Public ReadOnly Property ManufacturerDeviceIDManufacturerID As Byte
    Get
public:
property unsigned char ManufacturerDeviceIDManufacturerID {
    unsigned char get ();
}
member ManufacturerDeviceIDManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ModeControlBLEN Property

IRD

Adp8870ModeControlBLEN Property

Mode Control: BL_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeModeControlBlEn ModeControlBLEN { get; set; }
Public Property ModeControlBLEN As Adp8870TypeModeControlBlEn
    Get
    Set
public:
property Adp8870TypeModeControlBlEn ModeControlBLEN {
    Adp8870TypeModeControlBlEn get ();
    void set (Adp8870TypeModeControlBlEn value);
}
member ModeControlBLEN : Adp8870TypeModeControlBlEn with get, set

Property Value

Type: Adp8870TypeModeControlBlEn
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ModeControlCMPAUTOEN Property

IRD

Adp8870ModeControlCMPAUTOEN Property

Mode Control: CMP_AUTOEN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeModeControlCmpAutoen ModeControlCMPAUTOEN { get; set; }
Public Property ModeControlCMPAUTOEN As Adp8870TypeModeControlCmpAutoen
    Get
    Set
public:
property Adp8870TypeModeControlCmpAutoen ModeControlCMPAUTOEN {
    Adp8870TypeModeControlCmpAutoen get ();
    void set (Adp8870TypeModeControlCmpAutoen value);
}
member ModeControlCMPAUTOEN : Adp8870TypeModeControlCmpAutoen with get, set

Property Value

Type: Adp8870TypeModeControlCmpAutoen
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ModeControlD7ALSEN Property

IRD

Adp8870ModeControlD7ALSEN Property

Mode Control: D7ALS_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeModeControlD7alsEn ModeControlD7ALSEN { get; set; }
Public Property ModeControlD7ALSEN As Adp8870TypeModeControlD7alsEn
    Get
    Set
public:
property Adp8870TypeModeControlD7alsEn ModeControlD7ALSEN {
    Adp8870TypeModeControlD7alsEn get ();
    void set (Adp8870TypeModeControlD7alsEn value);
}
member ModeControlD7ALSEN : Adp8870TypeModeControlD7alsEn with get, set

Property Value

Type: Adp8870TypeModeControlD7alsEn
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ModeControlDIMEN Property

IRD

Adp8870ModeControlDIMEN Property

Mode Control: DIM_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeModeControlDimEn ModeControlDIMEN { get; set; }
Public Property ModeControlDIMEN As Adp8870TypeModeControlDimEn
    Get
    Set
public:
property Adp8870TypeModeControlDimEn ModeControlDIMEN {
    Adp8870TypeModeControlDimEn get ();
    void set (Adp8870TypeModeControlDimEn value);
}
member ModeControlDIMEN : Adp8870TypeModeControlDimEn with get, set

Property Value

Type: Adp8870TypeModeControlDimEn
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ModeControlGDWINDIS Property

IRD

Adp8870ModeControlGDWINDIS Property

Mode Control: GDWIN_DIS

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeModeControlGdwinDis ModeControlGDWINDIS { get; set; }
Public Property ModeControlGDWINDIS As Adp8870TypeModeControlGdwinDis
    Get
    Set
public:
property Adp8870TypeModeControlGdwinDis ModeControlGDWINDIS {
    Adp8870TypeModeControlGdwinDis get ();
    void set (Adp8870TypeModeControlGdwinDis value);
}
member ModeControlGDWINDIS : Adp8870TypeModeControlGdwinDis with get, set

Property Value

Type: Adp8870TypeModeControlGdwinDis
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ModeControlINTCFG Property

IRD

Adp8870ModeControlINTCFG Property

Mode Control: INT_CFG

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeModeControlIntCfg ModeControlINTCFG { get; set; }
Public Property ModeControlINTCFG As Adp8870TypeModeControlIntCfg
    Get
    Set
public:
property Adp8870TypeModeControlIntCfg ModeControlINTCFG {
    Adp8870TypeModeControlIntCfg get ();
    void set (Adp8870TypeModeControlIntCfg value);
}
member ModeControlINTCFG : Adp8870TypeModeControlIntCfg with get, set

Property Value

Type: Adp8870TypeModeControlIntCfg
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ModeControlNSTBY Property

IRD

Adp8870ModeControlNSTBY Property

Mode Control: nSTBY

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeModeControlNstby ModeControlNSTBY { get; set; }
Public Property ModeControlNSTBY As Adp8870TypeModeControlNstby
    Get
    Set
public:
property Adp8870TypeModeControlNstby ModeControlNSTBY {
    Adp8870TypeModeControlNstby get ();
    void set (Adp8870TypeModeControlNstby value);
}
member ModeControlNSTBY : Adp8870TypeModeControlNstby with get, set

Property Value

Type: Adp8870TypeModeControlNstby
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.ModeControlSISEN Property

IRD

Adp8870ModeControlSISEN Property

Mode Control: SIS_EN

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeModeControlSisEn ModeControlSISEN { get; set; }
Public Property ModeControlSISEN As Adp8870TypeModeControlSisEn
    Get
    Set
public:
property Adp8870TypeModeControlSisEn ModeControlSISEN {
    Adp8870TypeModeControlSisEn get ();
    void set (Adp8870TypeModeControlSisEn value);
}
member ModeControlSISEN : Adp8870TypeModeControlSisEn with get, set

Property Value

Type: Adp8870TypeModeControlSisEn
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.PWMEnableSelectionD1ENPWM Property

IRD

Adp8870PWMEnableSelectionD1ENPWM Property

PWM Enable Selection: D1ENPWM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypePwmled PWMEnableSelectionD1ENPWM { get; set; }
Public Property PWMEnableSelectionD1ENPWM As Adp8870TypePwmled
    Get
    Set
public:
property Adp8870TypePwmled PWMEnableSelectionD1ENPWM {
    Adp8870TypePwmled get ();
    void set (Adp8870TypePwmled value);
}
member PWMEnableSelectionD1ENPWM : Adp8870TypePwmled with get, set

Property Value

Type: Adp8870TypePwmled
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.PWMEnableSelectionD2ENPWM Property

IRD

Adp8870PWMEnableSelectionD2ENPWM Property

PWM Enable Selection: D2ENPWM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypePwmled PWMEnableSelectionD2ENPWM { get; set; }
Public Property PWMEnableSelectionD2ENPWM As Adp8870TypePwmled
    Get
    Set
public:
property Adp8870TypePwmled PWMEnableSelectionD2ENPWM {
    Adp8870TypePwmled get ();
    void set (Adp8870TypePwmled value);
}
member PWMEnableSelectionD2ENPWM : Adp8870TypePwmled with get, set

Property Value

Type: Adp8870TypePwmled
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.PWMEnableSelectionD3ENPWM Property

IRD

Adp8870PWMEnableSelectionD3ENPWM Property

PWM Enable Selection: D3ENPWM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypePwmled PWMEnableSelectionD3ENPWM { get; set; }
Public Property PWMEnableSelectionD3ENPWM As Adp8870TypePwmled
    Get
    Set
public:
property Adp8870TypePwmled PWMEnableSelectionD3ENPWM {
    Adp8870TypePwmled get ();
    void set (Adp8870TypePwmled value);
}
member PWMEnableSelectionD3ENPWM : Adp8870TypePwmled with get, set

Property Value

Type: Adp8870TypePwmled
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.PWMEnableSelectionD4ENPWM Property

IRD

Adp8870PWMEnableSelectionD4ENPWM Property

PWM Enable Selection: D4ENPWM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypePwmled PWMEnableSelectionD4ENPWM { get; set; }
Public Property PWMEnableSelectionD4ENPWM As Adp8870TypePwmled
    Get
    Set
public:
property Adp8870TypePwmled PWMEnableSelectionD4ENPWM {
    Adp8870TypePwmled get ();
    void set (Adp8870TypePwmled value);
}
member PWMEnableSelectionD4ENPWM : Adp8870TypePwmled with get, set

Property Value

Type: Adp8870TypePwmled
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.PWMEnableSelectionD5ENPWM Property

IRD

Adp8870PWMEnableSelectionD5ENPWM Property

PWM Enable Selection: D5ENPWM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypePwmled PWMEnableSelectionD5ENPWM { get; set; }
Public Property PWMEnableSelectionD5ENPWM As Adp8870TypePwmled
    Get
    Set
public:
property Adp8870TypePwmled PWMEnableSelectionD5ENPWM {
    Adp8870TypePwmled get ();
    void set (Adp8870TypePwmled value);
}
member PWMEnableSelectionD5ENPWM : Adp8870TypePwmled with get, set

Property Value

Type: Adp8870TypePwmled
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.PWMEnableSelectionD6ENPWM Property

IRD

Adp8870PWMEnableSelectionD6ENPWM Property

PWM Enable Selection: D6ENPWM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypePwmled PWMEnableSelectionD6ENPWM { get; set; }
Public Property PWMEnableSelectionD6ENPWM As Adp8870TypePwmled
    Get
    Set
public:
property Adp8870TypePwmled PWMEnableSelectionD6ENPWM {
    Adp8870TypePwmled get ();
    void set (Adp8870TypePwmled value);
}
member PWMEnableSelectionD6ENPWM : Adp8870TypePwmled with get, set

Property Value

Type: Adp8870TypePwmled
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.PWMEnableSelectionD7ENPWM Property

IRD

Adp8870PWMEnableSelectionD7ENPWM Property

PWM Enable Selection: D7ENPWM

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypePwmled PWMEnableSelectionD7ENPWM { get; set; }
Public Property PWMEnableSelectionD7ENPWM As Adp8870TypePwmled
    Get
    Set
public:
property Adp8870TypePwmled PWMEnableSelectionD7ENPWM {
    Adp8870TypePwmled get ();
    void set (Adp8870TypePwmled value);
}
member PWMEnableSelectionD7ENPWM : Adp8870TypePwmled with get, set

Property Value

Type: Adp8870TypePwmled
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SecondALSComparatorStatusCMP2L2OUT Property

IRD

Adp8870SecondALSComparatorStatusCMP2L2OUT Property

Second ALS Comparator Status: CMP2_L2_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SecondALSComparatorStatusCMP2L2OUT { get; set; }
Public Property SecondALSComparatorStatusCMP2L2OUT As Byte
    Get
    Set
public:
property unsigned char SecondALSComparatorStatusCMP2L2OUT {
    unsigned char get ();
    void set (unsigned char value);
}
member SecondALSComparatorStatusCMP2L2OUT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SecondALSComparatorStatusCMP2L3OUT Property

IRD

Adp8870SecondALSComparatorStatusCMP2L3OUT Property

Second ALS Comparator Status: CMP2_L3_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SecondALSComparatorStatusCMP2L3OUT { get; set; }
Public Property SecondALSComparatorStatusCMP2L3OUT As Byte
    Get
    Set
public:
property unsigned char SecondALSComparatorStatusCMP2L3OUT {
    unsigned char get ();
    void set (unsigned char value);
}
member SecondALSComparatorStatusCMP2L3OUT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SecondALSComparatorStatusCMP2L4OUT Property

IRD

Adp8870SecondALSComparatorStatusCMP2L4OUT Property

Second ALS Comparator Status: CMP2_L4_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SecondALSComparatorStatusCMP2L4OUT { get; set; }
Public Property SecondALSComparatorStatusCMP2L4OUT As Byte
    Get
    Set
public:
property unsigned char SecondALSComparatorStatusCMP2L4OUT {
    unsigned char get ();
    void set (unsigned char value);
}
member SecondALSComparatorStatusCMP2L4OUT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SecondALSComparatorStatusCMP2L5OUT Property

IRD

Adp8870SecondALSComparatorStatusCMP2L5OUT Property

Second ALS Comparator Status: CMP2_L5_OUT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SecondALSComparatorStatusCMP2L5OUT { get; set; }
Public Property SecondALSComparatorStatusCMP2L5OUT As Byte
    Get
    Set
public:
property unsigned char SecondALSComparatorStatusCMP2L5OUT {
    unsigned char get ();
    void set (unsigned char value);
}
member SecondALSComparatorStatusCMP2L5OUT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SecondaryALSComparatorLevelEnableL2EN2 Property

IRD

Adp8870SecondaryALSComparatorLevelEnableL2EN2 Property

Secondary ALS Comparator Level Enable: L2_EN2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeAlsEn SecondaryALSComparatorLevelEnableL2EN2 { get; set; }
Public Property SecondaryALSComparatorLevelEnableL2EN2 As Adp8870TypeAlsEn
    Get
    Set
public:
property Adp8870TypeAlsEn SecondaryALSComparatorLevelEnableL2EN2 {
    Adp8870TypeAlsEn get ();
    void set (Adp8870TypeAlsEn value);
}
member SecondaryALSComparatorLevelEnableL2EN2 : Adp8870TypeAlsEn with get, set

Property Value

Type: Adp8870TypeAlsEn
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SecondaryALSComparatorLevelEnableL3EN2 Property

IRD

Adp8870SecondaryALSComparatorLevelEnableL3EN2 Property

Secondary ALS Comparator Level Enable: L3_EN2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeAlsEn SecondaryALSComparatorLevelEnableL3EN2 { get; set; }
Public Property SecondaryALSComparatorLevelEnableL3EN2 As Adp8870TypeAlsEn
    Get
    Set
public:
property Adp8870TypeAlsEn SecondaryALSComparatorLevelEnableL3EN2 {
    Adp8870TypeAlsEn get ();
    void set (Adp8870TypeAlsEn value);
}
member SecondaryALSComparatorLevelEnableL3EN2 : Adp8870TypeAlsEn with get, set

Property Value

Type: Adp8870TypeAlsEn
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SecondaryALSComparatorLevelEnableL4EN2 Property

IRD

Adp8870SecondaryALSComparatorLevelEnableL4EN2 Property

Secondary ALS Comparator Level Enable: L4_EN2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeAlsEn SecondaryALSComparatorLevelEnableL4EN2 { get; set; }
Public Property SecondaryALSComparatorLevelEnableL4EN2 As Adp8870TypeAlsEn
    Get
    Set
public:
property Adp8870TypeAlsEn SecondaryALSComparatorLevelEnableL4EN2 {
    Adp8870TypeAlsEn get ();
    void set (Adp8870TypeAlsEn value);
}
member SecondaryALSComparatorLevelEnableL4EN2 : Adp8870TypeAlsEn with get, set

Property Value

Type: Adp8870TypeAlsEn
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SecondaryALSComparatorLevelEnableL5EN2 Property

IRD

Adp8870SecondaryALSComparatorLevelEnableL5EN2 Property

Secondary ALS Comparator Level Enable: L5_EN2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeAlsEn SecondaryALSComparatorLevelEnableL5EN2 { get; set; }
Public Property SecondaryALSComparatorLevelEnableL5EN2 As Adp8870TypeAlsEn
    Get
    Set
public:
property Adp8870TypeAlsEn SecondaryALSComparatorLevelEnableL5EN2 {
    Adp8870TypeAlsEn get ();
    void set (Adp8870TypeAlsEn value);
}
member SecondaryALSComparatorLevelEnableL5EN2 : Adp8870TypeAlsEn with get, set

Property Value

Type: Adp8870TypeAlsEn
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SecondPhototransistorPH2LEV Property

IRD

Adp8870SecondPhototransistorPH2LEV Property

Second Phototransistor: PH2LEV

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort SecondPhototransistorPH2LEV { get; }
Public ReadOnly Property SecondPhototransistorPH2LEV As UShort
    Get
public:
property unsigned short SecondPhototransistorPH2LEV {
    unsigned short get ();
}
member SecondPhototransistorPH2LEV : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SinkCurrentLED1SCD1 Property

IRD

Adp8870SinkCurrentLED1SCD1 Property

Sink Current LED 1: SCD1 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl SinkCurrentLED1SCD1 { get; set; }
Public Property SinkCurrentLED1SCD1 As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl SinkCurrentLED1SCD1 {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member SinkCurrentLED1SCD1 : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SinkCurrentLED2SCD2 Property

IRD

Adp8870SinkCurrentLED2SCD2 Property

Sink Current LED 2: SCD2 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl SinkCurrentLED2SCD2 { get; set; }
Public Property SinkCurrentLED2SCD2 As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl SinkCurrentLED2SCD2 {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member SinkCurrentLED2SCD2 : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SinkCurrentLED3SCD3 Property

IRD

Adp8870SinkCurrentLED3SCD3 Property

Sink Current LED 3: SCD3 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl SinkCurrentLED3SCD3 { get; set; }
Public Property SinkCurrentLED3SCD3 As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl SinkCurrentLED3SCD3 {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member SinkCurrentLED3SCD3 : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SinkCurrentLED4SCD4 Property

IRD

Adp8870SinkCurrentLED4SCD4 Property

Sink Current LED 4: SCD4 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl SinkCurrentLED4SCD4 { get; set; }
Public Property SinkCurrentLED4SCD4 As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl SinkCurrentLED4SCD4 {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member SinkCurrentLED4SCD4 : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SinkCurrentLED5SCD5 Property

IRD

Adp8870SinkCurrentLED5SCD5 Property

Sink Current LED 5: SCD5 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl SinkCurrentLED5SCD5 { get; set; }
Public Property SinkCurrentLED5SCD5 As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl SinkCurrentLED5SCD5 {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member SinkCurrentLED5SCD5 : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SinkCurrentLED6SCD6 Property

IRD

Adp8870SinkCurrentLED6SCD6 Property

Sink Current LED 6: SCD6 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl SinkCurrentLED6SCD6 { get; set; }
Public Property SinkCurrentLED6SCD6 As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl SinkCurrentLED6SCD6 {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member SinkCurrentLED6SCD6 : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SinkCurrentLED7BrightnessLevel2SCD7L2 Property

IRD

Adp8870SinkCurrentLED7BrightnessLevel2SCD7L2 Property

Sink Current LED 7 Brightness Level 2: SCD7_L2 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl SinkCurrentLED7BrightnessLevel2SCD7L2 { get; set; }
Public Property SinkCurrentLED7BrightnessLevel2SCD7L2 As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl SinkCurrentLED7BrightnessLevel2SCD7L2 {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member SinkCurrentLED7BrightnessLevel2SCD7L2 : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SinkCurrentLED7BrightnessLevel2SCD7L3 Property

IRD

Adp8870SinkCurrentLED7BrightnessLevel2SCD7L3 Property

Sink Current LED 7 Brightness Level 2: SCD7_L3 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl SinkCurrentLED7BrightnessLevel2SCD7L3 { get; set; }
Public Property SinkCurrentLED7BrightnessLevel2SCD7L3 As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl SinkCurrentLED7BrightnessLevel2SCD7L3 {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member SinkCurrentLED7BrightnessLevel2SCD7L3 : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SinkCurrentLED7BrightnessLevel2SCD7L4 Property

IRD

Adp8870SinkCurrentLED7BrightnessLevel2SCD7L4 Property

Sink Current LED 7 Brightness Level 2: SCD7_L4 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl SinkCurrentLED7BrightnessLevel2SCD7L4 { get; set; }
Public Property SinkCurrentLED7BrightnessLevel2SCD7L4 As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl SinkCurrentLED7BrightnessLevel2SCD7L4 {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member SinkCurrentLED7BrightnessLevel2SCD7L4 : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SinkCurrentLED7BrightnessLevel2SCD7L5 Property

IRD

Adp8870SinkCurrentLED7BrightnessLevel2SCD7L5 Property

Sink Current LED 7 Brightness Level 2: SCD7_L5 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl SinkCurrentLED7BrightnessLevel2SCD7L5 { get; set; }
Public Property SinkCurrentLED7BrightnessLevel2SCD7L5 As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl SinkCurrentLED7BrightnessLevel2SCD7L5 {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member SinkCurrentLED7BrightnessLevel2SCD7L5 : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SinkCurrentLED7SCD7 Property

IRD

Adp8870SinkCurrentLED7SCD7 Property

Sink Current LED 7: SCD7 (unit: mA)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeBl SinkCurrentLED7SCD7 { get; set; }
Public Property SinkCurrentLED7SCD7 As Adp8870TypeBl
    Get
    Set
public:
property Adp8870TypeBl SinkCurrentLED7SCD7 {
    Adp8870TypeBl get ();
    void set (Adp8870TypeBl value);
}
member SinkCurrentLED7SCD7 : Adp8870TypeBl with get, set

Property Value

Type: Adp8870TypeBl
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.SinkCurrentLED7SCR Property

IRD

Adp8870SinkCurrentLED7SCR Property

Sink Current LED 7: SCR

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adp8870TypeIsc7Scr SinkCurrentLED7SCR { get; set; }
Public Property SinkCurrentLED7SCR As Adp8870TypeIsc7Scr
    Get
    Set
public:
property Adp8870TypeIsc7Scr SinkCurrentLED7SCR {
    Adp8870TypeIsc7Scr get ();
    void set (Adp8870TypeIsc7Scr value);
}
member SinkCurrentLED7SCR : Adp8870TypeIsc7Scr with get, set

Property Value

Type: Adp8870TypeIsc7Scr
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870 Methods

The Adp8870 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.Flush Method

IRD

Adp8870Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adp8870 Class
telos.Ird.AnalogDevices Namespace


Adp8870.TypeAlsEn Enumeration

IRD

Adp8870TypeAlsEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlsEn
Public Enumeration TypeAlsEn
public enum class TypeAlsEn
type TypeAlsEn
Members
Member name | Value | Description
Enabled | 1 | Enabled
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeBl Enumeration

IRD

Adp8870TypeBl Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBl
Public Enumeration TypeBl
public enum class TypeBl
type TypeBl
Members
Member name | Value | Description
Value_0_000 | 0 | 0.000
Value_0_002 | 1 | 0.002
Value_0_007 | 2 | 0.007
Value_0_017 | 3 | 0.017
Value_0_030 | 4 | 0.030
Value_0_047 | 5 | 0.047
Value_0_067 | 6 | 0.067
Value_0_091 | 7 | 0.091
Value_0_119 | 8 | 0.119
Value_0_151 | 9 | 0.151
Value_0_186 | 10 | 0.186
Value_0_225 | 11 | 0.225
Value_0_268 | 12 | 0.268
Value_0_314 | 13 | 0.314
Value_0_365 | 14 | 0.365
Value_0_419 | 15 | 0.419
Value_0_476 | 16 | 0.476
Value_0_538 | 17 | 0.538
Value_0_603 | 18 | 0.603
Value_0_671 | 19 | 0.671
Value_0_744 | 20 | 0.744
Value_0_820 | 21 | 0.820
Value_0_900 | 22 | 0.900
Value_0_984 | 23 | 0.984
Value_1_071 | 24 | 1.071
Value_1_163 | 25 | 1.163
Value_1_257 | 26 | 1.257
Value_1_356 | 27 | 1.356
Value_1_458 | 28 | 1.458
Value_1_564 | 29 | 1.564
Value_1_674 | 30 | 1.674
Value_1_787 | 31 | 1.787
Value_1_905 | 32 | 1.905
Value_2_026 | 33 | 2.026
Value_2_150 | 34 | 2.150
Value_2_279 | 35 | 2.279
Value_2_411 | 36 | 2.411
Value_2_546 | 37 | 2.546
Value_2_686 | 38 | 2.686
Value_2_829 | 39 | 2.829
Value_2_976 | 40 | 2.976
Value_3_127 | 41 | 3.127
Value_3_281 | 42 | 3.281
Value_3_439 | 43 | 3.439
Value_3_601 | 44 | 3.601
Value_3_767 | 45 | 3.767
Value_3_936 | 46 | 3.936
Value_4_109 | 47 | 4.109
Value_4_285 | 48 | 4.285
Value_4_466 | 49 | 4.466
Value_4_650 | 50 | 4.650
Value_4_838 | 51 | 4.838
Value_5_029 | 52 | 5.029
Value_5_225 | 53 | 5.225
Value_5_424 | 54 | 5.424
Value_5_627 | 55 | 5.627
Value_5_833 | 56 | 5.833
Value_6_043 | 57 | 6.043
Value_6_257 | 58 | 6.257
Value_6_475 | 59 | 6.475
Value_6_696 | 60 | 6.696
Value_6_921 | 61 | 6.921
Value_7_150 | 62 | 7.150
Value_7_382 | 63 | 7.382
Value_7_619 | 64 | 7.619
Value_7_859 | 65 | 7.859
Value_8_102 | 66 | 8.102
Value_8_350 | 67 | 8.350
Value_8_601 | 68 | 8.601
Value_8_855 | 69 | 8.855
Value_9_114 | 70 | 9.114
Value_9_376 | 71 | 9.376
Value_9_642 | 72 | 9.642
Value_9_912 | 73 | 9.912
Value_10_185 | 74 | 10.185
Value_10_463 | 75 | 10.463
Value_10_743 | 76 | 10.743
Value_11_028 | 77 | 11.028
Value_11_316 | 78 | 11.316
Value_11_608 | 79 | 11.608
Value_11_904 | 80 | 11.904
Value_12_203 | 81 | 12.203
Value_12_507 | 82 | 12.507
Value_12_814 | 83 | 12.814
Value_13_124 | 84 | 13.124
Value_13_439 | 85 | 13.439
Value_13_757 | 86 | 13.757
Value_14_078 | 87 | 14.078
Value_14_404 | 88 | 14.404
Value_14_733 | 89 | 14.733
Value_15_066 | 90 | 15.066
Value_15_403 | 91 | 15.403
Value_15_743 | 92 | 15.743
Value_16_087 | 93 | 16.087
Value_16_435 | 94 | 16.435
Value_16_787 | 95 | 16.787
Value_17_142 | 96 | 17.142
Value_17_501 | 97 | 17.501
Value_17_863 | 98 | 17.863
Value_18_230 | 99 | 18.230
Value_18_600 | 100 | 18.600
Value_18_974 | 101 | 18.974
Value_19_351 | 102 | 19.351
Value_19_733 | 103 | 19.733
Value_20_118 | 104 | 20.118
Value_20_507 | 105 | 20.507
Value_20_899 | 106 | 20.899
Value_21_295 | 107 | 21.295
Value_21_695 | 108 | 21.695
Value_22_099 | 109 | 22.099
Value_22_506 | 110 | 22.506
Value_22_917 | 111 | 22.917
Value_23_332 | 112 | 23.332
Value_23_750 | 113 | 23.750
Value_24_173 | 114 | 24.173
Value_24_599 | 115 | 24.599
Value_25_028 | 116 | 25.028
Value_25_462 | 117 | 25.462
Value_25_899 | 118 | 25.899
Value_26_340 | 119 | 26.340
Value_26_784 | 120 | 26.784
Value_27_232 | 121 | 27.232
Value_27_684 | 122 | 27.684
Value_28_140 | 123 | 28.140
Value_28_599 | 124 | 28.599
Value_29_063 | 125 | 29.063
Value_29_592 | 126 | 29.592
Value_30_000 | 127 | 30.000
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeBlfr Enumeration

IRD

Adp8870TypeBlfr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBlfr
Public Enumeration TypeBlfr
public enum class TypeBlfr
type TypeBlfr
Members
Member name | Value | Description
Value_01Sec | 0 | 0.1 sec
Value_03Sec | 1 | 0.3 sec
Value_06Sec | 2 | 0.6 sec
Value_09Sec | 3 | 0.9 sec
Value_12Sec | 4 | 1.2 sec
Value_15Sec | 5 | 1.5 sec
Value_18Sec | 6 | 1.8 sec
Value_21Sec | 7 | 2.1 sec
Value_24Sec | 8 | 2.4 sec
Value_27Sec | 9 | 2.7 sec
Value_30Sec | 10 | 3.0 sec
Value_35Sec | 11 | 3.5 sec
Value_40Sec | 12 | 4.0 sec
Value_45Sec | 13 | 4.5 sec
Value_50Sec | 14 | 5.0 sec
Value_55Sec | 15 | 5.5 sec
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeBlsel Enumeration

IRD

Adp8870TypeBlsel Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBlsel
Public Enumeration TypeBlsel
public enum class TypeBlsel
type TypeBlsel
Members
Member name | Value | Description
IndependentSink | 1 | Independent Sink
SinkConnectedToBacklightEnableBLEN | 0 | Sink Connected To Backlight Enable (BL_EN)
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeCfgrBlLaw Enumeration

IRD

Adp8870TypeCfgrBlLaw Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgrBlLaw
Public Enumeration TypeCfgrBlLaw
public enum class TypeCfgrBlLaw
type TypeCfgrBlLaw
Members
Member name | Value | Description
SquareLawDACLinearTimeSteps | 0 | Square Law DAC, Linear Time Steps
SquareLawDACNonlinearTimeStepsCubic10 | 2 | Square Law DAC, Nonlinear Time Steps (Cubic 10)
SquareLawDACNonlinearTimeStepsCubic11 | 3 | Square Law DAC, Nonlinear Time Steps (Cubic 11)
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeCfgrBlv Enumeration

IRD

Adp8870TypeCfgrBlv Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgrBlv
Public Enumeration TypeCfgrBlv
public enum class TypeCfgrBlv
type TypeCfgrBlv
Members
Member name | Value | Description
Level1Daylight | 0 | Level 1 (Daylight)
Level2Bright | 1 | Level 2 (Bright)
Level3Office | 2 | Level 3 (Office)
Level4Indoor | 3 | Level 4 (Indoor)
Level5Dark | 4 | Level 5 (Dark)
Disabled | 5 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeCfgrCmp2Sel Enumeration

IRD

Adp8870TypeCfgrCmp2Sel Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgrCmp2Sel
Public Enumeration TypeCfgrCmp2Sel
public enum class TypeCfgrCmp2Sel
type TypeCfgrCmp2Sel
Members
Member name | Value | Description
Value_2ndPhototransistorEnabledD6CurrentSinkDisabled | 1 | 2nd Phototransistor: Enabled / D6 Current Sink: Disabled
Value_2ndPhototransistorDisabledD6CurrentSinkEnabled | 0 | 2nd Phototransistor: Disabled / D6 Current Sink: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeCfgrFovr Enumeration

IRD

Adp8870TypeCfgrFovr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgrFovr
Public Enumeration TypeCfgrFovr
public enum class TypeCfgrFovr
type TypeCfgrFovr
Members
Member name | Value | Description
BacklightFadeOverrideEnabled | 1 | Backlight Fade Override: Enabled
BacklightFadeOverrideDisabled | 0 | Backlight Fade Override: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeCfgrSelAb Enumeration

IRD

Adp8870TypeCfgrSelAb Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCfgrSelAb
Public Enumeration TypeCfgrSelAb
public enum class TypeCfgrSelAb
type TypeCfgrSelAb
Members
Member name | Value | Description
CMPIN2 | 1 | CMP_IN2
CMPIN | 0 | CMP_IN
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeCmpCtlFilt Enumeration

IRD

Adp8870TypeCmpCtlFilt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCmpCtlFilt
Public Enumeration TypeCmpCtlFilt
public enum class TypeCmpCtlFilt
type TypeCmpCtlFilt
Members
Member name | Value | Description
Value_80Ms | 0 | 80 ms
Value_160Ms | 1 | 160 ms
Value_320Ms | 2 | 320 ms
Value_640Ms | 3 | 640 ms
Value_1280Ms | 4 | 1280 ms
Value_2560Ms | 5 | 2560 ms
Value_5120Ms | 6 | 5120 ms
Value_10240Ms | 7 | 10240 ms
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeCmpForceRd Enumeration

IRD

Adp8870TypeCmpForceRd Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCmpForceRd
Public Enumeration TypeCmpForceRd
public enum class TypeCmpForceRd
type TypeCmpForceRd
Members
Member name | Value | Description
ForceRead | 1 | Force Read
Default | 0 | Default
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeIntEn Enumeration

IRD

Adp8870TypeIntEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEn
Public Enumeration TypeIntEn
public enum class TypeIntEn
type TypeIntEn
Members
Member name | Value | Description
Enabled | 1 | Enabled
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeIntStat Enumeration

IRD

Adp8870TypeIntStat Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntStat
Public Enumeration TypeIntStat
public enum class TypeIntStat
type TypeIntStat
Members
Member name | Value | Description
Set | 1 | Set
NotSet | 0 | Not Set
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeIsc7Scr Enumeration

IRD

Adp8870TypeIsc7Scr Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIsc7Scr
Public Enumeration TypeIsc7Scr
public enum class TypeIsc7Scr
type TypeIsc7Scr
Members
Member name | Value | Description
SinkCurrent1 | 1 | Sink Current 1
SinkCurrent0 | 0 | Sink Current 0
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeIscc Enumeration

IRD

Adp8870TypeIscc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIscc
Public Enumeration TypeIscc
public enum class TypeIscc
type TypeIscc
Members
Member name | Value | Description
TurnedOn | 1 | Turned On
TurnedOff | 0 | Turned Off
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeIscf Enumeration

IRD

Adp8870TypeIscf Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIscf
Public Enumeration TypeIscf
public enum class TypeIscf
type TypeIscf
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_030Sec | 1 | 0.30 sec
Value_060Sec | 2 | 0.60 sec
Value_090Sec | 3 | 0.90 sec
Value_12Sec | 4 | 1.2 sec
Value_15Sec | 5 | 1.5 sec
Value_18Sec | 6 | 1.8 sec
Value_21Sec | 7 | 2.1 sec
Value_24Sec | 8 | 2.4 sec
Value_27Sec | 9 | 2.7 sec
Value_30Sec | 10 | 3.0 sec
Value_35Sec | 11 | 3.5 sec
Value_40Sec | 12 | 4.0 sec
Value_45Sec | 13 | 4.5 sec
Value_50Sec | 14 | 5.0 sec
Value_55Sec | 15 | 5.5 sec
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeIsclaw Enumeration

IRD

Adp8870TypeIsclaw Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIsclaw
Public Enumeration TypeIsclaw
public enum class TypeIsclaw
type TypeIsclaw
Members
Member name | Value | Description
SquareLawDACLinearTimeSteps | 0 | Square Law DAC, Linear Time Steps
SquareLawDACNonlinearTimeStepsCubic10 | 2 | Square Law DAC, Nonlinear Time Steps (Cubic 10)
SquareLawDACNonlinearTimeStepsCubic11 | 3 | Square Law DAC, Nonlinear Time Steps (Cubic 11)
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeIsctScoff Enumeration

IRD

Adp8870TypeIsctScoff Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIsctScoff
Public Enumeration TypeIsctScoff
public enum class TypeIsctScoff
type TypeIsctScoff
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_06Sec | 1 | 0.6 sec
Value_12Sec | 2 | 1.2 sec
Value_18Sec | 3 | 1.8 sec
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeIsctScon Enumeration

IRD

Adp8870TypeIsctScon Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIsctScon
Public Enumeration TypeIsctScon
public enum class TypeIsctScon
type TypeIsctScon
Members
Member name | Value | Description
Value_02Sec | 0 | 0.2 sec
Value_06Sec | 1 | 0.6 sec
Value_08Sec | 2 | 0.8 sec
Value_12Sec | 3 | 1.2 sec
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeModeControlBlEn Enumeration

IRD

Adp8870TypeModeControlBlEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlBlEn
Public Enumeration TypeModeControlBlEn
public enum class TypeModeControlBlEn
type TypeModeControlBlEn
Members
Member name | Value | Description
BacklightEnabled | 1 | Backlight: Enabled
BacklightDisabled | 0 | Backlight: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeModeControlCmpAutoen Enumeration

IRD

Adp8870TypeModeControlCmpAutoen Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlCmpAutoen
Public Enumeration TypeModeControlCmpAutoen
public enum class TypeModeControlCmpAutoen
type TypeModeControlCmpAutoen
Members
Member name | Value | Description
Enabled | 1 | Enabled
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeModeControlD7alsEn Enumeration

IRD

Adp8870TypeModeControlD7alsEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlD7alsEn
Public Enumeration TypeModeControlD7alsEn
public enum class TypeModeControlD7alsEn
type TypeModeControlD7alsEn
Members
Member name | Value | Description
ALSControlOfD7Enabled | 1 | ALS Control of D7: Enabled
ALSControlOfD7Disabled | 0 | ALS Control of D7: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeModeControlDimEn Enumeration

IRD

Adp8870TypeModeControlDimEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlDimEn
Public Enumeration TypeModeControlDimEn
public enum class TypeModeControlDimEn
type TypeModeControlDimEn
Members
Member name | Value | Description
DIMEnabled | 1 | DIM: Enabled
DIMDisabled | 0 | DIM: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeModeControlGdwinDis Enumeration

IRD

Adp8870TypeModeControlGdwinDis Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlGdwinDis
Public Enumeration TypeModeControlGdwinDis
public enum class TypeModeControlGdwinDis
type TypeModeControlGdwinDis
Members
Member name | Value | Description
SwitchDownUpNotAutomatically | 1 | Switch Down/Up: Not Automatically
SwitchDownUpAutomatically | 0 | Switch Down/Up: Automatically
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeModeControlIntCfg Enumeration

IRD

Adp8870TypeModeControlIntCfg Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlIntCfg
Public Enumeration TypeModeControlIntCfg
public enum class TypeModeControlIntCfg
type TypeModeControlIntCfg
Members
Member name | Value | Description
IRQDessertedFor50Us | 1 | IRQ: Desserted for 50 µs
IRQRemainsAsserted | 0 | IRQ: Remains Asserted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeModeControlNstby Enumeration

IRD

Adp8870TypeModeControlNstby Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlNstby
Public Enumeration TypeModeControlNstby
public enum class TypeModeControlNstby
type TypeModeControlNstby
Members
Member name | Value | Description
NormalMode | 1 | Normal Mode
Standby | 0 | Standby
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypeModeControlSisEn Enumeration

IRD

Adp8870TypeModeControlSisEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlSisEn
Public Enumeration TypeModeControlSisEn
public enum class TypeModeControlSisEn
type TypeModeControlSisEn
Members
Member name | Value | Description
Enabled | 1 | Enabled
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adp8870.TypePwmled Enumeration

IRD

Adp8870TypePwmled Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePwmled
Public Enumeration TypePwmled
public enum class TypePwmled
type TypePwmled
Members
Member name | Value | Description
PWMEnabled | 1 | PWM: Enabled
PWMDisabled | 0 | PWM: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316 Class

Analog Devices: ADT 7316
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdt7316

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adt7316
Public Class Adt7316
public ref class Adt7316
type Adt7316 =  class end

The Adt7316 type exposes the following members.

Constructors
 | Name | Description
Public method | Adt7316 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlConfiguration1INTOutput | Control Configuration 1: INT Output
Public property | ControlConfiguration1INTOutputPolarity | Control Configuration 1: INT Output Polarity
Public property | ControlConfiguration1Monitoring | Control Configuration 1: Monitoring
Public property | ControlConfiguration1PowerDown | Control Configuration 1: Power Down
Public property | ControlConfiguration2Averaging | Control Configuration 2: Averaging
Public property | ControlConfiguration2ChannelSelection | Control Configuration 2: Channel Selection
Public property | ControlConfiguration2Conversion | Control Configuration 2: Conversion
Public property | ControlConfiguration2SMBusTimeout | Control Configuration 2: SMBus Timeout
Public property | ControlConfiguration2SoftwareReset | Control Configuration 2: Software Reset
Public property | ControlConfiguration3DACAOutputProportionalToInternalTemperature | Control Configuration 3: DAC A Output Proportional To Internal Temperature
Public property | ControlConfiguration3DACBOutputProportionalToExternalTemperature | Control Configuration 3: DAC B Output Proportional To External Temperature
Public property | ControlConfiguration3Resolution | Control Configuration 3: Resolution
Public property | ControlConfiguration3Speed | Control Configuration 3: Speed
Public property | ControlConfiguration3UpdatingOfDACOutputs | Control Configuration 3: Updating of DAC Outputs
Public property | DACA | DAC A
Public property | DACB | DAC B
Public property | DACC | DAC C
Public property | DACConfigurationOutputRangeDACA | DAC Configuration: Output Range DAC A
Public property | DACConfigurationOutputRangeDACB | DAC Configuration: Output Range DAC B
Public property | DACConfigurationOutputRangeDACC | DAC Configuration: Output Range DAC C
Public property | DACConfigurationOutputRangeDACD | DAC Configuration: Output Range DAC D
Public property | DACConfigurationUpdate | DAC Configuration: Update
Public property | DACConfigurationVREFBypassDACAB | DAC Configuration: V_REF Bypass DAC A / B
Public property | DACConfigurationVREFBypassDACCD | DAC Configuration: V_REF Bypass DAC C / D
Public property | DACD | DAC D
Public property | DeviceID | Device ID
Public property | ExternalAnalogTemperatureOffset | External Analog Temperature Offset (unit: °C)
Public property | ExternalTemperature | External Temperature (unit: °C)
Public property | ExternalTemperatureOffset | External Temperature Offset (unit: °C)
Public property | ExternalTHIGHLimit | External T_HIGH Limit (unit: °C)
Public property | ExternalTLOWLimit | External T_LOW Limit (unit: °C)
Public property | InternalAnalogTemperatureOffset | Internal Analog Temperature Offset (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | InternalTemperatureOffset | Internal Temperature Offset (unit: °C)
Public property | InternalTHIGHLimit | Internal T_HIGH Limit (unit: °C)
Public property | InternalTLOWLimit | Internal T_LOW Limit (unit: °C)
Public property | InterruptMask1ExternalTemperatureFault | Interrupt Mask 1: External Temperature Fault
Public property | InterruptMask1ExternalTHIGH | Interrupt Mask 1: External T_HIGH
Public property | InterruptMask1ExternalTLOW | Interrupt Mask 1: External T_LOW
Public property | InterruptMask1InternalTHIGH | Interrupt Mask 1: Internal T_HIGH
Public property | InterruptMask1InternalTLOW | Interrupt Mask 1: Internal T_LOW
Public property | InterruptMask2VDD | Interrupt Mask 2: V_DD
Public property | InterruptStatus1ExternalSensorFault | Interrupt Status 1: External Sensor Fault
Public property | InterruptStatus1TEXTTHIGH | Interrupt Status 1: T_EXT > T_HIGH
Public property | InterruptStatus1TEXTTLOW | Interrupt Status 1: T_EXT <= T_LOW
Public property | InterruptStatus1TINTTHIGH | Interrupt Status 1: T_INT > T_HIGH
Public property | InterruptStatus1TINTTLOW | Interrupt Status 1: T_INT <= T_LOW
Public property | InterruptStatus2VDDVHIGHVDDVLOW | Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW
Public property | LDACConfigurationDACA | LDAC Configuration: DAC A
Public property | LDACConfigurationDACB | LDAC Configuration: DAC B
Public property | LDACConfigurationDACC | LDAC Configuration: DAC C
Public property | LDACConfigurationDACD | LDAC Configuration: DAC D
Public property | ManufacturerSID | Manufacturer's ID
Public property | SiliconRevisionStepping | Silicon Revision: Stepping
Public property | SiliconRevisionVersion | Silicon Revision: Version
Public property | SPILockStatus | SPI Lock Status
Public property | VDD | V_DD (unit: V)
Public property | VDDVHIGHLimit | V_DD V_HIGH Limit (unit: V)
Public property | VDDVLOWLimit | V_DD V_LOW Limit (unit: V)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
±0.5°C Accurate Digital Temperature Sensor and Quad Voltage Output 12-Bit DACs
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adt7316(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adt7316

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316 Properties

The Adt7316 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlConfiguration1INTOutput | Control Configuration 1: INT Output
Public property | ControlConfiguration1INTOutputPolarity | Control Configuration 1: INT Output Polarity
Public property | ControlConfiguration1Monitoring | Control Configuration 1: Monitoring
Public property | ControlConfiguration1PowerDown | Control Configuration 1: Power Down
Public property | ControlConfiguration2Averaging | Control Configuration 2: Averaging
Public property | ControlConfiguration2ChannelSelection | Control Configuration 2: Channel Selection
Public property | ControlConfiguration2Conversion | Control Configuration 2: Conversion
Public property | ControlConfiguration2SMBusTimeout | Control Configuration 2: SMBus Timeout
Public property | ControlConfiguration2SoftwareReset | Control Configuration 2: Software Reset
Public property | ControlConfiguration3DACAOutputProportionalToInternalTemperature | Control Configuration 3: DAC A Output Proportional To Internal Temperature
Public property | ControlConfiguration3DACBOutputProportionalToExternalTemperature | Control Configuration 3: DAC B Output Proportional To External Temperature
Public property | ControlConfiguration3Resolution | Control Configuration 3: Resolution
Public property | ControlConfiguration3Speed | Control Configuration 3: Speed
Public property | ControlConfiguration3UpdatingOfDACOutputs | Control Configuration 3: Updating of DAC Outputs
Public property | DACA | DAC A
Public property | DACB | DAC B
Public property | DACC | DAC C
Public property | DACConfigurationOutputRangeDACA | DAC Configuration: Output Range DAC A
Public property | DACConfigurationOutputRangeDACB | DAC Configuration: Output Range DAC B
Public property | DACConfigurationOutputRangeDACC | DAC Configuration: Output Range DAC C
Public property | DACConfigurationOutputRangeDACD | DAC Configuration: Output Range DAC D
Public property | DACConfigurationUpdate | DAC Configuration: Update
Public property | DACConfigurationVREFBypassDACAB | DAC Configuration: V_REF Bypass DAC A / B
Public property | DACConfigurationVREFBypassDACCD | DAC Configuration: V_REF Bypass DAC C / D
Public property | DACD | DAC D
Public property | DeviceID | Device ID
Public property | ExternalAnalogTemperatureOffset | External Analog Temperature Offset (unit: °C)
Public property | ExternalTemperature | External Temperature (unit: °C)
Public property | ExternalTemperatureOffset | External Temperature Offset (unit: °C)
Public property | ExternalTHIGHLimit | External T_HIGH Limit (unit: °C)
Public property | ExternalTLOWLimit | External T_LOW Limit (unit: °C)
Public property | InternalAnalogTemperatureOffset | Internal Analog Temperature Offset (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | InternalTemperatureOffset | Internal Temperature Offset (unit: °C)
Public property | InternalTHIGHLimit | Internal T_HIGH Limit (unit: °C)
Public property | InternalTLOWLimit | Internal T_LOW Limit (unit: °C)
Public property | InterruptMask1ExternalTemperatureFault | Interrupt Mask 1: External Temperature Fault
Public property | InterruptMask1ExternalTHIGH | Interrupt Mask 1: External T_HIGH
Public property | InterruptMask1ExternalTLOW | Interrupt Mask 1: External T_LOW
Public property | InterruptMask1InternalTHIGH | Interrupt Mask 1: Internal T_HIGH
Public property | InterruptMask1InternalTLOW | Interrupt Mask 1: Internal T_LOW
Public property | InterruptMask2VDD | Interrupt Mask 2: V_DD
Public property | InterruptStatus1ExternalSensorFault | Interrupt Status 1: External Sensor Fault
Public property | InterruptStatus1TEXTTHIGH | Interrupt Status 1: T_EXT > T_HIGH
Public property | InterruptStatus1TEXTTLOW | Interrupt Status 1: T_EXT <= T_LOW
Public property | InterruptStatus1TINTTHIGH | Interrupt Status 1: T_INT > T_HIGH
Public property | InterruptStatus1TINTTLOW | Interrupt Status 1: T_INT <= T_LOW
Public property | InterruptStatus2VDDVHIGHVDDVLOW | Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW
Public property | LDACConfigurationDACA | LDAC Configuration: DAC A
Public property | LDACConfigurationDACB | LDAC Configuration: DAC B
Public property | LDACConfigurationDACC | LDAC Configuration: DAC C
Public property | LDACConfigurationDACD | LDAC Configuration: DAC D
Public property | ManufacturerSID | Manufacturer's ID
Public property | SiliconRevisionStepping | Silicon Revision: Stepping
Public property | SiliconRevisionVersion | Silicon Revision: Version
Public property | SPILockStatus | SPI Lock Status
Public property | VDD | V_DD (unit: V)
Public property | VDDVHIGHLimit | V_DD V_HIGH Limit (unit: V)
Public property | VDDVLOWLimit | V_DD V_LOW Limit (unit: V)
Top
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.AutoFlush Property

IRD

Adt7316AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ControlConfiguration1INTOutput Property

IRD

Adt7316ControlConfiguration1INTOutput Property

Control Configuration 1: INT Output

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeControlConfiguration1IntOutput ControlConfiguration1INTOutput { get; set; }
Public Property ControlConfiguration1INTOutput As Adt7316TypeControlConfiguration1IntOutput
    Get
    Set
public:
property Adt7316TypeControlConfiguration1IntOutput ControlConfiguration1INTOutput {
    Adt7316TypeControlConfiguration1IntOutput get ();
    void set (Adt7316TypeControlConfiguration1IntOutput value);
}
member ControlConfiguration1INTOutput : Adt7316TypeControlConfiguration1IntOutput with get, set

Property Value

Type: Adt7316TypeControlConfiguration1IntOutput
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ControlConfiguration1INTOutputPolarity Property

IRD

Adt7316ControlConfiguration1INTOutputPolarity Property

Control Configuration 1: INT Output Polarity

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeControlConfiguration1IntOutputPolarity ControlConfiguration1INTOutputPolarity { get; set; }
Public Property ControlConfiguration1INTOutputPolarity As Adt7316TypeControlConfiguration1IntOutputPolarity
    Get
    Set
public:
property Adt7316TypeControlConfiguration1IntOutputPolarity ControlConfiguration1INTOutputPolarity {
    Adt7316TypeControlConfiguration1IntOutputPolarity get ();
    void set (Adt7316TypeControlConfiguration1IntOutputPolarity value);
}
member ControlConfiguration1INTOutputPolarity : Adt7316TypeControlConfiguration1IntOutputPolarity with get, set

Property Value

Type: Adt7316TypeControlConfiguration1IntOutputPolarity
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ControlConfiguration1Monitoring Property

IRD

Adt7316ControlConfiguration1Monitoring Property

Control Configuration 1: Monitoring

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeControlConfiguration1Monitoring ControlConfiguration1Monitoring { get; set; }
Public Property ControlConfiguration1Monitoring As Adt7316TypeControlConfiguration1Monitoring
    Get
    Set
public:
property Adt7316TypeControlConfiguration1Monitoring ControlConfiguration1Monitoring {
    Adt7316TypeControlConfiguration1Monitoring get ();
    void set (Adt7316TypeControlConfiguration1Monitoring value);
}
member ControlConfiguration1Monitoring : Adt7316TypeControlConfiguration1Monitoring with get, set

Property Value

Type: Adt7316TypeControlConfiguration1Monitoring
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ControlConfiguration1PowerDown Property

IRD

Adt7316ControlConfiguration1PowerDown Property

Control Configuration 1: Power Down

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeControlConfiguration1PowerDown ControlConfiguration1PowerDown { get; set; }
Public Property ControlConfiguration1PowerDown As Adt7316TypeControlConfiguration1PowerDown
    Get
    Set
public:
property Adt7316TypeControlConfiguration1PowerDown ControlConfiguration1PowerDown {
    Adt7316TypeControlConfiguration1PowerDown get ();
    void set (Adt7316TypeControlConfiguration1PowerDown value);
}
member ControlConfiguration1PowerDown : Adt7316TypeControlConfiguration1PowerDown with get, set

Property Value

Type: Adt7316TypeControlConfiguration1PowerDown
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ControlConfiguration2Averaging Property

IRD

Adt7316ControlConfiguration2Averaging Property

Control Configuration 2: Averaging

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeControlConfiguration2Averaging ControlConfiguration2Averaging { get; set; }
Public Property ControlConfiguration2Averaging As Adt7316TypeControlConfiguration2Averaging
    Get
    Set
public:
property Adt7316TypeControlConfiguration2Averaging ControlConfiguration2Averaging {
    Adt7316TypeControlConfiguration2Averaging get ();
    void set (Adt7316TypeControlConfiguration2Averaging value);
}
member ControlConfiguration2Averaging : Adt7316TypeControlConfiguration2Averaging with get, set

Property Value

Type: Adt7316TypeControlConfiguration2Averaging
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ControlConfiguration2ChannelSelection Property

IRD

Adt7316ControlConfiguration2ChannelSelection Property

Control Configuration 2: Channel Selection

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeControlConfiguration2ChannelSelection ControlConfiguration2ChannelSelection { get; set; }
Public Property ControlConfiguration2ChannelSelection As Adt7316TypeControlConfiguration2ChannelSelection
    Get
    Set
public:
property Adt7316TypeControlConfiguration2ChannelSelection ControlConfiguration2ChannelSelection {
    Adt7316TypeControlConfiguration2ChannelSelection get ();
    void set (Adt7316TypeControlConfiguration2ChannelSelection value);
}
member ControlConfiguration2ChannelSelection : Adt7316TypeControlConfiguration2ChannelSelection with get, set

Property Value

Type: Adt7316TypeControlConfiguration2ChannelSelection
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ControlConfiguration2Conversion Property

IRD

Adt7316ControlConfiguration2Conversion Property

Control Configuration 2: Conversion

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeControlConfiguration2Conversion ControlConfiguration2Conversion { get; set; }
Public Property ControlConfiguration2Conversion As Adt7316TypeControlConfiguration2Conversion
    Get
    Set
public:
property Adt7316TypeControlConfiguration2Conversion ControlConfiguration2Conversion {
    Adt7316TypeControlConfiguration2Conversion get ();
    void set (Adt7316TypeControlConfiguration2Conversion value);
}
member ControlConfiguration2Conversion : Adt7316TypeControlConfiguration2Conversion with get, set

Property Value

Type: Adt7316TypeControlConfiguration2Conversion
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ControlConfiguration2SMBusTimeout Property

IRD

Adt7316ControlConfiguration2SMBusTimeout Property

Control Configuration 2: SMBus Timeout

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeControlConfiguration2Timeout ControlConfiguration2SMBusTimeout { get; set; }
Public Property ControlConfiguration2SMBusTimeout As Adt7316TypeControlConfiguration2Timeout
    Get
    Set
public:
property Adt7316TypeControlConfiguration2Timeout ControlConfiguration2SMBusTimeout {
    Adt7316TypeControlConfiguration2Timeout get ();
    void set (Adt7316TypeControlConfiguration2Timeout value);
}
member ControlConfiguration2SMBusTimeout : Adt7316TypeControlConfiguration2Timeout with get, set

Property Value

Type: Adt7316TypeControlConfiguration2Timeout
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ControlConfiguration2SoftwareReset Property

IRD

Adt7316ControlConfiguration2SoftwareReset Property

Control Configuration 2: Software Reset

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeControlConfiguration2SoftwareReset ControlConfiguration2SoftwareReset { get; set; }
Public Property ControlConfiguration2SoftwareReset As Adt7316TypeControlConfiguration2SoftwareReset
    Get
    Set
public:
property Adt7316TypeControlConfiguration2SoftwareReset ControlConfiguration2SoftwareReset {
    Adt7316TypeControlConfiguration2SoftwareReset get ();
    void set (Adt7316TypeControlConfiguration2SoftwareReset value);
}
member ControlConfiguration2SoftwareReset : Adt7316TypeControlConfiguration2SoftwareReset with get, set

Property Value

Type: Adt7316TypeControlConfiguration2SoftwareReset
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ControlConfiguration3DACAOutputProportionalToInternalTemperature Property

IRD

Adt7316ControlConfiguration3DACAOutputProportionalToInternalTemperature Property

Control Configuration 3: DAC A Output Proportional To Internal Temperature

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeControlConfiguration3DacAOutput ControlConfiguration3DACAOutputProportionalToInternalTemperature { get; set; }
Public Property ControlConfiguration3DACAOutputProportionalToInternalTemperature As Adt7316TypeControlConfiguration3DacAOutput
    Get
    Set
public:
property Adt7316TypeControlConfiguration3DacAOutput ControlConfiguration3DACAOutputProportionalToInternalTemperature {
    Adt7316TypeControlConfiguration3DacAOutput get ();
    void set (Adt7316TypeControlConfiguration3DacAOutput value);
}
member ControlConfiguration3DACAOutputProportionalToInternalTemperature : Adt7316TypeControlConfiguration3DacAOutput with get, set

Property Value

Type: Adt7316TypeControlConfiguration3DacAOutput
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ControlConfiguration3DACBOutputProportionalToExternalTemperature Property

IRD

Adt7316ControlConfiguration3DACBOutputProportionalToExternalTemperature Property

Control Configuration 3: DAC B Output Proportional To External Temperature

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeControlConfiguration3DacBOutput ControlConfiguration3DACBOutputProportionalToExternalTemperature { get; set; }
Public Property ControlConfiguration3DACBOutputProportionalToExternalTemperature As Adt7316TypeControlConfiguration3DacBOutput
    Get
    Set
public:
property Adt7316TypeControlConfiguration3DacBOutput ControlConfiguration3DACBOutputProportionalToExternalTemperature {
    Adt7316TypeControlConfiguration3DacBOutput get ();
    void set (Adt7316TypeControlConfiguration3DacBOutput value);
}
member ControlConfiguration3DACBOutputProportionalToExternalTemperature : Adt7316TypeControlConfiguration3DacBOutput with get, set

Property Value

Type: Adt7316TypeControlConfiguration3DacBOutput
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ControlConfiguration3Resolution Property

IRD

Adt7316ControlConfiguration3Resolution Property

Control Configuration 3: Resolution

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeControlConfiguration3Resolution ControlConfiguration3Resolution { get; set; }
Public Property ControlConfiguration3Resolution As Adt7316TypeControlConfiguration3Resolution
    Get
    Set
public:
property Adt7316TypeControlConfiguration3Resolution ControlConfiguration3Resolution {
    Adt7316TypeControlConfiguration3Resolution get ();
    void set (Adt7316TypeControlConfiguration3Resolution value);
}
member ControlConfiguration3Resolution : Adt7316TypeControlConfiguration3Resolution with get, set

Property Value

Type: Adt7316TypeControlConfiguration3Resolution
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ControlConfiguration3Speed Property

IRD

Adt7316ControlConfiguration3Speed Property

Control Configuration 3: Speed

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeControlConfiguration3Speed ControlConfiguration3Speed { get; set; }
Public Property ControlConfiguration3Speed As Adt7316TypeControlConfiguration3Speed
    Get
    Set
public:
property Adt7316TypeControlConfiguration3Speed ControlConfiguration3Speed {
    Adt7316TypeControlConfiguration3Speed get ();
    void set (Adt7316TypeControlConfiguration3Speed value);
}
member ControlConfiguration3Speed : Adt7316TypeControlConfiguration3Speed with get, set

Property Value

Type: Adt7316TypeControlConfiguration3Speed
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ControlConfiguration3UpdatingOfDACOutputs Property

IRD

Adt7316ControlConfiguration3UpdatingOfDACOutputs Property

Control Configuration 3: Updating of DAC Outputs

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeControlConfiguration3UpdatingDacOutputs ControlConfiguration3UpdatingOfDACOutputs { get; set; }
Public Property ControlConfiguration3UpdatingOfDACOutputs As Adt7316TypeControlConfiguration3UpdatingDacOutputs
    Get
    Set
public:
property Adt7316TypeControlConfiguration3UpdatingDacOutputs ControlConfiguration3UpdatingOfDACOutputs {
    Adt7316TypeControlConfiguration3UpdatingDacOutputs get ();
    void set (Adt7316TypeControlConfiguration3UpdatingDacOutputs value);
}
member ControlConfiguration3UpdatingOfDACOutputs : Adt7316TypeControlConfiguration3UpdatingDacOutputs with get, set

Property Value

Type: Adt7316TypeControlConfiguration3UpdatingDacOutputs
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.DACA Property

IRD

Adt7316DACA Property

DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DACA { get; set; }
Public Property DACA As UShort
    Get
    Set
public:
property unsigned short DACA {
    unsigned short get ();
    void set (unsigned short value);
}
member DACA : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.DACB Property

IRD

Adt7316DACB Property

DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DACB { get; set; }
Public Property DACB As UShort
    Get
    Set
public:
property unsigned short DACB {
    unsigned short get ();
    void set (unsigned short value);
}
member DACB : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.DACC Property

IRD

Adt7316DACC Property

DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DACC { get; set; }
Public Property DACC As UShort
    Get
    Set
public:
property unsigned short DACC {
    unsigned short get ();
    void set (unsigned short value);
}
member DACC : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.DACConfigurationOutputRangeDACA Property

IRD

Adt7316DACConfigurationOutputRangeDACA Property

DAC Configuration: Output Range DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeDacConfigurationRange DACConfigurationOutputRangeDACA { get; set; }
Public Property DACConfigurationOutputRangeDACA As Adt7316TypeDacConfigurationRange
    Get
    Set
public:
property Adt7316TypeDacConfigurationRange DACConfigurationOutputRangeDACA {
    Adt7316TypeDacConfigurationRange get ();
    void set (Adt7316TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACA : Adt7316TypeDacConfigurationRange with get, set

Property Value

Type: Adt7316TypeDacConfigurationRange
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.DACConfigurationOutputRangeDACB Property

IRD

Adt7316DACConfigurationOutputRangeDACB Property

DAC Configuration: Output Range DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeDacConfigurationRange DACConfigurationOutputRangeDACB { get; set; }
Public Property DACConfigurationOutputRangeDACB As Adt7316TypeDacConfigurationRange
    Get
    Set
public:
property Adt7316TypeDacConfigurationRange DACConfigurationOutputRangeDACB {
    Adt7316TypeDacConfigurationRange get ();
    void set (Adt7316TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACB : Adt7316TypeDacConfigurationRange with get, set

Property Value

Type: Adt7316TypeDacConfigurationRange
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.DACConfigurationOutputRangeDACC Property

IRD

Adt7316DACConfigurationOutputRangeDACC Property

DAC Configuration: Output Range DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeDacConfigurationRange DACConfigurationOutputRangeDACC { get; set; }
Public Property DACConfigurationOutputRangeDACC As Adt7316TypeDacConfigurationRange
    Get
    Set
public:
property Adt7316TypeDacConfigurationRange DACConfigurationOutputRangeDACC {
    Adt7316TypeDacConfigurationRange get ();
    void set (Adt7316TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACC : Adt7316TypeDacConfigurationRange with get, set

Property Value

Type: Adt7316TypeDacConfigurationRange
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.DACConfigurationOutputRangeDACD Property

IRD

Adt7316DACConfigurationOutputRangeDACD Property

DAC Configuration: Output Range DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeDacConfigurationRange DACConfigurationOutputRangeDACD { get; set; }
Public Property DACConfigurationOutputRangeDACD As Adt7316TypeDacConfigurationRange
    Get
    Set
public:
property Adt7316TypeDacConfigurationRange DACConfigurationOutputRangeDACD {
    Adt7316TypeDacConfigurationRange get ();
    void set (Adt7316TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACD : Adt7316TypeDacConfigurationRange with get, set

Property Value

Type: Adt7316TypeDacConfigurationRange
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.DACConfigurationUpdate Property

IRD

Adt7316DACConfigurationUpdate Property

DAC Configuration: Update

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeDacConfigurationUpdate DACConfigurationUpdate { get; set; }
Public Property DACConfigurationUpdate As Adt7316TypeDacConfigurationUpdate
    Get
    Set
public:
property Adt7316TypeDacConfigurationUpdate DACConfigurationUpdate {
    Adt7316TypeDacConfigurationUpdate get ();
    void set (Adt7316TypeDacConfigurationUpdate value);
}
member DACConfigurationUpdate : Adt7316TypeDacConfigurationUpdate with get, set

Property Value

Type: Adt7316TypeDacConfigurationUpdate
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.DACConfigurationVREFBypassDACAB Property

IRD

Adt7316DACConfigurationVREFBypassDACAB Property

DAC Configuration: V_REF Bypass DAC A / B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeDacConfigurationBypass DACConfigurationVREFBypassDACAB { get; set; }
Public Property DACConfigurationVREFBypassDACAB As Adt7316TypeDacConfigurationBypass
    Get
    Set
public:
property Adt7316TypeDacConfigurationBypass DACConfigurationVREFBypassDACAB {
    Adt7316TypeDacConfigurationBypass get ();
    void set (Adt7316TypeDacConfigurationBypass value);
}
member DACConfigurationVREFBypassDACAB : Adt7316TypeDacConfigurationBypass with get, set

Property Value

Type: Adt7316TypeDacConfigurationBypass
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.DACConfigurationVREFBypassDACCD Property

IRD

Adt7316DACConfigurationVREFBypassDACCD Property

DAC Configuration: V_REF Bypass DAC C / D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeDacConfigurationBypass DACConfigurationVREFBypassDACCD { get; set; }
Public Property DACConfigurationVREFBypassDACCD As Adt7316TypeDacConfigurationBypass
    Get
    Set
public:
property Adt7316TypeDacConfigurationBypass DACConfigurationVREFBypassDACCD {
    Adt7316TypeDacConfigurationBypass get ();
    void set (Adt7316TypeDacConfigurationBypass value);
}
member DACConfigurationVREFBypassDACCD : Adt7316TypeDacConfigurationBypass with get, set

Property Value

Type: Adt7316TypeDacConfigurationBypass
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.DACD Property

IRD

Adt7316DACD Property

DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DACD { get; set; }
Public Property DACD As UShort
    Get
    Set
public:
property unsigned short DACD {
    unsigned short get ();
    void set (unsigned short value);
}
member DACD : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.DeviceID Property

IRD

Adt7316DeviceID Property

Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ExternalAnalogTemperatureOffset Property

IRD

Adt7316ExternalAnalogTemperatureOffset Property

External Analog Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalAnalogTemperatureOffset { get; set; }
Public Property ExternalAnalogTemperatureOffset As SByte
    Get
    Set
public:
property signed char ExternalAnalogTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member ExternalAnalogTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ExternalTemperature Property

IRD

Adt7316ExternalTemperature Property

External Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ExternalTemperature { get; }
Public ReadOnly Property ExternalTemperature As Double
    Get
public:
property double ExternalTemperature {
    double get ();
}
member ExternalTemperature : float with get

Property Value

Type: Double
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ExternalTemperatureOffset Property

IRD

Adt7316ExternalTemperatureOffset Property

External Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperatureOffset { get; set; }
Public Property ExternalTemperatureOffset As SByte
    Get
    Set
public:
property signed char ExternalTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member ExternalTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ExternalTHIGHLimit Property

IRD

Adt7316ExternalTHIGHLimit Property

External T_HIGH Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTHIGHLimit { get; set; }
Public Property ExternalTHIGHLimit As SByte
    Get
    Set
public:
property signed char ExternalTHIGHLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalTHIGHLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ExternalTLOWLimit Property

IRD

Adt7316ExternalTLOWLimit Property

External T_LOW Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTLOWLimit { get; set; }
Public Property ExternalTLOWLimit As SByte
    Get
    Set
public:
property signed char ExternalTLOWLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalTLOWLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.InternalAnalogTemperatureOffset Property

IRD

Adt7316InternalAnalogTemperatureOffset Property

Internal Analog Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalAnalogTemperatureOffset { get; set; }
Public Property InternalAnalogTemperatureOffset As SByte
    Get
    Set
public:
property signed char InternalAnalogTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member InternalAnalogTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.InternalTemperature Property

IRD

Adt7316InternalTemperature Property

Internal Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double InternalTemperature { get; }
Public ReadOnly Property InternalTemperature As Double
    Get
public:
property double InternalTemperature {
    double get ();
}
member InternalTemperature : float with get

Property Value

Type: Double
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.InternalTemperatureOffset Property

IRD

Adt7316InternalTemperatureOffset Property

Internal Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureOffset { get; set; }
Public Property InternalTemperatureOffset As SByte
    Get
    Set
public:
property signed char InternalTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member InternalTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.InternalTHIGHLimit Property

IRD

Adt7316InternalTHIGHLimit Property

Internal T_HIGH Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTHIGHLimit { get; set; }
Public Property InternalTHIGHLimit As SByte
    Get
    Set
public:
property signed char InternalTHIGHLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTHIGHLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.InternalTLOWLimit Property

IRD

Adt7316InternalTLOWLimit Property

Internal T_LOW Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTLOWLimit { get; set; }
Public Property InternalTLOWLimit As SByte
    Get
    Set
public:
property signed char InternalTLOWLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTLOWLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.InterruptMask1ExternalTemperatureFault Property

IRD

Adt7316InterruptMask1ExternalTemperatureFault Property

Interrupt Mask 1: External Temperature Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeInterruptMaskEnableDisable InterruptMask1ExternalTemperatureFault { get; set; }
Public Property InterruptMask1ExternalTemperatureFault As Adt7316TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7316TypeInterruptMaskEnableDisable InterruptMask1ExternalTemperatureFault {
    Adt7316TypeInterruptMaskEnableDisable get ();
    void set (Adt7316TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTemperatureFault : Adt7316TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7316TypeInterruptMaskEnableDisable
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.InterruptMask1ExternalTHIGH Property

IRD

Adt7316InterruptMask1ExternalTHIGH Property

Interrupt Mask 1: External T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeInterruptMaskEnableDisable InterruptMask1ExternalTHIGH { get; set; }
Public Property InterruptMask1ExternalTHIGH As Adt7316TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7316TypeInterruptMaskEnableDisable InterruptMask1ExternalTHIGH {
    Adt7316TypeInterruptMaskEnableDisable get ();
    void set (Adt7316TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTHIGH : Adt7316TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7316TypeInterruptMaskEnableDisable
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.InterruptMask1ExternalTLOW Property

IRD

Adt7316InterruptMask1ExternalTLOW Property

Interrupt Mask 1: External T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeInterruptMaskEnableDisable InterruptMask1ExternalTLOW { get; set; }
Public Property InterruptMask1ExternalTLOW As Adt7316TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7316TypeInterruptMaskEnableDisable InterruptMask1ExternalTLOW {
    Adt7316TypeInterruptMaskEnableDisable get ();
    void set (Adt7316TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTLOW : Adt7316TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7316TypeInterruptMaskEnableDisable
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.InterruptMask1InternalTHIGH Property

IRD

Adt7316InterruptMask1InternalTHIGH Property

Interrupt Mask 1: Internal T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeInterruptMaskEnableDisable InterruptMask1InternalTHIGH { get; set; }
Public Property InterruptMask1InternalTHIGH As Adt7316TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7316TypeInterruptMaskEnableDisable InterruptMask1InternalTHIGH {
    Adt7316TypeInterruptMaskEnableDisable get ();
    void set (Adt7316TypeInterruptMaskEnableDisable value);
}
member InterruptMask1InternalTHIGH : Adt7316TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7316TypeInterruptMaskEnableDisable
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.InterruptMask1InternalTLOW Property

IRD

Adt7316InterruptMask1InternalTLOW Property

Interrupt Mask 1: Internal T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeInterruptMaskEnableDisable InterruptMask1InternalTLOW { get; set; }
Public Property InterruptMask1InternalTLOW As Adt7316TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7316TypeInterruptMaskEnableDisable InterruptMask1InternalTLOW {
    Adt7316TypeInterruptMaskEnableDisable get ();
    void set (Adt7316TypeInterruptMaskEnableDisable value);
}
member InterruptMask1InternalTLOW : Adt7316TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7316TypeInterruptMaskEnableDisable
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.InterruptMask2VDD Property

IRD

Adt7316InterruptMask2VDD Property

Interrupt Mask 2: V_DD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeInterruptMaskEnableDisable InterruptMask2VDD { get; set; }
Public Property InterruptMask2VDD As Adt7316TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7316TypeInterruptMaskEnableDisable InterruptMask2VDD {
    Adt7316TypeInterruptMaskEnableDisable get ();
    void set (Adt7316TypeInterruptMaskEnableDisable value);
}
member InterruptMask2VDD : Adt7316TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7316TypeInterruptMaskEnableDisable
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.InterruptStatus1ExternalSensorFault Property

IRD

Adt7316InterruptStatus1ExternalSensorFault Property

Interrupt Status 1: External Sensor Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeInterruptStatus InterruptStatus1ExternalSensorFault { get; }
Public ReadOnly Property InterruptStatus1ExternalSensorFault As Adt7316TypeInterruptStatus
    Get
public:
property Adt7316TypeInterruptStatus InterruptStatus1ExternalSensorFault {
    Adt7316TypeInterruptStatus get ();
}
member InterruptStatus1ExternalSensorFault : Adt7316TypeInterruptStatus with get

Property Value

Type: Adt7316TypeInterruptStatus
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.InterruptStatus1TEXTTHIGH Property

IRD

Adt7316InterruptStatus1TEXTTHIGH Property

Interrupt Status 1: T_EXT > T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeInterruptStatus InterruptStatus1TEXTTHIGH { get; }
Public ReadOnly Property InterruptStatus1TEXTTHIGH As Adt7316TypeInterruptStatus
    Get
public:
property Adt7316TypeInterruptStatus InterruptStatus1TEXTTHIGH {
    Adt7316TypeInterruptStatus get ();
}
member InterruptStatus1TEXTTHIGH : Adt7316TypeInterruptStatus with get

Property Value

Type: Adt7316TypeInterruptStatus
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.InterruptStatus1TEXTTLOW Property

IRD

Adt7316InterruptStatus1TEXTTLOW Property

Interrupt Status 1: T_EXT <= T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeInterruptStatus InterruptStatus1TEXTTLOW { get; }
Public ReadOnly Property InterruptStatus1TEXTTLOW As Adt7316TypeInterruptStatus
    Get
public:
property Adt7316TypeInterruptStatus InterruptStatus1TEXTTLOW {
    Adt7316TypeInterruptStatus get ();
}
member InterruptStatus1TEXTTLOW : Adt7316TypeInterruptStatus with get

Property Value

Type: Adt7316TypeInterruptStatus
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.InterruptStatus1TINTTHIGH Property

IRD

Adt7316InterruptStatus1TINTTHIGH Property

Interrupt Status 1: T_INT > T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeInterruptStatus InterruptStatus1TINTTHIGH { get; }
Public ReadOnly Property InterruptStatus1TINTTHIGH As Adt7316TypeInterruptStatus
    Get
public:
property Adt7316TypeInterruptStatus InterruptStatus1TINTTHIGH {
    Adt7316TypeInterruptStatus get ();
}
member InterruptStatus1TINTTHIGH : Adt7316TypeInterruptStatus with get

Property Value

Type: Adt7316TypeInterruptStatus
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.InterruptStatus1TINTTLOW Property

IRD

Adt7316InterruptStatus1TINTTLOW Property

Interrupt Status 1: T_INT <= T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeInterruptStatus InterruptStatus1TINTTLOW { get; }
Public ReadOnly Property InterruptStatus1TINTTLOW As Adt7316TypeInterruptStatus
    Get
public:
property Adt7316TypeInterruptStatus InterruptStatus1TINTTLOW {
    Adt7316TypeInterruptStatus get ();
}
member InterruptStatus1TINTTLOW : Adt7316TypeInterruptStatus with get

Property Value

Type: Adt7316TypeInterruptStatus
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.InterruptStatus2VDDVHIGHVDDVLOW Property

IRD

Adt7316InterruptStatus2VDDVHIGHVDDVLOW Property

Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeInterruptStatus InterruptStatus2VDDVHIGHVDDVLOW { get; }
Public ReadOnly Property InterruptStatus2VDDVHIGHVDDVLOW As Adt7316TypeInterruptStatus
    Get
public:
property Adt7316TypeInterruptStatus InterruptStatus2VDDVHIGHVDDVLOW {
    Adt7316TypeInterruptStatus get ();
}
member InterruptStatus2VDDVHIGHVDDVLOW : Adt7316TypeInterruptStatus with get

Property Value

Type: Adt7316TypeInterruptStatus
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.LDACConfigurationDACA Property

IRD

Adt7316LDACConfigurationDACA Property

LDAC Configuration: DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeLdacConfigurationUpdate LDACConfigurationDACA { set; }
Public WriteOnly Property LDACConfigurationDACA As Adt7316TypeLdacConfigurationUpdate
    Set
public:
property Adt7316TypeLdacConfigurationUpdate LDACConfigurationDACA {
    void set (Adt7316TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACA : Adt7316TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7316TypeLdacConfigurationUpdate
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.LDACConfigurationDACB Property

IRD

Adt7316LDACConfigurationDACB Property

LDAC Configuration: DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeLdacConfigurationUpdate LDACConfigurationDACB { set; }
Public WriteOnly Property LDACConfigurationDACB As Adt7316TypeLdacConfigurationUpdate
    Set
public:
property Adt7316TypeLdacConfigurationUpdate LDACConfigurationDACB {
    void set (Adt7316TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACB : Adt7316TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7316TypeLdacConfigurationUpdate
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.LDACConfigurationDACC Property

IRD

Adt7316LDACConfigurationDACC Property

LDAC Configuration: DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeLdacConfigurationUpdate LDACConfigurationDACC { set; }
Public WriteOnly Property LDACConfigurationDACC As Adt7316TypeLdacConfigurationUpdate
    Set
public:
property Adt7316TypeLdacConfigurationUpdate LDACConfigurationDACC {
    void set (Adt7316TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACC : Adt7316TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7316TypeLdacConfigurationUpdate
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.LDACConfigurationDACD Property

IRD

Adt7316LDACConfigurationDACD Property

LDAC Configuration: DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeLdacConfigurationUpdate LDACConfigurationDACD { set; }
Public WriteOnly Property LDACConfigurationDACD As Adt7316TypeLdacConfigurationUpdate
    Set
public:
property Adt7316TypeLdacConfigurationUpdate LDACConfigurationDACD {
    void set (Adt7316TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACD : Adt7316TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7316TypeLdacConfigurationUpdate
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.ManufacturerSID Property

IRD

Adt7316ManufacturerSID Property

Manufacturer's ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerSID { get; }
Public ReadOnly Property ManufacturerSID As Byte
    Get
public:
property unsigned char ManufacturerSID {
    unsigned char get ();
}
member ManufacturerSID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.SiliconRevisionStepping Property

IRD

Adt7316SiliconRevisionStepping Property

Silicon Revision: Stepping

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SiliconRevisionStepping { get; }
Public ReadOnly Property SiliconRevisionStepping As Byte
    Get
public:
property unsigned char SiliconRevisionStepping {
    unsigned char get ();
}
member SiliconRevisionStepping : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.SiliconRevisionVersion Property

IRD

Adt7316SiliconRevisionVersion Property

Silicon Revision: Version

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SiliconRevisionVersion { get; }
Public ReadOnly Property SiliconRevisionVersion As Byte
    Get
public:
property unsigned char SiliconRevisionVersion {
    unsigned char get ();
}
member SiliconRevisionVersion : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.SPILockStatus Property

IRD

Adt7316SPILockStatus Property

SPI Lock Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7316TypeSpiLockStatus SPILockStatus { get; }
Public ReadOnly Property SPILockStatus As Adt7316TypeSpiLockStatus
    Get
public:
property Adt7316TypeSpiLockStatus SPILockStatus {
    Adt7316TypeSpiLockStatus get ();
}
member SPILockStatus : Adt7316TypeSpiLockStatus with get

Property Value

Type: Adt7316TypeSpiLockStatus
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.VDD Property

IRD

Adt7316VDD Property

V_DD (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDD { get; }
Public ReadOnly Property VDD As Double
    Get
public:
property double VDD {
    double get ();
}
member VDD : float with get

Property Value

Type: Double
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.VDDVHIGHLimit Property

IRD

Adt7316VDDVHIGHLimit Property

V_DD V_HIGH Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDDVHIGHLimit { get; set; }
Public Property VDDVHIGHLimit As Double
    Get
    Set
public:
property double VDDVHIGHLimit {
    double get ();
    void set (double value);
}
member VDDVHIGHLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.VDDVLOWLimit Property

IRD

Adt7316VDDVLOWLimit Property

V_DD V_LOW Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDDVLOWLimit { get; set; }
Public Property VDDVLOWLimit As Double
    Get
    Set
public:
property double VDDVLOWLimit {
    double get ();
    void set (double value);
}
member VDDVLOWLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316 Methods

The Adt7316 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.Flush Method

IRD

Adt7316Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adt7316 Class
telos.Ird.AnalogDevices Namespace


Adt7316.TypeControlConfiguration1IntOutput Enumeration

IRD

Adt7316TypeControlConfiguration1IntOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1IntOutput
Public Enumeration TypeControlConfiguration1IntOutput
public enum class TypeControlConfiguration1IntOutput
type TypeControlConfiguration1IntOutput
Members
Member name | Value | Description
INTOutputEnabled | 0 | INT Output: Enabled
INTOutputDisabled | 1 | INT Output: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeControlConfiguration1IntOutputPolarity Enumeration

IRD

Adt7316TypeControlConfiguration1IntOutputPolarity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1IntOutputPolarity
Public Enumeration TypeControlConfiguration1IntOutputPolarity
public enum class TypeControlConfiguration1IntOutputPolarity
type TypeControlConfiguration1IntOutputPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeControlConfiguration1Monitoring Enumeration

IRD

Adt7316TypeControlConfiguration1Monitoring Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1Monitoring
Public Enumeration TypeControlConfiguration1Monitoring
public enum class TypeControlConfiguration1Monitoring
type TypeControlConfiguration1Monitoring
Members
Member name | Value | Description
StopMonitoring | 0 | Stop Monitoring
StartMonitoring | 1 | Start Monitoring
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeControlConfiguration1PowerDown Enumeration

IRD

Adt7316TypeControlConfiguration1PowerDown Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1PowerDown
Public Enumeration TypeControlConfiguration1PowerDown
public enum class TypeControlConfiguration1PowerDown
type TypeControlConfiguration1PowerDown
Members
Member name | Value | Description
PowerUp | 0 | Power Up
PowerDown | 1 | Power Down
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeControlConfiguration2Averaging Enumeration

IRD

Adt7316TypeControlConfiguration2Averaging Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Averaging
Public Enumeration TypeControlConfiguration2Averaging
public enum class TypeControlConfiguration2Averaging
type TypeControlConfiguration2Averaging
Members
Member name | Value | Description
AveragingEnabled | 0 | Averaging Enabled
AveragingDisabled | 1 | Averaging Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeControlConfiguration2ChannelSelection Enumeration

IRD

Adt7316TypeControlConfiguration2ChannelSelection Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2ChannelSelection
Public Enumeration TypeControlConfiguration2ChannelSelection
public enum class TypeControlConfiguration2ChannelSelection
type TypeControlConfiguration2ChannelSelection
Members
Member name | Value | Description
VDD | 0 | V_DD
InternalTemperatureSensor | 1 | Internal Temperature Sensor
ExternalTemperatureSensor | 2 | External Temperature Sensor
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeControlConfiguration2Conversion Enumeration

IRD

Adt7316TypeControlConfiguration2Conversion Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Conversion
Public Enumeration TypeControlConfiguration2Conversion
public enum class TypeControlConfiguration2Conversion
type TypeControlConfiguration2Conversion
Members
Member name | Value | Description
RoundRobin | 0 | Round Robin
SingleChannel | 1 | Single Channel
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeControlConfiguration2SoftwareReset Enumeration

IRD

Adt7316TypeControlConfiguration2SoftwareReset Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2SoftwareReset
Public Enumeration TypeControlConfiguration2SoftwareReset
public enum class TypeControlConfiguration2SoftwareReset
type TypeControlConfiguration2SoftwareReset
Members
Member name | Value | Description
Default | 0 | Default
SoftwareReset | 1 | Software Reset
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeControlConfiguration2Timeout Enumeration

IRD

Adt7316TypeControlConfiguration2Timeout Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Timeout
Public Enumeration TypeControlConfiguration2Timeout
public enum class TypeControlConfiguration2Timeout
type TypeControlConfiguration2Timeout
Members
Member name | Value | Description
SMBusTimeoutDisabled | 0 | SMBus Timeout: Disabled
SMBusTimeoutEnabled | 1 | SMBus Timeout: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeControlConfiguration3DacAOutput Enumeration

IRD

Adt7316TypeControlConfiguration3DacAOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3DacAOutput
Public Enumeration TypeControlConfiguration3DacAOutput
public enum class TypeControlConfiguration3DacAOutput
type TypeControlConfiguration3DacAOutput
Members
Member name | Value | Description
NotProportional | 0 | Not Proportional
Proportional | 1 | Proportional
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeControlConfiguration3DacBOutput Enumeration

IRD

Adt7316TypeControlConfiguration3DacBOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3DacBOutput
Public Enumeration TypeControlConfiguration3DacBOutput
public enum class TypeControlConfiguration3DacBOutput
type TypeControlConfiguration3DacBOutput
Members
Member name | Value | Description
NotProportional | 0 | Not Proportional
Proportional | 1 | Proportional
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeControlConfiguration3Resolution Enumeration

IRD

Adt7316TypeControlConfiguration3Resolution Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3Resolution
Public Enumeration TypeControlConfiguration3Resolution
public enum class TypeControlConfiguration3Resolution
type TypeControlConfiguration3Resolution
Members
Member name | Value | Description
Value_8Bit | 0 | 8-bit
Value_10Bit | 1 | 10-bit
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeControlConfiguration3Speed Enumeration

IRD

Adt7316TypeControlConfiguration3Speed Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3Speed
Public Enumeration TypeControlConfiguration3Speed
public enum class TypeControlConfiguration3Speed
type TypeControlConfiguration3Speed
Members
Member name | Value | Description
Value_14KHz | 0 | 1.4 kHz
Value_225KHz | 1 | 22.5 kHz
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeControlConfiguration3UpdatingDacOutputs Enumeration

IRD

Adt7316TypeControlConfiguration3UpdatingDacOutputs Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3UpdatingDacOutputs
Public Enumeration TypeControlConfiguration3UpdatingDacOutputs
public enum class TypeControlConfiguration3UpdatingDacOutputs
type TypeControlConfiguration3UpdatingDacOutputs
Members
Member name | Value | Description
LDACPin | 0 | LDAC Pin
DACLDACConfiguration | 1 | DAC & LDAC Configuration
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeDacConfigurationBypass Enumeration

IRD

Adt7316TypeDacConfigurationBypass Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacConfigurationBypass
Public Enumeration TypeDacConfigurationBypass
public enum class TypeDacConfigurationBypass
type TypeDacConfigurationBypass
Members
Member name | Value | Description
BypassReferenceBufferDisabled | 0 | Bypass Reference Buffer: Disabled
BypassReferenceBufferEnabled | 1 | Bypass Reference Buffer: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeDacConfigurationRange Enumeration

IRD

Adt7316TypeDacConfigurationRange Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacConfigurationRange
Public Enumeration TypeDacConfigurationRange
public enum class TypeDacConfigurationRange
type TypeDacConfigurationRange
Members
Member name | Value | Description
Value_0VToVREF | 0 | 0V to V_REF
Value_0VTo2VREF | 1 | 0V to 2 V_REF
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeDacConfigurationUpdate Enumeration

IRD

Adt7316TypeDacConfigurationUpdate Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacConfigurationUpdate
Public Enumeration TypeDacConfigurationUpdate
public enum class TypeDacConfigurationUpdate
type TypeDacConfigurationUpdate
Members
Member name | Value | Description
MSBWriteToAnyDACRegisterGeneratesLDACCommandThatUpdatesThatDACOnly | 0 | MSB write to any DAC register generates LDAC command that updates that DAC only
MSBWriteToDACBOrDACDRegisterGeneratesLDACCommandThatUpdatesDACAAndDACBOrDACCAndDACDRespectively | 1 | MSB write to DAC B or DAC D register generates LDAC command that updates DAC A and DAC B or DAC C and DAC D, respectively
MSBWriteToDACDRegisterGeneratesLDACCommandThatUpdatesAllFourDACs | 2 | MSB write to DAC D register generates LDAC command that updates all four DACs
LDACCommandGeneratedFromLDACRegister | 3 | LDAC command generated from LDAC register
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeInterruptMaskEnableDisable Enumeration

IRD

Adt7316TypeInterruptMaskEnableDisable Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptMaskEnableDisable
Public Enumeration TypeInterruptMaskEnableDisable
public enum class TypeInterruptMaskEnableDisable
type TypeInterruptMaskEnableDisable
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeInterruptStatus Enumeration

IRD

Adt7316TypeInterruptStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatus
Public Enumeration TypeInterruptStatus
public enum class TypeInterruptStatus
type TypeInterruptStatus
Members
Member name | Value | Description
NotSet | 0 | Not Set
Set | 1 | Set
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeLdacConfigurationUpdate Enumeration

IRD

Adt7316TypeLdacConfigurationUpdate Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLdacConfigurationUpdate
Public Enumeration TypeLdacConfigurationUpdate
public enum class TypeLdacConfigurationUpdate
type TypeLdacConfigurationUpdate
Members
Member name | Value | Description
DoNotUpdate | 0 | Do Not Update
Update | 1 | Update
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7316.TypeSpiLockStatus Enumeration

IRD

Adt7316TypeSpiLockStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSpiLockStatus
Public Enumeration TypeSpiLockStatus
public enum class TypeSpiLockStatus
type TypeSpiLockStatus
Members
Member name | Value | Description
I2CInterface | 0 | I2C Interface
SPIInterfaceLocked | 1 | SPI Interface / Locked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317 Class

Analog Devices: ADT 7317
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdt7317

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adt7317
Public Class Adt7317
public ref class Adt7317
type Adt7317 =  class end

The Adt7317 type exposes the following members.

Constructors
 | Name | Description
Public method | Adt7317 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlConfiguration1INTOutput | Control Configuration 1: INT Output
Public property | ControlConfiguration1INTOutputPolarity | Control Configuration 1: INT Output Polarity
Public property | ControlConfiguration1Monitoring | Control Configuration 1: Monitoring
Public property | ControlConfiguration1PowerDown | Control Configuration 1: Power Down
Public property | ControlConfiguration2Averaging | Control Configuration 2: Averaging
Public property | ControlConfiguration2ChannelSelection | Control Configuration 2: Channel Selection
Public property | ControlConfiguration2Conversion | Control Configuration 2: Conversion
Public property | ControlConfiguration2SMBusTimeout | Control Configuration 2: SMBus Timeout
Public property | ControlConfiguration2SoftwareReset | Control Configuration 2: Software Reset
Public property | ControlConfiguration3DACAOutputProportionalToInternalTemperature | Control Configuration 3: DAC A Output Proportional To Internal Temperature
Public property | ControlConfiguration3DACBOutputProportionalToExternalTemperature | Control Configuration 3: DAC B Output Proportional To External Temperature
Public property | ControlConfiguration3Resolution | Control Configuration 3: Resolution
Public property | ControlConfiguration3Speed | Control Configuration 3: Speed
Public property | ControlConfiguration3UpdatingOfDACOutputs | Control Configuration 3: Updating of DAC Outputs
Public property | DACA | DAC A
Public property | DACB | DAC B
Public property | DACC | DAC C
Public property | DACConfigurationOutputRangeDACA | DAC Configuration: Output Range DAC A
Public property | DACConfigurationOutputRangeDACB | DAC Configuration: Output Range DAC B
Public property | DACConfigurationOutputRangeDACC | DAC Configuration: Output Range DAC C
Public property | DACConfigurationOutputRangeDACD | DAC Configuration: Output Range DAC D
Public property | DACConfigurationUpdate | DAC Configuration: Update
Public property | DACConfigurationVREFBypassDACAB | DAC Configuration: V_REF Bypass DAC A / B
Public property | DACConfigurationVREFBypassDACCD | DAC Configuration: V_REF Bypass DAC C / D
Public property | DACD | DAC D
Public property | DeviceID | Device ID
Public property | ExternalAnalogTemperatureOffset | External Analog Temperature Offset (unit: °C)
Public property | ExternalTemperature | External Temperature (unit: °C)
Public property | ExternalTemperatureOffset | External Temperature Offset (unit: °C)
Public property | ExternalTHIGHLimit | External T_HIGH Limit (unit: °C)
Public property | ExternalTLOWLimit | External T_LOW Limit (unit: °C)
Public property | InternalAnalogTemperatureOffset | Internal Analog Temperature Offset (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | InternalTemperatureOffset | Internal Temperature Offset (unit: °C)
Public property | InternalTHIGHLimit | Internal T_HIGH Limit (unit: °C)
Public property | InternalTLOWLimit | Internal T_LOW Limit (unit: °C)
Public property | InterruptMask1ExternalTemperatureFault | Interrupt Mask 1: External Temperature Fault
Public property | InterruptMask1ExternalTHIGH | Interrupt Mask 1: External T_HIGH
Public property | InterruptMask1ExternalTLOW | Interrupt Mask 1: External T_LOW
Public property | InterruptMask1InternalTHIGH | Interrupt Mask 1: Internal T_HIGH
Public property | InterruptMask1InternalTLOW | Interrupt Mask 1: Internal T_LOW
Public property | InterruptMask2VDD | Interrupt Mask 2: V_DD
Public property | InterruptStatus1ExternalSensorFault | Interrupt Status 1: External Sensor Fault
Public property | InterruptStatus1TEXTTHIGH | Interrupt Status 1: T_EXT > T_HIGH
Public property | InterruptStatus1TEXTTLOW | Interrupt Status 1: T_EXT <= T_LOW
Public property | InterruptStatus1TINTTHIGH | Interrupt Status 1: T_INT > T_HIGH
Public property | InterruptStatus1TINTTLOW | Interrupt Status 1: T_INT <= T_LOW
Public property | InterruptStatus2VDDVHIGHVDDVLOW | Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW
Public property | LDACConfigurationDACA | LDAC Configuration: DAC A
Public property | LDACConfigurationDACB | LDAC Configuration: DAC B
Public property | LDACConfigurationDACC | LDAC Configuration: DAC C
Public property | LDACConfigurationDACD | LDAC Configuration: DAC D
Public property | ManufacturerSID | Manufacturer's ID
Public property | SiliconRevisionStepping | Silicon Revision: Stepping
Public property | SiliconRevisionVersion | Silicon Revision: Version
Public property | SPILockStatus | SPI Lock Status
Public property | VDD | V_DD (unit: V)
Public property | VDDVHIGHLimit | V_DD V_HIGH Limit (unit: V)
Public property | VDDVLOWLimit | V_DD V_LOW Limit (unit: V)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
±0.5°C Accurate Digital Temperature Sensor and Quad Voltage Output 10-Bit DACs
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adt7317(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adt7317

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317 Properties

The Adt7317 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlConfiguration1INTOutput | Control Configuration 1: INT Output
Public property | ControlConfiguration1INTOutputPolarity | Control Configuration 1: INT Output Polarity
Public property | ControlConfiguration1Monitoring | Control Configuration 1: Monitoring
Public property | ControlConfiguration1PowerDown | Control Configuration 1: Power Down
Public property | ControlConfiguration2Averaging | Control Configuration 2: Averaging
Public property | ControlConfiguration2ChannelSelection | Control Configuration 2: Channel Selection
Public property | ControlConfiguration2Conversion | Control Configuration 2: Conversion
Public property | ControlConfiguration2SMBusTimeout | Control Configuration 2: SMBus Timeout
Public property | ControlConfiguration2SoftwareReset | Control Configuration 2: Software Reset
Public property | ControlConfiguration3DACAOutputProportionalToInternalTemperature | Control Configuration 3: DAC A Output Proportional To Internal Temperature
Public property | ControlConfiguration3DACBOutputProportionalToExternalTemperature | Control Configuration 3: DAC B Output Proportional To External Temperature
Public property | ControlConfiguration3Resolution | Control Configuration 3: Resolution
Public property | ControlConfiguration3Speed | Control Configuration 3: Speed
Public property | ControlConfiguration3UpdatingOfDACOutputs | Control Configuration 3: Updating of DAC Outputs
Public property | DACA | DAC A
Public property | DACB | DAC B
Public property | DACC | DAC C
Public property | DACConfigurationOutputRangeDACA | DAC Configuration: Output Range DAC A
Public property | DACConfigurationOutputRangeDACB | DAC Configuration: Output Range DAC B
Public property | DACConfigurationOutputRangeDACC | DAC Configuration: Output Range DAC C
Public property | DACConfigurationOutputRangeDACD | DAC Configuration: Output Range DAC D
Public property | DACConfigurationUpdate | DAC Configuration: Update
Public property | DACConfigurationVREFBypassDACAB | DAC Configuration: V_REF Bypass DAC A / B
Public property | DACConfigurationVREFBypassDACCD | DAC Configuration: V_REF Bypass DAC C / D
Public property | DACD | DAC D
Public property | DeviceID | Device ID
Public property | ExternalAnalogTemperatureOffset | External Analog Temperature Offset (unit: °C)
Public property | ExternalTemperature | External Temperature (unit: °C)
Public property | ExternalTemperatureOffset | External Temperature Offset (unit: °C)
Public property | ExternalTHIGHLimit | External T_HIGH Limit (unit: °C)
Public property | ExternalTLOWLimit | External T_LOW Limit (unit: °C)
Public property | InternalAnalogTemperatureOffset | Internal Analog Temperature Offset (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | InternalTemperatureOffset | Internal Temperature Offset (unit: °C)
Public property | InternalTHIGHLimit | Internal T_HIGH Limit (unit: °C)
Public property | InternalTLOWLimit | Internal T_LOW Limit (unit: °C)
Public property | InterruptMask1ExternalTemperatureFault | Interrupt Mask 1: External Temperature Fault
Public property | InterruptMask1ExternalTHIGH | Interrupt Mask 1: External T_HIGH
Public property | InterruptMask1ExternalTLOW | Interrupt Mask 1: External T_LOW
Public property | InterruptMask1InternalTHIGH | Interrupt Mask 1: Internal T_HIGH
Public property | InterruptMask1InternalTLOW | Interrupt Mask 1: Internal T_LOW
Public property | InterruptMask2VDD | Interrupt Mask 2: V_DD
Public property | InterruptStatus1ExternalSensorFault | Interrupt Status 1: External Sensor Fault
Public property | InterruptStatus1TEXTTHIGH | Interrupt Status 1: T_EXT > T_HIGH
Public property | InterruptStatus1TEXTTLOW | Interrupt Status 1: T_EXT <= T_LOW
Public property | InterruptStatus1TINTTHIGH | Interrupt Status 1: T_INT > T_HIGH
Public property | InterruptStatus1TINTTLOW | Interrupt Status 1: T_INT <= T_LOW
Public property | InterruptStatus2VDDVHIGHVDDVLOW | Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW
Public property | LDACConfigurationDACA | LDAC Configuration: DAC A
Public property | LDACConfigurationDACB | LDAC Configuration: DAC B
Public property | LDACConfigurationDACC | LDAC Configuration: DAC C
Public property | LDACConfigurationDACD | LDAC Configuration: DAC D
Public property | ManufacturerSID | Manufacturer's ID
Public property | SiliconRevisionStepping | Silicon Revision: Stepping
Public property | SiliconRevisionVersion | Silicon Revision: Version
Public property | SPILockStatus | SPI Lock Status
Public property | VDD | V_DD (unit: V)
Public property | VDDVHIGHLimit | V_DD V_HIGH Limit (unit: V)
Public property | VDDVLOWLimit | V_DD V_LOW Limit (unit: V)
Top
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.AutoFlush Property

IRD

Adt7317AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ControlConfiguration1INTOutput Property

IRD

Adt7317ControlConfiguration1INTOutput Property

Control Configuration 1: INT Output

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeControlConfiguration1IntOutput ControlConfiguration1INTOutput { get; set; }
Public Property ControlConfiguration1INTOutput As Adt7317TypeControlConfiguration1IntOutput
    Get
    Set
public:
property Adt7317TypeControlConfiguration1IntOutput ControlConfiguration1INTOutput {
    Adt7317TypeControlConfiguration1IntOutput get ();
    void set (Adt7317TypeControlConfiguration1IntOutput value);
}
member ControlConfiguration1INTOutput : Adt7317TypeControlConfiguration1IntOutput with get, set

Property Value

Type: Adt7317TypeControlConfiguration1IntOutput
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ControlConfiguration1INTOutputPolarity Property

IRD

Adt7317ControlConfiguration1INTOutputPolarity Property

Control Configuration 1: INT Output Polarity

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeControlConfiguration1IntOutputPolarity ControlConfiguration1INTOutputPolarity { get; set; }
Public Property ControlConfiguration1INTOutputPolarity As Adt7317TypeControlConfiguration1IntOutputPolarity
    Get
    Set
public:
property Adt7317TypeControlConfiguration1IntOutputPolarity ControlConfiguration1INTOutputPolarity {
    Adt7317TypeControlConfiguration1IntOutputPolarity get ();
    void set (Adt7317TypeControlConfiguration1IntOutputPolarity value);
}
member ControlConfiguration1INTOutputPolarity : Adt7317TypeControlConfiguration1IntOutputPolarity with get, set

Property Value

Type: Adt7317TypeControlConfiguration1IntOutputPolarity
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ControlConfiguration1Monitoring Property

IRD

Adt7317ControlConfiguration1Monitoring Property

Control Configuration 1: Monitoring

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeControlConfiguration1Monitoring ControlConfiguration1Monitoring { get; set; }
Public Property ControlConfiguration1Monitoring As Adt7317TypeControlConfiguration1Monitoring
    Get
    Set
public:
property Adt7317TypeControlConfiguration1Monitoring ControlConfiguration1Monitoring {
    Adt7317TypeControlConfiguration1Monitoring get ();
    void set (Adt7317TypeControlConfiguration1Monitoring value);
}
member ControlConfiguration1Monitoring : Adt7317TypeControlConfiguration1Monitoring with get, set

Property Value

Type: Adt7317TypeControlConfiguration1Monitoring
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ControlConfiguration1PowerDown Property

IRD

Adt7317ControlConfiguration1PowerDown Property

Control Configuration 1: Power Down

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeControlConfiguration1PowerDown ControlConfiguration1PowerDown { get; set; }
Public Property ControlConfiguration1PowerDown As Adt7317TypeControlConfiguration1PowerDown
    Get
    Set
public:
property Adt7317TypeControlConfiguration1PowerDown ControlConfiguration1PowerDown {
    Adt7317TypeControlConfiguration1PowerDown get ();
    void set (Adt7317TypeControlConfiguration1PowerDown value);
}
member ControlConfiguration1PowerDown : Adt7317TypeControlConfiguration1PowerDown with get, set

Property Value

Type: Adt7317TypeControlConfiguration1PowerDown
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ControlConfiguration2Averaging Property

IRD

Adt7317ControlConfiguration2Averaging Property

Control Configuration 2: Averaging

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeControlConfiguration2Averaging ControlConfiguration2Averaging { get; set; }
Public Property ControlConfiguration2Averaging As Adt7317TypeControlConfiguration2Averaging
    Get
    Set
public:
property Adt7317TypeControlConfiguration2Averaging ControlConfiguration2Averaging {
    Adt7317TypeControlConfiguration2Averaging get ();
    void set (Adt7317TypeControlConfiguration2Averaging value);
}
member ControlConfiguration2Averaging : Adt7317TypeControlConfiguration2Averaging with get, set

Property Value

Type: Adt7317TypeControlConfiguration2Averaging
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ControlConfiguration2ChannelSelection Property

IRD

Adt7317ControlConfiguration2ChannelSelection Property

Control Configuration 2: Channel Selection

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeControlConfiguration2ChannelSelection ControlConfiguration2ChannelSelection { get; set; }
Public Property ControlConfiguration2ChannelSelection As Adt7317TypeControlConfiguration2ChannelSelection
    Get
    Set
public:
property Adt7317TypeControlConfiguration2ChannelSelection ControlConfiguration2ChannelSelection {
    Adt7317TypeControlConfiguration2ChannelSelection get ();
    void set (Adt7317TypeControlConfiguration2ChannelSelection value);
}
member ControlConfiguration2ChannelSelection : Adt7317TypeControlConfiguration2ChannelSelection with get, set

Property Value

Type: Adt7317TypeControlConfiguration2ChannelSelection
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ControlConfiguration2Conversion Property

IRD

Adt7317ControlConfiguration2Conversion Property

Control Configuration 2: Conversion

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeControlConfiguration2Conversion ControlConfiguration2Conversion { get; set; }
Public Property ControlConfiguration2Conversion As Adt7317TypeControlConfiguration2Conversion
    Get
    Set
public:
property Adt7317TypeControlConfiguration2Conversion ControlConfiguration2Conversion {
    Adt7317TypeControlConfiguration2Conversion get ();
    void set (Adt7317TypeControlConfiguration2Conversion value);
}
member ControlConfiguration2Conversion : Adt7317TypeControlConfiguration2Conversion with get, set

Property Value

Type: Adt7317TypeControlConfiguration2Conversion
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ControlConfiguration2SMBusTimeout Property

IRD

Adt7317ControlConfiguration2SMBusTimeout Property

Control Configuration 2: SMBus Timeout

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeControlConfiguration2Timeout ControlConfiguration2SMBusTimeout { get; set; }
Public Property ControlConfiguration2SMBusTimeout As Adt7317TypeControlConfiguration2Timeout
    Get
    Set
public:
property Adt7317TypeControlConfiguration2Timeout ControlConfiguration2SMBusTimeout {
    Adt7317TypeControlConfiguration2Timeout get ();
    void set (Adt7317TypeControlConfiguration2Timeout value);
}
member ControlConfiguration2SMBusTimeout : Adt7317TypeControlConfiguration2Timeout with get, set

Property Value

Type: Adt7317TypeControlConfiguration2Timeout
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ControlConfiguration2SoftwareReset Property

IRD

Adt7317ControlConfiguration2SoftwareReset Property

Control Configuration 2: Software Reset

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeControlConfiguration2SoftwareReset ControlConfiguration2SoftwareReset { get; set; }
Public Property ControlConfiguration2SoftwareReset As Adt7317TypeControlConfiguration2SoftwareReset
    Get
    Set
public:
property Adt7317TypeControlConfiguration2SoftwareReset ControlConfiguration2SoftwareReset {
    Adt7317TypeControlConfiguration2SoftwareReset get ();
    void set (Adt7317TypeControlConfiguration2SoftwareReset value);
}
member ControlConfiguration2SoftwareReset : Adt7317TypeControlConfiguration2SoftwareReset with get, set

Property Value

Type: Adt7317TypeControlConfiguration2SoftwareReset
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ControlConfiguration3DACAOutputProportionalToInternalTemperature Property

IRD

Adt7317ControlConfiguration3DACAOutputProportionalToInternalTemperature Property

Control Configuration 3: DAC A Output Proportional To Internal Temperature

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeControlConfiguration3DacAOutput ControlConfiguration3DACAOutputProportionalToInternalTemperature { get; set; }
Public Property ControlConfiguration3DACAOutputProportionalToInternalTemperature As Adt7317TypeControlConfiguration3DacAOutput
    Get
    Set
public:
property Adt7317TypeControlConfiguration3DacAOutput ControlConfiguration3DACAOutputProportionalToInternalTemperature {
    Adt7317TypeControlConfiguration3DacAOutput get ();
    void set (Adt7317TypeControlConfiguration3DacAOutput value);
}
member ControlConfiguration3DACAOutputProportionalToInternalTemperature : Adt7317TypeControlConfiguration3DacAOutput with get, set

Property Value

Type: Adt7317TypeControlConfiguration3DacAOutput
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ControlConfiguration3DACBOutputProportionalToExternalTemperature Property

IRD

Adt7317ControlConfiguration3DACBOutputProportionalToExternalTemperature Property

Control Configuration 3: DAC B Output Proportional To External Temperature

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeControlConfiguration3DacBOutput ControlConfiguration3DACBOutputProportionalToExternalTemperature { get; set; }
Public Property ControlConfiguration3DACBOutputProportionalToExternalTemperature As Adt7317TypeControlConfiguration3DacBOutput
    Get
    Set
public:
property Adt7317TypeControlConfiguration3DacBOutput ControlConfiguration3DACBOutputProportionalToExternalTemperature {
    Adt7317TypeControlConfiguration3DacBOutput get ();
    void set (Adt7317TypeControlConfiguration3DacBOutput value);
}
member ControlConfiguration3DACBOutputProportionalToExternalTemperature : Adt7317TypeControlConfiguration3DacBOutput with get, set

Property Value

Type: Adt7317TypeControlConfiguration3DacBOutput
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ControlConfiguration3Resolution Property

IRD

Adt7317ControlConfiguration3Resolution Property

Control Configuration 3: Resolution

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeControlConfiguration3Resolution ControlConfiguration3Resolution { get; set; }
Public Property ControlConfiguration3Resolution As Adt7317TypeControlConfiguration3Resolution
    Get
    Set
public:
property Adt7317TypeControlConfiguration3Resolution ControlConfiguration3Resolution {
    Adt7317TypeControlConfiguration3Resolution get ();
    void set (Adt7317TypeControlConfiguration3Resolution value);
}
member ControlConfiguration3Resolution : Adt7317TypeControlConfiguration3Resolution with get, set

Property Value

Type: Adt7317TypeControlConfiguration3Resolution
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ControlConfiguration3Speed Property

IRD

Adt7317ControlConfiguration3Speed Property

Control Configuration 3: Speed

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeControlConfiguration3Speed ControlConfiguration3Speed { get; set; }
Public Property ControlConfiguration3Speed As Adt7317TypeControlConfiguration3Speed
    Get
    Set
public:
property Adt7317TypeControlConfiguration3Speed ControlConfiguration3Speed {
    Adt7317TypeControlConfiguration3Speed get ();
    void set (Adt7317TypeControlConfiguration3Speed value);
}
member ControlConfiguration3Speed : Adt7317TypeControlConfiguration3Speed with get, set

Property Value

Type: Adt7317TypeControlConfiguration3Speed
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ControlConfiguration3UpdatingOfDACOutputs Property

IRD

Adt7317ControlConfiguration3UpdatingOfDACOutputs Property

Control Configuration 3: Updating of DAC Outputs

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeControlConfiguration3UpdatingDacOutputs ControlConfiguration3UpdatingOfDACOutputs { get; set; }
Public Property ControlConfiguration3UpdatingOfDACOutputs As Adt7317TypeControlConfiguration3UpdatingDacOutputs
    Get
    Set
public:
property Adt7317TypeControlConfiguration3UpdatingDacOutputs ControlConfiguration3UpdatingOfDACOutputs {
    Adt7317TypeControlConfiguration3UpdatingDacOutputs get ();
    void set (Adt7317TypeControlConfiguration3UpdatingDacOutputs value);
}
member ControlConfiguration3UpdatingOfDACOutputs : Adt7317TypeControlConfiguration3UpdatingDacOutputs with get, set

Property Value

Type: Adt7317TypeControlConfiguration3UpdatingDacOutputs
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.DACA Property

IRD

Adt7317DACA Property

DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DACA { get; set; }
Public Property DACA As UShort
    Get
    Set
public:
property unsigned short DACA {
    unsigned short get ();
    void set (unsigned short value);
}
member DACA : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.DACB Property

IRD

Adt7317DACB Property

DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DACB { get; set; }
Public Property DACB As UShort
    Get
    Set
public:
property unsigned short DACB {
    unsigned short get ();
    void set (unsigned short value);
}
member DACB : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.DACC Property

IRD

Adt7317DACC Property

DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DACC { get; set; }
Public Property DACC As UShort
    Get
    Set
public:
property unsigned short DACC {
    unsigned short get ();
    void set (unsigned short value);
}
member DACC : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.DACConfigurationOutputRangeDACA Property

IRD

Adt7317DACConfigurationOutputRangeDACA Property

DAC Configuration: Output Range DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeDacConfigurationRange DACConfigurationOutputRangeDACA { get; set; }
Public Property DACConfigurationOutputRangeDACA As Adt7317TypeDacConfigurationRange
    Get
    Set
public:
property Adt7317TypeDacConfigurationRange DACConfigurationOutputRangeDACA {
    Adt7317TypeDacConfigurationRange get ();
    void set (Adt7317TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACA : Adt7317TypeDacConfigurationRange with get, set

Property Value

Type: Adt7317TypeDacConfigurationRange
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.DACConfigurationOutputRangeDACB Property

IRD

Adt7317DACConfigurationOutputRangeDACB Property

DAC Configuration: Output Range DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeDacConfigurationRange DACConfigurationOutputRangeDACB { get; set; }
Public Property DACConfigurationOutputRangeDACB As Adt7317TypeDacConfigurationRange
    Get
    Set
public:
property Adt7317TypeDacConfigurationRange DACConfigurationOutputRangeDACB {
    Adt7317TypeDacConfigurationRange get ();
    void set (Adt7317TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACB : Adt7317TypeDacConfigurationRange with get, set

Property Value

Type: Adt7317TypeDacConfigurationRange
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.DACConfigurationOutputRangeDACC Property

IRD

Adt7317DACConfigurationOutputRangeDACC Property

DAC Configuration: Output Range DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeDacConfigurationRange DACConfigurationOutputRangeDACC { get; set; }
Public Property DACConfigurationOutputRangeDACC As Adt7317TypeDacConfigurationRange
    Get
    Set
public:
property Adt7317TypeDacConfigurationRange DACConfigurationOutputRangeDACC {
    Adt7317TypeDacConfigurationRange get ();
    void set (Adt7317TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACC : Adt7317TypeDacConfigurationRange with get, set

Property Value

Type: Adt7317TypeDacConfigurationRange
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.DACConfigurationOutputRangeDACD Property

IRD

Adt7317DACConfigurationOutputRangeDACD Property

DAC Configuration: Output Range DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeDacConfigurationRange DACConfigurationOutputRangeDACD { get; set; }
Public Property DACConfigurationOutputRangeDACD As Adt7317TypeDacConfigurationRange
    Get
    Set
public:
property Adt7317TypeDacConfigurationRange DACConfigurationOutputRangeDACD {
    Adt7317TypeDacConfigurationRange get ();
    void set (Adt7317TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACD : Adt7317TypeDacConfigurationRange with get, set

Property Value

Type: Adt7317TypeDacConfigurationRange
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.DACConfigurationUpdate Property

IRD

Adt7317DACConfigurationUpdate Property

DAC Configuration: Update

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeDacConfigurationUpdate DACConfigurationUpdate { get; set; }
Public Property DACConfigurationUpdate As Adt7317TypeDacConfigurationUpdate
    Get
    Set
public:
property Adt7317TypeDacConfigurationUpdate DACConfigurationUpdate {
    Adt7317TypeDacConfigurationUpdate get ();
    void set (Adt7317TypeDacConfigurationUpdate value);
}
member DACConfigurationUpdate : Adt7317TypeDacConfigurationUpdate with get, set

Property Value

Type: Adt7317TypeDacConfigurationUpdate
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.DACConfigurationVREFBypassDACAB Property

IRD

Adt7317DACConfigurationVREFBypassDACAB Property

DAC Configuration: V_REF Bypass DAC A / B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeDacConfigurationBypass DACConfigurationVREFBypassDACAB { get; set; }
Public Property DACConfigurationVREFBypassDACAB As Adt7317TypeDacConfigurationBypass
    Get
    Set
public:
property Adt7317TypeDacConfigurationBypass DACConfigurationVREFBypassDACAB {
    Adt7317TypeDacConfigurationBypass get ();
    void set (Adt7317TypeDacConfigurationBypass value);
}
member DACConfigurationVREFBypassDACAB : Adt7317TypeDacConfigurationBypass with get, set

Property Value

Type: Adt7317TypeDacConfigurationBypass
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.DACConfigurationVREFBypassDACCD Property

IRD

Adt7317DACConfigurationVREFBypassDACCD Property

DAC Configuration: V_REF Bypass DAC C / D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeDacConfigurationBypass DACConfigurationVREFBypassDACCD { get; set; }
Public Property DACConfigurationVREFBypassDACCD As Adt7317TypeDacConfigurationBypass
    Get
    Set
public:
property Adt7317TypeDacConfigurationBypass DACConfigurationVREFBypassDACCD {
    Adt7317TypeDacConfigurationBypass get ();
    void set (Adt7317TypeDacConfigurationBypass value);
}
member DACConfigurationVREFBypassDACCD : Adt7317TypeDacConfigurationBypass with get, set

Property Value

Type: Adt7317TypeDacConfigurationBypass
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.DACD Property

IRD

Adt7317DACD Property

DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DACD { get; set; }
Public Property DACD As UShort
    Get
    Set
public:
property unsigned short DACD {
    unsigned short get ();
    void set (unsigned short value);
}
member DACD : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.DeviceID Property

IRD

Adt7317DeviceID Property

Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ExternalAnalogTemperatureOffset Property

IRD

Adt7317ExternalAnalogTemperatureOffset Property

External Analog Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalAnalogTemperatureOffset { get; set; }
Public Property ExternalAnalogTemperatureOffset As SByte
    Get
    Set
public:
property signed char ExternalAnalogTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member ExternalAnalogTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ExternalTemperature Property

IRD

Adt7317ExternalTemperature Property

External Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ExternalTemperature { get; }
Public ReadOnly Property ExternalTemperature As Double
    Get
public:
property double ExternalTemperature {
    double get ();
}
member ExternalTemperature : float with get

Property Value

Type: Double
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ExternalTemperatureOffset Property

IRD

Adt7317ExternalTemperatureOffset Property

External Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperatureOffset { get; set; }
Public Property ExternalTemperatureOffset As SByte
    Get
    Set
public:
property signed char ExternalTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member ExternalTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ExternalTHIGHLimit Property

IRD

Adt7317ExternalTHIGHLimit Property

External T_HIGH Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTHIGHLimit { get; set; }
Public Property ExternalTHIGHLimit As SByte
    Get
    Set
public:
property signed char ExternalTHIGHLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalTHIGHLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ExternalTLOWLimit Property

IRD

Adt7317ExternalTLOWLimit Property

External T_LOW Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTLOWLimit { get; set; }
Public Property ExternalTLOWLimit As SByte
    Get
    Set
public:
property signed char ExternalTLOWLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalTLOWLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.InternalAnalogTemperatureOffset Property

IRD

Adt7317InternalAnalogTemperatureOffset Property

Internal Analog Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalAnalogTemperatureOffset { get; set; }
Public Property InternalAnalogTemperatureOffset As SByte
    Get
    Set
public:
property signed char InternalAnalogTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member InternalAnalogTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.InternalTemperature Property

IRD

Adt7317InternalTemperature Property

Internal Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double InternalTemperature { get; }
Public ReadOnly Property InternalTemperature As Double
    Get
public:
property double InternalTemperature {
    double get ();
}
member InternalTemperature : float with get

Property Value

Type: Double
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.InternalTemperatureOffset Property

IRD

Adt7317InternalTemperatureOffset Property

Internal Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureOffset { get; set; }
Public Property InternalTemperatureOffset As SByte
    Get
    Set
public:
property signed char InternalTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member InternalTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.InternalTHIGHLimit Property

IRD

Adt7317InternalTHIGHLimit Property

Internal T_HIGH Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTHIGHLimit { get; set; }
Public Property InternalTHIGHLimit As SByte
    Get
    Set
public:
property signed char InternalTHIGHLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTHIGHLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.InternalTLOWLimit Property

IRD

Adt7317InternalTLOWLimit Property

Internal T_LOW Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTLOWLimit { get; set; }
Public Property InternalTLOWLimit As SByte
    Get
    Set
public:
property signed char InternalTLOWLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTLOWLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.InterruptMask1ExternalTemperatureFault Property

IRD

Adt7317InterruptMask1ExternalTemperatureFault Property

Interrupt Mask 1: External Temperature Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeInterruptMaskEnableDisable InterruptMask1ExternalTemperatureFault { get; set; }
Public Property InterruptMask1ExternalTemperatureFault As Adt7317TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7317TypeInterruptMaskEnableDisable InterruptMask1ExternalTemperatureFault {
    Adt7317TypeInterruptMaskEnableDisable get ();
    void set (Adt7317TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTemperatureFault : Adt7317TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7317TypeInterruptMaskEnableDisable
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.InterruptMask1ExternalTHIGH Property

IRD

Adt7317InterruptMask1ExternalTHIGH Property

Interrupt Mask 1: External T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeInterruptMaskEnableDisable InterruptMask1ExternalTHIGH { get; set; }
Public Property InterruptMask1ExternalTHIGH As Adt7317TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7317TypeInterruptMaskEnableDisable InterruptMask1ExternalTHIGH {
    Adt7317TypeInterruptMaskEnableDisable get ();
    void set (Adt7317TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTHIGH : Adt7317TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7317TypeInterruptMaskEnableDisable
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.InterruptMask1ExternalTLOW Property

IRD

Adt7317InterruptMask1ExternalTLOW Property

Interrupt Mask 1: External T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeInterruptMaskEnableDisable InterruptMask1ExternalTLOW { get; set; }
Public Property InterruptMask1ExternalTLOW As Adt7317TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7317TypeInterruptMaskEnableDisable InterruptMask1ExternalTLOW {
    Adt7317TypeInterruptMaskEnableDisable get ();
    void set (Adt7317TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTLOW : Adt7317TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7317TypeInterruptMaskEnableDisable
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.InterruptMask1InternalTHIGH Property

IRD

Adt7317InterruptMask1InternalTHIGH Property

Interrupt Mask 1: Internal T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeInterruptMaskEnableDisable InterruptMask1InternalTHIGH { get; set; }
Public Property InterruptMask1InternalTHIGH As Adt7317TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7317TypeInterruptMaskEnableDisable InterruptMask1InternalTHIGH {
    Adt7317TypeInterruptMaskEnableDisable get ();
    void set (Adt7317TypeInterruptMaskEnableDisable value);
}
member InterruptMask1InternalTHIGH : Adt7317TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7317TypeInterruptMaskEnableDisable
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.InterruptMask1InternalTLOW Property

IRD

Adt7317InterruptMask1InternalTLOW Property

Interrupt Mask 1: Internal T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeInterruptMaskEnableDisable InterruptMask1InternalTLOW { get; set; }
Public Property InterruptMask1InternalTLOW As Adt7317TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7317TypeInterruptMaskEnableDisable InterruptMask1InternalTLOW {
    Adt7317TypeInterruptMaskEnableDisable get ();
    void set (Adt7317TypeInterruptMaskEnableDisable value);
}
member InterruptMask1InternalTLOW : Adt7317TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7317TypeInterruptMaskEnableDisable
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.InterruptMask2VDD Property

IRD

Adt7317InterruptMask2VDD Property

Interrupt Mask 2: V_DD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeInterruptMaskEnableDisable InterruptMask2VDD { get; set; }
Public Property InterruptMask2VDD As Adt7317TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7317TypeInterruptMaskEnableDisable InterruptMask2VDD {
    Adt7317TypeInterruptMaskEnableDisable get ();
    void set (Adt7317TypeInterruptMaskEnableDisable value);
}
member InterruptMask2VDD : Adt7317TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7317TypeInterruptMaskEnableDisable
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.InterruptStatus1ExternalSensorFault Property

IRD

Adt7317InterruptStatus1ExternalSensorFault Property

Interrupt Status 1: External Sensor Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeInterruptStatus InterruptStatus1ExternalSensorFault { get; }
Public ReadOnly Property InterruptStatus1ExternalSensorFault As Adt7317TypeInterruptStatus
    Get
public:
property Adt7317TypeInterruptStatus InterruptStatus1ExternalSensorFault {
    Adt7317TypeInterruptStatus get ();
}
member InterruptStatus1ExternalSensorFault : Adt7317TypeInterruptStatus with get

Property Value

Type: Adt7317TypeInterruptStatus
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.InterruptStatus1TEXTTHIGH Property

IRD

Adt7317InterruptStatus1TEXTTHIGH Property

Interrupt Status 1: T_EXT > T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeInterruptStatus InterruptStatus1TEXTTHIGH { get; }
Public ReadOnly Property InterruptStatus1TEXTTHIGH As Adt7317TypeInterruptStatus
    Get
public:
property Adt7317TypeInterruptStatus InterruptStatus1TEXTTHIGH {
    Adt7317TypeInterruptStatus get ();
}
member InterruptStatus1TEXTTHIGH : Adt7317TypeInterruptStatus with get

Property Value

Type: Adt7317TypeInterruptStatus
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.InterruptStatus1TEXTTLOW Property

IRD

Adt7317InterruptStatus1TEXTTLOW Property

Interrupt Status 1: T_EXT <= T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeInterruptStatus InterruptStatus1TEXTTLOW { get; }
Public ReadOnly Property InterruptStatus1TEXTTLOW As Adt7317TypeInterruptStatus
    Get
public:
property Adt7317TypeInterruptStatus InterruptStatus1TEXTTLOW {
    Adt7317TypeInterruptStatus get ();
}
member InterruptStatus1TEXTTLOW : Adt7317TypeInterruptStatus with get

Property Value

Type: Adt7317TypeInterruptStatus
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.InterruptStatus1TINTTHIGH Property

IRD

Adt7317InterruptStatus1TINTTHIGH Property

Interrupt Status 1: T_INT > T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeInterruptStatus InterruptStatus1TINTTHIGH { get; }
Public ReadOnly Property InterruptStatus1TINTTHIGH As Adt7317TypeInterruptStatus
    Get
public:
property Adt7317TypeInterruptStatus InterruptStatus1TINTTHIGH {
    Adt7317TypeInterruptStatus get ();
}
member InterruptStatus1TINTTHIGH : Adt7317TypeInterruptStatus with get

Property Value

Type: Adt7317TypeInterruptStatus
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.InterruptStatus1TINTTLOW Property

IRD

Adt7317InterruptStatus1TINTTLOW Property

Interrupt Status 1: T_INT <= T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeInterruptStatus InterruptStatus1TINTTLOW { get; }
Public ReadOnly Property InterruptStatus1TINTTLOW As Adt7317TypeInterruptStatus
    Get
public:
property Adt7317TypeInterruptStatus InterruptStatus1TINTTLOW {
    Adt7317TypeInterruptStatus get ();
}
member InterruptStatus1TINTTLOW : Adt7317TypeInterruptStatus with get

Property Value

Type: Adt7317TypeInterruptStatus
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.InterruptStatus2VDDVHIGHVDDVLOW Property

IRD

Adt7317InterruptStatus2VDDVHIGHVDDVLOW Property

Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeInterruptStatus InterruptStatus2VDDVHIGHVDDVLOW { get; }
Public ReadOnly Property InterruptStatus2VDDVHIGHVDDVLOW As Adt7317TypeInterruptStatus
    Get
public:
property Adt7317TypeInterruptStatus InterruptStatus2VDDVHIGHVDDVLOW {
    Adt7317TypeInterruptStatus get ();
}
member InterruptStatus2VDDVHIGHVDDVLOW : Adt7317TypeInterruptStatus with get

Property Value

Type: Adt7317TypeInterruptStatus
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.LDACConfigurationDACA Property

IRD

Adt7317LDACConfigurationDACA Property

LDAC Configuration: DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeLdacConfigurationUpdate LDACConfigurationDACA { set; }
Public WriteOnly Property LDACConfigurationDACA As Adt7317TypeLdacConfigurationUpdate
    Set
public:
property Adt7317TypeLdacConfigurationUpdate LDACConfigurationDACA {
    void set (Adt7317TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACA : Adt7317TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7317TypeLdacConfigurationUpdate
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.LDACConfigurationDACB Property

IRD

Adt7317LDACConfigurationDACB Property

LDAC Configuration: DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeLdacConfigurationUpdate LDACConfigurationDACB { set; }
Public WriteOnly Property LDACConfigurationDACB As Adt7317TypeLdacConfigurationUpdate
    Set
public:
property Adt7317TypeLdacConfigurationUpdate LDACConfigurationDACB {
    void set (Adt7317TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACB : Adt7317TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7317TypeLdacConfigurationUpdate
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.LDACConfigurationDACC Property

IRD

Adt7317LDACConfigurationDACC Property

LDAC Configuration: DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeLdacConfigurationUpdate LDACConfigurationDACC { set; }
Public WriteOnly Property LDACConfigurationDACC As Adt7317TypeLdacConfigurationUpdate
    Set
public:
property Adt7317TypeLdacConfigurationUpdate LDACConfigurationDACC {
    void set (Adt7317TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACC : Adt7317TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7317TypeLdacConfigurationUpdate
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.LDACConfigurationDACD Property

IRD

Adt7317LDACConfigurationDACD Property

LDAC Configuration: DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeLdacConfigurationUpdate LDACConfigurationDACD { set; }
Public WriteOnly Property LDACConfigurationDACD As Adt7317TypeLdacConfigurationUpdate
    Set
public:
property Adt7317TypeLdacConfigurationUpdate LDACConfigurationDACD {
    void set (Adt7317TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACD : Adt7317TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7317TypeLdacConfigurationUpdate
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.ManufacturerSID Property

IRD

Adt7317ManufacturerSID Property

Manufacturer's ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerSID { get; }
Public ReadOnly Property ManufacturerSID As Byte
    Get
public:
property unsigned char ManufacturerSID {
    unsigned char get ();
}
member ManufacturerSID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.SiliconRevisionStepping Property

IRD

Adt7317SiliconRevisionStepping Property

Silicon Revision: Stepping

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SiliconRevisionStepping { get; }
Public ReadOnly Property SiliconRevisionStepping As Byte
    Get
public:
property unsigned char SiliconRevisionStepping {
    unsigned char get ();
}
member SiliconRevisionStepping : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.SiliconRevisionVersion Property

IRD

Adt7317SiliconRevisionVersion Property

Silicon Revision: Version

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SiliconRevisionVersion { get; }
Public ReadOnly Property SiliconRevisionVersion As Byte
    Get
public:
property unsigned char SiliconRevisionVersion {
    unsigned char get ();
}
member SiliconRevisionVersion : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.SPILockStatus Property

IRD

Adt7317SPILockStatus Property

SPI Lock Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7317TypeSpiLockStatus SPILockStatus { get; }
Public ReadOnly Property SPILockStatus As Adt7317TypeSpiLockStatus
    Get
public:
property Adt7317TypeSpiLockStatus SPILockStatus {
    Adt7317TypeSpiLockStatus get ();
}
member SPILockStatus : Adt7317TypeSpiLockStatus with get

Property Value

Type: Adt7317TypeSpiLockStatus
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.VDD Property

IRD

Adt7317VDD Property

V_DD (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDD { get; }
Public ReadOnly Property VDD As Double
    Get
public:
property double VDD {
    double get ();
}
member VDD : float with get

Property Value

Type: Double
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.VDDVHIGHLimit Property

IRD

Adt7317VDDVHIGHLimit Property

V_DD V_HIGH Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDDVHIGHLimit { get; set; }
Public Property VDDVHIGHLimit As Double
    Get
    Set
public:
property double VDDVHIGHLimit {
    double get ();
    void set (double value);
}
member VDDVHIGHLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.VDDVLOWLimit Property

IRD

Adt7317VDDVLOWLimit Property

V_DD V_LOW Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDDVLOWLimit { get; set; }
Public Property VDDVLOWLimit As Double
    Get
    Set
public:
property double VDDVLOWLimit {
    double get ();
    void set (double value);
}
member VDDVLOWLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317 Methods

The Adt7317 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.Flush Method

IRD

Adt7317Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adt7317 Class
telos.Ird.AnalogDevices Namespace


Adt7317.TypeControlConfiguration1IntOutput Enumeration

IRD

Adt7317TypeControlConfiguration1IntOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1IntOutput
Public Enumeration TypeControlConfiguration1IntOutput
public enum class TypeControlConfiguration1IntOutput
type TypeControlConfiguration1IntOutput
Members
Member name | Value | Description
INTOutputEnabled | 0 | INT Output: Enabled
INTOutputDisabled | 1 | INT Output: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeControlConfiguration1IntOutputPolarity Enumeration

IRD

Adt7317TypeControlConfiguration1IntOutputPolarity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1IntOutputPolarity
Public Enumeration TypeControlConfiguration1IntOutputPolarity
public enum class TypeControlConfiguration1IntOutputPolarity
type TypeControlConfiguration1IntOutputPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeControlConfiguration1Monitoring Enumeration

IRD

Adt7317TypeControlConfiguration1Monitoring Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1Monitoring
Public Enumeration TypeControlConfiguration1Monitoring
public enum class TypeControlConfiguration1Monitoring
type TypeControlConfiguration1Monitoring
Members
Member name | Value | Description
StopMonitoring | 0 | Stop Monitoring
StartMonitoring | 1 | Start Monitoring
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeControlConfiguration1PowerDown Enumeration

IRD

Adt7317TypeControlConfiguration1PowerDown Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1PowerDown
Public Enumeration TypeControlConfiguration1PowerDown
public enum class TypeControlConfiguration1PowerDown
type TypeControlConfiguration1PowerDown
Members
Member name | Value | Description
PowerUp | 0 | Power Up
PowerDown | 1 | Power Down
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeControlConfiguration2Averaging Enumeration

IRD

Adt7317TypeControlConfiguration2Averaging Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Averaging
Public Enumeration TypeControlConfiguration2Averaging
public enum class TypeControlConfiguration2Averaging
type TypeControlConfiguration2Averaging
Members
Member name | Value | Description
AveragingEnabled | 0 | Averaging Enabled
AveragingDisabled | 1 | Averaging Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeControlConfiguration2ChannelSelection Enumeration

IRD

Adt7317TypeControlConfiguration2ChannelSelection Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2ChannelSelection
Public Enumeration TypeControlConfiguration2ChannelSelection
public enum class TypeControlConfiguration2ChannelSelection
type TypeControlConfiguration2ChannelSelection
Members
Member name | Value | Description
VDD | 0 | V_DD
InternalTemperatureSensor | 1 | Internal Temperature Sensor
ExternalTemperatureSensor | 2 | External Temperature Sensor
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeControlConfiguration2Conversion Enumeration

IRD

Adt7317TypeControlConfiguration2Conversion Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Conversion
Public Enumeration TypeControlConfiguration2Conversion
public enum class TypeControlConfiguration2Conversion
type TypeControlConfiguration2Conversion
Members
Member name | Value | Description
RoundRobin | 0 | Round Robin
SingleChannel | 1 | Single Channel
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeControlConfiguration2SoftwareReset Enumeration

IRD

Adt7317TypeControlConfiguration2SoftwareReset Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2SoftwareReset
Public Enumeration TypeControlConfiguration2SoftwareReset
public enum class TypeControlConfiguration2SoftwareReset
type TypeControlConfiguration2SoftwareReset
Members
Member name | Value | Description
Default | 0 | Default
SoftwareReset | 1 | Software Reset
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeControlConfiguration2Timeout Enumeration

IRD

Adt7317TypeControlConfiguration2Timeout Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Timeout
Public Enumeration TypeControlConfiguration2Timeout
public enum class TypeControlConfiguration2Timeout
type TypeControlConfiguration2Timeout
Members
Member name | Value | Description
SMBusTimeoutDisabled | 0 | SMBus Timeout: Disabled
SMBusTimeoutEnabled | 1 | SMBus Timeout: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeControlConfiguration3DacAOutput Enumeration

IRD

Adt7317TypeControlConfiguration3DacAOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3DacAOutput
Public Enumeration TypeControlConfiguration3DacAOutput
public enum class TypeControlConfiguration3DacAOutput
type TypeControlConfiguration3DacAOutput
Members
Member name | Value | Description
NotProportional | 0 | Not Proportional
Proportional | 1 | Proportional
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeControlConfiguration3DacBOutput Enumeration

IRD

Adt7317TypeControlConfiguration3DacBOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3DacBOutput
Public Enumeration TypeControlConfiguration3DacBOutput
public enum class TypeControlConfiguration3DacBOutput
type TypeControlConfiguration3DacBOutput
Members
Member name | Value | Description
NotProportional | 0 | Not Proportional
Proportional | 1 | Proportional
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeControlConfiguration3Resolution Enumeration

IRD

Adt7317TypeControlConfiguration3Resolution Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3Resolution
Public Enumeration TypeControlConfiguration3Resolution
public enum class TypeControlConfiguration3Resolution
type TypeControlConfiguration3Resolution
Members
Member name | Value | Description
Value_8Bit | 0 | 8-bit
Value_10Bit | 1 | 10-bit
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeControlConfiguration3Speed Enumeration

IRD

Adt7317TypeControlConfiguration3Speed Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3Speed
Public Enumeration TypeControlConfiguration3Speed
public enum class TypeControlConfiguration3Speed
type TypeControlConfiguration3Speed
Members
Member name | Value | Description
Value_14KHz | 0 | 1.4 kHz
Value_225KHz | 1 | 22.5 kHz
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeControlConfiguration3UpdatingDacOutputs Enumeration

IRD

Adt7317TypeControlConfiguration3UpdatingDacOutputs Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3UpdatingDacOutputs
Public Enumeration TypeControlConfiguration3UpdatingDacOutputs
public enum class TypeControlConfiguration3UpdatingDacOutputs
type TypeControlConfiguration3UpdatingDacOutputs
Members
Member name | Value | Description
LDACPin | 0 | LDAC Pin
DACLDACConfiguration | 1 | DAC & LDAC Configuration
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeDacConfigurationBypass Enumeration

IRD

Adt7317TypeDacConfigurationBypass Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacConfigurationBypass
Public Enumeration TypeDacConfigurationBypass
public enum class TypeDacConfigurationBypass
type TypeDacConfigurationBypass
Members
Member name | Value | Description
BypassReferenceBufferDisabled | 0 | Bypass Reference Buffer: Disabled
BypassReferenceBufferEnabled | 1 | Bypass Reference Buffer: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeDacConfigurationRange Enumeration

IRD

Adt7317TypeDacConfigurationRange Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacConfigurationRange
Public Enumeration TypeDacConfigurationRange
public enum class TypeDacConfigurationRange
type TypeDacConfigurationRange
Members
Member name | Value | Description
Value_0VToVREF | 0 | 0V to V_REF
Value_0VTo2VREF | 1 | 0V to 2 V_REF
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeDacConfigurationUpdate Enumeration

IRD

Adt7317TypeDacConfigurationUpdate Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacConfigurationUpdate
Public Enumeration TypeDacConfigurationUpdate
public enum class TypeDacConfigurationUpdate
type TypeDacConfigurationUpdate
Members
Member name | Value | Description
MSBWriteToAnyDACRegisterGeneratesLDACCommandThatUpdatesThatDACOnly | 0 | MSB write to any DAC register generates LDAC command that updates that DAC only
MSBWriteToDACBOrDACDRegisterGeneratesLDACCommandThatUpdatesDACAAndDACBOrDACCAndDACDRespectively | 1 | MSB write to DAC B or DAC D register generates LDAC command that updates DAC A and DAC B or DAC C and DAC D, respectively
MSBWriteToDACDRegisterGeneratesLDACCommandThatUpdatesAllFourDACs | 2 | MSB write to DAC D register generates LDAC command that updates all four DACs
LDACCommandGeneratedFromLDACRegister | 3 | LDAC command generated from LDAC register
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeInterruptMaskEnableDisable Enumeration

IRD

Adt7317TypeInterruptMaskEnableDisable Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptMaskEnableDisable
Public Enumeration TypeInterruptMaskEnableDisable
public enum class TypeInterruptMaskEnableDisable
type TypeInterruptMaskEnableDisable
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeInterruptStatus Enumeration

IRD

Adt7317TypeInterruptStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatus
Public Enumeration TypeInterruptStatus
public enum class TypeInterruptStatus
type TypeInterruptStatus
Members
Member name | Value | Description
NotSet | 0 | Not Set
Set | 1 | Set
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeLdacConfigurationUpdate Enumeration

IRD

Adt7317TypeLdacConfigurationUpdate Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLdacConfigurationUpdate
Public Enumeration TypeLdacConfigurationUpdate
public enum class TypeLdacConfigurationUpdate
type TypeLdacConfigurationUpdate
Members
Member name | Value | Description
DoNotUpdate | 0 | Do Not Update
Update | 1 | Update
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7317.TypeSpiLockStatus Enumeration

IRD

Adt7317TypeSpiLockStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSpiLockStatus
Public Enumeration TypeSpiLockStatus
public enum class TypeSpiLockStatus
type TypeSpiLockStatus
Members
Member name | Value | Description
I2CInterface | 0 | I2C Interface
SPIInterfaceLocked | 1 | SPI Interface / Locked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318 Class

Analog Devices: ADT 7318
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdt7318

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adt7318
Public Class Adt7318
public ref class Adt7318
type Adt7318 =  class end

The Adt7318 type exposes the following members.

Constructors
 | Name | Description
Public method | Adt7318 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlConfiguration1INTOutput | Control Configuration 1: INT Output
Public property | ControlConfiguration1INTOutputPolarity | Control Configuration 1: INT Output Polarity
Public property | ControlConfiguration1Monitoring | Control Configuration 1: Monitoring
Public property | ControlConfiguration1PowerDown | Control Configuration 1: Power Down
Public property | ControlConfiguration2Averaging | Control Configuration 2: Averaging
Public property | ControlConfiguration2ChannelSelection | Control Configuration 2: Channel Selection
Public property | ControlConfiguration2Conversion | Control Configuration 2: Conversion
Public property | ControlConfiguration2SMBusTimeout | Control Configuration 2: SMBus Timeout
Public property | ControlConfiguration2SoftwareReset | Control Configuration 2: Software Reset
Public property | ControlConfiguration3DACAOutputProportionalToInternalTemperature | Control Configuration 3: DAC A Output Proportional To Internal Temperature
Public property | ControlConfiguration3DACBOutputProportionalToExternalTemperature | Control Configuration 3: DAC B Output Proportional To External Temperature
Public property | ControlConfiguration3Speed | Control Configuration 3: Speed
Public property | ControlConfiguration3UpdatingOfDACOutputs | Control Configuration 3: Updating of DAC Outputs
Public property | DACA | DAC A
Public property | DACB | DAC B
Public property | DACC | DAC C
Public property | DACConfigurationOutputRangeDACA | DAC Configuration: Output Range DAC A
Public property | DACConfigurationOutputRangeDACB | DAC Configuration: Output Range DAC B
Public property | DACConfigurationOutputRangeDACC | DAC Configuration: Output Range DAC C
Public property | DACConfigurationOutputRangeDACD | DAC Configuration: Output Range DAC D
Public property | DACConfigurationUpdate | DAC Configuration: Update
Public property | DACConfigurationVREFBypassDACAB | DAC Configuration: V_REF Bypass DAC A / B
Public property | DACConfigurationVREFBypassDACCD | DAC Configuration: V_REF Bypass DAC C / D
Public property | DACD | DAC D
Public property | DeviceID | Device ID
Public property | ExternalAnalogTemperatureOffset | External Analog Temperature Offset (unit: °C)
Public property | ExternalTemperature | External Temperature (unit: °C)
Public property | ExternalTemperatureOffset | External Temperature Offset (unit: °C)
Public property | ExternalTHIGHLimit | External T_HIGH Limit (unit: °C)
Public property | ExternalTLOWLimit | External T_LOW Limit (unit: °C)
Public property | InternalAnalogTemperatureOffset | Internal Analog Temperature Offset (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | InternalTemperatureOffset | Internal Temperature Offset (unit: °C)
Public property | InternalTHIGHLimit | Internal T_HIGH Limit (unit: °C)
Public property | InternalTLOWLimit | Internal T_LOW Limit (unit: °C)
Public property | InterruptMask1ExternalTemperatureFault | Interrupt Mask 1: External Temperature Fault
Public property | InterruptMask1ExternalTHIGH | Interrupt Mask 1: External T_HIGH
Public property | InterruptMask1ExternalTLOW | Interrupt Mask 1: External T_LOW
Public property | InterruptMask1InternalTHIGH | Interrupt Mask 1: Internal T_HIGH
Public property | InterruptMask1InternalTLOW | Interrupt Mask 1: Internal T_LOW
Public property | InterruptMask2VDD | Interrupt Mask 2: V_DD
Public property | InterruptStatus1ExternalSensorFault | Interrupt Status 1: External Sensor Fault
Public property | InterruptStatus1TEXTTHIGH | Interrupt Status 1: T_EXT > T_HIGH
Public property | InterruptStatus1TEXTTLOW | Interrupt Status 1: T_EXT <= T_LOW
Public property | InterruptStatus1TINTTHIGH | Interrupt Status 1: T_INT > T_HIGH
Public property | InterruptStatus1TINTTLOW | Interrupt Status 1: T_INT <= T_LOW
Public property | InterruptStatus2VDDVHIGHVDDVLOW | Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW
Public property | LDACConfigurationDACA | LDAC Configuration: DAC A
Public property | LDACConfigurationDACB | LDAC Configuration: DAC B
Public property | LDACConfigurationDACC | LDAC Configuration: DAC C
Public property | LDACConfigurationDACD | LDAC Configuration: DAC D
Public property | ManufacturerSID | Manufacturer's ID
Public property | SiliconRevisionStepping | Silicon Revision: Stepping
Public property | SiliconRevisionVersion | Silicon Revision: Version
Public property | SPILockStatus | SPI Lock Status
Public property | VDD | V_DD (unit: V)
Public property | VDDVHIGHLimit | V_DD V_HIGH Limit (unit: V)
Public property | VDDVLOWLimit | V_DD V_LOW Limit (unit: V)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
±0.5°C Accurate Digital Temperature Sensor and Quad Voltage Output 8-Bit DACs
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adt7318(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adt7318

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318 Properties

The Adt7318 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlConfiguration1INTOutput | Control Configuration 1: INT Output
Public property | ControlConfiguration1INTOutputPolarity | Control Configuration 1: INT Output Polarity
Public property | ControlConfiguration1Monitoring | Control Configuration 1: Monitoring
Public property | ControlConfiguration1PowerDown | Control Configuration 1: Power Down
Public property | ControlConfiguration2Averaging | Control Configuration 2: Averaging
Public property | ControlConfiguration2ChannelSelection | Control Configuration 2: Channel Selection
Public property | ControlConfiguration2Conversion | Control Configuration 2: Conversion
Public property | ControlConfiguration2SMBusTimeout | Control Configuration 2: SMBus Timeout
Public property | ControlConfiguration2SoftwareReset | Control Configuration 2: Software Reset
Public property | ControlConfiguration3DACAOutputProportionalToInternalTemperature | Control Configuration 3: DAC A Output Proportional To Internal Temperature
Public property | ControlConfiguration3DACBOutputProportionalToExternalTemperature | Control Configuration 3: DAC B Output Proportional To External Temperature
Public property | ControlConfiguration3Speed | Control Configuration 3: Speed
Public property | ControlConfiguration3UpdatingOfDACOutputs | Control Configuration 3: Updating of DAC Outputs
Public property | DACA | DAC A
Public property | DACB | DAC B
Public property | DACC | DAC C
Public property | DACConfigurationOutputRangeDACA | DAC Configuration: Output Range DAC A
Public property | DACConfigurationOutputRangeDACB | DAC Configuration: Output Range DAC B
Public property | DACConfigurationOutputRangeDACC | DAC Configuration: Output Range DAC C
Public property | DACConfigurationOutputRangeDACD | DAC Configuration: Output Range DAC D
Public property | DACConfigurationUpdate | DAC Configuration: Update
Public property | DACConfigurationVREFBypassDACAB | DAC Configuration: V_REF Bypass DAC A / B
Public property | DACConfigurationVREFBypassDACCD | DAC Configuration: V_REF Bypass DAC C / D
Public property | DACD | DAC D
Public property | DeviceID | Device ID
Public property | ExternalAnalogTemperatureOffset | External Analog Temperature Offset (unit: °C)
Public property | ExternalTemperature | External Temperature (unit: °C)
Public property | ExternalTemperatureOffset | External Temperature Offset (unit: °C)
Public property | ExternalTHIGHLimit | External T_HIGH Limit (unit: °C)
Public property | ExternalTLOWLimit | External T_LOW Limit (unit: °C)
Public property | InternalAnalogTemperatureOffset | Internal Analog Temperature Offset (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | InternalTemperatureOffset | Internal Temperature Offset (unit: °C)
Public property | InternalTHIGHLimit | Internal T_HIGH Limit (unit: °C)
Public property | InternalTLOWLimit | Internal T_LOW Limit (unit: °C)
Public property | InterruptMask1ExternalTemperatureFault | Interrupt Mask 1: External Temperature Fault
Public property | InterruptMask1ExternalTHIGH | Interrupt Mask 1: External T_HIGH
Public property | InterruptMask1ExternalTLOW | Interrupt Mask 1: External T_LOW
Public property | InterruptMask1InternalTHIGH | Interrupt Mask 1: Internal T_HIGH
Public property | InterruptMask1InternalTLOW | Interrupt Mask 1: Internal T_LOW
Public property | InterruptMask2VDD | Interrupt Mask 2: V_DD
Public property | InterruptStatus1ExternalSensorFault | Interrupt Status 1: External Sensor Fault
Public property | InterruptStatus1TEXTTHIGH | Interrupt Status 1: T_EXT > T_HIGH
Public property | InterruptStatus1TEXTTLOW | Interrupt Status 1: T_EXT <= T_LOW
Public property | InterruptStatus1TINTTHIGH | Interrupt Status 1: T_INT > T_HIGH
Public property | InterruptStatus1TINTTLOW | Interrupt Status 1: T_INT <= T_LOW
Public property | InterruptStatus2VDDVHIGHVDDVLOW | Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW
Public property | LDACConfigurationDACA | LDAC Configuration: DAC A
Public property | LDACConfigurationDACB | LDAC Configuration: DAC B
Public property | LDACConfigurationDACC | LDAC Configuration: DAC C
Public property | LDACConfigurationDACD | LDAC Configuration: DAC D
Public property | ManufacturerSID | Manufacturer's ID
Public property | SiliconRevisionStepping | Silicon Revision: Stepping
Public property | SiliconRevisionVersion | Silicon Revision: Version
Public property | SPILockStatus | SPI Lock Status
Public property | VDD | V_DD (unit: V)
Public property | VDDVHIGHLimit | V_DD V_HIGH Limit (unit: V)
Public property | VDDVLOWLimit | V_DD V_LOW Limit (unit: V)
Top
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.AutoFlush Property

IRD

Adt7318AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ControlConfiguration1INTOutput Property

IRD

Adt7318ControlConfiguration1INTOutput Property

Control Configuration 1: INT Output

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeControlConfiguration1IntOutput ControlConfiguration1INTOutput { get; set; }
Public Property ControlConfiguration1INTOutput As Adt7318TypeControlConfiguration1IntOutput
    Get
    Set
public:
property Adt7318TypeControlConfiguration1IntOutput ControlConfiguration1INTOutput {
    Adt7318TypeControlConfiguration1IntOutput get ();
    void set (Adt7318TypeControlConfiguration1IntOutput value);
}
member ControlConfiguration1INTOutput : Adt7318TypeControlConfiguration1IntOutput with get, set

Property Value

Type: Adt7318TypeControlConfiguration1IntOutput
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ControlConfiguration1INTOutputPolarity Property

IRD

Adt7318ControlConfiguration1INTOutputPolarity Property

Control Configuration 1: INT Output Polarity

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeControlConfiguration1IntOutputPolarity ControlConfiguration1INTOutputPolarity { get; set; }
Public Property ControlConfiguration1INTOutputPolarity As Adt7318TypeControlConfiguration1IntOutputPolarity
    Get
    Set
public:
property Adt7318TypeControlConfiguration1IntOutputPolarity ControlConfiguration1INTOutputPolarity {
    Adt7318TypeControlConfiguration1IntOutputPolarity get ();
    void set (Adt7318TypeControlConfiguration1IntOutputPolarity value);
}
member ControlConfiguration1INTOutputPolarity : Adt7318TypeControlConfiguration1IntOutputPolarity with get, set

Property Value

Type: Adt7318TypeControlConfiguration1IntOutputPolarity
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ControlConfiguration1Monitoring Property

IRD

Adt7318ControlConfiguration1Monitoring Property

Control Configuration 1: Monitoring

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeControlConfiguration1Monitoring ControlConfiguration1Monitoring { get; set; }
Public Property ControlConfiguration1Monitoring As Adt7318TypeControlConfiguration1Monitoring
    Get
    Set
public:
property Adt7318TypeControlConfiguration1Monitoring ControlConfiguration1Monitoring {
    Adt7318TypeControlConfiguration1Monitoring get ();
    void set (Adt7318TypeControlConfiguration1Monitoring value);
}
member ControlConfiguration1Monitoring : Adt7318TypeControlConfiguration1Monitoring with get, set

Property Value

Type: Adt7318TypeControlConfiguration1Monitoring
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ControlConfiguration1PowerDown Property

IRD

Adt7318ControlConfiguration1PowerDown Property

Control Configuration 1: Power Down

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeControlConfiguration1PowerDown ControlConfiguration1PowerDown { get; set; }
Public Property ControlConfiguration1PowerDown As Adt7318TypeControlConfiguration1PowerDown
    Get
    Set
public:
property Adt7318TypeControlConfiguration1PowerDown ControlConfiguration1PowerDown {
    Adt7318TypeControlConfiguration1PowerDown get ();
    void set (Adt7318TypeControlConfiguration1PowerDown value);
}
member ControlConfiguration1PowerDown : Adt7318TypeControlConfiguration1PowerDown with get, set

Property Value

Type: Adt7318TypeControlConfiguration1PowerDown
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ControlConfiguration2Averaging Property

IRD

Adt7318ControlConfiguration2Averaging Property

Control Configuration 2: Averaging

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeControlConfiguration2Averaging ControlConfiguration2Averaging { get; set; }
Public Property ControlConfiguration2Averaging As Adt7318TypeControlConfiguration2Averaging
    Get
    Set
public:
property Adt7318TypeControlConfiguration2Averaging ControlConfiguration2Averaging {
    Adt7318TypeControlConfiguration2Averaging get ();
    void set (Adt7318TypeControlConfiguration2Averaging value);
}
member ControlConfiguration2Averaging : Adt7318TypeControlConfiguration2Averaging with get, set

Property Value

Type: Adt7318TypeControlConfiguration2Averaging
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ControlConfiguration2ChannelSelection Property

IRD

Adt7318ControlConfiguration2ChannelSelection Property

Control Configuration 2: Channel Selection

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeControlConfiguration2ChannelSelection ControlConfiguration2ChannelSelection { get; set; }
Public Property ControlConfiguration2ChannelSelection As Adt7318TypeControlConfiguration2ChannelSelection
    Get
    Set
public:
property Adt7318TypeControlConfiguration2ChannelSelection ControlConfiguration2ChannelSelection {
    Adt7318TypeControlConfiguration2ChannelSelection get ();
    void set (Adt7318TypeControlConfiguration2ChannelSelection value);
}
member ControlConfiguration2ChannelSelection : Adt7318TypeControlConfiguration2ChannelSelection with get, set

Property Value

Type: Adt7318TypeControlConfiguration2ChannelSelection
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ControlConfiguration2Conversion Property

IRD

Adt7318ControlConfiguration2Conversion Property

Control Configuration 2: Conversion

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeControlConfiguration2Conversion ControlConfiguration2Conversion { get; set; }
Public Property ControlConfiguration2Conversion As Adt7318TypeControlConfiguration2Conversion
    Get
    Set
public:
property Adt7318TypeControlConfiguration2Conversion ControlConfiguration2Conversion {
    Adt7318TypeControlConfiguration2Conversion get ();
    void set (Adt7318TypeControlConfiguration2Conversion value);
}
member ControlConfiguration2Conversion : Adt7318TypeControlConfiguration2Conversion with get, set

Property Value

Type: Adt7318TypeControlConfiguration2Conversion
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ControlConfiguration2SMBusTimeout Property

IRD

Adt7318ControlConfiguration2SMBusTimeout Property

Control Configuration 2: SMBus Timeout

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeControlConfiguration2Timeout ControlConfiguration2SMBusTimeout { get; set; }
Public Property ControlConfiguration2SMBusTimeout As Adt7318TypeControlConfiguration2Timeout
    Get
    Set
public:
property Adt7318TypeControlConfiguration2Timeout ControlConfiguration2SMBusTimeout {
    Adt7318TypeControlConfiguration2Timeout get ();
    void set (Adt7318TypeControlConfiguration2Timeout value);
}
member ControlConfiguration2SMBusTimeout : Adt7318TypeControlConfiguration2Timeout with get, set

Property Value

Type: Adt7318TypeControlConfiguration2Timeout
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ControlConfiguration2SoftwareReset Property

IRD

Adt7318ControlConfiguration2SoftwareReset Property

Control Configuration 2: Software Reset

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeControlConfiguration2SoftwareReset ControlConfiguration2SoftwareReset { get; set; }
Public Property ControlConfiguration2SoftwareReset As Adt7318TypeControlConfiguration2SoftwareReset
    Get
    Set
public:
property Adt7318TypeControlConfiguration2SoftwareReset ControlConfiguration2SoftwareReset {
    Adt7318TypeControlConfiguration2SoftwareReset get ();
    void set (Adt7318TypeControlConfiguration2SoftwareReset value);
}
member ControlConfiguration2SoftwareReset : Adt7318TypeControlConfiguration2SoftwareReset with get, set

Property Value

Type: Adt7318TypeControlConfiguration2SoftwareReset
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ControlConfiguration3DACAOutputProportionalToInternalTemperature Property

IRD

Adt7318ControlConfiguration3DACAOutputProportionalToInternalTemperature Property

Control Configuration 3: DAC A Output Proportional To Internal Temperature

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeControlConfiguration3DacAOutput ControlConfiguration3DACAOutputProportionalToInternalTemperature { get; set; }
Public Property ControlConfiguration3DACAOutputProportionalToInternalTemperature As Adt7318TypeControlConfiguration3DacAOutput
    Get
    Set
public:
property Adt7318TypeControlConfiguration3DacAOutput ControlConfiguration3DACAOutputProportionalToInternalTemperature {
    Adt7318TypeControlConfiguration3DacAOutput get ();
    void set (Adt7318TypeControlConfiguration3DacAOutput value);
}
member ControlConfiguration3DACAOutputProportionalToInternalTemperature : Adt7318TypeControlConfiguration3DacAOutput with get, set

Property Value

Type: Adt7318TypeControlConfiguration3DacAOutput
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ControlConfiguration3DACBOutputProportionalToExternalTemperature Property

IRD

Adt7318ControlConfiguration3DACBOutputProportionalToExternalTemperature Property

Control Configuration 3: DAC B Output Proportional To External Temperature

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeControlConfiguration3DacBOutput ControlConfiguration3DACBOutputProportionalToExternalTemperature { get; set; }
Public Property ControlConfiguration3DACBOutputProportionalToExternalTemperature As Adt7318TypeControlConfiguration3DacBOutput
    Get
    Set
public:
property Adt7318TypeControlConfiguration3DacBOutput ControlConfiguration3DACBOutputProportionalToExternalTemperature {
    Adt7318TypeControlConfiguration3DacBOutput get ();
    void set (Adt7318TypeControlConfiguration3DacBOutput value);
}
member ControlConfiguration3DACBOutputProportionalToExternalTemperature : Adt7318TypeControlConfiguration3DacBOutput with get, set

Property Value

Type: Adt7318TypeControlConfiguration3DacBOutput
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ControlConfiguration3Speed Property

IRD

Adt7318ControlConfiguration3Speed Property

Control Configuration 3: Speed

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeControlConfiguration3Speed ControlConfiguration3Speed { get; set; }
Public Property ControlConfiguration3Speed As Adt7318TypeControlConfiguration3Speed
    Get
    Set
public:
property Adt7318TypeControlConfiguration3Speed ControlConfiguration3Speed {
    Adt7318TypeControlConfiguration3Speed get ();
    void set (Adt7318TypeControlConfiguration3Speed value);
}
member ControlConfiguration3Speed : Adt7318TypeControlConfiguration3Speed with get, set

Property Value

Type: Adt7318TypeControlConfiguration3Speed
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ControlConfiguration3UpdatingOfDACOutputs Property

IRD

Adt7318ControlConfiguration3UpdatingOfDACOutputs Property

Control Configuration 3: Updating of DAC Outputs

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeControlConfiguration3UpdatingDacOutputs ControlConfiguration3UpdatingOfDACOutputs { get; set; }
Public Property ControlConfiguration3UpdatingOfDACOutputs As Adt7318TypeControlConfiguration3UpdatingDacOutputs
    Get
    Set
public:
property Adt7318TypeControlConfiguration3UpdatingDacOutputs ControlConfiguration3UpdatingOfDACOutputs {
    Adt7318TypeControlConfiguration3UpdatingDacOutputs get ();
    void set (Adt7318TypeControlConfiguration3UpdatingDacOutputs value);
}
member ControlConfiguration3UpdatingOfDACOutputs : Adt7318TypeControlConfiguration3UpdatingDacOutputs with get, set

Property Value

Type: Adt7318TypeControlConfiguration3UpdatingDacOutputs
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.DACA Property

IRD

Adt7318DACA Property

DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACA { get; set; }
Public Property DACA As Byte
    Get
    Set
public:
property unsigned char DACA {
    unsigned char get ();
    void set (unsigned char value);
}
member DACA : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.DACB Property

IRD

Adt7318DACB Property

DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACB { get; set; }
Public Property DACB As Byte
    Get
    Set
public:
property unsigned char DACB {
    unsigned char get ();
    void set (unsigned char value);
}
member DACB : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.DACC Property

IRD

Adt7318DACC Property

DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACC { get; set; }
Public Property DACC As Byte
    Get
    Set
public:
property unsigned char DACC {
    unsigned char get ();
    void set (unsigned char value);
}
member DACC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.DACConfigurationOutputRangeDACA Property

IRD

Adt7318DACConfigurationOutputRangeDACA Property

DAC Configuration: Output Range DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeDacConfigurationRange DACConfigurationOutputRangeDACA { get; set; }
Public Property DACConfigurationOutputRangeDACA As Adt7318TypeDacConfigurationRange
    Get
    Set
public:
property Adt7318TypeDacConfigurationRange DACConfigurationOutputRangeDACA {
    Adt7318TypeDacConfigurationRange get ();
    void set (Adt7318TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACA : Adt7318TypeDacConfigurationRange with get, set

Property Value

Type: Adt7318TypeDacConfigurationRange
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.DACConfigurationOutputRangeDACB Property

IRD

Adt7318DACConfigurationOutputRangeDACB Property

DAC Configuration: Output Range DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeDacConfigurationRange DACConfigurationOutputRangeDACB { get; set; }
Public Property DACConfigurationOutputRangeDACB As Adt7318TypeDacConfigurationRange
    Get
    Set
public:
property Adt7318TypeDacConfigurationRange DACConfigurationOutputRangeDACB {
    Adt7318TypeDacConfigurationRange get ();
    void set (Adt7318TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACB : Adt7318TypeDacConfigurationRange with get, set

Property Value

Type: Adt7318TypeDacConfigurationRange
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.DACConfigurationOutputRangeDACC Property

IRD

Adt7318DACConfigurationOutputRangeDACC Property

DAC Configuration: Output Range DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeDacConfigurationRange DACConfigurationOutputRangeDACC { get; set; }
Public Property DACConfigurationOutputRangeDACC As Adt7318TypeDacConfigurationRange
    Get
    Set
public:
property Adt7318TypeDacConfigurationRange DACConfigurationOutputRangeDACC {
    Adt7318TypeDacConfigurationRange get ();
    void set (Adt7318TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACC : Adt7318TypeDacConfigurationRange with get, set

Property Value

Type: Adt7318TypeDacConfigurationRange
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.DACConfigurationOutputRangeDACD Property

IRD

Adt7318DACConfigurationOutputRangeDACD Property

DAC Configuration: Output Range DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeDacConfigurationRange DACConfigurationOutputRangeDACD { get; set; }
Public Property DACConfigurationOutputRangeDACD As Adt7318TypeDacConfigurationRange
    Get
    Set
public:
property Adt7318TypeDacConfigurationRange DACConfigurationOutputRangeDACD {
    Adt7318TypeDacConfigurationRange get ();
    void set (Adt7318TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACD : Adt7318TypeDacConfigurationRange with get, set

Property Value

Type: Adt7318TypeDacConfigurationRange
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.DACConfigurationUpdate Property

IRD

Adt7318DACConfigurationUpdate Property

DAC Configuration: Update

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeDacConfigurationUpdate DACConfigurationUpdate { get; set; }
Public Property DACConfigurationUpdate As Adt7318TypeDacConfigurationUpdate
    Get
    Set
public:
property Adt7318TypeDacConfigurationUpdate DACConfigurationUpdate {
    Adt7318TypeDacConfigurationUpdate get ();
    void set (Adt7318TypeDacConfigurationUpdate value);
}
member DACConfigurationUpdate : Adt7318TypeDacConfigurationUpdate with get, set

Property Value

Type: Adt7318TypeDacConfigurationUpdate
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.DACConfigurationVREFBypassDACAB Property

IRD

Adt7318DACConfigurationVREFBypassDACAB Property

DAC Configuration: V_REF Bypass DAC A / B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeDacConfigurationBypass DACConfigurationVREFBypassDACAB { get; set; }
Public Property DACConfigurationVREFBypassDACAB As Adt7318TypeDacConfigurationBypass
    Get
    Set
public:
property Adt7318TypeDacConfigurationBypass DACConfigurationVREFBypassDACAB {
    Adt7318TypeDacConfigurationBypass get ();
    void set (Adt7318TypeDacConfigurationBypass value);
}
member DACConfigurationVREFBypassDACAB : Adt7318TypeDacConfigurationBypass with get, set

Property Value

Type: Adt7318TypeDacConfigurationBypass
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.DACConfigurationVREFBypassDACCD Property

IRD

Adt7318DACConfigurationVREFBypassDACCD Property

DAC Configuration: V_REF Bypass DAC C / D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeDacConfigurationBypass DACConfigurationVREFBypassDACCD { get; set; }
Public Property DACConfigurationVREFBypassDACCD As Adt7318TypeDacConfigurationBypass
    Get
    Set
public:
property Adt7318TypeDacConfigurationBypass DACConfigurationVREFBypassDACCD {
    Adt7318TypeDacConfigurationBypass get ();
    void set (Adt7318TypeDacConfigurationBypass value);
}
member DACConfigurationVREFBypassDACCD : Adt7318TypeDacConfigurationBypass with get, set

Property Value

Type: Adt7318TypeDacConfigurationBypass
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.DACD Property

IRD

Adt7318DACD Property

DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACD { get; set; }
Public Property DACD As Byte
    Get
    Set
public:
property unsigned char DACD {
    unsigned char get ();
    void set (unsigned char value);
}
member DACD : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.DeviceID Property

IRD

Adt7318DeviceID Property

Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ExternalAnalogTemperatureOffset Property

IRD

Adt7318ExternalAnalogTemperatureOffset Property

External Analog Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalAnalogTemperatureOffset { get; set; }
Public Property ExternalAnalogTemperatureOffset As SByte
    Get
    Set
public:
property signed char ExternalAnalogTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member ExternalAnalogTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ExternalTemperature Property

IRD

Adt7318ExternalTemperature Property

External Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ExternalTemperature { get; }
Public ReadOnly Property ExternalTemperature As Double
    Get
public:
property double ExternalTemperature {
    double get ();
}
member ExternalTemperature : float with get

Property Value

Type: Double
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ExternalTemperatureOffset Property

IRD

Adt7318ExternalTemperatureOffset Property

External Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperatureOffset { get; set; }
Public Property ExternalTemperatureOffset As SByte
    Get
    Set
public:
property signed char ExternalTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member ExternalTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ExternalTHIGHLimit Property

IRD

Adt7318ExternalTHIGHLimit Property

External T_HIGH Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTHIGHLimit { get; set; }
Public Property ExternalTHIGHLimit As SByte
    Get
    Set
public:
property signed char ExternalTHIGHLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalTHIGHLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ExternalTLOWLimit Property

IRD

Adt7318ExternalTLOWLimit Property

External T_LOW Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTLOWLimit { get; set; }
Public Property ExternalTLOWLimit As SByte
    Get
    Set
public:
property signed char ExternalTLOWLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalTLOWLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.InternalAnalogTemperatureOffset Property

IRD

Adt7318InternalAnalogTemperatureOffset Property

Internal Analog Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalAnalogTemperatureOffset { get; set; }
Public Property InternalAnalogTemperatureOffset As SByte
    Get
    Set
public:
property signed char InternalAnalogTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member InternalAnalogTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.InternalTemperature Property

IRD

Adt7318InternalTemperature Property

Internal Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double InternalTemperature { get; }
Public ReadOnly Property InternalTemperature As Double
    Get
public:
property double InternalTemperature {
    double get ();
}
member InternalTemperature : float with get

Property Value

Type: Double
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.InternalTemperatureOffset Property

IRD

Adt7318InternalTemperatureOffset Property

Internal Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureOffset { get; set; }
Public Property InternalTemperatureOffset As SByte
    Get
    Set
public:
property signed char InternalTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member InternalTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.InternalTHIGHLimit Property

IRD

Adt7318InternalTHIGHLimit Property

Internal T_HIGH Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTHIGHLimit { get; set; }
Public Property InternalTHIGHLimit As SByte
    Get
    Set
public:
property signed char InternalTHIGHLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTHIGHLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.InternalTLOWLimit Property

IRD

Adt7318InternalTLOWLimit Property

Internal T_LOW Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTLOWLimit { get; set; }
Public Property InternalTLOWLimit As SByte
    Get
    Set
public:
property signed char InternalTLOWLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTLOWLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.InterruptMask1ExternalTemperatureFault Property

IRD

Adt7318InterruptMask1ExternalTemperatureFault Property

Interrupt Mask 1: External Temperature Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeInterruptMaskEnableDisable InterruptMask1ExternalTemperatureFault { get; set; }
Public Property InterruptMask1ExternalTemperatureFault As Adt7318TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7318TypeInterruptMaskEnableDisable InterruptMask1ExternalTemperatureFault {
    Adt7318TypeInterruptMaskEnableDisable get ();
    void set (Adt7318TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTemperatureFault : Adt7318TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7318TypeInterruptMaskEnableDisable
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.InterruptMask1ExternalTHIGH Property

IRD

Adt7318InterruptMask1ExternalTHIGH Property

Interrupt Mask 1: External T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeInterruptMaskEnableDisable InterruptMask1ExternalTHIGH { get; set; }
Public Property InterruptMask1ExternalTHIGH As Adt7318TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7318TypeInterruptMaskEnableDisable InterruptMask1ExternalTHIGH {
    Adt7318TypeInterruptMaskEnableDisable get ();
    void set (Adt7318TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTHIGH : Adt7318TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7318TypeInterruptMaskEnableDisable
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.InterruptMask1ExternalTLOW Property

IRD

Adt7318InterruptMask1ExternalTLOW Property

Interrupt Mask 1: External T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeInterruptMaskEnableDisable InterruptMask1ExternalTLOW { get; set; }
Public Property InterruptMask1ExternalTLOW As Adt7318TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7318TypeInterruptMaskEnableDisable InterruptMask1ExternalTLOW {
    Adt7318TypeInterruptMaskEnableDisable get ();
    void set (Adt7318TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTLOW : Adt7318TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7318TypeInterruptMaskEnableDisable
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.InterruptMask1InternalTHIGH Property

IRD

Adt7318InterruptMask1InternalTHIGH Property

Interrupt Mask 1: Internal T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeInterruptMaskEnableDisable InterruptMask1InternalTHIGH { get; set; }
Public Property InterruptMask1InternalTHIGH As Adt7318TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7318TypeInterruptMaskEnableDisable InterruptMask1InternalTHIGH {
    Adt7318TypeInterruptMaskEnableDisable get ();
    void set (Adt7318TypeInterruptMaskEnableDisable value);
}
member InterruptMask1InternalTHIGH : Adt7318TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7318TypeInterruptMaskEnableDisable
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.InterruptMask1InternalTLOW Property

IRD

Adt7318InterruptMask1InternalTLOW Property

Interrupt Mask 1: Internal T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeInterruptMaskEnableDisable InterruptMask1InternalTLOW { get; set; }
Public Property InterruptMask1InternalTLOW As Adt7318TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7318TypeInterruptMaskEnableDisable InterruptMask1InternalTLOW {
    Adt7318TypeInterruptMaskEnableDisable get ();
    void set (Adt7318TypeInterruptMaskEnableDisable value);
}
member InterruptMask1InternalTLOW : Adt7318TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7318TypeInterruptMaskEnableDisable
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.InterruptMask2VDD Property

IRD

Adt7318InterruptMask2VDD Property

Interrupt Mask 2: V_DD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeInterruptMaskEnableDisable InterruptMask2VDD { get; set; }
Public Property InterruptMask2VDD As Adt7318TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7318TypeInterruptMaskEnableDisable InterruptMask2VDD {
    Adt7318TypeInterruptMaskEnableDisable get ();
    void set (Adt7318TypeInterruptMaskEnableDisable value);
}
member InterruptMask2VDD : Adt7318TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7318TypeInterruptMaskEnableDisable
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.InterruptStatus1ExternalSensorFault Property

IRD

Adt7318InterruptStatus1ExternalSensorFault Property

Interrupt Status 1: External Sensor Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeInterruptStatus InterruptStatus1ExternalSensorFault { get; }
Public ReadOnly Property InterruptStatus1ExternalSensorFault As Adt7318TypeInterruptStatus
    Get
public:
property Adt7318TypeInterruptStatus InterruptStatus1ExternalSensorFault {
    Adt7318TypeInterruptStatus get ();
}
member InterruptStatus1ExternalSensorFault : Adt7318TypeInterruptStatus with get

Property Value

Type: Adt7318TypeInterruptStatus
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.InterruptStatus1TEXTTHIGH Property

IRD

Adt7318InterruptStatus1TEXTTHIGH Property

Interrupt Status 1: T_EXT > T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeInterruptStatus InterruptStatus1TEXTTHIGH { get; }
Public ReadOnly Property InterruptStatus1TEXTTHIGH As Adt7318TypeInterruptStatus
    Get
public:
property Adt7318TypeInterruptStatus InterruptStatus1TEXTTHIGH {
    Adt7318TypeInterruptStatus get ();
}
member InterruptStatus1TEXTTHIGH : Adt7318TypeInterruptStatus with get

Property Value

Type: Adt7318TypeInterruptStatus
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.InterruptStatus1TEXTTLOW Property

IRD

Adt7318InterruptStatus1TEXTTLOW Property

Interrupt Status 1: T_EXT <= T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeInterruptStatus InterruptStatus1TEXTTLOW { get; }
Public ReadOnly Property InterruptStatus1TEXTTLOW As Adt7318TypeInterruptStatus
    Get
public:
property Adt7318TypeInterruptStatus InterruptStatus1TEXTTLOW {
    Adt7318TypeInterruptStatus get ();
}
member InterruptStatus1TEXTTLOW : Adt7318TypeInterruptStatus with get

Property Value

Type: Adt7318TypeInterruptStatus
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.InterruptStatus1TINTTHIGH Property

IRD

Adt7318InterruptStatus1TINTTHIGH Property

Interrupt Status 1: T_INT > T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeInterruptStatus InterruptStatus1TINTTHIGH { get; }
Public ReadOnly Property InterruptStatus1TINTTHIGH As Adt7318TypeInterruptStatus
    Get
public:
property Adt7318TypeInterruptStatus InterruptStatus1TINTTHIGH {
    Adt7318TypeInterruptStatus get ();
}
member InterruptStatus1TINTTHIGH : Adt7318TypeInterruptStatus with get

Property Value

Type: Adt7318TypeInterruptStatus
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.InterruptStatus1TINTTLOW Property

IRD

Adt7318InterruptStatus1TINTTLOW Property

Interrupt Status 1: T_INT <= T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeInterruptStatus InterruptStatus1TINTTLOW { get; }
Public ReadOnly Property InterruptStatus1TINTTLOW As Adt7318TypeInterruptStatus
    Get
public:
property Adt7318TypeInterruptStatus InterruptStatus1TINTTLOW {
    Adt7318TypeInterruptStatus get ();
}
member InterruptStatus1TINTTLOW : Adt7318TypeInterruptStatus with get

Property Value

Type: Adt7318TypeInterruptStatus
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.InterruptStatus2VDDVHIGHVDDVLOW Property

IRD

Adt7318InterruptStatus2VDDVHIGHVDDVLOW Property

Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeInterruptStatus InterruptStatus2VDDVHIGHVDDVLOW { get; }
Public ReadOnly Property InterruptStatus2VDDVHIGHVDDVLOW As Adt7318TypeInterruptStatus
    Get
public:
property Adt7318TypeInterruptStatus InterruptStatus2VDDVHIGHVDDVLOW {
    Adt7318TypeInterruptStatus get ();
}
member InterruptStatus2VDDVHIGHVDDVLOW : Adt7318TypeInterruptStatus with get

Property Value

Type: Adt7318TypeInterruptStatus
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.LDACConfigurationDACA Property

IRD

Adt7318LDACConfigurationDACA Property

LDAC Configuration: DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeLdacConfigurationUpdate LDACConfigurationDACA { set; }
Public WriteOnly Property LDACConfigurationDACA As Adt7318TypeLdacConfigurationUpdate
    Set
public:
property Adt7318TypeLdacConfigurationUpdate LDACConfigurationDACA {
    void set (Adt7318TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACA : Adt7318TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7318TypeLdacConfigurationUpdate
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.LDACConfigurationDACB Property

IRD

Adt7318LDACConfigurationDACB Property

LDAC Configuration: DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeLdacConfigurationUpdate LDACConfigurationDACB { set; }
Public WriteOnly Property LDACConfigurationDACB As Adt7318TypeLdacConfigurationUpdate
    Set
public:
property Adt7318TypeLdacConfigurationUpdate LDACConfigurationDACB {
    void set (Adt7318TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACB : Adt7318TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7318TypeLdacConfigurationUpdate
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.LDACConfigurationDACC Property

IRD

Adt7318LDACConfigurationDACC Property

LDAC Configuration: DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeLdacConfigurationUpdate LDACConfigurationDACC { set; }
Public WriteOnly Property LDACConfigurationDACC As Adt7318TypeLdacConfigurationUpdate
    Set
public:
property Adt7318TypeLdacConfigurationUpdate LDACConfigurationDACC {
    void set (Adt7318TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACC : Adt7318TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7318TypeLdacConfigurationUpdate
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.LDACConfigurationDACD Property

IRD

Adt7318LDACConfigurationDACD Property

LDAC Configuration: DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeLdacConfigurationUpdate LDACConfigurationDACD { set; }
Public WriteOnly Property LDACConfigurationDACD As Adt7318TypeLdacConfigurationUpdate
    Set
public:
property Adt7318TypeLdacConfigurationUpdate LDACConfigurationDACD {
    void set (Adt7318TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACD : Adt7318TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7318TypeLdacConfigurationUpdate
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.ManufacturerSID Property

IRD

Adt7318ManufacturerSID Property

Manufacturer's ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerSID { get; }
Public ReadOnly Property ManufacturerSID As Byte
    Get
public:
property unsigned char ManufacturerSID {
    unsigned char get ();
}
member ManufacturerSID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.SiliconRevisionStepping Property

IRD

Adt7318SiliconRevisionStepping Property

Silicon Revision: Stepping

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SiliconRevisionStepping { get; }
Public ReadOnly Property SiliconRevisionStepping As Byte
    Get
public:
property unsigned char SiliconRevisionStepping {
    unsigned char get ();
}
member SiliconRevisionStepping : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.SiliconRevisionVersion Property

IRD

Adt7318SiliconRevisionVersion Property

Silicon Revision: Version

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SiliconRevisionVersion { get; }
Public ReadOnly Property SiliconRevisionVersion As Byte
    Get
public:
property unsigned char SiliconRevisionVersion {
    unsigned char get ();
}
member SiliconRevisionVersion : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.SPILockStatus Property

IRD

Adt7318SPILockStatus Property

SPI Lock Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7318TypeSpiLockStatus SPILockStatus { get; }
Public ReadOnly Property SPILockStatus As Adt7318TypeSpiLockStatus
    Get
public:
property Adt7318TypeSpiLockStatus SPILockStatus {
    Adt7318TypeSpiLockStatus get ();
}
member SPILockStatus : Adt7318TypeSpiLockStatus with get

Property Value

Type: Adt7318TypeSpiLockStatus
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.VDD Property

IRD

Adt7318VDD Property

V_DD (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDD { get; }
Public ReadOnly Property VDD As Double
    Get
public:
property double VDD {
    double get ();
}
member VDD : float with get

Property Value

Type: Double
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.VDDVHIGHLimit Property

IRD

Adt7318VDDVHIGHLimit Property

V_DD V_HIGH Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDDVHIGHLimit { get; set; }
Public Property VDDVHIGHLimit As Double
    Get
    Set
public:
property double VDDVHIGHLimit {
    double get ();
    void set (double value);
}
member VDDVHIGHLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.VDDVLOWLimit Property

IRD

Adt7318VDDVLOWLimit Property

V_DD V_LOW Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDDVLOWLimit { get; set; }
Public Property VDDVLOWLimit As Double
    Get
    Set
public:
property double VDDVLOWLimit {
    double get ();
    void set (double value);
}
member VDDVLOWLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318 Methods

The Adt7318 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.Flush Method

IRD

Adt7318Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adt7318 Class
telos.Ird.AnalogDevices Namespace


Adt7318.TypeControlConfiguration1IntOutput Enumeration

IRD

Adt7318TypeControlConfiguration1IntOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1IntOutput
Public Enumeration TypeControlConfiguration1IntOutput
public enum class TypeControlConfiguration1IntOutput
type TypeControlConfiguration1IntOutput
Members
Member name | Value | Description
INTOutputEnabled | 0 | INT Output: Enabled
INTOutputDisabled | 1 | INT Output: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeControlConfiguration1IntOutputPolarity Enumeration

IRD

Adt7318TypeControlConfiguration1IntOutputPolarity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1IntOutputPolarity
Public Enumeration TypeControlConfiguration1IntOutputPolarity
public enum class TypeControlConfiguration1IntOutputPolarity
type TypeControlConfiguration1IntOutputPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeControlConfiguration1Monitoring Enumeration

IRD

Adt7318TypeControlConfiguration1Monitoring Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1Monitoring
Public Enumeration TypeControlConfiguration1Monitoring
public enum class TypeControlConfiguration1Monitoring
type TypeControlConfiguration1Monitoring
Members
Member name | Value | Description
StopMonitoring | 0 | Stop Monitoring
StartMonitoring | 1 | Start Monitoring
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeControlConfiguration1PowerDown Enumeration

IRD

Adt7318TypeControlConfiguration1PowerDown Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1PowerDown
Public Enumeration TypeControlConfiguration1PowerDown
public enum class TypeControlConfiguration1PowerDown
type TypeControlConfiguration1PowerDown
Members
Member name | Value | Description
PowerUp | 0 | Power Up
PowerDown | 1 | Power Down
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeControlConfiguration2Averaging Enumeration

IRD

Adt7318TypeControlConfiguration2Averaging Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Averaging
Public Enumeration TypeControlConfiguration2Averaging
public enum class TypeControlConfiguration2Averaging
type TypeControlConfiguration2Averaging
Members
Member name | Value | Description
AveragingEnabled | 0 | Averaging Enabled
AveragingDisabled | 1 | Averaging Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeControlConfiguration2ChannelSelection Enumeration

IRD

Adt7318TypeControlConfiguration2ChannelSelection Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2ChannelSelection
Public Enumeration TypeControlConfiguration2ChannelSelection
public enum class TypeControlConfiguration2ChannelSelection
type TypeControlConfiguration2ChannelSelection
Members
Member name | Value | Description
VDD | 0 | V_DD
InternalTemperatureSensor | 1 | Internal Temperature Sensor
ExternalTemperatureSensor | 2 | External Temperature Sensor
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeControlConfiguration2Conversion Enumeration

IRD

Adt7318TypeControlConfiguration2Conversion Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Conversion
Public Enumeration TypeControlConfiguration2Conversion
public enum class TypeControlConfiguration2Conversion
type TypeControlConfiguration2Conversion
Members
Member name | Value | Description
RoundRobin | 0 | Round Robin
SingleChannel | 1 | Single Channel
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeControlConfiguration2SoftwareReset Enumeration

IRD

Adt7318TypeControlConfiguration2SoftwareReset Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2SoftwareReset
Public Enumeration TypeControlConfiguration2SoftwareReset
public enum class TypeControlConfiguration2SoftwareReset
type TypeControlConfiguration2SoftwareReset
Members
Member name | Value | Description
Default | 0 | Default
SoftwareReset | 1 | Software Reset
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeControlConfiguration2Timeout Enumeration

IRD

Adt7318TypeControlConfiguration2Timeout Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Timeout
Public Enumeration TypeControlConfiguration2Timeout
public enum class TypeControlConfiguration2Timeout
type TypeControlConfiguration2Timeout
Members
Member name | Value | Description
SMBusTimeoutDisabled | 0 | SMBus Timeout: Disabled
SMBusTimeoutEnabled | 1 | SMBus Timeout: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeControlConfiguration3DacAOutput Enumeration

IRD

Adt7318TypeControlConfiguration3DacAOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3DacAOutput
Public Enumeration TypeControlConfiguration3DacAOutput
public enum class TypeControlConfiguration3DacAOutput
type TypeControlConfiguration3DacAOutput
Members
Member name | Value | Description
NotProportional | 0 | Not Proportional
Proportional | 1 | Proportional
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeControlConfiguration3DacBOutput Enumeration

IRD

Adt7318TypeControlConfiguration3DacBOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3DacBOutput
Public Enumeration TypeControlConfiguration3DacBOutput
public enum class TypeControlConfiguration3DacBOutput
type TypeControlConfiguration3DacBOutput
Members
Member name | Value | Description
NotProportional | 0 | Not Proportional
Proportional | 1 | Proportional
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeControlConfiguration3Speed Enumeration

IRD

Adt7318TypeControlConfiguration3Speed Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3Speed
Public Enumeration TypeControlConfiguration3Speed
public enum class TypeControlConfiguration3Speed
type TypeControlConfiguration3Speed
Members
Member name | Value | Description
Value_14KHz | 0 | 1.4 kHz
Value_225KHz | 1 | 22.5 kHz
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeControlConfiguration3UpdatingDacOutputs Enumeration

IRD

Adt7318TypeControlConfiguration3UpdatingDacOutputs Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3UpdatingDacOutputs
Public Enumeration TypeControlConfiguration3UpdatingDacOutputs
public enum class TypeControlConfiguration3UpdatingDacOutputs
type TypeControlConfiguration3UpdatingDacOutputs
Members
Member name | Value | Description
LDACPin | 0 | LDAC Pin
DACLDACConfiguration | 1 | DAC & LDAC Configuration
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeDacConfigurationBypass Enumeration

IRD

Adt7318TypeDacConfigurationBypass Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacConfigurationBypass
Public Enumeration TypeDacConfigurationBypass
public enum class TypeDacConfigurationBypass
type TypeDacConfigurationBypass
Members
Member name | Value | Description
BypassReferenceBufferDisabled | 0 | Bypass Reference Buffer: Disabled
BypassReferenceBufferEnabled | 1 | Bypass Reference Buffer: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeDacConfigurationRange Enumeration

IRD

Adt7318TypeDacConfigurationRange Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacConfigurationRange
Public Enumeration TypeDacConfigurationRange
public enum class TypeDacConfigurationRange
type TypeDacConfigurationRange
Members
Member name | Value | Description
Value_0VToVREF | 0 | 0V to V_REF
Value_0VTo2VREF | 1 | 0V to 2 V_REF
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeDacConfigurationUpdate Enumeration

IRD

Adt7318TypeDacConfigurationUpdate Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacConfigurationUpdate
Public Enumeration TypeDacConfigurationUpdate
public enum class TypeDacConfigurationUpdate
type TypeDacConfigurationUpdate
Members
Member name | Value | Description
MSBWriteToAnyDACRegisterGeneratesLDACCommandThatUpdatesThatDACOnly | 0 | MSB write to any DAC register generates LDAC command that updates that DAC only
MSBWriteToDACBOrDACDRegisterGeneratesLDACCommandThatUpdatesDACAAndDACBOrDACCAndDACDRespectively | 1 | MSB write to DAC B or DAC D register generates LDAC command that updates DAC A and DAC B or DAC C and DAC D, respectively
MSBWriteToDACDRegisterGeneratesLDACCommandThatUpdatesAllFourDACs | 2 | MSB write to DAC D register generates LDAC command that updates all four DACs
LDACCommandGeneratedFromLDACRegister | 3 | LDAC command generated from LDAC register
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeInterruptMaskEnableDisable Enumeration

IRD

Adt7318TypeInterruptMaskEnableDisable Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptMaskEnableDisable
Public Enumeration TypeInterruptMaskEnableDisable
public enum class TypeInterruptMaskEnableDisable
type TypeInterruptMaskEnableDisable
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeInterruptStatus Enumeration

IRD

Adt7318TypeInterruptStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatus
Public Enumeration TypeInterruptStatus
public enum class TypeInterruptStatus
type TypeInterruptStatus
Members
Member name | Value | Description
NotSet | 0 | Not Set
Set | 1 | Set
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeLdacConfigurationUpdate Enumeration

IRD

Adt7318TypeLdacConfigurationUpdate Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLdacConfigurationUpdate
Public Enumeration TypeLdacConfigurationUpdate
public enum class TypeLdacConfigurationUpdate
type TypeLdacConfigurationUpdate
Members
Member name | Value | Description
DoNotUpdate | 0 | Do Not Update
Update | 1 | Update
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7318.TypeSpiLockStatus Enumeration

IRD

Adt7318TypeSpiLockStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSpiLockStatus
Public Enumeration TypeSpiLockStatus
public enum class TypeSpiLockStatus
type TypeSpiLockStatus
Members
Member name | Value | Description
I2CInterface | 0 | I2C Interface
SPIInterfaceLocked | 1 | SPI Interface / Locked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7408 Class

Analog Devices: ADT 7408
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdt7408

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adt7408
Public Class Adt7408
public ref class Adt7408
type Adt7408 =  class end

The Adt7408 type exposes the following members.

Constructors
 | Name | Description
Public method | Adt7408 | Constructor
Top
Properties
 | Name | Description
Public property | AlarmTemperatureLowerBoundaryTrip | Alarm Temperature Lower Boundary Trip (unit: °C)
Public property | AlarmTemperatureUpperBoundaryTrip | Alarm Temperature Upper Boundary Trip (unit: °C)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CapabilityAccuracy | Capability: Accuracy
Public property | CapabilityTemperatureRange | Capability: Temperature Range
Public property | CapabilityTemperatureResolution | Capability: Temperature Resolution
Public property | CapabilityTrips | Capability: Trips
Public property | ConfigurationAlarmWindowLock | Configuration: Alarm Window Lock
Public property | ConfigurationClearEvent | Configuration: Clear Event
Public property | ConfigurationCriticalEventOnly | Configuration: Critical Event Only
Public property | ConfigurationCriticalTripLock | Configuration: Critical Trip Lock
Public property | ConfigurationEventMode | Configuration: Event Mode
Public property | ConfigurationEventOutputControl | Configuration: Event Output Control
Public property | ConfigurationEventOutputStatus | Configuration: Event Output Status
Public property | ConfigurationEventPolarity | Configuration: Event Polarity
Public property | ConfigurationHysteresisEnable | Configuration: Hysteresis Enable
Public property | ConfigurationShutdownMode | Configuration: Shutdown Mode
Public property | CriticalTemperatureTrip | Critical Temperature Trip (unit: °C)
Public property | DeviceIDRevision | Device ID / Revision
Public property | ManufacturerID | Manufacturer ID
Public property | TemperatureValueAboveAlarmWindow | Temperature Value: Above Alarm Window
Public property | TemperatureValueAboveCriticalTrip | Temperature Value: Above Critical Trip
Public property | TemperatureValueBelowAlarmWindow | Temperature Value: Below Alarm Window
Public property | TemperatureValueTemperature | Temperature Value: Temperature (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
±2°C Accurate, 12-Bit Digital Temperature Sensor
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7408 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7408(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adt7408(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adt7408

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408 Properties

The Adt7408 type exposes the following members.

Properties
 | Name | Description
Public property | AlarmTemperatureLowerBoundaryTrip | Alarm Temperature Lower Boundary Trip (unit: °C)
Public property | AlarmTemperatureUpperBoundaryTrip | Alarm Temperature Upper Boundary Trip (unit: °C)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CapabilityAccuracy | Capability: Accuracy
Public property | CapabilityTemperatureRange | Capability: Temperature Range
Public property | CapabilityTemperatureResolution | Capability: Temperature Resolution
Public property | CapabilityTrips | Capability: Trips
Public property | ConfigurationAlarmWindowLock | Configuration: Alarm Window Lock
Public property | ConfigurationClearEvent | Configuration: Clear Event
Public property | ConfigurationCriticalEventOnly | Configuration: Critical Event Only
Public property | ConfigurationCriticalTripLock | Configuration: Critical Trip Lock
Public property | ConfigurationEventMode | Configuration: Event Mode
Public property | ConfigurationEventOutputControl | Configuration: Event Output Control
Public property | ConfigurationEventOutputStatus | Configuration: Event Output Status
Public property | ConfigurationEventPolarity | Configuration: Event Polarity
Public property | ConfigurationHysteresisEnable | Configuration: Hysteresis Enable
Public property | ConfigurationShutdownMode | Configuration: Shutdown Mode
Public property | CriticalTemperatureTrip | Critical Temperature Trip (unit: °C)
Public property | DeviceIDRevision | Device ID / Revision
Public property | ManufacturerID | Manufacturer ID
Public property | TemperatureValueAboveAlarmWindow | Temperature Value: Above Alarm Window
Public property | TemperatureValueAboveCriticalTrip | Temperature Value: Above Critical Trip
Public property | TemperatureValueBelowAlarmWindow | Temperature Value: Below Alarm Window
Public property | TemperatureValueTemperature | Temperature Value: Temperature (unit: °C)
Top
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.AlarmTemperatureLowerBoundaryTrip Property

IRD

Adt7408AlarmTemperatureLowerBoundaryTrip Property

Alarm Temperature Lower Boundary Trip (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AlarmTemperatureLowerBoundaryTrip { get; set; }
Public Property AlarmTemperatureLowerBoundaryTrip As Double
    Get
    Set
public:
property double AlarmTemperatureLowerBoundaryTrip {
    double get ();
    void set (double value);
}
member AlarmTemperatureLowerBoundaryTrip : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.AlarmTemperatureUpperBoundaryTrip Property

IRD

Adt7408AlarmTemperatureUpperBoundaryTrip Property

Alarm Temperature Upper Boundary Trip (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AlarmTemperatureUpperBoundaryTrip { get; set; }
Public Property AlarmTemperatureUpperBoundaryTrip As Double
    Get
    Set
public:
property double AlarmTemperatureUpperBoundaryTrip {
    double get ();
    void set (double value);
}
member AlarmTemperatureUpperBoundaryTrip : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.AutoFlush Property

IRD

Adt7408AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.CapabilityAccuracy Property

IRD

Adt7408CapabilityAccuracy Property

Capability: Accuracy

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7408TypeCapabilityAccuracy CapabilityAccuracy { get; }
Public ReadOnly Property CapabilityAccuracy As Adt7408TypeCapabilityAccuracy
    Get
public:
property Adt7408TypeCapabilityAccuracy CapabilityAccuracy {
    Adt7408TypeCapabilityAccuracy get ();
}
member CapabilityAccuracy : Adt7408TypeCapabilityAccuracy with get

Property Value

Type: Adt7408TypeCapabilityAccuracy
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.CapabilityTemperatureRange Property

IRD

Adt7408CapabilityTemperatureRange Property

Capability: Temperature Range

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7408TypeCapabilityTemperatureRange CapabilityTemperatureRange { get; }
Public ReadOnly Property CapabilityTemperatureRange As Adt7408TypeCapabilityTemperatureRange
    Get
public:
property Adt7408TypeCapabilityTemperatureRange CapabilityTemperatureRange {
    Adt7408TypeCapabilityTemperatureRange get ();
}
member CapabilityTemperatureRange : Adt7408TypeCapabilityTemperatureRange with get

Property Value

Type: Adt7408TypeCapabilityTemperatureRange
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.CapabilityTemperatureResolution Property

IRD

Adt7408CapabilityTemperatureResolution Property

Capability: Temperature Resolution

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7408TypeCapabilityTemperatureResolution CapabilityTemperatureResolution { get; }
Public ReadOnly Property CapabilityTemperatureResolution As Adt7408TypeCapabilityTemperatureResolution
    Get
public:
property Adt7408TypeCapabilityTemperatureResolution CapabilityTemperatureResolution {
    Adt7408TypeCapabilityTemperatureResolution get ();
}
member CapabilityTemperatureResolution : Adt7408TypeCapabilityTemperatureResolution with get

Property Value

Type: Adt7408TypeCapabilityTemperatureResolution
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.CapabilityTrips Property

IRD

Adt7408CapabilityTrips Property

Capability: Trips

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7408TypeCapabilityTrips CapabilityTrips { get; }
Public ReadOnly Property CapabilityTrips As Adt7408TypeCapabilityTrips
    Get
public:
property Adt7408TypeCapabilityTrips CapabilityTrips {
    Adt7408TypeCapabilityTrips get ();
}
member CapabilityTrips : Adt7408TypeCapabilityTrips with get

Property Value

Type: Adt7408TypeCapabilityTrips
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.ConfigurationAlarmWindowLock Property

IRD

Adt7408ConfigurationAlarmWindowLock Property

Configuration: Alarm Window Lock

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7408TypeConfigurationAlarmWindowLock ConfigurationAlarmWindowLock { get; set; }
Public Property ConfigurationAlarmWindowLock As Adt7408TypeConfigurationAlarmWindowLock
    Get
    Set
public:
property Adt7408TypeConfigurationAlarmWindowLock ConfigurationAlarmWindowLock {
    Adt7408TypeConfigurationAlarmWindowLock get ();
    void set (Adt7408TypeConfigurationAlarmWindowLock value);
}
member ConfigurationAlarmWindowLock : Adt7408TypeConfigurationAlarmWindowLock with get, set

Property Value

Type: Adt7408TypeConfigurationAlarmWindowLock
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.ConfigurationClearEvent Property

IRD

Adt7408ConfigurationClearEvent Property

Configuration: Clear Event

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7408TypeConfigurationClearEvent ConfigurationClearEvent { set; }
Public WriteOnly Property ConfigurationClearEvent As Adt7408TypeConfigurationClearEvent
    Set
public:
property Adt7408TypeConfigurationClearEvent ConfigurationClearEvent {
    void set (Adt7408TypeConfigurationClearEvent value);
}
member ConfigurationClearEvent : Adt7408TypeConfigurationClearEvent with set

Property Value

Type: Adt7408TypeConfigurationClearEvent
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.ConfigurationCriticalEventOnly Property

IRD

Adt7408ConfigurationCriticalEventOnly Property

Configuration: Critical Event Only

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7408TypeConfigurationCriticalEventOnly ConfigurationCriticalEventOnly { get; set; }
Public Property ConfigurationCriticalEventOnly As Adt7408TypeConfigurationCriticalEventOnly
    Get
    Set
public:
property Adt7408TypeConfigurationCriticalEventOnly ConfigurationCriticalEventOnly {
    Adt7408TypeConfigurationCriticalEventOnly get ();
    void set (Adt7408TypeConfigurationCriticalEventOnly value);
}
member ConfigurationCriticalEventOnly : Adt7408TypeConfigurationCriticalEventOnly with get, set

Property Value

Type: Adt7408TypeConfigurationCriticalEventOnly
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.ConfigurationCriticalTripLock Property

IRD

Adt7408ConfigurationCriticalTripLock Property

Configuration: Critical Trip Lock

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7408TypeConfigurationCriticalTripLock ConfigurationCriticalTripLock { get; set; }
Public Property ConfigurationCriticalTripLock As Adt7408TypeConfigurationCriticalTripLock
    Get
    Set
public:
property Adt7408TypeConfigurationCriticalTripLock ConfigurationCriticalTripLock {
    Adt7408TypeConfigurationCriticalTripLock get ();
    void set (Adt7408TypeConfigurationCriticalTripLock value);
}
member ConfigurationCriticalTripLock : Adt7408TypeConfigurationCriticalTripLock with get, set

Property Value

Type: Adt7408TypeConfigurationCriticalTripLock
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.ConfigurationEventMode Property

IRD

Adt7408ConfigurationEventMode Property

Configuration: Event Mode

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7408TypeConfigurationEventMode ConfigurationEventMode { get; set; }
Public Property ConfigurationEventMode As Adt7408TypeConfigurationEventMode
    Get
    Set
public:
property Adt7408TypeConfigurationEventMode ConfigurationEventMode {
    Adt7408TypeConfigurationEventMode get ();
    void set (Adt7408TypeConfigurationEventMode value);
}
member ConfigurationEventMode : Adt7408TypeConfigurationEventMode with get, set

Property Value

Type: Adt7408TypeConfigurationEventMode
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.ConfigurationEventOutputControl Property

IRD

Adt7408ConfigurationEventOutputControl Property

Configuration: Event Output Control

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7408TypeConfigurationEventOutputControl ConfigurationEventOutputControl { get; set; }
Public Property ConfigurationEventOutputControl As Adt7408TypeConfigurationEventOutputControl
    Get
    Set
public:
property Adt7408TypeConfigurationEventOutputControl ConfigurationEventOutputControl {
    Adt7408TypeConfigurationEventOutputControl get ();
    void set (Adt7408TypeConfigurationEventOutputControl value);
}
member ConfigurationEventOutputControl : Adt7408TypeConfigurationEventOutputControl with get, set

Property Value

Type: Adt7408TypeConfigurationEventOutputControl
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.ConfigurationEventOutputStatus Property

IRD

Adt7408ConfigurationEventOutputStatus Property

Configuration: Event Output Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7408TypeConfigurationEventOutputStatus ConfigurationEventOutputStatus { get; }
Public ReadOnly Property ConfigurationEventOutputStatus As Adt7408TypeConfigurationEventOutputStatus
    Get
public:
property Adt7408TypeConfigurationEventOutputStatus ConfigurationEventOutputStatus {
    Adt7408TypeConfigurationEventOutputStatus get ();
}
member ConfigurationEventOutputStatus : Adt7408TypeConfigurationEventOutputStatus with get

Property Value

Type: Adt7408TypeConfigurationEventOutputStatus
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.ConfigurationEventPolarity Property

IRD

Adt7408ConfigurationEventPolarity Property

Configuration: Event Polarity

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7408TypeConfigurationEventPolarity ConfigurationEventPolarity { get; set; }
Public Property ConfigurationEventPolarity As Adt7408TypeConfigurationEventPolarity
    Get
    Set
public:
property Adt7408TypeConfigurationEventPolarity ConfigurationEventPolarity {
    Adt7408TypeConfigurationEventPolarity get ();
    void set (Adt7408TypeConfigurationEventPolarity value);
}
member ConfigurationEventPolarity : Adt7408TypeConfigurationEventPolarity with get, set

Property Value

Type: Adt7408TypeConfigurationEventPolarity
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.ConfigurationHysteresisEnable Property

IRD

Adt7408ConfigurationHysteresisEnable Property

Configuration: Hysteresis Enable

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7408TypeConfigurationHysteresisEnable ConfigurationHysteresisEnable { get; set; }
Public Property ConfigurationHysteresisEnable As Adt7408TypeConfigurationHysteresisEnable
    Get
    Set
public:
property Adt7408TypeConfigurationHysteresisEnable ConfigurationHysteresisEnable {
    Adt7408TypeConfigurationHysteresisEnable get ();
    void set (Adt7408TypeConfigurationHysteresisEnable value);
}
member ConfigurationHysteresisEnable : Adt7408TypeConfigurationHysteresisEnable with get, set

Property Value

Type: Adt7408TypeConfigurationHysteresisEnable
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.ConfigurationShutdownMode Property

IRD

Adt7408ConfigurationShutdownMode Property

Configuration: Shutdown Mode

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7408TypeConfigurationShutdownMode ConfigurationShutdownMode { get; set; }
Public Property ConfigurationShutdownMode As Adt7408TypeConfigurationShutdownMode
    Get
    Set
public:
property Adt7408TypeConfigurationShutdownMode ConfigurationShutdownMode {
    Adt7408TypeConfigurationShutdownMode get ();
    void set (Adt7408TypeConfigurationShutdownMode value);
}
member ConfigurationShutdownMode : Adt7408TypeConfigurationShutdownMode with get, set

Property Value

Type: Adt7408TypeConfigurationShutdownMode
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.CriticalTemperatureTrip Property

IRD

Adt7408CriticalTemperatureTrip Property

Critical Temperature Trip (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CriticalTemperatureTrip { get; set; }
Public Property CriticalTemperatureTrip As Double
    Get
    Set
public:
property double CriticalTemperatureTrip {
    double get ();
    void set (double value);
}
member CriticalTemperatureTrip : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.DeviceIDRevision Property

IRD

Adt7408DeviceIDRevision Property

Device ID / Revision

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DeviceIDRevision { get; }
Public ReadOnly Property DeviceIDRevision As UShort
    Get
public:
property unsigned short DeviceIDRevision {
    unsigned short get ();
}
member DeviceIDRevision : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.ManufacturerID Property

IRD

Adt7408ManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As UShort
    Get
public:
property unsigned short ManufacturerID {
    unsigned short get ();
}
member ManufacturerID : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.TemperatureValueAboveAlarmWindow Property

IRD

Adt7408TemperatureValueAboveAlarmWindow Property

Temperature Value: Above Alarm Window

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7408TypeTemperatureStatus TemperatureValueAboveAlarmWindow { get; }
Public ReadOnly Property TemperatureValueAboveAlarmWindow As Adt7408TypeTemperatureStatus
    Get
public:
property Adt7408TypeTemperatureStatus TemperatureValueAboveAlarmWindow {
    Adt7408TypeTemperatureStatus get ();
}
member TemperatureValueAboveAlarmWindow : Adt7408TypeTemperatureStatus with get

Property Value

Type: Adt7408TypeTemperatureStatus
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.TemperatureValueAboveCriticalTrip Property

IRD

Adt7408TemperatureValueAboveCriticalTrip Property

Temperature Value: Above Critical Trip

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7408TypeTemperatureStatus TemperatureValueAboveCriticalTrip { get; }
Public ReadOnly Property TemperatureValueAboveCriticalTrip As Adt7408TypeTemperatureStatus
    Get
public:
property Adt7408TypeTemperatureStatus TemperatureValueAboveCriticalTrip {
    Adt7408TypeTemperatureStatus get ();
}
member TemperatureValueAboveCriticalTrip : Adt7408TypeTemperatureStatus with get

Property Value

Type: Adt7408TypeTemperatureStatus
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.TemperatureValueBelowAlarmWindow Property

IRD

Adt7408TemperatureValueBelowAlarmWindow Property

Temperature Value: Below Alarm Window

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7408TypeTemperatureStatus TemperatureValueBelowAlarmWindow { get; }
Public ReadOnly Property TemperatureValueBelowAlarmWindow As Adt7408TypeTemperatureStatus
    Get
public:
property Adt7408TypeTemperatureStatus TemperatureValueBelowAlarmWindow {
    Adt7408TypeTemperatureStatus get ();
}
member TemperatureValueBelowAlarmWindow : Adt7408TypeTemperatureStatus with get

Property Value

Type: Adt7408TypeTemperatureStatus
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.TemperatureValueTemperature Property

IRD

Adt7408TemperatureValueTemperature Property

Temperature Value: Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TemperatureValueTemperature { get; }
Public ReadOnly Property TemperatureValueTemperature As Double
    Get
public:
property double TemperatureValueTemperature {
    double get ();
}
member TemperatureValueTemperature : float with get

Property Value

Type: Double
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408 Methods

The Adt7408 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.Flush Method

IRD

Adt7408Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adt7408 Class
telos.Ird.AnalogDevices Namespace


Adt7408.TypeCapabilityAccuracy Enumeration

IRD

Adt7408TypeCapabilityAccuracy Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityAccuracy
Public Enumeration TypeCapabilityAccuracy
public enum class TypeCapabilityAccuracy
type TypeCapabilityAccuracy
Members
Member name | Value | Description
DefaultAccuracy2COverTheActiveRangeAnd3COverTheMonitorRange | 0 | Default accuracy ±2°C over the active range and ±3°C over the monitor range
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7408.TypeCapabilityTemperatureRange Enumeration

IRD

Adt7408TypeCapabilityTemperatureRange Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityTemperatureRange
Public Enumeration TypeCapabilityTemperatureRange
public enum class TypeCapabilityTemperatureRange
type TypeCapabilityTemperatureRange
Members
Member name | Value | Description
CanReadTemperatureBelow0CAndSetSignBitAccordingly | 1 | Can read temperature below 0°C and set sign bit accordingly
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7408.TypeCapabilityTemperatureResolution Enumeration

IRD

Adt7408TypeCapabilityTemperatureResolution Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityTemperatureResolution
Public Enumeration TypeCapabilityTemperatureResolution
public enum class TypeCapabilityTemperatureResolution
type TypeCapabilityTemperatureResolution
Members
Member name | Value | Description
Value_025CLSB | 1 | 0.25°C/LSB
Value_00625CLSB | 3 | 0.0625°C/LSB
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7408.TypeCapabilityTrips Enumeration

IRD

Adt7408TypeCapabilityTrips Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityTrips
Public Enumeration TypeCapabilityTrips
public enum class TypeCapabilityTrips
type TypeCapabilityTrips
Members
Member name | Value | Description
AlarmAndCriticalTipsCapability | 1 | Alarm and critical tips capability
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7408.TypeConfigurationAlarmWindowLock Enumeration

IRD

Adt7408TypeConfigurationAlarmWindowLock Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationAlarmWindowLock
Public Enumeration TypeConfigurationAlarmWindowLock
public enum class TypeConfigurationAlarmWindowLock
type TypeConfigurationAlarmWindowLock
Members
Member name | Value | Description
NotLocked | 0 | Not locked
Locked | 1 | Locked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7408.TypeConfigurationClearEvent Enumeration

IRD

Adt7408TypeConfigurationClearEvent Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationClearEvent
Public Enumeration TypeConfigurationClearEvent
public enum class TypeConfigurationClearEvent
type TypeConfigurationClearEvent
Members
Member name | Value | Description
NoEffect | 0 | No effect
ClearActiveEvent | 1 | Clear active event
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7408.TypeConfigurationCriticalEventOnly Enumeration

IRD

Adt7408TypeConfigurationCriticalEventOnly Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationCriticalEventOnly
Public Enumeration TypeConfigurationCriticalEventOnly
public enum class TypeConfigurationCriticalEventOnly
type TypeConfigurationCriticalEventOnly
Members
Member name | Value | Description
EventOutputOnAlarmOrCriticalTemperaturEvent | 0 | Event output on alarm or critical temperatur event
EventOnlyIfTemperatureIsAboveTheValueInTheCriticalTemperatureTripRegister | 1 | Event only if temperature is above the value in the critical temperature trip register
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7408.TypeConfigurationCriticalTripLock Enumeration

IRD

Adt7408TypeConfigurationCriticalTripLock Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationCriticalTripLock
Public Enumeration TypeConfigurationCriticalTripLock
public enum class TypeConfigurationCriticalTripLock
type TypeConfigurationCriticalTripLock
Members
Member name | Value | Description
NotLocked | 0 | Not locked
Locked | 1 | Locked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7408.TypeConfigurationEventMode Enumeration

IRD

Adt7408TypeConfigurationEventMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationEventMode
Public Enumeration TypeConfigurationEventMode
public enum class TypeConfigurationEventMode
type TypeConfigurationEventMode
Members
Member name | Value | Description
ComparatorOutputMode | 0 | Comparator Output Mode
InterruptMode | 1 | Interrupt Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7408.TypeConfigurationEventOutputControl Enumeration

IRD

Adt7408TypeConfigurationEventOutputControl Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationEventOutputControl
Public Enumeration TypeConfigurationEventOutputControl
public enum class TypeConfigurationEventOutputControl
type TypeConfigurationEventOutputControl
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7408.TypeConfigurationEventOutputStatus Enumeration

IRD

Adt7408TypeConfigurationEventOutputStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationEventOutputStatus
Public Enumeration TypeConfigurationEventOutputStatus
public enum class TypeConfigurationEventOutputStatus
type TypeConfigurationEventOutputStatus
Members
Member name | Value | Description
NotAsserted | 0 | Not Asserted
Asserted | 1 | Asserted
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7408.TypeConfigurationEventPolarity Enumeration

IRD

Adt7408TypeConfigurationEventPolarity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationEventPolarity
Public Enumeration TypeConfigurationEventPolarity
public enum class TypeConfigurationEventPolarity
type TypeConfigurationEventPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7408.TypeConfigurationHysteresisEnable Enumeration

IRD

Adt7408TypeConfigurationHysteresisEnable Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationHysteresisEnable
Public Enumeration TypeConfigurationHysteresisEnable
public enum class TypeConfigurationHysteresisEnable
type TypeConfigurationHysteresisEnable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled15C | 1 | Enabled (1.5°C)
Enabled3C | 2 | Enabled (3°C)
Enabled6C | 3 | Enabled (6°C)
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7408.TypeConfigurationShutdownMode Enumeration

IRD

Adt7408TypeConfigurationShutdownMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationShutdownMode
Public Enumeration TypeConfigurationShutdownMode
public enum class TypeConfigurationShutdownMode
type TypeConfigurationShutdownMode
Members
Member name | Value | Description
TSEnabled | 0 | TS enabled
TSShutDown | 1 | TS shut down
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7408.TypeTemperatureStatus Enumeration

IRD

Adt7408TypeTemperatureStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTemperatureStatus
Public Enumeration TypeTemperatureStatus
public enum class TypeTemperatureStatus
type TypeTemperatureStatus
Members
Member name | Value | Description
NotSet | 0 | Not Set
Set | 1 | Set
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7410 Class

Analog Devices: ADT 7410
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdt7410

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adt7410
Public Class Adt7410
public ref class Adt7410
type Adt7410 =  class end

The Adt7410 type exposes the following members.

Constructors
 | Name | Description
Public method | Adt7410 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationCTPinPolarity | Configuration: CT Pin Polarity
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationINTCTMode | Configuration: INT/CT Mode
Public property | ConfigurationINTPinPolarity | Configuration: INT Pin Polarity
Public property | ConfigurationOperationMode | Configuration: Operation Mode
Public property | ConfigurationResolution | Configuration: Resolution
Public property | IDManufacturerID | ID: Manufacturer ID
Public property | IDRevisionID | ID: Revision ID
Public property | StatusRDY | Status: RDY
Public property | StatusTCRIT | Status: T_CRIT
Public property | StatusTHIGH | Status: T_HIGH
Public property | StatusTLOW | Status: T_LOW
Public property | TCRITSetpoint | T_CRIT Setpoint (unit: °C)
Public property | Temperature | Temperature (unit: °C)
Public property | TemperatureTCRITFlag | Temperature: T_CRIT Flag
Public property | TemperatureTHIGHFlag | Temperature: T_HIGH Flag
Public property | TemperatureTLOWFlag | Temperature: T_LOW Flag
Public property | THIGHSetpoint | T_HIGH Setpoint (unit: °C)
Public property | THYSTSetpoint | T_HYST Setpoint (unit: °C)
Public property | TLOWSetpoint | T_LOW Setpoint (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Reset
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
±0.5°C Accurate, 16-Bit Digital Temperature Sensor
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7410 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7410(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adt7410(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adt7410

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410 Properties

The Adt7410 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationCTPinPolarity | Configuration: CT Pin Polarity
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationINTCTMode | Configuration: INT/CT Mode
Public property | ConfigurationINTPinPolarity | Configuration: INT Pin Polarity
Public property | ConfigurationOperationMode | Configuration: Operation Mode
Public property | ConfigurationResolution | Configuration: Resolution
Public property | IDManufacturerID | ID: Manufacturer ID
Public property | IDRevisionID | ID: Revision ID
Public property | StatusRDY | Status: RDY
Public property | StatusTCRIT | Status: T_CRIT
Public property | StatusTHIGH | Status: T_HIGH
Public property | StatusTLOW | Status: T_LOW
Public property | TCRITSetpoint | T_CRIT Setpoint (unit: °C)
Public property | Temperature | Temperature (unit: °C)
Public property | TemperatureTCRITFlag | Temperature: T_CRIT Flag
Public property | TemperatureTHIGHFlag | Temperature: T_HIGH Flag
Public property | TemperatureTLOWFlag | Temperature: T_LOW Flag
Public property | THIGHSetpoint | T_HIGH Setpoint (unit: °C)
Public property | THYSTSetpoint | T_HYST Setpoint (unit: °C)
Public property | TLOWSetpoint | T_LOW Setpoint (unit: °C)
Top
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.AutoFlush Property

IRD

Adt7410AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.ConfigurationCTPinPolarity Property

IRD

Adt7410ConfigurationCTPinPolarity Property

Configuration: CT Pin Polarity

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7410TypeConfigurationIntCtPinPolarity ConfigurationCTPinPolarity { get; set; }
Public Property ConfigurationCTPinPolarity As Adt7410TypeConfigurationIntCtPinPolarity
    Get
    Set
public:
property Adt7410TypeConfigurationIntCtPinPolarity ConfigurationCTPinPolarity {
    Adt7410TypeConfigurationIntCtPinPolarity get ();
    void set (Adt7410TypeConfigurationIntCtPinPolarity value);
}
member ConfigurationCTPinPolarity : Adt7410TypeConfigurationIntCtPinPolarity with get, set

Property Value

Type: Adt7410TypeConfigurationIntCtPinPolarity
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.ConfigurationFaultQueue Property

IRD

Adt7410ConfigurationFaultQueue Property

Configuration: Fault Queue

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ConfigurationFaultQueue { get; set; }
Public Property ConfigurationFaultQueue As Byte
    Get
    Set
public:
property unsigned char ConfigurationFaultQueue {
    unsigned char get ();
    void set (unsigned char value);
}
member ConfigurationFaultQueue : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.ConfigurationINTCTMode Property

IRD

Adt7410ConfigurationINTCTMode Property

Configuration: INT/CT Mode

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7410TypeConfigurationIntCtMode ConfigurationINTCTMode { get; set; }
Public Property ConfigurationINTCTMode As Adt7410TypeConfigurationIntCtMode
    Get
    Set
public:
property Adt7410TypeConfigurationIntCtMode ConfigurationINTCTMode {
    Adt7410TypeConfigurationIntCtMode get ();
    void set (Adt7410TypeConfigurationIntCtMode value);
}
member ConfigurationINTCTMode : Adt7410TypeConfigurationIntCtMode with get, set

Property Value

Type: Adt7410TypeConfigurationIntCtMode
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.ConfigurationINTPinPolarity Property

IRD

Adt7410ConfigurationINTPinPolarity Property

Configuration: INT Pin Polarity

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7410TypeConfigurationIntCtPinPolarity ConfigurationINTPinPolarity { get; set; }
Public Property ConfigurationINTPinPolarity As Adt7410TypeConfigurationIntCtPinPolarity
    Get
    Set
public:
property Adt7410TypeConfigurationIntCtPinPolarity ConfigurationINTPinPolarity {
    Adt7410TypeConfigurationIntCtPinPolarity get ();
    void set (Adt7410TypeConfigurationIntCtPinPolarity value);
}
member ConfigurationINTPinPolarity : Adt7410TypeConfigurationIntCtPinPolarity with get, set

Property Value

Type: Adt7410TypeConfigurationIntCtPinPolarity
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.ConfigurationOperationMode Property

IRD

Adt7410ConfigurationOperationMode Property

Configuration: Operation Mode

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7410TypeConfigurationOperationMode ConfigurationOperationMode { get; set; }
Public Property ConfigurationOperationMode As Adt7410TypeConfigurationOperationMode
    Get
    Set
public:
property Adt7410TypeConfigurationOperationMode ConfigurationOperationMode {
    Adt7410TypeConfigurationOperationMode get ();
    void set (Adt7410TypeConfigurationOperationMode value);
}
member ConfigurationOperationMode : Adt7410TypeConfigurationOperationMode with get, set

Property Value

Type: Adt7410TypeConfigurationOperationMode
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.ConfigurationResolution Property

IRD

Adt7410ConfigurationResolution Property

Configuration: Resolution

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7410TypeConfigurationResolution ConfigurationResolution { get; set; }
Public Property ConfigurationResolution As Adt7410TypeConfigurationResolution
    Get
    Set
public:
property Adt7410TypeConfigurationResolution ConfigurationResolution {
    Adt7410TypeConfigurationResolution get ();
    void set (Adt7410TypeConfigurationResolution value);
}
member ConfigurationResolution : Adt7410TypeConfigurationResolution with get, set

Property Value

Type: Adt7410TypeConfigurationResolution
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.IDManufacturerID Property

IRD

Adt7410IDManufacturerID Property

ID: Manufacturer ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IDManufacturerID { get; }
Public ReadOnly Property IDManufacturerID As Byte
    Get
public:
property unsigned char IDManufacturerID {
    unsigned char get ();
}
member IDManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.IDRevisionID Property

IRD

Adt7410IDRevisionID Property

ID: Revision ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IDRevisionID { get; }
Public ReadOnly Property IDRevisionID As Byte
    Get
public:
property unsigned char IDRevisionID {
    unsigned char get ();
}
member IDRevisionID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.StatusRDY Property

IRD

Adt7410StatusRDY Property

Status: RDY

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7410TypeStatus StatusRDY { get; }
Public ReadOnly Property StatusRDY As Adt7410TypeStatus
    Get
public:
property Adt7410TypeStatus StatusRDY {
    Adt7410TypeStatus get ();
}
member StatusRDY : Adt7410TypeStatus with get

Property Value

Type: Adt7410TypeStatus
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.StatusTCRIT Property

IRD

Adt7410StatusTCRIT Property

Status: T_CRIT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7410TypeStatus StatusTCRIT { get; }
Public ReadOnly Property StatusTCRIT As Adt7410TypeStatus
    Get
public:
property Adt7410TypeStatus StatusTCRIT {
    Adt7410TypeStatus get ();
}
member StatusTCRIT : Adt7410TypeStatus with get

Property Value

Type: Adt7410TypeStatus
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.StatusTHIGH Property

IRD

Adt7410StatusTHIGH Property

Status: T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7410TypeStatus StatusTHIGH { get; }
Public ReadOnly Property StatusTHIGH As Adt7410TypeStatus
    Get
public:
property Adt7410TypeStatus StatusTHIGH {
    Adt7410TypeStatus get ();
}
member StatusTHIGH : Adt7410TypeStatus with get

Property Value

Type: Adt7410TypeStatus
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.StatusTLOW Property

IRD

Adt7410StatusTLOW Property

Status: T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7410TypeStatus StatusTLOW { get; }
Public ReadOnly Property StatusTLOW As Adt7410TypeStatus
    Get
public:
property Adt7410TypeStatus StatusTLOW {
    Adt7410TypeStatus get ();
}
member StatusTLOW : Adt7410TypeStatus with get

Property Value

Type: Adt7410TypeStatus
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.TCRITSetpoint Property

IRD

Adt7410TCRITSetpoint Property

T_CRIT Setpoint (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TCRITSetpoint { get; set; }
Public Property TCRITSetpoint As Double
    Get
    Set
public:
property double TCRITSetpoint {
    double get ();
    void set (double value);
}
member TCRITSetpoint : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.Temperature Property

IRD

Adt7410Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.TemperatureTCRITFlag Property

IRD

Adt7410TemperatureTCRITFlag Property

Temperature: T_CRIT Flag

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7410TypeTempFlag TemperatureTCRITFlag { get; }
Public ReadOnly Property TemperatureTCRITFlag As Adt7410TypeTempFlag
    Get
public:
property Adt7410TypeTempFlag TemperatureTCRITFlag {
    Adt7410TypeTempFlag get ();
}
member TemperatureTCRITFlag : Adt7410TypeTempFlag with get

Property Value

Type: Adt7410TypeTempFlag
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.TemperatureTHIGHFlag Property

IRD

Adt7410TemperatureTHIGHFlag Property

Temperature: T_HIGH Flag

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7410TypeTempFlag TemperatureTHIGHFlag { get; }
Public ReadOnly Property TemperatureTHIGHFlag As Adt7410TypeTempFlag
    Get
public:
property Adt7410TypeTempFlag TemperatureTHIGHFlag {
    Adt7410TypeTempFlag get ();
}
member TemperatureTHIGHFlag : Adt7410TypeTempFlag with get

Property Value

Type: Adt7410TypeTempFlag
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.TemperatureTLOWFlag Property

IRD

Adt7410TemperatureTLOWFlag Property

Temperature: T_LOW Flag

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7410TypeTempFlag TemperatureTLOWFlag { get; }
Public ReadOnly Property TemperatureTLOWFlag As Adt7410TypeTempFlag
    Get
public:
property Adt7410TypeTempFlag TemperatureTLOWFlag {
    Adt7410TypeTempFlag get ();
}
member TemperatureTLOWFlag : Adt7410TypeTempFlag with get

Property Value

Type: Adt7410TypeTempFlag
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.THIGHSetpoint Property

IRD

Adt7410THIGHSetpoint Property

T_HIGH Setpoint (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double THIGHSetpoint { get; set; }
Public Property THIGHSetpoint As Double
    Get
    Set
public:
property double THIGHSetpoint {
    double get ();
    void set (double value);
}
member THIGHSetpoint : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.THYSTSetpoint Property

IRD

Adt7410THYSTSetpoint Property

T_HYST Setpoint (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte THYSTSetpoint { get; set; }
Public Property THYSTSetpoint As Byte
    Get
    Set
public:
property unsigned char THYSTSetpoint {
    unsigned char get ();
    void set (unsigned char value);
}
member THYSTSetpoint : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.TLOWSetpoint Property

IRD

Adt7410TLOWSetpoint Property

T_LOW Setpoint (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TLOWSetpoint { get; set; }
Public Property TLOWSetpoint As Double
    Get
    Set
public:
property double TLOWSetpoint {
    double get ();
    void set (double value);
}
member TLOWSetpoint : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410 Methods

The Adt7410 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Reset
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.Flush Method

IRD

Adt7410Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.Reset Method

IRD

Adt7410Reset Method

Reset

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Reset()
Public Sub Reset
public:
void Reset()
member Reset : unit -> unit
See Also

Reference

Adt7410 Class
telos.Ird.AnalogDevices Namespace


Adt7410.TypeConfigurationIntCtMode Enumeration

IRD

Adt7410TypeConfigurationIntCtMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationIntCtMode
Public Enumeration TypeConfigurationIntCtMode
public enum class TypeConfigurationIntCtMode
type TypeConfigurationIntCtMode
Members
Member name | Value | Description
InterruptMode | 0 | Interrupt Mode
ComparatorMode | 1 | Comparator Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7410.TypeConfigurationIntCtPinPolarity Enumeration

IRD

Adt7410TypeConfigurationIntCtPinPolarity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationIntCtPinPolarity
Public Enumeration TypeConfigurationIntCtPinPolarity
public enum class TypeConfigurationIntCtPinPolarity
type TypeConfigurationIntCtPinPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7410.TypeConfigurationOperationMode Enumeration

IRD

Adt7410TypeConfigurationOperationMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationOperationMode
Public Enumeration TypeConfigurationOperationMode
public enum class TypeConfigurationOperationMode
type TypeConfigurationOperationMode
Members
Member name | Value | Description
ContinuousConversion | 0 | Continuous Conversion
OneShot | 1 | One Shot
Value_1SPS | 2 | 1 SPS
Shutdown | 3 | Shutdown
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7410.TypeConfigurationResolution Enumeration

IRD

Adt7410TypeConfigurationResolution Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationResolution
Public Enumeration TypeConfigurationResolution
public enum class TypeConfigurationResolution
type TypeConfigurationResolution
Members
Member name | Value | Description
Value_13Bit | 0 | 13-bit
Value_16Bit | 1 | 16-bit
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7410.TypeStatus Enumeration

IRD

Adt7410TypeStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus
Public Enumeration TypeStatus
public enum class TypeStatus
type TypeStatus
Members
Member name | Value | Description
NotSet | 0 | Not Set
Set | 1 | Set
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7410.TypeTempFlag Enumeration

IRD

Adt7410TypeTempFlag Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTempFlag
Public Enumeration TypeTempFlag
public enum class TypeTempFlag
type TypeTempFlag
Members
Member name | Value | Description
NotSet | 0 | Not Set
Set | 1 | Set
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7411 Class

Analog Devices: ADT 7411
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdt7411

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adt7411
Public Class Adt7411
public ref class Adt7411
type Adt7411 =  class end

The Adt7411 type exposes the following members.

Constructors
 | Name | Description
Public method | Adt7411 | Constructor
Top
Properties
 | Name | Description
Public property | AIN2 | AIN2
Public property | AIN2VHIGHLimit | AIN2 V_HIGH Limit
Public property | AIN2VLOWLimit | AIN2 V_LOW Limit
Public property | AIN3 | AIN3
Public property | AIN3VHIGHLimit | AIN3 V_HIGH Limit
Public property | AIN3VLOWLimit | AIN3 V_LOW Limit
Public property | AIN4 | AIN4
Public property | AIN4VHIGHLimit | AIN4 V_HIGH Limit
Public property | AIN4VLOWLimit | AIN4 V_LOW Limit
Public property | AIN5 | AIN5
Public property | AIN5VHIGHLimit | AIN5 V_HIGH Limit
Public property | AIN5VLOWLimit | AIN5 V_LOW Limit
Public property | AIN6 | AIN6
Public property | AIN6VHIGHLimit | AIN6 V_HIGH Limit
Public property | AIN6VLOWLimit | AIN6 V_LOW Limit
Public property | AIN7 | AIN7
Public property | AIN7VHIGHLimit | AIN7 V_HIGH Limit
Public property | AIN7VLOWLimit | AIN7 V_LOW Limit
Public property | AIN8 | AIN8
Public property | AIN8VHIGHLimit | AIN8 V_HIGH Limit
Public property | AIN8VLOWLimit | AIN8 V_LOW Limit
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlConfiguration1INTOutput | Control Configuration 1: INT Output
Public property | ControlConfiguration1INTOutputPolarity | Control Configuration 1: INT Output Polarity
Public property | ControlConfiguration1Monitoring | Control Configuration 1: Monitoring
Public property | ControlConfiguration1Pin7Pin8 | Control Configuration 1: Pin 7 / Pin 8
Public property | ControlConfiguration1PowerDown | Control Configuration 1: Power Down
Public property | ControlConfiguration2Averaging | Control Configuration 2: Averaging
Public property | ControlConfiguration2ChannelSelection | Control Configuration 2: Channel Selection
Public property | ControlConfiguration2Conversion | Control Configuration 2: Conversion
Public property | ControlConfiguration2SMBusTimeout | Control Configuration 2: SMBus Timeout
Public property | ControlConfiguration2SoftwareReset | Control Configuration 2: Software Reset
Public property | ControlConfiguration3ADCReference | Control Configuration 3: ADC Reference
Public property | ControlConfiguration3Speed | Control Configuration 3: Speed
Public property | DeviceID | Device ID
Public property | ExternalTemperatureAIN1 | External Temperature / AIN1 (unit: °C)
Public property | ExternalTemperatureOffset | External Temperature Offset (unit: °C)
Public property | ExternalTHIGHAIN1VHIGHLimits | External T_HIGH/AIN1 V_HIGH Limits (unit: °C)
Public property | ExternalTLOWAIN1VLOWLimits | External T_LOW/AIN1 V_LOW Limits (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | InternalTemperatureOffset | Internal Temperature Offset (unit: °C)
Public property | InternalTHIGHLimit | Internal T_HIGH Limit (unit: °C)
Public property | InternalTLOWLimit | Internal T_LOW Limit (unit: °C)
Public property | InterruptMask1AIN2 | Interrupt Mask 1: AIN2
Public property | InterruptMask1AIN3 | Interrupt Mask 1: AIN3
Public property | InterruptMask1AIN4 | Interrupt Mask 1: AIN4
Public property | InterruptMask1ExternalTemperatureFault | Interrupt Mask 1: External Temperature Fault
Public property | InterruptMask1ExternalTHIGHAIN1 | Interrupt Mask 1: External T_HIGH / AIN1
Public property | InterruptMask1ExternalTLOW | Interrupt Mask 1: External T_LOW
Public property | InterruptMask1InternalTHIGH | Interrupt Mask 1: Internal T_HIGH
Public property | InterruptMask1InternalTLOW | Interrupt Mask 1: Internal T_LOW
Public property | InterruptMask2AIN5 | Interrupt Mask 2: AIN5
Public property | InterruptMask2AIN6 | Interrupt Mask 2: AIN6
Public property | InterruptMask2AIN7 | Interrupt Mask 2: AIN7
Public property | InterruptMask2AIN8 | Interrupt Mask 2: AIN8
Public property | InterruptMask2VDD | Interrupt Mask 2: V_DD
Public property | InterruptStatus1AIN2VHIGHAIN2VLOW | Interrupt Status 1: AIN2 > V_HIGH / AIN2 <= V_LOW
Public property | InterruptStatus1AIN3VHIGHAIN3VLOW | Interrupt Status 1: AIN3 > V_HIGH / AIN3 <= V_LOW
Public property | InterruptStatus1AIN4VHIGHAIN4VLOW | Interrupt Status 1: AIN4 > V_HIGH / AIN4 <= V_LOW
Public property | InterruptStatus1ExternalSensorFault | Interrupt Status 1: External Sensor Fault
Public property | InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW | Interrupt Status 1: T_EXT > T_HIGH / AIN1 > V_HIGH / AIN1 <= V_LOW
Public property | InterruptStatus1TEXTTLOW | Interrupt Status 1: T_EXT <= T_LOW
Public property | InterruptStatus1TINTTHIGH | Interrupt Status 1: T_INT > T_HIGH
Public property | InterruptStatus1TINTTLOW | Interrupt Status 1: T_INT <= T_LOW
Public property | InterruptStatus2AIN5VHIGHAIN5VLOW | Interrupt Status 2: AIN5 > V_HIGH / AIN5 <= V_LOW
Public property | InterruptStatus2AIN6VHIGHAIN6VLOW | Interrupt Status 2: AIN6 > V_HIGH / AIN6 <= V_LOW
Public property | InterruptStatus2AIN7VHIGHAIN7VLOW | Interrupt Status 2: AIN7 > V_HIGH / AIN7 <= V_LOW
Public property | InterruptStatus2AIN8VHIGHAIN8VLOW | Interrupt Status 2: AIN8 > V_HIGH / AIN8 <= V_LOW
Public property | InterruptStatus2VDDVHIGHVDDVLOW | Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW
Public property | ManufacturerSID | Manufacturer's ID
Public property | SiliconRevisionStepping | Silicon Revision: Stepping
Public property | SiliconRevisionVersion | Silicon Revision: Version
Public property | SPILockStatus | SPI Lock Status
Public property | VDD | V_DD (unit: V)
Public property | VDDVHIGHLimit | V_DD V_HIGH Limit (unit: V)
Public property | VDDVLOWLimit | V_DD V_LOW Limit (unit: V)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
10-Bit Digital Temperature Sensor and 8-Channel ADC
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7411 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adt7411(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adt7411

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411 Properties

The Adt7411 type exposes the following members.

Properties
 | Name | Description
Public property | AIN2 | AIN2
Public property | AIN2VHIGHLimit | AIN2 V_HIGH Limit
Public property | AIN2VLOWLimit | AIN2 V_LOW Limit
Public property | AIN3 | AIN3
Public property | AIN3VHIGHLimit | AIN3 V_HIGH Limit
Public property | AIN3VLOWLimit | AIN3 V_LOW Limit
Public property | AIN4 | AIN4
Public property | AIN4VHIGHLimit | AIN4 V_HIGH Limit
Public property | AIN4VLOWLimit | AIN4 V_LOW Limit
Public property | AIN5 | AIN5
Public property | AIN5VHIGHLimit | AIN5 V_HIGH Limit
Public property | AIN5VLOWLimit | AIN5 V_LOW Limit
Public property | AIN6 | AIN6
Public property | AIN6VHIGHLimit | AIN6 V_HIGH Limit
Public property | AIN6VLOWLimit | AIN6 V_LOW Limit
Public property | AIN7 | AIN7
Public property | AIN7VHIGHLimit | AIN7 V_HIGH Limit
Public property | AIN7VLOWLimit | AIN7 V_LOW Limit
Public property | AIN8 | AIN8
Public property | AIN8VHIGHLimit | AIN8 V_HIGH Limit
Public property | AIN8VLOWLimit | AIN8 V_LOW Limit
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlConfiguration1INTOutput | Control Configuration 1: INT Output
Public property | ControlConfiguration1INTOutputPolarity | Control Configuration 1: INT Output Polarity
Public property | ControlConfiguration1Monitoring | Control Configuration 1: Monitoring
Public property | ControlConfiguration1Pin7Pin8 | Control Configuration 1: Pin 7 / Pin 8
Public property | ControlConfiguration1PowerDown | Control Configuration 1: Power Down
Public property | ControlConfiguration2Averaging | Control Configuration 2: Averaging
Public property | ControlConfiguration2ChannelSelection | Control Configuration 2: Channel Selection
Public property | ControlConfiguration2Conversion | Control Configuration 2: Conversion
Public property | ControlConfiguration2SMBusTimeout | Control Configuration 2: SMBus Timeout
Public property | ControlConfiguration2SoftwareReset | Control Configuration 2: Software Reset
Public property | ControlConfiguration3ADCReference | Control Configuration 3: ADC Reference
Public property | ControlConfiguration3Speed | Control Configuration 3: Speed
Public property | DeviceID | Device ID
Public property | ExternalTemperatureAIN1 | External Temperature / AIN1 (unit: °C)
Public property | ExternalTemperatureOffset | External Temperature Offset (unit: °C)
Public property | ExternalTHIGHAIN1VHIGHLimits | External T_HIGH/AIN1 V_HIGH Limits (unit: °C)
Public property | ExternalTLOWAIN1VLOWLimits | External T_LOW/AIN1 V_LOW Limits (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | InternalTemperatureOffset | Internal Temperature Offset (unit: °C)
Public property | InternalTHIGHLimit | Internal T_HIGH Limit (unit: °C)
Public property | InternalTLOWLimit | Internal T_LOW Limit (unit: °C)
Public property | InterruptMask1AIN2 | Interrupt Mask 1: AIN2
Public property | InterruptMask1AIN3 | Interrupt Mask 1: AIN3
Public property | InterruptMask1AIN4 | Interrupt Mask 1: AIN4
Public property | InterruptMask1ExternalTemperatureFault | Interrupt Mask 1: External Temperature Fault
Public property | InterruptMask1ExternalTHIGHAIN1 | Interrupt Mask 1: External T_HIGH / AIN1
Public property | InterruptMask1ExternalTLOW | Interrupt Mask 1: External T_LOW
Public property | InterruptMask1InternalTHIGH | Interrupt Mask 1: Internal T_HIGH
Public property | InterruptMask1InternalTLOW | Interrupt Mask 1: Internal T_LOW
Public property | InterruptMask2AIN5 | Interrupt Mask 2: AIN5
Public property | InterruptMask2AIN6 | Interrupt Mask 2: AIN6
Public property | InterruptMask2AIN7 | Interrupt Mask 2: AIN7
Public property | InterruptMask2AIN8 | Interrupt Mask 2: AIN8
Public property | InterruptMask2VDD | Interrupt Mask 2: V_DD
Public property | InterruptStatus1AIN2VHIGHAIN2VLOW | Interrupt Status 1: AIN2 > V_HIGH / AIN2 <= V_LOW
Public property | InterruptStatus1AIN3VHIGHAIN3VLOW | Interrupt Status 1: AIN3 > V_HIGH / AIN3 <= V_LOW
Public property | InterruptStatus1AIN4VHIGHAIN4VLOW | Interrupt Status 1: AIN4 > V_HIGH / AIN4 <= V_LOW
Public property | InterruptStatus1ExternalSensorFault | Interrupt Status 1: External Sensor Fault
Public property | InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW | Interrupt Status 1: T_EXT > T_HIGH / AIN1 > V_HIGH / AIN1 <= V_LOW
Public property | InterruptStatus1TEXTTLOW | Interrupt Status 1: T_EXT <= T_LOW
Public property | InterruptStatus1TINTTHIGH | Interrupt Status 1: T_INT > T_HIGH
Public property | InterruptStatus1TINTTLOW | Interrupt Status 1: T_INT <= T_LOW
Public property | InterruptStatus2AIN5VHIGHAIN5VLOW | Interrupt Status 2: AIN5 > V_HIGH / AIN5 <= V_LOW
Public property | InterruptStatus2AIN6VHIGHAIN6VLOW | Interrupt Status 2: AIN6 > V_HIGH / AIN6 <= V_LOW
Public property | InterruptStatus2AIN7VHIGHAIN7VLOW | Interrupt Status 2: AIN7 > V_HIGH / AIN7 <= V_LOW
Public property | InterruptStatus2AIN8VHIGHAIN8VLOW | Interrupt Status 2: AIN8 > V_HIGH / AIN8 <= V_LOW
Public property | InterruptStatus2VDDVHIGHVDDVLOW | Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW
Public property | ManufacturerSID | Manufacturer's ID
Public property | SiliconRevisionStepping | Silicon Revision: Stepping
Public property | SiliconRevisionVersion | Silicon Revision: Version
Public property | SPILockStatus | SPI Lock Status
Public property | VDD | V_DD (unit: V)
Public property | VDDVHIGHLimit | V_DD V_HIGH Limit (unit: V)
Public property | VDDVLOWLimit | V_DD V_LOW Limit (unit: V)
Top
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN2 Property

IRD

Adt7411AIN2 Property

AIN2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AIN2 { get; }
Public ReadOnly Property AIN2 As UShort
    Get
public:
property unsigned short AIN2 {
    unsigned short get ();
}
member AIN2 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN2VHIGHLimit Property

IRD

Adt7411AIN2VHIGHLimit Property

AIN2 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN2VHIGHLimit { get; set; }
Public Property AIN2VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN2VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN2VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN2VLOWLimit Property

IRD

Adt7411AIN2VLOWLimit Property

AIN2 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN2VLOWLimit { get; set; }
Public Property AIN2VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN2VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN2VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN3 Property

IRD

Adt7411AIN3 Property

AIN3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AIN3 { get; }
Public ReadOnly Property AIN3 As UShort
    Get
public:
property unsigned short AIN3 {
    unsigned short get ();
}
member AIN3 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN3VHIGHLimit Property

IRD

Adt7411AIN3VHIGHLimit Property

AIN3 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN3VHIGHLimit { get; set; }
Public Property AIN3VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN3VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN3VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN3VLOWLimit Property

IRD

Adt7411AIN3VLOWLimit Property

AIN3 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN3VLOWLimit { get; set; }
Public Property AIN3VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN3VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN3VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN4 Property

IRD

Adt7411AIN4 Property

AIN4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AIN4 { get; }
Public ReadOnly Property AIN4 As UShort
    Get
public:
property unsigned short AIN4 {
    unsigned short get ();
}
member AIN4 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN4VHIGHLimit Property

IRD

Adt7411AIN4VHIGHLimit Property

AIN4 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN4VHIGHLimit { get; set; }
Public Property AIN4VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN4VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN4VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN4VLOWLimit Property

IRD

Adt7411AIN4VLOWLimit Property

AIN4 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN4VLOWLimit { get; set; }
Public Property AIN4VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN4VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN4VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN5 Property

IRD

Adt7411AIN5 Property

AIN5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AIN5 { get; }
Public ReadOnly Property AIN5 As UShort
    Get
public:
property unsigned short AIN5 {
    unsigned short get ();
}
member AIN5 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN5VHIGHLimit Property

IRD

Adt7411AIN5VHIGHLimit Property

AIN5 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN5VHIGHLimit { get; set; }
Public Property AIN5VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN5VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN5VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN5VLOWLimit Property

IRD

Adt7411AIN5VLOWLimit Property

AIN5 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN5VLOWLimit { get; set; }
Public Property AIN5VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN5VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN5VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN6 Property

IRD

Adt7411AIN6 Property

AIN6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AIN6 { get; }
Public ReadOnly Property AIN6 As UShort
    Get
public:
property unsigned short AIN6 {
    unsigned short get ();
}
member AIN6 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN6VHIGHLimit Property

IRD

Adt7411AIN6VHIGHLimit Property

AIN6 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN6VHIGHLimit { get; set; }
Public Property AIN6VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN6VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN6VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN6VLOWLimit Property

IRD

Adt7411AIN6VLOWLimit Property

AIN6 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN6VLOWLimit { get; set; }
Public Property AIN6VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN6VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN6VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN7 Property

IRD

Adt7411AIN7 Property

AIN7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AIN7 { get; }
Public ReadOnly Property AIN7 As UShort
    Get
public:
property unsigned short AIN7 {
    unsigned short get ();
}
member AIN7 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN7VHIGHLimit Property

IRD

Adt7411AIN7VHIGHLimit Property

AIN7 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN7VHIGHLimit { get; set; }
Public Property AIN7VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN7VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN7VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN7VLOWLimit Property

IRD

Adt7411AIN7VLOWLimit Property

AIN7 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN7VLOWLimit { get; set; }
Public Property AIN7VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN7VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN7VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN8 Property

IRD

Adt7411AIN8 Property

AIN8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AIN8 { get; }
Public ReadOnly Property AIN8 As UShort
    Get
public:
property unsigned short AIN8 {
    unsigned short get ();
}
member AIN8 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN8VHIGHLimit Property

IRD

Adt7411AIN8VHIGHLimit Property

AIN8 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN8VHIGHLimit { get; set; }
Public Property AIN8VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN8VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN8VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AIN8VLOWLimit Property

IRD

Adt7411AIN8VLOWLimit Property

AIN8 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN8VLOWLimit { get; set; }
Public Property AIN8VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN8VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN8VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.AutoFlush Property

IRD

Adt7411AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.ControlConfiguration1INTOutput Property

IRD

Adt7411ControlConfiguration1INTOutput Property

Control Configuration 1: INT Output

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeControlConfiguration1IntOutput ControlConfiguration1INTOutput { get; set; }
Public Property ControlConfiguration1INTOutput As Adt7411TypeControlConfiguration1IntOutput
    Get
    Set
public:
property Adt7411TypeControlConfiguration1IntOutput ControlConfiguration1INTOutput {
    Adt7411TypeControlConfiguration1IntOutput get ();
    void set (Adt7411TypeControlConfiguration1IntOutput value);
}
member ControlConfiguration1INTOutput : Adt7411TypeControlConfiguration1IntOutput with get, set

Property Value

Type: Adt7411TypeControlConfiguration1IntOutput
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.ControlConfiguration1INTOutputPolarity Property

IRD

Adt7411ControlConfiguration1INTOutputPolarity Property

Control Configuration 1: INT Output Polarity

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeControlConfiguration1IntOutputPolarity ControlConfiguration1INTOutputPolarity { get; set; }
Public Property ControlConfiguration1INTOutputPolarity As Adt7411TypeControlConfiguration1IntOutputPolarity
    Get
    Set
public:
property Adt7411TypeControlConfiguration1IntOutputPolarity ControlConfiguration1INTOutputPolarity {
    Adt7411TypeControlConfiguration1IntOutputPolarity get ();
    void set (Adt7411TypeControlConfiguration1IntOutputPolarity value);
}
member ControlConfiguration1INTOutputPolarity : Adt7411TypeControlConfiguration1IntOutputPolarity with get, set

Property Value

Type: Adt7411TypeControlConfiguration1IntOutputPolarity
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.ControlConfiguration1Monitoring Property

IRD

Adt7411ControlConfiguration1Monitoring Property

Control Configuration 1: Monitoring

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeControlConfiguration1Monitoring ControlConfiguration1Monitoring { get; set; }
Public Property ControlConfiguration1Monitoring As Adt7411TypeControlConfiguration1Monitoring
    Get
    Set
public:
property Adt7411TypeControlConfiguration1Monitoring ControlConfiguration1Monitoring {
    Adt7411TypeControlConfiguration1Monitoring get ();
    void set (Adt7411TypeControlConfiguration1Monitoring value);
}
member ControlConfiguration1Monitoring : Adt7411TypeControlConfiguration1Monitoring with get, set

Property Value

Type: Adt7411TypeControlConfiguration1Monitoring
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.ControlConfiguration1Pin7Pin8 Property

IRD

Adt7411ControlConfiguration1Pin7Pin8 Property

Control Configuration 1: Pin 7 / Pin 8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeControlConfiguration1AinTdmSelection ControlConfiguration1Pin7Pin8 { get; set; }
Public Property ControlConfiguration1Pin7Pin8 As Adt7411TypeControlConfiguration1AinTdmSelection
    Get
    Set
public:
property Adt7411TypeControlConfiguration1AinTdmSelection ControlConfiguration1Pin7Pin8 {
    Adt7411TypeControlConfiguration1AinTdmSelection get ();
    void set (Adt7411TypeControlConfiguration1AinTdmSelection value);
}
member ControlConfiguration1Pin7Pin8 : Adt7411TypeControlConfiguration1AinTdmSelection with get, set

Property Value

Type: Adt7411TypeControlConfiguration1AinTdmSelection
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.ControlConfiguration1PowerDown Property

IRD

Adt7411ControlConfiguration1PowerDown Property

Control Configuration 1: Power Down

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeControlConfiguration1PowerDown ControlConfiguration1PowerDown { get; set; }
Public Property ControlConfiguration1PowerDown As Adt7411TypeControlConfiguration1PowerDown
    Get
    Set
public:
property Adt7411TypeControlConfiguration1PowerDown ControlConfiguration1PowerDown {
    Adt7411TypeControlConfiguration1PowerDown get ();
    void set (Adt7411TypeControlConfiguration1PowerDown value);
}
member ControlConfiguration1PowerDown : Adt7411TypeControlConfiguration1PowerDown with get, set

Property Value

Type: Adt7411TypeControlConfiguration1PowerDown
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.ControlConfiguration2Averaging Property

IRD

Adt7411ControlConfiguration2Averaging Property

Control Configuration 2: Averaging

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeControlConfiguration2Averaging ControlConfiguration2Averaging { get; set; }
Public Property ControlConfiguration2Averaging As Adt7411TypeControlConfiguration2Averaging
    Get
    Set
public:
property Adt7411TypeControlConfiguration2Averaging ControlConfiguration2Averaging {
    Adt7411TypeControlConfiguration2Averaging get ();
    void set (Adt7411TypeControlConfiguration2Averaging value);
}
member ControlConfiguration2Averaging : Adt7411TypeControlConfiguration2Averaging with get, set

Property Value

Type: Adt7411TypeControlConfiguration2Averaging
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.ControlConfiguration2ChannelSelection Property

IRD

Adt7411ControlConfiguration2ChannelSelection Property

Control Configuration 2: Channel Selection

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeControlConfiguration2ChannelSelection ControlConfiguration2ChannelSelection { get; set; }
Public Property ControlConfiguration2ChannelSelection As Adt7411TypeControlConfiguration2ChannelSelection
    Get
    Set
public:
property Adt7411TypeControlConfiguration2ChannelSelection ControlConfiguration2ChannelSelection {
    Adt7411TypeControlConfiguration2ChannelSelection get ();
    void set (Adt7411TypeControlConfiguration2ChannelSelection value);
}
member ControlConfiguration2ChannelSelection : Adt7411TypeControlConfiguration2ChannelSelection with get, set

Property Value

Type: Adt7411TypeControlConfiguration2ChannelSelection
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.ControlConfiguration2Conversion Property

IRD

Adt7411ControlConfiguration2Conversion Property

Control Configuration 2: Conversion

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeControlConfiguration2Conversion ControlConfiguration2Conversion { get; set; }
Public Property ControlConfiguration2Conversion As Adt7411TypeControlConfiguration2Conversion
    Get
    Set
public:
property Adt7411TypeControlConfiguration2Conversion ControlConfiguration2Conversion {
    Adt7411TypeControlConfiguration2Conversion get ();
    void set (Adt7411TypeControlConfiguration2Conversion value);
}
member ControlConfiguration2Conversion : Adt7411TypeControlConfiguration2Conversion with get, set

Property Value

Type: Adt7411TypeControlConfiguration2Conversion
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.ControlConfiguration2SMBusTimeout Property

IRD

Adt7411ControlConfiguration2SMBusTimeout Property

Control Configuration 2: SMBus Timeout

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeControlConfiguration2Timeout ControlConfiguration2SMBusTimeout { get; set; }
Public Property ControlConfiguration2SMBusTimeout As Adt7411TypeControlConfiguration2Timeout
    Get
    Set
public:
property Adt7411TypeControlConfiguration2Timeout ControlConfiguration2SMBusTimeout {
    Adt7411TypeControlConfiguration2Timeout get ();
    void set (Adt7411TypeControlConfiguration2Timeout value);
}
member ControlConfiguration2SMBusTimeout : Adt7411TypeControlConfiguration2Timeout with get, set

Property Value

Type: Adt7411TypeControlConfiguration2Timeout
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.ControlConfiguration2SoftwareReset Property

IRD

Adt7411ControlConfiguration2SoftwareReset Property

Control Configuration 2: Software Reset

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeControlConfiguration2SoftwareReset ControlConfiguration2SoftwareReset { get; set; }
Public Property ControlConfiguration2SoftwareReset As Adt7411TypeControlConfiguration2SoftwareReset
    Get
    Set
public:
property Adt7411TypeControlConfiguration2SoftwareReset ControlConfiguration2SoftwareReset {
    Adt7411TypeControlConfiguration2SoftwareReset get ();
    void set (Adt7411TypeControlConfiguration2SoftwareReset value);
}
member ControlConfiguration2SoftwareReset : Adt7411TypeControlConfiguration2SoftwareReset with get, set

Property Value

Type: Adt7411TypeControlConfiguration2SoftwareReset
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.ControlConfiguration3ADCReference Property

IRD

Adt7411ControlConfiguration3ADCReference Property

Control Configuration 3: ADC Reference

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeControlConfiguration3AdcReference ControlConfiguration3ADCReference { get; set; }
Public Property ControlConfiguration3ADCReference As Adt7411TypeControlConfiguration3AdcReference
    Get
    Set
public:
property Adt7411TypeControlConfiguration3AdcReference ControlConfiguration3ADCReference {
    Adt7411TypeControlConfiguration3AdcReference get ();
    void set (Adt7411TypeControlConfiguration3AdcReference value);
}
member ControlConfiguration3ADCReference : Adt7411TypeControlConfiguration3AdcReference with get, set

Property Value

Type: Adt7411TypeControlConfiguration3AdcReference
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.ControlConfiguration3Speed Property

IRD

Adt7411ControlConfiguration3Speed Property

Control Configuration 3: Speed

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeControlConfiguration3Speed ControlConfiguration3Speed { get; set; }
Public Property ControlConfiguration3Speed As Adt7411TypeControlConfiguration3Speed
    Get
    Set
public:
property Adt7411TypeControlConfiguration3Speed ControlConfiguration3Speed {
    Adt7411TypeControlConfiguration3Speed get ();
    void set (Adt7411TypeControlConfiguration3Speed value);
}
member ControlConfiguration3Speed : Adt7411TypeControlConfiguration3Speed with get, set

Property Value

Type: Adt7411TypeControlConfiguration3Speed
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.DeviceID Property

IRD

Adt7411DeviceID Property

Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.ExternalTemperatureAIN1 Property

IRD

Adt7411ExternalTemperatureAIN1 Property

External Temperature / AIN1 (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ExternalTemperatureAIN1 { get; }
Public ReadOnly Property ExternalTemperatureAIN1 As Double
    Get
public:
property double ExternalTemperatureAIN1 {
    double get ();
}
member ExternalTemperatureAIN1 : float with get

Property Value

Type: Double
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.ExternalTemperatureOffset Property

IRD

Adt7411ExternalTemperatureOffset Property

External Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperatureOffset { get; set; }
Public Property ExternalTemperatureOffset As SByte
    Get
    Set
public:
property signed char ExternalTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member ExternalTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.ExternalTHIGHAIN1VHIGHLimits Property

IRD

Adt7411ExternalTHIGHAIN1VHIGHLimits Property

External T_HIGH/AIN1 V_HIGH Limits (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTHIGHAIN1VHIGHLimits { get; set; }
Public Property ExternalTHIGHAIN1VHIGHLimits As SByte
    Get
    Set
public:
property signed char ExternalTHIGHAIN1VHIGHLimits {
    signed char get ();
    void set (signed char value);
}
member ExternalTHIGHAIN1VHIGHLimits : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.ExternalTLOWAIN1VLOWLimits Property

IRD

Adt7411ExternalTLOWAIN1VLOWLimits Property

External T_LOW/AIN1 V_LOW Limits (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTLOWAIN1VLOWLimits { get; set; }
Public Property ExternalTLOWAIN1VLOWLimits As SByte
    Get
    Set
public:
property signed char ExternalTLOWAIN1VLOWLimits {
    signed char get ();
    void set (signed char value);
}
member ExternalTLOWAIN1VLOWLimits : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InternalTemperature Property

IRD

Adt7411InternalTemperature Property

Internal Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double InternalTemperature { get; }
Public ReadOnly Property InternalTemperature As Double
    Get
public:
property double InternalTemperature {
    double get ();
}
member InternalTemperature : float with get

Property Value

Type: Double
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InternalTemperatureOffset Property

IRD

Adt7411InternalTemperatureOffset Property

Internal Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureOffset { get; set; }
Public Property InternalTemperatureOffset As SByte
    Get
    Set
public:
property signed char InternalTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member InternalTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InternalTHIGHLimit Property

IRD

Adt7411InternalTHIGHLimit Property

Internal T_HIGH Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTHIGHLimit { get; set; }
Public Property InternalTHIGHLimit As SByte
    Get
    Set
public:
property signed char InternalTHIGHLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTHIGHLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InternalTLOWLimit Property

IRD

Adt7411InternalTLOWLimit Property

Internal T_LOW Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTLOWLimit { get; set; }
Public Property InternalTLOWLimit As SByte
    Get
    Set
public:
property signed char InternalTLOWLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTLOWLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptMask1AIN2 Property

IRD

Adt7411InterruptMask1AIN2 Property

Interrupt Mask 1: AIN2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptMaskEnableDisable InterruptMask1AIN2 { get; set; }
Public Property InterruptMask1AIN2 As Adt7411TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7411TypeInterruptMaskEnableDisable InterruptMask1AIN2 {
    Adt7411TypeInterruptMaskEnableDisable get ();
    void set (Adt7411TypeInterruptMaskEnableDisable value);
}
member InterruptMask1AIN2 : Adt7411TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7411TypeInterruptMaskEnableDisable
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptMask1AIN3 Property

IRD

Adt7411InterruptMask1AIN3 Property

Interrupt Mask 1: AIN3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptMaskEnableDisable InterruptMask1AIN3 { get; set; }
Public Property InterruptMask1AIN3 As Adt7411TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7411TypeInterruptMaskEnableDisable InterruptMask1AIN3 {
    Adt7411TypeInterruptMaskEnableDisable get ();
    void set (Adt7411TypeInterruptMaskEnableDisable value);
}
member InterruptMask1AIN3 : Adt7411TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7411TypeInterruptMaskEnableDisable
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptMask1AIN4 Property

IRD

Adt7411InterruptMask1AIN4 Property

Interrupt Mask 1: AIN4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptMaskEnableDisable InterruptMask1AIN4 { get; set; }
Public Property InterruptMask1AIN4 As Adt7411TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7411TypeInterruptMaskEnableDisable InterruptMask1AIN4 {
    Adt7411TypeInterruptMaskEnableDisable get ();
    void set (Adt7411TypeInterruptMaskEnableDisable value);
}
member InterruptMask1AIN4 : Adt7411TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7411TypeInterruptMaskEnableDisable
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptMask1ExternalTemperatureFault Property

IRD

Adt7411InterruptMask1ExternalTemperatureFault Property

Interrupt Mask 1: External Temperature Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptMaskEnableDisable InterruptMask1ExternalTemperatureFault { get; set; }
Public Property InterruptMask1ExternalTemperatureFault As Adt7411TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7411TypeInterruptMaskEnableDisable InterruptMask1ExternalTemperatureFault {
    Adt7411TypeInterruptMaskEnableDisable get ();
    void set (Adt7411TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTemperatureFault : Adt7411TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7411TypeInterruptMaskEnableDisable
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptMask1ExternalTHIGHAIN1 Property

IRD

Adt7411InterruptMask1ExternalTHIGHAIN1 Property

Interrupt Mask 1: External T_HIGH / AIN1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptMaskEnableDisable InterruptMask1ExternalTHIGHAIN1 { get; set; }
Public Property InterruptMask1ExternalTHIGHAIN1 As Adt7411TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7411TypeInterruptMaskEnableDisable InterruptMask1ExternalTHIGHAIN1 {
    Adt7411TypeInterruptMaskEnableDisable get ();
    void set (Adt7411TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTHIGHAIN1 : Adt7411TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7411TypeInterruptMaskEnableDisable
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptMask1ExternalTLOW Property

IRD

Adt7411InterruptMask1ExternalTLOW Property

Interrupt Mask 1: External T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptMaskEnableDisable InterruptMask1ExternalTLOW { get; set; }
Public Property InterruptMask1ExternalTLOW As Adt7411TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7411TypeInterruptMaskEnableDisable InterruptMask1ExternalTLOW {
    Adt7411TypeInterruptMaskEnableDisable get ();
    void set (Adt7411TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTLOW : Adt7411TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7411TypeInterruptMaskEnableDisable
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptMask1InternalTHIGH Property

IRD

Adt7411InterruptMask1InternalTHIGH Property

Interrupt Mask 1: Internal T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptMaskEnableDisable InterruptMask1InternalTHIGH { get; set; }
Public Property InterruptMask1InternalTHIGH As Adt7411TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7411TypeInterruptMaskEnableDisable InterruptMask1InternalTHIGH {
    Adt7411TypeInterruptMaskEnableDisable get ();
    void set (Adt7411TypeInterruptMaskEnableDisable value);
}
member InterruptMask1InternalTHIGH : Adt7411TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7411TypeInterruptMaskEnableDisable
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptMask1InternalTLOW Property

IRD

Adt7411InterruptMask1InternalTLOW Property

Interrupt Mask 1: Internal T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptMaskEnableDisable InterruptMask1InternalTLOW { get; set; }
Public Property InterruptMask1InternalTLOW As Adt7411TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7411TypeInterruptMaskEnableDisable InterruptMask1InternalTLOW {
    Adt7411TypeInterruptMaskEnableDisable get ();
    void set (Adt7411TypeInterruptMaskEnableDisable value);
}
member InterruptMask1InternalTLOW : Adt7411TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7411TypeInterruptMaskEnableDisable
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptMask2AIN5 Property

IRD

Adt7411InterruptMask2AIN5 Property

Interrupt Mask 2: AIN5

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptMaskEnableDisable InterruptMask2AIN5 { get; set; }
Public Property InterruptMask2AIN5 As Adt7411TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7411TypeInterruptMaskEnableDisable InterruptMask2AIN5 {
    Adt7411TypeInterruptMaskEnableDisable get ();
    void set (Adt7411TypeInterruptMaskEnableDisable value);
}
member InterruptMask2AIN5 : Adt7411TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7411TypeInterruptMaskEnableDisable
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptMask2AIN6 Property

IRD

Adt7411InterruptMask2AIN6 Property

Interrupt Mask 2: AIN6

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptMaskEnableDisable InterruptMask2AIN6 { get; set; }
Public Property InterruptMask2AIN6 As Adt7411TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7411TypeInterruptMaskEnableDisable InterruptMask2AIN6 {
    Adt7411TypeInterruptMaskEnableDisable get ();
    void set (Adt7411TypeInterruptMaskEnableDisable value);
}
member InterruptMask2AIN6 : Adt7411TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7411TypeInterruptMaskEnableDisable
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptMask2AIN7 Property

IRD

Adt7411InterruptMask2AIN7 Property

Interrupt Mask 2: AIN7

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptMaskEnableDisable InterruptMask2AIN7 { get; set; }
Public Property InterruptMask2AIN7 As Adt7411TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7411TypeInterruptMaskEnableDisable InterruptMask2AIN7 {
    Adt7411TypeInterruptMaskEnableDisable get ();
    void set (Adt7411TypeInterruptMaskEnableDisable value);
}
member InterruptMask2AIN7 : Adt7411TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7411TypeInterruptMaskEnableDisable
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptMask2AIN8 Property

IRD

Adt7411InterruptMask2AIN8 Property

Interrupt Mask 2: AIN8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptMaskEnableDisable InterruptMask2AIN8 { get; set; }
Public Property InterruptMask2AIN8 As Adt7411TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7411TypeInterruptMaskEnableDisable InterruptMask2AIN8 {
    Adt7411TypeInterruptMaskEnableDisable get ();
    void set (Adt7411TypeInterruptMaskEnableDisable value);
}
member InterruptMask2AIN8 : Adt7411TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7411TypeInterruptMaskEnableDisable
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptMask2VDD Property

IRD

Adt7411InterruptMask2VDD Property

Interrupt Mask 2: V_DD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptMaskEnableDisable InterruptMask2VDD { get; set; }
Public Property InterruptMask2VDD As Adt7411TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7411TypeInterruptMaskEnableDisable InterruptMask2VDD {
    Adt7411TypeInterruptMaskEnableDisable get ();
    void set (Adt7411TypeInterruptMaskEnableDisable value);
}
member InterruptMask2VDD : Adt7411TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7411TypeInterruptMaskEnableDisable
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptStatus1AIN2VHIGHAIN2VLOW Property

IRD

Adt7411InterruptStatus1AIN2VHIGHAIN2VLOW Property

Interrupt Status 1: AIN2 > V_HIGH / AIN2 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptStatus InterruptStatus1AIN2VHIGHAIN2VLOW { get; }
Public ReadOnly Property InterruptStatus1AIN2VHIGHAIN2VLOW As Adt7411TypeInterruptStatus
    Get
public:
property Adt7411TypeInterruptStatus InterruptStatus1AIN2VHIGHAIN2VLOW {
    Adt7411TypeInterruptStatus get ();
}
member InterruptStatus1AIN2VHIGHAIN2VLOW : Adt7411TypeInterruptStatus with get

Property Value

Type: Adt7411TypeInterruptStatus
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptStatus1AIN3VHIGHAIN3VLOW Property

IRD

Adt7411InterruptStatus1AIN3VHIGHAIN3VLOW Property

Interrupt Status 1: AIN3 > V_HIGH / AIN3 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptStatus InterruptStatus1AIN3VHIGHAIN3VLOW { get; }
Public ReadOnly Property InterruptStatus1AIN3VHIGHAIN3VLOW As Adt7411TypeInterruptStatus
    Get
public:
property Adt7411TypeInterruptStatus InterruptStatus1AIN3VHIGHAIN3VLOW {
    Adt7411TypeInterruptStatus get ();
}
member InterruptStatus1AIN3VHIGHAIN3VLOW : Adt7411TypeInterruptStatus with get

Property Value

Type: Adt7411TypeInterruptStatus
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptStatus1AIN4VHIGHAIN4VLOW Property

IRD

Adt7411InterruptStatus1AIN4VHIGHAIN4VLOW Property

Interrupt Status 1: AIN4 > V_HIGH / AIN4 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptStatus InterruptStatus1AIN4VHIGHAIN4VLOW { get; }
Public ReadOnly Property InterruptStatus1AIN4VHIGHAIN4VLOW As Adt7411TypeInterruptStatus
    Get
public:
property Adt7411TypeInterruptStatus InterruptStatus1AIN4VHIGHAIN4VLOW {
    Adt7411TypeInterruptStatus get ();
}
member InterruptStatus1AIN4VHIGHAIN4VLOW : Adt7411TypeInterruptStatus with get

Property Value

Type: Adt7411TypeInterruptStatus
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptStatus1ExternalSensorFault Property

IRD

Adt7411InterruptStatus1ExternalSensorFault Property

Interrupt Status 1: External Sensor Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptStatus InterruptStatus1ExternalSensorFault { get; }
Public ReadOnly Property InterruptStatus1ExternalSensorFault As Adt7411TypeInterruptStatus
    Get
public:
property Adt7411TypeInterruptStatus InterruptStatus1ExternalSensorFault {
    Adt7411TypeInterruptStatus get ();
}
member InterruptStatus1ExternalSensorFault : Adt7411TypeInterruptStatus with get

Property Value

Type: Adt7411TypeInterruptStatus
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW Property

IRD

Adt7411InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW Property

Interrupt Status 1: T_EXT > T_HIGH / AIN1 > V_HIGH / AIN1 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptStatus InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW { get; }
Public ReadOnly Property InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW As Adt7411TypeInterruptStatus
    Get
public:
property Adt7411TypeInterruptStatus InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW {
    Adt7411TypeInterruptStatus get ();
}
member InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW : Adt7411TypeInterruptStatus with get

Property Value

Type: Adt7411TypeInterruptStatus
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptStatus1TEXTTLOW Property

IRD

Adt7411InterruptStatus1TEXTTLOW Property

Interrupt Status 1: T_EXT <= T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptStatus InterruptStatus1TEXTTLOW { get; }
Public ReadOnly Property InterruptStatus1TEXTTLOW As Adt7411TypeInterruptStatus
    Get
public:
property Adt7411TypeInterruptStatus InterruptStatus1TEXTTLOW {
    Adt7411TypeInterruptStatus get ();
}
member InterruptStatus1TEXTTLOW : Adt7411TypeInterruptStatus with get

Property Value

Type: Adt7411TypeInterruptStatus
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptStatus1TINTTHIGH Property

IRD

Adt7411InterruptStatus1TINTTHIGH Property

Interrupt Status 1: T_INT > T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptStatus InterruptStatus1TINTTHIGH { get; }
Public ReadOnly Property InterruptStatus1TINTTHIGH As Adt7411TypeInterruptStatus
    Get
public:
property Adt7411TypeInterruptStatus InterruptStatus1TINTTHIGH {
    Adt7411TypeInterruptStatus get ();
}
member InterruptStatus1TINTTHIGH : Adt7411TypeInterruptStatus with get

Property Value

Type: Adt7411TypeInterruptStatus
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptStatus1TINTTLOW Property

IRD

Adt7411InterruptStatus1TINTTLOW Property

Interrupt Status 1: T_INT <= T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptStatus InterruptStatus1TINTTLOW { get; }
Public ReadOnly Property InterruptStatus1TINTTLOW As Adt7411TypeInterruptStatus
    Get
public:
property Adt7411TypeInterruptStatus InterruptStatus1TINTTLOW {
    Adt7411TypeInterruptStatus get ();
}
member InterruptStatus1TINTTLOW : Adt7411TypeInterruptStatus with get

Property Value

Type: Adt7411TypeInterruptStatus
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptStatus2AIN5VHIGHAIN5VLOW Property

IRD

Adt7411InterruptStatus2AIN5VHIGHAIN5VLOW Property

Interrupt Status 2: AIN5 > V_HIGH / AIN5 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptStatus InterruptStatus2AIN5VHIGHAIN5VLOW { get; }
Public ReadOnly Property InterruptStatus2AIN5VHIGHAIN5VLOW As Adt7411TypeInterruptStatus
    Get
public:
property Adt7411TypeInterruptStatus InterruptStatus2AIN5VHIGHAIN5VLOW {
    Adt7411TypeInterruptStatus get ();
}
member InterruptStatus2AIN5VHIGHAIN5VLOW : Adt7411TypeInterruptStatus with get

Property Value

Type: Adt7411TypeInterruptStatus
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptStatus2AIN6VHIGHAIN6VLOW Property

IRD

Adt7411InterruptStatus2AIN6VHIGHAIN6VLOW Property

Interrupt Status 2: AIN6 > V_HIGH / AIN6 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptStatus InterruptStatus2AIN6VHIGHAIN6VLOW { get; }
Public ReadOnly Property InterruptStatus2AIN6VHIGHAIN6VLOW As Adt7411TypeInterruptStatus
    Get
public:
property Adt7411TypeInterruptStatus InterruptStatus2AIN6VHIGHAIN6VLOW {
    Adt7411TypeInterruptStatus get ();
}
member InterruptStatus2AIN6VHIGHAIN6VLOW : Adt7411TypeInterruptStatus with get

Property Value

Type: Adt7411TypeInterruptStatus
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptStatus2AIN7VHIGHAIN7VLOW Property

IRD

Adt7411InterruptStatus2AIN7VHIGHAIN7VLOW Property

Interrupt Status 2: AIN7 > V_HIGH / AIN7 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptStatus InterruptStatus2AIN7VHIGHAIN7VLOW { get; }
Public ReadOnly Property InterruptStatus2AIN7VHIGHAIN7VLOW As Adt7411TypeInterruptStatus
    Get
public:
property Adt7411TypeInterruptStatus InterruptStatus2AIN7VHIGHAIN7VLOW {
    Adt7411TypeInterruptStatus get ();
}
member InterruptStatus2AIN7VHIGHAIN7VLOW : Adt7411TypeInterruptStatus with get

Property Value

Type: Adt7411TypeInterruptStatus
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptStatus2AIN8VHIGHAIN8VLOW Property

IRD

Adt7411InterruptStatus2AIN8VHIGHAIN8VLOW Property

Interrupt Status 2: AIN8 > V_HIGH / AIN8 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptStatus InterruptStatus2AIN8VHIGHAIN8VLOW { get; }
Public ReadOnly Property InterruptStatus2AIN8VHIGHAIN8VLOW As Adt7411TypeInterruptStatus
    Get
public:
property Adt7411TypeInterruptStatus InterruptStatus2AIN8VHIGHAIN8VLOW {
    Adt7411TypeInterruptStatus get ();
}
member InterruptStatus2AIN8VHIGHAIN8VLOW : Adt7411TypeInterruptStatus with get

Property Value

Type: Adt7411TypeInterruptStatus
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.InterruptStatus2VDDVHIGHVDDVLOW Property

IRD

Adt7411InterruptStatus2VDDVHIGHVDDVLOW Property

Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeInterruptStatus InterruptStatus2VDDVHIGHVDDVLOW { get; }
Public ReadOnly Property InterruptStatus2VDDVHIGHVDDVLOW As Adt7411TypeInterruptStatus
    Get
public:
property Adt7411TypeInterruptStatus InterruptStatus2VDDVHIGHVDDVLOW {
    Adt7411TypeInterruptStatus get ();
}
member InterruptStatus2VDDVHIGHVDDVLOW : Adt7411TypeInterruptStatus with get

Property Value

Type: Adt7411TypeInterruptStatus
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.ManufacturerSID Property

IRD

Adt7411ManufacturerSID Property

Manufacturer's ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerSID { get; }
Public ReadOnly Property ManufacturerSID As Byte
    Get
public:
property unsigned char ManufacturerSID {
    unsigned char get ();
}
member ManufacturerSID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.SiliconRevisionStepping Property

IRD

Adt7411SiliconRevisionStepping Property

Silicon Revision: Stepping

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SiliconRevisionStepping { get; }
Public ReadOnly Property SiliconRevisionStepping As Byte
    Get
public:
property unsigned char SiliconRevisionStepping {
    unsigned char get ();
}
member SiliconRevisionStepping : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.SiliconRevisionVersion Property

IRD

Adt7411SiliconRevisionVersion Property

Silicon Revision: Version

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SiliconRevisionVersion { get; }
Public ReadOnly Property SiliconRevisionVersion As Byte
    Get
public:
property unsigned char SiliconRevisionVersion {
    unsigned char get ();
}
member SiliconRevisionVersion : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.SPILockStatus Property

IRD

Adt7411SPILockStatus Property

SPI Lock Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7411TypeSpiLockStatus SPILockStatus { get; }
Public ReadOnly Property SPILockStatus As Adt7411TypeSpiLockStatus
    Get
public:
property Adt7411TypeSpiLockStatus SPILockStatus {
    Adt7411TypeSpiLockStatus get ();
}
member SPILockStatus : Adt7411TypeSpiLockStatus with get

Property Value

Type: Adt7411TypeSpiLockStatus
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.VDD Property

IRD

Adt7411VDD Property

V_DD (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDD { get; }
Public ReadOnly Property VDD As Double
    Get
public:
property double VDD {
    double get ();
}
member VDD : float with get

Property Value

Type: Double
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.VDDVHIGHLimit Property

IRD

Adt7411VDDVHIGHLimit Property

V_DD V_HIGH Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDDVHIGHLimit { get; set; }
Public Property VDDVHIGHLimit As Double
    Get
    Set
public:
property double VDDVHIGHLimit {
    double get ();
    void set (double value);
}
member VDDVHIGHLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.VDDVLOWLimit Property

IRD

Adt7411VDDVLOWLimit Property

V_DD V_LOW Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDDVLOWLimit { get; set; }
Public Property VDDVLOWLimit As Double
    Get
    Set
public:
property double VDDVLOWLimit {
    double get ();
    void set (double value);
}
member VDDVLOWLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411 Methods

The Adt7411 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.Flush Method

IRD

Adt7411Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adt7411 Class
telos.Ird.AnalogDevices Namespace


Adt7411.TypeControlConfiguration1AinTdmSelection Enumeration

IRD

Adt7411TypeControlConfiguration1AinTdmSelection Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1AinTdmSelection
Public Enumeration TypeControlConfiguration1AinTdmSelection
public enum class TypeControlConfiguration1AinTdmSelection
type TypeControlConfiguration1AinTdmSelection
Members
Member name | Value | Description
AIN1AndAIN2 | 0 | AIN1 and AIN2
Reserved | 1 | Reserved
ExternalTDM | 2 | External TDM
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7411.TypeControlConfiguration1IntOutput Enumeration

IRD

Adt7411TypeControlConfiguration1IntOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1IntOutput
Public Enumeration TypeControlConfiguration1IntOutput
public enum class TypeControlConfiguration1IntOutput
type TypeControlConfiguration1IntOutput
Members
Member name | Value | Description
INTOutputEnabled | 0 | INT Output: Enabled
INTOutputDisabled | 1 | INT Output: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7411.TypeControlConfiguration1IntOutputPolarity Enumeration

IRD

Adt7411TypeControlConfiguration1IntOutputPolarity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1IntOutputPolarity
Public Enumeration TypeControlConfiguration1IntOutputPolarity
public enum class TypeControlConfiguration1IntOutputPolarity
type TypeControlConfiguration1IntOutputPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7411.TypeControlConfiguration1Monitoring Enumeration

IRD

Adt7411TypeControlConfiguration1Monitoring Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1Monitoring
Public Enumeration TypeControlConfiguration1Monitoring
public enum class TypeControlConfiguration1Monitoring
type TypeControlConfiguration1Monitoring
Members
Member name | Value | Description
StopMonitoring | 0 | Stop Monitoring
StartMonitoring | 1 | Start Monitoring
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7411.TypeControlConfiguration1PowerDown Enumeration

IRD

Adt7411TypeControlConfiguration1PowerDown Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1PowerDown
Public Enumeration TypeControlConfiguration1PowerDown
public enum class TypeControlConfiguration1PowerDown
type TypeControlConfiguration1PowerDown
Members
Member name | Value | Description
PowerUp | 0 | Power Up
PowerDown | 1 | Power Down
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7411.TypeControlConfiguration2Averaging Enumeration

IRD

Adt7411TypeControlConfiguration2Averaging Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Averaging
Public Enumeration TypeControlConfiguration2Averaging
public enum class TypeControlConfiguration2Averaging
type TypeControlConfiguration2Averaging
Members
Member name | Value | Description
AveragingEnabled | 0 | Averaging Enabled
AveragingDisabled | 1 | Averaging Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7411.TypeControlConfiguration2ChannelSelection Enumeration

IRD

Adt7411TypeControlConfiguration2ChannelSelection Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2ChannelSelection
Public Enumeration TypeControlConfiguration2ChannelSelection
public enum class TypeControlConfiguration2ChannelSelection
type TypeControlConfiguration2ChannelSelection
Members
Member name | Value | Description
VDD | 0 | V_DD
InternalTemperatureSensor | 1 | Internal Temperature Sensor
ExternalTemperatureSensorAIN1 | 2 | External Temperature Sensor / AIN1
AIN2 | 3 | AIN2
AIN3 | 4 | AIN3
AIN4 | 5 | AIN4
AIN5 | 6 | AIN5
AIN6 | 7 | AIN6
AIN7 | 8 | AIN7
AIN8 | 9 | AIN8
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7411.TypeControlConfiguration2Conversion Enumeration

IRD

Adt7411TypeControlConfiguration2Conversion Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Conversion
Public Enumeration TypeControlConfiguration2Conversion
public enum class TypeControlConfiguration2Conversion
type TypeControlConfiguration2Conversion
Members
Member name | Value | Description
RoundRobin | 0 | Round Robin
SingleChannel | 1 | Single Channel
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7411.TypeControlConfiguration2SoftwareReset Enumeration

IRD

Adt7411TypeControlConfiguration2SoftwareReset Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2SoftwareReset
Public Enumeration TypeControlConfiguration2SoftwareReset
public enum class TypeControlConfiguration2SoftwareReset
type TypeControlConfiguration2SoftwareReset
Members
Member name | Value | Description
Default | 0 | Default
SoftwareReset | 1 | Software Reset
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7411.TypeControlConfiguration2Timeout Enumeration

IRD

Adt7411TypeControlConfiguration2Timeout Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Timeout
Public Enumeration TypeControlConfiguration2Timeout
public enum class TypeControlConfiguration2Timeout
type TypeControlConfiguration2Timeout
Members
Member name | Value | Description
SMBusTimeoutDisabled | 0 | SMBus Timeout: Disabled
SMBusTimeoutEnabled | 1 | SMBus Timeout: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7411.TypeControlConfiguration3AdcReference Enumeration

IRD

Adt7411TypeControlConfiguration3AdcReference Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3AdcReference
Public Enumeration TypeControlConfiguration3AdcReference
public enum class TypeControlConfiguration3AdcReference
type TypeControlConfiguration3AdcReference
Members
Member name | Value | Description
IntVREF | 0 | Int V_REF
VDD | 1 | V_DD
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7411.TypeControlConfiguration3Speed Enumeration

IRD

Adt7411TypeControlConfiguration3Speed Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3Speed
Public Enumeration TypeControlConfiguration3Speed
public enum class TypeControlConfiguration3Speed
type TypeControlConfiguration3Speed
Members
Member name | Value | Description
Value_14KHz | 0 | 1.4 kHz
Value_225KHz | 1 | 22.5 kHz
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7411.TypeInterruptMaskEnableDisable Enumeration

IRD

Adt7411TypeInterruptMaskEnableDisable Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptMaskEnableDisable
Public Enumeration TypeInterruptMaskEnableDisable
public enum class TypeInterruptMaskEnableDisable
type TypeInterruptMaskEnableDisable
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7411.TypeInterruptStatus Enumeration

IRD

Adt7411TypeInterruptStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatus
Public Enumeration TypeInterruptStatus
public enum class TypeInterruptStatus
type TypeInterruptStatus
Members
Member name | Value | Description
NotSet | 0 | Not Set
Set | 1 | Set
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7411.TypeSpiLockStatus Enumeration

IRD

Adt7411TypeSpiLockStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSpiLockStatus
Public Enumeration TypeSpiLockStatus
public enum class TypeSpiLockStatus
type TypeSpiLockStatus
Members
Member name | Value | Description
I2CInterface | 0 | I2C Interface
SPIInterfaceLocked | 1 | SPI Interface / Locked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7420 Class

Analog Devices: ADT 7420
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdt7420

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adt7420
Public Class Adt7420
public ref class Adt7420
type Adt7420 =  class end

The Adt7420 type exposes the following members.

Constructors
 | Name | Description
Public method | Adt7420 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationCTPinPolarity | Configuration: CT Pin Polarity
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationINTCTMode | Configuration: INT/CT Mode
Public property | ConfigurationINTPinPolarity | Configuration: INT Pin Polarity
Public property | ConfigurationOperationMode | Configuration: Operation Mode
Public property | ConfigurationResolution | Configuration: Resolution
Public property | IDManufacturerID | ID: Manufacturer ID
Public property | IDRevisionID | ID: Revision ID
Public property | StatusRDY | Status: RDY
Public property | StatusTCRIT | Status: T_CRIT
Public property | StatusTHIGH | Status: T_HIGH
Public property | StatusTLOW | Status: T_LOW
Public property | TCRITSetpoint | T_CRIT Setpoint (unit: °C)
Public property | Temperature | Temperature (unit: °C)
Public property | TemperatureTCRITFlag | Temperature: T_CRIT Flag
Public property | TemperatureTHIGHFlag | Temperature: T_HIGH Flag
Public property | TemperatureTLOWFlag | Temperature: T_LOW Flag
Public property | THIGHSetpoint | T_HIGH Setpoint (unit: °C)
Public property | THYSTSetpoint | T_HYST Setpoint (unit: °C)
Public property | TLOWSetpoint | T_LOW Setpoint (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Reset
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
±0.25°C Accurate, 16-Bit Digital Temperature Sensor
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7420 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7420(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adt7420(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adt7420

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420 Properties

The Adt7420 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationCTPinPolarity | Configuration: CT Pin Polarity
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationINTCTMode | Configuration: INT/CT Mode
Public property | ConfigurationINTPinPolarity | Configuration: INT Pin Polarity
Public property | ConfigurationOperationMode | Configuration: Operation Mode
Public property | ConfigurationResolution | Configuration: Resolution
Public property | IDManufacturerID | ID: Manufacturer ID
Public property | IDRevisionID | ID: Revision ID
Public property | StatusRDY | Status: RDY
Public property | StatusTCRIT | Status: T_CRIT
Public property | StatusTHIGH | Status: T_HIGH
Public property | StatusTLOW | Status: T_LOW
Public property | TCRITSetpoint | T_CRIT Setpoint (unit: °C)
Public property | Temperature | Temperature (unit: °C)
Public property | TemperatureTCRITFlag | Temperature: T_CRIT Flag
Public property | TemperatureTHIGHFlag | Temperature: T_HIGH Flag
Public property | TemperatureTLOWFlag | Temperature: T_LOW Flag
Public property | THIGHSetpoint | T_HIGH Setpoint (unit: °C)
Public property | THYSTSetpoint | T_HYST Setpoint (unit: °C)
Public property | TLOWSetpoint | T_LOW Setpoint (unit: °C)
Top
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.AutoFlush Property

IRD

Adt7420AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.ConfigurationCTPinPolarity Property

IRD

Adt7420ConfigurationCTPinPolarity Property

Configuration: CT Pin Polarity

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7420TypeConfigurationIntCtPinPolarity ConfigurationCTPinPolarity { get; set; }
Public Property ConfigurationCTPinPolarity As Adt7420TypeConfigurationIntCtPinPolarity
    Get
    Set
public:
property Adt7420TypeConfigurationIntCtPinPolarity ConfigurationCTPinPolarity {
    Adt7420TypeConfigurationIntCtPinPolarity get ();
    void set (Adt7420TypeConfigurationIntCtPinPolarity value);
}
member ConfigurationCTPinPolarity : Adt7420TypeConfigurationIntCtPinPolarity with get, set

Property Value

Type: Adt7420TypeConfigurationIntCtPinPolarity
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.ConfigurationFaultQueue Property

IRD

Adt7420ConfigurationFaultQueue Property

Configuration: Fault Queue

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ConfigurationFaultQueue { get; set; }
Public Property ConfigurationFaultQueue As Byte
    Get
    Set
public:
property unsigned char ConfigurationFaultQueue {
    unsigned char get ();
    void set (unsigned char value);
}
member ConfigurationFaultQueue : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.ConfigurationINTCTMode Property

IRD

Adt7420ConfigurationINTCTMode Property

Configuration: INT/CT Mode

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7420TypeConfigurationIntCtMode ConfigurationINTCTMode { get; set; }
Public Property ConfigurationINTCTMode As Adt7420TypeConfigurationIntCtMode
    Get
    Set
public:
property Adt7420TypeConfigurationIntCtMode ConfigurationINTCTMode {
    Adt7420TypeConfigurationIntCtMode get ();
    void set (Adt7420TypeConfigurationIntCtMode value);
}
member ConfigurationINTCTMode : Adt7420TypeConfigurationIntCtMode with get, set

Property Value

Type: Adt7420TypeConfigurationIntCtMode
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.ConfigurationINTPinPolarity Property

IRD

Adt7420ConfigurationINTPinPolarity Property

Configuration: INT Pin Polarity

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7420TypeConfigurationIntCtPinPolarity ConfigurationINTPinPolarity { get; set; }
Public Property ConfigurationINTPinPolarity As Adt7420TypeConfigurationIntCtPinPolarity
    Get
    Set
public:
property Adt7420TypeConfigurationIntCtPinPolarity ConfigurationINTPinPolarity {
    Adt7420TypeConfigurationIntCtPinPolarity get ();
    void set (Adt7420TypeConfigurationIntCtPinPolarity value);
}
member ConfigurationINTPinPolarity : Adt7420TypeConfigurationIntCtPinPolarity with get, set

Property Value

Type: Adt7420TypeConfigurationIntCtPinPolarity
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.ConfigurationOperationMode Property

IRD

Adt7420ConfigurationOperationMode Property

Configuration: Operation Mode

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7420TypeConfigurationOperationMode ConfigurationOperationMode { get; set; }
Public Property ConfigurationOperationMode As Adt7420TypeConfigurationOperationMode
    Get
    Set
public:
property Adt7420TypeConfigurationOperationMode ConfigurationOperationMode {
    Adt7420TypeConfigurationOperationMode get ();
    void set (Adt7420TypeConfigurationOperationMode value);
}
member ConfigurationOperationMode : Adt7420TypeConfigurationOperationMode with get, set

Property Value

Type: Adt7420TypeConfigurationOperationMode
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.ConfigurationResolution Property

IRD

Adt7420ConfigurationResolution Property

Configuration: Resolution

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7420TypeConfigurationResolution ConfigurationResolution { get; set; }
Public Property ConfigurationResolution As Adt7420TypeConfigurationResolution
    Get
    Set
public:
property Adt7420TypeConfigurationResolution ConfigurationResolution {
    Adt7420TypeConfigurationResolution get ();
    void set (Adt7420TypeConfigurationResolution value);
}
member ConfigurationResolution : Adt7420TypeConfigurationResolution with get, set

Property Value

Type: Adt7420TypeConfigurationResolution
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.IDManufacturerID Property

IRD

Adt7420IDManufacturerID Property

ID: Manufacturer ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IDManufacturerID { get; }
Public ReadOnly Property IDManufacturerID As Byte
    Get
public:
property unsigned char IDManufacturerID {
    unsigned char get ();
}
member IDManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.IDRevisionID Property

IRD

Adt7420IDRevisionID Property

ID: Revision ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IDRevisionID { get; }
Public ReadOnly Property IDRevisionID As Byte
    Get
public:
property unsigned char IDRevisionID {
    unsigned char get ();
}
member IDRevisionID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.StatusRDY Property

IRD

Adt7420StatusRDY Property

Status: RDY

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7420TypeStatus StatusRDY { get; }
Public ReadOnly Property StatusRDY As Adt7420TypeStatus
    Get
public:
property Adt7420TypeStatus StatusRDY {
    Adt7420TypeStatus get ();
}
member StatusRDY : Adt7420TypeStatus with get

Property Value

Type: Adt7420TypeStatus
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.StatusTCRIT Property

IRD

Adt7420StatusTCRIT Property

Status: T_CRIT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7420TypeStatus StatusTCRIT { get; }
Public ReadOnly Property StatusTCRIT As Adt7420TypeStatus
    Get
public:
property Adt7420TypeStatus StatusTCRIT {
    Adt7420TypeStatus get ();
}
member StatusTCRIT : Adt7420TypeStatus with get

Property Value

Type: Adt7420TypeStatus
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.StatusTHIGH Property

IRD

Adt7420StatusTHIGH Property

Status: T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7420TypeStatus StatusTHIGH { get; }
Public ReadOnly Property StatusTHIGH As Adt7420TypeStatus
    Get
public:
property Adt7420TypeStatus StatusTHIGH {
    Adt7420TypeStatus get ();
}
member StatusTHIGH : Adt7420TypeStatus with get

Property Value

Type: Adt7420TypeStatus
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.StatusTLOW Property

IRD

Adt7420StatusTLOW Property

Status: T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7420TypeStatus StatusTLOW { get; }
Public ReadOnly Property StatusTLOW As Adt7420TypeStatus
    Get
public:
property Adt7420TypeStatus StatusTLOW {
    Adt7420TypeStatus get ();
}
member StatusTLOW : Adt7420TypeStatus with get

Property Value

Type: Adt7420TypeStatus
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.TCRITSetpoint Property

IRD

Adt7420TCRITSetpoint Property

T_CRIT Setpoint (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TCRITSetpoint { get; set; }
Public Property TCRITSetpoint As Double
    Get
    Set
public:
property double TCRITSetpoint {
    double get ();
    void set (double value);
}
member TCRITSetpoint : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.Temperature Property

IRD

Adt7420Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.TemperatureTCRITFlag Property

IRD

Adt7420TemperatureTCRITFlag Property

Temperature: T_CRIT Flag

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7420TypeTempFlag TemperatureTCRITFlag { get; }
Public ReadOnly Property TemperatureTCRITFlag As Adt7420TypeTempFlag
    Get
public:
property Adt7420TypeTempFlag TemperatureTCRITFlag {
    Adt7420TypeTempFlag get ();
}
member TemperatureTCRITFlag : Adt7420TypeTempFlag with get

Property Value

Type: Adt7420TypeTempFlag
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.TemperatureTHIGHFlag Property

IRD

Adt7420TemperatureTHIGHFlag Property

Temperature: T_HIGH Flag

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7420TypeTempFlag TemperatureTHIGHFlag { get; }
Public ReadOnly Property TemperatureTHIGHFlag As Adt7420TypeTempFlag
    Get
public:
property Adt7420TypeTempFlag TemperatureTHIGHFlag {
    Adt7420TypeTempFlag get ();
}
member TemperatureTHIGHFlag : Adt7420TypeTempFlag with get

Property Value

Type: Adt7420TypeTempFlag
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.TemperatureTLOWFlag Property

IRD

Adt7420TemperatureTLOWFlag Property

Temperature: T_LOW Flag

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7420TypeTempFlag TemperatureTLOWFlag { get; }
Public ReadOnly Property TemperatureTLOWFlag As Adt7420TypeTempFlag
    Get
public:
property Adt7420TypeTempFlag TemperatureTLOWFlag {
    Adt7420TypeTempFlag get ();
}
member TemperatureTLOWFlag : Adt7420TypeTempFlag with get

Property Value

Type: Adt7420TypeTempFlag
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.THIGHSetpoint Property

IRD

Adt7420THIGHSetpoint Property

T_HIGH Setpoint (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double THIGHSetpoint { get; set; }
Public Property THIGHSetpoint As Double
    Get
    Set
public:
property double THIGHSetpoint {
    double get ();
    void set (double value);
}
member THIGHSetpoint : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.THYSTSetpoint Property

IRD

Adt7420THYSTSetpoint Property

T_HYST Setpoint (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte THYSTSetpoint { get; set; }
Public Property THYSTSetpoint As Byte
    Get
    Set
public:
property unsigned char THYSTSetpoint {
    unsigned char get ();
    void set (unsigned char value);
}
member THYSTSetpoint : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.TLOWSetpoint Property

IRD

Adt7420TLOWSetpoint Property

T_LOW Setpoint (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TLOWSetpoint { get; set; }
Public Property TLOWSetpoint As Double
    Get
    Set
public:
property double TLOWSetpoint {
    double get ();
    void set (double value);
}
member TLOWSetpoint : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420 Methods

The Adt7420 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Reset
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.Flush Method

IRD

Adt7420Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.Reset Method

IRD

Adt7420Reset Method

Reset

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Reset()
Public Sub Reset
public:
void Reset()
member Reset : unit -> unit
See Also

Reference

Adt7420 Class
telos.Ird.AnalogDevices Namespace


Adt7420.TypeConfigurationIntCtMode Enumeration

IRD

Adt7420TypeConfigurationIntCtMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationIntCtMode
Public Enumeration TypeConfigurationIntCtMode
public enum class TypeConfigurationIntCtMode
type TypeConfigurationIntCtMode
Members
Member name | Value | Description
InterruptMode | 0 | Interrupt Mode
ComparatorMode | 1 | Comparator Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7420.TypeConfigurationIntCtPinPolarity Enumeration

IRD

Adt7420TypeConfigurationIntCtPinPolarity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationIntCtPinPolarity
Public Enumeration TypeConfigurationIntCtPinPolarity
public enum class TypeConfigurationIntCtPinPolarity
type TypeConfigurationIntCtPinPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7420.TypeConfigurationOperationMode Enumeration

IRD

Adt7420TypeConfigurationOperationMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationOperationMode
Public Enumeration TypeConfigurationOperationMode
public enum class TypeConfigurationOperationMode
type TypeConfigurationOperationMode
Members
Member name | Value | Description
ContinuousConversion | 0 | Continuous Conversion
OneShot | 1 | One Shot
Value_1SPS | 2 | 1 SPS
Shutdown | 3 | Shutdown
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7420.TypeConfigurationResolution Enumeration

IRD

Adt7420TypeConfigurationResolution Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationResolution
Public Enumeration TypeConfigurationResolution
public enum class TypeConfigurationResolution
type TypeConfigurationResolution
Members
Member name | Value | Description
Value_13Bit | 0 | 13-bit
Value_16Bit | 1 | 16-bit
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7420.TypeStatus Enumeration

IRD

Adt7420TypeStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus
Public Enumeration TypeStatus
public enum class TypeStatus
type TypeStatus
Members
Member name | Value | Description
NotSet | 0 | Not Set
Set | 1 | Set
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7420.TypeTempFlag Enumeration

IRD

Adt7420TypeTempFlag Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTempFlag
Public Enumeration TypeTempFlag
public enum class TypeTempFlag
type TypeTempFlag
Members
Member name | Value | Description
NotSet | 0 | Not Set
Set | 1 | Set
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt75 Class

Analog Devices: ADT 75
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdt75

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adt75
Public Class Adt75
public ref class Adt75
type Adt75 =  class end

The Adt75 type exposes the following members.

Constructors
 | Name | Description
Public method | Adt75 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationCmpInt | Configuration: Cmp/Int
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationOneShot | Configuration: One-Shot
Public property | ConfigurationOSALERT | Configuration: OS/ALERT
Public property | ConfigurationOSSMBusAlertMode | Configuration: OS/SMBus Alert Mode
Public property | ConfigurationShutdown | Configuration: Shutdown
Public property | TemperatureValue | Temperature Value (unit: °C)
Public property | THYSTSetpoint | T_HYST Setpoint (unit: °C)
Public property | TOSSetpoint | T_OS Setpoint (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
±1°C Accurate, 12-Bit Digital Temperature Sensor
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt75 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt75(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adt75(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adt75

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adt75 Class
telos.Ird.AnalogDevices Namespace


Adt75 Properties

The Adt75 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationCmpInt | Configuration: Cmp/Int
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationOneShot | Configuration: One-Shot
Public property | ConfigurationOSALERT | Configuration: OS/ALERT
Public property | ConfigurationOSSMBusAlertMode | Configuration: OS/SMBus Alert Mode
Public property | ConfigurationShutdown | Configuration: Shutdown
Public property | TemperatureValue | Temperature Value (unit: °C)
Public property | THYSTSetpoint | T_HYST Setpoint (unit: °C)
Public property | TOSSetpoint | T_OS Setpoint (unit: °C)
Top
See Also

Reference

Adt75 Class
telos.Ird.AnalogDevices Namespace


Adt75.AutoFlush Property

IRD

Adt75AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adt75 Class
telos.Ird.AnalogDevices Namespace


Adt75.ConfigurationCmpInt Property

IRD

Adt75ConfigurationCmpInt Property

Configuration: Cmp/Int

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt75TypeConfigurationCmpInt ConfigurationCmpInt { get; set; }
Public Property ConfigurationCmpInt As Adt75TypeConfigurationCmpInt
    Get
    Set
public:
property Adt75TypeConfigurationCmpInt ConfigurationCmpInt {
    Adt75TypeConfigurationCmpInt get ();
    void set (Adt75TypeConfigurationCmpInt value);
}
member ConfigurationCmpInt : Adt75TypeConfigurationCmpInt with get, set

Property Value

Type: Adt75TypeConfigurationCmpInt
See Also

Reference

Adt75 Class
telos.Ird.AnalogDevices Namespace


Adt75.ConfigurationFaultQueue Property

IRD

Adt75ConfigurationFaultQueue Property

Configuration: Fault Queue

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt75TypeConfigurationFaultQueue ConfigurationFaultQueue { get; set; }
Public Property ConfigurationFaultQueue As Adt75TypeConfigurationFaultQueue
    Get
    Set
public:
property Adt75TypeConfigurationFaultQueue ConfigurationFaultQueue {
    Adt75TypeConfigurationFaultQueue get ();
    void set (Adt75TypeConfigurationFaultQueue value);
}
member ConfigurationFaultQueue : Adt75TypeConfigurationFaultQueue with get, set

Property Value

Type: Adt75TypeConfigurationFaultQueue
See Also

Reference

Adt75 Class
telos.Ird.AnalogDevices Namespace


Adt75.ConfigurationOneShot Property

IRD

Adt75ConfigurationOneShot Property

Configuration: One-Shot

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt75TypeConfigurationOneShot ConfigurationOneShot { get; set; }
Public Property ConfigurationOneShot As Adt75TypeConfigurationOneShot
    Get
    Set
public:
property Adt75TypeConfigurationOneShot ConfigurationOneShot {
    Adt75TypeConfigurationOneShot get ();
    void set (Adt75TypeConfigurationOneShot value);
}
member ConfigurationOneShot : Adt75TypeConfigurationOneShot with get, set

Property Value

Type: Adt75TypeConfigurationOneShot
See Also

Reference

Adt75 Class
telos.Ird.AnalogDevices Namespace


Adt75.ConfigurationOSALERT Property

IRD

Adt75ConfigurationOSALERT Property

Configuration: OS/ALERT

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt75TypeConfigurationOsAlert ConfigurationOSALERT { get; set; }
Public Property ConfigurationOSALERT As Adt75TypeConfigurationOsAlert
    Get
    Set
public:
property Adt75TypeConfigurationOsAlert ConfigurationOSALERT {
    Adt75TypeConfigurationOsAlert get ();
    void set (Adt75TypeConfigurationOsAlert value);
}
member ConfigurationOSALERT : Adt75TypeConfigurationOsAlert with get, set

Property Value

Type: Adt75TypeConfigurationOsAlert
See Also

Reference

Adt75 Class
telos.Ird.AnalogDevices Namespace


Adt75.ConfigurationOSSMBusAlertMode Property

IRD

Adt75ConfigurationOSSMBusAlertMode Property

Configuration: OS/SMBus Alert Mode

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt75TypeConfigurationOsSmbusAlertMode ConfigurationOSSMBusAlertMode { get; set; }
Public Property ConfigurationOSSMBusAlertMode As Adt75TypeConfigurationOsSmbusAlertMode
    Get
    Set
public:
property Adt75TypeConfigurationOsSmbusAlertMode ConfigurationOSSMBusAlertMode {
    Adt75TypeConfigurationOsSmbusAlertMode get ();
    void set (Adt75TypeConfigurationOsSmbusAlertMode value);
}
member ConfigurationOSSMBusAlertMode : Adt75TypeConfigurationOsSmbusAlertMode with get, set

Property Value

Type: Adt75TypeConfigurationOsSmbusAlertMode
See Also

Reference

Adt75 Class
telos.Ird.AnalogDevices Namespace


Adt75.ConfigurationShutdown Property

IRD

Adt75ConfigurationShutdown Property

Configuration: Shutdown

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt75TypeConfigurationShutdown ConfigurationShutdown { get; set; }
Public Property ConfigurationShutdown As Adt75TypeConfigurationShutdown
    Get
    Set
public:
property Adt75TypeConfigurationShutdown ConfigurationShutdown {
    Adt75TypeConfigurationShutdown get ();
    void set (Adt75TypeConfigurationShutdown value);
}
member ConfigurationShutdown : Adt75TypeConfigurationShutdown with get, set

Property Value

Type: Adt75TypeConfigurationShutdown
See Also

Reference

Adt75 Class
telos.Ird.AnalogDevices Namespace


Adt75.TemperatureValue Property

IRD

Adt75TemperatureValue Property

Temperature Value (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TemperatureValue { get; }
Public ReadOnly Property TemperatureValue As Double
    Get
public:
property double TemperatureValue {
    double get ();
}
member TemperatureValue : float with get

Property Value

Type: Double
See Also

Reference

Adt75 Class
telos.Ird.AnalogDevices Namespace


Adt75.THYSTSetpoint Property

IRD

Adt75THYSTSetpoint Property

T_HYST Setpoint (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double THYSTSetpoint { get; set; }
Public Property THYSTSetpoint As Double
    Get
    Set
public:
property double THYSTSetpoint {
    double get ();
    void set (double value);
}
member THYSTSetpoint : float with get, set

Property Value

Type: Double
See Also

Reference

Adt75 Class
telos.Ird.AnalogDevices Namespace


Adt75.TOSSetpoint Property

IRD

Adt75TOSSetpoint Property

T_OS Setpoint (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TOSSetpoint { get; set; }
Public Property TOSSetpoint As Double
    Get
    Set
public:
property double TOSSetpoint {
    double get ();
    void set (double value);
}
member TOSSetpoint : float with get, set

Property Value

Type: Double
See Also

Reference

Adt75 Class
telos.Ird.AnalogDevices Namespace


Adt75 Methods

The Adt75 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adt75 Class
telos.Ird.AnalogDevices Namespace


Adt75.Flush Method

IRD

Adt75Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adt75 Class
telos.Ird.AnalogDevices Namespace


Adt75.OneShot Method

IRD

Adt75OneShot Method

One-Shot

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void OneShot()
Public Sub OneShot
public:
void OneShot()
member OneShot : unit -> unit
See Also

Reference

Adt75 Class
telos.Ird.AnalogDevices Namespace


Adt75.TypeConfigurationCmpInt Enumeration

IRD

Adt75TypeConfigurationCmpInt Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationCmpInt
Public Enumeration TypeConfigurationCmpInt
public enum class TypeConfigurationCmpInt
type TypeConfigurationCmpInt
Members
Member name | Value | Description
ComparatorMode | 0 | Comparator Mode
InterruptMode | 1 | Interrupt Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt75.TypeConfigurationFaultQueue Enumeration

IRD

Adt75TypeConfigurationFaultQueue Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationFaultQueue
Public Enumeration TypeConfigurationFaultQueue
public enum class TypeConfigurationFaultQueue
type TypeConfigurationFaultQueue
Members
Member name | Value | Description
Value_1Fault | 0 | 1 Fault
Value_2Faults | 1 | 2 Faults
Value_4Faults | 2 | 4 Faults
Value_6Faults | 3 | 6 Faults
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt75.TypeConfigurationOneShot Enumeration

IRD

Adt75TypeConfigurationOneShot Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationOneShot
Public Enumeration TypeConfigurationOneShot
public enum class TypeConfigurationOneShot
type TypeConfigurationOneShot
Members
Member name | Value | Description
NormalMode | 0 | Normal Mode
OneShotMode | 1 | One-Shot Mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt75.TypeConfigurationOsAlert Enumeration

IRD

Adt75TypeConfigurationOsAlert Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationOsAlert
Public Enumeration TypeConfigurationOsAlert
public enum class TypeConfigurationOsAlert
type TypeConfigurationOsAlert
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt75.TypeConfigurationOsSmbusAlertMode Enumeration

IRD

Adt75TypeConfigurationOsSmbusAlertMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationOsSmbusAlertMode
Public Enumeration TypeConfigurationOsSmbusAlertMode
public enum class TypeConfigurationOsSmbusAlertMode
type TypeConfigurationOsSmbusAlertMode
Members
Member name | Value | Description
SMBusAlertDisabled | 0 | SMBus Alert: Disabled
SMBusAlertEnabled | 1 | SMBus Alert: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt75.TypeConfigurationShutdown Enumeration

IRD

Adt75TypeConfigurationShutdown Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationShutdown
Public Enumeration TypeConfigurationShutdown
public enum class TypeConfigurationShutdown
type TypeConfigurationShutdown
Members
Member name | Value | Description
Default | 0 | Default
Shutdown | 1 | Shutdown
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516 Class

Analog Devices: ADT 7516
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdt7516

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adt7516
Public Class Adt7516
public ref class Adt7516
type Adt7516 =  class end

The Adt7516 type exposes the following members.

Constructors
 | Name | Description
Public method | Adt7516 | Constructor
Top
Properties
 | Name | Description
Public property | AIN2 | AIN2
Public property | AIN2VHIGHLimit | AIN2 V_HIGH Limit
Public property | AIN2VLOWLimit | AIN2 V_LOW Limit
Public property | AIN3 | AIN3
Public property | AIN3VHIGHLimit | AIN3 V_HIGH Limit
Public property | AIN3VLOWLimit | AIN3 V_LOW Limit
Public property | AIN4 | AIN4
Public property | AIN4VHIGHLimit | AIN4 V_HIGH Limit
Public property | AIN4VLOWLimit | AIN4 V_LOW Limit
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlConfiguration1INTOutput | Control Configuration 1: INT Output
Public property | ControlConfiguration1INTOutputPolarity | Control Configuration 1: INT Output Polarity
Public property | ControlConfiguration1LDACAIN3 | Control Configuration 1: LDAC / AIN3
Public property | ControlConfiguration1Monitoring | Control Configuration 1: Monitoring
Public property | ControlConfiguration1Pin7Pin8 | Control Configuration 1: Pin 7 / Pin 8
Public property | ControlConfiguration1PowerDown | Control Configuration 1: Power Down
Public property | ControlConfiguration2Averaging | Control Configuration 2: Averaging
Public property | ControlConfiguration2ChannelSelection | Control Configuration 2: Channel Selection
Public property | ControlConfiguration2Conversion | Control Configuration 2: Conversion
Public property | ControlConfiguration2SMBusTimeout | Control Configuration 2: SMBus Timeout
Public property | ControlConfiguration2SoftwareReset | Control Configuration 2: Software Reset
Public property | ControlConfiguration3ADCReference | Control Configuration 3: ADC Reference
Public property | ControlConfiguration3DACAOutputProportionalToInternalTemperature | Control Configuration 3: DAC A Output Proportional To Internal Temperature
Public property | ControlConfiguration3DACBOutputProportionalToExternalTemperature | Control Configuration 3: DAC B Output Proportional To External Temperature
Public property | ControlConfiguration3Resolution | Control Configuration 3: Resolution
Public property | ControlConfiguration3Speed | Control Configuration 3: Speed
Public property | ControlConfiguration3UpdatingOfDACOutputs | Control Configuration 3: Updating of DAC Outputs
Public property | DACA | DAC A
Public property | DACB | DAC B
Public property | DACC | DAC C
Public property | DACConfigurationOutputRangeDACA | DAC Configuration: Output Range DAC A
Public property | DACConfigurationOutputRangeDACB | DAC Configuration: Output Range DAC B
Public property | DACConfigurationOutputRangeDACC | DAC Configuration: Output Range DAC C
Public property | DACConfigurationOutputRangeDACD | DAC Configuration: Output Range DAC D
Public property | DACConfigurationUpdate | DAC Configuration: Update
Public property | DACD | DAC D
Public property | DeviceID | Device ID
Public property | ExternalAnalogTemperatureOffset | External Analog Temperature Offset (unit: °C)
Public property | ExternalTemperatureAIN1 | External Temperature / AIN1 (unit: °C)
Public property | ExternalTemperatureOffset | External Temperature Offset (unit: °C)
Public property | ExternalTHIGHAIN1VHIGHLimits | External T_HIGH/AIN1 V_HIGH Limits (unit: °C)
Public property | ExternalTLOWAIN1VLOWLimits | External T_LOW/AIN1 V_LOW Limits (unit: °C)
Public property | InternalAnalogTemperatureOffset | Internal Analog Temperature Offset (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | InternalTemperatureOffset | Internal Temperature Offset (unit: °C)
Public property | InternalTHIGHLimit | Internal T_HIGH Limit (unit: °C)
Public property | InternalTLOWLimit | Internal T_LOW Limit (unit: °C)
Public property | InterruptMask1AIN2 | Interrupt Mask 1: AIN2
Public property | InterruptMask1AIN3 | Interrupt Mask 1: AIN3
Public property | InterruptMask1AIN4 | Interrupt Mask 1: AIN4
Public property | InterruptMask1ExternalTemperatureFault | Interrupt Mask 1: External Temperature Fault
Public property | InterruptMask1ExternalTHIGHAIN1 | Interrupt Mask 1: External T_HIGH / AIN1
Public property | InterruptMask1ExternalTLOW | Interrupt Mask 1: External T_LOW
Public property | InterruptMask1InternalTHIGH | Interrupt Mask 1: Internal T_HIGH
Public property | InterruptMask1InternalTLOW | Interrupt Mask 1: Internal T_LOW
Public property | InterruptMask2VDD | Interrupt Mask 2: V_DD
Public property | InterruptStatus1AIN2VHIGHAIN2VLOW | Interrupt Status 1: AIN2 > V_HIGH / AIN2 <= V_LOW
Public property | InterruptStatus1AIN3VHIGHAIN3VLOW | Interrupt Status 1: AIN3 > V_HIGH / AIN3 <= V_LOW
Public property | InterruptStatus1AIN4VHIGHAIN4VLOW | Interrupt Status 1: AIN4 > V_HIGH / AIN4 <= V_LOW
Public property | InterruptStatus1ExternalSensorFault | Interrupt Status 1: External Sensor Fault
Public property | InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW | Interrupt Status 1: T_EXT > T_HIGH / AIN1 > V_HIGH / AIN1 <= V_LOW
Public property | InterruptStatus1TEXTTLOW | Interrupt Status 1: T_EXT <= T_LOW
Public property | InterruptStatus1TINTTHIGH | Interrupt Status 1: T_INT > T_HIGH
Public property | InterruptStatus1TINTTLOW | Interrupt Status 1: T_INT <= T_LOW
Public property | InterruptStatus2VDDVHIGHVDDVLOW | Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW
Public property | LDACConfigurationDACA | LDAC Configuration: DAC A
Public property | LDACConfigurationDACB | LDAC Configuration: DAC B
Public property | LDACConfigurationDACC | LDAC Configuration: DAC C
Public property | LDACConfigurationDACD | LDAC Configuration: DAC D
Public property | LDACConfigurationReferenceDACAB | LDAC Configuration: Reference DAC A / B
Public property | LDACConfigurationReferenceDACCD | LDAC Configuration: Reference DAC C / D
Public property | ManufacturerSID | Manufacturer's ID
Public property | SiliconRevisionStepping | Silicon Revision: Stepping
Public property | SiliconRevisionVersion | Silicon Revision: Version
Public property | SPILockStatus | SPI Lock Status
Public property | VDD | V_DD (unit: V)
Public property | VDDVHIGHLimit | V_DD V_HIGH Limit (unit: V)
Public property | VDDVLOWLimit | V_DD V_LOW Limit (unit: V)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Temperature Sensor, 4-Channel ADC and Quad Voltage Output
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adt7516(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adt7516

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516 Properties

The Adt7516 type exposes the following members.

Properties
 | Name | Description
Public property | AIN2 | AIN2
Public property | AIN2VHIGHLimit | AIN2 V_HIGH Limit
Public property | AIN2VLOWLimit | AIN2 V_LOW Limit
Public property | AIN3 | AIN3
Public property | AIN3VHIGHLimit | AIN3 V_HIGH Limit
Public property | AIN3VLOWLimit | AIN3 V_LOW Limit
Public property | AIN4 | AIN4
Public property | AIN4VHIGHLimit | AIN4 V_HIGH Limit
Public property | AIN4VLOWLimit | AIN4 V_LOW Limit
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlConfiguration1INTOutput | Control Configuration 1: INT Output
Public property | ControlConfiguration1INTOutputPolarity | Control Configuration 1: INT Output Polarity
Public property | ControlConfiguration1LDACAIN3 | Control Configuration 1: LDAC / AIN3
Public property | ControlConfiguration1Monitoring | Control Configuration 1: Monitoring
Public property | ControlConfiguration1Pin7Pin8 | Control Configuration 1: Pin 7 / Pin 8
Public property | ControlConfiguration1PowerDown | Control Configuration 1: Power Down
Public property | ControlConfiguration2Averaging | Control Configuration 2: Averaging
Public property | ControlConfiguration2ChannelSelection | Control Configuration 2: Channel Selection
Public property | ControlConfiguration2Conversion | Control Configuration 2: Conversion
Public property | ControlConfiguration2SMBusTimeout | Control Configuration 2: SMBus Timeout
Public property | ControlConfiguration2SoftwareReset | Control Configuration 2: Software Reset
Public property | ControlConfiguration3ADCReference | Control Configuration 3: ADC Reference
Public property | ControlConfiguration3DACAOutputProportionalToInternalTemperature | Control Configuration 3: DAC A Output Proportional To Internal Temperature
Public property | ControlConfiguration3DACBOutputProportionalToExternalTemperature | Control Configuration 3: DAC B Output Proportional To External Temperature
Public property | ControlConfiguration3Resolution | Control Configuration 3: Resolution
Public property | ControlConfiguration3Speed | Control Configuration 3: Speed
Public property | ControlConfiguration3UpdatingOfDACOutputs | Control Configuration 3: Updating of DAC Outputs
Public property | DACA | DAC A
Public property | DACB | DAC B
Public property | DACC | DAC C
Public property | DACConfigurationOutputRangeDACA | DAC Configuration: Output Range DAC A
Public property | DACConfigurationOutputRangeDACB | DAC Configuration: Output Range DAC B
Public property | DACConfigurationOutputRangeDACC | DAC Configuration: Output Range DAC C
Public property | DACConfigurationOutputRangeDACD | DAC Configuration: Output Range DAC D
Public property | DACConfigurationUpdate | DAC Configuration: Update
Public property | DACD | DAC D
Public property | DeviceID | Device ID
Public property | ExternalAnalogTemperatureOffset | External Analog Temperature Offset (unit: °C)
Public property | ExternalTemperatureAIN1 | External Temperature / AIN1 (unit: °C)
Public property | ExternalTemperatureOffset | External Temperature Offset (unit: °C)
Public property | ExternalTHIGHAIN1VHIGHLimits | External T_HIGH/AIN1 V_HIGH Limits (unit: °C)
Public property | ExternalTLOWAIN1VLOWLimits | External T_LOW/AIN1 V_LOW Limits (unit: °C)
Public property | InternalAnalogTemperatureOffset | Internal Analog Temperature Offset (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | InternalTemperatureOffset | Internal Temperature Offset (unit: °C)
Public property | InternalTHIGHLimit | Internal T_HIGH Limit (unit: °C)
Public property | InternalTLOWLimit | Internal T_LOW Limit (unit: °C)
Public property | InterruptMask1AIN2 | Interrupt Mask 1: AIN2
Public property | InterruptMask1AIN3 | Interrupt Mask 1: AIN3
Public property | InterruptMask1AIN4 | Interrupt Mask 1: AIN4
Public property | InterruptMask1ExternalTemperatureFault | Interrupt Mask 1: External Temperature Fault
Public property | InterruptMask1ExternalTHIGHAIN1 | Interrupt Mask 1: External T_HIGH / AIN1
Public property | InterruptMask1ExternalTLOW | Interrupt Mask 1: External T_LOW
Public property | InterruptMask1InternalTHIGH | Interrupt Mask 1: Internal T_HIGH
Public property | InterruptMask1InternalTLOW | Interrupt Mask 1: Internal T_LOW
Public property | InterruptMask2VDD | Interrupt Mask 2: V_DD
Public property | InterruptStatus1AIN2VHIGHAIN2VLOW | Interrupt Status 1: AIN2 > V_HIGH / AIN2 <= V_LOW
Public property | InterruptStatus1AIN3VHIGHAIN3VLOW | Interrupt Status 1: AIN3 > V_HIGH / AIN3 <= V_LOW
Public property | InterruptStatus1AIN4VHIGHAIN4VLOW | Interrupt Status 1: AIN4 > V_HIGH / AIN4 <= V_LOW
Public property | InterruptStatus1ExternalSensorFault | Interrupt Status 1: External Sensor Fault
Public property | InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW | Interrupt Status 1: T_EXT > T_HIGH / AIN1 > V_HIGH / AIN1 <= V_LOW
Public property | InterruptStatus1TEXTTLOW | Interrupt Status 1: T_EXT <= T_LOW
Public property | InterruptStatus1TINTTHIGH | Interrupt Status 1: T_INT > T_HIGH
Public property | InterruptStatus1TINTTLOW | Interrupt Status 1: T_INT <= T_LOW
Public property | InterruptStatus2VDDVHIGHVDDVLOW | Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW
Public property | LDACConfigurationDACA | LDAC Configuration: DAC A
Public property | LDACConfigurationDACB | LDAC Configuration: DAC B
Public property | LDACConfigurationDACC | LDAC Configuration: DAC C
Public property | LDACConfigurationDACD | LDAC Configuration: DAC D
Public property | LDACConfigurationReferenceDACAB | LDAC Configuration: Reference DAC A / B
Public property | LDACConfigurationReferenceDACCD | LDAC Configuration: Reference DAC C / D
Public property | ManufacturerSID | Manufacturer's ID
Public property | SiliconRevisionStepping | Silicon Revision: Stepping
Public property | SiliconRevisionVersion | Silicon Revision: Version
Public property | SPILockStatus | SPI Lock Status
Public property | VDD | V_DD (unit: V)
Public property | VDDVHIGHLimit | V_DD V_HIGH Limit (unit: V)
Public property | VDDVLOWLimit | V_DD V_LOW Limit (unit: V)
Top
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.AIN2 Property

IRD

Adt7516AIN2 Property

AIN2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AIN2 { get; }
Public ReadOnly Property AIN2 As UShort
    Get
public:
property unsigned short AIN2 {
    unsigned short get ();
}
member AIN2 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.AIN2VHIGHLimit Property

IRD

Adt7516AIN2VHIGHLimit Property

AIN2 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN2VHIGHLimit { get; set; }
Public Property AIN2VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN2VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN2VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.AIN2VLOWLimit Property

IRD

Adt7516AIN2VLOWLimit Property

AIN2 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN2VLOWLimit { get; set; }
Public Property AIN2VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN2VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN2VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.AIN3 Property

IRD

Adt7516AIN3 Property

AIN3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AIN3 { get; }
Public ReadOnly Property AIN3 As UShort
    Get
public:
property unsigned short AIN3 {
    unsigned short get ();
}
member AIN3 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.AIN3VHIGHLimit Property

IRD

Adt7516AIN3VHIGHLimit Property

AIN3 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN3VHIGHLimit { get; set; }
Public Property AIN3VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN3VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN3VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.AIN3VLOWLimit Property

IRD

Adt7516AIN3VLOWLimit Property

AIN3 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN3VLOWLimit { get; set; }
Public Property AIN3VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN3VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN3VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.AIN4 Property

IRD

Adt7516AIN4 Property

AIN4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AIN4 { get; }
Public ReadOnly Property AIN4 As UShort
    Get
public:
property unsigned short AIN4 {
    unsigned short get ();
}
member AIN4 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.AIN4VHIGHLimit Property

IRD

Adt7516AIN4VHIGHLimit Property

AIN4 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN4VHIGHLimit { get; set; }
Public Property AIN4VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN4VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN4VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.AIN4VLOWLimit Property

IRD

Adt7516AIN4VLOWLimit Property

AIN4 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN4VLOWLimit { get; set; }
Public Property AIN4VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN4VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN4VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.AutoFlush Property

IRD

Adt7516AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ControlConfiguration1INTOutput Property

IRD

Adt7516ControlConfiguration1INTOutput Property

Control Configuration 1: INT Output

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeControlConfiguration1IntOutput ControlConfiguration1INTOutput { get; set; }
Public Property ControlConfiguration1INTOutput As Adt7516TypeControlConfiguration1IntOutput
    Get
    Set
public:
property Adt7516TypeControlConfiguration1IntOutput ControlConfiguration1INTOutput {
    Adt7516TypeControlConfiguration1IntOutput get ();
    void set (Adt7516TypeControlConfiguration1IntOutput value);
}
member ControlConfiguration1INTOutput : Adt7516TypeControlConfiguration1IntOutput with get, set

Property Value

Type: Adt7516TypeControlConfiguration1IntOutput
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ControlConfiguration1INTOutputPolarity Property

IRD

Adt7516ControlConfiguration1INTOutputPolarity Property

Control Configuration 1: INT Output Polarity

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeControlConfiguration1IntOutputPolarity ControlConfiguration1INTOutputPolarity { get; set; }
Public Property ControlConfiguration1INTOutputPolarity As Adt7516TypeControlConfiguration1IntOutputPolarity
    Get
    Set
public:
property Adt7516TypeControlConfiguration1IntOutputPolarity ControlConfiguration1INTOutputPolarity {
    Adt7516TypeControlConfiguration1IntOutputPolarity get ();
    void set (Adt7516TypeControlConfiguration1IntOutputPolarity value);
}
member ControlConfiguration1INTOutputPolarity : Adt7516TypeControlConfiguration1IntOutputPolarity with get, set

Property Value

Type: Adt7516TypeControlConfiguration1IntOutputPolarity
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ControlConfiguration1LDACAIN3 Property

IRD

Adt7516ControlConfiguration1LDACAIN3 Property

Control Configuration 1: LDAC / AIN3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeControlConfiguration1LdacAin3 ControlConfiguration1LDACAIN3 { get; set; }
Public Property ControlConfiguration1LDACAIN3 As Adt7516TypeControlConfiguration1LdacAin3
    Get
    Set
public:
property Adt7516TypeControlConfiguration1LdacAin3 ControlConfiguration1LDACAIN3 {
    Adt7516TypeControlConfiguration1LdacAin3 get ();
    void set (Adt7516TypeControlConfiguration1LdacAin3 value);
}
member ControlConfiguration1LDACAIN3 : Adt7516TypeControlConfiguration1LdacAin3 with get, set

Property Value

Type: Adt7516TypeControlConfiguration1LdacAin3
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ControlConfiguration1Monitoring Property

IRD

Adt7516ControlConfiguration1Monitoring Property

Control Configuration 1: Monitoring

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeControlConfiguration1Monitoring ControlConfiguration1Monitoring { get; set; }
Public Property ControlConfiguration1Monitoring As Adt7516TypeControlConfiguration1Monitoring
    Get
    Set
public:
property Adt7516TypeControlConfiguration1Monitoring ControlConfiguration1Monitoring {
    Adt7516TypeControlConfiguration1Monitoring get ();
    void set (Adt7516TypeControlConfiguration1Monitoring value);
}
member ControlConfiguration1Monitoring : Adt7516TypeControlConfiguration1Monitoring with get, set

Property Value

Type: Adt7516TypeControlConfiguration1Monitoring
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ControlConfiguration1Pin7Pin8 Property

IRD

Adt7516ControlConfiguration1Pin7Pin8 Property

Control Configuration 1: Pin 7 / Pin 8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeControlConfiguration1AinTdmSelection ControlConfiguration1Pin7Pin8 { get; set; }
Public Property ControlConfiguration1Pin7Pin8 As Adt7516TypeControlConfiguration1AinTdmSelection
    Get
    Set
public:
property Adt7516TypeControlConfiguration1AinTdmSelection ControlConfiguration1Pin7Pin8 {
    Adt7516TypeControlConfiguration1AinTdmSelection get ();
    void set (Adt7516TypeControlConfiguration1AinTdmSelection value);
}
member ControlConfiguration1Pin7Pin8 : Adt7516TypeControlConfiguration1AinTdmSelection with get, set

Property Value

Type: Adt7516TypeControlConfiguration1AinTdmSelection
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ControlConfiguration1PowerDown Property

IRD

Adt7516ControlConfiguration1PowerDown Property

Control Configuration 1: Power Down

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeControlConfiguration1PowerDown ControlConfiguration1PowerDown { get; set; }
Public Property ControlConfiguration1PowerDown As Adt7516TypeControlConfiguration1PowerDown
    Get
    Set
public:
property Adt7516TypeControlConfiguration1PowerDown ControlConfiguration1PowerDown {
    Adt7516TypeControlConfiguration1PowerDown get ();
    void set (Adt7516TypeControlConfiguration1PowerDown value);
}
member ControlConfiguration1PowerDown : Adt7516TypeControlConfiguration1PowerDown with get, set

Property Value

Type: Adt7516TypeControlConfiguration1PowerDown
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ControlConfiguration2Averaging Property

IRD

Adt7516ControlConfiguration2Averaging Property

Control Configuration 2: Averaging

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeControlConfiguration2Averaging ControlConfiguration2Averaging { get; set; }
Public Property ControlConfiguration2Averaging As Adt7516TypeControlConfiguration2Averaging
    Get
    Set
public:
property Adt7516TypeControlConfiguration2Averaging ControlConfiguration2Averaging {
    Adt7516TypeControlConfiguration2Averaging get ();
    void set (Adt7516TypeControlConfiguration2Averaging value);
}
member ControlConfiguration2Averaging : Adt7516TypeControlConfiguration2Averaging with get, set

Property Value

Type: Adt7516TypeControlConfiguration2Averaging
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ControlConfiguration2ChannelSelection Property

IRD

Adt7516ControlConfiguration2ChannelSelection Property

Control Configuration 2: Channel Selection

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeControlConfiguration2ChannelSelection ControlConfiguration2ChannelSelection { get; set; }
Public Property ControlConfiguration2ChannelSelection As Adt7516TypeControlConfiguration2ChannelSelection
    Get
    Set
public:
property Adt7516TypeControlConfiguration2ChannelSelection ControlConfiguration2ChannelSelection {
    Adt7516TypeControlConfiguration2ChannelSelection get ();
    void set (Adt7516TypeControlConfiguration2ChannelSelection value);
}
member ControlConfiguration2ChannelSelection : Adt7516TypeControlConfiguration2ChannelSelection with get, set

Property Value

Type: Adt7516TypeControlConfiguration2ChannelSelection
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ControlConfiguration2Conversion Property

IRD

Adt7516ControlConfiguration2Conversion Property

Control Configuration 2: Conversion

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeControlConfiguration2Conversion ControlConfiguration2Conversion { get; set; }
Public Property ControlConfiguration2Conversion As Adt7516TypeControlConfiguration2Conversion
    Get
    Set
public:
property Adt7516TypeControlConfiguration2Conversion ControlConfiguration2Conversion {
    Adt7516TypeControlConfiguration2Conversion get ();
    void set (Adt7516TypeControlConfiguration2Conversion value);
}
member ControlConfiguration2Conversion : Adt7516TypeControlConfiguration2Conversion with get, set

Property Value

Type: Adt7516TypeControlConfiguration2Conversion
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ControlConfiguration2SMBusTimeout Property

IRD

Adt7516ControlConfiguration2SMBusTimeout Property

Control Configuration 2: SMBus Timeout

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeControlConfiguration2Timeout ControlConfiguration2SMBusTimeout { get; set; }
Public Property ControlConfiguration2SMBusTimeout As Adt7516TypeControlConfiguration2Timeout
    Get
    Set
public:
property Adt7516TypeControlConfiguration2Timeout ControlConfiguration2SMBusTimeout {
    Adt7516TypeControlConfiguration2Timeout get ();
    void set (Adt7516TypeControlConfiguration2Timeout value);
}
member ControlConfiguration2SMBusTimeout : Adt7516TypeControlConfiguration2Timeout with get, set

Property Value

Type: Adt7516TypeControlConfiguration2Timeout
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ControlConfiguration2SoftwareReset Property

IRD

Adt7516ControlConfiguration2SoftwareReset Property

Control Configuration 2: Software Reset

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeControlConfiguration2SoftwareReset ControlConfiguration2SoftwareReset { get; set; }
Public Property ControlConfiguration2SoftwareReset As Adt7516TypeControlConfiguration2SoftwareReset
    Get
    Set
public:
property Adt7516TypeControlConfiguration2SoftwareReset ControlConfiguration2SoftwareReset {
    Adt7516TypeControlConfiguration2SoftwareReset get ();
    void set (Adt7516TypeControlConfiguration2SoftwareReset value);
}
member ControlConfiguration2SoftwareReset : Adt7516TypeControlConfiguration2SoftwareReset with get, set

Property Value

Type: Adt7516TypeControlConfiguration2SoftwareReset
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ControlConfiguration3ADCReference Property

IRD

Adt7516ControlConfiguration3ADCReference Property

Control Configuration 3: ADC Reference

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeControlConfiguration3AdcReference ControlConfiguration3ADCReference { get; set; }
Public Property ControlConfiguration3ADCReference As Adt7516TypeControlConfiguration3AdcReference
    Get
    Set
public:
property Adt7516TypeControlConfiguration3AdcReference ControlConfiguration3ADCReference {
    Adt7516TypeControlConfiguration3AdcReference get ();
    void set (Adt7516TypeControlConfiguration3AdcReference value);
}
member ControlConfiguration3ADCReference : Adt7516TypeControlConfiguration3AdcReference with get, set

Property Value

Type: Adt7516TypeControlConfiguration3AdcReference
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ControlConfiguration3DACAOutputProportionalToInternalTemperature Property

IRD

Adt7516ControlConfiguration3DACAOutputProportionalToInternalTemperature Property

Control Configuration 3: DAC A Output Proportional To Internal Temperature

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeControlConfiguration3DacAOutput ControlConfiguration3DACAOutputProportionalToInternalTemperature { get; set; }
Public Property ControlConfiguration3DACAOutputProportionalToInternalTemperature As Adt7516TypeControlConfiguration3DacAOutput
    Get
    Set
public:
property Adt7516TypeControlConfiguration3DacAOutput ControlConfiguration3DACAOutputProportionalToInternalTemperature {
    Adt7516TypeControlConfiguration3DacAOutput get ();
    void set (Adt7516TypeControlConfiguration3DacAOutput value);
}
member ControlConfiguration3DACAOutputProportionalToInternalTemperature : Adt7516TypeControlConfiguration3DacAOutput with get, set

Property Value

Type: Adt7516TypeControlConfiguration3DacAOutput
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ControlConfiguration3DACBOutputProportionalToExternalTemperature Property

IRD

Adt7516ControlConfiguration3DACBOutputProportionalToExternalTemperature Property

Control Configuration 3: DAC B Output Proportional To External Temperature

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeControlConfiguration3DacBOutput ControlConfiguration3DACBOutputProportionalToExternalTemperature { get; set; }
Public Property ControlConfiguration3DACBOutputProportionalToExternalTemperature As Adt7516TypeControlConfiguration3DacBOutput
    Get
    Set
public:
property Adt7516TypeControlConfiguration3DacBOutput ControlConfiguration3DACBOutputProportionalToExternalTemperature {
    Adt7516TypeControlConfiguration3DacBOutput get ();
    void set (Adt7516TypeControlConfiguration3DacBOutput value);
}
member ControlConfiguration3DACBOutputProportionalToExternalTemperature : Adt7516TypeControlConfiguration3DacBOutput with get, set

Property Value

Type: Adt7516TypeControlConfiguration3DacBOutput
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ControlConfiguration3Resolution Property

IRD

Adt7516ControlConfiguration3Resolution Property

Control Configuration 3: Resolution

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeControlConfiguration3Resolution ControlConfiguration3Resolution { get; set; }
Public Property ControlConfiguration3Resolution As Adt7516TypeControlConfiguration3Resolution
    Get
    Set
public:
property Adt7516TypeControlConfiguration3Resolution ControlConfiguration3Resolution {
    Adt7516TypeControlConfiguration3Resolution get ();
    void set (Adt7516TypeControlConfiguration3Resolution value);
}
member ControlConfiguration3Resolution : Adt7516TypeControlConfiguration3Resolution with get, set

Property Value

Type: Adt7516TypeControlConfiguration3Resolution
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ControlConfiguration3Speed Property

IRD

Adt7516ControlConfiguration3Speed Property

Control Configuration 3: Speed

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeControlConfiguration3Speed ControlConfiguration3Speed { get; set; }
Public Property ControlConfiguration3Speed As Adt7516TypeControlConfiguration3Speed
    Get
    Set
public:
property Adt7516TypeControlConfiguration3Speed ControlConfiguration3Speed {
    Adt7516TypeControlConfiguration3Speed get ();
    void set (Adt7516TypeControlConfiguration3Speed value);
}
member ControlConfiguration3Speed : Adt7516TypeControlConfiguration3Speed with get, set

Property Value

Type: Adt7516TypeControlConfiguration3Speed
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ControlConfiguration3UpdatingOfDACOutputs Property

IRD

Adt7516ControlConfiguration3UpdatingOfDACOutputs Property

Control Configuration 3: Updating of DAC Outputs

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeControlConfiguration3UpdatingDacOutputs ControlConfiguration3UpdatingOfDACOutputs { get; set; }
Public Property ControlConfiguration3UpdatingOfDACOutputs As Adt7516TypeControlConfiguration3UpdatingDacOutputs
    Get
    Set
public:
property Adt7516TypeControlConfiguration3UpdatingDacOutputs ControlConfiguration3UpdatingOfDACOutputs {
    Adt7516TypeControlConfiguration3UpdatingDacOutputs get ();
    void set (Adt7516TypeControlConfiguration3UpdatingDacOutputs value);
}
member ControlConfiguration3UpdatingOfDACOutputs : Adt7516TypeControlConfiguration3UpdatingDacOutputs with get, set

Property Value

Type: Adt7516TypeControlConfiguration3UpdatingDacOutputs
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.DACA Property

IRD

Adt7516DACA Property

DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DACA { get; set; }
Public Property DACA As UShort
    Get
    Set
public:
property unsigned short DACA {
    unsigned short get ();
    void set (unsigned short value);
}
member DACA : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.DACB Property

IRD

Adt7516DACB Property

DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DACB { get; set; }
Public Property DACB As UShort
    Get
    Set
public:
property unsigned short DACB {
    unsigned short get ();
    void set (unsigned short value);
}
member DACB : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.DACC Property

IRD

Adt7516DACC Property

DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DACC { get; set; }
Public Property DACC As UShort
    Get
    Set
public:
property unsigned short DACC {
    unsigned short get ();
    void set (unsigned short value);
}
member DACC : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.DACConfigurationOutputRangeDACA Property

IRD

Adt7516DACConfigurationOutputRangeDACA Property

DAC Configuration: Output Range DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeDacConfigurationRange DACConfigurationOutputRangeDACA { get; set; }
Public Property DACConfigurationOutputRangeDACA As Adt7516TypeDacConfigurationRange
    Get
    Set
public:
property Adt7516TypeDacConfigurationRange DACConfigurationOutputRangeDACA {
    Adt7516TypeDacConfigurationRange get ();
    void set (Adt7516TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACA : Adt7516TypeDacConfigurationRange with get, set

Property Value

Type: Adt7516TypeDacConfigurationRange
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.DACConfigurationOutputRangeDACB Property

IRD

Adt7516DACConfigurationOutputRangeDACB Property

DAC Configuration: Output Range DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeDacConfigurationRange DACConfigurationOutputRangeDACB { get; set; }
Public Property DACConfigurationOutputRangeDACB As Adt7516TypeDacConfigurationRange
    Get
    Set
public:
property Adt7516TypeDacConfigurationRange DACConfigurationOutputRangeDACB {
    Adt7516TypeDacConfigurationRange get ();
    void set (Adt7516TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACB : Adt7516TypeDacConfigurationRange with get, set

Property Value

Type: Adt7516TypeDacConfigurationRange
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.DACConfigurationOutputRangeDACC Property

IRD

Adt7516DACConfigurationOutputRangeDACC Property

DAC Configuration: Output Range DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeDacConfigurationRange DACConfigurationOutputRangeDACC { get; set; }
Public Property DACConfigurationOutputRangeDACC As Adt7516TypeDacConfigurationRange
    Get
    Set
public:
property Adt7516TypeDacConfigurationRange DACConfigurationOutputRangeDACC {
    Adt7516TypeDacConfigurationRange get ();
    void set (Adt7516TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACC : Adt7516TypeDacConfigurationRange with get, set

Property Value

Type: Adt7516TypeDacConfigurationRange
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.DACConfigurationOutputRangeDACD Property

IRD

Adt7516DACConfigurationOutputRangeDACD Property

DAC Configuration: Output Range DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeDacConfigurationRange DACConfigurationOutputRangeDACD { get; set; }
Public Property DACConfigurationOutputRangeDACD As Adt7516TypeDacConfigurationRange
    Get
    Set
public:
property Adt7516TypeDacConfigurationRange DACConfigurationOutputRangeDACD {
    Adt7516TypeDacConfigurationRange get ();
    void set (Adt7516TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACD : Adt7516TypeDacConfigurationRange with get, set

Property Value

Type: Adt7516TypeDacConfigurationRange
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.DACConfigurationUpdate Property

IRD

Adt7516DACConfigurationUpdate Property

DAC Configuration: Update

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeDacConfigurationUpdate DACConfigurationUpdate { get; set; }
Public Property DACConfigurationUpdate As Adt7516TypeDacConfigurationUpdate
    Get
    Set
public:
property Adt7516TypeDacConfigurationUpdate DACConfigurationUpdate {
    Adt7516TypeDacConfigurationUpdate get ();
    void set (Adt7516TypeDacConfigurationUpdate value);
}
member DACConfigurationUpdate : Adt7516TypeDacConfigurationUpdate with get, set

Property Value

Type: Adt7516TypeDacConfigurationUpdate
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.DACD Property

IRD

Adt7516DACD Property

DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DACD { get; set; }
Public Property DACD As UShort
    Get
    Set
public:
property unsigned short DACD {
    unsigned short get ();
    void set (unsigned short value);
}
member DACD : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.DeviceID Property

IRD

Adt7516DeviceID Property

Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ExternalAnalogTemperatureOffset Property

IRD

Adt7516ExternalAnalogTemperatureOffset Property

External Analog Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalAnalogTemperatureOffset { get; set; }
Public Property ExternalAnalogTemperatureOffset As SByte
    Get
    Set
public:
property signed char ExternalAnalogTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member ExternalAnalogTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ExternalTemperatureAIN1 Property

IRD

Adt7516ExternalTemperatureAIN1 Property

External Temperature / AIN1 (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ExternalTemperatureAIN1 { get; }
Public ReadOnly Property ExternalTemperatureAIN1 As Double
    Get
public:
property double ExternalTemperatureAIN1 {
    double get ();
}
member ExternalTemperatureAIN1 : float with get

Property Value

Type: Double
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ExternalTemperatureOffset Property

IRD

Adt7516ExternalTemperatureOffset Property

External Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperatureOffset { get; set; }
Public Property ExternalTemperatureOffset As SByte
    Get
    Set
public:
property signed char ExternalTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member ExternalTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ExternalTHIGHAIN1VHIGHLimits Property

IRD

Adt7516ExternalTHIGHAIN1VHIGHLimits Property

External T_HIGH/AIN1 V_HIGH Limits (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTHIGHAIN1VHIGHLimits { get; set; }
Public Property ExternalTHIGHAIN1VHIGHLimits As SByte
    Get
    Set
public:
property signed char ExternalTHIGHAIN1VHIGHLimits {
    signed char get ();
    void set (signed char value);
}
member ExternalTHIGHAIN1VHIGHLimits : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ExternalTLOWAIN1VLOWLimits Property

IRD

Adt7516ExternalTLOWAIN1VLOWLimits Property

External T_LOW/AIN1 V_LOW Limits (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTLOWAIN1VLOWLimits { get; set; }
Public Property ExternalTLOWAIN1VLOWLimits As SByte
    Get
    Set
public:
property signed char ExternalTLOWAIN1VLOWLimits {
    signed char get ();
    void set (signed char value);
}
member ExternalTLOWAIN1VLOWLimits : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InternalAnalogTemperatureOffset Property

IRD

Adt7516InternalAnalogTemperatureOffset Property

Internal Analog Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalAnalogTemperatureOffset { get; set; }
Public Property InternalAnalogTemperatureOffset As SByte
    Get
    Set
public:
property signed char InternalAnalogTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member InternalAnalogTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InternalTemperature Property

IRD

Adt7516InternalTemperature Property

Internal Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double InternalTemperature { get; }
Public ReadOnly Property InternalTemperature As Double
    Get
public:
property double InternalTemperature {
    double get ();
}
member InternalTemperature : float with get

Property Value

Type: Double
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InternalTemperatureOffset Property

IRD

Adt7516InternalTemperatureOffset Property

Internal Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureOffset { get; set; }
Public Property InternalTemperatureOffset As SByte
    Get
    Set
public:
property signed char InternalTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member InternalTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InternalTHIGHLimit Property

IRD

Adt7516InternalTHIGHLimit Property

Internal T_HIGH Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTHIGHLimit { get; set; }
Public Property InternalTHIGHLimit As SByte
    Get
    Set
public:
property signed char InternalTHIGHLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTHIGHLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InternalTLOWLimit Property

IRD

Adt7516InternalTLOWLimit Property

Internal T_LOW Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTLOWLimit { get; set; }
Public Property InternalTLOWLimit As SByte
    Get
    Set
public:
property signed char InternalTLOWLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTLOWLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InterruptMask1AIN2 Property

IRD

Adt7516InterruptMask1AIN2 Property

Interrupt Mask 1: AIN2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeInterruptMaskEnableDisable InterruptMask1AIN2 { get; set; }
Public Property InterruptMask1AIN2 As Adt7516TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7516TypeInterruptMaskEnableDisable InterruptMask1AIN2 {
    Adt7516TypeInterruptMaskEnableDisable get ();
    void set (Adt7516TypeInterruptMaskEnableDisable value);
}
member InterruptMask1AIN2 : Adt7516TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7516TypeInterruptMaskEnableDisable
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InterruptMask1AIN3 Property

IRD

Adt7516InterruptMask1AIN3 Property

Interrupt Mask 1: AIN3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeInterruptMaskEnableDisable InterruptMask1AIN3 { get; set; }
Public Property InterruptMask1AIN3 As Adt7516TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7516TypeInterruptMaskEnableDisable InterruptMask1AIN3 {
    Adt7516TypeInterruptMaskEnableDisable get ();
    void set (Adt7516TypeInterruptMaskEnableDisable value);
}
member InterruptMask1AIN3 : Adt7516TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7516TypeInterruptMaskEnableDisable
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InterruptMask1AIN4 Property

IRD

Adt7516InterruptMask1AIN4 Property

Interrupt Mask 1: AIN4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeInterruptMaskEnableDisable InterruptMask1AIN4 { get; set; }
Public Property InterruptMask1AIN4 As Adt7516TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7516TypeInterruptMaskEnableDisable InterruptMask1AIN4 {
    Adt7516TypeInterruptMaskEnableDisable get ();
    void set (Adt7516TypeInterruptMaskEnableDisable value);
}
member InterruptMask1AIN4 : Adt7516TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7516TypeInterruptMaskEnableDisable
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InterruptMask1ExternalTemperatureFault Property

IRD

Adt7516InterruptMask1ExternalTemperatureFault Property

Interrupt Mask 1: External Temperature Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeInterruptMaskEnableDisable InterruptMask1ExternalTemperatureFault { get; set; }
Public Property InterruptMask1ExternalTemperatureFault As Adt7516TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7516TypeInterruptMaskEnableDisable InterruptMask1ExternalTemperatureFault {
    Adt7516TypeInterruptMaskEnableDisable get ();
    void set (Adt7516TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTemperatureFault : Adt7516TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7516TypeInterruptMaskEnableDisable
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InterruptMask1ExternalTHIGHAIN1 Property

IRD

Adt7516InterruptMask1ExternalTHIGHAIN1 Property

Interrupt Mask 1: External T_HIGH / AIN1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeInterruptMaskEnableDisable InterruptMask1ExternalTHIGHAIN1 { get; set; }
Public Property InterruptMask1ExternalTHIGHAIN1 As Adt7516TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7516TypeInterruptMaskEnableDisable InterruptMask1ExternalTHIGHAIN1 {
    Adt7516TypeInterruptMaskEnableDisable get ();
    void set (Adt7516TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTHIGHAIN1 : Adt7516TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7516TypeInterruptMaskEnableDisable
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InterruptMask1ExternalTLOW Property

IRD

Adt7516InterruptMask1ExternalTLOW Property

Interrupt Mask 1: External T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeInterruptMaskEnableDisable InterruptMask1ExternalTLOW { get; set; }
Public Property InterruptMask1ExternalTLOW As Adt7516TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7516TypeInterruptMaskEnableDisable InterruptMask1ExternalTLOW {
    Adt7516TypeInterruptMaskEnableDisable get ();
    void set (Adt7516TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTLOW : Adt7516TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7516TypeInterruptMaskEnableDisable
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InterruptMask1InternalTHIGH Property

IRD

Adt7516InterruptMask1InternalTHIGH Property

Interrupt Mask 1: Internal T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeInterruptMaskEnableDisable InterruptMask1InternalTHIGH { get; set; }
Public Property InterruptMask1InternalTHIGH As Adt7516TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7516TypeInterruptMaskEnableDisable InterruptMask1InternalTHIGH {
    Adt7516TypeInterruptMaskEnableDisable get ();
    void set (Adt7516TypeInterruptMaskEnableDisable value);
}
member InterruptMask1InternalTHIGH : Adt7516TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7516TypeInterruptMaskEnableDisable
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InterruptMask1InternalTLOW Property

IRD

Adt7516InterruptMask1InternalTLOW Property

Interrupt Mask 1: Internal T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeInterruptMaskEnableDisable InterruptMask1InternalTLOW { get; set; }
Public Property InterruptMask1InternalTLOW As Adt7516TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7516TypeInterruptMaskEnableDisable InterruptMask1InternalTLOW {
    Adt7516TypeInterruptMaskEnableDisable get ();
    void set (Adt7516TypeInterruptMaskEnableDisable value);
}
member InterruptMask1InternalTLOW : Adt7516TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7516TypeInterruptMaskEnableDisable
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InterruptMask2VDD Property

IRD

Adt7516InterruptMask2VDD Property

Interrupt Mask 2: V_DD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeInterruptMaskEnableDisable InterruptMask2VDD { get; set; }
Public Property InterruptMask2VDD As Adt7516TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7516TypeInterruptMaskEnableDisable InterruptMask2VDD {
    Adt7516TypeInterruptMaskEnableDisable get ();
    void set (Adt7516TypeInterruptMaskEnableDisable value);
}
member InterruptMask2VDD : Adt7516TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7516TypeInterruptMaskEnableDisable
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InterruptStatus1AIN2VHIGHAIN2VLOW Property

IRD

Adt7516InterruptStatus1AIN2VHIGHAIN2VLOW Property

Interrupt Status 1: AIN2 > V_HIGH / AIN2 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeInterruptStatus InterruptStatus1AIN2VHIGHAIN2VLOW { get; }
Public ReadOnly Property InterruptStatus1AIN2VHIGHAIN2VLOW As Adt7516TypeInterruptStatus
    Get
public:
property Adt7516TypeInterruptStatus InterruptStatus1AIN2VHIGHAIN2VLOW {
    Adt7516TypeInterruptStatus get ();
}
member InterruptStatus1AIN2VHIGHAIN2VLOW : Adt7516TypeInterruptStatus with get

Property Value

Type: Adt7516TypeInterruptStatus
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InterruptStatus1AIN3VHIGHAIN3VLOW Property

IRD

Adt7516InterruptStatus1AIN3VHIGHAIN3VLOW Property

Interrupt Status 1: AIN3 > V_HIGH / AIN3 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeInterruptStatus InterruptStatus1AIN3VHIGHAIN3VLOW { get; }
Public ReadOnly Property InterruptStatus1AIN3VHIGHAIN3VLOW As Adt7516TypeInterruptStatus
    Get
public:
property Adt7516TypeInterruptStatus InterruptStatus1AIN3VHIGHAIN3VLOW {
    Adt7516TypeInterruptStatus get ();
}
member InterruptStatus1AIN3VHIGHAIN3VLOW : Adt7516TypeInterruptStatus with get

Property Value

Type: Adt7516TypeInterruptStatus
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InterruptStatus1AIN4VHIGHAIN4VLOW Property

IRD

Adt7516InterruptStatus1AIN4VHIGHAIN4VLOW Property

Interrupt Status 1: AIN4 > V_HIGH / AIN4 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeInterruptStatus InterruptStatus1AIN4VHIGHAIN4VLOW { get; }
Public ReadOnly Property InterruptStatus1AIN4VHIGHAIN4VLOW As Adt7516TypeInterruptStatus
    Get
public:
property Adt7516TypeInterruptStatus InterruptStatus1AIN4VHIGHAIN4VLOW {
    Adt7516TypeInterruptStatus get ();
}
member InterruptStatus1AIN4VHIGHAIN4VLOW : Adt7516TypeInterruptStatus with get

Property Value

Type: Adt7516TypeInterruptStatus
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InterruptStatus1ExternalSensorFault Property

IRD

Adt7516InterruptStatus1ExternalSensorFault Property

Interrupt Status 1: External Sensor Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeInterruptStatus InterruptStatus1ExternalSensorFault { get; }
Public ReadOnly Property InterruptStatus1ExternalSensorFault As Adt7516TypeInterruptStatus
    Get
public:
property Adt7516TypeInterruptStatus InterruptStatus1ExternalSensorFault {
    Adt7516TypeInterruptStatus get ();
}
member InterruptStatus1ExternalSensorFault : Adt7516TypeInterruptStatus with get

Property Value

Type: Adt7516TypeInterruptStatus
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW Property

IRD

Adt7516InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW Property

Interrupt Status 1: T_EXT > T_HIGH / AIN1 > V_HIGH / AIN1 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeInterruptStatus InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW { get; }
Public ReadOnly Property InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW As Adt7516TypeInterruptStatus
    Get
public:
property Adt7516TypeInterruptStatus InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW {
    Adt7516TypeInterruptStatus get ();
}
member InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW : Adt7516TypeInterruptStatus with get

Property Value

Type: Adt7516TypeInterruptStatus
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InterruptStatus1TEXTTLOW Property

IRD

Adt7516InterruptStatus1TEXTTLOW Property

Interrupt Status 1: T_EXT <= T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeInterruptStatus InterruptStatus1TEXTTLOW { get; }
Public ReadOnly Property InterruptStatus1TEXTTLOW As Adt7516TypeInterruptStatus
    Get
public:
property Adt7516TypeInterruptStatus InterruptStatus1TEXTTLOW {
    Adt7516TypeInterruptStatus get ();
}
member InterruptStatus1TEXTTLOW : Adt7516TypeInterruptStatus with get

Property Value

Type: Adt7516TypeInterruptStatus
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InterruptStatus1TINTTHIGH Property

IRD

Adt7516InterruptStatus1TINTTHIGH Property

Interrupt Status 1: T_INT > T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeInterruptStatus InterruptStatus1TINTTHIGH { get; }
Public ReadOnly Property InterruptStatus1TINTTHIGH As Adt7516TypeInterruptStatus
    Get
public:
property Adt7516TypeInterruptStatus InterruptStatus1TINTTHIGH {
    Adt7516TypeInterruptStatus get ();
}
member InterruptStatus1TINTTHIGH : Adt7516TypeInterruptStatus with get

Property Value

Type: Adt7516TypeInterruptStatus
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InterruptStatus1TINTTLOW Property

IRD

Adt7516InterruptStatus1TINTTLOW Property

Interrupt Status 1: T_INT <= T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeInterruptStatus InterruptStatus1TINTTLOW { get; }
Public ReadOnly Property InterruptStatus1TINTTLOW As Adt7516TypeInterruptStatus
    Get
public:
property Adt7516TypeInterruptStatus InterruptStatus1TINTTLOW {
    Adt7516TypeInterruptStatus get ();
}
member InterruptStatus1TINTTLOW : Adt7516TypeInterruptStatus with get

Property Value

Type: Adt7516TypeInterruptStatus
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.InterruptStatus2VDDVHIGHVDDVLOW Property

IRD

Adt7516InterruptStatus2VDDVHIGHVDDVLOW Property

Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeInterruptStatus InterruptStatus2VDDVHIGHVDDVLOW { get; }
Public ReadOnly Property InterruptStatus2VDDVHIGHVDDVLOW As Adt7516TypeInterruptStatus
    Get
public:
property Adt7516TypeInterruptStatus InterruptStatus2VDDVHIGHVDDVLOW {
    Adt7516TypeInterruptStatus get ();
}
member InterruptStatus2VDDVHIGHVDDVLOW : Adt7516TypeInterruptStatus with get

Property Value

Type: Adt7516TypeInterruptStatus
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.LDACConfigurationDACA Property

IRD

Adt7516LDACConfigurationDACA Property

LDAC Configuration: DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeLdacConfigurationUpdate LDACConfigurationDACA { set; }
Public WriteOnly Property LDACConfigurationDACA As Adt7516TypeLdacConfigurationUpdate
    Set
public:
property Adt7516TypeLdacConfigurationUpdate LDACConfigurationDACA {
    void set (Adt7516TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACA : Adt7516TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7516TypeLdacConfigurationUpdate
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.LDACConfigurationDACB Property

IRD

Adt7516LDACConfigurationDACB Property

LDAC Configuration: DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeLdacConfigurationUpdate LDACConfigurationDACB { set; }
Public WriteOnly Property LDACConfigurationDACB As Adt7516TypeLdacConfigurationUpdate
    Set
public:
property Adt7516TypeLdacConfigurationUpdate LDACConfigurationDACB {
    void set (Adt7516TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACB : Adt7516TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7516TypeLdacConfigurationUpdate
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.LDACConfigurationDACC Property

IRD

Adt7516LDACConfigurationDACC Property

LDAC Configuration: DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeLdacConfigurationUpdate LDACConfigurationDACC { set; }
Public WriteOnly Property LDACConfigurationDACC As Adt7516TypeLdacConfigurationUpdate
    Set
public:
property Adt7516TypeLdacConfigurationUpdate LDACConfigurationDACC {
    void set (Adt7516TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACC : Adt7516TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7516TypeLdacConfigurationUpdate
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.LDACConfigurationDACD Property

IRD

Adt7516LDACConfigurationDACD Property

LDAC Configuration: DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeLdacConfigurationUpdate LDACConfigurationDACD { set; }
Public WriteOnly Property LDACConfigurationDACD As Adt7516TypeLdacConfigurationUpdate
    Set
public:
property Adt7516TypeLdacConfigurationUpdate LDACConfigurationDACD {
    void set (Adt7516TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACD : Adt7516TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7516TypeLdacConfigurationUpdate
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.LDACConfigurationReferenceDACAB Property

IRD

Adt7516LDACConfigurationReferenceDACAB Property

LDAC Configuration: Reference DAC A / B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeLdacConfigurationReference LDACConfigurationReferenceDACAB { set; }
Public WriteOnly Property LDACConfigurationReferenceDACAB As Adt7516TypeLdacConfigurationReference
    Set
public:
property Adt7516TypeLdacConfigurationReference LDACConfigurationReferenceDACAB {
    void set (Adt7516TypeLdacConfigurationReference value);
}
member LDACConfigurationReferenceDACAB : Adt7516TypeLdacConfigurationReference with set

Property Value

Type: Adt7516TypeLdacConfigurationReference
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.LDACConfigurationReferenceDACCD Property

IRD

Adt7516LDACConfigurationReferenceDACCD Property

LDAC Configuration: Reference DAC C / D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeLdacConfigurationReference LDACConfigurationReferenceDACCD { set; }
Public WriteOnly Property LDACConfigurationReferenceDACCD As Adt7516TypeLdacConfigurationReference
    Set
public:
property Adt7516TypeLdacConfigurationReference LDACConfigurationReferenceDACCD {
    void set (Adt7516TypeLdacConfigurationReference value);
}
member LDACConfigurationReferenceDACCD : Adt7516TypeLdacConfigurationReference with set

Property Value

Type: Adt7516TypeLdacConfigurationReference
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.ManufacturerSID Property

IRD

Adt7516ManufacturerSID Property

Manufacturer's ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerSID { get; }
Public ReadOnly Property ManufacturerSID As Byte
    Get
public:
property unsigned char ManufacturerSID {
    unsigned char get ();
}
member ManufacturerSID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.SiliconRevisionStepping Property

IRD

Adt7516SiliconRevisionStepping Property

Silicon Revision: Stepping

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SiliconRevisionStepping { get; }
Public ReadOnly Property SiliconRevisionStepping As Byte
    Get
public:
property unsigned char SiliconRevisionStepping {
    unsigned char get ();
}
member SiliconRevisionStepping : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.SiliconRevisionVersion Property

IRD

Adt7516SiliconRevisionVersion Property

Silicon Revision: Version

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SiliconRevisionVersion { get; }
Public ReadOnly Property SiliconRevisionVersion As Byte
    Get
public:
property unsigned char SiliconRevisionVersion {
    unsigned char get ();
}
member SiliconRevisionVersion : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.SPILockStatus Property

IRD

Adt7516SPILockStatus Property

SPI Lock Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7516TypeSpiLockStatus SPILockStatus { get; }
Public ReadOnly Property SPILockStatus As Adt7516TypeSpiLockStatus
    Get
public:
property Adt7516TypeSpiLockStatus SPILockStatus {
    Adt7516TypeSpiLockStatus get ();
}
member SPILockStatus : Adt7516TypeSpiLockStatus with get

Property Value

Type: Adt7516TypeSpiLockStatus
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.VDD Property

IRD

Adt7516VDD Property

V_DD (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDD { get; }
Public ReadOnly Property VDD As Double
    Get
public:
property double VDD {
    double get ();
}
member VDD : float with get

Property Value

Type: Double
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.VDDVHIGHLimit Property

IRD

Adt7516VDDVHIGHLimit Property

V_DD V_HIGH Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDDVHIGHLimit { get; set; }
Public Property VDDVHIGHLimit As Double
    Get
    Set
public:
property double VDDVHIGHLimit {
    double get ();
    void set (double value);
}
member VDDVHIGHLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.VDDVLOWLimit Property

IRD

Adt7516VDDVLOWLimit Property

V_DD V_LOW Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDDVLOWLimit { get; set; }
Public Property VDDVLOWLimit As Double
    Get
    Set
public:
property double VDDVLOWLimit {
    double get ();
    void set (double value);
}
member VDDVLOWLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516 Methods

The Adt7516 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.Flush Method

IRD

Adt7516Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adt7516 Class
telos.Ird.AnalogDevices Namespace


Adt7516.TypeControlConfiguration1AinTdmSelection Enumeration

IRD

Adt7516TypeControlConfiguration1AinTdmSelection Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1AinTdmSelection
Public Enumeration TypeControlConfiguration1AinTdmSelection
public enum class TypeControlConfiguration1AinTdmSelection
type TypeControlConfiguration1AinTdmSelection
Members
Member name | Value | Description
AIN1AndAIN2 | 0 | AIN1 and AIN2
Reserved | 1 | Reserved
ExternalTDM | 2 | External TDM
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeControlConfiguration1IntOutput Enumeration

IRD

Adt7516TypeControlConfiguration1IntOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1IntOutput
Public Enumeration TypeControlConfiguration1IntOutput
public enum class TypeControlConfiguration1IntOutput
type TypeControlConfiguration1IntOutput
Members
Member name | Value | Description
INTOutputEnabled | 0 | INT Output: Enabled
INTOutputDisabled | 1 | INT Output: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeControlConfiguration1IntOutputPolarity Enumeration

IRD

Adt7516TypeControlConfiguration1IntOutputPolarity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1IntOutputPolarity
Public Enumeration TypeControlConfiguration1IntOutputPolarity
public enum class TypeControlConfiguration1IntOutputPolarity
type TypeControlConfiguration1IntOutputPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeControlConfiguration1LdacAin3 Enumeration

IRD

Adt7516TypeControlConfiguration1LdacAin3 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1LdacAin3
Public Enumeration TypeControlConfiguration1LdacAin3
public enum class TypeControlConfiguration1LdacAin3
type TypeControlConfiguration1LdacAin3
Members
Member name | Value | Description
LDAC | 0 | LDAC
AIN3 | 1 | AIN3
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeControlConfiguration1Monitoring Enumeration

IRD

Adt7516TypeControlConfiguration1Monitoring Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1Monitoring
Public Enumeration TypeControlConfiguration1Monitoring
public enum class TypeControlConfiguration1Monitoring
type TypeControlConfiguration1Monitoring
Members
Member name | Value | Description
StopMonitoring | 0 | Stop Monitoring
StartMonitoring | 1 | Start Monitoring
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeControlConfiguration1PowerDown Enumeration

IRD

Adt7516TypeControlConfiguration1PowerDown Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1PowerDown
Public Enumeration TypeControlConfiguration1PowerDown
public enum class TypeControlConfiguration1PowerDown
type TypeControlConfiguration1PowerDown
Members
Member name | Value | Description
PowerUp | 0 | Power Up
PowerDown | 1 | Power Down
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeControlConfiguration2Averaging Enumeration

IRD

Adt7516TypeControlConfiguration2Averaging Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Averaging
Public Enumeration TypeControlConfiguration2Averaging
public enum class TypeControlConfiguration2Averaging
type TypeControlConfiguration2Averaging
Members
Member name | Value | Description
AveragingEnabled | 0 | Averaging Enabled
AveragingDisabled | 1 | Averaging Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeControlConfiguration2ChannelSelection Enumeration

IRD

Adt7516TypeControlConfiguration2ChannelSelection Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2ChannelSelection
Public Enumeration TypeControlConfiguration2ChannelSelection
public enum class TypeControlConfiguration2ChannelSelection
type TypeControlConfiguration2ChannelSelection
Members
Member name | Value | Description
VDD | 0 | V_DD
InternalTemperatureSensor | 1 | Internal Temperature Sensor
ExternalTemperatureSensorAIN1 | 2 | External Temperature Sensor / AIN1
AIN2 | 3 | AIN2
AIN3 | 4 | AIN3
AIN4 | 5 | AIN4
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeControlConfiguration2Conversion Enumeration

IRD

Adt7516TypeControlConfiguration2Conversion Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Conversion
Public Enumeration TypeControlConfiguration2Conversion
public enum class TypeControlConfiguration2Conversion
type TypeControlConfiguration2Conversion
Members
Member name | Value | Description
RoundRobin | 0 | Round Robin
SingleChannel | 1 | Single Channel
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeControlConfiguration2SoftwareReset Enumeration

IRD

Adt7516TypeControlConfiguration2SoftwareReset Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2SoftwareReset
Public Enumeration TypeControlConfiguration2SoftwareReset
public enum class TypeControlConfiguration2SoftwareReset
type TypeControlConfiguration2SoftwareReset
Members
Member name | Value | Description
Default | 0 | Default
SoftwareReset | 1 | Software Reset
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeControlConfiguration2Timeout Enumeration

IRD

Adt7516TypeControlConfiguration2Timeout Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Timeout
Public Enumeration TypeControlConfiguration2Timeout
public enum class TypeControlConfiguration2Timeout
type TypeControlConfiguration2Timeout
Members
Member name | Value | Description
SMBusTimeoutDisabled | 0 | SMBus Timeout: Disabled
SMBusTimeoutEnabled | 1 | SMBus Timeout: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeControlConfiguration3AdcReference Enumeration

IRD

Adt7516TypeControlConfiguration3AdcReference Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3AdcReference
Public Enumeration TypeControlConfiguration3AdcReference
public enum class TypeControlConfiguration3AdcReference
type TypeControlConfiguration3AdcReference
Members
Member name | Value | Description
InternalVREF | 0 | Internal V_REF
VDD | 1 | V_DD
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeControlConfiguration3DacAOutput Enumeration

IRD

Adt7516TypeControlConfiguration3DacAOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3DacAOutput
Public Enumeration TypeControlConfiguration3DacAOutput
public enum class TypeControlConfiguration3DacAOutput
type TypeControlConfiguration3DacAOutput
Members
Member name | Value | Description
NotProportional | 0 | Not Proportional
Proportional | 1 | Proportional
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeControlConfiguration3DacBOutput Enumeration

IRD

Adt7516TypeControlConfiguration3DacBOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3DacBOutput
Public Enumeration TypeControlConfiguration3DacBOutput
public enum class TypeControlConfiguration3DacBOutput
type TypeControlConfiguration3DacBOutput
Members
Member name | Value | Description
NotProportional | 0 | Not Proportional
Proportional | 1 | Proportional
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeControlConfiguration3Resolution Enumeration

IRD

Adt7516TypeControlConfiguration3Resolution Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3Resolution
Public Enumeration TypeControlConfiguration3Resolution
public enum class TypeControlConfiguration3Resolution
type TypeControlConfiguration3Resolution
Members
Member name | Value | Description
Value_8Bit | 0 | 8-bit
Value_10Bit | 1 | 10-bit
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeControlConfiguration3Speed Enumeration

IRD

Adt7516TypeControlConfiguration3Speed Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3Speed
Public Enumeration TypeControlConfiguration3Speed
public enum class TypeControlConfiguration3Speed
type TypeControlConfiguration3Speed
Members
Member name | Value | Description
Value_14KHz | 0 | 1.4 kHz
Value_225KHz | 1 | 22.5 kHz
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeControlConfiguration3UpdatingDacOutputs Enumeration

IRD

Adt7516TypeControlConfiguration3UpdatingDacOutputs Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3UpdatingDacOutputs
Public Enumeration TypeControlConfiguration3UpdatingDacOutputs
public enum class TypeControlConfiguration3UpdatingDacOutputs
type TypeControlConfiguration3UpdatingDacOutputs
Members
Member name | Value | Description
LDACPin | 0 | LDAC Pin
DACLDACConfiguration | 1 | DAC & LDAC Configuration
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeDacConfigurationRange Enumeration

IRD

Adt7516TypeDacConfigurationRange Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacConfigurationRange
Public Enumeration TypeDacConfigurationRange
public enum class TypeDacConfigurationRange
type TypeDacConfigurationRange
Members
Member name | Value | Description
Value_0VToVREF | 0 | 0V to V_REF
Value_0VTo2VREF | 1 | 0V to 2 V_REF
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeDacConfigurationUpdate Enumeration

IRD

Adt7516TypeDacConfigurationUpdate Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacConfigurationUpdate
Public Enumeration TypeDacConfigurationUpdate
public enum class TypeDacConfigurationUpdate
type TypeDacConfigurationUpdate
Members
Member name | Value | Description
MSBWriteToAnyDACRegisterGeneratesLDACCommandThatUpdatesThatDACOnly | 0 | MSB write to any DAC register generates LDAC command that updates that DAC only
MSBWriteToDACBOrDACDRegisterGeneratesLDACCommandThatUpdatesDACAAndDACBOrDACCAndDACDRespectively | 1 | MSB write to DAC B or DAC D register generates LDAC command that updates DAC A and DAC B or DAC C and DAC D, respectively
MSBWriteToDACDRegisterGeneratesLDACCommandThatUpdatesAllFourDACs | 2 | MSB write to DAC D register generates LDAC command that updates all four DACs
LDACCommandGeneratedFromLDACRegister | 3 | LDAC command generated from LDAC register
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeInterruptMaskEnableDisable Enumeration

IRD

Adt7516TypeInterruptMaskEnableDisable Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptMaskEnableDisable
Public Enumeration TypeInterruptMaskEnableDisable
public enum class TypeInterruptMaskEnableDisable
type TypeInterruptMaskEnableDisable
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeInterruptStatus Enumeration

IRD

Adt7516TypeInterruptStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatus
Public Enumeration TypeInterruptStatus
public enum class TypeInterruptStatus
type TypeInterruptStatus
Members
Member name | Value | Description
NotSet | 0 | Not Set
Set | 1 | Set
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeLdacConfigurationReference Enumeration

IRD

Adt7516TypeLdacConfigurationReference Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLdacConfigurationReference
Public Enumeration TypeLdacConfigurationReference
public enum class TypeLdacConfigurationReference
type TypeLdacConfigurationReference
Members
Member name | Value | Description
ExternalVREF | 0 | External V_REF
InternelVREF | 1 | Internel V_REF
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeLdacConfigurationUpdate Enumeration

IRD

Adt7516TypeLdacConfigurationUpdate Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLdacConfigurationUpdate
Public Enumeration TypeLdacConfigurationUpdate
public enum class TypeLdacConfigurationUpdate
type TypeLdacConfigurationUpdate
Members
Member name | Value | Description
DoNotUpdate | 0 | Do Not Update
Update | 1 | Update
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7516.TypeSpiLockStatus Enumeration

IRD

Adt7516TypeSpiLockStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSpiLockStatus
Public Enumeration TypeSpiLockStatus
public enum class TypeSpiLockStatus
type TypeSpiLockStatus
Members
Member name | Value | Description
I2CInterface | 0 | I2C Interface
SPIInterfaceLocked | 1 | SPI Interface / Locked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517 Class

Analog Devices: ADT 7517
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdt7517

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adt7517
Public Class Adt7517
public ref class Adt7517
type Adt7517 =  class end

The Adt7517 type exposes the following members.

Constructors
 | Name | Description
Public method | Adt7517 | Constructor
Top
Properties
 | Name | Description
Public property | AIN2 | AIN2
Public property | AIN2VHIGHLimit | AIN2 V_HIGH Limit
Public property | AIN2VLOWLimit | AIN2 V_LOW Limit
Public property | AIN3 | AIN3
Public property | AIN3VHIGHLimit | AIN3 V_HIGH Limit
Public property | AIN3VLOWLimit | AIN3 V_LOW Limit
Public property | AIN4 | AIN4
Public property | AIN4VHIGHLimit | AIN4 V_HIGH Limit
Public property | AIN4VLOWLimit | AIN4 V_LOW Limit
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlConfiguration1INTOutput | Control Configuration 1: INT Output
Public property | ControlConfiguration1INTOutputPolarity | Control Configuration 1: INT Output Polarity
Public property | ControlConfiguration1LDACAIN3 | Control Configuration 1: LDAC / AIN3
Public property | ControlConfiguration1Monitoring | Control Configuration 1: Monitoring
Public property | ControlConfiguration1Pin7Pin8 | Control Configuration 1: Pin 7 / Pin 8
Public property | ControlConfiguration1PowerDown | Control Configuration 1: Power Down
Public property | ControlConfiguration2Averaging | Control Configuration 2: Averaging
Public property | ControlConfiguration2ChannelSelection | Control Configuration 2: Channel Selection
Public property | ControlConfiguration2Conversion | Control Configuration 2: Conversion
Public property | ControlConfiguration2SMBusTimeout | Control Configuration 2: SMBus Timeout
Public property | ControlConfiguration2SoftwareReset | Control Configuration 2: Software Reset
Public property | ControlConfiguration3ADCReference | Control Configuration 3: ADC Reference
Public property | ControlConfiguration3DACAOutputProportionalToInternalTemperature | Control Configuration 3: DAC A Output Proportional To Internal Temperature
Public property | ControlConfiguration3DACBOutputProportionalToExternalTemperature | Control Configuration 3: DAC B Output Proportional To External Temperature
Public property | ControlConfiguration3Resolution | Control Configuration 3: Resolution
Public property | ControlConfiguration3Speed | Control Configuration 3: Speed
Public property | ControlConfiguration3UpdatingOfDACOutputs | Control Configuration 3: Updating of DAC Outputs
Public property | DACA | DAC A
Public property | DACB | DAC B
Public property | DACC | DAC C
Public property | DACConfigurationOutputRangeDACA | DAC Configuration: Output Range DAC A
Public property | DACConfigurationOutputRangeDACB | DAC Configuration: Output Range DAC B
Public property | DACConfigurationOutputRangeDACC | DAC Configuration: Output Range DAC C
Public property | DACConfigurationOutputRangeDACD | DAC Configuration: Output Range DAC D
Public property | DACConfigurationUpdate | DAC Configuration: Update
Public property | DACD | DAC D
Public property | DeviceID | Device ID
Public property | ExternalAnalogTemperatureOffset | External Analog Temperature Offset (unit: °C)
Public property | ExternalTemperatureAIN1 | External Temperature / AIN1 (unit: °C)
Public property | ExternalTemperatureOffset | External Temperature Offset (unit: °C)
Public property | ExternalTHIGHAIN1VHIGHLimits | External T_HIGH/AIN1 V_HIGH Limits (unit: °C)
Public property | ExternalTLOWAIN1VLOWLimits | External T_LOW/AIN1 V_LOW Limits (unit: °C)
Public property | InternalAnalogTemperatureOffset | Internal Analog Temperature Offset (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | InternalTemperatureOffset | Internal Temperature Offset (unit: °C)
Public property | InternalTHIGHLimit | Internal T_HIGH Limit (unit: °C)
Public property | InternalTLOWLimit | Internal T_LOW Limit (unit: °C)
Public property | InterruptMask1AIN2 | Interrupt Mask 1: AIN2
Public property | InterruptMask1AIN3 | Interrupt Mask 1: AIN3
Public property | InterruptMask1AIN4 | Interrupt Mask 1: AIN4
Public property | InterruptMask1ExternalTemperatureFault | Interrupt Mask 1: External Temperature Fault
Public property | InterruptMask1ExternalTHIGHAIN1 | Interrupt Mask 1: External T_HIGH / AIN1
Public property | InterruptMask1ExternalTLOW | Interrupt Mask 1: External T_LOW
Public property | InterruptMask1InternalTHIGH | Interrupt Mask 1: Internal T_HIGH
Public property | InterruptMask1InternalTLOW | Interrupt Mask 1: Internal T_LOW
Public property | InterruptMask2VDD | Interrupt Mask 2: V_DD
Public property | InterruptStatus1AIN2VHIGHAIN2VLOW | Interrupt Status 1: AIN2 > V_HIGH / AIN2 <= V_LOW
Public property | InterruptStatus1AIN3VHIGHAIN3VLOW | Interrupt Status 1: AIN3 > V_HIGH / AIN3 <= V_LOW
Public property | InterruptStatus1AIN4VHIGHAIN4VLOW | Interrupt Status 1: AIN4 > V_HIGH / AIN4 <= V_LOW
Public property | InterruptStatus1ExternalSensorFault | Interrupt Status 1: External Sensor Fault
Public property | InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW | Interrupt Status 1: T_EXT > T_HIGH / AIN1 > V_HIGH / AIN1 <= V_LOW
Public property | InterruptStatus1TEXTTLOW | Interrupt Status 1: T_EXT <= T_LOW
Public property | InterruptStatus1TINTTHIGH | Interrupt Status 1: T_INT > T_HIGH
Public property | InterruptStatus1TINTTLOW | Interrupt Status 1: T_INT <= T_LOW
Public property | InterruptStatus2VDDVHIGHVDDVLOW | Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW
Public property | LDACConfigurationDACA | LDAC Configuration: DAC A
Public property | LDACConfigurationDACB | LDAC Configuration: DAC B
Public property | LDACConfigurationDACC | LDAC Configuration: DAC C
Public property | LDACConfigurationDACD | LDAC Configuration: DAC D
Public property | LDACConfigurationReferenceDACAB | LDAC Configuration: Reference DAC A / B
Public property | LDACConfigurationReferenceDACCD | LDAC Configuration: Reference DAC C / D
Public property | ManufacturerSID | Manufacturer's ID
Public property | SiliconRevisionStepping | Silicon Revision: Stepping
Public property | SiliconRevisionVersion | Silicon Revision: Version
Public property | SPILockStatus | SPI Lock Status
Public property | VDD | V_DD (unit: V)
Public property | VDDVHIGHLimit | V_DD V_HIGH Limit (unit: V)
Public property | VDDVLOWLimit | V_DD V_LOW Limit (unit: V)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Temperature Sensor, 4-Channel ADC and Quad Voltage Output
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adt7517(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adt7517

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517 Properties

The Adt7517 type exposes the following members.

Properties
 | Name | Description
Public property | AIN2 | AIN2
Public property | AIN2VHIGHLimit | AIN2 V_HIGH Limit
Public property | AIN2VLOWLimit | AIN2 V_LOW Limit
Public property | AIN3 | AIN3
Public property | AIN3VHIGHLimit | AIN3 V_HIGH Limit
Public property | AIN3VLOWLimit | AIN3 V_LOW Limit
Public property | AIN4 | AIN4
Public property | AIN4VHIGHLimit | AIN4 V_HIGH Limit
Public property | AIN4VLOWLimit | AIN4 V_LOW Limit
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlConfiguration1INTOutput | Control Configuration 1: INT Output
Public property | ControlConfiguration1INTOutputPolarity | Control Configuration 1: INT Output Polarity
Public property | ControlConfiguration1LDACAIN3 | Control Configuration 1: LDAC / AIN3
Public property | ControlConfiguration1Monitoring | Control Configuration 1: Monitoring
Public property | ControlConfiguration1Pin7Pin8 | Control Configuration 1: Pin 7 / Pin 8
Public property | ControlConfiguration1PowerDown | Control Configuration 1: Power Down
Public property | ControlConfiguration2Averaging | Control Configuration 2: Averaging
Public property | ControlConfiguration2ChannelSelection | Control Configuration 2: Channel Selection
Public property | ControlConfiguration2Conversion | Control Configuration 2: Conversion
Public property | ControlConfiguration2SMBusTimeout | Control Configuration 2: SMBus Timeout
Public property | ControlConfiguration2SoftwareReset | Control Configuration 2: Software Reset
Public property | ControlConfiguration3ADCReference | Control Configuration 3: ADC Reference
Public property | ControlConfiguration3DACAOutputProportionalToInternalTemperature | Control Configuration 3: DAC A Output Proportional To Internal Temperature
Public property | ControlConfiguration3DACBOutputProportionalToExternalTemperature | Control Configuration 3: DAC B Output Proportional To External Temperature
Public property | ControlConfiguration3Resolution | Control Configuration 3: Resolution
Public property | ControlConfiguration3Speed | Control Configuration 3: Speed
Public property | ControlConfiguration3UpdatingOfDACOutputs | Control Configuration 3: Updating of DAC Outputs
Public property | DACA | DAC A
Public property | DACB | DAC B
Public property | DACC | DAC C
Public property | DACConfigurationOutputRangeDACA | DAC Configuration: Output Range DAC A
Public property | DACConfigurationOutputRangeDACB | DAC Configuration: Output Range DAC B
Public property | DACConfigurationOutputRangeDACC | DAC Configuration: Output Range DAC C
Public property | DACConfigurationOutputRangeDACD | DAC Configuration: Output Range DAC D
Public property | DACConfigurationUpdate | DAC Configuration: Update
Public property | DACD | DAC D
Public property | DeviceID | Device ID
Public property | ExternalAnalogTemperatureOffset | External Analog Temperature Offset (unit: °C)
Public property | ExternalTemperatureAIN1 | External Temperature / AIN1 (unit: °C)
Public property | ExternalTemperatureOffset | External Temperature Offset (unit: °C)
Public property | ExternalTHIGHAIN1VHIGHLimits | External T_HIGH/AIN1 V_HIGH Limits (unit: °C)
Public property | ExternalTLOWAIN1VLOWLimits | External T_LOW/AIN1 V_LOW Limits (unit: °C)
Public property | InternalAnalogTemperatureOffset | Internal Analog Temperature Offset (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | InternalTemperatureOffset | Internal Temperature Offset (unit: °C)
Public property | InternalTHIGHLimit | Internal T_HIGH Limit (unit: °C)
Public property | InternalTLOWLimit | Internal T_LOW Limit (unit: °C)
Public property | InterruptMask1AIN2 | Interrupt Mask 1: AIN2
Public property | InterruptMask1AIN3 | Interrupt Mask 1: AIN3
Public property | InterruptMask1AIN4 | Interrupt Mask 1: AIN4
Public property | InterruptMask1ExternalTemperatureFault | Interrupt Mask 1: External Temperature Fault
Public property | InterruptMask1ExternalTHIGHAIN1 | Interrupt Mask 1: External T_HIGH / AIN1
Public property | InterruptMask1ExternalTLOW | Interrupt Mask 1: External T_LOW
Public property | InterruptMask1InternalTHIGH | Interrupt Mask 1: Internal T_HIGH
Public property | InterruptMask1InternalTLOW | Interrupt Mask 1: Internal T_LOW
Public property | InterruptMask2VDD | Interrupt Mask 2: V_DD
Public property | InterruptStatus1AIN2VHIGHAIN2VLOW | Interrupt Status 1: AIN2 > V_HIGH / AIN2 <= V_LOW
Public property | InterruptStatus1AIN3VHIGHAIN3VLOW | Interrupt Status 1: AIN3 > V_HIGH / AIN3 <= V_LOW
Public property | InterruptStatus1AIN4VHIGHAIN4VLOW | Interrupt Status 1: AIN4 > V_HIGH / AIN4 <= V_LOW
Public property | InterruptStatus1ExternalSensorFault | Interrupt Status 1: External Sensor Fault
Public property | InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW | Interrupt Status 1: T_EXT > T_HIGH / AIN1 > V_HIGH / AIN1 <= V_LOW
Public property | InterruptStatus1TEXTTLOW | Interrupt Status 1: T_EXT <= T_LOW
Public property | InterruptStatus1TINTTHIGH | Interrupt Status 1: T_INT > T_HIGH
Public property | InterruptStatus1TINTTLOW | Interrupt Status 1: T_INT <= T_LOW
Public property | InterruptStatus2VDDVHIGHVDDVLOW | Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW
Public property | LDACConfigurationDACA | LDAC Configuration: DAC A
Public property | LDACConfigurationDACB | LDAC Configuration: DAC B
Public property | LDACConfigurationDACC | LDAC Configuration: DAC C
Public property | LDACConfigurationDACD | LDAC Configuration: DAC D
Public property | LDACConfigurationReferenceDACAB | LDAC Configuration: Reference DAC A / B
Public property | LDACConfigurationReferenceDACCD | LDAC Configuration: Reference DAC C / D
Public property | ManufacturerSID | Manufacturer's ID
Public property | SiliconRevisionStepping | Silicon Revision: Stepping
Public property | SiliconRevisionVersion | Silicon Revision: Version
Public property | SPILockStatus | SPI Lock Status
Public property | VDD | V_DD (unit: V)
Public property | VDDVHIGHLimit | V_DD V_HIGH Limit (unit: V)
Public property | VDDVLOWLimit | V_DD V_LOW Limit (unit: V)
Top
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.AIN2 Property

IRD

Adt7517AIN2 Property

AIN2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AIN2 { get; }
Public ReadOnly Property AIN2 As UShort
    Get
public:
property unsigned short AIN2 {
    unsigned short get ();
}
member AIN2 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.AIN2VHIGHLimit Property

IRD

Adt7517AIN2VHIGHLimit Property

AIN2 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN2VHIGHLimit { get; set; }
Public Property AIN2VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN2VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN2VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.AIN2VLOWLimit Property

IRD

Adt7517AIN2VLOWLimit Property

AIN2 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN2VLOWLimit { get; set; }
Public Property AIN2VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN2VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN2VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.AIN3 Property

IRD

Adt7517AIN3 Property

AIN3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AIN3 { get; }
Public ReadOnly Property AIN3 As UShort
    Get
public:
property unsigned short AIN3 {
    unsigned short get ();
}
member AIN3 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.AIN3VHIGHLimit Property

IRD

Adt7517AIN3VHIGHLimit Property

AIN3 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN3VHIGHLimit { get; set; }
Public Property AIN3VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN3VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN3VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.AIN3VLOWLimit Property

IRD

Adt7517AIN3VLOWLimit Property

AIN3 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN3VLOWLimit { get; set; }
Public Property AIN3VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN3VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN3VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.AIN4 Property

IRD

Adt7517AIN4 Property

AIN4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AIN4 { get; }
Public ReadOnly Property AIN4 As UShort
    Get
public:
property unsigned short AIN4 {
    unsigned short get ();
}
member AIN4 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.AIN4VHIGHLimit Property

IRD

Adt7517AIN4VHIGHLimit Property

AIN4 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN4VHIGHLimit { get; set; }
Public Property AIN4VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN4VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN4VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.AIN4VLOWLimit Property

IRD

Adt7517AIN4VLOWLimit Property

AIN4 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN4VLOWLimit { get; set; }
Public Property AIN4VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN4VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN4VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.AutoFlush Property

IRD

Adt7517AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ControlConfiguration1INTOutput Property

IRD

Adt7517ControlConfiguration1INTOutput Property

Control Configuration 1: INT Output

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeControlConfiguration1IntOutput ControlConfiguration1INTOutput { get; set; }
Public Property ControlConfiguration1INTOutput As Adt7517TypeControlConfiguration1IntOutput
    Get
    Set
public:
property Adt7517TypeControlConfiguration1IntOutput ControlConfiguration1INTOutput {
    Adt7517TypeControlConfiguration1IntOutput get ();
    void set (Adt7517TypeControlConfiguration1IntOutput value);
}
member ControlConfiguration1INTOutput : Adt7517TypeControlConfiguration1IntOutput with get, set

Property Value

Type: Adt7517TypeControlConfiguration1IntOutput
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ControlConfiguration1INTOutputPolarity Property

IRD

Adt7517ControlConfiguration1INTOutputPolarity Property

Control Configuration 1: INT Output Polarity

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeControlConfiguration1IntOutputPolarity ControlConfiguration1INTOutputPolarity { get; set; }
Public Property ControlConfiguration1INTOutputPolarity As Adt7517TypeControlConfiguration1IntOutputPolarity
    Get
    Set
public:
property Adt7517TypeControlConfiguration1IntOutputPolarity ControlConfiguration1INTOutputPolarity {
    Adt7517TypeControlConfiguration1IntOutputPolarity get ();
    void set (Adt7517TypeControlConfiguration1IntOutputPolarity value);
}
member ControlConfiguration1INTOutputPolarity : Adt7517TypeControlConfiguration1IntOutputPolarity with get, set

Property Value

Type: Adt7517TypeControlConfiguration1IntOutputPolarity
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ControlConfiguration1LDACAIN3 Property

IRD

Adt7517ControlConfiguration1LDACAIN3 Property

Control Configuration 1: LDAC / AIN3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeControlConfiguration1LdacAin3 ControlConfiguration1LDACAIN3 { get; set; }
Public Property ControlConfiguration1LDACAIN3 As Adt7517TypeControlConfiguration1LdacAin3
    Get
    Set
public:
property Adt7517TypeControlConfiguration1LdacAin3 ControlConfiguration1LDACAIN3 {
    Adt7517TypeControlConfiguration1LdacAin3 get ();
    void set (Adt7517TypeControlConfiguration1LdacAin3 value);
}
member ControlConfiguration1LDACAIN3 : Adt7517TypeControlConfiguration1LdacAin3 with get, set

Property Value

Type: Adt7517TypeControlConfiguration1LdacAin3
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ControlConfiguration1Monitoring Property

IRD

Adt7517ControlConfiguration1Monitoring Property

Control Configuration 1: Monitoring

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeControlConfiguration1Monitoring ControlConfiguration1Monitoring { get; set; }
Public Property ControlConfiguration1Monitoring As Adt7517TypeControlConfiguration1Monitoring
    Get
    Set
public:
property Adt7517TypeControlConfiguration1Monitoring ControlConfiguration1Monitoring {
    Adt7517TypeControlConfiguration1Monitoring get ();
    void set (Adt7517TypeControlConfiguration1Monitoring value);
}
member ControlConfiguration1Monitoring : Adt7517TypeControlConfiguration1Monitoring with get, set

Property Value

Type: Adt7517TypeControlConfiguration1Monitoring
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ControlConfiguration1Pin7Pin8 Property

IRD

Adt7517ControlConfiguration1Pin7Pin8 Property

Control Configuration 1: Pin 7 / Pin 8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeControlConfiguration1AinTdmSelection ControlConfiguration1Pin7Pin8 { get; set; }
Public Property ControlConfiguration1Pin7Pin8 As Adt7517TypeControlConfiguration1AinTdmSelection
    Get
    Set
public:
property Adt7517TypeControlConfiguration1AinTdmSelection ControlConfiguration1Pin7Pin8 {
    Adt7517TypeControlConfiguration1AinTdmSelection get ();
    void set (Adt7517TypeControlConfiguration1AinTdmSelection value);
}
member ControlConfiguration1Pin7Pin8 : Adt7517TypeControlConfiguration1AinTdmSelection with get, set

Property Value

Type: Adt7517TypeControlConfiguration1AinTdmSelection
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ControlConfiguration1PowerDown Property

IRD

Adt7517ControlConfiguration1PowerDown Property

Control Configuration 1: Power Down

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeControlConfiguration1PowerDown ControlConfiguration1PowerDown { get; set; }
Public Property ControlConfiguration1PowerDown As Adt7517TypeControlConfiguration1PowerDown
    Get
    Set
public:
property Adt7517TypeControlConfiguration1PowerDown ControlConfiguration1PowerDown {
    Adt7517TypeControlConfiguration1PowerDown get ();
    void set (Adt7517TypeControlConfiguration1PowerDown value);
}
member ControlConfiguration1PowerDown : Adt7517TypeControlConfiguration1PowerDown with get, set

Property Value

Type: Adt7517TypeControlConfiguration1PowerDown
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ControlConfiguration2Averaging Property

IRD

Adt7517ControlConfiguration2Averaging Property

Control Configuration 2: Averaging

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeControlConfiguration2Averaging ControlConfiguration2Averaging { get; set; }
Public Property ControlConfiguration2Averaging As Adt7517TypeControlConfiguration2Averaging
    Get
    Set
public:
property Adt7517TypeControlConfiguration2Averaging ControlConfiguration2Averaging {
    Adt7517TypeControlConfiguration2Averaging get ();
    void set (Adt7517TypeControlConfiguration2Averaging value);
}
member ControlConfiguration2Averaging : Adt7517TypeControlConfiguration2Averaging with get, set

Property Value

Type: Adt7517TypeControlConfiguration2Averaging
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ControlConfiguration2ChannelSelection Property

IRD

Adt7517ControlConfiguration2ChannelSelection Property

Control Configuration 2: Channel Selection

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeControlConfiguration2ChannelSelection ControlConfiguration2ChannelSelection { get; set; }
Public Property ControlConfiguration2ChannelSelection As Adt7517TypeControlConfiguration2ChannelSelection
    Get
    Set
public:
property Adt7517TypeControlConfiguration2ChannelSelection ControlConfiguration2ChannelSelection {
    Adt7517TypeControlConfiguration2ChannelSelection get ();
    void set (Adt7517TypeControlConfiguration2ChannelSelection value);
}
member ControlConfiguration2ChannelSelection : Adt7517TypeControlConfiguration2ChannelSelection with get, set

Property Value

Type: Adt7517TypeControlConfiguration2ChannelSelection
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ControlConfiguration2Conversion Property

IRD

Adt7517ControlConfiguration2Conversion Property

Control Configuration 2: Conversion

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeControlConfiguration2Conversion ControlConfiguration2Conversion { get; set; }
Public Property ControlConfiguration2Conversion As Adt7517TypeControlConfiguration2Conversion
    Get
    Set
public:
property Adt7517TypeControlConfiguration2Conversion ControlConfiguration2Conversion {
    Adt7517TypeControlConfiguration2Conversion get ();
    void set (Adt7517TypeControlConfiguration2Conversion value);
}
member ControlConfiguration2Conversion : Adt7517TypeControlConfiguration2Conversion with get, set

Property Value

Type: Adt7517TypeControlConfiguration2Conversion
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ControlConfiguration2SMBusTimeout Property

IRD

Adt7517ControlConfiguration2SMBusTimeout Property

Control Configuration 2: SMBus Timeout

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeControlConfiguration2Timeout ControlConfiguration2SMBusTimeout { get; set; }
Public Property ControlConfiguration2SMBusTimeout As Adt7517TypeControlConfiguration2Timeout
    Get
    Set
public:
property Adt7517TypeControlConfiguration2Timeout ControlConfiguration2SMBusTimeout {
    Adt7517TypeControlConfiguration2Timeout get ();
    void set (Adt7517TypeControlConfiguration2Timeout value);
}
member ControlConfiguration2SMBusTimeout : Adt7517TypeControlConfiguration2Timeout with get, set

Property Value

Type: Adt7517TypeControlConfiguration2Timeout
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ControlConfiguration2SoftwareReset Property

IRD

Adt7517ControlConfiguration2SoftwareReset Property

Control Configuration 2: Software Reset

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeControlConfiguration2SoftwareReset ControlConfiguration2SoftwareReset { get; set; }
Public Property ControlConfiguration2SoftwareReset As Adt7517TypeControlConfiguration2SoftwareReset
    Get
    Set
public:
property Adt7517TypeControlConfiguration2SoftwareReset ControlConfiguration2SoftwareReset {
    Adt7517TypeControlConfiguration2SoftwareReset get ();
    void set (Adt7517TypeControlConfiguration2SoftwareReset value);
}
member ControlConfiguration2SoftwareReset : Adt7517TypeControlConfiguration2SoftwareReset with get, set

Property Value

Type: Adt7517TypeControlConfiguration2SoftwareReset
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ControlConfiguration3ADCReference Property

IRD

Adt7517ControlConfiguration3ADCReference Property

Control Configuration 3: ADC Reference

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeControlConfiguration3AdcReference ControlConfiguration3ADCReference { get; set; }
Public Property ControlConfiguration3ADCReference As Adt7517TypeControlConfiguration3AdcReference
    Get
    Set
public:
property Adt7517TypeControlConfiguration3AdcReference ControlConfiguration3ADCReference {
    Adt7517TypeControlConfiguration3AdcReference get ();
    void set (Adt7517TypeControlConfiguration3AdcReference value);
}
member ControlConfiguration3ADCReference : Adt7517TypeControlConfiguration3AdcReference with get, set

Property Value

Type: Adt7517TypeControlConfiguration3AdcReference
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ControlConfiguration3DACAOutputProportionalToInternalTemperature Property

IRD

Adt7517ControlConfiguration3DACAOutputProportionalToInternalTemperature Property

Control Configuration 3: DAC A Output Proportional To Internal Temperature

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeControlConfiguration3DacAOutput ControlConfiguration3DACAOutputProportionalToInternalTemperature { get; set; }
Public Property ControlConfiguration3DACAOutputProportionalToInternalTemperature As Adt7517TypeControlConfiguration3DacAOutput
    Get
    Set
public:
property Adt7517TypeControlConfiguration3DacAOutput ControlConfiguration3DACAOutputProportionalToInternalTemperature {
    Adt7517TypeControlConfiguration3DacAOutput get ();
    void set (Adt7517TypeControlConfiguration3DacAOutput value);
}
member ControlConfiguration3DACAOutputProportionalToInternalTemperature : Adt7517TypeControlConfiguration3DacAOutput with get, set

Property Value

Type: Adt7517TypeControlConfiguration3DacAOutput
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ControlConfiguration3DACBOutputProportionalToExternalTemperature Property

IRD

Adt7517ControlConfiguration3DACBOutputProportionalToExternalTemperature Property

Control Configuration 3: DAC B Output Proportional To External Temperature

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeControlConfiguration3DacBOutput ControlConfiguration3DACBOutputProportionalToExternalTemperature { get; set; }
Public Property ControlConfiguration3DACBOutputProportionalToExternalTemperature As Adt7517TypeControlConfiguration3DacBOutput
    Get
    Set
public:
property Adt7517TypeControlConfiguration3DacBOutput ControlConfiguration3DACBOutputProportionalToExternalTemperature {
    Adt7517TypeControlConfiguration3DacBOutput get ();
    void set (Adt7517TypeControlConfiguration3DacBOutput value);
}
member ControlConfiguration3DACBOutputProportionalToExternalTemperature : Adt7517TypeControlConfiguration3DacBOutput with get, set

Property Value

Type: Adt7517TypeControlConfiguration3DacBOutput
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ControlConfiguration3Resolution Property

IRD

Adt7517ControlConfiguration3Resolution Property

Control Configuration 3: Resolution

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeControlConfiguration3Resolution ControlConfiguration3Resolution { get; set; }
Public Property ControlConfiguration3Resolution As Adt7517TypeControlConfiguration3Resolution
    Get
    Set
public:
property Adt7517TypeControlConfiguration3Resolution ControlConfiguration3Resolution {
    Adt7517TypeControlConfiguration3Resolution get ();
    void set (Adt7517TypeControlConfiguration3Resolution value);
}
member ControlConfiguration3Resolution : Adt7517TypeControlConfiguration3Resolution with get, set

Property Value

Type: Adt7517TypeControlConfiguration3Resolution
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ControlConfiguration3Speed Property

IRD

Adt7517ControlConfiguration3Speed Property

Control Configuration 3: Speed

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeControlConfiguration3Speed ControlConfiguration3Speed { get; set; }
Public Property ControlConfiguration3Speed As Adt7517TypeControlConfiguration3Speed
    Get
    Set
public:
property Adt7517TypeControlConfiguration3Speed ControlConfiguration3Speed {
    Adt7517TypeControlConfiguration3Speed get ();
    void set (Adt7517TypeControlConfiguration3Speed value);
}
member ControlConfiguration3Speed : Adt7517TypeControlConfiguration3Speed with get, set

Property Value

Type: Adt7517TypeControlConfiguration3Speed
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ControlConfiguration3UpdatingOfDACOutputs Property

IRD

Adt7517ControlConfiguration3UpdatingOfDACOutputs Property

Control Configuration 3: Updating of DAC Outputs

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeControlConfiguration3UpdatingDacOutputs ControlConfiguration3UpdatingOfDACOutputs { get; set; }
Public Property ControlConfiguration3UpdatingOfDACOutputs As Adt7517TypeControlConfiguration3UpdatingDacOutputs
    Get
    Set
public:
property Adt7517TypeControlConfiguration3UpdatingDacOutputs ControlConfiguration3UpdatingOfDACOutputs {
    Adt7517TypeControlConfiguration3UpdatingDacOutputs get ();
    void set (Adt7517TypeControlConfiguration3UpdatingDacOutputs value);
}
member ControlConfiguration3UpdatingOfDACOutputs : Adt7517TypeControlConfiguration3UpdatingDacOutputs with get, set

Property Value

Type: Adt7517TypeControlConfiguration3UpdatingDacOutputs
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.DACA Property

IRD

Adt7517DACA Property

DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DACA { get; set; }
Public Property DACA As UShort
    Get
    Set
public:
property unsigned short DACA {
    unsigned short get ();
    void set (unsigned short value);
}
member DACA : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.DACB Property

IRD

Adt7517DACB Property

DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DACB { get; set; }
Public Property DACB As UShort
    Get
    Set
public:
property unsigned short DACB {
    unsigned short get ();
    void set (unsigned short value);
}
member DACB : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.DACC Property

IRD

Adt7517DACC Property

DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DACC { get; set; }
Public Property DACC As UShort
    Get
    Set
public:
property unsigned short DACC {
    unsigned short get ();
    void set (unsigned short value);
}
member DACC : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.DACConfigurationOutputRangeDACA Property

IRD

Adt7517DACConfigurationOutputRangeDACA Property

DAC Configuration: Output Range DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeDacConfigurationRange DACConfigurationOutputRangeDACA { get; set; }
Public Property DACConfigurationOutputRangeDACA As Adt7517TypeDacConfigurationRange
    Get
    Set
public:
property Adt7517TypeDacConfigurationRange DACConfigurationOutputRangeDACA {
    Adt7517TypeDacConfigurationRange get ();
    void set (Adt7517TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACA : Adt7517TypeDacConfigurationRange with get, set

Property Value

Type: Adt7517TypeDacConfigurationRange
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.DACConfigurationOutputRangeDACB Property

IRD

Adt7517DACConfigurationOutputRangeDACB Property

DAC Configuration: Output Range DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeDacConfigurationRange DACConfigurationOutputRangeDACB { get; set; }
Public Property DACConfigurationOutputRangeDACB As Adt7517TypeDacConfigurationRange
    Get
    Set
public:
property Adt7517TypeDacConfigurationRange DACConfigurationOutputRangeDACB {
    Adt7517TypeDacConfigurationRange get ();
    void set (Adt7517TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACB : Adt7517TypeDacConfigurationRange with get, set

Property Value

Type: Adt7517TypeDacConfigurationRange
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.DACConfigurationOutputRangeDACC Property

IRD

Adt7517DACConfigurationOutputRangeDACC Property

DAC Configuration: Output Range DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeDacConfigurationRange DACConfigurationOutputRangeDACC { get; set; }
Public Property DACConfigurationOutputRangeDACC As Adt7517TypeDacConfigurationRange
    Get
    Set
public:
property Adt7517TypeDacConfigurationRange DACConfigurationOutputRangeDACC {
    Adt7517TypeDacConfigurationRange get ();
    void set (Adt7517TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACC : Adt7517TypeDacConfigurationRange with get, set

Property Value

Type: Adt7517TypeDacConfigurationRange
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.DACConfigurationOutputRangeDACD Property

IRD

Adt7517DACConfigurationOutputRangeDACD Property

DAC Configuration: Output Range DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeDacConfigurationRange DACConfigurationOutputRangeDACD { get; set; }
Public Property DACConfigurationOutputRangeDACD As Adt7517TypeDacConfigurationRange
    Get
    Set
public:
property Adt7517TypeDacConfigurationRange DACConfigurationOutputRangeDACD {
    Adt7517TypeDacConfigurationRange get ();
    void set (Adt7517TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACD : Adt7517TypeDacConfigurationRange with get, set

Property Value

Type: Adt7517TypeDacConfigurationRange
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.DACConfigurationUpdate Property

IRD

Adt7517DACConfigurationUpdate Property

DAC Configuration: Update

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeDacConfigurationUpdate DACConfigurationUpdate { get; set; }
Public Property DACConfigurationUpdate As Adt7517TypeDacConfigurationUpdate
    Get
    Set
public:
property Adt7517TypeDacConfigurationUpdate DACConfigurationUpdate {
    Adt7517TypeDacConfigurationUpdate get ();
    void set (Adt7517TypeDacConfigurationUpdate value);
}
member DACConfigurationUpdate : Adt7517TypeDacConfigurationUpdate with get, set

Property Value

Type: Adt7517TypeDacConfigurationUpdate
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.DACD Property

IRD

Adt7517DACD Property

DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DACD { get; set; }
Public Property DACD As UShort
    Get
    Set
public:
property unsigned short DACD {
    unsigned short get ();
    void set (unsigned short value);
}
member DACD : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.DeviceID Property

IRD

Adt7517DeviceID Property

Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ExternalAnalogTemperatureOffset Property

IRD

Adt7517ExternalAnalogTemperatureOffset Property

External Analog Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalAnalogTemperatureOffset { get; set; }
Public Property ExternalAnalogTemperatureOffset As SByte
    Get
    Set
public:
property signed char ExternalAnalogTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member ExternalAnalogTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ExternalTemperatureAIN1 Property

IRD

Adt7517ExternalTemperatureAIN1 Property

External Temperature / AIN1 (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ExternalTemperatureAIN1 { get; }
Public ReadOnly Property ExternalTemperatureAIN1 As Double
    Get
public:
property double ExternalTemperatureAIN1 {
    double get ();
}
member ExternalTemperatureAIN1 : float with get

Property Value

Type: Double
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ExternalTemperatureOffset Property

IRD

Adt7517ExternalTemperatureOffset Property

External Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperatureOffset { get; set; }
Public Property ExternalTemperatureOffset As SByte
    Get
    Set
public:
property signed char ExternalTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member ExternalTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ExternalTHIGHAIN1VHIGHLimits Property

IRD

Adt7517ExternalTHIGHAIN1VHIGHLimits Property

External T_HIGH/AIN1 V_HIGH Limits (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTHIGHAIN1VHIGHLimits { get; set; }
Public Property ExternalTHIGHAIN1VHIGHLimits As SByte
    Get
    Set
public:
property signed char ExternalTHIGHAIN1VHIGHLimits {
    signed char get ();
    void set (signed char value);
}
member ExternalTHIGHAIN1VHIGHLimits : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ExternalTLOWAIN1VLOWLimits Property

IRD

Adt7517ExternalTLOWAIN1VLOWLimits Property

External T_LOW/AIN1 V_LOW Limits (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTLOWAIN1VLOWLimits { get; set; }
Public Property ExternalTLOWAIN1VLOWLimits As SByte
    Get
    Set
public:
property signed char ExternalTLOWAIN1VLOWLimits {
    signed char get ();
    void set (signed char value);
}
member ExternalTLOWAIN1VLOWLimits : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InternalAnalogTemperatureOffset Property

IRD

Adt7517InternalAnalogTemperatureOffset Property

Internal Analog Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalAnalogTemperatureOffset { get; set; }
Public Property InternalAnalogTemperatureOffset As SByte
    Get
    Set
public:
property signed char InternalAnalogTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member InternalAnalogTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InternalTemperature Property

IRD

Adt7517InternalTemperature Property

Internal Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double InternalTemperature { get; }
Public ReadOnly Property InternalTemperature As Double
    Get
public:
property double InternalTemperature {
    double get ();
}
member InternalTemperature : float with get

Property Value

Type: Double
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InternalTemperatureOffset Property

IRD

Adt7517InternalTemperatureOffset Property

Internal Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureOffset { get; set; }
Public Property InternalTemperatureOffset As SByte
    Get
    Set
public:
property signed char InternalTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member InternalTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InternalTHIGHLimit Property

IRD

Adt7517InternalTHIGHLimit Property

Internal T_HIGH Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTHIGHLimit { get; set; }
Public Property InternalTHIGHLimit As SByte
    Get
    Set
public:
property signed char InternalTHIGHLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTHIGHLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InternalTLOWLimit Property

IRD

Adt7517InternalTLOWLimit Property

Internal T_LOW Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTLOWLimit { get; set; }
Public Property InternalTLOWLimit As SByte
    Get
    Set
public:
property signed char InternalTLOWLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTLOWLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InterruptMask1AIN2 Property

IRD

Adt7517InterruptMask1AIN2 Property

Interrupt Mask 1: AIN2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeInterruptMaskEnableDisable InterruptMask1AIN2 { get; set; }
Public Property InterruptMask1AIN2 As Adt7517TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7517TypeInterruptMaskEnableDisable InterruptMask1AIN2 {
    Adt7517TypeInterruptMaskEnableDisable get ();
    void set (Adt7517TypeInterruptMaskEnableDisable value);
}
member InterruptMask1AIN2 : Adt7517TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7517TypeInterruptMaskEnableDisable
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InterruptMask1AIN3 Property

IRD

Adt7517InterruptMask1AIN3 Property

Interrupt Mask 1: AIN3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeInterruptMaskEnableDisable InterruptMask1AIN3 { get; set; }
Public Property InterruptMask1AIN3 As Adt7517TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7517TypeInterruptMaskEnableDisable InterruptMask1AIN3 {
    Adt7517TypeInterruptMaskEnableDisable get ();
    void set (Adt7517TypeInterruptMaskEnableDisable value);
}
member InterruptMask1AIN3 : Adt7517TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7517TypeInterruptMaskEnableDisable
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InterruptMask1AIN4 Property

IRD

Adt7517InterruptMask1AIN4 Property

Interrupt Mask 1: AIN4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeInterruptMaskEnableDisable InterruptMask1AIN4 { get; set; }
Public Property InterruptMask1AIN4 As Adt7517TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7517TypeInterruptMaskEnableDisable InterruptMask1AIN4 {
    Adt7517TypeInterruptMaskEnableDisable get ();
    void set (Adt7517TypeInterruptMaskEnableDisable value);
}
member InterruptMask1AIN4 : Adt7517TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7517TypeInterruptMaskEnableDisable
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InterruptMask1ExternalTemperatureFault Property

IRD

Adt7517InterruptMask1ExternalTemperatureFault Property

Interrupt Mask 1: External Temperature Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeInterruptMaskEnableDisable InterruptMask1ExternalTemperatureFault { get; set; }
Public Property InterruptMask1ExternalTemperatureFault As Adt7517TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7517TypeInterruptMaskEnableDisable InterruptMask1ExternalTemperatureFault {
    Adt7517TypeInterruptMaskEnableDisable get ();
    void set (Adt7517TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTemperatureFault : Adt7517TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7517TypeInterruptMaskEnableDisable
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InterruptMask1ExternalTHIGHAIN1 Property

IRD

Adt7517InterruptMask1ExternalTHIGHAIN1 Property

Interrupt Mask 1: External T_HIGH / AIN1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeInterruptMaskEnableDisable InterruptMask1ExternalTHIGHAIN1 { get; set; }
Public Property InterruptMask1ExternalTHIGHAIN1 As Adt7517TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7517TypeInterruptMaskEnableDisable InterruptMask1ExternalTHIGHAIN1 {
    Adt7517TypeInterruptMaskEnableDisable get ();
    void set (Adt7517TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTHIGHAIN1 : Adt7517TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7517TypeInterruptMaskEnableDisable
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InterruptMask1ExternalTLOW Property

IRD

Adt7517InterruptMask1ExternalTLOW Property

Interrupt Mask 1: External T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeInterruptMaskEnableDisable InterruptMask1ExternalTLOW { get; set; }
Public Property InterruptMask1ExternalTLOW As Adt7517TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7517TypeInterruptMaskEnableDisable InterruptMask1ExternalTLOW {
    Adt7517TypeInterruptMaskEnableDisable get ();
    void set (Adt7517TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTLOW : Adt7517TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7517TypeInterruptMaskEnableDisable
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InterruptMask1InternalTHIGH Property

IRD

Adt7517InterruptMask1InternalTHIGH Property

Interrupt Mask 1: Internal T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeInterruptMaskEnableDisable InterruptMask1InternalTHIGH { get; set; }
Public Property InterruptMask1InternalTHIGH As Adt7517TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7517TypeInterruptMaskEnableDisable InterruptMask1InternalTHIGH {
    Adt7517TypeInterruptMaskEnableDisable get ();
    void set (Adt7517TypeInterruptMaskEnableDisable value);
}
member InterruptMask1InternalTHIGH : Adt7517TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7517TypeInterruptMaskEnableDisable
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InterruptMask1InternalTLOW Property

IRD

Adt7517InterruptMask1InternalTLOW Property

Interrupt Mask 1: Internal T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeInterruptMaskEnableDisable InterruptMask1InternalTLOW { get; set; }
Public Property InterruptMask1InternalTLOW As Adt7517TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7517TypeInterruptMaskEnableDisable InterruptMask1InternalTLOW {
    Adt7517TypeInterruptMaskEnableDisable get ();
    void set (Adt7517TypeInterruptMaskEnableDisable value);
}
member InterruptMask1InternalTLOW : Adt7517TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7517TypeInterruptMaskEnableDisable
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InterruptMask2VDD Property

IRD

Adt7517InterruptMask2VDD Property

Interrupt Mask 2: V_DD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeInterruptMaskEnableDisable InterruptMask2VDD { get; set; }
Public Property InterruptMask2VDD As Adt7517TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7517TypeInterruptMaskEnableDisable InterruptMask2VDD {
    Adt7517TypeInterruptMaskEnableDisable get ();
    void set (Adt7517TypeInterruptMaskEnableDisable value);
}
member InterruptMask2VDD : Adt7517TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7517TypeInterruptMaskEnableDisable
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InterruptStatus1AIN2VHIGHAIN2VLOW Property

IRD

Adt7517InterruptStatus1AIN2VHIGHAIN2VLOW Property

Interrupt Status 1: AIN2 > V_HIGH / AIN2 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeInterruptStatus InterruptStatus1AIN2VHIGHAIN2VLOW { get; }
Public ReadOnly Property InterruptStatus1AIN2VHIGHAIN2VLOW As Adt7517TypeInterruptStatus
    Get
public:
property Adt7517TypeInterruptStatus InterruptStatus1AIN2VHIGHAIN2VLOW {
    Adt7517TypeInterruptStatus get ();
}
member InterruptStatus1AIN2VHIGHAIN2VLOW : Adt7517TypeInterruptStatus with get

Property Value

Type: Adt7517TypeInterruptStatus
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InterruptStatus1AIN3VHIGHAIN3VLOW Property

IRD

Adt7517InterruptStatus1AIN3VHIGHAIN3VLOW Property

Interrupt Status 1: AIN3 > V_HIGH / AIN3 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeInterruptStatus InterruptStatus1AIN3VHIGHAIN3VLOW { get; }
Public ReadOnly Property InterruptStatus1AIN3VHIGHAIN3VLOW As Adt7517TypeInterruptStatus
    Get
public:
property Adt7517TypeInterruptStatus InterruptStatus1AIN3VHIGHAIN3VLOW {
    Adt7517TypeInterruptStatus get ();
}
member InterruptStatus1AIN3VHIGHAIN3VLOW : Adt7517TypeInterruptStatus with get

Property Value

Type: Adt7517TypeInterruptStatus
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InterruptStatus1AIN4VHIGHAIN4VLOW Property

IRD

Adt7517InterruptStatus1AIN4VHIGHAIN4VLOW Property

Interrupt Status 1: AIN4 > V_HIGH / AIN4 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeInterruptStatus InterruptStatus1AIN4VHIGHAIN4VLOW { get; }
Public ReadOnly Property InterruptStatus1AIN4VHIGHAIN4VLOW As Adt7517TypeInterruptStatus
    Get
public:
property Adt7517TypeInterruptStatus InterruptStatus1AIN4VHIGHAIN4VLOW {
    Adt7517TypeInterruptStatus get ();
}
member InterruptStatus1AIN4VHIGHAIN4VLOW : Adt7517TypeInterruptStatus with get

Property Value

Type: Adt7517TypeInterruptStatus
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InterruptStatus1ExternalSensorFault Property

IRD

Adt7517InterruptStatus1ExternalSensorFault Property

Interrupt Status 1: External Sensor Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeInterruptStatus InterruptStatus1ExternalSensorFault { get; }
Public ReadOnly Property InterruptStatus1ExternalSensorFault As Adt7517TypeInterruptStatus
    Get
public:
property Adt7517TypeInterruptStatus InterruptStatus1ExternalSensorFault {
    Adt7517TypeInterruptStatus get ();
}
member InterruptStatus1ExternalSensorFault : Adt7517TypeInterruptStatus with get

Property Value

Type: Adt7517TypeInterruptStatus
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW Property

IRD

Adt7517InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW Property

Interrupt Status 1: T_EXT > T_HIGH / AIN1 > V_HIGH / AIN1 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeInterruptStatus InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW { get; }
Public ReadOnly Property InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW As Adt7517TypeInterruptStatus
    Get
public:
property Adt7517TypeInterruptStatus InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW {
    Adt7517TypeInterruptStatus get ();
}
member InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW : Adt7517TypeInterruptStatus with get

Property Value

Type: Adt7517TypeInterruptStatus
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InterruptStatus1TEXTTLOW Property

IRD

Adt7517InterruptStatus1TEXTTLOW Property

Interrupt Status 1: T_EXT <= T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeInterruptStatus InterruptStatus1TEXTTLOW { get; }
Public ReadOnly Property InterruptStatus1TEXTTLOW As Adt7517TypeInterruptStatus
    Get
public:
property Adt7517TypeInterruptStatus InterruptStatus1TEXTTLOW {
    Adt7517TypeInterruptStatus get ();
}
member InterruptStatus1TEXTTLOW : Adt7517TypeInterruptStatus with get

Property Value

Type: Adt7517TypeInterruptStatus
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InterruptStatus1TINTTHIGH Property

IRD

Adt7517InterruptStatus1TINTTHIGH Property

Interrupt Status 1: T_INT > T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeInterruptStatus InterruptStatus1TINTTHIGH { get; }
Public ReadOnly Property InterruptStatus1TINTTHIGH As Adt7517TypeInterruptStatus
    Get
public:
property Adt7517TypeInterruptStatus InterruptStatus1TINTTHIGH {
    Adt7517TypeInterruptStatus get ();
}
member InterruptStatus1TINTTHIGH : Adt7517TypeInterruptStatus with get

Property Value

Type: Adt7517TypeInterruptStatus
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InterruptStatus1TINTTLOW Property

IRD

Adt7517InterruptStatus1TINTTLOW Property

Interrupt Status 1: T_INT <= T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeInterruptStatus InterruptStatus1TINTTLOW { get; }
Public ReadOnly Property InterruptStatus1TINTTLOW As Adt7517TypeInterruptStatus
    Get
public:
property Adt7517TypeInterruptStatus InterruptStatus1TINTTLOW {
    Adt7517TypeInterruptStatus get ();
}
member InterruptStatus1TINTTLOW : Adt7517TypeInterruptStatus with get

Property Value

Type: Adt7517TypeInterruptStatus
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.InterruptStatus2VDDVHIGHVDDVLOW Property

IRD

Adt7517InterruptStatus2VDDVHIGHVDDVLOW Property

Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeInterruptStatus InterruptStatus2VDDVHIGHVDDVLOW { get; }
Public ReadOnly Property InterruptStatus2VDDVHIGHVDDVLOW As Adt7517TypeInterruptStatus
    Get
public:
property Adt7517TypeInterruptStatus InterruptStatus2VDDVHIGHVDDVLOW {
    Adt7517TypeInterruptStatus get ();
}
member InterruptStatus2VDDVHIGHVDDVLOW : Adt7517TypeInterruptStatus with get

Property Value

Type: Adt7517TypeInterruptStatus
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.LDACConfigurationDACA Property

IRD

Adt7517LDACConfigurationDACA Property

LDAC Configuration: DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeLdacConfigurationUpdate LDACConfigurationDACA { set; }
Public WriteOnly Property LDACConfigurationDACA As Adt7517TypeLdacConfigurationUpdate
    Set
public:
property Adt7517TypeLdacConfigurationUpdate LDACConfigurationDACA {
    void set (Adt7517TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACA : Adt7517TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7517TypeLdacConfigurationUpdate
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.LDACConfigurationDACB Property

IRD

Adt7517LDACConfigurationDACB Property

LDAC Configuration: DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeLdacConfigurationUpdate LDACConfigurationDACB { set; }
Public WriteOnly Property LDACConfigurationDACB As Adt7517TypeLdacConfigurationUpdate
    Set
public:
property Adt7517TypeLdacConfigurationUpdate LDACConfigurationDACB {
    void set (Adt7517TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACB : Adt7517TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7517TypeLdacConfigurationUpdate
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.LDACConfigurationDACC Property

IRD

Adt7517LDACConfigurationDACC Property

LDAC Configuration: DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeLdacConfigurationUpdate LDACConfigurationDACC { set; }
Public WriteOnly Property LDACConfigurationDACC As Adt7517TypeLdacConfigurationUpdate
    Set
public:
property Adt7517TypeLdacConfigurationUpdate LDACConfigurationDACC {
    void set (Adt7517TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACC : Adt7517TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7517TypeLdacConfigurationUpdate
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.LDACConfigurationDACD Property

IRD

Adt7517LDACConfigurationDACD Property

LDAC Configuration: DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeLdacConfigurationUpdate LDACConfigurationDACD { set; }
Public WriteOnly Property LDACConfigurationDACD As Adt7517TypeLdacConfigurationUpdate
    Set
public:
property Adt7517TypeLdacConfigurationUpdate LDACConfigurationDACD {
    void set (Adt7517TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACD : Adt7517TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7517TypeLdacConfigurationUpdate
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.LDACConfigurationReferenceDACAB Property

IRD

Adt7517LDACConfigurationReferenceDACAB Property

LDAC Configuration: Reference DAC A / B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeLdacConfigurationReference LDACConfigurationReferenceDACAB { set; }
Public WriteOnly Property LDACConfigurationReferenceDACAB As Adt7517TypeLdacConfigurationReference
    Set
public:
property Adt7517TypeLdacConfigurationReference LDACConfigurationReferenceDACAB {
    void set (Adt7517TypeLdacConfigurationReference value);
}
member LDACConfigurationReferenceDACAB : Adt7517TypeLdacConfigurationReference with set

Property Value

Type: Adt7517TypeLdacConfigurationReference
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.LDACConfigurationReferenceDACCD Property

IRD

Adt7517LDACConfigurationReferenceDACCD Property

LDAC Configuration: Reference DAC C / D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeLdacConfigurationReference LDACConfigurationReferenceDACCD { set; }
Public WriteOnly Property LDACConfigurationReferenceDACCD As Adt7517TypeLdacConfigurationReference
    Set
public:
property Adt7517TypeLdacConfigurationReference LDACConfigurationReferenceDACCD {
    void set (Adt7517TypeLdacConfigurationReference value);
}
member LDACConfigurationReferenceDACCD : Adt7517TypeLdacConfigurationReference with set

Property Value

Type: Adt7517TypeLdacConfigurationReference
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.ManufacturerSID Property

IRD

Adt7517ManufacturerSID Property

Manufacturer's ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerSID { get; }
Public ReadOnly Property ManufacturerSID As Byte
    Get
public:
property unsigned char ManufacturerSID {
    unsigned char get ();
}
member ManufacturerSID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.SiliconRevisionStepping Property

IRD

Adt7517SiliconRevisionStepping Property

Silicon Revision: Stepping

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SiliconRevisionStepping { get; }
Public ReadOnly Property SiliconRevisionStepping As Byte
    Get
public:
property unsigned char SiliconRevisionStepping {
    unsigned char get ();
}
member SiliconRevisionStepping : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.SiliconRevisionVersion Property

IRD

Adt7517SiliconRevisionVersion Property

Silicon Revision: Version

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SiliconRevisionVersion { get; }
Public ReadOnly Property SiliconRevisionVersion As Byte
    Get
public:
property unsigned char SiliconRevisionVersion {
    unsigned char get ();
}
member SiliconRevisionVersion : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.SPILockStatus Property

IRD

Adt7517SPILockStatus Property

SPI Lock Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7517TypeSpiLockStatus SPILockStatus { get; }
Public ReadOnly Property SPILockStatus As Adt7517TypeSpiLockStatus
    Get
public:
property Adt7517TypeSpiLockStatus SPILockStatus {
    Adt7517TypeSpiLockStatus get ();
}
member SPILockStatus : Adt7517TypeSpiLockStatus with get

Property Value

Type: Adt7517TypeSpiLockStatus
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.VDD Property

IRD

Adt7517VDD Property

V_DD (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDD { get; }
Public ReadOnly Property VDD As Double
    Get
public:
property double VDD {
    double get ();
}
member VDD : float with get

Property Value

Type: Double
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.VDDVHIGHLimit Property

IRD

Adt7517VDDVHIGHLimit Property

V_DD V_HIGH Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDDVHIGHLimit { get; set; }
Public Property VDDVHIGHLimit As Double
    Get
    Set
public:
property double VDDVHIGHLimit {
    double get ();
    void set (double value);
}
member VDDVHIGHLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.VDDVLOWLimit Property

IRD

Adt7517VDDVLOWLimit Property

V_DD V_LOW Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDDVLOWLimit { get; set; }
Public Property VDDVLOWLimit As Double
    Get
    Set
public:
property double VDDVLOWLimit {
    double get ();
    void set (double value);
}
member VDDVLOWLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517 Methods

The Adt7517 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.Flush Method

IRD

Adt7517Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adt7517 Class
telos.Ird.AnalogDevices Namespace


Adt7517.TypeControlConfiguration1AinTdmSelection Enumeration

IRD

Adt7517TypeControlConfiguration1AinTdmSelection Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1AinTdmSelection
Public Enumeration TypeControlConfiguration1AinTdmSelection
public enum class TypeControlConfiguration1AinTdmSelection
type TypeControlConfiguration1AinTdmSelection
Members
Member name | Value | Description
AIN1AndAIN2 | 0 | AIN1 and AIN2
Reserved | 1 | Reserved
ExternalTDM | 2 | External TDM
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeControlConfiguration1IntOutput Enumeration

IRD

Adt7517TypeControlConfiguration1IntOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1IntOutput
Public Enumeration TypeControlConfiguration1IntOutput
public enum class TypeControlConfiguration1IntOutput
type TypeControlConfiguration1IntOutput
Members
Member name | Value | Description
INTOutputEnabled | 0 | INT Output: Enabled
INTOutputDisabled | 1 | INT Output: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeControlConfiguration1IntOutputPolarity Enumeration

IRD

Adt7517TypeControlConfiguration1IntOutputPolarity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1IntOutputPolarity
Public Enumeration TypeControlConfiguration1IntOutputPolarity
public enum class TypeControlConfiguration1IntOutputPolarity
type TypeControlConfiguration1IntOutputPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeControlConfiguration1LdacAin3 Enumeration

IRD

Adt7517TypeControlConfiguration1LdacAin3 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1LdacAin3
Public Enumeration TypeControlConfiguration1LdacAin3
public enum class TypeControlConfiguration1LdacAin3
type TypeControlConfiguration1LdacAin3
Members
Member name | Value | Description
LDAC | 0 | LDAC
AIN3 | 1 | AIN3
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeControlConfiguration1Monitoring Enumeration

IRD

Adt7517TypeControlConfiguration1Monitoring Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1Monitoring
Public Enumeration TypeControlConfiguration1Monitoring
public enum class TypeControlConfiguration1Monitoring
type TypeControlConfiguration1Monitoring
Members
Member name | Value | Description
StopMonitoring | 0 | Stop Monitoring
StartMonitoring | 1 | Start Monitoring
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeControlConfiguration1PowerDown Enumeration

IRD

Adt7517TypeControlConfiguration1PowerDown Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1PowerDown
Public Enumeration TypeControlConfiguration1PowerDown
public enum class TypeControlConfiguration1PowerDown
type TypeControlConfiguration1PowerDown
Members
Member name | Value | Description
PowerUp | 0 | Power Up
PowerDown | 1 | Power Down
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeControlConfiguration2Averaging Enumeration

IRD

Adt7517TypeControlConfiguration2Averaging Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Averaging
Public Enumeration TypeControlConfiguration2Averaging
public enum class TypeControlConfiguration2Averaging
type TypeControlConfiguration2Averaging
Members
Member name | Value | Description
AveragingEnabled | 0 | Averaging Enabled
AveragingDisabled | 1 | Averaging Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeControlConfiguration2ChannelSelection Enumeration

IRD

Adt7517TypeControlConfiguration2ChannelSelection Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2ChannelSelection
Public Enumeration TypeControlConfiguration2ChannelSelection
public enum class TypeControlConfiguration2ChannelSelection
type TypeControlConfiguration2ChannelSelection
Members
Member name | Value | Description
VDD | 0 | V_DD
InternalTemperatureSensor | 1 | Internal Temperature Sensor
ExternalTemperatureSensorAIN1 | 2 | External Temperature Sensor / AIN1
AIN2 | 3 | AIN2
AIN3 | 4 | AIN3
AIN4 | 5 | AIN4
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeControlConfiguration2Conversion Enumeration

IRD

Adt7517TypeControlConfiguration2Conversion Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Conversion
Public Enumeration TypeControlConfiguration2Conversion
public enum class TypeControlConfiguration2Conversion
type TypeControlConfiguration2Conversion
Members
Member name | Value | Description
RoundRobin | 0 | Round Robin
SingleChannel | 1 | Single Channel
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeControlConfiguration2SoftwareReset Enumeration

IRD

Adt7517TypeControlConfiguration2SoftwareReset Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2SoftwareReset
Public Enumeration TypeControlConfiguration2SoftwareReset
public enum class TypeControlConfiguration2SoftwareReset
type TypeControlConfiguration2SoftwareReset
Members
Member name | Value | Description
Default | 0 | Default
SoftwareReset | 1 | Software Reset
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeControlConfiguration2Timeout Enumeration

IRD

Adt7517TypeControlConfiguration2Timeout Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Timeout
Public Enumeration TypeControlConfiguration2Timeout
public enum class TypeControlConfiguration2Timeout
type TypeControlConfiguration2Timeout
Members
Member name | Value | Description
SMBusTimeoutDisabled | 0 | SMBus Timeout: Disabled
SMBusTimeoutEnabled | 1 | SMBus Timeout: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeControlConfiguration3AdcReference Enumeration

IRD

Adt7517TypeControlConfiguration3AdcReference Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3AdcReference
Public Enumeration TypeControlConfiguration3AdcReference
public enum class TypeControlConfiguration3AdcReference
type TypeControlConfiguration3AdcReference
Members
Member name | Value | Description
InternalVREF | 0 | Internal V_REF
VDD | 1 | V_DD
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeControlConfiguration3DacAOutput Enumeration

IRD

Adt7517TypeControlConfiguration3DacAOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3DacAOutput
Public Enumeration TypeControlConfiguration3DacAOutput
public enum class TypeControlConfiguration3DacAOutput
type TypeControlConfiguration3DacAOutput
Members
Member name | Value | Description
NotProportional | 0 | Not Proportional
Proportional | 1 | Proportional
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeControlConfiguration3DacBOutput Enumeration

IRD

Adt7517TypeControlConfiguration3DacBOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3DacBOutput
Public Enumeration TypeControlConfiguration3DacBOutput
public enum class TypeControlConfiguration3DacBOutput
type TypeControlConfiguration3DacBOutput
Members
Member name | Value | Description
NotProportional | 0 | Not Proportional
Proportional | 1 | Proportional
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeControlConfiguration3Resolution Enumeration

IRD

Adt7517TypeControlConfiguration3Resolution Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3Resolution
Public Enumeration TypeControlConfiguration3Resolution
public enum class TypeControlConfiguration3Resolution
type TypeControlConfiguration3Resolution
Members
Member name | Value | Description
Value_8Bit | 0 | 8-bit
Value_10Bit | 1 | 10-bit
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeControlConfiguration3Speed Enumeration

IRD

Adt7517TypeControlConfiguration3Speed Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3Speed
Public Enumeration TypeControlConfiguration3Speed
public enum class TypeControlConfiguration3Speed
type TypeControlConfiguration3Speed
Members
Member name | Value | Description
Value_14KHz | 0 | 1.4 kHz
Value_225KHz | 1 | 22.5 kHz
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeControlConfiguration3UpdatingDacOutputs Enumeration

IRD

Adt7517TypeControlConfiguration3UpdatingDacOutputs Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3UpdatingDacOutputs
Public Enumeration TypeControlConfiguration3UpdatingDacOutputs
public enum class TypeControlConfiguration3UpdatingDacOutputs
type TypeControlConfiguration3UpdatingDacOutputs
Members
Member name | Value | Description
LDACPin | 0 | LDAC Pin
DACLDACConfiguration | 1 | DAC & LDAC Configuration
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeDacConfigurationRange Enumeration

IRD

Adt7517TypeDacConfigurationRange Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacConfigurationRange
Public Enumeration TypeDacConfigurationRange
public enum class TypeDacConfigurationRange
type TypeDacConfigurationRange
Members
Member name | Value | Description
Value_0VToVREF | 0 | 0V to V_REF
Value_0VTo2VREF | 1 | 0V to 2 V_REF
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeDacConfigurationUpdate Enumeration

IRD

Adt7517TypeDacConfigurationUpdate Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacConfigurationUpdate
Public Enumeration TypeDacConfigurationUpdate
public enum class TypeDacConfigurationUpdate
type TypeDacConfigurationUpdate
Members
Member name | Value | Description
MSBWriteToAnyDACRegisterGeneratesLDACCommandThatUpdatesThatDACOnly | 0 | MSB write to any DAC register generates LDAC command that updates that DAC only
MSBWriteToDACBOrDACDRegisterGeneratesLDACCommandThatUpdatesDACAAndDACBOrDACCAndDACDRespectively | 1 | MSB write to DAC B or DAC D register generates LDAC command that updates DAC A and DAC B or DAC C and DAC D, respectively
MSBWriteToDACDRegisterGeneratesLDACCommandThatUpdatesAllFourDACs | 2 | MSB write to DAC D register generates LDAC command that updates all four DACs
LDACCommandGeneratedFromLDACRegister | 3 | LDAC command generated from LDAC register
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeInterruptMaskEnableDisable Enumeration

IRD

Adt7517TypeInterruptMaskEnableDisable Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptMaskEnableDisable
Public Enumeration TypeInterruptMaskEnableDisable
public enum class TypeInterruptMaskEnableDisable
type TypeInterruptMaskEnableDisable
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeInterruptStatus Enumeration

IRD

Adt7517TypeInterruptStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatus
Public Enumeration TypeInterruptStatus
public enum class TypeInterruptStatus
type TypeInterruptStatus
Members
Member name | Value | Description
NotSet | 0 | Not Set
Set | 1 | Set
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeLdacConfigurationReference Enumeration

IRD

Adt7517TypeLdacConfigurationReference Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLdacConfigurationReference
Public Enumeration TypeLdacConfigurationReference
public enum class TypeLdacConfigurationReference
type TypeLdacConfigurationReference
Members
Member name | Value | Description
ExternalVREF | 0 | External V_REF
InternelVREF | 1 | Internel V_REF
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeLdacConfigurationUpdate Enumeration

IRD

Adt7517TypeLdacConfigurationUpdate Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLdacConfigurationUpdate
Public Enumeration TypeLdacConfigurationUpdate
public enum class TypeLdacConfigurationUpdate
type TypeLdacConfigurationUpdate
Members
Member name | Value | Description
DoNotUpdate | 0 | Do Not Update
Update | 1 | Update
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7517.TypeSpiLockStatus Enumeration

IRD

Adt7517TypeSpiLockStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSpiLockStatus
Public Enumeration TypeSpiLockStatus
public enum class TypeSpiLockStatus
type TypeSpiLockStatus
Members
Member name | Value | Description
I2CInterface | 0 | I2C Interface
SPIInterfaceLocked | 1 | SPI Interface / Locked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518 Class

Analog Devices: ADT 7518
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdt7518

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adt7518
Public Class Adt7518
public ref class Adt7518
type Adt7518 =  class end

The Adt7518 type exposes the following members.

Constructors
 | Name | Description
Public method | Adt7518 | Constructor
Top
Properties
 | Name | Description
Public property | AIN2VHIGHLimit | AIN2 V_HIGH Limit
Public property | AIN2VLOWLimit | AIN2 V_LOW Limit
Public property | AIN3VHIGHLimit | AIN3 V_HIGH Limit
Public property | AIN3VLOWLimit | AIN3 V_LOW Limit
Public property | AIN4VHIGHLimit | AIN4 V_HIGH Limit
Public property | AIN4VLOWLimit | AIN4 V_LOW Limit
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlConfiguration1C0 | Control Configuration 1 (C0)
Public property | ControlConfiguration1C2C1 | Control Configuration 1 (C2:C1)
Public property | ControlConfiguration1C3 | Control Configuration 1 (C3)
Public property | ControlConfiguration1C5 | Control Configuration 1 (C5)
Public property | ControlConfiguration1C6 | Control Configuration 1 (C6)
Public property | ControlConfiguration1PD | Control Configuration 1 (PD)
Public property | ControlConfiguration2C20 | Control Configuration 2 (C2:0)
Public property | ControlConfiguration2C4 | Control Configuration 2 (C4)
Public property | ControlConfiguration2C5 | Control Configuration 2 (C5)
Public property | ControlConfiguration2C6 | Control Configuration 2 (C6)
Public property | ControlConfiguration2C7 | Control Configuration 2 (C7)
Public property | ControlConfiguration3C0 | Control Configuration 3 (C0)
Public property | ControlConfiguration3C3 | Control Configuration 3 (C3)
Public property | ControlConfiguration3C4 | Control Configuration 3 (C4)
Public property | ControlConfiguration3C5 | Control Configuration 3 (C5)
Public property | ControlConfiguration3C6 | Control Configuration 3 (C6)
Public property | DACA | DAC A
Public property | DACB | DAC B
Public property | DACC | DAC C
Public property | DACConfigurationD0 | DAC Configuration (D0)
Public property | DACConfigurationD1 | DAC Configuration (D1)
Public property | DACConfigurationD2 | DAC Configuration (D2)
Public property | DACConfigurationD3 | DAC Configuration (D3)
Public property | DACConfigurationD5D4 | DAC Configuration (D5:D4)
Public property | DACD | DAC D
Public property | DeviceID | Device ID
Public property | ExternalAnalogTempOffset | External Analog Temp Offset (unit: °C)
Public property | ExternalTemperatureInputAIN1 | External Temperature / Input AIN1
Public property | ExternalTempOffset | External Temp Offset (unit: °C)
Public property | ExternalTHIGHAIN1VHIGHLimit | External T_HIGH/AIN1 V_HIGH Limit
Public property | ExternalTLOWAIN1VLOWLimit | External T_LOW/AIN1 V_LOW Limit
Public property | InputAIN2 | Input AIN2
Public property | InputAIN3 | Input AIN3
Public property | InputAIN4 | Input AIN4
Public property | InternalAnalogTempOffset | Internal Analog Temp Offset (unit: °C)
Public property | InternalTemp | Internal Temp (unit: °C)
Public property | InternalTempOffset | Internal Temp Offset (unit: °C)
Public property | InternalTHIGHLimit | Internal T_HIGH Limit (unit: °C)
Public property | InternalTLOWLimit | Internal T_LOW Limit (unit: °C)
Public property | InterruptMask1D0 | Interrupt Mask 1 (D0)
Public property | InterruptMask1D1 | Interrupt Mask 1 (D1)
Public property | InterruptMask1D2 | Interrupt Mask 1 (D2)
Public property | InterruptMask1D3 | Interrupt Mask 1 (D3)
Public property | InterruptMask1D4 | Interrupt Mask 1 (D4)
Public property | InterruptMask1D5 | Interrupt Mask 1 (D5)
Public property | InterruptMask1D6 | Interrupt Mask 1 (D6)
Public property | InterruptMask1D7 | Interrupt Mask 1 (D7)
Public property | InterruptMask2D4 | Interrupt Mask 2 (D4)
Public property | InterruptStatus1D0 | Interrupt Status 1 (D0)
Public property | InterruptStatus1D1 | Interrupt Status 1 (D1)
Public property | InterruptStatus1D2 | Interrupt Status 1 (D2)
Public property | InterruptStatus1D3 | Interrupt Status 1 (D3)
Public property | InterruptStatus1D4 | Interrupt Status 1 (D4)
Public property | InterruptStatus1D5 | Interrupt Status 1 (D5)
Public property | InterruptStatus1D6 | Interrupt Status 1 (D6)
Public property | InterruptStatus1D7 | Interrupt Status 1 (D7)
Public property | InterruptStatus2D4 | Interrupt Status 2 (D4)
Public property | LDACConfigurationD0 | LDAC Configuration (D0)
Public property | LDACConfigurationD1 | LDAC Configuration (D1)
Public property | LDACConfigurationD2 | LDAC Configuration (D2)
Public property | LDACConfigurationD3 | LDAC Configuration (D3)
Public property | LDACConfigurationD4 | LDAC Configuration (D4)
Public property | LDACConfigurationD5 | LDAC Configuration (D5)
Public property | ManufacturerSID | Manufacturer's ID
Public property | SPILockStatus | SPI Lock Status
Public property | Stepping | Stepping
Public property | VDD | V_DD (unit: V)
Public property | VDDVHIGHLimit | V_DD V_HIGH Limit (unit: V)
Public property | VDDVLOWLimit | V_DD V_LOW Limit (unit: V)
Public property | Version | Version
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Temperature Sensor, 4-Channel ADC And Quad Voltage Output DAC
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adt7518(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adt7518

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518 Properties

The Adt7518 type exposes the following members.

Properties
 | Name | Description
Public property | AIN2VHIGHLimit | AIN2 V_HIGH Limit
Public property | AIN2VLOWLimit | AIN2 V_LOW Limit
Public property | AIN3VHIGHLimit | AIN3 V_HIGH Limit
Public property | AIN3VLOWLimit | AIN3 V_LOW Limit
Public property | AIN4VHIGHLimit | AIN4 V_HIGH Limit
Public property | AIN4VLOWLimit | AIN4 V_LOW Limit
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlConfiguration1C0 | Control Configuration 1 (C0)
Public property | ControlConfiguration1C2C1 | Control Configuration 1 (C2:C1)
Public property | ControlConfiguration1C3 | Control Configuration 1 (C3)
Public property | ControlConfiguration1C5 | Control Configuration 1 (C5)
Public property | ControlConfiguration1C6 | Control Configuration 1 (C6)
Public property | ControlConfiguration1PD | Control Configuration 1 (PD)
Public property | ControlConfiguration2C20 | Control Configuration 2 (C2:0)
Public property | ControlConfiguration2C4 | Control Configuration 2 (C4)
Public property | ControlConfiguration2C5 | Control Configuration 2 (C5)
Public property | ControlConfiguration2C6 | Control Configuration 2 (C6)
Public property | ControlConfiguration2C7 | Control Configuration 2 (C7)
Public property | ControlConfiguration3C0 | Control Configuration 3 (C0)
Public property | ControlConfiguration3C3 | Control Configuration 3 (C3)
Public property | ControlConfiguration3C4 | Control Configuration 3 (C4)
Public property | ControlConfiguration3C5 | Control Configuration 3 (C5)
Public property | ControlConfiguration3C6 | Control Configuration 3 (C6)
Public property | DACA | DAC A
Public property | DACB | DAC B
Public property | DACC | DAC C
Public property | DACConfigurationD0 | DAC Configuration (D0)
Public property | DACConfigurationD1 | DAC Configuration (D1)
Public property | DACConfigurationD2 | DAC Configuration (D2)
Public property | DACConfigurationD3 | DAC Configuration (D3)
Public property | DACConfigurationD5D4 | DAC Configuration (D5:D4)
Public property | DACD | DAC D
Public property | DeviceID | Device ID
Public property | ExternalAnalogTempOffset | External Analog Temp Offset (unit: °C)
Public property | ExternalTemperatureInputAIN1 | External Temperature / Input AIN1
Public property | ExternalTempOffset | External Temp Offset (unit: °C)
Public property | ExternalTHIGHAIN1VHIGHLimit | External T_HIGH/AIN1 V_HIGH Limit
Public property | ExternalTLOWAIN1VLOWLimit | External T_LOW/AIN1 V_LOW Limit
Public property | InputAIN2 | Input AIN2
Public property | InputAIN3 | Input AIN3
Public property | InputAIN4 | Input AIN4
Public property | InternalAnalogTempOffset | Internal Analog Temp Offset (unit: °C)
Public property | InternalTemp | Internal Temp (unit: °C)
Public property | InternalTempOffset | Internal Temp Offset (unit: °C)
Public property | InternalTHIGHLimit | Internal T_HIGH Limit (unit: °C)
Public property | InternalTLOWLimit | Internal T_LOW Limit (unit: °C)
Public property | InterruptMask1D0 | Interrupt Mask 1 (D0)
Public property | InterruptMask1D1 | Interrupt Mask 1 (D1)
Public property | InterruptMask1D2 | Interrupt Mask 1 (D2)
Public property | InterruptMask1D3 | Interrupt Mask 1 (D3)
Public property | InterruptMask1D4 | Interrupt Mask 1 (D4)
Public property | InterruptMask1D5 | Interrupt Mask 1 (D5)
Public property | InterruptMask1D6 | Interrupt Mask 1 (D6)
Public property | InterruptMask1D7 | Interrupt Mask 1 (D7)
Public property | InterruptMask2D4 | Interrupt Mask 2 (D4)
Public property | InterruptStatus1D0 | Interrupt Status 1 (D0)
Public property | InterruptStatus1D1 | Interrupt Status 1 (D1)
Public property | InterruptStatus1D2 | Interrupt Status 1 (D2)
Public property | InterruptStatus1D3 | Interrupt Status 1 (D3)
Public property | InterruptStatus1D4 | Interrupt Status 1 (D4)
Public property | InterruptStatus1D5 | Interrupt Status 1 (D5)
Public property | InterruptStatus1D6 | Interrupt Status 1 (D6)
Public property | InterruptStatus1D7 | Interrupt Status 1 (D7)
Public property | InterruptStatus2D4 | Interrupt Status 2 (D4)
Public property | LDACConfigurationD0 | LDAC Configuration (D0)
Public property | LDACConfigurationD1 | LDAC Configuration (D1)
Public property | LDACConfigurationD2 | LDAC Configuration (D2)
Public property | LDACConfigurationD3 | LDAC Configuration (D3)
Public property | LDACConfigurationD4 | LDAC Configuration (D4)
Public property | LDACConfigurationD5 | LDAC Configuration (D5)
Public property | ManufacturerSID | Manufacturer's ID
Public property | SPILockStatus | SPI Lock Status
Public property | Stepping | Stepping
Public property | VDD | V_DD (unit: V)
Public property | VDDVHIGHLimit | V_DD V_HIGH Limit (unit: V)
Public property | VDDVLOWLimit | V_DD V_LOW Limit (unit: V)
Public property | Version | Version
Top
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.AIN2VHIGHLimit Property

IRD

Adt7518AIN2VHIGHLimit Property

AIN2 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN2VHIGHLimit { get; set; }
Public Property AIN2VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN2VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN2VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.AIN2VLOWLimit Property

IRD

Adt7518AIN2VLOWLimit Property

AIN2 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN2VLOWLimit { get; set; }
Public Property AIN2VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN2VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN2VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.AIN3VHIGHLimit Property

IRD

Adt7518AIN3VHIGHLimit Property

AIN3 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN3VHIGHLimit { get; set; }
Public Property AIN3VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN3VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN3VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.AIN3VLOWLimit Property

IRD

Adt7518AIN3VLOWLimit Property

AIN3 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN3VLOWLimit { get; set; }
Public Property AIN3VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN3VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN3VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.AIN4VHIGHLimit Property

IRD

Adt7518AIN4VHIGHLimit Property

AIN4 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN4VHIGHLimit { get; set; }
Public Property AIN4VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN4VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN4VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.AIN4VLOWLimit Property

IRD

Adt7518AIN4VLOWLimit Property

AIN4 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN4VLOWLimit { get; set; }
Public Property AIN4VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN4VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN4VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.AutoFlush Property

IRD

Adt7518AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfiguration1C0 Property

IRD

Adt7518ControlConfiguration1C0 Property

Control Configuration 1 (C0)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518ControlConfig1C0Type ControlConfiguration1C0 { get; set; }
Public Property ControlConfiguration1C0 As Adt7518ControlConfig1C0Type
    Get
    Set
public:
property Adt7518ControlConfig1C0Type ControlConfiguration1C0 {
    Adt7518ControlConfig1C0Type get ();
    void set (Adt7518ControlConfig1C0Type value);
}
member ControlConfiguration1C0 : Adt7518ControlConfig1C0Type with get, set

Property Value

Type: Adt7518ControlConfig1C0Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfiguration1C2C1 Property

IRD

Adt7518ControlConfiguration1C2C1 Property

Control Configuration 1 (C2:C1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518ControlConfig1C12Type ControlConfiguration1C2C1 { get; set; }
Public Property ControlConfiguration1C2C1 As Adt7518ControlConfig1C12Type
    Get
    Set
public:
property Adt7518ControlConfig1C12Type ControlConfiguration1C2C1 {
    Adt7518ControlConfig1C12Type get ();
    void set (Adt7518ControlConfig1C12Type value);
}
member ControlConfiguration1C2C1 : Adt7518ControlConfig1C12Type with get, set

Property Value

Type: Adt7518ControlConfig1C12Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfiguration1C3 Property

IRD

Adt7518ControlConfiguration1C3 Property

Control Configuration 1 (C3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518ControlConfig1C3Type ControlConfiguration1C3 { get; set; }
Public Property ControlConfiguration1C3 As Adt7518ControlConfig1C3Type
    Get
    Set
public:
property Adt7518ControlConfig1C3Type ControlConfiguration1C3 {
    Adt7518ControlConfig1C3Type get ();
    void set (Adt7518ControlConfig1C3Type value);
}
member ControlConfiguration1C3 : Adt7518ControlConfig1C3Type with get, set

Property Value

Type: Adt7518ControlConfig1C3Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfiguration1C5 Property

IRD

Adt7518ControlConfiguration1C5 Property

Control Configuration 1 (C5)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518ControlConfig1C5Type ControlConfiguration1C5 { get; set; }
Public Property ControlConfiguration1C5 As Adt7518ControlConfig1C5Type
    Get
    Set
public:
property Adt7518ControlConfig1C5Type ControlConfiguration1C5 {
    Adt7518ControlConfig1C5Type get ();
    void set (Adt7518ControlConfig1C5Type value);
}
member ControlConfiguration1C5 : Adt7518ControlConfig1C5Type with get, set

Property Value

Type: Adt7518ControlConfig1C5Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfiguration1C6 Property

IRD

Adt7518ControlConfiguration1C6 Property

Control Configuration 1 (C6)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518ControlConfig1C6Type ControlConfiguration1C6 { get; set; }
Public Property ControlConfiguration1C6 As Adt7518ControlConfig1C6Type
    Get
    Set
public:
property Adt7518ControlConfig1C6Type ControlConfiguration1C6 {
    Adt7518ControlConfig1C6Type get ();
    void set (Adt7518ControlConfig1C6Type value);
}
member ControlConfiguration1C6 : Adt7518ControlConfig1C6Type with get, set

Property Value

Type: Adt7518ControlConfig1C6Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfiguration1PD Property

IRD

Adt7518ControlConfiguration1PD Property

Control Configuration 1 (PD)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518ControlConfig1PdType ControlConfiguration1PD { get; set; }
Public Property ControlConfiguration1PD As Adt7518ControlConfig1PdType
    Get
    Set
public:
property Adt7518ControlConfig1PdType ControlConfiguration1PD {
    Adt7518ControlConfig1PdType get ();
    void set (Adt7518ControlConfig1PdType value);
}
member ControlConfiguration1PD : Adt7518ControlConfig1PdType with get, set

Property Value

Type: Adt7518ControlConfig1PdType
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfiguration2C20 Property

IRD

Adt7518ControlConfiguration2C20 Property

Control Configuration 2 (C2:0)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518ControlConfig2C02Type ControlConfiguration2C20 { get; set; }
Public Property ControlConfiguration2C20 As Adt7518ControlConfig2C02Type
    Get
    Set
public:
property Adt7518ControlConfig2C02Type ControlConfiguration2C20 {
    Adt7518ControlConfig2C02Type get ();
    void set (Adt7518ControlConfig2C02Type value);
}
member ControlConfiguration2C20 : Adt7518ControlConfig2C02Type with get, set

Property Value

Type: Adt7518ControlConfig2C02Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfiguration2C4 Property

IRD

Adt7518ControlConfiguration2C4 Property

Control Configuration 2 (C4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518ControlConfig2C4Type ControlConfiguration2C4 { get; set; }
Public Property ControlConfiguration2C4 As Adt7518ControlConfig2C4Type
    Get
    Set
public:
property Adt7518ControlConfig2C4Type ControlConfiguration2C4 {
    Adt7518ControlConfig2C4Type get ();
    void set (Adt7518ControlConfig2C4Type value);
}
member ControlConfiguration2C4 : Adt7518ControlConfig2C4Type with get, set

Property Value

Type: Adt7518ControlConfig2C4Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfiguration2C5 Property

IRD

Adt7518ControlConfiguration2C5 Property

Control Configuration 2 (C5)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518ControlConfig2C5Type ControlConfiguration2C5 { get; set; }
Public Property ControlConfiguration2C5 As Adt7518ControlConfig2C5Type
    Get
    Set
public:
property Adt7518ControlConfig2C5Type ControlConfiguration2C5 {
    Adt7518ControlConfig2C5Type get ();
    void set (Adt7518ControlConfig2C5Type value);
}
member ControlConfiguration2C5 : Adt7518ControlConfig2C5Type with get, set

Property Value

Type: Adt7518ControlConfig2C5Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfiguration2C6 Property

IRD

Adt7518ControlConfiguration2C6 Property

Control Configuration 2 (C6)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518ControlConfig2C6Type ControlConfiguration2C6 { get; set; }
Public Property ControlConfiguration2C6 As Adt7518ControlConfig2C6Type
    Get
    Set
public:
property Adt7518ControlConfig2C6Type ControlConfiguration2C6 {
    Adt7518ControlConfig2C6Type get ();
    void set (Adt7518ControlConfig2C6Type value);
}
member ControlConfiguration2C6 : Adt7518ControlConfig2C6Type with get, set

Property Value

Type: Adt7518ControlConfig2C6Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfiguration2C7 Property

IRD

Adt7518ControlConfiguration2C7 Property

Control Configuration 2 (C7)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518ControlConfig2C7Type ControlConfiguration2C7 { get; set; }
Public Property ControlConfiguration2C7 As Adt7518ControlConfig2C7Type
    Get
    Set
public:
property Adt7518ControlConfig2C7Type ControlConfiguration2C7 {
    Adt7518ControlConfig2C7Type get ();
    void set (Adt7518ControlConfig2C7Type value);
}
member ControlConfiguration2C7 : Adt7518ControlConfig2C7Type with get, set

Property Value

Type: Adt7518ControlConfig2C7Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfiguration3C0 Property

IRD

Adt7518ControlConfiguration3C0 Property

Control Configuration 3 (C0)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518ControlConfig3C0Type ControlConfiguration3C0 { get; set; }
Public Property ControlConfiguration3C0 As Adt7518ControlConfig3C0Type
    Get
    Set
public:
property Adt7518ControlConfig3C0Type ControlConfiguration3C0 {
    Adt7518ControlConfig3C0Type get ();
    void set (Adt7518ControlConfig3C0Type value);
}
member ControlConfiguration3C0 : Adt7518ControlConfig3C0Type with get, set

Property Value

Type: Adt7518ControlConfig3C0Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfiguration3C3 Property

IRD

Adt7518ControlConfiguration3C3 Property

Control Configuration 3 (C3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518ControlConfig3C3Type ControlConfiguration3C3 { get; set; }
Public Property ControlConfiguration3C3 As Adt7518ControlConfig3C3Type
    Get
    Set
public:
property Adt7518ControlConfig3C3Type ControlConfiguration3C3 {
    Adt7518ControlConfig3C3Type get ();
    void set (Adt7518ControlConfig3C3Type value);
}
member ControlConfiguration3C3 : Adt7518ControlConfig3C3Type with get, set

Property Value

Type: Adt7518ControlConfig3C3Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfiguration3C4 Property

IRD

Adt7518ControlConfiguration3C4 Property

Control Configuration 3 (C4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518ControlConfig3C4Type ControlConfiguration3C4 { get; set; }
Public Property ControlConfiguration3C4 As Adt7518ControlConfig3C4Type
    Get
    Set
public:
property Adt7518ControlConfig3C4Type ControlConfiguration3C4 {
    Adt7518ControlConfig3C4Type get ();
    void set (Adt7518ControlConfig3C4Type value);
}
member ControlConfiguration3C4 : Adt7518ControlConfig3C4Type with get, set

Property Value

Type: Adt7518ControlConfig3C4Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfiguration3C5 Property

IRD

Adt7518ControlConfiguration3C5 Property

Control Configuration 3 (C5)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518ControlConfig3C5Type ControlConfiguration3C5 { get; set; }
Public Property ControlConfiguration3C5 As Adt7518ControlConfig3C5Type
    Get
    Set
public:
property Adt7518ControlConfig3C5Type ControlConfiguration3C5 {
    Adt7518ControlConfig3C5Type get ();
    void set (Adt7518ControlConfig3C5Type value);
}
member ControlConfiguration3C5 : Adt7518ControlConfig3C5Type with get, set

Property Value

Type: Adt7518ControlConfig3C5Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfiguration3C6 Property

IRD

Adt7518ControlConfiguration3C6 Property

Control Configuration 3 (C6)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518ControlConfig3C6Type ControlConfiguration3C6 { get; set; }
Public Property ControlConfiguration3C6 As Adt7518ControlConfig3C6Type
    Get
    Set
public:
property Adt7518ControlConfig3C6Type ControlConfiguration3C6 {
    Adt7518ControlConfig3C6Type get ();
    void set (Adt7518ControlConfig3C6Type value);
}
member ControlConfiguration3C6 : Adt7518ControlConfig3C6Type with get, set

Property Value

Type: Adt7518ControlConfig3C6Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.DACA Property

IRD

Adt7518DACA Property

DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACA { get; set; }
Public Property DACA As Byte
    Get
    Set
public:
property unsigned char DACA {
    unsigned char get ();
    void set (unsigned char value);
}
member DACA : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.DACB Property

IRD

Adt7518DACB Property

DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACB { get; set; }
Public Property DACB As Byte
    Get
    Set
public:
property unsigned char DACB {
    unsigned char get ();
    void set (unsigned char value);
}
member DACB : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.DACC Property

IRD

Adt7518DACC Property

DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACC { get; set; }
Public Property DACC As Byte
    Get
    Set
public:
property unsigned char DACC {
    unsigned char get ();
    void set (unsigned char value);
}
member DACC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.DACConfigurationD0 Property

IRD

Adt7518DACConfigurationD0 Property

DAC Configuration (D0)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518DacConfigD0Type DACConfigurationD0 { get; set; }
Public Property DACConfigurationD0 As Adt7518DacConfigD0Type
    Get
    Set
public:
property Adt7518DacConfigD0Type DACConfigurationD0 {
    Adt7518DacConfigD0Type get ();
    void set (Adt7518DacConfigD0Type value);
}
member DACConfigurationD0 : Adt7518DacConfigD0Type with get, set

Property Value

Type: Adt7518DacConfigD0Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.DACConfigurationD1 Property

IRD

Adt7518DACConfigurationD1 Property

DAC Configuration (D1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518DacConfigD1Type DACConfigurationD1 { get; set; }
Public Property DACConfigurationD1 As Adt7518DacConfigD1Type
    Get
    Set
public:
property Adt7518DacConfigD1Type DACConfigurationD1 {
    Adt7518DacConfigD1Type get ();
    void set (Adt7518DacConfigD1Type value);
}
member DACConfigurationD1 : Adt7518DacConfigD1Type with get, set

Property Value

Type: Adt7518DacConfigD1Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.DACConfigurationD2 Property

IRD

Adt7518DACConfigurationD2 Property

DAC Configuration (D2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518DacConfigD2Type DACConfigurationD2 { get; set; }
Public Property DACConfigurationD2 As Adt7518DacConfigD2Type
    Get
    Set
public:
property Adt7518DacConfigD2Type DACConfigurationD2 {
    Adt7518DacConfigD2Type get ();
    void set (Adt7518DacConfigD2Type value);
}
member DACConfigurationD2 : Adt7518DacConfigD2Type with get, set

Property Value

Type: Adt7518DacConfigD2Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.DACConfigurationD3 Property

IRD

Adt7518DACConfigurationD3 Property

DAC Configuration (D3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518DacConfigD3Type DACConfigurationD3 { get; set; }
Public Property DACConfigurationD3 As Adt7518DacConfigD3Type
    Get
    Set
public:
property Adt7518DacConfigD3Type DACConfigurationD3 {
    Adt7518DacConfigD3Type get ();
    void set (Adt7518DacConfigD3Type value);
}
member DACConfigurationD3 : Adt7518DacConfigD3Type with get, set

Property Value

Type: Adt7518DacConfigD3Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.DACConfigurationD5D4 Property

IRD

Adt7518DACConfigurationD5D4 Property

DAC Configuration (D5:D4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518DacConfigD45Type DACConfigurationD5D4 { get; set; }
Public Property DACConfigurationD5D4 As Adt7518DacConfigD45Type
    Get
    Set
public:
property Adt7518DacConfigD45Type DACConfigurationD5D4 {
    Adt7518DacConfigD45Type get ();
    void set (Adt7518DacConfigD45Type value);
}
member DACConfigurationD5D4 : Adt7518DacConfigD45Type with get, set

Property Value

Type: Adt7518DacConfigD45Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.DACD Property

IRD

Adt7518DACD Property

DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACD { get; set; }
Public Property DACD As Byte
    Get
    Set
public:
property unsigned char DACD {
    unsigned char get ();
    void set (unsigned char value);
}
member DACD : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.DeviceID Property

IRD

Adt7518DeviceID Property

Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ExternalAnalogTempOffset Property

IRD

Adt7518ExternalAnalogTempOffset Property

External Analog Temp Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalAnalogTempOffset { get; set; }
Public Property ExternalAnalogTempOffset As SByte
    Get
    Set
public:
property signed char ExternalAnalogTempOffset {
    signed char get ();
    void set (signed char value);
}
member ExternalAnalogTempOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ExternalTemperatureInputAIN1 Property

IRD

Adt7518ExternalTemperatureInputAIN1 Property

External Temperature / Input AIN1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ExternalTemperatureInputAIN1 { get; }
Public ReadOnly Property ExternalTemperatureInputAIN1 As UShort
    Get
public:
property unsigned short ExternalTemperatureInputAIN1 {
    unsigned short get ();
}
member ExternalTemperatureInputAIN1 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ExternalTempOffset Property

IRD

Adt7518ExternalTempOffset Property

External Temp Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTempOffset { get; set; }
Public Property ExternalTempOffset As SByte
    Get
    Set
public:
property signed char ExternalTempOffset {
    signed char get ();
    void set (signed char value);
}
member ExternalTempOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ExternalTHIGHAIN1VHIGHLimit Property

IRD

Adt7518ExternalTHIGHAIN1VHIGHLimit Property

External T_HIGH/AIN1 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTHIGHAIN1VHIGHLimit { get; set; }
Public Property ExternalTHIGHAIN1VHIGHLimit As SByte
    Get
    Set
public:
property signed char ExternalTHIGHAIN1VHIGHLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalTHIGHAIN1VHIGHLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ExternalTLOWAIN1VLOWLimit Property

IRD

Adt7518ExternalTLOWAIN1VLOWLimit Property

External T_LOW/AIN1 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTLOWAIN1VLOWLimit { get; set; }
Public Property ExternalTLOWAIN1VLOWLimit As SByte
    Get
    Set
public:
property signed char ExternalTLOWAIN1VLOWLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalTLOWAIN1VLOWLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InputAIN2 Property

IRD

Adt7518InputAIN2 Property

Input AIN2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort InputAIN2 { get; }
Public ReadOnly Property InputAIN2 As UShort
    Get
public:
property unsigned short InputAIN2 {
    unsigned short get ();
}
member InputAIN2 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InputAIN3 Property

IRD

Adt7518InputAIN3 Property

Input AIN3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort InputAIN3 { get; }
Public ReadOnly Property InputAIN3 As UShort
    Get
public:
property unsigned short InputAIN3 {
    unsigned short get ();
}
member InputAIN3 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InputAIN4 Property

IRD

Adt7518InputAIN4 Property

Input AIN4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort InputAIN4 { get; }
Public ReadOnly Property InputAIN4 As UShort
    Get
public:
property unsigned short InputAIN4 {
    unsigned short get ();
}
member InputAIN4 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InternalAnalogTempOffset Property

IRD

Adt7518InternalAnalogTempOffset Property

Internal Analog Temp Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalAnalogTempOffset { get; set; }
Public Property InternalAnalogTempOffset As SByte
    Get
    Set
public:
property signed char InternalAnalogTempOffset {
    signed char get ();
    void set (signed char value);
}
member InternalAnalogTempOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InternalTemp Property

IRD

Adt7518InternalTemp Property

Internal Temp (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double InternalTemp { get; }
Public ReadOnly Property InternalTemp As Double
    Get
public:
property double InternalTemp {
    double get ();
}
member InternalTemp : float with get

Property Value

Type: Double
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InternalTempOffset Property

IRD

Adt7518InternalTempOffset Property

Internal Temp Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTempOffset { get; set; }
Public Property InternalTempOffset As SByte
    Get
    Set
public:
property signed char InternalTempOffset {
    signed char get ();
    void set (signed char value);
}
member InternalTempOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InternalTHIGHLimit Property

IRD

Adt7518InternalTHIGHLimit Property

Internal T_HIGH Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTHIGHLimit { get; set; }
Public Property InternalTHIGHLimit As SByte
    Get
    Set
public:
property signed char InternalTHIGHLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTHIGHLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InternalTLOWLimit Property

IRD

Adt7518InternalTLOWLimit Property

Internal T_LOW Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTLOWLimit { get; set; }
Public Property InternalTLOWLimit As SByte
    Get
    Set
public:
property signed char InternalTLOWLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTLOWLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InterruptMask1D0 Property

IRD

Adt7518InterruptMask1D0 Property

Interrupt Mask 1 (D0)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518IrqMask1D0Type InterruptMask1D0 { get; set; }
Public Property InterruptMask1D0 As Adt7518IrqMask1D0Type
    Get
    Set
public:
property Adt7518IrqMask1D0Type InterruptMask1D0 {
    Adt7518IrqMask1D0Type get ();
    void set (Adt7518IrqMask1D0Type value);
}
member InterruptMask1D0 : Adt7518IrqMask1D0Type with get, set

Property Value

Type: Adt7518IrqMask1D0Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InterruptMask1D1 Property

IRD

Adt7518InterruptMask1D1 Property

Interrupt Mask 1 (D1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518IrqMask1D1Type InterruptMask1D1 { get; set; }
Public Property InterruptMask1D1 As Adt7518IrqMask1D1Type
    Get
    Set
public:
property Adt7518IrqMask1D1Type InterruptMask1D1 {
    Adt7518IrqMask1D1Type get ();
    void set (Adt7518IrqMask1D1Type value);
}
member InterruptMask1D1 : Adt7518IrqMask1D1Type with get, set

Property Value

Type: Adt7518IrqMask1D1Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InterruptMask1D2 Property

IRD

Adt7518InterruptMask1D2 Property

Interrupt Mask 1 (D2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518IrqMask1D2Type InterruptMask1D2 { get; set; }
Public Property InterruptMask1D2 As Adt7518IrqMask1D2Type
    Get
    Set
public:
property Adt7518IrqMask1D2Type InterruptMask1D2 {
    Adt7518IrqMask1D2Type get ();
    void set (Adt7518IrqMask1D2Type value);
}
member InterruptMask1D2 : Adt7518IrqMask1D2Type with get, set

Property Value

Type: Adt7518IrqMask1D2Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InterruptMask1D3 Property

IRD

Adt7518InterruptMask1D3 Property

Interrupt Mask 1 (D3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518IrqMask1D3Type InterruptMask1D3 { get; set; }
Public Property InterruptMask1D3 As Adt7518IrqMask1D3Type
    Get
    Set
public:
property Adt7518IrqMask1D3Type InterruptMask1D3 {
    Adt7518IrqMask1D3Type get ();
    void set (Adt7518IrqMask1D3Type value);
}
member InterruptMask1D3 : Adt7518IrqMask1D3Type with get, set

Property Value

Type: Adt7518IrqMask1D3Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InterruptMask1D4 Property

IRD

Adt7518InterruptMask1D4 Property

Interrupt Mask 1 (D4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518IrqMask1D0Type InterruptMask1D4 { get; set; }
Public Property InterruptMask1D4 As Adt7518IrqMask1D0Type
    Get
    Set
public:
property Adt7518IrqMask1D0Type InterruptMask1D4 {
    Adt7518IrqMask1D0Type get ();
    void set (Adt7518IrqMask1D0Type value);
}
member InterruptMask1D4 : Adt7518IrqMask1D0Type with get, set

Property Value

Type: Adt7518IrqMask1D0Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InterruptMask1D5 Property

IRD

Adt7518InterruptMask1D5 Property

Interrupt Mask 1 (D5)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518IrqMask1D0Type InterruptMask1D5 { get; set; }
Public Property InterruptMask1D5 As Adt7518IrqMask1D0Type
    Get
    Set
public:
property Adt7518IrqMask1D0Type InterruptMask1D5 {
    Adt7518IrqMask1D0Type get ();
    void set (Adt7518IrqMask1D0Type value);
}
member InterruptMask1D5 : Adt7518IrqMask1D0Type with get, set

Property Value

Type: Adt7518IrqMask1D0Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InterruptMask1D6 Property

IRD

Adt7518InterruptMask1D6 Property

Interrupt Mask 1 (D6)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518IrqMask1D0Type InterruptMask1D6 { get; set; }
Public Property InterruptMask1D6 As Adt7518IrqMask1D0Type
    Get
    Set
public:
property Adt7518IrqMask1D0Type InterruptMask1D6 {
    Adt7518IrqMask1D0Type get ();
    void set (Adt7518IrqMask1D0Type value);
}
member InterruptMask1D6 : Adt7518IrqMask1D0Type with get, set

Property Value

Type: Adt7518IrqMask1D0Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InterruptMask1D7 Property

IRD

Adt7518InterruptMask1D7 Property

Interrupt Mask 1 (D7)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518IrqMask1D0Type InterruptMask1D7 { get; set; }
Public Property InterruptMask1D7 As Adt7518IrqMask1D0Type
    Get
    Set
public:
property Adt7518IrqMask1D0Type InterruptMask1D7 {
    Adt7518IrqMask1D0Type get ();
    void set (Adt7518IrqMask1D0Type value);
}
member InterruptMask1D7 : Adt7518IrqMask1D0Type with get, set

Property Value

Type: Adt7518IrqMask1D0Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InterruptMask2D4 Property

IRD

Adt7518InterruptMask2D4 Property

Interrupt Mask 2 (D4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518IrqMask2D4Type InterruptMask2D4 { get; set; }
Public Property InterruptMask2D4 As Adt7518IrqMask2D4Type
    Get
    Set
public:
property Adt7518IrqMask2D4Type InterruptMask2D4 {
    Adt7518IrqMask2D4Type get ();
    void set (Adt7518IrqMask2D4Type value);
}
member InterruptMask2D4 : Adt7518IrqMask2D4Type with get, set

Property Value

Type: Adt7518IrqMask2D4Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InterruptStatus1D0 Property

IRD

Adt7518InterruptStatus1D0 Property

Interrupt Status 1 (D0)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518IrqStatus1D0Type InterruptStatus1D0 { get; }
Public ReadOnly Property InterruptStatus1D0 As Adt7518IrqStatus1D0Type
    Get
public:
property Adt7518IrqStatus1D0Type InterruptStatus1D0 {
    Adt7518IrqStatus1D0Type get ();
}
member InterruptStatus1D0 : Adt7518IrqStatus1D0Type with get

Property Value

Type: Adt7518IrqStatus1D0Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InterruptStatus1D1 Property

IRD

Adt7518InterruptStatus1D1 Property

Interrupt Status 1 (D1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518IrqStatus1D1Type InterruptStatus1D1 { get; }
Public ReadOnly Property InterruptStatus1D1 As Adt7518IrqStatus1D1Type
    Get
public:
property Adt7518IrqStatus1D1Type InterruptStatus1D1 {
    Adt7518IrqStatus1D1Type get ();
}
member InterruptStatus1D1 : Adt7518IrqStatus1D1Type with get

Property Value

Type: Adt7518IrqStatus1D1Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InterruptStatus1D2 Property

IRD

Adt7518InterruptStatus1D2 Property

Interrupt Status 1 (D2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518IrqStatus1D2Type InterruptStatus1D2 { get; }
Public ReadOnly Property InterruptStatus1D2 As Adt7518IrqStatus1D2Type
    Get
public:
property Adt7518IrqStatus1D2Type InterruptStatus1D2 {
    Adt7518IrqStatus1D2Type get ();
}
member InterruptStatus1D2 : Adt7518IrqStatus1D2Type with get

Property Value

Type: Adt7518IrqStatus1D2Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InterruptStatus1D3 Property

IRD

Adt7518InterruptStatus1D3 Property

Interrupt Status 1 (D3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518IrqStatus1D3Type InterruptStatus1D3 { get; }
Public ReadOnly Property InterruptStatus1D3 As Adt7518IrqStatus1D3Type
    Get
public:
property Adt7518IrqStatus1D3Type InterruptStatus1D3 {
    Adt7518IrqStatus1D3Type get ();
}
member InterruptStatus1D3 : Adt7518IrqStatus1D3Type with get

Property Value

Type: Adt7518IrqStatus1D3Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InterruptStatus1D4 Property

IRD

Adt7518InterruptStatus1D4 Property

Interrupt Status 1 (D4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518IrqStatus1D4Type InterruptStatus1D4 { get; }
Public ReadOnly Property InterruptStatus1D4 As Adt7518IrqStatus1D4Type
    Get
public:
property Adt7518IrqStatus1D4Type InterruptStatus1D4 {
    Adt7518IrqStatus1D4Type get ();
}
member InterruptStatus1D4 : Adt7518IrqStatus1D4Type with get

Property Value

Type: Adt7518IrqStatus1D4Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InterruptStatus1D5 Property

IRD

Adt7518InterruptStatus1D5 Property

Interrupt Status 1 (D5)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518IrqStatus1D5Type InterruptStatus1D5 { get; }
Public ReadOnly Property InterruptStatus1D5 As Adt7518IrqStatus1D5Type
    Get
public:
property Adt7518IrqStatus1D5Type InterruptStatus1D5 {
    Adt7518IrqStatus1D5Type get ();
}
member InterruptStatus1D5 : Adt7518IrqStatus1D5Type with get

Property Value

Type: Adt7518IrqStatus1D5Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InterruptStatus1D6 Property

IRD

Adt7518InterruptStatus1D6 Property

Interrupt Status 1 (D6)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518IrqStatus1D6Type InterruptStatus1D6 { get; }
Public ReadOnly Property InterruptStatus1D6 As Adt7518IrqStatus1D6Type
    Get
public:
property Adt7518IrqStatus1D6Type InterruptStatus1D6 {
    Adt7518IrqStatus1D6Type get ();
}
member InterruptStatus1D6 : Adt7518IrqStatus1D6Type with get

Property Value

Type: Adt7518IrqStatus1D6Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InterruptStatus1D7 Property

IRD

Adt7518InterruptStatus1D7 Property

Interrupt Status 1 (D7)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518IrqStatus1D7Type InterruptStatus1D7 { get; }
Public ReadOnly Property InterruptStatus1D7 As Adt7518IrqStatus1D7Type
    Get
public:
property Adt7518IrqStatus1D7Type InterruptStatus1D7 {
    Adt7518IrqStatus1D7Type get ();
}
member InterruptStatus1D7 : Adt7518IrqStatus1D7Type with get

Property Value

Type: Adt7518IrqStatus1D7Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.InterruptStatus2D4 Property

IRD

Adt7518InterruptStatus2D4 Property

Interrupt Status 2 (D4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518IrqStatus2D4Type InterruptStatus2D4 { get; }
Public ReadOnly Property InterruptStatus2D4 As Adt7518IrqStatus2D4Type
    Get
public:
property Adt7518IrqStatus2D4Type InterruptStatus2D4 {
    Adt7518IrqStatus2D4Type get ();
}
member InterruptStatus2D4 : Adt7518IrqStatus2D4Type with get

Property Value

Type: Adt7518IrqStatus2D4Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.LDACConfigurationD0 Property

IRD

Adt7518LDACConfigurationD0 Property

LDAC Configuration (D0)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518LdacConfigD0Type LDACConfigurationD0 { set; }
Public WriteOnly Property LDACConfigurationD0 As Adt7518LdacConfigD0Type
    Set
public:
property Adt7518LdacConfigD0Type LDACConfigurationD0 {
    void set (Adt7518LdacConfigD0Type value);
}
member LDACConfigurationD0 : Adt7518LdacConfigD0Type with set

Property Value

Type: Adt7518LdacConfigD0Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.LDACConfigurationD1 Property

IRD

Adt7518LDACConfigurationD1 Property

LDAC Configuration (D1)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518LdacConfigD1Type LDACConfigurationD1 { set; }
Public WriteOnly Property LDACConfigurationD1 As Adt7518LdacConfigD1Type
    Set
public:
property Adt7518LdacConfigD1Type LDACConfigurationD1 {
    void set (Adt7518LdacConfigD1Type value);
}
member LDACConfigurationD1 : Adt7518LdacConfigD1Type with set

Property Value

Type: Adt7518LdacConfigD1Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.LDACConfigurationD2 Property

IRD

Adt7518LDACConfigurationD2 Property

LDAC Configuration (D2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518LdacConfigD2Type LDACConfigurationD2 { set; }
Public WriteOnly Property LDACConfigurationD2 As Adt7518LdacConfigD2Type
    Set
public:
property Adt7518LdacConfigD2Type LDACConfigurationD2 {
    void set (Adt7518LdacConfigD2Type value);
}
member LDACConfigurationD2 : Adt7518LdacConfigD2Type with set

Property Value

Type: Adt7518LdacConfigD2Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.LDACConfigurationD3 Property

IRD

Adt7518LDACConfigurationD3 Property

LDAC Configuration (D3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518LdacConfigD3Type LDACConfigurationD3 { set; }
Public WriteOnly Property LDACConfigurationD3 As Adt7518LdacConfigD3Type
    Set
public:
property Adt7518LdacConfigD3Type LDACConfigurationD3 {
    void set (Adt7518LdacConfigD3Type value);
}
member LDACConfigurationD3 : Adt7518LdacConfigD3Type with set

Property Value

Type: Adt7518LdacConfigD3Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.LDACConfigurationD4 Property

IRD

Adt7518LDACConfigurationD4 Property

LDAC Configuration (D4)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518LdacConfigD4Type LDACConfigurationD4 { set; }
Public WriteOnly Property LDACConfigurationD4 As Adt7518LdacConfigD4Type
    Set
public:
property Adt7518LdacConfigD4Type LDACConfigurationD4 {
    void set (Adt7518LdacConfigD4Type value);
}
member LDACConfigurationD4 : Adt7518LdacConfigD4Type with set

Property Value

Type: Adt7518LdacConfigD4Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.LDACConfigurationD5 Property

IRD

Adt7518LDACConfigurationD5 Property

LDAC Configuration (D5)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518LdacConfigD5Type LDACConfigurationD5 { set; }
Public WriteOnly Property LDACConfigurationD5 As Adt7518LdacConfigD5Type
    Set
public:
property Adt7518LdacConfigD5Type LDACConfigurationD5 {
    void set (Adt7518LdacConfigD5Type value);
}
member LDACConfigurationD5 : Adt7518LdacConfigD5Type with set

Property Value

Type: Adt7518LdacConfigD5Type
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ManufacturerSID Property

IRD

Adt7518ManufacturerSID Property

Manufacturer's ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerSID { get; }
Public ReadOnly Property ManufacturerSID As Byte
    Get
public:
property unsigned char ManufacturerSID {
    unsigned char get ();
}
member ManufacturerSID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.SPILockStatus Property

IRD

Adt7518SPILockStatus Property

SPI Lock Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7518SpiLockType SPILockStatus { get; }
Public ReadOnly Property SPILockStatus As Adt7518SpiLockType
    Get
public:
property Adt7518SpiLockType SPILockStatus {
    Adt7518SpiLockType get ();
}
member SPILockStatus : Adt7518SpiLockType with get

Property Value

Type: Adt7518SpiLockType
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.Stepping Property

IRD

Adt7518Stepping Property

Stepping

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Stepping { get; }
Public ReadOnly Property Stepping As Byte
    Get
public:
property unsigned char Stepping {
    unsigned char get ();
}
member Stepping : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.VDD Property

IRD

Adt7518VDD Property

V_DD (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDD { get; }
Public ReadOnly Property VDD As Double
    Get
public:
property double VDD {
    double get ();
}
member VDD : float with get

Property Value

Type: Double
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.VDDVHIGHLimit Property

IRD

Adt7518VDDVHIGHLimit Property

V_DD V_HIGH Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDDVHIGHLimit { get; set; }
Public Property VDDVHIGHLimit As Double
    Get
    Set
public:
property double VDDVHIGHLimit {
    double get ();
    void set (double value);
}
member VDDVHIGHLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.VDDVLOWLimit Property

IRD

Adt7518VDDVLOWLimit Property

V_DD V_LOW Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDDVLOWLimit { get; set; }
Public Property VDDVLOWLimit As Double
    Get
    Set
public:
property double VDDVLOWLimit {
    double get ();
    void set (double value);
}
member VDDVLOWLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.Version Property

IRD

Adt7518Version Property

Version

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Version { get; }
Public ReadOnly Property Version As Byte
    Get
public:
property unsigned char Version {
    unsigned char get ();
}
member Version : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518 Methods

The Adt7518 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.Flush Method

IRD

Adt7518Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adt7518 Class
telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfig1C0Type Enumeration

IRD

Adt7518ControlConfig1C0Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlConfig1C0Type
Public Enumeration ControlConfig1C0Type
public enum class ControlConfig1C0Type
type ControlConfig1C0Type
Members
Member name | Value | Description
StartMonitoring | 1 | Start Monitoring
StopMonitoring | 0 | Stop Monitoring
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfig1C12Type Enumeration

IRD

Adt7518ControlConfig1C12Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlConfig1C12Type
Public Enumeration ControlConfig1C12Type
public enum class ControlConfig1C12Type
type ControlConfig1C12Type
Members
Member name | Value | Description
Undefined | 3 | Undefined
Pins78ExternalTDM | 2 | Pins 7/8: External TDM
Undefined__1 | 1 | Undefined
Pins78AIN1AndAIN2 | 0 | Pins 7/8: AIN1 And AIN2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfig1C3Type Enumeration

IRD

Adt7518ControlConfig1C3Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlConfig1C3Type
Public Enumeration ControlConfig1C3Type
public enum class ControlConfig1C3Type
type ControlConfig1C3Type
Members
Member name | Value | Description
Pin9AIN3 | 1 | Pin 9: AIN3
Pin9LDAC | 0 | Pin 9: LDAC
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfig1C5Type Enumeration

IRD

Adt7518ControlConfig1C5Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlConfig1C5Type
Public Enumeration ControlConfig1C5Type
public enum class ControlConfig1C5Type
type ControlConfig1C5Type
Members
Member name | Value | Description
DisableINTOutput | 1 | Disable INT Output
EnableINTOutput | 0 | Enable INT Output
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfig1C6Type Enumeration

IRD

Adt7518ControlConfig1C6Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlConfig1C6Type
Public Enumeration ControlConfig1C6Type
public enum class ControlConfig1C6Type
type ControlConfig1C6Type
Members
Member name | Value | Description
INTPolarityActiveHigh | 1 | INT Polarity: Active High
INTPolarityActiveLow | 0 | INT Polarity: Active Low
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfig1PdType Enumeration

IRD

Adt7518ControlConfig1PdType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlConfig1PdType
Public Enumeration ControlConfig1PdType
public enum class ControlConfig1PdType
type ControlConfig1PdType
Members
Member name | Value | Description
Standby | 1 | Standby
PowerUp | 0 | Power Up
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfig2C02Type Enumeration

IRD

Adt7518ControlConfig2C02Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlConfig2C02Type
Public Enumeration ControlConfig2C02Type
public enum class ControlConfig2C02Type
type ControlConfig2C02Type
Members
Member name | Value | Description
VDD | 0 | V_DD
InternalTemperatureSensor | 1 | Internal Temperature Sensor
ExternalTemperatureSensor | 2 | External Temperature Sensor
AIN2 | 3 | AIN2
AIN3 | 4 | AIN3
AIN4 | 5 | AIN4
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfig2C4Type Enumeration

IRD

Adt7518ControlConfig2C4Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlConfig2C4Type
Public Enumeration ControlConfig2C4Type
public enum class ControlConfig2C4Type
type ControlConfig2C4Type
Members
Member name | Value | Description
ConversionCycleRoundRobin | 0 | Conversion Cycle: Round Robin
ConversionCycleSingleChannel | 1 | Conversion Cycle: Single Channel
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfig2C5Type Enumeration

IRD

Adt7518ControlConfig2C5Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlConfig2C5Type
Public Enumeration ControlConfig2C5Type
public enum class ControlConfig2C5Type
type ControlConfig2C5Type
Members
Member name | Value | Description
AveragingEnabled | 0 | Averaging: Enabled
AveragingDisabled | 1 | Averaging: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfig2C6Type Enumeration

IRD

Adt7518ControlConfig2C6Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlConfig2C6Type
Public Enumeration ControlConfig2C6Type
public enum class ControlConfig2C6Type
type ControlConfig2C6Type
Members
Member name | Value | Description
SMBusTimeoutDisabled | 0 | SMBus Timeout: Disabled
SMBusTimeoutEnabled | 1 | SMBus Timeout: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfig2C7Type Enumeration

IRD

Adt7518ControlConfig2C7Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlConfig2C7Type
Public Enumeration ControlConfig2C7Type
public enum class ControlConfig2C7Type
type ControlConfig2C7Type
Members
Member name | Value | Description
Unmodified | 0 | Unmodified
SoftwareReset | 1 | Software Reset
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfig3C0Type Enumeration

IRD

Adt7518ControlConfig3C0Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlConfig3C0Type
Public Enumeration ControlConfig3C0Type
public enum class ControlConfig3C0Type
type ControlConfig3C0Type
Members
Member name | Value | Description
ADCClock14KHz | 0 | ADC Clock: 1.4 kHz
ADCClock225KHzDAndDAnalogFiltersDisabled | 1 | ADC Clock: 22.5 kHz / D+ And D- Analog Filters: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfig3C3Type Enumeration

IRD

Adt7518ControlConfig3C3Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlConfig3C3Type
Public Enumeration ControlConfig3C3Type
public enum class ControlConfig3C3Type
type ControlConfig3C3Type
Members
Member name | Value | Description
UpdatingOfDACOutputsControlledByLDACPin | 0 | Updating Of DAC Outputs: Controlled By LDAC Pin
UpdatingOfDACOutputsControlledByDACLDACConfigRegisters | 1 | Updating Of DAC Outputs: Controlled By DAC/LDAC Config Registers
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfig3C4Type Enumeration

IRD

Adt7518ControlConfig3C4Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlConfig3C4Type
Public Enumeration ControlConfig3C4Type
public enum class ControlConfig3C4Type
type ControlConfig3C4Type
Members
Member name | Value | Description
ADCReferenceInternalVREF | 0 | ADC Reference: Internal V_REF
ADCReferenceVDD | 1 | ADC Reference: V_DD
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfig3C5Type Enumeration

IRD

Adt7518ControlConfig3C5Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlConfig3C5Type
Public Enumeration ControlConfig3C5Type
public enum class ControlConfig3C5Type
type ControlConfig3C5Type
Members
Member name | Value | Description
Default | 0 | Default
DACAOutputProportionalToInternalTemperature | 1 | DAC A Output: Proportional To Internal Temperature
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.ControlConfig3C6Type Enumeration

IRD

Adt7518ControlConfig3C6Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlConfig3C6Type
Public Enumeration ControlConfig3C6Type
public enum class ControlConfig3C6Type
type ControlConfig3C6Type
Members
Member name | Value | Description
Default | 0 | Default
DACBOutputProportionalToExternalTemperature | 1 | DAC B Output: Proportional To External Temperature
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.DacConfigD0Type Enumeration

IRD

Adt7518DacConfigD0Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DacConfigD0Type
Public Enumeration DacConfigD0Type
public enum class DacConfigD0Type
type DacConfigD0Type
Members
Member name | Value | Description
OutputRangeDACA0VREF | 0 | Output Range DAC A: 0 .. V_REF
OutputRangeDACA02VREF | 1 | Output Range DAC A: 0 .. 2 V_REF
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.DacConfigD1Type Enumeration

IRD

Adt7518DacConfigD1Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DacConfigD1Type
Public Enumeration DacConfigD1Type
public enum class DacConfigD1Type
type DacConfigD1Type
Members
Member name | Value | Description
OutputRangeDACB0VREF | 0 | Output Range DAC B: 0 .. V_REF
OutputRangeDACB02VREF | 1 | Output Range DAC B: 0 .. 2 V_REF
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.DacConfigD2Type Enumeration

IRD

Adt7518DacConfigD2Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DacConfigD2Type
Public Enumeration DacConfigD2Type
public enum class DacConfigD2Type
type DacConfigD2Type
Members
Member name | Value | Description
OutputRangeDACC0VREF | 0 | Output Range DAC C: 0 .. V_REF
OutputRangeDACC02VREF | 1 | Output Range DAC C: 0 .. 2 V_REF
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.DacConfigD3Type Enumeration

IRD

Adt7518DacConfigD3Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DacConfigD3Type
Public Enumeration DacConfigD3Type
public enum class DacConfigD3Type
type DacConfigD3Type
Members
Member name | Value | Description
OutputRangeDACD0VREF | 0 | Output Range DAC D: 0 .. V_REF
OutputRangeDACD02VREF | 1 | Output Range DAC D: 0 .. 2 V_REF
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.DacConfigD45Type Enumeration

IRD

Adt7518DacConfigD45Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DacConfigD45Type
Public Enumeration DacConfigD45Type
public enum class DacConfigD45Type
type DacConfigD45Type
Members
Member name | Value | Description
WritingAnyDACRegisterLDACUpdateOnlyThisOne | 0 | Writing Any DAC Register: LDAC Update Only This One
WritingDACBOrDACDRegisterLDACUpdateABOrCD | 1 | Writing DAC B Or DAC D Register: LDAC Update A/B Or C/D
WritingDACDRegisterLDACUpdateAll | 2 | Writing DAC D Register: LDAC Update All
LDACGeneratedFromLDACRegister | 3 | LDAC Generated From LDAC Register
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.IrqMask1D0Type Enumeration

IRD

Adt7518IrqMask1D0Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqMask1D0Type
Public Enumeration IrqMask1D0Type
public enum class IrqMask1D0Type
type IrqMask1D0Type
Members
Member name | Value | Description
InternalTHIGHInterruptEnabled | 0 | Internal T_HIGH Interrupt: Enabled
InternalTHIGHInterruptDisabled | 1 | Internal T_HIGH Interrupt: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.IrqMask1D1Type Enumeration

IRD

Adt7518IrqMask1D1Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqMask1D1Type
Public Enumeration IrqMask1D1Type
public enum class IrqMask1D1Type
type IrqMask1D1Type
Members
Member name | Value | Description
InternalTLOWInterruptEnabled | 0 | Internal T_LOW Interrupt: Enabled
InternalTLOWInterruptDisabled | 1 | Internal T_LOW Interrupt: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.IrqMask1D2Type Enumeration

IRD

Adt7518IrqMask1D2Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqMask1D2Type
Public Enumeration IrqMask1D2Type
public enum class IrqMask1D2Type
type IrqMask1D2Type
Members
Member name | Value | Description
ExternalTHIGHAIN1InterruptEnabled | 0 | External T_HIGH / AIN1 Interrupt: Enabled
ExternalTHIGHAIN1InterruptDisabled | 1 | External T_HIGH / AIN1 Interrupt: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.IrqMask1D3Type Enumeration

IRD

Adt7518IrqMask1D3Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqMask1D3Type
Public Enumeration IrqMask1D3Type
public enum class IrqMask1D3Type
type IrqMask1D3Type
Members
Member name | Value | Description
ExternalTLOWInterruptEnabled | 0 | External T_LOW Interrupt: Enabled
ExternalTLOWInterruptDisabled | 1 | External T_LOW Interrupt: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.IrqMask1D4Type Enumeration

IRD

Adt7518IrqMask1D4Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqMask1D4Type
Public Enumeration IrqMask1D4Type
public enum class IrqMask1D4Type
type IrqMask1D4Type
Members
Member name | Value | Description
ExternalTemperatureFaultInterruptEnabled | 0 | External Temperature Fault Interrupt: Enabled
ExternalTemperatureFaultInterruptDisabled | 1 | External Temperature Fault Interrupt: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.IrqMask1D5Type Enumeration

IRD

Adt7518IrqMask1D5Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqMask1D5Type
Public Enumeration IrqMask1D5Type
public enum class IrqMask1D5Type
type IrqMask1D5Type
Members
Member name | Value | Description
AIN2InterruptEnabled | 0 | AIN2 Interrupt: Enabled
AIN2InterruptDisabled | 1 | AIN2 Interrupt: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.IrqMask1D6Type Enumeration

IRD

Adt7518IrqMask1D6Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqMask1D6Type
Public Enumeration IrqMask1D6Type
public enum class IrqMask1D6Type
type IrqMask1D6Type
Members
Member name | Value | Description
AIN3InterruptEnabled | 0 | AIN3 Interrupt: Enabled
AIN3InterruptDisabled | 1 | AIN3 Interrupt: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.IrqMask1D7Type Enumeration

IRD

Adt7518IrqMask1D7Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqMask1D7Type
Public Enumeration IrqMask1D7Type
public enum class IrqMask1D7Type
type IrqMask1D7Type
Members
Member name | Value | Description
AIN4InterruptEnabled | 0 | AIN4 Interrupt: Enabled
AIN4InterruptDisabled | 1 | AIN4 Interrupt: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.IrqMask2D4Type Enumeration

IRD

Adt7518IrqMask2D4Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqMask2D4Type
Public Enumeration IrqMask2D4Type
public enum class IrqMask2D4Type
type IrqMask2D4Type
Members
Member name | Value | Description
VDDInterruptsEnabled | 0 | V_DD Interrupts: Enabled
VDDInterruptsDisabled | 1 | V_DD Interrupts: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.IrqStatus1D0Type Enumeration

IRD

Adt7518IrqStatus1D0Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqStatus1D0Type
Public Enumeration IrqStatus1D0Type
public enum class IrqStatus1D0Type
type IrqStatus1D0Type
Members
Member name | Value | Description
InternalTempTHIGH | 1 | Internal Temp > T_HIGH
InternalTempTHIGH__1 | 0 | Internal Temp <= T_HIGH
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.IrqStatus1D1Type Enumeration

IRD

Adt7518IrqStatus1D1Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqStatus1D1Type
Public Enumeration IrqStatus1D1Type
public enum class IrqStatus1D1Type
type IrqStatus1D1Type
Members
Member name | Value | Description
InternalTempTLOW | 1 | Internal Temp <= T_LOW
InternalTempTLOW__1 | 0 | Internal Temp > T_LOW
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.IrqStatus1D2Type Enumeration

IRD

Adt7518IrqStatus1D2Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqStatus1D2Type
Public Enumeration IrqStatus1D2Type
public enum class IrqStatus1D2Type
type IrqStatus1D2Type
Members
Member name | Value | Description
ExternalTempTHIGHAIN1VHIGHLOWExceeded | 1 | External Temp > T_HIGH / AIN1: V_HIGH/LOW Exceeded
ExternalTempTHIGHAIN1VHIGHLOWNotExceeded | 0 | External Temp <= T_HIGH / AIN1: V_HIGH/LOW Not Exceeded
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.IrqStatus1D3Type Enumeration

IRD

Adt7518IrqStatus1D3Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqStatus1D3Type
Public Enumeration IrqStatus1D3Type
public enum class IrqStatus1D3Type
type IrqStatus1D3Type
Members
Member name | Value | Description
ExternalTempTLOW | 1 | External Temp <= T_LOW
ExternalTempTLOW__1 | 0 | External Temp > T_LOW
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.IrqStatus1D4Type Enumeration

IRD

Adt7518IrqStatus1D4Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqStatus1D4Type
Public Enumeration IrqStatus1D4Type
public enum class IrqStatus1D4Type
type IrqStatus1D4Type
Members
Member name | Value | Description
ExternalTemperatureSensorFault | 1 | External Temperature Sensor: Fault
ExternalTemperatureSensorOK | 0 | External Temperature Sensor: OK
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.IrqStatus1D5Type Enumeration

IRD

Adt7518IrqStatus1D5Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqStatus1D5Type
Public Enumeration IrqStatus1D5Type
public enum class IrqStatus1D5Type
type IrqStatus1D5Type
Members
Member name | Value | Description
AIN2VHIGHLOWExceeded | 1 | AIN2: V_HIGH/LOW Exceeded
AIN2VHIGHLOWNotExceeded | 0 | AIN2: V_HIGH/LOW Not Exceeded
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.IrqStatus1D6Type Enumeration

IRD

Adt7518IrqStatus1D6Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqStatus1D6Type
Public Enumeration IrqStatus1D6Type
public enum class IrqStatus1D6Type
type IrqStatus1D6Type
Members
Member name | Value | Description
AIN3VHIGHLOWExceeded | 1 | AIN3: V_HIGH/LOW Exceeded
AIN3VHIGHLOWNotExceeded | 0 | AIN3: V_HIGH/LOW Not Exceeded
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.IrqStatus1D7Type Enumeration

IRD

Adt7518IrqStatus1D7Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqStatus1D7Type
Public Enumeration IrqStatus1D7Type
public enum class IrqStatus1D7Type
type IrqStatus1D7Type
Members
Member name | Value | Description
AIN4VHIGHLOWExceeded | 1 | AIN4: V_HIGH/LOW Exceeded
AIN4VHIGHLOWNotExceeded | 0 | AIN4: V_HIGH/LOW Not Exceeded
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.IrqStatus2D4Type Enumeration

IRD

Adt7518IrqStatus2D4Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IrqStatus2D4Type
Public Enumeration IrqStatus2D4Type
public enum class IrqStatus2D4Type
type IrqStatus2D4Type
Members
Member name | Value | Description
VDDVHIGHLOWExceeded | 1 | V_DD V_HIGH/LOW Exceeded
VDDVHIGHLOWNotExceeded | 0 | V_DD: V_HIGH/LOW Not Exceeded
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.LdacConfigD0Type Enumeration

IRD

Adt7518LdacConfigD0Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum LdacConfigD0Type
Public Enumeration LdacConfigD0Type
public enum class LdacConfigD0Type
type LdacConfigD0Type
Members
Member name | Value | Description
Default | 0 | Default
LDACCommandUpdatesDACAOutputOnly | 1 | LDAC Command Updates DAC A Output Only
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.LdacConfigD1Type Enumeration

IRD

Adt7518LdacConfigD1Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum LdacConfigD1Type
Public Enumeration LdacConfigD1Type
public enum class LdacConfigD1Type
type LdacConfigD1Type
Members
Member name | Value | Description
Default | 0 | Default
LDACCommandUpdatesDACBOutputOnly | 1 | LDAC Command Updates DAC B Output Only
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.LdacConfigD2Type Enumeration

IRD

Adt7518LdacConfigD2Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum LdacConfigD2Type
Public Enumeration LdacConfigD2Type
public enum class LdacConfigD2Type
type LdacConfigD2Type
Members
Member name | Value | Description
Default | 0 | Default
LDACCommandUpdatesDACCOutputOnly | 1 | LDAC Command Updates DAC C Output Only
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.LdacConfigD3Type Enumeration

IRD

Adt7518LdacConfigD3Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum LdacConfigD3Type
Public Enumeration LdacConfigD3Type
public enum class LdacConfigD3Type
type LdacConfigD3Type
Members
Member name | Value | Description
Default | 0 | Default
LDACCommandUpdatesDACDOutputOnly | 1 | LDAC Command Updates DAC D Output Only
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.LdacConfigD4Type Enumeration

IRD

Adt7518LdacConfigD4Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum LdacConfigD4Type
Public Enumeration LdacConfigD4Type
public enum class LdacConfigD4Type
type LdacConfigD4Type
Members
Member name | Value | Description
DACABExternalVREF | 0 | DAC A/B: External V_REF
DACABInternalVREF | 1 | DAC A/B: Internal V_REF
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.LdacConfigD5Type Enumeration

IRD

Adt7518LdacConfigD5Type Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum LdacConfigD5Type
Public Enumeration LdacConfigD5Type
public enum class LdacConfigD5Type
type LdacConfigD5Type
Members
Member name | Value | Description
DACCDExternalVREF | 0 | DAC C/D: External V_REF
DACCDInternalVREF | 1 | DAC C/D: Internal V_REF
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7518.SpiLockType Enumeration

IRD

Adt7518SpiLockType Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SpiLockType
Public Enumeration SpiLockType
public enum class SpiLockType
type SpiLockType
Members
Member name | Value | Description
SPIInterfaceSelectedLocked | 1 | SPI Interface Selected/Locked
I2CInterface | 0 | I2C Interface
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519 Class

Analog Devices: ADT 7519
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdt7519

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adt7519
Public Class Adt7519
public ref class Adt7519
type Adt7519 =  class end

The Adt7519 type exposes the following members.

Constructors
 | Name | Description
Public method | Adt7519 | Constructor
Top
Properties
 | Name | Description
Public property | AIN2 | AIN2
Public property | AIN2VHIGHLimit | AIN2 V_HIGH Limit
Public property | AIN2VLOWLimit | AIN2 V_LOW Limit
Public property | AIN3 | AIN3
Public property | AIN3VHIGHLimit | AIN3 V_HIGH Limit
Public property | AIN3VLOWLimit | AIN3 V_LOW Limit
Public property | AIN4 | AIN4
Public property | AIN4VHIGHLimit | AIN4 V_HIGH Limit
Public property | AIN4VLOWLimit | AIN4 V_LOW Limit
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlConfiguration1INTOutput | Control Configuration 1: INT Output
Public property | ControlConfiguration1INTOutputPolarity | Control Configuration 1: INT Output Polarity
Public property | ControlConfiguration1LDACAIN3 | Control Configuration 1: LDAC / AIN3
Public property | ControlConfiguration1Monitoring | Control Configuration 1: Monitoring
Public property | ControlConfiguration1Pin7Pin8 | Control Configuration 1: Pin 7 / Pin 8
Public property | ControlConfiguration1PowerDown | Control Configuration 1: Power Down
Public property | ControlConfiguration2Averaging | Control Configuration 2: Averaging
Public property | ControlConfiguration2ChannelSelection | Control Configuration 2: Channel Selection
Public property | ControlConfiguration2Conversion | Control Configuration 2: Conversion
Public property | ControlConfiguration2SMBusTimeout | Control Configuration 2: SMBus Timeout
Public property | ControlConfiguration2SoftwareReset | Control Configuration 2: Software Reset
Public property | ControlConfiguration3ADCReference | Control Configuration 3: ADC Reference
Public property | ControlConfiguration3DACAOutputProportionalToInternalTemperature | Control Configuration 3: DAC A Output Proportional To Internal Temperature
Public property | ControlConfiguration3DACBOutputProportionalToExternalTemperature | Control Configuration 3: DAC B Output Proportional To External Temperature
Public property | ControlConfiguration3Resolution | Control Configuration 3: Resolution
Public property | ControlConfiguration3Speed | Control Configuration 3: Speed
Public property | ControlConfiguration3UpdatingOfDACOutputs | Control Configuration 3: Updating of DAC Outputs
Public property | DACA | DAC A
Public property | DACB | DAC B
Public property | DACC | DAC C
Public property | DACConfigurationOutputRangeDACA | DAC Configuration: Output Range DAC A
Public property | DACConfigurationOutputRangeDACB | DAC Configuration: Output Range DAC B
Public property | DACConfigurationOutputRangeDACC | DAC Configuration: Output Range DAC C
Public property | DACConfigurationOutputRangeDACD | DAC Configuration: Output Range DAC D
Public property | DACConfigurationUpdate | DAC Configuration: Update
Public property | DACD | DAC D
Public property | DeviceID | Device ID
Public property | ExternalAnalogTemperatureOffset | External Analog Temperature Offset (unit: °C)
Public property | ExternalTemperatureAIN1 | External Temperature / AIN1 (unit: °C)
Public property | ExternalTemperatureOffset | External Temperature Offset (unit: °C)
Public property | ExternalTHIGHAIN1VHIGHLimits | External T_HIGH/AIN1 V_HIGH Limits (unit: °C)
Public property | ExternalTLOWAIN1VLOWLimits | External T_LOW/AIN1 V_LOW Limits (unit: °C)
Public property | InternalAnalogTemperatureOffset | Internal Analog Temperature Offset (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | InternalTemperatureOffset | Internal Temperature Offset (unit: °C)
Public property | InternalTHIGHLimit | Internal T_HIGH Limit (unit: °C)
Public property | InternalTLOWLimit | Internal T_LOW Limit (unit: °C)
Public property | InterruptMask1AIN2 | Interrupt Mask 1: AIN2
Public property | InterruptMask1AIN3 | Interrupt Mask 1: AIN3
Public property | InterruptMask1AIN4 | Interrupt Mask 1: AIN4
Public property | InterruptMask1ExternalTemperatureFault | Interrupt Mask 1: External Temperature Fault
Public property | InterruptMask1ExternalTHIGHAIN1 | Interrupt Mask 1: External T_HIGH / AIN1
Public property | InterruptMask1ExternalTLOW | Interrupt Mask 1: External T_LOW
Public property | InterruptMask1InternalTHIGH | Interrupt Mask 1: Internal T_HIGH
Public property | InterruptMask1InternalTLOW | Interrupt Mask 1: Internal T_LOW
Public property | InterruptMask2VDD | Interrupt Mask 2: V_DD
Public property | InterruptStatus1AIN2VHIGHAIN2VLOW | Interrupt Status 1: AIN2 > V_HIGH / AIN2 <= V_LOW
Public property | InterruptStatus1AIN3VHIGHAIN3VLOW | Interrupt Status 1: AIN3 > V_HIGH / AIN3 <= V_LOW
Public property | InterruptStatus1AIN4VHIGHAIN4VLOW | Interrupt Status 1: AIN4 > V_HIGH / AIN4 <= V_LOW
Public property | InterruptStatus1ExternalSensorFault | Interrupt Status 1: External Sensor Fault
Public property | InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW | Interrupt Status 1: T_EXT > T_HIGH / AIN1 > V_HIGH / AIN1 <= V_LOW
Public property | InterruptStatus1TEXTTLOW | Interrupt Status 1: T_EXT <= T_LOW
Public property | InterruptStatus1TINTTHIGH | Interrupt Status 1: T_INT > T_HIGH
Public property | InterruptStatus1TINTTLOW | Interrupt Status 1: T_INT <= T_LOW
Public property | InterruptStatus2VDDVHIGHVDDVLOW | Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW
Public property | LDACConfigurationDACA | LDAC Configuration: DAC A
Public property | LDACConfigurationDACB | LDAC Configuration: DAC B
Public property | LDACConfigurationDACC | LDAC Configuration: DAC C
Public property | LDACConfigurationDACD | LDAC Configuration: DAC D
Public property | LDACConfigurationReferenceDACAB | LDAC Configuration: Reference DAC A / B
Public property | LDACConfigurationReferenceDACCD | LDAC Configuration: Reference DAC C / D
Public property | ManufacturerSID | Manufacturer's ID
Public property | SiliconRevisionStepping | Silicon Revision: Stepping
Public property | SiliconRevisionVersion | Silicon Revision: Version
Public property | SPILockStatus | SPI Lock Status
Public property | VDD | V_DD (unit: V)
Public property | VDDVHIGHLimit | V_DD V_HIGH Limit (unit: V)
Public property | VDDVLOWLimit | V_DD V_LOW Limit (unit: V)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Temperature Sensor, 4-Channel ADC and Quad Voltage Output
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adt7519(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adt7519

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519 Properties

The Adt7519 type exposes the following members.

Properties
 | Name | Description
Public property | AIN2 | AIN2
Public property | AIN2VHIGHLimit | AIN2 V_HIGH Limit
Public property | AIN2VLOWLimit | AIN2 V_LOW Limit
Public property | AIN3 | AIN3
Public property | AIN3VHIGHLimit | AIN3 V_HIGH Limit
Public property | AIN3VLOWLimit | AIN3 V_LOW Limit
Public property | AIN4 | AIN4
Public property | AIN4VHIGHLimit | AIN4 V_HIGH Limit
Public property | AIN4VLOWLimit | AIN4 V_LOW Limit
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlConfiguration1INTOutput | Control Configuration 1: INT Output
Public property | ControlConfiguration1INTOutputPolarity | Control Configuration 1: INT Output Polarity
Public property | ControlConfiguration1LDACAIN3 | Control Configuration 1: LDAC / AIN3
Public property | ControlConfiguration1Monitoring | Control Configuration 1: Monitoring
Public property | ControlConfiguration1Pin7Pin8 | Control Configuration 1: Pin 7 / Pin 8
Public property | ControlConfiguration1PowerDown | Control Configuration 1: Power Down
Public property | ControlConfiguration2Averaging | Control Configuration 2: Averaging
Public property | ControlConfiguration2ChannelSelection | Control Configuration 2: Channel Selection
Public property | ControlConfiguration2Conversion | Control Configuration 2: Conversion
Public property | ControlConfiguration2SMBusTimeout | Control Configuration 2: SMBus Timeout
Public property | ControlConfiguration2SoftwareReset | Control Configuration 2: Software Reset
Public property | ControlConfiguration3ADCReference | Control Configuration 3: ADC Reference
Public property | ControlConfiguration3DACAOutputProportionalToInternalTemperature | Control Configuration 3: DAC A Output Proportional To Internal Temperature
Public property | ControlConfiguration3DACBOutputProportionalToExternalTemperature | Control Configuration 3: DAC B Output Proportional To External Temperature
Public property | ControlConfiguration3Resolution | Control Configuration 3: Resolution
Public property | ControlConfiguration3Speed | Control Configuration 3: Speed
Public property | ControlConfiguration3UpdatingOfDACOutputs | Control Configuration 3: Updating of DAC Outputs
Public property | DACA | DAC A
Public property | DACB | DAC B
Public property | DACC | DAC C
Public property | DACConfigurationOutputRangeDACA | DAC Configuration: Output Range DAC A
Public property | DACConfigurationOutputRangeDACB | DAC Configuration: Output Range DAC B
Public property | DACConfigurationOutputRangeDACC | DAC Configuration: Output Range DAC C
Public property | DACConfigurationOutputRangeDACD | DAC Configuration: Output Range DAC D
Public property | DACConfigurationUpdate | DAC Configuration: Update
Public property | DACD | DAC D
Public property | DeviceID | Device ID
Public property | ExternalAnalogTemperatureOffset | External Analog Temperature Offset (unit: °C)
Public property | ExternalTemperatureAIN1 | External Temperature / AIN1 (unit: °C)
Public property | ExternalTemperatureOffset | External Temperature Offset (unit: °C)
Public property | ExternalTHIGHAIN1VHIGHLimits | External T_HIGH/AIN1 V_HIGH Limits (unit: °C)
Public property | ExternalTLOWAIN1VLOWLimits | External T_LOW/AIN1 V_LOW Limits (unit: °C)
Public property | InternalAnalogTemperatureOffset | Internal Analog Temperature Offset (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | InternalTemperatureOffset | Internal Temperature Offset (unit: °C)
Public property | InternalTHIGHLimit | Internal T_HIGH Limit (unit: °C)
Public property | InternalTLOWLimit | Internal T_LOW Limit (unit: °C)
Public property | InterruptMask1AIN2 | Interrupt Mask 1: AIN2
Public property | InterruptMask1AIN3 | Interrupt Mask 1: AIN3
Public property | InterruptMask1AIN4 | Interrupt Mask 1: AIN4
Public property | InterruptMask1ExternalTemperatureFault | Interrupt Mask 1: External Temperature Fault
Public property | InterruptMask1ExternalTHIGHAIN1 | Interrupt Mask 1: External T_HIGH / AIN1
Public property | InterruptMask1ExternalTLOW | Interrupt Mask 1: External T_LOW
Public property | InterruptMask1InternalTHIGH | Interrupt Mask 1: Internal T_HIGH
Public property | InterruptMask1InternalTLOW | Interrupt Mask 1: Internal T_LOW
Public property | InterruptMask2VDD | Interrupt Mask 2: V_DD
Public property | InterruptStatus1AIN2VHIGHAIN2VLOW | Interrupt Status 1: AIN2 > V_HIGH / AIN2 <= V_LOW
Public property | InterruptStatus1AIN3VHIGHAIN3VLOW | Interrupt Status 1: AIN3 > V_HIGH / AIN3 <= V_LOW
Public property | InterruptStatus1AIN4VHIGHAIN4VLOW | Interrupt Status 1: AIN4 > V_HIGH / AIN4 <= V_LOW
Public property | InterruptStatus1ExternalSensorFault | Interrupt Status 1: External Sensor Fault
Public property | InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW | Interrupt Status 1: T_EXT > T_HIGH / AIN1 > V_HIGH / AIN1 <= V_LOW
Public property | InterruptStatus1TEXTTLOW | Interrupt Status 1: T_EXT <= T_LOW
Public property | InterruptStatus1TINTTHIGH | Interrupt Status 1: T_INT > T_HIGH
Public property | InterruptStatus1TINTTLOW | Interrupt Status 1: T_INT <= T_LOW
Public property | InterruptStatus2VDDVHIGHVDDVLOW | Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW
Public property | LDACConfigurationDACA | LDAC Configuration: DAC A
Public property | LDACConfigurationDACB | LDAC Configuration: DAC B
Public property | LDACConfigurationDACC | LDAC Configuration: DAC C
Public property | LDACConfigurationDACD | LDAC Configuration: DAC D
Public property | LDACConfigurationReferenceDACAB | LDAC Configuration: Reference DAC A / B
Public property | LDACConfigurationReferenceDACCD | LDAC Configuration: Reference DAC C / D
Public property | ManufacturerSID | Manufacturer's ID
Public property | SiliconRevisionStepping | Silicon Revision: Stepping
Public property | SiliconRevisionVersion | Silicon Revision: Version
Public property | SPILockStatus | SPI Lock Status
Public property | VDD | V_DD (unit: V)
Public property | VDDVHIGHLimit | V_DD V_HIGH Limit (unit: V)
Public property | VDDVLOWLimit | V_DD V_LOW Limit (unit: V)
Top
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.AIN2 Property

IRD

Adt7519AIN2 Property

AIN2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AIN2 { get; }
Public ReadOnly Property AIN2 As UShort
    Get
public:
property unsigned short AIN2 {
    unsigned short get ();
}
member AIN2 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.AIN2VHIGHLimit Property

IRD

Adt7519AIN2VHIGHLimit Property

AIN2 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN2VHIGHLimit { get; set; }
Public Property AIN2VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN2VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN2VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.AIN2VLOWLimit Property

IRD

Adt7519AIN2VLOWLimit Property

AIN2 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN2VLOWLimit { get; set; }
Public Property AIN2VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN2VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN2VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.AIN3 Property

IRD

Adt7519AIN3 Property

AIN3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AIN3 { get; }
Public ReadOnly Property AIN3 As UShort
    Get
public:
property unsigned short AIN3 {
    unsigned short get ();
}
member AIN3 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.AIN3VHIGHLimit Property

IRD

Adt7519AIN3VHIGHLimit Property

AIN3 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN3VHIGHLimit { get; set; }
Public Property AIN3VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN3VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN3VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.AIN3VLOWLimit Property

IRD

Adt7519AIN3VLOWLimit Property

AIN3 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN3VLOWLimit { get; set; }
Public Property AIN3VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN3VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN3VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.AIN4 Property

IRD

Adt7519AIN4 Property

AIN4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AIN4 { get; }
Public ReadOnly Property AIN4 As UShort
    Get
public:
property unsigned short AIN4 {
    unsigned short get ();
}
member AIN4 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.AIN4VHIGHLimit Property

IRD

Adt7519AIN4VHIGHLimit Property

AIN4 V_HIGH Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN4VHIGHLimit { get; set; }
Public Property AIN4VHIGHLimit As Byte
    Get
    Set
public:
property unsigned char AIN4VHIGHLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN4VHIGHLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.AIN4VLOWLimit Property

IRD

Adt7519AIN4VLOWLimit Property

AIN4 V_LOW Limit

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AIN4VLOWLimit { get; set; }
Public Property AIN4VLOWLimit As Byte
    Get
    Set
public:
property unsigned char AIN4VLOWLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member AIN4VLOWLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.AutoFlush Property

IRD

Adt7519AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ControlConfiguration1INTOutput Property

IRD

Adt7519ControlConfiguration1INTOutput Property

Control Configuration 1: INT Output

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeControlConfiguration1IntOutput ControlConfiguration1INTOutput { get; set; }
Public Property ControlConfiguration1INTOutput As Adt7519TypeControlConfiguration1IntOutput
    Get
    Set
public:
property Adt7519TypeControlConfiguration1IntOutput ControlConfiguration1INTOutput {
    Adt7519TypeControlConfiguration1IntOutput get ();
    void set (Adt7519TypeControlConfiguration1IntOutput value);
}
member ControlConfiguration1INTOutput : Adt7519TypeControlConfiguration1IntOutput with get, set

Property Value

Type: Adt7519TypeControlConfiguration1IntOutput
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ControlConfiguration1INTOutputPolarity Property

IRD

Adt7519ControlConfiguration1INTOutputPolarity Property

Control Configuration 1: INT Output Polarity

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeControlConfiguration1IntOutputPolarity ControlConfiguration1INTOutputPolarity { get; set; }
Public Property ControlConfiguration1INTOutputPolarity As Adt7519TypeControlConfiguration1IntOutputPolarity
    Get
    Set
public:
property Adt7519TypeControlConfiguration1IntOutputPolarity ControlConfiguration1INTOutputPolarity {
    Adt7519TypeControlConfiguration1IntOutputPolarity get ();
    void set (Adt7519TypeControlConfiguration1IntOutputPolarity value);
}
member ControlConfiguration1INTOutputPolarity : Adt7519TypeControlConfiguration1IntOutputPolarity with get, set

Property Value

Type: Adt7519TypeControlConfiguration1IntOutputPolarity
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ControlConfiguration1LDACAIN3 Property

IRD

Adt7519ControlConfiguration1LDACAIN3 Property

Control Configuration 1: LDAC / AIN3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeControlConfiguration1LdacAin3 ControlConfiguration1LDACAIN3 { get; set; }
Public Property ControlConfiguration1LDACAIN3 As Adt7519TypeControlConfiguration1LdacAin3
    Get
    Set
public:
property Adt7519TypeControlConfiguration1LdacAin3 ControlConfiguration1LDACAIN3 {
    Adt7519TypeControlConfiguration1LdacAin3 get ();
    void set (Adt7519TypeControlConfiguration1LdacAin3 value);
}
member ControlConfiguration1LDACAIN3 : Adt7519TypeControlConfiguration1LdacAin3 with get, set

Property Value

Type: Adt7519TypeControlConfiguration1LdacAin3
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ControlConfiguration1Monitoring Property

IRD

Adt7519ControlConfiguration1Monitoring Property

Control Configuration 1: Monitoring

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeControlConfiguration1Monitoring ControlConfiguration1Monitoring { get; set; }
Public Property ControlConfiguration1Monitoring As Adt7519TypeControlConfiguration1Monitoring
    Get
    Set
public:
property Adt7519TypeControlConfiguration1Monitoring ControlConfiguration1Monitoring {
    Adt7519TypeControlConfiguration1Monitoring get ();
    void set (Adt7519TypeControlConfiguration1Monitoring value);
}
member ControlConfiguration1Monitoring : Adt7519TypeControlConfiguration1Monitoring with get, set

Property Value

Type: Adt7519TypeControlConfiguration1Monitoring
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ControlConfiguration1Pin7Pin8 Property

IRD

Adt7519ControlConfiguration1Pin7Pin8 Property

Control Configuration 1: Pin 7 / Pin 8

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeControlConfiguration1AinTdmSelection ControlConfiguration1Pin7Pin8 { get; set; }
Public Property ControlConfiguration1Pin7Pin8 As Adt7519TypeControlConfiguration1AinTdmSelection
    Get
    Set
public:
property Adt7519TypeControlConfiguration1AinTdmSelection ControlConfiguration1Pin7Pin8 {
    Adt7519TypeControlConfiguration1AinTdmSelection get ();
    void set (Adt7519TypeControlConfiguration1AinTdmSelection value);
}
member ControlConfiguration1Pin7Pin8 : Adt7519TypeControlConfiguration1AinTdmSelection with get, set

Property Value

Type: Adt7519TypeControlConfiguration1AinTdmSelection
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ControlConfiguration1PowerDown Property

IRD

Adt7519ControlConfiguration1PowerDown Property

Control Configuration 1: Power Down

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeControlConfiguration1PowerDown ControlConfiguration1PowerDown { get; set; }
Public Property ControlConfiguration1PowerDown As Adt7519TypeControlConfiguration1PowerDown
    Get
    Set
public:
property Adt7519TypeControlConfiguration1PowerDown ControlConfiguration1PowerDown {
    Adt7519TypeControlConfiguration1PowerDown get ();
    void set (Adt7519TypeControlConfiguration1PowerDown value);
}
member ControlConfiguration1PowerDown : Adt7519TypeControlConfiguration1PowerDown with get, set

Property Value

Type: Adt7519TypeControlConfiguration1PowerDown
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ControlConfiguration2Averaging Property

IRD

Adt7519ControlConfiguration2Averaging Property

Control Configuration 2: Averaging

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeControlConfiguration2Averaging ControlConfiguration2Averaging { get; set; }
Public Property ControlConfiguration2Averaging As Adt7519TypeControlConfiguration2Averaging
    Get
    Set
public:
property Adt7519TypeControlConfiguration2Averaging ControlConfiguration2Averaging {
    Adt7519TypeControlConfiguration2Averaging get ();
    void set (Adt7519TypeControlConfiguration2Averaging value);
}
member ControlConfiguration2Averaging : Adt7519TypeControlConfiguration2Averaging with get, set

Property Value

Type: Adt7519TypeControlConfiguration2Averaging
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ControlConfiguration2ChannelSelection Property

IRD

Adt7519ControlConfiguration2ChannelSelection Property

Control Configuration 2: Channel Selection

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeControlConfiguration2ChannelSelection ControlConfiguration2ChannelSelection { get; set; }
Public Property ControlConfiguration2ChannelSelection As Adt7519TypeControlConfiguration2ChannelSelection
    Get
    Set
public:
property Adt7519TypeControlConfiguration2ChannelSelection ControlConfiguration2ChannelSelection {
    Adt7519TypeControlConfiguration2ChannelSelection get ();
    void set (Adt7519TypeControlConfiguration2ChannelSelection value);
}
member ControlConfiguration2ChannelSelection : Adt7519TypeControlConfiguration2ChannelSelection with get, set

Property Value

Type: Adt7519TypeControlConfiguration2ChannelSelection
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ControlConfiguration2Conversion Property

IRD

Adt7519ControlConfiguration2Conversion Property

Control Configuration 2: Conversion

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeControlConfiguration2Conversion ControlConfiguration2Conversion { get; set; }
Public Property ControlConfiguration2Conversion As Adt7519TypeControlConfiguration2Conversion
    Get
    Set
public:
property Adt7519TypeControlConfiguration2Conversion ControlConfiguration2Conversion {
    Adt7519TypeControlConfiguration2Conversion get ();
    void set (Adt7519TypeControlConfiguration2Conversion value);
}
member ControlConfiguration2Conversion : Adt7519TypeControlConfiguration2Conversion with get, set

Property Value

Type: Adt7519TypeControlConfiguration2Conversion
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ControlConfiguration2SMBusTimeout Property

IRD

Adt7519ControlConfiguration2SMBusTimeout Property

Control Configuration 2: SMBus Timeout

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeControlConfiguration2Timeout ControlConfiguration2SMBusTimeout { get; set; }
Public Property ControlConfiguration2SMBusTimeout As Adt7519TypeControlConfiguration2Timeout
    Get
    Set
public:
property Adt7519TypeControlConfiguration2Timeout ControlConfiguration2SMBusTimeout {
    Adt7519TypeControlConfiguration2Timeout get ();
    void set (Adt7519TypeControlConfiguration2Timeout value);
}
member ControlConfiguration2SMBusTimeout : Adt7519TypeControlConfiguration2Timeout with get, set

Property Value

Type: Adt7519TypeControlConfiguration2Timeout
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ControlConfiguration2SoftwareReset Property

IRD

Adt7519ControlConfiguration2SoftwareReset Property

Control Configuration 2: Software Reset

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeControlConfiguration2SoftwareReset ControlConfiguration2SoftwareReset { get; set; }
Public Property ControlConfiguration2SoftwareReset As Adt7519TypeControlConfiguration2SoftwareReset
    Get
    Set
public:
property Adt7519TypeControlConfiguration2SoftwareReset ControlConfiguration2SoftwareReset {
    Adt7519TypeControlConfiguration2SoftwareReset get ();
    void set (Adt7519TypeControlConfiguration2SoftwareReset value);
}
member ControlConfiguration2SoftwareReset : Adt7519TypeControlConfiguration2SoftwareReset with get, set

Property Value

Type: Adt7519TypeControlConfiguration2SoftwareReset
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ControlConfiguration3ADCReference Property

IRD

Adt7519ControlConfiguration3ADCReference Property

Control Configuration 3: ADC Reference

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeControlConfiguration3AdcReference ControlConfiguration3ADCReference { get; set; }
Public Property ControlConfiguration3ADCReference As Adt7519TypeControlConfiguration3AdcReference
    Get
    Set
public:
property Adt7519TypeControlConfiguration3AdcReference ControlConfiguration3ADCReference {
    Adt7519TypeControlConfiguration3AdcReference get ();
    void set (Adt7519TypeControlConfiguration3AdcReference value);
}
member ControlConfiguration3ADCReference : Adt7519TypeControlConfiguration3AdcReference with get, set

Property Value

Type: Adt7519TypeControlConfiguration3AdcReference
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ControlConfiguration3DACAOutputProportionalToInternalTemperature Property

IRD

Adt7519ControlConfiguration3DACAOutputProportionalToInternalTemperature Property

Control Configuration 3: DAC A Output Proportional To Internal Temperature

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeControlConfiguration3DacAOutput ControlConfiguration3DACAOutputProportionalToInternalTemperature { get; set; }
Public Property ControlConfiguration3DACAOutputProportionalToInternalTemperature As Adt7519TypeControlConfiguration3DacAOutput
    Get
    Set
public:
property Adt7519TypeControlConfiguration3DacAOutput ControlConfiguration3DACAOutputProportionalToInternalTemperature {
    Adt7519TypeControlConfiguration3DacAOutput get ();
    void set (Adt7519TypeControlConfiguration3DacAOutput value);
}
member ControlConfiguration3DACAOutputProportionalToInternalTemperature : Adt7519TypeControlConfiguration3DacAOutput with get, set

Property Value

Type: Adt7519TypeControlConfiguration3DacAOutput
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ControlConfiguration3DACBOutputProportionalToExternalTemperature Property

IRD

Adt7519ControlConfiguration3DACBOutputProportionalToExternalTemperature Property

Control Configuration 3: DAC B Output Proportional To External Temperature

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeControlConfiguration3DacBOutput ControlConfiguration3DACBOutputProportionalToExternalTemperature { get; set; }
Public Property ControlConfiguration3DACBOutputProportionalToExternalTemperature As Adt7519TypeControlConfiguration3DacBOutput
    Get
    Set
public:
property Adt7519TypeControlConfiguration3DacBOutput ControlConfiguration3DACBOutputProportionalToExternalTemperature {
    Adt7519TypeControlConfiguration3DacBOutput get ();
    void set (Adt7519TypeControlConfiguration3DacBOutput value);
}
member ControlConfiguration3DACBOutputProportionalToExternalTemperature : Adt7519TypeControlConfiguration3DacBOutput with get, set

Property Value

Type: Adt7519TypeControlConfiguration3DacBOutput
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ControlConfiguration3Resolution Property

IRD

Adt7519ControlConfiguration3Resolution Property

Control Configuration 3: Resolution

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeControlConfiguration3Resolution ControlConfiguration3Resolution { get; set; }
Public Property ControlConfiguration3Resolution As Adt7519TypeControlConfiguration3Resolution
    Get
    Set
public:
property Adt7519TypeControlConfiguration3Resolution ControlConfiguration3Resolution {
    Adt7519TypeControlConfiguration3Resolution get ();
    void set (Adt7519TypeControlConfiguration3Resolution value);
}
member ControlConfiguration3Resolution : Adt7519TypeControlConfiguration3Resolution with get, set

Property Value

Type: Adt7519TypeControlConfiguration3Resolution
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ControlConfiguration3Speed Property

IRD

Adt7519ControlConfiguration3Speed Property

Control Configuration 3: Speed

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeControlConfiguration3Speed ControlConfiguration3Speed { get; set; }
Public Property ControlConfiguration3Speed As Adt7519TypeControlConfiguration3Speed
    Get
    Set
public:
property Adt7519TypeControlConfiguration3Speed ControlConfiguration3Speed {
    Adt7519TypeControlConfiguration3Speed get ();
    void set (Adt7519TypeControlConfiguration3Speed value);
}
member ControlConfiguration3Speed : Adt7519TypeControlConfiguration3Speed with get, set

Property Value

Type: Adt7519TypeControlConfiguration3Speed
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ControlConfiguration3UpdatingOfDACOutputs Property

IRD

Adt7519ControlConfiguration3UpdatingOfDACOutputs Property

Control Configuration 3: Updating of DAC Outputs

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeControlConfiguration3UpdatingDacOutputs ControlConfiguration3UpdatingOfDACOutputs { get; set; }
Public Property ControlConfiguration3UpdatingOfDACOutputs As Adt7519TypeControlConfiguration3UpdatingDacOutputs
    Get
    Set
public:
property Adt7519TypeControlConfiguration3UpdatingDacOutputs ControlConfiguration3UpdatingOfDACOutputs {
    Adt7519TypeControlConfiguration3UpdatingDacOutputs get ();
    void set (Adt7519TypeControlConfiguration3UpdatingDacOutputs value);
}
member ControlConfiguration3UpdatingOfDACOutputs : Adt7519TypeControlConfiguration3UpdatingDacOutputs with get, set

Property Value

Type: Adt7519TypeControlConfiguration3UpdatingDacOutputs
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.DACA Property

IRD

Adt7519DACA Property

DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACA { get; set; }
Public Property DACA As Byte
    Get
    Set
public:
property unsigned char DACA {
    unsigned char get ();
    void set (unsigned char value);
}
member DACA : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.DACB Property

IRD

Adt7519DACB Property

DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACB { get; set; }
Public Property DACB As Byte
    Get
    Set
public:
property unsigned char DACB {
    unsigned char get ();
    void set (unsigned char value);
}
member DACB : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.DACC Property

IRD

Adt7519DACC Property

DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACC { get; set; }
Public Property DACC As Byte
    Get
    Set
public:
property unsigned char DACC {
    unsigned char get ();
    void set (unsigned char value);
}
member DACC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.DACConfigurationOutputRangeDACA Property

IRD

Adt7519DACConfigurationOutputRangeDACA Property

DAC Configuration: Output Range DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeDacConfigurationRange DACConfigurationOutputRangeDACA { get; set; }
Public Property DACConfigurationOutputRangeDACA As Adt7519TypeDacConfigurationRange
    Get
    Set
public:
property Adt7519TypeDacConfigurationRange DACConfigurationOutputRangeDACA {
    Adt7519TypeDacConfigurationRange get ();
    void set (Adt7519TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACA : Adt7519TypeDacConfigurationRange with get, set

Property Value

Type: Adt7519TypeDacConfigurationRange
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.DACConfigurationOutputRangeDACB Property

IRD

Adt7519DACConfigurationOutputRangeDACB Property

DAC Configuration: Output Range DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeDacConfigurationRange DACConfigurationOutputRangeDACB { get; set; }
Public Property DACConfigurationOutputRangeDACB As Adt7519TypeDacConfigurationRange
    Get
    Set
public:
property Adt7519TypeDacConfigurationRange DACConfigurationOutputRangeDACB {
    Adt7519TypeDacConfigurationRange get ();
    void set (Adt7519TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACB : Adt7519TypeDacConfigurationRange with get, set

Property Value

Type: Adt7519TypeDacConfigurationRange
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.DACConfigurationOutputRangeDACC Property

IRD

Adt7519DACConfigurationOutputRangeDACC Property

DAC Configuration: Output Range DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeDacConfigurationRange DACConfigurationOutputRangeDACC { get; set; }
Public Property DACConfigurationOutputRangeDACC As Adt7519TypeDacConfigurationRange
    Get
    Set
public:
property Adt7519TypeDacConfigurationRange DACConfigurationOutputRangeDACC {
    Adt7519TypeDacConfigurationRange get ();
    void set (Adt7519TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACC : Adt7519TypeDacConfigurationRange with get, set

Property Value

Type: Adt7519TypeDacConfigurationRange
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.DACConfigurationOutputRangeDACD Property

IRD

Adt7519DACConfigurationOutputRangeDACD Property

DAC Configuration: Output Range DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeDacConfigurationRange DACConfigurationOutputRangeDACD { get; set; }
Public Property DACConfigurationOutputRangeDACD As Adt7519TypeDacConfigurationRange
    Get
    Set
public:
property Adt7519TypeDacConfigurationRange DACConfigurationOutputRangeDACD {
    Adt7519TypeDacConfigurationRange get ();
    void set (Adt7519TypeDacConfigurationRange value);
}
member DACConfigurationOutputRangeDACD : Adt7519TypeDacConfigurationRange with get, set

Property Value

Type: Adt7519TypeDacConfigurationRange
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.DACConfigurationUpdate Property

IRD

Adt7519DACConfigurationUpdate Property

DAC Configuration: Update

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeDacConfigurationUpdate DACConfigurationUpdate { get; set; }
Public Property DACConfigurationUpdate As Adt7519TypeDacConfigurationUpdate
    Get
    Set
public:
property Adt7519TypeDacConfigurationUpdate DACConfigurationUpdate {
    Adt7519TypeDacConfigurationUpdate get ();
    void set (Adt7519TypeDacConfigurationUpdate value);
}
member DACConfigurationUpdate : Adt7519TypeDacConfigurationUpdate with get, set

Property Value

Type: Adt7519TypeDacConfigurationUpdate
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.DACD Property

IRD

Adt7519DACD Property

DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACD { get; set; }
Public Property DACD As Byte
    Get
    Set
public:
property unsigned char DACD {
    unsigned char get ();
    void set (unsigned char value);
}
member DACD : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.DeviceID Property

IRD

Adt7519DeviceID Property

Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ExternalAnalogTemperatureOffset Property

IRD

Adt7519ExternalAnalogTemperatureOffset Property

External Analog Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalAnalogTemperatureOffset { get; set; }
Public Property ExternalAnalogTemperatureOffset As SByte
    Get
    Set
public:
property signed char ExternalAnalogTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member ExternalAnalogTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ExternalTemperatureAIN1 Property

IRD

Adt7519ExternalTemperatureAIN1 Property

External Temperature / AIN1 (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ExternalTemperatureAIN1 { get; }
Public ReadOnly Property ExternalTemperatureAIN1 As Double
    Get
public:
property double ExternalTemperatureAIN1 {
    double get ();
}
member ExternalTemperatureAIN1 : float with get

Property Value

Type: Double
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ExternalTemperatureOffset Property

IRD

Adt7519ExternalTemperatureOffset Property

External Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperatureOffset { get; set; }
Public Property ExternalTemperatureOffset As SByte
    Get
    Set
public:
property signed char ExternalTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member ExternalTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ExternalTHIGHAIN1VHIGHLimits Property

IRD

Adt7519ExternalTHIGHAIN1VHIGHLimits Property

External T_HIGH/AIN1 V_HIGH Limits (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTHIGHAIN1VHIGHLimits { get; set; }
Public Property ExternalTHIGHAIN1VHIGHLimits As SByte
    Get
    Set
public:
property signed char ExternalTHIGHAIN1VHIGHLimits {
    signed char get ();
    void set (signed char value);
}
member ExternalTHIGHAIN1VHIGHLimits : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ExternalTLOWAIN1VLOWLimits Property

IRD

Adt7519ExternalTLOWAIN1VLOWLimits Property

External T_LOW/AIN1 V_LOW Limits (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTLOWAIN1VLOWLimits { get; set; }
Public Property ExternalTLOWAIN1VLOWLimits As SByte
    Get
    Set
public:
property signed char ExternalTLOWAIN1VLOWLimits {
    signed char get ();
    void set (signed char value);
}
member ExternalTLOWAIN1VLOWLimits : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InternalAnalogTemperatureOffset Property

IRD

Adt7519InternalAnalogTemperatureOffset Property

Internal Analog Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalAnalogTemperatureOffset { get; set; }
Public Property InternalAnalogTemperatureOffset As SByte
    Get
    Set
public:
property signed char InternalAnalogTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member InternalAnalogTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InternalTemperature Property

IRD

Adt7519InternalTemperature Property

Internal Temperature (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double InternalTemperature { get; }
Public ReadOnly Property InternalTemperature As Double
    Get
public:
property double InternalTemperature {
    double get ();
}
member InternalTemperature : float with get

Property Value

Type: Double
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InternalTemperatureOffset Property

IRD

Adt7519InternalTemperatureOffset Property

Internal Temperature Offset (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureOffset { get; set; }
Public Property InternalTemperatureOffset As SByte
    Get
    Set
public:
property signed char InternalTemperatureOffset {
    signed char get ();
    void set (signed char value);
}
member InternalTemperatureOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InternalTHIGHLimit Property

IRD

Adt7519InternalTHIGHLimit Property

Internal T_HIGH Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTHIGHLimit { get; set; }
Public Property InternalTHIGHLimit As SByte
    Get
    Set
public:
property signed char InternalTHIGHLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTHIGHLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InternalTLOWLimit Property

IRD

Adt7519InternalTLOWLimit Property

Internal T_LOW Limit (unit: °C)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTLOWLimit { get; set; }
Public Property InternalTLOWLimit As SByte
    Get
    Set
public:
property signed char InternalTLOWLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTLOWLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InterruptMask1AIN2 Property

IRD

Adt7519InterruptMask1AIN2 Property

Interrupt Mask 1: AIN2

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeInterruptMaskEnableDisable InterruptMask1AIN2 { get; set; }
Public Property InterruptMask1AIN2 As Adt7519TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7519TypeInterruptMaskEnableDisable InterruptMask1AIN2 {
    Adt7519TypeInterruptMaskEnableDisable get ();
    void set (Adt7519TypeInterruptMaskEnableDisable value);
}
member InterruptMask1AIN2 : Adt7519TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7519TypeInterruptMaskEnableDisable
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InterruptMask1AIN3 Property

IRD

Adt7519InterruptMask1AIN3 Property

Interrupt Mask 1: AIN3

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeInterruptMaskEnableDisable InterruptMask1AIN3 { get; set; }
Public Property InterruptMask1AIN3 As Adt7519TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7519TypeInterruptMaskEnableDisable InterruptMask1AIN3 {
    Adt7519TypeInterruptMaskEnableDisable get ();
    void set (Adt7519TypeInterruptMaskEnableDisable value);
}
member InterruptMask1AIN3 : Adt7519TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7519TypeInterruptMaskEnableDisable
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InterruptMask1AIN4 Property

IRD

Adt7519InterruptMask1AIN4 Property

Interrupt Mask 1: AIN4

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeInterruptMaskEnableDisable InterruptMask1AIN4 { get; set; }
Public Property InterruptMask1AIN4 As Adt7519TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7519TypeInterruptMaskEnableDisable InterruptMask1AIN4 {
    Adt7519TypeInterruptMaskEnableDisable get ();
    void set (Adt7519TypeInterruptMaskEnableDisable value);
}
member InterruptMask1AIN4 : Adt7519TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7519TypeInterruptMaskEnableDisable
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InterruptMask1ExternalTemperatureFault Property

IRD

Adt7519InterruptMask1ExternalTemperatureFault Property

Interrupt Mask 1: External Temperature Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeInterruptMaskEnableDisable InterruptMask1ExternalTemperatureFault { get; set; }
Public Property InterruptMask1ExternalTemperatureFault As Adt7519TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7519TypeInterruptMaskEnableDisable InterruptMask1ExternalTemperatureFault {
    Adt7519TypeInterruptMaskEnableDisable get ();
    void set (Adt7519TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTemperatureFault : Adt7519TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7519TypeInterruptMaskEnableDisable
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InterruptMask1ExternalTHIGHAIN1 Property

IRD

Adt7519InterruptMask1ExternalTHIGHAIN1 Property

Interrupt Mask 1: External T_HIGH / AIN1

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeInterruptMaskEnableDisable InterruptMask1ExternalTHIGHAIN1 { get; set; }
Public Property InterruptMask1ExternalTHIGHAIN1 As Adt7519TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7519TypeInterruptMaskEnableDisable InterruptMask1ExternalTHIGHAIN1 {
    Adt7519TypeInterruptMaskEnableDisable get ();
    void set (Adt7519TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTHIGHAIN1 : Adt7519TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7519TypeInterruptMaskEnableDisable
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InterruptMask1ExternalTLOW Property

IRD

Adt7519InterruptMask1ExternalTLOW Property

Interrupt Mask 1: External T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeInterruptMaskEnableDisable InterruptMask1ExternalTLOW { get; set; }
Public Property InterruptMask1ExternalTLOW As Adt7519TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7519TypeInterruptMaskEnableDisable InterruptMask1ExternalTLOW {
    Adt7519TypeInterruptMaskEnableDisable get ();
    void set (Adt7519TypeInterruptMaskEnableDisable value);
}
member InterruptMask1ExternalTLOW : Adt7519TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7519TypeInterruptMaskEnableDisable
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InterruptMask1InternalTHIGH Property

IRD

Adt7519InterruptMask1InternalTHIGH Property

Interrupt Mask 1: Internal T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeInterruptMaskEnableDisable InterruptMask1InternalTHIGH { get; set; }
Public Property InterruptMask1InternalTHIGH As Adt7519TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7519TypeInterruptMaskEnableDisable InterruptMask1InternalTHIGH {
    Adt7519TypeInterruptMaskEnableDisable get ();
    void set (Adt7519TypeInterruptMaskEnableDisable value);
}
member InterruptMask1InternalTHIGH : Adt7519TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7519TypeInterruptMaskEnableDisable
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InterruptMask1InternalTLOW Property

IRD

Adt7519InterruptMask1InternalTLOW Property

Interrupt Mask 1: Internal T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeInterruptMaskEnableDisable InterruptMask1InternalTLOW { get; set; }
Public Property InterruptMask1InternalTLOW As Adt7519TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7519TypeInterruptMaskEnableDisable InterruptMask1InternalTLOW {
    Adt7519TypeInterruptMaskEnableDisable get ();
    void set (Adt7519TypeInterruptMaskEnableDisable value);
}
member InterruptMask1InternalTLOW : Adt7519TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7519TypeInterruptMaskEnableDisable
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InterruptMask2VDD Property

IRD

Adt7519InterruptMask2VDD Property

Interrupt Mask 2: V_DD

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeInterruptMaskEnableDisable InterruptMask2VDD { get; set; }
Public Property InterruptMask2VDD As Adt7519TypeInterruptMaskEnableDisable
    Get
    Set
public:
property Adt7519TypeInterruptMaskEnableDisable InterruptMask2VDD {
    Adt7519TypeInterruptMaskEnableDisable get ();
    void set (Adt7519TypeInterruptMaskEnableDisable value);
}
member InterruptMask2VDD : Adt7519TypeInterruptMaskEnableDisable with get, set

Property Value

Type: Adt7519TypeInterruptMaskEnableDisable
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InterruptStatus1AIN2VHIGHAIN2VLOW Property

IRD

Adt7519InterruptStatus1AIN2VHIGHAIN2VLOW Property

Interrupt Status 1: AIN2 > V_HIGH / AIN2 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeInterruptStatus InterruptStatus1AIN2VHIGHAIN2VLOW { get; }
Public ReadOnly Property InterruptStatus1AIN2VHIGHAIN2VLOW As Adt7519TypeInterruptStatus
    Get
public:
property Adt7519TypeInterruptStatus InterruptStatus1AIN2VHIGHAIN2VLOW {
    Adt7519TypeInterruptStatus get ();
}
member InterruptStatus1AIN2VHIGHAIN2VLOW : Adt7519TypeInterruptStatus with get

Property Value

Type: Adt7519TypeInterruptStatus
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InterruptStatus1AIN3VHIGHAIN3VLOW Property

IRD

Adt7519InterruptStatus1AIN3VHIGHAIN3VLOW Property

Interrupt Status 1: AIN3 > V_HIGH / AIN3 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeInterruptStatus InterruptStatus1AIN3VHIGHAIN3VLOW { get; }
Public ReadOnly Property InterruptStatus1AIN3VHIGHAIN3VLOW As Adt7519TypeInterruptStatus
    Get
public:
property Adt7519TypeInterruptStatus InterruptStatus1AIN3VHIGHAIN3VLOW {
    Adt7519TypeInterruptStatus get ();
}
member InterruptStatus1AIN3VHIGHAIN3VLOW : Adt7519TypeInterruptStatus with get

Property Value

Type: Adt7519TypeInterruptStatus
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InterruptStatus1AIN4VHIGHAIN4VLOW Property

IRD

Adt7519InterruptStatus1AIN4VHIGHAIN4VLOW Property

Interrupt Status 1: AIN4 > V_HIGH / AIN4 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeInterruptStatus InterruptStatus1AIN4VHIGHAIN4VLOW { get; }
Public ReadOnly Property InterruptStatus1AIN4VHIGHAIN4VLOW As Adt7519TypeInterruptStatus
    Get
public:
property Adt7519TypeInterruptStatus InterruptStatus1AIN4VHIGHAIN4VLOW {
    Adt7519TypeInterruptStatus get ();
}
member InterruptStatus1AIN4VHIGHAIN4VLOW : Adt7519TypeInterruptStatus with get

Property Value

Type: Adt7519TypeInterruptStatus
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InterruptStatus1ExternalSensorFault Property

IRD

Adt7519InterruptStatus1ExternalSensorFault Property

Interrupt Status 1: External Sensor Fault

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeInterruptStatus InterruptStatus1ExternalSensorFault { get; }
Public ReadOnly Property InterruptStatus1ExternalSensorFault As Adt7519TypeInterruptStatus
    Get
public:
property Adt7519TypeInterruptStatus InterruptStatus1ExternalSensorFault {
    Adt7519TypeInterruptStatus get ();
}
member InterruptStatus1ExternalSensorFault : Adt7519TypeInterruptStatus with get

Property Value

Type: Adt7519TypeInterruptStatus
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW Property

IRD

Adt7519InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW Property

Interrupt Status 1: T_EXT > T_HIGH / AIN1 > V_HIGH / AIN1 <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeInterruptStatus InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW { get; }
Public ReadOnly Property InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW As Adt7519TypeInterruptStatus
    Get
public:
property Adt7519TypeInterruptStatus InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW {
    Adt7519TypeInterruptStatus get ();
}
member InterruptStatus1TEXTTHIGHAIN1VHIGHAIN1VLOW : Adt7519TypeInterruptStatus with get

Property Value

Type: Adt7519TypeInterruptStatus
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InterruptStatus1TEXTTLOW Property

IRD

Adt7519InterruptStatus1TEXTTLOW Property

Interrupt Status 1: T_EXT <= T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeInterruptStatus InterruptStatus1TEXTTLOW { get; }
Public ReadOnly Property InterruptStatus1TEXTTLOW As Adt7519TypeInterruptStatus
    Get
public:
property Adt7519TypeInterruptStatus InterruptStatus1TEXTTLOW {
    Adt7519TypeInterruptStatus get ();
}
member InterruptStatus1TEXTTLOW : Adt7519TypeInterruptStatus with get

Property Value

Type: Adt7519TypeInterruptStatus
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InterruptStatus1TINTTHIGH Property

IRD

Adt7519InterruptStatus1TINTTHIGH Property

Interrupt Status 1: T_INT > T_HIGH

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeInterruptStatus InterruptStatus1TINTTHIGH { get; }
Public ReadOnly Property InterruptStatus1TINTTHIGH As Adt7519TypeInterruptStatus
    Get
public:
property Adt7519TypeInterruptStatus InterruptStatus1TINTTHIGH {
    Adt7519TypeInterruptStatus get ();
}
member InterruptStatus1TINTTHIGH : Adt7519TypeInterruptStatus with get

Property Value

Type: Adt7519TypeInterruptStatus
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InterruptStatus1TINTTLOW Property

IRD

Adt7519InterruptStatus1TINTTLOW Property

Interrupt Status 1: T_INT <= T_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeInterruptStatus InterruptStatus1TINTTLOW { get; }
Public ReadOnly Property InterruptStatus1TINTTLOW As Adt7519TypeInterruptStatus
    Get
public:
property Adt7519TypeInterruptStatus InterruptStatus1TINTTLOW {
    Adt7519TypeInterruptStatus get ();
}
member InterruptStatus1TINTTLOW : Adt7519TypeInterruptStatus with get

Property Value

Type: Adt7519TypeInterruptStatus
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.InterruptStatus2VDDVHIGHVDDVLOW Property

IRD

Adt7519InterruptStatus2VDDVHIGHVDDVLOW Property

Interrupt Status 2: V_DD > V_HIGH / VDD <= V_LOW

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeInterruptStatus InterruptStatus2VDDVHIGHVDDVLOW { get; }
Public ReadOnly Property InterruptStatus2VDDVHIGHVDDVLOW As Adt7519TypeInterruptStatus
    Get
public:
property Adt7519TypeInterruptStatus InterruptStatus2VDDVHIGHVDDVLOW {
    Adt7519TypeInterruptStatus get ();
}
member InterruptStatus2VDDVHIGHVDDVLOW : Adt7519TypeInterruptStatus with get

Property Value

Type: Adt7519TypeInterruptStatus
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.LDACConfigurationDACA Property

IRD

Adt7519LDACConfigurationDACA Property

LDAC Configuration: DAC A

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeLdacConfigurationUpdate LDACConfigurationDACA { set; }
Public WriteOnly Property LDACConfigurationDACA As Adt7519TypeLdacConfigurationUpdate
    Set
public:
property Adt7519TypeLdacConfigurationUpdate LDACConfigurationDACA {
    void set (Adt7519TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACA : Adt7519TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7519TypeLdacConfigurationUpdate
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.LDACConfigurationDACB Property

IRD

Adt7519LDACConfigurationDACB Property

LDAC Configuration: DAC B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeLdacConfigurationUpdate LDACConfigurationDACB { set; }
Public WriteOnly Property LDACConfigurationDACB As Adt7519TypeLdacConfigurationUpdate
    Set
public:
property Adt7519TypeLdacConfigurationUpdate LDACConfigurationDACB {
    void set (Adt7519TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACB : Adt7519TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7519TypeLdacConfigurationUpdate
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.LDACConfigurationDACC Property

IRD

Adt7519LDACConfigurationDACC Property

LDAC Configuration: DAC C

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeLdacConfigurationUpdate LDACConfigurationDACC { set; }
Public WriteOnly Property LDACConfigurationDACC As Adt7519TypeLdacConfigurationUpdate
    Set
public:
property Adt7519TypeLdacConfigurationUpdate LDACConfigurationDACC {
    void set (Adt7519TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACC : Adt7519TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7519TypeLdacConfigurationUpdate
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.LDACConfigurationDACD Property

IRD

Adt7519LDACConfigurationDACD Property

LDAC Configuration: DAC D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeLdacConfigurationUpdate LDACConfigurationDACD { set; }
Public WriteOnly Property LDACConfigurationDACD As Adt7519TypeLdacConfigurationUpdate
    Set
public:
property Adt7519TypeLdacConfigurationUpdate LDACConfigurationDACD {
    void set (Adt7519TypeLdacConfigurationUpdate value);
}
member LDACConfigurationDACD : Adt7519TypeLdacConfigurationUpdate with set

Property Value

Type: Adt7519TypeLdacConfigurationUpdate
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.LDACConfigurationReferenceDACAB Property

IRD

Adt7519LDACConfigurationReferenceDACAB Property

LDAC Configuration: Reference DAC A / B

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeLdacConfigurationReference LDACConfigurationReferenceDACAB { set; }
Public WriteOnly Property LDACConfigurationReferenceDACAB As Adt7519TypeLdacConfigurationReference
    Set
public:
property Adt7519TypeLdacConfigurationReference LDACConfigurationReferenceDACAB {
    void set (Adt7519TypeLdacConfigurationReference value);
}
member LDACConfigurationReferenceDACAB : Adt7519TypeLdacConfigurationReference with set

Property Value

Type: Adt7519TypeLdacConfigurationReference
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.LDACConfigurationReferenceDACCD Property

IRD

Adt7519LDACConfigurationReferenceDACCD Property

LDAC Configuration: Reference DAC C / D

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeLdacConfigurationReference LDACConfigurationReferenceDACCD { set; }
Public WriteOnly Property LDACConfigurationReferenceDACCD As Adt7519TypeLdacConfigurationReference
    Set
public:
property Adt7519TypeLdacConfigurationReference LDACConfigurationReferenceDACCD {
    void set (Adt7519TypeLdacConfigurationReference value);
}
member LDACConfigurationReferenceDACCD : Adt7519TypeLdacConfigurationReference with set

Property Value

Type: Adt7519TypeLdacConfigurationReference
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.ManufacturerSID Property

IRD

Adt7519ManufacturerSID Property

Manufacturer's ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerSID { get; }
Public ReadOnly Property ManufacturerSID As Byte
    Get
public:
property unsigned char ManufacturerSID {
    unsigned char get ();
}
member ManufacturerSID : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.SiliconRevisionStepping Property

IRD

Adt7519SiliconRevisionStepping Property

Silicon Revision: Stepping

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SiliconRevisionStepping { get; }
Public ReadOnly Property SiliconRevisionStepping As Byte
    Get
public:
property unsigned char SiliconRevisionStepping {
    unsigned char get ();
}
member SiliconRevisionStepping : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.SiliconRevisionVersion Property

IRD

Adt7519SiliconRevisionVersion Property

Silicon Revision: Version

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SiliconRevisionVersion { get; }
Public ReadOnly Property SiliconRevisionVersion As Byte
    Get
public:
property unsigned char SiliconRevisionVersion {
    unsigned char get ();
}
member SiliconRevisionVersion : byte with get

Property Value

Type: Byte
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.SPILockStatus Property

IRD

Adt7519SPILockStatus Property

SPI Lock Status

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adt7519TypeSpiLockStatus SPILockStatus { get; }
Public ReadOnly Property SPILockStatus As Adt7519TypeSpiLockStatus
    Get
public:
property Adt7519TypeSpiLockStatus SPILockStatus {
    Adt7519TypeSpiLockStatus get ();
}
member SPILockStatus : Adt7519TypeSpiLockStatus with get

Property Value

Type: Adt7519TypeSpiLockStatus
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.VDD Property

IRD

Adt7519VDD Property

V_DD (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDD { get; }
Public ReadOnly Property VDD As Double
    Get
public:
property double VDD {
    double get ();
}
member VDD : float with get

Property Value

Type: Double
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.VDDVHIGHLimit Property

IRD

Adt7519VDDVHIGHLimit Property

V_DD V_HIGH Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDDVHIGHLimit { get; set; }
Public Property VDDVHIGHLimit As Double
    Get
    Set
public:
property double VDDVHIGHLimit {
    double get ();
    void set (double value);
}
member VDDVHIGHLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.VDDVLOWLimit Property

IRD

Adt7519VDDVLOWLimit Property

V_DD V_LOW Limit (unit: V)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VDDVLOWLimit { get; set; }
Public Property VDDVLOWLimit As Double
    Get
    Set
public:
property double VDDVLOWLimit {
    double get ();
    void set (double value);
}
member VDDVLOWLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519 Methods

The Adt7519 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.Flush Method

IRD

Adt7519Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adt7519 Class
telos.Ird.AnalogDevices Namespace


Adt7519.TypeControlConfiguration1AinTdmSelection Enumeration

IRD

Adt7519TypeControlConfiguration1AinTdmSelection Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1AinTdmSelection
Public Enumeration TypeControlConfiguration1AinTdmSelection
public enum class TypeControlConfiguration1AinTdmSelection
type TypeControlConfiguration1AinTdmSelection
Members
Member name | Value | Description
AIN1AndAIN2 | 0 | AIN1 and AIN2
Reserved | 1 | Reserved
ExternalTDM | 2 | External TDM
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeControlConfiguration1IntOutput Enumeration

IRD

Adt7519TypeControlConfiguration1IntOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1IntOutput
Public Enumeration TypeControlConfiguration1IntOutput
public enum class TypeControlConfiguration1IntOutput
type TypeControlConfiguration1IntOutput
Members
Member name | Value | Description
INTOutputEnabled | 0 | INT Output: Enabled
INTOutputDisabled | 1 | INT Output: Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeControlConfiguration1IntOutputPolarity Enumeration

IRD

Adt7519TypeControlConfiguration1IntOutputPolarity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1IntOutputPolarity
Public Enumeration TypeControlConfiguration1IntOutputPolarity
public enum class TypeControlConfiguration1IntOutputPolarity
type TypeControlConfiguration1IntOutputPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeControlConfiguration1LdacAin3 Enumeration

IRD

Adt7519TypeControlConfiguration1LdacAin3 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1LdacAin3
Public Enumeration TypeControlConfiguration1LdacAin3
public enum class TypeControlConfiguration1LdacAin3
type TypeControlConfiguration1LdacAin3
Members
Member name | Value | Description
LDAC | 0 | LDAC
AIN3 | 1 | AIN3
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeControlConfiguration1Monitoring Enumeration

IRD

Adt7519TypeControlConfiguration1Monitoring Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1Monitoring
Public Enumeration TypeControlConfiguration1Monitoring
public enum class TypeControlConfiguration1Monitoring
type TypeControlConfiguration1Monitoring
Members
Member name | Value | Description
StopMonitoring | 0 | Stop Monitoring
StartMonitoring | 1 | Start Monitoring
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeControlConfiguration1PowerDown Enumeration

IRD

Adt7519TypeControlConfiguration1PowerDown Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration1PowerDown
Public Enumeration TypeControlConfiguration1PowerDown
public enum class TypeControlConfiguration1PowerDown
type TypeControlConfiguration1PowerDown
Members
Member name | Value | Description
PowerUp | 0 | Power Up
PowerDown | 1 | Power Down
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeControlConfiguration2Averaging Enumeration

IRD

Adt7519TypeControlConfiguration2Averaging Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Averaging
Public Enumeration TypeControlConfiguration2Averaging
public enum class TypeControlConfiguration2Averaging
type TypeControlConfiguration2Averaging
Members
Member name | Value | Description
AveragingEnabled | 0 | Averaging Enabled
AveragingDisabled | 1 | Averaging Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeControlConfiguration2ChannelSelection Enumeration

IRD

Adt7519TypeControlConfiguration2ChannelSelection Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2ChannelSelection
Public Enumeration TypeControlConfiguration2ChannelSelection
public enum class TypeControlConfiguration2ChannelSelection
type TypeControlConfiguration2ChannelSelection
Members
Member name | Value | Description
VDD | 0 | V_DD
InternalTemperatureSensor | 1 | Internal Temperature Sensor
ExternalTemperatureSensorAIN1 | 2 | External Temperature Sensor / AIN1
AIN2 | 3 | AIN2
AIN3 | 4 | AIN3
AIN4 | 5 | AIN4
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeControlConfiguration2Conversion Enumeration

IRD

Adt7519TypeControlConfiguration2Conversion Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Conversion
Public Enumeration TypeControlConfiguration2Conversion
public enum class TypeControlConfiguration2Conversion
type TypeControlConfiguration2Conversion
Members
Member name | Value | Description
RoundRobin | 0 | Round Robin
SingleChannel | 1 | Single Channel
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeControlConfiguration2SoftwareReset Enumeration

IRD

Adt7519TypeControlConfiguration2SoftwareReset Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2SoftwareReset
Public Enumeration TypeControlConfiguration2SoftwareReset
public enum class TypeControlConfiguration2SoftwareReset
type TypeControlConfiguration2SoftwareReset
Members
Member name | Value | Description
Default | 0 | Default
SoftwareReset | 1 | Software Reset
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeControlConfiguration2Timeout Enumeration

IRD

Adt7519TypeControlConfiguration2Timeout Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration2Timeout
Public Enumeration TypeControlConfiguration2Timeout
public enum class TypeControlConfiguration2Timeout
type TypeControlConfiguration2Timeout
Members
Member name | Value | Description
SMBusTimeoutDisabled | 0 | SMBus Timeout: Disabled
SMBusTimeoutEnabled | 1 | SMBus Timeout: Enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeControlConfiguration3AdcReference Enumeration

IRD

Adt7519TypeControlConfiguration3AdcReference Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3AdcReference
Public Enumeration TypeControlConfiguration3AdcReference
public enum class TypeControlConfiguration3AdcReference
type TypeControlConfiguration3AdcReference
Members
Member name | Value | Description
InternalVREF | 0 | Internal V_REF
VDD | 1 | V_DD
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeControlConfiguration3DacAOutput Enumeration

IRD

Adt7519TypeControlConfiguration3DacAOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3DacAOutput
Public Enumeration TypeControlConfiguration3DacAOutput
public enum class TypeControlConfiguration3DacAOutput
type TypeControlConfiguration3DacAOutput
Members
Member name | Value | Description
NotProportional | 0 | Not Proportional
Proportional | 1 | Proportional
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeControlConfiguration3DacBOutput Enumeration

IRD

Adt7519TypeControlConfiguration3DacBOutput Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3DacBOutput
Public Enumeration TypeControlConfiguration3DacBOutput
public enum class TypeControlConfiguration3DacBOutput
type TypeControlConfiguration3DacBOutput
Members
Member name | Value | Description
NotProportional | 0 | Not Proportional
Proportional | 1 | Proportional
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeControlConfiguration3Resolution Enumeration

IRD

Adt7519TypeControlConfiguration3Resolution Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3Resolution
Public Enumeration TypeControlConfiguration3Resolution
public enum class TypeControlConfiguration3Resolution
type TypeControlConfiguration3Resolution
Members
Member name | Value | Description
Value_8Bit | 0 | 8-bit
Value_10Bit | 1 | 10-bit
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeControlConfiguration3Speed Enumeration

IRD

Adt7519TypeControlConfiguration3Speed Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3Speed
Public Enumeration TypeControlConfiguration3Speed
public enum class TypeControlConfiguration3Speed
type TypeControlConfiguration3Speed
Members
Member name | Value | Description
Value_14KHz | 0 | 1.4 kHz
Value_225KHz | 1 | 22.5 kHz
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeControlConfiguration3UpdatingDacOutputs Enumeration

IRD

Adt7519TypeControlConfiguration3UpdatingDacOutputs Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlConfiguration3UpdatingDacOutputs
Public Enumeration TypeControlConfiguration3UpdatingDacOutputs
public enum class TypeControlConfiguration3UpdatingDacOutputs
type TypeControlConfiguration3UpdatingDacOutputs
Members
Member name | Value | Description
LDACPin | 0 | LDAC Pin
DACLDACConfiguration | 1 | DAC & LDAC Configuration
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeDacConfigurationRange Enumeration

IRD

Adt7519TypeDacConfigurationRange Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacConfigurationRange
Public Enumeration TypeDacConfigurationRange
public enum class TypeDacConfigurationRange
type TypeDacConfigurationRange
Members
Member name | Value | Description
Value_0VToVREF | 0 | 0V to V_REF
Value_0VTo2VREF | 1 | 0V to 2 V_REF
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeDacConfigurationUpdate Enumeration

IRD

Adt7519TypeDacConfigurationUpdate Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacConfigurationUpdate
Public Enumeration TypeDacConfigurationUpdate
public enum class TypeDacConfigurationUpdate
type TypeDacConfigurationUpdate
Members
Member name | Value | Description
MSBWriteToAnyDACRegisterGeneratesLDACCommandThatUpdatesThatDACOnly | 0 | MSB write to any DAC register generates LDAC command that updates that DAC only
MSBWriteToDACBOrDACDRegisterGeneratesLDACCommandThatUpdatesDACAAndDACBOrDACCAndDACDRespectively | 1 | MSB write to DAC B or DAC D register generates LDAC command that updates DAC A and DAC B or DAC C and DAC D, respectively
MSBWriteToDACDRegisterGeneratesLDACCommandThatUpdatesAllFourDACs | 2 | MSB write to DAC D register generates LDAC command that updates all four DACs
LDACCommandGeneratedFromLDACRegister | 3 | LDAC command generated from LDAC register
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeInterruptMaskEnableDisable Enumeration

IRD

Adt7519TypeInterruptMaskEnableDisable Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptMaskEnableDisable
Public Enumeration TypeInterruptMaskEnableDisable
public enum class TypeInterruptMaskEnableDisable
type TypeInterruptMaskEnableDisable
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeInterruptStatus Enumeration

IRD

Adt7519TypeInterruptStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatus
Public Enumeration TypeInterruptStatus
public enum class TypeInterruptStatus
type TypeInterruptStatus
Members
Member name | Value | Description
NotSet | 0 | Not Set
Set | 1 | Set
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeLdacConfigurationReference Enumeration

IRD

Adt7519TypeLdacConfigurationReference Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLdacConfigurationReference
Public Enumeration TypeLdacConfigurationReference
public enum class TypeLdacConfigurationReference
type TypeLdacConfigurationReference
Members
Member name | Value | Description
ExternalVREF | 0 | External V_REF
InternelVREF | 1 | Internel V_REF
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeLdacConfigurationUpdate Enumeration

IRD

Adt7519TypeLdacConfigurationUpdate Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLdacConfigurationUpdate
Public Enumeration TypeLdacConfigurationUpdate
public enum class TypeLdacConfigurationUpdate
type TypeLdacConfigurationUpdate
Members
Member name | Value | Description
DoNotUpdate | 0 | Do Not Update
Update | 1 | Update
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adt7519.TypeSpiLockStatus Enumeration

IRD

Adt7519TypeSpiLockStatus Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSpiLockStatus
Public Enumeration TypeSpiLockStatus
public enum class TypeSpiLockStatus
type TypeSpiLockStatus
Members
Member name | Value | Description
I2CInterface | 0 | I2C Interface
SPIInterfaceLocked | 1 | SPI Interface / Locked
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312 Class

Analog Devices: ADXL 312
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdxl312

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adxl312
Public Class Adxl312
public ref class Adxl312
type Adxl312 =  class end

The Adxl312 type exposes the following members.

Constructors
 | Name | Description
Public method | Adxl312 | Constructor
Top
Properties
 | Name | Description
Public property | ActInactControlACTACDC | Act Inact Control (ACT AC/DC)
Public property | ActInactControlACTXEN | Act Inact Control (ACT X EN)
Public property | ActInactControlACTYEN | Act Inact Control (ACT Y EN)
Public property | ActInactControlACTZEN | Act Inact Control (ACT Z EN)
Public property | ActInactControlINACTACDC | Act Inact Control (INACT AC/DC)
Public property | ActInactControlINACTXEN | Act Inact Control (INACT X EN)
Public property | ActInactControlINACTYEN | Act Inact Control (INACT Y EN)
Public property | ActInactControlINACTZEN | Act Inact Control (INACT Z EN)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BWRateLowPower | BW Rate (Low Power)
Public property | BWRateRate | BW Rate (Rate)
Public property | DataFormatFullRes | Data Format (Full Res)
Public property | DataFormatIntInvert | Data Format (Int Invert)
Public property | DataFormatJustify | Data Format (Justify)
Public property | DataFormatRange | Data Format (Range)
Public property | DataFormatSelfTest | Data Format (Self Test)
Public property | DataFormatSPI | Data Format (SPI)
Public property | DataX | Data X
Public property | DataY | Data Y
Public property | DataZ | Data Z
Public property | DeviceID | Device ID
Public property | FIFOCTLFIFOMode | FIFO CTL (FIFO Mode)
Public property | FIFOCTLSamples | FIFO CTL (Samples)
Public property | FIFOCTLTrigger | FIFO CTL (Trigger)
Public property | FIFOStatusEntries | FIFO Status (Entries)
Public property | FIFOStatusFIFOTrig | FIFO Status (FIFO Trig)
Public property | INTEnableActivity | INT Enable (Activity)
Public property | INTEnableDataReady | INT Enable (Data Ready)
Public property | INTEnableInactivity | INT Enable (Inactivity)
Public property | INTEnableOverrun | INT Enable (Overrun)
Public property | INTEnableWatermark | INT Enable (Watermark)
Public property | INTMapActivity | INT Map (Activity)
Public property | INTMapDataReady | INT Map (Data Ready)
Public property | INTMapInactivity | INT Map (Inactivity)
Public property | INTMapOverrun | INT Map (Overrun)
Public property | INTMapWatermark | INT Map (Watermark)
Public property | INTSourceActivity | INT Source (Activity)
Public property | INTSourceDataReady | INT Source (Data Ready)
Public property | INTSourceInactivity | INT Source (Inactivity)
Public property | INTSourceOverrun | INT Source (Overrun)
Public property | INTSourceWatermark | INT Source (Watermark)
Public property | OFSX | OFSX (unit: mg)
Public property | OFSY | OFSY (unit: mg)
Public property | OFSZ | OFSZ (unit: mg)
Public property | PowerCTLAutoSleep | Power CTL (Auto Sleep)
Public property | PowerCTLLink | Power CTL (Link)
Public property | PowerCTLMeasure | Power CTL (Measure)
Public property | PowerCTLSleep | Power CTL (Sleep)
Public property | PowerCTLWakeUp | Power CTL (Wake Up)
Public property | ThreshAct | Thresh Act (unit: mg)
Public property | ThreshInact | Thresh Inact (unit: mg)
Public property | TimeInact | Time Inact (unit: s)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
3-Axis, ±1.5 g/±3 g/±6 g/±12 g Digital Accelerometer
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adxl312(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adxl312

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312 Properties

The Adxl312 type exposes the following members.

Properties
 | Name | Description
Public property | ActInactControlACTACDC | Act Inact Control (ACT AC/DC)
Public property | ActInactControlACTXEN | Act Inact Control (ACT X EN)
Public property | ActInactControlACTYEN | Act Inact Control (ACT Y EN)
Public property | ActInactControlACTZEN | Act Inact Control (ACT Z EN)
Public property | ActInactControlINACTACDC | Act Inact Control (INACT AC/DC)
Public property | ActInactControlINACTXEN | Act Inact Control (INACT X EN)
Public property | ActInactControlINACTYEN | Act Inact Control (INACT Y EN)
Public property | ActInactControlINACTZEN | Act Inact Control (INACT Z EN)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BWRateLowPower | BW Rate (Low Power)
Public property | BWRateRate | BW Rate (Rate)
Public property | DataFormatFullRes | Data Format (Full Res)
Public property | DataFormatIntInvert | Data Format (Int Invert)
Public property | DataFormatJustify | Data Format (Justify)
Public property | DataFormatRange | Data Format (Range)
Public property | DataFormatSelfTest | Data Format (Self Test)
Public property | DataFormatSPI | Data Format (SPI)
Public property | DataX | Data X
Public property | DataY | Data Y
Public property | DataZ | Data Z
Public property | DeviceID | Device ID
Public property | FIFOCTLFIFOMode | FIFO CTL (FIFO Mode)
Public property | FIFOCTLSamples | FIFO CTL (Samples)
Public property | FIFOCTLTrigger | FIFO CTL (Trigger)
Public property | FIFOStatusEntries | FIFO Status (Entries)
Public property | FIFOStatusFIFOTrig | FIFO Status (FIFO Trig)
Public property | INTEnableActivity | INT Enable (Activity)
Public property | INTEnableDataReady | INT Enable (Data Ready)
Public property | INTEnableInactivity | INT Enable (Inactivity)
Public property | INTEnableOverrun | INT Enable (Overrun)
Public property | INTEnableWatermark | INT Enable (Watermark)
Public property | INTMapActivity | INT Map (Activity)
Public property | INTMapDataReady | INT Map (Data Ready)
Public property | INTMapInactivity | INT Map (Inactivity)
Public property | INTMapOverrun | INT Map (Overrun)
Public property | INTMapWatermark | INT Map (Watermark)
Public property | INTSourceActivity | INT Source (Activity)
Public property | INTSourceDataReady | INT Source (Data Ready)
Public property | INTSourceInactivity | INT Source (Inactivity)
Public property | INTSourceOverrun | INT Source (Overrun)
Public property | INTSourceWatermark | INT Source (Watermark)
Public property | OFSX | OFSX (unit: mg)
Public property | OFSY | OFSY (unit: mg)
Public property | OFSZ | OFSZ (unit: mg)
Public property | PowerCTLAutoSleep | Power CTL (Auto Sleep)
Public property | PowerCTLLink | Power CTL (Link)
Public property | PowerCTLMeasure | Power CTL (Measure)
Public property | PowerCTLSleep | Power CTL (Sleep)
Public property | PowerCTLWakeUp | Power CTL (Wake Up)
Public property | ThreshAct | Thresh Act (unit: mg)
Public property | ThreshInact | Thresh Inact (unit: mg)
Public property | TimeInact | Time Inact (unit: s)
Top
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.ActInactControlACTACDC Property

IRD

Adxl312ActInactControlACTACDC Property

Act Inact Control (ACT AC/DC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeActInactCtlActAcDc ActInactControlACTACDC { get; set; }
Public Property ActInactControlACTACDC As Adxl312TypeActInactCtlActAcDc
    Get
    Set
public:
property Adxl312TypeActInactCtlActAcDc ActInactControlACTACDC {
    Adxl312TypeActInactCtlActAcDc get ();
    void set (Adxl312TypeActInactCtlActAcDc value);
}
member ActInactControlACTACDC : Adxl312TypeActInactCtlActAcDc with get, set

Property Value

Type: Adxl312TypeActInactCtlActAcDc
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.ActInactControlACTXEN Property

IRD

Adxl312ActInactControlACTXEN Property

Act Inact Control (ACT X EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeActInactCtlActX ActInactControlACTXEN { get; set; }
Public Property ActInactControlACTXEN As Adxl312TypeActInactCtlActX
    Get
    Set
public:
property Adxl312TypeActInactCtlActX ActInactControlACTXEN {
    Adxl312TypeActInactCtlActX get ();
    void set (Adxl312TypeActInactCtlActX value);
}
member ActInactControlACTXEN : Adxl312TypeActInactCtlActX with get, set

Property Value

Type: Adxl312TypeActInactCtlActX
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.ActInactControlACTYEN Property

IRD

Adxl312ActInactControlACTYEN Property

Act Inact Control (ACT Y EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeActInactCtlActY ActInactControlACTYEN { get; set; }
Public Property ActInactControlACTYEN As Adxl312TypeActInactCtlActY
    Get
    Set
public:
property Adxl312TypeActInactCtlActY ActInactControlACTYEN {
    Adxl312TypeActInactCtlActY get ();
    void set (Adxl312TypeActInactCtlActY value);
}
member ActInactControlACTYEN : Adxl312TypeActInactCtlActY with get, set

Property Value

Type: Adxl312TypeActInactCtlActY
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.ActInactControlACTZEN Property

IRD

Adxl312ActInactControlACTZEN Property

Act Inact Control (ACT Z EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeActInactCtlActZ ActInactControlACTZEN { get; set; }
Public Property ActInactControlACTZEN As Adxl312TypeActInactCtlActZ
    Get
    Set
public:
property Adxl312TypeActInactCtlActZ ActInactControlACTZEN {
    Adxl312TypeActInactCtlActZ get ();
    void set (Adxl312TypeActInactCtlActZ value);
}
member ActInactControlACTZEN : Adxl312TypeActInactCtlActZ with get, set

Property Value

Type: Adxl312TypeActInactCtlActZ
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.ActInactControlINACTACDC Property

IRD

Adxl312ActInactControlINACTACDC Property

Act Inact Control (INACT AC/DC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeActInactCtlInactAcDc ActInactControlINACTACDC { get; set; }
Public Property ActInactControlINACTACDC As Adxl312TypeActInactCtlInactAcDc
    Get
    Set
public:
property Adxl312TypeActInactCtlInactAcDc ActInactControlINACTACDC {
    Adxl312TypeActInactCtlInactAcDc get ();
    void set (Adxl312TypeActInactCtlInactAcDc value);
}
member ActInactControlINACTACDC : Adxl312TypeActInactCtlInactAcDc with get, set

Property Value

Type: Adxl312TypeActInactCtlInactAcDc
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.ActInactControlINACTXEN Property

IRD

Adxl312ActInactControlINACTXEN Property

Act Inact Control (INACT X EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeActInactCtlInactX ActInactControlINACTXEN { get; set; }
Public Property ActInactControlINACTXEN As Adxl312TypeActInactCtlInactX
    Get
    Set
public:
property Adxl312TypeActInactCtlInactX ActInactControlINACTXEN {
    Adxl312TypeActInactCtlInactX get ();
    void set (Adxl312TypeActInactCtlInactX value);
}
member ActInactControlINACTXEN : Adxl312TypeActInactCtlInactX with get, set

Property Value

Type: Adxl312TypeActInactCtlInactX
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.ActInactControlINACTYEN Property

IRD

Adxl312ActInactControlINACTYEN Property

Act Inact Control (INACT Y EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeActInactCtlInactY ActInactControlINACTYEN { get; set; }
Public Property ActInactControlINACTYEN As Adxl312TypeActInactCtlInactY
    Get
    Set
public:
property Adxl312TypeActInactCtlInactY ActInactControlINACTYEN {
    Adxl312TypeActInactCtlInactY get ();
    void set (Adxl312TypeActInactCtlInactY value);
}
member ActInactControlINACTYEN : Adxl312TypeActInactCtlInactY with get, set

Property Value

Type: Adxl312TypeActInactCtlInactY
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.ActInactControlINACTZEN Property

IRD

Adxl312ActInactControlINACTZEN Property

Act Inact Control (INACT Z EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeActInactCtlActZ ActInactControlINACTZEN { get; set; }
Public Property ActInactControlINACTZEN As Adxl312TypeActInactCtlActZ
    Get
    Set
public:
property Adxl312TypeActInactCtlActZ ActInactControlINACTZEN {
    Adxl312TypeActInactCtlActZ get ();
    void set (Adxl312TypeActInactCtlActZ value);
}
member ActInactControlINACTZEN : Adxl312TypeActInactCtlActZ with get, set

Property Value

Type: Adxl312TypeActInactCtlActZ
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.AutoFlush Property

IRD

Adxl312AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.BWRateLowPower Property

IRD

Adxl312BWRateLowPower Property

BW Rate (Low Power)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeBwRateLowPower BWRateLowPower { get; set; }
Public Property BWRateLowPower As Adxl312TypeBwRateLowPower
    Get
    Set
public:
property Adxl312TypeBwRateLowPower BWRateLowPower {
    Adxl312TypeBwRateLowPower get ();
    void set (Adxl312TypeBwRateLowPower value);
}
member BWRateLowPower : Adxl312TypeBwRateLowPower with get, set

Property Value

Type: Adxl312TypeBwRateLowPower
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.BWRateRate Property

IRD

Adxl312BWRateRate Property

BW Rate (Rate)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeBwRateRateBits BWRateRate { get; set; }
Public Property BWRateRate As Adxl312TypeBwRateRateBits
    Get
    Set
public:
property Adxl312TypeBwRateRateBits BWRateRate {
    Adxl312TypeBwRateRateBits get ();
    void set (Adxl312TypeBwRateRateBits value);
}
member BWRateRate : Adxl312TypeBwRateRateBits with get, set

Property Value

Type: Adxl312TypeBwRateRateBits
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.DataFormatFullRes Property

IRD

Adxl312DataFormatFullRes Property

Data Format (Full Res)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeDataFormatFullRes DataFormatFullRes { get; set; }
Public Property DataFormatFullRes As Adxl312TypeDataFormatFullRes
    Get
    Set
public:
property Adxl312TypeDataFormatFullRes DataFormatFullRes {
    Adxl312TypeDataFormatFullRes get ();
    void set (Adxl312TypeDataFormatFullRes value);
}
member DataFormatFullRes : Adxl312TypeDataFormatFullRes with get, set

Property Value

Type: Adxl312TypeDataFormatFullRes
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.DataFormatIntInvert Property

IRD

Adxl312DataFormatIntInvert Property

Data Format (Int Invert)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeDataFormatIntInvert DataFormatIntInvert { get; set; }
Public Property DataFormatIntInvert As Adxl312TypeDataFormatIntInvert
    Get
    Set
public:
property Adxl312TypeDataFormatIntInvert DataFormatIntInvert {
    Adxl312TypeDataFormatIntInvert get ();
    void set (Adxl312TypeDataFormatIntInvert value);
}
member DataFormatIntInvert : Adxl312TypeDataFormatIntInvert with get, set

Property Value

Type: Adxl312TypeDataFormatIntInvert
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.DataFormatJustify Property

IRD

Adxl312DataFormatJustify Property

Data Format (Justify)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeDataFormatJustify DataFormatJustify { get; set; }
Public Property DataFormatJustify As Adxl312TypeDataFormatJustify
    Get
    Set
public:
property Adxl312TypeDataFormatJustify DataFormatJustify {
    Adxl312TypeDataFormatJustify get ();
    void set (Adxl312TypeDataFormatJustify value);
}
member DataFormatJustify : Adxl312TypeDataFormatJustify with get, set

Property Value

Type: Adxl312TypeDataFormatJustify
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.DataFormatRange Property

IRD

Adxl312DataFormatRange Property

Data Format (Range)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeDataFormatRange DataFormatRange { get; set; }
Public Property DataFormatRange As Adxl312TypeDataFormatRange
    Get
    Set
public:
property Adxl312TypeDataFormatRange DataFormatRange {
    Adxl312TypeDataFormatRange get ();
    void set (Adxl312TypeDataFormatRange value);
}
member DataFormatRange : Adxl312TypeDataFormatRange with get, set

Property Value

Type: Adxl312TypeDataFormatRange
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.DataFormatSelfTest Property

IRD

Adxl312DataFormatSelfTest Property

Data Format (Self Test)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeDataFormatSelfTest DataFormatSelfTest { get; set; }
Public Property DataFormatSelfTest As Adxl312TypeDataFormatSelfTest
    Get
    Set
public:
property Adxl312TypeDataFormatSelfTest DataFormatSelfTest {
    Adxl312TypeDataFormatSelfTest get ();
    void set (Adxl312TypeDataFormatSelfTest value);
}
member DataFormatSelfTest : Adxl312TypeDataFormatSelfTest with get, set

Property Value

Type: Adxl312TypeDataFormatSelfTest
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.DataFormatSPI Property

IRD

Adxl312DataFormatSPI Property

Data Format (SPI)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeDataFormatSpi DataFormatSPI { get; set; }
Public Property DataFormatSPI As Adxl312TypeDataFormatSpi
    Get
    Set
public:
property Adxl312TypeDataFormatSpi DataFormatSPI {
    Adxl312TypeDataFormatSpi get ();
    void set (Adxl312TypeDataFormatSpi value);
}
member DataFormatSPI : Adxl312TypeDataFormatSpi with get, set

Property Value

Type: Adxl312TypeDataFormatSpi
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.DataX Property

IRD

Adxl312DataX Property

Data X

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short DataX { get; }
Public ReadOnly Property DataX As Short
    Get
public:
property short DataX {
    short get ();
}
member DataX : int16 with get

Property Value

Type: Int16
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.DataY Property

IRD

Adxl312DataY Property

Data Y

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short DataY { get; }
Public ReadOnly Property DataY As Short
    Get
public:
property short DataY {
    short get ();
}
member DataY : int16 with get

Property Value

Type: Int16
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.DataZ Property

IRD

Adxl312DataZ Property

Data Z

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short DataZ { get; }
Public ReadOnly Property DataZ As Short
    Get
public:
property short DataZ {
    short get ();
}
member DataZ : int16 with get

Property Value

Type: Int16
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.DeviceID Property

IRD

Adxl312DeviceID Property

Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.FIFOCTLFIFOMode Property

IRD

Adxl312FIFOCTLFIFOMode Property

FIFO CTL (FIFO Mode)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeFifoCtlFifoMode FIFOCTLFIFOMode { get; set; }
Public Property FIFOCTLFIFOMode As Adxl312TypeFifoCtlFifoMode
    Get
    Set
public:
property Adxl312TypeFifoCtlFifoMode FIFOCTLFIFOMode {
    Adxl312TypeFifoCtlFifoMode get ();
    void set (Adxl312TypeFifoCtlFifoMode value);
}
member FIFOCTLFIFOMode : Adxl312TypeFifoCtlFifoMode with get, set

Property Value

Type: Adxl312TypeFifoCtlFifoMode
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.FIFOCTLSamples Property

IRD

Adxl312FIFOCTLSamples Property

FIFO CTL (Samples)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOCTLSamples { get; set; }
Public Property FIFOCTLSamples As Byte
    Get
    Set
public:
property unsigned char FIFOCTLSamples {
    unsigned char get ();
    void set (unsigned char value);
}
member FIFOCTLSamples : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.FIFOCTLTrigger Property

IRD

Adxl312FIFOCTLTrigger Property

FIFO CTL (Trigger)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeFifoCtlTrigger FIFOCTLTrigger { get; set; }
Public Property FIFOCTLTrigger As Adxl312TypeFifoCtlTrigger
    Get
    Set
public:
property Adxl312TypeFifoCtlTrigger FIFOCTLTrigger {
    Adxl312TypeFifoCtlTrigger get ();
    void set (Adxl312TypeFifoCtlTrigger value);
}
member FIFOCTLTrigger : Adxl312TypeFifoCtlTrigger with get, set

Property Value

Type: Adxl312TypeFifoCtlTrigger
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.FIFOStatusEntries Property

IRD

Adxl312FIFOStatusEntries Property

FIFO Status (Entries)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOStatusEntries { get; }
Public ReadOnly Property FIFOStatusEntries As Byte
    Get
public:
property unsigned char FIFOStatusEntries {
    unsigned char get ();
}
member FIFOStatusEntries : byte with get

Property Value

Type: Byte
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.FIFOStatusFIFOTrig Property

IRD

Adxl312FIFOStatusFIFOTrig Property

FIFO Status (FIFO Trig)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeFifoStatusFifoTrig FIFOStatusFIFOTrig { get; }
Public ReadOnly Property FIFOStatusFIFOTrig As Adxl312TypeFifoStatusFifoTrig
    Get
public:
property Adxl312TypeFifoStatusFifoTrig FIFOStatusFIFOTrig {
    Adxl312TypeFifoStatusFifoTrig get ();
}
member FIFOStatusFIFOTrig : Adxl312TypeFifoStatusFifoTrig with get

Property Value

Type: Adxl312TypeFifoStatusFifoTrig
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.INTEnableActivity Property

IRD

Adxl312INTEnableActivity Property

INT Enable (Activity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeIntEnableActivity INTEnableActivity { get; set; }
Public Property INTEnableActivity As Adxl312TypeIntEnableActivity
    Get
    Set
public:
property Adxl312TypeIntEnableActivity INTEnableActivity {
    Adxl312TypeIntEnableActivity get ();
    void set (Adxl312TypeIntEnableActivity value);
}
member INTEnableActivity : Adxl312TypeIntEnableActivity with get, set

Property Value

Type: Adxl312TypeIntEnableActivity
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.INTEnableDataReady Property

IRD

Adxl312INTEnableDataReady Property

INT Enable (Data Ready)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeIntEnableDataReady INTEnableDataReady { get; set; }
Public Property INTEnableDataReady As Adxl312TypeIntEnableDataReady
    Get
    Set
public:
property Adxl312TypeIntEnableDataReady INTEnableDataReady {
    Adxl312TypeIntEnableDataReady get ();
    void set (Adxl312TypeIntEnableDataReady value);
}
member INTEnableDataReady : Adxl312TypeIntEnableDataReady with get, set

Property Value

Type: Adxl312TypeIntEnableDataReady
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.INTEnableInactivity Property

IRD

Adxl312INTEnableInactivity Property

INT Enable (Inactivity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeIntEnableInactivity INTEnableInactivity { get; set; }
Public Property INTEnableInactivity As Adxl312TypeIntEnableInactivity
    Get
    Set
public:
property Adxl312TypeIntEnableInactivity INTEnableInactivity {
    Adxl312TypeIntEnableInactivity get ();
    void set (Adxl312TypeIntEnableInactivity value);
}
member INTEnableInactivity : Adxl312TypeIntEnableInactivity with get, set

Property Value

Type: Adxl312TypeIntEnableInactivity
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.INTEnableOverrun Property

IRD

Adxl312INTEnableOverrun Property

INT Enable (Overrun)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeIntEnableOverrun INTEnableOverrun { get; set; }
Public Property INTEnableOverrun As Adxl312TypeIntEnableOverrun
    Get
    Set
public:
property Adxl312TypeIntEnableOverrun INTEnableOverrun {
    Adxl312TypeIntEnableOverrun get ();
    void set (Adxl312TypeIntEnableOverrun value);
}
member INTEnableOverrun : Adxl312TypeIntEnableOverrun with get, set

Property Value

Type: Adxl312TypeIntEnableOverrun
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.INTEnableWatermark Property

IRD

Adxl312INTEnableWatermark Property

INT Enable (Watermark)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeIntEnableWatermark INTEnableWatermark { get; set; }
Public Property INTEnableWatermark As Adxl312TypeIntEnableWatermark
    Get
    Set
public:
property Adxl312TypeIntEnableWatermark INTEnableWatermark {
    Adxl312TypeIntEnableWatermark get ();
    void set (Adxl312TypeIntEnableWatermark value);
}
member INTEnableWatermark : Adxl312TypeIntEnableWatermark with get, set

Property Value

Type: Adxl312TypeIntEnableWatermark
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.INTMapActivity Property

IRD

Adxl312INTMapActivity Property

INT Map (Activity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeIntMapActivity INTMapActivity { get; set; }
Public Property INTMapActivity As Adxl312TypeIntMapActivity
    Get
    Set
public:
property Adxl312TypeIntMapActivity INTMapActivity {
    Adxl312TypeIntMapActivity get ();
    void set (Adxl312TypeIntMapActivity value);
}
member INTMapActivity : Adxl312TypeIntMapActivity with get, set

Property Value

Type: Adxl312TypeIntMapActivity
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.INTMapDataReady Property

IRD

Adxl312INTMapDataReady Property

INT Map (Data Ready)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeIntMapDataReady INTMapDataReady { get; set; }
Public Property INTMapDataReady As Adxl312TypeIntMapDataReady
    Get
    Set
public:
property Adxl312TypeIntMapDataReady INTMapDataReady {
    Adxl312TypeIntMapDataReady get ();
    void set (Adxl312TypeIntMapDataReady value);
}
member INTMapDataReady : Adxl312TypeIntMapDataReady with get, set

Property Value

Type: Adxl312TypeIntMapDataReady
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.INTMapInactivity Property

IRD

Adxl312INTMapInactivity Property

INT Map (Inactivity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeIntMapInactivity INTMapInactivity { get; set; }
Public Property INTMapInactivity As Adxl312TypeIntMapInactivity
    Get
    Set
public:
property Adxl312TypeIntMapInactivity INTMapInactivity {
    Adxl312TypeIntMapInactivity get ();
    void set (Adxl312TypeIntMapInactivity value);
}
member INTMapInactivity : Adxl312TypeIntMapInactivity with get, set

Property Value

Type: Adxl312TypeIntMapInactivity
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.INTMapOverrun Property

IRD

Adxl312INTMapOverrun Property

INT Map (Overrun)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeIntMapOverrun INTMapOverrun { get; set; }
Public Property INTMapOverrun As Adxl312TypeIntMapOverrun
    Get
    Set
public:
property Adxl312TypeIntMapOverrun INTMapOverrun {
    Adxl312TypeIntMapOverrun get ();
    void set (Adxl312TypeIntMapOverrun value);
}
member INTMapOverrun : Adxl312TypeIntMapOverrun with get, set

Property Value

Type: Adxl312TypeIntMapOverrun
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.INTMapWatermark Property

IRD

Adxl312INTMapWatermark Property

INT Map (Watermark)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeIntMapWatermark INTMapWatermark { get; set; }
Public Property INTMapWatermark As Adxl312TypeIntMapWatermark
    Get
    Set
public:
property Adxl312TypeIntMapWatermark INTMapWatermark {
    Adxl312TypeIntMapWatermark get ();
    void set (Adxl312TypeIntMapWatermark value);
}
member INTMapWatermark : Adxl312TypeIntMapWatermark with get, set

Property Value

Type: Adxl312TypeIntMapWatermark
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.INTSourceActivity Property

IRD

Adxl312INTSourceActivity Property

INT Source (Activity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeIntSourceActivity INTSourceActivity { get; }
Public ReadOnly Property INTSourceActivity As Adxl312TypeIntSourceActivity
    Get
public:
property Adxl312TypeIntSourceActivity INTSourceActivity {
    Adxl312TypeIntSourceActivity get ();
}
member INTSourceActivity : Adxl312TypeIntSourceActivity with get

Property Value

Type: Adxl312TypeIntSourceActivity
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.INTSourceDataReady Property

IRD

Adxl312INTSourceDataReady Property

INT Source (Data Ready)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeIntSourceDataReady INTSourceDataReady { get; }
Public ReadOnly Property INTSourceDataReady As Adxl312TypeIntSourceDataReady
    Get
public:
property Adxl312TypeIntSourceDataReady INTSourceDataReady {
    Adxl312TypeIntSourceDataReady get ();
}
member INTSourceDataReady : Adxl312TypeIntSourceDataReady with get

Property Value

Type: Adxl312TypeIntSourceDataReady
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.INTSourceInactivity Property

IRD

Adxl312INTSourceInactivity Property

INT Source (Inactivity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeIntSourceInactivity INTSourceInactivity { get; }
Public ReadOnly Property INTSourceInactivity As Adxl312TypeIntSourceInactivity
    Get
public:
property Adxl312TypeIntSourceInactivity INTSourceInactivity {
    Adxl312TypeIntSourceInactivity get ();
}
member INTSourceInactivity : Adxl312TypeIntSourceInactivity with get

Property Value

Type: Adxl312TypeIntSourceInactivity
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.INTSourceOverrun Property

IRD

Adxl312INTSourceOverrun Property

INT Source (Overrun)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeIntSourceOverrun INTSourceOverrun { get; }
Public ReadOnly Property INTSourceOverrun As Adxl312TypeIntSourceOverrun
    Get
public:
property Adxl312TypeIntSourceOverrun INTSourceOverrun {
    Adxl312TypeIntSourceOverrun get ();
}
member INTSourceOverrun : Adxl312TypeIntSourceOverrun with get

Property Value

Type: Adxl312TypeIntSourceOverrun
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.INTSourceWatermark Property

IRD

Adxl312INTSourceWatermark Property

INT Source (Watermark)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypeIntSourceWatermark INTSourceWatermark { get; }
Public ReadOnly Property INTSourceWatermark As Adxl312TypeIntSourceWatermark
    Get
public:
property Adxl312TypeIntSourceWatermark INTSourceWatermark {
    Adxl312TypeIntSourceWatermark get ();
}
member INTSourceWatermark : Adxl312TypeIntSourceWatermark with get

Property Value

Type: Adxl312TypeIntSourceWatermark
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.OFSX Property

IRD

Adxl312OFSX Property

OFSX (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double OFSX { get; set; }
Public Property OFSX As Double
    Get
    Set
public:
property double OFSX {
    double get ();
    void set (double value);
}
member OFSX : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.OFSY Property

IRD

Adxl312OFSY Property

OFSY (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double OFSY { get; set; }
Public Property OFSY As Double
    Get
    Set
public:
property double OFSY {
    double get ();
    void set (double value);
}
member OFSY : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.OFSZ Property

IRD

Adxl312OFSZ Property

OFSZ (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double OFSZ { get; set; }
Public Property OFSZ As Double
    Get
    Set
public:
property double OFSZ {
    double get ();
    void set (double value);
}
member OFSZ : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.PowerCTLAutoSleep Property

IRD

Adxl312PowerCTLAutoSleep Property

Power CTL (Auto Sleep)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypePowerCtlAutoSleep PowerCTLAutoSleep { get; set; }
Public Property PowerCTLAutoSleep As Adxl312TypePowerCtlAutoSleep
    Get
    Set
public:
property Adxl312TypePowerCtlAutoSleep PowerCTLAutoSleep {
    Adxl312TypePowerCtlAutoSleep get ();
    void set (Adxl312TypePowerCtlAutoSleep value);
}
member PowerCTLAutoSleep : Adxl312TypePowerCtlAutoSleep with get, set

Property Value

Type: Adxl312TypePowerCtlAutoSleep
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.PowerCTLLink Property

IRD

Adxl312PowerCTLLink Property

Power CTL (Link)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypePowerCtlLink PowerCTLLink { get; set; }
Public Property PowerCTLLink As Adxl312TypePowerCtlLink
    Get
    Set
public:
property Adxl312TypePowerCtlLink PowerCTLLink {
    Adxl312TypePowerCtlLink get ();
    void set (Adxl312TypePowerCtlLink value);
}
member PowerCTLLink : Adxl312TypePowerCtlLink with get, set

Property Value

Type: Adxl312TypePowerCtlLink
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.PowerCTLMeasure Property

IRD

Adxl312PowerCTLMeasure Property

Power CTL (Measure)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypePowerCtlMeasure PowerCTLMeasure { get; set; }
Public Property PowerCTLMeasure As Adxl312TypePowerCtlMeasure
    Get
    Set
public:
property Adxl312TypePowerCtlMeasure PowerCTLMeasure {
    Adxl312TypePowerCtlMeasure get ();
    void set (Adxl312TypePowerCtlMeasure value);
}
member PowerCTLMeasure : Adxl312TypePowerCtlMeasure with get, set

Property Value

Type: Adxl312TypePowerCtlMeasure
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.PowerCTLSleep Property

IRD

Adxl312PowerCTLSleep Property

Power CTL (Sleep)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypePowerCtlSleep PowerCTLSleep { get; set; }
Public Property PowerCTLSleep As Adxl312TypePowerCtlSleep
    Get
    Set
public:
property Adxl312TypePowerCtlSleep PowerCTLSleep {
    Adxl312TypePowerCtlSleep get ();
    void set (Adxl312TypePowerCtlSleep value);
}
member PowerCTLSleep : Adxl312TypePowerCtlSleep with get, set

Property Value

Type: Adxl312TypePowerCtlSleep
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.PowerCTLWakeUp Property

IRD

Adxl312PowerCTLWakeUp Property

Power CTL (Wake Up)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl312TypePowerCtlWakeup PowerCTLWakeUp { get; set; }
Public Property PowerCTLWakeUp As Adxl312TypePowerCtlWakeup
    Get
    Set
public:
property Adxl312TypePowerCtlWakeup PowerCTLWakeUp {
    Adxl312TypePowerCtlWakeup get ();
    void set (Adxl312TypePowerCtlWakeup value);
}
member PowerCTLWakeUp : Adxl312TypePowerCtlWakeup with get, set

Property Value

Type: Adxl312TypePowerCtlWakeup
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.ThreshAct Property

IRD

Adxl312ThreshAct Property

Thresh Act (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ThreshAct { get; set; }
Public Property ThreshAct As Double
    Get
    Set
public:
property double ThreshAct {
    double get ();
    void set (double value);
}
member ThreshAct : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.ThreshInact Property

IRD

Adxl312ThreshInact Property

Thresh Inact (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ThreshInact { get; set; }
Public Property ThreshInact As Double
    Get
    Set
public:
property double ThreshInact {
    double get ();
    void set (double value);
}
member ThreshInact : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.TimeInact Property

IRD

Adxl312TimeInact Property

Time Inact (unit: s)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TimeInact { get; set; }
Public Property TimeInact As Byte
    Get
    Set
public:
property unsigned char TimeInact {
    unsigned char get ();
    void set (unsigned char value);
}
member TimeInact : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312 Methods

The Adxl312 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.Flush Method

IRD

Adxl312Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adxl312 Class
telos.Ird.AnalogDevices Namespace


Adxl312.TypeActInactCtlActAcDc Enumeration

IRD

Adxl312TypeActInactCtlActAcDc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlActAcDc
Public Enumeration TypeActInactCtlActAcDc
public enum class TypeActInactCtlActAcDc
type TypeActInactCtlActAcDc
Members
Member name | Value | Description
DetectActivityOfDCCoupledOperation | 0 | Detect activity of DC coupled operation
DetectActivityOfACCoupledOperation | 1 | Detect activity of AC coupled operation
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeActInactCtlActX Enumeration

IRD

Adxl312TypeActInactCtlActX Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlActX
Public Enumeration TypeActInactCtlActX
public enum class TypeActInactCtlActX
type TypeActInactCtlActX
Members
Member name | Value | Description
DisableXAxisActivityDetection | 0 | Disable x-axis activity detection
EnableXAxisActivityDetection | 1 | Enable x-axis activity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeActInactCtlActY Enumeration

IRD

Adxl312TypeActInactCtlActY Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlActY
Public Enumeration TypeActInactCtlActY
public enum class TypeActInactCtlActY
type TypeActInactCtlActY
Members
Member name | Value | Description
DisableYAxisActivityDetection | 0 | Disable y-axis activity detection
EnableYAxisActivityDetection | 1 | Enable y-axis activity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeActInactCtlActZ Enumeration

IRD

Adxl312TypeActInactCtlActZ Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlActZ
Public Enumeration TypeActInactCtlActZ
public enum class TypeActInactCtlActZ
type TypeActInactCtlActZ
Members
Member name | Value | Description
DisableZAxisActivityDetection | 0 | Disable z-axis activity detection
EnableZAxisActivityDetection | 1 | Enable z-axis activity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeActInactCtlInactAcDc Enumeration

IRD

Adxl312TypeActInactCtlInactAcDc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlInactAcDc
Public Enumeration TypeActInactCtlInactAcDc
public enum class TypeActInactCtlInactAcDc
type TypeActInactCtlInactAcDc
Members
Member name | Value | Description
DetectInactivityOfDCCoupledOperation | 0 | Detect inactivity of DC coupled operation
DetectInactivityOfACCoupledOperation | 1 | Detect inactivity of AC coupled operation
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeActInactCtlInactX Enumeration

IRD

Adxl312TypeActInactCtlInactX Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlInactX
Public Enumeration TypeActInactCtlInactX
public enum class TypeActInactCtlInactX
type TypeActInactCtlInactX
Members
Member name | Value | Description
DisableXAxisInactivityDetection | 0 | Disable x-axis inactivity detection
EnableXAxisInactivityDetection | 1 | Enable x-axis inactivity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeActInactCtlInactY Enumeration

IRD

Adxl312TypeActInactCtlInactY Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlInactY
Public Enumeration TypeActInactCtlInactY
public enum class TypeActInactCtlInactY
type TypeActInactCtlInactY
Members
Member name | Value | Description
DisableYAxisInactivityDetection | 0 | Disable y-axis inactivity detection
EnableYAxisInactivityDetection | 1 | Enable y-axis inactivity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeActInactCtlInactZ Enumeration

IRD

Adxl312TypeActInactCtlInactZ Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlInactZ
Public Enumeration TypeActInactCtlInactZ
public enum class TypeActInactCtlInactZ
type TypeActInactCtlInactZ
Members
Member name | Value | Description
DisableZAxisInactivityDetection | 0 | Disable z-axis inactivity detection
EnableZAxisInactivityDetection | 1 | Enable z-axis inactivity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeBwRateLowPower Enumeration

IRD

Adxl312TypeBwRateLowPower Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBwRateLowPower
Public Enumeration TypeBwRateLowPower
public enum class TypeBwRateLowPower
type TypeBwRateLowPower
Members
Member name | Value | Description
NormalOperation | 0 | Normal operation
ReducedPowerOperation | 1 | Reduced power operation
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeBwRateRateBits Enumeration

IRD

Adxl312TypeBwRateRateBits Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBwRateRateBits
Public Enumeration TypeBwRateRateBits
public enum class TypeBwRateRateBits
type TypeBwRateRateBits
Members
Member name | Value | Description
Value_6_25 | 6 | 6.25
Value_12_5 | 7 | 12.5
Value_25 | 8 | 25
Value_50 | 9 | 50
Value_100 | 10 | 100
Value_200 | 11 | 200
Value_400 | 12 | 400
Value_800 | 13 | 800
Value_1600 | 14 | 1600
Value_3200 | 15 | 3200
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeDataFormatFullRes Enumeration

IRD

Adxl312TypeDataFormatFullRes Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatFullRes
Public Enumeration TypeDataFormatFullRes
public enum class TypeDataFormatFullRes
type TypeDataFormatFullRes
Members
Member name | Value | Description
Value_10BitMode | 0 | 10 bit mode
FullResolution | 1 | Full resolution
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeDataFormatIntInvert Enumeration

IRD

Adxl312TypeDataFormatIntInvert Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatIntInvert
Public Enumeration TypeDataFormatIntInvert
public enum class TypeDataFormatIntInvert
type TypeDataFormatIntInvert
Members
Member name | Value | Description
SetInterruptsToActiveHigh | 0 | Set interrupts to active high
SetInterruptsToActiveLow | 1 | Set interrupts to active low
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeDataFormatJustify Enumeration

IRD

Adxl312TypeDataFormatJustify Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatJustify
Public Enumeration TypeDataFormatJustify
public enum class TypeDataFormatJustify
type TypeDataFormatJustify
Members
Member name | Value | Description
RightJustifiedModeWithSignExtension | 0 | Right justified mode with sign extension
LeftMSBJustifiedMode | 1 | Left (MSB) justified mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeDataFormatRange Enumeration

IRD

Adxl312TypeDataFormatRange Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatRange
Public Enumeration TypeDataFormatRange
public enum class TypeDataFormatRange
type TypeDataFormatRange
Members
Member name | Value | Description
Value_15g | 0 | +/- 1.5g
Value_3g | 1 | +/- 3g
Value_6g | 2 | +/- 6g
Value_12g | 3 | +/- 12g
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeDataFormatSelfTest Enumeration

IRD

Adxl312TypeDataFormatSelfTest Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatSelfTest
Public Enumeration TypeDataFormatSelfTest
public enum class TypeDataFormatSelfTest
type TypeDataFormatSelfTest
Members
Member name | Value | Description
DisableTheSelfTestForce | 0 | Disable the self-test force
EnablesTheSelfTestForce | 1 | Enables the self-test force
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeDataFormatSpi Enumeration

IRD

Adxl312TypeDataFormatSpi Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatSpi
Public Enumeration TypeDataFormatSpi
public enum class TypeDataFormatSpi
type TypeDataFormatSpi
Members
Member name | Value | Description
Value_4WireSPI | 0 | 4-wire SPI
Value_3WireSPI | 1 | 3-wire SPI
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeFifoCtlFifoMode Enumeration

IRD

Adxl312TypeFifoCtlFifoMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFifoCtlFifoMode
Public Enumeration TypeFifoCtlFifoMode
public enum class TypeFifoCtlFifoMode
type TypeFifoCtlFifoMode
Members
Member name | Value | Description
BypassFIFOBypassed | 0 | Bypass: FIFO bypassed
FIFOCollectUpTo32ValuesInFIFO | 1 | FIFO: Collect up to 32 values in FIFO
StreamFIFOHoldsTheLast32DataValues | 2 | Stream: FIFO holds the last 32 data values
TriggerFIFOHoldsTheLastDataSamplesBeforeTheTriggerEvent | 3 | Trigger: FIFO holds the last data samples before the trigger event
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeFifoCtlTrigger Enumeration

IRD

Adxl312TypeFifoCtlTrigger Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFifoCtlTrigger
Public Enumeration TypeFifoCtlTrigger
public enum class TypeFifoCtlTrigger
type TypeFifoCtlTrigger
Members
Member name | Value | Description
SetsTheTriggerEventOfTriggerModeToBeLinkedToINT1 | 0 | sets the trigger event of trigger mode to be linked to INT1
SetsTheTriggerEventOfTriggerModeToBeLinkedToINT2 | 1 | sets the trigger event of trigger mode to be linked to INT2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeFifoStatusFifoTrig Enumeration

IRD

Adxl312TypeFifoStatusFifoTrig Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFifoStatusFifoTrig
Public Enumeration TypeFifoStatusFifoTrig
public enum class TypeFifoStatusFifoTrig
type TypeFifoStatusFifoTrig
Members
Member name | Value | Description
FIFOTriggerEventHasNotOccurred | 0 | FIFO trigger event has not occurred
FIFOTriggerEventOccurring | 1 | FIFO trigger event occurring
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeIntEnableActivity Enumeration

IRD

Adxl312TypeIntEnableActivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableActivity
Public Enumeration TypeIntEnableActivity
public enum class TypeIntEnableActivity
type TypeIntEnableActivity
Members
Member name | Value | Description
DisableActivityFunctionInterrupts | 0 | Disable activity function interrupts
EnableActivityFunctionInterrupts | 1 | Enable activity function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeIntEnableDataReady Enumeration

IRD

Adxl312TypeIntEnableDataReady Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableDataReady
Public Enumeration TypeIntEnableDataReady
public enum class TypeIntEnableDataReady
type TypeIntEnableDataReady
Members
Member name | Value | Description
DisableDataReadyFunctionInterrupts | 0 | Disable data_ready function interrupts
EnableDataReadyFunctionInterrupts | 1 | Enable data_ready function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeIntEnableInactivity Enumeration

IRD

Adxl312TypeIntEnableInactivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableInactivity
Public Enumeration TypeIntEnableInactivity
public enum class TypeIntEnableInactivity
type TypeIntEnableInactivity
Members
Member name | Value | Description
DisableInactivityFunctionInterrupts | 0 | Disable inactivity function interrupts
EnableInactivityFunctionInterrupts | 1 | Enable inactivity function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeIntEnableOverrun Enumeration

IRD

Adxl312TypeIntEnableOverrun Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableOverrun
Public Enumeration TypeIntEnableOverrun
public enum class TypeIntEnableOverrun
type TypeIntEnableOverrun
Members
Member name | Value | Description
DisableOverrunFunctionInterrupts | 0 | Disable overrun function interrupts
EnableOverrunFunctionInterrupts | 1 | Enable overrun function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeIntEnableWatermark Enumeration

IRD

Adxl312TypeIntEnableWatermark Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableWatermark
Public Enumeration TypeIntEnableWatermark
public enum class TypeIntEnableWatermark
type TypeIntEnableWatermark
Members
Member name | Value | Description
DisableWatermarkFunctionInterrupts | 0 | Disable watermark function interrupts
EnableWatermarkFunctionInterrupts | 1 | Enable watermark function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeIntMapActivity Enumeration

IRD

Adxl312TypeIntMapActivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapActivity
Public Enumeration TypeIntMapActivity
public enum class TypeIntMapActivity
type TypeIntMapActivity
Members
Member name | Value | Description
SendActivityInterruptToINT1Pin | 0 | Send activity interrupt to INT1 pin
SendActivityInterruptToINT2Pin | 1 | Send activity interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeIntMapDataReady Enumeration

IRD

Adxl312TypeIntMapDataReady Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapDataReady
Public Enumeration TypeIntMapDataReady
public enum class TypeIntMapDataReady
type TypeIntMapDataReady
Members
Member name | Value | Description
SendDataReadyInterruptToINT1Pin | 0 | Send data_ready interrupt to INT1 pin
SendDataReadyInterruptToINT2Pin | 1 | Send data_ready interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeIntMapInactivity Enumeration

IRD

Adxl312TypeIntMapInactivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapInactivity
Public Enumeration TypeIntMapInactivity
public enum class TypeIntMapInactivity
type TypeIntMapInactivity
Members
Member name | Value | Description
SendInactivityInterruptToINT1Pin | 0 | Send inactivity interrupt to INT1 pin
SendInactivityInterruptToINT2Pin | 1 | Send inactivity interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeIntMapOverrun Enumeration

IRD

Adxl312TypeIntMapOverrun Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapOverrun
Public Enumeration TypeIntMapOverrun
public enum class TypeIntMapOverrun
type TypeIntMapOverrun
Members
Member name | Value | Description
SendOverrunInterruptToINT1Pin | 0 | Send overrun interrupt to INT1 pin
SendOverrunInterruptToINT2Pin | 1 | Send overrun interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeIntMapWatermark Enumeration

IRD

Adxl312TypeIntMapWatermark Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapWatermark
Public Enumeration TypeIntMapWatermark
public enum class TypeIntMapWatermark
type TypeIntMapWatermark
Members
Member name | Value | Description
SendWatermarkInterruptToINT1Pin | 0 | Send watermark interrupt to INT1 pin
SendWatermarkInterruptToINT2Pin | 1 | Send watermark interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeIntSourceActivity Enumeration

IRD

Adxl312TypeIntSourceActivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceActivity
Public Enumeration TypeIntSourceActivity
public enum class TypeIntSourceActivity
type TypeIntSourceActivity
Members
Member name | Value | Description
ActivityFunctionEventNotOccurred | 0 | Activity function event not occurred
ActivityFunctionHasTriggered | 1 | Activity function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeIntSourceDataReady Enumeration

IRD

Adxl312TypeIntSourceDataReady Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceDataReady
Public Enumeration TypeIntSourceDataReady
public enum class TypeIntSourceDataReady
type TypeIntSourceDataReady
Members
Member name | Value | Description
ActivityFunctionEventNotOccurred | 0 | Activity function event not occurred
ActivityFunctionHasTriggered | 1 | Activity function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeIntSourceInactivity Enumeration

IRD

Adxl312TypeIntSourceInactivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceInactivity
Public Enumeration TypeIntSourceInactivity
public enum class TypeIntSourceInactivity
type TypeIntSourceInactivity
Members
Member name | Value | Description
InactivityFunctionEventNotOccurred | 0 | Inactivity function event not occurred
InactivityFunctionHasTriggered | 1 | Inactivity function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeIntSourceOverrun Enumeration

IRD

Adxl312TypeIntSourceOverrun Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceOverrun
Public Enumeration TypeIntSourceOverrun
public enum class TypeIntSourceOverrun
type TypeIntSourceOverrun
Members
Member name | Value | Description
ActivityFunctionEventNotOccurred | 0 | Activity function event not occurred
ActivityFunctionHasTriggered | 1 | Activity function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypeIntSourceWatermark Enumeration

IRD

Adxl312TypeIntSourceWatermark Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceWatermark
Public Enumeration TypeIntSourceWatermark
public enum class TypeIntSourceWatermark
type TypeIntSourceWatermark
Members
Member name | Value | Description
WatermarkFunctionEventNotOccurred | 0 | Watermark function event not occurred
WatermarkFunctionHasTriggered | 1 | Watermark function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypePowerCtlAutoSleep Enumeration

IRD

Adxl312TypePowerCtlAutoSleep Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlAutoSleep
Public Enumeration TypePowerCtlAutoSleep
public enum class TypePowerCtlAutoSleep
type TypePowerCtlAutoSleep
Members
Member name | Value | Description
DisableAutomaticSwitchingToSleepMode | 0 | Disable automatic switching to sleep mode
SwitchToSleepModeWhenInactivityIsDetected | 1 | Switch to sleep mode when inactivity is detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypePowerCtlLink Enumeration

IRD

Adxl312TypePowerCtlLink Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlLink
Public Enumeration TypePowerCtlLink
public enum class TypePowerCtlLink
type TypePowerCtlLink
Members
Member name | Value | Description
InactivityAndActivityFunctionsAreConcurrent | 0 | Inactivity and activity functions are concurrent
DelaysTheStartOfTheActivityFunctionUntilInactivityIsDetected | 1 | Delays the start of the activity function until inactivity is detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypePowerCtlMeasure Enumeration

IRD

Adxl312TypePowerCtlMeasure Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlMeasure
Public Enumeration TypePowerCtlMeasure
public enum class TypePowerCtlMeasure
type TypePowerCtlMeasure
Members
Member name | Value | Description
StandbyMode | 0 | Standby mode
MeasurementMode | 1 | Measurement mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypePowerCtlSleep Enumeration

IRD

Adxl312TypePowerCtlSleep Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlSleep
Public Enumeration TypePowerCtlSleep
public enum class TypePowerCtlSleep
type TypePowerCtlSleep
Members
Member name | Value | Description
NormalOperation | 0 | Normal operation
SleepMode | 1 | Sleep mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl312.TypePowerCtlWakeup Enumeration

IRD

Adxl312TypePowerCtlWakeup Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlWakeup
Public Enumeration TypePowerCtlWakeup
public enum class TypePowerCtlWakeup
type TypePowerCtlWakeup
Members
Member name | Value | Description
FrequencyReadingInSleepMode8Hz | 0 | Frequency reading in sleep mode: 8 Hz
FrequencyReadingInSleepMode4Hz | 1 | Frequency reading in sleep mode: 4 Hz
FrequencyReadingInSleepMode2Hz | 2 | Frequency reading in sleep mode: 2 Hz
FrequencyReadingInSleepMode1Hz | 3 | Frequency reading in sleep mode: 1 Hz
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343 Class

Analog Devices: ADXL 343
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdxl343

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adxl343
Public Class Adxl343
public ref class Adxl343
type Adxl343 =  class end

The Adxl343 type exposes the following members.

Constructors
 | Name | Description
Public method | Adxl343 | Constructor
Top
Properties
 | Name | Description
Public property | ActInactControlACTACDC | Act Inact Control (ACT AC/DC)
Public property | ActInactControlACTXEN | Act Inact Control (ACT X EN)
Public property | ActInactControlACTYEN | Act Inact Control (ACT Y EN)
Public property | ActInactControlACTZEN | Act Inact Control (ACT Z EN)
Public property | ActInactControlINACTACDC | Act Inact Control (INACT AC/DC)
Public property | ActInactControlINACTXEN | Act Inact Control (INACT X EN)
Public property | ActInactControlINACTYEN | Act Inact Control (INACT Y EN)
Public property | ActInactControlINACTZEN | Act Inact Control (INACT Z EN)
Public property | ActTapStatusACTXSRC | Act Tap Status (ACT X SRC)
Public property | ActTapStatusACTYSRC | Act Tap Status (ACT Y SRC)
Public property | ActTapStatusACTZSRC | Act Tap Status (ACT Z SRC)
Public property | ActTapStatusAsleep | Act Tap Status (Asleep)
Public property | ActTapStatusTAPXSRC | Act Tap Status (TAP X SRC)
Public property | ActTapStatusTAPYSRC | Act Tap Status (TAP Y SRC)
Public property | ActTapStatusTAPZSRC | Act Tap Status (TAP Z SRC)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BWRateLowPower | BW Rate (Low Power)
Public property | BWRateRate | BW Rate (Rate)
Public property | DataFormatFullRes | Data Format (Full Res)
Public property | DataFormatIntInvert | Data Format (Int Invert)
Public property | DataFormatJustify | Data Format (Justify)
Public property | DataFormatRange | Data Format (Range)
Public property | DataFormatSelfTest | Data Format (Self Test)
Public property | DataFormatSPI | Data Format (SPI)
Public property | DataX | Data X
Public property | DataY | Data Y
Public property | DataZ | Data Z
Public property | DeviceID | Device ID
Public property | DUR | DUR (unit: μs)
Public property | FIFOCTLFIFOMode | FIFO CTL (FIFO Mode)
Public property | FIFOCTLSamples | FIFO CTL (Samples)
Public property | FIFOCTLTrigger | FIFO CTL (Trigger)
Public property | FIFOStatusEntries | FIFO Status (Entries)
Public property | FIFOStatusFIFOTrig | FIFO Status (FIFO Trig)
Public property | INTEnableActivity | INT Enable (Activity)
Public property | INTEnableDataReady | INT Enable (Data Ready)
Public property | INTEnableDoubleTap | INT Enable (Double Tap)
Public property | INTEnableFreeFall | INT Enable (Free Fall)
Public property | INTEnableInactivity | INT Enable (Inactivity)
Public property | INTEnableOverrun | INT Enable (Overrun)
Public property | INTEnableSingleTap | INT Enable (Single Tap)
Public property | INTEnableWatermark | INT Enable (Watermark)
Public property | INTMapActivity | INT Map (Activity)
Public property | INTMapDataReady | INT Map (Data Ready)
Public property | INTMapDoubleTap | INT Map (Double Tap)
Public property | INTMapFreeFall | INT Map (Free Fall)
Public property | INTMapInactivity | INT Map (Inactivity)
Public property | INTMapOverrun | INT Map (Overrun)
Public property | INTMapSingleTap | INT Map (Single Tap)
Public property | INTMapWatermark | INT Map (Watermark)
Public property | INTSourceActivity | INT Source (Activity)
Public property | INTSourceDataReady | INT Source (Data Ready)
Public property | INTSourceDoubleTap | INT Source (Double Tap)
Public property | INTSourceFreeFall | INT Source (Free Fall)
Public property | INTSourceInactivity | INT Source (Inactivity)
Public property | INTSourceOverrun | INT Source (Overrun)
Public property | INTSourceSingleTap | INT Source (Single Tap)
Public property | INTSourceWatermark | INT Source (Watermark)
Public property | Latent | Latent (unit: ms)
Public property | OFSX | OFSX (unit: mg)
Public property | OFSY | OFSY (unit: mg)
Public property | OFSZ | OFSZ (unit: mg)
Public property | PowerCTLAutoSleep | Power CTL (Auto Sleep)
Public property | PowerCTLLink | Power CTL (Link)
Public property | PowerCTLMeasure | Power CTL (Measure)
Public property | PowerCTLSleep | Power CTL (Sleep)
Public property | PowerCTLWakeUp | Power CTL (Wake Up)
Public property | TapAxesSuppress | Tap Axes (Suppress)
Public property | TapAxesTAPXEN | Tap Axes (TAP X EN)
Public property | TapAxesTAPYEN | Tap Axes (TAP Y EN)
Public property | TapAxesTAPZEN | Tap Axes (TAP Z EN)
Public property | ThreshAct | Thresh Act (unit: mg)
Public property | ThreshFF | Thresh FF (unit: mg)
Public property | ThreshInact | Thresh Inact (unit: mg)
Public property | ThreshTap | Thresh Tap (unit: mg)
Public property | TimeFF | Time FF (unit: ms)
Public property | TimeInact | Time Inact (unit: s)
Public property | Window | Window (unit: ms)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
3-Axis ±2 g/±4 g/±8 g/±16 g Digital MEMS Accelerometer
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adxl343(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adxl343

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343 Properties

The Adxl343 type exposes the following members.

Properties
 | Name | Description
Public property | ActInactControlACTACDC | Act Inact Control (ACT AC/DC)
Public property | ActInactControlACTXEN | Act Inact Control (ACT X EN)
Public property | ActInactControlACTYEN | Act Inact Control (ACT Y EN)
Public property | ActInactControlACTZEN | Act Inact Control (ACT Z EN)
Public property | ActInactControlINACTACDC | Act Inact Control (INACT AC/DC)
Public property | ActInactControlINACTXEN | Act Inact Control (INACT X EN)
Public property | ActInactControlINACTYEN | Act Inact Control (INACT Y EN)
Public property | ActInactControlINACTZEN | Act Inact Control (INACT Z EN)
Public property | ActTapStatusACTXSRC | Act Tap Status (ACT X SRC)
Public property | ActTapStatusACTYSRC | Act Tap Status (ACT Y SRC)
Public property | ActTapStatusACTZSRC | Act Tap Status (ACT Z SRC)
Public property | ActTapStatusAsleep | Act Tap Status (Asleep)
Public property | ActTapStatusTAPXSRC | Act Tap Status (TAP X SRC)
Public property | ActTapStatusTAPYSRC | Act Tap Status (TAP Y SRC)
Public property | ActTapStatusTAPZSRC | Act Tap Status (TAP Z SRC)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BWRateLowPower | BW Rate (Low Power)
Public property | BWRateRate | BW Rate (Rate)
Public property | DataFormatFullRes | Data Format (Full Res)
Public property | DataFormatIntInvert | Data Format (Int Invert)
Public property | DataFormatJustify | Data Format (Justify)
Public property | DataFormatRange | Data Format (Range)
Public property | DataFormatSelfTest | Data Format (Self Test)
Public property | DataFormatSPI | Data Format (SPI)
Public property | DataX | Data X
Public property | DataY | Data Y
Public property | DataZ | Data Z
Public property | DeviceID | Device ID
Public property | DUR | DUR (unit: μs)
Public property | FIFOCTLFIFOMode | FIFO CTL (FIFO Mode)
Public property | FIFOCTLSamples | FIFO CTL (Samples)
Public property | FIFOCTLTrigger | FIFO CTL (Trigger)
Public property | FIFOStatusEntries | FIFO Status (Entries)
Public property | FIFOStatusFIFOTrig | FIFO Status (FIFO Trig)
Public property | INTEnableActivity | INT Enable (Activity)
Public property | INTEnableDataReady | INT Enable (Data Ready)
Public property | INTEnableDoubleTap | INT Enable (Double Tap)
Public property | INTEnableFreeFall | INT Enable (Free Fall)
Public property | INTEnableInactivity | INT Enable (Inactivity)
Public property | INTEnableOverrun | INT Enable (Overrun)
Public property | INTEnableSingleTap | INT Enable (Single Tap)
Public property | INTEnableWatermark | INT Enable (Watermark)
Public property | INTMapActivity | INT Map (Activity)
Public property | INTMapDataReady | INT Map (Data Ready)
Public property | INTMapDoubleTap | INT Map (Double Tap)
Public property | INTMapFreeFall | INT Map (Free Fall)
Public property | INTMapInactivity | INT Map (Inactivity)
Public property | INTMapOverrun | INT Map (Overrun)
Public property | INTMapSingleTap | INT Map (Single Tap)
Public property | INTMapWatermark | INT Map (Watermark)
Public property | INTSourceActivity | INT Source (Activity)
Public property | INTSourceDataReady | INT Source (Data Ready)
Public property | INTSourceDoubleTap | INT Source (Double Tap)
Public property | INTSourceFreeFall | INT Source (Free Fall)
Public property | INTSourceInactivity | INT Source (Inactivity)
Public property | INTSourceOverrun | INT Source (Overrun)
Public property | INTSourceSingleTap | INT Source (Single Tap)
Public property | INTSourceWatermark | INT Source (Watermark)
Public property | Latent | Latent (unit: ms)
Public property | OFSX | OFSX (unit: mg)
Public property | OFSY | OFSY (unit: mg)
Public property | OFSZ | OFSZ (unit: mg)
Public property | PowerCTLAutoSleep | Power CTL (Auto Sleep)
Public property | PowerCTLLink | Power CTL (Link)
Public property | PowerCTLMeasure | Power CTL (Measure)
Public property | PowerCTLSleep | Power CTL (Sleep)
Public property | PowerCTLWakeUp | Power CTL (Wake Up)
Public property | TapAxesSuppress | Tap Axes (Suppress)
Public property | TapAxesTAPXEN | Tap Axes (TAP X EN)
Public property | TapAxesTAPYEN | Tap Axes (TAP Y EN)
Public property | TapAxesTAPZEN | Tap Axes (TAP Z EN)
Public property | ThreshAct | Thresh Act (unit: mg)
Public property | ThreshFF | Thresh FF (unit: mg)
Public property | ThreshInact | Thresh Inact (unit: mg)
Public property | ThreshTap | Thresh Tap (unit: mg)
Public property | TimeFF | Time FF (unit: ms)
Public property | TimeInact | Time Inact (unit: s)
Public property | Window | Window (unit: ms)
Top
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ActInactControlACTACDC Property

IRD

Adxl343ActInactControlACTACDC Property

Act Inact Control (ACT AC/DC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeActInactCtlActAcDc ActInactControlACTACDC { get; set; }
Public Property ActInactControlACTACDC As Adxl343TypeActInactCtlActAcDc
    Get
    Set
public:
property Adxl343TypeActInactCtlActAcDc ActInactControlACTACDC {
    Adxl343TypeActInactCtlActAcDc get ();
    void set (Adxl343TypeActInactCtlActAcDc value);
}
member ActInactControlACTACDC : Adxl343TypeActInactCtlActAcDc with get, set

Property Value

Type: Adxl343TypeActInactCtlActAcDc
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ActInactControlACTXEN Property

IRD

Adxl343ActInactControlACTXEN Property

Act Inact Control (ACT X EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeActInactCtlActX ActInactControlACTXEN { get; set; }
Public Property ActInactControlACTXEN As Adxl343TypeActInactCtlActX
    Get
    Set
public:
property Adxl343TypeActInactCtlActX ActInactControlACTXEN {
    Adxl343TypeActInactCtlActX get ();
    void set (Adxl343TypeActInactCtlActX value);
}
member ActInactControlACTXEN : Adxl343TypeActInactCtlActX with get, set

Property Value

Type: Adxl343TypeActInactCtlActX
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ActInactControlACTYEN Property

IRD

Adxl343ActInactControlACTYEN Property

Act Inact Control (ACT Y EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeActInactCtlActY ActInactControlACTYEN { get; set; }
Public Property ActInactControlACTYEN As Adxl343TypeActInactCtlActY
    Get
    Set
public:
property Adxl343TypeActInactCtlActY ActInactControlACTYEN {
    Adxl343TypeActInactCtlActY get ();
    void set (Adxl343TypeActInactCtlActY value);
}
member ActInactControlACTYEN : Adxl343TypeActInactCtlActY with get, set

Property Value

Type: Adxl343TypeActInactCtlActY
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ActInactControlACTZEN Property

IRD

Adxl343ActInactControlACTZEN Property

Act Inact Control (ACT Z EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeActInactCtlActZ ActInactControlACTZEN { get; set; }
Public Property ActInactControlACTZEN As Adxl343TypeActInactCtlActZ
    Get
    Set
public:
property Adxl343TypeActInactCtlActZ ActInactControlACTZEN {
    Adxl343TypeActInactCtlActZ get ();
    void set (Adxl343TypeActInactCtlActZ value);
}
member ActInactControlACTZEN : Adxl343TypeActInactCtlActZ with get, set

Property Value

Type: Adxl343TypeActInactCtlActZ
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ActInactControlINACTACDC Property

IRD

Adxl343ActInactControlINACTACDC Property

Act Inact Control (INACT AC/DC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeActInactCtlInactAcDc ActInactControlINACTACDC { get; set; }
Public Property ActInactControlINACTACDC As Adxl343TypeActInactCtlInactAcDc
    Get
    Set
public:
property Adxl343TypeActInactCtlInactAcDc ActInactControlINACTACDC {
    Adxl343TypeActInactCtlInactAcDc get ();
    void set (Adxl343TypeActInactCtlInactAcDc value);
}
member ActInactControlINACTACDC : Adxl343TypeActInactCtlInactAcDc with get, set

Property Value

Type: Adxl343TypeActInactCtlInactAcDc
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ActInactControlINACTXEN Property

IRD

Adxl343ActInactControlINACTXEN Property

Act Inact Control (INACT X EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeActInactCtlInactX ActInactControlINACTXEN { get; set; }
Public Property ActInactControlINACTXEN As Adxl343TypeActInactCtlInactX
    Get
    Set
public:
property Adxl343TypeActInactCtlInactX ActInactControlINACTXEN {
    Adxl343TypeActInactCtlInactX get ();
    void set (Adxl343TypeActInactCtlInactX value);
}
member ActInactControlINACTXEN : Adxl343TypeActInactCtlInactX with get, set

Property Value

Type: Adxl343TypeActInactCtlInactX
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ActInactControlINACTYEN Property

IRD

Adxl343ActInactControlINACTYEN Property

Act Inact Control (INACT Y EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeActInactCtlInactY ActInactControlINACTYEN { get; set; }
Public Property ActInactControlINACTYEN As Adxl343TypeActInactCtlInactY
    Get
    Set
public:
property Adxl343TypeActInactCtlInactY ActInactControlINACTYEN {
    Adxl343TypeActInactCtlInactY get ();
    void set (Adxl343TypeActInactCtlInactY value);
}
member ActInactControlINACTYEN : Adxl343TypeActInactCtlInactY with get, set

Property Value

Type: Adxl343TypeActInactCtlInactY
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ActInactControlINACTZEN Property

IRD

Adxl343ActInactControlINACTZEN Property

Act Inact Control (INACT Z EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeActInactCtlActZ ActInactControlINACTZEN { get; set; }
Public Property ActInactControlINACTZEN As Adxl343TypeActInactCtlActZ
    Get
    Set
public:
property Adxl343TypeActInactCtlActZ ActInactControlINACTZEN {
    Adxl343TypeActInactCtlActZ get ();
    void set (Adxl343TypeActInactCtlActZ value);
}
member ActInactControlINACTZEN : Adxl343TypeActInactCtlActZ with get, set

Property Value

Type: Adxl343TypeActInactCtlActZ
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ActTapStatusACTXSRC Property

IRD

Adxl343ActTapStatusACTXSRC Property

Act Tap Status (ACT X SRC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeActTapStatusActXSrc ActTapStatusACTXSRC { get; }
Public ReadOnly Property ActTapStatusACTXSRC As Adxl343TypeActTapStatusActXSrc
    Get
public:
property Adxl343TypeActTapStatusActXSrc ActTapStatusACTXSRC {
    Adxl343TypeActTapStatusActXSrc get ();
}
member ActTapStatusACTXSRC : Adxl343TypeActTapStatusActXSrc with get

Property Value

Type: Adxl343TypeActTapStatusActXSrc
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ActTapStatusACTYSRC Property

IRD

Adxl343ActTapStatusACTYSRC Property

Act Tap Status (ACT Y SRC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeActTapStatusActYSrc ActTapStatusACTYSRC { get; }
Public ReadOnly Property ActTapStatusACTYSRC As Adxl343TypeActTapStatusActYSrc
    Get
public:
property Adxl343TypeActTapStatusActYSrc ActTapStatusACTYSRC {
    Adxl343TypeActTapStatusActYSrc get ();
}
member ActTapStatusACTYSRC : Adxl343TypeActTapStatusActYSrc with get

Property Value

Type: Adxl343TypeActTapStatusActYSrc
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ActTapStatusACTZSRC Property

IRD

Adxl343ActTapStatusACTZSRC Property

Act Tap Status (ACT Z SRC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeActTapStatusActZSrc ActTapStatusACTZSRC { get; }
Public ReadOnly Property ActTapStatusACTZSRC As Adxl343TypeActTapStatusActZSrc
    Get
public:
property Adxl343TypeActTapStatusActZSrc ActTapStatusACTZSRC {
    Adxl343TypeActTapStatusActZSrc get ();
}
member ActTapStatusACTZSRC : Adxl343TypeActTapStatusActZSrc with get

Property Value

Type: Adxl343TypeActTapStatusActZSrc
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ActTapStatusAsleep Property

IRD

Adxl343ActTapStatusAsleep Property

Act Tap Status (Asleep)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeActTapStatusAsleep ActTapStatusAsleep { get; }
Public ReadOnly Property ActTapStatusAsleep As Adxl343TypeActTapStatusAsleep
    Get
public:
property Adxl343TypeActTapStatusAsleep ActTapStatusAsleep {
    Adxl343TypeActTapStatusAsleep get ();
}
member ActTapStatusAsleep : Adxl343TypeActTapStatusAsleep with get

Property Value

Type: Adxl343TypeActTapStatusAsleep
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ActTapStatusTAPXSRC Property

IRD

Adxl343ActTapStatusTAPXSRC Property

Act Tap Status (TAP X SRC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeActTapStatusTapXSrc ActTapStatusTAPXSRC { get; }
Public ReadOnly Property ActTapStatusTAPXSRC As Adxl343TypeActTapStatusTapXSrc
    Get
public:
property Adxl343TypeActTapStatusTapXSrc ActTapStatusTAPXSRC {
    Adxl343TypeActTapStatusTapXSrc get ();
}
member ActTapStatusTAPXSRC : Adxl343TypeActTapStatusTapXSrc with get

Property Value

Type: Adxl343TypeActTapStatusTapXSrc
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ActTapStatusTAPYSRC Property

IRD

Adxl343ActTapStatusTAPYSRC Property

Act Tap Status (TAP Y SRC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeActTapStatusTapYSrc ActTapStatusTAPYSRC { get; }
Public ReadOnly Property ActTapStatusTAPYSRC As Adxl343TypeActTapStatusTapYSrc
    Get
public:
property Adxl343TypeActTapStatusTapYSrc ActTapStatusTAPYSRC {
    Adxl343TypeActTapStatusTapYSrc get ();
}
member ActTapStatusTAPYSRC : Adxl343TypeActTapStatusTapYSrc with get

Property Value

Type: Adxl343TypeActTapStatusTapYSrc
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ActTapStatusTAPZSRC Property

IRD

Adxl343ActTapStatusTAPZSRC Property

Act Tap Status (TAP Z SRC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeActTapStatusTapZSrc ActTapStatusTAPZSRC { get; }
Public ReadOnly Property ActTapStatusTAPZSRC As Adxl343TypeActTapStatusTapZSrc
    Get
public:
property Adxl343TypeActTapStatusTapZSrc ActTapStatusTAPZSRC {
    Adxl343TypeActTapStatusTapZSrc get ();
}
member ActTapStatusTAPZSRC : Adxl343TypeActTapStatusTapZSrc with get

Property Value

Type: Adxl343TypeActTapStatusTapZSrc
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.AutoFlush Property

IRD

Adxl343AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.BWRateLowPower Property

IRD

Adxl343BWRateLowPower Property

BW Rate (Low Power)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeBwRateLowPower BWRateLowPower { get; set; }
Public Property BWRateLowPower As Adxl343TypeBwRateLowPower
    Get
    Set
public:
property Adxl343TypeBwRateLowPower BWRateLowPower {
    Adxl343TypeBwRateLowPower get ();
    void set (Adxl343TypeBwRateLowPower value);
}
member BWRateLowPower : Adxl343TypeBwRateLowPower with get, set

Property Value

Type: Adxl343TypeBwRateLowPower
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.BWRateRate Property

IRD

Adxl343BWRateRate Property

BW Rate (Rate)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeBwRateRateBits BWRateRate { get; set; }
Public Property BWRateRate As Adxl343TypeBwRateRateBits
    Get
    Set
public:
property Adxl343TypeBwRateRateBits BWRateRate {
    Adxl343TypeBwRateRateBits get ();
    void set (Adxl343TypeBwRateRateBits value);
}
member BWRateRate : Adxl343TypeBwRateRateBits with get, set

Property Value

Type: Adxl343TypeBwRateRateBits
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.DataFormatFullRes Property

IRD

Adxl343DataFormatFullRes Property

Data Format (Full Res)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeDataFormatFullRes DataFormatFullRes { get; set; }
Public Property DataFormatFullRes As Adxl343TypeDataFormatFullRes
    Get
    Set
public:
property Adxl343TypeDataFormatFullRes DataFormatFullRes {
    Adxl343TypeDataFormatFullRes get ();
    void set (Adxl343TypeDataFormatFullRes value);
}
member DataFormatFullRes : Adxl343TypeDataFormatFullRes with get, set

Property Value

Type: Adxl343TypeDataFormatFullRes
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.DataFormatIntInvert Property

IRD

Adxl343DataFormatIntInvert Property

Data Format (Int Invert)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeDataFormatIntInvert DataFormatIntInvert { get; set; }
Public Property DataFormatIntInvert As Adxl343TypeDataFormatIntInvert
    Get
    Set
public:
property Adxl343TypeDataFormatIntInvert DataFormatIntInvert {
    Adxl343TypeDataFormatIntInvert get ();
    void set (Adxl343TypeDataFormatIntInvert value);
}
member DataFormatIntInvert : Adxl343TypeDataFormatIntInvert with get, set

Property Value

Type: Adxl343TypeDataFormatIntInvert
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.DataFormatJustify Property

IRD

Adxl343DataFormatJustify Property

Data Format (Justify)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeDataFormatJustify DataFormatJustify { get; set; }
Public Property DataFormatJustify As Adxl343TypeDataFormatJustify
    Get
    Set
public:
property Adxl343TypeDataFormatJustify DataFormatJustify {
    Adxl343TypeDataFormatJustify get ();
    void set (Adxl343TypeDataFormatJustify value);
}
member DataFormatJustify : Adxl343TypeDataFormatJustify with get, set

Property Value

Type: Adxl343TypeDataFormatJustify
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.DataFormatRange Property

IRD

Adxl343DataFormatRange Property

Data Format (Range)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeDataFormatRange DataFormatRange { get; set; }
Public Property DataFormatRange As Adxl343TypeDataFormatRange
    Get
    Set
public:
property Adxl343TypeDataFormatRange DataFormatRange {
    Adxl343TypeDataFormatRange get ();
    void set (Adxl343TypeDataFormatRange value);
}
member DataFormatRange : Adxl343TypeDataFormatRange with get, set

Property Value

Type: Adxl343TypeDataFormatRange
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.DataFormatSelfTest Property

IRD

Adxl343DataFormatSelfTest Property

Data Format (Self Test)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeDataFormatSelfTest DataFormatSelfTest { get; set; }
Public Property DataFormatSelfTest As Adxl343TypeDataFormatSelfTest
    Get
    Set
public:
property Adxl343TypeDataFormatSelfTest DataFormatSelfTest {
    Adxl343TypeDataFormatSelfTest get ();
    void set (Adxl343TypeDataFormatSelfTest value);
}
member DataFormatSelfTest : Adxl343TypeDataFormatSelfTest with get, set

Property Value

Type: Adxl343TypeDataFormatSelfTest
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.DataFormatSPI Property

IRD

Adxl343DataFormatSPI Property

Data Format (SPI)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeDataFormatSpi DataFormatSPI { get; set; }
Public Property DataFormatSPI As Adxl343TypeDataFormatSpi
    Get
    Set
public:
property Adxl343TypeDataFormatSpi DataFormatSPI {
    Adxl343TypeDataFormatSpi get ();
    void set (Adxl343TypeDataFormatSpi value);
}
member DataFormatSPI : Adxl343TypeDataFormatSpi with get, set

Property Value

Type: Adxl343TypeDataFormatSpi
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.DataX Property

IRD

Adxl343DataX Property

Data X

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short DataX { get; }
Public ReadOnly Property DataX As Short
    Get
public:
property short DataX {
    short get ();
}
member DataX : int16 with get

Property Value

Type: Int16
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.DataY Property

IRD

Adxl343DataY Property

Data Y

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short DataY { get; }
Public ReadOnly Property DataY As Short
    Get
public:
property short DataY {
    short get ();
}
member DataY : int16 with get

Property Value

Type: Int16
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.DataZ Property

IRD

Adxl343DataZ Property

Data Z

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short DataZ { get; }
Public ReadOnly Property DataZ As Short
    Get
public:
property short DataZ {
    short get ();
}
member DataZ : int16 with get

Property Value

Type: Int16
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.DeviceID Property

IRD

Adxl343DeviceID Property

Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.DUR Property

IRD

Adxl343DUR Property

DUR (unit: μs)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DUR { get; set; }
Public Property DUR As Double
    Get
    Set
public:
property double DUR {
    double get ();
    void set (double value);
}
member DUR : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.FIFOCTLFIFOMode Property

IRD

Adxl343FIFOCTLFIFOMode Property

FIFO CTL (FIFO Mode)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeFifoCtlFifoMode FIFOCTLFIFOMode { get; set; }
Public Property FIFOCTLFIFOMode As Adxl343TypeFifoCtlFifoMode
    Get
    Set
public:
property Adxl343TypeFifoCtlFifoMode FIFOCTLFIFOMode {
    Adxl343TypeFifoCtlFifoMode get ();
    void set (Adxl343TypeFifoCtlFifoMode value);
}
member FIFOCTLFIFOMode : Adxl343TypeFifoCtlFifoMode with get, set

Property Value

Type: Adxl343TypeFifoCtlFifoMode
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.FIFOCTLSamples Property

IRD

Adxl343FIFOCTLSamples Property

FIFO CTL (Samples)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOCTLSamples { get; set; }
Public Property FIFOCTLSamples As Byte
    Get
    Set
public:
property unsigned char FIFOCTLSamples {
    unsigned char get ();
    void set (unsigned char value);
}
member FIFOCTLSamples : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.FIFOCTLTrigger Property

IRD

Adxl343FIFOCTLTrigger Property

FIFO CTL (Trigger)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeFifoCtlTrigger FIFOCTLTrigger { get; set; }
Public Property FIFOCTLTrigger As Adxl343TypeFifoCtlTrigger
    Get
    Set
public:
property Adxl343TypeFifoCtlTrigger FIFOCTLTrigger {
    Adxl343TypeFifoCtlTrigger get ();
    void set (Adxl343TypeFifoCtlTrigger value);
}
member FIFOCTLTrigger : Adxl343TypeFifoCtlTrigger with get, set

Property Value

Type: Adxl343TypeFifoCtlTrigger
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.FIFOStatusEntries Property

IRD

Adxl343FIFOStatusEntries Property

FIFO Status (Entries)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOStatusEntries { get; }
Public ReadOnly Property FIFOStatusEntries As Byte
    Get
public:
property unsigned char FIFOStatusEntries {
    unsigned char get ();
}
member FIFOStatusEntries : byte with get

Property Value

Type: Byte
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.FIFOStatusFIFOTrig Property

IRD

Adxl343FIFOStatusFIFOTrig Property

FIFO Status (FIFO Trig)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeFifoStatusFifoTrig FIFOStatusFIFOTrig { get; }
Public ReadOnly Property FIFOStatusFIFOTrig As Adxl343TypeFifoStatusFifoTrig
    Get
public:
property Adxl343TypeFifoStatusFifoTrig FIFOStatusFIFOTrig {
    Adxl343TypeFifoStatusFifoTrig get ();
}
member FIFOStatusFIFOTrig : Adxl343TypeFifoStatusFifoTrig with get

Property Value

Type: Adxl343TypeFifoStatusFifoTrig
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTEnableActivity Property

IRD

Adxl343INTEnableActivity Property

INT Enable (Activity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntEnableActivity INTEnableActivity { get; set; }
Public Property INTEnableActivity As Adxl343TypeIntEnableActivity
    Get
    Set
public:
property Adxl343TypeIntEnableActivity INTEnableActivity {
    Adxl343TypeIntEnableActivity get ();
    void set (Adxl343TypeIntEnableActivity value);
}
member INTEnableActivity : Adxl343TypeIntEnableActivity with get, set

Property Value

Type: Adxl343TypeIntEnableActivity
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTEnableDataReady Property

IRD

Adxl343INTEnableDataReady Property

INT Enable (Data Ready)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntEnableDataReady INTEnableDataReady { get; set; }
Public Property INTEnableDataReady As Adxl343TypeIntEnableDataReady
    Get
    Set
public:
property Adxl343TypeIntEnableDataReady INTEnableDataReady {
    Adxl343TypeIntEnableDataReady get ();
    void set (Adxl343TypeIntEnableDataReady value);
}
member INTEnableDataReady : Adxl343TypeIntEnableDataReady with get, set

Property Value

Type: Adxl343TypeIntEnableDataReady
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTEnableDoubleTap Property

IRD

Adxl343INTEnableDoubleTap Property

INT Enable (Double Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntEnableDoubleTap INTEnableDoubleTap { get; set; }
Public Property INTEnableDoubleTap As Adxl343TypeIntEnableDoubleTap
    Get
    Set
public:
property Adxl343TypeIntEnableDoubleTap INTEnableDoubleTap {
    Adxl343TypeIntEnableDoubleTap get ();
    void set (Adxl343TypeIntEnableDoubleTap value);
}
member INTEnableDoubleTap : Adxl343TypeIntEnableDoubleTap with get, set

Property Value

Type: Adxl343TypeIntEnableDoubleTap
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTEnableFreeFall Property

IRD

Adxl343INTEnableFreeFall Property

INT Enable (Free Fall)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntEnableFreeFall INTEnableFreeFall { get; set; }
Public Property INTEnableFreeFall As Adxl343TypeIntEnableFreeFall
    Get
    Set
public:
property Adxl343TypeIntEnableFreeFall INTEnableFreeFall {
    Adxl343TypeIntEnableFreeFall get ();
    void set (Adxl343TypeIntEnableFreeFall value);
}
member INTEnableFreeFall : Adxl343TypeIntEnableFreeFall with get, set

Property Value

Type: Adxl343TypeIntEnableFreeFall
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTEnableInactivity Property

IRD

Adxl343INTEnableInactivity Property

INT Enable (Inactivity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntEnableInactivity INTEnableInactivity { get; set; }
Public Property INTEnableInactivity As Adxl343TypeIntEnableInactivity
    Get
    Set
public:
property Adxl343TypeIntEnableInactivity INTEnableInactivity {
    Adxl343TypeIntEnableInactivity get ();
    void set (Adxl343TypeIntEnableInactivity value);
}
member INTEnableInactivity : Adxl343TypeIntEnableInactivity with get, set

Property Value

Type: Adxl343TypeIntEnableInactivity
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTEnableOverrun Property

IRD

Adxl343INTEnableOverrun Property

INT Enable (Overrun)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntEnableOverrun INTEnableOverrun { get; set; }
Public Property INTEnableOverrun As Adxl343TypeIntEnableOverrun
    Get
    Set
public:
property Adxl343TypeIntEnableOverrun INTEnableOverrun {
    Adxl343TypeIntEnableOverrun get ();
    void set (Adxl343TypeIntEnableOverrun value);
}
member INTEnableOverrun : Adxl343TypeIntEnableOverrun with get, set

Property Value

Type: Adxl343TypeIntEnableOverrun
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTEnableSingleTap Property

IRD

Adxl343INTEnableSingleTap Property

INT Enable (Single Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntEnableSingleTap INTEnableSingleTap { get; set; }
Public Property INTEnableSingleTap As Adxl343TypeIntEnableSingleTap
    Get
    Set
public:
property Adxl343TypeIntEnableSingleTap INTEnableSingleTap {
    Adxl343TypeIntEnableSingleTap get ();
    void set (Adxl343TypeIntEnableSingleTap value);
}
member INTEnableSingleTap : Adxl343TypeIntEnableSingleTap with get, set

Property Value

Type: Adxl343TypeIntEnableSingleTap
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTEnableWatermark Property

IRD

Adxl343INTEnableWatermark Property

INT Enable (Watermark)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntEnableWatermark INTEnableWatermark { get; set; }
Public Property INTEnableWatermark As Adxl343TypeIntEnableWatermark
    Get
    Set
public:
property Adxl343TypeIntEnableWatermark INTEnableWatermark {
    Adxl343TypeIntEnableWatermark get ();
    void set (Adxl343TypeIntEnableWatermark value);
}
member INTEnableWatermark : Adxl343TypeIntEnableWatermark with get, set

Property Value

Type: Adxl343TypeIntEnableWatermark
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTMapActivity Property

IRD

Adxl343INTMapActivity Property

INT Map (Activity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntMapActivity INTMapActivity { get; set; }
Public Property INTMapActivity As Adxl343TypeIntMapActivity
    Get
    Set
public:
property Adxl343TypeIntMapActivity INTMapActivity {
    Adxl343TypeIntMapActivity get ();
    void set (Adxl343TypeIntMapActivity value);
}
member INTMapActivity : Adxl343TypeIntMapActivity with get, set

Property Value

Type: Adxl343TypeIntMapActivity
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTMapDataReady Property

IRD

Adxl343INTMapDataReady Property

INT Map (Data Ready)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntMapDataReady INTMapDataReady { get; set; }
Public Property INTMapDataReady As Adxl343TypeIntMapDataReady
    Get
    Set
public:
property Adxl343TypeIntMapDataReady INTMapDataReady {
    Adxl343TypeIntMapDataReady get ();
    void set (Adxl343TypeIntMapDataReady value);
}
member INTMapDataReady : Adxl343TypeIntMapDataReady with get, set

Property Value

Type: Adxl343TypeIntMapDataReady
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTMapDoubleTap Property

IRD

Adxl343INTMapDoubleTap Property

INT Map (Double Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntMapDoubleTap INTMapDoubleTap { get; set; }
Public Property INTMapDoubleTap As Adxl343TypeIntMapDoubleTap
    Get
    Set
public:
property Adxl343TypeIntMapDoubleTap INTMapDoubleTap {
    Adxl343TypeIntMapDoubleTap get ();
    void set (Adxl343TypeIntMapDoubleTap value);
}
member INTMapDoubleTap : Adxl343TypeIntMapDoubleTap with get, set

Property Value

Type: Adxl343TypeIntMapDoubleTap
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTMapFreeFall Property

IRD

Adxl343INTMapFreeFall Property

INT Map (Free Fall)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntMapFreeFall INTMapFreeFall { get; set; }
Public Property INTMapFreeFall As Adxl343TypeIntMapFreeFall
    Get
    Set
public:
property Adxl343TypeIntMapFreeFall INTMapFreeFall {
    Adxl343TypeIntMapFreeFall get ();
    void set (Adxl343TypeIntMapFreeFall value);
}
member INTMapFreeFall : Adxl343TypeIntMapFreeFall with get, set

Property Value

Type: Adxl343TypeIntMapFreeFall
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTMapInactivity Property

IRD

Adxl343INTMapInactivity Property

INT Map (Inactivity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntMapInactivity INTMapInactivity { get; set; }
Public Property INTMapInactivity As Adxl343TypeIntMapInactivity
    Get
    Set
public:
property Adxl343TypeIntMapInactivity INTMapInactivity {
    Adxl343TypeIntMapInactivity get ();
    void set (Adxl343TypeIntMapInactivity value);
}
member INTMapInactivity : Adxl343TypeIntMapInactivity with get, set

Property Value

Type: Adxl343TypeIntMapInactivity
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTMapOverrun Property

IRD

Adxl343INTMapOverrun Property

INT Map (Overrun)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntMapOverrun INTMapOverrun { get; set; }
Public Property INTMapOverrun As Adxl343TypeIntMapOverrun
    Get
    Set
public:
property Adxl343TypeIntMapOverrun INTMapOverrun {
    Adxl343TypeIntMapOverrun get ();
    void set (Adxl343TypeIntMapOverrun value);
}
member INTMapOverrun : Adxl343TypeIntMapOverrun with get, set

Property Value

Type: Adxl343TypeIntMapOverrun
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTMapSingleTap Property

IRD

Adxl343INTMapSingleTap Property

INT Map (Single Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntMapSingleTap INTMapSingleTap { get; set; }
Public Property INTMapSingleTap As Adxl343TypeIntMapSingleTap
    Get
    Set
public:
property Adxl343TypeIntMapSingleTap INTMapSingleTap {
    Adxl343TypeIntMapSingleTap get ();
    void set (Adxl343TypeIntMapSingleTap value);
}
member INTMapSingleTap : Adxl343TypeIntMapSingleTap with get, set

Property Value

Type: Adxl343TypeIntMapSingleTap
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTMapWatermark Property

IRD

Adxl343INTMapWatermark Property

INT Map (Watermark)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntMapWatermark INTMapWatermark { get; set; }
Public Property INTMapWatermark As Adxl343TypeIntMapWatermark
    Get
    Set
public:
property Adxl343TypeIntMapWatermark INTMapWatermark {
    Adxl343TypeIntMapWatermark get ();
    void set (Adxl343TypeIntMapWatermark value);
}
member INTMapWatermark : Adxl343TypeIntMapWatermark with get, set

Property Value

Type: Adxl343TypeIntMapWatermark
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTSourceActivity Property

IRD

Adxl343INTSourceActivity Property

INT Source (Activity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntSourceActivity INTSourceActivity { get; }
Public ReadOnly Property INTSourceActivity As Adxl343TypeIntSourceActivity
    Get
public:
property Adxl343TypeIntSourceActivity INTSourceActivity {
    Adxl343TypeIntSourceActivity get ();
}
member INTSourceActivity : Adxl343TypeIntSourceActivity with get

Property Value

Type: Adxl343TypeIntSourceActivity
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTSourceDataReady Property

IRD

Adxl343INTSourceDataReady Property

INT Source (Data Ready)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntSourceDataReady INTSourceDataReady { get; }
Public ReadOnly Property INTSourceDataReady As Adxl343TypeIntSourceDataReady
    Get
public:
property Adxl343TypeIntSourceDataReady INTSourceDataReady {
    Adxl343TypeIntSourceDataReady get ();
}
member INTSourceDataReady : Adxl343TypeIntSourceDataReady with get

Property Value

Type: Adxl343TypeIntSourceDataReady
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTSourceDoubleTap Property

IRD

Adxl343INTSourceDoubleTap Property

INT Source (Double Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntSourceDoubleTap INTSourceDoubleTap { get; }
Public ReadOnly Property INTSourceDoubleTap As Adxl343TypeIntSourceDoubleTap
    Get
public:
property Adxl343TypeIntSourceDoubleTap INTSourceDoubleTap {
    Adxl343TypeIntSourceDoubleTap get ();
}
member INTSourceDoubleTap : Adxl343TypeIntSourceDoubleTap with get

Property Value

Type: Adxl343TypeIntSourceDoubleTap
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTSourceFreeFall Property

IRD

Adxl343INTSourceFreeFall Property

INT Source (Free Fall)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntSourceFreeFall INTSourceFreeFall { get; }
Public ReadOnly Property INTSourceFreeFall As Adxl343TypeIntSourceFreeFall
    Get
public:
property Adxl343TypeIntSourceFreeFall INTSourceFreeFall {
    Adxl343TypeIntSourceFreeFall get ();
}
member INTSourceFreeFall : Adxl343TypeIntSourceFreeFall with get

Property Value

Type: Adxl343TypeIntSourceFreeFall
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTSourceInactivity Property

IRD

Adxl343INTSourceInactivity Property

INT Source (Inactivity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntSourceInactivity INTSourceInactivity { get; }
Public ReadOnly Property INTSourceInactivity As Adxl343TypeIntSourceInactivity
    Get
public:
property Adxl343TypeIntSourceInactivity INTSourceInactivity {
    Adxl343TypeIntSourceInactivity get ();
}
member INTSourceInactivity : Adxl343TypeIntSourceInactivity with get

Property Value

Type: Adxl343TypeIntSourceInactivity
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTSourceOverrun Property

IRD

Adxl343INTSourceOverrun Property

INT Source (Overrun)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntSourceOverrun INTSourceOverrun { get; }
Public ReadOnly Property INTSourceOverrun As Adxl343TypeIntSourceOverrun
    Get
public:
property Adxl343TypeIntSourceOverrun INTSourceOverrun {
    Adxl343TypeIntSourceOverrun get ();
}
member INTSourceOverrun : Adxl343TypeIntSourceOverrun with get

Property Value

Type: Adxl343TypeIntSourceOverrun
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTSourceSingleTap Property

IRD

Adxl343INTSourceSingleTap Property

INT Source (Single Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntSourceSingleTap INTSourceSingleTap { get; }
Public ReadOnly Property INTSourceSingleTap As Adxl343TypeIntSourceSingleTap
    Get
public:
property Adxl343TypeIntSourceSingleTap INTSourceSingleTap {
    Adxl343TypeIntSourceSingleTap get ();
}
member INTSourceSingleTap : Adxl343TypeIntSourceSingleTap with get

Property Value

Type: Adxl343TypeIntSourceSingleTap
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.INTSourceWatermark Property

IRD

Adxl343INTSourceWatermark Property

INT Source (Watermark)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeIntSourceWatermark INTSourceWatermark { get; }
Public ReadOnly Property INTSourceWatermark As Adxl343TypeIntSourceWatermark
    Get
public:
property Adxl343TypeIntSourceWatermark INTSourceWatermark {
    Adxl343TypeIntSourceWatermark get ();
}
member INTSourceWatermark : Adxl343TypeIntSourceWatermark with get

Property Value

Type: Adxl343TypeIntSourceWatermark
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.Latent Property

IRD

Adxl343Latent Property

Latent (unit: ms)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Latent { get; set; }
Public Property Latent As Double
    Get
    Set
public:
property double Latent {
    double get ();
    void set (double value);
}
member Latent : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.OFSX Property

IRD

Adxl343OFSX Property

OFSX (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double OFSX { get; set; }
Public Property OFSX As Double
    Get
    Set
public:
property double OFSX {
    double get ();
    void set (double value);
}
member OFSX : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.OFSY Property

IRD

Adxl343OFSY Property

OFSY (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double OFSY { get; set; }
Public Property OFSY As Double
    Get
    Set
public:
property double OFSY {
    double get ();
    void set (double value);
}
member OFSY : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.OFSZ Property

IRD

Adxl343OFSZ Property

OFSZ (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double OFSZ { get; set; }
Public Property OFSZ As Double
    Get
    Set
public:
property double OFSZ {
    double get ();
    void set (double value);
}
member OFSZ : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.PowerCTLAutoSleep Property

IRD

Adxl343PowerCTLAutoSleep Property

Power CTL (Auto Sleep)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypePowerCtlAutoSleep PowerCTLAutoSleep { get; set; }
Public Property PowerCTLAutoSleep As Adxl343TypePowerCtlAutoSleep
    Get
    Set
public:
property Adxl343TypePowerCtlAutoSleep PowerCTLAutoSleep {
    Adxl343TypePowerCtlAutoSleep get ();
    void set (Adxl343TypePowerCtlAutoSleep value);
}
member PowerCTLAutoSleep : Adxl343TypePowerCtlAutoSleep with get, set

Property Value

Type: Adxl343TypePowerCtlAutoSleep
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.PowerCTLLink Property

IRD

Adxl343PowerCTLLink Property

Power CTL (Link)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypePowerCtlLink PowerCTLLink { get; set; }
Public Property PowerCTLLink As Adxl343TypePowerCtlLink
    Get
    Set
public:
property Adxl343TypePowerCtlLink PowerCTLLink {
    Adxl343TypePowerCtlLink get ();
    void set (Adxl343TypePowerCtlLink value);
}
member PowerCTLLink : Adxl343TypePowerCtlLink with get, set

Property Value

Type: Adxl343TypePowerCtlLink
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.PowerCTLMeasure Property

IRD

Adxl343PowerCTLMeasure Property

Power CTL (Measure)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypePowerCtlMeasure PowerCTLMeasure { get; set; }
Public Property PowerCTLMeasure As Adxl343TypePowerCtlMeasure
    Get
    Set
public:
property Adxl343TypePowerCtlMeasure PowerCTLMeasure {
    Adxl343TypePowerCtlMeasure get ();
    void set (Adxl343TypePowerCtlMeasure value);
}
member PowerCTLMeasure : Adxl343TypePowerCtlMeasure with get, set

Property Value

Type: Adxl343TypePowerCtlMeasure
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.PowerCTLSleep Property

IRD

Adxl343PowerCTLSleep Property

Power CTL (Sleep)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypePowerCtlSleep PowerCTLSleep { get; set; }
Public Property PowerCTLSleep As Adxl343TypePowerCtlSleep
    Get
    Set
public:
property Adxl343TypePowerCtlSleep PowerCTLSleep {
    Adxl343TypePowerCtlSleep get ();
    void set (Adxl343TypePowerCtlSleep value);
}
member PowerCTLSleep : Adxl343TypePowerCtlSleep with get, set

Property Value

Type: Adxl343TypePowerCtlSleep
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.PowerCTLWakeUp Property

IRD

Adxl343PowerCTLWakeUp Property

Power CTL (Wake Up)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypePowerCtlWakeup PowerCTLWakeUp { get; set; }
Public Property PowerCTLWakeUp As Adxl343TypePowerCtlWakeup
    Get
    Set
public:
property Adxl343TypePowerCtlWakeup PowerCTLWakeUp {
    Adxl343TypePowerCtlWakeup get ();
    void set (Adxl343TypePowerCtlWakeup value);
}
member PowerCTLWakeUp : Adxl343TypePowerCtlWakeup with get, set

Property Value

Type: Adxl343TypePowerCtlWakeup
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.TapAxesSuppress Property

IRD

Adxl343TapAxesSuppress Property

Tap Axes (Suppress)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeTapAxesSuppress TapAxesSuppress { get; set; }
Public Property TapAxesSuppress As Adxl343TypeTapAxesSuppress
    Get
    Set
public:
property Adxl343TypeTapAxesSuppress TapAxesSuppress {
    Adxl343TypeTapAxesSuppress get ();
    void set (Adxl343TypeTapAxesSuppress value);
}
member TapAxesSuppress : Adxl343TypeTapAxesSuppress with get, set

Property Value

Type: Adxl343TypeTapAxesSuppress
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.TapAxesTAPXEN Property

IRD

Adxl343TapAxesTAPXEN Property

Tap Axes (TAP X EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeTapAxesTapXEn TapAxesTAPXEN { get; set; }
Public Property TapAxesTAPXEN As Adxl343TypeTapAxesTapXEn
    Get
    Set
public:
property Adxl343TypeTapAxesTapXEn TapAxesTAPXEN {
    Adxl343TypeTapAxesTapXEn get ();
    void set (Adxl343TypeTapAxesTapXEn value);
}
member TapAxesTAPXEN : Adxl343TypeTapAxesTapXEn with get, set

Property Value

Type: Adxl343TypeTapAxesTapXEn
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.TapAxesTAPYEN Property

IRD

Adxl343TapAxesTAPYEN Property

Tap Axes (TAP Y EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeTapAxesTapYEn TapAxesTAPYEN { get; set; }
Public Property TapAxesTAPYEN As Adxl343TypeTapAxesTapYEn
    Get
    Set
public:
property Adxl343TypeTapAxesTapYEn TapAxesTAPYEN {
    Adxl343TypeTapAxesTapYEn get ();
    void set (Adxl343TypeTapAxesTapYEn value);
}
member TapAxesTAPYEN : Adxl343TypeTapAxesTapYEn with get, set

Property Value

Type: Adxl343TypeTapAxesTapYEn
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.TapAxesTAPZEN Property

IRD

Adxl343TapAxesTAPZEN Property

Tap Axes (TAP Z EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl343TypeTapAxesTapZEn TapAxesTAPZEN { get; set; }
Public Property TapAxesTAPZEN As Adxl343TypeTapAxesTapZEn
    Get
    Set
public:
property Adxl343TypeTapAxesTapZEn TapAxesTAPZEN {
    Adxl343TypeTapAxesTapZEn get ();
    void set (Adxl343TypeTapAxesTapZEn value);
}
member TapAxesTAPZEN : Adxl343TypeTapAxesTapZEn with get, set

Property Value

Type: Adxl343TypeTapAxesTapZEn
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ThreshAct Property

IRD

Adxl343ThreshAct Property

Thresh Act (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ThreshAct { get; set; }
Public Property ThreshAct As Double
    Get
    Set
public:
property double ThreshAct {
    double get ();
    void set (double value);
}
member ThreshAct : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ThreshFF Property

IRD

Adxl343ThreshFF Property

Thresh FF (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ThreshFF { get; set; }
Public Property ThreshFF As Byte
    Get
    Set
public:
property unsigned char ThreshFF {
    unsigned char get ();
    void set (unsigned char value);
}
member ThreshFF : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ThreshInact Property

IRD

Adxl343ThreshInact Property

Thresh Inact (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ThreshInact { get; set; }
Public Property ThreshInact As Double
    Get
    Set
public:
property double ThreshInact {
    double get ();
    void set (double value);
}
member ThreshInact : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.ThreshTap Property

IRD

Adxl343ThreshTap Property

Thresh Tap (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ThreshTap { get; set; }
Public Property ThreshTap As Double
    Get
    Set
public:
property double ThreshTap {
    double get ();
    void set (double value);
}
member ThreshTap : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.TimeFF Property

IRD

Adxl343TimeFF Property

Time FF (unit: ms)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TimeFF { get; set; }
Public Property TimeFF As Double
    Get
    Set
public:
property double TimeFF {
    double get ();
    void set (double value);
}
member TimeFF : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.TimeInact Property

IRD

Adxl343TimeInact Property

Time Inact (unit: s)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TimeInact { get; set; }
Public Property TimeInact As Byte
    Get
    Set
public:
property unsigned char TimeInact {
    unsigned char get ();
    void set (unsigned char value);
}
member TimeInact : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.Window Property

IRD

Adxl343Window Property

Window (unit: ms)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Window { get; set; }
Public Property Window As Double
    Get
    Set
public:
property double Window {
    double get ();
    void set (double value);
}
member Window : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343 Methods

The Adxl343 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.Flush Method

IRD

Adxl343Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adxl343 Class
telos.Ird.AnalogDevices Namespace


Adxl343.TypeActInactCtlActAcDc Enumeration

IRD

Adxl343TypeActInactCtlActAcDc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlActAcDc
Public Enumeration TypeActInactCtlActAcDc
public enum class TypeActInactCtlActAcDc
type TypeActInactCtlActAcDc
Members
Member name | Value | Description
DetectActivityOfDCCoupledOperation | 0 | Detect activity of DC coupled operation
DetectActivityOfACCoupledOperation | 1 | Detect activity of AC coupled operation
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeActInactCtlActX Enumeration

IRD

Adxl343TypeActInactCtlActX Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlActX
Public Enumeration TypeActInactCtlActX
public enum class TypeActInactCtlActX
type TypeActInactCtlActX
Members
Member name | Value | Description
DisableXAxisActivityDetection | 0 | Disable x-axis activity detection
EnableXAxisActivityDetection | 1 | Enable x-axis activity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeActInactCtlActY Enumeration

IRD

Adxl343TypeActInactCtlActY Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlActY
Public Enumeration TypeActInactCtlActY
public enum class TypeActInactCtlActY
type TypeActInactCtlActY
Members
Member name | Value | Description
DisableYAxisActivityDetection | 0 | Disable y-axis activity detection
EnableYAxisActivityDetection | 1 | Enable y-axis activity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeActInactCtlActZ Enumeration

IRD

Adxl343TypeActInactCtlActZ Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlActZ
Public Enumeration TypeActInactCtlActZ
public enum class TypeActInactCtlActZ
type TypeActInactCtlActZ
Members
Member name | Value | Description
DisableZAxisActivityDetection | 0 | Disable z-axis activity detection
EnableZAxisActivityDetection | 1 | Enable z-axis activity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeActInactCtlInactAcDc Enumeration

IRD

Adxl343TypeActInactCtlInactAcDc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlInactAcDc
Public Enumeration TypeActInactCtlInactAcDc
public enum class TypeActInactCtlInactAcDc
type TypeActInactCtlInactAcDc
Members
Member name | Value | Description
DetectInactivityOfDCCoupledOperation | 0 | Detect inactivity of DC coupled operation
DetectInactivityOfACCoupledOperation | 1 | Detect inactivity of AC coupled operation
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeActInactCtlInactX Enumeration

IRD

Adxl343TypeActInactCtlInactX Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlInactX
Public Enumeration TypeActInactCtlInactX
public enum class TypeActInactCtlInactX
type TypeActInactCtlInactX
Members
Member name | Value | Description
DisableXAxisInactivityDetection | 0 | Disable x-axis inactivity detection
EnableXAxisInactivityDetection | 1 | Enable x-axis inactivity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeActInactCtlInactY Enumeration

IRD

Adxl343TypeActInactCtlInactY Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlInactY
Public Enumeration TypeActInactCtlInactY
public enum class TypeActInactCtlInactY
type TypeActInactCtlInactY
Members
Member name | Value | Description
DisableYAxisInactivityDetection | 0 | Disable y-axis inactivity detection
EnableYAxisInactivityDetection | 1 | Enable y-axis inactivity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeActInactCtlInactZ Enumeration

IRD

Adxl343TypeActInactCtlInactZ Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlInactZ
Public Enumeration TypeActInactCtlInactZ
public enum class TypeActInactCtlInactZ
type TypeActInactCtlInactZ
Members
Member name | Value | Description
DisableZAxisInactivityDetection | 0 | Disable z-axis inactivity detection
EnableZAxisInactivityDetection | 1 | Enable z-axis inactivity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeActTapStatusActXSrc Enumeration

IRD

Adxl343TypeActTapStatusActXSrc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusActXSrc
Public Enumeration TypeActTapStatusActXSrc
public enum class TypeActTapStatusActXSrc
type TypeActTapStatusActXSrc
Members
Member name | Value | Description
NoInvolvementInActivityEventInXAxis | 0 | No involvement in activity event in x-axis
InvolvementInActivityEventInXAxis | 1 | Involvement in activity event in x-axis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeActTapStatusActYSrc Enumeration

IRD

Adxl343TypeActTapStatusActYSrc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusActYSrc
Public Enumeration TypeActTapStatusActYSrc
public enum class TypeActTapStatusActYSrc
type TypeActTapStatusActYSrc
Members
Member name | Value | Description
NoInvolvementInActivityEventInYAxis | 0 | No involvement in activity event in y-axis
InvolvementInActivityEventInYAxis | 1 | Involvement in activity event in y-axis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeActTapStatusActZSrc Enumeration

IRD

Adxl343TypeActTapStatusActZSrc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusActZSrc
Public Enumeration TypeActTapStatusActZSrc
public enum class TypeActTapStatusActZSrc
type TypeActTapStatusActZSrc
Members
Member name | Value | Description
NoInvolvementInActivityEventInZAxis | 0 | No involvement in activity event in z-axis
InvolvementInActivityEventInZAxis | 1 | Involvement in activity event in z-axis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeActTapStatusAsleep Enumeration

IRD

Adxl343TypeActTapStatusAsleep Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusAsleep
Public Enumeration TypeActTapStatusAsleep
public enum class TypeActTapStatusAsleep
type TypeActTapStatusAsleep
Members
Member name | Value | Description
ThePartIsNotAsleep | 0 | The part is not asleep
ThePartIsAsleep | 1 | The part is asleep
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeActTapStatusTapXSrc Enumeration

IRD

Adxl343TypeActTapStatusTapXSrc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusTapXSrc
Public Enumeration TypeActTapStatusTapXSrc
public enum class TypeActTapStatusTapXSrc
type TypeActTapStatusTapXSrc
Members
Member name | Value | Description
NoInvolvementInTapEventInXAxis | 0 | No involvement in tap event in x-axis
InvolvementInTapEventInXAxis | 1 | Involvement in tap event in x-axis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeActTapStatusTapYSrc Enumeration

IRD

Adxl343TypeActTapStatusTapYSrc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusTapYSrc
Public Enumeration TypeActTapStatusTapYSrc
public enum class TypeActTapStatusTapYSrc
type TypeActTapStatusTapYSrc
Members
Member name | Value | Description
NoInvolvementInTapEventInYAxis | 0 | No involvement in tap event in y-axis
InvolvementInTapEventInYAxis | 1 | Involvement in tap event in y-axis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeActTapStatusTapZSrc Enumeration

IRD

Adxl343TypeActTapStatusTapZSrc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusTapZSrc
Public Enumeration TypeActTapStatusTapZSrc
public enum class TypeActTapStatusTapZSrc
type TypeActTapStatusTapZSrc
Members
Member name | Value | Description
NoInvolvementInTapEventInZAxis | 0 | No involvement in tap event in z-axis
InvolvementInTapEventInZAxis | 1 | Involvement in tap event in z-axis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeBwRateLowPower Enumeration

IRD

Adxl343TypeBwRateLowPower Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBwRateLowPower
Public Enumeration TypeBwRateLowPower
public enum class TypeBwRateLowPower
type TypeBwRateLowPower
Members
Member name | Value | Description
NormalOperation | 0 | Normal operation
ReducedPowerOperation | 1 | Reduced power operation
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeBwRateRateBits Enumeration

IRD

Adxl343TypeBwRateRateBits Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBwRateRateBits
Public Enumeration TypeBwRateRateBits
public enum class TypeBwRateRateBits
type TypeBwRateRateBits
Members
Member name | Value | Description
Value_0_10 | 0 | 0.10
Value_0_20 | 1 | 0.20
Value_0_39 | 2 | 0.39
Value_0_78 | 3 | 0.78
Value_1_56 | 4 | 1.56
Value_3_13 | 5 | 3.13
Value_6_25 | 6 | 6.25
Value_12_5 | 7 | 12.5
Value_25 | 8 | 25
Value_50 | 9 | 50
Value_100 | 10 | 100
Value_200 | 11 | 200
Value_400 | 12 | 400
Value_800 | 13 | 800
Value_1600 | 14 | 1600
Value_3200 | 15 | 3200
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeDataFormatFullRes Enumeration

IRD

Adxl343TypeDataFormatFullRes Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatFullRes
Public Enumeration TypeDataFormatFullRes
public enum class TypeDataFormatFullRes
type TypeDataFormatFullRes
Members
Member name | Value | Description
Value_10BitMode | 0 | 10 bit mode
FullResolution | 1 | Full resolution
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeDataFormatIntInvert Enumeration

IRD

Adxl343TypeDataFormatIntInvert Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatIntInvert
Public Enumeration TypeDataFormatIntInvert
public enum class TypeDataFormatIntInvert
type TypeDataFormatIntInvert
Members
Member name | Value | Description
SetInterruptsToActiveHigh | 0 | Set interrupts to active high
SetInterruptsToActiveLow | 1 | Set interrupts to active low
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeDataFormatJustify Enumeration

IRD

Adxl343TypeDataFormatJustify Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatJustify
Public Enumeration TypeDataFormatJustify
public enum class TypeDataFormatJustify
type TypeDataFormatJustify
Members
Member name | Value | Description
RightJustifiedModeWithSignExtension | 0 | Right justified mode with sign extension
LeftMSBJustifiedMode | 1 | Left (MSB) justified mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeDataFormatRange Enumeration

IRD

Adxl343TypeDataFormatRange Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatRange
Public Enumeration TypeDataFormatRange
public enum class TypeDataFormatRange
type TypeDataFormatRange
Members
Member name | Value | Description
Value_2g | 0 | +/- 2g
Value_4g | 1 | +/- 4g
Value_8g | 2 | +/- 8g
Value_16g | 3 | +/- 16g
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeDataFormatSelfTest Enumeration

IRD

Adxl343TypeDataFormatSelfTest Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatSelfTest
Public Enumeration TypeDataFormatSelfTest
public enum class TypeDataFormatSelfTest
type TypeDataFormatSelfTest
Members
Member name | Value | Description
DisableTheSelfTestForce | 0 | Disable the self-test force
EnablesTheSelfTestForce | 1 | Enables the self-test force
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeDataFormatSpi Enumeration

IRD

Adxl343TypeDataFormatSpi Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatSpi
Public Enumeration TypeDataFormatSpi
public enum class TypeDataFormatSpi
type TypeDataFormatSpi
Members
Member name | Value | Description
Value_4WireSPI | 0 | 4-wire SPI
Value_3WireSPI | 1 | 3-wire SPI
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeFifoCtlFifoMode Enumeration

IRD

Adxl343TypeFifoCtlFifoMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFifoCtlFifoMode
Public Enumeration TypeFifoCtlFifoMode
public enum class TypeFifoCtlFifoMode
type TypeFifoCtlFifoMode
Members
Member name | Value | Description
BypassFIFOBypassed | 0 | Bypass: FIFO bypassed
FIFOCollectUpTo32ValuesInFIFO | 1 | FIFO: Collect up to 32 values in FIFO
StreamFIFOHoldsTheLast32DataValues | 2 | Stream: FIFO holds the last 32 data values
TriggerFIFOHoldsTheLastDataSamplesBeforeTheTriggerEvent | 3 | Trigger: FIFO holds the last data samples before the trigger event
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeFifoCtlTrigger Enumeration

IRD

Adxl343TypeFifoCtlTrigger Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFifoCtlTrigger
Public Enumeration TypeFifoCtlTrigger
public enum class TypeFifoCtlTrigger
type TypeFifoCtlTrigger
Members
Member name | Value | Description
SetsTheTriggerEventOfTriggerModeToBeLinkedToINT1 | 0 | sets the trigger event of trigger mode to be linked to INT1
SetsTheTriggerEventOfTriggerModeToBeLinkedToINT2 | 1 | sets the trigger event of trigger mode to be linked to INT2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeFifoStatusFifoTrig Enumeration

IRD

Adxl343TypeFifoStatusFifoTrig Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFifoStatusFifoTrig
Public Enumeration TypeFifoStatusFifoTrig
public enum class TypeFifoStatusFifoTrig
type TypeFifoStatusFifoTrig
Members
Member name | Value | Description
FIFOTriggerEventHasNotOccurred | 0 | FIFO trigger event has not occurred
FIFOTriggerEventOccurring | 1 | FIFO trigger event occurring
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntEnableActivity Enumeration

IRD

Adxl343TypeIntEnableActivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableActivity
Public Enumeration TypeIntEnableActivity
public enum class TypeIntEnableActivity
type TypeIntEnableActivity
Members
Member name | Value | Description
DisableActivityFunctionInterrupts | 0 | Disable activity function interrupts
EnableActivityFunctionInterrupts | 1 | Enable activity function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntEnableDataReady Enumeration

IRD

Adxl343TypeIntEnableDataReady Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableDataReady
Public Enumeration TypeIntEnableDataReady
public enum class TypeIntEnableDataReady
type TypeIntEnableDataReady
Members
Member name | Value | Description
DisableDataReadyFunctionInterrupts | 0 | Disable data_ready function interrupts
EnableDataReadyFunctionInterrupts | 1 | Enable data_ready function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntEnableDoubleTap Enumeration

IRD

Adxl343TypeIntEnableDoubleTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableDoubleTap
Public Enumeration TypeIntEnableDoubleTap
public enum class TypeIntEnableDoubleTap
type TypeIntEnableDoubleTap
Members
Member name | Value | Description
DisableDoubleTapFunctionInterrupts | 0 | Disable double_tap function interrupts
EnableDoubleTapFunctionInterrupts | 1 | Enable double_tap function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntEnableFreeFall Enumeration

IRD

Adxl343TypeIntEnableFreeFall Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableFreeFall
Public Enumeration TypeIntEnableFreeFall
public enum class TypeIntEnableFreeFall
type TypeIntEnableFreeFall
Members
Member name | Value | Description
DisableFreeFallFunctionInterrupts | 0 | Disable free_fall function interrupts
EnableFreeFallFunctionInterrupts | 1 | Enable free_fall function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntEnableInactivity Enumeration

IRD

Adxl343TypeIntEnableInactivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableInactivity
Public Enumeration TypeIntEnableInactivity
public enum class TypeIntEnableInactivity
type TypeIntEnableInactivity
Members
Member name | Value | Description
DisableInactivityFunctionInterrupts | 0 | Disable inactivity function interrupts
EnableInactivityFunctionInterrupts | 1 | Enable inactivity function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntEnableOverrun Enumeration

IRD

Adxl343TypeIntEnableOverrun Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableOverrun
Public Enumeration TypeIntEnableOverrun
public enum class TypeIntEnableOverrun
type TypeIntEnableOverrun
Members
Member name | Value | Description
DisableOverrunFunctionInterrupts | 0 | Disable overrun function interrupts
EnableOverrunFunctionInterrupts | 1 | Enable overrun function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntEnableSingleTap Enumeration

IRD

Adxl343TypeIntEnableSingleTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableSingleTap
Public Enumeration TypeIntEnableSingleTap
public enum class TypeIntEnableSingleTap
type TypeIntEnableSingleTap
Members
Member name | Value | Description
DisableSingleTapFunctionInterrupts | 0 | Disable single_tap function interrupts
EnableSingleTapFunctionInterrupts | 1 | Enable single_tap function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntEnableWatermark Enumeration

IRD

Adxl343TypeIntEnableWatermark Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableWatermark
Public Enumeration TypeIntEnableWatermark
public enum class TypeIntEnableWatermark
type TypeIntEnableWatermark
Members
Member name | Value | Description
DisableWatermarkFunctionInterrupts | 0 | Disable watermark function interrupts
EnableWatermarkFunctionInterrupts | 1 | Enable watermark function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntMapActivity Enumeration

IRD

Adxl343TypeIntMapActivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapActivity
Public Enumeration TypeIntMapActivity
public enum class TypeIntMapActivity
type TypeIntMapActivity
Members
Member name | Value | Description
SendActivityInterruptToINT1Pin | 0 | Send activity interrupt to INT1 pin
SendActivityInterruptToINT2Pin | 1 | Send activity interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntMapDataReady Enumeration

IRD

Adxl343TypeIntMapDataReady Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapDataReady
Public Enumeration TypeIntMapDataReady
public enum class TypeIntMapDataReady
type TypeIntMapDataReady
Members
Member name | Value | Description
SendDataReadyInterruptToINT1Pin | 0 | Send data_ready interrupt to INT1 pin
SendDataReadyInterruptToINT2Pin | 1 | Send data_ready interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntMapDoubleTap Enumeration

IRD

Adxl343TypeIntMapDoubleTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapDoubleTap
Public Enumeration TypeIntMapDoubleTap
public enum class TypeIntMapDoubleTap
type TypeIntMapDoubleTap
Members
Member name | Value | Description
SendDoubleTapInterruptToINT1Pin | 0 | Send double_tap interrupt to INT1 pin
SendDoubleTapInterruptToINT2Pin | 1 | Send double_tap interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntMapFreeFall Enumeration

IRD

Adxl343TypeIntMapFreeFall Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapFreeFall
Public Enumeration TypeIntMapFreeFall
public enum class TypeIntMapFreeFall
type TypeIntMapFreeFall
Members
Member name | Value | Description
SendFreeFallInterruptToINT1Pin | 0 | Send free_fall interrupt to INT1 pin
SendFreeFallInterruptToINT2Pin | 1 | Send free_fall interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntMapInactivity Enumeration

IRD

Adxl343TypeIntMapInactivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapInactivity
Public Enumeration TypeIntMapInactivity
public enum class TypeIntMapInactivity
type TypeIntMapInactivity
Members
Member name | Value | Description
SendInactivityInterruptToINT1Pin | 0 | Send inactivity interrupt to INT1 pin
SendInactivityInterruptToINT2Pin | 1 | Send inactivity interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntMapOverrun Enumeration

IRD

Adxl343TypeIntMapOverrun Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapOverrun
Public Enumeration TypeIntMapOverrun
public enum class TypeIntMapOverrun
type TypeIntMapOverrun
Members
Member name | Value | Description
SendOverrunInterruptToINT1Pin | 0 | Send overrun interrupt to INT1 pin
SendOverrunInterruptToINT2Pin | 1 | Send overrun interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntMapSingleTap Enumeration

IRD

Adxl343TypeIntMapSingleTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapSingleTap
Public Enumeration TypeIntMapSingleTap
public enum class TypeIntMapSingleTap
type TypeIntMapSingleTap
Members
Member name | Value | Description
SendSingleTapInterruptToINT1Pin | 0 | Send single_tap interrupt to INT1 pin
SendSingleTapInterruptToINT2Pin | 1 | Send single_tap interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntMapWatermark Enumeration

IRD

Adxl343TypeIntMapWatermark Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapWatermark
Public Enumeration TypeIntMapWatermark
public enum class TypeIntMapWatermark
type TypeIntMapWatermark
Members
Member name | Value | Description
SendWatermarkInterruptToINT1Pin | 0 | Send watermark interrupt to INT1 pin
SendWatermarkInterruptToINT2Pin | 1 | Send watermark interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntSourceActivity Enumeration

IRD

Adxl343TypeIntSourceActivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceActivity
Public Enumeration TypeIntSourceActivity
public enum class TypeIntSourceActivity
type TypeIntSourceActivity
Members
Member name | Value | Description
ActivityFunctionEventNotOccurred | 0 | Activity function event not occurred
ActivityFunctionHasTriggered | 1 | Activity function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntSourceDataReady Enumeration

IRD

Adxl343TypeIntSourceDataReady Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceDataReady
Public Enumeration TypeIntSourceDataReady
public enum class TypeIntSourceDataReady
type TypeIntSourceDataReady
Members
Member name | Value | Description
ActivityFunctionEventNotOccurred | 0 | Activity function event not occurred
ActivityFunctionHasTriggered | 1 | Activity function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntSourceDoubleTap Enumeration

IRD

Adxl343TypeIntSourceDoubleTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceDoubleTap
Public Enumeration TypeIntSourceDoubleTap
public enum class TypeIntSourceDoubleTap
type TypeIntSourceDoubleTap
Members
Member name | Value | Description
DataReadyFunctionEventNotOccurred | 0 | Data_ready function event not occurred
DataReadyFunctionHasTriggered | 1 | Data_ready function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntSourceFreeFall Enumeration

IRD

Adxl343TypeIntSourceFreeFall Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceFreeFall
Public Enumeration TypeIntSourceFreeFall
public enum class TypeIntSourceFreeFall
type TypeIntSourceFreeFall
Members
Member name | Value | Description
FreeFallFunctionEventNotOccurred | 0 | Free_fall function event not occurred
FreeFallFunctionHasTriggered | 1 | Free_fall function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntSourceInactivity Enumeration

IRD

Adxl343TypeIntSourceInactivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceInactivity
Public Enumeration TypeIntSourceInactivity
public enum class TypeIntSourceInactivity
type TypeIntSourceInactivity
Members
Member name | Value | Description
InactivityFunctionEventNotOccurred | 0 | Inactivity function event not occurred
InactivityFunctionHasTriggered | 1 | Inactivity function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntSourceOverrun Enumeration

IRD

Adxl343TypeIntSourceOverrun Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceOverrun
Public Enumeration TypeIntSourceOverrun
public enum class TypeIntSourceOverrun
type TypeIntSourceOverrun
Members
Member name | Value | Description
ActivityFunctionEventNotOccurred | 0 | Activity function event not occurred
ActivityFunctionHasTriggered | 1 | Activity function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntSourceSingleTap Enumeration

IRD

Adxl343TypeIntSourceSingleTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceSingleTap
Public Enumeration TypeIntSourceSingleTap
public enum class TypeIntSourceSingleTap
type TypeIntSourceSingleTap
Members
Member name | Value | Description
OverrunFunctionEventNotOccurred | 0 | Overrun function event not occurred
OverrunFunctionHasTriggered | 1 | Overrun function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeIntSourceWatermark Enumeration

IRD

Adxl343TypeIntSourceWatermark Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceWatermark
Public Enumeration TypeIntSourceWatermark
public enum class TypeIntSourceWatermark
type TypeIntSourceWatermark
Members
Member name | Value | Description
WatermarkFunctionEventNotOccurred | 0 | Watermark function event not occurred
WatermarkFunctionHasTriggered | 1 | Watermark function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypePowerCtlAutoSleep Enumeration

IRD

Adxl343TypePowerCtlAutoSleep Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlAutoSleep
Public Enumeration TypePowerCtlAutoSleep
public enum class TypePowerCtlAutoSleep
type TypePowerCtlAutoSleep
Members
Member name | Value | Description
DisableAutomaticSwitchingToSleepMode | 0 | Disable automatic switching to sleep mode
SwitchToSleepModeWhenInactivityIsDetected | 1 | Switch to sleep mode when inactivity is detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypePowerCtlLink Enumeration

IRD

Adxl343TypePowerCtlLink Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlLink
Public Enumeration TypePowerCtlLink
public enum class TypePowerCtlLink
type TypePowerCtlLink
Members
Member name | Value | Description
InactivityAndActivityFunctionsAreConcurrent | 0 | Inactivity and activity functions are concurrent
DelaysTheStartOfTheActivityFunctionUntilInactivityIsDetected | 1 | Delays the start of the activity function until inactivity is detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypePowerCtlMeasure Enumeration

IRD

Adxl343TypePowerCtlMeasure Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlMeasure
Public Enumeration TypePowerCtlMeasure
public enum class TypePowerCtlMeasure
type TypePowerCtlMeasure
Members
Member name | Value | Description
StandbyMode | 0 | Standby mode
MeasurementMode | 1 | Measurement mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypePowerCtlSleep Enumeration

IRD

Adxl343TypePowerCtlSleep Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlSleep
Public Enumeration TypePowerCtlSleep
public enum class TypePowerCtlSleep
type TypePowerCtlSleep
Members
Member name | Value | Description
NormalOperation | 0 | Normal operation
SleepMode | 1 | Sleep mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypePowerCtlWakeup Enumeration

IRD

Adxl343TypePowerCtlWakeup Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlWakeup
Public Enumeration TypePowerCtlWakeup
public enum class TypePowerCtlWakeup
type TypePowerCtlWakeup
Members
Member name | Value | Description
FrequencyReadingInSleepMode8Hz | 0 | Frequency reading in sleep mode: 8 Hz
FrequencyReadingInSleepMode4Hz | 1 | Frequency reading in sleep mode: 4 Hz
FrequencyReadingInSleepMode2Hz | 2 | Frequency reading in sleep mode: 2 Hz
FrequencyReadingInSleepMode1Hz | 3 | Frequency reading in sleep mode: 1 Hz
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeTapAxesSuppress Enumeration

IRD

Adxl343TypeTapAxesSuppress Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapAxesSuppress
Public Enumeration TypeTapAxesSuppress
public enum class TypeTapAxesSuppress
type TypeTapAxesSuppress
Members
Member name | Value | Description
DoubleTapDetectionPossible | 0 | Double tap detection possible
DoubleTapDetectionSuppressed | 1 | Double tap detection suppressed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeTapAxesTapXEn Enumeration

IRD

Adxl343TypeTapAxesTapXEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapAxesTapXEn
Public Enumeration TypeTapAxesTapXEn
public enum class TypeTapAxesTapXEn
type TypeTapAxesTapXEn
Members
Member name | Value | Description
ExcludesXAxisFromParticipation | 0 | Excludes x-axis from participation
EnableXAxisParticipationInTapDetection | 1 | Enable x-axis participation in tap detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeTapAxesTapYEn Enumeration

IRD

Adxl343TypeTapAxesTapYEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapAxesTapYEn
Public Enumeration TypeTapAxesTapYEn
public enum class TypeTapAxesTapYEn
type TypeTapAxesTapYEn
Members
Member name | Value | Description
ExcludesYAxisFromParticipation | 0 | Excludes y-axis from participation
EnableYAxisParticipationInTapDetection | 1 | Enable y-axis participation in tap detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl343.TypeTapAxesTapZEn Enumeration

IRD

Adxl343TypeTapAxesTapZEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapAxesTapZEn
Public Enumeration TypeTapAxesTapZEn
public enum class TypeTapAxesTapZEn
type TypeTapAxesTapZEn
Members
Member name | Value | Description
ExcludesZAxisFromParticipation | 0 | Excludes z-axis from participation
EnableZAxisParticipationInTapDetection | 1 | Enable z-axis participation in tap detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345 Class

Analog Devices: ADXL 345
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdxl345

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adxl345
Public Class Adxl345
public ref class Adxl345
type Adxl345 =  class end

The Adxl345 type exposes the following members.

Constructors
 | Name | Description
Public method | Adxl345 | Constructor
Top
Properties
 | Name | Description
Public property | ActInactControlACTACDC | Act Inact Control (ACT AC/DC)
Public property | ActInactControlACTXEN | Act Inact Control (ACT X EN)
Public property | ActInactControlACTYEN | Act Inact Control (ACT Y EN)
Public property | ActInactControlACTZEN | Act Inact Control (ACT Z EN)
Public property | ActInactControlINACTACDC | Act Inact Control (INACT AC/DC)
Public property | ActInactControlINACTXEN | Act Inact Control (INACT X EN)
Public property | ActInactControlINACTYEN | Act Inact Control (INACT Y EN)
Public property | ActInactControlINACTZEN | Act Inact Control (INACT Z EN)
Public property | ActTapStatusACTXSRC | Act Tap Status (ACT X SRC)
Public property | ActTapStatusACTYSRC | Act Tap Status (ACT Y SRC)
Public property | ActTapStatusACTZSRC | Act Tap Status (ACT Z SRC)
Public property | ActTapStatusAsleep | Act Tap Status (Asleep)
Public property | ActTapStatusTAPXSRC | Act Tap Status (TAP X SRC)
Public property | ActTapStatusTAPYSRC | Act Tap Status (TAP Y SRC)
Public property | ActTapStatusTAPZSRC | Act Tap Status (TAP Z SRC)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BWRateLowPower | BW Rate (Low Power)
Public property | BWRateRate | BW Rate (Rate)
Public property | DataFormatFullRes | Data Format (Full Res)
Public property | DataFormatIntInvert | Data Format (Int Invert)
Public property | DataFormatJustify | Data Format (Justify)
Public property | DataFormatRange | Data Format (Range)
Public property | DataFormatSelfTest | Data Format (Self Test)
Public property | DataFormatSPI | Data Format (SPI)
Public property | DataX | Data X
Public property | DataY | Data Y
Public property | DataZ | Data Z
Public property | DeviceID | Device ID
Public property | DUR | DUR (unit: μs)
Public property | FIFOCTLFIFOMode | FIFO CTL (FIFO Mode)
Public property | FIFOCTLSamples | FIFO CTL (Samples)
Public property | FIFOCTLTrigger | FIFO CTL (Trigger)
Public property | FIFOStatusEntries | FIFO Status (Entries)
Public property | FIFOStatusFIFOTrig | FIFO Status (FIFO Trig)
Public property | INTEnableActivity | INT Enable (Activity)
Public property | INTEnableDataReady | INT Enable (Data Ready)
Public property | INTEnableDoubleTap | INT Enable (Double Tap)
Public property | INTEnableFreeFall | INT Enable (Free Fall)
Public property | INTEnableInactivity | INT Enable (Inactivity)
Public property | INTEnableOverrun | INT Enable (Overrun)
Public property | INTEnableSingleTap | INT Enable (Single Tap)
Public property | INTEnableWatermark | INT Enable (Watermark)
Public property | INTMapActivity | INT Map (Activity)
Public property | INTMapDataReady | INT Map (Data Ready)
Public property | INTMapDoubleTap | INT Map (Double Tap)
Public property | INTMapFreeFall | INT Map (Free Fall)
Public property | INTMapInactivity | INT Map (Inactivity)
Public property | INTMapOverrun | INT Map (Overrun)
Public property | INTMapSingleTap | INT Map (Single Tap)
Public property | INTMapWatermark | INT Map (Watermark)
Public property | INTSourceActivity | INT Source (Activity)
Public property | INTSourceDataReady | INT Source (Data Ready)
Public property | INTSourceDoubleTap | INT Source (Double Tap)
Public property | INTSourceFreeFall | INT Source (Free Fall)
Public property | INTSourceInactivity | INT Source (Inactivity)
Public property | INTSourceOverrun | INT Source (Overrun)
Public property | INTSourceSingleTap | INT Source (Single Tap)
Public property | INTSourceWatermark | INT Source (Watermark)
Public property | Latent | Latent (unit: ms)
Public property | OFSX | OFSX (unit: mg)
Public property | OFSY | OFSY (unit: mg)
Public property | OFSZ | OFSZ (unit: mg)
Public property | PowerCTLAutoSleep | Power CTL (Auto Sleep)
Public property | PowerCTLLink | Power CTL (Link)
Public property | PowerCTLMeasure | Power CTL (Measure)
Public property | PowerCTLSleep | Power CTL (Sleep)
Public property | PowerCTLWakeUp | Power CTL (Wake Up)
Public property | TapAxesSuppress | Tap Axes (Suppress)
Public property | TapAxesTAPXEN | Tap Axes (TAP X EN)
Public property | TapAxesTAPYEN | Tap Axes (TAP Y EN)
Public property | TapAxesTAPZEN | Tap Axes (TAP Z EN)
Public property | ThreshAct | Thresh Act (unit: mg)
Public property | ThreshFF | Thresh FF (unit: mg)
Public property | ThreshInact | Thresh Inact (unit: mg)
Public property | ThreshTap | Thresh Tap (unit: mg)
Public property | TimeFF | Time FF (unit: ms)
Public property | TimeInact | Time Inact (unit: s)
Public property | Window | Window (unit: ms)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
3-Axis ±2 g/±4 g/±8 g/±16 g Digital Accelerometer
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adxl345(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adxl345

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345 Properties

The Adxl345 type exposes the following members.

Properties
 | Name | Description
Public property | ActInactControlACTACDC | Act Inact Control (ACT AC/DC)
Public property | ActInactControlACTXEN | Act Inact Control (ACT X EN)
Public property | ActInactControlACTYEN | Act Inact Control (ACT Y EN)
Public property | ActInactControlACTZEN | Act Inact Control (ACT Z EN)
Public property | ActInactControlINACTACDC | Act Inact Control (INACT AC/DC)
Public property | ActInactControlINACTXEN | Act Inact Control (INACT X EN)
Public property | ActInactControlINACTYEN | Act Inact Control (INACT Y EN)
Public property | ActInactControlINACTZEN | Act Inact Control (INACT Z EN)
Public property | ActTapStatusACTXSRC | Act Tap Status (ACT X SRC)
Public property | ActTapStatusACTYSRC | Act Tap Status (ACT Y SRC)
Public property | ActTapStatusACTZSRC | Act Tap Status (ACT Z SRC)
Public property | ActTapStatusAsleep | Act Tap Status (Asleep)
Public property | ActTapStatusTAPXSRC | Act Tap Status (TAP X SRC)
Public property | ActTapStatusTAPYSRC | Act Tap Status (TAP Y SRC)
Public property | ActTapStatusTAPZSRC | Act Tap Status (TAP Z SRC)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BWRateLowPower | BW Rate (Low Power)
Public property | BWRateRate | BW Rate (Rate)
Public property | DataFormatFullRes | Data Format (Full Res)
Public property | DataFormatIntInvert | Data Format (Int Invert)
Public property | DataFormatJustify | Data Format (Justify)
Public property | DataFormatRange | Data Format (Range)
Public property | DataFormatSelfTest | Data Format (Self Test)
Public property | DataFormatSPI | Data Format (SPI)
Public property | DataX | Data X
Public property | DataY | Data Y
Public property | DataZ | Data Z
Public property | DeviceID | Device ID
Public property | DUR | DUR (unit: μs)
Public property | FIFOCTLFIFOMode | FIFO CTL (FIFO Mode)
Public property | FIFOCTLSamples | FIFO CTL (Samples)
Public property | FIFOCTLTrigger | FIFO CTL (Trigger)
Public property | FIFOStatusEntries | FIFO Status (Entries)
Public property | FIFOStatusFIFOTrig | FIFO Status (FIFO Trig)
Public property | INTEnableActivity | INT Enable (Activity)
Public property | INTEnableDataReady | INT Enable (Data Ready)
Public property | INTEnableDoubleTap | INT Enable (Double Tap)
Public property | INTEnableFreeFall | INT Enable (Free Fall)
Public property | INTEnableInactivity | INT Enable (Inactivity)
Public property | INTEnableOverrun | INT Enable (Overrun)
Public property | INTEnableSingleTap | INT Enable (Single Tap)
Public property | INTEnableWatermark | INT Enable (Watermark)
Public property | INTMapActivity | INT Map (Activity)
Public property | INTMapDataReady | INT Map (Data Ready)
Public property | INTMapDoubleTap | INT Map (Double Tap)
Public property | INTMapFreeFall | INT Map (Free Fall)
Public property | INTMapInactivity | INT Map (Inactivity)
Public property | INTMapOverrun | INT Map (Overrun)
Public property | INTMapSingleTap | INT Map (Single Tap)
Public property | INTMapWatermark | INT Map (Watermark)
Public property | INTSourceActivity | INT Source (Activity)
Public property | INTSourceDataReady | INT Source (Data Ready)
Public property | INTSourceDoubleTap | INT Source (Double Tap)
Public property | INTSourceFreeFall | INT Source (Free Fall)
Public property | INTSourceInactivity | INT Source (Inactivity)
Public property | INTSourceOverrun | INT Source (Overrun)
Public property | INTSourceSingleTap | INT Source (Single Tap)
Public property | INTSourceWatermark | INT Source (Watermark)
Public property | Latent | Latent (unit: ms)
Public property | OFSX | OFSX (unit: mg)
Public property | OFSY | OFSY (unit: mg)
Public property | OFSZ | OFSZ (unit: mg)
Public property | PowerCTLAutoSleep | Power CTL (Auto Sleep)
Public property | PowerCTLLink | Power CTL (Link)
Public property | PowerCTLMeasure | Power CTL (Measure)
Public property | PowerCTLSleep | Power CTL (Sleep)
Public property | PowerCTLWakeUp | Power CTL (Wake Up)
Public property | TapAxesSuppress | Tap Axes (Suppress)
Public property | TapAxesTAPXEN | Tap Axes (TAP X EN)
Public property | TapAxesTAPYEN | Tap Axes (TAP Y EN)
Public property | TapAxesTAPZEN | Tap Axes (TAP Z EN)
Public property | ThreshAct | Thresh Act (unit: mg)
Public property | ThreshFF | Thresh FF (unit: mg)
Public property | ThreshInact | Thresh Inact (unit: mg)
Public property | ThreshTap | Thresh Tap (unit: mg)
Public property | TimeFF | Time FF (unit: ms)
Public property | TimeInact | Time Inact (unit: s)
Public property | Window | Window (unit: ms)
Top
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ActInactControlACTACDC Property

IRD

Adxl345ActInactControlACTACDC Property

Act Inact Control (ACT AC/DC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeActInactCtlActAcDc ActInactControlACTACDC { get; set; }
Public Property ActInactControlACTACDC As Adxl345TypeActInactCtlActAcDc
    Get
    Set
public:
property Adxl345TypeActInactCtlActAcDc ActInactControlACTACDC {
    Adxl345TypeActInactCtlActAcDc get ();
    void set (Adxl345TypeActInactCtlActAcDc value);
}
member ActInactControlACTACDC : Adxl345TypeActInactCtlActAcDc with get, set

Property Value

Type: Adxl345TypeActInactCtlActAcDc
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ActInactControlACTXEN Property

IRD

Adxl345ActInactControlACTXEN Property

Act Inact Control (ACT X EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeActInactCtlActX ActInactControlACTXEN { get; set; }
Public Property ActInactControlACTXEN As Adxl345TypeActInactCtlActX
    Get
    Set
public:
property Adxl345TypeActInactCtlActX ActInactControlACTXEN {
    Adxl345TypeActInactCtlActX get ();
    void set (Adxl345TypeActInactCtlActX value);
}
member ActInactControlACTXEN : Adxl345TypeActInactCtlActX with get, set

Property Value

Type: Adxl345TypeActInactCtlActX
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ActInactControlACTYEN Property

IRD

Adxl345ActInactControlACTYEN Property

Act Inact Control (ACT Y EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeActInactCtlActY ActInactControlACTYEN { get; set; }
Public Property ActInactControlACTYEN As Adxl345TypeActInactCtlActY
    Get
    Set
public:
property Adxl345TypeActInactCtlActY ActInactControlACTYEN {
    Adxl345TypeActInactCtlActY get ();
    void set (Adxl345TypeActInactCtlActY value);
}
member ActInactControlACTYEN : Adxl345TypeActInactCtlActY with get, set

Property Value

Type: Adxl345TypeActInactCtlActY
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ActInactControlACTZEN Property

IRD

Adxl345ActInactControlACTZEN Property

Act Inact Control (ACT Z EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeActInactCtlActZ ActInactControlACTZEN { get; set; }
Public Property ActInactControlACTZEN As Adxl345TypeActInactCtlActZ
    Get
    Set
public:
property Adxl345TypeActInactCtlActZ ActInactControlACTZEN {
    Adxl345TypeActInactCtlActZ get ();
    void set (Adxl345TypeActInactCtlActZ value);
}
member ActInactControlACTZEN : Adxl345TypeActInactCtlActZ with get, set

Property Value

Type: Adxl345TypeActInactCtlActZ
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ActInactControlINACTACDC Property

IRD

Adxl345ActInactControlINACTACDC Property

Act Inact Control (INACT AC/DC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeActInactCtlInactAcDc ActInactControlINACTACDC { get; set; }
Public Property ActInactControlINACTACDC As Adxl345TypeActInactCtlInactAcDc
    Get
    Set
public:
property Adxl345TypeActInactCtlInactAcDc ActInactControlINACTACDC {
    Adxl345TypeActInactCtlInactAcDc get ();
    void set (Adxl345TypeActInactCtlInactAcDc value);
}
member ActInactControlINACTACDC : Adxl345TypeActInactCtlInactAcDc with get, set

Property Value

Type: Adxl345TypeActInactCtlInactAcDc
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ActInactControlINACTXEN Property

IRD

Adxl345ActInactControlINACTXEN Property

Act Inact Control (INACT X EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeActInactCtlInactX ActInactControlINACTXEN { get; set; }
Public Property ActInactControlINACTXEN As Adxl345TypeActInactCtlInactX
    Get
    Set
public:
property Adxl345TypeActInactCtlInactX ActInactControlINACTXEN {
    Adxl345TypeActInactCtlInactX get ();
    void set (Adxl345TypeActInactCtlInactX value);
}
member ActInactControlINACTXEN : Adxl345TypeActInactCtlInactX with get, set

Property Value

Type: Adxl345TypeActInactCtlInactX
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ActInactControlINACTYEN Property

IRD

Adxl345ActInactControlINACTYEN Property

Act Inact Control (INACT Y EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeActInactCtlInactY ActInactControlINACTYEN { get; set; }
Public Property ActInactControlINACTYEN As Adxl345TypeActInactCtlInactY
    Get
    Set
public:
property Adxl345TypeActInactCtlInactY ActInactControlINACTYEN {
    Adxl345TypeActInactCtlInactY get ();
    void set (Adxl345TypeActInactCtlInactY value);
}
member ActInactControlINACTYEN : Adxl345TypeActInactCtlInactY with get, set

Property Value

Type: Adxl345TypeActInactCtlInactY
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ActInactControlINACTZEN Property

IRD

Adxl345ActInactControlINACTZEN Property

Act Inact Control (INACT Z EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeActInactCtlActZ ActInactControlINACTZEN { get; set; }
Public Property ActInactControlINACTZEN As Adxl345TypeActInactCtlActZ
    Get
    Set
public:
property Adxl345TypeActInactCtlActZ ActInactControlINACTZEN {
    Adxl345TypeActInactCtlActZ get ();
    void set (Adxl345TypeActInactCtlActZ value);
}
member ActInactControlINACTZEN : Adxl345TypeActInactCtlActZ with get, set

Property Value

Type: Adxl345TypeActInactCtlActZ
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ActTapStatusACTXSRC Property

IRD

Adxl345ActTapStatusACTXSRC Property

Act Tap Status (ACT X SRC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeActTapStatusActXSrc ActTapStatusACTXSRC { get; }
Public ReadOnly Property ActTapStatusACTXSRC As Adxl345TypeActTapStatusActXSrc
    Get
public:
property Adxl345TypeActTapStatusActXSrc ActTapStatusACTXSRC {
    Adxl345TypeActTapStatusActXSrc get ();
}
member ActTapStatusACTXSRC : Adxl345TypeActTapStatusActXSrc with get

Property Value

Type: Adxl345TypeActTapStatusActXSrc
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ActTapStatusACTYSRC Property

IRD

Adxl345ActTapStatusACTYSRC Property

Act Tap Status (ACT Y SRC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeActTapStatusActYSrc ActTapStatusACTYSRC { get; }
Public ReadOnly Property ActTapStatusACTYSRC As Adxl345TypeActTapStatusActYSrc
    Get
public:
property Adxl345TypeActTapStatusActYSrc ActTapStatusACTYSRC {
    Adxl345TypeActTapStatusActYSrc get ();
}
member ActTapStatusACTYSRC : Adxl345TypeActTapStatusActYSrc with get

Property Value

Type: Adxl345TypeActTapStatusActYSrc
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ActTapStatusACTZSRC Property

IRD

Adxl345ActTapStatusACTZSRC Property

Act Tap Status (ACT Z SRC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeActTapStatusActZSrc ActTapStatusACTZSRC { get; }
Public ReadOnly Property ActTapStatusACTZSRC As Adxl345TypeActTapStatusActZSrc
    Get
public:
property Adxl345TypeActTapStatusActZSrc ActTapStatusACTZSRC {
    Adxl345TypeActTapStatusActZSrc get ();
}
member ActTapStatusACTZSRC : Adxl345TypeActTapStatusActZSrc with get

Property Value

Type: Adxl345TypeActTapStatusActZSrc
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ActTapStatusAsleep Property

IRD

Adxl345ActTapStatusAsleep Property

Act Tap Status (Asleep)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeActTapStatusAsleep ActTapStatusAsleep { get; }
Public ReadOnly Property ActTapStatusAsleep As Adxl345TypeActTapStatusAsleep
    Get
public:
property Adxl345TypeActTapStatusAsleep ActTapStatusAsleep {
    Adxl345TypeActTapStatusAsleep get ();
}
member ActTapStatusAsleep : Adxl345TypeActTapStatusAsleep with get

Property Value

Type: Adxl345TypeActTapStatusAsleep
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ActTapStatusTAPXSRC Property

IRD

Adxl345ActTapStatusTAPXSRC Property

Act Tap Status (TAP X SRC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeActTapStatusTapXSrc ActTapStatusTAPXSRC { get; }
Public ReadOnly Property ActTapStatusTAPXSRC As Adxl345TypeActTapStatusTapXSrc
    Get
public:
property Adxl345TypeActTapStatusTapXSrc ActTapStatusTAPXSRC {
    Adxl345TypeActTapStatusTapXSrc get ();
}
member ActTapStatusTAPXSRC : Adxl345TypeActTapStatusTapXSrc with get

Property Value

Type: Adxl345TypeActTapStatusTapXSrc
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ActTapStatusTAPYSRC Property

IRD

Adxl345ActTapStatusTAPYSRC Property

Act Tap Status (TAP Y SRC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeActTapStatusTapYSrc ActTapStatusTAPYSRC { get; }
Public ReadOnly Property ActTapStatusTAPYSRC As Adxl345TypeActTapStatusTapYSrc
    Get
public:
property Adxl345TypeActTapStatusTapYSrc ActTapStatusTAPYSRC {
    Adxl345TypeActTapStatusTapYSrc get ();
}
member ActTapStatusTAPYSRC : Adxl345TypeActTapStatusTapYSrc with get

Property Value

Type: Adxl345TypeActTapStatusTapYSrc
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ActTapStatusTAPZSRC Property

IRD

Adxl345ActTapStatusTAPZSRC Property

Act Tap Status (TAP Z SRC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeActTapStatusTapZSrc ActTapStatusTAPZSRC { get; }
Public ReadOnly Property ActTapStatusTAPZSRC As Adxl345TypeActTapStatusTapZSrc
    Get
public:
property Adxl345TypeActTapStatusTapZSrc ActTapStatusTAPZSRC {
    Adxl345TypeActTapStatusTapZSrc get ();
}
member ActTapStatusTAPZSRC : Adxl345TypeActTapStatusTapZSrc with get

Property Value

Type: Adxl345TypeActTapStatusTapZSrc
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.AutoFlush Property

IRD

Adxl345AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.BWRateLowPower Property

IRD

Adxl345BWRateLowPower Property

BW Rate (Low Power)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeBwRateLowPower BWRateLowPower { get; set; }
Public Property BWRateLowPower As Adxl345TypeBwRateLowPower
    Get
    Set
public:
property Adxl345TypeBwRateLowPower BWRateLowPower {
    Adxl345TypeBwRateLowPower get ();
    void set (Adxl345TypeBwRateLowPower value);
}
member BWRateLowPower : Adxl345TypeBwRateLowPower with get, set

Property Value

Type: Adxl345TypeBwRateLowPower
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.BWRateRate Property

IRD

Adxl345BWRateRate Property

BW Rate (Rate)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeBwRateRateBits BWRateRate { get; set; }
Public Property BWRateRate As Adxl345TypeBwRateRateBits
    Get
    Set
public:
property Adxl345TypeBwRateRateBits BWRateRate {
    Adxl345TypeBwRateRateBits get ();
    void set (Adxl345TypeBwRateRateBits value);
}
member BWRateRate : Adxl345TypeBwRateRateBits with get, set

Property Value

Type: Adxl345TypeBwRateRateBits
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.DataFormatFullRes Property

IRD

Adxl345DataFormatFullRes Property

Data Format (Full Res)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeDataFormatFullRes DataFormatFullRes { get; set; }
Public Property DataFormatFullRes As Adxl345TypeDataFormatFullRes
    Get
    Set
public:
property Adxl345TypeDataFormatFullRes DataFormatFullRes {
    Adxl345TypeDataFormatFullRes get ();
    void set (Adxl345TypeDataFormatFullRes value);
}
member DataFormatFullRes : Adxl345TypeDataFormatFullRes with get, set

Property Value

Type: Adxl345TypeDataFormatFullRes
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.DataFormatIntInvert Property

IRD

Adxl345DataFormatIntInvert Property

Data Format (Int Invert)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeDataFormatIntInvert DataFormatIntInvert { get; set; }
Public Property DataFormatIntInvert As Adxl345TypeDataFormatIntInvert
    Get
    Set
public:
property Adxl345TypeDataFormatIntInvert DataFormatIntInvert {
    Adxl345TypeDataFormatIntInvert get ();
    void set (Adxl345TypeDataFormatIntInvert value);
}
member DataFormatIntInvert : Adxl345TypeDataFormatIntInvert with get, set

Property Value

Type: Adxl345TypeDataFormatIntInvert
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.DataFormatJustify Property

IRD

Adxl345DataFormatJustify Property

Data Format (Justify)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeDataFormatJustify DataFormatJustify { get; set; }
Public Property DataFormatJustify As Adxl345TypeDataFormatJustify
    Get
    Set
public:
property Adxl345TypeDataFormatJustify DataFormatJustify {
    Adxl345TypeDataFormatJustify get ();
    void set (Adxl345TypeDataFormatJustify value);
}
member DataFormatJustify : Adxl345TypeDataFormatJustify with get, set

Property Value

Type: Adxl345TypeDataFormatJustify
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.DataFormatRange Property

IRD

Adxl345DataFormatRange Property

Data Format (Range)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeDataFormatRange DataFormatRange { get; set; }
Public Property DataFormatRange As Adxl345TypeDataFormatRange
    Get
    Set
public:
property Adxl345TypeDataFormatRange DataFormatRange {
    Adxl345TypeDataFormatRange get ();
    void set (Adxl345TypeDataFormatRange value);
}
member DataFormatRange : Adxl345TypeDataFormatRange with get, set

Property Value

Type: Adxl345TypeDataFormatRange
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.DataFormatSelfTest Property

IRD

Adxl345DataFormatSelfTest Property

Data Format (Self Test)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeDataFormatSelfTest DataFormatSelfTest { get; set; }
Public Property DataFormatSelfTest As Adxl345TypeDataFormatSelfTest
    Get
    Set
public:
property Adxl345TypeDataFormatSelfTest DataFormatSelfTest {
    Adxl345TypeDataFormatSelfTest get ();
    void set (Adxl345TypeDataFormatSelfTest value);
}
member DataFormatSelfTest : Adxl345TypeDataFormatSelfTest with get, set

Property Value

Type: Adxl345TypeDataFormatSelfTest
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.DataFormatSPI Property

IRD

Adxl345DataFormatSPI Property

Data Format (SPI)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeDataFormatSpi DataFormatSPI { get; set; }
Public Property DataFormatSPI As Adxl345TypeDataFormatSpi
    Get
    Set
public:
property Adxl345TypeDataFormatSpi DataFormatSPI {
    Adxl345TypeDataFormatSpi get ();
    void set (Adxl345TypeDataFormatSpi value);
}
member DataFormatSPI : Adxl345TypeDataFormatSpi with get, set

Property Value

Type: Adxl345TypeDataFormatSpi
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.DataX Property

IRD

Adxl345DataX Property

Data X

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short DataX { get; }
Public ReadOnly Property DataX As Short
    Get
public:
property short DataX {
    short get ();
}
member DataX : int16 with get

Property Value

Type: Int16
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.DataY Property

IRD

Adxl345DataY Property

Data Y

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short DataY { get; }
Public ReadOnly Property DataY As Short
    Get
public:
property short DataY {
    short get ();
}
member DataY : int16 with get

Property Value

Type: Int16
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.DataZ Property

IRD

Adxl345DataZ Property

Data Z

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short DataZ { get; }
Public ReadOnly Property DataZ As Short
    Get
public:
property short DataZ {
    short get ();
}
member DataZ : int16 with get

Property Value

Type: Int16
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.DeviceID Property

IRD

Adxl345DeviceID Property

Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.DUR Property

IRD

Adxl345DUR Property

DUR (unit: μs)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DUR { get; set; }
Public Property DUR As Double
    Get
    Set
public:
property double DUR {
    double get ();
    void set (double value);
}
member DUR : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.FIFOCTLFIFOMode Property

IRD

Adxl345FIFOCTLFIFOMode Property

FIFO CTL (FIFO Mode)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeFifoCtlFifoMode FIFOCTLFIFOMode { get; set; }
Public Property FIFOCTLFIFOMode As Adxl345TypeFifoCtlFifoMode
    Get
    Set
public:
property Adxl345TypeFifoCtlFifoMode FIFOCTLFIFOMode {
    Adxl345TypeFifoCtlFifoMode get ();
    void set (Adxl345TypeFifoCtlFifoMode value);
}
member FIFOCTLFIFOMode : Adxl345TypeFifoCtlFifoMode with get, set

Property Value

Type: Adxl345TypeFifoCtlFifoMode
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.FIFOCTLSamples Property

IRD

Adxl345FIFOCTLSamples Property

FIFO CTL (Samples)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOCTLSamples { get; set; }
Public Property FIFOCTLSamples As Byte
    Get
    Set
public:
property unsigned char FIFOCTLSamples {
    unsigned char get ();
    void set (unsigned char value);
}
member FIFOCTLSamples : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.FIFOCTLTrigger Property

IRD

Adxl345FIFOCTLTrigger Property

FIFO CTL (Trigger)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeFifoCtlTrigger FIFOCTLTrigger { get; set; }
Public Property FIFOCTLTrigger As Adxl345TypeFifoCtlTrigger
    Get
    Set
public:
property Adxl345TypeFifoCtlTrigger FIFOCTLTrigger {
    Adxl345TypeFifoCtlTrigger get ();
    void set (Adxl345TypeFifoCtlTrigger value);
}
member FIFOCTLTrigger : Adxl345TypeFifoCtlTrigger with get, set

Property Value

Type: Adxl345TypeFifoCtlTrigger
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.FIFOStatusEntries Property

IRD

Adxl345FIFOStatusEntries Property

FIFO Status (Entries)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOStatusEntries { get; }
Public ReadOnly Property FIFOStatusEntries As Byte
    Get
public:
property unsigned char FIFOStatusEntries {
    unsigned char get ();
}
member FIFOStatusEntries : byte with get

Property Value

Type: Byte
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.FIFOStatusFIFOTrig Property

IRD

Adxl345FIFOStatusFIFOTrig Property

FIFO Status (FIFO Trig)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeFifoStatusFifoTrig FIFOStatusFIFOTrig { get; }
Public ReadOnly Property FIFOStatusFIFOTrig As Adxl345TypeFifoStatusFifoTrig
    Get
public:
property Adxl345TypeFifoStatusFifoTrig FIFOStatusFIFOTrig {
    Adxl345TypeFifoStatusFifoTrig get ();
}
member FIFOStatusFIFOTrig : Adxl345TypeFifoStatusFifoTrig with get

Property Value

Type: Adxl345TypeFifoStatusFifoTrig
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTEnableActivity Property

IRD

Adxl345INTEnableActivity Property

INT Enable (Activity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntEnableActivity INTEnableActivity { get; set; }
Public Property INTEnableActivity As Adxl345TypeIntEnableActivity
    Get
    Set
public:
property Adxl345TypeIntEnableActivity INTEnableActivity {
    Adxl345TypeIntEnableActivity get ();
    void set (Adxl345TypeIntEnableActivity value);
}
member INTEnableActivity : Adxl345TypeIntEnableActivity with get, set

Property Value

Type: Adxl345TypeIntEnableActivity
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTEnableDataReady Property

IRD

Adxl345INTEnableDataReady Property

INT Enable (Data Ready)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntEnableDataReady INTEnableDataReady { get; set; }
Public Property INTEnableDataReady As Adxl345TypeIntEnableDataReady
    Get
    Set
public:
property Adxl345TypeIntEnableDataReady INTEnableDataReady {
    Adxl345TypeIntEnableDataReady get ();
    void set (Adxl345TypeIntEnableDataReady value);
}
member INTEnableDataReady : Adxl345TypeIntEnableDataReady with get, set

Property Value

Type: Adxl345TypeIntEnableDataReady
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTEnableDoubleTap Property

IRD

Adxl345INTEnableDoubleTap Property

INT Enable (Double Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntEnableDoubleTap INTEnableDoubleTap { get; set; }
Public Property INTEnableDoubleTap As Adxl345TypeIntEnableDoubleTap
    Get
    Set
public:
property Adxl345TypeIntEnableDoubleTap INTEnableDoubleTap {
    Adxl345TypeIntEnableDoubleTap get ();
    void set (Adxl345TypeIntEnableDoubleTap value);
}
member INTEnableDoubleTap : Adxl345TypeIntEnableDoubleTap with get, set

Property Value

Type: Adxl345TypeIntEnableDoubleTap
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTEnableFreeFall Property

IRD

Adxl345INTEnableFreeFall Property

INT Enable (Free Fall)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntEnableFreeFall INTEnableFreeFall { get; set; }
Public Property INTEnableFreeFall As Adxl345TypeIntEnableFreeFall
    Get
    Set
public:
property Adxl345TypeIntEnableFreeFall INTEnableFreeFall {
    Adxl345TypeIntEnableFreeFall get ();
    void set (Adxl345TypeIntEnableFreeFall value);
}
member INTEnableFreeFall : Adxl345TypeIntEnableFreeFall with get, set

Property Value

Type: Adxl345TypeIntEnableFreeFall
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTEnableInactivity Property

IRD

Adxl345INTEnableInactivity Property

INT Enable (Inactivity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntEnableInactivity INTEnableInactivity { get; set; }
Public Property INTEnableInactivity As Adxl345TypeIntEnableInactivity
    Get
    Set
public:
property Adxl345TypeIntEnableInactivity INTEnableInactivity {
    Adxl345TypeIntEnableInactivity get ();
    void set (Adxl345TypeIntEnableInactivity value);
}
member INTEnableInactivity : Adxl345TypeIntEnableInactivity with get, set

Property Value

Type: Adxl345TypeIntEnableInactivity
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTEnableOverrun Property

IRD

Adxl345INTEnableOverrun Property

INT Enable (Overrun)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntEnableOverrun INTEnableOverrun { get; set; }
Public Property INTEnableOverrun As Adxl345TypeIntEnableOverrun
    Get
    Set
public:
property Adxl345TypeIntEnableOverrun INTEnableOverrun {
    Adxl345TypeIntEnableOverrun get ();
    void set (Adxl345TypeIntEnableOverrun value);
}
member INTEnableOverrun : Adxl345TypeIntEnableOverrun with get, set

Property Value

Type: Adxl345TypeIntEnableOverrun
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTEnableSingleTap Property

IRD

Adxl345INTEnableSingleTap Property

INT Enable (Single Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntEnableSingleTap INTEnableSingleTap { get; set; }
Public Property INTEnableSingleTap As Adxl345TypeIntEnableSingleTap
    Get
    Set
public:
property Adxl345TypeIntEnableSingleTap INTEnableSingleTap {
    Adxl345TypeIntEnableSingleTap get ();
    void set (Adxl345TypeIntEnableSingleTap value);
}
member INTEnableSingleTap : Adxl345TypeIntEnableSingleTap with get, set

Property Value

Type: Adxl345TypeIntEnableSingleTap
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTEnableWatermark Property

IRD

Adxl345INTEnableWatermark Property

INT Enable (Watermark)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntEnableWatermark INTEnableWatermark { get; set; }
Public Property INTEnableWatermark As Adxl345TypeIntEnableWatermark
    Get
    Set
public:
property Adxl345TypeIntEnableWatermark INTEnableWatermark {
    Adxl345TypeIntEnableWatermark get ();
    void set (Adxl345TypeIntEnableWatermark value);
}
member INTEnableWatermark : Adxl345TypeIntEnableWatermark with get, set

Property Value

Type: Adxl345TypeIntEnableWatermark
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTMapActivity Property

IRD

Adxl345INTMapActivity Property

INT Map (Activity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntMapActivity INTMapActivity { get; set; }
Public Property INTMapActivity As Adxl345TypeIntMapActivity
    Get
    Set
public:
property Adxl345TypeIntMapActivity INTMapActivity {
    Adxl345TypeIntMapActivity get ();
    void set (Adxl345TypeIntMapActivity value);
}
member INTMapActivity : Adxl345TypeIntMapActivity with get, set

Property Value

Type: Adxl345TypeIntMapActivity
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTMapDataReady Property

IRD

Adxl345INTMapDataReady Property

INT Map (Data Ready)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntMapDataReady INTMapDataReady { get; set; }
Public Property INTMapDataReady As Adxl345TypeIntMapDataReady
    Get
    Set
public:
property Adxl345TypeIntMapDataReady INTMapDataReady {
    Adxl345TypeIntMapDataReady get ();
    void set (Adxl345TypeIntMapDataReady value);
}
member INTMapDataReady : Adxl345TypeIntMapDataReady with get, set

Property Value

Type: Adxl345TypeIntMapDataReady
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTMapDoubleTap Property

IRD

Adxl345INTMapDoubleTap Property

INT Map (Double Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntMapDoubleTap INTMapDoubleTap { get; set; }
Public Property INTMapDoubleTap As Adxl345TypeIntMapDoubleTap
    Get
    Set
public:
property Adxl345TypeIntMapDoubleTap INTMapDoubleTap {
    Adxl345TypeIntMapDoubleTap get ();
    void set (Adxl345TypeIntMapDoubleTap value);
}
member INTMapDoubleTap : Adxl345TypeIntMapDoubleTap with get, set

Property Value

Type: Adxl345TypeIntMapDoubleTap
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTMapFreeFall Property

IRD

Adxl345INTMapFreeFall Property

INT Map (Free Fall)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntMapFreeFall INTMapFreeFall { get; set; }
Public Property INTMapFreeFall As Adxl345TypeIntMapFreeFall
    Get
    Set
public:
property Adxl345TypeIntMapFreeFall INTMapFreeFall {
    Adxl345TypeIntMapFreeFall get ();
    void set (Adxl345TypeIntMapFreeFall value);
}
member INTMapFreeFall : Adxl345TypeIntMapFreeFall with get, set

Property Value

Type: Adxl345TypeIntMapFreeFall
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTMapInactivity Property

IRD

Adxl345INTMapInactivity Property

INT Map (Inactivity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntMapInactivity INTMapInactivity { get; set; }
Public Property INTMapInactivity As Adxl345TypeIntMapInactivity
    Get
    Set
public:
property Adxl345TypeIntMapInactivity INTMapInactivity {
    Adxl345TypeIntMapInactivity get ();
    void set (Adxl345TypeIntMapInactivity value);
}
member INTMapInactivity : Adxl345TypeIntMapInactivity with get, set

Property Value

Type: Adxl345TypeIntMapInactivity
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTMapOverrun Property

IRD

Adxl345INTMapOverrun Property

INT Map (Overrun)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntMapOverrun INTMapOverrun { get; set; }
Public Property INTMapOverrun As Adxl345TypeIntMapOverrun
    Get
    Set
public:
property Adxl345TypeIntMapOverrun INTMapOverrun {
    Adxl345TypeIntMapOverrun get ();
    void set (Adxl345TypeIntMapOverrun value);
}
member INTMapOverrun : Adxl345TypeIntMapOverrun with get, set

Property Value

Type: Adxl345TypeIntMapOverrun
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTMapSingleTap Property

IRD

Adxl345INTMapSingleTap Property

INT Map (Single Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntMapSingleTap INTMapSingleTap { get; set; }
Public Property INTMapSingleTap As Adxl345TypeIntMapSingleTap
    Get
    Set
public:
property Adxl345TypeIntMapSingleTap INTMapSingleTap {
    Adxl345TypeIntMapSingleTap get ();
    void set (Adxl345TypeIntMapSingleTap value);
}
member INTMapSingleTap : Adxl345TypeIntMapSingleTap with get, set

Property Value

Type: Adxl345TypeIntMapSingleTap
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTMapWatermark Property

IRD

Adxl345INTMapWatermark Property

INT Map (Watermark)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntMapWatermark INTMapWatermark { get; set; }
Public Property INTMapWatermark As Adxl345TypeIntMapWatermark
    Get
    Set
public:
property Adxl345TypeIntMapWatermark INTMapWatermark {
    Adxl345TypeIntMapWatermark get ();
    void set (Adxl345TypeIntMapWatermark value);
}
member INTMapWatermark : Adxl345TypeIntMapWatermark with get, set

Property Value

Type: Adxl345TypeIntMapWatermark
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTSourceActivity Property

IRD

Adxl345INTSourceActivity Property

INT Source (Activity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntSourceActivity INTSourceActivity { get; }
Public ReadOnly Property INTSourceActivity As Adxl345TypeIntSourceActivity
    Get
public:
property Adxl345TypeIntSourceActivity INTSourceActivity {
    Adxl345TypeIntSourceActivity get ();
}
member INTSourceActivity : Adxl345TypeIntSourceActivity with get

Property Value

Type: Adxl345TypeIntSourceActivity
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTSourceDataReady Property

IRD

Adxl345INTSourceDataReady Property

INT Source (Data Ready)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntSourceDataReady INTSourceDataReady { get; }
Public ReadOnly Property INTSourceDataReady As Adxl345TypeIntSourceDataReady
    Get
public:
property Adxl345TypeIntSourceDataReady INTSourceDataReady {
    Adxl345TypeIntSourceDataReady get ();
}
member INTSourceDataReady : Adxl345TypeIntSourceDataReady with get

Property Value

Type: Adxl345TypeIntSourceDataReady
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTSourceDoubleTap Property

IRD

Adxl345INTSourceDoubleTap Property

INT Source (Double Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntSourceDoubleTap INTSourceDoubleTap { get; }
Public ReadOnly Property INTSourceDoubleTap As Adxl345TypeIntSourceDoubleTap
    Get
public:
property Adxl345TypeIntSourceDoubleTap INTSourceDoubleTap {
    Adxl345TypeIntSourceDoubleTap get ();
}
member INTSourceDoubleTap : Adxl345TypeIntSourceDoubleTap with get

Property Value

Type: Adxl345TypeIntSourceDoubleTap
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTSourceFreeFall Property

IRD

Adxl345INTSourceFreeFall Property

INT Source (Free Fall)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntSourceFreeFall INTSourceFreeFall { get; }
Public ReadOnly Property INTSourceFreeFall As Adxl345TypeIntSourceFreeFall
    Get
public:
property Adxl345TypeIntSourceFreeFall INTSourceFreeFall {
    Adxl345TypeIntSourceFreeFall get ();
}
member INTSourceFreeFall : Adxl345TypeIntSourceFreeFall with get

Property Value

Type: Adxl345TypeIntSourceFreeFall
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTSourceInactivity Property

IRD

Adxl345INTSourceInactivity Property

INT Source (Inactivity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntSourceInactivity INTSourceInactivity { get; }
Public ReadOnly Property INTSourceInactivity As Adxl345TypeIntSourceInactivity
    Get
public:
property Adxl345TypeIntSourceInactivity INTSourceInactivity {
    Adxl345TypeIntSourceInactivity get ();
}
member INTSourceInactivity : Adxl345TypeIntSourceInactivity with get

Property Value

Type: Adxl345TypeIntSourceInactivity
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTSourceOverrun Property

IRD

Adxl345INTSourceOverrun Property

INT Source (Overrun)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntSourceOverrun INTSourceOverrun { get; }
Public ReadOnly Property INTSourceOverrun As Adxl345TypeIntSourceOverrun
    Get
public:
property Adxl345TypeIntSourceOverrun INTSourceOverrun {
    Adxl345TypeIntSourceOverrun get ();
}
member INTSourceOverrun : Adxl345TypeIntSourceOverrun with get

Property Value

Type: Adxl345TypeIntSourceOverrun
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTSourceSingleTap Property

IRD

Adxl345INTSourceSingleTap Property

INT Source (Single Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntSourceSingleTap INTSourceSingleTap { get; }
Public ReadOnly Property INTSourceSingleTap As Adxl345TypeIntSourceSingleTap
    Get
public:
property Adxl345TypeIntSourceSingleTap INTSourceSingleTap {
    Adxl345TypeIntSourceSingleTap get ();
}
member INTSourceSingleTap : Adxl345TypeIntSourceSingleTap with get

Property Value

Type: Adxl345TypeIntSourceSingleTap
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.INTSourceWatermark Property

IRD

Adxl345INTSourceWatermark Property

INT Source (Watermark)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeIntSourceWatermark INTSourceWatermark { get; }
Public ReadOnly Property INTSourceWatermark As Adxl345TypeIntSourceWatermark
    Get
public:
property Adxl345TypeIntSourceWatermark INTSourceWatermark {
    Adxl345TypeIntSourceWatermark get ();
}
member INTSourceWatermark : Adxl345TypeIntSourceWatermark with get

Property Value

Type: Adxl345TypeIntSourceWatermark
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.Latent Property

IRD

Adxl345Latent Property

Latent (unit: ms)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Latent { get; set; }
Public Property Latent As Double
    Get
    Set
public:
property double Latent {
    double get ();
    void set (double value);
}
member Latent : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.OFSX Property

IRD

Adxl345OFSX Property

OFSX (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double OFSX { get; set; }
Public Property OFSX As Double
    Get
    Set
public:
property double OFSX {
    double get ();
    void set (double value);
}
member OFSX : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.OFSY Property

IRD

Adxl345OFSY Property

OFSY (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double OFSY { get; set; }
Public Property OFSY As Double
    Get
    Set
public:
property double OFSY {
    double get ();
    void set (double value);
}
member OFSY : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.OFSZ Property

IRD

Adxl345OFSZ Property

OFSZ (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double OFSZ { get; set; }
Public Property OFSZ As Double
    Get
    Set
public:
property double OFSZ {
    double get ();
    void set (double value);
}
member OFSZ : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.PowerCTLAutoSleep Property

IRD

Adxl345PowerCTLAutoSleep Property

Power CTL (Auto Sleep)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypePowerCtlAutoSleep PowerCTLAutoSleep { get; set; }
Public Property PowerCTLAutoSleep As Adxl345TypePowerCtlAutoSleep
    Get
    Set
public:
property Adxl345TypePowerCtlAutoSleep PowerCTLAutoSleep {
    Adxl345TypePowerCtlAutoSleep get ();
    void set (Adxl345TypePowerCtlAutoSleep value);
}
member PowerCTLAutoSleep : Adxl345TypePowerCtlAutoSleep with get, set

Property Value

Type: Adxl345TypePowerCtlAutoSleep
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.PowerCTLLink Property

IRD

Adxl345PowerCTLLink Property

Power CTL (Link)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypePowerCtlLink PowerCTLLink { get; set; }
Public Property PowerCTLLink As Adxl345TypePowerCtlLink
    Get
    Set
public:
property Adxl345TypePowerCtlLink PowerCTLLink {
    Adxl345TypePowerCtlLink get ();
    void set (Adxl345TypePowerCtlLink value);
}
member PowerCTLLink : Adxl345TypePowerCtlLink with get, set

Property Value

Type: Adxl345TypePowerCtlLink
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.PowerCTLMeasure Property

IRD

Adxl345PowerCTLMeasure Property

Power CTL (Measure)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypePowerCtlMeasure PowerCTLMeasure { get; set; }
Public Property PowerCTLMeasure As Adxl345TypePowerCtlMeasure
    Get
    Set
public:
property Adxl345TypePowerCtlMeasure PowerCTLMeasure {
    Adxl345TypePowerCtlMeasure get ();
    void set (Adxl345TypePowerCtlMeasure value);
}
member PowerCTLMeasure : Adxl345TypePowerCtlMeasure with get, set

Property Value

Type: Adxl345TypePowerCtlMeasure
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.PowerCTLSleep Property

IRD

Adxl345PowerCTLSleep Property

Power CTL (Sleep)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypePowerCtlSleep PowerCTLSleep { get; set; }
Public Property PowerCTLSleep As Adxl345TypePowerCtlSleep
    Get
    Set
public:
property Adxl345TypePowerCtlSleep PowerCTLSleep {
    Adxl345TypePowerCtlSleep get ();
    void set (Adxl345TypePowerCtlSleep value);
}
member PowerCTLSleep : Adxl345TypePowerCtlSleep with get, set

Property Value

Type: Adxl345TypePowerCtlSleep
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.PowerCTLWakeUp Property

IRD

Adxl345PowerCTLWakeUp Property

Power CTL (Wake Up)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypePowerCtlWakeup PowerCTLWakeUp { get; set; }
Public Property PowerCTLWakeUp As Adxl345TypePowerCtlWakeup
    Get
    Set
public:
property Adxl345TypePowerCtlWakeup PowerCTLWakeUp {
    Adxl345TypePowerCtlWakeup get ();
    void set (Adxl345TypePowerCtlWakeup value);
}
member PowerCTLWakeUp : Adxl345TypePowerCtlWakeup with get, set

Property Value

Type: Adxl345TypePowerCtlWakeup
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.TapAxesSuppress Property

IRD

Adxl345TapAxesSuppress Property

Tap Axes (Suppress)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeTapAxesSuppress TapAxesSuppress { get; set; }
Public Property TapAxesSuppress As Adxl345TypeTapAxesSuppress
    Get
    Set
public:
property Adxl345TypeTapAxesSuppress TapAxesSuppress {
    Adxl345TypeTapAxesSuppress get ();
    void set (Adxl345TypeTapAxesSuppress value);
}
member TapAxesSuppress : Adxl345TypeTapAxesSuppress with get, set

Property Value

Type: Adxl345TypeTapAxesSuppress
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.TapAxesTAPXEN Property

IRD

Adxl345TapAxesTAPXEN Property

Tap Axes (TAP X EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeTapAxesTapXEn TapAxesTAPXEN { get; set; }
Public Property TapAxesTAPXEN As Adxl345TypeTapAxesTapXEn
    Get
    Set
public:
property Adxl345TypeTapAxesTapXEn TapAxesTAPXEN {
    Adxl345TypeTapAxesTapXEn get ();
    void set (Adxl345TypeTapAxesTapXEn value);
}
member TapAxesTAPXEN : Adxl345TypeTapAxesTapXEn with get, set

Property Value

Type: Adxl345TypeTapAxesTapXEn
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.TapAxesTAPYEN Property

IRD

Adxl345TapAxesTAPYEN Property

Tap Axes (TAP Y EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeTapAxesTapYEn TapAxesTAPYEN { get; set; }
Public Property TapAxesTAPYEN As Adxl345TypeTapAxesTapYEn
    Get
    Set
public:
property Adxl345TypeTapAxesTapYEn TapAxesTAPYEN {
    Adxl345TypeTapAxesTapYEn get ();
    void set (Adxl345TypeTapAxesTapYEn value);
}
member TapAxesTAPYEN : Adxl345TypeTapAxesTapYEn with get, set

Property Value

Type: Adxl345TypeTapAxesTapYEn
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.TapAxesTAPZEN Property

IRD

Adxl345TapAxesTAPZEN Property

Tap Axes (TAP Z EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl345TypeTapAxesTapZEn TapAxesTAPZEN { get; set; }
Public Property TapAxesTAPZEN As Adxl345TypeTapAxesTapZEn
    Get
    Set
public:
property Adxl345TypeTapAxesTapZEn TapAxesTAPZEN {
    Adxl345TypeTapAxesTapZEn get ();
    void set (Adxl345TypeTapAxesTapZEn value);
}
member TapAxesTAPZEN : Adxl345TypeTapAxesTapZEn with get, set

Property Value

Type: Adxl345TypeTapAxesTapZEn
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ThreshAct Property

IRD

Adxl345ThreshAct Property

Thresh Act (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ThreshAct { get; set; }
Public Property ThreshAct As Double
    Get
    Set
public:
property double ThreshAct {
    double get ();
    void set (double value);
}
member ThreshAct : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ThreshFF Property

IRD

Adxl345ThreshFF Property

Thresh FF (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ThreshFF { get; set; }
Public Property ThreshFF As Byte
    Get
    Set
public:
property unsigned char ThreshFF {
    unsigned char get ();
    void set (unsigned char value);
}
member ThreshFF : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ThreshInact Property

IRD

Adxl345ThreshInact Property

Thresh Inact (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ThreshInact { get; set; }
Public Property ThreshInact As Double
    Get
    Set
public:
property double ThreshInact {
    double get ();
    void set (double value);
}
member ThreshInact : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.ThreshTap Property

IRD

Adxl345ThreshTap Property

Thresh Tap (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ThreshTap { get; set; }
Public Property ThreshTap As Double
    Get
    Set
public:
property double ThreshTap {
    double get ();
    void set (double value);
}
member ThreshTap : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.TimeFF Property

IRD

Adxl345TimeFF Property

Time FF (unit: ms)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TimeFF { get; set; }
Public Property TimeFF As Double
    Get
    Set
public:
property double TimeFF {
    double get ();
    void set (double value);
}
member TimeFF : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.TimeInact Property

IRD

Adxl345TimeInact Property

Time Inact (unit: s)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TimeInact { get; set; }
Public Property TimeInact As Byte
    Get
    Set
public:
property unsigned char TimeInact {
    unsigned char get ();
    void set (unsigned char value);
}
member TimeInact : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.Window Property

IRD

Adxl345Window Property

Window (unit: ms)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Window { get; set; }
Public Property Window As Double
    Get
    Set
public:
property double Window {
    double get ();
    void set (double value);
}
member Window : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345 Methods

The Adxl345 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.Flush Method

IRD

Adxl345Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adxl345 Class
telos.Ird.AnalogDevices Namespace


Adxl345.TypeActInactCtlActAcDc Enumeration

IRD

Adxl345TypeActInactCtlActAcDc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlActAcDc
Public Enumeration TypeActInactCtlActAcDc
public enum class TypeActInactCtlActAcDc
type TypeActInactCtlActAcDc
Members
Member name | Value | Description
DetectActivityOfDCCoupledOperation | 0 | Detect activity of DC coupled operation
DetectActivityOfACCoupledOperation | 1 | Detect activity of AC coupled operation
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeActInactCtlActX Enumeration

IRD

Adxl345TypeActInactCtlActX Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlActX
Public Enumeration TypeActInactCtlActX
public enum class TypeActInactCtlActX
type TypeActInactCtlActX
Members
Member name | Value | Description
DisableXAxisActivityDetection | 0 | Disable x-axis activity detection
EnableXAxisActivityDetection | 1 | Enable x-axis activity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeActInactCtlActY Enumeration

IRD

Adxl345TypeActInactCtlActY Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlActY
Public Enumeration TypeActInactCtlActY
public enum class TypeActInactCtlActY
type TypeActInactCtlActY
Members
Member name | Value | Description
DisableYAxisActivityDetection | 0 | Disable y-axis activity detection
EnableYAxisActivityDetection | 1 | Enable y-axis activity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeActInactCtlActZ Enumeration

IRD

Adxl345TypeActInactCtlActZ Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlActZ
Public Enumeration TypeActInactCtlActZ
public enum class TypeActInactCtlActZ
type TypeActInactCtlActZ
Members
Member name | Value | Description
DisableZAxisActivityDetection | 0 | Disable z-axis activity detection
EnableZAxisActivityDetection | 1 | Enable z-axis activity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeActInactCtlInactAcDc Enumeration

IRD

Adxl345TypeActInactCtlInactAcDc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlInactAcDc
Public Enumeration TypeActInactCtlInactAcDc
public enum class TypeActInactCtlInactAcDc
type TypeActInactCtlInactAcDc
Members
Member name | Value | Description
DetectInactivityOfDCCoupledOperation | 0 | Detect inactivity of DC coupled operation
DetectInactivityOfACCoupledOperation | 1 | Detect inactivity of AC coupled operation
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeActInactCtlInactX Enumeration

IRD

Adxl345TypeActInactCtlInactX Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlInactX
Public Enumeration TypeActInactCtlInactX
public enum class TypeActInactCtlInactX
type TypeActInactCtlInactX
Members
Member name | Value | Description
DisableXAxisInactivityDetection | 0 | Disable x-axis inactivity detection
EnableXAxisInactivityDetection | 1 | Enable x-axis inactivity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeActInactCtlInactY Enumeration

IRD

Adxl345TypeActInactCtlInactY Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlInactY
Public Enumeration TypeActInactCtlInactY
public enum class TypeActInactCtlInactY
type TypeActInactCtlInactY
Members
Member name | Value | Description
DisableYAxisInactivityDetection | 0 | Disable y-axis inactivity detection
EnableYAxisInactivityDetection | 1 | Enable y-axis inactivity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeActInactCtlInactZ Enumeration

IRD

Adxl345TypeActInactCtlInactZ Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlInactZ
Public Enumeration TypeActInactCtlInactZ
public enum class TypeActInactCtlInactZ
type TypeActInactCtlInactZ
Members
Member name | Value | Description
DisableZAxisInactivityDetection | 0 | Disable z-axis inactivity detection
EnableZAxisInactivityDetection | 1 | Enable z-axis inactivity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeActTapStatusActXSrc Enumeration

IRD

Adxl345TypeActTapStatusActXSrc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusActXSrc
Public Enumeration TypeActTapStatusActXSrc
public enum class TypeActTapStatusActXSrc
type TypeActTapStatusActXSrc
Members
Member name | Value | Description
NoInvolvementInActivityEventInXAxis | 0 | No involvement in activity event in x-axis
InvolvementInActivityEventInXAxis | 1 | Involvement in activity event in x-axis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeActTapStatusActYSrc Enumeration

IRD

Adxl345TypeActTapStatusActYSrc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusActYSrc
Public Enumeration TypeActTapStatusActYSrc
public enum class TypeActTapStatusActYSrc
type TypeActTapStatusActYSrc
Members
Member name | Value | Description
NoInvolvementInActivityEventInYAxis | 0 | No involvement in activity event in y-axis
InvolvementInActivityEventInYAxis | 1 | Involvement in activity event in y-axis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeActTapStatusActZSrc Enumeration

IRD

Adxl345TypeActTapStatusActZSrc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusActZSrc
Public Enumeration TypeActTapStatusActZSrc
public enum class TypeActTapStatusActZSrc
type TypeActTapStatusActZSrc
Members
Member name | Value | Description
NoInvolvementInActivityEventInZAxis | 0 | No involvement in activity event in z-axis
InvolvementInActivityEventInZAxis | 1 | Involvement in activity event in z-axis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeActTapStatusAsleep Enumeration

IRD

Adxl345TypeActTapStatusAsleep Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusAsleep
Public Enumeration TypeActTapStatusAsleep
public enum class TypeActTapStatusAsleep
type TypeActTapStatusAsleep
Members
Member name | Value | Description
ThePartIsNotAsleep | 0 | The part is not asleep
ThePartIsAsleep | 1 | The part is asleep
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeActTapStatusTapXSrc Enumeration

IRD

Adxl345TypeActTapStatusTapXSrc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusTapXSrc
Public Enumeration TypeActTapStatusTapXSrc
public enum class TypeActTapStatusTapXSrc
type TypeActTapStatusTapXSrc
Members
Member name | Value | Description
NoInvolvementInTapEventInXAxis | 0 | No involvement in tap event in x-axis
InvolvementInTapEventInXAxis | 1 | Involvement in tap event in x-axis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeActTapStatusTapYSrc Enumeration

IRD

Adxl345TypeActTapStatusTapYSrc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusTapYSrc
Public Enumeration TypeActTapStatusTapYSrc
public enum class TypeActTapStatusTapYSrc
type TypeActTapStatusTapYSrc
Members
Member name | Value | Description
NoInvolvementInTapEventInYAxis | 0 | No involvement in tap event in y-axis
InvolvementInTapEventInYAxis | 1 | Involvement in tap event in y-axis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeActTapStatusTapZSrc Enumeration

IRD

Adxl345TypeActTapStatusTapZSrc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusTapZSrc
Public Enumeration TypeActTapStatusTapZSrc
public enum class TypeActTapStatusTapZSrc
type TypeActTapStatusTapZSrc
Members
Member name | Value | Description
NoInvolvementInTapEventInZAxis | 0 | No involvement in tap event in z-axis
InvolvementInTapEventInZAxis | 1 | Involvement in tap event in z-axis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeBwRateLowPower Enumeration

IRD

Adxl345TypeBwRateLowPower Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBwRateLowPower
Public Enumeration TypeBwRateLowPower
public enum class TypeBwRateLowPower
type TypeBwRateLowPower
Members
Member name | Value | Description
NormalOperation | 0 | Normal operation
ReducedPowerOperation | 1 | Reduced power operation
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeBwRateRateBits Enumeration

IRD

Adxl345TypeBwRateRateBits Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBwRateRateBits
Public Enumeration TypeBwRateRateBits
public enum class TypeBwRateRateBits
type TypeBwRateRateBits
Members
Member name | Value | Description
Value_0_10 | 0 | 0.10
Value_0_20 | 1 | 0.20
Value_0_39 | 2 | 0.39
Value_0_78 | 3 | 0.78
Value_1_56 | 4 | 1.56
Value_3_13 | 5 | 3.13
Value_6_25 | 6 | 6.25
Value_12_5 | 7 | 12.5
Value_25 | 8 | 25
Value_50 | 9 | 50
Value_100 | 10 | 100
Value_200 | 11 | 200
Value_400 | 12 | 400
Value_800 | 13 | 800
Value_1600 | 14 | 1600
Value_3200 | 15 | 3200
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeDataFormatFullRes Enumeration

IRD

Adxl345TypeDataFormatFullRes Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatFullRes
Public Enumeration TypeDataFormatFullRes
public enum class TypeDataFormatFullRes
type TypeDataFormatFullRes
Members
Member name | Value | Description
Value_10BitMode | 0 | 10 bit mode
FullResolution | 1 | Full resolution
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeDataFormatIntInvert Enumeration

IRD

Adxl345TypeDataFormatIntInvert Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatIntInvert
Public Enumeration TypeDataFormatIntInvert
public enum class TypeDataFormatIntInvert
type TypeDataFormatIntInvert
Members
Member name | Value | Description
SetInterruptsToActiveHigh | 0 | Set interrupts to active high
SetInterruptsToActiveLow | 1 | Set interrupts to active low
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeDataFormatJustify Enumeration

IRD

Adxl345TypeDataFormatJustify Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatJustify
Public Enumeration TypeDataFormatJustify
public enum class TypeDataFormatJustify
type TypeDataFormatJustify
Members
Member name | Value | Description
RightJustifiedModeWithSignExtension | 0 | Right justified mode with sign extension
LeftMSBJustifiedMode | 1 | Left (MSB) justified mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeDataFormatRange Enumeration

IRD

Adxl345TypeDataFormatRange Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatRange
Public Enumeration TypeDataFormatRange
public enum class TypeDataFormatRange
type TypeDataFormatRange
Members
Member name | Value | Description
Value_2g | 0 | +/- 2g
Value_4g | 1 | +/- 4g
Value_8g | 2 | +/- 8g
Value_16g | 3 | +/- 16g
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeDataFormatSelfTest Enumeration

IRD

Adxl345TypeDataFormatSelfTest Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatSelfTest
Public Enumeration TypeDataFormatSelfTest
public enum class TypeDataFormatSelfTest
type TypeDataFormatSelfTest
Members
Member name | Value | Description
DisableTheSelfTestForce | 0 | Disable the self-test force
EnablesTheSelfTestForce | 1 | Enables the self-test force
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeDataFormatSpi Enumeration

IRD

Adxl345TypeDataFormatSpi Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatSpi
Public Enumeration TypeDataFormatSpi
public enum class TypeDataFormatSpi
type TypeDataFormatSpi
Members
Member name | Value | Description
Value_4WireSPI | 0 | 4-wire SPI
Value_3WireSPI | 1 | 3-wire SPI
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeFifoCtlFifoMode Enumeration

IRD

Adxl345TypeFifoCtlFifoMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFifoCtlFifoMode
Public Enumeration TypeFifoCtlFifoMode
public enum class TypeFifoCtlFifoMode
type TypeFifoCtlFifoMode
Members
Member name | Value | Description
BypassFIFOBypassed | 0 | Bypass: FIFO bypassed
FIFOCollectUpTo32ValuesInFIFO | 1 | FIFO: Collect up to 32 values in FIFO
StreamFIFOHoldsTheLast32DataValues | 2 | Stream: FIFO holds the last 32 data values
TriggerFIFOHoldsTheLastDataSamplesBeforeTheTriggerEvent | 3 | Trigger: FIFO holds the last data samples before the trigger event
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeFifoCtlTrigger Enumeration

IRD

Adxl345TypeFifoCtlTrigger Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFifoCtlTrigger
Public Enumeration TypeFifoCtlTrigger
public enum class TypeFifoCtlTrigger
type TypeFifoCtlTrigger
Members
Member name | Value | Description
SetsTheTriggerEventOfTriggerModeToBeLinkedToINT1 | 0 | sets the trigger event of trigger mode to be linked to INT1
SetsTheTriggerEventOfTriggerModeToBeLinkedToINT2 | 1 | sets the trigger event of trigger mode to be linked to INT2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeFifoStatusFifoTrig Enumeration

IRD

Adxl345TypeFifoStatusFifoTrig Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFifoStatusFifoTrig
Public Enumeration TypeFifoStatusFifoTrig
public enum class TypeFifoStatusFifoTrig
type TypeFifoStatusFifoTrig
Members
Member name | Value | Description
FIFOTriggerEventHasNotOccurred | 0 | FIFO trigger event has not occurred
FIFOTriggerEventOccurring | 1 | FIFO trigger event occurring
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntEnableActivity Enumeration

IRD

Adxl345TypeIntEnableActivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableActivity
Public Enumeration TypeIntEnableActivity
public enum class TypeIntEnableActivity
type TypeIntEnableActivity
Members
Member name | Value | Description
DisableActivityFunctionInterrupts | 0 | Disable activity function interrupts
EnableActivityFunctionInterrupts | 1 | Enable activity function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntEnableDataReady Enumeration

IRD

Adxl345TypeIntEnableDataReady Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableDataReady
Public Enumeration TypeIntEnableDataReady
public enum class TypeIntEnableDataReady
type TypeIntEnableDataReady
Members
Member name | Value | Description
DisableDataReadyFunctionInterrupts | 0 | Disable data_ready function interrupts
EnableDataReadyFunctionInterrupts | 1 | Enable data_ready function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntEnableDoubleTap Enumeration

IRD

Adxl345TypeIntEnableDoubleTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableDoubleTap
Public Enumeration TypeIntEnableDoubleTap
public enum class TypeIntEnableDoubleTap
type TypeIntEnableDoubleTap
Members
Member name | Value | Description
DisableDoubleTapFunctionInterrupts | 0 | Disable double_tap function interrupts
EnableDoubleTapFunctionInterrupts | 1 | Enable double_tap function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntEnableFreeFall Enumeration

IRD

Adxl345TypeIntEnableFreeFall Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableFreeFall
Public Enumeration TypeIntEnableFreeFall
public enum class TypeIntEnableFreeFall
type TypeIntEnableFreeFall
Members
Member name | Value | Description
DisableFreeFallFunctionInterrupts | 0 | Disable free_fall function interrupts
EnableFreeFallFunctionInterrupts | 1 | Enable free_fall function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntEnableInactivity Enumeration

IRD

Adxl345TypeIntEnableInactivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableInactivity
Public Enumeration TypeIntEnableInactivity
public enum class TypeIntEnableInactivity
type TypeIntEnableInactivity
Members
Member name | Value | Description
DisableInactivityFunctionInterrupts | 0 | Disable inactivity function interrupts
EnableInactivityFunctionInterrupts | 1 | Enable inactivity function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntEnableOverrun Enumeration

IRD

Adxl345TypeIntEnableOverrun Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableOverrun
Public Enumeration TypeIntEnableOverrun
public enum class TypeIntEnableOverrun
type TypeIntEnableOverrun
Members
Member name | Value | Description
DisableOverrunFunctionInterrupts | 0 | Disable overrun function interrupts
EnableOverrunFunctionInterrupts | 1 | Enable overrun function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntEnableSingleTap Enumeration

IRD

Adxl345TypeIntEnableSingleTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableSingleTap
Public Enumeration TypeIntEnableSingleTap
public enum class TypeIntEnableSingleTap
type TypeIntEnableSingleTap
Members
Member name | Value | Description
DisableSingleTapFunctionInterrupts | 0 | Disable single_tap function interrupts
EnableSingleTapFunctionInterrupts | 1 | Enable single_tap function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntEnableWatermark Enumeration

IRD

Adxl345TypeIntEnableWatermark Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableWatermark
Public Enumeration TypeIntEnableWatermark
public enum class TypeIntEnableWatermark
type TypeIntEnableWatermark
Members
Member name | Value | Description
DisableWatermarkFunctionInterrupts | 0 | Disable watermark function interrupts
EnableWatermarkFunctionInterrupts | 1 | Enable watermark function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntMapActivity Enumeration

IRD

Adxl345TypeIntMapActivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapActivity
Public Enumeration TypeIntMapActivity
public enum class TypeIntMapActivity
type TypeIntMapActivity
Members
Member name | Value | Description
SendActivityInterruptToINT1Pin | 0 | Send activity interrupt to INT1 pin
SendActivityInterruptToINT2Pin | 1 | Send activity interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntMapDataReady Enumeration

IRD

Adxl345TypeIntMapDataReady Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapDataReady
Public Enumeration TypeIntMapDataReady
public enum class TypeIntMapDataReady
type TypeIntMapDataReady
Members
Member name | Value | Description
SendDataReadyInterruptToINT1Pin | 0 | Send data_ready interrupt to INT1 pin
SendDataReadyInterruptToINT2Pin | 1 | Send data_ready interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntMapDoubleTap Enumeration

IRD

Adxl345TypeIntMapDoubleTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapDoubleTap
Public Enumeration TypeIntMapDoubleTap
public enum class TypeIntMapDoubleTap
type TypeIntMapDoubleTap
Members
Member name | Value | Description
SendDoubleTapInterruptToINT1Pin | 0 | Send double_tap interrupt to INT1 pin
SendDoubleTapInterruptToINT2Pin | 1 | Send double_tap interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntMapFreeFall Enumeration

IRD

Adxl345TypeIntMapFreeFall Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapFreeFall
Public Enumeration TypeIntMapFreeFall
public enum class TypeIntMapFreeFall
type TypeIntMapFreeFall
Members
Member name | Value | Description
SendFreeFallInterruptToINT1Pin | 0 | Send free_fall interrupt to INT1 pin
SendFreeFallInterruptToINT2Pin | 1 | Send free_fall interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntMapInactivity Enumeration

IRD

Adxl345TypeIntMapInactivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapInactivity
Public Enumeration TypeIntMapInactivity
public enum class TypeIntMapInactivity
type TypeIntMapInactivity
Members
Member name | Value | Description
SendInactivityInterruptToINT1Pin | 0 | Send inactivity interrupt to INT1 pin
SendInactivityInterruptToINT2Pin | 1 | Send inactivity interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntMapOverrun Enumeration

IRD

Adxl345TypeIntMapOverrun Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapOverrun
Public Enumeration TypeIntMapOverrun
public enum class TypeIntMapOverrun
type TypeIntMapOverrun
Members
Member name | Value | Description
SendOverrunInterruptToINT1Pin | 0 | Send overrun interrupt to INT1 pin
SendOverrunInterruptToINT2Pin | 1 | Send overrun interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntMapSingleTap Enumeration

IRD

Adxl345TypeIntMapSingleTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapSingleTap
Public Enumeration TypeIntMapSingleTap
public enum class TypeIntMapSingleTap
type TypeIntMapSingleTap
Members
Member name | Value | Description
SendSingleTapInterruptToINT1Pin | 0 | Send single_tap interrupt to INT1 pin
SendSingleTapInterruptToINT2Pin | 1 | Send single_tap interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntMapWatermark Enumeration

IRD

Adxl345TypeIntMapWatermark Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapWatermark
Public Enumeration TypeIntMapWatermark
public enum class TypeIntMapWatermark
type TypeIntMapWatermark
Members
Member name | Value | Description
SendWatermarkInterruptToINT1Pin | 0 | Send watermark interrupt to INT1 pin
SendWatermarkInterruptToINT2Pin | 1 | Send watermark interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntSourceActivity Enumeration

IRD

Adxl345TypeIntSourceActivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceActivity
Public Enumeration TypeIntSourceActivity
public enum class TypeIntSourceActivity
type TypeIntSourceActivity
Members
Member name | Value | Description
ActivityFunctionEventNotOccurred | 0 | Activity function event not occurred
ActivityFunctionHasTriggered | 1 | Activity function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntSourceDataReady Enumeration

IRD

Adxl345TypeIntSourceDataReady Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceDataReady
Public Enumeration TypeIntSourceDataReady
public enum class TypeIntSourceDataReady
type TypeIntSourceDataReady
Members
Member name | Value | Description
ActivityFunctionEventNotOccurred | 0 | Activity function event not occurred
ActivityFunctionHasTriggered | 1 | Activity function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntSourceDoubleTap Enumeration

IRD

Adxl345TypeIntSourceDoubleTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceDoubleTap
Public Enumeration TypeIntSourceDoubleTap
public enum class TypeIntSourceDoubleTap
type TypeIntSourceDoubleTap
Members
Member name | Value | Description
DataReadyFunctionEventNotOccurred | 0 | Data_ready function event not occurred
DataReadyFunctionHasTriggered | 1 | Data_ready function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntSourceFreeFall Enumeration

IRD

Adxl345TypeIntSourceFreeFall Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceFreeFall
Public Enumeration TypeIntSourceFreeFall
public enum class TypeIntSourceFreeFall
type TypeIntSourceFreeFall
Members
Member name | Value | Description
FreeFallFunctionEventNotOccurred | 0 | Free_fall function event not occurred
FreeFallFunctionHasTriggered | 1 | Free_fall function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntSourceInactivity Enumeration

IRD

Adxl345TypeIntSourceInactivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceInactivity
Public Enumeration TypeIntSourceInactivity
public enum class TypeIntSourceInactivity
type TypeIntSourceInactivity
Members
Member name | Value | Description
InactivityFunctionEventNotOccurred | 0 | Inactivity function event not occurred
InactivityFunctionHasTriggered | 1 | Inactivity function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntSourceOverrun Enumeration

IRD

Adxl345TypeIntSourceOverrun Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceOverrun
Public Enumeration TypeIntSourceOverrun
public enum class TypeIntSourceOverrun
type TypeIntSourceOverrun
Members
Member name | Value | Description
ActivityFunctionEventNotOccurred | 0 | Activity function event not occurred
ActivityFunctionHasTriggered | 1 | Activity function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntSourceSingleTap Enumeration

IRD

Adxl345TypeIntSourceSingleTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceSingleTap
Public Enumeration TypeIntSourceSingleTap
public enum class TypeIntSourceSingleTap
type TypeIntSourceSingleTap
Members
Member name | Value | Description
OverrunFunctionEventNotOccurred | 0 | Overrun function event not occurred
OverrunFunctionHasTriggered | 1 | Overrun function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeIntSourceWatermark Enumeration

IRD

Adxl345TypeIntSourceWatermark Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceWatermark
Public Enumeration TypeIntSourceWatermark
public enum class TypeIntSourceWatermark
type TypeIntSourceWatermark
Members
Member name | Value | Description
WatermarkFunctionEventNotOccurred | 0 | Watermark function event not occurred
WatermarkFunctionHasTriggered | 1 | Watermark function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypePowerCtlAutoSleep Enumeration

IRD

Adxl345TypePowerCtlAutoSleep Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlAutoSleep
Public Enumeration TypePowerCtlAutoSleep
public enum class TypePowerCtlAutoSleep
type TypePowerCtlAutoSleep
Members
Member name | Value | Description
DisableAutomaticSwitchingToSleepMode | 0 | Disable automatic switching to sleep mode
SwitchToSleepModeWhenInactivityIsDetected | 1 | Switch to sleep mode when inactivity is detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypePowerCtlLink Enumeration

IRD

Adxl345TypePowerCtlLink Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlLink
Public Enumeration TypePowerCtlLink
public enum class TypePowerCtlLink
type TypePowerCtlLink
Members
Member name | Value | Description
InactivityAndActivityFunctionsAreConcurrent | 0 | Inactivity and activity functions are concurrent
DelaysTheStartOfTheActivityFunctionUntilInactivityIsDetected | 1 | Delays the start of the activity function until inactivity is detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypePowerCtlMeasure Enumeration

IRD

Adxl345TypePowerCtlMeasure Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlMeasure
Public Enumeration TypePowerCtlMeasure
public enum class TypePowerCtlMeasure
type TypePowerCtlMeasure
Members
Member name | Value | Description
StandbyMode | 0 | Standby mode
MeasurementMode | 1 | Measurement mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypePowerCtlSleep Enumeration

IRD

Adxl345TypePowerCtlSleep Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlSleep
Public Enumeration TypePowerCtlSleep
public enum class TypePowerCtlSleep
type TypePowerCtlSleep
Members
Member name | Value | Description
NormalOperation | 0 | Normal operation
SleepMode | 1 | Sleep mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypePowerCtlWakeup Enumeration

IRD

Adxl345TypePowerCtlWakeup Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlWakeup
Public Enumeration TypePowerCtlWakeup
public enum class TypePowerCtlWakeup
type TypePowerCtlWakeup
Members
Member name | Value | Description
FrequencyReadingInSleepMode8Hz | 0 | Frequency reading in sleep mode: 8 Hz
FrequencyReadingInSleepMode4Hz | 1 | Frequency reading in sleep mode: 4 Hz
FrequencyReadingInSleepMode2Hz | 2 | Frequency reading in sleep mode: 2 Hz
FrequencyReadingInSleepMode1Hz | 3 | Frequency reading in sleep mode: 1 Hz
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeTapAxesSuppress Enumeration

IRD

Adxl345TypeTapAxesSuppress Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapAxesSuppress
Public Enumeration TypeTapAxesSuppress
public enum class TypeTapAxesSuppress
type TypeTapAxesSuppress
Members
Member name | Value | Description
DoubleTapDetectionPossible | 0 | Double tap detection possible
DoubleTapDetectionSuppressed | 1 | Double tap detection suppressed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeTapAxesTapXEn Enumeration

IRD

Adxl345TypeTapAxesTapXEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapAxesTapXEn
Public Enumeration TypeTapAxesTapXEn
public enum class TypeTapAxesTapXEn
type TypeTapAxesTapXEn
Members
Member name | Value | Description
ExcludesXAxisFromParticipation | 0 | Excludes x-axis from participation
EnableXAxisParticipationInTapDetection | 1 | Enable x-axis participation in tap detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeTapAxesTapYEn Enumeration

IRD

Adxl345TypeTapAxesTapYEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapAxesTapYEn
Public Enumeration TypeTapAxesTapYEn
public enum class TypeTapAxesTapYEn
type TypeTapAxesTapYEn
Members
Member name | Value | Description
ExcludesYAxisFromParticipation | 0 | Excludes y-axis from participation
EnableYAxisParticipationInTapDetection | 1 | Enable y-axis participation in tap detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl345.TypeTapAxesTapZEn Enumeration

IRD

Adxl345TypeTapAxesTapZEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapAxesTapZEn
Public Enumeration TypeTapAxesTapZEn
public enum class TypeTapAxesTapZEn
type TypeTapAxesTapZEn
Members
Member name | Value | Description
ExcludesZAxisFromParticipation | 0 | Excludes z-axis from participation
EnableZAxisParticipationInTapDetection | 1 | Enable z-axis participation in tap detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346 Class

Analog Devices: ADXL 346
Inheritance Hierarchy
SystemObject
telos.Ird.AnalogDevicesAdxl346

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Adxl346
Public Class Adxl346
public ref class Adxl346
type Adxl346 =  class end

The Adxl346 type exposes the following members.

Constructors
 | Name | Description
Public method | Adxl346 | Constructor
Top
Properties
 | Name | Description
Public property | ActInactControlACTACDC | Act Inact Control (ACT AC/DC)
Public property | ActInactControlACTXEN | Act Inact Control (ACT X EN)
Public property | ActInactControlACTYEN | Act Inact Control (ACT Y EN)
Public property | ActInactControlACTZEN | Act Inact Control (ACT Z EN)
Public property | ActInactControlINACTACDC | Act Inact Control (INACT AC/DC)
Public property | ActInactControlINACTXEN | Act Inact Control (INACT X EN)
Public property | ActInactControlINACTYEN | Act Inact Control (INACT Y EN)
Public property | ActInactControlINACTZEN | Act Inact Control (INACT Z EN)
Public property | ActTapStatusACTXSRC | Act Tap Status (ACT X SRC)
Public property | ActTapStatusACTYSRC | Act Tap Status (ACT Y SRC)
Public property | ActTapStatusACTZSRC | Act Tap Status (ACT Z SRC)
Public property | ActTapStatusAsleep | Act Tap Status (Asleep)
Public property | ActTapStatusTAPXSRC | Act Tap Status (TAP X SRC)
Public property | ActTapStatusTAPYSRC | Act Tap Status (TAP Y SRC)
Public property | ActTapStatusTAPZSRC | Act Tap Status (TAP Z SRC)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BWRateLowPower | BW Rate (Low Power)
Public property | BWRateRate | BW Rate (Rate)
Public property | DataFormatFullRes | Data Format (Full Res)
Public property | DataFormatIntInvert | Data Format (Int Invert)
Public property | DataFormatJustify | Data Format (Justify)
Public property | DataFormatRange | Data Format (Range)
Public property | DataFormatSelfTest | Data Format (Self Test)
Public property | DataFormatSPI | Data Format (SPI)
Public property | DataX | Data X
Public property | DataY | Data Y
Public property | DataZ | Data Z
Public property | DeviceID | Device ID
Public property | DUR | DUR (unit: μs)
Public property | FIFOCTLFIFOMode | FIFO CTL (FIFO Mode)
Public property | FIFOCTLSamples | FIFO CTL (Samples)
Public property | FIFOCTLTrigger | FIFO CTL (Trigger)
Public property | FIFOStatusEntries | FIFO Status (Entries)
Public property | FIFOStatusFIFOTrig | FIFO Status (FIFO Trig)
Public property | INTEnableActivity | INT Enable (Activity)
Public property | INTEnableDataReady | INT Enable (Data Ready)
Public property | INTEnableDoubleTap | INT Enable (Double Tap)
Public property | INTEnableFreeFall | INT Enable (Free Fall)
Public property | INTEnableInactivity | INT Enable (Inactivity)
Public property | INTEnableOverrun | INT Enable (Overrun)
Public property | INTEnableSingleTap | INT Enable (Single Tap)
Public property | INTEnableWatermark | INT Enable (Watermark)
Public property | INTMapActivity | INT Map (Activity)
Public property | INTMapDataReady | INT Map (Data Ready)
Public property | INTMapDoubleTap | INT Map (Double Tap)
Public property | INTMapFreeFall | INT Map (Free Fall)
Public property | INTMapInactivity | INT Map (Inactivity)
Public property | INTMapOverrun | INT Map (Overrun)
Public property | INTMapSingleTap | INT Map (Single Tap)
Public property | INTMapWatermark | INT Map (Watermark)
Public property | INTSourceActivity | INT Source (Activity)
Public property | INTSourceDataReady | INT Source (Data Ready)
Public property | INTSourceDoubleTap | INT Source (Double Tap)
Public property | INTSourceFreeFall | INT Source (Free Fall)
Public property | INTSourceInactivity | INT Source (Inactivity)
Public property | INTSourceOverrun | INT Source (Overrun)
Public property | INTSourceSingleTap | INT Source (Single Tap)
Public property | INTSourceWatermark | INT Source (Watermark)
Public property | Latent | Latent (unit: ms)
Public property | OFSX | OFSX (unit: mg)
Public property | OFSY | OFSY (unit: mg)
Public property | OFSZ | OFSZ (unit: mg)
Public property | Orient2DOrient | Orient (2D Orient)
Public property | Orient3DOrient | Orient (3D Orient)
Public property | OrientConfDeadzone | Orient Conf (Deadzone)
Public property | OrientConfDivisor | Orient Conf (Divisor)
Public property | OrientConfInt3D | Orient Conf (Int 3D)
Public property | OrientConfIntOrient | Orient Conf (Int Orient)
Public property | OrientV2 | Orient (V2)
Public property | OrientV3 | Orient (V3)
Public property | PowerCTLAutoSleep | Power CTL (Auto Sleep)
Public property | PowerCTLLink | Power CTL (Link)
Public property | PowerCTLMeasure | Power CTL (Measure)
Public property | PowerCTLSleep | Power CTL (Sleep)
Public property | PowerCTLWakeUp | Power CTL (Wake Up)
Public property | TapAxesImprovedTap | Tap Axes (Improved Tap)
Public property | TapAxesSuppress | Tap Axes (Suppress)
Public property | TapAxesTAPXEN | Tap Axes (TAP X EN)
Public property | TapAxesTAPYEN | Tap Axes (TAP Y EN)
Public property | TapAxesTAPZEN | Tap Axes (TAP Z EN)
Public property | TAPSignXSign | TAP Sign (X Sign)
Public property | TAPSignXTAP | TAP Sign (X TAP)
Public property | TAPSignYSign | TAP Sign (Y Sign)
Public property | TAPSignYTAP | TAP Sign (Y TAP)
Public property | TAPSignZSign | TAP Sign (Z Sign)
Public property | TAPSignZTAP | TAP Sign (Z TAP)
Public property | ThreshAct | Thresh Act (unit: mg)
Public property | ThreshFF | Thresh FF (unit: mg)
Public property | ThreshInact | Thresh Inact (unit: mg)
Public property | ThreshTap | Thresh Tap (unit: mg)
Public property | TimeFF | Time FF (unit: ms)
Public property | TimeInact | Time Inact (unit: s)
Public property | Window | Window (unit: ms)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
3-Axis ±2 g/±4 g/±8 g/±16 g Ultralow Power Digital Accelerometer
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346 Constructor

Constructor

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Adxl346(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Adxl346

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346 Properties

The Adxl346 type exposes the following members.

Properties
 | Name | Description
Public property | ActInactControlACTACDC | Act Inact Control (ACT AC/DC)
Public property | ActInactControlACTXEN | Act Inact Control (ACT X EN)
Public property | ActInactControlACTYEN | Act Inact Control (ACT Y EN)
Public property | ActInactControlACTZEN | Act Inact Control (ACT Z EN)
Public property | ActInactControlINACTACDC | Act Inact Control (INACT AC/DC)
Public property | ActInactControlINACTXEN | Act Inact Control (INACT X EN)
Public property | ActInactControlINACTYEN | Act Inact Control (INACT Y EN)
Public property | ActInactControlINACTZEN | Act Inact Control (INACT Z EN)
Public property | ActTapStatusACTXSRC | Act Tap Status (ACT X SRC)
Public property | ActTapStatusACTYSRC | Act Tap Status (ACT Y SRC)
Public property | ActTapStatusACTZSRC | Act Tap Status (ACT Z SRC)
Public property | ActTapStatusAsleep | Act Tap Status (Asleep)
Public property | ActTapStatusTAPXSRC | Act Tap Status (TAP X SRC)
Public property | ActTapStatusTAPYSRC | Act Tap Status (TAP Y SRC)
Public property | ActTapStatusTAPZSRC | Act Tap Status (TAP Z SRC)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BWRateLowPower | BW Rate (Low Power)
Public property | BWRateRate | BW Rate (Rate)
Public property | DataFormatFullRes | Data Format (Full Res)
Public property | DataFormatIntInvert | Data Format (Int Invert)
Public property | DataFormatJustify | Data Format (Justify)
Public property | DataFormatRange | Data Format (Range)
Public property | DataFormatSelfTest | Data Format (Self Test)
Public property | DataFormatSPI | Data Format (SPI)
Public property | DataX | Data X
Public property | DataY | Data Y
Public property | DataZ | Data Z
Public property | DeviceID | Device ID
Public property | DUR | DUR (unit: μs)
Public property | FIFOCTLFIFOMode | FIFO CTL (FIFO Mode)
Public property | FIFOCTLSamples | FIFO CTL (Samples)
Public property | FIFOCTLTrigger | FIFO CTL (Trigger)
Public property | FIFOStatusEntries | FIFO Status (Entries)
Public property | FIFOStatusFIFOTrig | FIFO Status (FIFO Trig)
Public property | INTEnableActivity | INT Enable (Activity)
Public property | INTEnableDataReady | INT Enable (Data Ready)
Public property | INTEnableDoubleTap | INT Enable (Double Tap)
Public property | INTEnableFreeFall | INT Enable (Free Fall)
Public property | INTEnableInactivity | INT Enable (Inactivity)
Public property | INTEnableOverrun | INT Enable (Overrun)
Public property | INTEnableSingleTap | INT Enable (Single Tap)
Public property | INTEnableWatermark | INT Enable (Watermark)
Public property | INTMapActivity | INT Map (Activity)
Public property | INTMapDataReady | INT Map (Data Ready)
Public property | INTMapDoubleTap | INT Map (Double Tap)
Public property | INTMapFreeFall | INT Map (Free Fall)
Public property | INTMapInactivity | INT Map (Inactivity)
Public property | INTMapOverrun | INT Map (Overrun)
Public property | INTMapSingleTap | INT Map (Single Tap)
Public property | INTMapWatermark | INT Map (Watermark)
Public property | INTSourceActivity | INT Source (Activity)
Public property | INTSourceDataReady | INT Source (Data Ready)
Public property | INTSourceDoubleTap | INT Source (Double Tap)
Public property | INTSourceFreeFall | INT Source (Free Fall)
Public property | INTSourceInactivity | INT Source (Inactivity)
Public property | INTSourceOverrun | INT Source (Overrun)
Public property | INTSourceSingleTap | INT Source (Single Tap)
Public property | INTSourceWatermark | INT Source (Watermark)
Public property | Latent | Latent (unit: ms)
Public property | OFSX | OFSX (unit: mg)
Public property | OFSY | OFSY (unit: mg)
Public property | OFSZ | OFSZ (unit: mg)
Public property | Orient2DOrient | Orient (2D Orient)
Public property | Orient3DOrient | Orient (3D Orient)
Public property | OrientConfDeadzone | Orient Conf (Deadzone)
Public property | OrientConfDivisor | Orient Conf (Divisor)
Public property | OrientConfInt3D | Orient Conf (Int 3D)
Public property | OrientConfIntOrient | Orient Conf (Int Orient)
Public property | OrientV2 | Orient (V2)
Public property | OrientV3 | Orient (V3)
Public property | PowerCTLAutoSleep | Power CTL (Auto Sleep)
Public property | PowerCTLLink | Power CTL (Link)
Public property | PowerCTLMeasure | Power CTL (Measure)
Public property | PowerCTLSleep | Power CTL (Sleep)
Public property | PowerCTLWakeUp | Power CTL (Wake Up)
Public property | TapAxesImprovedTap | Tap Axes (Improved Tap)
Public property | TapAxesSuppress | Tap Axes (Suppress)
Public property | TapAxesTAPXEN | Tap Axes (TAP X EN)
Public property | TapAxesTAPYEN | Tap Axes (TAP Y EN)
Public property | TapAxesTAPZEN | Tap Axes (TAP Z EN)
Public property | TAPSignXSign | TAP Sign (X Sign)
Public property | TAPSignXTAP | TAP Sign (X TAP)
Public property | TAPSignYSign | TAP Sign (Y Sign)
Public property | TAPSignYTAP | TAP Sign (Y TAP)
Public property | TAPSignZSign | TAP Sign (Z Sign)
Public property | TAPSignZTAP | TAP Sign (Z TAP)
Public property | ThreshAct | Thresh Act (unit: mg)
Public property | ThreshFF | Thresh FF (unit: mg)
Public property | ThreshInact | Thresh Inact (unit: mg)
Public property | ThreshTap | Thresh Tap (unit: mg)
Public property | TimeFF | Time FF (unit: ms)
Public property | TimeInact | Time Inact (unit: s)
Public property | Window | Window (unit: ms)
Top
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ActInactControlACTACDC Property

IRD

Adxl346ActInactControlACTACDC Property

Act Inact Control (ACT AC/DC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeActInactCtlActAcDc ActInactControlACTACDC { get; set; }
Public Property ActInactControlACTACDC As Adxl346TypeActInactCtlActAcDc
    Get
    Set
public:
property Adxl346TypeActInactCtlActAcDc ActInactControlACTACDC {
    Adxl346TypeActInactCtlActAcDc get ();
    void set (Adxl346TypeActInactCtlActAcDc value);
}
member ActInactControlACTACDC : Adxl346TypeActInactCtlActAcDc with get, set

Property Value

Type: Adxl346TypeActInactCtlActAcDc
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ActInactControlACTXEN Property

IRD

Adxl346ActInactControlACTXEN Property

Act Inact Control (ACT X EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeActInactCtlActX ActInactControlACTXEN { get; set; }
Public Property ActInactControlACTXEN As Adxl346TypeActInactCtlActX
    Get
    Set
public:
property Adxl346TypeActInactCtlActX ActInactControlACTXEN {
    Adxl346TypeActInactCtlActX get ();
    void set (Adxl346TypeActInactCtlActX value);
}
member ActInactControlACTXEN : Adxl346TypeActInactCtlActX with get, set

Property Value

Type: Adxl346TypeActInactCtlActX
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ActInactControlACTYEN Property

IRD

Adxl346ActInactControlACTYEN Property

Act Inact Control (ACT Y EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeActInactCtlActY ActInactControlACTYEN { get; set; }
Public Property ActInactControlACTYEN As Adxl346TypeActInactCtlActY
    Get
    Set
public:
property Adxl346TypeActInactCtlActY ActInactControlACTYEN {
    Adxl346TypeActInactCtlActY get ();
    void set (Adxl346TypeActInactCtlActY value);
}
member ActInactControlACTYEN : Adxl346TypeActInactCtlActY with get, set

Property Value

Type: Adxl346TypeActInactCtlActY
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ActInactControlACTZEN Property

IRD

Adxl346ActInactControlACTZEN Property

Act Inact Control (ACT Z EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeActInactCtlActZ ActInactControlACTZEN { get; set; }
Public Property ActInactControlACTZEN As Adxl346TypeActInactCtlActZ
    Get
    Set
public:
property Adxl346TypeActInactCtlActZ ActInactControlACTZEN {
    Adxl346TypeActInactCtlActZ get ();
    void set (Adxl346TypeActInactCtlActZ value);
}
member ActInactControlACTZEN : Adxl346TypeActInactCtlActZ with get, set

Property Value

Type: Adxl346TypeActInactCtlActZ
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ActInactControlINACTACDC Property

IRD

Adxl346ActInactControlINACTACDC Property

Act Inact Control (INACT AC/DC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeActInactCtlInactAcDc ActInactControlINACTACDC { get; set; }
Public Property ActInactControlINACTACDC As Adxl346TypeActInactCtlInactAcDc
    Get
    Set
public:
property Adxl346TypeActInactCtlInactAcDc ActInactControlINACTACDC {
    Adxl346TypeActInactCtlInactAcDc get ();
    void set (Adxl346TypeActInactCtlInactAcDc value);
}
member ActInactControlINACTACDC : Adxl346TypeActInactCtlInactAcDc with get, set

Property Value

Type: Adxl346TypeActInactCtlInactAcDc
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ActInactControlINACTXEN Property

IRD

Adxl346ActInactControlINACTXEN Property

Act Inact Control (INACT X EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeActInactCtlInactX ActInactControlINACTXEN { get; set; }
Public Property ActInactControlINACTXEN As Adxl346TypeActInactCtlInactX
    Get
    Set
public:
property Adxl346TypeActInactCtlInactX ActInactControlINACTXEN {
    Adxl346TypeActInactCtlInactX get ();
    void set (Adxl346TypeActInactCtlInactX value);
}
member ActInactControlINACTXEN : Adxl346TypeActInactCtlInactX with get, set

Property Value

Type: Adxl346TypeActInactCtlInactX
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ActInactControlINACTYEN Property

IRD

Adxl346ActInactControlINACTYEN Property

Act Inact Control (INACT Y EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeActInactCtlInactY ActInactControlINACTYEN { get; set; }
Public Property ActInactControlINACTYEN As Adxl346TypeActInactCtlInactY
    Get
    Set
public:
property Adxl346TypeActInactCtlInactY ActInactControlINACTYEN {
    Adxl346TypeActInactCtlInactY get ();
    void set (Adxl346TypeActInactCtlInactY value);
}
member ActInactControlINACTYEN : Adxl346TypeActInactCtlInactY with get, set

Property Value

Type: Adxl346TypeActInactCtlInactY
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ActInactControlINACTZEN Property

IRD

Adxl346ActInactControlINACTZEN Property

Act Inact Control (INACT Z EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeActInactCtlActZ ActInactControlINACTZEN { get; set; }
Public Property ActInactControlINACTZEN As Adxl346TypeActInactCtlActZ
    Get
    Set
public:
property Adxl346TypeActInactCtlActZ ActInactControlINACTZEN {
    Adxl346TypeActInactCtlActZ get ();
    void set (Adxl346TypeActInactCtlActZ value);
}
member ActInactControlINACTZEN : Adxl346TypeActInactCtlActZ with get, set

Property Value

Type: Adxl346TypeActInactCtlActZ
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ActTapStatusACTXSRC Property

IRD

Adxl346ActTapStatusACTXSRC Property

Act Tap Status (ACT X SRC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeActTapStatusActXSrc ActTapStatusACTXSRC { get; }
Public ReadOnly Property ActTapStatusACTXSRC As Adxl346TypeActTapStatusActXSrc
    Get
public:
property Adxl346TypeActTapStatusActXSrc ActTapStatusACTXSRC {
    Adxl346TypeActTapStatusActXSrc get ();
}
member ActTapStatusACTXSRC : Adxl346TypeActTapStatusActXSrc with get

Property Value

Type: Adxl346TypeActTapStatusActXSrc
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ActTapStatusACTYSRC Property

IRD

Adxl346ActTapStatusACTYSRC Property

Act Tap Status (ACT Y SRC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeActTapStatusActYSrc ActTapStatusACTYSRC { get; }
Public ReadOnly Property ActTapStatusACTYSRC As Adxl346TypeActTapStatusActYSrc
    Get
public:
property Adxl346TypeActTapStatusActYSrc ActTapStatusACTYSRC {
    Adxl346TypeActTapStatusActYSrc get ();
}
member ActTapStatusACTYSRC : Adxl346TypeActTapStatusActYSrc with get

Property Value

Type: Adxl346TypeActTapStatusActYSrc
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ActTapStatusACTZSRC Property

IRD

Adxl346ActTapStatusACTZSRC Property

Act Tap Status (ACT Z SRC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeActTapStatusActZSrc ActTapStatusACTZSRC { get; }
Public ReadOnly Property ActTapStatusACTZSRC As Adxl346TypeActTapStatusActZSrc
    Get
public:
property Adxl346TypeActTapStatusActZSrc ActTapStatusACTZSRC {
    Adxl346TypeActTapStatusActZSrc get ();
}
member ActTapStatusACTZSRC : Adxl346TypeActTapStatusActZSrc with get

Property Value

Type: Adxl346TypeActTapStatusActZSrc
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ActTapStatusAsleep Property

IRD

Adxl346ActTapStatusAsleep Property

Act Tap Status (Asleep)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeActTapStatusAsleep ActTapStatusAsleep { get; }
Public ReadOnly Property ActTapStatusAsleep As Adxl346TypeActTapStatusAsleep
    Get
public:
property Adxl346TypeActTapStatusAsleep ActTapStatusAsleep {
    Adxl346TypeActTapStatusAsleep get ();
}
member ActTapStatusAsleep : Adxl346TypeActTapStatusAsleep with get

Property Value

Type: Adxl346TypeActTapStatusAsleep
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ActTapStatusTAPXSRC Property

IRD

Adxl346ActTapStatusTAPXSRC Property

Act Tap Status (TAP X SRC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeActTapStatusTapXSrc ActTapStatusTAPXSRC { get; }
Public ReadOnly Property ActTapStatusTAPXSRC As Adxl346TypeActTapStatusTapXSrc
    Get
public:
property Adxl346TypeActTapStatusTapXSrc ActTapStatusTAPXSRC {
    Adxl346TypeActTapStatusTapXSrc get ();
}
member ActTapStatusTAPXSRC : Adxl346TypeActTapStatusTapXSrc with get

Property Value

Type: Adxl346TypeActTapStatusTapXSrc
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ActTapStatusTAPYSRC Property

IRD

Adxl346ActTapStatusTAPYSRC Property

Act Tap Status (TAP Y SRC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeActTapStatusTapYSrc ActTapStatusTAPYSRC { get; }
Public ReadOnly Property ActTapStatusTAPYSRC As Adxl346TypeActTapStatusTapYSrc
    Get
public:
property Adxl346TypeActTapStatusTapYSrc ActTapStatusTAPYSRC {
    Adxl346TypeActTapStatusTapYSrc get ();
}
member ActTapStatusTAPYSRC : Adxl346TypeActTapStatusTapYSrc with get

Property Value

Type: Adxl346TypeActTapStatusTapYSrc
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ActTapStatusTAPZSRC Property

IRD

Adxl346ActTapStatusTAPZSRC Property

Act Tap Status (TAP Z SRC)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeActTapStatusTapZSrc ActTapStatusTAPZSRC { get; }
Public ReadOnly Property ActTapStatusTAPZSRC As Adxl346TypeActTapStatusTapZSrc
    Get
public:
property Adxl346TypeActTapStatusTapZSrc ActTapStatusTAPZSRC {
    Adxl346TypeActTapStatusTapZSrc get ();
}
member ActTapStatusTAPZSRC : Adxl346TypeActTapStatusTapZSrc with get

Property Value

Type: Adxl346TypeActTapStatusTapZSrc
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.AutoFlush Property

IRD

Adxl346AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.BWRateLowPower Property

IRD

Adxl346BWRateLowPower Property

BW Rate (Low Power)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeBwRateLowPower BWRateLowPower { get; set; }
Public Property BWRateLowPower As Adxl346TypeBwRateLowPower
    Get
    Set
public:
property Adxl346TypeBwRateLowPower BWRateLowPower {
    Adxl346TypeBwRateLowPower get ();
    void set (Adxl346TypeBwRateLowPower value);
}
member BWRateLowPower : Adxl346TypeBwRateLowPower with get, set

Property Value

Type: Adxl346TypeBwRateLowPower
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.BWRateRate Property

IRD

Adxl346BWRateRate Property

BW Rate (Rate)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeBwRateRateBits BWRateRate { get; set; }
Public Property BWRateRate As Adxl346TypeBwRateRateBits
    Get
    Set
public:
property Adxl346TypeBwRateRateBits BWRateRate {
    Adxl346TypeBwRateRateBits get ();
    void set (Adxl346TypeBwRateRateBits value);
}
member BWRateRate : Adxl346TypeBwRateRateBits with get, set

Property Value

Type: Adxl346TypeBwRateRateBits
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.DataFormatFullRes Property

IRD

Adxl346DataFormatFullRes Property

Data Format (Full Res)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeDataFormatFullRes DataFormatFullRes { get; set; }
Public Property DataFormatFullRes As Adxl346TypeDataFormatFullRes
    Get
    Set
public:
property Adxl346TypeDataFormatFullRes DataFormatFullRes {
    Adxl346TypeDataFormatFullRes get ();
    void set (Adxl346TypeDataFormatFullRes value);
}
member DataFormatFullRes : Adxl346TypeDataFormatFullRes with get, set

Property Value

Type: Adxl346TypeDataFormatFullRes
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.DataFormatIntInvert Property

IRD

Adxl346DataFormatIntInvert Property

Data Format (Int Invert)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeDataFormatIntInvert DataFormatIntInvert { get; set; }
Public Property DataFormatIntInvert As Adxl346TypeDataFormatIntInvert
    Get
    Set
public:
property Adxl346TypeDataFormatIntInvert DataFormatIntInvert {
    Adxl346TypeDataFormatIntInvert get ();
    void set (Adxl346TypeDataFormatIntInvert value);
}
member DataFormatIntInvert : Adxl346TypeDataFormatIntInvert with get, set

Property Value

Type: Adxl346TypeDataFormatIntInvert
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.DataFormatJustify Property

IRD

Adxl346DataFormatJustify Property

Data Format (Justify)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeDataFormatJustify DataFormatJustify { get; set; }
Public Property DataFormatJustify As Adxl346TypeDataFormatJustify
    Get
    Set
public:
property Adxl346TypeDataFormatJustify DataFormatJustify {
    Adxl346TypeDataFormatJustify get ();
    void set (Adxl346TypeDataFormatJustify value);
}
member DataFormatJustify : Adxl346TypeDataFormatJustify with get, set

Property Value

Type: Adxl346TypeDataFormatJustify
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.DataFormatRange Property

IRD

Adxl346DataFormatRange Property

Data Format (Range)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeDataFormatRange DataFormatRange { get; set; }
Public Property DataFormatRange As Adxl346TypeDataFormatRange
    Get
    Set
public:
property Adxl346TypeDataFormatRange DataFormatRange {
    Adxl346TypeDataFormatRange get ();
    void set (Adxl346TypeDataFormatRange value);
}
member DataFormatRange : Adxl346TypeDataFormatRange with get, set

Property Value

Type: Adxl346TypeDataFormatRange
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.DataFormatSelfTest Property

IRD

Adxl346DataFormatSelfTest Property

Data Format (Self Test)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeDataFormatSelfTest DataFormatSelfTest { get; set; }
Public Property DataFormatSelfTest As Adxl346TypeDataFormatSelfTest
    Get
    Set
public:
property Adxl346TypeDataFormatSelfTest DataFormatSelfTest {
    Adxl346TypeDataFormatSelfTest get ();
    void set (Adxl346TypeDataFormatSelfTest value);
}
member DataFormatSelfTest : Adxl346TypeDataFormatSelfTest with get, set

Property Value

Type: Adxl346TypeDataFormatSelfTest
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.DataFormatSPI Property

IRD

Adxl346DataFormatSPI Property

Data Format (SPI)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeDataFormatSpi DataFormatSPI { get; set; }
Public Property DataFormatSPI As Adxl346TypeDataFormatSpi
    Get
    Set
public:
property Adxl346TypeDataFormatSpi DataFormatSPI {
    Adxl346TypeDataFormatSpi get ();
    void set (Adxl346TypeDataFormatSpi value);
}
member DataFormatSPI : Adxl346TypeDataFormatSpi with get, set

Property Value

Type: Adxl346TypeDataFormatSpi
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.DataX Property

IRD

Adxl346DataX Property

Data X

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short DataX { get; }
Public ReadOnly Property DataX As Short
    Get
public:
property short DataX {
    short get ();
}
member DataX : int16 with get

Property Value

Type: Int16
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.DataY Property

IRD

Adxl346DataY Property

Data Y

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short DataY { get; }
Public ReadOnly Property DataY As Short
    Get
public:
property short DataY {
    short get ();
}
member DataY : int16 with get

Property Value

Type: Int16
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.DataZ Property

IRD

Adxl346DataZ Property

Data Z

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short DataZ { get; }
Public ReadOnly Property DataZ As Short
    Get
public:
property short DataZ {
    short get ();
}
member DataZ : int16 with get

Property Value

Type: Int16
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.DeviceID Property

IRD

Adxl346DeviceID Property

Device ID

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.DUR Property

IRD

Adxl346DUR Property

DUR (unit: μs)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DUR { get; set; }
Public Property DUR As Double
    Get
    Set
public:
property double DUR {
    double get ();
    void set (double value);
}
member DUR : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.FIFOCTLFIFOMode Property

IRD

Adxl346FIFOCTLFIFOMode Property

FIFO CTL (FIFO Mode)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeFifoCtlFifoMode FIFOCTLFIFOMode { get; set; }
Public Property FIFOCTLFIFOMode As Adxl346TypeFifoCtlFifoMode
    Get
    Set
public:
property Adxl346TypeFifoCtlFifoMode FIFOCTLFIFOMode {
    Adxl346TypeFifoCtlFifoMode get ();
    void set (Adxl346TypeFifoCtlFifoMode value);
}
member FIFOCTLFIFOMode : Adxl346TypeFifoCtlFifoMode with get, set

Property Value

Type: Adxl346TypeFifoCtlFifoMode
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.FIFOCTLSamples Property

IRD

Adxl346FIFOCTLSamples Property

FIFO CTL (Samples)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOCTLSamples { get; set; }
Public Property FIFOCTLSamples As Byte
    Get
    Set
public:
property unsigned char FIFOCTLSamples {
    unsigned char get ();
    void set (unsigned char value);
}
member FIFOCTLSamples : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.FIFOCTLTrigger Property

IRD

Adxl346FIFOCTLTrigger Property

FIFO CTL (Trigger)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeFifoCtlTrigger FIFOCTLTrigger { get; set; }
Public Property FIFOCTLTrigger As Adxl346TypeFifoCtlTrigger
    Get
    Set
public:
property Adxl346TypeFifoCtlTrigger FIFOCTLTrigger {
    Adxl346TypeFifoCtlTrigger get ();
    void set (Adxl346TypeFifoCtlTrigger value);
}
member FIFOCTLTrigger : Adxl346TypeFifoCtlTrigger with get, set

Property Value

Type: Adxl346TypeFifoCtlTrigger
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.FIFOStatusEntries Property

IRD

Adxl346FIFOStatusEntries Property

FIFO Status (Entries)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOStatusEntries { get; }
Public ReadOnly Property FIFOStatusEntries As Byte
    Get
public:
property unsigned char FIFOStatusEntries {
    unsigned char get ();
}
member FIFOStatusEntries : byte with get

Property Value

Type: Byte
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.FIFOStatusFIFOTrig Property

IRD

Adxl346FIFOStatusFIFOTrig Property

FIFO Status (FIFO Trig)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeFifoStatusFifoTrig FIFOStatusFIFOTrig { get; }
Public ReadOnly Property FIFOStatusFIFOTrig As Adxl346TypeFifoStatusFifoTrig
    Get
public:
property Adxl346TypeFifoStatusFifoTrig FIFOStatusFIFOTrig {
    Adxl346TypeFifoStatusFifoTrig get ();
}
member FIFOStatusFIFOTrig : Adxl346TypeFifoStatusFifoTrig with get

Property Value

Type: Adxl346TypeFifoStatusFifoTrig
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTEnableActivity Property

IRD

Adxl346INTEnableActivity Property

INT Enable (Activity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntEnableActivity INTEnableActivity { get; set; }
Public Property INTEnableActivity As Adxl346TypeIntEnableActivity
    Get
    Set
public:
property Adxl346TypeIntEnableActivity INTEnableActivity {
    Adxl346TypeIntEnableActivity get ();
    void set (Adxl346TypeIntEnableActivity value);
}
member INTEnableActivity : Adxl346TypeIntEnableActivity with get, set

Property Value

Type: Adxl346TypeIntEnableActivity
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTEnableDataReady Property

IRD

Adxl346INTEnableDataReady Property

INT Enable (Data Ready)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntEnableDataReady INTEnableDataReady { get; set; }
Public Property INTEnableDataReady As Adxl346TypeIntEnableDataReady
    Get
    Set
public:
property Adxl346TypeIntEnableDataReady INTEnableDataReady {
    Adxl346TypeIntEnableDataReady get ();
    void set (Adxl346TypeIntEnableDataReady value);
}
member INTEnableDataReady : Adxl346TypeIntEnableDataReady with get, set

Property Value

Type: Adxl346TypeIntEnableDataReady
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTEnableDoubleTap Property

IRD

Adxl346INTEnableDoubleTap Property

INT Enable (Double Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntEnableDoubleTap INTEnableDoubleTap { get; set; }
Public Property INTEnableDoubleTap As Adxl346TypeIntEnableDoubleTap
    Get
    Set
public:
property Adxl346TypeIntEnableDoubleTap INTEnableDoubleTap {
    Adxl346TypeIntEnableDoubleTap get ();
    void set (Adxl346TypeIntEnableDoubleTap value);
}
member INTEnableDoubleTap : Adxl346TypeIntEnableDoubleTap with get, set

Property Value

Type: Adxl346TypeIntEnableDoubleTap
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTEnableFreeFall Property

IRD

Adxl346INTEnableFreeFall Property

INT Enable (Free Fall)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntEnableFreeFall INTEnableFreeFall { get; set; }
Public Property INTEnableFreeFall As Adxl346TypeIntEnableFreeFall
    Get
    Set
public:
property Adxl346TypeIntEnableFreeFall INTEnableFreeFall {
    Adxl346TypeIntEnableFreeFall get ();
    void set (Adxl346TypeIntEnableFreeFall value);
}
member INTEnableFreeFall : Adxl346TypeIntEnableFreeFall with get, set

Property Value

Type: Adxl346TypeIntEnableFreeFall
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTEnableInactivity Property

IRD

Adxl346INTEnableInactivity Property

INT Enable (Inactivity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntEnableInactivity INTEnableInactivity { get; set; }
Public Property INTEnableInactivity As Adxl346TypeIntEnableInactivity
    Get
    Set
public:
property Adxl346TypeIntEnableInactivity INTEnableInactivity {
    Adxl346TypeIntEnableInactivity get ();
    void set (Adxl346TypeIntEnableInactivity value);
}
member INTEnableInactivity : Adxl346TypeIntEnableInactivity with get, set

Property Value

Type: Adxl346TypeIntEnableInactivity
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTEnableOverrun Property

IRD

Adxl346INTEnableOverrun Property

INT Enable (Overrun)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntEnableOverrun INTEnableOverrun { get; set; }
Public Property INTEnableOverrun As Adxl346TypeIntEnableOverrun
    Get
    Set
public:
property Adxl346TypeIntEnableOverrun INTEnableOverrun {
    Adxl346TypeIntEnableOverrun get ();
    void set (Adxl346TypeIntEnableOverrun value);
}
member INTEnableOverrun : Adxl346TypeIntEnableOverrun with get, set

Property Value

Type: Adxl346TypeIntEnableOverrun
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTEnableSingleTap Property

IRD

Adxl346INTEnableSingleTap Property

INT Enable (Single Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntEnableSingleTap INTEnableSingleTap { get; set; }
Public Property INTEnableSingleTap As Adxl346TypeIntEnableSingleTap
    Get
    Set
public:
property Adxl346TypeIntEnableSingleTap INTEnableSingleTap {
    Adxl346TypeIntEnableSingleTap get ();
    void set (Adxl346TypeIntEnableSingleTap value);
}
member INTEnableSingleTap : Adxl346TypeIntEnableSingleTap with get, set

Property Value

Type: Adxl346TypeIntEnableSingleTap
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTEnableWatermark Property

IRD

Adxl346INTEnableWatermark Property

INT Enable (Watermark)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntEnableWatermark INTEnableWatermark { get; set; }
Public Property INTEnableWatermark As Adxl346TypeIntEnableWatermark
    Get
    Set
public:
property Adxl346TypeIntEnableWatermark INTEnableWatermark {
    Adxl346TypeIntEnableWatermark get ();
    void set (Adxl346TypeIntEnableWatermark value);
}
member INTEnableWatermark : Adxl346TypeIntEnableWatermark with get, set

Property Value

Type: Adxl346TypeIntEnableWatermark
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTMapActivity Property

IRD

Adxl346INTMapActivity Property

INT Map (Activity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntMapActivity INTMapActivity { get; set; }
Public Property INTMapActivity As Adxl346TypeIntMapActivity
    Get
    Set
public:
property Adxl346TypeIntMapActivity INTMapActivity {
    Adxl346TypeIntMapActivity get ();
    void set (Adxl346TypeIntMapActivity value);
}
member INTMapActivity : Adxl346TypeIntMapActivity with get, set

Property Value

Type: Adxl346TypeIntMapActivity
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTMapDataReady Property

IRD

Adxl346INTMapDataReady Property

INT Map (Data Ready)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntMapDataReady INTMapDataReady { get; set; }
Public Property INTMapDataReady As Adxl346TypeIntMapDataReady
    Get
    Set
public:
property Adxl346TypeIntMapDataReady INTMapDataReady {
    Adxl346TypeIntMapDataReady get ();
    void set (Adxl346TypeIntMapDataReady value);
}
member INTMapDataReady : Adxl346TypeIntMapDataReady with get, set

Property Value

Type: Adxl346TypeIntMapDataReady
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTMapDoubleTap Property

IRD

Adxl346INTMapDoubleTap Property

INT Map (Double Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntMapDoubleTap INTMapDoubleTap { get; set; }
Public Property INTMapDoubleTap As Adxl346TypeIntMapDoubleTap
    Get
    Set
public:
property Adxl346TypeIntMapDoubleTap INTMapDoubleTap {
    Adxl346TypeIntMapDoubleTap get ();
    void set (Adxl346TypeIntMapDoubleTap value);
}
member INTMapDoubleTap : Adxl346TypeIntMapDoubleTap with get, set

Property Value

Type: Adxl346TypeIntMapDoubleTap
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTMapFreeFall Property

IRD

Adxl346INTMapFreeFall Property

INT Map (Free Fall)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntMapFreeFall INTMapFreeFall { get; set; }
Public Property INTMapFreeFall As Adxl346TypeIntMapFreeFall
    Get
    Set
public:
property Adxl346TypeIntMapFreeFall INTMapFreeFall {
    Adxl346TypeIntMapFreeFall get ();
    void set (Adxl346TypeIntMapFreeFall value);
}
member INTMapFreeFall : Adxl346TypeIntMapFreeFall with get, set

Property Value

Type: Adxl346TypeIntMapFreeFall
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTMapInactivity Property

IRD

Adxl346INTMapInactivity Property

INT Map (Inactivity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntMapInactivity INTMapInactivity { get; set; }
Public Property INTMapInactivity As Adxl346TypeIntMapInactivity
    Get
    Set
public:
property Adxl346TypeIntMapInactivity INTMapInactivity {
    Adxl346TypeIntMapInactivity get ();
    void set (Adxl346TypeIntMapInactivity value);
}
member INTMapInactivity : Adxl346TypeIntMapInactivity with get, set

Property Value

Type: Adxl346TypeIntMapInactivity
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTMapOverrun Property

IRD

Adxl346INTMapOverrun Property

INT Map (Overrun)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntMapOverrun INTMapOverrun { get; set; }
Public Property INTMapOverrun As Adxl346TypeIntMapOverrun
    Get
    Set
public:
property Adxl346TypeIntMapOverrun INTMapOverrun {
    Adxl346TypeIntMapOverrun get ();
    void set (Adxl346TypeIntMapOverrun value);
}
member INTMapOverrun : Adxl346TypeIntMapOverrun with get, set

Property Value

Type: Adxl346TypeIntMapOverrun
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTMapSingleTap Property

IRD

Adxl346INTMapSingleTap Property

INT Map (Single Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntMapSingleTap INTMapSingleTap { get; set; }
Public Property INTMapSingleTap As Adxl346TypeIntMapSingleTap
    Get
    Set
public:
property Adxl346TypeIntMapSingleTap INTMapSingleTap {
    Adxl346TypeIntMapSingleTap get ();
    void set (Adxl346TypeIntMapSingleTap value);
}
member INTMapSingleTap : Adxl346TypeIntMapSingleTap with get, set

Property Value

Type: Adxl346TypeIntMapSingleTap
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTMapWatermark Property

IRD

Adxl346INTMapWatermark Property

INT Map (Watermark)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntMapWatermark INTMapWatermark { get; set; }
Public Property INTMapWatermark As Adxl346TypeIntMapWatermark
    Get
    Set
public:
property Adxl346TypeIntMapWatermark INTMapWatermark {
    Adxl346TypeIntMapWatermark get ();
    void set (Adxl346TypeIntMapWatermark value);
}
member INTMapWatermark : Adxl346TypeIntMapWatermark with get, set

Property Value

Type: Adxl346TypeIntMapWatermark
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTSourceActivity Property

IRD

Adxl346INTSourceActivity Property

INT Source (Activity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntSourceActivity INTSourceActivity { get; }
Public ReadOnly Property INTSourceActivity As Adxl346TypeIntSourceActivity
    Get
public:
property Adxl346TypeIntSourceActivity INTSourceActivity {
    Adxl346TypeIntSourceActivity get ();
}
member INTSourceActivity : Adxl346TypeIntSourceActivity with get

Property Value

Type: Adxl346TypeIntSourceActivity
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTSourceDataReady Property

IRD

Adxl346INTSourceDataReady Property

INT Source (Data Ready)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntSourceDataReady INTSourceDataReady { get; }
Public ReadOnly Property INTSourceDataReady As Adxl346TypeIntSourceDataReady
    Get
public:
property Adxl346TypeIntSourceDataReady INTSourceDataReady {
    Adxl346TypeIntSourceDataReady get ();
}
member INTSourceDataReady : Adxl346TypeIntSourceDataReady with get

Property Value

Type: Adxl346TypeIntSourceDataReady
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTSourceDoubleTap Property

IRD

Adxl346INTSourceDoubleTap Property

INT Source (Double Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntSourceDoubleTap INTSourceDoubleTap { get; }
Public ReadOnly Property INTSourceDoubleTap As Adxl346TypeIntSourceDoubleTap
    Get
public:
property Adxl346TypeIntSourceDoubleTap INTSourceDoubleTap {
    Adxl346TypeIntSourceDoubleTap get ();
}
member INTSourceDoubleTap : Adxl346TypeIntSourceDoubleTap with get

Property Value

Type: Adxl346TypeIntSourceDoubleTap
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTSourceFreeFall Property

IRD

Adxl346INTSourceFreeFall Property

INT Source (Free Fall)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntSourceFreeFall INTSourceFreeFall { get; }
Public ReadOnly Property INTSourceFreeFall As Adxl346TypeIntSourceFreeFall
    Get
public:
property Adxl346TypeIntSourceFreeFall INTSourceFreeFall {
    Adxl346TypeIntSourceFreeFall get ();
}
member INTSourceFreeFall : Adxl346TypeIntSourceFreeFall with get

Property Value

Type: Adxl346TypeIntSourceFreeFall
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTSourceInactivity Property

IRD

Adxl346INTSourceInactivity Property

INT Source (Inactivity)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntSourceInactivity INTSourceInactivity { get; }
Public ReadOnly Property INTSourceInactivity As Adxl346TypeIntSourceInactivity
    Get
public:
property Adxl346TypeIntSourceInactivity INTSourceInactivity {
    Adxl346TypeIntSourceInactivity get ();
}
member INTSourceInactivity : Adxl346TypeIntSourceInactivity with get

Property Value

Type: Adxl346TypeIntSourceInactivity
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTSourceOverrun Property

IRD

Adxl346INTSourceOverrun Property

INT Source (Overrun)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntSourceOverrun INTSourceOverrun { get; }
Public ReadOnly Property INTSourceOverrun As Adxl346TypeIntSourceOverrun
    Get
public:
property Adxl346TypeIntSourceOverrun INTSourceOverrun {
    Adxl346TypeIntSourceOverrun get ();
}
member INTSourceOverrun : Adxl346TypeIntSourceOverrun with get

Property Value

Type: Adxl346TypeIntSourceOverrun
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTSourceSingleTap Property

IRD

Adxl346INTSourceSingleTap Property

INT Source (Single Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntSourceSingleTap INTSourceSingleTap { get; }
Public ReadOnly Property INTSourceSingleTap As Adxl346TypeIntSourceSingleTap
    Get
public:
property Adxl346TypeIntSourceSingleTap INTSourceSingleTap {
    Adxl346TypeIntSourceSingleTap get ();
}
member INTSourceSingleTap : Adxl346TypeIntSourceSingleTap with get

Property Value

Type: Adxl346TypeIntSourceSingleTap
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.INTSourceWatermark Property

IRD

Adxl346INTSourceWatermark Property

INT Source (Watermark)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeIntSourceWatermark INTSourceWatermark { get; }
Public ReadOnly Property INTSourceWatermark As Adxl346TypeIntSourceWatermark
    Get
public:
property Adxl346TypeIntSourceWatermark INTSourceWatermark {
    Adxl346TypeIntSourceWatermark get ();
}
member INTSourceWatermark : Adxl346TypeIntSourceWatermark with get

Property Value

Type: Adxl346TypeIntSourceWatermark
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.Latent Property

IRD

Adxl346Latent Property

Latent (unit: ms)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Latent { get; set; }
Public Property Latent As Double
    Get
    Set
public:
property double Latent {
    double get ();
    void set (double value);
}
member Latent : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.OFSX Property

IRD

Adxl346OFSX Property

OFSX (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double OFSX { get; set; }
Public Property OFSX As Double
    Get
    Set
public:
property double OFSX {
    double get ();
    void set (double value);
}
member OFSX : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.OFSY Property

IRD

Adxl346OFSY Property

OFSY (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double OFSY { get; set; }
Public Property OFSY As Double
    Get
    Set
public:
property double OFSY {
    double get ();
    void set (double value);
}
member OFSY : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.OFSZ Property

IRD

Adxl346OFSZ Property

OFSZ (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double OFSZ { get; set; }
Public Property OFSZ As Double
    Get
    Set
public:
property double OFSZ {
    double get ();
    void set (double value);
}
member OFSZ : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.Orient2DOrient Property

IRD

Adxl346Orient2DOrient Property

Orient (2D Orient)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeOrient2dOrient Orient2DOrient { get; }
Public ReadOnly Property Orient2DOrient As Adxl346TypeOrient2dOrient
    Get
public:
property Adxl346TypeOrient2dOrient Orient2DOrient {
    Adxl346TypeOrient2dOrient get ();
}
member Orient2DOrient : Adxl346TypeOrient2dOrient with get

Property Value

Type: Adxl346TypeOrient2dOrient
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.Orient3DOrient Property

IRD

Adxl346Orient3DOrient Property

Orient (3D Orient)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeOrient3dOrient Orient3DOrient { get; }
Public ReadOnly Property Orient3DOrient As Adxl346TypeOrient3dOrient
    Get
public:
property Adxl346TypeOrient3dOrient Orient3DOrient {
    Adxl346TypeOrient3dOrient get ();
}
member Orient3DOrient : Adxl346TypeOrient3dOrient with get

Property Value

Type: Adxl346TypeOrient3dOrient
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.OrientConfDeadzone Property

IRD

Adxl346OrientConfDeadzone Property

Orient Conf (Deadzone)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeOrientConfDeadzone OrientConfDeadzone { get; set; }
Public Property OrientConfDeadzone As Adxl346TypeOrientConfDeadzone
    Get
    Set
public:
property Adxl346TypeOrientConfDeadzone OrientConfDeadzone {
    Adxl346TypeOrientConfDeadzone get ();
    void set (Adxl346TypeOrientConfDeadzone value);
}
member OrientConfDeadzone : Adxl346TypeOrientConfDeadzone with get, set

Property Value

Type: Adxl346TypeOrientConfDeadzone
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.OrientConfDivisor Property

IRD

Adxl346OrientConfDivisor Property

Orient Conf (Divisor)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeOrientConfDevisor OrientConfDivisor { get; set; }
Public Property OrientConfDivisor As Adxl346TypeOrientConfDevisor
    Get
    Set
public:
property Adxl346TypeOrientConfDevisor OrientConfDivisor {
    Adxl346TypeOrientConfDevisor get ();
    void set (Adxl346TypeOrientConfDevisor value);
}
member OrientConfDivisor : Adxl346TypeOrientConfDevisor with get, set

Property Value

Type: Adxl346TypeOrientConfDevisor
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.OrientConfInt3D Property

IRD

Adxl346OrientConfInt3D Property

Orient Conf (Int 3D)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeOrientConfInt3d OrientConfInt3D { get; set; }
Public Property OrientConfInt3D As Adxl346TypeOrientConfInt3d
    Get
    Set
public:
property Adxl346TypeOrientConfInt3d OrientConfInt3D {
    Adxl346TypeOrientConfInt3d get ();
    void set (Adxl346TypeOrientConfInt3d value);
}
member OrientConfInt3D : Adxl346TypeOrientConfInt3d with get, set

Property Value

Type: Adxl346TypeOrientConfInt3d
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.OrientConfIntOrient Property

IRD

Adxl346OrientConfIntOrient Property

Orient Conf (Int Orient)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeOrientConfIntOrient OrientConfIntOrient { get; set; }
Public Property OrientConfIntOrient As Adxl346TypeOrientConfIntOrient
    Get
    Set
public:
property Adxl346TypeOrientConfIntOrient OrientConfIntOrient {
    Adxl346TypeOrientConfIntOrient get ();
    void set (Adxl346TypeOrientConfIntOrient value);
}
member OrientConfIntOrient : Adxl346TypeOrientConfIntOrient with get, set

Property Value

Type: Adxl346TypeOrientConfIntOrient
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.OrientV2 Property

IRD

Adxl346OrientV2 Property

Orient (V2)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeOrientV2 OrientV2 { get; }
Public ReadOnly Property OrientV2 As Adxl346TypeOrientV2
    Get
public:
property Adxl346TypeOrientV2 OrientV2 {
    Adxl346TypeOrientV2 get ();
}
member OrientV2 : Adxl346TypeOrientV2 with get

Property Value

Type: Adxl346TypeOrientV2
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.OrientV3 Property

IRD

Adxl346OrientV3 Property

Orient (V3)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeOrientV3 OrientV3 { get; }
Public ReadOnly Property OrientV3 As Adxl346TypeOrientV3
    Get
public:
property Adxl346TypeOrientV3 OrientV3 {
    Adxl346TypeOrientV3 get ();
}
member OrientV3 : Adxl346TypeOrientV3 with get

Property Value

Type: Adxl346TypeOrientV3
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.PowerCTLAutoSleep Property

IRD

Adxl346PowerCTLAutoSleep Property

Power CTL (Auto Sleep)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypePowerCtlAutoSleep PowerCTLAutoSleep { get; set; }
Public Property PowerCTLAutoSleep As Adxl346TypePowerCtlAutoSleep
    Get
    Set
public:
property Adxl346TypePowerCtlAutoSleep PowerCTLAutoSleep {
    Adxl346TypePowerCtlAutoSleep get ();
    void set (Adxl346TypePowerCtlAutoSleep value);
}
member PowerCTLAutoSleep : Adxl346TypePowerCtlAutoSleep with get, set

Property Value

Type: Adxl346TypePowerCtlAutoSleep
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.PowerCTLLink Property

IRD

Adxl346PowerCTLLink Property

Power CTL (Link)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypePowerCtlLink PowerCTLLink { get; set; }
Public Property PowerCTLLink As Adxl346TypePowerCtlLink
    Get
    Set
public:
property Adxl346TypePowerCtlLink PowerCTLLink {
    Adxl346TypePowerCtlLink get ();
    void set (Adxl346TypePowerCtlLink value);
}
member PowerCTLLink : Adxl346TypePowerCtlLink with get, set

Property Value

Type: Adxl346TypePowerCtlLink
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.PowerCTLMeasure Property

IRD

Adxl346PowerCTLMeasure Property

Power CTL (Measure)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypePowerCtlMeasure PowerCTLMeasure { get; set; }
Public Property PowerCTLMeasure As Adxl346TypePowerCtlMeasure
    Get
    Set
public:
property Adxl346TypePowerCtlMeasure PowerCTLMeasure {
    Adxl346TypePowerCtlMeasure get ();
    void set (Adxl346TypePowerCtlMeasure value);
}
member PowerCTLMeasure : Adxl346TypePowerCtlMeasure with get, set

Property Value

Type: Adxl346TypePowerCtlMeasure
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.PowerCTLSleep Property

IRD

Adxl346PowerCTLSleep Property

Power CTL (Sleep)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypePowerCtlSleep PowerCTLSleep { get; set; }
Public Property PowerCTLSleep As Adxl346TypePowerCtlSleep
    Get
    Set
public:
property Adxl346TypePowerCtlSleep PowerCTLSleep {
    Adxl346TypePowerCtlSleep get ();
    void set (Adxl346TypePowerCtlSleep value);
}
member PowerCTLSleep : Adxl346TypePowerCtlSleep with get, set

Property Value

Type: Adxl346TypePowerCtlSleep
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.PowerCTLWakeUp Property

IRD

Adxl346PowerCTLWakeUp Property

Power CTL (Wake Up)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypePowerCtlWakeup PowerCTLWakeUp { get; set; }
Public Property PowerCTLWakeUp As Adxl346TypePowerCtlWakeup
    Get
    Set
public:
property Adxl346TypePowerCtlWakeup PowerCTLWakeUp {
    Adxl346TypePowerCtlWakeup get ();
    void set (Adxl346TypePowerCtlWakeup value);
}
member PowerCTLWakeUp : Adxl346TypePowerCtlWakeup with get, set

Property Value

Type: Adxl346TypePowerCtlWakeup
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.TapAxesImprovedTap Property

IRD

Adxl346TapAxesImprovedTap Property

Tap Axes (Improved Tap)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeTapAxesImprovedTap TapAxesImprovedTap { get; set; }
Public Property TapAxesImprovedTap As Adxl346TypeTapAxesImprovedTap
    Get
    Set
public:
property Adxl346TypeTapAxesImprovedTap TapAxesImprovedTap {
    Adxl346TypeTapAxesImprovedTap get ();
    void set (Adxl346TypeTapAxesImprovedTap value);
}
member TapAxesImprovedTap : Adxl346TypeTapAxesImprovedTap with get, set

Property Value

Type: Adxl346TypeTapAxesImprovedTap
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.TapAxesSuppress Property

IRD

Adxl346TapAxesSuppress Property

Tap Axes (Suppress)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeTapAxesSuppress TapAxesSuppress { get; set; }
Public Property TapAxesSuppress As Adxl346TypeTapAxesSuppress
    Get
    Set
public:
property Adxl346TypeTapAxesSuppress TapAxesSuppress {
    Adxl346TypeTapAxesSuppress get ();
    void set (Adxl346TypeTapAxesSuppress value);
}
member TapAxesSuppress : Adxl346TypeTapAxesSuppress with get, set

Property Value

Type: Adxl346TypeTapAxesSuppress
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.TapAxesTAPXEN Property

IRD

Adxl346TapAxesTAPXEN Property

Tap Axes (TAP X EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeTapAxesTapXEn TapAxesTAPXEN { get; set; }
Public Property TapAxesTAPXEN As Adxl346TypeTapAxesTapXEn
    Get
    Set
public:
property Adxl346TypeTapAxesTapXEn TapAxesTAPXEN {
    Adxl346TypeTapAxesTapXEn get ();
    void set (Adxl346TypeTapAxesTapXEn value);
}
member TapAxesTAPXEN : Adxl346TypeTapAxesTapXEn with get, set

Property Value

Type: Adxl346TypeTapAxesTapXEn
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.TapAxesTAPYEN Property

IRD

Adxl346TapAxesTAPYEN Property

Tap Axes (TAP Y EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeTapAxesTapYEn TapAxesTAPYEN { get; set; }
Public Property TapAxesTAPYEN As Adxl346TypeTapAxesTapYEn
    Get
    Set
public:
property Adxl346TypeTapAxesTapYEn TapAxesTAPYEN {
    Adxl346TypeTapAxesTapYEn get ();
    void set (Adxl346TypeTapAxesTapYEn value);
}
member TapAxesTAPYEN : Adxl346TypeTapAxesTapYEn with get, set

Property Value

Type: Adxl346TypeTapAxesTapYEn
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.TapAxesTAPZEN Property

IRD

Adxl346TapAxesTAPZEN Property

Tap Axes (TAP Z EN)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeTapAxesTapZEn TapAxesTAPZEN { get; set; }
Public Property TapAxesTAPZEN As Adxl346TypeTapAxesTapZEn
    Get
    Set
public:
property Adxl346TypeTapAxesTapZEn TapAxesTAPZEN {
    Adxl346TypeTapAxesTapZEn get ();
    void set (Adxl346TypeTapAxesTapZEn value);
}
member TapAxesTAPZEN : Adxl346TypeTapAxesTapZEn with get, set

Property Value

Type: Adxl346TypeTapAxesTapZEn
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.TAPSignXSign Property

IRD

Adxl346TAPSignXSign Property

TAP Sign (X Sign)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeTapSignXsign TAPSignXSign { get; }
Public ReadOnly Property TAPSignXSign As Adxl346TypeTapSignXsign
    Get
public:
property Adxl346TypeTapSignXsign TAPSignXSign {
    Adxl346TypeTapSignXsign get ();
}
member TAPSignXSign : Adxl346TypeTapSignXsign with get

Property Value

Type: Adxl346TypeTapSignXsign
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.TAPSignXTAP Property

IRD

Adxl346TAPSignXTAP Property

TAP Sign (X TAP)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeTapSignXtap TAPSignXTAP { get; }
Public ReadOnly Property TAPSignXTAP As Adxl346TypeTapSignXtap
    Get
public:
property Adxl346TypeTapSignXtap TAPSignXTAP {
    Adxl346TypeTapSignXtap get ();
}
member TAPSignXTAP : Adxl346TypeTapSignXtap with get

Property Value

Type: Adxl346TypeTapSignXtap
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.TAPSignYSign Property

IRD

Adxl346TAPSignYSign Property

TAP Sign (Y Sign)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeTapSignYsign TAPSignYSign { get; }
Public ReadOnly Property TAPSignYSign As Adxl346TypeTapSignYsign
    Get
public:
property Adxl346TypeTapSignYsign TAPSignYSign {
    Adxl346TypeTapSignYsign get ();
}
member TAPSignYSign : Adxl346TypeTapSignYsign with get

Property Value

Type: Adxl346TypeTapSignYsign
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.TAPSignYTAP Property

IRD

Adxl346TAPSignYTAP Property

TAP Sign (Y TAP)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeTapSignYtap TAPSignYTAP { get; }
Public ReadOnly Property TAPSignYTAP As Adxl346TypeTapSignYtap
    Get
public:
property Adxl346TypeTapSignYtap TAPSignYTAP {
    Adxl346TypeTapSignYtap get ();
}
member TAPSignYTAP : Adxl346TypeTapSignYtap with get

Property Value

Type: Adxl346TypeTapSignYtap
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.TAPSignZSign Property

IRD

Adxl346TAPSignZSign Property

TAP Sign (Z Sign)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeTapSignZsign TAPSignZSign { get; }
Public ReadOnly Property TAPSignZSign As Adxl346TypeTapSignZsign
    Get
public:
property Adxl346TypeTapSignZsign TAPSignZSign {
    Adxl346TypeTapSignZsign get ();
}
member TAPSignZSign : Adxl346TypeTapSignZsign with get

Property Value

Type: Adxl346TypeTapSignZsign
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.TAPSignZTAP Property

IRD

Adxl346TAPSignZTAP Property

TAP Sign (Z TAP)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Adxl346TypeTapSignZtap TAPSignZTAP { get; }
Public ReadOnly Property TAPSignZTAP As Adxl346TypeTapSignZtap
    Get
public:
property Adxl346TypeTapSignZtap TAPSignZTAP {
    Adxl346TypeTapSignZtap get ();
}
member TAPSignZTAP : Adxl346TypeTapSignZtap with get

Property Value

Type: Adxl346TypeTapSignZtap
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ThreshAct Property

IRD

Adxl346ThreshAct Property

Thresh Act (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ThreshAct { get; set; }
Public Property ThreshAct As Double
    Get
    Set
public:
property double ThreshAct {
    double get ();
    void set (double value);
}
member ThreshAct : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ThreshFF Property

IRD

Adxl346ThreshFF Property

Thresh FF (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ThreshFF { get; set; }
Public Property ThreshFF As Byte
    Get
    Set
public:
property unsigned char ThreshFF {
    unsigned char get ();
    void set (unsigned char value);
}
member ThreshFF : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ThreshInact Property

IRD

Adxl346ThreshInact Property

Thresh Inact (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ThreshInact { get; set; }
Public Property ThreshInact As Double
    Get
    Set
public:
property double ThreshInact {
    double get ();
    void set (double value);
}
member ThreshInact : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.ThreshTap Property

IRD

Adxl346ThreshTap Property

Thresh Tap (unit: mg)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ThreshTap { get; set; }
Public Property ThreshTap As Double
    Get
    Set
public:
property double ThreshTap {
    double get ();
    void set (double value);
}
member ThreshTap : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.TimeFF Property

IRD

Adxl346TimeFF Property

Time FF (unit: ms)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TimeFF { get; set; }
Public Property TimeFF As Double
    Get
    Set
public:
property double TimeFF {
    double get ();
    void set (double value);
}
member TimeFF : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.TimeInact Property

IRD

Adxl346TimeInact Property

Time Inact (unit: s)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TimeInact { get; set; }
Public Property TimeInact As Byte
    Get
    Set
public:
property unsigned char TimeInact {
    unsigned char get ();
    void set (unsigned char value);
}
member TimeInact : byte with get, set

Property Value

Type: Byte
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.Window Property

IRD

Adxl346Window Property

Window (unit: ms)

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Window { get; set; }
Public Property Window As Double
    Get
    Set
public:
property double Window {
    double get ();
    void set (double value);
}
member Window : float with get, set

Property Value

Type: Double
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346 Methods

The Adxl346 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.Flush Method

IRD

Adxl346Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Adxl346 Class
telos.Ird.AnalogDevices Namespace


Adxl346.TypeActInactCtlActAcDc Enumeration

IRD

Adxl346TypeActInactCtlActAcDc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlActAcDc
Public Enumeration TypeActInactCtlActAcDc
public enum class TypeActInactCtlActAcDc
type TypeActInactCtlActAcDc
Members
Member name | Value | Description
DetectActivityOfDCCoupledOperation | 0 | Detect activity of DC coupled operation
DetectActivityOfACCoupledOperation | 1 | Detect activity of AC coupled operation
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeActInactCtlActX Enumeration

IRD

Adxl346TypeActInactCtlActX Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlActX
Public Enumeration TypeActInactCtlActX
public enum class TypeActInactCtlActX
type TypeActInactCtlActX
Members
Member name | Value | Description
DisableXAxisActivityDetection | 0 | Disable x-axis activity detection
EnableXAxisActivityDetection | 1 | Enable x-axis activity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeActInactCtlActY Enumeration

IRD

Adxl346TypeActInactCtlActY Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlActY
Public Enumeration TypeActInactCtlActY
public enum class TypeActInactCtlActY
type TypeActInactCtlActY
Members
Member name | Value | Description
DisableYAxisActivityDetection | 0 | Disable y-axis activity detection
EnableYAxisActivityDetection | 1 | Enable y-axis activity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeActInactCtlActZ Enumeration

IRD

Adxl346TypeActInactCtlActZ Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlActZ
Public Enumeration TypeActInactCtlActZ
public enum class TypeActInactCtlActZ
type TypeActInactCtlActZ
Members
Member name | Value | Description
DisableZAxisActivityDetection | 0 | Disable z-axis activity detection
EnableZAxisActivityDetection | 1 | Enable z-axis activity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeActInactCtlInactAcDc Enumeration

IRD

Adxl346TypeActInactCtlInactAcDc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlInactAcDc
Public Enumeration TypeActInactCtlInactAcDc
public enum class TypeActInactCtlInactAcDc
type TypeActInactCtlInactAcDc
Members
Member name | Value | Description
DetectInactivityOfDCCoupledOperation | 0 | Detect inactivity of DC coupled operation
DetectInactivityOfACCoupledOperation | 1 | Detect inactivity of AC coupled operation
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeActInactCtlInactX Enumeration

IRD

Adxl346TypeActInactCtlInactX Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlInactX
Public Enumeration TypeActInactCtlInactX
public enum class TypeActInactCtlInactX
type TypeActInactCtlInactX
Members
Member name | Value | Description
DisableXAxisInactivityDetection | 0 | Disable x-axis inactivity detection
EnableXAxisInactivityDetection | 1 | Enable x-axis inactivity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeActInactCtlInactY Enumeration

IRD

Adxl346TypeActInactCtlInactY Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlInactY
Public Enumeration TypeActInactCtlInactY
public enum class TypeActInactCtlInactY
type TypeActInactCtlInactY
Members
Member name | Value | Description
DisableYAxisInactivityDetection | 0 | Disable y-axis inactivity detection
EnableYAxisInactivityDetection | 1 | Enable y-axis inactivity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeActInactCtlInactZ Enumeration

IRD

Adxl346TypeActInactCtlInactZ Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActInactCtlInactZ
Public Enumeration TypeActInactCtlInactZ
public enum class TypeActInactCtlInactZ
type TypeActInactCtlInactZ
Members
Member name | Value | Description
DisableZAxisInactivityDetection | 0 | Disable z-axis inactivity detection
EnableZAxisInactivityDetection | 1 | Enable z-axis inactivity detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeActTapStatusActXSrc Enumeration

IRD

Adxl346TypeActTapStatusActXSrc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusActXSrc
Public Enumeration TypeActTapStatusActXSrc
public enum class TypeActTapStatusActXSrc
type TypeActTapStatusActXSrc
Members
Member name | Value | Description
NoInvolvementInActivityEventInXAxis | 0 | No involvement in activity event in x-axis
InvolvementInActivityEventInXAxis | 1 | Involvement in activity event in x-axis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeActTapStatusActYSrc Enumeration

IRD

Adxl346TypeActTapStatusActYSrc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusActYSrc
Public Enumeration TypeActTapStatusActYSrc
public enum class TypeActTapStatusActYSrc
type TypeActTapStatusActYSrc
Members
Member name | Value | Description
NoInvolvementInActivityEventInYAxis | 0 | No involvement in activity event in y-axis
InvolvementInActivityEventInYAxis | 1 | Involvement in activity event in y-axis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeActTapStatusActZSrc Enumeration

IRD

Adxl346TypeActTapStatusActZSrc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusActZSrc
Public Enumeration TypeActTapStatusActZSrc
public enum class TypeActTapStatusActZSrc
type TypeActTapStatusActZSrc
Members
Member name | Value | Description
NoInvolvementInActivityEventInZAxis | 0 | No involvement in activity event in z-axis
InvolvementInActivityEventInZAxis | 1 | Involvement in activity event in z-axis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeActTapStatusAsleep Enumeration

IRD

Adxl346TypeActTapStatusAsleep Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusAsleep
Public Enumeration TypeActTapStatusAsleep
public enum class TypeActTapStatusAsleep
type TypeActTapStatusAsleep
Members
Member name | Value | Description
ThePartIsNotAsleep | 0 | The part is not asleep
ThePartIsAsleep | 1 | The part is asleep
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeActTapStatusTapXSrc Enumeration

IRD

Adxl346TypeActTapStatusTapXSrc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusTapXSrc
Public Enumeration TypeActTapStatusTapXSrc
public enum class TypeActTapStatusTapXSrc
type TypeActTapStatusTapXSrc
Members
Member name | Value | Description
NoInvolvementInTapEventInXAxis | 0 | No involvement in tap event in x-axis
InvolvementInTapEventInXAxis | 1 | Involvement in tap event in x-axis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeActTapStatusTapYSrc Enumeration

IRD

Adxl346TypeActTapStatusTapYSrc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusTapYSrc
Public Enumeration TypeActTapStatusTapYSrc
public enum class TypeActTapStatusTapYSrc
type TypeActTapStatusTapYSrc
Members
Member name | Value | Description
NoInvolvementInTapEventInYAxis | 0 | No involvement in tap event in y-axis
InvolvementInTapEventInYAxis | 1 | Involvement in tap event in y-axis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeActTapStatusTapZSrc Enumeration

IRD

Adxl346TypeActTapStatusTapZSrc Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActTapStatusTapZSrc
Public Enumeration TypeActTapStatusTapZSrc
public enum class TypeActTapStatusTapZSrc
type TypeActTapStatusTapZSrc
Members
Member name | Value | Description
NoInvolvementInTapEventInZAxis | 0 | No involvement in tap event in z-axis
InvolvementInTapEventInZAxis | 1 | Involvement in tap event in z-axis
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeBwRateLowPower Enumeration

IRD

Adxl346TypeBwRateLowPower Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBwRateLowPower
Public Enumeration TypeBwRateLowPower
public enum class TypeBwRateLowPower
type TypeBwRateLowPower
Members
Member name | Value | Description
NormalOperation | 0 | Normal operation
ReducedPowerOperation | 1 | Reduced power operation
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeBwRateRateBits Enumeration

IRD

Adxl346TypeBwRateRateBits Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBwRateRateBits
Public Enumeration TypeBwRateRateBits
public enum class TypeBwRateRateBits
type TypeBwRateRateBits
Members
Member name | Value | Description
Value_0_10 | 0 | 0.10
Value_0_20 | 1 | 0.20
Value_0_39 | 2 | 0.39
Value_0_78 | 3 | 0.78
Value_1_56 | 4 | 1.56
Value_3_13 | 5 | 3.13
Value_6_25 | 6 | 6.25
Value_12_5 | 7 | 12.5
Value_25 | 8 | 25
Value_50 | 9 | 50
Value_100 | 10 | 100
Value_200 | 11 | 200
Value_400 | 12 | 400
Value_800 | 13 | 800
Value_1600 | 14 | 1600
Value_3200 | 15 | 3200
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeDataFormatFullRes Enumeration

IRD

Adxl346TypeDataFormatFullRes Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatFullRes
Public Enumeration TypeDataFormatFullRes
public enum class TypeDataFormatFullRes
type TypeDataFormatFullRes
Members
Member name | Value | Description
Value_10BitMode | 0 | 10 bit mode
FullResolution | 1 | Full resolution
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeDataFormatIntInvert Enumeration

IRD

Adxl346TypeDataFormatIntInvert Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatIntInvert
Public Enumeration TypeDataFormatIntInvert
public enum class TypeDataFormatIntInvert
type TypeDataFormatIntInvert
Members
Member name | Value | Description
SetInterruptsToActiveHigh | 0 | Set interrupts to active high
SetInterruptsToActiveLow | 1 | Set interrupts to active low
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeDataFormatJustify Enumeration

IRD

Adxl346TypeDataFormatJustify Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatJustify
Public Enumeration TypeDataFormatJustify
public enum class TypeDataFormatJustify
type TypeDataFormatJustify
Members
Member name | Value | Description
RightJustifiedModeWithSignExtension | 0 | Right justified mode with sign extension
LeftMSBJustifiedMode | 1 | Left (MSB) justified mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeDataFormatRange Enumeration

IRD

Adxl346TypeDataFormatRange Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatRange
Public Enumeration TypeDataFormatRange
public enum class TypeDataFormatRange
type TypeDataFormatRange
Members
Member name | Value | Description
Value_2g | 0 | +/- 2g
Value_4g | 1 | +/- 4g
Value_8g | 2 | +/- 8g
Value_16g | 3 | +/- 16g
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeDataFormatSelfTest Enumeration

IRD

Adxl346TypeDataFormatSelfTest Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatSelfTest
Public Enumeration TypeDataFormatSelfTest
public enum class TypeDataFormatSelfTest
type TypeDataFormatSelfTest
Members
Member name | Value | Description
DisableTheSelfTestForce | 0 | Disable the self-test force
EnablesTheSelfTestForce | 1 | Enables the self-test force
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeDataFormatSpi Enumeration

IRD

Adxl346TypeDataFormatSpi Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDataFormatSpi
Public Enumeration TypeDataFormatSpi
public enum class TypeDataFormatSpi
type TypeDataFormatSpi
Members
Member name | Value | Description
Value_4WireSPI | 0 | 4-wire SPI
Value_3WireSPI | 1 | 3-wire SPI
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeFifoCtlFifoMode Enumeration

IRD

Adxl346TypeFifoCtlFifoMode Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFifoCtlFifoMode
Public Enumeration TypeFifoCtlFifoMode
public enum class TypeFifoCtlFifoMode
type TypeFifoCtlFifoMode
Members
Member name | Value | Description
BypassFIFOBypassed | 0 | Bypass: FIFO bypassed
FIFOCollectUpTo32ValuesInFIFO | 1 | FIFO: Collect up to 32 values in FIFO
StreamFIFOHoldsTheLast32DataValues | 2 | Stream: FIFO holds the last 32 data values
TriggerFIFOHoldsTheLastDataSamplesBeforeTheTriggerEvent | 3 | Trigger: FIFO holds the last data samples before the trigger event
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeFifoCtlTrigger Enumeration

IRD

Adxl346TypeFifoCtlTrigger Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFifoCtlTrigger
Public Enumeration TypeFifoCtlTrigger
public enum class TypeFifoCtlTrigger
type TypeFifoCtlTrigger
Members
Member name | Value | Description
SetsTheTriggerEventOfTriggerModeToBeLinkedToINT1 | 0 | sets the trigger event of trigger mode to be linked to INT1
SetsTheTriggerEventOfTriggerModeToBeLinkedToINT2 | 1 | sets the trigger event of trigger mode to be linked to INT2
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeFifoStatusFifoTrig Enumeration

IRD

Adxl346TypeFifoStatusFifoTrig Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFifoStatusFifoTrig
Public Enumeration TypeFifoStatusFifoTrig
public enum class TypeFifoStatusFifoTrig
type TypeFifoStatusFifoTrig
Members
Member name | Value | Description
FIFOTriggerEventHasNotOccurred | 0 | FIFO trigger event has not occurred
FIFOTriggerEventOccurring | 1 | FIFO trigger event occurring
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntEnableActivity Enumeration

IRD

Adxl346TypeIntEnableActivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableActivity
Public Enumeration TypeIntEnableActivity
public enum class TypeIntEnableActivity
type TypeIntEnableActivity
Members
Member name | Value | Description
DisableActivityFunctionInterrupts | 0 | Disable activity function interrupts
EnableActivityFunctionInterrupts | 1 | Enable activity function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntEnableDataReady Enumeration

IRD

Adxl346TypeIntEnableDataReady Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableDataReady
Public Enumeration TypeIntEnableDataReady
public enum class TypeIntEnableDataReady
type TypeIntEnableDataReady
Members
Member name | Value | Description
DisableDataReadyFunctionInterrupts | 0 | Disable data_ready function interrupts
EnableDataReadyFunctionInterrupts | 1 | Enable data_ready function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntEnableDoubleTap Enumeration

IRD

Adxl346TypeIntEnableDoubleTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableDoubleTap
Public Enumeration TypeIntEnableDoubleTap
public enum class TypeIntEnableDoubleTap
type TypeIntEnableDoubleTap
Members
Member name | Value | Description
DisableDoubleTapFunctionInterrupts | 0 | Disable double_tap function interrupts
EnableDoubleTapFunctionInterrupts | 1 | Enable double_tap function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntEnableFreeFall Enumeration

IRD

Adxl346TypeIntEnableFreeFall Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableFreeFall
Public Enumeration TypeIntEnableFreeFall
public enum class TypeIntEnableFreeFall
type TypeIntEnableFreeFall
Members
Member name | Value | Description
DisableFreeFallFunctionInterrupts | 0 | Disable free_fall function interrupts
EnableFreeFallFunctionInterrupts | 1 | Enable free_fall function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntEnableInactivity Enumeration

IRD

Adxl346TypeIntEnableInactivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableInactivity
Public Enumeration TypeIntEnableInactivity
public enum class TypeIntEnableInactivity
type TypeIntEnableInactivity
Members
Member name | Value | Description
DisableInactivityFunctionInterrupts | 0 | Disable inactivity function interrupts
EnableInactivityFunctionInterrupts | 1 | Enable inactivity function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntEnableOverrun Enumeration

IRD

Adxl346TypeIntEnableOverrun Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableOverrun
Public Enumeration TypeIntEnableOverrun
public enum class TypeIntEnableOverrun
type TypeIntEnableOverrun
Members
Member name | Value | Description
DisableOverrunFunctionInterrupts | 0 | Disable overrun function interrupts
EnableOverrunFunctionInterrupts | 1 | Enable overrun function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntEnableSingleTap Enumeration

IRD

Adxl346TypeIntEnableSingleTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableSingleTap
Public Enumeration TypeIntEnableSingleTap
public enum class TypeIntEnableSingleTap
type TypeIntEnableSingleTap
Members
Member name | Value | Description
DisableSingleTapFunctionInterrupts | 0 | Disable single_tap function interrupts
EnableSingleTapFunctionInterrupts | 1 | Enable single_tap function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntEnableWatermark Enumeration

IRD

Adxl346TypeIntEnableWatermark Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntEnableWatermark
Public Enumeration TypeIntEnableWatermark
public enum class TypeIntEnableWatermark
type TypeIntEnableWatermark
Members
Member name | Value | Description
DisableWatermarkFunctionInterrupts | 0 | Disable watermark function interrupts
EnableWatermarkFunctionInterrupts | 1 | Enable watermark function interrupts
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntMapActivity Enumeration

IRD

Adxl346TypeIntMapActivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapActivity
Public Enumeration TypeIntMapActivity
public enum class TypeIntMapActivity
type TypeIntMapActivity
Members
Member name | Value | Description
SendActivityInterruptToINT1Pin | 0 | Send activity interrupt to INT1 pin
SendActivityInterruptToINT2Pin | 1 | Send activity interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntMapDataReady Enumeration

IRD

Adxl346TypeIntMapDataReady Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapDataReady
Public Enumeration TypeIntMapDataReady
public enum class TypeIntMapDataReady
type TypeIntMapDataReady
Members
Member name | Value | Description
SendDataReadyInterruptToINT1Pin | 0 | Send data_ready interrupt to INT1 pin
SendDataReadyInterruptToINT2Pin | 1 | Send data_ready interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntMapDoubleTap Enumeration

IRD

Adxl346TypeIntMapDoubleTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapDoubleTap
Public Enumeration TypeIntMapDoubleTap
public enum class TypeIntMapDoubleTap
type TypeIntMapDoubleTap
Members
Member name | Value | Description
SendDoubleTapInterruptToINT1Pin | 0 | Send double_tap interrupt to INT1 pin
SendDoubleTapInterruptToINT2Pin | 1 | Send double_tap interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntMapFreeFall Enumeration

IRD

Adxl346TypeIntMapFreeFall Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapFreeFall
Public Enumeration TypeIntMapFreeFall
public enum class TypeIntMapFreeFall
type TypeIntMapFreeFall
Members
Member name | Value | Description
SendFreeFallInterruptToINT1Pin | 0 | Send free_fall interrupt to INT1 pin
SendFreeFallInterruptToINT2Pin | 1 | Send free_fall interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntMapInactivity Enumeration

IRD

Adxl346TypeIntMapInactivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapInactivity
Public Enumeration TypeIntMapInactivity
public enum class TypeIntMapInactivity
type TypeIntMapInactivity
Members
Member name | Value | Description
SendInactivityInterruptToINT1Pin | 0 | Send inactivity interrupt to INT1 pin
SendInactivityInterruptToINT2Pin | 1 | Send inactivity interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntMapOverrun Enumeration

IRD

Adxl346TypeIntMapOverrun Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapOverrun
Public Enumeration TypeIntMapOverrun
public enum class TypeIntMapOverrun
type TypeIntMapOverrun
Members
Member name | Value | Description
SendOverrunInterruptToINT1Pin | 0 | Send overrun interrupt to INT1 pin
SendOverrunInterruptToINT2Pin | 1 | Send overrun interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntMapSingleTap Enumeration

IRD

Adxl346TypeIntMapSingleTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapSingleTap
Public Enumeration TypeIntMapSingleTap
public enum class TypeIntMapSingleTap
type TypeIntMapSingleTap
Members
Member name | Value | Description
SendSingleTapInterruptToINT1Pin | 0 | Send single_tap interrupt to INT1 pin
SendSingleTapInterruptToINT2Pin | 1 | Send single_tap interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntMapWatermark Enumeration

IRD

Adxl346TypeIntMapWatermark Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMapWatermark
Public Enumeration TypeIntMapWatermark
public enum class TypeIntMapWatermark
type TypeIntMapWatermark
Members
Member name | Value | Description
SendWatermarkInterruptToINT1Pin | 0 | Send watermark interrupt to INT1 pin
SendWatermarkInterruptToINT2Pin | 1 | Send watermark interrupt to INT2 pin
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntSourceActivity Enumeration

IRD

Adxl346TypeIntSourceActivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceActivity
Public Enumeration TypeIntSourceActivity
public enum class TypeIntSourceActivity
type TypeIntSourceActivity
Members
Member name | Value | Description
ActivityFunctionEventNotOccurred | 0 | Activity function event not occurred
ActivityFunctionHasTriggered | 1 | Activity function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntSourceDataReady Enumeration

IRD

Adxl346TypeIntSourceDataReady Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceDataReady
Public Enumeration TypeIntSourceDataReady
public enum class TypeIntSourceDataReady
type TypeIntSourceDataReady
Members
Member name | Value | Description
ActivityFunctionEventNotOccurred | 0 | Activity function event not occurred
ActivityFunctionHasTriggered | 1 | Activity function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntSourceDoubleTap Enumeration

IRD

Adxl346TypeIntSourceDoubleTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceDoubleTap
Public Enumeration TypeIntSourceDoubleTap
public enum class TypeIntSourceDoubleTap
type TypeIntSourceDoubleTap
Members
Member name | Value | Description
DataReadyFunctionEventNotOccurred | 0 | Data_ready function event not occurred
DataReadyFunctionHasTriggered | 1 | Data_ready function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntSourceFreeFall Enumeration

IRD

Adxl346TypeIntSourceFreeFall Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceFreeFall
Public Enumeration TypeIntSourceFreeFall
public enum class TypeIntSourceFreeFall
type TypeIntSourceFreeFall
Members
Member name | Value | Description
FreeFallFunctionEventNotOccurred | 0 | Free_fall function event not occurred
FreeFallFunctionHasTriggered | 1 | Free_fall function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntSourceInactivity Enumeration

IRD

Adxl346TypeIntSourceInactivity Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceInactivity
Public Enumeration TypeIntSourceInactivity
public enum class TypeIntSourceInactivity
type TypeIntSourceInactivity
Members
Member name | Value | Description
InactivityFunctionEventNotOccurred | 0 | Inactivity function event not occurred
InactivityFunctionHasTriggered | 1 | Inactivity function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntSourceOverrun Enumeration

IRD

Adxl346TypeIntSourceOverrun Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceOverrun
Public Enumeration TypeIntSourceOverrun
public enum class TypeIntSourceOverrun
type TypeIntSourceOverrun
Members
Member name | Value | Description
ActivityFunctionEventNotOccurred | 0 | Activity function event not occurred
ActivityFunctionHasTriggered | 1 | Activity function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntSourceSingleTap Enumeration

IRD

Adxl346TypeIntSourceSingleTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceSingleTap
Public Enumeration TypeIntSourceSingleTap
public enum class TypeIntSourceSingleTap
type TypeIntSourceSingleTap
Members
Member name | Value | Description
OverrunFunctionEventNotOccurred | 0 | Overrun function event not occurred
OverrunFunctionHasTriggered | 1 | Overrun function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeIntSourceWatermark Enumeration

IRD

Adxl346TypeIntSourceWatermark Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSourceWatermark
Public Enumeration TypeIntSourceWatermark
public enum class TypeIntSourceWatermark
type TypeIntSourceWatermark
Members
Member name | Value | Description
WatermarkFunctionEventNotOccurred | 0 | Watermark function event not occurred
WatermarkFunctionHasTriggered | 1 | Watermark function has triggered
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeOrient2dOrient Enumeration

IRD

Adxl346TypeOrient2dOrient Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOrient2dOrient
Public Enumeration TypeOrient2dOrient
public enum class TypeOrient2dOrient
type TypeOrient2dOrient
Members
Member name | Value | Description
PortraitPositiveX | 0 | Portrait positive +X
PortraitNegativX | 1 | Portrait negativ -X
LandscapePositiveY | 2 | Landscape Positive +Y
LandscapeNegativeY | 3 | Landscape Negative -Y
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeOrient3dOrient Enumeration

IRD

Adxl346TypeOrient3dOrient Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOrient3dOrient
Public Enumeration TypeOrient3dOrient
public enum class TypeOrient3dOrient
type TypeOrient3dOrient
Members
Member name | Value | Description
TopZ | 1 | Top +Z
LeftY | 2 | Left +Y
FrontX | 3 | Front +X
BackX | 4 | Back -X
RightY | 5 | Right -Y
BottomZ | 6 | Bottom -Z
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeOrientConfDeadzone Enumeration

IRD

Adxl346TypeOrientConfDeadzone Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOrientConfDeadzone
Public Enumeration TypeOrientConfDeadzone
public enum class TypeOrientConfDeadzone
type TypeOrientConfDeadzone
Members
Member name | Value | Description
Value_5_1 | 0 | 5.1
Value_10_2 | 1 | 10.2
Value_15_2 | 2 | 15.2
Value_20_4 | 3 | 20.4
Value_25_5 | 4 | 25.5
Value_30_8 | 5 | 30.8
Value_36_1 | 6 | 36.1
Value_41_4 | 7 | 41.4
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeOrientConfDevisor Enumeration

IRD

Adxl346TypeOrientConfDevisor Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOrientConfDevisor
Public Enumeration TypeOrientConfDevisor
public enum class TypeOrientConfDevisor
type TypeOrientConfDevisor
Members
Member name | Value | Description
ODR9 | 0 | ODR/9
ODR22 | 1 | ODR/22
ODR50 | 2 | ODR/50
ODR100 | 3 | ODR/100
ODR200 | 4 | ODR/200
ODR400 | 5 | ODR/400
ODR800 | 6 | ODR/800
ODR1600 | 7 | ODR/1600
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeOrientConfInt3d Enumeration

IRD

Adxl346TypeOrientConfInt3d Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOrientConfInt3d
Public Enumeration TypeOrientConfInt3d
public enum class TypeOrientConfInt3d
type TypeOrientConfInt3d
Members
Member name | Value | Description
Value_2D | 0 | 2D
Value_3D | 1 | 3D
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeOrientConfIntOrient Enumeration

IRD

Adxl346TypeOrientConfIntOrient Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOrientConfIntOrient
Public Enumeration TypeOrientConfIntOrient
public enum class TypeOrientConfIntOrient
type TypeOrientConfIntOrient
Members
Member name | Value | Description
OrientationInterruptDisabled | 0 | Orientation interrupt disabled
OrientationInterruptEnabled | 1 | Orientation interrupt enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeOrientV2 Enumeration

IRD

Adxl346TypeOrientV2 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOrientV2
Public Enumeration TypeOrientV2
public enum class TypeOrientV2
type TypeOrientV2
Members
Member name | Value | Description
Value_2DOrientationNotValid | 0 | 2D orientation not valid
Value_2DOrientationValid | 1 | 2D orientation valid
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeOrientV3 Enumeration

IRD

Adxl346TypeOrientV3 Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOrientV3
Public Enumeration TypeOrientV3
public enum class TypeOrientV3
type TypeOrientV3
Members
Member name | Value | Description
Value_3DOrientationNotValid | 0 | 3D orientation not valid
Value_3DOrientationValid | 1 | 3D orientation valid
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypePowerCtlAutoSleep Enumeration

IRD

Adxl346TypePowerCtlAutoSleep Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlAutoSleep
Public Enumeration TypePowerCtlAutoSleep
public enum class TypePowerCtlAutoSleep
type TypePowerCtlAutoSleep
Members
Member name | Value | Description
DisableAutomaticSwitchingToSleepMode | 0 | Disable automatic switching to sleep mode
SwitchToSleepModeWhenInactivityIsDetected | 1 | Switch to sleep mode when inactivity is detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypePowerCtlLink Enumeration

IRD

Adxl346TypePowerCtlLink Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlLink
Public Enumeration TypePowerCtlLink
public enum class TypePowerCtlLink
type TypePowerCtlLink
Members
Member name | Value | Description
InactivityAndActivityFunctionsAreConcurrent | 0 | Inactivity and activity functions are concurrent
DelaysTheStartOfTheActivityFunctionUntilInactivityIsDetected | 1 | Delays the start of the activity function until inactivity is detected
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypePowerCtlMeasure Enumeration

IRD

Adxl346TypePowerCtlMeasure Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlMeasure
Public Enumeration TypePowerCtlMeasure
public enum class TypePowerCtlMeasure
type TypePowerCtlMeasure
Members
Member name | Value | Description
StandbyMode | 0 | Standby mode
MeasurementMode | 1 | Measurement mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypePowerCtlSleep Enumeration

IRD

Adxl346TypePowerCtlSleep Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlSleep
Public Enumeration TypePowerCtlSleep
public enum class TypePowerCtlSleep
type TypePowerCtlSleep
Members
Member name | Value | Description
NormalOperation | 0 | Normal operation
SleepMode | 1 | Sleep mode
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypePowerCtlWakeup Enumeration

IRD

Adxl346TypePowerCtlWakeup Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerCtlWakeup
Public Enumeration TypePowerCtlWakeup
public enum class TypePowerCtlWakeup
type TypePowerCtlWakeup
Members
Member name | Value | Description
FrequencyReadingInSleepMode8Hz | 0 | Frequency reading in sleep mode: 8 Hz
FrequencyReadingInSleepMode4Hz | 1 | Frequency reading in sleep mode: 4 Hz
FrequencyReadingInSleepMode2Hz | 2 | Frequency reading in sleep mode: 2 Hz
FrequencyReadingInSleepMode1Hz | 3 | Frequency reading in sleep mode: 1 Hz
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeTapAxesImprovedTap Enumeration

IRD

Adxl346TypeTapAxesImprovedTap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapAxesImprovedTap
Public Enumeration TypeTapAxesImprovedTap
public enum class TypeTapAxesImprovedTap
type TypeTapAxesImprovedTap
Members
Member name | Value | Description
ImprovedTapDetectionDisabled | 0 | Improved tap detection disabled
ImprovedTapDetectionEnabled | 1 | Improved tap detection enabled
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeTapAxesSuppress Enumeration

IRD

Adxl346TypeTapAxesSuppress Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapAxesSuppress
Public Enumeration TypeTapAxesSuppress
public enum class TypeTapAxesSuppress
type TypeTapAxesSuppress
Members
Member name | Value | Description
DoubleTapDetectionPossible | 0 | Double tap detection possible
DoubleTapDetectionSuppressed | 1 | Double tap detection suppressed
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeTapAxesTapXEn Enumeration

IRD

Adxl346TypeTapAxesTapXEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapAxesTapXEn
Public Enumeration TypeTapAxesTapXEn
public enum class TypeTapAxesTapXEn
type TypeTapAxesTapXEn
Members
Member name | Value | Description
ExcludesXAxisFromParticipation | 0 | Excludes x-axis from participation
EnableXAxisParticipationInTapDetection | 1 | Enable x-axis participation in tap detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeTapAxesTapYEn Enumeration

IRD

Adxl346TypeTapAxesTapYEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapAxesTapYEn
Public Enumeration TypeTapAxesTapYEn
public enum class TypeTapAxesTapYEn
type TypeTapAxesTapYEn
Members
Member name | Value | Description
ExcludesYAxisFromParticipation | 0 | Excludes y-axis from participation
EnableYAxisParticipationInTapDetection | 1 | Enable y-axis participation in tap detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeTapAxesTapZEn Enumeration

IRD

Adxl346TypeTapAxesTapZEn Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapAxesTapZEn
Public Enumeration TypeTapAxesTapZEn
public enum class TypeTapAxesTapZEn
type TypeTapAxesTapZEn
Members
Member name | Value | Description
ExcludesZAxisFromParticipation | 0 | Excludes z-axis from participation
EnableZAxisParticipationInTapDetection | 1 | Enable z-axis participation in tap detection
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeTapSignXsign Enumeration

IRD

Adxl346TypeTapSignXsign Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapSignXsign
Public Enumeration TypeTapSignXsign
public enum class TypeTapSignXsign
type TypeTapSignXsign
Members
Member name | Value | Description
AccelerationInTheNegativeXAxisDirection | 0 | Acceleration in the negative x-axis direction
AccelerationInThePositiveXAxisDirection | 1 | Acceleration in the positive x-axis direction
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeTapSignXtap Enumeration

IRD

Adxl346TypeTapSignXtap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapSignXtap
Public Enumeration TypeTapSignXtap
public enum class TypeTapSignXtap
type TypeTapSignXtap
Members
Member name | Value | Description
NoInvolvementOfXAxisInTapEvent | 0 | No involvement of x-axis in tap-event
InvolvementOfXAxisInTapEvent | 1 | Involvement of x-axis in tap-event
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeTapSignYsign Enumeration

IRD

Adxl346TypeTapSignYsign Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapSignYsign
Public Enumeration TypeTapSignYsign
public enum class TypeTapSignYsign
type TypeTapSignYsign
Members
Member name | Value | Description
AccelerationInTheNegativeYAxisDirection | 0 | Acceleration in the negative y-axis direction
AccelerationInThePositiveYAxisDirection | 1 | Acceleration in the positive y-axis direction
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeTapSignYtap Enumeration

IRD

Adxl346TypeTapSignYtap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapSignYtap
Public Enumeration TypeTapSignYtap
public enum class TypeTapSignYtap
type TypeTapSignYtap
Members
Member name | Value | Description
NoInvolvementOfYAxisInTapEvent | 0 | No involvement of y-axis in tap-event
InvolvementOfYAxisInTapEvent | 1 | Involvement of y-axis in tap-event
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeTapSignZsign Enumeration

IRD

Adxl346TypeTapSignZsign Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapSignZsign
Public Enumeration TypeTapSignZsign
public enum class TypeTapSignZsign
type TypeTapSignZsign
Members
Member name | Value | Description
AccelerationInTheNegativeZAxisDirection | 0 | Acceleration in the negative z-axis direction
AccelerationInThePositiveZAxisDirection | 1 | Acceleration in the positive z-axis direction
See Also

Reference

telos.Ird.AnalogDevices Namespace


Adxl346.TypeTapSignZtap Enumeration

IRD

Adxl346TypeTapSignZtap Enumeration

Namespace: telos.Ird.AnalogDevices
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTapSignZtap
Public Enumeration TypeTapSignZtap
public enum class TypeTapSignZtap
type TypeTapSignZtap
Members
Member name | Value | Description
NoInvolvementOfZAxisInTapEvent | 0 | No involvement of z-axis in tap-event
InvolvementOfZAxisInTapEvent | 1 | Involvement of z-axis in tap-event
See Also

Reference

telos.Ird.AnalogDevices Namespace


telos.Ird.FreescaleSemiconductor Namespace

Classes
 | Class | Description
Public class | Fxos8700cq | Freescale Semiconductor: FXOS 8700CQ
Public class | Mma7455l | Freescale Semiconductor: MMA 7455L
Public class | Mpl115a2 | Freescale Semiconductor: MPL 115A2
Enumerations
 | Enumeration | Description
Public enumeration | Fxos8700cqTypeAFfmtCfgAFfmtEle |
Public enumeration | Fxos8700cqTypeAFfmtCfgAFfmtOae |
Public enumeration | Fxos8700cqTypeAFfmtCfgAFfmtXyzefe |
Public enumeration | Fxos8700cqTypeAFfmtSrcAFfmtEa |
Public enumeration | Fxos8700cqTypeAFfmtSrcAFfmtXhe |
Public enumeration | Fxos8700cqTypeAFfmtSrcAFfmtXhp |
Public enumeration | Fxos8700cqTypeAFfmtSrcAFfmtYhe |
Public enumeration | Fxos8700cqTypeAFfmtSrcAFfmtYhp |
Public enumeration | Fxos8700cqTypeAFfmtSrcAFfmtZhe |
Public enumeration | Fxos8700cqTypeAFfmtSrcAFfmtZhp |
Public enumeration | Fxos8700cqTypeAFfmtThsAFfmtDbcntm |
Public enumeration | Fxos8700cqTypeAVecmCfgAVecmEle |
Public enumeration | Fxos8700cqTypeAVecmCfgAVecmEn |
Public enumeration | Fxos8700cqTypeAVecmCfgAVecmInitm |
Public enumeration | Fxos8700cqTypeAVecmCfgAVecmUpdm |
Public enumeration | Fxos8700cqTypeAVecmThsAVecmDbcntm |
Public enumeration | Fxos8700cqTypeCtrlReg1Active |
Public enumeration | Fxos8700cqTypeCtrlReg1AslpRate |
Public enumeration | Fxos8700cqTypeCtrlReg1FRead |
Public enumeration | Fxos8700cqTypeCtrlReg1Inoise |
Public enumeration | Fxos8700cqTypeCtrlReg2Mods |
Public enumeration | Fxos8700cqTypeCtrlReg2Rst |
Public enumeration | Fxos8700cqTypeCtrlReg2Slpe |
Public enumeration | Fxos8700cqTypeCtrlReg2Smods |
Public enumeration | Fxos8700cqTypeCtrlReg2St |
Public enumeration | Fxos8700cqTypeCtrlReg3FifoGate |
Public enumeration | Fxos8700cqTypeCtrlReg3WakeAVecm |
Public enumeration | Fxos8700cqTypeCtrlReg3WakeFfmt |
Public enumeration | Fxos8700cqTypeCtrlReg3WakeIpol |
Public enumeration | Fxos8700cqTypeCtrlReg3WakeLndprt |
Public enumeration | Fxos8700cqTypeCtrlReg3WakePpOd |
Public enumeration | Fxos8700cqTypeCtrlReg3WakePulse |
Public enumeration | Fxos8700cqTypeCtrlReg3WakeTran |
Public enumeration | Fxos8700cqTypeCtrlReg4IntEnAslp |
Public enumeration | Fxos8700cqTypeCtrlReg4IntEnAVecm |
Public enumeration | Fxos8700cqTypeCtrlReg4IntEnDrdy |
Public enumeration | Fxos8700cqTypeCtrlReg4IntEnFfmt |
Public enumeration | Fxos8700cqTypeCtrlReg4IntEnFifo |
Public enumeration | Fxos8700cqTypeCtrlReg4IntEnLndprt |
Public enumeration | Fxos8700cqTypeCtrlReg4IntEnPulse |
Public enumeration | Fxos8700cqTypeCtrlReg4IntEnTrans |
Public enumeration | Fxos8700cqTypeCtrlReg5IntCfgAslp |
Public enumeration | Fxos8700cqTypeCtrlReg5IntCfgAVecm |
Public enumeration | Fxos8700cqTypeCtrlReg5IntCfgDrdy |
Public enumeration | Fxos8700cqTypeCtrlReg5IntCfgFfmt |
Public enumeration | Fxos8700cqTypeCtrlReg5IntCfgFifo |
Public enumeration | Fxos8700cqTypeCtrlReg5IntCfgLndprt |
Public enumeration | Fxos8700cqTypeCtrlReg5IntCfgPulse |
Public enumeration | Fxos8700cqTypeCtrlReg5IntCfgTrans |
Public enumeration | Fxos8700cqTypeFSetupFMode |
Public enumeration | Fxos8700cqTypeHpFilterCutoffPulseHpfByp |
Public enumeration | Fxos8700cqTypeHpFilterCutoffPulseLpfEn |
Public enumeration | Fxos8700cqTypeIntSource |
Public enumeration | Fxos8700cqTypeMCtrlReg1MAcal |
Public enumeration | Fxos8700cqTypeMCtrlReg1MHms |
Public enumeration | Fxos8700cqTypeMCtrlReg1MOst |
Public enumeration | Fxos8700cqTypeMCtrlReg1MRst |
Public enumeration | Fxos8700cqTypeMCtrlReg2MMaxminCnt |
Public enumeration | Fxos8700cqTypeMCtrlReg2MMaxminDis |
Public enumeration | Fxos8700cqTypeMCtrlReg2MMaxminDisThs |
Public enumeration | Fxos8700cqTypeMCtrlReg2MMaxminRst |
Public enumeration | Fxos8700cqTypeMCtrlReg3MRaw |
Public enumeration | Fxos8700cqTypeMCtrlReg3MStXy |
Public enumeration | Fxos8700cqTypeMCtrlReg3MStZ |
Public enumeration | Fxos8700cqTypeMCtrlReg3MThsXyzUpdate |
Public enumeration | Fxos8700cqTypeMDrStatusXdr |
Public enumeration | Fxos8700cqTypeMDrStatusXow |
Public enumeration | Fxos8700cqTypeMDrStatusYdr |
Public enumeration | Fxos8700cqTypeMDrStatusYow |
Public enumeration | Fxos8700cqTypeMDrStatusZdr |
Public enumeration | Fxos8700cqTypeMDrStatusZow |
Public enumeration | Fxos8700cqTypeMDrStatusZyxdr |
Public enumeration | Fxos8700cqTypeMDrStatusZyxow |
Public enumeration | Fxos8700cqTypeMIntSrcSrcMDrdy |
Public enumeration | Fxos8700cqTypeMIntSrcSrcMThs |
Public enumeration | Fxos8700cqTypeMIntSrcSrcMVecm |
Public enumeration | Fxos8700cqTypeMThsCfgMThsEle |
Public enumeration | Fxos8700cqTypeMThsCfgMThsIntCfg |
Public enumeration | Fxos8700cqTypeMThsCfgMThsIntEn |
Public enumeration | Fxos8700cqTypeMThsCfgMThsOae |
Public enumeration | Fxos8700cqTypeMThsCfgMThsWakeEn |
Public enumeration | Fxos8700cqTypeMThsCfgMThsXefe |
Public enumeration | Fxos8700cqTypeMThsCfgMThsYefe |
Public enumeration | Fxos8700cqTypeMThsCfgMThsZefe |
Public enumeration | Fxos8700cqTypeMThsSrcMThsEa |
Public enumeration | Fxos8700cqTypeMThsSrcMThsXhe |
Public enumeration | Fxos8700cqTypeMThsSrcMThsXhp |
Public enumeration | Fxos8700cqTypeMThsSrcMThsYhe |
Public enumeration | Fxos8700cqTypeMThsSrcMThsYhp |
Public enumeration | Fxos8700cqTypeMThsSrcMThsZhe |
Public enumeration | Fxos8700cqTypeMThsSrcMThsZhp |
Public enumeration | Fxos8700cqTypeMThsXMThsDbcntm |
Public enumeration | Fxos8700cqTypeMVecmCfgMVecmEle |
Public enumeration | Fxos8700cqTypeMVecmCfgMVecmEn |
Public enumeration | Fxos8700cqTypeMVecmCfgMVecmInitm |
Public enumeration | Fxos8700cqTypeMVecmCfgMVecmIntCfg |
Public enumeration | Fxos8700cqTypeMVecmCfgMVecmIntEn |
Public enumeration | Fxos8700cqTypeMVecmCfgMVecmUpdm |
Public enumeration | Fxos8700cqTypeMVecmCfgMVecmWakeEn |
Public enumeration | Fxos8700cqTypePlBfZcompZlock |
Public enumeration | Fxos8700cqTypePlCfgDbcntm |
Public enumeration | Fxos8700cqTypePlCfgPlEn |
Public enumeration | Fxos8700cqTypePlStatusBafro |
Public enumeration | Fxos8700cqTypePlStatusIo |
Public enumeration | Fxos8700cqTypePlStatusLapo |
Public enumeration | Fxos8700cqTypePlStatusNewlp |
Public enumeration | Fxos8700cqTypePlThsRegHys |
Public enumeration | Fxos8700cqTypePlThsRegPlThs |
Public enumeration | Fxos8700cqTypePulseCfgPlsDpa |
Public enumeration | Fxos8700cqTypePulseCfgPlsEle |
Public enumeration | Fxos8700cqTypePulseCfgPlsXdpefe |
Public enumeration | Fxos8700cqTypePulseCfgPlsXspefe |
Public enumeration | Fxos8700cqTypePulseCfgPlsYdpefe |
Public enumeration | Fxos8700cqTypePulseCfgPlsYspefe |
Public enumeration | Fxos8700cqTypePulseCfgPlsZdpefe |
Public enumeration | Fxos8700cqTypePulseCfgPlsZspefe |
Public enumeration | Fxos8700cqTypePulseSrcPlsSrcAxx |
Public enumeration | Fxos8700cqTypePulseSrcPlsSrcAxy |
Public enumeration | Fxos8700cqTypePulseSrcPlsSrcAxz |
Public enumeration | Fxos8700cqTypePulseSrcPlsSrcDpe |
Public enumeration | Fxos8700cqTypePulseSrcPlsSrcEa |
Public enumeration | Fxos8700cqTypePulseSrcPlsSrcPolx |
Public enumeration | Fxos8700cqTypePulseSrcPlsSrcPoly |
Public enumeration | Fxos8700cqTypePulseSrcPlsSrcPolz |
Public enumeration | Fxos8700cqTypeSysmodFgerr |
Public enumeration | Fxos8700cqTypeSysmodSysmode |
Public enumeration | Fxos8700cqTypeTransientCfgTranEle |
Public enumeration | Fxos8700cqTypeTransientCfgTranHpfByp |
Public enumeration | Fxos8700cqTypeTransientCfgTranXefe |
Public enumeration | Fxos8700cqTypeTransientCfgTranYefe |
Public enumeration | Fxos8700cqTypeTransientCfgTranZefe |
Public enumeration | Fxos8700cqTypeTransientSrcTranEa |
Public enumeration | Fxos8700cqTypeTransientSrcTranXef |
Public enumeration | Fxos8700cqTypeTransientSrcTranXpol |
Public enumeration | Fxos8700cqTypeTransientSrcTranYef |
Public enumeration | Fxos8700cqTypeTransientSrcTranYpol |
Public enumeration | Fxos8700cqTypeTransientSrcTranZef |
Public enumeration | Fxos8700cqTypeTransientSrcTranZpol |
Public enumeration | Fxos8700cqTypeTransientThsTrDbcntm |
Public enumeration | Fxos8700cqTypeTrigCfg |
Public enumeration | Fxos8700cqTypeXyzDataCfgFs |
Public enumeration | Fxos8700cqTypeXyzDataCfgHpfOut |
Public enumeration | Mma7455lTypeControl1Dfbw |
Public enumeration | Mma7455lTypeControl1Intpin |
Public enumeration | Mma7455lTypeControl1Intreg |
Public enumeration | Mma7455lTypeControl1Thopt |
Public enumeration | Mma7455lTypeControl1Xda |
Public enumeration | Mma7455lTypeControl1Yda |
Public enumeration | Mma7455lTypeControl1Zda |
Public enumeration | Mma7455lTypeControl2Drvo |
Public enumeration | Mma7455lTypeControl2Ldpl |
Public enumeration | Mma7455lTypeControl2Pdpl |
Public enumeration | Mma7455lTypeDetectionInt |
Public enumeration | Mma7455lTypeDetectionSourceLdx |
Public enumeration | Mma7455lTypeDetectionSourceLdy |
Public enumeration | Mma7455lTypeDetectionSourceLdz |
Public enumeration | Mma7455lTypeDetectionSourcePdx |
Public enumeration | Mma7455lTypeDetectionSourcePdy |
Public enumeration | Mma7455lTypeDetectionSourcePdz |
Public enumeration | Mma7455lTypeI2cDeviceAddressI2cdis |
Public enumeration | Mma7455lTypeInterruptLatchResetClrInt1 |
Public enumeration | Mma7455lTypeInterruptLatchResetClrInt2 |
Public enumeration | Mma7455lTypeModeControlDrpd |
Public enumeration | Mma7455lTypeModeControlGlvl |
Public enumeration | Mma7455lTypeModeControlMode |
Public enumeration | Mma7455lTypeModeControlSpi3w |
Public enumeration | Mma7455lTypeModeControlSton |
Public enumeration | Mma7455lTypeStatusDovr |
Public enumeration | Mma7455lTypeStatusDrdy |
Public enumeration | Mma7455lTypeStatusPerr |


Fxos8700cq Class

Freescale Semiconductor: FXOS 8700CQ
Inheritance Hierarchy
SystemObject
telos.Ird.FreescaleSemiconductorFxos8700cq

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Fxos8700cq
Public Class Fxos8700cq
public ref class Fxos8700cq
type Fxos8700cq =  class end

The Fxos8700cq type exposes the following members.

Constructors
 | Name | Description
Public method | Fxos8700cq | Constructor
Top
Properties
 | Name | Description
Public property | AFFMTCFGAFFMTELE | A_FFMT_CFG: A_FFMT_ELE
Public property | AFFMTCFGAFFMTOAE | A_FFMT_CFG: A_FFMT_OAE
Public property | AFFMTCFGAFFMTXEFE | A_FFMT_CFG: A_FFMT_XEFE
Public property | AFFMTCFGAFFMTYEFE | A_FFMT_CFG: A_FFMT_YEFE
Public property | AFFMTCFGAFFMTZEFE | A_FFMT_CFG: A_FFMT_ZEFE
Public property | AFFMTCOUNT | A_FFMT_COUNT
Public property | AFFMTSRCAFFMTEA | A_FFMT_SRC: A_FFMT_EA
Public property | AFFMTSRCAFFMTXHE | A_FFMT_SRC: A_FFMT_XHE
Public property | AFFMTSRCAFFMTXHP | A_FFMT_SRC: A_FFMT_XHP
Public property | AFFMTSRCAFFMTYHE | A_FFMT_SRC: A_FFMT_YHE
Public property | AFFMTSRCAFFMTYHP | A_FFMT_SRC: A_FFMT_YHP
Public property | AFFMTSRCAFFMTZHE | A_FFMT_SRC: A_FFMT_ZHE
Public property | AFFMTSRCAFFMTZHP | A_FFMT_SRC: A_FFMT_ZHP
Public property | AFFMTTHSAFFMTDBCNTM | A_FFMT_THS: A_FFMT_DBCNTM
Public property | AFFMTTHSTHS | A_FFMT_THS: THS (unit: mg)
Public property | AFFMTTHSXAFFMTTHSX | A_FFMT_THS_X: A_FFMT_THS_X
Public property | AFFMTTHSXAFFMTTHSXYZEN | A_FFMT_THS_X: A_FFMT_THS_XYZ_EN
Public property | AFFMTTHSY | A_FFMT_THS_Y
Public property | AFFMTTHSZ | A_FFMT_THS_Z
Public property | ASLPCOUNT | ASLP_COUNT
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AVECMCFGAVECMELE | A_VECM_CFG: A_VECM_ELE
Public property | AVECMCFGAVECMEN | A_VECM_CFG: A_VECM_EN
Public property | AVECMCFGAVECMINITM | A_VECM_CFG: A_VECM_INITM
Public property | AVECMCFGAVECMUPDM | A_VECM_CFG: A_VECM_UPDM
Public property | AVECMCNT | A_VECM_CNT
Public property | AVECMINITX | A_VECM_INITX
Public property | AVECMINITY | A_VECM_INITY
Public property | AVECMINITZ | A_VECM_INITZ
Public property | AVECMTHSAVECMDBCNTM | A_VECM_THS: A_VECM_DBCNTM
Public property | AVECMTHSAVECMTHS | A_VECM_THS: A_VECM_THS
Public property | CMPX | CMP_X
Public property | CMPY | CMP_Y
Public property | CMPZ | CMP_Z
Public property | CTRLREG1ACTIVE | CTRL_REG1: ACTIVE
Public property | CTRLREG1ASLPRATE | CTRL_REG1: ASLP_RATE (unit: Hz)
Public property | CTRLREG1DR | CTRL_REG1: DR
Public property | CTRLREG1FREAD | CTRL_REG1: F_READ
Public property | CTRLREG1INOISE | CTRL_REG1: INOISE
Public property | CTRLREG2MODS | CTRL_REG2: MODS
Public property | CTRLREG2RST | CTRL_REG2: RST
Public property | CTRLREG2SLPE | CTRL_REG2: SLPE
Public property | CTRLREG2SMODS | CTRL_REG2: SMODS
Public property | CTRLREG2ST | CTRL_REG2: ST
Public property | CTRLREG3FIFOGATE | CTRL_REG3: FIFO_GATE
Public property | CTRLREG3IPOL | CTRL_REG3: IPOL
Public property | CTRLREG3PPOD | CTRL_REG3: PP_OD
Public property | CTRLREG3WAKEAVECM | CTRL_REG3: WAKE_A_VECM
Public property | CTRLREG3WAKEFFMT | CTRL_REG3: WAKE_FFMT
Public property | CTRLREG3WAKELNDPRT | CTRL_REG3: WAKE_LNDPRT
Public property | CTRLREG3WAKEPULSE | CTRL_REG3: WAKE_PULSE
Public property | CTRLREG3WAKETRAN | CTRL_REG3: WAKE_TRAN
Public property | CTRLREG4INTENASLP | CTRL_REG4: INT_EN_ASLP
Public property | CTRLREG4INTENAVECM | CTRL_REG4: INT_EN_A_VECM
Public property | CTRLREG4INTENDRDY | CTRL_REG4: INT_EN_DRDY
Public property | CTRLREG4INTENFFMT | CTRL_REG4: INT_EN_FFMT
Public property | CTRLREG4INTENFIFO | CTRL_REG4: INT_EN_FIFO
Public property | CTRLREG4INTENLNDPRT | CTRL_REG4: INT_EN_LNDPRT
Public property | CTRLREG4INTENPULSE | CTRL_REG4: INT_EN_PULSE
Public property | CTRLREG4INTENTRANS | CTRL_REG4: INT_EN_TRANS
Public property | CTRLREG5INTCFGASLP | CTRL_REG5: INT_CFG_ASLP
Public property | CTRLREG5INTCFGAVECM | CTRL_REG5: INT_CFG_A_VECM
Public property | CTRLREG5INTCFGDRDY | CTRL_REG5: INT_CFG_DRDY
Public property | CTRLREG5INTCFGFFMT | CTRL_REG5: INT_CFG_FFMT
Public property | CTRLREG5INTCFGFIFO | CTRL_REG5: INT_CFG_FIFO
Public property | CTRLREG5INTCFGLNDPRT | CTRL_REG5: INT_CFG_LNDPRT
Public property | CTRLREG5INTCFGPULSE | CTRL_REG5: INT_CFG_PULSE
Public property | CTRLREG5INTCFGTRANS | CTRL_REG5: INT_CFG_TRANS
Public property | FSETUPFMODE | F_SETUP: F_MODE
Public property | FSETUPFWMRK | F_SETUP: F_WMRK
Public property | HPFILTERCUTOFFPULSEHPFBYP | HP_FILTER_CUTOFF: PULSE_HPF_BYP
Public property | HPFILTERCUTOFFPULSELPFEN | HP_FILTER_CUTOFF: PULSE_LPF_EN
Public property | HPFILTERCUTOFFSEL | HP_FILTER_CUTOFF: SEL
Public property | INTSOURCESRCASLP | INT_SOURCE: SRC_ASLP
Public property | INTSOURCESRCAVECM | INT_SOURCE: SRC_A_VECM
Public property | INTSOURCESRCDRDY | INT_SOURCE: SRC_DRDY
Public property | INTSOURCESRCFFMT | INT_SOURCE: SRC_FFMT
Public property | INTSOURCESRCFIFO | INT_SOURCE: SRC_FIFO
Public property | INTSOURCESRCINDPRT | INT_SOURCE: SRC_INDPRT
Public property | INTSOURCESRCPULSE | INT_SOURCE: SRC_PULSE
Public property | INTSOURCESRCTRANS | INT_SOURCE: SRC_TRANS
Public property | MAXX | MAX_X (unit: μT)
Public property | MAXY | MAX_Y (unit: μT)
Public property | MAXZ | MAX_Z (unit: μT)
Public property | MCTRLREG1MACAL | M_CTRL_REG1: M_ACAL
Public property | MCTRLREG1MHMS | M_CTRL_REG1: M_HMS
Public property | MCTRLREG1MOS | M_CTRL_REG1: M_OS
Public property | MCTRLREG1MOST | M_CTRL_REG1: M_OST
Public property | MCTRLREG1MRST | M_CTRL_REG1: M_RST
Public property | MCTRLREG2HYBAUTOINCMODE | M_CTRL_REG2: HYB_AUTOINC_MODE
Public property | MCTRLREG2MMAXMINCNT | M_CTRL_REG2: M_MAXMIN_CNT
Public property | MCTRLREG2MMAXMINDIS | M_CTRL_REG2: M_MAXMIN_DIS
Public property | MCTRLREG2MMAXMINDISTHS | M_CTRL_REG2: M_MAXMIN_DIS_THS
Public property | MCTRLREG2MMAXMINRST | M_CTRL_REG2: M_MAXMIN_RST
Public property | MCTRLREG3MASLPOS | M_CTRL_REG3: M_ASLP_OS
Public property | MCTRLREG3MRAW | M_CTRL_REG3: M_RAW
Public property | MCTRLREG3MSTXY | M_CTRL_REG3: M_ST_XY
Public property | MCTRLREG3MSTZ | M_CTRL_REG3: M_ST_Z
Public property | MCTRLREG3MTHSXYZUPDATE | M_CTRL_REG3: M_THS_XYZ_UPDATE
Public property | MDRSTATUSXDR | M_DR_STATUS: XDR
Public property | MDRSTATUSXOW | M_DR_STATUS: XOW
Public property | MDRSTATUSYDR | M_DR_STATUS: YDR
Public property | MDRSTATUSYOW | M_DR_STATUS: YOW
Public property | MDRSTATUSZDR | M_DR_STATUS: ZDR
Public property | MDRSTATUSZOW | M_DR_STATUS: ZOW
Public property | MDRSTATUSZYXDR | M_DR_STATUS: ZYXDR
Public property | MDRSTATUSZYXOW | M_DR_STATUS: ZYXOW
Public property | MINTSRCSRCMDRDY | M_INT_SRC: SRC_M_DRDY
Public property | MINTSRCSRCMTHS | M_INT_SRC: SRC_M_THS
Public property | MINTSRCSRCMVECM | M_INT_SRC: SRC_M_VECM
Public property | MINX | MIN_X (unit: μT)
Public property | MINY | MIN_Y (unit: μT)
Public property | MINZ | MIN_Z (unit: μT)
Public property | MOFFX | M_OFF_X (unit: μT)
Public property | MOFFY | M_OFF_Y (unit: μT)
Public property | MOFFZ | M_OFF_Z (unit: μT)
Public property | MOUTX | M_OUT_X (unit: μT)
Public property | MOUTY | M_OUT_Y (unit: μT)
Public property | MOUTZ | M_OUT_Z (unit: μT)
Public property | MTHSCFGMTHSELE | M_THS_CFG: M_THS_ELE
Public property | MTHSCFGMTHSINTCFG | M_THS_CFG: M_THS_INT_CFG
Public property | MTHSCFGMTHSINTEN | M_THS_CFG: M_THS_INT_EN
Public property | MTHSCFGMTHSOAE | M_THS_CFG: M_THS_OAE
Public property | MTHSCFGMTHSWAKEEN | M_THS_CFG: M_THS_WAKE_EN
Public property | MTHSCFGMTHSXEFE | M_THS_CFG: M_THS_XEFE
Public property | MTHSCFGMTHSYEFE | M_THS_CFG: M_THS_YEFE
Public property | MTHSCFGMTHSZEFE | M_THS_CFG: M_THS_ZEFE
Public property | MTHSCOUNT | M_THS_COUNT
Public property | MTHSSRCMTHSEA | M_THS_SRC: M_THS_EA
Public property | MTHSSRCMTHSXHE | M_THS_SRC: M_THS_XHE
Public property | MTHSSRCMTHSXHP | M_THS_SRC: M_THS_XHP
Public property | MTHSSRCMTHSYHE | M_THS_SRC: M_THS_YHE
Public property | MTHSSRCMTHSYHP | M_THS_SRC: M_THS_YHP
Public property | MTHSSRCMTHSZHE | M_THS_SRC: M_THS_ZHE
Public property | MTHSSRCMTHSZHP | M_THS_SRC: M_THS_ZHP
Public property | MTHSXMTHSDBCNTM | M_THS_X: M_THS_DBCNTM
Public property | MTHSXMTHSX | M_THS_X: M_THS_X (unit: μT)
Public property | MTHSY | M_THS_Y (unit: μT)
Public property | MTHSZ | M_THS_Z (unit: μT)
Public property | MVECMCFGMVECMELE | M_VECM_CFG: M_VECM_ELE
Public property | MVECMCFGMVECMEN | M_VECM_CFG: M_VECM_EN
Public property | MVECMCFGMVECMINITM | M_VECM_CFG: M_VECM_INITM
Public property | MVECMCFGMVECMINTCFG | M_VECM_CFG: M_VECM_INT_CFG
Public property | MVECMCFGMVECMINTEN | M_VECM_CFG: M_VECM_INT_EN
Public property | MVECMCFGMVECMUPDM | M_VECM_CFG: M_VECM_UPDM
Public property | MVECMCFGMVECMWAKEEN | M_VECM_CFG: M_VECM_WAKE_EN
Public property | MVECMCNT | M_VECM_CNT
Public property | MVECMINITX | M_VECM_INITX
Public property | MVECMINITY | M_VECM_INITY
Public property | MVECMINITZ | M_VECM_INITZ
Public property | MVECMTHSMVECMDBCNTM | M_VECM_THS: M_VECM_DBCNTM
Public property | MVECMTHSMVECMTHS | M_VECM_THS: M_VECM_THS (unit: μT)
Public property | OFFX | OFF_X
Public property | OFFY | OFF_Y
Public property | OFFZ | OFF_Z
Public property | OUTX | OUT_X
Public property | OUTY | OUT_Y
Public property | OUTZ | OUT_Z
Public property | PLBFZCOMPBKFR | PL_BF_ZCOMP: BKFR
Public property | PLBFZCOMPZLOCK | PL_BF_ZCOMP: ZLOCK
Public property | PLCFGDBCNTM | PL_CFG: DBCNTM
Public property | PLCFGPLEN | PL_CFG: PL_EN
Public property | PLCOUNTDBNCE | PL_COUNT: DBNCE
Public property | PLSTATUSBAFRO | PL_STATUS: BAFRO
Public property | PLSTATUSIO | PL_STATUS: IO
Public property | PLSTATUSLAPO | PL_STATUS: LAPO
Public property | PLSTATUSNEWLP | PL_STATUS: NEWLP
Public property | PLTHSREGHYS | PL_THS_REG: HYS
Public property | PLTHSREGPLTHS | PL_THS_REG: PL_THS
Public property | PULSECFGPLSDPA | PULSE_CFG: PLS_DPA
Public property | PULSECFGPLSELE | PULSE_CFG: PLS_ELE
Public property | PULSECFGPLSXDPEFE | PULSE_CFG: PLS_XDPEFE
Public property | PULSECFGPLSXSPEFE | PULSE_CFG: PLS_XSPEFE
Public property | PULSECFGPLSYDPEFE | PULSE_CFG: PLS_YDPEFE
Public property | PULSECFGPLSYSPEFE | PULSE_CFG: PLS_YSPEFE
Public property | PULSECFGPLSZDPEFE | PULSE_CFG: PLS_ZDPEFE
Public property | PULSECFGPLSZSPEFE | PULSE_CFG: PLS_ZSPEFE
Public property | PULSELTCY | PULSE_LTCY
Public property | PULSESRCPLSSRCAXX | PULSE_SRC: PLS_SRC_AXX
Public property | PULSESRCPLSSRCAXY | PULSE_SRC: PLS_SRC_AXY
Public property | PULSESRCPLSSRCAXZ | PULSE_SRC: PLS_SRC_AXZ
Public property | PULSESRCPLSSRCDPE | PULSE_SRC: PLS_SRC_DPE
Public property | PULSESRCPLSSRCEA | PULSE_SRC: PLS_SRC_EA
Public property | PULSESRCPLSSRCPOLX | PULSE_SRC: PLS_SRC_POLX
Public property | PULSESRCPLSSRCPOLY | PULSE_SRC: PLS_SRC_POLY
Public property | PULSESRCPLSSRCPOLZ | PULSE_SRC: PLS_SRC_POLZ
Public property | PULSETHSX | PULSE_THSX (unit: mg)
Public property | PULSETHSY | PULSE_THSY (unit: mg)
Public property | PULSETHSZ | PULSE_THSZ (unit: mg)
Public property | PULSETMLT | PULSE_TMLT
Public property | PULSEWIND | PULSE_WIND
Public property | STATUS | STATUS
Public property | SYSMODFGERR | SYSMOD: FGERR
Public property | SYSMODFGT | SYSMOD: FGT
Public property | SYSMODSYSMOD | SYSMOD: SYSMOD
Public property | TEMP | TEMP (unit: °C)
Public property | TRANSIENTCFGTRANELE | TRANSIENT_CFG: TRAN_ELE
Public property | TRANSIENTCFGTRANHPFBYP | TRANSIENT_CFG: TRAN_HPF_BYP
Public property | TRANSIENTCFGTRANXEFE | TRANSIENT_CFG: TRAN_XEFE
Public property | TRANSIENTCFGTRANYEFE | TRANSIENT_CFG: TRAN_YEFE
Public property | TRANSIENTCFGTRANZEFE | TRANSIENT_CFG: TRAN_ZEFE
Public property | TRANSIENTCOUNT | TRANSIENT_COUNT
Public property | TRANSIENTSRCTRANEA | TRANSIENT_SRC: TRAN_EA
Public property | TRANSIENTSRCTRANXEF | TRANSIENT_SRC: TRAN_XEF
Public property | TRANSIENTSRCTRANXPOL | TRANSIENT_SRC: TRAN_XPOL
Public property | TRANSIENTSRCTRANYEF | TRANSIENT_SRC: TRAN_YEF
Public property | TRANSIENTSRCTRANYPOL | TRANSIENT_SRC: TRAN_YPOL
Public property | TRANSIENTSRCTRANZEF | TRANSIENT_SRC: TRAN_ZEF
Public property | TRANSIENTSRCTRANZPOL | TRANSIENT_SRC: TRAN_ZPOL
Public property | TRANSIENTTHSTRDBCNTM | TRANSIENT_THS: TR_DBCNTM
Public property | TRANSIENTTHSTRTHS | TRANSIENT_THS: TR_THS (unit: mg)
Public property | TRIGCFGTRIGAVECM | TRIG_CFG: TRIG_A_VECM
Public property | TRIGCFGTRIGFFMT | TRIG_CFG: TRIG_FFMT
Public property | TRIGCFGTRIGINDPRT | TRIG_CFG: TRIG_INDPRT
Public property | TRIGCFGTRIGPULSE | TRIG_CFG: TRIG_PULSE
Public property | TRIGCFGTRIGTRANS | TRIG_CFG: TRIG_TRANS
Public property | WHOAMI | WHO_AM_I
Public property | XYZDATACFGFS | XYZ_DATA_CFG: FS
Public property | XYZDATACFGHPFOUT | XYZ_DATA_CFG: HPF_OUT
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
6-Axis Sensor with Integrated Linear Accelerometer and Magnetometer
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq Constructor

Constructor

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cq(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Fxos8700cq(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Fxos8700cq

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq Properties

The Fxos8700cq type exposes the following members.

Properties
 | Name | Description
Public property | AFFMTCFGAFFMTELE | A_FFMT_CFG: A_FFMT_ELE
Public property | AFFMTCFGAFFMTOAE | A_FFMT_CFG: A_FFMT_OAE
Public property | AFFMTCFGAFFMTXEFE | A_FFMT_CFG: A_FFMT_XEFE
Public property | AFFMTCFGAFFMTYEFE | A_FFMT_CFG: A_FFMT_YEFE
Public property | AFFMTCFGAFFMTZEFE | A_FFMT_CFG: A_FFMT_ZEFE
Public property | AFFMTCOUNT | A_FFMT_COUNT
Public property | AFFMTSRCAFFMTEA | A_FFMT_SRC: A_FFMT_EA
Public property | AFFMTSRCAFFMTXHE | A_FFMT_SRC: A_FFMT_XHE
Public property | AFFMTSRCAFFMTXHP | A_FFMT_SRC: A_FFMT_XHP
Public property | AFFMTSRCAFFMTYHE | A_FFMT_SRC: A_FFMT_YHE
Public property | AFFMTSRCAFFMTYHP | A_FFMT_SRC: A_FFMT_YHP
Public property | AFFMTSRCAFFMTZHE | A_FFMT_SRC: A_FFMT_ZHE
Public property | AFFMTSRCAFFMTZHP | A_FFMT_SRC: A_FFMT_ZHP
Public property | AFFMTTHSAFFMTDBCNTM | A_FFMT_THS: A_FFMT_DBCNTM
Public property | AFFMTTHSTHS | A_FFMT_THS: THS (unit: mg)
Public property | AFFMTTHSXAFFMTTHSX | A_FFMT_THS_X: A_FFMT_THS_X
Public property | AFFMTTHSXAFFMTTHSXYZEN | A_FFMT_THS_X: A_FFMT_THS_XYZ_EN
Public property | AFFMTTHSY | A_FFMT_THS_Y
Public property | AFFMTTHSZ | A_FFMT_THS_Z
Public property | ASLPCOUNT | ASLP_COUNT
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AVECMCFGAVECMELE | A_VECM_CFG: A_VECM_ELE
Public property | AVECMCFGAVECMEN | A_VECM_CFG: A_VECM_EN
Public property | AVECMCFGAVECMINITM | A_VECM_CFG: A_VECM_INITM
Public property | AVECMCFGAVECMUPDM | A_VECM_CFG: A_VECM_UPDM
Public property | AVECMCNT | A_VECM_CNT
Public property | AVECMINITX | A_VECM_INITX
Public property | AVECMINITY | A_VECM_INITY
Public property | AVECMINITZ | A_VECM_INITZ
Public property | AVECMTHSAVECMDBCNTM | A_VECM_THS: A_VECM_DBCNTM
Public property | AVECMTHSAVECMTHS | A_VECM_THS: A_VECM_THS
Public property | CMPX | CMP_X
Public property | CMPY | CMP_Y
Public property | CMPZ | CMP_Z
Public property | CTRLREG1ACTIVE | CTRL_REG1: ACTIVE
Public property | CTRLREG1ASLPRATE | CTRL_REG1: ASLP_RATE (unit: Hz)
Public property | CTRLREG1DR | CTRL_REG1: DR
Public property | CTRLREG1FREAD | CTRL_REG1: F_READ
Public property | CTRLREG1INOISE | CTRL_REG1: INOISE
Public property | CTRLREG2MODS | CTRL_REG2: MODS
Public property | CTRLREG2RST | CTRL_REG2: RST
Public property | CTRLREG2SLPE | CTRL_REG2: SLPE
Public property | CTRLREG2SMODS | CTRL_REG2: SMODS
Public property | CTRLREG2ST | CTRL_REG2: ST
Public property | CTRLREG3FIFOGATE | CTRL_REG3: FIFO_GATE
Public property | CTRLREG3IPOL | CTRL_REG3: IPOL
Public property | CTRLREG3PPOD | CTRL_REG3: PP_OD
Public property | CTRLREG3WAKEAVECM | CTRL_REG3: WAKE_A_VECM
Public property | CTRLREG3WAKEFFMT | CTRL_REG3: WAKE_FFMT
Public property | CTRLREG3WAKELNDPRT | CTRL_REG3: WAKE_LNDPRT
Public property | CTRLREG3WAKEPULSE | CTRL_REG3: WAKE_PULSE
Public property | CTRLREG3WAKETRAN | CTRL_REG3: WAKE_TRAN
Public property | CTRLREG4INTENASLP | CTRL_REG4: INT_EN_ASLP
Public property | CTRLREG4INTENAVECM | CTRL_REG4: INT_EN_A_VECM
Public property | CTRLREG4INTENDRDY | CTRL_REG4: INT_EN_DRDY
Public property | CTRLREG4INTENFFMT | CTRL_REG4: INT_EN_FFMT
Public property | CTRLREG4INTENFIFO | CTRL_REG4: INT_EN_FIFO
Public property | CTRLREG4INTENLNDPRT | CTRL_REG4: INT_EN_LNDPRT
Public property | CTRLREG4INTENPULSE | CTRL_REG4: INT_EN_PULSE
Public property | CTRLREG4INTENTRANS | CTRL_REG4: INT_EN_TRANS
Public property | CTRLREG5INTCFGASLP | CTRL_REG5: INT_CFG_ASLP
Public property | CTRLREG5INTCFGAVECM | CTRL_REG5: INT_CFG_A_VECM
Public property | CTRLREG5INTCFGDRDY | CTRL_REG5: INT_CFG_DRDY
Public property | CTRLREG5INTCFGFFMT | CTRL_REG5: INT_CFG_FFMT
Public property | CTRLREG5INTCFGFIFO | CTRL_REG5: INT_CFG_FIFO
Public property | CTRLREG5INTCFGLNDPRT | CTRL_REG5: INT_CFG_LNDPRT
Public property | CTRLREG5INTCFGPULSE | CTRL_REG5: INT_CFG_PULSE
Public property | CTRLREG5INTCFGTRANS | CTRL_REG5: INT_CFG_TRANS
Public property | FSETUPFMODE | F_SETUP: F_MODE
Public property | FSETUPFWMRK | F_SETUP: F_WMRK
Public property | HPFILTERCUTOFFPULSEHPFBYP | HP_FILTER_CUTOFF: PULSE_HPF_BYP
Public property | HPFILTERCUTOFFPULSELPFEN | HP_FILTER_CUTOFF: PULSE_LPF_EN
Public property | HPFILTERCUTOFFSEL | HP_FILTER_CUTOFF: SEL
Public property | INTSOURCESRCASLP | INT_SOURCE: SRC_ASLP
Public property | INTSOURCESRCAVECM | INT_SOURCE: SRC_A_VECM
Public property | INTSOURCESRCDRDY | INT_SOURCE: SRC_DRDY
Public property | INTSOURCESRCFFMT | INT_SOURCE: SRC_FFMT
Public property | INTSOURCESRCFIFO | INT_SOURCE: SRC_FIFO
Public property | INTSOURCESRCINDPRT | INT_SOURCE: SRC_INDPRT
Public property | INTSOURCESRCPULSE | INT_SOURCE: SRC_PULSE
Public property | INTSOURCESRCTRANS | INT_SOURCE: SRC_TRANS
Public property | MAXX | MAX_X (unit: μT)
Public property | MAXY | MAX_Y (unit: μT)
Public property | MAXZ | MAX_Z (unit: μT)
Public property | MCTRLREG1MACAL | M_CTRL_REG1: M_ACAL
Public property | MCTRLREG1MHMS | M_CTRL_REG1: M_HMS
Public property | MCTRLREG1MOS | M_CTRL_REG1: M_OS
Public property | MCTRLREG1MOST | M_CTRL_REG1: M_OST
Public property | MCTRLREG1MRST | M_CTRL_REG1: M_RST
Public property | MCTRLREG2HYBAUTOINCMODE | M_CTRL_REG2: HYB_AUTOINC_MODE
Public property | MCTRLREG2MMAXMINCNT | M_CTRL_REG2: M_MAXMIN_CNT
Public property | MCTRLREG2MMAXMINDIS | M_CTRL_REG2: M_MAXMIN_DIS
Public property | MCTRLREG2MMAXMINDISTHS | M_CTRL_REG2: M_MAXMIN_DIS_THS
Public property | MCTRLREG2MMAXMINRST | M_CTRL_REG2: M_MAXMIN_RST
Public property | MCTRLREG3MASLPOS | M_CTRL_REG3: M_ASLP_OS
Public property | MCTRLREG3MRAW | M_CTRL_REG3: M_RAW
Public property | MCTRLREG3MSTXY | M_CTRL_REG3: M_ST_XY
Public property | MCTRLREG3MSTZ | M_CTRL_REG3: M_ST_Z
Public property | MCTRLREG3MTHSXYZUPDATE | M_CTRL_REG3: M_THS_XYZ_UPDATE
Public property | MDRSTATUSXDR | M_DR_STATUS: XDR
Public property | MDRSTATUSXOW | M_DR_STATUS: XOW
Public property | MDRSTATUSYDR | M_DR_STATUS: YDR
Public property | MDRSTATUSYOW | M_DR_STATUS: YOW
Public property | MDRSTATUSZDR | M_DR_STATUS: ZDR
Public property | MDRSTATUSZOW | M_DR_STATUS: ZOW
Public property | MDRSTATUSZYXDR | M_DR_STATUS: ZYXDR
Public property | MDRSTATUSZYXOW | M_DR_STATUS: ZYXOW
Public property | MINTSRCSRCMDRDY | M_INT_SRC: SRC_M_DRDY
Public property | MINTSRCSRCMTHS | M_INT_SRC: SRC_M_THS
Public property | MINTSRCSRCMVECM | M_INT_SRC: SRC_M_VECM
Public property | MINX | MIN_X (unit: μT)
Public property | MINY | MIN_Y (unit: μT)
Public property | MINZ | MIN_Z (unit: μT)
Public property | MOFFX | M_OFF_X (unit: μT)
Public property | MOFFY | M_OFF_Y (unit: μT)
Public property | MOFFZ | M_OFF_Z (unit: μT)
Public property | MOUTX | M_OUT_X (unit: μT)
Public property | MOUTY | M_OUT_Y (unit: μT)
Public property | MOUTZ | M_OUT_Z (unit: μT)
Public property | MTHSCFGMTHSELE | M_THS_CFG: M_THS_ELE
Public property | MTHSCFGMTHSINTCFG | M_THS_CFG: M_THS_INT_CFG
Public property | MTHSCFGMTHSINTEN | M_THS_CFG: M_THS_INT_EN
Public property | MTHSCFGMTHSOAE | M_THS_CFG: M_THS_OAE
Public property | MTHSCFGMTHSWAKEEN | M_THS_CFG: M_THS_WAKE_EN
Public property | MTHSCFGMTHSXEFE | M_THS_CFG: M_THS_XEFE
Public property | MTHSCFGMTHSYEFE | M_THS_CFG: M_THS_YEFE
Public property | MTHSCFGMTHSZEFE | M_THS_CFG: M_THS_ZEFE
Public property | MTHSCOUNT | M_THS_COUNT
Public property | MTHSSRCMTHSEA | M_THS_SRC: M_THS_EA
Public property | MTHSSRCMTHSXHE | M_THS_SRC: M_THS_XHE
Public property | MTHSSRCMTHSXHP | M_THS_SRC: M_THS_XHP
Public property | MTHSSRCMTHSYHE | M_THS_SRC: M_THS_YHE
Public property | MTHSSRCMTHSYHP | M_THS_SRC: M_THS_YHP
Public property | MTHSSRCMTHSZHE | M_THS_SRC: M_THS_ZHE
Public property | MTHSSRCMTHSZHP | M_THS_SRC: M_THS_ZHP
Public property | MTHSXMTHSDBCNTM | M_THS_X: M_THS_DBCNTM
Public property | MTHSXMTHSX | M_THS_X: M_THS_X (unit: μT)
Public property | MTHSY | M_THS_Y (unit: μT)
Public property | MTHSZ | M_THS_Z (unit: μT)
Public property | MVECMCFGMVECMELE | M_VECM_CFG: M_VECM_ELE
Public property | MVECMCFGMVECMEN | M_VECM_CFG: M_VECM_EN
Public property | MVECMCFGMVECMINITM | M_VECM_CFG: M_VECM_INITM
Public property | MVECMCFGMVECMINTCFG | M_VECM_CFG: M_VECM_INT_CFG
Public property | MVECMCFGMVECMINTEN | M_VECM_CFG: M_VECM_INT_EN
Public property | MVECMCFGMVECMUPDM | M_VECM_CFG: M_VECM_UPDM
Public property | MVECMCFGMVECMWAKEEN | M_VECM_CFG: M_VECM_WAKE_EN
Public property | MVECMCNT | M_VECM_CNT
Public property | MVECMINITX | M_VECM_INITX
Public property | MVECMINITY | M_VECM_INITY
Public property | MVECMINITZ | M_VECM_INITZ
Public property | MVECMTHSMVECMDBCNTM | M_VECM_THS: M_VECM_DBCNTM
Public property | MVECMTHSMVECMTHS | M_VECM_THS: M_VECM_THS (unit: μT)
Public property | OFFX | OFF_X
Public property | OFFY | OFF_Y
Public property | OFFZ | OFF_Z
Public property | OUTX | OUT_X
Public property | OUTY | OUT_Y
Public property | OUTZ | OUT_Z
Public property | PLBFZCOMPBKFR | PL_BF_ZCOMP: BKFR
Public property | PLBFZCOMPZLOCK | PL_BF_ZCOMP: ZLOCK
Public property | PLCFGDBCNTM | PL_CFG: DBCNTM
Public property | PLCFGPLEN | PL_CFG: PL_EN
Public property | PLCOUNTDBNCE | PL_COUNT: DBNCE
Public property | PLSTATUSBAFRO | PL_STATUS: BAFRO
Public property | PLSTATUSIO | PL_STATUS: IO
Public property | PLSTATUSLAPO | PL_STATUS: LAPO
Public property | PLSTATUSNEWLP | PL_STATUS: NEWLP
Public property | PLTHSREGHYS | PL_THS_REG: HYS
Public property | PLTHSREGPLTHS | PL_THS_REG: PL_THS
Public property | PULSECFGPLSDPA | PULSE_CFG: PLS_DPA
Public property | PULSECFGPLSELE | PULSE_CFG: PLS_ELE
Public property | PULSECFGPLSXDPEFE | PULSE_CFG: PLS_XDPEFE
Public property | PULSECFGPLSXSPEFE | PULSE_CFG: PLS_XSPEFE
Public property | PULSECFGPLSYDPEFE | PULSE_CFG: PLS_YDPEFE
Public property | PULSECFGPLSYSPEFE | PULSE_CFG: PLS_YSPEFE
Public property | PULSECFGPLSZDPEFE | PULSE_CFG: PLS_ZDPEFE
Public property | PULSECFGPLSZSPEFE | PULSE_CFG: PLS_ZSPEFE
Public property | PULSELTCY | PULSE_LTCY
Public property | PULSESRCPLSSRCAXX | PULSE_SRC: PLS_SRC_AXX
Public property | PULSESRCPLSSRCAXY | PULSE_SRC: PLS_SRC_AXY
Public property | PULSESRCPLSSRCAXZ | PULSE_SRC: PLS_SRC_AXZ
Public property | PULSESRCPLSSRCDPE | PULSE_SRC: PLS_SRC_DPE
Public property | PULSESRCPLSSRCEA | PULSE_SRC: PLS_SRC_EA
Public property | PULSESRCPLSSRCPOLX | PULSE_SRC: PLS_SRC_POLX
Public property | PULSESRCPLSSRCPOLY | PULSE_SRC: PLS_SRC_POLY
Public property | PULSESRCPLSSRCPOLZ | PULSE_SRC: PLS_SRC_POLZ
Public property | PULSETHSX | PULSE_THSX (unit: mg)
Public property | PULSETHSY | PULSE_THSY (unit: mg)
Public property | PULSETHSZ | PULSE_THSZ (unit: mg)
Public property | PULSETMLT | PULSE_TMLT
Public property | PULSEWIND | PULSE_WIND
Public property | STATUS | STATUS
Public property | SYSMODFGERR | SYSMOD: FGERR
Public property | SYSMODFGT | SYSMOD: FGT
Public property | SYSMODSYSMOD | SYSMOD: SYSMOD
Public property | TEMP | TEMP (unit: °C)
Public property | TRANSIENTCFGTRANELE | TRANSIENT_CFG: TRAN_ELE
Public property | TRANSIENTCFGTRANHPFBYP | TRANSIENT_CFG: TRAN_HPF_BYP
Public property | TRANSIENTCFGTRANXEFE | TRANSIENT_CFG: TRAN_XEFE
Public property | TRANSIENTCFGTRANYEFE | TRANSIENT_CFG: TRAN_YEFE
Public property | TRANSIENTCFGTRANZEFE | TRANSIENT_CFG: TRAN_ZEFE
Public property | TRANSIENTCOUNT | TRANSIENT_COUNT
Public property | TRANSIENTSRCTRANEA | TRANSIENT_SRC: TRAN_EA
Public property | TRANSIENTSRCTRANXEF | TRANSIENT_SRC: TRAN_XEF
Public property | TRANSIENTSRCTRANXPOL | TRANSIENT_SRC: TRAN_XPOL
Public property | TRANSIENTSRCTRANYEF | TRANSIENT_SRC: TRAN_YEF
Public property | TRANSIENTSRCTRANYPOL | TRANSIENT_SRC: TRAN_YPOL
Public property | TRANSIENTSRCTRANZEF | TRANSIENT_SRC: TRAN_ZEF
Public property | TRANSIENTSRCTRANZPOL | TRANSIENT_SRC: TRAN_ZPOL
Public property | TRANSIENTTHSTRDBCNTM | TRANSIENT_THS: TR_DBCNTM
Public property | TRANSIENTTHSTRTHS | TRANSIENT_THS: TR_THS (unit: mg)
Public property | TRIGCFGTRIGAVECM | TRIG_CFG: TRIG_A_VECM
Public property | TRIGCFGTRIGFFMT | TRIG_CFG: TRIG_FFMT
Public property | TRIGCFGTRIGINDPRT | TRIG_CFG: TRIG_INDPRT
Public property | TRIGCFGTRIGPULSE | TRIG_CFG: TRIG_PULSE
Public property | TRIGCFGTRIGTRANS | TRIG_CFG: TRIG_TRANS
Public property | WHOAMI | WHO_AM_I
Public property | XYZDATACFGFS | XYZ_DATA_CFG: FS
Public property | XYZDATACFGHPFOUT | XYZ_DATA_CFG: HPF_OUT
Top
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTCFGAFFMTELE Property

IRD

Fxos8700cqAFFMTCFGAFFMTELE Property

A_FFMT_CFG: A_FFMT_ELE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeAFfmtCfgAFfmtEle AFFMTCFGAFFMTELE { get; set; }
Public Property AFFMTCFGAFFMTELE As Fxos8700cqTypeAFfmtCfgAFfmtEle
    Get
    Set
public:
property Fxos8700cqTypeAFfmtCfgAFfmtEle AFFMTCFGAFFMTELE {
    Fxos8700cqTypeAFfmtCfgAFfmtEle get ();
    void set (Fxos8700cqTypeAFfmtCfgAFfmtEle value);
}
member AFFMTCFGAFFMTELE : Fxos8700cqTypeAFfmtCfgAFfmtEle with get, set

Property Value

Type: Fxos8700cqTypeAFfmtCfgAFfmtEle
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTCFGAFFMTOAE Property

IRD

Fxos8700cqAFFMTCFGAFFMTOAE Property

A_FFMT_CFG: A_FFMT_OAE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeAFfmtCfgAFfmtOae AFFMTCFGAFFMTOAE { get; set; }
Public Property AFFMTCFGAFFMTOAE As Fxos8700cqTypeAFfmtCfgAFfmtOae
    Get
    Set
public:
property Fxos8700cqTypeAFfmtCfgAFfmtOae AFFMTCFGAFFMTOAE {
    Fxos8700cqTypeAFfmtCfgAFfmtOae get ();
    void set (Fxos8700cqTypeAFfmtCfgAFfmtOae value);
}
member AFFMTCFGAFFMTOAE : Fxos8700cqTypeAFfmtCfgAFfmtOae with get, set

Property Value

Type: Fxos8700cqTypeAFfmtCfgAFfmtOae
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTCFGAFFMTXEFE Property

IRD

Fxos8700cqAFFMTCFGAFFMTXEFE Property

A_FFMT_CFG: A_FFMT_XEFE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeAFfmtCfgAFfmtXyzefe AFFMTCFGAFFMTXEFE { get; set; }
Public Property AFFMTCFGAFFMTXEFE As Fxos8700cqTypeAFfmtCfgAFfmtXyzefe
    Get
    Set
public:
property Fxos8700cqTypeAFfmtCfgAFfmtXyzefe AFFMTCFGAFFMTXEFE {
    Fxos8700cqTypeAFfmtCfgAFfmtXyzefe get ();
    void set (Fxos8700cqTypeAFfmtCfgAFfmtXyzefe value);
}
member AFFMTCFGAFFMTXEFE : Fxos8700cqTypeAFfmtCfgAFfmtXyzefe with get, set

Property Value

Type: Fxos8700cqTypeAFfmtCfgAFfmtXyzefe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTCFGAFFMTYEFE Property

IRD

Fxos8700cqAFFMTCFGAFFMTYEFE Property

A_FFMT_CFG: A_FFMT_YEFE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeAFfmtCfgAFfmtXyzefe AFFMTCFGAFFMTYEFE { get; set; }
Public Property AFFMTCFGAFFMTYEFE As Fxos8700cqTypeAFfmtCfgAFfmtXyzefe
    Get
    Set
public:
property Fxos8700cqTypeAFfmtCfgAFfmtXyzefe AFFMTCFGAFFMTYEFE {
    Fxos8700cqTypeAFfmtCfgAFfmtXyzefe get ();
    void set (Fxos8700cqTypeAFfmtCfgAFfmtXyzefe value);
}
member AFFMTCFGAFFMTYEFE : Fxos8700cqTypeAFfmtCfgAFfmtXyzefe with get, set

Property Value

Type: Fxos8700cqTypeAFfmtCfgAFfmtXyzefe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTCFGAFFMTZEFE Property

IRD

Fxos8700cqAFFMTCFGAFFMTZEFE Property

A_FFMT_CFG: A_FFMT_ZEFE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeAFfmtCfgAFfmtXyzefe AFFMTCFGAFFMTZEFE { get; set; }
Public Property AFFMTCFGAFFMTZEFE As Fxos8700cqTypeAFfmtCfgAFfmtXyzefe
    Get
    Set
public:
property Fxos8700cqTypeAFfmtCfgAFfmtXyzefe AFFMTCFGAFFMTZEFE {
    Fxos8700cqTypeAFfmtCfgAFfmtXyzefe get ();
    void set (Fxos8700cqTypeAFfmtCfgAFfmtXyzefe value);
}
member AFFMTCFGAFFMTZEFE : Fxos8700cqTypeAFfmtCfgAFfmtXyzefe with get, set

Property Value

Type: Fxos8700cqTypeAFfmtCfgAFfmtXyzefe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTCOUNT Property

IRD

Fxos8700cqAFFMTCOUNT Property

A_FFMT_COUNT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AFFMTCOUNT { get; set; }
Public Property AFFMTCOUNT As Byte
    Get
    Set
public:
property unsigned char AFFMTCOUNT {
    unsigned char get ();
    void set (unsigned char value);
}
member AFFMTCOUNT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTSRCAFFMTEA Property

IRD

Fxos8700cqAFFMTSRCAFFMTEA Property

A_FFMT_SRC: A_FFMT_EA

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeAFfmtSrcAFfmtEa AFFMTSRCAFFMTEA { get; }
Public ReadOnly Property AFFMTSRCAFFMTEA As Fxos8700cqTypeAFfmtSrcAFfmtEa
    Get
public:
property Fxos8700cqTypeAFfmtSrcAFfmtEa AFFMTSRCAFFMTEA {
    Fxos8700cqTypeAFfmtSrcAFfmtEa get ();
}
member AFFMTSRCAFFMTEA : Fxos8700cqTypeAFfmtSrcAFfmtEa with get

Property Value

Type: Fxos8700cqTypeAFfmtSrcAFfmtEa
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTSRCAFFMTXHE Property

IRD

Fxos8700cqAFFMTSRCAFFMTXHE Property

A_FFMT_SRC: A_FFMT_XHE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeAFfmtSrcAFfmtXhe AFFMTSRCAFFMTXHE { get; }
Public ReadOnly Property AFFMTSRCAFFMTXHE As Fxos8700cqTypeAFfmtSrcAFfmtXhe
    Get
public:
property Fxos8700cqTypeAFfmtSrcAFfmtXhe AFFMTSRCAFFMTXHE {
    Fxos8700cqTypeAFfmtSrcAFfmtXhe get ();
}
member AFFMTSRCAFFMTXHE : Fxos8700cqTypeAFfmtSrcAFfmtXhe with get

Property Value

Type: Fxos8700cqTypeAFfmtSrcAFfmtXhe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTSRCAFFMTXHP Property

IRD

Fxos8700cqAFFMTSRCAFFMTXHP Property

A_FFMT_SRC: A_FFMT_XHP

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeAFfmtSrcAFfmtXhp AFFMTSRCAFFMTXHP { get; }
Public ReadOnly Property AFFMTSRCAFFMTXHP As Fxos8700cqTypeAFfmtSrcAFfmtXhp
    Get
public:
property Fxos8700cqTypeAFfmtSrcAFfmtXhp AFFMTSRCAFFMTXHP {
    Fxos8700cqTypeAFfmtSrcAFfmtXhp get ();
}
member AFFMTSRCAFFMTXHP : Fxos8700cqTypeAFfmtSrcAFfmtXhp with get

Property Value

Type: Fxos8700cqTypeAFfmtSrcAFfmtXhp
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTSRCAFFMTYHE Property

IRD

Fxos8700cqAFFMTSRCAFFMTYHE Property

A_FFMT_SRC: A_FFMT_YHE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeAFfmtSrcAFfmtYhe AFFMTSRCAFFMTYHE { get; }
Public ReadOnly Property AFFMTSRCAFFMTYHE As Fxos8700cqTypeAFfmtSrcAFfmtYhe
    Get
public:
property Fxos8700cqTypeAFfmtSrcAFfmtYhe AFFMTSRCAFFMTYHE {
    Fxos8700cqTypeAFfmtSrcAFfmtYhe get ();
}
member AFFMTSRCAFFMTYHE : Fxos8700cqTypeAFfmtSrcAFfmtYhe with get

Property Value

Type: Fxos8700cqTypeAFfmtSrcAFfmtYhe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTSRCAFFMTYHP Property

IRD

Fxos8700cqAFFMTSRCAFFMTYHP Property

A_FFMT_SRC: A_FFMT_YHP

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeAFfmtSrcAFfmtYhp AFFMTSRCAFFMTYHP { get; }
Public ReadOnly Property AFFMTSRCAFFMTYHP As Fxos8700cqTypeAFfmtSrcAFfmtYhp
    Get
public:
property Fxos8700cqTypeAFfmtSrcAFfmtYhp AFFMTSRCAFFMTYHP {
    Fxos8700cqTypeAFfmtSrcAFfmtYhp get ();
}
member AFFMTSRCAFFMTYHP : Fxos8700cqTypeAFfmtSrcAFfmtYhp with get

Property Value

Type: Fxos8700cqTypeAFfmtSrcAFfmtYhp
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTSRCAFFMTZHE Property

IRD

Fxos8700cqAFFMTSRCAFFMTZHE Property

A_FFMT_SRC: A_FFMT_ZHE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeAFfmtSrcAFfmtZhe AFFMTSRCAFFMTZHE { get; }
Public ReadOnly Property AFFMTSRCAFFMTZHE As Fxos8700cqTypeAFfmtSrcAFfmtZhe
    Get
public:
property Fxos8700cqTypeAFfmtSrcAFfmtZhe AFFMTSRCAFFMTZHE {
    Fxos8700cqTypeAFfmtSrcAFfmtZhe get ();
}
member AFFMTSRCAFFMTZHE : Fxos8700cqTypeAFfmtSrcAFfmtZhe with get

Property Value

Type: Fxos8700cqTypeAFfmtSrcAFfmtZhe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTSRCAFFMTZHP Property

IRD

Fxos8700cqAFFMTSRCAFFMTZHP Property

A_FFMT_SRC: A_FFMT_ZHP

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeAFfmtSrcAFfmtZhp AFFMTSRCAFFMTZHP { get; }
Public ReadOnly Property AFFMTSRCAFFMTZHP As Fxos8700cqTypeAFfmtSrcAFfmtZhp
    Get
public:
property Fxos8700cqTypeAFfmtSrcAFfmtZhp AFFMTSRCAFFMTZHP {
    Fxos8700cqTypeAFfmtSrcAFfmtZhp get ();
}
member AFFMTSRCAFFMTZHP : Fxos8700cqTypeAFfmtSrcAFfmtZhp with get

Property Value

Type: Fxos8700cqTypeAFfmtSrcAFfmtZhp
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTTHSAFFMTDBCNTM Property

IRD

Fxos8700cqAFFMTTHSAFFMTDBCNTM Property

A_FFMT_THS: A_FFMT_DBCNTM

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeAFfmtThsAFfmtDbcntm AFFMTTHSAFFMTDBCNTM { get; set; }
Public Property AFFMTTHSAFFMTDBCNTM As Fxos8700cqTypeAFfmtThsAFfmtDbcntm
    Get
    Set
public:
property Fxos8700cqTypeAFfmtThsAFfmtDbcntm AFFMTTHSAFFMTDBCNTM {
    Fxos8700cqTypeAFfmtThsAFfmtDbcntm get ();
    void set (Fxos8700cqTypeAFfmtThsAFfmtDbcntm value);
}
member AFFMTTHSAFFMTDBCNTM : Fxos8700cqTypeAFfmtThsAFfmtDbcntm with get, set

Property Value

Type: Fxos8700cqTypeAFfmtThsAFfmtDbcntm
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTTHSTHS Property

IRD

Fxos8700cqAFFMTTHSTHS Property

A_FFMT_THS: THS (unit: mg)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AFFMTTHSTHS { get; set; }
Public Property AFFMTTHSTHS As Double
    Get
    Set
public:
property double AFFMTTHSTHS {
    double get ();
    void set (double value);
}
member AFFMTTHSTHS : float with get, set

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTTHSXAFFMTTHSX Property

IRD

Fxos8700cqAFFMTTHSXAFFMTTHSX Property

A_FFMT_THS_X: A_FFMT_THS_X

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AFFMTTHSXAFFMTTHSX { get; set; }
Public Property AFFMTTHSXAFFMTTHSX As UShort
    Get
    Set
public:
property unsigned short AFFMTTHSXAFFMTTHSX {
    unsigned short get ();
    void set (unsigned short value);
}
member AFFMTTHSXAFFMTTHSX : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTTHSXAFFMTTHSXYZEN Property

IRD

Fxos8700cqAFFMTTHSXAFFMTTHSXYZEN Property

A_FFMT_THS_X: A_FFMT_THS_XYZ_EN

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AFFMTTHSXAFFMTTHSXYZEN { get; set; }
Public Property AFFMTTHSXAFFMTTHSXYZEN As Byte
    Get
    Set
public:
property unsigned char AFFMTTHSXAFFMTTHSXYZEN {
    unsigned char get ();
    void set (unsigned char value);
}
member AFFMTTHSXAFFMTTHSXYZEN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTTHSY Property

IRD

Fxos8700cqAFFMTTHSY Property

A_FFMT_THS_Y

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AFFMTTHSY { get; set; }
Public Property AFFMTTHSY As UShort
    Get
    Set
public:
property unsigned short AFFMTTHSY {
    unsigned short get ();
    void set (unsigned short value);
}
member AFFMTTHSY : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AFFMTTHSZ Property

IRD

Fxos8700cqAFFMTTHSZ Property

A_FFMT_THS_Z

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AFFMTTHSZ { get; set; }
Public Property AFFMTTHSZ As UShort
    Get
    Set
public:
property unsigned short AFFMTTHSZ {
    unsigned short get ();
    void set (unsigned short value);
}
member AFFMTTHSZ : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.ASLPCOUNT Property

IRD

Fxos8700cqASLPCOUNT Property

ASLP_COUNT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ASLPCOUNT { get; set; }
Public Property ASLPCOUNT As Byte
    Get
    Set
public:
property unsigned char ASLPCOUNT {
    unsigned char get ();
    void set (unsigned char value);
}
member ASLPCOUNT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AutoFlush Property

IRD

Fxos8700cqAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AVECMCFGAVECMELE Property

IRD

Fxos8700cqAVECMCFGAVECMELE Property

A_VECM_CFG: A_VECM_ELE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeAVecmCfgAVecmEle AVECMCFGAVECMELE { get; set; }
Public Property AVECMCFGAVECMELE As Fxos8700cqTypeAVecmCfgAVecmEle
    Get
    Set
public:
property Fxos8700cqTypeAVecmCfgAVecmEle AVECMCFGAVECMELE {
    Fxos8700cqTypeAVecmCfgAVecmEle get ();
    void set (Fxos8700cqTypeAVecmCfgAVecmEle value);
}
member AVECMCFGAVECMELE : Fxos8700cqTypeAVecmCfgAVecmEle with get, set

Property Value

Type: Fxos8700cqTypeAVecmCfgAVecmEle
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AVECMCFGAVECMEN Property

IRD

Fxos8700cqAVECMCFGAVECMEN Property

A_VECM_CFG: A_VECM_EN

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeAVecmCfgAVecmEn AVECMCFGAVECMEN { get; set; }
Public Property AVECMCFGAVECMEN As Fxos8700cqTypeAVecmCfgAVecmEn
    Get
    Set
public:
property Fxos8700cqTypeAVecmCfgAVecmEn AVECMCFGAVECMEN {
    Fxos8700cqTypeAVecmCfgAVecmEn get ();
    void set (Fxos8700cqTypeAVecmCfgAVecmEn value);
}
member AVECMCFGAVECMEN : Fxos8700cqTypeAVecmCfgAVecmEn with get, set

Property Value

Type: Fxos8700cqTypeAVecmCfgAVecmEn
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AVECMCFGAVECMINITM Property

IRD

Fxos8700cqAVECMCFGAVECMINITM Property

A_VECM_CFG: A_VECM_INITM

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeAVecmCfgAVecmInitm AVECMCFGAVECMINITM { get; set; }
Public Property AVECMCFGAVECMINITM As Fxos8700cqTypeAVecmCfgAVecmInitm
    Get
    Set
public:
property Fxos8700cqTypeAVecmCfgAVecmInitm AVECMCFGAVECMINITM {
    Fxos8700cqTypeAVecmCfgAVecmInitm get ();
    void set (Fxos8700cqTypeAVecmCfgAVecmInitm value);
}
member AVECMCFGAVECMINITM : Fxos8700cqTypeAVecmCfgAVecmInitm with get, set

Property Value

Type: Fxos8700cqTypeAVecmCfgAVecmInitm
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AVECMCFGAVECMUPDM Property

IRD

Fxos8700cqAVECMCFGAVECMUPDM Property

A_VECM_CFG: A_VECM_UPDM

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeAVecmCfgAVecmUpdm AVECMCFGAVECMUPDM { get; set; }
Public Property AVECMCFGAVECMUPDM As Fxos8700cqTypeAVecmCfgAVecmUpdm
    Get
    Set
public:
property Fxos8700cqTypeAVecmCfgAVecmUpdm AVECMCFGAVECMUPDM {
    Fxos8700cqTypeAVecmCfgAVecmUpdm get ();
    void set (Fxos8700cqTypeAVecmCfgAVecmUpdm value);
}
member AVECMCFGAVECMUPDM : Fxos8700cqTypeAVecmCfgAVecmUpdm with get, set

Property Value

Type: Fxos8700cqTypeAVecmCfgAVecmUpdm
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AVECMCNT Property

IRD

Fxos8700cqAVECMCNT Property

A_VECM_CNT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AVECMCNT { get; set; }
Public Property AVECMCNT As Byte
    Get
    Set
public:
property unsigned char AVECMCNT {
    unsigned char get ();
    void set (unsigned char value);
}
member AVECMCNT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AVECMINITX Property

IRD

Fxos8700cqAVECMINITX Property

A_VECM_INITX

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short AVECMINITX { get; set; }
Public Property AVECMINITX As Short
    Get
    Set
public:
property short AVECMINITX {
    short get ();
    void set (short value);
}
member AVECMINITX : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AVECMINITY Property

IRD

Fxos8700cqAVECMINITY Property

A_VECM_INITY

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short AVECMINITY { get; set; }
Public Property AVECMINITY As Short
    Get
    Set
public:
property short AVECMINITY {
    short get ();
    void set (short value);
}
member AVECMINITY : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AVECMINITZ Property

IRD

Fxos8700cqAVECMINITZ Property

A_VECM_INITZ

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short AVECMINITZ { get; set; }
Public Property AVECMINITZ As Short
    Get
    Set
public:
property short AVECMINITZ {
    short get ();
    void set (short value);
}
member AVECMINITZ : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AVECMTHSAVECMDBCNTM Property

IRD

Fxos8700cqAVECMTHSAVECMDBCNTM Property

A_VECM_THS: A_VECM_DBCNTM

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeAVecmThsAVecmDbcntm AVECMTHSAVECMDBCNTM { get; set; }
Public Property AVECMTHSAVECMDBCNTM As Fxos8700cqTypeAVecmThsAVecmDbcntm
    Get
    Set
public:
property Fxos8700cqTypeAVecmThsAVecmDbcntm AVECMTHSAVECMDBCNTM {
    Fxos8700cqTypeAVecmThsAVecmDbcntm get ();
    void set (Fxos8700cqTypeAVecmThsAVecmDbcntm value);
}
member AVECMTHSAVECMDBCNTM : Fxos8700cqTypeAVecmThsAVecmDbcntm with get, set

Property Value

Type: Fxos8700cqTypeAVecmThsAVecmDbcntm
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.AVECMTHSAVECMTHS Property

IRD

Fxos8700cqAVECMTHSAVECMTHS Property

A_VECM_THS: A_VECM_THS

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AVECMTHSAVECMTHS { get; set; }
Public Property AVECMTHSAVECMTHS As UShort
    Get
    Set
public:
property unsigned short AVECMTHSAVECMTHS {
    unsigned short get ();
    void set (unsigned short value);
}
member AVECMTHSAVECMTHS : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CMPX Property

IRD

Fxos8700cqCMPX Property

CMP_X

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short CMPX { get; }
Public ReadOnly Property CMPX As Short
    Get
public:
property short CMPX {
    short get ();
}
member CMPX : int16 with get

Property Value

Type: Int16
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CMPY Property

IRD

Fxos8700cqCMPY Property

CMP_Y

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short CMPY { get; }
Public ReadOnly Property CMPY As Short
    Get
public:
property short CMPY {
    short get ();
}
member CMPY : int16 with get

Property Value

Type: Int16
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CMPZ Property

IRD

Fxos8700cqCMPZ Property

CMP_Z

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short CMPZ { get; }
Public ReadOnly Property CMPZ As Short
    Get
public:
property short CMPZ {
    short get ();
}
member CMPZ : int16 with get

Property Value

Type: Int16
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG1ACTIVE Property

IRD

Fxos8700cqCTRLREG1ACTIVE Property

CTRL_REG1: ACTIVE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg1Active CTRLREG1ACTIVE { get; set; }
Public Property CTRLREG1ACTIVE As Fxos8700cqTypeCtrlReg1Active
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg1Active CTRLREG1ACTIVE {
    Fxos8700cqTypeCtrlReg1Active get ();
    void set (Fxos8700cqTypeCtrlReg1Active value);
}
member CTRLREG1ACTIVE : Fxos8700cqTypeCtrlReg1Active with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg1Active
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG1ASLPRATE Property

IRD

Fxos8700cqCTRLREG1ASLPRATE Property

CTRL_REG1: ASLP_RATE (unit: Hz)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg1AslpRate CTRLREG1ASLPRATE { get; set; }
Public Property CTRLREG1ASLPRATE As Fxos8700cqTypeCtrlReg1AslpRate
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg1AslpRate CTRLREG1ASLPRATE {
    Fxos8700cqTypeCtrlReg1AslpRate get ();
    void set (Fxos8700cqTypeCtrlReg1AslpRate value);
}
member CTRLREG1ASLPRATE : Fxos8700cqTypeCtrlReg1AslpRate with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg1AslpRate
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG1DR Property

IRD

Fxos8700cqCTRLREG1DR Property

CTRL_REG1: DR

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CTRLREG1DR { get; set; }
Public Property CTRLREG1DR As Byte
    Get
    Set
public:
property unsigned char CTRLREG1DR {
    unsigned char get ();
    void set (unsigned char value);
}
member CTRLREG1DR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG1FREAD Property

IRD

Fxos8700cqCTRLREG1FREAD Property

CTRL_REG1: F_READ

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg1FRead CTRLREG1FREAD { get; set; }
Public Property CTRLREG1FREAD As Fxos8700cqTypeCtrlReg1FRead
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg1FRead CTRLREG1FREAD {
    Fxos8700cqTypeCtrlReg1FRead get ();
    void set (Fxos8700cqTypeCtrlReg1FRead value);
}
member CTRLREG1FREAD : Fxos8700cqTypeCtrlReg1FRead with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg1FRead
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG1INOISE Property

IRD

Fxos8700cqCTRLREG1INOISE Property

CTRL_REG1: INOISE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg1Inoise CTRLREG1INOISE { get; set; }
Public Property CTRLREG1INOISE As Fxos8700cqTypeCtrlReg1Inoise
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg1Inoise CTRLREG1INOISE {
    Fxos8700cqTypeCtrlReg1Inoise get ();
    void set (Fxos8700cqTypeCtrlReg1Inoise value);
}
member CTRLREG1INOISE : Fxos8700cqTypeCtrlReg1Inoise with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg1Inoise
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG2MODS Property

IRD

Fxos8700cqCTRLREG2MODS Property

CTRL_REG2: MODS

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg2Mods CTRLREG2MODS { get; set; }
Public Property CTRLREG2MODS As Fxos8700cqTypeCtrlReg2Mods
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg2Mods CTRLREG2MODS {
    Fxos8700cqTypeCtrlReg2Mods get ();
    void set (Fxos8700cqTypeCtrlReg2Mods value);
}
member CTRLREG2MODS : Fxos8700cqTypeCtrlReg2Mods with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg2Mods
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG2RST Property

IRD

Fxos8700cqCTRLREG2RST Property

CTRL_REG2: RST

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg2Rst CTRLREG2RST { get; set; }
Public Property CTRLREG2RST As Fxos8700cqTypeCtrlReg2Rst
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg2Rst CTRLREG2RST {
    Fxos8700cqTypeCtrlReg2Rst get ();
    void set (Fxos8700cqTypeCtrlReg2Rst value);
}
member CTRLREG2RST : Fxos8700cqTypeCtrlReg2Rst with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg2Rst
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG2SLPE Property

IRD

Fxos8700cqCTRLREG2SLPE Property

CTRL_REG2: SLPE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg2Slpe CTRLREG2SLPE { get; set; }
Public Property CTRLREG2SLPE As Fxos8700cqTypeCtrlReg2Slpe
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg2Slpe CTRLREG2SLPE {
    Fxos8700cqTypeCtrlReg2Slpe get ();
    void set (Fxos8700cqTypeCtrlReg2Slpe value);
}
member CTRLREG2SLPE : Fxos8700cqTypeCtrlReg2Slpe with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg2Slpe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG2SMODS Property

IRD

Fxos8700cqCTRLREG2SMODS Property

CTRL_REG2: SMODS

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg2Smods CTRLREG2SMODS { get; set; }
Public Property CTRLREG2SMODS As Fxos8700cqTypeCtrlReg2Smods
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg2Smods CTRLREG2SMODS {
    Fxos8700cqTypeCtrlReg2Smods get ();
    void set (Fxos8700cqTypeCtrlReg2Smods value);
}
member CTRLREG2SMODS : Fxos8700cqTypeCtrlReg2Smods with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg2Smods
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG2ST Property

IRD

Fxos8700cqCTRLREG2ST Property

CTRL_REG2: ST

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg2St CTRLREG2ST { get; set; }
Public Property CTRLREG2ST As Fxos8700cqTypeCtrlReg2St
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg2St CTRLREG2ST {
    Fxos8700cqTypeCtrlReg2St get ();
    void set (Fxos8700cqTypeCtrlReg2St value);
}
member CTRLREG2ST : Fxos8700cqTypeCtrlReg2St with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg2St
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG3FIFOGATE Property

IRD

Fxos8700cqCTRLREG3FIFOGATE Property

CTRL_REG3: FIFO_GATE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg3FifoGate CTRLREG3FIFOGATE { get; set; }
Public Property CTRLREG3FIFOGATE As Fxos8700cqTypeCtrlReg3FifoGate
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg3FifoGate CTRLREG3FIFOGATE {
    Fxos8700cqTypeCtrlReg3FifoGate get ();
    void set (Fxos8700cqTypeCtrlReg3FifoGate value);
}
member CTRLREG3FIFOGATE : Fxos8700cqTypeCtrlReg3FifoGate with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg3FifoGate
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG3IPOL Property

IRD

Fxos8700cqCTRLREG3IPOL Property

CTRL_REG3: IPOL

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg3WakeIpol CTRLREG3IPOL { get; set; }
Public Property CTRLREG3IPOL As Fxos8700cqTypeCtrlReg3WakeIpol
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg3WakeIpol CTRLREG3IPOL {
    Fxos8700cqTypeCtrlReg3WakeIpol get ();
    void set (Fxos8700cqTypeCtrlReg3WakeIpol value);
}
member CTRLREG3IPOL : Fxos8700cqTypeCtrlReg3WakeIpol with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg3WakeIpol
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG3PPOD Property

IRD

Fxos8700cqCTRLREG3PPOD Property

CTRL_REG3: PP_OD

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg3WakePpOd CTRLREG3PPOD { get; set; }
Public Property CTRLREG3PPOD As Fxos8700cqTypeCtrlReg3WakePpOd
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg3WakePpOd CTRLREG3PPOD {
    Fxos8700cqTypeCtrlReg3WakePpOd get ();
    void set (Fxos8700cqTypeCtrlReg3WakePpOd value);
}
member CTRLREG3PPOD : Fxos8700cqTypeCtrlReg3WakePpOd with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg3WakePpOd
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG3WAKEAVECM Property

IRD

Fxos8700cqCTRLREG3WAKEAVECM Property

CTRL_REG3: WAKE_A_VECM

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg3WakeAVecm CTRLREG3WAKEAVECM { get; set; }
Public Property CTRLREG3WAKEAVECM As Fxos8700cqTypeCtrlReg3WakeAVecm
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg3WakeAVecm CTRLREG3WAKEAVECM {
    Fxos8700cqTypeCtrlReg3WakeAVecm get ();
    void set (Fxos8700cqTypeCtrlReg3WakeAVecm value);
}
member CTRLREG3WAKEAVECM : Fxos8700cqTypeCtrlReg3WakeAVecm with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg3WakeAVecm
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG3WAKEFFMT Property

IRD

Fxos8700cqCTRLREG3WAKEFFMT Property

CTRL_REG3: WAKE_FFMT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg3WakeFfmt CTRLREG3WAKEFFMT { get; set; }
Public Property CTRLREG3WAKEFFMT As Fxos8700cqTypeCtrlReg3WakeFfmt
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg3WakeFfmt CTRLREG3WAKEFFMT {
    Fxos8700cqTypeCtrlReg3WakeFfmt get ();
    void set (Fxos8700cqTypeCtrlReg3WakeFfmt value);
}
member CTRLREG3WAKEFFMT : Fxos8700cqTypeCtrlReg3WakeFfmt with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg3WakeFfmt
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG3WAKELNDPRT Property

IRD

Fxos8700cqCTRLREG3WAKELNDPRT Property

CTRL_REG3: WAKE_LNDPRT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg3WakeLndprt CTRLREG3WAKELNDPRT { get; set; }
Public Property CTRLREG3WAKELNDPRT As Fxos8700cqTypeCtrlReg3WakeLndprt
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg3WakeLndprt CTRLREG3WAKELNDPRT {
    Fxos8700cqTypeCtrlReg3WakeLndprt get ();
    void set (Fxos8700cqTypeCtrlReg3WakeLndprt value);
}
member CTRLREG3WAKELNDPRT : Fxos8700cqTypeCtrlReg3WakeLndprt with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg3WakeLndprt
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG3WAKEPULSE Property

IRD

Fxos8700cqCTRLREG3WAKEPULSE Property

CTRL_REG3: WAKE_PULSE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg3WakePulse CTRLREG3WAKEPULSE { get; set; }
Public Property CTRLREG3WAKEPULSE As Fxos8700cqTypeCtrlReg3WakePulse
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg3WakePulse CTRLREG3WAKEPULSE {
    Fxos8700cqTypeCtrlReg3WakePulse get ();
    void set (Fxos8700cqTypeCtrlReg3WakePulse value);
}
member CTRLREG3WAKEPULSE : Fxos8700cqTypeCtrlReg3WakePulse with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg3WakePulse
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG3WAKETRAN Property

IRD

Fxos8700cqCTRLREG3WAKETRAN Property

CTRL_REG3: WAKE_TRAN

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg3WakeTran CTRLREG3WAKETRAN { get; set; }
Public Property CTRLREG3WAKETRAN As Fxos8700cqTypeCtrlReg3WakeTran
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg3WakeTran CTRLREG3WAKETRAN {
    Fxos8700cqTypeCtrlReg3WakeTran get ();
    void set (Fxos8700cqTypeCtrlReg3WakeTran value);
}
member CTRLREG3WAKETRAN : Fxos8700cqTypeCtrlReg3WakeTran with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg3WakeTran
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG4INTENASLP Property

IRD

Fxos8700cqCTRLREG4INTENASLP Property

CTRL_REG4: INT_EN_ASLP

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg4IntEnAslp CTRLREG4INTENASLP { get; set; }
Public Property CTRLREG4INTENASLP As Fxos8700cqTypeCtrlReg4IntEnAslp
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg4IntEnAslp CTRLREG4INTENASLP {
    Fxos8700cqTypeCtrlReg4IntEnAslp get ();
    void set (Fxos8700cqTypeCtrlReg4IntEnAslp value);
}
member CTRLREG4INTENASLP : Fxos8700cqTypeCtrlReg4IntEnAslp with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg4IntEnAslp
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG4INTENAVECM Property

IRD

Fxos8700cqCTRLREG4INTENAVECM Property

CTRL_REG4: INT_EN_A_VECM

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg4IntEnAVecm CTRLREG4INTENAVECM { get; set; }
Public Property CTRLREG4INTENAVECM As Fxos8700cqTypeCtrlReg4IntEnAVecm
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg4IntEnAVecm CTRLREG4INTENAVECM {
    Fxos8700cqTypeCtrlReg4IntEnAVecm get ();
    void set (Fxos8700cqTypeCtrlReg4IntEnAVecm value);
}
member CTRLREG4INTENAVECM : Fxos8700cqTypeCtrlReg4IntEnAVecm with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg4IntEnAVecm
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG4INTENDRDY Property

IRD

Fxos8700cqCTRLREG4INTENDRDY Property

CTRL_REG4: INT_EN_DRDY

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg4IntEnDrdy CTRLREG4INTENDRDY { get; set; }
Public Property CTRLREG4INTENDRDY As Fxos8700cqTypeCtrlReg4IntEnDrdy
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg4IntEnDrdy CTRLREG4INTENDRDY {
    Fxos8700cqTypeCtrlReg4IntEnDrdy get ();
    void set (Fxos8700cqTypeCtrlReg4IntEnDrdy value);
}
member CTRLREG4INTENDRDY : Fxos8700cqTypeCtrlReg4IntEnDrdy with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg4IntEnDrdy
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG4INTENFFMT Property

IRD

Fxos8700cqCTRLREG4INTENFFMT Property

CTRL_REG4: INT_EN_FFMT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg4IntEnFfmt CTRLREG4INTENFFMT { get; set; }
Public Property CTRLREG4INTENFFMT As Fxos8700cqTypeCtrlReg4IntEnFfmt
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg4IntEnFfmt CTRLREG4INTENFFMT {
    Fxos8700cqTypeCtrlReg4IntEnFfmt get ();
    void set (Fxos8700cqTypeCtrlReg4IntEnFfmt value);
}
member CTRLREG4INTENFFMT : Fxos8700cqTypeCtrlReg4IntEnFfmt with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg4IntEnFfmt
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG4INTENFIFO Property

IRD

Fxos8700cqCTRLREG4INTENFIFO Property

CTRL_REG4: INT_EN_FIFO

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg4IntEnFifo CTRLREG4INTENFIFO { get; set; }
Public Property CTRLREG4INTENFIFO As Fxos8700cqTypeCtrlReg4IntEnFifo
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg4IntEnFifo CTRLREG4INTENFIFO {
    Fxos8700cqTypeCtrlReg4IntEnFifo get ();
    void set (Fxos8700cqTypeCtrlReg4IntEnFifo value);
}
member CTRLREG4INTENFIFO : Fxos8700cqTypeCtrlReg4IntEnFifo with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg4IntEnFifo
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG4INTENLNDPRT Property

IRD

Fxos8700cqCTRLREG4INTENLNDPRT Property

CTRL_REG4: INT_EN_LNDPRT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg4IntEnLndprt CTRLREG4INTENLNDPRT { get; set; }
Public Property CTRLREG4INTENLNDPRT As Fxos8700cqTypeCtrlReg4IntEnLndprt
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg4IntEnLndprt CTRLREG4INTENLNDPRT {
    Fxos8700cqTypeCtrlReg4IntEnLndprt get ();
    void set (Fxos8700cqTypeCtrlReg4IntEnLndprt value);
}
member CTRLREG4INTENLNDPRT : Fxos8700cqTypeCtrlReg4IntEnLndprt with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg4IntEnLndprt
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG4INTENPULSE Property

IRD

Fxos8700cqCTRLREG4INTENPULSE Property

CTRL_REG4: INT_EN_PULSE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg4IntEnPulse CTRLREG4INTENPULSE { get; set; }
Public Property CTRLREG4INTENPULSE As Fxos8700cqTypeCtrlReg4IntEnPulse
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg4IntEnPulse CTRLREG4INTENPULSE {
    Fxos8700cqTypeCtrlReg4IntEnPulse get ();
    void set (Fxos8700cqTypeCtrlReg4IntEnPulse value);
}
member CTRLREG4INTENPULSE : Fxos8700cqTypeCtrlReg4IntEnPulse with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg4IntEnPulse
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG4INTENTRANS Property

IRD

Fxos8700cqCTRLREG4INTENTRANS Property

CTRL_REG4: INT_EN_TRANS

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg4IntEnTrans CTRLREG4INTENTRANS { get; set; }
Public Property CTRLREG4INTENTRANS As Fxos8700cqTypeCtrlReg4IntEnTrans
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg4IntEnTrans CTRLREG4INTENTRANS {
    Fxos8700cqTypeCtrlReg4IntEnTrans get ();
    void set (Fxos8700cqTypeCtrlReg4IntEnTrans value);
}
member CTRLREG4INTENTRANS : Fxos8700cqTypeCtrlReg4IntEnTrans with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg4IntEnTrans
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG5INTCFGASLP Property

IRD

Fxos8700cqCTRLREG5INTCFGASLP Property

CTRL_REG5: INT_CFG_ASLP

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg5IntCfgAslp CTRLREG5INTCFGASLP { get; set; }
Public Property CTRLREG5INTCFGASLP As Fxos8700cqTypeCtrlReg5IntCfgAslp
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg5IntCfgAslp CTRLREG5INTCFGASLP {
    Fxos8700cqTypeCtrlReg5IntCfgAslp get ();
    void set (Fxos8700cqTypeCtrlReg5IntCfgAslp value);
}
member CTRLREG5INTCFGASLP : Fxos8700cqTypeCtrlReg5IntCfgAslp with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg5IntCfgAslp
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG5INTCFGAVECM Property

IRD

Fxos8700cqCTRLREG5INTCFGAVECM Property

CTRL_REG5: INT_CFG_A_VECM

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg5IntCfgAVecm CTRLREG5INTCFGAVECM { get; set; }
Public Property CTRLREG5INTCFGAVECM As Fxos8700cqTypeCtrlReg5IntCfgAVecm
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg5IntCfgAVecm CTRLREG5INTCFGAVECM {
    Fxos8700cqTypeCtrlReg5IntCfgAVecm get ();
    void set (Fxos8700cqTypeCtrlReg5IntCfgAVecm value);
}
member CTRLREG5INTCFGAVECM : Fxos8700cqTypeCtrlReg5IntCfgAVecm with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg5IntCfgAVecm
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG5INTCFGDRDY Property

IRD

Fxos8700cqCTRLREG5INTCFGDRDY Property

CTRL_REG5: INT_CFG_DRDY

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg5IntCfgDrdy CTRLREG5INTCFGDRDY { get; set; }
Public Property CTRLREG5INTCFGDRDY As Fxos8700cqTypeCtrlReg5IntCfgDrdy
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg5IntCfgDrdy CTRLREG5INTCFGDRDY {
    Fxos8700cqTypeCtrlReg5IntCfgDrdy get ();
    void set (Fxos8700cqTypeCtrlReg5IntCfgDrdy value);
}
member CTRLREG5INTCFGDRDY : Fxos8700cqTypeCtrlReg5IntCfgDrdy with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg5IntCfgDrdy
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG5INTCFGFFMT Property

IRD

Fxos8700cqCTRLREG5INTCFGFFMT Property

CTRL_REG5: INT_CFG_FFMT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg5IntCfgFfmt CTRLREG5INTCFGFFMT { get; set; }
Public Property CTRLREG5INTCFGFFMT As Fxos8700cqTypeCtrlReg5IntCfgFfmt
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg5IntCfgFfmt CTRLREG5INTCFGFFMT {
    Fxos8700cqTypeCtrlReg5IntCfgFfmt get ();
    void set (Fxos8700cqTypeCtrlReg5IntCfgFfmt value);
}
member CTRLREG5INTCFGFFMT : Fxos8700cqTypeCtrlReg5IntCfgFfmt with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg5IntCfgFfmt
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG5INTCFGFIFO Property

IRD

Fxos8700cqCTRLREG5INTCFGFIFO Property

CTRL_REG5: INT_CFG_FIFO

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg5IntCfgFifo CTRLREG5INTCFGFIFO { get; set; }
Public Property CTRLREG5INTCFGFIFO As Fxos8700cqTypeCtrlReg5IntCfgFifo
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg5IntCfgFifo CTRLREG5INTCFGFIFO {
    Fxos8700cqTypeCtrlReg5IntCfgFifo get ();
    void set (Fxos8700cqTypeCtrlReg5IntCfgFifo value);
}
member CTRLREG5INTCFGFIFO : Fxos8700cqTypeCtrlReg5IntCfgFifo with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg5IntCfgFifo
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG5INTCFGLNDPRT Property

IRD

Fxos8700cqCTRLREG5INTCFGLNDPRT Property

CTRL_REG5: INT_CFG_LNDPRT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg5IntCfgLndprt CTRLREG5INTCFGLNDPRT { get; set; }
Public Property CTRLREG5INTCFGLNDPRT As Fxos8700cqTypeCtrlReg5IntCfgLndprt
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg5IntCfgLndprt CTRLREG5INTCFGLNDPRT {
    Fxos8700cqTypeCtrlReg5IntCfgLndprt get ();
    void set (Fxos8700cqTypeCtrlReg5IntCfgLndprt value);
}
member CTRLREG5INTCFGLNDPRT : Fxos8700cqTypeCtrlReg5IntCfgLndprt with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg5IntCfgLndprt
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG5INTCFGPULSE Property

IRD

Fxos8700cqCTRLREG5INTCFGPULSE Property

CTRL_REG5: INT_CFG_PULSE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg5IntCfgPulse CTRLREG5INTCFGPULSE { get; set; }
Public Property CTRLREG5INTCFGPULSE As Fxos8700cqTypeCtrlReg5IntCfgPulse
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg5IntCfgPulse CTRLREG5INTCFGPULSE {
    Fxos8700cqTypeCtrlReg5IntCfgPulse get ();
    void set (Fxos8700cqTypeCtrlReg5IntCfgPulse value);
}
member CTRLREG5INTCFGPULSE : Fxos8700cqTypeCtrlReg5IntCfgPulse with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg5IntCfgPulse
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.CTRLREG5INTCFGTRANS Property

IRD

Fxos8700cqCTRLREG5INTCFGTRANS Property

CTRL_REG5: INT_CFG_TRANS

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeCtrlReg5IntCfgTrans CTRLREG5INTCFGTRANS { get; set; }
Public Property CTRLREG5INTCFGTRANS As Fxos8700cqTypeCtrlReg5IntCfgTrans
    Get
    Set
public:
property Fxos8700cqTypeCtrlReg5IntCfgTrans CTRLREG5INTCFGTRANS {
    Fxos8700cqTypeCtrlReg5IntCfgTrans get ();
    void set (Fxos8700cqTypeCtrlReg5IntCfgTrans value);
}
member CTRLREG5INTCFGTRANS : Fxos8700cqTypeCtrlReg5IntCfgTrans with get, set

Property Value

Type: Fxos8700cqTypeCtrlReg5IntCfgTrans
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.FSETUPFMODE Property

IRD

Fxos8700cqFSETUPFMODE Property

F_SETUP: F_MODE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeFSetupFMode FSETUPFMODE { get; set; }
Public Property FSETUPFMODE As Fxos8700cqTypeFSetupFMode
    Get
    Set
public:
property Fxos8700cqTypeFSetupFMode FSETUPFMODE {
    Fxos8700cqTypeFSetupFMode get ();
    void set (Fxos8700cqTypeFSetupFMode value);
}
member FSETUPFMODE : Fxos8700cqTypeFSetupFMode with get, set

Property Value

Type: Fxos8700cqTypeFSetupFMode
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.FSETUPFWMRK Property

IRD

Fxos8700cqFSETUPFWMRK Property

F_SETUP: F_WMRK

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FSETUPFWMRK { get; set; }
Public Property FSETUPFWMRK As Byte
    Get
    Set
public:
property unsigned char FSETUPFWMRK {
    unsigned char get ();
    void set (unsigned char value);
}
member FSETUPFWMRK : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.HPFILTERCUTOFFPULSEHPFBYP Property

IRD

Fxos8700cqHPFILTERCUTOFFPULSEHPFBYP Property

HP_FILTER_CUTOFF: PULSE_HPF_BYP

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeHpFilterCutoffPulseHpfByp HPFILTERCUTOFFPULSEHPFBYP { get; set; }
Public Property HPFILTERCUTOFFPULSEHPFBYP As Fxos8700cqTypeHpFilterCutoffPulseHpfByp
    Get
    Set
public:
property Fxos8700cqTypeHpFilterCutoffPulseHpfByp HPFILTERCUTOFFPULSEHPFBYP {
    Fxos8700cqTypeHpFilterCutoffPulseHpfByp get ();
    void set (Fxos8700cqTypeHpFilterCutoffPulseHpfByp value);
}
member HPFILTERCUTOFFPULSEHPFBYP : Fxos8700cqTypeHpFilterCutoffPulseHpfByp with get, set

Property Value

Type: Fxos8700cqTypeHpFilterCutoffPulseHpfByp
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.HPFILTERCUTOFFPULSELPFEN Property

IRD

Fxos8700cqHPFILTERCUTOFFPULSELPFEN Property

HP_FILTER_CUTOFF: PULSE_LPF_EN

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeHpFilterCutoffPulseLpfEn HPFILTERCUTOFFPULSELPFEN { get; set; }
Public Property HPFILTERCUTOFFPULSELPFEN As Fxos8700cqTypeHpFilterCutoffPulseLpfEn
    Get
    Set
public:
property Fxos8700cqTypeHpFilterCutoffPulseLpfEn HPFILTERCUTOFFPULSELPFEN {
    Fxos8700cqTypeHpFilterCutoffPulseLpfEn get ();
    void set (Fxos8700cqTypeHpFilterCutoffPulseLpfEn value);
}
member HPFILTERCUTOFFPULSELPFEN : Fxos8700cqTypeHpFilterCutoffPulseLpfEn with get, set

Property Value

Type: Fxos8700cqTypeHpFilterCutoffPulseLpfEn
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.HPFILTERCUTOFFSEL Property

IRD

Fxos8700cqHPFILTERCUTOFFSEL Property

HP_FILTER_CUTOFF: SEL

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte HPFILTERCUTOFFSEL { get; set; }
Public Property HPFILTERCUTOFFSEL As Byte
    Get
    Set
public:
property unsigned char HPFILTERCUTOFFSEL {
    unsigned char get ();
    void set (unsigned char value);
}
member HPFILTERCUTOFFSEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.INTSOURCESRCASLP Property

IRD

Fxos8700cqINTSOURCESRCASLP Property

INT_SOURCE: SRC_ASLP

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeIntSource INTSOURCESRCASLP { get; }
Public ReadOnly Property INTSOURCESRCASLP As Fxos8700cqTypeIntSource
    Get
public:
property Fxos8700cqTypeIntSource INTSOURCESRCASLP {
    Fxos8700cqTypeIntSource get ();
}
member INTSOURCESRCASLP : Fxos8700cqTypeIntSource with get

Property Value

Type: Fxos8700cqTypeIntSource
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.INTSOURCESRCAVECM Property

IRD

Fxos8700cqINTSOURCESRCAVECM Property

INT_SOURCE: SRC_A_VECM

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeIntSource INTSOURCESRCAVECM { get; }
Public ReadOnly Property INTSOURCESRCAVECM As Fxos8700cqTypeIntSource
    Get
public:
property Fxos8700cqTypeIntSource INTSOURCESRCAVECM {
    Fxos8700cqTypeIntSource get ();
}
member INTSOURCESRCAVECM : Fxos8700cqTypeIntSource with get

Property Value

Type: Fxos8700cqTypeIntSource
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.INTSOURCESRCDRDY Property

IRD

Fxos8700cqINTSOURCESRCDRDY Property

INT_SOURCE: SRC_DRDY

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeIntSource INTSOURCESRCDRDY { get; }
Public ReadOnly Property INTSOURCESRCDRDY As Fxos8700cqTypeIntSource
    Get
public:
property Fxos8700cqTypeIntSource INTSOURCESRCDRDY {
    Fxos8700cqTypeIntSource get ();
}
member INTSOURCESRCDRDY : Fxos8700cqTypeIntSource with get

Property Value

Type: Fxos8700cqTypeIntSource
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.INTSOURCESRCFFMT Property

IRD

Fxos8700cqINTSOURCESRCFFMT Property

INT_SOURCE: SRC_FFMT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeIntSource INTSOURCESRCFFMT { get; }
Public ReadOnly Property INTSOURCESRCFFMT As Fxos8700cqTypeIntSource
    Get
public:
property Fxos8700cqTypeIntSource INTSOURCESRCFFMT {
    Fxos8700cqTypeIntSource get ();
}
member INTSOURCESRCFFMT : Fxos8700cqTypeIntSource with get

Property Value

Type: Fxos8700cqTypeIntSource
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.INTSOURCESRCFIFO Property

IRD

Fxos8700cqINTSOURCESRCFIFO Property

INT_SOURCE: SRC_FIFO

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeIntSource INTSOURCESRCFIFO { get; }
Public ReadOnly Property INTSOURCESRCFIFO As Fxos8700cqTypeIntSource
    Get
public:
property Fxos8700cqTypeIntSource INTSOURCESRCFIFO {
    Fxos8700cqTypeIntSource get ();
}
member INTSOURCESRCFIFO : Fxos8700cqTypeIntSource with get

Property Value

Type: Fxos8700cqTypeIntSource
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.INTSOURCESRCINDPRT Property

IRD

Fxos8700cqINTSOURCESRCINDPRT Property

INT_SOURCE: SRC_INDPRT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeIntSource INTSOURCESRCINDPRT { get; }
Public ReadOnly Property INTSOURCESRCINDPRT As Fxos8700cqTypeIntSource
    Get
public:
property Fxos8700cqTypeIntSource INTSOURCESRCINDPRT {
    Fxos8700cqTypeIntSource get ();
}
member INTSOURCESRCINDPRT : Fxos8700cqTypeIntSource with get

Property Value

Type: Fxos8700cqTypeIntSource
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.INTSOURCESRCPULSE Property

IRD

Fxos8700cqINTSOURCESRCPULSE Property

INT_SOURCE: SRC_PULSE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeIntSource INTSOURCESRCPULSE { get; }
Public ReadOnly Property INTSOURCESRCPULSE As Fxos8700cqTypeIntSource
    Get
public:
property Fxos8700cqTypeIntSource INTSOURCESRCPULSE {
    Fxos8700cqTypeIntSource get ();
}
member INTSOURCESRCPULSE : Fxos8700cqTypeIntSource with get

Property Value

Type: Fxos8700cqTypeIntSource
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.INTSOURCESRCTRANS Property

IRD

Fxos8700cqINTSOURCESRCTRANS Property

INT_SOURCE: SRC_TRANS

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeIntSource INTSOURCESRCTRANS { get; }
Public ReadOnly Property INTSOURCESRCTRANS As Fxos8700cqTypeIntSource
    Get
public:
property Fxos8700cqTypeIntSource INTSOURCESRCTRANS {
    Fxos8700cqTypeIntSource get ();
}
member INTSOURCESRCTRANS : Fxos8700cqTypeIntSource with get

Property Value

Type: Fxos8700cqTypeIntSource
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MAXX Property

IRD

Fxos8700cqMAXX Property

MAX_X (unit: μT)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MAXX { get; }
Public ReadOnly Property MAXX As Double
    Get
public:
property double MAXX {
    double get ();
}
member MAXX : float with get

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MAXY Property

IRD

Fxos8700cqMAXY Property

MAX_Y (unit: μT)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MAXY { get; }
Public ReadOnly Property MAXY As Double
    Get
public:
property double MAXY {
    double get ();
}
member MAXY : float with get

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MAXZ Property

IRD

Fxos8700cqMAXZ Property

MAX_Z (unit: μT)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MAXZ { get; }
Public ReadOnly Property MAXZ As Double
    Get
public:
property double MAXZ {
    double get ();
}
member MAXZ : float with get

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MCTRLREG1MACAL Property

IRD

Fxos8700cqMCTRLREG1MACAL Property

M_CTRL_REG1: M_ACAL

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMCtrlReg1MAcal MCTRLREG1MACAL { get; set; }
Public Property MCTRLREG1MACAL As Fxos8700cqTypeMCtrlReg1MAcal
    Get
    Set
public:
property Fxos8700cqTypeMCtrlReg1MAcal MCTRLREG1MACAL {
    Fxos8700cqTypeMCtrlReg1MAcal get ();
    void set (Fxos8700cqTypeMCtrlReg1MAcal value);
}
member MCTRLREG1MACAL : Fxos8700cqTypeMCtrlReg1MAcal with get, set

Property Value

Type: Fxos8700cqTypeMCtrlReg1MAcal
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MCTRLREG1MHMS Property

IRD

Fxos8700cqMCTRLREG1MHMS Property

M_CTRL_REG1: M_HMS

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMCtrlReg1MHms MCTRLREG1MHMS { get; set; }
Public Property MCTRLREG1MHMS As Fxos8700cqTypeMCtrlReg1MHms
    Get
    Set
public:
property Fxos8700cqTypeMCtrlReg1MHms MCTRLREG1MHMS {
    Fxos8700cqTypeMCtrlReg1MHms get ();
    void set (Fxos8700cqTypeMCtrlReg1MHms value);
}
member MCTRLREG1MHMS : Fxos8700cqTypeMCtrlReg1MHms with get, set

Property Value

Type: Fxos8700cqTypeMCtrlReg1MHms
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MCTRLREG1MOS Property

IRD

Fxos8700cqMCTRLREG1MOS Property

M_CTRL_REG1: M_OS

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MCTRLREG1MOS { get; set; }
Public Property MCTRLREG1MOS As Byte
    Get
    Set
public:
property unsigned char MCTRLREG1MOS {
    unsigned char get ();
    void set (unsigned char value);
}
member MCTRLREG1MOS : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MCTRLREG1MOST Property

IRD

Fxos8700cqMCTRLREG1MOST Property

M_CTRL_REG1: M_OST

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMCtrlReg1MOst MCTRLREG1MOST { get; set; }
Public Property MCTRLREG1MOST As Fxos8700cqTypeMCtrlReg1MOst
    Get
    Set
public:
property Fxos8700cqTypeMCtrlReg1MOst MCTRLREG1MOST {
    Fxos8700cqTypeMCtrlReg1MOst get ();
    void set (Fxos8700cqTypeMCtrlReg1MOst value);
}
member MCTRLREG1MOST : Fxos8700cqTypeMCtrlReg1MOst with get, set

Property Value

Type: Fxos8700cqTypeMCtrlReg1MOst
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MCTRLREG1MRST Property

IRD

Fxos8700cqMCTRLREG1MRST Property

M_CTRL_REG1: M_RST

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMCtrlReg1MRst MCTRLREG1MRST { get; set; }
Public Property MCTRLREG1MRST As Fxos8700cqTypeMCtrlReg1MRst
    Get
    Set
public:
property Fxos8700cqTypeMCtrlReg1MRst MCTRLREG1MRST {
    Fxos8700cqTypeMCtrlReg1MRst get ();
    void set (Fxos8700cqTypeMCtrlReg1MRst value);
}
member MCTRLREG1MRST : Fxos8700cqTypeMCtrlReg1MRst with get, set

Property Value

Type: Fxos8700cqTypeMCtrlReg1MRst
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MCTRLREG2HYBAUTOINCMODE Property

IRD

Fxos8700cqMCTRLREG2HYBAUTOINCMODE Property

M_CTRL_REG2: HYB_AUTOINC_MODE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MCTRLREG2HYBAUTOINCMODE { get; set; }
Public Property MCTRLREG2HYBAUTOINCMODE As Byte
    Get
    Set
public:
property unsigned char MCTRLREG2HYBAUTOINCMODE {
    unsigned char get ();
    void set (unsigned char value);
}
member MCTRLREG2HYBAUTOINCMODE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MCTRLREG2MMAXMINCNT Property

IRD

Fxos8700cqMCTRLREG2MMAXMINCNT Property

M_CTRL_REG2: M_MAXMIN_CNT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMCtrlReg2MMaxminCnt MCTRLREG2MMAXMINCNT { get; set; }
Public Property MCTRLREG2MMAXMINCNT As Fxos8700cqTypeMCtrlReg2MMaxminCnt
    Get
    Set
public:
property Fxos8700cqTypeMCtrlReg2MMaxminCnt MCTRLREG2MMAXMINCNT {
    Fxos8700cqTypeMCtrlReg2MMaxminCnt get ();
    void set (Fxos8700cqTypeMCtrlReg2MMaxminCnt value);
}
member MCTRLREG2MMAXMINCNT : Fxos8700cqTypeMCtrlReg2MMaxminCnt with get, set

Property Value

Type: Fxos8700cqTypeMCtrlReg2MMaxminCnt
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MCTRLREG2MMAXMINDIS Property

IRD

Fxos8700cqMCTRLREG2MMAXMINDIS Property

M_CTRL_REG2: M_MAXMIN_DIS

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMCtrlReg2MMaxminDis MCTRLREG2MMAXMINDIS { get; set; }
Public Property MCTRLREG2MMAXMINDIS As Fxos8700cqTypeMCtrlReg2MMaxminDis
    Get
    Set
public:
property Fxos8700cqTypeMCtrlReg2MMaxminDis MCTRLREG2MMAXMINDIS {
    Fxos8700cqTypeMCtrlReg2MMaxminDis get ();
    void set (Fxos8700cqTypeMCtrlReg2MMaxminDis value);
}
member MCTRLREG2MMAXMINDIS : Fxos8700cqTypeMCtrlReg2MMaxminDis with get, set

Property Value

Type: Fxos8700cqTypeMCtrlReg2MMaxminDis
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MCTRLREG2MMAXMINDISTHS Property

IRD

Fxos8700cqMCTRLREG2MMAXMINDISTHS Property

M_CTRL_REG2: M_MAXMIN_DIS_THS

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMCtrlReg2MMaxminDisThs MCTRLREG2MMAXMINDISTHS { get; set; }
Public Property MCTRLREG2MMAXMINDISTHS As Fxos8700cqTypeMCtrlReg2MMaxminDisThs
    Get
    Set
public:
property Fxos8700cqTypeMCtrlReg2MMaxminDisThs MCTRLREG2MMAXMINDISTHS {
    Fxos8700cqTypeMCtrlReg2MMaxminDisThs get ();
    void set (Fxos8700cqTypeMCtrlReg2MMaxminDisThs value);
}
member MCTRLREG2MMAXMINDISTHS : Fxos8700cqTypeMCtrlReg2MMaxminDisThs with get, set

Property Value

Type: Fxos8700cqTypeMCtrlReg2MMaxminDisThs
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MCTRLREG2MMAXMINRST Property

IRD

Fxos8700cqMCTRLREG2MMAXMINRST Property

M_CTRL_REG2: M_MAXMIN_RST

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMCtrlReg2MMaxminRst MCTRLREG2MMAXMINRST { get; set; }
Public Property MCTRLREG2MMAXMINRST As Fxos8700cqTypeMCtrlReg2MMaxminRst
    Get
    Set
public:
property Fxos8700cqTypeMCtrlReg2MMaxminRst MCTRLREG2MMAXMINRST {
    Fxos8700cqTypeMCtrlReg2MMaxminRst get ();
    void set (Fxos8700cqTypeMCtrlReg2MMaxminRst value);
}
member MCTRLREG2MMAXMINRST : Fxos8700cqTypeMCtrlReg2MMaxminRst with get, set

Property Value

Type: Fxos8700cqTypeMCtrlReg2MMaxminRst
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MCTRLREG3MASLPOS Property

IRD

Fxos8700cqMCTRLREG3MASLPOS Property

M_CTRL_REG3: M_ASLP_OS

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MCTRLREG3MASLPOS { get; set; }
Public Property MCTRLREG3MASLPOS As Byte
    Get
    Set
public:
property unsigned char MCTRLREG3MASLPOS {
    unsigned char get ();
    void set (unsigned char value);
}
member MCTRLREG3MASLPOS : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MCTRLREG3MRAW Property

IRD

Fxos8700cqMCTRLREG3MRAW Property

M_CTRL_REG3: M_RAW

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMCtrlReg3MRaw MCTRLREG3MRAW { get; set; }
Public Property MCTRLREG3MRAW As Fxos8700cqTypeMCtrlReg3MRaw
    Get
    Set
public:
property Fxos8700cqTypeMCtrlReg3MRaw MCTRLREG3MRAW {
    Fxos8700cqTypeMCtrlReg3MRaw get ();
    void set (Fxos8700cqTypeMCtrlReg3MRaw value);
}
member MCTRLREG3MRAW : Fxos8700cqTypeMCtrlReg3MRaw with get, set

Property Value

Type: Fxos8700cqTypeMCtrlReg3MRaw
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MCTRLREG3MSTXY Property

IRD

Fxos8700cqMCTRLREG3MSTXY Property

M_CTRL_REG3: M_ST_XY

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMCtrlReg3MStXy MCTRLREG3MSTXY { get; set; }
Public Property MCTRLREG3MSTXY As Fxos8700cqTypeMCtrlReg3MStXy
    Get
    Set
public:
property Fxos8700cqTypeMCtrlReg3MStXy MCTRLREG3MSTXY {
    Fxos8700cqTypeMCtrlReg3MStXy get ();
    void set (Fxos8700cqTypeMCtrlReg3MStXy value);
}
member MCTRLREG3MSTXY : Fxos8700cqTypeMCtrlReg3MStXy with get, set

Property Value

Type: Fxos8700cqTypeMCtrlReg3MStXy
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MCTRLREG3MSTZ Property

IRD

Fxos8700cqMCTRLREG3MSTZ Property

M_CTRL_REG3: M_ST_Z

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMCtrlReg3MStZ MCTRLREG3MSTZ { get; set; }
Public Property MCTRLREG3MSTZ As Fxos8700cqTypeMCtrlReg3MStZ
    Get
    Set
public:
property Fxos8700cqTypeMCtrlReg3MStZ MCTRLREG3MSTZ {
    Fxos8700cqTypeMCtrlReg3MStZ get ();
    void set (Fxos8700cqTypeMCtrlReg3MStZ value);
}
member MCTRLREG3MSTZ : Fxos8700cqTypeMCtrlReg3MStZ with get, set

Property Value

Type: Fxos8700cqTypeMCtrlReg3MStZ
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MCTRLREG3MTHSXYZUPDATE Property

IRD

Fxos8700cqMCTRLREG3MTHSXYZUPDATE Property

M_CTRL_REG3: M_THS_XYZ_UPDATE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMCtrlReg3MThsXyzUpdate MCTRLREG3MTHSXYZUPDATE { get; set; }
Public Property MCTRLREG3MTHSXYZUPDATE As Fxos8700cqTypeMCtrlReg3MThsXyzUpdate
    Get
    Set
public:
property Fxos8700cqTypeMCtrlReg3MThsXyzUpdate MCTRLREG3MTHSXYZUPDATE {
    Fxos8700cqTypeMCtrlReg3MThsXyzUpdate get ();
    void set (Fxos8700cqTypeMCtrlReg3MThsXyzUpdate value);
}
member MCTRLREG3MTHSXYZUPDATE : Fxos8700cqTypeMCtrlReg3MThsXyzUpdate with get, set

Property Value

Type: Fxos8700cqTypeMCtrlReg3MThsXyzUpdate
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MDRSTATUSXDR Property

IRD

Fxos8700cqMDRSTATUSXDR Property

M_DR_STATUS: XDR

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMDrStatusXdr MDRSTATUSXDR { get; }
Public ReadOnly Property MDRSTATUSXDR As Fxos8700cqTypeMDrStatusXdr
    Get
public:
property Fxos8700cqTypeMDrStatusXdr MDRSTATUSXDR {
    Fxos8700cqTypeMDrStatusXdr get ();
}
member MDRSTATUSXDR : Fxos8700cqTypeMDrStatusXdr with get

Property Value

Type: Fxos8700cqTypeMDrStatusXdr
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MDRSTATUSXOW Property

IRD

Fxos8700cqMDRSTATUSXOW Property

M_DR_STATUS: XOW

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMDrStatusXow MDRSTATUSXOW { get; }
Public ReadOnly Property MDRSTATUSXOW As Fxos8700cqTypeMDrStatusXow
    Get
public:
property Fxos8700cqTypeMDrStatusXow MDRSTATUSXOW {
    Fxos8700cqTypeMDrStatusXow get ();
}
member MDRSTATUSXOW : Fxos8700cqTypeMDrStatusXow with get

Property Value

Type: Fxos8700cqTypeMDrStatusXow
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MDRSTATUSYDR Property

IRD

Fxos8700cqMDRSTATUSYDR Property

M_DR_STATUS: YDR

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMDrStatusYdr MDRSTATUSYDR { get; }
Public ReadOnly Property MDRSTATUSYDR As Fxos8700cqTypeMDrStatusYdr
    Get
public:
property Fxos8700cqTypeMDrStatusYdr MDRSTATUSYDR {
    Fxos8700cqTypeMDrStatusYdr get ();
}
member MDRSTATUSYDR : Fxos8700cqTypeMDrStatusYdr with get

Property Value

Type: Fxos8700cqTypeMDrStatusYdr
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MDRSTATUSYOW Property

IRD

Fxos8700cqMDRSTATUSYOW Property

M_DR_STATUS: YOW

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMDrStatusYow MDRSTATUSYOW { get; }
Public ReadOnly Property MDRSTATUSYOW As Fxos8700cqTypeMDrStatusYow
    Get
public:
property Fxos8700cqTypeMDrStatusYow MDRSTATUSYOW {
    Fxos8700cqTypeMDrStatusYow get ();
}
member MDRSTATUSYOW : Fxos8700cqTypeMDrStatusYow with get

Property Value

Type: Fxos8700cqTypeMDrStatusYow
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MDRSTATUSZDR Property

IRD

Fxos8700cqMDRSTATUSZDR Property

M_DR_STATUS: ZDR

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMDrStatusZdr MDRSTATUSZDR { get; }
Public ReadOnly Property MDRSTATUSZDR As Fxos8700cqTypeMDrStatusZdr
    Get
public:
property Fxos8700cqTypeMDrStatusZdr MDRSTATUSZDR {
    Fxos8700cqTypeMDrStatusZdr get ();
}
member MDRSTATUSZDR : Fxos8700cqTypeMDrStatusZdr with get

Property Value

Type: Fxos8700cqTypeMDrStatusZdr
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MDRSTATUSZOW Property

IRD

Fxos8700cqMDRSTATUSZOW Property

M_DR_STATUS: ZOW

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMDrStatusZow MDRSTATUSZOW { get; }
Public ReadOnly Property MDRSTATUSZOW As Fxos8700cqTypeMDrStatusZow
    Get
public:
property Fxos8700cqTypeMDrStatusZow MDRSTATUSZOW {
    Fxos8700cqTypeMDrStatusZow get ();
}
member MDRSTATUSZOW : Fxos8700cqTypeMDrStatusZow with get

Property Value

Type: Fxos8700cqTypeMDrStatusZow
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MDRSTATUSZYXDR Property

IRD

Fxos8700cqMDRSTATUSZYXDR Property

M_DR_STATUS: ZYXDR

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMDrStatusZyxdr MDRSTATUSZYXDR { get; }
Public ReadOnly Property MDRSTATUSZYXDR As Fxos8700cqTypeMDrStatusZyxdr
    Get
public:
property Fxos8700cqTypeMDrStatusZyxdr MDRSTATUSZYXDR {
    Fxos8700cqTypeMDrStatusZyxdr get ();
}
member MDRSTATUSZYXDR : Fxos8700cqTypeMDrStatusZyxdr with get

Property Value

Type: Fxos8700cqTypeMDrStatusZyxdr
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MDRSTATUSZYXOW Property

IRD

Fxos8700cqMDRSTATUSZYXOW Property

M_DR_STATUS: ZYXOW

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMDrStatusZyxow MDRSTATUSZYXOW { get; }
Public ReadOnly Property MDRSTATUSZYXOW As Fxos8700cqTypeMDrStatusZyxow
    Get
public:
property Fxos8700cqTypeMDrStatusZyxow MDRSTATUSZYXOW {
    Fxos8700cqTypeMDrStatusZyxow get ();
}
member MDRSTATUSZYXOW : Fxos8700cqTypeMDrStatusZyxow with get

Property Value

Type: Fxos8700cqTypeMDrStatusZyxow
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MINTSRCSRCMDRDY Property

IRD

Fxos8700cqMINTSRCSRCMDRDY Property

M_INT_SRC: SRC_M_DRDY

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMIntSrcSrcMDrdy MINTSRCSRCMDRDY { get; }
Public ReadOnly Property MINTSRCSRCMDRDY As Fxos8700cqTypeMIntSrcSrcMDrdy
    Get
public:
property Fxos8700cqTypeMIntSrcSrcMDrdy MINTSRCSRCMDRDY {
    Fxos8700cqTypeMIntSrcSrcMDrdy get ();
}
member MINTSRCSRCMDRDY : Fxos8700cqTypeMIntSrcSrcMDrdy with get

Property Value

Type: Fxos8700cqTypeMIntSrcSrcMDrdy
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MINTSRCSRCMTHS Property

IRD

Fxos8700cqMINTSRCSRCMTHS Property

M_INT_SRC: SRC_M_THS

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMIntSrcSrcMThs MINTSRCSRCMTHS { get; }
Public ReadOnly Property MINTSRCSRCMTHS As Fxos8700cqTypeMIntSrcSrcMThs
    Get
public:
property Fxos8700cqTypeMIntSrcSrcMThs MINTSRCSRCMTHS {
    Fxos8700cqTypeMIntSrcSrcMThs get ();
}
member MINTSRCSRCMTHS : Fxos8700cqTypeMIntSrcSrcMThs with get

Property Value

Type: Fxos8700cqTypeMIntSrcSrcMThs
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MINTSRCSRCMVECM Property

IRD

Fxos8700cqMINTSRCSRCMVECM Property

M_INT_SRC: SRC_M_VECM

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMIntSrcSrcMVecm MINTSRCSRCMVECM { get; }
Public ReadOnly Property MINTSRCSRCMVECM As Fxos8700cqTypeMIntSrcSrcMVecm
    Get
public:
property Fxos8700cqTypeMIntSrcSrcMVecm MINTSRCSRCMVECM {
    Fxos8700cqTypeMIntSrcSrcMVecm get ();
}
member MINTSRCSRCMVECM : Fxos8700cqTypeMIntSrcSrcMVecm with get

Property Value

Type: Fxos8700cqTypeMIntSrcSrcMVecm
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MINX Property

IRD

Fxos8700cqMINX Property

MIN_X (unit: μT)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MINX { get; }
Public ReadOnly Property MINX As Double
    Get
public:
property double MINX {
    double get ();
}
member MINX : float with get

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MINY Property

IRD

Fxos8700cqMINY Property

MIN_Y (unit: μT)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MINY { get; }
Public ReadOnly Property MINY As Double
    Get
public:
property double MINY {
    double get ();
}
member MINY : float with get

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MINZ Property

IRD

Fxos8700cqMINZ Property

MIN_Z (unit: μT)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MINZ { get; }
Public ReadOnly Property MINZ As Double
    Get
public:
property double MINZ {
    double get ();
}
member MINZ : float with get

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MOFFX Property

IRD

Fxos8700cqMOFFX Property

M_OFF_X (unit: μT)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MOFFX { get; set; }
Public Property MOFFX As Double
    Get
    Set
public:
property double MOFFX {
    double get ();
    void set (double value);
}
member MOFFX : float with get, set

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MOFFY Property

IRD

Fxos8700cqMOFFY Property

M_OFF_Y (unit: μT)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MOFFY { get; set; }
Public Property MOFFY As Double
    Get
    Set
public:
property double MOFFY {
    double get ();
    void set (double value);
}
member MOFFY : float with get, set

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MOFFZ Property

IRD

Fxos8700cqMOFFZ Property

M_OFF_Z (unit: μT)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MOFFZ { get; set; }
Public Property MOFFZ As Double
    Get
    Set
public:
property double MOFFZ {
    double get ();
    void set (double value);
}
member MOFFZ : float with get, set

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MOUTX Property

IRD

Fxos8700cqMOUTX Property

M_OUT_X (unit: μT)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MOUTX { get; }
Public ReadOnly Property MOUTX As Double
    Get
public:
property double MOUTX {
    double get ();
}
member MOUTX : float with get

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MOUTY Property

IRD

Fxos8700cqMOUTY Property

M_OUT_Y (unit: μT)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MOUTY { get; }
Public ReadOnly Property MOUTY As Double
    Get
public:
property double MOUTY {
    double get ();
}
member MOUTY : float with get

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MOUTZ Property

IRD

Fxos8700cqMOUTZ Property

M_OUT_Z (unit: μT)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MOUTZ { get; }
Public ReadOnly Property MOUTZ As Double
    Get
public:
property double MOUTZ {
    double get ();
}
member MOUTZ : float with get

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSCFGMTHSELE Property

IRD

Fxos8700cqMTHSCFGMTHSELE Property

M_THS_CFG: M_THS_ELE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMThsCfgMThsEle MTHSCFGMTHSELE { get; set; }
Public Property MTHSCFGMTHSELE As Fxos8700cqTypeMThsCfgMThsEle
    Get
    Set
public:
property Fxos8700cqTypeMThsCfgMThsEle MTHSCFGMTHSELE {
    Fxos8700cqTypeMThsCfgMThsEle get ();
    void set (Fxos8700cqTypeMThsCfgMThsEle value);
}
member MTHSCFGMTHSELE : Fxos8700cqTypeMThsCfgMThsEle with get, set

Property Value

Type: Fxos8700cqTypeMThsCfgMThsEle
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSCFGMTHSINTCFG Property

IRD

Fxos8700cqMTHSCFGMTHSINTCFG Property

M_THS_CFG: M_THS_INT_CFG

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMThsCfgMThsIntCfg MTHSCFGMTHSINTCFG { get; set; }
Public Property MTHSCFGMTHSINTCFG As Fxos8700cqTypeMThsCfgMThsIntCfg
    Get
    Set
public:
property Fxos8700cqTypeMThsCfgMThsIntCfg MTHSCFGMTHSINTCFG {
    Fxos8700cqTypeMThsCfgMThsIntCfg get ();
    void set (Fxos8700cqTypeMThsCfgMThsIntCfg value);
}
member MTHSCFGMTHSINTCFG : Fxos8700cqTypeMThsCfgMThsIntCfg with get, set

Property Value

Type: Fxos8700cqTypeMThsCfgMThsIntCfg
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSCFGMTHSINTEN Property

IRD

Fxos8700cqMTHSCFGMTHSINTEN Property

M_THS_CFG: M_THS_INT_EN

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMThsCfgMThsIntEn MTHSCFGMTHSINTEN { get; set; }
Public Property MTHSCFGMTHSINTEN As Fxos8700cqTypeMThsCfgMThsIntEn
    Get
    Set
public:
property Fxos8700cqTypeMThsCfgMThsIntEn MTHSCFGMTHSINTEN {
    Fxos8700cqTypeMThsCfgMThsIntEn get ();
    void set (Fxos8700cqTypeMThsCfgMThsIntEn value);
}
member MTHSCFGMTHSINTEN : Fxos8700cqTypeMThsCfgMThsIntEn with get, set

Property Value

Type: Fxos8700cqTypeMThsCfgMThsIntEn
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSCFGMTHSOAE Property

IRD

Fxos8700cqMTHSCFGMTHSOAE Property

M_THS_CFG: M_THS_OAE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMThsCfgMThsOae MTHSCFGMTHSOAE { get; set; }
Public Property MTHSCFGMTHSOAE As Fxos8700cqTypeMThsCfgMThsOae
    Get
    Set
public:
property Fxos8700cqTypeMThsCfgMThsOae MTHSCFGMTHSOAE {
    Fxos8700cqTypeMThsCfgMThsOae get ();
    void set (Fxos8700cqTypeMThsCfgMThsOae value);
}
member MTHSCFGMTHSOAE : Fxos8700cqTypeMThsCfgMThsOae with get, set

Property Value

Type: Fxos8700cqTypeMThsCfgMThsOae
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSCFGMTHSWAKEEN Property

IRD

Fxos8700cqMTHSCFGMTHSWAKEEN Property

M_THS_CFG: M_THS_WAKE_EN

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMThsCfgMThsWakeEn MTHSCFGMTHSWAKEEN { get; set; }
Public Property MTHSCFGMTHSWAKEEN As Fxos8700cqTypeMThsCfgMThsWakeEn
    Get
    Set
public:
property Fxos8700cqTypeMThsCfgMThsWakeEn MTHSCFGMTHSWAKEEN {
    Fxos8700cqTypeMThsCfgMThsWakeEn get ();
    void set (Fxos8700cqTypeMThsCfgMThsWakeEn value);
}
member MTHSCFGMTHSWAKEEN : Fxos8700cqTypeMThsCfgMThsWakeEn with get, set

Property Value

Type: Fxos8700cqTypeMThsCfgMThsWakeEn
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSCFGMTHSXEFE Property

IRD

Fxos8700cqMTHSCFGMTHSXEFE Property

M_THS_CFG: M_THS_XEFE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMThsCfgMThsXefe MTHSCFGMTHSXEFE { get; set; }
Public Property MTHSCFGMTHSXEFE As Fxos8700cqTypeMThsCfgMThsXefe
    Get
    Set
public:
property Fxos8700cqTypeMThsCfgMThsXefe MTHSCFGMTHSXEFE {
    Fxos8700cqTypeMThsCfgMThsXefe get ();
    void set (Fxos8700cqTypeMThsCfgMThsXefe value);
}
member MTHSCFGMTHSXEFE : Fxos8700cqTypeMThsCfgMThsXefe with get, set

Property Value

Type: Fxos8700cqTypeMThsCfgMThsXefe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSCFGMTHSYEFE Property

IRD

Fxos8700cqMTHSCFGMTHSYEFE Property

M_THS_CFG: M_THS_YEFE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMThsCfgMThsYefe MTHSCFGMTHSYEFE { get; set; }
Public Property MTHSCFGMTHSYEFE As Fxos8700cqTypeMThsCfgMThsYefe
    Get
    Set
public:
property Fxos8700cqTypeMThsCfgMThsYefe MTHSCFGMTHSYEFE {
    Fxos8700cqTypeMThsCfgMThsYefe get ();
    void set (Fxos8700cqTypeMThsCfgMThsYefe value);
}
member MTHSCFGMTHSYEFE : Fxos8700cqTypeMThsCfgMThsYefe with get, set

Property Value

Type: Fxos8700cqTypeMThsCfgMThsYefe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSCFGMTHSZEFE Property

IRD

Fxos8700cqMTHSCFGMTHSZEFE Property

M_THS_CFG: M_THS_ZEFE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMThsCfgMThsZefe MTHSCFGMTHSZEFE { get; set; }
Public Property MTHSCFGMTHSZEFE As Fxos8700cqTypeMThsCfgMThsZefe
    Get
    Set
public:
property Fxos8700cqTypeMThsCfgMThsZefe MTHSCFGMTHSZEFE {
    Fxos8700cqTypeMThsCfgMThsZefe get ();
    void set (Fxos8700cqTypeMThsCfgMThsZefe value);
}
member MTHSCFGMTHSZEFE : Fxos8700cqTypeMThsCfgMThsZefe with get, set

Property Value

Type: Fxos8700cqTypeMThsCfgMThsZefe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSCOUNT Property

IRD

Fxos8700cqMTHSCOUNT Property

M_THS_COUNT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MTHSCOUNT { get; set; }
Public Property MTHSCOUNT As Byte
    Get
    Set
public:
property unsigned char MTHSCOUNT {
    unsigned char get ();
    void set (unsigned char value);
}
member MTHSCOUNT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSSRCMTHSEA Property

IRD

Fxos8700cqMTHSSRCMTHSEA Property

M_THS_SRC: M_THS_EA

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMThsSrcMThsEa MTHSSRCMTHSEA { get; }
Public ReadOnly Property MTHSSRCMTHSEA As Fxos8700cqTypeMThsSrcMThsEa
    Get
public:
property Fxos8700cqTypeMThsSrcMThsEa MTHSSRCMTHSEA {
    Fxos8700cqTypeMThsSrcMThsEa get ();
}
member MTHSSRCMTHSEA : Fxos8700cqTypeMThsSrcMThsEa with get

Property Value

Type: Fxos8700cqTypeMThsSrcMThsEa
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSSRCMTHSXHE Property

IRD

Fxos8700cqMTHSSRCMTHSXHE Property

M_THS_SRC: M_THS_XHE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMThsSrcMThsXhe MTHSSRCMTHSXHE { get; }
Public ReadOnly Property MTHSSRCMTHSXHE As Fxos8700cqTypeMThsSrcMThsXhe
    Get
public:
property Fxos8700cqTypeMThsSrcMThsXhe MTHSSRCMTHSXHE {
    Fxos8700cqTypeMThsSrcMThsXhe get ();
}
member MTHSSRCMTHSXHE : Fxos8700cqTypeMThsSrcMThsXhe with get

Property Value

Type: Fxos8700cqTypeMThsSrcMThsXhe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSSRCMTHSXHP Property

IRD

Fxos8700cqMTHSSRCMTHSXHP Property

M_THS_SRC: M_THS_XHP

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMThsSrcMThsXhp MTHSSRCMTHSXHP { get; }
Public ReadOnly Property MTHSSRCMTHSXHP As Fxos8700cqTypeMThsSrcMThsXhp
    Get
public:
property Fxos8700cqTypeMThsSrcMThsXhp MTHSSRCMTHSXHP {
    Fxos8700cqTypeMThsSrcMThsXhp get ();
}
member MTHSSRCMTHSXHP : Fxos8700cqTypeMThsSrcMThsXhp with get

Property Value

Type: Fxos8700cqTypeMThsSrcMThsXhp
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSSRCMTHSYHE Property

IRD

Fxos8700cqMTHSSRCMTHSYHE Property

M_THS_SRC: M_THS_YHE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMThsSrcMThsYhe MTHSSRCMTHSYHE { get; }
Public ReadOnly Property MTHSSRCMTHSYHE As Fxos8700cqTypeMThsSrcMThsYhe
    Get
public:
property Fxos8700cqTypeMThsSrcMThsYhe MTHSSRCMTHSYHE {
    Fxos8700cqTypeMThsSrcMThsYhe get ();
}
member MTHSSRCMTHSYHE : Fxos8700cqTypeMThsSrcMThsYhe with get

Property Value

Type: Fxos8700cqTypeMThsSrcMThsYhe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSSRCMTHSYHP Property

IRD

Fxos8700cqMTHSSRCMTHSYHP Property

M_THS_SRC: M_THS_YHP

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMThsSrcMThsYhp MTHSSRCMTHSYHP { get; }
Public ReadOnly Property MTHSSRCMTHSYHP As Fxos8700cqTypeMThsSrcMThsYhp
    Get
public:
property Fxos8700cqTypeMThsSrcMThsYhp MTHSSRCMTHSYHP {
    Fxos8700cqTypeMThsSrcMThsYhp get ();
}
member MTHSSRCMTHSYHP : Fxos8700cqTypeMThsSrcMThsYhp with get

Property Value

Type: Fxos8700cqTypeMThsSrcMThsYhp
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSSRCMTHSZHE Property

IRD

Fxos8700cqMTHSSRCMTHSZHE Property

M_THS_SRC: M_THS_ZHE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMThsSrcMThsZhe MTHSSRCMTHSZHE { get; }
Public ReadOnly Property MTHSSRCMTHSZHE As Fxos8700cqTypeMThsSrcMThsZhe
    Get
public:
property Fxos8700cqTypeMThsSrcMThsZhe MTHSSRCMTHSZHE {
    Fxos8700cqTypeMThsSrcMThsZhe get ();
}
member MTHSSRCMTHSZHE : Fxos8700cqTypeMThsSrcMThsZhe with get

Property Value

Type: Fxos8700cqTypeMThsSrcMThsZhe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSSRCMTHSZHP Property

IRD

Fxos8700cqMTHSSRCMTHSZHP Property

M_THS_SRC: M_THS_ZHP

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMThsSrcMThsZhp MTHSSRCMTHSZHP { get; }
Public ReadOnly Property MTHSSRCMTHSZHP As Fxos8700cqTypeMThsSrcMThsZhp
    Get
public:
property Fxos8700cqTypeMThsSrcMThsZhp MTHSSRCMTHSZHP {
    Fxos8700cqTypeMThsSrcMThsZhp get ();
}
member MTHSSRCMTHSZHP : Fxos8700cqTypeMThsSrcMThsZhp with get

Property Value

Type: Fxos8700cqTypeMThsSrcMThsZhp
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSXMTHSDBCNTM Property

IRD

Fxos8700cqMTHSXMTHSDBCNTM Property

M_THS_X: M_THS_DBCNTM

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMThsXMThsDbcntm MTHSXMTHSDBCNTM { get; set; }
Public Property MTHSXMTHSDBCNTM As Fxos8700cqTypeMThsXMThsDbcntm
    Get
    Set
public:
property Fxos8700cqTypeMThsXMThsDbcntm MTHSXMTHSDBCNTM {
    Fxos8700cqTypeMThsXMThsDbcntm get ();
    void set (Fxos8700cqTypeMThsXMThsDbcntm value);
}
member MTHSXMTHSDBCNTM : Fxos8700cqTypeMThsXMThsDbcntm with get, set

Property Value

Type: Fxos8700cqTypeMThsXMThsDbcntm
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSXMTHSX Property

IRD

Fxos8700cqMTHSXMTHSX Property

M_THS_X: M_THS_X (unit: μT)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MTHSXMTHSX { get; set; }
Public Property MTHSXMTHSX As Double
    Get
    Set
public:
property double MTHSXMTHSX {
    double get ();
    void set (double value);
}
member MTHSXMTHSX : float with get, set

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSY Property

IRD

Fxos8700cqMTHSY Property

M_THS_Y (unit: μT)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MTHSY { get; set; }
Public Property MTHSY As Double
    Get
    Set
public:
property double MTHSY {
    double get ();
    void set (double value);
}
member MTHSY : float with get, set

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MTHSZ Property

IRD

Fxos8700cqMTHSZ Property

M_THS_Z (unit: μT)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MTHSZ { get; set; }
Public Property MTHSZ As Double
    Get
    Set
public:
property double MTHSZ {
    double get ();
    void set (double value);
}
member MTHSZ : float with get, set

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MVECMCFGMVECMELE Property

IRD

Fxos8700cqMVECMCFGMVECMELE Property

M_VECM_CFG: M_VECM_ELE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMVecmCfgMVecmEle MVECMCFGMVECMELE { get; set; }
Public Property MVECMCFGMVECMELE As Fxos8700cqTypeMVecmCfgMVecmEle
    Get
    Set
public:
property Fxos8700cqTypeMVecmCfgMVecmEle MVECMCFGMVECMELE {
    Fxos8700cqTypeMVecmCfgMVecmEle get ();
    void set (Fxos8700cqTypeMVecmCfgMVecmEle value);
}
member MVECMCFGMVECMELE : Fxos8700cqTypeMVecmCfgMVecmEle with get, set

Property Value

Type: Fxos8700cqTypeMVecmCfgMVecmEle
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MVECMCFGMVECMEN Property

IRD

Fxos8700cqMVECMCFGMVECMEN Property

M_VECM_CFG: M_VECM_EN

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMVecmCfgMVecmEn MVECMCFGMVECMEN { get; set; }
Public Property MVECMCFGMVECMEN As Fxos8700cqTypeMVecmCfgMVecmEn
    Get
    Set
public:
property Fxos8700cqTypeMVecmCfgMVecmEn MVECMCFGMVECMEN {
    Fxos8700cqTypeMVecmCfgMVecmEn get ();
    void set (Fxos8700cqTypeMVecmCfgMVecmEn value);
}
member MVECMCFGMVECMEN : Fxos8700cqTypeMVecmCfgMVecmEn with get, set

Property Value

Type: Fxos8700cqTypeMVecmCfgMVecmEn
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MVECMCFGMVECMINITM Property

IRD

Fxos8700cqMVECMCFGMVECMINITM Property

M_VECM_CFG: M_VECM_INITM

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMVecmCfgMVecmInitm MVECMCFGMVECMINITM { get; set; }
Public Property MVECMCFGMVECMINITM As Fxos8700cqTypeMVecmCfgMVecmInitm
    Get
    Set
public:
property Fxos8700cqTypeMVecmCfgMVecmInitm MVECMCFGMVECMINITM {
    Fxos8700cqTypeMVecmCfgMVecmInitm get ();
    void set (Fxos8700cqTypeMVecmCfgMVecmInitm value);
}
member MVECMCFGMVECMINITM : Fxos8700cqTypeMVecmCfgMVecmInitm with get, set

Property Value

Type: Fxos8700cqTypeMVecmCfgMVecmInitm
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MVECMCFGMVECMINTCFG Property

IRD

Fxos8700cqMVECMCFGMVECMINTCFG Property

M_VECM_CFG: M_VECM_INT_CFG

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMVecmCfgMVecmIntCfg MVECMCFGMVECMINTCFG { get; set; }
Public Property MVECMCFGMVECMINTCFG As Fxos8700cqTypeMVecmCfgMVecmIntCfg
    Get
    Set
public:
property Fxos8700cqTypeMVecmCfgMVecmIntCfg MVECMCFGMVECMINTCFG {
    Fxos8700cqTypeMVecmCfgMVecmIntCfg get ();
    void set (Fxos8700cqTypeMVecmCfgMVecmIntCfg value);
}
member MVECMCFGMVECMINTCFG : Fxos8700cqTypeMVecmCfgMVecmIntCfg with get, set

Property Value

Type: Fxos8700cqTypeMVecmCfgMVecmIntCfg
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MVECMCFGMVECMINTEN Property

IRD

Fxos8700cqMVECMCFGMVECMINTEN Property

M_VECM_CFG: M_VECM_INT_EN

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMVecmCfgMVecmIntEn MVECMCFGMVECMINTEN { get; set; }
Public Property MVECMCFGMVECMINTEN As Fxos8700cqTypeMVecmCfgMVecmIntEn
    Get
    Set
public:
property Fxos8700cqTypeMVecmCfgMVecmIntEn MVECMCFGMVECMINTEN {
    Fxos8700cqTypeMVecmCfgMVecmIntEn get ();
    void set (Fxos8700cqTypeMVecmCfgMVecmIntEn value);
}
member MVECMCFGMVECMINTEN : Fxos8700cqTypeMVecmCfgMVecmIntEn with get, set

Property Value

Type: Fxos8700cqTypeMVecmCfgMVecmIntEn
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MVECMCFGMVECMUPDM Property

IRD

Fxos8700cqMVECMCFGMVECMUPDM Property

M_VECM_CFG: M_VECM_UPDM

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMVecmCfgMVecmUpdm MVECMCFGMVECMUPDM { get; set; }
Public Property MVECMCFGMVECMUPDM As Fxos8700cqTypeMVecmCfgMVecmUpdm
    Get
    Set
public:
property Fxos8700cqTypeMVecmCfgMVecmUpdm MVECMCFGMVECMUPDM {
    Fxos8700cqTypeMVecmCfgMVecmUpdm get ();
    void set (Fxos8700cqTypeMVecmCfgMVecmUpdm value);
}
member MVECMCFGMVECMUPDM : Fxos8700cqTypeMVecmCfgMVecmUpdm with get, set

Property Value

Type: Fxos8700cqTypeMVecmCfgMVecmUpdm
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MVECMCFGMVECMWAKEEN Property

IRD

Fxos8700cqMVECMCFGMVECMWAKEEN Property

M_VECM_CFG: M_VECM_WAKE_EN

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeMVecmCfgMVecmWakeEn MVECMCFGMVECMWAKEEN { get; set; }
Public Property MVECMCFGMVECMWAKEEN As Fxos8700cqTypeMVecmCfgMVecmWakeEn
    Get
    Set
public:
property Fxos8700cqTypeMVecmCfgMVecmWakeEn MVECMCFGMVECMWAKEEN {
    Fxos8700cqTypeMVecmCfgMVecmWakeEn get ();
    void set (Fxos8700cqTypeMVecmCfgMVecmWakeEn value);
}
member MVECMCFGMVECMWAKEEN : Fxos8700cqTypeMVecmCfgMVecmWakeEn with get, set

Property Value

Type: Fxos8700cqTypeMVecmCfgMVecmWakeEn
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MVECMCNT Property

IRD

Fxos8700cqMVECMCNT Property

M_VECM_CNT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MVECMCNT { get; set; }
Public Property MVECMCNT As Byte
    Get
    Set
public:
property unsigned char MVECMCNT {
    unsigned char get ();
    void set (unsigned char value);
}
member MVECMCNT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MVECMINITX Property

IRD

Fxos8700cqMVECMINITX Property

M_VECM_INITX

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short MVECMINITX { get; set; }
Public Property MVECMINITX As Short
    Get
    Set
public:
property short MVECMINITX {
    short get ();
    void set (short value);
}
member MVECMINITX : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MVECMINITY Property

IRD

Fxos8700cqMVECMINITY Property

M_VECM_INITY

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short MVECMINITY { get; set; }
Public Property MVECMINITY As Short
    Get
    Set
public:
property short MVECMINITY {
    short get ();
    void set (short value);
}
member MVECMINITY : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MVECMINITZ Property

IRD

Fxos8700cqMVECMINITZ Property

M_VECM_INITZ

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short MVECMINITZ { get; set; }
Public Property MVECMINITZ As Short
    Get
    Set
public:
property short MVECMINITZ {
    short get ();
    void set (short value);
}
member MVECMINITZ : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MVECMTHSMVECMDBCNTM Property

IRD

Fxos8700cqMVECMTHSMVECMDBCNTM Property

M_VECM_THS: M_VECM_DBCNTM

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MVECMTHSMVECMDBCNTM { get; set; }
Public Property MVECMTHSMVECMDBCNTM As Byte
    Get
    Set
public:
property unsigned char MVECMTHSMVECMDBCNTM {
    unsigned char get ();
    void set (unsigned char value);
}
member MVECMTHSMVECMDBCNTM : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.MVECMTHSMVECMTHS Property

IRD

Fxos8700cqMVECMTHSMVECMTHS Property

M_VECM_THS: M_VECM_THS (unit: μT)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MVECMTHSMVECMTHS { get; set; }
Public Property MVECMTHSMVECMTHS As Double
    Get
    Set
public:
property double MVECMTHSMVECMTHS {
    double get ();
    void set (double value);
}
member MVECMTHSMVECMTHS : float with get, set

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.OFFX Property

IRD

Fxos8700cqOFFX Property

OFF_X

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte OFFX { get; set; }
Public Property OFFX As SByte
    Get
    Set
public:
property signed char OFFX {
    signed char get ();
    void set (signed char value);
}
member OFFX : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.OFFY Property

IRD

Fxos8700cqOFFY Property

OFF_Y

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte OFFY { get; set; }
Public Property OFFY As SByte
    Get
    Set
public:
property signed char OFFY {
    signed char get ();
    void set (signed char value);
}
member OFFY : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.OFFZ Property

IRD

Fxos8700cqOFFZ Property

OFF_Z

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte OFFZ { get; set; }
Public Property OFFZ As SByte
    Get
    Set
public:
property signed char OFFZ {
    signed char get ();
    void set (signed char value);
}
member OFFZ : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.OUTX Property

IRD

Fxos8700cqOUTX Property

OUT_X

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short OUTX { get; }
Public ReadOnly Property OUTX As Short
    Get
public:
property short OUTX {
    short get ();
}
member OUTX : int16 with get

Property Value

Type: Int16
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.OUTY Property

IRD

Fxos8700cqOUTY Property

OUT_Y

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short OUTY { get; }
Public ReadOnly Property OUTY As Short
    Get
public:
property short OUTY {
    short get ();
}
member OUTY : int16 with get

Property Value

Type: Int16
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.OUTZ Property

IRD

Fxos8700cqOUTZ Property

OUT_Z

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short OUTZ { get; }
Public ReadOnly Property OUTZ As Short
    Get
public:
property short OUTZ {
    short get ();
}
member OUTZ : int16 with get

Property Value

Type: Int16
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PLBFZCOMPBKFR Property

IRD

Fxos8700cqPLBFZCOMPBKFR Property

PL_BF_ZCOMP: BKFR

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PLBFZCOMPBKFR { get; set; }
Public Property PLBFZCOMPBKFR As Byte
    Get
    Set
public:
property unsigned char PLBFZCOMPBKFR {
    unsigned char get ();
    void set (unsigned char value);
}
member PLBFZCOMPBKFR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PLBFZCOMPZLOCK Property

IRD

Fxos8700cqPLBFZCOMPZLOCK Property

PL_BF_ZCOMP: ZLOCK

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePlBfZcompZlock PLBFZCOMPZLOCK { get; set; }
Public Property PLBFZCOMPZLOCK As Fxos8700cqTypePlBfZcompZlock
    Get
    Set
public:
property Fxos8700cqTypePlBfZcompZlock PLBFZCOMPZLOCK {
    Fxos8700cqTypePlBfZcompZlock get ();
    void set (Fxos8700cqTypePlBfZcompZlock value);
}
member PLBFZCOMPZLOCK : Fxos8700cqTypePlBfZcompZlock with get, set

Property Value

Type: Fxos8700cqTypePlBfZcompZlock
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PLCFGDBCNTM Property

IRD

Fxos8700cqPLCFGDBCNTM Property

PL_CFG: DBCNTM

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePlCfgDbcntm PLCFGDBCNTM { get; set; }
Public Property PLCFGDBCNTM As Fxos8700cqTypePlCfgDbcntm
    Get
    Set
public:
property Fxos8700cqTypePlCfgDbcntm PLCFGDBCNTM {
    Fxos8700cqTypePlCfgDbcntm get ();
    void set (Fxos8700cqTypePlCfgDbcntm value);
}
member PLCFGDBCNTM : Fxos8700cqTypePlCfgDbcntm with get, set

Property Value

Type: Fxos8700cqTypePlCfgDbcntm
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PLCFGPLEN Property

IRD

Fxos8700cqPLCFGPLEN Property

PL_CFG: PL_EN

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePlCfgPlEn PLCFGPLEN { get; set; }
Public Property PLCFGPLEN As Fxos8700cqTypePlCfgPlEn
    Get
    Set
public:
property Fxos8700cqTypePlCfgPlEn PLCFGPLEN {
    Fxos8700cqTypePlCfgPlEn get ();
    void set (Fxos8700cqTypePlCfgPlEn value);
}
member PLCFGPLEN : Fxos8700cqTypePlCfgPlEn with get, set

Property Value

Type: Fxos8700cqTypePlCfgPlEn
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PLCOUNTDBNCE Property

IRD

Fxos8700cqPLCOUNTDBNCE Property

PL_COUNT: DBNCE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PLCOUNTDBNCE { get; set; }
Public Property PLCOUNTDBNCE As Byte
    Get
    Set
public:
property unsigned char PLCOUNTDBNCE {
    unsigned char get ();
    void set (unsigned char value);
}
member PLCOUNTDBNCE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PLSTATUSBAFRO Property

IRD

Fxos8700cqPLSTATUSBAFRO Property

PL_STATUS: BAFRO

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePlStatusBafro PLSTATUSBAFRO { get; }
Public ReadOnly Property PLSTATUSBAFRO As Fxos8700cqTypePlStatusBafro
    Get
public:
property Fxos8700cqTypePlStatusBafro PLSTATUSBAFRO {
    Fxos8700cqTypePlStatusBafro get ();
}
member PLSTATUSBAFRO : Fxos8700cqTypePlStatusBafro with get

Property Value

Type: Fxos8700cqTypePlStatusBafro
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PLSTATUSIO Property

IRD

Fxos8700cqPLSTATUSIO Property

PL_STATUS: IO

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePlStatusIo PLSTATUSIO { get; }
Public ReadOnly Property PLSTATUSIO As Fxos8700cqTypePlStatusIo
    Get
public:
property Fxos8700cqTypePlStatusIo PLSTATUSIO {
    Fxos8700cqTypePlStatusIo get ();
}
member PLSTATUSIO : Fxos8700cqTypePlStatusIo with get

Property Value

Type: Fxos8700cqTypePlStatusIo
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PLSTATUSLAPO Property

IRD

Fxos8700cqPLSTATUSLAPO Property

PL_STATUS: LAPO

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePlStatusLapo PLSTATUSLAPO { get; }
Public ReadOnly Property PLSTATUSLAPO As Fxos8700cqTypePlStatusLapo
    Get
public:
property Fxos8700cqTypePlStatusLapo PLSTATUSLAPO {
    Fxos8700cqTypePlStatusLapo get ();
}
member PLSTATUSLAPO : Fxos8700cqTypePlStatusLapo with get

Property Value

Type: Fxos8700cqTypePlStatusLapo
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PLSTATUSNEWLP Property

IRD

Fxos8700cqPLSTATUSNEWLP Property

PL_STATUS: NEWLP

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePlStatusNewlp PLSTATUSNEWLP { get; }
Public ReadOnly Property PLSTATUSNEWLP As Fxos8700cqTypePlStatusNewlp
    Get
public:
property Fxos8700cqTypePlStatusNewlp PLSTATUSNEWLP {
    Fxos8700cqTypePlStatusNewlp get ();
}
member PLSTATUSNEWLP : Fxos8700cqTypePlStatusNewlp with get

Property Value

Type: Fxos8700cqTypePlStatusNewlp
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PLTHSREGHYS Property

IRD

Fxos8700cqPLTHSREGHYS Property

PL_THS_REG: HYS

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePlThsRegHys PLTHSREGHYS { get; set; }
Public Property PLTHSREGHYS As Fxos8700cqTypePlThsRegHys
    Get
    Set
public:
property Fxos8700cqTypePlThsRegHys PLTHSREGHYS {
    Fxos8700cqTypePlThsRegHys get ();
    void set (Fxos8700cqTypePlThsRegHys value);
}
member PLTHSREGHYS : Fxos8700cqTypePlThsRegHys with get, set

Property Value

Type: Fxos8700cqTypePlThsRegHys
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PLTHSREGPLTHS Property

IRD

Fxos8700cqPLTHSREGPLTHS Property

PL_THS_REG: PL_THS

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePlThsRegPlThs PLTHSREGPLTHS { get; set; }
Public Property PLTHSREGPLTHS As Fxos8700cqTypePlThsRegPlThs
    Get
    Set
public:
property Fxos8700cqTypePlThsRegPlThs PLTHSREGPLTHS {
    Fxos8700cqTypePlThsRegPlThs get ();
    void set (Fxos8700cqTypePlThsRegPlThs value);
}
member PLTHSREGPLTHS : Fxos8700cqTypePlThsRegPlThs with get, set

Property Value

Type: Fxos8700cqTypePlThsRegPlThs
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSECFGPLSDPA Property

IRD

Fxos8700cqPULSECFGPLSDPA Property

PULSE_CFG: PLS_DPA

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePulseCfgPlsDpa PULSECFGPLSDPA { get; set; }
Public Property PULSECFGPLSDPA As Fxos8700cqTypePulseCfgPlsDpa
    Get
    Set
public:
property Fxos8700cqTypePulseCfgPlsDpa PULSECFGPLSDPA {
    Fxos8700cqTypePulseCfgPlsDpa get ();
    void set (Fxos8700cqTypePulseCfgPlsDpa value);
}
member PULSECFGPLSDPA : Fxos8700cqTypePulseCfgPlsDpa with get, set

Property Value

Type: Fxos8700cqTypePulseCfgPlsDpa
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSECFGPLSELE Property

IRD

Fxos8700cqPULSECFGPLSELE Property

PULSE_CFG: PLS_ELE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePulseCfgPlsEle PULSECFGPLSELE { get; set; }
Public Property PULSECFGPLSELE As Fxos8700cqTypePulseCfgPlsEle
    Get
    Set
public:
property Fxos8700cqTypePulseCfgPlsEle PULSECFGPLSELE {
    Fxos8700cqTypePulseCfgPlsEle get ();
    void set (Fxos8700cqTypePulseCfgPlsEle value);
}
member PULSECFGPLSELE : Fxos8700cqTypePulseCfgPlsEle with get, set

Property Value

Type: Fxos8700cqTypePulseCfgPlsEle
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSECFGPLSXDPEFE Property

IRD

Fxos8700cqPULSECFGPLSXDPEFE Property

PULSE_CFG: PLS_XDPEFE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePulseCfgPlsXdpefe PULSECFGPLSXDPEFE { get; set; }
Public Property PULSECFGPLSXDPEFE As Fxos8700cqTypePulseCfgPlsXdpefe
    Get
    Set
public:
property Fxos8700cqTypePulseCfgPlsXdpefe PULSECFGPLSXDPEFE {
    Fxos8700cqTypePulseCfgPlsXdpefe get ();
    void set (Fxos8700cqTypePulseCfgPlsXdpefe value);
}
member PULSECFGPLSXDPEFE : Fxos8700cqTypePulseCfgPlsXdpefe with get, set

Property Value

Type: Fxos8700cqTypePulseCfgPlsXdpefe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSECFGPLSXSPEFE Property

IRD

Fxos8700cqPULSECFGPLSXSPEFE Property

PULSE_CFG: PLS_XSPEFE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePulseCfgPlsXspefe PULSECFGPLSXSPEFE { get; set; }
Public Property PULSECFGPLSXSPEFE As Fxos8700cqTypePulseCfgPlsXspefe
    Get
    Set
public:
property Fxos8700cqTypePulseCfgPlsXspefe PULSECFGPLSXSPEFE {
    Fxos8700cqTypePulseCfgPlsXspefe get ();
    void set (Fxos8700cqTypePulseCfgPlsXspefe value);
}
member PULSECFGPLSXSPEFE : Fxos8700cqTypePulseCfgPlsXspefe with get, set

Property Value

Type: Fxos8700cqTypePulseCfgPlsXspefe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSECFGPLSYDPEFE Property

IRD

Fxos8700cqPULSECFGPLSYDPEFE Property

PULSE_CFG: PLS_YDPEFE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePulseCfgPlsYdpefe PULSECFGPLSYDPEFE { get; set; }
Public Property PULSECFGPLSYDPEFE As Fxos8700cqTypePulseCfgPlsYdpefe
    Get
    Set
public:
property Fxos8700cqTypePulseCfgPlsYdpefe PULSECFGPLSYDPEFE {
    Fxos8700cqTypePulseCfgPlsYdpefe get ();
    void set (Fxos8700cqTypePulseCfgPlsYdpefe value);
}
member PULSECFGPLSYDPEFE : Fxos8700cqTypePulseCfgPlsYdpefe with get, set

Property Value

Type: Fxos8700cqTypePulseCfgPlsYdpefe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSECFGPLSYSPEFE Property

IRD

Fxos8700cqPULSECFGPLSYSPEFE Property

PULSE_CFG: PLS_YSPEFE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePulseCfgPlsYspefe PULSECFGPLSYSPEFE { get; set; }
Public Property PULSECFGPLSYSPEFE As Fxos8700cqTypePulseCfgPlsYspefe
    Get
    Set
public:
property Fxos8700cqTypePulseCfgPlsYspefe PULSECFGPLSYSPEFE {
    Fxos8700cqTypePulseCfgPlsYspefe get ();
    void set (Fxos8700cqTypePulseCfgPlsYspefe value);
}
member PULSECFGPLSYSPEFE : Fxos8700cqTypePulseCfgPlsYspefe with get, set

Property Value

Type: Fxos8700cqTypePulseCfgPlsYspefe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSECFGPLSZDPEFE Property

IRD

Fxos8700cqPULSECFGPLSZDPEFE Property

PULSE_CFG: PLS_ZDPEFE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePulseCfgPlsZdpefe PULSECFGPLSZDPEFE { get; set; }
Public Property PULSECFGPLSZDPEFE As Fxos8700cqTypePulseCfgPlsZdpefe
    Get
    Set
public:
property Fxos8700cqTypePulseCfgPlsZdpefe PULSECFGPLSZDPEFE {
    Fxos8700cqTypePulseCfgPlsZdpefe get ();
    void set (Fxos8700cqTypePulseCfgPlsZdpefe value);
}
member PULSECFGPLSZDPEFE : Fxos8700cqTypePulseCfgPlsZdpefe with get, set

Property Value

Type: Fxos8700cqTypePulseCfgPlsZdpefe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSECFGPLSZSPEFE Property

IRD

Fxos8700cqPULSECFGPLSZSPEFE Property

PULSE_CFG: PLS_ZSPEFE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePulseCfgPlsZspefe PULSECFGPLSZSPEFE { get; set; }
Public Property PULSECFGPLSZSPEFE As Fxos8700cqTypePulseCfgPlsZspefe
    Get
    Set
public:
property Fxos8700cqTypePulseCfgPlsZspefe PULSECFGPLSZSPEFE {
    Fxos8700cqTypePulseCfgPlsZspefe get ();
    void set (Fxos8700cqTypePulseCfgPlsZspefe value);
}
member PULSECFGPLSZSPEFE : Fxos8700cqTypePulseCfgPlsZspefe with get, set

Property Value

Type: Fxos8700cqTypePulseCfgPlsZspefe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSELTCY Property

IRD

Fxos8700cqPULSELTCY Property

PULSE_LTCY

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PULSELTCY { get; set; }
Public Property PULSELTCY As Byte
    Get
    Set
public:
property unsigned char PULSELTCY {
    unsigned char get ();
    void set (unsigned char value);
}
member PULSELTCY : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSESRCPLSSRCAXX Property

IRD

Fxos8700cqPULSESRCPLSSRCAXX Property

PULSE_SRC: PLS_SRC_AXX

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePulseSrcPlsSrcAxx PULSESRCPLSSRCAXX { get; }
Public ReadOnly Property PULSESRCPLSSRCAXX As Fxos8700cqTypePulseSrcPlsSrcAxx
    Get
public:
property Fxos8700cqTypePulseSrcPlsSrcAxx PULSESRCPLSSRCAXX {
    Fxos8700cqTypePulseSrcPlsSrcAxx get ();
}
member PULSESRCPLSSRCAXX : Fxos8700cqTypePulseSrcPlsSrcAxx with get

Property Value

Type: Fxos8700cqTypePulseSrcPlsSrcAxx
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSESRCPLSSRCAXY Property

IRD

Fxos8700cqPULSESRCPLSSRCAXY Property

PULSE_SRC: PLS_SRC_AXY

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePulseSrcPlsSrcAxy PULSESRCPLSSRCAXY { get; }
Public ReadOnly Property PULSESRCPLSSRCAXY As Fxos8700cqTypePulseSrcPlsSrcAxy
    Get
public:
property Fxos8700cqTypePulseSrcPlsSrcAxy PULSESRCPLSSRCAXY {
    Fxos8700cqTypePulseSrcPlsSrcAxy get ();
}
member PULSESRCPLSSRCAXY : Fxos8700cqTypePulseSrcPlsSrcAxy with get

Property Value

Type: Fxos8700cqTypePulseSrcPlsSrcAxy
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSESRCPLSSRCAXZ Property

IRD

Fxos8700cqPULSESRCPLSSRCAXZ Property

PULSE_SRC: PLS_SRC_AXZ

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePulseSrcPlsSrcAxz PULSESRCPLSSRCAXZ { get; }
Public ReadOnly Property PULSESRCPLSSRCAXZ As Fxos8700cqTypePulseSrcPlsSrcAxz
    Get
public:
property Fxos8700cqTypePulseSrcPlsSrcAxz PULSESRCPLSSRCAXZ {
    Fxos8700cqTypePulseSrcPlsSrcAxz get ();
}
member PULSESRCPLSSRCAXZ : Fxos8700cqTypePulseSrcPlsSrcAxz with get

Property Value

Type: Fxos8700cqTypePulseSrcPlsSrcAxz
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSESRCPLSSRCDPE Property

IRD

Fxos8700cqPULSESRCPLSSRCDPE Property

PULSE_SRC: PLS_SRC_DPE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePulseSrcPlsSrcDpe PULSESRCPLSSRCDPE { get; }
Public ReadOnly Property PULSESRCPLSSRCDPE As Fxos8700cqTypePulseSrcPlsSrcDpe
    Get
public:
property Fxos8700cqTypePulseSrcPlsSrcDpe PULSESRCPLSSRCDPE {
    Fxos8700cqTypePulseSrcPlsSrcDpe get ();
}
member PULSESRCPLSSRCDPE : Fxos8700cqTypePulseSrcPlsSrcDpe with get

Property Value

Type: Fxos8700cqTypePulseSrcPlsSrcDpe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSESRCPLSSRCEA Property

IRD

Fxos8700cqPULSESRCPLSSRCEA Property

PULSE_SRC: PLS_SRC_EA

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePulseSrcPlsSrcEa PULSESRCPLSSRCEA { get; }
Public ReadOnly Property PULSESRCPLSSRCEA As Fxos8700cqTypePulseSrcPlsSrcEa
    Get
public:
property Fxos8700cqTypePulseSrcPlsSrcEa PULSESRCPLSSRCEA {
    Fxos8700cqTypePulseSrcPlsSrcEa get ();
}
member PULSESRCPLSSRCEA : Fxos8700cqTypePulseSrcPlsSrcEa with get

Property Value

Type: Fxos8700cqTypePulseSrcPlsSrcEa
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSESRCPLSSRCPOLX Property

IRD

Fxos8700cqPULSESRCPLSSRCPOLX Property

PULSE_SRC: PLS_SRC_POLX

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePulseSrcPlsSrcPolx PULSESRCPLSSRCPOLX { get; }
Public ReadOnly Property PULSESRCPLSSRCPOLX As Fxos8700cqTypePulseSrcPlsSrcPolx
    Get
public:
property Fxos8700cqTypePulseSrcPlsSrcPolx PULSESRCPLSSRCPOLX {
    Fxos8700cqTypePulseSrcPlsSrcPolx get ();
}
member PULSESRCPLSSRCPOLX : Fxos8700cqTypePulseSrcPlsSrcPolx with get

Property Value

Type: Fxos8700cqTypePulseSrcPlsSrcPolx
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSESRCPLSSRCPOLY Property

IRD

Fxos8700cqPULSESRCPLSSRCPOLY Property

PULSE_SRC: PLS_SRC_POLY

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePulseSrcPlsSrcPoly PULSESRCPLSSRCPOLY { get; }
Public ReadOnly Property PULSESRCPLSSRCPOLY As Fxos8700cqTypePulseSrcPlsSrcPoly
    Get
public:
property Fxos8700cqTypePulseSrcPlsSrcPoly PULSESRCPLSSRCPOLY {
    Fxos8700cqTypePulseSrcPlsSrcPoly get ();
}
member PULSESRCPLSSRCPOLY : Fxos8700cqTypePulseSrcPlsSrcPoly with get

Property Value

Type: Fxos8700cqTypePulseSrcPlsSrcPoly
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSESRCPLSSRCPOLZ Property

IRD

Fxos8700cqPULSESRCPLSSRCPOLZ Property

PULSE_SRC: PLS_SRC_POLZ

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypePulseSrcPlsSrcPolz PULSESRCPLSSRCPOLZ { get; }
Public ReadOnly Property PULSESRCPLSSRCPOLZ As Fxos8700cqTypePulseSrcPlsSrcPolz
    Get
public:
property Fxos8700cqTypePulseSrcPlsSrcPolz PULSESRCPLSSRCPOLZ {
    Fxos8700cqTypePulseSrcPlsSrcPolz get ();
}
member PULSESRCPLSSRCPOLZ : Fxos8700cqTypePulseSrcPlsSrcPolz with get

Property Value

Type: Fxos8700cqTypePulseSrcPlsSrcPolz
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSETHSX Property

IRD

Fxos8700cqPULSETHSX Property

PULSE_THSX (unit: mg)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double PULSETHSX { get; set; }
Public Property PULSETHSX As Double
    Get
    Set
public:
property double PULSETHSX {
    double get ();
    void set (double value);
}
member PULSETHSX : float with get, set

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSETHSY Property

IRD

Fxos8700cqPULSETHSY Property

PULSE_THSY (unit: mg)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double PULSETHSY { get; set; }
Public Property PULSETHSY As Double
    Get
    Set
public:
property double PULSETHSY {
    double get ();
    void set (double value);
}
member PULSETHSY : float with get, set

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSETHSZ Property

IRD

Fxos8700cqPULSETHSZ Property

PULSE_THSZ (unit: mg)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double PULSETHSZ { get; set; }
Public Property PULSETHSZ As Double
    Get
    Set
public:
property double PULSETHSZ {
    double get ();
    void set (double value);
}
member PULSETHSZ : float with get, set

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSETMLT Property

IRD

Fxos8700cqPULSETMLT Property

PULSE_TMLT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PULSETMLT { get; set; }
Public Property PULSETMLT As Byte
    Get
    Set
public:
property unsigned char PULSETMLT {
    unsigned char get ();
    void set (unsigned char value);
}
member PULSETMLT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.PULSEWIND Property

IRD

Fxos8700cqPULSEWIND Property

PULSE_WIND

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PULSEWIND { get; set; }
Public Property PULSEWIND As Byte
    Get
    Set
public:
property unsigned char PULSEWIND {
    unsigned char get ();
    void set (unsigned char value);
}
member PULSEWIND : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.STATUS Property

IRD

Fxos8700cqSTATUS Property

STATUS

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STATUS { get; }
Public ReadOnly Property STATUS As Byte
    Get
public:
property unsigned char STATUS {
    unsigned char get ();
}
member STATUS : byte with get

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.SYSMODFGERR Property

IRD

Fxos8700cqSYSMODFGERR Property

SYSMOD: FGERR

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeSysmodFgerr SYSMODFGERR { get; }
Public ReadOnly Property SYSMODFGERR As Fxos8700cqTypeSysmodFgerr
    Get
public:
property Fxos8700cqTypeSysmodFgerr SYSMODFGERR {
    Fxos8700cqTypeSysmodFgerr get ();
}
member SYSMODFGERR : Fxos8700cqTypeSysmodFgerr with get

Property Value

Type: Fxos8700cqTypeSysmodFgerr
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.SYSMODFGT Property

IRD

Fxos8700cqSYSMODFGT Property

SYSMOD: FGT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSMODFGT { get; }
Public ReadOnly Property SYSMODFGT As Byte
    Get
public:
property unsigned char SYSMODFGT {
    unsigned char get ();
}
member SYSMODFGT : byte with get

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.SYSMODSYSMOD Property

IRD

Fxos8700cqSYSMODSYSMOD Property

SYSMOD: SYSMOD

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeSysmodSysmode SYSMODSYSMOD { get; }
Public ReadOnly Property SYSMODSYSMOD As Fxos8700cqTypeSysmodSysmode
    Get
public:
property Fxos8700cqTypeSysmodSysmode SYSMODSYSMOD {
    Fxos8700cqTypeSysmodSysmode get ();
}
member SYSMODSYSMOD : Fxos8700cqTypeSysmodSysmode with get

Property Value

Type: Fxos8700cqTypeSysmodSysmode
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TEMP Property

IRD

Fxos8700cqTEMP Property

TEMP (unit: °C)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TEMP { get; }
Public ReadOnly Property TEMP As Double
    Get
public:
property double TEMP {
    double get ();
}
member TEMP : float with get

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRANSIENTCFGTRANELE Property

IRD

Fxos8700cqTRANSIENTCFGTRANELE Property

TRANSIENT_CFG: TRAN_ELE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeTransientCfgTranEle TRANSIENTCFGTRANELE { get; set; }
Public Property TRANSIENTCFGTRANELE As Fxos8700cqTypeTransientCfgTranEle
    Get
    Set
public:
property Fxos8700cqTypeTransientCfgTranEle TRANSIENTCFGTRANELE {
    Fxos8700cqTypeTransientCfgTranEle get ();
    void set (Fxos8700cqTypeTransientCfgTranEle value);
}
member TRANSIENTCFGTRANELE : Fxos8700cqTypeTransientCfgTranEle with get, set

Property Value

Type: Fxos8700cqTypeTransientCfgTranEle
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRANSIENTCFGTRANHPFBYP Property

IRD

Fxos8700cqTRANSIENTCFGTRANHPFBYP Property

TRANSIENT_CFG: TRAN_HPF_BYP

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeTransientCfgTranHpfByp TRANSIENTCFGTRANHPFBYP { get; set; }
Public Property TRANSIENTCFGTRANHPFBYP As Fxos8700cqTypeTransientCfgTranHpfByp
    Get
    Set
public:
property Fxos8700cqTypeTransientCfgTranHpfByp TRANSIENTCFGTRANHPFBYP {
    Fxos8700cqTypeTransientCfgTranHpfByp get ();
    void set (Fxos8700cqTypeTransientCfgTranHpfByp value);
}
member TRANSIENTCFGTRANHPFBYP : Fxos8700cqTypeTransientCfgTranHpfByp with get, set

Property Value

Type: Fxos8700cqTypeTransientCfgTranHpfByp
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRANSIENTCFGTRANXEFE Property

IRD

Fxos8700cqTRANSIENTCFGTRANXEFE Property

TRANSIENT_CFG: TRAN_XEFE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeTransientCfgTranXefe TRANSIENTCFGTRANXEFE { get; set; }
Public Property TRANSIENTCFGTRANXEFE As Fxos8700cqTypeTransientCfgTranXefe
    Get
    Set
public:
property Fxos8700cqTypeTransientCfgTranXefe TRANSIENTCFGTRANXEFE {
    Fxos8700cqTypeTransientCfgTranXefe get ();
    void set (Fxos8700cqTypeTransientCfgTranXefe value);
}
member TRANSIENTCFGTRANXEFE : Fxos8700cqTypeTransientCfgTranXefe with get, set

Property Value

Type: Fxos8700cqTypeTransientCfgTranXefe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRANSIENTCFGTRANYEFE Property

IRD

Fxos8700cqTRANSIENTCFGTRANYEFE Property

TRANSIENT_CFG: TRAN_YEFE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeTransientCfgTranYefe TRANSIENTCFGTRANYEFE { get; set; }
Public Property TRANSIENTCFGTRANYEFE As Fxos8700cqTypeTransientCfgTranYefe
    Get
    Set
public:
property Fxos8700cqTypeTransientCfgTranYefe TRANSIENTCFGTRANYEFE {
    Fxos8700cqTypeTransientCfgTranYefe get ();
    void set (Fxos8700cqTypeTransientCfgTranYefe value);
}
member TRANSIENTCFGTRANYEFE : Fxos8700cqTypeTransientCfgTranYefe with get, set

Property Value

Type: Fxos8700cqTypeTransientCfgTranYefe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRANSIENTCFGTRANZEFE Property

IRD

Fxos8700cqTRANSIENTCFGTRANZEFE Property

TRANSIENT_CFG: TRAN_ZEFE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeTransientCfgTranZefe TRANSIENTCFGTRANZEFE { get; set; }
Public Property TRANSIENTCFGTRANZEFE As Fxos8700cqTypeTransientCfgTranZefe
    Get
    Set
public:
property Fxos8700cqTypeTransientCfgTranZefe TRANSIENTCFGTRANZEFE {
    Fxos8700cqTypeTransientCfgTranZefe get ();
    void set (Fxos8700cqTypeTransientCfgTranZefe value);
}
member TRANSIENTCFGTRANZEFE : Fxos8700cqTypeTransientCfgTranZefe with get, set

Property Value

Type: Fxos8700cqTypeTransientCfgTranZefe
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRANSIENTCOUNT Property

IRD

Fxos8700cqTRANSIENTCOUNT Property

TRANSIENT_COUNT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TRANSIENTCOUNT { get; set; }
Public Property TRANSIENTCOUNT As Byte
    Get
    Set
public:
property unsigned char TRANSIENTCOUNT {
    unsigned char get ();
    void set (unsigned char value);
}
member TRANSIENTCOUNT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRANSIENTSRCTRANEA Property

IRD

Fxos8700cqTRANSIENTSRCTRANEA Property

TRANSIENT_SRC: TRAN_EA

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeTransientSrcTranEa TRANSIENTSRCTRANEA { get; }
Public ReadOnly Property TRANSIENTSRCTRANEA As Fxos8700cqTypeTransientSrcTranEa
    Get
public:
property Fxos8700cqTypeTransientSrcTranEa TRANSIENTSRCTRANEA {
    Fxos8700cqTypeTransientSrcTranEa get ();
}
member TRANSIENTSRCTRANEA : Fxos8700cqTypeTransientSrcTranEa with get

Property Value

Type: Fxos8700cqTypeTransientSrcTranEa
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRANSIENTSRCTRANXEF Property

IRD

Fxos8700cqTRANSIENTSRCTRANXEF Property

TRANSIENT_SRC: TRAN_XEF

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeTransientSrcTranXef TRANSIENTSRCTRANXEF { get; }
Public ReadOnly Property TRANSIENTSRCTRANXEF As Fxos8700cqTypeTransientSrcTranXef
    Get
public:
property Fxos8700cqTypeTransientSrcTranXef TRANSIENTSRCTRANXEF {
    Fxos8700cqTypeTransientSrcTranXef get ();
}
member TRANSIENTSRCTRANXEF : Fxos8700cqTypeTransientSrcTranXef with get

Property Value

Type: Fxos8700cqTypeTransientSrcTranXef
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRANSIENTSRCTRANXPOL Property

IRD

Fxos8700cqTRANSIENTSRCTRANXPOL Property

TRANSIENT_SRC: TRAN_XPOL

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeTransientSrcTranXpol TRANSIENTSRCTRANXPOL { get; }
Public ReadOnly Property TRANSIENTSRCTRANXPOL As Fxos8700cqTypeTransientSrcTranXpol
    Get
public:
property Fxos8700cqTypeTransientSrcTranXpol TRANSIENTSRCTRANXPOL {
    Fxos8700cqTypeTransientSrcTranXpol get ();
}
member TRANSIENTSRCTRANXPOL : Fxos8700cqTypeTransientSrcTranXpol with get

Property Value

Type: Fxos8700cqTypeTransientSrcTranXpol
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRANSIENTSRCTRANYEF Property

IRD

Fxos8700cqTRANSIENTSRCTRANYEF Property

TRANSIENT_SRC: TRAN_YEF

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeTransientSrcTranYef TRANSIENTSRCTRANYEF { get; }
Public ReadOnly Property TRANSIENTSRCTRANYEF As Fxos8700cqTypeTransientSrcTranYef
    Get
public:
property Fxos8700cqTypeTransientSrcTranYef TRANSIENTSRCTRANYEF {
    Fxos8700cqTypeTransientSrcTranYef get ();
}
member TRANSIENTSRCTRANYEF : Fxos8700cqTypeTransientSrcTranYef with get

Property Value

Type: Fxos8700cqTypeTransientSrcTranYef
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRANSIENTSRCTRANYPOL Property

IRD

Fxos8700cqTRANSIENTSRCTRANYPOL Property

TRANSIENT_SRC: TRAN_YPOL

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeTransientSrcTranYpol TRANSIENTSRCTRANYPOL { get; }
Public ReadOnly Property TRANSIENTSRCTRANYPOL As Fxos8700cqTypeTransientSrcTranYpol
    Get
public:
property Fxos8700cqTypeTransientSrcTranYpol TRANSIENTSRCTRANYPOL {
    Fxos8700cqTypeTransientSrcTranYpol get ();
}
member TRANSIENTSRCTRANYPOL : Fxos8700cqTypeTransientSrcTranYpol with get

Property Value

Type: Fxos8700cqTypeTransientSrcTranYpol
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRANSIENTSRCTRANZEF Property

IRD

Fxos8700cqTRANSIENTSRCTRANZEF Property

TRANSIENT_SRC: TRAN_ZEF

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeTransientSrcTranZef TRANSIENTSRCTRANZEF { get; }
Public ReadOnly Property TRANSIENTSRCTRANZEF As Fxos8700cqTypeTransientSrcTranZef
    Get
public:
property Fxos8700cqTypeTransientSrcTranZef TRANSIENTSRCTRANZEF {
    Fxos8700cqTypeTransientSrcTranZef get ();
}
member TRANSIENTSRCTRANZEF : Fxos8700cqTypeTransientSrcTranZef with get

Property Value

Type: Fxos8700cqTypeTransientSrcTranZef
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRANSIENTSRCTRANZPOL Property

IRD

Fxos8700cqTRANSIENTSRCTRANZPOL Property

TRANSIENT_SRC: TRAN_ZPOL

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeTransientSrcTranZpol TRANSIENTSRCTRANZPOL { get; }
Public ReadOnly Property TRANSIENTSRCTRANZPOL As Fxos8700cqTypeTransientSrcTranZpol
    Get
public:
property Fxos8700cqTypeTransientSrcTranZpol TRANSIENTSRCTRANZPOL {
    Fxos8700cqTypeTransientSrcTranZpol get ();
}
member TRANSIENTSRCTRANZPOL : Fxos8700cqTypeTransientSrcTranZpol with get

Property Value

Type: Fxos8700cqTypeTransientSrcTranZpol
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRANSIENTTHSTRDBCNTM Property

IRD

Fxos8700cqTRANSIENTTHSTRDBCNTM Property

TRANSIENT_THS: TR_DBCNTM

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeTransientThsTrDbcntm TRANSIENTTHSTRDBCNTM { get; set; }
Public Property TRANSIENTTHSTRDBCNTM As Fxos8700cqTypeTransientThsTrDbcntm
    Get
    Set
public:
property Fxos8700cqTypeTransientThsTrDbcntm TRANSIENTTHSTRDBCNTM {
    Fxos8700cqTypeTransientThsTrDbcntm get ();
    void set (Fxos8700cqTypeTransientThsTrDbcntm value);
}
member TRANSIENTTHSTRDBCNTM : Fxos8700cqTypeTransientThsTrDbcntm with get, set

Property Value

Type: Fxos8700cqTypeTransientThsTrDbcntm
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRANSIENTTHSTRTHS Property

IRD

Fxos8700cqTRANSIENTTHSTRTHS Property

TRANSIENT_THS: TR_THS (unit: mg)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TRANSIENTTHSTRTHS { get; set; }
Public Property TRANSIENTTHSTRTHS As Double
    Get
    Set
public:
property double TRANSIENTTHSTRTHS {
    double get ();
    void set (double value);
}
member TRANSIENTTHSTRTHS : float with get, set

Property Value

Type: Double
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRIGCFGTRIGAVECM Property

IRD

Fxos8700cqTRIGCFGTRIGAVECM Property

TRIG_CFG: TRIG_A_VECM

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeTrigCfg TRIGCFGTRIGAVECM { get; set; }
Public Property TRIGCFGTRIGAVECM As Fxos8700cqTypeTrigCfg
    Get
    Set
public:
property Fxos8700cqTypeTrigCfg TRIGCFGTRIGAVECM {
    Fxos8700cqTypeTrigCfg get ();
    void set (Fxos8700cqTypeTrigCfg value);
}
member TRIGCFGTRIGAVECM : Fxos8700cqTypeTrigCfg with get, set

Property Value

Type: Fxos8700cqTypeTrigCfg
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRIGCFGTRIGFFMT Property

IRD

Fxos8700cqTRIGCFGTRIGFFMT Property

TRIG_CFG: TRIG_FFMT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeTrigCfg TRIGCFGTRIGFFMT { get; set; }
Public Property TRIGCFGTRIGFFMT As Fxos8700cqTypeTrigCfg
    Get
    Set
public:
property Fxos8700cqTypeTrigCfg TRIGCFGTRIGFFMT {
    Fxos8700cqTypeTrigCfg get ();
    void set (Fxos8700cqTypeTrigCfg value);
}
member TRIGCFGTRIGFFMT : Fxos8700cqTypeTrigCfg with get, set

Property Value

Type: Fxos8700cqTypeTrigCfg
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRIGCFGTRIGINDPRT Property

IRD

Fxos8700cqTRIGCFGTRIGINDPRT Property

TRIG_CFG: TRIG_INDPRT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeTrigCfg TRIGCFGTRIGINDPRT { get; set; }
Public Property TRIGCFGTRIGINDPRT As Fxos8700cqTypeTrigCfg
    Get
    Set
public:
property Fxos8700cqTypeTrigCfg TRIGCFGTRIGINDPRT {
    Fxos8700cqTypeTrigCfg get ();
    void set (Fxos8700cqTypeTrigCfg value);
}
member TRIGCFGTRIGINDPRT : Fxos8700cqTypeTrigCfg with get, set

Property Value

Type: Fxos8700cqTypeTrigCfg
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRIGCFGTRIGPULSE Property

IRD

Fxos8700cqTRIGCFGTRIGPULSE Property

TRIG_CFG: TRIG_PULSE

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeTrigCfg TRIGCFGTRIGPULSE { get; set; }
Public Property TRIGCFGTRIGPULSE As Fxos8700cqTypeTrigCfg
    Get
    Set
public:
property Fxos8700cqTypeTrigCfg TRIGCFGTRIGPULSE {
    Fxos8700cqTypeTrigCfg get ();
    void set (Fxos8700cqTypeTrigCfg value);
}
member TRIGCFGTRIGPULSE : Fxos8700cqTypeTrigCfg with get, set

Property Value

Type: Fxos8700cqTypeTrigCfg
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TRIGCFGTRIGTRANS Property

IRD

Fxos8700cqTRIGCFGTRIGTRANS Property

TRIG_CFG: TRIG_TRANS

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeTrigCfg TRIGCFGTRIGTRANS { get; set; }
Public Property TRIGCFGTRIGTRANS As Fxos8700cqTypeTrigCfg
    Get
    Set
public:
property Fxos8700cqTypeTrigCfg TRIGCFGTRIGTRANS {
    Fxos8700cqTypeTrigCfg get ();
    void set (Fxos8700cqTypeTrigCfg value);
}
member TRIGCFGTRIGTRANS : Fxos8700cqTypeTrigCfg with get, set

Property Value

Type: Fxos8700cqTypeTrigCfg
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.WHOAMI Property

IRD

Fxos8700cqWHOAMI Property

WHO_AM_I

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WHOAMI { get; }
Public ReadOnly Property WHOAMI As Byte
    Get
public:
property unsigned char WHOAMI {
    unsigned char get ();
}
member WHOAMI : byte with get

Property Value

Type: Byte
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.XYZDATACFGFS Property

IRD

Fxos8700cqXYZDATACFGFS Property

XYZ_DATA_CFG: FS

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeXyzDataCfgFs XYZDATACFGFS { get; set; }
Public Property XYZDATACFGFS As Fxos8700cqTypeXyzDataCfgFs
    Get
    Set
public:
property Fxos8700cqTypeXyzDataCfgFs XYZDATACFGFS {
    Fxos8700cqTypeXyzDataCfgFs get ();
    void set (Fxos8700cqTypeXyzDataCfgFs value);
}
member XYZDATACFGFS : Fxos8700cqTypeXyzDataCfgFs with get, set

Property Value

Type: Fxos8700cqTypeXyzDataCfgFs
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.XYZDATACFGHPFOUT Property

IRD

Fxos8700cqXYZDATACFGHPFOUT Property

XYZ_DATA_CFG: HPF_OUT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Fxos8700cqTypeXyzDataCfgHpfOut XYZDATACFGHPFOUT { get; set; }
Public Property XYZDATACFGHPFOUT As Fxos8700cqTypeXyzDataCfgHpfOut
    Get
    Set
public:
property Fxos8700cqTypeXyzDataCfgHpfOut XYZDATACFGHPFOUT {
    Fxos8700cqTypeXyzDataCfgHpfOut get ();
    void set (Fxos8700cqTypeXyzDataCfgHpfOut value);
}
member XYZDATACFGHPFOUT : Fxos8700cqTypeXyzDataCfgHpfOut with get, set

Property Value

Type: Fxos8700cqTypeXyzDataCfgHpfOut
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq Methods

The Fxos8700cq type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.Flush Method

IRD

Fxos8700cqFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Fxos8700cq Class
telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeAFfmtCfgAFfmtEle Enumeration

IRD

Fxos8700cqTypeAFfmtCfgAFfmtEle Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAFfmtCfgAFfmtEle
Public Enumeration TypeAFfmtCfgAFfmtEle
public enum class TypeAFfmtCfgAFfmtEle
type TypeAFfmtCfgAFfmtEle
Members
Member name | Value | Description
EventFlagLatchDisabled | 0 | Event Flag Latch: Disabled
EventFlagLatchEnabled | 1 | Event Flag Latch: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeAFfmtCfgAFfmtOae Enumeration

IRD

Fxos8700cqTypeAFfmtCfgAFfmtOae Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAFfmtCfgAFfmtOae
Public Enumeration TypeAFfmtCfgAFfmtOae
public enum class TypeAFfmtCfgAFfmtOae
type TypeAFfmtCfgAFfmtOae
Members
Member name | Value | Description
FreefallFlag | 0 | Freefall Flag
MotionFlag | 1 | Motion Flag
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeAFfmtCfgAFfmtXyzefe Enumeration

IRD

Fxos8700cqTypeAFfmtCfgAFfmtXyzefe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAFfmtCfgAFfmtXyzefe
Public Enumeration TypeAFfmtCfgAFfmtXyzefe
public enum class TypeAFfmtCfgAFfmtXyzefe
type TypeAFfmtCfgAFfmtXyzefe
Members
Member name | Value | Description
EventDetectionDisabled | 0 | Event Detection: Disabled
EventDetectionEnabled | 1 | Event Detection: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeAFfmtSrcAFfmtEa Enumeration

IRD

Fxos8700cqTypeAFfmtSrcAFfmtEa Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAFfmtSrcAFfmtEa
Public Enumeration TypeAFfmtSrcAFfmtEa
public enum class TypeAFfmtSrcAFfmtEa
type TypeAFfmtSrcAFfmtEa
Members
Member name | Value | Description
NotAsserted | 0 | Not Asserted
Asserted | 1 | Asserted
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeAFfmtSrcAFfmtXhe Enumeration

IRD

Fxos8700cqTypeAFfmtSrcAFfmtXhe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAFfmtSrcAFfmtXhe
Public Enumeration TypeAFfmtSrcAFfmtXhe
public enum class TypeAFfmtSrcAFfmtXhe
type TypeAFfmtSrcAFfmtXhe
Members
Member name | Value | Description
NoEventDetected | 0 | No Event Detected
XHighEventHasBeenDetected | 1 | X-High Event Has Been Detected
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeAFfmtSrcAFfmtXhp Enumeration

IRD

Fxos8700cqTypeAFfmtSrcAFfmtXhp Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAFfmtSrcAFfmtXhp
Public Enumeration TypeAFfmtSrcAFfmtXhp
public enum class TypeAFfmtSrcAFfmtXhp
type TypeAFfmtSrcAFfmtXhp
Members
Member name | Value | Description
XEventPositiveG | 0 | X Event: Positive G
XEventNegativeG | 1 | X Event: Negative G
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeAFfmtSrcAFfmtYhe Enumeration

IRD

Fxos8700cqTypeAFfmtSrcAFfmtYhe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAFfmtSrcAFfmtYhe
Public Enumeration TypeAFfmtSrcAFfmtYhe
public enum class TypeAFfmtSrcAFfmtYhe
type TypeAFfmtSrcAFfmtYhe
Members
Member name | Value | Description
NoEventDetected | 0 | No Event Detected
YHighEventHasBeenDetected | 1 | Y-High Event Has Been Detected
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeAFfmtSrcAFfmtYhp Enumeration

IRD

Fxos8700cqTypeAFfmtSrcAFfmtYhp Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAFfmtSrcAFfmtYhp
Public Enumeration TypeAFfmtSrcAFfmtYhp
public enum class TypeAFfmtSrcAFfmtYhp
type TypeAFfmtSrcAFfmtYhp
Members
Member name | Value | Description
YEventPositiveG | 0 | Y Event: Positive G
YEventNegativeG | 1 | Y Event: Negative G
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeAFfmtSrcAFfmtZhe Enumeration

IRD

Fxos8700cqTypeAFfmtSrcAFfmtZhe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAFfmtSrcAFfmtZhe
Public Enumeration TypeAFfmtSrcAFfmtZhe
public enum class TypeAFfmtSrcAFfmtZhe
type TypeAFfmtSrcAFfmtZhe
Members
Member name | Value | Description
EventDetected | 0 | Event Detected
ZHighEventHasBeenDetected | 1 | Z-High Event Has Been Detected
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeAFfmtSrcAFfmtZhp Enumeration

IRD

Fxos8700cqTypeAFfmtSrcAFfmtZhp Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAFfmtSrcAFfmtZhp
Public Enumeration TypeAFfmtSrcAFfmtZhp
public enum class TypeAFfmtSrcAFfmtZhp
type TypeAFfmtSrcAFfmtZhp
Members
Member name | Value | Description
ZEventPositiveG | 0 | Z Event: Positive G
ZEventNegativeG | 1 | Z Event: Negative G
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeAFfmtThsAFfmtDbcntm Enumeration

IRD

Fxos8700cqTypeAFfmtThsAFfmtDbcntm Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAFfmtThsAFfmtDbcntm
Public Enumeration TypeAFfmtThsAFfmtDbcntm
public enum class TypeAFfmtThsAFfmtDbcntm
type TypeAFfmtThsAFfmtDbcntm
Members
Member name | Value | Description
DebounceCounterDecrement | 0 | Debounce Counter: Decrement
DebounceCounterCleared | 1 | Debounce Counter: Cleared
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeAVecmCfgAVecmEle Enumeration

IRD

Fxos8700cqTypeAVecmCfgAVecmEle Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAVecmCfgAVecmEle
Public Enumeration TypeAVecmCfgAVecmEle
public enum class TypeAVecmCfgAVecmEle
type TypeAVecmCfgAVecmEle
Members
Member name | Value | Description
EventLatchDisabled | 0 | Event Latch: Disabled
EventLatchEnabled | 1 | Event Latch: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeAVecmCfgAVecmEn Enumeration

IRD

Fxos8700cqTypeAVecmCfgAVecmEn Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAVecmCfgAVecmEn
Public Enumeration TypeAVecmCfgAVecmEn
public enum class TypeAVecmCfgAVecmEn
type TypeAVecmCfgAVecmEn
Members
Member name | Value | Description
AccelerometerVectorMagnitudeDisabled | 0 | Accelerometer Vector-Magnitude: Disabled
AccelerometerVectorMagnitudeEnabled | 1 | Accelerometer Vector-Magnitude: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeAVecmCfgAVecmInitm Enumeration

IRD

Fxos8700cqTypeAVecmCfgAVecmInitm Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAVecmCfgAVecmInitm
Public Enumeration TypeAVecmCfgAVecmInitm
public enum class TypeAVecmCfgAVecmInitm
type TypeAVecmCfgAVecmInitm
Members
Member name | Value | Description
InitialReferenceValuesCurrentData | 0 | Initial Reference Values: Current Data
InitialReferenceValuesFromAVECMINITXYZ | 1 | Initial Reference Values: From A_VECM_INIT_X/Y/Z
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeAVecmCfgAVecmUpdm Enumeration

IRD

Fxos8700cqTypeAVecmCfgAVecmUpdm Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAVecmCfgAVecmUpdm
Public Enumeration TypeAVecmCfgAVecmUpdm
public enum class TypeAVecmCfgAVecmUpdm
type TypeAVecmCfgAVecmUpdm
Members
Member name | Value | Description
ReferenceValuesUpdated | 0 | Reference Values: Updated
ReferenceValuesNotUpdated | 1 | Reference Values: Not Updated
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeAVecmThsAVecmDbcntm Enumeration

IRD

Fxos8700cqTypeAVecmThsAVecmDbcntm Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAVecmThsAVecmDbcntm
Public Enumeration TypeAVecmThsAVecmDbcntm
public enum class TypeAVecmThsAVecmDbcntm
type TypeAVecmThsAVecmDbcntm
Members
Member name | Value | Description
DebounceCounterDecremented | 0 | Debounce Counter: Decremented
DebounceCounterCleared | 1 | Debounce Counter: Cleared
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg1Active Enumeration

IRD

Fxos8700cqTypeCtrlReg1Active Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg1Active
Public Enumeration TypeCtrlReg1Active
public enum class TypeCtrlReg1Active
type TypeCtrlReg1Active
Members
Member name | Value | Description
StandbyMode | 0 | Standby Mode
ActiveMode | 1 | Active Mode
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg1AslpRate Enumeration

IRD

Fxos8700cqTypeCtrlReg1AslpRate Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg1AslpRate
Public Enumeration TypeCtrlReg1AslpRate
public enum class TypeCtrlReg1AslpRate
type TypeCtrlReg1AslpRate
Members
Member name | Value | Description
Value_50 | 0 | 50
Value_12_5 | 1 | 12.5
Value_6_25 | 2 | 6.25
Value_1_56 | 3 | 1.56
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg1FRead Enumeration

IRD

Fxos8700cqTypeCtrlReg1FRead Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg1FRead
Public Enumeration TypeCtrlReg1FRead
public enum class TypeCtrlReg1FRead
type TypeCtrlReg1FRead
Members
Member name | Value | Description
NormalMode | 0 | Normal Mode
FastReadMode | 1 | Fast-Read Mode
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg1Inoise Enumeration

IRD

Fxos8700cqTypeCtrlReg1Inoise Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg1Inoise
Public Enumeration TypeCtrlReg1Inoise
public enum class TypeCtrlReg1Inoise
type TypeCtrlReg1Inoise
Members
Member name | Value | Description
NormalMode | 0 | Normal Mode
ReducedNoiseMode | 1 | Reduced Noise Mode
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg2Mods Enumeration

IRD

Fxos8700cqTypeCtrlReg2Mods Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg2Mods
Public Enumeration TypeCtrlReg2Mods
public enum class TypeCtrlReg2Mods
type TypeCtrlReg2Mods
Members
Member name | Value | Description
PowerModeNormal | 0 | Power Mode: Normal
PowerModeLowNoiseLowPower | 1 | Power Mode: Low Noise, Low Power
PowerModeHighResolution | 2 | Power Mode: High Resolution
PowerModeLowPower | 3 | Power Mode: Low Power
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg2Rst Enumeration

IRD

Fxos8700cqTypeCtrlReg2Rst Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg2Rst
Public Enumeration TypeCtrlReg2Rst
public enum class TypeCtrlReg2Rst
type TypeCtrlReg2Rst
Members
Member name | Value | Description
DeviceResetDisabled | 0 | Device Reset: Disabled
DeviceResetEnabled | 1 | Device Reset: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg2Slpe Enumeration

IRD

Fxos8700cqTypeCtrlReg2Slpe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg2Slpe
Public Enumeration TypeCtrlReg2Slpe
public enum class TypeCtrlReg2Slpe
type TypeCtrlReg2Slpe
Members
Member name | Value | Description
AutoSleepDisabled | 0 | Auto-Sleep: Disabled
AutoSleepEnabled | 1 | Auto-Sleep: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg2Smods Enumeration

IRD

Fxos8700cqTypeCtrlReg2Smods Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg2Smods
Public Enumeration TypeCtrlReg2Smods
public enum class TypeCtrlReg2Smods
type TypeCtrlReg2Smods
Members
Member name | Value | Description
PowerModeNormal | 0 | Power Mode: Normal
PowerModeLowNoiseLowPower | 1 | Power Mode: Low Noise, Low Power
PowerModeHighResolution | 2 | Power Mode: High Resolution
PowerModeLowPower | 3 | Power Mode: Low Power
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg2St Enumeration

IRD

Fxos8700cqTypeCtrlReg2St Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg2St
Public Enumeration TypeCtrlReg2St
public enum class TypeCtrlReg2St
type TypeCtrlReg2St
Members
Member name | Value | Description
SelfTestDisabled | 0 | Self-Test: Disabled
SelfTestEnabled | 1 | Self-Test: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg3FifoGate Enumeration

IRD

Fxos8700cqTypeCtrlReg3FifoGate Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg3FifoGate
Public Enumeration TypeCtrlReg3FifoGate
public enum class TypeCtrlReg3FifoGate
type TypeCtrlReg3FifoGate
Members
Member name | Value | Description
FIFOGateBypassed | 0 | FIFO Gate: Bypassed
FIFOGateNotBypassed | 1 | FIFO Gate: Not Bypassed
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg3WakeAVecm Enumeration

IRD

Fxos8700cqTypeCtrlReg3WakeAVecm Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg3WakeAVecm
Public Enumeration TypeCtrlReg3WakeAVecm
public enum class TypeCtrlReg3WakeAVecm
type TypeCtrlReg3WakeAVecm
Members
Member name | Value | Description
AccelerationVectorMagnitudeFunctionInSleepModeDisabled | 0 | Acceleration Vector-Magnitude Function In Sleep Mode: Disabled
AccelerationVectorMagnitudeFunctionInSleepModeEnabled | 1 | Acceleration Vector-Magnitude Function In Sleep Mode: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg3WakeFfmt Enumeration

IRD

Fxos8700cqTypeCtrlReg3WakeFfmt Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg3WakeFfmt
Public Enumeration TypeCtrlReg3WakeFfmt
public enum class TypeCtrlReg3WakeFfmt
type TypeCtrlReg3WakeFfmt
Members
Member name | Value | Description
FreefallMotionFunctionInSleepModeDisabled | 0 | Freefall/Motion Function In Sleep Mode: Disabled
FreefallMotionFunctionInSleepModeEnabled | 1 | Freefall/Motion Function In Sleep Mode: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg3WakeIpol Enumeration

IRD

Fxos8700cqTypeCtrlReg3WakeIpol Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg3WakeIpol
Public Enumeration TypeCtrlReg3WakeIpol
public enum class TypeCtrlReg3WakeIpol
type TypeCtrlReg3WakeIpol
Members
Member name | Value | Description
IRQPolarityActiveLow | 0 | IRQ Polarity: Active Low
IRQPolarityActiveHigh | 1 | IRQ Polarity: Active High
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg3WakeLndprt Enumeration

IRD

Fxos8700cqTypeCtrlReg3WakeLndprt Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg3WakeLndprt
Public Enumeration TypeCtrlReg3WakeLndprt
public enum class TypeCtrlReg3WakeLndprt
type TypeCtrlReg3WakeLndprt
Members
Member name | Value | Description
OrientationFunctionInSleepModeDisabled | 0 | Orientation Function In Sleep Mode: Disabled
OrientationFunctionInSleepModeEnabled | 1 | Orientation Function In Sleep Mode: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg3WakePpOd Enumeration

IRD

Fxos8700cqTypeCtrlReg3WakePpOd Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg3WakePpOd
Public Enumeration TypeCtrlReg3WakePpOd
public enum class TypeCtrlReg3WakePpOd
type TypeCtrlReg3WakePpOd
Members
Member name | Value | Description
IRQOutputModePushPull | 0 | IRQ Output Mode: Push-Pull
IRQOutputModeOpenDrain | 1 | IRQ Output Mode: Open-Drain
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg3WakePulse Enumeration

IRD

Fxos8700cqTypeCtrlReg3WakePulse Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg3WakePulse
Public Enumeration TypeCtrlReg3WakePulse
public enum class TypeCtrlReg3WakePulse
type TypeCtrlReg3WakePulse
Members
Member name | Value | Description
PulseFunctionInSleepModeDisabled | 0 | Pulse Function In Sleep Mode: Disabled
PulseFunctionInSleepModeEnabled | 1 | Pulse Function In Sleep Mode: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg3WakeTran Enumeration

IRD

Fxos8700cqTypeCtrlReg3WakeTran Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg3WakeTran
Public Enumeration TypeCtrlReg3WakeTran
public enum class TypeCtrlReg3WakeTran
type TypeCtrlReg3WakeTran
Members
Member name | Value | Description
TransientFunctionInSleepModeDisabled | 0 | Transient Function In Sleep Mode: Disabled
TransientFunctionInSleepModeEnabled | 1 | Transient Function In Sleep Mode: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg4IntEnAslp Enumeration

IRD

Fxos8700cqTypeCtrlReg4IntEnAslp Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg4IntEnAslp
Public Enumeration TypeCtrlReg4IntEnAslp
public enum class TypeCtrlReg4IntEnAslp
type TypeCtrlReg4IntEnAslp
Members
Member name | Value | Description
SleepInterruptDisabled | 0 | Sleep Interrupt: Disabled
SleepInterruptEnabled | 1 | Sleep Interrupt: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg4IntEnAVecm Enumeration

IRD

Fxos8700cqTypeCtrlReg4IntEnAVecm Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg4IntEnAVecm
Public Enumeration TypeCtrlReg4IntEnAVecm
public enum class TypeCtrlReg4IntEnAVecm
type TypeCtrlReg4IntEnAVecm
Members
Member name | Value | Description
AccelerationVectorMagnitudeInterruptDisabled | 0 | Acceleration Vector-Magnitude Interrupt: Disabled
AccelerationVectorMagnitudeInterruptEnabled | 1 | Acceleration Vector-Magnitude Interrupt: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg4IntEnDrdy Enumeration

IRD

Fxos8700cqTypeCtrlReg4IntEnDrdy Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg4IntEnDrdy
Public Enumeration TypeCtrlReg4IntEnDrdy
public enum class TypeCtrlReg4IntEnDrdy
type TypeCtrlReg4IntEnDrdy
Members
Member name | Value | Description
DataReadyInterruptDisabled | 0 | Data-Ready Interrupt: Disabled
DataReadyInterruptEnabled | 1 | Data-Ready Interrupt: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg4IntEnFfmt Enumeration

IRD

Fxos8700cqTypeCtrlReg4IntEnFfmt Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg4IntEnFfmt
Public Enumeration TypeCtrlReg4IntEnFfmt
public enum class TypeCtrlReg4IntEnFfmt
type TypeCtrlReg4IntEnFfmt
Members
Member name | Value | Description
FreefallMotionInterruptDisabled | 0 | Freefall/Motion Interrupt: Disabled
FreefallMotionInterruptEnabled | 1 | Freefall/Motion Interrupt: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg4IntEnFifo Enumeration

IRD

Fxos8700cqTypeCtrlReg4IntEnFifo Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg4IntEnFifo
Public Enumeration TypeCtrlReg4IntEnFifo
public enum class TypeCtrlReg4IntEnFifo
type TypeCtrlReg4IntEnFifo
Members
Member name | Value | Description
FIFOInterruptDisabled | 0 | FIFO Interrupt: Disabled
FIFOInterruptEnabled | 1 | FIFO Interrupt: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg4IntEnLndprt Enumeration

IRD

Fxos8700cqTypeCtrlReg4IntEnLndprt Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg4IntEnLndprt
Public Enumeration TypeCtrlReg4IntEnLndprt
public enum class TypeCtrlReg4IntEnLndprt
type TypeCtrlReg4IntEnLndprt
Members
Member name | Value | Description
OrientationInterruptDisabled | 0 | Orientation Interrupt: Disabled
OrientationInterruptEnabled | 1 | Orientation Interrupt: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg4IntEnPulse Enumeration

IRD

Fxos8700cqTypeCtrlReg4IntEnPulse Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg4IntEnPulse
Public Enumeration TypeCtrlReg4IntEnPulse
public enum class TypeCtrlReg4IntEnPulse
type TypeCtrlReg4IntEnPulse
Members
Member name | Value | Description
PulseInterruptDisabled | 0 | Pulse Interrupt: Disabled
PulseInterruptEnabled | 1 | Pulse Interrupt: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg4IntEnTrans Enumeration

IRD

Fxos8700cqTypeCtrlReg4IntEnTrans Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg4IntEnTrans
Public Enumeration TypeCtrlReg4IntEnTrans
public enum class TypeCtrlReg4IntEnTrans
type TypeCtrlReg4IntEnTrans
Members
Member name | Value | Description
TransientInterruptDisabled | 0 | Transient Interrupt: Disabled
TransientInterruptEnabled | 1 | Transient Interrupt: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg5IntCfgAslp Enumeration

IRD

Fxos8700cqTypeCtrlReg5IntCfgAslp Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg5IntCfgAslp
Public Enumeration TypeCtrlReg5IntCfgAslp
public enum class TypeCtrlReg5IntCfgAslp
type TypeCtrlReg5IntCfgAslp
Members
Member name | Value | Description
SleepInterruptRoutedToINT2 | 0 | Sleep Interrupt Routed To: INT2
SleepInterruptRoutedToINT1 | 1 | Sleep Interrupt Routed To: INT1
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg5IntCfgAVecm Enumeration

IRD

Fxos8700cqTypeCtrlReg5IntCfgAVecm Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg5IntCfgAVecm
Public Enumeration TypeCtrlReg5IntCfgAVecm
public enum class TypeCtrlReg5IntCfgAVecm
type TypeCtrlReg5IntCfgAVecm
Members
Member name | Value | Description
AccelerationVectorMagnitudeDetectionInterruptRoutedToINT2 | 0 | Acceleration Vector-Magnitude Detection Interrupt Routed To: INT2
AccelerationVectorMagnitudeDetectionInterruptRoutedToINT1 | 1 | Acceleration Vector-Magnitude Detection Interrupt Routed To: INT1
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg5IntCfgDrdy Enumeration

IRD

Fxos8700cqTypeCtrlReg5IntCfgDrdy Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg5IntCfgDrdy
Public Enumeration TypeCtrlReg5IntCfgDrdy
public enum class TypeCtrlReg5IntCfgDrdy
type TypeCtrlReg5IntCfgDrdy
Members
Member name | Value | Description
DataReadyInterruptRoutedToINT2 | 0 | Data-Ready Interrupt Routed To: INT2
DataReadyInterruptRoutedToINT1 | 1 | Data-Ready Interrupt Routed To: INT1
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg5IntCfgFfmt Enumeration

IRD

Fxos8700cqTypeCtrlReg5IntCfgFfmt Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg5IntCfgFfmt
Public Enumeration TypeCtrlReg5IntCfgFfmt
public enum class TypeCtrlReg5IntCfgFfmt
type TypeCtrlReg5IntCfgFfmt
Members
Member name | Value | Description
FreefallMotionDetectionInterruptRoutedToINT2 | 0 | Freefall/Motion Detection Interrupt Routed To: INT2
FreefallMotionDetectionInterruptRoutedToINT1 | 1 | Freefall/Motion Detection Interrupt Routed To: INT1
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg5IntCfgFifo Enumeration

IRD

Fxos8700cqTypeCtrlReg5IntCfgFifo Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg5IntCfgFifo
Public Enumeration TypeCtrlReg5IntCfgFifo
public enum class TypeCtrlReg5IntCfgFifo
type TypeCtrlReg5IntCfgFifo
Members
Member name | Value | Description
FIFOInterruptRoutedToINT2 | 0 | FIFO Interrupt Routed To: INT2
FIFOInterruptRoutedToINT1 | 1 | FIFO Interrupt Routed To: INT1
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg5IntCfgLndprt Enumeration

IRD

Fxos8700cqTypeCtrlReg5IntCfgLndprt Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg5IntCfgLndprt
Public Enumeration TypeCtrlReg5IntCfgLndprt
public enum class TypeCtrlReg5IntCfgLndprt
type TypeCtrlReg5IntCfgLndprt
Members
Member name | Value | Description
OrientationDetectionInterruptRoutedToINT2 | 0 | Orientation Detection Interrupt Routed To: INT2
OrientationDetectionInterruptRoutedToINT1 | 1 | Orientation Detection Interrupt Routed To: INT1
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg5IntCfgPulse Enumeration

IRD

Fxos8700cqTypeCtrlReg5IntCfgPulse Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg5IntCfgPulse
Public Enumeration TypeCtrlReg5IntCfgPulse
public enum class TypeCtrlReg5IntCfgPulse
type TypeCtrlReg5IntCfgPulse
Members
Member name | Value | Description
PulseDetectionInterruptRoutedToINT2 | 0 | Pulse Detection Interrupt Routed To: INT2
PulseDetectionInterruptRoutedToINT1 | 1 | Pulse Detection Interrupt Routed To: INT1
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeCtrlReg5IntCfgTrans Enumeration

IRD

Fxos8700cqTypeCtrlReg5IntCfgTrans Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCtrlReg5IntCfgTrans
Public Enumeration TypeCtrlReg5IntCfgTrans
public enum class TypeCtrlReg5IntCfgTrans
type TypeCtrlReg5IntCfgTrans
Members
Member name | Value | Description
TransientInterruptRoutedToINT2 | 0 | Transient Interrupt Routed To: INT2
TransientInterruptRoutedToINT1 | 1 | Transient Interrupt Routed To: INT1
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeFSetupFMode Enumeration

IRD

Fxos8700cqTypeFSetupFMode Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFSetupFMode
Public Enumeration TypeFSetupFMode
public enum class TypeFSetupFMode
type TypeFSetupFMode
Members
Member name | Value | Description
FIFODisabled | 0 | FIFO: Disabled
FIFOMostRecentSamplesWhenOverflowed | 1 | FIFO: Most Recent Samples When Overflowed
FIFOStopsAcceptingNewSamplesWhenOverflowed | 2 | FIFO: Stops Accepting New Samples When Overflowed
FIFOTriggerMode | 3 | FIFO: Trigger Mode
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeHpFilterCutoffPulseHpfByp Enumeration

IRD

Fxos8700cqTypeHpFilterCutoffPulseHpfByp Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHpFilterCutoffPulseHpfByp
Public Enumeration TypeHpFilterCutoffPulseHpfByp
public enum class TypeHpFilterCutoffPulseHpfByp
type TypeHpFilterCutoffPulseHpfByp
Members
Member name | Value | Description
HPFEnabledForPulseProcessing | 0 | HPF: Enabled For Pulse Processing
HPFBypassedForPulseProcessing | 1 | HPF: Bypassed For Pulse Processing
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeHpFilterCutoffPulseLpfEn Enumeration

IRD

Fxos8700cqTypeHpFilterCutoffPulseLpfEn Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHpFilterCutoffPulseLpfEn
Public Enumeration TypeHpFilterCutoffPulseLpfEn
public enum class TypeHpFilterCutoffPulseLpfEn
type TypeHpFilterCutoffPulseLpfEn
Members
Member name | Value | Description
LPFDisabledForPulseProcessing | 0 | LPF: Disabled For Pulse Processing
LPFEnabledForPulseProcessing | 1 | LPF: Enabled For Pulse Processing
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeIntSource Enumeration

IRD

Fxos8700cqTypeIntSource Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntSource
Public Enumeration TypeIntSource
public enum class TypeIntSource
type TypeIntSource
Members
Member name | Value | Description
Cleared | 0 | Cleared
Set | 1 | Set
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMCtrlReg1MAcal Enumeration

IRD

Fxos8700cqTypeMCtrlReg1MAcal Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMCtrlReg1MAcal
Public Enumeration TypeMCtrlReg1MAcal
public enum class TypeMCtrlReg1MAcal
type TypeMCtrlReg1MAcal
Members
Member name | Value | Description
MagneticHardIronOffsetAutoCalibrationDisabled | 0 | Magnetic Hard-Iron Offset Auto-Calibration: Disabled
MagneticHardIronOffsetAutoCalibrationEnabled | 1 | Magnetic Hard-Iron Offset Auto-Calibration: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMCtrlReg1MHms Enumeration

IRD

Fxos8700cqTypeMCtrlReg1MHms Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMCtrlReg1MHms
Public Enumeration TypeMCtrlReg1MHms
public enum class TypeMCtrlReg1MHms
type TypeMCtrlReg1MHms
Members
Member name | Value | Description
AccelerometerSensorActive | 0 | Accelerometer Sensor Active
MagnetometerSensorActive | 1 | Magnetometer Sensor Active
AccelerometerMagnetometerSensorsActive | 2 | Accelerometer/Magnetometer Sensors Active
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMCtrlReg1MOst Enumeration

IRD

Fxos8700cqTypeMCtrlReg1MOst Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMCtrlReg1MOst
Public Enumeration TypeMCtrlReg1MOst
public enum class TypeMCtrlReg1MOst
type TypeMCtrlReg1MOst
Members
Member name | Value | Description
OneShotTriggeredMagneticMeasurementModeDisabled | 0 | One-Shot Triggered Magnetic Measurement Mode: Disabled
OneShotTriggeredMagneticMeasurementModeEnabled | 1 | One-Shot Triggered Magnetic Measurement Mode: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMCtrlReg1MRst Enumeration

IRD

Fxos8700cqTypeMCtrlReg1MRst Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMCtrlReg1MRst
Public Enumeration TypeMCtrlReg1MRst
public enum class TypeMCtrlReg1MRst
type TypeMCtrlReg1MRst
Members
Member name | Value | Description
OneShotMagneticResetDisabled | 0 | One-Shot Magnetic Reset: Disabled
OneShotMagneticResetEnabled | 1 | One-Shot Magnetic Reset: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMCtrlReg2MMaxminCnt Enumeration

IRD

Fxos8700cqTypeMCtrlReg2MMaxminCnt Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMCtrlReg2MMaxminCnt
Public Enumeration TypeMCtrlReg2MMaxminCnt
public enum class TypeMCtrlReg2MMaxminCnt
type TypeMCtrlReg2MMaxminCnt
Members
Member name | Value | Description
MagneticSensorResetFrequencyBeginningOfEachODRCycle | 0 | Magnetic Sensor Reset Frequency: Beginning Of Each ODR Cycle
MagneticSensorResetFrequencyEvery16ODRCycles | 1 | Magnetic Sensor Reset Frequency: Every 16 ODR Cycles
MagneticSensorResetFrequencyEvery512ODRCycles | 2 | Magnetic Sensor Reset Frequency: Every 512 ODR Cycles
MagneticSensorResetFrequencyDisabled | 3 | Magnetic Sensor Reset Frequency: Disabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMCtrlReg2MMaxminDis Enumeration

IRD

Fxos8700cqTypeMCtrlReg2MMaxminDis Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMCtrlReg2MMaxminDis
Public Enumeration TypeMCtrlReg2MMaxminDis
public enum class TypeMCtrlReg2MMaxminDis
type TypeMCtrlReg2MMaxminDis
Members
Member name | Value | Description
MagneticMeasurementMaxMinDetectionEnabled | 0 | Magnetic Measurement Max/Min Detection: Enabled
MagneticMeasurementMaxMinDetectionDisabled | 1 | Magnetic Measurement Max/Min Detection: Disabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMCtrlReg2MMaxminDisThs Enumeration

IRD

Fxos8700cqTypeMCtrlReg2MMaxminDisThs Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMCtrlReg2MMaxminDisThs
Public Enumeration TypeMCtrlReg2MMaxminDisThs
public enum class TypeMCtrlReg2MMaxminDisThs
type TypeMCtrlReg2MMaxminDisThs
Members
Member name | Value | Description
MagneticThresholdEventTriggerNoImpactToMinMax | 0 | Magnetic Threshold Event Trigger: No Impact To Min/Max
MagneticThresholdEventTriggerImpactToMinMax | 1 | Magnetic Threshold Event Trigger: Impact To Min/Max
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMCtrlReg2MMaxminRst Enumeration

IRD

Fxos8700cqTypeMCtrlReg2MMaxminRst Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMCtrlReg2MMaxminRst
Public Enumeration TypeMCtrlReg2MMaxminRst
public enum class TypeMCtrlReg2MMaxminRst
type TypeMCtrlReg2MMaxminRst
Members
Member name | Value | Description
MagneticMeasurementMaxMinDetectionNoReset | 0 | Magnetic Measurement Max/Min Detection: No Reset
MagneticMeasurementMaxMinDetectionReset | 1 | Magnetic Measurement Max/Min Detection: Reset
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMCtrlReg3MRaw Enumeration

IRD

Fxos8700cqTypeMCtrlReg3MRaw Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMCtrlReg3MRaw
Public Enumeration TypeMCtrlReg3MRaw
public enum class TypeMCtrlReg3MRaw
type TypeMCtrlReg3MRaw
Members
Member name | Value | Description
MagneticMeasurementRAWModeDisabled | 0 | Magnetic Measurement RAW Mode: Disabled
MagneticMeasurementRAWModeEnabled | 1 | Magnetic Measurement RAW Mode: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMCtrlReg3MStXy Enumeration

IRD

Fxos8700cqTypeMCtrlReg3MStXy Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMCtrlReg3MStXy
Public Enumeration TypeMCtrlReg3MStXy
public enum class TypeMCtrlReg3MStXy
type TypeMCtrlReg3MStXy
Members
Member name | Value | Description
XYAxisMagneticSelfTestDisabled | 0 | X-/Y-Axis Magnetic Self-Test: Disabled
XYAxisMagneticSelfTestEnabled | 1 | X-/Y-Axis Magnetic Self-Test: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMCtrlReg3MStZ Enumeration

IRD

Fxos8700cqTypeMCtrlReg3MStZ Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMCtrlReg3MStZ
Public Enumeration TypeMCtrlReg3MStZ
public enum class TypeMCtrlReg3MStZ
type TypeMCtrlReg3MStZ
Members
Member name | Value | Description
ZAxisMagneticSelfTestDisabled | 0 | Z-Axis Magnetic Self-Test: Disabled
ZAxisMagneticSelfTestEnabled | 1 | Z-Axis Magnetic Self-Test: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMCtrlReg3MThsXyzUpdate Enumeration

IRD

Fxos8700cqTypeMCtrlReg3MThsXyzUpdate Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMCtrlReg3MThsXyzUpdate
Public Enumeration TypeMCtrlReg3MThsXyzUpdate
public enum class TypeMCtrlReg3MThsXyzUpdate
type TypeMCtrlReg3MThsXyzUpdate
Members
Member name | Value | Description
UpdateXYZReference | 0 | Update X, Y, Z Reference
UpdateOnlyReferenceTriggeringDetectionEvent | 1 | Update Only Reference Triggering Detection Event
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMDrStatusXdr Enumeration

IRD

Fxos8700cqTypeMDrStatusXdr Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMDrStatusXdr
Public Enumeration TypeMDrStatusXdr
public enum class TypeMDrStatusXdr
type TypeMDrStatusXdr
Members
Member name | Value | Description
XAxisNewMagneticDataNotAvailable | 0 | X-Axis New Magnetic Data: Not Available
XAxisNewMagneticDataAvailable | 1 | X-Axis New Magnetic Data: Available
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMDrStatusXow Enumeration

IRD

Fxos8700cqTypeMDrStatusXow Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMDrStatusXow
Public Enumeration TypeMDrStatusXow
public enum class TypeMDrStatusXow
type TypeMDrStatusXow
Members
Member name | Value | Description
XAxisMagneticDataNotOverwritten | 0 | X-Axis Magnetic Data: Not Overwritten
XAxisMagneticDataOverwritten | 1 | X-Axis Magnetic Data: Overwritten
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMDrStatusYdr Enumeration

IRD

Fxos8700cqTypeMDrStatusYdr Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMDrStatusYdr
Public Enumeration TypeMDrStatusYdr
public enum class TypeMDrStatusYdr
type TypeMDrStatusYdr
Members
Member name | Value | Description
YAxisNewMagneticDataNotAvailable | 0 | Y-Axis New Magnetic Data: Not Available
YAxisNewMagneticDataAvailable | 1 | Y-Axis New Magnetic Data: Available
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMDrStatusYow Enumeration

IRD

Fxos8700cqTypeMDrStatusYow Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMDrStatusYow
Public Enumeration TypeMDrStatusYow
public enum class TypeMDrStatusYow
type TypeMDrStatusYow
Members
Member name | Value | Description
YAxisMagneticDataNotOverwritten | 0 | Y-Axis Magnetic Data: Not Overwritten
YAxisMagneticDataOverwritten | 1 | Y-Axis Magnetic Data: Overwritten
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMDrStatusZdr Enumeration

IRD

Fxos8700cqTypeMDrStatusZdr Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMDrStatusZdr
Public Enumeration TypeMDrStatusZdr
public enum class TypeMDrStatusZdr
type TypeMDrStatusZdr
Members
Member name | Value | Description
ZAxisNewMagneticDataNotAvailable | 0 | Z-Axis New Magnetic Data: Not Available
ZAxisNewMagneticDataAvailable | 1 | Z-Axis New Magnetic Data: Available
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMDrStatusZow Enumeration

IRD

Fxos8700cqTypeMDrStatusZow Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMDrStatusZow
Public Enumeration TypeMDrStatusZow
public enum class TypeMDrStatusZow
type TypeMDrStatusZow
Members
Member name | Value | Description
ZAxisMagneticDataNotOverwritten | 0 | Z-Axis Magnetic Data: Not Overwritten
ZAxisMagneticDataOverwritten | 1 | Z-Axis Magnetic Data: Overwritten
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMDrStatusZyxdr Enumeration

IRD

Fxos8700cqTypeMDrStatusZyxdr Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMDrStatusZyxdr
Public Enumeration TypeMDrStatusZyxdr
public enum class TypeMDrStatusZyxdr
type TypeMDrStatusZyxdr
Members
Member name | Value | Description
XYZAxisNewMagneticDataNotAvailable | 0 | X-/Y-/Z-Axis New Magnetic Data: Not Available
XYZAxisNewMagneticDataAvailable | 1 | X-/Y-/Z-Axis New Magnetic Data: Available
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMDrStatusZyxow Enumeration

IRD

Fxos8700cqTypeMDrStatusZyxow Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMDrStatusZyxow
Public Enumeration TypeMDrStatusZyxow
public enum class TypeMDrStatusZyxow
type TypeMDrStatusZyxow
Members
Member name | Value | Description
XYZAxisMagneticDataNotOverwritten | 0 | X-/Y-/Z-Axis Magnetic Data: Not Overwritten
XYZAxisMagneticDataOverwritten | 1 | X-/Y-/Z-Axis Magnetic Data: Overwritten
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMIntSrcSrcMDrdy Enumeration

IRD

Fxos8700cqTypeMIntSrcSrcMDrdy Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMIntSrcSrcMDrdy
Public Enumeration TypeMIntSrcSrcMDrdy
public enum class TypeMIntSrcSrcMDrdy
type TypeMIntSrcSrcMDrdy
Members
Member name | Value | Description
MagneticDataReadyInterruptFlagNotDetected | 0 | Magnetic Data-Ready Interrupt Flag: Not Detected
MagneticDataReadyInterruptFlagDetected | 1 | Magnetic Data-Ready Interrupt Flag: Detected
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMIntSrcSrcMThs Enumeration

IRD

Fxos8700cqTypeMIntSrcSrcMThs Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMIntSrcSrcMThs
Public Enumeration TypeMIntSrcSrcMThs
public enum class TypeMIntSrcSrcMThs
type TypeMIntSrcSrcMThs
Members
Member name | Value | Description
MagneticThresholdInterruptFlagNotDetected | 0 | Magnetic Threshold Interrupt Flag: Not Detected
MagneticThresholdInterruptFlagDetected | 1 | Magnetic Threshold Interrupt Flag: Detected
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMIntSrcSrcMVecm Enumeration

IRD

Fxos8700cqTypeMIntSrcSrcMVecm Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMIntSrcSrcMVecm
Public Enumeration TypeMIntSrcSrcMVecm
public enum class TypeMIntSrcSrcMVecm
type TypeMIntSrcSrcMVecm
Members
Member name | Value | Description
MagneticVectorMagnitudeInterruptFlagNotDetected | 0 | Magnetic Vector-Magnitude Interrupt Flag: Not Detected
MagneticVectorMagnitudeInterruptFlagDetected | 1 | Magnetic Vector-Magnitude Interrupt Flag: Detected
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMThsCfgMThsEle Enumeration

IRD

Fxos8700cqTypeMThsCfgMThsEle Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMThsCfgMThsEle
Public Enumeration TypeMThsCfgMThsEle
public enum class TypeMThsCfgMThsEle
type TypeMThsCfgMThsEle
Members
Member name | Value | Description
MagneticThresholdEventLatchDisabled | 0 | Magnetic-Threshold Event Latch: Disabled
MagneticThresholdEventLatchEnabled | 1 | Magnetic-Threshold Event Latch: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMThsCfgMThsIntCfg Enumeration

IRD

Fxos8700cqTypeMThsCfgMThsIntCfg Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMThsCfgMThsIntCfg
Public Enumeration TypeMThsCfgMThsIntCfg
public enum class TypeMThsCfgMThsIntCfg
type TypeMThsCfgMThsIntCfg
Members
Member name | Value | Description
MagneticThresholdEventFlagOutputINT2 | 0 | Magnetic-Threshold Event Flag Output: INT2
MagneticThresholdEventFlagOutputINT1 | 1 | Magnetic-Threshold Event Flag Output: INT1
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMThsCfgMThsIntEn Enumeration

IRD

Fxos8700cqTypeMThsCfgMThsIntEn Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMThsCfgMThsIntEn
Public Enumeration TypeMThsCfgMThsIntEn
public enum class TypeMThsCfgMThsIntEn
type TypeMThsCfgMThsIntEn
Members
Member name | Value | Description
MagneticThresholdInterruptDisabled | 0 | Magnetic-Threshold Interrupt: Disabled
MagneticThresholdInterruptEnabled | 1 | Magnetic-Threshold Interrupt: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMThsCfgMThsOae Enumeration

IRD

Fxos8700cqTypeMThsCfgMThsOae Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMThsCfgMThsOae
Public Enumeration TypeMThsCfgMThsOae
public enum class TypeMThsCfgMThsOae
type TypeMThsCfgMThsOae
Members
Member name | Value | Description
MagneticThresholdEventLogicAND | 0 | Magnetic-Threshold Event Logic: AND
MagneticThresholdEventLogicOR | 1 | Magnetic-Threshold Event Logic: OR
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMThsCfgMThsWakeEn Enumeration

IRD

Fxos8700cqTypeMThsCfgMThsWakeEn Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMThsCfgMThsWakeEn
Public Enumeration TypeMThsCfgMThsWakeEn
public enum class TypeMThsCfgMThsWakeEn
type TypeMThsCfgMThsWakeEn
Members
Member name | Value | Description
MagneticThresholdEventFlagExcluded | 0 | Magnetic-Threshold Event Flag: Excluded
MagneticThresholdEventFlagIncluded | 1 | Magnetic-Threshold Event Flag: Included
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMThsCfgMThsXefe Enumeration

IRD

Fxos8700cqTypeMThsCfgMThsXefe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMThsCfgMThsXefe
Public Enumeration TypeMThsCfgMThsXefe
public enum class TypeMThsCfgMThsXefe
type TypeMThsCfgMThsXefe
Members
Member name | Value | Description
EventFlagXAxisDisabled | 0 | Event-Flag X-Axis: Disabled
EventFlagXAxisEnabled | 1 | Event-Flag X-Axis: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMThsCfgMThsYefe Enumeration

IRD

Fxos8700cqTypeMThsCfgMThsYefe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMThsCfgMThsYefe
Public Enumeration TypeMThsCfgMThsYefe
public enum class TypeMThsCfgMThsYefe
type TypeMThsCfgMThsYefe
Members
Member name | Value | Description
EventFlagYAxisDisabled | 0 | Event-Flag Y-Axis: Disabled
EventFlagYAxisEnabled | 1 | Event-Flag Y-Axis: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMThsCfgMThsZefe Enumeration

IRD

Fxos8700cqTypeMThsCfgMThsZefe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMThsCfgMThsZefe
Public Enumeration TypeMThsCfgMThsZefe
public enum class TypeMThsCfgMThsZefe
type TypeMThsCfgMThsZefe
Members
Member name | Value | Description
EventFlagZAxisDisabled | 0 | Event-Flag Z-Axis: Disabled
EventFlagZAxisEnabled | 1 | Event-Flag Z-Axis: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMThsSrcMThsEa Enumeration

IRD

Fxos8700cqTypeMThsSrcMThsEa Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMThsSrcMThsEa
Public Enumeration TypeMThsSrcMThsEa
public enum class TypeMThsSrcMThsEa
type TypeMThsSrcMThsEa
Members
Member name | Value | Description
EventActiveFlagNone | 0 | Event Active Flag: None
EventActiveFlagOneMore | 1 | Event Active Flag: One/More
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMThsSrcMThsXhe Enumeration

IRD

Fxos8700cqTypeMThsSrcMThsXhe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMThsSrcMThsXhe
Public Enumeration TypeMThsSrcMThsXhe
public enum class TypeMThsSrcMThsXhe
type TypeMThsSrcMThsXhe
Members
Member name | Value | Description
XHighEventFlagNotDetected | 0 | X-High Event Flag: Not Detected
XHighEventFlagDetected | 1 | X-High Event Flag: Detected
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMThsSrcMThsXhp Enumeration

IRD

Fxos8700cqTypeMThsSrcMThsXhp Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMThsSrcMThsXhp
Public Enumeration TypeMThsSrcMThsXhp
public enum class TypeMThsSrcMThsXhp
type TypeMThsSrcMThsXhp
Members
Member name | Value | Description
XHighEventPolarityFlagPositive | 0 | X-High Event Polarity Flag: Positive
XHighEventPolarityFlagNegative | 1 | X-High Event Polarity Flag: Negative
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMThsSrcMThsYhe Enumeration

IRD

Fxos8700cqTypeMThsSrcMThsYhe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMThsSrcMThsYhe
Public Enumeration TypeMThsSrcMThsYhe
public enum class TypeMThsSrcMThsYhe
type TypeMThsSrcMThsYhe
Members
Member name | Value | Description
YHighEventFlagNotDetected | 0 | Y-High Event Flag: Not Detected
YHighEventFlagDetected | 1 | Y-High Event Flag: Detected
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMThsSrcMThsYhp Enumeration

IRD

Fxos8700cqTypeMThsSrcMThsYhp Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMThsSrcMThsYhp
Public Enumeration TypeMThsSrcMThsYhp
public enum class TypeMThsSrcMThsYhp
type TypeMThsSrcMThsYhp
Members
Member name | Value | Description
YHighEventPolarityFlagPositive | 0 | Y-High Event Polarity Flag: Positive
YHighEventPolarityFlagNegative | 1 | Y-High Event Polarity Flag: Negative
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMThsSrcMThsZhe Enumeration

IRD

Fxos8700cqTypeMThsSrcMThsZhe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMThsSrcMThsZhe
Public Enumeration TypeMThsSrcMThsZhe
public enum class TypeMThsSrcMThsZhe
type TypeMThsSrcMThsZhe
Members
Member name | Value | Description
ZHighEventFlagNotDetected | 0 | Z-High Event Flag: Not Detected
ZHighEventFlagDetected | 1 | Z-High Event Flag: Detected
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMThsSrcMThsZhp Enumeration

IRD

Fxos8700cqTypeMThsSrcMThsZhp Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMThsSrcMThsZhp
Public Enumeration TypeMThsSrcMThsZhp
public enum class TypeMThsSrcMThsZhp
type TypeMThsSrcMThsZhp
Members
Member name | Value | Description
ZHighEventPolarityFlagPositive | 0 | Z-High Event Polarity Flag: Positive
ZHighEventPolarityFlagNegative | 1 | Z-High Event Polarity Flag: Negative
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMThsXMThsDbcntm Enumeration

IRD

Fxos8700cqTypeMThsXMThsDbcntm Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMThsXMThsDbcntm
Public Enumeration TypeMThsXMThsDbcntm
public enum class TypeMThsXMThsDbcntm
type TypeMThsXMThsDbcntm
Members
Member name | Value | Description
DebounceCounterCleared | 0 | Debounce Counter: Cleared
DebounceCounterDecremented | 1 | Debounce Counter: Decremented
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMVecmCfgMVecmEle Enumeration

IRD

Fxos8700cqTypeMVecmCfgMVecmEle Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMVecmCfgMVecmEle
Public Enumeration TypeMVecmCfgMVecmEle
public enum class TypeMVecmCfgMVecmEle
type TypeMVecmCfgMVecmEle
Members
Member name | Value | Description
MagneticVectorMagnitudeEventLatchDisabled | 0 | Magnetic Vector-Magnitude Event Latch: Disabled
MagneticVectorMagnitudeEventLatchEnabled | 1 | Magnetic Vector-Magnitude Event Latch: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMVecmCfgMVecmEn Enumeration

IRD

Fxos8700cqTypeMVecmCfgMVecmEn Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMVecmCfgMVecmEn
Public Enumeration TypeMVecmCfgMVecmEn
public enum class TypeMVecmCfgMVecmEn
type TypeMVecmCfgMVecmEn
Members
Member name | Value | Description
MagneticVectorMagnitudeDisabled | 0 | Magnetic Vector-Magnitude: Disabled
MagneticVectorMagnitudeEnabled | 1 | Magnetic Vector-Magnitude: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMVecmCfgMVecmInitm Enumeration

IRD

Fxos8700cqTypeMVecmCfgMVecmInitm Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMVecmCfgMVecmInitm
Public Enumeration TypeMVecmCfgMVecmInitm
public enum class TypeMVecmCfgMVecmInitm
type TypeMVecmCfgMVecmInitm
Members
Member name | Value | Description
MagneticVectorMagnitudeInitializationModeCurrentData | 0 | Magnetic Vector-Magnitude Initialization Mode: Current Data
MagneticVectorMagnitudeInitializationModeFromMVECMXYZINIT | 1 | Magnetic Vector-Magnitude Initialization Mode: From M_VECM_X/Y/Z_INIT
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMVecmCfgMVecmIntCfg Enumeration

IRD

Fxos8700cqTypeMVecmCfgMVecmIntCfg Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMVecmCfgMVecmIntCfg
Public Enumeration TypeMVecmCfgMVecmIntCfg
public enum class TypeMVecmCfgMVecmIntCfg
type TypeMVecmCfgMVecmIntCfg
Members
Member name | Value | Description
MagneticVectorMagnitudeInterruptOutputINT2 | 0 | Magnetic Vector-Magnitude Interrupt Output: INT2
MagneticVectorMagnitudeInterruptOutputINT1 | 1 | Magnetic Vector-Magnitude Interrupt Output: INT1
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMVecmCfgMVecmIntEn Enumeration

IRD

Fxos8700cqTypeMVecmCfgMVecmIntEn Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMVecmCfgMVecmIntEn
Public Enumeration TypeMVecmCfgMVecmIntEn
public enum class TypeMVecmCfgMVecmIntEn
type TypeMVecmCfgMVecmIntEn
Members
Member name | Value | Description
MagneticVectorMagnitudeInterruptDisabled | 0 | Magnetic Vector-Magnitude Interrupt: Disabled
MagneticVectorMagnitudeInterruptEnabled | 1 | Magnetic Vector-Magnitude Interrupt: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMVecmCfgMVecmUpdm Enumeration

IRD

Fxos8700cqTypeMVecmCfgMVecmUpdm Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMVecmCfgMVecmUpdm
Public Enumeration TypeMVecmCfgMVecmUpdm
public enum class TypeMVecmCfgMVecmUpdm
type TypeMVecmCfgMVecmUpdm
Members
Member name | Value | Description
MagneticVectorMagnitudeReferenceValueUpdateModeFromCurrentData | 0 | Magnetic Vector-Magnitude Reference Value Update Mode: From Current Data
MagneticVectorMagnitudeReferenceValueUpdateModeNotUpdated | 1 | Magnetic Vector-Magnitude Reference Value Update Mode: Not Updated
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeMVecmCfgMVecmWakeEn Enumeration

IRD

Fxos8700cqTypeMVecmCfgMVecmWakeEn Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMVecmCfgMVecmWakeEn
Public Enumeration TypeMVecmCfgMVecmWakeEn
public enum class TypeMVecmCfgMVecmWakeEn
type TypeMVecmCfgMVecmWakeEn
Members
Member name | Value | Description
MagneticVectorMagnitudeWakeDisabled | 0 | Magnetic Vector-Magnitude Wake: Disabled
MagneticVectorMagnitudeWakeEnabled | 1 | Magnetic Vector-Magnitude Wake: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePlBfZcompZlock Enumeration

IRD

Fxos8700cqTypePlBfZcompZlock Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePlBfZcompZlock
Public Enumeration TypePlBfZcompZlock
public enum class TypePlBfZcompZlock
type TypePlBfZcompZlock
Members
Member name | Value | Description
Value_136145 | 0 | 13.6° / 14.5°
Value_171182 | 1 | 17.1° / 18.2°
Value_207220 | 2 | 20.7° / 22.0°
Value_244259 | 3 | 24.4° / 25.9°
Value_281300 | 4 | 28.1° / 30.0°
Value_320342 | 5 | 32.0° / 34.2°
Value_361387 | 6 | 36.1° / 38.7°
Value_404434 | 7 | 40.4° / 43.4°
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePlCfgDbcntm Enumeration

IRD

Fxos8700cqTypePlCfgDbcntm Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePlCfgDbcntm
Public Enumeration TypePlCfgDbcntm
public enum class TypePlCfgDbcntm
type TypePlCfgDbcntm
Members
Member name | Value | Description
DecrementsDebounce | 0 | Decrements Debounce
ClearsCounter | 1 | Clears Counter
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePlCfgPlEn Enumeration

IRD

Fxos8700cqTypePlCfgPlEn Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePlCfgPlEn
Public Enumeration TypePlCfgPlEn
public enum class TypePlCfgPlEn
type TypePlCfgPlEn
Members
Member name | Value | Description
PortraitLandscapeDetectionDisabled | 0 | Portrait/Landscape Detection: Disabled
PortraitLandscapeDetectionEnabled | 1 | Portrait/Landscape Detection: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePlStatusBafro Enumeration

IRD

Fxos8700cqTypePlStatusBafro Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePlStatusBafro
Public Enumeration TypePlStatusBafro
public enum class TypePlStatusBafro
type TypePlStatusBafro
Members
Member name | Value | Description
FrontFacingOrientation | 0 | Front Facing Orientation
BackFacingOrientation | 1 | Back Facing Orientation
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePlStatusIo Enumeration

IRD

Fxos8700cqTypePlStatusIo Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePlStatusIo
Public Enumeration TypePlStatusIo
public enum class TypePlStatusIo
type TypePlStatusIo
Members
Member name | Value | Description
LockoutConditionNotDetected | 0 | Lockout Condition:Not Detected
ZTiltLockoutTripAngleExceededLockoutConditionDetected | 1 | Z-Tilt Lockout Trip Angle: Exceeded / Lockout Condition: Detected
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePlStatusLapo Enumeration

IRD

Fxos8700cqTypePlStatusLapo Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePlStatusLapo
Public Enumeration TypePlStatusLapo
public enum class TypePlStatusLapo
type TypePlStatusLapo
Members
Member name | Value | Description
PortraitUp | 0 | Portrait Up
PortraitDown | 1 | Portrait Down
LandscapeRight | 2 | Landscape Right
LandscapeLeft | 3 | Landscape Left
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePlStatusNewlp Enumeration

IRD

Fxos8700cqTypePlStatusNewlp Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePlStatusNewlp
Public Enumeration TypePlStatusNewlp
public enum class TypePlStatusNewlp
type TypePlStatusNewlp
Members
Member name | Value | Description
NotChanged | 0 | Not Changed
Changed | 1 | Changed
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePlThsRegHys Enumeration

IRD

Fxos8700cqTypePlThsRegHys Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePlThsRegHys
Public Enumeration TypePlThsRegHys
public enum class TypePlThsRegHys
type TypePlThsRegHys
Members
Member name | Value | Description
Value_4545 | 0 | 45° / 45°
Value_4941 | 1 | 49° / 41°
Value_5238 | 2 | 52° / 38°
Value_5634 | 3 | 56° / 34°
Value_5931 | 4 | 59° / 31°
Value_6228 | 5 | 62° / 28°
Value_6624 | 6 | 66° / 24°
Value_6921 | 7 | 69° / 21°
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePlThsRegPlThs Enumeration

IRD

Fxos8700cqTypePlThsRegPlThs Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePlThsRegPlThs
Public Enumeration TypePlThsRegPlThs
public enum class TypePlThsRegPlThs
type TypePlThsRegPlThs
Members
Member name | Value | Description
Value_15 | 7 | 15°
Value_20 | 9 | 20°
Value_30 | 12 | 30°
Value_35 | 13 | 35°
Value_40 | 15 | 40°
Value_45 | 16 | 45°
Value_55 | 19 | 55°
Value_60 | 20 | 60°
Value_70 | 23 | 70°
Value_75 | 25 | 75°
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePulseCfgPlsDpa Enumeration

IRD

Fxos8700cqTypePulseCfgPlsDpa Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePulseCfgPlsDpa
Public Enumeration TypePulseCfgPlsDpa
public enum class TypePulseCfgPlsDpa
type TypePulseCfgPlsDpa
Members
Member name | Value | Description
DoublePulseAbortNotAborted | 0 | Double-Pulse Abort: Not Aborted
DoublePulseAbortAborted | 1 | Double-Pulse Abort: Aborted
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePulseCfgPlsEle Enumeration

IRD

Fxos8700cqTypePulseCfgPlsEle Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePulseCfgPlsEle
Public Enumeration TypePulseCfgPlsEle
public enum class TypePulseCfgPlsEle
type TypePulseCfgPlsEle
Members
Member name | Value | Description
PulseEventFlagLatchDisabled | 0 | Pulse Event Flag Latch: Disabled
PulseEventFlagLatchEnabled | 1 | Pulse Event Flag Latch: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePulseCfgPlsXdpefe Enumeration

IRD

Fxos8700cqTypePulseCfgPlsXdpefe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePulseCfgPlsXdpefe
Public Enumeration TypePulseCfgPlsXdpefe
public enum class TypePulseCfgPlsXdpefe
type TypePulseCfgPlsXdpefe
Members
Member name | Value | Description
EventFlagOnDoublePulseEventOnXAxisDisabled | 0 | Event Flag On Double-Pulse Event On X-Axis: Disabled
EventFlagOnDoublePulseEventOnXAxisEnabled | 1 | Event Flag On Double-Pulse Event On X-Axis: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePulseCfgPlsXspefe Enumeration

IRD

Fxos8700cqTypePulseCfgPlsXspefe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePulseCfgPlsXspefe
Public Enumeration TypePulseCfgPlsXspefe
public enum class TypePulseCfgPlsXspefe
type TypePulseCfgPlsXspefe
Members
Member name | Value | Description
EventFlagOnSinglePulseEventOnXAxisDisabled | 0 | Event Flag On Single-Pulse Event On X-Axis: Disabled
EventFlagOnSinglePulseEventOnXAxisEnabled | 1 | Event Flag On Single-Pulse Event On X-Axis: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePulseCfgPlsYdpefe Enumeration

IRD

Fxos8700cqTypePulseCfgPlsYdpefe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePulseCfgPlsYdpefe
Public Enumeration TypePulseCfgPlsYdpefe
public enum class TypePulseCfgPlsYdpefe
type TypePulseCfgPlsYdpefe
Members
Member name | Value | Description
EventFlagOnDoublePulseEventOnYAxisDisabled | 0 | Event Flag On Double-Pulse Event On Y-Axis: Disabled
EventFlagOnDoublePulseEventOnYAxisEnabled | 1 | Event Flag On Double-Pulse Event On Y-Axis: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePulseCfgPlsYspefe Enumeration

IRD

Fxos8700cqTypePulseCfgPlsYspefe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePulseCfgPlsYspefe
Public Enumeration TypePulseCfgPlsYspefe
public enum class TypePulseCfgPlsYspefe
type TypePulseCfgPlsYspefe
Members
Member name | Value | Description
EventFlagOnSinglePulseEventOnYAxisDisabled | 0 | Event Flag On Single-Pulse Event On Y-Axis: Disabled
EventFlagOnSinglePulseEventOnYAxisEnabled | 1 | Event Flag On Single-Pulse Event On Y-Axis: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePulseCfgPlsZdpefe Enumeration

IRD

Fxos8700cqTypePulseCfgPlsZdpefe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePulseCfgPlsZdpefe
Public Enumeration TypePulseCfgPlsZdpefe
public enum class TypePulseCfgPlsZdpefe
type TypePulseCfgPlsZdpefe
Members
Member name | Value | Description
EventFlagOnDoublePulseEventOnZAxisDisabled | 0 | Event Flag On Double-Pulse Event On Z-Axis: Disabled
EventFlagOnDoublePulseEventOnZAxisEnabled | 1 | Event Flag On Double-Pulse Event On Z-Axis: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePulseCfgPlsZspefe Enumeration

IRD

Fxos8700cqTypePulseCfgPlsZspefe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePulseCfgPlsZspefe
Public Enumeration TypePulseCfgPlsZspefe
public enum class TypePulseCfgPlsZspefe
type TypePulseCfgPlsZspefe
Members
Member name | Value | Description
EventFlagOnSinglePulseEventOnZAxisDisabled | 0 | Event Flag On Single-Pulse Event On Z-Axis: Disabled
EventFlagOnSinglePulseEventOnZAxisEnabled | 1 | Event Flag On Single-Pulse Event On Z-Axis: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePulseSrcPlsSrcAxx Enumeration

IRD

Fxos8700cqTypePulseSrcPlsSrcAxx Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePulseSrcPlsSrcAxx
Public Enumeration TypePulseSrcPlsSrcAxx
public enum class TypePulseSrcPlsSrcAxx
type TypePulseSrcPlsSrcAxx
Members
Member name | Value | Description
XAxisEventFlagNoInterrupt | 0 | X-Axis Event Flag: No Interrupt
XAxisEventFlagInterrupt | 1 | X-Axis Event Flag: Interrupt
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePulseSrcPlsSrcAxy Enumeration

IRD

Fxos8700cqTypePulseSrcPlsSrcAxy Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePulseSrcPlsSrcAxy
Public Enumeration TypePulseSrcPlsSrcAxy
public enum class TypePulseSrcPlsSrcAxy
type TypePulseSrcPlsSrcAxy
Members
Member name | Value | Description
YAxisEventFlagNoInterrupt | 0 | Y-Axis Event Flag: No Interrupt
YAxisEventFlagInterrupt | 1 | Y-Axis Event Flag: Interrupt
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePulseSrcPlsSrcAxz Enumeration

IRD

Fxos8700cqTypePulseSrcPlsSrcAxz Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePulseSrcPlsSrcAxz
Public Enumeration TypePulseSrcPlsSrcAxz
public enum class TypePulseSrcPlsSrcAxz
type TypePulseSrcPlsSrcAxz
Members
Member name | Value | Description
ZAxisEventFlagNoInterrupt | 0 | Z-Axis Event Flag: No Interrupt
ZAxisEventFlagInterrupt | 1 | Z-Axis Event Flag: Interrupt
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePulseSrcPlsSrcDpe Enumeration

IRD

Fxos8700cqTypePulseSrcPlsSrcDpe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePulseSrcPlsSrcDpe
Public Enumeration TypePulseSrcPlsSrcDpe
public enum class TypePulseSrcPlsSrcDpe
type TypePulseSrcPlsSrcDpe
Members
Member name | Value | Description
DoublePluseOnFirstEventSinglePulse | 0 | Double Pluse On First Event: Single-Pulse
DoublePluseOnFirstEventDoublePulse | 1 | Double Pluse On First Event: Double-Pulse
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePulseSrcPlsSrcEa Enumeration

IRD

Fxos8700cqTypePulseSrcPlsSrcEa Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePulseSrcPlsSrcEa
Public Enumeration TypePulseSrcPlsSrcEa
public enum class TypePulseSrcPlsSrcEa
type TypePulseSrcPlsSrcEa
Members
Member name | Value | Description
EventActiveFlagNone | 0 | Event Active Flag: None
EventActiveFlagOneMore | 1 | Event Active Flag: One/More
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePulseSrcPlsSrcPolx Enumeration

IRD

Fxos8700cqTypePulseSrcPlsSrcPolx Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePulseSrcPlsSrcPolx
Public Enumeration TypePulseSrcPlsSrcPolx
public enum class TypePulseSrcPlsSrcPolx
type TypePulseSrcPlsSrcPolx
Members
Member name | Value | Description
PulsePolarityOfXAxisPositive | 0 | Pulse Polarity Of X-Axis: Positive
PulsePolarityOfXAxisNegative | 1 | Pulse Polarity Of X-Axis: Negative
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePulseSrcPlsSrcPoly Enumeration

IRD

Fxos8700cqTypePulseSrcPlsSrcPoly Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePulseSrcPlsSrcPoly
Public Enumeration TypePulseSrcPlsSrcPoly
public enum class TypePulseSrcPlsSrcPoly
type TypePulseSrcPlsSrcPoly
Members
Member name | Value | Description
PulsePolarityOfYAxisPositive | 0 | Pulse Polarity Of Y-Axis: Positive
PulsePolarityOfYAxisNegative | 1 | Pulse Polarity Of Y-Axis: Negative
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypePulseSrcPlsSrcPolz Enumeration

IRD

Fxos8700cqTypePulseSrcPlsSrcPolz Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePulseSrcPlsSrcPolz
Public Enumeration TypePulseSrcPlsSrcPolz
public enum class TypePulseSrcPlsSrcPolz
type TypePulseSrcPlsSrcPolz
Members
Member name | Value | Description
PulsePolarityOfZAxisPositive | 0 | Pulse Polarity Of Z-Axis: Positive
PulsePolarityOfZAxisNegative | 1 | Pulse Polarity Of Z-Axis: Negative
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeSysmodFgerr Enumeration

IRD

Fxos8700cqTypeSysmodFgerr Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSysmodFgerr
Public Enumeration TypeSysmodFgerr
public enum class TypeSysmodFgerr
type TypeSysmodFgerr
Members
Member name | Value | Description
FIFOGateErrorNotDetected | 0 | FIFO Gate Error: Not Detected
FIFOGateErrorDetected | 1 | FIFO Gate Error: Detected
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeSysmodSysmode Enumeration

IRD

Fxos8700cqTypeSysmodSysmode Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSysmodSysmode
Public Enumeration TypeSysmodSysmode
public enum class TypeSysmodSysmode
type TypeSysmodSysmode
Members
Member name | Value | Description
StandbyMode | 0 | Standby Mode
WakeMode | 1 | Wake Mode
SleepMode | 2 | Sleep Mode
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeTransientCfgTranEle Enumeration

IRD

Fxos8700cqTypeTransientCfgTranEle Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTransientCfgTranEle
Public Enumeration TypeTransientCfgTranEle
public enum class TypeTransientCfgTranEle
type TypeTransientCfgTranEle
Members
Member name | Value | Description
EventFlagLatchDisabled | 0 | Event Flag Latch: Disabled
EventFlagLatchEnabled | 1 | Event Flag Latch: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeTransientCfgTranHpfByp Enumeration

IRD

Fxos8700cqTypeTransientCfgTranHpfByp Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTransientCfgTranHpfByp
Public Enumeration TypeTransientCfgTranHpfByp
public enum class TypeTransientCfgTranHpfByp
type TypeTransientCfgTranHpfByp
Members
Member name | Value | Description
HighPassFilterApplied | 0 | High-Pass Filter: Applied
HighPassFilterNotApplied | 1 | High-Pass Filter: Not Applied
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeTransientCfgTranXefe Enumeration

IRD

Fxos8700cqTypeTransientCfgTranXefe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTransientCfgTranXefe
Public Enumeration TypeTransientCfgTranXefe
public enum class TypeTransientCfgTranXefe
type TypeTransientCfgTranXefe
Members
Member name | Value | Description
XAxisEventDetectionDisabled | 0 | X-Axis Event Detection: Disabled
ZAxisEventDetectionEnabled | 1 | Z-Axis Event Detection: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeTransientCfgTranYefe Enumeration

IRD

Fxos8700cqTypeTransientCfgTranYefe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTransientCfgTranYefe
Public Enumeration TypeTransientCfgTranYefe
public enum class TypeTransientCfgTranYefe
type TypeTransientCfgTranYefe
Members
Member name | Value | Description
YAxisEventDetectionDisabled | 0 | Y-Axis Event Detection: Disabled
YAxisEventDetectionEnabled | 1 | Y-Axis Event Detection: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeTransientCfgTranZefe Enumeration

IRD

Fxos8700cqTypeTransientCfgTranZefe Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTransientCfgTranZefe
Public Enumeration TypeTransientCfgTranZefe
public enum class TypeTransientCfgTranZefe
type TypeTransientCfgTranZefe
Members
Member name | Value | Description
ZAxisEventDetectionDisabled | 0 | Z-Axis Event Detection: Disabled
ZAxisEventDetectionEnabled | 1 | Z-Axis Event Detection: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeTransientSrcTranEa Enumeration

IRD

Fxos8700cqTypeTransientSrcTranEa Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTransientSrcTranEa
Public Enumeration TypeTransientSrcTranEa
public enum class TypeTransientSrcTranEa
type TypeTransientSrcTranEa
Members
Member name | Value | Description
TransientEventActiveFlagNone | 0 | Transient Event Active Flag: None
TransientEventActiveFlagOneMore | 1 | Transient Event Active Flag: One/More
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeTransientSrcTranXef Enumeration

IRD

Fxos8700cqTypeTransientSrcTranXef Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTransientSrcTranXef
Public Enumeration TypeTransientSrcTranXef
public enum class TypeTransientSrcTranXef
type TypeTransientSrcTranXef
Members
Member name | Value | Description
ZAxisEventFlagNotActive | 0 | Z-Axis Event Flag: Not Active
ZAxisEventFlagActive | 1 | Z-Axis Event Flag: Active
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeTransientSrcTranXpol Enumeration

IRD

Fxos8700cqTypeTransientSrcTranXpol Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTransientSrcTranXpol
Public Enumeration TypeTransientSrcTranXpol
public enum class TypeTransientSrcTranXpol
type TypeTransientSrcTranXpol
Members
Member name | Value | Description
ZAxisEventPolarityAbovePositiveThreshold | 0 | Z-Axis Event Polarity: Above Positive Threshold
ZAxisEventPolarityBelowNegativeThreshold | 1 | Z-Axis Event Polarity: Below Negative Threshold
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeTransientSrcTranYef Enumeration

IRD

Fxos8700cqTypeTransientSrcTranYef Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTransientSrcTranYef
Public Enumeration TypeTransientSrcTranYef
public enum class TypeTransientSrcTranYef
type TypeTransientSrcTranYef
Members
Member name | Value | Description
YAxisEventFlagNotActive | 0 | Y-Axis Event Flag: Not Active
YAxisEventFlagActive | 1 | Y-Axis Event Flag: Active
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeTransientSrcTranYpol Enumeration

IRD

Fxos8700cqTypeTransientSrcTranYpol Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTransientSrcTranYpol
Public Enumeration TypeTransientSrcTranYpol
public enum class TypeTransientSrcTranYpol
type TypeTransientSrcTranYpol
Members
Member name | Value | Description
YAxisEventPolarityAbovePositiveThreshold | 0 | Y-Axis Event Polarity: Above Positive Threshold
YAxisEventPolarityBelowNegativeThreshold | 1 | Y-Axis Event Polarity: Below Negative Threshold
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeTransientSrcTranZef Enumeration

IRD

Fxos8700cqTypeTransientSrcTranZef Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTransientSrcTranZef
Public Enumeration TypeTransientSrcTranZef
public enum class TypeTransientSrcTranZef
type TypeTransientSrcTranZef
Members
Member name | Value | Description
ZAxisEventFlagNotActive | 0 | Z-Axis Event Flag: Not Active
ZAxisEventFlagActive | 1 | Z-Axis Event Flag: Active
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeTransientSrcTranZpol Enumeration

IRD

Fxos8700cqTypeTransientSrcTranZpol Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTransientSrcTranZpol
Public Enumeration TypeTransientSrcTranZpol
public enum class TypeTransientSrcTranZpol
type TypeTransientSrcTranZpol
Members
Member name | Value | Description
XAxisEventPolarityAbovePositiveThreshold | 0 | X-Axis Event Polarity: Above Positive Threshold
XAxisEventPolarityBelowNegativeThreshold | 1 | X-Axis Event Polarity: Below Negative Threshold
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeTransientThsTrDbcntm Enumeration

IRD

Fxos8700cqTypeTransientThsTrDbcntm Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTransientThsTrDbcntm
Public Enumeration TypeTransientThsTrDbcntm
public enum class TypeTransientThsTrDbcntm
type TypeTransientThsTrDbcntm
Members
Member name | Value | Description
DebounceCounterModeSelectionDecrementCounter | 0 | Debounce Counter Mode Selection: Decrement Counter
DebounceCounterModeSelectionClearCounter | 1 | Debounce Counter Mode Selection: Clear Counter
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeTrigCfg Enumeration

IRD

Fxos8700cqTypeTrigCfg Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTrigCfg
Public Enumeration TypeTrigCfg
public enum class TypeTrigCfg
type TypeTrigCfg
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeXyzDataCfgFs Enumeration

IRD

Fxos8700cqTypeXyzDataCfgFs Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeXyzDataCfgFs
Public Enumeration TypeXyzDataCfgFs
public enum class TypeXyzDataCfgFs
type TypeXyzDataCfgFs
Members
Member name | Value | Description
Value_0244MgLSB | 0 | ±0.244 mg/LSB
Value_0488MgLSB | 1 | ±0.488 mg/LSB
Value_0976MgLSB | 2 | ±0.976 mg/LSB
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Fxos8700cq.TypeXyzDataCfgHpfOut Enumeration

IRD

Fxos8700cqTypeXyzDataCfgHpfOut Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeXyzDataCfgHpfOut
Public Enumeration TypeXyzDataCfgHpfOut
public enum class TypeXyzDataCfgHpfOut
type TypeXyzDataCfgHpfOut
Members
Member name | Value | Description
HighPassFilterDisabled | 0 | High-Pass Filter: Disabled
HighPassFilterEnabled | 1 | High-Pass Filter: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l Class

Freescale Semiconductor: MMA 7455L
Inheritance Hierarchy
SystemObject
telos.Ird.FreescaleSemiconductorMma7455l

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Mma7455l
Public Class Mma7455l
public ref class Mma7455l
type Mma7455l =  class end

The Mma7455l type exposes the following members.

Constructors
 | Name | Description
Public method | Mma7455l | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlDFBW | Control: DFBW
Public property | ControlDRVO | Control: DRVO
Public property | ControlINTPIN | Control: INTPIN
Public property | ControlINTREG | Control: INTREG
Public property | ControlLDPL | Control: LDPL
Public property | ControlPDPL | Control: PDPL
Public property | ControlTHOPT | Control: THOPT
Public property | ControlXDA | Control: XDA
Public property | ControlYDA | Control: YDA
Public property | ControlZDA | Control: ZDA
Public property | DetectionSourceINT1 | Detection Source: INT1
Public property | DetectionSourceINT2 | Detection Source: INT2
Public property | DetectionSourceLDX | Detection Source: LDX
Public property | DetectionSourceLDY | Detection Source: LDY
Public property | DetectionSourceLDZ | Detection Source: LDZ
Public property | DetectionSourcePDX | Detection Source: PDX
Public property | DetectionSourcePDY | Detection Source: PDY
Public property | DetectionSourcePDZ | Detection Source: PDZ
Public property | I2CDeviceAddressDVAD | I2C Device Address: DVAD
Public property | I2CDeviceAddressI2CDIS | I2C Device Address: I2CDIS
Public property | InterruptLatchResetCLRINT1 | Interrupt Latch Reset: CLR_INT1
Public property | InterruptLatchResetCLRINT2 | Interrupt Latch Reset: CLR_INT2
Public property | LatencyTimeValue | Latency Time Value (unit: ms)
Public property | LevelDetectionThresholdLimitValue | Level Detection Threshold Limit Value
Public property | ModeControlDRPD | Mode Control: DRPD
Public property | ModeControlGLVL | Mode Control: GLVL
Public property | ModeControlMode | Mode Control: Mode
Public property | ModeControlSPI3W | Mode Control: SPI3W
Public property | ModeControlSTON | Mode Control: STON
Public property | OffsetDriftX | Offset Drift X
Public property | OffsetDriftY | Offset Drift Y
Public property | OffsetDriftZ | Offset Drift Z
Public property | Property_10BitsOutputValueX | 10 Bits Output Value X
Public property | Property_10BitsOutputValueY | 10 Bits Output Value Y
Public property | Property_10BitsOutputValueZ | 10 Bits Output Value Z
Public property | Property_8BitsOutputValueX | 8 Bits Output Value X
Public property | Property_8BitsOutputValueY | 8 Bits Output Value Y
Public property | Property_8BitsOutputValueZ | 8 Bits Output Value Z
Public property | PulseDetectionThresholdLimitValue | Pulse Detection Threshold Limit Value
Public property | PulseDurationValue | Pulse Duration Value (unit: ms)
Public property | StatusDOVR | Status: DOVR
Public property | StatusDRDY | Status: DRDY
Public property | StatusPERR | Status: PERR
Public property | TimeWindowFor2ndPulseValue | Time Window For 2nd Pulse Value (unit: ms)
Public property | UserInformation | User Information
Public property | WhoAmIValue | "Who Am I" Value
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
±2g/±4g/±8g Three Axis Low-G Digital Output Accelerometer
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l Constructor

Constructor

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455l(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Mma7455l(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Mma7455l

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l Properties

The Mma7455l type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlDFBW | Control: DFBW
Public property | ControlDRVO | Control: DRVO
Public property | ControlINTPIN | Control: INTPIN
Public property | ControlINTREG | Control: INTREG
Public property | ControlLDPL | Control: LDPL
Public property | ControlPDPL | Control: PDPL
Public property | ControlTHOPT | Control: THOPT
Public property | ControlXDA | Control: XDA
Public property | ControlYDA | Control: YDA
Public property | ControlZDA | Control: ZDA
Public property | DetectionSourceINT1 | Detection Source: INT1
Public property | DetectionSourceINT2 | Detection Source: INT2
Public property | DetectionSourceLDX | Detection Source: LDX
Public property | DetectionSourceLDY | Detection Source: LDY
Public property | DetectionSourceLDZ | Detection Source: LDZ
Public property | DetectionSourcePDX | Detection Source: PDX
Public property | DetectionSourcePDY | Detection Source: PDY
Public property | DetectionSourcePDZ | Detection Source: PDZ
Public property | I2CDeviceAddressDVAD | I2C Device Address: DVAD
Public property | I2CDeviceAddressI2CDIS | I2C Device Address: I2CDIS
Public property | InterruptLatchResetCLRINT1 | Interrupt Latch Reset: CLR_INT1
Public property | InterruptLatchResetCLRINT2 | Interrupt Latch Reset: CLR_INT2
Public property | LatencyTimeValue | Latency Time Value (unit: ms)
Public property | LevelDetectionThresholdLimitValue | Level Detection Threshold Limit Value
Public property | ModeControlDRPD | Mode Control: DRPD
Public property | ModeControlGLVL | Mode Control: GLVL
Public property | ModeControlMode | Mode Control: Mode
Public property | ModeControlSPI3W | Mode Control: SPI3W
Public property | ModeControlSTON | Mode Control: STON
Public property | OffsetDriftX | Offset Drift X
Public property | OffsetDriftY | Offset Drift Y
Public property | OffsetDriftZ | Offset Drift Z
Public property | Property_10BitsOutputValueX | 10 Bits Output Value X
Public property | Property_10BitsOutputValueY | 10 Bits Output Value Y
Public property | Property_10BitsOutputValueZ | 10 Bits Output Value Z
Public property | Property_8BitsOutputValueX | 8 Bits Output Value X
Public property | Property_8BitsOutputValueY | 8 Bits Output Value Y
Public property | Property_8BitsOutputValueZ | 8 Bits Output Value Z
Public property | PulseDetectionThresholdLimitValue | Pulse Detection Threshold Limit Value
Public property | PulseDurationValue | Pulse Duration Value (unit: ms)
Public property | StatusDOVR | Status: DOVR
Public property | StatusDRDY | Status: DRDY
Public property | StatusPERR | Status: PERR
Public property | TimeWindowFor2ndPulseValue | Time Window For 2nd Pulse Value (unit: ms)
Public property | UserInformation | User Information
Public property | WhoAmIValue | "Who Am I" Value
Top
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.AutoFlush Property

IRD

Mma7455lAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.ControlDFBW Property

IRD

Mma7455lControlDFBW Property

Control: DFBW

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeControl1Dfbw ControlDFBW { get; set; }
Public Property ControlDFBW As Mma7455lTypeControl1Dfbw
    Get
    Set
public:
property Mma7455lTypeControl1Dfbw ControlDFBW {
    Mma7455lTypeControl1Dfbw get ();
    void set (Mma7455lTypeControl1Dfbw value);
}
member ControlDFBW : Mma7455lTypeControl1Dfbw with get, set

Property Value

Type: Mma7455lTypeControl1Dfbw
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.ControlDRVO Property

IRD

Mma7455lControlDRVO Property

Control: DRVO

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeControl2Drvo ControlDRVO { get; set; }
Public Property ControlDRVO As Mma7455lTypeControl2Drvo
    Get
    Set
public:
property Mma7455lTypeControl2Drvo ControlDRVO {
    Mma7455lTypeControl2Drvo get ();
    void set (Mma7455lTypeControl2Drvo value);
}
member ControlDRVO : Mma7455lTypeControl2Drvo with get, set

Property Value

Type: Mma7455lTypeControl2Drvo
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.ControlINTPIN Property

IRD

Mma7455lControlINTPIN Property

Control: INTPIN

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeControl1Intpin ControlINTPIN { get; set; }
Public Property ControlINTPIN As Mma7455lTypeControl1Intpin
    Get
    Set
public:
property Mma7455lTypeControl1Intpin ControlINTPIN {
    Mma7455lTypeControl1Intpin get ();
    void set (Mma7455lTypeControl1Intpin value);
}
member ControlINTPIN : Mma7455lTypeControl1Intpin with get, set

Property Value

Type: Mma7455lTypeControl1Intpin
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.ControlINTREG Property

IRD

Mma7455lControlINTREG Property

Control: INTREG

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeControl1Intreg ControlINTREG { get; set; }
Public Property ControlINTREG As Mma7455lTypeControl1Intreg
    Get
    Set
public:
property Mma7455lTypeControl1Intreg ControlINTREG {
    Mma7455lTypeControl1Intreg get ();
    void set (Mma7455lTypeControl1Intreg value);
}
member ControlINTREG : Mma7455lTypeControl1Intreg with get, set

Property Value

Type: Mma7455lTypeControl1Intreg
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.ControlLDPL Property

IRD

Mma7455lControlLDPL Property

Control: LDPL

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeControl2Ldpl ControlLDPL { get; set; }
Public Property ControlLDPL As Mma7455lTypeControl2Ldpl
    Get
    Set
public:
property Mma7455lTypeControl2Ldpl ControlLDPL {
    Mma7455lTypeControl2Ldpl get ();
    void set (Mma7455lTypeControl2Ldpl value);
}
member ControlLDPL : Mma7455lTypeControl2Ldpl with get, set

Property Value

Type: Mma7455lTypeControl2Ldpl
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.ControlPDPL Property

IRD

Mma7455lControlPDPL Property

Control: PDPL

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeControl2Pdpl ControlPDPL { get; set; }
Public Property ControlPDPL As Mma7455lTypeControl2Pdpl
    Get
    Set
public:
property Mma7455lTypeControl2Pdpl ControlPDPL {
    Mma7455lTypeControl2Pdpl get ();
    void set (Mma7455lTypeControl2Pdpl value);
}
member ControlPDPL : Mma7455lTypeControl2Pdpl with get, set

Property Value

Type: Mma7455lTypeControl2Pdpl
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.ControlTHOPT Property

IRD

Mma7455lControlTHOPT Property

Control: THOPT

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeControl1Thopt ControlTHOPT { get; set; }
Public Property ControlTHOPT As Mma7455lTypeControl1Thopt
    Get
    Set
public:
property Mma7455lTypeControl1Thopt ControlTHOPT {
    Mma7455lTypeControl1Thopt get ();
    void set (Mma7455lTypeControl1Thopt value);
}
member ControlTHOPT : Mma7455lTypeControl1Thopt with get, set

Property Value

Type: Mma7455lTypeControl1Thopt
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.ControlXDA Property

IRD

Mma7455lControlXDA Property

Control: XDA

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeControl1Xda ControlXDA { get; set; }
Public Property ControlXDA As Mma7455lTypeControl1Xda
    Get
    Set
public:
property Mma7455lTypeControl1Xda ControlXDA {
    Mma7455lTypeControl1Xda get ();
    void set (Mma7455lTypeControl1Xda value);
}
member ControlXDA : Mma7455lTypeControl1Xda with get, set

Property Value

Type: Mma7455lTypeControl1Xda
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.ControlYDA Property

IRD

Mma7455lControlYDA Property

Control: YDA

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeControl1Yda ControlYDA { get; set; }
Public Property ControlYDA As Mma7455lTypeControl1Yda
    Get
    Set
public:
property Mma7455lTypeControl1Yda ControlYDA {
    Mma7455lTypeControl1Yda get ();
    void set (Mma7455lTypeControl1Yda value);
}
member ControlYDA : Mma7455lTypeControl1Yda with get, set

Property Value

Type: Mma7455lTypeControl1Yda
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.ControlZDA Property

IRD

Mma7455lControlZDA Property

Control: ZDA

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeControl1Zda ControlZDA { get; set; }
Public Property ControlZDA As Mma7455lTypeControl1Zda
    Get
    Set
public:
property Mma7455lTypeControl1Zda ControlZDA {
    Mma7455lTypeControl1Zda get ();
    void set (Mma7455lTypeControl1Zda value);
}
member ControlZDA : Mma7455lTypeControl1Zda with get, set

Property Value

Type: Mma7455lTypeControl1Zda
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.DetectionSourceINT1 Property

IRD

Mma7455lDetectionSourceINT1 Property

Detection Source: INT1

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeDetectionInt DetectionSourceINT1 { get; }
Public ReadOnly Property DetectionSourceINT1 As Mma7455lTypeDetectionInt
    Get
public:
property Mma7455lTypeDetectionInt DetectionSourceINT1 {
    Mma7455lTypeDetectionInt get ();
}
member DetectionSourceINT1 : Mma7455lTypeDetectionInt with get

Property Value

Type: Mma7455lTypeDetectionInt
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.DetectionSourceINT2 Property

IRD

Mma7455lDetectionSourceINT2 Property

Detection Source: INT2

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeDetectionInt DetectionSourceINT2 { get; }
Public ReadOnly Property DetectionSourceINT2 As Mma7455lTypeDetectionInt
    Get
public:
property Mma7455lTypeDetectionInt DetectionSourceINT2 {
    Mma7455lTypeDetectionInt get ();
}
member DetectionSourceINT2 : Mma7455lTypeDetectionInt with get

Property Value

Type: Mma7455lTypeDetectionInt
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.DetectionSourceLDX Property

IRD

Mma7455lDetectionSourceLDX Property

Detection Source: LDX

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeDetectionSourceLdx DetectionSourceLDX { get; }
Public ReadOnly Property DetectionSourceLDX As Mma7455lTypeDetectionSourceLdx
    Get
public:
property Mma7455lTypeDetectionSourceLdx DetectionSourceLDX {
    Mma7455lTypeDetectionSourceLdx get ();
}
member DetectionSourceLDX : Mma7455lTypeDetectionSourceLdx with get

Property Value

Type: Mma7455lTypeDetectionSourceLdx
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.DetectionSourceLDY Property

IRD

Mma7455lDetectionSourceLDY Property

Detection Source: LDY

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeDetectionSourceLdy DetectionSourceLDY { get; }
Public ReadOnly Property DetectionSourceLDY As Mma7455lTypeDetectionSourceLdy
    Get
public:
property Mma7455lTypeDetectionSourceLdy DetectionSourceLDY {
    Mma7455lTypeDetectionSourceLdy get ();
}
member DetectionSourceLDY : Mma7455lTypeDetectionSourceLdy with get

Property Value

Type: Mma7455lTypeDetectionSourceLdy
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.DetectionSourceLDZ Property

IRD

Mma7455lDetectionSourceLDZ Property

Detection Source: LDZ

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeDetectionSourceLdz DetectionSourceLDZ { get; }
Public ReadOnly Property DetectionSourceLDZ As Mma7455lTypeDetectionSourceLdz
    Get
public:
property Mma7455lTypeDetectionSourceLdz DetectionSourceLDZ {
    Mma7455lTypeDetectionSourceLdz get ();
}
member DetectionSourceLDZ : Mma7455lTypeDetectionSourceLdz with get

Property Value

Type: Mma7455lTypeDetectionSourceLdz
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.DetectionSourcePDX Property

IRD

Mma7455lDetectionSourcePDX Property

Detection Source: PDX

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeDetectionSourcePdx DetectionSourcePDX { get; }
Public ReadOnly Property DetectionSourcePDX As Mma7455lTypeDetectionSourcePdx
    Get
public:
property Mma7455lTypeDetectionSourcePdx DetectionSourcePDX {
    Mma7455lTypeDetectionSourcePdx get ();
}
member DetectionSourcePDX : Mma7455lTypeDetectionSourcePdx with get

Property Value

Type: Mma7455lTypeDetectionSourcePdx
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.DetectionSourcePDY Property

IRD

Mma7455lDetectionSourcePDY Property

Detection Source: PDY

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeDetectionSourcePdy DetectionSourcePDY { get; }
Public ReadOnly Property DetectionSourcePDY As Mma7455lTypeDetectionSourcePdy
    Get
public:
property Mma7455lTypeDetectionSourcePdy DetectionSourcePDY {
    Mma7455lTypeDetectionSourcePdy get ();
}
member DetectionSourcePDY : Mma7455lTypeDetectionSourcePdy with get

Property Value

Type: Mma7455lTypeDetectionSourcePdy
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.DetectionSourcePDZ Property

IRD

Mma7455lDetectionSourcePDZ Property

Detection Source: PDZ

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeDetectionSourcePdz DetectionSourcePDZ { get; }
Public ReadOnly Property DetectionSourcePDZ As Mma7455lTypeDetectionSourcePdz
    Get
public:
property Mma7455lTypeDetectionSourcePdz DetectionSourcePDZ {
    Mma7455lTypeDetectionSourcePdz get ();
}
member DetectionSourcePDZ : Mma7455lTypeDetectionSourcePdz with get

Property Value

Type: Mma7455lTypeDetectionSourcePdz
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.I2CDeviceAddressDVAD Property

IRD

Mma7455lI2CDeviceAddressDVAD Property

I2C Device Address: DVAD

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte I2CDeviceAddressDVAD { get; }
Public ReadOnly Property I2CDeviceAddressDVAD As Byte
    Get
public:
property unsigned char I2CDeviceAddressDVAD {
    unsigned char get ();
}
member I2CDeviceAddressDVAD : byte with get

Property Value

Type: Byte
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.I2CDeviceAddressI2CDIS Property

IRD

Mma7455lI2CDeviceAddressI2CDIS Property

I2C Device Address: I2CDIS

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeI2cDeviceAddressI2cdis I2CDeviceAddressI2CDIS { get; set; }
Public Property I2CDeviceAddressI2CDIS As Mma7455lTypeI2cDeviceAddressI2cdis
    Get
    Set
public:
property Mma7455lTypeI2cDeviceAddressI2cdis I2CDeviceAddressI2CDIS {
    Mma7455lTypeI2cDeviceAddressI2cdis get ();
    void set (Mma7455lTypeI2cDeviceAddressI2cdis value);
}
member I2CDeviceAddressI2CDIS : Mma7455lTypeI2cDeviceAddressI2cdis with get, set

Property Value

Type: Mma7455lTypeI2cDeviceAddressI2cdis
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.InterruptLatchResetCLRINT1 Property

IRD

Mma7455lInterruptLatchResetCLRINT1 Property

Interrupt Latch Reset: CLR_INT1

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeInterruptLatchResetClrInt1 InterruptLatchResetCLRINT1 { get; set; }
Public Property InterruptLatchResetCLRINT1 As Mma7455lTypeInterruptLatchResetClrInt1
    Get
    Set
public:
property Mma7455lTypeInterruptLatchResetClrInt1 InterruptLatchResetCLRINT1 {
    Mma7455lTypeInterruptLatchResetClrInt1 get ();
    void set (Mma7455lTypeInterruptLatchResetClrInt1 value);
}
member InterruptLatchResetCLRINT1 : Mma7455lTypeInterruptLatchResetClrInt1 with get, set

Property Value

Type: Mma7455lTypeInterruptLatchResetClrInt1
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.InterruptLatchResetCLRINT2 Property

IRD

Mma7455lInterruptLatchResetCLRINT2 Property

Interrupt Latch Reset: CLR_INT2

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeInterruptLatchResetClrInt2 InterruptLatchResetCLRINT2 { get; set; }
Public Property InterruptLatchResetCLRINT2 As Mma7455lTypeInterruptLatchResetClrInt2
    Get
    Set
public:
property Mma7455lTypeInterruptLatchResetClrInt2 InterruptLatchResetCLRINT2 {
    Mma7455lTypeInterruptLatchResetClrInt2 get ();
    void set (Mma7455lTypeInterruptLatchResetClrInt2 value);
}
member InterruptLatchResetCLRINT2 : Mma7455lTypeInterruptLatchResetClrInt2 with get, set

Property Value

Type: Mma7455lTypeInterruptLatchResetClrInt2
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.LatencyTimeValue Property

IRD

Mma7455lLatencyTimeValue Property

Latency Time Value (unit: ms)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LatencyTimeValue { get; set; }
Public Property LatencyTimeValue As Byte
    Get
    Set
public:
property unsigned char LatencyTimeValue {
    unsigned char get ();
    void set (unsigned char value);
}
member LatencyTimeValue : byte with get, set

Property Value

Type: Byte
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.LevelDetectionThresholdLimitValue Property

IRD

Mma7455lLevelDetectionThresholdLimitValue Property

Level Detection Threshold Limit Value

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LevelDetectionThresholdLimitValue { get; set; }
Public Property LevelDetectionThresholdLimitValue As SByte
    Get
    Set
public:
property signed char LevelDetectionThresholdLimitValue {
    signed char get ();
    void set (signed char value);
}
member LevelDetectionThresholdLimitValue : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.ModeControlDRPD Property

IRD

Mma7455lModeControlDRPD Property

Mode Control: DRPD

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeModeControlDrpd ModeControlDRPD { get; set; }
Public Property ModeControlDRPD As Mma7455lTypeModeControlDrpd
    Get
    Set
public:
property Mma7455lTypeModeControlDrpd ModeControlDRPD {
    Mma7455lTypeModeControlDrpd get ();
    void set (Mma7455lTypeModeControlDrpd value);
}
member ModeControlDRPD : Mma7455lTypeModeControlDrpd with get, set

Property Value

Type: Mma7455lTypeModeControlDrpd
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.ModeControlGLVL Property

IRD

Mma7455lModeControlGLVL Property

Mode Control: GLVL

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeModeControlGlvl ModeControlGLVL { get; set; }
Public Property ModeControlGLVL As Mma7455lTypeModeControlGlvl
    Get
    Set
public:
property Mma7455lTypeModeControlGlvl ModeControlGLVL {
    Mma7455lTypeModeControlGlvl get ();
    void set (Mma7455lTypeModeControlGlvl value);
}
member ModeControlGLVL : Mma7455lTypeModeControlGlvl with get, set

Property Value

Type: Mma7455lTypeModeControlGlvl
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.ModeControlMode Property

IRD

Mma7455lModeControlMode Property

Mode Control: Mode

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeModeControlMode ModeControlMode { get; set; }
Public Property ModeControlMode As Mma7455lTypeModeControlMode
    Get
    Set
public:
property Mma7455lTypeModeControlMode ModeControlMode {
    Mma7455lTypeModeControlMode get ();
    void set (Mma7455lTypeModeControlMode value);
}
member ModeControlMode : Mma7455lTypeModeControlMode with get, set

Property Value

Type: Mma7455lTypeModeControlMode
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.ModeControlSPI3W Property

IRD

Mma7455lModeControlSPI3W Property

Mode Control: SPI3W

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeModeControlSpi3w ModeControlSPI3W { get; set; }
Public Property ModeControlSPI3W As Mma7455lTypeModeControlSpi3w
    Get
    Set
public:
property Mma7455lTypeModeControlSpi3w ModeControlSPI3W {
    Mma7455lTypeModeControlSpi3w get ();
    void set (Mma7455lTypeModeControlSpi3w value);
}
member ModeControlSPI3W : Mma7455lTypeModeControlSpi3w with get, set

Property Value

Type: Mma7455lTypeModeControlSpi3w
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.ModeControlSTON Property

IRD

Mma7455lModeControlSTON Property

Mode Control: STON

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeModeControlSton ModeControlSTON { get; set; }
Public Property ModeControlSTON As Mma7455lTypeModeControlSton
    Get
    Set
public:
property Mma7455lTypeModeControlSton ModeControlSTON {
    Mma7455lTypeModeControlSton get ();
    void set (Mma7455lTypeModeControlSton value);
}
member ModeControlSTON : Mma7455lTypeModeControlSton with get, set

Property Value

Type: Mma7455lTypeModeControlSton
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.OffsetDriftX Property

IRD

Mma7455lOffsetDriftX Property

Offset Drift X

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short OffsetDriftX { get; set; }
Public Property OffsetDriftX As Short
    Get
    Set
public:
property short OffsetDriftX {
    short get ();
    void set (short value);
}
member OffsetDriftX : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.OffsetDriftY Property

IRD

Mma7455lOffsetDriftY Property

Offset Drift Y

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short OffsetDriftY { get; set; }
Public Property OffsetDriftY As Short
    Get
    Set
public:
property short OffsetDriftY {
    short get ();
    void set (short value);
}
member OffsetDriftY : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.OffsetDriftZ Property

IRD

Mma7455lOffsetDriftZ Property

Offset Drift Z

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short OffsetDriftZ { get; set; }
Public Property OffsetDriftZ As Short
    Get
    Set
public:
property short OffsetDriftZ {
    short get ();
    void set (short value);
}
member OffsetDriftZ : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.Property_10BitsOutputValueX Property

IRD

Mma7455lProperty_10BitsOutputValueX Property

10 Bits Output Value X

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short Property_10BitsOutputValueX { get; }
Public ReadOnly Property Property_10BitsOutputValueX As Short
    Get
public:
property short Property_10BitsOutputValueX {
    short get ();
}
member Property_10BitsOutputValueX : int16 with get

Property Value

Type: Int16
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.Property_10BitsOutputValueY Property

IRD

Mma7455lProperty_10BitsOutputValueY Property

10 Bits Output Value Y

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short Property_10BitsOutputValueY { get; }
Public ReadOnly Property Property_10BitsOutputValueY As Short
    Get
public:
property short Property_10BitsOutputValueY {
    short get ();
}
member Property_10BitsOutputValueY : int16 with get

Property Value

Type: Int16
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.Property_10BitsOutputValueZ Property

IRD

Mma7455lProperty_10BitsOutputValueZ Property

10 Bits Output Value Z

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short Property_10BitsOutputValueZ { get; }
Public ReadOnly Property Property_10BitsOutputValueZ As Short
    Get
public:
property short Property_10BitsOutputValueZ {
    short get ();
}
member Property_10BitsOutputValueZ : int16 with get

Property Value

Type: Int16
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.Property_8BitsOutputValueX Property

IRD

Mma7455lProperty_8BitsOutputValueX Property

8 Bits Output Value X

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Property_8BitsOutputValueX { get; }
Public ReadOnly Property Property_8BitsOutputValueX As SByte
    Get
public:
property signed char Property_8BitsOutputValueX {
    signed char get ();
}
member Property_8BitsOutputValueX : sbyte with get

Property Value

Type: SByte
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.Property_8BitsOutputValueY Property

IRD

Mma7455lProperty_8BitsOutputValueY Property

8 Bits Output Value Y

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Property_8BitsOutputValueY { get; }
Public ReadOnly Property Property_8BitsOutputValueY As SByte
    Get
public:
property signed char Property_8BitsOutputValueY {
    signed char get ();
}
member Property_8BitsOutputValueY : sbyte with get

Property Value

Type: SByte
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.Property_8BitsOutputValueZ Property

IRD

Mma7455lProperty_8BitsOutputValueZ Property

8 Bits Output Value Z

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Property_8BitsOutputValueZ { get; }
Public ReadOnly Property Property_8BitsOutputValueZ As SByte
    Get
public:
property signed char Property_8BitsOutputValueZ {
    signed char get ();
}
member Property_8BitsOutputValueZ : sbyte with get

Property Value

Type: SByte
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.PulseDetectionThresholdLimitValue Property

IRD

Mma7455lPulseDetectionThresholdLimitValue Property

Pulse Detection Threshold Limit Value

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PulseDetectionThresholdLimitValue { get; set; }
Public Property PulseDetectionThresholdLimitValue As Byte
    Get
    Set
public:
property unsigned char PulseDetectionThresholdLimitValue {
    unsigned char get ();
    void set (unsigned char value);
}
member PulseDetectionThresholdLimitValue : byte with get, set

Property Value

Type: Byte
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.PulseDurationValue Property

IRD

Mma7455lPulseDurationValue Property

Pulse Duration Value (unit: ms)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double PulseDurationValue { get; set; }
Public Property PulseDurationValue As Double
    Get
    Set
public:
property double PulseDurationValue {
    double get ();
    void set (double value);
}
member PulseDurationValue : float with get, set

Property Value

Type: Double
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.StatusDOVR Property

IRD

Mma7455lStatusDOVR Property

Status: DOVR

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeStatusDovr StatusDOVR { get; }
Public ReadOnly Property StatusDOVR As Mma7455lTypeStatusDovr
    Get
public:
property Mma7455lTypeStatusDovr StatusDOVR {
    Mma7455lTypeStatusDovr get ();
}
member StatusDOVR : Mma7455lTypeStatusDovr with get

Property Value

Type: Mma7455lTypeStatusDovr
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.StatusDRDY Property

IRD

Mma7455lStatusDRDY Property

Status: DRDY

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeStatusDrdy StatusDRDY { get; }
Public ReadOnly Property StatusDRDY As Mma7455lTypeStatusDrdy
    Get
public:
property Mma7455lTypeStatusDrdy StatusDRDY {
    Mma7455lTypeStatusDrdy get ();
}
member StatusDRDY : Mma7455lTypeStatusDrdy with get

Property Value

Type: Mma7455lTypeStatusDrdy
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.StatusPERR Property

IRD

Mma7455lStatusPERR Property

Status: PERR

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mma7455lTypeStatusPerr StatusPERR { get; }
Public ReadOnly Property StatusPERR As Mma7455lTypeStatusPerr
    Get
public:
property Mma7455lTypeStatusPerr StatusPERR {
    Mma7455lTypeStatusPerr get ();
}
member StatusPERR : Mma7455lTypeStatusPerr with get

Property Value

Type: Mma7455lTypeStatusPerr
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TimeWindowFor2ndPulseValue Property

IRD

Mma7455lTimeWindowFor2ndPulseValue Property

Time Window For 2nd Pulse Value (unit: ms)

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TimeWindowFor2ndPulseValue { get; set; }
Public Property TimeWindowFor2ndPulseValue As Byte
    Get
    Set
public:
property unsigned char TimeWindowFor2ndPulseValue {
    unsigned char get ();
    void set (unsigned char value);
}
member TimeWindowFor2ndPulseValue : byte with get, set

Property Value

Type: Byte
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.UserInformation Property

IRD

Mma7455lUserInformation Property

User Information

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte UserInformation { get; }
Public ReadOnly Property UserInformation As Byte
    Get
public:
property unsigned char UserInformation {
    unsigned char get ();
}
member UserInformation : byte with get

Property Value

Type: Byte
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.WhoAmIValue Property

IRD

Mma7455lWhoAmIValue Property

"Who Am I" Value

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WhoAmIValue { get; }
Public ReadOnly Property WhoAmIValue As Byte
    Get
public:
property unsigned char WhoAmIValue {
    unsigned char get ();
}
member WhoAmIValue : byte with get

Property Value

Type: Byte
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l Methods

The Mma7455l type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.Flush Method

IRD

Mma7455lFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Mma7455l Class
telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeControl1Dfbw Enumeration

IRD

Mma7455lTypeControl1Dfbw Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Dfbw
Public Enumeration TypeControl1Dfbw
public enum class TypeControl1Dfbw
type TypeControl1Dfbw
Members
Member name | Value | Description
DigitalFilterBandWidth625Hz | 0 | Digital Filter Band Width: 62.5 Hz
DigitalFilterBandWidth125Hz | 1 | Digital Filter Band Width: 125 Hz
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeControl1Intpin Enumeration

IRD

Mma7455lTypeControl1Intpin Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Intpin
Public Enumeration TypeControl1Intpin
public enum class TypeControl1Intpin
type TypeControl1Intpin
Members
Member name | Value | Description
INT1PinINT1RegisterINT2PinINT2Register | 0 | INT1 Pin -> "INT1" Register / INT2 Pin -> "INT2" Register
INT2PinINT1RegisterINT1PinINT2Register | 1 | INT2 Pin -> "INT1" Register / INT1 Pin -> "INT2" Register
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeControl1Intreg Enumeration

IRD

Mma7455lTypeControl1Intreg Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Intreg
Public Enumeration TypeControl1Intreg
public enum class TypeControl1Intreg
type TypeControl1Intreg
Members
Member name | Value | Description
INT1LevelDetectionINT2PulseDetection | 0 | INT1: Level Detection / INT2: Pulse Detection
INT1PulseDetectionINT2LevelDetection | 1 | INT1: Pulse Detection / INT2: Level Detection
INT1SinglePulseDetectionINT2PulseDetection | 2 | INT1: Single Pulse Detection / INT2: Pulse Detection
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeControl1Thopt Enumeration

IRD

Mma7455lTypeControl1Thopt Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Thopt
Public Enumeration TypeControl1Thopt
public enum class TypeControl1Thopt
type TypeControl1Thopt
Members
Member name | Value | Description
ThresholdAbsolute | 0 | Threshold: Absolute
ThresholdPositiveNegative | 1 | Threshold: Positive/Negative
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeControl1Xda Enumeration

IRD

Mma7455lTypeControl1Xda Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Xda
Public Enumeration TypeControl1Xda
public enum class TypeControl1Xda
type TypeControl1Xda
Members
Member name | Value | Description
XAxisDetectionDisabled | 1 | X Axis Detection: Disabled
XAxisDetectionEnabled | 0 | X Axis Detection: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeControl1Yda Enumeration

IRD

Mma7455lTypeControl1Yda Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Yda
Public Enumeration TypeControl1Yda
public enum class TypeControl1Yda
type TypeControl1Yda
Members
Member name | Value | Description
YAxisDetectionDisabled | 1 | Y Axis Detection: Disabled
YAxisDetectionEnabled | 0 | Y Axis Detection: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeControl1Zda Enumeration

IRD

Mma7455lTypeControl1Zda Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Zda
Public Enumeration TypeControl1Zda
public enum class TypeControl1Zda
type TypeControl1Zda
Members
Member name | Value | Description
ZAxisDetectionDisabled | 1 | Z Axis Detection: Disabled
ZAxisDetectionEnabled | 0 | Z Axis Detection: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeControl2Drvo Enumeration

IRD

Mma7455lTypeControl2Drvo Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Drvo
Public Enumeration TypeControl2Drvo
public enum class TypeControl2Drvo
type TypeControl2Drvo
Members
Member name | Value | Description
SDASDOPinStandardDriveStrength | 0 | SDA/SDO Pin: Standard Drive Strength
SDASDOPinStrongDriveStrength | 1 | SDA/SDO Pin: Strong Drive Strength
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeControl2Ldpl Enumeration

IRD

Mma7455lTypeControl2Ldpl Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Ldpl
Public Enumeration TypeControl2Ldpl
public enum class TypeControl2Ldpl
type TypeControl2Ldpl
Members
Member name | Value | Description
LevelDetectionPolarityPositiveDetectingConditionOR3Axes | 0 | Level Detection Polarity: Positive / Detecting Condition: OR 3 Axes
LevelDetectionPolarityNegativeDetectingConditionAND3Axes | 1 | Level Detection Polarity: Negative / Detecting Condition: AND 3 Axes
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeControl2Pdpl Enumeration

IRD

Mma7455lTypeControl2Pdpl Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Pdpl
Public Enumeration TypeControl2Pdpl
public enum class TypeControl2Pdpl
type TypeControl2Pdpl
Members
Member name | Value | Description
PulseDetectionPolarityPositiveDetectingConditionOR3Axes | 0 | Pulse Detection Polarity: Positive / Detecting Condition: OR 3 Axes
PulseDetectionPolarityNegativeDetectingConditionAND3Axes | 1 | Pulse Detection Polarity: Negative / Detecting Condition: AND 3 Axes
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeDetectionInt Enumeration

IRD

Mma7455lTypeDetectionInt Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectionInt
Public Enumeration TypeDetectionInt
public enum class TypeDetectionInt
type TypeDetectionInt
Members
Member name | Value | Description
DetectionControlIRQDetected | 1 | "Detection Control" IRQ: Detected
DetectionControlIRQNotDetected | 0 | "Detection Control" IRQ: Not Detected
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeDetectionSourceLdx Enumeration

IRD

Mma7455lTypeDetectionSourceLdx Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectionSourceLdx
Public Enumeration TypeDetectionSourceLdx
public enum class TypeDetectionSourceLdx
type TypeDetectionSourceLdx
Members
Member name | Value | Description
LevelDetectionOnXAxisDetected | 1 | Level Detection On X Axis: Detected
LevelDetectionOnXAxisNotDetected | 0 | Level Detection On X Axis: Not Detected
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeDetectionSourceLdy Enumeration

IRD

Mma7455lTypeDetectionSourceLdy Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectionSourceLdy
Public Enumeration TypeDetectionSourceLdy
public enum class TypeDetectionSourceLdy
type TypeDetectionSourceLdy
Members
Member name | Value | Description
LevelDetectionOnYAxisDetected | 1 | Level Detection On Y Axis: Detected
LevelDetectionOnYAxisNotDetected | 0 | Level Detection On Y Axis: Not Detected
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeDetectionSourceLdz Enumeration

IRD

Mma7455lTypeDetectionSourceLdz Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectionSourceLdz
Public Enumeration TypeDetectionSourceLdz
public enum class TypeDetectionSourceLdz
type TypeDetectionSourceLdz
Members
Member name | Value | Description
LevelDetectionOnZAxisDetected | 1 | Level Detection On Z Axis: Detected
LevelDetectionOnZAxisNotDetected | 0 | Level Detection On Z Axis: Not Detected
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeDetectionSourcePdx Enumeration

IRD

Mma7455lTypeDetectionSourcePdx Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectionSourcePdx
Public Enumeration TypeDetectionSourcePdx
public enum class TypeDetectionSourcePdx
type TypeDetectionSourcePdx
Members
Member name | Value | Description
PulseIsDetectedOnXAxisAtSinglePulseDetection | 1 | Pulse Is Detected On X Axis At Single Pulse Detection
PulseIsNotDetectedOnXAxisAtSinglePulseDetection | 0 | Pulse Is Not Detected On X Axis At Single Pulse Detection
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeDetectionSourcePdy Enumeration

IRD

Mma7455lTypeDetectionSourcePdy Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectionSourcePdy
Public Enumeration TypeDetectionSourcePdy
public enum class TypeDetectionSourcePdy
type TypeDetectionSourcePdy
Members
Member name | Value | Description
PulseIsDetectedOnYAxisAtSinglePulseDetection | 1 | Pulse Is Detected On Y Axis At Single Pulse Detection
PulseIsNotDetectedOnYAxisAtSinglePulseDetection | 0 | Pulse Is Not Detected On Y Axis At Single Pulse Detection
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeDetectionSourcePdz Enumeration

IRD

Mma7455lTypeDetectionSourcePdz Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectionSourcePdz
Public Enumeration TypeDetectionSourcePdz
public enum class TypeDetectionSourcePdz
type TypeDetectionSourcePdz
Members
Member name | Value | Description
PulseIsDetectedOnZAxisAtSinglePulseDetection | 1 | Pulse Is Detected On Z Axis At Single Pulse Detection
PulseIsNotDetectedOnZAxisAtSinglePulseDetection | 0 | Pulse Is Not Detected On Z Axis At Single Pulse Detection
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeI2cDeviceAddressI2cdis Enumeration

IRD

Mma7455lTypeI2cDeviceAddressI2cdis Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeI2cDeviceAddressI2cdis
Public Enumeration TypeI2cDeviceAddressI2cdis
public enum class TypeI2cDeviceAddressI2cdis
type TypeI2cDeviceAddressI2cdis
Members
Member name | Value | Description
I2CAndSPIAvailable | 0 | I2C And SPI Available
I2CDisabled | 1 | I2C Disabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeInterruptLatchResetClrInt1 Enumeration

IRD

Mma7455lTypeInterruptLatchResetClrInt1 Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptLatchResetClrInt1
Public Enumeration TypeInterruptLatchResetClrInt1
public enum class TypeInterruptLatchResetClrInt1
type TypeInterruptLatchResetClrInt1
Members
Member name | Value | Description
ClearINT1AndLDXLDYLDZOrPDXPDYPDZ | 1 | Clear "INT1" and LDX/LDY/LDZ or PDX/PDY/PDZ
DoNotClearINT1AndLDXLDYLDZOrPDXPDYPDZ | 0 | Do Not Clear "INT1" and LDX/LDY/LDZ or PDX/PDY/PDZ
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeInterruptLatchResetClrInt2 Enumeration

IRD

Mma7455lTypeInterruptLatchResetClrInt2 Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptLatchResetClrInt2
Public Enumeration TypeInterruptLatchResetClrInt2
public enum class TypeInterruptLatchResetClrInt2
type TypeInterruptLatchResetClrInt2
Members
Member name | Value | Description
ClearINT2AndLDXLDYLDZOrPDXPDYPDZ | 1 | Clear "INT2" and LDX/LDY/LDZ or PDX/PDY/PDZ
DoNotClearINT1AndLDXLDYLDZOrPDXPDYPDZ | 0 | Do Not Clear "INT1" and LDX/LDY/LDZ or PDX/PDY/PDZ
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeModeControlDrpd Enumeration

IRD

Mma7455lTypeModeControlDrpd Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlDrpd
Public Enumeration TypeModeControlDrpd
public enum class TypeModeControlDrpd
type TypeModeControlDrpd
Members
Member name | Value | Description
DataReadyStatusToINT1DRDYPin | 0 | Data Ready Status: To INT1/DRDY Pin
DataReadyStatusNotToINT1DRDYPin | 1 | Data Ready Status: Not To INT1/DRDY Pin
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeModeControlGlvl Enumeration

IRD

Mma7455lTypeModeControlGlvl Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlGlvl
Public Enumeration TypeModeControlGlvl
public enum class TypeModeControlGlvl
type TypeModeControlGlvl
Members
Member name | Value | Description
Value_8g | 0 | 8g
Value_4g | 2 | 4g
Value_2g | 1 | 2g
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeModeControlMode Enumeration

IRD

Mma7455lTypeModeControlMode Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlMode
Public Enumeration TypeModeControlMode
public enum class TypeModeControlMode
type TypeModeControlMode
Members
Member name | Value | Description
Standby | 0 | Standby
Measurement | 1 | Measurement
LevelDetection | 2 | Level Detection
PulseDetection | 3 | Pulse Detection
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeModeControlSpi3w Enumeration

IRD

Mma7455lTypeModeControlSpi3w Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlSpi3w
Public Enumeration TypeModeControlSpi3w
public enum class TypeModeControlSpi3w
type TypeModeControlSpi3w
Members
Member name | Value | Description
SPIMode4Wire | 0 | SPI Mode: 4 Wire
SPIMode3Wire | 1 | SPI Mode: 3 Wire
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeModeControlSton Enumeration

IRD

Mma7455lTypeModeControlSton Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlSton
Public Enumeration TypeModeControlSton
public enum class TypeModeControlSton
type TypeModeControlSton
Members
Member name | Value | Description
SelfTestNotEnabled | 0 | Self Test: Not Enabled
SelfTestEnabled | 1 | Self Test: Enabled
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeStatusDovr Enumeration

IRD

Mma7455lTypeStatusDovr Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusDovr
Public Enumeration TypeStatusDovr
public enum class TypeStatusDovr
type TypeStatusDovr
Members
Member name | Value | Description
DataNotOverWritten | 0 | Data: Not Over Written
DataOverWritten | 1 | Data: Over Written
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeStatusDrdy Enumeration

IRD

Mma7455lTypeStatusDrdy Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusDrdy
Public Enumeration TypeStatusDrdy
public enum class TypeStatusDrdy
type TypeStatusDrdy
Members
Member name | Value | Description
DataNotReady | 0 | Data: Not Ready
DataReady | 1 | Data: Ready
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mma7455l.TypeStatusPerr Enumeration

IRD

Mma7455lTypeStatusPerr Enumeration

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusPerr
Public Enumeration TypeStatusPerr
public enum class TypeStatusPerr
type TypeStatusPerr
Members
Member name | Value | Description
ParityErrorInTrimDataNotDetected | 0 | Parity Error In Trim Data: Not Detected
ParityErrorInTrimDataDetected | 1 | Parity Error In Trim Data: Detected
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mpl115a2 Class

Freescale Semiconductor: MPL 115A2
Inheritance Hierarchy
SystemObject
telos.Ird.FreescaleSemiconductorMpl115a2

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Mpl115a2
Public Class Mpl115a2
public ref class Mpl115a2
type Mpl115a2 =  class end

The Mpl115a2 type exposes the following members.

Constructors
 | Name | Description
Public method | Mpl115a2 | Constructor
Top
Properties
 | Name | Description
Public property | A0Coefficient | a0 Coefficient
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | B1Coefficient | b1 Coefficient
Public property | B2Coefficient | b2 Coefficient
Public property | C12Coefficient | c12 Coefficient
Public property | Property_10BitPressureADCOutput | 10-Bit Pressure ADC Output
Public property | Property_10BitTemperatureADCOutput | 10-Bit Temperature ADC Output
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartPressureAndTemperatureConversion | Start Pressure And Temperature Conversion
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Miniature I2C Digital Barometer
See Also

Reference

telos.Ird.FreescaleSemiconductor Namespace


Mpl115a2 Constructor

Constructor

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Mpl115a2(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Mpl115a2(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Mpl115a2

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Mpl115a2 Class
telos.Ird.FreescaleSemiconductor Namespace


Mpl115a2 Properties

The Mpl115a2 type exposes the following members.

Properties
 | Name | Description
Public property | A0Coefficient | a0 Coefficient
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | B1Coefficient | b1 Coefficient
Public property | B2Coefficient | b2 Coefficient
Public property | C12Coefficient | c12 Coefficient
Public property | Property_10BitPressureADCOutput | 10-Bit Pressure ADC Output
Public property | Property_10BitTemperatureADCOutput | 10-Bit Temperature ADC Output
Top
See Also

Reference

Mpl115a2 Class
telos.Ird.FreescaleSemiconductor Namespace


Mpl115a2.A0Coefficient Property

IRD

Mpl115a2A0Coefficient Property

a0 Coefficient

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double A0Coefficient { get; }
Public ReadOnly Property A0Coefficient As Double
    Get
public:
property double A0Coefficient {
    double get ();
}
member A0Coefficient : float with get

Property Value

Type: Double
See Also

Reference

Mpl115a2 Class
telos.Ird.FreescaleSemiconductor Namespace


Mpl115a2.AutoFlush Property

IRD

Mpl115a2AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Mpl115a2 Class
telos.Ird.FreescaleSemiconductor Namespace


Mpl115a2.B1Coefficient Property

IRD

Mpl115a2B1Coefficient Property

b1 Coefficient

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double B1Coefficient { get; }
Public ReadOnly Property B1Coefficient As Double
    Get
public:
property double B1Coefficient {
    double get ();
}
member B1Coefficient : float with get

Property Value

Type: Double
See Also

Reference

Mpl115a2 Class
telos.Ird.FreescaleSemiconductor Namespace


Mpl115a2.B2Coefficient Property

IRD

Mpl115a2B2Coefficient Property

b2 Coefficient

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double B2Coefficient { get; }
Public ReadOnly Property B2Coefficient As Double
    Get
public:
property double B2Coefficient {
    double get ();
}
member B2Coefficient : float with get

Property Value

Type: Double
See Also

Reference

Mpl115a2 Class
telos.Ird.FreescaleSemiconductor Namespace


Mpl115a2.C12Coefficient Property

IRD

Mpl115a2C12Coefficient Property

c12 Coefficient

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double C12Coefficient { get; }
Public ReadOnly Property C12Coefficient As Double
    Get
public:
property double C12Coefficient {
    double get ();
}
member C12Coefficient : float with get

Property Value

Type: Double
See Also

Reference

Mpl115a2 Class
telos.Ird.FreescaleSemiconductor Namespace


Mpl115a2.Property_10BitPressureADCOutput Property

IRD

Mpl115a2Property_10BitPressureADCOutput Property

10-Bit Pressure ADC Output

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort Property_10BitPressureADCOutput { get; }
Public ReadOnly Property Property_10BitPressureADCOutput As UShort
    Get
public:
property unsigned short Property_10BitPressureADCOutput {
    unsigned short get ();
}
member Property_10BitPressureADCOutput : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Mpl115a2 Class
telos.Ird.FreescaleSemiconductor Namespace


Mpl115a2.Property_10BitTemperatureADCOutput Property

IRD

Mpl115a2Property_10BitTemperatureADCOutput Property

10-Bit Temperature ADC Output

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort Property_10BitTemperatureADCOutput { get; }
Public ReadOnly Property Property_10BitTemperatureADCOutput As UShort
    Get
public:
property unsigned short Property_10BitTemperatureADCOutput {
    unsigned short get ();
}
member Property_10BitTemperatureADCOutput : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Mpl115a2 Class
telos.Ird.FreescaleSemiconductor Namespace


Mpl115a2 Methods

The Mpl115a2 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartPressureAndTemperatureConversion | Start Pressure And Temperature Conversion
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Mpl115a2 Class
telos.Ird.FreescaleSemiconductor Namespace


Mpl115a2.Flush Method

IRD

Mpl115a2Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Mpl115a2 Class
telos.Ird.FreescaleSemiconductor Namespace


Mpl115a2.StartPressureAndTemperatureConversion Method

IRD

Mpl115a2StartPressureAndTemperatureConversion Method

Start Pressure And Temperature Conversion

Namespace: telos.Ird.FreescaleSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void StartPressureAndTemperatureConversion()
Public Sub StartPressureAndTemperatureConversion
public:
void StartPressureAndTemperatureConversion()
member StartPressureAndTemperatureConversion : unit -> unit
See Also

Reference

Mpl115a2 Class
telos.Ird.FreescaleSemiconductor Namespace


telos.Ird.JEDEC Namespace

Classes
 | Class | Description
Public class | No21cPage47 | JEDEC: No. 21-C Page 4.7
Enumerations
 | Enumeration | Description
Public enumeration | No21cPage47TypeCapabilityAccuracy |
Public enumeration | No21cPage47TypeCapabilityBasicCapability |
Public enumeration | No21cPage47TypeCapabilityTemperatureResolution |
Public enumeration | No21cPage47TypeCapabilityWiderRange |
Public enumeration | No21cPage47TypeConfigurationAlarmWindowLockBit |
Public enumeration | No21cPage47TypeConfigurationClearEvent |
Public enumeration | No21cPage47TypeConfigurationCriticalEventOnly |
Public enumeration | No21cPage47TypeConfigurationCriticalTripLockBit |
Public enumeration | No21cPage47TypeConfigurationEventMode |
Public enumeration | No21cPage47TypeConfigurationEventOutputControl |
Public enumeration | No21cPage47TypeConfigurationEventPolarity |
Public enumeration | No21cPage47TypeConfigurationEventStatus |
Public enumeration | No21cPage47TypeConfigurationHysteresisEnable |
Public enumeration | No21cPage47TypeConfigurationShutdownMode |
Public enumeration | No21cPage47TypeTemperatureAboveAlarmWindow |
Public enumeration | No21cPage47TypeTemperatureAboveCriticalTrip |
Public enumeration | No21cPage47TypeTemperatureBelowAlarmWindow |


No21cPage47 Class

JEDEC: No. 21-C Page 4.7
Inheritance Hierarchy
SystemObject
telos.Ird.JEDECNo21cPage47

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class No21cPage47
Public Class No21cPage47
public ref class No21cPage47
type No21cPage47 =  class end

The No21cPage47 type exposes the following members.

Constructors
 | Name | Description
Public method | No21cPage47 | Constructor
Top
Properties
 | Name | Description
Public property | AlarmTemperatureLowerBoundaryTrip | Alarm Temperature Lower Boundary Trip (unit: °C)
Public property | AlarmTemperatureUpperBoundaryTrip | Alarm Temperature Upper Boundary Trip (unit: °C)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CapabilityAccuracy | Capability (Accuracy)
Public property | CapabilityBasicCapability | Capability (Basic Capability)
Public property | CapabilityTemperatureResolution | Capability (Temperature Resolution) (unit: °C)
Public property | CapabilityWiderRange | Capability (Wider Range)
Public property | ConfigurationAlarmWindowLockBit | Configuration (Alarm Window Lock Bit)
Public property | ConfigurationClearEvent | Configuration (Clear Event)
Public property | ConfigurationCriticalEventOnly | Configuration (Critical Event Only)
Public property | ConfigurationCriticalTripLockBit | Configuration (Critical Trip Lock bit)
Public property | ConfigurationEnabledHysteresis | Configuration (Enabled Hysteresis)
Public property | ConfigurationEventMode | Configuration (Event Mode)
Public property | ConfigurationEventOutputControl | Configuration (Event Output Control)
Public property | ConfigurationEventPolarity | Configuration (Event Polarity)
Public property | ConfigurationEventStatus | Configuration (Event Status)
Public property | ConfigurationShutdownMode | Configuration (Shutdown Mode)
Public property | CriticalTemperature | Critical Temperature (unit: °C)
Public property | DeviceID | Device ID
Public property | DeviceRevision | Device Revision
Public property | ManufacturerID | Manufacturer ID
Public property | Temperature | Temperature (unit: °C)
Public property | TemperatureAboveAlarmWindow | Temperature (Above Alarm Window)
Public property | TemperatureAboveCriticalTrip | Temperature (Above Critical Trip)
Public property | TemperatureBelowAlarmWindow | Temperature (Below Alarm Window)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Mobile Platform Memory Module Thermal Sensor Component (Release 15)
See Also

Reference

telos.Ird.JEDEC Namespace


No21cPage47 Constructor

Constructor

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public No21cPage47(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
No21cPage47(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> No21cPage47

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47 Properties

The No21cPage47 type exposes the following members.

Properties
 | Name | Description
Public property | AlarmTemperatureLowerBoundaryTrip | Alarm Temperature Lower Boundary Trip (unit: °C)
Public property | AlarmTemperatureUpperBoundaryTrip | Alarm Temperature Upper Boundary Trip (unit: °C)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CapabilityAccuracy | Capability (Accuracy)
Public property | CapabilityBasicCapability | Capability (Basic Capability)
Public property | CapabilityTemperatureResolution | Capability (Temperature Resolution) (unit: °C)
Public property | CapabilityWiderRange | Capability (Wider Range)
Public property | ConfigurationAlarmWindowLockBit | Configuration (Alarm Window Lock Bit)
Public property | ConfigurationClearEvent | Configuration (Clear Event)
Public property | ConfigurationCriticalEventOnly | Configuration (Critical Event Only)
Public property | ConfigurationCriticalTripLockBit | Configuration (Critical Trip Lock bit)
Public property | ConfigurationEnabledHysteresis | Configuration (Enabled Hysteresis)
Public property | ConfigurationEventMode | Configuration (Event Mode)
Public property | ConfigurationEventOutputControl | Configuration (Event Output Control)
Public property | ConfigurationEventPolarity | Configuration (Event Polarity)
Public property | ConfigurationEventStatus | Configuration (Event Status)
Public property | ConfigurationShutdownMode | Configuration (Shutdown Mode)
Public property | CriticalTemperature | Critical Temperature (unit: °C)
Public property | DeviceID | Device ID
Public property | DeviceRevision | Device Revision
Public property | ManufacturerID | Manufacturer ID
Public property | Temperature | Temperature (unit: °C)
Public property | TemperatureAboveAlarmWindow | Temperature (Above Alarm Window)
Public property | TemperatureAboveCriticalTrip | Temperature (Above Critical Trip)
Public property | TemperatureBelowAlarmWindow | Temperature (Below Alarm Window)
Top
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.AlarmTemperatureLowerBoundaryTrip Property

IRD

No21cPage47AlarmTemperatureLowerBoundaryTrip Property

Alarm Temperature Lower Boundary Trip (unit: °C)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AlarmTemperatureLowerBoundaryTrip { get; set; }
Public Property AlarmTemperatureLowerBoundaryTrip As Double
    Get
    Set
public:
property double AlarmTemperatureLowerBoundaryTrip {
    double get ();
    void set (double value);
}
member AlarmTemperatureLowerBoundaryTrip : float with get, set

Property Value

Type: Double
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.AlarmTemperatureUpperBoundaryTrip Property

IRD

No21cPage47AlarmTemperatureUpperBoundaryTrip Property

Alarm Temperature Upper Boundary Trip (unit: °C)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AlarmTemperatureUpperBoundaryTrip { get; set; }
Public Property AlarmTemperatureUpperBoundaryTrip As Double
    Get
    Set
public:
property double AlarmTemperatureUpperBoundaryTrip {
    double get ();
    void set (double value);
}
member AlarmTemperatureUpperBoundaryTrip : float with get, set

Property Value

Type: Double
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.AutoFlush Property

IRD

No21cPage47AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.CapabilityAccuracy Property

IRD

No21cPage47CapabilityAccuracy Property

Capability (Accuracy)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public No21cPage47TypeCapabilityAccuracy CapabilityAccuracy { get; }
Public ReadOnly Property CapabilityAccuracy As No21cPage47TypeCapabilityAccuracy
    Get
public:
property No21cPage47TypeCapabilityAccuracy CapabilityAccuracy {
    No21cPage47TypeCapabilityAccuracy get ();
}
member CapabilityAccuracy : No21cPage47TypeCapabilityAccuracy with get

Property Value

Type: No21cPage47TypeCapabilityAccuracy
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.CapabilityBasicCapability Property

IRD

No21cPage47CapabilityBasicCapability Property

Capability (Basic Capability)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public No21cPage47TypeCapabilityBasicCapability CapabilityBasicCapability { get; }
Public ReadOnly Property CapabilityBasicCapability As No21cPage47TypeCapabilityBasicCapability
    Get
public:
property No21cPage47TypeCapabilityBasicCapability CapabilityBasicCapability {
    No21cPage47TypeCapabilityBasicCapability get ();
}
member CapabilityBasicCapability : No21cPage47TypeCapabilityBasicCapability with get

Property Value

Type: No21cPage47TypeCapabilityBasicCapability
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.CapabilityTemperatureResolution Property

IRD

No21cPage47CapabilityTemperatureResolution Property

Capability (Temperature Resolution) (unit: °C)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public No21cPage47TypeCapabilityTemperatureResolution CapabilityTemperatureResolution { get; }
Public ReadOnly Property CapabilityTemperatureResolution As No21cPage47TypeCapabilityTemperatureResolution
    Get
public:
property No21cPage47TypeCapabilityTemperatureResolution CapabilityTemperatureResolution {
    No21cPage47TypeCapabilityTemperatureResolution get ();
}
member CapabilityTemperatureResolution : No21cPage47TypeCapabilityTemperatureResolution with get

Property Value

Type: No21cPage47TypeCapabilityTemperatureResolution
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.CapabilityWiderRange Property

IRD

No21cPage47CapabilityWiderRange Property

Capability (Wider Range)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public No21cPage47TypeCapabilityWiderRange CapabilityWiderRange { get; }
Public ReadOnly Property CapabilityWiderRange As No21cPage47TypeCapabilityWiderRange
    Get
public:
property No21cPage47TypeCapabilityWiderRange CapabilityWiderRange {
    No21cPage47TypeCapabilityWiderRange get ();
}
member CapabilityWiderRange : No21cPage47TypeCapabilityWiderRange with get

Property Value

Type: No21cPage47TypeCapabilityWiderRange
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.ConfigurationAlarmWindowLockBit Property

IRD

No21cPage47ConfigurationAlarmWindowLockBit Property

Configuration (Alarm Window Lock Bit)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public No21cPage47TypeConfigurationAlarmWindowLockBit ConfigurationAlarmWindowLockBit { get; set; }
Public Property ConfigurationAlarmWindowLockBit As No21cPage47TypeConfigurationAlarmWindowLockBit
    Get
    Set
public:
property No21cPage47TypeConfigurationAlarmWindowLockBit ConfigurationAlarmWindowLockBit {
    No21cPage47TypeConfigurationAlarmWindowLockBit get ();
    void set (No21cPage47TypeConfigurationAlarmWindowLockBit value);
}
member ConfigurationAlarmWindowLockBit : No21cPage47TypeConfigurationAlarmWindowLockBit with get, set

Property Value

Type: No21cPage47TypeConfigurationAlarmWindowLockBit
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.ConfigurationClearEvent Property

IRD

No21cPage47ConfigurationClearEvent Property

Configuration (Clear Event)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public No21cPage47TypeConfigurationClearEvent ConfigurationClearEvent { set; }
Public WriteOnly Property ConfigurationClearEvent As No21cPage47TypeConfigurationClearEvent
    Set
public:
property No21cPage47TypeConfigurationClearEvent ConfigurationClearEvent {
    void set (No21cPage47TypeConfigurationClearEvent value);
}
member ConfigurationClearEvent : No21cPage47TypeConfigurationClearEvent with set

Property Value

Type: No21cPage47TypeConfigurationClearEvent
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.ConfigurationCriticalEventOnly Property

IRD

No21cPage47ConfigurationCriticalEventOnly Property

Configuration (Critical Event Only)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public No21cPage47TypeConfigurationCriticalEventOnly ConfigurationCriticalEventOnly { get; set; }
Public Property ConfigurationCriticalEventOnly As No21cPage47TypeConfigurationCriticalEventOnly
    Get
    Set
public:
property No21cPage47TypeConfigurationCriticalEventOnly ConfigurationCriticalEventOnly {
    No21cPage47TypeConfigurationCriticalEventOnly get ();
    void set (No21cPage47TypeConfigurationCriticalEventOnly value);
}
member ConfigurationCriticalEventOnly : No21cPage47TypeConfigurationCriticalEventOnly with get, set

Property Value

Type: No21cPage47TypeConfigurationCriticalEventOnly
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.ConfigurationCriticalTripLockBit Property

IRD

No21cPage47ConfigurationCriticalTripLockBit Property

Configuration (Critical Trip Lock bit)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public No21cPage47TypeConfigurationCriticalTripLockBit ConfigurationCriticalTripLockBit { get; set; }
Public Property ConfigurationCriticalTripLockBit As No21cPage47TypeConfigurationCriticalTripLockBit
    Get
    Set
public:
property No21cPage47TypeConfigurationCriticalTripLockBit ConfigurationCriticalTripLockBit {
    No21cPage47TypeConfigurationCriticalTripLockBit get ();
    void set (No21cPage47TypeConfigurationCriticalTripLockBit value);
}
member ConfigurationCriticalTripLockBit : No21cPage47TypeConfigurationCriticalTripLockBit with get, set

Property Value

Type: No21cPage47TypeConfigurationCriticalTripLockBit
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.ConfigurationEnabledHysteresis Property

IRD

No21cPage47ConfigurationEnabledHysteresis Property

Configuration (Enabled Hysteresis)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public No21cPage47TypeConfigurationHysteresisEnable ConfigurationEnabledHysteresis { get; set; }
Public Property ConfigurationEnabledHysteresis As No21cPage47TypeConfigurationHysteresisEnable
    Get
    Set
public:
property No21cPage47TypeConfigurationHysteresisEnable ConfigurationEnabledHysteresis {
    No21cPage47TypeConfigurationHysteresisEnable get ();
    void set (No21cPage47TypeConfigurationHysteresisEnable value);
}
member ConfigurationEnabledHysteresis : No21cPage47TypeConfigurationHysteresisEnable with get, set

Property Value

Type: No21cPage47TypeConfigurationHysteresisEnable
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.ConfigurationEventMode Property

IRD

No21cPage47ConfigurationEventMode Property

Configuration (Event Mode)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public No21cPage47TypeConfigurationEventMode ConfigurationEventMode { get; set; }
Public Property ConfigurationEventMode As No21cPage47TypeConfigurationEventMode
    Get
    Set
public:
property No21cPage47TypeConfigurationEventMode ConfigurationEventMode {
    No21cPage47TypeConfigurationEventMode get ();
    void set (No21cPage47TypeConfigurationEventMode value);
}
member ConfigurationEventMode : No21cPage47TypeConfigurationEventMode with get, set

Property Value

Type: No21cPage47TypeConfigurationEventMode
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.ConfigurationEventOutputControl Property

IRD

No21cPage47ConfigurationEventOutputControl Property

Configuration (Event Output Control)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public No21cPage47TypeConfigurationEventOutputControl ConfigurationEventOutputControl { get; set; }
Public Property ConfigurationEventOutputControl As No21cPage47TypeConfigurationEventOutputControl
    Get
    Set
public:
property No21cPage47TypeConfigurationEventOutputControl ConfigurationEventOutputControl {
    No21cPage47TypeConfigurationEventOutputControl get ();
    void set (No21cPage47TypeConfigurationEventOutputControl value);
}
member ConfigurationEventOutputControl : No21cPage47TypeConfigurationEventOutputControl with get, set

Property Value

Type: No21cPage47TypeConfigurationEventOutputControl
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.ConfigurationEventPolarity Property

IRD

No21cPage47ConfigurationEventPolarity Property

Configuration (Event Polarity)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public No21cPage47TypeConfigurationEventPolarity ConfigurationEventPolarity { get; set; }
Public Property ConfigurationEventPolarity As No21cPage47TypeConfigurationEventPolarity
    Get
    Set
public:
property No21cPage47TypeConfigurationEventPolarity ConfigurationEventPolarity {
    No21cPage47TypeConfigurationEventPolarity get ();
    void set (No21cPage47TypeConfigurationEventPolarity value);
}
member ConfigurationEventPolarity : No21cPage47TypeConfigurationEventPolarity with get, set

Property Value

Type: No21cPage47TypeConfigurationEventPolarity
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.ConfigurationEventStatus Property

IRD

No21cPage47ConfigurationEventStatus Property

Configuration (Event Status)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public No21cPage47TypeConfigurationEventStatus ConfigurationEventStatus { get; }
Public ReadOnly Property ConfigurationEventStatus As No21cPage47TypeConfigurationEventStatus
    Get
public:
property No21cPage47TypeConfigurationEventStatus ConfigurationEventStatus {
    No21cPage47TypeConfigurationEventStatus get ();
}
member ConfigurationEventStatus : No21cPage47TypeConfigurationEventStatus with get

Property Value

Type: No21cPage47TypeConfigurationEventStatus
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.ConfigurationShutdownMode Property

IRD

No21cPage47ConfigurationShutdownMode Property

Configuration (Shutdown Mode)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public No21cPage47TypeConfigurationShutdownMode ConfigurationShutdownMode { get; set; }
Public Property ConfigurationShutdownMode As No21cPage47TypeConfigurationShutdownMode
    Get
    Set
public:
property No21cPage47TypeConfigurationShutdownMode ConfigurationShutdownMode {
    No21cPage47TypeConfigurationShutdownMode get ();
    void set (No21cPage47TypeConfigurationShutdownMode value);
}
member ConfigurationShutdownMode : No21cPage47TypeConfigurationShutdownMode with get, set

Property Value

Type: No21cPage47TypeConfigurationShutdownMode
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.CriticalTemperature Property

IRD

No21cPage47CriticalTemperature Property

Critical Temperature (unit: °C)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CriticalTemperature { get; set; }
Public Property CriticalTemperature As Double
    Get
    Set
public:
property double CriticalTemperature {
    double get ();
    void set (double value);
}
member CriticalTemperature : float with get, set

Property Value

Type: Double
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.DeviceID Property

IRD

No21cPage47DeviceID Property

Device ID

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.DeviceRevision Property

IRD

No21cPage47DeviceRevision Property

Device Revision

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceRevision { get; }
Public ReadOnly Property DeviceRevision As Byte
    Get
public:
property unsigned char DeviceRevision {
    unsigned char get ();
}
member DeviceRevision : byte with get

Property Value

Type: Byte
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.ManufacturerID Property

IRD

No21cPage47ManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As UShort
    Get
public:
property unsigned short ManufacturerID {
    unsigned short get ();
}
member ManufacturerID : uint16 with get

Property Value

Type: UInt16
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.Temperature Property

IRD

No21cPage47Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.TemperatureAboveAlarmWindow Property

IRD

No21cPage47TemperatureAboveAlarmWindow Property

Temperature (Above Alarm Window)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public No21cPage47TypeTemperatureAboveAlarmWindow TemperatureAboveAlarmWindow { get; }
Public ReadOnly Property TemperatureAboveAlarmWindow As No21cPage47TypeTemperatureAboveAlarmWindow
    Get
public:
property No21cPage47TypeTemperatureAboveAlarmWindow TemperatureAboveAlarmWindow {
    No21cPage47TypeTemperatureAboveAlarmWindow get ();
}
member TemperatureAboveAlarmWindow : No21cPage47TypeTemperatureAboveAlarmWindow with get

Property Value

Type: No21cPage47TypeTemperatureAboveAlarmWindow
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.TemperatureAboveCriticalTrip Property

IRD

No21cPage47TemperatureAboveCriticalTrip Property

Temperature (Above Critical Trip)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public No21cPage47TypeTemperatureAboveCriticalTrip TemperatureAboveCriticalTrip { get; }
Public ReadOnly Property TemperatureAboveCriticalTrip As No21cPage47TypeTemperatureAboveCriticalTrip
    Get
public:
property No21cPage47TypeTemperatureAboveCriticalTrip TemperatureAboveCriticalTrip {
    No21cPage47TypeTemperatureAboveCriticalTrip get ();
}
member TemperatureAboveCriticalTrip : No21cPage47TypeTemperatureAboveCriticalTrip with get

Property Value

Type: No21cPage47TypeTemperatureAboveCriticalTrip
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.TemperatureBelowAlarmWindow Property

IRD

No21cPage47TemperatureBelowAlarmWindow Property

Temperature (Below Alarm Window)

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public No21cPage47TypeTemperatureBelowAlarmWindow TemperatureBelowAlarmWindow { get; }
Public ReadOnly Property TemperatureBelowAlarmWindow As No21cPage47TypeTemperatureBelowAlarmWindow
    Get
public:
property No21cPage47TypeTemperatureBelowAlarmWindow TemperatureBelowAlarmWindow {
    No21cPage47TypeTemperatureBelowAlarmWindow get ();
}
member TemperatureBelowAlarmWindow : No21cPage47TypeTemperatureBelowAlarmWindow with get

Property Value

Type: No21cPage47TypeTemperatureBelowAlarmWindow
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47 Methods

The No21cPage47 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.Flush Method

IRD

No21cPage47Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

No21cPage47 Class
telos.Ird.JEDEC Namespace


No21cPage47.TypeCapabilityAccuracy Enumeration

IRD

No21cPage47TypeCapabilityAccuracy Enumeration

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityAccuracy
Public Enumeration TypeCapabilityAccuracy
public enum class TypeCapabilityAccuracy
type TypeCapabilityAccuracy
Members
Member name | Value | Description
DefaultAccuracy2COverTheActiveAnd3CMonitorRanges | 0 | Default, accuracy ±2 °C over the active and ±3 °C monitor ranges
HighAccuracy1COverTheActiveAnd2CMonitorRanges | 1 | High accuracy ±1 °C over the active and ±2 °C monitor ranges
See Also

Reference

telos.Ird.JEDEC Namespace


No21cPage47.TypeCapabilityBasicCapability Enumeration

IRD

No21cPage47TypeCapabilityBasicCapability Enumeration

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityBasicCapability
Public Enumeration TypeCapabilityBasicCapability
public enum class TypeCapabilityBasicCapability
type TypeCapabilityBasicCapability
Members
Member name | Value | Description
HasAlarmCriticalTripsCapability | 1 | Has Alarm & Critical trips capability
See Also

Reference

telos.Ird.JEDEC Namespace


No21cPage47.TypeCapabilityTemperatureResolution Enumeration

IRD

No21cPage47TypeCapabilityTemperatureResolution Enumeration

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityTemperatureResolution
Public Enumeration TypeCapabilityTemperatureResolution
public enum class TypeCapabilityTemperatureResolution
type TypeCapabilityTemperatureResolution
Members
Member name | Value | Description
Value_0_5 | 0 | 0.5
Value_0_25 | 1 | 0.25
Value_0_125 | 2 | 0.125
Value_0_0625 | 3 | 0.0625
See Also

Reference

telos.Ird.JEDEC Namespace


No21cPage47.TypeCapabilityWiderRange Enumeration

IRD

No21cPage47TypeCapabilityWiderRange Enumeration

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityWiderRange
Public Enumeration TypeCapabilityWiderRange
public enum class TypeCapabilityWiderRange
type TypeCapabilityWiderRange
Members
Member name | Value | Description
ValuesLowerThan0CWillBeClampedAndRepresentedAsBinaryValue0 | 0 | Values lower than 0 °C will be clamped and represented as binary value 0
CanReadTemperaturesBelow0CAndSetSignBitAccordingly | 1 | Can read temperatures below 0 °C and set sign bit accordingly
See Also

Reference

telos.Ird.JEDEC Namespace


No21cPage47.TypeConfigurationAlarmWindowLockBit Enumeration

IRD

No21cPage47TypeConfigurationAlarmWindowLockBit Enumeration

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationAlarmWindowLockBit
Public Enumeration TypeConfigurationAlarmWindowLockBit
public enum class TypeConfigurationAlarmWindowLockBit
type TypeConfigurationAlarmWindowLockBit
Members
Member name | Value | Description
AlarmTripsNotLockedCanBeAltered | 0 | Alarm trips: not locked / can be altered
AlarmTripsLockedCannotBeAltered | 1 | Alarm trips: locked / cannot be altered
See Also

Reference

telos.Ird.JEDEC Namespace


No21cPage47.TypeConfigurationClearEvent Enumeration

IRD

No21cPage47TypeConfigurationClearEvent Enumeration

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationClearEvent
Public Enumeration TypeConfigurationClearEvent
public enum class TypeConfigurationClearEvent
type TypeConfigurationClearEvent
Members
Member name | Value | Description
NoEffect | 0 | No effect
ClearsActiveEventInInterruptMode | 1 | Clears active event in Interrupt Mode.
See Also

Reference

telos.Ird.JEDEC Namespace


No21cPage47.TypeConfigurationCriticalEventOnly Enumeration

IRD

No21cPage47TypeConfigurationCriticalEventOnly Enumeration

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationCriticalEventOnly
Public Enumeration TypeConfigurationCriticalEventOnly
public enum class TypeConfigurationCriticalEventOnly
type TypeConfigurationCriticalEventOnly
Members
Member name | Value | Description
EventOutputOnAlarmOrCriticalTemperatureEvent | 0 | Event output: on Alarm or Critical Temperature event
EventOutputOnCriticalTemperatureEvent | 1 | Event output: on Critical Temperature event
See Also

Reference

telos.Ird.JEDEC Namespace


No21cPage47.TypeConfigurationCriticalTripLockBit Enumeration

IRD

No21cPage47TypeConfigurationCriticalTripLockBit Enumeration

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationCriticalTripLockBit
Public Enumeration TypeConfigurationCriticalTripLockBit
public enum class TypeConfigurationCriticalTripLockBit
type TypeConfigurationCriticalTripLockBit
Members
Member name | Value | Description
CriticalTripNotLockedCanBeAltered | 0 | Critical Trip: not locked / can be altered
CriticalTripLockedCannotBeAltered | 1 | Critical Trip: locked / cannot be altered
See Also

Reference

telos.Ird.JEDEC Namespace


No21cPage47.TypeConfigurationEventMode Enumeration

IRD

No21cPage47TypeConfigurationEventMode Enumeration

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationEventMode
Public Enumeration TypeConfigurationEventMode
public enum class TypeConfigurationEventMode
type TypeConfigurationEventMode
Members
Member name | Value | Description
ComparatorMode | 0 | Comparator mode
InterruptMode | 1 | Interrupt mode
See Also

Reference

telos.Ird.JEDEC Namespace


No21cPage47.TypeConfigurationEventOutputControl Enumeration

IRD

No21cPage47TypeConfigurationEventOutputControl Enumeration

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationEventOutputControl
Public Enumeration TypeConfigurationEventOutputControl
public enum class TypeConfigurationEventOutputControl
type TypeConfigurationEventOutputControl
Members
Member name | Value | Description
EventOutputDisabled | 0 | Event Output: disabled
EventOutputEnabled | 1 | Event Output: enabled
See Also

Reference

telos.Ird.JEDEC Namespace


No21cPage47.TypeConfigurationEventPolarity Enumeration

IRD

No21cPage47TypeConfigurationEventPolarity Enumeration

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationEventPolarity
Public Enumeration TypeConfigurationEventPolarity
public enum class TypeConfigurationEventPolarity
type TypeConfigurationEventPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.JEDEC Namespace


No21cPage47.TypeConfigurationEventStatus Enumeration

IRD

No21cPage47TypeConfigurationEventStatus Enumeration

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationEventStatus
Public Enumeration TypeConfigurationEventStatus
public enum class TypeConfigurationEventStatus
type TypeConfigurationEventStatus
Members
Member name | Value | Description
EventOutputNotAsserted | 0 | Event Output: not asserted
EventOutputByAlarmWindowOrCriticalTripCondition | 1 | Event Output: by Alarm Window or Critical Trip condition
See Also

Reference

telos.Ird.JEDEC Namespace


No21cPage47.TypeConfigurationHysteresisEnable Enumeration

IRD

No21cPage47TypeConfigurationHysteresisEnable Enumeration

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationHysteresisEnable
Public Enumeration TypeConfigurationHysteresisEnable
public enum class TypeConfigurationHysteresisEnable
type TypeConfigurationHysteresisEnable
Members
Member name | Value | Description
DisableHysteresis | 0 | Disable Hysteresis
EnableHysteresisAt15C | 1 | Enable Hysteresis at 1.5 °C
EnableHysteresisAt3C | 2 | Enable Hysteresis at 3 °C
EnableHysteresisAt6C | 3 | Enable Hysteresis at 6 °C
See Also

Reference

telos.Ird.JEDEC Namespace


No21cPage47.TypeConfigurationShutdownMode Enumeration

IRD

No21cPage47TypeConfigurationShutdownMode Enumeration

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationShutdownMode
Public Enumeration TypeConfigurationShutdownMode
public enum class TypeConfigurationShutdownMode
type TypeConfigurationShutdownMode
Members
Member name | Value | Description
EnabledTS | 0 | Enabled TS
ShutdownTS | 1 | Shutdown TS
See Also

Reference

telos.Ird.JEDEC Namespace


No21cPage47.TypeTemperatureAboveAlarmWindow Enumeration

IRD

No21cPage47TypeTemperatureAboveAlarmWindow Enumeration

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTemperatureAboveAlarmWindow
Public Enumeration TypeTemperatureAboveAlarmWindow
public enum class TypeTemperatureAboveAlarmWindow
type TypeTemperatureAboveAlarmWindow
Members
Member name | Value | Description
TemperatureAlarmTemperatureUpperBoundaryTrip | 0 | Temperature <= Alarm Temperature Upper Boundary Trip
TemperatureAlarmTemperatureUpperBoundaryTrip__1 | 1 | Temperature > Alarm Temperature Upper Boundary Trip
See Also

Reference

telos.Ird.JEDEC Namespace


No21cPage47.TypeTemperatureAboveCriticalTrip Enumeration

IRD

No21cPage47TypeTemperatureAboveCriticalTrip Enumeration

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTemperatureAboveCriticalTrip
Public Enumeration TypeTemperatureAboveCriticalTrip
public enum class TypeTemperatureAboveCriticalTrip
type TypeTemperatureAboveCriticalTrip
Members
Member name | Value | Description
TemperatureCriticalTemperature | 0 | Temperature < Critical Temperature
TemperatureCriticalTemperature__1 | 1 | Temperature >= Critical Temperature
See Also

Reference

telos.Ird.JEDEC Namespace


No21cPage47.TypeTemperatureBelowAlarmWindow Enumeration

IRD

No21cPage47TypeTemperatureBelowAlarmWindow Enumeration

Namespace: telos.Ird.JEDEC
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTemperatureBelowAlarmWindow
Public Enumeration TypeTemperatureBelowAlarmWindow
public enum class TypeTemperatureBelowAlarmWindow
type TypeTemperatureBelowAlarmWindow
Members
Member name | Value | Description
TemperatureAlarmTemperatureLowerBoundaryTrip | 0 | Temperature >= Alarm Temperature Lower Boundary Trip
TemperatureAlarmTemperatureLowerBoundaryTrip__1 | 1 | Temperature < Alarm Temperature Lower Boundary Trip
See Also

Reference

telos.Ird.JEDEC Namespace


telos.Ird.LinearTechnology Namespace

Classes
 | Class | Description
Public class | Ltc263710 | Linear Technology: LTC 2637-10
Public class | Ltc263712 | Linear Technology: LTC 2637-12
Public class | Ltc26378 | Linear Technology: LTC 2637-8
Public class | Ltc3447 | Linear Technology: LTC 3447
Public class | Ltc4151 | Linear Technology: LTC 4151
Enumerations
 | Enumeration | Description
Public enumeration | Ltc3447IDEnableDisable |
Public enumeration | Ltc3447TYPIDDATA0 |
Public enumeration | Ltc3447TYPIDDATA2 |
Public enumeration | Ltc4151TypeAdinAdcBusy |
Public enumeration | Ltc4151TypeControlAdcChannelLabelForSnapshotMode |
Public enumeration | Ltc4151TypeControlAdcSnapshotModeEnabled |
Public enumeration | Ltc4151TypeControlPageReadWriteEnable |
Public enumeration | Ltc4151TypeControlStuckBusTimerEnable |
Public enumeration | Ltc4151TypeControlTestModeEnable |
Public enumeration | Ltc4151TypeSenseAdcBusy |
Public enumeration | Ltc4151TypeVinAdcBusy |


Ltc263710 Class

Linear Technology: LTC 2637-10
Inheritance Hierarchy
SystemObject
telos.Ird.LinearTechnologyLtc263710

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ltc263710
Public Class Ltc263710
public ref class Ltc263710
type Ltc263710 =  class end

The Ltc263710 type exposes the following members.

Constructors
 | Name | Description
Public method | Ltc263710 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | UpdatePowerUpDACRegisterAllDACs | Update (Power Up) DAC Register "All DACs"
Public property | UpdatePowerUpDACRegisterDACA | Update (Power Up) DAC Register "DAC A"
Public property | UpdatePowerUpDACRegisterDACB | Update (Power Up) DAC Register "DAC B"
Public property | UpdatePowerUpDACRegisterDACC | Update (Power Up) DAC Register "DAC C"
Public property | UpdatePowerUpDACRegisterDACD | Update (Power Up) DAC Register "DAC D"
Public property | UpdatePowerUpDACRegisterDACE | Update (Power Up) DAC Register "DAC E"
Public property | UpdatePowerUpDACRegisterDACF | Update (Power Up) DAC Register "DAC F"
Public property | UpdatePowerUpDACRegisterDACG | Update (Power Up) DAC Register "DAC G"
Public property | UpdatePowerUpDACRegisterDACH | Update (Power Up) DAC Register "DAC H"
Public property | WriteToAndUpdatePowerUpDACRegisterAllDACs | Write To And Update (Power Up) DAC Register "All DACs"
Public property | WriteToAndUpdatePowerUpDACRegisterDACA | Write To And Update (Power Up) DAC Register "DAC A"
Public property | WriteToAndUpdatePowerUpDACRegisterDACB | Write To And Update (Power Up) DAC Register "DAC B"
Public property | WriteToAndUpdatePowerUpDACRegisterDACC | Write To And Update (Power Up) DAC Register "DAC C"
Public property | WriteToAndUpdatePowerUpDACRegisterDACD | Write To And Update (Power Up) DAC Register "DAC D"
Public property | WriteToAndUpdatePowerUpDACRegisterDACE | Write To And Update (Power Up) DAC Register "DAC E"
Public property | WriteToAndUpdatePowerUpDACRegisterDACF | Write To And Update (Power Up) DAC Register "DAC F"
Public property | WriteToAndUpdatePowerUpDACRegisterDACG | Write To And Update (Power Up) DAC Register "DAC G"
Public property | WriteToAndUpdatePowerUpDACRegisterDACH | Write To And Update (Power Up) DAC Register "DAC H"
Public property | WriteToInputRegisterAllDACs | Write To Input Register "All DACs"
Public property | WriteToInputRegisterAllDACsUpdatePowerUpAll | Write To Input Register "All DACs", Update (Power Up) All
Public property | WriteToInputRegisterDACA | Write To Input Register "DAC A"
Public property | WriteToInputRegisterDACAUpdatePowerUpAll | Write To Input Register "DAC A", Update (Power Up) All
Public property | WriteToInputRegisterDACB | Write To Input Register "DAC B"
Public property | WriteToInputRegisterDACBUpdatePowerUpAll | Write To Input Register "DAC B", Update (Power Up) All
Public property | WriteToInputRegisterDACC | Write To Input Register "DAC C"
Public property | WriteToInputRegisterDACCUpdatePowerUpAll | Write To Input Register "DAC C", Update (Power Up) All
Public property | WriteToInputRegisterDACD | Write To Input Register "DAC D"
Public property | WriteToInputRegisterDACDUpdatePowerUpAll | Write To Input Register "DAC D", Update (Power Up) All
Public property | WriteToInputRegisterDACE | Write To Input Register "DAC E"
Public property | WriteToInputRegisterDACEUpdatePowerUpAll | Write To Input Register "DAC E", Update (Power Up) All
Public property | WriteToInputRegisterDACF | Write To Input Register "DAC F"
Public property | WriteToInputRegisterDACFUpdatePowerUpAll | Write To Input Register "DAC F", Update (Power Up) All
Public property | WriteToInputRegisterDACG | Write To Input Register "DAC G"
Public property | WriteToInputRegisterDACGUpdatePowerUpAll | Write To Input Register "DAC G", Update (Power Up) All
Public property | WriteToInputRegisterDACH | Write To Input Register "DAC H"
Public property | WriteToInputRegisterDACHUpdatePowerUpAll | Write To Input Register "DAC H", Update (Power Up) All
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PowerDownAllDACs | Power Down "All DACs"
Public method | PowerDownChipAllDACsAndReferences | Power Down Chip (All DACs and References)
Public method | PowerDownDACA | Power Down "DAC A"
Public method | PowerDownDACB | Power Down "DAC B"
Public method | PowerDownDACC | Power Down "DAC C"
Public method | PowerDownDACD | Power Down "DAC D"
Public method | PowerDownDACE | Power Down "DAC E"
Public method | PowerDownDACF | Power Down "DAC F"
Public method | PowerDownDACG | Power Down "DAC G"
Public method | PowerDownDACH | Power Down "DAC H"
Public method | SelectExternalReferencePowerDownInternalReference | Select External Reference (Power Down Internal Reference)
Public method | SelectInternalReferencePowerUpReference | Select Internal Reference (Power Up Reference)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Octal 10-Bit I2C VOUT DACs with 10ppm/°C Reference
See Also

Reference

telos.Ird.LinearTechnology Namespace


Ltc263710 Constructor

Constructor

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ltc263710(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ltc263710(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ltc263710

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710 Properties

The Ltc263710 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | UpdatePowerUpDACRegisterAllDACs | Update (Power Up) DAC Register "All DACs"
Public property | UpdatePowerUpDACRegisterDACA | Update (Power Up) DAC Register "DAC A"
Public property | UpdatePowerUpDACRegisterDACB | Update (Power Up) DAC Register "DAC B"
Public property | UpdatePowerUpDACRegisterDACC | Update (Power Up) DAC Register "DAC C"
Public property | UpdatePowerUpDACRegisterDACD | Update (Power Up) DAC Register "DAC D"
Public property | UpdatePowerUpDACRegisterDACE | Update (Power Up) DAC Register "DAC E"
Public property | UpdatePowerUpDACRegisterDACF | Update (Power Up) DAC Register "DAC F"
Public property | UpdatePowerUpDACRegisterDACG | Update (Power Up) DAC Register "DAC G"
Public property | UpdatePowerUpDACRegisterDACH | Update (Power Up) DAC Register "DAC H"
Public property | WriteToAndUpdatePowerUpDACRegisterAllDACs | Write To And Update (Power Up) DAC Register "All DACs"
Public property | WriteToAndUpdatePowerUpDACRegisterDACA | Write To And Update (Power Up) DAC Register "DAC A"
Public property | WriteToAndUpdatePowerUpDACRegisterDACB | Write To And Update (Power Up) DAC Register "DAC B"
Public property | WriteToAndUpdatePowerUpDACRegisterDACC | Write To And Update (Power Up) DAC Register "DAC C"
Public property | WriteToAndUpdatePowerUpDACRegisterDACD | Write To And Update (Power Up) DAC Register "DAC D"
Public property | WriteToAndUpdatePowerUpDACRegisterDACE | Write To And Update (Power Up) DAC Register "DAC E"
Public property | WriteToAndUpdatePowerUpDACRegisterDACF | Write To And Update (Power Up) DAC Register "DAC F"
Public property | WriteToAndUpdatePowerUpDACRegisterDACG | Write To And Update (Power Up) DAC Register "DAC G"
Public property | WriteToAndUpdatePowerUpDACRegisterDACH | Write To And Update (Power Up) DAC Register "DAC H"
Public property | WriteToInputRegisterAllDACs | Write To Input Register "All DACs"
Public property | WriteToInputRegisterAllDACsUpdatePowerUpAll | Write To Input Register "All DACs", Update (Power Up) All
Public property | WriteToInputRegisterDACA | Write To Input Register "DAC A"
Public property | WriteToInputRegisterDACAUpdatePowerUpAll | Write To Input Register "DAC A", Update (Power Up) All
Public property | WriteToInputRegisterDACB | Write To Input Register "DAC B"
Public property | WriteToInputRegisterDACBUpdatePowerUpAll | Write To Input Register "DAC B", Update (Power Up) All
Public property | WriteToInputRegisterDACC | Write To Input Register "DAC C"
Public property | WriteToInputRegisterDACCUpdatePowerUpAll | Write To Input Register "DAC C", Update (Power Up) All
Public property | WriteToInputRegisterDACD | Write To Input Register "DAC D"
Public property | WriteToInputRegisterDACDUpdatePowerUpAll | Write To Input Register "DAC D", Update (Power Up) All
Public property | WriteToInputRegisterDACE | Write To Input Register "DAC E"
Public property | WriteToInputRegisterDACEUpdatePowerUpAll | Write To Input Register "DAC E", Update (Power Up) All
Public property | WriteToInputRegisterDACF | Write To Input Register "DAC F"
Public property | WriteToInputRegisterDACFUpdatePowerUpAll | Write To Input Register "DAC F", Update (Power Up) All
Public property | WriteToInputRegisterDACG | Write To Input Register "DAC G"
Public property | WriteToInputRegisterDACGUpdatePowerUpAll | Write To Input Register "DAC G", Update (Power Up) All
Public property | WriteToInputRegisterDACH | Write To Input Register "DAC H"
Public property | WriteToInputRegisterDACHUpdatePowerUpAll | Write To Input Register "DAC H", Update (Power Up) All
Top
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.AutoFlush Property

IRD

Ltc263710AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.UpdatePowerUpDACRegisterAllDACs Property

IRD

Ltc263710UpdatePowerUpDACRegisterAllDACs Property

Update (Power Up) DAC Register "All DACs"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UpdatePowerUpDACRegisterAllDACs { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterAllDACs As UShort
    Set
public:
property unsigned short UpdatePowerUpDACRegisterAllDACs {
    void set (unsigned short value);
}
member UpdatePowerUpDACRegisterAllDACs : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.UpdatePowerUpDACRegisterDACA Property

IRD

Ltc263710UpdatePowerUpDACRegisterDACA Property

Update (Power Up) DAC Register "DAC A"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UpdatePowerUpDACRegisterDACA { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACA As UShort
    Set
public:
property unsigned short UpdatePowerUpDACRegisterDACA {
    void set (unsigned short value);
}
member UpdatePowerUpDACRegisterDACA : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.UpdatePowerUpDACRegisterDACB Property

IRD

Ltc263710UpdatePowerUpDACRegisterDACB Property

Update (Power Up) DAC Register "DAC B"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UpdatePowerUpDACRegisterDACB { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACB As UShort
    Set
public:
property unsigned short UpdatePowerUpDACRegisterDACB {
    void set (unsigned short value);
}
member UpdatePowerUpDACRegisterDACB : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.UpdatePowerUpDACRegisterDACC Property

IRD

Ltc263710UpdatePowerUpDACRegisterDACC Property

Update (Power Up) DAC Register "DAC C"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UpdatePowerUpDACRegisterDACC { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACC As UShort
    Set
public:
property unsigned short UpdatePowerUpDACRegisterDACC {
    void set (unsigned short value);
}
member UpdatePowerUpDACRegisterDACC : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.UpdatePowerUpDACRegisterDACD Property

IRD

Ltc263710UpdatePowerUpDACRegisterDACD Property

Update (Power Up) DAC Register "DAC D"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UpdatePowerUpDACRegisterDACD { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACD As UShort
    Set
public:
property unsigned short UpdatePowerUpDACRegisterDACD {
    void set (unsigned short value);
}
member UpdatePowerUpDACRegisterDACD : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.UpdatePowerUpDACRegisterDACE Property

IRD

Ltc263710UpdatePowerUpDACRegisterDACE Property

Update (Power Up) DAC Register "DAC E"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UpdatePowerUpDACRegisterDACE { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACE As UShort
    Set
public:
property unsigned short UpdatePowerUpDACRegisterDACE {
    void set (unsigned short value);
}
member UpdatePowerUpDACRegisterDACE : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.UpdatePowerUpDACRegisterDACF Property

IRD

Ltc263710UpdatePowerUpDACRegisterDACF Property

Update (Power Up) DAC Register "DAC F"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UpdatePowerUpDACRegisterDACF { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACF As UShort
    Set
public:
property unsigned short UpdatePowerUpDACRegisterDACF {
    void set (unsigned short value);
}
member UpdatePowerUpDACRegisterDACF : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.UpdatePowerUpDACRegisterDACG Property

IRD

Ltc263710UpdatePowerUpDACRegisterDACG Property

Update (Power Up) DAC Register "DAC G"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UpdatePowerUpDACRegisterDACG { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACG As UShort
    Set
public:
property unsigned short UpdatePowerUpDACRegisterDACG {
    void set (unsigned short value);
}
member UpdatePowerUpDACRegisterDACG : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.UpdatePowerUpDACRegisterDACH Property

IRD

Ltc263710UpdatePowerUpDACRegisterDACH Property

Update (Power Up) DAC Register "DAC H"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UpdatePowerUpDACRegisterDACH { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACH As UShort
    Set
public:
property unsigned short UpdatePowerUpDACRegisterDACH {
    void set (unsigned short value);
}
member UpdatePowerUpDACRegisterDACH : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToAndUpdatePowerUpDACRegisterAllDACs Property

IRD

Ltc263710WriteToAndUpdatePowerUpDACRegisterAllDACs Property

Write To And Update (Power Up) DAC Register "All DACs"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToAndUpdatePowerUpDACRegisterAllDACs { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterAllDACs As UShort
    Set
public:
property unsigned short WriteToAndUpdatePowerUpDACRegisterAllDACs {
    void set (unsigned short value);
}
member WriteToAndUpdatePowerUpDACRegisterAllDACs : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToAndUpdatePowerUpDACRegisterDACA Property

IRD

Ltc263710WriteToAndUpdatePowerUpDACRegisterDACA Property

Write To And Update (Power Up) DAC Register "DAC A"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToAndUpdatePowerUpDACRegisterDACA { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACA As UShort
    Set
public:
property unsigned short WriteToAndUpdatePowerUpDACRegisterDACA {
    void set (unsigned short value);
}
member WriteToAndUpdatePowerUpDACRegisterDACA : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToAndUpdatePowerUpDACRegisterDACB Property

IRD

Ltc263710WriteToAndUpdatePowerUpDACRegisterDACB Property

Write To And Update (Power Up) DAC Register "DAC B"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToAndUpdatePowerUpDACRegisterDACB { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACB As UShort
    Set
public:
property unsigned short WriteToAndUpdatePowerUpDACRegisterDACB {
    void set (unsigned short value);
}
member WriteToAndUpdatePowerUpDACRegisterDACB : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToAndUpdatePowerUpDACRegisterDACC Property

IRD

Ltc263710WriteToAndUpdatePowerUpDACRegisterDACC Property

Write To And Update (Power Up) DAC Register "DAC C"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToAndUpdatePowerUpDACRegisterDACC { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACC As UShort
    Set
public:
property unsigned short WriteToAndUpdatePowerUpDACRegisterDACC {
    void set (unsigned short value);
}
member WriteToAndUpdatePowerUpDACRegisterDACC : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToAndUpdatePowerUpDACRegisterDACD Property

IRD

Ltc263710WriteToAndUpdatePowerUpDACRegisterDACD Property

Write To And Update (Power Up) DAC Register "DAC D"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToAndUpdatePowerUpDACRegisterDACD { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACD As UShort
    Set
public:
property unsigned short WriteToAndUpdatePowerUpDACRegisterDACD {
    void set (unsigned short value);
}
member WriteToAndUpdatePowerUpDACRegisterDACD : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToAndUpdatePowerUpDACRegisterDACE Property

IRD

Ltc263710WriteToAndUpdatePowerUpDACRegisterDACE Property

Write To And Update (Power Up) DAC Register "DAC E"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToAndUpdatePowerUpDACRegisterDACE { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACE As UShort
    Set
public:
property unsigned short WriteToAndUpdatePowerUpDACRegisterDACE {
    void set (unsigned short value);
}
member WriteToAndUpdatePowerUpDACRegisterDACE : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToAndUpdatePowerUpDACRegisterDACF Property

IRD

Ltc263710WriteToAndUpdatePowerUpDACRegisterDACF Property

Write To And Update (Power Up) DAC Register "DAC F"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToAndUpdatePowerUpDACRegisterDACF { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACF As UShort
    Set
public:
property unsigned short WriteToAndUpdatePowerUpDACRegisterDACF {
    void set (unsigned short value);
}
member WriteToAndUpdatePowerUpDACRegisterDACF : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToAndUpdatePowerUpDACRegisterDACG Property

IRD

Ltc263710WriteToAndUpdatePowerUpDACRegisterDACG Property

Write To And Update (Power Up) DAC Register "DAC G"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToAndUpdatePowerUpDACRegisterDACG { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACG As UShort
    Set
public:
property unsigned short WriteToAndUpdatePowerUpDACRegisterDACG {
    void set (unsigned short value);
}
member WriteToAndUpdatePowerUpDACRegisterDACG : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToAndUpdatePowerUpDACRegisterDACH Property

IRD

Ltc263710WriteToAndUpdatePowerUpDACRegisterDACH Property

Write To And Update (Power Up) DAC Register "DAC H"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToAndUpdatePowerUpDACRegisterDACH { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACH As UShort
    Set
public:
property unsigned short WriteToAndUpdatePowerUpDACRegisterDACH {
    void set (unsigned short value);
}
member WriteToAndUpdatePowerUpDACRegisterDACH : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToInputRegisterAllDACs Property

IRD

Ltc263710WriteToInputRegisterAllDACs Property

Write To Input Register "All DACs"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterAllDACs { set; }
Public WriteOnly Property WriteToInputRegisterAllDACs As UShort
    Set
public:
property unsigned short WriteToInputRegisterAllDACs {
    void set (unsigned short value);
}
member WriteToInputRegisterAllDACs : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToInputRegisterAllDACsUpdatePowerUpAll Property

IRD

Ltc263710WriteToInputRegisterAllDACsUpdatePowerUpAll Property

Write To Input Register "All DACs", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterAllDACsUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterAllDACsUpdatePowerUpAll As UShort
    Set
public:
property unsigned short WriteToInputRegisterAllDACsUpdatePowerUpAll {
    void set (unsigned short value);
}
member WriteToInputRegisterAllDACsUpdatePowerUpAll : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToInputRegisterDACA Property

IRD

Ltc263710WriteToInputRegisterDACA Property

Write To Input Register "DAC A"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACA { set; }
Public WriteOnly Property WriteToInputRegisterDACA As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACA {
    void set (unsigned short value);
}
member WriteToInputRegisterDACA : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToInputRegisterDACAUpdatePowerUpAll Property

IRD

Ltc263710WriteToInputRegisterDACAUpdatePowerUpAll Property

Write To Input Register "DAC A", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACAUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACAUpdatePowerUpAll As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACAUpdatePowerUpAll {
    void set (unsigned short value);
}
member WriteToInputRegisterDACAUpdatePowerUpAll : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToInputRegisterDACB Property

IRD

Ltc263710WriteToInputRegisterDACB Property

Write To Input Register "DAC B"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACB { set; }
Public WriteOnly Property WriteToInputRegisterDACB As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACB {
    void set (unsigned short value);
}
member WriteToInputRegisterDACB : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToInputRegisterDACBUpdatePowerUpAll Property

IRD

Ltc263710WriteToInputRegisterDACBUpdatePowerUpAll Property

Write To Input Register "DAC B", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACBUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACBUpdatePowerUpAll As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACBUpdatePowerUpAll {
    void set (unsigned short value);
}
member WriteToInputRegisterDACBUpdatePowerUpAll : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToInputRegisterDACC Property

IRD

Ltc263710WriteToInputRegisterDACC Property

Write To Input Register "DAC C"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACC { set; }
Public WriteOnly Property WriteToInputRegisterDACC As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACC {
    void set (unsigned short value);
}
member WriteToInputRegisterDACC : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToInputRegisterDACCUpdatePowerUpAll Property

IRD

Ltc263710WriteToInputRegisterDACCUpdatePowerUpAll Property

Write To Input Register "DAC C", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACCUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACCUpdatePowerUpAll As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACCUpdatePowerUpAll {
    void set (unsigned short value);
}
member WriteToInputRegisterDACCUpdatePowerUpAll : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToInputRegisterDACD Property

IRD

Ltc263710WriteToInputRegisterDACD Property

Write To Input Register "DAC D"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACD { set; }
Public WriteOnly Property WriteToInputRegisterDACD As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACD {
    void set (unsigned short value);
}
member WriteToInputRegisterDACD : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToInputRegisterDACDUpdatePowerUpAll Property

IRD

Ltc263710WriteToInputRegisterDACDUpdatePowerUpAll Property

Write To Input Register "DAC D", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACDUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACDUpdatePowerUpAll As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACDUpdatePowerUpAll {
    void set (unsigned short value);
}
member WriteToInputRegisterDACDUpdatePowerUpAll : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToInputRegisterDACE Property

IRD

Ltc263710WriteToInputRegisterDACE Property

Write To Input Register "DAC E"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACE { set; }
Public WriteOnly Property WriteToInputRegisterDACE As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACE {
    void set (unsigned short value);
}
member WriteToInputRegisterDACE : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToInputRegisterDACEUpdatePowerUpAll Property

IRD

Ltc263710WriteToInputRegisterDACEUpdatePowerUpAll Property

Write To Input Register "DAC E", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACEUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACEUpdatePowerUpAll As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACEUpdatePowerUpAll {
    void set (unsigned short value);
}
member WriteToInputRegisterDACEUpdatePowerUpAll : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToInputRegisterDACF Property

IRD

Ltc263710WriteToInputRegisterDACF Property

Write To Input Register "DAC F"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACF { set; }
Public WriteOnly Property WriteToInputRegisterDACF As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACF {
    void set (unsigned short value);
}
member WriteToInputRegisterDACF : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToInputRegisterDACFUpdatePowerUpAll Property

IRD

Ltc263710WriteToInputRegisterDACFUpdatePowerUpAll Property

Write To Input Register "DAC F", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACFUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACFUpdatePowerUpAll As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACFUpdatePowerUpAll {
    void set (unsigned short value);
}
member WriteToInputRegisterDACFUpdatePowerUpAll : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToInputRegisterDACG Property

IRD

Ltc263710WriteToInputRegisterDACG Property

Write To Input Register "DAC G"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACG { set; }
Public WriteOnly Property WriteToInputRegisterDACG As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACG {
    void set (unsigned short value);
}
member WriteToInputRegisterDACG : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToInputRegisterDACGUpdatePowerUpAll Property

IRD

Ltc263710WriteToInputRegisterDACGUpdatePowerUpAll Property

Write To Input Register "DAC G", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACGUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACGUpdatePowerUpAll As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACGUpdatePowerUpAll {
    void set (unsigned short value);
}
member WriteToInputRegisterDACGUpdatePowerUpAll : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToInputRegisterDACH Property

IRD

Ltc263710WriteToInputRegisterDACH Property

Write To Input Register "DAC H"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACH { set; }
Public WriteOnly Property WriteToInputRegisterDACH As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACH {
    void set (unsigned short value);
}
member WriteToInputRegisterDACH : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.WriteToInputRegisterDACHUpdatePowerUpAll Property

IRD

Ltc263710WriteToInputRegisterDACHUpdatePowerUpAll Property

Write To Input Register "DAC H", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACHUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACHUpdatePowerUpAll As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACHUpdatePowerUpAll {
    void set (unsigned short value);
}
member WriteToInputRegisterDACHUpdatePowerUpAll : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710 Methods

The Ltc263710 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PowerDownAllDACs | Power Down "All DACs"
Public method | PowerDownChipAllDACsAndReferences | Power Down Chip (All DACs and References)
Public method | PowerDownDACA | Power Down "DAC A"
Public method | PowerDownDACB | Power Down "DAC B"
Public method | PowerDownDACC | Power Down "DAC C"
Public method | PowerDownDACD | Power Down "DAC D"
Public method | PowerDownDACE | Power Down "DAC E"
Public method | PowerDownDACF | Power Down "DAC F"
Public method | PowerDownDACG | Power Down "DAC G"
Public method | PowerDownDACH | Power Down "DAC H"
Public method | SelectExternalReferencePowerDownInternalReference | Select External Reference (Power Down Internal Reference)
Public method | SelectInternalReferencePowerUpReference | Select Internal Reference (Power Up Reference)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.Flush Method

IRD

Ltc263710Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.PowerDownAllDACs Method

IRD

Ltc263710PowerDownAllDACs Method

Power Down "All DACs"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownAllDACs()
Public Sub PowerDownAllDACs
public:
void PowerDownAllDACs()
member PowerDownAllDACs : unit -> unit
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.PowerDownChipAllDACsAndReferences Method

IRD

Ltc263710PowerDownChipAllDACsAndReferences Method

Power Down Chip (All DACs and References)

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownChipAllDACsAndReferences()
Public Sub PowerDownChipAllDACsAndReferences
public:
void PowerDownChipAllDACsAndReferences()
member PowerDownChipAllDACsAndReferences : unit -> unit
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.PowerDownDACA Method

IRD

Ltc263710PowerDownDACA Method

Power Down "DAC A"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACA()
Public Sub PowerDownDACA
public:
void PowerDownDACA()
member PowerDownDACA : unit -> unit
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.PowerDownDACB Method

IRD

Ltc263710PowerDownDACB Method

Power Down "DAC B"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACB()
Public Sub PowerDownDACB
public:
void PowerDownDACB()
member PowerDownDACB : unit -> unit
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.PowerDownDACC Method

IRD

Ltc263710PowerDownDACC Method

Power Down "DAC C"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACC()
Public Sub PowerDownDACC
public:
void PowerDownDACC()
member PowerDownDACC : unit -> unit
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.PowerDownDACD Method

IRD

Ltc263710PowerDownDACD Method

Power Down "DAC D"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACD()
Public Sub PowerDownDACD
public:
void PowerDownDACD()
member PowerDownDACD : unit -> unit
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.PowerDownDACE Method

IRD

Ltc263710PowerDownDACE Method

Power Down "DAC E"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACE()
Public Sub PowerDownDACE
public:
void PowerDownDACE()
member PowerDownDACE : unit -> unit
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.PowerDownDACF Method

IRD

Ltc263710PowerDownDACF Method

Power Down "DAC F"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACF()
Public Sub PowerDownDACF
public:
void PowerDownDACF()
member PowerDownDACF : unit -> unit
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.PowerDownDACG Method

IRD

Ltc263710PowerDownDACG Method

Power Down "DAC G"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACG()
Public Sub PowerDownDACG
public:
void PowerDownDACG()
member PowerDownDACG : unit -> unit
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.PowerDownDACH Method

IRD

Ltc263710PowerDownDACH Method

Power Down "DAC H"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACH()
Public Sub PowerDownDACH
public:
void PowerDownDACH()
member PowerDownDACH : unit -> unit
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.SelectExternalReferencePowerDownInternalReference Method

IRD

Ltc263710SelectExternalReferencePowerDownInternalReference Method

Select External Reference (Power Down Internal Reference)

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectExternalReferencePowerDownInternalReference()
Public Sub SelectExternalReferencePowerDownInternalReference
public:
void SelectExternalReferencePowerDownInternalReference()
member SelectExternalReferencePowerDownInternalReference : unit -> unit
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263710.SelectInternalReferencePowerUpReference Method

IRD

Ltc263710SelectInternalReferencePowerUpReference Method

Select Internal Reference (Power Up Reference)

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectInternalReferencePowerUpReference()
Public Sub SelectInternalReferencePowerUpReference
public:
void SelectInternalReferencePowerUpReference()
member SelectInternalReferencePowerUpReference : unit -> unit
See Also

Reference

Ltc263710 Class
telos.Ird.LinearTechnology Namespace


Ltc263712 Class

Linear Technology: LTC 2637-12
Inheritance Hierarchy
SystemObject
telos.Ird.LinearTechnologyLtc263712

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ltc263712
Public Class Ltc263712
public ref class Ltc263712
type Ltc263712 =  class end

The Ltc263712 type exposes the following members.

Constructors
 | Name | Description
Public method | Ltc263712 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | UpdatePowerUpDACRegisterAllDACs | Update (Power Up) DAC Register "All DACs"
Public property | UpdatePowerUpDACRegisterDACA | Update (Power Up) DAC Register "DAC A"
Public property | UpdatePowerUpDACRegisterDACB | Update (Power Up) DAC Register "DAC B"
Public property | UpdatePowerUpDACRegisterDACC | Update (Power Up) DAC Register "DAC C"
Public property | UpdatePowerUpDACRegisterDACD | Update (Power Up) DAC Register "DAC D"
Public property | UpdatePowerUpDACRegisterDACE | Update (Power Up) DAC Register "DAC E"
Public property | UpdatePowerUpDACRegisterDACF | Update (Power Up) DAC Register "DAC F"
Public property | UpdatePowerUpDACRegisterDACG | Update (Power Up) DAC Register "DAC G"
Public property | UpdatePowerUpDACRegisterDACH | Update (Power Up) DAC Register "DAC H"
Public property | WriteToAndUpdatePowerUpDACRegisterAllDACs | Write To And Update (Power Up) DAC Register "All DACs"
Public property | WriteToAndUpdatePowerUpDACRegisterDACA | Write To And Update (Power Up) DAC Register "DAC A"
Public property | WriteToAndUpdatePowerUpDACRegisterDACB | Write To And Update (Power Up) DAC Register "DAC B"
Public property | WriteToAndUpdatePowerUpDACRegisterDACC | Write To And Update (Power Up) DAC Register "DAC C"
Public property | WriteToAndUpdatePowerUpDACRegisterDACD | Write To And Update (Power Up) DAC Register "DAC D"
Public property | WriteToAndUpdatePowerUpDACRegisterDACE | Write To And Update (Power Up) DAC Register "DAC E"
Public property | WriteToAndUpdatePowerUpDACRegisterDACF | Write To And Update (Power Up) DAC Register "DAC F"
Public property | WriteToAndUpdatePowerUpDACRegisterDACG | Write To And Update (Power Up) DAC Register "DAC G"
Public property | WriteToAndUpdatePowerUpDACRegisterDACH | Write To And Update (Power Up) DAC Register "DAC H"
Public property | WriteToInputRegisterAllDACs | Write To Input Register "All DACs"
Public property | WriteToInputRegisterAllDACsUpdatePowerUpAll | Write To Input Register "All DACs", Update (Power Up) All
Public property | WriteToInputRegisterDACA | Write To Input Register "DAC A"
Public property | WriteToInputRegisterDACAUpdatePowerUpAll | Write To Input Register "DAC A", Update (Power Up) All
Public property | WriteToInputRegisterDACB | Write To Input Register "DAC B"
Public property | WriteToInputRegisterDACBUpdatePowerUpAll | Write To Input Register "DAC B", Update (Power Up) All
Public property | WriteToInputRegisterDACC | Write To Input Register "DAC C"
Public property | WriteToInputRegisterDACCUpdatePowerUpAll | Write To Input Register "DAC C", Update (Power Up) All
Public property | WriteToInputRegisterDACD | Write To Input Register "DAC D"
Public property | WriteToInputRegisterDACDUpdatePowerUpAll | Write To Input Register "DAC D", Update (Power Up) All
Public property | WriteToInputRegisterDACE | Write To Input Register "DAC E"
Public property | WriteToInputRegisterDACEUpdatePowerUpAll | Write To Input Register "DAC E", Update (Power Up) All
Public property | WriteToInputRegisterDACF | Write To Input Register "DAC F"
Public property | WriteToInputRegisterDACFUpdatePowerUpAll | Write To Input Register "DAC F", Update (Power Up) All
Public property | WriteToInputRegisterDACG | Write To Input Register "DAC G"
Public property | WriteToInputRegisterDACGUpdatePowerUpAll | Write To Input Register "DAC G", Update (Power Up) All
Public property | WriteToInputRegisterDACH | Write To Input Register "DAC H"
Public property | WriteToInputRegisterDACHUpdatePowerUpAll | Write To Input Register "DAC H", Update (Power Up) All
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PowerDownAllDACs | Power Down "All DACs"
Public method | PowerDownChipAllDACsAndReferences | Power Down Chip (All DACs and References)
Public method | PowerDownDACA | Power Down "DAC A"
Public method | PowerDownDACB | Power Down "DAC B"
Public method | PowerDownDACC | Power Down "DAC C"
Public method | PowerDownDACD | Power Down "DAC D"
Public method | PowerDownDACE | Power Down "DAC E"
Public method | PowerDownDACF | Power Down "DAC F"
Public method | PowerDownDACG | Power Down "DAC G"
Public method | PowerDownDACH | Power Down "DAC H"
Public method | SelectExternalReferencePowerDownInternalReference | Select External Reference (Power Down Internal Reference)
Public method | SelectInternalReferencePowerUpReference | Select Internal Reference (Power Up Reference)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Octal 12-Bit I2C VOUT DACs with 10ppm/°C Reference
See Also

Reference

telos.Ird.LinearTechnology Namespace


Ltc263712 Constructor

Constructor

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ltc263712(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ltc263712(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ltc263712

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712 Properties

The Ltc263712 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | UpdatePowerUpDACRegisterAllDACs | Update (Power Up) DAC Register "All DACs"
Public property | UpdatePowerUpDACRegisterDACA | Update (Power Up) DAC Register "DAC A"
Public property | UpdatePowerUpDACRegisterDACB | Update (Power Up) DAC Register "DAC B"
Public property | UpdatePowerUpDACRegisterDACC | Update (Power Up) DAC Register "DAC C"
Public property | UpdatePowerUpDACRegisterDACD | Update (Power Up) DAC Register "DAC D"
Public property | UpdatePowerUpDACRegisterDACE | Update (Power Up) DAC Register "DAC E"
Public property | UpdatePowerUpDACRegisterDACF | Update (Power Up) DAC Register "DAC F"
Public property | UpdatePowerUpDACRegisterDACG | Update (Power Up) DAC Register "DAC G"
Public property | UpdatePowerUpDACRegisterDACH | Update (Power Up) DAC Register "DAC H"
Public property | WriteToAndUpdatePowerUpDACRegisterAllDACs | Write To And Update (Power Up) DAC Register "All DACs"
Public property | WriteToAndUpdatePowerUpDACRegisterDACA | Write To And Update (Power Up) DAC Register "DAC A"
Public property | WriteToAndUpdatePowerUpDACRegisterDACB | Write To And Update (Power Up) DAC Register "DAC B"
Public property | WriteToAndUpdatePowerUpDACRegisterDACC | Write To And Update (Power Up) DAC Register "DAC C"
Public property | WriteToAndUpdatePowerUpDACRegisterDACD | Write To And Update (Power Up) DAC Register "DAC D"
Public property | WriteToAndUpdatePowerUpDACRegisterDACE | Write To And Update (Power Up) DAC Register "DAC E"
Public property | WriteToAndUpdatePowerUpDACRegisterDACF | Write To And Update (Power Up) DAC Register "DAC F"
Public property | WriteToAndUpdatePowerUpDACRegisterDACG | Write To And Update (Power Up) DAC Register "DAC G"
Public property | WriteToAndUpdatePowerUpDACRegisterDACH | Write To And Update (Power Up) DAC Register "DAC H"
Public property | WriteToInputRegisterAllDACs | Write To Input Register "All DACs"
Public property | WriteToInputRegisterAllDACsUpdatePowerUpAll | Write To Input Register "All DACs", Update (Power Up) All
Public property | WriteToInputRegisterDACA | Write To Input Register "DAC A"
Public property | WriteToInputRegisterDACAUpdatePowerUpAll | Write To Input Register "DAC A", Update (Power Up) All
Public property | WriteToInputRegisterDACB | Write To Input Register "DAC B"
Public property | WriteToInputRegisterDACBUpdatePowerUpAll | Write To Input Register "DAC B", Update (Power Up) All
Public property | WriteToInputRegisterDACC | Write To Input Register "DAC C"
Public property | WriteToInputRegisterDACCUpdatePowerUpAll | Write To Input Register "DAC C", Update (Power Up) All
Public property | WriteToInputRegisterDACD | Write To Input Register "DAC D"
Public property | WriteToInputRegisterDACDUpdatePowerUpAll | Write To Input Register "DAC D", Update (Power Up) All
Public property | WriteToInputRegisterDACE | Write To Input Register "DAC E"
Public property | WriteToInputRegisterDACEUpdatePowerUpAll | Write To Input Register "DAC E", Update (Power Up) All
Public property | WriteToInputRegisterDACF | Write To Input Register "DAC F"
Public property | WriteToInputRegisterDACFUpdatePowerUpAll | Write To Input Register "DAC F", Update (Power Up) All
Public property | WriteToInputRegisterDACG | Write To Input Register "DAC G"
Public property | WriteToInputRegisterDACGUpdatePowerUpAll | Write To Input Register "DAC G", Update (Power Up) All
Public property | WriteToInputRegisterDACH | Write To Input Register "DAC H"
Public property | WriteToInputRegisterDACHUpdatePowerUpAll | Write To Input Register "DAC H", Update (Power Up) All
Top
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.AutoFlush Property

IRD

Ltc263712AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.UpdatePowerUpDACRegisterAllDACs Property

IRD

Ltc263712UpdatePowerUpDACRegisterAllDACs Property

Update (Power Up) DAC Register "All DACs"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UpdatePowerUpDACRegisterAllDACs { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterAllDACs As UShort
    Set
public:
property unsigned short UpdatePowerUpDACRegisterAllDACs {
    void set (unsigned short value);
}
member UpdatePowerUpDACRegisterAllDACs : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.UpdatePowerUpDACRegisterDACA Property

IRD

Ltc263712UpdatePowerUpDACRegisterDACA Property

Update (Power Up) DAC Register "DAC A"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UpdatePowerUpDACRegisterDACA { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACA As UShort
    Set
public:
property unsigned short UpdatePowerUpDACRegisterDACA {
    void set (unsigned short value);
}
member UpdatePowerUpDACRegisterDACA : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.UpdatePowerUpDACRegisterDACB Property

IRD

Ltc263712UpdatePowerUpDACRegisterDACB Property

Update (Power Up) DAC Register "DAC B"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UpdatePowerUpDACRegisterDACB { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACB As UShort
    Set
public:
property unsigned short UpdatePowerUpDACRegisterDACB {
    void set (unsigned short value);
}
member UpdatePowerUpDACRegisterDACB : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.UpdatePowerUpDACRegisterDACC Property

IRD

Ltc263712UpdatePowerUpDACRegisterDACC Property

Update (Power Up) DAC Register "DAC C"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UpdatePowerUpDACRegisterDACC { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACC As UShort
    Set
public:
property unsigned short UpdatePowerUpDACRegisterDACC {
    void set (unsigned short value);
}
member UpdatePowerUpDACRegisterDACC : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.UpdatePowerUpDACRegisterDACD Property

IRD

Ltc263712UpdatePowerUpDACRegisterDACD Property

Update (Power Up) DAC Register "DAC D"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UpdatePowerUpDACRegisterDACD { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACD As UShort
    Set
public:
property unsigned short UpdatePowerUpDACRegisterDACD {
    void set (unsigned short value);
}
member UpdatePowerUpDACRegisterDACD : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.UpdatePowerUpDACRegisterDACE Property

IRD

Ltc263712UpdatePowerUpDACRegisterDACE Property

Update (Power Up) DAC Register "DAC E"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UpdatePowerUpDACRegisterDACE { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACE As UShort
    Set
public:
property unsigned short UpdatePowerUpDACRegisterDACE {
    void set (unsigned short value);
}
member UpdatePowerUpDACRegisterDACE : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.UpdatePowerUpDACRegisterDACF Property

IRD

Ltc263712UpdatePowerUpDACRegisterDACF Property

Update (Power Up) DAC Register "DAC F"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UpdatePowerUpDACRegisterDACF { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACF As UShort
    Set
public:
property unsigned short UpdatePowerUpDACRegisterDACF {
    void set (unsigned short value);
}
member UpdatePowerUpDACRegisterDACF : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.UpdatePowerUpDACRegisterDACG Property

IRD

Ltc263712UpdatePowerUpDACRegisterDACG Property

Update (Power Up) DAC Register "DAC G"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UpdatePowerUpDACRegisterDACG { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACG As UShort
    Set
public:
property unsigned short UpdatePowerUpDACRegisterDACG {
    void set (unsigned short value);
}
member UpdatePowerUpDACRegisterDACG : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.UpdatePowerUpDACRegisterDACH Property

IRD

Ltc263712UpdatePowerUpDACRegisterDACH Property

Update (Power Up) DAC Register "DAC H"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UpdatePowerUpDACRegisterDACH { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACH As UShort
    Set
public:
property unsigned short UpdatePowerUpDACRegisterDACH {
    void set (unsigned short value);
}
member UpdatePowerUpDACRegisterDACH : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToAndUpdatePowerUpDACRegisterAllDACs Property

IRD

Ltc263712WriteToAndUpdatePowerUpDACRegisterAllDACs Property

Write To And Update (Power Up) DAC Register "All DACs"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToAndUpdatePowerUpDACRegisterAllDACs { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterAllDACs As UShort
    Set
public:
property unsigned short WriteToAndUpdatePowerUpDACRegisterAllDACs {
    void set (unsigned short value);
}
member WriteToAndUpdatePowerUpDACRegisterAllDACs : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToAndUpdatePowerUpDACRegisterDACA Property

IRD

Ltc263712WriteToAndUpdatePowerUpDACRegisterDACA Property

Write To And Update (Power Up) DAC Register "DAC A"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToAndUpdatePowerUpDACRegisterDACA { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACA As UShort
    Set
public:
property unsigned short WriteToAndUpdatePowerUpDACRegisterDACA {
    void set (unsigned short value);
}
member WriteToAndUpdatePowerUpDACRegisterDACA : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToAndUpdatePowerUpDACRegisterDACB Property

IRD

Ltc263712WriteToAndUpdatePowerUpDACRegisterDACB Property

Write To And Update (Power Up) DAC Register "DAC B"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToAndUpdatePowerUpDACRegisterDACB { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACB As UShort
    Set
public:
property unsigned short WriteToAndUpdatePowerUpDACRegisterDACB {
    void set (unsigned short value);
}
member WriteToAndUpdatePowerUpDACRegisterDACB : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToAndUpdatePowerUpDACRegisterDACC Property

IRD

Ltc263712WriteToAndUpdatePowerUpDACRegisterDACC Property

Write To And Update (Power Up) DAC Register "DAC C"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToAndUpdatePowerUpDACRegisterDACC { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACC As UShort
    Set
public:
property unsigned short WriteToAndUpdatePowerUpDACRegisterDACC {
    void set (unsigned short value);
}
member WriteToAndUpdatePowerUpDACRegisterDACC : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToAndUpdatePowerUpDACRegisterDACD Property

IRD

Ltc263712WriteToAndUpdatePowerUpDACRegisterDACD Property

Write To And Update (Power Up) DAC Register "DAC D"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToAndUpdatePowerUpDACRegisterDACD { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACD As UShort
    Set
public:
property unsigned short WriteToAndUpdatePowerUpDACRegisterDACD {
    void set (unsigned short value);
}
member WriteToAndUpdatePowerUpDACRegisterDACD : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToAndUpdatePowerUpDACRegisterDACE Property

IRD

Ltc263712WriteToAndUpdatePowerUpDACRegisterDACE Property

Write To And Update (Power Up) DAC Register "DAC E"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToAndUpdatePowerUpDACRegisterDACE { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACE As UShort
    Set
public:
property unsigned short WriteToAndUpdatePowerUpDACRegisterDACE {
    void set (unsigned short value);
}
member WriteToAndUpdatePowerUpDACRegisterDACE : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToAndUpdatePowerUpDACRegisterDACF Property

IRD

Ltc263712WriteToAndUpdatePowerUpDACRegisterDACF Property

Write To And Update (Power Up) DAC Register "DAC F"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToAndUpdatePowerUpDACRegisterDACF { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACF As UShort
    Set
public:
property unsigned short WriteToAndUpdatePowerUpDACRegisterDACF {
    void set (unsigned short value);
}
member WriteToAndUpdatePowerUpDACRegisterDACF : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToAndUpdatePowerUpDACRegisterDACG Property

IRD

Ltc263712WriteToAndUpdatePowerUpDACRegisterDACG Property

Write To And Update (Power Up) DAC Register "DAC G"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToAndUpdatePowerUpDACRegisterDACG { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACG As UShort
    Set
public:
property unsigned short WriteToAndUpdatePowerUpDACRegisterDACG {
    void set (unsigned short value);
}
member WriteToAndUpdatePowerUpDACRegisterDACG : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToAndUpdatePowerUpDACRegisterDACH Property

IRD

Ltc263712WriteToAndUpdatePowerUpDACRegisterDACH Property

Write To And Update (Power Up) DAC Register "DAC H"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToAndUpdatePowerUpDACRegisterDACH { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACH As UShort
    Set
public:
property unsigned short WriteToAndUpdatePowerUpDACRegisterDACH {
    void set (unsigned short value);
}
member WriteToAndUpdatePowerUpDACRegisterDACH : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToInputRegisterAllDACs Property

IRD

Ltc263712WriteToInputRegisterAllDACs Property

Write To Input Register "All DACs"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterAllDACs { set; }
Public WriteOnly Property WriteToInputRegisterAllDACs As UShort
    Set
public:
property unsigned short WriteToInputRegisterAllDACs {
    void set (unsigned short value);
}
member WriteToInputRegisterAllDACs : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToInputRegisterAllDACsUpdatePowerUpAll Property

IRD

Ltc263712WriteToInputRegisterAllDACsUpdatePowerUpAll Property

Write To Input Register "All DACs", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterAllDACsUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterAllDACsUpdatePowerUpAll As UShort
    Set
public:
property unsigned short WriteToInputRegisterAllDACsUpdatePowerUpAll {
    void set (unsigned short value);
}
member WriteToInputRegisterAllDACsUpdatePowerUpAll : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToInputRegisterDACA Property

IRD

Ltc263712WriteToInputRegisterDACA Property

Write To Input Register "DAC A"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACA { set; }
Public WriteOnly Property WriteToInputRegisterDACA As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACA {
    void set (unsigned short value);
}
member WriteToInputRegisterDACA : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToInputRegisterDACAUpdatePowerUpAll Property

IRD

Ltc263712WriteToInputRegisterDACAUpdatePowerUpAll Property

Write To Input Register "DAC A", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACAUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACAUpdatePowerUpAll As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACAUpdatePowerUpAll {
    void set (unsigned short value);
}
member WriteToInputRegisterDACAUpdatePowerUpAll : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToInputRegisterDACB Property

IRD

Ltc263712WriteToInputRegisterDACB Property

Write To Input Register "DAC B"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACB { set; }
Public WriteOnly Property WriteToInputRegisterDACB As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACB {
    void set (unsigned short value);
}
member WriteToInputRegisterDACB : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToInputRegisterDACBUpdatePowerUpAll Property

IRD

Ltc263712WriteToInputRegisterDACBUpdatePowerUpAll Property

Write To Input Register "DAC B", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACBUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACBUpdatePowerUpAll As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACBUpdatePowerUpAll {
    void set (unsigned short value);
}
member WriteToInputRegisterDACBUpdatePowerUpAll : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToInputRegisterDACC Property

IRD

Ltc263712WriteToInputRegisterDACC Property

Write To Input Register "DAC C"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACC { set; }
Public WriteOnly Property WriteToInputRegisterDACC As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACC {
    void set (unsigned short value);
}
member WriteToInputRegisterDACC : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToInputRegisterDACCUpdatePowerUpAll Property

IRD

Ltc263712WriteToInputRegisterDACCUpdatePowerUpAll Property

Write To Input Register "DAC C", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACCUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACCUpdatePowerUpAll As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACCUpdatePowerUpAll {
    void set (unsigned short value);
}
member WriteToInputRegisterDACCUpdatePowerUpAll : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToInputRegisterDACD Property

IRD

Ltc263712WriteToInputRegisterDACD Property

Write To Input Register "DAC D"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACD { set; }
Public WriteOnly Property WriteToInputRegisterDACD As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACD {
    void set (unsigned short value);
}
member WriteToInputRegisterDACD : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToInputRegisterDACDUpdatePowerUpAll Property

IRD

Ltc263712WriteToInputRegisterDACDUpdatePowerUpAll Property

Write To Input Register "DAC D", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACDUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACDUpdatePowerUpAll As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACDUpdatePowerUpAll {
    void set (unsigned short value);
}
member WriteToInputRegisterDACDUpdatePowerUpAll : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToInputRegisterDACE Property

IRD

Ltc263712WriteToInputRegisterDACE Property

Write To Input Register "DAC E"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACE { set; }
Public WriteOnly Property WriteToInputRegisterDACE As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACE {
    void set (unsigned short value);
}
member WriteToInputRegisterDACE : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToInputRegisterDACEUpdatePowerUpAll Property

IRD

Ltc263712WriteToInputRegisterDACEUpdatePowerUpAll Property

Write To Input Register "DAC E", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACEUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACEUpdatePowerUpAll As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACEUpdatePowerUpAll {
    void set (unsigned short value);
}
member WriteToInputRegisterDACEUpdatePowerUpAll : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToInputRegisterDACF Property

IRD

Ltc263712WriteToInputRegisterDACF Property

Write To Input Register "DAC F"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACF { set; }
Public WriteOnly Property WriteToInputRegisterDACF As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACF {
    void set (unsigned short value);
}
member WriteToInputRegisterDACF : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToInputRegisterDACFUpdatePowerUpAll Property

IRD

Ltc263712WriteToInputRegisterDACFUpdatePowerUpAll Property

Write To Input Register "DAC F", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACFUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACFUpdatePowerUpAll As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACFUpdatePowerUpAll {
    void set (unsigned short value);
}
member WriteToInputRegisterDACFUpdatePowerUpAll : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToInputRegisterDACG Property

IRD

Ltc263712WriteToInputRegisterDACG Property

Write To Input Register "DAC G"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACG { set; }
Public WriteOnly Property WriteToInputRegisterDACG As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACG {
    void set (unsigned short value);
}
member WriteToInputRegisterDACG : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToInputRegisterDACGUpdatePowerUpAll Property

IRD

Ltc263712WriteToInputRegisterDACGUpdatePowerUpAll Property

Write To Input Register "DAC G", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACGUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACGUpdatePowerUpAll As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACGUpdatePowerUpAll {
    void set (unsigned short value);
}
member WriteToInputRegisterDACGUpdatePowerUpAll : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToInputRegisterDACH Property

IRD

Ltc263712WriteToInputRegisterDACH Property

Write To Input Register "DAC H"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACH { set; }
Public WriteOnly Property WriteToInputRegisterDACH As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACH {
    void set (unsigned short value);
}
member WriteToInputRegisterDACH : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.WriteToInputRegisterDACHUpdatePowerUpAll Property

IRD

Ltc263712WriteToInputRegisterDACHUpdatePowerUpAll Property

Write To Input Register "DAC H", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WriteToInputRegisterDACHUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACHUpdatePowerUpAll As UShort
    Set
public:
property unsigned short WriteToInputRegisterDACHUpdatePowerUpAll {
    void set (unsigned short value);
}
member WriteToInputRegisterDACHUpdatePowerUpAll : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712 Methods

The Ltc263712 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PowerDownAllDACs | Power Down "All DACs"
Public method | PowerDownChipAllDACsAndReferences | Power Down Chip (All DACs and References)
Public method | PowerDownDACA | Power Down "DAC A"
Public method | PowerDownDACB | Power Down "DAC B"
Public method | PowerDownDACC | Power Down "DAC C"
Public method | PowerDownDACD | Power Down "DAC D"
Public method | PowerDownDACE | Power Down "DAC E"
Public method | PowerDownDACF | Power Down "DAC F"
Public method | PowerDownDACG | Power Down "DAC G"
Public method | PowerDownDACH | Power Down "DAC H"
Public method | SelectExternalReferencePowerDownInternalReference | Select External Reference (Power Down Internal Reference)
Public method | SelectInternalReferencePowerUpReference | Select Internal Reference (Power Up Reference)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.Flush Method

IRD

Ltc263712Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.PowerDownAllDACs Method

IRD

Ltc263712PowerDownAllDACs Method

Power Down "All DACs"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownAllDACs()
Public Sub PowerDownAllDACs
public:
void PowerDownAllDACs()
member PowerDownAllDACs : unit -> unit
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.PowerDownChipAllDACsAndReferences Method

IRD

Ltc263712PowerDownChipAllDACsAndReferences Method

Power Down Chip (All DACs and References)

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownChipAllDACsAndReferences()
Public Sub PowerDownChipAllDACsAndReferences
public:
void PowerDownChipAllDACsAndReferences()
member PowerDownChipAllDACsAndReferences : unit -> unit
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.PowerDownDACA Method

IRD

Ltc263712PowerDownDACA Method

Power Down "DAC A"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACA()
Public Sub PowerDownDACA
public:
void PowerDownDACA()
member PowerDownDACA : unit -> unit
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.PowerDownDACB Method

IRD

Ltc263712PowerDownDACB Method

Power Down "DAC B"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACB()
Public Sub PowerDownDACB
public:
void PowerDownDACB()
member PowerDownDACB : unit -> unit
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.PowerDownDACC Method

IRD

Ltc263712PowerDownDACC Method

Power Down "DAC C"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACC()
Public Sub PowerDownDACC
public:
void PowerDownDACC()
member PowerDownDACC : unit -> unit
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.PowerDownDACD Method

IRD

Ltc263712PowerDownDACD Method

Power Down "DAC D"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACD()
Public Sub PowerDownDACD
public:
void PowerDownDACD()
member PowerDownDACD : unit -> unit
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.PowerDownDACE Method

IRD

Ltc263712PowerDownDACE Method

Power Down "DAC E"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACE()
Public Sub PowerDownDACE
public:
void PowerDownDACE()
member PowerDownDACE : unit -> unit
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.PowerDownDACF Method

IRD

Ltc263712PowerDownDACF Method

Power Down "DAC F"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACF()
Public Sub PowerDownDACF
public:
void PowerDownDACF()
member PowerDownDACF : unit -> unit
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.PowerDownDACG Method

IRD

Ltc263712PowerDownDACG Method

Power Down "DAC G"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACG()
Public Sub PowerDownDACG
public:
void PowerDownDACG()
member PowerDownDACG : unit -> unit
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.PowerDownDACH Method

IRD

Ltc263712PowerDownDACH Method

Power Down "DAC H"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACH()
Public Sub PowerDownDACH
public:
void PowerDownDACH()
member PowerDownDACH : unit -> unit
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.SelectExternalReferencePowerDownInternalReference Method

IRD

Ltc263712SelectExternalReferencePowerDownInternalReference Method

Select External Reference (Power Down Internal Reference)

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectExternalReferencePowerDownInternalReference()
Public Sub SelectExternalReferencePowerDownInternalReference
public:
void SelectExternalReferencePowerDownInternalReference()
member SelectExternalReferencePowerDownInternalReference : unit -> unit
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc263712.SelectInternalReferencePowerUpReference Method

IRD

Ltc263712SelectInternalReferencePowerUpReference Method

Select Internal Reference (Power Up Reference)

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectInternalReferencePowerUpReference()
Public Sub SelectInternalReferencePowerUpReference
public:
void SelectInternalReferencePowerUpReference()
member SelectInternalReferencePowerUpReference : unit -> unit
See Also

Reference

Ltc263712 Class
telos.Ird.LinearTechnology Namespace


Ltc26378 Class

Linear Technology: LTC 2637-8
Inheritance Hierarchy
SystemObject
telos.Ird.LinearTechnologyLtc26378

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ltc26378
Public Class Ltc26378
public ref class Ltc26378
type Ltc26378 =  class end

The Ltc26378 type exposes the following members.

Constructors
 | Name | Description
Public method | Ltc26378 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | UpdatePowerUpDACRegisterAllDACs | Update (Power Up) DAC Register "All DACs"
Public property | UpdatePowerUpDACRegisterDACA | Update (Power Up) DAC Register "DAC A"
Public property | UpdatePowerUpDACRegisterDACB | Update (Power Up) DAC Register "DAC B"
Public property | UpdatePowerUpDACRegisterDACC | Update (Power Up) DAC Register "DAC C"
Public property | UpdatePowerUpDACRegisterDACD | Update (Power Up) DAC Register "DAC D"
Public property | UpdatePowerUpDACRegisterDACE | Update (Power Up) DAC Register "DAC E"
Public property | UpdatePowerUpDACRegisterDACF | Update (Power Up) DAC Register "DAC F"
Public property | UpdatePowerUpDACRegisterDACG | Update (Power Up) DAC Register "DAC G"
Public property | UpdatePowerUpDACRegisterDACH | Update (Power Up) DAC Register "DAC H"
Public property | WriteToAndUpdatePowerUpDACRegisterAllDACs | Write To And Update (Power Up) DAC Register "All DACs"
Public property | WriteToAndUpdatePowerUpDACRegisterDACA | Write To And Update (Power Up) DAC Register "DAC A"
Public property | WriteToAndUpdatePowerUpDACRegisterDACB | Write To And Update (Power Up) DAC Register "DAC B"
Public property | WriteToAndUpdatePowerUpDACRegisterDACC | Write To And Update (Power Up) DAC Register "DAC C"
Public property | WriteToAndUpdatePowerUpDACRegisterDACD | Write To And Update (Power Up) DAC Register "DAC D"
Public property | WriteToAndUpdatePowerUpDACRegisterDACE | Write To And Update (Power Up) DAC Register "DAC E"
Public property | WriteToAndUpdatePowerUpDACRegisterDACF | Write To And Update (Power Up) DAC Register "DAC F"
Public property | WriteToAndUpdatePowerUpDACRegisterDACG | Write To And Update (Power Up) DAC Register "DAC G"
Public property | WriteToAndUpdatePowerUpDACRegisterDACH | Write To And Update (Power Up) DAC Register "DAC H"
Public property | WriteToInputRegisterAllDACs | Write To Input Register "All DACs"
Public property | WriteToInputRegisterAllDACsUpdatePowerUpAll | Write To Input Register "All DACs", Update (Power Up) All
Public property | WriteToInputRegisterDACA | Write To Input Register "DAC A"
Public property | WriteToInputRegisterDACAUpdatePowerUpAll | Write To Input Register "DAC A", Update (Power Up) All
Public property | WriteToInputRegisterDACB | Write To Input Register "DAC B"
Public property | WriteToInputRegisterDACBUpdatePowerUpAll | Write To Input Register "DAC B", Update (Power Up) All
Public property | WriteToInputRegisterDACC | Write To Input Register "DAC C"
Public property | WriteToInputRegisterDACCUpdatePowerUpAll | Write To Input Register "DAC C", Update (Power Up) All
Public property | WriteToInputRegisterDACD | Write To Input Register "DAC D"
Public property | WriteToInputRegisterDACDUpdatePowerUpAll | Write To Input Register "DAC D", Update (Power Up) All
Public property | WriteToInputRegisterDACE | Write To Input Register "DAC E"
Public property | WriteToInputRegisterDACEUpdatePowerUpAll | Write To Input Register "DAC E", Update (Power Up) All
Public property | WriteToInputRegisterDACF | Write To Input Register "DAC F"
Public property | WriteToInputRegisterDACFUpdatePowerUpAll | Write To Input Register "DAC F", Update (Power Up) All
Public property | WriteToInputRegisterDACG | Write To Input Register "DAC G"
Public property | WriteToInputRegisterDACGUpdatePowerUpAll | Write To Input Register "DAC G", Update (Power Up) All
Public property | WriteToInputRegisterDACH | Write To Input Register "DAC H"
Public property | WriteToInputRegisterDACHUpdatePowerUpAll | Write To Input Register "DAC H", Update (Power Up) All
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PowerDownAllDACs | Power Down "All DACs"
Public method | PowerDownChipAllDACsAndReferences | Power Down Chip (All DACs and References)
Public method | PowerDownDACA | Power Down "DAC A"
Public method | PowerDownDACB | Power Down "DAC B"
Public method | PowerDownDACC | Power Down "DAC C"
Public method | PowerDownDACD | Power Down "DAC D"
Public method | PowerDownDACE | Power Down "DAC E"
Public method | PowerDownDACF | Power Down "DAC F"
Public method | PowerDownDACG | Power Down "DAC G"
Public method | PowerDownDACH | Power Down "DAC H"
Public method | SelectExternalReferencePowerDownInternalReference | Select External Reference (Power Down Internal Reference)
Public method | SelectInternalReferencePowerUpReference | Select Internal Reference (Power Up Reference)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Octal 8-Bit I2C VOUT DACs with 10ppm/°C Reference
See Also

Reference

telos.Ird.LinearTechnology Namespace


Ltc26378 Constructor

Constructor

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ltc26378(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ltc26378(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ltc26378

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378 Properties

The Ltc26378 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | UpdatePowerUpDACRegisterAllDACs | Update (Power Up) DAC Register "All DACs"
Public property | UpdatePowerUpDACRegisterDACA | Update (Power Up) DAC Register "DAC A"
Public property | UpdatePowerUpDACRegisterDACB | Update (Power Up) DAC Register "DAC B"
Public property | UpdatePowerUpDACRegisterDACC | Update (Power Up) DAC Register "DAC C"
Public property | UpdatePowerUpDACRegisterDACD | Update (Power Up) DAC Register "DAC D"
Public property | UpdatePowerUpDACRegisterDACE | Update (Power Up) DAC Register "DAC E"
Public property | UpdatePowerUpDACRegisterDACF | Update (Power Up) DAC Register "DAC F"
Public property | UpdatePowerUpDACRegisterDACG | Update (Power Up) DAC Register "DAC G"
Public property | UpdatePowerUpDACRegisterDACH | Update (Power Up) DAC Register "DAC H"
Public property | WriteToAndUpdatePowerUpDACRegisterAllDACs | Write To And Update (Power Up) DAC Register "All DACs"
Public property | WriteToAndUpdatePowerUpDACRegisterDACA | Write To And Update (Power Up) DAC Register "DAC A"
Public property | WriteToAndUpdatePowerUpDACRegisterDACB | Write To And Update (Power Up) DAC Register "DAC B"
Public property | WriteToAndUpdatePowerUpDACRegisterDACC | Write To And Update (Power Up) DAC Register "DAC C"
Public property | WriteToAndUpdatePowerUpDACRegisterDACD | Write To And Update (Power Up) DAC Register "DAC D"
Public property | WriteToAndUpdatePowerUpDACRegisterDACE | Write To And Update (Power Up) DAC Register "DAC E"
Public property | WriteToAndUpdatePowerUpDACRegisterDACF | Write To And Update (Power Up) DAC Register "DAC F"
Public property | WriteToAndUpdatePowerUpDACRegisterDACG | Write To And Update (Power Up) DAC Register "DAC G"
Public property | WriteToAndUpdatePowerUpDACRegisterDACH | Write To And Update (Power Up) DAC Register "DAC H"
Public property | WriteToInputRegisterAllDACs | Write To Input Register "All DACs"
Public property | WriteToInputRegisterAllDACsUpdatePowerUpAll | Write To Input Register "All DACs", Update (Power Up) All
Public property | WriteToInputRegisterDACA | Write To Input Register "DAC A"
Public property | WriteToInputRegisterDACAUpdatePowerUpAll | Write To Input Register "DAC A", Update (Power Up) All
Public property | WriteToInputRegisterDACB | Write To Input Register "DAC B"
Public property | WriteToInputRegisterDACBUpdatePowerUpAll | Write To Input Register "DAC B", Update (Power Up) All
Public property | WriteToInputRegisterDACC | Write To Input Register "DAC C"
Public property | WriteToInputRegisterDACCUpdatePowerUpAll | Write To Input Register "DAC C", Update (Power Up) All
Public property | WriteToInputRegisterDACD | Write To Input Register "DAC D"
Public property | WriteToInputRegisterDACDUpdatePowerUpAll | Write To Input Register "DAC D", Update (Power Up) All
Public property | WriteToInputRegisterDACE | Write To Input Register "DAC E"
Public property | WriteToInputRegisterDACEUpdatePowerUpAll | Write To Input Register "DAC E", Update (Power Up) All
Public property | WriteToInputRegisterDACF | Write To Input Register "DAC F"
Public property | WriteToInputRegisterDACFUpdatePowerUpAll | Write To Input Register "DAC F", Update (Power Up) All
Public property | WriteToInputRegisterDACG | Write To Input Register "DAC G"
Public property | WriteToInputRegisterDACGUpdatePowerUpAll | Write To Input Register "DAC G", Update (Power Up) All
Public property | WriteToInputRegisterDACH | Write To Input Register "DAC H"
Public property | WriteToInputRegisterDACHUpdatePowerUpAll | Write To Input Register "DAC H", Update (Power Up) All
Top
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.AutoFlush Property

IRD

Ltc26378AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.UpdatePowerUpDACRegisterAllDACs Property

IRD

Ltc26378UpdatePowerUpDACRegisterAllDACs Property

Update (Power Up) DAC Register "All DACs"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte UpdatePowerUpDACRegisterAllDACs { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterAllDACs As Byte
    Set
public:
property unsigned char UpdatePowerUpDACRegisterAllDACs {
    void set (unsigned char value);
}
member UpdatePowerUpDACRegisterAllDACs : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.UpdatePowerUpDACRegisterDACA Property

IRD

Ltc26378UpdatePowerUpDACRegisterDACA Property

Update (Power Up) DAC Register "DAC A"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte UpdatePowerUpDACRegisterDACA { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACA As Byte
    Set
public:
property unsigned char UpdatePowerUpDACRegisterDACA {
    void set (unsigned char value);
}
member UpdatePowerUpDACRegisterDACA : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.UpdatePowerUpDACRegisterDACB Property

IRD

Ltc26378UpdatePowerUpDACRegisterDACB Property

Update (Power Up) DAC Register "DAC B"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte UpdatePowerUpDACRegisterDACB { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACB As Byte
    Set
public:
property unsigned char UpdatePowerUpDACRegisterDACB {
    void set (unsigned char value);
}
member UpdatePowerUpDACRegisterDACB : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.UpdatePowerUpDACRegisterDACC Property

IRD

Ltc26378UpdatePowerUpDACRegisterDACC Property

Update (Power Up) DAC Register "DAC C"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte UpdatePowerUpDACRegisterDACC { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACC As Byte
    Set
public:
property unsigned char UpdatePowerUpDACRegisterDACC {
    void set (unsigned char value);
}
member UpdatePowerUpDACRegisterDACC : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.UpdatePowerUpDACRegisterDACD Property

IRD

Ltc26378UpdatePowerUpDACRegisterDACD Property

Update (Power Up) DAC Register "DAC D"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte UpdatePowerUpDACRegisterDACD { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACD As Byte
    Set
public:
property unsigned char UpdatePowerUpDACRegisterDACD {
    void set (unsigned char value);
}
member UpdatePowerUpDACRegisterDACD : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.UpdatePowerUpDACRegisterDACE Property

IRD

Ltc26378UpdatePowerUpDACRegisterDACE Property

Update (Power Up) DAC Register "DAC E"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte UpdatePowerUpDACRegisterDACE { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACE As Byte
    Set
public:
property unsigned char UpdatePowerUpDACRegisterDACE {
    void set (unsigned char value);
}
member UpdatePowerUpDACRegisterDACE : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.UpdatePowerUpDACRegisterDACF Property

IRD

Ltc26378UpdatePowerUpDACRegisterDACF Property

Update (Power Up) DAC Register "DAC F"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte UpdatePowerUpDACRegisterDACF { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACF As Byte
    Set
public:
property unsigned char UpdatePowerUpDACRegisterDACF {
    void set (unsigned char value);
}
member UpdatePowerUpDACRegisterDACF : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.UpdatePowerUpDACRegisterDACG Property

IRD

Ltc26378UpdatePowerUpDACRegisterDACG Property

Update (Power Up) DAC Register "DAC G"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte UpdatePowerUpDACRegisterDACG { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACG As Byte
    Set
public:
property unsigned char UpdatePowerUpDACRegisterDACG {
    void set (unsigned char value);
}
member UpdatePowerUpDACRegisterDACG : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.UpdatePowerUpDACRegisterDACH Property

IRD

Ltc26378UpdatePowerUpDACRegisterDACH Property

Update (Power Up) DAC Register "DAC H"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte UpdatePowerUpDACRegisterDACH { set; }
Public WriteOnly Property UpdatePowerUpDACRegisterDACH As Byte
    Set
public:
property unsigned char UpdatePowerUpDACRegisterDACH {
    void set (unsigned char value);
}
member UpdatePowerUpDACRegisterDACH : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToAndUpdatePowerUpDACRegisterAllDACs Property

IRD

Ltc26378WriteToAndUpdatePowerUpDACRegisterAllDACs Property

Write To And Update (Power Up) DAC Register "All DACs"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToAndUpdatePowerUpDACRegisterAllDACs { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterAllDACs As Byte
    Set
public:
property unsigned char WriteToAndUpdatePowerUpDACRegisterAllDACs {
    void set (unsigned char value);
}
member WriteToAndUpdatePowerUpDACRegisterAllDACs : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToAndUpdatePowerUpDACRegisterDACA Property

IRD

Ltc26378WriteToAndUpdatePowerUpDACRegisterDACA Property

Write To And Update (Power Up) DAC Register "DAC A"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToAndUpdatePowerUpDACRegisterDACA { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACA As Byte
    Set
public:
property unsigned char WriteToAndUpdatePowerUpDACRegisterDACA {
    void set (unsigned char value);
}
member WriteToAndUpdatePowerUpDACRegisterDACA : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToAndUpdatePowerUpDACRegisterDACB Property

IRD

Ltc26378WriteToAndUpdatePowerUpDACRegisterDACB Property

Write To And Update (Power Up) DAC Register "DAC B"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToAndUpdatePowerUpDACRegisterDACB { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACB As Byte
    Set
public:
property unsigned char WriteToAndUpdatePowerUpDACRegisterDACB {
    void set (unsigned char value);
}
member WriteToAndUpdatePowerUpDACRegisterDACB : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToAndUpdatePowerUpDACRegisterDACC Property

IRD

Ltc26378WriteToAndUpdatePowerUpDACRegisterDACC Property

Write To And Update (Power Up) DAC Register "DAC C"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToAndUpdatePowerUpDACRegisterDACC { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACC As Byte
    Set
public:
property unsigned char WriteToAndUpdatePowerUpDACRegisterDACC {
    void set (unsigned char value);
}
member WriteToAndUpdatePowerUpDACRegisterDACC : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToAndUpdatePowerUpDACRegisterDACD Property

IRD

Ltc26378WriteToAndUpdatePowerUpDACRegisterDACD Property

Write To And Update (Power Up) DAC Register "DAC D"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToAndUpdatePowerUpDACRegisterDACD { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACD As Byte
    Set
public:
property unsigned char WriteToAndUpdatePowerUpDACRegisterDACD {
    void set (unsigned char value);
}
member WriteToAndUpdatePowerUpDACRegisterDACD : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToAndUpdatePowerUpDACRegisterDACE Property

IRD

Ltc26378WriteToAndUpdatePowerUpDACRegisterDACE Property

Write To And Update (Power Up) DAC Register "DAC E"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToAndUpdatePowerUpDACRegisterDACE { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACE As Byte
    Set
public:
property unsigned char WriteToAndUpdatePowerUpDACRegisterDACE {
    void set (unsigned char value);
}
member WriteToAndUpdatePowerUpDACRegisterDACE : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToAndUpdatePowerUpDACRegisterDACF Property

IRD

Ltc26378WriteToAndUpdatePowerUpDACRegisterDACF Property

Write To And Update (Power Up) DAC Register "DAC F"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToAndUpdatePowerUpDACRegisterDACF { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACF As Byte
    Set
public:
property unsigned char WriteToAndUpdatePowerUpDACRegisterDACF {
    void set (unsigned char value);
}
member WriteToAndUpdatePowerUpDACRegisterDACF : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToAndUpdatePowerUpDACRegisterDACG Property

IRD

Ltc26378WriteToAndUpdatePowerUpDACRegisterDACG Property

Write To And Update (Power Up) DAC Register "DAC G"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToAndUpdatePowerUpDACRegisterDACG { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACG As Byte
    Set
public:
property unsigned char WriteToAndUpdatePowerUpDACRegisterDACG {
    void set (unsigned char value);
}
member WriteToAndUpdatePowerUpDACRegisterDACG : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToAndUpdatePowerUpDACRegisterDACH Property

IRD

Ltc26378WriteToAndUpdatePowerUpDACRegisterDACH Property

Write To And Update (Power Up) DAC Register "DAC H"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToAndUpdatePowerUpDACRegisterDACH { set; }
Public WriteOnly Property WriteToAndUpdatePowerUpDACRegisterDACH As Byte
    Set
public:
property unsigned char WriteToAndUpdatePowerUpDACRegisterDACH {
    void set (unsigned char value);
}
member WriteToAndUpdatePowerUpDACRegisterDACH : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToInputRegisterAllDACs Property

IRD

Ltc26378WriteToInputRegisterAllDACs Property

Write To Input Register "All DACs"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToInputRegisterAllDACs { set; }
Public WriteOnly Property WriteToInputRegisterAllDACs As Byte
    Set
public:
property unsigned char WriteToInputRegisterAllDACs {
    void set (unsigned char value);
}
member WriteToInputRegisterAllDACs : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToInputRegisterAllDACsUpdatePowerUpAll Property

IRD

Ltc26378WriteToInputRegisterAllDACsUpdatePowerUpAll Property

Write To Input Register "All DACs", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToInputRegisterAllDACsUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterAllDACsUpdatePowerUpAll As Byte
    Set
public:
property unsigned char WriteToInputRegisterAllDACsUpdatePowerUpAll {
    void set (unsigned char value);
}
member WriteToInputRegisterAllDACsUpdatePowerUpAll : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToInputRegisterDACA Property

IRD

Ltc26378WriteToInputRegisterDACA Property

Write To Input Register "DAC A"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToInputRegisterDACA { set; }
Public WriteOnly Property WriteToInputRegisterDACA As Byte
    Set
public:
property unsigned char WriteToInputRegisterDACA {
    void set (unsigned char value);
}
member WriteToInputRegisterDACA : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToInputRegisterDACAUpdatePowerUpAll Property

IRD

Ltc26378WriteToInputRegisterDACAUpdatePowerUpAll Property

Write To Input Register "DAC A", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToInputRegisterDACAUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACAUpdatePowerUpAll As Byte
    Set
public:
property unsigned char WriteToInputRegisterDACAUpdatePowerUpAll {
    void set (unsigned char value);
}
member WriteToInputRegisterDACAUpdatePowerUpAll : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToInputRegisterDACB Property

IRD

Ltc26378WriteToInputRegisterDACB Property

Write To Input Register "DAC B"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToInputRegisterDACB { set; }
Public WriteOnly Property WriteToInputRegisterDACB As Byte
    Set
public:
property unsigned char WriteToInputRegisterDACB {
    void set (unsigned char value);
}
member WriteToInputRegisterDACB : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToInputRegisterDACBUpdatePowerUpAll Property

IRD

Ltc26378WriteToInputRegisterDACBUpdatePowerUpAll Property

Write To Input Register "DAC B", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToInputRegisterDACBUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACBUpdatePowerUpAll As Byte
    Set
public:
property unsigned char WriteToInputRegisterDACBUpdatePowerUpAll {
    void set (unsigned char value);
}
member WriteToInputRegisterDACBUpdatePowerUpAll : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToInputRegisterDACC Property

IRD

Ltc26378WriteToInputRegisterDACC Property

Write To Input Register "DAC C"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToInputRegisterDACC { set; }
Public WriteOnly Property WriteToInputRegisterDACC As Byte
    Set
public:
property unsigned char WriteToInputRegisterDACC {
    void set (unsigned char value);
}
member WriteToInputRegisterDACC : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToInputRegisterDACCUpdatePowerUpAll Property

IRD

Ltc26378WriteToInputRegisterDACCUpdatePowerUpAll Property

Write To Input Register "DAC C", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToInputRegisterDACCUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACCUpdatePowerUpAll As Byte
    Set
public:
property unsigned char WriteToInputRegisterDACCUpdatePowerUpAll {
    void set (unsigned char value);
}
member WriteToInputRegisterDACCUpdatePowerUpAll : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToInputRegisterDACD Property

IRD

Ltc26378WriteToInputRegisterDACD Property

Write To Input Register "DAC D"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToInputRegisterDACD { set; }
Public WriteOnly Property WriteToInputRegisterDACD As Byte
    Set
public:
property unsigned char WriteToInputRegisterDACD {
    void set (unsigned char value);
}
member WriteToInputRegisterDACD : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToInputRegisterDACDUpdatePowerUpAll Property

IRD

Ltc26378WriteToInputRegisterDACDUpdatePowerUpAll Property

Write To Input Register "DAC D", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToInputRegisterDACDUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACDUpdatePowerUpAll As Byte
    Set
public:
property unsigned char WriteToInputRegisterDACDUpdatePowerUpAll {
    void set (unsigned char value);
}
member WriteToInputRegisterDACDUpdatePowerUpAll : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToInputRegisterDACE Property

IRD

Ltc26378WriteToInputRegisterDACE Property

Write To Input Register "DAC E"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToInputRegisterDACE { set; }
Public WriteOnly Property WriteToInputRegisterDACE As Byte
    Set
public:
property unsigned char WriteToInputRegisterDACE {
    void set (unsigned char value);
}
member WriteToInputRegisterDACE : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToInputRegisterDACEUpdatePowerUpAll Property

IRD

Ltc26378WriteToInputRegisterDACEUpdatePowerUpAll Property

Write To Input Register "DAC E", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToInputRegisterDACEUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACEUpdatePowerUpAll As Byte
    Set
public:
property unsigned char WriteToInputRegisterDACEUpdatePowerUpAll {
    void set (unsigned char value);
}
member WriteToInputRegisterDACEUpdatePowerUpAll : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToInputRegisterDACF Property

IRD

Ltc26378WriteToInputRegisterDACF Property

Write To Input Register "DAC F"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToInputRegisterDACF { set; }
Public WriteOnly Property WriteToInputRegisterDACF As Byte
    Set
public:
property unsigned char WriteToInputRegisterDACF {
    void set (unsigned char value);
}
member WriteToInputRegisterDACF : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToInputRegisterDACFUpdatePowerUpAll Property

IRD

Ltc26378WriteToInputRegisterDACFUpdatePowerUpAll Property

Write To Input Register "DAC F", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToInputRegisterDACFUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACFUpdatePowerUpAll As Byte
    Set
public:
property unsigned char WriteToInputRegisterDACFUpdatePowerUpAll {
    void set (unsigned char value);
}
member WriteToInputRegisterDACFUpdatePowerUpAll : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToInputRegisterDACG Property

IRD

Ltc26378WriteToInputRegisterDACG Property

Write To Input Register "DAC G"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToInputRegisterDACG { set; }
Public WriteOnly Property WriteToInputRegisterDACG As Byte
    Set
public:
property unsigned char WriteToInputRegisterDACG {
    void set (unsigned char value);
}
member WriteToInputRegisterDACG : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToInputRegisterDACGUpdatePowerUpAll Property

IRD

Ltc26378WriteToInputRegisterDACGUpdatePowerUpAll Property

Write To Input Register "DAC G", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToInputRegisterDACGUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACGUpdatePowerUpAll As Byte
    Set
public:
property unsigned char WriteToInputRegisterDACGUpdatePowerUpAll {
    void set (unsigned char value);
}
member WriteToInputRegisterDACGUpdatePowerUpAll : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToInputRegisterDACH Property

IRD

Ltc26378WriteToInputRegisterDACH Property

Write To Input Register "DAC H"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToInputRegisterDACH { set; }
Public WriteOnly Property WriteToInputRegisterDACH As Byte
    Set
public:
property unsigned char WriteToInputRegisterDACH {
    void set (unsigned char value);
}
member WriteToInputRegisterDACH : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.WriteToInputRegisterDACHUpdatePowerUpAll Property

IRD

Ltc26378WriteToInputRegisterDACHUpdatePowerUpAll Property

Write To Input Register "DAC H", Update (Power Up) All

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteToInputRegisterDACHUpdatePowerUpAll { set; }
Public WriteOnly Property WriteToInputRegisterDACHUpdatePowerUpAll As Byte
    Set
public:
property unsigned char WriteToInputRegisterDACHUpdatePowerUpAll {
    void set (unsigned char value);
}
member WriteToInputRegisterDACHUpdatePowerUpAll : byte with set

Property Value

Type: Byte
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378 Methods

The Ltc26378 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PowerDownAllDACs | Power Down "All DACs"
Public method | PowerDownChipAllDACsAndReferences | Power Down Chip (All DACs and References)
Public method | PowerDownDACA | Power Down "DAC A"
Public method | PowerDownDACB | Power Down "DAC B"
Public method | PowerDownDACC | Power Down "DAC C"
Public method | PowerDownDACD | Power Down "DAC D"
Public method | PowerDownDACE | Power Down "DAC E"
Public method | PowerDownDACF | Power Down "DAC F"
Public method | PowerDownDACG | Power Down "DAC G"
Public method | PowerDownDACH | Power Down "DAC H"
Public method | SelectExternalReferencePowerDownInternalReference | Select External Reference (Power Down Internal Reference)
Public method | SelectInternalReferencePowerUpReference | Select Internal Reference (Power Up Reference)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.Flush Method

IRD

Ltc26378Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.PowerDownAllDACs Method

IRD

Ltc26378PowerDownAllDACs Method

Power Down "All DACs"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownAllDACs()
Public Sub PowerDownAllDACs
public:
void PowerDownAllDACs()
member PowerDownAllDACs : unit -> unit
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.PowerDownChipAllDACsAndReferences Method

IRD

Ltc26378PowerDownChipAllDACsAndReferences Method

Power Down Chip (All DACs and References)

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownChipAllDACsAndReferences()
Public Sub PowerDownChipAllDACsAndReferences
public:
void PowerDownChipAllDACsAndReferences()
member PowerDownChipAllDACsAndReferences : unit -> unit
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.PowerDownDACA Method

IRD

Ltc26378PowerDownDACA Method

Power Down "DAC A"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACA()
Public Sub PowerDownDACA
public:
void PowerDownDACA()
member PowerDownDACA : unit -> unit
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.PowerDownDACB Method

IRD

Ltc26378PowerDownDACB Method

Power Down "DAC B"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACB()
Public Sub PowerDownDACB
public:
void PowerDownDACB()
member PowerDownDACB : unit -> unit
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.PowerDownDACC Method

IRD

Ltc26378PowerDownDACC Method

Power Down "DAC C"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACC()
Public Sub PowerDownDACC
public:
void PowerDownDACC()
member PowerDownDACC : unit -> unit
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.PowerDownDACD Method

IRD

Ltc26378PowerDownDACD Method

Power Down "DAC D"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACD()
Public Sub PowerDownDACD
public:
void PowerDownDACD()
member PowerDownDACD : unit -> unit
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.PowerDownDACE Method

IRD

Ltc26378PowerDownDACE Method

Power Down "DAC E"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACE()
Public Sub PowerDownDACE
public:
void PowerDownDACE()
member PowerDownDACE : unit -> unit
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.PowerDownDACF Method

IRD

Ltc26378PowerDownDACF Method

Power Down "DAC F"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACF()
Public Sub PowerDownDACF
public:
void PowerDownDACF()
member PowerDownDACF : unit -> unit
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.PowerDownDACG Method

IRD

Ltc26378PowerDownDACG Method

Power Down "DAC G"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACG()
Public Sub PowerDownDACG
public:
void PowerDownDACG()
member PowerDownDACG : unit -> unit
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.PowerDownDACH Method

IRD

Ltc26378PowerDownDACH Method

Power Down "DAC H"

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PowerDownDACH()
Public Sub PowerDownDACH
public:
void PowerDownDACH()
member PowerDownDACH : unit -> unit
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.SelectExternalReferencePowerDownInternalReference Method

IRD

Ltc26378SelectExternalReferencePowerDownInternalReference Method

Select External Reference (Power Down Internal Reference)

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectExternalReferencePowerDownInternalReference()
Public Sub SelectExternalReferencePowerDownInternalReference
public:
void SelectExternalReferencePowerDownInternalReference()
member SelectExternalReferencePowerDownInternalReference : unit -> unit
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc26378.SelectInternalReferencePowerUpReference Method

IRD

Ltc26378SelectInternalReferencePowerUpReference Method

Select Internal Reference (Power Up Reference)

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectInternalReferencePowerUpReference()
Public Sub SelectInternalReferencePowerUpReference
public:
void SelectInternalReferencePowerUpReference()
member SelectInternalReferencePowerUpReference : unit -> unit
See Also

Reference

Ltc26378 Class
telos.Ird.LinearTechnology Namespace


Ltc3447 Class

Linear Technology: LTC 3447
Inheritance Hierarchy
SystemObject
telos.Ird.LinearTechnologyLtc3447

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ltc3447
Public Class Ltc3447
public ref class Ltc3447
type Ltc3447 =  class end

The Ltc3447 type exposes the following members.

Constructors
 | Name | Description
Public method | Ltc3447 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Burst | Burst
Public property | DAC | DAC
Public property | PGOOD | PGOOD
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Controllable Buck Regulator
See Also

Reference

telos.Ird.LinearTechnology Namespace


Ltc3447 Constructor

Constructor

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ltc3447(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ltc3447(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ltc3447

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ltc3447 Class
telos.Ird.LinearTechnology Namespace


Ltc3447 Properties

The Ltc3447 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Burst | Burst
Public property | DAC | DAC
Public property | PGOOD | PGOOD
Top
See Also

Reference

Ltc3447 Class
telos.Ird.LinearTechnology Namespace


Ltc3447.AutoFlush Property

IRD

Ltc3447AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ltc3447 Class
telos.Ird.LinearTechnology Namespace


Ltc3447.Burst Property

IRD

Ltc3447Burst Property

Burst

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ltc3447TYPIDDATA2 Burst { set; }
Public WriteOnly Property Burst As Ltc3447TYPIDDATA2
    Set
public:
property Ltc3447TYPIDDATA2 Burst {
    void set (Ltc3447TYPIDDATA2 value);
}
member Burst : Ltc3447TYPIDDATA2 with set

Property Value

Type: Ltc3447TYPIDDATA2
See Also

Reference

Ltc3447 Class
telos.Ird.LinearTechnology Namespace


Ltc3447.DAC Property

IRD

Ltc3447DAC Property

DAC

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ltc3447TYPIDDATA0 DAC { set; }
Public WriteOnly Property DAC As Ltc3447TYPIDDATA0
    Set
public:
property Ltc3447TYPIDDATA0 DAC {
    void set (Ltc3447TYPIDDATA0 value);
}
member DAC : Ltc3447TYPIDDATA0 with set

Property Value

Type: Ltc3447TYPIDDATA0
See Also

Reference

Ltc3447 Class
telos.Ird.LinearTechnology Namespace


Ltc3447.PGOOD Property

IRD

Ltc3447PGOOD Property

PGOOD

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ltc3447IDEnableDisable PGOOD { set; }
Public WriteOnly Property PGOOD As Ltc3447IDEnableDisable
    Set
public:
property Ltc3447IDEnableDisable PGOOD {
    void set (Ltc3447IDEnableDisable value);
}
member PGOOD : Ltc3447IDEnableDisable with set

Property Value

Type: Ltc3447IDEnableDisable
See Also

Reference

Ltc3447 Class
telos.Ird.LinearTechnology Namespace


Ltc3447 Methods

The Ltc3447 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ltc3447 Class
telos.Ird.LinearTechnology Namespace


Ltc3447.Flush Method

IRD

Ltc3447Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ltc3447 Class
telos.Ird.LinearTechnology Namespace


Ltc3447.IDEnableDisable Enumeration

IRD

Ltc3447IDEnableDisable Enumeration

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IDEnableDisable
Public Enumeration IDEnableDisable
public enum class IDEnableDisable
type IDEnableDisable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.LinearTechnology Namespace


Ltc3447.TYPIDDATA0 Enumeration

IRD

Ltc3447TYPIDDATA0 Enumeration

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDDATA0
Public Enumeration TYPIDDATA0
public enum class TYPIDDATA0
type TYPIDDATA0
Members
Member name | Value | Description
Value_0_69 | 0 | 0.69
Value_0_71 | 1 | 0.71
Value_0_73 | 2 | 0.73
Value_0_75 | 3 | 0.75
Value_0_78 | 4 | 0.78
Value_0_80 | 5 | 0.80
Value_0_82 | 6 | 0.82
Value_0_84 | 7 | 0.84
Value_0_86 | 8 | 0.86
Value_0_88 | 9 | 0.88
Value_0_91 | 10 | 0.91
Value_0_93 | 11 | 0.93
Value_0_95 | 12 | 0.95
Value_0_97 | 13 | 0.97
Value_0_99 | 14 | 0.99
Value_1_01 | 15 | 1.01
Value_1_04 | 16 | 1.04
Value_1_06 | 17 | 1.06
Value_1_08 | 18 | 1.08
Value_1_10 | 19 | 1.10
Value_1_12 | 20 | 1.12
Value_1_14 | 21 | 1.14
Value_1_17 | 22 | 1.17
Value_1_19 | 23 | 1.19
Value_1_21 | 24 | 1.21
Value_1_23 | 25 | 1.23
Value_1_25 | 26 | 1.25
Value_1_27 | 27 | 1.27
Value_1_29 | 28 | 1.29
Value_1_32 | 29 | 1.32
Value_1_34 | 30 | 1.34
Value_1_36 | 31 | 1.36
Value_1_38 | 32 | 1.38
Value_1_40 | 33 | 1.40
Value_1_42 | 34 | 1.42
Value_1_45 | 35 | 1.45
Value_1_47 | 36 | 1.47
Value_1_49 | 37 | 1.49
Value_1_51 | 38 | 1.51
Value_1_53 | 39 | 1.53
Value_1_55 | 40 | 1.55
Value_1_58 | 41 | 1.58
Value_1_60 | 42 | 1.60
Value_1_62 | 43 | 1.62
Value_1_64 | 44 | 1.64
Value_1_66 | 45 | 1.66
Value_1_68 | 46 | 1.68
Value_1_71 | 47 | 1.71
Value_1_73 | 48 | 1.73
Value_1_75 | 49 | 1.75
Value_1_77 | 50 | 1.77
Value_1_79 | 51 | 1.79
Value_1_81 | 52 | 1.81
Value_1_83 | 53 | 1.83
Value_1_86 | 54 | 1.86
Value_1_88 | 55 | 1.88
Value_1_90 | 56 | 1.90
Value_1_92 | 57 | 1.92
Value_1_94 | 58 | 1.94
Value_1_96 | 59 | 1.96
Value_1_99 | 60 | 1.99
Value_2_01 | 61 | 2.01
Value_2_03 | 62 | 2.03
Value_2_05 | 63 | 2.05
See Also

Reference

telos.Ird.LinearTechnology Namespace


Ltc3447.TYPIDDATA2 Enumeration

IRD

Ltc3447TYPIDDATA2 Enumeration

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDDATA2
Public Enumeration TYPIDDATA2
public enum class TYPIDDATA2
type TYPIDDATA2
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.LinearTechnology Namespace


Ltc4151 Class

Linear Technology: LTC 4151
Inheritance Hierarchy
SystemObject
telos.Ird.LinearTechnologyLtc4151

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ltc4151
Public Class Ltc4151
public ref class Ltc4151
type Ltc4151 =  class end

The Ltc4151 type exposes the following members.

Constructors
 | Name | Description
Public method | Ltc4151 | Constructor
Top
Properties
 | Name | Description
Public property | ADCChannelLabelForSnapshotMode | ADC Channel Label for Snapshot Mode
Public property | ADCSnapshotModeEnable | ADC Snapshot Mode Enable
Public property | ADINVoltageData | ADIN Voltage Data (unit: mV)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | PageReadWriteEnable | Page Read/Write Enable
Public property | SENSEADCBusyInSnapshotMode | SENSE: ADC Busy in Snapshot Mode
Public property | SENSEVoltageData | SENSE Voltage Data (unit: mV)
Public property | StuckBusTimerEnable | Stuck-Bus Timer Enable
Public property | TestModeEnable | Test Mode Enable
Public property | VINADCBusyInSnapshotMode | V_IN: ADC Busy in Snapshot Mode
Public property | VINVoltageData | V_IN Voltage Data (unit: V)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
High Voltage I2C Current and Voltage Monitor
See Also

Reference

telos.Ird.LinearTechnology Namespace


Ltc4151 Constructor

Constructor

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ltc4151(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ltc4151(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ltc4151

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ltc4151 Class
telos.Ird.LinearTechnology Namespace


Ltc4151 Properties

The Ltc4151 type exposes the following members.

Properties
 | Name | Description
Public property | ADCChannelLabelForSnapshotMode | ADC Channel Label for Snapshot Mode
Public property | ADCSnapshotModeEnable | ADC Snapshot Mode Enable
Public property | ADINVoltageData | ADIN Voltage Data (unit: mV)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | PageReadWriteEnable | Page Read/Write Enable
Public property | SENSEADCBusyInSnapshotMode | SENSE: ADC Busy in Snapshot Mode
Public property | SENSEVoltageData | SENSE Voltage Data (unit: mV)
Public property | StuckBusTimerEnable | Stuck-Bus Timer Enable
Public property | TestModeEnable | Test Mode Enable
Public property | VINADCBusyInSnapshotMode | V_IN: ADC Busy in Snapshot Mode
Public property | VINVoltageData | V_IN Voltage Data (unit: V)
Top
See Also

Reference

Ltc4151 Class
telos.Ird.LinearTechnology Namespace


Ltc4151.ADCChannelLabelForSnapshotMode Property

IRD

Ltc4151ADCChannelLabelForSnapshotMode Property

ADC Channel Label for Snapshot Mode

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ltc4151TypeControlAdcChannelLabelForSnapshotMode ADCChannelLabelForSnapshotMode { get; set; }
Public Property ADCChannelLabelForSnapshotMode As Ltc4151TypeControlAdcChannelLabelForSnapshotMode
    Get
    Set
public:
property Ltc4151TypeControlAdcChannelLabelForSnapshotMode ADCChannelLabelForSnapshotMode {
    Ltc4151TypeControlAdcChannelLabelForSnapshotMode get ();
    void set (Ltc4151TypeControlAdcChannelLabelForSnapshotMode value);
}
member ADCChannelLabelForSnapshotMode : Ltc4151TypeControlAdcChannelLabelForSnapshotMode with get, set

Property Value

Type: Ltc4151TypeControlAdcChannelLabelForSnapshotMode
See Also

Reference

Ltc4151 Class
telos.Ird.LinearTechnology Namespace


Ltc4151.ADCSnapshotModeEnable Property

IRD

Ltc4151ADCSnapshotModeEnable Property

ADC Snapshot Mode Enable

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ltc4151TypeControlAdcSnapshotModeEnabled ADCSnapshotModeEnable { get; set; }
Public Property ADCSnapshotModeEnable As Ltc4151TypeControlAdcSnapshotModeEnabled
    Get
    Set
public:
property Ltc4151TypeControlAdcSnapshotModeEnabled ADCSnapshotModeEnable {
    Ltc4151TypeControlAdcSnapshotModeEnabled get ();
    void set (Ltc4151TypeControlAdcSnapshotModeEnabled value);
}
member ADCSnapshotModeEnable : Ltc4151TypeControlAdcSnapshotModeEnabled with get, set

Property Value

Type: Ltc4151TypeControlAdcSnapshotModeEnabled
See Also

Reference

Ltc4151 Class
telos.Ird.LinearTechnology Namespace


Ltc4151.ADINVoltageData Property

IRD

Ltc4151ADINVoltageData Property

ADIN Voltage Data (unit: mV)

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ADINVoltageData { get; set; }
Public Property ADINVoltageData As Double
    Get
    Set
public:
property double ADINVoltageData {
    double get ();
    void set (double value);
}
member ADINVoltageData : float with get, set

Property Value

Type: Double
See Also

Reference

Ltc4151 Class
telos.Ird.LinearTechnology Namespace


Ltc4151.AutoFlush Property

IRD

Ltc4151AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ltc4151 Class
telos.Ird.LinearTechnology Namespace


Ltc4151.PageReadWriteEnable Property

IRD

Ltc4151PageReadWriteEnable Property

Page Read/Write Enable

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ltc4151TypeControlPageReadWriteEnable PageReadWriteEnable { get; set; }
Public Property PageReadWriteEnable As Ltc4151TypeControlPageReadWriteEnable
    Get
    Set
public:
property Ltc4151TypeControlPageReadWriteEnable PageReadWriteEnable {
    Ltc4151TypeControlPageReadWriteEnable get ();
    void set (Ltc4151TypeControlPageReadWriteEnable value);
}
member PageReadWriteEnable : Ltc4151TypeControlPageReadWriteEnable with get, set

Property Value

Type: Ltc4151TypeControlPageReadWriteEnable
See Also

Reference

Ltc4151 Class
telos.Ird.LinearTechnology Namespace


Ltc4151.SENSEADCBusyInSnapshotMode Property

IRD

Ltc4151SENSEADCBusyInSnapshotMode Property

SENSE: ADC Busy in Snapshot Mode

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ltc4151TypeSenseAdcBusy SENSEADCBusyInSnapshotMode { get; set; }
Public Property SENSEADCBusyInSnapshotMode As Ltc4151TypeSenseAdcBusy
    Get
    Set
public:
property Ltc4151TypeSenseAdcBusy SENSEADCBusyInSnapshotMode {
    Ltc4151TypeSenseAdcBusy get ();
    void set (Ltc4151TypeSenseAdcBusy value);
}
member SENSEADCBusyInSnapshotMode : Ltc4151TypeSenseAdcBusy with get, set

Property Value

Type: Ltc4151TypeSenseAdcBusy
See Also

Reference

Ltc4151 Class
telos.Ird.LinearTechnology Namespace


Ltc4151.SENSEVoltageData Property

IRD

Ltc4151SENSEVoltageData Property

SENSE Voltage Data (unit: mV)

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double SENSEVoltageData { get; set; }
Public Property SENSEVoltageData As Double
    Get
    Set
public:
property double SENSEVoltageData {
    double get ();
    void set (double value);
}
member SENSEVoltageData : float with get, set

Property Value

Type: Double
See Also

Reference

Ltc4151 Class
telos.Ird.LinearTechnology Namespace


Ltc4151.StuckBusTimerEnable Property

IRD

Ltc4151StuckBusTimerEnable Property

Stuck-Bus Timer Enable

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ltc4151TypeControlStuckBusTimerEnable StuckBusTimerEnable { get; set; }
Public Property StuckBusTimerEnable As Ltc4151TypeControlStuckBusTimerEnable
    Get
    Set
public:
property Ltc4151TypeControlStuckBusTimerEnable StuckBusTimerEnable {
    Ltc4151TypeControlStuckBusTimerEnable get ();
    void set (Ltc4151TypeControlStuckBusTimerEnable value);
}
member StuckBusTimerEnable : Ltc4151TypeControlStuckBusTimerEnable with get, set

Property Value

Type: Ltc4151TypeControlStuckBusTimerEnable
See Also

Reference

Ltc4151 Class
telos.Ird.LinearTechnology Namespace


Ltc4151.TestModeEnable Property

IRD

Ltc4151TestModeEnable Property

Test Mode Enable

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ltc4151TypeControlTestModeEnable TestModeEnable { get; set; }
Public Property TestModeEnable As Ltc4151TypeControlTestModeEnable
    Get
    Set
public:
property Ltc4151TypeControlTestModeEnable TestModeEnable {
    Ltc4151TypeControlTestModeEnable get ();
    void set (Ltc4151TypeControlTestModeEnable value);
}
member TestModeEnable : Ltc4151TypeControlTestModeEnable with get, set

Property Value

Type: Ltc4151TypeControlTestModeEnable
See Also

Reference

Ltc4151 Class
telos.Ird.LinearTechnology Namespace


Ltc4151.VINADCBusyInSnapshotMode Property

IRD

Ltc4151VINADCBusyInSnapshotMode Property

V_IN: ADC Busy in Snapshot Mode

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ltc4151TypeVinAdcBusy VINADCBusyInSnapshotMode { get; set; }
Public Property VINADCBusyInSnapshotMode As Ltc4151TypeVinAdcBusy
    Get
    Set
public:
property Ltc4151TypeVinAdcBusy VINADCBusyInSnapshotMode {
    Ltc4151TypeVinAdcBusy get ();
    void set (Ltc4151TypeVinAdcBusy value);
}
member VINADCBusyInSnapshotMode : Ltc4151TypeVinAdcBusy with get, set

Property Value

Type: Ltc4151TypeVinAdcBusy
See Also

Reference

Ltc4151 Class
telos.Ird.LinearTechnology Namespace


Ltc4151.VINVoltageData Property

IRD

Ltc4151VINVoltageData Property

V_IN Voltage Data (unit: V)

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VINVoltageData { get; set; }
Public Property VINVoltageData As Double
    Get
    Set
public:
property double VINVoltageData {
    double get ();
    void set (double value);
}
member VINVoltageData : float with get, set

Property Value

Type: Double
See Also

Reference

Ltc4151 Class
telos.Ird.LinearTechnology Namespace


Ltc4151 Methods

The Ltc4151 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ltc4151 Class
telos.Ird.LinearTechnology Namespace


Ltc4151.Flush Method

IRD

Ltc4151Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ltc4151 Class
telos.Ird.LinearTechnology Namespace


Ltc4151.TypeAdinAdcBusy Enumeration

IRD

Ltc4151TypeAdinAdcBusy Enumeration

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdinAdcBusy
Public Enumeration TypeAdinAdcBusy
public enum class TypeAdinAdcBusy
type TypeAdinAdcBusy
Members
Member name | Value | Description
ADINConversionCompleted | 0 | ADIN Conversion Completed
ADINBeingConverted | 1 | ADIN Being Converted
See Also

Reference

telos.Ird.LinearTechnology Namespace


Ltc4151.TypeControlAdcChannelLabelForSnapshotMode Enumeration

IRD

Ltc4151TypeControlAdcChannelLabelForSnapshotMode Enumeration

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlAdcChannelLabelForSnapshotMode
Public Enumeration TypeControlAdcChannelLabelForSnapshotMode
public enum class TypeControlAdcChannelLabelForSnapshotMode
type TypeControlAdcChannelLabelForSnapshotMode
Members
Member name | Value | Description
SENSE | 0 | SENSE
VIN | 1 | V_IN
ADIN | 2 | ADIN
See Also

Reference

telos.Ird.LinearTechnology Namespace


Ltc4151.TypeControlAdcSnapshotModeEnabled Enumeration

IRD

Ltc4151TypeControlAdcSnapshotModeEnabled Enumeration

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlAdcSnapshotModeEnabled
Public Enumeration TypeControlAdcSnapshotModeEnabled
public enum class TypeControlAdcSnapshotModeEnabled
type TypeControlAdcSnapshotModeEnabled
Members
Member name | Value | Description
SnapshotModeDisabled | 0 | Snapshot Mode: Disabled
SnapshotModeEnabled | 1 | Snapshot Mode: Enabled
See Also

Reference

telos.Ird.LinearTechnology Namespace


Ltc4151.TypeControlPageReadWriteEnable Enumeration

IRD

Ltc4151TypeControlPageReadWriteEnable Enumeration

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlPageReadWriteEnable
Public Enumeration TypeControlPageReadWriteEnable
public enum class TypeControlPageReadWriteEnable
type TypeControlPageReadWriteEnable
Members
Member name | Value | Description
I2CPageReadWriteDisabled | 0 | I2C Page Read/Write: Disabled
I2CPageReadWriteEnabled | 1 | I2C Page Read/Write: Enabled
See Also

Reference

telos.Ird.LinearTechnology Namespace


Ltc4151.TypeControlStuckBusTimerEnable Enumeration

IRD

Ltc4151TypeControlStuckBusTimerEnable Enumeration

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlStuckBusTimerEnable
Public Enumeration TypeControlStuckBusTimerEnable
public enum class TypeControlStuckBusTimerEnable
type TypeControlStuckBusTimerEnable
Members
Member name | Value | Description
StuckBusTimerDisabled | 0 | Stuck-Bus Timer: Disabled
StuckBusTimerEnabled | 1 | Stuck-Bus Timer: Enabled
See Also

Reference

telos.Ird.LinearTechnology Namespace


Ltc4151.TypeControlTestModeEnable Enumeration

IRD

Ltc4151TypeControlTestModeEnable Enumeration

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlTestModeEnable
Public Enumeration TypeControlTestModeEnable
public enum class TypeControlTestModeEnable
type TypeControlTestModeEnable
Members
Member name | Value | Description
TestModeDisabled | 0 | Test Mode: Disabled
TestModeEnabled | 1 | Test Mode: Enabled
See Also

Reference

telos.Ird.LinearTechnology Namespace


Ltc4151.TypeSenseAdcBusy Enumeration

IRD

Ltc4151TypeSenseAdcBusy Enumeration

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSenseAdcBusy
Public Enumeration TypeSenseAdcBusy
public enum class TypeSenseAdcBusy
type TypeSenseAdcBusy
Members
Member name | Value | Description
SENSEConversionCompleted | 0 | SENSE Conversion Completed
SENSEBeingConverted | 1 | SENSE Being Converted
See Also

Reference

telos.Ird.LinearTechnology Namespace


Ltc4151.TypeVinAdcBusy Enumeration

IRD

Ltc4151TypeVinAdcBusy Enumeration

Namespace: telos.Ird.LinearTechnology
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVinAdcBusy
Public Enumeration TypeVinAdcBusy
public enum class TypeVinAdcBusy
type TypeVinAdcBusy
Members
Member name | Value | Description
VINConversionCompleted | 0 | V_IN Conversion Completed
VINBeginConverted | 1 | V_IN Begin Converted
See Also

Reference

telos.Ird.LinearTechnology Namespace


telos.Ird.Maxim Namespace

Classes
 | Class | Description
Public class | Ds1307 | Maxim: DS 1307
Public class | Ds1337 | Maxim: DS 1337
Public class | Ds1338 | Maxim: DS 1338
Public class | Ds1339 | Maxim: DS 1339
Public class | Ds1340 | Maxim: DS 1340
Public class | Ds1371 | Maxim: DS 1371
Public class | Ds1374 | Maxim: DS 1374
Public class | Ds1375 | Maxim: DS 1375
Public class | Ds13881 | Maxim: DS 1388(RTC)
Public class | Ds13882 | Maxim: DS 1388(EEPROM Bank 1)
Public class | Ds13883 | Maxim: DS 1388(EEPROM Bank 2)
Public class | Ds1631 | Maxim: DS 1631 (A) / DS 1731
Public class | Ds1672 | Maxim: DS 1672
Public class | Ds1678 | Maxim: DS 1678
Public class | Ds1682 | Maxim: DS 1682
Public class | Ds1721 | Maxim: DS 1721
Public class | Ds1775 | Maxim: DS 1775
Public class | Ds1841 | Maxim: DS 1841
Public class | Ds2745 | Maxim: DS 2745
Public class | Ds2786 | Maxim: DS 2786
Public class | Ds28cm00 | Maxim: DS 28CM00
Public class | Ds3231 | Maxim: DS 3231
Public class | Ds75 | Maxim: DS 75
Public class | Max11801 | Maxim: MAX 11801
Public class | Max11803 | Maxim: MAX 11803
Public class | Max1617a | Maxim: MAX 1617 A
Public class | Max1619 | Maxim: MAX 1619
Public class | Max16805 | Maxim: MAX 16805
Public class | Max16806 | Maxim: MAX 16806
Public class | Max16826 | Maxim: MAX 16826
Public class | Max17061 | Maxim: MAX 17061
Public class | Max6625 | Maxim: MAX 6625
Public class | Max6626 | Maxim: MAX 6626
Public class | Max6633 | Maxim: MAX 6633
Public class | Max6634 | Maxim: MAX 6634
Public class | Max6635 | Maxim: MAX 6635
Public class | Max6646 | Maxim: MAX 6646
Public class | Max6647 | Maxim: MAX 6647
Public class | Max6649 | Maxim: MAX 6649
Public class | Max6660 | Maxim: MAX 6660
Public class | Max6680 | Maxim: MAX 6680 / MAX 6681
Public class | Max6690 | Maxim: MAX 6690
Public class | Max6900 | Maxim: MAX 6900
Public class | Max69096910 | Maxim: MAX 6909 / 6910
Public class | Max6917 | Maxim: MAX 6917
Public class | Max77387 | Maxim: MAX 77387
Public class | Max8821 | Maxim: MAX 8821
Public class | Max8831 | Maxim: MAX 8831
Public class | Max8834 | Maxim: MAX 8834Y / MAX 8834Z
Public class | Max8930 | Maxim: MAX 8930
Public class | Max9526 | Maxim: MAX 9526
Public class | Max9700197002 | Maxim: MAX 97001 / MAX 97002
Public class | Max9856 | Maxim: MAX 9856
Public class | Max9860 | Maxim: MAX 9860
Public class | Max9867 | Maxim: MAX 9867
Enumerations
 | Enumeration | Description
Public enumeration | Ds1307ChType |
Public enumeration | Ds1307H1224Type |
Public enumeration | Ds1307OutType |
Public enumeration | Ds1307RateType |
Public enumeration | Ds1307SqweType |
Public enumeration | Ds1337AlarmFlagType |
Public enumeration | Ds1337AlarmIntType |
Public enumeration | Ds1337AlarmMask1Type |
Public enumeration | Ds1337AlarmMask2Type |
Public enumeration | Ds1337DayDateType |
Public enumeration | Ds1337EnableOscType |
Public enumeration | Ds1337H1224Type |
Public enumeration | Ds1337InterruptControlType |
Public enumeration | Ds1337OscStopType |
Public enumeration | Ds1337SquareWaveType |
Public enumeration | Ds1338ChType |
Public enumeration | Ds1338H1224Type |
Public enumeration | Ds1338OsfType |
Public enumeration | Ds1338OutType |
Public enumeration | Ds1338RateType |
Public enumeration | Ds1338SqweType |
Public enumeration | Ds1339AlarmFlagType |
Public enumeration | Ds1339AlarmIntType |
Public enumeration | Ds1339AlarmMask1Type |
Public enumeration | Ds1339AlarmMask2Type |
Public enumeration | Ds1339BbsqiType |
Public enumeration | Ds1339DayDateType |
Public enumeration | Ds1339DiodeSelectType |
Public enumeration | Ds1339EnableOscType |
Public enumeration | Ds1339H1224Type |
Public enumeration | Ds1339InterruptControlType |
Public enumeration | Ds1339OscStopType |
Public enumeration | Ds1339ResistorType |
Public enumeration | Ds1339SquareWaveType |
Public enumeration | Ds1339TrickleType |
Public enumeration | Ds1340CalibrationSignType |
Public enumeration | Ds1340CenturyEnableType |
Public enumeration | Ds1340DiodeSelectType |
Public enumeration | Ds1340EnableOscType |
Public enumeration | Ds1340FreqTestType |
Public enumeration | Ds1340OscStopType |
Public enumeration | Ds1340OutputCtrlType |
Public enumeration | Ds1340ResistorType |
Public enumeration | Ds1340TrickleType |
Public enumeration | Ds1371ControlAintType |
Public enumeration | Ds1371ControlCountenaType |
Public enumeration | Ds1371ControlCountselType |
Public enumeration | Ds1371ControlIntType |
Public enumeration | Ds1371ControlOscenaType |
Public enumeration | Ds1371ControlWaveType |
Public enumeration | Ds1371StatusAlarmType |
Public enumeration | Ds1371StatusOscstopType |
Public enumeration | Ds1374AlarmIntType |
Public enumeration | Ds1374BbsqwType |
Public enumeration | Ds1374CounterEnableType |
Public enumeration | Ds1374CounterSelectType |
Public enumeration | Ds1374DiodeSelectType |
Public enumeration | Ds1374EnableOscType |
Public enumeration | Ds1374OscStopType |
Public enumeration | Ds1374ResistorType |
Public enumeration | Ds1374SquareWaveType |
Public enumeration | Ds1374StatusAlarmType |
Public enumeration | Ds1374TrickleType |
Public enumeration | Ds1374WatchdogResetType |
Public enumeration | Ds1375AlarmFlagType |
Public enumeration | Ds1375AlarmIntType |
Public enumeration | Ds1375AlarmMask1Type |
Public enumeration | Ds1375AlarmMask2Type |
Public enumeration | Ds1375ClockEnableType |
Public enumeration | Ds1375ClockSelectType |
Public enumeration | Ds1375DayDateType |
Public enumeration | Ds1375H1224Type |
Public enumeration | Ds1375InterruptControlType |
Public enumeration | Ds1375SquareWaveType |
Public enumeration | Ds13881AlarmFlagType |
Public enumeration | Ds13881ControlOscenaType |
Public enumeration | Ds13881DiodeSelectType |
Public enumeration | Ds13881H1224Type |
Public enumeration | Ds13881OscStopType |
Public enumeration | Ds13881ResistorType |
Public enumeration | Ds13881TrickleType |
Public enumeration | Ds13881WatchdogEnableType |
Public enumeration | Ds13881WatchdogResetType |
Public enumeration | Ds1631Config1shotType |
Public enumeration | Ds1631ConfigDoneType |
Public enumeration | Ds1631ConfigNvbType |
Public enumeration | Ds1631ConfigPolType |
Public enumeration | Ds1631ConfigResType |
Public enumeration | Ds1631ConfigThfType |
Public enumeration | Ds1631ConfigTlfType |
Public enumeration | Ds1672ControlOscenaType |
Public enumeration | Ds1672DiodeSelectType |
Public enumeration | Ds1672ResistorType |
Public enumeration | Ds1672TrickleType |
Public enumeration | Ds1678AlarmFlagType |
Public enumeration | Ds1678AlarmMaskType |
Public enumeration | Ds1678ClearEnableType |
Public enumeration | Ds1678ClearMemType |
Public enumeration | Ds1678DurationSelectType |
Public enumeration | Ds1678H1224Type |
Public enumeration | Ds1678LowBatType |
Public enumeration | Ds1678MemClearType |
Public enumeration | Ds1678MissionEnableType |
Public enumeration | Ds1678MissionProgressType |
Public enumeration | Ds1678OscEnableType |
Public enumeration | Ds1678RolloverFlagType |
Public enumeration | Ds1678RollOverType |
Public enumeration | Ds1678TriggerSelectType |
Public enumeration | Ds1682AlarmFlagType |
Public enumeration | Ds1682AlarmOutputType |
Public enumeration | Ds1682AlarmPolarityType |
Public enumeration | Ds1682CounterMsbType |
Public enumeration | Ds1682ResetEnableType |
Public enumeration | Ds1682WriteDisableType |
Public enumeration | Ds1682WriteMemoryType |
Public enumeration | Ds1721Config1shotType |
Public enumeration | Ds1721ConfigDoneType |
Public enumeration | Ds1721ConfigPolType |
Public enumeration | Ds1721ConfigResType |
Public enumeration | Ds1775ConfigConversionType |
Public enumeration | Ds1775ConfigFaultType |
Public enumeration | Ds1775ConfigOpModeType |
Public enumeration | Ds1775ConfigPolType |
Public enumeration | Ds1775ConfigShutdownType |
Public enumeration | Ds1841TypeControl0See |
Public enumeration | Ds1841TypeControl1Adder |
Public enumeration | Ds1841TypeControl1Update |
Public enumeration | Ds1841TypeControl2Lutar |
Public enumeration | Ds1841TypeControl2Wipe |
Public enumeration | Ds2745TypeStatusConfigNben |
Public enumeration | Ds2745TypeStatusConfigPio |
Public enumeration | Ds2745TypeStatusConfigPorf |
Public enumeration | Ds2745TypeStatusConfigSmod |
Public enumeration | Ds2786TypeCommandBit6 |
Public enumeration | Ds2786TypeCommandCopy |
Public enumeration | Ds2786TypeCommandPocv |
Public enumeration | Ds2786TypeCommandPor |
Public enumeration | Ds2786TypeCommandRcall |
Public enumeration | Ds2786TypeCommandSocv |
Public enumeration | Ds2786TypeOcvThresholdItemp |
Public enumeration | Ds2786TypeOcvThresholdLdis |
Public enumeration | Ds2786TypeOcvThresholdSmod |
Public enumeration | Ds2786TypeOcvThresholdVodis |
Public enumeration | Ds2786TypeStatusConfigAin0 |
Public enumeration | Ds2786TypeStatusConfigAin1 |
Public enumeration | Ds2786TypeStatusConfigItemp |
Public enumeration | Ds2786TypeStatusConfigLdis |
Public enumeration | Ds2786TypeStatusConfigPorf |
Public enumeration | Ds2786TypeStatusConfigSmod |
Public enumeration | Ds2786TypeStatusConfigVodis |
Public enumeration | Ds28cm00TypeControlCm |
Public enumeration | Ds3231AlarmFlagType |
Public enumeration | Ds3231AlarmIntType |
Public enumeration | Ds3231AlarmMask1Type |
Public enumeration | Ds3231AlarmMask2Type |
Public enumeration | Ds3231BbsqwType |
Public enumeration | Ds3231BusyType |
Public enumeration | Ds3231ConvertType |
Public enumeration | Ds3231DayDateType |
Public enumeration | Ds3231Enable32khzType |
Public enumeration | Ds3231EnableOscType |
Public enumeration | Ds3231H1224Type |
Public enumeration | Ds3231InterruptControlType |
Public enumeration | Ds3231OscStopType |
Public enumeration | Ds3231RateType |
Public enumeration | Ds75ConfigConversionType |
Public enumeration | Ds75ConfigFaultType |
Public enumeration | Ds75ConfigOpModeType |
Public enumeration | Ds75ConfigPolType |
Public enumeration | Ds75ConfigShutdownType |
Public enumeration | Max11801TypeAdcSamplingTime |
Public enumeration | Max11801TypeApertureConfiguration |
Public enumeration | Max11801TypeAutonomousMode |
Public enumeration | Max11801TypeAuxiliaryMeasurementAveragingSample |
Public enumeration | Max11801TypeAuxiliaryMeasurementDelay |
Public enumeration | Max11801TypeAuxiliaryMeasurementResolution |
Public enumeration | Max11801TypeAuxiliaryMeasurementSamplingTime |
Public enumeration | Max11801TypeDelayedConversionTime |
Public enumeration | Max11801TypeGeneralConfiguratuionEdgeIrq |
Public enumeration | Max11801TypeGeneralConfiguratuionEdgeTime |
Public enumeration | Max11801TypeGeneralConfiguratuionHold |
Public enumeration | Max11801TypeGeneralConfiguratuionMask |
Public enumeration | Max11801TypeGeneralConfiguratuionOdn |
Public enumeration | Max11801TypeGeneralConfiguratuionPuIrq |
Public enumeration | Max11801TypeGeneralConfiguratuionRtSel |
Public enumeration | Max11801TypeGeneralStatusAdc |
Public enumeration | Max11801TypeGeneralStatusCont |
Public enumeration | Max11801TypeGeneralStatusEdge |
Public enumeration | Max11801TypeGeneralStatusFifoInt |
Public enumeration | Max11801TypeGeneralStatusFifoOvr |
Public enumeration | Max11801TypeGeneralStatusLpm |
Public enumeration | Max11801TypeGeneralStatusScan |
Public enumeration | Max11801TypeGeneralStatusTdm |
Public enumeration | Max11801TypeMeasurementAveragingAvg |
Public enumeration | Max11801TypeMeasurementResolutionPwr |
Public enumeration | Max11801TypeMeasurementResolutionRes |
Public enumeration | Max11801TypeOperatingModeAperture |
Public enumeration | Max11801TypeOperatingModeAveraging |
Public enumeration | Max11801TypeOperatingModeConversion |
Public enumeration | Max11801TypeOperatingModePosition |
Public enumeration | Max11801TypeOperatingModePower |
Public enumeration | Max11801TypeOperatingModePressure |
Public enumeration | Max11801TypePanelSetupTimingPsu |
Public enumeration | Max11801TypeTouchDetectPullupPuf |
Public enumeration | Max11801TypeTouchDetectPullupPur |
Public enumeration | Max11803TypeAdcSamplingTime |
Public enumeration | Max11803TypeAuxiliaryMeasurementAveragingSample |
Public enumeration | Max11803TypeAuxiliaryMeasurementDelay |
Public enumeration | Max11803TypeAuxiliaryMeasurementResolution |
Public enumeration | Max11803TypeAuxiliaryMeasurementSamplingTime |
Public enumeration | Max11803TypeDelayedConversionTime |
Public enumeration | Max11803TypeGeneralConfiguratuionEdgeIrq |
Public enumeration | Max11803TypeGeneralConfiguratuionEdgeTime |
Public enumeration | Max11803TypeGeneralConfiguratuionHold |
Public enumeration | Max11803TypeGeneralConfiguratuionMask |
Public enumeration | Max11803TypeGeneralConfiguratuionOdn |
Public enumeration | Max11803TypeGeneralConfiguratuionPuIrq |
Public enumeration | Max11803TypeGeneralConfiguratuionRtSel |
Public enumeration | Max11803TypeGeneralStatusAdc |
Public enumeration | Max11803TypeGeneralStatusCont |
Public enumeration | Max11803TypeGeneralStatusEdge |
Public enumeration | Max11803TypeGeneralStatusFifoInt |
Public enumeration | Max11803TypeGeneralStatusFifoOvr |
Public enumeration | Max11803TypeGeneralStatusLpm |
Public enumeration | Max11803TypeGeneralStatusScan |
Public enumeration | Max11803TypeGeneralStatusTdm |
Public enumeration | Max11803TypeMeasurementAveragingAvg |
Public enumeration | Max11803TypeMeasurementResolutionPwr |
Public enumeration | Max11803TypeMeasurementResolutionRes |
Public enumeration | Max11803TypeOperatingModeAperture |
Public enumeration | Max11803TypeOperatingModeAveraging |
Public enumeration | Max11803TypeOperatingModeConversion |
Public enumeration | Max11803TypeOperatingModePosition |
Public enumeration | Max11803TypeOperatingModePower |
Public enumeration | Max11803TypeOperatingModePressure |
Public enumeration | Max11803TypePanelSetupTimingPsu |
Public enumeration | Max11803TypeTouchDetectPullupPuf |
Public enumeration | Max11803TypeTouchDetectPullupPur |
Public enumeration | Max1617aConfigMaskType |
Public enumeration | Max1617aConfigRunType |
Public enumeration | Max1617aConversionRateType |
Public enumeration | Max1617aStatusBusyType |
Public enumeration | Max1617aStatusLhighType |
Public enumeration | Max1617aStatusLlowType |
Public enumeration | Max1617aStatusOpenType |
Public enumeration | Max1617aStatusRhighType |
Public enumeration | Max1617aStatusRlowType |
Public enumeration | Max1619ConfigId1Type |
Public enumeration | Max1619ConfigId2Type |
Public enumeration | Max1619ConfigMaskType |
Public enumeration | Max1619ConfigPolType |
Public enumeration | Max1619ConfigProtType |
Public enumeration | Max1619ConfigRunType |
Public enumeration | Max1619ConversionRateType |
Public enumeration | Max1619StatusBusyType |
Public enumeration | Max1619StatusOpenType |
Public enumeration | Max1619StatusOverType |
Public enumeration | Max1619StatusRhighType |
Public enumeration | Max1619StatusRlowType |
Public enumeration | Max16805TypeBinningAdjustment |
Public enumeration | Max16805TypeLedCurrentFoldbackThreshold |
Public enumeration | Max16805TypePassword |
Public enumeration | Max16806TypeBinningAdjustment |
Public enumeration | Max16806TypeLedCurrentFoldbackThreshold |
Public enumeration | Max16806TypePassword |
Public enumeration | Max16806TypeRampPeak |
Public enumeration | Max16806TypeThermalFoldbackClampLevel |
Public enumeration | Max16806TypeThermalFoldbackKneePoint |
Public enumeration | Max16806TypeThermalFoldbackSlopeGain |
Public enumeration | Max16826TypeDeviceStandbyCommand |
Public enumeration | Max16826TypeFaultStatusLedString1 |
Public enumeration | Max16826TypeFaultStatusLedString2 |
Public enumeration | Max16826TypeFaultStatusLedString3 |
Public enumeration | Max16826TypeFaultStatusLedString4 |
Public enumeration | Max16826TypeFaultStatusOvervoltage |
Public enumeration | Max16826TypeLedString1ExternalFetAdcStatus |
Public enumeration | Max16826TypeLedString2ExternalFetAdcStatus |
Public enumeration | Max16826TypeLedString3ExternalFetAdcStatus |
Public enumeration | Max16826TypeLedString4ExternalFetAdcStatus |
Public enumeration | Max16826TypeLedStringCurrent |
Public enumeration | Max16826TypeSwitchingRegulator |
Public enumeration | Max17061TypeDeviceControlBacklightControl |
Public enumeration | Max17061TypeDeviceControlBrightnessMux |
Public enumeration | Max17061TypeDeviceControlPwmMode |
Public enumeration | Max17061TypeFaultStatusBacklightStatus |
Public enumeration | Max17061TypeFaultStatusFaultCondition |
Public enumeration | Max17061TypeFaultStatusInputOvercurrent |
Public enumeration | Max17061TypeFaultStatusMultiLedOutput |
Public enumeration | Max17061TypeFaultStatusSingleLedOutput |
Public enumeration | Max17061TypeFaultStatusThermalShutdown |
Public enumeration | Max17061TypeIdentificationLedPanel |
Public enumeration | Max17061TypeIdentificationManufacturerId |
Public enumeration | Max6625CompIntType |
Public enumeration | Max6625ConfigShutdownType |
Public enumeration | Max6625FaultQueueType |
Public enumeration | Max6625PolarityType |
Public enumeration | Max6626CompIntType |
Public enumeration | Max6626ConfigShutdownType |
Public enumeration | Max6626FaultQueueType |
Public enumeration | Max6626PolarityType |
Public enumeration | Max6633AlertType |
Public enumeration | Max6633CompIntType |
Public enumeration | Max6633FaultQueueType |
Public enumeration | Max6633OverTType |
Public enumeration | Max6633ShutdownType |
Public enumeration | Max6633SmbTimeoutType |
Public enumeration | Max6634AlertType |
Public enumeration | Max6634CompIntType |
Public enumeration | Max6634FaultQueueType |
Public enumeration | Max6634OverTType |
Public enumeration | Max6634ShutdownType |
Public enumeration | Max6634SmbTimeoutType |
Public enumeration | Max6634TFlagType |
Public enumeration | Max6635AlertType |
Public enumeration | Max6635CompIntType |
Public enumeration | Max6635FaultQueueType |
Public enumeration | Max6635OverTType |
Public enumeration | Max6635ShutdownType |
Public enumeration | Max6635SmbTimeoutType |
Public enumeration | Max6635TFlagType |
Public enumeration | Max6646BusyType |
Public enumeration | Max6646ConversionRateType |
Public enumeration | Max6646EotType |
Public enumeration | Max6646FaultQueueType |
Public enumeration | Max6646FaultType |
Public enumeration | Max6646IotType |
Public enumeration | Max6646LhighType |
Public enumeration | Max6646LlowType |
Public enumeration | Max6646MaskType |
Public enumeration | Max6646RhighType |
Public enumeration | Max6646RlowType |
Public enumeration | Max6646RunType |
Public enumeration | Max6646TempExType |
Public enumeration | Max6647BusyType |
Public enumeration | Max6647ConversionRateType |
Public enumeration | Max6647EotType |
Public enumeration | Max6647FaultQueueType |
Public enumeration | Max6647FaultType |
Public enumeration | Max6647IotType |
Public enumeration | Max6647LhighType |
Public enumeration | Max6647LlowType |
Public enumeration | Max6647MaskType |
Public enumeration | Max6647RhighType |
Public enumeration | Max6647RlowType |
Public enumeration | Max6647RunType |
Public enumeration | Max6647TempExType |
Public enumeration | Max6649BusyType |
Public enumeration | Max6649ConversionRateType |
Public enumeration | Max6649EotType |
Public enumeration | Max6649FaultQueueType |
Public enumeration | Max6649FaultType |
Public enumeration | Max6649IotType |
Public enumeration | Max6649LhighType |
Public enumeration | Max6649LlowType |
Public enumeration | Max6649MaskType |
Public enumeration | Max6649RhighType |
Public enumeration | Max6649RlowType |
Public enumeration | Max6649RunType |
Public enumeration | Max6649TempExType |
Public enumeration | Max6660ConfigAlertClearType |
Public enumeration | Max6660ConfigMaskType |
Public enumeration | Max6660ConfigOvertType |
Public enumeration | Max6660ConfigPolType |
Public enumeration | Max6660ConfigRunType |
Public enumeration | Max6660ConfigThermalLoopType |
Public enumeration | Max6660ConfigWpType |
Public enumeration | Max6660FanGainFeedbackType |
Public enumeration | Max6660FanGainModeType |
Public enumeration | Max6660FanGainSmbusType |
Public enumeration | Max6660FcrType |
Public enumeration | Max6660ModePrcType |
Public enumeration | Max6660StatusAlertType |
Public enumeration | Max6660StatusFanFailureType |
Public enumeration | Max6660StatusOpenType |
Public enumeration | Max6660StatusOverheatType |
Public enumeration | Max6660StatusOvertType |
Public enumeration | Max6660StatusRemoteHighType |
Public enumeration | Max6660StatusRemoteLowType |
Public enumeration | Max6660StatusScaleType |
Public enumeration | Max6680ConfigExtRangeType |
Public enumeration | Max6680ConfigExtResType |
Public enumeration | Max6680ConfigMaskType |
Public enumeration | Max6680ConfigResetType |
Public enumeration | Max6680ConfigRunType |
Public enumeration | Max6680ConfigSmbusType |
Public enumeration | Max6680ConfigSpnpType |
Public enumeration | Max6680ConversionRateType |
Public enumeration | Max6680StatusBusyType |
Public enumeration | Max6680StatusLhighType |
Public enumeration | Max6680StatusLlowType |
Public enumeration | Max6680StatusOpenType |
Public enumeration | Max6680StatusOveType |
Public enumeration | Max6680StatusOviType |
Public enumeration | Max6680StatusRhighType |
Public enumeration | Max6680StatusRlowType |
Public enumeration | Max6680TempExtType |
Public enumeration | Max6680TempType |
Public enumeration | Max6690ConfigEtaType |
Public enumeration | Max6690ConfigMaskType |
Public enumeration | Max6690ConfigPrcmType |
Public enumeration | Max6690ConfigRunType |
Public enumeration | Max6690ConversionRateType |
Public enumeration | Max6690StatusBusyType |
Public enumeration | Max6690StatusLhighType |
Public enumeration | Max6690StatusLlowType |
Public enumeration | Max6690StatusOpenType |
Public enumeration | Max6690StatusRhighType |
Public enumeration | Max6690StatusRlowType |
Public enumeration | Max6690TempExtType |
Public enumeration | Max6690TempType |
Public enumeration | Max6900H1224Type |
Public enumeration | Max6900ProtectType |
Public enumeration | Max69096910AlarmStatusType |
Public enumeration | Max69096910CrystalDetectType |
Public enumeration | Max69096910CrystalFailType |
Public enumeration | Max69096910DateEnableType |
Public enumeration | Max69096910DayEnableType |
Public enumeration | Max69096910DiodeSelectType |
Public enumeration | Max69096910H1224Type |
Public enumeration | Max69096910HourEnableType |
Public enumeration | Max69096910MinEnableType |
Public enumeration | Max69096910MonthEnableType |
Public enumeration | Max69096910PiezoTransducerType |
Public enumeration | Max69096910PiezoType |
Public enumeration | Max69096910ProtectType |
Public enumeration | Max69096910ResistorType |
Public enumeration | Max69096910SecEnableType |
Public enumeration | Max69096910TrickleType |
Public enumeration | Max69096910WatchdogEnableType |
Public enumeration | Max69096910WatchdogTimeoutType |
Public enumeration | Max69096910YearEnableType |
Public enumeration | Max6917AlarmOutType |
Public enumeration | Max6917BatteryTestType |
Public enumeration | Max6917BattLoblinkType |
Public enumeration | Max6917BattLoType |
Public enumeration | Max6917BattOnblinkType |
Public enumeration | Max6917CrystalFailType |
Public enumeration | Max6917DataValidType |
Public enumeration | Max6917DateEnableType |
Public enumeration | Max6917DayEnableType |
Public enumeration | Max6917H1224Type |
Public enumeration | Max6917HourEnableType |
Public enumeration | Max6917MinEnableType |
Public enumeration | Max6917MonthEnableType |
Public enumeration | Max6917OncesecEnableType |
Public enumeration | Max6917SecEnableType |
Public enumeration | Max6917Vbat1khzType |
Public enumeration | Max6917Vbat32khzType |
Public enumeration | Max6917Vcc1khzType |
Public enumeration | Max6917Vcc32khzType |
Public enumeration | Max6917WatchdogEnableType |
Public enumeration | Max6917WatchdogTimeType |
Public enumeration | Max6917WriteProtectType |
Public enumeration | Max6917XtalFailType |
Public enumeration | Max6917YearEnableType |
Public enumeration | Max77387TypeDcdcCntl1Mode |
Public enumeration | Max77387TypeDcdcCntl1OvervoltageThreshold |
Public enumeration | Max77387TypeDcdcCntl1PwmFrequency |
Public enumeration | Max77387TypeDcdcCntl2AdaptiveRegulation |
Public enumeration | Max77387TypeDcdcCntl2Gain |
Public enumeration | Max77387TypeDcdcCntl2OperationMode |
Public enumeration | Max77387TypeDcdcLimCurrentLimit |
Public enumeration | Max77387TypeDcdcLimSoftStartThreshold |
Public enumeration | Max77387TypeDcdcOutMaxOutputVoltage |
Public enumeration | Max77387TypeDcdcOutOutputVoltage |
Public enumeration | Max77387TypeFlashRampSelRampDown |
Public enumeration | Max77387TypeFlashRampSelRampUp |
Public enumeration | Max77387TypeFlashTmrCntlFlashTimer |
Public enumeration | Max77387TypeFlashTmrCntlTimerMode |
Public enumeration | Max77387TypeIflash1Enable |
Public enumeration | Max77387TypeIflash1FlashCurrent |
Public enumeration | Max77387TypeIflash2Enable |
Public enumeration | Max77387TypeIflash2FlashCurrent |
Public enumeration | Max77387TypeItorch1Dimming |
Public enumeration | Max77387TypeItorch1Enable |
Public enumeration | Max77387TypeItorch1TorchCurrent |
Public enumeration | Max77387TypeItorch2Dimming |
Public enumeration | Max77387TypeItorch2Enable |
Public enumeration | Max77387TypeItorch2TorchCurrent |
Public enumeration | Max77387TypeMaxflash1Hysteresis |
Public enumeration | Max77387TypeMaxflash1Threshold |
Public enumeration | Max77387TypeMaxflash2TimerFallingInputVoltage |
Public enumeration | Max77387TypeMaxflash2TimerRisingInputVoltage |
Public enumeration | Max77387TypeModeSelFlashMode |
Public enumeration | Max77387TypeModeSelFlashStbPulldown |
Public enumeration | Max77387TypeModeSelTorchEnPulldown |
Public enumeration | Max77387TypeModeSelTorchMode |
Public enumeration | Max77387TypeNtcOnOffControl |
Public enumeration | Max77387TypeNtcThresholdFlashMode |
Public enumeration | Max77387TypeNtcThresholdTorchMode |
Public enumeration | Max77387TypeStatus1InPowerAndTemp |
Public enumeration | Max77387TypeStatus1Led1Short |
Public enumeration | Max77387TypeStatus1Led2Short |
Public enumeration | Max77387TypeStatus1NtcResistor |
Public enumeration | Max77387TypeStatus1NtcShort |
Public enumeration | Max77387TypeStatus1OvervoltageAnalog |
Public enumeration | Max77387TypeStatus1OvervoltageDigital |
Public enumeration | Max77387TypeStatus1RegInPower |
Public enumeration | Max77387TypeStatus2FlashTimer |
Public enumeration | Max77387TypeStatus2InductorCurrentLimit |
Public enumeration | Max77387TypeStatus2MaxFlash |
Public enumeration | Max77387TypeStatus2Reset |
Public enumeration | Max77387TypeStatus2TorchFlashEvent |
Public enumeration | Max77387TypeStatus2TorchTimer |
Public enumeration | Max77387TypeStatus2Tx1Mask |
Public enumeration | Max77387TypeStatus2Tx2Mask |
Public enumeration | Max77387TypeTorchRampSelRampDown |
Public enumeration | Max77387TypeTorchRampSelRampUp |
Public enumeration | Max77387TypeTorchTmrCntlTimerMode |
Public enumeration | Max77387TypeTorchTmrCntlTorchTimer |
Public enumeration | Max77387TypeTx1MaskEnable |
Public enumeration | Max77387TypeTx1MaskFlashCurrent |
Public enumeration | Max77387TypeTx1MaskPullDownResistor |
Public enumeration | Max77387TypeTx2MaskEnable |
Public enumeration | Max77387TypeTx2MaskFlashCurrent |
Public enumeration | Max77387TypeTx2MaskPullDownResistor |
Public enumeration | Max8821TypeAudioControlAmplifier |
Public enumeration | Max8821TypeAudioControlClock |
Public enumeration | Max8821TypeAudioControlGain |
Public enumeration | Max8821TypeAudioControlSynchronize |
Public enumeration | Max8821TypeBlinkControlBlinkTime |
Public enumeration | Max8821TypeLdo1ControlLdo1 |
Public enumeration | Max8821TypeLdo1ControlLdo1Enable |
Public enumeration | Max8821TypeLdo1ControlLdo1Pulldown |
Public enumeration | Max8821TypeLdo2ControlLdo2 |
Public enumeration | Max8821TypeLdo2ControlLdo2Enable |
Public enumeration | Max8821TypeLdo2ControlLdo2Pulldown |
Public enumeration | Max8821TypeLed1CurrentRegulatorCurrent |
Public enumeration | Max8821TypeLed1CurrentRegulatorRampUpdown |
Public enumeration | Max8821TypeLed2CurrentRegulatorCurrent |
Public enumeration | Max8821TypeLed2CurrentRegulatorRampUpdown |
Public enumeration | Max8821TypeLed3CurrentRegulatorCurrent |
Public enumeration | Max8821TypeLed3CurrentRegulatorRampUpdown |
Public enumeration | Max8821TypeLed4CurrentRegulatorCurrent |
Public enumeration | Max8821TypeLed4CurrentRegulatorRampUpdown |
Public enumeration | Max8821TypeLed5CurrentRegulatorCurrent |
Public enumeration | Max8821TypeLed5CurrentRegulatorRampUpdown |
Public enumeration | Max8821TypeLed6CurrentRegulatorCurrent |
Public enumeration | Max8821TypeLed6CurrentRegulatorRampUpdown |
Public enumeration | Max8821TypeLedEnableLed1 |
Public enumeration | Max8821TypeLedEnableLed2 |
Public enumeration | Max8821TypeLedEnableLed3 |
Public enumeration | Max8821TypeLedEnableLed4 |
Public enumeration | Max8821TypeLedEnableLed5 |
Public enumeration | Max8821TypeLedEnableLed6 |
Public enumeration | Max8821TypePumpControlPump |
Public enumeration | Max8821TypePumpControlTemperature |
Public enumeration | Max8821TypeRampControlRampTime |
Public enumeration | Max8831TypeBoostCntlLed3BoostCntl |
Public enumeration | Max8831TypeBoostCntlLed4BoostCntl |
Public enumeration | Max8831TypeBoostCntlLed5BoostCntl |
Public enumeration | Max8831TypeLed1RampCntlLedRampDown |
Public enumeration | Max8831TypeLed1RampCntlLedRampUp |
Public enumeration | Max8831TypeLed2RampCntlLedRampDown |
Public enumeration | Max8831TypeLed2RampCntlLedRampUp |
Public enumeration | Max8831TypeLed3BlinkCntlLedBlinkEnable |
Public enumeration | Max8831TypeLed3BlinkCntlLedToffBlink |
Public enumeration | Max8831TypeLed3BlinkCntlLedTonBlink |
Public enumeration | Max8831TypeLed3RampCntlLedRampDown |
Public enumeration | Max8831TypeLed3RampCntlLedRampUp |
Public enumeration | Max8831TypeLed4BlinkCntlLedBlinkEnable |
Public enumeration | Max8831TypeLed4BlinkCntlLedToffBlink |
Public enumeration | Max8831TypeLed4BlinkCntlLedTonBlink |
Public enumeration | Max8831TypeLed4RampCntlLedRampDown |
Public enumeration | Max8831TypeLed4RampCntlLedRampUp |
Public enumeration | Max8831TypeLed5BlinkCntlLedBlinkEnable |
Public enumeration | Max8831TypeLed5BlinkCntlLedToffBlink |
Public enumeration | Max8831TypeLed5BlinkCntlLedTonBlink |
Public enumeration | Max8831TypeLed5RampCntlLedRampDown |
Public enumeration | Max8831TypeLed5RampCntlLedRampUp |
Public enumeration | Max8831TypeOnoffCntlLed1Enable |
Public enumeration | Max8831TypeOnoffCntlLed2Enable |
Public enumeration | Max8831TypeOnoffCntlLed3Enable |
Public enumeration | Max8831TypeOnoffCntlLed4Enable |
Public enumeration | Max8831TypeOnoffCntlLed5Enable |
Public enumeration | Max8831TypeStat1Led1Fault |
Public enumeration | Max8831TypeStat1Led2Fault |
Public enumeration | Max8831TypeStat1Led3Fault |
Public enumeration | Max8831TypeStat1Led4Fault |
Public enumeration | Max8831TypeStat1Led5Fault |
Public enumeration | Max8831TypeStat2OpenSchottkyDiodeDetect |
Public enumeration | Max8831TypeStat2OutputVoltageProtection |
Public enumeration | Max8831TypeStat2ThermalShutdownDetection |
Public enumeration | Max8834TypeBoostControlBoostEnable |
Public enumeration | Max8834TypeBoostControlBoostMode |
Public enumeration | Max8834TypeFlash12Current |
Public enumeration | Max8834TypeGsmbCurrentGsmBlank |
Public enumeration | Max8834TypeGsmbCurrentGsmPolarity |
Public enumeration | Max8834TypeGsmbCurrentGsmResetTimer |
Public enumeration | Max8834TypeIndicatorControlOffBlinkTimer |
Public enumeration | Max8834TypeIndicatorControlOnBlinkTimer |
Public enumeration | Max8834TypeIndicatorControlRampDownTimer |
Public enumeration | Max8834TypeIndicatorControlRampUpTimer |
Public enumeration | Max8834TypeIndicatorCurrentBlinkTimer |
Public enumeration | Max8834TypeIndicatorCurrentRampUpdown |
Public enumeration | Max8834TypeLedControlFlashMode |
Public enumeration | Max8834TypeLedControlIndicatorLed |
Public enumeration | Max8834TypeLedControlMovieMode |
Public enumeration | Max8834TypeMaxflash1FunctionEnable |
Public enumeration | Max8834TypeMaxflash1LowBatteryHysteresis |
Public enumeration | Max8834TypeMaxflash1LowBatteryThreshold |
Public enumeration | Max8834TypeMaxflash2LowBatteryReset |
Public enumeration | Max8834TypeNtcControlFlashReset |
Public enumeration | Max8834TypeNtcControlNtcFunction |
Public enumeration | Max8834TypeStatus1DieTemperature |
Public enumeration | Max8834TypeStatus1Fled1Status |
Public enumeration | Max8834TypeStatus1Fled2Status |
Public enumeration | Max8834TypeStatus1GsmbStatus |
Public enumeration | Max8834TypeStatus1IndledStatus |
Public enumeration | Max8834TypeStatus1NtcStatus |
Public enumeration | Max8834TypeStatus1NtcTemperature |
Public enumeration | Max8834TypeStatus1PokWindowStatus |
Public enumeration | Max8834TypeStatus2InputCurrent |
Public enumeration | Max8834TypeStatus2MaxflashEvent |
Public enumeration | Max8834TypeTimerControlTimerMode |
Public enumeration | Max8834TypeTimerControlWatchdogDuration |
Public enumeration | Max8834TypeTimerControlWatchdogFunction |
Public enumeration | Max8834TypeWatchdogReset |
Public enumeration | Max8930TypeActiveDischargeFuncBoost |
Public enumeration | Max8930TypeActiveDischargeFuncLdo1Adis |
Public enumeration | Max8930TypeActiveDischargeFuncLdo2Adis |
Public enumeration | Max8930TypeActiveDischargeFuncLdo3 |
Public enumeration | Max8930TypeActiveDischargeFuncLdo3Adis |
Public enumeration | Max8930TypeAlcControl1MeasureCycle |
Public enumeration | Max8930TypeAlcControl1OffsetValue |
Public enumeration | Max8930TypeAlcControl1Sbias |
Public enumeration | Max8930TypeAlcControl1SensorType |
Public enumeration | Max8930TypeAlcControl2Alda |
Public enumeration | Max8930TypeKeypadControlAlcHysteresis |
Public enumeration | Max8930TypeKeypadControlAlcOffTime |
Public enumeration | Max8930TypeKeypadControlPwmSlopeTime |
Public enumeration | Max8930TypeLdo1Ldo2PwmKeypad |
Public enumeration | Max8930TypeLdo1Ldo2Voltage |
Public enumeration | Max8930TypeOnOff1AlcKeypad |
Public enumeration | Max8930TypeOnOff1AlcWled |
Public enumeration | Max8930TypeOnOff1BoostOutput |
Public enumeration | Max8930TypeOnOff1Ldo1Output |
Public enumeration | Max8930TypeOnOff1Ldo2Output |
Public enumeration | Max8930TypeOnOff1Ldo3Output |
Public enumeration | Max8930TypeOnOff1MainWled |
Public enumeration | Max8930TypeOnOff1Reset |
Public enumeration | Max8930TypeOnOff2LedSlope |
Public enumeration | Max8930TypeOnOff2RgbSlope |
Public enumeration | Max8930TypeOnOff2Sub5 |
Public enumeration | Max8930TypeOnOff2Sub6 |
Public enumeration | Max8930TypeOnOff2Sub7 |
Public enumeration | Max8930TypeOnOff2Wled5 |
Public enumeration | Max8930TypeOnOff2Wled6 |
Public enumeration | Max8930TypeOnOff2Wled7 |
Public enumeration | Max8930TypeOnOff3CaiDimming |
Public enumeration | Max8930TypeOnOff3ChargeIndicator |
Public enumeration | Max8930TypeOnOff3I2cKeypad |
Public enumeration | Max8930TypeOnOff3MainI2cDimming |
Public enumeration | Max8930TypeOnOff3Sub8 |
Public enumeration | Max8930TypeOnOff3WaitTime |
Public enumeration | Max8930TypeOnOff3Wled8 |
Public enumeration | Max8930TypeOnOff3WledHighLow |
Public enumeration | Max8930TypeOnoffControlMode |
Public enumeration | Max8930TypeOnoffControlOutputLdo1 |
Public enumeration | Max8930TypeOnoffControlOutputLdo2 |
Public enumeration | Max8930TypeOnoffControlOutputLdo3 |
Public enumeration | Max8930TypeRgbLedOnoffActive |
Public enumeration | Max8930TypeRgbLedOnoffBlueLed |
Public enumeration | Max8930TypeRgbLedOnoffGreenLed |
Public enumeration | Max8930TypeRgbLedOnoffRedLed |
Public enumeration | Max8930TypeRgbLedOnoffRgbEnable |
Public enumeration | Max8930TypeSlopeControlUpDown |
Public enumeration | Max9526TypeClockOutputClip |
Public enumeration | Max9526TypeClockOutputClock |
Public enumeration | Max9526TypeClockOutputCrystal |
Public enumeration | Max9526TypeClockOutputData |
Public enumeration | Max9526TypeClockOutputInputClock |
Public enumeration | Max9526TypeClockOutputLineLock |
Public enumeration | Max9526TypeClockOutputSync |
Public enumeration | Max9526TypeColorKillBlackWhite |
Public enumeration | Max9526TypeColorKillSelect |
Public enumeration | Max9526TypeColorKillThreshold |
Public enumeration | Max9526TypeGainControlChrominance |
Public enumeration | Max9526TypeGainControlComposite |
Public enumeration | Max9526TypeGainControlGain |
Public enumeration | Max9526TypeGainControlGainControl |
Public enumeration | Max9526TypeIrqMask0AdcInt |
Public enumeration | Max9526TypeIrqMask0ColorKillInt |
Public enumeration | Max9526TypeIrqMask0DemodulatorInt |
Public enumeration | Max9526TypeIrqMask0HorizontalInt |
Public enumeration | Max9526TypeIrqMask0NonstdVideoInt |
Public enumeration | Max9526TypeIrqMask0Video1Int |
Public enumeration | Max9526TypeIrqMask0Video2Int |
Public enumeration | Max9526TypeIrqMask1CopyProtInt |
Public enumeration | Max9526TypeIrqMask1LineModeInt |
Public enumeration | Max9526TypeMiscellaneousAlias |
Public enumeration | Max9526TypePllControlBypass |
Public enumeration | Max9526TypePllControlLineLock |
Public enumeration | Max9526TypePllControlSpeed |
Public enumeration | Max9526TypeStandardSelectDetect |
Public enumeration | Max9526TypeStandardSelectLowPower |
Public enumeration | Max9526TypeStandardSelectSleep |
Public enumeration | Max9526TypeStandardSelectSoftReset |
Public enumeration | Max9526TypeStandardSelectSysReset |
Public enumeration | Max9526TypeStandardSelectVideo |
Public enumeration | Max9526TypeStatus0Adc |
Public enumeration | Max9526TypeStatus0ColorKill |
Public enumeration | Max9526TypeStatus0DemodulatorLock |
Public enumeration | Max9526TypeStatus0HorizontalLock |
Public enumeration | Max9526TypeStatus0NonstandardVideo |
Public enumeration | Max9526TypeStatus0VideoInput1 |
Public enumeration | Max9526TypeStatus0VideoInput2 |
Public enumeration | Max9526TypeStatus1CopyProtection |
Public enumeration | Max9526TypeStatus1LineMode |
Public enumeration | Max9526TypeTestSignalAdcOnly |
Public enumeration | Max9526TypeTestSignalColorBar |
Public enumeration | Max9526TypeTestSignalPattern |
Public enumeration | Max9526TypeTestSignalSource |
Public enumeration | Max9526TypeTestSignalTiming |
Public enumeration | Max9526TypeVideoInputCurrentRange |
Public enumeration | Max9526TypeVideoInputDigitalClamp |
Public enumeration | Max9526TypeVideoInputManual |
Public enumeration | Max9526TypeVideoInputSelect |
Public enumeration | Max9700197002TypeChargePumpMode |
Public enumeration | Max9700197002TypeChargePumpSelect |
Public enumeration | Max9700197002TypeHeadphoneLeftMute |
Public enumeration | Max9700197002TypeHeadphoneLeftSlewing |
Public enumeration | Max9700197002TypeHeadphoneLeftZeroCrossing |
Public enumeration | Max9700197002TypeHeadphoneMixersIn |
Public enumeration | Max9700197002TypeHeadphoneRightGain |
Public enumeration | Max9700197002TypeHeadphoneRightMute |
Public enumeration | Max9700197002TypeHeadphoneVolume |
Public enumeration | Max9700197002TypeInputGainInputa |
Public enumeration | Max9700197002TypeInputGainInputb |
Public enumeration | Max9700197002TypeInputGainPreampa |
Public enumeration | Max9700197002TypeInputGainPreampb |
Public enumeration | Max9700197002TypeLimiterDistortionLimit |
Public enumeration | Max9700197002TypeLimiterDistortionTime |
Public enumeration | Max9700197002TypePowerManagementAnalog |
Public enumeration | Max9700197002TypePowerManagementHpLeft |
Public enumeration | Max9700197002TypePowerManagementHpRight |
Public enumeration | Max9700197002TypePowerManagementMode |
Public enumeration | Max9700197002TypePowerManagementShutdown |
Public enumeration | Max9700197002TypePowerManagementSpeaker |
Public enumeration | Max9700197002TypeSpeakerFrequency |
Public enumeration | Max9700197002TypeSpeakerMixerIn |
Public enumeration | Max9700197002TypeSpeakerMute |
Public enumeration | Max9700197002TypeSpeakerVolume |
Public enumeration | Max9856TypeAdcInterfaceMsbPll |
Public enumeration | Max9856TypeAdcLevelNoise |
Public enumeration | Max9856TypeAdcMixerAuxout |
Public enumeration | Max9856TypeAdcMixerLinein1 |
Public enumeration | Max9856TypeAdcMixerLinein2 |
Public enumeration | Max9856TypeAdcMixerMicl |
Public enumeration | Max9856TypeAdcMixerMicr |
Public enumeration | Max9856TypeAdcSystemBclock |
Public enumeration | Max9856TypeAdcSystemDelay |
Public enumeration | Max9856TypeAdcSystemPinConfig |
Public enumeration | Max9856TypeAdcSystemWordClock |
Public enumeration | Max9856TypeAgcControlAttackTime |
Public enumeration | Max9856TypeAgcControlHoldTime |
Public enumeration | Max9856TypeAgcControlReleaseTime |
Public enumeration | Max9856TypeAgcThresholdNoiseGate |
Public enumeration | Max9856TypeClockControlMode |
Public enumeration | Max9856TypeClockControlPrescaler |
Public enumeration | Max9856TypeClockControlSelect |
Public enumeration | Max9856TypeDacInterfaceMsbPll |
Public enumeration | Max9856TypeDacSystemBclock |
Public enumeration | Max9856TypeDacSystemDelay |
Public enumeration | Max9856TypeDacSystemModRate |
Public enumeration | Max9856TypeDacSystemPcm |
Public enumeration | Max9856TypeDacSystemSampleRate |
Public enumeration | Max9856TypeDacSystemWordClock |
Public enumeration | Max9856TypeDacSystemWordSize |
Public enumeration | Max9856TypeDigitalInputGain |
Public enumeration | Max9856TypeHeadsetSystemHpl |
Public enumeration | Max9856TypeHeadsetSystemHpr |
Public enumeration | Max9856TypeHeadsetSystemJackDetect |
Public enumeration | Max9856TypeHeadsetSystemJackSense |
Public enumeration | Max9856TypeHpVolumeGain |
Public enumeration | Max9856TypeInterruptEnableClipDetect |
Public enumeration | Max9856TypeInterruptEnableGpi |
Public enumeration | Max9856TypeInterruptEnableHeadphoneLeft |
Public enumeration | Max9856TypeInterruptEnableHeadphoneRight |
Public enumeration | Max9856TypeInterruptEnableHeadset |
Public enumeration | Max9856TypeInterruptEnablePllUnlock |
Public enumeration | Max9856TypeInterruptEnableSlewLevel |
Public enumeration | Max9856TypeMicGainPga |
Public enumeration | Max9856TypeMicGainPreamp |
Public enumeration | Max9856TypeMicModeBias |
Public enumeration | Max9856TypeMicModeLeftInput |
Public enumeration | Max9856TypeMicModeMute |
Public enumeration | Max9856TypeOutputMixerDacOutput |
Public enumeration | Max9856TypeOutputMixerLinein1 |
Public enumeration | Max9856TypeOutputMixerLinein2 |
Public enumeration | Max9856TypeOutputMixerMicOutput |
Public enumeration | Max9856TypeOutputModeDcMeasure |
Public enumeration | Max9856TypeOutputModeHeadphoneAmp |
Public enumeration | Max9856TypeOutputModeHpMode |
Public enumeration | Max9856TypeOutputModeSlewing |
Public enumeration | Max9856TypePowerSystemAdcLeft |
Public enumeration | Max9856TypePowerSystemAdcRight |
Public enumeration | Max9856TypePowerSystemDacLeft |
Public enumeration | Max9856TypePowerSystemDacRight |
Public enumeration | Max9856TypePowerSystemDigital |
Public enumeration | Max9856TypePowerSystemLine |
Public enumeration | Max9856TypePowerSystemShutdown |
Public enumeration | Max9856TypeStatus0ClipDetect |
Public enumeration | Max9856TypeStatus0Gpi |
Public enumeration | Max9856TypeStatus0HeadphoneLeft |
Public enumeration | Max9856TypeStatus0HeadphoneRight |
Public enumeration | Max9856TypeStatus0Headset |
Public enumeration | Max9856TypeStatus0MicroJack |
Public enumeration | Max9856TypeStatus0PllUnlock |
Public enumeration | Max9856TypeStatus0SlewLevel |
Public enumeration | Max9856TypeStatus1HeadphoneSense |
Public enumeration | Max9856TypeStatus1JackSense |
Public enumeration | Max9856TypeStatus1LoadImpedance |
Public enumeration | Max9860TypeAudioClockHighPll |
Public enumeration | Max9860TypeAudioInterface1DacDelay |
Public enumeration | Max9860TypeAudioInterface1Dbci |
Public enumeration | Max9860TypeAudioInterface1Impedance |
Public enumeration | Max9860TypeAudioInterface1Master |
Public enumeration | Max9860TypeAudioInterface1TdmMode |
Public enumeration | Max9860TypeAudioInterface1Wci |
Public enumeration | Max9860TypeAudioInterface2Abci |
Public enumeration | Max9860TypeAudioInterface2AdcDelay |
Public enumeration | Max9860TypeAudioInterface2BclkSelect |
Public enumeration | Max9860TypeAudioInterface2Stereo |
Public enumeration | Max9860TypeDacAttenuationLevel |
Public enumeration | Max9860TypeDacGainDvg |
Public enumeration | Max9860TypeDacGainSidetone |
Public enumeration | Max9860TypeInterruptEnableClipDetect |
Public enumeration | Max9860TypeInterruptEnablePllUnlock |
Public enumeration | Max9860TypeInterruptEnableSlewLevel |
Public enumeration | Max9860TypeInterruptStatusClipDetect |
Public enumeration | Max9860TypeInterruptStatusPllUnlock |
Public enumeration | Max9860TypeInterruptStatusSlewLevel |
Public enumeration | Max9860TypeMicrophoneAgcAttack |
Public enumeration | Max9860TypeMicrophoneAgcHold |
Public enumeration | Max9860TypeMicrophoneAgcRelease |
Public enumeration | Max9860TypeMicrophoneAgcSelect |
Public enumeration | Max9860TypeMicrophoneGainPga |
Public enumeration | Max9860TypeMicrophoneGainPreamp |
Public enumeration | Max9860TypeMicrophoneNgNoiseGate |
Public enumeration | Max9860TypeNoiseGateThreshold |
Public enumeration | Max9860TypeSystemClock16khz |
Public enumeration | Max9860TypeSystemClockMode |
Public enumeration | Max9860TypeSystemClockPrescaler |
Public enumeration | Max9860TypeSystemShutdownAdcLeft |
Public enumeration | Max9860TypeSystemShutdownAdcRight |
Public enumeration | Max9860TypeSystemShutdownDac |
Public enumeration | Max9860TypeSystemShutdownSelect |
Public enumeration | Max9860TypeVoiceFilter |
Public enumeration | Max9867TypeAdcInputAuxCapture |
Public enumeration | Max9867TypeAdcInputAuxGain |
Public enumeration | Max9867TypeAdcInputAuxInput |
Public enumeration | Max9867TypeAdcInputAuxOffset |
Public enumeration | Max9867TypeAdcInputMixerLeft |
Public enumeration | Max9867TypeAdcInputMixerRight |
Public enumeration | Max9867TypeAudioClockHighPll |
Public enumeration | Max9867TypeAudioInterface1Bci |
Public enumeration | Max9867TypeAudioInterface1Delay |
Public enumeration | Max9867TypeAudioInterface1Impedance |
Public enumeration | Max9867TypeAudioInterface1Master |
Public enumeration | Max9867TypeAudioInterface1TdmMode |
Public enumeration | Max9867TypeAudioInterface1Wci |
Public enumeration | Max9867TypeAudioInterface2BclkSelect |
Public enumeration | Max9867TypeAudioInterface2FixLine |
Public enumeration | Max9867TypeAudioInterface2Mono |
Public enumeration | Max9867TypeCodecFiltersFilter |
Public enumeration | Max9867TypeCodecFiltersMode |
Public enumeration | Max9867TypeDacLevelGain |
Public enumeration | Max9867TypeDacLevelMute |
Public enumeration | Max9867TypeGainAmplifier |
Public enumeration | Max9867TypeGainPreamp |
Public enumeration | Max9867TypeInterruptEnableClipDetect |
Public enumeration | Max9867TypeInterruptEnableHeadset |
Public enumeration | Max9867TypeInterruptEnablePllUnlock |
Public enumeration | Max9867TypeInterruptEnableSdout |
Public enumeration | Max9867TypeInterruptEnableSlewLevel |
Public enumeration | Max9867TypeJackSenseJack |
Public enumeration | Max9867TypeJackSenseLoutp |
Public enumeration | Max9867TypeJackSenseMicrophone |
Public enumeration | Max9867TypeLineMute |
Public enumeration | Max9867TypeMicrophoneClock |
Public enumeration | Max9867TypeMicrophoneLeftRight |
Public enumeration | Max9867TypeModeHeadphone |
Public enumeration | Max9867TypeModeJackDetection |
Public enumeration | Max9867TypeModeSlewSpeed |
Public enumeration | Max9867TypeModeSmoothing |
Public enumeration | Max9867TypeModeZeroCrossing |
Public enumeration | Max9867TypeSidetoneMixer |
Public enumeration | Max9867TypeSidetoneOutput |
Public enumeration | Max9867TypeStatusClipDetect |
Public enumeration | Max9867TypeStatusHeadset |
Public enumeration | Max9867TypeStatusPllUnlock |
Public enumeration | Max9867TypeStatusSlewLevel |
Public enumeration | Max9867TypeSystemClockFrequency |
Public enumeration | Max9867TypeSystemClockPrescaler |
Public enumeration | Max9867TypeSystemShutdownLeftAdc |
Public enumeration | Max9867TypeSystemShutdownLeftDac |
Public enumeration | Max9867TypeSystemShutdownLeftLine |
Public enumeration | Max9867TypeSystemShutdownRightAdc |
Public enumeration | Max9867TypeSystemShutdownRightDac |
Public enumeration | Max9867TypeSystemShutdownRightLine |
Public enumeration | Max9867TypeSystemShutdownShdn |
Public enumeration | Max9867TypeVolumeGain |
Public enumeration | Max9867TypeVolumeMute |


Ds1307 Class

Maxim: DS 1307
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs1307

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds1307
Public Class Ds1307
public ref class Ds1307
type Ds1307 =  class end

The Ds1307 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds1307 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CH | CH
Public property | Date | Date
Public property | Day | Day
Public property | Hours | Hours (unit: h)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | OutputControlOUT | Output Control (OUT)
Public property | Property_1224HourMode | 12/24-Hour Mode
Public property | RateSelectRS1RS0 | Rate Select (RS1, RS0) (unit: Hz)
Public property | Seconds | Seconds (unit: s)
Public property | SquareWaveEnableSQWE | Square-Wave Enable (SQWE)
Public property | Year | Year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Real-Time Clock
See Also

Reference

telos.Ird.Maxim Namespace


Ds1307 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1307(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds1307(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds1307

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds1307 Class
telos.Ird.Maxim Namespace


Ds1307 Properties

The Ds1307 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CH | CH
Public property | Date | Date
Public property | Day | Day
Public property | Hours | Hours (unit: h)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | OutputControlOUT | Output Control (OUT)
Public property | Property_1224HourMode | 12/24-Hour Mode
Public property | RateSelectRS1RS0 | Rate Select (RS1, RS0) (unit: Hz)
Public property | Seconds | Seconds (unit: s)
Public property | SquareWaveEnableSQWE | Square-Wave Enable (SQWE)
Public property | Year | Year
Top
See Also

Reference

Ds1307 Class
telos.Ird.Maxim Namespace


Ds1307.AutoFlush Property

IRD

Ds1307AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds1307 Class
telos.Ird.Maxim Namespace


Ds1307.CH Property

IRD

Ds1307CH Property

CH

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1307ChType CH { get; set; }
Public Property CH As Ds1307ChType
    Get
    Set
public:
property Ds1307ChType CH {
    Ds1307ChType get ();
    void set (Ds1307ChType value);
}
member CH : Ds1307ChType with get, set

Property Value

Type: Ds1307ChType
See Also

Reference

Ds1307 Class
telos.Ird.Maxim Namespace


Ds1307.Date Property

IRD

Ds1307Date Property

Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Date { get; set; }
Public Property Date As Byte
    Get
    Set
public:
property unsigned char Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1307 Class
telos.Ird.Maxim Namespace


Ds1307.Day Property

IRD

Ds1307Day Property

Day

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Day { get; set; }
Public Property Day As Byte
    Get
    Set
public:
property unsigned char Day {
    unsigned char get ();
    void set (unsigned char value);
}
member Day : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1307 Class
telos.Ird.Maxim Namespace


Ds1307.Hours Property

IRD

Ds1307Hours Property

Hours (unit: h)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Hours { get; set; }
Public Property Hours As Byte
    Get
    Set
public:
property unsigned char Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1307 Class
telos.Ird.Maxim Namespace


Ds1307.Minutes Property

IRD

Ds1307Minutes Property

Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Minutes { get; set; }
Public Property Minutes As Byte
    Get
    Set
public:
property unsigned char Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1307 Class
telos.Ird.Maxim Namespace


Ds1307.Month Property

IRD

Ds1307Month Property

Month

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Month { get; set; }
Public Property Month As Byte
    Get
    Set
public:
property unsigned char Month {
    unsigned char get ();
    void set (unsigned char value);
}
member Month : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1307 Class
telos.Ird.Maxim Namespace


Ds1307.OutputControlOUT Property

IRD

Ds1307OutputControlOUT Property

Output Control (OUT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1307OutType OutputControlOUT { get; set; }
Public Property OutputControlOUT As Ds1307OutType
    Get
    Set
public:
property Ds1307OutType OutputControlOUT {
    Ds1307OutType get ();
    void set (Ds1307OutType value);
}
member OutputControlOUT : Ds1307OutType with get, set

Property Value

Type: Ds1307OutType
See Also

Reference

Ds1307 Class
telos.Ird.Maxim Namespace


Ds1307.Property_1224HourMode Property

IRD

Ds1307Property_1224HourMode Property

12/24-Hour Mode

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1307H1224Type Property_1224HourMode { get; set; }
Public Property Property_1224HourMode As Ds1307H1224Type
    Get
    Set
public:
property Ds1307H1224Type Property_1224HourMode {
    Ds1307H1224Type get ();
    void set (Ds1307H1224Type value);
}
member Property_1224HourMode : Ds1307H1224Type with get, set

Property Value

Type: Ds1307H1224Type
See Also

Reference

Ds1307 Class
telos.Ird.Maxim Namespace


Ds1307.RateSelectRS1RS0 Property

IRD

Ds1307RateSelectRS1RS0 Property

Rate Select (RS1, RS0) (unit: Hz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1307RateType RateSelectRS1RS0 { get; set; }
Public Property RateSelectRS1RS0 As Ds1307RateType
    Get
    Set
public:
property Ds1307RateType RateSelectRS1RS0 {
    Ds1307RateType get ();
    void set (Ds1307RateType value);
}
member RateSelectRS1RS0 : Ds1307RateType with get, set

Property Value

Type: Ds1307RateType
See Also

Reference

Ds1307 Class
telos.Ird.Maxim Namespace


Ds1307.Seconds Property

IRD

Ds1307Seconds Property

Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Seconds { get; set; }
Public Property Seconds As Byte
    Get
    Set
public:
property unsigned char Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1307 Class
telos.Ird.Maxim Namespace


Ds1307.SquareWaveEnableSQWE Property

IRD

Ds1307SquareWaveEnableSQWE Property

Square-Wave Enable (SQWE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1307SqweType SquareWaveEnableSQWE { get; set; }
Public Property SquareWaveEnableSQWE As Ds1307SqweType
    Get
    Set
public:
property Ds1307SqweType SquareWaveEnableSQWE {
    Ds1307SqweType get ();
    void set (Ds1307SqweType value);
}
member SquareWaveEnableSQWE : Ds1307SqweType with get, set

Property Value

Type: Ds1307SqweType
See Also

Reference

Ds1307 Class
telos.Ird.Maxim Namespace


Ds1307.Year Property

IRD

Ds1307Year Property

Year

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Year { get; set; }
Public Property Year As Byte
    Get
    Set
public:
property unsigned char Year {
    unsigned char get ();
    void set (unsigned char value);
}
member Year : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1307 Class
telos.Ird.Maxim Namespace


Ds1307 Methods

The Ds1307 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds1307 Class
telos.Ird.Maxim Namespace


Ds1307.Flush Method

IRD

Ds1307Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds1307 Class
telos.Ird.Maxim Namespace


Ds1307.ChType Enumeration

IRD

Ds1307ChType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ChType
Public Enumeration ChType
public enum class ChType
type ChType
Members
Member name | Value | Description
OscillatorDisabled | 1 | Oscillator Disabled
OscillatorEnabled | 0 | Oscillator Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds1307.H1224Type Enumeration

IRD

Ds1307H1224Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum H1224Type
Public Enumeration H1224Type
public enum class H1224Type
type H1224Type
Members
Member name | Value | Description
Value_12HourMode | 1 | 12-hour mode
Value_24HourMode | 0 | 24-hour mode
See Also

Reference

telos.Ird.Maxim Namespace


Ds1307.OutType Enumeration

IRD

Ds1307OutType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum OutType
Public Enumeration OutType
public enum class OutType
type OutType
Members
Member name | Value | Description
OUT1 | 1 | OUT=1
OUT0 | 0 | OUT=0
See Also

Reference

telos.Ird.Maxim Namespace


Ds1307.RateType Enumeration

IRD

Ds1307RateType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum RateType
Public Enumeration RateType
public enum class RateType
type RateType
Members
Member name | Value | Description
Value_32768 | 3 | 32768
Value_8192 | 2 | 8192
Value_4096 | 1 | 4096
Value_1 | 0 | 1
See Also

Reference

telos.Ird.Maxim Namespace


Ds1307.SqweType Enumeration

IRD

Ds1307SqweType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SqweType
Public Enumeration SqweType
public enum class SqweType
type SqweType
Members
Member name | Value | Description
OutputEnabled | 1 | Output Enabled
OutputDisabled | 0 | Output Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds1337 Class

Maxim: DS 1337
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs1337

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds1337
Public Class Ds1337
public ref class Ds1337
type Ds1337 =  class end

The Ds1337 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds1337 | Constructor
Top
Properties
 | Name | Description
Public property | Alarm1Date | Alarm 1 Date
Public property | Alarm1DayDateSwitchDYDT | Alarm 1 Day Date Switch (DY/DT)
Public property | Alarm1FlagA1F | Alarm 1 Flag (A1F)
Public property | Alarm1Hours | Alarm 1 Hours (unit: hour)
Public property | Alarm1InterruptEnableA1IE | Alarm 1 Interrupt Enable (A1IE)
Public property | Alarm1MaskBitsA1Mx | Alarm1 Mask Bits (A1Mx)
Public property | Alarm1Minutes | Alarm 1 Minutes (unit: min)
Public property | Alarm1Seconds | Alarm 1 Seconds (unit: s)
Public property | Alarm1Switch12To24Hours1224 | Alarm 1 Switch 12 To 24 Hours (12/24)
Public property | Alarm2Date | Alarm 2 Date
Public property | Alarm2DayDateSwitchDYDT | Alarm 2 Day Date Switch (DY/DT)
Public property | Alarm2FlagA2F | Alarm 2 Flag (A2F)
Public property | Alarm2Hours | Alarm 2 Hours (unit: hour)
Public property | Alarm2InterruptControlINTCN | Alarm 2 Interrupt Control (INTCN)
Public property | Alarm2InterruptEnableA2IE | Alarm 2 Interrupt Enable (A2IE)
Public property | Alarm2MaskBitsA2Mx | Alarm2 Mask Bits (A2Mx)
Public property | Alarm2Minutes | Alarm 2 Minutes (unit: min)
Public property | Alarm2Switch12To24Hours1224 | Alarm 2 Switch 12 To 24 Hours (12/24)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Century | Century
Public property | Date | Date
Public property | Day | Day
Public property | EnableOscillatorEOSC | Enable Oscillator (EOSC)
Public property | Hours | Hours (unit: hour)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | OscillatorStopFlagOSF | Oscillator Stop Flag (OSF)
Public property | Seconds | Seconds (unit: s)
Public property | SquareWaveOutputRSx | Square Wave Output (RSx) (unit: Hz)
Public property | Switch12To24Hours1224 | Switch 12 To 24 Hours (12/24)
Public property | Year | Year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Serial Real Time Clock
See Also

Reference

telos.Ird.Maxim Namespace


Ds1337 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1337(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds1337(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds1337

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337 Properties

The Ds1337 type exposes the following members.

Properties
 | Name | Description
Public property | Alarm1Date | Alarm 1 Date
Public property | Alarm1DayDateSwitchDYDT | Alarm 1 Day Date Switch (DY/DT)
Public property | Alarm1FlagA1F | Alarm 1 Flag (A1F)
Public property | Alarm1Hours | Alarm 1 Hours (unit: hour)
Public property | Alarm1InterruptEnableA1IE | Alarm 1 Interrupt Enable (A1IE)
Public property | Alarm1MaskBitsA1Mx | Alarm1 Mask Bits (A1Mx)
Public property | Alarm1Minutes | Alarm 1 Minutes (unit: min)
Public property | Alarm1Seconds | Alarm 1 Seconds (unit: s)
Public property | Alarm1Switch12To24Hours1224 | Alarm 1 Switch 12 To 24 Hours (12/24)
Public property | Alarm2Date | Alarm 2 Date
Public property | Alarm2DayDateSwitchDYDT | Alarm 2 Day Date Switch (DY/DT)
Public property | Alarm2FlagA2F | Alarm 2 Flag (A2F)
Public property | Alarm2Hours | Alarm 2 Hours (unit: hour)
Public property | Alarm2InterruptControlINTCN | Alarm 2 Interrupt Control (INTCN)
Public property | Alarm2InterruptEnableA2IE | Alarm 2 Interrupt Enable (A2IE)
Public property | Alarm2MaskBitsA2Mx | Alarm2 Mask Bits (A2Mx)
Public property | Alarm2Minutes | Alarm 2 Minutes (unit: min)
Public property | Alarm2Switch12To24Hours1224 | Alarm 2 Switch 12 To 24 Hours (12/24)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Century | Century
Public property | Date | Date
Public property | Day | Day
Public property | EnableOscillatorEOSC | Enable Oscillator (EOSC)
Public property | Hours | Hours (unit: hour)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | OscillatorStopFlagOSF | Oscillator Stop Flag (OSF)
Public property | Seconds | Seconds (unit: s)
Public property | SquareWaveOutputRSx | Square Wave Output (RSx) (unit: Hz)
Public property | Switch12To24Hours1224 | Switch 12 To 24 Hours (12/24)
Public property | Year | Year
Top
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Alarm1Date Property

IRD

Ds1337Alarm1Date Property

Alarm 1 Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm1Date { get; set; }
Public Property Alarm1Date As Byte
    Get
    Set
public:
property unsigned char Alarm1Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm1Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Alarm1DayDateSwitchDYDT Property

IRD

Ds1337Alarm1DayDateSwitchDYDT Property

Alarm 1 Day Date Switch (DY/DT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1337DayDateType Alarm1DayDateSwitchDYDT { get; set; }
Public Property Alarm1DayDateSwitchDYDT As Ds1337DayDateType
    Get
    Set
public:
property Ds1337DayDateType Alarm1DayDateSwitchDYDT {
    Ds1337DayDateType get ();
    void set (Ds1337DayDateType value);
}
member Alarm1DayDateSwitchDYDT : Ds1337DayDateType with get, set

Property Value

Type: Ds1337DayDateType
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Alarm1FlagA1F Property

IRD

Ds1337Alarm1FlagA1F Property

Alarm 1 Flag (A1F)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1337AlarmFlagType Alarm1FlagA1F { get; set; }
Public Property Alarm1FlagA1F As Ds1337AlarmFlagType
    Get
    Set
public:
property Ds1337AlarmFlagType Alarm1FlagA1F {
    Ds1337AlarmFlagType get ();
    void set (Ds1337AlarmFlagType value);
}
member Alarm1FlagA1F : Ds1337AlarmFlagType with get, set

Property Value

Type: Ds1337AlarmFlagType
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Alarm1Hours Property

IRD

Ds1337Alarm1Hours Property

Alarm 1 Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm1Hours { get; set; }
Public Property Alarm1Hours As Byte
    Get
    Set
public:
property unsigned char Alarm1Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm1Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Alarm1InterruptEnableA1IE Property

IRD

Ds1337Alarm1InterruptEnableA1IE Property

Alarm 1 Interrupt Enable (A1IE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1337AlarmIntType Alarm1InterruptEnableA1IE { get; set; }
Public Property Alarm1InterruptEnableA1IE As Ds1337AlarmIntType
    Get
    Set
public:
property Ds1337AlarmIntType Alarm1InterruptEnableA1IE {
    Ds1337AlarmIntType get ();
    void set (Ds1337AlarmIntType value);
}
member Alarm1InterruptEnableA1IE : Ds1337AlarmIntType with get, set

Property Value

Type: Ds1337AlarmIntType
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Alarm1MaskBitsA1Mx Property

IRD

Ds1337Alarm1MaskBitsA1Mx Property

Alarm1 Mask Bits (A1Mx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1337AlarmMask1Type Alarm1MaskBitsA1Mx { get; set; }
Public Property Alarm1MaskBitsA1Mx As Ds1337AlarmMask1Type
    Get
    Set
public:
property Ds1337AlarmMask1Type Alarm1MaskBitsA1Mx {
    Ds1337AlarmMask1Type get ();
    void set (Ds1337AlarmMask1Type value);
}
member Alarm1MaskBitsA1Mx : Ds1337AlarmMask1Type with get, set

Property Value

Type: Ds1337AlarmMask1Type
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Alarm1Minutes Property

IRD

Ds1337Alarm1Minutes Property

Alarm 1 Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm1Minutes { get; set; }
Public Property Alarm1Minutes As Byte
    Get
    Set
public:
property unsigned char Alarm1Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm1Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Alarm1Seconds Property

IRD

Ds1337Alarm1Seconds Property

Alarm 1 Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm1Seconds { get; set; }
Public Property Alarm1Seconds As Byte
    Get
    Set
public:
property unsigned char Alarm1Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm1Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Alarm1Switch12To24Hours1224 Property

IRD

Ds1337Alarm1Switch12To24Hours1224 Property

Alarm 1 Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1337H1224Type Alarm1Switch12To24Hours1224 { get; set; }
Public Property Alarm1Switch12To24Hours1224 As Ds1337H1224Type
    Get
    Set
public:
property Ds1337H1224Type Alarm1Switch12To24Hours1224 {
    Ds1337H1224Type get ();
    void set (Ds1337H1224Type value);
}
member Alarm1Switch12To24Hours1224 : Ds1337H1224Type with get, set

Property Value

Type: Ds1337H1224Type
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Alarm2Date Property

IRD

Ds1337Alarm2Date Property

Alarm 2 Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm2Date { get; set; }
Public Property Alarm2Date As Byte
    Get
    Set
public:
property unsigned char Alarm2Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm2Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Alarm2DayDateSwitchDYDT Property

IRD

Ds1337Alarm2DayDateSwitchDYDT Property

Alarm 2 Day Date Switch (DY/DT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1337DayDateType Alarm2DayDateSwitchDYDT { get; set; }
Public Property Alarm2DayDateSwitchDYDT As Ds1337DayDateType
    Get
    Set
public:
property Ds1337DayDateType Alarm2DayDateSwitchDYDT {
    Ds1337DayDateType get ();
    void set (Ds1337DayDateType value);
}
member Alarm2DayDateSwitchDYDT : Ds1337DayDateType with get, set

Property Value

Type: Ds1337DayDateType
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Alarm2FlagA2F Property

IRD

Ds1337Alarm2FlagA2F Property

Alarm 2 Flag (A2F)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1337AlarmFlagType Alarm2FlagA2F { get; set; }
Public Property Alarm2FlagA2F As Ds1337AlarmFlagType
    Get
    Set
public:
property Ds1337AlarmFlagType Alarm2FlagA2F {
    Ds1337AlarmFlagType get ();
    void set (Ds1337AlarmFlagType value);
}
member Alarm2FlagA2F : Ds1337AlarmFlagType with get, set

Property Value

Type: Ds1337AlarmFlagType
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Alarm2Hours Property

IRD

Ds1337Alarm2Hours Property

Alarm 2 Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm2Hours { get; set; }
Public Property Alarm2Hours As Byte
    Get
    Set
public:
property unsigned char Alarm2Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm2Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Alarm2InterruptControlINTCN Property

IRD

Ds1337Alarm2InterruptControlINTCN Property

Alarm 2 Interrupt Control (INTCN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1337InterruptControlType Alarm2InterruptControlINTCN { get; set; }
Public Property Alarm2InterruptControlINTCN As Ds1337InterruptControlType
    Get
    Set
public:
property Ds1337InterruptControlType Alarm2InterruptControlINTCN {
    Ds1337InterruptControlType get ();
    void set (Ds1337InterruptControlType value);
}
member Alarm2InterruptControlINTCN : Ds1337InterruptControlType with get, set

Property Value

Type: Ds1337InterruptControlType
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Alarm2InterruptEnableA2IE Property

IRD

Ds1337Alarm2InterruptEnableA2IE Property

Alarm 2 Interrupt Enable (A2IE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1337AlarmIntType Alarm2InterruptEnableA2IE { get; set; }
Public Property Alarm2InterruptEnableA2IE As Ds1337AlarmIntType
    Get
    Set
public:
property Ds1337AlarmIntType Alarm2InterruptEnableA2IE {
    Ds1337AlarmIntType get ();
    void set (Ds1337AlarmIntType value);
}
member Alarm2InterruptEnableA2IE : Ds1337AlarmIntType with get, set

Property Value

Type: Ds1337AlarmIntType
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Alarm2MaskBitsA2Mx Property

IRD

Ds1337Alarm2MaskBitsA2Mx Property

Alarm2 Mask Bits (A2Mx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1337AlarmMask2Type Alarm2MaskBitsA2Mx { get; set; }
Public Property Alarm2MaskBitsA2Mx As Ds1337AlarmMask2Type
    Get
    Set
public:
property Ds1337AlarmMask2Type Alarm2MaskBitsA2Mx {
    Ds1337AlarmMask2Type get ();
    void set (Ds1337AlarmMask2Type value);
}
member Alarm2MaskBitsA2Mx : Ds1337AlarmMask2Type with get, set

Property Value

Type: Ds1337AlarmMask2Type
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Alarm2Minutes Property

IRD

Ds1337Alarm2Minutes Property

Alarm 2 Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm2Minutes { get; set; }
Public Property Alarm2Minutes As Byte
    Get
    Set
public:
property unsigned char Alarm2Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm2Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Alarm2Switch12To24Hours1224 Property

IRD

Ds1337Alarm2Switch12To24Hours1224 Property

Alarm 2 Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1337H1224Type Alarm2Switch12To24Hours1224 { get; set; }
Public Property Alarm2Switch12To24Hours1224 As Ds1337H1224Type
    Get
    Set
public:
property Ds1337H1224Type Alarm2Switch12To24Hours1224 {
    Ds1337H1224Type get ();
    void set (Ds1337H1224Type value);
}
member Alarm2Switch12To24Hours1224 : Ds1337H1224Type with get, set

Property Value

Type: Ds1337H1224Type
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.AutoFlush Property

IRD

Ds1337AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Century Property

IRD

Ds1337Century Property

Century

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Century { get; set; }
Public Property Century As Byte
    Get
    Set
public:
property unsigned char Century {
    unsigned char get ();
    void set (unsigned char value);
}
member Century : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Date Property

IRD

Ds1337Date Property

Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Date { get; set; }
Public Property Date As Byte
    Get
    Set
public:
property unsigned char Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Day Property

IRD

Ds1337Day Property

Day

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Day { get; set; }
Public Property Day As Byte
    Get
    Set
public:
property unsigned char Day {
    unsigned char get ();
    void set (unsigned char value);
}
member Day : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.EnableOscillatorEOSC Property

IRD

Ds1337EnableOscillatorEOSC Property

Enable Oscillator (EOSC)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1337EnableOscType EnableOscillatorEOSC { get; set; }
Public Property EnableOscillatorEOSC As Ds1337EnableOscType
    Get
    Set
public:
property Ds1337EnableOscType EnableOscillatorEOSC {
    Ds1337EnableOscType get ();
    void set (Ds1337EnableOscType value);
}
member EnableOscillatorEOSC : Ds1337EnableOscType with get, set

Property Value

Type: Ds1337EnableOscType
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Hours Property

IRD

Ds1337Hours Property

Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Hours { get; set; }
Public Property Hours As Byte
    Get
    Set
public:
property unsigned char Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Minutes Property

IRD

Ds1337Minutes Property

Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Minutes { get; set; }
Public Property Minutes As Byte
    Get
    Set
public:
property unsigned char Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Month Property

IRD

Ds1337Month Property

Month

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Month { get; set; }
Public Property Month As Byte
    Get
    Set
public:
property unsigned char Month {
    unsigned char get ();
    void set (unsigned char value);
}
member Month : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.OscillatorStopFlagOSF Property

IRD

Ds1337OscillatorStopFlagOSF Property

Oscillator Stop Flag (OSF)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1337OscStopType OscillatorStopFlagOSF { get; set; }
Public Property OscillatorStopFlagOSF As Ds1337OscStopType
    Get
    Set
public:
property Ds1337OscStopType OscillatorStopFlagOSF {
    Ds1337OscStopType get ();
    void set (Ds1337OscStopType value);
}
member OscillatorStopFlagOSF : Ds1337OscStopType with get, set

Property Value

Type: Ds1337OscStopType
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Seconds Property

IRD

Ds1337Seconds Property

Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Seconds { get; set; }
Public Property Seconds As Byte
    Get
    Set
public:
property unsigned char Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.SquareWaveOutputRSx Property

IRD

Ds1337SquareWaveOutputRSx Property

Square Wave Output (RSx) (unit: Hz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1337SquareWaveType SquareWaveOutputRSx { get; set; }
Public Property SquareWaveOutputRSx As Ds1337SquareWaveType
    Get
    Set
public:
property Ds1337SquareWaveType SquareWaveOutputRSx {
    Ds1337SquareWaveType get ();
    void set (Ds1337SquareWaveType value);
}
member SquareWaveOutputRSx : Ds1337SquareWaveType with get, set

Property Value

Type: Ds1337SquareWaveType
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Switch12To24Hours1224 Property

IRD

Ds1337Switch12To24Hours1224 Property

Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1337H1224Type Switch12To24Hours1224 { get; set; }
Public Property Switch12To24Hours1224 As Ds1337H1224Type
    Get
    Set
public:
property Ds1337H1224Type Switch12To24Hours1224 {
    Ds1337H1224Type get ();
    void set (Ds1337H1224Type value);
}
member Switch12To24Hours1224 : Ds1337H1224Type with get, set

Property Value

Type: Ds1337H1224Type
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Year Property

IRD

Ds1337Year Property

Year

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Year { get; set; }
Public Property Year As Byte
    Get
    Set
public:
property unsigned char Year {
    unsigned char get ();
    void set (unsigned char value);
}
member Year : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337 Methods

The Ds1337 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.Flush Method

IRD

Ds1337Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds1337 Class
telos.Ird.Maxim Namespace


Ds1337.AlarmFlagType Enumeration

IRD

Ds1337AlarmFlagType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmFlagType
Public Enumeration AlarmFlagType
public enum class AlarmFlagType
type AlarmFlagType
Members
Member name | Value | Description
TimeMatchedAlarm | 1 | Time Matched Alarm
NoTimeMatchAlarm | 0 | No Time Match Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Ds1337.AlarmIntType Enumeration

IRD

Ds1337AlarmIntType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmIntType
Public Enumeration AlarmIntType
public enum class AlarmIntType
type AlarmIntType
Members
Member name | Value | Description
AlarmInterruptEnable | 1 | Alarm Interrupt: Enable
AlarmInterruptDisable | 0 | Alarm Interrupt: Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds1337.AlarmMask1Type Enumeration

IRD

Ds1337AlarmMask1Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmMask1Type
Public Enumeration AlarmMask1Type
public enum class AlarmMask1Type
type AlarmMask1Type
Members
Member name | Value | Description
AlarmOncePerSecond | 15 | Alarm Once Per Second
AlarmOncePerSecond__1 | 31 | Alarm Once Per Second
AlarmWhenSecondsMatch | 14 | Alarm When Seconds Match
AlarmWhenSecondsMatch__1 | 30 | Alarm When Seconds Match
AlarmWhenMinutesMatch | 12 | Alarm When Minutes Match
AlarmWhenMinutesMatch__1 | 28 | Alarm When Minutes Match
AlarmWhenHoursMatch | 8 | Alarm When Hours Match
AlarmWhenHoursMatch__1 | 24 | Alarm When Hours Match
AlarmWhenDateMatch | 0 | Alarm When Date Match
AlarmWhenDayMatch | 16 | Alarm When Day Match
Reserved | 1 | Reserved
Reserved__1 | 9 | Reserved
Reserved__2 | 13 | Reserved
Reserved__3 | 17 | Reserved
Reserved__4 | 25 | Reserved
Reserved__5 | 29 | Reserved
See Also

Reference

telos.Ird.Maxim Namespace


Ds1337.AlarmMask2Type Enumeration

IRD

Ds1337AlarmMask2Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmMask2Type
Public Enumeration AlarmMask2Type
public enum class AlarmMask2Type
type AlarmMask2Type
Members
Member name | Value | Description
AlarmOncePerMinute | 7 | Alarm Once Per Minute
AlarmOncePerMinute__1 | 15 | Alarm Once Per Minute
AlarmWhenMinutesMatch | 6 | Alarm When Minutes Match
AlarmWhenMinutesMatch__1 | 14 | Alarm When Minutes Match
AlarmWhenHoursMatch | 4 | Alarm When Hours Match
AlarmWhenHoursMatch__1 | 12 | Alarm When Hours Match
AlarmWhenDateMatch | 0 | Alarm When Date Match
AlarmWhenDayMatch | 8 | Alarm When Day Match
Reserved | 2 | Reserved
Reserved__1 | 5 | Reserved
Reserved__2 | 9 | Reserved
Reserved__3 | 13 | Reserved
See Also

Reference

telos.Ird.Maxim Namespace


Ds1337.DayDateType Enumeration

IRD

Ds1337DayDateType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DayDateType
Public Enumeration DayDateType
public enum class DayDateType
type DayDateType
Members
Member name | Value | Description
Day | 1 | Day
Date | 0 | Date
See Also

Reference

telos.Ird.Maxim Namespace


Ds1337.EnableOscType Enumeration

IRD

Ds1337EnableOscType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum EnableOscType
Public Enumeration EnableOscType
public enum class EnableOscType
type EnableOscType
Members
Member name | Value | Description
StopOscillator | 1 | Stop Oscillator
StartOscillator | 0 | Start Oscillator
See Also

Reference

telos.Ird.Maxim Namespace


Ds1337.H1224Type Enumeration

IRD

Ds1337H1224Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum H1224Type
Public Enumeration H1224Type
public enum class H1224Type
type H1224Type
Members
Member name | Value | Description
Value_12Hours | 1 | 12 Hours
Value_24Hours | 0 | 24 Hours
See Also

Reference

telos.Ird.Maxim Namespace


Ds1337.InterruptControlType Enumeration

IRD

Ds1337InterruptControlType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum InterruptControlType
Public Enumeration InterruptControlType
public enum class InterruptControlType
type InterruptControlType
Members
Member name | Value | Description
Alarm1ActivatesINTAPin | 1 | Alarm1 Activates INTA Pin
Alarm1OrAlarm2ActivatesINTAPin | 0 | Alarm1 Or Alarm2 Activates INTA Pin
See Also

Reference

telos.Ird.Maxim Namespace


Ds1337.OscStopType Enumeration

IRD

Ds1337OscStopType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum OscStopType
Public Enumeration OscStopType
public enum class OscStopType
type OscStopType
Members
Member name | Value | Description
OscillatorStopFlagOSCStop | 1 | Oscillator Stop Flag: OSC Stop
OscillatorStopFlagOSCRunning | 0 | Oscillator Stop Flag: OSC Running
See Also

Reference

telos.Ird.Maxim Namespace


Ds1337.SquareWaveType Enumeration

IRD

Ds1337SquareWaveType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SquareWaveType
Public Enumeration SquareWaveType
public enum class SquareWaveType
type SquareWaveType
Members
Member name | Value | Description
SquareWaveFrequency1 | 0 | Square Wave Frequency: 1
SquareWaveFrequency4096 | 1 | Square Wave Frequency: 4096
SquareWaveFrequency8192 | 2 | Square Wave Frequency: 8192
SquareWaveFrequency32768 | 3 | Square Wave Frequency: 32768
See Also

Reference

telos.Ird.Maxim Namespace


Ds1338 Class

Maxim: DS 1338
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs1338

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds1338
Public Class Ds1338
public ref class Ds1338
type Ds1338 =  class end

The Ds1338 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds1338 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CH | CH
Public property | Date | Date
Public property | Day | Day
Public property | Hours | Hours (unit: h)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | OscillatorStopFlagOSF | Oscillator Stop Flag (OSF)
Public property | OutputControlOUT | Output Control (OUT)
Public property | Property_1224HourMode | 12/24-Hour Mode
Public property | RateSelectRS1RS0 | Rate Select (RS1, RS0) (unit: Hz)
Public property | Seconds | Seconds (unit: s)
Public property | SquareWaveEnableSQWE | Square-Wave Enable (SQWE)
Public property | Year | Year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Real-Time Clock
See Also

Reference

telos.Ird.Maxim Namespace


Ds1338 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1338(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds1338(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds1338

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds1338 Class
telos.Ird.Maxim Namespace


Ds1338 Properties

The Ds1338 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CH | CH
Public property | Date | Date
Public property | Day | Day
Public property | Hours | Hours (unit: h)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | OscillatorStopFlagOSF | Oscillator Stop Flag (OSF)
Public property | OutputControlOUT | Output Control (OUT)
Public property | Property_1224HourMode | 12/24-Hour Mode
Public property | RateSelectRS1RS0 | Rate Select (RS1, RS0) (unit: Hz)
Public property | Seconds | Seconds (unit: s)
Public property | SquareWaveEnableSQWE | Square-Wave Enable (SQWE)
Public property | Year | Year
Top
See Also

Reference

Ds1338 Class
telos.Ird.Maxim Namespace


Ds1338.AutoFlush Property

IRD

Ds1338AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds1338 Class
telos.Ird.Maxim Namespace


Ds1338.CH Property

IRD

Ds1338CH Property

CH

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1338ChType CH { get; set; }
Public Property CH As Ds1338ChType
    Get
    Set
public:
property Ds1338ChType CH {
    Ds1338ChType get ();
    void set (Ds1338ChType value);
}
member CH : Ds1338ChType with get, set

Property Value

Type: Ds1338ChType
See Also

Reference

Ds1338 Class
telos.Ird.Maxim Namespace


Ds1338.Date Property

IRD

Ds1338Date Property

Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Date { get; set; }
Public Property Date As Byte
    Get
    Set
public:
property unsigned char Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1338 Class
telos.Ird.Maxim Namespace


Ds1338.Day Property

IRD

Ds1338Day Property

Day

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Day { get; set; }
Public Property Day As Byte
    Get
    Set
public:
property unsigned char Day {
    unsigned char get ();
    void set (unsigned char value);
}
member Day : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1338 Class
telos.Ird.Maxim Namespace


Ds1338.Hours Property

IRD

Ds1338Hours Property

Hours (unit: h)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Hours { get; set; }
Public Property Hours As Byte
    Get
    Set
public:
property unsigned char Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1338 Class
telos.Ird.Maxim Namespace


Ds1338.Minutes Property

IRD

Ds1338Minutes Property

Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Minutes { get; set; }
Public Property Minutes As Byte
    Get
    Set
public:
property unsigned char Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1338 Class
telos.Ird.Maxim Namespace


Ds1338.Month Property

IRD

Ds1338Month Property

Month

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Month { get; set; }
Public Property Month As Byte
    Get
    Set
public:
property unsigned char Month {
    unsigned char get ();
    void set (unsigned char value);
}
member Month : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1338 Class
telos.Ird.Maxim Namespace


Ds1338.OscillatorStopFlagOSF Property

IRD

Ds1338OscillatorStopFlagOSF Property

Oscillator Stop Flag (OSF)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1338OsfType OscillatorStopFlagOSF { get; set; }
Public Property OscillatorStopFlagOSF As Ds1338OsfType
    Get
    Set
public:
property Ds1338OsfType OscillatorStopFlagOSF {
    Ds1338OsfType get ();
    void set (Ds1338OsfType value);
}
member OscillatorStopFlagOSF : Ds1338OsfType with get, set

Property Value

Type: Ds1338OsfType
See Also

Reference

Ds1338 Class
telos.Ird.Maxim Namespace


Ds1338.OutputControlOUT Property

IRD

Ds1338OutputControlOUT Property

Output Control (OUT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1338OutType OutputControlOUT { get; set; }
Public Property OutputControlOUT As Ds1338OutType
    Get
    Set
public:
property Ds1338OutType OutputControlOUT {
    Ds1338OutType get ();
    void set (Ds1338OutType value);
}
member OutputControlOUT : Ds1338OutType with get, set

Property Value

Type: Ds1338OutType
See Also

Reference

Ds1338 Class
telos.Ird.Maxim Namespace


Ds1338.Property_1224HourMode Property

IRD

Ds1338Property_1224HourMode Property

12/24-Hour Mode

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1338H1224Type Property_1224HourMode { get; set; }
Public Property Property_1224HourMode As Ds1338H1224Type
    Get
    Set
public:
property Ds1338H1224Type Property_1224HourMode {
    Ds1338H1224Type get ();
    void set (Ds1338H1224Type value);
}
member Property_1224HourMode : Ds1338H1224Type with get, set

Property Value

Type: Ds1338H1224Type
See Also

Reference

Ds1338 Class
telos.Ird.Maxim Namespace


Ds1338.RateSelectRS1RS0 Property

IRD

Ds1338RateSelectRS1RS0 Property

Rate Select (RS1, RS0) (unit: Hz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1338RateType RateSelectRS1RS0 { get; set; }
Public Property RateSelectRS1RS0 As Ds1338RateType
    Get
    Set
public:
property Ds1338RateType RateSelectRS1RS0 {
    Ds1338RateType get ();
    void set (Ds1338RateType value);
}
member RateSelectRS1RS0 : Ds1338RateType with get, set

Property Value

Type: Ds1338RateType
See Also

Reference

Ds1338 Class
telos.Ird.Maxim Namespace


Ds1338.Seconds Property

IRD

Ds1338Seconds Property

Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Seconds { get; set; }
Public Property Seconds As Byte
    Get
    Set
public:
property unsigned char Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1338 Class
telos.Ird.Maxim Namespace


Ds1338.SquareWaveEnableSQWE Property

IRD

Ds1338SquareWaveEnableSQWE Property

Square-Wave Enable (SQWE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1338SqweType SquareWaveEnableSQWE { get; set; }
Public Property SquareWaveEnableSQWE As Ds1338SqweType
    Get
    Set
public:
property Ds1338SqweType SquareWaveEnableSQWE {
    Ds1338SqweType get ();
    void set (Ds1338SqweType value);
}
member SquareWaveEnableSQWE : Ds1338SqweType with get, set

Property Value

Type: Ds1338SqweType
See Also

Reference

Ds1338 Class
telos.Ird.Maxim Namespace


Ds1338.Year Property

IRD

Ds1338Year Property

Year

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Year { get; set; }
Public Property Year As Byte
    Get
    Set
public:
property unsigned char Year {
    unsigned char get ();
    void set (unsigned char value);
}
member Year : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1338 Class
telos.Ird.Maxim Namespace


Ds1338 Methods

The Ds1338 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds1338 Class
telos.Ird.Maxim Namespace


Ds1338.Flush Method

IRD

Ds1338Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds1338 Class
telos.Ird.Maxim Namespace


Ds1338.ChType Enumeration

IRD

Ds1338ChType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ChType
Public Enumeration ChType
public enum class ChType
type ChType
Members
Member name | Value | Description
OscillatorDisabled | 1 | Oscillator Disabled
OscillatorEnabled | 0 | Oscillator Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds1338.H1224Type Enumeration

IRD

Ds1338H1224Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum H1224Type
Public Enumeration H1224Type
public enum class H1224Type
type H1224Type
Members
Member name | Value | Description
Value_12HourMode | 1 | 12-hour mode
Value_24HourMode | 0 | 24-hour mode
See Also

Reference

telos.Ird.Maxim Namespace


Ds1338.OsfType Enumeration

IRD

Ds1338OsfType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum OsfType
Public Enumeration OsfType
public enum class OsfType
type OsfType
Members
Member name | Value | Description
OscillatorStop | 1 | Oscillator Stop
OscillatorStart | 0 | Oscillator Start
See Also

Reference

telos.Ird.Maxim Namespace


Ds1338.OutType Enumeration

IRD

Ds1338OutType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum OutType
Public Enumeration OutType
public enum class OutType
type OutType
Members
Member name | Value | Description
OUT1 | 1 | OUT=1
OUT0 | 0 | OUT=0
See Also

Reference

telos.Ird.Maxim Namespace


Ds1338.RateType Enumeration

IRD

Ds1338RateType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum RateType
Public Enumeration RateType
public enum class RateType
type RateType
Members
Member name | Value | Description
Value_32768 | 3 | 32768
Value_8192 | 2 | 8192
Value_4096 | 1 | 4096
Value_1 | 0 | 1
See Also

Reference

telos.Ird.Maxim Namespace


Ds1338.SqweType Enumeration

IRD

Ds1338SqweType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SqweType
Public Enumeration SqweType
public enum class SqweType
type SqweType
Members
Member name | Value | Description
OutputEnabled | 1 | Output Enabled
OutputDisabled | 0 | Output Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds1339 Class

Maxim: DS 1339
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs1339

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds1339
Public Class Ds1339
public ref class Ds1339
type Ds1339 =  class end

The Ds1339 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds1339 | Constructor
Top
Properties
 | Name | Description
Public property | Alarm1Date | Alarm 1 Date
Public property | Alarm1DayDateSwitchDYDT | Alarm 1 Day Date Switch (DY/DT)
Public property | Alarm1FlagA1F | Alarm 1 Flag (A1F)
Public property | Alarm1Hours | Alarm 1 Hours (unit: hour)
Public property | Alarm1InterruptEnableA1IE | Alarm 1 Interrupt Enable (A1IE)
Public property | Alarm1MaskBitsA1Mx | Alarm1 Mask Bits (A1Mx)
Public property | Alarm1Minutes | Alarm 1 Minutes (unit: min)
Public property | Alarm1Seconds | Alarm 1 Seconds (unit: s)
Public property | Alarm1Switch12To24Hours1224 | Alarm 1 Switch 12 To 24 Hours (12/24)
Public property | Alarm2Date | Alarm 2 Date
Public property | Alarm2DayDateSwitchDYDT | Alarm 2 Day Date Switch (DY/DT)
Public property | Alarm2FlagA2F | Alarm 2 Flag (A2F)
Public property | Alarm2Hours | Alarm 2 Hours (unit: hour)
Public property | Alarm2InterruptControlINTCN | Alarm 2 Interrupt Control (INTCN)
Public property | Alarm2InterruptEnableA2IE | Alarm 2 Interrupt Enable (A2IE)
Public property | Alarm2MaskBitsA2Mx | Alarm2 Mask Bits (A2Mx)
Public property | Alarm2Minutes | Alarm 2 Minutes (unit: min)
Public property | Alarm2Switch12To24Hours1224 | Alarm 2 Switch 12 To 24 Hours (12/24)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryBackedSquareWaveInterrruptEnableBBSQI | Battery Backed Square Wave Interrrupt Enable (BBSQI)
Public property | Century | Century
Public property | Date | Date
Public property | Day | Day
Public property | DiodeSelectDSx | Diode Select (DSx)
Public property | EnableOscillatorEOSC | Enable Oscillator (EOSC)
Public property | Hours | Hours (unit: hour)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | OscillatorStopFlagOSF | Oscillator Stop Flag (OSF)
Public property | ResistorSelectROUTx | Resistor Select (ROUTx)
Public property | Seconds | Seconds (unit: s)
Public property | SquareWaveOutputRSx | Square Wave Output (RSx) (unit: Hz)
Public property | Switch12To24Hours1224 | Switch 12 To 24 Hours (12/24)
Public property | TrickleChargeTCSx | Trickle Charge (TCSx)
Public property | Year | Year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Serial Real Time Clock
See Also

Reference

telos.Ird.Maxim Namespace


Ds1339 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds1339(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds1339

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339 Properties

The Ds1339 type exposes the following members.

Properties
 | Name | Description
Public property | Alarm1Date | Alarm 1 Date
Public property | Alarm1DayDateSwitchDYDT | Alarm 1 Day Date Switch (DY/DT)
Public property | Alarm1FlagA1F | Alarm 1 Flag (A1F)
Public property | Alarm1Hours | Alarm 1 Hours (unit: hour)
Public property | Alarm1InterruptEnableA1IE | Alarm 1 Interrupt Enable (A1IE)
Public property | Alarm1MaskBitsA1Mx | Alarm1 Mask Bits (A1Mx)
Public property | Alarm1Minutes | Alarm 1 Minutes (unit: min)
Public property | Alarm1Seconds | Alarm 1 Seconds (unit: s)
Public property | Alarm1Switch12To24Hours1224 | Alarm 1 Switch 12 To 24 Hours (12/24)
Public property | Alarm2Date | Alarm 2 Date
Public property | Alarm2DayDateSwitchDYDT | Alarm 2 Day Date Switch (DY/DT)
Public property | Alarm2FlagA2F | Alarm 2 Flag (A2F)
Public property | Alarm2Hours | Alarm 2 Hours (unit: hour)
Public property | Alarm2InterruptControlINTCN | Alarm 2 Interrupt Control (INTCN)
Public property | Alarm2InterruptEnableA2IE | Alarm 2 Interrupt Enable (A2IE)
Public property | Alarm2MaskBitsA2Mx | Alarm2 Mask Bits (A2Mx)
Public property | Alarm2Minutes | Alarm 2 Minutes (unit: min)
Public property | Alarm2Switch12To24Hours1224 | Alarm 2 Switch 12 To 24 Hours (12/24)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryBackedSquareWaveInterrruptEnableBBSQI | Battery Backed Square Wave Interrrupt Enable (BBSQI)
Public property | Century | Century
Public property | Date | Date
Public property | Day | Day
Public property | DiodeSelectDSx | Diode Select (DSx)
Public property | EnableOscillatorEOSC | Enable Oscillator (EOSC)
Public property | Hours | Hours (unit: hour)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | OscillatorStopFlagOSF | Oscillator Stop Flag (OSF)
Public property | ResistorSelectROUTx | Resistor Select (ROUTx)
Public property | Seconds | Seconds (unit: s)
Public property | SquareWaveOutputRSx | Square Wave Output (RSx) (unit: Hz)
Public property | Switch12To24Hours1224 | Switch 12 To 24 Hours (12/24)
Public property | TrickleChargeTCSx | Trickle Charge (TCSx)
Public property | Year | Year
Top
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Alarm1Date Property

IRD

Ds1339Alarm1Date Property

Alarm 1 Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm1Date { get; set; }
Public Property Alarm1Date As Byte
    Get
    Set
public:
property unsigned char Alarm1Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm1Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Alarm1DayDateSwitchDYDT Property

IRD

Ds1339Alarm1DayDateSwitchDYDT Property

Alarm 1 Day Date Switch (DY/DT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339DayDateType Alarm1DayDateSwitchDYDT { get; set; }
Public Property Alarm1DayDateSwitchDYDT As Ds1339DayDateType
    Get
    Set
public:
property Ds1339DayDateType Alarm1DayDateSwitchDYDT {
    Ds1339DayDateType get ();
    void set (Ds1339DayDateType value);
}
member Alarm1DayDateSwitchDYDT : Ds1339DayDateType with get, set

Property Value

Type: Ds1339DayDateType
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Alarm1FlagA1F Property

IRD

Ds1339Alarm1FlagA1F Property

Alarm 1 Flag (A1F)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339AlarmFlagType Alarm1FlagA1F { get; set; }
Public Property Alarm1FlagA1F As Ds1339AlarmFlagType
    Get
    Set
public:
property Ds1339AlarmFlagType Alarm1FlagA1F {
    Ds1339AlarmFlagType get ();
    void set (Ds1339AlarmFlagType value);
}
member Alarm1FlagA1F : Ds1339AlarmFlagType with get, set

Property Value

Type: Ds1339AlarmFlagType
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Alarm1Hours Property

IRD

Ds1339Alarm1Hours Property

Alarm 1 Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm1Hours { get; set; }
Public Property Alarm1Hours As Byte
    Get
    Set
public:
property unsigned char Alarm1Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm1Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Alarm1InterruptEnableA1IE Property

IRD

Ds1339Alarm1InterruptEnableA1IE Property

Alarm 1 Interrupt Enable (A1IE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339AlarmIntType Alarm1InterruptEnableA1IE { get; set; }
Public Property Alarm1InterruptEnableA1IE As Ds1339AlarmIntType
    Get
    Set
public:
property Ds1339AlarmIntType Alarm1InterruptEnableA1IE {
    Ds1339AlarmIntType get ();
    void set (Ds1339AlarmIntType value);
}
member Alarm1InterruptEnableA1IE : Ds1339AlarmIntType with get, set

Property Value

Type: Ds1339AlarmIntType
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Alarm1MaskBitsA1Mx Property

IRD

Ds1339Alarm1MaskBitsA1Mx Property

Alarm1 Mask Bits (A1Mx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339AlarmMask1Type Alarm1MaskBitsA1Mx { get; set; }
Public Property Alarm1MaskBitsA1Mx As Ds1339AlarmMask1Type
    Get
    Set
public:
property Ds1339AlarmMask1Type Alarm1MaskBitsA1Mx {
    Ds1339AlarmMask1Type get ();
    void set (Ds1339AlarmMask1Type value);
}
member Alarm1MaskBitsA1Mx : Ds1339AlarmMask1Type with get, set

Property Value

Type: Ds1339AlarmMask1Type
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Alarm1Minutes Property

IRD

Ds1339Alarm1Minutes Property

Alarm 1 Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm1Minutes { get; set; }
Public Property Alarm1Minutes As Byte
    Get
    Set
public:
property unsigned char Alarm1Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm1Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Alarm1Seconds Property

IRD

Ds1339Alarm1Seconds Property

Alarm 1 Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm1Seconds { get; set; }
Public Property Alarm1Seconds As Byte
    Get
    Set
public:
property unsigned char Alarm1Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm1Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Alarm1Switch12To24Hours1224 Property

IRD

Ds1339Alarm1Switch12To24Hours1224 Property

Alarm 1 Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339H1224Type Alarm1Switch12To24Hours1224 { get; set; }
Public Property Alarm1Switch12To24Hours1224 As Ds1339H1224Type
    Get
    Set
public:
property Ds1339H1224Type Alarm1Switch12To24Hours1224 {
    Ds1339H1224Type get ();
    void set (Ds1339H1224Type value);
}
member Alarm1Switch12To24Hours1224 : Ds1339H1224Type with get, set

Property Value

Type: Ds1339H1224Type
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Alarm2Date Property

IRD

Ds1339Alarm2Date Property

Alarm 2 Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm2Date { get; set; }
Public Property Alarm2Date As Byte
    Get
    Set
public:
property unsigned char Alarm2Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm2Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Alarm2DayDateSwitchDYDT Property

IRD

Ds1339Alarm2DayDateSwitchDYDT Property

Alarm 2 Day Date Switch (DY/DT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339DayDateType Alarm2DayDateSwitchDYDT { get; set; }
Public Property Alarm2DayDateSwitchDYDT As Ds1339DayDateType
    Get
    Set
public:
property Ds1339DayDateType Alarm2DayDateSwitchDYDT {
    Ds1339DayDateType get ();
    void set (Ds1339DayDateType value);
}
member Alarm2DayDateSwitchDYDT : Ds1339DayDateType with get, set

Property Value

Type: Ds1339DayDateType
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Alarm2FlagA2F Property

IRD

Ds1339Alarm2FlagA2F Property

Alarm 2 Flag (A2F)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339AlarmFlagType Alarm2FlagA2F { get; set; }
Public Property Alarm2FlagA2F As Ds1339AlarmFlagType
    Get
    Set
public:
property Ds1339AlarmFlagType Alarm2FlagA2F {
    Ds1339AlarmFlagType get ();
    void set (Ds1339AlarmFlagType value);
}
member Alarm2FlagA2F : Ds1339AlarmFlagType with get, set

Property Value

Type: Ds1339AlarmFlagType
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Alarm2Hours Property

IRD

Ds1339Alarm2Hours Property

Alarm 2 Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm2Hours { get; set; }
Public Property Alarm2Hours As Byte
    Get
    Set
public:
property unsigned char Alarm2Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm2Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Alarm2InterruptControlINTCN Property

IRD

Ds1339Alarm2InterruptControlINTCN Property

Alarm 2 Interrupt Control (INTCN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339InterruptControlType Alarm2InterruptControlINTCN { get; set; }
Public Property Alarm2InterruptControlINTCN As Ds1339InterruptControlType
    Get
    Set
public:
property Ds1339InterruptControlType Alarm2InterruptControlINTCN {
    Ds1339InterruptControlType get ();
    void set (Ds1339InterruptControlType value);
}
member Alarm2InterruptControlINTCN : Ds1339InterruptControlType with get, set

Property Value

Type: Ds1339InterruptControlType
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Alarm2InterruptEnableA2IE Property

IRD

Ds1339Alarm2InterruptEnableA2IE Property

Alarm 2 Interrupt Enable (A2IE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339AlarmIntType Alarm2InterruptEnableA2IE { get; set; }
Public Property Alarm2InterruptEnableA2IE As Ds1339AlarmIntType
    Get
    Set
public:
property Ds1339AlarmIntType Alarm2InterruptEnableA2IE {
    Ds1339AlarmIntType get ();
    void set (Ds1339AlarmIntType value);
}
member Alarm2InterruptEnableA2IE : Ds1339AlarmIntType with get, set

Property Value

Type: Ds1339AlarmIntType
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Alarm2MaskBitsA2Mx Property

IRD

Ds1339Alarm2MaskBitsA2Mx Property

Alarm2 Mask Bits (A2Mx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339AlarmMask2Type Alarm2MaskBitsA2Mx { get; set; }
Public Property Alarm2MaskBitsA2Mx As Ds1339AlarmMask2Type
    Get
    Set
public:
property Ds1339AlarmMask2Type Alarm2MaskBitsA2Mx {
    Ds1339AlarmMask2Type get ();
    void set (Ds1339AlarmMask2Type value);
}
member Alarm2MaskBitsA2Mx : Ds1339AlarmMask2Type with get, set

Property Value

Type: Ds1339AlarmMask2Type
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Alarm2Minutes Property

IRD

Ds1339Alarm2Minutes Property

Alarm 2 Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm2Minutes { get; set; }
Public Property Alarm2Minutes As Byte
    Get
    Set
public:
property unsigned char Alarm2Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm2Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Alarm2Switch12To24Hours1224 Property

IRD

Ds1339Alarm2Switch12To24Hours1224 Property

Alarm 2 Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339H1224Type Alarm2Switch12To24Hours1224 { get; set; }
Public Property Alarm2Switch12To24Hours1224 As Ds1339H1224Type
    Get
    Set
public:
property Ds1339H1224Type Alarm2Switch12To24Hours1224 {
    Ds1339H1224Type get ();
    void set (Ds1339H1224Type value);
}
member Alarm2Switch12To24Hours1224 : Ds1339H1224Type with get, set

Property Value

Type: Ds1339H1224Type
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.AutoFlush Property

IRD

Ds1339AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.BatteryBackedSquareWaveInterrruptEnableBBSQI Property

IRD

Ds1339BatteryBackedSquareWaveInterrruptEnableBBSQI Property

Battery Backed Square Wave Interrrupt Enable (BBSQI)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339BbsqiType BatteryBackedSquareWaveInterrruptEnableBBSQI { get; set; }
Public Property BatteryBackedSquareWaveInterrruptEnableBBSQI As Ds1339BbsqiType
    Get
    Set
public:
property Ds1339BbsqiType BatteryBackedSquareWaveInterrruptEnableBBSQI {
    Ds1339BbsqiType get ();
    void set (Ds1339BbsqiType value);
}
member BatteryBackedSquareWaveInterrruptEnableBBSQI : Ds1339BbsqiType with get, set

Property Value

Type: Ds1339BbsqiType
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Century Property

IRD

Ds1339Century Property

Century

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Century { get; set; }
Public Property Century As Byte
    Get
    Set
public:
property unsigned char Century {
    unsigned char get ();
    void set (unsigned char value);
}
member Century : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Date Property

IRD

Ds1339Date Property

Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Date { get; set; }
Public Property Date As Byte
    Get
    Set
public:
property unsigned char Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Day Property

IRD

Ds1339Day Property

Day

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Day { get; set; }
Public Property Day As Byte
    Get
    Set
public:
property unsigned char Day {
    unsigned char get ();
    void set (unsigned char value);
}
member Day : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.DiodeSelectDSx Property

IRD

Ds1339DiodeSelectDSx Property

Diode Select (DSx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339DiodeSelectType DiodeSelectDSx { get; set; }
Public Property DiodeSelectDSx As Ds1339DiodeSelectType
    Get
    Set
public:
property Ds1339DiodeSelectType DiodeSelectDSx {
    Ds1339DiodeSelectType get ();
    void set (Ds1339DiodeSelectType value);
}
member DiodeSelectDSx : Ds1339DiodeSelectType with get, set

Property Value

Type: Ds1339DiodeSelectType
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.EnableOscillatorEOSC Property

IRD

Ds1339EnableOscillatorEOSC Property

Enable Oscillator (EOSC)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339EnableOscType EnableOscillatorEOSC { get; set; }
Public Property EnableOscillatorEOSC As Ds1339EnableOscType
    Get
    Set
public:
property Ds1339EnableOscType EnableOscillatorEOSC {
    Ds1339EnableOscType get ();
    void set (Ds1339EnableOscType value);
}
member EnableOscillatorEOSC : Ds1339EnableOscType with get, set

Property Value

Type: Ds1339EnableOscType
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Hours Property

IRD

Ds1339Hours Property

Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Hours { get; set; }
Public Property Hours As Byte
    Get
    Set
public:
property unsigned char Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Minutes Property

IRD

Ds1339Minutes Property

Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Minutes { get; set; }
Public Property Minutes As Byte
    Get
    Set
public:
property unsigned char Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Month Property

IRD

Ds1339Month Property

Month

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Month { get; set; }
Public Property Month As Byte
    Get
    Set
public:
property unsigned char Month {
    unsigned char get ();
    void set (unsigned char value);
}
member Month : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.OscillatorStopFlagOSF Property

IRD

Ds1339OscillatorStopFlagOSF Property

Oscillator Stop Flag (OSF)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339OscStopType OscillatorStopFlagOSF { get; set; }
Public Property OscillatorStopFlagOSF As Ds1339OscStopType
    Get
    Set
public:
property Ds1339OscStopType OscillatorStopFlagOSF {
    Ds1339OscStopType get ();
    void set (Ds1339OscStopType value);
}
member OscillatorStopFlagOSF : Ds1339OscStopType with get, set

Property Value

Type: Ds1339OscStopType
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.ResistorSelectROUTx Property

IRD

Ds1339ResistorSelectROUTx Property

Resistor Select (ROUTx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339ResistorType ResistorSelectROUTx { get; set; }
Public Property ResistorSelectROUTx As Ds1339ResistorType
    Get
    Set
public:
property Ds1339ResistorType ResistorSelectROUTx {
    Ds1339ResistorType get ();
    void set (Ds1339ResistorType value);
}
member ResistorSelectROUTx : Ds1339ResistorType with get, set

Property Value

Type: Ds1339ResistorType
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Seconds Property

IRD

Ds1339Seconds Property

Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Seconds { get; set; }
Public Property Seconds As Byte
    Get
    Set
public:
property unsigned char Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.SquareWaveOutputRSx Property

IRD

Ds1339SquareWaveOutputRSx Property

Square Wave Output (RSx) (unit: Hz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339SquareWaveType SquareWaveOutputRSx { get; set; }
Public Property SquareWaveOutputRSx As Ds1339SquareWaveType
    Get
    Set
public:
property Ds1339SquareWaveType SquareWaveOutputRSx {
    Ds1339SquareWaveType get ();
    void set (Ds1339SquareWaveType value);
}
member SquareWaveOutputRSx : Ds1339SquareWaveType with get, set

Property Value

Type: Ds1339SquareWaveType
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Switch12To24Hours1224 Property

IRD

Ds1339Switch12To24Hours1224 Property

Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339H1224Type Switch12To24Hours1224 { get; set; }
Public Property Switch12To24Hours1224 As Ds1339H1224Type
    Get
    Set
public:
property Ds1339H1224Type Switch12To24Hours1224 {
    Ds1339H1224Type get ();
    void set (Ds1339H1224Type value);
}
member Switch12To24Hours1224 : Ds1339H1224Type with get, set

Property Value

Type: Ds1339H1224Type
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.TrickleChargeTCSx Property

IRD

Ds1339TrickleChargeTCSx Property

Trickle Charge (TCSx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1339TrickleType TrickleChargeTCSx { get; set; }
Public Property TrickleChargeTCSx As Ds1339TrickleType
    Get
    Set
public:
property Ds1339TrickleType TrickleChargeTCSx {
    Ds1339TrickleType get ();
    void set (Ds1339TrickleType value);
}
member TrickleChargeTCSx : Ds1339TrickleType with get, set

Property Value

Type: Ds1339TrickleType
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Year Property

IRD

Ds1339Year Property

Year

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Year { get; set; }
Public Property Year As Byte
    Get
    Set
public:
property unsigned char Year {
    unsigned char get ();
    void set (unsigned char value);
}
member Year : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339 Methods

The Ds1339 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.Flush Method

IRD

Ds1339Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds1339 Class
telos.Ird.Maxim Namespace


Ds1339.AlarmFlagType Enumeration

IRD

Ds1339AlarmFlagType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmFlagType
Public Enumeration AlarmFlagType
public enum class AlarmFlagType
type AlarmFlagType
Members
Member name | Value | Description
TimeMatchedAlarm | 1 | Time Matched Alarm
NoTimeMatchAlarm | 0 | No Time Match Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Ds1339.AlarmIntType Enumeration

IRD

Ds1339AlarmIntType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmIntType
Public Enumeration AlarmIntType
public enum class AlarmIntType
type AlarmIntType
Members
Member name | Value | Description
AlarmInterruptEnable | 1 | Alarm Interrupt: Enable
AlarmInterruptDisable | 0 | Alarm Interrupt: Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds1339.AlarmMask1Type Enumeration

IRD

Ds1339AlarmMask1Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmMask1Type
Public Enumeration AlarmMask1Type
public enum class AlarmMask1Type
type AlarmMask1Type
Members
Member name | Value | Description
AlarmOncePerSecond | 15 | Alarm Once Per Second
AlarmOncePerSecond__1 | 31 | Alarm Once Per Second
AlarmWhenSecondsMatch | 14 | Alarm When Seconds Match
AlarmWhenSecondsMatch__1 | 30 | Alarm When Seconds Match
AlarmWhenMinutesMatch | 12 | Alarm When Minutes Match
AlarmWhenMinutesMatch__1 | 28 | Alarm When Minutes Match
AlarmWhenHoursMatch | 8 | Alarm When Hours Match
AlarmWhenHoursMatch__1 | 24 | Alarm When Hours Match
AlarmWhenDateMatch | 0 | Alarm When Date Match
AlarmWhenDayMatch | 16 | Alarm When Day Match
Reserved | 1 | Reserved
Reserved__1 | 9 | Reserved
Reserved__2 | 13 | Reserved
Reserved__3 | 17 | Reserved
Reserved__4 | 25 | Reserved
Reserved__5 | 29 | Reserved
See Also

Reference

telos.Ird.Maxim Namespace


Ds1339.AlarmMask2Type Enumeration

IRD

Ds1339AlarmMask2Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmMask2Type
Public Enumeration AlarmMask2Type
public enum class AlarmMask2Type
type AlarmMask2Type
Members
Member name | Value | Description
AlarmOncePerMinute | 7 | Alarm Once Per Minute
AlarmOncePerMinute__1 | 15 | Alarm Once Per Minute
AlarmWhenMinutesMatch | 6 | Alarm When Minutes Match
AlarmWhenMinutesMatch__1 | 14 | Alarm When Minutes Match
AlarmWhenHoursMatch | 4 | Alarm When Hours Match
AlarmWhenHoursMatch__1 | 12 | Alarm When Hours Match
AlarmWhenDateMatch | 0 | Alarm When Date Match
AlarmWhenDayMatch | 8 | Alarm When Day Match
Reserved | 2 | Reserved
Reserved__1 | 5 | Reserved
Reserved__2 | 9 | Reserved
Reserved__3 | 13 | Reserved
See Also

Reference

telos.Ird.Maxim Namespace


Ds1339.BbsqiType Enumeration

IRD

Ds1339BbsqiType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum BbsqiType
Public Enumeration BbsqiType
public enum class BbsqiType
type BbsqiType
Members
Member name | Value | Description
BBSQIEnable | 1 | BBSQI Enable
BBSQIDisable | 0 | BBSQI Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds1339.DayDateType Enumeration

IRD

Ds1339DayDateType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DayDateType
Public Enumeration DayDateType
public enum class DayDateType
type DayDateType
Members
Member name | Value | Description
Day | 1 | Day
Date | 0 | Date
See Also

Reference

telos.Ird.Maxim Namespace


Ds1339.DiodeSelectType Enumeration

IRD

Ds1339DiodeSelectType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DiodeSelectType
Public Enumeration DiodeSelectType
public enum class DiodeSelectType
type DiodeSelectType
Members
Member name | Value | Description
Disabled | 0 | Disabled
NoDiodeSelected | 1 | No Diode Selected
OneDiodeSelected | 2 | One Diode Selected
Disabled__1 | 3 | Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds1339.EnableOscType Enumeration

IRD

Ds1339EnableOscType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum EnableOscType
Public Enumeration EnableOscType
public enum class EnableOscType
type EnableOscType
Members
Member name | Value | Description
StopOscillator | 1 | Stop Oscillator
StartOscillator | 0 | Start Oscillator
See Also

Reference

telos.Ird.Maxim Namespace


Ds1339.H1224Type Enumeration

IRD

Ds1339H1224Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum H1224Type
Public Enumeration H1224Type
public enum class H1224Type
type H1224Type
Members
Member name | Value | Description
Value_12Hours | 1 | 12 Hours
Value_24Hours | 0 | 24 Hours
See Also

Reference

telos.Ird.Maxim Namespace


Ds1339.InterruptControlType Enumeration

IRD

Ds1339InterruptControlType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum InterruptControlType
Public Enumeration InterruptControlType
public enum class InterruptControlType
type InterruptControlType
Members
Member name | Value | Description
Alarm1ActivatesINTAPin | 1 | Alarm1 Activates INTA Pin
Alarm1OrAlarm2ActivatesINTAPin | 0 | Alarm1 Or Alarm2 Activates INTA Pin
See Also

Reference

telos.Ird.Maxim Namespace


Ds1339.OscStopType Enumeration

IRD

Ds1339OscStopType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum OscStopType
Public Enumeration OscStopType
public enum class OscStopType
type OscStopType
Members
Member name | Value | Description
OscillatorStopFlagOSCStop | 1 | Oscillator Stop Flag: OSC Stop
OscillatorStopFlagOSCRunning | 0 | Oscillator Stop Flag: OSC Running
See Also

Reference

telos.Ird.Maxim Namespace


Ds1339.ResistorType Enumeration

IRD

Ds1339ResistorType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ResistorType
Public Enumeration ResistorType
public enum class ResistorType
type ResistorType
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_250OhmResistor | 1 | 250 Ohm Resistor
Value_2KOhmResistor | 2 | 2 kOhm Resistor
Value_4KOhmResistor | 3 | 4 kOhm Resistor
See Also

Reference

telos.Ird.Maxim Namespace


Ds1339.SquareWaveType Enumeration

IRD

Ds1339SquareWaveType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SquareWaveType
Public Enumeration SquareWaveType
public enum class SquareWaveType
type SquareWaveType
Members
Member name | Value | Description
SquareWaveFrequency1 | 0 | Square Wave Frequency: 1
SquareWaveFrequency4096 | 1 | Square Wave Frequency: 4096
SquareWaveFrequency8192 | 2 | Square Wave Frequency: 8192
SquareWaveFrequency32768 | 3 | Square Wave Frequency: 32768
See Also

Reference

telos.Ird.Maxim Namespace


Ds1339.TrickleType Enumeration

IRD

Ds1339TrickleType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TrickleType
Public Enumeration TrickleType
public enum class TrickleType
type TrickleType
Members
Member name | Value | Description
TrickleChargeDisabled | 0 | Trickle Charge Disabled
TrickleChargeEnabled | 10 | Trickle Charge Enabled
TrickleChargeDisabled__1 | 11 | Trickle Charge Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds1340 Class

Maxim: DS 1340
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs1340

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds1340
Public Class Ds1340
public ref class Ds1340
type Ds1340 =  class end

The Ds1340 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds1340 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CalibrationCALx | Calibration (CALx)
Public property | CalibrationSignS | Calibration Sign (S)
Public property | CenturyCB | Century (CB)
Public property | CenturyEnableCEB | Century Enable (CEB)
Public property | Date | Date
Public property | Day | Day
Public property | DiodeSelectDSx | Diode Select (DSx)
Public property | EnableOscillatorEOSC | Enable Oscillator (EOSC)
Public property | FrequencyTestFT | Frequency Test (FT)
Public property | Hours | Hours (unit: hour)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | OscillatorStopFlagOSF | Oscillator Stop Flag (OSF)
Public property | OutputControlOUT | Output Control (OUT)
Public property | ResistorSelectROUTx | Resistor Select (ROUTx)
Public property | Seconds | Seconds (unit: s)
Public property | TrickleChargeTCSx | Trickle Charge (TCSx)
Public property | Year | Year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
RTC With Trickle Charger
See Also

Reference

telos.Ird.Maxim Namespace


Ds1340 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1340(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds1340(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds1340

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340 Properties

The Ds1340 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CalibrationCALx | Calibration (CALx)
Public property | CalibrationSignS | Calibration Sign (S)
Public property | CenturyCB | Century (CB)
Public property | CenturyEnableCEB | Century Enable (CEB)
Public property | Date | Date
Public property | Day | Day
Public property | DiodeSelectDSx | Diode Select (DSx)
Public property | EnableOscillatorEOSC | Enable Oscillator (EOSC)
Public property | FrequencyTestFT | Frequency Test (FT)
Public property | Hours | Hours (unit: hour)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | OscillatorStopFlagOSF | Oscillator Stop Flag (OSF)
Public property | OutputControlOUT | Output Control (OUT)
Public property | ResistorSelectROUTx | Resistor Select (ROUTx)
Public property | Seconds | Seconds (unit: s)
Public property | TrickleChargeTCSx | Trickle Charge (TCSx)
Public property | Year | Year
Top
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.AutoFlush Property

IRD

Ds1340AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.CalibrationCALx Property

IRD

Ds1340CalibrationCALx Property

Calibration (CALx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CalibrationCALx { get; set; }
Public Property CalibrationCALx As Byte
    Get
    Set
public:
property unsigned char CalibrationCALx {
    unsigned char get ();
    void set (unsigned char value);
}
member CalibrationCALx : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.CalibrationSignS Property

IRD

Ds1340CalibrationSignS Property

Calibration Sign (S)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1340CalibrationSignType CalibrationSignS { get; set; }
Public Property CalibrationSignS As Ds1340CalibrationSignType
    Get
    Set
public:
property Ds1340CalibrationSignType CalibrationSignS {
    Ds1340CalibrationSignType get ();
    void set (Ds1340CalibrationSignType value);
}
member CalibrationSignS : Ds1340CalibrationSignType with get, set

Property Value

Type: Ds1340CalibrationSignType
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.CenturyCB Property

IRD

Ds1340CenturyCB Property

Century (CB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CenturyCB { get; set; }
Public Property CenturyCB As Byte
    Get
    Set
public:
property unsigned char CenturyCB {
    unsigned char get ();
    void set (unsigned char value);
}
member CenturyCB : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.CenturyEnableCEB Property

IRD

Ds1340CenturyEnableCEB Property

Century Enable (CEB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1340CenturyEnableType CenturyEnableCEB { get; set; }
Public Property CenturyEnableCEB As Ds1340CenturyEnableType
    Get
    Set
public:
property Ds1340CenturyEnableType CenturyEnableCEB {
    Ds1340CenturyEnableType get ();
    void set (Ds1340CenturyEnableType value);
}
member CenturyEnableCEB : Ds1340CenturyEnableType with get, set

Property Value

Type: Ds1340CenturyEnableType
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.Date Property

IRD

Ds1340Date Property

Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Date { get; set; }
Public Property Date As Byte
    Get
    Set
public:
property unsigned char Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.Day Property

IRD

Ds1340Day Property

Day

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Day { get; set; }
Public Property Day As Byte
    Get
    Set
public:
property unsigned char Day {
    unsigned char get ();
    void set (unsigned char value);
}
member Day : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.DiodeSelectDSx Property

IRD

Ds1340DiodeSelectDSx Property

Diode Select (DSx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1340DiodeSelectType DiodeSelectDSx { get; set; }
Public Property DiodeSelectDSx As Ds1340DiodeSelectType
    Get
    Set
public:
property Ds1340DiodeSelectType DiodeSelectDSx {
    Ds1340DiodeSelectType get ();
    void set (Ds1340DiodeSelectType value);
}
member DiodeSelectDSx : Ds1340DiodeSelectType with get, set

Property Value

Type: Ds1340DiodeSelectType
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.EnableOscillatorEOSC Property

IRD

Ds1340EnableOscillatorEOSC Property

Enable Oscillator (EOSC)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1340EnableOscType EnableOscillatorEOSC { get; set; }
Public Property EnableOscillatorEOSC As Ds1340EnableOscType
    Get
    Set
public:
property Ds1340EnableOscType EnableOscillatorEOSC {
    Ds1340EnableOscType get ();
    void set (Ds1340EnableOscType value);
}
member EnableOscillatorEOSC : Ds1340EnableOscType with get, set

Property Value

Type: Ds1340EnableOscType
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.FrequencyTestFT Property

IRD

Ds1340FrequencyTestFT Property

Frequency Test (FT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1340FreqTestType FrequencyTestFT { get; set; }
Public Property FrequencyTestFT As Ds1340FreqTestType
    Get
    Set
public:
property Ds1340FreqTestType FrequencyTestFT {
    Ds1340FreqTestType get ();
    void set (Ds1340FreqTestType value);
}
member FrequencyTestFT : Ds1340FreqTestType with get, set

Property Value

Type: Ds1340FreqTestType
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.Hours Property

IRD

Ds1340Hours Property

Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Hours { get; set; }
Public Property Hours As Byte
    Get
    Set
public:
property unsigned char Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.Minutes Property

IRD

Ds1340Minutes Property

Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Minutes { get; set; }
Public Property Minutes As Byte
    Get
    Set
public:
property unsigned char Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.Month Property

IRD

Ds1340Month Property

Month

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Month { get; set; }
Public Property Month As Byte
    Get
    Set
public:
property unsigned char Month {
    unsigned char get ();
    void set (unsigned char value);
}
member Month : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.OscillatorStopFlagOSF Property

IRD

Ds1340OscillatorStopFlagOSF Property

Oscillator Stop Flag (OSF)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1340OscStopType OscillatorStopFlagOSF { get; set; }
Public Property OscillatorStopFlagOSF As Ds1340OscStopType
    Get
    Set
public:
property Ds1340OscStopType OscillatorStopFlagOSF {
    Ds1340OscStopType get ();
    void set (Ds1340OscStopType value);
}
member OscillatorStopFlagOSF : Ds1340OscStopType with get, set

Property Value

Type: Ds1340OscStopType
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.OutputControlOUT Property

IRD

Ds1340OutputControlOUT Property

Output Control (OUT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1340OutputCtrlType OutputControlOUT { get; set; }
Public Property OutputControlOUT As Ds1340OutputCtrlType
    Get
    Set
public:
property Ds1340OutputCtrlType OutputControlOUT {
    Ds1340OutputCtrlType get ();
    void set (Ds1340OutputCtrlType value);
}
member OutputControlOUT : Ds1340OutputCtrlType with get, set

Property Value

Type: Ds1340OutputCtrlType
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.ResistorSelectROUTx Property

IRD

Ds1340ResistorSelectROUTx Property

Resistor Select (ROUTx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1340ResistorType ResistorSelectROUTx { get; set; }
Public Property ResistorSelectROUTx As Ds1340ResistorType
    Get
    Set
public:
property Ds1340ResistorType ResistorSelectROUTx {
    Ds1340ResistorType get ();
    void set (Ds1340ResistorType value);
}
member ResistorSelectROUTx : Ds1340ResistorType with get, set

Property Value

Type: Ds1340ResistorType
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.Seconds Property

IRD

Ds1340Seconds Property

Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Seconds { get; set; }
Public Property Seconds As Byte
    Get
    Set
public:
property unsigned char Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.TrickleChargeTCSx Property

IRD

Ds1340TrickleChargeTCSx Property

Trickle Charge (TCSx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1340TrickleType TrickleChargeTCSx { get; set; }
Public Property TrickleChargeTCSx As Ds1340TrickleType
    Get
    Set
public:
property Ds1340TrickleType TrickleChargeTCSx {
    Ds1340TrickleType get ();
    void set (Ds1340TrickleType value);
}
member TrickleChargeTCSx : Ds1340TrickleType with get, set

Property Value

Type: Ds1340TrickleType
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.Year Property

IRD

Ds1340Year Property

Year

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Year { get; set; }
Public Property Year As Byte
    Get
    Set
public:
property unsigned char Year {
    unsigned char get ();
    void set (unsigned char value);
}
member Year : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340 Methods

The Ds1340 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.Flush Method

IRD

Ds1340Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds1340 Class
telos.Ird.Maxim Namespace


Ds1340.CalibrationSignType Enumeration

IRD

Ds1340CalibrationSignType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CalibrationSignType
Public Enumeration CalibrationSignType
public enum class CalibrationSignType
type CalibrationSignType
Members
Member name | Value | Description
PositiveClockCalibration | 1 | Positive Clock Calibration
NegativeClockCalibration | 0 | Negative Clock Calibration
See Also

Reference

telos.Ird.Maxim Namespace


Ds1340.CenturyEnableType Enumeration

IRD

Ds1340CenturyEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CenturyEnableType
Public Enumeration CenturyEnableType
public enum class CenturyEnableType
type CenturyEnableType
Members
Member name | Value | Description
ToggleCenturyBitCBEnable | 1 | Toggle Century Bit (CB) Enable
ToggleCenturyBitCBDisable | 0 | Toggle Century Bit (CB) Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds1340.DiodeSelectType Enumeration

IRD

Ds1340DiodeSelectType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DiodeSelectType
Public Enumeration DiodeSelectType
public enum class DiodeSelectType
type DiodeSelectType
Members
Member name | Value | Description
Disabled | 0 | Disabled
NoDiodeSelected | 1 | No Diode Selected
OneDiodeSelected | 2 | One Diode Selected
Disabled__1 | 3 | Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds1340.EnableOscType Enumeration

IRD

Ds1340EnableOscType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum EnableOscType
Public Enumeration EnableOscType
public enum class EnableOscType
type EnableOscType
Members
Member name | Value | Description
StopOscillator | 1 | Stop Oscillator
StartOscillator | 0 | Start Oscillator
See Also

Reference

telos.Ird.Maxim Namespace


Ds1340.FreqTestType Enumeration

IRD

Ds1340FreqTestType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FreqTestType
Public Enumeration FreqTestType
public enum class FreqTestType
type FreqTestType
Members
Member name | Value | Description
ToggleFTOUTPinAt512Hz | 1 | Toggle FT/OUT Pin At 512 Hz
NoToggleFTOUTPin | 0 | No Toggle FT/OUT Pin
See Also

Reference

telos.Ird.Maxim Namespace


Ds1340.OscStopType Enumeration

IRD

Ds1340OscStopType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum OscStopType
Public Enumeration OscStopType
public enum class OscStopType
type OscStopType
Members
Member name | Value | Description
OscillatorStopFlagOSCStop | 1 | Oscillator Stop Flag: OSC Stop
OscillatorStopFlagOSCRunning | 0 | Oscillator Stop Flag: OSC Running
See Also

Reference

telos.Ird.Maxim Namespace


Ds1340.OutputCtrlType Enumeration

IRD

Ds1340OutputCtrlType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum OutputCtrlType
Public Enumeration OutputCtrlType
public enum class OutputCtrlType
type OutputCtrlType
Members
Member name | Value | Description
FT0FTOUTPin1 | 1 | FT=0: FT/OUT Pin = 1
FT0FTOUTPin0 | 0 | FT=0: FT/OUT Pin = 0
See Also

Reference

telos.Ird.Maxim Namespace


Ds1340.ResistorType Enumeration

IRD

Ds1340ResistorType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ResistorType
Public Enumeration ResistorType
public enum class ResistorType
type ResistorType
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_250OhmResistor | 1 | 250 Ohm Resistor
Value_2KOhmResistor | 2 | 2 kOhm Resistor
Value_4KOhmResistor | 3 | 4 kOhm Resistor
See Also

Reference

telos.Ird.Maxim Namespace


Ds1340.TrickleType Enumeration

IRD

Ds1340TrickleType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TrickleType
Public Enumeration TrickleType
public enum class TrickleType
type TrickleType
Members
Member name | Value | Description
TrickleChargeDisabled | 0 | Trickle Charge Disabled
TrickleChargeEnabled | 10 | Trickle Charge Enabled
TrickleChargeDisabled__1 | 11 | Trickle Charge Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds1371 Class

Maxim: DS 1371
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs1371

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds1371
Public Class Ds1371
public ref class Ds1371
type Ds1371 =  class end

The Ds1371 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds1371 | Constructor
Top
Properties
 | Name | Description
Public property | AlarmFlagAF | Alarm Flag (AF)
Public property | AlarmInterruptEnableAIE | Alarm Interrupt Enable (AIE)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CounterEnableWACE | Counter Enable (WACE)
Public property | CounterSelectWDALM | Counter Select (WD/ALM)
Public property | EnableOscillatorEOSC | Enable Oscillator (EOSC)
Public property | InterruptControlINTCN | Interrupt Control (INTCN)
Public property | OscillatorStopFlagOSF | Oscillator Stop Flag (OSF)
Public property | RateSelect1And2RSx | Rate Select 1 and 2 (RSx) (unit: Hz)
Public property | TimeOfDayCounter | Time Of Day Counter
Public property | WatchdogAlarmCounter | Watchdog Alarm Counter
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
32 Bit Binary Counter Watchdog Clock
See Also

Reference

telos.Ird.Maxim Namespace


Ds1371 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1371(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds1371(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds1371

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds1371 Class
telos.Ird.Maxim Namespace


Ds1371 Properties

The Ds1371 type exposes the following members.

Properties
 | Name | Description
Public property | AlarmFlagAF | Alarm Flag (AF)
Public property | AlarmInterruptEnableAIE | Alarm Interrupt Enable (AIE)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CounterEnableWACE | Counter Enable (WACE)
Public property | CounterSelectWDALM | Counter Select (WD/ALM)
Public property | EnableOscillatorEOSC | Enable Oscillator (EOSC)
Public property | InterruptControlINTCN | Interrupt Control (INTCN)
Public property | OscillatorStopFlagOSF | Oscillator Stop Flag (OSF)
Public property | RateSelect1And2RSx | Rate Select 1 and 2 (RSx) (unit: Hz)
Public property | TimeOfDayCounter | Time Of Day Counter
Public property | WatchdogAlarmCounter | Watchdog Alarm Counter
Top
See Also

Reference

Ds1371 Class
telos.Ird.Maxim Namespace


Ds1371.AlarmFlagAF Property

IRD

Ds1371AlarmFlagAF Property

Alarm Flag (AF)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1371StatusAlarmType AlarmFlagAF { get; set; }
Public Property AlarmFlagAF As Ds1371StatusAlarmType
    Get
    Set
public:
property Ds1371StatusAlarmType AlarmFlagAF {
    Ds1371StatusAlarmType get ();
    void set (Ds1371StatusAlarmType value);
}
member AlarmFlagAF : Ds1371StatusAlarmType with get, set

Property Value

Type: Ds1371StatusAlarmType
See Also

Reference

Ds1371 Class
telos.Ird.Maxim Namespace


Ds1371.AlarmInterruptEnableAIE Property

IRD

Ds1371AlarmInterruptEnableAIE Property

Alarm Interrupt Enable (AIE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1371ControlAintType AlarmInterruptEnableAIE { get; set; }
Public Property AlarmInterruptEnableAIE As Ds1371ControlAintType
    Get
    Set
public:
property Ds1371ControlAintType AlarmInterruptEnableAIE {
    Ds1371ControlAintType get ();
    void set (Ds1371ControlAintType value);
}
member AlarmInterruptEnableAIE : Ds1371ControlAintType with get, set

Property Value

Type: Ds1371ControlAintType
See Also

Reference

Ds1371 Class
telos.Ird.Maxim Namespace


Ds1371.AutoFlush Property

IRD

Ds1371AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds1371 Class
telos.Ird.Maxim Namespace


Ds1371.CounterEnableWACE Property

IRD

Ds1371CounterEnableWACE Property

Counter Enable (WACE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1371ControlCountenaType CounterEnableWACE { get; set; }
Public Property CounterEnableWACE As Ds1371ControlCountenaType
    Get
    Set
public:
property Ds1371ControlCountenaType CounterEnableWACE {
    Ds1371ControlCountenaType get ();
    void set (Ds1371ControlCountenaType value);
}
member CounterEnableWACE : Ds1371ControlCountenaType with get, set

Property Value

Type: Ds1371ControlCountenaType
See Also

Reference

Ds1371 Class
telos.Ird.Maxim Namespace


Ds1371.CounterSelectWDALM Property

IRD

Ds1371CounterSelectWDALM Property

Counter Select (WD/ALM)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1371ControlCountselType CounterSelectWDALM { get; set; }
Public Property CounterSelectWDALM As Ds1371ControlCountselType
    Get
    Set
public:
property Ds1371ControlCountselType CounterSelectWDALM {
    Ds1371ControlCountselType get ();
    void set (Ds1371ControlCountselType value);
}
member CounterSelectWDALM : Ds1371ControlCountselType with get, set

Property Value

Type: Ds1371ControlCountselType
See Also

Reference

Ds1371 Class
telos.Ird.Maxim Namespace


Ds1371.EnableOscillatorEOSC Property

IRD

Ds1371EnableOscillatorEOSC Property

Enable Oscillator (EOSC)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1371ControlOscenaType EnableOscillatorEOSC { get; set; }
Public Property EnableOscillatorEOSC As Ds1371ControlOscenaType
    Get
    Set
public:
property Ds1371ControlOscenaType EnableOscillatorEOSC {
    Ds1371ControlOscenaType get ();
    void set (Ds1371ControlOscenaType value);
}
member EnableOscillatorEOSC : Ds1371ControlOscenaType with get, set

Property Value

Type: Ds1371ControlOscenaType
See Also

Reference

Ds1371 Class
telos.Ird.Maxim Namespace


Ds1371.InterruptControlINTCN Property

IRD

Ds1371InterruptControlINTCN Property

Interrupt Control (INTCN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1371ControlIntType InterruptControlINTCN { get; set; }
Public Property InterruptControlINTCN As Ds1371ControlIntType
    Get
    Set
public:
property Ds1371ControlIntType InterruptControlINTCN {
    Ds1371ControlIntType get ();
    void set (Ds1371ControlIntType value);
}
member InterruptControlINTCN : Ds1371ControlIntType with get, set

Property Value

Type: Ds1371ControlIntType
See Also

Reference

Ds1371 Class
telos.Ird.Maxim Namespace


Ds1371.OscillatorStopFlagOSF Property

IRD

Ds1371OscillatorStopFlagOSF Property

Oscillator Stop Flag (OSF)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1371StatusOscstopType OscillatorStopFlagOSF { get; }
Public ReadOnly Property OscillatorStopFlagOSF As Ds1371StatusOscstopType
    Get
public:
property Ds1371StatusOscstopType OscillatorStopFlagOSF {
    Ds1371StatusOscstopType get ();
}
member OscillatorStopFlagOSF : Ds1371StatusOscstopType with get

Property Value

Type: Ds1371StatusOscstopType
See Also

Reference

Ds1371 Class
telos.Ird.Maxim Namespace


Ds1371.RateSelect1And2RSx Property

IRD

Ds1371RateSelect1And2RSx Property

Rate Select 1 and 2 (RSx) (unit: Hz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1371ControlWaveType RateSelect1And2RSx { get; set; }
Public Property RateSelect1And2RSx As Ds1371ControlWaveType
    Get
    Set
public:
property Ds1371ControlWaveType RateSelect1And2RSx {
    Ds1371ControlWaveType get ();
    void set (Ds1371ControlWaveType value);
}
member RateSelect1And2RSx : Ds1371ControlWaveType with get, set

Property Value

Type: Ds1371ControlWaveType
See Also

Reference

Ds1371 Class
telos.Ird.Maxim Namespace


Ds1371.TimeOfDayCounter Property

IRD

Ds1371TimeOfDayCounter Property

Time Of Day Counter

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint TimeOfDayCounter { get; set; }
Public Property TimeOfDayCounter As UInteger
    Get
    Set
public:
property unsigned int TimeOfDayCounter {
    unsigned int get ();
    void set (unsigned int value);
}
member TimeOfDayCounter : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

Ds1371 Class
telos.Ird.Maxim Namespace


Ds1371.WatchdogAlarmCounter Property

IRD

Ds1371WatchdogAlarmCounter Property

Watchdog Alarm Counter

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint WatchdogAlarmCounter { get; set; }
Public Property WatchdogAlarmCounter As UInteger
    Get
    Set
public:
property unsigned int WatchdogAlarmCounter {
    unsigned int get ();
    void set (unsigned int value);
}
member WatchdogAlarmCounter : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

Ds1371 Class
telos.Ird.Maxim Namespace


Ds1371 Methods

The Ds1371 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds1371 Class
telos.Ird.Maxim Namespace


Ds1371.Flush Method

IRD

Ds1371Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds1371 Class
telos.Ird.Maxim Namespace


Ds1371.ControlAintType Enumeration

IRD

Ds1371ControlAintType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlAintType
Public Enumeration ControlAintType
public enum class ControlAintType
type ControlAintType
Members
Member name | Value | Description
AlarmInterruptEnable | 1 | Alarm Interrupt: Enable
AlarmInterruptDisable | 0 | Alarm Interrupt: Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds1371.ControlCountenaType Enumeration

IRD

Ds1371ControlCountenaType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlCountenaType
Public Enumeration ControlCountenaType
public enum class ControlCountenaType
type ControlCountenaType
Members
Member name | Value | Description
CounterEnable | 1 | Counter: Enable
CounterDisable | 0 | Counter: Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds1371.ControlCountselType Enumeration

IRD

Ds1371ControlCountselType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlCountselType
Public Enumeration ControlCountselType
public enum class ControlCountselType
type ControlCountselType
Members
Member name | Value | Description
DecrementCounterPlusStop | 1 | Decrement Counter: Plus Stop
DecrementCounterPlusReloadAndRestart | 0 | Decrement Counter: Plus Reload And Restart
See Also

Reference

telos.Ird.Maxim Namespace


Ds1371.ControlIntType Enumeration

IRD

Ds1371ControlIntType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlIntType
Public Enumeration ControlIntType
public enum class ControlIntType
type ControlIntType
Members
Member name | Value | Description
InterruptControlEnable | 1 | Interrupt Control: Enable
InterruptControlDisable | 0 | Interrupt Control: Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds1371.ControlOscenaType Enumeration

IRD

Ds1371ControlOscenaType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlOscenaType
Public Enumeration ControlOscenaType
public enum class ControlOscenaType
type ControlOscenaType
Members
Member name | Value | Description
OscillatorStop | 1 | Oscillator: Stop
OscillatorStart | 0 | Oscillator: Start
See Also

Reference

telos.Ird.Maxim Namespace


Ds1371.ControlWaveType Enumeration

IRD

Ds1371ControlWaveType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlWaveType
Public Enumeration ControlWaveType
public enum class ControlWaveType
type ControlWaveType
Members
Member name | Value | Description
SquareWaveFrequency1 | 0 | Square Wave Frequency: 1
SquareWaveFrequency4096 | 1 | Square Wave Frequency: 4096
SquareWaveFrequency8192 | 2 | Square Wave Frequency: 8192
SquareWaveFrequency32768 | 3 | Square Wave Frequency: 32768
See Also

Reference

telos.Ird.Maxim Namespace


Ds1371.StatusAlarmType Enumeration

IRD

Ds1371StatusAlarmType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusAlarmType
Public Enumeration StatusAlarmType
public enum class StatusAlarmType
type StatusAlarmType
Members
Member name | Value | Description
AlarmFlagCounterReachedZero | 1 | Alarm Flag: Counter Reached Zero
AlarmFlagClear | 0 | Alarm Flag: Clear
See Also

Reference

telos.Ird.Maxim Namespace


Ds1371.StatusOscstopType Enumeration

IRD

Ds1371StatusOscstopType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusOscstopType
Public Enumeration StatusOscstopType
public enum class StatusOscstopType
type StatusOscstopType
Members
Member name | Value | Description
OscillatorStopFlagOSCStop | 1 | Oscillator Stop Flag: OSC Stop
OscillatorStopFlagOSCRunning | 0 | Oscillator Stop Flag: OSC Running
See Also

Reference

telos.Ird.Maxim Namespace


Ds1374 Class

Maxim: DS 1374
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs1374

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds1374
Public Class Ds1374
public ref class Ds1374
type Ds1374 =  class end

The Ds1374 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds1374 | Constructor
Top
Properties
 | Name | Description
Public property | AlarmFlagAF | Alarm Flag (AF)
Public property | AlarmInterruptEnableAIE | Alarm Interrupt Enable (AIE)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryBackedSquareWaveEnableBBSQW | Battery Backed Square Wave Enable (BBSQW)
Public property | CounterEnableWACE | Counter Enable (WACE)
Public property | CounterSelectWDALM | Counter Select (WD/ALM)
Public property | DiodeSelectDSx | Diode Select (DSx)
Public property | EnableOscillatorEOSC | Enable Oscillator (EOSC)
Public property | OscillatorStopFlagOSF | Oscillator Stop Flag (OSF)
Public property | ResistorSelectROUTx | Resistor Select (ROUTx)
Public property | SquareWaveOutputRSx | Square Wave Output (RSx) (unit: Hz)
Public property | TimeOfDayCounter | Time Of Day Counter
Public property | TrickleChargeTCSx | Trickle Charge (TCSx)
Public property | WatchdogAlarmCounter | Watchdog Alarm Counter
Public property | WatchdogResetSteeringWDSTR | Watchdog Reset Steering (WDSTR)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
32 Bit Binary Counter Watchdog RTC With Trickle Charger
See Also

Reference

telos.Ird.Maxim Namespace


Ds1374 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1374(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds1374(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds1374

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374 Properties

The Ds1374 type exposes the following members.

Properties
 | Name | Description
Public property | AlarmFlagAF | Alarm Flag (AF)
Public property | AlarmInterruptEnableAIE | Alarm Interrupt Enable (AIE)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryBackedSquareWaveEnableBBSQW | Battery Backed Square Wave Enable (BBSQW)
Public property | CounterEnableWACE | Counter Enable (WACE)
Public property | CounterSelectWDALM | Counter Select (WD/ALM)
Public property | DiodeSelectDSx | Diode Select (DSx)
Public property | EnableOscillatorEOSC | Enable Oscillator (EOSC)
Public property | OscillatorStopFlagOSF | Oscillator Stop Flag (OSF)
Public property | ResistorSelectROUTx | Resistor Select (ROUTx)
Public property | SquareWaveOutputRSx | Square Wave Output (RSx) (unit: Hz)
Public property | TimeOfDayCounter | Time Of Day Counter
Public property | TrickleChargeTCSx | Trickle Charge (TCSx)
Public property | WatchdogAlarmCounter | Watchdog Alarm Counter
Public property | WatchdogResetSteeringWDSTR | Watchdog Reset Steering (WDSTR)
Top
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374.AlarmFlagAF Property

IRD

Ds1374AlarmFlagAF Property

Alarm Flag (AF)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1374StatusAlarmType AlarmFlagAF { get; set; }
Public Property AlarmFlagAF As Ds1374StatusAlarmType
    Get
    Set
public:
property Ds1374StatusAlarmType AlarmFlagAF {
    Ds1374StatusAlarmType get ();
    void set (Ds1374StatusAlarmType value);
}
member AlarmFlagAF : Ds1374StatusAlarmType with get, set

Property Value

Type: Ds1374StatusAlarmType
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374.AlarmInterruptEnableAIE Property

IRD

Ds1374AlarmInterruptEnableAIE Property

Alarm Interrupt Enable (AIE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1374AlarmIntType AlarmInterruptEnableAIE { get; set; }
Public Property AlarmInterruptEnableAIE As Ds1374AlarmIntType
    Get
    Set
public:
property Ds1374AlarmIntType AlarmInterruptEnableAIE {
    Ds1374AlarmIntType get ();
    void set (Ds1374AlarmIntType value);
}
member AlarmInterruptEnableAIE : Ds1374AlarmIntType with get, set

Property Value

Type: Ds1374AlarmIntType
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374.AutoFlush Property

IRD

Ds1374AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374.BatteryBackedSquareWaveEnableBBSQW Property

IRD

Ds1374BatteryBackedSquareWaveEnableBBSQW Property

Battery Backed Square Wave Enable (BBSQW)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1374BbsqwType BatteryBackedSquareWaveEnableBBSQW { get; set; }
Public Property BatteryBackedSquareWaveEnableBBSQW As Ds1374BbsqwType
    Get
    Set
public:
property Ds1374BbsqwType BatteryBackedSquareWaveEnableBBSQW {
    Ds1374BbsqwType get ();
    void set (Ds1374BbsqwType value);
}
member BatteryBackedSquareWaveEnableBBSQW : Ds1374BbsqwType with get, set

Property Value

Type: Ds1374BbsqwType
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374.CounterEnableWACE Property

IRD

Ds1374CounterEnableWACE Property

Counter Enable (WACE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1374CounterEnableType CounterEnableWACE { get; set; }
Public Property CounterEnableWACE As Ds1374CounterEnableType
    Get
    Set
public:
property Ds1374CounterEnableType CounterEnableWACE {
    Ds1374CounterEnableType get ();
    void set (Ds1374CounterEnableType value);
}
member CounterEnableWACE : Ds1374CounterEnableType with get, set

Property Value

Type: Ds1374CounterEnableType
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374.CounterSelectWDALM Property

IRD

Ds1374CounterSelectWDALM Property

Counter Select (WD/ALM)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1374CounterSelectType CounterSelectWDALM { get; set; }
Public Property CounterSelectWDALM As Ds1374CounterSelectType
    Get
    Set
public:
property Ds1374CounterSelectType CounterSelectWDALM {
    Ds1374CounterSelectType get ();
    void set (Ds1374CounterSelectType value);
}
member CounterSelectWDALM : Ds1374CounterSelectType with get, set

Property Value

Type: Ds1374CounterSelectType
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374.DiodeSelectDSx Property

IRD

Ds1374DiodeSelectDSx Property

Diode Select (DSx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1374DiodeSelectType DiodeSelectDSx { get; set; }
Public Property DiodeSelectDSx As Ds1374DiodeSelectType
    Get
    Set
public:
property Ds1374DiodeSelectType DiodeSelectDSx {
    Ds1374DiodeSelectType get ();
    void set (Ds1374DiodeSelectType value);
}
member DiodeSelectDSx : Ds1374DiodeSelectType with get, set

Property Value

Type: Ds1374DiodeSelectType
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374.EnableOscillatorEOSC Property

IRD

Ds1374EnableOscillatorEOSC Property

Enable Oscillator (EOSC)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1374EnableOscType EnableOscillatorEOSC { get; set; }
Public Property EnableOscillatorEOSC As Ds1374EnableOscType
    Get
    Set
public:
property Ds1374EnableOscType EnableOscillatorEOSC {
    Ds1374EnableOscType get ();
    void set (Ds1374EnableOscType value);
}
member EnableOscillatorEOSC : Ds1374EnableOscType with get, set

Property Value

Type: Ds1374EnableOscType
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374.OscillatorStopFlagOSF Property

IRD

Ds1374OscillatorStopFlagOSF Property

Oscillator Stop Flag (OSF)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1374OscStopType OscillatorStopFlagOSF { get; set; }
Public Property OscillatorStopFlagOSF As Ds1374OscStopType
    Get
    Set
public:
property Ds1374OscStopType OscillatorStopFlagOSF {
    Ds1374OscStopType get ();
    void set (Ds1374OscStopType value);
}
member OscillatorStopFlagOSF : Ds1374OscStopType with get, set

Property Value

Type: Ds1374OscStopType
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374.ResistorSelectROUTx Property

IRD

Ds1374ResistorSelectROUTx Property

Resistor Select (ROUTx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1374ResistorType ResistorSelectROUTx { get; set; }
Public Property ResistorSelectROUTx As Ds1374ResistorType
    Get
    Set
public:
property Ds1374ResistorType ResistorSelectROUTx {
    Ds1374ResistorType get ();
    void set (Ds1374ResistorType value);
}
member ResistorSelectROUTx : Ds1374ResistorType with get, set

Property Value

Type: Ds1374ResistorType
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374.SquareWaveOutputRSx Property

IRD

Ds1374SquareWaveOutputRSx Property

Square Wave Output (RSx) (unit: Hz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1374SquareWaveType SquareWaveOutputRSx { get; set; }
Public Property SquareWaveOutputRSx As Ds1374SquareWaveType
    Get
    Set
public:
property Ds1374SquareWaveType SquareWaveOutputRSx {
    Ds1374SquareWaveType get ();
    void set (Ds1374SquareWaveType value);
}
member SquareWaveOutputRSx : Ds1374SquareWaveType with get, set

Property Value

Type: Ds1374SquareWaveType
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374.TimeOfDayCounter Property

IRD

Ds1374TimeOfDayCounter Property

Time Of Day Counter

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint TimeOfDayCounter { get; set; }
Public Property TimeOfDayCounter As UInteger
    Get
    Set
public:
property unsigned int TimeOfDayCounter {
    unsigned int get ();
    void set (unsigned int value);
}
member TimeOfDayCounter : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374.TrickleChargeTCSx Property

IRD

Ds1374TrickleChargeTCSx Property

Trickle Charge (TCSx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1374TrickleType TrickleChargeTCSx { get; set; }
Public Property TrickleChargeTCSx As Ds1374TrickleType
    Get
    Set
public:
property Ds1374TrickleType TrickleChargeTCSx {
    Ds1374TrickleType get ();
    void set (Ds1374TrickleType value);
}
member TrickleChargeTCSx : Ds1374TrickleType with get, set

Property Value

Type: Ds1374TrickleType
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374.WatchdogAlarmCounter Property

IRD

Ds1374WatchdogAlarmCounter Property

Watchdog Alarm Counter

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint WatchdogAlarmCounter { get; set; }
Public Property WatchdogAlarmCounter As UInteger
    Get
    Set
public:
property unsigned int WatchdogAlarmCounter {
    unsigned int get ();
    void set (unsigned int value);
}
member WatchdogAlarmCounter : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374.WatchdogResetSteeringWDSTR Property

IRD

Ds1374WatchdogResetSteeringWDSTR Property

Watchdog Reset Steering (WDSTR)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1374WatchdogResetType WatchdogResetSteeringWDSTR { get; set; }
Public Property WatchdogResetSteeringWDSTR As Ds1374WatchdogResetType
    Get
    Set
public:
property Ds1374WatchdogResetType WatchdogResetSteeringWDSTR {
    Ds1374WatchdogResetType get ();
    void set (Ds1374WatchdogResetType value);
}
member WatchdogResetSteeringWDSTR : Ds1374WatchdogResetType with get, set

Property Value

Type: Ds1374WatchdogResetType
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374 Methods

The Ds1374 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374.Flush Method

IRD

Ds1374Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds1374 Class
telos.Ird.Maxim Namespace


Ds1374.AlarmIntType Enumeration

IRD

Ds1374AlarmIntType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmIntType
Public Enumeration AlarmIntType
public enum class AlarmIntType
type AlarmIntType
Members
Member name | Value | Description
AlarmInterruptEnable | 1 | Alarm Interrupt: Enable
AlarmInterruptDisable | 0 | Alarm Interrupt: Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds1374.BbsqwType Enumeration

IRD

Ds1374BbsqwType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum BbsqwType
Public Enumeration BbsqwType
public enum class BbsqwType
type BbsqwType
Members
Member name | Value | Description
BBSQWEnable | 1 | BBSQW Enable
BBSQWDisable | 0 | BBSQW Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds1374.CounterEnableType Enumeration

IRD

Ds1374CounterEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CounterEnableType
Public Enumeration CounterEnableType
public enum class CounterEnableType
type CounterEnableType
Members
Member name | Value | Description
WDALMCounterEnable | 1 | WD/ALM Counter Enable
WDALMCounterDisable | 0 | WD/ALM Counter Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds1374.CounterSelectType Enumeration

IRD

Ds1374CounterSelectType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CounterSelectType
Public Enumeration CounterSelectType
public enum class CounterSelectType
type CounterSelectType
Members
Member name | Value | Description
DecrementEvery244MicroSecondAndStop | 1 | Decrement Every 244 Micro Second And Stop
DecrementEverySecondWithRestart | 0 | Decrement Every Second With Restart
See Also

Reference

telos.Ird.Maxim Namespace


Ds1374.DiodeSelectType Enumeration

IRD

Ds1374DiodeSelectType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DiodeSelectType
Public Enumeration DiodeSelectType
public enum class DiodeSelectType
type DiodeSelectType
Members
Member name | Value | Description
Disabled | 0 | Disabled
NoDiodeSelected | 1 | No Diode Selected
OneDiodeSelected | 2 | One Diode Selected
Disabled__1 | 3 | Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds1374.EnableOscType Enumeration

IRD

Ds1374EnableOscType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum EnableOscType
Public Enumeration EnableOscType
public enum class EnableOscType
type EnableOscType
Members
Member name | Value | Description
StopOscillator | 1 | Stop Oscillator
StartOscillator | 0 | Start Oscillator
See Also

Reference

telos.Ird.Maxim Namespace


Ds1374.OscStopType Enumeration

IRD

Ds1374OscStopType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum OscStopType
Public Enumeration OscStopType
public enum class OscStopType
type OscStopType
Members
Member name | Value | Description
OscillatorStopFlagOSCStop | 1 | Oscillator Stop Flag: OSC Stop
OscillatorStopFlagOSCRunning | 0 | Oscillator Stop Flag: OSC Running
See Also

Reference

telos.Ird.Maxim Namespace


Ds1374.ResistorType Enumeration

IRD

Ds1374ResistorType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ResistorType
Public Enumeration ResistorType
public enum class ResistorType
type ResistorType
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_250OhmResistor | 1 | 250 Ohm Resistor
Value_2KOhmResistor | 2 | 2 kOhm Resistor
Value_4KOhmResistor | 3 | 4 kOhm Resistor
See Also

Reference

telos.Ird.Maxim Namespace


Ds1374.SquareWaveType Enumeration

IRD

Ds1374SquareWaveType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SquareWaveType
Public Enumeration SquareWaveType
public enum class SquareWaveType
type SquareWaveType
Members
Member name | Value | Description
SquareWaveFrequency1 | 0 | Square Wave Frequency: 1
SquareWaveFrequency4096 | 1 | Square Wave Frequency: 4096
SquareWaveFrequency8192 | 2 | Square Wave Frequency: 8192
SquareWaveFrequency32768 | 3 | Square Wave Frequency: 32768
See Also

Reference

telos.Ird.Maxim Namespace


Ds1374.StatusAlarmType Enumeration

IRD

Ds1374StatusAlarmType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusAlarmType
Public Enumeration StatusAlarmType
public enum class StatusAlarmType
type StatusAlarmType
Members
Member name | Value | Description
WDALMCounterReachedZero | 1 | WD/ALM Counter Reached Zero
AlarmFlagCleared | 0 | Alarm Flag Cleared
See Also

Reference

telos.Ird.Maxim Namespace


Ds1374.TrickleType Enumeration

IRD

Ds1374TrickleType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TrickleType
Public Enumeration TrickleType
public enum class TrickleType
type TrickleType
Members
Member name | Value | Description
TrickleChargeDisabled | 0 | Trickle Charge Disabled
TrickleChargeEnabled | 10 | Trickle Charge Enabled
TrickleChargeDisabled__1 | 11 | Trickle Charge Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds1374.WatchdogResetType Enumeration

IRD

Ds1374WatchdogResetType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum WatchdogResetType
Public Enumeration WatchdogResetType
public enum class WatchdogResetType
type WatchdogResetType
Members
Member name | Value | Description
Value_250MsPulseToINTPin | 1 | 250 ms Pulse To INT Pin
Value_250MsPulseToRSTPin | 0 | 250 ms Pulse To RST Pin
See Also

Reference

telos.Ird.Maxim Namespace


Ds1375 Class

Maxim: DS 1375
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs1375

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds1375
Public Class Ds1375
public ref class Ds1375
type Ds1375 =  class end

The Ds1375 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds1375 | Constructor
Top
Properties
 | Name | Description
Public property | Alarm1Date | Alarm 1 Date
Public property | Alarm1DayDateSwitchDYDT | Alarm 1 Day Date Switch (DY/DT)
Public property | Alarm1FlagA1F | Alarm 1 Flag (A1F)
Public property | Alarm1Hours | Alarm 1 Hours (unit: hour)
Public property | Alarm1InterruptEnableA1IE | Alarm 1 Interrupt Enable (A1IE)
Public property | Alarm1MaskBitsA1Mx | Alarm1 Mask Bits (A1Mx)
Public property | Alarm1Minutes | Alarm 1 Minutes (unit: min)
Public property | Alarm1Seconds | Alarm 1 Seconds (unit: s)
Public property | Alarm1Switch12To24Hours1224 | Alarm 1 Switch 12 To 24 Hours (12/24)
Public property | Alarm2Date | Alarm 2 Date
Public property | Alarm2DayDateSwitchDYDT | Alarm 2 Day Date Switch (DY/DT)
Public property | Alarm2FlagA2F | Alarm 2 Flag (A2F)
Public property | Alarm2Hours | Alarm 2 Hours (unit: hour)
Public property | Alarm2InterruptEnableA2IE | Alarm 2 Interrupt Enable (A2IE)
Public property | Alarm2MaskBitsA2Mx | Alarm2 Mask Bits (A2Mx)
Public property | Alarm2Minutes | Alarm 2 Minutes (unit: min)
Public property | Alarm2Switch12To24Hours1224 | Alarm 2 Switch 12 To 24 Hours (12/24)
Public property | AlarmInterruptControlINTCN | Alarm Interrupt Control (INTCN)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Century | Century
Public property | ClockSelectCLKSELx | Clock Select (CLKSELx) (unit: Hz)
Public property | Date | Date
Public property | Day | Day
Public property | EnableClockECLK | Enable Clock (ECLK)
Public property | Hours | Hours (unit: hour)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | Seconds | Seconds (unit: s)
Public property | SquareWaveOutputRSx | Square Wave Output (RSx) (unit: Hz)
Public property | Switch12To24Hours1224 | Switch 12 To 24 Hours (12/24)
Public property | Year | Year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Digital Input RTC With Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Ds1375 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1375(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds1375(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds1375

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375 Properties

The Ds1375 type exposes the following members.

Properties
 | Name | Description
Public property | Alarm1Date | Alarm 1 Date
Public property | Alarm1DayDateSwitchDYDT | Alarm 1 Day Date Switch (DY/DT)
Public property | Alarm1FlagA1F | Alarm 1 Flag (A1F)
Public property | Alarm1Hours | Alarm 1 Hours (unit: hour)
Public property | Alarm1InterruptEnableA1IE | Alarm 1 Interrupt Enable (A1IE)
Public property | Alarm1MaskBitsA1Mx | Alarm1 Mask Bits (A1Mx)
Public property | Alarm1Minutes | Alarm 1 Minutes (unit: min)
Public property | Alarm1Seconds | Alarm 1 Seconds (unit: s)
Public property | Alarm1Switch12To24Hours1224 | Alarm 1 Switch 12 To 24 Hours (12/24)
Public property | Alarm2Date | Alarm 2 Date
Public property | Alarm2DayDateSwitchDYDT | Alarm 2 Day Date Switch (DY/DT)
Public property | Alarm2FlagA2F | Alarm 2 Flag (A2F)
Public property | Alarm2Hours | Alarm 2 Hours (unit: hour)
Public property | Alarm2InterruptEnableA2IE | Alarm 2 Interrupt Enable (A2IE)
Public property | Alarm2MaskBitsA2Mx | Alarm2 Mask Bits (A2Mx)
Public property | Alarm2Minutes | Alarm 2 Minutes (unit: min)
Public property | Alarm2Switch12To24Hours1224 | Alarm 2 Switch 12 To 24 Hours (12/24)
Public property | AlarmInterruptControlINTCN | Alarm Interrupt Control (INTCN)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Century | Century
Public property | ClockSelectCLKSELx | Clock Select (CLKSELx) (unit: Hz)
Public property | Date | Date
Public property | Day | Day
Public property | EnableClockECLK | Enable Clock (ECLK)
Public property | Hours | Hours (unit: hour)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | Seconds | Seconds (unit: s)
Public property | SquareWaveOutputRSx | Square Wave Output (RSx) (unit: Hz)
Public property | Switch12To24Hours1224 | Switch 12 To 24 Hours (12/24)
Public property | Year | Year
Top
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Alarm1Date Property

IRD

Ds1375Alarm1Date Property

Alarm 1 Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm1Date { get; set; }
Public Property Alarm1Date As Byte
    Get
    Set
public:
property unsigned char Alarm1Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm1Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Alarm1DayDateSwitchDYDT Property

IRD

Ds1375Alarm1DayDateSwitchDYDT Property

Alarm 1 Day Date Switch (DY/DT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1375DayDateType Alarm1DayDateSwitchDYDT { get; set; }
Public Property Alarm1DayDateSwitchDYDT As Ds1375DayDateType
    Get
    Set
public:
property Ds1375DayDateType Alarm1DayDateSwitchDYDT {
    Ds1375DayDateType get ();
    void set (Ds1375DayDateType value);
}
member Alarm1DayDateSwitchDYDT : Ds1375DayDateType with get, set

Property Value

Type: Ds1375DayDateType
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Alarm1FlagA1F Property

IRD

Ds1375Alarm1FlagA1F Property

Alarm 1 Flag (A1F)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1375AlarmFlagType Alarm1FlagA1F { get; set; }
Public Property Alarm1FlagA1F As Ds1375AlarmFlagType
    Get
    Set
public:
property Ds1375AlarmFlagType Alarm1FlagA1F {
    Ds1375AlarmFlagType get ();
    void set (Ds1375AlarmFlagType value);
}
member Alarm1FlagA1F : Ds1375AlarmFlagType with get, set

Property Value

Type: Ds1375AlarmFlagType
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Alarm1Hours Property

IRD

Ds1375Alarm1Hours Property

Alarm 1 Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm1Hours { get; set; }
Public Property Alarm1Hours As Byte
    Get
    Set
public:
property unsigned char Alarm1Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm1Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Alarm1InterruptEnableA1IE Property

IRD

Ds1375Alarm1InterruptEnableA1IE Property

Alarm 1 Interrupt Enable (A1IE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1375AlarmIntType Alarm1InterruptEnableA1IE { get; set; }
Public Property Alarm1InterruptEnableA1IE As Ds1375AlarmIntType
    Get
    Set
public:
property Ds1375AlarmIntType Alarm1InterruptEnableA1IE {
    Ds1375AlarmIntType get ();
    void set (Ds1375AlarmIntType value);
}
member Alarm1InterruptEnableA1IE : Ds1375AlarmIntType with get, set

Property Value

Type: Ds1375AlarmIntType
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Alarm1MaskBitsA1Mx Property

IRD

Ds1375Alarm1MaskBitsA1Mx Property

Alarm1 Mask Bits (A1Mx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1375AlarmMask1Type Alarm1MaskBitsA1Mx { get; set; }
Public Property Alarm1MaskBitsA1Mx As Ds1375AlarmMask1Type
    Get
    Set
public:
property Ds1375AlarmMask1Type Alarm1MaskBitsA1Mx {
    Ds1375AlarmMask1Type get ();
    void set (Ds1375AlarmMask1Type value);
}
member Alarm1MaskBitsA1Mx : Ds1375AlarmMask1Type with get, set

Property Value

Type: Ds1375AlarmMask1Type
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Alarm1Minutes Property

IRD

Ds1375Alarm1Minutes Property

Alarm 1 Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm1Minutes { get; set; }
Public Property Alarm1Minutes As Byte
    Get
    Set
public:
property unsigned char Alarm1Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm1Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Alarm1Seconds Property

IRD

Ds1375Alarm1Seconds Property

Alarm 1 Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm1Seconds { get; set; }
Public Property Alarm1Seconds As Byte
    Get
    Set
public:
property unsigned char Alarm1Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm1Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Alarm1Switch12To24Hours1224 Property

IRD

Ds1375Alarm1Switch12To24Hours1224 Property

Alarm 1 Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1375H1224Type Alarm1Switch12To24Hours1224 { get; set; }
Public Property Alarm1Switch12To24Hours1224 As Ds1375H1224Type
    Get
    Set
public:
property Ds1375H1224Type Alarm1Switch12To24Hours1224 {
    Ds1375H1224Type get ();
    void set (Ds1375H1224Type value);
}
member Alarm1Switch12To24Hours1224 : Ds1375H1224Type with get, set

Property Value

Type: Ds1375H1224Type
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Alarm2Date Property

IRD

Ds1375Alarm2Date Property

Alarm 2 Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm2Date { get; set; }
Public Property Alarm2Date As Byte
    Get
    Set
public:
property unsigned char Alarm2Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm2Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Alarm2DayDateSwitchDYDT Property

IRD

Ds1375Alarm2DayDateSwitchDYDT Property

Alarm 2 Day Date Switch (DY/DT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1375DayDateType Alarm2DayDateSwitchDYDT { get; set; }
Public Property Alarm2DayDateSwitchDYDT As Ds1375DayDateType
    Get
    Set
public:
property Ds1375DayDateType Alarm2DayDateSwitchDYDT {
    Ds1375DayDateType get ();
    void set (Ds1375DayDateType value);
}
member Alarm2DayDateSwitchDYDT : Ds1375DayDateType with get, set

Property Value

Type: Ds1375DayDateType
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Alarm2FlagA2F Property

IRD

Ds1375Alarm2FlagA2F Property

Alarm 2 Flag (A2F)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1375AlarmFlagType Alarm2FlagA2F { get; set; }
Public Property Alarm2FlagA2F As Ds1375AlarmFlagType
    Get
    Set
public:
property Ds1375AlarmFlagType Alarm2FlagA2F {
    Ds1375AlarmFlagType get ();
    void set (Ds1375AlarmFlagType value);
}
member Alarm2FlagA2F : Ds1375AlarmFlagType with get, set

Property Value

Type: Ds1375AlarmFlagType
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Alarm2Hours Property

IRD

Ds1375Alarm2Hours Property

Alarm 2 Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm2Hours { get; set; }
Public Property Alarm2Hours As Byte
    Get
    Set
public:
property unsigned char Alarm2Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm2Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Alarm2InterruptEnableA2IE Property

IRD

Ds1375Alarm2InterruptEnableA2IE Property

Alarm 2 Interrupt Enable (A2IE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1375AlarmIntType Alarm2InterruptEnableA2IE { get; set; }
Public Property Alarm2InterruptEnableA2IE As Ds1375AlarmIntType
    Get
    Set
public:
property Ds1375AlarmIntType Alarm2InterruptEnableA2IE {
    Ds1375AlarmIntType get ();
    void set (Ds1375AlarmIntType value);
}
member Alarm2InterruptEnableA2IE : Ds1375AlarmIntType with get, set

Property Value

Type: Ds1375AlarmIntType
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Alarm2MaskBitsA2Mx Property

IRD

Ds1375Alarm2MaskBitsA2Mx Property

Alarm2 Mask Bits (A2Mx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1375AlarmMask2Type Alarm2MaskBitsA2Mx { get; set; }
Public Property Alarm2MaskBitsA2Mx As Ds1375AlarmMask2Type
    Get
    Set
public:
property Ds1375AlarmMask2Type Alarm2MaskBitsA2Mx {
    Ds1375AlarmMask2Type get ();
    void set (Ds1375AlarmMask2Type value);
}
member Alarm2MaskBitsA2Mx : Ds1375AlarmMask2Type with get, set

Property Value

Type: Ds1375AlarmMask2Type
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Alarm2Minutes Property

IRD

Ds1375Alarm2Minutes Property

Alarm 2 Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm2Minutes { get; set; }
Public Property Alarm2Minutes As Byte
    Get
    Set
public:
property unsigned char Alarm2Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm2Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Alarm2Switch12To24Hours1224 Property

IRD

Ds1375Alarm2Switch12To24Hours1224 Property

Alarm 2 Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1375H1224Type Alarm2Switch12To24Hours1224 { get; set; }
Public Property Alarm2Switch12To24Hours1224 As Ds1375H1224Type
    Get
    Set
public:
property Ds1375H1224Type Alarm2Switch12To24Hours1224 {
    Ds1375H1224Type get ();
    void set (Ds1375H1224Type value);
}
member Alarm2Switch12To24Hours1224 : Ds1375H1224Type with get, set

Property Value

Type: Ds1375H1224Type
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.AlarmInterruptControlINTCN Property

IRD

Ds1375AlarmInterruptControlINTCN Property

Alarm Interrupt Control (INTCN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1375InterruptControlType AlarmInterruptControlINTCN { get; set; }
Public Property AlarmInterruptControlINTCN As Ds1375InterruptControlType
    Get
    Set
public:
property Ds1375InterruptControlType AlarmInterruptControlINTCN {
    Ds1375InterruptControlType get ();
    void set (Ds1375InterruptControlType value);
}
member AlarmInterruptControlINTCN : Ds1375InterruptControlType with get, set

Property Value

Type: Ds1375InterruptControlType
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.AutoFlush Property

IRD

Ds1375AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Century Property

IRD

Ds1375Century Property

Century

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Century { get; set; }
Public Property Century As Byte
    Get
    Set
public:
property unsigned char Century {
    unsigned char get ();
    void set (unsigned char value);
}
member Century : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.ClockSelectCLKSELx Property

IRD

Ds1375ClockSelectCLKSELx Property

Clock Select (CLKSELx) (unit: Hz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1375ClockSelectType ClockSelectCLKSELx { get; set; }
Public Property ClockSelectCLKSELx As Ds1375ClockSelectType
    Get
    Set
public:
property Ds1375ClockSelectType ClockSelectCLKSELx {
    Ds1375ClockSelectType get ();
    void set (Ds1375ClockSelectType value);
}
member ClockSelectCLKSELx : Ds1375ClockSelectType with get, set

Property Value

Type: Ds1375ClockSelectType
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Date Property

IRD

Ds1375Date Property

Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Date { get; set; }
Public Property Date As Byte
    Get
    Set
public:
property unsigned char Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Day Property

IRD

Ds1375Day Property

Day

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Day { get; set; }
Public Property Day As Byte
    Get
    Set
public:
property unsigned char Day {
    unsigned char get ();
    void set (unsigned char value);
}
member Day : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.EnableClockECLK Property

IRD

Ds1375EnableClockECLK Property

Enable Clock (ECLK)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1375ClockEnableType EnableClockECLK { get; set; }
Public Property EnableClockECLK As Ds1375ClockEnableType
    Get
    Set
public:
property Ds1375ClockEnableType EnableClockECLK {
    Ds1375ClockEnableType get ();
    void set (Ds1375ClockEnableType value);
}
member EnableClockECLK : Ds1375ClockEnableType with get, set

Property Value

Type: Ds1375ClockEnableType
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Hours Property

IRD

Ds1375Hours Property

Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Hours { get; set; }
Public Property Hours As Byte
    Get
    Set
public:
property unsigned char Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Minutes Property

IRD

Ds1375Minutes Property

Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Minutes { get; set; }
Public Property Minutes As Byte
    Get
    Set
public:
property unsigned char Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Month Property

IRD

Ds1375Month Property

Month

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Month { get; set; }
Public Property Month As Byte
    Get
    Set
public:
property unsigned char Month {
    unsigned char get ();
    void set (unsigned char value);
}
member Month : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Seconds Property

IRD

Ds1375Seconds Property

Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Seconds { get; set; }
Public Property Seconds As Byte
    Get
    Set
public:
property unsigned char Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.SquareWaveOutputRSx Property

IRD

Ds1375SquareWaveOutputRSx Property

Square Wave Output (RSx) (unit: Hz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1375SquareWaveType SquareWaveOutputRSx { get; set; }
Public Property SquareWaveOutputRSx As Ds1375SquareWaveType
    Get
    Set
public:
property Ds1375SquareWaveType SquareWaveOutputRSx {
    Ds1375SquareWaveType get ();
    void set (Ds1375SquareWaveType value);
}
member SquareWaveOutputRSx : Ds1375SquareWaveType with get, set

Property Value

Type: Ds1375SquareWaveType
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Switch12To24Hours1224 Property

IRD

Ds1375Switch12To24Hours1224 Property

Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1375H1224Type Switch12To24Hours1224 { get; set; }
Public Property Switch12To24Hours1224 As Ds1375H1224Type
    Get
    Set
public:
property Ds1375H1224Type Switch12To24Hours1224 {
    Ds1375H1224Type get ();
    void set (Ds1375H1224Type value);
}
member Switch12To24Hours1224 : Ds1375H1224Type with get, set

Property Value

Type: Ds1375H1224Type
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Year Property

IRD

Ds1375Year Property

Year

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Year { get; set; }
Public Property Year As Byte
    Get
    Set
public:
property unsigned char Year {
    unsigned char get ();
    void set (unsigned char value);
}
member Year : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375 Methods

The Ds1375 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.Flush Method

IRD

Ds1375Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds1375 Class
telos.Ird.Maxim Namespace


Ds1375.AlarmFlagType Enumeration

IRD

Ds1375AlarmFlagType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmFlagType
Public Enumeration AlarmFlagType
public enum class AlarmFlagType
type AlarmFlagType
Members
Member name | Value | Description
TimeMatchedAlarm | 1 | Time Matched Alarm
NoTimeMatchAlarm | 0 | No Time Match Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Ds1375.AlarmIntType Enumeration

IRD

Ds1375AlarmIntType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmIntType
Public Enumeration AlarmIntType
public enum class AlarmIntType
type AlarmIntType
Members
Member name | Value | Description
AlarmInterruptEnable | 1 | Alarm Interrupt: Enable
AlarmInterruptDisable | 0 | Alarm Interrupt: Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds1375.AlarmMask1Type Enumeration

IRD

Ds1375AlarmMask1Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmMask1Type
Public Enumeration AlarmMask1Type
public enum class AlarmMask1Type
type AlarmMask1Type
Members
Member name | Value | Description
AlarmOncePerSecond | 15 | Alarm Once Per Second
AlarmOncePerSecond__1 | 31 | Alarm Once Per Second
AlarmWhenSecondsMatch | 14 | Alarm When Seconds Match
AlarmWhenSecondsMatch__1 | 30 | Alarm When Seconds Match
AlarmWhenMinutesMatch | 12 | Alarm When Minutes Match
AlarmWhenMinutesMatch__1 | 28 | Alarm When Minutes Match
AlarmWhenHoursMatch | 8 | Alarm When Hours Match
AlarmWhenHoursMatch__1 | 24 | Alarm When Hours Match
AlarmWhenDateMatch | 0 | Alarm When Date Match
AlarmWhenDayMatch | 16 | Alarm When Day Match
Reserved | 1 | Reserved
Reserved__1 | 9 | Reserved
Reserved__2 | 13 | Reserved
Reserved__3 | 17 | Reserved
Reserved__4 | 25 | Reserved
Reserved__5 | 29 | Reserved
See Also

Reference

telos.Ird.Maxim Namespace


Ds1375.AlarmMask2Type Enumeration

IRD

Ds1375AlarmMask2Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmMask2Type
Public Enumeration AlarmMask2Type
public enum class AlarmMask2Type
type AlarmMask2Type
Members
Member name | Value | Description
AlarmOncePerMinute | 7 | Alarm Once Per Minute
AlarmOncePerMinute__1 | 15 | Alarm Once Per Minute
AlarmWhenMinutesMatch | 6 | Alarm When Minutes Match
AlarmWhenMinutesMatch__1 | 14 | Alarm When Minutes Match
AlarmWhenHoursMatch | 4 | Alarm When Hours Match
AlarmWhenHoursMatch__1 | 12 | Alarm When Hours Match
AlarmWhenDateMatch | 0 | Alarm When Date Match
AlarmWhenDayMatch | 8 | Alarm When Day Match
Reserved | 2 | Reserved
Reserved__1 | 5 | Reserved
Reserved__2 | 9 | Reserved
Reserved__3 | 13 | Reserved
See Also

Reference

telos.Ird.Maxim Namespace


Ds1375.ClockEnableType Enumeration

IRD

Ds1375ClockEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ClockEnableType
Public Enumeration ClockEnableType
public enum class ClockEnableType
type ClockEnableType
Members
Member name | Value | Description
ClockEnable | 1 | Clock Enable
ClockDisable | 0 | Clock Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds1375.ClockSelectType Enumeration

IRD

Ds1375ClockSelectType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ClockSelectType
Public Enumeration ClockSelectType
public enum class ClockSelectType
type ClockSelectType
Members
Member name | Value | Description
InputFrequency32768 | 0 | Input Frequency: 32768
InputFrequency8192 | 1 | Input Frequency: 8192
InputFrequency60 | 2 | Input Frequency: 60
InputFrequency50 | 3 | Input Frequency: 50
See Also

Reference

telos.Ird.Maxim Namespace


Ds1375.DayDateType Enumeration

IRD

Ds1375DayDateType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DayDateType
Public Enumeration DayDateType
public enum class DayDateType
type DayDateType
Members
Member name | Value | Description
Day | 1 | Day
Date | 0 | Date
See Also

Reference

telos.Ird.Maxim Namespace


Ds1375.H1224Type Enumeration

IRD

Ds1375H1224Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum H1224Type
Public Enumeration H1224Type
public enum class H1224Type
type H1224Type
Members
Member name | Value | Description
Value_12Hours | 1 | 12 Hours
Value_24Hours | 0 | 24 Hours
See Also

Reference

telos.Ird.Maxim Namespace


Ds1375.InterruptControlType Enumeration

IRD

Ds1375InterruptControlType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum InterruptControlType
Public Enumeration InterruptControlType
public enum class InterruptControlType
type InterruptControlType
Members
Member name | Value | Description
Alarm1ActivatesINTAPin | 1 | Alarm1 Activates INTA Pin
Alarm1OrAlarm2ActivatesINTAPin | 0 | Alarm1 Or Alarm2 Activates INTA Pin
See Also

Reference

telos.Ird.Maxim Namespace


Ds1375.SquareWaveType Enumeration

IRD

Ds1375SquareWaveType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SquareWaveType
Public Enumeration SquareWaveType
public enum class SquareWaveType
type SquareWaveType
Members
Member name | Value | Description
SquareWaveFrequency1 | 0 | Square Wave Frequency: 1
SquareWaveFrequency4096 | 1 | Square Wave Frequency: 4096
SquareWaveFrequency8192 | 2 | Square Wave Frequency: 8192
SquareWaveFrequency32768 | 3 | Square Wave Frequency: 32768
See Also

Reference

telos.Ird.Maxim Namespace


Ds13881 Class

Maxim: DS 1388(RTC)
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs13881

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds13881
Public Class Ds13881
public ref class Ds13881
type Ds13881 =  class end

The Ds13881 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds13881 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Date | Date
Public property | Day | Day
Public property | DiodeSelectDSx | Diode Select (DSx)
Public property | EnableOscillatorEOSC | Enable Oscillator (EOSC)
Public property | Hours | Hours (unit: hour)
Public property | HundredthsOfSeconds | Hundredths Of Seconds
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | OscillatorStopFlagOSF | Oscillator Stop Flag (OSF)
Public property | ResistorSelectROUTx | Resistor Select (ROUTx)
Public property | Seconds | Seconds (unit: s)
Public property | Switch12To24Hours1224 | Switch 12 To 24 Hours (12/24)
Public property | TrickleChargeTCSx | Trickle Charge (TCSx)
Public property | WatchdogAlarmFlagWD | Watchdog Alarm Flag (WD)
Public property | WatchdogEnableWDE | Watchdog Enable (WDE)
Public property | WatchdogHundredthsOfSeconds | Watchdog Hundredths Of Seconds
Public property | WatchdogResetWDRST | Watchdog Reset (WD/RST)
Public property | WatchdogSeconds | Watchdog Seconds
Public property | Year | Year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
RTC/Supervisor With Trickle Charger
See Also

Reference

telos.Ird.Maxim Namespace


Ds13881 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds13881(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds13881(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds13881

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881 Properties

The Ds13881 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Date | Date
Public property | Day | Day
Public property | DiodeSelectDSx | Diode Select (DSx)
Public property | EnableOscillatorEOSC | Enable Oscillator (EOSC)
Public property | Hours | Hours (unit: hour)
Public property | HundredthsOfSeconds | Hundredths Of Seconds
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | OscillatorStopFlagOSF | Oscillator Stop Flag (OSF)
Public property | ResistorSelectROUTx | Resistor Select (ROUTx)
Public property | Seconds | Seconds (unit: s)
Public property | Switch12To24Hours1224 | Switch 12 To 24 Hours (12/24)
Public property | TrickleChargeTCSx | Trickle Charge (TCSx)
Public property | WatchdogAlarmFlagWD | Watchdog Alarm Flag (WD)
Public property | WatchdogEnableWDE | Watchdog Enable (WDE)
Public property | WatchdogHundredthsOfSeconds | Watchdog Hundredths Of Seconds
Public property | WatchdogResetWDRST | Watchdog Reset (WD/RST)
Public property | WatchdogSeconds | Watchdog Seconds
Public property | Year | Year
Top
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.AutoFlush Property

IRD

Ds13881AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.Date Property

IRD

Ds13881Date Property

Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Date { get; set; }
Public Property Date As Byte
    Get
    Set
public:
property unsigned char Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.Day Property

IRD

Ds13881Day Property

Day

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Day { get; set; }
Public Property Day As Byte
    Get
    Set
public:
property unsigned char Day {
    unsigned char get ();
    void set (unsigned char value);
}
member Day : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.DiodeSelectDSx Property

IRD

Ds13881DiodeSelectDSx Property

Diode Select (DSx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds13881DiodeSelectType DiodeSelectDSx { get; set; }
Public Property DiodeSelectDSx As Ds13881DiodeSelectType
    Get
    Set
public:
property Ds13881DiodeSelectType DiodeSelectDSx {
    Ds13881DiodeSelectType get ();
    void set (Ds13881DiodeSelectType value);
}
member DiodeSelectDSx : Ds13881DiodeSelectType with get, set

Property Value

Type: Ds13881DiodeSelectType
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.EnableOscillatorEOSC Property

IRD

Ds13881EnableOscillatorEOSC Property

Enable Oscillator (EOSC)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds13881ControlOscenaType EnableOscillatorEOSC { get; set; }
Public Property EnableOscillatorEOSC As Ds13881ControlOscenaType
    Get
    Set
public:
property Ds13881ControlOscenaType EnableOscillatorEOSC {
    Ds13881ControlOscenaType get ();
    void set (Ds13881ControlOscenaType value);
}
member EnableOscillatorEOSC : Ds13881ControlOscenaType with get, set

Property Value

Type: Ds13881ControlOscenaType
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.Hours Property

IRD

Ds13881Hours Property

Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Hours { get; set; }
Public Property Hours As Byte
    Get
    Set
public:
property unsigned char Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.HundredthsOfSeconds Property

IRD

Ds13881HundredthsOfSeconds Property

Hundredths Of Seconds

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte HundredthsOfSeconds { get; set; }
Public Property HundredthsOfSeconds As Byte
    Get
    Set
public:
property unsigned char HundredthsOfSeconds {
    unsigned char get ();
    void set (unsigned char value);
}
member HundredthsOfSeconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.Minutes Property

IRD

Ds13881Minutes Property

Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Minutes { get; set; }
Public Property Minutes As Byte
    Get
    Set
public:
property unsigned char Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.Month Property

IRD

Ds13881Month Property

Month

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Month { get; set; }
Public Property Month As Byte
    Get
    Set
public:
property unsigned char Month {
    unsigned char get ();
    void set (unsigned char value);
}
member Month : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.OscillatorStopFlagOSF Property

IRD

Ds13881OscillatorStopFlagOSF Property

Oscillator Stop Flag (OSF)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds13881OscStopType OscillatorStopFlagOSF { get; set; }
Public Property OscillatorStopFlagOSF As Ds13881OscStopType
    Get
    Set
public:
property Ds13881OscStopType OscillatorStopFlagOSF {
    Ds13881OscStopType get ();
    void set (Ds13881OscStopType value);
}
member OscillatorStopFlagOSF : Ds13881OscStopType with get, set

Property Value

Type: Ds13881OscStopType
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.ResistorSelectROUTx Property

IRD

Ds13881ResistorSelectROUTx Property

Resistor Select (ROUTx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds13881ResistorType ResistorSelectROUTx { get; set; }
Public Property ResistorSelectROUTx As Ds13881ResistorType
    Get
    Set
public:
property Ds13881ResistorType ResistorSelectROUTx {
    Ds13881ResistorType get ();
    void set (Ds13881ResistorType value);
}
member ResistorSelectROUTx : Ds13881ResistorType with get, set

Property Value

Type: Ds13881ResistorType
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.Seconds Property

IRD

Ds13881Seconds Property

Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Seconds { get; set; }
Public Property Seconds As Byte
    Get
    Set
public:
property unsigned char Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.Switch12To24Hours1224 Property

IRD

Ds13881Switch12To24Hours1224 Property

Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds13881H1224Type Switch12To24Hours1224 { get; set; }
Public Property Switch12To24Hours1224 As Ds13881H1224Type
    Get
    Set
public:
property Ds13881H1224Type Switch12To24Hours1224 {
    Ds13881H1224Type get ();
    void set (Ds13881H1224Type value);
}
member Switch12To24Hours1224 : Ds13881H1224Type with get, set

Property Value

Type: Ds13881H1224Type
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.TrickleChargeTCSx Property

IRD

Ds13881TrickleChargeTCSx Property

Trickle Charge (TCSx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds13881TrickleType TrickleChargeTCSx { get; set; }
Public Property TrickleChargeTCSx As Ds13881TrickleType
    Get
    Set
public:
property Ds13881TrickleType TrickleChargeTCSx {
    Ds13881TrickleType get ();
    void set (Ds13881TrickleType value);
}
member TrickleChargeTCSx : Ds13881TrickleType with get, set

Property Value

Type: Ds13881TrickleType
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.WatchdogAlarmFlagWD Property

IRD

Ds13881WatchdogAlarmFlagWD Property

Watchdog Alarm Flag (WD)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds13881AlarmFlagType WatchdogAlarmFlagWD { get; set; }
Public Property WatchdogAlarmFlagWD As Ds13881AlarmFlagType
    Get
    Set
public:
property Ds13881AlarmFlagType WatchdogAlarmFlagWD {
    Ds13881AlarmFlagType get ();
    void set (Ds13881AlarmFlagType value);
}
member WatchdogAlarmFlagWD : Ds13881AlarmFlagType with get, set

Property Value

Type: Ds13881AlarmFlagType
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.WatchdogEnableWDE Property

IRD

Ds13881WatchdogEnableWDE Property

Watchdog Enable (WDE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds13881WatchdogEnableType WatchdogEnableWDE { get; set; }
Public Property WatchdogEnableWDE As Ds13881WatchdogEnableType
    Get
    Set
public:
property Ds13881WatchdogEnableType WatchdogEnableWDE {
    Ds13881WatchdogEnableType get ();
    void set (Ds13881WatchdogEnableType value);
}
member WatchdogEnableWDE : Ds13881WatchdogEnableType with get, set

Property Value

Type: Ds13881WatchdogEnableType
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.WatchdogHundredthsOfSeconds Property

IRD

Ds13881WatchdogHundredthsOfSeconds Property

Watchdog Hundredths Of Seconds

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WatchdogHundredthsOfSeconds { get; set; }
Public Property WatchdogHundredthsOfSeconds As Byte
    Get
    Set
public:
property unsigned char WatchdogHundredthsOfSeconds {
    unsigned char get ();
    void set (unsigned char value);
}
member WatchdogHundredthsOfSeconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.WatchdogResetWDRST Property

IRD

Ds13881WatchdogResetWDRST Property

Watchdog Reset (WD/RST)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds13881WatchdogResetType WatchdogResetWDRST { get; set; }
Public Property WatchdogResetWDRST As Ds13881WatchdogResetType
    Get
    Set
public:
property Ds13881WatchdogResetType WatchdogResetWDRST {
    Ds13881WatchdogResetType get ();
    void set (Ds13881WatchdogResetType value);
}
member WatchdogResetWDRST : Ds13881WatchdogResetType with get, set

Property Value

Type: Ds13881WatchdogResetType
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.WatchdogSeconds Property

IRD

Ds13881WatchdogSeconds Property

Watchdog Seconds

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WatchdogSeconds { get; set; }
Public Property WatchdogSeconds As Byte
    Get
    Set
public:
property unsigned char WatchdogSeconds {
    unsigned char get ();
    void set (unsigned char value);
}
member WatchdogSeconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.Year Property

IRD

Ds13881Year Property

Year

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Year { get; set; }
Public Property Year As Byte
    Get
    Set
public:
property unsigned char Year {
    unsigned char get ();
    void set (unsigned char value);
}
member Year : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881 Methods

The Ds13881 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.Flush Method

IRD

Ds13881Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds13881 Class
telos.Ird.Maxim Namespace


Ds13881.AlarmFlagType Enumeration

IRD

Ds13881AlarmFlagType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmFlagType
Public Enumeration AlarmFlagType
public enum class AlarmFlagType
type AlarmFlagType
Members
Member name | Value | Description
WatchdogCounterReachesZero | 1 | Watchdog Counter Reaches Zero
WatchdogFlagClear | 0 | Watchdog Flag Clear
See Also

Reference

telos.Ird.Maxim Namespace


Ds13881.ControlOscenaType Enumeration

IRD

Ds13881ControlOscenaType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlOscenaType
Public Enumeration ControlOscenaType
public enum class ControlOscenaType
type ControlOscenaType
Members
Member name | Value | Description
OscillatorStop | 1 | Oscillator: Stop
OscillatorStart | 0 | Oscillator: Start
See Also

Reference

telos.Ird.Maxim Namespace


Ds13881.DiodeSelectType Enumeration

IRD

Ds13881DiodeSelectType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DiodeSelectType
Public Enumeration DiodeSelectType
public enum class DiodeSelectType
type DiodeSelectType
Members
Member name | Value | Description
Disabled | 0 | Disabled
NoDiodeSelected | 1 | No Diode Selected
OneDiodeSelected | 2 | One Diode Selected
Disabled__1 | 3 | Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds13881.H1224Type Enumeration

IRD

Ds13881H1224Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum H1224Type
Public Enumeration H1224Type
public enum class H1224Type
type H1224Type
Members
Member name | Value | Description
Value_12Hours | 1 | 12 Hours
Value_24Hours | 0 | 24 Hours
See Also

Reference

telos.Ird.Maxim Namespace


Ds13881.OscStopType Enumeration

IRD

Ds13881OscStopType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum OscStopType
Public Enumeration OscStopType
public enum class OscStopType
type OscStopType
Members
Member name | Value | Description
OscillatorStopFlagOSCStop | 1 | Oscillator Stop Flag: OSC Stop
OscillatorStopFlagOSCRunning | 0 | Oscillator Stop Flag: OSC Running
See Also

Reference

telos.Ird.Maxim Namespace


Ds13881.ResistorType Enumeration

IRD

Ds13881ResistorType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ResistorType
Public Enumeration ResistorType
public enum class ResistorType
type ResistorType
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_250OhmResistor | 1 | 250 Ohm Resistor
Value_2KOhmResistor | 2 | 2 kOhm Resistor
Value_4KOhmResistor | 3 | 4 kOhm Resistor
See Also

Reference

telos.Ird.Maxim Namespace


Ds13881.TrickleType Enumeration

IRD

Ds13881TrickleType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TrickleType
Public Enumeration TrickleType
public enum class TrickleType
type TrickleType
Members
Member name | Value | Description
TrickleChargeDisabled | 0 | Trickle Charge Disabled
TrickleChargeEnabled | 10 | Trickle Charge Enabled
TrickleChargeDisabled__1 | 11 | Trickle Charge Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds13881.WatchdogEnableType Enumeration

IRD

Ds13881WatchdogEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum WatchdogEnableType
Public Enumeration WatchdogEnableType
public enum class WatchdogEnableType
type WatchdogEnableType
Members
Member name | Value | Description
WatchdogCounterEnable | 1 | Watchdog Counter Enable
WatchdogCounterDisable | 0 | Watchdog Counter Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds13881.WatchdogResetType Enumeration

IRD

Ds13881WatchdogResetType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum WatchdogResetType
Public Enumeration WatchdogResetType
public enum class WatchdogResetType
type WatchdogResetType
Members
Member name | Value | Description
WatchdogAlarmAtRSTPin | 1 | Watchdog Alarm At RST Pin
NoWatchdogAlarm | 0 | No Watchdog Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Ds13882 Class

Maxim: DS 1388(EEPROM Bank 1)
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs13882

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds13882
Public Class Ds13882
public ref class Ds13882
type Ds13882 =  class end

The Ds13882 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds13882 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
RTC/Supervisor EEPROM Bank 1
See Also

Reference

telos.Ird.Maxim Namespace


Ds13882 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds13882(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds13882(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds13882

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds13882 Class
telos.Ird.Maxim Namespace


Ds13882 Properties

The Ds13882 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Top
See Also

Reference

Ds13882 Class
telos.Ird.Maxim Namespace


Ds13882.AutoFlush Property

IRD

Ds13882AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds13882 Class
telos.Ird.Maxim Namespace


Ds13882 Methods

The Ds13882 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds13882 Class
telos.Ird.Maxim Namespace


Ds13882.Flush Method

IRD

Ds13882Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds13882 Class
telos.Ird.Maxim Namespace


Ds13883 Class

Maxim: DS 1388(EEPROM Bank 2)
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs13883

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds13883
Public Class Ds13883
public ref class Ds13883
type Ds13883 =  class end

The Ds13883 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds13883 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
RTC/Supervisor EEPROM Bank 2
See Also

Reference

telos.Ird.Maxim Namespace


Ds13883 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds13883(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds13883(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds13883

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds13883 Class
telos.Ird.Maxim Namespace


Ds13883 Properties

The Ds13883 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Top
See Also

Reference

Ds13883 Class
telos.Ird.Maxim Namespace


Ds13883.AutoFlush Property

IRD

Ds13883AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds13883 Class
telos.Ird.Maxim Namespace


Ds13883 Methods

The Ds13883 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds13883 Class
telos.Ird.Maxim Namespace


Ds13883.Flush Method

IRD

Ds13883Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds13883 Class
telos.Ird.Maxim Namespace


Ds1631 Class

Maxim: DS 1631 (A) / DS 1731
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs1631

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds1631
Public Class Ds1631
public ref class Ds1631
type Ds1631 =  class end

The Ds1631 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds1631 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Config1SHOT | Config (1SHOT)
Public property | ConfigDONE | Config (DONE)
Public property | ConfigNVB | Config (NVB)
Public property | ConfigPOL | Config (POL)
Public property | ConfigResolution | Config (Resolution) (unit: bit)
Public property | ConfigTHF | Config (THF)
Public property | ConfigTLF | Config (TLF)
Public property | Temperature | Temperature (unit: °C)
Public property | TH | T_H (unit: °C)
Public property | TL | T_L (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SoftwarePOR | Software POR
Public method | StartConvertT | Start Convert T
Public method | StopConvertT | Stop Convert T
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
High-Precision Digital Thermometer And Thermostat
See Also

Reference

telos.Ird.Maxim Namespace


Ds1631 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1631(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds1631(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds1631

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds1631 Class
telos.Ird.Maxim Namespace


Ds1631 Properties

The Ds1631 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Config1SHOT | Config (1SHOT)
Public property | ConfigDONE | Config (DONE)
Public property | ConfigNVB | Config (NVB)
Public property | ConfigPOL | Config (POL)
Public property | ConfigResolution | Config (Resolution) (unit: bit)
Public property | ConfigTHF | Config (THF)
Public property | ConfigTLF | Config (TLF)
Public property | Temperature | Temperature (unit: °C)
Public property | TH | T_H (unit: °C)
Public property | TL | T_L (unit: °C)
Top
See Also

Reference

Ds1631 Class
telos.Ird.Maxim Namespace


Ds1631.AutoFlush Property

IRD

Ds1631AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds1631 Class
telos.Ird.Maxim Namespace


Ds1631.Config1SHOT Property

IRD

Ds1631Config1SHOT Property

Config (1SHOT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1631Config1shotType Config1SHOT { get; set; }
Public Property Config1SHOT As Ds1631Config1shotType
    Get
    Set
public:
property Ds1631Config1shotType Config1SHOT {
    Ds1631Config1shotType get ();
    void set (Ds1631Config1shotType value);
}
member Config1SHOT : Ds1631Config1shotType with get, set

Property Value

Type: Ds1631Config1shotType
See Also

Reference

Ds1631 Class
telos.Ird.Maxim Namespace


Ds1631.ConfigDONE Property

IRD

Ds1631ConfigDONE Property

Config (DONE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1631ConfigDoneType ConfigDONE { get; }
Public ReadOnly Property ConfigDONE As Ds1631ConfigDoneType
    Get
public:
property Ds1631ConfigDoneType ConfigDONE {
    Ds1631ConfigDoneType get ();
}
member ConfigDONE : Ds1631ConfigDoneType with get

Property Value

Type: Ds1631ConfigDoneType
See Also

Reference

Ds1631 Class
telos.Ird.Maxim Namespace


Ds1631.ConfigNVB Property

IRD

Ds1631ConfigNVB Property

Config (NVB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1631ConfigNvbType ConfigNVB { get; }
Public ReadOnly Property ConfigNVB As Ds1631ConfigNvbType
    Get
public:
property Ds1631ConfigNvbType ConfigNVB {
    Ds1631ConfigNvbType get ();
}
member ConfigNVB : Ds1631ConfigNvbType with get

Property Value

Type: Ds1631ConfigNvbType
See Also

Reference

Ds1631 Class
telos.Ird.Maxim Namespace


Ds1631.ConfigPOL Property

IRD

Ds1631ConfigPOL Property

Config (POL)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1631ConfigPolType ConfigPOL { get; set; }
Public Property ConfigPOL As Ds1631ConfigPolType
    Get
    Set
public:
property Ds1631ConfigPolType ConfigPOL {
    Ds1631ConfigPolType get ();
    void set (Ds1631ConfigPolType value);
}
member ConfigPOL : Ds1631ConfigPolType with get, set

Property Value

Type: Ds1631ConfigPolType
See Also

Reference

Ds1631 Class
telos.Ird.Maxim Namespace


Ds1631.ConfigResolution Property

IRD

Ds1631ConfigResolution Property

Config (Resolution) (unit: bit)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1631ConfigResType ConfigResolution { get; set; }
Public Property ConfigResolution As Ds1631ConfigResType
    Get
    Set
public:
property Ds1631ConfigResType ConfigResolution {
    Ds1631ConfigResType get ();
    void set (Ds1631ConfigResType value);
}
member ConfigResolution : Ds1631ConfigResType with get, set

Property Value

Type: Ds1631ConfigResType
See Also

Reference

Ds1631 Class
telos.Ird.Maxim Namespace


Ds1631.ConfigTHF Property

IRD

Ds1631ConfigTHF Property

Config (THF)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1631ConfigThfType ConfigTHF { get; set; }
Public Property ConfigTHF As Ds1631ConfigThfType
    Get
    Set
public:
property Ds1631ConfigThfType ConfigTHF {
    Ds1631ConfigThfType get ();
    void set (Ds1631ConfigThfType value);
}
member ConfigTHF : Ds1631ConfigThfType with get, set

Property Value

Type: Ds1631ConfigThfType
See Also

Reference

Ds1631 Class
telos.Ird.Maxim Namespace


Ds1631.ConfigTLF Property

IRD

Ds1631ConfigTLF Property

Config (TLF)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1631ConfigTlfType ConfigTLF { get; set; }
Public Property ConfigTLF As Ds1631ConfigTlfType
    Get
    Set
public:
property Ds1631ConfigTlfType ConfigTLF {
    Ds1631ConfigTlfType get ();
    void set (Ds1631ConfigTlfType value);
}
member ConfigTLF : Ds1631ConfigTlfType with get, set

Property Value

Type: Ds1631ConfigTlfType
See Also

Reference

Ds1631 Class
telos.Ird.Maxim Namespace


Ds1631.Temperature Property

IRD

Ds1631Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Ds1631 Class
telos.Ird.Maxim Namespace


Ds1631.TH Property

IRD

Ds1631TH Property

T_H (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TH { get; set; }
Public Property TH As Double
    Get
    Set
public:
property double TH {
    double get ();
    void set (double value);
}
member TH : float with get, set

Property Value

Type: Double
See Also

Reference

Ds1631 Class
telos.Ird.Maxim Namespace


Ds1631.TL Property

IRD

Ds1631TL Property

T_L (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TL { get; set; }
Public Property TL As Double
    Get
    Set
public:
property double TL {
    double get ();
    void set (double value);
}
member TL : float with get, set

Property Value

Type: Double
See Also

Reference

Ds1631 Class
telos.Ird.Maxim Namespace


Ds1631 Methods

The Ds1631 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SoftwarePOR | Software POR
Public method | StartConvertT | Start Convert T
Public method | StopConvertT | Stop Convert T
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds1631 Class
telos.Ird.Maxim Namespace


Ds1631.Flush Method

IRD

Ds1631Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds1631 Class
telos.Ird.Maxim Namespace


Ds1631.SoftwarePOR Method

IRD

Ds1631SoftwarePOR Method

Software POR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void SoftwarePOR()
Public Sub SoftwarePOR
public:
void SoftwarePOR()
member SoftwarePOR : unit -> unit
See Also

Reference

Ds1631 Class
telos.Ird.Maxim Namespace


Ds1631.StartConvertT Method

IRD

Ds1631StartConvertT Method

Start Convert T

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void StartConvertT()
Public Sub StartConvertT
public:
void StartConvertT()
member StartConvertT : unit -> unit
See Also

Reference

Ds1631 Class
telos.Ird.Maxim Namespace


Ds1631.StopConvertT Method

IRD

Ds1631StopConvertT Method

Stop Convert T

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void StopConvertT()
Public Sub StopConvertT
public:
void StopConvertT()
member StopConvertT : unit -> unit
See Also

Reference

Ds1631 Class
telos.Ird.Maxim Namespace


Ds1631.Config1shotType Enumeration

IRD

Ds1631Config1shotType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Config1shotType
Public Enumeration Config1shotType
public enum class Config1shotType
type Config1shotType
Members
Member name | Value | Description
ContinuousConversionMode | 0 | Continuous Conversion Mode
OneShotMode | 1 | One-Shot Mode
See Also

Reference

telos.Ird.Maxim Namespace


Ds1631.ConfigDoneType Enumeration

IRD

Ds1631ConfigDoneType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigDoneType
Public Enumeration ConfigDoneType
public enum class ConfigDoneType
type ConfigDoneType
Members
Member name | Value | Description
TempConversionInProgress | 0 | Temp Conversion: In Progress
TempConversionComplete | 1 | Temp Conversion: Complete
See Also

Reference

telos.Ird.Maxim Namespace


Ds1631.ConfigNvbType Enumeration

IRD

Ds1631ConfigNvbType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigNvbType
Public Enumeration ConfigNvbType
public enum class ConfigNvbType
type ConfigNvbType
Members
Member name | Value | Description
NVMemoryNotBusy | 0 | NV Memory: Not Busy
NVMemoryBusy | 1 | NV Memory: Busy
See Also

Reference

telos.Ird.Maxim Namespace


Ds1631.ConfigPolType Enumeration

IRD

Ds1631ConfigPolType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigPolType
Public Enumeration ConfigPolType
public enum class ConfigPolType
type ConfigPolType
Members
Member name | Value | Description
TOUTPolarityActiveHigh | 0 | T_OUT Polarity: Active High
TOUTPolarityActiveLow | 1 | T_OUT Polarity: Active Low
See Also

Reference

telos.Ird.Maxim Namespace


Ds1631.ConfigResType Enumeration

IRD

Ds1631ConfigResType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigResType
Public Enumeration ConfigResType
public enum class ConfigResType
type ConfigResType
Members
Member name | Value | Description
Value_9 | 0 | 9
Value_10 | 1 | 10
Value_11 | 2 | 11
Value_12 | 3 | 12
See Also

Reference

telos.Ird.Maxim Namespace


Ds1631.ConfigThfType Enumeration

IRD

Ds1631ConfigThfType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigThfType
Public Enumeration ConfigThfType
public enum class ConfigThfType
type ConfigThfType
Members
Member name | Value | Description
THNotExceeded | 0 | T_H: Not Exceeded
THExceeded | 1 | T_H: Exceeded
See Also

Reference

telos.Ird.Maxim Namespace


Ds1631.ConfigTlfType Enumeration

IRD

Ds1631ConfigTlfType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigTlfType
Public Enumeration ConfigTlfType
public enum class ConfigTlfType
type ConfigTlfType
Members
Member name | Value | Description
TLNotLower | 0 | T_L: Not Lower
TLLower | 1 | T_L: Lower
See Also

Reference

telos.Ird.Maxim Namespace


Ds1672 Class

Maxim: DS 1672
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs1672

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds1672
Public Class Ds1672
public ref class Ds1672
type Ds1672 =  class end

The Ds1672 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds1672 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CounterBytes14 | Counter Bytes 1-4
Public property | DiodeSelectDSx | Diode Select (DSx)
Public property | EnableOscillatorEOSC | Enable Oscillator (EOSC)
Public property | ResistorSelectROUTx | Resistor Select (ROUTx)
Public property | TrickleChargeTCSx | Trickle Charge (TCSx)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low Voltage Serial Timekeeping Chip
See Also

Reference

telos.Ird.Maxim Namespace


Ds1672 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1672(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds1672(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds1672

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds1672 Class
telos.Ird.Maxim Namespace


Ds1672 Properties

The Ds1672 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CounterBytes14 | Counter Bytes 1-4
Public property | DiodeSelectDSx | Diode Select (DSx)
Public property | EnableOscillatorEOSC | Enable Oscillator (EOSC)
Public property | ResistorSelectROUTx | Resistor Select (ROUTx)
Public property | TrickleChargeTCSx | Trickle Charge (TCSx)
Top
See Also

Reference

Ds1672 Class
telos.Ird.Maxim Namespace


Ds1672.AutoFlush Property

IRD

Ds1672AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds1672 Class
telos.Ird.Maxim Namespace


Ds1672.CounterBytes14 Property

IRD

Ds1672CounterBytes14 Property

Counter Bytes 1-4

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint CounterBytes14 { get; set; }
Public Property CounterBytes14 As UInteger
    Get
    Set
public:
property unsigned int CounterBytes14 {
    unsigned int get ();
    void set (unsigned int value);
}
member CounterBytes14 : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

Ds1672 Class
telos.Ird.Maxim Namespace


Ds1672.DiodeSelectDSx Property

IRD

Ds1672DiodeSelectDSx Property

Diode Select (DSx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1672DiodeSelectType DiodeSelectDSx { get; set; }
Public Property DiodeSelectDSx As Ds1672DiodeSelectType
    Get
    Set
public:
property Ds1672DiodeSelectType DiodeSelectDSx {
    Ds1672DiodeSelectType get ();
    void set (Ds1672DiodeSelectType value);
}
member DiodeSelectDSx : Ds1672DiodeSelectType with get, set

Property Value

Type: Ds1672DiodeSelectType
See Also

Reference

Ds1672 Class
telos.Ird.Maxim Namespace


Ds1672.EnableOscillatorEOSC Property

IRD

Ds1672EnableOscillatorEOSC Property

Enable Oscillator (EOSC)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1672ControlOscenaType EnableOscillatorEOSC { get; set; }
Public Property EnableOscillatorEOSC As Ds1672ControlOscenaType
    Get
    Set
public:
property Ds1672ControlOscenaType EnableOscillatorEOSC {
    Ds1672ControlOscenaType get ();
    void set (Ds1672ControlOscenaType value);
}
member EnableOscillatorEOSC : Ds1672ControlOscenaType with get, set

Property Value

Type: Ds1672ControlOscenaType
See Also

Reference

Ds1672 Class
telos.Ird.Maxim Namespace


Ds1672.ResistorSelectROUTx Property

IRD

Ds1672ResistorSelectROUTx Property

Resistor Select (ROUTx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1672ResistorType ResistorSelectROUTx { get; set; }
Public Property ResistorSelectROUTx As Ds1672ResistorType
    Get
    Set
public:
property Ds1672ResistorType ResistorSelectROUTx {
    Ds1672ResistorType get ();
    void set (Ds1672ResistorType value);
}
member ResistorSelectROUTx : Ds1672ResistorType with get, set

Property Value

Type: Ds1672ResistorType
See Also

Reference

Ds1672 Class
telos.Ird.Maxim Namespace


Ds1672.TrickleChargeTCSx Property

IRD

Ds1672TrickleChargeTCSx Property

Trickle Charge (TCSx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1672TrickleType TrickleChargeTCSx { get; set; }
Public Property TrickleChargeTCSx As Ds1672TrickleType
    Get
    Set
public:
property Ds1672TrickleType TrickleChargeTCSx {
    Ds1672TrickleType get ();
    void set (Ds1672TrickleType value);
}
member TrickleChargeTCSx : Ds1672TrickleType with get, set

Property Value

Type: Ds1672TrickleType
See Also

Reference

Ds1672 Class
telos.Ird.Maxim Namespace


Ds1672 Methods

The Ds1672 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds1672 Class
telos.Ird.Maxim Namespace


Ds1672.Flush Method

IRD

Ds1672Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds1672 Class
telos.Ird.Maxim Namespace


Ds1672.ControlOscenaType Enumeration

IRD

Ds1672ControlOscenaType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlOscenaType
Public Enumeration ControlOscenaType
public enum class ControlOscenaType
type ControlOscenaType
Members
Member name | Value | Description
OscillatorStop | 1 | Oscillator: Stop
OscillatorStart | 0 | Oscillator: Start
See Also

Reference

telos.Ird.Maxim Namespace


Ds1672.DiodeSelectType Enumeration

IRD

Ds1672DiodeSelectType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DiodeSelectType
Public Enumeration DiodeSelectType
public enum class DiodeSelectType
type DiodeSelectType
Members
Member name | Value | Description
Disabled | 0 | Disabled
NoDiodeSelected | 1 | No Diode Selected
OneDiodeSelected | 2 | One Diode Selected
Disabled__1 | 3 | Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds1672.ResistorType Enumeration

IRD

Ds1672ResistorType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ResistorType
Public Enumeration ResistorType
public enum class ResistorType
type ResistorType
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_250OhmResistor | 1 | 250 Ohm Resistor
Value_2KOhmResistor | 2 | 2 kOhm Resistor
Value_4KOhmResistor | 3 | 4 kOhm Resistor
See Also

Reference

telos.Ird.Maxim Namespace


Ds1672.TrickleType Enumeration

IRD

Ds1672TrickleType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TrickleType
Public Enumeration TrickleType
public enum class TrickleType
type TrickleType
Members
Member name | Value | Description
TrickleChargeDisabled | 0 | Trickle Charge Disabled
TrickleChargeEnabled | 10 | Trickle Charge Enabled
TrickleChargeDisabled__1 | 11 | Trickle Charge Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds1678 Class

Maxim: DS 1678
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs1678

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds1678
Public Class Ds1678
public ref class Ds1678
type Ds1678 =  class end

The Ds1678 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds1678 | Constructor
Top
Properties
 | Name | Description
Public property | AddressPointer | Address Pointer
Public property | AlarmDate | Alarm Date
Public property | AlarmFlagALMF | Alarm Flag (ALMF)
Public property | AlarmHours | Alarm Hours (unit: hour)
Public property | AlarmMinutes | Alarm Minutes (unit: min)
Public property | AlarmRegisterMaskBitsMSMMMHMD | Alarm Register Mask Bits (MS/MM/MH/MD)
Public property | AlarmSeconds | Alarm Seconds (unit: s)
Public property | AlarmSwitch12To24Hours1224 | Alarm Switch 12 To 24 Hours (12/24)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Century | Century
Public property | ClearEnableCLR | Clear Enable (CLR)
Public property | ClearMemoryCM | Clear Memory (CM)
Public property | ClockOscillatorEnableCOE | Clock Oscillator Enable (COE)
Public property | CounterCentury | Counter Century
Public property | CounterDate | Counter Date
Public property | CounterDayOfWeek | Counter Day Of Week
Public property | CounterHours | Counter Hours (unit: hour)
Public property | CounterMinutes | Counter Minutes (unit: min)
Public property | CounterMonth | Counter Month
Public property | CounterSeconds | Counter Seconds (unit: s)
Public property | CounterSwitch12To24Hours1224 | Counter Switch 12 To 24 Hours (12/24)
Public property | CounterYear | Counter Year
Public property | DataLogRAMPortAddress | Data Log RAM Port Address
Public property | DataLogRAMPortDataByte | Data Log RAM Port Data Byte
Public property | Date | Date
Public property | DayOfWeek | Day Of Week
Public property | DurationIntervalSelectDISx | Duration Interval Select (DISx)
Public property | ElapseTimeCounterETC | Elapse Time Counter (ETC)
Public property | Event0ElapseTime | Event 0 Elapse Time
Public property | EventCounter | Event Counter
Public property | Hours | Hours (unit: hour)
Public property | LowBatteryFlagLOBAT | Low Battery Flag (LOBAT)
Public property | MemoryClearMEMCLR | Memory Clear (MEM CLR)
Public property | Minutes | Minutes (unit: min)
Public property | MissionEnableME | Mission Enable (ME)
Public property | MissionInProgressMIP | Mission In Progress (MIP)
Public property | Month | Month
Public property | RollOverFlagROF | Roll Over Flag (ROF)
Public property | RollOverRO | Roll Over (RO)
Public property | Seconds | Seconds (unit: s)
Public property | Switch12To24Hours1224 | Switch 12 To 24 Hours (12/24)
Public property | TriggerSelectTRx | Trigger Select (TRx)
Public property | Year | Year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Real Time Event Recorder
See Also

Reference

telos.Ird.Maxim Namespace


Ds1678 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1678(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds1678(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds1678

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678 Properties

The Ds1678 type exposes the following members.

Properties
 | Name | Description
Public property | AddressPointer | Address Pointer
Public property | AlarmDate | Alarm Date
Public property | AlarmFlagALMF | Alarm Flag (ALMF)
Public property | AlarmHours | Alarm Hours (unit: hour)
Public property | AlarmMinutes | Alarm Minutes (unit: min)
Public property | AlarmRegisterMaskBitsMSMMMHMD | Alarm Register Mask Bits (MS/MM/MH/MD)
Public property | AlarmSeconds | Alarm Seconds (unit: s)
Public property | AlarmSwitch12To24Hours1224 | Alarm Switch 12 To 24 Hours (12/24)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Century | Century
Public property | ClearEnableCLR | Clear Enable (CLR)
Public property | ClearMemoryCM | Clear Memory (CM)
Public property | ClockOscillatorEnableCOE | Clock Oscillator Enable (COE)
Public property | CounterCentury | Counter Century
Public property | CounterDate | Counter Date
Public property | CounterDayOfWeek | Counter Day Of Week
Public property | CounterHours | Counter Hours (unit: hour)
Public property | CounterMinutes | Counter Minutes (unit: min)
Public property | CounterMonth | Counter Month
Public property | CounterSeconds | Counter Seconds (unit: s)
Public property | CounterSwitch12To24Hours1224 | Counter Switch 12 To 24 Hours (12/24)
Public property | CounterYear | Counter Year
Public property | DataLogRAMPortAddress | Data Log RAM Port Address
Public property | DataLogRAMPortDataByte | Data Log RAM Port Data Byte
Public property | Date | Date
Public property | DayOfWeek | Day Of Week
Public property | DurationIntervalSelectDISx | Duration Interval Select (DISx)
Public property | ElapseTimeCounterETC | Elapse Time Counter (ETC)
Public property | Event0ElapseTime | Event 0 Elapse Time
Public property | EventCounter | Event Counter
Public property | Hours | Hours (unit: hour)
Public property | LowBatteryFlagLOBAT | Low Battery Flag (LOBAT)
Public property | MemoryClearMEMCLR | Memory Clear (MEM CLR)
Public property | Minutes | Minutes (unit: min)
Public property | MissionEnableME | Mission Enable (ME)
Public property | MissionInProgressMIP | Mission In Progress (MIP)
Public property | Month | Month
Public property | RollOverFlagROF | Roll Over Flag (ROF)
Public property | RollOverRO | Roll Over (RO)
Public property | Seconds | Seconds (unit: s)
Public property | Switch12To24Hours1224 | Switch 12 To 24 Hours (12/24)
Public property | TriggerSelectTRx | Trigger Select (TRx)
Public property | Year | Year
Top
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.AddressPointer Property

IRD

Ds1678AddressPointer Property

Address Pointer

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AddressPointer { get; set; }
Public Property AddressPointer As UShort
    Get
    Set
public:
property unsigned short AddressPointer {
    unsigned short get ();
    void set (unsigned short value);
}
member AddressPointer : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.AlarmDate Property

IRD

Ds1678AlarmDate Property

Alarm Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmDate { get; set; }
Public Property AlarmDate As Byte
    Get
    Set
public:
property unsigned char AlarmDate {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmDate : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.AlarmFlagALMF Property

IRD

Ds1678AlarmFlagALMF Property

Alarm Flag (ALMF)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1678AlarmFlagType AlarmFlagALMF { get; }
Public ReadOnly Property AlarmFlagALMF As Ds1678AlarmFlagType
    Get
public:
property Ds1678AlarmFlagType AlarmFlagALMF {
    Ds1678AlarmFlagType get ();
}
member AlarmFlagALMF : Ds1678AlarmFlagType with get

Property Value

Type: Ds1678AlarmFlagType
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.AlarmHours Property

IRD

Ds1678AlarmHours Property

Alarm Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmHours { get; set; }
Public Property AlarmHours As Byte
    Get
    Set
public:
property unsigned char AlarmHours {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmHours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.AlarmMinutes Property

IRD

Ds1678AlarmMinutes Property

Alarm Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmMinutes { get; set; }
Public Property AlarmMinutes As Byte
    Get
    Set
public:
property unsigned char AlarmMinutes {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmMinutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.AlarmRegisterMaskBitsMSMMMHMD Property

IRD

Ds1678AlarmRegisterMaskBitsMSMMMHMD Property

Alarm Register Mask Bits (MS/MM/MH/MD)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1678AlarmMaskType AlarmRegisterMaskBitsMSMMMHMD { get; set; }
Public Property AlarmRegisterMaskBitsMSMMMHMD As Ds1678AlarmMaskType
    Get
    Set
public:
property Ds1678AlarmMaskType AlarmRegisterMaskBitsMSMMMHMD {
    Ds1678AlarmMaskType get ();
    void set (Ds1678AlarmMaskType value);
}
member AlarmRegisterMaskBitsMSMMMHMD : Ds1678AlarmMaskType with get, set

Property Value

Type: Ds1678AlarmMaskType
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.AlarmSeconds Property

IRD

Ds1678AlarmSeconds Property

Alarm Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmSeconds { get; set; }
Public Property AlarmSeconds As Byte
    Get
    Set
public:
property unsigned char AlarmSeconds {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmSeconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.AlarmSwitch12To24Hours1224 Property

IRD

Ds1678AlarmSwitch12To24Hours1224 Property

Alarm Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1678H1224Type AlarmSwitch12To24Hours1224 { get; set; }
Public Property AlarmSwitch12To24Hours1224 As Ds1678H1224Type
    Get
    Set
public:
property Ds1678H1224Type AlarmSwitch12To24Hours1224 {
    Ds1678H1224Type get ();
    void set (Ds1678H1224Type value);
}
member AlarmSwitch12To24Hours1224 : Ds1678H1224Type with get, set

Property Value

Type: Ds1678H1224Type
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.AutoFlush Property

IRD

Ds1678AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.Century Property

IRD

Ds1678Century Property

Century

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Century { get; set; }
Public Property Century As Byte
    Get
    Set
public:
property unsigned char Century {
    unsigned char get ();
    void set (unsigned char value);
}
member Century : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.ClearEnableCLR Property

IRD

Ds1678ClearEnableCLR Property

Clear Enable (CLR)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1678ClearEnableType ClearEnableCLR { get; set; }
Public Property ClearEnableCLR As Ds1678ClearEnableType
    Get
    Set
public:
property Ds1678ClearEnableType ClearEnableCLR {
    Ds1678ClearEnableType get ();
    void set (Ds1678ClearEnableType value);
}
member ClearEnableCLR : Ds1678ClearEnableType with get, set

Property Value

Type: Ds1678ClearEnableType
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.ClearMemoryCM Property

IRD

Ds1678ClearMemoryCM Property

Clear Memory (CM)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1678ClearMemType ClearMemoryCM { get; set; }
Public Property ClearMemoryCM As Ds1678ClearMemType
    Get
    Set
public:
property Ds1678ClearMemType ClearMemoryCM {
    Ds1678ClearMemType get ();
    void set (Ds1678ClearMemType value);
}
member ClearMemoryCM : Ds1678ClearMemType with get, set

Property Value

Type: Ds1678ClearMemType
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.ClockOscillatorEnableCOE Property

IRD

Ds1678ClockOscillatorEnableCOE Property

Clock Oscillator Enable (COE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1678OscEnableType ClockOscillatorEnableCOE { get; set; }
Public Property ClockOscillatorEnableCOE As Ds1678OscEnableType
    Get
    Set
public:
property Ds1678OscEnableType ClockOscillatorEnableCOE {
    Ds1678OscEnableType get ();
    void set (Ds1678OscEnableType value);
}
member ClockOscillatorEnableCOE : Ds1678OscEnableType with get, set

Property Value

Type: Ds1678OscEnableType
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.CounterCentury Property

IRD

Ds1678CounterCentury Property

Counter Century

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CounterCentury { get; set; }
Public Property CounterCentury As Byte
    Get
    Set
public:
property unsigned char CounterCentury {
    unsigned char get ();
    void set (unsigned char value);
}
member CounterCentury : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.CounterDate Property

IRD

Ds1678CounterDate Property

Counter Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CounterDate { get; set; }
Public Property CounterDate As Byte
    Get
    Set
public:
property unsigned char CounterDate {
    unsigned char get ();
    void set (unsigned char value);
}
member CounterDate : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.CounterDayOfWeek Property

IRD

Ds1678CounterDayOfWeek Property

Counter Day Of Week

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CounterDayOfWeek { get; set; }
Public Property CounterDayOfWeek As Byte
    Get
    Set
public:
property unsigned char CounterDayOfWeek {
    unsigned char get ();
    void set (unsigned char value);
}
member CounterDayOfWeek : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.CounterHours Property

IRD

Ds1678CounterHours Property

Counter Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CounterHours { get; set; }
Public Property CounterHours As Byte
    Get
    Set
public:
property unsigned char CounterHours {
    unsigned char get ();
    void set (unsigned char value);
}
member CounterHours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.CounterMinutes Property

IRD

Ds1678CounterMinutes Property

Counter Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CounterMinutes { get; set; }
Public Property CounterMinutes As Byte
    Get
    Set
public:
property unsigned char CounterMinutes {
    unsigned char get ();
    void set (unsigned char value);
}
member CounterMinutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.CounterMonth Property

IRD

Ds1678CounterMonth Property

Counter Month

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CounterMonth { get; set; }
Public Property CounterMonth As Byte
    Get
    Set
public:
property unsigned char CounterMonth {
    unsigned char get ();
    void set (unsigned char value);
}
member CounterMonth : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.CounterSeconds Property

IRD

Ds1678CounterSeconds Property

Counter Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CounterSeconds { get; set; }
Public Property CounterSeconds As Byte
    Get
    Set
public:
property unsigned char CounterSeconds {
    unsigned char get ();
    void set (unsigned char value);
}
member CounterSeconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.CounterSwitch12To24Hours1224 Property

IRD

Ds1678CounterSwitch12To24Hours1224 Property

Counter Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1678H1224Type CounterSwitch12To24Hours1224 { get; set; }
Public Property CounterSwitch12To24Hours1224 As Ds1678H1224Type
    Get
    Set
public:
property Ds1678H1224Type CounterSwitch12To24Hours1224 {
    Ds1678H1224Type get ();
    void set (Ds1678H1224Type value);
}
member CounterSwitch12To24Hours1224 : Ds1678H1224Type with get, set

Property Value

Type: Ds1678H1224Type
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.CounterYear Property

IRD

Ds1678CounterYear Property

Counter Year

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CounterYear { get; set; }
Public Property CounterYear As Byte
    Get
    Set
public:
property unsigned char CounterYear {
    unsigned char get ();
    void set (unsigned char value);
}
member CounterYear : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.DataLogRAMPortAddress Property

IRD

Ds1678DataLogRAMPortAddress Property

Data Log RAM Port Address

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DataLogRAMPortAddress { get; set; }
Public Property DataLogRAMPortAddress As UShort
    Get
    Set
public:
property unsigned short DataLogRAMPortAddress {
    unsigned short get ();
    void set (unsigned short value);
}
member DataLogRAMPortAddress : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.DataLogRAMPortDataByte Property

IRD

Ds1678DataLogRAMPortDataByte Property

Data Log RAM Port Data Byte

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DataLogRAMPortDataByte { get; }
Public ReadOnly Property DataLogRAMPortDataByte As Byte
    Get
public:
property unsigned char DataLogRAMPortDataByte {
    unsigned char get ();
}
member DataLogRAMPortDataByte : byte with get

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.Date Property

IRD

Ds1678Date Property

Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Date { get; set; }
Public Property Date As Byte
    Get
    Set
public:
property unsigned char Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.DayOfWeek Property

IRD

Ds1678DayOfWeek Property

Day Of Week

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DayOfWeek { get; set; }
Public Property DayOfWeek As Byte
    Get
    Set
public:
property unsigned char DayOfWeek {
    unsigned char get ();
    void set (unsigned char value);
}
member DayOfWeek : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.DurationIntervalSelectDISx Property

IRD

Ds1678DurationIntervalSelectDISx Property

Duration Interval Select (DISx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1678DurationSelectType DurationIntervalSelectDISx { get; set; }
Public Property DurationIntervalSelectDISx As Ds1678DurationSelectType
    Get
    Set
public:
property Ds1678DurationSelectType DurationIntervalSelectDISx {
    Ds1678DurationSelectType get ();
    void set (Ds1678DurationSelectType value);
}
member DurationIntervalSelectDISx : Ds1678DurationSelectType with get, set

Property Value

Type: Ds1678DurationSelectType
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.ElapseTimeCounterETC Property

IRD

Ds1678ElapseTimeCounterETC Property

Elapse Time Counter (ETC)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ElapseTimeCounterETC { get; set; }
Public Property ElapseTimeCounterETC As UShort
    Get
    Set
public:
property unsigned short ElapseTimeCounterETC {
    unsigned short get ();
    void set (unsigned short value);
}
member ElapseTimeCounterETC : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.Event0ElapseTime Property

IRD

Ds1678Event0ElapseTime Property

Event 0 Elapse Time

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort Event0ElapseTime { get; set; }
Public Property Event0ElapseTime As UShort
    Get
    Set
public:
property unsigned short Event0ElapseTime {
    unsigned short get ();
    void set (unsigned short value);
}
member Event0ElapseTime : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.EventCounter Property

IRD

Ds1678EventCounter Property

Event Counter

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint EventCounter { get; set; }
Public Property EventCounter As UInteger
    Get
    Set
public:
property unsigned int EventCounter {
    unsigned int get ();
    void set (unsigned int value);
}
member EventCounter : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.Hours Property

IRD

Ds1678Hours Property

Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Hours { get; set; }
Public Property Hours As Byte
    Get
    Set
public:
property unsigned char Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.LowBatteryFlagLOBAT Property

IRD

Ds1678LowBatteryFlagLOBAT Property

Low Battery Flag (LOBAT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1678LowBatType LowBatteryFlagLOBAT { get; set; }
Public Property LowBatteryFlagLOBAT As Ds1678LowBatType
    Get
    Set
public:
property Ds1678LowBatType LowBatteryFlagLOBAT {
    Ds1678LowBatType get ();
    void set (Ds1678LowBatType value);
}
member LowBatteryFlagLOBAT : Ds1678LowBatType with get, set

Property Value

Type: Ds1678LowBatType
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.MemoryClearMEMCLR Property

IRD

Ds1678MemoryClearMEMCLR Property

Memory Clear (MEM CLR)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1678MemClearType MemoryClearMEMCLR { get; set; }
Public Property MemoryClearMEMCLR As Ds1678MemClearType
    Get
    Set
public:
property Ds1678MemClearType MemoryClearMEMCLR {
    Ds1678MemClearType get ();
    void set (Ds1678MemClearType value);
}
member MemoryClearMEMCLR : Ds1678MemClearType with get, set

Property Value

Type: Ds1678MemClearType
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.Minutes Property

IRD

Ds1678Minutes Property

Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Minutes { get; set; }
Public Property Minutes As Byte
    Get
    Set
public:
property unsigned char Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.MissionEnableME Property

IRD

Ds1678MissionEnableME Property

Mission Enable (ME)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1678MissionEnableType MissionEnableME { get; set; }
Public Property MissionEnableME As Ds1678MissionEnableType
    Get
    Set
public:
property Ds1678MissionEnableType MissionEnableME {
    Ds1678MissionEnableType get ();
    void set (Ds1678MissionEnableType value);
}
member MissionEnableME : Ds1678MissionEnableType with get, set

Property Value

Type: Ds1678MissionEnableType
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.MissionInProgressMIP Property

IRD

Ds1678MissionInProgressMIP Property

Mission In Progress (MIP)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1678MissionProgressType MissionInProgressMIP { get; set; }
Public Property MissionInProgressMIP As Ds1678MissionProgressType
    Get
    Set
public:
property Ds1678MissionProgressType MissionInProgressMIP {
    Ds1678MissionProgressType get ();
    void set (Ds1678MissionProgressType value);
}
member MissionInProgressMIP : Ds1678MissionProgressType with get, set

Property Value

Type: Ds1678MissionProgressType
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.Month Property

IRD

Ds1678Month Property

Month

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Month { get; set; }
Public Property Month As Byte
    Get
    Set
public:
property unsigned char Month {
    unsigned char get ();
    void set (unsigned char value);
}
member Month : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.RollOverFlagROF Property

IRD

Ds1678RollOverFlagROF Property

Roll Over Flag (ROF)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1678RolloverFlagType RollOverFlagROF { get; set; }
Public Property RollOverFlagROF As Ds1678RolloverFlagType
    Get
    Set
public:
property Ds1678RolloverFlagType RollOverFlagROF {
    Ds1678RolloverFlagType get ();
    void set (Ds1678RolloverFlagType value);
}
member RollOverFlagROF : Ds1678RolloverFlagType with get, set

Property Value

Type: Ds1678RolloverFlagType
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.RollOverRO Property

IRD

Ds1678RollOverRO Property

Roll Over (RO)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1678RollOverType RollOverRO { get; set; }
Public Property RollOverRO As Ds1678RollOverType
    Get
    Set
public:
property Ds1678RollOverType RollOverRO {
    Ds1678RollOverType get ();
    void set (Ds1678RollOverType value);
}
member RollOverRO : Ds1678RollOverType with get, set

Property Value

Type: Ds1678RollOverType
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.Seconds Property

IRD

Ds1678Seconds Property

Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Seconds { get; set; }
Public Property Seconds As Byte
    Get
    Set
public:
property unsigned char Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.Switch12To24Hours1224 Property

IRD

Ds1678Switch12To24Hours1224 Property

Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1678H1224Type Switch12To24Hours1224 { get; set; }
Public Property Switch12To24Hours1224 As Ds1678H1224Type
    Get
    Set
public:
property Ds1678H1224Type Switch12To24Hours1224 {
    Ds1678H1224Type get ();
    void set (Ds1678H1224Type value);
}
member Switch12To24Hours1224 : Ds1678H1224Type with get, set

Property Value

Type: Ds1678H1224Type
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.TriggerSelectTRx Property

IRD

Ds1678TriggerSelectTRx Property

Trigger Select (TRx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1678DurationSelectType TriggerSelectTRx { get; set; }
Public Property TriggerSelectTRx As Ds1678DurationSelectType
    Get
    Set
public:
property Ds1678DurationSelectType TriggerSelectTRx {
    Ds1678DurationSelectType get ();
    void set (Ds1678DurationSelectType value);
}
member TriggerSelectTRx : Ds1678DurationSelectType with get, set

Property Value

Type: Ds1678DurationSelectType
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.Year Property

IRD

Ds1678Year Property

Year

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Year { get; set; }
Public Property Year As Byte
    Get
    Set
public:
property unsigned char Year {
    unsigned char get ();
    void set (unsigned char value);
}
member Year : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678 Methods

The Ds1678 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.Flush Method

IRD

Ds1678Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds1678 Class
telos.Ird.Maxim Namespace


Ds1678.AlarmFlagType Enumeration

IRD

Ds1678AlarmFlagType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmFlagType
Public Enumeration AlarmFlagType
public enum class AlarmFlagType
type AlarmFlagType
Members
Member name | Value | Description
CurrentTimeMatchedAlarmTime | 1 | Current Time Matched Alarm Time
AlarmTimeNotMatched | 0 | Alarm Time Not Matched
See Also

Reference

telos.Ird.Maxim Namespace


Ds1678.AlarmMaskType Enumeration

IRD

Ds1678AlarmMaskType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmMaskType
Public Enumeration AlarmMaskType
public enum class AlarmMaskType
type AlarmMaskType
Members
Member name | Value | Description
AlarmOncePerSecond | 15 | Alarm Once Per Second
Reserved | 8 | Reserved
AlarmWhenSecondsMatch | 7 | Alarm When Seconds Match
Reserved__1 | 4 | Reserved
AlarmWhenMinutesMatch | 3 | Alarm When Minutes Match
Reserved__2 | 2 | Reserved
AlarmWhenHoursMatch | 1 | Alarm When Hours Match
AlarmWhenDateMatch | 0 | Alarm When Date Match
See Also

Reference

telos.Ird.Maxim Namespace


Ds1678.ClearEnableType Enumeration

IRD

Ds1678ClearEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ClearEnableType
Public Enumeration ClearEnableType
public enum class ClearEnableType
type ClearEnableType
Members
Member name | Value | Description
EnableToClearMemory | 1 | Enable To Clear Memory
MemoryClearDisable | 0 | Memory Clear Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds1678.ClearMemType Enumeration

IRD

Ds1678ClearMemType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ClearMemType
Public Enumeration ClearMemType
public enum class ClearMemType
type ClearMemType
Members
Member name | Value | Description
ClearingMemory | 1 | Clearing Memory
NoClearingMemory | 0 | No Clearing Memory
See Also

Reference

telos.Ird.Maxim Namespace


Ds1678.DurationSelectType Enumeration

IRD

Ds1678DurationSelectType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DurationSelectType
Public Enumeration DurationSelectType
public enum class DurationSelectType
type DurationSelectType
Members
Member name | Value | Description
CounterIncrementEveryHour | 3 | Counter Increment Every Hour
CounterIncrementEveryMinute | 2 | Counter Increment Every Minute
CounterIncrementEverySecond | 1 | Counter Increment Every Second
AlarmInterruptOutputEnable | 0 | Alarm Interrupt Output Enable
See Also

Reference

telos.Ird.Maxim Namespace


Ds1678.H1224Type Enumeration

IRD

Ds1678H1224Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum H1224Type
Public Enumeration H1224Type
public enum class H1224Type
type H1224Type
Members
Member name | Value | Description
Value_12Hours | 1 | 12 Hours
Value_24Hours | 0 | 24 Hours
See Also

Reference

telos.Ird.Maxim Namespace


Ds1678.LowBatType Enumeration

IRD

Ds1678LowBatType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum LowBatType
Public Enumeration LowBatType
public enum class LowBatType
type LowBatType
Members
Member name | Value | Description
ExhaustedEnergySource | 1 | Exhausted Energy Source
EnergySourceNotExhausted | 0 | Energy Source Not Exhausted
See Also

Reference

telos.Ird.Maxim Namespace


Ds1678.MemClearType Enumeration

IRD

Ds1678MemClearType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum MemClearType
Public Enumeration MemClearType
public enum class MemClearType
type MemClearType
Members
Member name | Value | Description
LogMemoryAndEventCountAreClear | 1 | Log Memory And Event Count Are Clear
EventLogStart | 0 | Event Log Start
See Also

Reference

telos.Ird.Maxim Namespace


Ds1678.MissionEnableType Enumeration

IRD

Ds1678MissionEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum MissionEnableType
Public Enumeration MissionEnableType
public enum class MissionEnableType
type MissionEnableType
Members
Member name | Value | Description
DeviceEnable | 1 | Device Enable
DeviceDisable | 0 | Device Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds1678.MissionProgressType Enumeration

IRD

Ds1678MissionProgressType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum MissionProgressType
Public Enumeration MissionProgressType
public enum class MissionProgressType
type MissionProgressType
Members
Member name | Value | Description
MissionInProgress | 1 | Mission In Progress
NoMissionInProgress | 0 | No Mission In Progress
See Also

Reference

telos.Ird.Maxim Namespace


Ds1678.OscEnableType Enumeration

IRD

Ds1678OscEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum OscEnableType
Public Enumeration OscEnableType
public enum class OscEnableType
type OscEnableType
Members
Member name | Value | Description
ClockOscillatorEnable | 1 | Clock Oscillator Enable
ClockOscillatorDisable | 0 | Clock Oscillator Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds1678.RolloverFlagType Enumeration

IRD

Ds1678RolloverFlagType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum RolloverFlagType
Public Enumeration RolloverFlagType
public enum class RolloverFlagType
type RolloverFlagType
Members
Member name | Value | Description
ROBitSet | 1 | RO Bit Set
ROBitNotSet | 0 | RO Bit Not Set
See Also

Reference

telos.Ird.Maxim Namespace


Ds1678.RollOverType Enumeration

IRD

Ds1678RollOverType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum RollOverType
Public Enumeration RollOverType
public enum class RollOverType
type RollOverType
Members
Member name | Value | Description
EventLogMemoryRollOver | 1 | Event Log Memory Roll Over
NoEventLogMemoryRollOver | 0 | No Event Log Memory Roll Over
See Also

Reference

telos.Ird.Maxim Namespace


Ds1678.TriggerSelectType Enumeration

IRD

Ds1678TriggerSelectType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TriggerSelectType
Public Enumeration TriggerSelectType
public enum class TriggerSelectType
type TriggerSelectType
Members
Member name | Value | Description
TriggerOnRisingAndFallingEdges | 3 | Trigger On Rising And Falling Edges
TriggerOnRisingEdge | 2 | Trigger On Rising Edge
TriggerOnFallingEdge | 1 | Trigger On Falling Edge
IllegalState | 0 | Illegal State
See Also

Reference

telos.Ird.Maxim Namespace


Ds1682 Class

Maxim: DS 1682
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs1682

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds1682
Public Class Ds1682
public ref class Ds1682
type Ds1682 =  class end

The Ds1682 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds1682 | Constructor
Top
Properties
 | Name | Description
Public property | AlarmFlagAF | Alarm Flag (AF)
Public property | AlarmOutputSelectAOS | Alarm Output Select (AOS)
Public property | AlarmPolarityAP | Alarm Polarity (AP)
Public property | AlarmRegister | Alarm Register
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ElapseTimeCounterETC | Elapse Time Counter (ETC)
Public property | EventCounter | Event Counter
Public property | EventCounterMSBECMSB | Event Counter MSB (ECMSB)
Public property | ResetCommand | Reset Command
Public property | ResetEnableRE | Reset Enable (RE)
Public property | WriteDisableCommand | Write Disable Command
Public property | WriteDisableFlagWDF | Write Disable Flag (WDF)
Public property | WriteMemoryDisableCommand | Write Memory Disable Command
Public property | WriteMemoryDisableFlagWMDF | Write Memory Disable Flag (WMDF)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Total Elapse Time Recorder With Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Ds1682 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1682(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds1682(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds1682

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds1682 Class
telos.Ird.Maxim Namespace


Ds1682 Properties

The Ds1682 type exposes the following members.

Properties
 | Name | Description
Public property | AlarmFlagAF | Alarm Flag (AF)
Public property | AlarmOutputSelectAOS | Alarm Output Select (AOS)
Public property | AlarmPolarityAP | Alarm Polarity (AP)
Public property | AlarmRegister | Alarm Register
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ElapseTimeCounterETC | Elapse Time Counter (ETC)
Public property | EventCounter | Event Counter
Public property | EventCounterMSBECMSB | Event Counter MSB (ECMSB)
Public property | ResetCommand | Reset Command
Public property | ResetEnableRE | Reset Enable (RE)
Public property | WriteDisableCommand | Write Disable Command
Public property | WriteDisableFlagWDF | Write Disable Flag (WDF)
Public property | WriteMemoryDisableCommand | Write Memory Disable Command
Public property | WriteMemoryDisableFlagWMDF | Write Memory Disable Flag (WMDF)
Top
See Also

Reference

Ds1682 Class
telos.Ird.Maxim Namespace


Ds1682.AlarmFlagAF Property

IRD

Ds1682AlarmFlagAF Property

Alarm Flag (AF)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1682AlarmFlagType AlarmFlagAF { get; }
Public ReadOnly Property AlarmFlagAF As Ds1682AlarmFlagType
    Get
public:
property Ds1682AlarmFlagType AlarmFlagAF {
    Ds1682AlarmFlagType get ();
}
member AlarmFlagAF : Ds1682AlarmFlagType with get

Property Value

Type: Ds1682AlarmFlagType
See Also

Reference

Ds1682 Class
telos.Ird.Maxim Namespace


Ds1682.AlarmOutputSelectAOS Property

IRD

Ds1682AlarmOutputSelectAOS Property

Alarm Output Select (AOS)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1682AlarmOutputType AlarmOutputSelectAOS { get; set; }
Public Property AlarmOutputSelectAOS As Ds1682AlarmOutputType
    Get
    Set
public:
property Ds1682AlarmOutputType AlarmOutputSelectAOS {
    Ds1682AlarmOutputType get ();
    void set (Ds1682AlarmOutputType value);
}
member AlarmOutputSelectAOS : Ds1682AlarmOutputType with get, set

Property Value

Type: Ds1682AlarmOutputType
See Also

Reference

Ds1682 Class
telos.Ird.Maxim Namespace


Ds1682.AlarmPolarityAP Property

IRD

Ds1682AlarmPolarityAP Property

Alarm Polarity (AP)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1682AlarmPolarityType AlarmPolarityAP { get; set; }
Public Property AlarmPolarityAP As Ds1682AlarmPolarityType
    Get
    Set
public:
property Ds1682AlarmPolarityType AlarmPolarityAP {
    Ds1682AlarmPolarityType get ();
    void set (Ds1682AlarmPolarityType value);
}
member AlarmPolarityAP : Ds1682AlarmPolarityType with get, set

Property Value

Type: Ds1682AlarmPolarityType
See Also

Reference

Ds1682 Class
telos.Ird.Maxim Namespace


Ds1682.AlarmRegister Property

IRD

Ds1682AlarmRegister Property

Alarm Register

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint AlarmRegister { get; set; }
Public Property AlarmRegister As UInteger
    Get
    Set
public:
property unsigned int AlarmRegister {
    unsigned int get ();
    void set (unsigned int value);
}
member AlarmRegister : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

Ds1682 Class
telos.Ird.Maxim Namespace


Ds1682.AutoFlush Property

IRD

Ds1682AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds1682 Class
telos.Ird.Maxim Namespace


Ds1682.ElapseTimeCounterETC Property

IRD

Ds1682ElapseTimeCounterETC Property

Elapse Time Counter (ETC)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint ElapseTimeCounterETC { get; set; }
Public Property ElapseTimeCounterETC As UInteger
    Get
    Set
public:
property unsigned int ElapseTimeCounterETC {
    unsigned int get ();
    void set (unsigned int value);
}
member ElapseTimeCounterETC : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

Ds1682 Class
telos.Ird.Maxim Namespace


Ds1682.EventCounter Property

IRD

Ds1682EventCounter Property

Event Counter

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort EventCounter { get; set; }
Public Property EventCounter As UShort
    Get
    Set
public:
property unsigned short EventCounter {
    unsigned short get ();
    void set (unsigned short value);
}
member EventCounter : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Ds1682 Class
telos.Ird.Maxim Namespace


Ds1682.EventCounterMSBECMSB Property

IRD

Ds1682EventCounterMSBECMSB Property

Event Counter MSB (ECMSB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1682CounterMsbType EventCounterMSBECMSB { get; }
Public ReadOnly Property EventCounterMSBECMSB As Ds1682CounterMsbType
    Get
public:
property Ds1682CounterMsbType EventCounterMSBECMSB {
    Ds1682CounterMsbType get ();
}
member EventCounterMSBECMSB : Ds1682CounterMsbType with get

Property Value

Type: Ds1682CounterMsbType
See Also

Reference

Ds1682 Class
telos.Ird.Maxim Namespace


Ds1682.ResetCommand Property

IRD

Ds1682ResetCommand Property

Reset Command

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ResetCommand { get; set; }
Public Property ResetCommand As Byte
    Get
    Set
public:
property unsigned char ResetCommand {
    unsigned char get ();
    void set (unsigned char value);
}
member ResetCommand : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1682 Class
telos.Ird.Maxim Namespace


Ds1682.ResetEnableRE Property

IRD

Ds1682ResetEnableRE Property

Reset Enable (RE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1682ResetEnableType ResetEnableRE { get; set; }
Public Property ResetEnableRE As Ds1682ResetEnableType
    Get
    Set
public:
property Ds1682ResetEnableType ResetEnableRE {
    Ds1682ResetEnableType get ();
    void set (Ds1682ResetEnableType value);
}
member ResetEnableRE : Ds1682ResetEnableType with get, set

Property Value

Type: Ds1682ResetEnableType
See Also

Reference

Ds1682 Class
telos.Ird.Maxim Namespace


Ds1682.WriteDisableCommand Property

IRD

Ds1682WriteDisableCommand Property

Write Disable Command

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteDisableCommand { get; set; }
Public Property WriteDisableCommand As Byte
    Get
    Set
public:
property unsigned char WriteDisableCommand {
    unsigned char get ();
    void set (unsigned char value);
}
member WriteDisableCommand : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1682 Class
telos.Ird.Maxim Namespace


Ds1682.WriteDisableFlagWDF Property

IRD

Ds1682WriteDisableFlagWDF Property

Write Disable Flag (WDF)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1682WriteDisableType WriteDisableFlagWDF { get; }
Public ReadOnly Property WriteDisableFlagWDF As Ds1682WriteDisableType
    Get
public:
property Ds1682WriteDisableType WriteDisableFlagWDF {
    Ds1682WriteDisableType get ();
}
member WriteDisableFlagWDF : Ds1682WriteDisableType with get

Property Value

Type: Ds1682WriteDisableType
See Also

Reference

Ds1682 Class
telos.Ird.Maxim Namespace


Ds1682.WriteMemoryDisableCommand Property

IRD

Ds1682WriteMemoryDisableCommand Property

Write Memory Disable Command

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WriteMemoryDisableCommand { get; set; }
Public Property WriteMemoryDisableCommand As Byte
    Get
    Set
public:
property unsigned char WriteMemoryDisableCommand {
    unsigned char get ();
    void set (unsigned char value);
}
member WriteMemoryDisableCommand : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1682 Class
telos.Ird.Maxim Namespace


Ds1682.WriteMemoryDisableFlagWMDF Property

IRD

Ds1682WriteMemoryDisableFlagWMDF Property

Write Memory Disable Flag (WMDF)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1682WriteMemoryType WriteMemoryDisableFlagWMDF { get; }
Public ReadOnly Property WriteMemoryDisableFlagWMDF As Ds1682WriteMemoryType
    Get
public:
property Ds1682WriteMemoryType WriteMemoryDisableFlagWMDF {
    Ds1682WriteMemoryType get ();
}
member WriteMemoryDisableFlagWMDF : Ds1682WriteMemoryType with get

Property Value

Type: Ds1682WriteMemoryType
See Also

Reference

Ds1682 Class
telos.Ird.Maxim Namespace


Ds1682 Methods

The Ds1682 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds1682 Class
telos.Ird.Maxim Namespace


Ds1682.Flush Method

IRD

Ds1682Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds1682 Class
telos.Ird.Maxim Namespace


Ds1682.AlarmFlagType Enumeration

IRD

Ds1682AlarmFlagType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmFlagType
Public Enumeration AlarmFlagType
public enum class AlarmFlagType
type AlarmFlagType
Members
Member name | Value | Description
ETCMatchedAlarmTime | 1 | ETC Matched Alarm Time
AlarmTimeNotMatched | 0 | Alarm Time Not Matched
See Also

Reference

telos.Ird.Maxim Namespace


Ds1682.AlarmOutputType Enumeration

IRD

Ds1682AlarmOutputType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmOutputType
Public Enumeration AlarmOutputType
public enum class AlarmOutputType
type AlarmOutputType
Members
Member name | Value | Description
NoAlarmOutput | 1 | No Alarm Output
AlarmOutputOnEvent | 0 | Alarm Output On Event
See Also

Reference

telos.Ird.Maxim Namespace


Ds1682.AlarmPolarityType Enumeration

IRD

Ds1682AlarmPolarityType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmPolarityType
Public Enumeration AlarmPolarityType
public enum class AlarmPolarityType
type AlarmPolarityType
Members
Member name | Value | Description
AlarmOutputLowDuringCount | 1 | Alarm Output Low During Count
AlarmOutputHighDuringCount | 0 | Alarm Output High During Count
See Also

Reference

telos.Ird.Maxim Namespace


Ds1682.CounterMsbType Enumeration

IRD

Ds1682CounterMsbType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CounterMsbType
Public Enumeration CounterMsbType
public enum class CounterMsbType
type CounterMsbType
Members
Member name | Value | Description
EventCounterMSBSet | 1 | Event Counter MSB Set
EventCounterMSBNotSet | 0 | Event Counter MSB Not Set
See Also

Reference

telos.Ird.Maxim Namespace


Ds1682.ResetEnableType Enumeration

IRD

Ds1682ResetEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ResetEnableType
Public Enumeration ResetEnableType
public enum class ResetEnableType
type ResetEnableType
Members
Member name | Value | Description
ResetETCEEPROMAndEventCounter | 1 | Reset ETC, EEPROM And Event Counter
NoReset | 0 | No Reset
See Also

Reference

telos.Ird.Maxim Namespace


Ds1682.WriteDisableType Enumeration

IRD

Ds1682WriteDisableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum WriteDisableType
Public Enumeration WriteDisableType
public enum class WriteDisableType
type WriteDisableType
Members
Member name | Value | Description
WriteDisable | 1 | Write Disable
WriteEnable | 0 | Write Enable
See Also

Reference

telos.Ird.Maxim Namespace


Ds1682.WriteMemoryType Enumeration

IRD

Ds1682WriteMemoryType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum WriteMemoryType
Public Enumeration WriteMemoryType
public enum class WriteMemoryType
type WriteMemoryType
Members
Member name | Value | Description
WriteMemoryDisable | 1 | Write Memory Disable
WriteMemoryEnable | 0 | Write Memory Enable
See Also

Reference

telos.Ird.Maxim Namespace


Ds1721 Class

Maxim: DS 1721
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs1721

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds1721
Public Class Ds1721
public ref class Ds1721
type Ds1721 =  class end

The Ds1721 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds1721 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Config1SHOT | Config (1SHOT)
Public property | ConfigDONE | Config (DONE)
Public property | ConfigPOL | Config (POL)
Public property | ConfigResolution | Config (Resolution) (unit: bit)
Public property | Temperature | Temperature (unit: °C)
Public property | TH | T_H (unit: °C)
Public property | TL | T_L (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartConvertT | Start Convert T
Public method | StopConvertT | Stop Convert T
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Digital Thermometer And Thermostat
See Also

Reference

telos.Ird.Maxim Namespace


Ds1721 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1721(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds1721(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds1721

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds1721 Class
telos.Ird.Maxim Namespace


Ds1721 Properties

The Ds1721 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Config1SHOT | Config (1SHOT)
Public property | ConfigDONE | Config (DONE)
Public property | ConfigPOL | Config (POL)
Public property | ConfigResolution | Config (Resolution) (unit: bit)
Public property | Temperature | Temperature (unit: °C)
Public property | TH | T_H (unit: °C)
Public property | TL | T_L (unit: °C)
Top
See Also

Reference

Ds1721 Class
telos.Ird.Maxim Namespace


Ds1721.AutoFlush Property

IRD

Ds1721AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds1721 Class
telos.Ird.Maxim Namespace


Ds1721.Config1SHOT Property

IRD

Ds1721Config1SHOT Property

Config (1SHOT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1721Config1shotType Config1SHOT { get; set; }
Public Property Config1SHOT As Ds1721Config1shotType
    Get
    Set
public:
property Ds1721Config1shotType Config1SHOT {
    Ds1721Config1shotType get ();
    void set (Ds1721Config1shotType value);
}
member Config1SHOT : Ds1721Config1shotType with get, set

Property Value

Type: Ds1721Config1shotType
See Also

Reference

Ds1721 Class
telos.Ird.Maxim Namespace


Ds1721.ConfigDONE Property

IRD

Ds1721ConfigDONE Property

Config (DONE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1721ConfigDoneType ConfigDONE { get; }
Public ReadOnly Property ConfigDONE As Ds1721ConfigDoneType
    Get
public:
property Ds1721ConfigDoneType ConfigDONE {
    Ds1721ConfigDoneType get ();
}
member ConfigDONE : Ds1721ConfigDoneType with get

Property Value

Type: Ds1721ConfigDoneType
See Also

Reference

Ds1721 Class
telos.Ird.Maxim Namespace


Ds1721.ConfigPOL Property

IRD

Ds1721ConfigPOL Property

Config (POL)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1721ConfigPolType ConfigPOL { get; set; }
Public Property ConfigPOL As Ds1721ConfigPolType
    Get
    Set
public:
property Ds1721ConfigPolType ConfigPOL {
    Ds1721ConfigPolType get ();
    void set (Ds1721ConfigPolType value);
}
member ConfigPOL : Ds1721ConfigPolType with get, set

Property Value

Type: Ds1721ConfigPolType
See Also

Reference

Ds1721 Class
telos.Ird.Maxim Namespace


Ds1721.ConfigResolution Property

IRD

Ds1721ConfigResolution Property

Config (Resolution) (unit: bit)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1721ConfigResType ConfigResolution { get; set; }
Public Property ConfigResolution As Ds1721ConfigResType
    Get
    Set
public:
property Ds1721ConfigResType ConfigResolution {
    Ds1721ConfigResType get ();
    void set (Ds1721ConfigResType value);
}
member ConfigResolution : Ds1721ConfigResType with get, set

Property Value

Type: Ds1721ConfigResType
See Also

Reference

Ds1721 Class
telos.Ird.Maxim Namespace


Ds1721.Temperature Property

IRD

Ds1721Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Ds1721 Class
telos.Ird.Maxim Namespace


Ds1721.TH Property

IRD

Ds1721TH Property

T_H (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TH { get; set; }
Public Property TH As Double
    Get
    Set
public:
property double TH {
    double get ();
    void set (double value);
}
member TH : float with get, set

Property Value

Type: Double
See Also

Reference

Ds1721 Class
telos.Ird.Maxim Namespace


Ds1721.TL Property

IRD

Ds1721TL Property

T_L (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TL { get; set; }
Public Property TL As Double
    Get
    Set
public:
property double TL {
    double get ();
    void set (double value);
}
member TL : float with get, set

Property Value

Type: Double
See Also

Reference

Ds1721 Class
telos.Ird.Maxim Namespace


Ds1721 Methods

The Ds1721 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartConvertT | Start Convert T
Public method | StopConvertT | Stop Convert T
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds1721 Class
telos.Ird.Maxim Namespace


Ds1721.Flush Method

IRD

Ds1721Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds1721 Class
telos.Ird.Maxim Namespace


Ds1721.StartConvertT Method

IRD

Ds1721StartConvertT Method

Start Convert T

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void StartConvertT()
Public Sub StartConvertT
public:
void StartConvertT()
member StartConvertT : unit -> unit
See Also

Reference

Ds1721 Class
telos.Ird.Maxim Namespace


Ds1721.StopConvertT Method

IRD

Ds1721StopConvertT Method

Stop Convert T

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void StopConvertT()
Public Sub StopConvertT
public:
void StopConvertT()
member StopConvertT : unit -> unit
See Also

Reference

Ds1721 Class
telos.Ird.Maxim Namespace


Ds1721.Config1shotType Enumeration

IRD

Ds1721Config1shotType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Config1shotType
Public Enumeration Config1shotType
public enum class Config1shotType
type Config1shotType
Members
Member name | Value | Description
ContinuousConversionMode | 0 | Continuous Conversion Mode
OneShotMode | 1 | One-Shot Mode
See Also

Reference

telos.Ird.Maxim Namespace


Ds1721.ConfigDoneType Enumeration

IRD

Ds1721ConfigDoneType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigDoneType
Public Enumeration ConfigDoneType
public enum class ConfigDoneType
type ConfigDoneType
Members
Member name | Value | Description
TempConversionInProgress | 0 | Temp Conversion: In Progress
TempConversionComplete | 1 | Temp Conversion: Complete
See Also

Reference

telos.Ird.Maxim Namespace


Ds1721.ConfigPolType Enumeration

IRD

Ds1721ConfigPolType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigPolType
Public Enumeration ConfigPolType
public enum class ConfigPolType
type ConfigPolType
Members
Member name | Value | Description
TCOMPolarityActiveHigh | 0 | T_COM Polarity: Active High
TCOMPolarityActiveLow | 1 | T_COM Polarity: Active Low
See Also

Reference

telos.Ird.Maxim Namespace


Ds1721.ConfigResType Enumeration

IRD

Ds1721ConfigResType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigResType
Public Enumeration ConfigResType
public enum class ConfigResType
type ConfigResType
Members
Member name | Value | Description
Value_9 | 0 | 9
Value_10 | 1 | 10
Value_11 | 2 | 11
Value_12 | 3 | 12
See Also

Reference

telos.Ird.Maxim Namespace


Ds1775 Class

Maxim: DS 1775
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs1775

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds1775
Public Class Ds1775
public ref class Ds1775
type Ds1775 =  class end

The Ds1775 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds1775 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FaultTolerance | Fault Tolerance
Public property | Polarity | Polarity
Public property | Shutdown | Shutdown
Public property | Temperature | Temperature (unit: °C)
Public property | ThermometerResolution | Thermometer Resolution (unit: bit)
Public property | ThermostatMode | Thermostat Mode
Public property | THYST | T_HYST (unit: °C)
Public property | TOS | T_OS (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Digital Thermometer And Thermostat
See Also

Reference

telos.Ird.Maxim Namespace


Ds1775 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1775(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds1775(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds1775

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds1775 Class
telos.Ird.Maxim Namespace


Ds1775 Properties

The Ds1775 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FaultTolerance | Fault Tolerance
Public property | Polarity | Polarity
Public property | Shutdown | Shutdown
Public property | Temperature | Temperature (unit: °C)
Public property | ThermometerResolution | Thermometer Resolution (unit: bit)
Public property | ThermostatMode | Thermostat Mode
Public property | THYST | T_HYST (unit: °C)
Public property | TOS | T_OS (unit: °C)
Top
See Also

Reference

Ds1775 Class
telos.Ird.Maxim Namespace


Ds1775.AutoFlush Property

IRD

Ds1775AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds1775 Class
telos.Ird.Maxim Namespace


Ds1775.FaultTolerance Property

IRD

Ds1775FaultTolerance Property

Fault Tolerance

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1775ConfigFaultType FaultTolerance { get; set; }
Public Property FaultTolerance As Ds1775ConfigFaultType
    Get
    Set
public:
property Ds1775ConfigFaultType FaultTolerance {
    Ds1775ConfigFaultType get ();
    void set (Ds1775ConfigFaultType value);
}
member FaultTolerance : Ds1775ConfigFaultType with get, set

Property Value

Type: Ds1775ConfigFaultType
See Also

Reference

Ds1775 Class
telos.Ird.Maxim Namespace


Ds1775.Polarity Property

IRD

Ds1775Polarity Property

Polarity

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1775ConfigPolType Polarity { get; set; }
Public Property Polarity As Ds1775ConfigPolType
    Get
    Set
public:
property Ds1775ConfigPolType Polarity {
    Ds1775ConfigPolType get ();
    void set (Ds1775ConfigPolType value);
}
member Polarity : Ds1775ConfigPolType with get, set

Property Value

Type: Ds1775ConfigPolType
See Also

Reference

Ds1775 Class
telos.Ird.Maxim Namespace


Ds1775.Shutdown Property

IRD

Ds1775Shutdown Property

Shutdown

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1775ConfigShutdownType Shutdown { get; set; }
Public Property Shutdown As Ds1775ConfigShutdownType
    Get
    Set
public:
property Ds1775ConfigShutdownType Shutdown {
    Ds1775ConfigShutdownType get ();
    void set (Ds1775ConfigShutdownType value);
}
member Shutdown : Ds1775ConfigShutdownType with get, set

Property Value

Type: Ds1775ConfigShutdownType
See Also

Reference

Ds1775 Class
telos.Ird.Maxim Namespace


Ds1775.Temperature Property

IRD

Ds1775Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Ds1775 Class
telos.Ird.Maxim Namespace


Ds1775.ThermometerResolution Property

IRD

Ds1775ThermometerResolution Property

Thermometer Resolution (unit: bit)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1775ConfigConversionType ThermometerResolution { get; set; }
Public Property ThermometerResolution As Ds1775ConfigConversionType
    Get
    Set
public:
property Ds1775ConfigConversionType ThermometerResolution {
    Ds1775ConfigConversionType get ();
    void set (Ds1775ConfigConversionType value);
}
member ThermometerResolution : Ds1775ConfigConversionType with get, set

Property Value

Type: Ds1775ConfigConversionType
See Also

Reference

Ds1775 Class
telos.Ird.Maxim Namespace


Ds1775.ThermostatMode Property

IRD

Ds1775ThermostatMode Property

Thermostat Mode

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1775ConfigOpModeType ThermostatMode { get; set; }
Public Property ThermostatMode As Ds1775ConfigOpModeType
    Get
    Set
public:
property Ds1775ConfigOpModeType ThermostatMode {
    Ds1775ConfigOpModeType get ();
    void set (Ds1775ConfigOpModeType value);
}
member ThermostatMode : Ds1775ConfigOpModeType with get, set

Property Value

Type: Ds1775ConfigOpModeType
See Also

Reference

Ds1775 Class
telos.Ird.Maxim Namespace


Ds1775.THYST Property

IRD

Ds1775THYST Property

T_HYST (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double THYST { get; set; }
Public Property THYST As Double
    Get
    Set
public:
property double THYST {
    double get ();
    void set (double value);
}
member THYST : float with get, set

Property Value

Type: Double
See Also

Reference

Ds1775 Class
telos.Ird.Maxim Namespace


Ds1775.TOS Property

IRD

Ds1775TOS Property

T_OS (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TOS { get; set; }
Public Property TOS As Double
    Get
    Set
public:
property double TOS {
    double get ();
    void set (double value);
}
member TOS : float with get, set

Property Value

Type: Double
See Also

Reference

Ds1775 Class
telos.Ird.Maxim Namespace


Ds1775 Methods

The Ds1775 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds1775 Class
telos.Ird.Maxim Namespace


Ds1775.Flush Method

IRD

Ds1775Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds1775 Class
telos.Ird.Maxim Namespace


Ds1775.ConfigConversionType Enumeration

IRD

Ds1775ConfigConversionType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigConversionType
Public Enumeration ConfigConversionType
public enum class ConfigConversionType
type ConfigConversionType
Members
Member name | Value | Description
Value_9 | 0 | 9
Value_10 | 1 | 10
Value_11 | 2 | 11
Value_12 | 3 | 12
See Also

Reference

telos.Ird.Maxim Namespace


Ds1775.ConfigFaultType Enumeration

IRD

Ds1775ConfigFaultType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigFaultType
Public Enumeration ConfigFaultType
public enum class ConfigFaultType
type ConfigFaultType
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_2 | 1 | 2
Value_4 | 2 | 4
Value_6 | 3 | 6
See Also

Reference

telos.Ird.Maxim Namespace


Ds1775.ConfigOpModeType Enumeration

IRD

Ds1775ConfigOpModeType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigOpModeType
Public Enumeration ConfigOpModeType
public enum class ConfigOpModeType
type ConfigOpModeType
Members
Member name | Value | Description
ComparatorMode | 0 | Comparator Mode
InterruptMode | 1 | Interrupt Mode
See Also

Reference

telos.Ird.Maxim Namespace


Ds1775.ConfigPolType Enumeration

IRD

Ds1775ConfigPolType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigPolType
Public Enumeration ConfigPolType
public enum class ConfigPolType
type ConfigPolType
Members
Member name | Value | Description
OSActiveLow | 0 | O.S.: Active Low
OSActiveHigh | 1 | O.S.: Active High
See Also

Reference

telos.Ird.Maxim Namespace


Ds1775.ConfigShutdownType Enumeration

IRD

Ds1775ConfigShutdownType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigShutdownType
Public Enumeration ConfigShutdownType
public enum class ConfigShutdownType
type ConfigShutdownType
Members
Member name | Value | Description
ContinuousConversionMode | 0 | Continuous Conversion Mode
ShutdownMode | 1 | Shutdown Mode
See Also

Reference

telos.Ird.Maxim Namespace


Ds1841 Class

Maxim: DS 1841
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs1841

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds1841
Public Class Ds1841
public ref class Ds1841
type Ds1841 =  class end

The Ds1841 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds1841 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Control0SEE | Control 0: SEE
Public property | Control1AdderMode | Control 1: Adder Mode
Public property | Control1UpdateMode | Control 1: Update Mode
Public property | Control2LUTARMode | Control 2: LUTAR Mode
Public property | Control2WipeAccessControl | Control 2: Wipe Access Control
Public property | InitialValue | Initial Value
Public property | LUTAddress | LUT Address
Public property | LUTValue | LUT Value
Public property | SupplyVoltage | Supply Voltage
Public property | Temperature | Temperature
Public property | TemperatureLookup00 | Temperature Lookup 00
Public property | TemperatureLookup01 | Temperature Lookup 01
Public property | TemperatureLookup02 | Temperature Lookup 02
Public property | TemperatureLookup03 | Temperature Lookup 03
Public property | TemperatureLookup04 | Temperature Lookup 04
Public property | TemperatureLookup05 | Temperature Lookup 05
Public property | TemperatureLookup06 | Temperature Lookup 06
Public property | TemperatureLookup07 | Temperature Lookup 07
Public property | TemperatureLookup08 | Temperature Lookup 08
Public property | TemperatureLookup09 | Temperature Lookup 09
Public property | TemperatureLookup10 | Temperature Lookup 10
Public property | TemperatureLookup11 | Temperature Lookup 11
Public property | TemperatureLookup12 | Temperature Lookup 12
Public property | TemperatureLookup13 | Temperature Lookup 13
Public property | TemperatureLookup14 | Temperature Lookup 14
Public property | TemperatureLookup15 | Temperature Lookup 15
Public property | TemperatureLookup16 | Temperature Lookup 16
Public property | TemperatureLookup17 | Temperature Lookup 17
Public property | TemperatureLookup18 | Temperature Lookup 18
Public property | TemperatureLookup19 | Temperature Lookup 19
Public property | TemperatureLookup20 | Temperature Lookup 20
Public property | TemperatureLookup21 | Temperature Lookup 21
Public property | TemperatureLookup22 | Temperature Lookup 22
Public property | TemperatureLookup23 | Temperature Lookup 23
Public property | TemperatureLookup24 | Temperature Lookup 24
Public property | TemperatureLookup25 | Temperature Lookup 25
Public property | TemperatureLookup26 | Temperature Lookup 26
Public property | TemperatureLookup27 | Temperature Lookup 27
Public property | TemperatureLookup28 | Temperature Lookup 28
Public property | TemperatureLookup29 | Temperature Lookup 29
Public property | TemperatureLookup30 | Temperature Lookup 30
Public property | TemperatureLookup31 | Temperature Lookup 31
Public property | TemperatureLookup32 | Temperature Lookup 32
Public property | TemperatureLookup33 | Temperature Lookup 33
Public property | TemperatureLookup34 | Temperature Lookup 34
Public property | TemperatureLookup35 | Temperature Lookup 35
Public property | TemperatureLookup36 | Temperature Lookup 36
Public property | TemperatureLookup37 | Temperature Lookup 37
Public property | TemperatureLookup38 | Temperature Lookup 38
Public property | TemperatureLookup39 | Temperature Lookup 39
Public property | TemperatureLookup40 | Temperature Lookup 40
Public property | TemperatureLookup41 | Temperature Lookup 41
Public property | TemperatureLookup42 | Temperature Lookup 42
Public property | TemperatureLookup43 | Temperature Lookup 43
Public property | TemperatureLookup44 | Temperature Lookup 44
Public property | TemperatureLookup45 | Temperature Lookup 45
Public property | TemperatureLookup46 | Temperature Lookup 46
Public property | TemperatureLookup47 | Temperature Lookup 47
Public property | TemperatureLookup48 | Temperature Lookup 48
Public property | TemperatureLookup49 | Temperature Lookup 49
Public property | TemperatureLookup50 | Temperature Lookup 50
Public property | TemperatureLookup51 | Temperature Lookup 51
Public property | TemperatureLookup52 | Temperature Lookup 52
Public property | TemperatureLookup53 | Temperature Lookup 53
Public property | TemperatureLookup54 | Temperature Lookup 54
Public property | TemperatureLookup55 | Temperature Lookup 55
Public property | TemperatureLookup56 | Temperature Lookup 56
Public property | TemperatureLookup57 | Temperature Lookup 57
Public property | TemperatureLookup58 | Temperature Lookup 58
Public property | TemperatureLookup59 | Temperature Lookup 59
Public property | TemperatureLookup60 | Temperature Lookup 60
Public property | TemperatureLookup61 | Temperature Lookup 61
Public property | TemperatureLookup62 | Temperature Lookup 62
Public property | TemperatureLookup63 | Temperature Lookup 63
Public property | TemperatureLookup64 | Temperature Lookup 64
Public property | TemperatureLookup65 | Temperature Lookup 65
Public property | TemperatureLookup66 | Temperature Lookup 66
Public property | TemperatureLookup67 | Temperature Lookup 67
Public property | TemperatureLookup68 | Temperature Lookup 68
Public property | TemperatureLookup69 | Temperature Lookup 69
Public property | TemperatureLookup70 | Temperature Lookup 70
Public property | TemperatureLookup71 | Temperature Lookup 71
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Temperature-Controlled Logarithmic Resistor
See Also

Reference

telos.Ird.Maxim Namespace


Ds1841 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1841(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds1841(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds1841

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841 Properties

The Ds1841 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Control0SEE | Control 0: SEE
Public property | Control1AdderMode | Control 1: Adder Mode
Public property | Control1UpdateMode | Control 1: Update Mode
Public property | Control2LUTARMode | Control 2: LUTAR Mode
Public property | Control2WipeAccessControl | Control 2: Wipe Access Control
Public property | InitialValue | Initial Value
Public property | LUTAddress | LUT Address
Public property | LUTValue | LUT Value
Public property | SupplyVoltage | Supply Voltage
Public property | Temperature | Temperature
Public property | TemperatureLookup00 | Temperature Lookup 00
Public property | TemperatureLookup01 | Temperature Lookup 01
Public property | TemperatureLookup02 | Temperature Lookup 02
Public property | TemperatureLookup03 | Temperature Lookup 03
Public property | TemperatureLookup04 | Temperature Lookup 04
Public property | TemperatureLookup05 | Temperature Lookup 05
Public property | TemperatureLookup06 | Temperature Lookup 06
Public property | TemperatureLookup07 | Temperature Lookup 07
Public property | TemperatureLookup08 | Temperature Lookup 08
Public property | TemperatureLookup09 | Temperature Lookup 09
Public property | TemperatureLookup10 | Temperature Lookup 10
Public property | TemperatureLookup11 | Temperature Lookup 11
Public property | TemperatureLookup12 | Temperature Lookup 12
Public property | TemperatureLookup13 | Temperature Lookup 13
Public property | TemperatureLookup14 | Temperature Lookup 14
Public property | TemperatureLookup15 | Temperature Lookup 15
Public property | TemperatureLookup16 | Temperature Lookup 16
Public property | TemperatureLookup17 | Temperature Lookup 17
Public property | TemperatureLookup18 | Temperature Lookup 18
Public property | TemperatureLookup19 | Temperature Lookup 19
Public property | TemperatureLookup20 | Temperature Lookup 20
Public property | TemperatureLookup21 | Temperature Lookup 21
Public property | TemperatureLookup22 | Temperature Lookup 22
Public property | TemperatureLookup23 | Temperature Lookup 23
Public property | TemperatureLookup24 | Temperature Lookup 24
Public property | TemperatureLookup25 | Temperature Lookup 25
Public property | TemperatureLookup26 | Temperature Lookup 26
Public property | TemperatureLookup27 | Temperature Lookup 27
Public property | TemperatureLookup28 | Temperature Lookup 28
Public property | TemperatureLookup29 | Temperature Lookup 29
Public property | TemperatureLookup30 | Temperature Lookup 30
Public property | TemperatureLookup31 | Temperature Lookup 31
Public property | TemperatureLookup32 | Temperature Lookup 32
Public property | TemperatureLookup33 | Temperature Lookup 33
Public property | TemperatureLookup34 | Temperature Lookup 34
Public property | TemperatureLookup35 | Temperature Lookup 35
Public property | TemperatureLookup36 | Temperature Lookup 36
Public property | TemperatureLookup37 | Temperature Lookup 37
Public property | TemperatureLookup38 | Temperature Lookup 38
Public property | TemperatureLookup39 | Temperature Lookup 39
Public property | TemperatureLookup40 | Temperature Lookup 40
Public property | TemperatureLookup41 | Temperature Lookup 41
Public property | TemperatureLookup42 | Temperature Lookup 42
Public property | TemperatureLookup43 | Temperature Lookup 43
Public property | TemperatureLookup44 | Temperature Lookup 44
Public property | TemperatureLookup45 | Temperature Lookup 45
Public property | TemperatureLookup46 | Temperature Lookup 46
Public property | TemperatureLookup47 | Temperature Lookup 47
Public property | TemperatureLookup48 | Temperature Lookup 48
Public property | TemperatureLookup49 | Temperature Lookup 49
Public property | TemperatureLookup50 | Temperature Lookup 50
Public property | TemperatureLookup51 | Temperature Lookup 51
Public property | TemperatureLookup52 | Temperature Lookup 52
Public property | TemperatureLookup53 | Temperature Lookup 53
Public property | TemperatureLookup54 | Temperature Lookup 54
Public property | TemperatureLookup55 | Temperature Lookup 55
Public property | TemperatureLookup56 | Temperature Lookup 56
Public property | TemperatureLookup57 | Temperature Lookup 57
Public property | TemperatureLookup58 | Temperature Lookup 58
Public property | TemperatureLookup59 | Temperature Lookup 59
Public property | TemperatureLookup60 | Temperature Lookup 60
Public property | TemperatureLookup61 | Temperature Lookup 61
Public property | TemperatureLookup62 | Temperature Lookup 62
Public property | TemperatureLookup63 | Temperature Lookup 63
Public property | TemperatureLookup64 | Temperature Lookup 64
Public property | TemperatureLookup65 | Temperature Lookup 65
Public property | TemperatureLookup66 | Temperature Lookup 66
Public property | TemperatureLookup67 | Temperature Lookup 67
Public property | TemperatureLookup68 | Temperature Lookup 68
Public property | TemperatureLookup69 | Temperature Lookup 69
Public property | TemperatureLookup70 | Temperature Lookup 70
Public property | TemperatureLookup71 | Temperature Lookup 71
Top
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.AutoFlush Property

IRD

Ds1841AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.Control0SEE Property

IRD

Ds1841Control0SEE Property

Control 0: SEE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1841TypeControl0See Control0SEE { get; set; }
Public Property Control0SEE As Ds1841TypeControl0See
    Get
    Set
public:
property Ds1841TypeControl0See Control0SEE {
    Ds1841TypeControl0See get ();
    void set (Ds1841TypeControl0See value);
}
member Control0SEE : Ds1841TypeControl0See with get, set

Property Value

Type: Ds1841TypeControl0See
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.Control1AdderMode Property

IRD

Ds1841Control1AdderMode Property

Control 1: Adder Mode

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1841TypeControl1Adder Control1AdderMode { get; set; }
Public Property Control1AdderMode As Ds1841TypeControl1Adder
    Get
    Set
public:
property Ds1841TypeControl1Adder Control1AdderMode {
    Ds1841TypeControl1Adder get ();
    void set (Ds1841TypeControl1Adder value);
}
member Control1AdderMode : Ds1841TypeControl1Adder with get, set

Property Value

Type: Ds1841TypeControl1Adder
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.Control1UpdateMode Property

IRD

Ds1841Control1UpdateMode Property

Control 1: Update Mode

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1841TypeControl1Update Control1UpdateMode { get; set; }
Public Property Control1UpdateMode As Ds1841TypeControl1Update
    Get
    Set
public:
property Ds1841TypeControl1Update Control1UpdateMode {
    Ds1841TypeControl1Update get ();
    void set (Ds1841TypeControl1Update value);
}
member Control1UpdateMode : Ds1841TypeControl1Update with get, set

Property Value

Type: Ds1841TypeControl1Update
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.Control2LUTARMode Property

IRD

Ds1841Control2LUTARMode Property

Control 2: LUTAR Mode

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1841TypeControl2Lutar Control2LUTARMode { get; set; }
Public Property Control2LUTARMode As Ds1841TypeControl2Lutar
    Get
    Set
public:
property Ds1841TypeControl2Lutar Control2LUTARMode {
    Ds1841TypeControl2Lutar get ();
    void set (Ds1841TypeControl2Lutar value);
}
member Control2LUTARMode : Ds1841TypeControl2Lutar with get, set

Property Value

Type: Ds1841TypeControl2Lutar
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.Control2WipeAccessControl Property

IRD

Ds1841Control2WipeAccessControl Property

Control 2: Wipe Access Control

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds1841TypeControl2Wipe Control2WipeAccessControl { get; set; }
Public Property Control2WipeAccessControl As Ds1841TypeControl2Wipe
    Get
    Set
public:
property Ds1841TypeControl2Wipe Control2WipeAccessControl {
    Ds1841TypeControl2Wipe get ();
    void set (Ds1841TypeControl2Wipe value);
}
member Control2WipeAccessControl : Ds1841TypeControl2Wipe with get, set

Property Value

Type: Ds1841TypeControl2Wipe
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.InitialValue Property

IRD

Ds1841InitialValue Property

Initial Value

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InitialValue { get; set; }
Public Property InitialValue As Byte
    Get
    Set
public:
property unsigned char InitialValue {
    unsigned char get ();
    void set (unsigned char value);
}
member InitialValue : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.LUTAddress Property

IRD

Ds1841LUTAddress Property

LUT Address

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LUTAddress { get; set; }
Public Property LUTAddress As Byte
    Get
    Set
public:
property unsigned char LUTAddress {
    unsigned char get ();
    void set (unsigned char value);
}
member LUTAddress : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.LUTValue Property

IRD

Ds1841LUTValue Property

LUT Value

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LUTValue { get; set; }
Public Property LUTValue As Byte
    Get
    Set
public:
property unsigned char LUTValue {
    unsigned char get ();
    void set (unsigned char value);
}
member LUTValue : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.SupplyVoltage Property

IRD

Ds1841SupplyVoltage Property

Supply Voltage

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SupplyVoltage { get; set; }
Public Property SupplyVoltage As Byte
    Get
    Set
public:
property unsigned char SupplyVoltage {
    unsigned char get ();
    void set (unsigned char value);
}
member SupplyVoltage : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.Temperature Property

IRD

Ds1841Temperature Property

Temperature

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Temperature { get; }
Public ReadOnly Property Temperature As SByte
    Get
public:
property signed char Temperature {
    signed char get ();
}
member Temperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup00 Property

IRD

Ds1841TemperatureLookup00 Property

Temperature Lookup 00

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup00 { get; set; }
Public Property TemperatureLookup00 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup00 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup00 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup01 Property

IRD

Ds1841TemperatureLookup01 Property

Temperature Lookup 01

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup01 { get; set; }
Public Property TemperatureLookup01 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup01 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup01 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup02 Property

IRD

Ds1841TemperatureLookup02 Property

Temperature Lookup 02

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup02 { get; set; }
Public Property TemperatureLookup02 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup02 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup02 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup03 Property

IRD

Ds1841TemperatureLookup03 Property

Temperature Lookup 03

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup03 { get; set; }
Public Property TemperatureLookup03 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup03 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup03 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup04 Property

IRD

Ds1841TemperatureLookup04 Property

Temperature Lookup 04

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup04 { get; set; }
Public Property TemperatureLookup04 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup04 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup04 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup05 Property

IRD

Ds1841TemperatureLookup05 Property

Temperature Lookup 05

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup05 { get; set; }
Public Property TemperatureLookup05 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup05 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup05 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup06 Property

IRD

Ds1841TemperatureLookup06 Property

Temperature Lookup 06

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup06 { get; set; }
Public Property TemperatureLookup06 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup06 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup06 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup07 Property

IRD

Ds1841TemperatureLookup07 Property

Temperature Lookup 07

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup07 { get; set; }
Public Property TemperatureLookup07 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup07 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup07 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup08 Property

IRD

Ds1841TemperatureLookup08 Property

Temperature Lookup 08

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup08 { get; set; }
Public Property TemperatureLookup08 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup08 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup08 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup09 Property

IRD

Ds1841TemperatureLookup09 Property

Temperature Lookup 09

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup09 { get; set; }
Public Property TemperatureLookup09 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup09 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup09 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup10 Property

IRD

Ds1841TemperatureLookup10 Property

Temperature Lookup 10

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup10 { get; set; }
Public Property TemperatureLookup10 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup10 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup10 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup11 Property

IRD

Ds1841TemperatureLookup11 Property

Temperature Lookup 11

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup11 { get; set; }
Public Property TemperatureLookup11 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup11 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup11 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup12 Property

IRD

Ds1841TemperatureLookup12 Property

Temperature Lookup 12

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup12 { get; set; }
Public Property TemperatureLookup12 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup12 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup12 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup13 Property

IRD

Ds1841TemperatureLookup13 Property

Temperature Lookup 13

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup13 { get; set; }
Public Property TemperatureLookup13 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup13 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup13 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup14 Property

IRD

Ds1841TemperatureLookup14 Property

Temperature Lookup 14

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup14 { get; set; }
Public Property TemperatureLookup14 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup14 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup14 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup15 Property

IRD

Ds1841TemperatureLookup15 Property

Temperature Lookup 15

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup15 { get; set; }
Public Property TemperatureLookup15 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup15 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup15 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup16 Property

IRD

Ds1841TemperatureLookup16 Property

Temperature Lookup 16

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup16 { get; set; }
Public Property TemperatureLookup16 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup16 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup16 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup17 Property

IRD

Ds1841TemperatureLookup17 Property

Temperature Lookup 17

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup17 { get; set; }
Public Property TemperatureLookup17 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup17 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup17 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup18 Property

IRD

Ds1841TemperatureLookup18 Property

Temperature Lookup 18

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup18 { get; set; }
Public Property TemperatureLookup18 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup18 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup18 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup19 Property

IRD

Ds1841TemperatureLookup19 Property

Temperature Lookup 19

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup19 { get; set; }
Public Property TemperatureLookup19 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup19 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup19 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup20 Property

IRD

Ds1841TemperatureLookup20 Property

Temperature Lookup 20

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup20 { get; set; }
Public Property TemperatureLookup20 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup20 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup20 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup21 Property

IRD

Ds1841TemperatureLookup21 Property

Temperature Lookup 21

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup21 { get; set; }
Public Property TemperatureLookup21 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup21 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup21 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup22 Property

IRD

Ds1841TemperatureLookup22 Property

Temperature Lookup 22

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup22 { get; set; }
Public Property TemperatureLookup22 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup22 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup22 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup23 Property

IRD

Ds1841TemperatureLookup23 Property

Temperature Lookup 23

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup23 { get; set; }
Public Property TemperatureLookup23 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup23 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup23 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup24 Property

IRD

Ds1841TemperatureLookup24 Property

Temperature Lookup 24

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup24 { get; set; }
Public Property TemperatureLookup24 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup24 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup24 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup25 Property

IRD

Ds1841TemperatureLookup25 Property

Temperature Lookup 25

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup25 { get; set; }
Public Property TemperatureLookup25 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup25 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup25 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup26 Property

IRD

Ds1841TemperatureLookup26 Property

Temperature Lookup 26

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup26 { get; set; }
Public Property TemperatureLookup26 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup26 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup26 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup27 Property

IRD

Ds1841TemperatureLookup27 Property

Temperature Lookup 27

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup27 { get; set; }
Public Property TemperatureLookup27 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup27 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup27 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup28 Property

IRD

Ds1841TemperatureLookup28 Property

Temperature Lookup 28

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup28 { get; set; }
Public Property TemperatureLookup28 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup28 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup28 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup29 Property

IRD

Ds1841TemperatureLookup29 Property

Temperature Lookup 29

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup29 { get; set; }
Public Property TemperatureLookup29 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup29 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup29 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup30 Property

IRD

Ds1841TemperatureLookup30 Property

Temperature Lookup 30

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup30 { get; set; }
Public Property TemperatureLookup30 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup30 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup30 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup31 Property

IRD

Ds1841TemperatureLookup31 Property

Temperature Lookup 31

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup31 { get; set; }
Public Property TemperatureLookup31 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup31 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup31 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup32 Property

IRD

Ds1841TemperatureLookup32 Property

Temperature Lookup 32

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup32 { get; set; }
Public Property TemperatureLookup32 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup32 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup32 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup33 Property

IRD

Ds1841TemperatureLookup33 Property

Temperature Lookup 33

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup33 { get; set; }
Public Property TemperatureLookup33 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup33 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup33 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup34 Property

IRD

Ds1841TemperatureLookup34 Property

Temperature Lookup 34

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup34 { get; set; }
Public Property TemperatureLookup34 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup34 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup34 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup35 Property

IRD

Ds1841TemperatureLookup35 Property

Temperature Lookup 35

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup35 { get; set; }
Public Property TemperatureLookup35 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup35 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup35 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup36 Property

IRD

Ds1841TemperatureLookup36 Property

Temperature Lookup 36

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup36 { get; set; }
Public Property TemperatureLookup36 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup36 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup36 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup37 Property

IRD

Ds1841TemperatureLookup37 Property

Temperature Lookup 37

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup37 { get; set; }
Public Property TemperatureLookup37 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup37 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup37 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup38 Property

IRD

Ds1841TemperatureLookup38 Property

Temperature Lookup 38

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup38 { get; set; }
Public Property TemperatureLookup38 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup38 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup38 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup39 Property

IRD

Ds1841TemperatureLookup39 Property

Temperature Lookup 39

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup39 { get; set; }
Public Property TemperatureLookup39 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup39 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup39 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup40 Property

IRD

Ds1841TemperatureLookup40 Property

Temperature Lookup 40

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup40 { get; set; }
Public Property TemperatureLookup40 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup40 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup40 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup41 Property

IRD

Ds1841TemperatureLookup41 Property

Temperature Lookup 41

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup41 { get; set; }
Public Property TemperatureLookup41 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup41 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup41 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup42 Property

IRD

Ds1841TemperatureLookup42 Property

Temperature Lookup 42

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup42 { get; set; }
Public Property TemperatureLookup42 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup42 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup42 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup43 Property

IRD

Ds1841TemperatureLookup43 Property

Temperature Lookup 43

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup43 { get; set; }
Public Property TemperatureLookup43 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup43 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup43 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup44 Property

IRD

Ds1841TemperatureLookup44 Property

Temperature Lookup 44

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup44 { get; set; }
Public Property TemperatureLookup44 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup44 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup44 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup45 Property

IRD

Ds1841TemperatureLookup45 Property

Temperature Lookup 45

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup45 { get; set; }
Public Property TemperatureLookup45 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup45 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup45 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup46 Property

IRD

Ds1841TemperatureLookup46 Property

Temperature Lookup 46

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup46 { get; set; }
Public Property TemperatureLookup46 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup46 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup46 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup47 Property

IRD

Ds1841TemperatureLookup47 Property

Temperature Lookup 47

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup47 { get; set; }
Public Property TemperatureLookup47 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup47 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup47 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup48 Property

IRD

Ds1841TemperatureLookup48 Property

Temperature Lookup 48

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup48 { get; set; }
Public Property TemperatureLookup48 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup48 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup48 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup49 Property

IRD

Ds1841TemperatureLookup49 Property

Temperature Lookup 49

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup49 { get; set; }
Public Property TemperatureLookup49 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup49 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup49 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup50 Property

IRD

Ds1841TemperatureLookup50 Property

Temperature Lookup 50

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup50 { get; set; }
Public Property TemperatureLookup50 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup50 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup50 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup51 Property

IRD

Ds1841TemperatureLookup51 Property

Temperature Lookup 51

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup51 { get; set; }
Public Property TemperatureLookup51 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup51 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup51 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup52 Property

IRD

Ds1841TemperatureLookup52 Property

Temperature Lookup 52

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup52 { get; set; }
Public Property TemperatureLookup52 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup52 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup52 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup53 Property

IRD

Ds1841TemperatureLookup53 Property

Temperature Lookup 53

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup53 { get; set; }
Public Property TemperatureLookup53 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup53 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup53 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup54 Property

IRD

Ds1841TemperatureLookup54 Property

Temperature Lookup 54

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup54 { get; set; }
Public Property TemperatureLookup54 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup54 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup54 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup55 Property

IRD

Ds1841TemperatureLookup55 Property

Temperature Lookup 55

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup55 { get; set; }
Public Property TemperatureLookup55 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup55 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup55 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup56 Property

IRD

Ds1841TemperatureLookup56 Property

Temperature Lookup 56

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup56 { get; set; }
Public Property TemperatureLookup56 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup56 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup56 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup57 Property

IRD

Ds1841TemperatureLookup57 Property

Temperature Lookup 57

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup57 { get; set; }
Public Property TemperatureLookup57 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup57 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup57 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup58 Property

IRD

Ds1841TemperatureLookup58 Property

Temperature Lookup 58

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup58 { get; set; }
Public Property TemperatureLookup58 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup58 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup58 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup59 Property

IRD

Ds1841TemperatureLookup59 Property

Temperature Lookup 59

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup59 { get; set; }
Public Property TemperatureLookup59 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup59 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup59 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup60 Property

IRD

Ds1841TemperatureLookup60 Property

Temperature Lookup 60

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup60 { get; set; }
Public Property TemperatureLookup60 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup60 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup60 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup61 Property

IRD

Ds1841TemperatureLookup61 Property

Temperature Lookup 61

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup61 { get; set; }
Public Property TemperatureLookup61 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup61 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup61 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup62 Property

IRD

Ds1841TemperatureLookup62 Property

Temperature Lookup 62

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup62 { get; set; }
Public Property TemperatureLookup62 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup62 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup62 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup63 Property

IRD

Ds1841TemperatureLookup63 Property

Temperature Lookup 63

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup63 { get; set; }
Public Property TemperatureLookup63 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup63 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup63 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup64 Property

IRD

Ds1841TemperatureLookup64 Property

Temperature Lookup 64

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup64 { get; set; }
Public Property TemperatureLookup64 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup64 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup64 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup65 Property

IRD

Ds1841TemperatureLookup65 Property

Temperature Lookup 65

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup65 { get; set; }
Public Property TemperatureLookup65 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup65 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup65 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup66 Property

IRD

Ds1841TemperatureLookup66 Property

Temperature Lookup 66

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup66 { get; set; }
Public Property TemperatureLookup66 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup66 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup66 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup67 Property

IRD

Ds1841TemperatureLookup67 Property

Temperature Lookup 67

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup67 { get; set; }
Public Property TemperatureLookup67 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup67 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup67 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup68 Property

IRD

Ds1841TemperatureLookup68 Property

Temperature Lookup 68

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup68 { get; set; }
Public Property TemperatureLookup68 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup68 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup68 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup69 Property

IRD

Ds1841TemperatureLookup69 Property

Temperature Lookup 69

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup69 { get; set; }
Public Property TemperatureLookup69 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup69 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup69 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup70 Property

IRD

Ds1841TemperatureLookup70 Property

Temperature Lookup 70

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup70 { get; set; }
Public Property TemperatureLookup70 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup70 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup70 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TemperatureLookup71 Property

IRD

Ds1841TemperatureLookup71 Property

Temperature Lookup 71

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TemperatureLookup71 { get; set; }
Public Property TemperatureLookup71 As Byte
    Get
    Set
public:
property unsigned char TemperatureLookup71 {
    unsigned char get ();
    void set (unsigned char value);
}
member TemperatureLookup71 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841 Methods

The Ds1841 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.Flush Method

IRD

Ds1841Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds1841 Class
telos.Ird.Maxim Namespace


Ds1841.TypeControl0See Enumeration

IRD

Ds1841TypeControl0See Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl0See
Public Enumeration TypeControl0See
public enum class TypeControl0See
type TypeControl0See
Members
Member name | Value | Description
DataAtAddr0x00AreStoredToSRAMWRAndEEPROMIVR | 0 | Data At Addr. 0x00 Are Stored To SRAM (WR) And EEPROM (IVR)
DataAtAddr0x00IsStoredToSRAMWR | 1 | Data At Addr. 0x00 Is Stored To SRAM (WR)
See Also

Reference

telos.Ird.Maxim Namespace


Ds1841.TypeControl1Adder Enumeration

IRD

Ds1841TypeControl1Adder Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Adder
Public Enumeration TypeControl1Adder
public enum class TypeControl1Adder
type TypeControl1Adder
Members
Member name | Value | Description
LUTVALOrIVRLoadedDirectlyToWR | 0 | LUTVAL Or IVR Loaded Directly To WR
LUTVALIsSummedWithIVRAndLoadedToWR | 1 | LUTVAL Is Summed With IVR And Loaded To WR
See Also

Reference

telos.Ird.Maxim Namespace


Ds1841.TypeControl1Update Enumeration

IRD

Ds1841TypeControl1Update Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Update
Public Enumeration TypeControl1Update
public enum class TypeControl1Update
type TypeControl1Update
Members
Member name | Value | Description
IVRValueIsLoadedIntoWRDuringPowerUp | 0 | IVR Value Is Loaded Into WR During Power-Up
WRControlledByI2COrTemperatureCompensation | 1 | WR Controlled By I2C Or Temperature Compensation
See Also

Reference

telos.Ird.Maxim Namespace


Ds1841.TypeControl2Lutar Enumeration

IRD

Ds1841TypeControl2Lutar Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Lutar
Public Enumeration TypeControl2Lutar
public enum class TypeControl2Lutar
type TypeControl2Lutar
Members
Member name | Value | Description
LUTARValueIsCalculated | 0 | LUTAR Value Is Calculated
AutomaticUpdateOfLUTARDisabled | 1 | Automatic Update Of LUTAR Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds1841.TypeControl2Wipe Enumeration

IRD

Ds1841TypeControl2Wipe Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Wipe
Public Enumeration TypeControl2Wipe
public enum class TypeControl2Wipe
type TypeControl2Wipe
Members
Member name | Value | Description
WRIsLoadedWithValueFromIVR | 0 | WR Is Loaded With Value From IVR
WRProgrammedUsingI2CCommandsManualMode | 1 | WR Programmed Using I2C Commands (Manual Mode)
See Also

Reference

telos.Ird.Maxim Namespace


Ds2745 Class

Maxim: DS 2745
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs2745

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds2745
Public Class Ds2745
public ref class Ds2745
type Ds2745 =  class end

The Ds2745 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds2745 | Constructor
Top
Properties
 | Name | Description
Public property | AccumulatedCurrent | Accumulated Current (unit: µVh/Rsns)
Public property | AccumulationBias | Accumulation Bias (unit: µV/Rsns)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Current | Current (unit: µV/Rsns)
Public property | OffsetBias | Offset Bias (unit: µV/Rsns)
Public property | StatusConfigAddress | Status Config: Address
Public property | StatusConfigNBEN | Status Config: NBEN
Public property | StatusConfigPIO | Status Config: PIO
Public property | StatusConfigPORF | Status Config: PORF
Public property | StatusConfigSMOD | Status Config: SMOD
Public property | Temperature | Temperature (unit: °C)
Public property | Voltage | Voltage (unit: mV)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low Cost I2C Battery Monitor
See Also

Reference

telos.Ird.Maxim Namespace


Ds2745 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2745(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds2745(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds2745

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds2745 Class
telos.Ird.Maxim Namespace


Ds2745 Properties

The Ds2745 type exposes the following members.

Properties
 | Name | Description
Public property | AccumulatedCurrent | Accumulated Current (unit: µVh/Rsns)
Public property | AccumulationBias | Accumulation Bias (unit: µV/Rsns)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Current | Current (unit: µV/Rsns)
Public property | OffsetBias | Offset Bias (unit: µV/Rsns)
Public property | StatusConfigAddress | Status Config: Address
Public property | StatusConfigNBEN | Status Config: NBEN
Public property | StatusConfigPIO | Status Config: PIO
Public property | StatusConfigPORF | Status Config: PORF
Public property | StatusConfigSMOD | Status Config: SMOD
Public property | Temperature | Temperature (unit: °C)
Public property | Voltage | Voltage (unit: mV)
Top
See Also

Reference

Ds2745 Class
telos.Ird.Maxim Namespace


Ds2745.AccumulatedCurrent Property

IRD

Ds2745AccumulatedCurrent Property

Accumulated Current (unit: µVh/Rsns)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AccumulatedCurrent { get; }
Public ReadOnly Property AccumulatedCurrent As Double
    Get
public:
property double AccumulatedCurrent {
    double get ();
}
member AccumulatedCurrent : float with get

Property Value

Type: Double
See Also

Reference

Ds2745 Class
telos.Ird.Maxim Namespace


Ds2745.AccumulationBias Property

IRD

Ds2745AccumulationBias Property

Accumulation Bias (unit: µV/Rsns)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AccumulationBias { get; set; }
Public Property AccumulationBias As Double
    Get
    Set
public:
property double AccumulationBias {
    double get ();
    void set (double value);
}
member AccumulationBias : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2745 Class
telos.Ird.Maxim Namespace


Ds2745.AutoFlush Property

IRD

Ds2745AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds2745 Class
telos.Ird.Maxim Namespace


Ds2745.Current Property

IRD

Ds2745Current Property

Current (unit: µV/Rsns)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Current { get; }
Public ReadOnly Property Current As Double
    Get
public:
property double Current {
    double get ();
}
member Current : float with get

Property Value

Type: Double
See Also

Reference

Ds2745 Class
telos.Ird.Maxim Namespace


Ds2745.OffsetBias Property

IRD

Ds2745OffsetBias Property

Offset Bias (unit: µV/Rsns)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double OffsetBias { get; set; }
Public Property OffsetBias As Double
    Get
    Set
public:
property double OffsetBias {
    double get ();
    void set (double value);
}
member OffsetBias : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2745 Class
telos.Ird.Maxim Namespace


Ds2745.StatusConfigAddress Property

IRD

Ds2745StatusConfigAddress Property

Status Config: Address

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte StatusConfigAddress { get; set; }
Public Property StatusConfigAddress As Byte
    Get
    Set
public:
property unsigned char StatusConfigAddress {
    unsigned char get ();
    void set (unsigned char value);
}
member StatusConfigAddress : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds2745 Class
telos.Ird.Maxim Namespace


Ds2745.StatusConfigNBEN Property

IRD

Ds2745StatusConfigNBEN Property

Status Config: NBEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2745TypeStatusConfigNben StatusConfigNBEN { get; set; }
Public Property StatusConfigNBEN As Ds2745TypeStatusConfigNben
    Get
    Set
public:
property Ds2745TypeStatusConfigNben StatusConfigNBEN {
    Ds2745TypeStatusConfigNben get ();
    void set (Ds2745TypeStatusConfigNben value);
}
member StatusConfigNBEN : Ds2745TypeStatusConfigNben with get, set

Property Value

Type: Ds2745TypeStatusConfigNben
See Also

Reference

Ds2745 Class
telos.Ird.Maxim Namespace


Ds2745.StatusConfigPIO Property

IRD

Ds2745StatusConfigPIO Property

Status Config: PIO

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2745TypeStatusConfigPio StatusConfigPIO { get; set; }
Public Property StatusConfigPIO As Ds2745TypeStatusConfigPio
    Get
    Set
public:
property Ds2745TypeStatusConfigPio StatusConfigPIO {
    Ds2745TypeStatusConfigPio get ();
    void set (Ds2745TypeStatusConfigPio value);
}
member StatusConfigPIO : Ds2745TypeStatusConfigPio with get, set

Property Value

Type: Ds2745TypeStatusConfigPio
See Also

Reference

Ds2745 Class
telos.Ird.Maxim Namespace


Ds2745.StatusConfigPORF Property

IRD

Ds2745StatusConfigPORF Property

Status Config: PORF

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2745TypeStatusConfigPorf StatusConfigPORF { get; set; }
Public Property StatusConfigPORF As Ds2745TypeStatusConfigPorf
    Get
    Set
public:
property Ds2745TypeStatusConfigPorf StatusConfigPORF {
    Ds2745TypeStatusConfigPorf get ();
    void set (Ds2745TypeStatusConfigPorf value);
}
member StatusConfigPORF : Ds2745TypeStatusConfigPorf with get, set

Property Value

Type: Ds2745TypeStatusConfigPorf
See Also

Reference

Ds2745 Class
telos.Ird.Maxim Namespace


Ds2745.StatusConfigSMOD Property

IRD

Ds2745StatusConfigSMOD Property

Status Config: SMOD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2745TypeStatusConfigSmod StatusConfigSMOD { get; set; }
Public Property StatusConfigSMOD As Ds2745TypeStatusConfigSmod
    Get
    Set
public:
property Ds2745TypeStatusConfigSmod StatusConfigSMOD {
    Ds2745TypeStatusConfigSmod get ();
    void set (Ds2745TypeStatusConfigSmod value);
}
member StatusConfigSMOD : Ds2745TypeStatusConfigSmod with get, set

Property Value

Type: Ds2745TypeStatusConfigSmod
See Also

Reference

Ds2745 Class
telos.Ird.Maxim Namespace


Ds2745.Temperature Property

IRD

Ds2745Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Ds2745 Class
telos.Ird.Maxim Namespace


Ds2745.Voltage Property

IRD

Ds2745Voltage Property

Voltage (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Voltage { get; }
Public ReadOnly Property Voltage As Double
    Get
public:
property double Voltage {
    double get ();
}
member Voltage : float with get

Property Value

Type: Double
See Also

Reference

Ds2745 Class
telos.Ird.Maxim Namespace


Ds2745 Methods

The Ds2745 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds2745 Class
telos.Ird.Maxim Namespace


Ds2745.Flush Method

IRD

Ds2745Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds2745 Class
telos.Ird.Maxim Namespace


Ds2745.TypeStatusConfigNben Enumeration

IRD

Ds2745TypeStatusConfigNben Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusConfigNben
Public Enumeration TypeStatusConfigNben
public enum class TypeStatusConfigNben
type TypeStatusConfigNben
Members
Member name | Value | Description
NegativeBlankingDisabled | 0 | Negative Blanking: Disabled
NegativeBlankingEnabled | 1 | Negative Blanking: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds2745.TypeStatusConfigPio Enumeration

IRD

Ds2745TypeStatusConfigPio Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusConfigPio
Public Enumeration TypeStatusConfigPio
public enum class TypeStatusConfigPio
type TypeStatusConfigPio
Members
Member name | Value | Description
PIOOutputActivated | 0 | PIO Output: Activated
PIOOutputDeactivated | 1 | PIO Output: Deactivated
See Also

Reference

telos.Ird.Maxim Namespace


Ds2745.TypeStatusConfigPorf Enumeration

IRD

Ds2745TypeStatusConfigPorf Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusConfigPorf
Public Enumeration TypeStatusConfigPorf
public enum class TypeStatusConfigPorf
type TypeStatusConfigPorf
Members
Member name | Value | Description
InitialPowerUpEventNotOccurred | 0 | Initial Power-Up Event: Not Occurred
InitialPowerUpEventOccurred | 1 | Initial Power-Up Event: Occurred
See Also

Reference

telos.Ird.Maxim Namespace


Ds2745.TypeStatusConfigSmod Enumeration

IRD

Ds2745TypeStatusConfigSmod Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusConfigSmod
Public Enumeration TypeStatusConfigSmod
public enum class TypeStatusConfigSmod
type TypeStatusConfigSmod
Members
Member name | Value | Description
SleepModeDisable | 0 | Sleep Mode: Disable
SleepModeEnable | 1 | Sleep Mode: Enable
See Also

Reference

telos.Ird.Maxim Namespace


Ds2786 Class

Maxim: DS 2786
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs2786

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds2786
Public Class Ds2786
public ref class Ds2786
type Ds2786 =  class end

The Ds2786 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds2786 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AuxiliaryInput0 | Auxiliary Input 0
Public property | AuxiliaryInput1 | Auxiliary Input 1
Public property | BlankingCurrentThreshold | Blanking Current Threshold (unit: µV/Rsns)
Public property | Capacity1 | Capacity 1 (unit: %)
Public property | Capacity2 | Capacity 2 (unit: %)
Public property | Capacity3 | Capacity 3 (unit: %)
Public property | Capacity4 | Capacity 4 (unit: %)
Public property | Capacity5 | Capacity 5 (unit: %)
Public property | Capacity6 | Capacity 6 (unit: %)
Public property | Capacity7 | Capacity 7 (unit: %)
Public property | CommandBit6 | Command: Bit6
Public property | CommandCOPY | Command: COPY
Public property | CommandPOCV | Command: POCV
Public property | CommandPOR | Command: POR
Public property | CommandRCALL | Command: RCALL
Public property | CommandSOCV | Command: SOCV
Public property | Current | Current (unit: µV/Rsns)
Public property | CurrentOffsetBias | Current Offset Bias (unit: µV/Rsns)
Public property | I2CAddressConfiguration | I2C Address Configuration
Public property | InitialCapacityScalingFactor | Initial Capacity Scaling Factor (unit: %/Vh)
Public property | InitialVoltage | Initial Voltage (unit: mV)
Public property | LastOCVCapacity | Last OCV Capacity (unit: %)
Public property | LearnedCapacityScalingFactor | Learned Capacity Scaling Factor (unit: %/Vh)
Public property | LearnThreshold | Learn Threshold (unit: %)
Public property | OCVThresholdDVDt | OCV Threshold: dV/dt (unit: mV/15min)
Public property | OCVThresholdITEMP | OCV Threshold: ITEMP
Public property | OCVThresholdLDIS | OCV Threshold: LDIS
Public property | OCVThresholdSMOD | OCV Threshold: SMOD
Public property | OCVThresholdVODIS | OCV Threshold: VODIS
Public property | RelativeCapacity | Relative Capacity (unit: %)
Public property | StatusConfigAIN0 | Status Config: AIN0
Public property | StatusConfigAIN1 | Status Config: AIN1
Public property | StatusConfigITEMP | Status Config: ITEMP
Public property | StatusConfigLDIS | Status Config: LDIS
Public property | StatusConfigPORF | Status Config: PORF
Public property | StatusConfigSMOD | Status Config: SMOD
Public property | StatusConfigVODIS | Status Config: VODIS
Public property | UserEEPROM | User EEPROM
Public property | Voltage | Voltage (unit: mV)
Public property | VoltageBreakpoint0 | Voltage Breakpoint 0 (unit: mV)
Public property | VoltageBreakpoint1 | Voltage Breakpoint 1 (unit: mV)
Public property | VoltageBreakpoint2 | Voltage Breakpoint 2 (unit: mV)
Public property | VoltageBreakpoint3 | Voltage Breakpoint 3 (unit: mV)
Public property | VoltageBreakpoint4 | Voltage Breakpoint 4 (unit: mV)
Public property | VoltageBreakpoint5 | Voltage Breakpoint 5 (unit: mV)
Public property | VoltageBreakpoint6 | Voltage Breakpoint 6 (unit: mV)
Public property | VoltageBreakpoint7 | Voltage Breakpoint 7 (unit: mV)
Public property | VoltageBreakpoint8 | Voltage Breakpoint 8 (unit: mV)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Stand-Alone OCV-Based Fuel Gauge
See Also

Reference

telos.Ird.Maxim Namespace


Ds2786 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2786(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds2786(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds2786

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786 Properties

The Ds2786 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AuxiliaryInput0 | Auxiliary Input 0
Public property | AuxiliaryInput1 | Auxiliary Input 1
Public property | BlankingCurrentThreshold | Blanking Current Threshold (unit: µV/Rsns)
Public property | Capacity1 | Capacity 1 (unit: %)
Public property | Capacity2 | Capacity 2 (unit: %)
Public property | Capacity3 | Capacity 3 (unit: %)
Public property | Capacity4 | Capacity 4 (unit: %)
Public property | Capacity5 | Capacity 5 (unit: %)
Public property | Capacity6 | Capacity 6 (unit: %)
Public property | Capacity7 | Capacity 7 (unit: %)
Public property | CommandBit6 | Command: Bit6
Public property | CommandCOPY | Command: COPY
Public property | CommandPOCV | Command: POCV
Public property | CommandPOR | Command: POR
Public property | CommandRCALL | Command: RCALL
Public property | CommandSOCV | Command: SOCV
Public property | Current | Current (unit: µV/Rsns)
Public property | CurrentOffsetBias | Current Offset Bias (unit: µV/Rsns)
Public property | I2CAddressConfiguration | I2C Address Configuration
Public property | InitialCapacityScalingFactor | Initial Capacity Scaling Factor (unit: %/Vh)
Public property | InitialVoltage | Initial Voltage (unit: mV)
Public property | LastOCVCapacity | Last OCV Capacity (unit: %)
Public property | LearnedCapacityScalingFactor | Learned Capacity Scaling Factor (unit: %/Vh)
Public property | LearnThreshold | Learn Threshold (unit: %)
Public property | OCVThresholdDVDt | OCV Threshold: dV/dt (unit: mV/15min)
Public property | OCVThresholdITEMP | OCV Threshold: ITEMP
Public property | OCVThresholdLDIS | OCV Threshold: LDIS
Public property | OCVThresholdSMOD | OCV Threshold: SMOD
Public property | OCVThresholdVODIS | OCV Threshold: VODIS
Public property | RelativeCapacity | Relative Capacity (unit: %)
Public property | StatusConfigAIN0 | Status Config: AIN0
Public property | StatusConfigAIN1 | Status Config: AIN1
Public property | StatusConfigITEMP | Status Config: ITEMP
Public property | StatusConfigLDIS | Status Config: LDIS
Public property | StatusConfigPORF | Status Config: PORF
Public property | StatusConfigSMOD | Status Config: SMOD
Public property | StatusConfigVODIS | Status Config: VODIS
Public property | UserEEPROM | User EEPROM
Public property | Voltage | Voltage (unit: mV)
Public property | VoltageBreakpoint0 | Voltage Breakpoint 0 (unit: mV)
Public property | VoltageBreakpoint1 | Voltage Breakpoint 1 (unit: mV)
Public property | VoltageBreakpoint2 | Voltage Breakpoint 2 (unit: mV)
Public property | VoltageBreakpoint3 | Voltage Breakpoint 3 (unit: mV)
Public property | VoltageBreakpoint4 | Voltage Breakpoint 4 (unit: mV)
Public property | VoltageBreakpoint5 | Voltage Breakpoint 5 (unit: mV)
Public property | VoltageBreakpoint6 | Voltage Breakpoint 6 (unit: mV)
Public property | VoltageBreakpoint7 | Voltage Breakpoint 7 (unit: mV)
Public property | VoltageBreakpoint8 | Voltage Breakpoint 8 (unit: mV)
Top
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.AutoFlush Property

IRD

Ds2786AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.AuxiliaryInput0 Property

IRD

Ds2786AuxiliaryInput0 Property

Auxiliary Input 0

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AuxiliaryInput0 { get; }
Public ReadOnly Property AuxiliaryInput0 As Double
    Get
public:
property double AuxiliaryInput0 {
    double get ();
}
member AuxiliaryInput0 : float with get

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.AuxiliaryInput1 Property

IRD

Ds2786AuxiliaryInput1 Property

Auxiliary Input 1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AuxiliaryInput1 { get; }
Public ReadOnly Property AuxiliaryInput1 As Double
    Get
public:
property double AuxiliaryInput1 {
    double get ();
}
member AuxiliaryInput1 : float with get

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.BlankingCurrentThreshold Property

IRD

Ds2786BlankingCurrentThreshold Property

Blanking Current Threshold (unit: µV/Rsns)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double BlankingCurrentThreshold { get; set; }
Public Property BlankingCurrentThreshold As Double
    Get
    Set
public:
property double BlankingCurrentThreshold {
    double get ();
    void set (double value);
}
member BlankingCurrentThreshold : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.Capacity1 Property

IRD

Ds2786Capacity1 Property

Capacity 1 (unit: %)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Capacity1 { get; set; }
Public Property Capacity1 As Double
    Get
    Set
public:
property double Capacity1 {
    double get ();
    void set (double value);
}
member Capacity1 : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.Capacity2 Property

IRD

Ds2786Capacity2 Property

Capacity 2 (unit: %)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Capacity2 { get; set; }
Public Property Capacity2 As Double
    Get
    Set
public:
property double Capacity2 {
    double get ();
    void set (double value);
}
member Capacity2 : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.Capacity3 Property

IRD

Ds2786Capacity3 Property

Capacity 3 (unit: %)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Capacity3 { get; set; }
Public Property Capacity3 As Double
    Get
    Set
public:
property double Capacity3 {
    double get ();
    void set (double value);
}
member Capacity3 : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.Capacity4 Property

IRD

Ds2786Capacity4 Property

Capacity 4 (unit: %)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Capacity4 { get; set; }
Public Property Capacity4 As Double
    Get
    Set
public:
property double Capacity4 {
    double get ();
    void set (double value);
}
member Capacity4 : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.Capacity5 Property

IRD

Ds2786Capacity5 Property

Capacity 5 (unit: %)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Capacity5 { get; set; }
Public Property Capacity5 As Double
    Get
    Set
public:
property double Capacity5 {
    double get ();
    void set (double value);
}
member Capacity5 : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.Capacity6 Property

IRD

Ds2786Capacity6 Property

Capacity 6 (unit: %)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Capacity6 { get; set; }
Public Property Capacity6 As Double
    Get
    Set
public:
property double Capacity6 {
    double get ();
    void set (double value);
}
member Capacity6 : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.Capacity7 Property

IRD

Ds2786Capacity7 Property

Capacity 7 (unit: %)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Capacity7 { get; set; }
Public Property Capacity7 As Double
    Get
    Set
public:
property double Capacity7 {
    double get ();
    void set (double value);
}
member Capacity7 : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.CommandBit6 Property

IRD

Ds2786CommandBit6 Property

Command: Bit6

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2786TypeCommandBit6 CommandBit6 { get; set; }
Public Property CommandBit6 As Ds2786TypeCommandBit6
    Get
    Set
public:
property Ds2786TypeCommandBit6 CommandBit6 {
    Ds2786TypeCommandBit6 get ();
    void set (Ds2786TypeCommandBit6 value);
}
member CommandBit6 : Ds2786TypeCommandBit6 with get, set

Property Value

Type: Ds2786TypeCommandBit6
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.CommandCOPY Property

IRD

Ds2786CommandCOPY Property

Command: COPY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2786TypeCommandCopy CommandCOPY { get; set; }
Public Property CommandCOPY As Ds2786TypeCommandCopy
    Get
    Set
public:
property Ds2786TypeCommandCopy CommandCOPY {
    Ds2786TypeCommandCopy get ();
    void set (Ds2786TypeCommandCopy value);
}
member CommandCOPY : Ds2786TypeCommandCopy with get, set

Property Value

Type: Ds2786TypeCommandCopy
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.CommandPOCV Property

IRD

Ds2786CommandPOCV Property

Command: POCV

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2786TypeCommandPocv CommandPOCV { get; set; }
Public Property CommandPOCV As Ds2786TypeCommandPocv
    Get
    Set
public:
property Ds2786TypeCommandPocv CommandPOCV {
    Ds2786TypeCommandPocv get ();
    void set (Ds2786TypeCommandPocv value);
}
member CommandPOCV : Ds2786TypeCommandPocv with get, set

Property Value

Type: Ds2786TypeCommandPocv
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.CommandPOR Property

IRD

Ds2786CommandPOR Property

Command: POR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2786TypeCommandPor CommandPOR { get; set; }
Public Property CommandPOR As Ds2786TypeCommandPor
    Get
    Set
public:
property Ds2786TypeCommandPor CommandPOR {
    Ds2786TypeCommandPor get ();
    void set (Ds2786TypeCommandPor value);
}
member CommandPOR : Ds2786TypeCommandPor with get, set

Property Value

Type: Ds2786TypeCommandPor
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.CommandRCALL Property

IRD

Ds2786CommandRCALL Property

Command: RCALL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2786TypeCommandRcall CommandRCALL { get; set; }
Public Property CommandRCALL As Ds2786TypeCommandRcall
    Get
    Set
public:
property Ds2786TypeCommandRcall CommandRCALL {
    Ds2786TypeCommandRcall get ();
    void set (Ds2786TypeCommandRcall value);
}
member CommandRCALL : Ds2786TypeCommandRcall with get, set

Property Value

Type: Ds2786TypeCommandRcall
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.CommandSOCV Property

IRD

Ds2786CommandSOCV Property

Command: SOCV

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2786TypeCommandSocv CommandSOCV { get; set; }
Public Property CommandSOCV As Ds2786TypeCommandSocv
    Get
    Set
public:
property Ds2786TypeCommandSocv CommandSOCV {
    Ds2786TypeCommandSocv get ();
    void set (Ds2786TypeCommandSocv value);
}
member CommandSOCV : Ds2786TypeCommandSocv with get, set

Property Value

Type: Ds2786TypeCommandSocv
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.Current Property

IRD

Ds2786Current Property

Current (unit: µV/Rsns)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Current { get; }
Public ReadOnly Property Current As Double
    Get
public:
property double Current {
    double get ();
}
member Current : float with get

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.CurrentOffsetBias Property

IRD

Ds2786CurrentOffsetBias Property

Current Offset Bias (unit: µV/Rsns)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CurrentOffsetBias { get; set; }
Public Property CurrentOffsetBias As Double
    Get
    Set
public:
property double CurrentOffsetBias {
    double get ();
    void set (double value);
}
member CurrentOffsetBias : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.I2CAddressConfiguration Property

IRD

Ds2786I2CAddressConfiguration Property

I2C Address Configuration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte I2CAddressConfiguration { get; set; }
Public Property I2CAddressConfiguration As Byte
    Get
    Set
public:
property unsigned char I2CAddressConfiguration {
    unsigned char get ();
    void set (unsigned char value);
}
member I2CAddressConfiguration : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.InitialCapacityScalingFactor Property

IRD

Ds2786InitialCapacityScalingFactor Property

Initial Capacity Scaling Factor (unit: %/Vh)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double InitialCapacityScalingFactor { get; set; }
Public Property InitialCapacityScalingFactor As Double
    Get
    Set
public:
property double InitialCapacityScalingFactor {
    double get ();
    void set (double value);
}
member InitialCapacityScalingFactor : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.InitialVoltage Property

IRD

Ds2786InitialVoltage Property

Initial Voltage (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double InitialVoltage { get; }
Public ReadOnly Property InitialVoltage As Double
    Get
public:
property double InitialVoltage {
    double get ();
}
member InitialVoltage : float with get

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.LastOCVCapacity Property

IRD

Ds2786LastOCVCapacity Property

Last OCV Capacity (unit: %)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LastOCVCapacity { get; }
Public ReadOnly Property LastOCVCapacity As Double
    Get
public:
property double LastOCVCapacity {
    double get ();
}
member LastOCVCapacity : float with get

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.LearnedCapacityScalingFactor Property

IRD

Ds2786LearnedCapacityScalingFactor Property

Learned Capacity Scaling Factor (unit: %/Vh)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LearnedCapacityScalingFactor { get; }
Public ReadOnly Property LearnedCapacityScalingFactor As Double
    Get
public:
property double LearnedCapacityScalingFactor {
    double get ();
}
member LearnedCapacityScalingFactor : float with get

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.LearnThreshold Property

IRD

Ds2786LearnThreshold Property

Learn Threshold (unit: %)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LearnThreshold { get; set; }
Public Property LearnThreshold As Double
    Get
    Set
public:
property double LearnThreshold {
    double get ();
    void set (double value);
}
member LearnThreshold : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.OCVThresholdDVDt Property

IRD

Ds2786OCVThresholdDVDt Property

OCV Threshold: dV/dt (unit: mV/15min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double OCVThresholdDVDt { get; set; }
Public Property OCVThresholdDVDt As Double
    Get
    Set
public:
property double OCVThresholdDVDt {
    double get ();
    void set (double value);
}
member OCVThresholdDVDt : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.OCVThresholdITEMP Property

IRD

Ds2786OCVThresholdITEMP Property

OCV Threshold: ITEMP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2786TypeStatusConfigItemp OCVThresholdITEMP { get; set; }
Public Property OCVThresholdITEMP As Ds2786TypeStatusConfigItemp
    Get
    Set
public:
property Ds2786TypeStatusConfigItemp OCVThresholdITEMP {
    Ds2786TypeStatusConfigItemp get ();
    void set (Ds2786TypeStatusConfigItemp value);
}
member OCVThresholdITEMP : Ds2786TypeStatusConfigItemp with get, set

Property Value

Type: Ds2786TypeStatusConfigItemp
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.OCVThresholdLDIS Property

IRD

Ds2786OCVThresholdLDIS Property

OCV Threshold: LDIS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2786TypeOcvThresholdLdis OCVThresholdLDIS { get; set; }
Public Property OCVThresholdLDIS As Ds2786TypeOcvThresholdLdis
    Get
    Set
public:
property Ds2786TypeOcvThresholdLdis OCVThresholdLDIS {
    Ds2786TypeOcvThresholdLdis get ();
    void set (Ds2786TypeOcvThresholdLdis value);
}
member OCVThresholdLDIS : Ds2786TypeOcvThresholdLdis with get, set

Property Value

Type: Ds2786TypeOcvThresholdLdis
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.OCVThresholdSMOD Property

IRD

Ds2786OCVThresholdSMOD Property

OCV Threshold: SMOD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2786TypeOcvThresholdSmod OCVThresholdSMOD { get; set; }
Public Property OCVThresholdSMOD As Ds2786TypeOcvThresholdSmod
    Get
    Set
public:
property Ds2786TypeOcvThresholdSmod OCVThresholdSMOD {
    Ds2786TypeOcvThresholdSmod get ();
    void set (Ds2786TypeOcvThresholdSmod value);
}
member OCVThresholdSMOD : Ds2786TypeOcvThresholdSmod with get, set

Property Value

Type: Ds2786TypeOcvThresholdSmod
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.OCVThresholdVODIS Property

IRD

Ds2786OCVThresholdVODIS Property

OCV Threshold: VODIS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2786TypeOcvThresholdVodis OCVThresholdVODIS { get; set; }
Public Property OCVThresholdVODIS As Ds2786TypeOcvThresholdVodis
    Get
    Set
public:
property Ds2786TypeOcvThresholdVodis OCVThresholdVODIS {
    Ds2786TypeOcvThresholdVodis get ();
    void set (Ds2786TypeOcvThresholdVodis value);
}
member OCVThresholdVODIS : Ds2786TypeOcvThresholdVodis with get, set

Property Value

Type: Ds2786TypeOcvThresholdVodis
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.RelativeCapacity Property

IRD

Ds2786RelativeCapacity Property

Relative Capacity (unit: %)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RelativeCapacity { get; }
Public ReadOnly Property RelativeCapacity As Double
    Get
public:
property double RelativeCapacity {
    double get ();
}
member RelativeCapacity : float with get

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.StatusConfigAIN0 Property

IRD

Ds2786StatusConfigAIN0 Property

Status Config: AIN0

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2786TypeStatusConfigAin0 StatusConfigAIN0 { get; }
Public ReadOnly Property StatusConfigAIN0 As Ds2786TypeStatusConfigAin0
    Get
public:
property Ds2786TypeStatusConfigAin0 StatusConfigAIN0 {
    Ds2786TypeStatusConfigAin0 get ();
}
member StatusConfigAIN0 : Ds2786TypeStatusConfigAin0 with get

Property Value

Type: Ds2786TypeStatusConfigAin0
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.StatusConfigAIN1 Property

IRD

Ds2786StatusConfigAIN1 Property

Status Config: AIN1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2786TypeStatusConfigAin1 StatusConfigAIN1 { get; }
Public ReadOnly Property StatusConfigAIN1 As Ds2786TypeStatusConfigAin1
    Get
public:
property Ds2786TypeStatusConfigAin1 StatusConfigAIN1 {
    Ds2786TypeStatusConfigAin1 get ();
}
member StatusConfigAIN1 : Ds2786TypeStatusConfigAin1 with get

Property Value

Type: Ds2786TypeStatusConfigAin1
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.StatusConfigITEMP Property

IRD

Ds2786StatusConfigITEMP Property

Status Config: ITEMP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2786TypeStatusConfigItemp StatusConfigITEMP { get; set; }
Public Property StatusConfigITEMP As Ds2786TypeStatusConfigItemp
    Get
    Set
public:
property Ds2786TypeStatusConfigItemp StatusConfigITEMP {
    Ds2786TypeStatusConfigItemp get ();
    void set (Ds2786TypeStatusConfigItemp value);
}
member StatusConfigITEMP : Ds2786TypeStatusConfigItemp with get, set

Property Value

Type: Ds2786TypeStatusConfigItemp
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.StatusConfigLDIS Property

IRD

Ds2786StatusConfigLDIS Property

Status Config: LDIS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2786TypeStatusConfigLdis StatusConfigLDIS { get; set; }
Public Property StatusConfigLDIS As Ds2786TypeStatusConfigLdis
    Get
    Set
public:
property Ds2786TypeStatusConfigLdis StatusConfigLDIS {
    Ds2786TypeStatusConfigLdis get ();
    void set (Ds2786TypeStatusConfigLdis value);
}
member StatusConfigLDIS : Ds2786TypeStatusConfigLdis with get, set

Property Value

Type: Ds2786TypeStatusConfigLdis
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.StatusConfigPORF Property

IRD

Ds2786StatusConfigPORF Property

Status Config: PORF

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2786TypeStatusConfigPorf StatusConfigPORF { get; set; }
Public Property StatusConfigPORF As Ds2786TypeStatusConfigPorf
    Get
    Set
public:
property Ds2786TypeStatusConfigPorf StatusConfigPORF {
    Ds2786TypeStatusConfigPorf get ();
    void set (Ds2786TypeStatusConfigPorf value);
}
member StatusConfigPORF : Ds2786TypeStatusConfigPorf with get, set

Property Value

Type: Ds2786TypeStatusConfigPorf
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.StatusConfigSMOD Property

IRD

Ds2786StatusConfigSMOD Property

Status Config: SMOD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2786TypeStatusConfigSmod StatusConfigSMOD { get; set; }
Public Property StatusConfigSMOD As Ds2786TypeStatusConfigSmod
    Get
    Set
public:
property Ds2786TypeStatusConfigSmod StatusConfigSMOD {
    Ds2786TypeStatusConfigSmod get ();
    void set (Ds2786TypeStatusConfigSmod value);
}
member StatusConfigSMOD : Ds2786TypeStatusConfigSmod with get, set

Property Value

Type: Ds2786TypeStatusConfigSmod
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.StatusConfigVODIS Property

IRD

Ds2786StatusConfigVODIS Property

Status Config: VODIS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds2786TypeStatusConfigVodis StatusConfigVODIS { get; set; }
Public Property StatusConfigVODIS As Ds2786TypeStatusConfigVodis
    Get
    Set
public:
property Ds2786TypeStatusConfigVodis StatusConfigVODIS {
    Ds2786TypeStatusConfigVodis get ();
    void set (Ds2786TypeStatusConfigVodis value);
}
member StatusConfigVODIS : Ds2786TypeStatusConfigVodis with get, set

Property Value

Type: Ds2786TypeStatusConfigVodis
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.UserEEPROM Property

IRD

Ds2786UserEEPROM Property

User EEPROM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte UserEEPROM { get; set; }
Public Property UserEEPROM As Byte
    Get
    Set
public:
property unsigned char UserEEPROM {
    unsigned char get ();
    void set (unsigned char value);
}
member UserEEPROM : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.Voltage Property

IRD

Ds2786Voltage Property

Voltage (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Voltage { get; }
Public ReadOnly Property Voltage As Double
    Get
public:
property double Voltage {
    double get ();
}
member Voltage : float with get

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.VoltageBreakpoint0 Property

IRD

Ds2786VoltageBreakpoint0 Property

Voltage Breakpoint 0 (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VoltageBreakpoint0 { get; set; }
Public Property VoltageBreakpoint0 As Double
    Get
    Set
public:
property double VoltageBreakpoint0 {
    double get ();
    void set (double value);
}
member VoltageBreakpoint0 : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.VoltageBreakpoint1 Property

IRD

Ds2786VoltageBreakpoint1 Property

Voltage Breakpoint 1 (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VoltageBreakpoint1 { get; set; }
Public Property VoltageBreakpoint1 As Double
    Get
    Set
public:
property double VoltageBreakpoint1 {
    double get ();
    void set (double value);
}
member VoltageBreakpoint1 : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.VoltageBreakpoint2 Property

IRD

Ds2786VoltageBreakpoint2 Property

Voltage Breakpoint 2 (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VoltageBreakpoint2 { get; set; }
Public Property VoltageBreakpoint2 As Double
    Get
    Set
public:
property double VoltageBreakpoint2 {
    double get ();
    void set (double value);
}
member VoltageBreakpoint2 : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.VoltageBreakpoint3 Property

IRD

Ds2786VoltageBreakpoint3 Property

Voltage Breakpoint 3 (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VoltageBreakpoint3 { get; set; }
Public Property VoltageBreakpoint3 As Double
    Get
    Set
public:
property double VoltageBreakpoint3 {
    double get ();
    void set (double value);
}
member VoltageBreakpoint3 : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.VoltageBreakpoint4 Property

IRD

Ds2786VoltageBreakpoint4 Property

Voltage Breakpoint 4 (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VoltageBreakpoint4 { get; set; }
Public Property VoltageBreakpoint4 As Double
    Get
    Set
public:
property double VoltageBreakpoint4 {
    double get ();
    void set (double value);
}
member VoltageBreakpoint4 : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.VoltageBreakpoint5 Property

IRD

Ds2786VoltageBreakpoint5 Property

Voltage Breakpoint 5 (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VoltageBreakpoint5 { get; set; }
Public Property VoltageBreakpoint5 As Double
    Get
    Set
public:
property double VoltageBreakpoint5 {
    double get ();
    void set (double value);
}
member VoltageBreakpoint5 : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.VoltageBreakpoint6 Property

IRD

Ds2786VoltageBreakpoint6 Property

Voltage Breakpoint 6 (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VoltageBreakpoint6 { get; set; }
Public Property VoltageBreakpoint6 As Double
    Get
    Set
public:
property double VoltageBreakpoint6 {
    double get ();
    void set (double value);
}
member VoltageBreakpoint6 : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.VoltageBreakpoint7 Property

IRD

Ds2786VoltageBreakpoint7 Property

Voltage Breakpoint 7 (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VoltageBreakpoint7 { get; set; }
Public Property VoltageBreakpoint7 As Double
    Get
    Set
public:
property double VoltageBreakpoint7 {
    double get ();
    void set (double value);
}
member VoltageBreakpoint7 : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.VoltageBreakpoint8 Property

IRD

Ds2786VoltageBreakpoint8 Property

Voltage Breakpoint 8 (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VoltageBreakpoint8 { get; set; }
Public Property VoltageBreakpoint8 As Double
    Get
    Set
public:
property double VoltageBreakpoint8 {
    double get ();
    void set (double value);
}
member VoltageBreakpoint8 : float with get, set

Property Value

Type: Double
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786 Methods

The Ds2786 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.Flush Method

IRD

Ds2786Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds2786 Class
telos.Ird.Maxim Namespace


Ds2786.TypeCommandBit6 Enumeration

IRD

Ds2786TypeCommandBit6 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommandBit6
Public Enumeration TypeCommandBit6
public enum class TypeCommandBit6
type TypeCommandBit6
Members
Member name | Value | Description
AlwaysReadLogic0 | 0 | Always Read Logic 0
See Also

Reference

telos.Ird.Maxim Namespace


Ds2786.TypeCommandCopy Enumeration

IRD

Ds2786TypeCommandCopy Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommandCopy
Public Enumeration TypeCommandCopy
public enum class TypeCommandCopy
type TypeCommandCopy
Members
Member name | Value | Description
CopyScratchPadToEEPROMNotStarted | 0 | Copy Scratch Pad To EEPROM: Not Started
CopyScratchPadToEEPROMStarted | 1 | Copy Scratch Pad To EEPROM: Started
See Also

Reference

telos.Ird.Maxim Namespace


Ds2786.TypeCommandPocv Enumeration

IRD

Ds2786TypeCommandPocv Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommandPocv
Public Enumeration TypeCommandPocv
public enum class TypeCommandPocv
type TypeCommandPocv
Members
Member name | Value | Description
PresentOCVCalculationNotForcedToPerform | 0 | Present OCV Calculation: Not Forced To Perform
PresentOCVCalculationForcedToPerform | 1 | Present OCV Calculation: Forced To Perform
See Also

Reference

telos.Ird.Maxim Namespace


Ds2786.TypeCommandPor Enumeration

IRD

Ds2786TypeCommandPor Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommandPor
Public Enumeration TypeCommandPor
public enum class TypeCommandPor
type TypeCommandPor
Members
Member name | Value | Description
PowerOnResetEventNotInitiated | 0 | Power-On Reset Event: Not Initiated
PowerOnResetEventInitiated | 1 | Power-On Reset Event: Initiated
See Also

Reference

telos.Ird.Maxim Namespace


Ds2786.TypeCommandRcall Enumeration

IRD

Ds2786TypeCommandRcall Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommandRcall
Public Enumeration TypeCommandRcall
public enum class TypeCommandRcall
type TypeCommandRcall
Members
Member name | Value | Description
ContentOfEEPROMNotRecalledIntoScratchPad | 0 | Content Of EEPROM: Not Recalled Into Scratch Pad
ContentOfEEPROMRecalledIntoScratchPad | 1 | Content Of EEPROM: Recalled Into Scratch Pad
See Also

Reference

telos.Ird.Maxim Namespace


Ds2786.TypeCommandSocv Enumeration

IRD

Ds2786TypeCommandSocv Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommandSocv
Public Enumeration TypeCommandSocv
public enum class TypeCommandSocv
type TypeCommandSocv
Members
Member name | Value | Description
StoredOCVCalculationNotForcedToPerform | 0 | Stored OCV Calculation: Not Forced To Perform
StoredOCVCalculationForcedToPerform | 1 | Stored OCV Calculation: Forced To Perform
See Also

Reference

telos.Ird.Maxim Namespace


Ds2786.TypeOcvThresholdItemp Enumeration

IRD

Ds2786TypeOcvThresholdItemp Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOcvThresholdItemp
Public Enumeration TypeOcvThresholdItemp
public enum class TypeOcvThresholdItemp
type TypeOcvThresholdItemp
Members
Member name | Value | Description
TemperatureMeasurementDisabled | 0 | Temperature Measurement: Disabled
TemperatureMeasurementEnabled | 1 | Temperature Measurement: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds2786.TypeOcvThresholdLdis Enumeration

IRD

Ds2786TypeOcvThresholdLdis Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOcvThresholdLdis
Public Enumeration TypeOcvThresholdLdis
public enum class TypeOcvThresholdLdis
type TypeOcvThresholdLdis
Members
Member name | Value | Description
CellCapacityLearningEnabled | 0 | Cell Capacity Learning: Enabled
CellCapacityLearningDisabled | 1 | Cell Capacity Learning: Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds2786.TypeOcvThresholdSmod Enumeration

IRD

Ds2786TypeOcvThresholdSmod Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOcvThresholdSmod
Public Enumeration TypeOcvThresholdSmod
public enum class TypeOcvThresholdSmod
type TypeOcvThresholdSmod
Members
Member name | Value | Description
SleepModeDisable | 0 | Sleep Mode: Disable
SllepModeEnable | 1 | Sllep Mode: Enable
See Also

Reference

telos.Ird.Maxim Namespace


Ds2786.TypeOcvThresholdVodis Enumeration

IRD

Ds2786TypeOcvThresholdVodis Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOcvThresholdVodis
Public Enumeration TypeOcvThresholdVodis
public enum class TypeOcvThresholdVodis
type TypeOcvThresholdVodis
Members
Member name | Value | Description
VoutEnable | 0 | Vout Enable
VoutDisable | 1 | Vout Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds2786.TypeStatusConfigAin0 Enumeration

IRD

Ds2786TypeStatusConfigAin0 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusConfigAin0
Public Enumeration TypeStatusConfigAin0
public enum class TypeStatusConfigAin0
type TypeStatusConfigAin0
Members
Member name | Value | Description
ConversionOnAIN0PinNotOccurred | 0 | Conversion On AIN0 Pin: Not Occurred
ConversionOnAIN0PinOccurred | 1 | Conversion On AIN0 Pin: Occurred
See Also

Reference

telos.Ird.Maxim Namespace


Ds2786.TypeStatusConfigAin1 Enumeration

IRD

Ds2786TypeStatusConfigAin1 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusConfigAin1
Public Enumeration TypeStatusConfigAin1
public enum class TypeStatusConfigAin1
type TypeStatusConfigAin1
Members
Member name | Value | Description
ConversionOnAIN1PinNotOccurred | 0 | Conversion On AIN1 Pin: Not Occurred
ConversionOnAIN1PinOccurred | 1 | Conversion On AIN1 Pin: Occurred
See Also

Reference

telos.Ird.Maxim Namespace


Ds2786.TypeStatusConfigItemp Enumeration

IRD

Ds2786TypeStatusConfigItemp Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusConfigItemp
Public Enumeration TypeStatusConfigItemp
public enum class TypeStatusConfigItemp
type TypeStatusConfigItemp
Members
Member name | Value | Description
TemperatureMeasurementDisabled | 0 | Temperature Measurement: Disabled
TemperatureMeasurementEnabled | 1 | Temperature Measurement: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds2786.TypeStatusConfigLdis Enumeration

IRD

Ds2786TypeStatusConfigLdis Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusConfigLdis
Public Enumeration TypeStatusConfigLdis
public enum class TypeStatusConfigLdis
type TypeStatusConfigLdis
Members
Member name | Value | Description
CellCapacityLearningEnabled | 0 | Cell Capacity Learning: Enabled
CellCapacityLearningDisabled | 1 | Cell Capacity Learning: Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Ds2786.TypeStatusConfigPorf Enumeration

IRD

Ds2786TypeStatusConfigPorf Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusConfigPorf
Public Enumeration TypeStatusConfigPorf
public enum class TypeStatusConfigPorf
type TypeStatusConfigPorf
Members
Member name | Value | Description
InitialPowerUpEventNotOccurred | 0 | Initial Power-Up Event: Not Occurred
InitialPowerUpEventOccurred | 1 | Initial Power-Up Event: Occurred
See Also

Reference

telos.Ird.Maxim Namespace


Ds2786.TypeStatusConfigSmod Enumeration

IRD

Ds2786TypeStatusConfigSmod Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusConfigSmod
Public Enumeration TypeStatusConfigSmod
public enum class TypeStatusConfigSmod
type TypeStatusConfigSmod
Members
Member name | Value | Description
SleepModeDisable | 0 | Sleep Mode: Disable
SleepModeEnable | 1 | Sleep Mode: Enable
See Also

Reference

telos.Ird.Maxim Namespace


Ds2786.TypeStatusConfigVodis Enumeration

IRD

Ds2786TypeStatusConfigVodis Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusConfigVodis
Public Enumeration TypeStatusConfigVodis
public enum class TypeStatusConfigVodis
type TypeStatusConfigVodis
Members
Member name | Value | Description
VoutEnable | 0 | Vout Enable
VoutDisable | 1 | Vout Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds28cm00 Class

Maxim: DS 28CM00
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs28cm00

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds28cm00
Public Class Ds28cm00
public ref class Ds28cm00
type Ds28cm00 =  class end

The Ds28cm00 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds28cm00 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlCM | Control (CM)
Public property | CRCOfFamilyCodeAnd48BitSerialNumber | CRC of Family Code and 48-bit Serial Number
Public property | DeviceFamilyCode | Device Family Code
Public property | SerialNumberBits07 | Serial Number, Bits 0-7
Public property | SerialNumberBits1623 | Serial Number, Bits 16-23
Public property | SerialNumberBits2431 | Serial Number, Bits 24-31
Public property | SerialNumberBits3239 | Serial Number, Bits 32-39
Public property | SerialNumberBits4047 | Serial Number, Bits 40-47
Public property | SerialNumberBits815 | Serial Number, Bits 8-15
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
I2C/SMBus Silicon Serial Number
See Also

Reference

telos.Ird.Maxim Namespace


Ds28cm00 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds28cm00(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds28cm00(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds28cm00

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds28cm00 Class
telos.Ird.Maxim Namespace


Ds28cm00 Properties

The Ds28cm00 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlCM | Control (CM)
Public property | CRCOfFamilyCodeAnd48BitSerialNumber | CRC of Family Code and 48-bit Serial Number
Public property | DeviceFamilyCode | Device Family Code
Public property | SerialNumberBits07 | Serial Number, Bits 0-7
Public property | SerialNumberBits1623 | Serial Number, Bits 16-23
Public property | SerialNumberBits2431 | Serial Number, Bits 24-31
Public property | SerialNumberBits3239 | Serial Number, Bits 32-39
Public property | SerialNumberBits4047 | Serial Number, Bits 40-47
Public property | SerialNumberBits815 | Serial Number, Bits 8-15
Top
See Also

Reference

Ds28cm00 Class
telos.Ird.Maxim Namespace


Ds28cm00.AutoFlush Property

IRD

Ds28cm00AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds28cm00 Class
telos.Ird.Maxim Namespace


Ds28cm00.ControlCM Property

IRD

Ds28cm00ControlCM Property

Control (CM)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds28cm00TypeControlCm ControlCM { get; set; }
Public Property ControlCM As Ds28cm00TypeControlCm
    Get
    Set
public:
property Ds28cm00TypeControlCm ControlCM {
    Ds28cm00TypeControlCm get ();
    void set (Ds28cm00TypeControlCm value);
}
member ControlCM : Ds28cm00TypeControlCm with get, set

Property Value

Type: Ds28cm00TypeControlCm
See Also

Reference

Ds28cm00 Class
telos.Ird.Maxim Namespace


Ds28cm00.CRCOfFamilyCodeAnd48BitSerialNumber Property

IRD

Ds28cm00CRCOfFamilyCodeAnd48BitSerialNumber Property

CRC of Family Code and 48-bit Serial Number

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CRCOfFamilyCodeAnd48BitSerialNumber { get; }
Public ReadOnly Property CRCOfFamilyCodeAnd48BitSerialNumber As Byte
    Get
public:
property unsigned char CRCOfFamilyCodeAnd48BitSerialNumber {
    unsigned char get ();
}
member CRCOfFamilyCodeAnd48BitSerialNumber : byte with get

Property Value

Type: Byte
See Also

Reference

Ds28cm00 Class
telos.Ird.Maxim Namespace


Ds28cm00.DeviceFamilyCode Property

IRD

Ds28cm00DeviceFamilyCode Property

Device Family Code

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceFamilyCode { get; }
Public ReadOnly Property DeviceFamilyCode As Byte
    Get
public:
property unsigned char DeviceFamilyCode {
    unsigned char get ();
}
member DeviceFamilyCode : byte with get

Property Value

Type: Byte
See Also

Reference

Ds28cm00 Class
telos.Ird.Maxim Namespace


Ds28cm00.SerialNumberBits07 Property

IRD

Ds28cm00SerialNumberBits07 Property

Serial Number, Bits 0-7

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SerialNumberBits07 { get; }
Public ReadOnly Property SerialNumberBits07 As Byte
    Get
public:
property unsigned char SerialNumberBits07 {
    unsigned char get ();
}
member SerialNumberBits07 : byte with get

Property Value

Type: Byte
See Also

Reference

Ds28cm00 Class
telos.Ird.Maxim Namespace


Ds28cm00.SerialNumberBits1623 Property

IRD

Ds28cm00SerialNumberBits1623 Property

Serial Number, Bits 16-23

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SerialNumberBits1623 { get; }
Public ReadOnly Property SerialNumberBits1623 As Byte
    Get
public:
property unsigned char SerialNumberBits1623 {
    unsigned char get ();
}
member SerialNumberBits1623 : byte with get

Property Value

Type: Byte
See Also

Reference

Ds28cm00 Class
telos.Ird.Maxim Namespace


Ds28cm00.SerialNumberBits2431 Property

IRD

Ds28cm00SerialNumberBits2431 Property

Serial Number, Bits 24-31

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SerialNumberBits2431 { get; }
Public ReadOnly Property SerialNumberBits2431 As Byte
    Get
public:
property unsigned char SerialNumberBits2431 {
    unsigned char get ();
}
member SerialNumberBits2431 : byte with get

Property Value

Type: Byte
See Also

Reference

Ds28cm00 Class
telos.Ird.Maxim Namespace


Ds28cm00.SerialNumberBits3239 Property

IRD

Ds28cm00SerialNumberBits3239 Property

Serial Number, Bits 32-39

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SerialNumberBits3239 { get; }
Public ReadOnly Property SerialNumberBits3239 As Byte
    Get
public:
property unsigned char SerialNumberBits3239 {
    unsigned char get ();
}
member SerialNumberBits3239 : byte with get

Property Value

Type: Byte
See Also

Reference

Ds28cm00 Class
telos.Ird.Maxim Namespace


Ds28cm00.SerialNumberBits4047 Property

IRD

Ds28cm00SerialNumberBits4047 Property

Serial Number, Bits 40-47

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SerialNumberBits4047 { get; }
Public ReadOnly Property SerialNumberBits4047 As Byte
    Get
public:
property unsigned char SerialNumberBits4047 {
    unsigned char get ();
}
member SerialNumberBits4047 : byte with get

Property Value

Type: Byte
See Also

Reference

Ds28cm00 Class
telos.Ird.Maxim Namespace


Ds28cm00.SerialNumberBits815 Property

IRD

Ds28cm00SerialNumberBits815 Property

Serial Number, Bits 8-15

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SerialNumberBits815 { get; }
Public ReadOnly Property SerialNumberBits815 As Byte
    Get
public:
property unsigned char SerialNumberBits815 {
    unsigned char get ();
}
member SerialNumberBits815 : byte with get

Property Value

Type: Byte
See Also

Reference

Ds28cm00 Class
telos.Ird.Maxim Namespace


Ds28cm00 Methods

The Ds28cm00 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds28cm00 Class
telos.Ird.Maxim Namespace


Ds28cm00.Flush Method

IRD

Ds28cm00Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds28cm00 Class
telos.Ird.Maxim Namespace


Ds28cm00.TypeControlCm Enumeration

IRD

Ds28cm00TypeControlCm Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlCm
Public Enumeration TypeControlCm
public enum class TypeControlCm
type TypeControlCm
Members
Member name | Value | Description
I2CMode | 0 | I2C Mode
SMBusMode | 1 | SMBus Mode
See Also

Reference

telos.Ird.Maxim Namespace


Ds3231 Class

Maxim: DS 3231
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs3231

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds3231
Public Class Ds3231
public ref class Ds3231
type Ds3231 =  class end

The Ds3231 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds3231 | Constructor
Top
Properties
 | Name | Description
Public property | Alarm1Date | Alarm 1 Date
Public property | Alarm1DayDateSwitchDYDT | Alarm 1 Day Date Switch (DY/DT)
Public property | Alarm1FlagA1F | Alarm 1 Flag (A1F)
Public property | Alarm1Hours | Alarm 1 Hours (unit: hour)
Public property | Alarm1InterruptEnableA1IE | Alarm 1 Interrupt Enable (A1IE)
Public property | Alarm1Minutes | Alarm 1 Minutes (unit: min)
Public property | Alarm1Seconds | Alarm 1 Seconds (unit: s)
Public property | Alarm1Switch12To24Hours1224 | Alarm 1 Switch 12 To 24 Hours (12/24)
Public property | Alarm2Date | Alarm 2 Date
Public property | Alarm2DayDateSwitchDYDT | Alarm 2 Day Date Switch (DY/DT)
Public property | Alarm2FlagA2F | Alarm 2 Flag (A2F)
Public property | Alarm2Hours | Alarm 2 Hours (unit: hour)
Public property | Alarm2InterruptEnableA2IE | Alarm 2 Interrupt Enable (A2IE)
Public property | Alarm2Minutes | Alarm 2 Minutes (unit: min)
Public property | Alarm2Switch12To24Hours1224 | Alarm 2 Switch 12 To 24 Hours (12/24)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryBackedSquareWaveEnableBBSQW | Battery Backed Square Wave Enable (BBSQW)
Public property | BusyBSY | Busy (BSY)
Public property | ConvertTemperatureCONV | Convert Temperature (CONV)
Public property | CrystalAgingOffset | Crystal Aging Offset
Public property | Date | Date
Public property | Day | Day
Public property | Enable32kHzOutputEN32kHz | Enable 32kHz Output (EN32kHz)
Public property | EnableOscillatorEOSC | Enable Oscillator (EOSC)
Public property | Hours | Hours (unit: hour)
Public property | InterruptControlINTCN | Interrupt Control (INTCN)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | OscillatorStopFlagOSF | Oscillator Stop Flag (OSF)
Public property | RateSelectRSx | Rate Select (RSx) (unit: Hz)
Public property | Seconds | Seconds (unit: s)
Public property | Switch12To24Hours1224 | Switch 12 To 24 Hours (12/24)
Public property | TemperatureRegister | Temperature Register
Public property | Year | Year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Extremly Accurate RTC With TCXO
See Also

Reference

telos.Ird.Maxim Namespace


Ds3231 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds3231(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds3231(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds3231

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231 Properties

The Ds3231 type exposes the following members.

Properties
 | Name | Description
Public property | Alarm1Date | Alarm 1 Date
Public property | Alarm1DayDateSwitchDYDT | Alarm 1 Day Date Switch (DY/DT)
Public property | Alarm1FlagA1F | Alarm 1 Flag (A1F)
Public property | Alarm1Hours | Alarm 1 Hours (unit: hour)
Public property | Alarm1InterruptEnableA1IE | Alarm 1 Interrupt Enable (A1IE)
Public property | Alarm1Minutes | Alarm 1 Minutes (unit: min)
Public property | Alarm1Seconds | Alarm 1 Seconds (unit: s)
Public property | Alarm1Switch12To24Hours1224 | Alarm 1 Switch 12 To 24 Hours (12/24)
Public property | Alarm2Date | Alarm 2 Date
Public property | Alarm2DayDateSwitchDYDT | Alarm 2 Day Date Switch (DY/DT)
Public property | Alarm2FlagA2F | Alarm 2 Flag (A2F)
Public property | Alarm2Hours | Alarm 2 Hours (unit: hour)
Public property | Alarm2InterruptEnableA2IE | Alarm 2 Interrupt Enable (A2IE)
Public property | Alarm2Minutes | Alarm 2 Minutes (unit: min)
Public property | Alarm2Switch12To24Hours1224 | Alarm 2 Switch 12 To 24 Hours (12/24)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryBackedSquareWaveEnableBBSQW | Battery Backed Square Wave Enable (BBSQW)
Public property | BusyBSY | Busy (BSY)
Public property | ConvertTemperatureCONV | Convert Temperature (CONV)
Public property | CrystalAgingOffset | Crystal Aging Offset
Public property | Date | Date
Public property | Day | Day
Public property | Enable32kHzOutputEN32kHz | Enable 32kHz Output (EN32kHz)
Public property | EnableOscillatorEOSC | Enable Oscillator (EOSC)
Public property | Hours | Hours (unit: hour)
Public property | InterruptControlINTCN | Interrupt Control (INTCN)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | OscillatorStopFlagOSF | Oscillator Stop Flag (OSF)
Public property | RateSelectRSx | Rate Select (RSx) (unit: Hz)
Public property | Seconds | Seconds (unit: s)
Public property | Switch12To24Hours1224 | Switch 12 To 24 Hours (12/24)
Public property | TemperatureRegister | Temperature Register
Public property | Year | Year
Top
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Alarm1Date Property

IRD

Ds3231Alarm1Date Property

Alarm 1 Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm1Date { get; set; }
Public Property Alarm1Date As Byte
    Get
    Set
public:
property unsigned char Alarm1Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm1Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Alarm1DayDateSwitchDYDT Property

IRD

Ds3231Alarm1DayDateSwitchDYDT Property

Alarm 1 Day Date Switch (DY/DT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds3231DayDateType Alarm1DayDateSwitchDYDT { get; set; }
Public Property Alarm1DayDateSwitchDYDT As Ds3231DayDateType
    Get
    Set
public:
property Ds3231DayDateType Alarm1DayDateSwitchDYDT {
    Ds3231DayDateType get ();
    void set (Ds3231DayDateType value);
}
member Alarm1DayDateSwitchDYDT : Ds3231DayDateType with get, set

Property Value

Type: Ds3231DayDateType
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Alarm1FlagA1F Property

IRD

Ds3231Alarm1FlagA1F Property

Alarm 1 Flag (A1F)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds3231AlarmFlagType Alarm1FlagA1F { get; set; }
Public Property Alarm1FlagA1F As Ds3231AlarmFlagType
    Get
    Set
public:
property Ds3231AlarmFlagType Alarm1FlagA1F {
    Ds3231AlarmFlagType get ();
    void set (Ds3231AlarmFlagType value);
}
member Alarm1FlagA1F : Ds3231AlarmFlagType with get, set

Property Value

Type: Ds3231AlarmFlagType
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Alarm1Hours Property

IRD

Ds3231Alarm1Hours Property

Alarm 1 Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm1Hours { get; set; }
Public Property Alarm1Hours As Byte
    Get
    Set
public:
property unsigned char Alarm1Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm1Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Alarm1InterruptEnableA1IE Property

IRD

Ds3231Alarm1InterruptEnableA1IE Property

Alarm 1 Interrupt Enable (A1IE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds3231AlarmIntType Alarm1InterruptEnableA1IE { get; set; }
Public Property Alarm1InterruptEnableA1IE As Ds3231AlarmIntType
    Get
    Set
public:
property Ds3231AlarmIntType Alarm1InterruptEnableA1IE {
    Ds3231AlarmIntType get ();
    void set (Ds3231AlarmIntType value);
}
member Alarm1InterruptEnableA1IE : Ds3231AlarmIntType with get, set

Property Value

Type: Ds3231AlarmIntType
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Alarm1Minutes Property

IRD

Ds3231Alarm1Minutes Property

Alarm 1 Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm1Minutes { get; set; }
Public Property Alarm1Minutes As Byte
    Get
    Set
public:
property unsigned char Alarm1Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm1Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Alarm1Seconds Property

IRD

Ds3231Alarm1Seconds Property

Alarm 1 Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm1Seconds { get; set; }
Public Property Alarm1Seconds As Byte
    Get
    Set
public:
property unsigned char Alarm1Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm1Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Alarm1Switch12To24Hours1224 Property

IRD

Ds3231Alarm1Switch12To24Hours1224 Property

Alarm 1 Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds3231H1224Type Alarm1Switch12To24Hours1224 { get; set; }
Public Property Alarm1Switch12To24Hours1224 As Ds3231H1224Type
    Get
    Set
public:
property Ds3231H1224Type Alarm1Switch12To24Hours1224 {
    Ds3231H1224Type get ();
    void set (Ds3231H1224Type value);
}
member Alarm1Switch12To24Hours1224 : Ds3231H1224Type with get, set

Property Value

Type: Ds3231H1224Type
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Alarm2Date Property

IRD

Ds3231Alarm2Date Property

Alarm 2 Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm2Date { get; set; }
Public Property Alarm2Date As Byte
    Get
    Set
public:
property unsigned char Alarm2Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm2Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Alarm2DayDateSwitchDYDT Property

IRD

Ds3231Alarm2DayDateSwitchDYDT Property

Alarm 2 Day Date Switch (DY/DT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds3231DayDateType Alarm2DayDateSwitchDYDT { get; set; }
Public Property Alarm2DayDateSwitchDYDT As Ds3231DayDateType
    Get
    Set
public:
property Ds3231DayDateType Alarm2DayDateSwitchDYDT {
    Ds3231DayDateType get ();
    void set (Ds3231DayDateType value);
}
member Alarm2DayDateSwitchDYDT : Ds3231DayDateType with get, set

Property Value

Type: Ds3231DayDateType
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Alarm2FlagA2F Property

IRD

Ds3231Alarm2FlagA2F Property

Alarm 2 Flag (A2F)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds3231AlarmFlagType Alarm2FlagA2F { get; set; }
Public Property Alarm2FlagA2F As Ds3231AlarmFlagType
    Get
    Set
public:
property Ds3231AlarmFlagType Alarm2FlagA2F {
    Ds3231AlarmFlagType get ();
    void set (Ds3231AlarmFlagType value);
}
member Alarm2FlagA2F : Ds3231AlarmFlagType with get, set

Property Value

Type: Ds3231AlarmFlagType
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Alarm2Hours Property

IRD

Ds3231Alarm2Hours Property

Alarm 2 Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm2Hours { get; set; }
Public Property Alarm2Hours As Byte
    Get
    Set
public:
property unsigned char Alarm2Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm2Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Alarm2InterruptEnableA2IE Property

IRD

Ds3231Alarm2InterruptEnableA2IE Property

Alarm 2 Interrupt Enable (A2IE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds3231AlarmIntType Alarm2InterruptEnableA2IE { get; set; }
Public Property Alarm2InterruptEnableA2IE As Ds3231AlarmIntType
    Get
    Set
public:
property Ds3231AlarmIntType Alarm2InterruptEnableA2IE {
    Ds3231AlarmIntType get ();
    void set (Ds3231AlarmIntType value);
}
member Alarm2InterruptEnableA2IE : Ds3231AlarmIntType with get, set

Property Value

Type: Ds3231AlarmIntType
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Alarm2Minutes Property

IRD

Ds3231Alarm2Minutes Property

Alarm 2 Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Alarm2Minutes { get; set; }
Public Property Alarm2Minutes As Byte
    Get
    Set
public:
property unsigned char Alarm2Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Alarm2Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Alarm2Switch12To24Hours1224 Property

IRD

Ds3231Alarm2Switch12To24Hours1224 Property

Alarm 2 Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds3231H1224Type Alarm2Switch12To24Hours1224 { get; set; }
Public Property Alarm2Switch12To24Hours1224 As Ds3231H1224Type
    Get
    Set
public:
property Ds3231H1224Type Alarm2Switch12To24Hours1224 {
    Ds3231H1224Type get ();
    void set (Ds3231H1224Type value);
}
member Alarm2Switch12To24Hours1224 : Ds3231H1224Type with get, set

Property Value

Type: Ds3231H1224Type
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.AutoFlush Property

IRD

Ds3231AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.BatteryBackedSquareWaveEnableBBSQW Property

IRD

Ds3231BatteryBackedSquareWaveEnableBBSQW Property

Battery Backed Square Wave Enable (BBSQW)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds3231BbsqwType BatteryBackedSquareWaveEnableBBSQW { get; set; }
Public Property BatteryBackedSquareWaveEnableBBSQW As Ds3231BbsqwType
    Get
    Set
public:
property Ds3231BbsqwType BatteryBackedSquareWaveEnableBBSQW {
    Ds3231BbsqwType get ();
    void set (Ds3231BbsqwType value);
}
member BatteryBackedSquareWaveEnableBBSQW : Ds3231BbsqwType with get, set

Property Value

Type: Ds3231BbsqwType
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.BusyBSY Property

IRD

Ds3231BusyBSY Property

Busy (BSY)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds3231BusyType BusyBSY { get; set; }
Public Property BusyBSY As Ds3231BusyType
    Get
    Set
public:
property Ds3231BusyType BusyBSY {
    Ds3231BusyType get ();
    void set (Ds3231BusyType value);
}
member BusyBSY : Ds3231BusyType with get, set

Property Value

Type: Ds3231BusyType
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.ConvertTemperatureCONV Property

IRD

Ds3231ConvertTemperatureCONV Property

Convert Temperature (CONV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds3231ConvertType ConvertTemperatureCONV { get; set; }
Public Property ConvertTemperatureCONV As Ds3231ConvertType
    Get
    Set
public:
property Ds3231ConvertType ConvertTemperatureCONV {
    Ds3231ConvertType get ();
    void set (Ds3231ConvertType value);
}
member ConvertTemperatureCONV : Ds3231ConvertType with get, set

Property Value

Type: Ds3231ConvertType
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.CrystalAgingOffset Property

IRD

Ds3231CrystalAgingOffset Property

Crystal Aging Offset

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte CrystalAgingOffset { get; set; }
Public Property CrystalAgingOffset As SByte
    Get
    Set
public:
property signed char CrystalAgingOffset {
    signed char get ();
    void set (signed char value);
}
member CrystalAgingOffset : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Date Property

IRD

Ds3231Date Property

Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Date { get; set; }
Public Property Date As Byte
    Get
    Set
public:
property unsigned char Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Day Property

IRD

Ds3231Day Property

Day

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Day { get; set; }
Public Property Day As Byte
    Get
    Set
public:
property unsigned char Day {
    unsigned char get ();
    void set (unsigned char value);
}
member Day : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Enable32kHzOutputEN32kHz Property

IRD

Ds3231Enable32kHzOutputEN32kHz Property

Enable 32kHz Output (EN32kHz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds3231Enable32khzType Enable32kHzOutputEN32kHz { get; set; }
Public Property Enable32kHzOutputEN32kHz As Ds3231Enable32khzType
    Get
    Set
public:
property Ds3231Enable32khzType Enable32kHzOutputEN32kHz {
    Ds3231Enable32khzType get ();
    void set (Ds3231Enable32khzType value);
}
member Enable32kHzOutputEN32kHz : Ds3231Enable32khzType with get, set

Property Value

Type: Ds3231Enable32khzType
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.EnableOscillatorEOSC Property

IRD

Ds3231EnableOscillatorEOSC Property

Enable Oscillator (EOSC)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds3231EnableOscType EnableOscillatorEOSC { get; set; }
Public Property EnableOscillatorEOSC As Ds3231EnableOscType
    Get
    Set
public:
property Ds3231EnableOscType EnableOscillatorEOSC {
    Ds3231EnableOscType get ();
    void set (Ds3231EnableOscType value);
}
member EnableOscillatorEOSC : Ds3231EnableOscType with get, set

Property Value

Type: Ds3231EnableOscType
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Hours Property

IRD

Ds3231Hours Property

Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Hours { get; set; }
Public Property Hours As Byte
    Get
    Set
public:
property unsigned char Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.InterruptControlINTCN Property

IRD

Ds3231InterruptControlINTCN Property

Interrupt Control (INTCN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds3231InterruptControlType InterruptControlINTCN { get; set; }
Public Property InterruptControlINTCN As Ds3231InterruptControlType
    Get
    Set
public:
property Ds3231InterruptControlType InterruptControlINTCN {
    Ds3231InterruptControlType get ();
    void set (Ds3231InterruptControlType value);
}
member InterruptControlINTCN : Ds3231InterruptControlType with get, set

Property Value

Type: Ds3231InterruptControlType
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Minutes Property

IRD

Ds3231Minutes Property

Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Minutes { get; set; }
Public Property Minutes As Byte
    Get
    Set
public:
property unsigned char Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Month Property

IRD

Ds3231Month Property

Month

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Month { get; set; }
Public Property Month As Byte
    Get
    Set
public:
property unsigned char Month {
    unsigned char get ();
    void set (unsigned char value);
}
member Month : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.OscillatorStopFlagOSF Property

IRD

Ds3231OscillatorStopFlagOSF Property

Oscillator Stop Flag (OSF)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds3231OscStopType OscillatorStopFlagOSF { get; set; }
Public Property OscillatorStopFlagOSF As Ds3231OscStopType
    Get
    Set
public:
property Ds3231OscStopType OscillatorStopFlagOSF {
    Ds3231OscStopType get ();
    void set (Ds3231OscStopType value);
}
member OscillatorStopFlagOSF : Ds3231OscStopType with get, set

Property Value

Type: Ds3231OscStopType
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.RateSelectRSx Property

IRD

Ds3231RateSelectRSx Property

Rate Select (RSx) (unit: Hz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds3231RateType RateSelectRSx { get; set; }
Public Property RateSelectRSx As Ds3231RateType
    Get
    Set
public:
property Ds3231RateType RateSelectRSx {
    Ds3231RateType get ();
    void set (Ds3231RateType value);
}
member RateSelectRSx : Ds3231RateType with get, set

Property Value

Type: Ds3231RateType
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Seconds Property

IRD

Ds3231Seconds Property

Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Seconds { get; set; }
Public Property Seconds As Byte
    Get
    Set
public:
property unsigned char Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Switch12To24Hours1224 Property

IRD

Ds3231Switch12To24Hours1224 Property

Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds3231H1224Type Switch12To24Hours1224 { get; set; }
Public Property Switch12To24Hours1224 As Ds3231H1224Type
    Get
    Set
public:
property Ds3231H1224Type Switch12To24Hours1224 {
    Ds3231H1224Type get ();
    void set (Ds3231H1224Type value);
}
member Switch12To24Hours1224 : Ds3231H1224Type with get, set

Property Value

Type: Ds3231H1224Type
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.TemperatureRegister Property

IRD

Ds3231TemperatureRegister Property

Temperature Register

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short TemperatureRegister { get; set; }
Public Property TemperatureRegister As Short
    Get
    Set
public:
property short TemperatureRegister {
    short get ();
    void set (short value);
}
member TemperatureRegister : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Year Property

IRD

Ds3231Year Property

Year

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Year { get; set; }
Public Property Year As Byte
    Get
    Set
public:
property unsigned char Year {
    unsigned char get ();
    void set (unsigned char value);
}
member Year : byte with get, set

Property Value

Type: Byte
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231 Methods

The Ds3231 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.Flush Method

IRD

Ds3231Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds3231 Class
telos.Ird.Maxim Namespace


Ds3231.AlarmFlagType Enumeration

IRD

Ds3231AlarmFlagType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmFlagType
Public Enumeration AlarmFlagType
public enum class AlarmFlagType
type AlarmFlagType
Members
Member name | Value | Description
TimeMatchedAlarm | 1 | Time Matched Alarm
NoTimeMatchAlarm | 0 | No Time Match Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Ds3231.AlarmIntType Enumeration

IRD

Ds3231AlarmIntType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmIntType
Public Enumeration AlarmIntType
public enum class AlarmIntType
type AlarmIntType
Members
Member name | Value | Description
AlarmInterruptEnable | 1 | Alarm Interrupt: Enable
AlarmInterruptDisable | 0 | Alarm Interrupt: Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds3231.AlarmMask1Type Enumeration

IRD

Ds3231AlarmMask1Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmMask1Type
Public Enumeration AlarmMask1Type
public enum class AlarmMask1Type
type AlarmMask1Type
Members
Member name | Value | Description
AlarmOncePerSecond | 15 | Alarm Once Per Second
AlarmOncePerSecond__1 | 31 | Alarm Once Per Second
AlarmWhenSecondsMatch | 14 | Alarm When Seconds Match
AlarmWhenSecondsMatch__1 | 30 | Alarm When Seconds Match
AlarmWhenMinutesMatch | 12 | Alarm When Minutes Match
AlarmWhenMinutesMatch__1 | 28 | Alarm When Minutes Match
AlarmWhenHoursMatch | 8 | Alarm When Hours Match
AlarmWhenHoursMatch__1 | 24 | Alarm When Hours Match
AlarmWhenDateMatch | 0 | Alarm When Date Match
AlarmWhenDayMatch | 16 | Alarm When Day Match
Reserved | 1 | Reserved
Reserved__1 | 9 | Reserved
Reserved__2 | 13 | Reserved
Reserved__3 | 17 | Reserved
Reserved__4 | 25 | Reserved
Reserved__5 | 29 | Reserved
See Also

Reference

telos.Ird.Maxim Namespace


Ds3231.AlarmMask2Type Enumeration

IRD

Ds3231AlarmMask2Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmMask2Type
Public Enumeration AlarmMask2Type
public enum class AlarmMask2Type
type AlarmMask2Type
Members
Member name | Value | Description
AlarmOncePerMinute | 7 | Alarm Once Per Minute
AlarmOncePerMinute__1 | 15 | Alarm Once Per Minute
AlarmWhenMinutesMatch | 6 | Alarm When Minutes Match
AlarmWhenMinutesMatch__1 | 14 | Alarm When Minutes Match
AlarmWhenHoursMatch | 4 | Alarm When Hours Match
AlarmWhenHoursMatch__1 | 12 | Alarm When Hours Match
AlarmWhenDateMatch | 0 | Alarm When Date Match
AlarmWhenDayMatch | 8 | Alarm When Day Match
Reserved | 2 | Reserved
Reserved__1 | 5 | Reserved
Reserved__2 | 9 | Reserved
Reserved__3 | 13 | Reserved
See Also

Reference

telos.Ird.Maxim Namespace


Ds3231.BbsqwType Enumeration

IRD

Ds3231BbsqwType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum BbsqwType
Public Enumeration BbsqwType
public enum class BbsqwType
type BbsqwType
Members
Member name | Value | Description
BBSQWEnable | 1 | BBSQW Enable
BBSQWDisable | 0 | BBSQW Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds3231.BusyType Enumeration

IRD

Ds3231BusyType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum BusyType
Public Enumeration BusyType
public enum class BusyType
type BusyType
Members
Member name | Value | Description
BusyExecutingTCXOFunction | 1 | Busy: Executing TCXO Function
Value_1MinuteIdleState | 0 | 1 Minute Idle State
See Also

Reference

telos.Ird.Maxim Namespace


Ds3231.ConvertType Enumeration

IRD

Ds3231ConvertType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConvertType
Public Enumeration ConvertType
public enum class ConvertType
type ConvertType
Members
Member name | Value | Description
ConvertTemperature | 1 | Convert Temperature
NoConvertTemperature | 0 | No Convert Temperature
See Also

Reference

telos.Ird.Maxim Namespace


Ds3231.DayDateType Enumeration

IRD

Ds3231DayDateType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DayDateType
Public Enumeration DayDateType
public enum class DayDateType
type DayDateType
Members
Member name | Value | Description
Day | 1 | Day
Date | 0 | Date
See Also

Reference

telos.Ird.Maxim Namespace


Ds3231.Enable32khzType Enumeration

IRD

Ds3231Enable32khzType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Enable32khzType
Public Enumeration Enable32khzType
public enum class Enable32khzType
type Enable32khzType
Members
Member name | Value | Description
Value_32kHzSQWOutputEnable | 1 | 32kHz SQW Output Enable
Value_32kHzSQWOutputDisable | 0 | 32kHz SQW Output Disable
See Also

Reference

telos.Ird.Maxim Namespace


Ds3231.EnableOscType Enumeration

IRD

Ds3231EnableOscType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum EnableOscType
Public Enumeration EnableOscType
public enum class EnableOscType
type EnableOscType
Members
Member name | Value | Description
StopOscillator | 1 | Stop Oscillator
StartOscillator | 0 | Start Oscillator
See Also

Reference

telos.Ird.Maxim Namespace


Ds3231.H1224Type Enumeration

IRD

Ds3231H1224Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum H1224Type
Public Enumeration H1224Type
public enum class H1224Type
type H1224Type
Members
Member name | Value | Description
Value_12Hours | 1 | 12 Hours
Value_24Hours | 0 | 24 Hours
See Also

Reference

telos.Ird.Maxim Namespace


Ds3231.InterruptControlType Enumeration

IRD

Ds3231InterruptControlType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum InterruptControlType
Public Enumeration InterruptControlType
public enum class InterruptControlType
type InterruptControlType
Members
Member name | Value | Description
AlarmActivatesINTSQW | 1 | Alarm Activates INT/SQW
SquareWaveOutputAtINTSQW | 0 | Square Wave Output At INT/SQW
See Also

Reference

telos.Ird.Maxim Namespace


Ds3231.OscStopType Enumeration

IRD

Ds3231OscStopType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum OscStopType
Public Enumeration OscStopType
public enum class OscStopType
type OscStopType
Members
Member name | Value | Description
OscillatorStopFlagOSCStop | 1 | Oscillator Stop Flag: OSC Stop
OscillatorStopFlagOSCRunning | 0 | Oscillator Stop Flag: OSC Running
See Also

Reference

telos.Ird.Maxim Namespace


Ds3231.RateType Enumeration

IRD

Ds3231RateType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum RateType
Public Enumeration RateType
public enum class RateType
type RateType
Members
Member name | Value | Description
Value_8192 | 3 | 8192
Value_4096 | 2 | 4096
Value_1024 | 1 | 1024
Value_1 | 0 | 1
See Also

Reference

telos.Ird.Maxim Namespace


Ds75 Class

Maxim: DS 75
Inheritance Hierarchy
SystemObject
telos.Ird.MaximDs75

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ds75
Public Class Ds75
public ref class Ds75
type Ds75 =  class end

The Ds75 type exposes the following members.

Constructors
 | Name | Description
Public method | Ds75 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConversionResolution | Conversion Resolution (unit: bit)
Public property | Shutdown | Shutdown
Public property | Temperature | Temperature (unit: °C)
Public property | ThermostatFaultTolerance | Thermostat Fault Tolerance
Public property | ThermostatOperatingMode | Thermostat Operating Mode
Public property | ThermostatOutputOSPolarity | Thermostat Output (O.S.) Polarity
Public property | THYST | T_HYST (unit: °C)
Public property | TOS | T_OS (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Digital Thermometer And Thermostat
See Also

Reference

telos.Ird.Maxim Namespace


Ds75 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds75(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ds75(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ds75

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ds75 Class
telos.Ird.Maxim Namespace


Ds75 Properties

The Ds75 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConversionResolution | Conversion Resolution (unit: bit)
Public property | Shutdown | Shutdown
Public property | Temperature | Temperature (unit: °C)
Public property | ThermostatFaultTolerance | Thermostat Fault Tolerance
Public property | ThermostatOperatingMode | Thermostat Operating Mode
Public property | ThermostatOutputOSPolarity | Thermostat Output (O.S.) Polarity
Public property | THYST | T_HYST (unit: °C)
Public property | TOS | T_OS (unit: °C)
Top
See Also

Reference

Ds75 Class
telos.Ird.Maxim Namespace


Ds75.AutoFlush Property

IRD

Ds75AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ds75 Class
telos.Ird.Maxim Namespace


Ds75.ConversionResolution Property

IRD

Ds75ConversionResolution Property

Conversion Resolution (unit: bit)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds75ConfigConversionType ConversionResolution { get; set; }
Public Property ConversionResolution As Ds75ConfigConversionType
    Get
    Set
public:
property Ds75ConfigConversionType ConversionResolution {
    Ds75ConfigConversionType get ();
    void set (Ds75ConfigConversionType value);
}
member ConversionResolution : Ds75ConfigConversionType with get, set

Property Value

Type: Ds75ConfigConversionType
See Also

Reference

Ds75 Class
telos.Ird.Maxim Namespace


Ds75.Shutdown Property

IRD

Ds75Shutdown Property

Shutdown

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds75ConfigShutdownType Shutdown { get; set; }
Public Property Shutdown As Ds75ConfigShutdownType
    Get
    Set
public:
property Ds75ConfigShutdownType Shutdown {
    Ds75ConfigShutdownType get ();
    void set (Ds75ConfigShutdownType value);
}
member Shutdown : Ds75ConfigShutdownType with get, set

Property Value

Type: Ds75ConfigShutdownType
See Also

Reference

Ds75 Class
telos.Ird.Maxim Namespace


Ds75.Temperature Property

IRD

Ds75Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Ds75 Class
telos.Ird.Maxim Namespace


Ds75.ThermostatFaultTolerance Property

IRD

Ds75ThermostatFaultTolerance Property

Thermostat Fault Tolerance

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds75ConfigFaultType ThermostatFaultTolerance { get; set; }
Public Property ThermostatFaultTolerance As Ds75ConfigFaultType
    Get
    Set
public:
property Ds75ConfigFaultType ThermostatFaultTolerance {
    Ds75ConfigFaultType get ();
    void set (Ds75ConfigFaultType value);
}
member ThermostatFaultTolerance : Ds75ConfigFaultType with get, set

Property Value

Type: Ds75ConfigFaultType
See Also

Reference

Ds75 Class
telos.Ird.Maxim Namespace


Ds75.ThermostatOperatingMode Property

IRD

Ds75ThermostatOperatingMode Property

Thermostat Operating Mode

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds75ConfigOpModeType ThermostatOperatingMode { get; set; }
Public Property ThermostatOperatingMode As Ds75ConfigOpModeType
    Get
    Set
public:
property Ds75ConfigOpModeType ThermostatOperatingMode {
    Ds75ConfigOpModeType get ();
    void set (Ds75ConfigOpModeType value);
}
member ThermostatOperatingMode : Ds75ConfigOpModeType with get, set

Property Value

Type: Ds75ConfigOpModeType
See Also

Reference

Ds75 Class
telos.Ird.Maxim Namespace


Ds75.ThermostatOutputOSPolarity Property

IRD

Ds75ThermostatOutputOSPolarity Property

Thermostat Output (O.S.) Polarity

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ds75ConfigPolType ThermostatOutputOSPolarity { get; set; }
Public Property ThermostatOutputOSPolarity As Ds75ConfigPolType
    Get
    Set
public:
property Ds75ConfigPolType ThermostatOutputOSPolarity {
    Ds75ConfigPolType get ();
    void set (Ds75ConfigPolType value);
}
member ThermostatOutputOSPolarity : Ds75ConfigPolType with get, set

Property Value

Type: Ds75ConfigPolType
See Also

Reference

Ds75 Class
telos.Ird.Maxim Namespace


Ds75.THYST Property

IRD

Ds75THYST Property

T_HYST (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double THYST { get; set; }
Public Property THYST As Double
    Get
    Set
public:
property double THYST {
    double get ();
    void set (double value);
}
member THYST : float with get, set

Property Value

Type: Double
See Also

Reference

Ds75 Class
telos.Ird.Maxim Namespace


Ds75.TOS Property

IRD

Ds75TOS Property

T_OS (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TOS { get; set; }
Public Property TOS As Double
    Get
    Set
public:
property double TOS {
    double get ();
    void set (double value);
}
member TOS : float with get, set

Property Value

Type: Double
See Also

Reference

Ds75 Class
telos.Ird.Maxim Namespace


Ds75 Methods

The Ds75 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ds75 Class
telos.Ird.Maxim Namespace


Ds75.Flush Method

IRD

Ds75Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ds75 Class
telos.Ird.Maxim Namespace


Ds75.ConfigConversionType Enumeration

IRD

Ds75ConfigConversionType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigConversionType
Public Enumeration ConfigConversionType
public enum class ConfigConversionType
type ConfigConversionType
Members
Member name | Value | Description
Value_9 | 0 | 9
Value_10 | 1 | 10
Value_11 | 2 | 11
Value_12 | 3 | 12
See Also

Reference

telos.Ird.Maxim Namespace


Ds75.ConfigFaultType Enumeration

IRD

Ds75ConfigFaultType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigFaultType
Public Enumeration ConfigFaultType
public enum class ConfigFaultType
type ConfigFaultType
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_2 | 1 | 2
Value_4 | 2 | 4
Value_6 | 3 | 6
See Also

Reference

telos.Ird.Maxim Namespace


Ds75.ConfigOpModeType Enumeration

IRD

Ds75ConfigOpModeType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigOpModeType
Public Enumeration ConfigOpModeType
public enum class ConfigOpModeType
type ConfigOpModeType
Members
Member name | Value | Description
ComparatorMode | 0 | Comparator Mode
InterruptMode | 1 | Interrupt Mode
See Also

Reference

telos.Ird.Maxim Namespace


Ds75.ConfigPolType Enumeration

IRD

Ds75ConfigPolType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigPolType
Public Enumeration ConfigPolType
public enum class ConfigPolType
type ConfigPolType
Members
Member name | Value | Description
OSActiveLow | 0 | O.S.: Active Low
OSActiveHigh | 1 | O.S.: Active High
See Also

Reference

telos.Ird.Maxim Namespace


Ds75.ConfigShutdownType Enumeration

IRD

Ds75ConfigShutdownType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigShutdownType
Public Enumeration ConfigShutdownType
public enum class ConfigShutdownType
type ConfigShutdownType
Members
Member name | Value | Description
ActiveConversionThermostatOperation | 0 | Active Conversion / Thermostat Operation
ShutdownMode | 1 | Shutdown Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max11801 Class

Maxim: MAX 11801
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax11801

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max11801
Public Class Max11801
public ref class Max11801
type Max11801 =  class end

The Max11801 type exposes the following members.

Constructors
 | Name | Description
Public method | Max11801 | Constructor
Top
Properties
 | Name | Description
Public property | ADCSamplingTimeTSAMPLEX | ADC Sampling Time: T_SAMPLE_X
Public property | ADCSamplingTimeTSAMPLEY | ADC Sampling Time: T_SAMPLE_Y
Public property | ADCSamplingTimeTSAMPLEZ1 | ADC Sampling Time: T_SAMPLE_Z1
Public property | ADCSamplingTimeTSAMPLEZ2 | ADC Sampling Time: T_SAMPLE_Z2
Public property | ApertureConfigurationAPRX | Aperture Configuration: APRX
Public property | ApertureConfigurationAPRY | Aperture Configuration: APRY
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AutonomousConversionMode | Autonomous Conversion Mode
Public property | AutonomousModeSCANP | Autonomous Mode: SCANP
Public property | AutonomousModeTINIT | Autonomous Mode: TINIT
Public property | AUXConversion | AUX Conversion
Public property | AuxiliaryMeasurementAVGA | Auxiliary Measurement: AVGA
Public property | AuxiliaryMeasurementDCVA | Auxiliary Measurement: D_CV_A
Public property | AuxiliaryMeasurementRESA | Auxiliary Measurement: RESA
Public property | AuxiliaryMeasurementTSAMPLEA | Auxiliary Measurement: T_SAMPLE_A
Public property | DelayConversionDCVZ | Delay Conversion: D_CV_Z
Public property | DelayedConversionDCVXY | Delayed Conversion: D_CV_XY
Public property | DirectConversionModeAUX | Direct Conversion Mode: AUX
Public property | DirectConversionModeX | Direct Conversion Mode: X
Public property | DirectConversionModeY | Direct Conversion Mode: Y
Public property | DirectConversionModeZ1 | Direct Conversion Mode: Z1
Public property | DirectConversionModeZ2 | Direct Conversion Mode: Z2
Public property | GeneralConfigurationEDGEIRQ | General Configuration: EDGE_IRQ
Public property | GeneralConfigurationEDGETIME | General Configuration: EDGE_TIME
Public property | GeneralConfigurationHOLDDO | General Configuration: HOLD_DO
Public property | GeneralConfigurationMASKIRQ | General Configuration: MASK_IRQ
Public property | GeneralConfigurationODNIRQ | General Configuration: ODN_IRQ
Public property | GeneralConfigurationPUIRQ | General Configuration: PU_IRQ
Public property | GeneralConfigurationRTSEL | General Configuration: RT_SEL
Public property | GeneralStatusADCBUSY | General Status: ADC_BUSY
Public property | GeneralStatusCONTINT | General Status: CONT_INT
Public property | GeneralStatusEDGEINT | General Status: EDGE_INT
Public property | GeneralStatusFIFOINT | General Status: FIFO_INT
Public property | GeneralStatusFIFOOVR | General Status: FIFO_OVR
Public property | GeneralStatusLPM | General Status: LPM
Public property | GeneralStatusSCAN | General Status: SCAN
Public property | GeneralStatusTDM | General Status: TDM
Public property | MeasurementAveragingAVGX | Measurement Averaging: AVG_X
Public property | MeasurementAveragingAVGY | Measurement Averaging: AVG_Y
Public property | MeasurementAveragingAVGZ1 | Measurement Averaging: AVG_Z1
Public property | MeasurementAveragingAVGZ2 | Measurement Averaging: AVG_Z2
Public property | MeasurementResolutionPWRSAV | Measurement Resolution: PWR_SAV
Public property | MeasurementResolutionRESX | Measurement Resolution: RESX
Public property | MeasurementResolutionRESY | Measurement Resolution: RESY
Public property | MeasurementResolutionRESZ1 | Measurement Resolution: RESZ1
Public property | MeasurementResolutionRESZ2 | Measurement Resolution: RESZ2
Public property | OperatingModeAMODE | Operating Mode: AMODE
Public property | OperatingModeAPER | Operating Mode: APER
Public property | OperatingModeAVGFLT | Operating Mode: AVG_FLT
Public property | OperatingModeENAVGXY | Operating Mode: EN_AVG_XY
Public property | OperatingModeENAVGZ | Operating Mode: EN_AVG_Z
Public property | OperatingModePWRDN | Operating Mode: PWRDN
Public property | PanelSetupTimingPSUXY | Panel Setup Timing: PSUXY
Public property | PanelSetupTimingPSUZ | Panel Setup Timing: PSUZ
Public property | TouchDetectPullupPUF | Touch Detect Pullup: PUF
Public property | TouchDetectPullupPUR | Touch Detect Pullup: PUR
Public property | XMeasurementCONT0 | X Measurement CONT0
Public property | XMeasurementCONT1 | X Measurement CONT1
Public property | XPanelSetup | X Panel Setup
Public property | XYCombinedCommand | XY Combined Command
Public property | XYZ1CombinedCommand | XYZ1 Combined Command
Public property | XYZ1Z2CombinedCommand | XYZ1Z2 Combined Command
Public property | YMeasurementCONT0 | Y Measurement CONT0
Public property | YMeasurementCONT1 | Y Measurement CONT1
Public property | YPanelSetup | Y Panel Setup
Public property | Z1MeasurementCONT0 | Z1 Measurement CONT0
Public property | Z1MeasurementCONT1 | Z1 Measurement CONT1
Public property | Z1PanelSetup | Z1 Panel Setup
Public property | Z2MeasurementCONT0 | Z2 Measurement CONT0
Public property | Z2MeasurementCONT1 | Z2 Measurement CONT1
Public property | Z2PanelSetup | Z2 Panel Setup
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Ultra-Small ResistiveTouch-Screen Controller
See Also

Reference

telos.Ird.Maxim Namespace


Max11801 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max11801(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max11801

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801 Properties

The Max11801 type exposes the following members.

Properties
 | Name | Description
Public property | ADCSamplingTimeTSAMPLEX | ADC Sampling Time: T_SAMPLE_X
Public property | ADCSamplingTimeTSAMPLEY | ADC Sampling Time: T_SAMPLE_Y
Public property | ADCSamplingTimeTSAMPLEZ1 | ADC Sampling Time: T_SAMPLE_Z1
Public property | ADCSamplingTimeTSAMPLEZ2 | ADC Sampling Time: T_SAMPLE_Z2
Public property | ApertureConfigurationAPRX | Aperture Configuration: APRX
Public property | ApertureConfigurationAPRY | Aperture Configuration: APRY
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AutonomousConversionMode | Autonomous Conversion Mode
Public property | AutonomousModeSCANP | Autonomous Mode: SCANP
Public property | AutonomousModeTINIT | Autonomous Mode: TINIT
Public property | AUXConversion | AUX Conversion
Public property | AuxiliaryMeasurementAVGA | Auxiliary Measurement: AVGA
Public property | AuxiliaryMeasurementDCVA | Auxiliary Measurement: D_CV_A
Public property | AuxiliaryMeasurementRESA | Auxiliary Measurement: RESA
Public property | AuxiliaryMeasurementTSAMPLEA | Auxiliary Measurement: T_SAMPLE_A
Public property | DelayConversionDCVZ | Delay Conversion: D_CV_Z
Public property | DelayedConversionDCVXY | Delayed Conversion: D_CV_XY
Public property | DirectConversionModeAUX | Direct Conversion Mode: AUX
Public property | DirectConversionModeX | Direct Conversion Mode: X
Public property | DirectConversionModeY | Direct Conversion Mode: Y
Public property | DirectConversionModeZ1 | Direct Conversion Mode: Z1
Public property | DirectConversionModeZ2 | Direct Conversion Mode: Z2
Public property | GeneralConfigurationEDGEIRQ | General Configuration: EDGE_IRQ
Public property | GeneralConfigurationEDGETIME | General Configuration: EDGE_TIME
Public property | GeneralConfigurationHOLDDO | General Configuration: HOLD_DO
Public property | GeneralConfigurationMASKIRQ | General Configuration: MASK_IRQ
Public property | GeneralConfigurationODNIRQ | General Configuration: ODN_IRQ
Public property | GeneralConfigurationPUIRQ | General Configuration: PU_IRQ
Public property | GeneralConfigurationRTSEL | General Configuration: RT_SEL
Public property | GeneralStatusADCBUSY | General Status: ADC_BUSY
Public property | GeneralStatusCONTINT | General Status: CONT_INT
Public property | GeneralStatusEDGEINT | General Status: EDGE_INT
Public property | GeneralStatusFIFOINT | General Status: FIFO_INT
Public property | GeneralStatusFIFOOVR | General Status: FIFO_OVR
Public property | GeneralStatusLPM | General Status: LPM
Public property | GeneralStatusSCAN | General Status: SCAN
Public property | GeneralStatusTDM | General Status: TDM
Public property | MeasurementAveragingAVGX | Measurement Averaging: AVG_X
Public property | MeasurementAveragingAVGY | Measurement Averaging: AVG_Y
Public property | MeasurementAveragingAVGZ1 | Measurement Averaging: AVG_Z1
Public property | MeasurementAveragingAVGZ2 | Measurement Averaging: AVG_Z2
Public property | MeasurementResolutionPWRSAV | Measurement Resolution: PWR_SAV
Public property | MeasurementResolutionRESX | Measurement Resolution: RESX
Public property | MeasurementResolutionRESY | Measurement Resolution: RESY
Public property | MeasurementResolutionRESZ1 | Measurement Resolution: RESZ1
Public property | MeasurementResolutionRESZ2 | Measurement Resolution: RESZ2
Public property | OperatingModeAMODE | Operating Mode: AMODE
Public property | OperatingModeAPER | Operating Mode: APER
Public property | OperatingModeAVGFLT | Operating Mode: AVG_FLT
Public property | OperatingModeENAVGXY | Operating Mode: EN_AVG_XY
Public property | OperatingModeENAVGZ | Operating Mode: EN_AVG_Z
Public property | OperatingModePWRDN | Operating Mode: PWRDN
Public property | PanelSetupTimingPSUXY | Panel Setup Timing: PSUXY
Public property | PanelSetupTimingPSUZ | Panel Setup Timing: PSUZ
Public property | TouchDetectPullupPUF | Touch Detect Pullup: PUF
Public property | TouchDetectPullupPUR | Touch Detect Pullup: PUR
Public property | XMeasurementCONT0 | X Measurement CONT0
Public property | XMeasurementCONT1 | X Measurement CONT1
Public property | XPanelSetup | X Panel Setup
Public property | XYCombinedCommand | XY Combined Command
Public property | XYZ1CombinedCommand | XYZ1 Combined Command
Public property | XYZ1Z2CombinedCommand | XYZ1Z2 Combined Command
Public property | YMeasurementCONT0 | Y Measurement CONT0
Public property | YMeasurementCONT1 | Y Measurement CONT1
Public property | YPanelSetup | Y Panel Setup
Public property | Z1MeasurementCONT0 | Z1 Measurement CONT0
Public property | Z1MeasurementCONT1 | Z1 Measurement CONT1
Public property | Z1PanelSetup | Z1 Panel Setup
Public property | Z2MeasurementCONT0 | Z2 Measurement CONT0
Public property | Z2MeasurementCONT1 | Z2 Measurement CONT1
Public property | Z2PanelSetup | Z2 Panel Setup
Top
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.ADCSamplingTimeTSAMPLEX Property

IRD

Max11801ADCSamplingTimeTSAMPLEX Property

ADC Sampling Time: T_SAMPLE_X

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeAdcSamplingTime ADCSamplingTimeTSAMPLEX { get; set; }
Public Property ADCSamplingTimeTSAMPLEX As Max11801TypeAdcSamplingTime
    Get
    Set
public:
property Max11801TypeAdcSamplingTime ADCSamplingTimeTSAMPLEX {
    Max11801TypeAdcSamplingTime get ();
    void set (Max11801TypeAdcSamplingTime value);
}
member ADCSamplingTimeTSAMPLEX : Max11801TypeAdcSamplingTime with get, set

Property Value

Type: Max11801TypeAdcSamplingTime
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.ADCSamplingTimeTSAMPLEY Property

IRD

Max11801ADCSamplingTimeTSAMPLEY Property

ADC Sampling Time: T_SAMPLE_Y

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeAdcSamplingTime ADCSamplingTimeTSAMPLEY { get; set; }
Public Property ADCSamplingTimeTSAMPLEY As Max11801TypeAdcSamplingTime
    Get
    Set
public:
property Max11801TypeAdcSamplingTime ADCSamplingTimeTSAMPLEY {
    Max11801TypeAdcSamplingTime get ();
    void set (Max11801TypeAdcSamplingTime value);
}
member ADCSamplingTimeTSAMPLEY : Max11801TypeAdcSamplingTime with get, set

Property Value

Type: Max11801TypeAdcSamplingTime
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.ADCSamplingTimeTSAMPLEZ1 Property

IRD

Max11801ADCSamplingTimeTSAMPLEZ1 Property

ADC Sampling Time: T_SAMPLE_Z1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeAdcSamplingTime ADCSamplingTimeTSAMPLEZ1 { get; set; }
Public Property ADCSamplingTimeTSAMPLEZ1 As Max11801TypeAdcSamplingTime
    Get
    Set
public:
property Max11801TypeAdcSamplingTime ADCSamplingTimeTSAMPLEZ1 {
    Max11801TypeAdcSamplingTime get ();
    void set (Max11801TypeAdcSamplingTime value);
}
member ADCSamplingTimeTSAMPLEZ1 : Max11801TypeAdcSamplingTime with get, set

Property Value

Type: Max11801TypeAdcSamplingTime
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.ADCSamplingTimeTSAMPLEZ2 Property

IRD

Max11801ADCSamplingTimeTSAMPLEZ2 Property

ADC Sampling Time: T_SAMPLE_Z2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeAdcSamplingTime ADCSamplingTimeTSAMPLEZ2 { get; set; }
Public Property ADCSamplingTimeTSAMPLEZ2 As Max11801TypeAdcSamplingTime
    Get
    Set
public:
property Max11801TypeAdcSamplingTime ADCSamplingTimeTSAMPLEZ2 {
    Max11801TypeAdcSamplingTime get ();
    void set (Max11801TypeAdcSamplingTime value);
}
member ADCSamplingTimeTSAMPLEZ2 : Max11801TypeAdcSamplingTime with get, set

Property Value

Type: Max11801TypeAdcSamplingTime
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.ApertureConfigurationAPRX Property

IRD

Max11801ApertureConfigurationAPRX Property

Aperture Configuration: APRX

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeApertureConfiguration ApertureConfigurationAPRX { get; set; }
Public Property ApertureConfigurationAPRX As Max11801TypeApertureConfiguration
    Get
    Set
public:
property Max11801TypeApertureConfiguration ApertureConfigurationAPRX {
    Max11801TypeApertureConfiguration get ();
    void set (Max11801TypeApertureConfiguration value);
}
member ApertureConfigurationAPRX : Max11801TypeApertureConfiguration with get, set

Property Value

Type: Max11801TypeApertureConfiguration
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.ApertureConfigurationAPRY Property

IRD

Max11801ApertureConfigurationAPRY Property

Aperture Configuration: APRY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeApertureConfiguration ApertureConfigurationAPRY { get; set; }
Public Property ApertureConfigurationAPRY As Max11801TypeApertureConfiguration
    Get
    Set
public:
property Max11801TypeApertureConfiguration ApertureConfigurationAPRY {
    Max11801TypeApertureConfiguration get ();
    void set (Max11801TypeApertureConfiguration value);
}
member ApertureConfigurationAPRY : Max11801TypeApertureConfiguration with get, set

Property Value

Type: Max11801TypeApertureConfiguration
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.AutoFlush Property

IRD

Max11801AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.AutonomousConversionMode Property

IRD

Max11801AutonomousConversionMode Property

Autonomous Conversion Mode

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AutonomousConversionMode { get; }
Public ReadOnly Property AutonomousConversionMode As Byte
    Get
public:
property unsigned char AutonomousConversionMode {
    unsigned char get ();
}
member AutonomousConversionMode : byte with get

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.AutonomousModeSCANP Property

IRD

Max11801AutonomousModeSCANP Property

Autonomous Mode: SCANP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeAutonomousMode AutonomousModeSCANP { get; set; }
Public Property AutonomousModeSCANP As Max11801TypeAutonomousMode
    Get
    Set
public:
property Max11801TypeAutonomousMode AutonomousModeSCANP {
    Max11801TypeAutonomousMode get ();
    void set (Max11801TypeAutonomousMode value);
}
member AutonomousModeSCANP : Max11801TypeAutonomousMode with get, set

Property Value

Type: Max11801TypeAutonomousMode
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.AutonomousModeTINIT Property

IRD

Max11801AutonomousModeTINIT Property

Autonomous Mode: TINIT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeAutonomousMode AutonomousModeTINIT { get; set; }
Public Property AutonomousModeTINIT As Max11801TypeAutonomousMode
    Get
    Set
public:
property Max11801TypeAutonomousMode AutonomousModeTINIT {
    Max11801TypeAutonomousMode get ();
    void set (Max11801TypeAutonomousMode value);
}
member AutonomousModeTINIT : Max11801TypeAutonomousMode with get, set

Property Value

Type: Max11801TypeAutonomousMode
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.AUXConversion Property

IRD

Max11801AUXConversion Property

AUX Conversion

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AUXConversion { set; }
Public WriteOnly Property AUXConversion As Byte
    Set
public:
property unsigned char AUXConversion {
    void set (unsigned char value);
}
member AUXConversion : byte with set

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.AuxiliaryMeasurementAVGA Property

IRD

Max11801AuxiliaryMeasurementAVGA Property

Auxiliary Measurement: AVGA

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeAuxiliaryMeasurementAveragingSample AuxiliaryMeasurementAVGA { get; set; }
Public Property AuxiliaryMeasurementAVGA As Max11801TypeAuxiliaryMeasurementAveragingSample
    Get
    Set
public:
property Max11801TypeAuxiliaryMeasurementAveragingSample AuxiliaryMeasurementAVGA {
    Max11801TypeAuxiliaryMeasurementAveragingSample get ();
    void set (Max11801TypeAuxiliaryMeasurementAveragingSample value);
}
member AuxiliaryMeasurementAVGA : Max11801TypeAuxiliaryMeasurementAveragingSample with get, set

Property Value

Type: Max11801TypeAuxiliaryMeasurementAveragingSample
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.AuxiliaryMeasurementDCVA Property

IRD

Max11801AuxiliaryMeasurementDCVA Property

Auxiliary Measurement: D_CV_A

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeAuxiliaryMeasurementDelay AuxiliaryMeasurementDCVA { get; set; }
Public Property AuxiliaryMeasurementDCVA As Max11801TypeAuxiliaryMeasurementDelay
    Get
    Set
public:
property Max11801TypeAuxiliaryMeasurementDelay AuxiliaryMeasurementDCVA {
    Max11801TypeAuxiliaryMeasurementDelay get ();
    void set (Max11801TypeAuxiliaryMeasurementDelay value);
}
member AuxiliaryMeasurementDCVA : Max11801TypeAuxiliaryMeasurementDelay with get, set

Property Value

Type: Max11801TypeAuxiliaryMeasurementDelay
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.AuxiliaryMeasurementRESA Property

IRD

Max11801AuxiliaryMeasurementRESA Property

Auxiliary Measurement: RESA

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeAuxiliaryMeasurementResolution AuxiliaryMeasurementRESA { get; set; }
Public Property AuxiliaryMeasurementRESA As Max11801TypeAuxiliaryMeasurementResolution
    Get
    Set
public:
property Max11801TypeAuxiliaryMeasurementResolution AuxiliaryMeasurementRESA {
    Max11801TypeAuxiliaryMeasurementResolution get ();
    void set (Max11801TypeAuxiliaryMeasurementResolution value);
}
member AuxiliaryMeasurementRESA : Max11801TypeAuxiliaryMeasurementResolution with get, set

Property Value

Type: Max11801TypeAuxiliaryMeasurementResolution
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.AuxiliaryMeasurementTSAMPLEA Property

IRD

Max11801AuxiliaryMeasurementTSAMPLEA Property

Auxiliary Measurement: T_SAMPLE_A

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeAuxiliaryMeasurementSamplingTime AuxiliaryMeasurementTSAMPLEA { get; set; }
Public Property AuxiliaryMeasurementTSAMPLEA As Max11801TypeAuxiliaryMeasurementSamplingTime
    Get
    Set
public:
property Max11801TypeAuxiliaryMeasurementSamplingTime AuxiliaryMeasurementTSAMPLEA {
    Max11801TypeAuxiliaryMeasurementSamplingTime get ();
    void set (Max11801TypeAuxiliaryMeasurementSamplingTime value);
}
member AuxiliaryMeasurementTSAMPLEA : Max11801TypeAuxiliaryMeasurementSamplingTime with get, set

Property Value

Type: Max11801TypeAuxiliaryMeasurementSamplingTime
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.DelayConversionDCVZ Property

IRD

Max11801DelayConversionDCVZ Property

Delay Conversion: D_CV_Z

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeDelayedConversionTime DelayConversionDCVZ { get; set; }
Public Property DelayConversionDCVZ As Max11801TypeDelayedConversionTime
    Get
    Set
public:
property Max11801TypeDelayedConversionTime DelayConversionDCVZ {
    Max11801TypeDelayedConversionTime get ();
    void set (Max11801TypeDelayedConversionTime value);
}
member DelayConversionDCVZ : Max11801TypeDelayedConversionTime with get, set

Property Value

Type: Max11801TypeDelayedConversionTime
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.DelayedConversionDCVXY Property

IRD

Max11801DelayedConversionDCVXY Property

Delayed Conversion: D_CV_XY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeDelayedConversionTime DelayedConversionDCVXY { get; set; }
Public Property DelayedConversionDCVXY As Max11801TypeDelayedConversionTime
    Get
    Set
public:
property Max11801TypeDelayedConversionTime DelayedConversionDCVXY {
    Max11801TypeDelayedConversionTime get ();
    void set (Max11801TypeDelayedConversionTime value);
}
member DelayedConversionDCVXY : Max11801TypeDelayedConversionTime with get, set

Property Value

Type: Max11801TypeDelayedConversionTime
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.DirectConversionModeAUX Property

IRD

Max11801DirectConversionModeAUX Property

Direct Conversion Mode: AUX

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DirectConversionModeAUX { get; }
Public ReadOnly Property DirectConversionModeAUX As Byte
    Get
public:
property unsigned char DirectConversionModeAUX {
    unsigned char get ();
}
member DirectConversionModeAUX : byte with get

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.DirectConversionModeX Property

IRD

Max11801DirectConversionModeX Property

Direct Conversion Mode: X

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DirectConversionModeX { get; }
Public ReadOnly Property DirectConversionModeX As Byte
    Get
public:
property unsigned char DirectConversionModeX {
    unsigned char get ();
}
member DirectConversionModeX : byte with get

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.DirectConversionModeY Property

IRD

Max11801DirectConversionModeY Property

Direct Conversion Mode: Y

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DirectConversionModeY { get; }
Public ReadOnly Property DirectConversionModeY As Byte
    Get
public:
property unsigned char DirectConversionModeY {
    unsigned char get ();
}
member DirectConversionModeY : byte with get

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.DirectConversionModeZ1 Property

IRD

Max11801DirectConversionModeZ1 Property

Direct Conversion Mode: Z1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DirectConversionModeZ1 { get; }
Public ReadOnly Property DirectConversionModeZ1 As Byte
    Get
public:
property unsigned char DirectConversionModeZ1 {
    unsigned char get ();
}
member DirectConversionModeZ1 : byte with get

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.DirectConversionModeZ2 Property

IRD

Max11801DirectConversionModeZ2 Property

Direct Conversion Mode: Z2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DirectConversionModeZ2 { get; }
Public ReadOnly Property DirectConversionModeZ2 As Byte
    Get
public:
property unsigned char DirectConversionModeZ2 {
    unsigned char get ();
}
member DirectConversionModeZ2 : byte with get

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.GeneralConfigurationEDGEIRQ Property

IRD

Max11801GeneralConfigurationEDGEIRQ Property

General Configuration: EDGE_IRQ

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeGeneralConfiguratuionEdgeIrq GeneralConfigurationEDGEIRQ { get; set; }
Public Property GeneralConfigurationEDGEIRQ As Max11801TypeGeneralConfiguratuionEdgeIrq
    Get
    Set
public:
property Max11801TypeGeneralConfiguratuionEdgeIrq GeneralConfigurationEDGEIRQ {
    Max11801TypeGeneralConfiguratuionEdgeIrq get ();
    void set (Max11801TypeGeneralConfiguratuionEdgeIrq value);
}
member GeneralConfigurationEDGEIRQ : Max11801TypeGeneralConfiguratuionEdgeIrq with get, set

Property Value

Type: Max11801TypeGeneralConfiguratuionEdgeIrq
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.GeneralConfigurationEDGETIME Property

IRD

Max11801GeneralConfigurationEDGETIME Property

General Configuration: EDGE_TIME

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeGeneralConfiguratuionEdgeTime GeneralConfigurationEDGETIME { get; set; }
Public Property GeneralConfigurationEDGETIME As Max11801TypeGeneralConfiguratuionEdgeTime
    Get
    Set
public:
property Max11801TypeGeneralConfiguratuionEdgeTime GeneralConfigurationEDGETIME {
    Max11801TypeGeneralConfiguratuionEdgeTime get ();
    void set (Max11801TypeGeneralConfiguratuionEdgeTime value);
}
member GeneralConfigurationEDGETIME : Max11801TypeGeneralConfiguratuionEdgeTime with get, set

Property Value

Type: Max11801TypeGeneralConfiguratuionEdgeTime
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.GeneralConfigurationHOLDDO Property

IRD

Max11801GeneralConfigurationHOLDDO Property

General Configuration: HOLD_DO

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeGeneralConfiguratuionHold GeneralConfigurationHOLDDO { get; set; }
Public Property GeneralConfigurationHOLDDO As Max11801TypeGeneralConfiguratuionHold
    Get
    Set
public:
property Max11801TypeGeneralConfiguratuionHold GeneralConfigurationHOLDDO {
    Max11801TypeGeneralConfiguratuionHold get ();
    void set (Max11801TypeGeneralConfiguratuionHold value);
}
member GeneralConfigurationHOLDDO : Max11801TypeGeneralConfiguratuionHold with get, set

Property Value

Type: Max11801TypeGeneralConfiguratuionHold
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.GeneralConfigurationMASKIRQ Property

IRD

Max11801GeneralConfigurationMASKIRQ Property

General Configuration: MASK_IRQ

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeGeneralConfiguratuionMask GeneralConfigurationMASKIRQ { get; set; }
Public Property GeneralConfigurationMASKIRQ As Max11801TypeGeneralConfiguratuionMask
    Get
    Set
public:
property Max11801TypeGeneralConfiguratuionMask GeneralConfigurationMASKIRQ {
    Max11801TypeGeneralConfiguratuionMask get ();
    void set (Max11801TypeGeneralConfiguratuionMask value);
}
member GeneralConfigurationMASKIRQ : Max11801TypeGeneralConfiguratuionMask with get, set

Property Value

Type: Max11801TypeGeneralConfiguratuionMask
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.GeneralConfigurationODNIRQ Property

IRD

Max11801GeneralConfigurationODNIRQ Property

General Configuration: ODN_IRQ

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeGeneralConfiguratuionOdn GeneralConfigurationODNIRQ { get; set; }
Public Property GeneralConfigurationODNIRQ As Max11801TypeGeneralConfiguratuionOdn
    Get
    Set
public:
property Max11801TypeGeneralConfiguratuionOdn GeneralConfigurationODNIRQ {
    Max11801TypeGeneralConfiguratuionOdn get ();
    void set (Max11801TypeGeneralConfiguratuionOdn value);
}
member GeneralConfigurationODNIRQ : Max11801TypeGeneralConfiguratuionOdn with get, set

Property Value

Type: Max11801TypeGeneralConfiguratuionOdn
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.GeneralConfigurationPUIRQ Property

IRD

Max11801GeneralConfigurationPUIRQ Property

General Configuration: PU_IRQ

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeGeneralConfiguratuionPuIrq GeneralConfigurationPUIRQ { get; set; }
Public Property GeneralConfigurationPUIRQ As Max11801TypeGeneralConfiguratuionPuIrq
    Get
    Set
public:
property Max11801TypeGeneralConfiguratuionPuIrq GeneralConfigurationPUIRQ {
    Max11801TypeGeneralConfiguratuionPuIrq get ();
    void set (Max11801TypeGeneralConfiguratuionPuIrq value);
}
member GeneralConfigurationPUIRQ : Max11801TypeGeneralConfiguratuionPuIrq with get, set

Property Value

Type: Max11801TypeGeneralConfiguratuionPuIrq
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.GeneralConfigurationRTSEL Property

IRD

Max11801GeneralConfigurationRTSEL Property

General Configuration: RT_SEL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeGeneralConfiguratuionRtSel GeneralConfigurationRTSEL { get; set; }
Public Property GeneralConfigurationRTSEL As Max11801TypeGeneralConfiguratuionRtSel
    Get
    Set
public:
property Max11801TypeGeneralConfiguratuionRtSel GeneralConfigurationRTSEL {
    Max11801TypeGeneralConfiguratuionRtSel get ();
    void set (Max11801TypeGeneralConfiguratuionRtSel value);
}
member GeneralConfigurationRTSEL : Max11801TypeGeneralConfiguratuionRtSel with get, set

Property Value

Type: Max11801TypeGeneralConfiguratuionRtSel
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.GeneralStatusADCBUSY Property

IRD

Max11801GeneralStatusADCBUSY Property

General Status: ADC_BUSY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeGeneralStatusAdc GeneralStatusADCBUSY { get; }
Public ReadOnly Property GeneralStatusADCBUSY As Max11801TypeGeneralStatusAdc
    Get
public:
property Max11801TypeGeneralStatusAdc GeneralStatusADCBUSY {
    Max11801TypeGeneralStatusAdc get ();
}
member GeneralStatusADCBUSY : Max11801TypeGeneralStatusAdc with get

Property Value

Type: Max11801TypeGeneralStatusAdc
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.GeneralStatusCONTINT Property

IRD

Max11801GeneralStatusCONTINT Property

General Status: CONT_INT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeGeneralStatusCont GeneralStatusCONTINT { get; }
Public ReadOnly Property GeneralStatusCONTINT As Max11801TypeGeneralStatusCont
    Get
public:
property Max11801TypeGeneralStatusCont GeneralStatusCONTINT {
    Max11801TypeGeneralStatusCont get ();
}
member GeneralStatusCONTINT : Max11801TypeGeneralStatusCont with get

Property Value

Type: Max11801TypeGeneralStatusCont
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.GeneralStatusEDGEINT Property

IRD

Max11801GeneralStatusEDGEINT Property

General Status: EDGE_INT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeGeneralStatusEdge GeneralStatusEDGEINT { get; }
Public ReadOnly Property GeneralStatusEDGEINT As Max11801TypeGeneralStatusEdge
    Get
public:
property Max11801TypeGeneralStatusEdge GeneralStatusEDGEINT {
    Max11801TypeGeneralStatusEdge get ();
}
member GeneralStatusEDGEINT : Max11801TypeGeneralStatusEdge with get

Property Value

Type: Max11801TypeGeneralStatusEdge
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.GeneralStatusFIFOINT Property

IRD

Max11801GeneralStatusFIFOINT Property

General Status: FIFO_INT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeGeneralStatusFifoInt GeneralStatusFIFOINT { get; }
Public ReadOnly Property GeneralStatusFIFOINT As Max11801TypeGeneralStatusFifoInt
    Get
public:
property Max11801TypeGeneralStatusFifoInt GeneralStatusFIFOINT {
    Max11801TypeGeneralStatusFifoInt get ();
}
member GeneralStatusFIFOINT : Max11801TypeGeneralStatusFifoInt with get

Property Value

Type: Max11801TypeGeneralStatusFifoInt
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.GeneralStatusFIFOOVR Property

IRD

Max11801GeneralStatusFIFOOVR Property

General Status: FIFO_OVR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeGeneralStatusFifoOvr GeneralStatusFIFOOVR { get; }
Public ReadOnly Property GeneralStatusFIFOOVR As Max11801TypeGeneralStatusFifoOvr
    Get
public:
property Max11801TypeGeneralStatusFifoOvr GeneralStatusFIFOOVR {
    Max11801TypeGeneralStatusFifoOvr get ();
}
member GeneralStatusFIFOOVR : Max11801TypeGeneralStatusFifoOvr with get

Property Value

Type: Max11801TypeGeneralStatusFifoOvr
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.GeneralStatusLPM Property

IRD

Max11801GeneralStatusLPM Property

General Status: LPM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeGeneralStatusLpm GeneralStatusLPM { get; }
Public ReadOnly Property GeneralStatusLPM As Max11801TypeGeneralStatusLpm
    Get
public:
property Max11801TypeGeneralStatusLpm GeneralStatusLPM {
    Max11801TypeGeneralStatusLpm get ();
}
member GeneralStatusLPM : Max11801TypeGeneralStatusLpm with get

Property Value

Type: Max11801TypeGeneralStatusLpm
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.GeneralStatusSCAN Property

IRD

Max11801GeneralStatusSCAN Property

General Status: SCAN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeGeneralStatusScan GeneralStatusSCAN { get; }
Public ReadOnly Property GeneralStatusSCAN As Max11801TypeGeneralStatusScan
    Get
public:
property Max11801TypeGeneralStatusScan GeneralStatusSCAN {
    Max11801TypeGeneralStatusScan get ();
}
member GeneralStatusSCAN : Max11801TypeGeneralStatusScan with get

Property Value

Type: Max11801TypeGeneralStatusScan
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.GeneralStatusTDM Property

IRD

Max11801GeneralStatusTDM Property

General Status: TDM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeGeneralStatusTdm GeneralStatusTDM { get; }
Public ReadOnly Property GeneralStatusTDM As Max11801TypeGeneralStatusTdm
    Get
public:
property Max11801TypeGeneralStatusTdm GeneralStatusTDM {
    Max11801TypeGeneralStatusTdm get ();
}
member GeneralStatusTDM : Max11801TypeGeneralStatusTdm with get

Property Value

Type: Max11801TypeGeneralStatusTdm
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.MeasurementAveragingAVGX Property

IRD

Max11801MeasurementAveragingAVGX Property

Measurement Averaging: AVG_X

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeMeasurementAveragingAvg MeasurementAveragingAVGX { get; set; }
Public Property MeasurementAveragingAVGX As Max11801TypeMeasurementAveragingAvg
    Get
    Set
public:
property Max11801TypeMeasurementAveragingAvg MeasurementAveragingAVGX {
    Max11801TypeMeasurementAveragingAvg get ();
    void set (Max11801TypeMeasurementAveragingAvg value);
}
member MeasurementAveragingAVGX : Max11801TypeMeasurementAveragingAvg with get, set

Property Value

Type: Max11801TypeMeasurementAveragingAvg
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.MeasurementAveragingAVGY Property

IRD

Max11801MeasurementAveragingAVGY Property

Measurement Averaging: AVG_Y

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeMeasurementAveragingAvg MeasurementAveragingAVGY { get; set; }
Public Property MeasurementAveragingAVGY As Max11801TypeMeasurementAveragingAvg
    Get
    Set
public:
property Max11801TypeMeasurementAveragingAvg MeasurementAveragingAVGY {
    Max11801TypeMeasurementAveragingAvg get ();
    void set (Max11801TypeMeasurementAveragingAvg value);
}
member MeasurementAveragingAVGY : Max11801TypeMeasurementAveragingAvg with get, set

Property Value

Type: Max11801TypeMeasurementAveragingAvg
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.MeasurementAveragingAVGZ1 Property

IRD

Max11801MeasurementAveragingAVGZ1 Property

Measurement Averaging: AVG_Z1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeMeasurementAveragingAvg MeasurementAveragingAVGZ1 { get; set; }
Public Property MeasurementAveragingAVGZ1 As Max11801TypeMeasurementAveragingAvg
    Get
    Set
public:
property Max11801TypeMeasurementAveragingAvg MeasurementAveragingAVGZ1 {
    Max11801TypeMeasurementAveragingAvg get ();
    void set (Max11801TypeMeasurementAveragingAvg value);
}
member MeasurementAveragingAVGZ1 : Max11801TypeMeasurementAveragingAvg with get, set

Property Value

Type: Max11801TypeMeasurementAveragingAvg
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.MeasurementAveragingAVGZ2 Property

IRD

Max11801MeasurementAveragingAVGZ2 Property

Measurement Averaging: AVG_Z2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeMeasurementAveragingAvg MeasurementAveragingAVGZ2 { get; set; }
Public Property MeasurementAveragingAVGZ2 As Max11801TypeMeasurementAveragingAvg
    Get
    Set
public:
property Max11801TypeMeasurementAveragingAvg MeasurementAveragingAVGZ2 {
    Max11801TypeMeasurementAveragingAvg get ();
    void set (Max11801TypeMeasurementAveragingAvg value);
}
member MeasurementAveragingAVGZ2 : Max11801TypeMeasurementAveragingAvg with get, set

Property Value

Type: Max11801TypeMeasurementAveragingAvg
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.MeasurementResolutionPWRSAV Property

IRD

Max11801MeasurementResolutionPWRSAV Property

Measurement Resolution: PWR_SAV

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeMeasurementResolutionPwr MeasurementResolutionPWRSAV { get; set; }
Public Property MeasurementResolutionPWRSAV As Max11801TypeMeasurementResolutionPwr
    Get
    Set
public:
property Max11801TypeMeasurementResolutionPwr MeasurementResolutionPWRSAV {
    Max11801TypeMeasurementResolutionPwr get ();
    void set (Max11801TypeMeasurementResolutionPwr value);
}
member MeasurementResolutionPWRSAV : Max11801TypeMeasurementResolutionPwr with get, set

Property Value

Type: Max11801TypeMeasurementResolutionPwr
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.MeasurementResolutionRESX Property

IRD

Max11801MeasurementResolutionRESX Property

Measurement Resolution: RESX

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeMeasurementResolutionRes MeasurementResolutionRESX { get; set; }
Public Property MeasurementResolutionRESX As Max11801TypeMeasurementResolutionRes
    Get
    Set
public:
property Max11801TypeMeasurementResolutionRes MeasurementResolutionRESX {
    Max11801TypeMeasurementResolutionRes get ();
    void set (Max11801TypeMeasurementResolutionRes value);
}
member MeasurementResolutionRESX : Max11801TypeMeasurementResolutionRes with get, set

Property Value

Type: Max11801TypeMeasurementResolutionRes
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.MeasurementResolutionRESY Property

IRD

Max11801MeasurementResolutionRESY Property

Measurement Resolution: RESY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeMeasurementResolutionRes MeasurementResolutionRESY { get; set; }
Public Property MeasurementResolutionRESY As Max11801TypeMeasurementResolutionRes
    Get
    Set
public:
property Max11801TypeMeasurementResolutionRes MeasurementResolutionRESY {
    Max11801TypeMeasurementResolutionRes get ();
    void set (Max11801TypeMeasurementResolutionRes value);
}
member MeasurementResolutionRESY : Max11801TypeMeasurementResolutionRes with get, set

Property Value

Type: Max11801TypeMeasurementResolutionRes
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.MeasurementResolutionRESZ1 Property

IRD

Max11801MeasurementResolutionRESZ1 Property

Measurement Resolution: RESZ1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeMeasurementResolutionRes MeasurementResolutionRESZ1 { get; set; }
Public Property MeasurementResolutionRESZ1 As Max11801TypeMeasurementResolutionRes
    Get
    Set
public:
property Max11801TypeMeasurementResolutionRes MeasurementResolutionRESZ1 {
    Max11801TypeMeasurementResolutionRes get ();
    void set (Max11801TypeMeasurementResolutionRes value);
}
member MeasurementResolutionRESZ1 : Max11801TypeMeasurementResolutionRes with get, set

Property Value

Type: Max11801TypeMeasurementResolutionRes
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.MeasurementResolutionRESZ2 Property

IRD

Max11801MeasurementResolutionRESZ2 Property

Measurement Resolution: RESZ2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeMeasurementResolutionRes MeasurementResolutionRESZ2 { get; set; }
Public Property MeasurementResolutionRESZ2 As Max11801TypeMeasurementResolutionRes
    Get
    Set
public:
property Max11801TypeMeasurementResolutionRes MeasurementResolutionRESZ2 {
    Max11801TypeMeasurementResolutionRes get ();
    void set (Max11801TypeMeasurementResolutionRes value);
}
member MeasurementResolutionRESZ2 : Max11801TypeMeasurementResolutionRes with get, set

Property Value

Type: Max11801TypeMeasurementResolutionRes
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.OperatingModeAMODE Property

IRD

Max11801OperatingModeAMODE Property

Operating Mode: AMODE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeOperatingModeConversion OperatingModeAMODE { get; set; }
Public Property OperatingModeAMODE As Max11801TypeOperatingModeConversion
    Get
    Set
public:
property Max11801TypeOperatingModeConversion OperatingModeAMODE {
    Max11801TypeOperatingModeConversion get ();
    void set (Max11801TypeOperatingModeConversion value);
}
member OperatingModeAMODE : Max11801TypeOperatingModeConversion with get, set

Property Value

Type: Max11801TypeOperatingModeConversion
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.OperatingModeAPER Property

IRD

Max11801OperatingModeAPER Property

Operating Mode: APER

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeOperatingModeAperture OperatingModeAPER { get; set; }
Public Property OperatingModeAPER As Max11801TypeOperatingModeAperture
    Get
    Set
public:
property Max11801TypeOperatingModeAperture OperatingModeAPER {
    Max11801TypeOperatingModeAperture get ();
    void set (Max11801TypeOperatingModeAperture value);
}
member OperatingModeAPER : Max11801TypeOperatingModeAperture with get, set

Property Value

Type: Max11801TypeOperatingModeAperture
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.OperatingModeAVGFLT Property

IRD

Max11801OperatingModeAVGFLT Property

Operating Mode: AVG_FLT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeOperatingModeAveraging OperatingModeAVGFLT { get; set; }
Public Property OperatingModeAVGFLT As Max11801TypeOperatingModeAveraging
    Get
    Set
public:
property Max11801TypeOperatingModeAveraging OperatingModeAVGFLT {
    Max11801TypeOperatingModeAveraging get ();
    void set (Max11801TypeOperatingModeAveraging value);
}
member OperatingModeAVGFLT : Max11801TypeOperatingModeAveraging with get, set

Property Value

Type: Max11801TypeOperatingModeAveraging
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.OperatingModeENAVGXY Property

IRD

Max11801OperatingModeENAVGXY Property

Operating Mode: EN_AVG_XY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeOperatingModePosition OperatingModeENAVGXY { get; set; }
Public Property OperatingModeENAVGXY As Max11801TypeOperatingModePosition
    Get
    Set
public:
property Max11801TypeOperatingModePosition OperatingModeENAVGXY {
    Max11801TypeOperatingModePosition get ();
    void set (Max11801TypeOperatingModePosition value);
}
member OperatingModeENAVGXY : Max11801TypeOperatingModePosition with get, set

Property Value

Type: Max11801TypeOperatingModePosition
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.OperatingModeENAVGZ Property

IRD

Max11801OperatingModeENAVGZ Property

Operating Mode: EN_AVG_Z

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeOperatingModePressure OperatingModeENAVGZ { get; set; }
Public Property OperatingModeENAVGZ As Max11801TypeOperatingModePressure
    Get
    Set
public:
property Max11801TypeOperatingModePressure OperatingModeENAVGZ {
    Max11801TypeOperatingModePressure get ();
    void set (Max11801TypeOperatingModePressure value);
}
member OperatingModeENAVGZ : Max11801TypeOperatingModePressure with get, set

Property Value

Type: Max11801TypeOperatingModePressure
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.OperatingModePWRDN Property

IRD

Max11801OperatingModePWRDN Property

Operating Mode: PWRDN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeOperatingModePower OperatingModePWRDN { get; set; }
Public Property OperatingModePWRDN As Max11801TypeOperatingModePower
    Get
    Set
public:
property Max11801TypeOperatingModePower OperatingModePWRDN {
    Max11801TypeOperatingModePower get ();
    void set (Max11801TypeOperatingModePower value);
}
member OperatingModePWRDN : Max11801TypeOperatingModePower with get, set

Property Value

Type: Max11801TypeOperatingModePower
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.PanelSetupTimingPSUXY Property

IRD

Max11801PanelSetupTimingPSUXY Property

Panel Setup Timing: PSUXY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypePanelSetupTimingPsu PanelSetupTimingPSUXY { get; set; }
Public Property PanelSetupTimingPSUXY As Max11801TypePanelSetupTimingPsu
    Get
    Set
public:
property Max11801TypePanelSetupTimingPsu PanelSetupTimingPSUXY {
    Max11801TypePanelSetupTimingPsu get ();
    void set (Max11801TypePanelSetupTimingPsu value);
}
member PanelSetupTimingPSUXY : Max11801TypePanelSetupTimingPsu with get, set

Property Value

Type: Max11801TypePanelSetupTimingPsu
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.PanelSetupTimingPSUZ Property

IRD

Max11801PanelSetupTimingPSUZ Property

Panel Setup Timing: PSUZ

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypePanelSetupTimingPsu PanelSetupTimingPSUZ { get; set; }
Public Property PanelSetupTimingPSUZ As Max11801TypePanelSetupTimingPsu
    Get
    Set
public:
property Max11801TypePanelSetupTimingPsu PanelSetupTimingPSUZ {
    Max11801TypePanelSetupTimingPsu get ();
    void set (Max11801TypePanelSetupTimingPsu value);
}
member PanelSetupTimingPSUZ : Max11801TypePanelSetupTimingPsu with get, set

Property Value

Type: Max11801TypePanelSetupTimingPsu
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.TouchDetectPullupPUF Property

IRD

Max11801TouchDetectPullupPUF Property

Touch Detect Pullup: PUF

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeTouchDetectPullupPuf TouchDetectPullupPUF { get; set; }
Public Property TouchDetectPullupPUF As Max11801TypeTouchDetectPullupPuf
    Get
    Set
public:
property Max11801TypeTouchDetectPullupPuf TouchDetectPullupPUF {
    Max11801TypeTouchDetectPullupPuf get ();
    void set (Max11801TypeTouchDetectPullupPuf value);
}
member TouchDetectPullupPUF : Max11801TypeTouchDetectPullupPuf with get, set

Property Value

Type: Max11801TypeTouchDetectPullupPuf
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.TouchDetectPullupPUR Property

IRD

Max11801TouchDetectPullupPUR Property

Touch Detect Pullup: PUR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11801TypeTouchDetectPullupPur TouchDetectPullupPUR { get; set; }
Public Property TouchDetectPullupPUR As Max11801TypeTouchDetectPullupPur
    Get
    Set
public:
property Max11801TypeTouchDetectPullupPur TouchDetectPullupPUR {
    Max11801TypeTouchDetectPullupPur get ();
    void set (Max11801TypeTouchDetectPullupPur value);
}
member TouchDetectPullupPUR : Max11801TypeTouchDetectPullupPur with get, set

Property Value

Type: Max11801TypeTouchDetectPullupPur
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.XMeasurementCONT0 Property

IRD

Max11801XMeasurementCONT0 Property

X Measurement CONT0

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte XMeasurementCONT0 { set; }
Public WriteOnly Property XMeasurementCONT0 As Byte
    Set
public:
property unsigned char XMeasurementCONT0 {
    void set (unsigned char value);
}
member XMeasurementCONT0 : byte with set

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.XMeasurementCONT1 Property

IRD

Max11801XMeasurementCONT1 Property

X Measurement CONT1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte XMeasurementCONT1 { set; }
Public WriteOnly Property XMeasurementCONT1 As Byte
    Set
public:
property unsigned char XMeasurementCONT1 {
    void set (unsigned char value);
}
member XMeasurementCONT1 : byte with set

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.XPanelSetup Property

IRD

Max11801XPanelSetup Property

X Panel Setup

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte XPanelSetup { set; }
Public WriteOnly Property XPanelSetup As Byte
    Set
public:
property unsigned char XPanelSetup {
    void set (unsigned char value);
}
member XPanelSetup : byte with set

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.XYCombinedCommand Property

IRD

Max11801XYCombinedCommand Property

XY Combined Command

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte XYCombinedCommand { set; }
Public WriteOnly Property XYCombinedCommand As Byte
    Set
public:
property unsigned char XYCombinedCommand {
    void set (unsigned char value);
}
member XYCombinedCommand : byte with set

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.XYZ1CombinedCommand Property

IRD

Max11801XYZ1CombinedCommand Property

XYZ1 Combined Command

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte XYZ1CombinedCommand { set; }
Public WriteOnly Property XYZ1CombinedCommand As Byte
    Set
public:
property unsigned char XYZ1CombinedCommand {
    void set (unsigned char value);
}
member XYZ1CombinedCommand : byte with set

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.XYZ1Z2CombinedCommand Property

IRD

Max11801XYZ1Z2CombinedCommand Property

XYZ1Z2 Combined Command

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte XYZ1Z2CombinedCommand { set; }
Public WriteOnly Property XYZ1Z2CombinedCommand As Byte
    Set
public:
property unsigned char XYZ1Z2CombinedCommand {
    void set (unsigned char value);
}
member XYZ1Z2CombinedCommand : byte with set

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.YMeasurementCONT0 Property

IRD

Max11801YMeasurementCONT0 Property

Y Measurement CONT0

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte YMeasurementCONT0 { set; }
Public WriteOnly Property YMeasurementCONT0 As Byte
    Set
public:
property unsigned char YMeasurementCONT0 {
    void set (unsigned char value);
}
member YMeasurementCONT0 : byte with set

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.YMeasurementCONT1 Property

IRD

Max11801YMeasurementCONT1 Property

Y Measurement CONT1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte YMeasurementCONT1 { set; }
Public WriteOnly Property YMeasurementCONT1 As Byte
    Set
public:
property unsigned char YMeasurementCONT1 {
    void set (unsigned char value);
}
member YMeasurementCONT1 : byte with set

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.YPanelSetup Property

IRD

Max11801YPanelSetup Property

Y Panel Setup

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte YPanelSetup { set; }
Public WriteOnly Property YPanelSetup As Byte
    Set
public:
property unsigned char YPanelSetup {
    void set (unsigned char value);
}
member YPanelSetup : byte with set

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.Z1MeasurementCONT0 Property

IRD

Max11801Z1MeasurementCONT0 Property

Z1 Measurement CONT0

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Z1MeasurementCONT0 { set; }
Public WriteOnly Property Z1MeasurementCONT0 As Byte
    Set
public:
property unsigned char Z1MeasurementCONT0 {
    void set (unsigned char value);
}
member Z1MeasurementCONT0 : byte with set

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.Z1MeasurementCONT1 Property

IRD

Max11801Z1MeasurementCONT1 Property

Z1 Measurement CONT1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Z1MeasurementCONT1 { set; }
Public WriteOnly Property Z1MeasurementCONT1 As Byte
    Set
public:
property unsigned char Z1MeasurementCONT1 {
    void set (unsigned char value);
}
member Z1MeasurementCONT1 : byte with set

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.Z1PanelSetup Property

IRD

Max11801Z1PanelSetup Property

Z1 Panel Setup

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Z1PanelSetup { set; }
Public WriteOnly Property Z1PanelSetup As Byte
    Set
public:
property unsigned char Z1PanelSetup {
    void set (unsigned char value);
}
member Z1PanelSetup : byte with set

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.Z2MeasurementCONT0 Property

IRD

Max11801Z2MeasurementCONT0 Property

Z2 Measurement CONT0

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Z2MeasurementCONT0 { set; }
Public WriteOnly Property Z2MeasurementCONT0 As Byte
    Set
public:
property unsigned char Z2MeasurementCONT0 {
    void set (unsigned char value);
}
member Z2MeasurementCONT0 : byte with set

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.Z2MeasurementCONT1 Property

IRD

Max11801Z2MeasurementCONT1 Property

Z2 Measurement CONT1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Z2MeasurementCONT1 { set; }
Public WriteOnly Property Z2MeasurementCONT1 As Byte
    Set
public:
property unsigned char Z2MeasurementCONT1 {
    void set (unsigned char value);
}
member Z2MeasurementCONT1 : byte with set

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.Z2PanelSetup Property

IRD

Max11801Z2PanelSetup Property

Z2 Panel Setup

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Z2PanelSetup { set; }
Public WriteOnly Property Z2PanelSetup As Byte
    Set
public:
property unsigned char Z2PanelSetup {
    void set (unsigned char value);
}
member Z2PanelSetup : byte with set

Property Value

Type: Byte
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801 Methods

The Max11801 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.Flush Method

IRD

Max11801Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max11801 Class
telos.Ird.Maxim Namespace


Max11801.TypeAdcSamplingTime Enumeration

IRD

Max11801TypeAdcSamplingTime Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcSamplingTime
Public Enumeration TypeAdcSamplingTime
public enum class TypeAdcSamplingTime
type TypeAdcSamplingTime
Members
Member name | Value | Description
Value_4X2MHzOscillatorClockPeriod2Us | 0 | 4 x (2 MHz Oscillator Clock Period) = 2 µs
Value_16X2MHzOscillatorClockPeriod8Us | 1 | 16 x (2 MHz Oscillator Clock Period) = 8 µs
Value_64X2MHzOscillatorClockPeriod32Us | 2 | 64 x (2 MHz Oscillator Clock Period) = 32 µs
Value_256X2MHzOscillatorClockPeriod128Us | 3 | 256 x (2 MHz Oscillator Clock Period) = 128 µs
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeApertureConfiguration Enumeration

IRD

Max11801TypeApertureConfiguration Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeApertureConfiguration
Public Enumeration TypeApertureConfiguration
public enum class TypeApertureConfiguration
type TypeApertureConfiguration
Members
Member name | Value | Description
Value_201LSBApertureCheckingDisabled | 0 | 2^(0-1) / LSB = Aperture Checking Disabled
Value_211LSB1LSB | 1 | 2^(1-1) / LSB = +/- 1 LSB
Value_221LSB2LSB | 2 | 2^(2-1) / LSB = +/- 2 LSB
Value_231LSB4LSB | 3 | 2^(3-1) / LSB = +/- 4 LSB
Value_241LSB8LSB | 4 | 2^(4-1) / LSB = +/- 8 LSB
Value_251LSB16LSB | 5 | 2^(5-1) / LSB = +/- 16 LSB
Value_261LSB32LSB | 6 | 2^(6-1) / LSB = +/- 32 LSB
Value_271LSB64LSB | 7 | 2^(7-1) / LSB = +/- 64 LSB
Value_281LSB128LSB | 8 | 2^(8-1) / LSB = +/- 128 LSB
Value_291LSB256LSB | 9 | 2^(9-1) / LSB = +/- 256 LSB
Value_2101LSB512LSB | 10 | 2^(10-1) / LSB = +/- 512 LSB
Value_2111LSB1024LSB | 11 | 2^(11-1) / LSB = +/- 1024 LSB
Value_2121LSB2048LSB | 12 | 2^(12-1) / LSB = +/- 2048 LSB
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeAutonomousMode Enumeration

IRD

Max11801TypeAutonomousMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAutonomousMode
Public Enumeration TypeAutonomousMode
public enum class TypeAutonomousMode
type TypeAutonomousMode
Members
Member name | Value | Description
Value_10Us | 0 | 10 µs
Value_20Us | 1 | 20 µs
Value_50Us | 2 | 50 µs
Value_80Us | 3 | 80 µs
Value_100Us | 4 | 100 µs
Value_200Us | 5 | 200 µs
Value_500Us | 6 | 500 µs
Value_800Us | 7 | 800 µs
Value_1Ms | 8 | 1 ms
Value_2Ms | 9 | 2 ms
Value_5Ms | 10 | 5 ms
Value_10Ms | 11 | 10 ms
Value_20Ms | 12 | 20 ms
Value_50Ms | 13 | 50 ms
Value_100Ms | 14 | 100 ms
Value_200Ms | 15 | 200 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeAuxiliaryMeasurementAveragingSample Enumeration

IRD

Max11801TypeAuxiliaryMeasurementAveragingSample Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAuxiliaryMeasurementAveragingSample
Public Enumeration TypeAuxiliaryMeasurementAveragingSample
public enum class TypeAuxiliaryMeasurementAveragingSample
type TypeAuxiliaryMeasurementAveragingSample
Members
Member name | Value | Description
SingleSampleNoAveraging | 0 | Single Sample, No Averaging
TakeFourSamples | 1 | Take Four Samples
TakeEightSamples | 2 | Take Eight Samples
Take16Samples | 3 | Take 16 Samples
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeAuxiliaryMeasurementDelay Enumeration

IRD

Max11801TypeAuxiliaryMeasurementDelay Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAuxiliaryMeasurementDelay
Public Enumeration TypeAuxiliaryMeasurementDelay
public enum class TypeAuxiliaryMeasurementDelay
type TypeAuxiliaryMeasurementDelay
Members
Member name | Value | Description
Value_10Us | 0 | 10 µs
Value_100Us | 1 | 100 µs
Value_500Us | 2 | 500 µs
Value_1Ms | 3 | 1 ms
Value_5Ms | 4 | 5 ms
Value_10Ms | 5 | 10 ms
Value_50Ms | 6 | 50 ms
Value_100Ms | 7 | 100 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeAuxiliaryMeasurementResolution Enumeration

IRD

Max11801TypeAuxiliaryMeasurementResolution Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAuxiliaryMeasurementResolution
Public Enumeration TypeAuxiliaryMeasurementResolution
public enum class TypeAuxiliaryMeasurementResolution
type TypeAuxiliaryMeasurementResolution
Members
Member name | Value | Description
Value_12BitConversion | 0 | 12-Bit Conversion
Value_8BitConversion | 1 | 8-Bit Conversion
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeAuxiliaryMeasurementSamplingTime Enumeration

IRD

Max11801TypeAuxiliaryMeasurementSamplingTime Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAuxiliaryMeasurementSamplingTime
Public Enumeration TypeAuxiliaryMeasurementSamplingTime
public enum class TypeAuxiliaryMeasurementSamplingTime
type TypeAuxiliaryMeasurementSamplingTime
Members
Member name | Value | Description
Value_4X2MHzOscillatorClockPeriod2Us | 0 | 4 x (2 MHz Oscillator Clock Period) = 2 µs
Value_16X2MHzOscillatorClockPeriod8Us | 1 | 16 x (2 MHz Oscillator Clock Period) = 8 µs
Value_64X2MHzOscillatorClockPeriod32Us | 2 | 64 x (2 MHz Oscillator Clock Period) = 32 µs
Value_256X2MHzOscillatorClockPeriod128Us | 3 | 256 x (2 MHz Oscillator Clock Period) = 128 µs
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeDelayedConversionTime Enumeration

IRD

Max11801TypeDelayedConversionTime Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDelayedConversionTime
Public Enumeration TypeDelayedConversionTime
public enum class TypeDelayedConversionTime
type TypeDelayedConversionTime
Members
Member name | Value | Description
Value_10Us | 0 | 10 µs
Value_20Us | 1 | 20 µs
Value_50Us | 2 | 50 µs
Value_80Us | 3 | 80 µs
Value_100Us | 4 | 100 µs
Value_200Us | 5 | 200 µs
Value_500Us | 6 | 500 µs
Value_800Us | 7 | 800 µs
Value_1Ms | 8 | 1 ms
Value_2Ms | 9 | 2 ms
Value_5Ms | 10 | 5 ms
Value_10Ms | 11 | 10 ms
Value_20Ms | 12 | 20 ms
Value_50Ms | 13 | 50 ms
Value_100Ms | 14 | 100 ms
Value_200Ms | 15 | 200 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeGeneralConfiguratuionEdgeIrq Enumeration

IRD

Max11801TypeGeneralConfiguratuionEdgeIrq Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralConfiguratuionEdgeIrq
Public Enumeration TypeGeneralConfiguratuionEdgeIrq
public enum class TypeGeneralConfiguratuionEdgeIrq
type TypeGeneralConfiguratuionEdgeIrq
Members
Member name | Value | Description
UseContinuousInterrupt | 0 | Use Continuous Interrupt
UseEdgeInterrupt | 1 | Use Edge Interrupt
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeGeneralConfiguratuionEdgeTime Enumeration

IRD

Max11801TypeGeneralConfiguratuionEdgeTime Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralConfiguratuionEdgeTime
Public Enumeration TypeGeneralConfiguratuionEdgeTime
public enum class TypeGeneralConfiguratuionEdgeTime
type TypeGeneralConfiguratuionEdgeTime
Members
Member name | Value | Description
Value_4X2MHzOscillatorClockPeriod2Us | 0 | 4 x (2 MHz Oscillator Clock Period) = 2 µs
Value_16X2MHzOscillatorClockPeriod8Us | 1 | 16 x (2 MHz Oscillator Clock Period) = 8 µs
Value_64X2MHzOscillatorClockPeriod32Us | 2 | 64 x (2 MHz Oscillator Clock Period) = 32 µs
Value_128X2MHzOscillatorClockPeriod128Us | 3 | 128 x (2 MHz Oscillator Clock Period) = 128 µs
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeGeneralConfiguratuionHold Enumeration

IRD

Max11801TypeGeneralConfiguratuionHold Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralConfiguratuionHold
Public Enumeration TypeGeneralConfiguratuionHold
public enum class TypeGeneralConfiguratuionHold
type TypeGeneralConfiguratuionHold
Members
Member name | Value | Description
DOUTInternalBusHolderDisable | 0 | DOUT Internal Bus Holder: Disable
DOUTInternalBusHolderEnable | 1 | DOUT Internal Bus Holder: Enable
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeGeneralConfiguratuionMask Enumeration

IRD

Max11801TypeGeneralConfiguratuionMask Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralConfiguratuionMask
Public Enumeration TypeGeneralConfiguratuionMask
public enum class TypeGeneralConfiguratuionMask
type TypeGeneralConfiguratuionMask
Members
Member name | Value | Description
EnableTIRQOutput | 0 | Enable ^TIRQ Output
MaskDisableTIRGOutput | 1 | Mask/Disable ^TIRG Output
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeGeneralConfiguratuionOdn Enumeration

IRD

Max11801TypeGeneralConfiguratuionOdn Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralConfiguratuionOdn
Public Enumeration TypeGeneralConfiguratuionOdn
public enum class TypeGeneralConfiguratuionOdn
type TypeGeneralConfiguratuionOdn
Members
Member name | Value | Description
TIRQISCMOSBufferedOutput | 0 | ^TIRQ IS CMOS Buffered Output
TIRQIsOpenDrainNMOSOutput | 1 | ^TIRQ Is Open-Drain nMOS Output
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeGeneralConfiguratuionPuIrq Enumeration

IRD

Max11801TypeGeneralConfiguratuionPuIrq Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralConfiguratuionPuIrq
Public Enumeration TypeGeneralConfiguratuionPuIrq
public enum class TypeGeneralConfiguratuionPuIrq
type TypeGeneralConfiguratuionPuIrq
Members
Member name | Value | Description
IRQInternalPullupResistanceDisable | 0 | IRQ Internal Pullup Resistance: Disable
IRQInternalPullupResistanceEnable | 1 | IRQ Internal Pullup Resistance: Enable
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeGeneralConfiguratuionRtSel Enumeration

IRD

Max11801TypeGeneralConfiguratuionRtSel Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralConfiguratuionRtSel
Public Enumeration TypeGeneralConfiguratuionRtSel
public enum class TypeGeneralConfiguratuionRtSel
type TypeGeneralConfiguratuionRtSel
Members
Member name | Value | Description
Value_50KOhmTouchDetectionPullupResistance | 0 | 50 kOhm Touch-Detection Pullup Resistance
Value_100KOhmTouchDetectionPullupResistance | 1 | 100 kOhm Touch-Detection Pullup Resistance
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeGeneralStatusAdc Enumeration

IRD

Max11801TypeGeneralStatusAdc Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralStatusAdc
Public Enumeration TypeGeneralStatusAdc
public enum class TypeGeneralStatusAdc
type TypeGeneralStatusAdc
Members
Member name | Value | Description
ADCIsNotInACQOrCONVState | 0 | ADC Is Not In ACQ Or CONV State
ADCIsInACQOrCONVState | 1 | ADC Is In ACQ Or CONV State
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeGeneralStatusCont Enumeration

IRD

Max11801TypeGeneralStatusCont Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralStatusCont
Public Enumeration TypeGeneralStatusCont
public enum class TypeGeneralStatusCont
type TypeGeneralStatusCont
Members
Member name | Value | Description
NoTouchPresent | 0 | No Touch Present
TouchPresent | 1 | Touch Present
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeGeneralStatusEdge Enumeration

IRD

Max11801TypeGeneralStatusEdge Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralStatusEdge
Public Enumeration TypeGeneralStatusEdge
public enum class TypeGeneralStatusEdge
type TypeGeneralStatusEdge
Members
Member name | Value | Description
NoTouchEventInProgress | 0 | No Touch Event In Progress
TouchEventInProgress | 1 | Touch Event In Progress
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeGeneralStatusFifoInt Enumeration

IRD

Max11801TypeGeneralStatusFifoInt Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralStatusFifoInt
Public Enumeration TypeGeneralStatusFifoInt
public enum class TypeGeneralStatusFifoInt
type TypeGeneralStatusFifoInt
Members
Member name | Value | Description
NoUnreadDataInFIFO | 0 | No Unread Data In FIFO
NewDataAvailableInFIFO | 1 | New Data Available In FIFO
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeGeneralStatusFifoOvr Enumeration

IRD

Max11801TypeGeneralStatusFifoOvr Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralStatusFifoOvr
Public Enumeration TypeGeneralStatusFifoOvr
public enum class TypeGeneralStatusFifoOvr
type TypeGeneralStatusFifoOvr
Members
Member name | Value | Description
FIFOOverflowNotOccurred | 0 | FIFO Overflow: Not Occurred
FiFOOverflowOccurredSinceLastReadbackOperation | 1 | FiFO Overflow: Occurred Since Last Readback Operation
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeGeneralStatusLpm Enumeration

IRD

Max11801TypeGeneralStatusLpm Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralStatusLpm
Public Enumeration TypeGeneralStatusLpm
public enum class TypeGeneralStatusLpm
type TypeGeneralStatusLpm
Members
Member name | Value | Description
DeviceIsNotInLPMOrStandbyMode | 0 | Device Is Not In LPM Or Standby Mode
DeviceIsInLPMOrStandbyMode | 1 | Device Is In LPM Or Standby Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeGeneralStatusScan Enumeration

IRD

Max11801TypeGeneralStatusScan Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralStatusScan
Public Enumeration TypeGeneralStatusScan
public enum class TypeGeneralStatusScan
type TypeGeneralStatusScan
Members
Member name | Value | Description
ScanOrMeasurementNotInProgress | 0 | Scan Or Measurement: Not In Progress
ScanOrMeasurementInProgress | 1 | Scan Or Measurement: In Progress
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeGeneralStatusTdm Enumeration

IRD

Max11801TypeGeneralStatusTdm Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralStatusTdm
Public Enumeration TypeGeneralStatusTdm
public enum class TypeGeneralStatusTdm
type TypeGeneralStatusTdm
Members
Member name | Value | Description
DeviceIsNotInTDMMode | 0 | Device Is Not In TDM Mode
DeviceIsInTDMMode | 1 | Device Is In TDM Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeMeasurementAveragingAvg Enumeration

IRD

Max11801TypeMeasurementAveragingAvg Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMeasurementAveragingAvg
Public Enumeration TypeMeasurementAveragingAvg
public enum class TypeMeasurementAveragingAvg
type TypeMeasurementAveragingAvg
Members
Member name | Value | Description
SingleSampleNoAveraging | 0 | Single Sample, No Averaging
TakeFourSample | 1 | Take Four Sample
TakeEightSample | 2 | Take Eight Sample
Take16Sample | 3 | Take 16 Sample
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeMeasurementResolutionPwr Enumeration

IRD

Max11801TypeMeasurementResolutionPwr Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMeasurementResolutionPwr
Public Enumeration TypeMeasurementResolutionPwr
public enum class TypeMeasurementResolutionPwr
type TypeMeasurementResolutionPwr
Members
Member name | Value | Description
InternalADCRunsAtNormalPower | 0 | Internal ADC Runs At: Normal Power
InternalADCRunsAtReducedPower | 1 | Internal ADC Runs At: Reduced Power
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeMeasurementResolutionRes Enumeration

IRD

Max11801TypeMeasurementResolutionRes Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMeasurementResolutionRes
Public Enumeration TypeMeasurementResolutionRes
public enum class TypeMeasurementResolutionRes
type TypeMeasurementResolutionRes
Members
Member name | Value | Description
Value_12BitConversion | 0 | 12-Bit Conversion
Value_8BitConversion | 1 | 8-Bit Conversion
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeOperatingModeAperture Enumeration

IRD

Max11801TypeOperatingModeAperture Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperatingModeAperture
Public Enumeration TypeOperatingModeAperture
public enum class TypeOperatingModeAperture
type TypeOperatingModeAperture
Members
Member name | Value | Description
DisregardApertureCriteria | 0 | Disregard Aperture Criteria
EnableApertureCriteria | 1 | Enable Aperture Criteria
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeOperatingModeAveraging Enumeration

IRD

Max11801TypeOperatingModeAveraging Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperatingModeAveraging
Public Enumeration TypeOperatingModeAveraging
public enum class TypeOperatingModeAveraging
type TypeOperatingModeAveraging
Members
Member name | Value | Description
UseMedianAveragingFilter | 0 | Use Median Averaging Filter
UseStraightAveragingFilter | 1 | Use Straight Averaging Filter
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeOperatingModeConversion Enumeration

IRD

Max11801TypeOperatingModeConversion Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperatingModeConversion
Public Enumeration TypeOperatingModeConversion
public enum class TypeOperatingModeConversion
type TypeOperatingModeConversion
Members
Member name | Value | Description
DeviceConversionMode | 0 | Device Conversion Mode
AutonomousXAndYScan | 1 | Autonomous X And Y Scan
AutonomousXYZ1Scan | 2 | Autonomous X, Y, Z1 Scan
AutonomousXYZ1Z2Scan | 3 | Autonomous X, Y, Z1, Z2 Scan
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeOperatingModePosition Enumeration

IRD

Max11801TypeOperatingModePosition Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperatingModePosition
Public Enumeration TypeOperatingModePosition
public enum class TypeOperatingModePosition
type TypeOperatingModePosition
Members
Member name | Value | Description
DisableXYPositionAveragingInSelectedMode | 0 | Disable (X,Y) Position Averaging In Selected Mode
EnableXYPositionAveragingInSelectedMode | 1 | Enable (X,Y) Position Averaging In Selected Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeOperatingModePower Enumeration

IRD

Max11801TypeOperatingModePower Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperatingModePower
Public Enumeration TypeOperatingModePower
public enum class TypeOperatingModePower
type TypeOperatingModePower
Members
Member name | Value | Description
DeviceIsPowerdedUp | 0 | Device Is Powerded Up
DeviceIsPowerdedDown | 1 | Device Is Powerded Down
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeOperatingModePressure Enumeration

IRD

Max11801TypeOperatingModePressure Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperatingModePressure
Public Enumeration TypeOperatingModePressure
public enum class TypeOperatingModePressure
type TypeOperatingModePressure
Members
Member name | Value | Description
DisableZ1Z2PressureAveragingInSelectedMode | 0 | Disable (Z1, Z2) Pressure Averaging In Selected Mode
EnableZ1Z2PressureAveragingInSelectedMode | 1 | Enable (Z1, Z2) Pressure Averaging In Selected Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypePanelSetupTimingPsu Enumeration

IRD

Max11801TypePanelSetupTimingPsu Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePanelSetupTimingPsu
Public Enumeration TypePanelSetupTimingPsu
public enum class TypePanelSetupTimingPsu
type TypePanelSetupTimingPsu
Members
Member name | Value | Description
Value_0Us | 0 | 0 µs
Value_20Us | 1 | 20 µs
Value_50Us | 2 | 50 µs
Value_80Us | 3 | 80 µs
Value_100Us | 4 | 100 µs
Value_200Us | 5 | 200 µs
Value_500Us | 6 | 500 µs
Value_800Us | 7 | 800 µs
Value_1Ms | 8 | 1 ms
Value_2Ms | 9 | 2 ms
Value_5Ms | 10 | 5 ms
Value_10Ms | 11 | 10 ms
Value_20Ms | 12 | 20 ms
Value_50Ms | 13 | 50 ms
Value_100Ms | 14 | 100 ms
Value_200Ms | 15 | 200 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeTouchDetectPullupPuf Enumeration

IRD

Max11801TypeTouchDetectPullupPuf Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTouchDetectPullupPuf
Public Enumeration TypeTouchDetectPullupPuf
public enum class TypeTouchDetectPullupPuf
type TypeTouchDetectPullupPuf
Members
Member name | Value | Description
Value_10Us | 0 | 10 µs
Value_20Us | 1 | 20 µs
Value_50Us | 2 | 50 µs
Value_80Us | 3 | 80 µs
Value_100Us | 4 | 100 µs
Value_200Us | 5 | 200 µs
Value_500Us | 6 | 500 µs
Value_800Us | 7 | 800 µs
Value_1Ms | 8 | 1 ms
Value_2Ms | 9 | 2 ms
Value_5Ms | 10 | 5 ms
Value_10Ms | 11 | 10 ms
Value_20Ms | 12 | 20 ms
Value_50Ms | 13 | 50 ms
Value_100Ms | 14 | 100 ms
Value_200Ms | 15 | 200 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max11801.TypeTouchDetectPullupPur Enumeration

IRD

Max11801TypeTouchDetectPullupPur Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTouchDetectPullupPur
Public Enumeration TypeTouchDetectPullupPur
public enum class TypeTouchDetectPullupPur
type TypeTouchDetectPullupPur
Members
Member name | Value | Description
Value_2Us | 0 | 2 µs
Value_2Us__1 | 1 | 2 µs
Value_4Us | 2 | 4 µs
Value_8Us | 3 | 8 µs
Value_10Us | 4 | 10 µs
Value_50Us | 5 | 50 µs
Value_100Us | 6 | 100 µs
Value_500Us | 7 | 500 µs
Value_1Ms | 8 | 1 ms
Value_2Ms | 9 | 2 ms
Value_5Ms | 10 | 5 ms
Value_10Ms | 11 | 10 ms
Value_20Ms | 12 | 20 ms
Value_50Ms | 13 | 50 ms
Value_100Ms | 14 | 100 ms
Value_200Ms | 15 | 200 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max11803 Class

Maxim: MAX 11803
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax11803

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max11803
Public Class Max11803
public ref class Max11803
type Max11803 =  class end

The Max11803 type exposes the following members.

Constructors
 | Name | Description
Public method | Max11803 | Constructor
Top
Properties
 | Name | Description
Public property | ADCSamplingTimeTSAMPLEX | ADC Sampling Time: T_SAMPLE_X
Public property | ADCSamplingTimeTSAMPLEY | ADC Sampling Time: T_SAMPLE_Y
Public property | ADCSamplingTimeTSAMPLEZ1 | ADC Sampling Time: T_SAMPLE_Z1
Public property | ADCSamplingTimeTSAMPLEZ2 | ADC Sampling Time: T_SAMPLE_Z2
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AUXConversion | AUX Conversion
Public property | AuxiliaryMeasurementAVGA | Auxiliary Measurement: AVGA
Public property | AuxiliaryMeasurementDCVA | Auxiliary Measurement: D_CV_A
Public property | AuxiliaryMeasurementRESA | Auxiliary Measurement: RESA
Public property | AuxiliaryMeasurementTSAMPLEA | Auxiliary Measurement: T_SAMPLE_A
Public property | DelayConversionDCVZ | Delay Conversion: D_CV_Z
Public property | DelayedConversionDCVXY | Delayed Conversion: D_CV_XY
Public property | DirectConversionModeAUX | Direct Conversion Mode: AUX
Public property | DirectConversionModeX | Direct Conversion Mode: X
Public property | DirectConversionModeY | Direct Conversion Mode: Y
Public property | DirectConversionModeZ1 | Direct Conversion Mode: Z1
Public property | DirectConversionModeZ2 | Direct Conversion Mode: Z2
Public property | GeneralConfigurationEDGEIRQ | General Configuration: EDGE_IRQ
Public property | GeneralConfigurationEDGETIME | General Configuration: EDGE_TIME
Public property | GeneralConfigurationHOLDDO | General Configuration: HOLD_DO
Public property | GeneralConfigurationMASKIRQ | General Configuration: MASK_IRQ
Public property | GeneralConfigurationODNIRQ | General Configuration: ODN_IRQ
Public property | GeneralConfigurationPUIRQ | General Configuration: PU_IRQ
Public property | GeneralConfigurationRTSEL | General Configuration: RT_SEL
Public property | GeneralStatusADCBUSY | General Status: ADC_BUSY
Public property | GeneralStatusCONTINT | General Status: CONT_INT
Public property | GeneralStatusEDGEINT | General Status: EDGE_INT
Public property | GeneralStatusFIFOINT | General Status: FIFO_INT
Public property | GeneralStatusFIFOOVR | General Status: FIFO_OVR
Public property | GeneralStatusLPM | General Status: LPM
Public property | GeneralStatusSCAN | General Status: SCAN
Public property | GeneralStatusTDM | General Status: TDM
Public property | MeasurementAveragingAVGX | Measurement Averaging: AVG_X
Public property | MeasurementAveragingAVGY | Measurement Averaging: AVG_Y
Public property | MeasurementAveragingAVGZ1 | Measurement Averaging: AVG_Z1
Public property | MeasurementAveragingAVGZ2 | Measurement Averaging: AVG_Z2
Public property | MeasurementResolutionPWRSAV | Measurement Resolution: PWR_SAV
Public property | MeasurementResolutionRESX | Measurement Resolution: RESX
Public property | MeasurementResolutionRESY | Measurement Resolution: RESY
Public property | MeasurementResolutionRESZ1 | Measurement Resolution: RESZ1
Public property | MeasurementResolutionRESZ2 | Measurement Resolution: RESZ2
Public property | OperatingModeAMODE | Operating Mode: AMODE
Public property | OperatingModeAPER | Operating Mode: APER
Public property | OperatingModeAVGFLT | Operating Mode: AVG_FLT
Public property | OperatingModeENAVGXY | Operating Mode: EN_AVG_XY
Public property | OperatingModeENAVGZ | Operating Mode: EN_AVG_Z
Public property | OperatingModePWRDN | Operating Mode: PWRDN
Public property | PanelSetupTimingPSUXY | Panel Setup Timing: PSUXY
Public property | PanelSetupTimingPSUZ | Panel Setup Timing: PSUZ
Public property | TouchDetectPullupPUF | Touch Detect Pullup: PUF
Public property | TouchDetectPullupPUR | Touch Detect Pullup: PUR
Public property | XMeasurementCONT0 | X Measurement CONT0
Public property | XMeasurementCONT1 | X Measurement CONT1
Public property | XPanelSetup | X Panel Setup
Public property | XYCombinedCommand | XY Combined Command
Public property | XYZ1CombinedCommand | XYZ1 Combined Command
Public property | XYZ1Z2CombinedCommand | XYZ1Z2 Combined Command
Public property | YMeasurementCONT0 | Y Measurement CONT0
Public property | YMeasurementCONT1 | Y Measurement CONT1
Public property | YPanelSetup | Y Panel Setup
Public property | Z1MeasurementCONT0 | Z1 Measurement CONT0
Public property | Z1MeasurementCONT1 | Z1 Measurement CONT1
Public property | Z1PanelSetup | Z1 Panel Setup
Public property | Z2MeasurementCONT0 | Z2 Measurement CONT0
Public property | Z2MeasurementCONT1 | Z2 Measurement CONT1
Public property | Z2PanelSetup | Z2 Panel Setup
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Ultra-Small ResistiveTouch-Screen Controller
See Also

Reference

telos.Ird.Maxim Namespace


Max11803 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max11803(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max11803

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803 Properties

The Max11803 type exposes the following members.

Properties
 | Name | Description
Public property | ADCSamplingTimeTSAMPLEX | ADC Sampling Time: T_SAMPLE_X
Public property | ADCSamplingTimeTSAMPLEY | ADC Sampling Time: T_SAMPLE_Y
Public property | ADCSamplingTimeTSAMPLEZ1 | ADC Sampling Time: T_SAMPLE_Z1
Public property | ADCSamplingTimeTSAMPLEZ2 | ADC Sampling Time: T_SAMPLE_Z2
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AUXConversion | AUX Conversion
Public property | AuxiliaryMeasurementAVGA | Auxiliary Measurement: AVGA
Public property | AuxiliaryMeasurementDCVA | Auxiliary Measurement: D_CV_A
Public property | AuxiliaryMeasurementRESA | Auxiliary Measurement: RESA
Public property | AuxiliaryMeasurementTSAMPLEA | Auxiliary Measurement: T_SAMPLE_A
Public property | DelayConversionDCVZ | Delay Conversion: D_CV_Z
Public property | DelayedConversionDCVXY | Delayed Conversion: D_CV_XY
Public property | DirectConversionModeAUX | Direct Conversion Mode: AUX
Public property | DirectConversionModeX | Direct Conversion Mode: X
Public property | DirectConversionModeY | Direct Conversion Mode: Y
Public property | DirectConversionModeZ1 | Direct Conversion Mode: Z1
Public property | DirectConversionModeZ2 | Direct Conversion Mode: Z2
Public property | GeneralConfigurationEDGEIRQ | General Configuration: EDGE_IRQ
Public property | GeneralConfigurationEDGETIME | General Configuration: EDGE_TIME
Public property | GeneralConfigurationHOLDDO | General Configuration: HOLD_DO
Public property | GeneralConfigurationMASKIRQ | General Configuration: MASK_IRQ
Public property | GeneralConfigurationODNIRQ | General Configuration: ODN_IRQ
Public property | GeneralConfigurationPUIRQ | General Configuration: PU_IRQ
Public property | GeneralConfigurationRTSEL | General Configuration: RT_SEL
Public property | GeneralStatusADCBUSY | General Status: ADC_BUSY
Public property | GeneralStatusCONTINT | General Status: CONT_INT
Public property | GeneralStatusEDGEINT | General Status: EDGE_INT
Public property | GeneralStatusFIFOINT | General Status: FIFO_INT
Public property | GeneralStatusFIFOOVR | General Status: FIFO_OVR
Public property | GeneralStatusLPM | General Status: LPM
Public property | GeneralStatusSCAN | General Status: SCAN
Public property | GeneralStatusTDM | General Status: TDM
Public property | MeasurementAveragingAVGX | Measurement Averaging: AVG_X
Public property | MeasurementAveragingAVGY | Measurement Averaging: AVG_Y
Public property | MeasurementAveragingAVGZ1 | Measurement Averaging: AVG_Z1
Public property | MeasurementAveragingAVGZ2 | Measurement Averaging: AVG_Z2
Public property | MeasurementResolutionPWRSAV | Measurement Resolution: PWR_SAV
Public property | MeasurementResolutionRESX | Measurement Resolution: RESX
Public property | MeasurementResolutionRESY | Measurement Resolution: RESY
Public property | MeasurementResolutionRESZ1 | Measurement Resolution: RESZ1
Public property | MeasurementResolutionRESZ2 | Measurement Resolution: RESZ2
Public property | OperatingModeAMODE | Operating Mode: AMODE
Public property | OperatingModeAPER | Operating Mode: APER
Public property | OperatingModeAVGFLT | Operating Mode: AVG_FLT
Public property | OperatingModeENAVGXY | Operating Mode: EN_AVG_XY
Public property | OperatingModeENAVGZ | Operating Mode: EN_AVG_Z
Public property | OperatingModePWRDN | Operating Mode: PWRDN
Public property | PanelSetupTimingPSUXY | Panel Setup Timing: PSUXY
Public property | PanelSetupTimingPSUZ | Panel Setup Timing: PSUZ
Public property | TouchDetectPullupPUF | Touch Detect Pullup: PUF
Public property | TouchDetectPullupPUR | Touch Detect Pullup: PUR
Public property | XMeasurementCONT0 | X Measurement CONT0
Public property | XMeasurementCONT1 | X Measurement CONT1
Public property | XPanelSetup | X Panel Setup
Public property | XYCombinedCommand | XY Combined Command
Public property | XYZ1CombinedCommand | XYZ1 Combined Command
Public property | XYZ1Z2CombinedCommand | XYZ1Z2 Combined Command
Public property | YMeasurementCONT0 | Y Measurement CONT0
Public property | YMeasurementCONT1 | Y Measurement CONT1
Public property | YPanelSetup | Y Panel Setup
Public property | Z1MeasurementCONT0 | Z1 Measurement CONT0
Public property | Z1MeasurementCONT1 | Z1 Measurement CONT1
Public property | Z1PanelSetup | Z1 Panel Setup
Public property | Z2MeasurementCONT0 | Z2 Measurement CONT0
Public property | Z2MeasurementCONT1 | Z2 Measurement CONT1
Public property | Z2PanelSetup | Z2 Panel Setup
Top
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.ADCSamplingTimeTSAMPLEX Property

IRD

Max11803ADCSamplingTimeTSAMPLEX Property

ADC Sampling Time: T_SAMPLE_X

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeAdcSamplingTime ADCSamplingTimeTSAMPLEX { get; set; }
Public Property ADCSamplingTimeTSAMPLEX As Max11803TypeAdcSamplingTime
    Get
    Set
public:
property Max11803TypeAdcSamplingTime ADCSamplingTimeTSAMPLEX {
    Max11803TypeAdcSamplingTime get ();
    void set (Max11803TypeAdcSamplingTime value);
}
member ADCSamplingTimeTSAMPLEX : Max11803TypeAdcSamplingTime with get, set

Property Value

Type: Max11803TypeAdcSamplingTime
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.ADCSamplingTimeTSAMPLEY Property

IRD

Max11803ADCSamplingTimeTSAMPLEY Property

ADC Sampling Time: T_SAMPLE_Y

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeAdcSamplingTime ADCSamplingTimeTSAMPLEY { get; set; }
Public Property ADCSamplingTimeTSAMPLEY As Max11803TypeAdcSamplingTime
    Get
    Set
public:
property Max11803TypeAdcSamplingTime ADCSamplingTimeTSAMPLEY {
    Max11803TypeAdcSamplingTime get ();
    void set (Max11803TypeAdcSamplingTime value);
}
member ADCSamplingTimeTSAMPLEY : Max11803TypeAdcSamplingTime with get, set

Property Value

Type: Max11803TypeAdcSamplingTime
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.ADCSamplingTimeTSAMPLEZ1 Property

IRD

Max11803ADCSamplingTimeTSAMPLEZ1 Property

ADC Sampling Time: T_SAMPLE_Z1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeAdcSamplingTime ADCSamplingTimeTSAMPLEZ1 { get; set; }
Public Property ADCSamplingTimeTSAMPLEZ1 As Max11803TypeAdcSamplingTime
    Get
    Set
public:
property Max11803TypeAdcSamplingTime ADCSamplingTimeTSAMPLEZ1 {
    Max11803TypeAdcSamplingTime get ();
    void set (Max11803TypeAdcSamplingTime value);
}
member ADCSamplingTimeTSAMPLEZ1 : Max11803TypeAdcSamplingTime with get, set

Property Value

Type: Max11803TypeAdcSamplingTime
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.ADCSamplingTimeTSAMPLEZ2 Property

IRD

Max11803ADCSamplingTimeTSAMPLEZ2 Property

ADC Sampling Time: T_SAMPLE_Z2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeAdcSamplingTime ADCSamplingTimeTSAMPLEZ2 { get; set; }
Public Property ADCSamplingTimeTSAMPLEZ2 As Max11803TypeAdcSamplingTime
    Get
    Set
public:
property Max11803TypeAdcSamplingTime ADCSamplingTimeTSAMPLEZ2 {
    Max11803TypeAdcSamplingTime get ();
    void set (Max11803TypeAdcSamplingTime value);
}
member ADCSamplingTimeTSAMPLEZ2 : Max11803TypeAdcSamplingTime with get, set

Property Value

Type: Max11803TypeAdcSamplingTime
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.AutoFlush Property

IRD

Max11803AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.AUXConversion Property

IRD

Max11803AUXConversion Property

AUX Conversion

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AUXConversion { set; }
Public WriteOnly Property AUXConversion As Byte
    Set
public:
property unsigned char AUXConversion {
    void set (unsigned char value);
}
member AUXConversion : byte with set

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.AuxiliaryMeasurementAVGA Property

IRD

Max11803AuxiliaryMeasurementAVGA Property

Auxiliary Measurement: AVGA

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeAuxiliaryMeasurementAveragingSample AuxiliaryMeasurementAVGA { get; set; }
Public Property AuxiliaryMeasurementAVGA As Max11803TypeAuxiliaryMeasurementAveragingSample
    Get
    Set
public:
property Max11803TypeAuxiliaryMeasurementAveragingSample AuxiliaryMeasurementAVGA {
    Max11803TypeAuxiliaryMeasurementAveragingSample get ();
    void set (Max11803TypeAuxiliaryMeasurementAveragingSample value);
}
member AuxiliaryMeasurementAVGA : Max11803TypeAuxiliaryMeasurementAveragingSample with get, set

Property Value

Type: Max11803TypeAuxiliaryMeasurementAveragingSample
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.AuxiliaryMeasurementDCVA Property

IRD

Max11803AuxiliaryMeasurementDCVA Property

Auxiliary Measurement: D_CV_A

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeAuxiliaryMeasurementDelay AuxiliaryMeasurementDCVA { get; set; }
Public Property AuxiliaryMeasurementDCVA As Max11803TypeAuxiliaryMeasurementDelay
    Get
    Set
public:
property Max11803TypeAuxiliaryMeasurementDelay AuxiliaryMeasurementDCVA {
    Max11803TypeAuxiliaryMeasurementDelay get ();
    void set (Max11803TypeAuxiliaryMeasurementDelay value);
}
member AuxiliaryMeasurementDCVA : Max11803TypeAuxiliaryMeasurementDelay with get, set

Property Value

Type: Max11803TypeAuxiliaryMeasurementDelay
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.AuxiliaryMeasurementRESA Property

IRD

Max11803AuxiliaryMeasurementRESA Property

Auxiliary Measurement: RESA

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeAuxiliaryMeasurementResolution AuxiliaryMeasurementRESA { get; set; }
Public Property AuxiliaryMeasurementRESA As Max11803TypeAuxiliaryMeasurementResolution
    Get
    Set
public:
property Max11803TypeAuxiliaryMeasurementResolution AuxiliaryMeasurementRESA {
    Max11803TypeAuxiliaryMeasurementResolution get ();
    void set (Max11803TypeAuxiliaryMeasurementResolution value);
}
member AuxiliaryMeasurementRESA : Max11803TypeAuxiliaryMeasurementResolution with get, set

Property Value

Type: Max11803TypeAuxiliaryMeasurementResolution
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.AuxiliaryMeasurementTSAMPLEA Property

IRD

Max11803AuxiliaryMeasurementTSAMPLEA Property

Auxiliary Measurement: T_SAMPLE_A

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeAuxiliaryMeasurementSamplingTime AuxiliaryMeasurementTSAMPLEA { get; set; }
Public Property AuxiliaryMeasurementTSAMPLEA As Max11803TypeAuxiliaryMeasurementSamplingTime
    Get
    Set
public:
property Max11803TypeAuxiliaryMeasurementSamplingTime AuxiliaryMeasurementTSAMPLEA {
    Max11803TypeAuxiliaryMeasurementSamplingTime get ();
    void set (Max11803TypeAuxiliaryMeasurementSamplingTime value);
}
member AuxiliaryMeasurementTSAMPLEA : Max11803TypeAuxiliaryMeasurementSamplingTime with get, set

Property Value

Type: Max11803TypeAuxiliaryMeasurementSamplingTime
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.DelayConversionDCVZ Property

IRD

Max11803DelayConversionDCVZ Property

Delay Conversion: D_CV_Z

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeDelayedConversionTime DelayConversionDCVZ { get; set; }
Public Property DelayConversionDCVZ As Max11803TypeDelayedConversionTime
    Get
    Set
public:
property Max11803TypeDelayedConversionTime DelayConversionDCVZ {
    Max11803TypeDelayedConversionTime get ();
    void set (Max11803TypeDelayedConversionTime value);
}
member DelayConversionDCVZ : Max11803TypeDelayedConversionTime with get, set

Property Value

Type: Max11803TypeDelayedConversionTime
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.DelayedConversionDCVXY Property

IRD

Max11803DelayedConversionDCVXY Property

Delayed Conversion: D_CV_XY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeDelayedConversionTime DelayedConversionDCVXY { get; set; }
Public Property DelayedConversionDCVXY As Max11803TypeDelayedConversionTime
    Get
    Set
public:
property Max11803TypeDelayedConversionTime DelayedConversionDCVXY {
    Max11803TypeDelayedConversionTime get ();
    void set (Max11803TypeDelayedConversionTime value);
}
member DelayedConversionDCVXY : Max11803TypeDelayedConversionTime with get, set

Property Value

Type: Max11803TypeDelayedConversionTime
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.DirectConversionModeAUX Property

IRD

Max11803DirectConversionModeAUX Property

Direct Conversion Mode: AUX

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DirectConversionModeAUX { get; }
Public ReadOnly Property DirectConversionModeAUX As Byte
    Get
public:
property unsigned char DirectConversionModeAUX {
    unsigned char get ();
}
member DirectConversionModeAUX : byte with get

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.DirectConversionModeX Property

IRD

Max11803DirectConversionModeX Property

Direct Conversion Mode: X

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DirectConversionModeX { get; }
Public ReadOnly Property DirectConversionModeX As Byte
    Get
public:
property unsigned char DirectConversionModeX {
    unsigned char get ();
}
member DirectConversionModeX : byte with get

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.DirectConversionModeY Property

IRD

Max11803DirectConversionModeY Property

Direct Conversion Mode: Y

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DirectConversionModeY { get; }
Public ReadOnly Property DirectConversionModeY As Byte
    Get
public:
property unsigned char DirectConversionModeY {
    unsigned char get ();
}
member DirectConversionModeY : byte with get

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.DirectConversionModeZ1 Property

IRD

Max11803DirectConversionModeZ1 Property

Direct Conversion Mode: Z1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DirectConversionModeZ1 { get; }
Public ReadOnly Property DirectConversionModeZ1 As Byte
    Get
public:
property unsigned char DirectConversionModeZ1 {
    unsigned char get ();
}
member DirectConversionModeZ1 : byte with get

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.DirectConversionModeZ2 Property

IRD

Max11803DirectConversionModeZ2 Property

Direct Conversion Mode: Z2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DirectConversionModeZ2 { get; }
Public ReadOnly Property DirectConversionModeZ2 As Byte
    Get
public:
property unsigned char DirectConversionModeZ2 {
    unsigned char get ();
}
member DirectConversionModeZ2 : byte with get

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.GeneralConfigurationEDGEIRQ Property

IRD

Max11803GeneralConfigurationEDGEIRQ Property

General Configuration: EDGE_IRQ

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeGeneralConfiguratuionEdgeIrq GeneralConfigurationEDGEIRQ { get; set; }
Public Property GeneralConfigurationEDGEIRQ As Max11803TypeGeneralConfiguratuionEdgeIrq
    Get
    Set
public:
property Max11803TypeGeneralConfiguratuionEdgeIrq GeneralConfigurationEDGEIRQ {
    Max11803TypeGeneralConfiguratuionEdgeIrq get ();
    void set (Max11803TypeGeneralConfiguratuionEdgeIrq value);
}
member GeneralConfigurationEDGEIRQ : Max11803TypeGeneralConfiguratuionEdgeIrq with get, set

Property Value

Type: Max11803TypeGeneralConfiguratuionEdgeIrq
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.GeneralConfigurationEDGETIME Property

IRD

Max11803GeneralConfigurationEDGETIME Property

General Configuration: EDGE_TIME

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeGeneralConfiguratuionEdgeTime GeneralConfigurationEDGETIME { get; set; }
Public Property GeneralConfigurationEDGETIME As Max11803TypeGeneralConfiguratuionEdgeTime
    Get
    Set
public:
property Max11803TypeGeneralConfiguratuionEdgeTime GeneralConfigurationEDGETIME {
    Max11803TypeGeneralConfiguratuionEdgeTime get ();
    void set (Max11803TypeGeneralConfiguratuionEdgeTime value);
}
member GeneralConfigurationEDGETIME : Max11803TypeGeneralConfiguratuionEdgeTime with get, set

Property Value

Type: Max11803TypeGeneralConfiguratuionEdgeTime
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.GeneralConfigurationHOLDDO Property

IRD

Max11803GeneralConfigurationHOLDDO Property

General Configuration: HOLD_DO

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeGeneralConfiguratuionHold GeneralConfigurationHOLDDO { get; set; }
Public Property GeneralConfigurationHOLDDO As Max11803TypeGeneralConfiguratuionHold
    Get
    Set
public:
property Max11803TypeGeneralConfiguratuionHold GeneralConfigurationHOLDDO {
    Max11803TypeGeneralConfiguratuionHold get ();
    void set (Max11803TypeGeneralConfiguratuionHold value);
}
member GeneralConfigurationHOLDDO : Max11803TypeGeneralConfiguratuionHold with get, set

Property Value

Type: Max11803TypeGeneralConfiguratuionHold
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.GeneralConfigurationMASKIRQ Property

IRD

Max11803GeneralConfigurationMASKIRQ Property

General Configuration: MASK_IRQ

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeGeneralConfiguratuionMask GeneralConfigurationMASKIRQ { get; set; }
Public Property GeneralConfigurationMASKIRQ As Max11803TypeGeneralConfiguratuionMask
    Get
    Set
public:
property Max11803TypeGeneralConfiguratuionMask GeneralConfigurationMASKIRQ {
    Max11803TypeGeneralConfiguratuionMask get ();
    void set (Max11803TypeGeneralConfiguratuionMask value);
}
member GeneralConfigurationMASKIRQ : Max11803TypeGeneralConfiguratuionMask with get, set

Property Value

Type: Max11803TypeGeneralConfiguratuionMask
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.GeneralConfigurationODNIRQ Property

IRD

Max11803GeneralConfigurationODNIRQ Property

General Configuration: ODN_IRQ

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeGeneralConfiguratuionOdn GeneralConfigurationODNIRQ { get; set; }
Public Property GeneralConfigurationODNIRQ As Max11803TypeGeneralConfiguratuionOdn
    Get
    Set
public:
property Max11803TypeGeneralConfiguratuionOdn GeneralConfigurationODNIRQ {
    Max11803TypeGeneralConfiguratuionOdn get ();
    void set (Max11803TypeGeneralConfiguratuionOdn value);
}
member GeneralConfigurationODNIRQ : Max11803TypeGeneralConfiguratuionOdn with get, set

Property Value

Type: Max11803TypeGeneralConfiguratuionOdn
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.GeneralConfigurationPUIRQ Property

IRD

Max11803GeneralConfigurationPUIRQ Property

General Configuration: PU_IRQ

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeGeneralConfiguratuionPuIrq GeneralConfigurationPUIRQ { get; set; }
Public Property GeneralConfigurationPUIRQ As Max11803TypeGeneralConfiguratuionPuIrq
    Get
    Set
public:
property Max11803TypeGeneralConfiguratuionPuIrq GeneralConfigurationPUIRQ {
    Max11803TypeGeneralConfiguratuionPuIrq get ();
    void set (Max11803TypeGeneralConfiguratuionPuIrq value);
}
member GeneralConfigurationPUIRQ : Max11803TypeGeneralConfiguratuionPuIrq with get, set

Property Value

Type: Max11803TypeGeneralConfiguratuionPuIrq
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.GeneralConfigurationRTSEL Property

IRD

Max11803GeneralConfigurationRTSEL Property

General Configuration: RT_SEL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeGeneralConfiguratuionRtSel GeneralConfigurationRTSEL { get; set; }
Public Property GeneralConfigurationRTSEL As Max11803TypeGeneralConfiguratuionRtSel
    Get
    Set
public:
property Max11803TypeGeneralConfiguratuionRtSel GeneralConfigurationRTSEL {
    Max11803TypeGeneralConfiguratuionRtSel get ();
    void set (Max11803TypeGeneralConfiguratuionRtSel value);
}
member GeneralConfigurationRTSEL : Max11803TypeGeneralConfiguratuionRtSel with get, set

Property Value

Type: Max11803TypeGeneralConfiguratuionRtSel
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.GeneralStatusADCBUSY Property

IRD

Max11803GeneralStatusADCBUSY Property

General Status: ADC_BUSY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeGeneralStatusAdc GeneralStatusADCBUSY { get; }
Public ReadOnly Property GeneralStatusADCBUSY As Max11803TypeGeneralStatusAdc
    Get
public:
property Max11803TypeGeneralStatusAdc GeneralStatusADCBUSY {
    Max11803TypeGeneralStatusAdc get ();
}
member GeneralStatusADCBUSY : Max11803TypeGeneralStatusAdc with get

Property Value

Type: Max11803TypeGeneralStatusAdc
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.GeneralStatusCONTINT Property

IRD

Max11803GeneralStatusCONTINT Property

General Status: CONT_INT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeGeneralStatusCont GeneralStatusCONTINT { get; }
Public ReadOnly Property GeneralStatusCONTINT As Max11803TypeGeneralStatusCont
    Get
public:
property Max11803TypeGeneralStatusCont GeneralStatusCONTINT {
    Max11803TypeGeneralStatusCont get ();
}
member GeneralStatusCONTINT : Max11803TypeGeneralStatusCont with get

Property Value

Type: Max11803TypeGeneralStatusCont
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.GeneralStatusEDGEINT Property

IRD

Max11803GeneralStatusEDGEINT Property

General Status: EDGE_INT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeGeneralStatusEdge GeneralStatusEDGEINT { get; }
Public ReadOnly Property GeneralStatusEDGEINT As Max11803TypeGeneralStatusEdge
    Get
public:
property Max11803TypeGeneralStatusEdge GeneralStatusEDGEINT {
    Max11803TypeGeneralStatusEdge get ();
}
member GeneralStatusEDGEINT : Max11803TypeGeneralStatusEdge with get

Property Value

Type: Max11803TypeGeneralStatusEdge
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.GeneralStatusFIFOINT Property

IRD

Max11803GeneralStatusFIFOINT Property

General Status: FIFO_INT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeGeneralStatusFifoInt GeneralStatusFIFOINT { get; }
Public ReadOnly Property GeneralStatusFIFOINT As Max11803TypeGeneralStatusFifoInt
    Get
public:
property Max11803TypeGeneralStatusFifoInt GeneralStatusFIFOINT {
    Max11803TypeGeneralStatusFifoInt get ();
}
member GeneralStatusFIFOINT : Max11803TypeGeneralStatusFifoInt with get

Property Value

Type: Max11803TypeGeneralStatusFifoInt
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.GeneralStatusFIFOOVR Property

IRD

Max11803GeneralStatusFIFOOVR Property

General Status: FIFO_OVR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeGeneralStatusFifoOvr GeneralStatusFIFOOVR { get; }
Public ReadOnly Property GeneralStatusFIFOOVR As Max11803TypeGeneralStatusFifoOvr
    Get
public:
property Max11803TypeGeneralStatusFifoOvr GeneralStatusFIFOOVR {
    Max11803TypeGeneralStatusFifoOvr get ();
}
member GeneralStatusFIFOOVR : Max11803TypeGeneralStatusFifoOvr with get

Property Value

Type: Max11803TypeGeneralStatusFifoOvr
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.GeneralStatusLPM Property

IRD

Max11803GeneralStatusLPM Property

General Status: LPM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeGeneralStatusLpm GeneralStatusLPM { get; }
Public ReadOnly Property GeneralStatusLPM As Max11803TypeGeneralStatusLpm
    Get
public:
property Max11803TypeGeneralStatusLpm GeneralStatusLPM {
    Max11803TypeGeneralStatusLpm get ();
}
member GeneralStatusLPM : Max11803TypeGeneralStatusLpm with get

Property Value

Type: Max11803TypeGeneralStatusLpm
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.GeneralStatusSCAN Property

IRD

Max11803GeneralStatusSCAN Property

General Status: SCAN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeGeneralStatusScan GeneralStatusSCAN { get; }
Public ReadOnly Property GeneralStatusSCAN As Max11803TypeGeneralStatusScan
    Get
public:
property Max11803TypeGeneralStatusScan GeneralStatusSCAN {
    Max11803TypeGeneralStatusScan get ();
}
member GeneralStatusSCAN : Max11803TypeGeneralStatusScan with get

Property Value

Type: Max11803TypeGeneralStatusScan
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.GeneralStatusTDM Property

IRD

Max11803GeneralStatusTDM Property

General Status: TDM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeGeneralStatusTdm GeneralStatusTDM { get; }
Public ReadOnly Property GeneralStatusTDM As Max11803TypeGeneralStatusTdm
    Get
public:
property Max11803TypeGeneralStatusTdm GeneralStatusTDM {
    Max11803TypeGeneralStatusTdm get ();
}
member GeneralStatusTDM : Max11803TypeGeneralStatusTdm with get

Property Value

Type: Max11803TypeGeneralStatusTdm
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.MeasurementAveragingAVGX Property

IRD

Max11803MeasurementAveragingAVGX Property

Measurement Averaging: AVG_X

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeMeasurementAveragingAvg MeasurementAveragingAVGX { get; set; }
Public Property MeasurementAveragingAVGX As Max11803TypeMeasurementAveragingAvg
    Get
    Set
public:
property Max11803TypeMeasurementAveragingAvg MeasurementAveragingAVGX {
    Max11803TypeMeasurementAveragingAvg get ();
    void set (Max11803TypeMeasurementAveragingAvg value);
}
member MeasurementAveragingAVGX : Max11803TypeMeasurementAveragingAvg with get, set

Property Value

Type: Max11803TypeMeasurementAveragingAvg
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.MeasurementAveragingAVGY Property

IRD

Max11803MeasurementAveragingAVGY Property

Measurement Averaging: AVG_Y

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeMeasurementAveragingAvg MeasurementAveragingAVGY { get; set; }
Public Property MeasurementAveragingAVGY As Max11803TypeMeasurementAveragingAvg
    Get
    Set
public:
property Max11803TypeMeasurementAveragingAvg MeasurementAveragingAVGY {
    Max11803TypeMeasurementAveragingAvg get ();
    void set (Max11803TypeMeasurementAveragingAvg value);
}
member MeasurementAveragingAVGY : Max11803TypeMeasurementAveragingAvg with get, set

Property Value

Type: Max11803TypeMeasurementAveragingAvg
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.MeasurementAveragingAVGZ1 Property

IRD

Max11803MeasurementAveragingAVGZ1 Property

Measurement Averaging: AVG_Z1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeMeasurementAveragingAvg MeasurementAveragingAVGZ1 { get; set; }
Public Property MeasurementAveragingAVGZ1 As Max11803TypeMeasurementAveragingAvg
    Get
    Set
public:
property Max11803TypeMeasurementAveragingAvg MeasurementAveragingAVGZ1 {
    Max11803TypeMeasurementAveragingAvg get ();
    void set (Max11803TypeMeasurementAveragingAvg value);
}
member MeasurementAveragingAVGZ1 : Max11803TypeMeasurementAveragingAvg with get, set

Property Value

Type: Max11803TypeMeasurementAveragingAvg
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.MeasurementAveragingAVGZ2 Property

IRD

Max11803MeasurementAveragingAVGZ2 Property

Measurement Averaging: AVG_Z2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeMeasurementAveragingAvg MeasurementAveragingAVGZ2 { get; set; }
Public Property MeasurementAveragingAVGZ2 As Max11803TypeMeasurementAveragingAvg
    Get
    Set
public:
property Max11803TypeMeasurementAveragingAvg MeasurementAveragingAVGZ2 {
    Max11803TypeMeasurementAveragingAvg get ();
    void set (Max11803TypeMeasurementAveragingAvg value);
}
member MeasurementAveragingAVGZ2 : Max11803TypeMeasurementAveragingAvg with get, set

Property Value

Type: Max11803TypeMeasurementAveragingAvg
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.MeasurementResolutionPWRSAV Property

IRD

Max11803MeasurementResolutionPWRSAV Property

Measurement Resolution: PWR_SAV

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeMeasurementResolutionPwr MeasurementResolutionPWRSAV { get; set; }
Public Property MeasurementResolutionPWRSAV As Max11803TypeMeasurementResolutionPwr
    Get
    Set
public:
property Max11803TypeMeasurementResolutionPwr MeasurementResolutionPWRSAV {
    Max11803TypeMeasurementResolutionPwr get ();
    void set (Max11803TypeMeasurementResolutionPwr value);
}
member MeasurementResolutionPWRSAV : Max11803TypeMeasurementResolutionPwr with get, set

Property Value

Type: Max11803TypeMeasurementResolutionPwr
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.MeasurementResolutionRESX Property

IRD

Max11803MeasurementResolutionRESX Property

Measurement Resolution: RESX

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeMeasurementResolutionRes MeasurementResolutionRESX { get; set; }
Public Property MeasurementResolutionRESX As Max11803TypeMeasurementResolutionRes
    Get
    Set
public:
property Max11803TypeMeasurementResolutionRes MeasurementResolutionRESX {
    Max11803TypeMeasurementResolutionRes get ();
    void set (Max11803TypeMeasurementResolutionRes value);
}
member MeasurementResolutionRESX : Max11803TypeMeasurementResolutionRes with get, set

Property Value

Type: Max11803TypeMeasurementResolutionRes
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.MeasurementResolutionRESY Property

IRD

Max11803MeasurementResolutionRESY Property

Measurement Resolution: RESY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeMeasurementResolutionRes MeasurementResolutionRESY { get; set; }
Public Property MeasurementResolutionRESY As Max11803TypeMeasurementResolutionRes
    Get
    Set
public:
property Max11803TypeMeasurementResolutionRes MeasurementResolutionRESY {
    Max11803TypeMeasurementResolutionRes get ();
    void set (Max11803TypeMeasurementResolutionRes value);
}
member MeasurementResolutionRESY : Max11803TypeMeasurementResolutionRes with get, set

Property Value

Type: Max11803TypeMeasurementResolutionRes
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.MeasurementResolutionRESZ1 Property

IRD

Max11803MeasurementResolutionRESZ1 Property

Measurement Resolution: RESZ1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeMeasurementResolutionRes MeasurementResolutionRESZ1 { get; set; }
Public Property MeasurementResolutionRESZ1 As Max11803TypeMeasurementResolutionRes
    Get
    Set
public:
property Max11803TypeMeasurementResolutionRes MeasurementResolutionRESZ1 {
    Max11803TypeMeasurementResolutionRes get ();
    void set (Max11803TypeMeasurementResolutionRes value);
}
member MeasurementResolutionRESZ1 : Max11803TypeMeasurementResolutionRes with get, set

Property Value

Type: Max11803TypeMeasurementResolutionRes
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.MeasurementResolutionRESZ2 Property

IRD

Max11803MeasurementResolutionRESZ2 Property

Measurement Resolution: RESZ2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeMeasurementResolutionRes MeasurementResolutionRESZ2 { get; set; }
Public Property MeasurementResolutionRESZ2 As Max11803TypeMeasurementResolutionRes
    Get
    Set
public:
property Max11803TypeMeasurementResolutionRes MeasurementResolutionRESZ2 {
    Max11803TypeMeasurementResolutionRes get ();
    void set (Max11803TypeMeasurementResolutionRes value);
}
member MeasurementResolutionRESZ2 : Max11803TypeMeasurementResolutionRes with get, set

Property Value

Type: Max11803TypeMeasurementResolutionRes
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.OperatingModeAMODE Property

IRD

Max11803OperatingModeAMODE Property

Operating Mode: AMODE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeOperatingModeConversion OperatingModeAMODE { get; set; }
Public Property OperatingModeAMODE As Max11803TypeOperatingModeConversion
    Get
    Set
public:
property Max11803TypeOperatingModeConversion OperatingModeAMODE {
    Max11803TypeOperatingModeConversion get ();
    void set (Max11803TypeOperatingModeConversion value);
}
member OperatingModeAMODE : Max11803TypeOperatingModeConversion with get, set

Property Value

Type: Max11803TypeOperatingModeConversion
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.OperatingModeAPER Property

IRD

Max11803OperatingModeAPER Property

Operating Mode: APER

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeOperatingModeAperture OperatingModeAPER { get; set; }
Public Property OperatingModeAPER As Max11803TypeOperatingModeAperture
    Get
    Set
public:
property Max11803TypeOperatingModeAperture OperatingModeAPER {
    Max11803TypeOperatingModeAperture get ();
    void set (Max11803TypeOperatingModeAperture value);
}
member OperatingModeAPER : Max11803TypeOperatingModeAperture with get, set

Property Value

Type: Max11803TypeOperatingModeAperture
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.OperatingModeAVGFLT Property

IRD

Max11803OperatingModeAVGFLT Property

Operating Mode: AVG_FLT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeOperatingModeAveraging OperatingModeAVGFLT { get; set; }
Public Property OperatingModeAVGFLT As Max11803TypeOperatingModeAveraging
    Get
    Set
public:
property Max11803TypeOperatingModeAveraging OperatingModeAVGFLT {
    Max11803TypeOperatingModeAveraging get ();
    void set (Max11803TypeOperatingModeAveraging value);
}
member OperatingModeAVGFLT : Max11803TypeOperatingModeAveraging with get, set

Property Value

Type: Max11803TypeOperatingModeAveraging
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.OperatingModeENAVGXY Property

IRD

Max11803OperatingModeENAVGXY Property

Operating Mode: EN_AVG_XY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeOperatingModePosition OperatingModeENAVGXY { get; set; }
Public Property OperatingModeENAVGXY As Max11803TypeOperatingModePosition
    Get
    Set
public:
property Max11803TypeOperatingModePosition OperatingModeENAVGXY {
    Max11803TypeOperatingModePosition get ();
    void set (Max11803TypeOperatingModePosition value);
}
member OperatingModeENAVGXY : Max11803TypeOperatingModePosition with get, set

Property Value

Type: Max11803TypeOperatingModePosition
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.OperatingModeENAVGZ Property

IRD

Max11803OperatingModeENAVGZ Property

Operating Mode: EN_AVG_Z

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeOperatingModePressure OperatingModeENAVGZ { get; set; }
Public Property OperatingModeENAVGZ As Max11803TypeOperatingModePressure
    Get
    Set
public:
property Max11803TypeOperatingModePressure OperatingModeENAVGZ {
    Max11803TypeOperatingModePressure get ();
    void set (Max11803TypeOperatingModePressure value);
}
member OperatingModeENAVGZ : Max11803TypeOperatingModePressure with get, set

Property Value

Type: Max11803TypeOperatingModePressure
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.OperatingModePWRDN Property

IRD

Max11803OperatingModePWRDN Property

Operating Mode: PWRDN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeOperatingModePower OperatingModePWRDN { get; set; }
Public Property OperatingModePWRDN As Max11803TypeOperatingModePower
    Get
    Set
public:
property Max11803TypeOperatingModePower OperatingModePWRDN {
    Max11803TypeOperatingModePower get ();
    void set (Max11803TypeOperatingModePower value);
}
member OperatingModePWRDN : Max11803TypeOperatingModePower with get, set

Property Value

Type: Max11803TypeOperatingModePower
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.PanelSetupTimingPSUXY Property

IRD

Max11803PanelSetupTimingPSUXY Property

Panel Setup Timing: PSUXY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypePanelSetupTimingPsu PanelSetupTimingPSUXY { get; set; }
Public Property PanelSetupTimingPSUXY As Max11803TypePanelSetupTimingPsu
    Get
    Set
public:
property Max11803TypePanelSetupTimingPsu PanelSetupTimingPSUXY {
    Max11803TypePanelSetupTimingPsu get ();
    void set (Max11803TypePanelSetupTimingPsu value);
}
member PanelSetupTimingPSUXY : Max11803TypePanelSetupTimingPsu with get, set

Property Value

Type: Max11803TypePanelSetupTimingPsu
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.PanelSetupTimingPSUZ Property

IRD

Max11803PanelSetupTimingPSUZ Property

Panel Setup Timing: PSUZ

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypePanelSetupTimingPsu PanelSetupTimingPSUZ { get; set; }
Public Property PanelSetupTimingPSUZ As Max11803TypePanelSetupTimingPsu
    Get
    Set
public:
property Max11803TypePanelSetupTimingPsu PanelSetupTimingPSUZ {
    Max11803TypePanelSetupTimingPsu get ();
    void set (Max11803TypePanelSetupTimingPsu value);
}
member PanelSetupTimingPSUZ : Max11803TypePanelSetupTimingPsu with get, set

Property Value

Type: Max11803TypePanelSetupTimingPsu
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.TouchDetectPullupPUF Property

IRD

Max11803TouchDetectPullupPUF Property

Touch Detect Pullup: PUF

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeTouchDetectPullupPuf TouchDetectPullupPUF { get; set; }
Public Property TouchDetectPullupPUF As Max11803TypeTouchDetectPullupPuf
    Get
    Set
public:
property Max11803TypeTouchDetectPullupPuf TouchDetectPullupPUF {
    Max11803TypeTouchDetectPullupPuf get ();
    void set (Max11803TypeTouchDetectPullupPuf value);
}
member TouchDetectPullupPUF : Max11803TypeTouchDetectPullupPuf with get, set

Property Value

Type: Max11803TypeTouchDetectPullupPuf
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.TouchDetectPullupPUR Property

IRD

Max11803TouchDetectPullupPUR Property

Touch Detect Pullup: PUR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max11803TypeTouchDetectPullupPur TouchDetectPullupPUR { get; set; }
Public Property TouchDetectPullupPUR As Max11803TypeTouchDetectPullupPur
    Get
    Set
public:
property Max11803TypeTouchDetectPullupPur TouchDetectPullupPUR {
    Max11803TypeTouchDetectPullupPur get ();
    void set (Max11803TypeTouchDetectPullupPur value);
}
member TouchDetectPullupPUR : Max11803TypeTouchDetectPullupPur with get, set

Property Value

Type: Max11803TypeTouchDetectPullupPur
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.XMeasurementCONT0 Property

IRD

Max11803XMeasurementCONT0 Property

X Measurement CONT0

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte XMeasurementCONT0 { set; }
Public WriteOnly Property XMeasurementCONT0 As Byte
    Set
public:
property unsigned char XMeasurementCONT0 {
    void set (unsigned char value);
}
member XMeasurementCONT0 : byte with set

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.XMeasurementCONT1 Property

IRD

Max11803XMeasurementCONT1 Property

X Measurement CONT1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte XMeasurementCONT1 { set; }
Public WriteOnly Property XMeasurementCONT1 As Byte
    Set
public:
property unsigned char XMeasurementCONT1 {
    void set (unsigned char value);
}
member XMeasurementCONT1 : byte with set

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.XPanelSetup Property

IRD

Max11803XPanelSetup Property

X Panel Setup

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte XPanelSetup { set; }
Public WriteOnly Property XPanelSetup As Byte
    Set
public:
property unsigned char XPanelSetup {
    void set (unsigned char value);
}
member XPanelSetup : byte with set

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.XYCombinedCommand Property

IRD

Max11803XYCombinedCommand Property

XY Combined Command

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte XYCombinedCommand { set; }
Public WriteOnly Property XYCombinedCommand As Byte
    Set
public:
property unsigned char XYCombinedCommand {
    void set (unsigned char value);
}
member XYCombinedCommand : byte with set

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.XYZ1CombinedCommand Property

IRD

Max11803XYZ1CombinedCommand Property

XYZ1 Combined Command

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte XYZ1CombinedCommand { set; }
Public WriteOnly Property XYZ1CombinedCommand As Byte
    Set
public:
property unsigned char XYZ1CombinedCommand {
    void set (unsigned char value);
}
member XYZ1CombinedCommand : byte with set

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.XYZ1Z2CombinedCommand Property

IRD

Max11803XYZ1Z2CombinedCommand Property

XYZ1Z2 Combined Command

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte XYZ1Z2CombinedCommand { set; }
Public WriteOnly Property XYZ1Z2CombinedCommand As Byte
    Set
public:
property unsigned char XYZ1Z2CombinedCommand {
    void set (unsigned char value);
}
member XYZ1Z2CombinedCommand : byte with set

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.YMeasurementCONT0 Property

IRD

Max11803YMeasurementCONT0 Property

Y Measurement CONT0

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte YMeasurementCONT0 { set; }
Public WriteOnly Property YMeasurementCONT0 As Byte
    Set
public:
property unsigned char YMeasurementCONT0 {
    void set (unsigned char value);
}
member YMeasurementCONT0 : byte with set

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.YMeasurementCONT1 Property

IRD

Max11803YMeasurementCONT1 Property

Y Measurement CONT1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte YMeasurementCONT1 { set; }
Public WriteOnly Property YMeasurementCONT1 As Byte
    Set
public:
property unsigned char YMeasurementCONT1 {
    void set (unsigned char value);
}
member YMeasurementCONT1 : byte with set

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.YPanelSetup Property

IRD

Max11803YPanelSetup Property

Y Panel Setup

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte YPanelSetup { set; }
Public WriteOnly Property YPanelSetup As Byte
    Set
public:
property unsigned char YPanelSetup {
    void set (unsigned char value);
}
member YPanelSetup : byte with set

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.Z1MeasurementCONT0 Property

IRD

Max11803Z1MeasurementCONT0 Property

Z1 Measurement CONT0

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Z1MeasurementCONT0 { set; }
Public WriteOnly Property Z1MeasurementCONT0 As Byte
    Set
public:
property unsigned char Z1MeasurementCONT0 {
    void set (unsigned char value);
}
member Z1MeasurementCONT0 : byte with set

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.Z1MeasurementCONT1 Property

IRD

Max11803Z1MeasurementCONT1 Property

Z1 Measurement CONT1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Z1MeasurementCONT1 { set; }
Public WriteOnly Property Z1MeasurementCONT1 As Byte
    Set
public:
property unsigned char Z1MeasurementCONT1 {
    void set (unsigned char value);
}
member Z1MeasurementCONT1 : byte with set

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.Z1PanelSetup Property

IRD

Max11803Z1PanelSetup Property

Z1 Panel Setup

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Z1PanelSetup { set; }
Public WriteOnly Property Z1PanelSetup As Byte
    Set
public:
property unsigned char Z1PanelSetup {
    void set (unsigned char value);
}
member Z1PanelSetup : byte with set

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.Z2MeasurementCONT0 Property

IRD

Max11803Z2MeasurementCONT0 Property

Z2 Measurement CONT0

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Z2MeasurementCONT0 { set; }
Public WriteOnly Property Z2MeasurementCONT0 As Byte
    Set
public:
property unsigned char Z2MeasurementCONT0 {
    void set (unsigned char value);
}
member Z2MeasurementCONT0 : byte with set

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.Z2MeasurementCONT1 Property

IRD

Max11803Z2MeasurementCONT1 Property

Z2 Measurement CONT1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Z2MeasurementCONT1 { set; }
Public WriteOnly Property Z2MeasurementCONT1 As Byte
    Set
public:
property unsigned char Z2MeasurementCONT1 {
    void set (unsigned char value);
}
member Z2MeasurementCONT1 : byte with set

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.Z2PanelSetup Property

IRD

Max11803Z2PanelSetup Property

Z2 Panel Setup

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Z2PanelSetup { set; }
Public WriteOnly Property Z2PanelSetup As Byte
    Set
public:
property unsigned char Z2PanelSetup {
    void set (unsigned char value);
}
member Z2PanelSetup : byte with set

Property Value

Type: Byte
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803 Methods

The Max11803 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.Flush Method

IRD

Max11803Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max11803 Class
telos.Ird.Maxim Namespace


Max11803.TypeAdcSamplingTime Enumeration

IRD

Max11803TypeAdcSamplingTime Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcSamplingTime
Public Enumeration TypeAdcSamplingTime
public enum class TypeAdcSamplingTime
type TypeAdcSamplingTime
Members
Member name | Value | Description
Value_4X2MHzOscillatorClockPeriod2Us | 0 | 4 x (2 MHz Oscillator Clock Period) = 2 µs
Value_16X2MHzOscillatorClockPeriod8Us | 1 | 16 x (2 MHz Oscillator Clock Period) = 8 µs
Value_64X2MHzOscillatorClockPeriod32Us | 2 | 64 x (2 MHz Oscillator Clock Period) = 32 µs
Value_256X2MHzOscillatorClockPeriod128Us | 3 | 256 x (2 MHz Oscillator Clock Period) = 128 µs
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeAuxiliaryMeasurementAveragingSample Enumeration

IRD

Max11803TypeAuxiliaryMeasurementAveragingSample Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAuxiliaryMeasurementAveragingSample
Public Enumeration TypeAuxiliaryMeasurementAveragingSample
public enum class TypeAuxiliaryMeasurementAveragingSample
type TypeAuxiliaryMeasurementAveragingSample
Members
Member name | Value | Description
SingleSampleNoAveraging | 0 | Single Sample, No Averaging
TakeFourSamples | 1 | Take Four Samples
TakeEightSamples | 2 | Take Eight Samples
Take16Samples | 3 | Take 16 Samples
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeAuxiliaryMeasurementDelay Enumeration

IRD

Max11803TypeAuxiliaryMeasurementDelay Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAuxiliaryMeasurementDelay
Public Enumeration TypeAuxiliaryMeasurementDelay
public enum class TypeAuxiliaryMeasurementDelay
type TypeAuxiliaryMeasurementDelay
Members
Member name | Value | Description
Value_10Us | 0 | 10 µs
Value_100Us | 1 | 100 µs
Value_500Us | 2 | 500 µs
Value_1Ms | 3 | 1 ms
Value_5Ms | 4 | 5 ms
Value_10Ms | 5 | 10 ms
Value_50Ms | 6 | 50 ms
Value_100Ms | 7 | 100 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeAuxiliaryMeasurementResolution Enumeration

IRD

Max11803TypeAuxiliaryMeasurementResolution Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAuxiliaryMeasurementResolution
Public Enumeration TypeAuxiliaryMeasurementResolution
public enum class TypeAuxiliaryMeasurementResolution
type TypeAuxiliaryMeasurementResolution
Members
Member name | Value | Description
Value_12BitConversion | 0 | 12-Bit Conversion
Value_8BitConversion | 1 | 8-Bit Conversion
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeAuxiliaryMeasurementSamplingTime Enumeration

IRD

Max11803TypeAuxiliaryMeasurementSamplingTime Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAuxiliaryMeasurementSamplingTime
Public Enumeration TypeAuxiliaryMeasurementSamplingTime
public enum class TypeAuxiliaryMeasurementSamplingTime
type TypeAuxiliaryMeasurementSamplingTime
Members
Member name | Value | Description
Value_4X2MHzOscillatorClockPeriod2Us | 0 | 4 x (2 MHz Oscillator Clock Period) = 2 µs
Value_16X2MHzOscillatorClockPeriod8Us | 1 | 16 x (2 MHz Oscillator Clock Period) = 8 µs
Value_64X2MHzOscillatorClockPeriod32Us | 2 | 64 x (2 MHz Oscillator Clock Period) = 32 µs
Value_256X2MHzOscillatorClockPeriod128Us | 3 | 256 x (2 MHz Oscillator Clock Period) = 128 µs
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeDelayedConversionTime Enumeration

IRD

Max11803TypeDelayedConversionTime Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDelayedConversionTime
Public Enumeration TypeDelayedConversionTime
public enum class TypeDelayedConversionTime
type TypeDelayedConversionTime
Members
Member name | Value | Description
Value_10Us | 0 | 10 µs
Value_20Us | 1 | 20 µs
Value_50Us | 2 | 50 µs
Value_80Us | 3 | 80 µs
Value_100Us | 4 | 100 µs
Value_200Us | 5 | 200 µs
Value_500Us | 6 | 500 µs
Value_800Us | 7 | 800 µs
Value_1Ms | 8 | 1 ms
Value_2Ms | 9 | 2 ms
Value_5Ms | 10 | 5 ms
Value_10Ms | 11 | 10 ms
Value_20Ms | 12 | 20 ms
Value_50Ms | 13 | 50 ms
Value_100Ms | 14 | 100 ms
Value_200Ms | 15 | 200 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeGeneralConfiguratuionEdgeIrq Enumeration

IRD

Max11803TypeGeneralConfiguratuionEdgeIrq Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralConfiguratuionEdgeIrq
Public Enumeration TypeGeneralConfiguratuionEdgeIrq
public enum class TypeGeneralConfiguratuionEdgeIrq
type TypeGeneralConfiguratuionEdgeIrq
Members
Member name | Value | Description
UseContinuousInterrupt | 0 | Use Continuous Interrupt
UseEdgeInterrupt | 1 | Use Edge Interrupt
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeGeneralConfiguratuionEdgeTime Enumeration

IRD

Max11803TypeGeneralConfiguratuionEdgeTime Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralConfiguratuionEdgeTime
Public Enumeration TypeGeneralConfiguratuionEdgeTime
public enum class TypeGeneralConfiguratuionEdgeTime
type TypeGeneralConfiguratuionEdgeTime
Members
Member name | Value | Description
Value_4X2MHzOscillatorClockPeriod2Us | 0 | 4 x (2 MHz Oscillator Clock Period) = 2 µs
Value_16X2MHzOscillatorClockPeriod8Us | 1 | 16 x (2 MHz Oscillator Clock Period) = 8 µs
Value_64X2MHzOscillatorClockPeriod32Us | 2 | 64 x (2 MHz Oscillator Clock Period) = 32 µs
Value_128X2MHzOscillatorClockPeriod128Us | 3 | 128 x (2 MHz Oscillator Clock Period) = 128 µs
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeGeneralConfiguratuionHold Enumeration

IRD

Max11803TypeGeneralConfiguratuionHold Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralConfiguratuionHold
Public Enumeration TypeGeneralConfiguratuionHold
public enum class TypeGeneralConfiguratuionHold
type TypeGeneralConfiguratuionHold
Members
Member name | Value | Description
DOUTInternalBusHolderDisable | 0 | DOUT Internal Bus Holder: Disable
DOUTInternalBusHolderEnable | 1 | DOUT Internal Bus Holder: Enable
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeGeneralConfiguratuionMask Enumeration

IRD

Max11803TypeGeneralConfiguratuionMask Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralConfiguratuionMask
Public Enumeration TypeGeneralConfiguratuionMask
public enum class TypeGeneralConfiguratuionMask
type TypeGeneralConfiguratuionMask
Members
Member name | Value | Description
EnableTIRQOutput | 0 | Enable ^TIRQ Output
MaskDisableTIRGOutput | 1 | Mask/Disable ^TIRG Output
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeGeneralConfiguratuionOdn Enumeration

IRD

Max11803TypeGeneralConfiguratuionOdn Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralConfiguratuionOdn
Public Enumeration TypeGeneralConfiguratuionOdn
public enum class TypeGeneralConfiguratuionOdn
type TypeGeneralConfiguratuionOdn
Members
Member name | Value | Description
TIRQISCMOSBufferedOutput | 0 | ^TIRQ IS CMOS Buffered Output
TIRQIsOpenDrainNMOSOutput | 1 | ^TIRQ Is Open-Drain nMOS Output
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeGeneralConfiguratuionPuIrq Enumeration

IRD

Max11803TypeGeneralConfiguratuionPuIrq Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralConfiguratuionPuIrq
Public Enumeration TypeGeneralConfiguratuionPuIrq
public enum class TypeGeneralConfiguratuionPuIrq
type TypeGeneralConfiguratuionPuIrq
Members
Member name | Value | Description
IRQInternalPullupResistanceDisable | 0 | IRQ Internal Pullup Resistance: Disable
IRQInternalPullupResistanceEnable | 1 | IRQ Internal Pullup Resistance: Enable
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeGeneralConfiguratuionRtSel Enumeration

IRD

Max11803TypeGeneralConfiguratuionRtSel Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralConfiguratuionRtSel
Public Enumeration TypeGeneralConfiguratuionRtSel
public enum class TypeGeneralConfiguratuionRtSel
type TypeGeneralConfiguratuionRtSel
Members
Member name | Value | Description
Value_50KOhmTouchDetectionPullupResistance | 0 | 50 kOhm Touch-Detection Pullup Resistance
Value_100KOhmTouchDetectionPullupResistance | 1 | 100 kOhm Touch-Detection Pullup Resistance
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeGeneralStatusAdc Enumeration

IRD

Max11803TypeGeneralStatusAdc Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralStatusAdc
Public Enumeration TypeGeneralStatusAdc
public enum class TypeGeneralStatusAdc
type TypeGeneralStatusAdc
Members
Member name | Value | Description
ADCIsNotInACQOrCONVState | 0 | ADC Is Not In ACQ Or CONV State
ADCIsInACQOrCONVState | 1 | ADC Is In ACQ Or CONV State
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeGeneralStatusCont Enumeration

IRD

Max11803TypeGeneralStatusCont Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralStatusCont
Public Enumeration TypeGeneralStatusCont
public enum class TypeGeneralStatusCont
type TypeGeneralStatusCont
Members
Member name | Value | Description
NoTouchPresent | 0 | No Touch Present
TouchPresent | 1 | Touch Present
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeGeneralStatusEdge Enumeration

IRD

Max11803TypeGeneralStatusEdge Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralStatusEdge
Public Enumeration TypeGeneralStatusEdge
public enum class TypeGeneralStatusEdge
type TypeGeneralStatusEdge
Members
Member name | Value | Description
NoTouchEventInProgress | 0 | No Touch Event In Progress
TouchEventInProgress | 1 | Touch Event In Progress
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeGeneralStatusFifoInt Enumeration

IRD

Max11803TypeGeneralStatusFifoInt Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralStatusFifoInt
Public Enumeration TypeGeneralStatusFifoInt
public enum class TypeGeneralStatusFifoInt
type TypeGeneralStatusFifoInt
Members
Member name | Value | Description
NoUnreadDataInFIFO | 0 | No Unread Data In FIFO
NewDataAvailableInFIFO | 1 | New Data Available In FIFO
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeGeneralStatusFifoOvr Enumeration

IRD

Max11803TypeGeneralStatusFifoOvr Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralStatusFifoOvr
Public Enumeration TypeGeneralStatusFifoOvr
public enum class TypeGeneralStatusFifoOvr
type TypeGeneralStatusFifoOvr
Members
Member name | Value | Description
FIFOOverflowNotOccurred | 0 | FIFO Overflow: Not Occurred
FiFOOverflowOccurredSinceLastReadbackOperation | 1 | FiFO Overflow: Occurred Since Last Readback Operation
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeGeneralStatusLpm Enumeration

IRD

Max11803TypeGeneralStatusLpm Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralStatusLpm
Public Enumeration TypeGeneralStatusLpm
public enum class TypeGeneralStatusLpm
type TypeGeneralStatusLpm
Members
Member name | Value | Description
DeviceIsNotInLPMOrStandbyMode | 0 | Device Is Not In LPM Or Standby Mode
DeviceIsInLPMOrStandbyMode | 1 | Device Is In LPM Or Standby Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeGeneralStatusScan Enumeration

IRD

Max11803TypeGeneralStatusScan Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralStatusScan
Public Enumeration TypeGeneralStatusScan
public enum class TypeGeneralStatusScan
type TypeGeneralStatusScan
Members
Member name | Value | Description
ScanOrMeasurementNotInProgress | 0 | Scan Or Measurement: Not In Progress
ScanOrMeasurementInProgress | 1 | Scan Or Measurement: In Progress
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeGeneralStatusTdm Enumeration

IRD

Max11803TypeGeneralStatusTdm Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGeneralStatusTdm
Public Enumeration TypeGeneralStatusTdm
public enum class TypeGeneralStatusTdm
type TypeGeneralStatusTdm
Members
Member name | Value | Description
DeviceIsNotInTDMMode | 0 | Device Is Not In TDM Mode
DeviceIsInTDMMode | 1 | Device Is In TDM Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeMeasurementAveragingAvg Enumeration

IRD

Max11803TypeMeasurementAveragingAvg Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMeasurementAveragingAvg
Public Enumeration TypeMeasurementAveragingAvg
public enum class TypeMeasurementAveragingAvg
type TypeMeasurementAveragingAvg
Members
Member name | Value | Description
SingleSampleNoAveraging | 0 | Single Sample, No Averaging
TakeFourSample | 1 | Take Four Sample
TakeEightSample | 2 | Take Eight Sample
Take16Sample | 3 | Take 16 Sample
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeMeasurementResolutionPwr Enumeration

IRD

Max11803TypeMeasurementResolutionPwr Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMeasurementResolutionPwr
Public Enumeration TypeMeasurementResolutionPwr
public enum class TypeMeasurementResolutionPwr
type TypeMeasurementResolutionPwr
Members
Member name | Value | Description
InternalADCRunsAtNormalPower | 0 | Internal ADC Runs At: Normal Power
InternalADCRunsAtReducedPower | 1 | Internal ADC Runs At: Reduced Power
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeMeasurementResolutionRes Enumeration

IRD

Max11803TypeMeasurementResolutionRes Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMeasurementResolutionRes
Public Enumeration TypeMeasurementResolutionRes
public enum class TypeMeasurementResolutionRes
type TypeMeasurementResolutionRes
Members
Member name | Value | Description
Value_12BitConversion | 0 | 12-Bit Conversion
Value_8BitConversion | 1 | 8-Bit Conversion
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeOperatingModeAperture Enumeration

IRD

Max11803TypeOperatingModeAperture Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperatingModeAperture
Public Enumeration TypeOperatingModeAperture
public enum class TypeOperatingModeAperture
type TypeOperatingModeAperture
Members
Member name | Value | Description
DisregardApertureCriteria | 0 | Disregard Aperture Criteria
EnableApertureCriteria | 1 | Enable Aperture Criteria
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeOperatingModeAveraging Enumeration

IRD

Max11803TypeOperatingModeAveraging Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperatingModeAveraging
Public Enumeration TypeOperatingModeAveraging
public enum class TypeOperatingModeAveraging
type TypeOperatingModeAveraging
Members
Member name | Value | Description
UseMedianAveragingFilter | 0 | Use Median Averaging Filter
UseStraightAveragingFilter | 1 | Use Straight Averaging Filter
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeOperatingModeConversion Enumeration

IRD

Max11803TypeOperatingModeConversion Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperatingModeConversion
Public Enumeration TypeOperatingModeConversion
public enum class TypeOperatingModeConversion
type TypeOperatingModeConversion
Members
Member name | Value | Description
DeviceConversionMode | 0 | Device Conversion Mode
AutonomousXAndYScan | 1 | Autonomous X And Y Scan
AutonomousXYZ1Scan | 2 | Autonomous X, Y, Z1 Scan
AutonomousXYZ1Z2Scan | 3 | Autonomous X, Y, Z1, Z2 Scan
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeOperatingModePosition Enumeration

IRD

Max11803TypeOperatingModePosition Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperatingModePosition
Public Enumeration TypeOperatingModePosition
public enum class TypeOperatingModePosition
type TypeOperatingModePosition
Members
Member name | Value | Description
DisableXYPositionAveragingInSelectedMode | 0 | Disable (X,Y) Position Averaging In Selected Mode
EnableXYPositionAveragingInSelectedMode | 1 | Enable (X,Y) Position Averaging In Selected Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeOperatingModePower Enumeration

IRD

Max11803TypeOperatingModePower Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperatingModePower
Public Enumeration TypeOperatingModePower
public enum class TypeOperatingModePower
type TypeOperatingModePower
Members
Member name | Value | Description
DeviceIsPowerdedUp | 0 | Device Is Powerded Up
DeviceIsPowerdedDown | 1 | Device Is Powerded Down
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeOperatingModePressure Enumeration

IRD

Max11803TypeOperatingModePressure Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperatingModePressure
Public Enumeration TypeOperatingModePressure
public enum class TypeOperatingModePressure
type TypeOperatingModePressure
Members
Member name | Value | Description
DisableZ1Z2PressureAveragingInSelectedMode | 0 | Disable (Z1, Z2) Pressure Averaging In Selected Mode
EnableZ1Z2PressureAveragingInSelectedMode | 1 | Enable (Z1, Z2) Pressure Averaging In Selected Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypePanelSetupTimingPsu Enumeration

IRD

Max11803TypePanelSetupTimingPsu Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePanelSetupTimingPsu
Public Enumeration TypePanelSetupTimingPsu
public enum class TypePanelSetupTimingPsu
type TypePanelSetupTimingPsu
Members
Member name | Value | Description
Value_0Us | 0 | 0 µs
Value_20Us | 1 | 20 µs
Value_50Us | 2 | 50 µs
Value_80Us | 3 | 80 µs
Value_100Us | 4 | 100 µs
Value_200Us | 5 | 200 µs
Value_500Us | 6 | 500 µs
Value_800Us | 7 | 800 µs
Value_1Ms | 8 | 1 ms
Value_2Ms | 9 | 2 ms
Value_5Ms | 10 | 5 ms
Value_10Ms | 11 | 10 ms
Value_20Ms | 12 | 20 ms
Value_50Ms | 13 | 50 ms
Value_100Ms | 14 | 100 ms
Value_200Ms | 15 | 200 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeTouchDetectPullupPuf Enumeration

IRD

Max11803TypeTouchDetectPullupPuf Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTouchDetectPullupPuf
Public Enumeration TypeTouchDetectPullupPuf
public enum class TypeTouchDetectPullupPuf
type TypeTouchDetectPullupPuf
Members
Member name | Value | Description
Value_10Us | 0 | 10 µs
Value_20Us | 1 | 20 µs
Value_50Us | 2 | 50 µs
Value_80Us | 3 | 80 µs
Value_100Us | 4 | 100 µs
Value_200Us | 5 | 200 µs
Value_500Us | 6 | 500 µs
Value_800Us | 7 | 800 µs
Value_1Ms | 8 | 1 ms
Value_2Ms | 9 | 2 ms
Value_5Ms | 10 | 5 ms
Value_10Ms | 11 | 10 ms
Value_20Ms | 12 | 20 ms
Value_50Ms | 13 | 50 ms
Value_100Ms | 14 | 100 ms
Value_200Ms | 15 | 200 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max11803.TypeTouchDetectPullupPur Enumeration

IRD

Max11803TypeTouchDetectPullupPur Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTouchDetectPullupPur
Public Enumeration TypeTouchDetectPullupPur
public enum class TypeTouchDetectPullupPur
type TypeTouchDetectPullupPur
Members
Member name | Value | Description
Value_2Us | 0 | 2 µs
Value_2Us__1 | 1 | 2 µs
Value_4Us | 2 | 4 µs
Value_8Us | 3 | 8 µs
Value_10Us | 4 | 10 µs
Value_50Us | 5 | 50 µs
Value_100Us | 6 | 100 µs
Value_500Us | 7 | 500 µs
Value_1Ms | 8 | 1 ms
Value_2Ms | 9 | 2 ms
Value_5Ms | 10 | 5 ms
Value_10Ms | 11 | 10 ms
Value_20Ms | 12 | 20 ms
Value_50Ms | 13 | 50 ms
Value_100Ms | 14 | 100 ms
Value_200Ms | 15 | 200 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max1617a Class

Maxim: MAX 1617 A
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax1617a

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max1617a
Public Class Max1617a
public ref class Max1617a
type Max1617a =  class end

The Max1617a type exposes the following members.

Constructors
 | Name | Description
Public method | Max1617a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationMASK | Configuration (MASK)
Public property | ConfigurationRUNSTOP | Configuration (RUN/STOP)
Public property | ConversionRate | Conversion Rate (unit: Hz)
Public property | DeviceID | Device ID
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | LocalTHIGHLimit | Local T_HIGH Limit (unit: °C)
Public property | LocalTLOWLimit | Local T_LOW Limit (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | RemoteTHIGHLimit | Remote T_HIGH Limit (unit: °C)
Public property | RemoteTLOWLimit | Remote T_LOW Limit (unit: °C)
Public property | StatusBUSY | Status (BUSY)
Public property | StatusLHIGH | Status (LHIGH)
Public property | StatusLLOW | Status (LLOW)
Public property | StatusOPEN | Status (OPEN)
Public property | StatusRHIGH | Status (RHIGH)
Public property | StatusRLOW | Status (RLOW)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One-Shot
Public method | SoftwarePOR | Software POR
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Remote/Local Temperature Sensor
See Also

Reference

telos.Ird.Maxim Namespace


Max1617a Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1617a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max1617a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max1617a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a Properties

The Max1617a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationMASK | Configuration (MASK)
Public property | ConfigurationRUNSTOP | Configuration (RUN/STOP)
Public property | ConversionRate | Conversion Rate (unit: Hz)
Public property | DeviceID | Device ID
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | LocalTHIGHLimit | Local T_HIGH Limit (unit: °C)
Public property | LocalTLOWLimit | Local T_LOW Limit (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | RemoteTHIGHLimit | Remote T_HIGH Limit (unit: °C)
Public property | RemoteTLOWLimit | Remote T_LOW Limit (unit: °C)
Public property | StatusBUSY | Status (BUSY)
Public property | StatusLHIGH | Status (LHIGH)
Public property | StatusLLOW | Status (LLOW)
Public property | StatusOPEN | Status (OPEN)
Public property | StatusRHIGH | Status (RHIGH)
Public property | StatusRLOW | Status (RLOW)
Top
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.AutoFlush Property

IRD

Max1617aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.ConfigurationMASK Property

IRD

Max1617aConfigurationMASK Property

Configuration (MASK)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1617aConfigMaskType ConfigurationMASK { get; set; }
Public Property ConfigurationMASK As Max1617aConfigMaskType
    Get
    Set
public:
property Max1617aConfigMaskType ConfigurationMASK {
    Max1617aConfigMaskType get ();
    void set (Max1617aConfigMaskType value);
}
member ConfigurationMASK : Max1617aConfigMaskType with get, set

Property Value

Type: Max1617aConfigMaskType
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.ConfigurationRUNSTOP Property

IRD

Max1617aConfigurationRUNSTOP Property

Configuration (RUN/STOP)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1617aConfigRunType ConfigurationRUNSTOP { get; set; }
Public Property ConfigurationRUNSTOP As Max1617aConfigRunType
    Get
    Set
public:
property Max1617aConfigRunType ConfigurationRUNSTOP {
    Max1617aConfigRunType get ();
    void set (Max1617aConfigRunType value);
}
member ConfigurationRUNSTOP : Max1617aConfigRunType with get, set

Property Value

Type: Max1617aConfigRunType
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.ConversionRate Property

IRD

Max1617aConversionRate Property

Conversion Rate (unit: Hz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1617aConversionRateType ConversionRate { get; set; }
Public Property ConversionRate As Max1617aConversionRateType
    Get
    Set
public:
property Max1617aConversionRateType ConversionRate {
    Max1617aConversionRateType get ();
    void set (Max1617aConversionRateType value);
}
member ConversionRate : Max1617aConversionRateType with get, set

Property Value

Type: Max1617aConversionRateType
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.DeviceID Property

IRD

Max1617aDeviceID Property

Device ID

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.LocalTemperature Property

IRD

Max1617aLocalTemperature Property

Local Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTemperature { get; }
Public ReadOnly Property LocalTemperature As SByte
    Get
public:
property signed char LocalTemperature {
    signed char get ();
}
member LocalTemperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.LocalTHIGHLimit Property

IRD

Max1617aLocalTHIGHLimit Property

Local T_HIGH Limit (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTHIGHLimit { get; set; }
Public Property LocalTHIGHLimit As SByte
    Get
    Set
public:
property signed char LocalTHIGHLimit {
    signed char get ();
    void set (signed char value);
}
member LocalTHIGHLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.LocalTLOWLimit Property

IRD

Max1617aLocalTLOWLimit Property

Local T_LOW Limit (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTLOWLimit { get; set; }
Public Property LocalTLOWLimit As SByte
    Get
    Set
public:
property signed char LocalTLOWLimit {
    signed char get ();
    void set (signed char value);
}
member LocalTLOWLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.ManufacturerID Property

IRD

Max1617aManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As Byte
    Get
public:
property unsigned char ManufacturerID {
    unsigned char get ();
}
member ManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.RemoteTemperature Property

IRD

Max1617aRemoteTemperature Property

Remote Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTemperature { get; }
Public ReadOnly Property RemoteTemperature As SByte
    Get
public:
property signed char RemoteTemperature {
    signed char get ();
}
member RemoteTemperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.RemoteTHIGHLimit Property

IRD

Max1617aRemoteTHIGHLimit Property

Remote T_HIGH Limit (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTHIGHLimit { get; set; }
Public Property RemoteTHIGHLimit As SByte
    Get
    Set
public:
property signed char RemoteTHIGHLimit {
    signed char get ();
    void set (signed char value);
}
member RemoteTHIGHLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.RemoteTLOWLimit Property

IRD

Max1617aRemoteTLOWLimit Property

Remote T_LOW Limit (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTLOWLimit { get; set; }
Public Property RemoteTLOWLimit As SByte
    Get
    Set
public:
property signed char RemoteTLOWLimit {
    signed char get ();
    void set (signed char value);
}
member RemoteTLOWLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.StatusBUSY Property

IRD

Max1617aStatusBUSY Property

Status (BUSY)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1617aStatusBusyType StatusBUSY { get; }
Public ReadOnly Property StatusBUSY As Max1617aStatusBusyType
    Get
public:
property Max1617aStatusBusyType StatusBUSY {
    Max1617aStatusBusyType get ();
}
member StatusBUSY : Max1617aStatusBusyType with get

Property Value

Type: Max1617aStatusBusyType
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.StatusLHIGH Property

IRD

Max1617aStatusLHIGH Property

Status (LHIGH)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1617aStatusLhighType StatusLHIGH { get; }
Public ReadOnly Property StatusLHIGH As Max1617aStatusLhighType
    Get
public:
property Max1617aStatusLhighType StatusLHIGH {
    Max1617aStatusLhighType get ();
}
member StatusLHIGH : Max1617aStatusLhighType with get

Property Value

Type: Max1617aStatusLhighType
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.StatusLLOW Property

IRD

Max1617aStatusLLOW Property

Status (LLOW)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1617aStatusLlowType StatusLLOW { get; }
Public ReadOnly Property StatusLLOW As Max1617aStatusLlowType
    Get
public:
property Max1617aStatusLlowType StatusLLOW {
    Max1617aStatusLlowType get ();
}
member StatusLLOW : Max1617aStatusLlowType with get

Property Value

Type: Max1617aStatusLlowType
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.StatusOPEN Property

IRD

Max1617aStatusOPEN Property

Status (OPEN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1617aStatusOpenType StatusOPEN { get; }
Public ReadOnly Property StatusOPEN As Max1617aStatusOpenType
    Get
public:
property Max1617aStatusOpenType StatusOPEN {
    Max1617aStatusOpenType get ();
}
member StatusOPEN : Max1617aStatusOpenType with get

Property Value

Type: Max1617aStatusOpenType
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.StatusRHIGH Property

IRD

Max1617aStatusRHIGH Property

Status (RHIGH)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1617aStatusRhighType StatusRHIGH { get; }
Public ReadOnly Property StatusRHIGH As Max1617aStatusRhighType
    Get
public:
property Max1617aStatusRhighType StatusRHIGH {
    Max1617aStatusRhighType get ();
}
member StatusRHIGH : Max1617aStatusRhighType with get

Property Value

Type: Max1617aStatusRhighType
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.StatusRLOW Property

IRD

Max1617aStatusRLOW Property

Status (RLOW)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1617aStatusRlowType StatusRLOW { get; }
Public ReadOnly Property StatusRLOW As Max1617aStatusRlowType
    Get
public:
property Max1617aStatusRlowType StatusRLOW {
    Max1617aStatusRlowType get ();
}
member StatusRLOW : Max1617aStatusRlowType with get

Property Value

Type: Max1617aStatusRlowType
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a Methods

The Max1617a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One-Shot
Public method | SoftwarePOR | Software POR
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.Flush Method

IRD

Max1617aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.OneShot Method

IRD

Max1617aOneShot Method

One-Shot

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void OneShot()
Public Sub OneShot
public:
void OneShot()
member OneShot : unit -> unit
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.SoftwarePOR Method

IRD

Max1617aSoftwarePOR Method

Software POR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void SoftwarePOR()
Public Sub SoftwarePOR
public:
void SoftwarePOR()
member SoftwarePOR : unit -> unit
See Also

Reference

Max1617a Class
telos.Ird.Maxim Namespace


Max1617a.ConfigMaskType Enumeration

IRD

Max1617aConfigMaskType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigMaskType
Public Enumeration ConfigMaskType
public enum class ConfigMaskType
type ConfigMaskType
Members
Member name | Value | Description
ALERTInterruptsWhenHighMasked | 1 | ALERT Interrupts When High: Masked
ALERTInterruptsWhenHighNotMasked | 0 | ALERT Interrupts When High: Not Masked
See Also

Reference

telos.Ird.Maxim Namespace


Max1617a.ConfigRunType Enumeration

IRD

Max1617aConfigRunType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigRunType
Public Enumeration ConfigRunType
public enum class ConfigRunType
type ConfigRunType
Members
Member name | Value | Description
Standby | 1 | Standby
OneShotTimerMode | 0 | One-Shot/Timer Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max1617a.ConversionRateType Enumeration

IRD

Max1617aConversionRateType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConversionRateType
Public Enumeration ConversionRateType
public enum class ConversionRateType
type ConversionRateType
Members
Member name | Value | Description
Value_0_0625 | 0 | 0.0625
Value_0_125 | 1 | 0.125
Value_0_25 | 2 | 0.25
Value_0_5 | 3 | 0.5
Value_1 | 4 | 1
Value_2 | 5 | 2
Value_4 | 6 | 4
Value_8 | 7 | 8
See Also

Reference

telos.Ird.Maxim Namespace


Max1617a.StatusBusyType Enumeration

IRD

Max1617aStatusBusyType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusBusyType
Public Enumeration StatusBusyType
public enum class StatusBusyType
type StatusBusyType
Members
Member name | Value | Description
ADCBusyConverting | 1 | ADC: Busy Converting
ADCNotBusyConverting | 0 | ADC: Not Busy Converting
See Also

Reference

telos.Ird.Maxim Namespace


Max1617a.StatusLhighType Enumeration

IRD

Max1617aStatusLhighType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusLhighType
Public Enumeration StatusLhighType
public enum class StatusLhighType
type StatusLhighType
Members
Member name | Value | Description
LocalHighTemperatureAlarmActivated | 1 | Local High Temperature Alarm: Activated
LocalHighTemperatureAlarmNotActivated | 0 | Local High Temperature Alarm: Not Activated
See Also

Reference

telos.Ird.Maxim Namespace


Max1617a.StatusLlowType Enumeration

IRD

Max1617aStatusLlowType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusLlowType
Public Enumeration StatusLlowType
public enum class StatusLlowType
type StatusLlowType
Members
Member name | Value | Description
LocalLowTemperatureAlarmActivated | 1 | Local Low Temperature Alarm: Activated
LocalLowTemperatureAlarmNotActivated | 0 | Local Low Temperature Alarm: Not Activated
See Also

Reference

telos.Ird.Maxim Namespace


Max1617a.StatusOpenType Enumeration

IRD

Max1617aStatusOpenType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusOpenType
Public Enumeration StatusOpenType
public enum class StatusOpenType
type StatusOpenType
Members
Member name | Value | Description
RemoteDiodeFault | 1 | Remote Diode: Fault
RemoteDiodeOK | 0 | Remote Diode: OK
See Also

Reference

telos.Ird.Maxim Namespace


Max1617a.StatusRhighType Enumeration

IRD

Max1617aStatusRhighType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusRhighType
Public Enumeration StatusRhighType
public enum class StatusRhighType
type StatusRhighType
Members
Member name | Value | Description
RemoteHighTemperatureAlarmActivated | 1 | Remote High Temperature Alarm: Activated
RemoteHighTemperatureAlarmNotActivated | 0 | Remote High Temperature Alarm: Not Activated
See Also

Reference

telos.Ird.Maxim Namespace


Max1617a.StatusRlowType Enumeration

IRD

Max1617aStatusRlowType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusRlowType
Public Enumeration StatusRlowType
public enum class StatusRlowType
type StatusRlowType
Members
Member name | Value | Description
RemoteLowTemperatureAlarmActivated | 1 | Remote Low Temperature Alarm: Activated
RemoteLowTemperatureAlarmNotActivated | 0 | Remote Low Temperature Alarm: Not Activated
See Also

Reference

telos.Ird.Maxim Namespace


Max1619 Class

Maxim: MAX 1619
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax1619

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max1619
Public Class Max1619
public ref class Max1619
type Max1619 =  class end

The Max1619 type exposes the following members.

Constructors
 | Name | Description
Public method | Max1619 | Constructor
Top
Properties
 | Name | Description
Public property | Address | Address
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationID1 | Configuration (ID1)
Public property | ConfigurationID2 | Configuration (ID2)
Public property | ConfigurationMASK | Configuration (MASK)
Public property | ConfigurationPOL | Configuration (POL)
Public property | ConfigurationPROT | Configuration (PROT)
Public property | ConfigurationRUNSTOP | Configuration (RUN/STOP)
Public property | ConversionRate | Conversion Rate (unit: Hz)
Public property | DeviceID | Device ID
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | RemoteTHIGHLimit | Remote T_HIGH Limit (unit: °C)
Public property | RemoteTHYSTLimit | Remote T_HYST Limit (unit: °C)
Public property | RemoteTLOWLimit | Remote T_LOW Limit (unit: °C)
Public property | RemoteTMAXLimit | Remote T_MAX Limit (unit: °C)
Public property | StatusBUSY | Status (BUSY)
Public property | StatusOPEN | Status (OPEN)
Public property | StatusOVER | Status (OVER)
Public property | StatusRHIGH | Status (RHIGH)
Public property | StatusRLOW | Status (RLOW)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One-Shot
Public method | SoftwarePOR | Software POR
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Remote/Local Temperature Sensor With Dual-Alarm Outputs
See Also

Reference

telos.Ird.Maxim Namespace


Max1619 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1619(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max1619(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max1619

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619 Properties

The Max1619 type exposes the following members.

Properties
 | Name | Description
Public property | Address | Address
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationID1 | Configuration (ID1)
Public property | ConfigurationID2 | Configuration (ID2)
Public property | ConfigurationMASK | Configuration (MASK)
Public property | ConfigurationPOL | Configuration (POL)
Public property | ConfigurationPROT | Configuration (PROT)
Public property | ConfigurationRUNSTOP | Configuration (RUN/STOP)
Public property | ConversionRate | Conversion Rate (unit: Hz)
Public property | DeviceID | Device ID
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | RemoteTHIGHLimit | Remote T_HIGH Limit (unit: °C)
Public property | RemoteTHYSTLimit | Remote T_HYST Limit (unit: °C)
Public property | RemoteTLOWLimit | Remote T_LOW Limit (unit: °C)
Public property | RemoteTMAXLimit | Remote T_MAX Limit (unit: °C)
Public property | StatusBUSY | Status (BUSY)
Public property | StatusOPEN | Status (OPEN)
Public property | StatusOVER | Status (OVER)
Public property | StatusRHIGH | Status (RHIGH)
Public property | StatusRLOW | Status (RLOW)
Top
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.Address Property

IRD

Max1619Address Property

Address

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Address { set; }
Public WriteOnly Property Address As Byte
    Set
public:
property unsigned char Address {
    void set (unsigned char value);
}
member Address : byte with set

Property Value

Type: Byte
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.AutoFlush Property

IRD

Max1619AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.ConfigurationID1 Property

IRD

Max1619ConfigurationID1 Property

Configuration (ID1)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1619ConfigProtType ConfigurationID1 { get; set; }
Public Property ConfigurationID1 As Max1619ConfigProtType
    Get
    Set
public:
property Max1619ConfigProtType ConfigurationID1 {
    Max1619ConfigProtType get ();
    void set (Max1619ConfigProtType value);
}
member ConfigurationID1 : Max1619ConfigProtType with get, set

Property Value

Type: Max1619ConfigProtType
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.ConfigurationID2 Property

IRD

Max1619ConfigurationID2 Property

Configuration (ID2)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1619ConfigProtType ConfigurationID2 { get; set; }
Public Property ConfigurationID2 As Max1619ConfigProtType
    Get
    Set
public:
property Max1619ConfigProtType ConfigurationID2 {
    Max1619ConfigProtType get ();
    void set (Max1619ConfigProtType value);
}
member ConfigurationID2 : Max1619ConfigProtType with get, set

Property Value

Type: Max1619ConfigProtType
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.ConfigurationMASK Property

IRD

Max1619ConfigurationMASK Property

Configuration (MASK)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1619ConfigMaskType ConfigurationMASK { get; set; }
Public Property ConfigurationMASK As Max1619ConfigMaskType
    Get
    Set
public:
property Max1619ConfigMaskType ConfigurationMASK {
    Max1619ConfigMaskType get ();
    void set (Max1619ConfigMaskType value);
}
member ConfigurationMASK : Max1619ConfigMaskType with get, set

Property Value

Type: Max1619ConfigMaskType
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.ConfigurationPOL Property

IRD

Max1619ConfigurationPOL Property

Configuration (POL)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1619ConfigPolType ConfigurationPOL { get; set; }
Public Property ConfigurationPOL As Max1619ConfigPolType
    Get
    Set
public:
property Max1619ConfigPolType ConfigurationPOL {
    Max1619ConfigPolType get ();
    void set (Max1619ConfigPolType value);
}
member ConfigurationPOL : Max1619ConfigPolType with get, set

Property Value

Type: Max1619ConfigPolType
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.ConfigurationPROT Property

IRD

Max1619ConfigurationPROT Property

Configuration (PROT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1619ConfigProtType ConfigurationPROT { get; set; }
Public Property ConfigurationPROT As Max1619ConfigProtType
    Get
    Set
public:
property Max1619ConfigProtType ConfigurationPROT {
    Max1619ConfigProtType get ();
    void set (Max1619ConfigProtType value);
}
member ConfigurationPROT : Max1619ConfigProtType with get, set

Property Value

Type: Max1619ConfigProtType
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.ConfigurationRUNSTOP Property

IRD

Max1619ConfigurationRUNSTOP Property

Configuration (RUN/STOP)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1619ConfigRunType ConfigurationRUNSTOP { get; set; }
Public Property ConfigurationRUNSTOP As Max1619ConfigRunType
    Get
    Set
public:
property Max1619ConfigRunType ConfigurationRUNSTOP {
    Max1619ConfigRunType get ();
    void set (Max1619ConfigRunType value);
}
member ConfigurationRUNSTOP : Max1619ConfigRunType with get, set

Property Value

Type: Max1619ConfigRunType
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.ConversionRate Property

IRD

Max1619ConversionRate Property

Conversion Rate (unit: Hz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1619ConversionRateType ConversionRate { get; set; }
Public Property ConversionRate As Max1619ConversionRateType
    Get
    Set
public:
property Max1619ConversionRateType ConversionRate {
    Max1619ConversionRateType get ();
    void set (Max1619ConversionRateType value);
}
member ConversionRate : Max1619ConversionRateType with get, set

Property Value

Type: Max1619ConversionRateType
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.DeviceID Property

IRD

Max1619DeviceID Property

Device ID

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.LocalTemperature Property

IRD

Max1619LocalTemperature Property

Local Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTemperature { get; }
Public ReadOnly Property LocalTemperature As SByte
    Get
public:
property signed char LocalTemperature {
    signed char get ();
}
member LocalTemperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.ManufacturerID Property

IRD

Max1619ManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As Byte
    Get
public:
property unsigned char ManufacturerID {
    unsigned char get ();
}
member ManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.RemoteTemperature Property

IRD

Max1619RemoteTemperature Property

Remote Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTemperature { get; }
Public ReadOnly Property RemoteTemperature As SByte
    Get
public:
property signed char RemoteTemperature {
    signed char get ();
}
member RemoteTemperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.RemoteTHIGHLimit Property

IRD

Max1619RemoteTHIGHLimit Property

Remote T_HIGH Limit (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTHIGHLimit { get; set; }
Public Property RemoteTHIGHLimit As SByte
    Get
    Set
public:
property signed char RemoteTHIGHLimit {
    signed char get ();
    void set (signed char value);
}
member RemoteTHIGHLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.RemoteTHYSTLimit Property

IRD

Max1619RemoteTHYSTLimit Property

Remote T_HYST Limit (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTHYSTLimit { get; set; }
Public Property RemoteTHYSTLimit As SByte
    Get
    Set
public:
property signed char RemoteTHYSTLimit {
    signed char get ();
    void set (signed char value);
}
member RemoteTHYSTLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.RemoteTLOWLimit Property

IRD

Max1619RemoteTLOWLimit Property

Remote T_LOW Limit (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTLOWLimit { get; set; }
Public Property RemoteTLOWLimit As SByte
    Get
    Set
public:
property signed char RemoteTLOWLimit {
    signed char get ();
    void set (signed char value);
}
member RemoteTLOWLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.RemoteTMAXLimit Property

IRD

Max1619RemoteTMAXLimit Property

Remote T_MAX Limit (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTMAXLimit { get; set; }
Public Property RemoteTMAXLimit As SByte
    Get
    Set
public:
property signed char RemoteTMAXLimit {
    signed char get ();
    void set (signed char value);
}
member RemoteTMAXLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.StatusBUSY Property

IRD

Max1619StatusBUSY Property

Status (BUSY)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1619StatusBusyType StatusBUSY { get; }
Public ReadOnly Property StatusBUSY As Max1619StatusBusyType
    Get
public:
property Max1619StatusBusyType StatusBUSY {
    Max1619StatusBusyType get ();
}
member StatusBUSY : Max1619StatusBusyType with get

Property Value

Type: Max1619StatusBusyType
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.StatusOPEN Property

IRD

Max1619StatusOPEN Property

Status (OPEN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1619StatusOpenType StatusOPEN { get; }
Public ReadOnly Property StatusOPEN As Max1619StatusOpenType
    Get
public:
property Max1619StatusOpenType StatusOPEN {
    Max1619StatusOpenType get ();
}
member StatusOPEN : Max1619StatusOpenType with get

Property Value

Type: Max1619StatusOpenType
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.StatusOVER Property

IRD

Max1619StatusOVER Property

Status (OVER)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1619StatusOverType StatusOVER { get; }
Public ReadOnly Property StatusOVER As Max1619StatusOverType
    Get
public:
property Max1619StatusOverType StatusOVER {
    Max1619StatusOverType get ();
}
member StatusOVER : Max1619StatusOverType with get

Property Value

Type: Max1619StatusOverType
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.StatusRHIGH Property

IRD

Max1619StatusRHIGH Property

Status (RHIGH)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1619StatusRhighType StatusRHIGH { get; }
Public ReadOnly Property StatusRHIGH As Max1619StatusRhighType
    Get
public:
property Max1619StatusRhighType StatusRHIGH {
    Max1619StatusRhighType get ();
}
member StatusRHIGH : Max1619StatusRhighType with get

Property Value

Type: Max1619StatusRhighType
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.StatusRLOW Property

IRD

Max1619StatusRLOW Property

Status (RLOW)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max1619StatusRlowType StatusRLOW { get; }
Public ReadOnly Property StatusRLOW As Max1619StatusRlowType
    Get
public:
property Max1619StatusRlowType StatusRLOW {
    Max1619StatusRlowType get ();
}
member StatusRLOW : Max1619StatusRlowType with get

Property Value

Type: Max1619StatusRlowType
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619 Methods

The Max1619 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One-Shot
Public method | SoftwarePOR | Software POR
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.Flush Method

IRD

Max1619Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.OneShot Method

IRD

Max1619OneShot Method

One-Shot

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void OneShot()
Public Sub OneShot
public:
void OneShot()
member OneShot : unit -> unit
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.SoftwarePOR Method

IRD

Max1619SoftwarePOR Method

Software POR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void SoftwarePOR()
Public Sub SoftwarePOR
public:
void SoftwarePOR()
member SoftwarePOR : unit -> unit
See Also

Reference

Max1619 Class
telos.Ird.Maxim Namespace


Max1619.ConfigId1Type Enumeration

IRD

Max1619ConfigId1Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigId1Type
Public Enumeration ConfigId1Type
public enum class ConfigId1Type
type ConfigId1Type
Members
Member name | Value | Description
Default | 1 | Default
DiodeCurrentReducedBy5UA | 0 | Diode Current: Reduced by 5 uA
See Also

Reference

telos.Ird.Maxim Namespace


Max1619.ConfigId2Type Enumeration

IRD

Max1619ConfigId2Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigId2Type
Public Enumeration ConfigId2Type
public enum class ConfigId2Type
type ConfigId2Type
Members
Member name | Value | Description
Default | 1 | Default
DiodeCurrentReducedBy25UA | 0 | Diode Current: Reduced by 2.5 uA
See Also

Reference

telos.Ird.Maxim Namespace


Max1619.ConfigMaskType Enumeration

IRD

Max1619ConfigMaskType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigMaskType
Public Enumeration ConfigMaskType
public enum class ConfigMaskType
type ConfigMaskType
Members
Member name | Value | Description
ALERTInterruptsWhenHighMasked | 1 | ALERT Interrupts When High: Masked
ALERTInterruptsWhenHighNotMasked | 0 | ALERT Interrupts When High: Not Masked
See Also

Reference

telos.Ird.Maxim Namespace


Max1619.ConfigPolType Enumeration

IRD

Max1619ConfigPolType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigPolType
Public Enumeration ConfigPolType
public enum class ConfigPolType
type ConfigPolType
Members
Member name | Value | Description
OVERTOutputPolarityActiveHigh | 1 | OVERT Output Polarity: Active High
OVERTOutputPolarityActiveLow | 0 | OVERT Output Polarity: Active Low
See Also

Reference

telos.Ird.Maxim Namespace


Max1619.ConfigProtType Enumeration

IRD

Max1619ConfigProtType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigProtType
Public Enumeration ConfigProtType
public enum class ConfigProtType
type ConfigProtType
Members
Member name | Value | Description
Protected | 1 | Protected
Default | 0 | Default
See Also

Reference

telos.Ird.Maxim Namespace


Max1619.ConfigRunType Enumeration

IRD

Max1619ConfigRunType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigRunType
Public Enumeration ConfigRunType
public enum class ConfigRunType
type ConfigRunType
Members
Member name | Value | Description
Standby | 1 | Standby
OneShotTimerMode | 0 | One-Shot/Timer Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max1619.ConversionRateType Enumeration

IRD

Max1619ConversionRateType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConversionRateType
Public Enumeration ConversionRateType
public enum class ConversionRateType
type ConversionRateType
Members
Member name | Value | Description
Value_0_0625 | 0 | 0.0625
Value_0_125 | 1 | 0.125
Value_0_25 | 2 | 0.25
Value_0_5 | 3 | 0.5
Value_1 | 4 | 1
Value_2 | 5 | 2
Value_4 | 6 | 4
Value_8 | 7 | 8
See Also

Reference

telos.Ird.Maxim Namespace


Max1619.StatusBusyType Enumeration

IRD

Max1619StatusBusyType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusBusyType
Public Enumeration StatusBusyType
public enum class StatusBusyType
type StatusBusyType
Members
Member name | Value | Description
ADCBusyConverting | 1 | ADC: Busy Converting
ADCNotBusyConverting | 0 | ADC: Not Busy Converting
See Also

Reference

telos.Ird.Maxim Namespace


Max1619.StatusOpenType Enumeration

IRD

Max1619StatusOpenType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusOpenType
Public Enumeration StatusOpenType
public enum class StatusOpenType
type StatusOpenType
Members
Member name | Value | Description
RemoteDiodeFault | 1 | Remote Diode: Fault
RemoteDiodeOK | 0 | Remote Diode: OK
See Also

Reference

telos.Ird.Maxim Namespace


Max1619.StatusOverType Enumeration

IRD

Max1619StatusOverType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusOverType
Public Enumeration StatusOverType
public enum class StatusOverType
type StatusOverType
Members
Member name | Value | Description
OVERTPinHigh | 1 | OVERT Pin: High
OVERTPinLow | 0 | OVERT Pin: Low
See Also

Reference

telos.Ird.Maxim Namespace


Max1619.StatusRhighType Enumeration

IRD

Max1619StatusRhighType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusRhighType
Public Enumeration StatusRhighType
public enum class StatusRhighType
type StatusRhighType
Members
Member name | Value | Description
RemoteHighTemperatureAlarmActivated | 1 | Remote High Temperature Alarm: Activated
RemoteHighTemperatureAlarmNotActivated | 0 | Remote High Temperature Alarm: Not Activated
See Also

Reference

telos.Ird.Maxim Namespace


Max1619.StatusRlowType Enumeration

IRD

Max1619StatusRlowType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusRlowType
Public Enumeration StatusRlowType
public enum class StatusRlowType
type StatusRlowType
Members
Member name | Value | Description
RemoteLowTemperatureAlarmActivated | 1 | Remote Low Temperature Alarm: Activated
RemoteLowTemperatureAlarmNotActivated | 0 | Remote Low Temperature Alarm: Not Activated
See Also

Reference

telos.Ird.Maxim Namespace


Max16805 Class

Maxim: MAX 16805
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax16805

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max16805
Public Class Max16805
public ref class Max16805
type Max16805 =  class end

The Max16805 type exposes the following members.

Constructors
 | Name | Description
Public method | Max16805 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BinningAdjustment | Binning Adjustment (unit: mV)
Public property | EEPROMContentTransfer | EEPROM Content Transfer
Public property | EEPROMProgramEnable | EEPROM Program Enable
Public property | LEDCurrentFoldbackThresholdLEDCFT | LED Current Foldback Threshold (LED_CFT) (unit: V)
Public property | Password | Password
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
EEPROM-Programmable, High-Voltage, 350mA LED Drivers with LED Current Foldback
See Also

Reference

telos.Ird.Maxim Namespace


Max16805 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16805(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max16805(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max16805

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max16805 Class
telos.Ird.Maxim Namespace


Max16805 Properties

The Max16805 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BinningAdjustment | Binning Adjustment (unit: mV)
Public property | EEPROMContentTransfer | EEPROM Content Transfer
Public property | EEPROMProgramEnable | EEPROM Program Enable
Public property | LEDCurrentFoldbackThresholdLEDCFT | LED Current Foldback Threshold (LED_CFT) (unit: V)
Public property | Password | Password
Top
See Also

Reference

Max16805 Class
telos.Ird.Maxim Namespace


Max16805.AutoFlush Property

IRD

Max16805AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max16805 Class
telos.Ird.Maxim Namespace


Max16805.BinningAdjustment Property

IRD

Max16805BinningAdjustment Property

Binning Adjustment (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16805TypeBinningAdjustment BinningAdjustment { get; set; }
Public Property BinningAdjustment As Max16805TypeBinningAdjustment
    Get
    Set
public:
property Max16805TypeBinningAdjustment BinningAdjustment {
    Max16805TypeBinningAdjustment get ();
    void set (Max16805TypeBinningAdjustment value);
}
member BinningAdjustment : Max16805TypeBinningAdjustment with get, set

Property Value

Type: Max16805TypeBinningAdjustment
See Also

Reference

Max16805 Class
telos.Ird.Maxim Namespace


Max16805.EEPROMContentTransfer Property

IRD

Max16805EEPROMContentTransfer Property

EEPROM Content Transfer

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EEPROMContentTransfer { set; }
Public WriteOnly Property EEPROMContentTransfer As Byte
    Set
public:
property unsigned char EEPROMContentTransfer {
    void set (unsigned char value);
}
member EEPROMContentTransfer : byte with set

Property Value

Type: Byte
See Also

Reference

Max16805 Class
telos.Ird.Maxim Namespace


Max16805.EEPROMProgramEnable Property

IRD

Max16805EEPROMProgramEnable Property

EEPROM Program Enable

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EEPROMProgramEnable { set; }
Public WriteOnly Property EEPROMProgramEnable As Byte
    Set
public:
property unsigned char EEPROMProgramEnable {
    void set (unsigned char value);
}
member EEPROMProgramEnable : byte with set

Property Value

Type: Byte
See Also

Reference

Max16805 Class
telos.Ird.Maxim Namespace


Max16805.LEDCurrentFoldbackThresholdLEDCFT Property

IRD

Max16805LEDCurrentFoldbackThresholdLEDCFT Property

LED Current Foldback Threshold (LED_CFT) (unit: V)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16805TypeLedCurrentFoldbackThreshold LEDCurrentFoldbackThresholdLEDCFT { get; set; }
Public Property LEDCurrentFoldbackThresholdLEDCFT As Max16805TypeLedCurrentFoldbackThreshold
    Get
    Set
public:
property Max16805TypeLedCurrentFoldbackThreshold LEDCurrentFoldbackThresholdLEDCFT {
    Max16805TypeLedCurrentFoldbackThreshold get ();
    void set (Max16805TypeLedCurrentFoldbackThreshold value);
}
member LEDCurrentFoldbackThresholdLEDCFT : Max16805TypeLedCurrentFoldbackThreshold with get, set

Property Value

Type: Max16805TypeLedCurrentFoldbackThreshold
See Also

Reference

Max16805 Class
telos.Ird.Maxim Namespace


Max16805.Password Property

IRD

Max16805Password Property

Password

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16805TypePassword Password { set; }
Public WriteOnly Property Password As Max16805TypePassword
    Set
public:
property Max16805TypePassword Password {
    void set (Max16805TypePassword value);
}
member Password : Max16805TypePassword with set

Property Value

Type: Max16805TypePassword
See Also

Reference

Max16805 Class
telos.Ird.Maxim Namespace


Max16805 Methods

The Max16805 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max16805 Class
telos.Ird.Maxim Namespace


Max16805.Flush Method

IRD

Max16805Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max16805 Class
telos.Ird.Maxim Namespace


Max16805.TypeBinningAdjustment Enumeration

IRD

Max16805TypeBinningAdjustment Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBinningAdjustment
Public Enumeration TypeBinningAdjustment
public enum class TypeBinningAdjustment
type TypeBinningAdjustment
Members
Member name | Value | Description
Value_103_0 | 0 | 103.0
Value_109_0 | 1 | 109.0
Value_115_4 | 2 | 115.4
Value_121_8 | 3 | 121.8
Value_128_2 | 4 | 128.2
Value_134_6 | 5 | 134.6
Value_141_0 | 6 | 141.0
Value_147_4 | 7 | 147.4
Value_153_7 | 8 | 153.7
Value_160_1 | 9 | 160.1
Value_166_5 | 10 | 166.5
Value_173_0 | 11 | 173.0
Value_179_3 | 12 | 179.3
Value_185_7 | 13 | 185.7
Value_192_1 | 14 | 192.1
Value_198_0 | 15 | 198.0
See Also

Reference

telos.Ird.Maxim Namespace


Max16805.TypeLedCurrentFoldbackThreshold Enumeration

IRD

Max16805TypeLedCurrentFoldbackThreshold Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedCurrentFoldbackThreshold
Public Enumeration TypeLedCurrentFoldbackThreshold
public enum class TypeLedCurrentFoldbackThreshold
type TypeLedCurrentFoldbackThreshold
Members
Member name | Value | Description
Value_16_4 | 0 | 16.4
Value_15_7 | 1 | 15.7
Value_15_0 | 2 | 15.0
Value_14_3 | 3 | 14.3
Value_13_5 | 4 | 13.5
Value_12_8 | 5 | 12.8
Value_12_1 | 6 | 12.1
Value_11_4 | 7 | 11.4
See Also

Reference

telos.Ird.Maxim Namespace


Max16805.TypePassword Enumeration

IRD

Max16805TypePassword Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePassword
Public Enumeration TypePassword
public enum class TypePassword
type TypePassword
Members
Member name | Value | Description
EEPROMProgrammingDisabled | 0 | EEPROM Programming: Disabled
EEPROMProgrammingEnabled | 202 | EEPROM Programming: Enabled
EEPROMProgrammingDisabled__1 | 203 | EEPROM Programming: Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Max16806 Class

Maxim: MAX 16806
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax16806

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max16806
Public Class Max16806
public ref class Max16806
type Max16806 =  class end

The Max16806 type exposes the following members.

Constructors
 | Name | Description
Public method | Max16806 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BinningAdjustment | Binning Adjustment (unit: mV)
Public property | EEPROMContentTransfer | EEPROM Content Transfer
Public property | EEPROMProgramEnable | EEPROM Program Enable
Public property | LEDCurrentFoldbackThresholdLEDCFT | LED Current Foldback Threshold (LED_CFT) (unit: V)
Public property | Password | Password
Public property | RampPeak | Ramp Peak (unit: V)
Public property | ThermalFoldbackClampLevel | Thermal Foldback Clamp Level (unit: %)
Public property | ThermalFoldbackKneePoint | Thermal Foldback Knee Point (unit: mV)
Public property | ThermalFoldbackSlopeGain | Thermal Foldback Slope Gain (unit: V/V)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
EEPROM-Programmable, High-Voltage, 350mA LED Drivers with LED Current Foldback
See Also

Reference

telos.Ird.Maxim Namespace


Max16806 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16806(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max16806(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max16806

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max16806 Class
telos.Ird.Maxim Namespace


Max16806 Properties

The Max16806 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BinningAdjustment | Binning Adjustment (unit: mV)
Public property | EEPROMContentTransfer | EEPROM Content Transfer
Public property | EEPROMProgramEnable | EEPROM Program Enable
Public property | LEDCurrentFoldbackThresholdLEDCFT | LED Current Foldback Threshold (LED_CFT) (unit: V)
Public property | Password | Password
Public property | RampPeak | Ramp Peak (unit: V)
Public property | ThermalFoldbackClampLevel | Thermal Foldback Clamp Level (unit: %)
Public property | ThermalFoldbackKneePoint | Thermal Foldback Knee Point (unit: mV)
Public property | ThermalFoldbackSlopeGain | Thermal Foldback Slope Gain (unit: V/V)
Top
See Also

Reference

Max16806 Class
telos.Ird.Maxim Namespace


Max16806.AutoFlush Property

IRD

Max16806AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max16806 Class
telos.Ird.Maxim Namespace


Max16806.BinningAdjustment Property

IRD

Max16806BinningAdjustment Property

Binning Adjustment (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16806TypeBinningAdjustment BinningAdjustment { get; set; }
Public Property BinningAdjustment As Max16806TypeBinningAdjustment
    Get
    Set
public:
property Max16806TypeBinningAdjustment BinningAdjustment {
    Max16806TypeBinningAdjustment get ();
    void set (Max16806TypeBinningAdjustment value);
}
member BinningAdjustment : Max16806TypeBinningAdjustment with get, set

Property Value

Type: Max16806TypeBinningAdjustment
See Also

Reference

Max16806 Class
telos.Ird.Maxim Namespace


Max16806.EEPROMContentTransfer Property

IRD

Max16806EEPROMContentTransfer Property

EEPROM Content Transfer

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EEPROMContentTransfer { set; }
Public WriteOnly Property EEPROMContentTransfer As Byte
    Set
public:
property unsigned char EEPROMContentTransfer {
    void set (unsigned char value);
}
member EEPROMContentTransfer : byte with set

Property Value

Type: Byte
See Also

Reference

Max16806 Class
telos.Ird.Maxim Namespace


Max16806.EEPROMProgramEnable Property

IRD

Max16806EEPROMProgramEnable Property

EEPROM Program Enable

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EEPROMProgramEnable { set; }
Public WriteOnly Property EEPROMProgramEnable As Byte
    Set
public:
property unsigned char EEPROMProgramEnable {
    void set (unsigned char value);
}
member EEPROMProgramEnable : byte with set

Property Value

Type: Byte
See Also

Reference

Max16806 Class
telos.Ird.Maxim Namespace


Max16806.LEDCurrentFoldbackThresholdLEDCFT Property

IRD

Max16806LEDCurrentFoldbackThresholdLEDCFT Property

LED Current Foldback Threshold (LED_CFT) (unit: V)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16806TypeLedCurrentFoldbackThreshold LEDCurrentFoldbackThresholdLEDCFT { get; set; }
Public Property LEDCurrentFoldbackThresholdLEDCFT As Max16806TypeLedCurrentFoldbackThreshold
    Get
    Set
public:
property Max16806TypeLedCurrentFoldbackThreshold LEDCurrentFoldbackThresholdLEDCFT {
    Max16806TypeLedCurrentFoldbackThreshold get ();
    void set (Max16806TypeLedCurrentFoldbackThreshold value);
}
member LEDCurrentFoldbackThresholdLEDCFT : Max16806TypeLedCurrentFoldbackThreshold with get, set

Property Value

Type: Max16806TypeLedCurrentFoldbackThreshold
See Also

Reference

Max16806 Class
telos.Ird.Maxim Namespace


Max16806.Password Property

IRD

Max16806Password Property

Password

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16806TypePassword Password { set; }
Public WriteOnly Property Password As Max16806TypePassword
    Set
public:
property Max16806TypePassword Password {
    void set (Max16806TypePassword value);
}
member Password : Max16806TypePassword with set

Property Value

Type: Max16806TypePassword
See Also

Reference

Max16806 Class
telos.Ird.Maxim Namespace


Max16806.RampPeak Property

IRD

Max16806RampPeak Property

Ramp Peak (unit: V)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16806TypeRampPeak RampPeak { get; set; }
Public Property RampPeak As Max16806TypeRampPeak
    Get
    Set
public:
property Max16806TypeRampPeak RampPeak {
    Max16806TypeRampPeak get ();
    void set (Max16806TypeRampPeak value);
}
member RampPeak : Max16806TypeRampPeak with get, set

Property Value

Type: Max16806TypeRampPeak
See Also

Reference

Max16806 Class
telos.Ird.Maxim Namespace


Max16806.ThermalFoldbackClampLevel Property

IRD

Max16806ThermalFoldbackClampLevel Property

Thermal Foldback Clamp Level (unit: %)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16806TypeThermalFoldbackClampLevel ThermalFoldbackClampLevel { get; set; }
Public Property ThermalFoldbackClampLevel As Max16806TypeThermalFoldbackClampLevel
    Get
    Set
public:
property Max16806TypeThermalFoldbackClampLevel ThermalFoldbackClampLevel {
    Max16806TypeThermalFoldbackClampLevel get ();
    void set (Max16806TypeThermalFoldbackClampLevel value);
}
member ThermalFoldbackClampLevel : Max16806TypeThermalFoldbackClampLevel with get, set

Property Value

Type: Max16806TypeThermalFoldbackClampLevel
See Also

Reference

Max16806 Class
telos.Ird.Maxim Namespace


Max16806.ThermalFoldbackKneePoint Property

IRD

Max16806ThermalFoldbackKneePoint Property

Thermal Foldback Knee Point (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16806TypeThermalFoldbackKneePoint ThermalFoldbackKneePoint { get; set; }
Public Property ThermalFoldbackKneePoint As Max16806TypeThermalFoldbackKneePoint
    Get
    Set
public:
property Max16806TypeThermalFoldbackKneePoint ThermalFoldbackKneePoint {
    Max16806TypeThermalFoldbackKneePoint get ();
    void set (Max16806TypeThermalFoldbackKneePoint value);
}
member ThermalFoldbackKneePoint : Max16806TypeThermalFoldbackKneePoint with get, set

Property Value

Type: Max16806TypeThermalFoldbackKneePoint
See Also

Reference

Max16806 Class
telos.Ird.Maxim Namespace


Max16806.ThermalFoldbackSlopeGain Property

IRD

Max16806ThermalFoldbackSlopeGain Property

Thermal Foldback Slope Gain (unit: V/V)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16806TypeThermalFoldbackSlopeGain ThermalFoldbackSlopeGain { get; set; }
Public Property ThermalFoldbackSlopeGain As Max16806TypeThermalFoldbackSlopeGain
    Get
    Set
public:
property Max16806TypeThermalFoldbackSlopeGain ThermalFoldbackSlopeGain {
    Max16806TypeThermalFoldbackSlopeGain get ();
    void set (Max16806TypeThermalFoldbackSlopeGain value);
}
member ThermalFoldbackSlopeGain : Max16806TypeThermalFoldbackSlopeGain with get, set

Property Value

Type: Max16806TypeThermalFoldbackSlopeGain
See Also

Reference

Max16806 Class
telos.Ird.Maxim Namespace


Max16806 Methods

The Max16806 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max16806 Class
telos.Ird.Maxim Namespace


Max16806.Flush Method

IRD

Max16806Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max16806 Class
telos.Ird.Maxim Namespace


Max16806.TypeBinningAdjustment Enumeration

IRD

Max16806TypeBinningAdjustment Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBinningAdjustment
Public Enumeration TypeBinningAdjustment
public enum class TypeBinningAdjustment
type TypeBinningAdjustment
Members
Member name | Value | Description
Value_103_0 | 0 | 103.0
Value_109_0 | 1 | 109.0
Value_115_4 | 2 | 115.4
Value_121_8 | 3 | 121.8
Value_128_2 | 4 | 128.2
Value_134_6 | 5 | 134.6
Value_141_0 | 6 | 141.0
Value_147_4 | 7 | 147.4
Value_153_7 | 8 | 153.7
Value_160_1 | 9 | 160.1
Value_166_5 | 10 | 166.5
Value_173_0 | 11 | 173.0
Value_179_3 | 12 | 179.3
Value_185_7 | 13 | 185.7
Value_192_1 | 14 | 192.1
Value_198_0 | 15 | 198.0
See Also

Reference

telos.Ird.Maxim Namespace


Max16806.TypeLedCurrentFoldbackThreshold Enumeration

IRD

Max16806TypeLedCurrentFoldbackThreshold Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedCurrentFoldbackThreshold
Public Enumeration TypeLedCurrentFoldbackThreshold
public enum class TypeLedCurrentFoldbackThreshold
type TypeLedCurrentFoldbackThreshold
Members
Member name | Value | Description
Value_16_4 | 0 | 16.4
Value_15_7 | 1 | 15.7
Value_15_0 | 2 | 15.0
Value_14_3 | 3 | 14.3
Value_13_5 | 4 | 13.5
Value_12_8 | 5 | 12.8
Value_12_1 | 6 | 12.1
Value_11_4 | 7 | 11.4
See Also

Reference

telos.Ird.Maxim Namespace


Max16806.TypePassword Enumeration

IRD

Max16806TypePassword Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePassword
Public Enumeration TypePassword
public enum class TypePassword
type TypePassword
Members
Member name | Value | Description
EEPROMProgrammingDisabled | 0 | EEPROM Programming: Disabled
EEPROMProgrammingEnabled | 202 | EEPROM Programming: Enabled
EEPROMProgrammingDisabled__1 | 203 | EEPROM Programming: Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Max16806.TypeRampPeak Enumeration

IRD

Max16806TypeRampPeak Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRampPeak
Public Enumeration TypeRampPeak
public enum class TypeRampPeak
type TypeRampPeak
Members
Member name | Value | Description
Value_1_55 | 0 | 1.55
Value_1_74 | 1 | 1.74
Value_1_93 | 2 | 1.93
Value_2_12 | 3 | 2.12
Value_2_32 | 4 | 2.32
Value_2_51 | 5 | 2.51
Value_2_70 | 6 | 2.70
Value_2_88 | 7 | 2.88
See Also

Reference

telos.Ird.Maxim Namespace


Max16806.TypeThermalFoldbackClampLevel Enumeration

IRD

Max16806TypeThermalFoldbackClampLevel Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeThermalFoldbackClampLevel
Public Enumeration TypeThermalFoldbackClampLevel
public enum class TypeThermalFoldbackClampLevel
type TypeThermalFoldbackClampLevel
Members
Member name | Value | Description
Value_100 | 0 | 100
Value_91 | 1 | 91
Value_83 | 2 | 83
Value_74 | 3 | 74
Value_66 | 4 | 66
Value_57 | 5 | 57
Value_49 | 6 | 49
Value_40 | 7 | 40
See Also

Reference

telos.Ird.Maxim Namespace


Max16806.TypeThermalFoldbackKneePoint Enumeration

IRD

Max16806TypeThermalFoldbackKneePoint Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeThermalFoldbackKneePoint
Public Enumeration TypeThermalFoldbackKneePoint
public enum class TypeThermalFoldbackKneePoint
type TypeThermalFoldbackKneePoint
Members
Member name | Value | Description
Value_1174 | 0 | 1174
Value_1118 | 1 | 1118
Value_1062 | 2 | 1062
Value_1006 | 3 | 1006
Value_950 | 4 | 950
Value_894 | 5 | 894
Value_838 | 6 | 838
Value_782 | 7 | 782
Value_726 | 8 | 726
Value_670 | 9 | 670
Value_615 | 10 | 615
Value_559 | 11 | 559
Value_503 | 12 | 503
Value_447 | 13 | 447
Value_391 | 14 | 391
Value_335 | 15 | 335
See Also

Reference

telos.Ird.Maxim Namespace


Max16806.TypeThermalFoldbackSlopeGain Enumeration

IRD

Max16806TypeThermalFoldbackSlopeGain Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeThermalFoldbackSlopeGain
Public Enumeration TypeThermalFoldbackSlopeGain
public enum class TypeThermalFoldbackSlopeGain
type TypeThermalFoldbackSlopeGain
Members
Member name | Value | Description
Value_16 | 0 | 16
Value_12 | 1 | 12
Value_8 | 2 | 8
Value_4 | 3 | 4
See Also

Reference

telos.Ird.Maxim Namespace


Max16826 Class

Maxim: MAX 16826
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax16826

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max16826
Public Class Max16826
public ref class Max16826
type Max16826 =  class end

The Max16826 type exposes the following members.

Constructors
 | Name | Description
Public method | Max16826 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DeviceRevisionCode | Device Revision Code
Public property | DeviceStandbyCommand | Device Standby: Command
Public property | FaultStatusLEDString1 | Fault Status: LED String 1
Public property | FaultStatusLEDString2 | Fault Status: LED String 2
Public property | FaultStatusLEDString3 | Fault Status: LED String 3
Public property | FaultStatusLEDString4 | Fault Status: LED String 4
Public property | FaultStatusOvervoltage | Fault Status: Overvoltage
Public property | LEDString1CurrentVCS1 | LED String 1 Current: VCS1 (unit: mV)
Public property | LEDString1ExternalFETADCOut | LED String 1 External FET: ADC Out
Public property | LEDString1ExternalFETADCStatus | LED String 1 External FET: ADC Status
Public property | LEDString2CurrentVCS2 | LED String 2 Current: VCS2 (unit: mV)
Public property | LEDString2ExternalFETADCOut | LED String 2 External FET: ADC Out
Public property | LEDString2ExternalFETADCStatus | LED String 2 External FET: ADC Status
Public property | LEDString3CurrentVCS3 | LED String 3 Current: VCS3 (unit: mV)
Public property | LEDString3ExternalFETADCOut | LED String 3 External FET: ADC Out
Public property | LEDString3ExternalFETADCStatus | LED String 3 External FET: ADC Status
Public property | LEDString4CurrentVCS4 | LED String 4 Current: VCS4 (unit: mV)
Public property | LEDString4ExternalFETADCOut | LED String 4 External FET: ADC Out
Public property | LEDString4ExternalFETADCStatus | LED String 4 External FET: ADC Status
Public property | OVPVoltageADCOutput | OVP Voltage: ADC Output
Public property | SwitchingRegulatorVFB | Switching Regulator: VFB (unit: mV)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Programmable Four-String HB LED Driver with Output-Voltage Optimization and Fault Detection
See Also

Reference

telos.Ird.Maxim Namespace


Max16826 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16826(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max16826(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max16826

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826 Properties

The Max16826 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DeviceRevisionCode | Device Revision Code
Public property | DeviceStandbyCommand | Device Standby: Command
Public property | FaultStatusLEDString1 | Fault Status: LED String 1
Public property | FaultStatusLEDString2 | Fault Status: LED String 2
Public property | FaultStatusLEDString3 | Fault Status: LED String 3
Public property | FaultStatusLEDString4 | Fault Status: LED String 4
Public property | FaultStatusOvervoltage | Fault Status: Overvoltage
Public property | LEDString1CurrentVCS1 | LED String 1 Current: VCS1 (unit: mV)
Public property | LEDString1ExternalFETADCOut | LED String 1 External FET: ADC Out
Public property | LEDString1ExternalFETADCStatus | LED String 1 External FET: ADC Status
Public property | LEDString2CurrentVCS2 | LED String 2 Current: VCS2 (unit: mV)
Public property | LEDString2ExternalFETADCOut | LED String 2 External FET: ADC Out
Public property | LEDString2ExternalFETADCStatus | LED String 2 External FET: ADC Status
Public property | LEDString3CurrentVCS3 | LED String 3 Current: VCS3 (unit: mV)
Public property | LEDString3ExternalFETADCOut | LED String 3 External FET: ADC Out
Public property | LEDString3ExternalFETADCStatus | LED String 3 External FET: ADC Status
Public property | LEDString4CurrentVCS4 | LED String 4 Current: VCS4 (unit: mV)
Public property | LEDString4ExternalFETADCOut | LED String 4 External FET: ADC Out
Public property | LEDString4ExternalFETADCStatus | LED String 4 External FET: ADC Status
Public property | OVPVoltageADCOutput | OVP Voltage: ADC Output
Public property | SwitchingRegulatorVFB | Switching Regulator: VFB (unit: mV)
Top
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.AutoFlush Property

IRD

Max16826AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.DeviceRevisionCode Property

IRD

Max16826DeviceRevisionCode Property

Device Revision Code

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceRevisionCode { get; }
Public ReadOnly Property DeviceRevisionCode As Byte
    Get
public:
property unsigned char DeviceRevisionCode {
    unsigned char get ();
}
member DeviceRevisionCode : byte with get

Property Value

Type: Byte
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.DeviceStandbyCommand Property

IRD

Max16826DeviceStandbyCommand Property

Device Standby: Command

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16826TypeDeviceStandbyCommand DeviceStandbyCommand { get; set; }
Public Property DeviceStandbyCommand As Max16826TypeDeviceStandbyCommand
    Get
    Set
public:
property Max16826TypeDeviceStandbyCommand DeviceStandbyCommand {
    Max16826TypeDeviceStandbyCommand get ();
    void set (Max16826TypeDeviceStandbyCommand value);
}
member DeviceStandbyCommand : Max16826TypeDeviceStandbyCommand with get, set

Property Value

Type: Max16826TypeDeviceStandbyCommand
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.FaultStatusLEDString1 Property

IRD

Max16826FaultStatusLEDString1 Property

Fault Status: LED String 1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16826TypeFaultStatusLedString1 FaultStatusLEDString1 { get; }
Public ReadOnly Property FaultStatusLEDString1 As Max16826TypeFaultStatusLedString1
    Get
public:
property Max16826TypeFaultStatusLedString1 FaultStatusLEDString1 {
    Max16826TypeFaultStatusLedString1 get ();
}
member FaultStatusLEDString1 : Max16826TypeFaultStatusLedString1 with get

Property Value

Type: Max16826TypeFaultStatusLedString1
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.FaultStatusLEDString2 Property

IRD

Max16826FaultStatusLEDString2 Property

Fault Status: LED String 2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16826TypeFaultStatusLedString2 FaultStatusLEDString2 { get; }
Public ReadOnly Property FaultStatusLEDString2 As Max16826TypeFaultStatusLedString2
    Get
public:
property Max16826TypeFaultStatusLedString2 FaultStatusLEDString2 {
    Max16826TypeFaultStatusLedString2 get ();
}
member FaultStatusLEDString2 : Max16826TypeFaultStatusLedString2 with get

Property Value

Type: Max16826TypeFaultStatusLedString2
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.FaultStatusLEDString3 Property

IRD

Max16826FaultStatusLEDString3 Property

Fault Status: LED String 3

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16826TypeFaultStatusLedString3 FaultStatusLEDString3 { get; }
Public ReadOnly Property FaultStatusLEDString3 As Max16826TypeFaultStatusLedString3
    Get
public:
property Max16826TypeFaultStatusLedString3 FaultStatusLEDString3 {
    Max16826TypeFaultStatusLedString3 get ();
}
member FaultStatusLEDString3 : Max16826TypeFaultStatusLedString3 with get

Property Value

Type: Max16826TypeFaultStatusLedString3
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.FaultStatusLEDString4 Property

IRD

Max16826FaultStatusLEDString4 Property

Fault Status: LED String 4

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16826TypeFaultStatusLedString4 FaultStatusLEDString4 { get; }
Public ReadOnly Property FaultStatusLEDString4 As Max16826TypeFaultStatusLedString4
    Get
public:
property Max16826TypeFaultStatusLedString4 FaultStatusLEDString4 {
    Max16826TypeFaultStatusLedString4 get ();
}
member FaultStatusLEDString4 : Max16826TypeFaultStatusLedString4 with get

Property Value

Type: Max16826TypeFaultStatusLedString4
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.FaultStatusOvervoltage Property

IRD

Max16826FaultStatusOvervoltage Property

Fault Status: Overvoltage

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16826TypeFaultStatusOvervoltage FaultStatusOvervoltage { get; }
Public ReadOnly Property FaultStatusOvervoltage As Max16826TypeFaultStatusOvervoltage
    Get
public:
property Max16826TypeFaultStatusOvervoltage FaultStatusOvervoltage {
    Max16826TypeFaultStatusOvervoltage get ();
}
member FaultStatusOvervoltage : Max16826TypeFaultStatusOvervoltage with get

Property Value

Type: Max16826TypeFaultStatusOvervoltage
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.LEDString1CurrentVCS1 Property

IRD

Max16826LEDString1CurrentVCS1 Property

LED String 1 Current: VCS1 (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16826TypeLedStringCurrent LEDString1CurrentVCS1 { get; set; }
Public Property LEDString1CurrentVCS1 As Max16826TypeLedStringCurrent
    Get
    Set
public:
property Max16826TypeLedStringCurrent LEDString1CurrentVCS1 {
    Max16826TypeLedStringCurrent get ();
    void set (Max16826TypeLedStringCurrent value);
}
member LEDString1CurrentVCS1 : Max16826TypeLedStringCurrent with get, set

Property Value

Type: Max16826TypeLedStringCurrent
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.LEDString1ExternalFETADCOut Property

IRD

Max16826LEDString1ExternalFETADCOut Property

LED String 1 External FET: ADC Out

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LEDString1ExternalFETADCOut { get; }
Public ReadOnly Property LEDString1ExternalFETADCOut As Byte
    Get
public:
property unsigned char LEDString1ExternalFETADCOut {
    unsigned char get ();
}
member LEDString1ExternalFETADCOut : byte with get

Property Value

Type: Byte
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.LEDString1ExternalFETADCStatus Property

IRD

Max16826LEDString1ExternalFETADCStatus Property

LED String 1 External FET: ADC Status

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16826TypeLedString1ExternalFetAdcStatus LEDString1ExternalFETADCStatus { get; }
Public ReadOnly Property LEDString1ExternalFETADCStatus As Max16826TypeLedString1ExternalFetAdcStatus
    Get
public:
property Max16826TypeLedString1ExternalFetAdcStatus LEDString1ExternalFETADCStatus {
    Max16826TypeLedString1ExternalFetAdcStatus get ();
}
member LEDString1ExternalFETADCStatus : Max16826TypeLedString1ExternalFetAdcStatus with get

Property Value

Type: Max16826TypeLedString1ExternalFetAdcStatus
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.LEDString2CurrentVCS2 Property

IRD

Max16826LEDString2CurrentVCS2 Property

LED String 2 Current: VCS2 (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16826TypeLedStringCurrent LEDString2CurrentVCS2 { get; set; }
Public Property LEDString2CurrentVCS2 As Max16826TypeLedStringCurrent
    Get
    Set
public:
property Max16826TypeLedStringCurrent LEDString2CurrentVCS2 {
    Max16826TypeLedStringCurrent get ();
    void set (Max16826TypeLedStringCurrent value);
}
member LEDString2CurrentVCS2 : Max16826TypeLedStringCurrent with get, set

Property Value

Type: Max16826TypeLedStringCurrent
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.LEDString2ExternalFETADCOut Property

IRD

Max16826LEDString2ExternalFETADCOut Property

LED String 2 External FET: ADC Out

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LEDString2ExternalFETADCOut { get; }
Public ReadOnly Property LEDString2ExternalFETADCOut As Byte
    Get
public:
property unsigned char LEDString2ExternalFETADCOut {
    unsigned char get ();
}
member LEDString2ExternalFETADCOut : byte with get

Property Value

Type: Byte
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.LEDString2ExternalFETADCStatus Property

IRD

Max16826LEDString2ExternalFETADCStatus Property

LED String 2 External FET: ADC Status

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16826TypeLedString2ExternalFetAdcStatus LEDString2ExternalFETADCStatus { get; }
Public ReadOnly Property LEDString2ExternalFETADCStatus As Max16826TypeLedString2ExternalFetAdcStatus
    Get
public:
property Max16826TypeLedString2ExternalFetAdcStatus LEDString2ExternalFETADCStatus {
    Max16826TypeLedString2ExternalFetAdcStatus get ();
}
member LEDString2ExternalFETADCStatus : Max16826TypeLedString2ExternalFetAdcStatus with get

Property Value

Type: Max16826TypeLedString2ExternalFetAdcStatus
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.LEDString3CurrentVCS3 Property

IRD

Max16826LEDString3CurrentVCS3 Property

LED String 3 Current: VCS3 (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16826TypeLedStringCurrent LEDString3CurrentVCS3 { get; set; }
Public Property LEDString3CurrentVCS3 As Max16826TypeLedStringCurrent
    Get
    Set
public:
property Max16826TypeLedStringCurrent LEDString3CurrentVCS3 {
    Max16826TypeLedStringCurrent get ();
    void set (Max16826TypeLedStringCurrent value);
}
member LEDString3CurrentVCS3 : Max16826TypeLedStringCurrent with get, set

Property Value

Type: Max16826TypeLedStringCurrent
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.LEDString3ExternalFETADCOut Property

IRD

Max16826LEDString3ExternalFETADCOut Property

LED String 3 External FET: ADC Out

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LEDString3ExternalFETADCOut { get; }
Public ReadOnly Property LEDString3ExternalFETADCOut As Byte
    Get
public:
property unsigned char LEDString3ExternalFETADCOut {
    unsigned char get ();
}
member LEDString3ExternalFETADCOut : byte with get

Property Value

Type: Byte
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.LEDString3ExternalFETADCStatus Property

IRD

Max16826LEDString3ExternalFETADCStatus Property

LED String 3 External FET: ADC Status

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16826TypeLedString3ExternalFetAdcStatus LEDString3ExternalFETADCStatus { get; }
Public ReadOnly Property LEDString3ExternalFETADCStatus As Max16826TypeLedString3ExternalFetAdcStatus
    Get
public:
property Max16826TypeLedString3ExternalFetAdcStatus LEDString3ExternalFETADCStatus {
    Max16826TypeLedString3ExternalFetAdcStatus get ();
}
member LEDString3ExternalFETADCStatus : Max16826TypeLedString3ExternalFetAdcStatus with get

Property Value

Type: Max16826TypeLedString3ExternalFetAdcStatus
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.LEDString4CurrentVCS4 Property

IRD

Max16826LEDString4CurrentVCS4 Property

LED String 4 Current: VCS4 (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16826TypeLedStringCurrent LEDString4CurrentVCS4 { get; set; }
Public Property LEDString4CurrentVCS4 As Max16826TypeLedStringCurrent
    Get
    Set
public:
property Max16826TypeLedStringCurrent LEDString4CurrentVCS4 {
    Max16826TypeLedStringCurrent get ();
    void set (Max16826TypeLedStringCurrent value);
}
member LEDString4CurrentVCS4 : Max16826TypeLedStringCurrent with get, set

Property Value

Type: Max16826TypeLedStringCurrent
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.LEDString4ExternalFETADCOut Property

IRD

Max16826LEDString4ExternalFETADCOut Property

LED String 4 External FET: ADC Out

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LEDString4ExternalFETADCOut { get; }
Public ReadOnly Property LEDString4ExternalFETADCOut As Byte
    Get
public:
property unsigned char LEDString4ExternalFETADCOut {
    unsigned char get ();
}
member LEDString4ExternalFETADCOut : byte with get

Property Value

Type: Byte
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.LEDString4ExternalFETADCStatus Property

IRD

Max16826LEDString4ExternalFETADCStatus Property

LED String 4 External FET: ADC Status

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16826TypeLedString4ExternalFetAdcStatus LEDString4ExternalFETADCStatus { get; }
Public ReadOnly Property LEDString4ExternalFETADCStatus As Max16826TypeLedString4ExternalFetAdcStatus
    Get
public:
property Max16826TypeLedString4ExternalFetAdcStatus LEDString4ExternalFETADCStatus {
    Max16826TypeLedString4ExternalFetAdcStatus get ();
}
member LEDString4ExternalFETADCStatus : Max16826TypeLedString4ExternalFetAdcStatus with get

Property Value

Type: Max16826TypeLedString4ExternalFetAdcStatus
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.OVPVoltageADCOutput Property

IRD

Max16826OVPVoltageADCOutput Property

OVP Voltage: ADC Output

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OVPVoltageADCOutput { get; }
Public ReadOnly Property OVPVoltageADCOutput As Byte
    Get
public:
property unsigned char OVPVoltageADCOutput {
    unsigned char get ();
}
member OVPVoltageADCOutput : byte with get

Property Value

Type: Byte
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.SwitchingRegulatorVFB Property

IRD

Max16826SwitchingRegulatorVFB Property

Switching Regulator: VFB (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max16826TypeSwitchingRegulator SwitchingRegulatorVFB { get; set; }
Public Property SwitchingRegulatorVFB As Max16826TypeSwitchingRegulator
    Get
    Set
public:
property Max16826TypeSwitchingRegulator SwitchingRegulatorVFB {
    Max16826TypeSwitchingRegulator get ();
    void set (Max16826TypeSwitchingRegulator value);
}
member SwitchingRegulatorVFB : Max16826TypeSwitchingRegulator with get, set

Property Value

Type: Max16826TypeSwitchingRegulator
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826 Methods

The Max16826 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.Flush Method

IRD

Max16826Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max16826 Class
telos.Ird.Maxim Namespace


Max16826.TypeDeviceStandbyCommand Enumeration

IRD

Max16826TypeDeviceStandbyCommand Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeviceStandbyCommand
Public Enumeration TypeDeviceStandbyCommand
public enum class TypeDeviceStandbyCommand
type TypeDeviceStandbyCommand
Members
Member name | Value | Description
NormalOperationMode | 0 | Normal Operation Mode
EnterLowCurrentStandByMode | 1 | Enter Low-Current Stand-By Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max16826.TypeFaultStatusLedString1 Enumeration

IRD

Max16826TypeFaultStatusLedString1 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusLedString1
Public Enumeration TypeFaultStatusLedString1
public enum class TypeFaultStatusLedString1
type TypeFaultStatusLedString1
Members
Member name | Value | Description
DiodeShortLEDString1NotDetected | 0 | Diode Short LED String 1: Not Detected
DiodeShortLEDString1Detected | 1 | Diode Short LED String 1: Detected
See Also

Reference

telos.Ird.Maxim Namespace


Max16826.TypeFaultStatusLedString2 Enumeration

IRD

Max16826TypeFaultStatusLedString2 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusLedString2
Public Enumeration TypeFaultStatusLedString2
public enum class TypeFaultStatusLedString2
type TypeFaultStatusLedString2
Members
Member name | Value | Description
DiodeShortLEDString2NotDetected | 0 | Diode Short LED String 2: Not Detected
DiodeShortLEDString2Detected | 1 | Diode Short LED String 2: Detected
See Also

Reference

telos.Ird.Maxim Namespace


Max16826.TypeFaultStatusLedString3 Enumeration

IRD

Max16826TypeFaultStatusLedString3 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusLedString3
Public Enumeration TypeFaultStatusLedString3
public enum class TypeFaultStatusLedString3
type TypeFaultStatusLedString3
Members
Member name | Value | Description
DiodeShortLEDString3NotDetected | 0 | Diode Short LED String 3: Not Detected
DiodeShortLEDString3Detected | 1 | Diode Short LED String 3: Detected
See Also

Reference

telos.Ird.Maxim Namespace


Max16826.TypeFaultStatusLedString4 Enumeration

IRD

Max16826TypeFaultStatusLedString4 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusLedString4
Public Enumeration TypeFaultStatusLedString4
public enum class TypeFaultStatusLedString4
type TypeFaultStatusLedString4
Members
Member name | Value | Description
DiodeShortLEDString4NotDetected | 0 | Diode Short LED String 4: Not Detected
DiodeShortLEDString4Detected | 1 | Diode Short LED String 4: Detected
See Also

Reference

telos.Ird.Maxim Namespace


Max16826.TypeFaultStatusOvervoltage Enumeration

IRD

Max16826TypeFaultStatusOvervoltage Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusOvervoltage
Public Enumeration TypeFaultStatusOvervoltage
public enum class TypeFaultStatusOvervoltage
type TypeFaultStatusOvervoltage
Members
Member name | Value | Description
OVPNotExceeds125V | 0 | OVP Not Exceeds 1.25 V
OVPExceeds125V | 1 | OVP Exceeds 1.25 V
See Also

Reference

telos.Ird.Maxim Namespace


Max16826.TypeLedString1ExternalFetAdcStatus Enumeration

IRD

Max16826TypeLedString1ExternalFetAdcStatus Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedString1ExternalFetAdcStatus
Public Enumeration TypeLedString1ExternalFetAdcStatus
public enum class TypeLedString1ExternalFetAdcStatus
type TypeLedString1ExternalFetAdcStatus
Members
Member name | Value | Description
ConversionIsTerminatedByADC | 0 | Conversion Is Terminated By ADC
InternalTimeout | 1 | Internal Timeout
See Also

Reference

telos.Ird.Maxim Namespace


Max16826.TypeLedString2ExternalFetAdcStatus Enumeration

IRD

Max16826TypeLedString2ExternalFetAdcStatus Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedString2ExternalFetAdcStatus
Public Enumeration TypeLedString2ExternalFetAdcStatus
public enum class TypeLedString2ExternalFetAdcStatus
type TypeLedString2ExternalFetAdcStatus
Members
Member name | Value | Description
ConversionIsTerminatedByADC | 0 | Conversion Is Terminated By ADC
InternalTimeout | 1 | Internal Timeout
See Also

Reference

telos.Ird.Maxim Namespace


Max16826.TypeLedString3ExternalFetAdcStatus Enumeration

IRD

Max16826TypeLedString3ExternalFetAdcStatus Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedString3ExternalFetAdcStatus
Public Enumeration TypeLedString3ExternalFetAdcStatus
public enum class TypeLedString3ExternalFetAdcStatus
type TypeLedString3ExternalFetAdcStatus
Members
Member name | Value | Description
ConversionIsTerminatedByADC | 0 | Conversion Is Terminated By ADC
InternalTimeout | 1 | Internal Timeout
See Also

Reference

telos.Ird.Maxim Namespace


Max16826.TypeLedString4ExternalFetAdcStatus Enumeration

IRD

Max16826TypeLedString4ExternalFetAdcStatus Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedString4ExternalFetAdcStatus
Public Enumeration TypeLedString4ExternalFetAdcStatus
public enum class TypeLedString4ExternalFetAdcStatus
type TypeLedString4ExternalFetAdcStatus
Members
Member name | Value | Description
ConversionIsTerminatedByADC | 0 | Conversion Is Terminated By ADC
InternalTimeout | 1 | Internal Timeout
See Also

Reference

telos.Ird.Maxim Namespace


Max16826.TypeLedStringCurrent Enumeration

IRD

Max16826TypeLedStringCurrent Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedStringCurrent
Public Enumeration TypeLedStringCurrent
public enum class TypeLedStringCurrent
type TypeLedStringCurrent
Members
Member name | Value | Description
Value_316_00 | 0 | 316.00
Value_314_28 | 1 | 314.28
Value_312_56 | 2 | 312.56
Value_310_84 | 3 | 310.84
Value_309_12 | 4 | 309.12
Value_307_40 | 5 | 307.40
Value_305_68 | 6 | 305.68
Value_303_96 | 7 | 303.96
Value_302_24 | 8 | 302.24
Value_300_52 | 9 | 300.52
Value_298_80 | 10 | 298.80
Value_297_08 | 11 | 297.08
Value_295_36 | 12 | 295.36
Value_293_64 | 13 | 293.64
Value_291_92 | 14 | 291.92
Value_290_20 | 15 | 290.20
Value_288_48 | 16 | 288.48
Value_286_76 | 17 | 286.76
Value_285_04 | 18 | 285.04
Value_283_32 | 19 | 283.32
Value_281_60 | 20 | 281.60
Value_279_88 | 21 | 279.88
Value_278_16 | 22 | 278.16
Value_276_44 | 23 | 276.44
Value_274_72 | 24 | 274.72
Value_273_00 | 25 | 273.00
Value_271_28 | 26 | 271.28
Value_269_56 | 27 | 269.56
Value_267_84 | 28 | 267.84
Value_266_12 | 29 | 266.12
Value_264_40 | 30 | 264.40
Value_262_68 | 31 | 262.68
Value_260_96 | 32 | 260.96
Value_259_24 | 33 | 259.24
Value_257_52 | 34 | 257.52
Value_255_80 | 35 | 255.80
Value_254_08 | 36 | 254.08
Value_252_36 | 37 | 252.36
Value_250_64 | 38 | 250.64
Value_248_92 | 39 | 248.92
Value_247_20 | 40 | 247.20
Value_245_48 | 41 | 245.48
Value_243_76 | 42 | 243.76
Value_242_04 | 43 | 242.04
Value_240_32 | 44 | 240.32
Value_238_60 | 45 | 238.60
Value_236_88 | 46 | 236.88
Value_235_16 | 47 | 235.16
Value_233_44 | 48 | 233.44
Value_231_72 | 49 | 231.72
Value_230_00 | 50 | 230.00
Value_228_28 | 51 | 228.28
Value_226_56 | 52 | 226.56
Value_224_84 | 53 | 224.84
Value_223_12 | 54 | 223.12
Value_221_40 | 55 | 221.40
Value_219_68 | 56 | 219.68
Value_217_96 | 57 | 217.96
Value_216_24 | 58 | 216.24
Value_214_52 | 59 | 214.52
Value_212_80 | 60 | 212.80
Value_211_08 | 61 | 211.08
Value_209_36 | 62 | 209.36
Value_207_64 | 63 | 207.64
Value_205_92 | 64 | 205.92
Value_204_20 | 65 | 204.20
Value_202_48 | 66 | 202.48
Value_200_76 | 67 | 200.76
Value_199_04 | 68 | 199.04
Value_197_32 | 69 | 197.32
Value_195_60 | 70 | 195.60
Value_193_88 | 71 | 193.88
Value_192_16 | 72 | 192.16
Value_190_44 | 73 | 190.44
Value_188_72 | 74 | 188.72
Value_187_00 | 75 | 187.00
Value_185_28 | 76 | 185.28
Value_183_56 | 77 | 183.56
Value_181_84 | 78 | 181.84
Value_180_12 | 79 | 180.12
Value_178_40 | 80 | 178.40
Value_176_68 | 81 | 176.68
Value_174_96 | 82 | 174.96
Value_173_24 | 83 | 173.24
Value_171_52 | 84 | 171.52
Value_169_80 | 85 | 169.80
Value_168_08 | 86 | 168.08
Value_166_36 | 87 | 166.36
Value_164_64 | 88 | 164.64
Value_162_92 | 89 | 162.92
Value_161_20 | 90 | 161.20
Value_159_48 | 91 | 159.48
Value_157_76 | 92 | 157.76
Value_156_04 | 93 | 156.04
Value_154_32 | 94 | 154.32
Value_152_60 | 95 | 152.60
Value_150_88 | 96 | 150.88
Value_149_16 | 97 | 149.16
Value_147_44 | 98 | 147.44
Value_145_72 | 99 | 145.72
Value_144_00 | 100 | 144.00
Value_142_28 | 101 | 142.28
Value_140_56 | 102 | 140.56
Value_138_84 | 103 | 138.84
Value_137_12 | 104 | 137.12
Value_135_40 | 105 | 135.40
Value_133_68 | 106 | 133.68
Value_131_96 | 107 | 131.96
Value_130_24 | 108 | 130.24
Value_128_52 | 109 | 128.52
Value_126_80 | 110 | 126.80
Value_125_08 | 111 | 125.08
Value_123_36 | 112 | 123.36
Value_121_64 | 113 | 121.64
Value_119_92 | 114 | 119.92
Value_118_20 | 115 | 118.20
Value_116_48 | 116 | 116.48
Value_114_76 | 117 | 114.76
Value_113_04 | 118 | 113.04
Value_111_32 | 119 | 111.32
Value_109_60 | 120 | 109.60
Value_107_88 | 121 | 107.88
Value_106_16 | 122 | 106.16
Value_104_44 | 123 | 104.44
Value_102_72 | 124 | 102.72
Value_101_00 | 125 | 101.00
Value_99_28 | 126 | 99.28
Value_97_56 | 127 | 97.56
See Also

Reference

telos.Ird.Maxim Namespace


Max16826.TypeSwitchingRegulator Enumeration

IRD

Max16826TypeSwitchingRegulator Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSwitchingRegulator
Public Enumeration TypeSwitchingRegulator
public enum class TypeSwitchingRegulator
type TypeSwitchingRegulator
Members
Member name | Value | Description
Value_1250_00 | 0 | 1250.00
Value_1247_09 | 1 | 1247.09
Value_1244_18 | 2 | 1244.18
Value_1241_27 | 3 | 1241.27
Value_1238_36 | 4 | 1238.36
Value_1235_45 | 5 | 1235.45
Value_1232_54 | 6 | 1232.54
Value_1229_63 | 7 | 1229.63
Value_1226_72 | 8 | 1226.72
Value_1223_81 | 9 | 1223.81
Value_1220_90 | 10 | 1220.90
Value_1217_99 | 11 | 1217.99
Value_1215_08 | 12 | 1215.08
Value_1212_17 | 13 | 1212.17
Value_1209_26 | 14 | 1209.26
Value_1206_35 | 15 | 1206.35
Value_1203_44 | 16 | 1203.44
Value_1200_53 | 17 | 1200.53
Value_1197_62 | 18 | 1197.62
Value_1194_71 | 19 | 1194.71
Value_1191_80 | 20 | 1191.80
Value_1188_89 | 21 | 1188.89
Value_1185_98 | 22 | 1185.98
Value_1183_07 | 23 | 1183.07
Value_1180_16 | 24 | 1180.16
Value_1177_25 | 25 | 1177.25
Value_1174_34 | 26 | 1174.34
Value_1171_43 | 27 | 1171.43
Value_1168_52 | 28 | 1168.52
Value_1165_61 | 29 | 1165.61
Value_1162_70 | 30 | 1162.70
Value_1159_79 | 31 | 1159.79
Value_1156_88 | 32 | 1156.88
Value_1153_97 | 33 | 1153.97
Value_1151_06 | 34 | 1151.06
Value_1148_15 | 35 | 1148.15
Value_1145_24 | 36 | 1145.24
Value_1142_33 | 37 | 1142.33
Value_1139_42 | 38 | 1139.42
Value_1136_51 | 39 | 1136.51
Value_1133_60 | 40 | 1133.60
Value_1130_69 | 41 | 1130.69
Value_1127_78 | 42 | 1127.78
Value_1124_87 | 43 | 1124.87
Value_1121_96 | 44 | 1121.96
Value_1119_05 | 45 | 1119.05
Value_1116_14 | 46 | 1116.14
Value_1113_23 | 47 | 1113.23
Value_1110_32 | 48 | 1110.32
Value_1107_41 | 49 | 1107.41
Value_1104_50 | 50 | 1104.50
Value_1101_59 | 51 | 1101.59
Value_1098_68 | 52 | 1098.68
Value_1095_77 | 53 | 1095.77
Value_1092_86 | 54 | 1092.86
Value_1089_95 | 55 | 1089.95
Value_1087_04 | 56 | 1087.04
Value_1084_13 | 57 | 1084.13
Value_1081_22 | 58 | 1081.22
Value_1078_31 | 59 | 1078.31
Value_1075_40 | 60 | 1075.40
Value_1072_49 | 61 | 1072.49
Value_1069_58 | 62 | 1069.58
Value_1066_67 | 63 | 1066.67
Value_1063_76 | 64 | 1063.76
Value_1060_85 | 65 | 1060.85
Value_1057_94 | 66 | 1057.94
Value_1055_03 | 67 | 1055.03
Value_1052_12 | 68 | 1052.12
Value_1049_21 | 69 | 1049.21
Value_1046_30 | 70 | 1046.30
Value_1043_39 | 71 | 1043.39
Value_1040_48 | 72 | 1040.48
Value_1037_57 | 73 | 1037.57
Value_1034_66 | 74 | 1034.66
Value_1031_75 | 75 | 1031.75
Value_1028_84 | 76 | 1028.84
Value_1025_93 | 77 | 1025.93
Value_1023_02 | 78 | 1023.02
Value_1020_11 | 79 | 1020.11
Value_1017_20 | 80 | 1017.20
Value_1014_29 | 81 | 1014.29
Value_1011_38 | 82 | 1011.38
Value_1008_47 | 83 | 1008.47
Value_1005_56 | 84 | 1005.56
Value_1002_65 | 85 | 1002.65
Value_999_74 | 86 | 999.74
Value_996_83 | 87 | 996.83
Value_993_92 | 88 | 993.92
Value_991_01 | 89 | 991.01
Value_988_10 | 90 | 988.10
Value_985_19 | 91 | 985.19
Value_982_28 | 92 | 982.28
Value_979_37 | 93 | 979.37
Value_976_46 | 94 | 976.46
Value_973_55 | 95 | 973.55
Value_970_64 | 96 | 970.64
Value_967_73 | 97 | 967.73
Value_964_82 | 98 | 964.82
Value_961_91 | 99 | 961.91
Value_959_00 | 100 | 959.00
Value_956_09 | 101 | 956.09
Value_953_18 | 102 | 953.18
Value_950_27 | 103 | 950.27
Value_947_36 | 104 | 947.36
Value_944_45 | 105 | 944.45
Value_941_54 | 106 | 941.54
Value_938_63 | 107 | 938.63
Value_935_72 | 108 | 935.72
Value_932_81 | 109 | 932.81
Value_929_90 | 110 | 929.90
Value_926_99 | 111 | 926.99
Value_924_08 | 112 | 924.08
Value_921_17 | 113 | 921.17
Value_918_26 | 114 | 918.26
Value_915_35 | 115 | 915.35
Value_912_44 | 116 | 912.44
Value_909_53 | 117 | 909.53
Value_906_62 | 118 | 906.62
Value_903_71 | 119 | 903.71
Value_900_80 | 120 | 900.80
Value_897_89 | 121 | 897.89
Value_894_98 | 122 | 894.98
Value_892_07 | 123 | 892.07
Value_889_16 | 124 | 889.16
Value_886_25 | 125 | 886.25
Value_883_34 | 126 | 883.34
Value_880_43 | 127 | 880.43
See Also

Reference

telos.Ird.Maxim Namespace


Max17061 Class

Maxim: MAX 17061
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax17061

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max17061
Public Class Max17061
public ref class Max17061
type Max17061 =  class end

The Max17061 type exposes the following members.

Constructors
 | Name | Description
Public method | Max17061 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BrightnessControlBRT | Brightness Control: BRT
Public property | DeviceControlBLCTL | Device Control: BL_CTL
Public property | DeviceControlPWMMD | Device Control: PWM_MD
Public property | DeviceControlPWMSEL | Device Control: PWM_SEL
Public property | FaultStatus1CHSD | Fault Status: 1_CH_SD
Public property | FaultStatus2CHSD | Fault Status: 2_CH_SD
Public property | FaultStatusBLSTAT | Fault Status: BL_STAT
Public property | FaultStatusFAULT | Fault Status: FAULT
Public property | FaultStatusOVCURR | Fault Status: OV_CURR
Public property | FaultStatusTHRMSHD | Fault Status: THRM_SHD
Public property | IdentificationLEDPANEL | Identification: LED PANEL
Public property | IdentificationMFG | Identification: MFG
Public property | IdentificationREV | Identification: REV
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
8-String White LED Driver
See Also

Reference

telos.Ird.Maxim Namespace


Max17061 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max17061(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max17061(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max17061

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max17061 Class
telos.Ird.Maxim Namespace


Max17061 Properties

The Max17061 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BrightnessControlBRT | Brightness Control: BRT
Public property | DeviceControlBLCTL | Device Control: BL_CTL
Public property | DeviceControlPWMMD | Device Control: PWM_MD
Public property | DeviceControlPWMSEL | Device Control: PWM_SEL
Public property | FaultStatus1CHSD | Fault Status: 1_CH_SD
Public property | FaultStatus2CHSD | Fault Status: 2_CH_SD
Public property | FaultStatusBLSTAT | Fault Status: BL_STAT
Public property | FaultStatusFAULT | Fault Status: FAULT
Public property | FaultStatusOVCURR | Fault Status: OV_CURR
Public property | FaultStatusTHRMSHD | Fault Status: THRM_SHD
Public property | IdentificationLEDPANEL | Identification: LED PANEL
Public property | IdentificationMFG | Identification: MFG
Public property | IdentificationREV | Identification: REV
Top
See Also

Reference

Max17061 Class
telos.Ird.Maxim Namespace


Max17061.AutoFlush Property

IRD

Max17061AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max17061 Class
telos.Ird.Maxim Namespace


Max17061.BrightnessControlBRT Property

IRD

Max17061BrightnessControlBRT Property

Brightness Control: BRT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte BrightnessControlBRT { get; set; }
Public Property BrightnessControlBRT As Byte
    Get
    Set
public:
property unsigned char BrightnessControlBRT {
    unsigned char get ();
    void set (unsigned char value);
}
member BrightnessControlBRT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max17061 Class
telos.Ird.Maxim Namespace


Max17061.DeviceControlBLCTL Property

IRD

Max17061DeviceControlBLCTL Property

Device Control: BL_CTL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max17061TypeDeviceControlBacklightControl DeviceControlBLCTL { get; set; }
Public Property DeviceControlBLCTL As Max17061TypeDeviceControlBacklightControl
    Get
    Set
public:
property Max17061TypeDeviceControlBacklightControl DeviceControlBLCTL {
    Max17061TypeDeviceControlBacklightControl get ();
    void set (Max17061TypeDeviceControlBacklightControl value);
}
member DeviceControlBLCTL : Max17061TypeDeviceControlBacklightControl with get, set

Property Value

Type: Max17061TypeDeviceControlBacklightControl
See Also

Reference

Max17061 Class
telos.Ird.Maxim Namespace


Max17061.DeviceControlPWMMD Property

IRD

Max17061DeviceControlPWMMD Property

Device Control: PWM_MD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max17061TypeDeviceControlPwmMode DeviceControlPWMMD { get; set; }
Public Property DeviceControlPWMMD As Max17061TypeDeviceControlPwmMode
    Get
    Set
public:
property Max17061TypeDeviceControlPwmMode DeviceControlPWMMD {
    Max17061TypeDeviceControlPwmMode get ();
    void set (Max17061TypeDeviceControlPwmMode value);
}
member DeviceControlPWMMD : Max17061TypeDeviceControlPwmMode with get, set

Property Value

Type: Max17061TypeDeviceControlPwmMode
See Also

Reference

Max17061 Class
telos.Ird.Maxim Namespace


Max17061.DeviceControlPWMSEL Property

IRD

Max17061DeviceControlPWMSEL Property

Device Control: PWM_SEL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max17061TypeDeviceControlBrightnessMux DeviceControlPWMSEL { get; set; }
Public Property DeviceControlPWMSEL As Max17061TypeDeviceControlBrightnessMux
    Get
    Set
public:
property Max17061TypeDeviceControlBrightnessMux DeviceControlPWMSEL {
    Max17061TypeDeviceControlBrightnessMux get ();
    void set (Max17061TypeDeviceControlBrightnessMux value);
}
member DeviceControlPWMSEL : Max17061TypeDeviceControlBrightnessMux with get, set

Property Value

Type: Max17061TypeDeviceControlBrightnessMux
See Also

Reference

Max17061 Class
telos.Ird.Maxim Namespace


Max17061.FaultStatus1CHSD Property

IRD

Max17061FaultStatus1CHSD Property

Fault Status: 1_CH_SD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max17061TypeFaultStatusSingleLedOutput FaultStatus1CHSD { get; }
Public ReadOnly Property FaultStatus1CHSD As Max17061TypeFaultStatusSingleLedOutput
    Get
public:
property Max17061TypeFaultStatusSingleLedOutput FaultStatus1CHSD {
    Max17061TypeFaultStatusSingleLedOutput get ();
}
member FaultStatus1CHSD : Max17061TypeFaultStatusSingleLedOutput with get

Property Value

Type: Max17061TypeFaultStatusSingleLedOutput
See Also

Reference

Max17061 Class
telos.Ird.Maxim Namespace


Max17061.FaultStatus2CHSD Property

IRD

Max17061FaultStatus2CHSD Property

Fault Status: 2_CH_SD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max17061TypeFaultStatusMultiLedOutput FaultStatus2CHSD { get; }
Public ReadOnly Property FaultStatus2CHSD As Max17061TypeFaultStatusMultiLedOutput
    Get
public:
property Max17061TypeFaultStatusMultiLedOutput FaultStatus2CHSD {
    Max17061TypeFaultStatusMultiLedOutput get ();
}
member FaultStatus2CHSD : Max17061TypeFaultStatusMultiLedOutput with get

Property Value

Type: Max17061TypeFaultStatusMultiLedOutput
See Also

Reference

Max17061 Class
telos.Ird.Maxim Namespace


Max17061.FaultStatusBLSTAT Property

IRD

Max17061FaultStatusBLSTAT Property

Fault Status: BL_STAT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max17061TypeFaultStatusBacklightStatus FaultStatusBLSTAT { get; }
Public ReadOnly Property FaultStatusBLSTAT As Max17061TypeFaultStatusBacklightStatus
    Get
public:
property Max17061TypeFaultStatusBacklightStatus FaultStatusBLSTAT {
    Max17061TypeFaultStatusBacklightStatus get ();
}
member FaultStatusBLSTAT : Max17061TypeFaultStatusBacklightStatus with get

Property Value

Type: Max17061TypeFaultStatusBacklightStatus
See Also

Reference

Max17061 Class
telos.Ird.Maxim Namespace


Max17061.FaultStatusFAULT Property

IRD

Max17061FaultStatusFAULT Property

Fault Status: FAULT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max17061TypeFaultStatusFaultCondition FaultStatusFAULT { get; }
Public ReadOnly Property FaultStatusFAULT As Max17061TypeFaultStatusFaultCondition
    Get
public:
property Max17061TypeFaultStatusFaultCondition FaultStatusFAULT {
    Max17061TypeFaultStatusFaultCondition get ();
}
member FaultStatusFAULT : Max17061TypeFaultStatusFaultCondition with get

Property Value

Type: Max17061TypeFaultStatusFaultCondition
See Also

Reference

Max17061 Class
telos.Ird.Maxim Namespace


Max17061.FaultStatusOVCURR Property

IRD

Max17061FaultStatusOVCURR Property

Fault Status: OV_CURR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max17061TypeFaultStatusInputOvercurrent FaultStatusOVCURR { get; }
Public ReadOnly Property FaultStatusOVCURR As Max17061TypeFaultStatusInputOvercurrent
    Get
public:
property Max17061TypeFaultStatusInputOvercurrent FaultStatusOVCURR {
    Max17061TypeFaultStatusInputOvercurrent get ();
}
member FaultStatusOVCURR : Max17061TypeFaultStatusInputOvercurrent with get

Property Value

Type: Max17061TypeFaultStatusInputOvercurrent
See Also

Reference

Max17061 Class
telos.Ird.Maxim Namespace


Max17061.FaultStatusTHRMSHD Property

IRD

Max17061FaultStatusTHRMSHD Property

Fault Status: THRM_SHD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max17061TypeFaultStatusThermalShutdown FaultStatusTHRMSHD { get; }
Public ReadOnly Property FaultStatusTHRMSHD As Max17061TypeFaultStatusThermalShutdown
    Get
public:
property Max17061TypeFaultStatusThermalShutdown FaultStatusTHRMSHD {
    Max17061TypeFaultStatusThermalShutdown get ();
}
member FaultStatusTHRMSHD : Max17061TypeFaultStatusThermalShutdown with get

Property Value

Type: Max17061TypeFaultStatusThermalShutdown
See Also

Reference

Max17061 Class
telos.Ird.Maxim Namespace


Max17061.IdentificationLEDPANEL Property

IRD

Max17061IdentificationLEDPANEL Property

Identification: LED PANEL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max17061TypeIdentificationLedPanel IdentificationLEDPANEL { get; }
Public ReadOnly Property IdentificationLEDPANEL As Max17061TypeIdentificationLedPanel
    Get
public:
property Max17061TypeIdentificationLedPanel IdentificationLEDPANEL {
    Max17061TypeIdentificationLedPanel get ();
}
member IdentificationLEDPANEL : Max17061TypeIdentificationLedPanel with get

Property Value

Type: Max17061TypeIdentificationLedPanel
See Also

Reference

Max17061 Class
telos.Ird.Maxim Namespace


Max17061.IdentificationMFG Property

IRD

Max17061IdentificationMFG Property

Identification: MFG

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max17061TypeIdentificationManufacturerId IdentificationMFG { get; }
Public ReadOnly Property IdentificationMFG As Max17061TypeIdentificationManufacturerId
    Get
public:
property Max17061TypeIdentificationManufacturerId IdentificationMFG {
    Max17061TypeIdentificationManufacturerId get ();
}
member IdentificationMFG : Max17061TypeIdentificationManufacturerId with get

Property Value

Type: Max17061TypeIdentificationManufacturerId
See Also

Reference

Max17061 Class
telos.Ird.Maxim Namespace


Max17061.IdentificationREV Property

IRD

Max17061IdentificationREV Property

Identification: REV

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IdentificationREV { get; }
Public ReadOnly Property IdentificationREV As Byte
    Get
public:
property unsigned char IdentificationREV {
    unsigned char get ();
}
member IdentificationREV : byte with get

Property Value

Type: Byte
See Also

Reference

Max17061 Class
telos.Ird.Maxim Namespace


Max17061 Methods

The Max17061 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max17061 Class
telos.Ird.Maxim Namespace


Max17061.Flush Method

IRD

Max17061Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max17061 Class
telos.Ird.Maxim Namespace


Max17061.TypeDeviceControlBacklightControl Enumeration

IRD

Max17061TypeDeviceControlBacklightControl Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeviceControlBacklightControl
Public Enumeration TypeDeviceControlBacklightControl
public enum class TypeDeviceControlBacklightControl
type TypeDeviceControlBacklightControl
Members
Member name | Value | Description
BacklightOff | 0 | Backlight: Off
BacklightOn | 1 | Backlight: On
See Also

Reference

telos.Ird.Maxim Namespace


Max17061.TypeDeviceControlBrightnessMux Enumeration

IRD

Max17061TypeDeviceControlBrightnessMux Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeviceControlBrightnessMux
Public Enumeration TypeDeviceControlBrightnessMux
public enum class TypeDeviceControlBrightnessMux
type TypeDeviceControlBrightnessMux
Members
Member name | Value | Description
BrightnessMUXSelectSMBusValue | 0 | Brightness MUX Select: SMBus Value
BrightnessMUXSelectPWMPin | 1 | Brightness MUX Select: PWM Pin
See Also

Reference

telos.Ird.Maxim Namespace


Max17061.TypeDeviceControlPwmMode Enumeration

IRD

Max17061TypeDeviceControlPwmMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeviceControlPwmMode
Public Enumeration TypeDeviceControlPwmMode
public enum class TypeDeviceControlPwmMode
type TypeDeviceControlPwmMode
Members
Member name | Value | Description
PWMModeSelectPercentageChange | 0 | PWM Mode Select: Percentage Change
PWMModeSelectAbsoluteBrightness | 1 | PWM Mode Select: Absolute Brightness
See Also

Reference

telos.Ird.Maxim Namespace


Max17061.TypeFaultStatusBacklightStatus Enumeration

IRD

Max17061TypeFaultStatusBacklightStatus Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusBacklightStatus
Public Enumeration TypeFaultStatusBacklightStatus
public enum class TypeFaultStatusBacklightStatus
type TypeFaultStatusBacklightStatus
Members
Member name | Value | Description
BacklightOff | 0 | Backlight Off
BacklightOn | 1 | Backlight On
See Also

Reference

telos.Ird.Maxim Namespace


Max17061.TypeFaultStatusFaultCondition Enumeration

IRD

Max17061TypeFaultStatusFaultCondition Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusFaultCondition
Public Enumeration TypeFaultStatusFaultCondition
public enum class TypeFaultStatusFaultCondition
type TypeFaultStatusFaultCondition
Members
Member name | Value | Description
NoFault | 0 | No Fault
FaultConditionAnyFaultExceptLEDOpenShort | 1 | Fault Condition (Any Fault Except LED Open/Short)
See Also

Reference

telos.Ird.Maxim Namespace


Max17061.TypeFaultStatusInputOvercurrent Enumeration

IRD

Max17061TypeFaultStatusInputOvercurrent Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusInputOvercurrent
Public Enumeration TypeFaultStatusInputOvercurrent
public enum class TypeFaultStatusInputOvercurrent
type TypeFaultStatusInputOvercurrent
Members
Member name | Value | Description
CurrentOK | 0 | Current OK
OvercurrentCondition | 1 | Overcurrent Condition
See Also

Reference

telos.Ird.Maxim Namespace


Max17061.TypeFaultStatusMultiLedOutput Enumeration

IRD

Max17061TypeFaultStatusMultiLedOutput Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusMultiLedOutput
Public Enumeration TypeFaultStatusMultiLedOutput
public enum class TypeFaultStatusMultiLedOutput
type TypeFaultStatusMultiLedOutput
Members
Member name | Value | Description
MultiLEDOutputChannelOK | 0 | Multi LED Output Channel: OK
MultiLEDOutputChannelFaulted | 1 | Multi LED Output Channel: Faulted
See Also

Reference

telos.Ird.Maxim Namespace


Max17061.TypeFaultStatusSingleLedOutput Enumeration

IRD

Max17061TypeFaultStatusSingleLedOutput Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusSingleLedOutput
Public Enumeration TypeFaultStatusSingleLedOutput
public enum class TypeFaultStatusSingleLedOutput
type TypeFaultStatusSingleLedOutput
Members
Member name | Value | Description
LEDOutputChannelOK | 0 | LED Output Channel: OK
LEDOutputChannelFaulted | 1 | LED Output Channel: Faulted
See Also

Reference

telos.Ird.Maxim Namespace


Max17061.TypeFaultStatusThermalShutdown Enumeration

IRD

Max17061TypeFaultStatusThermalShutdown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFaultStatusThermalShutdown
Public Enumeration TypeFaultStatusThermalShutdown
public enum class TypeFaultStatusThermalShutdown
type TypeFaultStatusThermalShutdown
Members
Member name | Value | Description
ThermalOK | 0 | Thermal OK
ThermalFault | 1 | Thermal Fault
See Also

Reference

telos.Ird.Maxim Namespace


Max17061.TypeIdentificationLedPanel Enumeration

IRD

Max17061TypeIdentificationLedPanel Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIdentificationLedPanel
Public Enumeration TypeIdentificationLedPanel
public enum class TypeIdentificationLedPanel
type TypeIdentificationLedPanel
Members
Member name | Value | Description
DisplayUsingLEDBacklightOff | 0 | Display Using LED Backlight: Off
DisplayUsingLEDBacklightOn | 1 | Display Using LED Backlight: On
See Also

Reference

telos.Ird.Maxim Namespace


Max17061.TypeIdentificationManufacturerId Enumeration

IRD

Max17061TypeIdentificationManufacturerId Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIdentificationManufacturerId
Public Enumeration TypeIdentificationManufacturerId
public enum class TypeIdentificationManufacturerId
type TypeIdentificationManufacturerId
Members
Member name | Value | Description
Maxim | 0 | Maxim
MicroSemi | 1 | Micro Semi
MPS | 2 | MPS
O2Micro | 3 | O2 Micro
TI | 4 | TI
ST | 5 | ST
AnalogDevices | 6 | Analog Devices
Reserved | 7 | Reserved
VendorIDRegisterNotImplemented | 15 | Vendor ID Register Not Implemented
See Also

Reference

telos.Ird.Maxim Namespace


Max6625 Class

Maxim: MAX 6625
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax6625

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max6625
Public Class Max6625
public ref class Max6625
type Max6625 =  class end

The Max6625 type exposes the following members.

Constructors
 | Name | Description
Public method | Max6625 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ComparatorInterruptMode | Comparator/Interrupt Mode
Public property | FaultQueueDepth | Fault Queue Depth
Public property | HighTemperature | High Temperature (unit: °C)
Public property | LowTemperature | Low Temperature (unit: °C)
Public property | OTPolarity | OT Polarity
Public property | Shutdown | Shutdown
Public property | Temperature | Temperature (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
9 Bit Temperature Sensor
See Also

Reference

telos.Ird.Maxim Namespace


Max6625 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6625(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max6625(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max6625

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max6625 Class
telos.Ird.Maxim Namespace


Max6625 Properties

The Max6625 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ComparatorInterruptMode | Comparator/Interrupt Mode
Public property | FaultQueueDepth | Fault Queue Depth
Public property | HighTemperature | High Temperature (unit: °C)
Public property | LowTemperature | Low Temperature (unit: °C)
Public property | OTPolarity | OT Polarity
Public property | Shutdown | Shutdown
Public property | Temperature | Temperature (unit: °C)
Top
See Also

Reference

Max6625 Class
telos.Ird.Maxim Namespace


Max6625.AutoFlush Property

IRD

Max6625AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max6625 Class
telos.Ird.Maxim Namespace


Max6625.ComparatorInterruptMode Property

IRD

Max6625ComparatorInterruptMode Property

Comparator/Interrupt Mode

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6625CompIntType ComparatorInterruptMode { get; set; }
Public Property ComparatorInterruptMode As Max6625CompIntType
    Get
    Set
public:
property Max6625CompIntType ComparatorInterruptMode {
    Max6625CompIntType get ();
    void set (Max6625CompIntType value);
}
member ComparatorInterruptMode : Max6625CompIntType with get, set

Property Value

Type: Max6625CompIntType
See Also

Reference

Max6625 Class
telos.Ird.Maxim Namespace


Max6625.FaultQueueDepth Property

IRD

Max6625FaultQueueDepth Property

Fault Queue Depth

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6625FaultQueueType FaultQueueDepth { get; set; }
Public Property FaultQueueDepth As Max6625FaultQueueType
    Get
    Set
public:
property Max6625FaultQueueType FaultQueueDepth {
    Max6625FaultQueueType get ();
    void set (Max6625FaultQueueType value);
}
member FaultQueueDepth : Max6625FaultQueueType with get, set

Property Value

Type: Max6625FaultQueueType
See Also

Reference

Max6625 Class
telos.Ird.Maxim Namespace


Max6625.HighTemperature Property

IRD

Max6625HighTemperature Property

High Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double HighTemperature { get; }
Public ReadOnly Property HighTemperature As Double
    Get
public:
property double HighTemperature {
    double get ();
}
member HighTemperature : float with get

Property Value

Type: Double
See Also

Reference

Max6625 Class
telos.Ird.Maxim Namespace


Max6625.LowTemperature Property

IRD

Max6625LowTemperature Property

Low Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LowTemperature { get; }
Public ReadOnly Property LowTemperature As Double
    Get
public:
property double LowTemperature {
    double get ();
}
member LowTemperature : float with get

Property Value

Type: Double
See Also

Reference

Max6625 Class
telos.Ird.Maxim Namespace


Max6625.OTPolarity Property

IRD

Max6625OTPolarity Property

OT Polarity

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6625PolarityType OTPolarity { get; set; }
Public Property OTPolarity As Max6625PolarityType
    Get
    Set
public:
property Max6625PolarityType OTPolarity {
    Max6625PolarityType get ();
    void set (Max6625PolarityType value);
}
member OTPolarity : Max6625PolarityType with get, set

Property Value

Type: Max6625PolarityType
See Also

Reference

Max6625 Class
telos.Ird.Maxim Namespace


Max6625.Shutdown Property

IRD

Max6625Shutdown Property

Shutdown

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6625ConfigShutdownType Shutdown { get; set; }
Public Property Shutdown As Max6625ConfigShutdownType
    Get
    Set
public:
property Max6625ConfigShutdownType Shutdown {
    Max6625ConfigShutdownType get ();
    void set (Max6625ConfigShutdownType value);
}
member Shutdown : Max6625ConfigShutdownType with get, set

Property Value

Type: Max6625ConfigShutdownType
See Also

Reference

Max6625 Class
telos.Ird.Maxim Namespace


Max6625.Temperature Property

IRD

Max6625Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Max6625 Class
telos.Ird.Maxim Namespace


Max6625 Methods

The Max6625 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max6625 Class
telos.Ird.Maxim Namespace


Max6625.Flush Method

IRD

Max6625Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max6625 Class
telos.Ird.Maxim Namespace


Max6625.CompIntType Enumeration

IRD

Max6625CompIntType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CompIntType
Public Enumeration CompIntType
public enum class CompIntType
type CompIntType
Members
Member name | Value | Description
ComparatorMode | 0 | Comparator Mode
InterruptMode | 1 | Interrupt Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max6625.ConfigShutdownType Enumeration

IRD

Max6625ConfigShutdownType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigShutdownType
Public Enumeration ConfigShutdownType
public enum class ConfigShutdownType
type ConfigShutdownType
Members
Member name | Value | Description
NormalOperation | 0 | Normal Operation
ShutdownMode | 1 | Shutdown Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max6625.FaultQueueType Enumeration

IRD

Max6625FaultQueueType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultQueueType
Public Enumeration FaultQueueType
public enum class FaultQueueType
type FaultQueueType
Members
Member name | Value | Description
NumberOfFaults1 | 0 | Number of Faults: 1
NumberOfFaults2 | 1 | Number of Faults: 2
NumberOfFaults4 | 2 | Number of Faults: 4
NumberOfFaults6 | 3 | Number of Faults: 6
See Also

Reference

telos.Ird.Maxim Namespace


Max6625.PolarityType Enumeration

IRD

Max6625PolarityType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum PolarityType
Public Enumeration PolarityType
public enum class PolarityType
type PolarityType
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.Maxim Namespace


Max6626 Class

Maxim: MAX 6626
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax6626

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max6626
Public Class Max6626
public ref class Max6626
type Max6626 =  class end

The Max6626 type exposes the following members.

Constructors
 | Name | Description
Public method | Max6626 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ComparatorInterruptMode | Comparator/Interrupt Mode
Public property | FaultQueueDepth | Fault Queue Depth
Public property | HighTemperature | High Temperature (unit: °C)
Public property | LowTemperature | Low Temperature (unit: °C)
Public property | OTPolarity | OT Polarity
Public property | Shutdown | Shutdown
Public property | Temperature | Temperature (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
12 Bit Temperature Sensor
See Also

Reference

telos.Ird.Maxim Namespace


Max6626 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6626(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max6626(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max6626

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max6626 Class
telos.Ird.Maxim Namespace


Max6626 Properties

The Max6626 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ComparatorInterruptMode | Comparator/Interrupt Mode
Public property | FaultQueueDepth | Fault Queue Depth
Public property | HighTemperature | High Temperature (unit: °C)
Public property | LowTemperature | Low Temperature (unit: °C)
Public property | OTPolarity | OT Polarity
Public property | Shutdown | Shutdown
Public property | Temperature | Temperature (unit: °C)
Top
See Also

Reference

Max6626 Class
telos.Ird.Maxim Namespace


Max6626.AutoFlush Property

IRD

Max6626AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max6626 Class
telos.Ird.Maxim Namespace


Max6626.ComparatorInterruptMode Property

IRD

Max6626ComparatorInterruptMode Property

Comparator/Interrupt Mode

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6626CompIntType ComparatorInterruptMode { get; set; }
Public Property ComparatorInterruptMode As Max6626CompIntType
    Get
    Set
public:
property Max6626CompIntType ComparatorInterruptMode {
    Max6626CompIntType get ();
    void set (Max6626CompIntType value);
}
member ComparatorInterruptMode : Max6626CompIntType with get, set

Property Value

Type: Max6626CompIntType
See Also

Reference

Max6626 Class
telos.Ird.Maxim Namespace


Max6626.FaultQueueDepth Property

IRD

Max6626FaultQueueDepth Property

Fault Queue Depth

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6626FaultQueueType FaultQueueDepth { get; set; }
Public Property FaultQueueDepth As Max6626FaultQueueType
    Get
    Set
public:
property Max6626FaultQueueType FaultQueueDepth {
    Max6626FaultQueueType get ();
    void set (Max6626FaultQueueType value);
}
member FaultQueueDepth : Max6626FaultQueueType with get, set

Property Value

Type: Max6626FaultQueueType
See Also

Reference

Max6626 Class
telos.Ird.Maxim Namespace


Max6626.HighTemperature Property

IRD

Max6626HighTemperature Property

High Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double HighTemperature { get; }
Public ReadOnly Property HighTemperature As Double
    Get
public:
property double HighTemperature {
    double get ();
}
member HighTemperature : float with get

Property Value

Type: Double
See Also

Reference

Max6626 Class
telos.Ird.Maxim Namespace


Max6626.LowTemperature Property

IRD

Max6626LowTemperature Property

Low Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LowTemperature { get; }
Public ReadOnly Property LowTemperature As Double
    Get
public:
property double LowTemperature {
    double get ();
}
member LowTemperature : float with get

Property Value

Type: Double
See Also

Reference

Max6626 Class
telos.Ird.Maxim Namespace


Max6626.OTPolarity Property

IRD

Max6626OTPolarity Property

OT Polarity

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6626PolarityType OTPolarity { get; set; }
Public Property OTPolarity As Max6626PolarityType
    Get
    Set
public:
property Max6626PolarityType OTPolarity {
    Max6626PolarityType get ();
    void set (Max6626PolarityType value);
}
member OTPolarity : Max6626PolarityType with get, set

Property Value

Type: Max6626PolarityType
See Also

Reference

Max6626 Class
telos.Ird.Maxim Namespace


Max6626.Shutdown Property

IRD

Max6626Shutdown Property

Shutdown

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6626ConfigShutdownType Shutdown { get; set; }
Public Property Shutdown As Max6626ConfigShutdownType
    Get
    Set
public:
property Max6626ConfigShutdownType Shutdown {
    Max6626ConfigShutdownType get ();
    void set (Max6626ConfigShutdownType value);
}
member Shutdown : Max6626ConfigShutdownType with get, set

Property Value

Type: Max6626ConfigShutdownType
See Also

Reference

Max6626 Class
telos.Ird.Maxim Namespace


Max6626.Temperature Property

IRD

Max6626Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Max6626 Class
telos.Ird.Maxim Namespace


Max6626 Methods

The Max6626 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max6626 Class
telos.Ird.Maxim Namespace


Max6626.Flush Method

IRD

Max6626Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max6626 Class
telos.Ird.Maxim Namespace


Max6626.CompIntType Enumeration

IRD

Max6626CompIntType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CompIntType
Public Enumeration CompIntType
public enum class CompIntType
type CompIntType
Members
Member name | Value | Description
ComparatorMode | 0 | Comparator Mode
InterruptMode | 1 | Interrupt Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max6626.ConfigShutdownType Enumeration

IRD

Max6626ConfigShutdownType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigShutdownType
Public Enumeration ConfigShutdownType
public enum class ConfigShutdownType
type ConfigShutdownType
Members
Member name | Value | Description
NormalOperation | 0 | Normal Operation
ShutdownMode | 1 | Shutdown Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max6626.FaultQueueType Enumeration

IRD

Max6626FaultQueueType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultQueueType
Public Enumeration FaultQueueType
public enum class FaultQueueType
type FaultQueueType
Members
Member name | Value | Description
NumberOfFaults1 | 0 | Number of Faults: 1
NumberOfFaults2 | 1 | Number of Faults: 2
NumberOfFaults4 | 2 | Number of Faults: 4
NumberOfFaults6 | 3 | Number of Faults: 6
See Also

Reference

telos.Ird.Maxim Namespace


Max6626.PolarityType Enumeration

IRD

Max6626PolarityType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum PolarityType
Public Enumeration PolarityType
public enum class PolarityType
type PolarityType
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.Maxim Namespace


Max6633 Class

Maxim: MAX 6633
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax6633

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max6633
Public Class Max6633
public ref class Max6633
type Max6633 =  class end

The Max6633 type exposes the following members.

Constructors
 | Name | Description
Public method | Max6633 | Constructor
Top
Properties
 | Name | Description
Public property | AlertPolarity | Alert Polarity
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ComparatorOrInterrupt | Comparator Or Interrupt
Public property | FaultQueueEnable | Fault Queue Enable
Public property | OverTemperaturePolarity | Over Temperature Polarity
Public property | Shutdown | Shutdown
Public property | SMBTimeoutDisable | SMB Timeout Disable
Public property | Temperature | Temperature (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
12 Bit Plus Sign Temperature Sensor
See Also

Reference

telos.Ird.Maxim Namespace


Max6633 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6633(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max6633(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max6633

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max6633 Class
telos.Ird.Maxim Namespace


Max6633 Properties

The Max6633 type exposes the following members.

Properties
 | Name | Description
Public property | AlertPolarity | Alert Polarity
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ComparatorOrInterrupt | Comparator Or Interrupt
Public property | FaultQueueEnable | Fault Queue Enable
Public property | OverTemperaturePolarity | Over Temperature Polarity
Public property | Shutdown | Shutdown
Public property | SMBTimeoutDisable | SMB Timeout Disable
Public property | Temperature | Temperature (unit: °C)
Top
See Also

Reference

Max6633 Class
telos.Ird.Maxim Namespace


Max6633.AlertPolarity Property

IRD

Max6633AlertPolarity Property

Alert Polarity

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6633AlertType AlertPolarity { get; set; }
Public Property AlertPolarity As Max6633AlertType
    Get
    Set
public:
property Max6633AlertType AlertPolarity {
    Max6633AlertType get ();
    void set (Max6633AlertType value);
}
member AlertPolarity : Max6633AlertType with get, set

Property Value

Type: Max6633AlertType
See Also

Reference

Max6633 Class
telos.Ird.Maxim Namespace


Max6633.AutoFlush Property

IRD

Max6633AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max6633 Class
telos.Ird.Maxim Namespace


Max6633.ComparatorOrInterrupt Property

IRD

Max6633ComparatorOrInterrupt Property

Comparator Or Interrupt

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6633CompIntType ComparatorOrInterrupt { get; set; }
Public Property ComparatorOrInterrupt As Max6633CompIntType
    Get
    Set
public:
property Max6633CompIntType ComparatorOrInterrupt {
    Max6633CompIntType get ();
    void set (Max6633CompIntType value);
}
member ComparatorOrInterrupt : Max6633CompIntType with get, set

Property Value

Type: Max6633CompIntType
See Also

Reference

Max6633 Class
telos.Ird.Maxim Namespace


Max6633.FaultQueueEnable Property

IRD

Max6633FaultQueueEnable Property

Fault Queue Enable

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6633FaultQueueType FaultQueueEnable { get; set; }
Public Property FaultQueueEnable As Max6633FaultQueueType
    Get
    Set
public:
property Max6633FaultQueueType FaultQueueEnable {
    Max6633FaultQueueType get ();
    void set (Max6633FaultQueueType value);
}
member FaultQueueEnable : Max6633FaultQueueType with get, set

Property Value

Type: Max6633FaultQueueType
See Also

Reference

Max6633 Class
telos.Ird.Maxim Namespace


Max6633.OverTemperaturePolarity Property

IRD

Max6633OverTemperaturePolarity Property

Over Temperature Polarity

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6633OverTType OverTemperaturePolarity { get; set; }
Public Property OverTemperaturePolarity As Max6633OverTType
    Get
    Set
public:
property Max6633OverTType OverTemperaturePolarity {
    Max6633OverTType get ();
    void set (Max6633OverTType value);
}
member OverTemperaturePolarity : Max6633OverTType with get, set

Property Value

Type: Max6633OverTType
See Also

Reference

Max6633 Class
telos.Ird.Maxim Namespace


Max6633.Shutdown Property

IRD

Max6633Shutdown Property

Shutdown

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6633ShutdownType Shutdown { get; set; }
Public Property Shutdown As Max6633ShutdownType
    Get
    Set
public:
property Max6633ShutdownType Shutdown {
    Max6633ShutdownType get ();
    void set (Max6633ShutdownType value);
}
member Shutdown : Max6633ShutdownType with get, set

Property Value

Type: Max6633ShutdownType
See Also

Reference

Max6633 Class
telos.Ird.Maxim Namespace


Max6633.SMBTimeoutDisable Property

IRD

Max6633SMBTimeoutDisable Property

SMB Timeout Disable

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6633SmbTimeoutType SMBTimeoutDisable { get; set; }
Public Property SMBTimeoutDisable As Max6633SmbTimeoutType
    Get
    Set
public:
property Max6633SmbTimeoutType SMBTimeoutDisable {
    Max6633SmbTimeoutType get ();
    void set (Max6633SmbTimeoutType value);
}
member SMBTimeoutDisable : Max6633SmbTimeoutType with get, set

Property Value

Type: Max6633SmbTimeoutType
See Also

Reference

Max6633 Class
telos.Ird.Maxim Namespace


Max6633.Temperature Property

IRD

Max6633Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Max6633 Class
telos.Ird.Maxim Namespace


Max6633 Methods

The Max6633 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max6633 Class
telos.Ird.Maxim Namespace


Max6633.Flush Method

IRD

Max6633Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max6633 Class
telos.Ird.Maxim Namespace


Max6633.AlertType Enumeration

IRD

Max6633AlertType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlertType
Public Enumeration AlertType
public enum class AlertType
type AlertType
Members
Member name | Value | Description
ActiveLowPolarity | 0 | Active Low Polarity
ActiveHighPolarity | 1 | Active High Polarity
See Also

Reference

telos.Ird.Maxim Namespace


Max6633.CompIntType Enumeration

IRD

Max6633CompIntType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CompIntType
Public Enumeration CompIntType
public enum class CompIntType
type CompIntType
Members
Member name | Value | Description
ComparatorMode | 0 | Comparator Mode
InterruptMode | 1 | Interrupt Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max6633.FaultQueueType Enumeration

IRD

Max6633FaultQueueType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultQueueType
Public Enumeration FaultQueueType
public enum class FaultQueueType
type FaultQueueType
Members
Member name | Value | Description
NumberOfFaults1 | 0 | Number Of Faults: 1
NumberOfFaults4 | 1 | Number Of Faults: 4
See Also

Reference

telos.Ird.Maxim Namespace


Max6633.OverTType Enumeration

IRD

Max6633OverTType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum OverTType
Public Enumeration OverTType
public enum class OverTType
type OverTType
Members
Member name | Value | Description
ActiveLowPolarity | 0 | Active Low Polarity
ActiveHighPolarity | 1 | Active High Polarity
See Also

Reference

telos.Ird.Maxim Namespace


Max6633.ShutdownType Enumeration

IRD

Max6633ShutdownType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ShutdownType
Public Enumeration ShutdownType
public enum class ShutdownType
type ShutdownType
Members
Member name | Value | Description
NormalOperation | 0 | Normal Operation
Shutdown | 1 | Shutdown
See Also

Reference

telos.Ird.Maxim Namespace


Max6633.SmbTimeoutType Enumeration

IRD

Max6633SmbTimeoutType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SmbTimeoutType
Public Enumeration SmbTimeoutType
public enum class SmbTimeoutType
type SmbTimeoutType
Members
Member name | Value | Description
NormalSMBusOperation | 0 | Normal SMBus Operation
FullI2CCompatibility | 1 | Full I2C Compatibility
See Also

Reference

telos.Ird.Maxim Namespace


Max6634 Class

Maxim: MAX 6634
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax6634

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max6634
Public Class Max6634
public ref class Max6634
type Max6634 =  class end

The Max6634 type exposes the following members.

Constructors
 | Name | Description
Public method | Max6634 | Constructor
Top
Properties
 | Name | Description
Public property | AlertPolarity | Alert Polarity
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ComparatorOrInterrupt | Comparator Or Interrupt
Public property | FaultQueueEnable | Fault Queue Enable
Public property | HighTemperatureFlagTHIGH | High Temperature Flag (T_HIGH)
Public property | HighTemperatureTHIGH | High Temperature (T_HIGH) (unit: °C)
Public property | LowTemperatureFlagTLOW | Low Temperature Flag (T_LOW)
Public property | LowTemperatureTLOW | Low Temperature (T_LOW) (unit: °C)
Public property | OverTemperaturePolarity | Over Temperature Polarity
Public property | Shutdown | Shutdown
Public property | SMBTimeoutDisable | SMB Timeout Disable
Public property | Temperature | Temperature (unit: °C)
Public property | TemperatureHysteresisTHYST | Temperature Hysteresis (T_HYST) (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
12 Bit Plus Sign Temperature Sensor
See Also

Reference

telos.Ird.Maxim Namespace


Max6634 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6634(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max6634(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max6634

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max6634 Class
telos.Ird.Maxim Namespace


Max6634 Properties

The Max6634 type exposes the following members.

Properties
 | Name | Description
Public property | AlertPolarity | Alert Polarity
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ComparatorOrInterrupt | Comparator Or Interrupt
Public property | FaultQueueEnable | Fault Queue Enable
Public property | HighTemperatureFlagTHIGH | High Temperature Flag (T_HIGH)
Public property | HighTemperatureTHIGH | High Temperature (T_HIGH) (unit: °C)
Public property | LowTemperatureFlagTLOW | Low Temperature Flag (T_LOW)
Public property | LowTemperatureTLOW | Low Temperature (T_LOW) (unit: °C)
Public property | OverTemperaturePolarity | Over Temperature Polarity
Public property | Shutdown | Shutdown
Public property | SMBTimeoutDisable | SMB Timeout Disable
Public property | Temperature | Temperature (unit: °C)
Public property | TemperatureHysteresisTHYST | Temperature Hysteresis (T_HYST) (unit: °C)
Top
See Also

Reference

Max6634 Class
telos.Ird.Maxim Namespace


Max6634.AlertPolarity Property

IRD

Max6634AlertPolarity Property

Alert Polarity

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6634AlertType AlertPolarity { get; set; }
Public Property AlertPolarity As Max6634AlertType
    Get
    Set
public:
property Max6634AlertType AlertPolarity {
    Max6634AlertType get ();
    void set (Max6634AlertType value);
}
member AlertPolarity : Max6634AlertType with get, set

Property Value

Type: Max6634AlertType
See Also

Reference

Max6634 Class
telos.Ird.Maxim Namespace


Max6634.AutoFlush Property

IRD

Max6634AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max6634 Class
telos.Ird.Maxim Namespace


Max6634.ComparatorOrInterrupt Property

IRD

Max6634ComparatorOrInterrupt Property

Comparator Or Interrupt

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6634CompIntType ComparatorOrInterrupt { get; set; }
Public Property ComparatorOrInterrupt As Max6634CompIntType
    Get
    Set
public:
property Max6634CompIntType ComparatorOrInterrupt {
    Max6634CompIntType get ();
    void set (Max6634CompIntType value);
}
member ComparatorOrInterrupt : Max6634CompIntType with get, set

Property Value

Type: Max6634CompIntType
See Also

Reference

Max6634 Class
telos.Ird.Maxim Namespace


Max6634.FaultQueueEnable Property

IRD

Max6634FaultQueueEnable Property

Fault Queue Enable

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6634FaultQueueType FaultQueueEnable { get; set; }
Public Property FaultQueueEnable As Max6634FaultQueueType
    Get
    Set
public:
property Max6634FaultQueueType FaultQueueEnable {
    Max6634FaultQueueType get ();
    void set (Max6634FaultQueueType value);
}
member FaultQueueEnable : Max6634FaultQueueType with get, set

Property Value

Type: Max6634FaultQueueType
See Also

Reference

Max6634 Class
telos.Ird.Maxim Namespace


Max6634.HighTemperatureFlagTHIGH Property

IRD

Max6634HighTemperatureFlagTHIGH Property

High Temperature Flag (T_HIGH)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6634TFlagType HighTemperatureFlagTHIGH { get; }
Public ReadOnly Property HighTemperatureFlagTHIGH As Max6634TFlagType
    Get
public:
property Max6634TFlagType HighTemperatureFlagTHIGH {
    Max6634TFlagType get ();
}
member HighTemperatureFlagTHIGH : Max6634TFlagType with get

Property Value

Type: Max6634TFlagType
See Also

Reference

Max6634 Class
telos.Ird.Maxim Namespace


Max6634.HighTemperatureTHIGH Property

IRD

Max6634HighTemperatureTHIGH Property

High Temperature (T_HIGH) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short HighTemperatureTHIGH { get; set; }
Public Property HighTemperatureTHIGH As Short
    Get
    Set
public:
property short HighTemperatureTHIGH {
    short get ();
    void set (short value);
}
member HighTemperatureTHIGH : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Max6634 Class
telos.Ird.Maxim Namespace


Max6634.LowTemperatureFlagTLOW Property

IRD

Max6634LowTemperatureFlagTLOW Property

Low Temperature Flag (T_LOW)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6634TFlagType LowTemperatureFlagTLOW { get; }
Public ReadOnly Property LowTemperatureFlagTLOW As Max6634TFlagType
    Get
public:
property Max6634TFlagType LowTemperatureFlagTLOW {
    Max6634TFlagType get ();
}
member LowTemperatureFlagTLOW : Max6634TFlagType with get

Property Value

Type: Max6634TFlagType
See Also

Reference

Max6634 Class
telos.Ird.Maxim Namespace


Max6634.LowTemperatureTLOW Property

IRD

Max6634LowTemperatureTLOW Property

Low Temperature (T_LOW) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short LowTemperatureTLOW { get; set; }
Public Property LowTemperatureTLOW As Short
    Get
    Set
public:
property short LowTemperatureTLOW {
    short get ();
    void set (short value);
}
member LowTemperatureTLOW : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Max6634 Class
telos.Ird.Maxim Namespace


Max6634.OverTemperaturePolarity Property

IRD

Max6634OverTemperaturePolarity Property

Over Temperature Polarity

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6634OverTType OverTemperaturePolarity { get; set; }
Public Property OverTemperaturePolarity As Max6634OverTType
    Get
    Set
public:
property Max6634OverTType OverTemperaturePolarity {
    Max6634OverTType get ();
    void set (Max6634OverTType value);
}
member OverTemperaturePolarity : Max6634OverTType with get, set

Property Value

Type: Max6634OverTType
See Also

Reference

Max6634 Class
telos.Ird.Maxim Namespace


Max6634.Shutdown Property

IRD

Max6634Shutdown Property

Shutdown

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6634ShutdownType Shutdown { get; set; }
Public Property Shutdown As Max6634ShutdownType
    Get
    Set
public:
property Max6634ShutdownType Shutdown {
    Max6634ShutdownType get ();
    void set (Max6634ShutdownType value);
}
member Shutdown : Max6634ShutdownType with get, set

Property Value

Type: Max6634ShutdownType
See Also

Reference

Max6634 Class
telos.Ird.Maxim Namespace


Max6634.SMBTimeoutDisable Property

IRD

Max6634SMBTimeoutDisable Property

SMB Timeout Disable

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6634SmbTimeoutType SMBTimeoutDisable { get; set; }
Public Property SMBTimeoutDisable As Max6634SmbTimeoutType
    Get
    Set
public:
property Max6634SmbTimeoutType SMBTimeoutDisable {
    Max6634SmbTimeoutType get ();
    void set (Max6634SmbTimeoutType value);
}
member SMBTimeoutDisable : Max6634SmbTimeoutType with get, set

Property Value

Type: Max6634SmbTimeoutType
See Also

Reference

Max6634 Class
telos.Ird.Maxim Namespace


Max6634.Temperature Property

IRD

Max6634Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Max6634 Class
telos.Ird.Maxim Namespace


Max6634.TemperatureHysteresisTHYST Property

IRD

Max6634TemperatureHysteresisTHYST Property

Temperature Hysteresis (T_HYST) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short TemperatureHysteresisTHYST { get; set; }
Public Property TemperatureHysteresisTHYST As Short
    Get
    Set
public:
property short TemperatureHysteresisTHYST {
    short get ();
    void set (short value);
}
member TemperatureHysteresisTHYST : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Max6634 Class
telos.Ird.Maxim Namespace


Max6634 Methods

The Max6634 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max6634 Class
telos.Ird.Maxim Namespace


Max6634.Flush Method

IRD

Max6634Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max6634 Class
telos.Ird.Maxim Namespace


Max6634.AlertType Enumeration

IRD

Max6634AlertType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlertType
Public Enumeration AlertType
public enum class AlertType
type AlertType
Members
Member name | Value | Description
ActiveLowPolarity | 0 | Active Low Polarity
ActiveHighPolarity | 1 | Active High Polarity
See Also

Reference

telos.Ird.Maxim Namespace


Max6634.CompIntType Enumeration

IRD

Max6634CompIntType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CompIntType
Public Enumeration CompIntType
public enum class CompIntType
type CompIntType
Members
Member name | Value | Description
ComparatorMode | 0 | Comparator Mode
InterruptMode | 1 | Interrupt Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max6634.FaultQueueType Enumeration

IRD

Max6634FaultQueueType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultQueueType
Public Enumeration FaultQueueType
public enum class FaultQueueType
type FaultQueueType
Members
Member name | Value | Description
NumberOfFaults1 | 0 | Number Of Faults: 1
NumberOfFaults4 | 1 | Number Of Faults: 4
See Also

Reference

telos.Ird.Maxim Namespace


Max6634.OverTType Enumeration

IRD

Max6634OverTType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum OverTType
Public Enumeration OverTType
public enum class OverTType
type OverTType
Members
Member name | Value | Description
ActiveLowPolarity | 0 | Active Low Polarity
ActiveHighPolarity | 1 | Active High Polarity
See Also

Reference

telos.Ird.Maxim Namespace


Max6634.ShutdownType Enumeration

IRD

Max6634ShutdownType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ShutdownType
Public Enumeration ShutdownType
public enum class ShutdownType
type ShutdownType
Members
Member name | Value | Description
NormalOperation | 0 | Normal Operation
Shutdown | 1 | Shutdown
See Also

Reference

telos.Ird.Maxim Namespace


Max6634.SmbTimeoutType Enumeration

IRD

Max6634SmbTimeoutType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SmbTimeoutType
Public Enumeration SmbTimeoutType
public enum class SmbTimeoutType
type SmbTimeoutType
Members
Member name | Value | Description
NormalSMBusOperation | 0 | Normal SMBus Operation
FullI2CCompatibility | 1 | Full I2C Compatibility
See Also

Reference

telos.Ird.Maxim Namespace


Max6634.TFlagType Enumeration

IRD

Max6634TFlagType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TFlagType
Public Enumeration TFlagType
public enum class TFlagType
type TFlagType
Members
Member name | Value | Description
TempWarningFlagNotSet | 0 | Temp Warning Flag Not Set
TempWarningFlagSet | 1 | Temp Warning Flag Set
See Also

Reference

telos.Ird.Maxim Namespace


Max6635 Class

Maxim: MAX 6635
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax6635

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max6635
Public Class Max6635
public ref class Max6635
type Max6635 =  class end

The Max6635 type exposes the following members.

Constructors
 | Name | Description
Public method | Max6635 | Constructor
Top
Properties
 | Name | Description
Public property | AlertPolarity | Alert Polarity
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ComparatorOrInterrupt | Comparator Or Interrupt
Public property | FaultQueueEnable | Fault Queue Enable
Public property | HighTemperatureFlagTHIGH | High Temperature Flag (T_HIGH)
Public property | HighTemperatureTHIGH | High Temperature (T_HIGH) (unit: °C)
Public property | LowTemperatureFlagTLOW | Low Temperature Flag (T_LOW)
Public property | LowTemperatureTLOW | Low Temperature (T_LOW) (unit: °C)
Public property | MaximumTemperatureFlagTMAX | Maximum Temperature Flag (T_MAX)
Public property | MaximumTemperatureTMAX | Maximum Temperature (T_MAX) (unit: °C)
Public property | OverTemperaturePolarity | Over Temperature Polarity
Public property | Shutdown | Shutdown
Public property | SMBTimeoutDisable | SMB Timeout Disable
Public property | Temperature | Temperature (unit: °C)
Public property | TemperatureHysteresisTHYST | Temperature Hysteresis (T_HYST) (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
12 Bit Plus Sign Temperature Sensor
See Also

Reference

telos.Ird.Maxim Namespace


Max6635 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6635(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max6635(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max6635

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635 Properties

The Max6635 type exposes the following members.

Properties
 | Name | Description
Public property | AlertPolarity | Alert Polarity
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ComparatorOrInterrupt | Comparator Or Interrupt
Public property | FaultQueueEnable | Fault Queue Enable
Public property | HighTemperatureFlagTHIGH | High Temperature Flag (T_HIGH)
Public property | HighTemperatureTHIGH | High Temperature (T_HIGH) (unit: °C)
Public property | LowTemperatureFlagTLOW | Low Temperature Flag (T_LOW)
Public property | LowTemperatureTLOW | Low Temperature (T_LOW) (unit: °C)
Public property | MaximumTemperatureFlagTMAX | Maximum Temperature Flag (T_MAX)
Public property | MaximumTemperatureTMAX | Maximum Temperature (T_MAX) (unit: °C)
Public property | OverTemperaturePolarity | Over Temperature Polarity
Public property | Shutdown | Shutdown
Public property | SMBTimeoutDisable | SMB Timeout Disable
Public property | Temperature | Temperature (unit: °C)
Public property | TemperatureHysteresisTHYST | Temperature Hysteresis (T_HYST) (unit: °C)
Top
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635.AlertPolarity Property

IRD

Max6635AlertPolarity Property

Alert Polarity

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6635AlertType AlertPolarity { get; set; }
Public Property AlertPolarity As Max6635AlertType
    Get
    Set
public:
property Max6635AlertType AlertPolarity {
    Max6635AlertType get ();
    void set (Max6635AlertType value);
}
member AlertPolarity : Max6635AlertType with get, set

Property Value

Type: Max6635AlertType
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635.AutoFlush Property

IRD

Max6635AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635.ComparatorOrInterrupt Property

IRD

Max6635ComparatorOrInterrupt Property

Comparator Or Interrupt

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6635CompIntType ComparatorOrInterrupt { get; set; }
Public Property ComparatorOrInterrupt As Max6635CompIntType
    Get
    Set
public:
property Max6635CompIntType ComparatorOrInterrupt {
    Max6635CompIntType get ();
    void set (Max6635CompIntType value);
}
member ComparatorOrInterrupt : Max6635CompIntType with get, set

Property Value

Type: Max6635CompIntType
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635.FaultQueueEnable Property

IRD

Max6635FaultQueueEnable Property

Fault Queue Enable

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6635FaultQueueType FaultQueueEnable { get; set; }
Public Property FaultQueueEnable As Max6635FaultQueueType
    Get
    Set
public:
property Max6635FaultQueueType FaultQueueEnable {
    Max6635FaultQueueType get ();
    void set (Max6635FaultQueueType value);
}
member FaultQueueEnable : Max6635FaultQueueType with get, set

Property Value

Type: Max6635FaultQueueType
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635.HighTemperatureFlagTHIGH Property

IRD

Max6635HighTemperatureFlagTHIGH Property

High Temperature Flag (T_HIGH)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6635TFlagType HighTemperatureFlagTHIGH { get; }
Public ReadOnly Property HighTemperatureFlagTHIGH As Max6635TFlagType
    Get
public:
property Max6635TFlagType HighTemperatureFlagTHIGH {
    Max6635TFlagType get ();
}
member HighTemperatureFlagTHIGH : Max6635TFlagType with get

Property Value

Type: Max6635TFlagType
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635.HighTemperatureTHIGH Property

IRD

Max6635HighTemperatureTHIGH Property

High Temperature (T_HIGH) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short HighTemperatureTHIGH { get; set; }
Public Property HighTemperatureTHIGH As Short
    Get
    Set
public:
property short HighTemperatureTHIGH {
    short get ();
    void set (short value);
}
member HighTemperatureTHIGH : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635.LowTemperatureFlagTLOW Property

IRD

Max6635LowTemperatureFlagTLOW Property

Low Temperature Flag (T_LOW)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6635TFlagType LowTemperatureFlagTLOW { get; }
Public ReadOnly Property LowTemperatureFlagTLOW As Max6635TFlagType
    Get
public:
property Max6635TFlagType LowTemperatureFlagTLOW {
    Max6635TFlagType get ();
}
member LowTemperatureFlagTLOW : Max6635TFlagType with get

Property Value

Type: Max6635TFlagType
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635.LowTemperatureTLOW Property

IRD

Max6635LowTemperatureTLOW Property

Low Temperature (T_LOW) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short LowTemperatureTLOW { get; set; }
Public Property LowTemperatureTLOW As Short
    Get
    Set
public:
property short LowTemperatureTLOW {
    short get ();
    void set (short value);
}
member LowTemperatureTLOW : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635.MaximumTemperatureFlagTMAX Property

IRD

Max6635MaximumTemperatureFlagTMAX Property

Maximum Temperature Flag (T_MAX)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6635TFlagType MaximumTemperatureFlagTMAX { get; }
Public ReadOnly Property MaximumTemperatureFlagTMAX As Max6635TFlagType
    Get
public:
property Max6635TFlagType MaximumTemperatureFlagTMAX {
    Max6635TFlagType get ();
}
member MaximumTemperatureFlagTMAX : Max6635TFlagType with get

Property Value

Type: Max6635TFlagType
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635.MaximumTemperatureTMAX Property

IRD

Max6635MaximumTemperatureTMAX Property

Maximum Temperature (T_MAX) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short MaximumTemperatureTMAX { get; set; }
Public Property MaximumTemperatureTMAX As Short
    Get
    Set
public:
property short MaximumTemperatureTMAX {
    short get ();
    void set (short value);
}
member MaximumTemperatureTMAX : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635.OverTemperaturePolarity Property

IRD

Max6635OverTemperaturePolarity Property

Over Temperature Polarity

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6635OverTType OverTemperaturePolarity { get; set; }
Public Property OverTemperaturePolarity As Max6635OverTType
    Get
    Set
public:
property Max6635OverTType OverTemperaturePolarity {
    Max6635OverTType get ();
    void set (Max6635OverTType value);
}
member OverTemperaturePolarity : Max6635OverTType with get, set

Property Value

Type: Max6635OverTType
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635.Shutdown Property

IRD

Max6635Shutdown Property

Shutdown

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6635ShutdownType Shutdown { get; set; }
Public Property Shutdown As Max6635ShutdownType
    Get
    Set
public:
property Max6635ShutdownType Shutdown {
    Max6635ShutdownType get ();
    void set (Max6635ShutdownType value);
}
member Shutdown : Max6635ShutdownType with get, set

Property Value

Type: Max6635ShutdownType
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635.SMBTimeoutDisable Property

IRD

Max6635SMBTimeoutDisable Property

SMB Timeout Disable

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6635SmbTimeoutType SMBTimeoutDisable { get; set; }
Public Property SMBTimeoutDisable As Max6635SmbTimeoutType
    Get
    Set
public:
property Max6635SmbTimeoutType SMBTimeoutDisable {
    Max6635SmbTimeoutType get ();
    void set (Max6635SmbTimeoutType value);
}
member SMBTimeoutDisable : Max6635SmbTimeoutType with get, set

Property Value

Type: Max6635SmbTimeoutType
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635.Temperature Property

IRD

Max6635Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635.TemperatureHysteresisTHYST Property

IRD

Max6635TemperatureHysteresisTHYST Property

Temperature Hysteresis (T_HYST) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short TemperatureHysteresisTHYST { get; set; }
Public Property TemperatureHysteresisTHYST As Short
    Get
    Set
public:
property short TemperatureHysteresisTHYST {
    short get ();
    void set (short value);
}
member TemperatureHysteresisTHYST : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635 Methods

The Max6635 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635.Flush Method

IRD

Max6635Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max6635 Class
telos.Ird.Maxim Namespace


Max6635.AlertType Enumeration

IRD

Max6635AlertType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlertType
Public Enumeration AlertType
public enum class AlertType
type AlertType
Members
Member name | Value | Description
ActiveLowPolarity | 0 | Active Low Polarity
ActiveHighPolarity | 1 | Active High Polarity
See Also

Reference

telos.Ird.Maxim Namespace


Max6635.CompIntType Enumeration

IRD

Max6635CompIntType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CompIntType
Public Enumeration CompIntType
public enum class CompIntType
type CompIntType
Members
Member name | Value | Description
ComparatorMode | 0 | Comparator Mode
InterruptMode | 1 | Interrupt Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max6635.FaultQueueType Enumeration

IRD

Max6635FaultQueueType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultQueueType
Public Enumeration FaultQueueType
public enum class FaultQueueType
type FaultQueueType
Members
Member name | Value | Description
NumberOfFaults1 | 0 | Number Of Faults: 1
NumberOfFaults4 | 1 | Number Of Faults: 4
See Also

Reference

telos.Ird.Maxim Namespace


Max6635.OverTType Enumeration

IRD

Max6635OverTType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum OverTType
Public Enumeration OverTType
public enum class OverTType
type OverTType
Members
Member name | Value | Description
ActiveLowPolarity | 0 | Active Low Polarity
ActiveHighPolarity | 1 | Active High Polarity
See Also

Reference

telos.Ird.Maxim Namespace


Max6635.ShutdownType Enumeration

IRD

Max6635ShutdownType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ShutdownType
Public Enumeration ShutdownType
public enum class ShutdownType
type ShutdownType
Members
Member name | Value | Description
NormalOperation | 0 | Normal Operation
Shutdown | 1 | Shutdown
See Also

Reference

telos.Ird.Maxim Namespace


Max6635.SmbTimeoutType Enumeration

IRD

Max6635SmbTimeoutType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SmbTimeoutType
Public Enumeration SmbTimeoutType
public enum class SmbTimeoutType
type SmbTimeoutType
Members
Member name | Value | Description
NormalSMBusOperation | 0 | Normal SMBus Operation
FullI2CCompatibility | 1 | Full I2C Compatibility
See Also

Reference

telos.Ird.Maxim Namespace


Max6635.TFlagType Enumeration

IRD

Max6635TFlagType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TFlagType
Public Enumeration TFlagType
public enum class TFlagType
type TFlagType
Members
Member name | Value | Description
TempWarningFlagNotSet | 0 | Temp Warning Flag Not Set
TempWarningFlagSet | 1 | Temp Warning Flag Set
See Also

Reference

telos.Ird.Maxim Namespace


Max6646 Class

Maxim: MAX 6646
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax6646

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max6646
Public Class Max6646
public ref class Max6646
type Max6646 =  class end

The Max6646 type exposes the following members.

Constructors
 | Name | Description
Public method | Max6646 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BusyFlagBUSY | Busy Flag (BUSY)
Public property | ConversionRateControl | Conversion Rate Control (unit: Hz)
Public property | ExternalOVERTExceedingIOT | External OVERT Exceeding (IOT)
Public property | FaultConditionForDXNAndDXPFAULT | Fault Condition for DXN And DXP (FAULT)
Public property | FaultQueueFQx | Fault Queue (FQx)
Public property | InternalOVERTExceedingIOT | Internal OVERT Exceeding (IOT)
Public property | LocalHighTemperatureAlarmLHIGH | Local High Temperature Alarm (LHIGH)
Public property | LocalInternalALERTHighLimitRLHNWLHO | Local Internal ALERT High Limit (RLHN/WLHO) (unit: °C)
Public property | LocalInternalALERTLowLimitRLLIWLLM | Local Internal ALERT Low Limit (RLLI/WLLM) (unit: °C)
Public property | LocalInternalOVERTLimitRWOI | Local Internal OVERT Limit (RWOI) (unit: °C)
Public property | LocalInternalTemperatureRLTS | Local Internal Temperature (RLTS) (unit: °C)
Public property | LocalLowTemperatureAlarmLLOW | Local Low Temperature Alarm (LLOW)
Public property | ManufactureID | Manufacture ID
Public property | MaskAlertInterruptMASK | Mask Alert Interrupt (MASK)
Public property | OvertemperatureHysteresisHYS | Overtemperature Hysteresis (HYS) (unit: °C)
Public property | RemoteExternalALERTHighLimitRRHIWRHA | Remote External ALERT High Limit (RRHI/WRHA) (unit: °C)
Public property | RemoteExternalALERTLowLimitRRLSWRLN | Remote External ALERT Low Limit (RRLS/WRLN) (unit: °C)
Public property | RemoteExternalExtendedTemperatureREET | Remote External Extended Temperature (REET) (unit: °C)
Public property | RemoteExternalOVERTLimitRWOE | Remote External OVERT Limit (RWOE) (unit: °C)
Public property | RemoteExternalTemperatureRRTE | Remote External Temperature (RRTE) (unit: °C)
Public property | RemoteHighTemperatureAlarmRHIGH | Remote High Temperature Alarm (RHIGH)
Public property | RemoteInternalExtendedTemperatureRIET | Remote Internal Extended Temperature (RIET) (unit: °C)
Public property | RemoteLowTemperatureAlarmRLOW | Remote Low Temperature Alarm (RLOW)
Public property | RevisionID | Revision ID
Public property | StandByModeControlRUN | Stand By Mode Control (RUN)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShotOSHT | One Shot (OSHT)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Precision Remote/Local Sensor With Overtemperature Alarms
See Also

Reference

telos.Ird.Maxim Namespace


Max6646 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6646(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max6646(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max6646

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646 Properties

The Max6646 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BusyFlagBUSY | Busy Flag (BUSY)
Public property | ConversionRateControl | Conversion Rate Control (unit: Hz)
Public property | ExternalOVERTExceedingIOT | External OVERT Exceeding (IOT)
Public property | FaultConditionForDXNAndDXPFAULT | Fault Condition for DXN And DXP (FAULT)
Public property | FaultQueueFQx | Fault Queue (FQx)
Public property | InternalOVERTExceedingIOT | Internal OVERT Exceeding (IOT)
Public property | LocalHighTemperatureAlarmLHIGH | Local High Temperature Alarm (LHIGH)
Public property | LocalInternalALERTHighLimitRLHNWLHO | Local Internal ALERT High Limit (RLHN/WLHO) (unit: °C)
Public property | LocalInternalALERTLowLimitRLLIWLLM | Local Internal ALERT Low Limit (RLLI/WLLM) (unit: °C)
Public property | LocalInternalOVERTLimitRWOI | Local Internal OVERT Limit (RWOI) (unit: °C)
Public property | LocalInternalTemperatureRLTS | Local Internal Temperature (RLTS) (unit: °C)
Public property | LocalLowTemperatureAlarmLLOW | Local Low Temperature Alarm (LLOW)
Public property | ManufactureID | Manufacture ID
Public property | MaskAlertInterruptMASK | Mask Alert Interrupt (MASK)
Public property | OvertemperatureHysteresisHYS | Overtemperature Hysteresis (HYS) (unit: °C)
Public property | RemoteExternalALERTHighLimitRRHIWRHA | Remote External ALERT High Limit (RRHI/WRHA) (unit: °C)
Public property | RemoteExternalALERTLowLimitRRLSWRLN | Remote External ALERT Low Limit (RRLS/WRLN) (unit: °C)
Public property | RemoteExternalExtendedTemperatureREET | Remote External Extended Temperature (REET) (unit: °C)
Public property | RemoteExternalOVERTLimitRWOE | Remote External OVERT Limit (RWOE) (unit: °C)
Public property | RemoteExternalTemperatureRRTE | Remote External Temperature (RRTE) (unit: °C)
Public property | RemoteHighTemperatureAlarmRHIGH | Remote High Temperature Alarm (RHIGH)
Public property | RemoteInternalExtendedTemperatureRIET | Remote Internal Extended Temperature (RIET) (unit: °C)
Public property | RemoteLowTemperatureAlarmRLOW | Remote Low Temperature Alarm (RLOW)
Public property | RevisionID | Revision ID
Public property | StandByModeControlRUN | Stand By Mode Control (RUN)
Top
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.AutoFlush Property

IRD

Max6646AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.BusyFlagBUSY Property

IRD

Max6646BusyFlagBUSY Property

Busy Flag (BUSY)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6646BusyType BusyFlagBUSY { get; }
Public ReadOnly Property BusyFlagBUSY As Max6646BusyType
    Get
public:
property Max6646BusyType BusyFlagBUSY {
    Max6646BusyType get ();
}
member BusyFlagBUSY : Max6646BusyType with get

Property Value

Type: Max6646BusyType
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.ConversionRateControl Property

IRD

Max6646ConversionRateControl Property

Conversion Rate Control (unit: Hz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6646ConversionRateType ConversionRateControl { get; set; }
Public Property ConversionRateControl As Max6646ConversionRateType
    Get
    Set
public:
property Max6646ConversionRateType ConversionRateControl {
    Max6646ConversionRateType get ();
    void set (Max6646ConversionRateType value);
}
member ConversionRateControl : Max6646ConversionRateType with get, set

Property Value

Type: Max6646ConversionRateType
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.ExternalOVERTExceedingIOT Property

IRD

Max6646ExternalOVERTExceedingIOT Property

External OVERT Exceeding (IOT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6646EotType ExternalOVERTExceedingIOT { get; }
Public ReadOnly Property ExternalOVERTExceedingIOT As Max6646EotType
    Get
public:
property Max6646EotType ExternalOVERTExceedingIOT {
    Max6646EotType get ();
}
member ExternalOVERTExceedingIOT : Max6646EotType with get

Property Value

Type: Max6646EotType
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.FaultConditionForDXNAndDXPFAULT Property

IRD

Max6646FaultConditionForDXNAndDXPFAULT Property

Fault Condition for DXN And DXP (FAULT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6646FaultType FaultConditionForDXNAndDXPFAULT { get; }
Public ReadOnly Property FaultConditionForDXNAndDXPFAULT As Max6646FaultType
    Get
public:
property Max6646FaultType FaultConditionForDXNAndDXPFAULT {
    Max6646FaultType get ();
}
member FaultConditionForDXNAndDXPFAULT : Max6646FaultType with get

Property Value

Type: Max6646FaultType
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.FaultQueueFQx Property

IRD

Max6646FaultQueueFQx Property

Fault Queue (FQx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6646FaultQueueType FaultQueueFQx { get; set; }
Public Property FaultQueueFQx As Max6646FaultQueueType
    Get
    Set
public:
property Max6646FaultQueueType FaultQueueFQx {
    Max6646FaultQueueType get ();
    void set (Max6646FaultQueueType value);
}
member FaultQueueFQx : Max6646FaultQueueType with get, set

Property Value

Type: Max6646FaultQueueType
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.InternalOVERTExceedingIOT Property

IRD

Max6646InternalOVERTExceedingIOT Property

Internal OVERT Exceeding (IOT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6646IotType InternalOVERTExceedingIOT { get; }
Public ReadOnly Property InternalOVERTExceedingIOT As Max6646IotType
    Get
public:
property Max6646IotType InternalOVERTExceedingIOT {
    Max6646IotType get ();
}
member InternalOVERTExceedingIOT : Max6646IotType with get

Property Value

Type: Max6646IotType
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.LocalHighTemperatureAlarmLHIGH Property

IRD

Max6646LocalHighTemperatureAlarmLHIGH Property

Local High Temperature Alarm (LHIGH)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6646LhighType LocalHighTemperatureAlarmLHIGH { get; }
Public ReadOnly Property LocalHighTemperatureAlarmLHIGH As Max6646LhighType
    Get
public:
property Max6646LhighType LocalHighTemperatureAlarmLHIGH {
    Max6646LhighType get ();
}
member LocalHighTemperatureAlarmLHIGH : Max6646LhighType with get

Property Value

Type: Max6646LhighType
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.LocalInternalALERTHighLimitRLHNWLHO Property

IRD

Max6646LocalInternalALERTHighLimitRLHNWLHO Property

Local Internal ALERT High Limit (RLHN/WLHO) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalInternalALERTHighLimitRLHNWLHO { get; set; }
Public Property LocalInternalALERTHighLimitRLHNWLHO As Byte
    Get
    Set
public:
property unsigned char LocalInternalALERTHighLimitRLHNWLHO {
    unsigned char get ();
    void set (unsigned char value);
}
member LocalInternalALERTHighLimitRLHNWLHO : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.LocalInternalALERTLowLimitRLLIWLLM Property

IRD

Max6646LocalInternalALERTLowLimitRLLIWLLM Property

Local Internal ALERT Low Limit (RLLI/WLLM) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalInternalALERTLowLimitRLLIWLLM { get; set; }
Public Property LocalInternalALERTLowLimitRLLIWLLM As Byte
    Get
    Set
public:
property unsigned char LocalInternalALERTLowLimitRLLIWLLM {
    unsigned char get ();
    void set (unsigned char value);
}
member LocalInternalALERTLowLimitRLLIWLLM : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.LocalInternalOVERTLimitRWOI Property

IRD

Max6646LocalInternalOVERTLimitRWOI Property

Local Internal OVERT Limit (RWOI) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalInternalOVERTLimitRWOI { get; set; }
Public Property LocalInternalOVERTLimitRWOI As Byte
    Get
    Set
public:
property unsigned char LocalInternalOVERTLimitRWOI {
    unsigned char get ();
    void set (unsigned char value);
}
member LocalInternalOVERTLimitRWOI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.LocalInternalTemperatureRLTS Property

IRD

Max6646LocalInternalTemperatureRLTS Property

Local Internal Temperature (RLTS) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalInternalTemperatureRLTS { get; }
Public ReadOnly Property LocalInternalTemperatureRLTS As Byte
    Get
public:
property unsigned char LocalInternalTemperatureRLTS {
    unsigned char get ();
}
member LocalInternalTemperatureRLTS : byte with get

Property Value

Type: Byte
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.LocalLowTemperatureAlarmLLOW Property

IRD

Max6646LocalLowTemperatureAlarmLLOW Property

Local Low Temperature Alarm (LLOW)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6646LlowType LocalLowTemperatureAlarmLLOW { get; }
Public ReadOnly Property LocalLowTemperatureAlarmLLOW As Max6646LlowType
    Get
public:
property Max6646LlowType LocalLowTemperatureAlarmLLOW {
    Max6646LlowType get ();
}
member LocalLowTemperatureAlarmLLOW : Max6646LlowType with get

Property Value

Type: Max6646LlowType
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.ManufactureID Property

IRD

Max6646ManufactureID Property

Manufacture ID

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufactureID { get; }
Public ReadOnly Property ManufactureID As Byte
    Get
public:
property unsigned char ManufactureID {
    unsigned char get ();
}
member ManufactureID : byte with get

Property Value

Type: Byte
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.MaskAlertInterruptMASK Property

IRD

Max6646MaskAlertInterruptMASK Property

Mask Alert Interrupt (MASK)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6646MaskType MaskAlertInterruptMASK { get; set; }
Public Property MaskAlertInterruptMASK As Max6646MaskType
    Get
    Set
public:
property Max6646MaskType MaskAlertInterruptMASK {
    Max6646MaskType get ();
    void set (Max6646MaskType value);
}
member MaskAlertInterruptMASK : Max6646MaskType with get, set

Property Value

Type: Max6646MaskType
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.OvertemperatureHysteresisHYS Property

IRD

Max6646OvertemperatureHysteresisHYS Property

Overtemperature Hysteresis (HYS) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OvertemperatureHysteresisHYS { get; set; }
Public Property OvertemperatureHysteresisHYS As Byte
    Get
    Set
public:
property unsigned char OvertemperatureHysteresisHYS {
    unsigned char get ();
    void set (unsigned char value);
}
member OvertemperatureHysteresisHYS : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.RemoteExternalALERTHighLimitRRHIWRHA Property

IRD

Max6646RemoteExternalALERTHighLimitRRHIWRHA Property

Remote External ALERT High Limit (RRHI/WRHA) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RemoteExternalALERTHighLimitRRHIWRHA { get; set; }
Public Property RemoteExternalALERTHighLimitRRHIWRHA As Byte
    Get
    Set
public:
property unsigned char RemoteExternalALERTHighLimitRRHIWRHA {
    unsigned char get ();
    void set (unsigned char value);
}
member RemoteExternalALERTHighLimitRRHIWRHA : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.RemoteExternalALERTLowLimitRRLSWRLN Property

IRD

Max6646RemoteExternalALERTLowLimitRRLSWRLN Property

Remote External ALERT Low Limit (RRLS/WRLN) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RemoteExternalALERTLowLimitRRLSWRLN { get; set; }
Public Property RemoteExternalALERTLowLimitRRLSWRLN As Byte
    Get
    Set
public:
property unsigned char RemoteExternalALERTLowLimitRRLSWRLN {
    unsigned char get ();
    void set (unsigned char value);
}
member RemoteExternalALERTLowLimitRRLSWRLN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.RemoteExternalExtendedTemperatureREET Property

IRD

Max6646RemoteExternalExtendedTemperatureREET Property

Remote External Extended Temperature (REET) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6646TempExType RemoteExternalExtendedTemperatureREET { get; }
Public ReadOnly Property RemoteExternalExtendedTemperatureREET As Max6646TempExType
    Get
public:
property Max6646TempExType RemoteExternalExtendedTemperatureREET {
    Max6646TempExType get ();
}
member RemoteExternalExtendedTemperatureREET : Max6646TempExType with get

Property Value

Type: Max6646TempExType
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.RemoteExternalOVERTLimitRWOE Property

IRD

Max6646RemoteExternalOVERTLimitRWOE Property

Remote External OVERT Limit (RWOE) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RemoteExternalOVERTLimitRWOE { get; set; }
Public Property RemoteExternalOVERTLimitRWOE As Byte
    Get
    Set
public:
property unsigned char RemoteExternalOVERTLimitRWOE {
    unsigned char get ();
    void set (unsigned char value);
}
member RemoteExternalOVERTLimitRWOE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.RemoteExternalTemperatureRRTE Property

IRD

Max6646RemoteExternalTemperatureRRTE Property

Remote External Temperature (RRTE) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RemoteExternalTemperatureRRTE { get; }
Public ReadOnly Property RemoteExternalTemperatureRRTE As Byte
    Get
public:
property unsigned char RemoteExternalTemperatureRRTE {
    unsigned char get ();
}
member RemoteExternalTemperatureRRTE : byte with get

Property Value

Type: Byte
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.RemoteHighTemperatureAlarmRHIGH Property

IRD

Max6646RemoteHighTemperatureAlarmRHIGH Property

Remote High Temperature Alarm (RHIGH)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6646RhighType RemoteHighTemperatureAlarmRHIGH { get; }
Public ReadOnly Property RemoteHighTemperatureAlarmRHIGH As Max6646RhighType
    Get
public:
property Max6646RhighType RemoteHighTemperatureAlarmRHIGH {
    Max6646RhighType get ();
}
member RemoteHighTemperatureAlarmRHIGH : Max6646RhighType with get

Property Value

Type: Max6646RhighType
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.RemoteInternalExtendedTemperatureRIET Property

IRD

Max6646RemoteInternalExtendedTemperatureRIET Property

Remote Internal Extended Temperature (RIET) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6646TempExType RemoteInternalExtendedTemperatureRIET { get; }
Public ReadOnly Property RemoteInternalExtendedTemperatureRIET As Max6646TempExType
    Get
public:
property Max6646TempExType RemoteInternalExtendedTemperatureRIET {
    Max6646TempExType get ();
}
member RemoteInternalExtendedTemperatureRIET : Max6646TempExType with get

Property Value

Type: Max6646TempExType
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.RemoteLowTemperatureAlarmRLOW Property

IRD

Max6646RemoteLowTemperatureAlarmRLOW Property

Remote Low Temperature Alarm (RLOW)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6646RlowType RemoteLowTemperatureAlarmRLOW { get; }
Public ReadOnly Property RemoteLowTemperatureAlarmRLOW As Max6646RlowType
    Get
public:
property Max6646RlowType RemoteLowTemperatureAlarmRLOW {
    Max6646RlowType get ();
}
member RemoteLowTemperatureAlarmRLOW : Max6646RlowType with get

Property Value

Type: Max6646RlowType
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.RevisionID Property

IRD

Max6646RevisionID Property

Revision ID

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionID { get; }
Public ReadOnly Property RevisionID As Byte
    Get
public:
property unsigned char RevisionID {
    unsigned char get ();
}
member RevisionID : byte with get

Property Value

Type: Byte
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.StandByModeControlRUN Property

IRD

Max6646StandByModeControlRUN Property

Stand By Mode Control (RUN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6646RunType StandByModeControlRUN { get; set; }
Public Property StandByModeControlRUN As Max6646RunType
    Get
    Set
public:
property Max6646RunType StandByModeControlRUN {
    Max6646RunType get ();
    void set (Max6646RunType value);
}
member StandByModeControlRUN : Max6646RunType with get, set

Property Value

Type: Max6646RunType
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646 Methods

The Max6646 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShotOSHT | One Shot (OSHT)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.Flush Method

IRD

Max6646Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.OneShotOSHT Method

IRD

Max6646OneShotOSHT Method

One Shot (OSHT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void OneShotOSHT()
Public Sub OneShotOSHT
public:
void OneShotOSHT()
member OneShotOSHT : unit -> unit
See Also

Reference

Max6646 Class
telos.Ird.Maxim Namespace


Max6646.BusyType Enumeration

IRD

Max6646BusyType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum BusyType
Public Enumeration BusyType
public enum class BusyType
type BusyType
Members
Member name | Value | Description
ADNotBusy | 0 | A/D Not Busy
ADBusy | 1 | A/D Busy
See Also

Reference

telos.Ird.Maxim Namespace


Max6646.ConversionRateType Enumeration

IRD

Max6646ConversionRateType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConversionRateType
Public Enumeration ConversionRateType
public enum class ConversionRateType
type ConversionRateType
Members
Member name | Value | Description
ConversionRate00625 | 0 | Conversion Rate: 0.0625
ConversionRate0125 | 1 | Conversion Rate: 0.125
ConversionRate025 | 2 | Conversion Rate: 0.25
ConversionRate05 | 3 | Conversion Rate: 0.5
ConversionRate1 | 4 | Conversion Rate: 1
ConversionRate2 | 5 | Conversion Rate: 2
ConversionRate4 | 6 | Conversion Rate: 4
ConversionRate4__1 | 7 | Conversion Rate: 4
See Also

Reference

telos.Ird.Maxim Namespace


Max6646.EotType Enumeration

IRD

Max6646EotType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum EotType
Public Enumeration EotType
public enum class EotType
type EotType
Members
Member name | Value | Description
RemoteExternalTemperatureExceedsExternalOVERTFalse | 0 | Remote External Temperature Exceeds External OVERT: False
RemoteExternalTemperatureExceedsExternalOVERTTrue | 1 | Remote External Temperature Exceeds External OVERT: True
See Also

Reference

telos.Ird.Maxim Namespace


Max6646.FaultQueueType Enumeration

IRD

Max6646FaultQueueType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultQueueType
Public Enumeration FaultQueueType
public enum class FaultQueueType
type FaultQueueType
Members
Member name | Value | Description
FaultQueueLength1 | 0 | Fault Queue Length: 1
FaultQueueLength2 | 1 | Fault Queue Length: 2
FaultQueueLength1__1 | 2 | Fault Queue Length: 1
FaultQueueLength3 | 3 | Fault Queue Length: 3
See Also

Reference

telos.Ird.Maxim Namespace


Max6646.FaultType Enumeration

IRD

Max6646FaultType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultType
Public Enumeration FaultType
public enum class FaultType
type FaultType
Members
Member name | Value | Description
DXNAndDXPPinAreEitherShortedOrOpenFalse | 0 | DXN And DXP Pin Are Either Shorted Or Open: False
DXNAndDXPPinAreEitherShortedOrOpenTrue | 1 | DXN And DXP Pin Are Either Shorted Or Open: True
See Also

Reference

telos.Ird.Maxim Namespace


Max6646.IotType Enumeration

IRD

Max6646IotType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IotType
Public Enumeration IotType
public enum class IotType
type IotType
Members
Member name | Value | Description
LocalInternalTemperatureExceedsInternalOVERTFalse | 0 | Local Internal Temperature Exceeds Internal OVERT: False
LocalInternalTemperatureExceedsInternalOVERTTrue | 1 | Local Internal Temperature Exceeds Internal OVERT: True
See Also

Reference

telos.Ird.Maxim Namespace


Max6646.LhighType Enumeration

IRD

Max6646LhighType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum LhighType
Public Enumeration LhighType
public enum class LhighType
type LhighType
Members
Member name | Value | Description
NoLocalInternalHighTemperatureAlarm | 0 | No Local Internal High-Temperature Alarm
LocalInternalHighTemperatureAlarm | 1 | Local Internal High-Temperature Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Max6646.LlowType Enumeration

IRD

Max6646LlowType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum LlowType
Public Enumeration LlowType
public enum class LlowType
type LlowType
Members
Member name | Value | Description
NoLocalInternalLowTemperatureAlarm | 0 | No Local Internal Low-Temperature Alarm
LocalInternalLowTemperatureAlarm | 1 | Local Internal Low-Temperature Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Max6646.MaskType Enumeration

IRD

Max6646MaskType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum MaskType
Public Enumeration MaskType
public enum class MaskType
type MaskType
Members
Member name | Value | Description
AlertInterruptDisable | 0 | Alert Interrupt Disable
AlertInterruptEnable | 1 | Alert Interrupt Enable
See Also

Reference

telos.Ird.Maxim Namespace


Max6646.RhighType Enumeration

IRD

Max6646RhighType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum RhighType
Public Enumeration RhighType
public enum class RhighType
type RhighType
Members
Member name | Value | Description
NoRemoteExternalHighTemperatureAlarm | 0 | No Remote External High-Temperature Alarm
RemoteExternalHighTemperatureAlarm | 1 | Remote External High-Temperature Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Max6646.RlowType Enumeration

IRD

Max6646RlowType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum RlowType
Public Enumeration RlowType
public enum class RlowType
type RlowType
Members
Member name | Value | Description
NoRemoteExternalLowTemperatureAlarm | 0 | No Remote External Low-Temperature Alarm
RemoteExternalLowTemperatureAlarm | 1 | Remote External Low-Temperature Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Max6646.RunType Enumeration

IRD

Max6646RunType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum RunType
Public Enumeration RunType
public enum class RunType
type RunType
Members
Member name | Value | Description
StandByModeNotInitiated | 0 | Stand By Mode Not Initiated
StandByModeInitiated | 1 | Stand By Mode Initiated
See Also

Reference

telos.Ird.Maxim Namespace


Max6646.TempExType Enumeration

IRD

Max6646TempExType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TempExType
Public Enumeration TempExType
public enum class TempExType
type TempExType
Members
Member name | Value | Description
FractionalTeperature0000 | 0 | Fractional Teperature: 0.000
FractionalTeperature0125 | 1 | Fractional Teperature: 0.125
FractionalTeperature0250 | 2 | Fractional Teperature: 0.250
FractionalTeperature0375 | 3 | Fractional Teperature: 0.375
FractionalTeperature0500 | 4 | Fractional Teperature: 0.500
FractionalTeperature0625 | 5 | Fractional Teperature: 0.625
FractionalTeperature0750 | 6 | Fractional Teperature: 0.750
FractionalTeperature0875 | 7 | Fractional Teperature: 0.875
See Also

Reference

telos.Ird.Maxim Namespace


Max6647 Class

Maxim: MAX 6647
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax6647

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max6647
Public Class Max6647
public ref class Max6647
type Max6647 =  class end

The Max6647 type exposes the following members.

Constructors
 | Name | Description
Public method | Max6647 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BusyFlagBUSY | Busy Flag (BUSY)
Public property | ConversionRateControl | Conversion Rate Control (unit: Hz)
Public property | ExternalOVERTExceedingIOT | External OVERT Exceeding (IOT)
Public property | FaultConditionForDXNAndDXPFAULT | Fault Condition for DXN And DXP (FAULT)
Public property | FaultQueueFQx | Fault Queue (FQx)
Public property | InternalOVERTExceedingIOT | Internal OVERT Exceeding (IOT)
Public property | LocalHighTemperatureAlarmLHIGH | Local High Temperature Alarm (LHIGH)
Public property | LocalInternalALERTHighLimitRLHNWLHO | Local Internal ALERT High Limit (RLHN/WLHO) (unit: °C)
Public property | LocalInternalALERTLowLimitRLLIWLLM | Local Internal ALERT Low Limit (RLLI/WLLM) (unit: °C)
Public property | LocalInternalOVERTLimitRWOI | Local Internal OVERT Limit (RWOI) (unit: °C)
Public property | LocalInternalTemperatureRLTS | Local Internal Temperature (RLTS) (unit: °C)
Public property | LocalLowTemperatureAlarmLLOW | Local Low Temperature Alarm (LLOW)
Public property | ManufactureID | Manufacture ID
Public property | MaskAlertInterruptMASK | Mask Alert Interrupt (MASK)
Public property | OvertemperatureHysteresisHYS | Overtemperature Hysteresis (HYS) (unit: °C)
Public property | RemoteExternalALERTHighLimitRRHIWRHA | Remote External ALERT High Limit (RRHI/WRHA) (unit: °C)
Public property | RemoteExternalALERTLowLimitRRLSWRLN | Remote External ALERT Low Limit (RRLS/WRLN) (unit: °C)
Public property | RemoteExternalExtendedTemperatureREET | Remote External Extended Temperature (REET) (unit: °C)
Public property | RemoteExternalOVERTLimitRWOE | Remote External OVERT Limit (RWOE) (unit: °C)
Public property | RemoteExternalTemperatureRRTE | Remote External Temperature (RRTE) (unit: °C)
Public property | RemoteHighTemperatureAlarmRHIGH | Remote High Temperature Alarm (RHIGH)
Public property | RemoteInternalExtendedTemperatureRIET | Remote Internal Extended Temperature (RIET) (unit: °C)
Public property | RemoteLowTemperatureAlarmRLOW | Remote Low Temperature Alarm (RLOW)
Public property | RevisionID | Revision ID
Public property | StandByModeControlRUN | Stand By Mode Control (RUN)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShotOSHT | One Shot (OSHT)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Precision Remote/Local Sensor With Overtemperature Alarms
See Also

Reference

telos.Ird.Maxim Namespace


Max6647 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6647(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max6647(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max6647

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647 Properties

The Max6647 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BusyFlagBUSY | Busy Flag (BUSY)
Public property | ConversionRateControl | Conversion Rate Control (unit: Hz)
Public property | ExternalOVERTExceedingIOT | External OVERT Exceeding (IOT)
Public property | FaultConditionForDXNAndDXPFAULT | Fault Condition for DXN And DXP (FAULT)
Public property | FaultQueueFQx | Fault Queue (FQx)
Public property | InternalOVERTExceedingIOT | Internal OVERT Exceeding (IOT)
Public property | LocalHighTemperatureAlarmLHIGH | Local High Temperature Alarm (LHIGH)
Public property | LocalInternalALERTHighLimitRLHNWLHO | Local Internal ALERT High Limit (RLHN/WLHO) (unit: °C)
Public property | LocalInternalALERTLowLimitRLLIWLLM | Local Internal ALERT Low Limit (RLLI/WLLM) (unit: °C)
Public property | LocalInternalOVERTLimitRWOI | Local Internal OVERT Limit (RWOI) (unit: °C)
Public property | LocalInternalTemperatureRLTS | Local Internal Temperature (RLTS) (unit: °C)
Public property | LocalLowTemperatureAlarmLLOW | Local Low Temperature Alarm (LLOW)
Public property | ManufactureID | Manufacture ID
Public property | MaskAlertInterruptMASK | Mask Alert Interrupt (MASK)
Public property | OvertemperatureHysteresisHYS | Overtemperature Hysteresis (HYS) (unit: °C)
Public property | RemoteExternalALERTHighLimitRRHIWRHA | Remote External ALERT High Limit (RRHI/WRHA) (unit: °C)
Public property | RemoteExternalALERTLowLimitRRLSWRLN | Remote External ALERT Low Limit (RRLS/WRLN) (unit: °C)
Public property | RemoteExternalExtendedTemperatureREET | Remote External Extended Temperature (REET) (unit: °C)
Public property | RemoteExternalOVERTLimitRWOE | Remote External OVERT Limit (RWOE) (unit: °C)
Public property | RemoteExternalTemperatureRRTE | Remote External Temperature (RRTE) (unit: °C)
Public property | RemoteHighTemperatureAlarmRHIGH | Remote High Temperature Alarm (RHIGH)
Public property | RemoteInternalExtendedTemperatureRIET | Remote Internal Extended Temperature (RIET) (unit: °C)
Public property | RemoteLowTemperatureAlarmRLOW | Remote Low Temperature Alarm (RLOW)
Public property | RevisionID | Revision ID
Public property | StandByModeControlRUN | Stand By Mode Control (RUN)
Top
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.AutoFlush Property

IRD

Max6647AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.BusyFlagBUSY Property

IRD

Max6647BusyFlagBUSY Property

Busy Flag (BUSY)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6647BusyType BusyFlagBUSY { get; }
Public ReadOnly Property BusyFlagBUSY As Max6647BusyType
    Get
public:
property Max6647BusyType BusyFlagBUSY {
    Max6647BusyType get ();
}
member BusyFlagBUSY : Max6647BusyType with get

Property Value

Type: Max6647BusyType
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.ConversionRateControl Property

IRD

Max6647ConversionRateControl Property

Conversion Rate Control (unit: Hz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6647ConversionRateType ConversionRateControl { get; set; }
Public Property ConversionRateControl As Max6647ConversionRateType
    Get
    Set
public:
property Max6647ConversionRateType ConversionRateControl {
    Max6647ConversionRateType get ();
    void set (Max6647ConversionRateType value);
}
member ConversionRateControl : Max6647ConversionRateType with get, set

Property Value

Type: Max6647ConversionRateType
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.ExternalOVERTExceedingIOT Property

IRD

Max6647ExternalOVERTExceedingIOT Property

External OVERT Exceeding (IOT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6647EotType ExternalOVERTExceedingIOT { get; }
Public ReadOnly Property ExternalOVERTExceedingIOT As Max6647EotType
    Get
public:
property Max6647EotType ExternalOVERTExceedingIOT {
    Max6647EotType get ();
}
member ExternalOVERTExceedingIOT : Max6647EotType with get

Property Value

Type: Max6647EotType
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.FaultConditionForDXNAndDXPFAULT Property

IRD

Max6647FaultConditionForDXNAndDXPFAULT Property

Fault Condition for DXN And DXP (FAULT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6647FaultType FaultConditionForDXNAndDXPFAULT { get; }
Public ReadOnly Property FaultConditionForDXNAndDXPFAULT As Max6647FaultType
    Get
public:
property Max6647FaultType FaultConditionForDXNAndDXPFAULT {
    Max6647FaultType get ();
}
member FaultConditionForDXNAndDXPFAULT : Max6647FaultType with get

Property Value

Type: Max6647FaultType
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.FaultQueueFQx Property

IRD

Max6647FaultQueueFQx Property

Fault Queue (FQx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6647FaultQueueType FaultQueueFQx { get; set; }
Public Property FaultQueueFQx As Max6647FaultQueueType
    Get
    Set
public:
property Max6647FaultQueueType FaultQueueFQx {
    Max6647FaultQueueType get ();
    void set (Max6647FaultQueueType value);
}
member FaultQueueFQx : Max6647FaultQueueType with get, set

Property Value

Type: Max6647FaultQueueType
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.InternalOVERTExceedingIOT Property

IRD

Max6647InternalOVERTExceedingIOT Property

Internal OVERT Exceeding (IOT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6647IotType InternalOVERTExceedingIOT { get; }
Public ReadOnly Property InternalOVERTExceedingIOT As Max6647IotType
    Get
public:
property Max6647IotType InternalOVERTExceedingIOT {
    Max6647IotType get ();
}
member InternalOVERTExceedingIOT : Max6647IotType with get

Property Value

Type: Max6647IotType
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.LocalHighTemperatureAlarmLHIGH Property

IRD

Max6647LocalHighTemperatureAlarmLHIGH Property

Local High Temperature Alarm (LHIGH)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6647LhighType LocalHighTemperatureAlarmLHIGH { get; }
Public ReadOnly Property LocalHighTemperatureAlarmLHIGH As Max6647LhighType
    Get
public:
property Max6647LhighType LocalHighTemperatureAlarmLHIGH {
    Max6647LhighType get ();
}
member LocalHighTemperatureAlarmLHIGH : Max6647LhighType with get

Property Value

Type: Max6647LhighType
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.LocalInternalALERTHighLimitRLHNWLHO Property

IRD

Max6647LocalInternalALERTHighLimitRLHNWLHO Property

Local Internal ALERT High Limit (RLHN/WLHO) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalInternalALERTHighLimitRLHNWLHO { get; set; }
Public Property LocalInternalALERTHighLimitRLHNWLHO As Byte
    Get
    Set
public:
property unsigned char LocalInternalALERTHighLimitRLHNWLHO {
    unsigned char get ();
    void set (unsigned char value);
}
member LocalInternalALERTHighLimitRLHNWLHO : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.LocalInternalALERTLowLimitRLLIWLLM Property

IRD

Max6647LocalInternalALERTLowLimitRLLIWLLM Property

Local Internal ALERT Low Limit (RLLI/WLLM) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalInternalALERTLowLimitRLLIWLLM { get; set; }
Public Property LocalInternalALERTLowLimitRLLIWLLM As Byte
    Get
    Set
public:
property unsigned char LocalInternalALERTLowLimitRLLIWLLM {
    unsigned char get ();
    void set (unsigned char value);
}
member LocalInternalALERTLowLimitRLLIWLLM : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.LocalInternalOVERTLimitRWOI Property

IRD

Max6647LocalInternalOVERTLimitRWOI Property

Local Internal OVERT Limit (RWOI) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalInternalOVERTLimitRWOI { get; set; }
Public Property LocalInternalOVERTLimitRWOI As Byte
    Get
    Set
public:
property unsigned char LocalInternalOVERTLimitRWOI {
    unsigned char get ();
    void set (unsigned char value);
}
member LocalInternalOVERTLimitRWOI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.LocalInternalTemperatureRLTS Property

IRD

Max6647LocalInternalTemperatureRLTS Property

Local Internal Temperature (RLTS) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalInternalTemperatureRLTS { get; }
Public ReadOnly Property LocalInternalTemperatureRLTS As Byte
    Get
public:
property unsigned char LocalInternalTemperatureRLTS {
    unsigned char get ();
}
member LocalInternalTemperatureRLTS : byte with get

Property Value

Type: Byte
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.LocalLowTemperatureAlarmLLOW Property

IRD

Max6647LocalLowTemperatureAlarmLLOW Property

Local Low Temperature Alarm (LLOW)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6647LlowType LocalLowTemperatureAlarmLLOW { get; }
Public ReadOnly Property LocalLowTemperatureAlarmLLOW As Max6647LlowType
    Get
public:
property Max6647LlowType LocalLowTemperatureAlarmLLOW {
    Max6647LlowType get ();
}
member LocalLowTemperatureAlarmLLOW : Max6647LlowType with get

Property Value

Type: Max6647LlowType
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.ManufactureID Property

IRD

Max6647ManufactureID Property

Manufacture ID

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufactureID { get; }
Public ReadOnly Property ManufactureID As Byte
    Get
public:
property unsigned char ManufactureID {
    unsigned char get ();
}
member ManufactureID : byte with get

Property Value

Type: Byte
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.MaskAlertInterruptMASK Property

IRD

Max6647MaskAlertInterruptMASK Property

Mask Alert Interrupt (MASK)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6647MaskType MaskAlertInterruptMASK { get; set; }
Public Property MaskAlertInterruptMASK As Max6647MaskType
    Get
    Set
public:
property Max6647MaskType MaskAlertInterruptMASK {
    Max6647MaskType get ();
    void set (Max6647MaskType value);
}
member MaskAlertInterruptMASK : Max6647MaskType with get, set

Property Value

Type: Max6647MaskType
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.OvertemperatureHysteresisHYS Property

IRD

Max6647OvertemperatureHysteresisHYS Property

Overtemperature Hysteresis (HYS) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OvertemperatureHysteresisHYS { get; set; }
Public Property OvertemperatureHysteresisHYS As Byte
    Get
    Set
public:
property unsigned char OvertemperatureHysteresisHYS {
    unsigned char get ();
    void set (unsigned char value);
}
member OvertemperatureHysteresisHYS : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.RemoteExternalALERTHighLimitRRHIWRHA Property

IRD

Max6647RemoteExternalALERTHighLimitRRHIWRHA Property

Remote External ALERT High Limit (RRHI/WRHA) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RemoteExternalALERTHighLimitRRHIWRHA { get; set; }
Public Property RemoteExternalALERTHighLimitRRHIWRHA As Byte
    Get
    Set
public:
property unsigned char RemoteExternalALERTHighLimitRRHIWRHA {
    unsigned char get ();
    void set (unsigned char value);
}
member RemoteExternalALERTHighLimitRRHIWRHA : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.RemoteExternalALERTLowLimitRRLSWRLN Property

IRD

Max6647RemoteExternalALERTLowLimitRRLSWRLN Property

Remote External ALERT Low Limit (RRLS/WRLN) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RemoteExternalALERTLowLimitRRLSWRLN { get; set; }
Public Property RemoteExternalALERTLowLimitRRLSWRLN As Byte
    Get
    Set
public:
property unsigned char RemoteExternalALERTLowLimitRRLSWRLN {
    unsigned char get ();
    void set (unsigned char value);
}
member RemoteExternalALERTLowLimitRRLSWRLN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.RemoteExternalExtendedTemperatureREET Property

IRD

Max6647RemoteExternalExtendedTemperatureREET Property

Remote External Extended Temperature (REET) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6647TempExType RemoteExternalExtendedTemperatureREET { get; }
Public ReadOnly Property RemoteExternalExtendedTemperatureREET As Max6647TempExType
    Get
public:
property Max6647TempExType RemoteExternalExtendedTemperatureREET {
    Max6647TempExType get ();
}
member RemoteExternalExtendedTemperatureREET : Max6647TempExType with get

Property Value

Type: Max6647TempExType
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.RemoteExternalOVERTLimitRWOE Property

IRD

Max6647RemoteExternalOVERTLimitRWOE Property

Remote External OVERT Limit (RWOE) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RemoteExternalOVERTLimitRWOE { get; set; }
Public Property RemoteExternalOVERTLimitRWOE As Byte
    Get
    Set
public:
property unsigned char RemoteExternalOVERTLimitRWOE {
    unsigned char get ();
    void set (unsigned char value);
}
member RemoteExternalOVERTLimitRWOE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.RemoteExternalTemperatureRRTE Property

IRD

Max6647RemoteExternalTemperatureRRTE Property

Remote External Temperature (RRTE) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RemoteExternalTemperatureRRTE { get; }
Public ReadOnly Property RemoteExternalTemperatureRRTE As Byte
    Get
public:
property unsigned char RemoteExternalTemperatureRRTE {
    unsigned char get ();
}
member RemoteExternalTemperatureRRTE : byte with get

Property Value

Type: Byte
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.RemoteHighTemperatureAlarmRHIGH Property

IRD

Max6647RemoteHighTemperatureAlarmRHIGH Property

Remote High Temperature Alarm (RHIGH)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6647RhighType RemoteHighTemperatureAlarmRHIGH { get; }
Public ReadOnly Property RemoteHighTemperatureAlarmRHIGH As Max6647RhighType
    Get
public:
property Max6647RhighType RemoteHighTemperatureAlarmRHIGH {
    Max6647RhighType get ();
}
member RemoteHighTemperatureAlarmRHIGH : Max6647RhighType with get

Property Value

Type: Max6647RhighType
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.RemoteInternalExtendedTemperatureRIET Property

IRD

Max6647RemoteInternalExtendedTemperatureRIET Property

Remote Internal Extended Temperature (RIET) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6647TempExType RemoteInternalExtendedTemperatureRIET { get; }
Public ReadOnly Property RemoteInternalExtendedTemperatureRIET As Max6647TempExType
    Get
public:
property Max6647TempExType RemoteInternalExtendedTemperatureRIET {
    Max6647TempExType get ();
}
member RemoteInternalExtendedTemperatureRIET : Max6647TempExType with get

Property Value

Type: Max6647TempExType
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.RemoteLowTemperatureAlarmRLOW Property

IRD

Max6647RemoteLowTemperatureAlarmRLOW Property

Remote Low Temperature Alarm (RLOW)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6647RlowType RemoteLowTemperatureAlarmRLOW { get; }
Public ReadOnly Property RemoteLowTemperatureAlarmRLOW As Max6647RlowType
    Get
public:
property Max6647RlowType RemoteLowTemperatureAlarmRLOW {
    Max6647RlowType get ();
}
member RemoteLowTemperatureAlarmRLOW : Max6647RlowType with get

Property Value

Type: Max6647RlowType
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.RevisionID Property

IRD

Max6647RevisionID Property

Revision ID

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionID { get; }
Public ReadOnly Property RevisionID As Byte
    Get
public:
property unsigned char RevisionID {
    unsigned char get ();
}
member RevisionID : byte with get

Property Value

Type: Byte
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.StandByModeControlRUN Property

IRD

Max6647StandByModeControlRUN Property

Stand By Mode Control (RUN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6647RunType StandByModeControlRUN { get; set; }
Public Property StandByModeControlRUN As Max6647RunType
    Get
    Set
public:
property Max6647RunType StandByModeControlRUN {
    Max6647RunType get ();
    void set (Max6647RunType value);
}
member StandByModeControlRUN : Max6647RunType with get, set

Property Value

Type: Max6647RunType
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647 Methods

The Max6647 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShotOSHT | One Shot (OSHT)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.Flush Method

IRD

Max6647Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.OneShotOSHT Method

IRD

Max6647OneShotOSHT Method

One Shot (OSHT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void OneShotOSHT()
Public Sub OneShotOSHT
public:
void OneShotOSHT()
member OneShotOSHT : unit -> unit
See Also

Reference

Max6647 Class
telos.Ird.Maxim Namespace


Max6647.BusyType Enumeration

IRD

Max6647BusyType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum BusyType
Public Enumeration BusyType
public enum class BusyType
type BusyType
Members
Member name | Value | Description
ADNotBusy | 0 | A/D Not Busy
ADBusy | 1 | A/D Busy
See Also

Reference

telos.Ird.Maxim Namespace


Max6647.ConversionRateType Enumeration

IRD

Max6647ConversionRateType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConversionRateType
Public Enumeration ConversionRateType
public enum class ConversionRateType
type ConversionRateType
Members
Member name | Value | Description
ConversionRate00625 | 0 | Conversion Rate: 0.0625
ConversionRate0125 | 1 | Conversion Rate: 0.125
ConversionRate025 | 2 | Conversion Rate: 0.25
ConversionRate05 | 3 | Conversion Rate: 0.5
ConversionRate1 | 4 | Conversion Rate: 1
ConversionRate2 | 5 | Conversion Rate: 2
ConversionRate4 | 6 | Conversion Rate: 4
ConversionRate4__1 | 7 | Conversion Rate: 4
See Also

Reference

telos.Ird.Maxim Namespace


Max6647.EotType Enumeration

IRD

Max6647EotType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum EotType
Public Enumeration EotType
public enum class EotType
type EotType
Members
Member name | Value | Description
RemoteExternalTemperatureExceedsExternalOVERTFalse | 0 | Remote External Temperature Exceeds External OVERT: False
RemoteExternalTemperatureExceedsExternalOVERTTrue | 1 | Remote External Temperature Exceeds External OVERT: True
See Also

Reference

telos.Ird.Maxim Namespace


Max6647.FaultQueueType Enumeration

IRD

Max6647FaultQueueType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultQueueType
Public Enumeration FaultQueueType
public enum class FaultQueueType
type FaultQueueType
Members
Member name | Value | Description
FaultQueueLength1 | 0 | Fault Queue Length: 1
FaultQueueLength2 | 1 | Fault Queue Length: 2
FaultQueueLength1__1 | 2 | Fault Queue Length: 1
FaultQueueLength3 | 3 | Fault Queue Length: 3
See Also

Reference

telos.Ird.Maxim Namespace


Max6647.FaultType Enumeration

IRD

Max6647FaultType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultType
Public Enumeration FaultType
public enum class FaultType
type FaultType
Members
Member name | Value | Description
DXNAndDXPPinAreEitherShortedOrOpenFalse | 0 | DXN And DXP Pin Are Either Shorted Or Open: False
DXNAndDXPPinAreEitherShortedOrOpenTrue | 1 | DXN And DXP Pin Are Either Shorted Or Open: True
See Also

Reference

telos.Ird.Maxim Namespace


Max6647.IotType Enumeration

IRD

Max6647IotType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IotType
Public Enumeration IotType
public enum class IotType
type IotType
Members
Member name | Value | Description
LocalInternalTemperatureExceedsInternalOVERTFalse | 0 | Local Internal Temperature Exceeds Internal OVERT: False
LocalInternalTemperatureExceedsInternalOVERTTrue | 1 | Local Internal Temperature Exceeds Internal OVERT: True
See Also

Reference

telos.Ird.Maxim Namespace


Max6647.LhighType Enumeration

IRD

Max6647LhighType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum LhighType
Public Enumeration LhighType
public enum class LhighType
type LhighType
Members
Member name | Value | Description
NoLocalInternalHighTemperatureAlarm | 0 | No Local Internal High-Temperature Alarm
LocalInternalHighTemperatureAlarm | 1 | Local Internal High-Temperature Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Max6647.LlowType Enumeration

IRD

Max6647LlowType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum LlowType
Public Enumeration LlowType
public enum class LlowType
type LlowType
Members
Member name | Value | Description
NoLocalInternalLowTemperatureAlarm | 0 | No Local Internal Low-Temperature Alarm
LocalInternalLowTemperatureAlarm | 1 | Local Internal Low-Temperature Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Max6647.MaskType Enumeration

IRD

Max6647MaskType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum MaskType
Public Enumeration MaskType
public enum class MaskType
type MaskType
Members
Member name | Value | Description
AlertInterruptDisable | 0 | Alert Interrupt Disable
AlertInterruptEnable | 1 | Alert Interrupt Enable
See Also

Reference

telos.Ird.Maxim Namespace


Max6647.RhighType Enumeration

IRD

Max6647RhighType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum RhighType
Public Enumeration RhighType
public enum class RhighType
type RhighType
Members
Member name | Value | Description
NoRemoteExternalHighTemperatureAlarm | 0 | No Remote External High-Temperature Alarm
RemoteExternalHighTemperatureAlarm | 1 | Remote External High-Temperature Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Max6647.RlowType Enumeration

IRD

Max6647RlowType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum RlowType
Public Enumeration RlowType
public enum class RlowType
type RlowType
Members
Member name | Value | Description
NoRemoteExternalLowTemperatureAlarm | 0 | No Remote External Low-Temperature Alarm
RemoteExternalLowTemperatureAlarm | 1 | Remote External Low-Temperature Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Max6647.RunType Enumeration

IRD

Max6647RunType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum RunType
Public Enumeration RunType
public enum class RunType
type RunType
Members
Member name | Value | Description
StandByModeNotInitiated | 0 | Stand By Mode Not Initiated
StandByModeInitiated | 1 | Stand By Mode Initiated
See Also

Reference

telos.Ird.Maxim Namespace


Max6647.TempExType Enumeration

IRD

Max6647TempExType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TempExType
Public Enumeration TempExType
public enum class TempExType
type TempExType
Members
Member name | Value | Description
FractionalTeperature0000 | 0 | Fractional Teperature: 0.000
FractionalTeperature0125 | 1 | Fractional Teperature: 0.125
FractionalTeperature0250 | 2 | Fractional Teperature: 0.250
FractionalTeperature0375 | 3 | Fractional Teperature: 0.375
FractionalTeperature0500 | 4 | Fractional Teperature: 0.500
FractionalTeperature0625 | 5 | Fractional Teperature: 0.625
FractionalTeperature0750 | 6 | Fractional Teperature: 0.750
FractionalTeperature0875 | 7 | Fractional Teperature: 0.875
See Also

Reference

telos.Ird.Maxim Namespace


Max6649 Class

Maxim: MAX 6649
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax6649

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max6649
Public Class Max6649
public ref class Max6649
type Max6649 =  class end

The Max6649 type exposes the following members.

Constructors
 | Name | Description
Public method | Max6649 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BusyFlagBUSY | Busy Flag (BUSY)
Public property | ConversionRateControl | Conversion Rate Control (unit: Hz)
Public property | ExternalOVERTExceedingIOT | External OVERT Exceeding (IOT)
Public property | FaultConditionForDXNAndDXPFAULT | Fault Condition for DXN And DXP (FAULT)
Public property | FaultQueueFQx | Fault Queue (FQx)
Public property | InternalOVERTExceedingIOT | Internal OVERT Exceeding (IOT)
Public property | LocalHighTemperatureAlarmLHIGH | Local High Temperature Alarm (LHIGH)
Public property | LocalInternalALERTHighLimitRLHNWLHO | Local Internal ALERT High Limit (RLHN/WLHO) (unit: °C)
Public property | LocalInternalALERTLowLimitRLLIWLLM | Local Internal ALERT Low Limit (RLLI/WLLM) (unit: °C)
Public property | LocalInternalOVERTLimitRWOI | Local Internal OVERT Limit (RWOI) (unit: °C)
Public property | LocalInternalTemperatureRLTS | Local Internal Temperature (RLTS) (unit: °C)
Public property | LocalLowTemperatureAlarmLLOW | Local Low Temperature Alarm (LLOW)
Public property | ManufactureID | Manufacture ID
Public property | MaskAlertInterruptMASK | Mask Alert Interrupt (MASK)
Public property | OvertemperatureHysteresisHYS | Overtemperature Hysteresis (HYS) (unit: °C)
Public property | RemoteExternalALERTHighLimitRRHIWRHA | Remote External ALERT High Limit (RRHI/WRHA) (unit: °C)
Public property | RemoteExternalALERTLowLimitRRLSWRLN | Remote External ALERT Low Limit (RRLS/WRLN) (unit: °C)
Public property | RemoteExternalExtendedTemperatureREET | Remote External Extended Temperature (REET) (unit: °C)
Public property | RemoteExternalOVERTLimitRWOE | Remote External OVERT Limit (RWOE) (unit: °C)
Public property | RemoteExternalTemperatureRRTE | Remote External Temperature (RRTE) (unit: °C)
Public property | RemoteHighTemperatureAlarmRHIGH | Remote High Temperature Alarm (RHIGH)
Public property | RemoteInternalExtendedTemperatureRIET | Remote Internal Extended Temperature (RIET) (unit: °C)
Public property | RemoteLowTemperatureAlarmRLOW | Remote Low Temperature Alarm (RLOW)
Public property | RevisionID | Revision ID
Public property | StandByModeControlRUN | Stand By Mode Control (RUN)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShotOSHT | One Shot (OSHT)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Precision Remote/Local Sensor With Overtemperature Alarms
See Also

Reference

telos.Ird.Maxim Namespace


Max6649 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6649(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max6649(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max6649

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649 Properties

The Max6649 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BusyFlagBUSY | Busy Flag (BUSY)
Public property | ConversionRateControl | Conversion Rate Control (unit: Hz)
Public property | ExternalOVERTExceedingIOT | External OVERT Exceeding (IOT)
Public property | FaultConditionForDXNAndDXPFAULT | Fault Condition for DXN And DXP (FAULT)
Public property | FaultQueueFQx | Fault Queue (FQx)
Public property | InternalOVERTExceedingIOT | Internal OVERT Exceeding (IOT)
Public property | LocalHighTemperatureAlarmLHIGH | Local High Temperature Alarm (LHIGH)
Public property | LocalInternalALERTHighLimitRLHNWLHO | Local Internal ALERT High Limit (RLHN/WLHO) (unit: °C)
Public property | LocalInternalALERTLowLimitRLLIWLLM | Local Internal ALERT Low Limit (RLLI/WLLM) (unit: °C)
Public property | LocalInternalOVERTLimitRWOI | Local Internal OVERT Limit (RWOI) (unit: °C)
Public property | LocalInternalTemperatureRLTS | Local Internal Temperature (RLTS) (unit: °C)
Public property | LocalLowTemperatureAlarmLLOW | Local Low Temperature Alarm (LLOW)
Public property | ManufactureID | Manufacture ID
Public property | MaskAlertInterruptMASK | Mask Alert Interrupt (MASK)
Public property | OvertemperatureHysteresisHYS | Overtemperature Hysteresis (HYS) (unit: °C)
Public property | RemoteExternalALERTHighLimitRRHIWRHA | Remote External ALERT High Limit (RRHI/WRHA) (unit: °C)
Public property | RemoteExternalALERTLowLimitRRLSWRLN | Remote External ALERT Low Limit (RRLS/WRLN) (unit: °C)
Public property | RemoteExternalExtendedTemperatureREET | Remote External Extended Temperature (REET) (unit: °C)
Public property | RemoteExternalOVERTLimitRWOE | Remote External OVERT Limit (RWOE) (unit: °C)
Public property | RemoteExternalTemperatureRRTE | Remote External Temperature (RRTE) (unit: °C)
Public property | RemoteHighTemperatureAlarmRHIGH | Remote High Temperature Alarm (RHIGH)
Public property | RemoteInternalExtendedTemperatureRIET | Remote Internal Extended Temperature (RIET) (unit: °C)
Public property | RemoteLowTemperatureAlarmRLOW | Remote Low Temperature Alarm (RLOW)
Public property | RevisionID | Revision ID
Public property | StandByModeControlRUN | Stand By Mode Control (RUN)
Top
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.AutoFlush Property

IRD

Max6649AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.BusyFlagBUSY Property

IRD

Max6649BusyFlagBUSY Property

Busy Flag (BUSY)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6649BusyType BusyFlagBUSY { get; }
Public ReadOnly Property BusyFlagBUSY As Max6649BusyType
    Get
public:
property Max6649BusyType BusyFlagBUSY {
    Max6649BusyType get ();
}
member BusyFlagBUSY : Max6649BusyType with get

Property Value

Type: Max6649BusyType
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.ConversionRateControl Property

IRD

Max6649ConversionRateControl Property

Conversion Rate Control (unit: Hz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6649ConversionRateType ConversionRateControl { get; set; }
Public Property ConversionRateControl As Max6649ConversionRateType
    Get
    Set
public:
property Max6649ConversionRateType ConversionRateControl {
    Max6649ConversionRateType get ();
    void set (Max6649ConversionRateType value);
}
member ConversionRateControl : Max6649ConversionRateType with get, set

Property Value

Type: Max6649ConversionRateType
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.ExternalOVERTExceedingIOT Property

IRD

Max6649ExternalOVERTExceedingIOT Property

External OVERT Exceeding (IOT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6649EotType ExternalOVERTExceedingIOT { get; }
Public ReadOnly Property ExternalOVERTExceedingIOT As Max6649EotType
    Get
public:
property Max6649EotType ExternalOVERTExceedingIOT {
    Max6649EotType get ();
}
member ExternalOVERTExceedingIOT : Max6649EotType with get

Property Value

Type: Max6649EotType
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.FaultConditionForDXNAndDXPFAULT Property

IRD

Max6649FaultConditionForDXNAndDXPFAULT Property

Fault Condition for DXN And DXP (FAULT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6649FaultType FaultConditionForDXNAndDXPFAULT { get; }
Public ReadOnly Property FaultConditionForDXNAndDXPFAULT As Max6649FaultType
    Get
public:
property Max6649FaultType FaultConditionForDXNAndDXPFAULT {
    Max6649FaultType get ();
}
member FaultConditionForDXNAndDXPFAULT : Max6649FaultType with get

Property Value

Type: Max6649FaultType
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.FaultQueueFQx Property

IRD

Max6649FaultQueueFQx Property

Fault Queue (FQx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6649FaultQueueType FaultQueueFQx { get; set; }
Public Property FaultQueueFQx As Max6649FaultQueueType
    Get
    Set
public:
property Max6649FaultQueueType FaultQueueFQx {
    Max6649FaultQueueType get ();
    void set (Max6649FaultQueueType value);
}
member FaultQueueFQx : Max6649FaultQueueType with get, set

Property Value

Type: Max6649FaultQueueType
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.InternalOVERTExceedingIOT Property

IRD

Max6649InternalOVERTExceedingIOT Property

Internal OVERT Exceeding (IOT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6649IotType InternalOVERTExceedingIOT { get; }
Public ReadOnly Property InternalOVERTExceedingIOT As Max6649IotType
    Get
public:
property Max6649IotType InternalOVERTExceedingIOT {
    Max6649IotType get ();
}
member InternalOVERTExceedingIOT : Max6649IotType with get

Property Value

Type: Max6649IotType
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.LocalHighTemperatureAlarmLHIGH Property

IRD

Max6649LocalHighTemperatureAlarmLHIGH Property

Local High Temperature Alarm (LHIGH)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6649LhighType LocalHighTemperatureAlarmLHIGH { get; }
Public ReadOnly Property LocalHighTemperatureAlarmLHIGH As Max6649LhighType
    Get
public:
property Max6649LhighType LocalHighTemperatureAlarmLHIGH {
    Max6649LhighType get ();
}
member LocalHighTemperatureAlarmLHIGH : Max6649LhighType with get

Property Value

Type: Max6649LhighType
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.LocalInternalALERTHighLimitRLHNWLHO Property

IRD

Max6649LocalInternalALERTHighLimitRLHNWLHO Property

Local Internal ALERT High Limit (RLHN/WLHO) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalInternalALERTHighLimitRLHNWLHO { get; set; }
Public Property LocalInternalALERTHighLimitRLHNWLHO As Byte
    Get
    Set
public:
property unsigned char LocalInternalALERTHighLimitRLHNWLHO {
    unsigned char get ();
    void set (unsigned char value);
}
member LocalInternalALERTHighLimitRLHNWLHO : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.LocalInternalALERTLowLimitRLLIWLLM Property

IRD

Max6649LocalInternalALERTLowLimitRLLIWLLM Property

Local Internal ALERT Low Limit (RLLI/WLLM) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalInternalALERTLowLimitRLLIWLLM { get; set; }
Public Property LocalInternalALERTLowLimitRLLIWLLM As Byte
    Get
    Set
public:
property unsigned char LocalInternalALERTLowLimitRLLIWLLM {
    unsigned char get ();
    void set (unsigned char value);
}
member LocalInternalALERTLowLimitRLLIWLLM : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.LocalInternalOVERTLimitRWOI Property

IRD

Max6649LocalInternalOVERTLimitRWOI Property

Local Internal OVERT Limit (RWOI) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalInternalOVERTLimitRWOI { get; set; }
Public Property LocalInternalOVERTLimitRWOI As Byte
    Get
    Set
public:
property unsigned char LocalInternalOVERTLimitRWOI {
    unsigned char get ();
    void set (unsigned char value);
}
member LocalInternalOVERTLimitRWOI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.LocalInternalTemperatureRLTS Property

IRD

Max6649LocalInternalTemperatureRLTS Property

Local Internal Temperature (RLTS) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalInternalTemperatureRLTS { get; }
Public ReadOnly Property LocalInternalTemperatureRLTS As Byte
    Get
public:
property unsigned char LocalInternalTemperatureRLTS {
    unsigned char get ();
}
member LocalInternalTemperatureRLTS : byte with get

Property Value

Type: Byte
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.LocalLowTemperatureAlarmLLOW Property

IRD

Max6649LocalLowTemperatureAlarmLLOW Property

Local Low Temperature Alarm (LLOW)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6649LlowType LocalLowTemperatureAlarmLLOW { get; }
Public ReadOnly Property LocalLowTemperatureAlarmLLOW As Max6649LlowType
    Get
public:
property Max6649LlowType LocalLowTemperatureAlarmLLOW {
    Max6649LlowType get ();
}
member LocalLowTemperatureAlarmLLOW : Max6649LlowType with get

Property Value

Type: Max6649LlowType
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.ManufactureID Property

IRD

Max6649ManufactureID Property

Manufacture ID

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufactureID { get; }
Public ReadOnly Property ManufactureID As Byte
    Get
public:
property unsigned char ManufactureID {
    unsigned char get ();
}
member ManufactureID : byte with get

Property Value

Type: Byte
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.MaskAlertInterruptMASK Property

IRD

Max6649MaskAlertInterruptMASK Property

Mask Alert Interrupt (MASK)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6649MaskType MaskAlertInterruptMASK { get; set; }
Public Property MaskAlertInterruptMASK As Max6649MaskType
    Get
    Set
public:
property Max6649MaskType MaskAlertInterruptMASK {
    Max6649MaskType get ();
    void set (Max6649MaskType value);
}
member MaskAlertInterruptMASK : Max6649MaskType with get, set

Property Value

Type: Max6649MaskType
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.OvertemperatureHysteresisHYS Property

IRD

Max6649OvertemperatureHysteresisHYS Property

Overtemperature Hysteresis (HYS) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OvertemperatureHysteresisHYS { get; set; }
Public Property OvertemperatureHysteresisHYS As Byte
    Get
    Set
public:
property unsigned char OvertemperatureHysteresisHYS {
    unsigned char get ();
    void set (unsigned char value);
}
member OvertemperatureHysteresisHYS : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.RemoteExternalALERTHighLimitRRHIWRHA Property

IRD

Max6649RemoteExternalALERTHighLimitRRHIWRHA Property

Remote External ALERT High Limit (RRHI/WRHA) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RemoteExternalALERTHighLimitRRHIWRHA { get; set; }
Public Property RemoteExternalALERTHighLimitRRHIWRHA As Byte
    Get
    Set
public:
property unsigned char RemoteExternalALERTHighLimitRRHIWRHA {
    unsigned char get ();
    void set (unsigned char value);
}
member RemoteExternalALERTHighLimitRRHIWRHA : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.RemoteExternalALERTLowLimitRRLSWRLN Property

IRD

Max6649RemoteExternalALERTLowLimitRRLSWRLN Property

Remote External ALERT Low Limit (RRLS/WRLN) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RemoteExternalALERTLowLimitRRLSWRLN { get; set; }
Public Property RemoteExternalALERTLowLimitRRLSWRLN As Byte
    Get
    Set
public:
property unsigned char RemoteExternalALERTLowLimitRRLSWRLN {
    unsigned char get ();
    void set (unsigned char value);
}
member RemoteExternalALERTLowLimitRRLSWRLN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.RemoteExternalExtendedTemperatureREET Property

IRD

Max6649RemoteExternalExtendedTemperatureREET Property

Remote External Extended Temperature (REET) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6649TempExType RemoteExternalExtendedTemperatureREET { get; }
Public ReadOnly Property RemoteExternalExtendedTemperatureREET As Max6649TempExType
    Get
public:
property Max6649TempExType RemoteExternalExtendedTemperatureREET {
    Max6649TempExType get ();
}
member RemoteExternalExtendedTemperatureREET : Max6649TempExType with get

Property Value

Type: Max6649TempExType
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.RemoteExternalOVERTLimitRWOE Property

IRD

Max6649RemoteExternalOVERTLimitRWOE Property

Remote External OVERT Limit (RWOE) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RemoteExternalOVERTLimitRWOE { get; set; }
Public Property RemoteExternalOVERTLimitRWOE As Byte
    Get
    Set
public:
property unsigned char RemoteExternalOVERTLimitRWOE {
    unsigned char get ();
    void set (unsigned char value);
}
member RemoteExternalOVERTLimitRWOE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.RemoteExternalTemperatureRRTE Property

IRD

Max6649RemoteExternalTemperatureRRTE Property

Remote External Temperature (RRTE) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RemoteExternalTemperatureRRTE { get; }
Public ReadOnly Property RemoteExternalTemperatureRRTE As Byte
    Get
public:
property unsigned char RemoteExternalTemperatureRRTE {
    unsigned char get ();
}
member RemoteExternalTemperatureRRTE : byte with get

Property Value

Type: Byte
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.RemoteHighTemperatureAlarmRHIGH Property

IRD

Max6649RemoteHighTemperatureAlarmRHIGH Property

Remote High Temperature Alarm (RHIGH)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6649RhighType RemoteHighTemperatureAlarmRHIGH { get; }
Public ReadOnly Property RemoteHighTemperatureAlarmRHIGH As Max6649RhighType
    Get
public:
property Max6649RhighType RemoteHighTemperatureAlarmRHIGH {
    Max6649RhighType get ();
}
member RemoteHighTemperatureAlarmRHIGH : Max6649RhighType with get

Property Value

Type: Max6649RhighType
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.RemoteInternalExtendedTemperatureRIET Property

IRD

Max6649RemoteInternalExtendedTemperatureRIET Property

Remote Internal Extended Temperature (RIET) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6649TempExType RemoteInternalExtendedTemperatureRIET { get; }
Public ReadOnly Property RemoteInternalExtendedTemperatureRIET As Max6649TempExType
    Get
public:
property Max6649TempExType RemoteInternalExtendedTemperatureRIET {
    Max6649TempExType get ();
}
member RemoteInternalExtendedTemperatureRIET : Max6649TempExType with get

Property Value

Type: Max6649TempExType
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.RemoteLowTemperatureAlarmRLOW Property

IRD

Max6649RemoteLowTemperatureAlarmRLOW Property

Remote Low Temperature Alarm (RLOW)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6649RlowType RemoteLowTemperatureAlarmRLOW { get; }
Public ReadOnly Property RemoteLowTemperatureAlarmRLOW As Max6649RlowType
    Get
public:
property Max6649RlowType RemoteLowTemperatureAlarmRLOW {
    Max6649RlowType get ();
}
member RemoteLowTemperatureAlarmRLOW : Max6649RlowType with get

Property Value

Type: Max6649RlowType
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.RevisionID Property

IRD

Max6649RevisionID Property

Revision ID

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionID { get; }
Public ReadOnly Property RevisionID As Byte
    Get
public:
property unsigned char RevisionID {
    unsigned char get ();
}
member RevisionID : byte with get

Property Value

Type: Byte
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.StandByModeControlRUN Property

IRD

Max6649StandByModeControlRUN Property

Stand By Mode Control (RUN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6649RunType StandByModeControlRUN { get; set; }
Public Property StandByModeControlRUN As Max6649RunType
    Get
    Set
public:
property Max6649RunType StandByModeControlRUN {
    Max6649RunType get ();
    void set (Max6649RunType value);
}
member StandByModeControlRUN : Max6649RunType with get, set

Property Value

Type: Max6649RunType
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649 Methods

The Max6649 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShotOSHT | One Shot (OSHT)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.Flush Method

IRD

Max6649Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.OneShotOSHT Method

IRD

Max6649OneShotOSHT Method

One Shot (OSHT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void OneShotOSHT()
Public Sub OneShotOSHT
public:
void OneShotOSHT()
member OneShotOSHT : unit -> unit
See Also

Reference

Max6649 Class
telos.Ird.Maxim Namespace


Max6649.BusyType Enumeration

IRD

Max6649BusyType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum BusyType
Public Enumeration BusyType
public enum class BusyType
type BusyType
Members
Member name | Value | Description
ADNotBusy | 0 | A/D Not Busy
ADBusy | 1 | A/D Busy
See Also

Reference

telos.Ird.Maxim Namespace


Max6649.ConversionRateType Enumeration

IRD

Max6649ConversionRateType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConversionRateType
Public Enumeration ConversionRateType
public enum class ConversionRateType
type ConversionRateType
Members
Member name | Value | Description
ConversionRate00625 | 0 | Conversion Rate: 0.0625
ConversionRate0125 | 1 | Conversion Rate: 0.125
ConversionRate025 | 2 | Conversion Rate: 0.25
ConversionRate05 | 3 | Conversion Rate: 0.5
ConversionRate1 | 4 | Conversion Rate: 1
ConversionRate2 | 5 | Conversion Rate: 2
ConversionRate4 | 6 | Conversion Rate: 4
ConversionRate4__1 | 7 | Conversion Rate: 4
See Also

Reference

telos.Ird.Maxim Namespace


Max6649.EotType Enumeration

IRD

Max6649EotType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum EotType
Public Enumeration EotType
public enum class EotType
type EotType
Members
Member name | Value | Description
RemoteExternalTemperatureExceedsExternalOVERTFalse | 0 | Remote External Temperature Exceeds External OVERT: False
RemoteExternalTemperatureExceedsExternalOVERTTrue | 1 | Remote External Temperature Exceeds External OVERT: True
See Also

Reference

telos.Ird.Maxim Namespace


Max6649.FaultQueueType Enumeration

IRD

Max6649FaultQueueType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultQueueType
Public Enumeration FaultQueueType
public enum class FaultQueueType
type FaultQueueType
Members
Member name | Value | Description
FaultQueueLength1 | 0 | Fault Queue Length: 1
FaultQueueLength2 | 1 | Fault Queue Length: 2
FaultQueueLength1__1 | 2 | Fault Queue Length: 1
FaultQueueLength3 | 3 | Fault Queue Length: 3
See Also

Reference

telos.Ird.Maxim Namespace


Max6649.FaultType Enumeration

IRD

Max6649FaultType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaultType
Public Enumeration FaultType
public enum class FaultType
type FaultType
Members
Member name | Value | Description
DXNAndDXPPinAreEitherShortedOrOpenFalse | 0 | DXN And DXP Pin Are Either Shorted Or Open: False
DXNAndDXPPinAreEitherShortedOrOpenTrue | 1 | DXN And DXP Pin Are Either Shorted Or Open: True
See Also

Reference

telos.Ird.Maxim Namespace


Max6649.IotType Enumeration

IRD

Max6649IotType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IotType
Public Enumeration IotType
public enum class IotType
type IotType
Members
Member name | Value | Description
LocalInternalTemperatureExceedsInternalOVERTFalse | 0 | Local Internal Temperature Exceeds Internal OVERT: False
LocalInternalTemperatureExceedsInternalOVERTTrue | 1 | Local Internal Temperature Exceeds Internal OVERT: True
See Also

Reference

telos.Ird.Maxim Namespace


Max6649.LhighType Enumeration

IRD

Max6649LhighType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum LhighType
Public Enumeration LhighType
public enum class LhighType
type LhighType
Members
Member name | Value | Description
NoLocalInternalHighTemperatureAlarm | 0 | No Local Internal High-Temperature Alarm
LocalInternalHighTemperatureAlarm | 1 | Local Internal High-Temperature Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Max6649.LlowType Enumeration

IRD

Max6649LlowType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum LlowType
Public Enumeration LlowType
public enum class LlowType
type LlowType
Members
Member name | Value | Description
NoLocalInternalLowTemperatureAlarm | 0 | No Local Internal Low-Temperature Alarm
LocalInternalLowTemperatureAlarm | 1 | Local Internal Low-Temperature Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Max6649.MaskType Enumeration

IRD

Max6649MaskType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum MaskType
Public Enumeration MaskType
public enum class MaskType
type MaskType
Members
Member name | Value | Description
AlertInterruptDisable | 0 | Alert Interrupt Disable
AlertInterruptEnable | 1 | Alert Interrupt Enable
See Also

Reference

telos.Ird.Maxim Namespace


Max6649.RhighType Enumeration

IRD

Max6649RhighType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum RhighType
Public Enumeration RhighType
public enum class RhighType
type RhighType
Members
Member name | Value | Description
NoRemoteExternalHighTemperatureAlarm | 0 | No Remote External High-Temperature Alarm
RemoteExternalHighTemperatureAlarm | 1 | Remote External High-Temperature Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Max6649.RlowType Enumeration

IRD

Max6649RlowType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum RlowType
Public Enumeration RlowType
public enum class RlowType
type RlowType
Members
Member name | Value | Description
NoRemoteExternalLowTemperatureAlarm | 0 | No Remote External Low-Temperature Alarm
RemoteExternalLowTemperatureAlarm | 1 | Remote External Low-Temperature Alarm
See Also

Reference

telos.Ird.Maxim Namespace


Max6649.RunType Enumeration

IRD

Max6649RunType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum RunType
Public Enumeration RunType
public enum class RunType
type RunType
Members
Member name | Value | Description
StandByModeNotInitiated | 0 | Stand By Mode Not Initiated
StandByModeInitiated | 1 | Stand By Mode Initiated
See Also

Reference

telos.Ird.Maxim Namespace


Max6649.TempExType Enumeration

IRD

Max6649TempExType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TempExType
Public Enumeration TempExType
public enum class TempExType
type TempExType
Members
Member name | Value | Description
FractionalTeperature0000 | 0 | Fractional Teperature: 0.000
FractionalTeperature0125 | 1 | Fractional Teperature: 0.125
FractionalTeperature0250 | 2 | Fractional Teperature: 0.250
FractionalTeperature0375 | 3 | Fractional Teperature: 0.375
FractionalTeperature0500 | 4 | Fractional Teperature: 0.500
FractionalTeperature0625 | 5 | Fractional Teperature: 0.625
FractionalTeperature0750 | 6 | Fractional Teperature: 0.750
FractionalTeperature0875 | 7 | Fractional Teperature: 0.875
See Also

Reference

telos.Ird.Maxim Namespace


Max6660 Class

Maxim: MAX 6660
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax6660

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max6660
Public Class Max6660
public ref class Max6660
type Max6660 =  class end

The Max6660 type exposes the following members.

Constructors
 | Name | Description
Public method | Max6660 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationALERTClearMode | Configuration (ALERT Clear Mode)
Public property | ConfigurationALERTMASK | Configuration (ALERT MASK)
Public property | ConfigurationMaskOVERTOutput | Configuration (Mask OVERT Output)
Public property | ConfigurationOVERTInputInhibit | Configuration (OVERT Input Inhibit)
Public property | ConfigurationOVERTPolarity | Configuration (OVERT Polarity)
Public property | ConfigurationRUNSTOP | Configuration (RUN/STOP)
Public property | ConfigurationThermalClosedOpenLoop | Configuration (Thermal Closed / Open Loop)
Public property | ConfigurationWriteProtect | Configuration (Write Protect)
Public property | DeviceID | Device ID
Public property | FanControlThresholdTemperatureTFAN | Fan-Control Threshold Temperature T_FAN (unit: °C)
Public property | FanConversionRate | Fan-Conversion Rate (unit: Hz)
Public property | FanCountDivisor | Fan Count Divisor
Public property | FanDriverMode | Fan Driver Mode
Public property | FanFeedbackMode | Fan Feedback Mode
Public property | FanGain | Fan Gain
Public property | FanSpeedControl | Fan-Speed Control
Public property | FanTachometerCount | Fan Tachometer Count
Public property | FanTachometerCountLimit | Fan Tachometer Count Limit
Public property | FullScale | Full-Scale
Public property | ManufacturerID | Manufacturer ID
Public property | ModeADCGain | Mode (ADC Gain) (unit: °C)
Public property | ModeParasiticResistanceCancellation | Mode (Parasitic Resistance Cancellation)
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | RemoteTHIGH | Remote T_HIGH (unit: °C)
Public property | RemoteTHYST | Remote T_HYST (unit: °C)
Public property | RemoteTLOW | Remote T_LOW (unit: °C)
Public property | RemoteTMAX | Remote T_MAX (unit: °C)
Public property | SMBusTimeout | SMBus Timeout
Public property | StatusALERT | Status (ALERT)
Public property | StatusDiodeOpen | Status (Diode Open)
Public property | StatusFanDriverFullScale | Status (Fan Driver Full Scale)
Public property | StatusFanFailure | Status (Fan Failure)
Public property | StatusOverheat | Status (Overheat)
Public property | StatusOVERT | Status (OVERT)
Public property | StatusRemoteHigh | Status (Remote High)
Public property | StatusRemoteLow | Status (Remote Low)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShotTemperatureConversion | One-Shot Temperature Conversion
Public method | SoftwarePOR | Software POR
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Remote-Junction Temperature-Controlled Fan-Speed Regulator
See Also

Reference

telos.Ird.Maxim Namespace


Max6660 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max6660(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max6660

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660 Properties

The Max6660 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationALERTClearMode | Configuration (ALERT Clear Mode)
Public property | ConfigurationALERTMASK | Configuration (ALERT MASK)
Public property | ConfigurationMaskOVERTOutput | Configuration (Mask OVERT Output)
Public property | ConfigurationOVERTInputInhibit | Configuration (OVERT Input Inhibit)
Public property | ConfigurationOVERTPolarity | Configuration (OVERT Polarity)
Public property | ConfigurationRUNSTOP | Configuration (RUN/STOP)
Public property | ConfigurationThermalClosedOpenLoop | Configuration (Thermal Closed / Open Loop)
Public property | ConfigurationWriteProtect | Configuration (Write Protect)
Public property | DeviceID | Device ID
Public property | FanControlThresholdTemperatureTFAN | Fan-Control Threshold Temperature T_FAN (unit: °C)
Public property | FanConversionRate | Fan-Conversion Rate (unit: Hz)
Public property | FanCountDivisor | Fan Count Divisor
Public property | FanDriverMode | Fan Driver Mode
Public property | FanFeedbackMode | Fan Feedback Mode
Public property | FanGain | Fan Gain
Public property | FanSpeedControl | Fan-Speed Control
Public property | FanTachometerCount | Fan Tachometer Count
Public property | FanTachometerCountLimit | Fan Tachometer Count Limit
Public property | FullScale | Full-Scale
Public property | ManufacturerID | Manufacturer ID
Public property | ModeADCGain | Mode (ADC Gain) (unit: °C)
Public property | ModeParasiticResistanceCancellation | Mode (Parasitic Resistance Cancellation)
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | RemoteTHIGH | Remote T_HIGH (unit: °C)
Public property | RemoteTHYST | Remote T_HYST (unit: °C)
Public property | RemoteTLOW | Remote T_LOW (unit: °C)
Public property | RemoteTMAX | Remote T_MAX (unit: °C)
Public property | SMBusTimeout | SMBus Timeout
Public property | StatusALERT | Status (ALERT)
Public property | StatusDiodeOpen | Status (Diode Open)
Public property | StatusFanDriverFullScale | Status (Fan Driver Full Scale)
Public property | StatusFanFailure | Status (Fan Failure)
Public property | StatusOverheat | Status (Overheat)
Public property | StatusOVERT | Status (OVERT)
Public property | StatusRemoteHigh | Status (Remote High)
Public property | StatusRemoteLow | Status (Remote Low)
Top
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.AutoFlush Property

IRD

Max6660AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.ConfigurationALERTClearMode Property

IRD

Max6660ConfigurationALERTClearMode Property

Configuration (ALERT Clear Mode)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660ConfigAlertClearType ConfigurationALERTClearMode { get; set; }
Public Property ConfigurationALERTClearMode As Max6660ConfigAlertClearType
    Get
    Set
public:
property Max6660ConfigAlertClearType ConfigurationALERTClearMode {
    Max6660ConfigAlertClearType get ();
    void set (Max6660ConfigAlertClearType value);
}
member ConfigurationALERTClearMode : Max6660ConfigAlertClearType with get, set

Property Value

Type: Max6660ConfigAlertClearType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.ConfigurationALERTMASK Property

IRD

Max6660ConfigurationALERTMASK Property

Configuration (ALERT MASK)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660ConfigMaskType ConfigurationALERTMASK { get; set; }
Public Property ConfigurationALERTMASK As Max6660ConfigMaskType
    Get
    Set
public:
property Max6660ConfigMaskType ConfigurationALERTMASK {
    Max6660ConfigMaskType get ();
    void set (Max6660ConfigMaskType value);
}
member ConfigurationALERTMASK : Max6660ConfigMaskType with get, set

Property Value

Type: Max6660ConfigMaskType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.ConfigurationMaskOVERTOutput Property

IRD

Max6660ConfigurationMaskOVERTOutput Property

Configuration (Mask OVERT Output)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660ConfigOvertType ConfigurationMaskOVERTOutput { get; set; }
Public Property ConfigurationMaskOVERTOutput As Max6660ConfigOvertType
    Get
    Set
public:
property Max6660ConfigOvertType ConfigurationMaskOVERTOutput {
    Max6660ConfigOvertType get ();
    void set (Max6660ConfigOvertType value);
}
member ConfigurationMaskOVERTOutput : Max6660ConfigOvertType with get, set

Property Value

Type: Max6660ConfigOvertType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.ConfigurationOVERTInputInhibit Property

IRD

Max6660ConfigurationOVERTInputInhibit Property

Configuration (OVERT Input Inhibit)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660ConfigOvertType ConfigurationOVERTInputInhibit { get; set; }
Public Property ConfigurationOVERTInputInhibit As Max6660ConfigOvertType
    Get
    Set
public:
property Max6660ConfigOvertType ConfigurationOVERTInputInhibit {
    Max6660ConfigOvertType get ();
    void set (Max6660ConfigOvertType value);
}
member ConfigurationOVERTInputInhibit : Max6660ConfigOvertType with get, set

Property Value

Type: Max6660ConfigOvertType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.ConfigurationOVERTPolarity Property

IRD

Max6660ConfigurationOVERTPolarity Property

Configuration (OVERT Polarity)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660ConfigPolType ConfigurationOVERTPolarity { get; set; }
Public Property ConfigurationOVERTPolarity As Max6660ConfigPolType
    Get
    Set
public:
property Max6660ConfigPolType ConfigurationOVERTPolarity {
    Max6660ConfigPolType get ();
    void set (Max6660ConfigPolType value);
}
member ConfigurationOVERTPolarity : Max6660ConfigPolType with get, set

Property Value

Type: Max6660ConfigPolType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.ConfigurationRUNSTOP Property

IRD

Max6660ConfigurationRUNSTOP Property

Configuration (RUN/STOP)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660ConfigRunType ConfigurationRUNSTOP { get; set; }
Public Property ConfigurationRUNSTOP As Max6660ConfigRunType
    Get
    Set
public:
property Max6660ConfigRunType ConfigurationRUNSTOP {
    Max6660ConfigRunType get ();
    void set (Max6660ConfigRunType value);
}
member ConfigurationRUNSTOP : Max6660ConfigRunType with get, set

Property Value

Type: Max6660ConfigRunType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.ConfigurationThermalClosedOpenLoop Property

IRD

Max6660ConfigurationThermalClosedOpenLoop Property

Configuration (Thermal Closed / Open Loop)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660ConfigThermalLoopType ConfigurationThermalClosedOpenLoop { get; set; }
Public Property ConfigurationThermalClosedOpenLoop As Max6660ConfigThermalLoopType
    Get
    Set
public:
property Max6660ConfigThermalLoopType ConfigurationThermalClosedOpenLoop {
    Max6660ConfigThermalLoopType get ();
    void set (Max6660ConfigThermalLoopType value);
}
member ConfigurationThermalClosedOpenLoop : Max6660ConfigThermalLoopType with get, set

Property Value

Type: Max6660ConfigThermalLoopType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.ConfigurationWriteProtect Property

IRD

Max6660ConfigurationWriteProtect Property

Configuration (Write Protect)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660ConfigWpType ConfigurationWriteProtect { get; set; }
Public Property ConfigurationWriteProtect As Max6660ConfigWpType
    Get
    Set
public:
property Max6660ConfigWpType ConfigurationWriteProtect {
    Max6660ConfigWpType get ();
    void set (Max6660ConfigWpType value);
}
member ConfigurationWriteProtect : Max6660ConfigWpType with get, set

Property Value

Type: Max6660ConfigWpType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.DeviceID Property

IRD

Max6660DeviceID Property

Device ID

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.FanControlThresholdTemperatureTFAN Property

IRD

Max6660FanControlThresholdTemperatureTFAN Property

Fan-Control Threshold Temperature T_FAN (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte FanControlThresholdTemperatureTFAN { get; set; }
Public Property FanControlThresholdTemperatureTFAN As SByte
    Get
    Set
public:
property signed char FanControlThresholdTemperatureTFAN {
    signed char get ();
    void set (signed char value);
}
member FanControlThresholdTemperatureTFAN : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.FanConversionRate Property

IRD

Max6660FanConversionRate Property

Fan-Conversion Rate (unit: Hz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660FcrType FanConversionRate { get; set; }
Public Property FanConversionRate As Max6660FcrType
    Get
    Set
public:
property Max6660FcrType FanConversionRate {
    Max6660FcrType get ();
    void set (Max6660FcrType value);
}
member FanConversionRate : Max6660FcrType with get, set

Property Value

Type: Max6660FcrType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.FanCountDivisor Property

IRD

Max6660FanCountDivisor Property

Fan Count Divisor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FanCountDivisor { get; set; }
Public Property FanCountDivisor As Byte
    Get
    Set
public:
property unsigned char FanCountDivisor {
    unsigned char get ();
    void set (unsigned char value);
}
member FanCountDivisor : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.FanDriverMode Property

IRD

Max6660FanDriverMode Property

Fan Driver Mode

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660FanGainModeType FanDriverMode { get; set; }
Public Property FanDriverMode As Max6660FanGainModeType
    Get
    Set
public:
property Max6660FanGainModeType FanDriverMode {
    Max6660FanGainModeType get ();
    void set (Max6660FanGainModeType value);
}
member FanDriverMode : Max6660FanGainModeType with get, set

Property Value

Type: Max6660FanGainModeType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.FanFeedbackMode Property

IRD

Max6660FanFeedbackMode Property

Fan Feedback Mode

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660FanGainFeedbackType FanFeedbackMode { get; set; }
Public Property FanFeedbackMode As Max6660FanGainFeedbackType
    Get
    Set
public:
property Max6660FanGainFeedbackType FanFeedbackMode {
    Max6660FanGainFeedbackType get ();
    void set (Max6660FanGainFeedbackType value);
}
member FanFeedbackMode : Max6660FanGainFeedbackType with get, set

Property Value

Type: Max6660FanGainFeedbackType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.FanGain Property

IRD

Max6660FanGain Property

Fan Gain

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FanGain { get; set; }
Public Property FanGain As Byte
    Get
    Set
public:
property unsigned char FanGain {
    unsigned char get ();
    void set (unsigned char value);
}
member FanGain : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.FanSpeedControl Property

IRD

Max6660FanSpeedControl Property

Fan-Speed Control

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FanSpeedControl { get; set; }
Public Property FanSpeedControl As Byte
    Get
    Set
public:
property unsigned char FanSpeedControl {
    unsigned char get ();
    void set (unsigned char value);
}
member FanSpeedControl : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.FanTachometerCount Property

IRD

Max6660FanTachometerCount Property

Fan Tachometer Count

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FanTachometerCount { get; }
Public ReadOnly Property FanTachometerCount As Byte
    Get
public:
property unsigned char FanTachometerCount {
    unsigned char get ();
}
member FanTachometerCount : byte with get

Property Value

Type: Byte
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.FanTachometerCountLimit Property

IRD

Max6660FanTachometerCountLimit Property

Fan Tachometer Count Limit

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FanTachometerCountLimit { get; set; }
Public Property FanTachometerCountLimit As Byte
    Get
    Set
public:
property unsigned char FanTachometerCountLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member FanTachometerCountLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.FullScale Property

IRD

Max6660FullScale Property

Full-Scale

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FullScale { get; set; }
Public Property FullScale As Byte
    Get
    Set
public:
property unsigned char FullScale {
    unsigned char get ();
    void set (unsigned char value);
}
member FullScale : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.ManufacturerID Property

IRD

Max6660ManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As Byte
    Get
public:
property unsigned char ManufacturerID {
    unsigned char get ();
}
member ManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.ModeADCGain Property

IRD

Max6660ModeADCGain Property

Mode (ADC Gain) (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ModeADCGain { get; set; }
Public Property ModeADCGain As Double
    Get
    Set
public:
property double ModeADCGain {
    double get ();
    void set (double value);
}
member ModeADCGain : float with get, set

Property Value

Type: Double
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.ModeParasiticResistanceCancellation Property

IRD

Max6660ModeParasiticResistanceCancellation Property

Mode (Parasitic Resistance Cancellation)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660ModePrcType ModeParasiticResistanceCancellation { get; set; }
Public Property ModeParasiticResistanceCancellation As Max6660ModePrcType
    Get
    Set
public:
property Max6660ModePrcType ModeParasiticResistanceCancellation {
    Max6660ModePrcType get ();
    void set (Max6660ModePrcType value);
}
member ModeParasiticResistanceCancellation : Max6660ModePrcType with get, set

Property Value

Type: Max6660ModePrcType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.RemoteTemperature Property

IRD

Max6660RemoteTemperature Property

Remote Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperature { get; }
Public ReadOnly Property RemoteTemperature As Double
    Get
public:
property double RemoteTemperature {
    double get ();
}
member RemoteTemperature : float with get

Property Value

Type: Double
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.RemoteTHIGH Property

IRD

Max6660RemoteTHIGH Property

Remote T_HIGH (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTHIGH { get; set; }
Public Property RemoteTHIGH As SByte
    Get
    Set
public:
property signed char RemoteTHIGH {
    signed char get ();
    void set (signed char value);
}
member RemoteTHIGH : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.RemoteTHYST Property

IRD

Max6660RemoteTHYST Property

Remote T_HYST (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTHYST { get; set; }
Public Property RemoteTHYST As SByte
    Get
    Set
public:
property signed char RemoteTHYST {
    signed char get ();
    void set (signed char value);
}
member RemoteTHYST : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.RemoteTLOW Property

IRD

Max6660RemoteTLOW Property

Remote T_LOW (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTLOW { get; set; }
Public Property RemoteTLOW As SByte
    Get
    Set
public:
property signed char RemoteTLOW {
    signed char get ();
    void set (signed char value);
}
member RemoteTLOW : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.RemoteTMAX Property

IRD

Max6660RemoteTMAX Property

Remote T_MAX (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTMAX { get; set; }
Public Property RemoteTMAX As SByte
    Get
    Set
public:
property signed char RemoteTMAX {
    signed char get ();
    void set (signed char value);
}
member RemoteTMAX : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.SMBusTimeout Property

IRD

Max6660SMBusTimeout Property

SMBus Timeout

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660FanGainSmbusType SMBusTimeout { get; set; }
Public Property SMBusTimeout As Max6660FanGainSmbusType
    Get
    Set
public:
property Max6660FanGainSmbusType SMBusTimeout {
    Max6660FanGainSmbusType get ();
    void set (Max6660FanGainSmbusType value);
}
member SMBusTimeout : Max6660FanGainSmbusType with get, set

Property Value

Type: Max6660FanGainSmbusType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.StatusALERT Property

IRD

Max6660StatusALERT Property

Status (ALERT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660StatusAlertType StatusALERT { get; }
Public ReadOnly Property StatusALERT As Max6660StatusAlertType
    Get
public:
property Max6660StatusAlertType StatusALERT {
    Max6660StatusAlertType get ();
}
member StatusALERT : Max6660StatusAlertType with get

Property Value

Type: Max6660StatusAlertType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.StatusDiodeOpen Property

IRD

Max6660StatusDiodeOpen Property

Status (Diode Open)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660StatusOpenType StatusDiodeOpen { get; }
Public ReadOnly Property StatusDiodeOpen As Max6660StatusOpenType
    Get
public:
property Max6660StatusOpenType StatusDiodeOpen {
    Max6660StatusOpenType get ();
}
member StatusDiodeOpen : Max6660StatusOpenType with get

Property Value

Type: Max6660StatusOpenType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.StatusFanDriverFullScale Property

IRD

Max6660StatusFanDriverFullScale Property

Status (Fan Driver Full Scale)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660StatusScaleType StatusFanDriverFullScale { get; }
Public ReadOnly Property StatusFanDriverFullScale As Max6660StatusScaleType
    Get
public:
property Max6660StatusScaleType StatusFanDriverFullScale {
    Max6660StatusScaleType get ();
}
member StatusFanDriverFullScale : Max6660StatusScaleType with get

Property Value

Type: Max6660StatusScaleType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.StatusFanFailure Property

IRD

Max6660StatusFanFailure Property

Status (Fan Failure)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660StatusFanFailureType StatusFanFailure { get; }
Public ReadOnly Property StatusFanFailure As Max6660StatusFanFailureType
    Get
public:
property Max6660StatusFanFailureType StatusFanFailure {
    Max6660StatusFanFailureType get ();
}
member StatusFanFailure : Max6660StatusFanFailureType with get

Property Value

Type: Max6660StatusFanFailureType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.StatusOverheat Property

IRD

Max6660StatusOverheat Property

Status (Overheat)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660StatusOverheatType StatusOverheat { get; }
Public ReadOnly Property StatusOverheat As Max6660StatusOverheatType
    Get
public:
property Max6660StatusOverheatType StatusOverheat {
    Max6660StatusOverheatType get ();
}
member StatusOverheat : Max6660StatusOverheatType with get

Property Value

Type: Max6660StatusOverheatType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.StatusOVERT Property

IRD

Max6660StatusOVERT Property

Status (OVERT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660StatusOvertType StatusOVERT { get; }
Public ReadOnly Property StatusOVERT As Max6660StatusOvertType
    Get
public:
property Max6660StatusOvertType StatusOVERT {
    Max6660StatusOvertType get ();
}
member StatusOVERT : Max6660StatusOvertType with get

Property Value

Type: Max6660StatusOvertType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.StatusRemoteHigh Property

IRD

Max6660StatusRemoteHigh Property

Status (Remote High)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660StatusRemoteHighType StatusRemoteHigh { get; }
Public ReadOnly Property StatusRemoteHigh As Max6660StatusRemoteHighType
    Get
public:
property Max6660StatusRemoteHighType StatusRemoteHigh {
    Max6660StatusRemoteHighType get ();
}
member StatusRemoteHigh : Max6660StatusRemoteHighType with get

Property Value

Type: Max6660StatusRemoteHighType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.StatusRemoteLow Property

IRD

Max6660StatusRemoteLow Property

Status (Remote Low)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6660StatusRemoteLowType StatusRemoteLow { get; }
Public ReadOnly Property StatusRemoteLow As Max6660StatusRemoteLowType
    Get
public:
property Max6660StatusRemoteLowType StatusRemoteLow {
    Max6660StatusRemoteLowType get ();
}
member StatusRemoteLow : Max6660StatusRemoteLowType with get

Property Value

Type: Max6660StatusRemoteLowType
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660 Methods

The Max6660 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShotTemperatureConversion | One-Shot Temperature Conversion
Public method | SoftwarePOR | Software POR
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.Flush Method

IRD

Max6660Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.OneShotTemperatureConversion Method

IRD

Max6660OneShotTemperatureConversion Method

One-Shot Temperature Conversion

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void OneShotTemperatureConversion()
Public Sub OneShotTemperatureConversion
public:
void OneShotTemperatureConversion()
member OneShotTemperatureConversion : unit -> unit
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.SoftwarePOR Method

IRD

Max6660SoftwarePOR Method

Software POR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void SoftwarePOR()
Public Sub SoftwarePOR
public:
void SoftwarePOR()
member SoftwarePOR : unit -> unit
See Also

Reference

Max6660 Class
telos.Ird.Maxim Namespace


Max6660.ConfigAlertClearType Enumeration

IRD

Max6660ConfigAlertClearType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigAlertClearType
Public Enumeration ConfigAlertClearType
public enum class ConfigAlertClearType
type ConfigAlertClearType
Members
Member name | Value | Description
ReadingStatusRegisterClearsALERT | 1 | Reading Status Register: Clears ALERT
ReadingStatusRegisterDoesNotClearALERT | 0 | Reading Status Register: Does Not Clear ALERT
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.ConfigMaskType Enumeration

IRD

Max6660ConfigMaskType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigMaskType
Public Enumeration ConfigMaskType
public enum class ConfigMaskType
type ConfigMaskType
Members
Member name | Value | Description
ALERTMasked | 1 | ALERT: Masked
ALERTNotMasked | 0 | ALERT: Not Masked
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.ConfigOvertType Enumeration

IRD

Max6660ConfigOvertType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigOvertType
Public Enumeration ConfigOvertType
public enum class ConfigOvertType
type ConfigOvertType
Members
Member name | Value | Description
OVERTMasked | 1 | OVERT: Masked
OVERTNotMasked | 0 | OVERT: Not Masked
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.ConfigPolType Enumeration

IRD

Max6660ConfigPolType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigPolType
Public Enumeration ConfigPolType
public enum class ConfigPolType
type ConfigPolType
Members
Member name | Value | Description
ActiveHigh | 1 | Active High
ActiveLow | 0 | Active Low
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.ConfigRunType Enumeration

IRD

Max6660ConfigRunType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigRunType
Public Enumeration ConfigRunType
public enum class ConfigRunType
type ConfigRunType
Members
Member name | Value | Description
Standby | 1 | Standby
Autoconvert | 0 | Autoconvert
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.ConfigThermalLoopType Enumeration

IRD

Max6660ConfigThermalLoopType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigThermalLoopType
Public Enumeration ConfigThermalLoopType
public enum class ConfigThermalLoopType
type ConfigThermalLoopType
Members
Member name | Value | Description
ThermalLoopOpen | 1 | Thermal Loop: Open
ThermalLoopClose | 0 | Thermal Loop: Close
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.ConfigWpType Enumeration

IRD

Max6660ConfigWpType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigWpType
Public Enumeration ConfigWpType
public enum class ConfigWpType
type ConfigWpType
Members
Member name | Value | Description
WriteProtectEnabled | 1 | Write Protect: Enabled
WriteProtectDisabled | 0 | Write Protect: Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.FanGainFeedbackType Enumeration

IRD

Max6660FanGainFeedbackType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FanGainFeedbackType
Public Enumeration FanGainFeedbackType
public enum class FanGainFeedbackType
type FanGainFeedbackType
Members
Member name | Value | Description
DriverCurrentSensing | 1 | Driver Current Sensing
TachometerFeedback | 0 | Tachometer Feedback
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.FanGainModeType Enumeration

IRD

Max6660FanGainModeType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FanGainModeType
Public Enumeration FanGainModeType
public enum class FanGainModeType
type FanGainModeType
Members
Member name | Value | Description
OpenLoopEnabled | 1 | Open Loop: Enabled
OpenLoopDisabled | 0 | Open Loop: Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.FanGainSmbusType Enumeration

IRD

Max6660FanGainSmbusType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FanGainSmbusType
Public Enumeration FanGainSmbusType
public enum class FanGainSmbusType
type FanGainSmbusType
Members
Member name | Value | Description
Disabled | 1 | Disabled
Enabled | 0 | Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.FcrType Enumeration

IRD

Max6660FcrType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FcrType
Public Enumeration FcrType
public enum class FcrType
type FcrType
Members
Member name | Value | Description
Value_0_0625 | 0 | 0.0625
Value_0_125 | 1 | 0.125
Value_0_25 | 2 | 0.25
Value_0_5 | 3 | 0.5
Value_1 | 4 | 1
Value_2 | 5 | 2
Value_4 | 6 | 4
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.ModePrcType Enumeration

IRD

Max6660ModePrcType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModePrcType
Public Enumeration ModePrcType
public enum class ModePrcType
type ModePrcType
Members
Member name | Value | Description
Enabled | 1 | Enabled
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.StatusAlertType Enumeration

IRD

Max6660StatusAlertType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusAlertType
Public Enumeration StatusAlertType
public enum class StatusAlertType
type StatusAlertType
Members
Member name | Value | Description
ALERTActivated | 1 | ALERT: Activated
ALERTNotActivated | 0 | ALERT: Not Activated
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.StatusFanFailureType Enumeration

IRD

Max6660StatusFanFailureType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusFanFailureType
Public Enumeration StatusFanFailureType
public enum class StatusFanFailureType
type StatusFanFailureType
Members
Member name | Value | Description
FanTachometerCountLimitExceeded | 1 | Fan Tachometer Count Limit: Exceeded
FanTachometerCountLimitNotExceeded | 0 | Fan Tachometer Count Limit: Not Exceeded
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.StatusOpenType Enumeration

IRD

Max6660StatusOpenType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusOpenType
Public Enumeration StatusOpenType
public enum class StatusOpenType
type StatusOpenType
Members
Member name | Value | Description
RemoteJunctionDiodeOpen | 1 | Remote-Junction Diode: Open
RemoteJunctionDiodeOK | 0 | Remote-Junction Diode: OK
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.StatusOverheatType Enumeration

IRD

Max6660StatusOverheatType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusOverheatType
Public Enumeration StatusOverheatType
public enum class StatusOverheatType
type StatusOverheatType
Members
Member name | Value | Description
FanDriverOverheated | 1 | Fan Driver: Overheated
FanDriverNotOverheated | 0 | Fan Driver: Not Overheated
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.StatusOvertType Enumeration

IRD

Max6660StatusOvertType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusOvertType
Public Enumeration StatusOvertType
public enum class StatusOvertType
type StatusOvertType
Members
Member name | Value | Description
OVERTActivated | 1 | OVERT: Activated
OVERTNotActivated | 0 | OVERT: Not Activated
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.StatusRemoteHighType Enumeration

IRD

Max6660StatusRemoteHighType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusRemoteHighType
Public Enumeration StatusRemoteHighType
public enum class StatusRemoteHighType
type StatusRemoteHighType
Members
Member name | Value | Description
RemoteJunctionTemperatureExceeded | 1 | Remote-Junction Temperature: Exceeded
RemoteJunctionTemperatureNotExceeded | 0 | Remote-Junction Temperature: Not Exceeded
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.StatusRemoteLowType Enumeration

IRD

Max6660StatusRemoteLowType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusRemoteLowType
Public Enumeration StatusRemoteLowType
public enum class StatusRemoteLowType
type StatusRemoteLowType
Members
Member name | Value | Description
RemoteJunctionTemperatureLower | 1 | Remote-Junction Temperature: Lower
RemoteJunctionTemperatureNotLower | 0 | Remote-Junction Temperature: Not Lower
See Also

Reference

telos.Ird.Maxim Namespace


Max6660.StatusScaleType Enumeration

IRD

Max6660StatusScaleType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusScaleType
Public Enumeration StatusScaleType
public enum class StatusScaleType
type StatusScaleType
Members
Member name | Value | Description
FanDriverFullScale | 1 | Fan Driver: Full Scale
FanDriverNotFullScale | 0 | Fan Driver: Not Full Scale
See Also

Reference

telos.Ird.Maxim Namespace


Max6680 Class

Maxim: MAX 6680 / MAX 6681
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax6680

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max6680
Public Class Max6680
public ref class Max6680
type Max6680 =  class end

The Max6680 type exposes the following members.

Constructors
 | Name | Description
Public method | Max6680 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationALERTMASK | Configuration (ALERT MASK)
Public property | ConfigurationExtendedRange | Configuration (Extended Range)
Public property | ConfigurationExtendedResolution | Configuration (Extended Resolution)
Public property | ConfigurationRUNSTOP | Configuration (RUN/STOP)
Public property | ConfigurationSMBusTimeout | Configuration (SMBus Timeout)
Public property | ConfigurationSoftwareReset | Configuration (Software Reset)
Public property | ConfigurationSPNP | Configuration (SPNP)
Public property | ConversionRate | Conversion Rate (unit: Hz)
Public property | DeviceRevision | Device Revision
Public property | ExternalALERTHighLimit | External ALERT High Limit (unit: °C)
Public property | ExternalALERTLowLimit | External ALERT Low Limit (unit: °C)
Public property | ExternalExtendedTemperature | External Extended Temperature (unit: °C)
Public property | ExternalOffsetHighByte | External Offset High Byte (unit: °C)
Public property | ExternalOffsetLowByte | External Offset Low Byte (unit: °C)
Public property | ExternalOVERTLimit | External OVERT Limit (unit: °C)
Public property | ExternalTemperature | External Temperature (unit: °C)
Public property | InternalALERTHighLimit | Internal ALERT High Limit (unit: °C)
Public property | InternalALERTLowLimit | Internal ALERT Low Limit (unit: °C)
Public property | InternalOVERTLimit | Internal OVERT Limit (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | OVERTHysteresis | OVERT Hysteresis (unit: °C)
Public property | StatusBUSY | Status (BUSY)
Public property | StatusLHIGH | Status (LHIGH)
Public property | StatusLLOW | Status (LLOW)
Public property | StatusOPEN | Status (OPEN)
Public property | StatusOVE | Status (OVE)
Public property | StatusOVI | Status (OVI)
Public property | StatusRHIGH | Status (RHIGH)
Public property | StatusRLOW | Status (RLOW)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
1°C Fail-Safe Remote/Local Temperature Sensor
See Also

Reference

telos.Ird.Maxim Namespace


Max6680 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max6680(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max6680

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680 Properties

The Max6680 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationALERTMASK | Configuration (ALERT MASK)
Public property | ConfigurationExtendedRange | Configuration (Extended Range)
Public property | ConfigurationExtendedResolution | Configuration (Extended Resolution)
Public property | ConfigurationRUNSTOP | Configuration (RUN/STOP)
Public property | ConfigurationSMBusTimeout | Configuration (SMBus Timeout)
Public property | ConfigurationSoftwareReset | Configuration (Software Reset)
Public property | ConfigurationSPNP | Configuration (SPNP)
Public property | ConversionRate | Conversion Rate (unit: Hz)
Public property | DeviceRevision | Device Revision
Public property | ExternalALERTHighLimit | External ALERT High Limit (unit: °C)
Public property | ExternalALERTLowLimit | External ALERT Low Limit (unit: °C)
Public property | ExternalExtendedTemperature | External Extended Temperature (unit: °C)
Public property | ExternalOffsetHighByte | External Offset High Byte (unit: °C)
Public property | ExternalOffsetLowByte | External Offset Low Byte (unit: °C)
Public property | ExternalOVERTLimit | External OVERT Limit (unit: °C)
Public property | ExternalTemperature | External Temperature (unit: °C)
Public property | InternalALERTHighLimit | Internal ALERT High Limit (unit: °C)
Public property | InternalALERTLowLimit | Internal ALERT Low Limit (unit: °C)
Public property | InternalOVERTLimit | Internal OVERT Limit (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | OVERTHysteresis | OVERT Hysteresis (unit: °C)
Public property | StatusBUSY | Status (BUSY)
Public property | StatusLHIGH | Status (LHIGH)
Public property | StatusLLOW | Status (LLOW)
Public property | StatusOPEN | Status (OPEN)
Public property | StatusOVE | Status (OVE)
Public property | StatusOVI | Status (OVI)
Public property | StatusRHIGH | Status (RHIGH)
Public property | StatusRLOW | Status (RLOW)
Top
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.AutoFlush Property

IRD

Max6680AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.ConfigurationALERTMASK Property

IRD

Max6680ConfigurationALERTMASK Property

Configuration (ALERT MASK)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680ConfigMaskType ConfigurationALERTMASK { get; set; }
Public Property ConfigurationALERTMASK As Max6680ConfigMaskType
    Get
    Set
public:
property Max6680ConfigMaskType ConfigurationALERTMASK {
    Max6680ConfigMaskType get ();
    void set (Max6680ConfigMaskType value);
}
member ConfigurationALERTMASK : Max6680ConfigMaskType with get, set

Property Value

Type: Max6680ConfigMaskType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.ConfigurationExtendedRange Property

IRD

Max6680ConfigurationExtendedRange Property

Configuration (Extended Range)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680ConfigExtRangeType ConfigurationExtendedRange { get; set; }
Public Property ConfigurationExtendedRange As Max6680ConfigExtRangeType
    Get
    Set
public:
property Max6680ConfigExtRangeType ConfigurationExtendedRange {
    Max6680ConfigExtRangeType get ();
    void set (Max6680ConfigExtRangeType value);
}
member ConfigurationExtendedRange : Max6680ConfigExtRangeType with get, set

Property Value

Type: Max6680ConfigExtRangeType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.ConfigurationExtendedResolution Property

IRD

Max6680ConfigurationExtendedResolution Property

Configuration (Extended Resolution)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680ConfigExtResType ConfigurationExtendedResolution { get; set; }
Public Property ConfigurationExtendedResolution As Max6680ConfigExtResType
    Get
    Set
public:
property Max6680ConfigExtResType ConfigurationExtendedResolution {
    Max6680ConfigExtResType get ();
    void set (Max6680ConfigExtResType value);
}
member ConfigurationExtendedResolution : Max6680ConfigExtResType with get, set

Property Value

Type: Max6680ConfigExtResType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.ConfigurationRUNSTOP Property

IRD

Max6680ConfigurationRUNSTOP Property

Configuration (RUN/STOP)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680ConfigRunType ConfigurationRUNSTOP { get; set; }
Public Property ConfigurationRUNSTOP As Max6680ConfigRunType
    Get
    Set
public:
property Max6680ConfigRunType ConfigurationRUNSTOP {
    Max6680ConfigRunType get ();
    void set (Max6680ConfigRunType value);
}
member ConfigurationRUNSTOP : Max6680ConfigRunType with get, set

Property Value

Type: Max6680ConfigRunType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.ConfigurationSMBusTimeout Property

IRD

Max6680ConfigurationSMBusTimeout Property

Configuration (SMBus Timeout)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680ConfigSmbusType ConfigurationSMBusTimeout { get; set; }
Public Property ConfigurationSMBusTimeout As Max6680ConfigSmbusType
    Get
    Set
public:
property Max6680ConfigSmbusType ConfigurationSMBusTimeout {
    Max6680ConfigSmbusType get ();
    void set (Max6680ConfigSmbusType value);
}
member ConfigurationSMBusTimeout : Max6680ConfigSmbusType with get, set

Property Value

Type: Max6680ConfigSmbusType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.ConfigurationSoftwareReset Property

IRD

Max6680ConfigurationSoftwareReset Property

Configuration (Software Reset)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680ConfigResetType ConfigurationSoftwareReset { get; set; }
Public Property ConfigurationSoftwareReset As Max6680ConfigResetType
    Get
    Set
public:
property Max6680ConfigResetType ConfigurationSoftwareReset {
    Max6680ConfigResetType get ();
    void set (Max6680ConfigResetType value);
}
member ConfigurationSoftwareReset : Max6680ConfigResetType with get, set

Property Value

Type: Max6680ConfigResetType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.ConfigurationSPNP Property

IRD

Max6680ConfigurationSPNP Property

Configuration (SPNP)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680ConfigSpnpType ConfigurationSPNP { get; set; }
Public Property ConfigurationSPNP As Max6680ConfigSpnpType
    Get
    Set
public:
property Max6680ConfigSpnpType ConfigurationSPNP {
    Max6680ConfigSpnpType get ();
    void set (Max6680ConfigSpnpType value);
}
member ConfigurationSPNP : Max6680ConfigSpnpType with get, set

Property Value

Type: Max6680ConfigSpnpType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.ConversionRate Property

IRD

Max6680ConversionRate Property

Conversion Rate (unit: Hz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680ConversionRateType ConversionRate { get; set; }
Public Property ConversionRate As Max6680ConversionRateType
    Get
    Set
public:
property Max6680ConversionRateType ConversionRate {
    Max6680ConversionRateType get ();
    void set (Max6680ConversionRateType value);
}
member ConversionRate : Max6680ConversionRateType with get, set

Property Value

Type: Max6680ConversionRateType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.DeviceRevision Property

IRD

Max6680DeviceRevision Property

Device Revision

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceRevision { get; }
Public ReadOnly Property DeviceRevision As Byte
    Get
public:
property unsigned char DeviceRevision {
    unsigned char get ();
}
member DeviceRevision : byte with get

Property Value

Type: Byte
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.ExternalALERTHighLimit Property

IRD

Max6680ExternalALERTHighLimit Property

External ALERT High Limit (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalALERTHighLimit { get; set; }
Public Property ExternalALERTHighLimit As SByte
    Get
    Set
public:
property signed char ExternalALERTHighLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalALERTHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.ExternalALERTLowLimit Property

IRD

Max6680ExternalALERTLowLimit Property

External ALERT Low Limit (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalALERTLowLimit { get; set; }
Public Property ExternalALERTLowLimit As SByte
    Get
    Set
public:
property signed char ExternalALERTLowLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalALERTLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.ExternalExtendedTemperature Property

IRD

Max6680ExternalExtendedTemperature Property

External Extended Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680TempExtType ExternalExtendedTemperature { get; }
Public ReadOnly Property ExternalExtendedTemperature As Max6680TempExtType
    Get
public:
property Max6680TempExtType ExternalExtendedTemperature {
    Max6680TempExtType get ();
}
member ExternalExtendedTemperature : Max6680TempExtType with get

Property Value

Type: Max6680TempExtType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.ExternalOffsetHighByte Property

IRD

Max6680ExternalOffsetHighByte Property

External Offset High Byte (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalOffsetHighByte { get; set; }
Public Property ExternalOffsetHighByte As SByte
    Get
    Set
public:
property signed char ExternalOffsetHighByte {
    signed char get ();
    void set (signed char value);
}
member ExternalOffsetHighByte : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.ExternalOffsetLowByte Property

IRD

Max6680ExternalOffsetLowByte Property

External Offset Low Byte (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680TempExtType ExternalOffsetLowByte { get; set; }
Public Property ExternalOffsetLowByte As Max6680TempExtType
    Get
    Set
public:
property Max6680TempExtType ExternalOffsetLowByte {
    Max6680TempExtType get ();
    void set (Max6680TempExtType value);
}
member ExternalOffsetLowByte : Max6680TempExtType with get, set

Property Value

Type: Max6680TempExtType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.ExternalOVERTLimit Property

IRD

Max6680ExternalOVERTLimit Property

External OVERT Limit (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalOVERTLimit { get; set; }
Public Property ExternalOVERTLimit As SByte
    Get
    Set
public:
property signed char ExternalOVERTLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalOVERTLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.ExternalTemperature Property

IRD

Max6680ExternalTemperature Property

External Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680TempType ExternalTemperature { get; }
Public ReadOnly Property ExternalTemperature As Max6680TempType
    Get
public:
property Max6680TempType ExternalTemperature {
    Max6680TempType get ();
}
member ExternalTemperature : Max6680TempType with get

Property Value

Type: Max6680TempType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.InternalALERTHighLimit Property

IRD

Max6680InternalALERTHighLimit Property

Internal ALERT High Limit (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalALERTHighLimit { get; set; }
Public Property InternalALERTHighLimit As SByte
    Get
    Set
public:
property signed char InternalALERTHighLimit {
    signed char get ();
    void set (signed char value);
}
member InternalALERTHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.InternalALERTLowLimit Property

IRD

Max6680InternalALERTLowLimit Property

Internal ALERT Low Limit (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalALERTLowLimit { get; set; }
Public Property InternalALERTLowLimit As SByte
    Get
    Set
public:
property signed char InternalALERTLowLimit {
    signed char get ();
    void set (signed char value);
}
member InternalALERTLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.InternalOVERTLimit Property

IRD

Max6680InternalOVERTLimit Property

Internal OVERT Limit (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalOVERTLimit { get; set; }
Public Property InternalOVERTLimit As SByte
    Get
    Set
public:
property signed char InternalOVERTLimit {
    signed char get ();
    void set (signed char value);
}
member InternalOVERTLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.InternalTemperature Property

IRD

Max6680InternalTemperature Property

Internal Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680TempType InternalTemperature { get; }
Public ReadOnly Property InternalTemperature As Max6680TempType
    Get
public:
property Max6680TempType InternalTemperature {
    Max6680TempType get ();
}
member InternalTemperature : Max6680TempType with get

Property Value

Type: Max6680TempType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.ManufacturerID Property

IRD

Max6680ManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As Byte
    Get
public:
property unsigned char ManufacturerID {
    unsigned char get ();
}
member ManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.OVERTHysteresis Property

IRD

Max6680OVERTHysteresis Property

OVERT Hysteresis (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte OVERTHysteresis { get; set; }
Public Property OVERTHysteresis As SByte
    Get
    Set
public:
property signed char OVERTHysteresis {
    signed char get ();
    void set (signed char value);
}
member OVERTHysteresis : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.StatusBUSY Property

IRD

Max6680StatusBUSY Property

Status (BUSY)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680StatusBusyType StatusBUSY { get; }
Public ReadOnly Property StatusBUSY As Max6680StatusBusyType
    Get
public:
property Max6680StatusBusyType StatusBUSY {
    Max6680StatusBusyType get ();
}
member StatusBUSY : Max6680StatusBusyType with get

Property Value

Type: Max6680StatusBusyType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.StatusLHIGH Property

IRD

Max6680StatusLHIGH Property

Status (LHIGH)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680StatusLhighType StatusLHIGH { get; }
Public ReadOnly Property StatusLHIGH As Max6680StatusLhighType
    Get
public:
property Max6680StatusLhighType StatusLHIGH {
    Max6680StatusLhighType get ();
}
member StatusLHIGH : Max6680StatusLhighType with get

Property Value

Type: Max6680StatusLhighType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.StatusLLOW Property

IRD

Max6680StatusLLOW Property

Status (LLOW)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680StatusLlowType StatusLLOW { get; }
Public ReadOnly Property StatusLLOW As Max6680StatusLlowType
    Get
public:
property Max6680StatusLlowType StatusLLOW {
    Max6680StatusLlowType get ();
}
member StatusLLOW : Max6680StatusLlowType with get

Property Value

Type: Max6680StatusLlowType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.StatusOPEN Property

IRD

Max6680StatusOPEN Property

Status (OPEN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680StatusOpenType StatusOPEN { get; }
Public ReadOnly Property StatusOPEN As Max6680StatusOpenType
    Get
public:
property Max6680StatusOpenType StatusOPEN {
    Max6680StatusOpenType get ();
}
member StatusOPEN : Max6680StatusOpenType with get

Property Value

Type: Max6680StatusOpenType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.StatusOVE Property

IRD

Max6680StatusOVE Property

Status (OVE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680StatusOveType StatusOVE { get; }
Public ReadOnly Property StatusOVE As Max6680StatusOveType
    Get
public:
property Max6680StatusOveType StatusOVE {
    Max6680StatusOveType get ();
}
member StatusOVE : Max6680StatusOveType with get

Property Value

Type: Max6680StatusOveType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.StatusOVI Property

IRD

Max6680StatusOVI Property

Status (OVI)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680StatusOviType StatusOVI { get; }
Public ReadOnly Property StatusOVI As Max6680StatusOviType
    Get
public:
property Max6680StatusOviType StatusOVI {
    Max6680StatusOviType get ();
}
member StatusOVI : Max6680StatusOviType with get

Property Value

Type: Max6680StatusOviType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.StatusRHIGH Property

IRD

Max6680StatusRHIGH Property

Status (RHIGH)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680StatusRhighType StatusRHIGH { get; }
Public ReadOnly Property StatusRHIGH As Max6680StatusRhighType
    Get
public:
property Max6680StatusRhighType StatusRHIGH {
    Max6680StatusRhighType get ();
}
member StatusRHIGH : Max6680StatusRhighType with get

Property Value

Type: Max6680StatusRhighType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.StatusRLOW Property

IRD

Max6680StatusRLOW Property

Status (RLOW)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6680StatusRlowType StatusRLOW { get; }
Public ReadOnly Property StatusRLOW As Max6680StatusRlowType
    Get
public:
property Max6680StatusRlowType StatusRLOW {
    Max6680StatusRlowType get ();
}
member StatusRLOW : Max6680StatusRlowType with get

Property Value

Type: Max6680StatusRlowType
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680 Methods

The Max6680 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.Flush Method

IRD

Max6680Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.OneShot Method

IRD

Max6680OneShot Method

One-Shot

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void OneShot()
Public Sub OneShot
public:
void OneShot()
member OneShot : unit -> unit
See Also

Reference

Max6680 Class
telos.Ird.Maxim Namespace


Max6680.ConfigExtRangeType Enumeration

IRD

Max6680ConfigExtRangeType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigExtRangeType
Public Enumeration ConfigExtRangeType
public enum class ConfigExtRangeType
type ConfigExtRangeType
Members
Member name | Value | Description
TemperatureRangeExtendedTo64C | 1 | Temperature Range: Extended To -64°C
TemperatureRangeNormal | 0 | Temperature Range: Normal
See Also

Reference

telos.Ird.Maxim Namespace


Max6680.ConfigExtResType Enumeration

IRD

Max6680ConfigExtResType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigExtResType
Public Enumeration ConfigExtResType
public enum class ConfigExtResType
type ConfigExtResType
Members
Member name | Value | Description
RemoteSensorResolutionExtended | 1 | Remote Sensor Resolution: Extended
RemoteSensorResolutionNormal | 0 | Remote Sensor Resolution: Normal
See Also

Reference

telos.Ird.Maxim Namespace


Max6680.ConfigMaskType Enumeration

IRD

Max6680ConfigMaskType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigMaskType
Public Enumeration ConfigMaskType
public enum class ConfigMaskType
type ConfigMaskType
Members
Member name | Value | Description
ALERTInterruptsMasked | 1 | ALERT Interrupts: Masked
ALERTInterruptsNotMasked | 0 | ALERT Interrupts: Not Masked
See Also

Reference

telos.Ird.Maxim Namespace


Max6680.ConfigResetType Enumeration

IRD

Max6680ConfigResetType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigResetType
Public Enumeration ConfigResetType
public enum class ConfigResetType
type ConfigResetType
Members
Member name | Value | Description
SoftwareReset | 1 | Software Reset
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.Maxim Namespace


Max6680.ConfigRunType Enumeration

IRD

Max6680ConfigRunType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigRunType
Public Enumeration ConfigRunType
public enum class ConfigRunType
type ConfigRunType
Members
Member name | Value | Description
Standby | 1 | Standby
OneShotTimerMode | 0 | One-Shot / Timer Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max6680.ConfigSmbusType Enumeration

IRD

Max6680ConfigSmbusType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigSmbusType
Public Enumeration ConfigSmbusType
public enum class ConfigSmbusType
type ConfigSmbusType
Members
Member name | Value | Description
SMBUSTimeoutALERTResponseDisabled | 1 | SMBUS Timeout / ALERT Response: Disabled
SMBUSTimeoutALERTResponseEnabled | 0 | SMBUS Timeout / ALERT Response: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max6680.ConfigSpnpType Enumeration

IRD

Max6680ConfigSpnpType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigSpnpType
Public Enumeration ConfigSpnpType
public enum class ConfigSpnpType
type ConfigSpnpType
Members
Member name | Value | Description
RemoteSensorCommonCollectorSubstratePNP | 1 | Remote Sensor: Common-Collector Substrate PNP
RemoteSensorDiodeConntectedTransistor | 0 | Remote Sensor: Diode-Conntected Transistor
See Also

Reference

telos.Ird.Maxim Namespace


Max6680.ConversionRateType Enumeration

IRD

Max6680ConversionRateType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConversionRateType
Public Enumeration ConversionRateType
public enum class ConversionRateType
type ConversionRateType
Members
Member name | Value | Description
Value_0_0625 | 0 | 0.0625
Value_0_125 | 1 | 0.125
Value_0_25 | 2 | 0.25
Value_0_5 | 3 | 0.5
Value_1 | 4 | 1
Value_2 | 5 | 2
Value_4 | 6 | 4
Value_8 | 7 | 8
See Also

Reference

telos.Ird.Maxim Namespace


Max6680.StatusBusyType Enumeration

IRD

Max6680StatusBusyType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusBusyType
Public Enumeration StatusBusyType
public enum class StatusBusyType
type StatusBusyType
Members
Member name | Value | Description
ADCBusyConverting | 1 | ADC: Busy Converting
ADCNotBusyConverting | 0 | ADC: Not Busy Converting
See Also

Reference

telos.Ird.Maxim Namespace


Max6680.StatusLhighType Enumeration

IRD

Max6680StatusLhighType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusLhighType
Public Enumeration StatusLhighType
public enum class StatusLhighType
type StatusLhighType
Members
Member name | Value | Description
InternalHighTemperatureAlarmTripped | 1 | Internal High Temperature Alarm: Tripped
InternalHighTemperatureAlarmNotTripped | 0 | Internal High Temperature Alarm: Not Tripped
See Also

Reference

telos.Ird.Maxim Namespace


Max6680.StatusLlowType Enumeration

IRD

Max6680StatusLlowType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusLlowType
Public Enumeration StatusLlowType
public enum class StatusLlowType
type StatusLlowType
Members
Member name | Value | Description
InternalLowTemperatureAlarmTripped | 1 | Internal Low Temperature Alarm: Tripped
InternalLowTemperatureAlarmNotTripped | 0 | Internal Low Temperature Alarm: Not Tripped
See Also

Reference

telos.Ird.Maxim Namespace


Max6680.StatusOpenType Enumeration

IRD

Max6680StatusOpenType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusOpenType
Public Enumeration StatusOpenType
public enum class StatusOpenType
type StatusOpenType
Members
Member name | Value | Description
ExternalDiodeOpen | 1 | External Diode: Open
ExternalDiodeOK | 0 | External Diode: OK
See Also

Reference

telos.Ird.Maxim Namespace


Max6680.StatusOveType Enumeration

IRD

Max6680StatusOveType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusOveType
Public Enumeration StatusOveType
public enum class StatusOveType
type StatusOveType
Members
Member name | Value | Description
RWOELimitExceeded | 1 | RWOE Limit: Exceeded
RWOELimitNotExceeded | 0 | RWOE Limit: Not Exceeded
See Also

Reference

telos.Ird.Maxim Namespace


Max6680.StatusOviType Enumeration

IRD

Max6680StatusOviType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusOviType
Public Enumeration StatusOviType
public enum class StatusOviType
type StatusOviType
Members
Member name | Value | Description
RWOILimitExceeded | 1 | RWOI Limit: Exceeded
RWOILimitNotExceeded | 0 | RWOI Limit: Not Exceeded
See Also

Reference

telos.Ird.Maxim Namespace


Max6680.StatusRhighType Enumeration

IRD

Max6680StatusRhighType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusRhighType
Public Enumeration StatusRhighType
public enum class StatusRhighType
type StatusRhighType
Members
Member name | Value | Description
ExternalHighTemperatureAlarmTripped | 1 | External High Temperature Alarm: Tripped
ExternalHighTemperatureAlarmNotTripped | 0 | External High Temperature Alarm: Not Tripped
See Also

Reference

telos.Ird.Maxim Namespace


Max6680.StatusRlowType Enumeration

IRD

Max6680StatusRlowType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusRlowType
Public Enumeration StatusRlowType
public enum class StatusRlowType
type StatusRlowType
Members
Member name | Value | Description
ExternalLowTemperatureAlarmTripped | 1 | External Low Temperature Alarm: Tripped
ExternalLowTemperatureAlarmNotTripped | 0 | External Low Temperature Alarm: Not Tripped
See Also

Reference

telos.Ird.Maxim Namespace


Max6680.TempExtType Enumeration

IRD

Max6680TempExtType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TempExtType
Public Enumeration TempExtType
public enum class TempExtType
type TempExtType
Members
Member name | Value | Description
Value_0_000 | 0 | 0.000
Value_0_125 | 1 | 0.125
Value_0_250 | 2 | 0.250
Value_0_375 | 3 | 0.375
Value_0_500 | 4 | 0.500
Value_0_625 | 5 | 0.625
Value_0_750 | 6 | 0.750
Value_0_875 | 7 | 0.875
See Also

Reference

telos.Ird.Maxim Namespace


Max6680.TempType Enumeration

IRD

Max6680TempType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TempType
Public Enumeration TempType
public enum class TempType
type TempType
Members
Member name | Value | Description
DiodeFault | -128 | Diode Fault
See Also

Reference

telos.Ird.Maxim Namespace


Max6690 Class

Maxim: MAX 6690
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax6690

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max6690
Public Class Max6690
public ref class Max6690
type Max6690 =  class end

The Max6690 type exposes the following members.

Constructors
 | Name | Description
Public method | Max6690 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationETA | Configuration (ETA)
Public property | ConfigurationMASK1 | Configuration (MASK1)
Public property | ConfigurationPRCM | Configuration (PRCM)
Public property | ConfigurationRUNSTOP | Configuration (RUN/STOP)
Public property | ConversionRate | Conversion Rate (unit: Hz)
Public property | DeviceID | Device ID
Public property | DeviceRevision | Device Revision
Public property | ExternalExtendedTemperature | External Extended Temperature (unit: °C)
Public property | ExternalHighLimit | External High Limit (unit: °C)
Public property | ExternalLowLimit | External Low Limit (unit: °C)
Public property | ExternalTemperature | External Temperature (unit: °C)
Public property | InternalExtendedTemperature | Internal Extended Temperature (unit: °C)
Public property | InternalHighLimit | Internal High Limit (unit: °C)
Public property | InternalLowLimit | Internal Low Limit (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | StatusBUSY | Status (BUSY)
Public property | StatusLHIGH | Status (LHIGH)
Public property | StatusLLOW | Status (LLOW)
Public property | StatusOPEN | Status (OPEN)
Public property | StatusRHIGH | Status (RHIGH)
Public property | StatusRLOW | Status (RLOW)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
2°C Accurate Remote/Local Temperature Sensor
See Also

Reference

telos.Ird.Maxim Namespace


Max6690 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max6690(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max6690

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690 Properties

The Max6690 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationETA | Configuration (ETA)
Public property | ConfigurationMASK1 | Configuration (MASK1)
Public property | ConfigurationPRCM | Configuration (PRCM)
Public property | ConfigurationRUNSTOP | Configuration (RUN/STOP)
Public property | ConversionRate | Conversion Rate (unit: Hz)
Public property | DeviceID | Device ID
Public property | DeviceRevision | Device Revision
Public property | ExternalExtendedTemperature | External Extended Temperature (unit: °C)
Public property | ExternalHighLimit | External High Limit (unit: °C)
Public property | ExternalLowLimit | External Low Limit (unit: °C)
Public property | ExternalTemperature | External Temperature (unit: °C)
Public property | InternalExtendedTemperature | Internal Extended Temperature (unit: °C)
Public property | InternalHighLimit | Internal High Limit (unit: °C)
Public property | InternalLowLimit | Internal Low Limit (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | StatusBUSY | Status (BUSY)
Public property | StatusLHIGH | Status (LHIGH)
Public property | StatusLLOW | Status (LLOW)
Public property | StatusOPEN | Status (OPEN)
Public property | StatusRHIGH | Status (RHIGH)
Public property | StatusRLOW | Status (RLOW)
Top
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.AutoFlush Property

IRD

Max6690AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.ConfigurationETA Property

IRD

Max6690ConfigurationETA Property

Configuration (ETA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690ConfigEtaType ConfigurationETA { get; set; }
Public Property ConfigurationETA As Max6690ConfigEtaType
    Get
    Set
public:
property Max6690ConfigEtaType ConfigurationETA {
    Max6690ConfigEtaType get ();
    void set (Max6690ConfigEtaType value);
}
member ConfigurationETA : Max6690ConfigEtaType with get, set

Property Value

Type: Max6690ConfigEtaType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.ConfigurationMASK1 Property

IRD

Max6690ConfigurationMASK1 Property

Configuration (MASK1)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690ConfigMaskType ConfigurationMASK1 { get; set; }
Public Property ConfigurationMASK1 As Max6690ConfigMaskType
    Get
    Set
public:
property Max6690ConfigMaskType ConfigurationMASK1 {
    Max6690ConfigMaskType get ();
    void set (Max6690ConfigMaskType value);
}
member ConfigurationMASK1 : Max6690ConfigMaskType with get, set

Property Value

Type: Max6690ConfigMaskType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.ConfigurationPRCM Property

IRD

Max6690ConfigurationPRCM Property

Configuration (PRCM)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690ConfigPrcmType ConfigurationPRCM { get; set; }
Public Property ConfigurationPRCM As Max6690ConfigPrcmType
    Get
    Set
public:
property Max6690ConfigPrcmType ConfigurationPRCM {
    Max6690ConfigPrcmType get ();
    void set (Max6690ConfigPrcmType value);
}
member ConfigurationPRCM : Max6690ConfigPrcmType with get, set

Property Value

Type: Max6690ConfigPrcmType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.ConfigurationRUNSTOP Property

IRD

Max6690ConfigurationRUNSTOP Property

Configuration (RUN/STOP)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690ConfigRunType ConfigurationRUNSTOP { get; set; }
Public Property ConfigurationRUNSTOP As Max6690ConfigRunType
    Get
    Set
public:
property Max6690ConfigRunType ConfigurationRUNSTOP {
    Max6690ConfigRunType get ();
    void set (Max6690ConfigRunType value);
}
member ConfigurationRUNSTOP : Max6690ConfigRunType with get, set

Property Value

Type: Max6690ConfigRunType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.ConversionRate Property

IRD

Max6690ConversionRate Property

Conversion Rate (unit: Hz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690ConversionRateType ConversionRate { get; set; }
Public Property ConversionRate As Max6690ConversionRateType
    Get
    Set
public:
property Max6690ConversionRateType ConversionRate {
    Max6690ConversionRateType get ();
    void set (Max6690ConversionRateType value);
}
member ConversionRate : Max6690ConversionRateType with get, set

Property Value

Type: Max6690ConversionRateType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.DeviceID Property

IRD

Max6690DeviceID Property

Device ID

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.DeviceRevision Property

IRD

Max6690DeviceRevision Property

Device Revision

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceRevision { get; }
Public ReadOnly Property DeviceRevision As Byte
    Get
public:
property unsigned char DeviceRevision {
    unsigned char get ();
}
member DeviceRevision : byte with get

Property Value

Type: Byte
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.ExternalExtendedTemperature Property

IRD

Max6690ExternalExtendedTemperature Property

External Extended Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690TempExtType ExternalExtendedTemperature { get; }
Public ReadOnly Property ExternalExtendedTemperature As Max6690TempExtType
    Get
public:
property Max6690TempExtType ExternalExtendedTemperature {
    Max6690TempExtType get ();
}
member ExternalExtendedTemperature : Max6690TempExtType with get

Property Value

Type: Max6690TempExtType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.ExternalHighLimit Property

IRD

Max6690ExternalHighLimit Property

External High Limit (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690TempType ExternalHighLimit { get; set; }
Public Property ExternalHighLimit As Max6690TempType
    Get
    Set
public:
property Max6690TempType ExternalHighLimit {
    Max6690TempType get ();
    void set (Max6690TempType value);
}
member ExternalHighLimit : Max6690TempType with get, set

Property Value

Type: Max6690TempType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.ExternalLowLimit Property

IRD

Max6690ExternalLowLimit Property

External Low Limit (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690TempType ExternalLowLimit { get; set; }
Public Property ExternalLowLimit As Max6690TempType
    Get
    Set
public:
property Max6690TempType ExternalLowLimit {
    Max6690TempType get ();
    void set (Max6690TempType value);
}
member ExternalLowLimit : Max6690TempType with get, set

Property Value

Type: Max6690TempType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.ExternalTemperature Property

IRD

Max6690ExternalTemperature Property

External Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690TempType ExternalTemperature { get; }
Public ReadOnly Property ExternalTemperature As Max6690TempType
    Get
public:
property Max6690TempType ExternalTemperature {
    Max6690TempType get ();
}
member ExternalTemperature : Max6690TempType with get

Property Value

Type: Max6690TempType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.InternalExtendedTemperature Property

IRD

Max6690InternalExtendedTemperature Property

Internal Extended Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690TempExtType InternalExtendedTemperature { get; }
Public ReadOnly Property InternalExtendedTemperature As Max6690TempExtType
    Get
public:
property Max6690TempExtType InternalExtendedTemperature {
    Max6690TempExtType get ();
}
member InternalExtendedTemperature : Max6690TempExtType with get

Property Value

Type: Max6690TempExtType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.InternalHighLimit Property

IRD

Max6690InternalHighLimit Property

Internal High Limit (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690TempType InternalHighLimit { get; set; }
Public Property InternalHighLimit As Max6690TempType
    Get
    Set
public:
property Max6690TempType InternalHighLimit {
    Max6690TempType get ();
    void set (Max6690TempType value);
}
member InternalHighLimit : Max6690TempType with get, set

Property Value

Type: Max6690TempType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.InternalLowLimit Property

IRD

Max6690InternalLowLimit Property

Internal Low Limit (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690TempType InternalLowLimit { get; set; }
Public Property InternalLowLimit As Max6690TempType
    Get
    Set
public:
property Max6690TempType InternalLowLimit {
    Max6690TempType get ();
    void set (Max6690TempType value);
}
member InternalLowLimit : Max6690TempType with get, set

Property Value

Type: Max6690TempType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.InternalTemperature Property

IRD

Max6690InternalTemperature Property

Internal Temperature (unit: °C)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690TempType InternalTemperature { get; }
Public ReadOnly Property InternalTemperature As Max6690TempType
    Get
public:
property Max6690TempType InternalTemperature {
    Max6690TempType get ();
}
member InternalTemperature : Max6690TempType with get

Property Value

Type: Max6690TempType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.StatusBUSY Property

IRD

Max6690StatusBUSY Property

Status (BUSY)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690StatusBusyType StatusBUSY { get; }
Public ReadOnly Property StatusBUSY As Max6690StatusBusyType
    Get
public:
property Max6690StatusBusyType StatusBUSY {
    Max6690StatusBusyType get ();
}
member StatusBUSY : Max6690StatusBusyType with get

Property Value

Type: Max6690StatusBusyType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.StatusLHIGH Property

IRD

Max6690StatusLHIGH Property

Status (LHIGH)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690StatusLhighType StatusLHIGH { get; }
Public ReadOnly Property StatusLHIGH As Max6690StatusLhighType
    Get
public:
property Max6690StatusLhighType StatusLHIGH {
    Max6690StatusLhighType get ();
}
member StatusLHIGH : Max6690StatusLhighType with get

Property Value

Type: Max6690StatusLhighType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.StatusLLOW Property

IRD

Max6690StatusLLOW Property

Status (LLOW)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690StatusLlowType StatusLLOW { get; }
Public ReadOnly Property StatusLLOW As Max6690StatusLlowType
    Get
public:
property Max6690StatusLlowType StatusLLOW {
    Max6690StatusLlowType get ();
}
member StatusLLOW : Max6690StatusLlowType with get

Property Value

Type: Max6690StatusLlowType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.StatusOPEN Property

IRD

Max6690StatusOPEN Property

Status (OPEN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690StatusOpenType StatusOPEN { get; }
Public ReadOnly Property StatusOPEN As Max6690StatusOpenType
    Get
public:
property Max6690StatusOpenType StatusOPEN {
    Max6690StatusOpenType get ();
}
member StatusOPEN : Max6690StatusOpenType with get

Property Value

Type: Max6690StatusOpenType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.StatusRHIGH Property

IRD

Max6690StatusRHIGH Property

Status (RHIGH)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690StatusRhighType StatusRHIGH { get; }
Public ReadOnly Property StatusRHIGH As Max6690StatusRhighType
    Get
public:
property Max6690StatusRhighType StatusRHIGH {
    Max6690StatusRhighType get ();
}
member StatusRHIGH : Max6690StatusRhighType with get

Property Value

Type: Max6690StatusRhighType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.StatusRLOW Property

IRD

Max6690StatusRLOW Property

Status (RLOW)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6690StatusRlowType StatusRLOW { get; }
Public ReadOnly Property StatusRLOW As Max6690StatusRlowType
    Get
public:
property Max6690StatusRlowType StatusRLOW {
    Max6690StatusRlowType get ();
}
member StatusRLOW : Max6690StatusRlowType with get

Property Value

Type: Max6690StatusRlowType
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690 Methods

The Max6690 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.Flush Method

IRD

Max6690Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.OneShot Method

IRD

Max6690OneShot Method

One-Shot

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void OneShot()
Public Sub OneShot
public:
void OneShot()
member OneShot : unit -> unit
See Also

Reference

Max6690 Class
telos.Ird.Maxim Namespace


Max6690.ConfigEtaType Enumeration

IRD

Max6690ConfigEtaType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigEtaType
Public Enumeration ConfigEtaType
public enum class ConfigEtaType
type ConfigEtaType
Members
Member name | Value | Description
LowerTemperatureRangeExtended | 1 | Lower Temperature Range: Extended
LowerTemperatureRangeNotExtended | 0 | Lower Temperature Range: Not Extended
See Also

Reference

telos.Ird.Maxim Namespace


Max6690.ConfigMaskType Enumeration

IRD

Max6690ConfigMaskType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigMaskType
Public Enumeration ConfigMaskType
public enum class ConfigMaskType
type ConfigMaskType
Members
Member name | Value | Description
ALERTInterruptsMasked | 1 | ALERT Interrupts: Masked
ALERTInterruptsNotMasked | 0 | ALERT Interrupts: Not Masked
See Also

Reference

telos.Ird.Maxim Namespace


Max6690.ConfigPrcmType Enumeration

IRD

Max6690ConfigPrcmType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigPrcmType
Public Enumeration ConfigPrcmType
public enum class ConfigPrcmType
type ConfigPrcmType
Members
Member name | Value | Description
ParasiticResistanceCancellationEnabled | 1 | Parasitic Resistance Cancellation: Enabled
ParasiticResistanceCancellationDisabled | 0 | Parasitic Resistance Cancellation: Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Max6690.ConfigRunType Enumeration

IRD

Max6690ConfigRunType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigRunType
Public Enumeration ConfigRunType
public enum class ConfigRunType
type ConfigRunType
Members
Member name | Value | Description
Standby | 1 | Standby
Autoconvert | 0 | Autoconvert
See Also

Reference

telos.Ird.Maxim Namespace


Max6690.ConversionRateType Enumeration

IRD

Max6690ConversionRateType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConversionRateType
Public Enumeration ConversionRateType
public enum class ConversionRateType
type ConversionRateType
Members
Member name | Value | Description
Value_0_0625 | 0 | 0.0625
Value_0_125 | 1 | 0.125
Value_0_25 | 2 | 0.25
Value_0_5 | 3 | 0.5
Value_1 | 4 | 1
Value_2 | 5 | 2
Value_4 | 6 | 4
Value_8 | 7 | 8
See Also

Reference

telos.Ird.Maxim Namespace


Max6690.StatusBusyType Enumeration

IRD

Max6690StatusBusyType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusBusyType
Public Enumeration StatusBusyType
public enum class StatusBusyType
type StatusBusyType
Members
Member name | Value | Description
ADCBusyConverting | 1 | ADC: Busy Converting
ADCNotBusyConverting | 0 | ADC: Not Busy Converting
See Also

Reference

telos.Ird.Maxim Namespace


Max6690.StatusLhighType Enumeration

IRD

Max6690StatusLhighType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusLhighType
Public Enumeration StatusLhighType
public enum class StatusLhighType
type StatusLhighType
Members
Member name | Value | Description
LocalHighTemperatureAlarmTripped | 1 | Local High Temperature Alarm: Tripped
LocalHighTemperatureAlarmNotTripped | 0 | Local High Temperature Alarm: Not Tripped
See Also

Reference

telos.Ird.Maxim Namespace


Max6690.StatusLlowType Enumeration

IRD

Max6690StatusLlowType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusLlowType
Public Enumeration StatusLlowType
public enum class StatusLlowType
type StatusLlowType
Members
Member name | Value | Description
LocalLowTemperatureAlarmTripped | 1 | Local Low Temperature Alarm: Tripped
LocalLowTemperatureAlarmNotTripped | 0 | Local Low Temperature Alarm: Not Tripped
See Also

Reference

telos.Ird.Maxim Namespace


Max6690.StatusOpenType Enumeration

IRD

Max6690StatusOpenType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusOpenType
Public Enumeration StatusOpenType
public enum class StatusOpenType
type StatusOpenType
Members
Member name | Value | Description
ExternalDiodeOpen | 1 | External Diode: Open
ExternalDiodeOK | 0 | External Diode: OK
See Also

Reference

telos.Ird.Maxim Namespace


Max6690.StatusRhighType Enumeration

IRD

Max6690StatusRhighType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusRhighType
Public Enumeration StatusRhighType
public enum class StatusRhighType
type StatusRhighType
Members
Member name | Value | Description
ExternalHighTemperatureAlarmTripped | 1 | External High Temperature Alarm: Tripped
ExternalHighTemperatureAlarmNotTripped | 0 | External High Temperature Alarm: Not Tripped
See Also

Reference

telos.Ird.Maxim Namespace


Max6690.StatusRlowType Enumeration

IRD

Max6690StatusRlowType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusRlowType
Public Enumeration StatusRlowType
public enum class StatusRlowType
type StatusRlowType
Members
Member name | Value | Description
ExternalLowTemperatureAlarmTripped | 1 | External Low Temperature Alarm: Tripped
ExternalLowTemperatureAlarmNotTripped | 0 | External Low Temperature Alarm: Not Tripped
See Also

Reference

telos.Ird.Maxim Namespace


Max6690.TempExtType Enumeration

IRD

Max6690TempExtType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TempExtType
Public Enumeration TempExtType
public enum class TempExtType
type TempExtType
Members
Member name | Value | Description
Value_0_000 | 0 | 0.000
Value_0_125 | 1 | 0.125
Value_0_250 | 2 | 0.250
Value_0_375 | 3 | 0.375
Value_0_500 | 4 | 0.500
Value_0_625 | 5 | 0.625
Value_0_750 | 6 | 0.750
Value_0_875 | 7 | 0.875
See Also

Reference

telos.Ird.Maxim Namespace


Max6690.TempType Enumeration

IRD

Max6690TempType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TempType
Public Enumeration TempType
public enum class TempType
type TempType
Members
Member name | Value | Description
DiodeFault | -128 | Diode Fault
See Also

Reference

telos.Ird.Maxim Namespace


Max6900 Class

Maxim: MAX 6900
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax6900

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max6900
Public Class Max6900
public ref class Max6900
type Max6900 =  class end

The Max6900 type exposes the following members.

Constructors
 | Name | Description
Public method | Max6900 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Century | Century
Public property | ClockBurstMode | Clock Burst Mode
Public property | Date | Date
Public property | Hours | Hours (unit: hour)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | Seconds | Seconds (unit: s)
Public property | Switch12To24Hours1224 | Switch 12 To 24 Hours (12/24)
Public property | WeekDay | Week Day
Public property | WriteProtection | Write Protection
Public property | Year | Year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
RTC In A TDFN
See Also

Reference

telos.Ird.Maxim Namespace


Max6900 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6900(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max6900(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max6900

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max6900 Class
telos.Ird.Maxim Namespace


Max6900 Properties

The Max6900 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Century | Century
Public property | ClockBurstMode | Clock Burst Mode
Public property | Date | Date
Public property | Hours | Hours (unit: hour)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | Seconds | Seconds (unit: s)
Public property | Switch12To24Hours1224 | Switch 12 To 24 Hours (12/24)
Public property | WeekDay | Week Day
Public property | WriteProtection | Write Protection
Public property | Year | Year
Top
See Also

Reference

Max6900 Class
telos.Ird.Maxim Namespace


Max6900.AutoFlush Property

IRD

Max6900AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max6900 Class
telos.Ird.Maxim Namespace


Max6900.Century Property

IRD

Max6900Century Property

Century

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Century { get; set; }
Public Property Century As Byte
    Get
    Set
public:
property unsigned char Century {
    unsigned char get ();
    void set (unsigned char value);
}
member Century : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6900 Class
telos.Ird.Maxim Namespace


Max6900.ClockBurstMode Property

IRD

Max6900ClockBurstMode Property

Clock Burst Mode

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ClockBurstMode { get; set; }
Public Property ClockBurstMode As Byte
    Get
    Set
public:
property unsigned char ClockBurstMode {
    unsigned char get ();
    void set (unsigned char value);
}
member ClockBurstMode : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6900 Class
telos.Ird.Maxim Namespace


Max6900.Date Property

IRD

Max6900Date Property

Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Date { get; set; }
Public Property Date As Byte
    Get
    Set
public:
property unsigned char Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6900 Class
telos.Ird.Maxim Namespace


Max6900.Hours Property

IRD

Max6900Hours Property

Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Hours { get; set; }
Public Property Hours As Byte
    Get
    Set
public:
property unsigned char Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6900 Class
telos.Ird.Maxim Namespace


Max6900.Minutes Property

IRD

Max6900Minutes Property

Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Minutes { get; set; }
Public Property Minutes As Byte
    Get
    Set
public:
property unsigned char Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6900 Class
telos.Ird.Maxim Namespace


Max6900.Month Property

IRD

Max6900Month Property

Month

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Month { get; set; }
Public Property Month As Byte
    Get
    Set
public:
property unsigned char Month {
    unsigned char get ();
    void set (unsigned char value);
}
member Month : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6900 Class
telos.Ird.Maxim Namespace


Max6900.Seconds Property

IRD

Max6900Seconds Property

Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Seconds { get; set; }
Public Property Seconds As Byte
    Get
    Set
public:
property unsigned char Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6900 Class
telos.Ird.Maxim Namespace


Max6900.Switch12To24Hours1224 Property

IRD

Max6900Switch12To24Hours1224 Property

Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6900H1224Type Switch12To24Hours1224 { get; set; }
Public Property Switch12To24Hours1224 As Max6900H1224Type
    Get
    Set
public:
property Max6900H1224Type Switch12To24Hours1224 {
    Max6900H1224Type get ();
    void set (Max6900H1224Type value);
}
member Switch12To24Hours1224 : Max6900H1224Type with get, set

Property Value

Type: Max6900H1224Type
See Also

Reference

Max6900 Class
telos.Ird.Maxim Namespace


Max6900.WeekDay Property

IRD

Max6900WeekDay Property

Week Day

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WeekDay { get; set; }
Public Property WeekDay As Byte
    Get
    Set
public:
property unsigned char WeekDay {
    unsigned char get ();
    void set (unsigned char value);
}
member WeekDay : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6900 Class
telos.Ird.Maxim Namespace


Max6900.WriteProtection Property

IRD

Max6900WriteProtection Property

Write Protection

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6900ProtectType WriteProtection { get; set; }
Public Property WriteProtection As Max6900ProtectType
    Get
    Set
public:
property Max6900ProtectType WriteProtection {
    Max6900ProtectType get ();
    void set (Max6900ProtectType value);
}
member WriteProtection : Max6900ProtectType with get, set

Property Value

Type: Max6900ProtectType
See Also

Reference

Max6900 Class
telos.Ird.Maxim Namespace


Max6900.Year Property

IRD

Max6900Year Property

Year

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Year { get; set; }
Public Property Year As Byte
    Get
    Set
public:
property unsigned char Year {
    unsigned char get ();
    void set (unsigned char value);
}
member Year : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6900 Class
telos.Ird.Maxim Namespace


Max6900 Methods

The Max6900 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max6900 Class
telos.Ird.Maxim Namespace


Max6900.Flush Method

IRD

Max6900Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max6900 Class
telos.Ird.Maxim Namespace


Max6900.H1224Type Enumeration

IRD

Max6900H1224Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum H1224Type
Public Enumeration H1224Type
public enum class H1224Type
type H1224Type
Members
Member name | Value | Description
Value_12Hours | 1 | 12 Hours
Value_24Hours | 0 | 24 Hours
See Also

Reference

telos.Ird.Maxim Namespace


Max6900.ProtectType Enumeration

IRD

Max6900ProtectType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ProtectType
Public Enumeration ProtectType
public enum class ProtectType
type ProtectType
Members
Member name | Value | Description
WriteProtectionEnable | 1 | Write Protection Enable
WriteProtectionDisable | 0 | Write Protection Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910 Class

Maxim: MAX 6909 / 6910
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax69096910

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max69096910
Public Class Max69096910
public ref class Max69096910
type Max69096910 =  class end

The Max69096910 type exposes the following members.

Constructors
 | Name | Description
Public method | Max69096910 | Constructor
Top
Properties
 | Name | Description
Public property | AlarmDate | Alarm Date
Public property | AlarmHours | Alarm Hours (unit: hour)
Public property | AlarmMinutes | Alarm Minutes (unit: min)
Public property | AlarmMonth | Alarm Month
Public property | AlarmOutStatusALMOUT | Alarm Out Status (ALM OUT)
Public property | AlarmSeconds | Alarm Seconds (unit: s)
Public property | AlarmSwitch12To24Hours1224 | Alarm Switch 12 To 24 Hours (12/24)
Public property | AlarmWeekDay | Alarm Week Day
Public property | AlarmYear | Alarm Year
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Century | Century
Public property | ClockBurstMode | Clock Burst Mode
Public property | CrystalFailDetectEnableCXFAILEN | Crystal Fail Detect Enable (CX FAIL EN)
Public property | CrystalFailureCXFAIL | Crystal Failure (CX FAIL)
Public property | Date | Date
Public property | DiodeSelectDSx | Diode Select (DSx)
Public property | Hours | Hours (unit: hour)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | PiezoTransducerControlPZTCNTLPZTSEL | Piezo Transducer Control (PZT CNTL, PZT SEL)
Public property | PiezoTransducerSelectFrequencyPZTFREQ | Piezo Transducer Select Frequency (PZT FREQ) (unit: kHz)
Public property | ResistorSelectRSx | Resistor Select (RSx)
Public property | Seconds | Seconds (unit: s)
Public property | Switch12To24Hours1224 | Switch 12 To 24 Hours (12/24)
Public property | TrickleChargeTCSx | Trickle Charge (TCSx)
Public property | TriggerAlarmOnASpecificDateDATE | Trigger Alarm On A Specific Date (DATE)
Public property | TriggerAlarmOnASpecificDayDAY | Trigger Alarm On A Specific Day (DAY)
Public property | TriggerAlarmOnASpecificHourHOUR | Trigger Alarm On A Specific Hour (HOUR)
Public property | TriggerAlarmOnASpecificMinuteMIN | Trigger Alarm On A Specific Minute (MIN)
Public property | TriggerAlarmOnASpecificMonthMONTH | Trigger Alarm On A Specific Month (MONTH)
Public property | TriggerAlarmOnASpecificSecondSEC | Trigger Alarm On A Specific Second (SEC)
Public property | TriggerAlarmOnASpecificYearYEAR | Trigger Alarm On A Specific Year (YEAR)
Public property | WatchdogEnableWDEN | Watchdog Enable (WD EN)
Public property | WatchdogTimeoutWDTIME | Watchdog Timeout (WD TIME)
Public property | WeekDay | Week Day
Public property | WriteProtection | Write Protection
Public property | Year | Year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
RTC With uP Supervisor And NV RAM Controller
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max69096910(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max69096910

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910 Properties

The Max69096910 type exposes the following members.

Properties
 | Name | Description
Public property | AlarmDate | Alarm Date
Public property | AlarmHours | Alarm Hours (unit: hour)
Public property | AlarmMinutes | Alarm Minutes (unit: min)
Public property | AlarmMonth | Alarm Month
Public property | AlarmOutStatusALMOUT | Alarm Out Status (ALM OUT)
Public property | AlarmSeconds | Alarm Seconds (unit: s)
Public property | AlarmSwitch12To24Hours1224 | Alarm Switch 12 To 24 Hours (12/24)
Public property | AlarmWeekDay | Alarm Week Day
Public property | AlarmYear | Alarm Year
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Century | Century
Public property | ClockBurstMode | Clock Burst Mode
Public property | CrystalFailDetectEnableCXFAILEN | Crystal Fail Detect Enable (CX FAIL EN)
Public property | CrystalFailureCXFAIL | Crystal Failure (CX FAIL)
Public property | Date | Date
Public property | DiodeSelectDSx | Diode Select (DSx)
Public property | Hours | Hours (unit: hour)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | PiezoTransducerControlPZTCNTLPZTSEL | Piezo Transducer Control (PZT CNTL, PZT SEL)
Public property | PiezoTransducerSelectFrequencyPZTFREQ | Piezo Transducer Select Frequency (PZT FREQ) (unit: kHz)
Public property | ResistorSelectRSx | Resistor Select (RSx)
Public property | Seconds | Seconds (unit: s)
Public property | Switch12To24Hours1224 | Switch 12 To 24 Hours (12/24)
Public property | TrickleChargeTCSx | Trickle Charge (TCSx)
Public property | TriggerAlarmOnASpecificDateDATE | Trigger Alarm On A Specific Date (DATE)
Public property | TriggerAlarmOnASpecificDayDAY | Trigger Alarm On A Specific Day (DAY)
Public property | TriggerAlarmOnASpecificHourHOUR | Trigger Alarm On A Specific Hour (HOUR)
Public property | TriggerAlarmOnASpecificMinuteMIN | Trigger Alarm On A Specific Minute (MIN)
Public property | TriggerAlarmOnASpecificMonthMONTH | Trigger Alarm On A Specific Month (MONTH)
Public property | TriggerAlarmOnASpecificSecondSEC | Trigger Alarm On A Specific Second (SEC)
Public property | TriggerAlarmOnASpecificYearYEAR | Trigger Alarm On A Specific Year (YEAR)
Public property | WatchdogEnableWDEN | Watchdog Enable (WD EN)
Public property | WatchdogTimeoutWDTIME | Watchdog Timeout (WD TIME)
Public property | WeekDay | Week Day
Public property | WriteProtection | Write Protection
Public property | Year | Year
Top
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.AlarmDate Property

IRD

Max69096910AlarmDate Property

Alarm Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmDate { get; set; }
Public Property AlarmDate As Byte
    Get
    Set
public:
property unsigned char AlarmDate {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmDate : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.AlarmHours Property

IRD

Max69096910AlarmHours Property

Alarm Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmHours { get; set; }
Public Property AlarmHours As Byte
    Get
    Set
public:
property unsigned char AlarmHours {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmHours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.AlarmMinutes Property

IRD

Max69096910AlarmMinutes Property

Alarm Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmMinutes { get; set; }
Public Property AlarmMinutes As Byte
    Get
    Set
public:
property unsigned char AlarmMinutes {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmMinutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.AlarmMonth Property

IRD

Max69096910AlarmMonth Property

Alarm Month

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmMonth { get; set; }
Public Property AlarmMonth As Byte
    Get
    Set
public:
property unsigned char AlarmMonth {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmMonth : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.AlarmOutStatusALMOUT Property

IRD

Max69096910AlarmOutStatusALMOUT Property

Alarm Out Status (ALM OUT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910AlarmStatusType AlarmOutStatusALMOUT { get; set; }
Public Property AlarmOutStatusALMOUT As Max69096910AlarmStatusType
    Get
    Set
public:
property Max69096910AlarmStatusType AlarmOutStatusALMOUT {
    Max69096910AlarmStatusType get ();
    void set (Max69096910AlarmStatusType value);
}
member AlarmOutStatusALMOUT : Max69096910AlarmStatusType with get, set

Property Value

Type: Max69096910AlarmStatusType
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.AlarmSeconds Property

IRD

Max69096910AlarmSeconds Property

Alarm Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmSeconds { get; set; }
Public Property AlarmSeconds As Byte
    Get
    Set
public:
property unsigned char AlarmSeconds {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmSeconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.AlarmSwitch12To24Hours1224 Property

IRD

Max69096910AlarmSwitch12To24Hours1224 Property

Alarm Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910H1224Type AlarmSwitch12To24Hours1224 { get; set; }
Public Property AlarmSwitch12To24Hours1224 As Max69096910H1224Type
    Get
    Set
public:
property Max69096910H1224Type AlarmSwitch12To24Hours1224 {
    Max69096910H1224Type get ();
    void set (Max69096910H1224Type value);
}
member AlarmSwitch12To24Hours1224 : Max69096910H1224Type with get, set

Property Value

Type: Max69096910H1224Type
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.AlarmWeekDay Property

IRD

Max69096910AlarmWeekDay Property

Alarm Week Day

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmWeekDay { get; set; }
Public Property AlarmWeekDay As Byte
    Get
    Set
public:
property unsigned char AlarmWeekDay {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmWeekDay : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.AlarmYear Property

IRD

Max69096910AlarmYear Property

Alarm Year

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmYear { get; set; }
Public Property AlarmYear As Byte
    Get
    Set
public:
property unsigned char AlarmYear {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmYear : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.AutoFlush Property

IRD

Max69096910AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.Century Property

IRD

Max69096910Century Property

Century

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Century { get; set; }
Public Property Century As Byte
    Get
    Set
public:
property unsigned char Century {
    unsigned char get ();
    void set (unsigned char value);
}
member Century : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.ClockBurstMode Property

IRD

Max69096910ClockBurstMode Property

Clock Burst Mode

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ClockBurstMode { get; set; }
Public Property ClockBurstMode As Byte
    Get
    Set
public:
property unsigned char ClockBurstMode {
    unsigned char get ();
    void set (unsigned char value);
}
member ClockBurstMode : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.CrystalFailDetectEnableCXFAILEN Property

IRD

Max69096910CrystalFailDetectEnableCXFAILEN Property

Crystal Fail Detect Enable (CX FAIL EN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910CrystalDetectType CrystalFailDetectEnableCXFAILEN { get; set; }
Public Property CrystalFailDetectEnableCXFAILEN As Max69096910CrystalDetectType
    Get
    Set
public:
property Max69096910CrystalDetectType CrystalFailDetectEnableCXFAILEN {
    Max69096910CrystalDetectType get ();
    void set (Max69096910CrystalDetectType value);
}
member CrystalFailDetectEnableCXFAILEN : Max69096910CrystalDetectType with get, set

Property Value

Type: Max69096910CrystalDetectType
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.CrystalFailureCXFAIL Property

IRD

Max69096910CrystalFailureCXFAIL Property

Crystal Failure (CX FAIL)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910CrystalDetectType CrystalFailureCXFAIL { get; set; }
Public Property CrystalFailureCXFAIL As Max69096910CrystalDetectType
    Get
    Set
public:
property Max69096910CrystalDetectType CrystalFailureCXFAIL {
    Max69096910CrystalDetectType get ();
    void set (Max69096910CrystalDetectType value);
}
member CrystalFailureCXFAIL : Max69096910CrystalDetectType with get, set

Property Value

Type: Max69096910CrystalDetectType
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.Date Property

IRD

Max69096910Date Property

Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Date { get; set; }
Public Property Date As Byte
    Get
    Set
public:
property unsigned char Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.DiodeSelectDSx Property

IRD

Max69096910DiodeSelectDSx Property

Diode Select (DSx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910DiodeSelectType DiodeSelectDSx { get; set; }
Public Property DiodeSelectDSx As Max69096910DiodeSelectType
    Get
    Set
public:
property Max69096910DiodeSelectType DiodeSelectDSx {
    Max69096910DiodeSelectType get ();
    void set (Max69096910DiodeSelectType value);
}
member DiodeSelectDSx : Max69096910DiodeSelectType with get, set

Property Value

Type: Max69096910DiodeSelectType
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.Hours Property

IRD

Max69096910Hours Property

Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Hours { get; set; }
Public Property Hours As Byte
    Get
    Set
public:
property unsigned char Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.Minutes Property

IRD

Max69096910Minutes Property

Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Minutes { get; set; }
Public Property Minutes As Byte
    Get
    Set
public:
property unsigned char Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.Month Property

IRD

Max69096910Month Property

Month

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Month { get; set; }
Public Property Month As Byte
    Get
    Set
public:
property unsigned char Month {
    unsigned char get ();
    void set (unsigned char value);
}
member Month : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.PiezoTransducerControlPZTCNTLPZTSEL Property

IRD

Max69096910PiezoTransducerControlPZTCNTLPZTSEL Property

Piezo Transducer Control (PZT CNTL, PZT SEL)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910PiezoTransducerType PiezoTransducerControlPZTCNTLPZTSEL { get; set; }
Public Property PiezoTransducerControlPZTCNTLPZTSEL As Max69096910PiezoTransducerType
    Get
    Set
public:
property Max69096910PiezoTransducerType PiezoTransducerControlPZTCNTLPZTSEL {
    Max69096910PiezoTransducerType get ();
    void set (Max69096910PiezoTransducerType value);
}
member PiezoTransducerControlPZTCNTLPZTSEL : Max69096910PiezoTransducerType with get, set

Property Value

Type: Max69096910PiezoTransducerType
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.PiezoTransducerSelectFrequencyPZTFREQ Property

IRD

Max69096910PiezoTransducerSelectFrequencyPZTFREQ Property

Piezo Transducer Select Frequency (PZT FREQ) (unit: kHz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910PiezoType PiezoTransducerSelectFrequencyPZTFREQ { get; set; }
Public Property PiezoTransducerSelectFrequencyPZTFREQ As Max69096910PiezoType
    Get
    Set
public:
property Max69096910PiezoType PiezoTransducerSelectFrequencyPZTFREQ {
    Max69096910PiezoType get ();
    void set (Max69096910PiezoType value);
}
member PiezoTransducerSelectFrequencyPZTFREQ : Max69096910PiezoType with get, set

Property Value

Type: Max69096910PiezoType
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.ResistorSelectRSx Property

IRD

Max69096910ResistorSelectRSx Property

Resistor Select (RSx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910ResistorType ResistorSelectRSx { get; set; }
Public Property ResistorSelectRSx As Max69096910ResistorType
    Get
    Set
public:
property Max69096910ResistorType ResistorSelectRSx {
    Max69096910ResistorType get ();
    void set (Max69096910ResistorType value);
}
member ResistorSelectRSx : Max69096910ResistorType with get, set

Property Value

Type: Max69096910ResistorType
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.Seconds Property

IRD

Max69096910Seconds Property

Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Seconds { get; set; }
Public Property Seconds As Byte
    Get
    Set
public:
property unsigned char Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.Switch12To24Hours1224 Property

IRD

Max69096910Switch12To24Hours1224 Property

Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910H1224Type Switch12To24Hours1224 { get; set; }
Public Property Switch12To24Hours1224 As Max69096910H1224Type
    Get
    Set
public:
property Max69096910H1224Type Switch12To24Hours1224 {
    Max69096910H1224Type get ();
    void set (Max69096910H1224Type value);
}
member Switch12To24Hours1224 : Max69096910H1224Type with get, set

Property Value

Type: Max69096910H1224Type
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.TrickleChargeTCSx Property

IRD

Max69096910TrickleChargeTCSx Property

Trickle Charge (TCSx)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910TrickleType TrickleChargeTCSx { get; set; }
Public Property TrickleChargeTCSx As Max69096910TrickleType
    Get
    Set
public:
property Max69096910TrickleType TrickleChargeTCSx {
    Max69096910TrickleType get ();
    void set (Max69096910TrickleType value);
}
member TrickleChargeTCSx : Max69096910TrickleType with get, set

Property Value

Type: Max69096910TrickleType
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.TriggerAlarmOnASpecificDateDATE Property

IRD

Max69096910TriggerAlarmOnASpecificDateDATE Property

Trigger Alarm On A Specific Date (DATE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910DateEnableType TriggerAlarmOnASpecificDateDATE { get; set; }
Public Property TriggerAlarmOnASpecificDateDATE As Max69096910DateEnableType
    Get
    Set
public:
property Max69096910DateEnableType TriggerAlarmOnASpecificDateDATE {
    Max69096910DateEnableType get ();
    void set (Max69096910DateEnableType value);
}
member TriggerAlarmOnASpecificDateDATE : Max69096910DateEnableType with get, set

Property Value

Type: Max69096910DateEnableType
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.TriggerAlarmOnASpecificDayDAY Property

IRD

Max69096910TriggerAlarmOnASpecificDayDAY Property

Trigger Alarm On A Specific Day (DAY)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910DayEnableType TriggerAlarmOnASpecificDayDAY { get; set; }
Public Property TriggerAlarmOnASpecificDayDAY As Max69096910DayEnableType
    Get
    Set
public:
property Max69096910DayEnableType TriggerAlarmOnASpecificDayDAY {
    Max69096910DayEnableType get ();
    void set (Max69096910DayEnableType value);
}
member TriggerAlarmOnASpecificDayDAY : Max69096910DayEnableType with get, set

Property Value

Type: Max69096910DayEnableType
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.TriggerAlarmOnASpecificHourHOUR Property

IRD

Max69096910TriggerAlarmOnASpecificHourHOUR Property

Trigger Alarm On A Specific Hour (HOUR)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910HourEnableType TriggerAlarmOnASpecificHourHOUR { get; set; }
Public Property TriggerAlarmOnASpecificHourHOUR As Max69096910HourEnableType
    Get
    Set
public:
property Max69096910HourEnableType TriggerAlarmOnASpecificHourHOUR {
    Max69096910HourEnableType get ();
    void set (Max69096910HourEnableType value);
}
member TriggerAlarmOnASpecificHourHOUR : Max69096910HourEnableType with get, set

Property Value

Type: Max69096910HourEnableType
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.TriggerAlarmOnASpecificMinuteMIN Property

IRD

Max69096910TriggerAlarmOnASpecificMinuteMIN Property

Trigger Alarm On A Specific Minute (MIN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910MinEnableType TriggerAlarmOnASpecificMinuteMIN { get; set; }
Public Property TriggerAlarmOnASpecificMinuteMIN As Max69096910MinEnableType
    Get
    Set
public:
property Max69096910MinEnableType TriggerAlarmOnASpecificMinuteMIN {
    Max69096910MinEnableType get ();
    void set (Max69096910MinEnableType value);
}
member TriggerAlarmOnASpecificMinuteMIN : Max69096910MinEnableType with get, set

Property Value

Type: Max69096910MinEnableType
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.TriggerAlarmOnASpecificMonthMONTH Property

IRD

Max69096910TriggerAlarmOnASpecificMonthMONTH Property

Trigger Alarm On A Specific Month (MONTH)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910MonthEnableType TriggerAlarmOnASpecificMonthMONTH { get; set; }
Public Property TriggerAlarmOnASpecificMonthMONTH As Max69096910MonthEnableType
    Get
    Set
public:
property Max69096910MonthEnableType TriggerAlarmOnASpecificMonthMONTH {
    Max69096910MonthEnableType get ();
    void set (Max69096910MonthEnableType value);
}
member TriggerAlarmOnASpecificMonthMONTH : Max69096910MonthEnableType with get, set

Property Value

Type: Max69096910MonthEnableType
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.TriggerAlarmOnASpecificSecondSEC Property

IRD

Max69096910TriggerAlarmOnASpecificSecondSEC Property

Trigger Alarm On A Specific Second (SEC)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910SecEnableType TriggerAlarmOnASpecificSecondSEC { get; set; }
Public Property TriggerAlarmOnASpecificSecondSEC As Max69096910SecEnableType
    Get
    Set
public:
property Max69096910SecEnableType TriggerAlarmOnASpecificSecondSEC {
    Max69096910SecEnableType get ();
    void set (Max69096910SecEnableType value);
}
member TriggerAlarmOnASpecificSecondSEC : Max69096910SecEnableType with get, set

Property Value

Type: Max69096910SecEnableType
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.TriggerAlarmOnASpecificYearYEAR Property

IRD

Max69096910TriggerAlarmOnASpecificYearYEAR Property

Trigger Alarm On A Specific Year (YEAR)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910YearEnableType TriggerAlarmOnASpecificYearYEAR { get; set; }
Public Property TriggerAlarmOnASpecificYearYEAR As Max69096910YearEnableType
    Get
    Set
public:
property Max69096910YearEnableType TriggerAlarmOnASpecificYearYEAR {
    Max69096910YearEnableType get ();
    void set (Max69096910YearEnableType value);
}
member TriggerAlarmOnASpecificYearYEAR : Max69096910YearEnableType with get, set

Property Value

Type: Max69096910YearEnableType
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.WatchdogEnableWDEN Property

IRD

Max69096910WatchdogEnableWDEN Property

Watchdog Enable (WD EN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910WatchdogEnableType WatchdogEnableWDEN { get; set; }
Public Property WatchdogEnableWDEN As Max69096910WatchdogEnableType
    Get
    Set
public:
property Max69096910WatchdogEnableType WatchdogEnableWDEN {
    Max69096910WatchdogEnableType get ();
    void set (Max69096910WatchdogEnableType value);
}
member WatchdogEnableWDEN : Max69096910WatchdogEnableType with get, set

Property Value

Type: Max69096910WatchdogEnableType
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.WatchdogTimeoutWDTIME Property

IRD

Max69096910WatchdogTimeoutWDTIME Property

Watchdog Timeout (WD TIME)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910WatchdogTimeoutType WatchdogTimeoutWDTIME { get; set; }
Public Property WatchdogTimeoutWDTIME As Max69096910WatchdogTimeoutType
    Get
    Set
public:
property Max69096910WatchdogTimeoutType WatchdogTimeoutWDTIME {
    Max69096910WatchdogTimeoutType get ();
    void set (Max69096910WatchdogTimeoutType value);
}
member WatchdogTimeoutWDTIME : Max69096910WatchdogTimeoutType with get, set

Property Value

Type: Max69096910WatchdogTimeoutType
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.WeekDay Property

IRD

Max69096910WeekDay Property

Week Day

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WeekDay { get; set; }
Public Property WeekDay As Byte
    Get
    Set
public:
property unsigned char WeekDay {
    unsigned char get ();
    void set (unsigned char value);
}
member WeekDay : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.WriteProtection Property

IRD

Max69096910WriteProtection Property

Write Protection

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max69096910ProtectType WriteProtection { get; set; }
Public Property WriteProtection As Max69096910ProtectType
    Get
    Set
public:
property Max69096910ProtectType WriteProtection {
    Max69096910ProtectType get ();
    void set (Max69096910ProtectType value);
}
member WriteProtection : Max69096910ProtectType with get, set

Property Value

Type: Max69096910ProtectType
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.Year Property

IRD

Max69096910Year Property

Year

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Year { get; set; }
Public Property Year As Byte
    Get
    Set
public:
property unsigned char Year {
    unsigned char get ();
    void set (unsigned char value);
}
member Year : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910 Methods

The Max69096910 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.Flush Method

IRD

Max69096910Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max69096910 Class
telos.Ird.Maxim Namespace


Max69096910.AlarmStatusType Enumeration

IRD

Max69096910AlarmStatusType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmStatusType
Public Enumeration AlarmStatusType
public enum class AlarmStatusType
type AlarmStatusType
Members
Member name | Value | Description
AlarmTrigger | 1 | Alarm Trigger
NoAlarmTrigger | 0 | No Alarm Trigger
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910.CrystalDetectType Enumeration

IRD

Max69096910CrystalDetectType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CrystalDetectType
Public Enumeration CrystalDetectType
public enum class CrystalDetectType
type CrystalDetectType
Members
Member name | Value | Description
CrystalFailDetectEnable | 1 | Crystal Fail Detect Enable
CrystalFailDetectDisable | 0 | Crystal Fail Detect Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910.CrystalFailType Enumeration

IRD

Max69096910CrystalFailType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CrystalFailType
Public Enumeration CrystalFailType
public enum class CrystalFailType
type CrystalFailType
Members
Member name | Value | Description
CrystalFailureDetected | 1 | Crystal Failure Detected
NoCrystalFailureDetected | 0 | No Crystal Failure Detected
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910.DateEnableType Enumeration

IRD

Max69096910DateEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DateEnableType
Public Enumeration DateEnableType
public enum class DateEnableType
type DateEnableType
Members
Member name | Value | Description
TriggerAlarmOnASpecificDateEnable | 1 | Trigger Alarm On A Specific Date Enable
TriggerAlarmOnASpecificDateDisable | 0 | Trigger Alarm On A Specific Date Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910.DayEnableType Enumeration

IRD

Max69096910DayEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DayEnableType
Public Enumeration DayEnableType
public enum class DayEnableType
type DayEnableType
Members
Member name | Value | Description
TriggerAlarmOnASpecificDayEnable | 1 | Trigger Alarm On A Specific Day Enable
TriggerAlarmOnASpecificDayDisable | 0 | Trigger Alarm On A Specific Day Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910.DiodeSelectType Enumeration

IRD

Max69096910DiodeSelectType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DiodeSelectType
Public Enumeration DiodeSelectType
public enum class DiodeSelectType
type DiodeSelectType
Members
Member name | Value | Description
Disabled | 0 | Disabled
TwoDiodesSelected | 1 | Two Diodes Selected
NoDiodeSelected | 2 | No Diode Selected
Disabled__1 | 3 | Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910.H1224Type Enumeration

IRD

Max69096910H1224Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum H1224Type
Public Enumeration H1224Type
public enum class H1224Type
type H1224Type
Members
Member name | Value | Description
Value_12Hours | 1 | 12 Hours
Value_24Hours | 0 | 24 Hours
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910.HourEnableType Enumeration

IRD

Max69096910HourEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum HourEnableType
Public Enumeration HourEnableType
public enum class HourEnableType
type HourEnableType
Members
Member name | Value | Description
TriggerAlarmOnASpecificHourEnable | 1 | Trigger Alarm On A Specific Hour Enable
TriggerAlarmOnASpecificHourDisable | 0 | Trigger Alarm On A Specific Hour Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910.MinEnableType Enumeration

IRD

Max69096910MinEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum MinEnableType
Public Enumeration MinEnableType
public enum class MinEnableType
type MinEnableType
Members
Member name | Value | Description
TriggerAlarmOnASpecificMinuteEnable | 1 | Trigger Alarm On A Specific Minute Enable
TriggerAlarmOnASpecificMinuteDisable | 0 | Trigger Alarm On A Specific Minute Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910.MonthEnableType Enumeration

IRD

Max69096910MonthEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum MonthEnableType
Public Enumeration MonthEnableType
public enum class MonthEnableType
type MonthEnableType
Members
Member name | Value | Description
TriggerAlarmOnASpecificMonthEnable | 1 | Trigger Alarm On A Specific Month Enable
TriggerAlarmOnASpecificMonthDisable | 0 | Trigger Alarm On A Specific Month Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910.PiezoTransducerType Enumeration

IRD

Max69096910PiezoTransducerType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum PiezoTransducerType
Public Enumeration PiezoTransducerType
public enum class PiezoTransducerType
type PiezoTransducerType
Members
Member name | Value | Description
PZTCNTLControlPZTLow | 0 | PZT CNTL Control, PZT Low
PZTCNTLControlPZTSelectedFrequency | 1 | PZT CNTL Control, PZT Selected Frequency
AlarmControlPZTSelectedFrequency | 2 | Alarm Control, PZT Selected Frequency
AlarmControlPZTLow | 3 | Alarm Control, PZT low
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910.PiezoType Enumeration

IRD

Max69096910PiezoType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum PiezoType
Public Enumeration PiezoType
public enum class PiezoType
type PiezoType
Members
Member name | Value | Description
Value_1_024 | 0 | 1.024
Value_2_048 | 1 | 2.048
Value_4_096 | 2 | 4.096
Value_8_19 | 3 | 8.19
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910.ProtectType Enumeration

IRD

Max69096910ProtectType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ProtectType
Public Enumeration ProtectType
public enum class ProtectType
type ProtectType
Members
Member name | Value | Description
WriteProtectionEnable | 1 | Write Protection Enable
WriteProtectionDisable | 0 | Write Protection Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910.ResistorType Enumeration

IRD

Max69096910ResistorType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ResistorType
Public Enumeration ResistorType
public enum class ResistorType
type ResistorType
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_29KOhmResistor | 1 | 2.9 kOhm Resistor
Value_17KOhmResistor | 2 | 1.7 kOhm Resistor
Value_5KOhmResistor | 3 | 5 kOhm Resistor
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910.SecEnableType Enumeration

IRD

Max69096910SecEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SecEnableType
Public Enumeration SecEnableType
public enum class SecEnableType
type SecEnableType
Members
Member name | Value | Description
TriggerAlarmOnASpecificSecondEnable | 1 | Trigger Alarm On A Specific Second Enable
TriggerAlarmOnASpecificSecondDisable | 0 | Trigger Alarm On A Specific Second Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910.TrickleType Enumeration

IRD

Max69096910TrickleType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TrickleType
Public Enumeration TrickleType
public enum class TrickleType
type TrickleType
Members
Member name | Value | Description
TrickleChargeDisabled | 0 | Trickle Charge Disabled
TrickleChargeEnabled | 10 | Trickle Charge Enabled
TrickleChargeDisabled__1 | 11 | Trickle Charge Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910.WatchdogEnableType Enumeration

IRD

Max69096910WatchdogEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum WatchdogEnableType
Public Enumeration WatchdogEnableType
public enum class WatchdogEnableType
type WatchdogEnableType
Members
Member name | Value | Description
WatchdogEnable | 1 | Watchdog Enable
WatchdogDisable | 0 | Watchdog Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910.WatchdogTimeoutType Enumeration

IRD

Max69096910WatchdogTimeoutType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum WatchdogTimeoutType
Public Enumeration WatchdogTimeoutType
public enum class WatchdogTimeoutType
type WatchdogTimeoutType
Members
Member name | Value | Description
WatchdogTimeout200Ms | 1 | Watchdog Timeout 200 ms
WatchdogTimeout16S | 0 | Watchdog Timeout 1.6 s
See Also

Reference

telos.Ird.Maxim Namespace


Max69096910.YearEnableType Enumeration

IRD

Max69096910YearEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum YearEnableType
Public Enumeration YearEnableType
public enum class YearEnableType
type YearEnableType
Members
Member name | Value | Description
TriggerAlarmOnASpecificYearEnable | 1 | Trigger Alarm On A Specific Year Enable
TriggerAlarmOnASpecificYearDisable | 0 | Trigger Alarm On A Specific Year Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max6917 Class

Maxim: MAX 6917
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax6917

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max6917
Public Class Max6917
public ref class Max6917
type Max6917 =  class end

The Max6917 type exposes the following members.

Constructors
 | Name | Description
Public method | Max6917 | Constructor
Top
Properties
 | Name | Description
Public property | AlarmDate | Alarm Date
Public property | AlarmHours | Alarm Hours (unit: hour)
Public property | AlarmMinutes | Alarm Minutes (unit: min)
Public property | AlarmMonth | Alarm Month
Public property | AlarmOutputFlagALMOUT | Alarm Output Flag (ALM OUT)
Public property | AlarmSeconds | Alarm Seconds (unit: s)
Public property | AlarmSwitch12To24Hours1224 | Alarm Switch 12 To 24 Hours (12/24)
Public property | AlarmWeekDay | Alarm Week Day
Public property | AlarmYear | Alarm Year
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryInternalExternalTestINTEXTTEST | Battery Internal/External Test (INT/EXT TEST)
Public property | BatteryLowBATTLO | Battery Low (BATT LO)
Public property | BatteryLowBlinkingBATTLOBLINK | Battery Low Blinking (BATT LO BLINK)
Public property | BatteryOnBlinkingBATTONBLINK | Battery On Blinking (BATT ON BLINK)
Public property | Century | Century
Public property | ClockBurstMode | Clock Burst Mode
Public property | CrystalFailDetectBitXTALFAIL | Crystal Fail Detect Bit (XTAL FAIL)
Public property | CrystalFailEnableXTALEN | Crystal Fail Enable (XTAL EN)
Public property | DataValidBitDATAVALID | Data Valid Bit (DATA VALID)
Public property | Date | Date
Public property | EnableFOUT1KHzUsingVBAT1kHzVBATEN | Enable FOUT 1 kHz, using VBAT (1kHz VBAT EN)
Public property | EnableFOUT1KHzUsingVCC1kHzVCCEN | Enable FOUT 1 kHz, using VCC (1kHz VCC EN)
Public property | EnableFOUT32KHzUsingVBAT32kHzVBATEN | Enable FOUT 32 kHz, using VBAT (32kHz VBAT EN)
Public property | EnableFOUT32KHzUsingVCC32kHzVCCEN | Enable FOUT 32 kHz, using VCC (32kHz VCC EN)
Public property | Hours | Hours (unit: hour)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | Seconds | Seconds (unit: s)
Public property | Switch12To24Hours1224 | Switch 12 To 24 Hours (12/24)
Public property | TriggerAlarmOnASpecificDateDATE | Trigger Alarm On A Specific Date (DATE)
Public property | TriggerAlarmOnASpecificDayDAY | Trigger Alarm On A Specific Day (DAY)
Public property | TriggerAlarmOnASpecificHourHOUR | Trigger Alarm On A Specific Hour (HOUR)
Public property | TriggerAlarmOnASpecificMinuteMIN | Trigger Alarm On A Specific Minute (MIN)
Public property | TriggerAlarmOnASpecificMonthMONTH | Trigger Alarm On A Specific Month (MONTH)
Public property | TriggerAlarmOnASpecificSecondSEC | Trigger Alarm On A Specific Second (SEC)
Public property | TriggerAlarmOnASpecificYearYEAR | Trigger Alarm On A Specific Year (YEAR)
Public property | TriggerAlarmOnceEverySecondONESEC | Trigger Alarm Once Every Second (ONE SEC)
Public property | WatchdogEnableWDEN | Watchdog Enable (WD EN)
Public property | WatchdogTimeWDTIME | Watchdog Time (WD TIME)
Public property | WeekDay | Week Day
Public property | WriteProtectionEnableWP | Write Protection Enable (WP)
Public property | Year | Year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
RTC With Microprocessor Supervisor And NV RAM Controller
See Also

Reference

telos.Ird.Maxim Namespace


Max6917 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max6917(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max6917

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917 Properties

The Max6917 type exposes the following members.

Properties
 | Name | Description
Public property | AlarmDate | Alarm Date
Public property | AlarmHours | Alarm Hours (unit: hour)
Public property | AlarmMinutes | Alarm Minutes (unit: min)
Public property | AlarmMonth | Alarm Month
Public property | AlarmOutputFlagALMOUT | Alarm Output Flag (ALM OUT)
Public property | AlarmSeconds | Alarm Seconds (unit: s)
Public property | AlarmSwitch12To24Hours1224 | Alarm Switch 12 To 24 Hours (12/24)
Public property | AlarmWeekDay | Alarm Week Day
Public property | AlarmYear | Alarm Year
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryInternalExternalTestINTEXTTEST | Battery Internal/External Test (INT/EXT TEST)
Public property | BatteryLowBATTLO | Battery Low (BATT LO)
Public property | BatteryLowBlinkingBATTLOBLINK | Battery Low Blinking (BATT LO BLINK)
Public property | BatteryOnBlinkingBATTONBLINK | Battery On Blinking (BATT ON BLINK)
Public property | Century | Century
Public property | ClockBurstMode | Clock Burst Mode
Public property | CrystalFailDetectBitXTALFAIL | Crystal Fail Detect Bit (XTAL FAIL)
Public property | CrystalFailEnableXTALEN | Crystal Fail Enable (XTAL EN)
Public property | DataValidBitDATAVALID | Data Valid Bit (DATA VALID)
Public property | Date | Date
Public property | EnableFOUT1KHzUsingVBAT1kHzVBATEN | Enable FOUT 1 kHz, using VBAT (1kHz VBAT EN)
Public property | EnableFOUT1KHzUsingVCC1kHzVCCEN | Enable FOUT 1 kHz, using VCC (1kHz VCC EN)
Public property | EnableFOUT32KHzUsingVBAT32kHzVBATEN | Enable FOUT 32 kHz, using VBAT (32kHz VBAT EN)
Public property | EnableFOUT32KHzUsingVCC32kHzVCCEN | Enable FOUT 32 kHz, using VCC (32kHz VCC EN)
Public property | Hours | Hours (unit: hour)
Public property | Minutes | Minutes (unit: min)
Public property | Month | Month
Public property | Seconds | Seconds (unit: s)
Public property | Switch12To24Hours1224 | Switch 12 To 24 Hours (12/24)
Public property | TriggerAlarmOnASpecificDateDATE | Trigger Alarm On A Specific Date (DATE)
Public property | TriggerAlarmOnASpecificDayDAY | Trigger Alarm On A Specific Day (DAY)
Public property | TriggerAlarmOnASpecificHourHOUR | Trigger Alarm On A Specific Hour (HOUR)
Public property | TriggerAlarmOnASpecificMinuteMIN | Trigger Alarm On A Specific Minute (MIN)
Public property | TriggerAlarmOnASpecificMonthMONTH | Trigger Alarm On A Specific Month (MONTH)
Public property | TriggerAlarmOnASpecificSecondSEC | Trigger Alarm On A Specific Second (SEC)
Public property | TriggerAlarmOnASpecificYearYEAR | Trigger Alarm On A Specific Year (YEAR)
Public property | TriggerAlarmOnceEverySecondONESEC | Trigger Alarm Once Every Second (ONE SEC)
Public property | WatchdogEnableWDEN | Watchdog Enable (WD EN)
Public property | WatchdogTimeWDTIME | Watchdog Time (WD TIME)
Public property | WeekDay | Week Day
Public property | WriteProtectionEnableWP | Write Protection Enable (WP)
Public property | Year | Year
Top
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.AlarmDate Property

IRD

Max6917AlarmDate Property

Alarm Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmDate { get; set; }
Public Property AlarmDate As Byte
    Get
    Set
public:
property unsigned char AlarmDate {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmDate : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.AlarmHours Property

IRD

Max6917AlarmHours Property

Alarm Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmHours { get; set; }
Public Property AlarmHours As Byte
    Get
    Set
public:
property unsigned char AlarmHours {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmHours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.AlarmMinutes Property

IRD

Max6917AlarmMinutes Property

Alarm Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmMinutes { get; set; }
Public Property AlarmMinutes As Byte
    Get
    Set
public:
property unsigned char AlarmMinutes {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmMinutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.AlarmMonth Property

IRD

Max6917AlarmMonth Property

Alarm Month

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmMonth { get; set; }
Public Property AlarmMonth As Byte
    Get
    Set
public:
property unsigned char AlarmMonth {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmMonth : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.AlarmOutputFlagALMOUT Property

IRD

Max6917AlarmOutputFlagALMOUT Property

Alarm Output Flag (ALM OUT)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917AlarmOutType AlarmOutputFlagALMOUT { get; set; }
Public Property AlarmOutputFlagALMOUT As Max6917AlarmOutType
    Get
    Set
public:
property Max6917AlarmOutType AlarmOutputFlagALMOUT {
    Max6917AlarmOutType get ();
    void set (Max6917AlarmOutType value);
}
member AlarmOutputFlagALMOUT : Max6917AlarmOutType with get, set

Property Value

Type: Max6917AlarmOutType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.AlarmSeconds Property

IRD

Max6917AlarmSeconds Property

Alarm Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmSeconds { get; set; }
Public Property AlarmSeconds As Byte
    Get
    Set
public:
property unsigned char AlarmSeconds {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmSeconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.AlarmSwitch12To24Hours1224 Property

IRD

Max6917AlarmSwitch12To24Hours1224 Property

Alarm Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917H1224Type AlarmSwitch12To24Hours1224 { get; set; }
Public Property AlarmSwitch12To24Hours1224 As Max6917H1224Type
    Get
    Set
public:
property Max6917H1224Type AlarmSwitch12To24Hours1224 {
    Max6917H1224Type get ();
    void set (Max6917H1224Type value);
}
member AlarmSwitch12To24Hours1224 : Max6917H1224Type with get, set

Property Value

Type: Max6917H1224Type
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.AlarmWeekDay Property

IRD

Max6917AlarmWeekDay Property

Alarm Week Day

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmWeekDay { get; set; }
Public Property AlarmWeekDay As Byte
    Get
    Set
public:
property unsigned char AlarmWeekDay {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmWeekDay : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.AlarmYear Property

IRD

Max6917AlarmYear Property

Alarm Year

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmYear { get; set; }
Public Property AlarmYear As Byte
    Get
    Set
public:
property unsigned char AlarmYear {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmYear : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.AutoFlush Property

IRD

Max6917AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.BatteryInternalExternalTestINTEXTTEST Property

IRD

Max6917BatteryInternalExternalTestINTEXTTEST Property

Battery Internal/External Test (INT/EXT TEST)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917BatteryTestType BatteryInternalExternalTestINTEXTTEST { get; set; }
Public Property BatteryInternalExternalTestINTEXTTEST As Max6917BatteryTestType
    Get
    Set
public:
property Max6917BatteryTestType BatteryInternalExternalTestINTEXTTEST {
    Max6917BatteryTestType get ();
    void set (Max6917BatteryTestType value);
}
member BatteryInternalExternalTestINTEXTTEST : Max6917BatteryTestType with get, set

Property Value

Type: Max6917BatteryTestType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.BatteryLowBATTLO Property

IRD

Max6917BatteryLowBATTLO Property

Battery Low (BATT LO)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917BattLoType BatteryLowBATTLO { get; set; }
Public Property BatteryLowBATTLO As Max6917BattLoType
    Get
    Set
public:
property Max6917BattLoType BatteryLowBATTLO {
    Max6917BattLoType get ();
    void set (Max6917BattLoType value);
}
member BatteryLowBATTLO : Max6917BattLoType with get, set

Property Value

Type: Max6917BattLoType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.BatteryLowBlinkingBATTLOBLINK Property

IRD

Max6917BatteryLowBlinkingBATTLOBLINK Property

Battery Low Blinking (BATT LO BLINK)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917BattLoblinkType BatteryLowBlinkingBATTLOBLINK { get; set; }
Public Property BatteryLowBlinkingBATTLOBLINK As Max6917BattLoblinkType
    Get
    Set
public:
property Max6917BattLoblinkType BatteryLowBlinkingBATTLOBLINK {
    Max6917BattLoblinkType get ();
    void set (Max6917BattLoblinkType value);
}
member BatteryLowBlinkingBATTLOBLINK : Max6917BattLoblinkType with get, set

Property Value

Type: Max6917BattLoblinkType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.BatteryOnBlinkingBATTONBLINK Property

IRD

Max6917BatteryOnBlinkingBATTONBLINK Property

Battery On Blinking (BATT ON BLINK)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917BattOnblinkType BatteryOnBlinkingBATTONBLINK { get; set; }
Public Property BatteryOnBlinkingBATTONBLINK As Max6917BattOnblinkType
    Get
    Set
public:
property Max6917BattOnblinkType BatteryOnBlinkingBATTONBLINK {
    Max6917BattOnblinkType get ();
    void set (Max6917BattOnblinkType value);
}
member BatteryOnBlinkingBATTONBLINK : Max6917BattOnblinkType with get, set

Property Value

Type: Max6917BattOnblinkType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.Century Property

IRD

Max6917Century Property

Century

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Century { get; set; }
Public Property Century As Byte
    Get
    Set
public:
property unsigned char Century {
    unsigned char get ();
    void set (unsigned char value);
}
member Century : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.ClockBurstMode Property

IRD

Max6917ClockBurstMode Property

Clock Burst Mode

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ClockBurstMode { get; set; }
Public Property ClockBurstMode As Byte
    Get
    Set
public:
property unsigned char ClockBurstMode {
    unsigned char get ();
    void set (unsigned char value);
}
member ClockBurstMode : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.CrystalFailDetectBitXTALFAIL Property

IRD

Max6917CrystalFailDetectBitXTALFAIL Property

Crystal Fail Detect Bit (XTAL FAIL)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917XtalFailType CrystalFailDetectBitXTALFAIL { get; set; }
Public Property CrystalFailDetectBitXTALFAIL As Max6917XtalFailType
    Get
    Set
public:
property Max6917XtalFailType CrystalFailDetectBitXTALFAIL {
    Max6917XtalFailType get ();
    void set (Max6917XtalFailType value);
}
member CrystalFailDetectBitXTALFAIL : Max6917XtalFailType with get, set

Property Value

Type: Max6917XtalFailType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.CrystalFailEnableXTALEN Property

IRD

Max6917CrystalFailEnableXTALEN Property

Crystal Fail Enable (XTAL EN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917CrystalFailType CrystalFailEnableXTALEN { get; set; }
Public Property CrystalFailEnableXTALEN As Max6917CrystalFailType
    Get
    Set
public:
property Max6917CrystalFailType CrystalFailEnableXTALEN {
    Max6917CrystalFailType get ();
    void set (Max6917CrystalFailType value);
}
member CrystalFailEnableXTALEN : Max6917CrystalFailType with get, set

Property Value

Type: Max6917CrystalFailType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.DataValidBitDATAVALID Property

IRD

Max6917DataValidBitDATAVALID Property

Data Valid Bit (DATA VALID)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917DataValidType DataValidBitDATAVALID { get; set; }
Public Property DataValidBitDATAVALID As Max6917DataValidType
    Get
    Set
public:
property Max6917DataValidType DataValidBitDATAVALID {
    Max6917DataValidType get ();
    void set (Max6917DataValidType value);
}
member DataValidBitDATAVALID : Max6917DataValidType with get, set

Property Value

Type: Max6917DataValidType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.Date Property

IRD

Max6917Date Property

Date

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Date { get; set; }
Public Property Date As Byte
    Get
    Set
public:
property unsigned char Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.EnableFOUT1KHzUsingVBAT1kHzVBATEN Property

IRD

Max6917EnableFOUT1KHzUsingVBAT1kHzVBATEN Property

Enable FOUT 1 kHz, using VBAT (1kHz VBAT EN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917Vbat1khzType EnableFOUT1KHzUsingVBAT1kHzVBATEN { get; set; }
Public Property EnableFOUT1KHzUsingVBAT1kHzVBATEN As Max6917Vbat1khzType
    Get
    Set
public:
property Max6917Vbat1khzType EnableFOUT1KHzUsingVBAT1kHzVBATEN {
    Max6917Vbat1khzType get ();
    void set (Max6917Vbat1khzType value);
}
member EnableFOUT1KHzUsingVBAT1kHzVBATEN : Max6917Vbat1khzType with get, set

Property Value

Type: Max6917Vbat1khzType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.EnableFOUT1KHzUsingVCC1kHzVCCEN Property

IRD

Max6917EnableFOUT1KHzUsingVCC1kHzVCCEN Property

Enable FOUT 1 kHz, using VCC (1kHz VCC EN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917Vcc1khzType EnableFOUT1KHzUsingVCC1kHzVCCEN { get; set; }
Public Property EnableFOUT1KHzUsingVCC1kHzVCCEN As Max6917Vcc1khzType
    Get
    Set
public:
property Max6917Vcc1khzType EnableFOUT1KHzUsingVCC1kHzVCCEN {
    Max6917Vcc1khzType get ();
    void set (Max6917Vcc1khzType value);
}
member EnableFOUT1KHzUsingVCC1kHzVCCEN : Max6917Vcc1khzType with get, set

Property Value

Type: Max6917Vcc1khzType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.EnableFOUT32KHzUsingVBAT32kHzVBATEN Property

IRD

Max6917EnableFOUT32KHzUsingVBAT32kHzVBATEN Property

Enable FOUT 32 kHz, using VBAT (32kHz VBAT EN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917Vbat32khzType EnableFOUT32KHzUsingVBAT32kHzVBATEN { get; set; }
Public Property EnableFOUT32KHzUsingVBAT32kHzVBATEN As Max6917Vbat32khzType
    Get
    Set
public:
property Max6917Vbat32khzType EnableFOUT32KHzUsingVBAT32kHzVBATEN {
    Max6917Vbat32khzType get ();
    void set (Max6917Vbat32khzType value);
}
member EnableFOUT32KHzUsingVBAT32kHzVBATEN : Max6917Vbat32khzType with get, set

Property Value

Type: Max6917Vbat32khzType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.EnableFOUT32KHzUsingVCC32kHzVCCEN Property

IRD

Max6917EnableFOUT32KHzUsingVCC32kHzVCCEN Property

Enable FOUT 32 kHz, using VCC (32kHz VCC EN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917Vcc32khzType EnableFOUT32KHzUsingVCC32kHzVCCEN { get; set; }
Public Property EnableFOUT32KHzUsingVCC32kHzVCCEN As Max6917Vcc32khzType
    Get
    Set
public:
property Max6917Vcc32khzType EnableFOUT32KHzUsingVCC32kHzVCCEN {
    Max6917Vcc32khzType get ();
    void set (Max6917Vcc32khzType value);
}
member EnableFOUT32KHzUsingVCC32kHzVCCEN : Max6917Vcc32khzType with get, set

Property Value

Type: Max6917Vcc32khzType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.Hours Property

IRD

Max6917Hours Property

Hours (unit: hour)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Hours { get; set; }
Public Property Hours As Byte
    Get
    Set
public:
property unsigned char Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.Minutes Property

IRD

Max6917Minutes Property

Minutes (unit: min)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Minutes { get; set; }
Public Property Minutes As Byte
    Get
    Set
public:
property unsigned char Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.Month Property

IRD

Max6917Month Property

Month

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Month { get; set; }
Public Property Month As Byte
    Get
    Set
public:
property unsigned char Month {
    unsigned char get ();
    void set (unsigned char value);
}
member Month : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.Seconds Property

IRD

Max6917Seconds Property

Seconds (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Seconds { get; set; }
Public Property Seconds As Byte
    Get
    Set
public:
property unsigned char Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.Switch12To24Hours1224 Property

IRD

Max6917Switch12To24Hours1224 Property

Switch 12 To 24 Hours (12/24)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917H1224Type Switch12To24Hours1224 { get; set; }
Public Property Switch12To24Hours1224 As Max6917H1224Type
    Get
    Set
public:
property Max6917H1224Type Switch12To24Hours1224 {
    Max6917H1224Type get ();
    void set (Max6917H1224Type value);
}
member Switch12To24Hours1224 : Max6917H1224Type with get, set

Property Value

Type: Max6917H1224Type
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.TriggerAlarmOnASpecificDateDATE Property

IRD

Max6917TriggerAlarmOnASpecificDateDATE Property

Trigger Alarm On A Specific Date (DATE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917DateEnableType TriggerAlarmOnASpecificDateDATE { get; set; }
Public Property TriggerAlarmOnASpecificDateDATE As Max6917DateEnableType
    Get
    Set
public:
property Max6917DateEnableType TriggerAlarmOnASpecificDateDATE {
    Max6917DateEnableType get ();
    void set (Max6917DateEnableType value);
}
member TriggerAlarmOnASpecificDateDATE : Max6917DateEnableType with get, set

Property Value

Type: Max6917DateEnableType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.TriggerAlarmOnASpecificDayDAY Property

IRD

Max6917TriggerAlarmOnASpecificDayDAY Property

Trigger Alarm On A Specific Day (DAY)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917DayEnableType TriggerAlarmOnASpecificDayDAY { get; set; }
Public Property TriggerAlarmOnASpecificDayDAY As Max6917DayEnableType
    Get
    Set
public:
property Max6917DayEnableType TriggerAlarmOnASpecificDayDAY {
    Max6917DayEnableType get ();
    void set (Max6917DayEnableType value);
}
member TriggerAlarmOnASpecificDayDAY : Max6917DayEnableType with get, set

Property Value

Type: Max6917DayEnableType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.TriggerAlarmOnASpecificHourHOUR Property

IRD

Max6917TriggerAlarmOnASpecificHourHOUR Property

Trigger Alarm On A Specific Hour (HOUR)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917HourEnableType TriggerAlarmOnASpecificHourHOUR { get; set; }
Public Property TriggerAlarmOnASpecificHourHOUR As Max6917HourEnableType
    Get
    Set
public:
property Max6917HourEnableType TriggerAlarmOnASpecificHourHOUR {
    Max6917HourEnableType get ();
    void set (Max6917HourEnableType value);
}
member TriggerAlarmOnASpecificHourHOUR : Max6917HourEnableType with get, set

Property Value

Type: Max6917HourEnableType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.TriggerAlarmOnASpecificMinuteMIN Property

IRD

Max6917TriggerAlarmOnASpecificMinuteMIN Property

Trigger Alarm On A Specific Minute (MIN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917MinEnableType TriggerAlarmOnASpecificMinuteMIN { get; set; }
Public Property TriggerAlarmOnASpecificMinuteMIN As Max6917MinEnableType
    Get
    Set
public:
property Max6917MinEnableType TriggerAlarmOnASpecificMinuteMIN {
    Max6917MinEnableType get ();
    void set (Max6917MinEnableType value);
}
member TriggerAlarmOnASpecificMinuteMIN : Max6917MinEnableType with get, set

Property Value

Type: Max6917MinEnableType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.TriggerAlarmOnASpecificMonthMONTH Property

IRD

Max6917TriggerAlarmOnASpecificMonthMONTH Property

Trigger Alarm On A Specific Month (MONTH)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917MonthEnableType TriggerAlarmOnASpecificMonthMONTH { get; set; }
Public Property TriggerAlarmOnASpecificMonthMONTH As Max6917MonthEnableType
    Get
    Set
public:
property Max6917MonthEnableType TriggerAlarmOnASpecificMonthMONTH {
    Max6917MonthEnableType get ();
    void set (Max6917MonthEnableType value);
}
member TriggerAlarmOnASpecificMonthMONTH : Max6917MonthEnableType with get, set

Property Value

Type: Max6917MonthEnableType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.TriggerAlarmOnASpecificSecondSEC Property

IRD

Max6917TriggerAlarmOnASpecificSecondSEC Property

Trigger Alarm On A Specific Second (SEC)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917SecEnableType TriggerAlarmOnASpecificSecondSEC { get; set; }
Public Property TriggerAlarmOnASpecificSecondSEC As Max6917SecEnableType
    Get
    Set
public:
property Max6917SecEnableType TriggerAlarmOnASpecificSecondSEC {
    Max6917SecEnableType get ();
    void set (Max6917SecEnableType value);
}
member TriggerAlarmOnASpecificSecondSEC : Max6917SecEnableType with get, set

Property Value

Type: Max6917SecEnableType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.TriggerAlarmOnASpecificYearYEAR Property

IRD

Max6917TriggerAlarmOnASpecificYearYEAR Property

Trigger Alarm On A Specific Year (YEAR)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917YearEnableType TriggerAlarmOnASpecificYearYEAR { get; set; }
Public Property TriggerAlarmOnASpecificYearYEAR As Max6917YearEnableType
    Get
    Set
public:
property Max6917YearEnableType TriggerAlarmOnASpecificYearYEAR {
    Max6917YearEnableType get ();
    void set (Max6917YearEnableType value);
}
member TriggerAlarmOnASpecificYearYEAR : Max6917YearEnableType with get, set

Property Value

Type: Max6917YearEnableType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.TriggerAlarmOnceEverySecondONESEC Property

IRD

Max6917TriggerAlarmOnceEverySecondONESEC Property

Trigger Alarm Once Every Second (ONE SEC)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917OncesecEnableType TriggerAlarmOnceEverySecondONESEC { get; set; }
Public Property TriggerAlarmOnceEverySecondONESEC As Max6917OncesecEnableType
    Get
    Set
public:
property Max6917OncesecEnableType TriggerAlarmOnceEverySecondONESEC {
    Max6917OncesecEnableType get ();
    void set (Max6917OncesecEnableType value);
}
member TriggerAlarmOnceEverySecondONESEC : Max6917OncesecEnableType with get, set

Property Value

Type: Max6917OncesecEnableType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.WatchdogEnableWDEN Property

IRD

Max6917WatchdogEnableWDEN Property

Watchdog Enable (WD EN)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917WatchdogEnableType WatchdogEnableWDEN { get; set; }
Public Property WatchdogEnableWDEN As Max6917WatchdogEnableType
    Get
    Set
public:
property Max6917WatchdogEnableType WatchdogEnableWDEN {
    Max6917WatchdogEnableType get ();
    void set (Max6917WatchdogEnableType value);
}
member WatchdogEnableWDEN : Max6917WatchdogEnableType with get, set

Property Value

Type: Max6917WatchdogEnableType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.WatchdogTimeWDTIME Property

IRD

Max6917WatchdogTimeWDTIME Property

Watchdog Time (WD TIME)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917WatchdogTimeType WatchdogTimeWDTIME { get; set; }
Public Property WatchdogTimeWDTIME As Max6917WatchdogTimeType
    Get
    Set
public:
property Max6917WatchdogTimeType WatchdogTimeWDTIME {
    Max6917WatchdogTimeType get ();
    void set (Max6917WatchdogTimeType value);
}
member WatchdogTimeWDTIME : Max6917WatchdogTimeType with get, set

Property Value

Type: Max6917WatchdogTimeType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.WeekDay Property

IRD

Max6917WeekDay Property

Week Day

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WeekDay { get; set; }
Public Property WeekDay As Byte
    Get
    Set
public:
property unsigned char WeekDay {
    unsigned char get ();
    void set (unsigned char value);
}
member WeekDay : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.WriteProtectionEnableWP Property

IRD

Max6917WriteProtectionEnableWP Property

Write Protection Enable (WP)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max6917WriteProtectType WriteProtectionEnableWP { get; set; }
Public Property WriteProtectionEnableWP As Max6917WriteProtectType
    Get
    Set
public:
property Max6917WriteProtectType WriteProtectionEnableWP {
    Max6917WriteProtectType get ();
    void set (Max6917WriteProtectType value);
}
member WriteProtectionEnableWP : Max6917WriteProtectType with get, set

Property Value

Type: Max6917WriteProtectType
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.Year Property

IRD

Max6917Year Property

Year

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Year { get; set; }
Public Property Year As Byte
    Get
    Set
public:
property unsigned char Year {
    unsigned char get ();
    void set (unsigned char value);
}
member Year : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917 Methods

The Max6917 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.Flush Method

IRD

Max6917Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max6917 Class
telos.Ird.Maxim Namespace


Max6917.AlarmOutType Enumeration

IRD

Max6917AlarmOutType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmOutType
Public Enumeration AlarmOutType
public enum class AlarmOutType
type AlarmOutType
Members
Member name | Value | Description
AlarmOutputIsTriggered | 1 | Alarm Output Is Triggered
AlarmOutputIsNotTriggered | 0 | Alarm Output Is Not Triggered
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.BatteryTestType Enumeration

IRD

Max6917BatteryTestType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum BatteryTestType
Public Enumeration BatteryTestType
public enum class BatteryTestType
type BatteryTestType
Members
Member name | Value | Description
UseExternalResistorDivider | 1 | Use External Resistor Divider
UseInternalResistorDivider | 0 | Use Internal Resistor Divider
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.BattLoblinkType Enumeration

IRD

Max6917BattLoblinkType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum BattLoblinkType
Public Enumeration BattLoblinkType
public enum class BattLoblinkType
type BattLoblinkType
Members
Member name | Value | Description
EnableBatteryLowBlinking | 1 | Enable Battery Low Blinking
DisableBatteryLowBlinking | 0 | Disable Battery Low Blinking
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.BattLoType Enumeration

IRD

Max6917BattLoType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum BattLoType
Public Enumeration BattLoType
public enum class BattLoType
type BattLoType
Members
Member name | Value | Description
BatteryPowerIsLow | 1 | Battery Power Is Low
BatteryPowerIsNotLow | 0 | Battery Power Is Not Low
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.BattOnblinkType Enumeration

IRD

Max6917BattOnblinkType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum BattOnblinkType
Public Enumeration BattOnblinkType
public enum class BattOnblinkType
type BattOnblinkType
Members
Member name | Value | Description
EnableBatteryOnBlinking | 1 | Enable Battery On Blinking
DisableBatteryOnBlinking | 0 | Disable Battery On Blinking
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.CrystalFailType Enumeration

IRD

Max6917CrystalFailType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CrystalFailType
Public Enumeration CrystalFailType
public enum class CrystalFailType
type CrystalFailType
Members
Member name | Value | Description
EnableCrystalFailDetection | 1 | Enable Crystal Fail Detection
DisableCrystalFailDetection | 0 | Disable Crystal Fail Detection
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.DataValidType Enumeration

IRD

Max6917DataValidType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DataValidType
Public Enumeration DataValidType
public enum class DataValidType
type DataValidType
Members
Member name | Value | Description
ValidDataInRTC | 1 | Valid Data In RTC
NoValidDataInRTC | 0 | No Valid Data In RTC
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.DateEnableType Enumeration

IRD

Max6917DateEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DateEnableType
Public Enumeration DateEnableType
public enum class DateEnableType
type DateEnableType
Members
Member name | Value | Description
TriggerAlarmOnASpecificDateEnable | 1 | Trigger Alarm On A Specific Date Enable
TriggerAlarmOnASpecificDateDisable | 0 | Trigger Alarm On A Specific Date Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.DayEnableType Enumeration

IRD

Max6917DayEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum DayEnableType
Public Enumeration DayEnableType
public enum class DayEnableType
type DayEnableType
Members
Member name | Value | Description
TriggerAlarmOnASpecificDayEnable | 1 | Trigger Alarm On A Specific Day Enable
TriggerAlarmOnASpecificDayDisable | 0 | Trigger Alarm On A Specific Day Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.H1224Type Enumeration

IRD

Max6917H1224Type Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum H1224Type
Public Enumeration H1224Type
public enum class H1224Type
type H1224Type
Members
Member name | Value | Description
Value_12Hours | 1 | 12 Hours
Value_24Hours | 0 | 24 Hours
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.HourEnableType Enumeration

IRD

Max6917HourEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum HourEnableType
Public Enumeration HourEnableType
public enum class HourEnableType
type HourEnableType
Members
Member name | Value | Description
TriggerAlarmOnASpecificHourEnable | 1 | Trigger Alarm On A Specific Hour Enable
TriggerAlarmOnASpecificHourDisable | 0 | Trigger Alarm On A Specific Hour Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.MinEnableType Enumeration

IRD

Max6917MinEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum MinEnableType
Public Enumeration MinEnableType
public enum class MinEnableType
type MinEnableType
Members
Member name | Value | Description
TriggerAlarmOnASpecificMinuteEnable | 1 | Trigger Alarm On A Specific Minute Enable
TriggerAlarmOnASpecificMinuteDisable | 0 | Trigger Alarm On A Specific Minute Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.MonthEnableType Enumeration

IRD

Max6917MonthEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum MonthEnableType
Public Enumeration MonthEnableType
public enum class MonthEnableType
type MonthEnableType
Members
Member name | Value | Description
TriggerAlarmOnASpecificMonthEnable | 1 | Trigger Alarm On A Specific Month Enable
TriggerAlarmOnASpecificMonthDisable | 0 | Trigger Alarm On A Specific Month Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.OncesecEnableType Enumeration

IRD

Max6917OncesecEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum OncesecEnableType
Public Enumeration OncesecEnableType
public enum class OncesecEnableType
type OncesecEnableType
Members
Member name | Value | Description
TriggerAlarmOnceEverySecondEnable | 1 | Trigger Alarm Once Every Second Enable
TriggerAlarmOnceEverySecondDisable | 0 | Trigger Alarm Once Every Second Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.SecEnableType Enumeration

IRD

Max6917SecEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SecEnableType
Public Enumeration SecEnableType
public enum class SecEnableType
type SecEnableType
Members
Member name | Value | Description
TriggerAlarmOnASpecificSecondEnable | 1 | Trigger Alarm On A Specific Second Enable
TriggerAlarmOnASpecificSecondDisable | 0 | Trigger Alarm On A Specific Second Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.Vbat1khzType Enumeration

IRD

Max6917Vbat1khzType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Vbat1khzType
Public Enumeration Vbat1khzType
public enum class Vbat1khzType
type Vbat1khzType
Members
Member name | Value | Description
EnableFout1KHzUsingVBAT | 1 | Enable Fout 1 kHz, Using VBAT
DisableFout1KHzUsingVBAT | 0 | Disable Fout 1 kHz, Using VBAT
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.Vbat32khzType Enumeration

IRD

Max6917Vbat32khzType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Vbat32khzType
Public Enumeration Vbat32khzType
public enum class Vbat32khzType
type Vbat32khzType
Members
Member name | Value | Description
EnableFout32KHzUsingVBAT | 1 | Enable Fout 32 kHz, Using VBAT
DisableFout32KHzUsingVBAT | 0 | Disable Fout 32 kHz, Using VBAT
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.Vcc1khzType Enumeration

IRD

Max6917Vcc1khzType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Vcc1khzType
Public Enumeration Vcc1khzType
public enum class Vcc1khzType
type Vcc1khzType
Members
Member name | Value | Description
EnableFout1KHzUsingVCC | 1 | Enable Fout 1 kHz, Using VCC
DisableFout1KHzUsingVCC | 0 | Disable Fout 1 kHz, Using VCC
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.Vcc32khzType Enumeration

IRD

Max6917Vcc32khzType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Vcc32khzType
Public Enumeration Vcc32khzType
public enum class Vcc32khzType
type Vcc32khzType
Members
Member name | Value | Description
EnableFout32KHzUsingVCC | 1 | Enable Fout 32 kHz, Using VCC
DisableFout32KHzUsingVCC | 0 | Disable Fout 32 kHz, Using VCC
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.WatchdogEnableType Enumeration

IRD

Max6917WatchdogEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum WatchdogEnableType
Public Enumeration WatchdogEnableType
public enum class WatchdogEnableType
type WatchdogEnableType
Members
Member name | Value | Description
EnableWatchdog | 1 | Enable Watchdog
DisableWatchdog | 0 | Disable Watchdog
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.WatchdogTimeType Enumeration

IRD

Max6917WatchdogTimeType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum WatchdogTimeType
Public Enumeration WatchdogTimeType
public enum class WatchdogTimeType
type WatchdogTimeType
Members
Member name | Value | Description
WatchdogTimeoutPeriod200Ms | 1 | Watchdog Timeout Period 200 ms
WatchdogTimeoutPeriod16S | 0 | Watchdog Timeout Period 1.6 s
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.WriteProtectType Enumeration

IRD

Max6917WriteProtectType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum WriteProtectType
Public Enumeration WriteProtectType
public enum class WriteProtectType
type WriteProtectType
Members
Member name | Value | Description
EnableWriteProtection | 1 | Enable Write Protection
DisableWriteProtection | 0 | Disable Write Protection
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.XtalFailType Enumeration

IRD

Max6917XtalFailType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum XtalFailType
Public Enumeration XtalFailType
public enum class XtalFailType
type XtalFailType
Members
Member name | Value | Description
CrystalFailure | 1 | Crystal Failure
NormalOperationOfCrystal | 0 | Normal Operation Of Crystal
See Also

Reference

telos.Ird.Maxim Namespace


Max6917.YearEnableType Enumeration

IRD

Max6917YearEnableType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum YearEnableType
Public Enumeration YearEnableType
public enum class YearEnableType
type YearEnableType
Members
Member name | Value | Description
TriggerAlarmOnASpecificYearEnable | 1 | Trigger Alarm On A Specific Year Enable
TriggerAlarmOnASpecificYearDisable | 0 | Trigger Alarm On A Specific Year Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max77387 Class

Maxim: MAX 77387
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax77387

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max77387
Public Class Max77387
public ref class Max77387
type Max77387 =  class end

The Max77387 type exposes the following members.

Constructors
 | Name | Description
Public method | Max77387 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CHIPID1DIETYPE | CHIP_ID1: DIE_TYPE
Public property | CHIPID2DIEDASH | CHIP_ID2: DIE_DASH
Public property | CHIPID2DIEREV | CHIP_ID2: DIE_REV
Public property | DCDCCNTL1DCDCMODE | DCDC_CNTL1: DCDC_MODE
Public property | DCDCCNTL1FREQPWM | DCDC_CNTL1: FREQ_PWM
Public property | DCDCCNTL1OVPTH | DCDC_CNTL1: OVP_TH (unit: V)
Public property | DCDCCNTL2DCDCADPTREG | DCDC_CNTL2: DCDC_ADPT_REG (unit: mV)
Public property | DCDCCNTL2DCDCGAIN | DCDC_CNTL2: DCDC_GAIN
Public property | DCDCCNTL2DCDCOPERATION | DCDC_CNTL2: DCDC_OPERATION
Public property | DCDCLIMDCDCLIM | DCDC_LIM: DCDC_LIM
Public property | DCDCLIMDCDCSS | DCDC_LIM: DCDC_SS (unit: V)
Public property | DCDCOUTDCDCOUT | DCDC_OUT: DCDC_OUT (unit: V)
Public property | DCDCOUTMAXDCDCOUTMAX | DCDC_OUT_MAX: DCDC_OUT_MAX (unit: V)
Public property | FLASHRAMPSELFLASHRD | FLASH_RAMP_SEL: FLASH_RD
Public property | FLASHRAMPSELFLASHRU | FLASH_RAMP_SEL: FLASH_RU
Public property | FLASHTMRCNTLFLASHTMR | FLASH_TMR_CNTL: FLASH_TMR (unit: ms)
Public property | FLASHTMRCNTLFLASHTMRCNTL | FLASH_TMR_CNTL: FLASH_TMR_CNTL
Public property | IFLASH1FLASH1 | IFLASH1: FLASH1 (unit: mA)
Public property | IFLASH1FLASH1EN | IFLASH1: FLASH1_EN
Public property | IFLASH2FLASH2 | IFLASH2: FLASH2 (unit: mA)
Public property | IFLASH2FLASH2EN | IFLASH2: FLASH2_EN
Public property | ITORCH1TORCH1 | ITORCH1: TORCH1 (unit: mA)
Public property | ITORCH1TORCH1DIM | ITORCH1: TORCH1_DIM
Public property | ITORCH1TORCH1EN | ITORCH1: TORCH1_EN
Public property | ITORCH2TORCH2 | ITORCH2: TORCH2 (unit: mA)
Public property | ITORCH2TORCH2DIM | ITORCH2: TORCH2_DIM
Public property | ITORCH2TORCH2EN | ITORCH2: TORCH2_EN
Public property | MAXFLASH1MAXFLASHHYS | MAXFLASH1: MAXFLASH_HYS
Public property | MAXFLASH1MAXFLASHTH | MAXFLASH1: MAXFLASH_TH
Public property | MAXFLASH2LBTMRF | MAXFLASH2: LB_TMR_F (unit: µs)
Public property | MAXFLASH2LBTMRR | MAXFLASH2: LB_TMR_R (unit: µs)
Public property | MAXFLASH3MAXFLASH1IMIN | MAXFLASH3: MAX_FLASH1_IMIN
Public property | MAXFLASH4MAXFLASH2IMIN | MAXFLASH4: MAX_FLASH2_IMIN
Public property | MODESELFLASHMODE | MODE_SEL: FLASH_MODE
Public property | MODESELFLASHSTBPD | MODE_SEL: FLASH_STB_PD
Public property | MODESELTORCHENPD | MODE_SEL: TORCH_EN_PD
Public property | MODESELTORCHMODE | MODE_SEL: TORCH_MODE
Public property | NTCNTCEN | NTC: NTC_EN
Public property | NTCNTCTHFLASH | NTC: NTC_TH_FLASH (unit: mV)
Public property | NTCNTCTHTORCH | NTC: NTC_TH_TORCH (unit: mV)
Public property | STATUS1INUVLOTHERM | STATUS1: IN_UVLO_THERM
Public property | STATUS1LED1SHORT | STATUS1: LED1_SHORT
Public property | STATUS1LED2SHORT | STATUS1: LED2_SHORT
Public property | STATUS1NTCSHORT | STATUS1: NTC_SHORT
Public property | STATUS1NTCTHERM | STATUS1: NTC_THERM
Public property | STATUS1OVPA | STATUS1: OVP_A
Public property | STATUS1OVPD | STATUS1: OVP_D
Public property | STATUS1REGINUVLO | STATUS1: REG_IN_UVLO
Public property | STATUS2DONE | STATUS2: DONE
Public property | STATUS2FLASHTMR | STATUS2: FLASH_TMR
Public property | STATUS2ILIM | STATUS2: ILIM
Public property | STATUS2MAXFLASH | STATUS2: MAXFLASH
Public property | STATUS2NRESET | STATUS2: nRESET
Public property | STATUS2TORCHTMR | STATUS2: TORCH_TMR
Public property | STATUS2TX1MASK | STATUS2: TX1_MASK
Public property | STATUS2TX2MASK | STATUS2: TX2_MASK
Public property | TORCHRAMPSELTORCHRD | TORCH_RAMP_SEL: TORCH_RD
Public property | TORCHRAMPSELTORCHRU | TORCH_RAMP_SEL: TORCH_RU
Public property | TORCHTMRCNTLTORCHTMR | TORCH_TMR_CNTL: TORCH_TMR (unit: ms)
Public property | TORCHTMRCNTLTORCHTMRCNTL | TORCH_TMR_CNTL: TORCH_TMR_CNTL
Public property | TX1MASKFLASHTX1MASK | TX1_MASK: FLASH_TX1_MASK (unit: mA)
Public property | TX1MASKTX1MASKEN | TX1_MASK: TX1_MASK_EN
Public property | TX1MASKTX1MASKPD | TX1_MASK: TX1_MASK_PD
Public property | TX2MASKFLASHTX2MASK | TX2_MASK: FLASH_TX2_MASK (unit: mA)
Public property | TX2MASKTX2MASKEN | TX2_MASK: TX2_MASK_EN
Public property | TX2MASKTX2MASKPD | TX2_MASK: TX2_MASK_PD
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Dual-Phase Adaptive DC-DC Step-Up Converter
See Also

Reference

telos.Ird.Maxim Namespace


Max77387 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max77387(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max77387

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387 Properties

The Max77387 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CHIPID1DIETYPE | CHIP_ID1: DIE_TYPE
Public property | CHIPID2DIEDASH | CHIP_ID2: DIE_DASH
Public property | CHIPID2DIEREV | CHIP_ID2: DIE_REV
Public property | DCDCCNTL1DCDCMODE | DCDC_CNTL1: DCDC_MODE
Public property | DCDCCNTL1FREQPWM | DCDC_CNTL1: FREQ_PWM
Public property | DCDCCNTL1OVPTH | DCDC_CNTL1: OVP_TH (unit: V)
Public property | DCDCCNTL2DCDCADPTREG | DCDC_CNTL2: DCDC_ADPT_REG (unit: mV)
Public property | DCDCCNTL2DCDCGAIN | DCDC_CNTL2: DCDC_GAIN
Public property | DCDCCNTL2DCDCOPERATION | DCDC_CNTL2: DCDC_OPERATION
Public property | DCDCLIMDCDCLIM | DCDC_LIM: DCDC_LIM
Public property | DCDCLIMDCDCSS | DCDC_LIM: DCDC_SS (unit: V)
Public property | DCDCOUTDCDCOUT | DCDC_OUT: DCDC_OUT (unit: V)
Public property | DCDCOUTMAXDCDCOUTMAX | DCDC_OUT_MAX: DCDC_OUT_MAX (unit: V)
Public property | FLASHRAMPSELFLASHRD | FLASH_RAMP_SEL: FLASH_RD
Public property | FLASHRAMPSELFLASHRU | FLASH_RAMP_SEL: FLASH_RU
Public property | FLASHTMRCNTLFLASHTMR | FLASH_TMR_CNTL: FLASH_TMR (unit: ms)
Public property | FLASHTMRCNTLFLASHTMRCNTL | FLASH_TMR_CNTL: FLASH_TMR_CNTL
Public property | IFLASH1FLASH1 | IFLASH1: FLASH1 (unit: mA)
Public property | IFLASH1FLASH1EN | IFLASH1: FLASH1_EN
Public property | IFLASH2FLASH2 | IFLASH2: FLASH2 (unit: mA)
Public property | IFLASH2FLASH2EN | IFLASH2: FLASH2_EN
Public property | ITORCH1TORCH1 | ITORCH1: TORCH1 (unit: mA)
Public property | ITORCH1TORCH1DIM | ITORCH1: TORCH1_DIM
Public property | ITORCH1TORCH1EN | ITORCH1: TORCH1_EN
Public property | ITORCH2TORCH2 | ITORCH2: TORCH2 (unit: mA)
Public property | ITORCH2TORCH2DIM | ITORCH2: TORCH2_DIM
Public property | ITORCH2TORCH2EN | ITORCH2: TORCH2_EN
Public property | MAXFLASH1MAXFLASHHYS | MAXFLASH1: MAXFLASH_HYS
Public property | MAXFLASH1MAXFLASHTH | MAXFLASH1: MAXFLASH_TH
Public property | MAXFLASH2LBTMRF | MAXFLASH2: LB_TMR_F (unit: µs)
Public property | MAXFLASH2LBTMRR | MAXFLASH2: LB_TMR_R (unit: µs)
Public property | MAXFLASH3MAXFLASH1IMIN | MAXFLASH3: MAX_FLASH1_IMIN
Public property | MAXFLASH4MAXFLASH2IMIN | MAXFLASH4: MAX_FLASH2_IMIN
Public property | MODESELFLASHMODE | MODE_SEL: FLASH_MODE
Public property | MODESELFLASHSTBPD | MODE_SEL: FLASH_STB_PD
Public property | MODESELTORCHENPD | MODE_SEL: TORCH_EN_PD
Public property | MODESELTORCHMODE | MODE_SEL: TORCH_MODE
Public property | NTCNTCEN | NTC: NTC_EN
Public property | NTCNTCTHFLASH | NTC: NTC_TH_FLASH (unit: mV)
Public property | NTCNTCTHTORCH | NTC: NTC_TH_TORCH (unit: mV)
Public property | STATUS1INUVLOTHERM | STATUS1: IN_UVLO_THERM
Public property | STATUS1LED1SHORT | STATUS1: LED1_SHORT
Public property | STATUS1LED2SHORT | STATUS1: LED2_SHORT
Public property | STATUS1NTCSHORT | STATUS1: NTC_SHORT
Public property | STATUS1NTCTHERM | STATUS1: NTC_THERM
Public property | STATUS1OVPA | STATUS1: OVP_A
Public property | STATUS1OVPD | STATUS1: OVP_D
Public property | STATUS1REGINUVLO | STATUS1: REG_IN_UVLO
Public property | STATUS2DONE | STATUS2: DONE
Public property | STATUS2FLASHTMR | STATUS2: FLASH_TMR
Public property | STATUS2ILIM | STATUS2: ILIM
Public property | STATUS2MAXFLASH | STATUS2: MAXFLASH
Public property | STATUS2NRESET | STATUS2: nRESET
Public property | STATUS2TORCHTMR | STATUS2: TORCH_TMR
Public property | STATUS2TX1MASK | STATUS2: TX1_MASK
Public property | STATUS2TX2MASK | STATUS2: TX2_MASK
Public property | TORCHRAMPSELTORCHRD | TORCH_RAMP_SEL: TORCH_RD
Public property | TORCHRAMPSELTORCHRU | TORCH_RAMP_SEL: TORCH_RU
Public property | TORCHTMRCNTLTORCHTMR | TORCH_TMR_CNTL: TORCH_TMR (unit: ms)
Public property | TORCHTMRCNTLTORCHTMRCNTL | TORCH_TMR_CNTL: TORCH_TMR_CNTL
Public property | TX1MASKFLASHTX1MASK | TX1_MASK: FLASH_TX1_MASK (unit: mA)
Public property | TX1MASKTX1MASKEN | TX1_MASK: TX1_MASK_EN
Public property | TX1MASKTX1MASKPD | TX1_MASK: TX1_MASK_PD
Public property | TX2MASKFLASHTX2MASK | TX2_MASK: FLASH_TX2_MASK (unit: mA)
Public property | TX2MASKTX2MASKEN | TX2_MASK: TX2_MASK_EN
Public property | TX2MASKTX2MASKPD | TX2_MASK: TX2_MASK_PD
Top
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.AutoFlush Property

IRD

Max77387AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.CHIPID1DIETYPE Property

IRD

Max77387CHIPID1DIETYPE Property

CHIP_ID1: DIE_TYPE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CHIPID1DIETYPE { get; }
Public ReadOnly Property CHIPID1DIETYPE As Byte
    Get
public:
property unsigned char CHIPID1DIETYPE {
    unsigned char get ();
}
member CHIPID1DIETYPE : byte with get

Property Value

Type: Byte
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.CHIPID2DIEDASH Property

IRD

Max77387CHIPID2DIEDASH Property

CHIP_ID2: DIE_DASH

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CHIPID2DIEDASH { get; }
Public ReadOnly Property CHIPID2DIEDASH As Byte
    Get
public:
property unsigned char CHIPID2DIEDASH {
    unsigned char get ();
}
member CHIPID2DIEDASH : byte with get

Property Value

Type: Byte
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.CHIPID2DIEREV Property

IRD

Max77387CHIPID2DIEREV Property

CHIP_ID2: DIE_REV

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CHIPID2DIEREV { get; }
Public ReadOnly Property CHIPID2DIEREV As Byte
    Get
public:
property unsigned char CHIPID2DIEREV {
    unsigned char get ();
}
member CHIPID2DIEREV : byte with get

Property Value

Type: Byte
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.DCDCCNTL1DCDCMODE Property

IRD

Max77387DCDCCNTL1DCDCMODE Property

DCDC_CNTL1: DCDC_MODE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeDcdcCntl1Mode DCDCCNTL1DCDCMODE { get; set; }
Public Property DCDCCNTL1DCDCMODE As Max77387TypeDcdcCntl1Mode
    Get
    Set
public:
property Max77387TypeDcdcCntl1Mode DCDCCNTL1DCDCMODE {
    Max77387TypeDcdcCntl1Mode get ();
    void set (Max77387TypeDcdcCntl1Mode value);
}
member DCDCCNTL1DCDCMODE : Max77387TypeDcdcCntl1Mode with get, set

Property Value

Type: Max77387TypeDcdcCntl1Mode
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.DCDCCNTL1FREQPWM Property

IRD

Max77387DCDCCNTL1FREQPWM Property

DCDC_CNTL1: FREQ_PWM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeDcdcCntl1PwmFrequency DCDCCNTL1FREQPWM { get; set; }
Public Property DCDCCNTL1FREQPWM As Max77387TypeDcdcCntl1PwmFrequency
    Get
    Set
public:
property Max77387TypeDcdcCntl1PwmFrequency DCDCCNTL1FREQPWM {
    Max77387TypeDcdcCntl1PwmFrequency get ();
    void set (Max77387TypeDcdcCntl1PwmFrequency value);
}
member DCDCCNTL1FREQPWM : Max77387TypeDcdcCntl1PwmFrequency with get, set

Property Value

Type: Max77387TypeDcdcCntl1PwmFrequency
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.DCDCCNTL1OVPTH Property

IRD

Max77387DCDCCNTL1OVPTH Property

DCDC_CNTL1: OVP_TH (unit: V)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeDcdcCntl1OvervoltageThreshold DCDCCNTL1OVPTH { get; set; }
Public Property DCDCCNTL1OVPTH As Max77387TypeDcdcCntl1OvervoltageThreshold
    Get
    Set
public:
property Max77387TypeDcdcCntl1OvervoltageThreshold DCDCCNTL1OVPTH {
    Max77387TypeDcdcCntl1OvervoltageThreshold get ();
    void set (Max77387TypeDcdcCntl1OvervoltageThreshold value);
}
member DCDCCNTL1OVPTH : Max77387TypeDcdcCntl1OvervoltageThreshold with get, set

Property Value

Type: Max77387TypeDcdcCntl1OvervoltageThreshold
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.DCDCCNTL2DCDCADPTREG Property

IRD

Max77387DCDCCNTL2DCDCADPTREG Property

DCDC_CNTL2: DCDC_ADPT_REG (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeDcdcCntl2AdaptiveRegulation DCDCCNTL2DCDCADPTREG { get; set; }
Public Property DCDCCNTL2DCDCADPTREG As Max77387TypeDcdcCntl2AdaptiveRegulation
    Get
    Set
public:
property Max77387TypeDcdcCntl2AdaptiveRegulation DCDCCNTL2DCDCADPTREG {
    Max77387TypeDcdcCntl2AdaptiveRegulation get ();
    void set (Max77387TypeDcdcCntl2AdaptiveRegulation value);
}
member DCDCCNTL2DCDCADPTREG : Max77387TypeDcdcCntl2AdaptiveRegulation with get, set

Property Value

Type: Max77387TypeDcdcCntl2AdaptiveRegulation
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.DCDCCNTL2DCDCGAIN Property

IRD

Max77387DCDCCNTL2DCDCGAIN Property

DCDC_CNTL2: DCDC_GAIN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeDcdcCntl2Gain DCDCCNTL2DCDCGAIN { get; set; }
Public Property DCDCCNTL2DCDCGAIN As Max77387TypeDcdcCntl2Gain
    Get
    Set
public:
property Max77387TypeDcdcCntl2Gain DCDCCNTL2DCDCGAIN {
    Max77387TypeDcdcCntl2Gain get ();
    void set (Max77387TypeDcdcCntl2Gain value);
}
member DCDCCNTL2DCDCGAIN : Max77387TypeDcdcCntl2Gain with get, set

Property Value

Type: Max77387TypeDcdcCntl2Gain
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.DCDCCNTL2DCDCOPERATION Property

IRD

Max77387DCDCCNTL2DCDCOPERATION Property

DCDC_CNTL2: DCDC_OPERATION

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeDcdcCntl2OperationMode DCDCCNTL2DCDCOPERATION { get; set; }
Public Property DCDCCNTL2DCDCOPERATION As Max77387TypeDcdcCntl2OperationMode
    Get
    Set
public:
property Max77387TypeDcdcCntl2OperationMode DCDCCNTL2DCDCOPERATION {
    Max77387TypeDcdcCntl2OperationMode get ();
    void set (Max77387TypeDcdcCntl2OperationMode value);
}
member DCDCCNTL2DCDCOPERATION : Max77387TypeDcdcCntl2OperationMode with get, set

Property Value

Type: Max77387TypeDcdcCntl2OperationMode
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.DCDCLIMDCDCLIM Property

IRD

Max77387DCDCLIMDCDCLIM Property

DCDC_LIM: DCDC_LIM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeDcdcLimCurrentLimit DCDCLIMDCDCLIM { get; set; }
Public Property DCDCLIMDCDCLIM As Max77387TypeDcdcLimCurrentLimit
    Get
    Set
public:
property Max77387TypeDcdcLimCurrentLimit DCDCLIMDCDCLIM {
    Max77387TypeDcdcLimCurrentLimit get ();
    void set (Max77387TypeDcdcLimCurrentLimit value);
}
member DCDCLIMDCDCLIM : Max77387TypeDcdcLimCurrentLimit with get, set

Property Value

Type: Max77387TypeDcdcLimCurrentLimit
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.DCDCLIMDCDCSS Property

IRD

Max77387DCDCLIMDCDCSS Property

DCDC_LIM: DCDC_SS (unit: V)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeDcdcLimSoftStartThreshold DCDCLIMDCDCSS { get; set; }
Public Property DCDCLIMDCDCSS As Max77387TypeDcdcLimSoftStartThreshold
    Get
    Set
public:
property Max77387TypeDcdcLimSoftStartThreshold DCDCLIMDCDCSS {
    Max77387TypeDcdcLimSoftStartThreshold get ();
    void set (Max77387TypeDcdcLimSoftStartThreshold value);
}
member DCDCLIMDCDCSS : Max77387TypeDcdcLimSoftStartThreshold with get, set

Property Value

Type: Max77387TypeDcdcLimSoftStartThreshold
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.DCDCOUTDCDCOUT Property

IRD

Max77387DCDCOUTDCDCOUT Property

DCDC_OUT: DCDC_OUT (unit: V)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeDcdcOutOutputVoltage DCDCOUTDCDCOUT { get; }
Public ReadOnly Property DCDCOUTDCDCOUT As Max77387TypeDcdcOutOutputVoltage
    Get
public:
property Max77387TypeDcdcOutOutputVoltage DCDCOUTDCDCOUT {
    Max77387TypeDcdcOutOutputVoltage get ();
}
member DCDCOUTDCDCOUT : Max77387TypeDcdcOutOutputVoltage with get

Property Value

Type: Max77387TypeDcdcOutOutputVoltage
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.DCDCOUTMAXDCDCOUTMAX Property

IRD

Max77387DCDCOUTMAXDCDCOUTMAX Property

DCDC_OUT_MAX: DCDC_OUT_MAX (unit: V)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeDcdcOutMaxOutputVoltage DCDCOUTMAXDCDCOUTMAX { get; }
Public ReadOnly Property DCDCOUTMAXDCDCOUTMAX As Max77387TypeDcdcOutMaxOutputVoltage
    Get
public:
property Max77387TypeDcdcOutMaxOutputVoltage DCDCOUTMAXDCDCOUTMAX {
    Max77387TypeDcdcOutMaxOutputVoltage get ();
}
member DCDCOUTMAXDCDCOUTMAX : Max77387TypeDcdcOutMaxOutputVoltage with get

Property Value

Type: Max77387TypeDcdcOutMaxOutputVoltage
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.FLASHRAMPSELFLASHRD Property

IRD

Max77387FLASHRAMPSELFLASHRD Property

FLASH_RAMP_SEL: FLASH_RD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeFlashRampSelRampDown FLASHRAMPSELFLASHRD { get; set; }
Public Property FLASHRAMPSELFLASHRD As Max77387TypeFlashRampSelRampDown
    Get
    Set
public:
property Max77387TypeFlashRampSelRampDown FLASHRAMPSELFLASHRD {
    Max77387TypeFlashRampSelRampDown get ();
    void set (Max77387TypeFlashRampSelRampDown value);
}
member FLASHRAMPSELFLASHRD : Max77387TypeFlashRampSelRampDown with get, set

Property Value

Type: Max77387TypeFlashRampSelRampDown
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.FLASHRAMPSELFLASHRU Property

IRD

Max77387FLASHRAMPSELFLASHRU Property

FLASH_RAMP_SEL: FLASH_RU

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeFlashRampSelRampUp FLASHRAMPSELFLASHRU { get; set; }
Public Property FLASHRAMPSELFLASHRU As Max77387TypeFlashRampSelRampUp
    Get
    Set
public:
property Max77387TypeFlashRampSelRampUp FLASHRAMPSELFLASHRU {
    Max77387TypeFlashRampSelRampUp get ();
    void set (Max77387TypeFlashRampSelRampUp value);
}
member FLASHRAMPSELFLASHRU : Max77387TypeFlashRampSelRampUp with get, set

Property Value

Type: Max77387TypeFlashRampSelRampUp
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.FLASHTMRCNTLFLASHTMR Property

IRD

Max77387FLASHTMRCNTLFLASHTMR Property

FLASH_TMR_CNTL: FLASH_TMR (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeFlashTmrCntlFlashTimer FLASHTMRCNTLFLASHTMR { get; set; }
Public Property FLASHTMRCNTLFLASHTMR As Max77387TypeFlashTmrCntlFlashTimer
    Get
    Set
public:
property Max77387TypeFlashTmrCntlFlashTimer FLASHTMRCNTLFLASHTMR {
    Max77387TypeFlashTmrCntlFlashTimer get ();
    void set (Max77387TypeFlashTmrCntlFlashTimer value);
}
member FLASHTMRCNTLFLASHTMR : Max77387TypeFlashTmrCntlFlashTimer with get, set

Property Value

Type: Max77387TypeFlashTmrCntlFlashTimer
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.FLASHTMRCNTLFLASHTMRCNTL Property

IRD

Max77387FLASHTMRCNTLFLASHTMRCNTL Property

FLASH_TMR_CNTL: FLASH_TMR_CNTL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeFlashTmrCntlTimerMode FLASHTMRCNTLFLASHTMRCNTL { get; set; }
Public Property FLASHTMRCNTLFLASHTMRCNTL As Max77387TypeFlashTmrCntlTimerMode
    Get
    Set
public:
property Max77387TypeFlashTmrCntlTimerMode FLASHTMRCNTLFLASHTMRCNTL {
    Max77387TypeFlashTmrCntlTimerMode get ();
    void set (Max77387TypeFlashTmrCntlTimerMode value);
}
member FLASHTMRCNTLFLASHTMRCNTL : Max77387TypeFlashTmrCntlTimerMode with get, set

Property Value

Type: Max77387TypeFlashTmrCntlTimerMode
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.IFLASH1FLASH1 Property

IRD

Max77387IFLASH1FLASH1 Property

IFLASH1: FLASH1 (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeIflash1FlashCurrent IFLASH1FLASH1 { get; set; }
Public Property IFLASH1FLASH1 As Max77387TypeIflash1FlashCurrent
    Get
    Set
public:
property Max77387TypeIflash1FlashCurrent IFLASH1FLASH1 {
    Max77387TypeIflash1FlashCurrent get ();
    void set (Max77387TypeIflash1FlashCurrent value);
}
member IFLASH1FLASH1 : Max77387TypeIflash1FlashCurrent with get, set

Property Value

Type: Max77387TypeIflash1FlashCurrent
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.IFLASH1FLASH1EN Property

IRD

Max77387IFLASH1FLASH1EN Property

IFLASH1: FLASH1_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeIflash1Enable IFLASH1FLASH1EN { get; set; }
Public Property IFLASH1FLASH1EN As Max77387TypeIflash1Enable
    Get
    Set
public:
property Max77387TypeIflash1Enable IFLASH1FLASH1EN {
    Max77387TypeIflash1Enable get ();
    void set (Max77387TypeIflash1Enable value);
}
member IFLASH1FLASH1EN : Max77387TypeIflash1Enable with get, set

Property Value

Type: Max77387TypeIflash1Enable
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.IFLASH2FLASH2 Property

IRD

Max77387IFLASH2FLASH2 Property

IFLASH2: FLASH2 (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeIflash2FlashCurrent IFLASH2FLASH2 { get; set; }
Public Property IFLASH2FLASH2 As Max77387TypeIflash2FlashCurrent
    Get
    Set
public:
property Max77387TypeIflash2FlashCurrent IFLASH2FLASH2 {
    Max77387TypeIflash2FlashCurrent get ();
    void set (Max77387TypeIflash2FlashCurrent value);
}
member IFLASH2FLASH2 : Max77387TypeIflash2FlashCurrent with get, set

Property Value

Type: Max77387TypeIflash2FlashCurrent
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.IFLASH2FLASH2EN Property

IRD

Max77387IFLASH2FLASH2EN Property

IFLASH2: FLASH2_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeIflash2Enable IFLASH2FLASH2EN { get; set; }
Public Property IFLASH2FLASH2EN As Max77387TypeIflash2Enable
    Get
    Set
public:
property Max77387TypeIflash2Enable IFLASH2FLASH2EN {
    Max77387TypeIflash2Enable get ();
    void set (Max77387TypeIflash2Enable value);
}
member IFLASH2FLASH2EN : Max77387TypeIflash2Enable with get, set

Property Value

Type: Max77387TypeIflash2Enable
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.ITORCH1TORCH1 Property

IRD

Max77387ITORCH1TORCH1 Property

ITORCH1: TORCH1 (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeItorch1TorchCurrent ITORCH1TORCH1 { get; set; }
Public Property ITORCH1TORCH1 As Max77387TypeItorch1TorchCurrent
    Get
    Set
public:
property Max77387TypeItorch1TorchCurrent ITORCH1TORCH1 {
    Max77387TypeItorch1TorchCurrent get ();
    void set (Max77387TypeItorch1TorchCurrent value);
}
member ITORCH1TORCH1 : Max77387TypeItorch1TorchCurrent with get, set

Property Value

Type: Max77387TypeItorch1TorchCurrent
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.ITORCH1TORCH1DIM Property

IRD

Max77387ITORCH1TORCH1DIM Property

ITORCH1: TORCH1_DIM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeItorch1Dimming ITORCH1TORCH1DIM { get; set; }
Public Property ITORCH1TORCH1DIM As Max77387TypeItorch1Dimming
    Get
    Set
public:
property Max77387TypeItorch1Dimming ITORCH1TORCH1DIM {
    Max77387TypeItorch1Dimming get ();
    void set (Max77387TypeItorch1Dimming value);
}
member ITORCH1TORCH1DIM : Max77387TypeItorch1Dimming with get, set

Property Value

Type: Max77387TypeItorch1Dimming
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.ITORCH1TORCH1EN Property

IRD

Max77387ITORCH1TORCH1EN Property

ITORCH1: TORCH1_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeItorch1Enable ITORCH1TORCH1EN { get; set; }
Public Property ITORCH1TORCH1EN As Max77387TypeItorch1Enable
    Get
    Set
public:
property Max77387TypeItorch1Enable ITORCH1TORCH1EN {
    Max77387TypeItorch1Enable get ();
    void set (Max77387TypeItorch1Enable value);
}
member ITORCH1TORCH1EN : Max77387TypeItorch1Enable with get, set

Property Value

Type: Max77387TypeItorch1Enable
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.ITORCH2TORCH2 Property

IRD

Max77387ITORCH2TORCH2 Property

ITORCH2: TORCH2 (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeItorch2TorchCurrent ITORCH2TORCH2 { get; set; }
Public Property ITORCH2TORCH2 As Max77387TypeItorch2TorchCurrent
    Get
    Set
public:
property Max77387TypeItorch2TorchCurrent ITORCH2TORCH2 {
    Max77387TypeItorch2TorchCurrent get ();
    void set (Max77387TypeItorch2TorchCurrent value);
}
member ITORCH2TORCH2 : Max77387TypeItorch2TorchCurrent with get, set

Property Value

Type: Max77387TypeItorch2TorchCurrent
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.ITORCH2TORCH2DIM Property

IRD

Max77387ITORCH2TORCH2DIM Property

ITORCH2: TORCH2_DIM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeItorch2Dimming ITORCH2TORCH2DIM { get; set; }
Public Property ITORCH2TORCH2DIM As Max77387TypeItorch2Dimming
    Get
    Set
public:
property Max77387TypeItorch2Dimming ITORCH2TORCH2DIM {
    Max77387TypeItorch2Dimming get ();
    void set (Max77387TypeItorch2Dimming value);
}
member ITORCH2TORCH2DIM : Max77387TypeItorch2Dimming with get, set

Property Value

Type: Max77387TypeItorch2Dimming
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.ITORCH2TORCH2EN Property

IRD

Max77387ITORCH2TORCH2EN Property

ITORCH2: TORCH2_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeItorch2Enable ITORCH2TORCH2EN { get; set; }
Public Property ITORCH2TORCH2EN As Max77387TypeItorch2Enable
    Get
    Set
public:
property Max77387TypeItorch2Enable ITORCH2TORCH2EN {
    Max77387TypeItorch2Enable get ();
    void set (Max77387TypeItorch2Enable value);
}
member ITORCH2TORCH2EN : Max77387TypeItorch2Enable with get, set

Property Value

Type: Max77387TypeItorch2Enable
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.MAXFLASH1MAXFLASHHYS Property

IRD

Max77387MAXFLASH1MAXFLASHHYS Property

MAXFLASH1: MAXFLASH_HYS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeMaxflash1Hysteresis MAXFLASH1MAXFLASHHYS { get; set; }
Public Property MAXFLASH1MAXFLASHHYS As Max77387TypeMaxflash1Hysteresis
    Get
    Set
public:
property Max77387TypeMaxflash1Hysteresis MAXFLASH1MAXFLASHHYS {
    Max77387TypeMaxflash1Hysteresis get ();
    void set (Max77387TypeMaxflash1Hysteresis value);
}
member MAXFLASH1MAXFLASHHYS : Max77387TypeMaxflash1Hysteresis with get, set

Property Value

Type: Max77387TypeMaxflash1Hysteresis
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.MAXFLASH1MAXFLASHTH Property

IRD

Max77387MAXFLASH1MAXFLASHTH Property

MAXFLASH1: MAXFLASH_TH

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeMaxflash1Threshold MAXFLASH1MAXFLASHTH { get; set; }
Public Property MAXFLASH1MAXFLASHTH As Max77387TypeMaxflash1Threshold
    Get
    Set
public:
property Max77387TypeMaxflash1Threshold MAXFLASH1MAXFLASHTH {
    Max77387TypeMaxflash1Threshold get ();
    void set (Max77387TypeMaxflash1Threshold value);
}
member MAXFLASH1MAXFLASHTH : Max77387TypeMaxflash1Threshold with get, set

Property Value

Type: Max77387TypeMaxflash1Threshold
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.MAXFLASH2LBTMRF Property

IRD

Max77387MAXFLASH2LBTMRF Property

MAXFLASH2: LB_TMR_F (unit: µs)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeMaxflash2TimerFallingInputVoltage MAXFLASH2LBTMRF { get; set; }
Public Property MAXFLASH2LBTMRF As Max77387TypeMaxflash2TimerFallingInputVoltage
    Get
    Set
public:
property Max77387TypeMaxflash2TimerFallingInputVoltage MAXFLASH2LBTMRF {
    Max77387TypeMaxflash2TimerFallingInputVoltage get ();
    void set (Max77387TypeMaxflash2TimerFallingInputVoltage value);
}
member MAXFLASH2LBTMRF : Max77387TypeMaxflash2TimerFallingInputVoltage with get, set

Property Value

Type: Max77387TypeMaxflash2TimerFallingInputVoltage
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.MAXFLASH2LBTMRR Property

IRD

Max77387MAXFLASH2LBTMRR Property

MAXFLASH2: LB_TMR_R (unit: µs)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeMaxflash2TimerRisingInputVoltage MAXFLASH2LBTMRR { get; set; }
Public Property MAXFLASH2LBTMRR As Max77387TypeMaxflash2TimerRisingInputVoltage
    Get
    Set
public:
property Max77387TypeMaxflash2TimerRisingInputVoltage MAXFLASH2LBTMRR {
    Max77387TypeMaxflash2TimerRisingInputVoltage get ();
    void set (Max77387TypeMaxflash2TimerRisingInputVoltage value);
}
member MAXFLASH2LBTMRR : Max77387TypeMaxflash2TimerRisingInputVoltage with get, set

Property Value

Type: Max77387TypeMaxflash2TimerRisingInputVoltage
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.MAXFLASH3MAXFLASH1IMIN Property

IRD

Max77387MAXFLASH3MAXFLASH1IMIN Property

MAXFLASH3: MAX_FLASH1_IMIN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MAXFLASH3MAXFLASH1IMIN { get; }
Public ReadOnly Property MAXFLASH3MAXFLASH1IMIN As Byte
    Get
public:
property unsigned char MAXFLASH3MAXFLASH1IMIN {
    unsigned char get ();
}
member MAXFLASH3MAXFLASH1IMIN : byte with get

Property Value

Type: Byte
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.MAXFLASH4MAXFLASH2IMIN Property

IRD

Max77387MAXFLASH4MAXFLASH2IMIN Property

MAXFLASH4: MAX_FLASH2_IMIN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MAXFLASH4MAXFLASH2IMIN { get; }
Public ReadOnly Property MAXFLASH4MAXFLASH2IMIN As Byte
    Get
public:
property unsigned char MAXFLASH4MAXFLASH2IMIN {
    unsigned char get ();
}
member MAXFLASH4MAXFLASH2IMIN : byte with get

Property Value

Type: Byte
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.MODESELFLASHMODE Property

IRD

Max77387MODESELFLASHMODE Property

MODE_SEL: FLASH_MODE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeModeSelFlashMode MODESELFLASHMODE { get; set; }
Public Property MODESELFLASHMODE As Max77387TypeModeSelFlashMode
    Get
    Set
public:
property Max77387TypeModeSelFlashMode MODESELFLASHMODE {
    Max77387TypeModeSelFlashMode get ();
    void set (Max77387TypeModeSelFlashMode value);
}
member MODESELFLASHMODE : Max77387TypeModeSelFlashMode with get, set

Property Value

Type: Max77387TypeModeSelFlashMode
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.MODESELFLASHSTBPD Property

IRD

Max77387MODESELFLASHSTBPD Property

MODE_SEL: FLASH_STB_PD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeModeSelFlashStbPulldown MODESELFLASHSTBPD { get; set; }
Public Property MODESELFLASHSTBPD As Max77387TypeModeSelFlashStbPulldown
    Get
    Set
public:
property Max77387TypeModeSelFlashStbPulldown MODESELFLASHSTBPD {
    Max77387TypeModeSelFlashStbPulldown get ();
    void set (Max77387TypeModeSelFlashStbPulldown value);
}
member MODESELFLASHSTBPD : Max77387TypeModeSelFlashStbPulldown with get, set

Property Value

Type: Max77387TypeModeSelFlashStbPulldown
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.MODESELTORCHENPD Property

IRD

Max77387MODESELTORCHENPD Property

MODE_SEL: TORCH_EN_PD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeModeSelTorchEnPulldown MODESELTORCHENPD { get; set; }
Public Property MODESELTORCHENPD As Max77387TypeModeSelTorchEnPulldown
    Get
    Set
public:
property Max77387TypeModeSelTorchEnPulldown MODESELTORCHENPD {
    Max77387TypeModeSelTorchEnPulldown get ();
    void set (Max77387TypeModeSelTorchEnPulldown value);
}
member MODESELTORCHENPD : Max77387TypeModeSelTorchEnPulldown with get, set

Property Value

Type: Max77387TypeModeSelTorchEnPulldown
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.MODESELTORCHMODE Property

IRD

Max77387MODESELTORCHMODE Property

MODE_SEL: TORCH_MODE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeModeSelTorchMode MODESELTORCHMODE { get; set; }
Public Property MODESELTORCHMODE As Max77387TypeModeSelTorchMode
    Get
    Set
public:
property Max77387TypeModeSelTorchMode MODESELTORCHMODE {
    Max77387TypeModeSelTorchMode get ();
    void set (Max77387TypeModeSelTorchMode value);
}
member MODESELTORCHMODE : Max77387TypeModeSelTorchMode with get, set

Property Value

Type: Max77387TypeModeSelTorchMode
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.NTCNTCEN Property

IRD

Max77387NTCNTCEN Property

NTC: NTC_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeNtcOnOffControl NTCNTCEN { get; set; }
Public Property NTCNTCEN As Max77387TypeNtcOnOffControl
    Get
    Set
public:
property Max77387TypeNtcOnOffControl NTCNTCEN {
    Max77387TypeNtcOnOffControl get ();
    void set (Max77387TypeNtcOnOffControl value);
}
member NTCNTCEN : Max77387TypeNtcOnOffControl with get, set

Property Value

Type: Max77387TypeNtcOnOffControl
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.NTCNTCTHFLASH Property

IRD

Max77387NTCNTCTHFLASH Property

NTC: NTC_TH_FLASH (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeNtcThresholdFlashMode NTCNTCTHFLASH { get; set; }
Public Property NTCNTCTHFLASH As Max77387TypeNtcThresholdFlashMode
    Get
    Set
public:
property Max77387TypeNtcThresholdFlashMode NTCNTCTHFLASH {
    Max77387TypeNtcThresholdFlashMode get ();
    void set (Max77387TypeNtcThresholdFlashMode value);
}
member NTCNTCTHFLASH : Max77387TypeNtcThresholdFlashMode with get, set

Property Value

Type: Max77387TypeNtcThresholdFlashMode
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.NTCNTCTHTORCH Property

IRD

Max77387NTCNTCTHTORCH Property

NTC: NTC_TH_TORCH (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeNtcThresholdTorchMode NTCNTCTHTORCH { get; set; }
Public Property NTCNTCTHTORCH As Max77387TypeNtcThresholdTorchMode
    Get
    Set
public:
property Max77387TypeNtcThresholdTorchMode NTCNTCTHTORCH {
    Max77387TypeNtcThresholdTorchMode get ();
    void set (Max77387TypeNtcThresholdTorchMode value);
}
member NTCNTCTHTORCH : Max77387TypeNtcThresholdTorchMode with get, set

Property Value

Type: Max77387TypeNtcThresholdTorchMode
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.STATUS1INUVLOTHERM Property

IRD

Max77387STATUS1INUVLOTHERM Property

STATUS1: IN_UVLO_THERM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeStatus1InPowerAndTemp STATUS1INUVLOTHERM { get; }
Public ReadOnly Property STATUS1INUVLOTHERM As Max77387TypeStatus1InPowerAndTemp
    Get
public:
property Max77387TypeStatus1InPowerAndTemp STATUS1INUVLOTHERM {
    Max77387TypeStatus1InPowerAndTemp get ();
}
member STATUS1INUVLOTHERM : Max77387TypeStatus1InPowerAndTemp with get

Property Value

Type: Max77387TypeStatus1InPowerAndTemp
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.STATUS1LED1SHORT Property

IRD

Max77387STATUS1LED1SHORT Property

STATUS1: LED1_SHORT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeStatus1Led1Short STATUS1LED1SHORT { get; }
Public ReadOnly Property STATUS1LED1SHORT As Max77387TypeStatus1Led1Short
    Get
public:
property Max77387TypeStatus1Led1Short STATUS1LED1SHORT {
    Max77387TypeStatus1Led1Short get ();
}
member STATUS1LED1SHORT : Max77387TypeStatus1Led1Short with get

Property Value

Type: Max77387TypeStatus1Led1Short
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.STATUS1LED2SHORT Property

IRD

Max77387STATUS1LED2SHORT Property

STATUS1: LED2_SHORT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeStatus1Led2Short STATUS1LED2SHORT { get; }
Public ReadOnly Property STATUS1LED2SHORT As Max77387TypeStatus1Led2Short
    Get
public:
property Max77387TypeStatus1Led2Short STATUS1LED2SHORT {
    Max77387TypeStatus1Led2Short get ();
}
member STATUS1LED2SHORT : Max77387TypeStatus1Led2Short with get

Property Value

Type: Max77387TypeStatus1Led2Short
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.STATUS1NTCSHORT Property

IRD

Max77387STATUS1NTCSHORT Property

STATUS1: NTC_SHORT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeStatus1NtcShort STATUS1NTCSHORT { get; }
Public ReadOnly Property STATUS1NTCSHORT As Max77387TypeStatus1NtcShort
    Get
public:
property Max77387TypeStatus1NtcShort STATUS1NTCSHORT {
    Max77387TypeStatus1NtcShort get ();
}
member STATUS1NTCSHORT : Max77387TypeStatus1NtcShort with get

Property Value

Type: Max77387TypeStatus1NtcShort
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.STATUS1NTCTHERM Property

IRD

Max77387STATUS1NTCTHERM Property

STATUS1: NTC_THERM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeStatus1NtcResistor STATUS1NTCTHERM { get; }
Public ReadOnly Property STATUS1NTCTHERM As Max77387TypeStatus1NtcResistor
    Get
public:
property Max77387TypeStatus1NtcResistor STATUS1NTCTHERM {
    Max77387TypeStatus1NtcResistor get ();
}
member STATUS1NTCTHERM : Max77387TypeStatus1NtcResistor with get

Property Value

Type: Max77387TypeStatus1NtcResistor
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.STATUS1OVPA Property

IRD

Max77387STATUS1OVPA Property

STATUS1: OVP_A

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeStatus1OvervoltageAnalog STATUS1OVPA { get; }
Public ReadOnly Property STATUS1OVPA As Max77387TypeStatus1OvervoltageAnalog
    Get
public:
property Max77387TypeStatus1OvervoltageAnalog STATUS1OVPA {
    Max77387TypeStatus1OvervoltageAnalog get ();
}
member STATUS1OVPA : Max77387TypeStatus1OvervoltageAnalog with get

Property Value

Type: Max77387TypeStatus1OvervoltageAnalog
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.STATUS1OVPD Property

IRD

Max77387STATUS1OVPD Property

STATUS1: OVP_D

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeStatus1OvervoltageDigital STATUS1OVPD { get; }
Public ReadOnly Property STATUS1OVPD As Max77387TypeStatus1OvervoltageDigital
    Get
public:
property Max77387TypeStatus1OvervoltageDigital STATUS1OVPD {
    Max77387TypeStatus1OvervoltageDigital get ();
}
member STATUS1OVPD : Max77387TypeStatus1OvervoltageDigital with get

Property Value

Type: Max77387TypeStatus1OvervoltageDigital
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.STATUS1REGINUVLO Property

IRD

Max77387STATUS1REGINUVLO Property

STATUS1: REG_IN_UVLO

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeStatus1RegInPower STATUS1REGINUVLO { get; }
Public ReadOnly Property STATUS1REGINUVLO As Max77387TypeStatus1RegInPower
    Get
public:
property Max77387TypeStatus1RegInPower STATUS1REGINUVLO {
    Max77387TypeStatus1RegInPower get ();
}
member STATUS1REGINUVLO : Max77387TypeStatus1RegInPower with get

Property Value

Type: Max77387TypeStatus1RegInPower
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.STATUS2DONE Property

IRD

Max77387STATUS2DONE Property

STATUS2: DONE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeStatus2TorchFlashEvent STATUS2DONE { get; }
Public ReadOnly Property STATUS2DONE As Max77387TypeStatus2TorchFlashEvent
    Get
public:
property Max77387TypeStatus2TorchFlashEvent STATUS2DONE {
    Max77387TypeStatus2TorchFlashEvent get ();
}
member STATUS2DONE : Max77387TypeStatus2TorchFlashEvent with get

Property Value

Type: Max77387TypeStatus2TorchFlashEvent
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.STATUS2FLASHTMR Property

IRD

Max77387STATUS2FLASHTMR Property

STATUS2: FLASH_TMR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeStatus2FlashTimer STATUS2FLASHTMR { get; }
Public ReadOnly Property STATUS2FLASHTMR As Max77387TypeStatus2FlashTimer
    Get
public:
property Max77387TypeStatus2FlashTimer STATUS2FLASHTMR {
    Max77387TypeStatus2FlashTimer get ();
}
member STATUS2FLASHTMR : Max77387TypeStatus2FlashTimer with get

Property Value

Type: Max77387TypeStatus2FlashTimer
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.STATUS2ILIM Property

IRD

Max77387STATUS2ILIM Property

STATUS2: ILIM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeStatus2InductorCurrentLimit STATUS2ILIM { get; }
Public ReadOnly Property STATUS2ILIM As Max77387TypeStatus2InductorCurrentLimit
    Get
public:
property Max77387TypeStatus2InductorCurrentLimit STATUS2ILIM {
    Max77387TypeStatus2InductorCurrentLimit get ();
}
member STATUS2ILIM : Max77387TypeStatus2InductorCurrentLimit with get

Property Value

Type: Max77387TypeStatus2InductorCurrentLimit
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.STATUS2MAXFLASH Property

IRD

Max77387STATUS2MAXFLASH Property

STATUS2: MAXFLASH

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeStatus2MaxFlash STATUS2MAXFLASH { get; }
Public ReadOnly Property STATUS2MAXFLASH As Max77387TypeStatus2MaxFlash
    Get
public:
property Max77387TypeStatus2MaxFlash STATUS2MAXFLASH {
    Max77387TypeStatus2MaxFlash get ();
}
member STATUS2MAXFLASH : Max77387TypeStatus2MaxFlash with get

Property Value

Type: Max77387TypeStatus2MaxFlash
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.STATUS2NRESET Property

IRD

Max77387STATUS2NRESET Property

STATUS2: nRESET

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeStatus2Reset STATUS2NRESET { get; }
Public ReadOnly Property STATUS2NRESET As Max77387TypeStatus2Reset
    Get
public:
property Max77387TypeStatus2Reset STATUS2NRESET {
    Max77387TypeStatus2Reset get ();
}
member STATUS2NRESET : Max77387TypeStatus2Reset with get

Property Value

Type: Max77387TypeStatus2Reset
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.STATUS2TORCHTMR Property

IRD

Max77387STATUS2TORCHTMR Property

STATUS2: TORCH_TMR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeStatus2TorchTimer STATUS2TORCHTMR { get; }
Public ReadOnly Property STATUS2TORCHTMR As Max77387TypeStatus2TorchTimer
    Get
public:
property Max77387TypeStatus2TorchTimer STATUS2TORCHTMR {
    Max77387TypeStatus2TorchTimer get ();
}
member STATUS2TORCHTMR : Max77387TypeStatus2TorchTimer with get

Property Value

Type: Max77387TypeStatus2TorchTimer
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.STATUS2TX1MASK Property

IRD

Max77387STATUS2TX1MASK Property

STATUS2: TX1_MASK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeStatus2Tx1Mask STATUS2TX1MASK { get; }
Public ReadOnly Property STATUS2TX1MASK As Max77387TypeStatus2Tx1Mask
    Get
public:
property Max77387TypeStatus2Tx1Mask STATUS2TX1MASK {
    Max77387TypeStatus2Tx1Mask get ();
}
member STATUS2TX1MASK : Max77387TypeStatus2Tx1Mask with get

Property Value

Type: Max77387TypeStatus2Tx1Mask
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.STATUS2TX2MASK Property

IRD

Max77387STATUS2TX2MASK Property

STATUS2: TX2_MASK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeStatus2Tx2Mask STATUS2TX2MASK { get; }
Public ReadOnly Property STATUS2TX2MASK As Max77387TypeStatus2Tx2Mask
    Get
public:
property Max77387TypeStatus2Tx2Mask STATUS2TX2MASK {
    Max77387TypeStatus2Tx2Mask get ();
}
member STATUS2TX2MASK : Max77387TypeStatus2Tx2Mask with get

Property Value

Type: Max77387TypeStatus2Tx2Mask
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.TORCHRAMPSELTORCHRD Property

IRD

Max77387TORCHRAMPSELTORCHRD Property

TORCH_RAMP_SEL: TORCH_RD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeTorchRampSelRampDown TORCHRAMPSELTORCHRD { get; set; }
Public Property TORCHRAMPSELTORCHRD As Max77387TypeTorchRampSelRampDown
    Get
    Set
public:
property Max77387TypeTorchRampSelRampDown TORCHRAMPSELTORCHRD {
    Max77387TypeTorchRampSelRampDown get ();
    void set (Max77387TypeTorchRampSelRampDown value);
}
member TORCHRAMPSELTORCHRD : Max77387TypeTorchRampSelRampDown with get, set

Property Value

Type: Max77387TypeTorchRampSelRampDown
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.TORCHRAMPSELTORCHRU Property

IRD

Max77387TORCHRAMPSELTORCHRU Property

TORCH_RAMP_SEL: TORCH_RU

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeTorchRampSelRampUp TORCHRAMPSELTORCHRU { get; set; }
Public Property TORCHRAMPSELTORCHRU As Max77387TypeTorchRampSelRampUp
    Get
    Set
public:
property Max77387TypeTorchRampSelRampUp TORCHRAMPSELTORCHRU {
    Max77387TypeTorchRampSelRampUp get ();
    void set (Max77387TypeTorchRampSelRampUp value);
}
member TORCHRAMPSELTORCHRU : Max77387TypeTorchRampSelRampUp with get, set

Property Value

Type: Max77387TypeTorchRampSelRampUp
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.TORCHTMRCNTLTORCHTMR Property

IRD

Max77387TORCHTMRCNTLTORCHTMR Property

TORCH_TMR_CNTL: TORCH_TMR (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeTorchTmrCntlTorchTimer TORCHTMRCNTLTORCHTMR { get; set; }
Public Property TORCHTMRCNTLTORCHTMR As Max77387TypeTorchTmrCntlTorchTimer
    Get
    Set
public:
property Max77387TypeTorchTmrCntlTorchTimer TORCHTMRCNTLTORCHTMR {
    Max77387TypeTorchTmrCntlTorchTimer get ();
    void set (Max77387TypeTorchTmrCntlTorchTimer value);
}
member TORCHTMRCNTLTORCHTMR : Max77387TypeTorchTmrCntlTorchTimer with get, set

Property Value

Type: Max77387TypeTorchTmrCntlTorchTimer
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.TORCHTMRCNTLTORCHTMRCNTL Property

IRD

Max77387TORCHTMRCNTLTORCHTMRCNTL Property

TORCH_TMR_CNTL: TORCH_TMR_CNTL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeTorchTmrCntlTimerMode TORCHTMRCNTLTORCHTMRCNTL { get; set; }
Public Property TORCHTMRCNTLTORCHTMRCNTL As Max77387TypeTorchTmrCntlTimerMode
    Get
    Set
public:
property Max77387TypeTorchTmrCntlTimerMode TORCHTMRCNTLTORCHTMRCNTL {
    Max77387TypeTorchTmrCntlTimerMode get ();
    void set (Max77387TypeTorchTmrCntlTimerMode value);
}
member TORCHTMRCNTLTORCHTMRCNTL : Max77387TypeTorchTmrCntlTimerMode with get, set

Property Value

Type: Max77387TypeTorchTmrCntlTimerMode
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.TX1MASKFLASHTX1MASK Property

IRD

Max77387TX1MASKFLASHTX1MASK Property

TX1_MASK: FLASH_TX1_MASK (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeTx1MaskFlashCurrent TX1MASKFLASHTX1MASK { get; set; }
Public Property TX1MASKFLASHTX1MASK As Max77387TypeTx1MaskFlashCurrent
    Get
    Set
public:
property Max77387TypeTx1MaskFlashCurrent TX1MASKFLASHTX1MASK {
    Max77387TypeTx1MaskFlashCurrent get ();
    void set (Max77387TypeTx1MaskFlashCurrent value);
}
member TX1MASKFLASHTX1MASK : Max77387TypeTx1MaskFlashCurrent with get, set

Property Value

Type: Max77387TypeTx1MaskFlashCurrent
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.TX1MASKTX1MASKEN Property

IRD

Max77387TX1MASKTX1MASKEN Property

TX1_MASK: TX1_MASK_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeTx1MaskEnable TX1MASKTX1MASKEN { get; set; }
Public Property TX1MASKTX1MASKEN As Max77387TypeTx1MaskEnable
    Get
    Set
public:
property Max77387TypeTx1MaskEnable TX1MASKTX1MASKEN {
    Max77387TypeTx1MaskEnable get ();
    void set (Max77387TypeTx1MaskEnable value);
}
member TX1MASKTX1MASKEN : Max77387TypeTx1MaskEnable with get, set

Property Value

Type: Max77387TypeTx1MaskEnable
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.TX1MASKTX1MASKPD Property

IRD

Max77387TX1MASKTX1MASKPD Property

TX1_MASK: TX1_MASK_PD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeTx1MaskPullDownResistor TX1MASKTX1MASKPD { get; set; }
Public Property TX1MASKTX1MASKPD As Max77387TypeTx1MaskPullDownResistor
    Get
    Set
public:
property Max77387TypeTx1MaskPullDownResistor TX1MASKTX1MASKPD {
    Max77387TypeTx1MaskPullDownResistor get ();
    void set (Max77387TypeTx1MaskPullDownResistor value);
}
member TX1MASKTX1MASKPD : Max77387TypeTx1MaskPullDownResistor with get, set

Property Value

Type: Max77387TypeTx1MaskPullDownResistor
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.TX2MASKFLASHTX2MASK Property

IRD

Max77387TX2MASKFLASHTX2MASK Property

TX2_MASK: FLASH_TX2_MASK (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeTx2MaskFlashCurrent TX2MASKFLASHTX2MASK { get; set; }
Public Property TX2MASKFLASHTX2MASK As Max77387TypeTx2MaskFlashCurrent
    Get
    Set
public:
property Max77387TypeTx2MaskFlashCurrent TX2MASKFLASHTX2MASK {
    Max77387TypeTx2MaskFlashCurrent get ();
    void set (Max77387TypeTx2MaskFlashCurrent value);
}
member TX2MASKFLASHTX2MASK : Max77387TypeTx2MaskFlashCurrent with get, set

Property Value

Type: Max77387TypeTx2MaskFlashCurrent
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.TX2MASKTX2MASKEN Property

IRD

Max77387TX2MASKTX2MASKEN Property

TX2_MASK: TX2_MASK_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeTx2MaskEnable TX2MASKTX2MASKEN { get; set; }
Public Property TX2MASKTX2MASKEN As Max77387TypeTx2MaskEnable
    Get
    Set
public:
property Max77387TypeTx2MaskEnable TX2MASKTX2MASKEN {
    Max77387TypeTx2MaskEnable get ();
    void set (Max77387TypeTx2MaskEnable value);
}
member TX2MASKTX2MASKEN : Max77387TypeTx2MaskEnable with get, set

Property Value

Type: Max77387TypeTx2MaskEnable
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.TX2MASKTX2MASKPD Property

IRD

Max77387TX2MASKTX2MASKPD Property

TX2_MASK: TX2_MASK_PD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max77387TypeTx2MaskPullDownResistor TX2MASKTX2MASKPD { get; set; }
Public Property TX2MASKTX2MASKPD As Max77387TypeTx2MaskPullDownResistor
    Get
    Set
public:
property Max77387TypeTx2MaskPullDownResistor TX2MASKTX2MASKPD {
    Max77387TypeTx2MaskPullDownResistor get ();
    void set (Max77387TypeTx2MaskPullDownResistor value);
}
member TX2MASKTX2MASKPD : Max77387TypeTx2MaskPullDownResistor with get, set

Property Value

Type: Max77387TypeTx2MaskPullDownResistor
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387 Methods

The Max77387 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.Flush Method

IRD

Max77387Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max77387 Class
telos.Ird.Maxim Namespace


Max77387.TypeDcdcCntl1Mode Enumeration

IRD

Max77387TypeDcdcCntl1Mode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDcdcCntl1Mode
Public Enumeration TypeDcdcCntl1Mode
public enum class TypeDcdcCntl1Mode
type TypeDcdcCntl1Mode
Members
Member name | Value | Description
AdaptiveMode | 0 | Adaptive Mode
PrebiasedAdaptiveMode | 1 | Prebiased Adaptive Mode
ForcedActiveMode | 2 | Forced Active Mode
DropoutMode | 3 | Dropout Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeDcdcCntl1OvervoltageThreshold Enumeration

IRD

Max77387TypeDcdcCntl1OvervoltageThreshold Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDcdcCntl1OvervoltageThreshold
Public Enumeration TypeDcdcCntl1OvervoltageThreshold
public enum class TypeDcdcCntl1OvervoltageThreshold
type TypeDcdcCntl1OvervoltageThreshold
Members
Member name | Value | Description
Value_4_5 | 0 | 4.5
Value_4_8 | 1 | 4.8
Value_5_1 | 2 | 5.1
Value_5_4 | 3 | 5.4
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeDcdcCntl1PwmFrequency Enumeration

IRD

Max77387TypeDcdcCntl1PwmFrequency Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDcdcCntl1PwmFrequency
Public Enumeration TypeDcdcCntl1PwmFrequency
public enum class TypeDcdcCntl1PwmFrequency
type TypeDcdcCntl1PwmFrequency
Members
Member name | Value | Description
Value_78KHz | 0 | 7.8 kHz
Value_19KHz | 1 | 1.9 kHz
Value_488Hz | 2 | 488 Hz
Value_122Hz | 3 | 122 Hz
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeDcdcCntl2AdaptiveRegulation Enumeration

IRD

Max77387TypeDcdcCntl2AdaptiveRegulation Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDcdcCntl2AdaptiveRegulation
Public Enumeration TypeDcdcCntl2AdaptiveRegulation
public enum class TypeDcdcCntl2AdaptiveRegulation
type TypeDcdcCntl2AdaptiveRegulation
Members
Member name | Value | Description
Value_120 | 0 | 120
Value_150 | 1 | 150
Value_180 | 2 | 180
Value_210 | 3 | 210
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeDcdcCntl2Gain Enumeration

IRD

Max77387TypeDcdcCntl2Gain Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDcdcCntl2Gain
Public Enumeration TypeDcdcCntl2Gain
public enum class TypeDcdcCntl2Gain
type TypeDcdcCntl2Gain
Members
Member name | Value | Description
Standard | 0 | Standard
Enhancement | 1 | Enhancement
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeDcdcCntl2OperationMode Enumeration

IRD

Max77387TypeDcdcCntl2OperationMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDcdcCntl2OperationMode
Public Enumeration TypeDcdcCntl2OperationMode
public enum class TypeDcdcCntl2OperationMode
type TypeDcdcCntl2OperationMode
Members
Member name | Value | Description
ModeSkipFrequency1MHzFixedDCMin3125 | 0 | Mode: Skip / Frequency: 1 MHz Fixed / DC Min: 3.125%
ModeSkipFrequency4MHzAutoAdjustDCMin3125 | 1 | Mode: Skip / Frequency: 4 MHz Auto Adjust / DC Min: 3.125%
ModeFPWMFrequency4MHzFixedDCMin125 | 2 | Mode: FPWM / Frequency: 4 MHz Fixed / DC Min: 12.5%
ModeFPWMFrequency4MHzAutoAdjustDCMin3125 | 3 | Mode: FPWM / Frequency: 4 MHz Auto Adjust / DC Min: 3.125%
ModeFPWMFrequency1MHzFixedDCMin3125 | 4 | Mode: FPWM / Frequency: 1 MHz Fixed / DC Min: 3.125%
ModeFPWMFrequency2MHzFixedDCMin125 | 5 | Mode: FPWM / Frequency: 2 MHz Fixed / DC Min: 12.5%
ModeFPWMFrequency2MHzAutoAdjustDCMin3125 | 6 | Mode: FPWM / Frequency: 2 MHz Auto Adjust / DC Min: 3.125%
ModeSkipFrequency2MHzAutoAdjustDCMin3125 | 7 | Mode: Skip / Frequency: 2 MHz Auto Adjust / DC Min: 3.125%
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeDcdcLimCurrentLimit Enumeration

IRD

Max77387TypeDcdcLimCurrentLimit Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDcdcLimCurrentLimit
Public Enumeration TypeDcdcLimCurrentLimit
public enum class TypeDcdcLimCurrentLimit
type TypeDcdcLimCurrentLimit
Members
Member name | Value | Description
Value_1_25 | 0 | 1.25
Value_1_5 | 1 | 1.5
Value_1_75 | 2 | 1.75
Value_2_0 | 3 | 2.0
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeDcdcLimSoftStartThreshold Enumeration

IRD

Max77387TypeDcdcLimSoftStartThreshold Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDcdcLimSoftStartThreshold
Public Enumeration TypeDcdcLimSoftStartThreshold
public enum class TypeDcdcLimSoftStartThreshold
type TypeDcdcLimSoftStartThreshold
Members
Member name | Value | Description
Value_2_30 | 0 | 2.30
Value_2_35 | 1 | 2.35
Value_2_40 | 2 | 2.40
Value_2_44 | 3 | 2.44
Value_2_49 | 4 | 2.49
Value_2_53 | 5 | 2.53
Value_2_58 | 6 | 2.58
Value_2_63 | 7 | 2.63
Value_2_67 | 8 | 2.67
Value_2_72 | 9 | 2.72
Value_2_76 | 10 | 2.76
Value_2_81 | 11 | 2.81
Value_2_86 | 12 | 2.86
Value_2_90 | 13 | 2.90
Value_2_95 | 14 | 2.95
Value_2_99 | 15 | 2.99
Value_3_04 | 16 | 3.04
Value_3_07 | 17 | 3.07
Value_3_13 | 18 | 3.13
Value_3_18 | 19 | 3.18
Value_3_22 | 20 | 3.22
Value_3_27 | 21 | 3.27
Value_3_32 | 22 | 3.32
Value_3_36 | 23 | 3.36
Value_3_41 | 24 | 3.41
Value_3_45 | 25 | 3.45
Value_3_50 | 26 | 3.50
Value_3_55 | 27 | 3.55
Value_3_59 | 28 | 3.59
Value_3_62 | 29 | 3.62
Value_3_68 | 30 | 3.68
Value_3_73 | 31 | 3.73
Value_3_78 | 32 | 3.78
Value_3_82 | 33 | 3.82
Value_3_87 | 34 | 3.87
Value_3_91 | 35 | 3.91
Value_3_96 | 36 | 3.96
Value_4_00 | 37 | 4.00
Value_4_05 | 38 | 4.05
Value_4_10 | 39 | 4.10
Value_4_14 | 40 | 4.14
Value_4_19 | 41 | 4.19
Value_4_24 | 42 | 4.24
Value_4_28 | 43 | 4.28
Value_4_33 | 44 | 4.33
Value_4_37 | 45 | 4.37
Value_4_42 | 46 | 4.42
Value_4_47 | 47 | 4.47
Value_4_51 | 48 | 4.51
Value_4_56 | 49 | 4.56
Value_4_60 | 50 | 4.60
Value_4_65 | 51 | 4.65
Value_4_70 | 52 | 4.70
Value_4_74 | 53 | 4.74
Value_4_79 | 54 | 4.79
Value_4_83 | 55 | 4.83
Value_4_88 | 56 | 4.88
Value_4_92 | 57 | 4.92
Value_4_97 | 58 | 4.97
Value_5_02 | 59 | 5.02
Value_5_06 | 60 | 5.06
Value_5_11 | 61 | 5.11
Value_5_15 | 62 | 5.15
Value_5_20 | 63 | 5.20
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeDcdcOutMaxOutputVoltage Enumeration

IRD

Max77387TypeDcdcOutMaxOutputVoltage Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDcdcOutMaxOutputVoltage
Public Enumeration TypeDcdcOutMaxOutputVoltage
public enum class TypeDcdcOutMaxOutputVoltage
type TypeDcdcOutMaxOutputVoltage
Members
Member name | Value | Description
Value_2_3000 | 0 | 2.3000
Value_2_3125 | 1 | 2.3125
Value_2_3239 | 2 | 2.3239
Value_2_3353 | 3 | 2.3353
Value_2_3467 | 4 | 2.3467
Value_2_3581 | 5 | 2.3581
Value_2_3695 | 6 | 2.3695
Value_2_3809 | 7 | 2.3809
Value_2_3923 | 8 | 2.3923
Value_2_4037 | 9 | 2.4037
Value_2_4151 | 10 | 2.4151
Value_2_4265 | 11 | 2.4265
Value_2_4379 | 12 | 2.4379
Value_2_4493 | 13 | 2.4493
Value_2_4607 | 14 | 2.4607
Value_2_4721 | 15 | 2.4721
Value_2_4835 | 16 | 2.4835
Value_2_4949 | 17 | 2.4949
Value_2_5063 | 18 | 2.5063
Value_2_5177 | 19 | 2.5177
Value_2_5291 | 20 | 2.5291
Value_2_5405 | 21 | 2.5405
Value_2_5519 | 22 | 2.5519
Value_2_5633 | 23 | 2.5633
Value_2_5747 | 24 | 2.5747
Value_2_5861 | 25 | 2.5861
Value_2_5975 | 26 | 2.5975
Value_2_6089 | 27 | 2.6089
Value_2_6203 | 28 | 2.6203
Value_2_6317 | 29 | 2.6317
Value_2_6431 | 30 | 2.6431
Value_2_6545 | 31 | 2.6545
Value_2_6659 | 32 | 2.6659
Value_2_6773 | 33 | 2.6773
Value_2_6887 | 34 | 2.6887
Value_2_7001 | 35 | 2.7001
Value_2_7115 | 36 | 2.7115
Value_2_7229 | 37 | 2.7229
Value_2_7343 | 38 | 2.7343
Value_2_7457 | 39 | 2.7457
Value_2_7571 | 40 | 2.7571
Value_2_7685 | 41 | 2.7685
Value_2_7799 | 42 | 2.7799
Value_2_7913 | 43 | 2.7913
Value_2_8027 | 44 | 2.8027
Value_2_8141 | 45 | 2.8141
Value_2_8255 | 46 | 2.8255
Value_2_8369 | 47 | 2.8369
Value_2_8483 | 48 | 2.8483
Value_2_8597 | 49 | 2.8597
Value_2_8711 | 50 | 2.8711
Value_2_8825 | 51 | 2.8825
Value_2_8939 | 52 | 2.8939
Value_2_9053 | 53 | 2.9053
Value_2_9167 | 54 | 2.9167
Value_2_9281 | 55 | 2.9281
Value_2_9395 | 56 | 2.9395
Value_2_9509 | 57 | 2.9509
Value_2_9623 | 58 | 2.9623
Value_2_9737 | 59 | 2.9737
Value_2_9851 | 60 | 2.9851
Value_2_9965 | 61 | 2.9965
Value_3_0079 | 62 | 3.0079
Value_3_0193 | 63 | 3.0193
Value_3_0307 | 64 | 3.0307
Value_3_0421 | 65 | 3.0421
Value_3_0535 | 66 | 3.0535
Value_3_0649 | 67 | 3.0649
Value_3_0763 | 68 | 3.0763
Value_3_0877 | 69 | 3.0877
Value_3_0991 | 70 | 3.0991
Value_3_1105 | 71 | 3.1105
Value_3_1219 | 72 | 3.1219
Value_3_1333 | 73 | 3.1333
Value_3_1447 | 74 | 3.1447
Value_3_1561 | 75 | 3.1561
Value_3_1675 | 76 | 3.1675
Value_3_1789 | 77 | 3.1789
Value_3_1903 | 78 | 3.1903
Value_3_2017 | 79 | 3.2017
Value_3_2131 | 80 | 3.2131
Value_3_2245 | 81 | 3.2245
Value_3_2359 | 82 | 3.2359
Value_3_2473 | 83 | 3.2473
Value_3_2587 | 84 | 3.2587
Value_3_2701 | 85 | 3.2701
Value_3_2815 | 86 | 3.2815
Value_3_2929 | 87 | 3.2929
Value_3_3043 | 88 | 3.3043
Value_3_3157 | 89 | 3.3157
Value_3_3271 | 90 | 3.3271
Value_3_3385 | 91 | 3.3385
Value_3_3499 | 92 | 3.3499
Value_3_3613 | 93 | 3.3613
Value_3_3727 | 94 | 3.3727
Value_3_3841 | 95 | 3.3841
Value_3_3955 | 96 | 3.3955
Value_3_4069 | 97 | 3.4069
Value_3_4183 | 98 | 3.4183
Value_3_4297 | 99 | 3.4297
Value_3_4411 | 100 | 3.4411
Value_3_4525 | 101 | 3.4525
Value_3_4639 | 102 | 3.4639
Value_3_4753 | 103 | 3.4753
Value_3_4867 | 104 | 3.4867
Value_3_4981 | 105 | 3.4981
Value_3_5095 | 106 | 3.5095
Value_3_5209 | 107 | 3.5209
Value_3_5323 | 108 | 3.5323
Value_3_5437 | 109 | 3.5437
Value_3_5551 | 110 | 3.5551
Value_3_5665 | 111 | 3.5665
Value_3_5779 | 112 | 3.5779
Value_3_5893 | 113 | 3.5893
Value_3_6007 | 114 | 3.6007
Value_3_6121 | 115 | 3.6121
Value_3_6235 | 116 | 3.6235
Value_3_6349 | 117 | 3.6349
Value_3_6463 | 118 | 3.6463
Value_3_6577 | 119 | 3.6577
Value_3_6691 | 120 | 3.6691
Value_3_6805 | 121 | 3.6805
Value_3_6919 | 122 | 3.6919
Value_3_7033 | 123 | 3.7033
Value_3_7147 | 124 | 3.7147
Value_3_7261 | 125 | 3.7261
Value_3_7375 | 126 | 3.7375
Value_3_7489 | 127 | 3.7489
Value_3_7603 | 128 | 3.7603
Value_3_7717 | 129 | 3.7717
Value_3_7831 | 130 | 3.7831
Value_3_7945 | 131 | 3.7945
Value_3_8059 | 132 | 3.8059
Value_3_8173 | 133 | 3.8173
Value_3_8287 | 134 | 3.8287
Value_3_8401 | 135 | 3.8401
Value_3_8515 | 136 | 3.8515
Value_3_8629 | 137 | 3.8629
Value_3_8743 | 138 | 3.8743
Value_3_8857 | 139 | 3.8857
Value_3_8971 | 140 | 3.8971
Value_3_9085 | 141 | 3.9085
Value_3_9199 | 142 | 3.9199
Value_3_9313 | 143 | 3.9313
Value_3_9427 | 144 | 3.9427
Value_3_9541 | 145 | 3.9541
Value_3_9655 | 146 | 3.9655
Value_3_9769 | 147 | 3.9769
Value_3_9883 | 148 | 3.9883
Value_3_9997 | 149 | 3.9997
Value_4_0111 | 150 | 4.0111
Value_4_0225 | 151 | 4.0225
Value_4_0339 | 152 | 4.0339
Value_4_0453 | 153 | 4.0453
Value_4_0567 | 154 | 4.0567
Value_4_0681 | 155 | 4.0681
Value_4_0795 | 156 | 4.0795
Value_4_0909 | 157 | 4.0909
Value_4_1023 | 158 | 4.1023
Value_4_1137 | 159 | 4.1137
Value_4_1251 | 160 | 4.1251
Value_4_1365 | 161 | 4.1365
Value_4_1479 | 162 | 4.1479
Value_4_1593 | 163 | 4.1593
Value_4_1707 | 164 | 4.1707
Value_4_1821 | 165 | 4.1821
Value_4_1935 | 166 | 4.1935
Value_4_2049 | 167 | 4.2049
Value_4_2163 | 168 | 4.2163
Value_4_2277 | 169 | 4.2277
Value_4_2391 | 170 | 4.2391
Value_4_2505 | 171 | 4.2505
Value_4_2619 | 172 | 4.2619
Value_4_2733 | 173 | 4.2733
Value_4_2847 | 174 | 4.2847
Value_4_2961 | 175 | 4.2961
Value_4_3075 | 176 | 4.3075
Value_4_3189 | 177 | 4.3189
Value_4_3303 | 178 | 4.3303
Value_4_3417 | 179 | 4.3417
Value_4_3531 | 180 | 4.3531
Value_4_3645 | 181 | 4.3645
Value_4_3759 | 182 | 4.3759
Value_4_3873 | 183 | 4.3873
Value_4_3987 | 184 | 4.3987
Value_4_4101 | 185 | 4.4101
Value_4_4215 | 186 | 4.4215
Value_4_4329 | 187 | 4.4329
Value_4_4443 | 188 | 4.4443
Value_4_4557 | 189 | 4.4557
Value_4_4671 | 190 | 4.4671
Value_4_4785 | 191 | 4.4785
Value_4_4899 | 192 | 4.4899
Value_4_5013 | 193 | 4.5013
Value_4_5127 | 194 | 4.5127
Value_4_5241 | 195 | 4.5241
Value_4_5355 | 196 | 4.5355
Value_4_5469 | 197 | 4.5469
Value_4_5583 | 198 | 4.5583
Value_4_5697 | 199 | 4.5697
Value_4_5811 | 200 | 4.5811
Value_4_5925 | 201 | 4.5925
Value_4_6039 | 202 | 4.6039
Value_4_6153 | 203 | 4.6153
Value_4_6267 | 204 | 4.6267
Value_4_6381 | 205 | 4.6381
Value_4_6495 | 206 | 4.6495
Value_4_6609 | 207 | 4.6609
Value_4_6723 | 208 | 4.6723
Value_4_6837 | 209 | 4.6837
Value_4_6951 | 210 | 4.6951
Value_4_7065 | 211 | 4.7065
Value_4_7179 | 212 | 4.7179
Value_4_7293 | 213 | 4.7293
Value_4_7407 | 214 | 4.7407
Value_4_7521 | 215 | 4.7521
Value_4_7635 | 216 | 4.7635
Value_4_7749 | 217 | 4.7749
Value_4_7863 | 218 | 4.7863
Value_4_7977 | 219 | 4.7977
Value_4_8091 | 220 | 4.8091
Value_4_8205 | 221 | 4.8205
Value_4_8319 | 222 | 4.8319
Value_4_8433 | 223 | 4.8433
Value_4_8547 | 224 | 4.8547
Value_4_8661 | 225 | 4.8661
Value_4_8775 | 226 | 4.8775
Value_4_8889 | 227 | 4.8889
Value_4_9003 | 228 | 4.9003
Value_4_9117 | 229 | 4.9117
Value_4_9231 | 230 | 4.9231
Value_4_9345 | 231 | 4.9345
Value_4_9459 | 232 | 4.9459
Value_4_9573 | 233 | 4.9573
Value_4_9687 | 234 | 4.9687
Value_4_9801 | 235 | 4.9801
Value_4_9915 | 236 | 4.9915
Value_5_0029 | 237 | 5.0029
Value_5_0143 | 238 | 5.0143
Value_5_0257 | 239 | 5.0257
Value_5_0371 | 240 | 5.0371
Value_5_0485 | 241 | 5.0485
Value_5_0599 | 242 | 5.0599
Value_5_0713 | 243 | 5.0713
Value_5_0827 | 244 | 5.0827
Value_5_0941 | 245 | 5.0941
Value_5_1055 | 246 | 5.1055
Value_5_1169 | 247 | 5.1169
Value_5_1283 | 248 | 5.1283
Value_5_1397 | 249 | 5.1397
Value_5_1511 | 250 | 5.1511
Value_5_1625 | 251 | 5.1625
Value_5_1739 | 252 | 5.1739
Value_5_1853 | 253 | 5.1853
Value_5_1875 | 254 | 5.1875
Value_5_2000 | 255 | 5.2000
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeDcdcOutOutputVoltage Enumeration

IRD

Max77387TypeDcdcOutOutputVoltage Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDcdcOutOutputVoltage
Public Enumeration TypeDcdcOutOutputVoltage
public enum class TypeDcdcOutOutputVoltage
type TypeDcdcOutOutputVoltage
Members
Member name | Value | Description
Value_2_3000 | 0 | 2.3000
Value_2_3125 | 1 | 2.3125
Value_2_3239 | 2 | 2.3239
Value_2_3353 | 3 | 2.3353
Value_2_3467 | 4 | 2.3467
Value_2_3581 | 5 | 2.3581
Value_2_3695 | 6 | 2.3695
Value_2_3809 | 7 | 2.3809
Value_2_3923 | 8 | 2.3923
Value_2_4037 | 9 | 2.4037
Value_2_4151 | 10 | 2.4151
Value_2_4265 | 11 | 2.4265
Value_2_4379 | 12 | 2.4379
Value_2_4493 | 13 | 2.4493
Value_2_4607 | 14 | 2.4607
Value_2_4721 | 15 | 2.4721
Value_2_4835 | 16 | 2.4835
Value_2_4949 | 17 | 2.4949
Value_2_5063 | 18 | 2.5063
Value_2_5177 | 19 | 2.5177
Value_2_5291 | 20 | 2.5291
Value_2_5405 | 21 | 2.5405
Value_2_5519 | 22 | 2.5519
Value_2_5633 | 23 | 2.5633
Value_2_5747 | 24 | 2.5747
Value_2_5861 | 25 | 2.5861
Value_2_5975 | 26 | 2.5975
Value_2_6089 | 27 | 2.6089
Value_2_6203 | 28 | 2.6203
Value_2_6317 | 29 | 2.6317
Value_2_6431 | 30 | 2.6431
Value_2_6545 | 31 | 2.6545
Value_2_6659 | 32 | 2.6659
Value_2_6773 | 33 | 2.6773
Value_2_6887 | 34 | 2.6887
Value_2_7001 | 35 | 2.7001
Value_2_7115 | 36 | 2.7115
Value_2_7229 | 37 | 2.7229
Value_2_7343 | 38 | 2.7343
Value_2_7457 | 39 | 2.7457
Value_2_7571 | 40 | 2.7571
Value_2_7685 | 41 | 2.7685
Value_2_7799 | 42 | 2.7799
Value_2_7913 | 43 | 2.7913
Value_2_8027 | 44 | 2.8027
Value_2_8141 | 45 | 2.8141
Value_2_8255 | 46 | 2.8255
Value_2_8369 | 47 | 2.8369
Value_2_8483 | 48 | 2.8483
Value_2_8597 | 49 | 2.8597
Value_2_8711 | 50 | 2.8711
Value_2_8825 | 51 | 2.8825
Value_2_8939 | 52 | 2.8939
Value_2_9053 | 53 | 2.9053
Value_2_9167 | 54 | 2.9167
Value_2_9281 | 55 | 2.9281
Value_2_9395 | 56 | 2.9395
Value_2_9509 | 57 | 2.9509
Value_2_9623 | 58 | 2.9623
Value_2_9737 | 59 | 2.9737
Value_2_9851 | 60 | 2.9851
Value_2_9965 | 61 | 2.9965
Value_3_0079 | 62 | 3.0079
Value_3_0193 | 63 | 3.0193
Value_3_0307 | 64 | 3.0307
Value_3_0421 | 65 | 3.0421
Value_3_0535 | 66 | 3.0535
Value_3_0649 | 67 | 3.0649
Value_3_0763 | 68 | 3.0763
Value_3_0877 | 69 | 3.0877
Value_3_0991 | 70 | 3.0991
Value_3_1105 | 71 | 3.1105
Value_3_1219 | 72 | 3.1219
Value_3_1333 | 73 | 3.1333
Value_3_1447 | 74 | 3.1447
Value_3_1561 | 75 | 3.1561
Value_3_1675 | 76 | 3.1675
Value_3_1789 | 77 | 3.1789
Value_3_1903 | 78 | 3.1903
Value_3_2017 | 79 | 3.2017
Value_3_2131 | 80 | 3.2131
Value_3_2245 | 81 | 3.2245
Value_3_2359 | 82 | 3.2359
Value_3_2473 | 83 | 3.2473
Value_3_2587 | 84 | 3.2587
Value_3_2701 | 85 | 3.2701
Value_3_2815 | 86 | 3.2815
Value_3_2929 | 87 | 3.2929
Value_3_3043 | 88 | 3.3043
Value_3_3157 | 89 | 3.3157
Value_3_3271 | 90 | 3.3271
Value_3_3385 | 91 | 3.3385
Value_3_3499 | 92 | 3.3499
Value_3_3613 | 93 | 3.3613
Value_3_3727 | 94 | 3.3727
Value_3_3841 | 95 | 3.3841
Value_3_3955 | 96 | 3.3955
Value_3_4069 | 97 | 3.4069
Value_3_4183 | 98 | 3.4183
Value_3_4297 | 99 | 3.4297
Value_3_4411 | 100 | 3.4411
Value_3_4525 | 101 | 3.4525
Value_3_4639 | 102 | 3.4639
Value_3_4753 | 103 | 3.4753
Value_3_4867 | 104 | 3.4867
Value_3_4981 | 105 | 3.4981
Value_3_5095 | 106 | 3.5095
Value_3_5209 | 107 | 3.5209
Value_3_5323 | 108 | 3.5323
Value_3_5437 | 109 | 3.5437
Value_3_5551 | 110 | 3.5551
Value_3_5665 | 111 | 3.5665
Value_3_5779 | 112 | 3.5779
Value_3_5893 | 113 | 3.5893
Value_3_6007 | 114 | 3.6007
Value_3_6121 | 115 | 3.6121
Value_3_6235 | 116 | 3.6235
Value_3_6349 | 117 | 3.6349
Value_3_6463 | 118 | 3.6463
Value_3_6577 | 119 | 3.6577
Value_3_6691 | 120 | 3.6691
Value_3_6805 | 121 | 3.6805
Value_3_6919 | 122 | 3.6919
Value_3_7033 | 123 | 3.7033
Value_3_7147 | 124 | 3.7147
Value_3_7261 | 125 | 3.7261
Value_3_7375 | 126 | 3.7375
Value_3_7489 | 127 | 3.7489
Value_3_7603 | 128 | 3.7603
Value_3_7717 | 129 | 3.7717
Value_3_7831 | 130 | 3.7831
Value_3_7945 | 131 | 3.7945
Value_3_8059 | 132 | 3.8059
Value_3_8173 | 133 | 3.8173
Value_3_8287 | 134 | 3.8287
Value_3_8401 | 135 | 3.8401
Value_3_8515 | 136 | 3.8515
Value_3_8629 | 137 | 3.8629
Value_3_8743 | 138 | 3.8743
Value_3_8857 | 139 | 3.8857
Value_3_8971 | 140 | 3.8971
Value_3_9085 | 141 | 3.9085
Value_3_9199 | 142 | 3.9199
Value_3_9313 | 143 | 3.9313
Value_3_9427 | 144 | 3.9427
Value_3_9541 | 145 | 3.9541
Value_3_9655 | 146 | 3.9655
Value_3_9769 | 147 | 3.9769
Value_3_9883 | 148 | 3.9883
Value_3_9997 | 149 | 3.9997
Value_4_0111 | 150 | 4.0111
Value_4_0225 | 151 | 4.0225
Value_4_0339 | 152 | 4.0339
Value_4_0453 | 153 | 4.0453
Value_4_0567 | 154 | 4.0567
Value_4_0681 | 155 | 4.0681
Value_4_0795 | 156 | 4.0795
Value_4_0909 | 157 | 4.0909
Value_4_1023 | 158 | 4.1023
Value_4_1137 | 159 | 4.1137
Value_4_1251 | 160 | 4.1251
Value_4_1365 | 161 | 4.1365
Value_4_1479 | 162 | 4.1479
Value_4_1593 | 163 | 4.1593
Value_4_1707 | 164 | 4.1707
Value_4_1821 | 165 | 4.1821
Value_4_1935 | 166 | 4.1935
Value_4_2049 | 167 | 4.2049
Value_4_2163 | 168 | 4.2163
Value_4_2277 | 169 | 4.2277
Value_4_2391 | 170 | 4.2391
Value_4_2505 | 171 | 4.2505
Value_4_2619 | 172 | 4.2619
Value_4_2733 | 173 | 4.2733
Value_4_2847 | 174 | 4.2847
Value_4_2961 | 175 | 4.2961
Value_4_3075 | 176 | 4.3075
Value_4_3189 | 177 | 4.3189
Value_4_3303 | 178 | 4.3303
Value_4_3417 | 179 | 4.3417
Value_4_3531 | 180 | 4.3531
Value_4_3645 | 181 | 4.3645
Value_4_3759 | 182 | 4.3759
Value_4_3873 | 183 | 4.3873
Value_4_3987 | 184 | 4.3987
Value_4_4101 | 185 | 4.4101
Value_4_4215 | 186 | 4.4215
Value_4_4329 | 187 | 4.4329
Value_4_4443 | 188 | 4.4443
Value_4_4557 | 189 | 4.4557
Value_4_4671 | 190 | 4.4671
Value_4_4785 | 191 | 4.4785
Value_4_4899 | 192 | 4.4899
Value_4_5013 | 193 | 4.5013
Value_4_5127 | 194 | 4.5127
Value_4_5241 | 195 | 4.5241
Value_4_5355 | 196 | 4.5355
Value_4_5469 | 197 | 4.5469
Value_4_5583 | 198 | 4.5583
Value_4_5697 | 199 | 4.5697
Value_4_5811 | 200 | 4.5811
Value_4_5925 | 201 | 4.5925
Value_4_6039 | 202 | 4.6039
Value_4_6153 | 203 | 4.6153
Value_4_6267 | 204 | 4.6267
Value_4_6381 | 205 | 4.6381
Value_4_6495 | 206 | 4.6495
Value_4_6609 | 207 | 4.6609
Value_4_6723 | 208 | 4.6723
Value_4_6837 | 209 | 4.6837
Value_4_6951 | 210 | 4.6951
Value_4_7065 | 211 | 4.7065
Value_4_7179 | 212 | 4.7179
Value_4_7293 | 213 | 4.7293
Value_4_7407 | 214 | 4.7407
Value_4_7521 | 215 | 4.7521
Value_4_7635 | 216 | 4.7635
Value_4_7749 | 217 | 4.7749
Value_4_7863 | 218 | 4.7863
Value_4_7977 | 219 | 4.7977
Value_4_8091 | 220 | 4.8091
Value_4_8205 | 221 | 4.8205
Value_4_8319 | 222 | 4.8319
Value_4_8433 | 223 | 4.8433
Value_4_8547 | 224 | 4.8547
Value_4_8661 | 225 | 4.8661
Value_4_8775 | 226 | 4.8775
Value_4_8889 | 227 | 4.8889
Value_4_9003 | 228 | 4.9003
Value_4_9117 | 229 | 4.9117
Value_4_9231 | 230 | 4.9231
Value_4_9345 | 231 | 4.9345
Value_4_9459 | 232 | 4.9459
Value_4_9573 | 233 | 4.9573
Value_4_9687 | 234 | 4.9687
Value_4_9801 | 235 | 4.9801
Value_4_9915 | 236 | 4.9915
Value_5_0029 | 237 | 5.0029
Value_5_0143 | 238 | 5.0143
Value_5_0257 | 239 | 5.0257
Value_5_0371 | 240 | 5.0371
Value_5_0485 | 241 | 5.0485
Value_5_0599 | 242 | 5.0599
Value_5_0713 | 243 | 5.0713
Value_5_0827 | 244 | 5.0827
Value_5_0941 | 245 | 5.0941
Value_5_1055 | 246 | 5.1055
Value_5_1169 | 247 | 5.1169
Value_5_1283 | 248 | 5.1283
Value_5_1397 | 249 | 5.1397
Value_5_1511 | 250 | 5.1511
Value_5_1625 | 251 | 5.1625
Value_5_1739 | 252 | 5.1739
Value_5_1853 | 253 | 5.1853
Value_5_1875 | 254 | 5.1875
Value_5_2000 | 255 | 5.2000
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeFlashRampSelRampDown Enumeration

IRD

Max77387TypeFlashRampSelRampDown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFlashRampSelRampDown
Public Enumeration TypeFlashRampSelRampDown
public enum class TypeFlashRampSelRampDown
type TypeFlashRampSelRampDown
Members
Member name | Value | Description
Value_384Us | 0 | 384 us
Value_640Us | 1 | 640 us
Value_1152Us | 2 | 1152 us
Value_2176Us | 3 | 2176 us
Value_4224Us | 4 | 4224 us
Value_8320Us | 5 | 8320 us
Value_16512Ms | 6 | 16.512 ms
Value_32896Ms | 7 | 32.896 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeFlashRampSelRampUp Enumeration

IRD

Max77387TypeFlashRampSelRampUp Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFlashRampSelRampUp
Public Enumeration TypeFlashRampSelRampUp
public enum class TypeFlashRampSelRampUp
type TypeFlashRampSelRampUp
Members
Member name | Value | Description
Value_384Us | 0 | 384 us
Value_640Us | 1 | 640 us
Value_1152Us | 2 | 1152 us
Value_2176Us | 3 | 2176 us
Value_4224Us | 4 | 4224 us
Value_8320Us | 5 | 8320 us
Value_16512Ms | 6 | 16.512 ms
Value_32896Ms | 7 | 32.896 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeFlashTmrCntlFlashTimer Enumeration

IRD

Max77387TypeFlashTmrCntlFlashTimer Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFlashTmrCntlFlashTimer
Public Enumeration TypeFlashTmrCntlFlashTimer
public enum class TypeFlashTmrCntlFlashTimer
type TypeFlashTmrCntlFlashTimer
Members
Member name | Value | Description
Value_0_128 | 0 | 0.128
Value_0_384 | 1 | 0.384
Value_0_640 | 2 | 0.640
Value_0_896 | 3 | 0.896
Value_1_410 | 4 | 1.410
Value_1_920 | 5 | 1.920
Value_2_430 | 6 | 2.430
Value_2_940 | 7 | 2.940
Value_3_970 | 8 | 3.970
Value_4_990 | 9 | 4.990
Value_6_010 | 10 | 6.010
Value_7_040 | 11 | 7.040
Value_8_060 | 12 | 8.060
Value_9_000 | 13 | 9.000
Value_10_110 | 14 | 10.110
Value_11_140 | 15 | 11.140
Value_13_180 | 16 | 13.180
Value_15_230 | 17 | 15.230
Value_17_280 | 18 | 17.280
Value_19_330 | 19 | 19.330
Value_21_370 | 20 | 21.370
Value_23_420 | 21 | 23.420
Value_25_470 | 22 | 25.470
Value_27_520 | 23 | 27.520
Value_29_570 | 24 | 29.570
Value_31_610 | 25 | 31.610
Value_33_660 | 26 | 33.660
Value_35_710 | 27 | 35.710
Value_37_760 | 28 | 37.760
Value_39_810 | 29 | 39.810
Value_41_860 | 30 | 41.860
Value_43_900 | 31 | 43.900
Value_48_000 | 32 | 48.000
Value_52_090 | 33 | 52.090
Value_56_190 | 34 | 56.190
Value_60_280 | 35 | 60.280
Value_64_380 | 36 | 64.380
Value_68_470 | 37 | 68.470
Value_72_570 | 38 | 72.570
Value_76_670 | 39 | 76.670
Value_80_760 | 40 | 80.760
Value_84_860 | 41 | 84.860
Value_88_950 | 42 | 88.950
Value_93_050 | 43 | 93.050
Value_97_150 | 44 | 97.150
Value_101_240 | 45 | 101.240
Value_105_340 | 46 | 105.340
Value_109_430 | 47 | 109.430
Value_113_530 | 48 | 113.530
Value_117_630 | 49 | 117.630
Value_121_720 | 50 | 121.720
Value_125_820 | 51 | 125.820
Value_129_910 | 52 | 129.910
Value_134_010 | 53 | 134.010
Value_138_110 | 54 | 138.110
Value_142_200 | 55 | 142.200
Value_146_300 | 56 | 146.300
Value_150_390 | 57 | 150.390
Value_154_490 | 58 | 154.490
Value_158_590 | 59 | 158.590
Value_162_680 | 60 | 162.680
Value_166_780 | 61 | 166.780
Value_170_880 | 62 | 170.880
Value_174_980 | 63 | 174.980
Value_183_170 | 64 | 183.170
Value_191_360 | 65 | 191.360
Value_199_550 | 66 | 199.550
Value_207_740 | 67 | 207.740
Value_215_940 | 68 | 215.940
Value_224_130 | 69 | 224.130
Value_232_320 | 70 | 232.320
Value_240_510 | 71 | 240.510
Value_248_700 | 72 | 248.700
Value_256_900 | 73 | 256.900
Value_265_090 | 74 | 265.090
Value_273_280 | 75 | 273.280
Value_281_470 | 76 | 281.470
Value_289_660 | 77 | 289.660
Value_297_860 | 78 | 297.860
Value_306_050 | 79 | 306.050
Value_314_240 | 80 | 314.240
Value_322_430 | 81 | 322.430
Value_330_620 | 82 | 330.620
Value_338_820 | 83 | 338.820
Value_347_010 | 84 | 347.010
Value_355_200 | 85 | 355.200
Value_363_390 | 86 | 363.390
Value_371_580 | 87 | 371.580
Value_379_780 | 88 | 379.780
Value_387_970 | 89 | 387.970
Value_396_160 | 90 | 396.160
Value_404_350 | 91 | 404.350
Value_412_540 | 92 | 412.540
Value_420_740 | 93 | 420.740
Value_428_930 | 94 | 428.930
Value_437_120 | 95 | 437.120
Value_445_310 | 96 | 445.310
Value_453_500 | 97 | 453.500
Value_461_700 | 98 | 461.700
Value_469_890 | 99 | 469.890
Value_478_080 | 100 | 478.080
Value_486_270 | 101 | 486.270
Value_494_460 | 102 | 494.460
Value_502_660 | 103 | 502.660
Value_510_850 | 104 | 510.850
Value_519_040 | 105 | 519.040
Value_527_230 | 106 | 527.230
Value_535_420 | 107 | 535.420
Value_543_620 | 108 | 543.620
Value_551_810 | 109 | 551.810
Value_560_000 | 110 | 560.000
Value_568_190 | 111 | 568.190
Value_576_380 | 112 | 576.380
Value_584_580 | 113 | 584.580
Value_592_770 | 114 | 592.770
Value_600_960 | 115 | 600.960
Value_609_150 | 116 | 609.150
Value_617_340 | 117 | 617.340
Value_625_540 | 118 | 625.540
Value_633_730 | 119 | 633.730
Value_641_920 | 120 | 641.920
Value_650_110 | 121 | 650.110
Value_658_300 | 122 | 658.300
Value_666_500 | 123 | 666.500
Value_674_690 | 124 | 674.690
Value_682_880 | 125 | 682.880
Value_691_070 | 126 | 691.070
Value_699_260 | 127 | 699.260
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeFlashTmrCntlTimerMode Enumeration

IRD

Max77387TypeFlashTmrCntlTimerMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFlashTmrCntlTimerMode
Public Enumeration TypeFlashTmrCntlTimerMode
public enum class TypeFlashTmrCntlTimerMode
type TypeFlashTmrCntlTimerMode
Members
Member name | Value | Description
OneShotTimerMode | 0 | One Shot Timer Mode
MaximumTimerMode | 1 | Maximum Timer Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeIflash1Enable Enumeration

IRD

Max77387TypeIflash1Enable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIflash1Enable
Public Enumeration TypeIflash1Enable
public enum class TypeIflash1Enable
type TypeIflash1Enable
Members
Member name | Value | Description
FLED1DisableInFlashMode | 0 | FLED1: Disable in Flash Mode
FLED1EnableInFlashMode | 1 | FLED1: Enable in Flash Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeIflash1FlashCurrent Enumeration

IRD

Max77387TypeIflash1FlashCurrent Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIflash1FlashCurrent
Public Enumeration TypeIflash1FlashCurrent
public enum class TypeIflash1FlashCurrent
type TypeIflash1FlashCurrent
Members
Member name | Value | Description
Value_15_625 | 0 | 15.625
Value_31_250 | 1 | 31.250
Value_46_875 | 2 | 46.875
Value_62_500 | 3 | 62.500
Value_78_125 | 4 | 78.125
Value_93_750 | 5 | 93.750
Value_109_375 | 6 | 109.375
Value_125_000 | 7 | 125.000
Value_140_625 | 8 | 140.625
Value_156_250 | 9 | 156.250
Value_171_875 | 10 | 171.875
Value_187_500 | 11 | 187.500
Value_203_125 | 12 | 203.125
Value_218_750 | 13 | 218.750
Value_234_375 | 14 | 234.375
Value_250_000 | 15 | 250.000
Value_265_625 | 16 | 265.625
Value_281_250 | 17 | 281.250
Value_296_875 | 18 | 296.875
Value_312_500 | 19 | 312.500
Value_328_125 | 20 | 328.125
Value_343_750 | 21 | 343.750
Value_359_375 | 22 | 359.375
Value_375_000 | 23 | 375.000
Value_390_625 | 24 | 390.625
Value_406_250 | 25 | 406.250
Value_421_875 | 26 | 421.875
Value_437_500 | 27 | 437.500
Value_453_125 | 28 | 453.125
Value_468_750 | 29 | 468.750
Value_484_375 | 30 | 484.375
Value_500_000 | 31 | 500.000
Value_515_625 | 32 | 515.625
Value_531_250 | 33 | 531.250
Value_546_875 | 34 | 546.875
Value_562_500 | 35 | 562.500
Value_578_125 | 36 | 578.125
Value_593_750 | 37 | 593.750
Value_609_375 | 38 | 609.375
Value_625_000 | 39 | 625.000
Value_640_625 | 40 | 640.625
Value_656_250 | 41 | 656.250
Value_671_875 | 42 | 671.875
Value_687_500 | 43 | 687.500
Value_703_125 | 44 | 703.125
Value_718_750 | 45 | 718.750
Value_734_375 | 46 | 734.375
Value_750_000 | 47 | 750.000
Value_765_625 | 48 | 765.625
Value_781_250 | 49 | 781.250
Value_796_875 | 50 | 796.875
Value_812_500 | 51 | 812.500
Value_828_125 | 52 | 828.125
Value_843_750 | 53 | 843.750
Value_859_375 | 54 | 859.375
Value_875_000 | 55 | 875.000
Value_890_625 | 56 | 890.625
Value_906_250 | 57 | 906.250
Value_921_875 | 58 | 921.875
Value_937_500 | 59 | 937.500
Value_953_125 | 60 | 953.125
Value_968_750 | 61 | 968.750
Value_984_375 | 62 | 984.375
Value_1000_000 | 63 | 1000.000
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeIflash2Enable Enumeration

IRD

Max77387TypeIflash2Enable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIflash2Enable
Public Enumeration TypeIflash2Enable
public enum class TypeIflash2Enable
type TypeIflash2Enable
Members
Member name | Value | Description
FLED2DisableInFlashMode | 0 | FLED2: Disable in Flash Mode
FLED2EnableInFlashMode | 1 | FLED2: Enable in Flash Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeIflash2FlashCurrent Enumeration

IRD

Max77387TypeIflash2FlashCurrent Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIflash2FlashCurrent
Public Enumeration TypeIflash2FlashCurrent
public enum class TypeIflash2FlashCurrent
type TypeIflash2FlashCurrent
Members
Member name | Value | Description
Value_15_625 | 0 | 15.625
Value_31_250 | 1 | 31.250
Value_46_875 | 2 | 46.875
Value_62_500 | 3 | 62.500
Value_78_125 | 4 | 78.125
Value_93_750 | 5 | 93.750
Value_109_375 | 6 | 109.375
Value_125_000 | 7 | 125.000
Value_140_625 | 8 | 140.625
Value_156_250 | 9 | 156.250
Value_171_875 | 10 | 171.875
Value_187_500 | 11 | 187.500
Value_203_125 | 12 | 203.125
Value_218_750 | 13 | 218.750
Value_234_375 | 14 | 234.375
Value_250_000 | 15 | 250.000
Value_265_625 | 16 | 265.625
Value_281_250 | 17 | 281.250
Value_296_875 | 18 | 296.875
Value_312_500 | 19 | 312.500
Value_328_125 | 20 | 328.125
Value_343_750 | 21 | 343.750
Value_359_375 | 22 | 359.375
Value_375_000 | 23 | 375.000
Value_390_625 | 24 | 390.625
Value_406_250 | 25 | 406.250
Value_421_875 | 26 | 421.875
Value_437_500 | 27 | 437.500
Value_453_125 | 28 | 453.125
Value_468_750 | 29 | 468.750
Value_484_375 | 30 | 484.375
Value_500_000 | 31 | 500.000
Value_515_625 | 32 | 515.625
Value_531_250 | 33 | 531.250
Value_546_875 | 34 | 546.875
Value_562_500 | 35 | 562.500
Value_578_125 | 36 | 578.125
Value_593_750 | 37 | 593.750
Value_609_375 | 38 | 609.375
Value_625_000 | 39 | 625.000
Value_640_625 | 40 | 640.625
Value_656_250 | 41 | 656.250
Value_671_875 | 42 | 671.875
Value_687_500 | 43 | 687.500
Value_703_125 | 44 | 703.125
Value_718_750 | 45 | 718.750
Value_734_375 | 46 | 734.375
Value_750_000 | 47 | 750.000
Value_765_625 | 48 | 765.625
Value_781_250 | 49 | 781.250
Value_796_875 | 50 | 796.875
Value_812_500 | 51 | 812.500
Value_828_125 | 52 | 828.125
Value_843_750 | 53 | 843.750
Value_859_375 | 54 | 859.375
Value_875_000 | 55 | 875.000
Value_890_625 | 56 | 890.625
Value_906_250 | 57 | 906.250
Value_921_875 | 58 | 921.875
Value_937_500 | 59 | 937.500
Value_953_125 | 60 | 953.125
Value_968_750 | 61 | 968.750
Value_984_375 | 62 | 984.375
Value_1000_000 | 63 | 1000.000
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeItorch1Dimming Enumeration

IRD

Max77387TypeItorch1Dimming Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeItorch1Dimming
Public Enumeration TypeItorch1Dimming
public enum class TypeItorch1Dimming
type TypeItorch1Dimming
Members
Member name | Value | Description
DACTorchDimming | 0 | DAC Torch Dimming
PWMTorchDimming | 1 | PWM Torch Dimming
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeItorch1Enable Enumeration

IRD

Max77387TypeItorch1Enable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeItorch1Enable
Public Enumeration TypeItorch1Enable
public enum class TypeItorch1Enable
type TypeItorch1Enable
Members
Member name | Value | Description
FLED1DisableInTorchMode | 0 | FLED1: Disable in Torch Mode
FLED1EnableInTorchMode | 1 | FLED1: Enable in Torch Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeItorch1TorchCurrent Enumeration

IRD

Max77387TypeItorch1TorchCurrent Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeItorch1TorchCurrent
Public Enumeration TypeItorch1TorchCurrent
public enum class TypeItorch1TorchCurrent
type TypeItorch1TorchCurrent
Members
Member name | Value | Description
DAC391PWM125Duty3125 | 0 | DAC: 3.91 / PWM: 125 / Duty: 3.125%
DAC782PWM250Duty3125 | 1 | DAC: 7.82 / PWM: 250 / Duty: 3.125%
DAC1173PWM375Duty3125 | 2 | DAC: 11.73 / PWM: 375 / Duty: 3.125%
DAC1564PWM500Duty3125 | 3 | DAC: 15.64 / PWM: 500 / Duty: 3.125%
DAC1955PWM625Duty3125 | 4 | DAC: 19.55 / PWM: 625 / Duty: 3.125%
DAC2346PWM750Duty3125 | 5 | DAC: 23.46 / PWM: 750 / Duty: 3.125%
DAC2737PWM875Duty3125 | 6 | DAC: 27.37 / PWM: 875 / Duty: 3.125%
DAC3128PWM1000Duty3125 | 7 | DAC: 31.28 / PWM: 1000 / Duty: 3.125%
DAC3519PWM125Duty625 | 8 | DAC: 35.19 / PWM: 125 / Duty: 6.25%
DAC3910PWM250Duty625 | 9 | DAC: 39.10 / PWM: 250 / Duty: 6.25%
DAC4301PWM375Duty625 | 10 | DAC: 43.01 / PWM: 375 / Duty: 6.25%
DAC4692PWM500Duty625 | 11 | DAC: 46.92 / PWM: 500 / Duty: 6.25%
DAC5083PWM625Duty625 | 12 | DAC: 50.83 / PWM: 625 / Duty: 6.25%
DAC5474PWM750Duty625 | 13 | DAC: 54.74 / PWM: 750 / Duty: 6.25%
DAC5865PWM875Duty625 | 14 | DAC: 58.65 / PWM: 875 / Duty: 6.25%
DAC6256PWM1000Duty625 | 15 | DAC: 62.56 / PWM: 1000 / Duty: 6.25%
DAC6647PWM125Duty9375 | 16 | DAC: 66.47 / PWM: 125 / Duty: 9.375%
DAC7038PWM250Duty9375 | 17 | DAC: 70.38 / PWM: 250 / Duty: 9.375%
DAC7429PWM375Duty9375 | 18 | DAC: 74.29 / PWM: 375 / Duty: 9.375%
DAC7820PWM500Duty9375 | 19 | DAC: 78.20 / PWM: 500 / Duty: 9.375%
DAC8211PWM625Duty9375 | 20 | DAC: 82.11 / PWM: 625 / Duty: 9.375%
DAC8602PWM750Duty9375 | 21 | DAC: 86.02 / PWM: 750 / Duty: 9.375%
DAC8993PWM875Duty9375 | 22 | DAC: 89.93 / PWM: 875 / Duty: 9.375%
DAC9384PWM1000Duty9375 | 23 | DAC: 93.84 / PWM: 1000 / Duty: 9.375%
DAC9775PWM125Duty125 | 24 | DAC: 97.75 / PWM: 125 / Duty: 12.5%
DAC10166PWM250Duty125 | 25 | DAC: 101.66 / PWM: 250 / Duty: 12.5%
DAC10557PWM375Duty125 | 26 | DAC: 105.57 / PWM: 375 / Duty: 12.5%
DAC10948PWM500Duty125 | 27 | DAC: 109.48 / PWM: 500 / Duty: 12.5%
DAC11339PWM625Duty125 | 28 | DAC: 113.39 / PWM: 625 / Duty: 12.5%
DAC11730PWM750Duty125 | 29 | DAC: 117.30 / PWM: 750 / Duty: 12.5%
DAC12121PWM875Duty125 | 30 | DAC: 121.21 / PWM: 875 / Duty: 12.5%
DAC12512PWM1000Duty125 | 31 | DAC: 125.12 / PWM: 1000 / Duty: 12.5%
DAC12903PWM125Duty15625 | 32 | DAC: 129.03 / PWM: 125 / Duty: 15.625%
DAC13294PWM250Duty15625 | 33 | DAC: 132.94 / PWM: 250 / Duty: 15.625%
DAC13685PWM375Duty15625 | 34 | DAC: 136.85 / PWM: 375 / Duty: 15.625%
DAC14076PWM500Duty15625 | 35 | DAC: 140.76 / PWM: 500 / Duty: 15.625%
DAC14467PWM625Duty15625 | 36 | DAC: 144.67 / PWM: 625 / Duty: 15.625%
DAC14858PWM750Duty15625 | 37 | DAC: 148.58 / PWM: 750 / Duty: 15.625%
DAC15249PWM875Duty15625 | 38 | DAC: 152.49 / PWM: 875 / Duty: 15.625%
DAC15640PWM1000Duty15625 | 39 | DAC: 156.40 / PWM: 1000 / Duty: 15.625%
DAC16031PWM125Duty1875 | 40 | DAC: 160.31 / PWM: 125 / Duty: 18.75%
DAC16422PWM250Duty1875 | 41 | DAC: 164.22 / PWM: 250 / Duty: 18.75%
DAC16813PWM375Duty1875 | 42 | DAC: 168.13 / PWM: 375 / Duty: 18.75%
DAC17204PWM500Duty1875 | 43 | DAC: 172.04 / PWM: 500 / Duty: 18.75%
DAC17595PWM625Duty1875 | 44 | DAC: 175.95 / PWM: 625 / Duty: 18.75%
DAC17986PWM750Duty1875 | 45 | DAC: 179.86 / PWM: 750 / Duty: 18.75%
DAC18377PWM875Duty1875 | 46 | DAC: 183.77 / PWM: 875 / Duty: 18.75%
DAC18768PWM1000Duty1875 | 47 | DAC: 187.68 / PWM: 1000 / Duty: 18.75%
DAC19159PWM125Duty21875 | 48 | DAC: 191.59 / PWM: 125 / Duty: 21.875%
DAC19550PWM250Duty21875 | 49 | DAC: 195.50 / PWM: 250 / Duty: 21.875%
DAC19941PWM375Duty21875 | 50 | DAC: 199.41 / PWM: 375 / Duty: 21.875%
DAC20332PWM500Duty21875 | 51 | DAC: 203.32 / PWM: 500 / Duty: 21.875%
DAC20723PWM625Duty21875 | 52 | DAC: 207.23 / PWM: 625 / Duty: 21.875%
DAC21114PWM750Duty21875 | 53 | DAC: 211.14 / PWM: 750 / Duty: 21.875%
DAC21505PWM875Duty21875 | 54 | DAC: 215.05 / PWM: 875 / Duty: 21.875%
DAC21896PWM1000Duty21875 | 55 | DAC: 218.96 / PWM: 1000 / Duty: 21.875%
DAC22287PWM125Duty25 | 56 | DAC: 222.87 / PWM: 125 / Duty: 25%
DAC22678PWM250Duty25 | 57 | DAC: 226.78 / PWM: 250 / Duty: 25%
DAC23069PWM375Duty25 | 58 | DAC: 230.69 / PWM: 375 / Duty: 25%
DAC23460PWM500Duty25 | 59 | DAC: 234.60 / PWM: 500 / Duty: 25%
DAC23851PWM625Duty25 | 60 | DAC: 238.51 / PWM: 625 / Duty: 25%
DAC24242PWM750Duty25 | 61 | DAC: 242.42 / PWM: 750 / Duty: 25%
DAC24610PWM875Duty25 | 62 | DAC: 246.10 / PWM: 875 / Duty: 25%
DAC25000PWM1000Duty25 | 63 | DAC: 250.00 / PWM: 1000 / Duty: 25%
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeItorch2Dimming Enumeration

IRD

Max77387TypeItorch2Dimming Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeItorch2Dimming
Public Enumeration TypeItorch2Dimming
public enum class TypeItorch2Dimming
type TypeItorch2Dimming
Members
Member name | Value | Description
DACTorchDimming | 0 | DAC Torch Dimming
PWMTorchDimming | 1 | PWM Torch Dimming
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeItorch2Enable Enumeration

IRD

Max77387TypeItorch2Enable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeItorch2Enable
Public Enumeration TypeItorch2Enable
public enum class TypeItorch2Enable
type TypeItorch2Enable
Members
Member name | Value | Description
FLED2DisableInTorchMode | 0 | FLED2: Disable in Torch Mode
FLED2EnableInTorchMode | 1 | FLED2: Enable in Torch Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeItorch2TorchCurrent Enumeration

IRD

Max77387TypeItorch2TorchCurrent Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeItorch2TorchCurrent
Public Enumeration TypeItorch2TorchCurrent
public enum class TypeItorch2TorchCurrent
type TypeItorch2TorchCurrent
Members
Member name | Value | Description
DAC391PWM125Duty3125 | 0 | DAC: 3.91 / PWM: 125 / Duty: 3.125%
DAC782PWM250Duty3125 | 1 | DAC: 7.82 / PWM: 250 / Duty: 3.125%
DAC1173PWM375Duty3125 | 2 | DAC: 11.73 / PWM: 375 / Duty: 3.125%
DAC1564PWM500Duty3125 | 3 | DAC: 15.64 / PWM: 500 / Duty: 3.125%
DAC1955PWM625Duty3125 | 4 | DAC: 19.55 / PWM: 625 / Duty: 3.125%
DAC2346PWM750Duty3125 | 5 | DAC: 23.46 / PWM: 750 / Duty: 3.125%
DAC2737PWM875Duty3125 | 6 | DAC: 27.37 / PWM: 875 / Duty: 3.125%
DAC3128PWM1000Duty3125 | 7 | DAC: 31.28 / PWM: 1000 / Duty: 3.125%
DAC3519PWM125Duty625 | 8 | DAC: 35.19 / PWM: 125 / Duty: 6.25%
DAC3910PWM250Duty625 | 9 | DAC: 39.10 / PWM: 250 / Duty: 6.25%
DAC4301PWM375Duty625 | 10 | DAC: 43.01 / PWM: 375 / Duty: 6.25%
DAC4692PWM500Duty625 | 11 | DAC: 46.92 / PWM: 500 / Duty: 6.25%
DAC5083PWM625Duty625 | 12 | DAC: 50.83 / PWM: 625 / Duty: 6.25%
DAC5474PWM750Duty625 | 13 | DAC: 54.74 / PWM: 750 / Duty: 6.25%
DAC5865PWM875Duty625 | 14 | DAC: 58.65 / PWM: 875 / Duty: 6.25%
DAC6256PWM1000Duty625 | 15 | DAC: 62.56 / PWM: 1000 / Duty: 6.25%
DAC6647PWM125Duty9375 | 16 | DAC: 66.47 / PWM: 125 / Duty: 9.375%
DAC7038PWM250Duty9375 | 17 | DAC: 70.38 / PWM: 250 / Duty: 9.375%
DAC7429PWM375Duty9375 | 18 | DAC: 74.29 / PWM: 375 / Duty: 9.375%
DAC7820PWM500Duty9375 | 19 | DAC: 78.20 / PWM: 500 / Duty: 9.375%
DAC8211PWM625Duty9375 | 20 | DAC: 82.11 / PWM: 625 / Duty: 9.375%
DAC8602PWM750Duty9375 | 21 | DAC: 86.02 / PWM: 750 / Duty: 9.375%
DAC8993PWM875Duty9375 | 22 | DAC: 89.93 / PWM: 875 / Duty: 9.375%
DAC9384PWM1000Duty9375 | 23 | DAC: 93.84 / PWM: 1000 / Duty: 9.375%
DAC9775PWM125Duty125 | 24 | DAC: 97.75 / PWM: 125 / Duty: 12.5%
DAC10166PWM250Duty125 | 25 | DAC: 101.66 / PWM: 250 / Duty: 12.5%
DAC10557PWM375Duty125 | 26 | DAC: 105.57 / PWM: 375 / Duty: 12.5%
DAC10948PWM500Duty125 | 27 | DAC: 109.48 / PWM: 500 / Duty: 12.5%
DAC11339PWM625Duty125 | 28 | DAC: 113.39 / PWM: 625 / Duty: 12.5%
DAC11730PWM750Duty125 | 29 | DAC: 117.30 / PWM: 750 / Duty: 12.5%
DAC12121PWM875Duty125 | 30 | DAC: 121.21 / PWM: 875 / Duty: 12.5%
DAC12512PWM1000Duty125 | 31 | DAC: 125.12 / PWM: 1000 / Duty: 12.5%
DAC12903PWM125Duty15625 | 32 | DAC: 129.03 / PWM: 125 / Duty: 15.625%
DAC13294PWM250Duty15625 | 33 | DAC: 132.94 / PWM: 250 / Duty: 15.625%
DAC13685PWM375Duty15625 | 34 | DAC: 136.85 / PWM: 375 / Duty: 15.625%
DAC14076PWM500Duty15625 | 35 | DAC: 140.76 / PWM: 500 / Duty: 15.625%
DAC14467PWM625Duty15625 | 36 | DAC: 144.67 / PWM: 625 / Duty: 15.625%
DAC14858PWM750Duty15625 | 37 | DAC: 148.58 / PWM: 750 / Duty: 15.625%
DAC15249PWM875Duty15625 | 38 | DAC: 152.49 / PWM: 875 / Duty: 15.625%
DAC15640PWM1000Duty15625 | 39 | DAC: 156.40 / PWM: 1000 / Duty: 15.625%
DAC16031PWM125Duty1875 | 40 | DAC: 160.31 / PWM: 125 / Duty: 18.75%
DAC16422PWM250Duty1875 | 41 | DAC: 164.22 / PWM: 250 / Duty: 18.75%
DAC16813PWM375Duty1875 | 42 | DAC: 168.13 / PWM: 375 / Duty: 18.75%
DAC17204PWM500Duty1875 | 43 | DAC: 172.04 / PWM: 500 / Duty: 18.75%
DAC17595PWM625Duty1875 | 44 | DAC: 175.95 / PWM: 625 / Duty: 18.75%
DAC17986PWM750Duty1875 | 45 | DAC: 179.86 / PWM: 750 / Duty: 18.75%
DAC18377PWM875Duty1875 | 46 | DAC: 183.77 / PWM: 875 / Duty: 18.75%
DAC18768PWM1000Duty1875 | 47 | DAC: 187.68 / PWM: 1000 / Duty: 18.75%
DAC19159PWM125Duty21875 | 48 | DAC: 191.59 / PWM: 125 / Duty: 21.875%
DAC19550PWM250Duty21875 | 49 | DAC: 195.50 / PWM: 250 / Duty: 21.875%
DAC19941PWM375Duty21875 | 50 | DAC: 199.41 / PWM: 375 / Duty: 21.875%
DAC20332PWM500Duty21875 | 51 | DAC: 203.32 / PWM: 500 / Duty: 21.875%
DAC20723PWM625Duty21875 | 52 | DAC: 207.23 / PWM: 625 / Duty: 21.875%
DAC21114PWM750Duty21875 | 53 | DAC: 211.14 / PWM: 750 / Duty: 21.875%
DAC21505PWM875Duty21875 | 54 | DAC: 215.05 / PWM: 875 / Duty: 21.875%
DAC21896PWM1000Duty21875 | 55 | DAC: 218.96 / PWM: 1000 / Duty: 21.875%
DAC22287PWM125Duty25 | 56 | DAC: 222.87 / PWM: 125 / Duty: 25%
DAC22678PWM250Duty25 | 57 | DAC: 226.78 / PWM: 250 / Duty: 25%
DAC23069PWM375Duty25 | 58 | DAC: 230.69 / PWM: 375 / Duty: 25%
DAC23460PWM500Duty25 | 59 | DAC: 234.60 / PWM: 500 / Duty: 25%
DAC23851PWM625Duty25 | 60 | DAC: 238.51 / PWM: 625 / Duty: 25%
DAC24242PWM750Duty25 | 61 | DAC: 242.42 / PWM: 750 / Duty: 25%
DAC24610PWM875Duty25 | 62 | DAC: 246.10 / PWM: 875 / Duty: 25%
DAC25000PWM1000Duty25 | 63 | DAC: 250.00 / PWM: 1000 / Duty: 25%
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeMaxflash1Hysteresis Enumeration

IRD

Max77387TypeMaxflash1Hysteresis Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMaxflash1Hysteresis
Public Enumeration TypeMaxflash1Hysteresis
public enum class TypeMaxflash1Hysteresis
type TypeMaxflash1Hysteresis
Members
Member name | Value | Description
HysteresisOff | 0 | Hysteresis Off
Value_50MV | 1 | 50 mV
Value_100MV | 2 | 100 mV
Value_300MV | 6 | 300 mV
Value_350MV | 7 | 350 mV
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeMaxflash1Threshold Enumeration

IRD

Max77387TypeMaxflash1Threshold Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMaxflash1Threshold
Public Enumeration TypeMaxflash1Threshold
public enum class TypeMaxflash1Threshold
type TypeMaxflash1Threshold
Members
Member name | Value | Description
Off | 0 | Off
Value_2400V | 1 | 2.400 V
Value_2433V | 2 | 2.433 V
Value_2466V | 3 | 2.466 V
Value_2499V | 4 | 2.499 V
Value_2532V | 5 | 2.532 V
Value_2565V | 6 | 2.565 V
Value_2598V | 7 | 2.598 V
Value_2631V | 8 | 2.631 V
Value_2664V | 9 | 2.664 V
Value_2697V | 10 | 2.697 V
Value_2730V | 11 | 2.730 V
Value_2763V | 12 | 2.763 V
Value_2796V | 13 | 2.796 V
Value_2829V | 14 | 2.829 V
Value_2862V | 15 | 2.862 V
Value_2895V | 16 | 2.895 V
Value_2928V | 17 | 2.928 V
Value_2961V | 18 | 2.961 V
Value_2994V | 19 | 2.994 V
Value_3027V | 20 | 3.027 V
Value_3060V | 21 | 3.060 V
Value_3093V | 22 | 3.093 V
Value_3126V | 23 | 3.126 V
Value_3159V | 24 | 3.159 V
Value_3192V | 25 | 3.192 V
Value_3225V | 26 | 3.225 V
Value_3258V | 27 | 3.258 V
Value_3291V | 28 | 3.291 V
Value_3324V | 29 | 3.324 V
Value_3366V | 30 | 3.366 V
Value_3400V | 31 | 3.400 V
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeMaxflash2TimerFallingInputVoltage Enumeration

IRD

Max77387TypeMaxflash2TimerFallingInputVoltage Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMaxflash2TimerFallingInputVoltage
Public Enumeration TypeMaxflash2TimerFallingInputVoltage
public enum class TypeMaxflash2TimerFallingInputVoltage
type TypeMaxflash2TimerFallingInputVoltage
Members
Member name | Value | Description
Value_256 | 0 | 256
Value_512 | 1 | 512
Value_610 | 2 | 610
Value_708 | 3 | 708
Value_806 | 4 | 806
Value_904 | 5 | 904
Value_1002 | 6 | 1002
Value_1100 | 7 | 1100
Value_1198 | 8 | 1198
Value_1296 | 9 | 1296
Value_1394 | 10 | 1394
Value_1492 | 11 | 1492
Value_1590 | 12 | 1590
Value_1688 | 13 | 1688
Value_1792 | 14 | 1792
Value_2048 | 15 | 2048
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeMaxflash2TimerRisingInputVoltage Enumeration

IRD

Max77387TypeMaxflash2TimerRisingInputVoltage Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMaxflash2TimerRisingInputVoltage
Public Enumeration TypeMaxflash2TimerRisingInputVoltage
public enum class TypeMaxflash2TimerRisingInputVoltage
type TypeMaxflash2TimerRisingInputVoltage
Members
Member name | Value | Description
Value_256 | 0 | 256
Value_512 | 1 | 512
Value_610 | 2 | 610
Value_708 | 3 | 708
Value_806 | 4 | 806
Value_904 | 5 | 904
Value_1002 | 6 | 1002
Value_1100 | 7 | 1100
Value_1198 | 8 | 1198
Value_1296 | 9 | 1296
Value_1394 | 10 | 1394
Value_1492 | 11 | 1492
Value_1590 | 12 | 1590
Value_1688 | 13 | 1688
Value_1792 | 14 | 1792
Value_2048 | 15 | 2048
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeModeSelFlashMode Enumeration

IRD

Max77387TypeModeSelFlashMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeSelFlashMode
Public Enumeration TypeModeSelFlashMode
public enum class TypeModeSelFlashMode
type TypeModeSelFlashMode
Members
Member name | Value | Description
FlashModeDisabled | 0 | Flash Mode Disabled
FlashModeEnabledUsingTORCHEN | 1 | Flash Mode Enabled Using: TORCH_EN
FlashModeEnabledUsingFLASHSTB | 2 | Flash Mode Enabled Using: FLASH_STB
FlashModeEnabledUsingTORCHENOrFLASHSTB | 3 | Flash Mode Enabled Using: TORCH_EN or FLASH_STB
FlashModeEnabledUsingTORCHENAndFLASHSTB | 4 | Flash Mode Enabled Using: TORCH_EN and FLASH_STB
FlashModeEnabledRegardlessOfLogicInputs | 5 | Flash Mode Enabled Regardless Of Logic Inputs
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeModeSelFlashStbPulldown Enumeration

IRD

Max77387TypeModeSelFlashStbPulldown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeSelFlashStbPulldown
Public Enumeration TypeModeSelFlashStbPulldown
public enum class TypeModeSelFlashStbPulldown
type TypeModeSelFlashStbPulldown
Members
Member name | Value | Description
PulldownResistorFLASHSTBInputNotEnabled | 0 | Pulldown Resistor FLASH_STB Input: Not Enabled
PulldownResistorFLASHSTBInputEnabled | 1 | Pulldown Resistor FLASH_STB Input: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeModeSelTorchEnPulldown Enumeration

IRD

Max77387TypeModeSelTorchEnPulldown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeSelTorchEnPulldown
Public Enumeration TypeModeSelTorchEnPulldown
public enum class TypeModeSelTorchEnPulldown
type TypeModeSelTorchEnPulldown
Members
Member name | Value | Description
PulldownResistorTORCHENInputNotEnabled | 0 | Pulldown Resistor TORCH_EN Input: Not Enabled
PulldownResistorTORCHENInputEnabled | 1 | Pulldown Resistor TORCH_EN Input: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeModeSelTorchMode Enumeration

IRD

Max77387TypeModeSelTorchMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeSelTorchMode
Public Enumeration TypeModeSelTorchMode
public enum class TypeModeSelTorchMode
type TypeModeSelTorchMode
Members
Member name | Value | Description
TorchModeDisabled | 0 | Torch Mode Disabled
TorchModeEnabledUsingTORCHEN | 1 | Torch Mode Enabled Using: TORCH_EN
TorchModeEnabledUsingFLASHSTB | 2 | Torch Mode Enabled Using: FLASH_STB
TorchModeEnabledUsingTORCHENOrFLASHSTB | 3 | Torch Mode Enabled Using: TORCH_EN or FLASH_STB
TorchModeEnabledUsingTORCHENAndFLASHSTB | 4 | Torch Mode Enabled Using: TORCH_EN and FLASH_STB
TorchModeEnabledRegardlessOfLogicInputs | 5 | Torch Mode Enabled Regardless Of Logic Inputs
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeNtcOnOffControl Enumeration

IRD

Max77387TypeNtcOnOffControl Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeNtcOnOffControl
Public Enumeration TypeNtcOnOffControl
public enum class TypeNtcOnOffControl
type TypeNtcOnOffControl
Members
Member name | Value | Description
NTCInputDisable | 0 | NTC Input: Disable
NTCInputEnable | 1 | NTC Input: Enable
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeNtcThresholdFlashMode Enumeration

IRD

Max77387TypeNtcThresholdFlashMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeNtcThresholdFlashMode
Public Enumeration TypeNtcThresholdFlashMode
public enum class TypeNtcThresholdFlashMode
type TypeNtcThresholdFlashMode
Members
Member name | Value | Description
Value_200 | 0 | 200
Value_250 | 1 | 250
Value_300 | 2 | 300
Value_350 | 3 | 350
Value_400 | 4 | 400
Value_450 | 5 | 450
Value_500 | 6 | 500
Value_550 | 7 | 550
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeNtcThresholdTorchMode Enumeration

IRD

Max77387TypeNtcThresholdTorchMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeNtcThresholdTorchMode
Public Enumeration TypeNtcThresholdTorchMode
public enum class TypeNtcThresholdTorchMode
type TypeNtcThresholdTorchMode
Members
Member name | Value | Description
Value_200 | 0 | 200
Value_250 | 1 | 250
Value_300 | 2 | 300
Value_350 | 3 | 350
Value_400 | 4 | 400
Value_450 | 5 | 450
Value_500 | 6 | 500
Value_550 | 7 | 550
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeStatus1InPowerAndTemp Enumeration

IRD

Max77387TypeStatus1InPowerAndTemp Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1InPowerAndTemp
Public Enumeration TypeStatus1InPowerAndTemp
public enum class TypeStatus1InPowerAndTemp
type TypeStatus1InPowerAndTemp
Members
Member name | Value | Description
INValidPowerAndNoTepmperatureFault | 0 | IN: ValidPower And No Tepmperature Fault
INNoValidPowerOrTemperatureFault | 1 | IN: No Valid Power Or Temperature Fault
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeStatus1Led1Short Enumeration

IRD

Max77387TypeStatus1Led1Short Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1Led1Short
Public Enumeration TypeStatus1Led1Short
public enum class TypeStatus1Led1Short
type TypeStatus1Led1Short
Members
Member name | Value | Description
LED1NotShorted | 0 | LED 1: Not Shorted
LED1Shorted | 1 | LED 1: Shorted
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeStatus1Led2Short Enumeration

IRD

Max77387TypeStatus1Led2Short Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1Led2Short
Public Enumeration TypeStatus1Led2Short
public enum class TypeStatus1Led2Short
type TypeStatus1Led2Short
Members
Member name | Value | Description
LED2NotShorted | 0 | LED 2: Not Shorted
LED2Shorted | 1 | LED 2: Shorted
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeStatus1NtcResistor Enumeration

IRD

Max77387TypeStatus1NtcResistor Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1NtcResistor
Public Enumeration TypeStatus1NtcResistor
public enum class TypeStatus1NtcResistor
type TypeStatus1NtcResistor
Members
Member name | Value | Description
NTCWithinNormalOperationRange | 0 | NTC: Within Normal Operation Range
NTCOvertemperatureDetected | 1 | NTC: Overtemperature Detected
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeStatus1NtcShort Enumeration

IRD

Max77387TypeStatus1NtcShort Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1NtcShort
Public Enumeration TypeStatus1NtcShort
public enum class TypeStatus1NtcShort
type TypeStatus1NtcShort
Members
Member name | Value | Description
NTCNotShortedToGround | 0 | NTC: Not Shorted to Ground
TCShortedToGround | 1 | TC: Shorted To Ground
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeStatus1OvervoltageAnalog Enumeration

IRD

Max77387TypeStatus1OvervoltageAnalog Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1OvervoltageAnalog
Public Enumeration TypeStatus1OvervoltageAnalog
public enum class TypeStatus1OvervoltageAnalog
type TypeStatus1OvervoltageAnalog
Members
Member name | Value | Description
OVPANotDetected | 0 | OVP_A: Not Detected
OVPADetected | 1 | OVP_A: Detected
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeStatus1OvervoltageDigital Enumeration

IRD

Max77387TypeStatus1OvervoltageDigital Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1OvervoltageDigital
Public Enumeration TypeStatus1OvervoltageDigital
public enum class TypeStatus1OvervoltageDigital
type TypeStatus1OvervoltageDigital
Members
Member name | Value | Description
OVPDNotDetected | 0 | OVP_D: Not Detected
OVPDDetected | 1 | OVP_D: Detected
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeStatus1RegInPower Enumeration

IRD

Max77387TypeStatus1RegInPower Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1RegInPower
Public Enumeration TypeStatus1RegInPower
public enum class TypeStatus1RegInPower
type TypeStatus1RegInPower
Members
Member name | Value | Description
REGINValidPower | 0 | REG_IN: Valid Power
REGINNoValidPower | 1 | REG_IN: No Valid Power
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeStatus2FlashTimer Enumeration

IRD

Max77387TypeStatus2FlashTimer Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus2FlashTimer
Public Enumeration TypeStatus2FlashTimer
public enum class TypeStatus2FlashTimer
type TypeStatus2FlashTimer
Members
Member name | Value | Description
FlashTimerNotExpired | 0 | Flash Timer: Not Expired
FlashTimerExpired | 1 | Flash Timer: Expired
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeStatus2InductorCurrentLimit Enumeration

IRD

Max77387TypeStatus2InductorCurrentLimit Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus2InductorCurrentLimit
Public Enumeration TypeStatus2InductorCurrentLimit
public enum class TypeStatus2InductorCurrentLimit
type TypeStatus2InductorCurrentLimit
Members
Member name | Value | Description
InductorPeakCurrentLimitNotReached | 0 | Inductor Peak Current Limit: Not Reached
InductorPeakCurrentLimitReached | 1 | Inductor Peak Current Limit: Reached
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeStatus2MaxFlash Enumeration

IRD

Max77387TypeStatus2MaxFlash Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus2MaxFlash
Public Enumeration TypeStatus2MaxFlash
public enum class TypeStatus2MaxFlash
type TypeStatus2MaxFlash
Members
Member name | Value | Description
MAXFLASHNotOccuredDuringLastFlashEvent | 0 | MAXFLASH: Not Occured During Last Flash Event
MAXFLASHOccuredDuringLastFlashEvent | 1 | MAXFLASH: Occured During Last Flash Event
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeStatus2Reset Enumeration

IRD

Max77387TypeStatus2Reset Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus2Reset
Public Enumeration TypeStatus2Reset
public enum class TypeStatus2Reset
type TypeStatus2Reset
Members
Member name | Value | Description
I2CRegistersNotReset | 0 | I2C Registers: Not Reset
I2CRegistersReset | 1 | I2C Registers: Reset
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeStatus2TorchFlashEvent Enumeration

IRD

Max77387TypeStatus2TorchFlashEvent Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus2TorchFlashEvent
Public Enumeration TypeStatus2TorchFlashEvent
public enum class TypeStatus2TorchFlashEvent
type TypeStatus2TorchFlashEvent
Members
Member name | Value | Description
TorchFlashEventInProgress | 0 | Torch Flash Event: In Progress
TorchFlashEventCompleted | 1 | Torch Flash Event: Completed
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeStatus2TorchTimer Enumeration

IRD

Max77387TypeStatus2TorchTimer Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus2TorchTimer
Public Enumeration TypeStatus2TorchTimer
public enum class TypeStatus2TorchTimer
type TypeStatus2TorchTimer
Members
Member name | Value | Description
TorchTimerNotExpired | 0 | Torch Timer: Not Expired
TorchTimerExpired | 1 | Torch Timer: Expired
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeStatus2Tx1Mask Enumeration

IRD

Max77387TypeStatus2Tx1Mask Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus2Tx1Mask
Public Enumeration TypeStatus2Tx1Mask
public enum class TypeStatus2Tx1Mask
type TypeStatus2Tx1Mask
Members
Member name | Value | Description
TX1MASKNotOccurred | 0 | TX1_MASK: Not Occurred
TX1MASKOccurred | 1 | TX1_MASK: Occurred
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeStatus2Tx2Mask Enumeration

IRD

Max77387TypeStatus2Tx2Mask Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus2Tx2Mask
Public Enumeration TypeStatus2Tx2Mask
public enum class TypeStatus2Tx2Mask
type TypeStatus2Tx2Mask
Members
Member name | Value | Description
TX2MASKNotOccurred | 0 | TX2_MASK: Not Occurred
TX2MASKOccurred | 1 | TX2_MASK: Occurred
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeTorchRampSelRampDown Enumeration

IRD

Max77387TypeTorchRampSelRampDown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTorchRampSelRampDown
Public Enumeration TypeTorchRampSelRampDown
public enum class TypeTorchRampSelRampDown
type TypeTorchRampSelRampDown
Members
Member name | Value | Description
Value_16392Ms | 0 | 16.392 ms
Value_32776Ms | 1 | 32.776 ms
Value_65544Ms | 2 | 65.544 ms
Value_131080Ms | 3 | 131.080 ms
Value_262152Ms | 4 | 262.152 ms
Value_524296Ms | 5 | 524.296 ms
Value_1048S | 6 | 1.048 s
Value_2097S | 7 | 2.097 s
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeTorchRampSelRampUp Enumeration

IRD

Max77387TypeTorchRampSelRampUp Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTorchRampSelRampUp
Public Enumeration TypeTorchRampSelRampUp
public enum class TypeTorchRampSelRampUp
type TypeTorchRampSelRampUp
Members
Member name | Value | Description
Value_16392Ms | 0 | 16.392 ms
Value_32776Ms | 1 | 32.776 ms
Value_65544Ms | 2 | 65.544 ms
Value_131080Ms | 3 | 131.080 ms
Value_262152Ms | 4 | 262.152 ms
Value_524296Ms | 5 | 524.296 ms
Value_1048S | 6 | 1.048 s
Value_2097S | 7 | 2.097 s
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeTorchTmrCntlTimerMode Enumeration

IRD

Max77387TypeTorchTmrCntlTimerMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTorchTmrCntlTimerMode
Public Enumeration TypeTorchTmrCntlTimerMode
public enum class TypeTorchTmrCntlTimerMode
type TypeTorchTmrCntlTimerMode
Members
Member name | Value | Description
OneShotTimerMode | 0 | One Shot Timer Mode
TimerModeDisabled | 1 | Timer Mode Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeTorchTmrCntlTorchTimer Enumeration

IRD

Max77387TypeTorchTmrCntlTorchTimer Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTorchTmrCntlTorchTimer
Public Enumeration TypeTorchTmrCntlTorchTimer
public enum class TypeTorchTmrCntlTorchTimer
type TypeTorchTmrCntlTorchTimer
Members
Member name | Value | Description
Value_122_880 | 0 | 122.880
Value_253_950 | 1 | 253.950
Value_385_020 | 2 | 385.020
Value_516_096 | 3 | 516.096
Value_778_240 | 4 | 778.240
Value_1040_380 | 5 | 1040.380
Value_1302_530 | 6 | 1302.530
Value_1564_670 | 7 | 1564.670
Value_2088_960 | 8 | 2088.960
Value_2351_100 | 9 | 2351.100
Value_2613_250 | 10 | 2613.250
Value_2875_390 | 11 | 2875.390
Value_3137_540 | 12 | 3137.540
Value_3399_680 | 13 | 3399.680
Value_3661_820 | 14 | 3661.820
Value_5758_976 | 15 | 5758.976
Value_6807_552 | 16 | 6807.552
Value_7856_130 | 17 | 7856.130
Value_8904_700 | 18 | 8904.700
Value_9953_280 | 19 | 9953.280
Value_11001_860 | 20 | 11001.860
Value_12050_430 | 21 | 12050.430
Value_13099_010 | 22 | 13099.010
Value_14147_580 | 23 | 14147.580
Value_15196_160 | 24 | 15196.160
Value_16244_740 | 25 | 16244.740
Value_17293_310 | 26 | 17293.310
Value_18341_890 | 27 | 18341.890
Value_19390_460 | 28 | 19390.460
Value_20439_040 | 29 | 20439.040
Value_21487_616 | 30 | 21487.616
Value_22536_192 | 31 | 22536.192
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeTx1MaskEnable Enumeration

IRD

Max77387TypeTx1MaskEnable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTx1MaskEnable
Public Enumeration TypeTx1MaskEnable
public enum class TypeTx1MaskEnable
type TypeTx1MaskEnable
Members
Member name | Value | Description
TX1MaskOnOffControlNotEnabled | 0 | TX1 Mask On/Off Control: Not Enabled
TX1MaskOnOffControlEnabled | 1 | TX1 Mask On/Off Control: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeTx1MaskFlashCurrent Enumeration

IRD

Max77387TypeTx1MaskFlashCurrent Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTx1MaskFlashCurrent
Public Enumeration TypeTx1MaskFlashCurrent
public enum class TypeTx1MaskFlashCurrent
type TypeTx1MaskFlashCurrent
Members
Member name | Value | Description
Value_15_625 | 0 | 15.625
Value_31_250 | 1 | 31.250
Value_46_875 | 2 | 46.875
Value_62_500 | 3 | 62.500
Value_78_125 | 4 | 78.125
Value_93_750 | 5 | 93.750
Value_109_375 | 6 | 109.375
Value_125_000 | 7 | 125.000
Value_140_625 | 8 | 140.625
Value_156_250 | 9 | 156.250
Value_171_875 | 10 | 171.875
Value_187_500 | 11 | 187.500
Value_203_125 | 12 | 203.125
Value_218_750 | 13 | 218.750
Value_234_375 | 14 | 234.375
Value_250_000 | 15 | 250.000
Value_265_625 | 16 | 265.625
Value_281_250 | 17 | 281.250
Value_296_875 | 18 | 296.875
Value_312_500 | 19 | 312.500
Value_328_125 | 20 | 328.125
Value_343_750 | 21 | 343.750
Value_359_375 | 22 | 359.375
Value_375_000 | 23 | 375.000
Value_390_625 | 24 | 390.625
Value_406_250 | 25 | 406.250
Value_421_875 | 26 | 421.875
Value_437_500 | 27 | 437.500
Value_453_125 | 28 | 453.125
Value_468_750 | 29 | 468.750
Value_484_375 | 30 | 484.375
Value_500_000 | 31 | 500.000
Value_515_625 | 32 | 515.625
Value_531_250 | 33 | 531.250
Value_546_875 | 34 | 546.875
Value_562_500 | 35 | 562.500
Value_578_125 | 36 | 578.125
Value_593_750 | 37 | 593.750
Value_609_375 | 38 | 609.375
Value_625_000 | 39 | 625.000
Value_640_625 | 40 | 640.625
Value_656_250 | 41 | 656.250
Value_671_875 | 42 | 671.875
Value_687_500 | 43 | 687.500
Value_703_125 | 44 | 703.125
Value_718_750 | 45 | 718.750
Value_734_375 | 46 | 734.375
Value_750_000 | 47 | 750.000
Value_765_625 | 48 | 765.625
Value_781_250 | 49 | 781.250
Value_796_875 | 50 | 796.875
Value_812_500 | 51 | 812.500
Value_828_125 | 52 | 828.125
Value_843_750 | 53 | 843.750
Value_859_375 | 54 | 859.375
Value_875_000 | 55 | 875.000
Value_890_625 | 56 | 890.625
Value_906_250 | 57 | 906.250
Value_921_875 | 58 | 921.875
Value_937_500 | 59 | 937.500
Value_953_125 | 60 | 953.125
Value_968_750 | 61 | 968.750
Value_984_375 | 62 | 984.375
Value_1000_000 | 63 | 1000.000
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeTx1MaskPullDownResistor Enumeration

IRD

Max77387TypeTx1MaskPullDownResistor Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTx1MaskPullDownResistor
Public Enumeration TypeTx1MaskPullDownResistor
public enum class TypeTx1MaskPullDownResistor
type TypeTx1MaskPullDownResistor
Members
Member name | Value | Description
TX1MaskPullDownResistorNotEnabled | 0 | TX1 Mask Pull Down Resistor: Not Enabled
TX1MaskPullDownResistorEnabled | 1 | TX1 Mask Pull Down Resistor: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeTx2MaskEnable Enumeration

IRD

Max77387TypeTx2MaskEnable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTx2MaskEnable
Public Enumeration TypeTx2MaskEnable
public enum class TypeTx2MaskEnable
type TypeTx2MaskEnable
Members
Member name | Value | Description
TX2MaskOnOffControlNotEnabled | 0 | TX2 Mask On/Off Control: Not Enabled
TX2MaskOnOffControlEnabled | 1 | TX2 Mask On/Off Control: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeTx2MaskFlashCurrent Enumeration

IRD

Max77387TypeTx2MaskFlashCurrent Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTx2MaskFlashCurrent
Public Enumeration TypeTx2MaskFlashCurrent
public enum class TypeTx2MaskFlashCurrent
type TypeTx2MaskFlashCurrent
Members
Member name | Value | Description
Value_15_625 | 0 | 15.625
Value_31_250 | 1 | 31.250
Value_46_875 | 2 | 46.875
Value_62_500 | 3 | 62.500
Value_78_125 | 4 | 78.125
Value_93_750 | 5 | 93.750
Value_109_375 | 6 | 109.375
Value_125_000 | 7 | 125.000
Value_140_625 | 8 | 140.625
Value_156_250 | 9 | 156.250
Value_171_875 | 10 | 171.875
Value_187_500 | 11 | 187.500
Value_203_125 | 12 | 203.125
Value_218_750 | 13 | 218.750
Value_234_375 | 14 | 234.375
Value_250_000 | 15 | 250.000
Value_265_625 | 16 | 265.625
Value_281_250 | 17 | 281.250
Value_296_875 | 18 | 296.875
Value_312_500 | 19 | 312.500
Value_328_125 | 20 | 328.125
Value_343_750 | 21 | 343.750
Value_359_375 | 22 | 359.375
Value_375_000 | 23 | 375.000
Value_390_625 | 24 | 390.625
Value_406_250 | 25 | 406.250
Value_421_875 | 26 | 421.875
Value_437_500 | 27 | 437.500
Value_453_125 | 28 | 453.125
Value_468_750 | 29 | 468.750
Value_484_375 | 30 | 484.375
Value_500_000 | 31 | 500.000
Value_515_625 | 32 | 515.625
Value_531_250 | 33 | 531.250
Value_546_875 | 34 | 546.875
Value_562_500 | 35 | 562.500
Value_578_125 | 36 | 578.125
Value_593_750 | 37 | 593.750
Value_609_375 | 38 | 609.375
Value_625_000 | 39 | 625.000
Value_640_625 | 40 | 640.625
Value_656_250 | 41 | 656.250
Value_671_875 | 42 | 671.875
Value_687_500 | 43 | 687.500
Value_703_125 | 44 | 703.125
Value_718_750 | 45 | 718.750
Value_734_375 | 46 | 734.375
Value_750_000 | 47 | 750.000
Value_765_625 | 48 | 765.625
Value_781_250 | 49 | 781.250
Value_796_875 | 50 | 796.875
Value_812_500 | 51 | 812.500
Value_828_125 | 52 | 828.125
Value_843_750 | 53 | 843.750
Value_859_375 | 54 | 859.375
Value_875_000 | 55 | 875.000
Value_890_625 | 56 | 890.625
Value_906_250 | 57 | 906.250
Value_921_875 | 58 | 921.875
Value_937_500 | 59 | 937.500
Value_953_125 | 60 | 953.125
Value_968_750 | 61 | 968.750
Value_984_375 | 62 | 984.375
Value_1000_000 | 63 | 1000.000
See Also

Reference

telos.Ird.Maxim Namespace


Max77387.TypeTx2MaskPullDownResistor Enumeration

IRD

Max77387TypeTx2MaskPullDownResistor Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTx2MaskPullDownResistor
Public Enumeration TypeTx2MaskPullDownResistor
public enum class TypeTx2MaskPullDownResistor
type TypeTx2MaskPullDownResistor
Members
Member name | Value | Description
TX2MaskPullDownResistorNotEnabled | 0 | TX2 Mask Pull Down Resistor: Not Enabled
TX2MaskPullDownResistorEnabled | 1 | TX2 Mask Pull Down Resistor: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8821 Class

Maxim: MAX 8821
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax8821

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max8821
Public Class Max8821
public ref class Max8821
type Max8821 =  class end

The Max8821 type exposes the following members.

Constructors
 | Name | Description
Public method | Max8821 | Constructor
Top
Properties
 | Name | Description
Public property | AudioControlAMPEN | Audio Control: AMP_EN
Public property | AudioControlAUDIOGAIN | Audio Control: AUDIO_GAIN (unit: dB)
Public property | AudioControlCLKCNTL | Audio Control: CLK_CNTL
Public property | AudioControlSYNC | Audio Control: SYNC
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BlinkControlLED5OFFBLINK | Blink Control: LED5_OFF_BLINK (unit: ms)
Public property | BlinkControlLED5ONBLINK | Blink Control: LED5_ON_BLINK (unit: ms)
Public property | BlinkControlLED6OFFBLINK | Blink Control: LED6_OFF_BLINK (unit: ms)
Public property | BlinkControlLED6ONBLINK | Blink Control: LED6_ON_BLINK (unit: ms)
Public property | LDO1ControlLDO1 | LDO1 Control: LDO1 (unit: V)
Public property | LDO1ControlLDO1EN | LDO1 Control: LDO1_EN
Public property | LDO1ControlLDO1PD | LDO1 Control: LDO1_PD
Public property | LDO2ControlLDO2 | LDO2 Control: LDO2 (unit: V)
Public property | LDO2ControlLDO2EN | LDO2 Control: LDO2_EN
Public property | LDO2ControlLDO2PD | LDO2 Control: LDO2_PD
Public property | LED1CurrentRegulatorLED1 | LED1 Current Regulator: LED1 (unit: mA)
Public property | LED1CurrentRegulatorLED1RPEN | LED1 Current Regulator: LED1_RP_EN
Public property | LED2CurrentRegulatorLED2 | LED2 Current Regulator: LED2 (unit: mA)
Public property | LED2CurrentRegulatorLED2RPEN | LED2 Current Regulator: LED2_RP_EN
Public property | LED3CurrentRegulatorLED3 | LED3 Current Regulator: LED3 (unit: mA)
Public property | LED3CurrentRegulatorLED3RPEN | LED3 Current Regulator: LED3_RP_EN
Public property | LED4CurrentRegulatorLED4 | LED4 Current Regulator: LED4 (unit: mA)
Public property | LED4CurrentRegulatorLED4RPEN | LED4 Current Regulator: LED4_RP_EN
Public property | LED5CurrentRegulatorLED5 | LED5 Current Regulator: LED5 (unit: mA)
Public property | LED5CurrentRegulatorLED5RPEN | LED5 Current Regulator: LED5_RP_EN
Public property | LED6CurrentRegulatorLED6 | LED6 Current Regulator: LED6 (unit: mA)
Public property | LED6CurrentRegulatorLED6RPEN | LED6 Current Regulator: LED6_RP_EN
Public property | LEDEnableLED1EN | LED Enable: LED1_EN
Public property | LEDEnableLED2EN | LED Enable: LED2_EN
Public property | LEDEnableLED3EN | LED Enable: LED3_EN
Public property | LEDEnableLED4EN | LED Enable: LED4_EN
Public property | LEDEnableLED5EN | LED Enable: LED5_EN
Public property | LEDEnableLED6EN | LED Enable: LED6_EN
Public property | PumpControlPUMPCNTL | Pump Control: PUMP_CNTL
Public property | PumpControlTEMPDR | Pump Control: TEMP_DR
Public property | Ramp1ControlLED1RD | Ramp1 Control: LED1_RD (unit: ms)
Public property | Ramp1ControlLED1RU | Ramp1 Control: LED1_RU (unit: ms)
Public property | Ramp1ControlLED2RD | Ramp1 Control: LED2_RD (unit: ms)
Public property | Ramp1ControlLED2RU | Ramp1 Control: LED2_RU (unit: ms)
Public property | Ramp2ControlLED3RD | Ramp2 Control: LED3_RD (unit: ms)
Public property | Ramp2ControlLED3RU | Ramp2 Control: LED3_RU (unit: ms)
Public property | Ramp2ControlLED4RD | Ramp2 Control: LED4_RD (unit: ms)
Public property | Ramp2ControlLED4RU | Ramp2 Control: LED4_RU (unit: ms)
Public property | Ramp3ControlLED5RD | Ramp3 Control: LED5_RD (unit: ms)
Public property | Ramp3ControlLED5RU | Ramp3 Control: LED5_RU (unit: ms)
Public property | Ramp3ControlLED6RD | Ramp3 Control: LED6_RD (unit: ms)
Public property | Ramp3ControlLED6RU | Ramp3 Control: LED6_RU (unit: ms)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
White LED Charge Pump
See Also

Reference

telos.Ird.Maxim Namespace


Max8821 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max8821(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max8821

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821 Properties

The Max8821 type exposes the following members.

Properties
 | Name | Description
Public property | AudioControlAMPEN | Audio Control: AMP_EN
Public property | AudioControlAUDIOGAIN | Audio Control: AUDIO_GAIN (unit: dB)
Public property | AudioControlCLKCNTL | Audio Control: CLK_CNTL
Public property | AudioControlSYNC | Audio Control: SYNC
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BlinkControlLED5OFFBLINK | Blink Control: LED5_OFF_BLINK (unit: ms)
Public property | BlinkControlLED5ONBLINK | Blink Control: LED5_ON_BLINK (unit: ms)
Public property | BlinkControlLED6OFFBLINK | Blink Control: LED6_OFF_BLINK (unit: ms)
Public property | BlinkControlLED6ONBLINK | Blink Control: LED6_ON_BLINK (unit: ms)
Public property | LDO1ControlLDO1 | LDO1 Control: LDO1 (unit: V)
Public property | LDO1ControlLDO1EN | LDO1 Control: LDO1_EN
Public property | LDO1ControlLDO1PD | LDO1 Control: LDO1_PD
Public property | LDO2ControlLDO2 | LDO2 Control: LDO2 (unit: V)
Public property | LDO2ControlLDO2EN | LDO2 Control: LDO2_EN
Public property | LDO2ControlLDO2PD | LDO2 Control: LDO2_PD
Public property | LED1CurrentRegulatorLED1 | LED1 Current Regulator: LED1 (unit: mA)
Public property | LED1CurrentRegulatorLED1RPEN | LED1 Current Regulator: LED1_RP_EN
Public property | LED2CurrentRegulatorLED2 | LED2 Current Regulator: LED2 (unit: mA)
Public property | LED2CurrentRegulatorLED2RPEN | LED2 Current Regulator: LED2_RP_EN
Public property | LED3CurrentRegulatorLED3 | LED3 Current Regulator: LED3 (unit: mA)
Public property | LED3CurrentRegulatorLED3RPEN | LED3 Current Regulator: LED3_RP_EN
Public property | LED4CurrentRegulatorLED4 | LED4 Current Regulator: LED4 (unit: mA)
Public property | LED4CurrentRegulatorLED4RPEN | LED4 Current Regulator: LED4_RP_EN
Public property | LED5CurrentRegulatorLED5 | LED5 Current Regulator: LED5 (unit: mA)
Public property | LED5CurrentRegulatorLED5RPEN | LED5 Current Regulator: LED5_RP_EN
Public property | LED6CurrentRegulatorLED6 | LED6 Current Regulator: LED6 (unit: mA)
Public property | LED6CurrentRegulatorLED6RPEN | LED6 Current Regulator: LED6_RP_EN
Public property | LEDEnableLED1EN | LED Enable: LED1_EN
Public property | LEDEnableLED2EN | LED Enable: LED2_EN
Public property | LEDEnableLED3EN | LED Enable: LED3_EN
Public property | LEDEnableLED4EN | LED Enable: LED4_EN
Public property | LEDEnableLED5EN | LED Enable: LED5_EN
Public property | LEDEnableLED6EN | LED Enable: LED6_EN
Public property | PumpControlPUMPCNTL | Pump Control: PUMP_CNTL
Public property | PumpControlTEMPDR | Pump Control: TEMP_DR
Public property | Ramp1ControlLED1RD | Ramp1 Control: LED1_RD (unit: ms)
Public property | Ramp1ControlLED1RU | Ramp1 Control: LED1_RU (unit: ms)
Public property | Ramp1ControlLED2RD | Ramp1 Control: LED2_RD (unit: ms)
Public property | Ramp1ControlLED2RU | Ramp1 Control: LED2_RU (unit: ms)
Public property | Ramp2ControlLED3RD | Ramp2 Control: LED3_RD (unit: ms)
Public property | Ramp2ControlLED3RU | Ramp2 Control: LED3_RU (unit: ms)
Public property | Ramp2ControlLED4RD | Ramp2 Control: LED4_RD (unit: ms)
Public property | Ramp2ControlLED4RU | Ramp2 Control: LED4_RU (unit: ms)
Public property | Ramp3ControlLED5RD | Ramp3 Control: LED5_RD (unit: ms)
Public property | Ramp3ControlLED5RU | Ramp3 Control: LED5_RU (unit: ms)
Public property | Ramp3ControlLED6RD | Ramp3 Control: LED6_RD (unit: ms)
Public property | Ramp3ControlLED6RU | Ramp3 Control: LED6_RU (unit: ms)
Top
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.AudioControlAMPEN Property

IRD

Max8821AudioControlAMPEN Property

Audio Control: AMP_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeAudioControlAmplifier AudioControlAMPEN { get; set; }
Public Property AudioControlAMPEN As Max8821TypeAudioControlAmplifier
    Get
    Set
public:
property Max8821TypeAudioControlAmplifier AudioControlAMPEN {
    Max8821TypeAudioControlAmplifier get ();
    void set (Max8821TypeAudioControlAmplifier value);
}
member AudioControlAMPEN : Max8821TypeAudioControlAmplifier with get, set

Property Value

Type: Max8821TypeAudioControlAmplifier
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.AudioControlAUDIOGAIN Property

IRD

Max8821AudioControlAUDIOGAIN Property

Audio Control: AUDIO_GAIN (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeAudioControlGain AudioControlAUDIOGAIN { get; set; }
Public Property AudioControlAUDIOGAIN As Max8821TypeAudioControlGain
    Get
    Set
public:
property Max8821TypeAudioControlGain AudioControlAUDIOGAIN {
    Max8821TypeAudioControlGain get ();
    void set (Max8821TypeAudioControlGain value);
}
member AudioControlAUDIOGAIN : Max8821TypeAudioControlGain with get, set

Property Value

Type: Max8821TypeAudioControlGain
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.AudioControlCLKCNTL Property

IRD

Max8821AudioControlCLKCNTL Property

Audio Control: CLK_CNTL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeAudioControlClock AudioControlCLKCNTL { get; set; }
Public Property AudioControlCLKCNTL As Max8821TypeAudioControlClock
    Get
    Set
public:
property Max8821TypeAudioControlClock AudioControlCLKCNTL {
    Max8821TypeAudioControlClock get ();
    void set (Max8821TypeAudioControlClock value);
}
member AudioControlCLKCNTL : Max8821TypeAudioControlClock with get, set

Property Value

Type: Max8821TypeAudioControlClock
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.AudioControlSYNC Property

IRD

Max8821AudioControlSYNC Property

Audio Control: SYNC

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeAudioControlSynchronize AudioControlSYNC { get; set; }
Public Property AudioControlSYNC As Max8821TypeAudioControlSynchronize
    Get
    Set
public:
property Max8821TypeAudioControlSynchronize AudioControlSYNC {
    Max8821TypeAudioControlSynchronize get ();
    void set (Max8821TypeAudioControlSynchronize value);
}
member AudioControlSYNC : Max8821TypeAudioControlSynchronize with get, set

Property Value

Type: Max8821TypeAudioControlSynchronize
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.AutoFlush Property

IRD

Max8821AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.BlinkControlLED5OFFBLINK Property

IRD

Max8821BlinkControlLED5OFFBLINK Property

Blink Control: LED5_OFF_BLINK (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeBlinkControlBlinkTime BlinkControlLED5OFFBLINK { get; set; }
Public Property BlinkControlLED5OFFBLINK As Max8821TypeBlinkControlBlinkTime
    Get
    Set
public:
property Max8821TypeBlinkControlBlinkTime BlinkControlLED5OFFBLINK {
    Max8821TypeBlinkControlBlinkTime get ();
    void set (Max8821TypeBlinkControlBlinkTime value);
}
member BlinkControlLED5OFFBLINK : Max8821TypeBlinkControlBlinkTime with get, set

Property Value

Type: Max8821TypeBlinkControlBlinkTime
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.BlinkControlLED5ONBLINK Property

IRD

Max8821BlinkControlLED5ONBLINK Property

Blink Control: LED5_ON_BLINK (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeBlinkControlBlinkTime BlinkControlLED5ONBLINK { get; set; }
Public Property BlinkControlLED5ONBLINK As Max8821TypeBlinkControlBlinkTime
    Get
    Set
public:
property Max8821TypeBlinkControlBlinkTime BlinkControlLED5ONBLINK {
    Max8821TypeBlinkControlBlinkTime get ();
    void set (Max8821TypeBlinkControlBlinkTime value);
}
member BlinkControlLED5ONBLINK : Max8821TypeBlinkControlBlinkTime with get, set

Property Value

Type: Max8821TypeBlinkControlBlinkTime
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.BlinkControlLED6OFFBLINK Property

IRD

Max8821BlinkControlLED6OFFBLINK Property

Blink Control: LED6_OFF_BLINK (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeBlinkControlBlinkTime BlinkControlLED6OFFBLINK { get; set; }
Public Property BlinkControlLED6OFFBLINK As Max8821TypeBlinkControlBlinkTime
    Get
    Set
public:
property Max8821TypeBlinkControlBlinkTime BlinkControlLED6OFFBLINK {
    Max8821TypeBlinkControlBlinkTime get ();
    void set (Max8821TypeBlinkControlBlinkTime value);
}
member BlinkControlLED6OFFBLINK : Max8821TypeBlinkControlBlinkTime with get, set

Property Value

Type: Max8821TypeBlinkControlBlinkTime
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.BlinkControlLED6ONBLINK Property

IRD

Max8821BlinkControlLED6ONBLINK Property

Blink Control: LED6_ON_BLINK (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeBlinkControlBlinkTime BlinkControlLED6ONBLINK { get; set; }
Public Property BlinkControlLED6ONBLINK As Max8821TypeBlinkControlBlinkTime
    Get
    Set
public:
property Max8821TypeBlinkControlBlinkTime BlinkControlLED6ONBLINK {
    Max8821TypeBlinkControlBlinkTime get ();
    void set (Max8821TypeBlinkControlBlinkTime value);
}
member BlinkControlLED6ONBLINK : Max8821TypeBlinkControlBlinkTime with get, set

Property Value

Type: Max8821TypeBlinkControlBlinkTime
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LDO1ControlLDO1 Property

IRD

Max8821LDO1ControlLDO1 Property

LDO1 Control: LDO1 (unit: V)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLdo1ControlLdo1 LDO1ControlLDO1 { get; set; }
Public Property LDO1ControlLDO1 As Max8821TypeLdo1ControlLdo1
    Get
    Set
public:
property Max8821TypeLdo1ControlLdo1 LDO1ControlLDO1 {
    Max8821TypeLdo1ControlLdo1 get ();
    void set (Max8821TypeLdo1ControlLdo1 value);
}
member LDO1ControlLDO1 : Max8821TypeLdo1ControlLdo1 with get, set

Property Value

Type: Max8821TypeLdo1ControlLdo1
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LDO1ControlLDO1EN Property

IRD

Max8821LDO1ControlLDO1EN Property

LDO1 Control: LDO1_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLdo1ControlLdo1Enable LDO1ControlLDO1EN { get; set; }
Public Property LDO1ControlLDO1EN As Max8821TypeLdo1ControlLdo1Enable
    Get
    Set
public:
property Max8821TypeLdo1ControlLdo1Enable LDO1ControlLDO1EN {
    Max8821TypeLdo1ControlLdo1Enable get ();
    void set (Max8821TypeLdo1ControlLdo1Enable value);
}
member LDO1ControlLDO1EN : Max8821TypeLdo1ControlLdo1Enable with get, set

Property Value

Type: Max8821TypeLdo1ControlLdo1Enable
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LDO1ControlLDO1PD Property

IRD

Max8821LDO1ControlLDO1PD Property

LDO1 Control: LDO1_PD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLdo1ControlLdo1Pulldown LDO1ControlLDO1PD { get; set; }
Public Property LDO1ControlLDO1PD As Max8821TypeLdo1ControlLdo1Pulldown
    Get
    Set
public:
property Max8821TypeLdo1ControlLdo1Pulldown LDO1ControlLDO1PD {
    Max8821TypeLdo1ControlLdo1Pulldown get ();
    void set (Max8821TypeLdo1ControlLdo1Pulldown value);
}
member LDO1ControlLDO1PD : Max8821TypeLdo1ControlLdo1Pulldown with get, set

Property Value

Type: Max8821TypeLdo1ControlLdo1Pulldown
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LDO2ControlLDO2 Property

IRD

Max8821LDO2ControlLDO2 Property

LDO2 Control: LDO2 (unit: V)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLdo2ControlLdo2 LDO2ControlLDO2 { get; set; }
Public Property LDO2ControlLDO2 As Max8821TypeLdo2ControlLdo2
    Get
    Set
public:
property Max8821TypeLdo2ControlLdo2 LDO2ControlLDO2 {
    Max8821TypeLdo2ControlLdo2 get ();
    void set (Max8821TypeLdo2ControlLdo2 value);
}
member LDO2ControlLDO2 : Max8821TypeLdo2ControlLdo2 with get, set

Property Value

Type: Max8821TypeLdo2ControlLdo2
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LDO2ControlLDO2EN Property

IRD

Max8821LDO2ControlLDO2EN Property

LDO2 Control: LDO2_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLdo2ControlLdo2Enable LDO2ControlLDO2EN { get; set; }
Public Property LDO2ControlLDO2EN As Max8821TypeLdo2ControlLdo2Enable
    Get
    Set
public:
property Max8821TypeLdo2ControlLdo2Enable LDO2ControlLDO2EN {
    Max8821TypeLdo2ControlLdo2Enable get ();
    void set (Max8821TypeLdo2ControlLdo2Enable value);
}
member LDO2ControlLDO2EN : Max8821TypeLdo2ControlLdo2Enable with get, set

Property Value

Type: Max8821TypeLdo2ControlLdo2Enable
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LDO2ControlLDO2PD Property

IRD

Max8821LDO2ControlLDO2PD Property

LDO2 Control: LDO2_PD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLdo2ControlLdo2Pulldown LDO2ControlLDO2PD { get; set; }
Public Property LDO2ControlLDO2PD As Max8821TypeLdo2ControlLdo2Pulldown
    Get
    Set
public:
property Max8821TypeLdo2ControlLdo2Pulldown LDO2ControlLDO2PD {
    Max8821TypeLdo2ControlLdo2Pulldown get ();
    void set (Max8821TypeLdo2ControlLdo2Pulldown value);
}
member LDO2ControlLDO2PD : Max8821TypeLdo2ControlLdo2Pulldown with get, set

Property Value

Type: Max8821TypeLdo2ControlLdo2Pulldown
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LED1CurrentRegulatorLED1 Property

IRD

Max8821LED1CurrentRegulatorLED1 Property

LED1 Current Regulator: LED1 (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLed1CurrentRegulatorCurrent LED1CurrentRegulatorLED1 { get; set; }
Public Property LED1CurrentRegulatorLED1 As Max8821TypeLed1CurrentRegulatorCurrent
    Get
    Set
public:
property Max8821TypeLed1CurrentRegulatorCurrent LED1CurrentRegulatorLED1 {
    Max8821TypeLed1CurrentRegulatorCurrent get ();
    void set (Max8821TypeLed1CurrentRegulatorCurrent value);
}
member LED1CurrentRegulatorLED1 : Max8821TypeLed1CurrentRegulatorCurrent with get, set

Property Value

Type: Max8821TypeLed1CurrentRegulatorCurrent
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LED1CurrentRegulatorLED1RPEN Property

IRD

Max8821LED1CurrentRegulatorLED1RPEN Property

LED1 Current Regulator: LED1_RP_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLed1CurrentRegulatorRampUpdown LED1CurrentRegulatorLED1RPEN { get; set; }
Public Property LED1CurrentRegulatorLED1RPEN As Max8821TypeLed1CurrentRegulatorRampUpdown
    Get
    Set
public:
property Max8821TypeLed1CurrentRegulatorRampUpdown LED1CurrentRegulatorLED1RPEN {
    Max8821TypeLed1CurrentRegulatorRampUpdown get ();
    void set (Max8821TypeLed1CurrentRegulatorRampUpdown value);
}
member LED1CurrentRegulatorLED1RPEN : Max8821TypeLed1CurrentRegulatorRampUpdown with get, set

Property Value

Type: Max8821TypeLed1CurrentRegulatorRampUpdown
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LED2CurrentRegulatorLED2 Property

IRD

Max8821LED2CurrentRegulatorLED2 Property

LED2 Current Regulator: LED2 (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLed2CurrentRegulatorCurrent LED2CurrentRegulatorLED2 { get; set; }
Public Property LED2CurrentRegulatorLED2 As Max8821TypeLed2CurrentRegulatorCurrent
    Get
    Set
public:
property Max8821TypeLed2CurrentRegulatorCurrent LED2CurrentRegulatorLED2 {
    Max8821TypeLed2CurrentRegulatorCurrent get ();
    void set (Max8821TypeLed2CurrentRegulatorCurrent value);
}
member LED2CurrentRegulatorLED2 : Max8821TypeLed2CurrentRegulatorCurrent with get, set

Property Value

Type: Max8821TypeLed2CurrentRegulatorCurrent
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LED2CurrentRegulatorLED2RPEN Property

IRD

Max8821LED2CurrentRegulatorLED2RPEN Property

LED2 Current Regulator: LED2_RP_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLed2CurrentRegulatorRampUpdown LED2CurrentRegulatorLED2RPEN { get; set; }
Public Property LED2CurrentRegulatorLED2RPEN As Max8821TypeLed2CurrentRegulatorRampUpdown
    Get
    Set
public:
property Max8821TypeLed2CurrentRegulatorRampUpdown LED2CurrentRegulatorLED2RPEN {
    Max8821TypeLed2CurrentRegulatorRampUpdown get ();
    void set (Max8821TypeLed2CurrentRegulatorRampUpdown value);
}
member LED2CurrentRegulatorLED2RPEN : Max8821TypeLed2CurrentRegulatorRampUpdown with get, set

Property Value

Type: Max8821TypeLed2CurrentRegulatorRampUpdown
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LED3CurrentRegulatorLED3 Property

IRD

Max8821LED3CurrentRegulatorLED3 Property

LED3 Current Regulator: LED3 (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLed3CurrentRegulatorCurrent LED3CurrentRegulatorLED3 { get; set; }
Public Property LED3CurrentRegulatorLED3 As Max8821TypeLed3CurrentRegulatorCurrent
    Get
    Set
public:
property Max8821TypeLed3CurrentRegulatorCurrent LED3CurrentRegulatorLED3 {
    Max8821TypeLed3CurrentRegulatorCurrent get ();
    void set (Max8821TypeLed3CurrentRegulatorCurrent value);
}
member LED3CurrentRegulatorLED3 : Max8821TypeLed3CurrentRegulatorCurrent with get, set

Property Value

Type: Max8821TypeLed3CurrentRegulatorCurrent
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LED3CurrentRegulatorLED3RPEN Property

IRD

Max8821LED3CurrentRegulatorLED3RPEN Property

LED3 Current Regulator: LED3_RP_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLed3CurrentRegulatorRampUpdown LED3CurrentRegulatorLED3RPEN { get; set; }
Public Property LED3CurrentRegulatorLED3RPEN As Max8821TypeLed3CurrentRegulatorRampUpdown
    Get
    Set
public:
property Max8821TypeLed3CurrentRegulatorRampUpdown LED3CurrentRegulatorLED3RPEN {
    Max8821TypeLed3CurrentRegulatorRampUpdown get ();
    void set (Max8821TypeLed3CurrentRegulatorRampUpdown value);
}
member LED3CurrentRegulatorLED3RPEN : Max8821TypeLed3CurrentRegulatorRampUpdown with get, set

Property Value

Type: Max8821TypeLed3CurrentRegulatorRampUpdown
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LED4CurrentRegulatorLED4 Property

IRD

Max8821LED4CurrentRegulatorLED4 Property

LED4 Current Regulator: LED4 (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLed4CurrentRegulatorCurrent LED4CurrentRegulatorLED4 { get; set; }
Public Property LED4CurrentRegulatorLED4 As Max8821TypeLed4CurrentRegulatorCurrent
    Get
    Set
public:
property Max8821TypeLed4CurrentRegulatorCurrent LED4CurrentRegulatorLED4 {
    Max8821TypeLed4CurrentRegulatorCurrent get ();
    void set (Max8821TypeLed4CurrentRegulatorCurrent value);
}
member LED4CurrentRegulatorLED4 : Max8821TypeLed4CurrentRegulatorCurrent with get, set

Property Value

Type: Max8821TypeLed4CurrentRegulatorCurrent
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LED4CurrentRegulatorLED4RPEN Property

IRD

Max8821LED4CurrentRegulatorLED4RPEN Property

LED4 Current Regulator: LED4_RP_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLed4CurrentRegulatorRampUpdown LED4CurrentRegulatorLED4RPEN { get; set; }
Public Property LED4CurrentRegulatorLED4RPEN As Max8821TypeLed4CurrentRegulatorRampUpdown
    Get
    Set
public:
property Max8821TypeLed4CurrentRegulatorRampUpdown LED4CurrentRegulatorLED4RPEN {
    Max8821TypeLed4CurrentRegulatorRampUpdown get ();
    void set (Max8821TypeLed4CurrentRegulatorRampUpdown value);
}
member LED4CurrentRegulatorLED4RPEN : Max8821TypeLed4CurrentRegulatorRampUpdown with get, set

Property Value

Type: Max8821TypeLed4CurrentRegulatorRampUpdown
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LED5CurrentRegulatorLED5 Property

IRD

Max8821LED5CurrentRegulatorLED5 Property

LED5 Current Regulator: LED5 (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLed5CurrentRegulatorCurrent LED5CurrentRegulatorLED5 { get; set; }
Public Property LED5CurrentRegulatorLED5 As Max8821TypeLed5CurrentRegulatorCurrent
    Get
    Set
public:
property Max8821TypeLed5CurrentRegulatorCurrent LED5CurrentRegulatorLED5 {
    Max8821TypeLed5CurrentRegulatorCurrent get ();
    void set (Max8821TypeLed5CurrentRegulatorCurrent value);
}
member LED5CurrentRegulatorLED5 : Max8821TypeLed5CurrentRegulatorCurrent with get, set

Property Value

Type: Max8821TypeLed5CurrentRegulatorCurrent
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LED5CurrentRegulatorLED5RPEN Property

IRD

Max8821LED5CurrentRegulatorLED5RPEN Property

LED5 Current Regulator: LED5_RP_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLed5CurrentRegulatorRampUpdown LED5CurrentRegulatorLED5RPEN { get; set; }
Public Property LED5CurrentRegulatorLED5RPEN As Max8821TypeLed5CurrentRegulatorRampUpdown
    Get
    Set
public:
property Max8821TypeLed5CurrentRegulatorRampUpdown LED5CurrentRegulatorLED5RPEN {
    Max8821TypeLed5CurrentRegulatorRampUpdown get ();
    void set (Max8821TypeLed5CurrentRegulatorRampUpdown value);
}
member LED5CurrentRegulatorLED5RPEN : Max8821TypeLed5CurrentRegulatorRampUpdown with get, set

Property Value

Type: Max8821TypeLed5CurrentRegulatorRampUpdown
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LED6CurrentRegulatorLED6 Property

IRD

Max8821LED6CurrentRegulatorLED6 Property

LED6 Current Regulator: LED6 (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLed6CurrentRegulatorCurrent LED6CurrentRegulatorLED6 { get; set; }
Public Property LED6CurrentRegulatorLED6 As Max8821TypeLed6CurrentRegulatorCurrent
    Get
    Set
public:
property Max8821TypeLed6CurrentRegulatorCurrent LED6CurrentRegulatorLED6 {
    Max8821TypeLed6CurrentRegulatorCurrent get ();
    void set (Max8821TypeLed6CurrentRegulatorCurrent value);
}
member LED6CurrentRegulatorLED6 : Max8821TypeLed6CurrentRegulatorCurrent with get, set

Property Value

Type: Max8821TypeLed6CurrentRegulatorCurrent
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LED6CurrentRegulatorLED6RPEN Property

IRD

Max8821LED6CurrentRegulatorLED6RPEN Property

LED6 Current Regulator: LED6_RP_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLed6CurrentRegulatorRampUpdown LED6CurrentRegulatorLED6RPEN { get; set; }
Public Property LED6CurrentRegulatorLED6RPEN As Max8821TypeLed6CurrentRegulatorRampUpdown
    Get
    Set
public:
property Max8821TypeLed6CurrentRegulatorRampUpdown LED6CurrentRegulatorLED6RPEN {
    Max8821TypeLed6CurrentRegulatorRampUpdown get ();
    void set (Max8821TypeLed6CurrentRegulatorRampUpdown value);
}
member LED6CurrentRegulatorLED6RPEN : Max8821TypeLed6CurrentRegulatorRampUpdown with get, set

Property Value

Type: Max8821TypeLed6CurrentRegulatorRampUpdown
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LEDEnableLED1EN Property

IRD

Max8821LEDEnableLED1EN Property

LED Enable: LED1_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLedEnableLed1 LEDEnableLED1EN { get; set; }
Public Property LEDEnableLED1EN As Max8821TypeLedEnableLed1
    Get
    Set
public:
property Max8821TypeLedEnableLed1 LEDEnableLED1EN {
    Max8821TypeLedEnableLed1 get ();
    void set (Max8821TypeLedEnableLed1 value);
}
member LEDEnableLED1EN : Max8821TypeLedEnableLed1 with get, set

Property Value

Type: Max8821TypeLedEnableLed1
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LEDEnableLED2EN Property

IRD

Max8821LEDEnableLED2EN Property

LED Enable: LED2_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLedEnableLed2 LEDEnableLED2EN { get; set; }
Public Property LEDEnableLED2EN As Max8821TypeLedEnableLed2
    Get
    Set
public:
property Max8821TypeLedEnableLed2 LEDEnableLED2EN {
    Max8821TypeLedEnableLed2 get ();
    void set (Max8821TypeLedEnableLed2 value);
}
member LEDEnableLED2EN : Max8821TypeLedEnableLed2 with get, set

Property Value

Type: Max8821TypeLedEnableLed2
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LEDEnableLED3EN Property

IRD

Max8821LEDEnableLED3EN Property

LED Enable: LED3_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLedEnableLed3 LEDEnableLED3EN { get; set; }
Public Property LEDEnableLED3EN As Max8821TypeLedEnableLed3
    Get
    Set
public:
property Max8821TypeLedEnableLed3 LEDEnableLED3EN {
    Max8821TypeLedEnableLed3 get ();
    void set (Max8821TypeLedEnableLed3 value);
}
member LEDEnableLED3EN : Max8821TypeLedEnableLed3 with get, set

Property Value

Type: Max8821TypeLedEnableLed3
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LEDEnableLED4EN Property

IRD

Max8821LEDEnableLED4EN Property

LED Enable: LED4_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLedEnableLed4 LEDEnableLED4EN { get; set; }
Public Property LEDEnableLED4EN As Max8821TypeLedEnableLed4
    Get
    Set
public:
property Max8821TypeLedEnableLed4 LEDEnableLED4EN {
    Max8821TypeLedEnableLed4 get ();
    void set (Max8821TypeLedEnableLed4 value);
}
member LEDEnableLED4EN : Max8821TypeLedEnableLed4 with get, set

Property Value

Type: Max8821TypeLedEnableLed4
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LEDEnableLED5EN Property

IRD

Max8821LEDEnableLED5EN Property

LED Enable: LED5_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLedEnableLed5 LEDEnableLED5EN { get; set; }
Public Property LEDEnableLED5EN As Max8821TypeLedEnableLed5
    Get
    Set
public:
property Max8821TypeLedEnableLed5 LEDEnableLED5EN {
    Max8821TypeLedEnableLed5 get ();
    void set (Max8821TypeLedEnableLed5 value);
}
member LEDEnableLED5EN : Max8821TypeLedEnableLed5 with get, set

Property Value

Type: Max8821TypeLedEnableLed5
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.LEDEnableLED6EN Property

IRD

Max8821LEDEnableLED6EN Property

LED Enable: LED6_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeLedEnableLed6 LEDEnableLED6EN { get; set; }
Public Property LEDEnableLED6EN As Max8821TypeLedEnableLed6
    Get
    Set
public:
property Max8821TypeLedEnableLed6 LEDEnableLED6EN {
    Max8821TypeLedEnableLed6 get ();
    void set (Max8821TypeLedEnableLed6 value);
}
member LEDEnableLED6EN : Max8821TypeLedEnableLed6 with get, set

Property Value

Type: Max8821TypeLedEnableLed6
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.PumpControlPUMPCNTL Property

IRD

Max8821PumpControlPUMPCNTL Property

Pump Control: PUMP_CNTL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypePumpControlPump PumpControlPUMPCNTL { get; set; }
Public Property PumpControlPUMPCNTL As Max8821TypePumpControlPump
    Get
    Set
public:
property Max8821TypePumpControlPump PumpControlPUMPCNTL {
    Max8821TypePumpControlPump get ();
    void set (Max8821TypePumpControlPump value);
}
member PumpControlPUMPCNTL : Max8821TypePumpControlPump with get, set

Property Value

Type: Max8821TypePumpControlPump
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.PumpControlTEMPDR Property

IRD

Max8821PumpControlTEMPDR Property

Pump Control: TEMP_DR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypePumpControlTemperature PumpControlTEMPDR { get; set; }
Public Property PumpControlTEMPDR As Max8821TypePumpControlTemperature
    Get
    Set
public:
property Max8821TypePumpControlTemperature PumpControlTEMPDR {
    Max8821TypePumpControlTemperature get ();
    void set (Max8821TypePumpControlTemperature value);
}
member PumpControlTEMPDR : Max8821TypePumpControlTemperature with get, set

Property Value

Type: Max8821TypePumpControlTemperature
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.Ramp1ControlLED1RD Property

IRD

Max8821Ramp1ControlLED1RD Property

Ramp1 Control: LED1_RD (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeRampControlRampTime Ramp1ControlLED1RD { get; set; }
Public Property Ramp1ControlLED1RD As Max8821TypeRampControlRampTime
    Get
    Set
public:
property Max8821TypeRampControlRampTime Ramp1ControlLED1RD {
    Max8821TypeRampControlRampTime get ();
    void set (Max8821TypeRampControlRampTime value);
}
member Ramp1ControlLED1RD : Max8821TypeRampControlRampTime with get, set

Property Value

Type: Max8821TypeRampControlRampTime
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.Ramp1ControlLED1RU Property

IRD

Max8821Ramp1ControlLED1RU Property

Ramp1 Control: LED1_RU (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeRampControlRampTime Ramp1ControlLED1RU { get; set; }
Public Property Ramp1ControlLED1RU As Max8821TypeRampControlRampTime
    Get
    Set
public:
property Max8821TypeRampControlRampTime Ramp1ControlLED1RU {
    Max8821TypeRampControlRampTime get ();
    void set (Max8821TypeRampControlRampTime value);
}
member Ramp1ControlLED1RU : Max8821TypeRampControlRampTime with get, set

Property Value

Type: Max8821TypeRampControlRampTime
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.Ramp1ControlLED2RD Property

IRD

Max8821Ramp1ControlLED2RD Property

Ramp1 Control: LED2_RD (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeRampControlRampTime Ramp1ControlLED2RD { get; set; }
Public Property Ramp1ControlLED2RD As Max8821TypeRampControlRampTime
    Get
    Set
public:
property Max8821TypeRampControlRampTime Ramp1ControlLED2RD {
    Max8821TypeRampControlRampTime get ();
    void set (Max8821TypeRampControlRampTime value);
}
member Ramp1ControlLED2RD : Max8821TypeRampControlRampTime with get, set

Property Value

Type: Max8821TypeRampControlRampTime
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.Ramp1ControlLED2RU Property

IRD

Max8821Ramp1ControlLED2RU Property

Ramp1 Control: LED2_RU (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeRampControlRampTime Ramp1ControlLED2RU { get; set; }
Public Property Ramp1ControlLED2RU As Max8821TypeRampControlRampTime
    Get
    Set
public:
property Max8821TypeRampControlRampTime Ramp1ControlLED2RU {
    Max8821TypeRampControlRampTime get ();
    void set (Max8821TypeRampControlRampTime value);
}
member Ramp1ControlLED2RU : Max8821TypeRampControlRampTime with get, set

Property Value

Type: Max8821TypeRampControlRampTime
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.Ramp2ControlLED3RD Property

IRD

Max8821Ramp2ControlLED3RD Property

Ramp2 Control: LED3_RD (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeRampControlRampTime Ramp2ControlLED3RD { get; set; }
Public Property Ramp2ControlLED3RD As Max8821TypeRampControlRampTime
    Get
    Set
public:
property Max8821TypeRampControlRampTime Ramp2ControlLED3RD {
    Max8821TypeRampControlRampTime get ();
    void set (Max8821TypeRampControlRampTime value);
}
member Ramp2ControlLED3RD : Max8821TypeRampControlRampTime with get, set

Property Value

Type: Max8821TypeRampControlRampTime
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.Ramp2ControlLED3RU Property

IRD

Max8821Ramp2ControlLED3RU Property

Ramp2 Control: LED3_RU (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeRampControlRampTime Ramp2ControlLED3RU { get; set; }
Public Property Ramp2ControlLED3RU As Max8821TypeRampControlRampTime
    Get
    Set
public:
property Max8821TypeRampControlRampTime Ramp2ControlLED3RU {
    Max8821TypeRampControlRampTime get ();
    void set (Max8821TypeRampControlRampTime value);
}
member Ramp2ControlLED3RU : Max8821TypeRampControlRampTime with get, set

Property Value

Type: Max8821TypeRampControlRampTime
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.Ramp2ControlLED4RD Property

IRD

Max8821Ramp2ControlLED4RD Property

Ramp2 Control: LED4_RD (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeRampControlRampTime Ramp2ControlLED4RD { get; set; }
Public Property Ramp2ControlLED4RD As Max8821TypeRampControlRampTime
    Get
    Set
public:
property Max8821TypeRampControlRampTime Ramp2ControlLED4RD {
    Max8821TypeRampControlRampTime get ();
    void set (Max8821TypeRampControlRampTime value);
}
member Ramp2ControlLED4RD : Max8821TypeRampControlRampTime with get, set

Property Value

Type: Max8821TypeRampControlRampTime
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.Ramp2ControlLED4RU Property

IRD

Max8821Ramp2ControlLED4RU Property

Ramp2 Control: LED4_RU (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeRampControlRampTime Ramp2ControlLED4RU { get; set; }
Public Property Ramp2ControlLED4RU As Max8821TypeRampControlRampTime
    Get
    Set
public:
property Max8821TypeRampControlRampTime Ramp2ControlLED4RU {
    Max8821TypeRampControlRampTime get ();
    void set (Max8821TypeRampControlRampTime value);
}
member Ramp2ControlLED4RU : Max8821TypeRampControlRampTime with get, set

Property Value

Type: Max8821TypeRampControlRampTime
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.Ramp3ControlLED5RD Property

IRD

Max8821Ramp3ControlLED5RD Property

Ramp3 Control: LED5_RD (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeRampControlRampTime Ramp3ControlLED5RD { get; set; }
Public Property Ramp3ControlLED5RD As Max8821TypeRampControlRampTime
    Get
    Set
public:
property Max8821TypeRampControlRampTime Ramp3ControlLED5RD {
    Max8821TypeRampControlRampTime get ();
    void set (Max8821TypeRampControlRampTime value);
}
member Ramp3ControlLED5RD : Max8821TypeRampControlRampTime with get, set

Property Value

Type: Max8821TypeRampControlRampTime
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.Ramp3ControlLED5RU Property

IRD

Max8821Ramp3ControlLED5RU Property

Ramp3 Control: LED5_RU (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeRampControlRampTime Ramp3ControlLED5RU { get; set; }
Public Property Ramp3ControlLED5RU As Max8821TypeRampControlRampTime
    Get
    Set
public:
property Max8821TypeRampControlRampTime Ramp3ControlLED5RU {
    Max8821TypeRampControlRampTime get ();
    void set (Max8821TypeRampControlRampTime value);
}
member Ramp3ControlLED5RU : Max8821TypeRampControlRampTime with get, set

Property Value

Type: Max8821TypeRampControlRampTime
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.Ramp3ControlLED6RD Property

IRD

Max8821Ramp3ControlLED6RD Property

Ramp3 Control: LED6_RD (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeRampControlRampTime Ramp3ControlLED6RD { get; set; }
Public Property Ramp3ControlLED6RD As Max8821TypeRampControlRampTime
    Get
    Set
public:
property Max8821TypeRampControlRampTime Ramp3ControlLED6RD {
    Max8821TypeRampControlRampTime get ();
    void set (Max8821TypeRampControlRampTime value);
}
member Ramp3ControlLED6RD : Max8821TypeRampControlRampTime with get, set

Property Value

Type: Max8821TypeRampControlRampTime
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.Ramp3ControlLED6RU Property

IRD

Max8821Ramp3ControlLED6RU Property

Ramp3 Control: LED6_RU (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8821TypeRampControlRampTime Ramp3ControlLED6RU { get; set; }
Public Property Ramp3ControlLED6RU As Max8821TypeRampControlRampTime
    Get
    Set
public:
property Max8821TypeRampControlRampTime Ramp3ControlLED6RU {
    Max8821TypeRampControlRampTime get ();
    void set (Max8821TypeRampControlRampTime value);
}
member Ramp3ControlLED6RU : Max8821TypeRampControlRampTime with get, set

Property Value

Type: Max8821TypeRampControlRampTime
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821 Methods

The Max8821 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.Flush Method

IRD

Max8821Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max8821 Class
telos.Ird.Maxim Namespace


Max8821.TypeAudioControlAmplifier Enumeration

IRD

Max8821TypeAudioControlAmplifier Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlAmplifier
Public Enumeration TypeAudioControlAmplifier
public enum class TypeAudioControlAmplifier
type TypeAudioControlAmplifier
Members
Member name | Value | Description
ClassDAmplifierDisabled | 0 | Class D Amplifier: Disabled
ClassDAmplifierEnabled | 1 | Class D Amplifier: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeAudioControlClock Enumeration

IRD

Max8821TypeAudioControlClock Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlClock
Public Enumeration TypeAudioControlClock
public enum class TypeAudioControlClock
type TypeAudioControlClock
Members
Member name | Value | Description
OscillatorFrequency1100KHzFixedFrequencyMode | 0 | Oscillator Frequency 1100 kHz Fixed Frequency Mode
OscillatorFrequency1400KHzFixedFrequencyMode | 1 | Oscillator Frequency 1400 kHz Fixed Frequency Mode
OscillatorFrequency1250KHzSpreadSpectrumMode | 2 | Oscillator Frequency 1250 kHz Spread Spectrum Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeAudioControlGain Enumeration

IRD

Max8821TypeAudioControlGain Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlGain
Public Enumeration TypeAudioControlGain
public enum class TypeAudioControlGain
type TypeAudioControlGain
Members
Member name | Value | Description
Value_M_3 | 0 | -3
Value_0 | 1 | 0
Value_3 | 2 | 3
Value_6 | 3 | 6
Value_9 | 4 | 9
Value_12 | 5 | 12
Value_15 | 6 | 15
Value_18 | 7 | 18
Value_24 | 9 | 24
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeAudioControlSynchronize Enumeration

IRD

Max8821TypeAudioControlSynchronize Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlSynchronize
Public Enumeration TypeAudioControlSynchronize
public enum class TypeAudioControlSynchronize
type TypeAudioControlSynchronize
Members
Member name | Value | Description
AudioAmplifierAndChargePumpClockNotSynchronized | 0 | Audio Amplifier And Charge Pump Clock: Not Synchronized
AudioAmplifierAndChargePumpClockSynchronized | 1 | Audio Amplifier And Charge Pump Clock: Synchronized
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeBlinkControlBlinkTime Enumeration

IRD

Max8821TypeBlinkControlBlinkTime Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBlinkControlBlinkTime
Public Enumeration TypeBlinkControlBlinkTime
public enum class TypeBlinkControlBlinkTime
type TypeBlinkControlBlinkTime
Members
Member name | Value | Description
Value_218XTqpclk | 0 | 2^18 x Tqpclk
Value_219XTqpclk | 1 | 2^19 x Tqpclk
Value_220XTqpclk | 2 | 2^20 x Tqpclk
Value_221XTqpclk | 3 | 2^21 x Tqpclk
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLdo1ControlLdo1 Enumeration

IRD

Max8821TypeLdo1ControlLdo1 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLdo1ControlLdo1
Public Enumeration TypeLdo1ControlLdo1
public enum class TypeLdo1ControlLdo1
type TypeLdo1ControlLdo1
Members
Member name | Value | Description
Value_1_2 | 0 | 1.2
Value_1_3 | 1 | 1.3
Value_1_5 | 2 | 1.5
Value_1_6 | 3 | 1.6
Value_1_8 | 4 | 1.8
Value_1_9 | 5 | 1.9
Value_2_0 | 6 | 2.0
Value_2_3 | 7 | 2.3
Value_2_5 | 8 | 2.5
Value_2_6 | 9 | 2.6
Value_2_7 | 10 | 2.7
Value_2_8 | 11 | 2.8
Value_2_9 | 12 | 2.9
Value_3_0 | 13 | 3.0
Value_3_1 | 14 | 3.1
Value_3_2 | 15 | 3.2
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLdo1ControlLdo1Enable Enumeration

IRD

Max8821TypeLdo1ControlLdo1Enable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLdo1ControlLdo1Enable
Public Enumeration TypeLdo1ControlLdo1Enable
public enum class TypeLdo1ControlLdo1Enable
type TypeLdo1ControlLdo1Enable
Members
Member name | Value | Description
LDO1Disabled | 0 | LDO1 Disabled
LDO1Enabled | 1 | LDO1 Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLdo1ControlLdo1Pulldown Enumeration

IRD

Max8821TypeLdo1ControlLdo1Pulldown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLdo1ControlLdo1Pulldown
Public Enumeration TypeLdo1ControlLdo1Pulldown
public enum class TypeLdo1ControlLdo1Pulldown
type TypeLdo1ControlLdo1Pulldown
Members
Member name | Value | Description
ActivePulldownEnabledDuringOFFCondition | 0 | Active Pulldown: Enabled (During OFF Condition)
ActivePulldownDisabledDuringOFFCondition | 1 | Active Pulldown: Disabled (During OFF Condition)
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLdo2ControlLdo2 Enumeration

IRD

Max8821TypeLdo2ControlLdo2 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLdo2ControlLdo2
Public Enumeration TypeLdo2ControlLdo2
public enum class TypeLdo2ControlLdo2
type TypeLdo2ControlLdo2
Members
Member name | Value | Description
Value_1_5 | 0 | 1.5
Value_1_6 | 1 | 1.6
Value_1_8 | 2 | 1.8
Value_2_0 | 3 | 2.0
Value_2_2 | 4 | 2.2
Value_2_3 | 5 | 2.3
Value_2_4 | 6 | 2.4
Value_2_5 | 7 | 2.5
Value_2_6 | 8 | 2.6
Value_2_7 | 9 | 2.7
Value_2_8 | 10 | 2.8
Value_2_9 | 11 | 2.9
Value_3_0 | 12 | 3.0
Value_3_1 | 13 | 3.1
Value_3_2 | 14 | 3.2
Value_3_3 | 15 | 3.3
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLdo2ControlLdo2Enable Enumeration

IRD

Max8821TypeLdo2ControlLdo2Enable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLdo2ControlLdo2Enable
Public Enumeration TypeLdo2ControlLdo2Enable
public enum class TypeLdo2ControlLdo2Enable
type TypeLdo2ControlLdo2Enable
Members
Member name | Value | Description
LDO2Disabled | 0 | LDO2 Disabled
LDO2Enabled | 1 | LDO2 Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLdo2ControlLdo2Pulldown Enumeration

IRD

Max8821TypeLdo2ControlLdo2Pulldown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLdo2ControlLdo2Pulldown
Public Enumeration TypeLdo2ControlLdo2Pulldown
public enum class TypeLdo2ControlLdo2Pulldown
type TypeLdo2ControlLdo2Pulldown
Members
Member name | Value | Description
ActivePulldownEnabledDuringOFFCondition | 0 | Active Pulldown: Enabled (During OFF Condition)
ActivePulldownDisabledDuringOFFCondition | 1 | Active Pulldown: Disabled (During OFF Condition)
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLed1CurrentRegulatorCurrent Enumeration

IRD

Max8821TypeLed1CurrentRegulatorCurrent Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed1CurrentRegulatorCurrent
Public Enumeration TypeLed1CurrentRegulatorCurrent
public enum class TypeLed1CurrentRegulatorCurrent
type TypeLed1CurrentRegulatorCurrent
Members
Member name | Value | Description
Value_0_1 | 0 | 0.1
Value_0_2 | 1 | 0.2
Value_0_3 | 2 | 0.3
Value_0_4 | 3 | 0.4
Value_0_5 | 4 | 0.5
Value_0_6 | 5 | 0.6
Value_0_7 | 6 | 0.7
Value_0_8 | 7 | 0.8
Value_1_0 | 8 | 1.0
Value_1_2 | 9 | 1.2
Value_1_4 | 10 | 1.4
Value_1_6 | 11 | 1.6
Value_2_0 | 12 | 2.0
Value_2_4 | 13 | 2.4
Value_2_8 | 14 | 2.8
Value_3_2 | 15 | 3.2
Value_4_0 | 16 | 4.0
Value_4_8 | 17 | 4.8
Value_5_6 | 18 | 5.6
Value_6_4 | 19 | 6.4
Value_8_0 | 20 | 8.0
Value_9_6 | 21 | 9.6
Value_11_2 | 22 | 11.2
Value_12_8 | 23 | 12.8
Value_14_4 | 24 | 14.4
Value_16_0 | 25 | 16.0
Value_17_6 | 26 | 17.6
Value_19_2 | 27 | 19.2
Value_20_8 | 28 | 20.8
Value_22_4 | 29 | 22.4
Value_24_0 | 30 | 24.0
Value_25_6 | 31 | 25.6
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLed1CurrentRegulatorRampUpdown Enumeration

IRD

Max8821TypeLed1CurrentRegulatorRampUpdown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed1CurrentRegulatorRampUpdown
Public Enumeration TypeLed1CurrentRegulatorRampUpdown
public enum class TypeLed1CurrentRegulatorRampUpdown
type TypeLed1CurrentRegulatorRampUpdown
Members
Member name | Value | Description
LED1RampUpDownDisabled | 0 | LED1 Ramp Up/Down: Disabled
LED1RampUpDownEnabled | 1 | LED1 Ramp Up/Down: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLed2CurrentRegulatorCurrent Enumeration

IRD

Max8821TypeLed2CurrentRegulatorCurrent Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed2CurrentRegulatorCurrent
Public Enumeration TypeLed2CurrentRegulatorCurrent
public enum class TypeLed2CurrentRegulatorCurrent
type TypeLed2CurrentRegulatorCurrent
Members
Member name | Value | Description
Value_0_1 | 0 | 0.1
Value_0_2 | 1 | 0.2
Value_0_3 | 2 | 0.3
Value_0_4 | 3 | 0.4
Value_0_5 | 4 | 0.5
Value_0_6 | 5 | 0.6
Value_0_7 | 6 | 0.7
Value_0_8 | 7 | 0.8
Value_1_0 | 8 | 1.0
Value_1_2 | 9 | 1.2
Value_1_4 | 10 | 1.4
Value_1_6 | 11 | 1.6
Value_2_0 | 12 | 2.0
Value_2_4 | 13 | 2.4
Value_2_8 | 14 | 2.8
Value_3_2 | 15 | 3.2
Value_4_0 | 16 | 4.0
Value_4_8 | 17 | 4.8
Value_5_6 | 18 | 5.6
Value_6_4 | 19 | 6.4
Value_8_0 | 20 | 8.0
Value_9_6 | 21 | 9.6
Value_11_2 | 22 | 11.2
Value_12_8 | 23 | 12.8
Value_14_4 | 24 | 14.4
Value_16_0 | 25 | 16.0
Value_17_6 | 26 | 17.6
Value_19_2 | 27 | 19.2
Value_20_8 | 28 | 20.8
Value_22_4 | 29 | 22.4
Value_24_0 | 30 | 24.0
Value_25_6 | 31 | 25.6
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLed2CurrentRegulatorRampUpdown Enumeration

IRD

Max8821TypeLed2CurrentRegulatorRampUpdown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed2CurrentRegulatorRampUpdown
Public Enumeration TypeLed2CurrentRegulatorRampUpdown
public enum class TypeLed2CurrentRegulatorRampUpdown
type TypeLed2CurrentRegulatorRampUpdown
Members
Member name | Value | Description
LED2RampUpDownDisabled | 0 | LED2 Ramp Up/Down: Disabled
LED2RampUpDownEnabled | 1 | LED2 Ramp Up/Down: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLed3CurrentRegulatorCurrent Enumeration

IRD

Max8821TypeLed3CurrentRegulatorCurrent Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed3CurrentRegulatorCurrent
Public Enumeration TypeLed3CurrentRegulatorCurrent
public enum class TypeLed3CurrentRegulatorCurrent
type TypeLed3CurrentRegulatorCurrent
Members
Member name | Value | Description
Value_0_1 | 0 | 0.1
Value_0_2 | 1 | 0.2
Value_0_3 | 2 | 0.3
Value_0_4 | 3 | 0.4
Value_0_5 | 4 | 0.5
Value_0_6 | 5 | 0.6
Value_0_7 | 6 | 0.7
Value_0_8 | 7 | 0.8
Value_1_0 | 8 | 1.0
Value_1_2 | 9 | 1.2
Value_1_4 | 10 | 1.4
Value_1_6 | 11 | 1.6
Value_2_0 | 12 | 2.0
Value_2_4 | 13 | 2.4
Value_2_8 | 14 | 2.8
Value_3_2 | 15 | 3.2
Value_4_0 | 16 | 4.0
Value_4_8 | 17 | 4.8
Value_5_6 | 18 | 5.6
Value_6_4 | 19 | 6.4
Value_8_0 | 20 | 8.0
Value_9_6 | 21 | 9.6
Value_11_2 | 22 | 11.2
Value_12_8 | 23 | 12.8
Value_14_4 | 24 | 14.4
Value_16_0 | 25 | 16.0
Value_17_6 | 26 | 17.6
Value_19_2 | 27 | 19.2
Value_20_8 | 28 | 20.8
Value_22_4 | 29 | 22.4
Value_24_0 | 30 | 24.0
Value_25_6 | 31 | 25.6
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLed3CurrentRegulatorRampUpdown Enumeration

IRD

Max8821TypeLed3CurrentRegulatorRampUpdown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed3CurrentRegulatorRampUpdown
Public Enumeration TypeLed3CurrentRegulatorRampUpdown
public enum class TypeLed3CurrentRegulatorRampUpdown
type TypeLed3CurrentRegulatorRampUpdown
Members
Member name | Value | Description
LED3RampUpDownDisabled | 0 | LED3 Ramp Up/Down: Disabled
LED3RampUpDownEnabled | 1 | LED3 Ramp Up/Down: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLed4CurrentRegulatorCurrent Enumeration

IRD

Max8821TypeLed4CurrentRegulatorCurrent Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed4CurrentRegulatorCurrent
Public Enumeration TypeLed4CurrentRegulatorCurrent
public enum class TypeLed4CurrentRegulatorCurrent
type TypeLed4CurrentRegulatorCurrent
Members
Member name | Value | Description
Value_0_1 | 0 | 0.1
Value_0_2 | 1 | 0.2
Value_0_3 | 2 | 0.3
Value_0_4 | 3 | 0.4
Value_0_5 | 4 | 0.5
Value_0_6 | 5 | 0.6
Value_0_7 | 6 | 0.7
Value_0_8 | 7 | 0.8
Value_1_0 | 8 | 1.0
Value_1_2 | 9 | 1.2
Value_1_4 | 10 | 1.4
Value_1_6 | 11 | 1.6
Value_2_0 | 12 | 2.0
Value_2_4 | 13 | 2.4
Value_2_8 | 14 | 2.8
Value_3_2 | 15 | 3.2
Value_4_0 | 16 | 4.0
Value_4_8 | 17 | 4.8
Value_5_6 | 18 | 5.6
Value_6_4 | 19 | 6.4
Value_8_0 | 20 | 8.0
Value_9_6 | 21 | 9.6
Value_11_2 | 22 | 11.2
Value_12_8 | 23 | 12.8
Value_14_4 | 24 | 14.4
Value_16_0 | 25 | 16.0
Value_17_6 | 26 | 17.6
Value_19_2 | 27 | 19.2
Value_20_8 | 28 | 20.8
Value_22_4 | 29 | 22.4
Value_24_0 | 30 | 24.0
Value_25_6 | 31 | 25.6
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLed4CurrentRegulatorRampUpdown Enumeration

IRD

Max8821TypeLed4CurrentRegulatorRampUpdown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed4CurrentRegulatorRampUpdown
Public Enumeration TypeLed4CurrentRegulatorRampUpdown
public enum class TypeLed4CurrentRegulatorRampUpdown
type TypeLed4CurrentRegulatorRampUpdown
Members
Member name | Value | Description
LED4RampUpDownDisabled | 0 | LED4 Ramp Up/Down: Disabled
LED4RampUpDownEnabled | 1 | LED4 Ramp Up/Down: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLed5CurrentRegulatorCurrent Enumeration

IRD

Max8821TypeLed5CurrentRegulatorCurrent Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed5CurrentRegulatorCurrent
Public Enumeration TypeLed5CurrentRegulatorCurrent
public enum class TypeLed5CurrentRegulatorCurrent
type TypeLed5CurrentRegulatorCurrent
Members
Member name | Value | Description
Value_0_1 | 0 | 0.1
Value_0_2 | 1 | 0.2
Value_0_3 | 2 | 0.3
Value_0_4 | 3 | 0.4
Value_0_5 | 4 | 0.5
Value_0_6 | 5 | 0.6
Value_0_7 | 6 | 0.7
Value_0_8 | 7 | 0.8
Value_1_0 | 8 | 1.0
Value_1_2 | 9 | 1.2
Value_1_4 | 10 | 1.4
Value_1_6 | 11 | 1.6
Value_2_0 | 12 | 2.0
Value_2_4 | 13 | 2.4
Value_2_8 | 14 | 2.8
Value_3_2 | 15 | 3.2
Value_4_0 | 16 | 4.0
Value_4_8 | 17 | 4.8
Value_5_6 | 18 | 5.6
Value_6_4 | 19 | 6.4
Value_8_0 | 20 | 8.0
Value_9_6 | 21 | 9.6
Value_11_2 | 22 | 11.2
Value_12_8 | 23 | 12.8
Value_14_4 | 24 | 14.4
Value_16_0 | 25 | 16.0
Value_17_6 | 26 | 17.6
Value_19_2 | 27 | 19.2
Value_20_8 | 28 | 20.8
Value_22_4 | 29 | 22.4
Value_24_0 | 30 | 24.0
Value_25_6 | 31 | 25.6
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLed5CurrentRegulatorRampUpdown Enumeration

IRD

Max8821TypeLed5CurrentRegulatorRampUpdown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed5CurrentRegulatorRampUpdown
Public Enumeration TypeLed5CurrentRegulatorRampUpdown
public enum class TypeLed5CurrentRegulatorRampUpdown
type TypeLed5CurrentRegulatorRampUpdown
Members
Member name | Value | Description
LED5RampUpDownDisabled | 0 | LED5 Ramp Up/Down: Disabled
LED5RampUpDownEnabled | 1 | LED5 Ramp Up/Down: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLed6CurrentRegulatorCurrent Enumeration

IRD

Max8821TypeLed6CurrentRegulatorCurrent Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed6CurrentRegulatorCurrent
Public Enumeration TypeLed6CurrentRegulatorCurrent
public enum class TypeLed6CurrentRegulatorCurrent
type TypeLed6CurrentRegulatorCurrent
Members
Member name | Value | Description
Value_0_1 | 0 | 0.1
Value_0_2 | 1 | 0.2
Value_0_3 | 2 | 0.3
Value_0_4 | 3 | 0.4
Value_0_5 | 4 | 0.5
Value_0_6 | 5 | 0.6
Value_0_7 | 6 | 0.7
Value_0_8 | 7 | 0.8
Value_1_0 | 8 | 1.0
Value_1_2 | 9 | 1.2
Value_1_4 | 10 | 1.4
Value_1_6 | 11 | 1.6
Value_2_0 | 12 | 2.0
Value_2_4 | 13 | 2.4
Value_2_8 | 14 | 2.8
Value_3_2 | 15 | 3.2
Value_4_0 | 16 | 4.0
Value_4_8 | 17 | 4.8
Value_5_6 | 18 | 5.6
Value_6_4 | 19 | 6.4
Value_8_0 | 20 | 8.0
Value_9_6 | 21 | 9.6
Value_11_2 | 22 | 11.2
Value_12_8 | 23 | 12.8
Value_14_4 | 24 | 14.4
Value_16_0 | 25 | 16.0
Value_17_6 | 26 | 17.6
Value_19_2 | 27 | 19.2
Value_20_8 | 28 | 20.8
Value_22_4 | 29 | 22.4
Value_24_0 | 30 | 24.0
Value_25_6 | 31 | 25.6
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLed6CurrentRegulatorRampUpdown Enumeration

IRD

Max8821TypeLed6CurrentRegulatorRampUpdown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed6CurrentRegulatorRampUpdown
Public Enumeration TypeLed6CurrentRegulatorRampUpdown
public enum class TypeLed6CurrentRegulatorRampUpdown
type TypeLed6CurrentRegulatorRampUpdown
Members
Member name | Value | Description
LED6RampUpDownDisabled | 0 | LED6 Ramp Up/Down: Disabled
LED6RampUpDownEnabled | 1 | LED6 Ramp Up/Down: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLedEnableLed1 Enumeration

IRD

Max8821TypeLedEnableLed1 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedEnableLed1
Public Enumeration TypeLedEnableLed1
public enum class TypeLedEnableLed1
type TypeLedEnableLed1
Members
Member name | Value | Description
LEDCurrentSourceDisabled | 0 | LED Current Source: Disabled
LEDCurrentSourceEnabled | 1 | LED Current Source: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLedEnableLed2 Enumeration

IRD

Max8821TypeLedEnableLed2 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedEnableLed2
Public Enumeration TypeLedEnableLed2
public enum class TypeLedEnableLed2
type TypeLedEnableLed2
Members
Member name | Value | Description
LEDCurrentSourceDisabled | 0 | LED Current Source: Disabled
LEDCurrentSourceEnabled | 1 | LED Current Source: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLedEnableLed3 Enumeration

IRD

Max8821TypeLedEnableLed3 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedEnableLed3
Public Enumeration TypeLedEnableLed3
public enum class TypeLedEnableLed3
type TypeLedEnableLed3
Members
Member name | Value | Description
LEDCurrentSourceDisabled | 0 | LED Current Source: Disabled
LEDCurrentSourceEnabled | 1 | LED Current Source: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLedEnableLed4 Enumeration

IRD

Max8821TypeLedEnableLed4 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedEnableLed4
Public Enumeration TypeLedEnableLed4
public enum class TypeLedEnableLed4
type TypeLedEnableLed4
Members
Member name | Value | Description
LEDCurrentSourceDisabled | 0 | LED Current Source: Disabled
LEDCurrentSourceEnabled | 1 | LED Current Source: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLedEnableLed5 Enumeration

IRD

Max8821TypeLedEnableLed5 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedEnableLed5
Public Enumeration TypeLedEnableLed5
public enum class TypeLedEnableLed5
type TypeLedEnableLed5
Members
Member name | Value | Description
LEDCurrentSourceDisabled | 0 | LED Current Source: Disabled
LEDCurrentSourceEnabled | 1 | LED Current Source: Enabled
LEDCurrentSourceControlledByBlinkTimer | 2 | LED Current Source: Controlled By Blink Timer
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeLedEnableLed6 Enumeration

IRD

Max8821TypeLedEnableLed6 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedEnableLed6
Public Enumeration TypeLedEnableLed6
public enum class TypeLedEnableLed6
type TypeLedEnableLed6
Members
Member name | Value | Description
LEDCurrentSourceDisabled | 0 | LED Current Source: Disabled
LEDCurrentSourceEnabled | 1 | LED Current Source: Enabled
LEDCurrentSourceControlledByBlinkTimer | 2 | LED Current Source: Controlled By Blink Timer
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypePumpControlPump Enumeration

IRD

Max8821TypePumpControlPump Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePumpControlPump
Public Enumeration TypePumpControlPump
public enum class TypePumpControlPump
type TypePumpControlPump
Members
Member name | Value | Description
ChargePumpChangesAutomaticallyBetween1x15xMode | 0 | Charge Pump Changes Automatically Between 1x/1.5x Mode
ChargePumpIsForcedInto15xMode | 1 | Charge Pump Is Forced Into 1.5x Mode
ChargePumpIsForcedInto15xModeWhenAudioAmplifierNotEnabled | 2 | Charge Pump Is Forced Into 1.5x Mode When Audio Amplifier Not Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypePumpControlTemperature Enumeration

IRD

Max8821TypePumpControlTemperature Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePumpControlTemperature
Public Enumeration TypePumpControlTemperature
public enum class TypePumpControlTemperature
type TypePumpControlTemperature
Members
Member name | Value | Description
TemperatureDeratingDisabled | 0 | Temperature Derating: Disabled
TemperatureDeratingEnabled | 1 | Temperature Derating: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8821.TypeRampControlRampTime Enumeration

IRD

Max8821TypeRampControlRampTime Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRampControlRampTime
Public Enumeration TypeRampControlRampTime
public enum class TypeRampControlRampTime
type TypeRampControlRampTime
Members
Member name | Value | Description
Value_218XTqpclk | 0 | 2^18 x Tqpclk
Value_219XTqpclk | 1 | 2^19 x Tqpclk
Value_220XTqpclk | 2 | 2^20 x Tqpclk
Value_221XTqpclk | 3 | 2^21 x Tqpclk
See Also

Reference

telos.Ird.Maxim Namespace


Max8831 Class

Maxim: MAX 8831
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax8831

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max8831
Public Class Max8831
public ref class Max8831
type Max8831 =  class end

The Max8831 type exposes the following members.

Constructors
 | Name | Description
Public method | Max8831 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BOOSTCNTLLED3BOOSTCNTL | BOOST_CNTL: LED3_BOOST_CNTL
Public property | BOOSTCNTLLED4BOOSTCNTL | BOOST_CNTL: LED4_BOOST_CNTL
Public property | BOOSTCNTLLED5BOOSTCNTL | BOOST_CNTL: LED5_BOOST_CNTL
Public property | CHIPID1DIETYPE | CHIP_ID1: DIE_TYPE
Public property | CHIPID2DASH | CHIP_ID2: DASH
Public property | CHIPID2MASKREV | CHIP_ID2: MASK_REV
Public property | ILED1CNTLILED1 | ILED1_CNTL: ILED1
Public property | ILED2CNTLILED2 | ILED2_CNTL: ILED2
Public property | ILED3CNTLILED3 | ILED3_CNTL: ILED3
Public property | ILED4CNTLILED4 | ILED4_CNTL: ILED4
Public property | ILED5CNTLILED5 | ILED5_CNTL: ILED5
Public property | LED1RAMPCNTLLED1RAMPDOWN | LED1_RAMP_CNTL: LED1_RAMP_DOWN
Public property | LED1RAMPCNTLLED1RAMPUP | LED1_RAMP_CNTL: LED1_RAMP_UP
Public property | LED2RAMPCNTLLED2RAMPDOWN | LED2_RAMP_CNTL: LED2_RAMP_DOWN
Public property | LED2RAMPCNTLLED2RAMPUP | LED2_RAMP_CNTL: LED2_RAMP_UP
Public property | LED3BLNKCNTLLED3BLINKEN | LED3_BLNK_CNTL: LED3_BLINK_EN
Public property | LED3BLNKCNTLLED3TOFFBLINK | LED3_BLNK_CNTL: LED3_TOFF_BLINK
Public property | LED3BLNKCNTLLED3TONBLINK | LED3_BLNK_CNTL: LED3_TON_BLINK
Public property | LED3RAMPCNTLLED3RAMPDOWN | LED3_RAMP_CNTL: LED3_RAMP_DOWN
Public property | LED3RAMPCNTLLED3RAMPUP | LED3_RAMP_CNTL: LED3_RAMP_UP
Public property | LED4BLNKCNTLLED4BLINKEN | LED4_BLNK_CNTL: LED4_BLINK_EN
Public property | LED4BLNKCNTLLED4TOFFBLINK | LED4_BLNK_CNTL: LED4_TOFF_BLINK
Public property | LED4BLNKCNTLLED4TONBLINK | LED4_BLNK_CNTL: LED4_TON_BLINK
Public property | LED4RAMPCNTLLED4RAMPDOWN | LED4_RAMP_CNTL: LED4_RAMP_DOWN
Public property | LED4RAMPCNTLLED4RAMPUP | LED4_RAMP_CNTL: LED4_RAMP_UP
Public property | LED5BLNKCNTLLED5BLINKEN | LED5_BLNK_CNTL: LED5_BLINK_EN
Public property | LED5BLNKCNTLLED5TOFFBLINK | LED5_BLNK_CNTL: LED5_TOFF_BLINK
Public property | LED5BLNKCNTLLED5TONBLINK | LED5_BLNK_CNTL: LED5_TON_BLINK
Public property | LED5RAMPCNTLLED5RAMPDOWN | LED5_RAMP_CNTL: LED5_RAMP_DOWN
Public property | LED5RAMPCNTLLED5RAMPUP | LED5_RAMP_CNTL: LED5_RAMP_UP
Public property | ONOFFCNTLLED1EN | ON/OFF_CNTL: LED1_EN
Public property | ONOFFCNTLLED2EN | ON/OFF_CNTL: LED2_EN
Public property | ONOFFCNTLLED3EN | ON/OFF_CNTL: LED3_EN
Public property | ONOFFCNTLLED4EN | ON/OFF_CNTL: LED4_EN
Public property | ONOFFCNTLLED5EN | ON/OFF_CNTL: LED5_EN
Public property | STAT1LED1FAULT | STAT1: LED1_FAULT
Public property | STAT1LED2FAULT | STAT1: LED2_FAULT
Public property | STAT1LED3FAULT | STAT1: LED3_FAULT
Public property | STAT1LED4FAULT | STAT1: LED4_FAULT
Public property | STAT1LED5FAULT | STAT1: LED5_FAULT
Public property | STAT2OSDD | STAT2: OSDD
Public property | STAT2OVP | STAT2: OVP
Public property | STAT2TSD | STAT2: TSD
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
High-Efficiency White LED Step-Up Converter
See Also

Reference

telos.Ird.Maxim Namespace


Max8831 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max8831(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max8831

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831 Properties

The Max8831 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BOOSTCNTLLED3BOOSTCNTL | BOOST_CNTL: LED3_BOOST_CNTL
Public property | BOOSTCNTLLED4BOOSTCNTL | BOOST_CNTL: LED4_BOOST_CNTL
Public property | BOOSTCNTLLED5BOOSTCNTL | BOOST_CNTL: LED5_BOOST_CNTL
Public property | CHIPID1DIETYPE | CHIP_ID1: DIE_TYPE
Public property | CHIPID2DASH | CHIP_ID2: DASH
Public property | CHIPID2MASKREV | CHIP_ID2: MASK_REV
Public property | ILED1CNTLILED1 | ILED1_CNTL: ILED1
Public property | ILED2CNTLILED2 | ILED2_CNTL: ILED2
Public property | ILED3CNTLILED3 | ILED3_CNTL: ILED3
Public property | ILED4CNTLILED4 | ILED4_CNTL: ILED4
Public property | ILED5CNTLILED5 | ILED5_CNTL: ILED5
Public property | LED1RAMPCNTLLED1RAMPDOWN | LED1_RAMP_CNTL: LED1_RAMP_DOWN
Public property | LED1RAMPCNTLLED1RAMPUP | LED1_RAMP_CNTL: LED1_RAMP_UP
Public property | LED2RAMPCNTLLED2RAMPDOWN | LED2_RAMP_CNTL: LED2_RAMP_DOWN
Public property | LED2RAMPCNTLLED2RAMPUP | LED2_RAMP_CNTL: LED2_RAMP_UP
Public property | LED3BLNKCNTLLED3BLINKEN | LED3_BLNK_CNTL: LED3_BLINK_EN
Public property | LED3BLNKCNTLLED3TOFFBLINK | LED3_BLNK_CNTL: LED3_TOFF_BLINK
Public property | LED3BLNKCNTLLED3TONBLINK | LED3_BLNK_CNTL: LED3_TON_BLINK
Public property | LED3RAMPCNTLLED3RAMPDOWN | LED3_RAMP_CNTL: LED3_RAMP_DOWN
Public property | LED3RAMPCNTLLED3RAMPUP | LED3_RAMP_CNTL: LED3_RAMP_UP
Public property | LED4BLNKCNTLLED4BLINKEN | LED4_BLNK_CNTL: LED4_BLINK_EN
Public property | LED4BLNKCNTLLED4TOFFBLINK | LED4_BLNK_CNTL: LED4_TOFF_BLINK
Public property | LED4BLNKCNTLLED4TONBLINK | LED4_BLNK_CNTL: LED4_TON_BLINK
Public property | LED4RAMPCNTLLED4RAMPDOWN | LED4_RAMP_CNTL: LED4_RAMP_DOWN
Public property | LED4RAMPCNTLLED4RAMPUP | LED4_RAMP_CNTL: LED4_RAMP_UP
Public property | LED5BLNKCNTLLED5BLINKEN | LED5_BLNK_CNTL: LED5_BLINK_EN
Public property | LED5BLNKCNTLLED5TOFFBLINK | LED5_BLNK_CNTL: LED5_TOFF_BLINK
Public property | LED5BLNKCNTLLED5TONBLINK | LED5_BLNK_CNTL: LED5_TON_BLINK
Public property | LED5RAMPCNTLLED5RAMPDOWN | LED5_RAMP_CNTL: LED5_RAMP_DOWN
Public property | LED5RAMPCNTLLED5RAMPUP | LED5_RAMP_CNTL: LED5_RAMP_UP
Public property | ONOFFCNTLLED1EN | ON/OFF_CNTL: LED1_EN
Public property | ONOFFCNTLLED2EN | ON/OFF_CNTL: LED2_EN
Public property | ONOFFCNTLLED3EN | ON/OFF_CNTL: LED3_EN
Public property | ONOFFCNTLLED4EN | ON/OFF_CNTL: LED4_EN
Public property | ONOFFCNTLLED5EN | ON/OFF_CNTL: LED5_EN
Public property | STAT1LED1FAULT | STAT1: LED1_FAULT
Public property | STAT1LED2FAULT | STAT1: LED2_FAULT
Public property | STAT1LED3FAULT | STAT1: LED3_FAULT
Public property | STAT1LED4FAULT | STAT1: LED4_FAULT
Public property | STAT1LED5FAULT | STAT1: LED5_FAULT
Public property | STAT2OSDD | STAT2: OSDD
Public property | STAT2OVP | STAT2: OVP
Public property | STAT2TSD | STAT2: TSD
Top
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.AutoFlush Property

IRD

Max8831AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.BOOSTCNTLLED3BOOSTCNTL Property

IRD

Max8831BOOSTCNTLLED3BOOSTCNTL Property

BOOST_CNTL: LED3_BOOST_CNTL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeBoostCntlLed3BoostCntl BOOSTCNTLLED3BOOSTCNTL { get; set; }
Public Property BOOSTCNTLLED3BOOSTCNTL As Max8831TypeBoostCntlLed3BoostCntl
    Get
    Set
public:
property Max8831TypeBoostCntlLed3BoostCntl BOOSTCNTLLED3BOOSTCNTL {
    Max8831TypeBoostCntlLed3BoostCntl get ();
    void set (Max8831TypeBoostCntlLed3BoostCntl value);
}
member BOOSTCNTLLED3BOOSTCNTL : Max8831TypeBoostCntlLed3BoostCntl with get, set

Property Value

Type: Max8831TypeBoostCntlLed3BoostCntl
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.BOOSTCNTLLED4BOOSTCNTL Property

IRD

Max8831BOOSTCNTLLED4BOOSTCNTL Property

BOOST_CNTL: LED4_BOOST_CNTL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeBoostCntlLed4BoostCntl BOOSTCNTLLED4BOOSTCNTL { get; set; }
Public Property BOOSTCNTLLED4BOOSTCNTL As Max8831TypeBoostCntlLed4BoostCntl
    Get
    Set
public:
property Max8831TypeBoostCntlLed4BoostCntl BOOSTCNTLLED4BOOSTCNTL {
    Max8831TypeBoostCntlLed4BoostCntl get ();
    void set (Max8831TypeBoostCntlLed4BoostCntl value);
}
member BOOSTCNTLLED4BOOSTCNTL : Max8831TypeBoostCntlLed4BoostCntl with get, set

Property Value

Type: Max8831TypeBoostCntlLed4BoostCntl
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.BOOSTCNTLLED5BOOSTCNTL Property

IRD

Max8831BOOSTCNTLLED5BOOSTCNTL Property

BOOST_CNTL: LED5_BOOST_CNTL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeBoostCntlLed5BoostCntl BOOSTCNTLLED5BOOSTCNTL { get; set; }
Public Property BOOSTCNTLLED5BOOSTCNTL As Max8831TypeBoostCntlLed5BoostCntl
    Get
    Set
public:
property Max8831TypeBoostCntlLed5BoostCntl BOOSTCNTLLED5BOOSTCNTL {
    Max8831TypeBoostCntlLed5BoostCntl get ();
    void set (Max8831TypeBoostCntlLed5BoostCntl value);
}
member BOOSTCNTLLED5BOOSTCNTL : Max8831TypeBoostCntlLed5BoostCntl with get, set

Property Value

Type: Max8831TypeBoostCntlLed5BoostCntl
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.CHIPID1DIETYPE Property

IRD

Max8831CHIPID1DIETYPE Property

CHIP_ID1: DIE_TYPE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CHIPID1DIETYPE { get; }
Public ReadOnly Property CHIPID1DIETYPE As Byte
    Get
public:
property unsigned char CHIPID1DIETYPE {
    unsigned char get ();
}
member CHIPID1DIETYPE : byte with get

Property Value

Type: Byte
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.CHIPID2DASH Property

IRD

Max8831CHIPID2DASH Property

CHIP_ID2: DASH

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CHIPID2DASH { get; }
Public ReadOnly Property CHIPID2DASH As Byte
    Get
public:
property unsigned char CHIPID2DASH {
    unsigned char get ();
}
member CHIPID2DASH : byte with get

Property Value

Type: Byte
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.CHIPID2MASKREV Property

IRD

Max8831CHIPID2MASKREV Property

CHIP_ID2: MASK_REV

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CHIPID2MASKREV { get; }
Public ReadOnly Property CHIPID2MASKREV As Byte
    Get
public:
property unsigned char CHIPID2MASKREV {
    unsigned char get ();
}
member CHIPID2MASKREV : byte with get

Property Value

Type: Byte
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.ILED1CNTLILED1 Property

IRD

Max8831ILED1CNTLILED1 Property

ILED1_CNTL: ILED1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ILED1CNTLILED1 { get; set; }
Public Property ILED1CNTLILED1 As Byte
    Get
    Set
public:
property unsigned char ILED1CNTLILED1 {
    unsigned char get ();
    void set (unsigned char value);
}
member ILED1CNTLILED1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.ILED2CNTLILED2 Property

IRD

Max8831ILED2CNTLILED2 Property

ILED2_CNTL: ILED2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ILED2CNTLILED2 { get; set; }
Public Property ILED2CNTLILED2 As Byte
    Get
    Set
public:
property unsigned char ILED2CNTLILED2 {
    unsigned char get ();
    void set (unsigned char value);
}
member ILED2CNTLILED2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.ILED3CNTLILED3 Property

IRD

Max8831ILED3CNTLILED3 Property

ILED3_CNTL: ILED3

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ILED3CNTLILED3 { get; set; }
Public Property ILED3CNTLILED3 As Byte
    Get
    Set
public:
property unsigned char ILED3CNTLILED3 {
    unsigned char get ();
    void set (unsigned char value);
}
member ILED3CNTLILED3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.ILED4CNTLILED4 Property

IRD

Max8831ILED4CNTLILED4 Property

ILED4_CNTL: ILED4

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ILED4CNTLILED4 { get; set; }
Public Property ILED4CNTLILED4 As Byte
    Get
    Set
public:
property unsigned char ILED4CNTLILED4 {
    unsigned char get ();
    void set (unsigned char value);
}
member ILED4CNTLILED4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.ILED5CNTLILED5 Property

IRD

Max8831ILED5CNTLILED5 Property

ILED5_CNTL: ILED5

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ILED5CNTLILED5 { get; set; }
Public Property ILED5CNTLILED5 As Byte
    Get
    Set
public:
property unsigned char ILED5CNTLILED5 {
    unsigned char get ();
    void set (unsigned char value);
}
member ILED5CNTLILED5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED1RAMPCNTLLED1RAMPDOWN Property

IRD

Max8831LED1RAMPCNTLLED1RAMPDOWN Property

LED1_RAMP_CNTL: LED1_RAMP_DOWN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed1RampCntlLedRampDown LED1RAMPCNTLLED1RAMPDOWN { get; set; }
Public Property LED1RAMPCNTLLED1RAMPDOWN As Max8831TypeLed1RampCntlLedRampDown
    Get
    Set
public:
property Max8831TypeLed1RampCntlLedRampDown LED1RAMPCNTLLED1RAMPDOWN {
    Max8831TypeLed1RampCntlLedRampDown get ();
    void set (Max8831TypeLed1RampCntlLedRampDown value);
}
member LED1RAMPCNTLLED1RAMPDOWN : Max8831TypeLed1RampCntlLedRampDown with get, set

Property Value

Type: Max8831TypeLed1RampCntlLedRampDown
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED1RAMPCNTLLED1RAMPUP Property

IRD

Max8831LED1RAMPCNTLLED1RAMPUP Property

LED1_RAMP_CNTL: LED1_RAMP_UP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed1RampCntlLedRampUp LED1RAMPCNTLLED1RAMPUP { get; set; }
Public Property LED1RAMPCNTLLED1RAMPUP As Max8831TypeLed1RampCntlLedRampUp
    Get
    Set
public:
property Max8831TypeLed1RampCntlLedRampUp LED1RAMPCNTLLED1RAMPUP {
    Max8831TypeLed1RampCntlLedRampUp get ();
    void set (Max8831TypeLed1RampCntlLedRampUp value);
}
member LED1RAMPCNTLLED1RAMPUP : Max8831TypeLed1RampCntlLedRampUp with get, set

Property Value

Type: Max8831TypeLed1RampCntlLedRampUp
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED2RAMPCNTLLED2RAMPDOWN Property

IRD

Max8831LED2RAMPCNTLLED2RAMPDOWN Property

LED2_RAMP_CNTL: LED2_RAMP_DOWN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed2RampCntlLedRampDown LED2RAMPCNTLLED2RAMPDOWN { get; set; }
Public Property LED2RAMPCNTLLED2RAMPDOWN As Max8831TypeLed2RampCntlLedRampDown
    Get
    Set
public:
property Max8831TypeLed2RampCntlLedRampDown LED2RAMPCNTLLED2RAMPDOWN {
    Max8831TypeLed2RampCntlLedRampDown get ();
    void set (Max8831TypeLed2RampCntlLedRampDown value);
}
member LED2RAMPCNTLLED2RAMPDOWN : Max8831TypeLed2RampCntlLedRampDown with get, set

Property Value

Type: Max8831TypeLed2RampCntlLedRampDown
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED2RAMPCNTLLED2RAMPUP Property

IRD

Max8831LED2RAMPCNTLLED2RAMPUP Property

LED2_RAMP_CNTL: LED2_RAMP_UP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed2RampCntlLedRampUp LED2RAMPCNTLLED2RAMPUP { get; set; }
Public Property LED2RAMPCNTLLED2RAMPUP As Max8831TypeLed2RampCntlLedRampUp
    Get
    Set
public:
property Max8831TypeLed2RampCntlLedRampUp LED2RAMPCNTLLED2RAMPUP {
    Max8831TypeLed2RampCntlLedRampUp get ();
    void set (Max8831TypeLed2RampCntlLedRampUp value);
}
member LED2RAMPCNTLLED2RAMPUP : Max8831TypeLed2RampCntlLedRampUp with get, set

Property Value

Type: Max8831TypeLed2RampCntlLedRampUp
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED3BLNKCNTLLED3BLINKEN Property

IRD

Max8831LED3BLNKCNTLLED3BLINKEN Property

LED3_BLNK_CNTL: LED3_BLINK_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed3BlinkCntlLedBlinkEnable LED3BLNKCNTLLED3BLINKEN { get; set; }
Public Property LED3BLNKCNTLLED3BLINKEN As Max8831TypeLed3BlinkCntlLedBlinkEnable
    Get
    Set
public:
property Max8831TypeLed3BlinkCntlLedBlinkEnable LED3BLNKCNTLLED3BLINKEN {
    Max8831TypeLed3BlinkCntlLedBlinkEnable get ();
    void set (Max8831TypeLed3BlinkCntlLedBlinkEnable value);
}
member LED3BLNKCNTLLED3BLINKEN : Max8831TypeLed3BlinkCntlLedBlinkEnable with get, set

Property Value

Type: Max8831TypeLed3BlinkCntlLedBlinkEnable
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED3BLNKCNTLLED3TOFFBLINK Property

IRD

Max8831LED3BLNKCNTLLED3TOFFBLINK Property

LED3_BLNK_CNTL: LED3_TOFF_BLINK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed3BlinkCntlLedToffBlink LED3BLNKCNTLLED3TOFFBLINK { get; set; }
Public Property LED3BLNKCNTLLED3TOFFBLINK As Max8831TypeLed3BlinkCntlLedToffBlink
    Get
    Set
public:
property Max8831TypeLed3BlinkCntlLedToffBlink LED3BLNKCNTLLED3TOFFBLINK {
    Max8831TypeLed3BlinkCntlLedToffBlink get ();
    void set (Max8831TypeLed3BlinkCntlLedToffBlink value);
}
member LED3BLNKCNTLLED3TOFFBLINK : Max8831TypeLed3BlinkCntlLedToffBlink with get, set

Property Value

Type: Max8831TypeLed3BlinkCntlLedToffBlink
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED3BLNKCNTLLED3TONBLINK Property

IRD

Max8831LED3BLNKCNTLLED3TONBLINK Property

LED3_BLNK_CNTL: LED3_TON_BLINK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed3BlinkCntlLedTonBlink LED3BLNKCNTLLED3TONBLINK { get; set; }
Public Property LED3BLNKCNTLLED3TONBLINK As Max8831TypeLed3BlinkCntlLedTonBlink
    Get
    Set
public:
property Max8831TypeLed3BlinkCntlLedTonBlink LED3BLNKCNTLLED3TONBLINK {
    Max8831TypeLed3BlinkCntlLedTonBlink get ();
    void set (Max8831TypeLed3BlinkCntlLedTonBlink value);
}
member LED3BLNKCNTLLED3TONBLINK : Max8831TypeLed3BlinkCntlLedTonBlink with get, set

Property Value

Type: Max8831TypeLed3BlinkCntlLedTonBlink
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED3RAMPCNTLLED3RAMPDOWN Property

IRD

Max8831LED3RAMPCNTLLED3RAMPDOWN Property

LED3_RAMP_CNTL: LED3_RAMP_DOWN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed3RampCntlLedRampDown LED3RAMPCNTLLED3RAMPDOWN { get; set; }
Public Property LED3RAMPCNTLLED3RAMPDOWN As Max8831TypeLed3RampCntlLedRampDown
    Get
    Set
public:
property Max8831TypeLed3RampCntlLedRampDown LED3RAMPCNTLLED3RAMPDOWN {
    Max8831TypeLed3RampCntlLedRampDown get ();
    void set (Max8831TypeLed3RampCntlLedRampDown value);
}
member LED3RAMPCNTLLED3RAMPDOWN : Max8831TypeLed3RampCntlLedRampDown with get, set

Property Value

Type: Max8831TypeLed3RampCntlLedRampDown
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED3RAMPCNTLLED3RAMPUP Property

IRD

Max8831LED3RAMPCNTLLED3RAMPUP Property

LED3_RAMP_CNTL: LED3_RAMP_UP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed3RampCntlLedRampUp LED3RAMPCNTLLED3RAMPUP { get; set; }
Public Property LED3RAMPCNTLLED3RAMPUP As Max8831TypeLed3RampCntlLedRampUp
    Get
    Set
public:
property Max8831TypeLed3RampCntlLedRampUp LED3RAMPCNTLLED3RAMPUP {
    Max8831TypeLed3RampCntlLedRampUp get ();
    void set (Max8831TypeLed3RampCntlLedRampUp value);
}
member LED3RAMPCNTLLED3RAMPUP : Max8831TypeLed3RampCntlLedRampUp with get, set

Property Value

Type: Max8831TypeLed3RampCntlLedRampUp
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED4BLNKCNTLLED4BLINKEN Property

IRD

Max8831LED4BLNKCNTLLED4BLINKEN Property

LED4_BLNK_CNTL: LED4_BLINK_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed4BlinkCntlLedBlinkEnable LED4BLNKCNTLLED4BLINKEN { get; set; }
Public Property LED4BLNKCNTLLED4BLINKEN As Max8831TypeLed4BlinkCntlLedBlinkEnable
    Get
    Set
public:
property Max8831TypeLed4BlinkCntlLedBlinkEnable LED4BLNKCNTLLED4BLINKEN {
    Max8831TypeLed4BlinkCntlLedBlinkEnable get ();
    void set (Max8831TypeLed4BlinkCntlLedBlinkEnable value);
}
member LED4BLNKCNTLLED4BLINKEN : Max8831TypeLed4BlinkCntlLedBlinkEnable with get, set

Property Value

Type: Max8831TypeLed4BlinkCntlLedBlinkEnable
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED4BLNKCNTLLED4TOFFBLINK Property

IRD

Max8831LED4BLNKCNTLLED4TOFFBLINK Property

LED4_BLNK_CNTL: LED4_TOFF_BLINK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed4BlinkCntlLedToffBlink LED4BLNKCNTLLED4TOFFBLINK { get; set; }
Public Property LED4BLNKCNTLLED4TOFFBLINK As Max8831TypeLed4BlinkCntlLedToffBlink
    Get
    Set
public:
property Max8831TypeLed4BlinkCntlLedToffBlink LED4BLNKCNTLLED4TOFFBLINK {
    Max8831TypeLed4BlinkCntlLedToffBlink get ();
    void set (Max8831TypeLed4BlinkCntlLedToffBlink value);
}
member LED4BLNKCNTLLED4TOFFBLINK : Max8831TypeLed4BlinkCntlLedToffBlink with get, set

Property Value

Type: Max8831TypeLed4BlinkCntlLedToffBlink
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED4BLNKCNTLLED4TONBLINK Property

IRD

Max8831LED4BLNKCNTLLED4TONBLINK Property

LED4_BLNK_CNTL: LED4_TON_BLINK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed4BlinkCntlLedTonBlink LED4BLNKCNTLLED4TONBLINK { get; set; }
Public Property LED4BLNKCNTLLED4TONBLINK As Max8831TypeLed4BlinkCntlLedTonBlink
    Get
    Set
public:
property Max8831TypeLed4BlinkCntlLedTonBlink LED4BLNKCNTLLED4TONBLINK {
    Max8831TypeLed4BlinkCntlLedTonBlink get ();
    void set (Max8831TypeLed4BlinkCntlLedTonBlink value);
}
member LED4BLNKCNTLLED4TONBLINK : Max8831TypeLed4BlinkCntlLedTonBlink with get, set

Property Value

Type: Max8831TypeLed4BlinkCntlLedTonBlink
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED4RAMPCNTLLED4RAMPDOWN Property

IRD

Max8831LED4RAMPCNTLLED4RAMPDOWN Property

LED4_RAMP_CNTL: LED4_RAMP_DOWN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed4RampCntlLedRampDown LED4RAMPCNTLLED4RAMPDOWN { get; set; }
Public Property LED4RAMPCNTLLED4RAMPDOWN As Max8831TypeLed4RampCntlLedRampDown
    Get
    Set
public:
property Max8831TypeLed4RampCntlLedRampDown LED4RAMPCNTLLED4RAMPDOWN {
    Max8831TypeLed4RampCntlLedRampDown get ();
    void set (Max8831TypeLed4RampCntlLedRampDown value);
}
member LED4RAMPCNTLLED4RAMPDOWN : Max8831TypeLed4RampCntlLedRampDown with get, set

Property Value

Type: Max8831TypeLed4RampCntlLedRampDown
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED4RAMPCNTLLED4RAMPUP Property

IRD

Max8831LED4RAMPCNTLLED4RAMPUP Property

LED4_RAMP_CNTL: LED4_RAMP_UP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed4RampCntlLedRampUp LED4RAMPCNTLLED4RAMPUP { get; set; }
Public Property LED4RAMPCNTLLED4RAMPUP As Max8831TypeLed4RampCntlLedRampUp
    Get
    Set
public:
property Max8831TypeLed4RampCntlLedRampUp LED4RAMPCNTLLED4RAMPUP {
    Max8831TypeLed4RampCntlLedRampUp get ();
    void set (Max8831TypeLed4RampCntlLedRampUp value);
}
member LED4RAMPCNTLLED4RAMPUP : Max8831TypeLed4RampCntlLedRampUp with get, set

Property Value

Type: Max8831TypeLed4RampCntlLedRampUp
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED5BLNKCNTLLED5BLINKEN Property

IRD

Max8831LED5BLNKCNTLLED5BLINKEN Property

LED5_BLNK_CNTL: LED5_BLINK_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed5BlinkCntlLedBlinkEnable LED5BLNKCNTLLED5BLINKEN { get; set; }
Public Property LED5BLNKCNTLLED5BLINKEN As Max8831TypeLed5BlinkCntlLedBlinkEnable
    Get
    Set
public:
property Max8831TypeLed5BlinkCntlLedBlinkEnable LED5BLNKCNTLLED5BLINKEN {
    Max8831TypeLed5BlinkCntlLedBlinkEnable get ();
    void set (Max8831TypeLed5BlinkCntlLedBlinkEnable value);
}
member LED5BLNKCNTLLED5BLINKEN : Max8831TypeLed5BlinkCntlLedBlinkEnable with get, set

Property Value

Type: Max8831TypeLed5BlinkCntlLedBlinkEnable
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED5BLNKCNTLLED5TOFFBLINK Property

IRD

Max8831LED5BLNKCNTLLED5TOFFBLINK Property

LED5_BLNK_CNTL: LED5_TOFF_BLINK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed5BlinkCntlLedToffBlink LED5BLNKCNTLLED5TOFFBLINK { get; set; }
Public Property LED5BLNKCNTLLED5TOFFBLINK As Max8831TypeLed5BlinkCntlLedToffBlink
    Get
    Set
public:
property Max8831TypeLed5BlinkCntlLedToffBlink LED5BLNKCNTLLED5TOFFBLINK {
    Max8831TypeLed5BlinkCntlLedToffBlink get ();
    void set (Max8831TypeLed5BlinkCntlLedToffBlink value);
}
member LED5BLNKCNTLLED5TOFFBLINK : Max8831TypeLed5BlinkCntlLedToffBlink with get, set

Property Value

Type: Max8831TypeLed5BlinkCntlLedToffBlink
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED5BLNKCNTLLED5TONBLINK Property

IRD

Max8831LED5BLNKCNTLLED5TONBLINK Property

LED5_BLNK_CNTL: LED5_TON_BLINK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed5BlinkCntlLedTonBlink LED5BLNKCNTLLED5TONBLINK { get; set; }
Public Property LED5BLNKCNTLLED5TONBLINK As Max8831TypeLed5BlinkCntlLedTonBlink
    Get
    Set
public:
property Max8831TypeLed5BlinkCntlLedTonBlink LED5BLNKCNTLLED5TONBLINK {
    Max8831TypeLed5BlinkCntlLedTonBlink get ();
    void set (Max8831TypeLed5BlinkCntlLedTonBlink value);
}
member LED5BLNKCNTLLED5TONBLINK : Max8831TypeLed5BlinkCntlLedTonBlink with get, set

Property Value

Type: Max8831TypeLed5BlinkCntlLedTonBlink
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED5RAMPCNTLLED5RAMPDOWN Property

IRD

Max8831LED5RAMPCNTLLED5RAMPDOWN Property

LED5_RAMP_CNTL: LED5_RAMP_DOWN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed5RampCntlLedRampDown LED5RAMPCNTLLED5RAMPDOWN { get; set; }
Public Property LED5RAMPCNTLLED5RAMPDOWN As Max8831TypeLed5RampCntlLedRampDown
    Get
    Set
public:
property Max8831TypeLed5RampCntlLedRampDown LED5RAMPCNTLLED5RAMPDOWN {
    Max8831TypeLed5RampCntlLedRampDown get ();
    void set (Max8831TypeLed5RampCntlLedRampDown value);
}
member LED5RAMPCNTLLED5RAMPDOWN : Max8831TypeLed5RampCntlLedRampDown with get, set

Property Value

Type: Max8831TypeLed5RampCntlLedRampDown
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.LED5RAMPCNTLLED5RAMPUP Property

IRD

Max8831LED5RAMPCNTLLED5RAMPUP Property

LED5_RAMP_CNTL: LED5_RAMP_UP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeLed5RampCntlLedRampUp LED5RAMPCNTLLED5RAMPUP { get; set; }
Public Property LED5RAMPCNTLLED5RAMPUP As Max8831TypeLed5RampCntlLedRampUp
    Get
    Set
public:
property Max8831TypeLed5RampCntlLedRampUp LED5RAMPCNTLLED5RAMPUP {
    Max8831TypeLed5RampCntlLedRampUp get ();
    void set (Max8831TypeLed5RampCntlLedRampUp value);
}
member LED5RAMPCNTLLED5RAMPUP : Max8831TypeLed5RampCntlLedRampUp with get, set

Property Value

Type: Max8831TypeLed5RampCntlLedRampUp
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.ONOFFCNTLLED1EN Property

IRD

Max8831ONOFFCNTLLED1EN Property

ON/OFF_CNTL: LED1_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeOnoffCntlLed1Enable ONOFFCNTLLED1EN { get; set; }
Public Property ONOFFCNTLLED1EN As Max8831TypeOnoffCntlLed1Enable
    Get
    Set
public:
property Max8831TypeOnoffCntlLed1Enable ONOFFCNTLLED1EN {
    Max8831TypeOnoffCntlLed1Enable get ();
    void set (Max8831TypeOnoffCntlLed1Enable value);
}
member ONOFFCNTLLED1EN : Max8831TypeOnoffCntlLed1Enable with get, set

Property Value

Type: Max8831TypeOnoffCntlLed1Enable
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.ONOFFCNTLLED2EN Property

IRD

Max8831ONOFFCNTLLED2EN Property

ON/OFF_CNTL: LED2_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeOnoffCntlLed2Enable ONOFFCNTLLED2EN { get; set; }
Public Property ONOFFCNTLLED2EN As Max8831TypeOnoffCntlLed2Enable
    Get
    Set
public:
property Max8831TypeOnoffCntlLed2Enable ONOFFCNTLLED2EN {
    Max8831TypeOnoffCntlLed2Enable get ();
    void set (Max8831TypeOnoffCntlLed2Enable value);
}
member ONOFFCNTLLED2EN : Max8831TypeOnoffCntlLed2Enable with get, set

Property Value

Type: Max8831TypeOnoffCntlLed2Enable
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.ONOFFCNTLLED3EN Property

IRD

Max8831ONOFFCNTLLED3EN Property

ON/OFF_CNTL: LED3_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeOnoffCntlLed3Enable ONOFFCNTLLED3EN { get; set; }
Public Property ONOFFCNTLLED3EN As Max8831TypeOnoffCntlLed3Enable
    Get
    Set
public:
property Max8831TypeOnoffCntlLed3Enable ONOFFCNTLLED3EN {
    Max8831TypeOnoffCntlLed3Enable get ();
    void set (Max8831TypeOnoffCntlLed3Enable value);
}
member ONOFFCNTLLED3EN : Max8831TypeOnoffCntlLed3Enable with get, set

Property Value

Type: Max8831TypeOnoffCntlLed3Enable
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.ONOFFCNTLLED4EN Property

IRD

Max8831ONOFFCNTLLED4EN Property

ON/OFF_CNTL: LED4_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeOnoffCntlLed4Enable ONOFFCNTLLED4EN { get; set; }
Public Property ONOFFCNTLLED4EN As Max8831TypeOnoffCntlLed4Enable
    Get
    Set
public:
property Max8831TypeOnoffCntlLed4Enable ONOFFCNTLLED4EN {
    Max8831TypeOnoffCntlLed4Enable get ();
    void set (Max8831TypeOnoffCntlLed4Enable value);
}
member ONOFFCNTLLED4EN : Max8831TypeOnoffCntlLed4Enable with get, set

Property Value

Type: Max8831TypeOnoffCntlLed4Enable
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.ONOFFCNTLLED5EN Property

IRD

Max8831ONOFFCNTLLED5EN Property

ON/OFF_CNTL: LED5_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeOnoffCntlLed5Enable ONOFFCNTLLED5EN { get; set; }
Public Property ONOFFCNTLLED5EN As Max8831TypeOnoffCntlLed5Enable
    Get
    Set
public:
property Max8831TypeOnoffCntlLed5Enable ONOFFCNTLLED5EN {
    Max8831TypeOnoffCntlLed5Enable get ();
    void set (Max8831TypeOnoffCntlLed5Enable value);
}
member ONOFFCNTLLED5EN : Max8831TypeOnoffCntlLed5Enable with get, set

Property Value

Type: Max8831TypeOnoffCntlLed5Enable
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.STAT1LED1FAULT Property

IRD

Max8831STAT1LED1FAULT Property

STAT1: LED1_FAULT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeStat1Led1Fault STAT1LED1FAULT { get; }
Public ReadOnly Property STAT1LED1FAULT As Max8831TypeStat1Led1Fault
    Get
public:
property Max8831TypeStat1Led1Fault STAT1LED1FAULT {
    Max8831TypeStat1Led1Fault get ();
}
member STAT1LED1FAULT : Max8831TypeStat1Led1Fault with get

Property Value

Type: Max8831TypeStat1Led1Fault
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.STAT1LED2FAULT Property

IRD

Max8831STAT1LED2FAULT Property

STAT1: LED2_FAULT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeStat1Led2Fault STAT1LED2FAULT { get; }
Public ReadOnly Property STAT1LED2FAULT As Max8831TypeStat1Led2Fault
    Get
public:
property Max8831TypeStat1Led2Fault STAT1LED2FAULT {
    Max8831TypeStat1Led2Fault get ();
}
member STAT1LED2FAULT : Max8831TypeStat1Led2Fault with get

Property Value

Type: Max8831TypeStat1Led2Fault
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.STAT1LED3FAULT Property

IRD

Max8831STAT1LED3FAULT Property

STAT1: LED3_FAULT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeStat1Led3Fault STAT1LED3FAULT { get; }
Public ReadOnly Property STAT1LED3FAULT As Max8831TypeStat1Led3Fault
    Get
public:
property Max8831TypeStat1Led3Fault STAT1LED3FAULT {
    Max8831TypeStat1Led3Fault get ();
}
member STAT1LED3FAULT : Max8831TypeStat1Led3Fault with get

Property Value

Type: Max8831TypeStat1Led3Fault
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.STAT1LED4FAULT Property

IRD

Max8831STAT1LED4FAULT Property

STAT1: LED4_FAULT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeStat1Led4Fault STAT1LED4FAULT { get; }
Public ReadOnly Property STAT1LED4FAULT As Max8831TypeStat1Led4Fault
    Get
public:
property Max8831TypeStat1Led4Fault STAT1LED4FAULT {
    Max8831TypeStat1Led4Fault get ();
}
member STAT1LED4FAULT : Max8831TypeStat1Led4Fault with get

Property Value

Type: Max8831TypeStat1Led4Fault
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.STAT1LED5FAULT Property

IRD

Max8831STAT1LED5FAULT Property

STAT1: LED5_FAULT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeStat1Led5Fault STAT1LED5FAULT { get; }
Public ReadOnly Property STAT1LED5FAULT As Max8831TypeStat1Led5Fault
    Get
public:
property Max8831TypeStat1Led5Fault STAT1LED5FAULT {
    Max8831TypeStat1Led5Fault get ();
}
member STAT1LED5FAULT : Max8831TypeStat1Led5Fault with get

Property Value

Type: Max8831TypeStat1Led5Fault
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.STAT2OSDD Property

IRD

Max8831STAT2OSDD Property

STAT2: OSDD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeStat2OpenSchottkyDiodeDetect STAT2OSDD { get; }
Public ReadOnly Property STAT2OSDD As Max8831TypeStat2OpenSchottkyDiodeDetect
    Get
public:
property Max8831TypeStat2OpenSchottkyDiodeDetect STAT2OSDD {
    Max8831TypeStat2OpenSchottkyDiodeDetect get ();
}
member STAT2OSDD : Max8831TypeStat2OpenSchottkyDiodeDetect with get

Property Value

Type: Max8831TypeStat2OpenSchottkyDiodeDetect
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.STAT2OVP Property

IRD

Max8831STAT2OVP Property

STAT2: OVP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeStat2OutputVoltageProtection STAT2OVP { get; }
Public ReadOnly Property STAT2OVP As Max8831TypeStat2OutputVoltageProtection
    Get
public:
property Max8831TypeStat2OutputVoltageProtection STAT2OVP {
    Max8831TypeStat2OutputVoltageProtection get ();
}
member STAT2OVP : Max8831TypeStat2OutputVoltageProtection with get

Property Value

Type: Max8831TypeStat2OutputVoltageProtection
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.STAT2TSD Property

IRD

Max8831STAT2TSD Property

STAT2: TSD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8831TypeStat2ThermalShutdownDetection STAT2TSD { get; }
Public ReadOnly Property STAT2TSD As Max8831TypeStat2ThermalShutdownDetection
    Get
public:
property Max8831TypeStat2ThermalShutdownDetection STAT2TSD {
    Max8831TypeStat2ThermalShutdownDetection get ();
}
member STAT2TSD : Max8831TypeStat2ThermalShutdownDetection with get

Property Value

Type: Max8831TypeStat2ThermalShutdownDetection
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831 Methods

The Max8831 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.Flush Method

IRD

Max8831Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max8831 Class
telos.Ird.Maxim Namespace


Max8831.TypeBoostCntlLed3BoostCntl Enumeration

IRD

Max8831TypeBoostCntlLed3BoostCntl Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBoostCntlLed3BoostCntl
Public Enumeration TypeBoostCntlLed3BoostCntl
public enum class TypeBoostCntlLed3BoostCntl
type TypeBoostCntlLed3BoostCntl
Members
Member name | Value | Description
LED3IsPoweredFromHighVoltageStepUpConverter | 0 | LED 3 Is Powered From High-Voltage Step-Up Converter
LED3IsPoweredFromAlternatePowerSource | 1 | LED 3 Is Powered From Alternate Power Source
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeBoostCntlLed4BoostCntl Enumeration

IRD

Max8831TypeBoostCntlLed4BoostCntl Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBoostCntlLed4BoostCntl
Public Enumeration TypeBoostCntlLed4BoostCntl
public enum class TypeBoostCntlLed4BoostCntl
type TypeBoostCntlLed4BoostCntl
Members
Member name | Value | Description
LED4IsPoweredFromHighVoltageStepUpConverter | 0 | LED 4 Is Powered From High-Voltage Step-Up Converter
LED4IsPoweredFromAlternatePowerSource | 1 | LED 4 Is Powered From Alternate Power Source
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeBoostCntlLed5BoostCntl Enumeration

IRD

Max8831TypeBoostCntlLed5BoostCntl Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBoostCntlLed5BoostCntl
Public Enumeration TypeBoostCntlLed5BoostCntl
public enum class TypeBoostCntlLed5BoostCntl
type TypeBoostCntlLed5BoostCntl
Members
Member name | Value | Description
LED5IsPoweredFromHighVoltageStepUpConverter | 0 | LED 5 Is Powered From High-Voltage Step-Up Converter
LED5IsPoweredFromAlternatePowerSource | 1 | LED 5 Is Powered From Alternate Power Source
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed1RampCntlLedRampDown Enumeration

IRD

Max8831TypeLed1RampCntlLedRampDown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed1RampCntlLedRampDown
Public Enumeration TypeLed1RampCntlLedRampDown
public enum class TypeLed1RampCntlLedRampDown
type TypeLed1RampCntlLedRampDown
Members
Member name | Value | Description
LED1CurrentRampDownRate64Ms | 0 | LED 1 Current Ramp Down Rate: 64 ms
LED1CurrentRampDownRate128Ms | 1 | LED 1 Current Ramp Down Rate: 128 ms
LED1CurrentRampDownRate256Ms | 2 | LED 1 Current Ramp Down Rate: 256 ms
LED1CurrentRampDownRate512Ms | 3 | LED 1 Current Ramp Down Rate: 512 ms
LED1CurrentRampDownRate1024Ms | 4 | LED 1 Current Ramp Down Rate: 1024 ms
LED1CurrentRampDownRate2048Ms | 5 | LED 1 Current Ramp Down Rate: 2048 ms
LED1CurrentRampDownRate4096Ms | 6 | LED 1 Current Ramp Down Rate: 4096 ms
LED1CurrentRampDownRate8192Ms | 7 | LED 1 Current Ramp Down Rate: 8192 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed1RampCntlLedRampUp Enumeration

IRD

Max8831TypeLed1RampCntlLedRampUp Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed1RampCntlLedRampUp
Public Enumeration TypeLed1RampCntlLedRampUp
public enum class TypeLed1RampCntlLedRampUp
type TypeLed1RampCntlLedRampUp
Members
Member name | Value | Description
LED1CurrentRampUpRate64Ms | 0 | LED 1 Current Ramp Up Rate: 64 ms
LED1CurrentRampUpRate128Ms | 1 | LED 1 Current Ramp Up Rate: 128 ms
LED1CurrentRampUpRate256Ms | 2 | LED 1 Current Ramp Up Rate: 256 ms
LED1CurrentRampUpRate512Ms | 3 | LED 1 Current Ramp Up Rate: 512 ms
LED1CurrentRampUpRate1024Ms | 4 | LED 1 Current Ramp Up Rate: 1024 ms
LED1CurrentRampUpRate2048Ms | 5 | LED 1 Current Ramp Up Rate: 2048 ms
LED1CurrentRampUpRate4096Ms | 6 | LED 1 Current Ramp Up Rate: 4096 ms
LED1CurrentRampUpRate8192Ms | 7 | LED 1 Current Ramp Up Rate: 8192 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed2RampCntlLedRampDown Enumeration

IRD

Max8831TypeLed2RampCntlLedRampDown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed2RampCntlLedRampDown
Public Enumeration TypeLed2RampCntlLedRampDown
public enum class TypeLed2RampCntlLedRampDown
type TypeLed2RampCntlLedRampDown
Members
Member name | Value | Description
LED2CurrentRampDownRate64Ms | 0 | LED 2 Current Ramp Down Rate: 64 ms
LED2CurrentRampDownRate128Ms | 1 | LED 2 Current Ramp Down Rate: 128 ms
LED2CurrentRampDownRate256Ms | 2 | LED 2 Current Ramp Down Rate: 256 ms
LED2CurrentRampDownRate512Ms | 3 | LED 2 Current Ramp Down Rate: 512 ms
LED2CurrentRampDownRate1024Ms | 4 | LED 2 Current Ramp Down Rate: 1024 ms
LED2CurrentRampDownRate2048Ms | 5 | LED 2 Current Ramp Down Rate: 2048 ms
LED2CurrentRampDownRate4096Ms | 6 | LED 2 Current Ramp Down Rate: 4096 ms
LED2CurrentRampDownRate8192Ms | 7 | LED 2 Current Ramp Down Rate: 8192 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed2RampCntlLedRampUp Enumeration

IRD

Max8831TypeLed2RampCntlLedRampUp Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed2RampCntlLedRampUp
Public Enumeration TypeLed2RampCntlLedRampUp
public enum class TypeLed2RampCntlLedRampUp
type TypeLed2RampCntlLedRampUp
Members
Member name | Value | Description
LED2CurrentRampUpRate64Ms | 0 | LED 2 Current Ramp Up Rate: 64 ms
LED2CurrentRampUpRate128Ms | 1 | LED 2 Current Ramp Up Rate: 128 ms
LED2CurrentRampUpRate256Ms | 2 | LED 2 Current Ramp Up Rate: 256 ms
LED2CurrentRampUpRate512Ms | 3 | LED 2 Current Ramp Up Rate: 512 ms
LED2CurrentRampUpRate1024Ms | 4 | LED 2 Current Ramp Up Rate: 1024 ms
LED2CurrentRampUpRate2048Ms | 5 | LED 2 Current Ramp Up Rate: 2048 ms
LED2CurrentRampUpRate4096Ms | 6 | LED 2 Current Ramp Up Rate: 4096 ms
LED2CurrentRampUpRate8192Ms | 7 | LED 2 Current Ramp Up Rate: 8192 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed3BlinkCntlLedBlinkEnable Enumeration

IRD

Max8831TypeLed3BlinkCntlLedBlinkEnable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed3BlinkCntlLedBlinkEnable
Public Enumeration TypeLed3BlinkCntlLedBlinkEnable
public enum class TypeLed3BlinkCntlLedBlinkEnable
type TypeLed3BlinkCntlLedBlinkEnable
Members
Member name | Value | Description
LED3BlinkFunctionDisable | 0 | LED 3 Blink Function: Disable
LED3BlinkFunctionEnable | 1 | LED 3 Blink Function: Enable
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed3BlinkCntlLedToffBlink Enumeration

IRD

Max8831TypeLed3BlinkCntlLedToffBlink Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed3BlinkCntlLedToffBlink
Public Enumeration TypeLed3BlinkCntlLedToffBlink
public enum class TypeLed3BlinkCntlLedToffBlink
type TypeLed3BlinkCntlLedToffBlink
Members
Member name | Value | Description
LED3BlinkOffTimerSetTo1024Ms | 0 | LED 3 Blink Off Timer Set To: 1024 ms
LED3BlinkOffTimerSetTo2048Ms | 1 | LED 3 Blink Off Timer Set To: 2048 ms
LED3BlinkOffTimerSetTo4096Ms | 2 | LED 3 Blink Off Timer Set To: 4096 ms
LED3BlinkOffTimerSetTo8192Ms | 3 | LED 3 Blink Off Timer Set To: 8192 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed3BlinkCntlLedTonBlink Enumeration

IRD

Max8831TypeLed3BlinkCntlLedTonBlink Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed3BlinkCntlLedTonBlink
Public Enumeration TypeLed3BlinkCntlLedTonBlink
public enum class TypeLed3BlinkCntlLedTonBlink
type TypeLed3BlinkCntlLedTonBlink
Members
Member name | Value | Description
LED3BlinkOnTimerSetTo256Ms | 0 | LED 3 BlinkOn Timer Set To: 256 ms
LED3BlinkOnTimerSetTo512Ms | 1 | LED 3 BlinkOn Timer Set To: 512 ms
LED3BlinkOnTimerSetTo1024Ms | 2 | LED 3 BlinkOn Timer Set To: 1024 ms
LED3BlinkOnTimerSetTo2048Ms | 3 | LED 3 BlinkOn Timer Set To: 2048 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed3RampCntlLedRampDown Enumeration

IRD

Max8831TypeLed3RampCntlLedRampDown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed3RampCntlLedRampDown
Public Enumeration TypeLed3RampCntlLedRampDown
public enum class TypeLed3RampCntlLedRampDown
type TypeLed3RampCntlLedRampDown
Members
Member name | Value | Description
LED3CurrentRampDownRate64Ms | 0 | LED 3 Current Ramp Down Rate: 64 ms
LED3CurrentRampDownRate128Ms | 1 | LED 3 Current Ramp Down Rate: 128 ms
LED3CurrentRampDownRate256Ms | 2 | LED 3 Current Ramp Down Rate: 256 ms
LED3CurrentRampDownRate512Ms | 3 | LED 3 Current Ramp Down Rate: 512 ms
LED3CurrentRampDownRate1024Ms | 4 | LED 3 Current Ramp Down Rate: 1024 ms
LED3CurrentRampDownRate2048Ms | 5 | LED 3 Current Ramp Down Rate: 2048 ms
LED3CurrentRampDownRate4096Ms | 6 | LED 3 Current Ramp Down Rate: 4096 ms
LED3CurrentRampDownRate8192Ms | 7 | LED 3 Current Ramp Down Rate: 8192 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed3RampCntlLedRampUp Enumeration

IRD

Max8831TypeLed3RampCntlLedRampUp Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed3RampCntlLedRampUp
Public Enumeration TypeLed3RampCntlLedRampUp
public enum class TypeLed3RampCntlLedRampUp
type TypeLed3RampCntlLedRampUp
Members
Member name | Value | Description
LED3CurrentRampUpRate64Ms | 0 | LED 3 Current Ramp Up Rate: 64 ms
LED3CurrentRampUpRate128Ms | 1 | LED 3 Current Ramp Up Rate: 128 ms
LED3CurrentRampUpRate256Ms | 2 | LED 3 Current Ramp Up Rate: 256 ms
LED3CurrentRampUpRate512Ms | 3 | LED 3 Current Ramp Up Rate: 512 ms
LED3CurrentRampUpRate1024Ms | 4 | LED 3 Current Ramp Up Rate: 1024 ms
LED3CurrentRampUpRate2048Ms | 5 | LED 3 Current Ramp Up Rate: 2048 ms
LED3CurrentRampUpRate4096Ms | 6 | LED 3 Current Ramp Up Rate: 4096 ms
LED3CurrentRampUpRate8192Ms | 7 | LED 3 Current Ramp Up Rate: 8192 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed4BlinkCntlLedBlinkEnable Enumeration

IRD

Max8831TypeLed4BlinkCntlLedBlinkEnable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed4BlinkCntlLedBlinkEnable
Public Enumeration TypeLed4BlinkCntlLedBlinkEnable
public enum class TypeLed4BlinkCntlLedBlinkEnable
type TypeLed4BlinkCntlLedBlinkEnable
Members
Member name | Value | Description
LED4BlinkFunctionDisable | 0 | LED 4 Blink Function: Disable
LED4BlinkFunctionEnable | 1 | LED 4 Blink Function: Enable
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed4BlinkCntlLedToffBlink Enumeration

IRD

Max8831TypeLed4BlinkCntlLedToffBlink Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed4BlinkCntlLedToffBlink
Public Enumeration TypeLed4BlinkCntlLedToffBlink
public enum class TypeLed4BlinkCntlLedToffBlink
type TypeLed4BlinkCntlLedToffBlink
Members
Member name | Value | Description
LED4BlinkOffTimerSetTo1024Ms | 0 | LED 4 Blink Off Timer Set To: 1024 ms
LED4BlinkOffTimerSetTo2048Ms | 1 | LED 4 Blink Off Timer Set To: 2048 ms
LED4BlinkOffTimerSetTo4096Ms | 2 | LED 4 Blink Off Timer Set To: 4096 ms
LED4BlinkOffTimerSetTo8192Ms | 3 | LED 4 Blink Off Timer Set To: 8192 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed4BlinkCntlLedTonBlink Enumeration

IRD

Max8831TypeLed4BlinkCntlLedTonBlink Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed4BlinkCntlLedTonBlink
Public Enumeration TypeLed4BlinkCntlLedTonBlink
public enum class TypeLed4BlinkCntlLedTonBlink
type TypeLed4BlinkCntlLedTonBlink
Members
Member name | Value | Description
LED4BlinkOnTimerSetTo256Ms | 0 | LED 4 BlinkOn Timer Set To: 256 ms
LED4BlinkOnTimerSetTo512Ms | 1 | LED 4 BlinkOn Timer Set To: 512 ms
LED4BlinkOnTimerSetTo1024Ms | 2 | LED 4 BlinkOn Timer Set To: 1024 ms
LED4BlinkOnTimerSetTo2048Ms | 3 | LED 4 BlinkOn Timer Set To: 2048 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed4RampCntlLedRampDown Enumeration

IRD

Max8831TypeLed4RampCntlLedRampDown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed4RampCntlLedRampDown
Public Enumeration TypeLed4RampCntlLedRampDown
public enum class TypeLed4RampCntlLedRampDown
type TypeLed4RampCntlLedRampDown
Members
Member name | Value | Description
LED4CurrentRampDownRate64Ms | 0 | LED 4 Current Ramp Down Rate: 64 ms
LED4CurrentRampDownRate128Ms | 1 | LED 4 Current Ramp Down Rate: 128 ms
LED4CurrentRampDownRate256Ms | 2 | LED 4 Current Ramp Down Rate: 256 ms
LED4CurrentRampDownRate512Ms | 3 | LED 4 Current Ramp Down Rate: 512 ms
LED4CurrentRampDownRate1024Ms | 4 | LED 4 Current Ramp Down Rate: 1024 ms
LED4CurrentRampDownRate2048Ms | 5 | LED 4 Current Ramp Down Rate: 2048 ms
LED4CurrentRampDownRate4096Ms | 6 | LED 4 Current Ramp Down Rate: 4096 ms
LED4CurrentRampDownRate8192Ms | 7 | LED 4 Current Ramp Down Rate: 8192 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed4RampCntlLedRampUp Enumeration

IRD

Max8831TypeLed4RampCntlLedRampUp Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed4RampCntlLedRampUp
Public Enumeration TypeLed4RampCntlLedRampUp
public enum class TypeLed4RampCntlLedRampUp
type TypeLed4RampCntlLedRampUp
Members
Member name | Value | Description
LED4CurrentRampUpRate64Ms | 0 | LED 4 Current Ramp Up Rate: 64 ms
LED4CurrentRampUpRate128Ms | 1 | LED 4 Current Ramp Up Rate: 128 ms
LED4CurrentRampUpRate256Ms | 2 | LED 4 Current Ramp Up Rate: 256 ms
LED4CurrentRampUpRate512Ms | 3 | LED 4 Current Ramp Up Rate: 512 ms
LED4CurrentRampUpRate1024Ms | 4 | LED 4 Current Ramp Up Rate: 1024 ms
LED4CurrentRampUpRate2048Ms | 5 | LED 4 Current Ramp Up Rate: 2048 ms
LED4CurrentRampUpRate4096Ms | 6 | LED 4 Current Ramp Up Rate: 4096 ms
LED4CurrentRampUpRate8192Ms | 7 | LED 4 Current Ramp Up Rate: 8192 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed5BlinkCntlLedBlinkEnable Enumeration

IRD

Max8831TypeLed5BlinkCntlLedBlinkEnable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed5BlinkCntlLedBlinkEnable
Public Enumeration TypeLed5BlinkCntlLedBlinkEnable
public enum class TypeLed5BlinkCntlLedBlinkEnable
type TypeLed5BlinkCntlLedBlinkEnable
Members
Member name | Value | Description
LED5BlinkFunctionDisable | 0 | LED 5 Blink Function: Disable
LED5BlinkFunctionEnable | 1 | LED 5 Blink Function: Enable
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed5BlinkCntlLedToffBlink Enumeration

IRD

Max8831TypeLed5BlinkCntlLedToffBlink Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed5BlinkCntlLedToffBlink
Public Enumeration TypeLed5BlinkCntlLedToffBlink
public enum class TypeLed5BlinkCntlLedToffBlink
type TypeLed5BlinkCntlLedToffBlink
Members
Member name | Value | Description
LED5BlinkOffTimerSetTo1024Ms | 0 | LED 5 Blink Off Timer Set To: 1024 ms
LED5BlinkOffTimerSetTo2048Ms | 1 | LED 5 Blink Off Timer Set To: 2048 ms
LED5BlinkOffTimerSetTo4096Ms | 2 | LED 5 Blink Off Timer Set To: 4096 ms
LED5BlinkOffTimerSetTo8192Ms | 3 | LED 5 Blink Off Timer Set To: 8192 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed5BlinkCntlLedTonBlink Enumeration

IRD

Max8831TypeLed5BlinkCntlLedTonBlink Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed5BlinkCntlLedTonBlink
Public Enumeration TypeLed5BlinkCntlLedTonBlink
public enum class TypeLed5BlinkCntlLedTonBlink
type TypeLed5BlinkCntlLedTonBlink
Members
Member name | Value | Description
LED5BlinkOnTimerSetTo256Ms | 0 | LED 5 BlinkOn Timer Set To: 256 ms
LED5BlinkOnTimerSetTo512Ms | 1 | LED 5 BlinkOn Timer Set To: 512 ms
LED5BlinkOnTimerSetTo1024Ms | 2 | LED 5 BlinkOn Timer Set To: 1024 ms
LED5BlinkOnTimerSetTo2048Ms | 3 | LED 5 BlinkOn Timer Set To: 2048 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed5RampCntlLedRampDown Enumeration

IRD

Max8831TypeLed5RampCntlLedRampDown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed5RampCntlLedRampDown
Public Enumeration TypeLed5RampCntlLedRampDown
public enum class TypeLed5RampCntlLedRampDown
type TypeLed5RampCntlLedRampDown
Members
Member name | Value | Description
LED5CurrentRampDownRate64Ms | 0 | LED 5 Current Ramp Down Rate: 64 ms
LED5CurrentRampDownRate128Ms | 1 | LED 5 Current Ramp Down Rate: 128 ms
LED5CurrentRampDownRate256Ms | 2 | LED 5 Current Ramp Down Rate: 256 ms
LED5CurrentRampDownRate512Ms | 3 | LED 5 Current Ramp Down Rate: 512 ms
LED5CurrentRampDownRate1024Ms | 4 | LED 5 Current Ramp Down Rate: 1024 ms
LED5CurrentRampDownRate2048Ms | 5 | LED 5 Current Ramp Down Rate: 2048 ms
LED5CurrentRampDownRate4096Ms | 6 | LED 5 Current Ramp Down Rate: 4096 ms
LED5CurrentRampDownRate8192Ms | 7 | LED 5 Current Ramp Down Rate: 8192 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeLed5RampCntlLedRampUp Enumeration

IRD

Max8831TypeLed5RampCntlLedRampUp Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLed5RampCntlLedRampUp
Public Enumeration TypeLed5RampCntlLedRampUp
public enum class TypeLed5RampCntlLedRampUp
type TypeLed5RampCntlLedRampUp
Members
Member name | Value | Description
LED5CurrentRampUpRate64Ms | 0 | LED 5 Current Ramp Up Rate: 64 ms
LED5CurrentRampUpRate128Ms | 1 | LED 5 Current Ramp Up Rate: 128 ms
LED5CurrentRampUpRate256Ms | 2 | LED 5 Current Ramp Up Rate: 256 ms
LED5CurrentRampUpRate512Ms | 3 | LED 5 Current Ramp Up Rate: 512 ms
LED5CurrentRampUpRate1024Ms | 4 | LED 5 Current Ramp Up Rate: 1024 ms
LED5CurrentRampUpRate2048Ms | 5 | LED 5 Current Ramp Up Rate: 2048 ms
LED5CurrentRampUpRate4096Ms | 6 | LED 5 Current Ramp Up Rate: 4096 ms
LED5CurrentRampUpRate8192Ms | 7 | LED 5 Current Ramp Up Rate: 8192 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeOnoffCntlLed1Enable Enumeration

IRD

Max8831TypeOnoffCntlLed1Enable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnoffCntlLed1Enable
Public Enumeration TypeOnoffCntlLed1Enable
public enum class TypeOnoffCntlLed1Enable
type TypeOnoffCntlLed1Enable
Members
Member name | Value | Description
DisableLED1CurrentRegulator | 0 | Disable LED1 Current Regulator
EnableLED1CurrentRegulator | 1 | Enable LED1 Current Regulator
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeOnoffCntlLed2Enable Enumeration

IRD

Max8831TypeOnoffCntlLed2Enable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnoffCntlLed2Enable
Public Enumeration TypeOnoffCntlLed2Enable
public enum class TypeOnoffCntlLed2Enable
type TypeOnoffCntlLed2Enable
Members
Member name | Value | Description
DisableLED2CurrentRegulator | 0 | Disable LED2 Current Regulator
EnableLED2CurrentRegulator | 1 | Enable LED2 Current Regulator
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeOnoffCntlLed3Enable Enumeration

IRD

Max8831TypeOnoffCntlLed3Enable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnoffCntlLed3Enable
Public Enumeration TypeOnoffCntlLed3Enable
public enum class TypeOnoffCntlLed3Enable
type TypeOnoffCntlLed3Enable
Members
Member name | Value | Description
DisableLED3CurrentRegulator | 0 | Disable LED3 Current Regulator
EnableLED3CurrentRegulator | 1 | Enable LED3 Current Regulator
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeOnoffCntlLed4Enable Enumeration

IRD

Max8831TypeOnoffCntlLed4Enable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnoffCntlLed4Enable
Public Enumeration TypeOnoffCntlLed4Enable
public enum class TypeOnoffCntlLed4Enable
type TypeOnoffCntlLed4Enable
Members
Member name | Value | Description
DisableLED4CurrentRegulator | 0 | Disable LED4 Current Regulator
EnableLED4CurrentRegulator | 1 | Enable LED4 Current Regulator
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeOnoffCntlLed5Enable Enumeration

IRD

Max8831TypeOnoffCntlLed5Enable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnoffCntlLed5Enable
Public Enumeration TypeOnoffCntlLed5Enable
public enum class TypeOnoffCntlLed5Enable
type TypeOnoffCntlLed5Enable
Members
Member name | Value | Description
DisableLED5CurrentRegulator | 0 | Disable LED5 Current Regulator
EnableLED5CurrentRegulator | 1 | Enable LED5 Current Regulator
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeStat1Led1Fault Enumeration

IRD

Max8831TypeStat1Led1Fault Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStat1Led1Fault
Public Enumeration TypeStat1Led1Fault
public enum class TypeStat1Led1Fault
type TypeStat1Led1Fault
Members
Member name | Value | Description
LED1OpenOrShortNotDetected | 0 | LED1 - Open Or Short: Not Detected
LED1OpenOrShortDetected | 1 | LED1 - Open Or Short: Detected
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeStat1Led2Fault Enumeration

IRD

Max8831TypeStat1Led2Fault Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStat1Led2Fault
Public Enumeration TypeStat1Led2Fault
public enum class TypeStat1Led2Fault
type TypeStat1Led2Fault
Members
Member name | Value | Description
LED2OpenOrShortNotDetected | 0 | LED2 - Open Or Short: Not Detected
LED2OpenOrShortDetected | 1 | LED2 - Open Or Short: Detected
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeStat1Led3Fault Enumeration

IRD

Max8831TypeStat1Led3Fault Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStat1Led3Fault
Public Enumeration TypeStat1Led3Fault
public enum class TypeStat1Led3Fault
type TypeStat1Led3Fault
Members
Member name | Value | Description
LED3OpenOrShortNotDetected | 0 | LED3 - Open Or Short: Not Detected
LED3OpenOrShortDetected | 1 | LED3 - Open Or Short: Detected
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeStat1Led4Fault Enumeration

IRD

Max8831TypeStat1Led4Fault Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStat1Led4Fault
Public Enumeration TypeStat1Led4Fault
public enum class TypeStat1Led4Fault
type TypeStat1Led4Fault
Members
Member name | Value | Description
LED4OpenOrShortNotDetected | 0 | LED4 - Open Or Short: Not Detected
LED4OpenOrShortDetected | 1 | LED4 - Open Or Short: Detected
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeStat1Led5Fault Enumeration

IRD

Max8831TypeStat1Led5Fault Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStat1Led5Fault
Public Enumeration TypeStat1Led5Fault
public enum class TypeStat1Led5Fault
type TypeStat1Led5Fault
Members
Member name | Value | Description
LED5OpenOrShortNotDetected | 0 | LED5 - Open Or Short: Not Detected
LED5OpenOrShortDetected | 1 | LED5 - Open Or Short: Detected
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeStat2OpenSchottkyDiodeDetect Enumeration

IRD

Max8831TypeStat2OpenSchottkyDiodeDetect Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStat2OpenSchottkyDiodeDetect
Public Enumeration TypeStat2OpenSchottkyDiodeDetect
public enum class TypeStat2OpenSchottkyDiodeDetect
type TypeStat2OpenSchottkyDiodeDetect
Members
Member name | Value | Description
SchottkyDiodeIsPresent | 0 | Schottky Diode Is: Present
SchottkyDiodeIsMissing | 1 | Schottky Diode Is: Missing
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeStat2OutputVoltageProtection Enumeration

IRD

Max8831TypeStat2OutputVoltageProtection Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStat2OutputVoltageProtection
Public Enumeration TypeStat2OutputVoltageProtection
public enum class TypeStat2OutputVoltageProtection
type TypeStat2OutputVoltageProtection
Members
Member name | Value | Description
NoOvervoltageProtectionOccurred | 0 | No Overvoltage Protection Occurred
DeviceEnteredOvervoltageProtection | 1 | Device Entered Overvoltage Protection
See Also

Reference

telos.Ird.Maxim Namespace


Max8831.TypeStat2ThermalShutdownDetection Enumeration

IRD

Max8831TypeStat2ThermalShutdownDetection Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStat2ThermalShutdownDetection
Public Enumeration TypeStat2ThermalShutdownDetection
public enum class TypeStat2ThermalShutdownDetection
type TypeStat2ThermalShutdownDetection
Members
Member name | Value | Description
NoThermalShutdownOccurred | 0 | No Thermal Shutdown Occurred
DeviceEnteredThermalShutdown | 1 | Device Entered Thermal Shutdown
See Also

Reference

telos.Ird.Maxim Namespace


Max8834 Class

Maxim: MAX 8834Y / MAX 8834Z
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax8834

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max8834
Public Class Max8834
public ref class Max8834
type Max8834 =  class end

The Max8834 type exposes the following members.

Constructors
 | Name | Description
Public method | Max8834 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BoostControlBOOSTCNTL | Boost Control: BOOST_CNTL (unit: V)
Public property | BoostControlBOOSTEN | Boost Control: BOOST_EN
Public property | BoostControlBOOSTMODE | Boost Control: BOOST_MODE
Public property | ChipID1DIETYPE | Chip ID1: DIE_TYPE
Public property | ChipID2DASH | Chip ID2: DASH
Public property | ChipID2MASKREV | Chip ID2: MASK_REV
Public property | Flash1CurrentFLASH1 | Flash1 Current: FLASH1 (unit: mA)
Public property | Flash2CurrentFLASH2 | Flash2 Current: FLASH2 (unit: mA)
Public property | GSMBCurrentGSMBEN | GSMB Current: GSMB_EN
Public property | GSMBCurrentGSMBPOL | GSMB Current: GSMB_POL
Public property | GSMBCurrentHCTMR | GSMB Current: HC_TMR (unit: µs)
Public property | GSMBCurrentILIM | GSMB Current: ILIM (unit: mA)
Public property | IndicatorControlINDOFF | Indicator Control: IND_OFF (unit: ms)
Public property | IndicatorControlINDON | Indicator Control: IND_ON (unit: ms)
Public property | IndicatorControlINDRD | Indicator Control: IND_RD (unit: ms)
Public property | IndicatorControlINDRU | Indicator Control: IND_RU (unit: ms)
Public property | IndicatorCurrentIND | Indicator Current: IND (unit: mA)
Public property | IndicatorCurrentINDBLEN | Indicator Current: IND_BL_EN
Public property | IndicatorCurrentINDRPEN | Indicator Current: IND_RP_EN
Public property | LEDControlFLASHEN | LED Control: FLASH_EN
Public property | LEDControlINDEN | LED Control: IND_EN
Public property | LEDControlMOVIEEN | LED Control: MOVIE_EN
Public property | Maxflash1LBEN | Maxflash1: LB_EN
Public property | Maxflash1LBHYS | Maxflash1: LB_HYS
Public property | Maxflash1LBTH | Maxflash1: LB_TH (unit: V)
Public property | Maxflash2LBTMR | Maxflash2: LB_TMR (unit: ms)
Public property | MovieCurrentMOVIE1 | Movie Current: MOVIE1 (unit: mA)
Public property | MovieCurrentMOVIE2 | Movie Current: MOVIE2 (unit: mA)
Public property | NTCControlFLASHTMRCNTL | NTC Control: FLASH_TMR_CNTL
Public property | NTCControlNTC | NTC Control: NTC (unit: mV)
Public property | NTCControlNTCEN | NTC Control: NTC_EN
Public property | Status1FLED1FLT | Status1: FLED1_FLT
Public property | Status1FLED2FLT | Status1: FLED2_FLT
Public property | Status1GSMB | Status1: GSMB
Public property | Status1INDLEDFLT | Status1: INDLED_FLT
Public property | Status1NTCFLT | Status1: NTC_FLT
Public property | Status1NTCOVT | Status1: NTC_OVT
Public property | Status1OVERTEMP | Status1: OVER_TEMP
Public property | Status1POKFLT | Status1: POK_FLT
Public property | Status2GSMBILIM | Status2: GSMB_ILIM
Public property | Status2MAXFLASHSTAT | Status2: MAXFLASH_STAT
Public property | TimerControlTMRDUR | Timer Control: TMR_DUR (unit: ms)
Public property | TimerControlTMRMODE | Timer Control: TMR_MODE
Public property | TimerControlWDTDUR | Timer Control: WDT_DUR (unit: s)
Public property | TimerControlWDTEN | Timer Control: WDT_EN
Public property | WatchdogResetWDTRST | Watchdog Reset: WDT_RST
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Adaptive Step-Up Converter
See Also

Reference

telos.Ird.Maxim Namespace


Max8834 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max8834(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max8834

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834 Properties

The Max8834 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BoostControlBOOSTCNTL | Boost Control: BOOST_CNTL (unit: V)
Public property | BoostControlBOOSTEN | Boost Control: BOOST_EN
Public property | BoostControlBOOSTMODE | Boost Control: BOOST_MODE
Public property | ChipID1DIETYPE | Chip ID1: DIE_TYPE
Public property | ChipID2DASH | Chip ID2: DASH
Public property | ChipID2MASKREV | Chip ID2: MASK_REV
Public property | Flash1CurrentFLASH1 | Flash1 Current: FLASH1 (unit: mA)
Public property | Flash2CurrentFLASH2 | Flash2 Current: FLASH2 (unit: mA)
Public property | GSMBCurrentGSMBEN | GSMB Current: GSMB_EN
Public property | GSMBCurrentGSMBPOL | GSMB Current: GSMB_POL
Public property | GSMBCurrentHCTMR | GSMB Current: HC_TMR (unit: µs)
Public property | GSMBCurrentILIM | GSMB Current: ILIM (unit: mA)
Public property | IndicatorControlINDOFF | Indicator Control: IND_OFF (unit: ms)
Public property | IndicatorControlINDON | Indicator Control: IND_ON (unit: ms)
Public property | IndicatorControlINDRD | Indicator Control: IND_RD (unit: ms)
Public property | IndicatorControlINDRU | Indicator Control: IND_RU (unit: ms)
Public property | IndicatorCurrentIND | Indicator Current: IND (unit: mA)
Public property | IndicatorCurrentINDBLEN | Indicator Current: IND_BL_EN
Public property | IndicatorCurrentINDRPEN | Indicator Current: IND_RP_EN
Public property | LEDControlFLASHEN | LED Control: FLASH_EN
Public property | LEDControlINDEN | LED Control: IND_EN
Public property | LEDControlMOVIEEN | LED Control: MOVIE_EN
Public property | Maxflash1LBEN | Maxflash1: LB_EN
Public property | Maxflash1LBHYS | Maxflash1: LB_HYS
Public property | Maxflash1LBTH | Maxflash1: LB_TH (unit: V)
Public property | Maxflash2LBTMR | Maxflash2: LB_TMR (unit: ms)
Public property | MovieCurrentMOVIE1 | Movie Current: MOVIE1 (unit: mA)
Public property | MovieCurrentMOVIE2 | Movie Current: MOVIE2 (unit: mA)
Public property | NTCControlFLASHTMRCNTL | NTC Control: FLASH_TMR_CNTL
Public property | NTCControlNTC | NTC Control: NTC (unit: mV)
Public property | NTCControlNTCEN | NTC Control: NTC_EN
Public property | Status1FLED1FLT | Status1: FLED1_FLT
Public property | Status1FLED2FLT | Status1: FLED2_FLT
Public property | Status1GSMB | Status1: GSMB
Public property | Status1INDLEDFLT | Status1: INDLED_FLT
Public property | Status1NTCFLT | Status1: NTC_FLT
Public property | Status1NTCOVT | Status1: NTC_OVT
Public property | Status1OVERTEMP | Status1: OVER_TEMP
Public property | Status1POKFLT | Status1: POK_FLT
Public property | Status2GSMBILIM | Status2: GSMB_ILIM
Public property | Status2MAXFLASHSTAT | Status2: MAXFLASH_STAT
Public property | TimerControlTMRDUR | Timer Control: TMR_DUR (unit: ms)
Public property | TimerControlTMRMODE | Timer Control: TMR_MODE
Public property | TimerControlWDTDUR | Timer Control: WDT_DUR (unit: s)
Public property | TimerControlWDTEN | Timer Control: WDT_EN
Public property | WatchdogResetWDTRST | Watchdog Reset: WDT_RST
Top
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.AutoFlush Property

IRD

Max8834AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.BoostControlBOOSTCNTL Property

IRD

Max8834BoostControlBOOSTCNTL Property

Boost Control: BOOST_CNTL (unit: V)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double BoostControlBOOSTCNTL { get; set; }
Public Property BoostControlBOOSTCNTL As Double
    Get
    Set
public:
property double BoostControlBOOSTCNTL {
    double get ();
    void set (double value);
}
member BoostControlBOOSTCNTL : float with get, set

Property Value

Type: Double
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.BoostControlBOOSTEN Property

IRD

Max8834BoostControlBOOSTEN Property

Boost Control: BOOST_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeBoostControlBoostEnable BoostControlBOOSTEN { get; set; }
Public Property BoostControlBOOSTEN As Max8834TypeBoostControlBoostEnable
    Get
    Set
public:
property Max8834TypeBoostControlBoostEnable BoostControlBOOSTEN {
    Max8834TypeBoostControlBoostEnable get ();
    void set (Max8834TypeBoostControlBoostEnable value);
}
member BoostControlBOOSTEN : Max8834TypeBoostControlBoostEnable with get, set

Property Value

Type: Max8834TypeBoostControlBoostEnable
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.BoostControlBOOSTMODE Property

IRD

Max8834BoostControlBOOSTMODE Property

Boost Control: BOOST_MODE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeBoostControlBoostMode BoostControlBOOSTMODE { get; set; }
Public Property BoostControlBOOSTMODE As Max8834TypeBoostControlBoostMode
    Get
    Set
public:
property Max8834TypeBoostControlBoostMode BoostControlBOOSTMODE {
    Max8834TypeBoostControlBoostMode get ();
    void set (Max8834TypeBoostControlBoostMode value);
}
member BoostControlBOOSTMODE : Max8834TypeBoostControlBoostMode with get, set

Property Value

Type: Max8834TypeBoostControlBoostMode
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.ChipID1DIETYPE Property

IRD

Max8834ChipID1DIETYPE Property

Chip ID1: DIE_TYPE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ChipID1DIETYPE { get; }
Public ReadOnly Property ChipID1DIETYPE As Byte
    Get
public:
property unsigned char ChipID1DIETYPE {
    unsigned char get ();
}
member ChipID1DIETYPE : byte with get

Property Value

Type: Byte
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.ChipID2DASH Property

IRD

Max8834ChipID2DASH Property

Chip ID2: DASH

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ChipID2DASH { get; }
Public ReadOnly Property ChipID2DASH As Byte
    Get
public:
property unsigned char ChipID2DASH {
    unsigned char get ();
}
member ChipID2DASH : byte with get

Property Value

Type: Byte
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.ChipID2MASKREV Property

IRD

Max8834ChipID2MASKREV Property

Chip ID2: MASK_REV

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ChipID2MASKREV { get; }
Public ReadOnly Property ChipID2MASKREV As Byte
    Get
public:
property unsigned char ChipID2MASKREV {
    unsigned char get ();
}
member ChipID2MASKREV : byte with get

Property Value

Type: Byte
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.Flash1CurrentFLASH1 Property

IRD

Max8834Flash1CurrentFLASH1 Property

Flash1 Current: FLASH1 (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeFlash12Current Flash1CurrentFLASH1 { get; set; }
Public Property Flash1CurrentFLASH1 As Max8834TypeFlash12Current
    Get
    Set
public:
property Max8834TypeFlash12Current Flash1CurrentFLASH1 {
    Max8834TypeFlash12Current get ();
    void set (Max8834TypeFlash12Current value);
}
member Flash1CurrentFLASH1 : Max8834TypeFlash12Current with get, set

Property Value

Type: Max8834TypeFlash12Current
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.Flash2CurrentFLASH2 Property

IRD

Max8834Flash2CurrentFLASH2 Property

Flash2 Current: FLASH2 (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeFlash12Current Flash2CurrentFLASH2 { get; set; }
Public Property Flash2CurrentFLASH2 As Max8834TypeFlash12Current
    Get
    Set
public:
property Max8834TypeFlash12Current Flash2CurrentFLASH2 {
    Max8834TypeFlash12Current get ();
    void set (Max8834TypeFlash12Current value);
}
member Flash2CurrentFLASH2 : Max8834TypeFlash12Current with get, set

Property Value

Type: Max8834TypeFlash12Current
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.GSMBCurrentGSMBEN Property

IRD

Max8834GSMBCurrentGSMBEN Property

GSMB Current: GSMB_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeGsmbCurrentGsmBlank GSMBCurrentGSMBEN { get; set; }
Public Property GSMBCurrentGSMBEN As Max8834TypeGsmbCurrentGsmBlank
    Get
    Set
public:
property Max8834TypeGsmbCurrentGsmBlank GSMBCurrentGSMBEN {
    Max8834TypeGsmbCurrentGsmBlank get ();
    void set (Max8834TypeGsmbCurrentGsmBlank value);
}
member GSMBCurrentGSMBEN : Max8834TypeGsmbCurrentGsmBlank with get, set

Property Value

Type: Max8834TypeGsmbCurrentGsmBlank
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.GSMBCurrentGSMBPOL Property

IRD

Max8834GSMBCurrentGSMBPOL Property

GSMB Current: GSMB_POL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeGsmbCurrentGsmPolarity GSMBCurrentGSMBPOL { get; set; }
Public Property GSMBCurrentGSMBPOL As Max8834TypeGsmbCurrentGsmPolarity
    Get
    Set
public:
property Max8834TypeGsmbCurrentGsmPolarity GSMBCurrentGSMBPOL {
    Max8834TypeGsmbCurrentGsmPolarity get ();
    void set (Max8834TypeGsmbCurrentGsmPolarity value);
}
member GSMBCurrentGSMBPOL : Max8834TypeGsmbCurrentGsmPolarity with get, set

Property Value

Type: Max8834TypeGsmbCurrentGsmPolarity
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.GSMBCurrentHCTMR Property

IRD

Max8834GSMBCurrentHCTMR Property

GSMB Current: HC_TMR (unit: µs)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeGsmbCurrentGsmResetTimer GSMBCurrentHCTMR { get; set; }
Public Property GSMBCurrentHCTMR As Max8834TypeGsmbCurrentGsmResetTimer
    Get
    Set
public:
property Max8834TypeGsmbCurrentGsmResetTimer GSMBCurrentHCTMR {
    Max8834TypeGsmbCurrentGsmResetTimer get ();
    void set (Max8834TypeGsmbCurrentGsmResetTimer value);
}
member GSMBCurrentHCTMR : Max8834TypeGsmbCurrentGsmResetTimer with get, set

Property Value

Type: Max8834TypeGsmbCurrentGsmResetTimer
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.GSMBCurrentILIM Property

IRD

Max8834GSMBCurrentILIM Property

GSMB Current: ILIM (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double GSMBCurrentILIM { get; set; }
Public Property GSMBCurrentILIM As Double
    Get
    Set
public:
property double GSMBCurrentILIM {
    double get ();
    void set (double value);
}
member GSMBCurrentILIM : float with get, set

Property Value

Type: Double
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.IndicatorControlINDOFF Property

IRD

Max8834IndicatorControlINDOFF Property

Indicator Control: IND_OFF (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeIndicatorControlOffBlinkTimer IndicatorControlINDOFF { get; set; }
Public Property IndicatorControlINDOFF As Max8834TypeIndicatorControlOffBlinkTimer
    Get
    Set
public:
property Max8834TypeIndicatorControlOffBlinkTimer IndicatorControlINDOFF {
    Max8834TypeIndicatorControlOffBlinkTimer get ();
    void set (Max8834TypeIndicatorControlOffBlinkTimer value);
}
member IndicatorControlINDOFF : Max8834TypeIndicatorControlOffBlinkTimer with get, set

Property Value

Type: Max8834TypeIndicatorControlOffBlinkTimer
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.IndicatorControlINDON Property

IRD

Max8834IndicatorControlINDON Property

Indicator Control: IND_ON (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeIndicatorControlOnBlinkTimer IndicatorControlINDON { get; set; }
Public Property IndicatorControlINDON As Max8834TypeIndicatorControlOnBlinkTimer
    Get
    Set
public:
property Max8834TypeIndicatorControlOnBlinkTimer IndicatorControlINDON {
    Max8834TypeIndicatorControlOnBlinkTimer get ();
    void set (Max8834TypeIndicatorControlOnBlinkTimer value);
}
member IndicatorControlINDON : Max8834TypeIndicatorControlOnBlinkTimer with get, set

Property Value

Type: Max8834TypeIndicatorControlOnBlinkTimer
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.IndicatorControlINDRD Property

IRD

Max8834IndicatorControlINDRD Property

Indicator Control: IND_RD (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeIndicatorControlRampDownTimer IndicatorControlINDRD { get; set; }
Public Property IndicatorControlINDRD As Max8834TypeIndicatorControlRampDownTimer
    Get
    Set
public:
property Max8834TypeIndicatorControlRampDownTimer IndicatorControlINDRD {
    Max8834TypeIndicatorControlRampDownTimer get ();
    void set (Max8834TypeIndicatorControlRampDownTimer value);
}
member IndicatorControlINDRD : Max8834TypeIndicatorControlRampDownTimer with get, set

Property Value

Type: Max8834TypeIndicatorControlRampDownTimer
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.IndicatorControlINDRU Property

IRD

Max8834IndicatorControlINDRU Property

Indicator Control: IND_RU (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeIndicatorControlRampUpTimer IndicatorControlINDRU { get; set; }
Public Property IndicatorControlINDRU As Max8834TypeIndicatorControlRampUpTimer
    Get
    Set
public:
property Max8834TypeIndicatorControlRampUpTimer IndicatorControlINDRU {
    Max8834TypeIndicatorControlRampUpTimer get ();
    void set (Max8834TypeIndicatorControlRampUpTimer value);
}
member IndicatorControlINDRU : Max8834TypeIndicatorControlRampUpTimer with get, set

Property Value

Type: Max8834TypeIndicatorControlRampUpTimer
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.IndicatorCurrentIND Property

IRD

Max8834IndicatorCurrentIND Property

Indicator Current: IND (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double IndicatorCurrentIND { get; set; }
Public Property IndicatorCurrentIND As Double
    Get
    Set
public:
property double IndicatorCurrentIND {
    double get ();
    void set (double value);
}
member IndicatorCurrentIND : float with get, set

Property Value

Type: Double
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.IndicatorCurrentINDBLEN Property

IRD

Max8834IndicatorCurrentINDBLEN Property

Indicator Current: IND_BL_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeIndicatorCurrentBlinkTimer IndicatorCurrentINDBLEN { get; set; }
Public Property IndicatorCurrentINDBLEN As Max8834TypeIndicatorCurrentBlinkTimer
    Get
    Set
public:
property Max8834TypeIndicatorCurrentBlinkTimer IndicatorCurrentINDBLEN {
    Max8834TypeIndicatorCurrentBlinkTimer get ();
    void set (Max8834TypeIndicatorCurrentBlinkTimer value);
}
member IndicatorCurrentINDBLEN : Max8834TypeIndicatorCurrentBlinkTimer with get, set

Property Value

Type: Max8834TypeIndicatorCurrentBlinkTimer
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.IndicatorCurrentINDRPEN Property

IRD

Max8834IndicatorCurrentINDRPEN Property

Indicator Current: IND_RP_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeIndicatorCurrentRampUpdown IndicatorCurrentINDRPEN { get; set; }
Public Property IndicatorCurrentINDRPEN As Max8834TypeIndicatorCurrentRampUpdown
    Get
    Set
public:
property Max8834TypeIndicatorCurrentRampUpdown IndicatorCurrentINDRPEN {
    Max8834TypeIndicatorCurrentRampUpdown get ();
    void set (Max8834TypeIndicatorCurrentRampUpdown value);
}
member IndicatorCurrentINDRPEN : Max8834TypeIndicatorCurrentRampUpdown with get, set

Property Value

Type: Max8834TypeIndicatorCurrentRampUpdown
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.LEDControlFLASHEN Property

IRD

Max8834LEDControlFLASHEN Property

LED Control: FLASH_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeLedControlFlashMode LEDControlFLASHEN { get; set; }
Public Property LEDControlFLASHEN As Max8834TypeLedControlFlashMode
    Get
    Set
public:
property Max8834TypeLedControlFlashMode LEDControlFLASHEN {
    Max8834TypeLedControlFlashMode get ();
    void set (Max8834TypeLedControlFlashMode value);
}
member LEDControlFLASHEN : Max8834TypeLedControlFlashMode with get, set

Property Value

Type: Max8834TypeLedControlFlashMode
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.LEDControlINDEN Property

IRD

Max8834LEDControlINDEN Property

LED Control: IND_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeLedControlIndicatorLed LEDControlINDEN { get; set; }
Public Property LEDControlINDEN As Max8834TypeLedControlIndicatorLed
    Get
    Set
public:
property Max8834TypeLedControlIndicatorLed LEDControlINDEN {
    Max8834TypeLedControlIndicatorLed get ();
    void set (Max8834TypeLedControlIndicatorLed value);
}
member LEDControlINDEN : Max8834TypeLedControlIndicatorLed with get, set

Property Value

Type: Max8834TypeLedControlIndicatorLed
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.LEDControlMOVIEEN Property

IRD

Max8834LEDControlMOVIEEN Property

LED Control: MOVIE_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeLedControlMovieMode LEDControlMOVIEEN { get; set; }
Public Property LEDControlMOVIEEN As Max8834TypeLedControlMovieMode
    Get
    Set
public:
property Max8834TypeLedControlMovieMode LEDControlMOVIEEN {
    Max8834TypeLedControlMovieMode get ();
    void set (Max8834TypeLedControlMovieMode value);
}
member LEDControlMOVIEEN : Max8834TypeLedControlMovieMode with get, set

Property Value

Type: Max8834TypeLedControlMovieMode
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.Maxflash1LBEN Property

IRD

Max8834Maxflash1LBEN Property

Maxflash1: LB_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeMaxflash1FunctionEnable Maxflash1LBEN { get; set; }
Public Property Maxflash1LBEN As Max8834TypeMaxflash1FunctionEnable
    Get
    Set
public:
property Max8834TypeMaxflash1FunctionEnable Maxflash1LBEN {
    Max8834TypeMaxflash1FunctionEnable get ();
    void set (Max8834TypeMaxflash1FunctionEnable value);
}
member Maxflash1LBEN : Max8834TypeMaxflash1FunctionEnable with get, set

Property Value

Type: Max8834TypeMaxflash1FunctionEnable
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.Maxflash1LBHYS Property

IRD

Max8834Maxflash1LBHYS Property

Maxflash1: LB_HYS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeMaxflash1LowBatteryHysteresis Maxflash1LBHYS { get; set; }
Public Property Maxflash1LBHYS As Max8834TypeMaxflash1LowBatteryHysteresis
    Get
    Set
public:
property Max8834TypeMaxflash1LowBatteryHysteresis Maxflash1LBHYS {
    Max8834TypeMaxflash1LowBatteryHysteresis get ();
    void set (Max8834TypeMaxflash1LowBatteryHysteresis value);
}
member Maxflash1LBHYS : Max8834TypeMaxflash1LowBatteryHysteresis with get, set

Property Value

Type: Max8834TypeMaxflash1LowBatteryHysteresis
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.Maxflash1LBTH Property

IRD

Max8834Maxflash1LBTH Property

Maxflash1: LB_TH (unit: V)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeMaxflash1LowBatteryThreshold Maxflash1LBTH { get; set; }
Public Property Maxflash1LBTH As Max8834TypeMaxflash1LowBatteryThreshold
    Get
    Set
public:
property Max8834TypeMaxflash1LowBatteryThreshold Maxflash1LBTH {
    Max8834TypeMaxflash1LowBatteryThreshold get ();
    void set (Max8834TypeMaxflash1LowBatteryThreshold value);
}
member Maxflash1LBTH : Max8834TypeMaxflash1LowBatteryThreshold with get, set

Property Value

Type: Max8834TypeMaxflash1LowBatteryThreshold
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.Maxflash2LBTMR Property

IRD

Max8834Maxflash2LBTMR Property

Maxflash2: LB_TMR (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeMaxflash2LowBatteryReset Maxflash2LBTMR { get; set; }
Public Property Maxflash2LBTMR As Max8834TypeMaxflash2LowBatteryReset
    Get
    Set
public:
property Max8834TypeMaxflash2LowBatteryReset Maxflash2LBTMR {
    Max8834TypeMaxflash2LowBatteryReset get ();
    void set (Max8834TypeMaxflash2LowBatteryReset value);
}
member Maxflash2LBTMR : Max8834TypeMaxflash2LowBatteryReset with get, set

Property Value

Type: Max8834TypeMaxflash2LowBatteryReset
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.MovieCurrentMOVIE1 Property

IRD

Max8834MovieCurrentMOVIE1 Property

Movie Current: MOVIE1 (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MovieCurrentMOVIE1 { get; set; }
Public Property MovieCurrentMOVIE1 As Double
    Get
    Set
public:
property double MovieCurrentMOVIE1 {
    double get ();
    void set (double value);
}
member MovieCurrentMOVIE1 : float with get, set

Property Value

Type: Double
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.MovieCurrentMOVIE2 Property

IRD

Max8834MovieCurrentMOVIE2 Property

Movie Current: MOVIE2 (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MovieCurrentMOVIE2 { get; set; }
Public Property MovieCurrentMOVIE2 As Double
    Get
    Set
public:
property double MovieCurrentMOVIE2 {
    double get ();
    void set (double value);
}
member MovieCurrentMOVIE2 : float with get, set

Property Value

Type: Double
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.NTCControlFLASHTMRCNTL Property

IRD

Max8834NTCControlFLASHTMRCNTL Property

NTC Control: FLASH_TMR_CNTL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeNtcControlFlashReset NTCControlFLASHTMRCNTL { get; set; }
Public Property NTCControlFLASHTMRCNTL As Max8834TypeNtcControlFlashReset
    Get
    Set
public:
property Max8834TypeNtcControlFlashReset NTCControlFLASHTMRCNTL {
    Max8834TypeNtcControlFlashReset get ();
    void set (Max8834TypeNtcControlFlashReset value);
}
member NTCControlFLASHTMRCNTL : Max8834TypeNtcControlFlashReset with get, set

Property Value

Type: Max8834TypeNtcControlFlashReset
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.NTCControlNTC Property

IRD

Max8834NTCControlNTC Property

NTC Control: NTC (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double NTCControlNTC { get; set; }
Public Property NTCControlNTC As Double
    Get
    Set
public:
property double NTCControlNTC {
    double get ();
    void set (double value);
}
member NTCControlNTC : float with get, set

Property Value

Type: Double
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.NTCControlNTCEN Property

IRD

Max8834NTCControlNTCEN Property

NTC Control: NTC_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeNtcControlNtcFunction NTCControlNTCEN { get; set; }
Public Property NTCControlNTCEN As Max8834TypeNtcControlNtcFunction
    Get
    Set
public:
property Max8834TypeNtcControlNtcFunction NTCControlNTCEN {
    Max8834TypeNtcControlNtcFunction get ();
    void set (Max8834TypeNtcControlNtcFunction value);
}
member NTCControlNTCEN : Max8834TypeNtcControlNtcFunction with get, set

Property Value

Type: Max8834TypeNtcControlNtcFunction
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.Status1FLED1FLT Property

IRD

Max8834Status1FLED1FLT Property

Status1: FLED1_FLT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeStatus1Fled1Status Status1FLED1FLT { get; }
Public ReadOnly Property Status1FLED1FLT As Max8834TypeStatus1Fled1Status
    Get
public:
property Max8834TypeStatus1Fled1Status Status1FLED1FLT {
    Max8834TypeStatus1Fled1Status get ();
}
member Status1FLED1FLT : Max8834TypeStatus1Fled1Status with get

Property Value

Type: Max8834TypeStatus1Fled1Status
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.Status1FLED2FLT Property

IRD

Max8834Status1FLED2FLT Property

Status1: FLED2_FLT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeStatus1Fled2Status Status1FLED2FLT { get; }
Public ReadOnly Property Status1FLED2FLT As Max8834TypeStatus1Fled2Status
    Get
public:
property Max8834TypeStatus1Fled2Status Status1FLED2FLT {
    Max8834TypeStatus1Fled2Status get ();
}
member Status1FLED2FLT : Max8834TypeStatus1Fled2Status with get

Property Value

Type: Max8834TypeStatus1Fled2Status
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.Status1GSMB Property

IRD

Max8834Status1GSMB Property

Status1: GSMB

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeStatus1GsmbStatus Status1GSMB { get; }
Public ReadOnly Property Status1GSMB As Max8834TypeStatus1GsmbStatus
    Get
public:
property Max8834TypeStatus1GsmbStatus Status1GSMB {
    Max8834TypeStatus1GsmbStatus get ();
}
member Status1GSMB : Max8834TypeStatus1GsmbStatus with get

Property Value

Type: Max8834TypeStatus1GsmbStatus
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.Status1INDLEDFLT Property

IRD

Max8834Status1INDLEDFLT Property

Status1: INDLED_FLT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeStatus1IndledStatus Status1INDLEDFLT { get; }
Public ReadOnly Property Status1INDLEDFLT As Max8834TypeStatus1IndledStatus
    Get
public:
property Max8834TypeStatus1IndledStatus Status1INDLEDFLT {
    Max8834TypeStatus1IndledStatus get ();
}
member Status1INDLEDFLT : Max8834TypeStatus1IndledStatus with get

Property Value

Type: Max8834TypeStatus1IndledStatus
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.Status1NTCFLT Property

IRD

Max8834Status1NTCFLT Property

Status1: NTC_FLT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeStatus1NtcStatus Status1NTCFLT { get; }
Public ReadOnly Property Status1NTCFLT As Max8834TypeStatus1NtcStatus
    Get
public:
property Max8834TypeStatus1NtcStatus Status1NTCFLT {
    Max8834TypeStatus1NtcStatus get ();
}
member Status1NTCFLT : Max8834TypeStatus1NtcStatus with get

Property Value

Type: Max8834TypeStatus1NtcStatus
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.Status1NTCOVT Property

IRD

Max8834Status1NTCOVT Property

Status1: NTC_OVT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeStatus1NtcTemperature Status1NTCOVT { get; }
Public ReadOnly Property Status1NTCOVT As Max8834TypeStatus1NtcTemperature
    Get
public:
property Max8834TypeStatus1NtcTemperature Status1NTCOVT {
    Max8834TypeStatus1NtcTemperature get ();
}
member Status1NTCOVT : Max8834TypeStatus1NtcTemperature with get

Property Value

Type: Max8834TypeStatus1NtcTemperature
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.Status1OVERTEMP Property

IRD

Max8834Status1OVERTEMP Property

Status1: OVER_TEMP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeStatus1DieTemperature Status1OVERTEMP { get; }
Public ReadOnly Property Status1OVERTEMP As Max8834TypeStatus1DieTemperature
    Get
public:
property Max8834TypeStatus1DieTemperature Status1OVERTEMP {
    Max8834TypeStatus1DieTemperature get ();
}
member Status1OVERTEMP : Max8834TypeStatus1DieTemperature with get

Property Value

Type: Max8834TypeStatus1DieTemperature
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.Status1POKFLT Property

IRD

Max8834Status1POKFLT Property

Status1: POK_FLT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeStatus1PokWindowStatus Status1POKFLT { get; }
Public ReadOnly Property Status1POKFLT As Max8834TypeStatus1PokWindowStatus
    Get
public:
property Max8834TypeStatus1PokWindowStatus Status1POKFLT {
    Max8834TypeStatus1PokWindowStatus get ();
}
member Status1POKFLT : Max8834TypeStatus1PokWindowStatus with get

Property Value

Type: Max8834TypeStatus1PokWindowStatus
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.Status2GSMBILIM Property

IRD

Max8834Status2GSMBILIM Property

Status2: GSMB_ILIM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeStatus2InputCurrent Status2GSMBILIM { get; }
Public ReadOnly Property Status2GSMBILIM As Max8834TypeStatus2InputCurrent
    Get
public:
property Max8834TypeStatus2InputCurrent Status2GSMBILIM {
    Max8834TypeStatus2InputCurrent get ();
}
member Status2GSMBILIM : Max8834TypeStatus2InputCurrent with get

Property Value

Type: Max8834TypeStatus2InputCurrent
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.Status2MAXFLASHSTAT Property

IRD

Max8834Status2MAXFLASHSTAT Property

Status2: MAXFLASH_STAT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeStatus2MaxflashEvent Status2MAXFLASHSTAT { get; }
Public ReadOnly Property Status2MAXFLASHSTAT As Max8834TypeStatus2MaxflashEvent
    Get
public:
property Max8834TypeStatus2MaxflashEvent Status2MAXFLASHSTAT {
    Max8834TypeStatus2MaxflashEvent get ();
}
member Status2MAXFLASHSTAT : Max8834TypeStatus2MaxflashEvent with get

Property Value

Type: Max8834TypeStatus2MaxflashEvent
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.TimerControlTMRDUR Property

IRD

Max8834TimerControlTMRDUR Property

Timer Control: TMR_DUR (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TimerControlTMRDUR { get; set; }
Public Property TimerControlTMRDUR As Double
    Get
    Set
public:
property double TimerControlTMRDUR {
    double get ();
    void set (double value);
}
member TimerControlTMRDUR : float with get, set

Property Value

Type: Double
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.TimerControlTMRMODE Property

IRD

Max8834TimerControlTMRMODE Property

Timer Control: TMR_MODE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeTimerControlTimerMode TimerControlTMRMODE { get; set; }
Public Property TimerControlTMRMODE As Max8834TypeTimerControlTimerMode
    Get
    Set
public:
property Max8834TypeTimerControlTimerMode TimerControlTMRMODE {
    Max8834TypeTimerControlTimerMode get ();
    void set (Max8834TypeTimerControlTimerMode value);
}
member TimerControlTMRMODE : Max8834TypeTimerControlTimerMode with get, set

Property Value

Type: Max8834TypeTimerControlTimerMode
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.TimerControlWDTDUR Property

IRD

Max8834TimerControlWDTDUR Property

Timer Control: WDT_DUR (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeTimerControlWatchdogDuration TimerControlWDTDUR { get; set; }
Public Property TimerControlWDTDUR As Max8834TypeTimerControlWatchdogDuration
    Get
    Set
public:
property Max8834TypeTimerControlWatchdogDuration TimerControlWDTDUR {
    Max8834TypeTimerControlWatchdogDuration get ();
    void set (Max8834TypeTimerControlWatchdogDuration value);
}
member TimerControlWDTDUR : Max8834TypeTimerControlWatchdogDuration with get, set

Property Value

Type: Max8834TypeTimerControlWatchdogDuration
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.TimerControlWDTEN Property

IRD

Max8834TimerControlWDTEN Property

Timer Control: WDT_EN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeTimerControlWatchdogFunction TimerControlWDTEN { get; set; }
Public Property TimerControlWDTEN As Max8834TypeTimerControlWatchdogFunction
    Get
    Set
public:
property Max8834TypeTimerControlWatchdogFunction TimerControlWDTEN {
    Max8834TypeTimerControlWatchdogFunction get ();
    void set (Max8834TypeTimerControlWatchdogFunction value);
}
member TimerControlWDTEN : Max8834TypeTimerControlWatchdogFunction with get, set

Property Value

Type: Max8834TypeTimerControlWatchdogFunction
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.WatchdogResetWDTRST Property

IRD

Max8834WatchdogResetWDTRST Property

Watchdog Reset: WDT_RST

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8834TypeWatchdogReset WatchdogResetWDTRST { get; set; }
Public Property WatchdogResetWDTRST As Max8834TypeWatchdogReset
    Get
    Set
public:
property Max8834TypeWatchdogReset WatchdogResetWDTRST {
    Max8834TypeWatchdogReset get ();
    void set (Max8834TypeWatchdogReset value);
}
member WatchdogResetWDTRST : Max8834TypeWatchdogReset with get, set

Property Value

Type: Max8834TypeWatchdogReset
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834 Methods

The Max8834 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.Flush Method

IRD

Max8834Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max8834 Class
telos.Ird.Maxim Namespace


Max8834.TypeBoostControlBoostEnable Enumeration

IRD

Max8834TypeBoostControlBoostEnable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBoostControlBoostEnable
Public Enumeration TypeBoostControlBoostEnable
public enum class TypeBoostControlBoostEnable
type TypeBoostControlBoostEnable
Members
Member name | Value | Description
StepUpConverterOff | 0 | Step-Up Converter: Off
StepUpConverterOn | 1 | Step-Up Converter: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeBoostControlBoostMode Enumeration

IRD

Max8834TypeBoostControlBoostMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBoostControlBoostMode
Public Enumeration TypeBoostControlBoostMode
public enum class TypeBoostControlBoostMode
type TypeBoostControlBoostMode
Members
Member name | Value | Description
StepUpVoltageSetAdaptively | 0 | Step-Up Voltage: Set Adaptively
StepUpVoltageSetProgrammatically | 1 | Step-Up Voltage: Set Programmatically
StepUpConverterRunsInDropOut | 2 | Step-Up Converter: Runs In Drop-Out
StepUpConverterChangeBetweenAdaptiveRegulationAndDropOutMode | 3 | Step-Up Converter: Change Between Adaptive Regulation And Drop-Out Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeFlash12Current Enumeration

IRD

Max8834TypeFlash12Current Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFlash12Current
Public Enumeration TypeFlash12Current
public enum class TypeFlash12Current
type TypeFlash12Current
Members
Member name | Value | Description
Value_23_44 | 0 | 23.44
Value_46_88 | 1 | 46.88
Value_70_32 | 2 | 70.32
Value_93_76 | 3 | 93.76
Value_117_20 | 4 | 117.20
Value_140_64 | 5 | 140.64
Value_164_08 | 6 | 164.08
Value_187_52 | 7 | 187.52
Value_210_96 | 8 | 210.96
Value_234_40 | 9 | 234.40
Value_257_84 | 10 | 257.84
Value_281_28 | 11 | 281.28
Value_304_72 | 12 | 304.72
Value_328_16 | 13 | 328.16
Value_351_60 | 14 | 351.60
Value_375_04 | 15 | 375.04
Value_398_48 | 16 | 398.48
Value_421_92 | 17 | 421.92
Value_445_36 | 18 | 445.36
Value_468_80 | 19 | 468.80
Value_492_24 | 20 | 492.24
Value_515_68 | 21 | 515.68
Value_539_12 | 22 | 539.12
Value_562_56 | 23 | 562.56
Value_586_00 | 24 | 586.00
Value_609_44 | 25 | 609.44
Value_632_88 | 26 | 632.88
Value_656_32 | 27 | 656.32
Value_679_76 | 28 | 679.76
Value_703_20 | 29 | 703.20
Value_726_56 | 30 | 726.56
Value_750_00 | 31 | 750.00
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeGsmbCurrentGsmBlank Enumeration

IRD

Max8834TypeGsmbCurrentGsmBlank Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGsmbCurrentGsmBlank
Public Enumeration TypeGsmbCurrentGsmBlank
public enum class TypeGsmbCurrentGsmBlank
type TypeGsmbCurrentGsmBlank
Members
Member name | Value | Description
GSMBlankInputDisabled | 0 | GSM Blank Input: Disabled
GSMBlankInputEnabled | 1 | GSM Blank Input: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeGsmbCurrentGsmPolarity Enumeration

IRD

Max8834TypeGsmbCurrentGsmPolarity Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGsmbCurrentGsmPolarity
Public Enumeration TypeGsmbCurrentGsmPolarity
public enum class TypeGsmbCurrentGsmPolarity
type TypeGsmbCurrentGsmPolarity
Members
Member name | Value | Description
GSMBlankPolarityActiveLow | 0 | GSM Blank Polarity: Active Low
GSMBlankPolarityActiveHigh | 1 | GSM Blank Polarity: Active High
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeGsmbCurrentGsmResetTimer Enumeration

IRD

Max8834TypeGsmbCurrentGsmResetTimer Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGsmbCurrentGsmResetTimer
Public Enumeration TypeGsmbCurrentGsmResetTimer
public enum class TypeGsmbCurrentGsmResetTimer
type TypeGsmbCurrentGsmResetTimer
Members
Member name | Value | Description
Value_10 | 0 | 10
Value_20 | 1 | 20
Value_40 | 2 | 40
Value_80 | 3 | 80
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeIndicatorControlOffBlinkTimer Enumeration

IRD

Max8834TypeIndicatorControlOffBlinkTimer Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIndicatorControlOffBlinkTimer
Public Enumeration TypeIndicatorControlOffBlinkTimer
public enum class TypeIndicatorControlOffBlinkTimer
type TypeIndicatorControlOffBlinkTimer
Members
Member name | Value | Description
Value_512 | 0 | 512
Value_1024 | 1 | 1024
Value_2048 | 2 | 2048
Value_4096 | 3 | 4096
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeIndicatorControlOnBlinkTimer Enumeration

IRD

Max8834TypeIndicatorControlOnBlinkTimer Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIndicatorControlOnBlinkTimer
Public Enumeration TypeIndicatorControlOnBlinkTimer
public enum class TypeIndicatorControlOnBlinkTimer
type TypeIndicatorControlOnBlinkTimer
Members
Member name | Value | Description
Value_128 | 0 | 128
Value_256 | 1 | 256
Value_512 | 2 | 512
Value_1024 | 3 | 1024
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeIndicatorControlRampDownTimer Enumeration

IRD

Max8834TypeIndicatorControlRampDownTimer Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIndicatorControlRampDownTimer
Public Enumeration TypeIndicatorControlRampDownTimer
public enum class TypeIndicatorControlRampDownTimer
type TypeIndicatorControlRampDownTimer
Members
Member name | Value | Description
Value_128 | 0 | 128
Value_256 | 1 | 256
Value_512 | 2 | 512
Value_1024 | 3 | 1024
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeIndicatorControlRampUpTimer Enumeration

IRD

Max8834TypeIndicatorControlRampUpTimer Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIndicatorControlRampUpTimer
Public Enumeration TypeIndicatorControlRampUpTimer
public enum class TypeIndicatorControlRampUpTimer
type TypeIndicatorControlRampUpTimer
Members
Member name | Value | Description
Value_128 | 0 | 128
Value_256 | 1 | 256
Value_512 | 2 | 512
Value_1024 | 3 | 1024
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeIndicatorCurrentBlinkTimer Enumeration

IRD

Max8834TypeIndicatorCurrentBlinkTimer Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIndicatorCurrentBlinkTimer
Public Enumeration TypeIndicatorCurrentBlinkTimer
public enum class TypeIndicatorCurrentBlinkTimer
type TypeIndicatorCurrentBlinkTimer
Members
Member name | Value | Description
IndicatorBlinkTimerDisabled | 0 | Indicator Blink Timer: Disabled
IndicatorBlinkTimerEnable | 1 | Indicator Blink Timer: Enable
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeIndicatorCurrentRampUpdown Enumeration

IRD

Max8834TypeIndicatorCurrentRampUpdown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIndicatorCurrentRampUpdown
Public Enumeration TypeIndicatorCurrentRampUpdown
public enum class TypeIndicatorCurrentRampUpdown
type TypeIndicatorCurrentRampUpdown
Members
Member name | Value | Description
IndicatorRampUpDownDisabled | 0 | Indicator Ramp Up/Down: Disabled
IndicatorRampUpDownEnabled | 1 | Indicator Ramp Up/Down: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeLedControlFlashMode Enumeration

IRD

Max8834TypeLedControlFlashMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedControlFlashMode
Public Enumeration TypeLedControlFlashMode
public enum class TypeLedControlFlashMode
type TypeLedControlFlashMode
Members
Member name | Value | Description
FLED1AndFLED2FlashModeDisabled | 0 | FLED1 And FLED2 Flash Mode Disabled
FLED1FlashModeEnabledFLED2FlashModeDisabled | 1 | FLED1 Flash Mode Enabled, FLED2 Flash Mode Disabled
FLED1FlashModeDisabledFLED2FlashModeEnabled | 2 | FLED1 Flash Mode Disabled, FLED2 Flash Mode Enabled
FLED1AndFLED2FlashModeEnabled | 3 | FLED1 And FLED2 Flash Mode Enabled
FLED1ControlledByLEDENInputFLED2FlashModeDisabled | 5 | FLED1 Controlled By LED_EN Input, FLED2 Flash Mode Disabled
FLED2ControlledByLEDENInputFLED1FlashModeDisabled | 6 | FLED2 Controlled By LED_EN Input, FLED1 Flash Mode Disabled
FLED1AndFLED2FlashModeControlledByLEDENInput | 7 | FLED1 And FLED2 Flash Mode Controlled By LED_EN Input
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeLedControlIndicatorLed Enumeration

IRD

Max8834TypeLedControlIndicatorLed Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedControlIndicatorLed
Public Enumeration TypeLedControlIndicatorLed
public enum class TypeLedControlIndicatorLed
type TypeLedControlIndicatorLed
Members
Member name | Value | Description
INDLEDIndicatorLEDDisabled | 0 | INDLED Indicator: LED Disabled
INDLEDIndicatorLEDEnabled | 2 | INDLED Indicator: LED Enabled
INDLEDIndicatorLEDControlledByLEDENInput | 3 | INDLED Indicator: LED Controlled By LED_EN Input
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeLedControlMovieMode Enumeration

IRD

Max8834TypeLedControlMovieMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedControlMovieMode
Public Enumeration TypeLedControlMovieMode
public enum class TypeLedControlMovieMode
type TypeLedControlMovieMode
Members
Member name | Value | Description
FLED1AndFLED2MovieModeDisabled | 0 | FLED1 And FLED2 Movie Mode Disabled
FLED1MovieModeEnabledFLED2MovieModeDisabled | 1 | FLED1 Movie Mode Enabled, FLED2 Movie Mode Disabled
FLED1MovieModeDisabledFLED2MovieModeEnabled | 2 | FLED1 Movie Mode Disabled, FLED2 Movie Mode Enabled
FLED1AndFLED2MovieModeEnabled | 3 | FLED1 And FLED2 Movie Mode Enabled
FLED1ControlledByLEDENInputFLED2MovieModeDisabled | 5 | FLED1 Controlled By LED_EN Input, FLED2 Movie Mode Disabled
FLED2ControlledByLEDENInputFLED1MovieModeDisabled | 6 | FLED2 Controlled By LED_EN Input, FLED1 Movie Mode Disabled
FLED1AndFLED2MovieModeControlledByLEDENInput | 7 | FLED1 And FLED2 Movie Mode Controlled By LED_EN Input
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeMaxflash1FunctionEnable Enumeration

IRD

Max8834TypeMaxflash1FunctionEnable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMaxflash1FunctionEnable
Public Enumeration TypeMaxflash1FunctionEnable
public enum class TypeMaxflash1FunctionEnable
type TypeMaxflash1FunctionEnable
Members
Member name | Value | Description
MaxflashFunctionDisabled | 0 | Maxflash Function: Disabled
LowBatteryFunctionEnabled | 1 | Low Battery Function: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeMaxflash1LowBatteryHysteresis Enumeration

IRD

Max8834TypeMaxflash1LowBatteryHysteresis Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMaxflash1LowBatteryHysteresis
Public Enumeration TypeMaxflash1LowBatteryHysteresis
public enum class TypeMaxflash1LowBatteryHysteresis
type TypeMaxflash1LowBatteryHysteresis
Members
Member name | Value | Description
Value_100MV | 0 | 100 mV
Value_200MV | 1 | 200 mV
Reserved | 2 | Reserved
HysteresisDisabled | 3 | Hysteresis Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeMaxflash1LowBatteryThreshold Enumeration

IRD

Max8834TypeMaxflash1LowBatteryThreshold Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMaxflash1LowBatteryThreshold
Public Enumeration TypeMaxflash1LowBatteryThreshold
public enum class TypeMaxflash1LowBatteryThreshold
type TypeMaxflash1LowBatteryThreshold
Members
Member name | Value | Description
Value_2_500 | 3 | 2.500
Value_2_533 | 4 | 2.533
Value_2_566 | 5 | 2.566
Value_2_600 | 6 | 2.600
Value_2_633 | 7 | 2.633
Value_2_666 | 8 | 2.666
Value_2_700 | 9 | 2.700
Value_2_733 | 10 | 2.733
Value_2_766 | 11 | 2.766
Value_2_800 | 12 | 2.800
Value_2_833 | 13 | 2.833
Value_2_866 | 14 | 2.866
Value_2_900 | 15 | 2.900
Value_2_933 | 16 | 2.933
Value_2_966 | 17 | 2.966
Value_3_000 | 18 | 3.000
Value_3_033 | 19 | 3.033
Value_3_066 | 20 | 3.066
Value_3_100 | 21 | 3.100
Value_3_133 | 22 | 3.133
Value_3_166 | 23 | 3.166
Value_3_200 | 24 | 3.200
Value_3_233 | 25 | 3.233
Value_3_266 | 26 | 3.266
Value_3_300 | 27 | 3.300
Value_3_333 | 28 | 3.333
Value_3_366 | 29 | 3.366
Value_3_400 | 30 | 3.400
Value_3_400__1 | 31 | 3.400
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeMaxflash2LowBatteryReset Enumeration

IRD

Max8834TypeMaxflash2LowBatteryReset Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMaxflash2LowBatteryReset
Public Enumeration TypeMaxflash2LowBatteryReset
public enum class TypeMaxflash2LowBatteryReset
type TypeMaxflash2LowBatteryReset
Members
Member name | Value | Description
Value_0_25 | 0 | 0.25
Value_0_50 | 1 | 0.50
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeNtcControlFlashReset Enumeration

IRD

Max8834TypeNtcControlFlashReset Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeNtcControlFlashReset
Public Enumeration TypeNtcControlFlashReset
public enum class TypeNtcControlFlashReset
type TypeNtcControlFlashReset
Members
Member name | Value | Description
FlashResetTimerEnable | 0 | Flash Reset Timer: Enable
FlashResetTimerDisable | 1 | Flash Reset Timer: Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeNtcControlNtcFunction Enumeration

IRD

Max8834TypeNtcControlNtcFunction Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeNtcControlNtcFunction
Public Enumeration TypeNtcControlNtcFunction
public enum class TypeNtcControlNtcFunction
type TypeNtcControlNtcFunction
Members
Member name | Value | Description
NTCFunctionDisable | 0 | NTC Function: Disable
NTCFunctionEnable | 1 | NTC Function: Enable
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeStatus1DieTemperature Enumeration

IRD

Max8834TypeStatus1DieTemperature Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1DieTemperature
Public Enumeration TypeStatus1DieTemperature
public enum class TypeStatus1DieTemperature
type TypeStatus1DieTemperature
Members
Member name | Value | Description
DieTemperatureIsWithinSpec | 0 | Die Temperature Is Within Spec
DieOverTemperatureHasOccurred | 1 | Die Over-Temperature Has Occurred
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeStatus1Fled1Status Enumeration

IRD

Max8834TypeStatus1Fled1Status Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1Fled1Status
Public Enumeration TypeStatus1Fled1Status
public enum class TypeStatus1Fled1Status
type TypeStatus1Fled1Status
Members
Member name | Value | Description
FLED1StatusOK | 0 | FLED1 Status: OK
FLED1StatusFaultOccurred | 1 | FLED1 Status: Fault Occurred
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeStatus1Fled2Status Enumeration

IRD

Max8834TypeStatus1Fled2Status Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1Fled2Status
Public Enumeration TypeStatus1Fled2Status
public enum class TypeStatus1Fled2Status
type TypeStatus1Fled2Status
Members
Member name | Value | Description
FLED2StatusOK | 0 | FLED2 Status: OK
FLED2StatusFaultOccurred | 1 | FLED2 Status: Fault Occurred
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeStatus1GsmbStatus Enumeration

IRD

Max8834TypeStatus1GsmbStatus Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1GsmbStatus
Public Enumeration TypeStatus1GsmbStatus
public enum class TypeStatus1GsmbStatus
type TypeStatus1GsmbStatus
Members
Member name | Value | Description
GSMBEventNotOccurred | 0 | GSMB Event: Not Occurred
GSMBEventOccurred | 1 | GSMB Event: Occurred
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeStatus1IndledStatus Enumeration

IRD

Max8834TypeStatus1IndledStatus Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1IndledStatus
Public Enumeration TypeStatus1IndledStatus
public enum class TypeStatus1IndledStatus
type TypeStatus1IndledStatus
Members
Member name | Value | Description
INDLEDStatusOK | 0 | INDLED Status: OK
INDLEDFaultOccurred | 1 | INDLED: Fault Occurred
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeStatus1NtcStatus Enumeration

IRD

Max8834TypeStatus1NtcStatus Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1NtcStatus
Public Enumeration TypeStatus1NtcStatus
public enum class TypeStatus1NtcStatus
type TypeStatus1NtcStatus
Members
Member name | Value | Description
NTCStatusOK | 0 | NTC Status: OK
NTCStatusFaultOccurredOnNTC | 1 | NTC Status: Fault Occurred On NTC
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeStatus1NtcTemperature Enumeration

IRD

Max8834TypeStatus1NtcTemperature Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1NtcTemperature
Public Enumeration TypeStatus1NtcTemperature
public enum class TypeStatus1NtcTemperature
type TypeStatus1NtcTemperature
Members
Member name | Value | Description
NTCTemperatureIsWithinSpec | 0 | NTC Temperature Is Within Spec
NTCTemperatureThresholdHasTripped | 1 | NTC Temperature Threshold Has Tripped
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeStatus1PokWindowStatus Enumeration

IRD

Max8834TypeStatus1PokWindowStatus Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1PokWindowStatus
Public Enumeration TypeStatus1PokWindowStatus
public enum class TypeStatus1PokWindowStatus
type TypeStatus1PokWindowStatus
Members
Member name | Value | Description
OutputVoltageIsWithinPOKWindow | 0 | Output voltage Is Within POK Window
POKFaultHasOccurred | 1 | POK Fault Has Occurred
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeStatus2InputCurrent Enumeration

IRD

Max8834TypeStatus2InputCurrent Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus2InputCurrent
Public Enumeration TypeStatus2InputCurrent
public enum class TypeStatus2InputCurrent
type TypeStatus2InputCurrent
Members
Member name | Value | Description
InputCurrentLimitNotReached | 0 | Input Current Limit: Not Reached
InputCurrentLimitReached | 1 | Input Current Limit: Reached
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeStatus2MaxflashEvent Enumeration

IRD

Max8834TypeStatus2MaxflashEvent Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus2MaxflashEvent
Public Enumeration TypeStatus2MaxflashEvent
public enum class TypeStatus2MaxflashEvent
type TypeStatus2MaxflashEvent
Members
Member name | Value | Description
MaxflashEventNotOccurred | 0 | Maxflash Event: Not Occurred
MaxflashEventOccurred | 1 | Maxflash Event: Occurred
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeTimerControlTimerMode Enumeration

IRD

Max8834TypeTimerControlTimerMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerControlTimerMode
Public Enumeration TypeTimerControlTimerMode
public enum class TypeTimerControlTimerMode
type TypeTimerControlTimerMode
Members
Member name | Value | Description
OneShotMode | 0 | One-Shot Mode
MaximumTimerMode | 1 | Maximum Timer Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeTimerControlWatchdogDuration Enumeration

IRD

Max8834TypeTimerControlWatchdogDuration Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerControlWatchdogDuration
Public Enumeration TypeTimerControlWatchdogDuration
public enum class TypeTimerControlWatchdogDuration
type TypeTimerControlWatchdogDuration
Members
Member name | Value | Description
Value_4 | 0 | 4
Value_8 | 1 | 8
Value_12 | 2 | 12
Value_16 | 3 | 16
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeTimerControlWatchdogFunction Enumeration

IRD

Max8834TypeTimerControlWatchdogFunction Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerControlWatchdogFunction
Public Enumeration TypeTimerControlWatchdogFunction
public enum class TypeTimerControlWatchdogFunction
type TypeTimerControlWatchdogFunction
Members
Member name | Value | Description
WatchdogTimerDisabled | 0 | Watchdog-Timer: Disabled
WatchdogTimerEnabled | 1 | Watchdog-Timer: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max8834.TypeWatchdogReset Enumeration

IRD

Max8834TypeWatchdogReset Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeWatchdogReset
Public Enumeration TypeWatchdogReset
public enum class TypeWatchdogReset
type TypeWatchdogReset
Members
Member name | Value | Description
WatchdogTimerDefault | 0 | Watchdog Timer: Default
WatchdogTimerReset | 1 | Watchdog Timer: Reset
See Also

Reference

telos.Ird.Maxim Namespace


Max8930 Class

Maxim: MAX 8930
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax8930

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max8930
Public Class Max8930
public ref class Max8930
type Max8930 =  class end

The Max8930 type exposes the following members.

Constructors
 | Name | Description
Public method | Max8930 | Constructor
Top
Properties
 | Name | Description
Public property | ActiveDischargeFuncBoost | Active Discharge Func: Boost
Public property | ActiveDischargeFuncLDO1ADIS | Active Discharge Func: LDO1ADIS
Public property | ActiveDischargeFuncLDO2ADIS | Active Discharge Func: LDO2ADIS
Public property | ActiveDischargeFuncLDO3 | Active Discharge Func: LDO3
Public property | ActiveDischargeFuncLDO3ADIS | Active Discharge Func: LDO3ADIS
Public property | ALCControl1ALCYC | ALC Control 1: ALCYC
Public property | ALCControl1LSTY | ALC Control 1: LSTY
Public property | ALCControl1OST | ALC Control 1: OST
Public property | ALCControl1SBIAS | ALC Control 1: SBIAS
Public property | ALCControl2ALDA | ALC Control 2: ALDA
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BlueLEDDimmingCurrentBLED | Blue LED Dimming Current: BLED (unit: mA)
Public property | ControlALC10CADA | Control ALC10: CADA (unit: mA)
Public property | ControlALC11CADA | Control ALC11: CADA (unit: mA)
Public property | ControlALC12CADA | Control ALC12: CADA (unit: mA)
Public property | ControlALC13CADA | Control ALC13: CADA (unit: mA)
Public property | ControlALC14CADA | Control ALC14: CADA (unit: mA)
Public property | ControlALC15CADA | Control ALC15: CADA (unit: mA)
Public property | ControlALC16CADA | Control ALC16: CADA (unit: mA)
Public property | ControlALC1CADA | Control ALC1: CADA (unit: mA)
Public property | ControlALC2CADA | Control ALC2: CADA (unit: mA)
Public property | ControlALC3CADA | Control ALC3: CADA (unit: mA)
Public property | ControlALC4CADA | Control ALC4: CADA (unit: mA)
Public property | ControlALC5CADA | Control ALC5: CADA (unit: mA)
Public property | ControlALC6CADA | Control ALC6: CADA (unit: mA)
Public property | ControlALC7CADA | Control ALC7: CADA (unit: mA)
Public property | ControlALC8CADA | Control ALC8: CADA (unit: mA)
Public property | ControlALC9CADA | Control ALC9: CADA (unit: mA)
Public property | DimmingCurrentMainWLEDIMLED | Dimming Current Main WLED: IMLED (unit: mA)
Public property | DimmingCurrentWLED5ISLED | Dimming Current WLED5: ISLED (unit: mA)
Public property | DimmingCurrentWLED6ISLED | Dimming Current WLED6: ISLED (unit: mA)
Public property | DimmingCurrentWLED7ISLED | Dimming Current WLED7: ISLED (unit: mA)
Public property | DimmingCurrentWLED8ISLED | Dimming Current WLED8: ISLED (unit: mA)
Public property | GreenLEDDimmingCurrentGLED | Green LED Dimming Current: GLED (unit: mA)
Public property | KeypadControlALCKYHS | Keypad Control ALC: KYHS
Public property | KeypadControlALCKYTH | Keypad Control ALC: KYTH
Public property | KeypadControlKYDT | Keypad Control: KYDT (unit: %)
Public property | KeypadControlKYSL | Keypad Control: KYSL (unit: ms)
Public property | LDO1AndLDO2KYPWM | LDO1 And LDO2: KYPWM
Public property | LDO1AndLDO2LDO1 | LDO1 And LDO2: LDO1
Public property | LDO1AndLDO2LDO2 | LDO1 And LDO2: LDO2
Public property | OnOff1ALCEN | On/Off 1: ALCEN
Public property | OnOff1KBALC | On/Off 1: KBALC
Public property | OnOff1LDO1 | On/Off 1: LDO1
Public property | OnOff1LDO2 | On/Off 1: LDO2
Public property | OnOff1LDO3 | On/Off 1: LDO3
Public property | OnOff1MainWLED | On/Off 1: Main WLED
Public property | OnOff1RESET | On/Off 1: RESET
Public property | OnOff1SUEN | On/Off 1: SUEN
Public property | OnOff2LEDSlope | On/Off 2: LED Slope
Public property | OnOff2RGBSlope | On/Off 2: RGB Slope
Public property | OnOff2SUB5 | On/Off 2: SUB5
Public property | OnOff2SUB6 | On/Off 2: SUB6
Public property | OnOff2SUB7 | On/Off 2: SUB7
Public property | OnOff2WLED5 | On/Off 2: WLED5
Public property | OnOff2WLED6 | On/Off 2: WLED6
Public property | OnOff2WLED7 | On/Off 2: WLED7
Public property | OnOff3CAI | On/Off 3: CAI
Public property | OnOff3CHG | On/Off 3: CHG
Public property | OnOff3HLCAI | On/Off 3: HLCAI
Public property | OnOff3KYI2C | On/Off 3:KYI2C
Public property | OnOff3MAINI2C | On/Off 3: MAINI2C
Public property | OnOff3SUB8 | On/Off 3: SUB8
Public property | OnOff3TWAIT | On/Off 3: TWAIT
Public property | OnOff3WLED8 | On/Off 3: WLED8
Public property | OnOffControlGPLD1 | On/Off Control: GPLD1
Public property | OnOffControlGPLD2 | On/Off Control: GPLD2
Public property | OnOffControlGPLD3 | On/Off Control: GPLD3
Public property | OnOffControlGPO1 | On/Off Control: GPO1
Public property | RedLEDDimmingCurrentRLED | Red LED Dimming Current: RLED (unit: mA)
Public property | RGBLEDOnOffControlBI2C | RGB LED On/Off Control: BI2C
Public property | RGBLEDOnOffControlGI2C | RGB LED On/Off Control: GI2C
Public property | RGBLEDOnOffControlHLRGB | RGB LED On/Off Control: HLRGB
Public property | RGBLEDOnOffControlRGBEN | RGB LED On/Off Control: RGBEN
Public property | RGBLEDOnOffControlRI2C | RGB LED On/Off Control: RI2C
Public property | SlopeControlMainWLEDDSLP | Slope Control Main WLED: DSLP (unit: ms)
Public property | SlopeControlMainWLEDUSLP | Slope Control Main WLED: USLP (unit: ms)
Public property | SlopeControlRGBLEDDSLP | Slope Control RGB LED: DSLP (unit: ms)
Public property | SlopeControlRGBLEDUSLP | Slope Control RGB LED: USLP (unit: ms)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
WLED Charge Pump, RGB, OLED Boost
See Also

Reference

telos.Ird.Maxim Namespace


Max8930 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max8930(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max8930

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930 Properties

The Max8930 type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDischargeFuncBoost | Active Discharge Func: Boost
Public property | ActiveDischargeFuncLDO1ADIS | Active Discharge Func: LDO1ADIS
Public property | ActiveDischargeFuncLDO2ADIS | Active Discharge Func: LDO2ADIS
Public property | ActiveDischargeFuncLDO3 | Active Discharge Func: LDO3
Public property | ActiveDischargeFuncLDO3ADIS | Active Discharge Func: LDO3ADIS
Public property | ALCControl1ALCYC | ALC Control 1: ALCYC
Public property | ALCControl1LSTY | ALC Control 1: LSTY
Public property | ALCControl1OST | ALC Control 1: OST
Public property | ALCControl1SBIAS | ALC Control 1: SBIAS
Public property | ALCControl2ALDA | ALC Control 2: ALDA
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BlueLEDDimmingCurrentBLED | Blue LED Dimming Current: BLED (unit: mA)
Public property | ControlALC10CADA | Control ALC10: CADA (unit: mA)
Public property | ControlALC11CADA | Control ALC11: CADA (unit: mA)
Public property | ControlALC12CADA | Control ALC12: CADA (unit: mA)
Public property | ControlALC13CADA | Control ALC13: CADA (unit: mA)
Public property | ControlALC14CADA | Control ALC14: CADA (unit: mA)
Public property | ControlALC15CADA | Control ALC15: CADA (unit: mA)
Public property | ControlALC16CADA | Control ALC16: CADA (unit: mA)
Public property | ControlALC1CADA | Control ALC1: CADA (unit: mA)
Public property | ControlALC2CADA | Control ALC2: CADA (unit: mA)
Public property | ControlALC3CADA | Control ALC3: CADA (unit: mA)
Public property | ControlALC4CADA | Control ALC4: CADA (unit: mA)
Public property | ControlALC5CADA | Control ALC5: CADA (unit: mA)
Public property | ControlALC6CADA | Control ALC6: CADA (unit: mA)
Public property | ControlALC7CADA | Control ALC7: CADA (unit: mA)
Public property | ControlALC8CADA | Control ALC8: CADA (unit: mA)
Public property | ControlALC9CADA | Control ALC9: CADA (unit: mA)
Public property | DimmingCurrentMainWLEDIMLED | Dimming Current Main WLED: IMLED (unit: mA)
Public property | DimmingCurrentWLED5ISLED | Dimming Current WLED5: ISLED (unit: mA)
Public property | DimmingCurrentWLED6ISLED | Dimming Current WLED6: ISLED (unit: mA)
Public property | DimmingCurrentWLED7ISLED | Dimming Current WLED7: ISLED (unit: mA)
Public property | DimmingCurrentWLED8ISLED | Dimming Current WLED8: ISLED (unit: mA)
Public property | GreenLEDDimmingCurrentGLED | Green LED Dimming Current: GLED (unit: mA)
Public property | KeypadControlALCKYHS | Keypad Control ALC: KYHS
Public property | KeypadControlALCKYTH | Keypad Control ALC: KYTH
Public property | KeypadControlKYDT | Keypad Control: KYDT (unit: %)
Public property | KeypadControlKYSL | Keypad Control: KYSL (unit: ms)
Public property | LDO1AndLDO2KYPWM | LDO1 And LDO2: KYPWM
Public property | LDO1AndLDO2LDO1 | LDO1 And LDO2: LDO1
Public property | LDO1AndLDO2LDO2 | LDO1 And LDO2: LDO2
Public property | OnOff1ALCEN | On/Off 1: ALCEN
Public property | OnOff1KBALC | On/Off 1: KBALC
Public property | OnOff1LDO1 | On/Off 1: LDO1
Public property | OnOff1LDO2 | On/Off 1: LDO2
Public property | OnOff1LDO3 | On/Off 1: LDO3
Public property | OnOff1MainWLED | On/Off 1: Main WLED
Public property | OnOff1RESET | On/Off 1: RESET
Public property | OnOff1SUEN | On/Off 1: SUEN
Public property | OnOff2LEDSlope | On/Off 2: LED Slope
Public property | OnOff2RGBSlope | On/Off 2: RGB Slope
Public property | OnOff2SUB5 | On/Off 2: SUB5
Public property | OnOff2SUB6 | On/Off 2: SUB6
Public property | OnOff2SUB7 | On/Off 2: SUB7
Public property | OnOff2WLED5 | On/Off 2: WLED5
Public property | OnOff2WLED6 | On/Off 2: WLED6
Public property | OnOff2WLED7 | On/Off 2: WLED7
Public property | OnOff3CAI | On/Off 3: CAI
Public property | OnOff3CHG | On/Off 3: CHG
Public property | OnOff3HLCAI | On/Off 3: HLCAI
Public property | OnOff3KYI2C | On/Off 3:KYI2C
Public property | OnOff3MAINI2C | On/Off 3: MAINI2C
Public property | OnOff3SUB8 | On/Off 3: SUB8
Public property | OnOff3TWAIT | On/Off 3: TWAIT
Public property | OnOff3WLED8 | On/Off 3: WLED8
Public property | OnOffControlGPLD1 | On/Off Control: GPLD1
Public property | OnOffControlGPLD2 | On/Off Control: GPLD2
Public property | OnOffControlGPLD3 | On/Off Control: GPLD3
Public property | OnOffControlGPO1 | On/Off Control: GPO1
Public property | RedLEDDimmingCurrentRLED | Red LED Dimming Current: RLED (unit: mA)
Public property | RGBLEDOnOffControlBI2C | RGB LED On/Off Control: BI2C
Public property | RGBLEDOnOffControlGI2C | RGB LED On/Off Control: GI2C
Public property | RGBLEDOnOffControlHLRGB | RGB LED On/Off Control: HLRGB
Public property | RGBLEDOnOffControlRGBEN | RGB LED On/Off Control: RGBEN
Public property | RGBLEDOnOffControlRI2C | RGB LED On/Off Control: RI2C
Public property | SlopeControlMainWLEDDSLP | Slope Control Main WLED: DSLP (unit: ms)
Public property | SlopeControlMainWLEDUSLP | Slope Control Main WLED: USLP (unit: ms)
Public property | SlopeControlRGBLEDDSLP | Slope Control RGB LED: DSLP (unit: ms)
Public property | SlopeControlRGBLEDUSLP | Slope Control RGB LED: USLP (unit: ms)
Top
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ActiveDischargeFuncBoost Property

IRD

Max8930ActiveDischargeFuncBoost Property

Active Discharge Func: Boost

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeActiveDischargeFuncBoost ActiveDischargeFuncBoost { get; set; }
Public Property ActiveDischargeFuncBoost As Max8930TypeActiveDischargeFuncBoost
    Get
    Set
public:
property Max8930TypeActiveDischargeFuncBoost ActiveDischargeFuncBoost {
    Max8930TypeActiveDischargeFuncBoost get ();
    void set (Max8930TypeActiveDischargeFuncBoost value);
}
member ActiveDischargeFuncBoost : Max8930TypeActiveDischargeFuncBoost with get, set

Property Value

Type: Max8930TypeActiveDischargeFuncBoost
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ActiveDischargeFuncLDO1ADIS Property

IRD

Max8930ActiveDischargeFuncLDO1ADIS Property

Active Discharge Func: LDO1ADIS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeActiveDischargeFuncLdo1Adis ActiveDischargeFuncLDO1ADIS { get; set; }
Public Property ActiveDischargeFuncLDO1ADIS As Max8930TypeActiveDischargeFuncLdo1Adis
    Get
    Set
public:
property Max8930TypeActiveDischargeFuncLdo1Adis ActiveDischargeFuncLDO1ADIS {
    Max8930TypeActiveDischargeFuncLdo1Adis get ();
    void set (Max8930TypeActiveDischargeFuncLdo1Adis value);
}
member ActiveDischargeFuncLDO1ADIS : Max8930TypeActiveDischargeFuncLdo1Adis with get, set

Property Value

Type: Max8930TypeActiveDischargeFuncLdo1Adis
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ActiveDischargeFuncLDO2ADIS Property

IRD

Max8930ActiveDischargeFuncLDO2ADIS Property

Active Discharge Func: LDO2ADIS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeActiveDischargeFuncLdo2Adis ActiveDischargeFuncLDO2ADIS { get; set; }
Public Property ActiveDischargeFuncLDO2ADIS As Max8930TypeActiveDischargeFuncLdo2Adis
    Get
    Set
public:
property Max8930TypeActiveDischargeFuncLdo2Adis ActiveDischargeFuncLDO2ADIS {
    Max8930TypeActiveDischargeFuncLdo2Adis get ();
    void set (Max8930TypeActiveDischargeFuncLdo2Adis value);
}
member ActiveDischargeFuncLDO2ADIS : Max8930TypeActiveDischargeFuncLdo2Adis with get, set

Property Value

Type: Max8930TypeActiveDischargeFuncLdo2Adis
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ActiveDischargeFuncLDO3 Property

IRD

Max8930ActiveDischargeFuncLDO3 Property

Active Discharge Func: LDO3

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeActiveDischargeFuncLdo3 ActiveDischargeFuncLDO3 { get; set; }
Public Property ActiveDischargeFuncLDO3 As Max8930TypeActiveDischargeFuncLdo3
    Get
    Set
public:
property Max8930TypeActiveDischargeFuncLdo3 ActiveDischargeFuncLDO3 {
    Max8930TypeActiveDischargeFuncLdo3 get ();
    void set (Max8930TypeActiveDischargeFuncLdo3 value);
}
member ActiveDischargeFuncLDO3 : Max8930TypeActiveDischargeFuncLdo3 with get, set

Property Value

Type: Max8930TypeActiveDischargeFuncLdo3
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ActiveDischargeFuncLDO3ADIS Property

IRD

Max8930ActiveDischargeFuncLDO3ADIS Property

Active Discharge Func: LDO3ADIS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeActiveDischargeFuncLdo3Adis ActiveDischargeFuncLDO3ADIS { get; set; }
Public Property ActiveDischargeFuncLDO3ADIS As Max8930TypeActiveDischargeFuncLdo3Adis
    Get
    Set
public:
property Max8930TypeActiveDischargeFuncLdo3Adis ActiveDischargeFuncLDO3ADIS {
    Max8930TypeActiveDischargeFuncLdo3Adis get ();
    void set (Max8930TypeActiveDischargeFuncLdo3Adis value);
}
member ActiveDischargeFuncLDO3ADIS : Max8930TypeActiveDischargeFuncLdo3Adis with get, set

Property Value

Type: Max8930TypeActiveDischargeFuncLdo3Adis
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ALCControl1ALCYC Property

IRD

Max8930ALCControl1ALCYC Property

ALC Control 1: ALCYC

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeAlcControl1MeasureCycle ALCControl1ALCYC { get; set; }
Public Property ALCControl1ALCYC As Max8930TypeAlcControl1MeasureCycle
    Get
    Set
public:
property Max8930TypeAlcControl1MeasureCycle ALCControl1ALCYC {
    Max8930TypeAlcControl1MeasureCycle get ();
    void set (Max8930TypeAlcControl1MeasureCycle value);
}
member ALCControl1ALCYC : Max8930TypeAlcControl1MeasureCycle with get, set

Property Value

Type: Max8930TypeAlcControl1MeasureCycle
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ALCControl1LSTY Property

IRD

Max8930ALCControl1LSTY Property

ALC Control 1: LSTY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeAlcControl1SensorType ALCControl1LSTY { get; set; }
Public Property ALCControl1LSTY As Max8930TypeAlcControl1SensorType
    Get
    Set
public:
property Max8930TypeAlcControl1SensorType ALCControl1LSTY {
    Max8930TypeAlcControl1SensorType get ();
    void set (Max8930TypeAlcControl1SensorType value);
}
member ALCControl1LSTY : Max8930TypeAlcControl1SensorType with get, set

Property Value

Type: Max8930TypeAlcControl1SensorType
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ALCControl1OST Property

IRD

Max8930ALCControl1OST Property

ALC Control 1: OST

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeAlcControl1OffsetValue ALCControl1OST { get; set; }
Public Property ALCControl1OST As Max8930TypeAlcControl1OffsetValue
    Get
    Set
public:
property Max8930TypeAlcControl1OffsetValue ALCControl1OST {
    Max8930TypeAlcControl1OffsetValue get ();
    void set (Max8930TypeAlcControl1OffsetValue value);
}
member ALCControl1OST : Max8930TypeAlcControl1OffsetValue with get, set

Property Value

Type: Max8930TypeAlcControl1OffsetValue
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ALCControl1SBIAS Property

IRD

Max8930ALCControl1SBIAS Property

ALC Control 1: SBIAS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeAlcControl1Sbias ALCControl1SBIAS { get; set; }
Public Property ALCControl1SBIAS As Max8930TypeAlcControl1Sbias
    Get
    Set
public:
property Max8930TypeAlcControl1Sbias ALCControl1SBIAS {
    Max8930TypeAlcControl1Sbias get ();
    void set (Max8930TypeAlcControl1Sbias value);
}
member ALCControl1SBIAS : Max8930TypeAlcControl1Sbias with get, set

Property Value

Type: Max8930TypeAlcControl1Sbias
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ALCControl2ALDA Property

IRD

Max8930ALCControl2ALDA Property

ALC Control 2: ALDA

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeAlcControl2Alda ALCControl2ALDA { get; }
Public ReadOnly Property ALCControl2ALDA As Max8930TypeAlcControl2Alda
    Get
public:
property Max8930TypeAlcControl2Alda ALCControl2ALDA {
    Max8930TypeAlcControl2Alda get ();
}
member ALCControl2ALDA : Max8930TypeAlcControl2Alda with get

Property Value

Type: Max8930TypeAlcControl2Alda
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.AutoFlush Property

IRD

Max8930AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.BlueLEDDimmingCurrentBLED Property

IRD

Max8930BlueLEDDimmingCurrentBLED Property

Blue LED Dimming Current: BLED (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double BlueLEDDimmingCurrentBLED { get; set; }
Public Property BlueLEDDimmingCurrentBLED As Double
    Get
    Set
public:
property double BlueLEDDimmingCurrentBLED {
    double get ();
    void set (double value);
}
member BlueLEDDimmingCurrentBLED : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ControlALC10CADA Property

IRD

Max8930ControlALC10CADA Property

Control ALC10: CADA (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ControlALC10CADA { get; set; }
Public Property ControlALC10CADA As Double
    Get
    Set
public:
property double ControlALC10CADA {
    double get ();
    void set (double value);
}
member ControlALC10CADA : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ControlALC11CADA Property

IRD

Max8930ControlALC11CADA Property

Control ALC11: CADA (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ControlALC11CADA { get; set; }
Public Property ControlALC11CADA As Double
    Get
    Set
public:
property double ControlALC11CADA {
    double get ();
    void set (double value);
}
member ControlALC11CADA : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ControlALC12CADA Property

IRD

Max8930ControlALC12CADA Property

Control ALC12: CADA (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ControlALC12CADA { get; set; }
Public Property ControlALC12CADA As Double
    Get
    Set
public:
property double ControlALC12CADA {
    double get ();
    void set (double value);
}
member ControlALC12CADA : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ControlALC13CADA Property

IRD

Max8930ControlALC13CADA Property

Control ALC13: CADA (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ControlALC13CADA { get; set; }
Public Property ControlALC13CADA As Double
    Get
    Set
public:
property double ControlALC13CADA {
    double get ();
    void set (double value);
}
member ControlALC13CADA : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ControlALC14CADA Property

IRD

Max8930ControlALC14CADA Property

Control ALC14: CADA (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ControlALC14CADA { get; set; }
Public Property ControlALC14CADA As Double
    Get
    Set
public:
property double ControlALC14CADA {
    double get ();
    void set (double value);
}
member ControlALC14CADA : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ControlALC15CADA Property

IRD

Max8930ControlALC15CADA Property

Control ALC15: CADA (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ControlALC15CADA { get; set; }
Public Property ControlALC15CADA As Double
    Get
    Set
public:
property double ControlALC15CADA {
    double get ();
    void set (double value);
}
member ControlALC15CADA : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ControlALC16CADA Property

IRD

Max8930ControlALC16CADA Property

Control ALC16: CADA (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ControlALC16CADA { get; set; }
Public Property ControlALC16CADA As Double
    Get
    Set
public:
property double ControlALC16CADA {
    double get ();
    void set (double value);
}
member ControlALC16CADA : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ControlALC1CADA Property

IRD

Max8930ControlALC1CADA Property

Control ALC1: CADA (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ControlALC1CADA { get; set; }
Public Property ControlALC1CADA As Double
    Get
    Set
public:
property double ControlALC1CADA {
    double get ();
    void set (double value);
}
member ControlALC1CADA : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ControlALC2CADA Property

IRD

Max8930ControlALC2CADA Property

Control ALC2: CADA (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ControlALC2CADA { get; set; }
Public Property ControlALC2CADA As Double
    Get
    Set
public:
property double ControlALC2CADA {
    double get ();
    void set (double value);
}
member ControlALC2CADA : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ControlALC3CADA Property

IRD

Max8930ControlALC3CADA Property

Control ALC3: CADA (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ControlALC3CADA { get; set; }
Public Property ControlALC3CADA As Double
    Get
    Set
public:
property double ControlALC3CADA {
    double get ();
    void set (double value);
}
member ControlALC3CADA : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ControlALC4CADA Property

IRD

Max8930ControlALC4CADA Property

Control ALC4: CADA (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ControlALC4CADA { get; set; }
Public Property ControlALC4CADA As Double
    Get
    Set
public:
property double ControlALC4CADA {
    double get ();
    void set (double value);
}
member ControlALC4CADA : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ControlALC5CADA Property

IRD

Max8930ControlALC5CADA Property

Control ALC5: CADA (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ControlALC5CADA { get; set; }
Public Property ControlALC5CADA As Double
    Get
    Set
public:
property double ControlALC5CADA {
    double get ();
    void set (double value);
}
member ControlALC5CADA : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ControlALC6CADA Property

IRD

Max8930ControlALC6CADA Property

Control ALC6: CADA (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ControlALC6CADA { get; set; }
Public Property ControlALC6CADA As Double
    Get
    Set
public:
property double ControlALC6CADA {
    double get ();
    void set (double value);
}
member ControlALC6CADA : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ControlALC7CADA Property

IRD

Max8930ControlALC7CADA Property

Control ALC7: CADA (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ControlALC7CADA { get; set; }
Public Property ControlALC7CADA As Double
    Get
    Set
public:
property double ControlALC7CADA {
    double get ();
    void set (double value);
}
member ControlALC7CADA : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ControlALC8CADA Property

IRD

Max8930ControlALC8CADA Property

Control ALC8: CADA (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ControlALC8CADA { get; set; }
Public Property ControlALC8CADA As Double
    Get
    Set
public:
property double ControlALC8CADA {
    double get ();
    void set (double value);
}
member ControlALC8CADA : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.ControlALC9CADA Property

IRD

Max8930ControlALC9CADA Property

Control ALC9: CADA (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ControlALC9CADA { get; set; }
Public Property ControlALC9CADA As Double
    Get
    Set
public:
property double ControlALC9CADA {
    double get ();
    void set (double value);
}
member ControlALC9CADA : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.DimmingCurrentMainWLEDIMLED Property

IRD

Max8930DimmingCurrentMainWLEDIMLED Property

Dimming Current Main WLED: IMLED (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DimmingCurrentMainWLEDIMLED { get; set; }
Public Property DimmingCurrentMainWLEDIMLED As Double
    Get
    Set
public:
property double DimmingCurrentMainWLEDIMLED {
    double get ();
    void set (double value);
}
member DimmingCurrentMainWLEDIMLED : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.DimmingCurrentWLED5ISLED Property

IRD

Max8930DimmingCurrentWLED5ISLED Property

Dimming Current WLED5: ISLED (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DimmingCurrentWLED5ISLED { get; set; }
Public Property DimmingCurrentWLED5ISLED As Double
    Get
    Set
public:
property double DimmingCurrentWLED5ISLED {
    double get ();
    void set (double value);
}
member DimmingCurrentWLED5ISLED : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.DimmingCurrentWLED6ISLED Property

IRD

Max8930DimmingCurrentWLED6ISLED Property

Dimming Current WLED6: ISLED (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DimmingCurrentWLED6ISLED { get; set; }
Public Property DimmingCurrentWLED6ISLED As Double
    Get
    Set
public:
property double DimmingCurrentWLED6ISLED {
    double get ();
    void set (double value);
}
member DimmingCurrentWLED6ISLED : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.DimmingCurrentWLED7ISLED Property

IRD

Max8930DimmingCurrentWLED7ISLED Property

Dimming Current WLED7: ISLED (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DimmingCurrentWLED7ISLED { get; set; }
Public Property DimmingCurrentWLED7ISLED As Double
    Get
    Set
public:
property double DimmingCurrentWLED7ISLED {
    double get ();
    void set (double value);
}
member DimmingCurrentWLED7ISLED : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.DimmingCurrentWLED8ISLED Property

IRD

Max8930DimmingCurrentWLED8ISLED Property

Dimming Current WLED8: ISLED (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DimmingCurrentWLED8ISLED { get; set; }
Public Property DimmingCurrentWLED8ISLED As Double
    Get
    Set
public:
property double DimmingCurrentWLED8ISLED {
    double get ();
    void set (double value);
}
member DimmingCurrentWLED8ISLED : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.GreenLEDDimmingCurrentGLED Property

IRD

Max8930GreenLEDDimmingCurrentGLED Property

Green LED Dimming Current: GLED (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double GreenLEDDimmingCurrentGLED { get; set; }
Public Property GreenLEDDimmingCurrentGLED As Double
    Get
    Set
public:
property double GreenLEDDimmingCurrentGLED {
    double get ();
    void set (double value);
}
member GreenLEDDimmingCurrentGLED : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.KeypadControlALCKYHS Property

IRD

Max8930KeypadControlALCKYHS Property

Keypad Control ALC: KYHS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeKeypadControlAlcHysteresis KeypadControlALCKYHS { get; set; }
Public Property KeypadControlALCKYHS As Max8930TypeKeypadControlAlcHysteresis
    Get
    Set
public:
property Max8930TypeKeypadControlAlcHysteresis KeypadControlALCKYHS {
    Max8930TypeKeypadControlAlcHysteresis get ();
    void set (Max8930TypeKeypadControlAlcHysteresis value);
}
member KeypadControlALCKYHS : Max8930TypeKeypadControlAlcHysteresis with get, set

Property Value

Type: Max8930TypeKeypadControlAlcHysteresis
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.KeypadControlALCKYTH Property

IRD

Max8930KeypadControlALCKYTH Property

Keypad Control ALC: KYTH

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeKeypadControlAlcOffTime KeypadControlALCKYTH { get; set; }
Public Property KeypadControlALCKYTH As Max8930TypeKeypadControlAlcOffTime
    Get
    Set
public:
property Max8930TypeKeypadControlAlcOffTime KeypadControlALCKYTH {
    Max8930TypeKeypadControlAlcOffTime get ();
    void set (Max8930TypeKeypadControlAlcOffTime value);
}
member KeypadControlALCKYTH : Max8930TypeKeypadControlAlcOffTime with get, set

Property Value

Type: Max8930TypeKeypadControlAlcOffTime
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.KeypadControlKYDT Property

IRD

Max8930KeypadControlKYDT Property

Keypad Control: KYDT (unit: %)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double KeypadControlKYDT { get; set; }
Public Property KeypadControlKYDT As Double
    Get
    Set
public:
property double KeypadControlKYDT {
    double get ();
    void set (double value);
}
member KeypadControlKYDT : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.KeypadControlKYSL Property

IRD

Max8930KeypadControlKYSL Property

Keypad Control: KYSL (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeKeypadControlPwmSlopeTime KeypadControlKYSL { get; set; }
Public Property KeypadControlKYSL As Max8930TypeKeypadControlPwmSlopeTime
    Get
    Set
public:
property Max8930TypeKeypadControlPwmSlopeTime KeypadControlKYSL {
    Max8930TypeKeypadControlPwmSlopeTime get ();
    void set (Max8930TypeKeypadControlPwmSlopeTime value);
}
member KeypadControlKYSL : Max8930TypeKeypadControlPwmSlopeTime with get, set

Property Value

Type: Max8930TypeKeypadControlPwmSlopeTime
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.LDO1AndLDO2KYPWM Property

IRD

Max8930LDO1AndLDO2KYPWM Property

LDO1 And LDO2: KYPWM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeLdo1Ldo2PwmKeypad LDO1AndLDO2KYPWM { get; set; }
Public Property LDO1AndLDO2KYPWM As Max8930TypeLdo1Ldo2PwmKeypad
    Get
    Set
public:
property Max8930TypeLdo1Ldo2PwmKeypad LDO1AndLDO2KYPWM {
    Max8930TypeLdo1Ldo2PwmKeypad get ();
    void set (Max8930TypeLdo1Ldo2PwmKeypad value);
}
member LDO1AndLDO2KYPWM : Max8930TypeLdo1Ldo2PwmKeypad with get, set

Property Value

Type: Max8930TypeLdo1Ldo2PwmKeypad
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.LDO1AndLDO2LDO1 Property

IRD

Max8930LDO1AndLDO2LDO1 Property

LDO1 And LDO2: LDO1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeLdo1Ldo2Voltage LDO1AndLDO2LDO1 { get; set; }
Public Property LDO1AndLDO2LDO1 As Max8930TypeLdo1Ldo2Voltage
    Get
    Set
public:
property Max8930TypeLdo1Ldo2Voltage LDO1AndLDO2LDO1 {
    Max8930TypeLdo1Ldo2Voltage get ();
    void set (Max8930TypeLdo1Ldo2Voltage value);
}
member LDO1AndLDO2LDO1 : Max8930TypeLdo1Ldo2Voltage with get, set

Property Value

Type: Max8930TypeLdo1Ldo2Voltage
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.LDO1AndLDO2LDO2 Property

IRD

Max8930LDO1AndLDO2LDO2 Property

LDO1 And LDO2: LDO2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeLdo1Ldo2Voltage LDO1AndLDO2LDO2 { get; set; }
Public Property LDO1AndLDO2LDO2 As Max8930TypeLdo1Ldo2Voltage
    Get
    Set
public:
property Max8930TypeLdo1Ldo2Voltage LDO1AndLDO2LDO2 {
    Max8930TypeLdo1Ldo2Voltage get ();
    void set (Max8930TypeLdo1Ldo2Voltage value);
}
member LDO1AndLDO2LDO2 : Max8930TypeLdo1Ldo2Voltage with get, set

Property Value

Type: Max8930TypeLdo1Ldo2Voltage
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff1ALCEN Property

IRD

Max8930OnOff1ALCEN Property

On/Off 1: ALCEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff1AlcWled OnOff1ALCEN { get; set; }
Public Property OnOff1ALCEN As Max8930TypeOnOff1AlcWled
    Get
    Set
public:
property Max8930TypeOnOff1AlcWled OnOff1ALCEN {
    Max8930TypeOnOff1AlcWled get ();
    void set (Max8930TypeOnOff1AlcWled value);
}
member OnOff1ALCEN : Max8930TypeOnOff1AlcWled with get, set

Property Value

Type: Max8930TypeOnOff1AlcWled
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff1KBALC Property

IRD

Max8930OnOff1KBALC Property

On/Off 1: KBALC

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff1AlcKeypad OnOff1KBALC { get; set; }
Public Property OnOff1KBALC As Max8930TypeOnOff1AlcKeypad
    Get
    Set
public:
property Max8930TypeOnOff1AlcKeypad OnOff1KBALC {
    Max8930TypeOnOff1AlcKeypad get ();
    void set (Max8930TypeOnOff1AlcKeypad value);
}
member OnOff1KBALC : Max8930TypeOnOff1AlcKeypad with get, set

Property Value

Type: Max8930TypeOnOff1AlcKeypad
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff1LDO1 Property

IRD

Max8930OnOff1LDO1 Property

On/Off 1: LDO1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff1Ldo1Output OnOff1LDO1 { get; set; }
Public Property OnOff1LDO1 As Max8930TypeOnOff1Ldo1Output
    Get
    Set
public:
property Max8930TypeOnOff1Ldo1Output OnOff1LDO1 {
    Max8930TypeOnOff1Ldo1Output get ();
    void set (Max8930TypeOnOff1Ldo1Output value);
}
member OnOff1LDO1 : Max8930TypeOnOff1Ldo1Output with get, set

Property Value

Type: Max8930TypeOnOff1Ldo1Output
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff1LDO2 Property

IRD

Max8930OnOff1LDO2 Property

On/Off 1: LDO2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff1Ldo2Output OnOff1LDO2 { get; set; }
Public Property OnOff1LDO2 As Max8930TypeOnOff1Ldo2Output
    Get
    Set
public:
property Max8930TypeOnOff1Ldo2Output OnOff1LDO2 {
    Max8930TypeOnOff1Ldo2Output get ();
    void set (Max8930TypeOnOff1Ldo2Output value);
}
member OnOff1LDO2 : Max8930TypeOnOff1Ldo2Output with get, set

Property Value

Type: Max8930TypeOnOff1Ldo2Output
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff1LDO3 Property

IRD

Max8930OnOff1LDO3 Property

On/Off 1: LDO3

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff1Ldo3Output OnOff1LDO3 { get; set; }
Public Property OnOff1LDO3 As Max8930TypeOnOff1Ldo3Output
    Get
    Set
public:
property Max8930TypeOnOff1Ldo3Output OnOff1LDO3 {
    Max8930TypeOnOff1Ldo3Output get ();
    void set (Max8930TypeOnOff1Ldo3Output value);
}
member OnOff1LDO3 : Max8930TypeOnOff1Ldo3Output with get, set

Property Value

Type: Max8930TypeOnOff1Ldo3Output
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff1MainWLED Property

IRD

Max8930OnOff1MainWLED Property

On/Off 1: Main WLED

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff1MainWled OnOff1MainWLED { get; set; }
Public Property OnOff1MainWLED As Max8930TypeOnOff1MainWled
    Get
    Set
public:
property Max8930TypeOnOff1MainWled OnOff1MainWLED {
    Max8930TypeOnOff1MainWled get ();
    void set (Max8930TypeOnOff1MainWled value);
}
member OnOff1MainWLED : Max8930TypeOnOff1MainWled with get, set

Property Value

Type: Max8930TypeOnOff1MainWled
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff1RESET Property

IRD

Max8930OnOff1RESET Property

On/Off 1: RESET

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff1Reset OnOff1RESET { get; set; }
Public Property OnOff1RESET As Max8930TypeOnOff1Reset
    Get
    Set
public:
property Max8930TypeOnOff1Reset OnOff1RESET {
    Max8930TypeOnOff1Reset get ();
    void set (Max8930TypeOnOff1Reset value);
}
member OnOff1RESET : Max8930TypeOnOff1Reset with get, set

Property Value

Type: Max8930TypeOnOff1Reset
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff1SUEN Property

IRD

Max8930OnOff1SUEN Property

On/Off 1: SUEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff1BoostOutput OnOff1SUEN { get; set; }
Public Property OnOff1SUEN As Max8930TypeOnOff1BoostOutput
    Get
    Set
public:
property Max8930TypeOnOff1BoostOutput OnOff1SUEN {
    Max8930TypeOnOff1BoostOutput get ();
    void set (Max8930TypeOnOff1BoostOutput value);
}
member OnOff1SUEN : Max8930TypeOnOff1BoostOutput with get, set

Property Value

Type: Max8930TypeOnOff1BoostOutput
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff2LEDSlope Property

IRD

Max8930OnOff2LEDSlope Property

On/Off 2: LED Slope

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff2LedSlope OnOff2LEDSlope { get; set; }
Public Property OnOff2LEDSlope As Max8930TypeOnOff2LedSlope
    Get
    Set
public:
property Max8930TypeOnOff2LedSlope OnOff2LEDSlope {
    Max8930TypeOnOff2LedSlope get ();
    void set (Max8930TypeOnOff2LedSlope value);
}
member OnOff2LEDSlope : Max8930TypeOnOff2LedSlope with get, set

Property Value

Type: Max8930TypeOnOff2LedSlope
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff2RGBSlope Property

IRD

Max8930OnOff2RGBSlope Property

On/Off 2: RGB Slope

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff2RgbSlope OnOff2RGBSlope { get; set; }
Public Property OnOff2RGBSlope As Max8930TypeOnOff2RgbSlope
    Get
    Set
public:
property Max8930TypeOnOff2RgbSlope OnOff2RGBSlope {
    Max8930TypeOnOff2RgbSlope get ();
    void set (Max8930TypeOnOff2RgbSlope value);
}
member OnOff2RGBSlope : Max8930TypeOnOff2RgbSlope with get, set

Property Value

Type: Max8930TypeOnOff2RgbSlope
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff2SUB5 Property

IRD

Max8930OnOff2SUB5 Property

On/Off 2: SUB5

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff2Sub5 OnOff2SUB5 { get; set; }
Public Property OnOff2SUB5 As Max8930TypeOnOff2Sub5
    Get
    Set
public:
property Max8930TypeOnOff2Sub5 OnOff2SUB5 {
    Max8930TypeOnOff2Sub5 get ();
    void set (Max8930TypeOnOff2Sub5 value);
}
member OnOff2SUB5 : Max8930TypeOnOff2Sub5 with get, set

Property Value

Type: Max8930TypeOnOff2Sub5
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff2SUB6 Property

IRD

Max8930OnOff2SUB6 Property

On/Off 2: SUB6

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff2Sub6 OnOff2SUB6 { get; set; }
Public Property OnOff2SUB6 As Max8930TypeOnOff2Sub6
    Get
    Set
public:
property Max8930TypeOnOff2Sub6 OnOff2SUB6 {
    Max8930TypeOnOff2Sub6 get ();
    void set (Max8930TypeOnOff2Sub6 value);
}
member OnOff2SUB6 : Max8930TypeOnOff2Sub6 with get, set

Property Value

Type: Max8930TypeOnOff2Sub6
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff2SUB7 Property

IRD

Max8930OnOff2SUB7 Property

On/Off 2: SUB7

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff2Sub7 OnOff2SUB7 { get; set; }
Public Property OnOff2SUB7 As Max8930TypeOnOff2Sub7
    Get
    Set
public:
property Max8930TypeOnOff2Sub7 OnOff2SUB7 {
    Max8930TypeOnOff2Sub7 get ();
    void set (Max8930TypeOnOff2Sub7 value);
}
member OnOff2SUB7 : Max8930TypeOnOff2Sub7 with get, set

Property Value

Type: Max8930TypeOnOff2Sub7
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff2WLED5 Property

IRD

Max8930OnOff2WLED5 Property

On/Off 2: WLED5

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff2Wled5 OnOff2WLED5 { get; set; }
Public Property OnOff2WLED5 As Max8930TypeOnOff2Wled5
    Get
    Set
public:
property Max8930TypeOnOff2Wled5 OnOff2WLED5 {
    Max8930TypeOnOff2Wled5 get ();
    void set (Max8930TypeOnOff2Wled5 value);
}
member OnOff2WLED5 : Max8930TypeOnOff2Wled5 with get, set

Property Value

Type: Max8930TypeOnOff2Wled5
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff2WLED6 Property

IRD

Max8930OnOff2WLED6 Property

On/Off 2: WLED6

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff2Wled6 OnOff2WLED6 { get; set; }
Public Property OnOff2WLED6 As Max8930TypeOnOff2Wled6
    Get
    Set
public:
property Max8930TypeOnOff2Wled6 OnOff2WLED6 {
    Max8930TypeOnOff2Wled6 get ();
    void set (Max8930TypeOnOff2Wled6 value);
}
member OnOff2WLED6 : Max8930TypeOnOff2Wled6 with get, set

Property Value

Type: Max8930TypeOnOff2Wled6
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff2WLED7 Property

IRD

Max8930OnOff2WLED7 Property

On/Off 2: WLED7

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff2Wled7 OnOff2WLED7 { get; set; }
Public Property OnOff2WLED7 As Max8930TypeOnOff2Wled7
    Get
    Set
public:
property Max8930TypeOnOff2Wled7 OnOff2WLED7 {
    Max8930TypeOnOff2Wled7 get ();
    void set (Max8930TypeOnOff2Wled7 value);
}
member OnOff2WLED7 : Max8930TypeOnOff2Wled7 with get, set

Property Value

Type: Max8930TypeOnOff2Wled7
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff3CAI Property

IRD

Max8930OnOff3CAI Property

On/Off 3: CAI

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff3CaiDimming OnOff3CAI { get; set; }
Public Property OnOff3CAI As Max8930TypeOnOff3CaiDimming
    Get
    Set
public:
property Max8930TypeOnOff3CaiDimming OnOff3CAI {
    Max8930TypeOnOff3CaiDimming get ();
    void set (Max8930TypeOnOff3CaiDimming value);
}
member OnOff3CAI : Max8930TypeOnOff3CaiDimming with get, set

Property Value

Type: Max8930TypeOnOff3CaiDimming
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff3CHG Property

IRD

Max8930OnOff3CHG Property

On/Off 3: CHG

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff3ChargeIndicator OnOff3CHG { get; set; }
Public Property OnOff3CHG As Max8930TypeOnOff3ChargeIndicator
    Get
    Set
public:
property Max8930TypeOnOff3ChargeIndicator OnOff3CHG {
    Max8930TypeOnOff3ChargeIndicator get ();
    void set (Max8930TypeOnOff3ChargeIndicator value);
}
member OnOff3CHG : Max8930TypeOnOff3ChargeIndicator with get, set

Property Value

Type: Max8930TypeOnOff3ChargeIndicator
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff3HLCAI Property

IRD

Max8930OnOff3HLCAI Property

On/Off 3: HLCAI

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff3WledHighLow OnOff3HLCAI { get; set; }
Public Property OnOff3HLCAI As Max8930TypeOnOff3WledHighLow
    Get
    Set
public:
property Max8930TypeOnOff3WledHighLow OnOff3HLCAI {
    Max8930TypeOnOff3WledHighLow get ();
    void set (Max8930TypeOnOff3WledHighLow value);
}
member OnOff3HLCAI : Max8930TypeOnOff3WledHighLow with get, set

Property Value

Type: Max8930TypeOnOff3WledHighLow
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff3KYI2C Property

IRD

Max8930OnOff3KYI2C Property

On/Off 3:KYI2C

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff3I2cKeypad OnOff3KYI2C { get; set; }
Public Property OnOff3KYI2C As Max8930TypeOnOff3I2cKeypad
    Get
    Set
public:
property Max8930TypeOnOff3I2cKeypad OnOff3KYI2C {
    Max8930TypeOnOff3I2cKeypad get ();
    void set (Max8930TypeOnOff3I2cKeypad value);
}
member OnOff3KYI2C : Max8930TypeOnOff3I2cKeypad with get, set

Property Value

Type: Max8930TypeOnOff3I2cKeypad
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff3MAINI2C Property

IRD

Max8930OnOff3MAINI2C Property

On/Off 3: MAINI2C

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff3MainI2cDimming OnOff3MAINI2C { get; set; }
Public Property OnOff3MAINI2C As Max8930TypeOnOff3MainI2cDimming
    Get
    Set
public:
property Max8930TypeOnOff3MainI2cDimming OnOff3MAINI2C {
    Max8930TypeOnOff3MainI2cDimming get ();
    void set (Max8930TypeOnOff3MainI2cDimming value);
}
member OnOff3MAINI2C : Max8930TypeOnOff3MainI2cDimming with get, set

Property Value

Type: Max8930TypeOnOff3MainI2cDimming
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff3SUB8 Property

IRD

Max8930OnOff3SUB8 Property

On/Off 3: SUB8

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff3Sub8 OnOff3SUB8 { get; set; }
Public Property OnOff3SUB8 As Max8930TypeOnOff3Sub8
    Get
    Set
public:
property Max8930TypeOnOff3Sub8 OnOff3SUB8 {
    Max8930TypeOnOff3Sub8 get ();
    void set (Max8930TypeOnOff3Sub8 value);
}
member OnOff3SUB8 : Max8930TypeOnOff3Sub8 with get, set

Property Value

Type: Max8930TypeOnOff3Sub8
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff3TWAIT Property

IRD

Max8930OnOff3TWAIT Property

On/Off 3: TWAIT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff3WaitTime OnOff3TWAIT { get; set; }
Public Property OnOff3TWAIT As Max8930TypeOnOff3WaitTime
    Get
    Set
public:
property Max8930TypeOnOff3WaitTime OnOff3TWAIT {
    Max8930TypeOnOff3WaitTime get ();
    void set (Max8930TypeOnOff3WaitTime value);
}
member OnOff3TWAIT : Max8930TypeOnOff3WaitTime with get, set

Property Value

Type: Max8930TypeOnOff3WaitTime
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOff3WLED8 Property

IRD

Max8930OnOff3WLED8 Property

On/Off 3: WLED8

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnOff3Wled8 OnOff3WLED8 { get; set; }
Public Property OnOff3WLED8 As Max8930TypeOnOff3Wled8
    Get
    Set
public:
property Max8930TypeOnOff3Wled8 OnOff3WLED8 {
    Max8930TypeOnOff3Wled8 get ();
    void set (Max8930TypeOnOff3Wled8 value);
}
member OnOff3WLED8 : Max8930TypeOnOff3Wled8 with get, set

Property Value

Type: Max8930TypeOnOff3Wled8
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOffControlGPLD1 Property

IRD

Max8930OnOffControlGPLD1 Property

On/Off Control: GPLD1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnoffControlOutputLdo1 OnOffControlGPLD1 { get; set; }
Public Property OnOffControlGPLD1 As Max8930TypeOnoffControlOutputLdo1
    Get
    Set
public:
property Max8930TypeOnoffControlOutputLdo1 OnOffControlGPLD1 {
    Max8930TypeOnoffControlOutputLdo1 get ();
    void set (Max8930TypeOnoffControlOutputLdo1 value);
}
member OnOffControlGPLD1 : Max8930TypeOnoffControlOutputLdo1 with get, set

Property Value

Type: Max8930TypeOnoffControlOutputLdo1
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOffControlGPLD2 Property

IRD

Max8930OnOffControlGPLD2 Property

On/Off Control: GPLD2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnoffControlOutputLdo2 OnOffControlGPLD2 { get; set; }
Public Property OnOffControlGPLD2 As Max8930TypeOnoffControlOutputLdo2
    Get
    Set
public:
property Max8930TypeOnoffControlOutputLdo2 OnOffControlGPLD2 {
    Max8930TypeOnoffControlOutputLdo2 get ();
    void set (Max8930TypeOnoffControlOutputLdo2 value);
}
member OnOffControlGPLD2 : Max8930TypeOnoffControlOutputLdo2 with get, set

Property Value

Type: Max8930TypeOnoffControlOutputLdo2
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOffControlGPLD3 Property

IRD

Max8930OnOffControlGPLD3 Property

On/Off Control: GPLD3

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnoffControlOutputLdo3 OnOffControlGPLD3 { get; set; }
Public Property OnOffControlGPLD3 As Max8930TypeOnoffControlOutputLdo3
    Get
    Set
public:
property Max8930TypeOnoffControlOutputLdo3 OnOffControlGPLD3 {
    Max8930TypeOnoffControlOutputLdo3 get ();
    void set (Max8930TypeOnoffControlOutputLdo3 value);
}
member OnOffControlGPLD3 : Max8930TypeOnoffControlOutputLdo3 with get, set

Property Value

Type: Max8930TypeOnoffControlOutputLdo3
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.OnOffControlGPO1 Property

IRD

Max8930OnOffControlGPO1 Property

On/Off Control: GPO1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeOnoffControlMode OnOffControlGPO1 { get; set; }
Public Property OnOffControlGPO1 As Max8930TypeOnoffControlMode
    Get
    Set
public:
property Max8930TypeOnoffControlMode OnOffControlGPO1 {
    Max8930TypeOnoffControlMode get ();
    void set (Max8930TypeOnoffControlMode value);
}
member OnOffControlGPO1 : Max8930TypeOnoffControlMode with get, set

Property Value

Type: Max8930TypeOnoffControlMode
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.RedLEDDimmingCurrentRLED Property

IRD

Max8930RedLEDDimmingCurrentRLED Property

Red LED Dimming Current: RLED (unit: mA)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RedLEDDimmingCurrentRLED { get; set; }
Public Property RedLEDDimmingCurrentRLED As Double
    Get
    Set
public:
property double RedLEDDimmingCurrentRLED {
    double get ();
    void set (double value);
}
member RedLEDDimmingCurrentRLED : float with get, set

Property Value

Type: Double
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.RGBLEDOnOffControlBI2C Property

IRD

Max8930RGBLEDOnOffControlBI2C Property

RGB LED On/Off Control: BI2C

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeRgbLedOnoffBlueLed RGBLEDOnOffControlBI2C { get; set; }
Public Property RGBLEDOnOffControlBI2C As Max8930TypeRgbLedOnoffBlueLed
    Get
    Set
public:
property Max8930TypeRgbLedOnoffBlueLed RGBLEDOnOffControlBI2C {
    Max8930TypeRgbLedOnoffBlueLed get ();
    void set (Max8930TypeRgbLedOnoffBlueLed value);
}
member RGBLEDOnOffControlBI2C : Max8930TypeRgbLedOnoffBlueLed with get, set

Property Value

Type: Max8930TypeRgbLedOnoffBlueLed
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.RGBLEDOnOffControlGI2C Property

IRD

Max8930RGBLEDOnOffControlGI2C Property

RGB LED On/Off Control: GI2C

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeRgbLedOnoffGreenLed RGBLEDOnOffControlGI2C { get; set; }
Public Property RGBLEDOnOffControlGI2C As Max8930TypeRgbLedOnoffGreenLed
    Get
    Set
public:
property Max8930TypeRgbLedOnoffGreenLed RGBLEDOnOffControlGI2C {
    Max8930TypeRgbLedOnoffGreenLed get ();
    void set (Max8930TypeRgbLedOnoffGreenLed value);
}
member RGBLEDOnOffControlGI2C : Max8930TypeRgbLedOnoffGreenLed with get, set

Property Value

Type: Max8930TypeRgbLedOnoffGreenLed
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.RGBLEDOnOffControlHLRGB Property

IRD

Max8930RGBLEDOnOffControlHLRGB Property

RGB LED On/Off Control: HLRGB

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeRgbLedOnoffActive RGBLEDOnOffControlHLRGB { get; set; }
Public Property RGBLEDOnOffControlHLRGB As Max8930TypeRgbLedOnoffActive
    Get
    Set
public:
property Max8930TypeRgbLedOnoffActive RGBLEDOnOffControlHLRGB {
    Max8930TypeRgbLedOnoffActive get ();
    void set (Max8930TypeRgbLedOnoffActive value);
}
member RGBLEDOnOffControlHLRGB : Max8930TypeRgbLedOnoffActive with get, set

Property Value

Type: Max8930TypeRgbLedOnoffActive
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.RGBLEDOnOffControlRGBEN Property

IRD

Max8930RGBLEDOnOffControlRGBEN Property

RGB LED On/Off Control: RGBEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeRgbLedOnoffRgbEnable RGBLEDOnOffControlRGBEN { get; set; }
Public Property RGBLEDOnOffControlRGBEN As Max8930TypeRgbLedOnoffRgbEnable
    Get
    Set
public:
property Max8930TypeRgbLedOnoffRgbEnable RGBLEDOnOffControlRGBEN {
    Max8930TypeRgbLedOnoffRgbEnable get ();
    void set (Max8930TypeRgbLedOnoffRgbEnable value);
}
member RGBLEDOnOffControlRGBEN : Max8930TypeRgbLedOnoffRgbEnable with get, set

Property Value

Type: Max8930TypeRgbLedOnoffRgbEnable
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.RGBLEDOnOffControlRI2C Property

IRD

Max8930RGBLEDOnOffControlRI2C Property

RGB LED On/Off Control: RI2C

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeRgbLedOnoffRedLed RGBLEDOnOffControlRI2C { get; set; }
Public Property RGBLEDOnOffControlRI2C As Max8930TypeRgbLedOnoffRedLed
    Get
    Set
public:
property Max8930TypeRgbLedOnoffRedLed RGBLEDOnOffControlRI2C {
    Max8930TypeRgbLedOnoffRedLed get ();
    void set (Max8930TypeRgbLedOnoffRedLed value);
}
member RGBLEDOnOffControlRI2C : Max8930TypeRgbLedOnoffRedLed with get, set

Property Value

Type: Max8930TypeRgbLedOnoffRedLed
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.SlopeControlMainWLEDDSLP Property

IRD

Max8930SlopeControlMainWLEDDSLP Property

Slope Control Main WLED: DSLP (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeSlopeControlUpDown SlopeControlMainWLEDDSLP { get; set; }
Public Property SlopeControlMainWLEDDSLP As Max8930TypeSlopeControlUpDown
    Get
    Set
public:
property Max8930TypeSlopeControlUpDown SlopeControlMainWLEDDSLP {
    Max8930TypeSlopeControlUpDown get ();
    void set (Max8930TypeSlopeControlUpDown value);
}
member SlopeControlMainWLEDDSLP : Max8930TypeSlopeControlUpDown with get, set

Property Value

Type: Max8930TypeSlopeControlUpDown
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.SlopeControlMainWLEDUSLP Property

IRD

Max8930SlopeControlMainWLEDUSLP Property

Slope Control Main WLED: USLP (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeSlopeControlUpDown SlopeControlMainWLEDUSLP { get; set; }
Public Property SlopeControlMainWLEDUSLP As Max8930TypeSlopeControlUpDown
    Get
    Set
public:
property Max8930TypeSlopeControlUpDown SlopeControlMainWLEDUSLP {
    Max8930TypeSlopeControlUpDown get ();
    void set (Max8930TypeSlopeControlUpDown value);
}
member SlopeControlMainWLEDUSLP : Max8930TypeSlopeControlUpDown with get, set

Property Value

Type: Max8930TypeSlopeControlUpDown
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.SlopeControlRGBLEDDSLP Property

IRD

Max8930SlopeControlRGBLEDDSLP Property

Slope Control RGB LED: DSLP (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeSlopeControlUpDown SlopeControlRGBLEDDSLP { get; set; }
Public Property SlopeControlRGBLEDDSLP As Max8930TypeSlopeControlUpDown
    Get
    Set
public:
property Max8930TypeSlopeControlUpDown SlopeControlRGBLEDDSLP {
    Max8930TypeSlopeControlUpDown get ();
    void set (Max8930TypeSlopeControlUpDown value);
}
member SlopeControlRGBLEDDSLP : Max8930TypeSlopeControlUpDown with get, set

Property Value

Type: Max8930TypeSlopeControlUpDown
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.SlopeControlRGBLEDUSLP Property

IRD

Max8930SlopeControlRGBLEDUSLP Property

Slope Control RGB LED: USLP (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max8930TypeSlopeControlUpDown SlopeControlRGBLEDUSLP { get; set; }
Public Property SlopeControlRGBLEDUSLP As Max8930TypeSlopeControlUpDown
    Get
    Set
public:
property Max8930TypeSlopeControlUpDown SlopeControlRGBLEDUSLP {
    Max8930TypeSlopeControlUpDown get ();
    void set (Max8930TypeSlopeControlUpDown value);
}
member SlopeControlRGBLEDUSLP : Max8930TypeSlopeControlUpDown with get, set

Property Value

Type: Max8930TypeSlopeControlUpDown
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930 Methods

The Max8930 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.Flush Method

IRD

Max8930Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max8930 Class
telos.Ird.Maxim Namespace


Max8930.TypeActiveDischargeFuncBoost Enumeration

IRD

Max8930TypeActiveDischargeFuncBoost Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActiveDischargeFuncBoost
Public Enumeration TypeActiveDischargeFuncBoost
public enum class TypeActiveDischargeFuncBoost
type TypeActiveDischargeFuncBoost
Members
Member name | Value | Description
Value_13_0 | 0 | 13.0
Value_13_5 | 1 | 13.5
Value_14_0 | 2 | 14.0
Value_14_5 | 3 | 14.5
Value_15_0 | 4 | 15.0
Value_15_5 | 5 | 15.5
Value_16_0 | 6 | 16.0
Value_16_5 | 7 | 16.5
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeActiveDischargeFuncLdo1Adis Enumeration

IRD

Max8930TypeActiveDischargeFuncLdo1Adis Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActiveDischargeFuncLdo1Adis
Public Enumeration TypeActiveDischargeFuncLdo1Adis
public enum class TypeActiveDischargeFuncLdo1Adis
type TypeActiveDischargeFuncLdo1Adis
Members
Member name | Value | Description
LDO1ActiveDischargeDisable | 0 | LDO1 Active Discharge: Disable
LDO1ActiveDischargeEnable | 1 | LDO1 Active Discharge: Enable
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeActiveDischargeFuncLdo2Adis Enumeration

IRD

Max8930TypeActiveDischargeFuncLdo2Adis Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActiveDischargeFuncLdo2Adis
Public Enumeration TypeActiveDischargeFuncLdo2Adis
public enum class TypeActiveDischargeFuncLdo2Adis
type TypeActiveDischargeFuncLdo2Adis
Members
Member name | Value | Description
LDO2ActiveDischargeDisable | 0 | LDO2 Active Discharge: Disable
LDO2ActiveDischargeEnable | 1 | LDO2 Active Discharge: Enable
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeActiveDischargeFuncLdo3 Enumeration

IRD

Max8930TypeActiveDischargeFuncLdo3 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActiveDischargeFuncLdo3
Public Enumeration TypeActiveDischargeFuncLdo3
public enum class TypeActiveDischargeFuncLdo3
type TypeActiveDischargeFuncLdo3
Members
Member name | Value | Description
Value_1_2 | 0 | 1.2
Value_1_5 | 1 | 1.5
Value_1_8 | 2 | 1.8
Value_2_5 | 3 | 2.5
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeActiveDischargeFuncLdo3Adis Enumeration

IRD

Max8930TypeActiveDischargeFuncLdo3Adis Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeActiveDischargeFuncLdo3Adis
Public Enumeration TypeActiveDischargeFuncLdo3Adis
public enum class TypeActiveDischargeFuncLdo3Adis
type TypeActiveDischargeFuncLdo3Adis
Members
Member name | Value | Description
LDO3ActiveDischargeDisable | 0 | LDO3 Active Discharge: Disable
LDO3ActiveDischargeEnable | 1 | LDO3 Active Discharge: Enable
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeAlcControl1MeasureCycle Enumeration

IRD

Max8930TypeAlcControl1MeasureCycle Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlcControl1MeasureCycle
Public Enumeration TypeAlcControl1MeasureCycle
public enum class TypeAlcControl1MeasureCycle
type TypeAlcControl1MeasureCycle
Members
Member name | Value | Description
Value_0_52 | 0 | 0.52
Value_1_05 | 1 | 1.05
Value_1_57 | 2 | 1.57
Value_2_10 | 3 | 2.10
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeAlcControl1OffsetValue Enumeration

IRD

Max8930TypeAlcControl1OffsetValue Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlcControl1OffsetValue
Public Enumeration TypeAlcControl1OffsetValue
public enum class TypeAlcControl1OffsetValue
type TypeAlcControl1OffsetValue
Members
Member name | Value | Description
NoOffset | 0 | No Offset
Value_1LSB | 1 | +1 LSB
Value_2LSB | 2 | +2 LSB
Value_3LSB | 3 | +3 LSB
Value_4LSB | 4 | +4 LSB
Value_5LSB | 5 | +5 LSB
Value_6LSB | 6 | +6 LSB
Value_7LSB | 7 | +7 LSB
Value_8LSB | 8 | -8 LSB
Value_7LSB__1 | 9 | -7 LSB
Value_6LSB__1 | 10 | -6 LSB
Value_5LSB__1 | 11 | -5 LSB
Value_4LSB__1 | 12 | -4 LSB
Value_3LSB__1 | 13 | -3 LSB
Value_2LSB__1 | 14 | -2 LSB
Value_1LSB__1 | 15 | -1 LSB
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeAlcControl1Sbias Enumeration

IRD

Max8930TypeAlcControl1Sbias Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlcControl1Sbias
Public Enumeration TypeAlcControl1Sbias
public enum class TypeAlcControl1Sbias
type TypeAlcControl1Sbias
Members
Member name | Value | Description
SBIASAlwaysOn | 0 | SBIAS: Always On
SBIASMeasurementCycleIsSynchronized | 1 | SBIAS: Measurement Cycle Is Synchronized
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeAlcControl1SensorType Enumeration

IRD

Max8930TypeAlcControl1SensorType Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlcControl1SensorType
Public Enumeration TypeAlcControl1SensorType
public enum class TypeAlcControl1SensorType
type TypeAlcControl1SensorType
Members
Member name | Value | Description
LinearTypeSensor | 0 | Linear Type Sensor
LOGTypeOfLightSensorIsConnected | 1 | LOG Type Of Light Sensor Is Connected
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeAlcControl2Alda Enumeration

IRD

Max8930TypeAlcControl2Alda Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlcControl2Alda
Public Enumeration TypeAlcControl2Alda
public enum class TypeAlcControl2Alda
type TypeAlcControl2Alda
Members
Member name | Value | Description
Value_0hLevel | 0 | 0h Level
Value_1hLevel | 1 | 1h Level
Value_2hLevel | 2 | 2h Level
Value_3hLevel | 3 | 3h Level
Value_4hLevel | 4 | 4h Level
Value_5hLevel | 5 | 5h Level
Value_6hLevel | 6 | 6h Level
Value_7hLevel | 7 | 7h Level
Value_8hLevel | 8 | 8h Level
Value_9hLevel | 9 | 9h Level
AhLevel | 10 | Ah Level
BhLevel | 11 | Bh Level
ChLevel | 12 | Ch Level
DhLevel | 13 | Dh Level
EhLevel | 14 | Eh Level
FhLevel | 15 | Fh Level
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeKeypadControlAlcHysteresis Enumeration

IRD

Max8930TypeKeypadControlAlcHysteresis Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeKeypadControlAlcHysteresis
Public Enumeration TypeKeypadControlAlcHysteresis
public enum class TypeKeypadControlAlcHysteresis
type TypeKeypadControlAlcHysteresis
Members
Member name | Value | Description
NoHysteresis | 0 | No Hysteresis
Value_2h | 1 | 2h
Value_3h | 2 | 3h
Value_4h | 3 | 4h
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeKeypadControlAlcOffTime Enumeration

IRD

Max8930TypeKeypadControlAlcOffTime Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeKeypadControlAlcOffTime
Public Enumeration TypeKeypadControlAlcOffTime
public enum class TypeKeypadControlAlcOffTime
type TypeKeypadControlAlcOffTime
Members
Member name | Value | Description
Value_0hOff | 0 | 0h Off
Value_1hOff | 1 | 1h Off
Value_2hOff | 2 | 2h Off
Value_3hOff | 3 | 3h Off
Value_4hOff | 4 | 4h Off
Value_5hOff | 5 | 5h Off
Value_6hOff | 6 | 6h Off
Value_7hOff | 7 | 7h Off
Value_8hOff | 8 | 8h Off
Value_9hOff | 9 | 9h Off
AhOff | 10 | Ah Off
BhOff | 11 | Bh Off
ChOff | 12 | Ch Off
DhOff | 13 | Dh Off
EhOff | 14 | Eh Off
FhOff | 15 | Fh Off
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeKeypadControlPwmSlopeTime Enumeration

IRD

Max8930TypeKeypadControlPwmSlopeTime Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeKeypadControlPwmSlopeTime
Public Enumeration TypeKeypadControlPwmSlopeTime
public enum class TypeKeypadControlPwmSlopeTime
type TypeKeypadControlPwmSlopeTime
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_32 | 1 | 32
Value_64 | 2 | 64
Value_128 | 3 | 128
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeLdo1Ldo2PwmKeypad Enumeration

IRD

Max8930TypeLdo1Ldo2PwmKeypad Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLdo1Ldo2PwmKeypad
Public Enumeration TypeLdo1Ldo2PwmKeypad
public enum class TypeLdo1Ldo2PwmKeypad
type TypeLdo1Ldo2PwmKeypad
Members
Member name | Value | Description
PWMForKeypadOff | 0 | PWM For Keypad: Off
PWMForKeypadOn | 1 | PWM For Keypad: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeLdo1Ldo2Voltage Enumeration

IRD

Max8930TypeLdo1Ldo2Voltage Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLdo1Ldo2Voltage
Public Enumeration TypeLdo1Ldo2Voltage
public enum class TypeLdo1Ldo2Voltage
type TypeLdo1Ldo2Voltage
Members
Member name | Value | Description
Value_2_3 | 0 | 2.3
Value_2_5 | 1 | 2.5
Value_2_6 | 2 | 2.6
Value_2_7 | 3 | 2.7
Value_2_8 | 4 | 2.8
Value_2_9 | 5 | 2.9
Value_3_0 | 6 | 3.0
Value_3_1 | 7 | 3.1
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff1AlcKeypad Enumeration

IRD

Max8930TypeOnOff1AlcKeypad Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff1AlcKeypad
Public Enumeration TypeOnOff1AlcKeypad
public enum class TypeOnOff1AlcKeypad
type TypeOnOff1AlcKeypad
Members
Member name | Value | Description
ALCForKeypadOff | 0 | ALC For Keypad: Off
AlcForKeypadOn | 1 | Alc For Keypad: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff1AlcWled Enumeration

IRD

Max8930TypeOnOff1AlcWled Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff1AlcWled
Public Enumeration TypeOnOff1AlcWled
public enum class TypeOnOff1AlcWled
type TypeOnOff1AlcWled
Members
Member name | Value | Description
ALCForMainWLEDOff | 0 | ALC For Main WLED: Off
ALCForMainWLEDOn | 1 | ALC For Main WLED: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff1BoostOutput Enumeration

IRD

Max8930TypeOnOff1BoostOutput Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff1BoostOutput
Public Enumeration TypeOnOff1BoostOutput
public enum class TypeOnOff1BoostOutput
type TypeOnOff1BoostOutput
Members
Member name | Value | Description
BoostOutputOff | 0 | Boost Output: Off
BoostOutputOn | 1 | Boost Output: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff1Ldo1Output Enumeration

IRD

Max8930TypeOnOff1Ldo1Output Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff1Ldo1Output
Public Enumeration TypeOnOff1Ldo1Output
public enum class TypeOnOff1Ldo1Output
type TypeOnOff1Ldo1Output
Members
Member name | Value | Description
LDO1OutputOff | 0 | LDO1 Output: Off
LDO1OutputOn | 1 | LDO1 Output: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff1Ldo2Output Enumeration

IRD

Max8930TypeOnOff1Ldo2Output Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff1Ldo2Output
Public Enumeration TypeOnOff1Ldo2Output
public enum class TypeOnOff1Ldo2Output
type TypeOnOff1Ldo2Output
Members
Member name | Value | Description
LDO2OutputOff | 0 | LDO2 Output: Off
LDO2OutputOn | 1 | LDO2 Output: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff1Ldo3Output Enumeration

IRD

Max8930TypeOnOff1Ldo3Output Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff1Ldo3Output
Public Enumeration TypeOnOff1Ldo3Output
public enum class TypeOnOff1Ldo3Output
type TypeOnOff1Ldo3Output
Members
Member name | Value | Description
LDO3OutputOff | 0 | LDO3 Output: Off
LDO3OutputOn | 1 | LDO3 Output: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff1MainWled Enumeration

IRD

Max8930TypeOnOff1MainWled Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff1MainWled
Public Enumeration TypeOnOff1MainWled
public enum class TypeOnOff1MainWled
type TypeOnOff1MainWled
Members
Member name | Value | Description
MainWLEDOff | 0 | Main WLED: Off
MainWLEDOn | 1 | Main WLED: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff1Reset Enumeration

IRD

Max8930TypeOnOff1Reset Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff1Reset
Public Enumeration TypeOnOff1Reset
public enum class TypeOnOff1Reset
type TypeOnOff1Reset
Members
Member name | Value | Description
ResetIsOff | 0 | Reset Is Off
ICReset | 1 | IC Reset
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff2LedSlope Enumeration

IRD

Max8930TypeOnOff2LedSlope Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff2LedSlope
Public Enumeration TypeOnOff2LedSlope
public enum class TypeOnOff2LedSlope
type TypeOnOff2LedSlope
Members
Member name | Value | Description
DimmingSlopeForMainWLEDOff | 0 | Dimming Slope For Main WLED: Off
DimmingSlopeForMainWLEDOn | 1 | Dimming Slope For Main WLED: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff2RgbSlope Enumeration

IRD

Max8930TypeOnOff2RgbSlope Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff2RgbSlope
Public Enumeration TypeOnOff2RgbSlope
public enum class TypeOnOff2RgbSlope
type TypeOnOff2RgbSlope
Members
Member name | Value | Description
DimmingSlopeForRGBOff | 0 | Dimming Slope For RGB: Off
DimmingSlopeForRGBOn | 1 | Dimming Slope For RGB: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff2Sub5 Enumeration

IRD

Max8930TypeOnOff2Sub5 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff2Sub5
Public Enumeration TypeOnOff2Sub5
public enum class TypeOnOff2Sub5
type TypeOnOff2Sub5
Members
Member name | Value | Description
WLED5BelongsToMainGroup | 0 | WLED5: Belongs To Main Group
WLED5BelongsToSubgroup | 1 | WLED5: Belongs To Subgroup
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff2Sub6 Enumeration

IRD

Max8930TypeOnOff2Sub6 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff2Sub6
Public Enumeration TypeOnOff2Sub6
public enum class TypeOnOff2Sub6
type TypeOnOff2Sub6
Members
Member name | Value | Description
WLED6BelongsToMainGroup | 0 | WLED6: Belongs To Main Group
WLED6BelongsToSubgroup | 1 | WLED6: Belongs To Subgroup
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff2Sub7 Enumeration

IRD

Max8930TypeOnOff2Sub7 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff2Sub7
Public Enumeration TypeOnOff2Sub7
public enum class TypeOnOff2Sub7
type TypeOnOff2Sub7
Members
Member name | Value | Description
WLED7BelongsToMainGroup | 0 | WLED7: Belongs To Main Group
WLED7BelongsToSubgroup | 1 | WLED7: Belongs To Subgroup
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff2Wled5 Enumeration

IRD

Max8930TypeOnOff2Wled5 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff2Wled5
Public Enumeration TypeOnOff2Wled5
public enum class TypeOnOff2Wled5
type TypeOnOff2Wled5
Members
Member name | Value | Description
WLED5OutputOff | 0 | WLED5 Output: Off
WLED5OutputOn | 1 | WLED5 Output: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff2Wled6 Enumeration

IRD

Max8930TypeOnOff2Wled6 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff2Wled6
Public Enumeration TypeOnOff2Wled6
public enum class TypeOnOff2Wled6
type TypeOnOff2Wled6
Members
Member name | Value | Description
WLED6OutputOff | 0 | WLED6 Output: Off
WLED6OutputOn | 1 | WLED6 Output: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff2Wled7 Enumeration

IRD

Max8930TypeOnOff2Wled7 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff2Wled7
Public Enumeration TypeOnOff2Wled7
public enum class TypeOnOff2Wled7
type TypeOnOff2Wled7
Members
Member name | Value | Description
WLED7OutputOff | 0 | WLED7 Output: Off
WLED7OutputOn | 1 | WLED7 Output: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff3CaiDimming Enumeration

IRD

Max8930TypeOnOff3CaiDimming Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff3CaiDimming
Public Enumeration TypeOnOff3CaiDimming
public enum class TypeOnOff3CaiDimming
type TypeOnOff3CaiDimming
Members
Member name | Value | Description
CAIDimmingForMainWLEDOff | 0 | CAI Dimming For Main WLED: Off
CAIDimmingForMainWLEDOn | 1 | CAI Dimming For Main WLED: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff3ChargeIndicator Enumeration

IRD

Max8930TypeOnOff3ChargeIndicator Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff3ChargeIndicator
Public Enumeration TypeOnOff3ChargeIndicator
public enum class TypeOnOff3ChargeIndicator
type TypeOnOff3ChargeIndicator
Members
Member name | Value | Description
NMOSChargingIndicatorOff | 0 | nMOS Charging Indicator: Off
NMOSChargingIndicatorOn | 1 | nMOS Charging Indicator: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff3I2cKeypad Enumeration

IRD

Max8930TypeOnOff3I2cKeypad Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff3I2cKeypad
Public Enumeration TypeOnOff3I2cKeypad
public enum class TypeOnOff3I2cKeypad
type TypeOnOff3I2cKeypad
Members
Member name | Value | Description
I2CForKeypadOff | 0 | I2C For Keypad: Off
I2CForKeypadOn | 1 | I2C For Keypad: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff3MainI2cDimming Enumeration

IRD

Max8930TypeOnOff3MainI2cDimming Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff3MainI2cDimming
Public Enumeration TypeOnOff3MainI2cDimming
public enum class TypeOnOff3MainI2cDimming
type TypeOnOff3MainI2cDimming
Members
Member name | Value | Description
I2CDimmingForMainWLEDOff | 0 | I2C Dimming For Main WLED: Off
I2CDimmingForMainWLEDOn | 1 | I2C Dimming For Main WLED: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff3Sub8 Enumeration

IRD

Max8930TypeOnOff3Sub8 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff3Sub8
Public Enumeration TypeOnOff3Sub8
public enum class TypeOnOff3Sub8
type TypeOnOff3Sub8
Members
Member name | Value | Description
WLED8BelongsToMainGroup | 0 | WLED 8: Belongs To Main Group
WLED8BelongsToSubgroup | 1 | WLED 8: Belongs To Subgroup
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff3WaitTime Enumeration

IRD

Max8930TypeOnOff3WaitTime Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff3WaitTime
Public Enumeration TypeOnOff3WaitTime
public enum class TypeOnOff3WaitTime
type TypeOnOff3WaitTime
Members
Member name | Value | Description
WaitingTimeForALC32Ms | 0 | Waiting Time For ALC: 32 ms
WaitingTimeForALC64Ms | 1 | Waiting Time For ALC: 64 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff3Wled8 Enumeration

IRD

Max8930TypeOnOff3Wled8 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff3Wled8
Public Enumeration TypeOnOff3Wled8
public enum class TypeOnOff3Wled8
type TypeOnOff3Wled8
Members
Member name | Value | Description
WLED8OutputOff | 0 | WLED8 Output: Off
WLED8OutputOn | 1 | WLED8 Output: On
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnOff3WledHighLow Enumeration

IRD

Max8930TypeOnOff3WledHighLow Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOff3WledHighLow
Public Enumeration TypeOnOff3WledHighLow
public enum class TypeOnOff3WledHighLow
type TypeOnOff3WledHighLow
Members
Member name | Value | Description
MainWLEDActiveHigh | 0 | Main WLED: Active High
MainWLEDActiveLow | 1 | Main WLED: Active Low
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnoffControlMode Enumeration

IRD

Max8930TypeOnoffControlMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnoffControlMode
Public Enumeration TypeOnoffControlMode
public enum class TypeOnoffControlMode
type TypeOnoffControlMode
Members
Member name | Value | Description
LDOModeForLDO1LDO2LDO3 | 0 | LDO Mode For LDO1, LDO2, LDO3
GPOMode | 1 | GPO Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnoffControlOutputLdo1 Enumeration

IRD

Max8930TypeOnoffControlOutputLdo1 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnoffControlOutputLdo1
Public Enumeration TypeOnoffControlOutputLdo1
public enum class TypeOnoffControlOutputLdo1
type TypeOnoffControlOutputLdo1
Members
Member name | Value | Description
LDO1OutputHighPowerSWOff | 0 | LDO1: Output High (Power SW Off)
LDO1OutputLowPowerSWOn | 1 | LDO1: Output Low (Power SW On)
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnoffControlOutputLdo2 Enumeration

IRD

Max8930TypeOnoffControlOutputLdo2 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnoffControlOutputLdo2
Public Enumeration TypeOnoffControlOutputLdo2
public enum class TypeOnoffControlOutputLdo2
type TypeOnoffControlOutputLdo2
Members
Member name | Value | Description
LDO2OutputHighPowerSWOff | 0 | LDO2: Output High (Power SW Off)
LDO2OutputLowPowerSWOn | 1 | LDO2: Output Low (Power SW On)
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeOnoffControlOutputLdo3 Enumeration

IRD

Max8930TypeOnoffControlOutputLdo3 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnoffControlOutputLdo3
Public Enumeration TypeOnoffControlOutputLdo3
public enum class TypeOnoffControlOutputLdo3
type TypeOnoffControlOutputLdo3
Members
Member name | Value | Description
LDO3OutputHighPowerSWOff | 0 | LDO3: Output High (Power SW Off)
LDO3OutputLowPowerSWOn | 1 | LDO3: Output Low (Power SW On)
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeRgbLedOnoffActive Enumeration

IRD

Max8930TypeRgbLedOnoffActive Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRgbLedOnoffActive
Public Enumeration TypeRgbLedOnoffActive
public enum class TypeRgbLedOnoffActive
type TypeRgbLedOnoffActive
Members
Member name | Value | Description
ActiveHighForRGBLEDOn | 0 | Active High For RGB LED On
ActiveLowForRGBLEDActivated | 1 | Active Low For RGB LED Activated
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeRgbLedOnoffBlueLed Enumeration

IRD

Max8930TypeRgbLedOnoffBlueLed Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRgbLedOnoffBlueLed
Public Enumeration TypeRgbLedOnoffBlueLed
public enum class TypeRgbLedOnoffBlueLed
type TypeRgbLedOnoffBlueLed
Members
Member name | Value | Description
BlueLEDIsOff | 0 | Blue LED Is: Off
BlueLEDIsOnByI2C | 1 | Blue LED Is: On By I2C
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeRgbLedOnoffGreenLed Enumeration

IRD

Max8930TypeRgbLedOnoffGreenLed Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRgbLedOnoffGreenLed
Public Enumeration TypeRgbLedOnoffGreenLed
public enum class TypeRgbLedOnoffGreenLed
type TypeRgbLedOnoffGreenLed
Members
Member name | Value | Description
GreenLEDIsOff | 0 | Green LED Is: Off
GreenLEDIsOnByI2C | 1 | Green LED Is: On By I2C
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeRgbLedOnoffRedLed Enumeration

IRD

Max8930TypeRgbLedOnoffRedLed Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRgbLedOnoffRedLed
Public Enumeration TypeRgbLedOnoffRedLed
public enum class TypeRgbLedOnoffRedLed
type TypeRgbLedOnoffRedLed
Members
Member name | Value | Description
REDLEDIsOff | 0 | RED LED Is: Off
REDLEDIsOnByI2C | 1 | RED LED Is: On by I2C
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeRgbLedOnoffRgbEnable Enumeration

IRD

Max8930TypeRgbLedOnoffRgbEnable Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRgbLedOnoffRgbEnable
Public Enumeration TypeRgbLedOnoffRgbEnable
public enum class TypeRgbLedOnoffRgbEnable
type TypeRgbLedOnoffRgbEnable
Members
Member name | Value | Description
RGBLEDIsOnByPlayPin | 0 | RGB LED Is On By: Play Pin
RGBLEDIsOnByI2C | 1 | RGB LED Is On By: I2C
See Also

Reference

telos.Ird.Maxim Namespace


Max8930.TypeSlopeControlUpDown Enumeration

IRD

Max8930TypeSlopeControlUpDown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSlopeControlUpDown
Public Enumeration TypeSlopeControlUpDown
public enum class TypeSlopeControlUpDown
type TypeSlopeControlUpDown
Members
Member name | Value | Description
Value_0_000 | 0 | 0.000
Value_0_016 | 1 | 0.016
Value_0_068 | 2 | 0.068
Value_0_128 | 3 | 0.128
Value_0_256 | 4 | 0.256
Value_0_512 | 5 | 0.512
Value_1_024 | 6 | 1.024
Value_2_048 | 7 | 2.048
See Also

Reference

telos.Ird.Maxim Namespace


Max9526 Class

Maxim: MAX 9526
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax9526

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max9526
Public Class Max9526
public ref class Max9526
type Max9526 =  class end

The Max9526 type exposes the following members.

Constructors
 | Name | Description
Public method | Max9526 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Brightness | Brightness (unit: IRE)
Public property | ClockOutputCLIP | Clock Output: CLIP
Public property | ClockOutputDATAZ | Clock Output: DATAZ
Public property | ClockOutputHSVS | Clock Output: HSVS
Public property | ClockOutputLLCINV | Clock Output: LLC_INV
Public property | ClockOutputLLCZ | Clock Output: LLCZ
Public property | ClockOutputSEL54MHZ | Clock Output: SEL_54MHZ
Public property | ClockOutputXTALDIS | Clock Output: XTAL_DIS
Public property | ColorKillBW | Color Kill: BW
Public property | ColorKillCRKDIS | Color Kill: CRKDIS
Public property | ColorKillCTHRSH | Color Kill: CTHRSH
Public property | Contrast | Contrast
Public property | GainControlADAGC | Gain Control: ADAGC
Public property | GainControlAGCGAIN | Gain Control: AGCGAIN (unit: mV)
Public property | GainControlCMPAGC | Gain Control: CMPAGC
Public property | GainControlCRAGC | Gain Control: CRAGC
Public property | Hue | Hue (unit: °)
Public property | IRQMask0IADCOVR | IRQ Mask 0: IADCOVR
Public property | IRQMask0ICTHR | IRQ Mask 0: ICTHR
Public property | IRQMask0IHLOCK | IRQ Mask 0: IHLOCK
Public property | IRQMask0ILSTLCK | IRQ Mask 0: ILSTLCK
Public property | IRQMask0INONSTD | IRQ Mask 0: INONSTD
Public property | IRQMask0IVID1 | IRQ Mask 0: IVID1
Public property | IRQMask0IVID2 | IRQ Mask 0: IVID2
Public property | IRQMask1IACP | IRQ Mask 1: IACP
Public property | IRQMask1IL525 | IRQ Mask 1: IL525
Public property | MiscellaneousDISAAFLT | Miscellaneous: DISAAFLT
Public property | MiscellaneousSSLICE | Miscellaneous: SSLICE
Public property | PLLControlLLCMODE | PLL Control: LLC_MODE
Public property | PLLControlPLLBW | PLL Control: PLLBW (unit: Hz)
Public property | PLLControlPLLBYP | PLL Control: PLLBYP
Public property | Saturation | Saturation
Public property | StandardSelectAUTOD | Standard Select: AUTOD
Public property | StandardSelectRESET | Standard Select: RESET
Public property | StandardSelectRESETS | Standard Select: RESET_S
Public property | StandardSelectSHDN | Standard Select: SHDN
Public property | StandardSelectSLEEP | Standard Select: SLEEP
Public property | StandardSelectSTDSEL | Standard Select: STDSEL
Public property | Status0ADCOVR | Status 0: ADCOVR
Public property | Status0CTHR | Status 0: CTHR
Public property | Status0HLOCK | Status 0: HLOCK
Public property | Status0LSTLCK | Status 0: LSTLCK
Public property | Status0NONSTD | Status 0: NONSTD
Public property | Status0VID1 | Status 0: VID1
Public property | Status0VID2 | Status 0: VID2
Public property | Status1ACP | Status 1: ACP
Public property | Status1L525 | Status 1: L525
Public property | TestSignalCBAR | Test Signal: CBAR
Public property | TestSignalRAWADC | Test Signal: RAWADC
Public property | TestSignalTGEab | Test Signal: TGEab
Public property | TestSignalTGSRC | Test Signal: TGSRC
Public property | TestSignalTGTIM | Test Signal: TGTIM
Public property | VideoInputAUTOSEL | Video Input: AUTOSEL
Public property | VideoInputDCLMPDIS | Video Input: D_CLMP_DIS
Public property | VideoInputDCRESTORERANGE | Video Input: DCRESTORE_RANGE
Public property | VideoInputINSEL | Video Input: INSEL
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Power, High-Performance NTSC/PAL Video Decoder
See Also

Reference

telos.Ird.Maxim Namespace


Max9526 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max9526(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max9526

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526 Properties

The Max9526 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Brightness | Brightness (unit: IRE)
Public property | ClockOutputCLIP | Clock Output: CLIP
Public property | ClockOutputDATAZ | Clock Output: DATAZ
Public property | ClockOutputHSVS | Clock Output: HSVS
Public property | ClockOutputLLCINV | Clock Output: LLC_INV
Public property | ClockOutputLLCZ | Clock Output: LLCZ
Public property | ClockOutputSEL54MHZ | Clock Output: SEL_54MHZ
Public property | ClockOutputXTALDIS | Clock Output: XTAL_DIS
Public property | ColorKillBW | Color Kill: BW
Public property | ColorKillCRKDIS | Color Kill: CRKDIS
Public property | ColorKillCTHRSH | Color Kill: CTHRSH
Public property | Contrast | Contrast
Public property | GainControlADAGC | Gain Control: ADAGC
Public property | GainControlAGCGAIN | Gain Control: AGCGAIN (unit: mV)
Public property | GainControlCMPAGC | Gain Control: CMPAGC
Public property | GainControlCRAGC | Gain Control: CRAGC
Public property | Hue | Hue (unit: °)
Public property | IRQMask0IADCOVR | IRQ Mask 0: IADCOVR
Public property | IRQMask0ICTHR | IRQ Mask 0: ICTHR
Public property | IRQMask0IHLOCK | IRQ Mask 0: IHLOCK
Public property | IRQMask0ILSTLCK | IRQ Mask 0: ILSTLCK
Public property | IRQMask0INONSTD | IRQ Mask 0: INONSTD
Public property | IRQMask0IVID1 | IRQ Mask 0: IVID1
Public property | IRQMask0IVID2 | IRQ Mask 0: IVID2
Public property | IRQMask1IACP | IRQ Mask 1: IACP
Public property | IRQMask1IL525 | IRQ Mask 1: IL525
Public property | MiscellaneousDISAAFLT | Miscellaneous: DISAAFLT
Public property | MiscellaneousSSLICE | Miscellaneous: SSLICE
Public property | PLLControlLLCMODE | PLL Control: LLC_MODE
Public property | PLLControlPLLBW | PLL Control: PLLBW (unit: Hz)
Public property | PLLControlPLLBYP | PLL Control: PLLBYP
Public property | Saturation | Saturation
Public property | StandardSelectAUTOD | Standard Select: AUTOD
Public property | StandardSelectRESET | Standard Select: RESET
Public property | StandardSelectRESETS | Standard Select: RESET_S
Public property | StandardSelectSHDN | Standard Select: SHDN
Public property | StandardSelectSLEEP | Standard Select: SLEEP
Public property | StandardSelectSTDSEL | Standard Select: STDSEL
Public property | Status0ADCOVR | Status 0: ADCOVR
Public property | Status0CTHR | Status 0: CTHR
Public property | Status0HLOCK | Status 0: HLOCK
Public property | Status0LSTLCK | Status 0: LSTLCK
Public property | Status0NONSTD | Status 0: NONSTD
Public property | Status0VID1 | Status 0: VID1
Public property | Status0VID2 | Status 0: VID2
Public property | Status1ACP | Status 1: ACP
Public property | Status1L525 | Status 1: L525
Public property | TestSignalCBAR | Test Signal: CBAR
Public property | TestSignalRAWADC | Test Signal: RAWADC
Public property | TestSignalTGEab | Test Signal: TGEab
Public property | TestSignalTGSRC | Test Signal: TGSRC
Public property | TestSignalTGTIM | Test Signal: TGTIM
Public property | VideoInputAUTOSEL | Video Input: AUTOSEL
Public property | VideoInputDCLMPDIS | Video Input: D_CLMP_DIS
Public property | VideoInputDCRESTORERANGE | Video Input: DCRESTORE_RANGE
Public property | VideoInputINSEL | Video Input: INSEL
Top
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.AutoFlush Property

IRD

Max9526AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.Brightness Property

IRD

Max9526Brightness Property

Brightness (unit: IRE)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Brightness { get; set; }
Public Property Brightness As Double
    Get
    Set
public:
property double Brightness {
    double get ();
    void set (double value);
}
member Brightness : float with get, set

Property Value

Type: Double
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.ClockOutputCLIP Property

IRD

Max9526ClockOutputCLIP Property

Clock Output: CLIP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeClockOutputClip ClockOutputCLIP { get; set; }
Public Property ClockOutputCLIP As Max9526TypeClockOutputClip
    Get
    Set
public:
property Max9526TypeClockOutputClip ClockOutputCLIP {
    Max9526TypeClockOutputClip get ();
    void set (Max9526TypeClockOutputClip value);
}
member ClockOutputCLIP : Max9526TypeClockOutputClip with get, set

Property Value

Type: Max9526TypeClockOutputClip
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.ClockOutputDATAZ Property

IRD

Max9526ClockOutputDATAZ Property

Clock Output: DATAZ

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeClockOutputData ClockOutputDATAZ { get; set; }
Public Property ClockOutputDATAZ As Max9526TypeClockOutputData
    Get
    Set
public:
property Max9526TypeClockOutputData ClockOutputDATAZ {
    Max9526TypeClockOutputData get ();
    void set (Max9526TypeClockOutputData value);
}
member ClockOutputDATAZ : Max9526TypeClockOutputData with get, set

Property Value

Type: Max9526TypeClockOutputData
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.ClockOutputHSVS Property

IRD

Max9526ClockOutputHSVS Property

Clock Output: HSVS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeClockOutputSync ClockOutputHSVS { get; set; }
Public Property ClockOutputHSVS As Max9526TypeClockOutputSync
    Get
    Set
public:
property Max9526TypeClockOutputSync ClockOutputHSVS {
    Max9526TypeClockOutputSync get ();
    void set (Max9526TypeClockOutputSync value);
}
member ClockOutputHSVS : Max9526TypeClockOutputSync with get, set

Property Value

Type: Max9526TypeClockOutputSync
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.ClockOutputLLCINV Property

IRD

Max9526ClockOutputLLCINV Property

Clock Output: LLC_INV

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeClockOutputLineLock ClockOutputLLCINV { get; set; }
Public Property ClockOutputLLCINV As Max9526TypeClockOutputLineLock
    Get
    Set
public:
property Max9526TypeClockOutputLineLock ClockOutputLLCINV {
    Max9526TypeClockOutputLineLock get ();
    void set (Max9526TypeClockOutputLineLock value);
}
member ClockOutputLLCINV : Max9526TypeClockOutputLineLock with get, set

Property Value

Type: Max9526TypeClockOutputLineLock
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.ClockOutputLLCZ Property

IRD

Max9526ClockOutputLLCZ Property

Clock Output: LLCZ

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeClockOutputClock ClockOutputLLCZ { get; set; }
Public Property ClockOutputLLCZ As Max9526TypeClockOutputClock
    Get
    Set
public:
property Max9526TypeClockOutputClock ClockOutputLLCZ {
    Max9526TypeClockOutputClock get ();
    void set (Max9526TypeClockOutputClock value);
}
member ClockOutputLLCZ : Max9526TypeClockOutputClock with get, set

Property Value

Type: Max9526TypeClockOutputClock
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.ClockOutputSEL54MHZ Property

IRD

Max9526ClockOutputSEL54MHZ Property

Clock Output: SEL_54MHZ

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeClockOutputInputClock ClockOutputSEL54MHZ { get; set; }
Public Property ClockOutputSEL54MHZ As Max9526TypeClockOutputInputClock
    Get
    Set
public:
property Max9526TypeClockOutputInputClock ClockOutputSEL54MHZ {
    Max9526TypeClockOutputInputClock get ();
    void set (Max9526TypeClockOutputInputClock value);
}
member ClockOutputSEL54MHZ : Max9526TypeClockOutputInputClock with get, set

Property Value

Type: Max9526TypeClockOutputInputClock
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.ClockOutputXTALDIS Property

IRD

Max9526ClockOutputXTALDIS Property

Clock Output: XTAL_DIS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeClockOutputCrystal ClockOutputXTALDIS { get; set; }
Public Property ClockOutputXTALDIS As Max9526TypeClockOutputCrystal
    Get
    Set
public:
property Max9526TypeClockOutputCrystal ClockOutputXTALDIS {
    Max9526TypeClockOutputCrystal get ();
    void set (Max9526TypeClockOutputCrystal value);
}
member ClockOutputXTALDIS : Max9526TypeClockOutputCrystal with get, set

Property Value

Type: Max9526TypeClockOutputCrystal
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.ColorKillBW Property

IRD

Max9526ColorKillBW Property

Color Kill: BW

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeColorKillBlackWhite ColorKillBW { get; set; }
Public Property ColorKillBW As Max9526TypeColorKillBlackWhite
    Get
    Set
public:
property Max9526TypeColorKillBlackWhite ColorKillBW {
    Max9526TypeColorKillBlackWhite get ();
    void set (Max9526TypeColorKillBlackWhite value);
}
member ColorKillBW : Max9526TypeColorKillBlackWhite with get, set

Property Value

Type: Max9526TypeColorKillBlackWhite
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.ColorKillCRKDIS Property

IRD

Max9526ColorKillCRKDIS Property

Color Kill: CRKDIS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeColorKillSelect ColorKillCRKDIS { get; set; }
Public Property ColorKillCRKDIS As Max9526TypeColorKillSelect
    Get
    Set
public:
property Max9526TypeColorKillSelect ColorKillCRKDIS {
    Max9526TypeColorKillSelect get ();
    void set (Max9526TypeColorKillSelect value);
}
member ColorKillCRKDIS : Max9526TypeColorKillSelect with get, set

Property Value

Type: Max9526TypeColorKillSelect
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.ColorKillCTHRSH Property

IRD

Max9526ColorKillCTHRSH Property

Color Kill: CTHRSH

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeColorKillThreshold ColorKillCTHRSH { get; set; }
Public Property ColorKillCTHRSH As Max9526TypeColorKillThreshold
    Get
    Set
public:
property Max9526TypeColorKillThreshold ColorKillCTHRSH {
    Max9526TypeColorKillThreshold get ();
    void set (Max9526TypeColorKillThreshold value);
}
member ColorKillCTHRSH : Max9526TypeColorKillThreshold with get, set

Property Value

Type: Max9526TypeColorKillThreshold
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.Contrast Property

IRD

Max9526Contrast Property

Contrast

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Contrast { get; set; }
Public Property Contrast As Double
    Get
    Set
public:
property double Contrast {
    double get ();
    void set (double value);
}
member Contrast : float with get, set

Property Value

Type: Double
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.GainControlADAGC Property

IRD

Max9526GainControlADAGC Property

Gain Control: ADAGC

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeGainControlGainControl GainControlADAGC { get; set; }
Public Property GainControlADAGC As Max9526TypeGainControlGainControl
    Get
    Set
public:
property Max9526TypeGainControlGainControl GainControlADAGC {
    Max9526TypeGainControlGainControl get ();
    void set (Max9526TypeGainControlGainControl value);
}
member GainControlADAGC : Max9526TypeGainControlGainControl with get, set

Property Value

Type: Max9526TypeGainControlGainControl
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.GainControlAGCGAIN Property

IRD

Max9526GainControlAGCGAIN Property

Gain Control: AGCGAIN (unit: mV)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeGainControlGain GainControlAGCGAIN { get; set; }
Public Property GainControlAGCGAIN As Max9526TypeGainControlGain
    Get
    Set
public:
property Max9526TypeGainControlGain GainControlAGCGAIN {
    Max9526TypeGainControlGain get ();
    void set (Max9526TypeGainControlGain value);
}
member GainControlAGCGAIN : Max9526TypeGainControlGain with get, set

Property Value

Type: Max9526TypeGainControlGain
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.GainControlCMPAGC Property

IRD

Max9526GainControlCMPAGC Property

Gain Control: CMPAGC

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeGainControlComposite GainControlCMPAGC { get; set; }
Public Property GainControlCMPAGC As Max9526TypeGainControlComposite
    Get
    Set
public:
property Max9526TypeGainControlComposite GainControlCMPAGC {
    Max9526TypeGainControlComposite get ();
    void set (Max9526TypeGainControlComposite value);
}
member GainControlCMPAGC : Max9526TypeGainControlComposite with get, set

Property Value

Type: Max9526TypeGainControlComposite
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.GainControlCRAGC Property

IRD

Max9526GainControlCRAGC Property

Gain Control: CRAGC

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeGainControlChrominance GainControlCRAGC { get; set; }
Public Property GainControlCRAGC As Max9526TypeGainControlChrominance
    Get
    Set
public:
property Max9526TypeGainControlChrominance GainControlCRAGC {
    Max9526TypeGainControlChrominance get ();
    void set (Max9526TypeGainControlChrominance value);
}
member GainControlCRAGC : Max9526TypeGainControlChrominance with get, set

Property Value

Type: Max9526TypeGainControlChrominance
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.Hue Property

IRD

Max9526Hue Property

Hue (unit: °)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Hue { get; set; }
Public Property Hue As Double
    Get
    Set
public:
property double Hue {
    double get ();
    void set (double value);
}
member Hue : float with get, set

Property Value

Type: Double
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.IRQMask0IADCOVR Property

IRD

Max9526IRQMask0IADCOVR Property

IRQ Mask 0: IADCOVR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeIrqMask0AdcInt IRQMask0IADCOVR { get; set; }
Public Property IRQMask0IADCOVR As Max9526TypeIrqMask0AdcInt
    Get
    Set
public:
property Max9526TypeIrqMask0AdcInt IRQMask0IADCOVR {
    Max9526TypeIrqMask0AdcInt get ();
    void set (Max9526TypeIrqMask0AdcInt value);
}
member IRQMask0IADCOVR : Max9526TypeIrqMask0AdcInt with get, set

Property Value

Type: Max9526TypeIrqMask0AdcInt
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.IRQMask0ICTHR Property

IRD

Max9526IRQMask0ICTHR Property

IRQ Mask 0: ICTHR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeIrqMask0ColorKillInt IRQMask0ICTHR { get; set; }
Public Property IRQMask0ICTHR As Max9526TypeIrqMask0ColorKillInt
    Get
    Set
public:
property Max9526TypeIrqMask0ColorKillInt IRQMask0ICTHR {
    Max9526TypeIrqMask0ColorKillInt get ();
    void set (Max9526TypeIrqMask0ColorKillInt value);
}
member IRQMask0ICTHR : Max9526TypeIrqMask0ColorKillInt with get, set

Property Value

Type: Max9526TypeIrqMask0ColorKillInt
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.IRQMask0IHLOCK Property

IRD

Max9526IRQMask0IHLOCK Property

IRQ Mask 0: IHLOCK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeIrqMask0HorizontalInt IRQMask0IHLOCK { get; set; }
Public Property IRQMask0IHLOCK As Max9526TypeIrqMask0HorizontalInt
    Get
    Set
public:
property Max9526TypeIrqMask0HorizontalInt IRQMask0IHLOCK {
    Max9526TypeIrqMask0HorizontalInt get ();
    void set (Max9526TypeIrqMask0HorizontalInt value);
}
member IRQMask0IHLOCK : Max9526TypeIrqMask0HorizontalInt with get, set

Property Value

Type: Max9526TypeIrqMask0HorizontalInt
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.IRQMask0ILSTLCK Property

IRD

Max9526IRQMask0ILSTLCK Property

IRQ Mask 0: ILSTLCK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeIrqMask0DemodulatorInt IRQMask0ILSTLCK { get; set; }
Public Property IRQMask0ILSTLCK As Max9526TypeIrqMask0DemodulatorInt
    Get
    Set
public:
property Max9526TypeIrqMask0DemodulatorInt IRQMask0ILSTLCK {
    Max9526TypeIrqMask0DemodulatorInt get ();
    void set (Max9526TypeIrqMask0DemodulatorInt value);
}
member IRQMask0ILSTLCK : Max9526TypeIrqMask0DemodulatorInt with get, set

Property Value

Type: Max9526TypeIrqMask0DemodulatorInt
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.IRQMask0INONSTD Property

IRD

Max9526IRQMask0INONSTD Property

IRQ Mask 0: INONSTD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeIrqMask0NonstdVideoInt IRQMask0INONSTD { get; set; }
Public Property IRQMask0INONSTD As Max9526TypeIrqMask0NonstdVideoInt
    Get
    Set
public:
property Max9526TypeIrqMask0NonstdVideoInt IRQMask0INONSTD {
    Max9526TypeIrqMask0NonstdVideoInt get ();
    void set (Max9526TypeIrqMask0NonstdVideoInt value);
}
member IRQMask0INONSTD : Max9526TypeIrqMask0NonstdVideoInt with get, set

Property Value

Type: Max9526TypeIrqMask0NonstdVideoInt
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.IRQMask0IVID1 Property

IRD

Max9526IRQMask0IVID1 Property

IRQ Mask 0: IVID1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeIrqMask0Video1Int IRQMask0IVID1 { get; set; }
Public Property IRQMask0IVID1 As Max9526TypeIrqMask0Video1Int
    Get
    Set
public:
property Max9526TypeIrqMask0Video1Int IRQMask0IVID1 {
    Max9526TypeIrqMask0Video1Int get ();
    void set (Max9526TypeIrqMask0Video1Int value);
}
member IRQMask0IVID1 : Max9526TypeIrqMask0Video1Int with get, set

Property Value

Type: Max9526TypeIrqMask0Video1Int
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.IRQMask0IVID2 Property

IRD

Max9526IRQMask0IVID2 Property

IRQ Mask 0: IVID2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeIrqMask0Video2Int IRQMask0IVID2 { get; set; }
Public Property IRQMask0IVID2 As Max9526TypeIrqMask0Video2Int
    Get
    Set
public:
property Max9526TypeIrqMask0Video2Int IRQMask0IVID2 {
    Max9526TypeIrqMask0Video2Int get ();
    void set (Max9526TypeIrqMask0Video2Int value);
}
member IRQMask0IVID2 : Max9526TypeIrqMask0Video2Int with get, set

Property Value

Type: Max9526TypeIrqMask0Video2Int
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.IRQMask1IACP Property

IRD

Max9526IRQMask1IACP Property

IRQ Mask 1: IACP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeIrqMask1CopyProtInt IRQMask1IACP { get; set; }
Public Property IRQMask1IACP As Max9526TypeIrqMask1CopyProtInt
    Get
    Set
public:
property Max9526TypeIrqMask1CopyProtInt IRQMask1IACP {
    Max9526TypeIrqMask1CopyProtInt get ();
    void set (Max9526TypeIrqMask1CopyProtInt value);
}
member IRQMask1IACP : Max9526TypeIrqMask1CopyProtInt with get, set

Property Value

Type: Max9526TypeIrqMask1CopyProtInt
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.IRQMask1IL525 Property

IRD

Max9526IRQMask1IL525 Property

IRQ Mask 1: IL525

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeIrqMask1LineModeInt IRQMask1IL525 { get; set; }
Public Property IRQMask1IL525 As Max9526TypeIrqMask1LineModeInt
    Get
    Set
public:
property Max9526TypeIrqMask1LineModeInt IRQMask1IL525 {
    Max9526TypeIrqMask1LineModeInt get ();
    void set (Max9526TypeIrqMask1LineModeInt value);
}
member IRQMask1IL525 : Max9526TypeIrqMask1LineModeInt with get, set

Property Value

Type: Max9526TypeIrqMask1LineModeInt
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.MiscellaneousDISAAFLT Property

IRD

Max9526MiscellaneousDISAAFLT Property

Miscellaneous: DISAAFLT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeMiscellaneousAlias MiscellaneousDISAAFLT { get; set; }
Public Property MiscellaneousDISAAFLT As Max9526TypeMiscellaneousAlias
    Get
    Set
public:
property Max9526TypeMiscellaneousAlias MiscellaneousDISAAFLT {
    Max9526TypeMiscellaneousAlias get ();
    void set (Max9526TypeMiscellaneousAlias value);
}
member MiscellaneousDISAAFLT : Max9526TypeMiscellaneousAlias with get, set

Property Value

Type: Max9526TypeMiscellaneousAlias
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.MiscellaneousSSLICE Property

IRD

Max9526MiscellaneousSSLICE Property

Miscellaneous: SSLICE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MiscellaneousSSLICE { get; set; }
Public Property MiscellaneousSSLICE As Double
    Get
    Set
public:
property double MiscellaneousSSLICE {
    double get ();
    void set (double value);
}
member MiscellaneousSSLICE : float with get, set

Property Value

Type: Double
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.PLLControlLLCMODE Property

IRD

Max9526PLLControlLLCMODE Property

PLL Control: LLC_MODE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypePllControlLineLock PLLControlLLCMODE { get; set; }
Public Property PLLControlLLCMODE As Max9526TypePllControlLineLock
    Get
    Set
public:
property Max9526TypePllControlLineLock PLLControlLLCMODE {
    Max9526TypePllControlLineLock get ();
    void set (Max9526TypePllControlLineLock value);
}
member PLLControlLLCMODE : Max9526TypePllControlLineLock with get, set

Property Value

Type: Max9526TypePllControlLineLock
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.PLLControlPLLBW Property

IRD

Max9526PLLControlPLLBW Property

PLL Control: PLLBW (unit: Hz)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypePllControlSpeed PLLControlPLLBW { get; set; }
Public Property PLLControlPLLBW As Max9526TypePllControlSpeed
    Get
    Set
public:
property Max9526TypePllControlSpeed PLLControlPLLBW {
    Max9526TypePllControlSpeed get ();
    void set (Max9526TypePllControlSpeed value);
}
member PLLControlPLLBW : Max9526TypePllControlSpeed with get, set

Property Value

Type: Max9526TypePllControlSpeed
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.PLLControlPLLBYP Property

IRD

Max9526PLLControlPLLBYP Property

PLL Control: PLLBYP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypePllControlBypass PLLControlPLLBYP { get; set; }
Public Property PLLControlPLLBYP As Max9526TypePllControlBypass
    Get
    Set
public:
property Max9526TypePllControlBypass PLLControlPLLBYP {
    Max9526TypePllControlBypass get ();
    void set (Max9526TypePllControlBypass value);
}
member PLLControlPLLBYP : Max9526TypePllControlBypass with get, set

Property Value

Type: Max9526TypePllControlBypass
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.Saturation Property

IRD

Max9526Saturation Property

Saturation

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Saturation { get; set; }
Public Property Saturation As Double
    Get
    Set
public:
property double Saturation {
    double get ();
    void set (double value);
}
member Saturation : float with get, set

Property Value

Type: Double
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.StandardSelectAUTOD Property

IRD

Max9526StandardSelectAUTOD Property

Standard Select: AUTOD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeStandardSelectDetect StandardSelectAUTOD { get; set; }
Public Property StandardSelectAUTOD As Max9526TypeStandardSelectDetect
    Get
    Set
public:
property Max9526TypeStandardSelectDetect StandardSelectAUTOD {
    Max9526TypeStandardSelectDetect get ();
    void set (Max9526TypeStandardSelectDetect value);
}
member StandardSelectAUTOD : Max9526TypeStandardSelectDetect with get, set

Property Value

Type: Max9526TypeStandardSelectDetect
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.StandardSelectRESET Property

IRD

Max9526StandardSelectRESET Property

Standard Select: RESET

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeStandardSelectSysReset StandardSelectRESET { get; set; }
Public Property StandardSelectRESET As Max9526TypeStandardSelectSysReset
    Get
    Set
public:
property Max9526TypeStandardSelectSysReset StandardSelectRESET {
    Max9526TypeStandardSelectSysReset get ();
    void set (Max9526TypeStandardSelectSysReset value);
}
member StandardSelectRESET : Max9526TypeStandardSelectSysReset with get, set

Property Value

Type: Max9526TypeStandardSelectSysReset
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.StandardSelectRESETS Property

IRD

Max9526StandardSelectRESETS Property

Standard Select: RESET_S

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeStandardSelectSoftReset StandardSelectRESETS { get; set; }
Public Property StandardSelectRESETS As Max9526TypeStandardSelectSoftReset
    Get
    Set
public:
property Max9526TypeStandardSelectSoftReset StandardSelectRESETS {
    Max9526TypeStandardSelectSoftReset get ();
    void set (Max9526TypeStandardSelectSoftReset value);
}
member StandardSelectRESETS : Max9526TypeStandardSelectSoftReset with get, set

Property Value

Type: Max9526TypeStandardSelectSoftReset
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.StandardSelectSHDN Property

IRD

Max9526StandardSelectSHDN Property

Standard Select: SHDN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeStandardSelectLowPower StandardSelectSHDN { get; set; }
Public Property StandardSelectSHDN As Max9526TypeStandardSelectLowPower
    Get
    Set
public:
property Max9526TypeStandardSelectLowPower StandardSelectSHDN {
    Max9526TypeStandardSelectLowPower get ();
    void set (Max9526TypeStandardSelectLowPower value);
}
member StandardSelectSHDN : Max9526TypeStandardSelectLowPower with get, set

Property Value

Type: Max9526TypeStandardSelectLowPower
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.StandardSelectSLEEP Property

IRD

Max9526StandardSelectSLEEP Property

Standard Select: SLEEP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeStandardSelectSleep StandardSelectSLEEP { get; set; }
Public Property StandardSelectSLEEP As Max9526TypeStandardSelectSleep
    Get
    Set
public:
property Max9526TypeStandardSelectSleep StandardSelectSLEEP {
    Max9526TypeStandardSelectSleep get ();
    void set (Max9526TypeStandardSelectSleep value);
}
member StandardSelectSLEEP : Max9526TypeStandardSelectSleep with get, set

Property Value

Type: Max9526TypeStandardSelectSleep
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.StandardSelectSTDSEL Property

IRD

Max9526StandardSelectSTDSEL Property

Standard Select: STDSEL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeStandardSelectVideo StandardSelectSTDSEL { get; set; }
Public Property StandardSelectSTDSEL As Max9526TypeStandardSelectVideo
    Get
    Set
public:
property Max9526TypeStandardSelectVideo StandardSelectSTDSEL {
    Max9526TypeStandardSelectVideo get ();
    void set (Max9526TypeStandardSelectVideo value);
}
member StandardSelectSTDSEL : Max9526TypeStandardSelectVideo with get, set

Property Value

Type: Max9526TypeStandardSelectVideo
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.Status0ADCOVR Property

IRD

Max9526Status0ADCOVR Property

Status 0: ADCOVR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeStatus0Adc Status0ADCOVR { get; set; }
Public Property Status0ADCOVR As Max9526TypeStatus0Adc
    Get
    Set
public:
property Max9526TypeStatus0Adc Status0ADCOVR {
    Max9526TypeStatus0Adc get ();
    void set (Max9526TypeStatus0Adc value);
}
member Status0ADCOVR : Max9526TypeStatus0Adc with get, set

Property Value

Type: Max9526TypeStatus0Adc
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.Status0CTHR Property

IRD

Max9526Status0CTHR Property

Status 0: CTHR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeStatus0ColorKill Status0CTHR { get; set; }
Public Property Status0CTHR As Max9526TypeStatus0ColorKill
    Get
    Set
public:
property Max9526TypeStatus0ColorKill Status0CTHR {
    Max9526TypeStatus0ColorKill get ();
    void set (Max9526TypeStatus0ColorKill value);
}
member Status0CTHR : Max9526TypeStatus0ColorKill with get, set

Property Value

Type: Max9526TypeStatus0ColorKill
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.Status0HLOCK Property

IRD

Max9526Status0HLOCK Property

Status 0: HLOCK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeStatus0HorizontalLock Status0HLOCK { get; set; }
Public Property Status0HLOCK As Max9526TypeStatus0HorizontalLock
    Get
    Set
public:
property Max9526TypeStatus0HorizontalLock Status0HLOCK {
    Max9526TypeStatus0HorizontalLock get ();
    void set (Max9526TypeStatus0HorizontalLock value);
}
member Status0HLOCK : Max9526TypeStatus0HorizontalLock with get, set

Property Value

Type: Max9526TypeStatus0HorizontalLock
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.Status0LSTLCK Property

IRD

Max9526Status0LSTLCK Property

Status 0: LSTLCK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeStatus0DemodulatorLock Status0LSTLCK { get; set; }
Public Property Status0LSTLCK As Max9526TypeStatus0DemodulatorLock
    Get
    Set
public:
property Max9526TypeStatus0DemodulatorLock Status0LSTLCK {
    Max9526TypeStatus0DemodulatorLock get ();
    void set (Max9526TypeStatus0DemodulatorLock value);
}
member Status0LSTLCK : Max9526TypeStatus0DemodulatorLock with get, set

Property Value

Type: Max9526TypeStatus0DemodulatorLock
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.Status0NONSTD Property

IRD

Max9526Status0NONSTD Property

Status 0: NONSTD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeStatus0NonstandardVideo Status0NONSTD { get; set; }
Public Property Status0NONSTD As Max9526TypeStatus0NonstandardVideo
    Get
    Set
public:
property Max9526TypeStatus0NonstandardVideo Status0NONSTD {
    Max9526TypeStatus0NonstandardVideo get ();
    void set (Max9526TypeStatus0NonstandardVideo value);
}
member Status0NONSTD : Max9526TypeStatus0NonstandardVideo with get, set

Property Value

Type: Max9526TypeStatus0NonstandardVideo
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.Status0VID1 Property

IRD

Max9526Status0VID1 Property

Status 0: VID1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeStatus0VideoInput1 Status0VID1 { get; set; }
Public Property Status0VID1 As Max9526TypeStatus0VideoInput1
    Get
    Set
public:
property Max9526TypeStatus0VideoInput1 Status0VID1 {
    Max9526TypeStatus0VideoInput1 get ();
    void set (Max9526TypeStatus0VideoInput1 value);
}
member Status0VID1 : Max9526TypeStatus0VideoInput1 with get, set

Property Value

Type: Max9526TypeStatus0VideoInput1
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.Status0VID2 Property

IRD

Max9526Status0VID2 Property

Status 0: VID2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeStatus0VideoInput2 Status0VID2 { get; set; }
Public Property Status0VID2 As Max9526TypeStatus0VideoInput2
    Get
    Set
public:
property Max9526TypeStatus0VideoInput2 Status0VID2 {
    Max9526TypeStatus0VideoInput2 get ();
    void set (Max9526TypeStatus0VideoInput2 value);
}
member Status0VID2 : Max9526TypeStatus0VideoInput2 with get, set

Property Value

Type: Max9526TypeStatus0VideoInput2
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.Status1ACP Property

IRD

Max9526Status1ACP Property

Status 1: ACP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeStatus1CopyProtection Status1ACP { get; set; }
Public Property Status1ACP As Max9526TypeStatus1CopyProtection
    Get
    Set
public:
property Max9526TypeStatus1CopyProtection Status1ACP {
    Max9526TypeStatus1CopyProtection get ();
    void set (Max9526TypeStatus1CopyProtection value);
}
member Status1ACP : Max9526TypeStatus1CopyProtection with get, set

Property Value

Type: Max9526TypeStatus1CopyProtection
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.Status1L525 Property

IRD

Max9526Status1L525 Property

Status 1: L525

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeStatus1LineMode Status1L525 { get; set; }
Public Property Status1L525 As Max9526TypeStatus1LineMode
    Get
    Set
public:
property Max9526TypeStatus1LineMode Status1L525 {
    Max9526TypeStatus1LineMode get ();
    void set (Max9526TypeStatus1LineMode value);
}
member Status1L525 : Max9526TypeStatus1LineMode with get, set

Property Value

Type: Max9526TypeStatus1LineMode
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.TestSignalCBAR Property

IRD

Max9526TestSignalCBAR Property

Test Signal: CBAR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeTestSignalColorBar TestSignalCBAR { get; set; }
Public Property TestSignalCBAR As Max9526TypeTestSignalColorBar
    Get
    Set
public:
property Max9526TypeTestSignalColorBar TestSignalCBAR {
    Max9526TypeTestSignalColorBar get ();
    void set (Max9526TypeTestSignalColorBar value);
}
member TestSignalCBAR : Max9526TypeTestSignalColorBar with get, set

Property Value

Type: Max9526TypeTestSignalColorBar
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.TestSignalRAWADC Property

IRD

Max9526TestSignalRAWADC Property

Test Signal: RAWADC

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeTestSignalAdcOnly TestSignalRAWADC { get; set; }
Public Property TestSignalRAWADC As Max9526TypeTestSignalAdcOnly
    Get
    Set
public:
property Max9526TypeTestSignalAdcOnly TestSignalRAWADC {
    Max9526TypeTestSignalAdcOnly get ();
    void set (Max9526TypeTestSignalAdcOnly value);
}
member TestSignalRAWADC : Max9526TypeTestSignalAdcOnly with get, set

Property Value

Type: Max9526TypeTestSignalAdcOnly
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.TestSignalTGEab Property

IRD

Max9526TestSignalTGEab Property

Test Signal: TGEab

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeTestSignalPattern TestSignalTGEab { get; set; }
Public Property TestSignalTGEab As Max9526TypeTestSignalPattern
    Get
    Set
public:
property Max9526TypeTestSignalPattern TestSignalTGEab {
    Max9526TypeTestSignalPattern get ();
    void set (Max9526TypeTestSignalPattern value);
}
member TestSignalTGEab : Max9526TypeTestSignalPattern with get, set

Property Value

Type: Max9526TypeTestSignalPattern
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.TestSignalTGSRC Property

IRD

Max9526TestSignalTGSRC Property

Test Signal: TGSRC

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeTestSignalSource TestSignalTGSRC { get; set; }
Public Property TestSignalTGSRC As Max9526TypeTestSignalSource
    Get
    Set
public:
property Max9526TypeTestSignalSource TestSignalTGSRC {
    Max9526TypeTestSignalSource get ();
    void set (Max9526TypeTestSignalSource value);
}
member TestSignalTGSRC : Max9526TypeTestSignalSource with get, set

Property Value

Type: Max9526TypeTestSignalSource
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.TestSignalTGTIM Property

IRD

Max9526TestSignalTGTIM Property

Test Signal: TGTIM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeTestSignalTiming TestSignalTGTIM { get; set; }
Public Property TestSignalTGTIM As Max9526TypeTestSignalTiming
    Get
    Set
public:
property Max9526TypeTestSignalTiming TestSignalTGTIM {
    Max9526TypeTestSignalTiming get ();
    void set (Max9526TypeTestSignalTiming value);
}
member TestSignalTGTIM : Max9526TypeTestSignalTiming with get, set

Property Value

Type: Max9526TypeTestSignalTiming
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.VideoInputAUTOSEL Property

IRD

Max9526VideoInputAUTOSEL Property

Video Input: AUTOSEL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeVideoInputSelect VideoInputAUTOSEL { get; set; }
Public Property VideoInputAUTOSEL As Max9526TypeVideoInputSelect
    Get
    Set
public:
property Max9526TypeVideoInputSelect VideoInputAUTOSEL {
    Max9526TypeVideoInputSelect get ();
    void set (Max9526TypeVideoInputSelect value);
}
member VideoInputAUTOSEL : Max9526TypeVideoInputSelect with get, set

Property Value

Type: Max9526TypeVideoInputSelect
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.VideoInputDCLMPDIS Property

IRD

Max9526VideoInputDCLMPDIS Property

Video Input: D_CLMP_DIS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeVideoInputDigitalClamp VideoInputDCLMPDIS { get; set; }
Public Property VideoInputDCLMPDIS As Max9526TypeVideoInputDigitalClamp
    Get
    Set
public:
property Max9526TypeVideoInputDigitalClamp VideoInputDCLMPDIS {
    Max9526TypeVideoInputDigitalClamp get ();
    void set (Max9526TypeVideoInputDigitalClamp value);
}
member VideoInputDCLMPDIS : Max9526TypeVideoInputDigitalClamp with get, set

Property Value

Type: Max9526TypeVideoInputDigitalClamp
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.VideoInputDCRESTORERANGE Property

IRD

Max9526VideoInputDCRESTORERANGE Property

Video Input: DCRESTORE_RANGE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeVideoInputCurrentRange VideoInputDCRESTORERANGE { get; set; }
Public Property VideoInputDCRESTORERANGE As Max9526TypeVideoInputCurrentRange
    Get
    Set
public:
property Max9526TypeVideoInputCurrentRange VideoInputDCRESTORERANGE {
    Max9526TypeVideoInputCurrentRange get ();
    void set (Max9526TypeVideoInputCurrentRange value);
}
member VideoInputDCRESTORERANGE : Max9526TypeVideoInputCurrentRange with get, set

Property Value

Type: Max9526TypeVideoInputCurrentRange
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.VideoInputINSEL Property

IRD

Max9526VideoInputINSEL Property

Video Input: INSEL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9526TypeVideoInputManual VideoInputINSEL { get; set; }
Public Property VideoInputINSEL As Max9526TypeVideoInputManual
    Get
    Set
public:
property Max9526TypeVideoInputManual VideoInputINSEL {
    Max9526TypeVideoInputManual get ();
    void set (Max9526TypeVideoInputManual value);
}
member VideoInputINSEL : Max9526TypeVideoInputManual with get, set

Property Value

Type: Max9526TypeVideoInputManual
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526 Methods

The Max9526 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.Flush Method

IRD

Max9526Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max9526 Class
telos.Ird.Maxim Namespace


Max9526.TypeClockOutputClip Enumeration

IRD

Max9526TypeClockOutputClip Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockOutputClip
Public Enumeration TypeClockOutputClip
public enum class TypeClockOutputClip
type TypeClockOutputClip
Members
Member name | Value | Description
ClipITUToYAndCbCrRangeIsBetween51019 | 0 | Clip ITU To Y And CbCr Range Is Between 5–1019
ClipITUToYRangeIsBetween64940AndCbCrRangeIsBetween64960 | 1 | Clip ITU To Y Range Is Between 64–940 And CbCr Range Is Between 64–960
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeClockOutputClock Enumeration

IRD

Max9526TypeClockOutputClock Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockOutputClock
Public Enumeration TypeClockOutputClock
public enum class TypeClockOutputClock
type TypeClockOutputClock
Members
Member name | Value | Description
LogicClockOutputLLCEnabled | 0 | Logic Clock Output (LLC): Enabled
LogicClockOutputLLCDisabledHighImpedanceState | 1 | Logic Clock Output (LLC): Disabled (High Impedance State)
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeClockOutputCrystal Enumeration

IRD

Max9526TypeClockOutputCrystal Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockOutputCrystal
Public Enumeration TypeClockOutputCrystal
public enum class TypeClockOutputCrystal
type TypeClockOutputCrystal
Members
Member name | Value | Description
Value_27MHzCrystalOscillatorEnabled | 0 | 27 MHz Crystal Oscillator Enabled
XTALOSCIs27MHzOr54MHzCMOSClockInput | 1 | XTAL/OSC Is 27 MHz Or 54 MHz CMOS Clock Input
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeClockOutputData Enumeration

IRD

Max9526TypeClockOutputData Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockOutputData
Public Enumeration TypeClockOutputData
public enum class TypeClockOutputData
type TypeClockOutputData
Members
Member name | Value | Description
LogicDataOutputsD9D0Enabled | 0 | Logic Data Outputs (D9–D0): Enabled
LogicDataOutputsD9D0DisabledHighImpedanceState | 1 | Logic Data Outputs (D9–D0): Disabled (High Impedance State)
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeClockOutputInputClock Enumeration

IRD

Max9526TypeClockOutputInputClock Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockOutputInputClock
Public Enumeration TypeClockOutputInputClock
public enum class TypeClockOutputInputClock
type TypeClockOutputInputClock
Members
Member name | Value | Description
Value_27MHzClockAtXTALOSCInput | 0 | 27MHz Clock At XTAL/OSC Input
Value_54MHzClockAtXTALOSCInput | 1 | 54MHz Clock At XTAL/OSC Input
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeClockOutputLineLock Enumeration

IRD

Max9526TypeClockOutputLineLock Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockOutputLineLock
Public Enumeration TypeClockOutputLineLock
public enum class TypeClockOutputLineLock
type TypeClockOutputLineLock
Members
Member name | Value | Description
LLCLockNotInverted | 0 | LLC Lock: Not Inverted
LLCLockInverted | 1 | LLC Lock: Inverted
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeClockOutputSync Enumeration

IRD

Max9526TypeClockOutputSync Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockOutputSync
Public Enumeration TypeClockOutputSync
public enum class TypeClockOutputSync
type TypeClockOutputSync
Members
Member name | Value | Description
D1AndD0AreLSBsOfDigitalComponentVideoOutput | 0 | D1 And D0 Are LSBs Of Digital Component Video Output
D1AndD0OutputHorizontalAndVerticalSyncPulses | 1 | D1 And D0 Output Horizontal And Vertical Sync Pulses
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeColorKillBlackWhite Enumeration

IRD

Max9526TypeColorKillBlackWhite Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeColorKillBlackWhite
Public Enumeration TypeColorKillBlackWhite
public enum class TypeColorKillBlackWhite
type TypeColorKillBlackWhite
Members
Member name | Value | Description
ChrominanceDemodulatorEnabled | 0 | Chrominance Demodulator: Enabled
ChrominanceDemodulatorDisabled | 1 | Chrominance Demodulator: Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeColorKillSelect Enumeration

IRD

Max9526TypeColorKillSelect Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeColorKillSelect
Public Enumeration TypeColorKillSelect
public enum class TypeColorKillSelect
type TypeColorKillSelect
Members
Member name | Value | Description
AutomaticColorKillEnabled | 0 | Automatic Color Kill: Enabled
ColorKillDisabled | 1 | Color Kill: Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeColorKillThreshold Enumeration

IRD

Max9526TypeColorKillThreshold Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeColorKillThreshold
Public Enumeration TypeColorKillThreshold
public enum class TypeColorKillThreshold
type TypeColorKillThreshold
Members
Member name | Value | Description
Off | 0 | Off
Off__1 | 1 | Off
Value_19 | 2 | 19
Value_25 | 3 | 25
Value_27 | 4 | 27
Value_29 | 5 | 29
Value_30 | 6 | 30
Value_31 | 7 | 31
Value_35 | 8 | 35
Value_39 | 9 | 39
Value_40 | 10 | 40
Value_41 | 11 | 41
Value_43 | 12 | 43
Value_45 | 13 | 45
Value_48 | 14 | 48
Value_51 | 15 | 51
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeGainControlChrominance Enumeration

IRD

Max9526TypeGainControlChrominance Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGainControlChrominance
Public Enumeration TypeGainControlChrominance
public enum class TypeGainControlChrominance
type TypeGainControlChrominance
Members
Member name | Value | Description
AutomaticChromaGainBasedOnColorBurstLevel | 0 | Automatic Chroma Gain Based On Color Burst Level
ChromaGainIsFrozen | 1 | Chroma Gain Is Frozen
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeGainControlComposite Enumeration

IRD

Max9526TypeGainControlComposite Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGainControlComposite
Public Enumeration TypeGainControlComposite
public enum class TypeGainControlComposite
type TypeGainControlComposite
Members
Member name | Value | Description
AutomaticDigitalCompositeGainBasedOnSyncLevel | 0 | Automatic Digital Composite Gain Based On Sync Level
DigitalCompositeGainFrozenAtDefaultValue0x80 | 1 | Digital Composite Gain Frozen At Default Value (0x80)
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeGainControlGain Enumeration

IRD

Max9526TypeGainControlGain Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGainControlGain
Public Enumeration TypeGainControlGain
public enum class TypeGainControlGain
type TypeGainControlGain
Members
Member name | Value | Description
Value_752 | 0 | 752
Value_683 | 1 | 683
Value_626 | 2 | 626
Value_578 | 3 | 578
Value_535 | 4 | 535
Value_500 | 5 | 500
Value_469 | 6 | 469
Value_441 | 7 | 441
Value_417 | 8 | 417
Value_394 | 9 | 394
Value_375 | 10 | 375
Value_357 | 11 | 357
Value_341 | 12 | 341
Value_326 | 13 | 326
Value_313 | 14 | 313
Value_300 | 15 | 300
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeGainControlGainControl Enumeration

IRD

Max9526TypeGainControlGainControl Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGainControlGainControl
Public Enumeration TypeGainControlGainControl
public enum class TypeGainControlGainControl
type TypeGainControlGainControl
Members
Member name | Value | Description
AnalogAutomaticGainControlEnabled | 0 | Analog Automatic Gain-Control: Enabled
AnalogAutomaticGainControlDisabled | 1 | Analog Automatic Gain-Control: Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeIrqMask0AdcInt Enumeration

IRD

Max9526TypeIrqMask0AdcInt Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIrqMask0AdcInt
Public Enumeration TypeIrqMask0AdcInt
public enum class TypeIrqMask0AdcInt
type TypeIrqMask0AdcInt
Members
Member name | Value | Description
NoInterruptOnADCOVRChanges | 0 | No Interrupt On ADCOVR Changes
ADCOVR01TransitionTriggersHardwareInterrupt | 1 | ADCOVR 0-1 Transition Triggers Hardware Interrupt
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeIrqMask0ColorKillInt Enumeration

IRD

Max9526TypeIrqMask0ColorKillInt Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIrqMask0ColorKillInt
Public Enumeration TypeIrqMask0ColorKillInt
public enum class TypeIrqMask0ColorKillInt
type TypeIrqMask0ColorKillInt
Members
Member name | Value | Description
NoInterruptOnCTHRChanges | 0 | No Interrupt on CTHR Changes
CTHR01TransitionTriggersHardwareInterrupt | 1 | CTHR 0-1 Transition Triggers Hardware Interrupt
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeIrqMask0DemodulatorInt Enumeration

IRD

Max9526TypeIrqMask0DemodulatorInt Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIrqMask0DemodulatorInt
Public Enumeration TypeIrqMask0DemodulatorInt
public enum class TypeIrqMask0DemodulatorInt
type TypeIrqMask0DemodulatorInt
Members
Member name | Value | Description
NoInterruptOnLSTLCKChanges | 0 | No Interrupt On LSTLCK Changes
LSTLCK01TransitionTriggersHardwareInterrupt | 1 | LSTLCK 0-1 Transition Triggers Hardware Interrupt
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeIrqMask0HorizontalInt Enumeration

IRD

Max9526TypeIrqMask0HorizontalInt Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIrqMask0HorizontalInt
Public Enumeration TypeIrqMask0HorizontalInt
public enum class TypeIrqMask0HorizontalInt
type TypeIrqMask0HorizontalInt
Members
Member name | Value | Description
NoInterruptOnHLOCKChanges | 0 | No Interrupt On HLOCK Changes
HLOCK01TransitionTriggersHardwareInterrupt | 1 | HLOCK 0-1 Transition Triggers Hardware Interrupt
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeIrqMask0NonstdVideoInt Enumeration

IRD

Max9526TypeIrqMask0NonstdVideoInt Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIrqMask0NonstdVideoInt
Public Enumeration TypeIrqMask0NonstdVideoInt
public enum class TypeIrqMask0NonstdVideoInt
type TypeIrqMask0NonstdVideoInt
Members
Member name | Value | Description
NoInterruptOnNONSTDChanges | 0 | No Interrupt On NONSTD Changes
NONSTD01TransitionTriggersHardwareInterrupt | 1 | NONSTD 0-1 Transition Triggers Hardware Interrupt
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeIrqMask0Video1Int Enumeration

IRD

Max9526TypeIrqMask0Video1Int Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIrqMask0Video1Int
Public Enumeration TypeIrqMask0Video1Int
public enum class TypeIrqMask0Video1Int
type TypeIrqMask0Video1Int
Members
Member name | Value | Description
NoInterruptOnVID1Changes | 0 | No Interrupt On VID1 Changes
ChangedVID1BitTriggeredHardwareInterrupt | 1 | Changed VID1 Bit Triggered Hardware Interrupt
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeIrqMask0Video2Int Enumeration

IRD

Max9526TypeIrqMask0Video2Int Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIrqMask0Video2Int
Public Enumeration TypeIrqMask0Video2Int
public enum class TypeIrqMask0Video2Int
type TypeIrqMask0Video2Int
Members
Member name | Value | Description
NoInterruptOnVID2Changes | 0 | No Interrupt On VID2 Changes
ChangedVID2BitTriggeredHardwareInterrupt | 1 | Changed VID2 Bit Triggered Hardware Interrupt
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeIrqMask1CopyProtInt Enumeration

IRD

Max9526TypeIrqMask1CopyProtInt Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIrqMask1CopyProtInt
Public Enumeration TypeIrqMask1CopyProtInt
public enum class TypeIrqMask1CopyProtInt
type TypeIrqMask1CopyProtInt
Members
Member name | Value | Description
NoInterruptOnACPChanges | 0 | No Interrupt On ACP Changes
AnyChangeInACPTriggersHardwareInterrupt | 1 | Any Change In ACP Triggers Hardware Interrupt
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeIrqMask1LineModeInt Enumeration

IRD

Max9526TypeIrqMask1LineModeInt Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIrqMask1LineModeInt
Public Enumeration TypeIrqMask1LineModeInt
public enum class TypeIrqMask1LineModeInt
type TypeIrqMask1LineModeInt
Members
Member name | Value | Description
NoInterruptOnL525Changes | 0 | No Interrupt On L525 Changes
L525TriggersHardwareInterrupt | 1 | L525 Triggers Hardware Interrupt
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeMiscellaneousAlias Enumeration

IRD

Max9526TypeMiscellaneousAlias Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMiscellaneousAlias
Public Enumeration TypeMiscellaneousAlias
public enum class TypeMiscellaneousAlias
type TypeMiscellaneousAlias
Members
Member name | Value | Description
DigitalAntiAliasingFilterEnabled | 0 | Digital Anti-Aliasing Filter: Enabled
DigitalAntiAliasingFilterDisabled | 1 | Digital Anti-Aliasing Filter: Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypePllControlBypass Enumeration

IRD

Max9526TypePllControlBypass Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllControlBypass
Public Enumeration TypePllControlBypass
public enum class TypePllControlBypass
type TypePllControlBypass
Members
Member name | Value | Description
PLLEnabled | 0 | PLL Enabled
BypassPLL | 1 | Bypass PLL
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypePllControlLineLock Enumeration

IRD

Max9526TypePllControlLineLock Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllControlLineLock
Public Enumeration TypePllControlLineLock
public enum class TypePllControlLineLock
type TypePllControlLineLock
Members
Member name | Value | Description
AutomaticSetOfAsyncModeOrLineLockedMode | 0 | Automatic Set Of Async Mode Or Line-Locked Mode
PLLIsForcedToLineLockedMode | 2 | PLL Is Forced To Line-Locked Mode
PLLIsForcedToAsyncMode | 3 | PLL Is Forced To Async Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypePllControlSpeed Enumeration

IRD

Max9526TypePllControlSpeed Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllControlSpeed
Public Enumeration TypePllControlSpeed
public enum class TypePllControlSpeed
type TypePllControlSpeed
Members
Member name | Value | Description
Value_180 | 0 | 180
Value_250 | 1 | 250
Value_375 | 2 | 375
Value_500 | 3 | 500
Value_750 | 4 | 750
Value_1000 | 5 | 1000
Value_1500 | 6 | 1500
Value_2000 | 7 | 2000
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeStandardSelectDetect Enumeration

IRD

Max9526TypeStandardSelectDetect Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStandardSelectDetect
Public Enumeration TypeStandardSelectDetect
public enum class TypeStandardSelectDetect
type TypeStandardSelectDetect
Members
Member name | Value | Description
ManuallyPrograms525Vs625LineVideo | 0 | Manually Programs 525 vs. 625 Line Video
AutomaticallyDetects525Vs625LineVideo | 1 | Automatically Detects 525 vs. 625 Line Video
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeStandardSelectLowPower Enumeration

IRD

Max9526TypeStandardSelectLowPower Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStandardSelectLowPower
Public Enumeration TypeStandardSelectLowPower
public enum class TypeStandardSelectLowPower
type TypeStandardSelectLowPower
Members
Member name | Value | Description
NormalOperationNoLowPowerShutdown | 0 | Normal Operation (No Low-Power Shutdown)
LowPowerShutdownMode | 1 | Low-Power Shutdown Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeStandardSelectSleep Enumeration

IRD

Max9526TypeStandardSelectSleep Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStandardSelectSleep
Public Enumeration TypeStandardSelectSleep
public enum class TypeStandardSelectSleep
type TypeStandardSelectSleep
Members
Member name | Value | Description
NormalOperationNoSleepMode | 0 | Normal Operation (No Sleep Mode)
LowPowerSleepMode | 1 | Low-Power Sleep Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeStandardSelectSoftReset Enumeration

IRD

Max9526TypeStandardSelectSoftReset Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStandardSelectSoftReset
Public Enumeration TypeStandardSelectSoftReset
public enum class TypeStandardSelectSoftReset
type TypeStandardSelectSoftReset
Members
Member name | Value | Description
NormalOperationNoSoftReset | 0 | Normal Operation (No Soft Reset)
SoftReset | 1 | Soft Reset
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeStandardSelectSysReset Enumeration

IRD

Max9526TypeStandardSelectSysReset Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStandardSelectSysReset
Public Enumeration TypeStandardSelectSysReset
public enum class TypeStandardSelectSysReset
type TypeStandardSelectSysReset
Members
Member name | Value | Description
NormalOperationNoSystemReset | 0 | Normal Operation (No System Reset)
RegistersAndSystemStateReset | 1 | Registers And System State Reset
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeStandardSelectVideo Enumeration

IRD

Max9526TypeStandardSelectVideo Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStandardSelectVideo
Public Enumeration TypeStandardSelectVideo
public enum class TypeStandardSelectVideo
type TypeStandardSelectVideo
Members
Member name | Value | Description
PALBGHIDStandardPAL | 0 | PAL B/G/H/I/D (Standard PAL)
PALCombinationN | 1 | PAL Combination N
NTSCMStandardNTSC | 2 | NTSC M (Standard NTSC)
PALM | 3 | PAL M
NTSC443 | 5 | NTSC 4.43
NTSCJ | 6 | NTSC J
PAL60 | 7 | PAL 60
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeStatus0Adc Enumeration

IRD

Max9526TypeStatus0Adc Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus0Adc
Public Enumeration TypeStatus0Adc
public enum class TypeStatus0Adc
type TypeStatus0Adc
Members
Member name | Value | Description
ADCNotOutOfRange | 0 | ADC Not Out-Of-Range
ADCOutOfRange | 1 | ADC Out Of Range
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeStatus0ColorKill Enumeration

IRD

Max9526TypeStatus0ColorKill Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus0ColorKill
Public Enumeration TypeStatus0ColorKill
public enum class TypeStatus0ColorKill
type TypeStatus0ColorKill
Members
Member name | Value | Description
ColorCarrierNotBelowColorKillThreshold | 0 | Color Carrier Not Below Color Kill Threshold
ColorCarrierBelowColorKillThreshold | 1 | Color Carrier Below Color Kill Threshold
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeStatus0DemodulatorLock Enumeration

IRD

Max9526TypeStatus0DemodulatorLock Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus0DemodulatorLock
Public Enumeration TypeStatus0DemodulatorLock
public enum class TypeStatus0DemodulatorLock
type TypeStatus0DemodulatorLock
Members
Member name | Value | Description
DemodulatorHasMaintainedLock | 0 | Demodulator Has Maintained Lock
DemodulatorHasLostLock | 1 | Demodulator Has Lost Lock
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeStatus0HorizontalLock Enumeration

IRD

Max9526TypeStatus0HorizontalLock Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus0HorizontalLock
Public Enumeration TypeStatus0HorizontalLock
public enum class TypeStatus0HorizontalLock
type TypeStatus0HorizontalLock
Members
Member name | Value | Description
LineLockedPLLHasLostLock | 0 | Line-Locked PLL Has Lost Lock
LineLockedPLLIsLockedToHorizontalLineRate | 1 | Line-Locked PLL Is Locked To Horizontal Line Rate
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeStatus0NonstandardVideo Enumeration

IRD

Max9526TypeStatus0NonstandardVideo Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus0NonstandardVideo
Public Enumeration TypeStatus0NonstandardVideo
public enum class TypeStatus0NonstandardVideo
type TypeStatus0NonstandardVideo
Members
Member name | Value | Description
StandardVideoFormatDetected | 0 | Standard Video Format Detected
NonStandardVideoFormatDetected | 1 | Non-Standard Video Format Detected
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeStatus0VideoInput1 Enumeration

IRD

Max9526TypeStatus0VideoInput1 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus0VideoInput1
Public Enumeration TypeStatus0VideoInput1
public enum class TypeStatus0VideoInput1
type TypeStatus0VideoInput1
Members
Member name | Value | Description
NoActiveVideoDetectedAtVin1 | 0 | No Active Video Detected At Vin1
ActiveVideoDetectedAtVin1 | 1 | Active Video Detected At Vin1
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeStatus0VideoInput2 Enumeration

IRD

Max9526TypeStatus0VideoInput2 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus0VideoInput2
Public Enumeration TypeStatus0VideoInput2
public enum class TypeStatus0VideoInput2
type TypeStatus0VideoInput2
Members
Member name | Value | Description
NoActiveVideoDetectedAtVin2 | 0 | No Active Video Detected At Vin2
ActiveVideoDetectedAtVin2 | 1 | Active Video Detected At Vin2
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeStatus1CopyProtection Enumeration

IRD

Max9526TypeStatus1CopyProtection Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1CopyProtection
Public Enumeration TypeStatus1CopyProtection
public enum class TypeStatus1CopyProtection
type TypeStatus1CopyProtection
Members
Member name | Value | Description
AnalogCopyProtectionNotDetected | 0 | Analog Copy Protection: Not Detected
AnalogCopyProtectionDetected | 1 | Analog Copy Protection: Detected
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeStatus1LineMode Enumeration

IRD

Max9526TypeStatus1LineMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1LineMode
Public Enumeration TypeStatus1LineMode
public enum class TypeStatus1LineMode
type TypeStatus1LineMode
Members
Member name | Value | Description
Value_625LineVideoDetected | 0 | 625 Line Video Detected
Value_525LineVideoDetected | 1 | 525 Line Video Detected
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeTestSignalAdcOnly Enumeration

IRD

Max9526TypeTestSignalAdcOnly Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTestSignalAdcOnly
Public Enumeration TypeTestSignalAdcOnly
public enum class TypeTestSignalAdcOnly
type TypeTestSignalAdcOnly
Members
Member name | Value | Description
D9D0Are10BitYCbCrComponentVideo | 0 | D9-D0 Are 10-Bit YCbCr Component Video
D9D0AreADCDirectOutputNoVideoDemodulatorProcessing | 1 | D9-D0 Are ADC Direct Output, No Video Demodulator Processing
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeTestSignalColorBar Enumeration

IRD

Max9526TypeTestSignalColorBar Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTestSignalColorBar
Public Enumeration TypeTestSignalColorBar
public enum class TypeTestSignalColorBar
type TypeTestSignalColorBar
Members
Member name | Value | Description
BlackScreen | 0 | Black Screen
BlueScreen | 1 | Blue Screen
Value_75ColorBars | 2 | 75% Color Bars
Value_100ColorBars | 3 | 100% Color Bars
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeTestSignalPattern Enumeration

IRD

Max9526TypeTestSignalPattern Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTestSignalPattern
Public Enumeration TypeTestSignalPattern
public enum class TypeTestSignalPattern
type TypeTestSignalPattern
Members
Member name | Value | Description
OutputTestPatternIfNoVideoPresent | 0 | Output Test Pattern If No Video Present
ForceTestPatternToVideoOutput | 1 | Force Test Pattern To Video Output
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeTestSignalSource Enumeration

IRD

Max9526TypeTestSignalSource Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTestSignalSource
Public Enumeration TypeTestSignalSource
public enum class TypeTestSignalSource
type TypeTestSignalSource
Members
Member name | Value | Description
TestGeneratorUsesInternalTiming | 0 | Test Generator Uses Internal Timing
TestGeneratorUsesTimingFromIncomingVideo | 1 | Test Generator Uses Timing From Incoming Video
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeTestSignalTiming Enumeration

IRD

Max9526TypeTestSignalTiming Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTestSignalTiming
Public Enumeration TypeTestSignalTiming
public enum class TypeTestSignalTiming
type TypeTestSignalTiming
Members
Member name | Value | Description
Value_625Line50HzFrameRate | 0 | 625 Line, 50 Hz Frame Rate
Value_525Line60HzFrameRate | 1 | 525 Line, 60 Hz Frame Rate
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeVideoInputCurrentRange Enumeration

IRD

Max9526TypeVideoInputCurrentRange Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVideoInputCurrentRange
Public Enumeration TypeVideoInputCurrentRange
public enum class TypeVideoInputCurrentRange
type TypeVideoInputCurrentRange
Members
Member name | Value | Description
AnalogDCRestorationCurrentRangeMediumFast12UA | 0 | Analog DC Restoration Current Range: Medium-Fast (+/- 12 µA)
AnalogDCRestorationCurrentRangeFast24UA | 1 | Analog DC Restoration Current Range: Fast (+/- 24 µA)
AnalogDCRestorationCurrentRangeSlow3UA | 2 | Analog DC Restoration Current Range: Slow (+/- 3 µA)
AnalogDCRestorationCurrentRangeMedium6UA | 3 | Analog DC Restoration Current Range: Medium (+/- 6 µA)
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeVideoInputDigitalClamp Enumeration

IRD

Max9526TypeVideoInputDigitalClamp Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVideoInputDigitalClamp
Public Enumeration TypeVideoInputDigitalClamp
public enum class TypeVideoInputDigitalClamp
type TypeVideoInputDigitalClamp
Members
Member name | Value | Description
DigitalSyncTipClampEnable | 0 | Digital Sync-Tip Clamp: Enable
DigitalSyncTipClampDisable | 1 | Digital Sync-Tip Clamp: Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeVideoInputManual Enumeration

IRD

Max9526TypeVideoInputManual Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVideoInputManual
Public Enumeration TypeVideoInputManual
public enum class TypeVideoInputManual
type TypeVideoInputManual
Members
Member name | Value | Description
ManualVideoInputVin1 | 0 | Manual Video Input: Vin1
ManualVideoInputVin2 | 1 | Manual Video Input: Vin2
See Also

Reference

telos.Ird.Maxim Namespace


Max9526.TypeVideoInputSelect Enumeration

IRD

Max9526TypeVideoInputSelect Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVideoInputSelect
Public Enumeration TypeVideoInputSelect
public enum class TypeVideoInputSelect
type TypeVideoInputSelect
Members
Member name | Value | Description
VideoInputIsSelectedManually | 0 | Video Input Is Selected Manually
AutomaticVideoInputSelection | 1 | Automatic Video Input Selection
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002 Class

Maxim: MAX 97001 / MAX 97002
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax9700197002

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max9700197002
Public Class Max9700197002
public ref class Max9700197002
type Max9700197002 =  class end

The Max9700197002 type exposes the following members.

Constructors
 | Name | Description
Public method | Max9700197002 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChargePumpCPSEL | Charge Pump: CPSEL
Public property | ChargePumpFIXED | Charge Pump: FIXED
Public property | HeadphoneLeftHPLM | Headphone Left: HPLM
Public property | HeadphoneLeftHPLVOL | Headphone Left: HPLVOL (unit: dB)
Public property | HeadphoneLeftSLEW | Headphone Left: SLEW
Public property | HeadphoneLeftZCD | Headphone Left: ZCD
Public property | HeadphoneMixersHPLMIX | Headphone Mixers: HPLMIX
Public property | HeadphoneMixersHPRMIX | Headphone Mixers: HPRMIX
Public property | HeadphoneRightHPGAIN | Headphone Right: HPGAIN
Public property | HeadphoneRightHPRM | Headphone Right: HPRM
Public property | HeadphoneRightHPRVOL | Headphone Right: HPRVOL (unit: dB)
Public property | InputGainINADIFF | Input Gain: INADIFF
Public property | InputGainINBDIFF | Input Gain: INBDIFF
Public property | InputGainPGAINA | Input Gain: PGAINA
Public property | InputGainPGAINB | Input Gain: PGAINB
Public property | LimiterTHDCLP | Limiter: THDCLP
Public property | LimiterTHDT1 | Limiter: THDT1 (unit: s)
Public property | PowerManagementBYPEN | Power Management: BYPEN
Public property | PowerManagementHPLEN | Power Management: HPLEN
Public property | PowerManagementHPREN | Power Management: HPREN
Public property | PowerManagementLPMODE | Power Management: LPMODE
Public property | PowerManagementSHDN | Power Management: SHDN
Public property | PowerManagementSPKEN | Power Management: SPKEN
Public property | RevisionID | Revision ID
Public property | SpeakerFFM | Speaker: FFM
Public property | SpeakerMixerSPKMIX | Speaker Mixer: SPKMIX
Public property | SpeakerSPKM | Speaker: SPKM
Public property | SpeakerSPKVOL | Speaker: SPKVOL (unit: dB)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Audio Subsystem
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max9700197002(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max9700197002

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002 Properties

The Max9700197002 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChargePumpCPSEL | Charge Pump: CPSEL
Public property | ChargePumpFIXED | Charge Pump: FIXED
Public property | HeadphoneLeftHPLM | Headphone Left: HPLM
Public property | HeadphoneLeftHPLVOL | Headphone Left: HPLVOL (unit: dB)
Public property | HeadphoneLeftSLEW | Headphone Left: SLEW
Public property | HeadphoneLeftZCD | Headphone Left: ZCD
Public property | HeadphoneMixersHPLMIX | Headphone Mixers: HPLMIX
Public property | HeadphoneMixersHPRMIX | Headphone Mixers: HPRMIX
Public property | HeadphoneRightHPGAIN | Headphone Right: HPGAIN
Public property | HeadphoneRightHPRM | Headphone Right: HPRM
Public property | HeadphoneRightHPRVOL | Headphone Right: HPRVOL (unit: dB)
Public property | InputGainINADIFF | Input Gain: INADIFF
Public property | InputGainINBDIFF | Input Gain: INBDIFF
Public property | InputGainPGAINA | Input Gain: PGAINA
Public property | InputGainPGAINB | Input Gain: PGAINB
Public property | LimiterTHDCLP | Limiter: THDCLP
Public property | LimiterTHDT1 | Limiter: THDT1 (unit: s)
Public property | PowerManagementBYPEN | Power Management: BYPEN
Public property | PowerManagementHPLEN | Power Management: HPLEN
Public property | PowerManagementHPREN | Power Management: HPREN
Public property | PowerManagementLPMODE | Power Management: LPMODE
Public property | PowerManagementSHDN | Power Management: SHDN
Public property | PowerManagementSPKEN | Power Management: SPKEN
Public property | RevisionID | Revision ID
Public property | SpeakerFFM | Speaker: FFM
Public property | SpeakerMixerSPKMIX | Speaker Mixer: SPKMIX
Public property | SpeakerSPKM | Speaker: SPKM
Public property | SpeakerSPKVOL | Speaker: SPKVOL (unit: dB)
Top
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.AutoFlush Property

IRD

Max9700197002AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.ChargePumpCPSEL Property

IRD

Max9700197002ChargePumpCPSEL Property

Charge Pump: CPSEL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeChargePumpSelect ChargePumpCPSEL { get; set; }
Public Property ChargePumpCPSEL As Max9700197002TypeChargePumpSelect
    Get
    Set
public:
property Max9700197002TypeChargePumpSelect ChargePumpCPSEL {
    Max9700197002TypeChargePumpSelect get ();
    void set (Max9700197002TypeChargePumpSelect value);
}
member ChargePumpCPSEL : Max9700197002TypeChargePumpSelect with get, set

Property Value

Type: Max9700197002TypeChargePumpSelect
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.ChargePumpFIXED Property

IRD

Max9700197002ChargePumpFIXED Property

Charge Pump: FIXED

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeChargePumpMode ChargePumpFIXED { get; set; }
Public Property ChargePumpFIXED As Max9700197002TypeChargePumpMode
    Get
    Set
public:
property Max9700197002TypeChargePumpMode ChargePumpFIXED {
    Max9700197002TypeChargePumpMode get ();
    void set (Max9700197002TypeChargePumpMode value);
}
member ChargePumpFIXED : Max9700197002TypeChargePumpMode with get, set

Property Value

Type: Max9700197002TypeChargePumpMode
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.HeadphoneLeftHPLM Property

IRD

Max9700197002HeadphoneLeftHPLM Property

Headphone Left: HPLM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeHeadphoneLeftMute HeadphoneLeftHPLM { get; set; }
Public Property HeadphoneLeftHPLM As Max9700197002TypeHeadphoneLeftMute
    Get
    Set
public:
property Max9700197002TypeHeadphoneLeftMute HeadphoneLeftHPLM {
    Max9700197002TypeHeadphoneLeftMute get ();
    void set (Max9700197002TypeHeadphoneLeftMute value);
}
member HeadphoneLeftHPLM : Max9700197002TypeHeadphoneLeftMute with get, set

Property Value

Type: Max9700197002TypeHeadphoneLeftMute
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.HeadphoneLeftHPLVOL Property

IRD

Max9700197002HeadphoneLeftHPLVOL Property

Headphone Left: HPLVOL (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeHeadphoneVolume HeadphoneLeftHPLVOL { get; set; }
Public Property HeadphoneLeftHPLVOL As Max9700197002TypeHeadphoneVolume
    Get
    Set
public:
property Max9700197002TypeHeadphoneVolume HeadphoneLeftHPLVOL {
    Max9700197002TypeHeadphoneVolume get ();
    void set (Max9700197002TypeHeadphoneVolume value);
}
member HeadphoneLeftHPLVOL : Max9700197002TypeHeadphoneVolume with get, set

Property Value

Type: Max9700197002TypeHeadphoneVolume
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.HeadphoneLeftSLEW Property

IRD

Max9700197002HeadphoneLeftSLEW Property

Headphone Left: SLEW

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeHeadphoneLeftSlewing HeadphoneLeftSLEW { get; set; }
Public Property HeadphoneLeftSLEW As Max9700197002TypeHeadphoneLeftSlewing
    Get
    Set
public:
property Max9700197002TypeHeadphoneLeftSlewing HeadphoneLeftSLEW {
    Max9700197002TypeHeadphoneLeftSlewing get ();
    void set (Max9700197002TypeHeadphoneLeftSlewing value);
}
member HeadphoneLeftSLEW : Max9700197002TypeHeadphoneLeftSlewing with get, set

Property Value

Type: Max9700197002TypeHeadphoneLeftSlewing
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.HeadphoneLeftZCD Property

IRD

Max9700197002HeadphoneLeftZCD Property

Headphone Left: ZCD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeHeadphoneLeftZeroCrossing HeadphoneLeftZCD { get; set; }
Public Property HeadphoneLeftZCD As Max9700197002TypeHeadphoneLeftZeroCrossing
    Get
    Set
public:
property Max9700197002TypeHeadphoneLeftZeroCrossing HeadphoneLeftZCD {
    Max9700197002TypeHeadphoneLeftZeroCrossing get ();
    void set (Max9700197002TypeHeadphoneLeftZeroCrossing value);
}
member HeadphoneLeftZCD : Max9700197002TypeHeadphoneLeftZeroCrossing with get, set

Property Value

Type: Max9700197002TypeHeadphoneLeftZeroCrossing
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.HeadphoneMixersHPLMIX Property

IRD

Max9700197002HeadphoneMixersHPLMIX Property

Headphone Mixers: HPLMIX

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeHeadphoneMixersIn HeadphoneMixersHPLMIX { get; set; }
Public Property HeadphoneMixersHPLMIX As Max9700197002TypeHeadphoneMixersIn
    Get
    Set
public:
property Max9700197002TypeHeadphoneMixersIn HeadphoneMixersHPLMIX {
    Max9700197002TypeHeadphoneMixersIn get ();
    void set (Max9700197002TypeHeadphoneMixersIn value);
}
member HeadphoneMixersHPLMIX : Max9700197002TypeHeadphoneMixersIn with get, set

Property Value

Type: Max9700197002TypeHeadphoneMixersIn
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.HeadphoneMixersHPRMIX Property

IRD

Max9700197002HeadphoneMixersHPRMIX Property

Headphone Mixers: HPRMIX

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeHeadphoneMixersIn HeadphoneMixersHPRMIX { get; set; }
Public Property HeadphoneMixersHPRMIX As Max9700197002TypeHeadphoneMixersIn
    Get
    Set
public:
property Max9700197002TypeHeadphoneMixersIn HeadphoneMixersHPRMIX {
    Max9700197002TypeHeadphoneMixersIn get ();
    void set (Max9700197002TypeHeadphoneMixersIn value);
}
member HeadphoneMixersHPRMIX : Max9700197002TypeHeadphoneMixersIn with get, set

Property Value

Type: Max9700197002TypeHeadphoneMixersIn
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.HeadphoneRightHPGAIN Property

IRD

Max9700197002HeadphoneRightHPGAIN Property

Headphone Right: HPGAIN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeHeadphoneRightGain HeadphoneRightHPGAIN { get; set; }
Public Property HeadphoneRightHPGAIN As Max9700197002TypeHeadphoneRightGain
    Get
    Set
public:
property Max9700197002TypeHeadphoneRightGain HeadphoneRightHPGAIN {
    Max9700197002TypeHeadphoneRightGain get ();
    void set (Max9700197002TypeHeadphoneRightGain value);
}
member HeadphoneRightHPGAIN : Max9700197002TypeHeadphoneRightGain with get, set

Property Value

Type: Max9700197002TypeHeadphoneRightGain
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.HeadphoneRightHPRM Property

IRD

Max9700197002HeadphoneRightHPRM Property

Headphone Right: HPRM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeHeadphoneRightMute HeadphoneRightHPRM { get; set; }
Public Property HeadphoneRightHPRM As Max9700197002TypeHeadphoneRightMute
    Get
    Set
public:
property Max9700197002TypeHeadphoneRightMute HeadphoneRightHPRM {
    Max9700197002TypeHeadphoneRightMute get ();
    void set (Max9700197002TypeHeadphoneRightMute value);
}
member HeadphoneRightHPRM : Max9700197002TypeHeadphoneRightMute with get, set

Property Value

Type: Max9700197002TypeHeadphoneRightMute
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.HeadphoneRightHPRVOL Property

IRD

Max9700197002HeadphoneRightHPRVOL Property

Headphone Right: HPRVOL (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeHeadphoneVolume HeadphoneRightHPRVOL { get; set; }
Public Property HeadphoneRightHPRVOL As Max9700197002TypeHeadphoneVolume
    Get
    Set
public:
property Max9700197002TypeHeadphoneVolume HeadphoneRightHPRVOL {
    Max9700197002TypeHeadphoneVolume get ();
    void set (Max9700197002TypeHeadphoneVolume value);
}
member HeadphoneRightHPRVOL : Max9700197002TypeHeadphoneVolume with get, set

Property Value

Type: Max9700197002TypeHeadphoneVolume
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.InputGainINADIFF Property

IRD

Max9700197002InputGainINADIFF Property

Input Gain: INADIFF

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeInputGainInputa InputGainINADIFF { get; set; }
Public Property InputGainINADIFF As Max9700197002TypeInputGainInputa
    Get
    Set
public:
property Max9700197002TypeInputGainInputa InputGainINADIFF {
    Max9700197002TypeInputGainInputa get ();
    void set (Max9700197002TypeInputGainInputa value);
}
member InputGainINADIFF : Max9700197002TypeInputGainInputa with get, set

Property Value

Type: Max9700197002TypeInputGainInputa
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.InputGainINBDIFF Property

IRD

Max9700197002InputGainINBDIFF Property

Input Gain: INBDIFF

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeInputGainInputb InputGainINBDIFF { get; set; }
Public Property InputGainINBDIFF As Max9700197002TypeInputGainInputb
    Get
    Set
public:
property Max9700197002TypeInputGainInputb InputGainINBDIFF {
    Max9700197002TypeInputGainInputb get ();
    void set (Max9700197002TypeInputGainInputb value);
}
member InputGainINBDIFF : Max9700197002TypeInputGainInputb with get, set

Property Value

Type: Max9700197002TypeInputGainInputb
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.InputGainPGAINA Property

IRD

Max9700197002InputGainPGAINA Property

Input Gain: PGAINA

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeInputGainPreampa InputGainPGAINA { get; set; }
Public Property InputGainPGAINA As Max9700197002TypeInputGainPreampa
    Get
    Set
public:
property Max9700197002TypeInputGainPreampa InputGainPGAINA {
    Max9700197002TypeInputGainPreampa get ();
    void set (Max9700197002TypeInputGainPreampa value);
}
member InputGainPGAINA : Max9700197002TypeInputGainPreampa with get, set

Property Value

Type: Max9700197002TypeInputGainPreampa
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.InputGainPGAINB Property

IRD

Max9700197002InputGainPGAINB Property

Input Gain: PGAINB

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeInputGainPreampb InputGainPGAINB { get; set; }
Public Property InputGainPGAINB As Max9700197002TypeInputGainPreampb
    Get
    Set
public:
property Max9700197002TypeInputGainPreampb InputGainPGAINB {
    Max9700197002TypeInputGainPreampb get ();
    void set (Max9700197002TypeInputGainPreampb value);
}
member InputGainPGAINB : Max9700197002TypeInputGainPreampb with get, set

Property Value

Type: Max9700197002TypeInputGainPreampb
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.LimiterTHDCLP Property

IRD

Max9700197002LimiterTHDCLP Property

Limiter: THDCLP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeLimiterDistortionLimit LimiterTHDCLP { get; set; }
Public Property LimiterTHDCLP As Max9700197002TypeLimiterDistortionLimit
    Get
    Set
public:
property Max9700197002TypeLimiterDistortionLimit LimiterTHDCLP {
    Max9700197002TypeLimiterDistortionLimit get ();
    void set (Max9700197002TypeLimiterDistortionLimit value);
}
member LimiterTHDCLP : Max9700197002TypeLimiterDistortionLimit with get, set

Property Value

Type: Max9700197002TypeLimiterDistortionLimit
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.LimiterTHDT1 Property

IRD

Max9700197002LimiterTHDT1 Property

Limiter: THDT1 (unit: s)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeLimiterDistortionTime LimiterTHDT1 { get; set; }
Public Property LimiterTHDT1 As Max9700197002TypeLimiterDistortionTime
    Get
    Set
public:
property Max9700197002TypeLimiterDistortionTime LimiterTHDT1 {
    Max9700197002TypeLimiterDistortionTime get ();
    void set (Max9700197002TypeLimiterDistortionTime value);
}
member LimiterTHDT1 : Max9700197002TypeLimiterDistortionTime with get, set

Property Value

Type: Max9700197002TypeLimiterDistortionTime
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.PowerManagementBYPEN Property

IRD

Max9700197002PowerManagementBYPEN Property

Power Management: BYPEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypePowerManagementAnalog PowerManagementBYPEN { get; set; }
Public Property PowerManagementBYPEN As Max9700197002TypePowerManagementAnalog
    Get
    Set
public:
property Max9700197002TypePowerManagementAnalog PowerManagementBYPEN {
    Max9700197002TypePowerManagementAnalog get ();
    void set (Max9700197002TypePowerManagementAnalog value);
}
member PowerManagementBYPEN : Max9700197002TypePowerManagementAnalog with get, set

Property Value

Type: Max9700197002TypePowerManagementAnalog
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.PowerManagementHPLEN Property

IRD

Max9700197002PowerManagementHPLEN Property

Power Management: HPLEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypePowerManagementHpLeft PowerManagementHPLEN { get; set; }
Public Property PowerManagementHPLEN As Max9700197002TypePowerManagementHpLeft
    Get
    Set
public:
property Max9700197002TypePowerManagementHpLeft PowerManagementHPLEN {
    Max9700197002TypePowerManagementHpLeft get ();
    void set (Max9700197002TypePowerManagementHpLeft value);
}
member PowerManagementHPLEN : Max9700197002TypePowerManagementHpLeft with get, set

Property Value

Type: Max9700197002TypePowerManagementHpLeft
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.PowerManagementHPREN Property

IRD

Max9700197002PowerManagementHPREN Property

Power Management: HPREN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypePowerManagementHpRight PowerManagementHPREN { get; set; }
Public Property PowerManagementHPREN As Max9700197002TypePowerManagementHpRight
    Get
    Set
public:
property Max9700197002TypePowerManagementHpRight PowerManagementHPREN {
    Max9700197002TypePowerManagementHpRight get ();
    void set (Max9700197002TypePowerManagementHpRight value);
}
member PowerManagementHPREN : Max9700197002TypePowerManagementHpRight with get, set

Property Value

Type: Max9700197002TypePowerManagementHpRight
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.PowerManagementLPMODE Property

IRD

Max9700197002PowerManagementLPMODE Property

Power Management: LPMODE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypePowerManagementMode PowerManagementLPMODE { get; set; }
Public Property PowerManagementLPMODE As Max9700197002TypePowerManagementMode
    Get
    Set
public:
property Max9700197002TypePowerManagementMode PowerManagementLPMODE {
    Max9700197002TypePowerManagementMode get ();
    void set (Max9700197002TypePowerManagementMode value);
}
member PowerManagementLPMODE : Max9700197002TypePowerManagementMode with get, set

Property Value

Type: Max9700197002TypePowerManagementMode
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.PowerManagementSHDN Property

IRD

Max9700197002PowerManagementSHDN Property

Power Management: SHDN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypePowerManagementShutdown PowerManagementSHDN { get; set; }
Public Property PowerManagementSHDN As Max9700197002TypePowerManagementShutdown
    Get
    Set
public:
property Max9700197002TypePowerManagementShutdown PowerManagementSHDN {
    Max9700197002TypePowerManagementShutdown get ();
    void set (Max9700197002TypePowerManagementShutdown value);
}
member PowerManagementSHDN : Max9700197002TypePowerManagementShutdown with get, set

Property Value

Type: Max9700197002TypePowerManagementShutdown
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.PowerManagementSPKEN Property

IRD

Max9700197002PowerManagementSPKEN Property

Power Management: SPKEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypePowerManagementSpeaker PowerManagementSPKEN { get; set; }
Public Property PowerManagementSPKEN As Max9700197002TypePowerManagementSpeaker
    Get
    Set
public:
property Max9700197002TypePowerManagementSpeaker PowerManagementSPKEN {
    Max9700197002TypePowerManagementSpeaker get ();
    void set (Max9700197002TypePowerManagementSpeaker value);
}
member PowerManagementSPKEN : Max9700197002TypePowerManagementSpeaker with get, set

Property Value

Type: Max9700197002TypePowerManagementSpeaker
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.RevisionID Property

IRD

Max9700197002RevisionID Property

Revision ID

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionID { get; }
Public ReadOnly Property RevisionID As Byte
    Get
public:
property unsigned char RevisionID {
    unsigned char get ();
}
member RevisionID : byte with get

Property Value

Type: Byte
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.SpeakerFFM Property

IRD

Max9700197002SpeakerFFM Property

Speaker: FFM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeSpeakerFrequency SpeakerFFM { get; set; }
Public Property SpeakerFFM As Max9700197002TypeSpeakerFrequency
    Get
    Set
public:
property Max9700197002TypeSpeakerFrequency SpeakerFFM {
    Max9700197002TypeSpeakerFrequency get ();
    void set (Max9700197002TypeSpeakerFrequency value);
}
member SpeakerFFM : Max9700197002TypeSpeakerFrequency with get, set

Property Value

Type: Max9700197002TypeSpeakerFrequency
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.SpeakerMixerSPKMIX Property

IRD

Max9700197002SpeakerMixerSPKMIX Property

Speaker Mixer: SPKMIX

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeSpeakerMixerIn SpeakerMixerSPKMIX { get; set; }
Public Property SpeakerMixerSPKMIX As Max9700197002TypeSpeakerMixerIn
    Get
    Set
public:
property Max9700197002TypeSpeakerMixerIn SpeakerMixerSPKMIX {
    Max9700197002TypeSpeakerMixerIn get ();
    void set (Max9700197002TypeSpeakerMixerIn value);
}
member SpeakerMixerSPKMIX : Max9700197002TypeSpeakerMixerIn with get, set

Property Value

Type: Max9700197002TypeSpeakerMixerIn
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.SpeakerSPKM Property

IRD

Max9700197002SpeakerSPKM Property

Speaker: SPKM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeSpeakerMute SpeakerSPKM { get; set; }
Public Property SpeakerSPKM As Max9700197002TypeSpeakerMute
    Get
    Set
public:
property Max9700197002TypeSpeakerMute SpeakerSPKM {
    Max9700197002TypeSpeakerMute get ();
    void set (Max9700197002TypeSpeakerMute value);
}
member SpeakerSPKM : Max9700197002TypeSpeakerMute with get, set

Property Value

Type: Max9700197002TypeSpeakerMute
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.SpeakerSPKVOL Property

IRD

Max9700197002SpeakerSPKVOL Property

Speaker: SPKVOL (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9700197002TypeSpeakerVolume SpeakerSPKVOL { get; set; }
Public Property SpeakerSPKVOL As Max9700197002TypeSpeakerVolume
    Get
    Set
public:
property Max9700197002TypeSpeakerVolume SpeakerSPKVOL {
    Max9700197002TypeSpeakerVolume get ();
    void set (Max9700197002TypeSpeakerVolume value);
}
member SpeakerSPKVOL : Max9700197002TypeSpeakerVolume with get, set

Property Value

Type: Max9700197002TypeSpeakerVolume
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002 Methods

The Max9700197002 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.Flush Method

IRD

Max9700197002Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max9700197002 Class
telos.Ird.Maxim Namespace


Max9700197002.TypeChargePumpMode Enumeration

IRD

Max9700197002TypeChargePumpMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargePumpMode
Public Enumeration TypeChargePumpMode
public enum class TypeChargePumpMode
type TypeChargePumpMode
Members
Member name | Value | Description
ClassHMode | 0 | Class H Mode
FixedSupplyMode | 1 | Fixed-Supply Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypeChargePumpSelect Enumeration

IRD

Max9700197002TypeChargePumpSelect Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargePumpSelect
Public Enumeration TypeChargePumpSelect
public enum class TypeChargePumpSelect
type TypeChargePumpSelect
Members
Member name | Value | Description
ChargePumpOutputSelect18VOnHPVDDHPVSS | 0 | Charge-Pump Output Select: +/- 1.8 V On HPVDD/HPVSS
ChargePumpOutputSelect09VOnHPVDDHPVSS | 1 | Charge-Pump Output Select: +/- 0.9 V On HPVDD/HPVSS
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypeHeadphoneLeftMute Enumeration

IRD

Max9700197002TypeHeadphoneLeftMute Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphoneLeftMute
Public Enumeration TypeHeadphoneLeftMute
public enum class TypeHeadphoneLeftMute
type TypeHeadphoneLeftMute
Members
Member name | Value | Description
LeftHeadphoneUnmuted | 0 | Left Headphone: Unmuted
LeftHeadphoneMuted | 1 | Left Headphone: Muted
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypeHeadphoneLeftSlewing Enumeration

IRD

Max9700197002TypeHeadphoneLeftSlewing Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphoneLeftSlewing
Public Enumeration TypeHeadphoneLeftSlewing
public enum class TypeHeadphoneLeftSlewing
type TypeHeadphoneLeftSlewing
Members
Member name | Value | Description
VolumeSlewingEnabled | 0 | Volume Slewing: Enabled
VolumeSlewingDisabled | 1 | Volume Slewing: Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypeHeadphoneLeftZeroCrossing Enumeration

IRD

Max9700197002TypeHeadphoneLeftZeroCrossing Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphoneLeftZeroCrossing
Public Enumeration TypeHeadphoneLeftZeroCrossing
public enum class TypeHeadphoneLeftZeroCrossing
type TypeHeadphoneLeftZeroCrossing
Members
Member name | Value | Description
ZeroCrossingDetectionEnabled | 0 | Zero Crossing Detection: Enabled
ZeroCrossingDetectionDisabled | 1 | Zero Crossing Detection: Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypeHeadphoneMixersIn Enumeration

IRD

Max9700197002TypeHeadphoneMixersIn Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphoneMixersIn
Public Enumeration TypeHeadphoneMixersIn
public enum class TypeHeadphoneMixersIn
type TypeHeadphoneMixersIn
Members
Member name | Value | Description
NoInput | 0 | No Input
INA1DisabledWhenINADIFF1 | 1 | INA1 (Disabled When INADIFF = 1)
INA2SelectWhenINADIFF1 | 2 | INA2 (Select When INADIFF = 1)
INB1DisabledWhenINBDIFF1 | 4 | INB1 (Disabled When INBDIFF = 1)
INB2SelectWhenINBDIFF1 | 8 | INB2 (Select When INBDIFF = 1)
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypeHeadphoneRightGain Enumeration

IRD

Max9700197002TypeHeadphoneRightGain Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphoneRightGain
Public Enumeration TypeHeadphoneRightGain
public enum class TypeHeadphoneRightGain
type TypeHeadphoneRightGain
Members
Member name | Value | Description
AmplifierGain0DB | 0 | Amplifier Gain: 0 dB
AmplifierGain3DB | 1 | Amplifier Gain: 3 dB
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypeHeadphoneRightMute Enumeration

IRD

Max9700197002TypeHeadphoneRightMute Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphoneRightMute
Public Enumeration TypeHeadphoneRightMute
public enum class TypeHeadphoneRightMute
type TypeHeadphoneRightMute
Members
Member name | Value | Description
HeadphoneRightUnmuted | 0 | Headphone Right: Unmuted
HeadphoneRightMuted | 1 | Headphone Right: Muted
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypeHeadphoneVolume Enumeration

IRD

Max9700197002TypeHeadphoneVolume Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphoneVolume
Public Enumeration TypeHeadphoneVolume
public enum class TypeHeadphoneVolume
type TypeHeadphoneVolume
Members
Member name | Value | Description
Value_M_64 | 0 | -64
Value_M_60 | 1 | -60
Value_M_56 | 2 | -56
Value_M_52 | 3 | -52
Value_M_48 | 4 | -48
Value_M_44 | 5 | -44
Value_M_40 | 6 | -40
Value_M_37 | 7 | -37
Value_M_34 | 8 | -34
Value_M_31 | 9 | -31
Value_M_28 | 10 | -28
Value_M_25 | 11 | -25
Value_M_22 | 12 | -22
Value_M_19 | 13 | -19
Value_M_16 | 14 | -16
Value_M_14 | 15 | -14
Value_M_12 | 16 | -12
Value_M_10 | 17 | -10
Value_M_8 | 18 | -8
Value_M_6 | 19 | -6
Value_M_4 | 20 | -4
Value_M_2 | 21 | -2
Value_M_1 | 22 | -1
Value_0 | 23 | 0
Value_1 | 24 | 1
Value_2 | 25 | 2
Value_3 | 26 | 3
Value_4 | 27 | 4
Value_4_5 | 28 | 4.5
Value_5 | 29 | 5
Value_5_5 | 30 | 5.5
Value_6 | 31 | 6
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypeInputGainInputa Enumeration

IRD

Max9700197002TypeInputGainInputa Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInputGainInputa
Public Enumeration TypeInputGainInputa
public enum class TypeInputGainInputa
type TypeInputGainInputa
Members
Member name | Value | Description
StereoSingleEnded | 0 | Stereo Single-Ended
MonoDifferential | 1 | Mono Differential
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypeInputGainInputb Enumeration

IRD

Max9700197002TypeInputGainInputb Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInputGainInputb
Public Enumeration TypeInputGainInputb
public enum class TypeInputGainInputb
type TypeInputGainInputb
Members
Member name | Value | Description
StereoSingleEnded | 0 | Stereo Single-Ended
MonoDifferential | 1 | Mono Differential
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypeInputGainPreampa Enumeration

IRD

Max9700197002TypeInputGainPreampa Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInputGainPreampa
Public Enumeration TypeInputGainPreampa
public enum class TypeInputGainPreampa
type TypeInputGainPreampa
Members
Member name | Value | Description
Value_6DB | 0 | -6 dB
Value_3DB | 1 | -3 dB
Value_0DB | 2 | 0 dB
Value_3DB__1 | 3 | 3 dB
Value_6DB__1 | 4 | 6 dB
Value_9DB | 5 | 9 dB
Value_18DB | 6 | 18 dB
External | 7 | External
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypeInputGainPreampb Enumeration

IRD

Max9700197002TypeInputGainPreampb Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInputGainPreampb
Public Enumeration TypeInputGainPreampb
public enum class TypeInputGainPreampb
type TypeInputGainPreampb
Members
Member name | Value | Description
Value_6DB | 0 | -6 dB
Value_3DB | 1 | -3 dB
Value_0DB | 2 | 0 dB
Value_3DB__1 | 3 | 3 dB
Value_6DB__1 | 4 | 6 dB
Value_9DB | 5 | 9 dB
Value_18DB | 6 | 18 dB
External | 7 | External
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypeLimiterDistortionLimit Enumeration

IRD

Max9700197002TypeLimiterDistortionLimit Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLimiterDistortionLimit
Public Enumeration TypeLimiterDistortionLimit
public enum class TypeLimiterDistortionLimit
type TypeLimiterDistortionLimit
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_4 | 1 | <= 4%
Value_5 | 10 | <= 5%
Value_6 | 11 | <= 6%
Value_8 | 12 | <= 8%
Value_11 | 13 | <= 11%
Value_12 | 14 | <= 12%
Value_15 | 15 | <= 15%
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypeLimiterDistortionTime Enumeration

IRD

Max9700197002TypeLimiterDistortionTime Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLimiterDistortionTime
Public Enumeration TypeLimiterDistortionTime
public enum class TypeLimiterDistortionTime
type TypeLimiterDistortionTime
Members
Member name | Value | Description
DistortionReleaseTimeConstant14 | 0 | Distortion Release Time Constant: 1.4
DistortionReleaseTimeConstant28 | 1 | Distortion Release Time Constant: 2.8
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypePowerManagementAnalog Enumeration

IRD

Max9700197002TypePowerManagementAnalog Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerManagementAnalog
Public Enumeration TypePowerManagementAnalog
public enum class TypePowerManagementAnalog
type TypePowerManagementAnalog
Members
Member name | Value | Description
AnalogSwitchOpen | 0 | Analog Switch: Open
AnalogSwitchClosed | 1 | Analog Switch: Closed
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypePowerManagementHpLeft Enumeration

IRD

Max9700197002TypePowerManagementHpLeft Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerManagementHpLeft
Public Enumeration TypePowerManagementHpLeft
public enum class TypePowerManagementHpLeft
type TypePowerManagementHpLeft
Members
Member name | Value | Description
LeftHeadphoneDisabled | 0 | Left Headphone: Disabled
LeftHeadphoneEnabled | 1 | Left Headphone: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypePowerManagementHpRight Enumeration

IRD

Max9700197002TypePowerManagementHpRight Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerManagementHpRight
Public Enumeration TypePowerManagementHpRight
public enum class TypePowerManagementHpRight
type TypePowerManagementHpRight
Members
Member name | Value | Description
RightHeadphoneDisabled | 0 | Right Headphone: Disabled
RightHeadphoneEnabled | 1 | Right Headphone: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypePowerManagementMode Enumeration

IRD

Max9700197002TypePowerManagementMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerManagementMode
Public Enumeration TypePowerManagementMode
public enum class TypePowerManagementMode
type TypePowerManagementMode
Members
Member name | Value | Description
LowPowerHeadphoneModeDisabled | 0 | Low-Power Headphone Mode: Disabled
LowPowerHeadphoneModeINAConnectedToHPOut | 1 | Low-Power Headphone Mode: INA Connected To HP Out
LowPowerHeadphoneModeINBConnectedToHPOut | 2 | Low-Power Headphone Mode: INB Connected To HP Out
LowPowerHeadphoneModeINAToHPLINBToHPR | 3 | Low-Power Headphone Mode: INA To HPL, INB To HPR
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypePowerManagementShutdown Enumeration

IRD

Max9700197002TypePowerManagementShutdown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerManagementShutdown
Public Enumeration TypePowerManagementShutdown
public enum class TypePowerManagementShutdown
type TypePowerManagementShutdown
Members
Member name | Value | Description
SoftwareShutdownDeviceDisabled | 0 | Software Shutdown: Device Disabled
SoftwareShutdownDeviceEnabled | 1 | Software Shutdown: Device Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypePowerManagementSpeaker Enumeration

IRD

Max9700197002TypePowerManagementSpeaker Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerManagementSpeaker
Public Enumeration TypePowerManagementSpeaker
public enum class TypePowerManagementSpeaker
type TypePowerManagementSpeaker
Members
Member name | Value | Description
SpeakerAmplifierDisabled | 0 | Speaker Amplifier: Disabled
SpeakerAmplifierEnabled | 1 | Speaker Amplifier: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypeSpeakerFrequency Enumeration

IRD

Max9700197002TypeSpeakerFrequency Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSpeakerFrequency
Public Enumeration TypeSpeakerFrequency
public enum class TypeSpeakerFrequency
type TypeSpeakerFrequency
Members
Member name | Value | Description
SpreadSpectrumMode | 0 | Spread-Spectrum Mode
FixedFrequencyMode | 1 | Fixed-Frequency Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypeSpeakerMixerIn Enumeration

IRD

Max9700197002TypeSpeakerMixerIn Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSpeakerMixerIn
Public Enumeration TypeSpeakerMixerIn
public enum class TypeSpeakerMixerIn
type TypeSpeakerMixerIn
Members
Member name | Value | Description
NoInput | 0 | No Input
INA1DisabledWhenINADIFF1 | 1 | INA1 (Disabled When INADIFF = 1)
INA2SelectWhenINADIFF1 | 2 | INA2 (Select When INADIFF = 1)
INB1DisabledWhenINBDIFF1 | 4 | INB1 (Disabled When INBDIFF = 1)
INB2SelectWhenINBDIFF1 | 8 | INB2 (Select When INBDIFF = 1)
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypeSpeakerMute Enumeration

IRD

Max9700197002TypeSpeakerMute Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSpeakerMute
Public Enumeration TypeSpeakerMute
public enum class TypeSpeakerMute
type TypeSpeakerMute
Members
Member name | Value | Description
SpeakerUnmuted | 0 | Speaker: Unmuted
SpeakerMuted | 1 | Speaker: Muted
See Also

Reference

telos.Ird.Maxim Namespace


Max9700197002.TypeSpeakerVolume Enumeration

IRD

Max9700197002TypeSpeakerVolume Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSpeakerVolume
Public Enumeration TypeSpeakerVolume
public enum class TypeSpeakerVolume
type TypeSpeakerVolume
Members
Member name | Value | Description
Value_M_30 | 0 | -30
Value_M_26 | 25 | -26
Value_M_22 | 26 | -22
Value_M_18 | 27 | -18
Value_M_14 | 28 | -14
Value_M_12 | 29 | -12
Value_M_10 | 30 | -10
Value_M_8 | 31 | -8
Value_M_6 | 32 | -6
Value_M_4 | 33 | -4
Value_M_2 | 34 | -2
Value_0 | 35 | 0
Value_1 | 36 | 1
Value_2 | 37 | 2
Value_3 | 38 | 3
Value_4 | 39 | 4
Value_5 | 40 | 5
Value_6 | 41 | 6
Value_7 | 42 | 7
Value_8 | 43 | 8
Value_9 | 44 | 9
Value_10 | 45 | 10
Value_11 | 46 | 11
Value_12 | 47 | 12
Value_12_5 | 48 | 12.5
Value_13 | 49 | 13
Value_13_5 | 50 | 13.5
Value_14 | 51 | 14
Value_14_5 | 52 | 14.5
Value_15 | 53 | 15
Value_15_5 | 54 | 15.5
Value_16 | 55 | 16
Value_16_5 | 56 | 16.5
Value_17 | 57 | 17
Value_17_5 | 58 | 17.5
Value_18 | 59 | 18
Value_18_5 | 60 | 18.5
Value_19 | 61 | 19
Value_19_5 | 62 | 19.5
Value_20 | 63 | 20
See Also

Reference

telos.Ird.Maxim Namespace


Max9856 Class

Maxim: MAX 9856
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax9856

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max9856
Public Class Max9856
public ref class Max9856
type Max9856 =  class end

The Max9856 type exposes the following members.

Constructors
 | Name | Description
Public method | Max9856 | Constructor
Top
Properties
 | Name | Description
Public property | ADCInterfaceADCNI | ADC Interface: ADCNI
Public property | ADCInterfaceMSBAPLLEN | ADC Interface MSB: APLLEN
Public property | ADCLevelAGAIN | ADC Level: AGAIN (unit: dB)
Public property | ADCLevelANTH | ADC Level: ANTH (unit: dB)
Public property | ADCMixerLeftMIXINLAUXOUT | ADC Mixer Left: MIXINL-AUXOUT
Public property | ADCMixerLeftMIXINLLINEIN1 | ADC Mixer Left: MIXINL-LINEIN1
Public property | ADCMixerLeftMIXINLLINEIN2 | ADC Mixer Left: MIXINL-LINEIN2
Public property | ADCMixerLeftMIXINLMICL | ADC Mixer Left: MIXINL-MICL
Public property | ADCMixerLeftMIXINLMICR | ADC Mixer Left: MIXINL-MICR
Public property | ADCMixerRightMIXINRAUXOUT | ADC Mixer Right: MIXINR-AUXOUT
Public property | ADCMixerRightMIXINRLINEIN1 | ADC Mixer Right: MIXINR-LINEIN1
Public property | ADCMixerRightMIXINRLINEIN2 | ADC Mixer Right: MIXINR-LINEIN2
Public property | ADCMixerRightMIXINRMICL | ADC Mixer Right: MIXINR-MICL
Public property | ADCMixerRightMIXINRMICR | ADC Mixer Right: MIXINR-MICR
Public property | ADCSystemABCI | ADC System: ABCI
Public property | ADCSystemADLY | ADC System: ADLY
Public property | ADCSystemAPIN | ADC System: APIN
Public property | ADCSystemAWCI | ADC System: AWCI
Public property | AGCControlAGCATK | AGC Control: AGCATK (unit: ms)
Public property | AGCControlAGCHLD | AGC Control: AGCHLD
Public property | AGCControlAGCRLS | AGC Control: AGCRLS
Public property | AGCThresholdAGCSRC | AGC Threshold: AGCSRC
Public property | AGCThresholdAGCSTH | AGC Threshold: AGCSTH (unit: dB)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AUXINGainPGAAUX | AUXIN Gain: PGAAUX (unit: dB)
Public property | ClockControlBSEL | Clock Control: BSEL
Public property | ClockControlMAS | Clock Control: MAS
Public property | ClockControlPSCLK | Clock Control: PSCLK
Public property | DACInterfaceDACNI | DAC Interface: DACNI
Public property | DACInterfaceMSBDPLLEN | DAC Interface MSB: DPLLEN
Public property | DACSystemDBCI | DAC System: DBCI
Public property | DACSystemDDLY | DAC System: DDLY
Public property | DACSystemDHF | DAC System: DHF
Public property | DACSystemDRATE | DAC System: DRATE
Public property | DACSystemDWCI | DAC System: DWCI
Public property | DACSystemPCM | DAC System: PCM
Public property | DACSystemWS | DAC System: WS
Public property | DigitalInputGain | Digital Input Gain (unit: dB)
Public property | HeadsetSystemENHPL | Headset System: EN-HPL
Public property | HeadsetSystemENHPR | Headset System: EN-HPR
Public property | HeadsetSystemENJACKSNS | Headset System: EN-JACKSNS
Public property | HeadsetSystemJDETEN | Headset System: JDETEN
Public property | HighpassFilterADCHP | Highpass Filter: ADCHP
Public property | HighpassFilterDACHP | Highpass Filter: DACHP
Public property | HPLVolumeHPMUTE | HPL Volume: HPMUTE
Public property | HPLVolumeHPVOLL | HPL Volume: HPVOLL
Public property | HPRVolumeHPVOLR | HPR Volume: HPVOLR
Public property | InterruptEnableICLD | Interrupt Enable: ICLD
Public property | InterruptEnableIGPI | Interrupt Enable: IGPI
Public property | InterruptEnableIHPOCL | Interrupt Enable: IHPOCL
Public property | InterruptEnableIHPOCR | Interrupt Enable: IHPOCR
Public property | InterruptEnableIJDET | Interrupt Enable: IJDET
Public property | InterruptEnableISLD | Interrupt Enable: ISLD
Public property | InterruptEnableIULK | Interrupt Enable: IULK
Public property | LINEIN1GainPGAL1 | LINEIN1 Gain: PGAL1 (unit: dB)
Public property | LINEIN2GainPGAL2 | LINEIN2 Gain: PGAL2 (unit: dB)
Public property | MICLGainPAENL | MICL Gain: PAENL
Public property | MICLGainPGAML | MICL Gain: PGAML (unit: dB)
Public property | MICModeLMICDIF | MIC Mode: LMICDIF
Public property | MICModeMBSEL | MIC Mode: MBSEL
Public property | MICModeMMIC | MIC Mode: MMIC
Public property | MICRGainPAENR | MICR Gain: PAENR
Public property | MICRGainPGAMR | MICR Gain: PGAMR (unit: dB)
Public property | OutputMixerMXOUTLDAC | Output Mixer: MXOUTL-DAC
Public property | OutputMixerMXOUTLLINEIN1 | Output Mixer: MXOUTL-LINEIN1
Public property | OutputMixerMXOUTLLINEIN2 | Output Mixer: MXOUTL-LINEIN2
Public property | OutputMixerMXOUTLMICL | Output Mixer: MXOUTL-MICL
Public property | OutputMixerMXOUTRDAC | Output Mixer: MXOUTR-DAC
Public property | OutputMixerMXOUTRLINEIN1 | Output Mixer: MXOUTR-LINEIN1
Public property | OutputMixerMXOUTRLINEIN2 | Output Mixer: MXOUTR-LINEIN2
Public property | OutputMixerMXOUTRMICR | Output Mixer: MXOUTR-MICR
Public property | OutputModeAUXDC | Output Mode: AUXDC
Public property | OutputModeAUXMIX | Output Mode: AUXMIX
Public property | OutputModeHPMODE | Output Mode: HPMODE
Public property | OutputModeVSEN | Output Mode: VSEN
Public property | PowerSystemADLEN | Power System: ADLEN
Public property | PowerSystemADREN | Power System: ADREN
Public property | PowerSystemDALEN | Power System: DALEN
Public property | PowerSystemDAREN | Power System: DAREN
Public property | PowerSystemDIGEN | Power System: DIGEN
Public property | PowerSystemLOUTEN | Power System: LOUTEN
Public property | PowerSystemSHDN | Power System: SHDN
Public property | Status0CLD | Status 0: CLD
Public property | Status0GPI | Status 0: GPI
Public property | Status0HPOCL | Status 0: HPOCL
Public property | Status0HPOCR | Status 0: HPOCR
Public property | Status0JDET | Status 0: JDET
Public property | Status0JKMIC | Status 0: JKMIC
Public property | Status0SLD | Status 0: SLD
Public property | Status0ULK | Status 0: ULK
Public property | Status1HSDETL | Status 1: HSDETL
Public property | Status1HSDETR | Status 1: HSDETR
Public property | Status1JKSNS | Status 1: JKSNS
Public property | Status1JSDET | Status 1: JSDET
Public property | Status1LSNS | Status 1: LSNS
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Power Audio CODEC With DirectDrive Headphone Amplifiers
See Also

Reference

telos.Ird.Maxim Namespace


Max9856 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max9856(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max9856

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856 Properties

The Max9856 type exposes the following members.

Properties
 | Name | Description
Public property | ADCInterfaceADCNI | ADC Interface: ADCNI
Public property | ADCInterfaceMSBAPLLEN | ADC Interface MSB: APLLEN
Public property | ADCLevelAGAIN | ADC Level: AGAIN (unit: dB)
Public property | ADCLevelANTH | ADC Level: ANTH (unit: dB)
Public property | ADCMixerLeftMIXINLAUXOUT | ADC Mixer Left: MIXINL-AUXOUT
Public property | ADCMixerLeftMIXINLLINEIN1 | ADC Mixer Left: MIXINL-LINEIN1
Public property | ADCMixerLeftMIXINLLINEIN2 | ADC Mixer Left: MIXINL-LINEIN2
Public property | ADCMixerLeftMIXINLMICL | ADC Mixer Left: MIXINL-MICL
Public property | ADCMixerLeftMIXINLMICR | ADC Mixer Left: MIXINL-MICR
Public property | ADCMixerRightMIXINRAUXOUT | ADC Mixer Right: MIXINR-AUXOUT
Public property | ADCMixerRightMIXINRLINEIN1 | ADC Mixer Right: MIXINR-LINEIN1
Public property | ADCMixerRightMIXINRLINEIN2 | ADC Mixer Right: MIXINR-LINEIN2
Public property | ADCMixerRightMIXINRMICL | ADC Mixer Right: MIXINR-MICL
Public property | ADCMixerRightMIXINRMICR | ADC Mixer Right: MIXINR-MICR
Public property | ADCSystemABCI | ADC System: ABCI
Public property | ADCSystemADLY | ADC System: ADLY
Public property | ADCSystemAPIN | ADC System: APIN
Public property | ADCSystemAWCI | ADC System: AWCI
Public property | AGCControlAGCATK | AGC Control: AGCATK (unit: ms)
Public property | AGCControlAGCHLD | AGC Control: AGCHLD
Public property | AGCControlAGCRLS | AGC Control: AGCRLS
Public property | AGCThresholdAGCSRC | AGC Threshold: AGCSRC
Public property | AGCThresholdAGCSTH | AGC Threshold: AGCSTH (unit: dB)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AUXINGainPGAAUX | AUXIN Gain: PGAAUX (unit: dB)
Public property | ClockControlBSEL | Clock Control: BSEL
Public property | ClockControlMAS | Clock Control: MAS
Public property | ClockControlPSCLK | Clock Control: PSCLK
Public property | DACInterfaceDACNI | DAC Interface: DACNI
Public property | DACInterfaceMSBDPLLEN | DAC Interface MSB: DPLLEN
Public property | DACSystemDBCI | DAC System: DBCI
Public property | DACSystemDDLY | DAC System: DDLY
Public property | DACSystemDHF | DAC System: DHF
Public property | DACSystemDRATE | DAC System: DRATE
Public property | DACSystemDWCI | DAC System: DWCI
Public property | DACSystemPCM | DAC System: PCM
Public property | DACSystemWS | DAC System: WS
Public property | DigitalInputGain | Digital Input Gain (unit: dB)
Public property | HeadsetSystemENHPL | Headset System: EN-HPL
Public property | HeadsetSystemENHPR | Headset System: EN-HPR
Public property | HeadsetSystemENJACKSNS | Headset System: EN-JACKSNS
Public property | HeadsetSystemJDETEN | Headset System: JDETEN
Public property | HighpassFilterADCHP | Highpass Filter: ADCHP
Public property | HighpassFilterDACHP | Highpass Filter: DACHP
Public property | HPLVolumeHPMUTE | HPL Volume: HPMUTE
Public property | HPLVolumeHPVOLL | HPL Volume: HPVOLL
Public property | HPRVolumeHPVOLR | HPR Volume: HPVOLR
Public property | InterruptEnableICLD | Interrupt Enable: ICLD
Public property | InterruptEnableIGPI | Interrupt Enable: IGPI
Public property | InterruptEnableIHPOCL | Interrupt Enable: IHPOCL
Public property | InterruptEnableIHPOCR | Interrupt Enable: IHPOCR
Public property | InterruptEnableIJDET | Interrupt Enable: IJDET
Public property | InterruptEnableISLD | Interrupt Enable: ISLD
Public property | InterruptEnableIULK | Interrupt Enable: IULK
Public property | LINEIN1GainPGAL1 | LINEIN1 Gain: PGAL1 (unit: dB)
Public property | LINEIN2GainPGAL2 | LINEIN2 Gain: PGAL2 (unit: dB)
Public property | MICLGainPAENL | MICL Gain: PAENL
Public property | MICLGainPGAML | MICL Gain: PGAML (unit: dB)
Public property | MICModeLMICDIF | MIC Mode: LMICDIF
Public property | MICModeMBSEL | MIC Mode: MBSEL
Public property | MICModeMMIC | MIC Mode: MMIC
Public property | MICRGainPAENR | MICR Gain: PAENR
Public property | MICRGainPGAMR | MICR Gain: PGAMR (unit: dB)
Public property | OutputMixerMXOUTLDAC | Output Mixer: MXOUTL-DAC
Public property | OutputMixerMXOUTLLINEIN1 | Output Mixer: MXOUTL-LINEIN1
Public property | OutputMixerMXOUTLLINEIN2 | Output Mixer: MXOUTL-LINEIN2
Public property | OutputMixerMXOUTLMICL | Output Mixer: MXOUTL-MICL
Public property | OutputMixerMXOUTRDAC | Output Mixer: MXOUTR-DAC
Public property | OutputMixerMXOUTRLINEIN1 | Output Mixer: MXOUTR-LINEIN1
Public property | OutputMixerMXOUTRLINEIN2 | Output Mixer: MXOUTR-LINEIN2
Public property | OutputMixerMXOUTRMICR | Output Mixer: MXOUTR-MICR
Public property | OutputModeAUXDC | Output Mode: AUXDC
Public property | OutputModeAUXMIX | Output Mode: AUXMIX
Public property | OutputModeHPMODE | Output Mode: HPMODE
Public property | OutputModeVSEN | Output Mode: VSEN
Public property | PowerSystemADLEN | Power System: ADLEN
Public property | PowerSystemADREN | Power System: ADREN
Public property | PowerSystemDALEN | Power System: DALEN
Public property | PowerSystemDAREN | Power System: DAREN
Public property | PowerSystemDIGEN | Power System: DIGEN
Public property | PowerSystemLOUTEN | Power System: LOUTEN
Public property | PowerSystemSHDN | Power System: SHDN
Public property | Status0CLD | Status 0: CLD
Public property | Status0GPI | Status 0: GPI
Public property | Status0HPOCL | Status 0: HPOCL
Public property | Status0HPOCR | Status 0: HPOCR
Public property | Status0JDET | Status 0: JDET
Public property | Status0JKMIC | Status 0: JKMIC
Public property | Status0SLD | Status 0: SLD
Public property | Status0ULK | Status 0: ULK
Public property | Status1HSDETL | Status 1: HSDETL
Public property | Status1HSDETR | Status 1: HSDETR
Public property | Status1JKSNS | Status 1: JKSNS
Public property | Status1JSDET | Status 1: JSDET
Public property | Status1LSNS | Status 1: LSNS
Top
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ADCInterfaceADCNI Property

IRD

Max9856ADCInterfaceADCNI Property

ADC Interface: ADCNI

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCInterfaceADCNI { get; set; }
Public Property ADCInterfaceADCNI As UShort
    Get
    Set
public:
property unsigned short ADCInterfaceADCNI {
    unsigned short get ();
    void set (unsigned short value);
}
member ADCInterfaceADCNI : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ADCInterfaceMSBAPLLEN Property

IRD

Max9856ADCInterfaceMSBAPLLEN Property

ADC Interface MSB: APLLEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAdcInterfaceMsbPll ADCInterfaceMSBAPLLEN { get; set; }
Public Property ADCInterfaceMSBAPLLEN As Max9856TypeAdcInterfaceMsbPll
    Get
    Set
public:
property Max9856TypeAdcInterfaceMsbPll ADCInterfaceMSBAPLLEN {
    Max9856TypeAdcInterfaceMsbPll get ();
    void set (Max9856TypeAdcInterfaceMsbPll value);
}
member ADCInterfaceMSBAPLLEN : Max9856TypeAdcInterfaceMsbPll with get, set

Property Value

Type: Max9856TypeAdcInterfaceMsbPll
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ADCLevelAGAIN Property

IRD

Max9856ADCLevelAGAIN Property

ADC Level: AGAIN (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ADCLevelAGAIN { get; set; }
Public Property ADCLevelAGAIN As Double
    Get
    Set
public:
property double ADCLevelAGAIN {
    double get ();
    void set (double value);
}
member ADCLevelAGAIN : float with get, set

Property Value

Type: Double
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ADCLevelANTH Property

IRD

Max9856ADCLevelANTH Property

ADC Level: ANTH (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAdcLevelNoise ADCLevelANTH { get; set; }
Public Property ADCLevelANTH As Max9856TypeAdcLevelNoise
    Get
    Set
public:
property Max9856TypeAdcLevelNoise ADCLevelANTH {
    Max9856TypeAdcLevelNoise get ();
    void set (Max9856TypeAdcLevelNoise value);
}
member ADCLevelANTH : Max9856TypeAdcLevelNoise with get, set

Property Value

Type: Max9856TypeAdcLevelNoise
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ADCMixerLeftMIXINLAUXOUT Property

IRD

Max9856ADCMixerLeftMIXINLAUXOUT Property

ADC Mixer Left: MIXINL-AUXOUT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAdcMixerAuxout ADCMixerLeftMIXINLAUXOUT { get; set; }
Public Property ADCMixerLeftMIXINLAUXOUT As Max9856TypeAdcMixerAuxout
    Get
    Set
public:
property Max9856TypeAdcMixerAuxout ADCMixerLeftMIXINLAUXOUT {
    Max9856TypeAdcMixerAuxout get ();
    void set (Max9856TypeAdcMixerAuxout value);
}
member ADCMixerLeftMIXINLAUXOUT : Max9856TypeAdcMixerAuxout with get, set

Property Value

Type: Max9856TypeAdcMixerAuxout
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ADCMixerLeftMIXINLLINEIN1 Property

IRD

Max9856ADCMixerLeftMIXINLLINEIN1 Property

ADC Mixer Left: MIXINL-LINEIN1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAdcMixerLinein1 ADCMixerLeftMIXINLLINEIN1 { get; set; }
Public Property ADCMixerLeftMIXINLLINEIN1 As Max9856TypeAdcMixerLinein1
    Get
    Set
public:
property Max9856TypeAdcMixerLinein1 ADCMixerLeftMIXINLLINEIN1 {
    Max9856TypeAdcMixerLinein1 get ();
    void set (Max9856TypeAdcMixerLinein1 value);
}
member ADCMixerLeftMIXINLLINEIN1 : Max9856TypeAdcMixerLinein1 with get, set

Property Value

Type: Max9856TypeAdcMixerLinein1
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ADCMixerLeftMIXINLLINEIN2 Property

IRD

Max9856ADCMixerLeftMIXINLLINEIN2 Property

ADC Mixer Left: MIXINL-LINEIN2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAdcMixerLinein2 ADCMixerLeftMIXINLLINEIN2 { get; set; }
Public Property ADCMixerLeftMIXINLLINEIN2 As Max9856TypeAdcMixerLinein2
    Get
    Set
public:
property Max9856TypeAdcMixerLinein2 ADCMixerLeftMIXINLLINEIN2 {
    Max9856TypeAdcMixerLinein2 get ();
    void set (Max9856TypeAdcMixerLinein2 value);
}
member ADCMixerLeftMIXINLLINEIN2 : Max9856TypeAdcMixerLinein2 with get, set

Property Value

Type: Max9856TypeAdcMixerLinein2
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ADCMixerLeftMIXINLMICL Property

IRD

Max9856ADCMixerLeftMIXINLMICL Property

ADC Mixer Left: MIXINL-MICL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAdcMixerMicl ADCMixerLeftMIXINLMICL { get; set; }
Public Property ADCMixerLeftMIXINLMICL As Max9856TypeAdcMixerMicl
    Get
    Set
public:
property Max9856TypeAdcMixerMicl ADCMixerLeftMIXINLMICL {
    Max9856TypeAdcMixerMicl get ();
    void set (Max9856TypeAdcMixerMicl value);
}
member ADCMixerLeftMIXINLMICL : Max9856TypeAdcMixerMicl with get, set

Property Value

Type: Max9856TypeAdcMixerMicl
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ADCMixerLeftMIXINLMICR Property

IRD

Max9856ADCMixerLeftMIXINLMICR Property

ADC Mixer Left: MIXINL-MICR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAdcMixerMicr ADCMixerLeftMIXINLMICR { get; set; }
Public Property ADCMixerLeftMIXINLMICR As Max9856TypeAdcMixerMicr
    Get
    Set
public:
property Max9856TypeAdcMixerMicr ADCMixerLeftMIXINLMICR {
    Max9856TypeAdcMixerMicr get ();
    void set (Max9856TypeAdcMixerMicr value);
}
member ADCMixerLeftMIXINLMICR : Max9856TypeAdcMixerMicr with get, set

Property Value

Type: Max9856TypeAdcMixerMicr
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ADCMixerRightMIXINRAUXOUT Property

IRD

Max9856ADCMixerRightMIXINRAUXOUT Property

ADC Mixer Right: MIXINR-AUXOUT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAdcMixerAuxout ADCMixerRightMIXINRAUXOUT { get; set; }
Public Property ADCMixerRightMIXINRAUXOUT As Max9856TypeAdcMixerAuxout
    Get
    Set
public:
property Max9856TypeAdcMixerAuxout ADCMixerRightMIXINRAUXOUT {
    Max9856TypeAdcMixerAuxout get ();
    void set (Max9856TypeAdcMixerAuxout value);
}
member ADCMixerRightMIXINRAUXOUT : Max9856TypeAdcMixerAuxout with get, set

Property Value

Type: Max9856TypeAdcMixerAuxout
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ADCMixerRightMIXINRLINEIN1 Property

IRD

Max9856ADCMixerRightMIXINRLINEIN1 Property

ADC Mixer Right: MIXINR-LINEIN1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAdcMixerLinein1 ADCMixerRightMIXINRLINEIN1 { get; set; }
Public Property ADCMixerRightMIXINRLINEIN1 As Max9856TypeAdcMixerLinein1
    Get
    Set
public:
property Max9856TypeAdcMixerLinein1 ADCMixerRightMIXINRLINEIN1 {
    Max9856TypeAdcMixerLinein1 get ();
    void set (Max9856TypeAdcMixerLinein1 value);
}
member ADCMixerRightMIXINRLINEIN1 : Max9856TypeAdcMixerLinein1 with get, set

Property Value

Type: Max9856TypeAdcMixerLinein1
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ADCMixerRightMIXINRLINEIN2 Property

IRD

Max9856ADCMixerRightMIXINRLINEIN2 Property

ADC Mixer Right: MIXINR-LINEIN2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAdcMixerLinein2 ADCMixerRightMIXINRLINEIN2 { get; set; }
Public Property ADCMixerRightMIXINRLINEIN2 As Max9856TypeAdcMixerLinein2
    Get
    Set
public:
property Max9856TypeAdcMixerLinein2 ADCMixerRightMIXINRLINEIN2 {
    Max9856TypeAdcMixerLinein2 get ();
    void set (Max9856TypeAdcMixerLinein2 value);
}
member ADCMixerRightMIXINRLINEIN2 : Max9856TypeAdcMixerLinein2 with get, set

Property Value

Type: Max9856TypeAdcMixerLinein2
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ADCMixerRightMIXINRMICL Property

IRD

Max9856ADCMixerRightMIXINRMICL Property

ADC Mixer Right: MIXINR-MICL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAdcMixerMicl ADCMixerRightMIXINRMICL { get; set; }
Public Property ADCMixerRightMIXINRMICL As Max9856TypeAdcMixerMicl
    Get
    Set
public:
property Max9856TypeAdcMixerMicl ADCMixerRightMIXINRMICL {
    Max9856TypeAdcMixerMicl get ();
    void set (Max9856TypeAdcMixerMicl value);
}
member ADCMixerRightMIXINRMICL : Max9856TypeAdcMixerMicl with get, set

Property Value

Type: Max9856TypeAdcMixerMicl
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ADCMixerRightMIXINRMICR Property

IRD

Max9856ADCMixerRightMIXINRMICR Property

ADC Mixer Right: MIXINR-MICR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAdcMixerMicr ADCMixerRightMIXINRMICR { get; set; }
Public Property ADCMixerRightMIXINRMICR As Max9856TypeAdcMixerMicr
    Get
    Set
public:
property Max9856TypeAdcMixerMicr ADCMixerRightMIXINRMICR {
    Max9856TypeAdcMixerMicr get ();
    void set (Max9856TypeAdcMixerMicr value);
}
member ADCMixerRightMIXINRMICR : Max9856TypeAdcMixerMicr with get, set

Property Value

Type: Max9856TypeAdcMixerMicr
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ADCSystemABCI Property

IRD

Max9856ADCSystemABCI Property

ADC System: ABCI

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAdcSystemBclock ADCSystemABCI { get; set; }
Public Property ADCSystemABCI As Max9856TypeAdcSystemBclock
    Get
    Set
public:
property Max9856TypeAdcSystemBclock ADCSystemABCI {
    Max9856TypeAdcSystemBclock get ();
    void set (Max9856TypeAdcSystemBclock value);
}
member ADCSystemABCI : Max9856TypeAdcSystemBclock with get, set

Property Value

Type: Max9856TypeAdcSystemBclock
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ADCSystemADLY Property

IRD

Max9856ADCSystemADLY Property

ADC System: ADLY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAdcSystemDelay ADCSystemADLY { get; set; }
Public Property ADCSystemADLY As Max9856TypeAdcSystemDelay
    Get
    Set
public:
property Max9856TypeAdcSystemDelay ADCSystemADLY {
    Max9856TypeAdcSystemDelay get ();
    void set (Max9856TypeAdcSystemDelay value);
}
member ADCSystemADLY : Max9856TypeAdcSystemDelay with get, set

Property Value

Type: Max9856TypeAdcSystemDelay
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ADCSystemAPIN Property

IRD

Max9856ADCSystemAPIN Property

ADC System: APIN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAdcSystemPinConfig ADCSystemAPIN { get; set; }
Public Property ADCSystemAPIN As Max9856TypeAdcSystemPinConfig
    Get
    Set
public:
property Max9856TypeAdcSystemPinConfig ADCSystemAPIN {
    Max9856TypeAdcSystemPinConfig get ();
    void set (Max9856TypeAdcSystemPinConfig value);
}
member ADCSystemAPIN : Max9856TypeAdcSystemPinConfig with get, set

Property Value

Type: Max9856TypeAdcSystemPinConfig
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ADCSystemAWCI Property

IRD

Max9856ADCSystemAWCI Property

ADC System: AWCI

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAdcSystemWordClock ADCSystemAWCI { get; set; }
Public Property ADCSystemAWCI As Max9856TypeAdcSystemWordClock
    Get
    Set
public:
property Max9856TypeAdcSystemWordClock ADCSystemAWCI {
    Max9856TypeAdcSystemWordClock get ();
    void set (Max9856TypeAdcSystemWordClock value);
}
member ADCSystemAWCI : Max9856TypeAdcSystemWordClock with get, set

Property Value

Type: Max9856TypeAdcSystemWordClock
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.AGCControlAGCATK Property

IRD

Max9856AGCControlAGCATK Property

AGC Control: AGCATK (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAgcControlAttackTime AGCControlAGCATK { get; set; }
Public Property AGCControlAGCATK As Max9856TypeAgcControlAttackTime
    Get
    Set
public:
property Max9856TypeAgcControlAttackTime AGCControlAGCATK {
    Max9856TypeAgcControlAttackTime get ();
    void set (Max9856TypeAgcControlAttackTime value);
}
member AGCControlAGCATK : Max9856TypeAgcControlAttackTime with get, set

Property Value

Type: Max9856TypeAgcControlAttackTime
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.AGCControlAGCHLD Property

IRD

Max9856AGCControlAGCHLD Property

AGC Control: AGCHLD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAgcControlHoldTime AGCControlAGCHLD { get; set; }
Public Property AGCControlAGCHLD As Max9856TypeAgcControlHoldTime
    Get
    Set
public:
property Max9856TypeAgcControlHoldTime AGCControlAGCHLD {
    Max9856TypeAgcControlHoldTime get ();
    void set (Max9856TypeAgcControlHoldTime value);
}
member AGCControlAGCHLD : Max9856TypeAgcControlHoldTime with get, set

Property Value

Type: Max9856TypeAgcControlHoldTime
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.AGCControlAGCRLS Property

IRD

Max9856AGCControlAGCRLS Property

AGC Control: AGCRLS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAgcControlReleaseTime AGCControlAGCRLS { get; set; }
Public Property AGCControlAGCRLS As Max9856TypeAgcControlReleaseTime
    Get
    Set
public:
property Max9856TypeAgcControlReleaseTime AGCControlAGCRLS {
    Max9856TypeAgcControlReleaseTime get ();
    void set (Max9856TypeAgcControlReleaseTime value);
}
member AGCControlAGCRLS : Max9856TypeAgcControlReleaseTime with get, set

Property Value

Type: Max9856TypeAgcControlReleaseTime
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.AGCThresholdAGCSRC Property

IRD

Max9856AGCThresholdAGCSRC Property

AGC Threshold: AGCSRC

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeAgcThresholdNoiseGate AGCThresholdAGCSRC { get; set; }
Public Property AGCThresholdAGCSRC As Max9856TypeAgcThresholdNoiseGate
    Get
    Set
public:
property Max9856TypeAgcThresholdNoiseGate AGCThresholdAGCSRC {
    Max9856TypeAgcThresholdNoiseGate get ();
    void set (Max9856TypeAgcThresholdNoiseGate value);
}
member AGCThresholdAGCSRC : Max9856TypeAgcThresholdNoiseGate with get, set

Property Value

Type: Max9856TypeAgcThresholdNoiseGate
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.AGCThresholdAGCSTH Property

IRD

Max9856AGCThresholdAGCSTH Property

AGC Threshold: AGCSTH (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AGCThresholdAGCSTH { get; set; }
Public Property AGCThresholdAGCSTH As Double
    Get
    Set
public:
property double AGCThresholdAGCSTH {
    double get ();
    void set (double value);
}
member AGCThresholdAGCSTH : float with get, set

Property Value

Type: Double
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.AutoFlush Property

IRD

Max9856AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.AUXINGainPGAAUX Property

IRD

Max9856AUXINGainPGAAUX Property

AUXIN Gain: PGAAUX (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AUXINGainPGAAUX { get; set; }
Public Property AUXINGainPGAAUX As Double
    Get
    Set
public:
property double AUXINGainPGAAUX {
    double get ();
    void set (double value);
}
member AUXINGainPGAAUX : float with get, set

Property Value

Type: Double
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ClockControlBSEL Property

IRD

Max9856ClockControlBSEL Property

Clock Control: BSEL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeClockControlSelect ClockControlBSEL { get; set; }
Public Property ClockControlBSEL As Max9856TypeClockControlSelect
    Get
    Set
public:
property Max9856TypeClockControlSelect ClockControlBSEL {
    Max9856TypeClockControlSelect get ();
    void set (Max9856TypeClockControlSelect value);
}
member ClockControlBSEL : Max9856TypeClockControlSelect with get, set

Property Value

Type: Max9856TypeClockControlSelect
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ClockControlMAS Property

IRD

Max9856ClockControlMAS Property

Clock Control: MAS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeClockControlMode ClockControlMAS { get; set; }
Public Property ClockControlMAS As Max9856TypeClockControlMode
    Get
    Set
public:
property Max9856TypeClockControlMode ClockControlMAS {
    Max9856TypeClockControlMode get ();
    void set (Max9856TypeClockControlMode value);
}
member ClockControlMAS : Max9856TypeClockControlMode with get, set

Property Value

Type: Max9856TypeClockControlMode
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.ClockControlPSCLK Property

IRD

Max9856ClockControlPSCLK Property

Clock Control: PSCLK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeClockControlPrescaler ClockControlPSCLK { get; set; }
Public Property ClockControlPSCLK As Max9856TypeClockControlPrescaler
    Get
    Set
public:
property Max9856TypeClockControlPrescaler ClockControlPSCLK {
    Max9856TypeClockControlPrescaler get ();
    void set (Max9856TypeClockControlPrescaler value);
}
member ClockControlPSCLK : Max9856TypeClockControlPrescaler with get, set

Property Value

Type: Max9856TypeClockControlPrescaler
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.DACInterfaceDACNI Property

IRD

Max9856DACInterfaceDACNI Property

DAC Interface: DACNI

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DACInterfaceDACNI { get; set; }
Public Property DACInterfaceDACNI As UShort
    Get
    Set
public:
property unsigned short DACInterfaceDACNI {
    unsigned short get ();
    void set (unsigned short value);
}
member DACInterfaceDACNI : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.DACInterfaceMSBDPLLEN Property

IRD

Max9856DACInterfaceMSBDPLLEN Property

DAC Interface MSB: DPLLEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeDacInterfaceMsbPll DACInterfaceMSBDPLLEN { get; set; }
Public Property DACInterfaceMSBDPLLEN As Max9856TypeDacInterfaceMsbPll
    Get
    Set
public:
property Max9856TypeDacInterfaceMsbPll DACInterfaceMSBDPLLEN {
    Max9856TypeDacInterfaceMsbPll get ();
    void set (Max9856TypeDacInterfaceMsbPll value);
}
member DACInterfaceMSBDPLLEN : Max9856TypeDacInterfaceMsbPll with get, set

Property Value

Type: Max9856TypeDacInterfaceMsbPll
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.DACSystemDBCI Property

IRD

Max9856DACSystemDBCI Property

DAC System: DBCI

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeDacSystemBclock DACSystemDBCI { get; set; }
Public Property DACSystemDBCI As Max9856TypeDacSystemBclock
    Get
    Set
public:
property Max9856TypeDacSystemBclock DACSystemDBCI {
    Max9856TypeDacSystemBclock get ();
    void set (Max9856TypeDacSystemBclock value);
}
member DACSystemDBCI : Max9856TypeDacSystemBclock with get, set

Property Value

Type: Max9856TypeDacSystemBclock
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.DACSystemDDLY Property

IRD

Max9856DACSystemDDLY Property

DAC System: DDLY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeDacSystemDelay DACSystemDDLY { get; set; }
Public Property DACSystemDDLY As Max9856TypeDacSystemDelay
    Get
    Set
public:
property Max9856TypeDacSystemDelay DACSystemDDLY {
    Max9856TypeDacSystemDelay get ();
    void set (Max9856TypeDacSystemDelay value);
}
member DACSystemDDLY : Max9856TypeDacSystemDelay with get, set

Property Value

Type: Max9856TypeDacSystemDelay
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.DACSystemDHF Property

IRD

Max9856DACSystemDHF Property

DAC System: DHF

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeDacSystemSampleRate DACSystemDHF { get; set; }
Public Property DACSystemDHF As Max9856TypeDacSystemSampleRate
    Get
    Set
public:
property Max9856TypeDacSystemSampleRate DACSystemDHF {
    Max9856TypeDacSystemSampleRate get ();
    void set (Max9856TypeDacSystemSampleRate value);
}
member DACSystemDHF : Max9856TypeDacSystemSampleRate with get, set

Property Value

Type: Max9856TypeDacSystemSampleRate
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.DACSystemDRATE Property

IRD

Max9856DACSystemDRATE Property

DAC System: DRATE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeDacSystemModRate DACSystemDRATE { get; set; }
Public Property DACSystemDRATE As Max9856TypeDacSystemModRate
    Get
    Set
public:
property Max9856TypeDacSystemModRate DACSystemDRATE {
    Max9856TypeDacSystemModRate get ();
    void set (Max9856TypeDacSystemModRate value);
}
member DACSystemDRATE : Max9856TypeDacSystemModRate with get, set

Property Value

Type: Max9856TypeDacSystemModRate
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.DACSystemDWCI Property

IRD

Max9856DACSystemDWCI Property

DAC System: DWCI

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeDacSystemWordClock DACSystemDWCI { get; set; }
Public Property DACSystemDWCI As Max9856TypeDacSystemWordClock
    Get
    Set
public:
property Max9856TypeDacSystemWordClock DACSystemDWCI {
    Max9856TypeDacSystemWordClock get ();
    void set (Max9856TypeDacSystemWordClock value);
}
member DACSystemDWCI : Max9856TypeDacSystemWordClock with get, set

Property Value

Type: Max9856TypeDacSystemWordClock
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.DACSystemPCM Property

IRD

Max9856DACSystemPCM Property

DAC System: PCM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeDacSystemPcm DACSystemPCM { get; set; }
Public Property DACSystemPCM As Max9856TypeDacSystemPcm
    Get
    Set
public:
property Max9856TypeDacSystemPcm DACSystemPCM {
    Max9856TypeDacSystemPcm get ();
    void set (Max9856TypeDacSystemPcm value);
}
member DACSystemPCM : Max9856TypeDacSystemPcm with get, set

Property Value

Type: Max9856TypeDacSystemPcm
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.DACSystemWS Property

IRD

Max9856DACSystemWS Property

DAC System: WS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeDacSystemWordSize DACSystemWS { get; set; }
Public Property DACSystemWS As Max9856TypeDacSystemWordSize
    Get
    Set
public:
property Max9856TypeDacSystemWordSize DACSystemWS {
    Max9856TypeDacSystemWordSize get ();
    void set (Max9856TypeDacSystemWordSize value);
}
member DACSystemWS : Max9856TypeDacSystemWordSize with get, set

Property Value

Type: Max9856TypeDacSystemWordSize
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.DigitalInputGain Property

IRD

Max9856DigitalInputGain Property

Digital Input Gain (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeDigitalInputGain DigitalInputGain { get; set; }
Public Property DigitalInputGain As Max9856TypeDigitalInputGain
    Get
    Set
public:
property Max9856TypeDigitalInputGain DigitalInputGain {
    Max9856TypeDigitalInputGain get ();
    void set (Max9856TypeDigitalInputGain value);
}
member DigitalInputGain : Max9856TypeDigitalInputGain with get, set

Property Value

Type: Max9856TypeDigitalInputGain
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.HeadsetSystemENHPL Property

IRD

Max9856HeadsetSystemENHPL Property

Headset System: EN-HPL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeHeadsetSystemHpl HeadsetSystemENHPL { get; set; }
Public Property HeadsetSystemENHPL As Max9856TypeHeadsetSystemHpl
    Get
    Set
public:
property Max9856TypeHeadsetSystemHpl HeadsetSystemENHPL {
    Max9856TypeHeadsetSystemHpl get ();
    void set (Max9856TypeHeadsetSystemHpl value);
}
member HeadsetSystemENHPL : Max9856TypeHeadsetSystemHpl with get, set

Property Value

Type: Max9856TypeHeadsetSystemHpl
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.HeadsetSystemENHPR Property

IRD

Max9856HeadsetSystemENHPR Property

Headset System: EN-HPR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeHeadsetSystemHpr HeadsetSystemENHPR { get; set; }
Public Property HeadsetSystemENHPR As Max9856TypeHeadsetSystemHpr
    Get
    Set
public:
property Max9856TypeHeadsetSystemHpr HeadsetSystemENHPR {
    Max9856TypeHeadsetSystemHpr get ();
    void set (Max9856TypeHeadsetSystemHpr value);
}
member HeadsetSystemENHPR : Max9856TypeHeadsetSystemHpr with get, set

Property Value

Type: Max9856TypeHeadsetSystemHpr
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.HeadsetSystemENJACKSNS Property

IRD

Max9856HeadsetSystemENJACKSNS Property

Headset System: EN-JACKSNS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeHeadsetSystemJackSense HeadsetSystemENJACKSNS { get; set; }
Public Property HeadsetSystemENJACKSNS As Max9856TypeHeadsetSystemJackSense
    Get
    Set
public:
property Max9856TypeHeadsetSystemJackSense HeadsetSystemENJACKSNS {
    Max9856TypeHeadsetSystemJackSense get ();
    void set (Max9856TypeHeadsetSystemJackSense value);
}
member HeadsetSystemENJACKSNS : Max9856TypeHeadsetSystemJackSense with get, set

Property Value

Type: Max9856TypeHeadsetSystemJackSense
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.HeadsetSystemJDETEN Property

IRD

Max9856HeadsetSystemJDETEN Property

Headset System: JDETEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeHeadsetSystemJackDetect HeadsetSystemJDETEN { get; set; }
Public Property HeadsetSystemJDETEN As Max9856TypeHeadsetSystemJackDetect
    Get
    Set
public:
property Max9856TypeHeadsetSystemJackDetect HeadsetSystemJDETEN {
    Max9856TypeHeadsetSystemJackDetect get ();
    void set (Max9856TypeHeadsetSystemJackDetect value);
}
member HeadsetSystemJDETEN : Max9856TypeHeadsetSystemJackDetect with get, set

Property Value

Type: Max9856TypeHeadsetSystemJackDetect
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.HighpassFilterADCHP Property

IRD

Max9856HighpassFilterADCHP Property

Highpass Filter: ADCHP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte HighpassFilterADCHP { get; set; }
Public Property HighpassFilterADCHP As Byte
    Get
    Set
public:
property unsigned char HighpassFilterADCHP {
    unsigned char get ();
    void set (unsigned char value);
}
member HighpassFilterADCHP : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.HighpassFilterDACHP Property

IRD

Max9856HighpassFilterDACHP Property

Highpass Filter: DACHP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte HighpassFilterDACHP { get; set; }
Public Property HighpassFilterDACHP As Byte
    Get
    Set
public:
property unsigned char HighpassFilterDACHP {
    unsigned char get ();
    void set (unsigned char value);
}
member HighpassFilterDACHP : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.HPLVolumeHPMUTE Property

IRD

Max9856HPLVolumeHPMUTE Property

HPL Volume: HPMUTE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte HPLVolumeHPMUTE { get; set; }
Public Property HPLVolumeHPMUTE As Byte
    Get
    Set
public:
property unsigned char HPLVolumeHPMUTE {
    unsigned char get ();
    void set (unsigned char value);
}
member HPLVolumeHPMUTE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.HPLVolumeHPVOLL Property

IRD

Max9856HPLVolumeHPVOLL Property

HPL Volume: HPVOLL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeHpVolumeGain HPLVolumeHPVOLL { get; set; }
Public Property HPLVolumeHPVOLL As Max9856TypeHpVolumeGain
    Get
    Set
public:
property Max9856TypeHpVolumeGain HPLVolumeHPVOLL {
    Max9856TypeHpVolumeGain get ();
    void set (Max9856TypeHpVolumeGain value);
}
member HPLVolumeHPVOLL : Max9856TypeHpVolumeGain with get, set

Property Value

Type: Max9856TypeHpVolumeGain
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.HPRVolumeHPVOLR Property

IRD

Max9856HPRVolumeHPVOLR Property

HPR Volume: HPVOLR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeHpVolumeGain HPRVolumeHPVOLR { get; set; }
Public Property HPRVolumeHPVOLR As Max9856TypeHpVolumeGain
    Get
    Set
public:
property Max9856TypeHpVolumeGain HPRVolumeHPVOLR {
    Max9856TypeHpVolumeGain get ();
    void set (Max9856TypeHpVolumeGain value);
}
member HPRVolumeHPVOLR : Max9856TypeHpVolumeGain with get, set

Property Value

Type: Max9856TypeHpVolumeGain
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.InterruptEnableICLD Property

IRD

Max9856InterruptEnableICLD Property

Interrupt Enable: ICLD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeInterruptEnableClipDetect InterruptEnableICLD { get; set; }
Public Property InterruptEnableICLD As Max9856TypeInterruptEnableClipDetect
    Get
    Set
public:
property Max9856TypeInterruptEnableClipDetect InterruptEnableICLD {
    Max9856TypeInterruptEnableClipDetect get ();
    void set (Max9856TypeInterruptEnableClipDetect value);
}
member InterruptEnableICLD : Max9856TypeInterruptEnableClipDetect with get, set

Property Value

Type: Max9856TypeInterruptEnableClipDetect
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.InterruptEnableIGPI Property

IRD

Max9856InterruptEnableIGPI Property

Interrupt Enable: IGPI

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeInterruptEnableGpi InterruptEnableIGPI { get; set; }
Public Property InterruptEnableIGPI As Max9856TypeInterruptEnableGpi
    Get
    Set
public:
property Max9856TypeInterruptEnableGpi InterruptEnableIGPI {
    Max9856TypeInterruptEnableGpi get ();
    void set (Max9856TypeInterruptEnableGpi value);
}
member InterruptEnableIGPI : Max9856TypeInterruptEnableGpi with get, set

Property Value

Type: Max9856TypeInterruptEnableGpi
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.InterruptEnableIHPOCL Property

IRD

Max9856InterruptEnableIHPOCL Property

Interrupt Enable: IHPOCL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeInterruptEnableHeadphoneLeft InterruptEnableIHPOCL { get; set; }
Public Property InterruptEnableIHPOCL As Max9856TypeInterruptEnableHeadphoneLeft
    Get
    Set
public:
property Max9856TypeInterruptEnableHeadphoneLeft InterruptEnableIHPOCL {
    Max9856TypeInterruptEnableHeadphoneLeft get ();
    void set (Max9856TypeInterruptEnableHeadphoneLeft value);
}
member InterruptEnableIHPOCL : Max9856TypeInterruptEnableHeadphoneLeft with get, set

Property Value

Type: Max9856TypeInterruptEnableHeadphoneLeft
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.InterruptEnableIHPOCR Property

IRD

Max9856InterruptEnableIHPOCR Property

Interrupt Enable: IHPOCR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeInterruptEnableHeadphoneRight InterruptEnableIHPOCR { get; set; }
Public Property InterruptEnableIHPOCR As Max9856TypeInterruptEnableHeadphoneRight
    Get
    Set
public:
property Max9856TypeInterruptEnableHeadphoneRight InterruptEnableIHPOCR {
    Max9856TypeInterruptEnableHeadphoneRight get ();
    void set (Max9856TypeInterruptEnableHeadphoneRight value);
}
member InterruptEnableIHPOCR : Max9856TypeInterruptEnableHeadphoneRight with get, set

Property Value

Type: Max9856TypeInterruptEnableHeadphoneRight
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.InterruptEnableIJDET Property

IRD

Max9856InterruptEnableIJDET Property

Interrupt Enable: IJDET

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeInterruptEnableHeadset InterruptEnableIJDET { get; set; }
Public Property InterruptEnableIJDET As Max9856TypeInterruptEnableHeadset
    Get
    Set
public:
property Max9856TypeInterruptEnableHeadset InterruptEnableIJDET {
    Max9856TypeInterruptEnableHeadset get ();
    void set (Max9856TypeInterruptEnableHeadset value);
}
member InterruptEnableIJDET : Max9856TypeInterruptEnableHeadset with get, set

Property Value

Type: Max9856TypeInterruptEnableHeadset
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.InterruptEnableISLD Property

IRD

Max9856InterruptEnableISLD Property

Interrupt Enable: ISLD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeInterruptEnableSlewLevel InterruptEnableISLD { get; set; }
Public Property InterruptEnableISLD As Max9856TypeInterruptEnableSlewLevel
    Get
    Set
public:
property Max9856TypeInterruptEnableSlewLevel InterruptEnableISLD {
    Max9856TypeInterruptEnableSlewLevel get ();
    void set (Max9856TypeInterruptEnableSlewLevel value);
}
member InterruptEnableISLD : Max9856TypeInterruptEnableSlewLevel with get, set

Property Value

Type: Max9856TypeInterruptEnableSlewLevel
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.InterruptEnableIULK Property

IRD

Max9856InterruptEnableIULK Property

Interrupt Enable: IULK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeInterruptEnablePllUnlock InterruptEnableIULK { get; set; }
Public Property InterruptEnableIULK As Max9856TypeInterruptEnablePllUnlock
    Get
    Set
public:
property Max9856TypeInterruptEnablePllUnlock InterruptEnableIULK {
    Max9856TypeInterruptEnablePllUnlock get ();
    void set (Max9856TypeInterruptEnablePllUnlock value);
}
member InterruptEnableIULK : Max9856TypeInterruptEnablePllUnlock with get, set

Property Value

Type: Max9856TypeInterruptEnablePllUnlock
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.LINEIN1GainPGAL1 Property

IRD

Max9856LINEIN1GainPGAL1 Property

LINEIN1 Gain: PGAL1 (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LINEIN1GainPGAL1 { get; set; }
Public Property LINEIN1GainPGAL1 As Double
    Get
    Set
public:
property double LINEIN1GainPGAL1 {
    double get ();
    void set (double value);
}
member LINEIN1GainPGAL1 : float with get, set

Property Value

Type: Double
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.LINEIN2GainPGAL2 Property

IRD

Max9856LINEIN2GainPGAL2 Property

LINEIN2 Gain: PGAL2 (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LINEIN2GainPGAL2 { get; set; }
Public Property LINEIN2GainPGAL2 As Double
    Get
    Set
public:
property double LINEIN2GainPGAL2 {
    double get ();
    void set (double value);
}
member LINEIN2GainPGAL2 : float with get, set

Property Value

Type: Double
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.MICLGainPAENL Property

IRD

Max9856MICLGainPAENL Property

MICL Gain: PAENL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeMicGainPreamp MICLGainPAENL { get; set; }
Public Property MICLGainPAENL As Max9856TypeMicGainPreamp
    Get
    Set
public:
property Max9856TypeMicGainPreamp MICLGainPAENL {
    Max9856TypeMicGainPreamp get ();
    void set (Max9856TypeMicGainPreamp value);
}
member MICLGainPAENL : Max9856TypeMicGainPreamp with get, set

Property Value

Type: Max9856TypeMicGainPreamp
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.MICLGainPGAML Property

IRD

Max9856MICLGainPGAML Property

MICL Gain: PGAML (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeMicGainPga MICLGainPGAML { get; set; }
Public Property MICLGainPGAML As Max9856TypeMicGainPga
    Get
    Set
public:
property Max9856TypeMicGainPga MICLGainPGAML {
    Max9856TypeMicGainPga get ();
    void set (Max9856TypeMicGainPga value);
}
member MICLGainPGAML : Max9856TypeMicGainPga with get, set

Property Value

Type: Max9856TypeMicGainPga
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.MICModeLMICDIF Property

IRD

Max9856MICModeLMICDIF Property

MIC Mode: LMICDIF

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeMicModeLeftInput MICModeLMICDIF { get; set; }
Public Property MICModeLMICDIF As Max9856TypeMicModeLeftInput
    Get
    Set
public:
property Max9856TypeMicModeLeftInput MICModeLMICDIF {
    Max9856TypeMicModeLeftInput get ();
    void set (Max9856TypeMicModeLeftInput value);
}
member MICModeLMICDIF : Max9856TypeMicModeLeftInput with get, set

Property Value

Type: Max9856TypeMicModeLeftInput
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.MICModeMBSEL Property

IRD

Max9856MICModeMBSEL Property

MIC Mode: MBSEL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeMicModeBias MICModeMBSEL { get; set; }
Public Property MICModeMBSEL As Max9856TypeMicModeBias
    Get
    Set
public:
property Max9856TypeMicModeBias MICModeMBSEL {
    Max9856TypeMicModeBias get ();
    void set (Max9856TypeMicModeBias value);
}
member MICModeMBSEL : Max9856TypeMicModeBias with get, set

Property Value

Type: Max9856TypeMicModeBias
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.MICModeMMIC Property

IRD

Max9856MICModeMMIC Property

MIC Mode: MMIC

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeMicModeMute MICModeMMIC { get; set; }
Public Property MICModeMMIC As Max9856TypeMicModeMute
    Get
    Set
public:
property Max9856TypeMicModeMute MICModeMMIC {
    Max9856TypeMicModeMute get ();
    void set (Max9856TypeMicModeMute value);
}
member MICModeMMIC : Max9856TypeMicModeMute with get, set

Property Value

Type: Max9856TypeMicModeMute
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.MICRGainPAENR Property

IRD

Max9856MICRGainPAENR Property

MICR Gain: PAENR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeMicGainPreamp MICRGainPAENR { get; set; }
Public Property MICRGainPAENR As Max9856TypeMicGainPreamp
    Get
    Set
public:
property Max9856TypeMicGainPreamp MICRGainPAENR {
    Max9856TypeMicGainPreamp get ();
    void set (Max9856TypeMicGainPreamp value);
}
member MICRGainPAENR : Max9856TypeMicGainPreamp with get, set

Property Value

Type: Max9856TypeMicGainPreamp
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.MICRGainPGAMR Property

IRD

Max9856MICRGainPGAMR Property

MICR Gain: PGAMR (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeMicGainPga MICRGainPGAMR { get; set; }
Public Property MICRGainPGAMR As Max9856TypeMicGainPga
    Get
    Set
public:
property Max9856TypeMicGainPga MICRGainPGAMR {
    Max9856TypeMicGainPga get ();
    void set (Max9856TypeMicGainPga value);
}
member MICRGainPGAMR : Max9856TypeMicGainPga with get, set

Property Value

Type: Max9856TypeMicGainPga
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.OutputMixerMXOUTLDAC Property

IRD

Max9856OutputMixerMXOUTLDAC Property

Output Mixer: MXOUTL-DAC

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeOutputMixerDacOutput OutputMixerMXOUTLDAC { get; set; }
Public Property OutputMixerMXOUTLDAC As Max9856TypeOutputMixerDacOutput
    Get
    Set
public:
property Max9856TypeOutputMixerDacOutput OutputMixerMXOUTLDAC {
    Max9856TypeOutputMixerDacOutput get ();
    void set (Max9856TypeOutputMixerDacOutput value);
}
member OutputMixerMXOUTLDAC : Max9856TypeOutputMixerDacOutput with get, set

Property Value

Type: Max9856TypeOutputMixerDacOutput
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.OutputMixerMXOUTLLINEIN1 Property

IRD

Max9856OutputMixerMXOUTLLINEIN1 Property

Output Mixer: MXOUTL-LINEIN1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeOutputMixerLinein1 OutputMixerMXOUTLLINEIN1 { get; set; }
Public Property OutputMixerMXOUTLLINEIN1 As Max9856TypeOutputMixerLinein1
    Get
    Set
public:
property Max9856TypeOutputMixerLinein1 OutputMixerMXOUTLLINEIN1 {
    Max9856TypeOutputMixerLinein1 get ();
    void set (Max9856TypeOutputMixerLinein1 value);
}
member OutputMixerMXOUTLLINEIN1 : Max9856TypeOutputMixerLinein1 with get, set

Property Value

Type: Max9856TypeOutputMixerLinein1
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.OutputMixerMXOUTLLINEIN2 Property

IRD

Max9856OutputMixerMXOUTLLINEIN2 Property

Output Mixer: MXOUTL-LINEIN2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeOutputMixerLinein2 OutputMixerMXOUTLLINEIN2 { get; set; }
Public Property OutputMixerMXOUTLLINEIN2 As Max9856TypeOutputMixerLinein2
    Get
    Set
public:
property Max9856TypeOutputMixerLinein2 OutputMixerMXOUTLLINEIN2 {
    Max9856TypeOutputMixerLinein2 get ();
    void set (Max9856TypeOutputMixerLinein2 value);
}
member OutputMixerMXOUTLLINEIN2 : Max9856TypeOutputMixerLinein2 with get, set

Property Value

Type: Max9856TypeOutputMixerLinein2
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.OutputMixerMXOUTLMICL Property

IRD

Max9856OutputMixerMXOUTLMICL Property

Output Mixer: MXOUTL-MICL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeOutputMixerMicOutput OutputMixerMXOUTLMICL { get; set; }
Public Property OutputMixerMXOUTLMICL As Max9856TypeOutputMixerMicOutput
    Get
    Set
public:
property Max9856TypeOutputMixerMicOutput OutputMixerMXOUTLMICL {
    Max9856TypeOutputMixerMicOutput get ();
    void set (Max9856TypeOutputMixerMicOutput value);
}
member OutputMixerMXOUTLMICL : Max9856TypeOutputMixerMicOutput with get, set

Property Value

Type: Max9856TypeOutputMixerMicOutput
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.OutputMixerMXOUTRDAC Property

IRD

Max9856OutputMixerMXOUTRDAC Property

Output Mixer: MXOUTR-DAC

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeOutputMixerDacOutput OutputMixerMXOUTRDAC { get; set; }
Public Property OutputMixerMXOUTRDAC As Max9856TypeOutputMixerDacOutput
    Get
    Set
public:
property Max9856TypeOutputMixerDacOutput OutputMixerMXOUTRDAC {
    Max9856TypeOutputMixerDacOutput get ();
    void set (Max9856TypeOutputMixerDacOutput value);
}
member OutputMixerMXOUTRDAC : Max9856TypeOutputMixerDacOutput with get, set

Property Value

Type: Max9856TypeOutputMixerDacOutput
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.OutputMixerMXOUTRLINEIN1 Property

IRD

Max9856OutputMixerMXOUTRLINEIN1 Property

Output Mixer: MXOUTR-LINEIN1

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeOutputMixerLinein1 OutputMixerMXOUTRLINEIN1 { get; set; }
Public Property OutputMixerMXOUTRLINEIN1 As Max9856TypeOutputMixerLinein1
    Get
    Set
public:
property Max9856TypeOutputMixerLinein1 OutputMixerMXOUTRLINEIN1 {
    Max9856TypeOutputMixerLinein1 get ();
    void set (Max9856TypeOutputMixerLinein1 value);
}
member OutputMixerMXOUTRLINEIN1 : Max9856TypeOutputMixerLinein1 with get, set

Property Value

Type: Max9856TypeOutputMixerLinein1
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.OutputMixerMXOUTRLINEIN2 Property

IRD

Max9856OutputMixerMXOUTRLINEIN2 Property

Output Mixer: MXOUTR-LINEIN2

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeOutputMixerLinein2 OutputMixerMXOUTRLINEIN2 { get; set; }
Public Property OutputMixerMXOUTRLINEIN2 As Max9856TypeOutputMixerLinein2
    Get
    Set
public:
property Max9856TypeOutputMixerLinein2 OutputMixerMXOUTRLINEIN2 {
    Max9856TypeOutputMixerLinein2 get ();
    void set (Max9856TypeOutputMixerLinein2 value);
}
member OutputMixerMXOUTRLINEIN2 : Max9856TypeOutputMixerLinein2 with get, set

Property Value

Type: Max9856TypeOutputMixerLinein2
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.OutputMixerMXOUTRMICR Property

IRD

Max9856OutputMixerMXOUTRMICR Property

Output Mixer: MXOUTR-MICR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeOutputMixerMicOutput OutputMixerMXOUTRMICR { get; set; }
Public Property OutputMixerMXOUTRMICR As Max9856TypeOutputMixerMicOutput
    Get
    Set
public:
property Max9856TypeOutputMixerMicOutput OutputMixerMXOUTRMICR {
    Max9856TypeOutputMixerMicOutput get ();
    void set (Max9856TypeOutputMixerMicOutput value);
}
member OutputMixerMXOUTRMICR : Max9856TypeOutputMixerMicOutput with get, set

Property Value

Type: Max9856TypeOutputMixerMicOutput
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.OutputModeAUXDC Property

IRD

Max9856OutputModeAUXDC Property

Output Mode: AUXDC

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeOutputModeDcMeasure OutputModeAUXDC { get; set; }
Public Property OutputModeAUXDC As Max9856TypeOutputModeDcMeasure
    Get
    Set
public:
property Max9856TypeOutputModeDcMeasure OutputModeAUXDC {
    Max9856TypeOutputModeDcMeasure get ();
    void set (Max9856TypeOutputModeDcMeasure value);
}
member OutputModeAUXDC : Max9856TypeOutputModeDcMeasure with get, set

Property Value

Type: Max9856TypeOutputModeDcMeasure
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.OutputModeAUXMIX Property

IRD

Max9856OutputModeAUXMIX Property

Output Mode: AUXMIX

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeOutputModeHeadphoneAmp OutputModeAUXMIX { get; set; }
Public Property OutputModeAUXMIX As Max9856TypeOutputModeHeadphoneAmp
    Get
    Set
public:
property Max9856TypeOutputModeHeadphoneAmp OutputModeAUXMIX {
    Max9856TypeOutputModeHeadphoneAmp get ();
    void set (Max9856TypeOutputModeHeadphoneAmp value);
}
member OutputModeAUXMIX : Max9856TypeOutputModeHeadphoneAmp with get, set

Property Value

Type: Max9856TypeOutputModeHeadphoneAmp
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.OutputModeHPMODE Property

IRD

Max9856OutputModeHPMODE Property

Output Mode: HPMODE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeOutputModeHpMode OutputModeHPMODE { get; set; }
Public Property OutputModeHPMODE As Max9856TypeOutputModeHpMode
    Get
    Set
public:
property Max9856TypeOutputModeHpMode OutputModeHPMODE {
    Max9856TypeOutputModeHpMode get ();
    void set (Max9856TypeOutputModeHpMode value);
}
member OutputModeHPMODE : Max9856TypeOutputModeHpMode with get, set

Property Value

Type: Max9856TypeOutputModeHpMode
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.OutputModeVSEN Property

IRD

Max9856OutputModeVSEN Property

Output Mode: VSEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeOutputModeSlewing OutputModeVSEN { get; set; }
Public Property OutputModeVSEN As Max9856TypeOutputModeSlewing
    Get
    Set
public:
property Max9856TypeOutputModeSlewing OutputModeVSEN {
    Max9856TypeOutputModeSlewing get ();
    void set (Max9856TypeOutputModeSlewing value);
}
member OutputModeVSEN : Max9856TypeOutputModeSlewing with get, set

Property Value

Type: Max9856TypeOutputModeSlewing
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.PowerSystemADLEN Property

IRD

Max9856PowerSystemADLEN Property

Power System: ADLEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypePowerSystemAdcLeft PowerSystemADLEN { get; set; }
Public Property PowerSystemADLEN As Max9856TypePowerSystemAdcLeft
    Get
    Set
public:
property Max9856TypePowerSystemAdcLeft PowerSystemADLEN {
    Max9856TypePowerSystemAdcLeft get ();
    void set (Max9856TypePowerSystemAdcLeft value);
}
member PowerSystemADLEN : Max9856TypePowerSystemAdcLeft with get, set

Property Value

Type: Max9856TypePowerSystemAdcLeft
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.PowerSystemADREN Property

IRD

Max9856PowerSystemADREN Property

Power System: ADREN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypePowerSystemAdcRight PowerSystemADREN { get; set; }
Public Property PowerSystemADREN As Max9856TypePowerSystemAdcRight
    Get
    Set
public:
property Max9856TypePowerSystemAdcRight PowerSystemADREN {
    Max9856TypePowerSystemAdcRight get ();
    void set (Max9856TypePowerSystemAdcRight value);
}
member PowerSystemADREN : Max9856TypePowerSystemAdcRight with get, set

Property Value

Type: Max9856TypePowerSystemAdcRight
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.PowerSystemDALEN Property

IRD

Max9856PowerSystemDALEN Property

Power System: DALEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypePowerSystemDacLeft PowerSystemDALEN { get; set; }
Public Property PowerSystemDALEN As Max9856TypePowerSystemDacLeft
    Get
    Set
public:
property Max9856TypePowerSystemDacLeft PowerSystemDALEN {
    Max9856TypePowerSystemDacLeft get ();
    void set (Max9856TypePowerSystemDacLeft value);
}
member PowerSystemDALEN : Max9856TypePowerSystemDacLeft with get, set

Property Value

Type: Max9856TypePowerSystemDacLeft
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.PowerSystemDAREN Property

IRD

Max9856PowerSystemDAREN Property

Power System: DAREN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypePowerSystemDacRight PowerSystemDAREN { get; set; }
Public Property PowerSystemDAREN As Max9856TypePowerSystemDacRight
    Get
    Set
public:
property Max9856TypePowerSystemDacRight PowerSystemDAREN {
    Max9856TypePowerSystemDacRight get ();
    void set (Max9856TypePowerSystemDacRight value);
}
member PowerSystemDAREN : Max9856TypePowerSystemDacRight with get, set

Property Value

Type: Max9856TypePowerSystemDacRight
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.PowerSystemDIGEN Property

IRD

Max9856PowerSystemDIGEN Property

Power System: DIGEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypePowerSystemDigital PowerSystemDIGEN { get; set; }
Public Property PowerSystemDIGEN As Max9856TypePowerSystemDigital
    Get
    Set
public:
property Max9856TypePowerSystemDigital PowerSystemDIGEN {
    Max9856TypePowerSystemDigital get ();
    void set (Max9856TypePowerSystemDigital value);
}
member PowerSystemDIGEN : Max9856TypePowerSystemDigital with get, set

Property Value

Type: Max9856TypePowerSystemDigital
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.PowerSystemLOUTEN Property

IRD

Max9856PowerSystemLOUTEN Property

Power System: LOUTEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypePowerSystemLine PowerSystemLOUTEN { get; set; }
Public Property PowerSystemLOUTEN As Max9856TypePowerSystemLine
    Get
    Set
public:
property Max9856TypePowerSystemLine PowerSystemLOUTEN {
    Max9856TypePowerSystemLine get ();
    void set (Max9856TypePowerSystemLine value);
}
member PowerSystemLOUTEN : Max9856TypePowerSystemLine with get, set

Property Value

Type: Max9856TypePowerSystemLine
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.PowerSystemSHDN Property

IRD

Max9856PowerSystemSHDN Property

Power System: SHDN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypePowerSystemShutdown PowerSystemSHDN { get; set; }
Public Property PowerSystemSHDN As Max9856TypePowerSystemShutdown
    Get
    Set
public:
property Max9856TypePowerSystemShutdown PowerSystemSHDN {
    Max9856TypePowerSystemShutdown get ();
    void set (Max9856TypePowerSystemShutdown value);
}
member PowerSystemSHDN : Max9856TypePowerSystemShutdown with get, set

Property Value

Type: Max9856TypePowerSystemShutdown
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.Status0CLD Property

IRD

Max9856Status0CLD Property

Status 0: CLD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeStatus0ClipDetect Status0CLD { get; }
Public ReadOnly Property Status0CLD As Max9856TypeStatus0ClipDetect
    Get
public:
property Max9856TypeStatus0ClipDetect Status0CLD {
    Max9856TypeStatus0ClipDetect get ();
}
member Status0CLD : Max9856TypeStatus0ClipDetect with get

Property Value

Type: Max9856TypeStatus0ClipDetect
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.Status0GPI Property

IRD

Max9856Status0GPI Property

Status 0: GPI

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeStatus0Gpi Status0GPI { get; }
Public ReadOnly Property Status0GPI As Max9856TypeStatus0Gpi
    Get
public:
property Max9856TypeStatus0Gpi Status0GPI {
    Max9856TypeStatus0Gpi get ();
}
member Status0GPI : Max9856TypeStatus0Gpi with get

Property Value

Type: Max9856TypeStatus0Gpi
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.Status0HPOCL Property

IRD

Max9856Status0HPOCL Property

Status 0: HPOCL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeStatus0HeadphoneLeft Status0HPOCL { get; }
Public ReadOnly Property Status0HPOCL As Max9856TypeStatus0HeadphoneLeft
    Get
public:
property Max9856TypeStatus0HeadphoneLeft Status0HPOCL {
    Max9856TypeStatus0HeadphoneLeft get ();
}
member Status0HPOCL : Max9856TypeStatus0HeadphoneLeft with get

Property Value

Type: Max9856TypeStatus0HeadphoneLeft
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.Status0HPOCR Property

IRD

Max9856Status0HPOCR Property

Status 0: HPOCR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeStatus0HeadphoneRight Status0HPOCR { get; }
Public ReadOnly Property Status0HPOCR As Max9856TypeStatus0HeadphoneRight
    Get
public:
property Max9856TypeStatus0HeadphoneRight Status0HPOCR {
    Max9856TypeStatus0HeadphoneRight get ();
}
member Status0HPOCR : Max9856TypeStatus0HeadphoneRight with get

Property Value

Type: Max9856TypeStatus0HeadphoneRight
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.Status0JDET Property

IRD

Max9856Status0JDET Property

Status 0: JDET

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeStatus0Headset Status0JDET { get; }
Public ReadOnly Property Status0JDET As Max9856TypeStatus0Headset
    Get
public:
property Max9856TypeStatus0Headset Status0JDET {
    Max9856TypeStatus0Headset get ();
}
member Status0JDET : Max9856TypeStatus0Headset with get

Property Value

Type: Max9856TypeStatus0Headset
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.Status0JKMIC Property

IRD

Max9856Status0JKMIC Property

Status 0: JKMIC

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeStatus0MicroJack Status0JKMIC { get; }
Public ReadOnly Property Status0JKMIC As Max9856TypeStatus0MicroJack
    Get
public:
property Max9856TypeStatus0MicroJack Status0JKMIC {
    Max9856TypeStatus0MicroJack get ();
}
member Status0JKMIC : Max9856TypeStatus0MicroJack with get

Property Value

Type: Max9856TypeStatus0MicroJack
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.Status0SLD Property

IRD

Max9856Status0SLD Property

Status 0: SLD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeStatus0SlewLevel Status0SLD { get; }
Public ReadOnly Property Status0SLD As Max9856TypeStatus0SlewLevel
    Get
public:
property Max9856TypeStatus0SlewLevel Status0SLD {
    Max9856TypeStatus0SlewLevel get ();
}
member Status0SLD : Max9856TypeStatus0SlewLevel with get

Property Value

Type: Max9856TypeStatus0SlewLevel
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.Status0ULK Property

IRD

Max9856Status0ULK Property

Status 0: ULK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeStatus0PllUnlock Status0ULK { get; }
Public ReadOnly Property Status0ULK As Max9856TypeStatus0PllUnlock
    Get
public:
property Max9856TypeStatus0PllUnlock Status0ULK {
    Max9856TypeStatus0PllUnlock get ();
}
member Status0ULK : Max9856TypeStatus0PllUnlock with get

Property Value

Type: Max9856TypeStatus0PllUnlock
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.Status1HSDETL Property

IRD

Max9856Status1HSDETL Property

Status 1: HSDETL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeStatus1LoadImpedance Status1HSDETL { get; }
Public ReadOnly Property Status1HSDETL As Max9856TypeStatus1LoadImpedance
    Get
public:
property Max9856TypeStatus1LoadImpedance Status1HSDETL {
    Max9856TypeStatus1LoadImpedance get ();
}
member Status1HSDETL : Max9856TypeStatus1LoadImpedance with get

Property Value

Type: Max9856TypeStatus1LoadImpedance
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.Status1HSDETR Property

IRD

Max9856Status1HSDETR Property

Status 1: HSDETR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeStatus1LoadImpedance Status1HSDETR { get; }
Public ReadOnly Property Status1HSDETR As Max9856TypeStatus1LoadImpedance
    Get
public:
property Max9856TypeStatus1LoadImpedance Status1HSDETR {
    Max9856TypeStatus1LoadImpedance get ();
}
member Status1HSDETR : Max9856TypeStatus1LoadImpedance with get

Property Value

Type: Max9856TypeStatus1LoadImpedance
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.Status1JKSNS Property

IRD

Max9856Status1JKSNS Property

Status 1: JKSNS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeStatus1JackSense Status1JKSNS { get; }
Public ReadOnly Property Status1JKSNS As Max9856TypeStatus1JackSense
    Get
public:
property Max9856TypeStatus1JackSense Status1JKSNS {
    Max9856TypeStatus1JackSense get ();
}
member Status1JKSNS : Max9856TypeStatus1JackSense with get

Property Value

Type: Max9856TypeStatus1JackSense
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.Status1JSDET Property

IRD

Max9856Status1JSDET Property

Status 1: JSDET

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeStatus1LoadImpedance Status1JSDET { get; }
Public ReadOnly Property Status1JSDET As Max9856TypeStatus1LoadImpedance
    Get
public:
property Max9856TypeStatus1LoadImpedance Status1JSDET {
    Max9856TypeStatus1LoadImpedance get ();
}
member Status1JSDET : Max9856TypeStatus1LoadImpedance with get

Property Value

Type: Max9856TypeStatus1LoadImpedance
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.Status1LSNS Property

IRD

Max9856Status1LSNS Property

Status 1: LSNS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9856TypeStatus1HeadphoneSense Status1LSNS { get; }
Public ReadOnly Property Status1LSNS As Max9856TypeStatus1HeadphoneSense
    Get
public:
property Max9856TypeStatus1HeadphoneSense Status1LSNS {
    Max9856TypeStatus1HeadphoneSense get ();
}
member Status1LSNS : Max9856TypeStatus1HeadphoneSense with get

Property Value

Type: Max9856TypeStatus1HeadphoneSense
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856 Methods

The Max9856 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.Flush Method

IRD

Max9856Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max9856 Class
telos.Ird.Maxim Namespace


Max9856.TypeAdcInterfaceMsbPll Enumeration

IRD

Max9856TypeAdcInterfaceMsbPll Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcInterfaceMsbPll
Public Enumeration TypeAdcInterfaceMsbPll
public enum class TypeAdcInterfaceMsbPll
type TypeAdcInterfaceMsbPll
Members
Member name | Value | Description
ADCPLLDisabled | 0 | ADC PLL: Disabled
ADCPLLEnabled | 1 | ADC PLL: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeAdcLevelNoise Enumeration

IRD

Max9856TypeAdcLevelNoise Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcLevelNoise
Public Enumeration TypeAdcLevelNoise
public enum class TypeAdcLevelNoise
type TypeAdcLevelNoise
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_M_64 | 6 | -64
Value_M_60 | 7 | -60
Value_M_56 | 8 | -56
Value_M_52 | 9 | -52
Value_M_48 | 10 | -48
Value_M_44 | 11 | -44
Value_M_40 | 12 | -40
Value_M_36 | 13 | -36
Value_M_32 | 14 | -32
Value_M_28 | 15 | -28
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeAdcMixerAuxout Enumeration

IRD

Max9856TypeAdcMixerAuxout Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcMixerAuxout
Public Enumeration TypeAdcMixerAuxout
public enum class TypeAdcMixerAuxout
type TypeAdcMixerAuxout
Members
Member name | Value | Description
AUXOUTNotSelected | 0 | AUXOUT: Not Selected
AUXOUTSelected | 1 | AUXOUT: Selected
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeAdcMixerLinein1 Enumeration

IRD

Max9856TypeAdcMixerLinein1 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcMixerLinein1
Public Enumeration TypeAdcMixerLinein1
public enum class TypeAdcMixerLinein1
type TypeAdcMixerLinein1
Members
Member name | Value | Description
LINEIN1NotSelected | 0 | LINEIN1: Not Selected
LINEIN1Selected | 1 | LINEIN1: Selected
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeAdcMixerLinein2 Enumeration

IRD

Max9856TypeAdcMixerLinein2 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcMixerLinein2
Public Enumeration TypeAdcMixerLinein2
public enum class TypeAdcMixerLinein2
type TypeAdcMixerLinein2
Members
Member name | Value | Description
LINEIN2NotSelected | 0 | LINEIN2: Not Selected
LINEIN2Selected | 1 | LINEIN2: Selected
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeAdcMixerMicl Enumeration

IRD

Max9856TypeAdcMixerMicl Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcMixerMicl
Public Enumeration TypeAdcMixerMicl
public enum class TypeAdcMixerMicl
type TypeAdcMixerMicl
Members
Member name | Value | Description
MICLNotSelected | 0 | MICL: Not Selected
MICLSelected | 1 | MICL: Selected
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeAdcMixerMicr Enumeration

IRD

Max9856TypeAdcMixerMicr Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcMixerMicr
Public Enumeration TypeAdcMixerMicr
public enum class TypeAdcMixerMicr
type TypeAdcMixerMicr
Members
Member name | Value | Description
MICRNotSelected | 0 | MICR: Not Selected
MICRSelected | 1 | MICR: Selected
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeAdcSystemBclock Enumeration

IRD

Max9856TypeAdcSystemBclock Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcSystemBclock
Public Enumeration TypeAdcSystemBclock
public enum class TypeAdcSystemBclock
type TypeAdcSystemBclock
Members
Member name | Value | Description
ADCBCLKInvertDisable | 0 | ADC BCLK Invert: Disable
ADCBCLKInvertEnable | 1 | ADC BCLK Invert: Enable
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeAdcSystemDelay Enumeration

IRD

Max9856TypeAdcSystemDelay Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcSystemDelay
Public Enumeration TypeAdcSystemDelay
public enum class TypeAdcSystemDelay
type TypeAdcSystemDelay
Members
Member name | Value | Description
ADCDataDelayAudioMSBValidAtFirstBLCKEdge | 0 | ADC Data Delay: Audio-MSB Valid At First BLCK-Edge
ADCDataDelayAudioMSBValidAtSecondBLCKEdge | 1 | ADC Data Delay: Audio-MSB Valid At Second BLCK-Edge
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeAdcSystemPinConfig Enumeration

IRD

Max9856TypeAdcSystemPinConfig Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcSystemPinConfig
Public Enumeration TypeAdcSystemPinConfig
public enum class TypeAdcSystemPinConfig
type TypeAdcSystemPinConfig
Members
Member name | Value | Description
GeneralPurposeInput | 0 | General Purpose Input
WordClockForADC | 1 | Word Clock for ADC
GeneralPurposeOutputLow | 2 | General Purpose Output: Low
GeneralPurposeOutputHigh | 3 | General Purpose Output: High
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeAdcSystemWordClock Enumeration

IRD

Max9856TypeAdcSystemWordClock Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcSystemWordClock
Public Enumeration TypeAdcSystemWordClock
public enum class TypeAdcSystemWordClock
type TypeAdcSystemWordClock
Members
Member name | Value | Description
ADCWordClockInvertDisabled | 0 | ADC Word Clock Invert: Disabled
ADCWordClockInvertEnabled | 1 | ADC Word Clock Invert: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeAgcControlAttackTime Enumeration

IRD

Max9856TypeAgcControlAttackTime Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAgcControlAttackTime
Public Enumeration TypeAgcControlAttackTime
public enum class TypeAgcControlAttackTime
type TypeAgcControlAttackTime
Members
Member name | Value | Description
Value_3 | 0 | 3
Value_12 | 1 | 12
Value_50 | 2 | 50
Value_200 | 3 | 200
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeAgcControlHoldTime Enumeration

IRD

Max9856TypeAgcControlHoldTime Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAgcControlHoldTime
Public Enumeration TypeAgcControlHoldTime
public enum class TypeAgcControlHoldTime
type TypeAgcControlHoldTime
Members
Member name | Value | Description
AGCDisabled | 0 | AGC Disabled
Value_50Ms | 1 | 50 ms
Value_100Ms | 2 | 100 ms
Value_400Ms | 3 | 400 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeAgcControlReleaseTime Enumeration

IRD

Max9856TypeAgcControlReleaseTime Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAgcControlReleaseTime
Public Enumeration TypeAgcControlReleaseTime
public enum class TypeAgcControlReleaseTime
type TypeAgcControlReleaseTime
Members
Member name | Value | Description
Value_78Ms | 0 | 78 ms
Value_156Ms | 1 | 156 ms
Value_312Ms | 2 | 312 ms
Value_625Ms | 3 | 625 ms
Value_125S | 4 | 1.25 s
Value_25S | 5 | 2.5 s
Value_5S | 6 | 5 s
Value_10S | 7 | 10 s
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeAgcThresholdNoiseGate Enumeration

IRD

Max9856TypeAgcThresholdNoiseGate Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAgcThresholdNoiseGate
Public Enumeration TypeAgcThresholdNoiseGate
public enum class TypeAgcThresholdNoiseGate
type TypeAgcThresholdNoiseGate
Members
Member name | Value | Description
LeftChannelADCOutput | 0 | Left Channel ADC Output
LeftRightChannelADCOutput | 1 | Left + Right Channel ADC Output
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeClockControlMode Enumeration

IRD

Max9856TypeClockControlMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockControlMode
Public Enumeration TypeClockControlMode
public enum class TypeClockControlMode
type TypeClockControlMode
Members
Member name | Value | Description
SlaveModeBCLKLRCLKDAndLRCLKAAreInputs | 0 | Slave Mode (BCLK, LRCLK_D And LRCLK_A Are Inputs)
MasterModeBCLKLRCLKDAndLRCLKAAreOutputs | 1 | Master Mode (BCLK, LRCLK_D And LRCLK_A Are Outputs)
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeClockControlPrescaler Enumeration

IRD

Max9856TypeClockControlPrescaler Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockControlPrescaler
Public Enumeration TypeClockControlPrescaler
public enum class TypeClockControlPrescaler
type TypeClockControlPrescaler
Members
Member name | Value | Description
DisableClockInputMCLK | 0 | Disable Clock Input (MCLK)
Value_10MHzMCLK16MHzPCLKMCLK1 | 1 | 10MHz <= MCLK <= 16MHz (PCLK = MCLK/1)
Value_16MHzMCLK20MHzPCLKMCLK1 | 2 | 16MHz <= MCLK <= 20MHz (PCLK = MCLK/1)
Value_20MHzMCLK32MHzPCLKMCLK2 | 3 | 20MHz <= MCLK <= 32MHz (PCLK = MCLK/2)
Value_32MHzMCLK40MHzPCLKMCLK2 | 4 | 32MHz <= MCLK<= 40MHz (PCLK = MCLK/2)
Value_40MHzMCLK60MHzPCLKMCLK4 | 5 | 40MHz <= MCLK <= 60MHz (PCLK = MCLK/4)
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeClockControlSelect Enumeration

IRD

Max9856TypeClockControlSelect Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockControlSelect
Public Enumeration TypeClockControlSelect
public enum class TypeClockControlSelect
type TypeClockControlSelect
Members
Member name | Value | Description
BCLKSelectOff | 0 | BCLK Select: Off
BCLK48XLRCLKD | 2 | BCLK = 48 x LRCLK_D
BCLK48XLRCLKA | 3 | BCLK = 48 x LRCLK_A
BCLKPCLK2 | 4 | BCLK = PCLK/2
BCLKPCLK4 | 5 | BCLK = PCLK/4
BCLKPCLK8 | 6 | BCLK = PCLK/8
BCLKPCLK16 | 7 | BCLK = PCLK/16
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeDacInterfaceMsbPll Enumeration

IRD

Max9856TypeDacInterfaceMsbPll Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacInterfaceMsbPll
Public Enumeration TypeDacInterfaceMsbPll
public enum class TypeDacInterfaceMsbPll
type TypeDacInterfaceMsbPll
Members
Member name | Value | Description
DACPLLDisabled | 0 | DAC PLL: Disabled
DACPLLEnabled | 1 | DAC PLL: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeDacSystemBclock Enumeration

IRD

Max9856TypeDacSystemBclock Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSystemBclock
Public Enumeration TypeDacSystemBclock
public enum class TypeDacSystemBclock
type TypeDacSystemBclock
Members
Member name | Value | Description
DACBCLKInvertDisabled | 0 | DAC BCLK Invert: Disabled
DACBLCKInvertEnabled | 1 | DAC BLCK Invert: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeDacSystemDelay Enumeration

IRD

Max9856TypeDacSystemDelay Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSystemDelay
Public Enumeration TypeDacSystemDelay
public enum class TypeDacSystemDelay
type TypeDacSystemDelay
Members
Member name | Value | Description
DACDataDelayAudioMSBLatchedAtFirstBLCKEdge | 0 | DAC Data Delay: Audio-MSB Latched At First BLCK-Edge
DACDataDelayAudioMSBLatchedAtSecondBLCKEdge | 1 | DAC Data Delay: Audio-MSB Latched At Second BLCK-Edge
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeDacSystemModRate Enumeration

IRD

Max9856TypeDacSystemModRate Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSystemModRate
Public Enumeration TypeDacSystemModRate
public enum class TypeDacSystemModRate
type TypeDacSystemModRate
Members
Member name | Value | Description
DACModulatorRateLowPowerMode | 0 | DAC Modulator Rate: Low Power Mode
DACModulatorRateHighPerformanceMode | 2 | DAC Modulator Rate: High Performance Mode
DACModulatorRateDACClockDisable | 3 | DAC Modulator Rate: DAC Clock Disable
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeDacSystemPcm Enumeration

IRD

Max9856TypeDacSystemPcm Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSystemPcm
Public Enumeration TypeDacSystemPcm
public enum class TypeDacSystemPcm
type TypeDacSystemPcm
Members
Member name | Value | Description
LRCLKDAndLRCLKASignalsHave50DutyCycle | 0 | LRCLK_D And LRCLK_A Signals Have 50% Duty Cycle
LRCLKDAndLRCLKAIndicateStartOfFrame | 1 | LRCLK_D And LRCLK_A Indicate Start Of Frame
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeDacSystemSampleRate Enumeration

IRD

Max9856TypeDacSystemSampleRate Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSystemSampleRate
Public Enumeration TypeDacSystemSampleRate
public enum class TypeDacSystemSampleRate
type TypeDacSystemSampleRate
Members
Member name | Value | Description
LRCLKD50KHz8XFIRInterpolationFilterUsed | 0 | LRCLK_D < 50 kHz / 8 x FIR Interpolation Filter Used
LRCLKD50KHz4XFIRInterpolationFilterUsed | 1 | LRCLK_D > 50 kHz / 4 x FIR Interpolation Filter Used
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeDacSystemWordClock Enumeration

IRD

Max9856TypeDacSystemWordClock Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSystemWordClock
Public Enumeration TypeDacSystemWordClock
public enum class TypeDacSystemWordClock
type TypeDacSystemWordClock
Members
Member name | Value | Description
DACWordClockInvertDisabled | 0 | DAC Word Clock Invert: Disabled
DACWordClockInvertEnabled | 1 | DAC Word Clock Invert: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeDacSystemWordSize Enumeration

IRD

Max9856TypeDacSystemWordSize Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSystemWordSize
Public Enumeration TypeDacSystemWordSize
public enum class TypeDacSystemWordSize
type TypeDacSystemWordSize
Members
Member name | Value | Description
DACAndADCWordSize16Bits | 0 | DAC And ADC Word Size: 16 Bits
DACAndADCWordSize18Bits | 1 | DAC And ADC Word Size: 18 Bits
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeDigitalInputGain Enumeration

IRD

Max9856TypeDigitalInputGain Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDigitalInputGain
Public Enumeration TypeDigitalInputGain
public enum class TypeDigitalInputGain
type TypeDigitalInputGain
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_M_0_5 | 7 | -0.5
Value_M_1 | 14 | -1
Value_M_1_5 | 21 | -1.5
Value_M_2 | 28 | -2
Value_M_2_5 | 34 | -2.5
Value_M_3 | 41 | -3
Value_M_3_5 | 47 | -3.5
Value_M_4 | 53 | -4
Value_M_4_5 | 58 | -4.5
Value_M_5 | 64 | -5
Value_M_5_5 | 69 | -5.5
Value_M_6 | 74 | -6
Value_M_6_5 | 80 | -6.5
Value_M_7 | 85 | -7
Value_M_7_5 | 89 | -7.5
Value_M_8 | 94 | -8
Value_M_8_5 | 99 | -8.5
Value_M_9 | 103 | -9
Value_M_9_5 | 107 | -9.5
Value_M_10 | 112 | -10
Value_M_10_5 | 116 | -10.5
Value_M_11 | 120 | -11
Value_M_11_5 | 124 | -11.5
Value_M_12 | 127 | -12
Value_M_12_5 | 131 | -12.5
Value_M_13 | 134 | -13
Value_M_13_5 | 138 | -13.5
Value_M_14 | 141 | -14
Value_M_14_5 | 144 | -14.5
Value_M_15 | 147 | -15
Value_M_15_5 | 150 | -15.5
Value_M_16 | 153 | -16
Value_M_16_5 | 156 | -16.5
Value_M_17 | 159 | -17
Value_M_17_5 | 162 | -17.5
Value_M_18 | 165 | -18
Value_M_18_5 | 167 | -18.5
Value_M_19 | 170 | -19
Value_M_19_5 | 172 | -19.5
Value_M_20 | 174 | -20
Value_M_21 | 179 | -21
Value_M_22 | 183 | -22
Value_M_23 | 187 | -23
Value_M_24 | 191 | -24
Value_M_25 | 194 | -25
Value_M_26 | 198 | -26
Value_M_27 | 201 | -27
Value_M_28 | 204 | -28
Value_M_29 | 207 | -29
Value_M_30 | 210 | -30
Value_M_31 | 212 | -31
Value_M_32 | 214 | -32
Value_M_33 | 217 | -33
Value_M_34 | 219 | -34
Value_M_35 | 221 | -35
Value_M_36 | 223 | -36
Value_M_37 | 225 | -37
Value_M_38 | 226 | -38
Value_M_39 | 228 | -39
Value_M_40 | 229 | -40
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeHeadsetSystemHpl Enumeration

IRD

Max9856TypeHeadsetSystemHpl Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadsetSystemHpl
Public Enumeration TypeHeadsetSystemHpl
public enum class TypeHeadsetSystemHpl
type TypeHeadsetSystemHpl
Members
Member name | Value | Description
HPLPinImpedanceSenseDisabled | 0 | HPL Pin Impedance Sense: Disabled
HPLPinImpedanceSenseEnabled | 1 | HPL Pin Impedance Sense: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeHeadsetSystemHpr Enumeration

IRD

Max9856TypeHeadsetSystemHpr Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadsetSystemHpr
Public Enumeration TypeHeadsetSystemHpr
public enum class TypeHeadsetSystemHpr
type TypeHeadsetSystemHpr
Members
Member name | Value | Description
HPRPinImpedanceSenseDisabled | 0 | HPR Pin Impedance Sense: Disabled
HPRPinImpedanceSenseEnabled | 1 | HPR Pin Impedance Sense: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeHeadsetSystemJackDetect Enumeration

IRD

Max9856TypeHeadsetSystemJackDetect Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadsetSystemJackDetect
Public Enumeration TypeHeadsetSystemJackDetect
public enum class TypeHeadsetSystemJackDetect
type TypeHeadsetSystemJackDetect
Members
Member name | Value | Description
JackDetectionDisabled | 0 | Jack Detection: Disabled
JackDetectionEnabled | 1 | Jack Detection: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeHeadsetSystemJackSense Enumeration

IRD

Max9856TypeHeadsetSystemJackSense Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadsetSystemJackSense
Public Enumeration TypeHeadsetSystemJackSense
public enum class TypeHeadsetSystemJackSense
type TypeHeadsetSystemJackSense
Members
Member name | Value | Description
JACKSNSPinImpedanceSenseDisabled | 0 | JACKSNS Pin Impedance Sense: Disabled
JACKSNSPinImpedanceSenseEnabled | 1 | JACKSNS Pin Impedance Sense: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeHpVolumeGain Enumeration

IRD

Max9856TypeHpVolumeGain Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHpVolumeGain
Public Enumeration TypeHpVolumeGain
public enum class TypeHpVolumeGain
type TypeHpVolumeGain
Members
Member name | Value | Description
Value_55DB | 0 | 5.5 dB
Value_50DB | 1 | 5.0 dB
Value_45DB | 2 | 4.5 dB
Value_40DB | 3 | 4.0 dB
Value_35DB | 4 | 3.5 dB
Value_30DB | 5 | 3.0 dB
Value_25DB | 6 | 2.5 dB
Value_20DB | 7 | 2.0 dB
Value_10DB | 8 | 1.0 dB
Value_0DB | 9 | 0 dB
Value_1DB | 10 | -1 dB
Value_2DB | 11 | -2 dB
Value_4DB | 12 | -4 dB
Value_6DB | 13 | -6 dB
Value_8DB | 14 | -8 dB
Value_10DB__1 | 15 | -10 dB
Value_12DB | 16 | -12 dB
Value_14DB | 17 | -14 dB
Value_16DB | 18 | -16 dB
Value_18DB | 19 | -18 dB
Value_20DB__1 | 20 | -20 dB
Value_22DB | 21 | -22 dB
Value_24DB | 22 | -24 dB
Value_26DB | 23 | -26 dB
Value_28DB | 24 | -28 dB
Value_30DB__1 | 25 | -30 dB
Value_32DB | 26 | -32 dB
Value_34DB | 27 | -34 dB
Value_36DB | 28 | -36 dB
Value_38DB | 29 | -38 dB
Value_40DB__1 | 30 | -40 dB
Value_42DB | 31 | -42 dB
Value_46DB | 32 | -46 dB
Value_50DB__1 | 33 | -50 dB
Value_54DB | 34 | -54 dB
Value_58DB | 35 | -58 dB
Value_62DB | 36 | -62 dB
Value_66DB | 37 | -66 dB
Value_70DB | 38 | -70 dB
Value_74DB | 39 | -74 dB
Mute | 40 | Mute
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeInterruptEnableClipDetect Enumeration

IRD

Max9856TypeInterruptEnableClipDetect Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableClipDetect
Public Enumeration TypeInterruptEnableClipDetect
public enum class TypeInterruptEnableClipDetect
type TypeInterruptEnableClipDetect
Members
Member name | Value | Description
ClipDetectInterruptDisabled | 0 | Clip Detect Interrupt: Disabled
ClipDetectInterruptEnabled | 1 | Clip Detect Interrupt: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeInterruptEnableGpi Enumeration

IRD

Max9856TypeInterruptEnableGpi Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableGpi
Public Enumeration TypeInterruptEnableGpi
public enum class TypeInterruptEnableGpi
type TypeInterruptEnableGpi
Members
Member name | Value | Description
GeneralPurposeInputInterruptDisabled | 0 | General Purpose Input Interrupt: Disabled
GeneralPurposeInputInterruptEnabled | 1 | General Purpose Input Interrupt: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeInterruptEnableHeadphoneLeft Enumeration

IRD

Max9856TypeInterruptEnableHeadphoneLeft Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableHeadphoneLeft
Public Enumeration TypeInterruptEnableHeadphoneLeft
public enum class TypeInterruptEnableHeadphoneLeft
type TypeInterruptEnableHeadphoneLeft
Members
Member name | Value | Description
HeadphoneLeftInterruptDisabled | 0 | Headphone Left Interrupt: Disabled
HeadphoneLeftInterruptEnabled | 1 | Headphone Left Interrupt: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeInterruptEnableHeadphoneRight Enumeration

IRD

Max9856TypeInterruptEnableHeadphoneRight Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableHeadphoneRight
Public Enumeration TypeInterruptEnableHeadphoneRight
public enum class TypeInterruptEnableHeadphoneRight
type TypeInterruptEnableHeadphoneRight
Members
Member name | Value | Description
HeadphoneRightInterruptDisabled | 0 | Headphone Right Interrupt: Disabled
HeadphoneRightInterruptEnabled | 1 | Headphone Right Interrupt: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeInterruptEnableHeadset Enumeration

IRD

Max9856TypeInterruptEnableHeadset Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableHeadset
Public Enumeration TypeInterruptEnableHeadset
public enum class TypeInterruptEnableHeadset
type TypeInterruptEnableHeadset
Members
Member name | Value | Description
HeadsetConfigurationChangeInterruptDisabled | 0 | Headset Configuration Change Interrupt: Disabled
HeadsetConfigurationChangeInterruptEnabled | 1 | Headset Configuration Change Interrupt: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeInterruptEnablePllUnlock Enumeration

IRD

Max9856TypeInterruptEnablePllUnlock Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnablePllUnlock
Public Enumeration TypeInterruptEnablePllUnlock
public enum class TypeInterruptEnablePllUnlock
type TypeInterruptEnablePllUnlock
Members
Member name | Value | Description
PLLUnlockInterruptDisabled | 0 | PLL Unlock Interrupt: Disabled
PLLUnlockInterruptEnabled | 1 | PLL Unlock Interrupt: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeInterruptEnableSlewLevel Enumeration

IRD

Max9856TypeInterruptEnableSlewLevel Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableSlewLevel
Public Enumeration TypeInterruptEnableSlewLevel
public enum class TypeInterruptEnableSlewLevel
type TypeInterruptEnableSlewLevel
Members
Member name | Value | Description
SlewLevelInterruptDisabled | 0 | Slew Level Interrupt: Disabled
SlewLevelInterruptEnabled | 1 | Slew Level Interrupt: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeMicGainPga Enumeration

IRD

Max9856TypeMicGainPga Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMicGainPga
Public Enumeration TypeMicGainPga
public enum class TypeMicGainPga
type TypeMicGainPga
Members
Member name | Value | Description
Value_20 | 0 | 20
Value_19 | 1 | 19
Value_18 | 2 | 18
Value_17 | 3 | 17
Value_16 | 4 | 16
Value_15 | 5 | 15
Value_14 | 6 | 14
Value_13 | 7 | 13
Value_12 | 8 | 12
Value_11 | 9 | 11
Value_10 | 10 | 10
Value_9 | 11 | 9
Value_8 | 12 | 8
Value_7 | 13 | 7
Value_6 | 14 | 6
Value_5 | 15 | 5
Value_4 | 16 | 4
Value_3 | 17 | 3
Value_2 | 18 | 2
Value_1 | 19 | 1
Value_0 | 20 | 0
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeMicGainPreamp Enumeration

IRD

Max9856TypeMicGainPreamp Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMicGainPreamp
Public Enumeration TypeMicGainPreamp
public enum class TypeMicGainPreamp
type TypeMicGainPreamp
Members
Member name | Value | Description
MicrophoneDisabled | 0 | Microphone Disabled
Value_0DB | 1 | 0 dB
Value_20DB | 2 | 20 dB
Value_30DB | 3 | 30 dB
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeMicModeBias Enumeration

IRD

Max9856TypeMicModeBias Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMicModeBias
Public Enumeration TypeMicModeBias
public enum class TypeMicModeBias
type TypeMicModeBias
Members
Member name | Value | Description
MICBIAS15V | 0 | MICBIAS = 1.5 V
MICBIAS24V | 1 | MICBIAS = 2.4 V
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeMicModeLeftInput Enumeration

IRD

Max9856TypeMicModeLeftInput Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMicModeLeftInput
Public Enumeration TypeMicModeLeftInput
public enum class TypeMicModeLeftInput
type TypeMicModeLeftInput
Members
Member name | Value | Description
MICLMICGNDPseudoDifferentialInput | 0 | MICL / MICGND Pseudo Differential Input
INLPINLNDifferentialInput | 1 | INLP / INLN Differential Input
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeMicModeMute Enumeration

IRD

Max9856TypeMicModeMute Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMicModeMute
Public Enumeration TypeMicModeMute
public enum class TypeMicModeMute
type TypeMicModeMute
Members
Member name | Value | Description
MicrophoneMuteDisable | 0 | Microphone Mute: Disable
MicrophoneMuteEnable | 1 | Microphone Mute: Enable
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeOutputMixerDacOutput Enumeration

IRD

Max9856TypeOutputMixerDacOutput Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputMixerDacOutput
Public Enumeration TypeOutputMixerDacOutput
public enum class TypeOutputMixerDacOutput
type TypeOutputMixerDacOutput
Members
Member name | Value | Description
DACOutputNotSelected | 0 | DAC Output: Not Selected
DACOutputSelected | 1 | DAC Output: Selected
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeOutputMixerLinein1 Enumeration

IRD

Max9856TypeOutputMixerLinein1 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputMixerLinein1
Public Enumeration TypeOutputMixerLinein1
public enum class TypeOutputMixerLinein1
type TypeOutputMixerLinein1
Members
Member name | Value | Description
LINEIN1NotSelected | 0 | LINEIN1: Not Selected
LINEIN1Selected | 1 | LINEIN1: Selected
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeOutputMixerLinein2 Enumeration

IRD

Max9856TypeOutputMixerLinein2 Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputMixerLinein2
Public Enumeration TypeOutputMixerLinein2
public enum class TypeOutputMixerLinein2
type TypeOutputMixerLinein2
Members
Member name | Value | Description
LINEIN2NotSelected | 0 | LINEIN2: Not Selected
LINEIN2Selected | 1 | LINEIN2: Selected
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeOutputMixerMicOutput Enumeration

IRD

Max9856TypeOutputMixerMicOutput Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputMixerMicOutput
Public Enumeration TypeOutputMixerMicOutput
public enum class TypeOutputMixerMicOutput
type TypeOutputMixerMicOutput
Members
Member name | Value | Description
MICLPGAOutputNotSelected | 0 | MICL PGA Output: Not Selected
MICLPGAOutputSelected | 1 | MICL PGA Output: Selected
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeOutputModeDcMeasure Enumeration

IRD

Max9856TypeOutputModeDcMeasure Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeDcMeasure
Public Enumeration TypeOutputModeDcMeasure
public enum class TypeOutputModeDcMeasure
type TypeOutputModeDcMeasure
Members
Member name | Value | Description
AUXINConnectedToInputPGAForAudioSignals | 0 | AUXIN: Connected To Input PGA For Audio Signals
AUXINConnectedToADCInputForDCMeasurement | 1 | AUXIN: Connected To ADC Input For DC Measurement
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeOutputModeHeadphoneAmp Enumeration

IRD

Max9856TypeOutputModeHeadphoneAmp Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeHeadphoneAmp
Public Enumeration TypeOutputModeHeadphoneAmp
public enum class TypeOutputModeHeadphoneAmp
type TypeOutputModeHeadphoneAmp
Members
Member name | Value | Description
AUXINNotConnectedToHeadphoneAmplifiers | 0 | AUXIN: Not Connected To Headphone Amplifiers
AUXINOutputMixerBypassingIntoHeadphoneAmplifiers | 1 | AUXIN: Output Mixer Bypassing Into Headphone Amplifiers
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeOutputModeHpMode Enumeration

IRD

Max9856TypeOutputModeHpMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeHpMode
Public Enumeration TypeOutputModeHpMode
public enum class TypeOutputModeHpMode
type TypeOutputModeHpMode
Members
Member name | Value | Description
HeadphoneOutputModeShutdown | 0 | Headphone Output Mode: Shutdown
HeadphoneOutputModeStandardMono | 1 | Headphone Output Mode: Standard Mono
HeadphoneOutputModeDualMono | 2 | Headphone Output Mode: Dual Mono
HeadphoneOutputModeStereoMode | 3 | Headphone Output Mode: Stereo Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeOutputModeSlewing Enumeration

IRD

Max9856TypeOutputModeSlewing Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputModeSlewing
Public Enumeration TypeOutputModeSlewing
public enum class TypeOutputModeSlewing
type TypeOutputModeSlewing
Members
Member name | Value | Description
VolumeSlewingDisabled | 0 | Volume Slewing: Disabled
VolumeSlewingEnabled | 1 | Volume Slewing: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypePowerSystemAdcLeft Enumeration

IRD

Max9856TypePowerSystemAdcLeft Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerSystemAdcLeft
Public Enumeration TypePowerSystemAdcLeft
public enum class TypePowerSystemAdcLeft
type TypePowerSystemAdcLeft
Members
Member name | Value | Description
LeftADCDisabled | 0 | Left ADC: Disabled
LeftADCEnabled | 1 | Left ADC: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypePowerSystemAdcRight Enumeration

IRD

Max9856TypePowerSystemAdcRight Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerSystemAdcRight
Public Enumeration TypePowerSystemAdcRight
public enum class TypePowerSystemAdcRight
type TypePowerSystemAdcRight
Members
Member name | Value | Description
RightADCDisabled | 0 | Right ADC: Disabled
RightADCEnabled | 1 | Right ADC: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypePowerSystemDacLeft Enumeration

IRD

Max9856TypePowerSystemDacLeft Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerSystemDacLeft
Public Enumeration TypePowerSystemDacLeft
public enum class TypePowerSystemDacLeft
type TypePowerSystemDacLeft
Members
Member name | Value | Description
LeftDACDisabled | 0 | Left DAC: Disabled
LeftDACEnabled | 1 | Left DAC: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypePowerSystemDacRight Enumeration

IRD

Max9856TypePowerSystemDacRight Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerSystemDacRight
Public Enumeration TypePowerSystemDacRight
public enum class TypePowerSystemDacRight
type TypePowerSystemDacRight
Members
Member name | Value | Description
RightDACDisabled | 0 | Right DAC: Disabled
RightDACEnabled | 1 | Right DAC: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypePowerSystemDigital Enumeration

IRD

Max9856TypePowerSystemDigital Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerSystemDigital
Public Enumeration TypePowerSystemDigital
public enum class TypePowerSystemDigital
type TypePowerSystemDigital
Members
Member name | Value | Description
DigitalCoreDisabled | 0 | Digital Core: Disabled
DigitalCoreEnabled | 1 | Digital Core: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypePowerSystemLine Enumeration

IRD

Max9856TypePowerSystemLine Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerSystemLine
Public Enumeration TypePowerSystemLine
public enum class TypePowerSystemLine
type TypePowerSystemLine
Members
Member name | Value | Description
LineOutputDisabled | 0 | Line Output: Disabled
LineOutputEnabled | 1 | Line Output: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypePowerSystemShutdown Enumeration

IRD

Max9856TypePowerSystemShutdown Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerSystemShutdown
Public Enumeration TypePowerSystemShutdown
public enum class TypePowerSystemShutdown
type TypePowerSystemShutdown
Members
Member name | Value | Description
ShutdownEnabled | 0 | Shutdown: Enabled
ShutdownDisabled | 1 | Shutdown: Disabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeStatus0ClipDetect Enumeration

IRD

Max9856TypeStatus0ClipDetect Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus0ClipDetect
Public Enumeration TypeStatus0ClipDetect
public enum class TypeStatus0ClipDetect
type TypeStatus0ClipDetect
Members
Member name | Value | Description
SignalNotClippedInADC | 0 | Signal Not Clipped In ADC
SignalClippedInADC | 1 | Signal Clipped in ADC
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeStatus0Gpi Enumeration

IRD

Max9856TypeStatus0Gpi Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus0Gpi
Public Enumeration TypeStatus0Gpi
public enum class TypeStatus0Gpi
type TypeStatus0Gpi
Members
Member name | Value | Description
LRCLKANotConfiguredAsGeneralPurposeInput | 0 | LRCLK_A Not Configured As General Purpose Input
LRCLKAConfiguredAsGeneralPurposeInput | 1 | LRCLK_A Configured As General Purpose Input
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeStatus0HeadphoneLeft Enumeration

IRD

Max9856TypeStatus0HeadphoneLeft Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus0HeadphoneLeft
Public Enumeration TypeStatus0HeadphoneLeft
public enum class TypeStatus0HeadphoneLeft
type TypeStatus0HeadphoneLeft
Members
Member name | Value | Description
LeftHeadphoneOutputAmplifierNotExceededRatedCurrent | 0 | Left Headphone Output Amplifier Not Exceeded Rated Current
LeftHeadphoneOutputAmplifierExceededRatedCurrent | 1 | Left Headphone Output Amplifier Exceeded Rated Current
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeStatus0HeadphoneRight Enumeration

IRD

Max9856TypeStatus0HeadphoneRight Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus0HeadphoneRight
Public Enumeration TypeStatus0HeadphoneRight
public enum class TypeStatus0HeadphoneRight
type TypeStatus0HeadphoneRight
Members
Member name | Value | Description
RightHeadphoneOutputAmplifierNotExceededRatedCurrent | 0 | Right Headphone Output Amplifier Not Exceeded Rated Current
RightHeadphoneOutputAmplifierExceededRatedCurrent | 1 | Right Headphone Output Amplifier Exceeded Rated Current
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeStatus0Headset Enumeration

IRD

Max9856TypeStatus0Headset Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus0Headset
Public Enumeration TypeStatus0Headset
public enum class TypeStatus0Headset
type TypeStatus0Headset
Members
Member name | Value | Description
HeadsetConfigurationNoChangeInJKMICLSNSOrJKSNS | 0 | Headset Configuration: No Change In JKMIC, LSNS Or JKSNS
HeadsetConfigurationJKMICLSNSOrJKSNSChanged | 1 | Headset Configuration: JKMIC, LSNS Or JKSNS Changed
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeStatus0MicroJack Enumeration

IRD

Max9856TypeStatus0MicroJack Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus0MicroJack
Public Enumeration TypeStatus0MicroJack
public enum class TypeStatus0MicroJack
type TypeStatus0MicroJack
Members
Member name | Value | Description
JACKSNSNotPulledUpToMICBIASVoltage | 0 | JACKSNS Not Pulled Up To MICBIAS Voltage
JACKSNSPulledUpToMICBIASVoltage | 1 | JACKSNS Pulled Up To MICBIAS Voltage
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeStatus0PllUnlock Enumeration

IRD

Max9856TypeStatus0PllUnlock Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus0PllUnlock
Public Enumeration TypeStatus0PllUnlock
public enum class TypeStatus0PllUnlock
type TypeStatus0PllUnlock
Members
Member name | Value | Description
DigitalAudioPLLForDACOrADCLocked | 0 | Digital Audio PLL For DAC Or ADC: Locked
DigitalAudioPLLForDACOrADCUnlocked | 1 | Digital Audio PLL For DAC Or ADC: Unlocked
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeStatus0SlewLevel Enumeration

IRD

Max9856TypeStatus0SlewLevel Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus0SlewLevel
Public Enumeration TypeStatus0SlewLevel
public enum class TypeStatus0SlewLevel
type TypeStatus0SlewLevel
Members
Member name | Value | Description
SlewingHasNotCompleted | 0 | Slewing Has Not Completed
SlewingHasCompleted | 1 | Slewing Has Completed
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeStatus1HeadphoneSense Enumeration

IRD

Max9856TypeStatus1HeadphoneSense Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1HeadphoneSense
Public Enumeration TypeStatus1HeadphoneSense
public enum class TypeStatus1HeadphoneSense
type TypeStatus1HeadphoneSense
Members
Member name | Value | Description
HeadphoneJackInsertionOrRemovalNotOccurred | 0 | Headphone Jack Insertion Or Removal: Not Occurred
HeadphoneJackInsertionOrRemovalOccurred | 1 | Headphone Jack Insertion Or Removal: Occurred
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeStatus1JackSense Enumeration

IRD

Max9856TypeStatus1JackSense Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1JackSense
Public Enumeration TypeStatus1JackSense
public enum class TypeStatus1JackSense
type TypeStatus1JackSense
Members
Member name | Value | Description
JackInsertionOrRemovalNotOccurred | 0 | Jack Insertion Or Removal: Not Occurred
JackInsertionOrRemovalOccurred | 1 | Jack Insertion Or Removal: Occurred
See Also

Reference

telos.Ird.Maxim Namespace


Max9856.TypeStatus1LoadImpedance Enumeration

IRD

Max9856TypeStatus1LoadImpedance Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatus1LoadImpedance
Public Enumeration TypeStatus1LoadImpedance
public enum class TypeStatus1LoadImpedance
type TypeStatus1LoadImpedance
Members
Member name | Value | Description
Value_200OhmLoadOpen | 0 | 200 Ohm < Load < Open
Value_50OhmLoad200Ohm | 1 | 50 Ohm < Load < 200 Ohm
Value_0OhmLoad50Ohm | 2 | 0 Ohm < Load < 50 Ohm
IdleState | 3 | Idle State
See Also

Reference

telos.Ird.Maxim Namespace


Max9860 Class

Maxim: MAX 9860
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax9860

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max9860
Public Class Max9860
public ref class Max9860
type Max9860 =  class end

The Max9860 type exposes the following members.

Constructors
 | Name | Description
Public method | Max9860 | Constructor
Top
Properties
 | Name | Description
Public property | ADCOutputLevelADCLL | ADC Output Level: ADCLL (unit: dB)
Public property | ADCOutputLevelADCRL | ADC Output Level: ADCRL (unit: dB)
Public property | AudioClockHighPLL | Audio Clock High: PLL
Public property | AudioClockNHINLO | Audio Clock: NHI-NLO
Public property | AudioInterface1DBCI | Audio Interface1: DBCI
Public property | AudioInterface1DDLY | Audio Interface1: DDLY
Public property | AudioInterface1HIZ | Audio Interface1: HIZ
Public property | AudioInterface1MAS | Audio Interface1: MAS
Public property | AudioInterface1TDM | Audio Interface1: TDM
Public property | AudioInterface1WCI | Audio Interface1: WCI
Public property | AudioInterface2ABCI | Audio Interface2: ABCI
Public property | AudioInterface2ADLY | Audio Interface2: ADLY
Public property | AudioInterface2BSEL | Audio Interface2: BSEL
Public property | AudioInterface2ST | Audio Interface2: ST
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DACAttenuationDVA | DAC Attenuation: DVA
Public property | DACGainDVG | DAC Gain: DVG (unit: dB)
Public property | DACGainDVST | DAC Gain: DVST
Public property | InterruptEnableICLD | Interrupt Enable: ICLD
Public property | InterruptEnableISLD | Interrupt Enable: ISLD
Public property | InterruptEnableIULK | Interrupt Enable: IULK
Public property | InterruptStatusCLD | Interrupt Status: CLD
Public property | InterruptStatusSLD | Interrupt Status: SLD
Public property | InterruptStatusULK | Interrupt Status: ULK
Public property | MicrophoneAGCAGCATK | Microphone AGC: AGCATK (unit: ms)
Public property | MicrophoneAGCAGCHLD | Microphone AGC: AGCHLD
Public property | MicrophoneAGCAGCRLS | Microphone AGC: AGCRLS
Public property | MicrophoneAGCAGCSRC | Microphone AGC: AGCSRC
Public property | MicrophoneGainPAM | Microphone Gain: PAM
Public property | MicrophoneGainPGAM | Microphone Gain: PGAM (unit: dB)
Public property | MicrophoneNGAGC | Microphone NG: AGC
Public property | MicrophoneNGNG | Microphone NG: NG (unit: dB)
Public property | NoiseGateAGCTH | Noise Gate: AGCTH (unit: dBFS)
Public property | NoiseGateANTH | Noise Gate: ANTH
Public property | RevisionCode | Revision Code
Public property | SystemClock16KHZ | System Clock: 16KHZ
Public property | SystemClockFREQ | System Clock: FREQ
Public property | SystemClockPSCLK | System Clock: PSCLK
Public property | SystemShutdownADCLEN | System Shutdown: ADCLEN
Public property | SystemShutdownDACEN | System Shutdown: DACEN
Public property | SystemShutdownSHDN | System Shutdown: SHDN
Public property | SystemSutdownADCREN | System Sutdown: ADCREN
Public property | VoiceFilterAVFLT | Voice Filter: AVFLT
Public property | VoiceFilterDVFLT | Voice Filter: DVFLT
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
16-Bit Mono Audio Voice Codec
See Also

Reference

telos.Ird.Maxim Namespace


Max9860 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max9860(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max9860

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860 Properties

The Max9860 type exposes the following members.

Properties
 | Name | Description
Public property | ADCOutputLevelADCLL | ADC Output Level: ADCLL (unit: dB)
Public property | ADCOutputLevelADCRL | ADC Output Level: ADCRL (unit: dB)
Public property | AudioClockHighPLL | Audio Clock High: PLL
Public property | AudioClockNHINLO | Audio Clock: NHI-NLO
Public property | AudioInterface1DBCI | Audio Interface1: DBCI
Public property | AudioInterface1DDLY | Audio Interface1: DDLY
Public property | AudioInterface1HIZ | Audio Interface1: HIZ
Public property | AudioInterface1MAS | Audio Interface1: MAS
Public property | AudioInterface1TDM | Audio Interface1: TDM
Public property | AudioInterface1WCI | Audio Interface1: WCI
Public property | AudioInterface2ABCI | Audio Interface2: ABCI
Public property | AudioInterface2ADLY | Audio Interface2: ADLY
Public property | AudioInterface2BSEL | Audio Interface2: BSEL
Public property | AudioInterface2ST | Audio Interface2: ST
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DACAttenuationDVA | DAC Attenuation: DVA
Public property | DACGainDVG | DAC Gain: DVG (unit: dB)
Public property | DACGainDVST | DAC Gain: DVST
Public property | InterruptEnableICLD | Interrupt Enable: ICLD
Public property | InterruptEnableISLD | Interrupt Enable: ISLD
Public property | InterruptEnableIULK | Interrupt Enable: IULK
Public property | InterruptStatusCLD | Interrupt Status: CLD
Public property | InterruptStatusSLD | Interrupt Status: SLD
Public property | InterruptStatusULK | Interrupt Status: ULK
Public property | MicrophoneAGCAGCATK | Microphone AGC: AGCATK (unit: ms)
Public property | MicrophoneAGCAGCHLD | Microphone AGC: AGCHLD
Public property | MicrophoneAGCAGCRLS | Microphone AGC: AGCRLS
Public property | MicrophoneAGCAGCSRC | Microphone AGC: AGCSRC
Public property | MicrophoneGainPAM | Microphone Gain: PAM
Public property | MicrophoneGainPGAM | Microphone Gain: PGAM (unit: dB)
Public property | MicrophoneNGAGC | Microphone NG: AGC
Public property | MicrophoneNGNG | Microphone NG: NG (unit: dB)
Public property | NoiseGateAGCTH | Noise Gate: AGCTH (unit: dBFS)
Public property | NoiseGateANTH | Noise Gate: ANTH
Public property | RevisionCode | Revision Code
Public property | SystemClock16KHZ | System Clock: 16KHZ
Public property | SystemClockFREQ | System Clock: FREQ
Public property | SystemClockPSCLK | System Clock: PSCLK
Public property | SystemShutdownADCLEN | System Shutdown: ADCLEN
Public property | SystemShutdownDACEN | System Shutdown: DACEN
Public property | SystemShutdownSHDN | System Shutdown: SHDN
Public property | SystemSutdownADCREN | System Sutdown: ADCREN
Public property | VoiceFilterAVFLT | Voice Filter: AVFLT
Public property | VoiceFilterDVFLT | Voice Filter: DVFLT
Top
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.ADCOutputLevelADCLL Property

IRD

Max9860ADCOutputLevelADCLL Property

ADC Output Level: ADCLL (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ADCOutputLevelADCLL { get; set; }
Public Property ADCOutputLevelADCLL As Double
    Get
    Set
public:
property double ADCOutputLevelADCLL {
    double get ();
    void set (double value);
}
member ADCOutputLevelADCLL : float with get, set

Property Value

Type: Double
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.ADCOutputLevelADCRL Property

IRD

Max9860ADCOutputLevelADCRL Property

ADC Output Level: ADCRL (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ADCOutputLevelADCRL { get; set; }
Public Property ADCOutputLevelADCRL As Double
    Get
    Set
public:
property double ADCOutputLevelADCRL {
    double get ();
    void set (double value);
}
member ADCOutputLevelADCRL : float with get, set

Property Value

Type: Double
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.AudioClockHighPLL Property

IRD

Max9860AudioClockHighPLL Property

Audio Clock High: PLL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeAudioClockHighPll AudioClockHighPLL { get; set; }
Public Property AudioClockHighPLL As Max9860TypeAudioClockHighPll
    Get
    Set
public:
property Max9860TypeAudioClockHighPll AudioClockHighPLL {
    Max9860TypeAudioClockHighPll get ();
    void set (Max9860TypeAudioClockHighPll value);
}
member AudioClockHighPLL : Max9860TypeAudioClockHighPll with get, set

Property Value

Type: Max9860TypeAudioClockHighPll
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.AudioClockNHINLO Property

IRD

Max9860AudioClockNHINLO Property

Audio Clock: NHI-NLO

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AudioClockNHINLO { get; set; }
Public Property AudioClockNHINLO As UShort
    Get
    Set
public:
property unsigned short AudioClockNHINLO {
    unsigned short get ();
    void set (unsigned short value);
}
member AudioClockNHINLO : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.AudioInterface1DBCI Property

IRD

Max9860AudioInterface1DBCI Property

Audio Interface1: DBCI

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeAudioInterface1Dbci AudioInterface1DBCI { get; set; }
Public Property AudioInterface1DBCI As Max9860TypeAudioInterface1Dbci
    Get
    Set
public:
property Max9860TypeAudioInterface1Dbci AudioInterface1DBCI {
    Max9860TypeAudioInterface1Dbci get ();
    void set (Max9860TypeAudioInterface1Dbci value);
}
member AudioInterface1DBCI : Max9860TypeAudioInterface1Dbci with get, set

Property Value

Type: Max9860TypeAudioInterface1Dbci
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.AudioInterface1DDLY Property

IRD

Max9860AudioInterface1DDLY Property

Audio Interface1: DDLY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeAudioInterface1DacDelay AudioInterface1DDLY { get; set; }
Public Property AudioInterface1DDLY As Max9860TypeAudioInterface1DacDelay
    Get
    Set
public:
property Max9860TypeAudioInterface1DacDelay AudioInterface1DDLY {
    Max9860TypeAudioInterface1DacDelay get ();
    void set (Max9860TypeAudioInterface1DacDelay value);
}
member AudioInterface1DDLY : Max9860TypeAudioInterface1DacDelay with get, set

Property Value

Type: Max9860TypeAudioInterface1DacDelay
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.AudioInterface1HIZ Property

IRD

Max9860AudioInterface1HIZ Property

Audio Interface1: HIZ

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeAudioInterface1Impedance AudioInterface1HIZ { get; set; }
Public Property AudioInterface1HIZ As Max9860TypeAudioInterface1Impedance
    Get
    Set
public:
property Max9860TypeAudioInterface1Impedance AudioInterface1HIZ {
    Max9860TypeAudioInterface1Impedance get ();
    void set (Max9860TypeAudioInterface1Impedance value);
}
member AudioInterface1HIZ : Max9860TypeAudioInterface1Impedance with get, set

Property Value

Type: Max9860TypeAudioInterface1Impedance
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.AudioInterface1MAS Property

IRD

Max9860AudioInterface1MAS Property

Audio Interface1: MAS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeAudioInterface1Master AudioInterface1MAS { get; set; }
Public Property AudioInterface1MAS As Max9860TypeAudioInterface1Master
    Get
    Set
public:
property Max9860TypeAudioInterface1Master AudioInterface1MAS {
    Max9860TypeAudioInterface1Master get ();
    void set (Max9860TypeAudioInterface1Master value);
}
member AudioInterface1MAS : Max9860TypeAudioInterface1Master with get, set

Property Value

Type: Max9860TypeAudioInterface1Master
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.AudioInterface1TDM Property

IRD

Max9860AudioInterface1TDM Property

Audio Interface1: TDM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeAudioInterface1TdmMode AudioInterface1TDM { get; set; }
Public Property AudioInterface1TDM As Max9860TypeAudioInterface1TdmMode
    Get
    Set
public:
property Max9860TypeAudioInterface1TdmMode AudioInterface1TDM {
    Max9860TypeAudioInterface1TdmMode get ();
    void set (Max9860TypeAudioInterface1TdmMode value);
}
member AudioInterface1TDM : Max9860TypeAudioInterface1TdmMode with get, set

Property Value

Type: Max9860TypeAudioInterface1TdmMode
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.AudioInterface1WCI Property

IRD

Max9860AudioInterface1WCI Property

Audio Interface1: WCI

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeAudioInterface1Wci AudioInterface1WCI { get; set; }
Public Property AudioInterface1WCI As Max9860TypeAudioInterface1Wci
    Get
    Set
public:
property Max9860TypeAudioInterface1Wci AudioInterface1WCI {
    Max9860TypeAudioInterface1Wci get ();
    void set (Max9860TypeAudioInterface1Wci value);
}
member AudioInterface1WCI : Max9860TypeAudioInterface1Wci with get, set

Property Value

Type: Max9860TypeAudioInterface1Wci
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.AudioInterface2ABCI Property

IRD

Max9860AudioInterface2ABCI Property

Audio Interface2: ABCI

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeAudioInterface2Abci AudioInterface2ABCI { get; set; }
Public Property AudioInterface2ABCI As Max9860TypeAudioInterface2Abci
    Get
    Set
public:
property Max9860TypeAudioInterface2Abci AudioInterface2ABCI {
    Max9860TypeAudioInterface2Abci get ();
    void set (Max9860TypeAudioInterface2Abci value);
}
member AudioInterface2ABCI : Max9860TypeAudioInterface2Abci with get, set

Property Value

Type: Max9860TypeAudioInterface2Abci
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.AudioInterface2ADLY Property

IRD

Max9860AudioInterface2ADLY Property

Audio Interface2: ADLY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeAudioInterface2AdcDelay AudioInterface2ADLY { get; set; }
Public Property AudioInterface2ADLY As Max9860TypeAudioInterface2AdcDelay
    Get
    Set
public:
property Max9860TypeAudioInterface2AdcDelay AudioInterface2ADLY {
    Max9860TypeAudioInterface2AdcDelay get ();
    void set (Max9860TypeAudioInterface2AdcDelay value);
}
member AudioInterface2ADLY : Max9860TypeAudioInterface2AdcDelay with get, set

Property Value

Type: Max9860TypeAudioInterface2AdcDelay
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.AudioInterface2BSEL Property

IRD

Max9860AudioInterface2BSEL Property

Audio Interface2: BSEL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeAudioInterface2BclkSelect AudioInterface2BSEL { get; set; }
Public Property AudioInterface2BSEL As Max9860TypeAudioInterface2BclkSelect
    Get
    Set
public:
property Max9860TypeAudioInterface2BclkSelect AudioInterface2BSEL {
    Max9860TypeAudioInterface2BclkSelect get ();
    void set (Max9860TypeAudioInterface2BclkSelect value);
}
member AudioInterface2BSEL : Max9860TypeAudioInterface2BclkSelect with get, set

Property Value

Type: Max9860TypeAudioInterface2BclkSelect
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.AudioInterface2ST Property

IRD

Max9860AudioInterface2ST Property

Audio Interface2: ST

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeAudioInterface2Stereo AudioInterface2ST { get; set; }
Public Property AudioInterface2ST As Max9860TypeAudioInterface2Stereo
    Get
    Set
public:
property Max9860TypeAudioInterface2Stereo AudioInterface2ST {
    Max9860TypeAudioInterface2Stereo get ();
    void set (Max9860TypeAudioInterface2Stereo value);
}
member AudioInterface2ST : Max9860TypeAudioInterface2Stereo with get, set

Property Value

Type: Max9860TypeAudioInterface2Stereo
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.AutoFlush Property

IRD

Max9860AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.DACAttenuationDVA Property

IRD

Max9860DACAttenuationDVA Property

DAC Attenuation: DVA

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeDacAttenuationLevel DACAttenuationDVA { get; set; }
Public Property DACAttenuationDVA As Max9860TypeDacAttenuationLevel
    Get
    Set
public:
property Max9860TypeDacAttenuationLevel DACAttenuationDVA {
    Max9860TypeDacAttenuationLevel get ();
    void set (Max9860TypeDacAttenuationLevel value);
}
member DACAttenuationDVA : Max9860TypeDacAttenuationLevel with get, set

Property Value

Type: Max9860TypeDacAttenuationLevel
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.DACGainDVG Property

IRD

Max9860DACGainDVG Property

DAC Gain: DVG (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeDacGainDvg DACGainDVG { get; set; }
Public Property DACGainDVG As Max9860TypeDacGainDvg
    Get
    Set
public:
property Max9860TypeDacGainDvg DACGainDVG {
    Max9860TypeDacGainDvg get ();
    void set (Max9860TypeDacGainDvg value);
}
member DACGainDVG : Max9860TypeDacGainDvg with get, set

Property Value

Type: Max9860TypeDacGainDvg
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.DACGainDVST Property

IRD

Max9860DACGainDVST Property

DAC Gain: DVST

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeDacGainSidetone DACGainDVST { get; set; }
Public Property DACGainDVST As Max9860TypeDacGainSidetone
    Get
    Set
public:
property Max9860TypeDacGainSidetone DACGainDVST {
    Max9860TypeDacGainSidetone get ();
    void set (Max9860TypeDacGainSidetone value);
}
member DACGainDVST : Max9860TypeDacGainSidetone with get, set

Property Value

Type: Max9860TypeDacGainSidetone
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.InterruptEnableICLD Property

IRD

Max9860InterruptEnableICLD Property

Interrupt Enable: ICLD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeInterruptEnableClipDetect InterruptEnableICLD { get; set; }
Public Property InterruptEnableICLD As Max9860TypeInterruptEnableClipDetect
    Get
    Set
public:
property Max9860TypeInterruptEnableClipDetect InterruptEnableICLD {
    Max9860TypeInterruptEnableClipDetect get ();
    void set (Max9860TypeInterruptEnableClipDetect value);
}
member InterruptEnableICLD : Max9860TypeInterruptEnableClipDetect with get, set

Property Value

Type: Max9860TypeInterruptEnableClipDetect
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.InterruptEnableISLD Property

IRD

Max9860InterruptEnableISLD Property

Interrupt Enable: ISLD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeInterruptEnableSlewLevel InterruptEnableISLD { get; set; }
Public Property InterruptEnableISLD As Max9860TypeInterruptEnableSlewLevel
    Get
    Set
public:
property Max9860TypeInterruptEnableSlewLevel InterruptEnableISLD {
    Max9860TypeInterruptEnableSlewLevel get ();
    void set (Max9860TypeInterruptEnableSlewLevel value);
}
member InterruptEnableISLD : Max9860TypeInterruptEnableSlewLevel with get, set

Property Value

Type: Max9860TypeInterruptEnableSlewLevel
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.InterruptEnableIULK Property

IRD

Max9860InterruptEnableIULK Property

Interrupt Enable: IULK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeInterruptEnablePllUnlock InterruptEnableIULK { get; set; }
Public Property InterruptEnableIULK As Max9860TypeInterruptEnablePllUnlock
    Get
    Set
public:
property Max9860TypeInterruptEnablePllUnlock InterruptEnableIULK {
    Max9860TypeInterruptEnablePllUnlock get ();
    void set (Max9860TypeInterruptEnablePllUnlock value);
}
member InterruptEnableIULK : Max9860TypeInterruptEnablePllUnlock with get, set

Property Value

Type: Max9860TypeInterruptEnablePllUnlock
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.InterruptStatusCLD Property

IRD

Max9860InterruptStatusCLD Property

Interrupt Status: CLD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeInterruptStatusClipDetect InterruptStatusCLD { get; }
Public ReadOnly Property InterruptStatusCLD As Max9860TypeInterruptStatusClipDetect
    Get
public:
property Max9860TypeInterruptStatusClipDetect InterruptStatusCLD {
    Max9860TypeInterruptStatusClipDetect get ();
}
member InterruptStatusCLD : Max9860TypeInterruptStatusClipDetect with get

Property Value

Type: Max9860TypeInterruptStatusClipDetect
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.InterruptStatusSLD Property

IRD

Max9860InterruptStatusSLD Property

Interrupt Status: SLD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeInterruptStatusSlewLevel InterruptStatusSLD { get; }
Public ReadOnly Property InterruptStatusSLD As Max9860TypeInterruptStatusSlewLevel
    Get
public:
property Max9860TypeInterruptStatusSlewLevel InterruptStatusSLD {
    Max9860TypeInterruptStatusSlewLevel get ();
}
member InterruptStatusSLD : Max9860TypeInterruptStatusSlewLevel with get

Property Value

Type: Max9860TypeInterruptStatusSlewLevel
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.InterruptStatusULK Property

IRD

Max9860InterruptStatusULK Property

Interrupt Status: ULK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeInterruptStatusPllUnlock InterruptStatusULK { get; }
Public ReadOnly Property InterruptStatusULK As Max9860TypeInterruptStatusPllUnlock
    Get
public:
property Max9860TypeInterruptStatusPllUnlock InterruptStatusULK {
    Max9860TypeInterruptStatusPllUnlock get ();
}
member InterruptStatusULK : Max9860TypeInterruptStatusPllUnlock with get

Property Value

Type: Max9860TypeInterruptStatusPllUnlock
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.MicrophoneAGCAGCATK Property

IRD

Max9860MicrophoneAGCAGCATK Property

Microphone AGC: AGCATK (unit: ms)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeMicrophoneAgcAttack MicrophoneAGCAGCATK { get; set; }
Public Property MicrophoneAGCAGCATK As Max9860TypeMicrophoneAgcAttack
    Get
    Set
public:
property Max9860TypeMicrophoneAgcAttack MicrophoneAGCAGCATK {
    Max9860TypeMicrophoneAgcAttack get ();
    void set (Max9860TypeMicrophoneAgcAttack value);
}
member MicrophoneAGCAGCATK : Max9860TypeMicrophoneAgcAttack with get, set

Property Value

Type: Max9860TypeMicrophoneAgcAttack
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.MicrophoneAGCAGCHLD Property

IRD

Max9860MicrophoneAGCAGCHLD Property

Microphone AGC: AGCHLD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeMicrophoneAgcHold MicrophoneAGCAGCHLD { get; set; }
Public Property MicrophoneAGCAGCHLD As Max9860TypeMicrophoneAgcHold
    Get
    Set
public:
property Max9860TypeMicrophoneAgcHold MicrophoneAGCAGCHLD {
    Max9860TypeMicrophoneAgcHold get ();
    void set (Max9860TypeMicrophoneAgcHold value);
}
member MicrophoneAGCAGCHLD : Max9860TypeMicrophoneAgcHold with get, set

Property Value

Type: Max9860TypeMicrophoneAgcHold
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.MicrophoneAGCAGCRLS Property

IRD

Max9860MicrophoneAGCAGCRLS Property

Microphone AGC: AGCRLS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeMicrophoneAgcRelease MicrophoneAGCAGCRLS { get; set; }
Public Property MicrophoneAGCAGCRLS As Max9860TypeMicrophoneAgcRelease
    Get
    Set
public:
property Max9860TypeMicrophoneAgcRelease MicrophoneAGCAGCRLS {
    Max9860TypeMicrophoneAgcRelease get ();
    void set (Max9860TypeMicrophoneAgcRelease value);
}
member MicrophoneAGCAGCRLS : Max9860TypeMicrophoneAgcRelease with get, set

Property Value

Type: Max9860TypeMicrophoneAgcRelease
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.MicrophoneAGCAGCSRC Property

IRD

Max9860MicrophoneAGCAGCSRC Property

Microphone AGC: AGCSRC

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeMicrophoneAgcSelect MicrophoneAGCAGCSRC { get; set; }
Public Property MicrophoneAGCAGCSRC As Max9860TypeMicrophoneAgcSelect
    Get
    Set
public:
property Max9860TypeMicrophoneAgcSelect MicrophoneAGCAGCSRC {
    Max9860TypeMicrophoneAgcSelect get ();
    void set (Max9860TypeMicrophoneAgcSelect value);
}
member MicrophoneAGCAGCSRC : Max9860TypeMicrophoneAgcSelect with get, set

Property Value

Type: Max9860TypeMicrophoneAgcSelect
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.MicrophoneGainPAM Property

IRD

Max9860MicrophoneGainPAM Property

Microphone Gain: PAM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeMicrophoneGainPreamp MicrophoneGainPAM { get; set; }
Public Property MicrophoneGainPAM As Max9860TypeMicrophoneGainPreamp
    Get
    Set
public:
property Max9860TypeMicrophoneGainPreamp MicrophoneGainPAM {
    Max9860TypeMicrophoneGainPreamp get ();
    void set (Max9860TypeMicrophoneGainPreamp value);
}
member MicrophoneGainPAM : Max9860TypeMicrophoneGainPreamp with get, set

Property Value

Type: Max9860TypeMicrophoneGainPreamp
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.MicrophoneGainPGAM Property

IRD

Max9860MicrophoneGainPGAM Property

Microphone Gain: PGAM (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeMicrophoneGainPga MicrophoneGainPGAM { get; set; }
Public Property MicrophoneGainPGAM As Max9860TypeMicrophoneGainPga
    Get
    Set
public:
property Max9860TypeMicrophoneGainPga MicrophoneGainPGAM {
    Max9860TypeMicrophoneGainPga get ();
    void set (Max9860TypeMicrophoneGainPga value);
}
member MicrophoneGainPGAM : Max9860TypeMicrophoneGainPga with get, set

Property Value

Type: Max9860TypeMicrophoneGainPga
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.MicrophoneNGAGC Property

IRD

Max9860MicrophoneNGAGC Property

Microphone NG: AGC

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MicrophoneNGAGC { get; }
Public ReadOnly Property MicrophoneNGAGC As Byte
    Get
public:
property unsigned char MicrophoneNGAGC {
    unsigned char get ();
}
member MicrophoneNGAGC : byte with get

Property Value

Type: Byte
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.MicrophoneNGNG Property

IRD

Max9860MicrophoneNGNG Property

Microphone NG: NG (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeMicrophoneNgNoiseGate MicrophoneNGNG { get; }
Public ReadOnly Property MicrophoneNGNG As Max9860TypeMicrophoneNgNoiseGate
    Get
public:
property Max9860TypeMicrophoneNgNoiseGate MicrophoneNGNG {
    Max9860TypeMicrophoneNgNoiseGate get ();
}
member MicrophoneNGNG : Max9860TypeMicrophoneNgNoiseGate with get

Property Value

Type: Max9860TypeMicrophoneNgNoiseGate
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.NoiseGateAGCTH Property

IRD

Max9860NoiseGateAGCTH Property

Noise Gate: AGCTH (unit: dBFS)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double NoiseGateAGCTH { get; set; }
Public Property NoiseGateAGCTH As Double
    Get
    Set
public:
property double NoiseGateAGCTH {
    double get ();
    void set (double value);
}
member NoiseGateAGCTH : float with get, set

Property Value

Type: Double
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.NoiseGateANTH Property

IRD

Max9860NoiseGateANTH Property

Noise Gate: ANTH

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeNoiseGateThreshold NoiseGateANTH { get; set; }
Public Property NoiseGateANTH As Max9860TypeNoiseGateThreshold
    Get
    Set
public:
property Max9860TypeNoiseGateThreshold NoiseGateANTH {
    Max9860TypeNoiseGateThreshold get ();
    void set (Max9860TypeNoiseGateThreshold value);
}
member NoiseGateANTH : Max9860TypeNoiseGateThreshold with get, set

Property Value

Type: Max9860TypeNoiseGateThreshold
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.RevisionCode Property

IRD

Max9860RevisionCode Property

Revision Code

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionCode { get; }
Public ReadOnly Property RevisionCode As Byte
    Get
public:
property unsigned char RevisionCode {
    unsigned char get ();
}
member RevisionCode : byte with get

Property Value

Type: Byte
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.SystemClock16KHZ Property

IRD

Max9860SystemClock16KHZ Property

System Clock: 16KHZ

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeSystemClock16khz SystemClock16KHZ { get; set; }
Public Property SystemClock16KHZ As Max9860TypeSystemClock16khz
    Get
    Set
public:
property Max9860TypeSystemClock16khz SystemClock16KHZ {
    Max9860TypeSystemClock16khz get ();
    void set (Max9860TypeSystemClock16khz value);
}
member SystemClock16KHZ : Max9860TypeSystemClock16khz with get, set

Property Value

Type: Max9860TypeSystemClock16khz
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.SystemClockFREQ Property

IRD

Max9860SystemClockFREQ Property

System Clock: FREQ

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeSystemClockMode SystemClockFREQ { get; set; }
Public Property SystemClockFREQ As Max9860TypeSystemClockMode
    Get
    Set
public:
property Max9860TypeSystemClockMode SystemClockFREQ {
    Max9860TypeSystemClockMode get ();
    void set (Max9860TypeSystemClockMode value);
}
member SystemClockFREQ : Max9860TypeSystemClockMode with get, set

Property Value

Type: Max9860TypeSystemClockMode
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.SystemClockPSCLK Property

IRD

Max9860SystemClockPSCLK Property

System Clock: PSCLK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeSystemClockPrescaler SystemClockPSCLK { get; set; }
Public Property SystemClockPSCLK As Max9860TypeSystemClockPrescaler
    Get
    Set
public:
property Max9860TypeSystemClockPrescaler SystemClockPSCLK {
    Max9860TypeSystemClockPrescaler get ();
    void set (Max9860TypeSystemClockPrescaler value);
}
member SystemClockPSCLK : Max9860TypeSystemClockPrescaler with get, set

Property Value

Type: Max9860TypeSystemClockPrescaler
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.SystemShutdownADCLEN Property

IRD

Max9860SystemShutdownADCLEN Property

System Shutdown: ADCLEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeSystemShutdownAdcLeft SystemShutdownADCLEN { get; set; }
Public Property SystemShutdownADCLEN As Max9860TypeSystemShutdownAdcLeft
    Get
    Set
public:
property Max9860TypeSystemShutdownAdcLeft SystemShutdownADCLEN {
    Max9860TypeSystemShutdownAdcLeft get ();
    void set (Max9860TypeSystemShutdownAdcLeft value);
}
member SystemShutdownADCLEN : Max9860TypeSystemShutdownAdcLeft with get, set

Property Value

Type: Max9860TypeSystemShutdownAdcLeft
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.SystemShutdownDACEN Property

IRD

Max9860SystemShutdownDACEN Property

System Shutdown: DACEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeSystemShutdownDac SystemShutdownDACEN { get; set; }
Public Property SystemShutdownDACEN As Max9860TypeSystemShutdownDac
    Get
    Set
public:
property Max9860TypeSystemShutdownDac SystemShutdownDACEN {
    Max9860TypeSystemShutdownDac get ();
    void set (Max9860TypeSystemShutdownDac value);
}
member SystemShutdownDACEN : Max9860TypeSystemShutdownDac with get, set

Property Value

Type: Max9860TypeSystemShutdownDac
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.SystemShutdownSHDN Property

IRD

Max9860SystemShutdownSHDN Property

System Shutdown: SHDN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeSystemShutdownSelect SystemShutdownSHDN { get; set; }
Public Property SystemShutdownSHDN As Max9860TypeSystemShutdownSelect
    Get
    Set
public:
property Max9860TypeSystemShutdownSelect SystemShutdownSHDN {
    Max9860TypeSystemShutdownSelect get ();
    void set (Max9860TypeSystemShutdownSelect value);
}
member SystemShutdownSHDN : Max9860TypeSystemShutdownSelect with get, set

Property Value

Type: Max9860TypeSystemShutdownSelect
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.SystemSutdownADCREN Property

IRD

Max9860SystemSutdownADCREN Property

System Sutdown: ADCREN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeSystemShutdownAdcRight SystemSutdownADCREN { get; set; }
Public Property SystemSutdownADCREN As Max9860TypeSystemShutdownAdcRight
    Get
    Set
public:
property Max9860TypeSystemShutdownAdcRight SystemSutdownADCREN {
    Max9860TypeSystemShutdownAdcRight get ();
    void set (Max9860TypeSystemShutdownAdcRight value);
}
member SystemSutdownADCREN : Max9860TypeSystemShutdownAdcRight with get, set

Property Value

Type: Max9860TypeSystemShutdownAdcRight
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.VoiceFilterAVFLT Property

IRD

Max9860VoiceFilterAVFLT Property

Voice Filter: AVFLT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeVoiceFilter VoiceFilterAVFLT { get; set; }
Public Property VoiceFilterAVFLT As Max9860TypeVoiceFilter
    Get
    Set
public:
property Max9860TypeVoiceFilter VoiceFilterAVFLT {
    Max9860TypeVoiceFilter get ();
    void set (Max9860TypeVoiceFilter value);
}
member VoiceFilterAVFLT : Max9860TypeVoiceFilter with get, set

Property Value

Type: Max9860TypeVoiceFilter
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.VoiceFilterDVFLT Property

IRD

Max9860VoiceFilterDVFLT Property

Voice Filter: DVFLT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9860TypeVoiceFilter VoiceFilterDVFLT { get; set; }
Public Property VoiceFilterDVFLT As Max9860TypeVoiceFilter
    Get
    Set
public:
property Max9860TypeVoiceFilter VoiceFilterDVFLT {
    Max9860TypeVoiceFilter get ();
    void set (Max9860TypeVoiceFilter value);
}
member VoiceFilterDVFLT : Max9860TypeVoiceFilter with get, set

Property Value

Type: Max9860TypeVoiceFilter
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860 Methods

The Max9860 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.Flush Method

IRD

Max9860Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max9860 Class
telos.Ird.Maxim Namespace


Max9860.TypeAudioClockHighPll Enumeration

IRD

Max9860TypeAudioClockHighPll Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioClockHighPll
Public Enumeration TypeAudioClockHighPll
public enum class TypeAudioClockHighPll
type TypeAudioClockHighPll
Members
Member name | Value | Description
PLLDisabled | 0 | PLL Disabled
PLLEnabled | 1 | PLL Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeAudioInterface1DacDelay Enumeration

IRD

Max9860TypeAudioInterface1DacDelay Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface1DacDelay
Public Enumeration TypeAudioInterface1DacDelay
public enum class TypeAudioInterface1DacDelay
type TypeAudioInterface1DacDelay
Members
Member name | Value | Description
SDINIsLatchedOnFirstBCLKEdge | 0 | SDIN Is Latched On First BCLK Edge
SDINIsLatchedOnSecondBCLKEdge | 1 | SDIN Is Latched On Second BCLK Edge
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeAudioInterface1Dbci Enumeration

IRD

Max9860TypeAudioInterface1Dbci Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface1Dbci
Public Enumeration TypeAudioInterface1Dbci
public enum class TypeAudioInterface1Dbci
type TypeAudioInterface1Dbci
Members
Member name | Value | Description
SDINIsLatchedOnRisingEdgeOfBCLK | 0 | SDIN Is Latched On Rising Edge Of BCLK
SDINIsLatchedOnFallingEdgeOfBCLK | 1 | SDIN Is Latched On Falling Edge Of BCLK
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeAudioInterface1Impedance Enumeration

IRD

Max9860TypeAudioInterface1Impedance Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface1Impedance
Public Enumeration TypeAudioInterface1Impedance
public enum class TypeAudioInterface1Impedance
type TypeAudioInterface1Impedance
Members
Member name | Value | Description
SDOUTIsHighOrLowAfterBitsHaveBeenTransferred | 0 | SDOUT Is High Or Low After Bits Have Been Transferred
SDOUTGoesToHighImpedanceAfterBitsHaveBeenTransferred | 1 | SDOUT Goes To High Impedance After Bits Have Been Transferred
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeAudioInterface1Master Enumeration

IRD

Max9860TypeAudioInterface1Master Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface1Master
Public Enumeration TypeAudioInterface1Master
public enum class TypeAudioInterface1Master
type TypeAudioInterface1Master
Members
Member name | Value | Description
TheDeviceOperatesInSlaveMode | 0 | The Device Operates In Slave Mode
TheDeviceOperatesInMasterMode | 1 | The Device Operates In Master Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeAudioInterface1TdmMode Enumeration

IRD

Max9860TypeAudioInterface1TdmMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface1TdmMode
Public Enumeration TypeAudioInterface1TdmMode
public enum class TypeAudioInterface1TdmMode
type TypeAudioInterface1TdmMode
Members
Member name | Value | Description
LRCLKIndicatesLeftAndRightAudio | 0 | LRCLK Indicates Left And Right Audio
LRCLKIndicatesTheStartOfAFrame | 1 | LRCLK Indicates The Start Of A Frame
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeAudioInterface1Wci Enumeration

IRD

Max9860TypeAudioInterface1Wci Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface1Wci
Public Enumeration TypeAudioInterface1Wci
public enum class TypeAudioInterface1Wci
type TypeAudioInterface1Wci
Members
Member name | Value | Description
LeftChannelDataIsInputAndOutput | 0 | Left Channel Data Is Input And Output
RightChannelDataIsInputAndOutput | 1 | Right Channel Data Is Input And Output
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeAudioInterface2Abci Enumeration

IRD

Max9860TypeAudioInterface2Abci Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface2Abci
Public Enumeration TypeAudioInterface2Abci
public enum class TypeAudioInterface2Abci
type TypeAudioInterface2Abci
Members
Member name | Value | Description
SDOUTValidOnRisingEdgeOfBCLK | 0 | SDOUT Valid On Rising Edge Of BCLK
SDOUTValidOnFallingEdgeOfBCLK | 1 | SDOUT Valid On Falling Edge Of BCLK
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeAudioInterface2AdcDelay Enumeration

IRD

Max9860TypeAudioInterface2AdcDelay Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface2AdcDelay
Public Enumeration TypeAudioInterface2AdcDelay
public enum class TypeAudioInterface2AdcDelay
type TypeAudioInterface2AdcDelay
Members
Member name | Value | Description
SDOUTIsValidOnFirstBCLKEdge | 0 | SDOUT Is Valid On First BCLK Edge
SDOUTIsValidOnSecondBCLKEdge | 1 | SDOUT Is Valid On Second BCLK Edge
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeAudioInterface2BclkSelect Enumeration

IRD

Max9860TypeAudioInterface2BclkSelect Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface2BclkSelect
Public Enumeration TypeAudioInterface2BclkSelect
public enum class TypeAudioInterface2BclkSelect
type TypeAudioInterface2BclkSelect
Members
Member name | Value | Description
BCLKSelectOff | 0 | BCLK Select: Off
BCLKSelect64XLRCLK | 1 | BCLK Select: 64 x LRCLK
BCLKSelect48XLRCLK | 2 | BCLK Select: 48 x LRCLK
BCLKSelectPCLK2 | 4 | BCLK Select: PCLK / 2
BCLKSelectPCLK4 | 5 | BCLK Select: PCLK / 4
BCLKSelectPCLK8 | 6 | BCLK Select: PCLK / 8
BCLKSelectPCLK16 | 7 | BCLK Select: PCLK / 16
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeAudioInterface2Stereo Enumeration

IRD

Max9860TypeAudioInterface2Stereo Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface2Stereo
Public Enumeration TypeAudioInterface2Stereo
public enum class TypeAudioInterface2Stereo
type TypeAudioInterface2Stereo
Members
Member name | Value | Description
InterfaceOperatesInMono | 0 | Interface Operates In Mono
InterfaceOperatesInStereo | 1 | Interface Operates In Stereo
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeDacAttenuationLevel Enumeration

IRD

Max9860TypeDacAttenuationLevel Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacAttenuationLevel
Public Enumeration TypeDacAttenuationLevel
public enum class TypeDacAttenuationLevel
type TypeDacAttenuationLevel
Members
Member name | Value | Description
Value_3DB | 0 | 3 dB
Value_2DB | 2 | 2 dB
Value_1DB | 4 | 1 dB
Value_0DB | 6 | 0 dB
Value_1DB__1 | 8 | -1 dB
Value_2DB__1 | 10 | -2 dB
Value_3DB__1 | 12 | -3 dB
Value_4DB | 14 | -4 dB
Value_5DB | 16 | -5 dB
Value_6DB | 18 | -6 dB
Value_7DB | 20 | -7 dB
Value_8DB | 22 | -8 dB
Value_9DB | 24 | -9 dB
Value_10DB | 26 | -10 dB
Value_11DB | 28 | -11 dB
Value_12DB | 30 | -12 dB
Value_13DB | 32 | -13 dB
Value_14DB | 34 | -14 dB
Value_15DB | 36 | -15 dB
Value_16DB | 38 | -16 dB
Value_17DB | 40 | -17 dB
Value_18DB | 42 | -18 dB
Value_19DB | 44 | -19 dB
Value_20DB | 46 | -20 dB
Value_21DB | 48 | -21 dB
Value_22DB | 50 | -22 dB
Value_23DB | 52 | -23 dB
Value_24DB | 54 | -24 dB
Value_25DB | 56 | -25 dB
Value_26DB | 58 | -26 dB
Value_27DB | 60 | -27 dB
Value_28DB | 62 | -28 dB
Value_29DB | 64 | -29 dB
Value_30DB | 66 | -30 dB
Value_31DB | 68 | -31 dB
Value_32DB | 70 | -32 dB
Value_33DB | 72 | -33 dB
Value_34DB | 74 | -34 dB
Value_35DB | 76 | -35 dB
Value_36DB | 78 | -36 dB
Value_37DB | 80 | -37 dB
Value_38DB | 82 | -38 dB
Value_39DB | 84 | -39 dB
Value_40DB | 86 | -40 dB
Value_41DB | 88 | -41 dB
Value_42DB | 90 | -42 dB
Value_43DB | 92 | -43 dB
Value_44DB | 94 | -44 dB
Value_45DB | 96 | -45 dB
Value_46DB | 98 | -46 dB
Value_47DB | 100 | -47 dB
Value_48DB | 102 | -48 dB
Value_49DB | 104 | -49 dB
Value_50DB | 106 | -50 dB
Value_51DB | 108 | -51 dB
Value_52DB | 110 | -52 dB
Value_53DB | 112 | -53 dB
Value_54DB | 114 | -54 dB
Value_55DB | 116 | -55 dB
Value_56DB | 118 | -56 dB
Value_57DB | 120 | -57 dB
Value_58DB | 122 | -58 dB
Value_59DB | 124 | -59 dB
Value_60DB | 126 | -60 dB
Value_61DB | 128 | -61 dB
Value_62DB | 130 | -62 dB
Value_63DB | 132 | -63 dB
Value_64DB | 134 | -64 dB
Value_65DB | 136 | -65 dB
Value_66DB | 138 | -66 dB
Value_67DB | 140 | -67 dB
Value_68DB | 142 | -68 dB
Value_69DB | 144 | -69 dB
Value_70DB | 146 | -70 dB
Value_71DB | 148 | -71 dB
Value_72DB | 150 | -72 dB
Value_73DB | 152 | -73 dB
Value_74DB | 154 | -74 dB
Value_75DB | 156 | -75 dB
Value_76DB | 158 | -76 dB
Value_77DB | 160 | -77 dB
Value_78DB | 162 | -78 dB
Value_79DB | 164 | -79 dB
Value_80DB | 166 | -80 dB
Value_81DB | 168 | -81 dB
Value_82DB | 170 | -82 dB
Value_83DB | 172 | -83 dB
Value_84DB | 174 | -84 dB
Value_85DB | 176 | -85 dB
Value_86DB | 178 | -86 dB
Value_87DB | 180 | -87 dB
Value_88DB | 182 | -88 dB
Value_89DB | 184 | -89 dB
Value_90DB | 186 | -90 dB
Mute | 187 | Mute
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeDacGainDvg Enumeration

IRD

Max9860TypeDacGainDvg Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacGainDvg
Public Enumeration TypeDacGainDvg
public enum class TypeDacGainDvg
type TypeDacGainDvg
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_6 | 1 | 6
Value_12 | 2 | 12
Value_18 | 3 | 18
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeDacGainSidetone Enumeration

IRD

Max9860TypeDacGainSidetone Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacGainSidetone
Public Enumeration TypeDacGainSidetone
public enum class TypeDacGainSidetone
type TypeDacGainSidetone
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_0DB | 1 | 0 dB
Value_2DB | 2 | -2 dB
Value_4DB | 3 | -4 dB
Value_6DB | 4 | -6 dB
Value_8DB | 5 | -8 dB
Value_10DB | 6 | -10 dB
Value_12DB | 7 | -12 dB
Value_14DB | 8 | -14 dB
Value_16DB | 9 | -16 dB
Value_18DB | 10 | -18 dB
Value_20DB | 11 | -20 dB
Value_22DB | 12 | -22 dB
Value_24DB | 13 | -24 dB
Value_26DB | 14 | -26 dB
Value_28DB | 15 | -28 dB
Value_30DB | 16 | -30 dB
Value_32DB | 17 | -32 dB
Value_34DB | 18 | -34 dB
Value_36DB | 19 | -36 dB
Value_38DB | 20 | -38 dB
Value_40DB | 21 | -40 dB
Value_42DB | 22 | -42 dB
Value_44DB | 23 | -44 dB
Value_46DB | 24 | -46 dB
Value_48DB | 25 | -48 dB
Value_50DB | 26 | -50 dB
Value_52DB | 27 | -52 dB
Value_54DB | 28 | -54 dB
Value_56DB | 29 | -56 dB
Value_58DB | 30 | -58 dB
Value_60DB | 31 | -60 dB
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeInterruptEnableClipDetect Enumeration

IRD

Max9860TypeInterruptEnableClipDetect Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableClipDetect
Public Enumeration TypeInterruptEnableClipDetect
public enum class TypeInterruptEnableClipDetect
type TypeInterruptEnableClipDetect
Members
Member name | Value | Description
ClipDetectInterruptDisabled | 0 | Clip Detect Interrupt: Disabled
ClipDetectInterruptEnabled | 1 | Clip Detect Interrupt: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeInterruptEnablePllUnlock Enumeration

IRD

Max9860TypeInterruptEnablePllUnlock Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnablePllUnlock
Public Enumeration TypeInterruptEnablePllUnlock
public enum class TypeInterruptEnablePllUnlock
type TypeInterruptEnablePllUnlock
Members
Member name | Value | Description
PLLUnlockInterruptDisabled | 0 | PLL Unlock Interrupt: Disabled
PLLUnlockInterruptEnabled | 1 | PLL Unlock Interrupt: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeInterruptEnableSlewLevel Enumeration

IRD

Max9860TypeInterruptEnableSlewLevel Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableSlewLevel
Public Enumeration TypeInterruptEnableSlewLevel
public enum class TypeInterruptEnableSlewLevel
type TypeInterruptEnableSlewLevel
Members
Member name | Value | Description
SlewLevelInterruptDisabled | 0 | Slew Level Interrupt: Disabled
SlewLevelInterruptEnabled | 1 | Slew Level Interrupt: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeInterruptStatusClipDetect Enumeration

IRD

Max9860TypeInterruptStatusClipDetect Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatusClipDetect
Public Enumeration TypeInterruptStatusClipDetect
public enum class TypeInterruptStatusClipDetect
type TypeInterruptStatusClipDetect
Members
Member name | Value | Description
SignalNotClippedInADCOrDAC | 0 | Signal Not Clipped In ADC Or DAC
SignalClippedInADCOrDAC | 1 | Signal Clipped in ADC Or DAC
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeInterruptStatusPllUnlock Enumeration

IRD

Max9860TypeInterruptStatusPllUnlock Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatusPllUnlock
Public Enumeration TypeInterruptStatusPllUnlock
public enum class TypeInterruptStatusPllUnlock
type TypeInterruptStatusPllUnlock
Members
Member name | Value | Description
DigitalAudioPLLForDACOrADCLocked | 0 | Digital Audio PLL For DAC Or ADC: Locked
DigitalAudioPLLForDACOrADCUnlocked | 1 | Digital Audio PLL For DAC Or ADC: Unlocked
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeInterruptStatusSlewLevel Enumeration

IRD

Max9860TypeInterruptStatusSlewLevel Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatusSlewLevel
Public Enumeration TypeInterruptStatusSlewLevel
public enum class TypeInterruptStatusSlewLevel
type TypeInterruptStatusSlewLevel
Members
Member name | Value | Description
SlewingHasNotCompleted | 0 | Slewing Has Not Completed
SlewingHasCompleted | 1 | Slewing Has Completed
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeMicrophoneAgcAttack Enumeration

IRD

Max9860TypeMicrophoneAgcAttack Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMicrophoneAgcAttack
Public Enumeration TypeMicrophoneAgcAttack
public enum class TypeMicrophoneAgcAttack
type TypeMicrophoneAgcAttack
Members
Member name | Value | Description
Value_3 | 0 | 3
Value_12 | 1 | 12
Value_50 | 2 | 50
Value_200 | 3 | 200
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeMicrophoneAgcHold Enumeration

IRD

Max9860TypeMicrophoneAgcHold Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMicrophoneAgcHold
Public Enumeration TypeMicrophoneAgcHold
public enum class TypeMicrophoneAgcHold
type TypeMicrophoneAgcHold
Members
Member name | Value | Description
AGCDisabled | 0 | AGC Disabled
Value_50Ms | 1 | 50 ms
Value_100Ms | 2 | 100 ms
Value_400Ms | 3 | 400 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeMicrophoneAgcRelease Enumeration

IRD

Max9860TypeMicrophoneAgcRelease Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMicrophoneAgcRelease
Public Enumeration TypeMicrophoneAgcRelease
public enum class TypeMicrophoneAgcRelease
type TypeMicrophoneAgcRelease
Members
Member name | Value | Description
Value_78Ms | 0 | 78 ms
Value_156Ms | 1 | 156 ms
Value_312Ms | 2 | 312 ms
Value_625Ms | 3 | 625 ms
Value_125S | 4 | 1.25 s
Value_25S | 5 | 2.5 s
Value_5S | 6 | 5 s
Value_10S | 7 | 10 s
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeMicrophoneAgcSelect Enumeration

IRD

Max9860TypeMicrophoneAgcSelect Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMicrophoneAgcSelect
Public Enumeration TypeMicrophoneAgcSelect
public enum class TypeMicrophoneAgcSelect
type TypeMicrophoneAgcSelect
Members
Member name | Value | Description
LeftADCOutputIsUsedByAGCAndNoiseGate | 0 | Left ADC Output Is Used By AGC And Noise Gate
SumOfLeftAndRightADCOutputIsUsedByAGCAndNoiseGate | 1 | Sum Of Left And Right ADC Output Is Used By AGC And Noise Gate
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeMicrophoneGainPga Enumeration

IRD

Max9860TypeMicrophoneGainPga Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMicrophoneGainPga
Public Enumeration TypeMicrophoneGainPga
public enum class TypeMicrophoneGainPga
type TypeMicrophoneGainPga
Members
Member name | Value | Description
Value_20 | 0 | 20
Value_19 | 1 | 19
Value_18 | 2 | 18
Value_17 | 3 | 17
Value_16 | 4 | 16
Value_15 | 5 | 15
Value_14 | 6 | 14
Value_13 | 7 | 13
Value_12 | 8 | 12
Value_11 | 9 | 11
Value_10 | 10 | 10
Value_9 | 11 | 9
Value_8 | 12 | 8
Value_7 | 13 | 7
Value_6 | 14 | 6
Value_5 | 15 | 5
Value_4 | 16 | 4
Value_3 | 17 | 3
Value_2 | 18 | 2
Value_1 | 19 | 1
Value_0 | 20 | 0
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeMicrophoneGainPreamp Enumeration

IRD

Max9860TypeMicrophoneGainPreamp Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMicrophoneGainPreamp
Public Enumeration TypeMicrophoneGainPreamp
public enum class TypeMicrophoneGainPreamp
type TypeMicrophoneGainPreamp
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_0DB | 1 | 0 dB
Value_20DB | 2 | 20 dB
Value_30DB | 3 | 30 dB
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeMicrophoneNgNoiseGate Enumeration

IRD

Max9860TypeMicrophoneNgNoiseGate Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMicrophoneNgNoiseGate
Public Enumeration TypeMicrophoneNgNoiseGate
public enum class TypeMicrophoneNgNoiseGate
type TypeMicrophoneNgNoiseGate
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_1 | 1 | 1
Value_2 | 2 | 2
Value_3 | 3 | 3
Value_6 | 4 | 6
Value_8 | 5 | 8
Value_10 | 6 | 10
Value_12 | 7 | 12
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeNoiseGateThreshold Enumeration

IRD

Max9860TypeNoiseGateThreshold Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeNoiseGateThreshold
Public Enumeration TypeNoiseGateThreshold
public enum class TypeNoiseGateThreshold
type TypeNoiseGateThreshold
Members
Member name | Value | Description
Disabled | 0 | Disabled
Value_72DB | 1 | -72 dB
Value_68DB | 2 | -68 dB
Value_64DB | 3 | -64 dB
Value_60DB | 4 | -60 dB
Value_56DB | 5 | -56 dB
Value_52DB | 6 | -52 dB
Value_48DB | 7 | -48 dB
Value_44DB | 8 | -44 dB
Value_40DB | 9 | -40 dB
Value_36DB | 10 | -36 dB
Value_32DB | 11 | -32 dB
Value_28DB | 12 | -28 dB
Value_24DB | 13 | -24 dB
Value_20DB | 14 | -20 dB
Value_16DB | 15 | -16 dB
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeSystemClock16khz Enumeration

IRD

Max9860TypeSystemClock16khz Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSystemClock16khz
Public Enumeration TypeSystemClock16khz
public enum class TypeSystemClock16khz
type TypeSystemClock16khz
Members
Member name | Value | Description
Value_16KHzModeDisabled | 0 | 16 kHz Mode: Disabled
Value_16KHzModeEnabled | 1 | 16 kHz Mode: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeSystemClockMode Enumeration

IRD

Max9860TypeSystemClockMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSystemClockMode
Public Enumeration TypeSystemClockMode
public enum class TypeSystemClockMode
type TypeSystemClockMode
Members
Member name | Value | Description
IntegerClockModeNormalOperation | 0 | Integer Clock Mode: Normal Operation
PCLK12MHz | 1 | PCLK = 12 MHz
PCLK13MHz | 2 | PCLK = 13 MHz
PCLK192MHz | 3 | PCLK = 19.2 MHz
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeSystemClockPrescaler Enumeration

IRD

Max9860TypeSystemClockPrescaler Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSystemClockPrescaler
Public Enumeration TypeSystemClockPrescaler
public enum class TypeSystemClockPrescaler
type TypeSystemClockPrescaler
Members
Member name | Value | Description
DisableClockForLowPowerShutdown | 0 | Disable Clock For Low-Power Shutdown
Value_10MHzMCLK20MHz | 1 | 10 MHz <= MCLK <= 20 MHz
Value_20MHzMCLK40MHz | 2 | 20 MHz <= MCLK <= 40 MHz
MCLK40MHz | 3 | MCLK > 40 MHz
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeSystemShutdownAdcLeft Enumeration

IRD

Max9860TypeSystemShutdownAdcLeft Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSystemShutdownAdcLeft
Public Enumeration TypeSystemShutdownAdcLeft
public enum class TypeSystemShutdownAdcLeft
type TypeSystemShutdownAdcLeft
Members
Member name | Value | Description
ADCLeftDisabled | 0 | ADC Left: Disabled
ADCLeftEnabled | 1 | ADC Left: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeSystemShutdownAdcRight Enumeration

IRD

Max9860TypeSystemShutdownAdcRight Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSystemShutdownAdcRight
Public Enumeration TypeSystemShutdownAdcRight
public enum class TypeSystemShutdownAdcRight
type TypeSystemShutdownAdcRight
Members
Member name | Value | Description
ADCRightDisabled | 0 | ADC Right: Disabled
ADCRightEnabled | 1 | ADC Right: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeSystemShutdownDac Enumeration

IRD

Max9860TypeSystemShutdownDac Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSystemShutdownDac
Public Enumeration TypeSystemShutdownDac
public enum class TypeSystemShutdownDac
type TypeSystemShutdownDac
Members
Member name | Value | Description
DACDisabled | 0 | DAC: Disabled
DACEnabled | 1 | DAC: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeSystemShutdownSelect Enumeration

IRD

Max9860TypeSystemShutdownSelect Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSystemShutdownSelect
Public Enumeration TypeSystemShutdownSelect
public enum class TypeSystemShutdownSelect
type TypeSystemShutdownSelect
Members
Member name | Value | Description
DeviceIsInFullShutdown | 0 | Device Is In Full Shutdown
DeviceIsPoweredOn | 1 | Device Is Powered On
See Also

Reference

telos.Ird.Maxim Namespace


Max9860.TypeVoiceFilter Enumeration

IRD

Max9860TypeVoiceFilter Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVoiceFilter
Public Enumeration TypeVoiceFilter
public enum class TypeVoiceFilter
type TypeVoiceFilter
Members
Member name | Value | Description
DigitalFilterDiabled | 0 | Digital Filter: Diabled
EllipticalHighpassFilter16KHzSampleRate217HzNotch | 1 | Elliptical Highpass Filter, 16 kHz Sample Rate, 217 Hz Notch
Value_500HzButterworthHighpassFilter16KHzSampleRate | 2 | 500 Hz Butterworth Highpass Filter, 16 kHz Sample Rate
EllipticalHighpassFilter8KHzSampleRate217HzNotch | 3 | Elliptical Highpass Filter, 8 kHz Sample Rate, 217 Hz Notch
Value_500HzButterworthHighpassFilter8KHzSampleRate | 4 | 500 Hz Butterworth Highpass Filter, 8 kHz Sample Rate
Value_200HzButterworthHighpassFilter48KHzSampleRate | 5 | 200 Hz Butterworth Highpass Filter, 48 kHz Sample Rate
See Also

Reference

telos.Ird.Maxim Namespace


Max9867 Class

Maxim: MAX 9867
Inheritance Hierarchy
SystemObject
telos.Ird.MaximMax9867

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Max9867
Public Class Max9867
public ref class Max9867
type Max9867 =  class end

The Max9867 type exposes the following members.

Constructors
 | Name | Description
Public method | Max9867 | Constructor
Top
Properties
 | Name | Description
Public property | ADCInputAUXCAL | ADC Input: AUXCAL
Public property | ADCInputAUXCAP | ADC Input: AUXCAP
Public property | ADCInputAUXEN | ADC Input: AUXEN
Public property | ADCInputAUXGAIN | ADC Input: AUXGAIN
Public property | ADCInputMXINL | ADC Input: MXINL
Public property | ADCInputMXINR | ADC Input: MXINR
Public property | ADCLevelAVL | ADC Level: AVL (unit: dB)
Public property | ADCLevelAVR | ADC Level: AVR (unit: dB)
Public property | AudioClockHighPLL | Audio Clock High: PLL
Public property | AudioClockNI | Audio Clock: NI
Public property | AudioInterface1BCI | Audio Interface1: BCI
Public property | AudioInterface1DLY | Audio Interface1: DLY
Public property | AudioInterface1HIZOFF | Audio Interface1: HIZOFF
Public property | AudioInterface1MAS | Audio Interface1: MAS
Public property | AudioInterface1TDM | Audio Interface1: TDM
Public property | AudioInterface1WCI | Audio Interface1: WCI
Public property | AudioInterface2BSEL | Audio Interface2: BSEL
Public property | AudioInterface2DMONO | Audio Interface2: DMONO
Public property | AudioInterface2LVOLFIX | Audio Interface2: LVOLFIX
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AUXAUX | AUX: AUX
Public property | CodecFiltersAVFLT | Codec Filters: AVFLT
Public property | CodecFiltersDVFLT | Codec Filters: DVFLT
Public property | CodecFiltersMODE | Codec Filters: MODE
Public property | DACLevelDACA | DAC Level: DACA (unit: dB)
Public property | DACLevelDACG | DAC Level: DACG (unit: dB)
Public property | DACLevelDACM | DAC Level: DACM
Public property | InterruptEnableICLD | Interrupt Enable: ICLD
Public property | InterruptEnableIJDET | Interrupt Enable: IJDET
Public property | InterruptEnableISLD | Interrupt Enable: ISLD
Public property | InterruptEnableIULK | Interrupt Enable: IULK
Public property | InterruptEnableSDODLY | Interrupt Enable: SDODLY
Public property | JackSenseJKMIC | Jack Sense: JKMIC
Public property | JackSenseJKSNS | Jack Sense: JKSNS
Public property | JackSenseLSNS | Jack Sense: LSNS
Public property | LeftGainPALEN | Left Gain: PALEN
Public property | LeftGainPGAML | Left Gain: PGAML
Public property | LeftLineLIGL | Left Line: LIGL (unit: dB)
Public property | LeftLineLILM | Left Line: LILM
Public property | LeftVolumeVOLL | Left Volume: VOLL
Public property | LeftVolumeVOLLM | Left Volume: VOLLM
Public property | MicrophoneDIGMICLDIGMICR | Microphone: DIGMICL-DIGMICR
Public property | MicrophoneMICCLK | Microphone: MICCLK
Public property | ModeDSLEW | Mode: DSLEW
Public property | ModeHPMODE | Mode: HPMODE
Public property | ModeJDETEN | Mode: JDETEN
Public property | ModeVSEN | Mode: VSEN
Public property | ModeZDEN | Mode: ZDEN
Public property | RevisionREV | Revision: REV
Public property | RightGainPAREN | Right Gain: PAREN
Public property | RightGainPGAMR | Right Gain: PGAMR
Public property | RightLineLIGR | Right Line: LIGR (unit: dB)
Public property | RightLineLIRM | Right Line: LIRM
Public property | RightVolumeVOLR | Right Volume: VOLR
Public property | RightVolumeVOLRM | Right Volume: VOLRM
Public property | SidetoneDSTS | Sidetone: DSTS
Public property | SidetoneDVST | Sidetone: DVST
Public property | StatusCLD | Status: CLD
Public property | StatusJDET | Status: JDET
Public property | StatusSLD | Status: SLD
Public property | StatusULK | Status: ULK
Public property | SystemClockFREQ | System Clock: FREQ
Public property | SystemClockPSCLK | System Clock: PSCLK
Public property | SystemShutdownADLEN | System Shutdown: ADLEN
Public property | SystemShutdownADREN | System Shutdown: ADREN
Public property | SystemShutdownDALEN | System Shutdown: DALEN
Public property | SystemShutdownDAREN | System Shutdown: DAREN
Public property | SystemShutdownLNLEN | System Shutdown: LNLEN
Public property | SystemShutdownLNREN | System Shutdown: LNREN
Public property | SystemShutdownSHDN | System Shutdown: SHDN
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Ultra-Low Power Stereo Audio Codec
See Also

Reference

telos.Ird.Maxim Namespace


Max9867 Constructor

Constructor

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Max9867(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Max9867

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867 Properties

The Max9867 type exposes the following members.

Properties
 | Name | Description
Public property | ADCInputAUXCAL | ADC Input: AUXCAL
Public property | ADCInputAUXCAP | ADC Input: AUXCAP
Public property | ADCInputAUXEN | ADC Input: AUXEN
Public property | ADCInputAUXGAIN | ADC Input: AUXGAIN
Public property | ADCInputMXINL | ADC Input: MXINL
Public property | ADCInputMXINR | ADC Input: MXINR
Public property | ADCLevelAVL | ADC Level: AVL (unit: dB)
Public property | ADCLevelAVR | ADC Level: AVR (unit: dB)
Public property | AudioClockHighPLL | Audio Clock High: PLL
Public property | AudioClockNI | Audio Clock: NI
Public property | AudioInterface1BCI | Audio Interface1: BCI
Public property | AudioInterface1DLY | Audio Interface1: DLY
Public property | AudioInterface1HIZOFF | Audio Interface1: HIZOFF
Public property | AudioInterface1MAS | Audio Interface1: MAS
Public property | AudioInterface1TDM | Audio Interface1: TDM
Public property | AudioInterface1WCI | Audio Interface1: WCI
Public property | AudioInterface2BSEL | Audio Interface2: BSEL
Public property | AudioInterface2DMONO | Audio Interface2: DMONO
Public property | AudioInterface2LVOLFIX | Audio Interface2: LVOLFIX
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AUXAUX | AUX: AUX
Public property | CodecFiltersAVFLT | Codec Filters: AVFLT
Public property | CodecFiltersDVFLT | Codec Filters: DVFLT
Public property | CodecFiltersMODE | Codec Filters: MODE
Public property | DACLevelDACA | DAC Level: DACA (unit: dB)
Public property | DACLevelDACG | DAC Level: DACG (unit: dB)
Public property | DACLevelDACM | DAC Level: DACM
Public property | InterruptEnableICLD | Interrupt Enable: ICLD
Public property | InterruptEnableIJDET | Interrupt Enable: IJDET
Public property | InterruptEnableISLD | Interrupt Enable: ISLD
Public property | InterruptEnableIULK | Interrupt Enable: IULK
Public property | InterruptEnableSDODLY | Interrupt Enable: SDODLY
Public property | JackSenseJKMIC | Jack Sense: JKMIC
Public property | JackSenseJKSNS | Jack Sense: JKSNS
Public property | JackSenseLSNS | Jack Sense: LSNS
Public property | LeftGainPALEN | Left Gain: PALEN
Public property | LeftGainPGAML | Left Gain: PGAML
Public property | LeftLineLIGL | Left Line: LIGL (unit: dB)
Public property | LeftLineLILM | Left Line: LILM
Public property | LeftVolumeVOLL | Left Volume: VOLL
Public property | LeftVolumeVOLLM | Left Volume: VOLLM
Public property | MicrophoneDIGMICLDIGMICR | Microphone: DIGMICL-DIGMICR
Public property | MicrophoneMICCLK | Microphone: MICCLK
Public property | ModeDSLEW | Mode: DSLEW
Public property | ModeHPMODE | Mode: HPMODE
Public property | ModeJDETEN | Mode: JDETEN
Public property | ModeVSEN | Mode: VSEN
Public property | ModeZDEN | Mode: ZDEN
Public property | RevisionREV | Revision: REV
Public property | RightGainPAREN | Right Gain: PAREN
Public property | RightGainPGAMR | Right Gain: PGAMR
Public property | RightLineLIGR | Right Line: LIGR (unit: dB)
Public property | RightLineLIRM | Right Line: LIRM
Public property | RightVolumeVOLR | Right Volume: VOLR
Public property | RightVolumeVOLRM | Right Volume: VOLRM
Public property | SidetoneDSTS | Sidetone: DSTS
Public property | SidetoneDVST | Sidetone: DVST
Public property | StatusCLD | Status: CLD
Public property | StatusJDET | Status: JDET
Public property | StatusSLD | Status: SLD
Public property | StatusULK | Status: ULK
Public property | SystemClockFREQ | System Clock: FREQ
Public property | SystemClockPSCLK | System Clock: PSCLK
Public property | SystemShutdownADLEN | System Shutdown: ADLEN
Public property | SystemShutdownADREN | System Shutdown: ADREN
Public property | SystemShutdownDALEN | System Shutdown: DALEN
Public property | SystemShutdownDAREN | System Shutdown: DAREN
Public property | SystemShutdownLNLEN | System Shutdown: LNLEN
Public property | SystemShutdownLNREN | System Shutdown: LNREN
Public property | SystemShutdownSHDN | System Shutdown: SHDN
Top
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.ADCInputAUXCAL Property

IRD

Max9867ADCInputAUXCAL Property

ADC Input: AUXCAL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeAdcInputAuxOffset ADCInputAUXCAL { get; set; }
Public Property ADCInputAUXCAL As Max9867TypeAdcInputAuxOffset
    Get
    Set
public:
property Max9867TypeAdcInputAuxOffset ADCInputAUXCAL {
    Max9867TypeAdcInputAuxOffset get ();
    void set (Max9867TypeAdcInputAuxOffset value);
}
member ADCInputAUXCAL : Max9867TypeAdcInputAuxOffset with get, set

Property Value

Type: Max9867TypeAdcInputAuxOffset
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.ADCInputAUXCAP Property

IRD

Max9867ADCInputAUXCAP Property

ADC Input: AUXCAP

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeAdcInputAuxCapture ADCInputAUXCAP { get; set; }
Public Property ADCInputAUXCAP As Max9867TypeAdcInputAuxCapture
    Get
    Set
public:
property Max9867TypeAdcInputAuxCapture ADCInputAUXCAP {
    Max9867TypeAdcInputAuxCapture get ();
    void set (Max9867TypeAdcInputAuxCapture value);
}
member ADCInputAUXCAP : Max9867TypeAdcInputAuxCapture with get, set

Property Value

Type: Max9867TypeAdcInputAuxCapture
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.ADCInputAUXEN Property

IRD

Max9867ADCInputAUXEN Property

ADC Input: AUXEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeAdcInputAuxInput ADCInputAUXEN { get; set; }
Public Property ADCInputAUXEN As Max9867TypeAdcInputAuxInput
    Get
    Set
public:
property Max9867TypeAdcInputAuxInput ADCInputAUXEN {
    Max9867TypeAdcInputAuxInput get ();
    void set (Max9867TypeAdcInputAuxInput value);
}
member ADCInputAUXEN : Max9867TypeAdcInputAuxInput with get, set

Property Value

Type: Max9867TypeAdcInputAuxInput
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.ADCInputAUXGAIN Property

IRD

Max9867ADCInputAUXGAIN Property

ADC Input: AUXGAIN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeAdcInputAuxGain ADCInputAUXGAIN { get; set; }
Public Property ADCInputAUXGAIN As Max9867TypeAdcInputAuxGain
    Get
    Set
public:
property Max9867TypeAdcInputAuxGain ADCInputAUXGAIN {
    Max9867TypeAdcInputAuxGain get ();
    void set (Max9867TypeAdcInputAuxGain value);
}
member ADCInputAUXGAIN : Max9867TypeAdcInputAuxGain with get, set

Property Value

Type: Max9867TypeAdcInputAuxGain
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.ADCInputMXINL Property

IRD

Max9867ADCInputMXINL Property

ADC Input: MXINL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeAdcInputMixerLeft ADCInputMXINL { get; set; }
Public Property ADCInputMXINL As Max9867TypeAdcInputMixerLeft
    Get
    Set
public:
property Max9867TypeAdcInputMixerLeft ADCInputMXINL {
    Max9867TypeAdcInputMixerLeft get ();
    void set (Max9867TypeAdcInputMixerLeft value);
}
member ADCInputMXINL : Max9867TypeAdcInputMixerLeft with get, set

Property Value

Type: Max9867TypeAdcInputMixerLeft
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.ADCInputMXINR Property

IRD

Max9867ADCInputMXINR Property

ADC Input: MXINR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeAdcInputMixerRight ADCInputMXINR { get; set; }
Public Property ADCInputMXINR As Max9867TypeAdcInputMixerRight
    Get
    Set
public:
property Max9867TypeAdcInputMixerRight ADCInputMXINR {
    Max9867TypeAdcInputMixerRight get ();
    void set (Max9867TypeAdcInputMixerRight value);
}
member ADCInputMXINR : Max9867TypeAdcInputMixerRight with get, set

Property Value

Type: Max9867TypeAdcInputMixerRight
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.ADCLevelAVL Property

IRD

Max9867ADCLevelAVL Property

ADC Level: AVL (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ADCLevelAVL { get; set; }
Public Property ADCLevelAVL As Double
    Get
    Set
public:
property double ADCLevelAVL {
    double get ();
    void set (double value);
}
member ADCLevelAVL : float with get, set

Property Value

Type: Double
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.ADCLevelAVR Property

IRD

Max9867ADCLevelAVR Property

ADC Level: AVR (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ADCLevelAVR { get; set; }
Public Property ADCLevelAVR As Double
    Get
    Set
public:
property double ADCLevelAVR {
    double get ();
    void set (double value);
}
member ADCLevelAVR : float with get, set

Property Value

Type: Double
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.AudioClockHighPLL Property

IRD

Max9867AudioClockHighPLL Property

Audio Clock High: PLL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeAudioClockHighPll AudioClockHighPLL { get; set; }
Public Property AudioClockHighPLL As Max9867TypeAudioClockHighPll
    Get
    Set
public:
property Max9867TypeAudioClockHighPll AudioClockHighPLL {
    Max9867TypeAudioClockHighPll get ();
    void set (Max9867TypeAudioClockHighPll value);
}
member AudioClockHighPLL : Max9867TypeAudioClockHighPll with get, set

Property Value

Type: Max9867TypeAudioClockHighPll
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.AudioClockNI Property

IRD

Max9867AudioClockNI Property

Audio Clock: NI

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AudioClockNI { get; set; }
Public Property AudioClockNI As UShort
    Get
    Set
public:
property unsigned short AudioClockNI {
    unsigned short get ();
    void set (unsigned short value);
}
member AudioClockNI : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.AudioInterface1BCI Property

IRD

Max9867AudioInterface1BCI Property

Audio Interface1: BCI

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeAudioInterface1Bci AudioInterface1BCI { get; set; }
Public Property AudioInterface1BCI As Max9867TypeAudioInterface1Bci
    Get
    Set
public:
property Max9867TypeAudioInterface1Bci AudioInterface1BCI {
    Max9867TypeAudioInterface1Bci get ();
    void set (Max9867TypeAudioInterface1Bci value);
}
member AudioInterface1BCI : Max9867TypeAudioInterface1Bci with get, set

Property Value

Type: Max9867TypeAudioInterface1Bci
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.AudioInterface1DLY Property

IRD

Max9867AudioInterface1DLY Property

Audio Interface1: DLY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeAudioInterface1Delay AudioInterface1DLY { get; set; }
Public Property AudioInterface1DLY As Max9867TypeAudioInterface1Delay
    Get
    Set
public:
property Max9867TypeAudioInterface1Delay AudioInterface1DLY {
    Max9867TypeAudioInterface1Delay get ();
    void set (Max9867TypeAudioInterface1Delay value);
}
member AudioInterface1DLY : Max9867TypeAudioInterface1Delay with get, set

Property Value

Type: Max9867TypeAudioInterface1Delay
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.AudioInterface1HIZOFF Property

IRD

Max9867AudioInterface1HIZOFF Property

Audio Interface1: HIZOFF

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeAudioInterface1Impedance AudioInterface1HIZOFF { get; set; }
Public Property AudioInterface1HIZOFF As Max9867TypeAudioInterface1Impedance
    Get
    Set
public:
property Max9867TypeAudioInterface1Impedance AudioInterface1HIZOFF {
    Max9867TypeAudioInterface1Impedance get ();
    void set (Max9867TypeAudioInterface1Impedance value);
}
member AudioInterface1HIZOFF : Max9867TypeAudioInterface1Impedance with get, set

Property Value

Type: Max9867TypeAudioInterface1Impedance
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.AudioInterface1MAS Property

IRD

Max9867AudioInterface1MAS Property

Audio Interface1: MAS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeAudioInterface1Master AudioInterface1MAS { get; set; }
Public Property AudioInterface1MAS As Max9867TypeAudioInterface1Master
    Get
    Set
public:
property Max9867TypeAudioInterface1Master AudioInterface1MAS {
    Max9867TypeAudioInterface1Master get ();
    void set (Max9867TypeAudioInterface1Master value);
}
member AudioInterface1MAS : Max9867TypeAudioInterface1Master with get, set

Property Value

Type: Max9867TypeAudioInterface1Master
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.AudioInterface1TDM Property

IRD

Max9867AudioInterface1TDM Property

Audio Interface1: TDM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeAudioInterface1TdmMode AudioInterface1TDM { get; set; }
Public Property AudioInterface1TDM As Max9867TypeAudioInterface1TdmMode
    Get
    Set
public:
property Max9867TypeAudioInterface1TdmMode AudioInterface1TDM {
    Max9867TypeAudioInterface1TdmMode get ();
    void set (Max9867TypeAudioInterface1TdmMode value);
}
member AudioInterface1TDM : Max9867TypeAudioInterface1TdmMode with get, set

Property Value

Type: Max9867TypeAudioInterface1TdmMode
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.AudioInterface1WCI Property

IRD

Max9867AudioInterface1WCI Property

Audio Interface1: WCI

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeAudioInterface1Wci AudioInterface1WCI { get; set; }
Public Property AudioInterface1WCI As Max9867TypeAudioInterface1Wci
    Get
    Set
public:
property Max9867TypeAudioInterface1Wci AudioInterface1WCI {
    Max9867TypeAudioInterface1Wci get ();
    void set (Max9867TypeAudioInterface1Wci value);
}
member AudioInterface1WCI : Max9867TypeAudioInterface1Wci with get, set

Property Value

Type: Max9867TypeAudioInterface1Wci
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.AudioInterface2BSEL Property

IRD

Max9867AudioInterface2BSEL Property

Audio Interface2: BSEL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeAudioInterface2BclkSelect AudioInterface2BSEL { get; set; }
Public Property AudioInterface2BSEL As Max9867TypeAudioInterface2BclkSelect
    Get
    Set
public:
property Max9867TypeAudioInterface2BclkSelect AudioInterface2BSEL {
    Max9867TypeAudioInterface2BclkSelect get ();
    void set (Max9867TypeAudioInterface2BclkSelect value);
}
member AudioInterface2BSEL : Max9867TypeAudioInterface2BclkSelect with get, set

Property Value

Type: Max9867TypeAudioInterface2BclkSelect
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.AudioInterface2DMONO Property

IRD

Max9867AudioInterface2DMONO Property

Audio Interface2: DMONO

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeAudioInterface2Mono AudioInterface2DMONO { get; set; }
Public Property AudioInterface2DMONO As Max9867TypeAudioInterface2Mono
    Get
    Set
public:
property Max9867TypeAudioInterface2Mono AudioInterface2DMONO {
    Max9867TypeAudioInterface2Mono get ();
    void set (Max9867TypeAudioInterface2Mono value);
}
member AudioInterface2DMONO : Max9867TypeAudioInterface2Mono with get, set

Property Value

Type: Max9867TypeAudioInterface2Mono
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.AudioInterface2LVOLFIX Property

IRD

Max9867AudioInterface2LVOLFIX Property

Audio Interface2: LVOLFIX

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeAudioInterface2FixLine AudioInterface2LVOLFIX { get; set; }
Public Property AudioInterface2LVOLFIX As Max9867TypeAudioInterface2FixLine
    Get
    Set
public:
property Max9867TypeAudioInterface2FixLine AudioInterface2LVOLFIX {
    Max9867TypeAudioInterface2FixLine get ();
    void set (Max9867TypeAudioInterface2FixLine value);
}
member AudioInterface2LVOLFIX : Max9867TypeAudioInterface2FixLine with get, set

Property Value

Type: Max9867TypeAudioInterface2FixLine
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.AutoFlush Property

IRD

Max9867AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.AUXAUX Property

IRD

Max9867AUXAUX Property

AUX: AUX

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short AUXAUX { get; }
Public ReadOnly Property AUXAUX As Short
    Get
public:
property short AUXAUX {
    short get ();
}
member AUXAUX : int16 with get

Property Value

Type: Int16
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.CodecFiltersAVFLT Property

IRD

Max9867CodecFiltersAVFLT Property

Codec Filters: AVFLT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeCodecFiltersFilter CodecFiltersAVFLT { get; set; }
Public Property CodecFiltersAVFLT As Max9867TypeCodecFiltersFilter
    Get
    Set
public:
property Max9867TypeCodecFiltersFilter CodecFiltersAVFLT {
    Max9867TypeCodecFiltersFilter get ();
    void set (Max9867TypeCodecFiltersFilter value);
}
member CodecFiltersAVFLT : Max9867TypeCodecFiltersFilter with get, set

Property Value

Type: Max9867TypeCodecFiltersFilter
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.CodecFiltersDVFLT Property

IRD

Max9867CodecFiltersDVFLT Property

Codec Filters: DVFLT

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeCodecFiltersFilter CodecFiltersDVFLT { get; set; }
Public Property CodecFiltersDVFLT As Max9867TypeCodecFiltersFilter
    Get
    Set
public:
property Max9867TypeCodecFiltersFilter CodecFiltersDVFLT {
    Max9867TypeCodecFiltersFilter get ();
    void set (Max9867TypeCodecFiltersFilter value);
}
member CodecFiltersDVFLT : Max9867TypeCodecFiltersFilter with get, set

Property Value

Type: Max9867TypeCodecFiltersFilter
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.CodecFiltersMODE Property

IRD

Max9867CodecFiltersMODE Property

Codec Filters: MODE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeCodecFiltersMode CodecFiltersMODE { get; set; }
Public Property CodecFiltersMODE As Max9867TypeCodecFiltersMode
    Get
    Set
public:
property Max9867TypeCodecFiltersMode CodecFiltersMODE {
    Max9867TypeCodecFiltersMode get ();
    void set (Max9867TypeCodecFiltersMode value);
}
member CodecFiltersMODE : Max9867TypeCodecFiltersMode with get, set

Property Value

Type: Max9867TypeCodecFiltersMode
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.DACLevelDACA Property

IRD

Max9867DACLevelDACA Property

DAC Level: DACA (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DACLevelDACA { get; set; }
Public Property DACLevelDACA As Double
    Get
    Set
public:
property double DACLevelDACA {
    double get ();
    void set (double value);
}
member DACLevelDACA : float with get, set

Property Value

Type: Double
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.DACLevelDACG Property

IRD

Max9867DACLevelDACG Property

DAC Level: DACG (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeDacLevelGain DACLevelDACG { get; set; }
Public Property DACLevelDACG As Max9867TypeDacLevelGain
    Get
    Set
public:
property Max9867TypeDacLevelGain DACLevelDACG {
    Max9867TypeDacLevelGain get ();
    void set (Max9867TypeDacLevelGain value);
}
member DACLevelDACG : Max9867TypeDacLevelGain with get, set

Property Value

Type: Max9867TypeDacLevelGain
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.DACLevelDACM Property

IRD

Max9867DACLevelDACM Property

DAC Level: DACM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeDacLevelMute DACLevelDACM { get; set; }
Public Property DACLevelDACM As Max9867TypeDacLevelMute
    Get
    Set
public:
property Max9867TypeDacLevelMute DACLevelDACM {
    Max9867TypeDacLevelMute get ();
    void set (Max9867TypeDacLevelMute value);
}
member DACLevelDACM : Max9867TypeDacLevelMute with get, set

Property Value

Type: Max9867TypeDacLevelMute
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.InterruptEnableICLD Property

IRD

Max9867InterruptEnableICLD Property

Interrupt Enable: ICLD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeInterruptEnableClipDetect InterruptEnableICLD { get; set; }
Public Property InterruptEnableICLD As Max9867TypeInterruptEnableClipDetect
    Get
    Set
public:
property Max9867TypeInterruptEnableClipDetect InterruptEnableICLD {
    Max9867TypeInterruptEnableClipDetect get ();
    void set (Max9867TypeInterruptEnableClipDetect value);
}
member InterruptEnableICLD : Max9867TypeInterruptEnableClipDetect with get, set

Property Value

Type: Max9867TypeInterruptEnableClipDetect
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.InterruptEnableIJDET Property

IRD

Max9867InterruptEnableIJDET Property

Interrupt Enable: IJDET

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeInterruptEnableHeadset InterruptEnableIJDET { get; set; }
Public Property InterruptEnableIJDET As Max9867TypeInterruptEnableHeadset
    Get
    Set
public:
property Max9867TypeInterruptEnableHeadset InterruptEnableIJDET {
    Max9867TypeInterruptEnableHeadset get ();
    void set (Max9867TypeInterruptEnableHeadset value);
}
member InterruptEnableIJDET : Max9867TypeInterruptEnableHeadset with get, set

Property Value

Type: Max9867TypeInterruptEnableHeadset
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.InterruptEnableISLD Property

IRD

Max9867InterruptEnableISLD Property

Interrupt Enable: ISLD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeInterruptEnableSlewLevel InterruptEnableISLD { get; set; }
Public Property InterruptEnableISLD As Max9867TypeInterruptEnableSlewLevel
    Get
    Set
public:
property Max9867TypeInterruptEnableSlewLevel InterruptEnableISLD {
    Max9867TypeInterruptEnableSlewLevel get ();
    void set (Max9867TypeInterruptEnableSlewLevel value);
}
member InterruptEnableISLD : Max9867TypeInterruptEnableSlewLevel with get, set

Property Value

Type: Max9867TypeInterruptEnableSlewLevel
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.InterruptEnableIULK Property

IRD

Max9867InterruptEnableIULK Property

Interrupt Enable: IULK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeInterruptEnablePllUnlock InterruptEnableIULK { get; set; }
Public Property InterruptEnableIULK As Max9867TypeInterruptEnablePllUnlock
    Get
    Set
public:
property Max9867TypeInterruptEnablePllUnlock InterruptEnableIULK {
    Max9867TypeInterruptEnablePllUnlock get ();
    void set (Max9867TypeInterruptEnablePllUnlock value);
}
member InterruptEnableIULK : Max9867TypeInterruptEnablePllUnlock with get, set

Property Value

Type: Max9867TypeInterruptEnablePllUnlock
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.InterruptEnableSDODLY Property

IRD

Max9867InterruptEnableSDODLY Property

Interrupt Enable: SDODLY

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeInterruptEnableSdout InterruptEnableSDODLY { get; set; }
Public Property InterruptEnableSDODLY As Max9867TypeInterruptEnableSdout
    Get
    Set
public:
property Max9867TypeInterruptEnableSdout InterruptEnableSDODLY {
    Max9867TypeInterruptEnableSdout get ();
    void set (Max9867TypeInterruptEnableSdout value);
}
member InterruptEnableSDODLY : Max9867TypeInterruptEnableSdout with get, set

Property Value

Type: Max9867TypeInterruptEnableSdout
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.JackSenseJKMIC Property

IRD

Max9867JackSenseJKMIC Property

Jack Sense: JKMIC

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeJackSenseMicrophone JackSenseJKMIC { get; }
Public ReadOnly Property JackSenseJKMIC As Max9867TypeJackSenseMicrophone
    Get
public:
property Max9867TypeJackSenseMicrophone JackSenseJKMIC {
    Max9867TypeJackSenseMicrophone get ();
}
member JackSenseJKMIC : Max9867TypeJackSenseMicrophone with get

Property Value

Type: Max9867TypeJackSenseMicrophone
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.JackSenseJKSNS Property

IRD

Max9867JackSenseJKSNS Property

Jack Sense: JKSNS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeJackSenseJack JackSenseJKSNS { get; }
Public ReadOnly Property JackSenseJKSNS As Max9867TypeJackSenseJack
    Get
public:
property Max9867TypeJackSenseJack JackSenseJKSNS {
    Max9867TypeJackSenseJack get ();
}
member JackSenseJKSNS : Max9867TypeJackSenseJack with get

Property Value

Type: Max9867TypeJackSenseJack
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.JackSenseLSNS Property

IRD

Max9867JackSenseLSNS Property

Jack Sense: LSNS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeJackSenseLoutp JackSenseLSNS { get; }
Public ReadOnly Property JackSenseLSNS As Max9867TypeJackSenseLoutp
    Get
public:
property Max9867TypeJackSenseLoutp JackSenseLSNS {
    Max9867TypeJackSenseLoutp get ();
}
member JackSenseLSNS : Max9867TypeJackSenseLoutp with get

Property Value

Type: Max9867TypeJackSenseLoutp
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.LeftGainPALEN Property

IRD

Max9867LeftGainPALEN Property

Left Gain: PALEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeGainPreamp LeftGainPALEN { get; set; }
Public Property LeftGainPALEN As Max9867TypeGainPreamp
    Get
    Set
public:
property Max9867TypeGainPreamp LeftGainPALEN {
    Max9867TypeGainPreamp get ();
    void set (Max9867TypeGainPreamp value);
}
member LeftGainPALEN : Max9867TypeGainPreamp with get, set

Property Value

Type: Max9867TypeGainPreamp
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.LeftGainPGAML Property

IRD

Max9867LeftGainPGAML Property

Left Gain: PGAML

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeGainAmplifier LeftGainPGAML { get; set; }
Public Property LeftGainPGAML As Max9867TypeGainAmplifier
    Get
    Set
public:
property Max9867TypeGainAmplifier LeftGainPGAML {
    Max9867TypeGainAmplifier get ();
    void set (Max9867TypeGainAmplifier value);
}
member LeftGainPGAML : Max9867TypeGainAmplifier with get, set

Property Value

Type: Max9867TypeGainAmplifier
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.LeftLineLIGL Property

IRD

Max9867LeftLineLIGL Property

Left Line: LIGL (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LeftLineLIGL { get; set; }
Public Property LeftLineLIGL As Double
    Get
    Set
public:
property double LeftLineLIGL {
    double get ();
    void set (double value);
}
member LeftLineLIGL : float with get, set

Property Value

Type: Double
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.LeftLineLILM Property

IRD

Max9867LeftLineLILM Property

Left Line: LILM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeLineMute LeftLineLILM { get; set; }
Public Property LeftLineLILM As Max9867TypeLineMute
    Get
    Set
public:
property Max9867TypeLineMute LeftLineLILM {
    Max9867TypeLineMute get ();
    void set (Max9867TypeLineMute value);
}
member LeftLineLILM : Max9867TypeLineMute with get, set

Property Value

Type: Max9867TypeLineMute
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.LeftVolumeVOLL Property

IRD

Max9867LeftVolumeVOLL Property

Left Volume: VOLL

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeVolumeGain LeftVolumeVOLL { get; set; }
Public Property LeftVolumeVOLL As Max9867TypeVolumeGain
    Get
    Set
public:
property Max9867TypeVolumeGain LeftVolumeVOLL {
    Max9867TypeVolumeGain get ();
    void set (Max9867TypeVolumeGain value);
}
member LeftVolumeVOLL : Max9867TypeVolumeGain with get, set

Property Value

Type: Max9867TypeVolumeGain
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.LeftVolumeVOLLM Property

IRD

Max9867LeftVolumeVOLLM Property

Left Volume: VOLLM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeVolumeMute LeftVolumeVOLLM { get; set; }
Public Property LeftVolumeVOLLM As Max9867TypeVolumeMute
    Get
    Set
public:
property Max9867TypeVolumeMute LeftVolumeVOLLM {
    Max9867TypeVolumeMute get ();
    void set (Max9867TypeVolumeMute value);
}
member LeftVolumeVOLLM : Max9867TypeVolumeMute with get, set

Property Value

Type: Max9867TypeVolumeMute
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.MicrophoneDIGMICLDIGMICR Property

IRD

Max9867MicrophoneDIGMICLDIGMICR Property

Microphone: DIGMICL-DIGMICR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeMicrophoneLeftRight MicrophoneDIGMICLDIGMICR { get; set; }
Public Property MicrophoneDIGMICLDIGMICR As Max9867TypeMicrophoneLeftRight
    Get
    Set
public:
property Max9867TypeMicrophoneLeftRight MicrophoneDIGMICLDIGMICR {
    Max9867TypeMicrophoneLeftRight get ();
    void set (Max9867TypeMicrophoneLeftRight value);
}
member MicrophoneDIGMICLDIGMICR : Max9867TypeMicrophoneLeftRight with get, set

Property Value

Type: Max9867TypeMicrophoneLeftRight
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.MicrophoneMICCLK Property

IRD

Max9867MicrophoneMICCLK Property

Microphone: MICCLK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeMicrophoneClock MicrophoneMICCLK { get; set; }
Public Property MicrophoneMICCLK As Max9867TypeMicrophoneClock
    Get
    Set
public:
property Max9867TypeMicrophoneClock MicrophoneMICCLK {
    Max9867TypeMicrophoneClock get ();
    void set (Max9867TypeMicrophoneClock value);
}
member MicrophoneMICCLK : Max9867TypeMicrophoneClock with get, set

Property Value

Type: Max9867TypeMicrophoneClock
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.ModeDSLEW Property

IRD

Max9867ModeDSLEW Property

Mode: DSLEW

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeModeSlewSpeed ModeDSLEW { get; set; }
Public Property ModeDSLEW As Max9867TypeModeSlewSpeed
    Get
    Set
public:
property Max9867TypeModeSlewSpeed ModeDSLEW {
    Max9867TypeModeSlewSpeed get ();
    void set (Max9867TypeModeSlewSpeed value);
}
member ModeDSLEW : Max9867TypeModeSlewSpeed with get, set

Property Value

Type: Max9867TypeModeSlewSpeed
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.ModeHPMODE Property

IRD

Max9867ModeHPMODE Property

Mode: HPMODE

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeModeHeadphone ModeHPMODE { get; set; }
Public Property ModeHPMODE As Max9867TypeModeHeadphone
    Get
    Set
public:
property Max9867TypeModeHeadphone ModeHPMODE {
    Max9867TypeModeHeadphone get ();
    void set (Max9867TypeModeHeadphone value);
}
member ModeHPMODE : Max9867TypeModeHeadphone with get, set

Property Value

Type: Max9867TypeModeHeadphone
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.ModeJDETEN Property

IRD

Max9867ModeJDETEN Property

Mode: JDETEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeModeJackDetection ModeJDETEN { get; set; }
Public Property ModeJDETEN As Max9867TypeModeJackDetection
    Get
    Set
public:
property Max9867TypeModeJackDetection ModeJDETEN {
    Max9867TypeModeJackDetection get ();
    void set (Max9867TypeModeJackDetection value);
}
member ModeJDETEN : Max9867TypeModeJackDetection with get, set

Property Value

Type: Max9867TypeModeJackDetection
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.ModeVSEN Property

IRD

Max9867ModeVSEN Property

Mode: VSEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeModeSmoothing ModeVSEN { get; set; }
Public Property ModeVSEN As Max9867TypeModeSmoothing
    Get
    Set
public:
property Max9867TypeModeSmoothing ModeVSEN {
    Max9867TypeModeSmoothing get ();
    void set (Max9867TypeModeSmoothing value);
}
member ModeVSEN : Max9867TypeModeSmoothing with get, set

Property Value

Type: Max9867TypeModeSmoothing
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.ModeZDEN Property

IRD

Max9867ModeZDEN Property

Mode: ZDEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeModeZeroCrossing ModeZDEN { get; set; }
Public Property ModeZDEN As Max9867TypeModeZeroCrossing
    Get
    Set
public:
property Max9867TypeModeZeroCrossing ModeZDEN {
    Max9867TypeModeZeroCrossing get ();
    void set (Max9867TypeModeZeroCrossing value);
}
member ModeZDEN : Max9867TypeModeZeroCrossing with get, set

Property Value

Type: Max9867TypeModeZeroCrossing
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.RevisionREV Property

IRD

Max9867RevisionREV Property

Revision: REV

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionREV { get; }
Public ReadOnly Property RevisionREV As Byte
    Get
public:
property unsigned char RevisionREV {
    unsigned char get ();
}
member RevisionREV : byte with get

Property Value

Type: Byte
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.RightGainPAREN Property

IRD

Max9867RightGainPAREN Property

Right Gain: PAREN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeGainPreamp RightGainPAREN { get; set; }
Public Property RightGainPAREN As Max9867TypeGainPreamp
    Get
    Set
public:
property Max9867TypeGainPreamp RightGainPAREN {
    Max9867TypeGainPreamp get ();
    void set (Max9867TypeGainPreamp value);
}
member RightGainPAREN : Max9867TypeGainPreamp with get, set

Property Value

Type: Max9867TypeGainPreamp
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.RightGainPGAMR Property

IRD

Max9867RightGainPGAMR Property

Right Gain: PGAMR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeGainAmplifier RightGainPGAMR { get; set; }
Public Property RightGainPGAMR As Max9867TypeGainAmplifier
    Get
    Set
public:
property Max9867TypeGainAmplifier RightGainPGAMR {
    Max9867TypeGainAmplifier get ();
    void set (Max9867TypeGainAmplifier value);
}
member RightGainPGAMR : Max9867TypeGainAmplifier with get, set

Property Value

Type: Max9867TypeGainAmplifier
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.RightLineLIGR Property

IRD

Max9867RightLineLIGR Property

Right Line: LIGR (unit: dB)

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RightLineLIGR { get; set; }
Public Property RightLineLIGR As Double
    Get
    Set
public:
property double RightLineLIGR {
    double get ();
    void set (double value);
}
member RightLineLIGR : float with get, set

Property Value

Type: Double
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.RightLineLIRM Property

IRD

Max9867RightLineLIRM Property

Right Line: LIRM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeLineMute RightLineLIRM { get; set; }
Public Property RightLineLIRM As Max9867TypeLineMute
    Get
    Set
public:
property Max9867TypeLineMute RightLineLIRM {
    Max9867TypeLineMute get ();
    void set (Max9867TypeLineMute value);
}
member RightLineLIRM : Max9867TypeLineMute with get, set

Property Value

Type: Max9867TypeLineMute
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.RightVolumeVOLR Property

IRD

Max9867RightVolumeVOLR Property

Right Volume: VOLR

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeVolumeGain RightVolumeVOLR { get; set; }
Public Property RightVolumeVOLR As Max9867TypeVolumeGain
    Get
    Set
public:
property Max9867TypeVolumeGain RightVolumeVOLR {
    Max9867TypeVolumeGain get ();
    void set (Max9867TypeVolumeGain value);
}
member RightVolumeVOLR : Max9867TypeVolumeGain with get, set

Property Value

Type: Max9867TypeVolumeGain
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.RightVolumeVOLRM Property

IRD

Max9867RightVolumeVOLRM Property

Right Volume: VOLRM

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeVolumeMute RightVolumeVOLRM { get; set; }
Public Property RightVolumeVOLRM As Max9867TypeVolumeMute
    Get
    Set
public:
property Max9867TypeVolumeMute RightVolumeVOLRM {
    Max9867TypeVolumeMute get ();
    void set (Max9867TypeVolumeMute value);
}
member RightVolumeVOLRM : Max9867TypeVolumeMute with get, set

Property Value

Type: Max9867TypeVolumeMute
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.SidetoneDSTS Property

IRD

Max9867SidetoneDSTS Property

Sidetone: DSTS

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeSidetoneMixer SidetoneDSTS { get; set; }
Public Property SidetoneDSTS As Max9867TypeSidetoneMixer
    Get
    Set
public:
property Max9867TypeSidetoneMixer SidetoneDSTS {
    Max9867TypeSidetoneMixer get ();
    void set (Max9867TypeSidetoneMixer value);
}
member SidetoneDSTS : Max9867TypeSidetoneMixer with get, set

Property Value

Type: Max9867TypeSidetoneMixer
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.SidetoneDVST Property

IRD

Max9867SidetoneDVST Property

Sidetone: DVST

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeSidetoneOutput SidetoneDVST { get; set; }
Public Property SidetoneDVST As Max9867TypeSidetoneOutput
    Get
    Set
public:
property Max9867TypeSidetoneOutput SidetoneDVST {
    Max9867TypeSidetoneOutput get ();
    void set (Max9867TypeSidetoneOutput value);
}
member SidetoneDVST : Max9867TypeSidetoneOutput with get, set

Property Value

Type: Max9867TypeSidetoneOutput
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.StatusCLD Property

IRD

Max9867StatusCLD Property

Status: CLD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeStatusClipDetect StatusCLD { get; }
Public ReadOnly Property StatusCLD As Max9867TypeStatusClipDetect
    Get
public:
property Max9867TypeStatusClipDetect StatusCLD {
    Max9867TypeStatusClipDetect get ();
}
member StatusCLD : Max9867TypeStatusClipDetect with get

Property Value

Type: Max9867TypeStatusClipDetect
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.StatusJDET Property

IRD

Max9867StatusJDET Property

Status: JDET

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeStatusHeadset StatusJDET { get; }
Public ReadOnly Property StatusJDET As Max9867TypeStatusHeadset
    Get
public:
property Max9867TypeStatusHeadset StatusJDET {
    Max9867TypeStatusHeadset get ();
}
member StatusJDET : Max9867TypeStatusHeadset with get

Property Value

Type: Max9867TypeStatusHeadset
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.StatusSLD Property

IRD

Max9867StatusSLD Property

Status: SLD

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeStatusSlewLevel StatusSLD { get; }
Public ReadOnly Property StatusSLD As Max9867TypeStatusSlewLevel
    Get
public:
property Max9867TypeStatusSlewLevel StatusSLD {
    Max9867TypeStatusSlewLevel get ();
}
member StatusSLD : Max9867TypeStatusSlewLevel with get

Property Value

Type: Max9867TypeStatusSlewLevel
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.StatusULK Property

IRD

Max9867StatusULK Property

Status: ULK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeStatusPllUnlock StatusULK { get; }
Public ReadOnly Property StatusULK As Max9867TypeStatusPllUnlock
    Get
public:
property Max9867TypeStatusPllUnlock StatusULK {
    Max9867TypeStatusPllUnlock get ();
}
member StatusULK : Max9867TypeStatusPllUnlock with get

Property Value

Type: Max9867TypeStatusPllUnlock
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.SystemClockFREQ Property

IRD

Max9867SystemClockFREQ Property

System Clock: FREQ

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeSystemClockFrequency SystemClockFREQ { get; set; }
Public Property SystemClockFREQ As Max9867TypeSystemClockFrequency
    Get
    Set
public:
property Max9867TypeSystemClockFrequency SystemClockFREQ {
    Max9867TypeSystemClockFrequency get ();
    void set (Max9867TypeSystemClockFrequency value);
}
member SystemClockFREQ : Max9867TypeSystemClockFrequency with get, set

Property Value

Type: Max9867TypeSystemClockFrequency
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.SystemClockPSCLK Property

IRD

Max9867SystemClockPSCLK Property

System Clock: PSCLK

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeSystemClockPrescaler SystemClockPSCLK { get; set; }
Public Property SystemClockPSCLK As Max9867TypeSystemClockPrescaler
    Get
    Set
public:
property Max9867TypeSystemClockPrescaler SystemClockPSCLK {
    Max9867TypeSystemClockPrescaler get ();
    void set (Max9867TypeSystemClockPrescaler value);
}
member SystemClockPSCLK : Max9867TypeSystemClockPrescaler with get, set

Property Value

Type: Max9867TypeSystemClockPrescaler
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.SystemShutdownADLEN Property

IRD

Max9867SystemShutdownADLEN Property

System Shutdown: ADLEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeSystemShutdownLeftAdc SystemShutdownADLEN { get; set; }
Public Property SystemShutdownADLEN As Max9867TypeSystemShutdownLeftAdc
    Get
    Set
public:
property Max9867TypeSystemShutdownLeftAdc SystemShutdownADLEN {
    Max9867TypeSystemShutdownLeftAdc get ();
    void set (Max9867TypeSystemShutdownLeftAdc value);
}
member SystemShutdownADLEN : Max9867TypeSystemShutdownLeftAdc with get, set

Property Value

Type: Max9867TypeSystemShutdownLeftAdc
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.SystemShutdownADREN Property

IRD

Max9867SystemShutdownADREN Property

System Shutdown: ADREN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeSystemShutdownRightAdc SystemShutdownADREN { get; set; }
Public Property SystemShutdownADREN As Max9867TypeSystemShutdownRightAdc
    Get
    Set
public:
property Max9867TypeSystemShutdownRightAdc SystemShutdownADREN {
    Max9867TypeSystemShutdownRightAdc get ();
    void set (Max9867TypeSystemShutdownRightAdc value);
}
member SystemShutdownADREN : Max9867TypeSystemShutdownRightAdc with get, set

Property Value

Type: Max9867TypeSystemShutdownRightAdc
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.SystemShutdownDALEN Property

IRD

Max9867SystemShutdownDALEN Property

System Shutdown: DALEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeSystemShutdownLeftDac SystemShutdownDALEN { get; set; }
Public Property SystemShutdownDALEN As Max9867TypeSystemShutdownLeftDac
    Get
    Set
public:
property Max9867TypeSystemShutdownLeftDac SystemShutdownDALEN {
    Max9867TypeSystemShutdownLeftDac get ();
    void set (Max9867TypeSystemShutdownLeftDac value);
}
member SystemShutdownDALEN : Max9867TypeSystemShutdownLeftDac with get, set

Property Value

Type: Max9867TypeSystemShutdownLeftDac
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.SystemShutdownDAREN Property

IRD

Max9867SystemShutdownDAREN Property

System Shutdown: DAREN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeSystemShutdownRightDac SystemShutdownDAREN { get; set; }
Public Property SystemShutdownDAREN As Max9867TypeSystemShutdownRightDac
    Get
    Set
public:
property Max9867TypeSystemShutdownRightDac SystemShutdownDAREN {
    Max9867TypeSystemShutdownRightDac get ();
    void set (Max9867TypeSystemShutdownRightDac value);
}
member SystemShutdownDAREN : Max9867TypeSystemShutdownRightDac with get, set

Property Value

Type: Max9867TypeSystemShutdownRightDac
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.SystemShutdownLNLEN Property

IRD

Max9867SystemShutdownLNLEN Property

System Shutdown: LNLEN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeSystemShutdownLeftLine SystemShutdownLNLEN { get; set; }
Public Property SystemShutdownLNLEN As Max9867TypeSystemShutdownLeftLine
    Get
    Set
public:
property Max9867TypeSystemShutdownLeftLine SystemShutdownLNLEN {
    Max9867TypeSystemShutdownLeftLine get ();
    void set (Max9867TypeSystemShutdownLeftLine value);
}
member SystemShutdownLNLEN : Max9867TypeSystemShutdownLeftLine with get, set

Property Value

Type: Max9867TypeSystemShutdownLeftLine
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.SystemShutdownLNREN Property

IRD

Max9867SystemShutdownLNREN Property

System Shutdown: LNREN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeSystemShutdownRightLine SystemShutdownLNREN { get; set; }
Public Property SystemShutdownLNREN As Max9867TypeSystemShutdownRightLine
    Get
    Set
public:
property Max9867TypeSystemShutdownRightLine SystemShutdownLNREN {
    Max9867TypeSystemShutdownRightLine get ();
    void set (Max9867TypeSystemShutdownRightLine value);
}
member SystemShutdownLNREN : Max9867TypeSystemShutdownRightLine with get, set

Property Value

Type: Max9867TypeSystemShutdownRightLine
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.SystemShutdownSHDN Property

IRD

Max9867SystemShutdownSHDN Property

System Shutdown: SHDN

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Max9867TypeSystemShutdownShdn SystemShutdownSHDN { get; set; }
Public Property SystemShutdownSHDN As Max9867TypeSystemShutdownShdn
    Get
    Set
public:
property Max9867TypeSystemShutdownShdn SystemShutdownSHDN {
    Max9867TypeSystemShutdownShdn get ();
    void set (Max9867TypeSystemShutdownShdn value);
}
member SystemShutdownSHDN : Max9867TypeSystemShutdownShdn with get, set

Property Value

Type: Max9867TypeSystemShutdownShdn
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867 Methods

The Max9867 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.Flush Method

IRD

Max9867Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Max9867 Class
telos.Ird.Maxim Namespace


Max9867.TypeAdcInputAuxCapture Enumeration

IRD

Max9867TypeAdcInputAuxCapture Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcInputAuxCapture
Public Enumeration TypeAdcInputAuxCapture
public enum class TypeAdcInputAuxCapture
type TypeAdcInputAuxCapture
Members
Member name | Value | Description
UpdateAUXWithVoltageAtJACKSNSAUX | 0 | Update AUX With Voltage At JACKSNS/AUX
HoldAUXForReading | 1 | Hold AUX For Reading
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeAdcInputAuxGain Enumeration

IRD

Max9867TypeAdcInputAuxGain Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcInputAuxGain
Public Enumeration TypeAdcInputAuxGain
public enum class TypeAdcInputAuxGain
type TypeAdcInputAuxGain
Members
Member name | Value | Description
NormalOperation | 0 | Normal Operation
InputBufferIsConnectedToInternalVoltageReference | 1 | Input Buffer Is Connected To Internal Voltage Reference
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeAdcInputAuxInput Enumeration

IRD

Max9867TypeAdcInputAuxInput Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcInputAuxInput
Public Enumeration TypeAdcInputAuxInput
public enum class TypeAdcInputAuxInput
type TypeAdcInputAuxInput
Members
Member name | Value | Description
UseJACKSNSAUXForJackDetection | 0 | Use JACKSNS/AUX For Jack Detection
UseJACKSNSAUXForDCMeasurement | 1 | Use JACKSNS/AUX For DC Measurement
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeAdcInputAuxOffset Enumeration

IRD

Max9867TypeAdcInputAuxOffset Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcInputAuxOffset
Public Enumeration TypeAdcInputAuxOffset
public enum class TypeAdcInputAuxOffset
type TypeAdcInputAuxOffset
Members
Member name | Value | Description
NormalOperation | 0 | Normal Operation
ADCCalibratesInternalOffsetsAutomatically | 1 | ADC Calibrates Internal Offsets Automatically
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeAdcInputMixerLeft Enumeration

IRD

Max9867TypeAdcInputMixerLeft Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcInputMixerLeft
Public Enumeration TypeAdcInputMixerLeft
public enum class TypeAdcInputMixerLeft
type TypeAdcInputMixerLeft
Members
Member name | Value | Description
NoInputSelected | 0 | No Input Selected
LeftInputAnalogMicrophone | 1 | Left Input: Analog Microphone
LeftInputLine | 2 | Left Input: Line
LeftInputAnalogMicrophoneLine | 3 | Left Input: Analog Microphone + Line
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeAdcInputMixerRight Enumeration

IRD

Max9867TypeAdcInputMixerRight Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcInputMixerRight
Public Enumeration TypeAdcInputMixerRight
public enum class TypeAdcInputMixerRight
type TypeAdcInputMixerRight
Members
Member name | Value | Description
NoInputSelected | 0 | No Input Selected
RightInputAnalogMicrophone | 1 | Right Input: Analog Microphone
RightInputLine | 2 | Right Input: Line
RightInputAnalogMicrophoneLine | 3 | Right Input: Analog Microphone + Line
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeAudioClockHighPll Enumeration

IRD

Max9867TypeAudioClockHighPll Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioClockHighPll
Public Enumeration TypeAudioClockHighPll
public enum class TypeAudioClockHighPll
type TypeAudioClockHighPll
Members
Member name | Value | Description
PLLDisabled | 0 | PLL Disabled
PLLEnabled | 1 | PLL Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeAudioInterface1Bci Enumeration

IRD

Max9867TypeAudioInterface1Bci Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface1Bci
Public Enumeration TypeAudioInterface1Bci
public enum class TypeAudioInterface1Bci
type TypeAudioInterface1Bci
Members
Member name | Value | Description
SDINIsLatchedOnRisingEdgeOfBCLK | 0 | SDIN Is Latched On Rising Edge Of BCLK
SDINIsLatchedOnFallingEdgeOfBCLK | 1 | SDIN Is Latched On Falling Edge Of BCLK
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeAudioInterface1Delay Enumeration

IRD

Max9867TypeAudioInterface1Delay Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface1Delay
Public Enumeration TypeAudioInterface1Delay
public enum class TypeAudioInterface1Delay
type TypeAudioInterface1Delay
Members
Member name | Value | Description
SDINSDOUTIsLatchedOnFirstBCLKEdge | 0 | SDIN/SDOUT Is Latched On First BCLK Edge
SDINSDOUTIsLatchedOnSecondBCLKEdge | 1 | SDIN/SDOUT Is Latched On Second BCLK Edge
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeAudioInterface1Impedance Enumeration

IRD

Max9867TypeAudioInterface1Impedance Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface1Impedance
Public Enumeration TypeAudioInterface1Impedance
public enum class TypeAudioInterface1Impedance
type TypeAudioInterface1Impedance
Members
Member name | Value | Description
SDOUTGoesToHighImpedanceAfterBitsHaveBeenTransferred | 0 | SDOUT Goes To High Impedance After Bits Have Been Transferred
SDOUTIsHighOrLowAfterBitsHaveBeenTransferred | 1 | SDOUT Is High Or Low After Bits Have Been Transferred
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeAudioInterface1Master Enumeration

IRD

Max9867TypeAudioInterface1Master Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface1Master
Public Enumeration TypeAudioInterface1Master
public enum class TypeAudioInterface1Master
type TypeAudioInterface1Master
Members
Member name | Value | Description
TheDeviceOperatesInSlaveMode | 0 | The Device Operates In Slave Mode
TheDeviceOperatesInMasterMode | 1 | The Device Operates In Master Mode
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeAudioInterface1TdmMode Enumeration

IRD

Max9867TypeAudioInterface1TdmMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface1TdmMode
Public Enumeration TypeAudioInterface1TdmMode
public enum class TypeAudioInterface1TdmMode
type TypeAudioInterface1TdmMode
Members
Member name | Value | Description
LRCLKIndicatesLeftAndRightAudio | 0 | LRCLK Indicates Left And Right Audio
LRCLKIndicatesTheStartOfAFrame | 1 | LRCLK Indicates The Start Of A Frame
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeAudioInterface1Wci Enumeration

IRD

Max9867TypeAudioInterface1Wci Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface1Wci
Public Enumeration TypeAudioInterface1Wci
public enum class TypeAudioInterface1Wci
type TypeAudioInterface1Wci
Members
Member name | Value | Description
LeftChannelDataIsInputAndOutput | 0 | Left Channel Data Is Input And Output
RightChannelDataIsInputAndOutput | 1 | Right Channel Data Is Input And Output
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeAudioInterface2BclkSelect Enumeration

IRD

Max9867TypeAudioInterface2BclkSelect Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface2BclkSelect
Public Enumeration TypeAudioInterface2BclkSelect
public enum class TypeAudioInterface2BclkSelect
type TypeAudioInterface2BclkSelect
Members
Member name | Value | Description
BCLKSelectOff | 0 | BCLK Select: Off
BCLKSelect64XLRCLK | 1 | BCLK Select: 64 x LRCLK
BCLKSelect48XLRCLK | 2 | BCLK Select: 48 x LRCLK
BCLKSelectPCLK2 | 4 | BCLK Select: PCLK / 2
BCLKSelectPCLK4 | 5 | BCLK Select: PCLK / 4
BCLKSelectPCLK8 | 6 | BCLK Select: PCLK / 8
BCLKSelectPCLK16 | 7 | BCLK Select: PCLK / 16
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeAudioInterface2FixLine Enumeration

IRD

Max9867TypeAudioInterface2FixLine Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface2FixLine
Public Enumeration TypeAudioInterface2FixLine
public enum class TypeAudioInterface2FixLine
type TypeAudioInterface2FixLine
Members
Member name | Value | Description
LineInputTracksVOLLAndVOLRBits | 0 | Line Input Tracks VOLL And VOLR Bits
LineInputFixedAtVOLLAndVOLRBits | 1 | Line Input Fixed At VOLL And VOLR Bits
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeAudioInterface2Mono Enumeration

IRD

Max9867TypeAudioInterface2Mono Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioInterface2Mono
Public Enumeration TypeAudioInterface2Mono
public enum class TypeAudioInterface2Mono
type TypeAudioInterface2Mono
Members
Member name | Value | Description
StereoDataInputIsProcessedSeparately | 0 | Stereo Data Input Is Processed Separately
StereoDataInputIsMixedToSingleChannel | 1 | Stereo Data Input Is Mixed To Single Channel
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeCodecFiltersFilter Enumeration

IRD

Max9867TypeCodecFiltersFilter Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCodecFiltersFilter
Public Enumeration TypeCodecFiltersFilter
public enum class TypeCodecFiltersFilter
type TypeCodecFiltersFilter
Members
Member name | Value | Description
Disabled | 0 | Disabled
EllipticalHighpassFilter16KHzSampleRate256HzCornerFreq | 1 | Elliptical Highpass Filter, 16 kHz Sample Rate, 256 Hz Corner Freq.
ButterworthHighpassFilter16KHzSampleRate500HzCornerFreq | 2 | Butterworth Highpass Filter, 16 kHz Sample Rate, 500 Hz Corner Freq.
EllipticalHighpassFilter8KHzSampleRate256HzCornerFreq | 3 | Elliptical Highpass Filter, 8 kHz Sample Rate, 256 Hz Corner Freq.
ButterworthHighpassFilter8KHzSampleRate500HzCornerFreq | 4 | Butterworth Highpass Filter, 8 kHz Sample Rate, 500 Hz Corner Freq.
ButterworthHighpassFilter824KHzSampleRateFs240HzCornerFreq | 5 | Butterworth Highpass Filter, 8 - 24 kHz Sample Rate, fs/240 Hz Corner Freq.
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeCodecFiltersMode Enumeration

IRD

Max9867TypeCodecFiltersMode Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCodecFiltersMode
Public Enumeration TypeCodecFiltersMode
public enum class TypeCodecFiltersMode
type TypeCodecFiltersMode
Members
Member name | Value | Description
IIRVoiceFilters | 0 | IIR Voice Filters
FIRAudioFilters | 1 | FIR Audio Filters
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeDacLevelGain Enumeration

IRD

Max9867TypeDacLevelGain Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacLevelGain
Public Enumeration TypeDacLevelGain
public enum class TypeDacLevelGain
type TypeDacLevelGain
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_6 | 1 | 6
Value_12 | 2 | 12
Value_18 | 3 | 18
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeDacLevelMute Enumeration

IRD

Max9867TypeDacLevelMute Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacLevelMute
Public Enumeration TypeDacLevelMute
public enum class TypeDacLevelMute
type TypeDacLevelMute
Members
Member name | Value | Description
NoMute | 0 | No Mute
Mute | 1 | Mute
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeGainAmplifier Enumeration

IRD

Max9867TypeGainAmplifier Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGainAmplifier
Public Enumeration TypeGainAmplifier
public enum class TypeGainAmplifier
type TypeGainAmplifier
Members
Member name | Value | Description
Value_20 | 0 | 20
Value_19 | 1 | 19
Value_18 | 2 | 18
Value_17 | 3 | 17
Value_16 | 4 | 16
Value_15 | 5 | 15
Value_14 | 6 | 14
Value_13 | 7 | 13
Value_12 | 8 | 12
Value_11 | 9 | 11
Value_10 | 10 | 10
Value_9 | 11 | 9
Value_8 | 12 | 8
Value_7 | 13 | 7
Value_6 | 14 | 6
Value_5 | 15 | 5
Value_4 | 16 | 4
Value_3 | 17 | 3
Value_2 | 18 | 2
Value_1 | 19 | 1
Value_0 | 20 | 0
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeGainPreamp Enumeration

IRD

Max9867TypeGainPreamp Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGainPreamp
Public Enumeration TypeGainPreamp
public enum class TypeGainPreamp
type TypeGainPreamp
Members
Member name | Value | Description
MicrophonePreamplifierDisabled | 0 | Microphone Preamplifier: Disabled
PreamplifierGain0DB | 1 | Preamplifier Gain: 0 dB
PreamplifierGain20DB | 2 | Preamplifier Gain: 20 dB
PreamplifierGain30DB | 3 | Preamplifier Gain: 30 dB
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeInterruptEnableClipDetect Enumeration

IRD

Max9867TypeInterruptEnableClipDetect Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableClipDetect
Public Enumeration TypeInterruptEnableClipDetect
public enum class TypeInterruptEnableClipDetect
type TypeInterruptEnableClipDetect
Members
Member name | Value | Description
ClipDetectInterruptDisabled | 0 | Clip Detect Interrupt: Disabled
ClipDetectInterruptEnabled | 1 | Clip Detect Interrupt: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeInterruptEnableHeadset Enumeration

IRD

Max9867TypeInterruptEnableHeadset Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableHeadset
Public Enumeration TypeInterruptEnableHeadset
public enum class TypeInterruptEnableHeadset
type TypeInterruptEnableHeadset
Members
Member name | Value | Description
HeadsetConfigurationChangeInterruptDisabled | 0 | Headset Configuration Change Interrupt: Disabled
HeadsetConfigurationChangeInterruptEnabled | 1 | Headset Configuration Change Interrupt: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeInterruptEnablePllUnlock Enumeration

IRD

Max9867TypeInterruptEnablePllUnlock Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnablePllUnlock
Public Enumeration TypeInterruptEnablePllUnlock
public enum class TypeInterruptEnablePllUnlock
type TypeInterruptEnablePllUnlock
Members
Member name | Value | Description
PLLUnlockInterruptDisabled | 0 | PLL Unlock Interrupt: Disabled
PLLUnlockInterruptEnabled | 1 | PLL Unlock Interrupt: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeInterruptEnableSdout Enumeration

IRD

Max9867TypeInterruptEnableSdout Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableSdout
Public Enumeration TypeInterruptEnableSdout
public enum class TypeInterruptEnableSdout
type TypeInterruptEnableSdout
Members
Member name | Value | Description
SDINSDOUTIsLatchedOnFirstBCLKEdge | 0 | SDIN/SDOUT Is Latched On First BCLK Edge
SDINSDOUTIsLatchedOnSecondBCLKEdge | 1 | SDIN/SDOUT Is Latched On Second BCLK Edge
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeInterruptEnableSlewLevel Enumeration

IRD

Max9867TypeInterruptEnableSlewLevel Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptEnableSlewLevel
Public Enumeration TypeInterruptEnableSlewLevel
public enum class TypeInterruptEnableSlewLevel
type TypeInterruptEnableSlewLevel
Members
Member name | Value | Description
SlewLevelInterruptDisabled | 0 | Slew Level Interrupt: Disabled
SlewLevelInterruptEnabled | 1 | Slew Level Interrupt: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeJackSenseJack Enumeration

IRD

Max9867TypeJackSenseJack Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeJackSenseJack
Public Enumeration TypeJackSenseJack
public enum class TypeJackSenseJack
type TypeJackSenseJack
Members
Member name | Value | Description
VoltageAtJACKSNSDoesNotExceedAVDD04V | 0 | Voltage At JACKSNS Does Not Exceed (AVDD - 0.4 V)
VoltageAtJACKSNSExceedsAVDD04V | 1 | Voltage At JACKSNS Exceeds (AVDD - 0.4 V)
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeJackSenseLoutp Enumeration

IRD

Max9867TypeJackSenseLoutp Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeJackSenseLoutp
Public Enumeration TypeJackSenseLoutp
public enum class TypeJackSenseLoutp
type TypeJackSenseLoutp
Members
Member name | Value | Description
VoltageAtLOUTPDoesNotExceedAVDD04V | 0 | Voltage At LOUTP Does Not Exceed (AVDD-0.4V)
VoltageAtLOUTPExceedsAVDD04V | 1 | Voltage At LOUTP Exceeds (AVDD-0.4V)
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeJackSenseMicrophone Enumeration

IRD

Max9867TypeJackSenseMicrophone Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeJackSenseMicrophone
Public Enumeration TypeJackSenseMicrophone
public enum class TypeJackSenseMicrophone
type TypeJackSenseMicrophone
Members
Member name | Value | Description
JACKSNSDoesNotExceed095XVmicbias | 0 | JACKSNS Does Not Exceed 0.95 x Vmicbias
JACKSNSExceeds095XVmicbias | 1 | JACKSNS Exceeds 0.95 x Vmicbias
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeLineMute Enumeration

IRD

Max9867TypeLineMute Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLineMute
Public Enumeration TypeLineMute
public enum class TypeLineMute
type TypeLineMute
Members
Member name | Value | Description
LineInputIsConnectedToHeadphoeAmplifiers | 0 | Line Input Is Connected To Headphoe Amplifiers
LineInputIsDisconnectedFromHeadphoeAmplifiers | 1 | Line Input Is Disconnected From Headphoe Amplifiers
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeMicrophoneClock Enumeration

IRD

Max9867TypeMicrophoneClock Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMicrophoneClock
Public Enumeration TypeMicrophoneClock
public enum class TypeMicrophoneClock
type TypeMicrophoneClock
Members
Member name | Value | Description
DigitalMicrophoneClockPCLK8 | 0 | Digital Microphone Clock: PCLK / 8
DigitalMicrophoneClockPCLK6 | 1 | Digital Microphone Clock: PCLK / 6
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeMicrophoneLeftRight Enumeration

IRD

Max9867TypeMicrophoneLeftRight Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMicrophoneLeftRight
Public Enumeration TypeMicrophoneLeftRight
public enum class TypeMicrophoneLeftRight
type TypeMicrophoneLeftRight
Members
Member name | Value | Description
LeftADCInputMixerRightADCInputMixer | 0 | Left: ADC Input Mixer / Right: ADC Input Mixer
LeftLineInputRightDigitalMicrophone | 1 | Left: Line Input / Right: Digital Microphone
LeftDigitalMicrophoneRightADCInputMixer | 2 | Left: Digital Microphone / Right: ADC Input Mixer
LeftDigitalMicrophoneRightDigitalMicrophone | 3 | Left: Digital Microphone / Right: Digital Microphone
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeModeHeadphone Enumeration

IRD

Max9867TypeModeHeadphone Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeHeadphone
Public Enumeration TypeModeHeadphone
public enum class TypeModeHeadphone
type TypeModeHeadphone
Members
Member name | Value | Description
StereoDifferential | 0 | Stereo Differential
MonoLeftDifferential | 1 | Mono Left Differential
StereoCapacitorless | 2 | Stereo Capacitorless
MonoLeftCapacitorless | 3 | Mono Left Capacitorless
StereoSingleEndedClickless | 4 | Stereo Single-Ended (Clickless)
MonoLeftSingleEndedClickless | 5 | Mono Left Single-Ended (Clickless)
StereoSingleEndedFastTurnOn | 6 | Stereo Single-Ended (Fast Turn-On)
MonoLeftSingleEndedFastTurnOn | 7 | Mono Left Single-Ended (Fast Turn-On)
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeModeJackDetection Enumeration

IRD

Max9867TypeModeJackDetection Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeJackDetection
Public Enumeration TypeModeJackDetection
public enum class TypeModeJackDetection
type TypeModeJackDetection
Members
Member name | Value | Description
JackDetectionDisabled | 0 | Jack Detection Disabled
JackDetectionEnabled | 1 | Jack Detection Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeModeSlewSpeed Enumeration

IRD

Max9867TypeModeSlewSpeed Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeSlewSpeed
Public Enumeration TypeModeSlewSpeed
public enum class TypeModeSlewSpeed
type TypeModeSlewSpeed
Members
Member name | Value | Description
DigitalVolumeChangesAreSlewedOver10Ms | 0 | Digital Volume Changes Are Slewed Over: 10 ms
DigitalVolumeChangesAreSlewedOver80Ms | 1 | Digital Volume Changes Are Slewed Over: 80 ms
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeModeSmoothing Enumeration

IRD

Max9867TypeModeSmoothing Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeSmoothing
Public Enumeration TypeModeSmoothing
public enum class TypeModeSmoothing
type TypeModeSmoothing
Members
Member name | Value | Description
VolumeChangesSlewThroughAllIntermediateValues | 0 | Volume Changes Slew Through All Intermediate Values
VolumeChangesOccurInOneStep | 1 | Volume Changes Occur In One Step
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeModeZeroCrossing Enumeration

IRD

Max9867TypeModeZeroCrossing Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeZeroCrossing
Public Enumeration TypeModeZeroCrossing
public enum class TypeModeZeroCrossing
type TypeModeZeroCrossing
Members
Member name | Value | Description
LineInputVolumeChangesOccurAtZeroCrossings | 0 | Line Input Volume Changes Occur: At Zero Crossings
LineInputVolumeChangesOccurImmediately | 1 | Line Input Volume Changes Occur: Immediately
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeSidetoneMixer Enumeration

IRD

Max9867TypeSidetoneMixer Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSidetoneMixer
Public Enumeration TypeSidetoneMixer
public enum class TypeSidetoneMixer
type TypeSidetoneMixer
Members
Member name | Value | Description
NoSidetoneSelected | 0 | No Sidetone Selected
LeftADC | 1 | Left ADC
RightADC | 2 | Right ADC
LeftRightADC | 3 | Left + Right ADC
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeSidetoneOutput Enumeration

IRD

Max9867TypeSidetoneOutput Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSidetoneOutput
Public Enumeration TypeSidetoneOutput
public enum class TypeSidetoneOutput
type TypeSidetoneOutput
Members
Member name | Value | Description
Off | 0 | Off
Value_0DB | 1 | 0 dB
Value_2DB | 2 | -2 dB
Value_4DB | 3 | -4 dB
Value_6DB | 4 | -6 dB
Value_8DB | 5 | -8 dB
Value_10DB | 6 | -10 dB
Value_12DB | 7 | -12 dB
Value_14DB | 8 | -14 dB
Value_16DB | 9 | -16 dB
Value_18DB | 10 | -18 dB
Value_20DB | 11 | -20 dB
Value_22DB | 12 | -22 dB
Value_24DB | 13 | -24 dB
Value_26DB | 14 | -26 dB
Value_28DB | 15 | -28 dB
Value_30DB | 16 | -30 dB
Value_32DB | 17 | -32 dB
Value_34DB | 18 | -34 dB
Value_36DB | 19 | -36 dB
Value_38DB | 20 | -38 dB
Value_40DB | 21 | -40 dB
Value_42DB | 22 | -42 dB
Value_44DB | 23 | -44 dB
Value_46DB | 24 | -46 dB
Value_48DB | 25 | -48 dB
Value_50DB | 26 | -50 dB
Value_52DB | 27 | -52 dB
Value_54DB | 28 | -54 dB
Value_56DB | 29 | -56 dB
Value_58DB | 30 | -58 dB
Value_60DB | 31 | -60 dB
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeStatusClipDetect Enumeration

IRD

Max9867TypeStatusClipDetect Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusClipDetect
Public Enumeration TypeStatusClipDetect
public enum class TypeStatusClipDetect
type TypeStatusClipDetect
Members
Member name | Value | Description
SignalHasNotReachedFullScaleInADCOrDAC | 0 | Signal Has Not Reached Full Scale In ADC Or DAC
SignalHasReachedOrExceededFullScaleInADCOrDAC | 1 | Signal Has Reached Or Exceeded Full Scale In ADC Or DAC
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeStatusHeadset Enumeration

IRD

Max9867TypeStatusHeadset Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusHeadset
Public Enumeration TypeStatusHeadset
public enum class TypeStatusHeadset
type TypeStatusHeadset
Members
Member name | Value | Description
HeadsetConfigurationNotChanged | 0 | Headset Configuration: Not Changed
HeadsetConfigurationChanged | 1 | Headset Configuration: Changed
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeStatusPllUnlock Enumeration

IRD

Max9867TypeStatusPllUnlock Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusPllUnlock
Public Enumeration TypeStatusPllUnlock
public enum class TypeStatusPllUnlock
type TypeStatusPllUnlock
Members
Member name | Value | Description
DigitalAudioPLLLocked | 0 | Digital Audio PLL: Locked
DigitalAudioPLLUnlocked | 1 | Digital Audio PLL: Unlocked
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeStatusSlewLevel Enumeration

IRD

Max9867TypeStatusSlewLevel Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusSlewLevel
Public Enumeration TypeStatusSlewLevel
public enum class TypeStatusSlewLevel
type TypeStatusSlewLevel
Members
Member name | Value | Description
SlewingHasNotCompleted | 0 | Slewing Has Not Completed
SlewingHasCompleted | 1 | Slewing Has Completed
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeSystemClockFrequency Enumeration

IRD

Max9867TypeSystemClockFrequency Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSystemClockFrequency
Public Enumeration TypeSystemClockFrequency
public enum class TypeSystemClockFrequency
type TypeSystemClockFrequency
Members
Member name | Value | Description
NormalPLLMode | 0 | Normal PLL Mode
PCLK12MHzLRCLK8KHz | 8 | PCLK = 12 MHz, LRCLK = 8 kHz
PCLK12MHzLRCLK16KHz | 9 | PCLK = 12 MHz, LRCLK = 16 kHz
PCLK13MHzLRCLK8KHz | 10 | PCLK = 13 MHz, LRCLK = 8 kHz
PCLK13MHzLRCLK16KHz | 11 | PCLK = 13 MHz, LRCLK = 16 kHz
PCLK16MHzLRCLK8KHz | 12 | PCLK = 16 MHz, LRCLK = 8 kHz
PCLK16MHzLRCLK16KHz | 13 | PCLK = 16 MHz, LRCLK = 16 kHz
PCLK192MHzLRCLK8KHz | 14 | PCLK = 19.2 MHz, LRCLK = 8 kHz
PCLK192MHzLRCLK16KHz | 15 | PCLK = 19.2 MHz, LRCLK = 16 kHz
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeSystemClockPrescaler Enumeration

IRD

Max9867TypeSystemClockPrescaler Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSystemClockPrescaler
Public Enumeration TypeSystemClockPrescaler
public enum class TypeSystemClockPrescaler
type TypeSystemClockPrescaler
Members
Member name | Value | Description
DisableClockForLowPowerShutdown | 0 | Disable Clock For Low-Power Shutdown
Value_10MHzMCLK20MHz | 1 | 10 MHz <= MCLK <= 20 MHz
Value_20MHzMCLK40MHz | 2 | 20 MHz < MCLK <= 40 MHz
Value_40MHzMCLK60MHz | 3 | 40 MHz < MCLK <= 60 MHz
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeSystemShutdownLeftAdc Enumeration

IRD

Max9867TypeSystemShutdownLeftAdc Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSystemShutdownLeftAdc
Public Enumeration TypeSystemShutdownLeftAdc
public enum class TypeSystemShutdownLeftAdc
type TypeSystemShutdownLeftAdc
Members
Member name | Value | Description
LeftADCDisabled | 0 | Left ADC: Disabled
LeftADCEnabled | 1 | Left ADC: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeSystemShutdownLeftDac Enumeration

IRD

Max9867TypeSystemShutdownLeftDac Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSystemShutdownLeftDac
Public Enumeration TypeSystemShutdownLeftDac
public enum class TypeSystemShutdownLeftDac
type TypeSystemShutdownLeftDac
Members
Member name | Value | Description
LeftDACDisabled | 0 | Left DAC: Disabled
LeftDACEnabled | 1 | Left DAC: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeSystemShutdownLeftLine Enumeration

IRD

Max9867TypeSystemShutdownLeftLine Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSystemShutdownLeftLine
Public Enumeration TypeSystemShutdownLeftLine
public enum class TypeSystemShutdownLeftLine
type TypeSystemShutdownLeftLine
Members
Member name | Value | Description
LeftLineInputPreampsDisabled | 0 | Left Line Input Preamps: Disabled
LeftLineInputPreampsEnabled | 1 | Left Line Input Preamps: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeSystemShutdownRightAdc Enumeration

IRD

Max9867TypeSystemShutdownRightAdc Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSystemShutdownRightAdc
Public Enumeration TypeSystemShutdownRightAdc
public enum class TypeSystemShutdownRightAdc
type TypeSystemShutdownRightAdc
Members
Member name | Value | Description
RightADCDisabled | 0 | Right ADC: Disabled
RightADCEnabled | 1 | Right ADC: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeSystemShutdownRightDac Enumeration

IRD

Max9867TypeSystemShutdownRightDac Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSystemShutdownRightDac
Public Enumeration TypeSystemShutdownRightDac
public enum class TypeSystemShutdownRightDac
type TypeSystemShutdownRightDac
Members
Member name | Value | Description
RightDACDisabled | 0 | Right DAC: Disabled
RightDACEnabled | 1 | Right DAC: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeSystemShutdownRightLine Enumeration

IRD

Max9867TypeSystemShutdownRightLine Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSystemShutdownRightLine
Public Enumeration TypeSystemShutdownRightLine
public enum class TypeSystemShutdownRightLine
type TypeSystemShutdownRightLine
Members
Member name | Value | Description
RightLineInputPreampsDisabled | 0 | Right Line Input Preamps: Disabled
RightLineInputPreampsEnabled | 1 | Right Line Input Preamps: Enabled
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeSystemShutdownShdn Enumeration

IRD

Max9867TypeSystemShutdownShdn Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSystemShutdownShdn
Public Enumeration TypeSystemShutdownShdn
public enum class TypeSystemShutdownShdn
type TypeSystemShutdownShdn
Members
Member name | Value | Description
SetDeviceInLowPowerShutdownMode | 0 | Set Device In Low-Power Shutdown Mode
NormalOperation | 1 | Normal Operation
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeVolumeGain Enumeration

IRD

Max9867TypeVolumeGain Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVolumeGain
Public Enumeration TypeVolumeGain
public enum class TypeVolumeGain
type TypeVolumeGain
Members
Member name | Value | Description
Value_60DB | 0 | 6.0 dB
Value_55DB | 1 | 5.5 dB
Value_50DB | 2 | 5.0 dB
Value_45DB | 3 | 4.5 dB
Value_40DB | 4 | 4.0 dB
Value_35DB | 5 | 3.5 dB
Value_30DB | 6 | 3.0 dB
Value_20DB | 7 | 2.0 dB
Value_10DB | 8 | 1.0 dB
Value_0DB | 9 | 0 dB
Value_1DB | 10 | -1 dB
Value_2DB | 11 | -2 dB
Value_3DB | 12 | -3 dB
Value_4DB | 13 | -4 dB
Value_5DB | 14 | -5 dB
Value_6DB | 15 | -6 dB
Value_8DB | 16 | -8 dB
Value_10DB__1 | 17 | -10 dB
Value_12DB | 18 | -12 dB
Value_14DB | 19 | -14 dB
Value_16DB | 20 | -16 dB
Value_18DB | 21 | -18 dB
Value_20DB__1 | 22 | -20 dB
Value_22DB | 23 | -22 dB
Value_26DB | 24 | -26 dB
Value_30DB__1 | 25 | -30 dB
Value_34DB | 26 | -34 dB
Value_38DB | 27 | -38 dB
Value_42DB | 28 | -42 dB
Value_46DB | 29 | -46 dB
Value_50DB__1 | 30 | -50 dB
Value_54DB | 31 | -54 dB
Value_58DB | 32 | -58 dB
Value_62DB | 33 | -62 dB
Value_66DB | 34 | -66 dB
Value_70DB | 35 | -70 dB
Value_74DB | 36 | -74 dB
Value_78DB | 37 | -78 dB
Value_82DB | 38 | -82 dB
Value_84DB | 39 | -84 dB
Mute | 40 | Mute
See Also

Reference

telos.Ird.Maxim Namespace


Max9867.TypeVolumeMute Enumeration

IRD

Max9867TypeVolumeMute Enumeration

Namespace: telos.Ird.Maxim
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVolumeMute
Public Enumeration TypeVolumeMute
public enum class TypeVolumeMute
type TypeVolumeMute
Members
Member name | Value | Description
AudioPlaybackIsUnmuted | 0 | Audio Playback Is Unmuted
AudioPlaybackIsMuted | 1 | Audio Playback Is Muted
See Also

Reference

telos.Ird.Maxim Namespace


telos.Ird.NationalSemiconductor Namespace

Classes
 | Class | Description
Public class | Lm48821 | National Semiconductor: LM 48821
Public class | Lm48823 | National Semiconductor: LM 48823
Public class | Lm48824 | National Semiconductor: LM 48824
Public class | Lm49350 | National Semiconductor: LM 49350
Public class | Lm49450 | National Semiconductor: LM 49450
Public class | Lm63 | National Semiconductor: LM 63
Public class | Lm64 | National Semiconductor: LM 64
Public class | Lm73 | National Semiconductor: LM 73
Public class | Lm75 | National Semiconductor: LM 75
Public class | Lm76 | National Semiconductor: LM 76
Public class | Lm77 | National Semiconductor: LM 77
Public class | Lm82 | National Semiconductor: LM 82
Public class | Lm83 | National Semiconductor: LM 83
Public class | Lm84 | National Semiconductor: LM 84
Public class | Lm85 | National Semiconductor: LM 85
Public class | Lm86 | National Semiconductor: LM 86
Public class | Lm87 | National Semiconductor: LM 87
Public class | Lm89 | National Semiconductor: LM 89
Public class | Lm92 | National Semiconductor: LM 92
Public class | Lm95213 | National Semiconductor: LM 95213
Public class | Lm95214 | National Semiconductor: LM 95214
Public class | Lm95221 | National Semiconductor: LM 95221
Public class | Lm95231 | National Semiconductor: LM 95231
Public class | Lm95233 | National Semiconductor: LM 95233
Public class | Lm95234 | National Semiconductor: LM 95234
Public class | Lm95235 | National Semiconductor: LM 95235
Public class | Lm95241 | National Semiconductor: LM 95241
Public class | Lm95245 | National Semiconductor: LM 95245
Public class | Lm99 | National Semiconductor: LM 99
Public class | Lmv1088 | National Semiconductor: LMV 1088
Public class | Lmv1089 | National Semiconductor: LMV 1089
Enumerations
 | Enumeration | Description
Public enumeration | Lm48821TypeEnableDisable |
Public enumeration | Lm48821TypeVd |
Public enumeration | Lm48823TypeEnableDisable |
Public enumeration | Lm48823TypeVolumne |
Public enumeration | Lm48824TypeHizL |
Public enumeration | Lm48824TypeHizR |
Public enumeration | Lm48824TypeHplEn |
Public enumeration | Lm48824TypeHprEn |
Public enumeration | Lm48824TypeLowThd |
Public enumeration | Lm48824TypeMuteL |
Public enumeration | Lm48824TypeMuteR |
Public enumeration | Lm48824TypeShdn |
Public enumeration | Lm48824TypeThrm |
Public enumeration | Lm48824TypeVol |
Public enumeration | Lm49350TypeAdcEffectsAdcLevel |
Public enumeration | Lm49350TypeAdcEffectsAttackRate |
Public enumeration | Lm49350TypeAdcEffectsClipLevel |
Public enumeration | Lm49350TypeAdcEffectsClipRatio |
Public enumeration | Lm49350TypeAdcEffectsClipThreshold |
Public enumeration | Lm49350TypeAdcEffectsDecayRate |
Public enumeration | Lm49350TypeAdcEffectsEq1Freq |
Public enumeration | Lm49350TypeAdcEffectsEq2Freq |
Public enumeration | Lm49350TypeAdcEffectsEq3Freq |
Public enumeration | Lm49350TypeAdcEffectsEq4Freq |
Public enumeration | Lm49350TypeAdcEffectsEq5Freq |
Public enumeration | Lm49350TypeAdcEffectsEqLevel |
Public enumeration | Lm49350TypeAdcEffectsEqQ |
Public enumeration | Lm49350TypeAdcEffectsHoldTime |
Public enumeration | Lm49350TypeAdcEffectsHpfMode |
Public enumeration | Lm49350TypeAdcEffectsNoiseFloor |
Public enumeration | Lm49350TypeAdcEffectsPkDecayRate |
Public enumeration | Lm49350TypeAdcEffectsSampleRate |
Public enumeration | Lm49350TypeAdcEffectsSourceSel |
Public enumeration | Lm49350TypeAdcEffectsTargetLevel |
Public enumeration | Lm49350TypeAudioPortBasicClockPhase |
Public enumeration | Lm49350TypeAudioPortClockSel |
Public enumeration | Lm49350TypeAudioPortHalfCycleDivider |
Public enumeration | Lm49350TypeAudioPortRxTxMode |
Public enumeration | Lm49350TypeAudioPortRxTxWidth |
Public enumeration | Lm49350TypeAudioPortSyncRate |
Public enumeration | Lm49350TypeAudioPortSyncWidth |
Public enumeration | Lm49350TypeAudioPortSynthDenom |
Public enumeration | Lm49350TypeAudioPortSynthNum |
Public enumeration | Lm49350TypeAudioPortTxExtraBits |
Public enumeration | Lm49350TypeAudioPortUlawAlaw |
Public enumeration | Lm49350TypeAuxLevel |
Public enumeration | Lm49350TypeClkDiv |
Public enumeration | Lm49350TypeClkSel |
Public enumeration | Lm49350TypeDacEffects3dEffectLevel |
Public enumeration | Lm49350TypeDacEffects3dEffectMode |
Public enumeration | Lm49350TypeDacEffects3dFilterType |
Public enumeration | Lm49350TypeDacMode |
Public enumeration | Lm49350TypeDigitalMixerInputLevel |
Public enumeration | Lm49350TypeDigitalMixerLSelDeci |
Public enumeration | Lm49350TypeDigitalMixerLSelPort1 |
Public enumeration | Lm49350TypeDigitalMixerLSelPort2 |
Public enumeration | Lm49350TypeDigitalMixerMxrClkSelDeci |
Public enumeration | Lm49350TypeDigitalMixerRSelDeci |
Public enumeration | Lm49350TypeDigitalMixerRSelPort1 |
Public enumeration | Lm49350TypeDigitalMixerRSelPort2 |
Public enumeration | Lm49350TypeEnabledDisabled |
Public enumeration | Lm49350TypeGpioMode |
Public enumeration | Lm49350TypeMicLevel |
Public enumeration | Lm49350TypeMixerAddedNotAdded |
Public enumeration | Lm49350TypePllClkSel |
Public enumeration | Lm49350TypePllM |
Public enumeration | Lm49350TypePllN |
Public enumeration | Lm49350TypePllNMod |
Public enumeration | Lm49350TypePllP |
Public enumeration | Lm49350TypePmcClocks |
Public enumeration | Lm49350TypePmcSetupChipActive |
Public enumeration | Lm49350TypePmcSetupChipEnable |
Public enumeration | Lm49350TypePmcSetupMclkOvr |
Public enumeration | Lm49350TypePmcSetupOscEnb |
Public enumeration | Lm49350TypePmcSetupPll1Enb |
Public enumeration | Lm49350TypePmcSetupPll2Enb |
Public enumeration | Lm49350TypePmcSetupPortClkOvr |
Public enumeration | Lm49350TypeSetNotSet |
Public enumeration | Lm49450TypeChargePump |
Public enumeration | Lm49450TypeClockDacDitherOff |
Public enumeration | Lm49450TypeClockDacDitherOn |
Public enumeration | Lm49450TypeClockRdiv |
Public enumeration | Lm49450TypeControlComp |
Public enumeration | Lm49450TypeControlDacMode |
Public enumeration | Lm49450TypeControlEnable |
Public enumeration | Lm49450TypeControlExtRef |
Public enumeration | Lm49450TypeControlMute |
Public enumeration | Lm49450TypeControlSs |
Public enumeration | Lm49450TypeHeadphone3dHp3d |
Public enumeration | Lm49450TypeHeadphone3dHp3dattn |
Public enumeration | Lm49450TypeHeadphone3dHp3den |
Public enumeration | Lm49450TypeHeadphone3dHp3dfreq23 |
Public enumeration | Lm49450TypeHeadphone3dHp3dfreq45 |
Public enumeration | Lm49450TypeHeadphoneVolume |
Public enumeration | Lm49450TypeI2sClockClk |
Public enumeration | Lm49450TypeI2sClockClkMs |
Public enumeration | Lm49450TypeI2sClockWs |
Public enumeration | Lm49450TypeI2sClockWsMs |
Public enumeration | Lm49450TypeI2sModeMode |
Public enumeration | Lm49450TypeI2sModeStereoReverse |
Public enumeration | Lm49450TypeI2sModeWordOrder |
Public enumeration | Lm49450TypeI2sModeWrd |
Public enumeration | Lm49450TypeLoudspeaker3dLs3den |
Public enumeration | Lm49450TypeLoudspeakerVolume |
Public enumeration | Lm63TYPIDALERTSTATUSANDMASK10 |
Public enumeration | Lm63TYPIDALERTSTATUSANDMASK11 |
Public enumeration | Lm63TYPIDALERTSTATUSANDMASK12 |
Public enumeration | Lm63TYPIDALERTSTATUSANDMASK13 |
Public enumeration | Lm63TYPIDALERTSTATUSANDMASK14 |
Public enumeration | Lm63TYPIDALERTSTATUSANDMASK15 |
Public enumeration | Lm63TYPIDALERTSTATUSANDMASK16 |
Public enumeration | Lm63TYPIDALERTSTATUSANDMASK20 |
Public enumeration | Lm63TYPIDALERTSTATUSANDMASK21 |
Public enumeration | Lm63TYPIDALERTSTATUSANDMASK22 |
Public enumeration | Lm63TYPIDALERTSTATUSANDMASK23 |
Public enumeration | Lm63TYPIDALERTSTATUSANDMASK24 |
Public enumeration | Lm63TYPIDCONFIGURATIONREGISTER0 |
Public enumeration | Lm63TYPIDCONFIGURATIONREGISTER1 |
Public enumeration | Lm63TYPIDCONFIGURATIONREGISTER2 |
Public enumeration | Lm63TYPIDCONFIGURATIONREGISTER3 |
Public enumeration | Lm63TYPIDCONFIGURATIONREGISTER4 |
Public enumeration | Lm63TYPIDCONFIGURATIONREGISTER5 |
Public enumeration | Lm63TYPIDCONVERSIONRATEREGISTER0 |
Public enumeration | Lm63TYPIDFANCONTROLREGISTERS10 |
Public enumeration | Lm63TYPIDFANCONTROLREGISTERS11 |
Public enumeration | Lm63TYPIDFANCONTROLREGISTERS12 |
Public enumeration | Lm63TYPIDFANCONTROLREGISTERS13 |
Public enumeration | Lm63TYPIDFANCONTROLREGISTERS20 |
Public enumeration | Lm63TYPIDFANCONTROLREGISTERS21 |
Public enumeration | Lm63TYPIDFANCONTROLREGISTERS22 |
Public enumeration | Lm63TYPIDFANPWMFREQUENCY0 |
Public enumeration | Lm63TYPIDREMOTEDIODETEMPPERATUREFILTER0 |
Public enumeration | Lm63TYPIDREMOTEDIODETEMPPERATUREFILTER1 |
Public enumeration | Lm64TYPIDALERTMASK0 |
Public enumeration | Lm64TYPIDALERTMASK1 |
Public enumeration | Lm64TYPIDALERTMASK2 |
Public enumeration | Lm64TYPIDALERTMASK3 |
Public enumeration | Lm64TYPIDALERTMASK4 |
Public enumeration | Lm64TYPIDALERTSTATUS0 |
Public enumeration | Lm64TYPIDALERTSTATUS1 |
Public enumeration | Lm64TYPIDALERTSTATUS2 |
Public enumeration | Lm64TYPIDALERTSTATUS3 |
Public enumeration | Lm64TYPIDALERTSTATUS4 |
Public enumeration | Lm64TYPIDALERTSTATUS5 |
Public enumeration | Lm64TYPIDALERTSTATUS6 |
Public enumeration | Lm64TYPIDCONFIGURATIONREGISTER0 |
Public enumeration | Lm64TYPIDCONFIGURATIONREGISTER1 |
Public enumeration | Lm64TYPIDCONFIGURATIONREGISTER2 |
Public enumeration | Lm64TYPIDCONFIGURATIONREGISTER3 |
Public enumeration | Lm64TYPIDCONVERSIONRATEREGISTER0 |
Public enumeration | Lm64TYPIDFANPWMFREQUENCY0 |
Public enumeration | Lm64TYPIDFANSPINUPCONFIRATIONREGISTER0 |
Public enumeration | Lm64TYPIDFANSPINUPCONFIRATIONREGISTER1 |
Public enumeration | Lm64TYPIDFANSPINUPCONFIRATIONREGISTER2 |
Public enumeration | Lm64TYPIDPWMANDRPMREGISTER0 |
Public enumeration | Lm64TYPIDPWMANDRPMREGISTER1 |
Public enumeration | Lm64TYPIDPWMANDRPMREGISTER2 |
Public enumeration | Lm64TYPIDPWMANDRPMREGISTER3 |
Public enumeration | Lm64TYPIDREMOTEDIODETEMPPERATUREFILTER0 |
Public enumeration | Lm64TYPIDREMOTEDIODETEMPPERATUREFILTER1 |
Public enumeration | Lm73TypeConfigurationAlertEnable |
Public enumeration | Lm73TypeConfigurationAlertPolarity |
Public enumeration | Lm73TypeConfigurationAlertReset |
Public enumeration | Lm73TypeConfigurationFullPowerDown |
Public enumeration | Lm73TypeConfigurationOneShot |
Public enumeration | Lm73TypeControlAlertStatus |
Public enumeration | Lm73TypeControlDataAvailableFlag |
Public enumeration | Lm73TypeControlTemperatureHighFlag |
Public enumeration | Lm73TypeControlTemperatureLowFlag |
Public enumeration | Lm73TypeControlTemperatureResolution |
Public enumeration | Lm73TypeControlTimeOutDisable |
Public enumeration | Lm75ConfigFaultType |
Public enumeration | Lm75ConfigOpModeType |
Public enumeration | Lm75ConfigPolType |
Public enumeration | Lm75ConfigShutdownType |
Public enumeration | Lm76TypeConfigFaultQueue |
Public enumeration | Lm76TypeConfigIntMode |
Public enumeration | Lm76TypeConfigPolarity |
Public enumeration | Lm76TypeConfigShutdown |
Public enumeration | Lm76TypeTriggered |
Public enumeration | Lm77TypeConfigFaultQueue |
Public enumeration | Lm77TypeConfigIntMode |
Public enumeration | Lm77TypeConfigPolarity |
Public enumeration | Lm77TypeConfigShutdown |
Public enumeration | Lm77TypeTriggered |
Public enumeration | Lm82ConfigIntInversionType |
Public enumeration | Lm82ConfigMaskType |
Public enumeration | Lm82StatusOpenType |
Public enumeration | Lm82StatusTcritType |
Public enumeration | Lm82StatusThighType |
Public enumeration | Lm83ConfigIntInvType |
Public enumeration | Lm83ConfigIntMaskType |
Public enumeration | Lm83ConfigTcritaType |
Public enumeration | Lm83Status1OpenType |
Public enumeration | Lm83Status1TcritType |
Public enumeration | Lm83Status1ThighType |
Public enumeration | Lm84ConfigType |
Public enumeration | Lm84StatusOpenType |
Public enumeration | Lm84StatusTcritType |
Public enumeration | Lm85IDEnableDisable |
Public enumeration | Lm85TYPID12V0 |
Public enumeration | Lm85TYPID12VLOWLIMIT0 |
Public enumeration | Lm85TYPID25V0 |
Public enumeration | Lm85TYPID33V0 |
Public enumeration | Lm85TYPID5V0 |
Public enumeration | Lm85TYPIDFAN1CONFIGURATION0 |
Public enumeration | Lm85TYPIDFAN1CONFIGURATION1 |
Public enumeration | Lm85TYPIDFAN1CONFIGURATION2 |
Public enumeration | Lm85TYPIDFAN1CURRENTPWMDUTY0 |
Public enumeration | Lm85TYPIDFAN1RANGEFREQUENCY0 |
Public enumeration | Lm85TYPIDFAN1RANGEFREQUENCY1 |
Public enumeration | Lm85TYPIDFANSPINUPMODE0 |
Public enumeration | Lm85TYPIDINTERRUPTSTATUSREGISTER10 |
Public enumeration | Lm85TYPIDINTERRUPTSTATUSREGISTER14 |
Public enumeration | Lm85TYPIDINTERRUPTSTATUSREGISTER15 |
Public enumeration | Lm85TYPIDINTERRUPTSTATUSREGISTER16 |
Public enumeration | Lm85TYPIDINTERRUPTSTATUSREGISTER17 |
Public enumeration | Lm85TYPIDINTERRUPTSTATUSREGISTER20 |
Public enumeration | Lm85TYPIDINTERRUPTSTATUSREGISTER21 |
Public enumeration | Lm85TYPIDINTERRUPTSTATUSREGISTER22 |
Public enumeration | Lm85TYPIDINTERRUPTSTATUSREGISTER23 |
Public enumeration | Lm85TYPIDINTERRUPTSTATUSREGISTER24 |
Public enumeration | Lm85TYPIDINTERRUPTSTATUSREGISTER25 |
Public enumeration | Lm85TYPIDINTERRUPTSTATUSREGISTER26 |
Public enumeration | Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0 |
Public enumeration | Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2 |
Public enumeration | Lm85TYPIDPROCESSORZONE1TEMP0 |
Public enumeration | Lm85TYPIDREADYLOCKSTARTOVERRIDE0 |
Public enumeration | Lm85TYPIDREADYLOCKSTARTOVERRIDE1 |
Public enumeration | Lm85TYPIDREADYLOCKSTARTOVERRIDE2 |
Public enumeration | Lm85TYPIDREADYLOCKSTARTOVERRIDE3 |
Public enumeration | Lm85TYPIDTACH1LSB0 |
Public enumeration | Lm85TYPIDTACH1MINIMUMLSB0 |
Public enumeration | Lm85TYPIDTACHMONITORMODE0 |
Public enumeration | Lm85TYPIDVCCP0 |
Public enumeration | Lm85TYPIDXORTESTTREEENABLE0 |
Public enumeration | Lm86TypeAlertConfigure |
Public enumeration | Lm86TypeConfigurationAlertMask |
Public enumeration | Lm86TypeConfigurationFaultQueue |
Public enumeration | Lm86TypeConfigurationLocalTCritMask |
Public enumeration | Lm86TypeConfigurationRemoteTCritMask |
Public enumeration | Lm86TypeConfigurationRunStop |
Public enumeration | Lm86TypeConversionRate |
Public enumeration | Lm86TypeFilterLevel |
Public enumeration | Lm86TypeStatusBusy |
Public enumeration | Lm86TypeStatusLcrit |
Public enumeration | Lm86TypeStatusLhigh |
Public enumeration | Lm86TypeStatusLlow |
Public enumeration | Lm86TypeStatusOpen |
Public enumeration | Lm86TypeStatusRcrit |
Public enumeration | Lm86TypeStatusRhigh |
Public enumeration | Lm86TypeStatusRlow |
Public enumeration | Lm87TypeChannelMode25vVccp2D2 |
Public enumeration | Lm87TypeChannelModeFanAin |
Public enumeration | Lm87TypeChannelModeIntVccRange |
Public enumeration | Lm87TypeChannelVidIrq |
Public enumeration | Lm87TypeCiClear |
Public enumeration | Lm87TypeConfigurationClear |
Public enumeration | Lm87TypeConfigurationEnable |
Public enumeration | Lm87TypeConfigurationInitialization |
Public enumeration | Lm87TypeConfigurationReset |
Public enumeration | Lm87TypeConfigurationStart |
Public enumeration | Lm87TypeConfigurationTempLock |
Public enumeration | Lm87TypeConfigurationThermalIntMask |
Public enumeration | Lm87TypeConfigurationThermInterruptMode |
Public enumeration | Lm87TypeFanRpmControl |
Public enumeration | Lm87TypeInterruptMask |
Public enumeration | Lm87TypeInterruptStatusCi |
Public enumeration | Lm87TypeInterruptStatusDFault |
Public enumeration | Lm87TypeInterruptStatusHighLowLimitExceeded |
Public enumeration | Lm87TypeInterruptStatusTherm |
Public enumeration | Lm87TypeSmbalertEnable |
Public enumeration | Lm87TypeTestShutdown |
Public enumeration | Lm89TypeAlertConfigure |
Public enumeration | Lm89TypeConfigurationAlertMask |
Public enumeration | Lm89TypeConfigurationFaultQueue |
Public enumeration | Lm89TypeConfigurationLocalTCritMask |
Public enumeration | Lm89TypeConfigurationRemoteTCritMask |
Public enumeration | Lm89TypeConfigurationRunStop |
Public enumeration | Lm89TypeConversionRate |
Public enumeration | Lm89TypeFilterLevel |
Public enumeration | Lm89TypeStatusBusy |
Public enumeration | Lm89TypeStatusLcrit |
Public enumeration | Lm89TypeStatusLhigh |
Public enumeration | Lm89TypeStatusLlow |
Public enumeration | Lm89TypeStatusOpen |
Public enumeration | Lm89TypeStatusRcrit |
Public enumeration | Lm89TypeStatusRhigh |
Public enumeration | Lm89TypeStatusRlow |
Public enumeration | Lm92TypeConfigFaultQueue |
Public enumeration | Lm92TypeConfigIntMode |
Public enumeration | Lm92TypeConfigPolarity |
Public enumeration | Lm92TypeConfigShutdown |
Public enumeration | Lm92TypeTriggered |
Public enumeration | Lm95213TypeChannelConversionEnable |
Public enumeration | Lm95213TypeCommonStatusBusy |
Public enumeration | Lm95213TypeCommonStatusNr |
Public enumeration | Lm95213TypeCommonStatusSr |
Public enumeration | Lm95213TypeConfigurationStby |
Public enumeration | Lm95213TypeConversionRate |
Public enumeration | Lm95213TypeFilterSetting |
Public enumeration | Lm95213TypeMask |
Public enumeration | Lm95213TypeStatusFault |
Public enumeration | Lm95213TypeStatusTcrit |
Public enumeration | Lm95214TypeChannelConversionEnable |
Public enumeration | Lm95214TypeCommonStatusBusy |
Public enumeration | Lm95214TypeCommonStatusNr |
Public enumeration | Lm95214TypeCommonStatusSr |
Public enumeration | Lm95214TypeConfigurationFaultQueue |
Public enumeration | Lm95214TypeConfigurationStby |
Public enumeration | Lm95214TypeConversionRate |
Public enumeration | Lm95214TypeFilterSetting |
Public enumeration | Lm95214TypeMask |
Public enumeration | Lm95214TypeStatusFault |
Public enumeration | Lm95214TypeStatusTcrit |
Public enumeration | Lm95221TypeConfigurationConversionRate |
Public enumeration | Lm95221TypeConfigurationDataFormat |
Public enumeration | Lm95221TypeConfigurationRunStop |
Public enumeration | Lm95221TypeStatusBusy |
Public enumeration | Lm95221TypeStatusDiodeMissing |
Public enumeration | Lm95231TypeConfigurationConversionRate |
Public enumeration | Lm95231TypeConfigurationDataFormat |
Public enumeration | Lm95231TypeConfigurationRunStop |
Public enumeration | Lm95231TypeRemoteDiodeFilterControl |
Public enumeration | Lm95231TypeRemoteDiodeModelTypeSelect |
Public enumeration | Lm95231TypeRemoteTruthermModeControl |
Public enumeration | Lm95231TypeStatusBusy |
Public enumeration | Lm95231TypeStatusDiodeMissing |
Public enumeration | Lm95231TypeStatusTruthermMode |
Public enumeration | Lm95233TypeChannelConversionEnable |
Public enumeration | Lm95233TypeCommonStatusBusy |
Public enumeration | Lm95233TypeCommonStatusNr |
Public enumeration | Lm95233TypeCommonStatusSr |
Public enumeration | Lm95233TypeConfigurationStby |
Public enumeration | Lm95233TypeConversionRate |
Public enumeration | Lm95233TypeDiodeModelSelect |
Public enumeration | Lm95233TypeDiodeModelStatus |
Public enumeration | Lm95233TypeFilterSetting |
Public enumeration | Lm95233TypeMask |
Public enumeration | Lm95233TypeStatusFault |
Public enumeration | Lm95233TypeStatusTcrit |
Public enumeration | Lm95234TypeChannelConversionEnable |
Public enumeration | Lm95234TypeCommonStatusBusy |
Public enumeration | Lm95234TypeCommonStatusNr |
Public enumeration | Lm95234TypeCommonStatusSr |
Public enumeration | Lm95234TypeConfigurationFaultQueue |
Public enumeration | Lm95234TypeConfigurationStby |
Public enumeration | Lm95234TypeConversionRate |
Public enumeration | Lm95234TypeDiodeModelSelect |
Public enumeration | Lm95234TypeDiodeModelStatus |
Public enumeration | Lm95234TypeFilterSetting |
Public enumeration | Lm95234TypeMask |
Public enumeration | Lm95234TypeStatusFault |
Public enumeration | Lm95234TypeStatusTcrit |
Public enumeration | Lm95235TypeConfigurationOnOff |
Public enumeration | Lm95235TypeConfigurationOsA0FunctionSelect |
Public enumeration | Lm95235TypeConfigurationRemoteDiodeTruthermModeSelect |
Public enumeration | Lm95235TypeConfigurationRemoteFilterEnable |
Public enumeration | Lm95235TypeConfigurationStopRun |
Public enumeration | Lm95235TypeConversionRate |
Public enumeration | Lm95235TypeStatusBusy |
Public enumeration | Lm95235TypeStatusNotReady |
Public enumeration | Lm95235TypeStatusTriggered |
Public enumeration | Lm95235TypeStatusTrutherm3904Detect |
Public enumeration | Lm95241TypeConfigurationConversionRate |
Public enumeration | Lm95241TypeConfigurationDataFormat |
Public enumeration | Lm95241TypeConfigurationRunStop |
Public enumeration | Lm95241TypeRemoteDiodeFilterControl |
Public enumeration | Lm95241TypeRemoteDiodeModelTypeSelect |
Public enumeration | Lm95241TypeRemoteTruthermModeControl |
Public enumeration | Lm95241TypeStatusBusy |
Public enumeration | Lm95241TypeStatusDiodeMissing |
Public enumeration | Lm95241TypeStatusTruthermMode |
Public enumeration | Lm95245TypeConfigurationOnOff |
Public enumeration | Lm95245TypeConfigurationOsA0FunctionSelect |
Public enumeration | Lm95245TypeConfigurationRemoteDiodeTruthermModeSelect |
Public enumeration | Lm95245TypeConfigurationRemoteFilterEnable |
Public enumeration | Lm95245TypeConfigurationStopRun |
Public enumeration | Lm95245TypeConversionRate |
Public enumeration | Lm95245TypeStatusBusy |
Public enumeration | Lm95245TypeStatusNotReady |
Public enumeration | Lm95245TypeStatusTriggered |
Public enumeration | Lm95245TypeStatusTrutherm3904Detect |
Public enumeration | Lm99TypeAlertConfigure |
Public enumeration | Lm99TypeConfigurationAlertMask |
Public enumeration | Lm99TypeConfigurationFaultQueue |
Public enumeration | Lm99TypeConfigurationLocalTCritMask |
Public enumeration | Lm99TypeConfigurationRemoteTCritMask |
Public enumeration | Lm99TypeConfigurationRunStop |
Public enumeration | Lm99TypeConversionRate |
Public enumeration | Lm99TypeFilterLevel |
Public enumeration | Lm99TypeStatusBusy |
Public enumeration | Lm99TypeStatusLcrit |
Public enumeration | Lm99TypeStatusLhigh |
Public enumeration | Lm99TypeStatusLlow |
Public enumeration | Lm99TypeStatusOpen |
Public enumeration | Lm99TypeStatusRcrit |
Public enumeration | Lm99TypeStatusRhigh |
Public enumeration | Lm99TypeStatusRlow |
Public enumeration | Lmv1088TypeAGain |
Public enumeration | Lmv1088TypeAMute |
Public enumeration | Lmv1088TypeBGain |
Public enumeration | Lmv1088TypeBMicSelect |
Public enumeration | Lmv1088TypeEnabledDisabled |
Public enumeration | Lmv1088TypeNReady |
Public enumeration | Lmv1088TypeOGainCompensation |
Public enumeration | Lmv1088TypePGainCompensation |
Public enumeration | Lmv1088TypeQStoreBar |
Public enumeration | Lmv1088TypeRStartCalibration |
Public enumeration | Lmv1089TypeAGain |
Public enumeration | Lmv1089TypeAMute |
Public enumeration | Lmv1089TypeBGain |
Public enumeration | Lmv1089TypeBMicSelect |
Public enumeration | Lmv1089TypeEnabledDisabled |
Public enumeration | Lmv1089TypeNReady |
Public enumeration | Lmv1089TypeOpGainCompensation |
Public enumeration | Lmv1089TypeQStoreBar |
Public enumeration | Lmv1089TypeRStartCalibration |


Lm48821 Class

National Semiconductor: LM 48821
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm48821

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm48821
Public Class Lm48821
public ref class Lm48821
type Lm48821 =  class end

The Lm48821 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm48821 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | LF | LF
Public property | Mute | Mute
Public property | RT | RT
Public property | VolumeControl | Volume Control (unit: dB)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Direct Coupled, Ultra Low Noise, 52mW Differential Input Stereo Headphone Amplifier with I2C Volume Control
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm48821 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48821(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm48821(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm48821

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm48821 Class
telos.Ird.NationalSemiconductor Namespace


Lm48821 Properties

The Lm48821 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | LF | LF
Public property | Mute | Mute
Public property | RT | RT
Public property | VolumeControl | Volume Control (unit: dB)
Top
See Also

Reference

Lm48821 Class
telos.Ird.NationalSemiconductor Namespace


Lm48821.AutoFlush Property

IRD

Lm48821AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm48821 Class
telos.Ird.NationalSemiconductor Namespace


Lm48821.LF Property

IRD

Lm48821LF Property

LF

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48821TypeEnableDisable LF { set; }
Public WriteOnly Property LF As Lm48821TypeEnableDisable
    Set
public:
property Lm48821TypeEnableDisable LF {
    void set (Lm48821TypeEnableDisable value);
}
member LF : Lm48821TypeEnableDisable with set

Property Value

Type: Lm48821TypeEnableDisable
See Also

Reference

Lm48821 Class
telos.Ird.NationalSemiconductor Namespace


Lm48821.Mute Property

IRD

Lm48821Mute Property

Mute

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48821TypeEnableDisable Mute { set; }
Public WriteOnly Property Mute As Lm48821TypeEnableDisable
    Set
public:
property Lm48821TypeEnableDisable Mute {
    void set (Lm48821TypeEnableDisable value);
}
member Mute : Lm48821TypeEnableDisable with set

Property Value

Type: Lm48821TypeEnableDisable
See Also

Reference

Lm48821 Class
telos.Ird.NationalSemiconductor Namespace


Lm48821.RT Property

IRD

Lm48821RT Property

RT

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48821TypeEnableDisable RT { set; }
Public WriteOnly Property RT As Lm48821TypeEnableDisable
    Set
public:
property Lm48821TypeEnableDisable RT {
    void set (Lm48821TypeEnableDisable value);
}
member RT : Lm48821TypeEnableDisable with set

Property Value

Type: Lm48821TypeEnableDisable
See Also

Reference

Lm48821 Class
telos.Ird.NationalSemiconductor Namespace


Lm48821.VolumeControl Property

IRD

Lm48821VolumeControl Property

Volume Control (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48821TypeVd VolumeControl { set; }
Public WriteOnly Property VolumeControl As Lm48821TypeVd
    Set
public:
property Lm48821TypeVd VolumeControl {
    void set (Lm48821TypeVd value);
}
member VolumeControl : Lm48821TypeVd with set

Property Value

Type: Lm48821TypeVd
See Also

Reference

Lm48821 Class
telos.Ird.NationalSemiconductor Namespace


Lm48821 Methods

The Lm48821 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm48821 Class
telos.Ird.NationalSemiconductor Namespace


Lm48821.Flush Method

IRD

Lm48821Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm48821 Class
telos.Ird.NationalSemiconductor Namespace


Lm48821.TypeEnableDisable Enumeration

IRD

Lm48821TypeEnableDisable Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeEnableDisable
Public Enumeration TypeEnableDisable
public enum class TypeEnableDisable
type TypeEnableDisable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm48821.TypeVd Enumeration

IRD

Lm48821TypeVd Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVd
Public Enumeration TypeVd
public enum class TypeVd
type TypeVd
Members
Member name | Value | Description
Value_M_76 | 0 | -76
Value_M_62 | 1 | -62
Value_M_52 | 2 | -52
Value_M_44 | 3 | -44
Value_M_38 | 4 | -38
Value_M_34 | 5 | -34
Value_M_30 | 6 | -30
Value_M_27 | 7 | -27
Value_M_24 | 8 | -24
Value_M_21 | 9 | -21
Value_M_18 | 10 | -18
Value_M_16 | 11 | -16
Value_M_14 | 12 | -14
Value_M_12 | 13 | -12
Value_M_10 | 14 | -10
Value_M_8 | 15 | -8
Value_M_6 | 16 | -6
Value_M_4 | 17 | -4
Value_M_2 | 18 | -2
Value_0 | 19 | 0
Value_2 | 20 | 2
Value_4 | 21 | 4
Value_6 | 22 | 6
Value_8 | 23 | 8
Value_10 | 24 | 10
Value_12 | 25 | 12
Value_13 | 26 | 13
Value_14 | 27 | 14
Value_15 | 28 | 15
Value_16 | 29 | 16
Value_17 | 30 | 17
Value_18 | 31 | 18
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm48823 Class

National Semiconductor: LM 48823
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm48823

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm48823
Public Class Lm48823
public ref class Lm48823
type Lm48823 =  class end

The Lm48823 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm48823 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ENABLEA | ENABLE_A
Public property | ENABLEB | ENABLE_B
Public property | VolumeControl | Volume Control (unit: dB)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Mono, Bridge-Tied Load, Ceramic Speaker Driver with I2C Volume Control and Reset
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm48823 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48823(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm48823(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm48823

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm48823 Class
telos.Ird.NationalSemiconductor Namespace


Lm48823 Properties

The Lm48823 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ENABLEA | ENABLE_A
Public property | ENABLEB | ENABLE_B
Public property | VolumeControl | Volume Control (unit: dB)
Top
See Also

Reference

Lm48823 Class
telos.Ird.NationalSemiconductor Namespace


Lm48823.AutoFlush Property

IRD

Lm48823AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm48823 Class
telos.Ird.NationalSemiconductor Namespace


Lm48823.ENABLEA Property

IRD

Lm48823ENABLEA Property

ENABLE_A

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48823TypeEnableDisable ENABLEA { set; }
Public WriteOnly Property ENABLEA As Lm48823TypeEnableDisable
    Set
public:
property Lm48823TypeEnableDisable ENABLEA {
    void set (Lm48823TypeEnableDisable value);
}
member ENABLEA : Lm48823TypeEnableDisable with set

Property Value

Type: Lm48823TypeEnableDisable
See Also

Reference

Lm48823 Class
telos.Ird.NationalSemiconductor Namespace


Lm48823.ENABLEB Property

IRD

Lm48823ENABLEB Property

ENABLE_B

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48823TypeEnableDisable ENABLEB { set; }
Public WriteOnly Property ENABLEB As Lm48823TypeEnableDisable
    Set
public:
property Lm48823TypeEnableDisable ENABLEB {
    void set (Lm48823TypeEnableDisable value);
}
member ENABLEB : Lm48823TypeEnableDisable with set

Property Value

Type: Lm48823TypeEnableDisable
See Also

Reference

Lm48823 Class
telos.Ird.NationalSemiconductor Namespace


Lm48823.VolumeControl Property

IRD

Lm48823VolumeControl Property

Volume Control (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48823TypeVolumne VolumeControl { set; }
Public WriteOnly Property VolumeControl As Lm48823TypeVolumne
    Set
public:
property Lm48823TypeVolumne VolumeControl {
    void set (Lm48823TypeVolumne value);
}
member VolumeControl : Lm48823TypeVolumne with set

Property Value

Type: Lm48823TypeVolumne
See Also

Reference

Lm48823 Class
telos.Ird.NationalSemiconductor Namespace


Lm48823 Methods

The Lm48823 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm48823 Class
telos.Ird.NationalSemiconductor Namespace


Lm48823.Flush Method

IRD

Lm48823Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm48823 Class
telos.Ird.NationalSemiconductor Namespace


Lm48823.TypeEnableDisable Enumeration

IRD

Lm48823TypeEnableDisable Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeEnableDisable
Public Enumeration TypeEnableDisable
public enum class TypeEnableDisable
type TypeEnableDisable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm48823.TypeVolumne Enumeration

IRD

Lm48823TypeVolumne Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVolumne
Public Enumeration TypeVolumne
public enum class TypeVolumne
type TypeVolumne
Members
Member name | Value | Description
Value_M_70 | 0 | -70
Value_M_56 | 1 | -56
Value_M_46 | 2 | -46
Value_M_38 | 3 | -38
Value_M_32 | 4 | -32
Value_M_28 | 5 | -28
Value_M_24 | 6 | -24
Value_M_21 | 7 | -21
Value_M_18 | 8 | -18
Value_M_15 | 9 | -15
Value_M_12 | 10 | -12
Value_M_10 | 11 | -10
Value_M_8 | 12 | -8
Value_M_6 | 13 | -6
Value_M_4 | 14 | -4
Value_M_2 | 15 | -2
Value_0 | 16 | 0
Value_2 | 17 | 2
Value_4 | 18 | 4
Value_6 | 19 | 6
Value_8 | 20 | 8
Value_10 | 21 | 10
Value_12 | 22 | 12
Value_16 | 23 | 16
Value_14 | 24 | 14
Value_15 | 25 | 15
Value_16__1 | 26 | 16
Value_17 | 27 | 17
Value_18 | 28 | 18
Value_22 | 29 | 22
Value_23 | 30 | 23
Value_24 | 31 | 24
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm48824 Class

National Semiconductor: LM 48824
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm48824

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm48824
Public Class Lm48824
public ref class Lm48824
type Lm48824 =  class end

The Lm48824 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm48824 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DeviceInformation | Device Information
Public property | ModeControlHPLEN | Mode Control (HPL_EN)
Public property | ModeControlHPREN | Mode Control (HPR_EN)
Public property | ModeControlSHDN | Mode Control (SHDN)
Public property | ModeControlTHRM | Mode Control (THRM)
Public property | OutputControlHiZL | Output Control (HiZ_L)
Public property | OutputControlHiZR | Output Control (HiZ_R)
Public property | OutputControlLOWTHD | Output Control (LOW_THD)
Public property | VolumeControlMUTEL | Volume Control (MUTE_L)
Public property | VolumeControlMUTER | Volume Control (MUTE_R)
Public property | VolumeControlVOL | Volume Control (VOL) (unit: dB)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Class G Headphone Amplifier with I2C Volume Control
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm48824 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48824(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm48824(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm48824

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm48824 Class
telos.Ird.NationalSemiconductor Namespace


Lm48824 Properties

The Lm48824 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DeviceInformation | Device Information
Public property | ModeControlHPLEN | Mode Control (HPL_EN)
Public property | ModeControlHPREN | Mode Control (HPR_EN)
Public property | ModeControlSHDN | Mode Control (SHDN)
Public property | ModeControlTHRM | Mode Control (THRM)
Public property | OutputControlHiZL | Output Control (HiZ_L)
Public property | OutputControlHiZR | Output Control (HiZ_R)
Public property | OutputControlLOWTHD | Output Control (LOW_THD)
Public property | VolumeControlMUTEL | Volume Control (MUTE_L)
Public property | VolumeControlMUTER | Volume Control (MUTE_R)
Public property | VolumeControlVOL | Volume Control (VOL) (unit: dB)
Top
See Also

Reference

Lm48824 Class
telos.Ird.NationalSemiconductor Namespace


Lm48824.AutoFlush Property

IRD

Lm48824AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm48824 Class
telos.Ird.NationalSemiconductor Namespace


Lm48824.DeviceInformation Property

IRD

Lm48824DeviceInformation Property

Device Information

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceInformation { get; }
Public ReadOnly Property DeviceInformation As Byte
    Get
public:
property unsigned char DeviceInformation {
    unsigned char get ();
}
member DeviceInformation : byte with get

Property Value

Type: Byte
See Also

Reference

Lm48824 Class
telos.Ird.NationalSemiconductor Namespace


Lm48824.ModeControlHPLEN Property

IRD

Lm48824ModeControlHPLEN Property

Mode Control (HPL_EN)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48824TypeHplEn ModeControlHPLEN { get; set; }
Public Property ModeControlHPLEN As Lm48824TypeHplEn
    Get
    Set
public:
property Lm48824TypeHplEn ModeControlHPLEN {
    Lm48824TypeHplEn get ();
    void set (Lm48824TypeHplEn value);
}
member ModeControlHPLEN : Lm48824TypeHplEn with get, set

Property Value

Type: Lm48824TypeHplEn
See Also

Reference

Lm48824 Class
telos.Ird.NationalSemiconductor Namespace


Lm48824.ModeControlHPREN Property

IRD

Lm48824ModeControlHPREN Property

Mode Control (HPR_EN)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48824TypeHprEn ModeControlHPREN { get; set; }
Public Property ModeControlHPREN As Lm48824TypeHprEn
    Get
    Set
public:
property Lm48824TypeHprEn ModeControlHPREN {
    Lm48824TypeHprEn get ();
    void set (Lm48824TypeHprEn value);
}
member ModeControlHPREN : Lm48824TypeHprEn with get, set

Property Value

Type: Lm48824TypeHprEn
See Also

Reference

Lm48824 Class
telos.Ird.NationalSemiconductor Namespace


Lm48824.ModeControlSHDN Property

IRD

Lm48824ModeControlSHDN Property

Mode Control (SHDN)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48824TypeShdn ModeControlSHDN { get; set; }
Public Property ModeControlSHDN As Lm48824TypeShdn
    Get
    Set
public:
property Lm48824TypeShdn ModeControlSHDN {
    Lm48824TypeShdn get ();
    void set (Lm48824TypeShdn value);
}
member ModeControlSHDN : Lm48824TypeShdn with get, set

Property Value

Type: Lm48824TypeShdn
See Also

Reference

Lm48824 Class
telos.Ird.NationalSemiconductor Namespace


Lm48824.ModeControlTHRM Property

IRD

Lm48824ModeControlTHRM Property

Mode Control (THRM)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48824TypeThrm ModeControlTHRM { get; set; }
Public Property ModeControlTHRM As Lm48824TypeThrm
    Get
    Set
public:
property Lm48824TypeThrm ModeControlTHRM {
    Lm48824TypeThrm get ();
    void set (Lm48824TypeThrm value);
}
member ModeControlTHRM : Lm48824TypeThrm with get, set

Property Value

Type: Lm48824TypeThrm
See Also

Reference

Lm48824 Class
telos.Ird.NationalSemiconductor Namespace


Lm48824.OutputControlHiZL Property

IRD

Lm48824OutputControlHiZL Property

Output Control (HiZ_L)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48824TypeHizL OutputControlHiZL { get; set; }
Public Property OutputControlHiZL As Lm48824TypeHizL
    Get
    Set
public:
property Lm48824TypeHizL OutputControlHiZL {
    Lm48824TypeHizL get ();
    void set (Lm48824TypeHizL value);
}
member OutputControlHiZL : Lm48824TypeHizL with get, set

Property Value

Type: Lm48824TypeHizL
See Also

Reference

Lm48824 Class
telos.Ird.NationalSemiconductor Namespace


Lm48824.OutputControlHiZR Property

IRD

Lm48824OutputControlHiZR Property

Output Control (HiZ_R)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48824TypeHizR OutputControlHiZR { get; set; }
Public Property OutputControlHiZR As Lm48824TypeHizR
    Get
    Set
public:
property Lm48824TypeHizR OutputControlHiZR {
    Lm48824TypeHizR get ();
    void set (Lm48824TypeHizR value);
}
member OutputControlHiZR : Lm48824TypeHizR with get, set

Property Value

Type: Lm48824TypeHizR
See Also

Reference

Lm48824 Class
telos.Ird.NationalSemiconductor Namespace


Lm48824.OutputControlLOWTHD Property

IRD

Lm48824OutputControlLOWTHD Property

Output Control (LOW_THD)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48824TypeLowThd OutputControlLOWTHD { get; set; }
Public Property OutputControlLOWTHD As Lm48824TypeLowThd
    Get
    Set
public:
property Lm48824TypeLowThd OutputControlLOWTHD {
    Lm48824TypeLowThd get ();
    void set (Lm48824TypeLowThd value);
}
member OutputControlLOWTHD : Lm48824TypeLowThd with get, set

Property Value

Type: Lm48824TypeLowThd
See Also

Reference

Lm48824 Class
telos.Ird.NationalSemiconductor Namespace


Lm48824.VolumeControlMUTEL Property

IRD

Lm48824VolumeControlMUTEL Property

Volume Control (MUTE_L)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48824TypeMuteL VolumeControlMUTEL { get; set; }
Public Property VolumeControlMUTEL As Lm48824TypeMuteL
    Get
    Set
public:
property Lm48824TypeMuteL VolumeControlMUTEL {
    Lm48824TypeMuteL get ();
    void set (Lm48824TypeMuteL value);
}
member VolumeControlMUTEL : Lm48824TypeMuteL with get, set

Property Value

Type: Lm48824TypeMuteL
See Also

Reference

Lm48824 Class
telos.Ird.NationalSemiconductor Namespace


Lm48824.VolumeControlMUTER Property

IRD

Lm48824VolumeControlMUTER Property

Volume Control (MUTE_R)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48824TypeMuteR VolumeControlMUTER { get; set; }
Public Property VolumeControlMUTER As Lm48824TypeMuteR
    Get
    Set
public:
property Lm48824TypeMuteR VolumeControlMUTER {
    Lm48824TypeMuteR get ();
    void set (Lm48824TypeMuteR value);
}
member VolumeControlMUTER : Lm48824TypeMuteR with get, set

Property Value

Type: Lm48824TypeMuteR
See Also

Reference

Lm48824 Class
telos.Ird.NationalSemiconductor Namespace


Lm48824.VolumeControlVOL Property

IRD

Lm48824VolumeControlVOL Property

Volume Control (VOL) (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm48824TypeVol VolumeControlVOL { get; set; }
Public Property VolumeControlVOL As Lm48824TypeVol
    Get
    Set
public:
property Lm48824TypeVol VolumeControlVOL {
    Lm48824TypeVol get ();
    void set (Lm48824TypeVol value);
}
member VolumeControlVOL : Lm48824TypeVol with get, set

Property Value

Type: Lm48824TypeVol
See Also

Reference

Lm48824 Class
telos.Ird.NationalSemiconductor Namespace


Lm48824 Methods

The Lm48824 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm48824 Class
telos.Ird.NationalSemiconductor Namespace


Lm48824.Flush Method

IRD

Lm48824Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm48824 Class
telos.Ird.NationalSemiconductor Namespace


Lm48824.TypeHizL Enumeration

IRD

Lm48824TypeHizL Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHizL
Public Enumeration TypeHizL
public enum class TypeHizL
type TypeHizL
Members
Member name | Value | Description
LeftChannelHighImpedanceModeDisabled | 0 | Left Channel High Impedance Mode: Disabled
LeftChannelHighImpedanceModeEnabled | 1 | Left Channel High Impedance Mode: Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm48824.TypeHizR Enumeration

IRD

Lm48824TypeHizR Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHizR
Public Enumeration TypeHizR
public enum class TypeHizR
type TypeHizR
Members
Member name | Value | Description
RightChannelHighImpedanceModeDisabled | 0 | Right Channel High Impedance Mode: Disabled
RightChannelHighImpedanceModeEnabled | 1 | Right Channel High Impedance Mode: Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm48824.TypeHplEn Enumeration

IRD

Lm48824TypeHplEn Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHplEn
Public Enumeration TypeHplEn
public enum class TypeHplEn
type TypeHplEn
Members
Member name | Value | Description
LeftChannelAmplifierDisabled | 0 | Left Channel Amplifier: Disabled
LeftChannelAmplifierEnabled | 1 | Left Channel Amplifier: Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm48824.TypeHprEn Enumeration

IRD

Lm48824TypeHprEn Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHprEn
Public Enumeration TypeHprEn
public enum class TypeHprEn
type TypeHprEn
Members
Member name | Value | Description
RightChannelAmplifierDisabled | 0 | Right Channel Amplifier: Disabled
RightChannelAmplifierEnabled | 1 | Right Channel Amplifier: Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm48824.TypeLowThd Enumeration

IRD

Lm48824TypeLowThd Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLowThd
Public Enumeration TypeLowThd
public enum class TypeLowThd
type TypeLowThd
Members
Member name | Value | Description
LOWTHDModeDisabled | 0 | LOW_THD Mode: Disabled
LOWTHDModeEnabled | 1 | LOW_THD Mode: Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm48824.TypeMuteL Enumeration

IRD

Lm48824TypeMuteL Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMuteL
Public Enumeration TypeMuteL
public enum class TypeMuteL
type TypeMuteL
Members
Member name | Value | Description
LeftChannelMuteDisabled | 0 | Left Channel Mute: Disabled
LeftChannelMuteEnabled | 1 | Left Channel Mute: Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm48824.TypeMuteR Enumeration

IRD

Lm48824TypeMuteR Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMuteR
Public Enumeration TypeMuteR
public enum class TypeMuteR
type TypeMuteR
Members
Member name | Value | Description
RightChannelMuteDisabled | 0 | Right Channel Mute: Disabled
RightChannelMuteEnabled | 1 | Right Channel Mute: Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm48824.TypeShdn Enumeration

IRD

Lm48824TypeShdn Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeShdn
Public Enumeration TypeShdn
public enum class TypeShdn
type TypeShdn
Members
Member name | Value | Description
DeviceEnabled | 0 | Device: Enabled
DeviceDisabled | 1 | Device: Disabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm48824.TypeThrm Enumeration

IRD

Lm48824TypeThrm Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeThrm
Public Enumeration TypeThrm
public enum class TypeThrm
type TypeThrm
Members
Member name | Value | Description
ThermalProtectionInactive | 0 | Thermal-Protection: Inactive
ThermalProtectionActive | 1 | Thermal-Protection: Active
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm48824.TypeVol Enumeration

IRD

Lm48824TypeVol Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVol
Public Enumeration TypeVol
public enum class TypeVol
type TypeVol
Members
Member name | Value | Description
Value_M_59 | 0 | -59
Value_M_55 | 1 | -55
Value_M_51 | 2 | -51
Value_M_47 | 3 | -47
Value_M_43 | 4 | -43
Value_M_39 | 5 | -39
Value_M_35 | 6 | -35
Value_M_31 | 7 | -31
Value_M_27 | 8 | -27
Value_M_25 | 9 | -25
Value_M_23 | 10 | -23
Value_M_21 | 11 | -21
Value_M_19 | 12 | -19
Value_M_17 | 13 | -17
Value_M_15 | 14 | -15
Value_M_13 | 15 | -13
Value_M_11 | 16 | -11
Value_M_10 | 17 | -10
Value_M_9 | 18 | -9
Value_M_8 | 19 | -8
Value_M_7 | 20 | -7
Value_M_6 | 21 | -6
Value_M_5 | 22 | -5
Value_M_4 | 23 | -4
Value_M_3 | 24 | -3
Value_M_2 | 25 | -2
Value_M_1 | 26 | -1
Value_0 | 27 | 0
Value_1 | 28 | 1
Value_2 | 29 | 2
Value_3 | 30 | 3
Value_4 | 31 | 4
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350 Class

National Semiconductor: LM 49350
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm49350

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm49350
Public Class Lm49350
public ref class Lm49350
type Lm49350 =  class end

The Lm49350 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm49350 | Constructor
Top
Properties
 | Name | Description
Public property | ADCADCCLKDIV | ADC: ADC_CLK_DIV
Public property | ADCADCCLKSEL | ADC: ADC_CLK_SEL
Public property | ADCADCDSPONLY | ADC: ADC_DSP_ONLY
Public property | ADCADCTRIM | ADC: ADC_TRIM
Public property | ADCCompensationFilterADCC0 | ADC Compensation Filter: ADC_C0
Public property | ADCCompensationFilterADCC1 | ADC Compensation Filter: ADC_C1
Public property | ADCCompensationFilterADCC2 | ADC Compensation Filter: ADC_C2
Public property | ADCCompensationFilterAUXLINEOUT | ADC Compensation Filter: AUX_LINE_OUT
Public property | ADCEffectMonitorsADCLCLIP | ADC Effect Monitors: ADC_L_CLIP
Public property | ADCEffectMonitorsADCRCLIP | ADC Effect Monitors: ADC_R_CLIP
Public property | ADCEffectMonitorsALCMONL | ADC Effect Monitors: ALCMONL
Public property | ADCEffectMonitorsALCMONR | ADC Effect Monitors: ALCMONR
Public property | ADCEffectMonitorsEQLCLIP | ADC Effect Monitors: EQ_L_CLIP
Public property | ADCEffectMonitorsEQRCLIP | ADC Effect Monitors: EQ_R_CLIP
Public property | ADCEffectMonitorsGAINLCLIP | ADC Effect Monitors: GAIN_L_CLIP
Public property | ADCEffectMonitorsGAINRCLIP | ADC Effect Monitors: GAIN_R_CLIP
Public property | ADCEffectMonitorsLVLMONL | ADC Effect Monitors: LVLMONL
Public property | ADCEffectMonitorsLVLMONR | ADC Effect Monitors: LVLMONR
Public property | ADCEffectMonitorsSCLPLCLIP | ADC Effect Monitors: SCLP_L_CLIP
Public property | ADCEffectMonitorsSCLPLDISTORTALCMONL | ADC Effect Monitors: SCLP_L_DISTORT (ALCMONL)
Public property | ADCEffectMonitorsSCLPLDISTORTALCMONR | ADC Effect Monitors: SCLP_L_DISTORT (ALCMONR)
Public property | ADCEffectMonitorsSCLPRCLIP | ADC Effect Monitors: SCLP_R_CLIP
Public property | ADCEffectMonitorsSCLPRDISTORTALCMONL | ADC Effect Monitors: SCLP_R_DISTORT (ALCMONL)
Public property | ADCEffectMonitorsSCLPRDISTORTALCMONR | ADC Effect Monitors: SCLP_R_DISTORT (ALCMONR)
Public property | ADCEffectsADCLLEVEL | ADC Effects: ADC_L_LEVEL (unit: dB)
Public property | ADCEffectsADCRLEVEL | ADC Effects: ADC_R_LEVEL (unit: dB)
Public property | ADCEffectsATTACKRATE | ADC Effects: ATTACK_RATE (unit: μs)
Public property | ADCEffectsDECAYRATE | ADC Effects: DECAY_RATE (unit: μs)
Public property | ADCEffectsEQBAND1FREQ | ADC Effects: EQ_BAND_1 (FREQ) (unit: Hz)
Public property | ADCEffectsEQBAND1LEVEL | ADC Effects: EQ_BAND_1 (LEVEL) (unit: dB)
Public property | ADCEffectsEQBAND2FREQ | ADC Effects: EQ_BAND_2 (FREQ) (unit: Hz)
Public property | ADCEffectsEQBAND2LEVEL | ADC Effects: EQ_BAND_2 (LEVEL) (unit: dB)
Public property | ADCEffectsEQBAND2Q | ADC Effects: EQ_BAND_2 (Q) (unit: Octave)
Public property | ADCEffectsEQBAND3FREQ | ADC Effects: EQ_BAND_3 (FREQ) (unit: Hz)
Public property | ADCEffectsEQBAND3LEVEL | ADC Effects: EQ_BAND_3 (LEVEL) (unit: dB)
Public property | ADCEffectsEQBAND3Q | ADC Effects: EQ_BAND_3 (Q) (unit: Octave)
Public property | ADCEffectsEQBAND4FREQ | ADC Effects: EQ_BAND_4 (FREQ) (unit: kHz)
Public property | ADCEffectsEQBAND4LEVEL | ADC Effects: EQ_BAND_4 (LEVEL) (unit: dB)
Public property | ADCEffectsEQBAND4Q | ADC Effects: EQ_BAND_4 (Q) (unit: Octave)
Public property | ADCEffectsEQBAND5FREQ | ADC Effects: EQ_BAND_5 (FREQ) (unit: kHz)
Public property | ADCEffectsEQBAND5LEVEL | ADC Effects: EQ_BAND_5 (LEVEL) (unit: dB)
Public property | ADCEffectsHOLDTIME | ADC Effects: HOLD_TIME (unit: ms)
Public property | ADCEffectsHPFMODE | ADC Effects: HPF_MODE
Public property | ADCEffectsLEVEL | ADC Effects: LEVEL (unit: dB)
Public property | ADCEffectsLIMITER | ADC Effects: LIMITER
Public property | ADCEffectsMAXLEVEL | ADC Effects: MAX_LEVEL
Public property | ADCEffectsMINLEVEL | ADC Effects: MIN_LEVEL
Public property | ADCEffectsNGENB | ADC Effects: NG_ENB
Public property | ADCEffectsNOISEFLOOR | ADC Effects: NOISE_FLOOR (unit: dB)
Public property | ADCEffectsPKDECAYRATE | ADC Effects: PK_DECAY_RATE (unit: ms)
Public property | ADCEffectsRATIO | ADC Effects: RATIO
Public property | ADCEffectsSAMPLERATE | ADC Effects: SAMPLE_RATE (unit: kHz)
Public property | ADCEffectsSOFTKNEE | ADC Effects: SOFT_KNEE
Public property | ADCEffectsSOURCEOVR | ADC Effects: SOURCE_OVR
Public property | ADCEffectsSOURCESEL | ADC Effects: SOURCE_SEL
Public property | ADCEffectsSTEREOLINK | ADC Effects: STEREO_LINK
Public property | ADCEffectsTARGETLEVEL | ADC Effects: TARGET_LEVEL (unit: dB)
Public property | ADCEffectsTHRESHOLD | ADC Effects: THRESHOLD (unit: dB)
Public property | ADCMONO | ADC: MONO
Public property | ADCMUTEL | ADC: MUTE_L
Public property | ADCMUTER | ADC: MUTE_R
Public property | ADCOSR | ADC: OSR
Public property | AnalogMixerAUX6dB | Analog Mixer: AUX-6dB
Public property | AnalogMixerAUXLADCL | Analog Mixer: AUXL_ADCL
Public property | AnalogMixerAUXLAX | Analog Mixer: AUXL_AX
Public property | AnalogMixerAUXLHPL | Analog Mixer: AUXL_HPL
Public property | AnalogMixerAUXLHPR | Analog Mixer: AUXL_HPR
Public property | AnalogMixerAUXLLEVEL | Analog Mixer: AUX_L_LEVEL (unit: dB)
Public property | AnalogMixerAUXLLS | Analog Mixer: AUXL_LS
Public property | AnalogMixerAUXRADCR | Analog Mixer: AUXR_ADCR
Public property | AnalogMixerAUXRAX | Analog Mixer: AUXR_AX
Public property | AnalogMixerAUXRHPL | Analog Mixer: AUXR_HPL
Public property | AnalogMixerAUXRHPR | Analog Mixer: AUXR_HPR
Public property | AnalogMixerAUXRLEVEL | Analog Mixer: AUX_R_LEVEL (unit: dB)
Public property | AnalogMixerAUXRLS | Analog Mixer: AUXR_LS
Public property | AnalogMixerCPFORCE | Analog Mixer: CP_FORCE
Public property | AnalogMixerDACLADCL | Analog Mixer: DACL_ADCL
Public property | AnalogMixerDACLAX | Analog Mixer: DACL_AX
Public property | AnalogMixerDACLHPL | Analog Mixer: DACL_HPL
Public property | AnalogMixerDACLHPR | Analog Mixer: DACL_HPR
Public property | AnalogMixerDACLLS | Analog Mixer: DACL_LS
Public property | AnalogMixerDACRADCR | Analog Mixer: DACR_ADCR
Public property | AnalogMixerDACRAX | Analog Mixer: DACR_AX
Public property | AnalogMixerDACRHPL | Analog Mixer: DACR_HPL
Public property | AnalogMixerDACRHPR | Analog Mixer: DACR_HPR
Public property | AnalogMixerDACRLS | Analog Mixer: DACR_LS
Public property | AnalogMixerDIFFMODE | Analog Mixer: DIFF_MODE
Public property | AnalogMixerEPMODE | Analog Mixer: EPMODE
Public property | AnalogMixerFROMLINEL | Analog Mixer: FROM_LINE_L
Public property | AnalogMixerFROMLINER | Analog Mixer: FROM_LINE_R
Public property | AnalogMixerHP6dB | Analog Mixer: HP-6dB
Public property | AnalogMixerLS6dB | Analog Mixer: LS-6dB
Public property | AnalogMixerMICLADCL | Analog Mixer: MICL_ADCL
Public property | AnalogMixerMICLAX | Analog Mixer: MICL_AX
Public property | AnalogMixerMICLHPL | Analog Mixer: MICL_HPL
Public property | AnalogMixerMICLHPR | Analog Mixer: MICL_HPR
Public property | AnalogMixerMICLLEVEL | Analog Mixer: MIC_L_LEVEL (unit: dB)
Public property | AnalogMixerMICLLS | Analog Mixer: MICL_LS
Public property | AnalogMixerMICRADCR | Analog Mixer: MICR_ADCR
Public property | AnalogMixerMICRAX | Analog Mixer: MICR_ AX
Public property | AnalogMixerMICRHPL | Analog Mixer: MICR_HPL
Public property | AnalogMixerMICRHPR | Analog Mixer: MICR_HPR
Public property | AnalogMixerMICRLEVEL | Analog Mixer: MIC_R_LEVEL (unit: dB)
Public property | AnalogMixerMICRLS | Analog Mixer: MICR_LS
Public property | AnalogMixerMUTEMICL | Analog Mixer: MUTE (MICL)
Public property | AnalogMixerMUTEMICR | Analog Mixer: MUTE (MICR)
Public property | AnalogMixerSEDIFFMICL | Analog Mixer: SE_DIFF (MICL)
Public property | AnalogMixerSEDIFFMICR | Analog Mixer: SE_DIFF (MICR)
Public property | AudioPort1CLKMS | Audio Port 1: CLK_MS
Public property | AudioPort1CLKPH | Audio Port 1: CLK_PH
Public property | AudioPort1CLOCKSEL | Audio Port 1: CLOCK_SEL
Public property | AudioPort1COMPANDRX | Audio Port 1: COMPAND (RX)
Public property | AudioPort1COMPANDTX | Audio Port 1: COMPAND (TX)
Public property | AudioPort1HALFCYCLECLKDIV | Audio Port 1: HALF_CYCLE_CLK_DIV
Public property | AudioPort1MSBPOSITIONRX | Audio Port 1: MSB_POSITION (RX)
Public property | AudioPort1MSBPOSITIONTX | Audio Port 1: MSB_POSITION (TX)
Public property | AudioPort1RXENB | Audio Port 1: RX_ENB
Public property | AudioPort1RXMODE | Audio Port 1: RX_MODE
Public property | AudioPort1RXWIDTH | Audio Port 1: RX_WIDTH (unit: bits)
Public property | AudioPort1STEREO | Audio Port 1: STEREO
Public property | AudioPort1STEREOSYNCMODE | Audio Port 1: STEREO_SYNC_MODE
Public property | AudioPort1STEREOSYNCPHASE | Audio Port 1: STEREO_SYNC_PHASE
Public property | AudioPort1SYNCMS | Audio Port 1: SYNC_MS
Public property | AudioPort1SYNCRATE | Audio Port 1: SYNC_RATE
Public property | AudioPort1SYNCWIDTH | Audio Port 1: SYNC_WIDTH (unit: bits)
Public property | AudioPort1SYNTHDENOM | Audio Port 1: SYNTH_DENOM
Public property | AudioPort1SYNTHNUM | Audio Port 1: SYNTH_NUM
Public property | AudioPort1TXENB | Audio Port 1: TX_ENB
Public property | AudioPort1TXEXTRABITS | Audio Port 1: TX_EXTRA_BITS
Public property | AudioPort1TXMODE | Audio Port 1: TX_MODE
Public property | AudioPort1TXWIDTH | Audio Port 1: TX_WIDTH (unit: bits)
Public property | AudioPort1ΜLawALawRX | Audio Port 1: μLaw/A-Law (RX)
Public property | AudioPort1ΜLawALawTX | Audio Port 1: μLaw/A-Law (TX)
Public property | AudioPort2CLKMS | Audio Port 2: CLK_MS
Public property | AudioPort2CLKPH | Audio Port 2: CLK_PH
Public property | AudioPort2CLOCKSEL | Audio Port 2: CLOCK_SEL
Public property | AudioPort2COMPANDRX | Audio Port 2: COMPAND (RX)
Public property | AudioPort2COMPANDTX | Audio Port 2: COMPAND (TX)
Public property | AudioPort2HALFCYCLECLKDIV | Audio Port 2: HALF_CYCLE_CLK_DIV
Public property | AudioPort2MSBPOSITIONRX | Audio Port 2: MSB_POSITION (RX)
Public property | AudioPort2MSBPOSITIONTX | Audio Port 2: MSB_POSITION (TX)
Public property | AudioPort2RXENB | Audio Port 2: RX_ENB
Public property | AudioPort2RXMODE | Audio Port 2: RX_MODE
Public property | AudioPort2RXWIDTH | Audio Port 2: RX_WIDTH (unit: bits)
Public property | AudioPort2STEREO | Audio Port 2: STEREO
Public property | AudioPort2STEREOSYNCMODE | Audio Port 2: STEREO_SYNC_MODE
Public property | AudioPort2STEREOSYNCPHASE | Audio Port 2: STEREO_SYNC_PHASE
Public property | AudioPort2SYNCMS | Audio Port 2: SYNC_MS
Public property | AudioPort2SYNCRATE | Audio Port 2: SYNC_RATE
Public property | AudioPort2SYNCWIDTH | Audio Port 2: SYNC_WIDTH (unit: bits)
Public property | AudioPort2SYNTHDENOM | Audio Port 2: SYNTH_DENOM
Public property | AudioPort2SYNTHNUM | Audio Port 2: SYNTH_NUM
Public property | AudioPort2TXENB | Audio Port 2: TX_ENB
Public property | AudioPort2TXEXTRABITS | Audio Port 2: TX_EXTRA_BITS
Public property | AudioPort2TXMODE | Audio Port 2: TX_MODE
Public property | AudioPort2TXWIDTH | Audio Port 2: TX_WIDTH (unit: bits)
Public property | AudioPort2ΜLawALawRX | Audio Port 2: μLaw/A-Law (RX)
Public property | AudioPort2ΜLawALawTX | Audio Port 2: μLaw/A-Law (TX)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BasicSetupCHIPACTIVE | Basic Setup: CHIP_ACTIVE
Public property | BasicSetupCHIPENABLE | Basic Setup: CHIP_ENABLE
Public property | BasicSetupMCLKOVR | Basic Setup: MCLK_OVR
Public property | BasicSetupOSCENB | Basic Setup: OSC_ENB
Public property | BasicSetupPLL1ENB | Basic Setup: PLL1_ENB
Public property | BasicSetupPLL2ENB | Basic Setup: PLL2_ENB
Public property | BasicSetupPMCCLKDIV | Basic Setup: PMC_CLK_DIV
Public property | BasicSetupPMCCLKSEL | Basic Setup: PMC_CLK_SEL
Public property | BasicSetupPORT1CLKOVR | Basic Setup: PORT1_CLK_OVR
Public property | BasicSetupPORT2CLKOVR | Basic Setup: PORT2_CLK_OVR
Public property | DACDACCLKDIV | DAC: DAC_CLK_DIV
Public property | DACDACCLKSEL | DAC: DAC_CLK_SEL
Public property | DACDACTRIM | DAC: DAC_TRIM
Public property | DACDSPONLY | DAC: DSP_ONLY
Public property | DACEffectMonitors3DLCLIP | DAC Effect Monitors: 3D_L_CLIP
Public property | DACEffectMonitors3DRCLIP | DAC Effect Monitors: 3D_R_CLIP
Public property | DACEffectMonitorsALCMONL | DAC Effect Monitors: ALCMONL
Public property | DACEffectMonitorsALCMONR | DAC Effect Monitors: ALCMONR
Public property | DACEffectMonitorsATTEN | DAC Effect Monitors: ATTEN
Public property | DACEffectMonitorsEFFECTLEVEL | DAC Effect Monitors: EFFECT_LEVEL (unit: %)
Public property | DACEffectMonitorsEFFECTMODE | DAC Effect Monitors: EFFECT_MODE
Public property | DACEffectMonitorsEQLCLIP | DAC Effect Monitors: EQ_L_CLIP
Public property | DACEffectMonitorsEQRCLIP | DAC Effect Monitors: EQ_R_CLIP
Public property | DACEffectMonitorsFILTERTYPE | DAC Effect Monitors: FILTER_TYPE
Public property | DACEffectMonitorsGAINLCLIP | DAC Effect Monitors: GAIN_L_CLIP
Public property | DACEffectMonitorsGAINRCLIP | DAC Effect Monitors: GAIN_R_CLIP
Public property | DACEffectMonitorsLVLMONL | DAC Effect Monitors: LVLMONL
Public property | DACEffectMonitorsLVLMONR | DAC Effect Monitors: LVLMONR
Public property | DACEffectMonitorsSCLPLCLIP | DAC Effect Monitors: SCLP_L_CLIP
Public property | DACEffectMonitorsSCLPLDISTORTALCMONL | DAC Effect Monitors: SCLP_L_DISTORT (ALCMONL)
Public property | DACEffectMonitorsSCLPLDISTORTALCMONR | DAC Effect Monitors: SCLP_L_DISTORT (ALCMONR)
Public property | DACEffectMonitorsSCLPRCLIP | DAC Effect Monitors: SCLP_R_CLIP
Public property | DACEffectMonitorsSCLPRDISTORTALCMONL | DAC Effect Monitors: SCLP_R_DISTORT (ALCMONL)
Public property | DACEffectMonitorsSCLPRDISTORTALCMONR | DAC Effect Monitors: SCLP_R_DISTORT (ALCMONR)
Public property | DACEffectsATTACKRATE | DAC Effects: ATTACK_RATE (unit: μs)
Public property | DACEffectsDACLLEVEL | DAC Effects: DAC_L_LEVEL (unit: dB)
Public property | DACEffectsDACRLEVEL | DAC Effects: DAC_R_LEVEL (unit: dB)
Public property | DACEffectsDECAYRATERELEASERATE | DAC Effects: DECAY_RATE/RELEASE_RATE (unit: μs)
Public property | DACEffectsEQBAND1FREQ | DAC Effects: EQ_BAND_1 (FREQ) (unit: Hz)
Public property | DACEffectsEQBAND1LEVEL | DAC Effects: EQ_BAND_1 (LEVEL) (unit: dB)
Public property | DACEffectsEQBAND2FREQ | DAC Effects: EQ_BAND_2 (FREQ) (unit: Hz)
Public property | DACEffectsEQBAND2LEVEL | DAC Effects: EQ_BAND_2 (LEVEL) (unit: dB)
Public property | DACEffectsEQBAND2Q | DAC Effects: EQ_BAND_2 (Q) (unit: Octave)
Public property | DACEffectsEQBAND3FREQ | DAC Effects: EQ_BAND_3 (FREQ) (unit: Hz)
Public property | DACEffectsEQBAND3LEVEL | DAC Effects: EQ_BAND_3 (LEVEL) (unit: dB)
Public property | DACEffectsEQBAND3Q | DAC Effects: EQ_BAND_3 (Q) (unit: Octave)
Public property | DACEffectsEQBAND4FREQ | DAC Effects: EQ_BAND_4 (FREQ) (unit: kHz)
Public property | DACEffectsEQBAND4LEVEL | DAC Effects: EQ_BAND_4 (LEVEL) (unit: dB)
Public property | DACEffectsEQBAND4Q | DAC Effects: EQ_BAND_4 (Q) (unit: Octave)
Public property | DACEffectsEQBAND5FREQ | DAC Effects: EQ_BAND_5 (FREQ) (unit: kHz)
Public property | DACEffectsEQBAND5LEVEL | DAC Effects: EQ_BAND_5 (LEVEL) (unit: dB)
Public property | DACEffectsHOLDTIME | DAC Effects: HOLD_TIME (unit: ms)
Public property | DACEffectsLEVEL | DAC Effects: LEVEL (unit: dB)
Public property | DACEffectsLIMITER | DAC Effects: LIMITER
Public property | DACEffectsMAXLEVEL | DAC Effects: MAX_LEVEL
Public property | DACEffectsMINLEVEL | DAC Effects: MIN_LEVEL
Public property | DACEffectsNGENB | DAC Effects: NG_ENB
Public property | DACEffectsNOISEFLOOR | DAC Effects: NOISE_FLOOR (unit: dB)
Public property | DACEffectsPKDECAYRATE | DAC Effects: PK_DECAY_RATE (unit: ms)
Public property | DACEffectsRATIO | DAC Effects: RATIO
Public property | DACEffectsSAMPLERATE | DAC Effects: SAMPLE_RATE (unit: kHz)
Public property | DACEffectsSOFTKNEE | DAC Effects: SOFT_KNEE
Public property | DACEffectsSTEREOLINK | DAC Effects: STEREO_LINK
Public property | DACEffectsTARGETLEVEL | DAC Effects: TARGET_LEVEL (unit: dB)
Public property | DACEffectsTHRESHOLD | DAC Effects: THRESHOLD (unit: dB)
Public property | DACMODE | DAC: MODE
Public property | DACMUTEL | DAC: MUTE_L
Public property | DACMUTER | DAC: MUTE_R
Public property | DigitalMixerADCLDAC | Digital Mixer: ADCL (DAC)
Public property | DigitalMixerADCLLVL | Digital Mixer: ADC_L_LVL (unit: dB)
Public property | DigitalMixerADCRDAC | Digital Mixer: ADCR (DAC)
Public property | DigitalMixerADCRLVL | Digital Mixer: ADC_R_LVL (unit: dB)
Public property | DigitalMixerINTERPLLVL | Digital Mixer: INTERP_L_LVL (unit: dB)
Public property | DigitalMixerINTERPRLVL | Digital Mixer: INTERP_R_LVL (unit: dB)
Public property | DigitalMixerLSELDecimator | Digital Mixer: L_SEL (Decimator)
Public property | DigitalMixerLSELInputPort1 | Digital Mixer: L_SEL (Input Port 1)
Public property | DigitalMixerLSELInputPort2 | Digital Mixer: L_SEL (Input Port 2)
Public property | DigitalMixerMONOInputPort1 | Digital Mixer: MONO (Input Port 1)
Public property | DigitalMixerMONOInputPort2 | Digital Mixer: MONO (Input Port 2)
Public property | DigitalMixerMXRCLKSELDecimator | Digital Mixer: MXRCLK_SEL (Decimator)
Public property | DigitalMixerPORT1LDAC | Digital Mixer: PORT1L (DAC)
Public property | DigitalMixerPORT1RDAC | Digital Mixer: PORT1R (DAC)
Public property | DigitalMixerPORT1RXLLVL | Digital Mixer: PORT1_RX_L_LVL (unit: dB)
Public property | DigitalMixerPORT1RXRLVL | Digital Mixer: PORT1_RX_R_LVL (unit: dB)
Public property | DigitalMixerPORT2LDAC | Digital Mixer: PORT2L (DAC)
Public property | DigitalMixerPORT2RDAC | Digital Mixer: PORT2R (DAC)
Public property | DigitalMixerPORT2RXLLVL | Digital Mixer: PORT2_RX_L_LVL (unit: dB)
Public property | DigitalMixerPORT2RXRLVL | Digital Mixer: PORT2_RX_R_LVL (unit: dB)
Public property | DigitalMixerRSELDecimator | Digital Mixer: R_SEL (Decimator)
Public property | DigitalMixerRSELInputPort1 | Digital Mixer: R_SEL (Input Port 1)
Public property | DigitalMixerRSELInputPort2 | Digital Mixer: R_SEL (Input Port 2)
Public property | DigitalMixerSWAPDAC | Digital Mixer: SWAP (DAC)
Public property | DigitalMixerSWAPInputPort1 | Digital Mixer: SWAP (Input Port 1)
Public property | DigitalMixerSWAPInputPort2 | Digital Mixer: SWAP (Input Port 2)
Public property | EffectsEngineADCALCENB | Effects Engine: ADC_ALC_ENB
Public property | EffectsEngineADCEQENB | Effects Engine: ADC_EQ_ENB
Public property | EffectsEngineADCHPFENB | Effects Engine: ADC_HPF_ENB
Public property | EffectsEngineADCPKENB | Effects Engine: ADC_PK_ENB
Public property | EffectsEngineADCSCLPENB | Effects Engine: ADC_SCLP_ENB
Public property | EffectsEngineDAC3DENB | Effects Engine: DAC_3D_ENB
Public property | EffectsEngineDACALCENB | Effects Engine: DAC_ALC_ENB
Public property | EffectsEngineDACEQENB | Effects Engine: DAC_EQ_ENB
Public property | EffectsEngineDACPKENB | Effects Engine: DAC_PK_ENB
Public property | EffectsEngineDACSCLPENB | Effects Engine: DAC_SCLP_ENB
Public property | GPIOGPIOMODE | GPIO: GPIO_MODE
Public property | GPIOGPIORX | GPIO: GPIO_RX
Public property | GPIOGPIOTX | GPIO: GPIO_TX
Public property | GPIOSHORT | GPIO: SHORT
Public property | GPIOTEMP | GPIO: TEMP
Public property | PLLsPLL1CLKSEL | PLLs: PLL1_CLK_SEL
Public property | PLLsPLL1M | PLLs: PLL1_M
Public property | PLLsPLL1N | PLLs: PLL1_N
Public property | PLLsPLL1NMOD | PLLs: PLL1_N_MOD
Public property | PLLsPLL1P1 | PLLs: PLL1_P1
Public property | PLLsPLL1P2 | PLLs: PLL1_P2
Public property | PLLsPLL2CLKSEL | PLLs: PLL2_CLK_SEL
Public property | PLLsPLL2M | PLLs: PLL2_M
Public property | PLLsPLL2N | PLLs: PLL2_N
Public property | PLLsPLL2NMOD | PLLs: PLL2_N_MOD
Public property | PLLsPLL2P | PLLs: PLL2_P
Public property | SpreadSpectrumSSDISABLE | Spread Spectrum: SS_DISABLE
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
High Performance Audio Codec Sub-System with a Ground-Referenced Stereo Headphone Amplifier & an Ultra Low EMI Class D Loudspeaker Amplifier with Dual I2S/PCM Digital Audio Interfaces
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm49350(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm49350

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350 Properties

The Lm49350 type exposes the following members.

Properties
 | Name | Description
Public property | ADCADCCLKDIV | ADC: ADC_CLK_DIV
Public property | ADCADCCLKSEL | ADC: ADC_CLK_SEL
Public property | ADCADCDSPONLY | ADC: ADC_DSP_ONLY
Public property | ADCADCTRIM | ADC: ADC_TRIM
Public property | ADCCompensationFilterADCC0 | ADC Compensation Filter: ADC_C0
Public property | ADCCompensationFilterADCC1 | ADC Compensation Filter: ADC_C1
Public property | ADCCompensationFilterADCC2 | ADC Compensation Filter: ADC_C2
Public property | ADCCompensationFilterAUXLINEOUT | ADC Compensation Filter: AUX_LINE_OUT
Public property | ADCEffectMonitorsADCLCLIP | ADC Effect Monitors: ADC_L_CLIP
Public property | ADCEffectMonitorsADCRCLIP | ADC Effect Monitors: ADC_R_CLIP
Public property | ADCEffectMonitorsALCMONL | ADC Effect Monitors: ALCMONL
Public property | ADCEffectMonitorsALCMONR | ADC Effect Monitors: ALCMONR
Public property | ADCEffectMonitorsEQLCLIP | ADC Effect Monitors: EQ_L_CLIP
Public property | ADCEffectMonitorsEQRCLIP | ADC Effect Monitors: EQ_R_CLIP
Public property | ADCEffectMonitorsGAINLCLIP | ADC Effect Monitors: GAIN_L_CLIP
Public property | ADCEffectMonitorsGAINRCLIP | ADC Effect Monitors: GAIN_R_CLIP
Public property | ADCEffectMonitorsLVLMONL | ADC Effect Monitors: LVLMONL
Public property | ADCEffectMonitorsLVLMONR | ADC Effect Monitors: LVLMONR
Public property | ADCEffectMonitorsSCLPLCLIP | ADC Effect Monitors: SCLP_L_CLIP
Public property | ADCEffectMonitorsSCLPLDISTORTALCMONL | ADC Effect Monitors: SCLP_L_DISTORT (ALCMONL)
Public property | ADCEffectMonitorsSCLPLDISTORTALCMONR | ADC Effect Monitors: SCLP_L_DISTORT (ALCMONR)
Public property | ADCEffectMonitorsSCLPRCLIP | ADC Effect Monitors: SCLP_R_CLIP
Public property | ADCEffectMonitorsSCLPRDISTORTALCMONL | ADC Effect Monitors: SCLP_R_DISTORT (ALCMONL)
Public property | ADCEffectMonitorsSCLPRDISTORTALCMONR | ADC Effect Monitors: SCLP_R_DISTORT (ALCMONR)
Public property | ADCEffectsADCLLEVEL | ADC Effects: ADC_L_LEVEL (unit: dB)
Public property | ADCEffectsADCRLEVEL | ADC Effects: ADC_R_LEVEL (unit: dB)
Public property | ADCEffectsATTACKRATE | ADC Effects: ATTACK_RATE (unit: μs)
Public property | ADCEffectsDECAYRATE | ADC Effects: DECAY_RATE (unit: μs)
Public property | ADCEffectsEQBAND1FREQ | ADC Effects: EQ_BAND_1 (FREQ) (unit: Hz)
Public property | ADCEffectsEQBAND1LEVEL | ADC Effects: EQ_BAND_1 (LEVEL) (unit: dB)
Public property | ADCEffectsEQBAND2FREQ | ADC Effects: EQ_BAND_2 (FREQ) (unit: Hz)
Public property | ADCEffectsEQBAND2LEVEL | ADC Effects: EQ_BAND_2 (LEVEL) (unit: dB)
Public property | ADCEffectsEQBAND2Q | ADC Effects: EQ_BAND_2 (Q) (unit: Octave)
Public property | ADCEffectsEQBAND3FREQ | ADC Effects: EQ_BAND_3 (FREQ) (unit: Hz)
Public property | ADCEffectsEQBAND3LEVEL | ADC Effects: EQ_BAND_3 (LEVEL) (unit: dB)
Public property | ADCEffectsEQBAND3Q | ADC Effects: EQ_BAND_3 (Q) (unit: Octave)
Public property | ADCEffectsEQBAND4FREQ | ADC Effects: EQ_BAND_4 (FREQ) (unit: kHz)
Public property | ADCEffectsEQBAND4LEVEL | ADC Effects: EQ_BAND_4 (LEVEL) (unit: dB)
Public property | ADCEffectsEQBAND4Q | ADC Effects: EQ_BAND_4 (Q) (unit: Octave)
Public property | ADCEffectsEQBAND5FREQ | ADC Effects: EQ_BAND_5 (FREQ) (unit: kHz)
Public property | ADCEffectsEQBAND5LEVEL | ADC Effects: EQ_BAND_5 (LEVEL) (unit: dB)
Public property | ADCEffectsHOLDTIME | ADC Effects: HOLD_TIME (unit: ms)
Public property | ADCEffectsHPFMODE | ADC Effects: HPF_MODE
Public property | ADCEffectsLEVEL | ADC Effects: LEVEL (unit: dB)
Public property | ADCEffectsLIMITER | ADC Effects: LIMITER
Public property | ADCEffectsMAXLEVEL | ADC Effects: MAX_LEVEL
Public property | ADCEffectsMINLEVEL | ADC Effects: MIN_LEVEL
Public property | ADCEffectsNGENB | ADC Effects: NG_ENB
Public property | ADCEffectsNOISEFLOOR | ADC Effects: NOISE_FLOOR (unit: dB)
Public property | ADCEffectsPKDECAYRATE | ADC Effects: PK_DECAY_RATE (unit: ms)
Public property | ADCEffectsRATIO | ADC Effects: RATIO
Public property | ADCEffectsSAMPLERATE | ADC Effects: SAMPLE_RATE (unit: kHz)
Public property | ADCEffectsSOFTKNEE | ADC Effects: SOFT_KNEE
Public property | ADCEffectsSOURCEOVR | ADC Effects: SOURCE_OVR
Public property | ADCEffectsSOURCESEL | ADC Effects: SOURCE_SEL
Public property | ADCEffectsSTEREOLINK | ADC Effects: STEREO_LINK
Public property | ADCEffectsTARGETLEVEL | ADC Effects: TARGET_LEVEL (unit: dB)
Public property | ADCEffectsTHRESHOLD | ADC Effects: THRESHOLD (unit: dB)
Public property | ADCMONO | ADC: MONO
Public property | ADCMUTEL | ADC: MUTE_L
Public property | ADCMUTER | ADC: MUTE_R
Public property | ADCOSR | ADC: OSR
Public property | AnalogMixerAUX6dB | Analog Mixer: AUX-6dB
Public property | AnalogMixerAUXLADCL | Analog Mixer: AUXL_ADCL
Public property | AnalogMixerAUXLAX | Analog Mixer: AUXL_AX
Public property | AnalogMixerAUXLHPL | Analog Mixer: AUXL_HPL
Public property | AnalogMixerAUXLHPR | Analog Mixer: AUXL_HPR
Public property | AnalogMixerAUXLLEVEL | Analog Mixer: AUX_L_LEVEL (unit: dB)
Public property | AnalogMixerAUXLLS | Analog Mixer: AUXL_LS
Public property | AnalogMixerAUXRADCR | Analog Mixer: AUXR_ADCR
Public property | AnalogMixerAUXRAX | Analog Mixer: AUXR_AX
Public property | AnalogMixerAUXRHPL | Analog Mixer: AUXR_HPL
Public property | AnalogMixerAUXRHPR | Analog Mixer: AUXR_HPR
Public property | AnalogMixerAUXRLEVEL | Analog Mixer: AUX_R_LEVEL (unit: dB)
Public property | AnalogMixerAUXRLS | Analog Mixer: AUXR_LS
Public property | AnalogMixerCPFORCE | Analog Mixer: CP_FORCE
Public property | AnalogMixerDACLADCL | Analog Mixer: DACL_ADCL
Public property | AnalogMixerDACLAX | Analog Mixer: DACL_AX
Public property | AnalogMixerDACLHPL | Analog Mixer: DACL_HPL
Public property | AnalogMixerDACLHPR | Analog Mixer: DACL_HPR
Public property | AnalogMixerDACLLS | Analog Mixer: DACL_LS
Public property | AnalogMixerDACRADCR | Analog Mixer: DACR_ADCR
Public property | AnalogMixerDACRAX | Analog Mixer: DACR_AX
Public property | AnalogMixerDACRHPL | Analog Mixer: DACR_HPL
Public property | AnalogMixerDACRHPR | Analog Mixer: DACR_HPR
Public property | AnalogMixerDACRLS | Analog Mixer: DACR_LS
Public property | AnalogMixerDIFFMODE | Analog Mixer: DIFF_MODE
Public property | AnalogMixerEPMODE | Analog Mixer: EPMODE
Public property | AnalogMixerFROMLINEL | Analog Mixer: FROM_LINE_L
Public property | AnalogMixerFROMLINER | Analog Mixer: FROM_LINE_R
Public property | AnalogMixerHP6dB | Analog Mixer: HP-6dB
Public property | AnalogMixerLS6dB | Analog Mixer: LS-6dB
Public property | AnalogMixerMICLADCL | Analog Mixer: MICL_ADCL
Public property | AnalogMixerMICLAX | Analog Mixer: MICL_AX
Public property | AnalogMixerMICLHPL | Analog Mixer: MICL_HPL
Public property | AnalogMixerMICLHPR | Analog Mixer: MICL_HPR
Public property | AnalogMixerMICLLEVEL | Analog Mixer: MIC_L_LEVEL (unit: dB)
Public property | AnalogMixerMICLLS | Analog Mixer: MICL_LS
Public property | AnalogMixerMICRADCR | Analog Mixer: MICR_ADCR
Public property | AnalogMixerMICRAX | Analog Mixer: MICR_ AX
Public property | AnalogMixerMICRHPL | Analog Mixer: MICR_HPL
Public property | AnalogMixerMICRHPR | Analog Mixer: MICR_HPR
Public property | AnalogMixerMICRLEVEL | Analog Mixer: MIC_R_LEVEL (unit: dB)
Public property | AnalogMixerMICRLS | Analog Mixer: MICR_LS
Public property | AnalogMixerMUTEMICL | Analog Mixer: MUTE (MICL)
Public property | AnalogMixerMUTEMICR | Analog Mixer: MUTE (MICR)
Public property | AnalogMixerSEDIFFMICL | Analog Mixer: SE_DIFF (MICL)
Public property | AnalogMixerSEDIFFMICR | Analog Mixer: SE_DIFF (MICR)
Public property | AudioPort1CLKMS | Audio Port 1: CLK_MS
Public property | AudioPort1CLKPH | Audio Port 1: CLK_PH
Public property | AudioPort1CLOCKSEL | Audio Port 1: CLOCK_SEL
Public property | AudioPort1COMPANDRX | Audio Port 1: COMPAND (RX)
Public property | AudioPort1COMPANDTX | Audio Port 1: COMPAND (TX)
Public property | AudioPort1HALFCYCLECLKDIV | Audio Port 1: HALF_CYCLE_CLK_DIV
Public property | AudioPort1MSBPOSITIONRX | Audio Port 1: MSB_POSITION (RX)
Public property | AudioPort1MSBPOSITIONTX | Audio Port 1: MSB_POSITION (TX)
Public property | AudioPort1RXENB | Audio Port 1: RX_ENB
Public property | AudioPort1RXMODE | Audio Port 1: RX_MODE
Public property | AudioPort1RXWIDTH | Audio Port 1: RX_WIDTH (unit: bits)
Public property | AudioPort1STEREO | Audio Port 1: STEREO
Public property | AudioPort1STEREOSYNCMODE | Audio Port 1: STEREO_SYNC_MODE
Public property | AudioPort1STEREOSYNCPHASE | Audio Port 1: STEREO_SYNC_PHASE
Public property | AudioPort1SYNCMS | Audio Port 1: SYNC_MS
Public property | AudioPort1SYNCRATE | Audio Port 1: SYNC_RATE
Public property | AudioPort1SYNCWIDTH | Audio Port 1: SYNC_WIDTH (unit: bits)
Public property | AudioPort1SYNTHDENOM | Audio Port 1: SYNTH_DENOM
Public property | AudioPort1SYNTHNUM | Audio Port 1: SYNTH_NUM
Public property | AudioPort1TXENB | Audio Port 1: TX_ENB
Public property | AudioPort1TXEXTRABITS | Audio Port 1: TX_EXTRA_BITS
Public property | AudioPort1TXMODE | Audio Port 1: TX_MODE
Public property | AudioPort1TXWIDTH | Audio Port 1: TX_WIDTH (unit: bits)
Public property | AudioPort1ΜLawALawRX | Audio Port 1: μLaw/A-Law (RX)
Public property | AudioPort1ΜLawALawTX | Audio Port 1: μLaw/A-Law (TX)
Public property | AudioPort2CLKMS | Audio Port 2: CLK_MS
Public property | AudioPort2CLKPH | Audio Port 2: CLK_PH
Public property | AudioPort2CLOCKSEL | Audio Port 2: CLOCK_SEL
Public property | AudioPort2COMPANDRX | Audio Port 2: COMPAND (RX)
Public property | AudioPort2COMPANDTX | Audio Port 2: COMPAND (TX)
Public property | AudioPort2HALFCYCLECLKDIV | Audio Port 2: HALF_CYCLE_CLK_DIV
Public property | AudioPort2MSBPOSITIONRX | Audio Port 2: MSB_POSITION (RX)
Public property | AudioPort2MSBPOSITIONTX | Audio Port 2: MSB_POSITION (TX)
Public property | AudioPort2RXENB | Audio Port 2: RX_ENB
Public property | AudioPort2RXMODE | Audio Port 2: RX_MODE
Public property | AudioPort2RXWIDTH | Audio Port 2: RX_WIDTH (unit: bits)
Public property | AudioPort2STEREO | Audio Port 2: STEREO
Public property | AudioPort2STEREOSYNCMODE | Audio Port 2: STEREO_SYNC_MODE
Public property | AudioPort2STEREOSYNCPHASE | Audio Port 2: STEREO_SYNC_PHASE
Public property | AudioPort2SYNCMS | Audio Port 2: SYNC_MS
Public property | AudioPort2SYNCRATE | Audio Port 2: SYNC_RATE
Public property | AudioPort2SYNCWIDTH | Audio Port 2: SYNC_WIDTH (unit: bits)
Public property | AudioPort2SYNTHDENOM | Audio Port 2: SYNTH_DENOM
Public property | AudioPort2SYNTHNUM | Audio Port 2: SYNTH_NUM
Public property | AudioPort2TXENB | Audio Port 2: TX_ENB
Public property | AudioPort2TXEXTRABITS | Audio Port 2: TX_EXTRA_BITS
Public property | AudioPort2TXMODE | Audio Port 2: TX_MODE
Public property | AudioPort2TXWIDTH | Audio Port 2: TX_WIDTH (unit: bits)
Public property | AudioPort2ΜLawALawRX | Audio Port 2: μLaw/A-Law (RX)
Public property | AudioPort2ΜLawALawTX | Audio Port 2: μLaw/A-Law (TX)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BasicSetupCHIPACTIVE | Basic Setup: CHIP_ACTIVE
Public property | BasicSetupCHIPENABLE | Basic Setup: CHIP_ENABLE
Public property | BasicSetupMCLKOVR | Basic Setup: MCLK_OVR
Public property | BasicSetupOSCENB | Basic Setup: OSC_ENB
Public property | BasicSetupPLL1ENB | Basic Setup: PLL1_ENB
Public property | BasicSetupPLL2ENB | Basic Setup: PLL2_ENB
Public property | BasicSetupPMCCLKDIV | Basic Setup: PMC_CLK_DIV
Public property | BasicSetupPMCCLKSEL | Basic Setup: PMC_CLK_SEL
Public property | BasicSetupPORT1CLKOVR | Basic Setup: PORT1_CLK_OVR
Public property | BasicSetupPORT2CLKOVR | Basic Setup: PORT2_CLK_OVR
Public property | DACDACCLKDIV | DAC: DAC_CLK_DIV
Public property | DACDACCLKSEL | DAC: DAC_CLK_SEL
Public property | DACDACTRIM | DAC: DAC_TRIM
Public property | DACDSPONLY | DAC: DSP_ONLY
Public property | DACEffectMonitors3DLCLIP | DAC Effect Monitors: 3D_L_CLIP
Public property | DACEffectMonitors3DRCLIP | DAC Effect Monitors: 3D_R_CLIP
Public property | DACEffectMonitorsALCMONL | DAC Effect Monitors: ALCMONL
Public property | DACEffectMonitorsALCMONR | DAC Effect Monitors: ALCMONR
Public property | DACEffectMonitorsATTEN | DAC Effect Monitors: ATTEN
Public property | DACEffectMonitorsEFFECTLEVEL | DAC Effect Monitors: EFFECT_LEVEL (unit: %)
Public property | DACEffectMonitorsEFFECTMODE | DAC Effect Monitors: EFFECT_MODE
Public property | DACEffectMonitorsEQLCLIP | DAC Effect Monitors: EQ_L_CLIP
Public property | DACEffectMonitorsEQRCLIP | DAC Effect Monitors: EQ_R_CLIP
Public property | DACEffectMonitorsFILTERTYPE | DAC Effect Monitors: FILTER_TYPE
Public property | DACEffectMonitorsGAINLCLIP | DAC Effect Monitors: GAIN_L_CLIP
Public property | DACEffectMonitorsGAINRCLIP | DAC Effect Monitors: GAIN_R_CLIP
Public property | DACEffectMonitorsLVLMONL | DAC Effect Monitors: LVLMONL
Public property | DACEffectMonitorsLVLMONR | DAC Effect Monitors: LVLMONR
Public property | DACEffectMonitorsSCLPLCLIP | DAC Effect Monitors: SCLP_L_CLIP
Public property | DACEffectMonitorsSCLPLDISTORTALCMONL | DAC Effect Monitors: SCLP_L_DISTORT (ALCMONL)
Public property | DACEffectMonitorsSCLPLDISTORTALCMONR | DAC Effect Monitors: SCLP_L_DISTORT (ALCMONR)
Public property | DACEffectMonitorsSCLPRCLIP | DAC Effect Monitors: SCLP_R_CLIP
Public property | DACEffectMonitorsSCLPRDISTORTALCMONL | DAC Effect Monitors: SCLP_R_DISTORT (ALCMONL)
Public property | DACEffectMonitorsSCLPRDISTORTALCMONR | DAC Effect Monitors: SCLP_R_DISTORT (ALCMONR)
Public property | DACEffectsATTACKRATE | DAC Effects: ATTACK_RATE (unit: μs)
Public property | DACEffectsDACLLEVEL | DAC Effects: DAC_L_LEVEL (unit: dB)
Public property | DACEffectsDACRLEVEL | DAC Effects: DAC_R_LEVEL (unit: dB)
Public property | DACEffectsDECAYRATERELEASERATE | DAC Effects: DECAY_RATE/RELEASE_RATE (unit: μs)
Public property | DACEffectsEQBAND1FREQ | DAC Effects: EQ_BAND_1 (FREQ) (unit: Hz)
Public property | DACEffectsEQBAND1LEVEL | DAC Effects: EQ_BAND_1 (LEVEL) (unit: dB)
Public property | DACEffectsEQBAND2FREQ | DAC Effects: EQ_BAND_2 (FREQ) (unit: Hz)
Public property | DACEffectsEQBAND2LEVEL | DAC Effects: EQ_BAND_2 (LEVEL) (unit: dB)
Public property | DACEffectsEQBAND2Q | DAC Effects: EQ_BAND_2 (Q) (unit: Octave)
Public property | DACEffectsEQBAND3FREQ | DAC Effects: EQ_BAND_3 (FREQ) (unit: Hz)
Public property | DACEffectsEQBAND3LEVEL | DAC Effects: EQ_BAND_3 (LEVEL) (unit: dB)
Public property | DACEffectsEQBAND3Q | DAC Effects: EQ_BAND_3 (Q) (unit: Octave)
Public property | DACEffectsEQBAND4FREQ | DAC Effects: EQ_BAND_4 (FREQ) (unit: kHz)
Public property | DACEffectsEQBAND4LEVEL | DAC Effects: EQ_BAND_4 (LEVEL) (unit: dB)
Public property | DACEffectsEQBAND4Q | DAC Effects: EQ_BAND_4 (Q) (unit: Octave)
Public property | DACEffectsEQBAND5FREQ | DAC Effects: EQ_BAND_5 (FREQ) (unit: kHz)
Public property | DACEffectsEQBAND5LEVEL | DAC Effects: EQ_BAND_5 (LEVEL) (unit: dB)
Public property | DACEffectsHOLDTIME | DAC Effects: HOLD_TIME (unit: ms)
Public property | DACEffectsLEVEL | DAC Effects: LEVEL (unit: dB)
Public property | DACEffectsLIMITER | DAC Effects: LIMITER
Public property | DACEffectsMAXLEVEL | DAC Effects: MAX_LEVEL
Public property | DACEffectsMINLEVEL | DAC Effects: MIN_LEVEL
Public property | DACEffectsNGENB | DAC Effects: NG_ENB
Public property | DACEffectsNOISEFLOOR | DAC Effects: NOISE_FLOOR (unit: dB)
Public property | DACEffectsPKDECAYRATE | DAC Effects: PK_DECAY_RATE (unit: ms)
Public property | DACEffectsRATIO | DAC Effects: RATIO
Public property | DACEffectsSAMPLERATE | DAC Effects: SAMPLE_RATE (unit: kHz)
Public property | DACEffectsSOFTKNEE | DAC Effects: SOFT_KNEE
Public property | DACEffectsSTEREOLINK | DAC Effects: STEREO_LINK
Public property | DACEffectsTARGETLEVEL | DAC Effects: TARGET_LEVEL (unit: dB)
Public property | DACEffectsTHRESHOLD | DAC Effects: THRESHOLD (unit: dB)
Public property | DACMODE | DAC: MODE
Public property | DACMUTEL | DAC: MUTE_L
Public property | DACMUTER | DAC: MUTE_R
Public property | DigitalMixerADCLDAC | Digital Mixer: ADCL (DAC)
Public property | DigitalMixerADCLLVL | Digital Mixer: ADC_L_LVL (unit: dB)
Public property | DigitalMixerADCRDAC | Digital Mixer: ADCR (DAC)
Public property | DigitalMixerADCRLVL | Digital Mixer: ADC_R_LVL (unit: dB)
Public property | DigitalMixerINTERPLLVL | Digital Mixer: INTERP_L_LVL (unit: dB)
Public property | DigitalMixerINTERPRLVL | Digital Mixer: INTERP_R_LVL (unit: dB)
Public property | DigitalMixerLSELDecimator | Digital Mixer: L_SEL (Decimator)
Public property | DigitalMixerLSELInputPort1 | Digital Mixer: L_SEL (Input Port 1)
Public property | DigitalMixerLSELInputPort2 | Digital Mixer: L_SEL (Input Port 2)
Public property | DigitalMixerMONOInputPort1 | Digital Mixer: MONO (Input Port 1)
Public property | DigitalMixerMONOInputPort2 | Digital Mixer: MONO (Input Port 2)
Public property | DigitalMixerMXRCLKSELDecimator | Digital Mixer: MXRCLK_SEL (Decimator)
Public property | DigitalMixerPORT1LDAC | Digital Mixer: PORT1L (DAC)
Public property | DigitalMixerPORT1RDAC | Digital Mixer: PORT1R (DAC)
Public property | DigitalMixerPORT1RXLLVL | Digital Mixer: PORT1_RX_L_LVL (unit: dB)
Public property | DigitalMixerPORT1RXRLVL | Digital Mixer: PORT1_RX_R_LVL (unit: dB)
Public property | DigitalMixerPORT2LDAC | Digital Mixer: PORT2L (DAC)
Public property | DigitalMixerPORT2RDAC | Digital Mixer: PORT2R (DAC)
Public property | DigitalMixerPORT2RXLLVL | Digital Mixer: PORT2_RX_L_LVL (unit: dB)
Public property | DigitalMixerPORT2RXRLVL | Digital Mixer: PORT2_RX_R_LVL (unit: dB)
Public property | DigitalMixerRSELDecimator | Digital Mixer: R_SEL (Decimator)
Public property | DigitalMixerRSELInputPort1 | Digital Mixer: R_SEL (Input Port 1)
Public property | DigitalMixerRSELInputPort2 | Digital Mixer: R_SEL (Input Port 2)
Public property | DigitalMixerSWAPDAC | Digital Mixer: SWAP (DAC)
Public property | DigitalMixerSWAPInputPort1 | Digital Mixer: SWAP (Input Port 1)
Public property | DigitalMixerSWAPInputPort2 | Digital Mixer: SWAP (Input Port 2)
Public property | EffectsEngineADCALCENB | Effects Engine: ADC_ALC_ENB
Public property | EffectsEngineADCEQENB | Effects Engine: ADC_EQ_ENB
Public property | EffectsEngineADCHPFENB | Effects Engine: ADC_HPF_ENB
Public property | EffectsEngineADCPKENB | Effects Engine: ADC_PK_ENB
Public property | EffectsEngineADCSCLPENB | Effects Engine: ADC_SCLP_ENB
Public property | EffectsEngineDAC3DENB | Effects Engine: DAC_3D_ENB
Public property | EffectsEngineDACALCENB | Effects Engine: DAC_ALC_ENB
Public property | EffectsEngineDACEQENB | Effects Engine: DAC_EQ_ENB
Public property | EffectsEngineDACPKENB | Effects Engine: DAC_PK_ENB
Public property | EffectsEngineDACSCLPENB | Effects Engine: DAC_SCLP_ENB
Public property | GPIOGPIOMODE | GPIO: GPIO_MODE
Public property | GPIOGPIORX | GPIO: GPIO_RX
Public property | GPIOGPIOTX | GPIO: GPIO_TX
Public property | GPIOSHORT | GPIO: SHORT
Public property | GPIOTEMP | GPIO: TEMP
Public property | PLLsPLL1CLKSEL | PLLs: PLL1_CLK_SEL
Public property | PLLsPLL1M | PLLs: PLL1_M
Public property | PLLsPLL1N | PLLs: PLL1_N
Public property | PLLsPLL1NMOD | PLLs: PLL1_N_MOD
Public property | PLLsPLL1P1 | PLLs: PLL1_P1
Public property | PLLsPLL1P2 | PLLs: PLL1_P2
Public property | PLLsPLL2CLKSEL | PLLs: PLL2_CLK_SEL
Public property | PLLsPLL2M | PLLs: PLL2_M
Public property | PLLsPLL2N | PLLs: PLL2_N
Public property | PLLsPLL2NMOD | PLLs: PLL2_N_MOD
Public property | PLLsPLL2P | PLLs: PLL2_P
Public property | SpreadSpectrumSSDISABLE | Spread Spectrum: SS_DISABLE
Top
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCADCCLKDIV Property

IRD

Lm49350ADCADCCLKDIV Property

ADC: ADC_CLK_DIV

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeClkDiv ADCADCCLKDIV { get; set; }
Public Property ADCADCCLKDIV As Lm49350TypeClkDiv
    Get
    Set
public:
property Lm49350TypeClkDiv ADCADCCLKDIV {
    Lm49350TypeClkDiv get ();
    void set (Lm49350TypeClkDiv value);
}
member ADCADCCLKDIV : Lm49350TypeClkDiv with get, set

Property Value

Type: Lm49350TypeClkDiv
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCADCCLKSEL Property

IRD

Lm49350ADCADCCLKSEL Property

ADC: ADC_CLK_SEL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeClkSel ADCADCCLKSEL { get; set; }
Public Property ADCADCCLKSEL As Lm49350TypeClkSel
    Get
    Set
public:
property Lm49350TypeClkSel ADCADCCLKSEL {
    Lm49350TypeClkSel get ();
    void set (Lm49350TypeClkSel value);
}
member ADCADCCLKSEL : Lm49350TypeClkSel with get, set

Property Value

Type: Lm49350TypeClkSel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCADCDSPONLY Property

IRD

Lm49350ADCADCDSPONLY Property

ADC: ADC_DSP_ONLY

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCADCDSPONLY { get; set; }
Public Property ADCADCDSPONLY As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCADCDSPONLY {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCADCDSPONLY : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCADCTRIM Property

IRD

Lm49350ADCADCTRIM Property

ADC: ADC_TRIM

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCADCTRIM { get; set; }
Public Property ADCADCTRIM As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCADCTRIM {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCADCTRIM : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCCompensationFilterADCC0 Property

IRD

Lm49350ADCCompensationFilterADCC0 Property

ADC Compensation Filter: ADC_C0

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCCompensationFilterADCC0 { get; set; }
Public Property ADCCompensationFilterADCC0 As UShort
    Get
    Set
public:
property unsigned short ADCCompensationFilterADCC0 {
    unsigned short get ();
    void set (unsigned short value);
}
member ADCCompensationFilterADCC0 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCCompensationFilterADCC1 Property

IRD

Lm49350ADCCompensationFilterADCC1 Property

ADC Compensation Filter: ADC_C1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCCompensationFilterADCC1 { get; set; }
Public Property ADCCompensationFilterADCC1 As UShort
    Get
    Set
public:
property unsigned short ADCCompensationFilterADCC1 {
    unsigned short get ();
    void set (unsigned short value);
}
member ADCCompensationFilterADCC1 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCCompensationFilterADCC2 Property

IRD

Lm49350ADCCompensationFilterADCC2 Property

ADC Compensation Filter: ADC_C2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCCompensationFilterADCC2 { get; set; }
Public Property ADCCompensationFilterADCC2 As UShort
    Get
    Set
public:
property unsigned short ADCCompensationFilterADCC2 {
    unsigned short get ();
    void set (unsigned short value);
}
member ADCCompensationFilterADCC2 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCCompensationFilterAUXLINEOUT Property

IRD

Lm49350ADCCompensationFilterAUXLINEOUT Property

ADC Compensation Filter: AUX_LINE_OUT

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCCompensationFilterAUXLINEOUT { get; set; }
Public Property ADCCompensationFilterAUXLINEOUT As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCCompensationFilterAUXLINEOUT {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCCompensationFilterAUXLINEOUT : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectMonitorsADCLCLIP Property

IRD

Lm49350ADCEffectMonitorsADCLCLIP Property

ADC Effect Monitors: ADC_L_CLIP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCEffectMonitorsADCLCLIP { get; set; }
Public Property ADCEffectMonitorsADCLCLIP As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCEffectMonitorsADCLCLIP {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCEffectMonitorsADCLCLIP : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectMonitorsADCRCLIP Property

IRD

Lm49350ADCEffectMonitorsADCRCLIP Property

ADC Effect Monitors: ADC_R_CLIP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCEffectMonitorsADCRCLIP { get; set; }
Public Property ADCEffectMonitorsADCRCLIP As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCEffectMonitorsADCRCLIP {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCEffectMonitorsADCRCLIP : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectMonitorsALCMONL Property

IRD

Lm49350ADCEffectMonitorsALCMONL Property

ADC Effect Monitors: ALCMONL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCEffectMonitorsALCMONL { get; set; }
Public Property ADCEffectMonitorsALCMONL As Byte
    Get
    Set
public:
property unsigned char ADCEffectMonitorsALCMONL {
    unsigned char get ();
    void set (unsigned char value);
}
member ADCEffectMonitorsALCMONL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectMonitorsALCMONR Property

IRD

Lm49350ADCEffectMonitorsALCMONR Property

ADC Effect Monitors: ALCMONR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCEffectMonitorsALCMONR { get; set; }
Public Property ADCEffectMonitorsALCMONR As Byte
    Get
    Set
public:
property unsigned char ADCEffectMonitorsALCMONR {
    unsigned char get ();
    void set (unsigned char value);
}
member ADCEffectMonitorsALCMONR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectMonitorsEQLCLIP Property

IRD

Lm49350ADCEffectMonitorsEQLCLIP Property

ADC Effect Monitors: EQ_L_CLIP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCEffectMonitorsEQLCLIP { get; set; }
Public Property ADCEffectMonitorsEQLCLIP As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCEffectMonitorsEQLCLIP {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCEffectMonitorsEQLCLIP : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectMonitorsEQRCLIP Property

IRD

Lm49350ADCEffectMonitorsEQRCLIP Property

ADC Effect Monitors: EQ_R_CLIP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCEffectMonitorsEQRCLIP { get; set; }
Public Property ADCEffectMonitorsEQRCLIP As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCEffectMonitorsEQRCLIP {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCEffectMonitorsEQRCLIP : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectMonitorsGAINLCLIP Property

IRD

Lm49350ADCEffectMonitorsGAINLCLIP Property

ADC Effect Monitors: GAIN_L_CLIP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCEffectMonitorsGAINLCLIP { get; set; }
Public Property ADCEffectMonitorsGAINLCLIP As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCEffectMonitorsGAINLCLIP {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCEffectMonitorsGAINLCLIP : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectMonitorsGAINRCLIP Property

IRD

Lm49350ADCEffectMonitorsGAINRCLIP Property

ADC Effect Monitors: GAIN_R_CLIP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCEffectMonitorsGAINRCLIP { get; set; }
Public Property ADCEffectMonitorsGAINRCLIP As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCEffectMonitorsGAINRCLIP {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCEffectMonitorsGAINRCLIP : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectMonitorsLVLMONL Property

IRD

Lm49350ADCEffectMonitorsLVLMONL Property

ADC Effect Monitors: LVLMONL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCEffectMonitorsLVLMONL { get; set; }
Public Property ADCEffectMonitorsLVLMONL As Byte
    Get
    Set
public:
property unsigned char ADCEffectMonitorsLVLMONL {
    unsigned char get ();
    void set (unsigned char value);
}
member ADCEffectMonitorsLVLMONL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectMonitorsLVLMONR Property

IRD

Lm49350ADCEffectMonitorsLVLMONR Property

ADC Effect Monitors: LVLMONR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCEffectMonitorsLVLMONR { get; set; }
Public Property ADCEffectMonitorsLVLMONR As Byte
    Get
    Set
public:
property unsigned char ADCEffectMonitorsLVLMONR {
    unsigned char get ();
    void set (unsigned char value);
}
member ADCEffectMonitorsLVLMONR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectMonitorsSCLPLCLIP Property

IRD

Lm49350ADCEffectMonitorsSCLPLCLIP Property

ADC Effect Monitors: SCLP_L_CLIP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCEffectMonitorsSCLPLCLIP { get; set; }
Public Property ADCEffectMonitorsSCLPLCLIP As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCEffectMonitorsSCLPLCLIP {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCEffectMonitorsSCLPLCLIP : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectMonitorsSCLPLDISTORTALCMONL Property

IRD

Lm49350ADCEffectMonitorsSCLPLDISTORTALCMONL Property

ADC Effect Monitors: SCLP_L_DISTORT (ALCMONL)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCEffectMonitorsSCLPLDISTORTALCMONL { get; set; }
Public Property ADCEffectMonitorsSCLPLDISTORTALCMONL As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCEffectMonitorsSCLPLDISTORTALCMONL {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCEffectMonitorsSCLPLDISTORTALCMONL : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectMonitorsSCLPLDISTORTALCMONR Property

IRD

Lm49350ADCEffectMonitorsSCLPLDISTORTALCMONR Property

ADC Effect Monitors: SCLP_L_DISTORT (ALCMONR)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCEffectMonitorsSCLPLDISTORTALCMONR { get; set; }
Public Property ADCEffectMonitorsSCLPLDISTORTALCMONR As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCEffectMonitorsSCLPLDISTORTALCMONR {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCEffectMonitorsSCLPLDISTORTALCMONR : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectMonitorsSCLPRCLIP Property

IRD

Lm49350ADCEffectMonitorsSCLPRCLIP Property

ADC Effect Monitors: SCLP_R_CLIP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCEffectMonitorsSCLPRCLIP { get; set; }
Public Property ADCEffectMonitorsSCLPRCLIP As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCEffectMonitorsSCLPRCLIP {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCEffectMonitorsSCLPRCLIP : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectMonitorsSCLPRDISTORTALCMONL Property

IRD

Lm49350ADCEffectMonitorsSCLPRDISTORTALCMONL Property

ADC Effect Monitors: SCLP_R_DISTORT (ALCMONL)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCEffectMonitorsSCLPRDISTORTALCMONL { get; set; }
Public Property ADCEffectMonitorsSCLPRDISTORTALCMONL As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCEffectMonitorsSCLPRDISTORTALCMONL {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCEffectMonitorsSCLPRDISTORTALCMONL : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectMonitorsSCLPRDISTORTALCMONR Property

IRD

Lm49350ADCEffectMonitorsSCLPRDISTORTALCMONR Property

ADC Effect Monitors: SCLP_R_DISTORT (ALCMONR)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCEffectMonitorsSCLPRDISTORTALCMONR { get; set; }
Public Property ADCEffectMonitorsSCLPRDISTORTALCMONR As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCEffectMonitorsSCLPRDISTORTALCMONR {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCEffectMonitorsSCLPRDISTORTALCMONR : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsADCLLEVEL Property

IRD

Lm49350ADCEffectsADCLLEVEL Property

ADC Effects: ADC_L_LEVEL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsAdcLevel ADCEffectsADCLLEVEL { get; set; }
Public Property ADCEffectsADCLLEVEL As Lm49350TypeAdcEffectsAdcLevel
    Get
    Set
public:
property Lm49350TypeAdcEffectsAdcLevel ADCEffectsADCLLEVEL {
    Lm49350TypeAdcEffectsAdcLevel get ();
    void set (Lm49350TypeAdcEffectsAdcLevel value);
}
member ADCEffectsADCLLEVEL : Lm49350TypeAdcEffectsAdcLevel with get, set

Property Value

Type: Lm49350TypeAdcEffectsAdcLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsADCRLEVEL Property

IRD

Lm49350ADCEffectsADCRLEVEL Property

ADC Effects: ADC_R_LEVEL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsAdcLevel ADCEffectsADCRLEVEL { get; set; }
Public Property ADCEffectsADCRLEVEL As Lm49350TypeAdcEffectsAdcLevel
    Get
    Set
public:
property Lm49350TypeAdcEffectsAdcLevel ADCEffectsADCRLEVEL {
    Lm49350TypeAdcEffectsAdcLevel get ();
    void set (Lm49350TypeAdcEffectsAdcLevel value);
}
member ADCEffectsADCRLEVEL : Lm49350TypeAdcEffectsAdcLevel with get, set

Property Value

Type: Lm49350TypeAdcEffectsAdcLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsATTACKRATE Property

IRD

Lm49350ADCEffectsATTACKRATE Property

ADC Effects: ATTACK_RATE (unit: μs)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsAttackRate ADCEffectsATTACKRATE { get; set; }
Public Property ADCEffectsATTACKRATE As Lm49350TypeAdcEffectsAttackRate
    Get
    Set
public:
property Lm49350TypeAdcEffectsAttackRate ADCEffectsATTACKRATE {
    Lm49350TypeAdcEffectsAttackRate get ();
    void set (Lm49350TypeAdcEffectsAttackRate value);
}
member ADCEffectsATTACKRATE : Lm49350TypeAdcEffectsAttackRate with get, set

Property Value

Type: Lm49350TypeAdcEffectsAttackRate
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsDECAYRATE Property

IRD

Lm49350ADCEffectsDECAYRATE Property

ADC Effects: DECAY_RATE (unit: μs)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsDecayRate ADCEffectsDECAYRATE { get; set; }
Public Property ADCEffectsDECAYRATE As Lm49350TypeAdcEffectsDecayRate
    Get
    Set
public:
property Lm49350TypeAdcEffectsDecayRate ADCEffectsDECAYRATE {
    Lm49350TypeAdcEffectsDecayRate get ();
    void set (Lm49350TypeAdcEffectsDecayRate value);
}
member ADCEffectsDECAYRATE : Lm49350TypeAdcEffectsDecayRate with get, set

Property Value

Type: Lm49350TypeAdcEffectsDecayRate
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsEQBAND1FREQ Property

IRD

Lm49350ADCEffectsEQBAND1FREQ Property

ADC Effects: EQ_BAND_1 (FREQ) (unit: Hz)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEq1Freq ADCEffectsEQBAND1FREQ { get; set; }
Public Property ADCEffectsEQBAND1FREQ As Lm49350TypeAdcEffectsEq1Freq
    Get
    Set
public:
property Lm49350TypeAdcEffectsEq1Freq ADCEffectsEQBAND1FREQ {
    Lm49350TypeAdcEffectsEq1Freq get ();
    void set (Lm49350TypeAdcEffectsEq1Freq value);
}
member ADCEffectsEQBAND1FREQ : Lm49350TypeAdcEffectsEq1Freq with get, set

Property Value

Type: Lm49350TypeAdcEffectsEq1Freq
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsEQBAND1LEVEL Property

IRD

Lm49350ADCEffectsEQBAND1LEVEL Property

ADC Effects: EQ_BAND_1 (LEVEL) (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEqLevel ADCEffectsEQBAND1LEVEL { get; set; }
Public Property ADCEffectsEQBAND1LEVEL As Lm49350TypeAdcEffectsEqLevel
    Get
    Set
public:
property Lm49350TypeAdcEffectsEqLevel ADCEffectsEQBAND1LEVEL {
    Lm49350TypeAdcEffectsEqLevel get ();
    void set (Lm49350TypeAdcEffectsEqLevel value);
}
member ADCEffectsEQBAND1LEVEL : Lm49350TypeAdcEffectsEqLevel with get, set

Property Value

Type: Lm49350TypeAdcEffectsEqLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsEQBAND2FREQ Property

IRD

Lm49350ADCEffectsEQBAND2FREQ Property

ADC Effects: EQ_BAND_2 (FREQ) (unit: Hz)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEq2Freq ADCEffectsEQBAND2FREQ { get; set; }
Public Property ADCEffectsEQBAND2FREQ As Lm49350TypeAdcEffectsEq2Freq
    Get
    Set
public:
property Lm49350TypeAdcEffectsEq2Freq ADCEffectsEQBAND2FREQ {
    Lm49350TypeAdcEffectsEq2Freq get ();
    void set (Lm49350TypeAdcEffectsEq2Freq value);
}
member ADCEffectsEQBAND2FREQ : Lm49350TypeAdcEffectsEq2Freq with get, set

Property Value

Type: Lm49350TypeAdcEffectsEq2Freq
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsEQBAND2LEVEL Property

IRD

Lm49350ADCEffectsEQBAND2LEVEL Property

ADC Effects: EQ_BAND_2 (LEVEL) (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEqLevel ADCEffectsEQBAND2LEVEL { get; set; }
Public Property ADCEffectsEQBAND2LEVEL As Lm49350TypeAdcEffectsEqLevel
    Get
    Set
public:
property Lm49350TypeAdcEffectsEqLevel ADCEffectsEQBAND2LEVEL {
    Lm49350TypeAdcEffectsEqLevel get ();
    void set (Lm49350TypeAdcEffectsEqLevel value);
}
member ADCEffectsEQBAND2LEVEL : Lm49350TypeAdcEffectsEqLevel with get, set

Property Value

Type: Lm49350TypeAdcEffectsEqLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsEQBAND2Q Property

IRD

Lm49350ADCEffectsEQBAND2Q Property

ADC Effects: EQ_BAND_2 (Q) (unit: Octave)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEqQ ADCEffectsEQBAND2Q { get; set; }
Public Property ADCEffectsEQBAND2Q As Lm49350TypeAdcEffectsEqQ
    Get
    Set
public:
property Lm49350TypeAdcEffectsEqQ ADCEffectsEQBAND2Q {
    Lm49350TypeAdcEffectsEqQ get ();
    void set (Lm49350TypeAdcEffectsEqQ value);
}
member ADCEffectsEQBAND2Q : Lm49350TypeAdcEffectsEqQ with get, set

Property Value

Type: Lm49350TypeAdcEffectsEqQ
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsEQBAND3FREQ Property

IRD

Lm49350ADCEffectsEQBAND3FREQ Property

ADC Effects: EQ_BAND_3 (FREQ) (unit: Hz)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEq3Freq ADCEffectsEQBAND3FREQ { get; set; }
Public Property ADCEffectsEQBAND3FREQ As Lm49350TypeAdcEffectsEq3Freq
    Get
    Set
public:
property Lm49350TypeAdcEffectsEq3Freq ADCEffectsEQBAND3FREQ {
    Lm49350TypeAdcEffectsEq3Freq get ();
    void set (Lm49350TypeAdcEffectsEq3Freq value);
}
member ADCEffectsEQBAND3FREQ : Lm49350TypeAdcEffectsEq3Freq with get, set

Property Value

Type: Lm49350TypeAdcEffectsEq3Freq
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsEQBAND3LEVEL Property

IRD

Lm49350ADCEffectsEQBAND3LEVEL Property

ADC Effects: EQ_BAND_3 (LEVEL) (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEqLevel ADCEffectsEQBAND3LEVEL { get; set; }
Public Property ADCEffectsEQBAND3LEVEL As Lm49350TypeAdcEffectsEqLevel
    Get
    Set
public:
property Lm49350TypeAdcEffectsEqLevel ADCEffectsEQBAND3LEVEL {
    Lm49350TypeAdcEffectsEqLevel get ();
    void set (Lm49350TypeAdcEffectsEqLevel value);
}
member ADCEffectsEQBAND3LEVEL : Lm49350TypeAdcEffectsEqLevel with get, set

Property Value

Type: Lm49350TypeAdcEffectsEqLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsEQBAND3Q Property

IRD

Lm49350ADCEffectsEQBAND3Q Property

ADC Effects: EQ_BAND_3 (Q) (unit: Octave)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEqQ ADCEffectsEQBAND3Q { get; set; }
Public Property ADCEffectsEQBAND3Q As Lm49350TypeAdcEffectsEqQ
    Get
    Set
public:
property Lm49350TypeAdcEffectsEqQ ADCEffectsEQBAND3Q {
    Lm49350TypeAdcEffectsEqQ get ();
    void set (Lm49350TypeAdcEffectsEqQ value);
}
member ADCEffectsEQBAND3Q : Lm49350TypeAdcEffectsEqQ with get, set

Property Value

Type: Lm49350TypeAdcEffectsEqQ
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsEQBAND4FREQ Property

IRD

Lm49350ADCEffectsEQBAND4FREQ Property

ADC Effects: EQ_BAND_4 (FREQ) (unit: kHz)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEq4Freq ADCEffectsEQBAND4FREQ { get; set; }
Public Property ADCEffectsEQBAND4FREQ As Lm49350TypeAdcEffectsEq4Freq
    Get
    Set
public:
property Lm49350TypeAdcEffectsEq4Freq ADCEffectsEQBAND4FREQ {
    Lm49350TypeAdcEffectsEq4Freq get ();
    void set (Lm49350TypeAdcEffectsEq4Freq value);
}
member ADCEffectsEQBAND4FREQ : Lm49350TypeAdcEffectsEq4Freq with get, set

Property Value

Type: Lm49350TypeAdcEffectsEq4Freq
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsEQBAND4LEVEL Property

IRD

Lm49350ADCEffectsEQBAND4LEVEL Property

ADC Effects: EQ_BAND_4 (LEVEL) (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEqLevel ADCEffectsEQBAND4LEVEL { get; set; }
Public Property ADCEffectsEQBAND4LEVEL As Lm49350TypeAdcEffectsEqLevel
    Get
    Set
public:
property Lm49350TypeAdcEffectsEqLevel ADCEffectsEQBAND4LEVEL {
    Lm49350TypeAdcEffectsEqLevel get ();
    void set (Lm49350TypeAdcEffectsEqLevel value);
}
member ADCEffectsEQBAND4LEVEL : Lm49350TypeAdcEffectsEqLevel with get, set

Property Value

Type: Lm49350TypeAdcEffectsEqLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsEQBAND4Q Property

IRD

Lm49350ADCEffectsEQBAND4Q Property

ADC Effects: EQ_BAND_4 (Q) (unit: Octave)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEqQ ADCEffectsEQBAND4Q { get; set; }
Public Property ADCEffectsEQBAND4Q As Lm49350TypeAdcEffectsEqQ
    Get
    Set
public:
property Lm49350TypeAdcEffectsEqQ ADCEffectsEQBAND4Q {
    Lm49350TypeAdcEffectsEqQ get ();
    void set (Lm49350TypeAdcEffectsEqQ value);
}
member ADCEffectsEQBAND4Q : Lm49350TypeAdcEffectsEqQ with get, set

Property Value

Type: Lm49350TypeAdcEffectsEqQ
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsEQBAND5FREQ Property

IRD

Lm49350ADCEffectsEQBAND5FREQ Property

ADC Effects: EQ_BAND_5 (FREQ) (unit: kHz)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEq5Freq ADCEffectsEQBAND5FREQ { get; set; }
Public Property ADCEffectsEQBAND5FREQ As Lm49350TypeAdcEffectsEq5Freq
    Get
    Set
public:
property Lm49350TypeAdcEffectsEq5Freq ADCEffectsEQBAND5FREQ {
    Lm49350TypeAdcEffectsEq5Freq get ();
    void set (Lm49350TypeAdcEffectsEq5Freq value);
}
member ADCEffectsEQBAND5FREQ : Lm49350TypeAdcEffectsEq5Freq with get, set

Property Value

Type: Lm49350TypeAdcEffectsEq5Freq
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsEQBAND5LEVEL Property

IRD

Lm49350ADCEffectsEQBAND5LEVEL Property

ADC Effects: EQ_BAND_5 (LEVEL) (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEqLevel ADCEffectsEQBAND5LEVEL { get; set; }
Public Property ADCEffectsEQBAND5LEVEL As Lm49350TypeAdcEffectsEqLevel
    Get
    Set
public:
property Lm49350TypeAdcEffectsEqLevel ADCEffectsEQBAND5LEVEL {
    Lm49350TypeAdcEffectsEqLevel get ();
    void set (Lm49350TypeAdcEffectsEqLevel value);
}
member ADCEffectsEQBAND5LEVEL : Lm49350TypeAdcEffectsEqLevel with get, set

Property Value

Type: Lm49350TypeAdcEffectsEqLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsHOLDTIME Property

IRD

Lm49350ADCEffectsHOLDTIME Property

ADC Effects: HOLD_TIME (unit: ms)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsHoldTime ADCEffectsHOLDTIME { get; set; }
Public Property ADCEffectsHOLDTIME As Lm49350TypeAdcEffectsHoldTime
    Get
    Set
public:
property Lm49350TypeAdcEffectsHoldTime ADCEffectsHOLDTIME {
    Lm49350TypeAdcEffectsHoldTime get ();
    void set (Lm49350TypeAdcEffectsHoldTime value);
}
member ADCEffectsHOLDTIME : Lm49350TypeAdcEffectsHoldTime with get, set

Property Value

Type: Lm49350TypeAdcEffectsHoldTime
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsHPFMODE Property

IRD

Lm49350ADCEffectsHPFMODE Property

ADC Effects: HPF_MODE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsHpfMode ADCEffectsHPFMODE { get; set; }
Public Property ADCEffectsHPFMODE As Lm49350TypeAdcEffectsHpfMode
    Get
    Set
public:
property Lm49350TypeAdcEffectsHpfMode ADCEffectsHPFMODE {
    Lm49350TypeAdcEffectsHpfMode get ();
    void set (Lm49350TypeAdcEffectsHpfMode value);
}
member ADCEffectsHPFMODE : Lm49350TypeAdcEffectsHpfMode with get, set

Property Value

Type: Lm49350TypeAdcEffectsHpfMode
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsLEVEL Property

IRD

Lm49350ADCEffectsLEVEL Property

ADC Effects: LEVEL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsClipLevel ADCEffectsLEVEL { get; set; }
Public Property ADCEffectsLEVEL As Lm49350TypeAdcEffectsClipLevel
    Get
    Set
public:
property Lm49350TypeAdcEffectsClipLevel ADCEffectsLEVEL {
    Lm49350TypeAdcEffectsClipLevel get ();
    void set (Lm49350TypeAdcEffectsClipLevel value);
}
member ADCEffectsLEVEL : Lm49350TypeAdcEffectsClipLevel with get, set

Property Value

Type: Lm49350TypeAdcEffectsClipLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsLIMITER Property

IRD

Lm49350ADCEffectsLIMITER Property

ADC Effects: LIMITER

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCEffectsLIMITER { get; set; }
Public Property ADCEffectsLIMITER As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCEffectsLIMITER {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCEffectsLIMITER : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsMAXLEVEL Property

IRD

Lm49350ADCEffectsMAXLEVEL Property

ADC Effects: MAX_LEVEL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCEffectsMAXLEVEL { get; set; }
Public Property ADCEffectsMAXLEVEL As Byte
    Get
    Set
public:
property unsigned char ADCEffectsMAXLEVEL {
    unsigned char get ();
    void set (unsigned char value);
}
member ADCEffectsMAXLEVEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsMINLEVEL Property

IRD

Lm49350ADCEffectsMINLEVEL Property

ADC Effects: MIN_LEVEL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCEffectsMINLEVEL { get; set; }
Public Property ADCEffectsMINLEVEL As Byte
    Get
    Set
public:
property unsigned char ADCEffectsMINLEVEL {
    unsigned char get ();
    void set (unsigned char value);
}
member ADCEffectsMINLEVEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsNGENB Property

IRD

Lm49350ADCEffectsNGENB Property

ADC Effects: NG_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeEnabledDisabled ADCEffectsNGENB { get; set; }
Public Property ADCEffectsNGENB As Lm49350TypeEnabledDisabled
    Get
    Set
public:
property Lm49350TypeEnabledDisabled ADCEffectsNGENB {
    Lm49350TypeEnabledDisabled get ();
    void set (Lm49350TypeEnabledDisabled value);
}
member ADCEffectsNGENB : Lm49350TypeEnabledDisabled with get, set

Property Value

Type: Lm49350TypeEnabledDisabled
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsNOISEFLOOR Property

IRD

Lm49350ADCEffectsNOISEFLOOR Property

ADC Effects: NOISE_FLOOR (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsNoiseFloor ADCEffectsNOISEFLOOR { get; set; }
Public Property ADCEffectsNOISEFLOOR As Lm49350TypeAdcEffectsNoiseFloor
    Get
    Set
public:
property Lm49350TypeAdcEffectsNoiseFloor ADCEffectsNOISEFLOOR {
    Lm49350TypeAdcEffectsNoiseFloor get ();
    void set (Lm49350TypeAdcEffectsNoiseFloor value);
}
member ADCEffectsNOISEFLOOR : Lm49350TypeAdcEffectsNoiseFloor with get, set

Property Value

Type: Lm49350TypeAdcEffectsNoiseFloor
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsPKDECAYRATE Property

IRD

Lm49350ADCEffectsPKDECAYRATE Property

ADC Effects: PK_DECAY_RATE (unit: ms)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsPkDecayRate ADCEffectsPKDECAYRATE { get; set; }
Public Property ADCEffectsPKDECAYRATE As Lm49350TypeAdcEffectsPkDecayRate
    Get
    Set
public:
property Lm49350TypeAdcEffectsPkDecayRate ADCEffectsPKDECAYRATE {
    Lm49350TypeAdcEffectsPkDecayRate get ();
    void set (Lm49350TypeAdcEffectsPkDecayRate value);
}
member ADCEffectsPKDECAYRATE : Lm49350TypeAdcEffectsPkDecayRate with get, set

Property Value

Type: Lm49350TypeAdcEffectsPkDecayRate
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsRATIO Property

IRD

Lm49350ADCEffectsRATIO Property

ADC Effects: RATIO

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsClipRatio ADCEffectsRATIO { get; set; }
Public Property ADCEffectsRATIO As Lm49350TypeAdcEffectsClipRatio
    Get
    Set
public:
property Lm49350TypeAdcEffectsClipRatio ADCEffectsRATIO {
    Lm49350TypeAdcEffectsClipRatio get ();
    void set (Lm49350TypeAdcEffectsClipRatio value);
}
member ADCEffectsRATIO : Lm49350TypeAdcEffectsClipRatio with get, set

Property Value

Type: Lm49350TypeAdcEffectsClipRatio
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsSAMPLERATE Property

IRD

Lm49350ADCEffectsSAMPLERATE Property

ADC Effects: SAMPLE_RATE (unit: kHz)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsSampleRate ADCEffectsSAMPLERATE { get; set; }
Public Property ADCEffectsSAMPLERATE As Lm49350TypeAdcEffectsSampleRate
    Get
    Set
public:
property Lm49350TypeAdcEffectsSampleRate ADCEffectsSAMPLERATE {
    Lm49350TypeAdcEffectsSampleRate get ();
    void set (Lm49350TypeAdcEffectsSampleRate value);
}
member ADCEffectsSAMPLERATE : Lm49350TypeAdcEffectsSampleRate with get, set

Property Value

Type: Lm49350TypeAdcEffectsSampleRate
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsSOFTKNEE Property

IRD

Lm49350ADCEffectsSOFTKNEE Property

ADC Effects: SOFT_KNEE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCEffectsSOFTKNEE { get; set; }
Public Property ADCEffectsSOFTKNEE As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCEffectsSOFTKNEE {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCEffectsSOFTKNEE : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsSOURCEOVR Property

IRD

Lm49350ADCEffectsSOURCEOVR Property

ADC Effects: SOURCE_OVR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCEffectsSOURCEOVR { get; set; }
Public Property ADCEffectsSOURCEOVR As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCEffectsSOURCEOVR {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCEffectsSOURCEOVR : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsSOURCESEL Property

IRD

Lm49350ADCEffectsSOURCESEL Property

ADC Effects: SOURCE_SEL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsSourceSel ADCEffectsSOURCESEL { get; set; }
Public Property ADCEffectsSOURCESEL As Lm49350TypeAdcEffectsSourceSel
    Get
    Set
public:
property Lm49350TypeAdcEffectsSourceSel ADCEffectsSOURCESEL {
    Lm49350TypeAdcEffectsSourceSel get ();
    void set (Lm49350TypeAdcEffectsSourceSel value);
}
member ADCEffectsSOURCESEL : Lm49350TypeAdcEffectsSourceSel with get, set

Property Value

Type: Lm49350TypeAdcEffectsSourceSel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsSTEREOLINK Property

IRD

Lm49350ADCEffectsSTEREOLINK Property

ADC Effects: STEREO_LINK

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCEffectsSTEREOLINK { get; set; }
Public Property ADCEffectsSTEREOLINK As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCEffectsSTEREOLINK {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCEffectsSTEREOLINK : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsTARGETLEVEL Property

IRD

Lm49350ADCEffectsTARGETLEVEL Property

ADC Effects: TARGET_LEVEL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsTargetLevel ADCEffectsTARGETLEVEL { get; set; }
Public Property ADCEffectsTARGETLEVEL As Lm49350TypeAdcEffectsTargetLevel
    Get
    Set
public:
property Lm49350TypeAdcEffectsTargetLevel ADCEffectsTARGETLEVEL {
    Lm49350TypeAdcEffectsTargetLevel get ();
    void set (Lm49350TypeAdcEffectsTargetLevel value);
}
member ADCEffectsTARGETLEVEL : Lm49350TypeAdcEffectsTargetLevel with get, set

Property Value

Type: Lm49350TypeAdcEffectsTargetLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCEffectsTHRESHOLD Property

IRD

Lm49350ADCEffectsTHRESHOLD Property

ADC Effects: THRESHOLD (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsClipThreshold ADCEffectsTHRESHOLD { get; set; }
Public Property ADCEffectsTHRESHOLD As Lm49350TypeAdcEffectsClipThreshold
    Get
    Set
public:
property Lm49350TypeAdcEffectsClipThreshold ADCEffectsTHRESHOLD {
    Lm49350TypeAdcEffectsClipThreshold get ();
    void set (Lm49350TypeAdcEffectsClipThreshold value);
}
member ADCEffectsTHRESHOLD : Lm49350TypeAdcEffectsClipThreshold with get, set

Property Value

Type: Lm49350TypeAdcEffectsClipThreshold
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCMONO Property

IRD

Lm49350ADCMONO Property

ADC: MONO

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCMONO { get; set; }
Public Property ADCMONO As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCMONO {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCMONO : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCMUTEL Property

IRD

Lm49350ADCMUTEL Property

ADC: MUTE_L

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCMUTEL { get; set; }
Public Property ADCMUTEL As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCMUTEL {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCMUTEL : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCMUTER Property

IRD

Lm49350ADCMUTER Property

ADC: MUTE_R

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCMUTER { get; set; }
Public Property ADCMUTER As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCMUTER {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCMUTER : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.ADCOSR Property

IRD

Lm49350ADCOSR Property

ADC: OSR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet ADCOSR { get; set; }
Public Property ADCOSR As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet ADCOSR {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member ADCOSR : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerAUX6dB Property

IRD

Lm49350AnalogMixerAUX6dB Property

Analog Mixer: AUX-6dB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AnalogMixerAUX6dB { get; set; }
Public Property AnalogMixerAUX6dB As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AnalogMixerAUX6dB {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AnalogMixerAUX6dB : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerAUXLADCL Property

IRD

Lm49350AnalogMixerAUXLADCL Property

Analog Mixer: AUXL_ADCL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerAUXLADCL { get; set; }
Public Property AnalogMixerAUXLADCL As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerAUXLADCL {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerAUXLADCL : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerAUXLAX Property

IRD

Lm49350AnalogMixerAUXLAX Property

Analog Mixer: AUXL_AX

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerAUXLAX { get; set; }
Public Property AnalogMixerAUXLAX As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerAUXLAX {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerAUXLAX : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerAUXLHPL Property

IRD

Lm49350AnalogMixerAUXLHPL Property

Analog Mixer: AUXL_HPL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerAUXLHPL { get; set; }
Public Property AnalogMixerAUXLHPL As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerAUXLHPL {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerAUXLHPL : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerAUXLHPR Property

IRD

Lm49350AnalogMixerAUXLHPR Property

Analog Mixer: AUXL_HPR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerAUXLHPR { get; set; }
Public Property AnalogMixerAUXLHPR As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerAUXLHPR {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerAUXLHPR : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerAUXLLEVEL Property

IRD

Lm49350AnalogMixerAUXLLEVEL Property

Analog Mixer: AUX_L_LEVEL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAuxLevel AnalogMixerAUXLLEVEL { get; set; }
Public Property AnalogMixerAUXLLEVEL As Lm49350TypeAuxLevel
    Get
    Set
public:
property Lm49350TypeAuxLevel AnalogMixerAUXLLEVEL {
    Lm49350TypeAuxLevel get ();
    void set (Lm49350TypeAuxLevel value);
}
member AnalogMixerAUXLLEVEL : Lm49350TypeAuxLevel with get, set

Property Value

Type: Lm49350TypeAuxLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerAUXLLS Property

IRD

Lm49350AnalogMixerAUXLLS Property

Analog Mixer: AUXL_LS

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerAUXLLS { get; set; }
Public Property AnalogMixerAUXLLS As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerAUXLLS {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerAUXLLS : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerAUXRADCR Property

IRD

Lm49350AnalogMixerAUXRADCR Property

Analog Mixer: AUXR_ADCR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerAUXRADCR { get; set; }
Public Property AnalogMixerAUXRADCR As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerAUXRADCR {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerAUXRADCR : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerAUXRAX Property

IRD

Lm49350AnalogMixerAUXRAX Property

Analog Mixer: AUXR_AX

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerAUXRAX { get; set; }
Public Property AnalogMixerAUXRAX As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerAUXRAX {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerAUXRAX : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerAUXRHPL Property

IRD

Lm49350AnalogMixerAUXRHPL Property

Analog Mixer: AUXR_HPL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerAUXRHPL { get; set; }
Public Property AnalogMixerAUXRHPL As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerAUXRHPL {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerAUXRHPL : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerAUXRHPR Property

IRD

Lm49350AnalogMixerAUXRHPR Property

Analog Mixer: AUXR_HPR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerAUXRHPR { get; set; }
Public Property AnalogMixerAUXRHPR As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerAUXRHPR {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerAUXRHPR : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerAUXRLEVEL Property

IRD

Lm49350AnalogMixerAUXRLEVEL Property

Analog Mixer: AUX_R_LEVEL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAuxLevel AnalogMixerAUXRLEVEL { get; set; }
Public Property AnalogMixerAUXRLEVEL As Lm49350TypeAuxLevel
    Get
    Set
public:
property Lm49350TypeAuxLevel AnalogMixerAUXRLEVEL {
    Lm49350TypeAuxLevel get ();
    void set (Lm49350TypeAuxLevel value);
}
member AnalogMixerAUXRLEVEL : Lm49350TypeAuxLevel with get, set

Property Value

Type: Lm49350TypeAuxLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerAUXRLS Property

IRD

Lm49350AnalogMixerAUXRLS Property

Analog Mixer: AUXR_LS

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerAUXRLS { get; set; }
Public Property AnalogMixerAUXRLS As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerAUXRLS {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerAUXRLS : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerCPFORCE Property

IRD

Lm49350AnalogMixerCPFORCE Property

Analog Mixer: CP_FORCE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AnalogMixerCPFORCE { get; set; }
Public Property AnalogMixerCPFORCE As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AnalogMixerCPFORCE {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AnalogMixerCPFORCE : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerDACLADCL Property

IRD

Lm49350AnalogMixerDACLADCL Property

Analog Mixer: DACL_ADCL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerDACLADCL { get; set; }
Public Property AnalogMixerDACLADCL As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerDACLADCL {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerDACLADCL : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerDACLAX Property

IRD

Lm49350AnalogMixerDACLAX Property

Analog Mixer: DACL_AX

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerDACLAX { get; set; }
Public Property AnalogMixerDACLAX As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerDACLAX {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerDACLAX : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerDACLHPL Property

IRD

Lm49350AnalogMixerDACLHPL Property

Analog Mixer: DACL_HPL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerDACLHPL { get; set; }
Public Property AnalogMixerDACLHPL As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerDACLHPL {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerDACLHPL : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerDACLHPR Property

IRD

Lm49350AnalogMixerDACLHPR Property

Analog Mixer: DACL_HPR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerDACLHPR { get; set; }
Public Property AnalogMixerDACLHPR As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerDACLHPR {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerDACLHPR : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerDACLLS Property

IRD

Lm49350AnalogMixerDACLLS Property

Analog Mixer: DACL_LS

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerDACLLS { get; set; }
Public Property AnalogMixerDACLLS As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerDACLLS {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerDACLLS : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerDACRADCR Property

IRD

Lm49350AnalogMixerDACRADCR Property

Analog Mixer: DACR_ADCR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerDACRADCR { get; set; }
Public Property AnalogMixerDACRADCR As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerDACRADCR {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerDACRADCR : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerDACRAX Property

IRD

Lm49350AnalogMixerDACRAX Property

Analog Mixer: DACR_AX

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerDACRAX { get; set; }
Public Property AnalogMixerDACRAX As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerDACRAX {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerDACRAX : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerDACRHPL Property

IRD

Lm49350AnalogMixerDACRHPL Property

Analog Mixer: DACR_HPL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerDACRHPL { get; set; }
Public Property AnalogMixerDACRHPL As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerDACRHPL {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerDACRHPL : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerDACRHPR Property

IRD

Lm49350AnalogMixerDACRHPR Property

Analog Mixer: DACR_HPR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerDACRHPR { get; set; }
Public Property AnalogMixerDACRHPR As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerDACRHPR {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerDACRHPR : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerDACRLS Property

IRD

Lm49350AnalogMixerDACRLS Property

Analog Mixer: DACR_LS

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerDACRLS { get; set; }
Public Property AnalogMixerDACRLS As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerDACRLS {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerDACRLS : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerDIFFMODE Property

IRD

Lm49350AnalogMixerDIFFMODE Property

Analog Mixer: DIFF_MODE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AnalogMixerDIFFMODE { get; set; }
Public Property AnalogMixerDIFFMODE As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AnalogMixerDIFFMODE {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AnalogMixerDIFFMODE : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerEPMODE Property

IRD

Lm49350AnalogMixerEPMODE Property

Analog Mixer: EPMODE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AnalogMixerEPMODE { get; set; }
Public Property AnalogMixerEPMODE As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AnalogMixerEPMODE {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AnalogMixerEPMODE : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerFROMLINEL Property

IRD

Lm49350AnalogMixerFROMLINEL Property

Analog Mixer: FROM_LINE_L

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AnalogMixerFROMLINEL { get; set; }
Public Property AnalogMixerFROMLINEL As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AnalogMixerFROMLINEL {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AnalogMixerFROMLINEL : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerFROMLINER Property

IRD

Lm49350AnalogMixerFROMLINER Property

Analog Mixer: FROM_LINE_R

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AnalogMixerFROMLINER { get; set; }
Public Property AnalogMixerFROMLINER As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AnalogMixerFROMLINER {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AnalogMixerFROMLINER : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerHP6dB Property

IRD

Lm49350AnalogMixerHP6dB Property

Analog Mixer: HP-6dB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AnalogMixerHP6dB { get; set; }
Public Property AnalogMixerHP6dB As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AnalogMixerHP6dB {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AnalogMixerHP6dB : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerLS6dB Property

IRD

Lm49350AnalogMixerLS6dB Property

Analog Mixer: LS-6dB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AnalogMixerLS6dB { get; set; }
Public Property AnalogMixerLS6dB As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AnalogMixerLS6dB {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AnalogMixerLS6dB : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerMICLADCL Property

IRD

Lm49350AnalogMixerMICLADCL Property

Analog Mixer: MICL_ADCL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerMICLADCL { get; set; }
Public Property AnalogMixerMICLADCL As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerMICLADCL {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerMICLADCL : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerMICLAX Property

IRD

Lm49350AnalogMixerMICLAX Property

Analog Mixer: MICL_AX

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerMICLAX { get; set; }
Public Property AnalogMixerMICLAX As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerMICLAX {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerMICLAX : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerMICLHPL Property

IRD

Lm49350AnalogMixerMICLHPL Property

Analog Mixer: MICL_HPL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerMICLHPL { get; set; }
Public Property AnalogMixerMICLHPL As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerMICLHPL {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerMICLHPL : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerMICLHPR Property

IRD

Lm49350AnalogMixerMICLHPR Property

Analog Mixer: MICL_HPR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerMICLHPR { get; set; }
Public Property AnalogMixerMICLHPR As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerMICLHPR {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerMICLHPR : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerMICLLEVEL Property

IRD

Lm49350AnalogMixerMICLLEVEL Property

Analog Mixer: MIC_L_LEVEL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMicLevel AnalogMixerMICLLEVEL { get; set; }
Public Property AnalogMixerMICLLEVEL As Lm49350TypeMicLevel
    Get
    Set
public:
property Lm49350TypeMicLevel AnalogMixerMICLLEVEL {
    Lm49350TypeMicLevel get ();
    void set (Lm49350TypeMicLevel value);
}
member AnalogMixerMICLLEVEL : Lm49350TypeMicLevel with get, set

Property Value

Type: Lm49350TypeMicLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerMICLLS Property

IRD

Lm49350AnalogMixerMICLLS Property

Analog Mixer: MICL_LS

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerMICLLS { get; set; }
Public Property AnalogMixerMICLLS As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerMICLLS {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerMICLLS : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerMICRADCR Property

IRD

Lm49350AnalogMixerMICRADCR Property

Analog Mixer: MICR_ADCR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerMICRADCR { get; set; }
Public Property AnalogMixerMICRADCR As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerMICRADCR {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerMICRADCR : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerMICRAX Property

IRD

Lm49350AnalogMixerMICRAX Property

Analog Mixer: MICR_ AX

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerMICRAX { get; set; }
Public Property AnalogMixerMICRAX As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerMICRAX {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerMICRAX : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerMICRHPL Property

IRD

Lm49350AnalogMixerMICRHPL Property

Analog Mixer: MICR_HPL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerMICRHPL { get; set; }
Public Property AnalogMixerMICRHPL As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerMICRHPL {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerMICRHPL : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerMICRHPR Property

IRD

Lm49350AnalogMixerMICRHPR Property

Analog Mixer: MICR_HPR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerMICRHPR { get; set; }
Public Property AnalogMixerMICRHPR As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerMICRHPR {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerMICRHPR : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerMICRLEVEL Property

IRD

Lm49350AnalogMixerMICRLEVEL Property

Analog Mixer: MIC_R_LEVEL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMicLevel AnalogMixerMICRLEVEL { get; set; }
Public Property AnalogMixerMICRLEVEL As Lm49350TypeMicLevel
    Get
    Set
public:
property Lm49350TypeMicLevel AnalogMixerMICRLEVEL {
    Lm49350TypeMicLevel get ();
    void set (Lm49350TypeMicLevel value);
}
member AnalogMixerMICRLEVEL : Lm49350TypeMicLevel with get, set

Property Value

Type: Lm49350TypeMicLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerMICRLS Property

IRD

Lm49350AnalogMixerMICRLS Property

Analog Mixer: MICR_LS

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded AnalogMixerMICRLS { get; set; }
Public Property AnalogMixerMICRLS As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded AnalogMixerMICRLS {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member AnalogMixerMICRLS : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerMUTEMICL Property

IRD

Lm49350AnalogMixerMUTEMICL Property

Analog Mixer: MUTE (MICL)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AnalogMixerMUTEMICL { get; set; }
Public Property AnalogMixerMUTEMICL As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AnalogMixerMUTEMICL {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AnalogMixerMUTEMICL : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerMUTEMICR Property

IRD

Lm49350AnalogMixerMUTEMICR Property

Analog Mixer: MUTE (MICR)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AnalogMixerMUTEMICR { get; set; }
Public Property AnalogMixerMUTEMICR As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AnalogMixerMUTEMICR {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AnalogMixerMUTEMICR : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerSEDIFFMICL Property

IRD

Lm49350AnalogMixerSEDIFFMICL Property

Analog Mixer: SE_DIFF (MICL)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AnalogMixerSEDIFFMICL { get; set; }
Public Property AnalogMixerSEDIFFMICL As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AnalogMixerSEDIFFMICL {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AnalogMixerSEDIFFMICL : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AnalogMixerSEDIFFMICR Property

IRD

Lm49350AnalogMixerSEDIFFMICR Property

Analog Mixer: SE_DIFF (MICR)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AnalogMixerSEDIFFMICR { get; set; }
Public Property AnalogMixerSEDIFFMICR As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AnalogMixerSEDIFFMICR {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AnalogMixerSEDIFFMICR : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1CLKMS Property

IRD

Lm49350AudioPort1CLKMS Property

Audio Port 1: CLK_MS

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AudioPort1CLKMS { get; set; }
Public Property AudioPort1CLKMS As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AudioPort1CLKMS {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AudioPort1CLKMS : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1CLKPH Property

IRD

Lm49350AudioPort1CLKPH Property

Audio Port 1: CLK_PH

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortBasicClockPhase AudioPort1CLKPH { get; set; }
Public Property AudioPort1CLKPH As Lm49350TypeAudioPortBasicClockPhase
    Get
    Set
public:
property Lm49350TypeAudioPortBasicClockPhase AudioPort1CLKPH {
    Lm49350TypeAudioPortBasicClockPhase get ();
    void set (Lm49350TypeAudioPortBasicClockPhase value);
}
member AudioPort1CLKPH : Lm49350TypeAudioPortBasicClockPhase with get, set

Property Value

Type: Lm49350TypeAudioPortBasicClockPhase
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1CLOCKSEL Property

IRD

Lm49350AudioPort1CLOCKSEL Property

Audio Port 1: CLOCK_SEL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortClockSel AudioPort1CLOCKSEL { get; set; }
Public Property AudioPort1CLOCKSEL As Lm49350TypeAudioPortClockSel
    Get
    Set
public:
property Lm49350TypeAudioPortClockSel AudioPort1CLOCKSEL {
    Lm49350TypeAudioPortClockSel get ();
    void set (Lm49350TypeAudioPortClockSel value);
}
member AudioPort1CLOCKSEL : Lm49350TypeAudioPortClockSel with get, set

Property Value

Type: Lm49350TypeAudioPortClockSel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1COMPANDRX Property

IRD

Lm49350AudioPort1COMPANDRX Property

Audio Port 1: COMPAND (RX)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AudioPort1COMPANDRX { get; set; }
Public Property AudioPort1COMPANDRX As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AudioPort1COMPANDRX {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AudioPort1COMPANDRX : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1COMPANDTX Property

IRD

Lm49350AudioPort1COMPANDTX Property

Audio Port 1: COMPAND (TX)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AudioPort1COMPANDTX { get; set; }
Public Property AudioPort1COMPANDTX As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AudioPort1COMPANDTX {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AudioPort1COMPANDTX : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1HALFCYCLECLKDIV Property

IRD

Lm49350AudioPort1HALFCYCLECLKDIV Property

Audio Port 1: HALF_CYCLE_CLK_DIV

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortHalfCycleDivider AudioPort1HALFCYCLECLKDIV { get; set; }
Public Property AudioPort1HALFCYCLECLKDIV As Lm49350TypeAudioPortHalfCycleDivider
    Get
    Set
public:
property Lm49350TypeAudioPortHalfCycleDivider AudioPort1HALFCYCLECLKDIV {
    Lm49350TypeAudioPortHalfCycleDivider get ();
    void set (Lm49350TypeAudioPortHalfCycleDivider value);
}
member AudioPort1HALFCYCLECLKDIV : Lm49350TypeAudioPortHalfCycleDivider with get, set

Property Value

Type: Lm49350TypeAudioPortHalfCycleDivider
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1MSBPOSITIONRX Property

IRD

Lm49350AudioPort1MSBPOSITIONRX Property

Audio Port 1: MSB_POSITION (RX)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AudioPort1MSBPOSITIONRX { get; set; }
Public Property AudioPort1MSBPOSITIONRX As Byte
    Get
    Set
public:
property unsigned char AudioPort1MSBPOSITIONRX {
    unsigned char get ();
    void set (unsigned char value);
}
member AudioPort1MSBPOSITIONRX : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1MSBPOSITIONTX Property

IRD

Lm49350AudioPort1MSBPOSITIONTX Property

Audio Port 1: MSB_POSITION (TX)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AudioPort1MSBPOSITIONTX { get; set; }
Public Property AudioPort1MSBPOSITIONTX As Byte
    Get
    Set
public:
property unsigned char AudioPort1MSBPOSITIONTX {
    unsigned char get ();
    void set (unsigned char value);
}
member AudioPort1MSBPOSITIONTX : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1RXENB Property

IRD

Lm49350AudioPort1RXENB Property

Audio Port 1: RX_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AudioPort1RXENB { get; set; }
Public Property AudioPort1RXENB As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AudioPort1RXENB {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AudioPort1RXENB : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1RXMODE Property

IRD

Lm49350AudioPort1RXMODE Property

Audio Port 1: RX_MODE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortRxTxMode AudioPort1RXMODE { get; set; }
Public Property AudioPort1RXMODE As Lm49350TypeAudioPortRxTxMode
    Get
    Set
public:
property Lm49350TypeAudioPortRxTxMode AudioPort1RXMODE {
    Lm49350TypeAudioPortRxTxMode get ();
    void set (Lm49350TypeAudioPortRxTxMode value);
}
member AudioPort1RXMODE : Lm49350TypeAudioPortRxTxMode with get, set

Property Value

Type: Lm49350TypeAudioPortRxTxMode
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1RXWIDTH Property

IRD

Lm49350AudioPort1RXWIDTH Property

Audio Port 1: RX_WIDTH (unit: bits)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortRxTxWidth AudioPort1RXWIDTH { get; set; }
Public Property AudioPort1RXWIDTH As Lm49350TypeAudioPortRxTxWidth
    Get
    Set
public:
property Lm49350TypeAudioPortRxTxWidth AudioPort1RXWIDTH {
    Lm49350TypeAudioPortRxTxWidth get ();
    void set (Lm49350TypeAudioPortRxTxWidth value);
}
member AudioPort1RXWIDTH : Lm49350TypeAudioPortRxTxWidth with get, set

Property Value

Type: Lm49350TypeAudioPortRxTxWidth
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1STEREO Property

IRD

Lm49350AudioPort1STEREO Property

Audio Port 1: STEREO

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AudioPort1STEREO { get; set; }
Public Property AudioPort1STEREO As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AudioPort1STEREO {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AudioPort1STEREO : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1STEREOSYNCMODE Property

IRD

Lm49350AudioPort1STEREOSYNCMODE Property

Audio Port 1: STEREO_SYNC_MODE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AudioPort1STEREOSYNCMODE { get; set; }
Public Property AudioPort1STEREOSYNCMODE As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AudioPort1STEREOSYNCMODE {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AudioPort1STEREOSYNCMODE : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1STEREOSYNCPHASE Property

IRD

Lm49350AudioPort1STEREOSYNCPHASE Property

Audio Port 1: STEREO_SYNC_PHASE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AudioPort1STEREOSYNCPHASE { get; set; }
Public Property AudioPort1STEREOSYNCPHASE As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AudioPort1STEREOSYNCPHASE {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AudioPort1STEREOSYNCPHASE : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1SYNCMS Property

IRD

Lm49350AudioPort1SYNCMS Property

Audio Port 1: SYNC_MS

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AudioPort1SYNCMS { get; set; }
Public Property AudioPort1SYNCMS As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AudioPort1SYNCMS {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AudioPort1SYNCMS : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1SYNCRATE Property

IRD

Lm49350AudioPort1SYNCRATE Property

Audio Port 1: SYNC_RATE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortSyncRate AudioPort1SYNCRATE { get; set; }
Public Property AudioPort1SYNCRATE As Lm49350TypeAudioPortSyncRate
    Get
    Set
public:
property Lm49350TypeAudioPortSyncRate AudioPort1SYNCRATE {
    Lm49350TypeAudioPortSyncRate get ();
    void set (Lm49350TypeAudioPortSyncRate value);
}
member AudioPort1SYNCRATE : Lm49350TypeAudioPortSyncRate with get, set

Property Value

Type: Lm49350TypeAudioPortSyncRate
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1SYNCWIDTH Property

IRD

Lm49350AudioPort1SYNCWIDTH Property

Audio Port 1: SYNC_WIDTH (unit: bits)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortSyncWidth AudioPort1SYNCWIDTH { get; set; }
Public Property AudioPort1SYNCWIDTH As Lm49350TypeAudioPortSyncWidth
    Get
    Set
public:
property Lm49350TypeAudioPortSyncWidth AudioPort1SYNCWIDTH {
    Lm49350TypeAudioPortSyncWidth get ();
    void set (Lm49350TypeAudioPortSyncWidth value);
}
member AudioPort1SYNCWIDTH : Lm49350TypeAudioPortSyncWidth with get, set

Property Value

Type: Lm49350TypeAudioPortSyncWidth
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1SYNTHDENOM Property

IRD

Lm49350AudioPort1SYNTHDENOM Property

Audio Port 1: SYNTH_DENOM

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortSynthDenom AudioPort1SYNTHDENOM { get; set; }
Public Property AudioPort1SYNTHDENOM As Lm49350TypeAudioPortSynthDenom
    Get
    Set
public:
property Lm49350TypeAudioPortSynthDenom AudioPort1SYNTHDENOM {
    Lm49350TypeAudioPortSynthDenom get ();
    void set (Lm49350TypeAudioPortSynthDenom value);
}
member AudioPort1SYNTHDENOM : Lm49350TypeAudioPortSynthDenom with get, set

Property Value

Type: Lm49350TypeAudioPortSynthDenom
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1SYNTHNUM Property

IRD

Lm49350AudioPort1SYNTHNUM Property

Audio Port 1: SYNTH_NUM

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortSynthNum AudioPort1SYNTHNUM { get; set; }
Public Property AudioPort1SYNTHNUM As Lm49350TypeAudioPortSynthNum
    Get
    Set
public:
property Lm49350TypeAudioPortSynthNum AudioPort1SYNTHNUM {
    Lm49350TypeAudioPortSynthNum get ();
    void set (Lm49350TypeAudioPortSynthNum value);
}
member AudioPort1SYNTHNUM : Lm49350TypeAudioPortSynthNum with get, set

Property Value

Type: Lm49350TypeAudioPortSynthNum
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1TXENB Property

IRD

Lm49350AudioPort1TXENB Property

Audio Port 1: TX_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AudioPort1TXENB { get; set; }
Public Property AudioPort1TXENB As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AudioPort1TXENB {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AudioPort1TXENB : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1TXEXTRABITS Property

IRD

Lm49350AudioPort1TXEXTRABITS Property

Audio Port 1: TX_EXTRA_BITS

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortTxExtraBits AudioPort1TXEXTRABITS { get; set; }
Public Property AudioPort1TXEXTRABITS As Lm49350TypeAudioPortTxExtraBits
    Get
    Set
public:
property Lm49350TypeAudioPortTxExtraBits AudioPort1TXEXTRABITS {
    Lm49350TypeAudioPortTxExtraBits get ();
    void set (Lm49350TypeAudioPortTxExtraBits value);
}
member AudioPort1TXEXTRABITS : Lm49350TypeAudioPortTxExtraBits with get, set

Property Value

Type: Lm49350TypeAudioPortTxExtraBits
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1TXMODE Property

IRD

Lm49350AudioPort1TXMODE Property

Audio Port 1: TX_MODE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortRxTxMode AudioPort1TXMODE { get; set; }
Public Property AudioPort1TXMODE As Lm49350TypeAudioPortRxTxMode
    Get
    Set
public:
property Lm49350TypeAudioPortRxTxMode AudioPort1TXMODE {
    Lm49350TypeAudioPortRxTxMode get ();
    void set (Lm49350TypeAudioPortRxTxMode value);
}
member AudioPort1TXMODE : Lm49350TypeAudioPortRxTxMode with get, set

Property Value

Type: Lm49350TypeAudioPortRxTxMode
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1TXWIDTH Property

IRD

Lm49350AudioPort1TXWIDTH Property

Audio Port 1: TX_WIDTH (unit: bits)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortRxTxWidth AudioPort1TXWIDTH { get; set; }
Public Property AudioPort1TXWIDTH As Lm49350TypeAudioPortRxTxWidth
    Get
    Set
public:
property Lm49350TypeAudioPortRxTxWidth AudioPort1TXWIDTH {
    Lm49350TypeAudioPortRxTxWidth get ();
    void set (Lm49350TypeAudioPortRxTxWidth value);
}
member AudioPort1TXWIDTH : Lm49350TypeAudioPortRxTxWidth with get, set

Property Value

Type: Lm49350TypeAudioPortRxTxWidth
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1ΜLawALawRX Property

IRD

Lm49350AudioPort1ΜLawALawRX Property

Audio Port 1: μLaw/A-Law (RX)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortUlawAlaw AudioPort1ΜLawALawRX { get; set; }
Public Property AudioPort1ΜLawALawRX As Lm49350TypeAudioPortUlawAlaw
    Get
    Set
public:
property Lm49350TypeAudioPortUlawAlaw AudioPort1ΜLawALawRX {
    Lm49350TypeAudioPortUlawAlaw get ();
    void set (Lm49350TypeAudioPortUlawAlaw value);
}
member AudioPort1ΜLawALawRX : Lm49350TypeAudioPortUlawAlaw with get, set

Property Value

Type: Lm49350TypeAudioPortUlawAlaw
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort1ΜLawALawTX Property

IRD

Lm49350AudioPort1ΜLawALawTX Property

Audio Port 1: μLaw/A-Law (TX)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortUlawAlaw AudioPort1ΜLawALawTX { get; set; }
Public Property AudioPort1ΜLawALawTX As Lm49350TypeAudioPortUlawAlaw
    Get
    Set
public:
property Lm49350TypeAudioPortUlawAlaw AudioPort1ΜLawALawTX {
    Lm49350TypeAudioPortUlawAlaw get ();
    void set (Lm49350TypeAudioPortUlawAlaw value);
}
member AudioPort1ΜLawALawTX : Lm49350TypeAudioPortUlawAlaw with get, set

Property Value

Type: Lm49350TypeAudioPortUlawAlaw
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2CLKMS Property

IRD

Lm49350AudioPort2CLKMS Property

Audio Port 2: CLK_MS

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AudioPort2CLKMS { get; set; }
Public Property AudioPort2CLKMS As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AudioPort2CLKMS {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AudioPort2CLKMS : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2CLKPH Property

IRD

Lm49350AudioPort2CLKPH Property

Audio Port 2: CLK_PH

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortBasicClockPhase AudioPort2CLKPH { get; set; }
Public Property AudioPort2CLKPH As Lm49350TypeAudioPortBasicClockPhase
    Get
    Set
public:
property Lm49350TypeAudioPortBasicClockPhase AudioPort2CLKPH {
    Lm49350TypeAudioPortBasicClockPhase get ();
    void set (Lm49350TypeAudioPortBasicClockPhase value);
}
member AudioPort2CLKPH : Lm49350TypeAudioPortBasicClockPhase with get, set

Property Value

Type: Lm49350TypeAudioPortBasicClockPhase
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2CLOCKSEL Property

IRD

Lm49350AudioPort2CLOCKSEL Property

Audio Port 2: CLOCK_SEL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortClockSel AudioPort2CLOCKSEL { get; set; }
Public Property AudioPort2CLOCKSEL As Lm49350TypeAudioPortClockSel
    Get
    Set
public:
property Lm49350TypeAudioPortClockSel AudioPort2CLOCKSEL {
    Lm49350TypeAudioPortClockSel get ();
    void set (Lm49350TypeAudioPortClockSel value);
}
member AudioPort2CLOCKSEL : Lm49350TypeAudioPortClockSel with get, set

Property Value

Type: Lm49350TypeAudioPortClockSel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2COMPANDRX Property

IRD

Lm49350AudioPort2COMPANDRX Property

Audio Port 2: COMPAND (RX)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AudioPort2COMPANDRX { get; set; }
Public Property AudioPort2COMPANDRX As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AudioPort2COMPANDRX {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AudioPort2COMPANDRX : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2COMPANDTX Property

IRD

Lm49350AudioPort2COMPANDTX Property

Audio Port 2: COMPAND (TX)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AudioPort2COMPANDTX { get; set; }
Public Property AudioPort2COMPANDTX As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AudioPort2COMPANDTX {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AudioPort2COMPANDTX : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2HALFCYCLECLKDIV Property

IRD

Lm49350AudioPort2HALFCYCLECLKDIV Property

Audio Port 2: HALF_CYCLE_CLK_DIV

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortHalfCycleDivider AudioPort2HALFCYCLECLKDIV { get; set; }
Public Property AudioPort2HALFCYCLECLKDIV As Lm49350TypeAudioPortHalfCycleDivider
    Get
    Set
public:
property Lm49350TypeAudioPortHalfCycleDivider AudioPort2HALFCYCLECLKDIV {
    Lm49350TypeAudioPortHalfCycleDivider get ();
    void set (Lm49350TypeAudioPortHalfCycleDivider value);
}
member AudioPort2HALFCYCLECLKDIV : Lm49350TypeAudioPortHalfCycleDivider with get, set

Property Value

Type: Lm49350TypeAudioPortHalfCycleDivider
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2MSBPOSITIONRX Property

IRD

Lm49350AudioPort2MSBPOSITIONRX Property

Audio Port 2: MSB_POSITION (RX)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AudioPort2MSBPOSITIONRX { get; set; }
Public Property AudioPort2MSBPOSITIONRX As Byte
    Get
    Set
public:
property unsigned char AudioPort2MSBPOSITIONRX {
    unsigned char get ();
    void set (unsigned char value);
}
member AudioPort2MSBPOSITIONRX : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2MSBPOSITIONTX Property

IRD

Lm49350AudioPort2MSBPOSITIONTX Property

Audio Port 2: MSB_POSITION (TX)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AudioPort2MSBPOSITIONTX { get; set; }
Public Property AudioPort2MSBPOSITIONTX As Byte
    Get
    Set
public:
property unsigned char AudioPort2MSBPOSITIONTX {
    unsigned char get ();
    void set (unsigned char value);
}
member AudioPort2MSBPOSITIONTX : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2RXENB Property

IRD

Lm49350AudioPort2RXENB Property

Audio Port 2: RX_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AudioPort2RXENB { get; set; }
Public Property AudioPort2RXENB As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AudioPort2RXENB {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AudioPort2RXENB : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2RXMODE Property

IRD

Lm49350AudioPort2RXMODE Property

Audio Port 2: RX_MODE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortRxTxMode AudioPort2RXMODE { get; set; }
Public Property AudioPort2RXMODE As Lm49350TypeAudioPortRxTxMode
    Get
    Set
public:
property Lm49350TypeAudioPortRxTxMode AudioPort2RXMODE {
    Lm49350TypeAudioPortRxTxMode get ();
    void set (Lm49350TypeAudioPortRxTxMode value);
}
member AudioPort2RXMODE : Lm49350TypeAudioPortRxTxMode with get, set

Property Value

Type: Lm49350TypeAudioPortRxTxMode
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2RXWIDTH Property

IRD

Lm49350AudioPort2RXWIDTH Property

Audio Port 2: RX_WIDTH (unit: bits)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortRxTxWidth AudioPort2RXWIDTH { get; set; }
Public Property AudioPort2RXWIDTH As Lm49350TypeAudioPortRxTxWidth
    Get
    Set
public:
property Lm49350TypeAudioPortRxTxWidth AudioPort2RXWIDTH {
    Lm49350TypeAudioPortRxTxWidth get ();
    void set (Lm49350TypeAudioPortRxTxWidth value);
}
member AudioPort2RXWIDTH : Lm49350TypeAudioPortRxTxWidth with get, set

Property Value

Type: Lm49350TypeAudioPortRxTxWidth
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2STEREO Property

IRD

Lm49350AudioPort2STEREO Property

Audio Port 2: STEREO

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AudioPort2STEREO { get; set; }
Public Property AudioPort2STEREO As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AudioPort2STEREO {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AudioPort2STEREO : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2STEREOSYNCMODE Property

IRD

Lm49350AudioPort2STEREOSYNCMODE Property

Audio Port 2: STEREO_SYNC_MODE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AudioPort2STEREOSYNCMODE { get; set; }
Public Property AudioPort2STEREOSYNCMODE As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AudioPort2STEREOSYNCMODE {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AudioPort2STEREOSYNCMODE : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2STEREOSYNCPHASE Property

IRD

Lm49350AudioPort2STEREOSYNCPHASE Property

Audio Port 2: STEREO_SYNC_PHASE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AudioPort2STEREOSYNCPHASE { get; set; }
Public Property AudioPort2STEREOSYNCPHASE As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AudioPort2STEREOSYNCPHASE {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AudioPort2STEREOSYNCPHASE : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2SYNCMS Property

IRD

Lm49350AudioPort2SYNCMS Property

Audio Port 2: SYNC_MS

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AudioPort2SYNCMS { get; set; }
Public Property AudioPort2SYNCMS As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AudioPort2SYNCMS {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AudioPort2SYNCMS : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2SYNCRATE Property

IRD

Lm49350AudioPort2SYNCRATE Property

Audio Port 2: SYNC_RATE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortSyncRate AudioPort2SYNCRATE { get; set; }
Public Property AudioPort2SYNCRATE As Lm49350TypeAudioPortSyncRate
    Get
    Set
public:
property Lm49350TypeAudioPortSyncRate AudioPort2SYNCRATE {
    Lm49350TypeAudioPortSyncRate get ();
    void set (Lm49350TypeAudioPortSyncRate value);
}
member AudioPort2SYNCRATE : Lm49350TypeAudioPortSyncRate with get, set

Property Value

Type: Lm49350TypeAudioPortSyncRate
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2SYNCWIDTH Property

IRD

Lm49350AudioPort2SYNCWIDTH Property

Audio Port 2: SYNC_WIDTH (unit: bits)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortSyncWidth AudioPort2SYNCWIDTH { get; set; }
Public Property AudioPort2SYNCWIDTH As Lm49350TypeAudioPortSyncWidth
    Get
    Set
public:
property Lm49350TypeAudioPortSyncWidth AudioPort2SYNCWIDTH {
    Lm49350TypeAudioPortSyncWidth get ();
    void set (Lm49350TypeAudioPortSyncWidth value);
}
member AudioPort2SYNCWIDTH : Lm49350TypeAudioPortSyncWidth with get, set

Property Value

Type: Lm49350TypeAudioPortSyncWidth
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2SYNTHDENOM Property

IRD

Lm49350AudioPort2SYNTHDENOM Property

Audio Port 2: SYNTH_DENOM

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortSynthDenom AudioPort2SYNTHDENOM { get; set; }
Public Property AudioPort2SYNTHDENOM As Lm49350TypeAudioPortSynthDenom
    Get
    Set
public:
property Lm49350TypeAudioPortSynthDenom AudioPort2SYNTHDENOM {
    Lm49350TypeAudioPortSynthDenom get ();
    void set (Lm49350TypeAudioPortSynthDenom value);
}
member AudioPort2SYNTHDENOM : Lm49350TypeAudioPortSynthDenom with get, set

Property Value

Type: Lm49350TypeAudioPortSynthDenom
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2SYNTHNUM Property

IRD

Lm49350AudioPort2SYNTHNUM Property

Audio Port 2: SYNTH_NUM

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortSynthNum AudioPort2SYNTHNUM { get; set; }
Public Property AudioPort2SYNTHNUM As Lm49350TypeAudioPortSynthNum
    Get
    Set
public:
property Lm49350TypeAudioPortSynthNum AudioPort2SYNTHNUM {
    Lm49350TypeAudioPortSynthNum get ();
    void set (Lm49350TypeAudioPortSynthNum value);
}
member AudioPort2SYNTHNUM : Lm49350TypeAudioPortSynthNum with get, set

Property Value

Type: Lm49350TypeAudioPortSynthNum
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2TXENB Property

IRD

Lm49350AudioPort2TXENB Property

Audio Port 2: TX_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet AudioPort2TXENB { get; set; }
Public Property AudioPort2TXENB As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet AudioPort2TXENB {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member AudioPort2TXENB : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2TXEXTRABITS Property

IRD

Lm49350AudioPort2TXEXTRABITS Property

Audio Port 2: TX_EXTRA_BITS

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortTxExtraBits AudioPort2TXEXTRABITS { get; set; }
Public Property AudioPort2TXEXTRABITS As Lm49350TypeAudioPortTxExtraBits
    Get
    Set
public:
property Lm49350TypeAudioPortTxExtraBits AudioPort2TXEXTRABITS {
    Lm49350TypeAudioPortTxExtraBits get ();
    void set (Lm49350TypeAudioPortTxExtraBits value);
}
member AudioPort2TXEXTRABITS : Lm49350TypeAudioPortTxExtraBits with get, set

Property Value

Type: Lm49350TypeAudioPortTxExtraBits
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2TXMODE Property

IRD

Lm49350AudioPort2TXMODE Property

Audio Port 2: TX_MODE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortRxTxMode AudioPort2TXMODE { get; set; }
Public Property AudioPort2TXMODE As Lm49350TypeAudioPortRxTxMode
    Get
    Set
public:
property Lm49350TypeAudioPortRxTxMode AudioPort2TXMODE {
    Lm49350TypeAudioPortRxTxMode get ();
    void set (Lm49350TypeAudioPortRxTxMode value);
}
member AudioPort2TXMODE : Lm49350TypeAudioPortRxTxMode with get, set

Property Value

Type: Lm49350TypeAudioPortRxTxMode
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2TXWIDTH Property

IRD

Lm49350AudioPort2TXWIDTH Property

Audio Port 2: TX_WIDTH (unit: bits)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortRxTxWidth AudioPort2TXWIDTH { get; set; }
Public Property AudioPort2TXWIDTH As Lm49350TypeAudioPortRxTxWidth
    Get
    Set
public:
property Lm49350TypeAudioPortRxTxWidth AudioPort2TXWIDTH {
    Lm49350TypeAudioPortRxTxWidth get ();
    void set (Lm49350TypeAudioPortRxTxWidth value);
}
member AudioPort2TXWIDTH : Lm49350TypeAudioPortRxTxWidth with get, set

Property Value

Type: Lm49350TypeAudioPortRxTxWidth
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2ΜLawALawRX Property

IRD

Lm49350AudioPort2ΜLawALawRX Property

Audio Port 2: μLaw/A-Law (RX)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortUlawAlaw AudioPort2ΜLawALawRX { get; set; }
Public Property AudioPort2ΜLawALawRX As Lm49350TypeAudioPortUlawAlaw
    Get
    Set
public:
property Lm49350TypeAudioPortUlawAlaw AudioPort2ΜLawALawRX {
    Lm49350TypeAudioPortUlawAlaw get ();
    void set (Lm49350TypeAudioPortUlawAlaw value);
}
member AudioPort2ΜLawALawRX : Lm49350TypeAudioPortUlawAlaw with get, set

Property Value

Type: Lm49350TypeAudioPortUlawAlaw
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AudioPort2ΜLawALawTX Property

IRD

Lm49350AudioPort2ΜLawALawTX Property

Audio Port 2: μLaw/A-Law (TX)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAudioPortUlawAlaw AudioPort2ΜLawALawTX { get; set; }
Public Property AudioPort2ΜLawALawTX As Lm49350TypeAudioPortUlawAlaw
    Get
    Set
public:
property Lm49350TypeAudioPortUlawAlaw AudioPort2ΜLawALawTX {
    Lm49350TypeAudioPortUlawAlaw get ();
    void set (Lm49350TypeAudioPortUlawAlaw value);
}
member AudioPort2ΜLawALawTX : Lm49350TypeAudioPortUlawAlaw with get, set

Property Value

Type: Lm49350TypeAudioPortUlawAlaw
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.AutoFlush Property

IRD

Lm49350AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.BasicSetupCHIPACTIVE Property

IRD

Lm49350BasicSetupCHIPACTIVE Property

Basic Setup: CHIP_ACTIVE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePmcSetupChipActive BasicSetupCHIPACTIVE { get; }
Public ReadOnly Property BasicSetupCHIPACTIVE As Lm49350TypePmcSetupChipActive
    Get
public:
property Lm49350TypePmcSetupChipActive BasicSetupCHIPACTIVE {
    Lm49350TypePmcSetupChipActive get ();
}
member BasicSetupCHIPACTIVE : Lm49350TypePmcSetupChipActive with get

Property Value

Type: Lm49350TypePmcSetupChipActive
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.BasicSetupCHIPENABLE Property

IRD

Lm49350BasicSetupCHIPENABLE Property

Basic Setup: CHIP_ENABLE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePmcSetupChipEnable BasicSetupCHIPENABLE { get; set; }
Public Property BasicSetupCHIPENABLE As Lm49350TypePmcSetupChipEnable
    Get
    Set
public:
property Lm49350TypePmcSetupChipEnable BasicSetupCHIPENABLE {
    Lm49350TypePmcSetupChipEnable get ();
    void set (Lm49350TypePmcSetupChipEnable value);
}
member BasicSetupCHIPENABLE : Lm49350TypePmcSetupChipEnable with get, set

Property Value

Type: Lm49350TypePmcSetupChipEnable
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.BasicSetupMCLKOVR Property

IRD

Lm49350BasicSetupMCLKOVR Property

Basic Setup: MCLK_OVR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePmcSetupMclkOvr BasicSetupMCLKOVR { get; set; }
Public Property BasicSetupMCLKOVR As Lm49350TypePmcSetupMclkOvr
    Get
    Set
public:
property Lm49350TypePmcSetupMclkOvr BasicSetupMCLKOVR {
    Lm49350TypePmcSetupMclkOvr get ();
    void set (Lm49350TypePmcSetupMclkOvr value);
}
member BasicSetupMCLKOVR : Lm49350TypePmcSetupMclkOvr with get, set

Property Value

Type: Lm49350TypePmcSetupMclkOvr
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.BasicSetupOSCENB Property

IRD

Lm49350BasicSetupOSCENB Property

Basic Setup: OSC_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePmcSetupOscEnb BasicSetupOSCENB { get; set; }
Public Property BasicSetupOSCENB As Lm49350TypePmcSetupOscEnb
    Get
    Set
public:
property Lm49350TypePmcSetupOscEnb BasicSetupOSCENB {
    Lm49350TypePmcSetupOscEnb get ();
    void set (Lm49350TypePmcSetupOscEnb value);
}
member BasicSetupOSCENB : Lm49350TypePmcSetupOscEnb with get, set

Property Value

Type: Lm49350TypePmcSetupOscEnb
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.BasicSetupPLL1ENB Property

IRD

Lm49350BasicSetupPLL1ENB Property

Basic Setup: PLL1_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePmcSetupPll1Enb BasicSetupPLL1ENB { get; set; }
Public Property BasicSetupPLL1ENB As Lm49350TypePmcSetupPll1Enb
    Get
    Set
public:
property Lm49350TypePmcSetupPll1Enb BasicSetupPLL1ENB {
    Lm49350TypePmcSetupPll1Enb get ();
    void set (Lm49350TypePmcSetupPll1Enb value);
}
member BasicSetupPLL1ENB : Lm49350TypePmcSetupPll1Enb with get, set

Property Value

Type: Lm49350TypePmcSetupPll1Enb
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.BasicSetupPLL2ENB Property

IRD

Lm49350BasicSetupPLL2ENB Property

Basic Setup: PLL2_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePmcSetupPll2Enb BasicSetupPLL2ENB { get; set; }
Public Property BasicSetupPLL2ENB As Lm49350TypePmcSetupPll2Enb
    Get
    Set
public:
property Lm49350TypePmcSetupPll2Enb BasicSetupPLL2ENB {
    Lm49350TypePmcSetupPll2Enb get ();
    void set (Lm49350TypePmcSetupPll2Enb value);
}
member BasicSetupPLL2ENB : Lm49350TypePmcSetupPll2Enb with get, set

Property Value

Type: Lm49350TypePmcSetupPll2Enb
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.BasicSetupPMCCLKDIV Property

IRD

Lm49350BasicSetupPMCCLKDIV Property

Basic Setup: PMC_CLK_DIV

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeClkDiv BasicSetupPMCCLKDIV { get; set; }
Public Property BasicSetupPMCCLKDIV As Lm49350TypeClkDiv
    Get
    Set
public:
property Lm49350TypeClkDiv BasicSetupPMCCLKDIV {
    Lm49350TypeClkDiv get ();
    void set (Lm49350TypeClkDiv value);
}
member BasicSetupPMCCLKDIV : Lm49350TypeClkDiv with get, set

Property Value

Type: Lm49350TypeClkDiv
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.BasicSetupPMCCLKSEL Property

IRD

Lm49350BasicSetupPMCCLKSEL Property

Basic Setup: PMC_CLK_SEL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePmcClocks BasicSetupPMCCLKSEL { get; set; }
Public Property BasicSetupPMCCLKSEL As Lm49350TypePmcClocks
    Get
    Set
public:
property Lm49350TypePmcClocks BasicSetupPMCCLKSEL {
    Lm49350TypePmcClocks get ();
    void set (Lm49350TypePmcClocks value);
}
member BasicSetupPMCCLKSEL : Lm49350TypePmcClocks with get, set

Property Value

Type: Lm49350TypePmcClocks
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.BasicSetupPORT1CLKOVR Property

IRD

Lm49350BasicSetupPORT1CLKOVR Property

Basic Setup: PORT1_CLK_OVR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePmcSetupPortClkOvr BasicSetupPORT1CLKOVR { get; set; }
Public Property BasicSetupPORT1CLKOVR As Lm49350TypePmcSetupPortClkOvr
    Get
    Set
public:
property Lm49350TypePmcSetupPortClkOvr BasicSetupPORT1CLKOVR {
    Lm49350TypePmcSetupPortClkOvr get ();
    void set (Lm49350TypePmcSetupPortClkOvr value);
}
member BasicSetupPORT1CLKOVR : Lm49350TypePmcSetupPortClkOvr with get, set

Property Value

Type: Lm49350TypePmcSetupPortClkOvr
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.BasicSetupPORT2CLKOVR Property

IRD

Lm49350BasicSetupPORT2CLKOVR Property

Basic Setup: PORT2_CLK_OVR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePmcSetupPortClkOvr BasicSetupPORT2CLKOVR { get; set; }
Public Property BasicSetupPORT2CLKOVR As Lm49350TypePmcSetupPortClkOvr
    Get
    Set
public:
property Lm49350TypePmcSetupPortClkOvr BasicSetupPORT2CLKOVR {
    Lm49350TypePmcSetupPortClkOvr get ();
    void set (Lm49350TypePmcSetupPortClkOvr value);
}
member BasicSetupPORT2CLKOVR : Lm49350TypePmcSetupPortClkOvr with get, set

Property Value

Type: Lm49350TypePmcSetupPortClkOvr
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACDACCLKDIV Property

IRD

Lm49350DACDACCLKDIV Property

DAC: DAC_CLK_DIV

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeClkDiv DACDACCLKDIV { get; set; }
Public Property DACDACCLKDIV As Lm49350TypeClkDiv
    Get
    Set
public:
property Lm49350TypeClkDiv DACDACCLKDIV {
    Lm49350TypeClkDiv get ();
    void set (Lm49350TypeClkDiv value);
}
member DACDACCLKDIV : Lm49350TypeClkDiv with get, set

Property Value

Type: Lm49350TypeClkDiv
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACDACCLKSEL Property

IRD

Lm49350DACDACCLKSEL Property

DAC: DAC_CLK_SEL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeClkSel DACDACCLKSEL { get; set; }
Public Property DACDACCLKSEL As Lm49350TypeClkSel
    Get
    Set
public:
property Lm49350TypeClkSel DACDACCLKSEL {
    Lm49350TypeClkSel get ();
    void set (Lm49350TypeClkSel value);
}
member DACDACCLKSEL : Lm49350TypeClkSel with get, set

Property Value

Type: Lm49350TypeClkSel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACDACTRIM Property

IRD

Lm49350DACDACTRIM Property

DAC: DAC_TRIM

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACDACTRIM { get; set; }
Public Property DACDACTRIM As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACDACTRIM {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACDACTRIM : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACDSPONLY Property

IRD

Lm49350DACDSPONLY Property

DAC: DSP_ONLY

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACDSPONLY { get; set; }
Public Property DACDSPONLY As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACDSPONLY {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACDSPONLY : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitors3DLCLIP Property

IRD

Lm49350DACEffectMonitors3DLCLIP Property

DAC Effect Monitors: 3D_L_CLIP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACEffectMonitors3DLCLIP { get; set; }
Public Property DACEffectMonitors3DLCLIP As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACEffectMonitors3DLCLIP {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACEffectMonitors3DLCLIP : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitors3DRCLIP Property

IRD

Lm49350DACEffectMonitors3DRCLIP Property

DAC Effect Monitors: 3D_R_CLIP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACEffectMonitors3DRCLIP { get; set; }
Public Property DACEffectMonitors3DRCLIP As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACEffectMonitors3DRCLIP {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACEffectMonitors3DRCLIP : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitorsALCMONL Property

IRD

Lm49350DACEffectMonitorsALCMONL Property

DAC Effect Monitors: ALCMONL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACEffectMonitorsALCMONL { get; set; }
Public Property DACEffectMonitorsALCMONL As Byte
    Get
    Set
public:
property unsigned char DACEffectMonitorsALCMONL {
    unsigned char get ();
    void set (unsigned char value);
}
member DACEffectMonitorsALCMONL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitorsALCMONR Property

IRD

Lm49350DACEffectMonitorsALCMONR Property

DAC Effect Monitors: ALCMONR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACEffectMonitorsALCMONR { get; set; }
Public Property DACEffectMonitorsALCMONR As Byte
    Get
    Set
public:
property unsigned char DACEffectMonitorsALCMONR {
    unsigned char get ();
    void set (unsigned char value);
}
member DACEffectMonitorsALCMONR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitorsATTEN Property

IRD

Lm49350DACEffectMonitorsATTEN Property

DAC Effect Monitors: ATTEN

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACEffectMonitorsATTEN { get; set; }
Public Property DACEffectMonitorsATTEN As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACEffectMonitorsATTEN {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACEffectMonitorsATTEN : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitorsEFFECTLEVEL Property

IRD

Lm49350DACEffectMonitorsEFFECTLEVEL Property

DAC Effect Monitors: EFFECT_LEVEL (unit: %)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDacEffects3dEffectLevel DACEffectMonitorsEFFECTLEVEL { get; set; }
Public Property DACEffectMonitorsEFFECTLEVEL As Lm49350TypeDacEffects3dEffectLevel
    Get
    Set
public:
property Lm49350TypeDacEffects3dEffectLevel DACEffectMonitorsEFFECTLEVEL {
    Lm49350TypeDacEffects3dEffectLevel get ();
    void set (Lm49350TypeDacEffects3dEffectLevel value);
}
member DACEffectMonitorsEFFECTLEVEL : Lm49350TypeDacEffects3dEffectLevel with get, set

Property Value

Type: Lm49350TypeDacEffects3dEffectLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitorsEFFECTMODE Property

IRD

Lm49350DACEffectMonitorsEFFECTMODE Property

DAC Effect Monitors: EFFECT_MODE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDacEffects3dEffectMode DACEffectMonitorsEFFECTMODE { get; set; }
Public Property DACEffectMonitorsEFFECTMODE As Lm49350TypeDacEffects3dEffectMode
    Get
    Set
public:
property Lm49350TypeDacEffects3dEffectMode DACEffectMonitorsEFFECTMODE {
    Lm49350TypeDacEffects3dEffectMode get ();
    void set (Lm49350TypeDacEffects3dEffectMode value);
}
member DACEffectMonitorsEFFECTMODE : Lm49350TypeDacEffects3dEffectMode with get, set

Property Value

Type: Lm49350TypeDacEffects3dEffectMode
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitorsEQLCLIP Property

IRD

Lm49350DACEffectMonitorsEQLCLIP Property

DAC Effect Monitors: EQ_L_CLIP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACEffectMonitorsEQLCLIP { get; set; }
Public Property DACEffectMonitorsEQLCLIP As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACEffectMonitorsEQLCLIP {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACEffectMonitorsEQLCLIP : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitorsEQRCLIP Property

IRD

Lm49350DACEffectMonitorsEQRCLIP Property

DAC Effect Monitors: EQ_R_CLIP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACEffectMonitorsEQRCLIP { get; set; }
Public Property DACEffectMonitorsEQRCLIP As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACEffectMonitorsEQRCLIP {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACEffectMonitorsEQRCLIP : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitorsFILTERTYPE Property

IRD

Lm49350DACEffectMonitorsFILTERTYPE Property

DAC Effect Monitors: FILTER_TYPE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDacEffects3dFilterType DACEffectMonitorsFILTERTYPE { get; set; }
Public Property DACEffectMonitorsFILTERTYPE As Lm49350TypeDacEffects3dFilterType
    Get
    Set
public:
property Lm49350TypeDacEffects3dFilterType DACEffectMonitorsFILTERTYPE {
    Lm49350TypeDacEffects3dFilterType get ();
    void set (Lm49350TypeDacEffects3dFilterType value);
}
member DACEffectMonitorsFILTERTYPE : Lm49350TypeDacEffects3dFilterType with get, set

Property Value

Type: Lm49350TypeDacEffects3dFilterType
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitorsGAINLCLIP Property

IRD

Lm49350DACEffectMonitorsGAINLCLIP Property

DAC Effect Monitors: GAIN_L_CLIP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACEffectMonitorsGAINLCLIP { get; set; }
Public Property DACEffectMonitorsGAINLCLIP As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACEffectMonitorsGAINLCLIP {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACEffectMonitorsGAINLCLIP : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitorsGAINRCLIP Property

IRD

Lm49350DACEffectMonitorsGAINRCLIP Property

DAC Effect Monitors: GAIN_R_CLIP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACEffectMonitorsGAINRCLIP { get; set; }
Public Property DACEffectMonitorsGAINRCLIP As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACEffectMonitorsGAINRCLIP {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACEffectMonitorsGAINRCLIP : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitorsLVLMONL Property

IRD

Lm49350DACEffectMonitorsLVLMONL Property

DAC Effect Monitors: LVLMONL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACEffectMonitorsLVLMONL { get; set; }
Public Property DACEffectMonitorsLVLMONL As Byte
    Get
    Set
public:
property unsigned char DACEffectMonitorsLVLMONL {
    unsigned char get ();
    void set (unsigned char value);
}
member DACEffectMonitorsLVLMONL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitorsLVLMONR Property

IRD

Lm49350DACEffectMonitorsLVLMONR Property

DAC Effect Monitors: LVLMONR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACEffectMonitorsLVLMONR { get; set; }
Public Property DACEffectMonitorsLVLMONR As Byte
    Get
    Set
public:
property unsigned char DACEffectMonitorsLVLMONR {
    unsigned char get ();
    void set (unsigned char value);
}
member DACEffectMonitorsLVLMONR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitorsSCLPLCLIP Property

IRD

Lm49350DACEffectMonitorsSCLPLCLIP Property

DAC Effect Monitors: SCLP_L_CLIP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACEffectMonitorsSCLPLCLIP { get; set; }
Public Property DACEffectMonitorsSCLPLCLIP As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACEffectMonitorsSCLPLCLIP {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACEffectMonitorsSCLPLCLIP : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitorsSCLPLDISTORTALCMONL Property

IRD

Lm49350DACEffectMonitorsSCLPLDISTORTALCMONL Property

DAC Effect Monitors: SCLP_L_DISTORT (ALCMONL)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACEffectMonitorsSCLPLDISTORTALCMONL { get; set; }
Public Property DACEffectMonitorsSCLPLDISTORTALCMONL As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACEffectMonitorsSCLPLDISTORTALCMONL {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACEffectMonitorsSCLPLDISTORTALCMONL : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitorsSCLPLDISTORTALCMONR Property

IRD

Lm49350DACEffectMonitorsSCLPLDISTORTALCMONR Property

DAC Effect Monitors: SCLP_L_DISTORT (ALCMONR)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACEffectMonitorsSCLPLDISTORTALCMONR { get; set; }
Public Property DACEffectMonitorsSCLPLDISTORTALCMONR As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACEffectMonitorsSCLPLDISTORTALCMONR {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACEffectMonitorsSCLPLDISTORTALCMONR : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitorsSCLPRCLIP Property

IRD

Lm49350DACEffectMonitorsSCLPRCLIP Property

DAC Effect Monitors: SCLP_R_CLIP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACEffectMonitorsSCLPRCLIP { get; set; }
Public Property DACEffectMonitorsSCLPRCLIP As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACEffectMonitorsSCLPRCLIP {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACEffectMonitorsSCLPRCLIP : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitorsSCLPRDISTORTALCMONL Property

IRD

Lm49350DACEffectMonitorsSCLPRDISTORTALCMONL Property

DAC Effect Monitors: SCLP_R_DISTORT (ALCMONL)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACEffectMonitorsSCLPRDISTORTALCMONL { get; set; }
Public Property DACEffectMonitorsSCLPRDISTORTALCMONL As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACEffectMonitorsSCLPRDISTORTALCMONL {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACEffectMonitorsSCLPRDISTORTALCMONL : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectMonitorsSCLPRDISTORTALCMONR Property

IRD

Lm49350DACEffectMonitorsSCLPRDISTORTALCMONR Property

DAC Effect Monitors: SCLP_R_DISTORT (ALCMONR)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACEffectMonitorsSCLPRDISTORTALCMONR { get; set; }
Public Property DACEffectMonitorsSCLPRDISTORTALCMONR As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACEffectMonitorsSCLPRDISTORTALCMONR {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACEffectMonitorsSCLPRDISTORTALCMONR : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsATTACKRATE Property

IRD

Lm49350DACEffectsATTACKRATE Property

DAC Effects: ATTACK_RATE (unit: μs)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsAttackRate DACEffectsATTACKRATE { get; set; }
Public Property DACEffectsATTACKRATE As Lm49350TypeAdcEffectsAttackRate
    Get
    Set
public:
property Lm49350TypeAdcEffectsAttackRate DACEffectsATTACKRATE {
    Lm49350TypeAdcEffectsAttackRate get ();
    void set (Lm49350TypeAdcEffectsAttackRate value);
}
member DACEffectsATTACKRATE : Lm49350TypeAdcEffectsAttackRate with get, set

Property Value

Type: Lm49350TypeAdcEffectsAttackRate
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsDACLLEVEL Property

IRD

Lm49350DACEffectsDACLLEVEL Property

DAC Effects: DAC_L_LEVEL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsAdcLevel DACEffectsDACLLEVEL { get; set; }
Public Property DACEffectsDACLLEVEL As Lm49350TypeAdcEffectsAdcLevel
    Get
    Set
public:
property Lm49350TypeAdcEffectsAdcLevel DACEffectsDACLLEVEL {
    Lm49350TypeAdcEffectsAdcLevel get ();
    void set (Lm49350TypeAdcEffectsAdcLevel value);
}
member DACEffectsDACLLEVEL : Lm49350TypeAdcEffectsAdcLevel with get, set

Property Value

Type: Lm49350TypeAdcEffectsAdcLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsDACRLEVEL Property

IRD

Lm49350DACEffectsDACRLEVEL Property

DAC Effects: DAC_R_LEVEL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsAdcLevel DACEffectsDACRLEVEL { get; set; }
Public Property DACEffectsDACRLEVEL As Lm49350TypeAdcEffectsAdcLevel
    Get
    Set
public:
property Lm49350TypeAdcEffectsAdcLevel DACEffectsDACRLEVEL {
    Lm49350TypeAdcEffectsAdcLevel get ();
    void set (Lm49350TypeAdcEffectsAdcLevel value);
}
member DACEffectsDACRLEVEL : Lm49350TypeAdcEffectsAdcLevel with get, set

Property Value

Type: Lm49350TypeAdcEffectsAdcLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsDECAYRATERELEASERATE Property

IRD

Lm49350DACEffectsDECAYRATERELEASERATE Property

DAC Effects: DECAY_RATE/RELEASE_RATE (unit: μs)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsDecayRate DACEffectsDECAYRATERELEASERATE { get; set; }
Public Property DACEffectsDECAYRATERELEASERATE As Lm49350TypeAdcEffectsDecayRate
    Get
    Set
public:
property Lm49350TypeAdcEffectsDecayRate DACEffectsDECAYRATERELEASERATE {
    Lm49350TypeAdcEffectsDecayRate get ();
    void set (Lm49350TypeAdcEffectsDecayRate value);
}
member DACEffectsDECAYRATERELEASERATE : Lm49350TypeAdcEffectsDecayRate with get, set

Property Value

Type: Lm49350TypeAdcEffectsDecayRate
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsEQBAND1FREQ Property

IRD

Lm49350DACEffectsEQBAND1FREQ Property

DAC Effects: EQ_BAND_1 (FREQ) (unit: Hz)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEq1Freq DACEffectsEQBAND1FREQ { get; set; }
Public Property DACEffectsEQBAND1FREQ As Lm49350TypeAdcEffectsEq1Freq
    Get
    Set
public:
property Lm49350TypeAdcEffectsEq1Freq DACEffectsEQBAND1FREQ {
    Lm49350TypeAdcEffectsEq1Freq get ();
    void set (Lm49350TypeAdcEffectsEq1Freq value);
}
member DACEffectsEQBAND1FREQ : Lm49350TypeAdcEffectsEq1Freq with get, set

Property Value

Type: Lm49350TypeAdcEffectsEq1Freq
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsEQBAND1LEVEL Property

IRD

Lm49350DACEffectsEQBAND1LEVEL Property

DAC Effects: EQ_BAND_1 (LEVEL) (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEqLevel DACEffectsEQBAND1LEVEL { get; set; }
Public Property DACEffectsEQBAND1LEVEL As Lm49350TypeAdcEffectsEqLevel
    Get
    Set
public:
property Lm49350TypeAdcEffectsEqLevel DACEffectsEQBAND1LEVEL {
    Lm49350TypeAdcEffectsEqLevel get ();
    void set (Lm49350TypeAdcEffectsEqLevel value);
}
member DACEffectsEQBAND1LEVEL : Lm49350TypeAdcEffectsEqLevel with get, set

Property Value

Type: Lm49350TypeAdcEffectsEqLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsEQBAND2FREQ Property

IRD

Lm49350DACEffectsEQBAND2FREQ Property

DAC Effects: EQ_BAND_2 (FREQ) (unit: Hz)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEq2Freq DACEffectsEQBAND2FREQ { get; set; }
Public Property DACEffectsEQBAND2FREQ As Lm49350TypeAdcEffectsEq2Freq
    Get
    Set
public:
property Lm49350TypeAdcEffectsEq2Freq DACEffectsEQBAND2FREQ {
    Lm49350TypeAdcEffectsEq2Freq get ();
    void set (Lm49350TypeAdcEffectsEq2Freq value);
}
member DACEffectsEQBAND2FREQ : Lm49350TypeAdcEffectsEq2Freq with get, set

Property Value

Type: Lm49350TypeAdcEffectsEq2Freq
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsEQBAND2LEVEL Property

IRD

Lm49350DACEffectsEQBAND2LEVEL Property

DAC Effects: EQ_BAND_2 (LEVEL) (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEqLevel DACEffectsEQBAND2LEVEL { get; set; }
Public Property DACEffectsEQBAND2LEVEL As Lm49350TypeAdcEffectsEqLevel
    Get
    Set
public:
property Lm49350TypeAdcEffectsEqLevel DACEffectsEQBAND2LEVEL {
    Lm49350TypeAdcEffectsEqLevel get ();
    void set (Lm49350TypeAdcEffectsEqLevel value);
}
member DACEffectsEQBAND2LEVEL : Lm49350TypeAdcEffectsEqLevel with get, set

Property Value

Type: Lm49350TypeAdcEffectsEqLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsEQBAND2Q Property

IRD

Lm49350DACEffectsEQBAND2Q Property

DAC Effects: EQ_BAND_2 (Q) (unit: Octave)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEqQ DACEffectsEQBAND2Q { get; set; }
Public Property DACEffectsEQBAND2Q As Lm49350TypeAdcEffectsEqQ
    Get
    Set
public:
property Lm49350TypeAdcEffectsEqQ DACEffectsEQBAND2Q {
    Lm49350TypeAdcEffectsEqQ get ();
    void set (Lm49350TypeAdcEffectsEqQ value);
}
member DACEffectsEQBAND2Q : Lm49350TypeAdcEffectsEqQ with get, set

Property Value

Type: Lm49350TypeAdcEffectsEqQ
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsEQBAND3FREQ Property

IRD

Lm49350DACEffectsEQBAND3FREQ Property

DAC Effects: EQ_BAND_3 (FREQ) (unit: Hz)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEq3Freq DACEffectsEQBAND3FREQ { get; set; }
Public Property DACEffectsEQBAND3FREQ As Lm49350TypeAdcEffectsEq3Freq
    Get
    Set
public:
property Lm49350TypeAdcEffectsEq3Freq DACEffectsEQBAND3FREQ {
    Lm49350TypeAdcEffectsEq3Freq get ();
    void set (Lm49350TypeAdcEffectsEq3Freq value);
}
member DACEffectsEQBAND3FREQ : Lm49350TypeAdcEffectsEq3Freq with get, set

Property Value

Type: Lm49350TypeAdcEffectsEq3Freq
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsEQBAND3LEVEL Property

IRD

Lm49350DACEffectsEQBAND3LEVEL Property

DAC Effects: EQ_BAND_3 (LEVEL) (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEqLevel DACEffectsEQBAND3LEVEL { get; set; }
Public Property DACEffectsEQBAND3LEVEL As Lm49350TypeAdcEffectsEqLevel
    Get
    Set
public:
property Lm49350TypeAdcEffectsEqLevel DACEffectsEQBAND3LEVEL {
    Lm49350TypeAdcEffectsEqLevel get ();
    void set (Lm49350TypeAdcEffectsEqLevel value);
}
member DACEffectsEQBAND3LEVEL : Lm49350TypeAdcEffectsEqLevel with get, set

Property Value

Type: Lm49350TypeAdcEffectsEqLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsEQBAND3Q Property

IRD

Lm49350DACEffectsEQBAND3Q Property

DAC Effects: EQ_BAND_3 (Q) (unit: Octave)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEqQ DACEffectsEQBAND3Q { get; set; }
Public Property DACEffectsEQBAND3Q As Lm49350TypeAdcEffectsEqQ
    Get
    Set
public:
property Lm49350TypeAdcEffectsEqQ DACEffectsEQBAND3Q {
    Lm49350TypeAdcEffectsEqQ get ();
    void set (Lm49350TypeAdcEffectsEqQ value);
}
member DACEffectsEQBAND3Q : Lm49350TypeAdcEffectsEqQ with get, set

Property Value

Type: Lm49350TypeAdcEffectsEqQ
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsEQBAND4FREQ Property

IRD

Lm49350DACEffectsEQBAND4FREQ Property

DAC Effects: EQ_BAND_4 (FREQ) (unit: kHz)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEq4Freq DACEffectsEQBAND4FREQ { get; set; }
Public Property DACEffectsEQBAND4FREQ As Lm49350TypeAdcEffectsEq4Freq
    Get
    Set
public:
property Lm49350TypeAdcEffectsEq4Freq DACEffectsEQBAND4FREQ {
    Lm49350TypeAdcEffectsEq4Freq get ();
    void set (Lm49350TypeAdcEffectsEq4Freq value);
}
member DACEffectsEQBAND4FREQ : Lm49350TypeAdcEffectsEq4Freq with get, set

Property Value

Type: Lm49350TypeAdcEffectsEq4Freq
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsEQBAND4LEVEL Property

IRD

Lm49350DACEffectsEQBAND4LEVEL Property

DAC Effects: EQ_BAND_4 (LEVEL) (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEqLevel DACEffectsEQBAND4LEVEL { get; set; }
Public Property DACEffectsEQBAND4LEVEL As Lm49350TypeAdcEffectsEqLevel
    Get
    Set
public:
property Lm49350TypeAdcEffectsEqLevel DACEffectsEQBAND4LEVEL {
    Lm49350TypeAdcEffectsEqLevel get ();
    void set (Lm49350TypeAdcEffectsEqLevel value);
}
member DACEffectsEQBAND4LEVEL : Lm49350TypeAdcEffectsEqLevel with get, set

Property Value

Type: Lm49350TypeAdcEffectsEqLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsEQBAND4Q Property

IRD

Lm49350DACEffectsEQBAND4Q Property

DAC Effects: EQ_BAND_4 (Q) (unit: Octave)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEqQ DACEffectsEQBAND4Q { get; set; }
Public Property DACEffectsEQBAND4Q As Lm49350TypeAdcEffectsEqQ
    Get
    Set
public:
property Lm49350TypeAdcEffectsEqQ DACEffectsEQBAND4Q {
    Lm49350TypeAdcEffectsEqQ get ();
    void set (Lm49350TypeAdcEffectsEqQ value);
}
member DACEffectsEQBAND4Q : Lm49350TypeAdcEffectsEqQ with get, set

Property Value

Type: Lm49350TypeAdcEffectsEqQ
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsEQBAND5FREQ Property

IRD

Lm49350DACEffectsEQBAND5FREQ Property

DAC Effects: EQ_BAND_5 (FREQ) (unit: kHz)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEq5Freq DACEffectsEQBAND5FREQ { get; set; }
Public Property DACEffectsEQBAND5FREQ As Lm49350TypeAdcEffectsEq5Freq
    Get
    Set
public:
property Lm49350TypeAdcEffectsEq5Freq DACEffectsEQBAND5FREQ {
    Lm49350TypeAdcEffectsEq5Freq get ();
    void set (Lm49350TypeAdcEffectsEq5Freq value);
}
member DACEffectsEQBAND5FREQ : Lm49350TypeAdcEffectsEq5Freq with get, set

Property Value

Type: Lm49350TypeAdcEffectsEq5Freq
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsEQBAND5LEVEL Property

IRD

Lm49350DACEffectsEQBAND5LEVEL Property

DAC Effects: EQ_BAND_5 (LEVEL) (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsEqLevel DACEffectsEQBAND5LEVEL { get; set; }
Public Property DACEffectsEQBAND5LEVEL As Lm49350TypeAdcEffectsEqLevel
    Get
    Set
public:
property Lm49350TypeAdcEffectsEqLevel DACEffectsEQBAND5LEVEL {
    Lm49350TypeAdcEffectsEqLevel get ();
    void set (Lm49350TypeAdcEffectsEqLevel value);
}
member DACEffectsEQBAND5LEVEL : Lm49350TypeAdcEffectsEqLevel with get, set

Property Value

Type: Lm49350TypeAdcEffectsEqLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsHOLDTIME Property

IRD

Lm49350DACEffectsHOLDTIME Property

DAC Effects: HOLD_TIME (unit: ms)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsHoldTime DACEffectsHOLDTIME { get; set; }
Public Property DACEffectsHOLDTIME As Lm49350TypeAdcEffectsHoldTime
    Get
    Set
public:
property Lm49350TypeAdcEffectsHoldTime DACEffectsHOLDTIME {
    Lm49350TypeAdcEffectsHoldTime get ();
    void set (Lm49350TypeAdcEffectsHoldTime value);
}
member DACEffectsHOLDTIME : Lm49350TypeAdcEffectsHoldTime with get, set

Property Value

Type: Lm49350TypeAdcEffectsHoldTime
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsLEVEL Property

IRD

Lm49350DACEffectsLEVEL Property

DAC Effects: LEVEL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsClipLevel DACEffectsLEVEL { get; set; }
Public Property DACEffectsLEVEL As Lm49350TypeAdcEffectsClipLevel
    Get
    Set
public:
property Lm49350TypeAdcEffectsClipLevel DACEffectsLEVEL {
    Lm49350TypeAdcEffectsClipLevel get ();
    void set (Lm49350TypeAdcEffectsClipLevel value);
}
member DACEffectsLEVEL : Lm49350TypeAdcEffectsClipLevel with get, set

Property Value

Type: Lm49350TypeAdcEffectsClipLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsLIMITER Property

IRD

Lm49350DACEffectsLIMITER Property

DAC Effects: LIMITER

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACEffectsLIMITER { get; set; }
Public Property DACEffectsLIMITER As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACEffectsLIMITER {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACEffectsLIMITER : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsMAXLEVEL Property

IRD

Lm49350DACEffectsMAXLEVEL Property

DAC Effects: MAX_LEVEL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACEffectsMAXLEVEL { get; set; }
Public Property DACEffectsMAXLEVEL As Byte
    Get
    Set
public:
property unsigned char DACEffectsMAXLEVEL {
    unsigned char get ();
    void set (unsigned char value);
}
member DACEffectsMAXLEVEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsMINLEVEL Property

IRD

Lm49350DACEffectsMINLEVEL Property

DAC Effects: MIN_LEVEL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACEffectsMINLEVEL { get; set; }
Public Property DACEffectsMINLEVEL As Byte
    Get
    Set
public:
property unsigned char DACEffectsMINLEVEL {
    unsigned char get ();
    void set (unsigned char value);
}
member DACEffectsMINLEVEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsNGENB Property

IRD

Lm49350DACEffectsNGENB Property

DAC Effects: NG_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeEnabledDisabled DACEffectsNGENB { get; set; }
Public Property DACEffectsNGENB As Lm49350TypeEnabledDisabled
    Get
    Set
public:
property Lm49350TypeEnabledDisabled DACEffectsNGENB {
    Lm49350TypeEnabledDisabled get ();
    void set (Lm49350TypeEnabledDisabled value);
}
member DACEffectsNGENB : Lm49350TypeEnabledDisabled with get, set

Property Value

Type: Lm49350TypeEnabledDisabled
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsNOISEFLOOR Property

IRD

Lm49350DACEffectsNOISEFLOOR Property

DAC Effects: NOISE_FLOOR (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsNoiseFloor DACEffectsNOISEFLOOR { get; set; }
Public Property DACEffectsNOISEFLOOR As Lm49350TypeAdcEffectsNoiseFloor
    Get
    Set
public:
property Lm49350TypeAdcEffectsNoiseFloor DACEffectsNOISEFLOOR {
    Lm49350TypeAdcEffectsNoiseFloor get ();
    void set (Lm49350TypeAdcEffectsNoiseFloor value);
}
member DACEffectsNOISEFLOOR : Lm49350TypeAdcEffectsNoiseFloor with get, set

Property Value

Type: Lm49350TypeAdcEffectsNoiseFloor
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsPKDECAYRATE Property

IRD

Lm49350DACEffectsPKDECAYRATE Property

DAC Effects: PK_DECAY_RATE (unit: ms)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsPkDecayRate DACEffectsPKDECAYRATE { get; set; }
Public Property DACEffectsPKDECAYRATE As Lm49350TypeAdcEffectsPkDecayRate
    Get
    Set
public:
property Lm49350TypeAdcEffectsPkDecayRate DACEffectsPKDECAYRATE {
    Lm49350TypeAdcEffectsPkDecayRate get ();
    void set (Lm49350TypeAdcEffectsPkDecayRate value);
}
member DACEffectsPKDECAYRATE : Lm49350TypeAdcEffectsPkDecayRate with get, set

Property Value

Type: Lm49350TypeAdcEffectsPkDecayRate
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsRATIO Property

IRD

Lm49350DACEffectsRATIO Property

DAC Effects: RATIO

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsClipRatio DACEffectsRATIO { get; set; }
Public Property DACEffectsRATIO As Lm49350TypeAdcEffectsClipRatio
    Get
    Set
public:
property Lm49350TypeAdcEffectsClipRatio DACEffectsRATIO {
    Lm49350TypeAdcEffectsClipRatio get ();
    void set (Lm49350TypeAdcEffectsClipRatio value);
}
member DACEffectsRATIO : Lm49350TypeAdcEffectsClipRatio with get, set

Property Value

Type: Lm49350TypeAdcEffectsClipRatio
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsSAMPLERATE Property

IRD

Lm49350DACEffectsSAMPLERATE Property

DAC Effects: SAMPLE_RATE (unit: kHz)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsSampleRate DACEffectsSAMPLERATE { get; set; }
Public Property DACEffectsSAMPLERATE As Lm49350TypeAdcEffectsSampleRate
    Get
    Set
public:
property Lm49350TypeAdcEffectsSampleRate DACEffectsSAMPLERATE {
    Lm49350TypeAdcEffectsSampleRate get ();
    void set (Lm49350TypeAdcEffectsSampleRate value);
}
member DACEffectsSAMPLERATE : Lm49350TypeAdcEffectsSampleRate with get, set

Property Value

Type: Lm49350TypeAdcEffectsSampleRate
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsSOFTKNEE Property

IRD

Lm49350DACEffectsSOFTKNEE Property

DAC Effects: SOFT_KNEE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACEffectsSOFTKNEE { get; set; }
Public Property DACEffectsSOFTKNEE As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACEffectsSOFTKNEE {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACEffectsSOFTKNEE : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsSTEREOLINK Property

IRD

Lm49350DACEffectsSTEREOLINK Property

DAC Effects: STEREO_LINK

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACEffectsSTEREOLINK { get; set; }
Public Property DACEffectsSTEREOLINK As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACEffectsSTEREOLINK {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACEffectsSTEREOLINK : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsTARGETLEVEL Property

IRD

Lm49350DACEffectsTARGETLEVEL Property

DAC Effects: TARGET_LEVEL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsTargetLevel DACEffectsTARGETLEVEL { get; set; }
Public Property DACEffectsTARGETLEVEL As Lm49350TypeAdcEffectsTargetLevel
    Get
    Set
public:
property Lm49350TypeAdcEffectsTargetLevel DACEffectsTARGETLEVEL {
    Lm49350TypeAdcEffectsTargetLevel get ();
    void set (Lm49350TypeAdcEffectsTargetLevel value);
}
member DACEffectsTARGETLEVEL : Lm49350TypeAdcEffectsTargetLevel with get, set

Property Value

Type: Lm49350TypeAdcEffectsTargetLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACEffectsTHRESHOLD Property

IRD

Lm49350DACEffectsTHRESHOLD Property

DAC Effects: THRESHOLD (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeAdcEffectsClipThreshold DACEffectsTHRESHOLD { get; set; }
Public Property DACEffectsTHRESHOLD As Lm49350TypeAdcEffectsClipThreshold
    Get
    Set
public:
property Lm49350TypeAdcEffectsClipThreshold DACEffectsTHRESHOLD {
    Lm49350TypeAdcEffectsClipThreshold get ();
    void set (Lm49350TypeAdcEffectsClipThreshold value);
}
member DACEffectsTHRESHOLD : Lm49350TypeAdcEffectsClipThreshold with get, set

Property Value

Type: Lm49350TypeAdcEffectsClipThreshold
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACMODE Property

IRD

Lm49350DACMODE Property

DAC: MODE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDacMode DACMODE { get; set; }
Public Property DACMODE As Lm49350TypeDacMode
    Get
    Set
public:
property Lm49350TypeDacMode DACMODE {
    Lm49350TypeDacMode get ();
    void set (Lm49350TypeDacMode value);
}
member DACMODE : Lm49350TypeDacMode with get, set

Property Value

Type: Lm49350TypeDacMode
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACMUTEL Property

IRD

Lm49350DACMUTEL Property

DAC: MUTE_L

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACMUTEL { get; set; }
Public Property DACMUTEL As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACMUTEL {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACMUTEL : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DACMUTER Property

IRD

Lm49350DACMUTER Property

DAC: MUTE_R

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DACMUTER { get; set; }
Public Property DACMUTER As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DACMUTER {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DACMUTER : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerADCLDAC Property

IRD

Lm49350DigitalMixerADCLDAC Property

Digital Mixer: ADCL (DAC)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded DigitalMixerADCLDAC { get; set; }
Public Property DigitalMixerADCLDAC As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded DigitalMixerADCLDAC {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member DigitalMixerADCLDAC : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerADCLLVL Property

IRD

Lm49350DigitalMixerADCLLVL Property

Digital Mixer: ADC_L_LVL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDigitalMixerInputLevel DigitalMixerADCLLVL { get; set; }
Public Property DigitalMixerADCLLVL As Lm49350TypeDigitalMixerInputLevel
    Get
    Set
public:
property Lm49350TypeDigitalMixerInputLevel DigitalMixerADCLLVL {
    Lm49350TypeDigitalMixerInputLevel get ();
    void set (Lm49350TypeDigitalMixerInputLevel value);
}
member DigitalMixerADCLLVL : Lm49350TypeDigitalMixerInputLevel with get, set

Property Value

Type: Lm49350TypeDigitalMixerInputLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerADCRDAC Property

IRD

Lm49350DigitalMixerADCRDAC Property

Digital Mixer: ADCR (DAC)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded DigitalMixerADCRDAC { get; set; }
Public Property DigitalMixerADCRDAC As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded DigitalMixerADCRDAC {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member DigitalMixerADCRDAC : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerADCRLVL Property

IRD

Lm49350DigitalMixerADCRLVL Property

Digital Mixer: ADC_R_LVL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDigitalMixerInputLevel DigitalMixerADCRLVL { get; set; }
Public Property DigitalMixerADCRLVL As Lm49350TypeDigitalMixerInputLevel
    Get
    Set
public:
property Lm49350TypeDigitalMixerInputLevel DigitalMixerADCRLVL {
    Lm49350TypeDigitalMixerInputLevel get ();
    void set (Lm49350TypeDigitalMixerInputLevel value);
}
member DigitalMixerADCRLVL : Lm49350TypeDigitalMixerInputLevel with get, set

Property Value

Type: Lm49350TypeDigitalMixerInputLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerINTERPLLVL Property

IRD

Lm49350DigitalMixerINTERPLLVL Property

Digital Mixer: INTERP_L_LVL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDigitalMixerInputLevel DigitalMixerINTERPLLVL { get; set; }
Public Property DigitalMixerINTERPLLVL As Lm49350TypeDigitalMixerInputLevel
    Get
    Set
public:
property Lm49350TypeDigitalMixerInputLevel DigitalMixerINTERPLLVL {
    Lm49350TypeDigitalMixerInputLevel get ();
    void set (Lm49350TypeDigitalMixerInputLevel value);
}
member DigitalMixerINTERPLLVL : Lm49350TypeDigitalMixerInputLevel with get, set

Property Value

Type: Lm49350TypeDigitalMixerInputLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerINTERPRLVL Property

IRD

Lm49350DigitalMixerINTERPRLVL Property

Digital Mixer: INTERP_R_LVL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDigitalMixerInputLevel DigitalMixerINTERPRLVL { get; set; }
Public Property DigitalMixerINTERPRLVL As Lm49350TypeDigitalMixerInputLevel
    Get
    Set
public:
property Lm49350TypeDigitalMixerInputLevel DigitalMixerINTERPRLVL {
    Lm49350TypeDigitalMixerInputLevel get ();
    void set (Lm49350TypeDigitalMixerInputLevel value);
}
member DigitalMixerINTERPRLVL : Lm49350TypeDigitalMixerInputLevel with get, set

Property Value

Type: Lm49350TypeDigitalMixerInputLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerLSELDecimator Property

IRD

Lm49350DigitalMixerLSELDecimator Property

Digital Mixer: L_SEL (Decimator)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDigitalMixerLSelDeci DigitalMixerLSELDecimator { get; set; }
Public Property DigitalMixerLSELDecimator As Lm49350TypeDigitalMixerLSelDeci
    Get
    Set
public:
property Lm49350TypeDigitalMixerLSelDeci DigitalMixerLSELDecimator {
    Lm49350TypeDigitalMixerLSelDeci get ();
    void set (Lm49350TypeDigitalMixerLSelDeci value);
}
member DigitalMixerLSELDecimator : Lm49350TypeDigitalMixerLSelDeci with get, set

Property Value

Type: Lm49350TypeDigitalMixerLSelDeci
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerLSELInputPort1 Property

IRD

Lm49350DigitalMixerLSELInputPort1 Property

Digital Mixer: L_SEL (Input Port 1)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDigitalMixerLSelPort1 DigitalMixerLSELInputPort1 { get; set; }
Public Property DigitalMixerLSELInputPort1 As Lm49350TypeDigitalMixerLSelPort1
    Get
    Set
public:
property Lm49350TypeDigitalMixerLSelPort1 DigitalMixerLSELInputPort1 {
    Lm49350TypeDigitalMixerLSelPort1 get ();
    void set (Lm49350TypeDigitalMixerLSelPort1 value);
}
member DigitalMixerLSELInputPort1 : Lm49350TypeDigitalMixerLSelPort1 with get, set

Property Value

Type: Lm49350TypeDigitalMixerLSelPort1
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerLSELInputPort2 Property

IRD

Lm49350DigitalMixerLSELInputPort2 Property

Digital Mixer: L_SEL (Input Port 2)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDigitalMixerLSelPort2 DigitalMixerLSELInputPort2 { get; set; }
Public Property DigitalMixerLSELInputPort2 As Lm49350TypeDigitalMixerLSelPort2
    Get
    Set
public:
property Lm49350TypeDigitalMixerLSelPort2 DigitalMixerLSELInputPort2 {
    Lm49350TypeDigitalMixerLSelPort2 get ();
    void set (Lm49350TypeDigitalMixerLSelPort2 value);
}
member DigitalMixerLSELInputPort2 : Lm49350TypeDigitalMixerLSelPort2 with get, set

Property Value

Type: Lm49350TypeDigitalMixerLSelPort2
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerMONOInputPort1 Property

IRD

Lm49350DigitalMixerMONOInputPort1 Property

Digital Mixer: MONO (Input Port 1)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DigitalMixerMONOInputPort1 { get; set; }
Public Property DigitalMixerMONOInputPort1 As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DigitalMixerMONOInputPort1 {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DigitalMixerMONOInputPort1 : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerMONOInputPort2 Property

IRD

Lm49350DigitalMixerMONOInputPort2 Property

Digital Mixer: MONO (Input Port 2)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DigitalMixerMONOInputPort2 { get; set; }
Public Property DigitalMixerMONOInputPort2 As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DigitalMixerMONOInputPort2 {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DigitalMixerMONOInputPort2 : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerMXRCLKSELDecimator Property

IRD

Lm49350DigitalMixerMXRCLKSELDecimator Property

Digital Mixer: MXRCLK_SEL (Decimator)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDigitalMixerMxrClkSelDeci DigitalMixerMXRCLKSELDecimator { get; set; }
Public Property DigitalMixerMXRCLKSELDecimator As Lm49350TypeDigitalMixerMxrClkSelDeci
    Get
    Set
public:
property Lm49350TypeDigitalMixerMxrClkSelDeci DigitalMixerMXRCLKSELDecimator {
    Lm49350TypeDigitalMixerMxrClkSelDeci get ();
    void set (Lm49350TypeDigitalMixerMxrClkSelDeci value);
}
member DigitalMixerMXRCLKSELDecimator : Lm49350TypeDigitalMixerMxrClkSelDeci with get, set

Property Value

Type: Lm49350TypeDigitalMixerMxrClkSelDeci
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerPORT1LDAC Property

IRD

Lm49350DigitalMixerPORT1LDAC Property

Digital Mixer: PORT1L (DAC)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded DigitalMixerPORT1LDAC { get; set; }
Public Property DigitalMixerPORT1LDAC As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded DigitalMixerPORT1LDAC {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member DigitalMixerPORT1LDAC : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerPORT1RDAC Property

IRD

Lm49350DigitalMixerPORT1RDAC Property

Digital Mixer: PORT1R (DAC)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded DigitalMixerPORT1RDAC { get; set; }
Public Property DigitalMixerPORT1RDAC As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded DigitalMixerPORT1RDAC {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member DigitalMixerPORT1RDAC : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerPORT1RXLLVL Property

IRD

Lm49350DigitalMixerPORT1RXLLVL Property

Digital Mixer: PORT1_RX_L_LVL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDigitalMixerInputLevel DigitalMixerPORT1RXLLVL { get; set; }
Public Property DigitalMixerPORT1RXLLVL As Lm49350TypeDigitalMixerInputLevel
    Get
    Set
public:
property Lm49350TypeDigitalMixerInputLevel DigitalMixerPORT1RXLLVL {
    Lm49350TypeDigitalMixerInputLevel get ();
    void set (Lm49350TypeDigitalMixerInputLevel value);
}
member DigitalMixerPORT1RXLLVL : Lm49350TypeDigitalMixerInputLevel with get, set

Property Value

Type: Lm49350TypeDigitalMixerInputLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerPORT1RXRLVL Property

IRD

Lm49350DigitalMixerPORT1RXRLVL Property

Digital Mixer: PORT1_RX_R_LVL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDigitalMixerInputLevel DigitalMixerPORT1RXRLVL { get; set; }
Public Property DigitalMixerPORT1RXRLVL As Lm49350TypeDigitalMixerInputLevel
    Get
    Set
public:
property Lm49350TypeDigitalMixerInputLevel DigitalMixerPORT1RXRLVL {
    Lm49350TypeDigitalMixerInputLevel get ();
    void set (Lm49350TypeDigitalMixerInputLevel value);
}
member DigitalMixerPORT1RXRLVL : Lm49350TypeDigitalMixerInputLevel with get, set

Property Value

Type: Lm49350TypeDigitalMixerInputLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerPORT2LDAC Property

IRD

Lm49350DigitalMixerPORT2LDAC Property

Digital Mixer: PORT2L (DAC)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded DigitalMixerPORT2LDAC { get; set; }
Public Property DigitalMixerPORT2LDAC As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded DigitalMixerPORT2LDAC {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member DigitalMixerPORT2LDAC : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerPORT2RDAC Property

IRD

Lm49350DigitalMixerPORT2RDAC Property

Digital Mixer: PORT2R (DAC)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeMixerAddedNotAdded DigitalMixerPORT2RDAC { get; set; }
Public Property DigitalMixerPORT2RDAC As Lm49350TypeMixerAddedNotAdded
    Get
    Set
public:
property Lm49350TypeMixerAddedNotAdded DigitalMixerPORT2RDAC {
    Lm49350TypeMixerAddedNotAdded get ();
    void set (Lm49350TypeMixerAddedNotAdded value);
}
member DigitalMixerPORT2RDAC : Lm49350TypeMixerAddedNotAdded with get, set

Property Value

Type: Lm49350TypeMixerAddedNotAdded
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerPORT2RXLLVL Property

IRD

Lm49350DigitalMixerPORT2RXLLVL Property

Digital Mixer: PORT2_RX_L_LVL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDigitalMixerInputLevel DigitalMixerPORT2RXLLVL { get; set; }
Public Property DigitalMixerPORT2RXLLVL As Lm49350TypeDigitalMixerInputLevel
    Get
    Set
public:
property Lm49350TypeDigitalMixerInputLevel DigitalMixerPORT2RXLLVL {
    Lm49350TypeDigitalMixerInputLevel get ();
    void set (Lm49350TypeDigitalMixerInputLevel value);
}
member DigitalMixerPORT2RXLLVL : Lm49350TypeDigitalMixerInputLevel with get, set

Property Value

Type: Lm49350TypeDigitalMixerInputLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerPORT2RXRLVL Property

IRD

Lm49350DigitalMixerPORT2RXRLVL Property

Digital Mixer: PORT2_RX_R_LVL (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDigitalMixerInputLevel DigitalMixerPORT2RXRLVL { get; set; }
Public Property DigitalMixerPORT2RXRLVL As Lm49350TypeDigitalMixerInputLevel
    Get
    Set
public:
property Lm49350TypeDigitalMixerInputLevel DigitalMixerPORT2RXRLVL {
    Lm49350TypeDigitalMixerInputLevel get ();
    void set (Lm49350TypeDigitalMixerInputLevel value);
}
member DigitalMixerPORT2RXRLVL : Lm49350TypeDigitalMixerInputLevel with get, set

Property Value

Type: Lm49350TypeDigitalMixerInputLevel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerRSELDecimator Property

IRD

Lm49350DigitalMixerRSELDecimator Property

Digital Mixer: R_SEL (Decimator)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDigitalMixerRSelDeci DigitalMixerRSELDecimator { get; set; }
Public Property DigitalMixerRSELDecimator As Lm49350TypeDigitalMixerRSelDeci
    Get
    Set
public:
property Lm49350TypeDigitalMixerRSelDeci DigitalMixerRSELDecimator {
    Lm49350TypeDigitalMixerRSelDeci get ();
    void set (Lm49350TypeDigitalMixerRSelDeci value);
}
member DigitalMixerRSELDecimator : Lm49350TypeDigitalMixerRSelDeci with get, set

Property Value

Type: Lm49350TypeDigitalMixerRSelDeci
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerRSELInputPort1 Property

IRD

Lm49350DigitalMixerRSELInputPort1 Property

Digital Mixer: R_SEL (Input Port 1)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDigitalMixerRSelPort1 DigitalMixerRSELInputPort1 { get; set; }
Public Property DigitalMixerRSELInputPort1 As Lm49350TypeDigitalMixerRSelPort1
    Get
    Set
public:
property Lm49350TypeDigitalMixerRSelPort1 DigitalMixerRSELInputPort1 {
    Lm49350TypeDigitalMixerRSelPort1 get ();
    void set (Lm49350TypeDigitalMixerRSelPort1 value);
}
member DigitalMixerRSELInputPort1 : Lm49350TypeDigitalMixerRSelPort1 with get, set

Property Value

Type: Lm49350TypeDigitalMixerRSelPort1
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerRSELInputPort2 Property

IRD

Lm49350DigitalMixerRSELInputPort2 Property

Digital Mixer: R_SEL (Input Port 2)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeDigitalMixerRSelPort2 DigitalMixerRSELInputPort2 { get; set; }
Public Property DigitalMixerRSELInputPort2 As Lm49350TypeDigitalMixerRSelPort2
    Get
    Set
public:
property Lm49350TypeDigitalMixerRSelPort2 DigitalMixerRSELInputPort2 {
    Lm49350TypeDigitalMixerRSelPort2 get ();
    void set (Lm49350TypeDigitalMixerRSelPort2 value);
}
member DigitalMixerRSELInputPort2 : Lm49350TypeDigitalMixerRSelPort2 with get, set

Property Value

Type: Lm49350TypeDigitalMixerRSelPort2
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerSWAPDAC Property

IRD

Lm49350DigitalMixerSWAPDAC Property

Digital Mixer: SWAP (DAC)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DigitalMixerSWAPDAC { get; set; }
Public Property DigitalMixerSWAPDAC As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DigitalMixerSWAPDAC {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DigitalMixerSWAPDAC : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerSWAPInputPort1 Property

IRD

Lm49350DigitalMixerSWAPInputPort1 Property

Digital Mixer: SWAP (Input Port 1)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DigitalMixerSWAPInputPort1 { get; set; }
Public Property DigitalMixerSWAPInputPort1 As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DigitalMixerSWAPInputPort1 {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DigitalMixerSWAPInputPort1 : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.DigitalMixerSWAPInputPort2 Property

IRD

Lm49350DigitalMixerSWAPInputPort2 Property

Digital Mixer: SWAP (Input Port 2)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet DigitalMixerSWAPInputPort2 { get; set; }
Public Property DigitalMixerSWAPInputPort2 As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet DigitalMixerSWAPInputPort2 {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member DigitalMixerSWAPInputPort2 : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.EffectsEngineADCALCENB Property

IRD

Lm49350EffectsEngineADCALCENB Property

Effects Engine: ADC_ALC_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeEnabledDisabled EffectsEngineADCALCENB { get; set; }
Public Property EffectsEngineADCALCENB As Lm49350TypeEnabledDisabled
    Get
    Set
public:
property Lm49350TypeEnabledDisabled EffectsEngineADCALCENB {
    Lm49350TypeEnabledDisabled get ();
    void set (Lm49350TypeEnabledDisabled value);
}
member EffectsEngineADCALCENB : Lm49350TypeEnabledDisabled with get, set

Property Value

Type: Lm49350TypeEnabledDisabled
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.EffectsEngineADCEQENB Property

IRD

Lm49350EffectsEngineADCEQENB Property

Effects Engine: ADC_EQ_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeEnabledDisabled EffectsEngineADCEQENB { get; set; }
Public Property EffectsEngineADCEQENB As Lm49350TypeEnabledDisabled
    Get
    Set
public:
property Lm49350TypeEnabledDisabled EffectsEngineADCEQENB {
    Lm49350TypeEnabledDisabled get ();
    void set (Lm49350TypeEnabledDisabled value);
}
member EffectsEngineADCEQENB : Lm49350TypeEnabledDisabled with get, set

Property Value

Type: Lm49350TypeEnabledDisabled
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.EffectsEngineADCHPFENB Property

IRD

Lm49350EffectsEngineADCHPFENB Property

Effects Engine: ADC_HPF_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeEnabledDisabled EffectsEngineADCHPFENB { get; set; }
Public Property EffectsEngineADCHPFENB As Lm49350TypeEnabledDisabled
    Get
    Set
public:
property Lm49350TypeEnabledDisabled EffectsEngineADCHPFENB {
    Lm49350TypeEnabledDisabled get ();
    void set (Lm49350TypeEnabledDisabled value);
}
member EffectsEngineADCHPFENB : Lm49350TypeEnabledDisabled with get, set

Property Value

Type: Lm49350TypeEnabledDisabled
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.EffectsEngineADCPKENB Property

IRD

Lm49350EffectsEngineADCPKENB Property

Effects Engine: ADC_PK_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeEnabledDisabled EffectsEngineADCPKENB { get; set; }
Public Property EffectsEngineADCPKENB As Lm49350TypeEnabledDisabled
    Get
    Set
public:
property Lm49350TypeEnabledDisabled EffectsEngineADCPKENB {
    Lm49350TypeEnabledDisabled get ();
    void set (Lm49350TypeEnabledDisabled value);
}
member EffectsEngineADCPKENB : Lm49350TypeEnabledDisabled with get, set

Property Value

Type: Lm49350TypeEnabledDisabled
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.EffectsEngineADCSCLPENB Property

IRD

Lm49350EffectsEngineADCSCLPENB Property

Effects Engine: ADC_SCLP_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeEnabledDisabled EffectsEngineADCSCLPENB { get; set; }
Public Property EffectsEngineADCSCLPENB As Lm49350TypeEnabledDisabled
    Get
    Set
public:
property Lm49350TypeEnabledDisabled EffectsEngineADCSCLPENB {
    Lm49350TypeEnabledDisabled get ();
    void set (Lm49350TypeEnabledDisabled value);
}
member EffectsEngineADCSCLPENB : Lm49350TypeEnabledDisabled with get, set

Property Value

Type: Lm49350TypeEnabledDisabled
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.EffectsEngineDAC3DENB Property

IRD

Lm49350EffectsEngineDAC3DENB Property

Effects Engine: DAC_3D_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeEnabledDisabled EffectsEngineDAC3DENB { get; set; }
Public Property EffectsEngineDAC3DENB As Lm49350TypeEnabledDisabled
    Get
    Set
public:
property Lm49350TypeEnabledDisabled EffectsEngineDAC3DENB {
    Lm49350TypeEnabledDisabled get ();
    void set (Lm49350TypeEnabledDisabled value);
}
member EffectsEngineDAC3DENB : Lm49350TypeEnabledDisabled with get, set

Property Value

Type: Lm49350TypeEnabledDisabled
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.EffectsEngineDACALCENB Property

IRD

Lm49350EffectsEngineDACALCENB Property

Effects Engine: DAC_ALC_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeEnabledDisabled EffectsEngineDACALCENB { get; set; }
Public Property EffectsEngineDACALCENB As Lm49350TypeEnabledDisabled
    Get
    Set
public:
property Lm49350TypeEnabledDisabled EffectsEngineDACALCENB {
    Lm49350TypeEnabledDisabled get ();
    void set (Lm49350TypeEnabledDisabled value);
}
member EffectsEngineDACALCENB : Lm49350TypeEnabledDisabled with get, set

Property Value

Type: Lm49350TypeEnabledDisabled
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.EffectsEngineDACEQENB Property

IRD

Lm49350EffectsEngineDACEQENB Property

Effects Engine: DAC_EQ_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeEnabledDisabled EffectsEngineDACEQENB { get; set; }
Public Property EffectsEngineDACEQENB As Lm49350TypeEnabledDisabled
    Get
    Set
public:
property Lm49350TypeEnabledDisabled EffectsEngineDACEQENB {
    Lm49350TypeEnabledDisabled get ();
    void set (Lm49350TypeEnabledDisabled value);
}
member EffectsEngineDACEQENB : Lm49350TypeEnabledDisabled with get, set

Property Value

Type: Lm49350TypeEnabledDisabled
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.EffectsEngineDACPKENB Property

IRD

Lm49350EffectsEngineDACPKENB Property

Effects Engine: DAC_PK_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeEnabledDisabled EffectsEngineDACPKENB { get; set; }
Public Property EffectsEngineDACPKENB As Lm49350TypeEnabledDisabled
    Get
    Set
public:
property Lm49350TypeEnabledDisabled EffectsEngineDACPKENB {
    Lm49350TypeEnabledDisabled get ();
    void set (Lm49350TypeEnabledDisabled value);
}
member EffectsEngineDACPKENB : Lm49350TypeEnabledDisabled with get, set

Property Value

Type: Lm49350TypeEnabledDisabled
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.EffectsEngineDACSCLPENB Property

IRD

Lm49350EffectsEngineDACSCLPENB Property

Effects Engine: DAC_SCLP_ENB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeEnabledDisabled EffectsEngineDACSCLPENB { get; set; }
Public Property EffectsEngineDACSCLPENB As Lm49350TypeEnabledDisabled
    Get
    Set
public:
property Lm49350TypeEnabledDisabled EffectsEngineDACSCLPENB {
    Lm49350TypeEnabledDisabled get ();
    void set (Lm49350TypeEnabledDisabled value);
}
member EffectsEngineDACSCLPENB : Lm49350TypeEnabledDisabled with get, set

Property Value

Type: Lm49350TypeEnabledDisabled
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.GPIOGPIOMODE Property

IRD

Lm49350GPIOGPIOMODE Property

GPIO: GPIO_MODE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeGpioMode GPIOGPIOMODE { get; set; }
Public Property GPIOGPIOMODE As Lm49350TypeGpioMode
    Get
    Set
public:
property Lm49350TypeGpioMode GPIOGPIOMODE {
    Lm49350TypeGpioMode get ();
    void set (Lm49350TypeGpioMode value);
}
member GPIOGPIOMODE : Lm49350TypeGpioMode with get, set

Property Value

Type: Lm49350TypeGpioMode
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.GPIOGPIORX Property

IRD

Lm49350GPIOGPIORX Property

GPIO: GPIO_RX

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet GPIOGPIORX { get; set; }
Public Property GPIOGPIORX As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet GPIOGPIORX {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member GPIOGPIORX : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.GPIOGPIOTX Property

IRD

Lm49350GPIOGPIOTX Property

GPIO: GPIO_TX

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet GPIOGPIOTX { get; set; }
Public Property GPIOGPIOTX As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet GPIOGPIOTX {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member GPIOGPIOTX : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.GPIOSHORT Property

IRD

Lm49350GPIOSHORT Property

GPIO: SHORT

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet GPIOSHORT { get; set; }
Public Property GPIOSHORT As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet GPIOSHORT {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member GPIOSHORT : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.GPIOTEMP Property

IRD

Lm49350GPIOTEMP Property

GPIO: TEMP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet GPIOTEMP { get; set; }
Public Property GPIOTEMP As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet GPIOTEMP {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member GPIOTEMP : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.PLLsPLL1CLKSEL Property

IRD

Lm49350PLLsPLL1CLKSEL Property

PLLs: PLL1_CLK_SEL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePllClkSel PLLsPLL1CLKSEL { get; set; }
Public Property PLLsPLL1CLKSEL As Lm49350TypePllClkSel
    Get
    Set
public:
property Lm49350TypePllClkSel PLLsPLL1CLKSEL {
    Lm49350TypePllClkSel get ();
    void set (Lm49350TypePllClkSel value);
}
member PLLsPLL1CLKSEL : Lm49350TypePllClkSel with get, set

Property Value

Type: Lm49350TypePllClkSel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.PLLsPLL1M Property

IRD

Lm49350PLLsPLL1M Property

PLLs: PLL1_M

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePllM PLLsPLL1M { get; set; }
Public Property PLLsPLL1M As Lm49350TypePllM
    Get
    Set
public:
property Lm49350TypePllM PLLsPLL1M {
    Lm49350TypePllM get ();
    void set (Lm49350TypePllM value);
}
member PLLsPLL1M : Lm49350TypePllM with get, set

Property Value

Type: Lm49350TypePllM
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.PLLsPLL1N Property

IRD

Lm49350PLLsPLL1N Property

PLLs: PLL1_N

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePllN PLLsPLL1N { get; set; }
Public Property PLLsPLL1N As Lm49350TypePllN
    Get
    Set
public:
property Lm49350TypePllN PLLsPLL1N {
    Lm49350TypePllN get ();
    void set (Lm49350TypePllN value);
}
member PLLsPLL1N : Lm49350TypePllN with get, set

Property Value

Type: Lm49350TypePllN
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.PLLsPLL1NMOD Property

IRD

Lm49350PLLsPLL1NMOD Property

PLLs: PLL1_N_MOD

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePllNMod PLLsPLL1NMOD { get; set; }
Public Property PLLsPLL1NMOD As Lm49350TypePllNMod
    Get
    Set
public:
property Lm49350TypePllNMod PLLsPLL1NMOD {
    Lm49350TypePllNMod get ();
    void set (Lm49350TypePllNMod value);
}
member PLLsPLL1NMOD : Lm49350TypePllNMod with get, set

Property Value

Type: Lm49350TypePllNMod
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.PLLsPLL1P1 Property

IRD

Lm49350PLLsPLL1P1 Property

PLLs: PLL1_P1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePllP PLLsPLL1P1 { get; set; }
Public Property PLLsPLL1P1 As Lm49350TypePllP
    Get
    Set
public:
property Lm49350TypePllP PLLsPLL1P1 {
    Lm49350TypePllP get ();
    void set (Lm49350TypePllP value);
}
member PLLsPLL1P1 : Lm49350TypePllP with get, set

Property Value

Type: Lm49350TypePllP
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.PLLsPLL1P2 Property

IRD

Lm49350PLLsPLL1P2 Property

PLLs: PLL1_P2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePllP PLLsPLL1P2 { get; set; }
Public Property PLLsPLL1P2 As Lm49350TypePllP
    Get
    Set
public:
property Lm49350TypePllP PLLsPLL1P2 {
    Lm49350TypePllP get ();
    void set (Lm49350TypePllP value);
}
member PLLsPLL1P2 : Lm49350TypePllP with get, set

Property Value

Type: Lm49350TypePllP
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.PLLsPLL2CLKSEL Property

IRD

Lm49350PLLsPLL2CLKSEL Property

PLLs: PLL2_CLK_SEL

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePllClkSel PLLsPLL2CLKSEL { get; set; }
Public Property PLLsPLL2CLKSEL As Lm49350TypePllClkSel
    Get
    Set
public:
property Lm49350TypePllClkSel PLLsPLL2CLKSEL {
    Lm49350TypePllClkSel get ();
    void set (Lm49350TypePllClkSel value);
}
member PLLsPLL2CLKSEL : Lm49350TypePllClkSel with get, set

Property Value

Type: Lm49350TypePllClkSel
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.PLLsPLL2M Property

IRD

Lm49350PLLsPLL2M Property

PLLs: PLL2_M

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePllM PLLsPLL2M { get; set; }
Public Property PLLsPLL2M As Lm49350TypePllM
    Get
    Set
public:
property Lm49350TypePllM PLLsPLL2M {
    Lm49350TypePllM get ();
    void set (Lm49350TypePllM value);
}
member PLLsPLL2M : Lm49350TypePllM with get, set

Property Value

Type: Lm49350TypePllM
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.PLLsPLL2N Property

IRD

Lm49350PLLsPLL2N Property

PLLs: PLL2_N

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePllN PLLsPLL2N { get; set; }
Public Property PLLsPLL2N As Lm49350TypePllN
    Get
    Set
public:
property Lm49350TypePllN PLLsPLL2N {
    Lm49350TypePllN get ();
    void set (Lm49350TypePllN value);
}
member PLLsPLL2N : Lm49350TypePllN with get, set

Property Value

Type: Lm49350TypePllN
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.PLLsPLL2NMOD Property

IRD

Lm49350PLLsPLL2NMOD Property

PLLs: PLL2_N_MOD

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePllNMod PLLsPLL2NMOD { get; set; }
Public Property PLLsPLL2NMOD As Lm49350TypePllNMod
    Get
    Set
public:
property Lm49350TypePllNMod PLLsPLL2NMOD {
    Lm49350TypePllNMod get ();
    void set (Lm49350TypePllNMod value);
}
member PLLsPLL2NMOD : Lm49350TypePllNMod with get, set

Property Value

Type: Lm49350TypePllNMod
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.PLLsPLL2P Property

IRD

Lm49350PLLsPLL2P Property

PLLs: PLL2_P

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypePllP PLLsPLL2P { get; set; }
Public Property PLLsPLL2P As Lm49350TypePllP
    Get
    Set
public:
property Lm49350TypePllP PLLsPLL2P {
    Lm49350TypePllP get ();
    void set (Lm49350TypePllP value);
}
member PLLsPLL2P : Lm49350TypePllP with get, set

Property Value

Type: Lm49350TypePllP
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.SpreadSpectrumSSDISABLE Property

IRD

Lm49350SpreadSpectrumSSDISABLE Property

Spread Spectrum: SS_DISABLE

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49350TypeSetNotSet SpreadSpectrumSSDISABLE { get; set; }
Public Property SpreadSpectrumSSDISABLE As Lm49350TypeSetNotSet
    Get
    Set
public:
property Lm49350TypeSetNotSet SpreadSpectrumSSDISABLE {
    Lm49350TypeSetNotSet get ();
    void set (Lm49350TypeSetNotSet value);
}
member SpreadSpectrumSSDISABLE : Lm49350TypeSetNotSet with get, set

Property Value

Type: Lm49350TypeSetNotSet
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350 Methods

The Lm49350 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.Flush Method

IRD

Lm49350Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm49350 Class
telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsAdcLevel Enumeration

IRD

Lm49350TypeAdcEffectsAdcLevel Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsAdcLevel
Public Enumeration TypeAdcEffectsAdcLevel
public enum class TypeAdcEffectsAdcLevel
type TypeAdcEffectsAdcLevel
Members
Member name | Value | Description
Value_M_76_5 | 0 | -76.5
Value_M_75 | 1 | -75
Value_M_73_5 | 2 | -73.5
Value_M_72 | 3 | -72
Value_M_70_5 | 4 | -70.5
Value_M_69 | 5 | -69
Value_M_67_5 | 6 | -67.5
Value_M_66 | 7 | -66
Value_M_64_5 | 8 | -64.5
Value_M_63 | 9 | -63
Value_M_61_5 | 10 | -61.5
Value_M_60 | 11 | -60
Value_M_58_5 | 12 | -58.5
Value_M_57 | 13 | -57
Value_M_55_5 | 14 | -55.5
Value_M_54 | 15 | -54
Value_M_52_5 | 16 | -52.5
Value_M_51 | 17 | -51
Value_M_49_5 | 18 | -49.5
Value_M_48 | 19 | -48
Value_M_46_5 | 20 | -46.5
Value_M_45 | 21 | -45
Value_M_43_5 | 22 | -43.5
Value_M_42 | 23 | -42
Value_M_40_5 | 24 | -40.5
Value_M_39 | 25 | -39
Value_M_37_5 | 26 | -37.5
Value_M_36 | 27 | -36
Value_M_34_5 | 28 | -34.5
Value_M_33 | 29 | -33
Value_M_31_5 | 30 | -31.5
Value_M_30 | 31 | -30
Value_M_28_5 | 32 | -28.5
Value_M_27 | 33 | -27
Value_M_25_5 | 34 | -25.5
Value_M_24 | 35 | -24
Value_M_22_5 | 36 | -22.5
Value_M_21 | 37 | -21
Value_M_19_5 | 38 | -19.5
Value_M_18 | 39 | -18
Value_M_16_5 | 40 | -16.5
Value_M_15 | 41 | -15
Value_M_13_5 | 42 | -13.5
Value_M_12 | 43 | -12
Value_M_10_5 | 44 | -10.5
Value_M_9 | 45 | -9
Value_M_7_5 | 46 | -7.5
Value_M_6 | 47 | -6
Value_M_4_5 | 48 | -4.5
Value_M_3 | 49 | -3
Value_M_1_5 | 50 | -1.5
Value_0 | 51 | 0
Value_1_5 | 52 | 1.5
Value_3 | 53 | 3
Value_4_5 | 54 | 4.5
Value_6 | 55 | 6
Value_7_5 | 56 | 7.5
Value_9 | 57 | 9
Value_10_5 | 58 | 10.5
Value_12 | 59 | 12
Value_13_5 | 60 | 13.5
Value_15 | 61 | 15
Value_16_5 | 62 | 16.5
Value_18 | 63 | 18
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsAttackRate Enumeration

IRD

Lm49350TypeAdcEffectsAttackRate Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsAttackRate
Public Enumeration TypeAdcEffectsAttackRate
public enum class TypeAdcEffectsAttackRate
type TypeAdcEffectsAttackRate
Members
Member name | Value | Description
Value_21 | 0 | 21
Value_42 | 1 | 42
Value_83 | 2 | 83
Value_167 | 3 | 167
Value_250 | 4 | 250
Value_333 | 5 | 333
Value_417 | 6 | 417
Value_542 | 7 | 542
Value_729 | 8 | 729
Value_958 | 9 | 958
Value_1250 | 10 | 1250
Value_1604 | 11 | 1604
Value_1896 | 12 | 1896
Value_2208 | 13 | 2208
Value_2792 | 14 | 2792
Value_3708 | 15 | 3708
Value_4792 | 16 | 4792
Value_5688 | 17 | 5688
Value_6563 | 18 | 6563
Value_8396 | 19 | 8396
Value_11000 | 20 | 11000
Value_14167 | 21 | 14167
Value_17083 | 22 | 17083
Value_20000 | 23 | 20000
Value_25000 | 24 | 25000
Value_32000 | 25 | 32000
Value_45000 | 26 | 45000
Value_60000 | 27 | 60000
Value_75000 | 28 | 75000
Value_87500 | 29 | 87500
Value_100000 | 30 | 100000
Value_114583 | 31 | 114583
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsClipLevel Enumeration

IRD

Lm49350TypeAdcEffectsClipLevel Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsClipLevel
Public Enumeration TypeAdcEffectsClipLevel
public enum class TypeAdcEffectsClipLevel
type TypeAdcEffectsClipLevel
Members
Member name | Value | Description
Value_M_22_5 | 0 | -22.5
Value_M_21 | 1 | -21
Value_M_19_5 | 2 | -19.5
Value_M_18 | 3 | -18
Value_M_16_5 | 4 | -16.5
Value_M_15 | 5 | -15
Value_M_13_5 | 6 | -13.5
Value_M_12 | 7 | -12
Value_M_10_5 | 8 | -10.5
Value_M_9 | 9 | -9
Value_M_7_5 | 10 | -7.5
Value_M_6 | 11 | -6
Value_M_4_5 | 12 | -4.5
Value_M_3 | 13 | -3
Value_M_1_5 | 14 | -1.5
Value_0 | 15 | 0
Value_1_5 | 16 | 1.5
Value_3 | 17 | 3
Value_4_5 | 18 | 4.5
Value_6 | 19 | 6
Value_7_5 | 20 | 7.5
Value_9 | 21 | 9
Value_10_5 | 22 | 10.5
Value_12 | 23 | 12
Value_13_5 | 24 | 13.5
Value_15 | 25 | 15
Value_16_5 | 26 | 16.5
Value_18 | 27 | 18
Value_19_5 | 28 | 19.5
Value_21 | 29 | 21
Value_22_5 | 30 | 22.5
Value_24 | 31 | 24
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsClipRatio Enumeration

IRD

Lm49350TypeAdcEffectsClipRatio Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsClipRatio
Public Enumeration TypeAdcEffectsClipRatio
public enum class TypeAdcEffectsClipRatio
type TypeAdcEffectsClipRatio
Members
Member name | Value | Description
Value_11 | 0 | 1:1
Value_112 | 1 | 1:1.2
Value_114 | 2 | 1:1.4
Value_117 | 3 | 1:1.7
Value_120 | 4 | 1:2.0
Value_124 | 5 | 1:2.4
Value_128 | 6 | 1:2.8
Value_134 | 7 | 1:3.4
Value_140 | 8 | 1:4.0
Value_147 | 9 | 1:4.7
Value_157 | 10 | 1:5.7
Value_167 | 11 | 1:6.7
Value_180 | 12 | 1:8.0
Value_195 | 13 | 1:9.5
Value_1113 | 14 | 1:11.3
Value_1135 | 15 | 1:13.5
Value_1160 | 16 | 1:16.0
Value_1190 | 17 | 1:19.0
Value_1228 | 18 | 1:22.8
Value_1270 | 19 | 1:27.0
Value_1320 | 20 | 1:32.0
Value_1379 | 21 | 1:37.9
Value_1455 | 22 | 1:45.5
Value_1539 | 23 | 1:53.9
Value_1640 | 24 | 1:64.0
Value_1750 | 25 | 1:75.0
Value_1910 | 26 | 1:91.0
Value_1108 | 27 | 1:108
Value_1128 | 28 | 1:128
Value_1152 | 29 | 1:152
Value_1182 | 30 | 1:182
Value_1215 | 31 | 1:215
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsClipThreshold Enumeration

IRD

Lm49350TypeAdcEffectsClipThreshold Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsClipThreshold
Public Enumeration TypeAdcEffectsClipThreshold
public enum class TypeAdcEffectsClipThreshold
type TypeAdcEffectsClipThreshold
Members
Member name | Value | Description
Value_M_36 | 0 | -36
Value_M_30 | 1 | -30
Value_M_24 | 2 | -24
Value_M_20 | 3 | -20
Value_M_18 | 4 | -18
Value_M_17 | 5 | -17
Value_M_16 | 6 | -16
Value_M_15 | 7 | -15
Value_M_14 | 8 | -14
Value_M_12 | 9 | -12
Value_M_10 | 10 | -10
Value_M_8 | 11 | -8
Value_M_6 | 12 | -6
Value_M_4 | 13 | -4
Value_M_2_5 | 14 | -2.5
Value_M_1 | 15 | -1
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsDecayRate Enumeration

IRD

Lm49350TypeAdcEffectsDecayRate Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsDecayRate
Public Enumeration TypeAdcEffectsDecayRate
public enum class TypeAdcEffectsDecayRate
type TypeAdcEffectsDecayRate
Members
Member name | Value | Description
Value_104 | 0 | 104
Value_125 | 1 | 125
Value_167 | 2 | 167
Value_250 | 3 | 250
Value_292 | 4 | 292
Value_396 | 5 | 396
Value_500 | 6 | 500
Value_708 | 7 | 708
Value_896 | 8 | 896
Value_1250 | 9 | 1250
Value_1396 | 10 | 1396
Value_2000 | 11 | 2000
Value_2708 | 12 | 2708
Value_3500 | 13 | 3500
Value_4750 | 14 | 4750
Value_6250 | 15 | 6250
Value_8000 | 16 | 8000
Value_11000 | 17 | 11000
Value_14000 | 18 | 14000
Value_18500 | 19 | 18500
Value_25000 | 20 | 25000
Value_32000 | 21 | 32000
Value_42000 | 22 | 42000
Value_55000 | 23 | 55000
Value_72500 | 24 | 72500
Value_100000 | 25 | 100000
Value_125000 | 26 | 125000
Value_160000 | 27 | 160000
Value_225000 | 28 | 225000
Value_300000 | 29 | 300000
Value_375000 | 30 | 375000
Value_500000 | 31 | 500000
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsEq1Freq Enumeration

IRD

Lm49350TypeAdcEffectsEq1Freq Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsEq1Freq
Public Enumeration TypeAdcEffectsEq1Freq
public enum class TypeAdcEffectsEq1Freq
type TypeAdcEffectsEq1Freq
Members
Member name | Value | Description
Value_60 | 0 | 60
Value_80 | 1 | 80
Value_100 | 2 | 100
Value_120 | 3 | 120
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsEq2Freq Enumeration

IRD

Lm49350TypeAdcEffectsEq2Freq Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsEq2Freq
Public Enumeration TypeAdcEffectsEq2Freq
public enum class TypeAdcEffectsEq2Freq
type TypeAdcEffectsEq2Freq
Members
Member name | Value | Description
Value_150 | 0 | 150
Value_200 | 1 | 200
Value_250 | 2 | 250
Value_300 | 3 | 300
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsEq3Freq Enumeration

IRD

Lm49350TypeAdcEffectsEq3Freq Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsEq3Freq
Public Enumeration TypeAdcEffectsEq3Freq
public enum class TypeAdcEffectsEq3Freq
type TypeAdcEffectsEq3Freq
Members
Member name | Value | Description
Value_600 | 0 | 600
Value_800 | 1 | 800
Value_1000 | 2 | 1000
Value_1200 | 3 | 1200
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsEq4Freq Enumeration

IRD

Lm49350TypeAdcEffectsEq4Freq Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsEq4Freq
Public Enumeration TypeAdcEffectsEq4Freq
public enum class TypeAdcEffectsEq4Freq
type TypeAdcEffectsEq4Freq
Members
Member name | Value | Description
Value_2 | 0 | 2
Value_2_7 | 1 | 2.7
Value_3_4 | 2 | 3.4
Value_4_1 | 3 | 4.1
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsEq5Freq Enumeration

IRD

Lm49350TypeAdcEffectsEq5Freq Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsEq5Freq
Public Enumeration TypeAdcEffectsEq5Freq
public enum class TypeAdcEffectsEq5Freq
type TypeAdcEffectsEq5Freq
Members
Member name | Value | Description
Value_7 | 0 | 7
Value_9 | 1 | 9
Value_11 | 2 | 11
Value_20 | 3 | 20
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsEqLevel Enumeration

IRD

Lm49350TypeAdcEffectsEqLevel Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsEqLevel
Public Enumeration TypeAdcEffectsEqLevel
public enum class TypeAdcEffectsEqLevel
type TypeAdcEffectsEqLevel
Members
Member name | Value | Description
Off | 0 | Off
Value_M_15 | 1 | -15
Value_M_14 | 2 | -14
Value_M_13 | 3 | -13
Value_M_12 | 4 | -12
Value_M_11 | 5 | -11
Value_M_10 | 6 | -10
Value_M_9 | 7 | -9
Value_M_8 | 8 | -8
Value_M_7 | 9 | -7
Value_M_6 | 10 | -6
Value_M_5 | 11 | -5
Value_M_4 | 12 | -4
Value_M_3 | 13 | -3
Value_M_2 | 14 | -2
Value_M_1 | 15 | -1
Value_0 | 16 | 0
Value_1 | 17 | 1
Value_2 | 18 | 2
Value_3 | 19 | 3
Value_4 | 20 | 4
Value_5 | 21 | 5
Value_6 | 22 | 6
Value_7 | 23 | 7
Value_8 | 24 | 8
Value_9 | 25 | 9
Value_10 | 26 | 10
Value_11 | 27 | 11
Value_12 | 28 | 12
Value_13 | 29 | 13
Value_14 | 30 | 14
Value_15 | 31 | 15
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsEqQ Enumeration

IRD

Lm49350TypeAdcEffectsEqQ Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsEqQ
Public Enumeration TypeAdcEffectsEqQ
public enum class TypeAdcEffectsEqQ
type TypeAdcEffectsEqQ
Members
Member name | Value | Description
Value_23 | 0 | 2/3
Value_43 | 1 | 4/3
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsHoldTime Enumeration

IRD

Lm49350TypeAdcEffectsHoldTime Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsHoldTime
Public Enumeration TypeAdcEffectsHoldTime
public enum class TypeAdcEffectsHoldTime
type TypeAdcEffectsHoldTime
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_1_25 | 1 | 1.25
Value_1_6 | 2 | 1.6
Value_2 | 3 | 2
Value_2_5 | 4 | 2.5
Value_3_2 | 5 | 3.2
Value_4 | 6 | 4
Value_5 | 7 | 5
Value_6_25 | 8 | 6.25
Value_8 | 9 | 8
Value_10 | 10 | 10
Value_12_5 | 11 | 12.5
Value_16 | 12 | 16
Value_20 | 13 | 20
Value_25 | 14 | 25
Value_32 | 15 | 32
Value_40 | 16 | 40
Value_50 | 17 | 50
Value_64 | 18 | 64
Value_80 | 19 | 80
Value_100 | 20 | 100
Value_125 | 21 | 125
Value_160 | 22 | 160
Value_200 | 23 | 200
Value_250 | 24 | 250
Value_320 | 25 | 320
Value_400 | 26 | 400
Value_500 | 27 | 500
Value_640 | 28 | 640
Value_800 | 29 | 800
Value_1000 | 30 | 1000
Value_1250 | 31 | 1250
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsHpfMode Enumeration

IRD

Lm49350TypeAdcEffectsHpfMode Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsHpfMode
Public Enumeration TypeAdcEffectsHpfMode
public enum class TypeAdcEffectsHpfMode
type TypeAdcEffectsHpfMode
Members
Member name | Value | Description
Value_8KHzVoice | 0 | 8 kHz Voice
Value_12KHzVoice | 1 | 12 kHz Voice
Value_16KHzVoice | 2 | 16 kHz Voice
Value_24KHzVoice | 3 | 24 kHz Voice
Value_32KHzVoice | 4 | 32 kHz Voice
Value_32KHzAudio | 5 | 32 kHz Audio
Value_48KHzAudio | 6 | 48 kHz Audio
Value_96KHzAudio | 7 | 96 kHz Audio
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsNoiseFloor Enumeration

IRD

Lm49350TypeAdcEffectsNoiseFloor Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsNoiseFloor
Public Enumeration TypeAdcEffectsNoiseFloor
public enum class TypeAdcEffectsNoiseFloor
type TypeAdcEffectsNoiseFloor
Members
Member name | Value | Description
Value_M_39 | 0 | -39
Value_M_42 | 1 | -42
Value_M_45 | 2 | -45
Value_M_48 | 3 | -48
Value_M_51 | 4 | -51
Value_M_54 | 5 | -54
Value_M_57 | 6 | -57
Value_M_60 | 7 | -60
Value_M_63 | 8 | -63
Value_M_66 | 9 | -66
Value_M_69 | 10 | -69
Value_M_72 | 11 | -72
Value_M_75 | 12 | -75
Value_M_78 | 13 | -78
Value_M_81 | 14 | -81
Value_M_84 | 15 | -84
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsPkDecayRate Enumeration

IRD

Lm49350TypeAdcEffectsPkDecayRate Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsPkDecayRate
Public Enumeration TypeAdcEffectsPkDecayRate
public enum class TypeAdcEffectsPkDecayRate
type TypeAdcEffectsPkDecayRate
Members
Member name | Value | Description
Value_1_3 | 0 | 1.3
Value_2_6 | 1 | 2.6
Value_5_3 | 2 | 5.3
Value_10_6 | 3 | 10.6
Value_21_3 | 4 | 21.3
Value_42_6 | 5 | 42.6
Value_85_5 | 6 | 85.5
Value_2730 | 7 | 2730
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsSampleRate Enumeration

IRD

Lm49350TypeAdcEffectsSampleRate Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsSampleRate
Public Enumeration TypeAdcEffectsSampleRate
public enum class TypeAdcEffectsSampleRate
type TypeAdcEffectsSampleRate
Members
Member name | Value | Description
Value_8 | 0 | 8
Value_12 | 1 | 12
Value_16 | 2 | 16
Value_24 | 3 | 24
Value_32 | 4 | 32
Value_48 | 5 | 48
Value_96 | 6 | 96
Value_192 | 7 | 192
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsSourceSel Enumeration

IRD

Lm49350TypeAdcEffectsSourceSel Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsSourceSel
Public Enumeration TypeAdcEffectsSourceSel
public enum class TypeAdcEffectsSourceSel
type TypeAdcEffectsSourceSel
Members
Member name | Value | Description
BothALCsControlAUXGain | 0 | Both ALCs Control AUX Gain
BothALCsControlMICGain | 1 | Both ALCs Control MIC Gain
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAdcEffectsTargetLevel Enumeration

IRD

Lm49350TypeAdcEffectsTargetLevel Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEffectsTargetLevel
Public Enumeration TypeAdcEffectsTargetLevel
public enum class TypeAdcEffectsTargetLevel
type TypeAdcEffectsTargetLevel
Members
Member name | Value | Description
Value_M_1_5 | 0 | -1.5
Value_M_3 | 1 | -3
Value_M_4_5 | 2 | -4.5
Value_M_6 | 3 | -6
Value_M_7_5 | 4 | -7.5
Value_M_9 | 5 | -9
Value_M_10_5 | 6 | -10.5
Value_M_12 | 7 | -12
Value_M_13_5 | 8 | -13.5
Value_M_15 | 9 | -15
Value_M_16_5 | 10 | -16.5
Value_M_18 | 11 | -18
Value_M_19_5 | 12 | -19.5
Value_M_21 | 13 | -21
Value_M_22_5 | 14 | -22.5
Value_M_24 | 15 | -24
Value_M_25_5 | 16 | -25.5
Value_M_27 | 17 | -27
Value_M_28_5 | 18 | -28.5
Value_M_30 | 19 | -30
Value_M_31_5 | 20 | -31.5
Value_M_33 | 21 | -33
Value_M_34_5 | 22 | -34.5
Value_M_36 | 23 | -36
Value_M_37_5 | 24 | -37.5
Value_M_39 | 25 | -39
Value_M_40_5 | 26 | -40.5
Value_M_42 | 27 | -42
Value_M_43_5 | 28 | -43.5
Value_M_45 | 29 | -45
Value_M_46_5 | 30 | -46.5
Value_M_48 | 31 | -48
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAudioPortBasicClockPhase Enumeration

IRD

Lm49350TypeAudioPortBasicClockPhase Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPortBasicClockPhase
Public Enumeration TypeAudioPortBasicClockPhase
public enum class TypeAudioPortBasicClockPhase
type TypeAudioPortBasicClockPhase
Members
Member name | Value | Description
I2S | 0 | I2S
PCM | 1 | PCM
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAudioPortClockSel Enumeration

IRD

Lm49350TypeAudioPortClockSel Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPortClockSel
Public Enumeration TypeAudioPortClockSel
public enum class TypeAudioPortClockSel
type TypeAudioPortClockSel
Members
Member name | Value | Description
DACSOURCECLK | 0 | DAC_SOURCE_CLK
ADCSOURCECLK | 1 | ADC_SOURCE_CLK
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAudioPortHalfCycleDivider Enumeration

IRD

Lm49350TypeAudioPortHalfCycleDivider Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPortHalfCycleDivider
Public Enumeration TypeAudioPortHalfCycleDivider
public enum class TypeAudioPortHalfCycleDivider
type TypeAudioPortHalfCycleDivider
Members
Member name | Value | Description
Bypass | 0 | Bypass
Value_1 | 1 | 1
Value_1_5 | 2 | 1.5
Value_2 | 3 | 2
Value_2_5 | 4 | 2.5
Value_3 | 5 | 3
Value_3_5 | 6 | 3.5
Value_4 | 7 | 4
Value_4_5 | 8 | 4.5
Value_5 | 9 | 5
Value_5_5 | 10 | 5.5
Value_6 | 11 | 6
Value_6_5 | 12 | 6.5
Value_7 | 13 | 7
Value_7_5 | 14 | 7.5
Value_8 | 15 | 8
Value_8_5 | 16 | 8.5
Value_9 | 17 | 9
Value_9_5 | 18 | 9.5
Value_10 | 19 | 10
Value_10_5 | 20 | 10.5
Value_11 | 21 | 11
Value_11_5 | 22 | 11.5
Value_12 | 23 | 12
Value_12_5 | 24 | 12.5
Value_13 | 25 | 13
Value_13_5 | 26 | 13.5
Value_14 | 27 | 14
Value_14_5 | 28 | 14.5
Value_15 | 29 | 15
Value_15_5 | 30 | 15.5
Value_16 | 31 | 16
Value_16_5 | 32 | 16.5
Value_17 | 33 | 17
Value_17_5 | 34 | 17.5
Value_18 | 35 | 18
Value_18_5 | 36 | 18.5
Value_19 | 37 | 19
Value_19_5 | 38 | 19.5
Value_20 | 39 | 20
Value_20_5 | 40 | 20.5
Value_21 | 41 | 21
Value_21_5 | 42 | 21.5
Value_22 | 43 | 22
Value_22_5 | 44 | 22.5
Value_23 | 45 | 23
Value_23_5 | 46 | 23.5
Value_24 | 47 | 24
Value_24_5 | 48 | 24.5
Value_25 | 49 | 25
Value_25_5 | 50 | 25.5
Value_26 | 51 | 26
Value_26_5 | 52 | 26.5
Value_27 | 53 | 27
Value_27_5 | 54 | 27.5
Value_28 | 55 | 28
Value_28_5 | 56 | 28.5
Value_29 | 57 | 29
Value_29_5 | 58 | 29.5
Value_30 | 59 | 30
Value_30_5 | 60 | 30.5
Value_31 | 61 | 31
Value_31_5 | 62 | 31.5
Value_32 | 63 | 32
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAudioPortRxTxMode Enumeration

IRD

Lm49350TypeAudioPortRxTxMode Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPortRxTxMode
Public Enumeration TypeAudioPortRxTxMode
public enum class TypeAudioPortRxTxMode
type TypeAudioPortRxTxMode
Members
Member name | Value | Description
MSBJustified | 0 | MSB Justified
LSBJustified | 1 | LSB Justified
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAudioPortRxTxWidth Enumeration

IRD

Lm49350TypeAudioPortRxTxWidth Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPortRxTxWidth
Public Enumeration TypeAudioPortRxTxWidth
public enum class TypeAudioPortRxTxWidth
type TypeAudioPortRxTxWidth
Members
Member name | Value | Description
Value_24 | 0 | 24
Value_20 | 1 | 20
Value_18 | 2 | 18
Value_16 | 3 | 16
Value_14 | 4 | 14
Value_13 | 5 | 13
Value_12 | 6 | 12
Value_8 | 7 | 8
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAudioPortSyncRate Enumeration

IRD

Lm49350TypeAudioPortSyncRate Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPortSyncRate
Public Enumeration TypeAudioPortSyncRate
public enum class TypeAudioPortSyncRate
type TypeAudioPortSyncRate
Members
Member name | Value | Description
Value_8Mono16Stereo | 0 | 8 (Mono), 16 (Stereo)
Value_12Mono24Stereo | 1 | 12 (Mono), 24 (Stereo)
Value_16Mono32Stereo | 2 | 16 (Mono), 32 (Stereo)
Value_18Mono36Stereo | 3 | 18 (Mono), 36 (Stereo)
Value_20Mono40Stereo | 4 | 20 (Mono), 40 (Stereo)
Value_24Mono48Stereo | 5 | 24 (Mono), 48 (Stereo)
Value_25Mono50Stereo | 6 | 25 (Mono), 50 (Stereo)
Value_32Mono64Stereo | 7 | 32 (Mono), 64 (Stereo)
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAudioPortSyncWidth Enumeration

IRD

Lm49350TypeAudioPortSyncWidth Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPortSyncWidth
Public Enumeration TypeAudioPortSyncWidth
public enum class TypeAudioPortSyncWidth
type TypeAudioPortSyncWidth
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_2 | 1 | 2
Value_4 | 2 | 4
Value_7 | 3 | 7
Value_8 | 4 | 8
Value_11 | 5 | 11
Value_15 | 6 | 15
Value_16 | 7 | 16
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAudioPortSynthDenom Enumeration

IRD

Lm49350TypeAudioPortSynthDenom Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPortSynthDenom
Public Enumeration TypeAudioPortSynthDenom
public enum class TypeAudioPortSynthDenom
type TypeAudioPortSynthDenom
Members
Member name | Value | Description
Value_128 | 0 | 128
Value_125 | 1 | 125
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAudioPortSynthNum Enumeration

IRD

Lm49350TypeAudioPortSynthNum Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPortSynthNum
Public Enumeration TypeAudioPortSynthNum
public enum class TypeAudioPortSynthNum
type TypeAudioPortSynthNum
Members
Member name | Value | Description
SYNTHDENOM | 0 | SYNTH_DENOM
Value_100SYNTHDENOM | 1 | 100/SYNTH_DENOM
Value_96SYNTHDENOM | 2 | 96/SYNTH_DENOM
Value_80SYNTHDENOM | 3 | 80/SYNTH_DENOM
Value_72SYNTHDENOM | 4 | 72/SYNTH_DENOM
Value_64SYNTHDENOM | 5 | 64/SYNTH_DENOM
Value_48SYNTHDENOM | 6 | 48/SYNTH_DENOM
Value_0SYNTHDENOM | 7 | 0/SYNTH_DENOM
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAudioPortTxExtraBits Enumeration

IRD

Lm49350TypeAudioPortTxExtraBits Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPortTxExtraBits
Public Enumeration TypeAudioPortTxExtraBits
public enum class TypeAudioPortTxExtraBits
type TypeAudioPortTxExtraBits
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_1 | 1 | 1
HighZ | 2 | High-Z
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAudioPortUlawAlaw Enumeration

IRD

Lm49350TypeAudioPortUlawAlaw Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPortUlawAlaw
Public Enumeration TypeAudioPortUlawAlaw
public enum class TypeAudioPortUlawAlaw
type TypeAudioPortUlawAlaw
Members
Member name | Value | Description
ΜLaw | 0 | μLaw
ALaw | 1 | A-Law
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeAuxLevel Enumeration

IRD

Lm49350TypeAuxLevel Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAuxLevel
Public Enumeration TypeAuxLevel
public enum class TypeAuxLevel
type TypeAuxLevel
Members
Member name | Value | Description
Value_M_46_5 | 0 | -46.5
Value_M_45 | 1 | -45
Value_M_43_5 | 2 | -43.5
Value_M_42 | 3 | -42
Value_M_40_5 | 4 | -40.5
Value_M_39 | 5 | -39
Value_M_37_5 | 6 | -37.5
Value_M_36 | 7 | -36
Value_M_34_5 | 8 | -34.5
Value_M_33 | 9 | -33
Value_M_31_5 | 10 | -31.5
Value_M_30 | 11 | -30
Value_M_28_5 | 12 | -28.5
Value_M_27 | 13 | -27
Value_M_25_5 | 14 | -25.5
Value_M_24 | 15 | -24
Value_M_22_5 | 16 | -22.5
Value_M_21 | 17 | -21
Value_M_19_5 | 18 | -19.5
Value_M_18 | 19 | -18
Value_M_16_5 | 20 | -16.5
Value_M_15 | 21 | -15
Value_M_13_5 | 22 | -13.5
Value_M_12 | 23 | -12
Value_M_10_5 | 24 | -10.5
Value_M_9 | 25 | -9
Value_M_7_5 | 26 | -7.5
Value_M_6 | 27 | -6
Value_M_4_5 | 28 | -4.5
Value_M_3 | 29 | -3
Value_M_1_5 | 30 | -1.5
Value_0 | 31 | 0
Value_1_5 | 32 | 1.5
Value_3 | 33 | 3
Value_4_5 | 34 | 4.5
Value_6 | 35 | 6
Value_7_5 | 36 | 7.5
Value_9 | 37 | 9
Value_10_5 | 38 | 10.5
Value_12 | 39 | 12
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeClkDiv Enumeration

IRD

Lm49350TypeClkDiv Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClkDiv
Public Enumeration TypeClkDiv
public enum class TypeClkDiv
type TypeClkDiv
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_1__1 | 1 | 1
Value_1_5 | 2 | 1.5
Value_2 | 3 | 2
Value_2_5 | 4 | 2.5
Value_3 | 5 | 3
Value_3_5 | 6 | 3.5
Value_4 | 7 | 4
Value_4_5 | 8 | 4.5
Value_5 | 9 | 5
Value_5_5 | 10 | 5.5
Value_6 | 11 | 6
Value_6_5 | 12 | 6.5
Value_7 | 13 | 7
Value_7_5 | 14 | 7.5
Value_8 | 15 | 8
Value_8_5 | 16 | 8.5
Value_9 | 17 | 9
Value_9_5 | 18 | 9.5
Value_10 | 19 | 10
Value_10_5 | 20 | 10.5
Value_11 | 21 | 11
Value_11_5 | 22 | 11.5
Value_12 | 23 | 12
Value_12_5 | 24 | 12.5
Value_13 | 25 | 13
Value_13_5 | 26 | 13.5
Value_14 | 27 | 14
Value_14_5 | 28 | 14.5
Value_15 | 29 | 15
Value_15_5 | 30 | 15.5
Value_16 | 31 | 16
Value_16_5 | 32 | 16.5
Value_17 | 33 | 17
Value_17_5 | 34 | 17.5
Value_18 | 35 | 18
Value_18_5 | 36 | 18.5
Value_19 | 37 | 19
Value_19_5 | 38 | 19.5
Value_20 | 39 | 20
Value_20_5 | 40 | 20.5
Value_21 | 41 | 21
Value_21_5 | 42 | 21.5
Value_22 | 43 | 22
Value_22_5 | 44 | 22.5
Value_23 | 45 | 23
Value_23_5 | 46 | 23.5
Value_24 | 47 | 24
Value_24_5 | 48 | 24.5
Value_25 | 49 | 25
Value_25_5 | 50 | 25.5
Value_26 | 51 | 26
Value_26_5 | 52 | 26.5
Value_27 | 53 | 27
Value_27_5 | 54 | 27.5
Value_28 | 55 | 28
Value_28_5 | 56 | 28.5
Value_29 | 57 | 29
Value_29_5 | 58 | 29.5
Value_30 | 59 | 30
Value_30_5 | 60 | 30.5
Value_31 | 61 | 31
Value_31_5 | 62 | 31.5
Value_32 | 63 | 32
Value_32_5 | 64 | 32.5
Value_33 | 65 | 33
Value_33_5 | 66 | 33.5
Value_34 | 67 | 34
Value_34_5 | 68 | 34.5
Value_35 | 69 | 35
Value_35_5 | 70 | 35.5
Value_36 | 71 | 36
Value_36_5 | 72 | 36.5
Value_37 | 73 | 37
Value_37_5 | 74 | 37.5
Value_38 | 75 | 38
Value_38_5 | 76 | 38.5
Value_39 | 77 | 39
Value_39_5 | 78 | 39.5
Value_40 | 79 | 40
Value_40_5 | 80 | 40.5
Value_41 | 81 | 41
Value_41_5 | 82 | 41.5
Value_42 | 83 | 42
Value_42_5 | 84 | 42.5
Value_43 | 85 | 43
Value_43_5 | 86 | 43.5
Value_44 | 87 | 44
Value_44_5 | 88 | 44.5
Value_45 | 89 | 45
Value_45_5 | 90 | 45.5
Value_46 | 91 | 46
Value_46_5 | 92 | 46.5
Value_47 | 93 | 47
Value_47_5 | 94 | 47.5
Value_48 | 95 | 48
Value_48_5 | 96 | 48.5
Value_49 | 97 | 49
Value_49_5 | 98 | 49.5
Value_50 | 99 | 50
Value_50_5 | 100 | 50.5
Value_51 | 101 | 51
Value_51_5 | 102 | 51.5
Value_52 | 103 | 52
Value_52_5 | 104 | 52.5
Value_53 | 105 | 53
Value_53_5 | 106 | 53.5
Value_54 | 107 | 54
Value_54_5 | 108 | 54.5
Value_55 | 109 | 55
Value_55_5 | 110 | 55.5
Value_56 | 111 | 56
Value_56_5 | 112 | 56.5
Value_57 | 113 | 57
Value_57_5 | 114 | 57.5
Value_58 | 115 | 58
Value_58_5 | 116 | 58.5
Value_59 | 117 | 59
Value_59_5 | 118 | 59.5
Value_60 | 119 | 60
Value_60_5 | 120 | 60.5
Value_61 | 121 | 61
Value_61_5 | 122 | 61.5
Value_62 | 123 | 62
Value_62_5 | 124 | 62.5
Value_63 | 125 | 63
Value_63_5 | 126 | 63.5
Value_64 | 127 | 64
Value_64_5 | 128 | 64.5
Value_65 | 129 | 65
Value_65_5 | 130 | 65.5
Value_66 | 131 | 66
Value_66_5 | 132 | 66.5
Value_67 | 133 | 67
Value_67_5 | 134 | 67.5
Value_68 | 135 | 68
Value_68_5 | 136 | 68.5
Value_69 | 137 | 69
Value_69_5 | 138 | 69.5
Value_70 | 139 | 70
Value_70_5 | 140 | 70.5
Value_71 | 141 | 71
Value_71_5 | 142 | 71.5
Value_72 | 143 | 72
Value_72_5 | 144 | 72.5
Value_73 | 145 | 73
Value_73_5 | 146 | 73.5
Value_74 | 147 | 74
Value_74_5 | 148 | 74.5
Value_75 | 149 | 75
Value_75_5 | 150 | 75.5
Value_76 | 151 | 76
Value_76_5 | 152 | 76.5
Value_77 | 153 | 77
Value_77_5 | 154 | 77.5
Value_78 | 155 | 78
Value_78_5 | 156 | 78.5
Value_79 | 157 | 79
Value_79_5 | 158 | 79.5
Value_80 | 159 | 80
Value_80_5 | 160 | 80.5
Value_81 | 161 | 81
Value_81_5 | 162 | 81.5
Value_82 | 163 | 82
Value_82_5 | 164 | 82.5
Value_83 | 165 | 83
Value_83_5 | 166 | 83.5
Value_84 | 167 | 84
Value_84_5 | 168 | 84.5
Value_85 | 169 | 85
Value_85_5 | 170 | 85.5
Value_86 | 171 | 86
Value_86_5 | 172 | 86.5
Value_87 | 173 | 87
Value_87_5 | 174 | 87.5
Value_88 | 175 | 88
Value_88_5 | 176 | 88.5
Value_89 | 177 | 89
Value_89_5 | 178 | 89.5
Value_90 | 179 | 90
Value_90_5 | 180 | 90.5
Value_91 | 181 | 91
Value_91_5 | 182 | 91.5
Value_92 | 183 | 92
Value_92_5 | 184 | 92.5
Value_93 | 185 | 93
Value_93_5 | 186 | 93.5
Value_94 | 187 | 94
Value_94_5 | 188 | 94.5
Value_95 | 189 | 95
Value_95_5 | 190 | 95.5
Value_96 | 191 | 96
Value_96_5 | 192 | 96.5
Value_97 | 193 | 97
Value_97_5 | 194 | 97.5
Value_98 | 195 | 98
Value_98_5 | 196 | 98.5
Value_99 | 197 | 99
Value_99_5 | 198 | 99.5
Value_100 | 199 | 100
Value_100_5 | 200 | 100.5
Value_101 | 201 | 101
Value_101_5 | 202 | 101.5
Value_102 | 203 | 102
Value_102_5 | 204 | 102.5
Value_103 | 205 | 103
Value_103_5 | 206 | 103.5
Value_104 | 207 | 104
Value_104_5 | 208 | 104.5
Value_105 | 209 | 105
Value_105_5 | 210 | 105.5
Value_106 | 211 | 106
Value_106_5 | 212 | 106.5
Value_107 | 213 | 107
Value_107_5 | 214 | 107.5
Value_108 | 215 | 108
Value_108_5 | 216 | 108.5
Value_109 | 217 | 109
Value_109_5 | 218 | 109.5
Value_110 | 219 | 110
Value_110_5 | 220 | 110.5
Value_111 | 221 | 111
Value_111_5 | 222 | 111.5
Value_112 | 223 | 112
Value_112_5 | 224 | 112.5
Value_113 | 225 | 113
Value_113_5 | 226 | 113.5
Value_114 | 227 | 114
Value_114_5 | 228 | 114.5
Value_115 | 229 | 115
Value_115_5 | 230 | 115.5
Value_116 | 231 | 116
Value_116_5 | 232 | 116.5
Value_117 | 233 | 117
Value_117_5 | 234 | 117.5
Value_118 | 235 | 118
Value_118_5 | 236 | 118.5
Value_119 | 237 | 119
Value_119_5 | 238 | 119.5
Value_120 | 239 | 120
Value_120_5 | 240 | 120.5
Value_121 | 241 | 121
Value_121_5 | 242 | 121.5
Value_122 | 243 | 122
Value_122_5 | 244 | 122.5
Value_123 | 245 | 123
Value_123_5 | 246 | 123.5
Value_124 | 247 | 124
Value_124_5 | 248 | 124.5
Value_125 | 249 | 125
Value_125_5 | 250 | 125.5
Value_126 | 251 | 126
Value_126_5 | 252 | 126.5
Value_127 | 253 | 127
Value_127_5 | 254 | 127.5
Value_128 | 255 | 128
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeClkSel Enumeration

IRD

Lm49350TypeClkSel Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClkSel
Public Enumeration TypeClkSel
public enum class TypeClkSel
type TypeClkSel
Members
Member name | Value | Description
MCLK | 0 | MCLK
PORT1RXCLK | 1 | PORT1_RX_CLK
PORT2RXCLK | 2 | PORT2_RX_CLK
PLL1OUTPUT2 | 3 | PLL1_OUTPUT2
PLL2OUTPUT | 4 | PLL2_OUTPUT
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeDacEffects3dEffectLevel Enumeration

IRD

Lm49350TypeDacEffects3dEffectLevel Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacEffects3dEffectLevel
Public Enumeration TypeDacEffects3dEffectLevel
public enum class TypeDacEffects3dEffectLevel
type TypeDacEffects3dEffectLevel
Members
Member name | Value | Description
Value_25 | 0 | 25
Value_37_50 | 1 | 37.50
Value_50 | 2 | 50
Value_75 | 3 | 75
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeDacEffects3dEffectMode Enumeration

IRD

Lm49350TypeDacEffects3dEffectMode Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacEffects3dEffectMode
Public Enumeration TypeDacEffects3dEffectMode
public enum class TypeDacEffects3dEffectMode
type TypeDacEffects3dEffectMode
Members
Member name | Value | Description
Loudspeaker | 0 | Loudspeaker
Headphone | 1 | Headphone
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeDacEffects3dFilterType Enumeration

IRD

Lm49350TypeDacEffects3dFilterType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacEffects3dFilterType
Public Enumeration TypeDacEffects3dFilterType
public enum class TypeDacEffects3dFilterType
type TypeDacEffects3dFilterType
Members
Member name | Value | Description
Value_200HzHPF | 0 | 200 Hz HPF
Value_300HzHPF | 1 | 300 Hz HPF
Value_600HzHPF | 2 | 600 Hz HPF
Value_900HzHPF | 3 | 900 Hz HPF
Value_200500HzBPF | 4 | 200-500 Hz BPF
Value_2001000HzBPF | 5 | 200-1000 Hz BPF
Value_2001600HzBPF | 6 | 200-1600 Hz BPF
Value_2002500HzBPF | 7 | 200-2500 Hz BPF
Value_3001000HzBPF | 8 | 300-1000 Hz BPF
Value_3001600HzBPF | 9 | 300-1600 Hz BPF
Value_3002500HzBPF | 10 | 300-2500 Hz BPF
Value_6001000HzBPF | 11 | 600-1000 Hz BPF
Value_6001600HzBPF | 12 | 600-1600 Hz BPF
Value_6002500HzBPF | 13 | 600-2500 Hz BPF
Value_9001600HzBPF | 14 | 900-1600 Hz BPF
Value_9002500HzBPF | 15 | 900-2500 Hz BPF
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeDacMode Enumeration

IRD

Lm49350TypeDacMode Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacMode
Public Enumeration TypeDacMode
public enum class TypeDacMode
type TypeDacMode
Members
Member name | Value | Description
Value_125 | 0 | 125
Value_128 | 1 | 128
Value_64 | 2 | 64
Value_32 | 3 | 32
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeDigitalMixerInputLevel Enumeration

IRD

Lm49350TypeDigitalMixerInputLevel Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDigitalMixerInputLevel
Public Enumeration TypeDigitalMixerInputLevel
public enum class TypeDigitalMixerInputLevel
type TypeDigitalMixerInputLevel
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_M_6 | 1 | -6
Value_M_12 | 2 | -12
Value_M_18 | 3 | -18
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeDigitalMixerLSelDeci Enumeration

IRD

Lm49350TypeDigitalMixerLSelDeci Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDigitalMixerLSelDeci
Public Enumeration TypeDigitalMixerLSelDeci
public enum class TypeDigitalMixerLSelDeci
type TypeDigitalMixerLSelDeci
Members
Member name | Value | Description
None | 0 | None
PORT1RXL | 1 | PORT1_RX_L
PORT2RXL | 2 | PORT2_RX_L
DACINTERPL | 3 | DAC_INTERP_L
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeDigitalMixerLSelPort1 Enumeration

IRD

Lm49350TypeDigitalMixerLSelPort1 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDigitalMixerLSelPort1
Public Enumeration TypeDigitalMixerLSelPort1
public enum class TypeDigitalMixerLSelPort1
type TypeDigitalMixerLSelPort1
Members
Member name | Value | Description
None | 0 | None
ADCL | 1 | ADC_L
PORT2RXL | 2 | PORT2_RX_L
DACINTERPL | 3 | DAC_INTERP_L
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeDigitalMixerLSelPort2 Enumeration

IRD

Lm49350TypeDigitalMixerLSelPort2 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDigitalMixerLSelPort2
Public Enumeration TypeDigitalMixerLSelPort2
public enum class TypeDigitalMixerLSelPort2
type TypeDigitalMixerLSelPort2
Members
Member name | Value | Description
None | 0 | None
ADCL | 1 | ADC_L
PORT1RXL | 2 | PORT1_RX_L
DACINTERPL | 3 | DAC_INTERP_L
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeDigitalMixerMxrClkSelDeci Enumeration

IRD

Lm49350TypeDigitalMixerMxrClkSelDeci Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDigitalMixerMxrClkSelDeci
Public Enumeration TypeDigitalMixerMxrClkSelDeci
public enum class TypeDigitalMixerMxrClkSelDeci
type TypeDigitalMixerMxrClkSelDeci
Members
Member name | Value | Description
Auto | 0 | Auto
MCLK | 1 | MCLK
DAC | 2 | DAC
ADC | 3 | ADC
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeDigitalMixerRSelDeci Enumeration

IRD

Lm49350TypeDigitalMixerRSelDeci Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDigitalMixerRSelDeci
Public Enumeration TypeDigitalMixerRSelDeci
public enum class TypeDigitalMixerRSelDeci
type TypeDigitalMixerRSelDeci
Members
Member name | Value | Description
None | 0 | None
PORT1RXR | 1 | PORT1_RX_R
PORT2RXR | 2 | PORT2_RX_R
DACINTERPR | 3 | DAC_INTERP_R
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeDigitalMixerRSelPort1 Enumeration

IRD

Lm49350TypeDigitalMixerRSelPort1 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDigitalMixerRSelPort1
Public Enumeration TypeDigitalMixerRSelPort1
public enum class TypeDigitalMixerRSelPort1
type TypeDigitalMixerRSelPort1
Members
Member name | Value | Description
None | 0 | None
ADCR | 1 | ADC_R
PORT2RXR | 2 | PORT2_RX_R
DACINTERPR | 3 | DAC_INTERP_R
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeDigitalMixerRSelPort2 Enumeration

IRD

Lm49350TypeDigitalMixerRSelPort2 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDigitalMixerRSelPort2
Public Enumeration TypeDigitalMixerRSelPort2
public enum class TypeDigitalMixerRSelPort2
type TypeDigitalMixerRSelPort2
Members
Member name | Value | Description
None | 0 | None
ADCR | 1 | ADC_R
PORT1RXR | 2 | PORT1_RX_R
DACINTERPR | 3 | DAC_INTERP_R
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeEnabledDisabled Enumeration

IRD

Lm49350TypeEnabledDisabled Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeEnabledDisabled
Public Enumeration TypeEnabledDisabled
public enum class TypeEnabledDisabled
type TypeEnabledDisabled
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeGpioMode Enumeration

IRD

Lm49350TypeGpioMode Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpioMode
Public Enumeration TypeGpioMode
public enum class TypeGpioMode
type TypeGpioMode
Members
Member name | Value | Description
OFF | 0 | OFF
GPIORX | 1 | GPIO_RX
GPIOTX | 2 | GPIO_TX
HPENBTRUE | 3 | HP_ENB: TRUE
HPENBFALSE | 4 | HP_ENB: FALSE
LSENBTRUE | 5 | LS_ENB: TRUE
LSENBFALSE | 6 | LS_ENB: FALSE
SHORTCCTTHERMAL | 7 | SHORT_CCT / THERMAL
SHORTCCTTHERMALCLIP | 8 | SHORT_CCT / THERMAL / CLIP
CLIP | 9 | CLIP
ADCNGACTIVETRUE | 10 | ADC_NG_ACTIVE: TRUE
ADCNGACTIVEFALSE | 11 | ADC_NG_ACTIVE: FALSE
MICMUTETRUE | 12 | MIC_MUTE: TRUE
MICMUTEFALSE | 13 | MIC_MUTE: FALSE
CHIPENBTRUE | 14 | CHIP_ENB: TRUE
CHIPENBFALSE | 15 | CHIP_ENB: FALSE
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeMicLevel Enumeration

IRD

Lm49350TypeMicLevel Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMicLevel
Public Enumeration TypeMicLevel
public enum class TypeMicLevel
type TypeMicLevel
Members
Member name | Value | Description
Value_6 | 0 | 6
Value_8 | 1 | 8
Value_10 | 2 | 10
Value_12 | 3 | 12
Value_14 | 4 | 14
Value_16 | 5 | 16
Value_18 | 6 | 18
Value_20 | 7 | 20
Value_22 | 8 | 22
Value_24 | 9 | 24
Value_26 | 10 | 26
Value_28 | 11 | 28
Value_30 | 12 | 30
Value_32 | 13 | 32
Value_34 | 14 | 34
Value_36 | 15 | 36
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeMixerAddedNotAdded Enumeration

IRD

Lm49350TypeMixerAddedNotAdded Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMixerAddedNotAdded
Public Enumeration TypeMixerAddedNotAdded
public enum class TypeMixerAddedNotAdded
type TypeMixerAddedNotAdded
Members
Member name | Value | Description
NotAdded | 0 | Not Added
Added | 1 | Added
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypePllClkSel Enumeration

IRD

Lm49350TypePllClkSel Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllClkSel
Public Enumeration TypePllClkSel
public enum class TypePllClkSel
type TypePllClkSel
Members
Member name | Value | Description
MCLK | 0 | MCLK
PORT1CLK | 1 | PORT1_CLK
PORT2CLK | 2 | PORT2_CLK
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypePllM Enumeration

IRD

Lm49350TypePllM Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllM
Public Enumeration TypePllM
public enum class TypePllM
type TypePllM
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_1__1 | 1 | 1
Value_1_5 | 2 | 1.5
Value_2 | 3 | 2
Value_2_5 | 4 | 2.5
Value_3 | 5 | 3
Value_3_5 | 6 | 3.5
Value_4 | 7 | 4
Value_4_5 | 8 | 4.5
Value_5 | 9 | 5
Value_5_5 | 10 | 5.5
Value_6 | 11 | 6
Value_6_5 | 12 | 6.5
Value_7 | 13 | 7
Value_7_5 | 14 | 7.5
Value_8 | 15 | 8
Value_8_5 | 16 | 8.5
Value_9 | 17 | 9
Value_9_5 | 18 | 9.5
Value_10 | 19 | 10
Value_10_5 | 20 | 10.5
Value_11 | 21 | 11
Value_11_5 | 22 | 11.5
Value_12 | 23 | 12
Value_12_5 | 24 | 12.5
Value_13 | 25 | 13
Value_13_5 | 26 | 13.5
Value_14 | 27 | 14
Value_14_5 | 28 | 14.5
Value_15 | 29 | 15
Value_15_5 | 30 | 15.5
Value_16 | 31 | 16
Value_16_5 | 32 | 16.5
Value_17 | 33 | 17
Value_17_5 | 34 | 17.5
Value_18 | 35 | 18
Value_18_5 | 36 | 18.5
Value_19 | 37 | 19
Value_19_5 | 38 | 19.5
Value_20 | 39 | 20
Value_20_5 | 40 | 20.5
Value_21 | 41 | 21
Value_21_5 | 42 | 21.5
Value_22 | 43 | 22
Value_22_5 | 44 | 22.5
Value_23 | 45 | 23
Value_23_5 | 46 | 23.5
Value_24 | 47 | 24
Value_24_5 | 48 | 24.5
Value_25 | 49 | 25
Value_25_5 | 50 | 25.5
Value_26 | 51 | 26
Value_26_5 | 52 | 26.5
Value_27 | 53 | 27
Value_27_5 | 54 | 27.5
Value_28 | 55 | 28
Value_28_5 | 56 | 28.5
Value_29 | 57 | 29
Value_29_5 | 58 | 29.5
Value_30 | 59 | 30
Value_30_5 | 60 | 30.5
Value_31 | 61 | 31
Value_31_5 | 62 | 31.5
Value_32 | 63 | 32
Value_32_5 | 64 | 32.5
Value_33 | 65 | 33
Value_33_5 | 66 | 33.5
Value_34 | 67 | 34
Value_34_5 | 68 | 34.5
Value_35 | 69 | 35
Value_35_5 | 70 | 35.5
Value_36 | 71 | 36
Value_36_5 | 72 | 36.5
Value_37 | 73 | 37
Value_37_5 | 74 | 37.5
Value_38 | 75 | 38
Value_38_5 | 76 | 38.5
Value_39 | 77 | 39
Value_39_5 | 78 | 39.5
Value_40 | 79 | 40
Value_40_5 | 80 | 40.5
Value_41 | 81 | 41
Value_41_5 | 82 | 41.5
Value_42 | 83 | 42
Value_42_5 | 84 | 42.5
Value_43 | 85 | 43
Value_43_5 | 86 | 43.5
Value_44 | 87 | 44
Value_44_5 | 88 | 44.5
Value_45 | 89 | 45
Value_45_5 | 90 | 45.5
Value_46 | 91 | 46
Value_46_5 | 92 | 46.5
Value_47 | 93 | 47
Value_47_5 | 94 | 47.5
Value_48 | 95 | 48
Value_48_5 | 96 | 48.5
Value_49 | 97 | 49
Value_49_5 | 98 | 49.5
Value_50 | 99 | 50
Value_50_5 | 100 | 50.5
Value_51 | 101 | 51
Value_51_5 | 102 | 51.5
Value_52 | 103 | 52
Value_52_5 | 104 | 52.5
Value_53 | 105 | 53
Value_53_5 | 106 | 53.5
Value_54 | 107 | 54
Value_54_5 | 108 | 54.5
Value_55 | 109 | 55
Value_55_5 | 110 | 55.5
Value_56 | 111 | 56
Value_56_5 | 112 | 56.5
Value_57 | 113 | 57
Value_57_5 | 114 | 57.5
Value_58 | 115 | 58
Value_58_5 | 116 | 58.5
Value_59 | 117 | 59
Value_59_5 | 118 | 59.5
Value_60 | 119 | 60
Value_60_5 | 120 | 60.5
Value_61 | 121 | 61
Value_61_5 | 122 | 61.5
Value_62 | 123 | 62
Value_62_5 | 124 | 62.5
Value_63 | 125 | 63
Value_63_5 | 126 | 63.5
Value_64 | 127 | 64
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypePllN Enumeration

IRD

Lm49350TypePllN Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllN
Public Enumeration TypePllN
public enum class TypePllN
type TypePllN
Members
Member name | Value | Description
Value_10 | 0 | 10
Value_11 | 11 | 11
Value_12 | 12 | 12
Value_13 | 13 | 13
Value_14 | 14 | 14
Value_15 | 15 | 15
Value_16 | 16 | 16
Value_17 | 17 | 17
Value_18 | 18 | 18
Value_19 | 19 | 19
Value_20 | 20 | 20
Value_21 | 21 | 21
Value_22 | 22 | 22
Value_23 | 23 | 23
Value_24 | 24 | 24
Value_25 | 25 | 25
Value_26 | 26 | 26
Value_27 | 27 | 27
Value_28 | 28 | 28
Value_29 | 29 | 29
Value_30 | 30 | 30
Value_31 | 31 | 31
Value_32 | 32 | 32
Value_33 | 33 | 33
Value_34 | 34 | 34
Value_35 | 35 | 35
Value_36 | 36 | 36
Value_37 | 37 | 37
Value_38 | 38 | 38
Value_39 | 39 | 39
Value_40 | 40 | 40
Value_41 | 41 | 41
Value_42 | 42 | 42
Value_43 | 43 | 43
Value_44 | 44 | 44
Value_45 | 45 | 45
Value_46 | 46 | 46
Value_47 | 47 | 47
Value_48 | 48 | 48
Value_49 | 49 | 49
Value_50 | 50 | 50
Value_51 | 51 | 51
Value_52 | 52 | 52
Value_53 | 53 | 53
Value_54 | 54 | 54
Value_55 | 55 | 55
Value_56 | 56 | 56
Value_57 | 57 | 57
Value_58 | 58 | 58
Value_59 | 59 | 59
Value_60 | 60 | 60
Value_61 | 61 | 61
Value_62 | 62 | 62
Value_63 | 63 | 63
Value_64 | 64 | 64
Value_65 | 65 | 65
Value_66 | 66 | 66
Value_67 | 67 | 67
Value_68 | 68 | 68
Value_69 | 69 | 69
Value_70 | 70 | 70
Value_71 | 71 | 71
Value_72 | 72 | 72
Value_73 | 73 | 73
Value_74 | 74 | 74
Value_75 | 75 | 75
Value_76 | 76 | 76
Value_77 | 77 | 77
Value_78 | 78 | 78
Value_79 | 79 | 79
Value_80 | 80 | 80
Value_81 | 81 | 81
Value_82 | 82 | 82
Value_83 | 83 | 83
Value_84 | 84 | 84
Value_85 | 85 | 85
Value_86 | 86 | 86
Value_87 | 87 | 87
Value_88 | 88 | 88
Value_89 | 89 | 89
Value_90 | 90 | 90
Value_91 | 91 | 91
Value_92 | 92 | 92
Value_93 | 93 | 93
Value_94 | 94 | 94
Value_95 | 95 | 95
Value_96 | 96 | 96
Value_97 | 97 | 97
Value_98 | 98 | 98
Value_99 | 99 | 99
Value_100 | 100 | 100
Value_101 | 101 | 101
Value_102 | 102 | 102
Value_103 | 103 | 103
Value_104 | 104 | 104
Value_105 | 105 | 105
Value_106 | 106 | 106
Value_107 | 107 | 107
Value_108 | 108 | 108
Value_109 | 109 | 109
Value_110 | 110 | 110
Value_111 | 111 | 111
Value_112 | 112 | 112
Value_113 | 113 | 113
Value_114 | 114 | 114
Value_115 | 115 | 115
Value_116 | 116 | 116
Value_117 | 117 | 117
Value_118 | 118 | 118
Value_119 | 119 | 119
Value_120 | 120 | 120
Value_121 | 121 | 121
Value_122 | 122 | 122
Value_123 | 123 | 123
Value_124 | 124 | 124
Value_125 | 125 | 125
Value_126 | 126 | 126
Value_127 | 127 | 127
Value_128 | 128 | 128
Value_129 | 129 | 129
Value_130 | 130 | 130
Value_131 | 131 | 131
Value_132 | 132 | 132
Value_133 | 133 | 133
Value_134 | 134 | 134
Value_135 | 135 | 135
Value_136 | 136 | 136
Value_137 | 137 | 137
Value_138 | 138 | 138
Value_139 | 139 | 139
Value_140 | 140 | 140
Value_141 | 141 | 141
Value_142 | 142 | 142
Value_143 | 143 | 143
Value_144 | 144 | 144
Value_145 | 145 | 145
Value_146 | 146 | 146
Value_147 | 147 | 147
Value_148 | 148 | 148
Value_149 | 149 | 149
Value_150 | 150 | 150
Value_151 | 151 | 151
Value_152 | 152 | 152
Value_153 | 153 | 153
Value_154 | 154 | 154
Value_155 | 155 | 155
Value_156 | 156 | 156
Value_157 | 157 | 157
Value_158 | 158 | 158
Value_159 | 159 | 159
Value_160 | 160 | 160
Value_161 | 161 | 161
Value_162 | 162 | 162
Value_163 | 163 | 163
Value_164 | 164 | 164
Value_165 | 165 | 165
Value_166 | 166 | 166
Value_167 | 167 | 167
Value_168 | 168 | 168
Value_169 | 169 | 169
Value_170 | 170 | 170
Value_171 | 171 | 171
Value_172 | 172 | 172
Value_173 | 173 | 173
Value_174 | 174 | 174
Value_175 | 175 | 175
Value_176 | 176 | 176
Value_177 | 177 | 177
Value_178 | 178 | 178
Value_179 | 179 | 179
Value_180 | 180 | 180
Value_181 | 181 | 181
Value_182 | 182 | 182
Value_183 | 183 | 183
Value_184 | 184 | 184
Value_185 | 185 | 185
Value_186 | 186 | 186
Value_187 | 187 | 187
Value_188 | 188 | 188
Value_189 | 189 | 189
Value_190 | 190 | 190
Value_191 | 191 | 191
Value_192 | 192 | 192
Value_193 | 193 | 193
Value_194 | 194 | 194
Value_195 | 195 | 195
Value_196 | 196 | 196
Value_197 | 197 | 197
Value_198 | 198 | 198
Value_199 | 199 | 199
Value_200 | 200 | 200
Value_201 | 201 | 201
Value_202 | 202 | 202
Value_203 | 203 | 203
Value_204 | 204 | 204
Value_205 | 205 | 205
Value_206 | 206 | 206
Value_207 | 207 | 207
Value_208 | 208 | 208
Value_209 | 209 | 209
Value_210 | 210 | 210
Value_211 | 211 | 211
Value_212 | 212 | 212
Value_213 | 213 | 213
Value_214 | 214 | 214
Value_215 | 215 | 215
Value_216 | 216 | 216
Value_217 | 217 | 217
Value_218 | 218 | 218
Value_219 | 219 | 219
Value_220 | 220 | 220
Value_221 | 221 | 221
Value_222 | 222 | 222
Value_223 | 223 | 223
Value_224 | 224 | 224
Value_225 | 225 | 225
Value_226 | 226 | 226
Value_227 | 227 | 227
Value_228 | 228 | 228
Value_229 | 229 | 229
Value_230 | 230 | 230
Value_231 | 231 | 231
Value_232 | 232 | 232
Value_233 | 233 | 233
Value_234 | 234 | 234
Value_235 | 235 | 235
Value_236 | 236 | 236
Value_237 | 237 | 237
Value_238 | 238 | 238
Value_239 | 239 | 239
Value_240 | 240 | 240
Value_241 | 241 | 241
Value_242 | 242 | 242
Value_243 | 243 | 243
Value_244 | 244 | 244
Value_245 | 245 | 245
Value_246 | 246 | 246
Value_247 | 247 | 247
Value_248 | 248 | 248
Value_249 | 249 | 249
Value_250 | 250 | 250
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypePllNMod Enumeration

IRD

Lm49350TypePllNMod Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllNMod
Public Enumeration TypePllNMod
public enum class TypePllNMod
type TypePllNMod
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_131 | 1 | 1/31
Value_231 | 2 | 2/31
Value_331 | 3 | 3/31
Value_431 | 4 | 4/31
Value_531 | 5 | 5/31
Value_631 | 6 | 6/31
Value_731 | 7 | 7/31
Value_831 | 8 | 8/31
Value_931 | 9 | 9/31
Value_1031 | 10 | 10/31
Value_1131 | 11 | 11/31
Value_1231 | 12 | 12/31
Value_1331 | 13 | 13/31
Value_1431 | 14 | 14/31
Value_1531 | 15 | 15/31
Value_1631 | 16 | 16/31
Value_1731 | 17 | 17/31
Value_1831 | 18 | 18/31
Value_1931 | 19 | 19/31
Value_2031 | 20 | 20/31
Value_2131 | 21 | 21/31
Value_2231 | 22 | 22/31
Value_2331 | 23 | 23/31
Value_2431 | 24 | 24/31
Value_2531 | 25 | 25/31
Value_2631 | 26 | 26/31
Value_2731 | 27 | 27/31
Value_2831 | 28 | 28/31
Value_2931 | 29 | 29/31
Value_3031 | 30 | 30/31
Value_3131 | 31 | 31/31
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypePllP Enumeration

IRD

Lm49350TypePllP Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllP
Public Enumeration TypePllP
public enum class TypePllP
type TypePllP
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_1_5 | 2 | 1.5
Value_2 | 3 | 2
Value_2_5 | 4 | 2.5
Value_3 | 5 | 3
Value_3_5 | 6 | 3.5
Value_4 | 7 | 4
Value_4_5 | 8 | 4.5
Value_5 | 9 | 5
Value_5_5 | 10 | 5.5
Value_6 | 11 | 6
Value_6_5 | 12 | 6.5
Value_7 | 13 | 7
Value_7_5 | 14 | 7.5
Value_8 | 15 | 8
Value_8_5 | 16 | 8.5
Value_9 | 17 | 9
Value_9_5 | 18 | 9.5
Value_10 | 19 | 10
Value_10_5 | 20 | 10.5
Value_11 | 21 | 11
Value_11_5 | 22 | 11.5
Value_12 | 23 | 12
Value_12_5 | 24 | 12.5
Value_13 | 25 | 13
Value_13_5 | 26 | 13.5
Value_14 | 27 | 14
Value_14_5 | 28 | 14.5
Value_15 | 29 | 15
Value_15_5 | 30 | 15.5
Value_16 | 31 | 16
Value_16_5 | 32 | 16.5
Value_17 | 33 | 17
Value_17_5 | 34 | 17.5
Value_18 | 35 | 18
Value_18_5 | 36 | 18.5
Value_19 | 37 | 19
Value_19_5 | 38 | 19.5
Value_20 | 39 | 20
Value_20_5 | 40 | 20.5
Value_21 | 41 | 21
Value_21_5 | 42 | 21.5
Value_22 | 43 | 22
Value_22_5 | 44 | 22.5
Value_23 | 45 | 23
Value_23_5 | 46 | 23.5
Value_24 | 47 | 24
Value_24_5 | 48 | 24.5
Value_25 | 49 | 25
Value_25_5 | 50 | 25.5
Value_26 | 51 | 26
Value_26_5 | 52 | 26.5
Value_27 | 53 | 27
Value_27_5 | 54 | 27.5
Value_28 | 55 | 28
Value_28_5 | 56 | 28.5
Value_29 | 57 | 29
Value_29_5 | 58 | 29.5
Value_30 | 59 | 30
Value_30_5 | 60 | 30.5
Value_31 | 61 | 31
Value_31_5 | 62 | 31.5
Value_32 | 63 | 32
Value_32_5 | 64 | 32.5
Value_33 | 65 | 33
Value_33_5 | 66 | 33.5
Value_34 | 67 | 34
Value_34_5 | 68 | 34.5
Value_35 | 69 | 35
Value_35_5 | 70 | 35.5
Value_36 | 71 | 36
Value_36_5 | 72 | 36.5
Value_37 | 73 | 37
Value_37_5 | 74 | 37.5
Value_38 | 75 | 38
Value_38_5 | 76 | 38.5
Value_39 | 77 | 39
Value_39_5 | 78 | 39.5
Value_40 | 79 | 40
Value_40_5 | 80 | 40.5
Value_41 | 81 | 41
Value_41_5 | 82 | 41.5
Value_42 | 83 | 42
Value_42_5 | 84 | 42.5
Value_43 | 85 | 43
Value_43_5 | 86 | 43.5
Value_44 | 87 | 44
Value_44_5 | 88 | 44.5
Value_45 | 89 | 45
Value_45_5 | 90 | 45.5
Value_46 | 91 | 46
Value_46_5 | 92 | 46.5
Value_47 | 93 | 47
Value_47_5 | 94 | 47.5
Value_48 | 95 | 48
Value_48_5 | 96 | 48.5
Value_49 | 97 | 49
Value_49_5 | 98 | 49.5
Value_50 | 99 | 50
Value_50_5 | 100 | 50.5
Value_51 | 101 | 51
Value_51_5 | 102 | 51.5
Value_52 | 103 | 52
Value_52_5 | 104 | 52.5
Value_53 | 105 | 53
Value_53_5 | 106 | 53.5
Value_54 | 107 | 54
Value_54_5 | 108 | 54.5
Value_55 | 109 | 55
Value_55_5 | 110 | 55.5
Value_56 | 111 | 56
Value_56_5 | 112 | 56.5
Value_57 | 113 | 57
Value_57_5 | 114 | 57.5
Value_58 | 115 | 58
Value_58_5 | 116 | 58.5
Value_59 | 117 | 59
Value_59_5 | 118 | 59.5
Value_60 | 119 | 60
Value_60_5 | 120 | 60.5
Value_61 | 121 | 61
Value_61_5 | 122 | 61.5
Value_62 | 123 | 62
Value_62_5 | 124 | 62.5
Value_63 | 125 | 63
Value_63_5 | 126 | 63.5
Value_64 | 127 | 64
Value_64_5 | 128 | 64.5
Value_65 | 129 | 65
Value_65_5 | 130 | 65.5
Value_66 | 131 | 66
Value_66_5 | 132 | 66.5
Value_67 | 133 | 67
Value_67_5 | 134 | 67.5
Value_68 | 135 | 68
Value_68_5 | 136 | 68.5
Value_69 | 137 | 69
Value_69_5 | 138 | 69.5
Value_70 | 139 | 70
Value_70_5 | 140 | 70.5
Value_71 | 141 | 71
Value_71_5 | 142 | 71.5
Value_72 | 143 | 72
Value_72_5 | 144 | 72.5
Value_73 | 145 | 73
Value_73_5 | 146 | 73.5
Value_74 | 147 | 74
Value_74_5 | 148 | 74.5
Value_75 | 149 | 75
Value_75_5 | 150 | 75.5
Value_76 | 151 | 76
Value_76_5 | 152 | 76.5
Value_77 | 153 | 77
Value_77_5 | 154 | 77.5
Value_78 | 155 | 78
Value_78_5 | 156 | 78.5
Value_79 | 157 | 79
Value_79_5 | 158 | 79.5
Value_80 | 159 | 80
Value_80_5 | 160 | 80.5
Value_81 | 161 | 81
Value_81_5 | 162 | 81.5
Value_82 | 163 | 82
Value_82_5 | 164 | 82.5
Value_83 | 165 | 83
Value_83_5 | 166 | 83.5
Value_84 | 167 | 84
Value_84_5 | 168 | 84.5
Value_85 | 169 | 85
Value_85_5 | 170 | 85.5
Value_86 | 171 | 86
Value_86_5 | 172 | 86.5
Value_87 | 173 | 87
Value_87_5 | 174 | 87.5
Value_88 | 175 | 88
Value_88_5 | 176 | 88.5
Value_89 | 177 | 89
Value_89_5 | 178 | 89.5
Value_90 | 179 | 90
Value_90_5 | 180 | 90.5
Value_91 | 181 | 91
Value_91_5 | 182 | 91.5
Value_92 | 183 | 92
Value_92_5 | 184 | 92.5
Value_93 | 185 | 93
Value_93_5 | 186 | 93.5
Value_94 | 187 | 94
Value_94_5 | 188 | 94.5
Value_95 | 189 | 95
Value_95_5 | 190 | 95.5
Value_96 | 191 | 96
Value_96_5 | 192 | 96.5
Value_97 | 193 | 97
Value_97_5 | 194 | 97.5
Value_98 | 195 | 98
Value_98_5 | 196 | 98.5
Value_99 | 197 | 99
Value_99_5 | 198 | 99.5
Value_100 | 199 | 100
Value_100_5 | 200 | 100.5
Value_101 | 201 | 101
Value_101_5 | 202 | 101.5
Value_102 | 203 | 102
Value_102_5 | 204 | 102.5
Value_103 | 205 | 103
Value_103_5 | 206 | 103.5
Value_104 | 207 | 104
Value_104_5 | 208 | 104.5
Value_105 | 209 | 105
Value_105_5 | 210 | 105.5
Value_106 | 211 | 106
Value_106_5 | 212 | 106.5
Value_107 | 213 | 107
Value_107_5 | 214 | 107.5
Value_108 | 215 | 108
Value_108_5 | 216 | 108.5
Value_109 | 217 | 109
Value_109_5 | 218 | 109.5
Value_110 | 219 | 110
Value_110_5 | 220 | 110.5
Value_111 | 221 | 111
Value_111_5 | 222 | 111.5
Value_112 | 223 | 112
Value_112_5 | 224 | 112.5
Value_113 | 225 | 113
Value_113_5 | 226 | 113.5
Value_114 | 227 | 114
Value_114_5 | 228 | 114.5
Value_115 | 229 | 115
Value_115_5 | 230 | 115.5
Value_116 | 231 | 116
Value_116_5 | 232 | 116.5
Value_117 | 233 | 117
Value_117_5 | 234 | 117.5
Value_118 | 235 | 118
Value_118_5 | 236 | 118.5
Value_119 | 237 | 119
Value_119_5 | 238 | 119.5
Value_120 | 239 | 120
Value_120_5 | 240 | 120.5
Value_121 | 241 | 121
Value_121_5 | 242 | 121.5
Value_122 | 243 | 122
Value_122_5 | 244 | 122.5
Value_123 | 245 | 123
Value_123_5 | 246 | 123.5
Value_124 | 247 | 124
Value_124_5 | 248 | 124.5
Value_125 | 249 | 125
Value_125_5 | 250 | 125.5
Value_126 | 251 | 126
Value_126_5 | 252 | 126.5
Value_127 | 253 | 127
Value_127_5 | 254 | 127.5
Value_128 | 255 | 128
Value_128_5 | 256 | 128.5
Value_129 | 257 | 129
Value_129_5 | 258 | 129.5
Value_130 | 259 | 130
Value_130_5 | 260 | 130.5
Value_131 | 261 | 131
Value_131_5 | 262 | 131.5
Value_132 | 263 | 132
Value_132_5 | 264 | 132.5
Value_133 | 265 | 133
Value_133_5 | 266 | 133.5
Value_134 | 267 | 134
Value_134_5 | 268 | 134.5
Value_135 | 269 | 135
Value_135_5 | 270 | 135.5
Value_136 | 271 | 136
Value_136_5 | 272 | 136.5
Value_137 | 273 | 137
Value_137_5 | 274 | 137.5
Value_138 | 275 | 138
Value_138_5 | 276 | 138.5
Value_139 | 277 | 139
Value_139_5 | 278 | 139.5
Value_140 | 279 | 140
Value_140_5 | 280 | 140.5
Value_141 | 281 | 141
Value_141_5 | 282 | 141.5
Value_142 | 283 | 142
Value_142_5 | 284 | 142.5
Value_143 | 285 | 143
Value_143_5 | 286 | 143.5
Value_144 | 287 | 144
Value_144_5 | 288 | 144.5
Value_145 | 289 | 145
Value_145_5 | 290 | 145.5
Value_146 | 291 | 146
Value_146_5 | 292 | 146.5
Value_147 | 293 | 147
Value_147_5 | 294 | 147.5
Value_148 | 295 | 148
Value_148_5 | 296 | 148.5
Value_149 | 297 | 149
Value_149_5 | 298 | 149.5
Value_150 | 299 | 150
Value_150_5 | 300 | 150.5
Value_151 | 301 | 151
Value_151_5 | 302 | 151.5
Value_152 | 303 | 152
Value_152_5 | 304 | 152.5
Value_153 | 305 | 153
Value_153_5 | 306 | 153.5
Value_154 | 307 | 154
Value_154_5 | 308 | 154.5
Value_155 | 309 | 155
Value_155_5 | 310 | 155.5
Value_156 | 311 | 156
Value_156_5 | 312 | 156.5
Value_157 | 313 | 157
Value_157_5 | 314 | 157.5
Value_158 | 315 | 158
Value_158_5 | 316 | 158.5
Value_159 | 317 | 159
Value_159_5 | 318 | 159.5
Value_160 | 319 | 160
Value_160_5 | 320 | 160.5
Value_161 | 321 | 161
Value_161_5 | 322 | 161.5
Value_162 | 323 | 162
Value_162_5 | 324 | 162.5
Value_163 | 325 | 163
Value_163_5 | 326 | 163.5
Value_164 | 327 | 164
Value_164_5 | 328 | 164.5
Value_165 | 329 | 165
Value_165_5 | 330 | 165.5
Value_166 | 331 | 166
Value_166_5 | 332 | 166.5
Value_167 | 333 | 167
Value_167_5 | 334 | 167.5
Value_168 | 335 | 168
Value_168_5 | 336 | 168.5
Value_169 | 337 | 169
Value_169_5 | 338 | 169.5
Value_170 | 339 | 170
Value_170_5 | 340 | 170.5
Value_171 | 341 | 171
Value_171_5 | 342 | 171.5
Value_172 | 343 | 172
Value_172_5 | 344 | 172.5
Value_173 | 345 | 173
Value_173_5 | 346 | 173.5
Value_174 | 347 | 174
Value_174_5 | 348 | 174.5
Value_175 | 349 | 175
Value_175_5 | 350 | 175.5
Value_176 | 351 | 176
Value_176_5 | 352 | 176.5
Value_177 | 353 | 177
Value_177_5 | 354 | 177.5
Value_178 | 355 | 178
Value_178_5 | 356 | 178.5
Value_179 | 357 | 179
Value_179_5 | 358 | 179.5
Value_180 | 359 | 180
Value_180_5 | 360 | 180.5
Value_181 | 361 | 181
Value_181_5 | 362 | 181.5
Value_182 | 363 | 182
Value_182_5 | 364 | 182.5
Value_183 | 365 | 183
Value_183_5 | 366 | 183.5
Value_184 | 367 | 184
Value_184_5 | 368 | 184.5
Value_185 | 369 | 185
Value_185_5 | 370 | 185.5
Value_186 | 371 | 186
Value_186_5 | 372 | 186.5
Value_187 | 373 | 187
Value_187_5 | 374 | 187.5
Value_188 | 375 | 188
Value_188_5 | 376 | 188.5
Value_189 | 377 | 189
Value_189_5 | 378 | 189.5
Value_190 | 379 | 190
Value_190_5 | 380 | 190.5
Value_191 | 381 | 191
Value_191_5 | 382 | 191.5
Value_192 | 383 | 192
Value_192_5 | 384 | 192.5
Value_193 | 385 | 193
Value_193_5 | 386 | 193.5
Value_194 | 387 | 194
Value_194_5 | 388 | 194.5
Value_195 | 389 | 195
Value_195_5 | 390 | 195.5
Value_196 | 391 | 196
Value_196_5 | 392 | 196.5
Value_197 | 393 | 197
Value_197_5 | 394 | 197.5
Value_198 | 395 | 198
Value_198_5 | 396 | 198.5
Value_199 | 397 | 199
Value_199_5 | 398 | 199.5
Value_200 | 399 | 200
Value_200_5 | 400 | 200.5
Value_201 | 401 | 201
Value_201_5 | 402 | 201.5
Value_202 | 403 | 202
Value_202_5 | 404 | 202.5
Value_203 | 405 | 203
Value_203_5 | 406 | 203.5
Value_204 | 407 | 204
Value_204_5 | 408 | 204.5
Value_205 | 409 | 205
Value_205_5 | 410 | 205.5
Value_206 | 411 | 206
Value_206_5 | 412 | 206.5
Value_207 | 413 | 207
Value_207_5 | 414 | 207.5
Value_208 | 415 | 208
Value_208_5 | 416 | 208.5
Value_209 | 417 | 209
Value_209_5 | 418 | 209.5
Value_210 | 419 | 210
Value_210_5 | 420 | 210.5
Value_211 | 421 | 211
Value_211_5 | 422 | 211.5
Value_212 | 423 | 212
Value_212_5 | 424 | 212.5
Value_213 | 425 | 213
Value_213_5 | 426 | 213.5
Value_214 | 427 | 214
Value_214_5 | 428 | 214.5
Value_215 | 429 | 215
Value_215_5 | 430 | 215.5
Value_216 | 431 | 216
Value_216_5 | 432 | 216.5
Value_217 | 433 | 217
Value_217_5 | 434 | 217.5
Value_218 | 435 | 218
Value_218_5 | 436 | 218.5
Value_219 | 437 | 219
Value_219_5 | 438 | 219.5
Value_220 | 439 | 220
Value_220_5 | 440 | 220.5
Value_221 | 441 | 221
Value_221_5 | 442 | 221.5
Value_222 | 443 | 222
Value_222_5 | 444 | 222.5
Value_223 | 445 | 223
Value_223_5 | 446 | 223.5
Value_224 | 447 | 224
Value_224_5 | 448 | 224.5
Value_225 | 449 | 225
Value_225_5 | 450 | 225.5
Value_226 | 451 | 226
Value_226_5 | 452 | 226.5
Value_227 | 453 | 227
Value_227_5 | 454 | 227.5
Value_228 | 455 | 228
Value_228_5 | 456 | 228.5
Value_229 | 457 | 229
Value_229_5 | 458 | 229.5
Value_230 | 459 | 230
Value_230_5 | 460 | 230.5
Value_231 | 461 | 231
Value_231_5 | 462 | 231.5
Value_232 | 463 | 232
Value_232_5 | 464 | 232.5
Value_233 | 465 | 233
Value_233_5 | 466 | 233.5
Value_234 | 467 | 234
Value_234_5 | 468 | 234.5
Value_235 | 469 | 235
Value_235_5 | 470 | 235.5
Value_236 | 471 | 236
Value_236_5 | 472 | 236.5
Value_237 | 473 | 237
Value_237_5 | 474 | 237.5
Value_238 | 475 | 238
Value_238_5 | 476 | 238.5
Value_239 | 477 | 239
Value_239_5 | 478 | 239.5
Value_240 | 479 | 240
Value_240_5 | 480 | 240.5
Value_241 | 481 | 241
Value_241_5 | 482 | 241.5
Value_242 | 483 | 242
Value_242_5 | 484 | 242.5
Value_243 | 485 | 243
Value_243_5 | 486 | 243.5
Value_244 | 487 | 244
Value_244_5 | 488 | 244.5
Value_245 | 489 | 245
Value_245_5 | 490 | 245.5
Value_246 | 491 | 246
Value_246_5 | 492 | 246.5
Value_247 | 493 | 247
Value_247_5 | 494 | 247.5
Value_248 | 495 | 248
Value_248_5 | 496 | 248.5
Value_249 | 497 | 249
Value_249_5 | 498 | 249.5
Value_250 | 499 | 250
Value_250_5 | 500 | 250.5
Value_251 | 501 | 251
Value_251_5 | 502 | 251.5
Value_252 | 503 | 252
Value_252_5 | 504 | 252.5
Value_253 | 505 | 253
Value_253_5 | 506 | 253.5
Value_254 | 507 | 254
Value_254_5 | 508 | 254.5
Value_255 | 509 | 255
Value_255_5 | 510 | 255.5
Value_256 | 511 | 256
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypePmcClocks Enumeration

IRD

Lm49350TypePmcClocks Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePmcClocks
Public Enumeration TypePmcClocks
public enum class TypePmcClocks
type TypePmcClocks
Members
Member name | Value | Description
MCLK | 0 | MCLK
Internal300KHzOscillator | 1 | Internal 300 kHz Oscillator
DACSOURCECLOCK | 2 | DAC SOURCE CLOCK
ADCSOURCECLOCK | 3 | ADC SOURCE CLOCK
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypePmcSetupChipActive Enumeration

IRD

Lm49350TypePmcSetupChipActive Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePmcSetupChipActive
Public Enumeration TypePmcSetupChipActive
public enum class TypePmcSetupChipActive
type TypePmcSetupChipActive
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypePmcSetupChipEnable Enumeration

IRD

Lm49350TypePmcSetupChipEnable Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePmcSetupChipEnable
Public Enumeration TypePmcSetupChipEnable
public enum class TypePmcSetupChipEnable
type TypePmcSetupChipEnable
Members
Member name | Value | Description
ChipOff | 0 | Chip: Off
ChipOn | 1 | Chip: On
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypePmcSetupMclkOvr Enumeration

IRD

Lm49350TypePmcSetupMclkOvr Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePmcSetupMclkOvr
Public Enumeration TypePmcSetupMclkOvr
public enum class TypePmcSetupMclkOvr
type TypePmcSetupMclkOvr
Members
Member name | Value | Description
IOControlAutomatic | 0 | I/O Control Automatic
MCLKInputForcedOn | 1 | MCLK Input Forced On
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypePmcSetupOscEnb Enumeration

IRD

Lm49350TypePmcSetupOscEnb Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePmcSetupOscEnb
Public Enumeration TypePmcSetupOscEnb
public enum class TypePmcSetupOscEnb
type TypePmcSetupOscEnb
Members
Member name | Value | Description
OscillatorOff | 0 | Oscillator: Off
OscillatorOn | 1 | Oscillator: On
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypePmcSetupPll1Enb Enumeration

IRD

Lm49350TypePmcSetupPll1Enb Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePmcSetupPll1Enb
Public Enumeration TypePmcSetupPll1Enb
public enum class TypePmcSetupPll1Enb
type TypePmcSetupPll1Enb
Members
Member name | Value | Description
PLL1Off | 0 | PLL1: Off
PLL1On | 1 | PLL1: On
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypePmcSetupPll2Enb Enumeration

IRD

Lm49350TypePmcSetupPll2Enb Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePmcSetupPll2Enb
Public Enumeration TypePmcSetupPll2Enb
public enum class TypePmcSetupPll2Enb
type TypePmcSetupPll2Enb
Members
Member name | Value | Description
PLL2Off | 0 | PLL2: Off
PLL2On | 1 | PLL2: On
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypePmcSetupPortClkOvr Enumeration

IRD

Lm49350TypePmcSetupPortClkOvr Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePmcSetupPortClkOvr
Public Enumeration TypePmcSetupPortClkOvr
public enum class TypePmcSetupPortClkOvr
type TypePmcSetupPortClkOvr
Members
Member name | Value | Description
IOControlAutomatic | 0 | I/O Control Automatic
PORTCLKInputForcedOn | 1 | PORT_CLK Input Forced On
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49350.TypeSetNotSet Enumeration

IRD

Lm49350TypeSetNotSet Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSetNotSet
Public Enumeration TypeSetNotSet
public enum class TypeSetNotSet
type TypeSetNotSet
Members
Member name | Value | Description
NotSet | 0 | Not Set
Set | 1 | Set
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450 Class

National Semiconductor: LM 49450
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm49450

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm49450
Public Class Lm49450
public ref class Lm49450
type Lm49450 =  class end

The Lm49450 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm49450 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChargePumpClock | Charge Pump Clock
Public property | ClockControlDACDITHEROFF | Clock Control (DAC_DITHER_OFF)
Public property | ClockControlDACDITHERON | Clock Control (DAC_DITHER_ON)
Public property | ClockControlRDIV | Clock Control (RDIV)
Public property | CMP0LSB | CMP_0_LSB
Public property | CMP0MSB | CMP_0_MSB
Public property | CMP1LSB | CMP_1_LSB
Public property | CMP1MSB | CMP_1_MSB
Public property | CMP2LSB | CMP_2_LSB
Public property | CMP2MSB | CMP_2_MSB
Public property | Headphone3DConfigurationHP3D | Headphone 3D Configuration (HP_3D)
Public property | Headphone3DConfigurationHP3DATTN | Headphone 3D Configuration (HP_3DATTN)
Public property | Headphone3DConfigurationHP3DEN | Headphone 3D Configuration (HP_3DEN)
Public property | Headphone3DConfigurationHP3DFREQ | Headphone 3D Configuration (HP_3DFREQ) (unit: Hz)
Public property | Headphone3DConfigurationHP3DMIX | Headphone 3D Configuration (HP_3DMIX) (unit: %)
Public property | HeadphoneVolumeControl | Headphone Volume Control (unit: dB)
Public property | I2SClockI2SCLK | I2S Clock (I2S_CLK)
Public property | I2SClockI2SCLKMS | I2S Clock (I2S_CLK_MS)
Public property | I2SClockI2SWS | I2S Clock (I2S_WS)
Public property | I2SClockI2SWSMS | I2S Clock (I2S_WS_MS)
Public property | I2SModeI2SMODE | I2S Mode (I2S_MODE)
Public property | I2SModeI2SSTEREOREVERSE | I2S Mode (I2S_STEREO_REVERSE)
Public property | I2SModeI2SWORDORDER | I2S Mode (I2S_WORD_ORDER)
Public property | I2SModeI2SWRD | I2S Mode (I2S_WRD)
Public property | Loudspeaker3DConfigurationLS3D | Loudspeaker 3D Configuration (LS_3D)
Public property | Loudspeaker3DConfigurationLS3DATTN | Loudspeaker 3D Configuration (LS_3DATTN)
Public property | Loudspeaker3DConfigurationLS3DEN | Loudspeaker 3D Configuration (LS_3DEN)
Public property | Loudspeaker3DConfigurationLS3DFREQ | Loudspeaker 3D Configuration (LS_3DFREQ) (unit: Hz)
Public property | Loudspeaker3DConfigurationLS3DMIX | Loudspeaker 3D Configuration (LS_3DMIX) (unit: %)
Public property | LoudspeakerVolumeControl | Loudspeaker Volume Control (unit: dB)
Public property | ModeControlCOMP | Mode Control (COMP)
Public property | ModeControlDACMODE | Mode Control (DAC_MODE)
Public property | ModeControlENABLE | Mode Control (ENABLE)
Public property | ModeControlEXTREF | Mode Control (EXT_REF)
Public property | ModeControlMUTE | Mode Control (MUTE)
Public property | ModeControlSS | Mode Control (SS)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
I2S Input, 2.5W/Channel, Low EMI, Stereo, Class D Audio Sub-System with Ground Referenced Headphone Amplifier, 3D Enhancement, and Headphone Sense
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm49450(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm49450

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450 Properties

The Lm49450 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChargePumpClock | Charge Pump Clock
Public property | ClockControlDACDITHEROFF | Clock Control (DAC_DITHER_OFF)
Public property | ClockControlDACDITHERON | Clock Control (DAC_DITHER_ON)
Public property | ClockControlRDIV | Clock Control (RDIV)
Public property | CMP0LSB | CMP_0_LSB
Public property | CMP0MSB | CMP_0_MSB
Public property | CMP1LSB | CMP_1_LSB
Public property | CMP1MSB | CMP_1_MSB
Public property | CMP2LSB | CMP_2_LSB
Public property | CMP2MSB | CMP_2_MSB
Public property | Headphone3DConfigurationHP3D | Headphone 3D Configuration (HP_3D)
Public property | Headphone3DConfigurationHP3DATTN | Headphone 3D Configuration (HP_3DATTN)
Public property | Headphone3DConfigurationHP3DEN | Headphone 3D Configuration (HP_3DEN)
Public property | Headphone3DConfigurationHP3DFREQ | Headphone 3D Configuration (HP_3DFREQ) (unit: Hz)
Public property | Headphone3DConfigurationHP3DMIX | Headphone 3D Configuration (HP_3DMIX) (unit: %)
Public property | HeadphoneVolumeControl | Headphone Volume Control (unit: dB)
Public property | I2SClockI2SCLK | I2S Clock (I2S_CLK)
Public property | I2SClockI2SCLKMS | I2S Clock (I2S_CLK_MS)
Public property | I2SClockI2SWS | I2S Clock (I2S_WS)
Public property | I2SClockI2SWSMS | I2S Clock (I2S_WS_MS)
Public property | I2SModeI2SMODE | I2S Mode (I2S_MODE)
Public property | I2SModeI2SSTEREOREVERSE | I2S Mode (I2S_STEREO_REVERSE)
Public property | I2SModeI2SWORDORDER | I2S Mode (I2S_WORD_ORDER)
Public property | I2SModeI2SWRD | I2S Mode (I2S_WRD)
Public property | Loudspeaker3DConfigurationLS3D | Loudspeaker 3D Configuration (LS_3D)
Public property | Loudspeaker3DConfigurationLS3DATTN | Loudspeaker 3D Configuration (LS_3DATTN)
Public property | Loudspeaker3DConfigurationLS3DEN | Loudspeaker 3D Configuration (LS_3DEN)
Public property | Loudspeaker3DConfigurationLS3DFREQ | Loudspeaker 3D Configuration (LS_3DFREQ) (unit: Hz)
Public property | Loudspeaker3DConfigurationLS3DMIX | Loudspeaker 3D Configuration (LS_3DMIX) (unit: %)
Public property | LoudspeakerVolumeControl | Loudspeaker Volume Control (unit: dB)
Public property | ModeControlCOMP | Mode Control (COMP)
Public property | ModeControlDACMODE | Mode Control (DAC_MODE)
Public property | ModeControlENABLE | Mode Control (ENABLE)
Public property | ModeControlEXTREF | Mode Control (EXT_REF)
Public property | ModeControlMUTE | Mode Control (MUTE)
Public property | ModeControlSS | Mode Control (SS)
Top
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.AutoFlush Property

IRD

Lm49450AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.ChargePumpClock Property

IRD

Lm49450ChargePumpClock Property

Charge Pump Clock

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeChargePump ChargePumpClock { get; set; }
Public Property ChargePumpClock As Lm49450TypeChargePump
    Get
    Set
public:
property Lm49450TypeChargePump ChargePumpClock {
    Lm49450TypeChargePump get ();
    void set (Lm49450TypeChargePump value);
}
member ChargePumpClock : Lm49450TypeChargePump with get, set

Property Value

Type: Lm49450TypeChargePump
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.ClockControlDACDITHEROFF Property

IRD

Lm49450ClockControlDACDITHEROFF Property

Clock Control (DAC_DITHER_OFF)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeClockDacDitherOff ClockControlDACDITHEROFF { get; set; }
Public Property ClockControlDACDITHEROFF As Lm49450TypeClockDacDitherOff
    Get
    Set
public:
property Lm49450TypeClockDacDitherOff ClockControlDACDITHEROFF {
    Lm49450TypeClockDacDitherOff get ();
    void set (Lm49450TypeClockDacDitherOff value);
}
member ClockControlDACDITHEROFF : Lm49450TypeClockDacDitherOff with get, set

Property Value

Type: Lm49450TypeClockDacDitherOff
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.ClockControlDACDITHERON Property

IRD

Lm49450ClockControlDACDITHERON Property

Clock Control (DAC_DITHER_ON)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeClockDacDitherOn ClockControlDACDITHERON { get; set; }
Public Property ClockControlDACDITHERON As Lm49450TypeClockDacDitherOn
    Get
    Set
public:
property Lm49450TypeClockDacDitherOn ClockControlDACDITHERON {
    Lm49450TypeClockDacDitherOn get ();
    void set (Lm49450TypeClockDacDitherOn value);
}
member ClockControlDACDITHERON : Lm49450TypeClockDacDitherOn with get, set

Property Value

Type: Lm49450TypeClockDacDitherOn
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.ClockControlRDIV Property

IRD

Lm49450ClockControlRDIV Property

Clock Control (RDIV)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeClockRdiv ClockControlRDIV { get; set; }
Public Property ClockControlRDIV As Lm49450TypeClockRdiv
    Get
    Set
public:
property Lm49450TypeClockRdiv ClockControlRDIV {
    Lm49450TypeClockRdiv get ();
    void set (Lm49450TypeClockRdiv value);
}
member ClockControlRDIV : Lm49450TypeClockRdiv with get, set

Property Value

Type: Lm49450TypeClockRdiv
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.CMP0LSB Property

IRD

Lm49450CMP0LSB Property

CMP_0_LSB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CMP0LSB { get; set; }
Public Property CMP0LSB As Byte
    Get
    Set
public:
property unsigned char CMP0LSB {
    unsigned char get ();
    void set (unsigned char value);
}
member CMP0LSB : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.CMP0MSB Property

IRD

Lm49450CMP0MSB Property

CMP_0_MSB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CMP0MSB { get; set; }
Public Property CMP0MSB As Byte
    Get
    Set
public:
property unsigned char CMP0MSB {
    unsigned char get ();
    void set (unsigned char value);
}
member CMP0MSB : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.CMP1LSB Property

IRD

Lm49450CMP1LSB Property

CMP_1_LSB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CMP1LSB { get; set; }
Public Property CMP1LSB As Byte
    Get
    Set
public:
property unsigned char CMP1LSB {
    unsigned char get ();
    void set (unsigned char value);
}
member CMP1LSB : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.CMP1MSB Property

IRD

Lm49450CMP1MSB Property

CMP_1_MSB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CMP1MSB { get; set; }
Public Property CMP1MSB As Byte
    Get
    Set
public:
property unsigned char CMP1MSB {
    unsigned char get ();
    void set (unsigned char value);
}
member CMP1MSB : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.CMP2LSB Property

IRD

Lm49450CMP2LSB Property

CMP_2_LSB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CMP2LSB { get; set; }
Public Property CMP2LSB As Byte
    Get
    Set
public:
property unsigned char CMP2LSB {
    unsigned char get ();
    void set (unsigned char value);
}
member CMP2LSB : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.CMP2MSB Property

IRD

Lm49450CMP2MSB Property

CMP_2_MSB

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CMP2MSB { get; set; }
Public Property CMP2MSB As Byte
    Get
    Set
public:
property unsigned char CMP2MSB {
    unsigned char get ();
    void set (unsigned char value);
}
member CMP2MSB : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.Headphone3DConfigurationHP3D Property

IRD

Lm49450Headphone3DConfigurationHP3D Property

Headphone 3D Configuration (HP_3D)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeHeadphone3dHp3d Headphone3DConfigurationHP3D { get; set; }
Public Property Headphone3DConfigurationHP3D As Lm49450TypeHeadphone3dHp3d
    Get
    Set
public:
property Lm49450TypeHeadphone3dHp3d Headphone3DConfigurationHP3D {
    Lm49450TypeHeadphone3dHp3d get ();
    void set (Lm49450TypeHeadphone3dHp3d value);
}
member Headphone3DConfigurationHP3D : Lm49450TypeHeadphone3dHp3d with get, set

Property Value

Type: Lm49450TypeHeadphone3dHp3d
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.Headphone3DConfigurationHP3DATTN Property

IRD

Lm49450Headphone3DConfigurationHP3DATTN Property

Headphone 3D Configuration (HP_3DATTN)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeHeadphone3dHp3dattn Headphone3DConfigurationHP3DATTN { get; set; }
Public Property Headphone3DConfigurationHP3DATTN As Lm49450TypeHeadphone3dHp3dattn
    Get
    Set
public:
property Lm49450TypeHeadphone3dHp3dattn Headphone3DConfigurationHP3DATTN {
    Lm49450TypeHeadphone3dHp3dattn get ();
    void set (Lm49450TypeHeadphone3dHp3dattn value);
}
member Headphone3DConfigurationHP3DATTN : Lm49450TypeHeadphone3dHp3dattn with get, set

Property Value

Type: Lm49450TypeHeadphone3dHp3dattn
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.Headphone3DConfigurationHP3DEN Property

IRD

Lm49450Headphone3DConfigurationHP3DEN Property

Headphone 3D Configuration (HP_3DEN)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeHeadphone3dHp3den Headphone3DConfigurationHP3DEN { get; set; }
Public Property Headphone3DConfigurationHP3DEN As Lm49450TypeHeadphone3dHp3den
    Get
    Set
public:
property Lm49450TypeHeadphone3dHp3den Headphone3DConfigurationHP3DEN {
    Lm49450TypeHeadphone3dHp3den get ();
    void set (Lm49450TypeHeadphone3dHp3den value);
}
member Headphone3DConfigurationHP3DEN : Lm49450TypeHeadphone3dHp3den with get, set

Property Value

Type: Lm49450TypeHeadphone3dHp3den
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.Headphone3DConfigurationHP3DFREQ Property

IRD

Lm49450Headphone3DConfigurationHP3DFREQ Property

Headphone 3D Configuration (HP_3DFREQ) (unit: Hz)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeHeadphone3dHp3dfreq45 Headphone3DConfigurationHP3DFREQ { get; set; }
Public Property Headphone3DConfigurationHP3DFREQ As Lm49450TypeHeadphone3dHp3dfreq45
    Get
    Set
public:
property Lm49450TypeHeadphone3dHp3dfreq45 Headphone3DConfigurationHP3DFREQ {
    Lm49450TypeHeadphone3dHp3dfreq45 get ();
    void set (Lm49450TypeHeadphone3dHp3dfreq45 value);
}
member Headphone3DConfigurationHP3DFREQ : Lm49450TypeHeadphone3dHp3dfreq45 with get, set

Property Value

Type: Lm49450TypeHeadphone3dHp3dfreq45
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.Headphone3DConfigurationHP3DMIX Property

IRD

Lm49450Headphone3DConfigurationHP3DMIX Property

Headphone 3D Configuration (HP_3DMIX) (unit: %)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeHeadphone3dHp3dfreq23 Headphone3DConfigurationHP3DMIX { get; set; }
Public Property Headphone3DConfigurationHP3DMIX As Lm49450TypeHeadphone3dHp3dfreq23
    Get
    Set
public:
property Lm49450TypeHeadphone3dHp3dfreq23 Headphone3DConfigurationHP3DMIX {
    Lm49450TypeHeadphone3dHp3dfreq23 get ();
    void set (Lm49450TypeHeadphone3dHp3dfreq23 value);
}
member Headphone3DConfigurationHP3DMIX : Lm49450TypeHeadphone3dHp3dfreq23 with get, set

Property Value

Type: Lm49450TypeHeadphone3dHp3dfreq23
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.HeadphoneVolumeControl Property

IRD

Lm49450HeadphoneVolumeControl Property

Headphone Volume Control (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeHeadphoneVolume HeadphoneVolumeControl { get; set; }
Public Property HeadphoneVolumeControl As Lm49450TypeHeadphoneVolume
    Get
    Set
public:
property Lm49450TypeHeadphoneVolume HeadphoneVolumeControl {
    Lm49450TypeHeadphoneVolume get ();
    void set (Lm49450TypeHeadphoneVolume value);
}
member HeadphoneVolumeControl : Lm49450TypeHeadphoneVolume with get, set

Property Value

Type: Lm49450TypeHeadphoneVolume
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.I2SClockI2SCLK Property

IRD

Lm49450I2SClockI2SCLK Property

I2S Clock (I2S_CLK)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeI2sClockClk I2SClockI2SCLK { get; set; }
Public Property I2SClockI2SCLK As Lm49450TypeI2sClockClk
    Get
    Set
public:
property Lm49450TypeI2sClockClk I2SClockI2SCLK {
    Lm49450TypeI2sClockClk get ();
    void set (Lm49450TypeI2sClockClk value);
}
member I2SClockI2SCLK : Lm49450TypeI2sClockClk with get, set

Property Value

Type: Lm49450TypeI2sClockClk
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.I2SClockI2SCLKMS Property

IRD

Lm49450I2SClockI2SCLKMS Property

I2S Clock (I2S_CLK_MS)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeI2sClockClkMs I2SClockI2SCLKMS { get; set; }
Public Property I2SClockI2SCLKMS As Lm49450TypeI2sClockClkMs
    Get
    Set
public:
property Lm49450TypeI2sClockClkMs I2SClockI2SCLKMS {
    Lm49450TypeI2sClockClkMs get ();
    void set (Lm49450TypeI2sClockClkMs value);
}
member I2SClockI2SCLKMS : Lm49450TypeI2sClockClkMs with get, set

Property Value

Type: Lm49450TypeI2sClockClkMs
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.I2SClockI2SWS Property

IRD

Lm49450I2SClockI2SWS Property

I2S Clock (I2S_WS)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeI2sClockWs I2SClockI2SWS { get; set; }
Public Property I2SClockI2SWS As Lm49450TypeI2sClockWs
    Get
    Set
public:
property Lm49450TypeI2sClockWs I2SClockI2SWS {
    Lm49450TypeI2sClockWs get ();
    void set (Lm49450TypeI2sClockWs value);
}
member I2SClockI2SWS : Lm49450TypeI2sClockWs with get, set

Property Value

Type: Lm49450TypeI2sClockWs
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.I2SClockI2SWSMS Property

IRD

Lm49450I2SClockI2SWSMS Property

I2S Clock (I2S_WS_MS)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeI2sClockWsMs I2SClockI2SWSMS { get; set; }
Public Property I2SClockI2SWSMS As Lm49450TypeI2sClockWsMs
    Get
    Set
public:
property Lm49450TypeI2sClockWsMs I2SClockI2SWSMS {
    Lm49450TypeI2sClockWsMs get ();
    void set (Lm49450TypeI2sClockWsMs value);
}
member I2SClockI2SWSMS : Lm49450TypeI2sClockWsMs with get, set

Property Value

Type: Lm49450TypeI2sClockWsMs
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.I2SModeI2SMODE Property

IRD

Lm49450I2SModeI2SMODE Property

I2S Mode (I2S_MODE)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeI2sModeMode I2SModeI2SMODE { get; set; }
Public Property I2SModeI2SMODE As Lm49450TypeI2sModeMode
    Get
    Set
public:
property Lm49450TypeI2sModeMode I2SModeI2SMODE {
    Lm49450TypeI2sModeMode get ();
    void set (Lm49450TypeI2sModeMode value);
}
member I2SModeI2SMODE : Lm49450TypeI2sModeMode with get, set

Property Value

Type: Lm49450TypeI2sModeMode
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.I2SModeI2SSTEREOREVERSE Property

IRD

Lm49450I2SModeI2SSTEREOREVERSE Property

I2S Mode (I2S_STEREO_REVERSE)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeI2sModeStereoReverse I2SModeI2SSTEREOREVERSE { get; set; }
Public Property I2SModeI2SSTEREOREVERSE As Lm49450TypeI2sModeStereoReverse
    Get
    Set
public:
property Lm49450TypeI2sModeStereoReverse I2SModeI2SSTEREOREVERSE {
    Lm49450TypeI2sModeStereoReverse get ();
    void set (Lm49450TypeI2sModeStereoReverse value);
}
member I2SModeI2SSTEREOREVERSE : Lm49450TypeI2sModeStereoReverse with get, set

Property Value

Type: Lm49450TypeI2sModeStereoReverse
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.I2SModeI2SWORDORDER Property

IRD

Lm49450I2SModeI2SWORDORDER Property

I2S Mode (I2S_WORD_ORDER)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeI2sModeWordOrder I2SModeI2SWORDORDER { get; set; }
Public Property I2SModeI2SWORDORDER As Lm49450TypeI2sModeWordOrder
    Get
    Set
public:
property Lm49450TypeI2sModeWordOrder I2SModeI2SWORDORDER {
    Lm49450TypeI2sModeWordOrder get ();
    void set (Lm49450TypeI2sModeWordOrder value);
}
member I2SModeI2SWORDORDER : Lm49450TypeI2sModeWordOrder with get, set

Property Value

Type: Lm49450TypeI2sModeWordOrder
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.I2SModeI2SWRD Property

IRD

Lm49450I2SModeI2SWRD Property

I2S Mode (I2S_WRD)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeI2sModeWrd I2SModeI2SWRD { get; set; }
Public Property I2SModeI2SWRD As Lm49450TypeI2sModeWrd
    Get
    Set
public:
property Lm49450TypeI2sModeWrd I2SModeI2SWRD {
    Lm49450TypeI2sModeWrd get ();
    void set (Lm49450TypeI2sModeWrd value);
}
member I2SModeI2SWRD : Lm49450TypeI2sModeWrd with get, set

Property Value

Type: Lm49450TypeI2sModeWrd
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.Loudspeaker3DConfigurationLS3D Property

IRD

Lm49450Loudspeaker3DConfigurationLS3D Property

Loudspeaker 3D Configuration (LS_3D)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeHeadphone3dHp3d Loudspeaker3DConfigurationLS3D { get; set; }
Public Property Loudspeaker3DConfigurationLS3D As Lm49450TypeHeadphone3dHp3d
    Get
    Set
public:
property Lm49450TypeHeadphone3dHp3d Loudspeaker3DConfigurationLS3D {
    Lm49450TypeHeadphone3dHp3d get ();
    void set (Lm49450TypeHeadphone3dHp3d value);
}
member Loudspeaker3DConfigurationLS3D : Lm49450TypeHeadphone3dHp3d with get, set

Property Value

Type: Lm49450TypeHeadphone3dHp3d
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.Loudspeaker3DConfigurationLS3DATTN Property

IRD

Lm49450Loudspeaker3DConfigurationLS3DATTN Property

Loudspeaker 3D Configuration (LS_3DATTN)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeHeadphone3dHp3dattn Loudspeaker3DConfigurationLS3DATTN { get; set; }
Public Property Loudspeaker3DConfigurationLS3DATTN As Lm49450TypeHeadphone3dHp3dattn
    Get
    Set
public:
property Lm49450TypeHeadphone3dHp3dattn Loudspeaker3DConfigurationLS3DATTN {
    Lm49450TypeHeadphone3dHp3dattn get ();
    void set (Lm49450TypeHeadphone3dHp3dattn value);
}
member Loudspeaker3DConfigurationLS3DATTN : Lm49450TypeHeadphone3dHp3dattn with get, set

Property Value

Type: Lm49450TypeHeadphone3dHp3dattn
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.Loudspeaker3DConfigurationLS3DEN Property

IRD

Lm49450Loudspeaker3DConfigurationLS3DEN Property

Loudspeaker 3D Configuration (LS_3DEN)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeLoudspeaker3dLs3den Loudspeaker3DConfigurationLS3DEN { get; set; }
Public Property Loudspeaker3DConfigurationLS3DEN As Lm49450TypeLoudspeaker3dLs3den
    Get
    Set
public:
property Lm49450TypeLoudspeaker3dLs3den Loudspeaker3DConfigurationLS3DEN {
    Lm49450TypeLoudspeaker3dLs3den get ();
    void set (Lm49450TypeLoudspeaker3dLs3den value);
}
member Loudspeaker3DConfigurationLS3DEN : Lm49450TypeLoudspeaker3dLs3den with get, set

Property Value

Type: Lm49450TypeLoudspeaker3dLs3den
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.Loudspeaker3DConfigurationLS3DFREQ Property

IRD

Lm49450Loudspeaker3DConfigurationLS3DFREQ Property

Loudspeaker 3D Configuration (LS_3DFREQ) (unit: Hz)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeHeadphone3dHp3dfreq45 Loudspeaker3DConfigurationLS3DFREQ { get; set; }
Public Property Loudspeaker3DConfigurationLS3DFREQ As Lm49450TypeHeadphone3dHp3dfreq45
    Get
    Set
public:
property Lm49450TypeHeadphone3dHp3dfreq45 Loudspeaker3DConfigurationLS3DFREQ {
    Lm49450TypeHeadphone3dHp3dfreq45 get ();
    void set (Lm49450TypeHeadphone3dHp3dfreq45 value);
}
member Loudspeaker3DConfigurationLS3DFREQ : Lm49450TypeHeadphone3dHp3dfreq45 with get, set

Property Value

Type: Lm49450TypeHeadphone3dHp3dfreq45
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.Loudspeaker3DConfigurationLS3DMIX Property

IRD

Lm49450Loudspeaker3DConfigurationLS3DMIX Property

Loudspeaker 3D Configuration (LS_3DMIX) (unit: %)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeHeadphone3dHp3dfreq23 Loudspeaker3DConfigurationLS3DMIX { get; set; }
Public Property Loudspeaker3DConfigurationLS3DMIX As Lm49450TypeHeadphone3dHp3dfreq23
    Get
    Set
public:
property Lm49450TypeHeadphone3dHp3dfreq23 Loudspeaker3DConfigurationLS3DMIX {
    Lm49450TypeHeadphone3dHp3dfreq23 get ();
    void set (Lm49450TypeHeadphone3dHp3dfreq23 value);
}
member Loudspeaker3DConfigurationLS3DMIX : Lm49450TypeHeadphone3dHp3dfreq23 with get, set

Property Value

Type: Lm49450TypeHeadphone3dHp3dfreq23
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.LoudspeakerVolumeControl Property

IRD

Lm49450LoudspeakerVolumeControl Property

Loudspeaker Volume Control (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeLoudspeakerVolume LoudspeakerVolumeControl { get; set; }
Public Property LoudspeakerVolumeControl As Lm49450TypeLoudspeakerVolume
    Get
    Set
public:
property Lm49450TypeLoudspeakerVolume LoudspeakerVolumeControl {
    Lm49450TypeLoudspeakerVolume get ();
    void set (Lm49450TypeLoudspeakerVolume value);
}
member LoudspeakerVolumeControl : Lm49450TypeLoudspeakerVolume with get, set

Property Value

Type: Lm49450TypeLoudspeakerVolume
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.ModeControlCOMP Property

IRD

Lm49450ModeControlCOMP Property

Mode Control (COMP)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeControlComp ModeControlCOMP { get; set; }
Public Property ModeControlCOMP As Lm49450TypeControlComp
    Get
    Set
public:
property Lm49450TypeControlComp ModeControlCOMP {
    Lm49450TypeControlComp get ();
    void set (Lm49450TypeControlComp value);
}
member ModeControlCOMP : Lm49450TypeControlComp with get, set

Property Value

Type: Lm49450TypeControlComp
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.ModeControlDACMODE Property

IRD

Lm49450ModeControlDACMODE Property

Mode Control (DAC_MODE)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeControlDacMode ModeControlDACMODE { get; set; }
Public Property ModeControlDACMODE As Lm49450TypeControlDacMode
    Get
    Set
public:
property Lm49450TypeControlDacMode ModeControlDACMODE {
    Lm49450TypeControlDacMode get ();
    void set (Lm49450TypeControlDacMode value);
}
member ModeControlDACMODE : Lm49450TypeControlDacMode with get, set

Property Value

Type: Lm49450TypeControlDacMode
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.ModeControlENABLE Property

IRD

Lm49450ModeControlENABLE Property

Mode Control (ENABLE)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeControlEnable ModeControlENABLE { get; set; }
Public Property ModeControlENABLE As Lm49450TypeControlEnable
    Get
    Set
public:
property Lm49450TypeControlEnable ModeControlENABLE {
    Lm49450TypeControlEnable get ();
    void set (Lm49450TypeControlEnable value);
}
member ModeControlENABLE : Lm49450TypeControlEnable with get, set

Property Value

Type: Lm49450TypeControlEnable
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.ModeControlEXTREF Property

IRD

Lm49450ModeControlEXTREF Property

Mode Control (EXT_REF)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeControlExtRef ModeControlEXTREF { get; set; }
Public Property ModeControlEXTREF As Lm49450TypeControlExtRef
    Get
    Set
public:
property Lm49450TypeControlExtRef ModeControlEXTREF {
    Lm49450TypeControlExtRef get ();
    void set (Lm49450TypeControlExtRef value);
}
member ModeControlEXTREF : Lm49450TypeControlExtRef with get, set

Property Value

Type: Lm49450TypeControlExtRef
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.ModeControlMUTE Property

IRD

Lm49450ModeControlMUTE Property

Mode Control (MUTE)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeControlMute ModeControlMUTE { get; set; }
Public Property ModeControlMUTE As Lm49450TypeControlMute
    Get
    Set
public:
property Lm49450TypeControlMute ModeControlMUTE {
    Lm49450TypeControlMute get ();
    void set (Lm49450TypeControlMute value);
}
member ModeControlMUTE : Lm49450TypeControlMute with get, set

Property Value

Type: Lm49450TypeControlMute
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.ModeControlSS Property

IRD

Lm49450ModeControlSS Property

Mode Control (SS)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49450TypeControlSs ModeControlSS { get; set; }
Public Property ModeControlSS As Lm49450TypeControlSs
    Get
    Set
public:
property Lm49450TypeControlSs ModeControlSS {
    Lm49450TypeControlSs get ();
    void set (Lm49450TypeControlSs value);
}
member ModeControlSS : Lm49450TypeControlSs with get, set

Property Value

Type: Lm49450TypeControlSs
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450 Methods

The Lm49450 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.Flush Method

IRD

Lm49450Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm49450 Class
telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeChargePump Enumeration

IRD

Lm49450TypeChargePump Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChargePump
Public Enumeration TypeChargePump
public enum class TypeChargePump
type TypeChargePump
Members
Member name | Value | Description
Bypass | 0 | Bypass
Value_1 | 1 | 1
Value_1_5 | 2 | 1.5
Value_2 | 3 | 2
Value_2_5 | 4 | 2.5
Value_3 | 5 | 3
Value_3_5 | 6 | 3.5
Value_4 | 7 | 4
Value_4_5 | 8 | 4.5
Value_5 | 9 | 5
Value_5_5 | 10 | 5.5
Value_6 | 11 | 6
Value_6_5 | 12 | 6.5
Value_7 | 13 | 7
Value_7_5 | 14 | 7.5
Value_8 | 15 | 8
Value_8_5 | 16 | 8.5
Value_9 | 17 | 9
Value_9_5 | 18 | 9.5
Value_10 | 19 | 10
Value_10_5 | 20 | 10.5
Value_11 | 21 | 11
Value_11_5 | 22 | 11.5
Value_12 | 23 | 12
Value_12_5 | 24 | 12.5
Value_13 | 25 | 13
Value_13_5 | 26 | 13.5
Value_14 | 27 | 14
Value_14_5 | 28 | 14.5
Value_15 | 29 | 15
Value_15_5 | 30 | 15.5
Value_16 | 31 | 16
Value_16_5 | 32 | 16.5
Value_17 | 33 | 17
Value_17_5 | 34 | 17.5
Value_18 | 35 | 18
Value_18_5 | 36 | 18.5
Value_19 | 37 | 19
Value_19_5 | 38 | 19.5
Value_20 | 39 | 20
Value_20_5 | 40 | 20.5
Value_21 | 41 | 21
Value_21_5 | 42 | 21.5
Value_22 | 43 | 22
Value_22_5 | 44 | 22.5
Value_23 | 45 | 23
Value_23_5 | 46 | 23.5
Value_24 | 47 | 24
Value_24_5 | 48 | 24.5
Value_25 | 49 | 25
Value_25_5 | 50 | 25.5
Value_26 | 51 | 26
Value_26_5 | 52 | 26.5
Value_27 | 53 | 27
Value_27_5 | 54 | 27.5
Value_28 | 55 | 28
Value_28_5 | 56 | 28.5
Value_29 | 57 | 29
Value_29_5 | 58 | 29.5
Value_30 | 59 | 30
Value_30_5 | 60 | 30.5
Value_31 | 61 | 31
Value_31_5 | 62 | 31.5
Value_32 | 63 | 32
Value_32_5 | 64 | 32.5
Value_33 | 65 | 33
Value_33_5 | 66 | 33.5
Value_34 | 67 | 34
Value_34_5 | 68 | 34.5
Value_35 | 69 | 35
Value_35_5 | 70 | 35.5
Value_36 | 71 | 36
Value_36_5 | 72 | 36.5
Value_37 | 73 | 37
Value_37_5 | 74 | 37.5
Value_38 | 75 | 38
Value_38_5 | 76 | 38.5
Value_39 | 77 | 39
Value_39_5 | 78 | 39.5
Value_40 | 79 | 40
Value_40_5 | 80 | 40.5
Value_41 | 81 | 41
Value_41_5 | 82 | 41.5
Value_42 | 83 | 42
Value_42_5 | 84 | 42.5
Value_43 | 85 | 43
Value_43_5 | 86 | 43.5
Value_44 | 87 | 44
Value_44_5 | 88 | 44.5
Value_45 | 89 | 45
Value_45_5 | 90 | 45.5
Value_46 | 91 | 46
Value_46_5 | 92 | 46.5
Value_47 | 93 | 47
Value_47_5 | 94 | 47.5
Value_48 | 95 | 48
Value_48_5 | 96 | 48.5
Value_49 | 97 | 49
Value_49_5 | 98 | 49.5
Value_50 | 99 | 50
Value_50_5 | 100 | 50.5
Value_51 | 101 | 51
Value_51_5 | 102 | 51.5
Value_52 | 103 | 52
Value_52_5 | 104 | 52.5
Value_53 | 105 | 53
Value_53_5 | 106 | 53.5
Value_54 | 107 | 54
Value_54_5 | 108 | 54.5
Value_55 | 109 | 55
Value_55_5 | 110 | 55.5
Value_56 | 111 | 56
Value_56_5 | 112 | 56.5
Value_57 | 113 | 57
Value_57_5 | 114 | 57.5
Value_58 | 115 | 58
Value_58_5 | 116 | 58.5
Value_59 | 117 | 59
Value_59_5 | 118 | 59.5
Value_60 | 119 | 60
Value_60_5 | 120 | 60.5
Value_61 | 121 | 61
Value_61_5 | 122 | 61.5
Value_62 | 123 | 62
Value_62_5 | 124 | 62.5
Value_63 | 125 | 63
Value_63_5 | 126 | 63.5
Value_64 | 127 | 64
Value_64_5 | 128 | 64.5
Value_65 | 129 | 65
Value_65_5 | 130 | 65.5
Value_66 | 131 | 66
Value_66_5 | 132 | 66.5
Value_67 | 133 | 67
Value_67_5 | 134 | 67.5
Value_68 | 135 | 68
Value_68_5 | 136 | 68.5
Value_69 | 137 | 69
Value_69_5 | 138 | 69.5
Value_70 | 139 | 70
Value_70_5 | 140 | 70.5
Value_71 | 141 | 71
Value_71_5 | 142 | 71.5
Value_72 | 143 | 72
Value_72_5 | 144 | 72.5
Value_73 | 145 | 73
Value_73_5 | 146 | 73.5
Value_74 | 147 | 74
Value_74_5 | 148 | 74.5
Value_75 | 149 | 75
Value_75_5 | 150 | 75.5
Value_76 | 151 | 76
Value_76_5 | 152 | 76.5
Value_77 | 153 | 77
Value_77_5 | 154 | 77.5
Value_78 | 155 | 78
Value_78_5 | 156 | 78.5
Value_79 | 157 | 79
Value_79_5 | 158 | 79.5
Value_80 | 159 | 80
Value_80_5 | 160 | 80.5
Value_81 | 161 | 81
Value_81_5 | 162 | 81.5
Value_82 | 163 | 82
Value_82_5 | 164 | 82.5
Value_83 | 165 | 83
Value_83_5 | 166 | 83.5
Value_84 | 167 | 84
Value_84_5 | 168 | 84.5
Value_85 | 169 | 85
Value_85_5 | 170 | 85.5
Value_86 | 171 | 86
Value_86_5 | 172 | 86.5
Value_87 | 173 | 87
Value_87_5 | 174 | 87.5
Value_88 | 175 | 88
Value_88_5 | 176 | 88.5
Value_89 | 177 | 89
Value_89_5 | 178 | 89.5
Value_90 | 179 | 90
Value_90_5 | 180 | 90.5
Value_91 | 181 | 91
Value_91_5 | 182 | 91.5
Value_92 | 183 | 92
Value_92_5 | 184 | 92.5
Value_93 | 185 | 93
Value_93_5 | 186 | 93.5
Value_94 | 187 | 94
Value_94_5 | 188 | 94.5
Value_95 | 189 | 95
Value_95_5 | 190 | 95.5
Value_96 | 191 | 96
Value_96_5 | 192 | 96.5
Value_97 | 193 | 97
Value_97_5 | 194 | 97.5
Value_98 | 195 | 98
Value_98_5 | 196 | 98.5
Value_99 | 197 | 99
Value_99_5 | 198 | 99.5
Value_100 | 199 | 100
Value_100_5 | 200 | 100.5
Value_101 | 201 | 101
Value_101_5 | 202 | 101.5
Value_102 | 203 | 102
Value_102_5 | 204 | 102.5
Value_103 | 205 | 103
Value_103_5 | 206 | 103.5
Value_104 | 207 | 104
Value_104_5 | 208 | 104.5
Value_105 | 209 | 105
Value_105_5 | 210 | 105.5
Value_106 | 211 | 106
Value_106_5 | 212 | 106.5
Value_107 | 213 | 107
Value_107_5 | 214 | 107.5
Value_108 | 215 | 108
Value_108_5 | 216 | 108.5
Value_109 | 217 | 109
Value_109_5 | 218 | 109.5
Value_110 | 219 | 110
Value_110_5 | 220 | 110.5
Value_111 | 221 | 111
Value_111_5 | 222 | 111.5
Value_112 | 223 | 112
Value_112_5 | 224 | 112.5
Value_113 | 225 | 113
Value_113_5 | 226 | 113.5
Value_114 | 227 | 114
Value_114_5 | 228 | 114.5
Value_115 | 229 | 115
Value_115_5 | 230 | 115.5
Value_116 | 231 | 116
Value_116_5 | 232 | 116.5
Value_117 | 233 | 117
Value_117_5 | 234 | 117.5
Value_118 | 235 | 118
Value_118_5 | 236 | 118.5
Value_119 | 237 | 119
Value_119_5 | 238 | 119.5
Value_120 | 239 | 120
Value_120_5 | 240 | 120.5
Value_121 | 241 | 121
Value_121_5 | 242 | 121.5
Value_122 | 243 | 122
Value_122_5 | 244 | 122.5
Value_123 | 245 | 123
Value_123_5 | 246 | 123.5
Value_124 | 247 | 124
Value_124_5 | 248 | 124.5
Value_125 | 249 | 125
Value_125_5 | 250 | 125.5
Value_126 | 251 | 126
Value_126_5 | 252 | 126.5
Value_127 | 253 | 127
Value_127_5 | 254 | 127.5
Value_128 | 255 | 128
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeClockDacDitherOff Enumeration

IRD

Lm49450TypeClockDacDitherOff Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockDacDitherOff
Public Enumeration TypeClockDacDitherOff
public enum class TypeClockDacDitherOff
type TypeClockDacDitherOff
Members
Member name | Value | Description
DefaultDACState | 0 | Default DAC State
PermanentlyDisableDACDither | 1 | Permanently Disable DAC Dither
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeClockDacDitherOn Enumeration

IRD

Lm49450TypeClockDacDitherOn Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockDacDitherOn
Public Enumeration TypeClockDacDitherOn
public enum class TypeClockDacDitherOn
type TypeClockDacDitherOn
Members
Member name | Value | Description
DefaultDACState | 0 | Default DAC State
PermanentlyEnableDACDither | 1 | Permanently Enable DAC Dither
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeClockRdiv Enumeration

IRD

Lm49450TypeClockRdiv Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockRdiv
Public Enumeration TypeClockRdiv
public enum class TypeClockRdiv
type TypeClockRdiv
Members
Member name | Value | Description
Bypass | 0 | Bypass
Value_1 | 1 | 1
Value_1_5 | 2 | 1.5
Value_2 | 3 | 2
Value_2_5 | 4 | 2.5
Value_3 | 5 | 3
Value_3_5 | 6 | 3.5
Value_4 | 7 | 4
Value_4_5 | 8 | 4.5
Value_5 | 9 | 5
Value_5_5 | 10 | 5.5
Value_6 | 11 | 6
Value_6_5 | 12 | 6.5
Value_7 | 13 | 7
Value_7_5 | 14 | 7.5
Value_8 | 15 | 8
Value_8_5 | 16 | 8.5
Value_9 | 17 | 9
Value_9_5 | 18 | 9.5
Value_10 | 19 | 10
Value_10_5 | 20 | 10.5
Value_11 | 21 | 11
Value_11_5 | 22 | 11.5
Value_12 | 23 | 12
Value_12_5 | 24 | 12.5
Value_13 | 25 | 13
Value_13_5 | 26 | 13.5
Value_14 | 27 | 14
Value_14_5 | 28 | 14.5
Value_15 | 29 | 15
Value_15_5 | 30 | 15.5
Value_16 | 31 | 16
Value_16_5 | 32 | 16.5
Value_17 | 33 | 17
Value_17_5 | 34 | 17.5
Value_18 | 35 | 18
Value_18_5 | 36 | 18.5
Value_19 | 37 | 19
Value_19_5 | 38 | 19.5
Value_20 | 39 | 20
Value_20_5 | 40 | 20.5
Value_21 | 41 | 21
Value_21_5 | 42 | 21.5
Value_22 | 43 | 22
Value_22_5 | 44 | 22.5
Value_23 | 45 | 23
Value_23_5 | 46 | 23.5
Value_24 | 47 | 24
Value_24_5 | 48 | 24.5
Value_25 | 49 | 25
Value_25_5 | 50 | 25.5
Value_26 | 51 | 26
Value_26_5 | 52 | 26.5
Value_27 | 53 | 27
Value_27_5 | 54 | 27.5
Value_28 | 55 | 28
Value_28_5 | 56 | 28.5
Value_29 | 57 | 29
Value_29_5 | 58 | 29.5
Value_30 | 59 | 30
Value_30_5 | 60 | 30.5
Value_31 | 61 | 31
Value_31_5 | 62 | 31.5
Value_32 | 63 | 32
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeControlComp Enumeration

IRD

Lm49450TypeControlComp Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlComp
Public Enumeration TypeControlComp
public enum class TypeControlComp
type TypeControlComp
Members
Member name | Value | Description
DACCompensationFilterDefault | 0 | DAC Compensation Filter: Default
DACCompensationFilterProgrammable | 1 | DAC Compensation Filter: Programmable
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeControlDacMode Enumeration

IRD

Lm49450TypeControlDacMode Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlDacMode
Public Enumeration TypeControlDacMode
public enum class TypeControlDacMode
type TypeControlDacMode
Members
Member name | Value | Description
Value_125 | 0 | 125
Value_128 | 1 | 128
Value_64 | 2 | 64
Value_32 | 3 | 32
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeControlEnable Enumeration

IRD

Lm49450TypeControlEnable Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlEnable
Public Enumeration TypeControlEnable
public enum class TypeControlEnable
type TypeControlEnable
Members
Member name | Value | Description
DeviceShutdown | 0 | Device Shutdown
DeviceEnabled | 1 | Device Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeControlExtRef Enumeration

IRD

Lm49450TypeControlExtRef Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlExtRef
Public Enumeration TypeControlExtRef
public enum class TypeControlExtRef
type TypeControlExtRef
Members
Member name | Value | Description
InternalReference | 0 | Internal Reference
ExternalReference | 1 | External Reference
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeControlMute Enumeration

IRD

Lm49450TypeControlMute Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlMute
Public Enumeration TypeControlMute
public enum class TypeControlMute
type TypeControlMute
Members
Member name | Value | Description
UnMute | 0 | Un-mute
Mute | 1 | Mute
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeControlSs Enumeration

IRD

Lm49450TypeControlSs Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlSs
Public Enumeration TypeControlSs
public enum class TypeControlSs
type TypeControlSs
Members
Member name | Value | Description
FixedFrequencyOscillator | 0 | Fixed Frequency Oscillator
SpreadSpectrumOscillator | 1 | Spread Spectrum Oscillator
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeHeadphone3dHp3d Enumeration

IRD

Lm49450TypeHeadphone3dHp3d Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphone3dHp3d
Public Enumeration TypeHeadphone3dHp3d
public enum class TypeHeadphone3dHp3d
type TypeHeadphone3dHp3d
Members
Member name | Value | Description
Narrow3DEffect | 0 | Narrow 3D Effect
Wide3DEffect | 1 | Wide 3D Effect
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeHeadphone3dHp3dattn Enumeration

IRD

Lm49450TypeHeadphone3dHp3dattn Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphone3dHp3dattn
Public Enumeration TypeHeadphone3dHp3dattn
public enum class TypeHeadphone3dHp3dattn
type TypeHeadphone3dHp3dattn
Members
Member name | Value | Description
NoAttenuation | 0 | No Attenuation
AttenuatedBy6DB | 1 | Attenuated By 6 dB
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeHeadphone3dHp3den Enumeration

IRD

Lm49450TypeHeadphone3dHp3den Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphone3dHp3den
Public Enumeration TypeHeadphone3dHp3den
public enum class TypeHeadphone3dHp3den
type TypeHeadphone3dHp3den
Members
Member name | Value | Description
Headphone3DDisabled | 0 | Headphone 3D: Disabled
Headphone3DEnabled | 1 | Headphone 3D: Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeHeadphone3dHp3dfreq23 Enumeration

IRD

Lm49450TypeHeadphone3dHp3dfreq23 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphone3dHp3dfreq23
Public Enumeration TypeHeadphone3dHp3dfreq23
public enum class TypeHeadphone3dHp3dfreq23
type TypeHeadphone3dHp3dfreq23
Members
Member name | Value | Description
Value_25 | 0 | 25
Value_37_5 | 1 | 37.5
Value_50 | 2 | 50
Value_75 | 3 | 75
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeHeadphone3dHp3dfreq45 Enumeration

IRD

Lm49450TypeHeadphone3dHp3dfreq45 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphone3dHp3dfreq45
Public Enumeration TypeHeadphone3dHp3dfreq45
public enum class TypeHeadphone3dHp3dfreq45
type TypeHeadphone3dHp3dfreq45
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_300 | 1 | 300
Value_600 | 2 | 600
Value_900 | 3 | 900
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeHeadphoneVolume Enumeration

IRD

Lm49450TypeHeadphoneVolume Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphoneVolume
Public Enumeration TypeHeadphoneVolume
public enum class TypeHeadphoneVolume
type TypeHeadphoneVolume
Members
Member name | Value | Description
Value_M_59 | 0 | -59
Value_M_48 | 1 | -48
Value_M_40_5 | 2 | -40.5
Value_M_34_5 | 3 | -34.5
Value_M_30 | 4 | -30
Value_M_27 | 5 | -27
Value_M_24 | 6 | -24
Value_M_21 | 7 | -21
Value_M_18 | 8 | -18
Value_M_15 | 9 | -15
Value_M_13_5 | 10 | -13.5
Value_M_12 | 11 | -12
Value_M_10_5 | 12 | -10.5
Value_M_9 | 13 | -9
Value_M_7_5 | 14 | -7.5
Value_M_6 | 15 | -6
Value_M_4_5 | 16 | -4.5
Value_M_3 | 17 | -3
Value_M_1_5 | 18 | -1.5
Value_0 | 19 | 0
Value_1_5 | 20 | 1.5
Value_3 | 21 | 3
Value_4_5 | 22 | 4.5
Value_6 | 23 | 6
Value_7_5 | 24 | 7.5
Value_9 | 25 | 9
Value_10_5 | 26 | 10.5
Value_12 | 27 | 12
Value_13_5 | 28 | 13.5
Value_15 | 29 | 15
Value_16_5 | 30 | 16.5
Value_18 | 31 | 18
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeI2sClockClk Enumeration

IRD

Lm49450TypeI2sClockClk Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeI2sClockClk
Public Enumeration TypeI2sClockClk
public enum class TypeI2sClockClk
type TypeI2sClockClk
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_2 | 1 | 2
Value_4 | 2 | 4
Value_6 | 3 | 6
Value_8 | 4 | 8
Value_10 | 5 | 10
Value_16 | 6 | 16
Value_20 | 7 | 20
Value_2_5 | 8 | 2.5
Value_3 | 9 | 3
Value_3_90625 | 10 | 3.90625
Value_5 | 11 | 5
Value_7_8125 | 12 | 7.8125
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeI2sClockClkMs Enumeration

IRD

Lm49450TypeI2sClockClkMs Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeI2sClockClkMs
Public Enumeration TypeI2sClockClkMs
public enum class TypeI2sClockClkMs
type TypeI2sClockClkMs
Members
Member name | Value | Description
I2SClockSlaveMode | 0 | I2S Clock: Slave Mode
I2SClockMasterMode | 1 | I2S Clock: Master Mode
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeI2sClockWs Enumeration

IRD

Lm49450TypeI2sClockWs Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeI2sClockWs
Public Enumeration TypeI2sClockWs
public enum class TypeI2sClockWs
type TypeI2sClockWs
Members
Member name | Value | Description
Value_16 | 0 | 16
Value_25 | 1 | 25
Value_32 | 2 | 32
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeI2sClockWsMs Enumeration

IRD

Lm49450TypeI2sClockWsMs Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeI2sClockWsMs
Public Enumeration TypeI2sClockWsMs
public enum class TypeI2sClockWsMs
type TypeI2sClockWsMs
Members
Member name | Value | Description
I2SWSSlaveMode | 0 | I2S WS: Slave Mode
I2SWSMasterMode | 1 | I2S WS: Master Mode
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeI2sModeMode Enumeration

IRD

Lm49450TypeI2sModeMode Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeI2sModeMode
Public Enumeration TypeI2sModeMode
public enum class TypeI2sModeMode
type TypeI2sModeMode
Members
Member name | Value | Description
NormalMode | 0 | Normal Mode
LeftJustifiedMode | 1 | Left Justified Mode
RightJustifiedMode | 2 | Right Justified Mode
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeI2sModeStereoReverse Enumeration

IRD

Lm49450TypeI2sModeStereoReverse Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeI2sModeStereoReverse
Public Enumeration TypeI2sModeStereoReverse
public enum class TypeI2sModeStereoReverse
type TypeI2sModeStereoReverse
Members
Member name | Value | Description
NormalMode | 0 | Normal Mode
ReverseMode | 1 | Reverse Mode
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeI2sModeWordOrder Enumeration

IRD

Lm49450TypeI2sModeWordOrder Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeI2sModeWordOrder
Public Enumeration TypeI2sModeWordOrder
public enum class TypeI2sModeWordOrder
type TypeI2sModeWordOrder
Members
Member name | Value | Description
NormalMode | 0 | Normal Mode
ReverseMode | 1 | Reverse Mode
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeI2sModeWrd Enumeration

IRD

Lm49450TypeI2sModeWrd Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeI2sModeWrd
Public Enumeration TypeI2sModeWrd
public enum class TypeI2sModeWrd
type TypeI2sModeWrd
Members
Member name | Value | Description
Value_16 | 0 | 16
Value_18 | 1 | 18
Value_20 | 2 | 20
Value_22 | 3 | 22
Value_24 | 4 | 24
Value_25 | 5 | 25
Value_26 | 6 | 26
Value_32 | 7 | 32
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeLoudspeaker3dLs3den Enumeration

IRD

Lm49450TypeLoudspeaker3dLs3den Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLoudspeaker3dLs3den
Public Enumeration TypeLoudspeaker3dLs3den
public enum class TypeLoudspeaker3dLs3den
type TypeLoudspeaker3dLs3den
Members
Member name | Value | Description
Loudspeaker3DDisabled | 0 | Loudspeaker 3D: Disabled
Loudspeaker3DEnabled | 1 | Loudspeaker 3D: Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm49450.TypeLoudspeakerVolume Enumeration

IRD

Lm49450TypeLoudspeakerVolume Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLoudspeakerVolume
Public Enumeration TypeLoudspeakerVolume
public enum class TypeLoudspeakerVolume
type TypeLoudspeakerVolume
Members
Member name | Value | Description
Value_M_53 | 0 | -53
Value_M_42 | 1 | -42
Value_M_34_5 | 2 | -34.5
Value_M_28_5 | 3 | -28.5
Value_M_24 | 4 | -24
Value_M_21 | 5 | -21
Value_M_18 | 6 | -18
Value_M_15 | 7 | -15
Value_M_12 | 8 | -12
Value_M_9 | 9 | -9
Value_M_7_5 | 10 | -7.5
Value_M_6 | 11 | -6
Value_M_4_5 | 12 | -4.5
Value_M_3 | 13 | -3
Value_M_1_5 | 14 | -1.5
Value_0 | 15 | 0
Value_1_5 | 16 | 1.5
Value_3 | 17 | 3
Value_4_5 | 18 | 4.5
Value_6 | 19 | 6
Value_7_5 | 20 | 7.5
Value_9 | 21 | 9
Value_10_5 | 22 | 10.5
Value_12 | 23 | 12
Value_13_5 | 24 | 13.5
Value_15 | 25 | 15
Value_16_5 | 26 | 16.5
Value_18 | 27 | 18
Value_19_5 | 28 | 19.5
Value_21 | 29 | 21
Value_22_5 | 30 | 22.5
Value_24 | 31 | 24
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63 Class

National Semiconductor: LM 63
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm63

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm63
Public Class Lm63
public ref class Lm63
type Lm63 =  class end

The Lm63 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm63 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Busy | Busy
Public property | ComparatorMode | Comparator Mode
Public property | ConfigRegisterALERTMask | Config Register: ALERT Mask
Public property | ConfigRegisterALERTTachSelect | Config Register: ALERT/Tach Select
Public property | ConfigRegisterMirrowALERTMask | Config Register (Mirrow): ALERT Mask
Public property | ConfigRegisterMirrowALERTTachSelect | Config Register (Mirrow): ALERT/Tach Select
Public property | ConfigRegisterMirrowPWMDisableInSTANDBY | Config Register (Mirrow): PWM Disable in STANDBY
Public property | ConfigRegisterMirrowRDTSFaultQueue | Config Register (Mirrow): RDTS Fault Queue
Public property | ConfigRegisterMirrowSTANDBY | Config Register (Mirrow): STANDBY
Public property | ConfigRegisterMirrowTCRITLimitOverride | Config Register (Mirrow): T_CRIT Limit Override
Public property | ConfigRegisterPWMDisableInSTANDBY | Config Register: PWM Disable in STANDBY
Public property | ConfigRegisterRDTSFaultQueue | Config Register: RDTS Fault Queue
Public property | ConfigRegisterSTANDBY | Config Register: STANDBY
Public property | ConfigRegisterTCRITLimitOverride | Config Register: T_CRIT Limit Override
Public property | ConversionRateRegister | Conversion Rate Register
Public property | ConversionRateRegister__1 | Conversion Rate Register_
Public property | FastTachometerSpinUp | Fast Tachometer Spin-Up
Public property | GPI1 | GPI 1
Public property | GPI2 | GPI 2
Public property | GPI3 | GPI 3
Public property | GPI4 | GPI 4
Public property | GPI5 | GPI 5
Public property | GPO1 | GPO 1
Public property | GPO2 | GPO 2
Public property | GPO3 | GPO 3
Public property | GPO4 | GPO 4
Public property | GPO5 | GPO 5
Public property | IDRegisters | ID Registers
Public property | IDRegistersManufacturer | ID Registers (Manufacturer)
Public property | LocalHighAlarm | Local High Alarm
Public property | LocalHighAlarmMask | Local High Alarm Mask
Public property | LocalHighSetpoint | Local High Setpoint
Public property | LocalHighSetpointMirrow | Local High Setpoint (Mirrow)
Public property | LocalTemperatur | Local Temperatur
Public property | LookupTableHysteresis | Lookup Table Hysteresis
Public property | LookupTablePWMEntry1 | Lookup Table PWM entry 1 (unit: °C)
Public property | LookupTablePWMEntry2 | Lookup Table PWM entry 2 (unit: °C)
Public property | LookupTablePWMEntry3 | Lookup Table PWM entry 3 (unit: °C)
Public property | LookupTablePWMEntry4 | Lookup Table PWM entry 4 (unit: °C)
Public property | LookupTablePWMEntry5 | Lookup Table PWM entry 5 (unit: °C)
Public property | LookupTablePWMEntry6 | Lookup Table PWM entry 6 (unit: °C)
Public property | LookupTablePWMEntry7 | Lookup Table PWM entry 7 (unit: °C)
Public property | LookupTablePWMEntry8 | Lookup Table PWM entry 8 (unit: °C)
Public property | LookupTableTemperatureEntry1 | Lookup Table Temperature Entry 1
Public property | LookupTableTemperatureEntry2 | Lookup Table Temperature Entry 2
Public property | LookupTableTemperatureEntry3 | Lookup Table Temperature Entry 3
Public property | LookupTableTemperatureEntry4 | Lookup Table Temperature Entry 4
Public property | LookupTableTemperatureEntry5 | Lookup Table Temperature Entry 5
Public property | LookupTableTemperatureEntry6 | Lookup Table Temperature Entry 6
Public property | LookupTableTemperatureEntry7 | Lookup Table Temperature Entry 7
Public property | LookupTableTemperatureEntry8 | Lookup Table Temperature Entry 8
Public property | OneShotRegister | One-Shot Register
Public property | PWMClockSelect | PWM Clock Select
Public property | PWMFrequency | PWM frequency (unit: kHz)
Public property | PWMOutputPolarity | PWM Output Polarity
Public property | PWMProgram | PWM Program
Public property | PWMSpinUpDutyCycle | PWM Spin-Up Duty Cycle
Public property | PWMSpinUpTime | PWM Spin-Up Time
Public property | PWMValue | PWM Value
Public property | RemoteDiodeFaultAlarm | Remote Diode Fault Alarm
Public property | RemoteDiodeTCRITHysteresis | Remote Diode T_CRIT Hysteresis (unit: °C)
Public property | RemoteDiodeTCRITLimit | Remote Diode T_CRIT Limit (unit: °C)
Public property | RemoteDiodeTemperatureFilter | Remote Diode Temperature Filter
Public property | RemoteDiodeTemperatureReading | Remote Diode Temperature Reading (unit: °C)
Public property | RemoteHighAlarm | Remote High Alarm
Public property | RemoteHighAlarmMask | Remote High Alarm Mask
Public property | RemoteHIGHSetpoint | Remote HIGH Setpoint (unit: °C)
Public property | RemoteHIGHSetpoint__1 | Remote HIGH Setpoint_ (unit: °C)
Public property | RemoteLowAlarm | Remote Low Alarm
Public property | RemoteLowAlarmMask | Remote Low Alarm Mask
Public property | RemoteLOWSetpoint | Remote LOW Setpoint (unit: °C)
Public property | RemoteLOWSetpoint__1 | Remote LOW Setpoint_ (unit: °C)
Public property | RemoteTCRITAlarm | Remote T_CRIT Alarm
Public property | RemoteTCRITAlarmMask | Remote T_CRIT Alarm Mask
Public property | RemoteTemperatureOFFSET | Remote Temperature OFFSET (unit: °C)
Public property | TachAlarm | Tach Alarm
Public property | TachAlarmMask | Tach Alarm Mask
Public property | TachometerCount | Tachometer Count
Public property | TachometerEdgeCount | Tachometer Edge Count
Public property | TachometerLimit | Tachometer Limit
Public property | TachometerMode | Tachometer Mode
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Accurate Remote Diode Digital Temperature Sensor
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm63(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm63

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63 Properties

The Lm63 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Busy | Busy
Public property | ComparatorMode | Comparator Mode
Public property | ConfigRegisterALERTMask | Config Register: ALERT Mask
Public property | ConfigRegisterALERTTachSelect | Config Register: ALERT/Tach Select
Public property | ConfigRegisterMirrowALERTMask | Config Register (Mirrow): ALERT Mask
Public property | ConfigRegisterMirrowALERTTachSelect | Config Register (Mirrow): ALERT/Tach Select
Public property | ConfigRegisterMirrowPWMDisableInSTANDBY | Config Register (Mirrow): PWM Disable in STANDBY
Public property | ConfigRegisterMirrowRDTSFaultQueue | Config Register (Mirrow): RDTS Fault Queue
Public property | ConfigRegisterMirrowSTANDBY | Config Register (Mirrow): STANDBY
Public property | ConfigRegisterMirrowTCRITLimitOverride | Config Register (Mirrow): T_CRIT Limit Override
Public property | ConfigRegisterPWMDisableInSTANDBY | Config Register: PWM Disable in STANDBY
Public property | ConfigRegisterRDTSFaultQueue | Config Register: RDTS Fault Queue
Public property | ConfigRegisterSTANDBY | Config Register: STANDBY
Public property | ConfigRegisterTCRITLimitOverride | Config Register: T_CRIT Limit Override
Public property | ConversionRateRegister | Conversion Rate Register
Public property | ConversionRateRegister__1 | Conversion Rate Register_
Public property | FastTachometerSpinUp | Fast Tachometer Spin-Up
Public property | GPI1 | GPI 1
Public property | GPI2 | GPI 2
Public property | GPI3 | GPI 3
Public property | GPI4 | GPI 4
Public property | GPI5 | GPI 5
Public property | GPO1 | GPO 1
Public property | GPO2 | GPO 2
Public property | GPO3 | GPO 3
Public property | GPO4 | GPO 4
Public property | GPO5 | GPO 5
Public property | IDRegisters | ID Registers
Public property | IDRegistersManufacturer | ID Registers (Manufacturer)
Public property | LocalHighAlarm | Local High Alarm
Public property | LocalHighAlarmMask | Local High Alarm Mask
Public property | LocalHighSetpoint | Local High Setpoint
Public property | LocalHighSetpointMirrow | Local High Setpoint (Mirrow)
Public property | LocalTemperatur | Local Temperatur
Public property | LookupTableHysteresis | Lookup Table Hysteresis
Public property | LookupTablePWMEntry1 | Lookup Table PWM entry 1 (unit: °C)
Public property | LookupTablePWMEntry2 | Lookup Table PWM entry 2 (unit: °C)
Public property | LookupTablePWMEntry3 | Lookup Table PWM entry 3 (unit: °C)
Public property | LookupTablePWMEntry4 | Lookup Table PWM entry 4 (unit: °C)
Public property | LookupTablePWMEntry5 | Lookup Table PWM entry 5 (unit: °C)
Public property | LookupTablePWMEntry6 | Lookup Table PWM entry 6 (unit: °C)
Public property | LookupTablePWMEntry7 | Lookup Table PWM entry 7 (unit: °C)
Public property | LookupTablePWMEntry8 | Lookup Table PWM entry 8 (unit: °C)
Public property | LookupTableTemperatureEntry1 | Lookup Table Temperature Entry 1
Public property | LookupTableTemperatureEntry2 | Lookup Table Temperature Entry 2
Public property | LookupTableTemperatureEntry3 | Lookup Table Temperature Entry 3
Public property | LookupTableTemperatureEntry4 | Lookup Table Temperature Entry 4
Public property | LookupTableTemperatureEntry5 | Lookup Table Temperature Entry 5
Public property | LookupTableTemperatureEntry6 | Lookup Table Temperature Entry 6
Public property | LookupTableTemperatureEntry7 | Lookup Table Temperature Entry 7
Public property | LookupTableTemperatureEntry8 | Lookup Table Temperature Entry 8
Public property | OneShotRegister | One-Shot Register
Public property | PWMClockSelect | PWM Clock Select
Public property | PWMFrequency | PWM frequency (unit: kHz)
Public property | PWMOutputPolarity | PWM Output Polarity
Public property | PWMProgram | PWM Program
Public property | PWMSpinUpDutyCycle | PWM Spin-Up Duty Cycle
Public property | PWMSpinUpTime | PWM Spin-Up Time
Public property | PWMValue | PWM Value
Public property | RemoteDiodeFaultAlarm | Remote Diode Fault Alarm
Public property | RemoteDiodeTCRITHysteresis | Remote Diode T_CRIT Hysteresis (unit: °C)
Public property | RemoteDiodeTCRITLimit | Remote Diode T_CRIT Limit (unit: °C)
Public property | RemoteDiodeTemperatureFilter | Remote Diode Temperature Filter
Public property | RemoteDiodeTemperatureReading | Remote Diode Temperature Reading (unit: °C)
Public property | RemoteHighAlarm | Remote High Alarm
Public property | RemoteHighAlarmMask | Remote High Alarm Mask
Public property | RemoteHIGHSetpoint | Remote HIGH Setpoint (unit: °C)
Public property | RemoteHIGHSetpoint__1 | Remote HIGH Setpoint_ (unit: °C)
Public property | RemoteLowAlarm | Remote Low Alarm
Public property | RemoteLowAlarmMask | Remote Low Alarm Mask
Public property | RemoteLOWSetpoint | Remote LOW Setpoint (unit: °C)
Public property | RemoteLOWSetpoint__1 | Remote LOW Setpoint_ (unit: °C)
Public property | RemoteTCRITAlarm | Remote T_CRIT Alarm
Public property | RemoteTCRITAlarmMask | Remote T_CRIT Alarm Mask
Public property | RemoteTemperatureOFFSET | Remote Temperature OFFSET (unit: °C)
Public property | TachAlarm | Tach Alarm
Public property | TachAlarmMask | Tach Alarm Mask
Public property | TachometerCount | Tachometer Count
Public property | TachometerEdgeCount | Tachometer Edge Count
Public property | TachometerLimit | Tachometer Limit
Public property | TachometerMode | Tachometer Mode
Top
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.AutoFlush Property

IRD

Lm63AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.Busy Property

IRD

Lm63Busy Property

Busy

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDALERTSTATUSANDMASK16 Busy { get; }
Public ReadOnly Property Busy As Lm63TYPIDALERTSTATUSANDMASK16
    Get
public:
property Lm63TYPIDALERTSTATUSANDMASK16 Busy {
    Lm63TYPIDALERTSTATUSANDMASK16 get ();
}
member Busy : Lm63TYPIDALERTSTATUSANDMASK16 with get

Property Value

Type: Lm63TYPIDALERTSTATUSANDMASK16
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.ComparatorMode Property

IRD

Lm63ComparatorMode Property

Comparator Mode

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDREMOTEDIODETEMPPERATUREFILTER0 ComparatorMode { get; set; }
Public Property ComparatorMode As Lm63TYPIDREMOTEDIODETEMPPERATUREFILTER0
    Get
    Set
public:
property Lm63TYPIDREMOTEDIODETEMPPERATUREFILTER0 ComparatorMode {
    Lm63TYPIDREMOTEDIODETEMPPERATUREFILTER0 get ();
    void set (Lm63TYPIDREMOTEDIODETEMPPERATUREFILTER0 value);
}
member ComparatorMode : Lm63TYPIDREMOTEDIODETEMPPERATUREFILTER0 with get, set

Property Value

Type: Lm63TYPIDREMOTEDIODETEMPPERATUREFILTER0
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.ConfigRegisterALERTMask Property

IRD

Lm63ConfigRegisterALERTMask Property

Config Register: ALERT Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDCONFIGURATIONREGISTER5 ConfigRegisterALERTMask { get; set; }
Public Property ConfigRegisterALERTMask As Lm63TYPIDCONFIGURATIONREGISTER5
    Get
    Set
public:
property Lm63TYPIDCONFIGURATIONREGISTER5 ConfigRegisterALERTMask {
    Lm63TYPIDCONFIGURATIONREGISTER5 get ();
    void set (Lm63TYPIDCONFIGURATIONREGISTER5 value);
}
member ConfigRegisterALERTMask : Lm63TYPIDCONFIGURATIONREGISTER5 with get, set

Property Value

Type: Lm63TYPIDCONFIGURATIONREGISTER5
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.ConfigRegisterALERTTachSelect Property

IRD

Lm63ConfigRegisterALERTTachSelect Property

Config Register: ALERT/Tach Select

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDCONFIGURATIONREGISTER2 ConfigRegisterALERTTachSelect { get; set; }
Public Property ConfigRegisterALERTTachSelect As Lm63TYPIDCONFIGURATIONREGISTER2
    Get
    Set
public:
property Lm63TYPIDCONFIGURATIONREGISTER2 ConfigRegisterALERTTachSelect {
    Lm63TYPIDCONFIGURATIONREGISTER2 get ();
    void set (Lm63TYPIDCONFIGURATIONREGISTER2 value);
}
member ConfigRegisterALERTTachSelect : Lm63TYPIDCONFIGURATIONREGISTER2 with get, set

Property Value

Type: Lm63TYPIDCONFIGURATIONREGISTER2
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.ConfigRegisterMirrowALERTMask Property

IRD

Lm63ConfigRegisterMirrowALERTMask Property

Config Register (Mirrow): ALERT Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDCONFIGURATIONREGISTER5 ConfigRegisterMirrowALERTMask { get; set; }
Public Property ConfigRegisterMirrowALERTMask As Lm63TYPIDCONFIGURATIONREGISTER5
    Get
    Set
public:
property Lm63TYPIDCONFIGURATIONREGISTER5 ConfigRegisterMirrowALERTMask {
    Lm63TYPIDCONFIGURATIONREGISTER5 get ();
    void set (Lm63TYPIDCONFIGURATIONREGISTER5 value);
}
member ConfigRegisterMirrowALERTMask : Lm63TYPIDCONFIGURATIONREGISTER5 with get, set

Property Value

Type: Lm63TYPIDCONFIGURATIONREGISTER5
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.ConfigRegisterMirrowALERTTachSelect Property

IRD

Lm63ConfigRegisterMirrowALERTTachSelect Property

Config Register (Mirrow): ALERT/Tach Select

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDCONFIGURATIONREGISTER2 ConfigRegisterMirrowALERTTachSelect { get; set; }
Public Property ConfigRegisterMirrowALERTTachSelect As Lm63TYPIDCONFIGURATIONREGISTER2
    Get
    Set
public:
property Lm63TYPIDCONFIGURATIONREGISTER2 ConfigRegisterMirrowALERTTachSelect {
    Lm63TYPIDCONFIGURATIONREGISTER2 get ();
    void set (Lm63TYPIDCONFIGURATIONREGISTER2 value);
}
member ConfigRegisterMirrowALERTTachSelect : Lm63TYPIDCONFIGURATIONREGISTER2 with get, set

Property Value

Type: Lm63TYPIDCONFIGURATIONREGISTER2
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.ConfigRegisterMirrowPWMDisableInSTANDBY Property

IRD

Lm63ConfigRegisterMirrowPWMDisableInSTANDBY Property

Config Register (Mirrow): PWM Disable in STANDBY

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDCONFIGURATIONREGISTER3 ConfigRegisterMirrowPWMDisableInSTANDBY { get; set; }
Public Property ConfigRegisterMirrowPWMDisableInSTANDBY As Lm63TYPIDCONFIGURATIONREGISTER3
    Get
    Set
public:
property Lm63TYPIDCONFIGURATIONREGISTER3 ConfigRegisterMirrowPWMDisableInSTANDBY {
    Lm63TYPIDCONFIGURATIONREGISTER3 get ();
    void set (Lm63TYPIDCONFIGURATIONREGISTER3 value);
}
member ConfigRegisterMirrowPWMDisableInSTANDBY : Lm63TYPIDCONFIGURATIONREGISTER3 with get, set

Property Value

Type: Lm63TYPIDCONFIGURATIONREGISTER3
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.ConfigRegisterMirrowRDTSFaultQueue Property

IRD

Lm63ConfigRegisterMirrowRDTSFaultQueue Property

Config Register (Mirrow): RDTS Fault Queue

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDCONFIGURATIONREGISTER0 ConfigRegisterMirrowRDTSFaultQueue { get; set; }
Public Property ConfigRegisterMirrowRDTSFaultQueue As Lm63TYPIDCONFIGURATIONREGISTER0
    Get
    Set
public:
property Lm63TYPIDCONFIGURATIONREGISTER0 ConfigRegisterMirrowRDTSFaultQueue {
    Lm63TYPIDCONFIGURATIONREGISTER0 get ();
    void set (Lm63TYPIDCONFIGURATIONREGISTER0 value);
}
member ConfigRegisterMirrowRDTSFaultQueue : Lm63TYPIDCONFIGURATIONREGISTER0 with get, set

Property Value

Type: Lm63TYPIDCONFIGURATIONREGISTER0
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.ConfigRegisterMirrowSTANDBY Property

IRD

Lm63ConfigRegisterMirrowSTANDBY Property

Config Register (Mirrow): STANDBY

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDCONFIGURATIONREGISTER4 ConfigRegisterMirrowSTANDBY { get; set; }
Public Property ConfigRegisterMirrowSTANDBY As Lm63TYPIDCONFIGURATIONREGISTER4
    Get
    Set
public:
property Lm63TYPIDCONFIGURATIONREGISTER4 ConfigRegisterMirrowSTANDBY {
    Lm63TYPIDCONFIGURATIONREGISTER4 get ();
    void set (Lm63TYPIDCONFIGURATIONREGISTER4 value);
}
member ConfigRegisterMirrowSTANDBY : Lm63TYPIDCONFIGURATIONREGISTER4 with get, set

Property Value

Type: Lm63TYPIDCONFIGURATIONREGISTER4
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.ConfigRegisterMirrowTCRITLimitOverride Property

IRD

Lm63ConfigRegisterMirrowTCRITLimitOverride Property

Config Register (Mirrow): T_CRIT Limit Override

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDCONFIGURATIONREGISTER1 ConfigRegisterMirrowTCRITLimitOverride { get; set; }
Public Property ConfigRegisterMirrowTCRITLimitOverride As Lm63TYPIDCONFIGURATIONREGISTER1
    Get
    Set
public:
property Lm63TYPIDCONFIGURATIONREGISTER1 ConfigRegisterMirrowTCRITLimitOverride {
    Lm63TYPIDCONFIGURATIONREGISTER1 get ();
    void set (Lm63TYPIDCONFIGURATIONREGISTER1 value);
}
member ConfigRegisterMirrowTCRITLimitOverride : Lm63TYPIDCONFIGURATIONREGISTER1 with get, set

Property Value

Type: Lm63TYPIDCONFIGURATIONREGISTER1
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.ConfigRegisterPWMDisableInSTANDBY Property

IRD

Lm63ConfigRegisterPWMDisableInSTANDBY Property

Config Register: PWM Disable in STANDBY

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDCONFIGURATIONREGISTER3 ConfigRegisterPWMDisableInSTANDBY { get; set; }
Public Property ConfigRegisterPWMDisableInSTANDBY As Lm63TYPIDCONFIGURATIONREGISTER3
    Get
    Set
public:
property Lm63TYPIDCONFIGURATIONREGISTER3 ConfigRegisterPWMDisableInSTANDBY {
    Lm63TYPIDCONFIGURATIONREGISTER3 get ();
    void set (Lm63TYPIDCONFIGURATIONREGISTER3 value);
}
member ConfigRegisterPWMDisableInSTANDBY : Lm63TYPIDCONFIGURATIONREGISTER3 with get, set

Property Value

Type: Lm63TYPIDCONFIGURATIONREGISTER3
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.ConfigRegisterRDTSFaultQueue Property

IRD

Lm63ConfigRegisterRDTSFaultQueue Property

Config Register: RDTS Fault Queue

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDCONFIGURATIONREGISTER0 ConfigRegisterRDTSFaultQueue { get; set; }
Public Property ConfigRegisterRDTSFaultQueue As Lm63TYPIDCONFIGURATIONREGISTER0
    Get
    Set
public:
property Lm63TYPIDCONFIGURATIONREGISTER0 ConfigRegisterRDTSFaultQueue {
    Lm63TYPIDCONFIGURATIONREGISTER0 get ();
    void set (Lm63TYPIDCONFIGURATIONREGISTER0 value);
}
member ConfigRegisterRDTSFaultQueue : Lm63TYPIDCONFIGURATIONREGISTER0 with get, set

Property Value

Type: Lm63TYPIDCONFIGURATIONREGISTER0
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.ConfigRegisterSTANDBY Property

IRD

Lm63ConfigRegisterSTANDBY Property

Config Register: STANDBY

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDCONFIGURATIONREGISTER4 ConfigRegisterSTANDBY { get; set; }
Public Property ConfigRegisterSTANDBY As Lm63TYPIDCONFIGURATIONREGISTER4
    Get
    Set
public:
property Lm63TYPIDCONFIGURATIONREGISTER4 ConfigRegisterSTANDBY {
    Lm63TYPIDCONFIGURATIONREGISTER4 get ();
    void set (Lm63TYPIDCONFIGURATIONREGISTER4 value);
}
member ConfigRegisterSTANDBY : Lm63TYPIDCONFIGURATIONREGISTER4 with get, set

Property Value

Type: Lm63TYPIDCONFIGURATIONREGISTER4
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.ConfigRegisterTCRITLimitOverride Property

IRD

Lm63ConfigRegisterTCRITLimitOverride Property

Config Register: T_CRIT Limit Override

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDCONFIGURATIONREGISTER1 ConfigRegisterTCRITLimitOverride { get; set; }
Public Property ConfigRegisterTCRITLimitOverride As Lm63TYPIDCONFIGURATIONREGISTER1
    Get
    Set
public:
property Lm63TYPIDCONFIGURATIONREGISTER1 ConfigRegisterTCRITLimitOverride {
    Lm63TYPIDCONFIGURATIONREGISTER1 get ();
    void set (Lm63TYPIDCONFIGURATIONREGISTER1 value);
}
member ConfigRegisterTCRITLimitOverride : Lm63TYPIDCONFIGURATIONREGISTER1 with get, set

Property Value

Type: Lm63TYPIDCONFIGURATIONREGISTER1
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.ConversionRateRegister Property

IRD

Lm63ConversionRateRegister Property

Conversion Rate Register

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDCONVERSIONRATEREGISTER0 ConversionRateRegister { get; set; }
Public Property ConversionRateRegister As Lm63TYPIDCONVERSIONRATEREGISTER0
    Get
    Set
public:
property Lm63TYPIDCONVERSIONRATEREGISTER0 ConversionRateRegister {
    Lm63TYPIDCONVERSIONRATEREGISTER0 get ();
    void set (Lm63TYPIDCONVERSIONRATEREGISTER0 value);
}
member ConversionRateRegister : Lm63TYPIDCONVERSIONRATEREGISTER0 with get, set

Property Value

Type: Lm63TYPIDCONVERSIONRATEREGISTER0
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.ConversionRateRegister__1 Property

IRD

Lm63ConversionRateRegister__1 Property

Conversion Rate Register_

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDCONVERSIONRATEREGISTER0 ConversionRateRegister__1 { get; set; }
Public Property ConversionRateRegister__1 As Lm63TYPIDCONVERSIONRATEREGISTER0
    Get
    Set
public:
property Lm63TYPIDCONVERSIONRATEREGISTER0 ConversionRateRegister__1 {
    Lm63TYPIDCONVERSIONRATEREGISTER0 get ();
    void set (Lm63TYPIDCONVERSIONRATEREGISTER0 value);
}
member ConversionRateRegister__1 : Lm63TYPIDCONVERSIONRATEREGISTER0 with get, set

Property Value

Type: Lm63TYPIDCONVERSIONRATEREGISTER0
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.FastTachometerSpinUp Property

IRD

Lm63FastTachometerSpinUp Property

Fast Tachometer Spin-Up

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDFANCONTROLREGISTERS22 FastTachometerSpinUp { get; set; }
Public Property FastTachometerSpinUp As Lm63TYPIDFANCONTROLREGISTERS22
    Get
    Set
public:
property Lm63TYPIDFANCONTROLREGISTERS22 FastTachometerSpinUp {
    Lm63TYPIDFANCONTROLREGISTERS22 get ();
    void set (Lm63TYPIDFANCONTROLREGISTERS22 value);
}
member FastTachometerSpinUp : Lm63TYPIDFANCONTROLREGISTERS22 with get, set

Property Value

Type: Lm63TYPIDFANCONTROLREGISTERS22
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.GPI1 Property

IRD

Lm63GPI1 Property

GPI 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPI1 { get; }
Public ReadOnly Property GPI1 As Byte
    Get
public:
property unsigned char GPI1 {
    unsigned char get ();
}
member GPI1 : byte with get

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.GPI2 Property

IRD

Lm63GPI2 Property

GPI 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPI2 { get; }
Public ReadOnly Property GPI2 As Byte
    Get
public:
property unsigned char GPI2 {
    unsigned char get ();
}
member GPI2 : byte with get

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.GPI3 Property

IRD

Lm63GPI3 Property

GPI 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPI3 { get; }
Public ReadOnly Property GPI3 As Byte
    Get
public:
property unsigned char GPI3 {
    unsigned char get ();
}
member GPI3 : byte with get

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.GPI4 Property

IRD

Lm63GPI4 Property

GPI 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPI4 { get; }
Public ReadOnly Property GPI4 As Byte
    Get
public:
property unsigned char GPI4 {
    unsigned char get ();
}
member GPI4 : byte with get

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.GPI5 Property

IRD

Lm63GPI5 Property

GPI 5

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPI5 { get; }
Public ReadOnly Property GPI5 As Byte
    Get
public:
property unsigned char GPI5 {
    unsigned char get ();
}
member GPI5 : byte with get

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.GPO1 Property

IRD

Lm63GPO1 Property

GPO 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPO1 { get; set; }
Public Property GPO1 As Byte
    Get
    Set
public:
property unsigned char GPO1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPO1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.GPO2 Property

IRD

Lm63GPO2 Property

GPO 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPO2 { get; set; }
Public Property GPO2 As Byte
    Get
    Set
public:
property unsigned char GPO2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPO2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.GPO3 Property

IRD

Lm63GPO3 Property

GPO 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPO3 { get; set; }
Public Property GPO3 As Byte
    Get
    Set
public:
property unsigned char GPO3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPO3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.GPO4 Property

IRD

Lm63GPO4 Property

GPO 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPO4 { get; set; }
Public Property GPO4 As Byte
    Get
    Set
public:
property unsigned char GPO4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPO4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.GPO5 Property

IRD

Lm63GPO5 Property

GPO 5

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPO5 { get; set; }
Public Property GPO5 As Byte
    Get
    Set
public:
property unsigned char GPO5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPO5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.IDRegisters Property

IRD

Lm63IDRegisters Property

ID Registers

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IDRegisters { get; }
Public ReadOnly Property IDRegisters As Byte
    Get
public:
property unsigned char IDRegisters {
    unsigned char get ();
}
member IDRegisters : byte with get

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.IDRegistersManufacturer Property

IRD

Lm63IDRegistersManufacturer Property

ID Registers (Manufacturer)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IDRegistersManufacturer { get; }
Public ReadOnly Property IDRegistersManufacturer As Byte
    Get
public:
property unsigned char IDRegistersManufacturer {
    unsigned char get ();
}
member IDRegistersManufacturer : byte with get

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LocalHighAlarm Property

IRD

Lm63LocalHighAlarm Property

Local High Alarm

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDALERTSTATUSANDMASK15 LocalHighAlarm { get; }
Public ReadOnly Property LocalHighAlarm As Lm63TYPIDALERTSTATUSANDMASK15
    Get
public:
property Lm63TYPIDALERTSTATUSANDMASK15 LocalHighAlarm {
    Lm63TYPIDALERTSTATUSANDMASK15 get ();
}
member LocalHighAlarm : Lm63TYPIDALERTSTATUSANDMASK15 with get

Property Value

Type: Lm63TYPIDALERTSTATUSANDMASK15
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LocalHighAlarmMask Property

IRD

Lm63LocalHighAlarmMask Property

Local High Alarm Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDALERTSTATUSANDMASK24 LocalHighAlarmMask { get; set; }
Public Property LocalHighAlarmMask As Lm63TYPIDALERTSTATUSANDMASK24
    Get
    Set
public:
property Lm63TYPIDALERTSTATUSANDMASK24 LocalHighAlarmMask {
    Lm63TYPIDALERTSTATUSANDMASK24 get ();
    void set (Lm63TYPIDALERTSTATUSANDMASK24 value);
}
member LocalHighAlarmMask : Lm63TYPIDALERTSTATUSANDMASK24 with get, set

Property Value

Type: Lm63TYPIDALERTSTATUSANDMASK24
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LocalHighSetpoint Property

IRD

Lm63LocalHighSetpoint Property

Local High Setpoint

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalHighSetpoint { get; set; }
Public Property LocalHighSetpoint As SByte
    Get
    Set
public:
property signed char LocalHighSetpoint {
    signed char get ();
    void set (signed char value);
}
member LocalHighSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LocalHighSetpointMirrow Property

IRD

Lm63LocalHighSetpointMirrow Property

Local High Setpoint (Mirrow)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalHighSetpointMirrow { set; }
Public WriteOnly Property LocalHighSetpointMirrow As SByte
    Set
public:
property signed char LocalHighSetpointMirrow {
    void set (signed char value);
}
member LocalHighSetpointMirrow : sbyte with set

Property Value

Type: SByte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LocalTemperatur Property

IRD

Lm63LocalTemperatur Property

Local Temperatur

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalTemperatur { get; }
Public ReadOnly Property LocalTemperatur As Byte
    Get
public:
property unsigned char LocalTemperatur {
    unsigned char get ();
}
member LocalTemperatur : byte with get

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LookupTableHysteresis Property

IRD

Lm63LookupTableHysteresis Property

Lookup Table Hysteresis

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTableHysteresis { get; set; }
Public Property LookupTableHysteresis As Byte
    Get
    Set
public:
property unsigned char LookupTableHysteresis {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTableHysteresis : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LookupTablePWMEntry1 Property

IRD

Lm63LookupTablePWMEntry1 Property

Lookup Table PWM entry 1 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTablePWMEntry1 { get; set; }
Public Property LookupTablePWMEntry1 As Byte
    Get
    Set
public:
property unsigned char LookupTablePWMEntry1 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTablePWMEntry1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LookupTablePWMEntry2 Property

IRD

Lm63LookupTablePWMEntry2 Property

Lookup Table PWM entry 2 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTablePWMEntry2 { get; set; }
Public Property LookupTablePWMEntry2 As Byte
    Get
    Set
public:
property unsigned char LookupTablePWMEntry2 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTablePWMEntry2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LookupTablePWMEntry3 Property

IRD

Lm63LookupTablePWMEntry3 Property

Lookup Table PWM entry 3 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTablePWMEntry3 { get; set; }
Public Property LookupTablePWMEntry3 As Byte
    Get
    Set
public:
property unsigned char LookupTablePWMEntry3 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTablePWMEntry3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LookupTablePWMEntry4 Property

IRD

Lm63LookupTablePWMEntry4 Property

Lookup Table PWM entry 4 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTablePWMEntry4 { get; set; }
Public Property LookupTablePWMEntry4 As Byte
    Get
    Set
public:
property unsigned char LookupTablePWMEntry4 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTablePWMEntry4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LookupTablePWMEntry5 Property

IRD

Lm63LookupTablePWMEntry5 Property

Lookup Table PWM entry 5 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTablePWMEntry5 { get; set; }
Public Property LookupTablePWMEntry5 As Byte
    Get
    Set
public:
property unsigned char LookupTablePWMEntry5 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTablePWMEntry5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LookupTablePWMEntry6 Property

IRD

Lm63LookupTablePWMEntry6 Property

Lookup Table PWM entry 6 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTablePWMEntry6 { get; set; }
Public Property LookupTablePWMEntry6 As Byte
    Get
    Set
public:
property unsigned char LookupTablePWMEntry6 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTablePWMEntry6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LookupTablePWMEntry7 Property

IRD

Lm63LookupTablePWMEntry7 Property

Lookup Table PWM entry 7 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTablePWMEntry7 { get; set; }
Public Property LookupTablePWMEntry7 As Byte
    Get
    Set
public:
property unsigned char LookupTablePWMEntry7 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTablePWMEntry7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LookupTablePWMEntry8 Property

IRD

Lm63LookupTablePWMEntry8 Property

Lookup Table PWM entry 8 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTablePWMEntry8 { get; set; }
Public Property LookupTablePWMEntry8 As Byte
    Get
    Set
public:
property unsigned char LookupTablePWMEntry8 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTablePWMEntry8 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LookupTableTemperatureEntry1 Property

IRD

Lm63LookupTableTemperatureEntry1 Property

Lookup Table Temperature Entry 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTableTemperatureEntry1 { get; set; }
Public Property LookupTableTemperatureEntry1 As Byte
    Get
    Set
public:
property unsigned char LookupTableTemperatureEntry1 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTableTemperatureEntry1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LookupTableTemperatureEntry2 Property

IRD

Lm63LookupTableTemperatureEntry2 Property

Lookup Table Temperature Entry 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTableTemperatureEntry2 { get; set; }
Public Property LookupTableTemperatureEntry2 As Byte
    Get
    Set
public:
property unsigned char LookupTableTemperatureEntry2 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTableTemperatureEntry2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LookupTableTemperatureEntry3 Property

IRD

Lm63LookupTableTemperatureEntry3 Property

Lookup Table Temperature Entry 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTableTemperatureEntry3 { get; set; }
Public Property LookupTableTemperatureEntry3 As Byte
    Get
    Set
public:
property unsigned char LookupTableTemperatureEntry3 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTableTemperatureEntry3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LookupTableTemperatureEntry4 Property

IRD

Lm63LookupTableTemperatureEntry4 Property

Lookup Table Temperature Entry 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTableTemperatureEntry4 { get; set; }
Public Property LookupTableTemperatureEntry4 As Byte
    Get
    Set
public:
property unsigned char LookupTableTemperatureEntry4 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTableTemperatureEntry4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LookupTableTemperatureEntry5 Property

IRD

Lm63LookupTableTemperatureEntry5 Property

Lookup Table Temperature Entry 5

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTableTemperatureEntry5 { get; set; }
Public Property LookupTableTemperatureEntry5 As Byte
    Get
    Set
public:
property unsigned char LookupTableTemperatureEntry5 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTableTemperatureEntry5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LookupTableTemperatureEntry6 Property

IRD

Lm63LookupTableTemperatureEntry6 Property

Lookup Table Temperature Entry 6

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTableTemperatureEntry6 { get; set; }
Public Property LookupTableTemperatureEntry6 As Byte
    Get
    Set
public:
property unsigned char LookupTableTemperatureEntry6 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTableTemperatureEntry6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LookupTableTemperatureEntry7 Property

IRD

Lm63LookupTableTemperatureEntry7 Property

Lookup Table Temperature Entry 7

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTableTemperatureEntry7 { get; set; }
Public Property LookupTableTemperatureEntry7 As Byte
    Get
    Set
public:
property unsigned char LookupTableTemperatureEntry7 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTableTemperatureEntry7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.LookupTableTemperatureEntry8 Property

IRD

Lm63LookupTableTemperatureEntry8 Property

Lookup Table Temperature Entry 8

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTableTemperatureEntry8 { get; set; }
Public Property LookupTableTemperatureEntry8 As Byte
    Get
    Set
public:
property unsigned char LookupTableTemperatureEntry8 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTableTemperatureEntry8 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.OneShotRegister Property

IRD

Lm63OneShotRegister Property

One-Shot Register

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OneShotRegister { set; }
Public WriteOnly Property OneShotRegister As Byte
    Set
public:
property unsigned char OneShotRegister {
    void set (unsigned char value);
}
member OneShotRegister : byte with set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.PWMClockSelect Property

IRD

Lm63PWMClockSelect Property

PWM Clock Select

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDFANCONTROLREGISTERS11 PWMClockSelect { get; set; }
Public Property PWMClockSelect As Lm63TYPIDFANCONTROLREGISTERS11
    Get
    Set
public:
property Lm63TYPIDFANCONTROLREGISTERS11 PWMClockSelect {
    Lm63TYPIDFANCONTROLREGISTERS11 get ();
    void set (Lm63TYPIDFANCONTROLREGISTERS11 value);
}
member PWMClockSelect : Lm63TYPIDFANCONTROLREGISTERS11 with get, set

Property Value

Type: Lm63TYPIDFANCONTROLREGISTERS11
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.PWMFrequency Property

IRD

Lm63PWMFrequency Property

PWM frequency (unit: kHz)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDFANPWMFREQUENCY0 PWMFrequency { get; set; }
Public Property PWMFrequency As Lm63TYPIDFANPWMFREQUENCY0
    Get
    Set
public:
property Lm63TYPIDFANPWMFREQUENCY0 PWMFrequency {
    Lm63TYPIDFANPWMFREQUENCY0 get ();
    void set (Lm63TYPIDFANPWMFREQUENCY0 value);
}
member PWMFrequency : Lm63TYPIDFANPWMFREQUENCY0 with get, set

Property Value

Type: Lm63TYPIDFANPWMFREQUENCY0
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.PWMOutputPolarity Property

IRD

Lm63PWMOutputPolarity Property

PWM Output Polarity

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDFANCONTROLREGISTERS12 PWMOutputPolarity { get; set; }
Public Property PWMOutputPolarity As Lm63TYPIDFANCONTROLREGISTERS12
    Get
    Set
public:
property Lm63TYPIDFANCONTROLREGISTERS12 PWMOutputPolarity {
    Lm63TYPIDFANCONTROLREGISTERS12 get ();
    void set (Lm63TYPIDFANCONTROLREGISTERS12 value);
}
member PWMOutputPolarity : Lm63TYPIDFANCONTROLREGISTERS12 with get, set

Property Value

Type: Lm63TYPIDFANCONTROLREGISTERS12
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.PWMProgram Property

IRD

Lm63PWMProgram Property

PWM Program

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDFANCONTROLREGISTERS13 PWMProgram { get; set; }
Public Property PWMProgram As Lm63TYPIDFANCONTROLREGISTERS13
    Get
    Set
public:
property Lm63TYPIDFANCONTROLREGISTERS13 PWMProgram {
    Lm63TYPIDFANCONTROLREGISTERS13 get ();
    void set (Lm63TYPIDFANCONTROLREGISTERS13 value);
}
member PWMProgram : Lm63TYPIDFANCONTROLREGISTERS13 with get, set

Property Value

Type: Lm63TYPIDFANCONTROLREGISTERS13
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.PWMSpinUpDutyCycle Property

IRD

Lm63PWMSpinUpDutyCycle Property

PWM Spin-Up Duty Cycle

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDFANCONTROLREGISTERS21 PWMSpinUpDutyCycle { get; set; }
Public Property PWMSpinUpDutyCycle As Lm63TYPIDFANCONTROLREGISTERS21
    Get
    Set
public:
property Lm63TYPIDFANCONTROLREGISTERS21 PWMSpinUpDutyCycle {
    Lm63TYPIDFANCONTROLREGISTERS21 get ();
    void set (Lm63TYPIDFANCONTROLREGISTERS21 value);
}
member PWMSpinUpDutyCycle : Lm63TYPIDFANCONTROLREGISTERS21 with get, set

Property Value

Type: Lm63TYPIDFANCONTROLREGISTERS21
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.PWMSpinUpTime Property

IRD

Lm63PWMSpinUpTime Property

PWM Spin-Up Time

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDFANCONTROLREGISTERS20 PWMSpinUpTime { get; set; }
Public Property PWMSpinUpTime As Lm63TYPIDFANCONTROLREGISTERS20
    Get
    Set
public:
property Lm63TYPIDFANCONTROLREGISTERS20 PWMSpinUpTime {
    Lm63TYPIDFANCONTROLREGISTERS20 get ();
    void set (Lm63TYPIDFANCONTROLREGISTERS20 value);
}
member PWMSpinUpTime : Lm63TYPIDFANCONTROLREGISTERS20 with get, set

Property Value

Type: Lm63TYPIDFANCONTROLREGISTERS20
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.PWMValue Property

IRD

Lm63PWMValue Property

PWM Value

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWMValue { get; set; }
Public Property PWMValue As Byte
    Get
    Set
public:
property unsigned char PWMValue {
    unsigned char get ();
    void set (unsigned char value);
}
member PWMValue : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.RemoteDiodeFaultAlarm Property

IRD

Lm63RemoteDiodeFaultAlarm Property

Remote Diode Fault Alarm

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDALERTSTATUSANDMASK12 RemoteDiodeFaultAlarm { get; }
Public ReadOnly Property RemoteDiodeFaultAlarm As Lm63TYPIDALERTSTATUSANDMASK12
    Get
public:
property Lm63TYPIDALERTSTATUSANDMASK12 RemoteDiodeFaultAlarm {
    Lm63TYPIDALERTSTATUSANDMASK12 get ();
}
member RemoteDiodeFaultAlarm : Lm63TYPIDALERTSTATUSANDMASK12 with get

Property Value

Type: Lm63TYPIDALERTSTATUSANDMASK12
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.RemoteDiodeTCRITHysteresis Property

IRD

Lm63RemoteDiodeTCRITHysteresis Property

Remote Diode T_CRIT Hysteresis (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteDiodeTCRITHysteresis { get; set; }
Public Property RemoteDiodeTCRITHysteresis As SByte
    Get
    Set
public:
property signed char RemoteDiodeTCRITHysteresis {
    signed char get ();
    void set (signed char value);
}
member RemoteDiodeTCRITHysteresis : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.RemoteDiodeTCRITLimit Property

IRD

Lm63RemoteDiodeTCRITLimit Property

Remote Diode T_CRIT Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteDiodeTCRITLimit { get; set; }
Public Property RemoteDiodeTCRITLimit As SByte
    Get
    Set
public:
property signed char RemoteDiodeTCRITLimit {
    signed char get ();
    void set (signed char value);
}
member RemoteDiodeTCRITLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.RemoteDiodeTemperatureFilter Property

IRD

Lm63RemoteDiodeTemperatureFilter Property

Remote Diode Temperature Filter

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDREMOTEDIODETEMPPERATUREFILTER1 RemoteDiodeTemperatureFilter { get; set; }
Public Property RemoteDiodeTemperatureFilter As Lm63TYPIDREMOTEDIODETEMPPERATUREFILTER1
    Get
    Set
public:
property Lm63TYPIDREMOTEDIODETEMPPERATUREFILTER1 RemoteDiodeTemperatureFilter {
    Lm63TYPIDREMOTEDIODETEMPPERATUREFILTER1 get ();
    void set (Lm63TYPIDREMOTEDIODETEMPPERATUREFILTER1 value);
}
member RemoteDiodeTemperatureFilter : Lm63TYPIDREMOTEDIODETEMPPERATUREFILTER1 with get, set

Property Value

Type: Lm63TYPIDREMOTEDIODETEMPPERATUREFILTER1
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.RemoteDiodeTemperatureReading Property

IRD

Lm63RemoteDiodeTemperatureReading Property

Remote Diode Temperature Reading (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteDiodeTemperatureReading { get; }
Public ReadOnly Property RemoteDiodeTemperatureReading As Double
    Get
public:
property double RemoteDiodeTemperatureReading {
    double get ();
}
member RemoteDiodeTemperatureReading : float with get

Property Value

Type: Double
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.RemoteHighAlarm Property

IRD

Lm63RemoteHighAlarm Property

Remote High Alarm

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDALERTSTATUSANDMASK14 RemoteHighAlarm { get; }
Public ReadOnly Property RemoteHighAlarm As Lm63TYPIDALERTSTATUSANDMASK14
    Get
public:
property Lm63TYPIDALERTSTATUSANDMASK14 RemoteHighAlarm {
    Lm63TYPIDALERTSTATUSANDMASK14 get ();
}
member RemoteHighAlarm : Lm63TYPIDALERTSTATUSANDMASK14 with get

Property Value

Type: Lm63TYPIDALERTSTATUSANDMASK14
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.RemoteHighAlarmMask Property

IRD

Lm63RemoteHighAlarmMask Property

Remote High Alarm Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDALERTSTATUSANDMASK23 RemoteHighAlarmMask { get; set; }
Public Property RemoteHighAlarmMask As Lm63TYPIDALERTSTATUSANDMASK23
    Get
    Set
public:
property Lm63TYPIDALERTSTATUSANDMASK23 RemoteHighAlarmMask {
    Lm63TYPIDALERTSTATUSANDMASK23 get ();
    void set (Lm63TYPIDALERTSTATUSANDMASK23 value);
}
member RemoteHighAlarmMask : Lm63TYPIDALERTSTATUSANDMASK23 with get, set

Property Value

Type: Lm63TYPIDALERTSTATUSANDMASK23
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.RemoteHIGHSetpoint Property

IRD

Lm63RemoteHIGHSetpoint Property

Remote HIGH Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteHIGHSetpoint { get; }
Public ReadOnly Property RemoteHIGHSetpoint As Double
    Get
public:
property double RemoteHIGHSetpoint {
    double get ();
}
member RemoteHIGHSetpoint : float with get

Property Value

Type: Double
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.RemoteHIGHSetpoint__1 Property

IRD

Lm63RemoteHIGHSetpoint__1 Property

Remote HIGH Setpoint_ (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteHIGHSetpoint__1 { set; }
Public WriteOnly Property RemoteHIGHSetpoint__1 As Double
    Set
public:
property double RemoteHIGHSetpoint__1 {
    void set (double value);
}
member RemoteHIGHSetpoint__1 : float with set

Property Value

Type: Double
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.RemoteLowAlarm Property

IRD

Lm63RemoteLowAlarm Property

Remote Low Alarm

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDALERTSTATUSANDMASK13 RemoteLowAlarm { get; }
Public ReadOnly Property RemoteLowAlarm As Lm63TYPIDALERTSTATUSANDMASK13
    Get
public:
property Lm63TYPIDALERTSTATUSANDMASK13 RemoteLowAlarm {
    Lm63TYPIDALERTSTATUSANDMASK13 get ();
}
member RemoteLowAlarm : Lm63TYPIDALERTSTATUSANDMASK13 with get

Property Value

Type: Lm63TYPIDALERTSTATUSANDMASK13
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.RemoteLowAlarmMask Property

IRD

Lm63RemoteLowAlarmMask Property

Remote Low Alarm Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDALERTSTATUSANDMASK22 RemoteLowAlarmMask { get; set; }
Public Property RemoteLowAlarmMask As Lm63TYPIDALERTSTATUSANDMASK22
    Get
    Set
public:
property Lm63TYPIDALERTSTATUSANDMASK22 RemoteLowAlarmMask {
    Lm63TYPIDALERTSTATUSANDMASK22 get ();
    void set (Lm63TYPIDALERTSTATUSANDMASK22 value);
}
member RemoteLowAlarmMask : Lm63TYPIDALERTSTATUSANDMASK22 with get, set

Property Value

Type: Lm63TYPIDALERTSTATUSANDMASK22
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.RemoteLOWSetpoint Property

IRD

Lm63RemoteLOWSetpoint Property

Remote LOW Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteLOWSetpoint { get; }
Public ReadOnly Property RemoteLOWSetpoint As Double
    Get
public:
property double RemoteLOWSetpoint {
    double get ();
}
member RemoteLOWSetpoint : float with get

Property Value

Type: Double
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.RemoteLOWSetpoint__1 Property

IRD

Lm63RemoteLOWSetpoint__1 Property

Remote LOW Setpoint_ (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteLOWSetpoint__1 { set; }
Public WriteOnly Property RemoteLOWSetpoint__1 As Double
    Set
public:
property double RemoteLOWSetpoint__1 {
    void set (double value);
}
member RemoteLOWSetpoint__1 : float with set

Property Value

Type: Double
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.RemoteTCRITAlarm Property

IRD

Lm63RemoteTCRITAlarm Property

Remote T_CRIT Alarm

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDALERTSTATUSANDMASK11 RemoteTCRITAlarm { get; }
Public ReadOnly Property RemoteTCRITAlarm As Lm63TYPIDALERTSTATUSANDMASK11
    Get
public:
property Lm63TYPIDALERTSTATUSANDMASK11 RemoteTCRITAlarm {
    Lm63TYPIDALERTSTATUSANDMASK11 get ();
}
member RemoteTCRITAlarm : Lm63TYPIDALERTSTATUSANDMASK11 with get

Property Value

Type: Lm63TYPIDALERTSTATUSANDMASK11
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.RemoteTCRITAlarmMask Property

IRD

Lm63RemoteTCRITAlarmMask Property

Remote T_CRIT Alarm Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDALERTSTATUSANDMASK21 RemoteTCRITAlarmMask { get; set; }
Public Property RemoteTCRITAlarmMask As Lm63TYPIDALERTSTATUSANDMASK21
    Get
    Set
public:
property Lm63TYPIDALERTSTATUSANDMASK21 RemoteTCRITAlarmMask {
    Lm63TYPIDALERTSTATUSANDMASK21 get ();
    void set (Lm63TYPIDALERTSTATUSANDMASK21 value);
}
member RemoteTCRITAlarmMask : Lm63TYPIDALERTSTATUSANDMASK21 with get, set

Property Value

Type: Lm63TYPIDALERTSTATUSANDMASK21
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.RemoteTemperatureOFFSET Property

IRD

Lm63RemoteTemperatureOFFSET Property

Remote Temperature OFFSET (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperatureOFFSET { get; set; }
Public Property RemoteTemperatureOFFSET As Double
    Get
    Set
public:
property double RemoteTemperatureOFFSET {
    double get ();
    void set (double value);
}
member RemoteTemperatureOFFSET : float with get, set

Property Value

Type: Double
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.TachAlarm Property

IRD

Lm63TachAlarm Property

Tach Alarm

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDALERTSTATUSANDMASK10 TachAlarm { get; }
Public ReadOnly Property TachAlarm As Lm63TYPIDALERTSTATUSANDMASK10
    Get
public:
property Lm63TYPIDALERTSTATUSANDMASK10 TachAlarm {
    Lm63TYPIDALERTSTATUSANDMASK10 get ();
}
member TachAlarm : Lm63TYPIDALERTSTATUSANDMASK10 with get

Property Value

Type: Lm63TYPIDALERTSTATUSANDMASK10
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.TachAlarmMask Property

IRD

Lm63TachAlarmMask Property

Tach Alarm Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDALERTSTATUSANDMASK20 TachAlarmMask { get; set; }
Public Property TachAlarmMask As Lm63TYPIDALERTSTATUSANDMASK20
    Get
    Set
public:
property Lm63TYPIDALERTSTATUSANDMASK20 TachAlarmMask {
    Lm63TYPIDALERTSTATUSANDMASK20 get ();
    void set (Lm63TYPIDALERTSTATUSANDMASK20 value);
}
member TachAlarmMask : Lm63TYPIDALERTSTATUSANDMASK20 with get, set

Property Value

Type: Lm63TYPIDALERTSTATUSANDMASK20
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.TachometerCount Property

IRD

Lm63TachometerCount Property

Tachometer Count

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TachometerCount { get; }
Public ReadOnly Property TachometerCount As UShort
    Get
public:
property unsigned short TachometerCount {
    unsigned short get ();
}
member TachometerCount : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.TachometerEdgeCount Property

IRD

Lm63TachometerEdgeCount Property

Tachometer Edge Count

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TachometerEdgeCount { get; }
Public ReadOnly Property TachometerEdgeCount As Byte
    Get
public:
property unsigned char TachometerEdgeCount {
    unsigned char get ();
}
member TachometerEdgeCount : byte with get

Property Value

Type: Byte
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.TachometerLimit Property

IRD

Lm63TachometerLimit Property

Tachometer Limit

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TachometerLimit { get; }
Public ReadOnly Property TachometerLimit As UShort
    Get
public:
property unsigned short TachometerLimit {
    unsigned short get ();
}
member TachometerLimit : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.TachometerMode Property

IRD

Lm63TachometerMode Property

Tachometer Mode

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm63TYPIDFANCONTROLREGISTERS10 TachometerMode { get; set; }
Public Property TachometerMode As Lm63TYPIDFANCONTROLREGISTERS10
    Get
    Set
public:
property Lm63TYPIDFANCONTROLREGISTERS10 TachometerMode {
    Lm63TYPIDFANCONTROLREGISTERS10 get ();
    void set (Lm63TYPIDFANCONTROLREGISTERS10 value);
}
member TachometerMode : Lm63TYPIDFANCONTROLREGISTERS10 with get, set

Property Value

Type: Lm63TYPIDFANCONTROLREGISTERS10
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63 Methods

The Lm63 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.Flush Method

IRD

Lm63Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm63 Class
telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDALERTSTATUSANDMASK10 Enumeration

IRD

Lm63TYPIDALERTSTATUSANDMASK10 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUSANDMASK10
Public Enumeration TYPIDALERTSTATUSANDMASK10
public enum class TYPIDALERTSTATUSANDMASK10
type TYPIDALERTSTATUSANDMASK10
Members
Member name | Value | Description
TachometerCountIsLowerThanOrEqualToTheTachometerLimit | 0 | Tachometer count is lower than or equal to the Tachometer Limit
TachometerCountIsHigherThanTheTachometerLimit | 1 | Tachometer count is higher than the Tachometer Limit
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDALERTSTATUSANDMASK11 Enumeration

IRD

Lm63TYPIDALERTSTATUSANDMASK11 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUSANDMASK11
Public Enumeration TYPIDALERTSTATUSANDMASK11
public enum class TYPIDALERTSTATUSANDMASK11
type TYPIDALERTSTATUSANDMASK11
Members
Member name | Value | Description
TemperatureOfTheRemoteDiodeIsAtOrBelowTheTCRITLimit | 0 | Temperature of the Remote Diode is at or below the T_CRIT Limit
TemperatureOfTheRemoteDiodeIsAboveTheTCRITLimit | 1 | Temperature of the Remote Diode is above the T_CRIT Limit
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDALERTSTATUSANDMASK12 Enumeration

IRD

Lm63TYPIDALERTSTATUSANDMASK12 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUSANDMASK12
Public Enumeration TYPIDALERTSTATUSANDMASK12
public enum class TYPIDALERTSTATUSANDMASK12
type TYPIDALERTSTATUSANDMASK12
Members
Member name | Value | Description
RemoteDiodeAppearsToBeCorrectlyConnected | 0 | Remote Diode appears to be correctly connected
RemoteDiodeMayBeDisconnectedOrShorted | 1 | Remote Diode may be disconnected or shorted
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDALERTSTATUSANDMASK13 Enumeration

IRD

Lm63TYPIDALERTSTATUSANDMASK13 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUSANDMASK13
Public Enumeration TYPIDALERTSTATUSANDMASK13
public enum class TYPIDALERTSTATUSANDMASK13
type TYPIDALERTSTATUSANDMASK13
Members
Member name | Value | Description
TemperatureOfTheRemoteDiodeIsAtOrAboveTheRemoteLowSetpoint | 0 | Temperature of the Remote Diode is at or above the Remote Low Setpoint
TemperatureOfTheRemoteDiodeIsBelowTheRemoteLowSetpoint | 1 | Temperature of the Remote Diode is below the Remote Low Setpoint
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDALERTSTATUSANDMASK14 Enumeration

IRD

Lm63TYPIDALERTSTATUSANDMASK14 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUSANDMASK14
Public Enumeration TYPIDALERTSTATUSANDMASK14
public enum class TYPIDALERTSTATUSANDMASK14
type TYPIDALERTSTATUSANDMASK14
Members
Member name | Value | Description
TemperatureOfTheRemoteDiodeIsAtOrBelowTheRemoteHighSetpoint | 0 | Temperature of the Remote Diode is at or below the Remote High Setpoint
TemperatureOfTheRemoteDiodeIsAboveTheRemoteHighSetpoint | 1 | Temperature of the Remote Diode is above the Remote High Setpoint
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDALERTSTATUSANDMASK15 Enumeration

IRD

Lm63TYPIDALERTSTATUSANDMASK15 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUSANDMASK15
Public Enumeration TYPIDALERTSTATUSANDMASK15
public enum class TYPIDALERTSTATUSANDMASK15
type TYPIDALERTSTATUSANDMASK15
Members
Member name | Value | Description
InternalTemperatureOfTheLM63IsAtOrBelowTheLocalHighSetpoint | 0 | Internal temperature of the LM63 is at or below the Local High Setpoint
InternalTemperatureOfTheLM63IsAboveTheLocalHighSetpoint | 1 | Internal temperature of the LM63 is above the Local High Setpoint
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDALERTSTATUSANDMASK16 Enumeration

IRD

Lm63TYPIDALERTSTATUSANDMASK16 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUSANDMASK16
Public Enumeration TYPIDALERTSTATUSANDMASK16
public enum class TYPIDALERTSTATUSANDMASK16
type TYPIDALERTSTATUSANDMASK16
Members
Member name | Value | Description
ADCIsNotConverting | 0 | ADC is not converting
ADCIsPerformingAConversion | 1 | ADC is performing a conversion
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDALERTSTATUSANDMASK20 Enumeration

IRD

Lm63TYPIDALERTSTATUSANDMASK20 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUSANDMASK20
Public Enumeration TYPIDALERTSTATUSANDMASK20
public enum class TYPIDALERTSTATUSANDMASK20
type TYPIDALERTSTATUSANDMASK20
Members
Member name | Value | Description
ALERTGeneratedByThisFlag | 0 | ALERT generated by this flag
ALERTNotGenerateByThisFlag | 1 | ALERT not generate by this flag
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDALERTSTATUSANDMASK21 Enumeration

IRD

Lm63TYPIDALERTSTATUSANDMASK21 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUSANDMASK21
Public Enumeration TYPIDALERTSTATUSANDMASK21
public enum class TYPIDALERTSTATUSANDMASK21
type TYPIDALERTSTATUSANDMASK21
Members
Member name | Value | Description
ALERTGeneratedByThisFlag | 0 | ALERT generated by this flag
ALERTNotGenerateByThisFlag | 1 | ALERT not generate by this flag
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDALERTSTATUSANDMASK22 Enumeration

IRD

Lm63TYPIDALERTSTATUSANDMASK22 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUSANDMASK22
Public Enumeration TYPIDALERTSTATUSANDMASK22
public enum class TYPIDALERTSTATUSANDMASK22
type TYPIDALERTSTATUSANDMASK22
Members
Member name | Value | Description
ALERTGeneratedByThisFlag | 0 | ALERT generated by this flag
ALERTNotGenerateByThisFlag | 1 | ALERT not generate by this flag
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDALERTSTATUSANDMASK23 Enumeration

IRD

Lm63TYPIDALERTSTATUSANDMASK23 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUSANDMASK23
Public Enumeration TYPIDALERTSTATUSANDMASK23
public enum class TYPIDALERTSTATUSANDMASK23
type TYPIDALERTSTATUSANDMASK23
Members
Member name | Value | Description
ALERTGeneratedByThisFlag | 0 | ALERT generated by this flag
ALERTNotGenerateByThisFlag | 1 | ALERT not generate by this flag
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDALERTSTATUSANDMASK24 Enumeration

IRD

Lm63TYPIDALERTSTATUSANDMASK24 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUSANDMASK24
Public Enumeration TYPIDALERTSTATUSANDMASK24
public enum class TYPIDALERTSTATUSANDMASK24
type TYPIDALERTSTATUSANDMASK24
Members
Member name | Value | Description
ALERTGeneratedByThisFlag | 0 | ALERT generated by this flag
ALERTNotGenerateByThisFlag | 1 | ALERT not generate by this flag
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDCONFIGURATIONREGISTER0 Enumeration

IRD

Lm63TYPIDCONFIGURATIONREGISTER0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONREGISTER0
Public Enumeration TYPIDCONFIGURATIONREGISTER0
public enum class TYPIDCONFIGURATIONREGISTER0
type TYPIDCONFIGURATIONREGISTER0
Members
Member name | Value | Description
ALERTIfAnyRemoteDiodeConversionResultAboveBelowTheRemoteHighLowSetPoint | 0 | ALERT if any Remote Diode conversion result above/below the Remote High/Low Set Point
ALERTIfOnlyThreeRemoteDiodeConversionsAreAboveBelowTheRemoteHighLowSetPoint | 1 | ALERT if only three Remote Diode conversions are above/below the Remote High/Low Set Point
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDCONFIGURATIONREGISTER1 Enumeration

IRD

Lm63TYPIDCONFIGURATIONREGISTER1 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONREGISTER1
Public Enumeration TYPIDCONFIGURATIONREGISTER1
public enum class TYPIDCONFIGURATIONREGISTER1
type TYPIDCONFIGURATIONREGISTER1
Members
Member name | Value | Description
TCRITLimitCanBeChangedSeveralTimes | 0 | T_CRIT limit can be changed several times
TCRITLimitCanBeChangedOnceAfterPowerUp | 1 | T_CRIT limit can be changed once after power-up
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDCONFIGURATIONREGISTER2 Enumeration

IRD

Lm63TYPIDCONFIGURATIONREGISTER2 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONREGISTER2
Public Enumeration TYPIDCONFIGURATIONREGISTER2
public enum class TYPIDCONFIGURATIONREGISTER2
type TYPIDCONFIGURATIONREGISTER2
Members
Member name | Value | Description
ALERTTachPinIsAnOpenDrainALERTOutput | 0 | ALERT/Tach pin is an open drain ALERT output
ALERTTachPinIsAHighImpedanceTachometerInput | 1 | ALERT/Tach pin is a high impedance Tachometer input
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDCONFIGURATIONREGISTER3 Enumeration

IRD

Lm63TYPIDCONFIGURATIONREGISTER3 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONREGISTER3
Public Enumeration TYPIDCONFIGURATIONREGISTER3
public enum class TYPIDCONFIGURATIONREGISTER3
type TYPIDCONFIGURATIONREGISTER3
Members
Member name | Value | Description
LM63SPWMOutputContinuesToOutputTheCurrentFanControlSignalWhileInSTANDBY | 0 | LM63's PWM output continues to output the current fan control signal while in STANDBY
PWMOutputIsDisabledAsDefinedByThePWMPolarityBitWhileInSTANDBY | 1 | PWM output is disabled (as defined by the PWM polarity bit) while in STANDBY
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDCONFIGURATIONREGISTER4 Enumeration

IRD

Lm63TYPIDCONFIGURATIONREGISTER4 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONREGISTER4
Public Enumeration TYPIDCONFIGURATIONREGISTER4
public enum class TYPIDCONFIGURATIONREGISTER4
type TYPIDCONFIGURATIONREGISTER4
Members
Member name | Value | Description
LM63IsInOperationalMode | 0 | LM63 is in operational mode
LM63EntersALowPowerStandbyMode | 1 | LM63 enters a low power standby mode
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDCONFIGURATIONREGISTER5 Enumeration

IRD

Lm63TYPIDCONFIGURATIONREGISTER5 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONREGISTER5
Public Enumeration TYPIDCONFIGURATIONREGISTER5
public enum class TYPIDCONFIGURATIONREGISTER5
type TYPIDCONFIGURATIONREGISTER5
Members
Member name | Value | Description
ALERTInterruptsAreEnabled | 0 | ALERT interrupts are enabled
ALERTInterruptsMaskedALERTPinHighImpedanceState | 1 | ALERT interrupts masked/ALERT pin=high impedance state
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDCONVERSIONRATEREGISTER0 Enumeration

IRD

Lm63TYPIDCONVERSIONRATEREGISTER0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONVERSIONRATEREGISTER0
Public Enumeration TYPIDCONVERSIONRATEREGISTER0
public enum class TYPIDCONVERSIONRATEREGISTER0
type TYPIDCONVERSIONRATEREGISTER0
Members
Member name | Value | Description
Value_0_0625 | 0 | 0.0625
Value_0_125 | 1 | 0.125
Value_0_25 | 2 | 0.25
Value_0_5 | 3 | 0.5
Value_1 | 4 | 1
Value_2 | 5 | 2
Value_4 | 6 | 4
Value_8 | 7 | 8
Value_16 | 8 | 16
Value_32 | 9 | 32
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDFANCONTROLREGISTERS10 Enumeration

IRD

Lm63TYPIDFANCONTROLREGISTERS10 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFANCONTROLREGISTERS10
Public Enumeration TYPIDFANCONTROLREGISTERS10
public enum class TYPIDFANCONTROLREGISTERS10
type TYPIDFANCONTROLREGISTERS10
Members
Member name | Value | Description
TraditionalTachInputMonitorFalseReadingsWhenUnderMinimumDetectableRPM | 0 | Traditional tach input monitor, false readings when under minimum detectable RPM
TraditionalTachInputMonitorFFFFReadingWhenUnderMinimumDetectableRPM | 1 | Traditional tach input monitor, FFFF reading when under minimum detectable RPM
MostAccurateReadingsFFFFReadingWhenUnderMinimumDetectableRPM | 2 | Most accurate readings, FFFF reading when under minimum detectable RPM
LeastEffortOnProgrammedPWMOfFanFFFFReadingWhenUnderMinimumDetectableRPM | 3 | Least effort on programmed PWM of fan, FFFF reading when under minimum detectable RPM
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDFANCONTROLREGISTERS11 Enumeration

IRD

Lm63TYPIDFANCONTROLREGISTERS11 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFANCONTROLREGISTERS11
Public Enumeration TYPIDFANCONTROLREGISTERS11
public enum class TYPIDFANCONTROLREGISTERS11
type TYPIDFANCONTROLREGISTERS11
Members
Member name | Value | Description
TheMasterPWMClockIs360KHz | 0 | The master PWM clock is 360 kHz
TheMasterPWMClockIs14KHz | 1 | The master PWM clock is 1.4 kHz
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDFANCONTROLREGISTERS12 Enumeration

IRD

Lm63TYPIDFANCONTROLREGISTERS12 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFANCONTROLREGISTERS12
Public Enumeration TYPIDFANCONTROLREGISTERS12
public enum class TYPIDFANCONTROLREGISTERS12
type TYPIDFANCONTROLREGISTERS12
Members
Member name | Value | Description
ThePWMOutputPinWillBe0VForFanOFFAndOpenForFanON | 0 | The PWM output pin will be 0 V for fan OFF and open for fan ON
ThePWMOutputPinWillBeOpenForFanOFFAnd0VForFanON | 1 | The PWM output pin will be open for fan OFF and 0 V for fan ON
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDFANCONTROLREGISTERS13 Enumeration

IRD

Lm63TYPIDFANCONTROLREGISTERS13 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFANCONTROLREGISTERS13
Public Enumeration TYPIDFANCONTROLREGISTERS13
public enum class TYPIDFANCONTROLREGISTERS13
type TYPIDFANCONTROLREGISTERS13
Members
Member name | Value | Description
PWMValueLookupTableReadOnly | 0 | PWM Value/Lookup Table: read-only
PWMValueLookupTableReadWriteEnabled | 1 | PWM Value/Lookup Table: read/write enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDFANCONTROLREGISTERS20 Enumeration

IRD

Lm63TYPIDFANCONTROLREGISTERS20 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFANCONTROLREGISTERS20
Public Enumeration TYPIDFANCONTROLREGISTERS20
public enum class TYPIDFANCONTROLREGISTERS20
type TYPIDFANCONTROLREGISTERS20
Members
Member name | Value | Description
SpinUpCycleBypassed | 0 | Spin-Up cycle bypassed
Value_005S | 1 | 0.05 s
Value_01S | 2 | 0.1 s
Value_02S | 3 | 0.2 s
Value_04S | 4 | 0.4 s
Value_08S | 5 | 0.8 s
Value_16S | 6 | 1.6 s
Value_32S | 7 | 3.2 s
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDFANCONTROLREGISTERS21 Enumeration

IRD

Lm63TYPIDFANCONTROLREGISTERS21 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFANCONTROLREGISTERS21
Public Enumeration TYPIDFANCONTROLREGISTERS21
public enum class TYPIDFANCONTROLREGISTERS21
type TYPIDFANCONTROLREGISTERS21
Members
Member name | Value | Description
SpinUpCycleBypassed | 0 | Spin-Up cycle bypassed
Value_50 | 1 | 50%
Value_7581DependsOnPWMFrequency | 2 | 75%..81% (Depends on PWM Frequency)
Value_100 | 3 | 100%
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDFANCONTROLREGISTERS22 Enumeration

IRD

Lm63TYPIDFANCONTROLREGISTERS22 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFANCONTROLREGISTERS22
Public Enumeration TYPIDFANCONTROLREGISTERS22
public enum class TYPIDFANCONTROLREGISTERS22
type TYPIDFANCONTROLREGISTERS22
Members
Member name | Value | Description
TheFanSpinUpUsesTheDutyCycleAndSpinUpTime | 0 | The fan spin-up uses the duty cycle and spin-up time
TheLM63SetsThePWMOutputTo100UntilTheSpinUpTimesOut | 1 | The LM63 sets the PWM output to 100% until the spin-up times out
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDFANPWMFREQUENCY0 Enumeration

IRD

Lm63TYPIDFANPWMFREQUENCY0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFANPWMFREQUENCY0
Public Enumeration TYPIDFANPWMFREQUENCY0
public enum class TYPIDFANPWMFREQUENCY0
type TYPIDFANPWMFREQUENCY0
Members
Member name | Value | Description
PWMFrequ36014KHz180000700 | 0 | PWM Frequ=360/1.4 kHz: 180.00/0.700
PWMFrequ36014KHz90000350 | 2 | PWM Frequ=360/1.4 kHz: 90.00/0.350
PWMFrequ36014KHz60000233 | 3 | PWM Frequ=360/1.4 kHz: 60.00/0.233
PWMFrequ36014KHz45000175 | 4 | PWM Frequ=360/1.4 kHz: 45.00/0.175
PWMFrequ36014KHz36000140 | 5 | PWM Frequ=360/1.4 kHz: 36.00/0.140
PWMFrequ36014KHz30000117 | 6 | PWM Frequ=360/1.4 kHz: 30.00/0.117
PWMFrequ36014KHz25710100 | 7 | PWM Frequ=360/1.4 kHz: 25.71/0.100
PWMFrequ36014KHz22500088 | 8 | PWM Frequ=360/1.4 kHz: 22.50/0.088
PWMFrequ36014KHz20000078 | 9 | PWM Frequ=360/1.4 kHz: 20.00/0.078
PWMFrequ36014KHz18000070 | 10 | PWM Frequ=360/1.4 kHz: 18.00/0.070
PWMFrequ36014KHz16360064 | 11 | PWM Frequ=360/1.4 kHz: 16.36/0.064
PWMFrequ36014KHz15000058 | 12 | PWM Frequ=360/1.4 kHz: 15.00/0.058
PWMFrequ36014KHz13850054 | 13 | PWM Frequ=360/1.4 kHz: 13.85/0.054
PWMFrequ36014KHz12860050 | 14 | PWM Frequ=360/1.4 kHz: 12.86/0.050
PWMFrequ36014KHz12000047 | 15 | PWM Frequ=360/1.4 kHz: 12.00/0.047
PWMFrequ36014KHz11250044 | 16 | PWM Frequ=360/1.4 kHz: 11.25/0.044
PWMFrequ36014KHz10590041 | 17 | PWM Frequ=360/1.4 kHz: 10.59/0.041
PWMFrequ36014KHz10000039 | 18 | PWM Frequ=360/1.4 kHz: 10.00/0.039
PWMFrequ36014KHz9470037 | 19 | PWM Frequ=360/1.4 kHz: 9.47/0.037
PWMFrequ36014KHz9000035 | 20 | PWM Frequ=360/1.4 kHz: 9.00/0.035
PWMFrequ36014KHz8570033 | 21 | PWM Frequ=360/1.4 kHz: 8.57/0.033
PWMFrequ36014KHz8180032 | 22 | PWM Frequ=360/1.4 kHz: 8.18/0.032
PWMFrequ36014KHz7830030 | 23 | PWM Frequ=360/1.4 kHz: 7.83/0.030
PWMFrequ36014KHz7500029 | 24 | PWM Frequ=360/1.4 kHz: 7.50/0.029
PWMFrequ36014KHz7200028 | 25 | PWM Frequ=360/1.4 kHz: 7.20/0.028
PWMFrequ36014KHz6920027 | 26 | PWM Frequ=360/1.4 kHz: 6.92/0.027
PWMFrequ36014KHz6670026 | 27 | PWM Frequ=360/1.4 kHz: 6.67/0.026
PWMFrequ36014KHz6430025 | 28 | PWM Frequ=360/1.4 kHz: 6.43/0.025
PWMFrequ36014KHz6210024 | 29 | PWM Frequ=360/1.4 kHz: 6.21/0.024
PWMFrequ36014KHz6000023 | 30 | PWM Frequ=360/1.4 kHz: 6.00/0.023
PWMFrequ36014KHz5810023 | 31 | PWM Frequ=360/1.4 kHz: 5.81/0.023
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDREMOTEDIODETEMPPERATUREFILTER0 Enumeration

IRD

Lm63TYPIDREMOTEDIODETEMPPERATUREFILTER0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDREMOTEDIODETEMPPERATUREFILTER0
Public Enumeration TYPIDREMOTEDIODETEMPPERATUREFILTER0
public enum class TYPIDREMOTEDIODETEMPPERATUREFILTER0
type TYPIDREMOTEDIODETEMPPERATUREFILTER0
Members
Member name | Value | Description
ALERTTachPinFunctionsNormally | 0 | ALERT/Tach pin functions normally
ALERTTachPinBehavesAsAComparator | 1 | ALERT/Tach pin behaves as a comparator
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm63.TYPIDREMOTEDIODETEMPPERATUREFILTER1 Enumeration

IRD

Lm63TYPIDREMOTEDIODETEMPPERATUREFILTER1 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDREMOTEDIODETEMPPERATUREFILTER1
Public Enumeration TYPIDREMOTEDIODETEMPPERATUREFILTER1
public enum class TYPIDREMOTEDIODETEMPPERATUREFILTER1
type TYPIDREMOTEDIODETEMPPERATUREFILTER1
Members
Member name | Value | Description
FilterDisabled | 0 | Filter Disabled
FilterLevel1 | 1 | Filter Level 1
FilterLevel2 | 3 | Filter Level 2
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64 Class

National Semiconductor: LM 64
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm64

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm64
Public Class Lm64
public ref class Lm64
type Lm64 =  class end

The Lm64 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm64 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Busy | Busy
Public property | ComparatorMode | Comparator Mode
Public property | ConfigRegisterALERTMask | Config Register: ALERT Mask
Public property | ConfigRegisterMirrowALERTMask | Config Register (Mirrow): ALERT Mask
Public property | ConfigRegisterMirrowPWMDisableInSTANDBY | Config Register (Mirrow): PWM Disable in STANDBY
Public property | ConfigRegisterMirrowRDTSFaultQueue | Config Register (Mirrow): RDTS Fault Queue
Public property | ConfigRegisterMirrowSTANDBY | Config Register (Mirrow): STANDBY
Public property | ConfigRegisterPWMDisableInSTANDBY | Config Register: PWM Disable in STANDBY
Public property | ConfigRegisterRDTSFaultQueue | Config Register: RDTS Fault Queue
Public property | ConfigRegisterSTANDBY | Config Register: STANDBY
Public property | ConversionRateRegister | Conversion Rate Register
Public property | ConversionRateRegister__1 | Conversion Rate Register_
Public property | FastTachometerSpinUp | Fast Tachometer Spin-Up
Public property | GPI1 | GPI 1
Public property | GPI2 | GPI 2
Public property | GPI3 | GPI 3
Public property | GPI4 | GPI 4
Public property | GPI5 | GPI 5
Public property | GPO1 | GPO 1
Public property | GPO2 | GPO 2
Public property | GPO3 | GPO 3
Public property | GPO4 | GPO 4
Public property | GPO5 | GPO 5
Public property | IDRegisters | ID Registers
Public property | IDRegistersManufacturer | ID Registers (Manufacturer)
Public property | LocalHighAlarm | Local High Alarm
Public property | LocalHighAlarmMask | Local High Alarm Mask
Public property | LocalHighSetpoint | Local High Setpoint
Public property | LocalHighSetpointMirrow | Local High Setpoint (Mirrow)
Public property | LocalTemperatur | Local Temperatur
Public property | LookupTableHysteresis | Lookup Table Hysteresis
Public property | LookupTablePWMEntry1 | Lookup Table PWM entry 1 (unit: °C)
Public property | LookupTablePWMEntry2 | Lookup Table PWM entry 2 (unit: °C)
Public property | LookupTablePWMEntry3 | Lookup Table PWM entry 3 (unit: °C)
Public property | LookupTablePWMEntry4 | Lookup Table PWM entry 4 (unit: °C)
Public property | LookupTablePWMEntry5 | Lookup Table PWM entry 5 (unit: °C)
Public property | LookupTablePWMEntry6 | Lookup Table PWM entry 6 (unit: °C)
Public property | LookupTablePWMEntry7 | Lookup Table PWM entry 7 (unit: °C)
Public property | LookupTablePWMEntry8 | Lookup Table PWM entry 8 (unit: °C)
Public property | LookupTableTemperatureEntry1 | Lookup Table Temperature Entry 1
Public property | LookupTableTemperatureEntry2 | Lookup Table Temperature Entry 2
Public property | LookupTableTemperatureEntry3 | Lookup Table Temperature Entry 3
Public property | LookupTableTemperatureEntry4 | Lookup Table Temperature Entry 4
Public property | LookupTableTemperatureEntry5 | Lookup Table Temperature Entry 5
Public property | LookupTableTemperatureEntry6 | Lookup Table Temperature Entry 6
Public property | LookupTableTemperatureEntry7 | Lookup Table Temperature Entry 7
Public property | LookupTableTemperatureEntry8 | Lookup Table Temperature Entry 8
Public property | OneShotRegister | One-Shot Register
Public property | PWMClockSelect | PWM Clock Select
Public property | PWMFrequency | PWM frequency (unit: kHz)
Public property | PWMOutputPolarity | PWM Output Polarity
Public property | PWMProgram | PWM Program
Public property | PWMSpinUpDutyCycle | PWM Spin-Up Duty Cycle
Public property | PWMSpinUpTime | PWM Spin-Up Time
Public property | PWMValue | PWM Value
Public property | RemoteDiodeFaultAlarm | Remote Diode Fault Alarm
Public property | RemoteDiodeTCRITHysteresis | Remote Diode T_CRIT Hysteresis (unit: °C)
Public property | RemoteDiodeTCRITLimit | Remote Diode T_CRIT Limit (unit: °C)
Public property | RemoteDiodeTemperatureFilter | Remote Diode Temperature Filter
Public property | RemoteDiodeTemperatureReading | Remote Diode Temperature Reading (unit: °C)
Public property | RemoteHighAlarm | Remote High Alarm
Public property | RemoteHighAlarmMask | Remote High Alarm Mask
Public property | RemoteHIGHSetpoint | Remote HIGH Setpoint (unit: °C)
Public property | RemoteHIGHSetpoint__1 | Remote HIGH Setpoint_ (unit: °C)
Public property | RemoteLowAlarm | Remote Low Alarm
Public property | RemoteLowAlarmMask | Remote Low Alarm Mask
Public property | RemoteLOWSetpoint | Remote LOW Setpoint (unit: °C)
Public property | RemoteLOWSetpoint__1 | Remote LOW Setpoint_ (unit: °C)
Public property | RemoteTCRITAlarm | Remote T_CRIT Alarm
Public property | RemoteTCRITAlarmMask | Remote T_CRIT Alarm Mask
Public property | RemoteTemperatureOFFSET | Remote Temperature OFFSET (unit: °C)
Public property | TachAlarm | Tach Alarm
Public property | TachAlarmMask | Tach Alarm Mask
Public property | TachometerCount | Tachometer Count
Public property | TachometerEdgeCount | Tachometer Edge Count
Public property | TachometerLimit | Tachometer Limit
Public property | TachometerMode | Tachometer Mode
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Remote Diode Temperature Sensor with PWM Fan Control and 5 GPIO's
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm64(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm64

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64 Properties

The Lm64 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Busy | Busy
Public property | ComparatorMode | Comparator Mode
Public property | ConfigRegisterALERTMask | Config Register: ALERT Mask
Public property | ConfigRegisterMirrowALERTMask | Config Register (Mirrow): ALERT Mask
Public property | ConfigRegisterMirrowPWMDisableInSTANDBY | Config Register (Mirrow): PWM Disable in STANDBY
Public property | ConfigRegisterMirrowRDTSFaultQueue | Config Register (Mirrow): RDTS Fault Queue
Public property | ConfigRegisterMirrowSTANDBY | Config Register (Mirrow): STANDBY
Public property | ConfigRegisterPWMDisableInSTANDBY | Config Register: PWM Disable in STANDBY
Public property | ConfigRegisterRDTSFaultQueue | Config Register: RDTS Fault Queue
Public property | ConfigRegisterSTANDBY | Config Register: STANDBY
Public property | ConversionRateRegister | Conversion Rate Register
Public property | ConversionRateRegister__1 | Conversion Rate Register_
Public property | FastTachometerSpinUp | Fast Tachometer Spin-Up
Public property | GPI1 | GPI 1
Public property | GPI2 | GPI 2
Public property | GPI3 | GPI 3
Public property | GPI4 | GPI 4
Public property | GPI5 | GPI 5
Public property | GPO1 | GPO 1
Public property | GPO2 | GPO 2
Public property | GPO3 | GPO 3
Public property | GPO4 | GPO 4
Public property | GPO5 | GPO 5
Public property | IDRegisters | ID Registers
Public property | IDRegistersManufacturer | ID Registers (Manufacturer)
Public property | LocalHighAlarm | Local High Alarm
Public property | LocalHighAlarmMask | Local High Alarm Mask
Public property | LocalHighSetpoint | Local High Setpoint
Public property | LocalHighSetpointMirrow | Local High Setpoint (Mirrow)
Public property | LocalTemperatur | Local Temperatur
Public property | LookupTableHysteresis | Lookup Table Hysteresis
Public property | LookupTablePWMEntry1 | Lookup Table PWM entry 1 (unit: °C)
Public property | LookupTablePWMEntry2 | Lookup Table PWM entry 2 (unit: °C)
Public property | LookupTablePWMEntry3 | Lookup Table PWM entry 3 (unit: °C)
Public property | LookupTablePWMEntry4 | Lookup Table PWM entry 4 (unit: °C)
Public property | LookupTablePWMEntry5 | Lookup Table PWM entry 5 (unit: °C)
Public property | LookupTablePWMEntry6 | Lookup Table PWM entry 6 (unit: °C)
Public property | LookupTablePWMEntry7 | Lookup Table PWM entry 7 (unit: °C)
Public property | LookupTablePWMEntry8 | Lookup Table PWM entry 8 (unit: °C)
Public property | LookupTableTemperatureEntry1 | Lookup Table Temperature Entry 1
Public property | LookupTableTemperatureEntry2 | Lookup Table Temperature Entry 2
Public property | LookupTableTemperatureEntry3 | Lookup Table Temperature Entry 3
Public property | LookupTableTemperatureEntry4 | Lookup Table Temperature Entry 4
Public property | LookupTableTemperatureEntry5 | Lookup Table Temperature Entry 5
Public property | LookupTableTemperatureEntry6 | Lookup Table Temperature Entry 6
Public property | LookupTableTemperatureEntry7 | Lookup Table Temperature Entry 7
Public property | LookupTableTemperatureEntry8 | Lookup Table Temperature Entry 8
Public property | OneShotRegister | One-Shot Register
Public property | PWMClockSelect | PWM Clock Select
Public property | PWMFrequency | PWM frequency (unit: kHz)
Public property | PWMOutputPolarity | PWM Output Polarity
Public property | PWMProgram | PWM Program
Public property | PWMSpinUpDutyCycle | PWM Spin-Up Duty Cycle
Public property | PWMSpinUpTime | PWM Spin-Up Time
Public property | PWMValue | PWM Value
Public property | RemoteDiodeFaultAlarm | Remote Diode Fault Alarm
Public property | RemoteDiodeTCRITHysteresis | Remote Diode T_CRIT Hysteresis (unit: °C)
Public property | RemoteDiodeTCRITLimit | Remote Diode T_CRIT Limit (unit: °C)
Public property | RemoteDiodeTemperatureFilter | Remote Diode Temperature Filter
Public property | RemoteDiodeTemperatureReading | Remote Diode Temperature Reading (unit: °C)
Public property | RemoteHighAlarm | Remote High Alarm
Public property | RemoteHighAlarmMask | Remote High Alarm Mask
Public property | RemoteHIGHSetpoint | Remote HIGH Setpoint (unit: °C)
Public property | RemoteHIGHSetpoint__1 | Remote HIGH Setpoint_ (unit: °C)
Public property | RemoteLowAlarm | Remote Low Alarm
Public property | RemoteLowAlarmMask | Remote Low Alarm Mask
Public property | RemoteLOWSetpoint | Remote LOW Setpoint (unit: °C)
Public property | RemoteLOWSetpoint__1 | Remote LOW Setpoint_ (unit: °C)
Public property | RemoteTCRITAlarm | Remote T_CRIT Alarm
Public property | RemoteTCRITAlarmMask | Remote T_CRIT Alarm Mask
Public property | RemoteTemperatureOFFSET | Remote Temperature OFFSET (unit: °C)
Public property | TachAlarm | Tach Alarm
Public property | TachAlarmMask | Tach Alarm Mask
Public property | TachometerCount | Tachometer Count
Public property | TachometerEdgeCount | Tachometer Edge Count
Public property | TachometerLimit | Tachometer Limit
Public property | TachometerMode | Tachometer Mode
Top
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.AutoFlush Property

IRD

Lm64AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.Busy Property

IRD

Lm64Busy Property

Busy

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDALERTSTATUS6 Busy { get; }
Public ReadOnly Property Busy As Lm64TYPIDALERTSTATUS6
    Get
public:
property Lm64TYPIDALERTSTATUS6 Busy {
    Lm64TYPIDALERTSTATUS6 get ();
}
member Busy : Lm64TYPIDALERTSTATUS6 with get

Property Value

Type: Lm64TYPIDALERTSTATUS6
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.ComparatorMode Property

IRD

Lm64ComparatorMode Property

Comparator Mode

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDREMOTEDIODETEMPPERATUREFILTER0 ComparatorMode { get; set; }
Public Property ComparatorMode As Lm64TYPIDREMOTEDIODETEMPPERATUREFILTER0
    Get
    Set
public:
property Lm64TYPIDREMOTEDIODETEMPPERATUREFILTER0 ComparatorMode {
    Lm64TYPIDREMOTEDIODETEMPPERATUREFILTER0 get ();
    void set (Lm64TYPIDREMOTEDIODETEMPPERATUREFILTER0 value);
}
member ComparatorMode : Lm64TYPIDREMOTEDIODETEMPPERATUREFILTER0 with get, set

Property Value

Type: Lm64TYPIDREMOTEDIODETEMPPERATUREFILTER0
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.ConfigRegisterALERTMask Property

IRD

Lm64ConfigRegisterALERTMask Property

Config Register: ALERT Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDCONFIGURATIONREGISTER3 ConfigRegisterALERTMask { get; set; }
Public Property ConfigRegisterALERTMask As Lm64TYPIDCONFIGURATIONREGISTER3
    Get
    Set
public:
property Lm64TYPIDCONFIGURATIONREGISTER3 ConfigRegisterALERTMask {
    Lm64TYPIDCONFIGURATIONREGISTER3 get ();
    void set (Lm64TYPIDCONFIGURATIONREGISTER3 value);
}
member ConfigRegisterALERTMask : Lm64TYPIDCONFIGURATIONREGISTER3 with get, set

Property Value

Type: Lm64TYPIDCONFIGURATIONREGISTER3
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.ConfigRegisterMirrowALERTMask Property

IRD

Lm64ConfigRegisterMirrowALERTMask Property

Config Register (Mirrow): ALERT Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDCONFIGURATIONREGISTER3 ConfigRegisterMirrowALERTMask { get; set; }
Public Property ConfigRegisterMirrowALERTMask As Lm64TYPIDCONFIGURATIONREGISTER3
    Get
    Set
public:
property Lm64TYPIDCONFIGURATIONREGISTER3 ConfigRegisterMirrowALERTMask {
    Lm64TYPIDCONFIGURATIONREGISTER3 get ();
    void set (Lm64TYPIDCONFIGURATIONREGISTER3 value);
}
member ConfigRegisterMirrowALERTMask : Lm64TYPIDCONFIGURATIONREGISTER3 with get, set

Property Value

Type: Lm64TYPIDCONFIGURATIONREGISTER3
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.ConfigRegisterMirrowPWMDisableInSTANDBY Property

IRD

Lm64ConfigRegisterMirrowPWMDisableInSTANDBY Property

Config Register (Mirrow): PWM Disable in STANDBY

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDCONFIGURATIONREGISTER1 ConfigRegisterMirrowPWMDisableInSTANDBY { get; set; }
Public Property ConfigRegisterMirrowPWMDisableInSTANDBY As Lm64TYPIDCONFIGURATIONREGISTER1
    Get
    Set
public:
property Lm64TYPIDCONFIGURATIONREGISTER1 ConfigRegisterMirrowPWMDisableInSTANDBY {
    Lm64TYPIDCONFIGURATIONREGISTER1 get ();
    void set (Lm64TYPIDCONFIGURATIONREGISTER1 value);
}
member ConfigRegisterMirrowPWMDisableInSTANDBY : Lm64TYPIDCONFIGURATIONREGISTER1 with get, set

Property Value

Type: Lm64TYPIDCONFIGURATIONREGISTER1
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.ConfigRegisterMirrowRDTSFaultQueue Property

IRD

Lm64ConfigRegisterMirrowRDTSFaultQueue Property

Config Register (Mirrow): RDTS Fault Queue

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDCONFIGURATIONREGISTER0 ConfigRegisterMirrowRDTSFaultQueue { get; set; }
Public Property ConfigRegisterMirrowRDTSFaultQueue As Lm64TYPIDCONFIGURATIONREGISTER0
    Get
    Set
public:
property Lm64TYPIDCONFIGURATIONREGISTER0 ConfigRegisterMirrowRDTSFaultQueue {
    Lm64TYPIDCONFIGURATIONREGISTER0 get ();
    void set (Lm64TYPIDCONFIGURATIONREGISTER0 value);
}
member ConfigRegisterMirrowRDTSFaultQueue : Lm64TYPIDCONFIGURATIONREGISTER0 with get, set

Property Value

Type: Lm64TYPIDCONFIGURATIONREGISTER0
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.ConfigRegisterMirrowSTANDBY Property

IRD

Lm64ConfigRegisterMirrowSTANDBY Property

Config Register (Mirrow): STANDBY

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDCONFIGURATIONREGISTER2 ConfigRegisterMirrowSTANDBY { get; set; }
Public Property ConfigRegisterMirrowSTANDBY As Lm64TYPIDCONFIGURATIONREGISTER2
    Get
    Set
public:
property Lm64TYPIDCONFIGURATIONREGISTER2 ConfigRegisterMirrowSTANDBY {
    Lm64TYPIDCONFIGURATIONREGISTER2 get ();
    void set (Lm64TYPIDCONFIGURATIONREGISTER2 value);
}
member ConfigRegisterMirrowSTANDBY : Lm64TYPIDCONFIGURATIONREGISTER2 with get, set

Property Value

Type: Lm64TYPIDCONFIGURATIONREGISTER2
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.ConfigRegisterPWMDisableInSTANDBY Property

IRD

Lm64ConfigRegisterPWMDisableInSTANDBY Property

Config Register: PWM Disable in STANDBY

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDCONFIGURATIONREGISTER1 ConfigRegisterPWMDisableInSTANDBY { get; set; }
Public Property ConfigRegisterPWMDisableInSTANDBY As Lm64TYPIDCONFIGURATIONREGISTER1
    Get
    Set
public:
property Lm64TYPIDCONFIGURATIONREGISTER1 ConfigRegisterPWMDisableInSTANDBY {
    Lm64TYPIDCONFIGURATIONREGISTER1 get ();
    void set (Lm64TYPIDCONFIGURATIONREGISTER1 value);
}
member ConfigRegisterPWMDisableInSTANDBY : Lm64TYPIDCONFIGURATIONREGISTER1 with get, set

Property Value

Type: Lm64TYPIDCONFIGURATIONREGISTER1
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.ConfigRegisterRDTSFaultQueue Property

IRD

Lm64ConfigRegisterRDTSFaultQueue Property

Config Register: RDTS Fault Queue

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDCONFIGURATIONREGISTER0 ConfigRegisterRDTSFaultQueue { get; set; }
Public Property ConfigRegisterRDTSFaultQueue As Lm64TYPIDCONFIGURATIONREGISTER0
    Get
    Set
public:
property Lm64TYPIDCONFIGURATIONREGISTER0 ConfigRegisterRDTSFaultQueue {
    Lm64TYPIDCONFIGURATIONREGISTER0 get ();
    void set (Lm64TYPIDCONFIGURATIONREGISTER0 value);
}
member ConfigRegisterRDTSFaultQueue : Lm64TYPIDCONFIGURATIONREGISTER0 with get, set

Property Value

Type: Lm64TYPIDCONFIGURATIONREGISTER0
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.ConfigRegisterSTANDBY Property

IRD

Lm64ConfigRegisterSTANDBY Property

Config Register: STANDBY

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDCONFIGURATIONREGISTER2 ConfigRegisterSTANDBY { get; set; }
Public Property ConfigRegisterSTANDBY As Lm64TYPIDCONFIGURATIONREGISTER2
    Get
    Set
public:
property Lm64TYPIDCONFIGURATIONREGISTER2 ConfigRegisterSTANDBY {
    Lm64TYPIDCONFIGURATIONREGISTER2 get ();
    void set (Lm64TYPIDCONFIGURATIONREGISTER2 value);
}
member ConfigRegisterSTANDBY : Lm64TYPIDCONFIGURATIONREGISTER2 with get, set

Property Value

Type: Lm64TYPIDCONFIGURATIONREGISTER2
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.ConversionRateRegister Property

IRD

Lm64ConversionRateRegister Property

Conversion Rate Register

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDCONVERSIONRATEREGISTER0 ConversionRateRegister { get; set; }
Public Property ConversionRateRegister As Lm64TYPIDCONVERSIONRATEREGISTER0
    Get
    Set
public:
property Lm64TYPIDCONVERSIONRATEREGISTER0 ConversionRateRegister {
    Lm64TYPIDCONVERSIONRATEREGISTER0 get ();
    void set (Lm64TYPIDCONVERSIONRATEREGISTER0 value);
}
member ConversionRateRegister : Lm64TYPIDCONVERSIONRATEREGISTER0 with get, set

Property Value

Type: Lm64TYPIDCONVERSIONRATEREGISTER0
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.ConversionRateRegister__1 Property

IRD

Lm64ConversionRateRegister__1 Property

Conversion Rate Register_

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDCONVERSIONRATEREGISTER0 ConversionRateRegister__1 { get; set; }
Public Property ConversionRateRegister__1 As Lm64TYPIDCONVERSIONRATEREGISTER0
    Get
    Set
public:
property Lm64TYPIDCONVERSIONRATEREGISTER0 ConversionRateRegister__1 {
    Lm64TYPIDCONVERSIONRATEREGISTER0 get ();
    void set (Lm64TYPIDCONVERSIONRATEREGISTER0 value);
}
member ConversionRateRegister__1 : Lm64TYPIDCONVERSIONRATEREGISTER0 with get, set

Property Value

Type: Lm64TYPIDCONVERSIONRATEREGISTER0
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.FastTachometerSpinUp Property

IRD

Lm64FastTachometerSpinUp Property

Fast Tachometer Spin-Up

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDFANSPINUPCONFIRATIONREGISTER2 FastTachometerSpinUp { get; set; }
Public Property FastTachometerSpinUp As Lm64TYPIDFANSPINUPCONFIRATIONREGISTER2
    Get
    Set
public:
property Lm64TYPIDFANSPINUPCONFIRATIONREGISTER2 FastTachometerSpinUp {
    Lm64TYPIDFANSPINUPCONFIRATIONREGISTER2 get ();
    void set (Lm64TYPIDFANSPINUPCONFIRATIONREGISTER2 value);
}
member FastTachometerSpinUp : Lm64TYPIDFANSPINUPCONFIRATIONREGISTER2 with get, set

Property Value

Type: Lm64TYPIDFANSPINUPCONFIRATIONREGISTER2
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.GPI1 Property

IRD

Lm64GPI1 Property

GPI 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPI1 { get; }
Public ReadOnly Property GPI1 As Byte
    Get
public:
property unsigned char GPI1 {
    unsigned char get ();
}
member GPI1 : byte with get

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.GPI2 Property

IRD

Lm64GPI2 Property

GPI 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPI2 { get; }
Public ReadOnly Property GPI2 As Byte
    Get
public:
property unsigned char GPI2 {
    unsigned char get ();
}
member GPI2 : byte with get

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.GPI3 Property

IRD

Lm64GPI3 Property

GPI 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPI3 { get; }
Public ReadOnly Property GPI3 As Byte
    Get
public:
property unsigned char GPI3 {
    unsigned char get ();
}
member GPI3 : byte with get

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.GPI4 Property

IRD

Lm64GPI4 Property

GPI 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPI4 { get; }
Public ReadOnly Property GPI4 As Byte
    Get
public:
property unsigned char GPI4 {
    unsigned char get ();
}
member GPI4 : byte with get

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.GPI5 Property

IRD

Lm64GPI5 Property

GPI 5

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPI5 { get; }
Public ReadOnly Property GPI5 As Byte
    Get
public:
property unsigned char GPI5 {
    unsigned char get ();
}
member GPI5 : byte with get

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.GPO1 Property

IRD

Lm64GPO1 Property

GPO 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPO1 { get; set; }
Public Property GPO1 As Byte
    Get
    Set
public:
property unsigned char GPO1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPO1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.GPO2 Property

IRD

Lm64GPO2 Property

GPO 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPO2 { get; set; }
Public Property GPO2 As Byte
    Get
    Set
public:
property unsigned char GPO2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPO2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.GPO3 Property

IRD

Lm64GPO3 Property

GPO 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPO3 { get; set; }
Public Property GPO3 As Byte
    Get
    Set
public:
property unsigned char GPO3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPO3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.GPO4 Property

IRD

Lm64GPO4 Property

GPO 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPO4 { get; set; }
Public Property GPO4 As Byte
    Get
    Set
public:
property unsigned char GPO4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPO4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.GPO5 Property

IRD

Lm64GPO5 Property

GPO 5

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPO5 { get; set; }
Public Property GPO5 As Byte
    Get
    Set
public:
property unsigned char GPO5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPO5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.IDRegisters Property

IRD

Lm64IDRegisters Property

ID Registers

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IDRegisters { get; }
Public ReadOnly Property IDRegisters As Byte
    Get
public:
property unsigned char IDRegisters {
    unsigned char get ();
}
member IDRegisters : byte with get

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.IDRegistersManufacturer Property

IRD

Lm64IDRegistersManufacturer Property

ID Registers (Manufacturer)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IDRegistersManufacturer { get; }
Public ReadOnly Property IDRegistersManufacturer As Byte
    Get
public:
property unsigned char IDRegistersManufacturer {
    unsigned char get ();
}
member IDRegistersManufacturer : byte with get

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LocalHighAlarm Property

IRD

Lm64LocalHighAlarm Property

Local High Alarm

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDALERTSTATUS5 LocalHighAlarm { get; }
Public ReadOnly Property LocalHighAlarm As Lm64TYPIDALERTSTATUS5
    Get
public:
property Lm64TYPIDALERTSTATUS5 LocalHighAlarm {
    Lm64TYPIDALERTSTATUS5 get ();
}
member LocalHighAlarm : Lm64TYPIDALERTSTATUS5 with get

Property Value

Type: Lm64TYPIDALERTSTATUS5
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LocalHighAlarmMask Property

IRD

Lm64LocalHighAlarmMask Property

Local High Alarm Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDALERTMASK4 LocalHighAlarmMask { get; set; }
Public Property LocalHighAlarmMask As Lm64TYPIDALERTMASK4
    Get
    Set
public:
property Lm64TYPIDALERTMASK4 LocalHighAlarmMask {
    Lm64TYPIDALERTMASK4 get ();
    void set (Lm64TYPIDALERTMASK4 value);
}
member LocalHighAlarmMask : Lm64TYPIDALERTMASK4 with get, set

Property Value

Type: Lm64TYPIDALERTMASK4
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LocalHighSetpoint Property

IRD

Lm64LocalHighSetpoint Property

Local High Setpoint

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalHighSetpoint { get; set; }
Public Property LocalHighSetpoint As SByte
    Get
    Set
public:
property signed char LocalHighSetpoint {
    signed char get ();
    void set (signed char value);
}
member LocalHighSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LocalHighSetpointMirrow Property

IRD

Lm64LocalHighSetpointMirrow Property

Local High Setpoint (Mirrow)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalHighSetpointMirrow { set; }
Public WriteOnly Property LocalHighSetpointMirrow As SByte
    Set
public:
property signed char LocalHighSetpointMirrow {
    void set (signed char value);
}
member LocalHighSetpointMirrow : sbyte with set

Property Value

Type: SByte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LocalTemperatur Property

IRD

Lm64LocalTemperatur Property

Local Temperatur

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalTemperatur { get; }
Public ReadOnly Property LocalTemperatur As Byte
    Get
public:
property unsigned char LocalTemperatur {
    unsigned char get ();
}
member LocalTemperatur : byte with get

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LookupTableHysteresis Property

IRD

Lm64LookupTableHysteresis Property

Lookup Table Hysteresis

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTableHysteresis { get; set; }
Public Property LookupTableHysteresis As Byte
    Get
    Set
public:
property unsigned char LookupTableHysteresis {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTableHysteresis : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LookupTablePWMEntry1 Property

IRD

Lm64LookupTablePWMEntry1 Property

Lookup Table PWM entry 1 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTablePWMEntry1 { get; set; }
Public Property LookupTablePWMEntry1 As Byte
    Get
    Set
public:
property unsigned char LookupTablePWMEntry1 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTablePWMEntry1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LookupTablePWMEntry2 Property

IRD

Lm64LookupTablePWMEntry2 Property

Lookup Table PWM entry 2 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTablePWMEntry2 { get; set; }
Public Property LookupTablePWMEntry2 As Byte
    Get
    Set
public:
property unsigned char LookupTablePWMEntry2 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTablePWMEntry2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LookupTablePWMEntry3 Property

IRD

Lm64LookupTablePWMEntry3 Property

Lookup Table PWM entry 3 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTablePWMEntry3 { get; set; }
Public Property LookupTablePWMEntry3 As Byte
    Get
    Set
public:
property unsigned char LookupTablePWMEntry3 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTablePWMEntry3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LookupTablePWMEntry4 Property

IRD

Lm64LookupTablePWMEntry4 Property

Lookup Table PWM entry 4 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTablePWMEntry4 { get; set; }
Public Property LookupTablePWMEntry4 As Byte
    Get
    Set
public:
property unsigned char LookupTablePWMEntry4 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTablePWMEntry4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LookupTablePWMEntry5 Property

IRD

Lm64LookupTablePWMEntry5 Property

Lookup Table PWM entry 5 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTablePWMEntry5 { get; set; }
Public Property LookupTablePWMEntry5 As Byte
    Get
    Set
public:
property unsigned char LookupTablePWMEntry5 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTablePWMEntry5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LookupTablePWMEntry6 Property

IRD

Lm64LookupTablePWMEntry6 Property

Lookup Table PWM entry 6 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTablePWMEntry6 { get; set; }
Public Property LookupTablePWMEntry6 As Byte
    Get
    Set
public:
property unsigned char LookupTablePWMEntry6 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTablePWMEntry6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LookupTablePWMEntry7 Property

IRD

Lm64LookupTablePWMEntry7 Property

Lookup Table PWM entry 7 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTablePWMEntry7 { get; set; }
Public Property LookupTablePWMEntry7 As Byte
    Get
    Set
public:
property unsigned char LookupTablePWMEntry7 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTablePWMEntry7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LookupTablePWMEntry8 Property

IRD

Lm64LookupTablePWMEntry8 Property

Lookup Table PWM entry 8 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTablePWMEntry8 { get; set; }
Public Property LookupTablePWMEntry8 As Byte
    Get
    Set
public:
property unsigned char LookupTablePWMEntry8 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTablePWMEntry8 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LookupTableTemperatureEntry1 Property

IRD

Lm64LookupTableTemperatureEntry1 Property

Lookup Table Temperature Entry 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTableTemperatureEntry1 { get; set; }
Public Property LookupTableTemperatureEntry1 As Byte
    Get
    Set
public:
property unsigned char LookupTableTemperatureEntry1 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTableTemperatureEntry1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LookupTableTemperatureEntry2 Property

IRD

Lm64LookupTableTemperatureEntry2 Property

Lookup Table Temperature Entry 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTableTemperatureEntry2 { get; set; }
Public Property LookupTableTemperatureEntry2 As Byte
    Get
    Set
public:
property unsigned char LookupTableTemperatureEntry2 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTableTemperatureEntry2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LookupTableTemperatureEntry3 Property

IRD

Lm64LookupTableTemperatureEntry3 Property

Lookup Table Temperature Entry 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTableTemperatureEntry3 { get; set; }
Public Property LookupTableTemperatureEntry3 As Byte
    Get
    Set
public:
property unsigned char LookupTableTemperatureEntry3 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTableTemperatureEntry3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LookupTableTemperatureEntry4 Property

IRD

Lm64LookupTableTemperatureEntry4 Property

Lookup Table Temperature Entry 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTableTemperatureEntry4 { get; set; }
Public Property LookupTableTemperatureEntry4 As Byte
    Get
    Set
public:
property unsigned char LookupTableTemperatureEntry4 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTableTemperatureEntry4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LookupTableTemperatureEntry5 Property

IRD

Lm64LookupTableTemperatureEntry5 Property

Lookup Table Temperature Entry 5

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTableTemperatureEntry5 { get; set; }
Public Property LookupTableTemperatureEntry5 As Byte
    Get
    Set
public:
property unsigned char LookupTableTemperatureEntry5 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTableTemperatureEntry5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LookupTableTemperatureEntry6 Property

IRD

Lm64LookupTableTemperatureEntry6 Property

Lookup Table Temperature Entry 6

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTableTemperatureEntry6 { get; set; }
Public Property LookupTableTemperatureEntry6 As Byte
    Get
    Set
public:
property unsigned char LookupTableTemperatureEntry6 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTableTemperatureEntry6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LookupTableTemperatureEntry7 Property

IRD

Lm64LookupTableTemperatureEntry7 Property

Lookup Table Temperature Entry 7

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTableTemperatureEntry7 { get; set; }
Public Property LookupTableTemperatureEntry7 As Byte
    Get
    Set
public:
property unsigned char LookupTableTemperatureEntry7 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTableTemperatureEntry7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.LookupTableTemperatureEntry8 Property

IRD

Lm64LookupTableTemperatureEntry8 Property

Lookup Table Temperature Entry 8

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LookupTableTemperatureEntry8 { get; set; }
Public Property LookupTableTemperatureEntry8 As Byte
    Get
    Set
public:
property unsigned char LookupTableTemperatureEntry8 {
    unsigned char get ();
    void set (unsigned char value);
}
member LookupTableTemperatureEntry8 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.OneShotRegister Property

IRD

Lm64OneShotRegister Property

One-Shot Register

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OneShotRegister { set; }
Public WriteOnly Property OneShotRegister As Byte
    Set
public:
property unsigned char OneShotRegister {
    void set (unsigned char value);
}
member OneShotRegister : byte with set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.PWMClockSelect Property

IRD

Lm64PWMClockSelect Property

PWM Clock Select

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDPWMANDRPMREGISTER1 PWMClockSelect { get; set; }
Public Property PWMClockSelect As Lm64TYPIDPWMANDRPMREGISTER1
    Get
    Set
public:
property Lm64TYPIDPWMANDRPMREGISTER1 PWMClockSelect {
    Lm64TYPIDPWMANDRPMREGISTER1 get ();
    void set (Lm64TYPIDPWMANDRPMREGISTER1 value);
}
member PWMClockSelect : Lm64TYPIDPWMANDRPMREGISTER1 with get, set

Property Value

Type: Lm64TYPIDPWMANDRPMREGISTER1
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.PWMFrequency Property

IRD

Lm64PWMFrequency Property

PWM frequency (unit: kHz)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDFANPWMFREQUENCY0 PWMFrequency { get; set; }
Public Property PWMFrequency As Lm64TYPIDFANPWMFREQUENCY0
    Get
    Set
public:
property Lm64TYPIDFANPWMFREQUENCY0 PWMFrequency {
    Lm64TYPIDFANPWMFREQUENCY0 get ();
    void set (Lm64TYPIDFANPWMFREQUENCY0 value);
}
member PWMFrequency : Lm64TYPIDFANPWMFREQUENCY0 with get, set

Property Value

Type: Lm64TYPIDFANPWMFREQUENCY0
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.PWMOutputPolarity Property

IRD

Lm64PWMOutputPolarity Property

PWM Output Polarity

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDPWMANDRPMREGISTER2 PWMOutputPolarity { get; set; }
Public Property PWMOutputPolarity As Lm64TYPIDPWMANDRPMREGISTER2
    Get
    Set
public:
property Lm64TYPIDPWMANDRPMREGISTER2 PWMOutputPolarity {
    Lm64TYPIDPWMANDRPMREGISTER2 get ();
    void set (Lm64TYPIDPWMANDRPMREGISTER2 value);
}
member PWMOutputPolarity : Lm64TYPIDPWMANDRPMREGISTER2 with get, set

Property Value

Type: Lm64TYPIDPWMANDRPMREGISTER2
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.PWMProgram Property

IRD

Lm64PWMProgram Property

PWM Program

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDPWMANDRPMREGISTER3 PWMProgram { get; set; }
Public Property PWMProgram As Lm64TYPIDPWMANDRPMREGISTER3
    Get
    Set
public:
property Lm64TYPIDPWMANDRPMREGISTER3 PWMProgram {
    Lm64TYPIDPWMANDRPMREGISTER3 get ();
    void set (Lm64TYPIDPWMANDRPMREGISTER3 value);
}
member PWMProgram : Lm64TYPIDPWMANDRPMREGISTER3 with get, set

Property Value

Type: Lm64TYPIDPWMANDRPMREGISTER3
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.PWMSpinUpDutyCycle Property

IRD

Lm64PWMSpinUpDutyCycle Property

PWM Spin-Up Duty Cycle

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDFANSPINUPCONFIRATIONREGISTER1 PWMSpinUpDutyCycle { get; set; }
Public Property PWMSpinUpDutyCycle As Lm64TYPIDFANSPINUPCONFIRATIONREGISTER1
    Get
    Set
public:
property Lm64TYPIDFANSPINUPCONFIRATIONREGISTER1 PWMSpinUpDutyCycle {
    Lm64TYPIDFANSPINUPCONFIRATIONREGISTER1 get ();
    void set (Lm64TYPIDFANSPINUPCONFIRATIONREGISTER1 value);
}
member PWMSpinUpDutyCycle : Lm64TYPIDFANSPINUPCONFIRATIONREGISTER1 with get, set

Property Value

Type: Lm64TYPIDFANSPINUPCONFIRATIONREGISTER1
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.PWMSpinUpTime Property

IRD

Lm64PWMSpinUpTime Property

PWM Spin-Up Time

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDFANSPINUPCONFIRATIONREGISTER0 PWMSpinUpTime { get; set; }
Public Property PWMSpinUpTime As Lm64TYPIDFANSPINUPCONFIRATIONREGISTER0
    Get
    Set
public:
property Lm64TYPIDFANSPINUPCONFIRATIONREGISTER0 PWMSpinUpTime {
    Lm64TYPIDFANSPINUPCONFIRATIONREGISTER0 get ();
    void set (Lm64TYPIDFANSPINUPCONFIRATIONREGISTER0 value);
}
member PWMSpinUpTime : Lm64TYPIDFANSPINUPCONFIRATIONREGISTER0 with get, set

Property Value

Type: Lm64TYPIDFANSPINUPCONFIRATIONREGISTER0
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.PWMValue Property

IRD

Lm64PWMValue Property

PWM Value

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWMValue { get; set; }
Public Property PWMValue As Byte
    Get
    Set
public:
property unsigned char PWMValue {
    unsigned char get ();
    void set (unsigned char value);
}
member PWMValue : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.RemoteDiodeFaultAlarm Property

IRD

Lm64RemoteDiodeFaultAlarm Property

Remote Diode Fault Alarm

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDALERTSTATUS2 RemoteDiodeFaultAlarm { get; }
Public ReadOnly Property RemoteDiodeFaultAlarm As Lm64TYPIDALERTSTATUS2
    Get
public:
property Lm64TYPIDALERTSTATUS2 RemoteDiodeFaultAlarm {
    Lm64TYPIDALERTSTATUS2 get ();
}
member RemoteDiodeFaultAlarm : Lm64TYPIDALERTSTATUS2 with get

Property Value

Type: Lm64TYPIDALERTSTATUS2
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.RemoteDiodeTCRITHysteresis Property

IRD

Lm64RemoteDiodeTCRITHysteresis Property

Remote Diode T_CRIT Hysteresis (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteDiodeTCRITHysteresis { get; set; }
Public Property RemoteDiodeTCRITHysteresis As SByte
    Get
    Set
public:
property signed char RemoteDiodeTCRITHysteresis {
    signed char get ();
    void set (signed char value);
}
member RemoteDiodeTCRITHysteresis : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.RemoteDiodeTCRITLimit Property

IRD

Lm64RemoteDiodeTCRITLimit Property

Remote Diode T_CRIT Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteDiodeTCRITLimit { get; set; }
Public Property RemoteDiodeTCRITLimit As SByte
    Get
    Set
public:
property signed char RemoteDiodeTCRITLimit {
    signed char get ();
    void set (signed char value);
}
member RemoteDiodeTCRITLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.RemoteDiodeTemperatureFilter Property

IRD

Lm64RemoteDiodeTemperatureFilter Property

Remote Diode Temperature Filter

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDREMOTEDIODETEMPPERATUREFILTER1 RemoteDiodeTemperatureFilter { get; set; }
Public Property RemoteDiodeTemperatureFilter As Lm64TYPIDREMOTEDIODETEMPPERATUREFILTER1
    Get
    Set
public:
property Lm64TYPIDREMOTEDIODETEMPPERATUREFILTER1 RemoteDiodeTemperatureFilter {
    Lm64TYPIDREMOTEDIODETEMPPERATUREFILTER1 get ();
    void set (Lm64TYPIDREMOTEDIODETEMPPERATUREFILTER1 value);
}
member RemoteDiodeTemperatureFilter : Lm64TYPIDREMOTEDIODETEMPPERATUREFILTER1 with get, set

Property Value

Type: Lm64TYPIDREMOTEDIODETEMPPERATUREFILTER1
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.RemoteDiodeTemperatureReading Property

IRD

Lm64RemoteDiodeTemperatureReading Property

Remote Diode Temperature Reading (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteDiodeTemperatureReading { get; }
Public ReadOnly Property RemoteDiodeTemperatureReading As Double
    Get
public:
property double RemoteDiodeTemperatureReading {
    double get ();
}
member RemoteDiodeTemperatureReading : float with get

Property Value

Type: Double
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.RemoteHighAlarm Property

IRD

Lm64RemoteHighAlarm Property

Remote High Alarm

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDALERTSTATUS4 RemoteHighAlarm { get; }
Public ReadOnly Property RemoteHighAlarm As Lm64TYPIDALERTSTATUS4
    Get
public:
property Lm64TYPIDALERTSTATUS4 RemoteHighAlarm {
    Lm64TYPIDALERTSTATUS4 get ();
}
member RemoteHighAlarm : Lm64TYPIDALERTSTATUS4 with get

Property Value

Type: Lm64TYPIDALERTSTATUS4
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.RemoteHighAlarmMask Property

IRD

Lm64RemoteHighAlarmMask Property

Remote High Alarm Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDALERTMASK3 RemoteHighAlarmMask { get; set; }
Public Property RemoteHighAlarmMask As Lm64TYPIDALERTMASK3
    Get
    Set
public:
property Lm64TYPIDALERTMASK3 RemoteHighAlarmMask {
    Lm64TYPIDALERTMASK3 get ();
    void set (Lm64TYPIDALERTMASK3 value);
}
member RemoteHighAlarmMask : Lm64TYPIDALERTMASK3 with get, set

Property Value

Type: Lm64TYPIDALERTMASK3
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.RemoteHIGHSetpoint Property

IRD

Lm64RemoteHIGHSetpoint Property

Remote HIGH Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteHIGHSetpoint { get; }
Public ReadOnly Property RemoteHIGHSetpoint As Double
    Get
public:
property double RemoteHIGHSetpoint {
    double get ();
}
member RemoteHIGHSetpoint : float with get

Property Value

Type: Double
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.RemoteHIGHSetpoint__1 Property

IRD

Lm64RemoteHIGHSetpoint__1 Property

Remote HIGH Setpoint_ (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteHIGHSetpoint__1 { set; }
Public WriteOnly Property RemoteHIGHSetpoint__1 As Double
    Set
public:
property double RemoteHIGHSetpoint__1 {
    void set (double value);
}
member RemoteHIGHSetpoint__1 : float with set

Property Value

Type: Double
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.RemoteLowAlarm Property

IRD

Lm64RemoteLowAlarm Property

Remote Low Alarm

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDALERTSTATUS3 RemoteLowAlarm { get; }
Public ReadOnly Property RemoteLowAlarm As Lm64TYPIDALERTSTATUS3
    Get
public:
property Lm64TYPIDALERTSTATUS3 RemoteLowAlarm {
    Lm64TYPIDALERTSTATUS3 get ();
}
member RemoteLowAlarm : Lm64TYPIDALERTSTATUS3 with get

Property Value

Type: Lm64TYPIDALERTSTATUS3
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.RemoteLowAlarmMask Property

IRD

Lm64RemoteLowAlarmMask Property

Remote Low Alarm Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDALERTMASK2 RemoteLowAlarmMask { get; set; }
Public Property RemoteLowAlarmMask As Lm64TYPIDALERTMASK2
    Get
    Set
public:
property Lm64TYPIDALERTMASK2 RemoteLowAlarmMask {
    Lm64TYPIDALERTMASK2 get ();
    void set (Lm64TYPIDALERTMASK2 value);
}
member RemoteLowAlarmMask : Lm64TYPIDALERTMASK2 with get, set

Property Value

Type: Lm64TYPIDALERTMASK2
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.RemoteLOWSetpoint Property

IRD

Lm64RemoteLOWSetpoint Property

Remote LOW Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteLOWSetpoint { get; }
Public ReadOnly Property RemoteLOWSetpoint As Double
    Get
public:
property double RemoteLOWSetpoint {
    double get ();
}
member RemoteLOWSetpoint : float with get

Property Value

Type: Double
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.RemoteLOWSetpoint__1 Property

IRD

Lm64RemoteLOWSetpoint__1 Property

Remote LOW Setpoint_ (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteLOWSetpoint__1 { set; }
Public WriteOnly Property RemoteLOWSetpoint__1 As Double
    Set
public:
property double RemoteLOWSetpoint__1 {
    void set (double value);
}
member RemoteLOWSetpoint__1 : float with set

Property Value

Type: Double
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.RemoteTCRITAlarm Property

IRD

Lm64RemoteTCRITAlarm Property

Remote T_CRIT Alarm

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDALERTSTATUS1 RemoteTCRITAlarm { get; }
Public ReadOnly Property RemoteTCRITAlarm As Lm64TYPIDALERTSTATUS1
    Get
public:
property Lm64TYPIDALERTSTATUS1 RemoteTCRITAlarm {
    Lm64TYPIDALERTSTATUS1 get ();
}
member RemoteTCRITAlarm : Lm64TYPIDALERTSTATUS1 with get

Property Value

Type: Lm64TYPIDALERTSTATUS1
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.RemoteTCRITAlarmMask Property

IRD

Lm64RemoteTCRITAlarmMask Property

Remote T_CRIT Alarm Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDALERTMASK1 RemoteTCRITAlarmMask { get; set; }
Public Property RemoteTCRITAlarmMask As Lm64TYPIDALERTMASK1
    Get
    Set
public:
property Lm64TYPIDALERTMASK1 RemoteTCRITAlarmMask {
    Lm64TYPIDALERTMASK1 get ();
    void set (Lm64TYPIDALERTMASK1 value);
}
member RemoteTCRITAlarmMask : Lm64TYPIDALERTMASK1 with get, set

Property Value

Type: Lm64TYPIDALERTMASK1
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.RemoteTemperatureOFFSET Property

IRD

Lm64RemoteTemperatureOFFSET Property

Remote Temperature OFFSET (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperatureOFFSET { get; set; }
Public Property RemoteTemperatureOFFSET As Double
    Get
    Set
public:
property double RemoteTemperatureOFFSET {
    double get ();
    void set (double value);
}
member RemoteTemperatureOFFSET : float with get, set

Property Value

Type: Double
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.TachAlarm Property

IRD

Lm64TachAlarm Property

Tach Alarm

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDALERTSTATUS0 TachAlarm { get; }
Public ReadOnly Property TachAlarm As Lm64TYPIDALERTSTATUS0
    Get
public:
property Lm64TYPIDALERTSTATUS0 TachAlarm {
    Lm64TYPIDALERTSTATUS0 get ();
}
member TachAlarm : Lm64TYPIDALERTSTATUS0 with get

Property Value

Type: Lm64TYPIDALERTSTATUS0
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.TachAlarmMask Property

IRD

Lm64TachAlarmMask Property

Tach Alarm Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDALERTMASK0 TachAlarmMask { get; set; }
Public Property TachAlarmMask As Lm64TYPIDALERTMASK0
    Get
    Set
public:
property Lm64TYPIDALERTMASK0 TachAlarmMask {
    Lm64TYPIDALERTMASK0 get ();
    void set (Lm64TYPIDALERTMASK0 value);
}
member TachAlarmMask : Lm64TYPIDALERTMASK0 with get, set

Property Value

Type: Lm64TYPIDALERTMASK0
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.TachometerCount Property

IRD

Lm64TachometerCount Property

Tachometer Count

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TachometerCount { get; }
Public ReadOnly Property TachometerCount As UShort
    Get
public:
property unsigned short TachometerCount {
    unsigned short get ();
}
member TachometerCount : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.TachometerEdgeCount Property

IRD

Lm64TachometerEdgeCount Property

Tachometer Edge Count

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TachometerEdgeCount { get; }
Public ReadOnly Property TachometerEdgeCount As Byte
    Get
public:
property unsigned char TachometerEdgeCount {
    unsigned char get ();
}
member TachometerEdgeCount : byte with get

Property Value

Type: Byte
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.TachometerLimit Property

IRD

Lm64TachometerLimit Property

Tachometer Limit

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TachometerLimit { get; }
Public ReadOnly Property TachometerLimit As UShort
    Get
public:
property unsigned short TachometerLimit {
    unsigned short get ();
}
member TachometerLimit : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.TachometerMode Property

IRD

Lm64TachometerMode Property

Tachometer Mode

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm64TYPIDPWMANDRPMREGISTER0 TachometerMode { get; set; }
Public Property TachometerMode As Lm64TYPIDPWMANDRPMREGISTER0
    Get
    Set
public:
property Lm64TYPIDPWMANDRPMREGISTER0 TachometerMode {
    Lm64TYPIDPWMANDRPMREGISTER0 get ();
    void set (Lm64TYPIDPWMANDRPMREGISTER0 value);
}
member TachometerMode : Lm64TYPIDPWMANDRPMREGISTER0 with get, set

Property Value

Type: Lm64TYPIDPWMANDRPMREGISTER0
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64 Methods

The Lm64 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.Flush Method

IRD

Lm64Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm64 Class
telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDALERTMASK0 Enumeration

IRD

Lm64TYPIDALERTMASK0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTMASK0
Public Enumeration TYPIDALERTMASK0
public enum class TYPIDALERTMASK0
type TYPIDALERTMASK0
Members
Member name | Value | Description
ALERTGeneratedByThisFlag | 0 | ALERT generated by this flag
ALERTNotGenerateByThisFlag | 1 | ALERT not generate by this flag
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDALERTMASK1 Enumeration

IRD

Lm64TYPIDALERTMASK1 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTMASK1
Public Enumeration TYPIDALERTMASK1
public enum class TYPIDALERTMASK1
type TYPIDALERTMASK1
Members
Member name | Value | Description
ALERTGeneratedByThisFlag | 0 | ALERT generated by this flag
ALERTNotGenerateByThisFlag | 1 | ALERT not generate by this flag
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDALERTMASK2 Enumeration

IRD

Lm64TYPIDALERTMASK2 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTMASK2
Public Enumeration TYPIDALERTMASK2
public enum class TYPIDALERTMASK2
type TYPIDALERTMASK2
Members
Member name | Value | Description
ALERTGeneratedByThisFlag | 0 | ALERT generated by this flag
ALERTNotGenerateByThisFlag | 1 | ALERT not generate by this flag
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDALERTMASK3 Enumeration

IRD

Lm64TYPIDALERTMASK3 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTMASK3
Public Enumeration TYPIDALERTMASK3
public enum class TYPIDALERTMASK3
type TYPIDALERTMASK3
Members
Member name | Value | Description
ALERTGeneratedByThisFlag | 0 | ALERT generated by this flag
ALERTNotGenerateByThisFlag | 1 | ALERT not generate by this flag
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDALERTMASK4 Enumeration

IRD

Lm64TYPIDALERTMASK4 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTMASK4
Public Enumeration TYPIDALERTMASK4
public enum class TYPIDALERTMASK4
type TYPIDALERTMASK4
Members
Member name | Value | Description
ALERTGeneratedByThisFlag | 0 | ALERT generated by this flag
ALERTNotGenerateByThisFlag | 1 | ALERT not generate by this flag
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDALERTSTATUS0 Enumeration

IRD

Lm64TYPIDALERTSTATUS0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUS0
Public Enumeration TYPIDALERTSTATUS0
public enum class TYPIDALERTSTATUS0
type TYPIDALERTSTATUS0
Members
Member name | Value | Description
TachometerCountIsLowerThanOrEqualToTheTachometerLimit | 0 | Tachometer count is lower than or equal to the Tachometer Limit
TachometerCountIsHigherThanTheTachometerLimit | 1 | Tachometer count is higher than the Tachometer Limit
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDALERTSTATUS1 Enumeration

IRD

Lm64TYPIDALERTSTATUS1 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUS1
Public Enumeration TYPIDALERTSTATUS1
public enum class TYPIDALERTSTATUS1
type TYPIDALERTSTATUS1
Members
Member name | Value | Description
TemperatureOfTheRemoteDiodeIsAtOrBelowTheTCRITLimit | 0 | Temperature of the Remote Diode is at or below the T_CRIT Limit
TemperatureOfTheRemoteDiodeIsAboveTheTCRITLimit | 1 | Temperature of the Remote Diode is above the T_CRIT Limit
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDALERTSTATUS2 Enumeration

IRD

Lm64TYPIDALERTSTATUS2 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUS2
Public Enumeration TYPIDALERTSTATUS2
public enum class TYPIDALERTSTATUS2
type TYPIDALERTSTATUS2
Members
Member name | Value | Description
RemoteDiodeAppearsToBeCorrectlyConnected | 0 | Remote Diode appears to be correctly connected
RemoteDiodeMayBeDisconnectedOrShorted | 1 | Remote Diode may be disconnected or shorted
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDALERTSTATUS3 Enumeration

IRD

Lm64TYPIDALERTSTATUS3 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUS3
Public Enumeration TYPIDALERTSTATUS3
public enum class TYPIDALERTSTATUS3
type TYPIDALERTSTATUS3
Members
Member name | Value | Description
TemperatureOfTheRemoteDiodeIsAtOrAboveTheRemoteLowSetpoint | 0 | Temperature of the Remote Diode is at or above the Remote Low Setpoint
TemperatureOfTheRemoteDiodeIsBelowTheRemoteLowSetpoint | 1 | Temperature of the Remote Diode is below the Remote Low Setpoint
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDALERTSTATUS4 Enumeration

IRD

Lm64TYPIDALERTSTATUS4 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUS4
Public Enumeration TYPIDALERTSTATUS4
public enum class TYPIDALERTSTATUS4
type TYPIDALERTSTATUS4
Members
Member name | Value | Description
TemperatureOfTheRemoteDiodeIsAtOrBelowTheRemoteHighSetpoint | 0 | Temperature of the Remote Diode is at or below the Remote High Setpoint
TemperatureOfTheRemoteDiodeIsAboveTheRemoteHighSetpoint | 1 | Temperature of the Remote Diode is above the Remote High Setpoint
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDALERTSTATUS5 Enumeration

IRD

Lm64TYPIDALERTSTATUS5 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUS5
Public Enumeration TYPIDALERTSTATUS5
public enum class TYPIDALERTSTATUS5
type TYPIDALERTSTATUS5
Members
Member name | Value | Description
InternalTemperatureOfTheLM64IsAtOrBelowTheLocalHighSetpoint | 0 | Internal temperature of the LM64 is at or below the Local High Setpoint
InternalTemperatureOfTheLM64IsAboveTheLocalHighSetpoint | 1 | Internal temperature of the LM64 is above the Local High Setpoint
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDALERTSTATUS6 Enumeration

IRD

Lm64TYPIDALERTSTATUS6 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDALERTSTATUS6
Public Enumeration TYPIDALERTSTATUS6
public enum class TYPIDALERTSTATUS6
type TYPIDALERTSTATUS6
Members
Member name | Value | Description
ADCIsNotConverting | 0 | ADC is not converting
ADCIsPerformingAConversion | 1 | ADC is performing a conversion
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDCONFIGURATIONREGISTER0 Enumeration

IRD

Lm64TYPIDCONFIGURATIONREGISTER0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONREGISTER0
Public Enumeration TYPIDCONFIGURATIONREGISTER0
public enum class TYPIDCONFIGURATIONREGISTER0
type TYPIDCONFIGURATIONREGISTER0
Members
Member name | Value | Description
ALERTIfAnyRemoteDiodeConversionResultAboveBelowTheRemoteHighLowSetPoint | 0 | ALERT if any Remote Diode conversion result above/below the Remote High/Low Set Point
ALERTIfOnlyThreeRemoteDiodeConversionsAreAboveBelowTheRemoteHighLowSetPoint | 1 | ALERT if only three Remote Diode conversions are above/below the Remote High/Low Set Point
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDCONFIGURATIONREGISTER1 Enumeration

IRD

Lm64TYPIDCONFIGURATIONREGISTER1 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONREGISTER1
Public Enumeration TYPIDCONFIGURATIONREGISTER1
public enum class TYPIDCONFIGURATIONREGISTER1
type TYPIDCONFIGURATIONREGISTER1
Members
Member name | Value | Description
LM64SPWMOutputContinuesToOutputTheCurrentFanControlSignalWhileInSTANDBY | 0 | LM64's PWM output continues to output the current fan control signal while in STANDBY
PWMOutputIsDisabledAsDefinedByThePWMPolarityBitWhileInSTANDBY | 1 | PWM output is disabled (as defined by the PWM polarity bit) while in STANDBY
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDCONFIGURATIONREGISTER2 Enumeration

IRD

Lm64TYPIDCONFIGURATIONREGISTER2 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONREGISTER2
Public Enumeration TYPIDCONFIGURATIONREGISTER2
public enum class TYPIDCONFIGURATIONREGISTER2
type TYPIDCONFIGURATIONREGISTER2
Members
Member name | Value | Description
LM64IsInOperationalMode | 0 | LM64 is in operational mode
LM64EntersALowPowerStandbyMode | 1 | LM64 enters a low power standby mode
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDCONFIGURATIONREGISTER3 Enumeration

IRD

Lm64TYPIDCONFIGURATIONREGISTER3 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONREGISTER3
Public Enumeration TYPIDCONFIGURATIONREGISTER3
public enum class TYPIDCONFIGURATIONREGISTER3
type TYPIDCONFIGURATIONREGISTER3
Members
Member name | Value | Description
ALERTInterruptsAreEnabled | 0 | ALERT interrupts are enabled
ALERTInterruptsMaskedALERTPinHighImpedanceState | 1 | ALERT interrupts masked/ALERT pin=high impedance state
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDCONVERSIONRATEREGISTER0 Enumeration

IRD

Lm64TYPIDCONVERSIONRATEREGISTER0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONVERSIONRATEREGISTER0
Public Enumeration TYPIDCONVERSIONRATEREGISTER0
public enum class TYPIDCONVERSIONRATEREGISTER0
type TYPIDCONVERSIONRATEREGISTER0
Members
Member name | Value | Description
Value_0_0625 | 0 | 0.0625
Value_0_125 | 1 | 0.125
Value_0_25 | 2 | 0.25
Value_0_5 | 3 | 0.5
Value_1 | 4 | 1
Value_2 | 5 | 2
Value_4 | 6 | 4
Value_8 | 7 | 8
Value_16 | 8 | 16
Value_32 | 9 | 32
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDFANPWMFREQUENCY0 Enumeration

IRD

Lm64TYPIDFANPWMFREQUENCY0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFANPWMFREQUENCY0
Public Enumeration TYPIDFANPWMFREQUENCY0
public enum class TYPIDFANPWMFREQUENCY0
type TYPIDFANPWMFREQUENCY0
Members
Member name | Value | Description
PWMFrequ36014KHz180000700 | 0 | PWM Frequ=360/1.4 kHz: 180.00/0.700
PWMFrequ36014KHz90000350 | 2 | PWM Frequ=360/1.4 kHz: 90.00/0.350
PWMFrequ36014KHz60000233 | 3 | PWM Frequ=360/1.4 kHz: 60.00/0.233
PWMFrequ36014KHz45000175 | 4 | PWM Frequ=360/1.4 kHz: 45.00/0.175
PWMFrequ36014KHz36000140 | 5 | PWM Frequ=360/1.4 kHz: 36.00/0.140
PWMFrequ36014KHz30000117 | 6 | PWM Frequ=360/1.4 kHz: 30.00/0.117
PWMFrequ36014KHz25710100 | 7 | PWM Frequ=360/1.4 kHz: 25.71/0.100
PWMFrequ36014KHz22500088 | 8 | PWM Frequ=360/1.4 kHz: 22.50/0.088
PWMFrequ36014KHz20000078 | 9 | PWM Frequ=360/1.4 kHz: 20.00/0.078
PWMFrequ36014KHz18000070 | 10 | PWM Frequ=360/1.4 kHz: 18.00/0.070
PWMFrequ36014KHz16360064 | 11 | PWM Frequ=360/1.4 kHz: 16.36/0.064
PWMFrequ36014KHz15000058 | 12 | PWM Frequ=360/1.4 kHz: 15.00/0.058
PWMFrequ36014KHz13850054 | 13 | PWM Frequ=360/1.4 kHz: 13.85/0.054
PWMFrequ36014KHz12860050 | 14 | PWM Frequ=360/1.4 kHz: 12.86/0.050
PWMFrequ36014KHz12000047 | 15 | PWM Frequ=360/1.4 kHz: 12.00/0.047
PWMFrequ36014KHz11250044 | 16 | PWM Frequ=360/1.4 kHz: 11.25/0.044
PWMFrequ36014KHz10590041 | 17 | PWM Frequ=360/1.4 kHz: 10.59/0.041
PWMFrequ36014KHz10000039 | 18 | PWM Frequ=360/1.4 kHz: 10.00/0.039
PWMFrequ36014KHz9470037 | 19 | PWM Frequ=360/1.4 kHz: 9.47/0.037
PWMFrequ36014KHz9000035 | 20 | PWM Frequ=360/1.4 kHz: 9.00/0.035
PWMFrequ36014KHz8570033 | 21 | PWM Frequ=360/1.4 kHz: 8.57/0.033
PWMFrequ36014KHz8180032 | 22 | PWM Frequ=360/1.4 kHz: 8.18/0.032
PWMFrequ36014KHz7830030 | 23 | PWM Frequ=360/1.4 kHz: 7.83/0.030
PWMFrequ36014KHz7500029 | 24 | PWM Frequ=360/1.4 kHz: 7.50/0.029
PWMFrequ36014KHz7200028 | 25 | PWM Frequ=360/1.4 kHz: 7.20/0.028
PWMFrequ36014KHz6920027 | 26 | PWM Frequ=360/1.4 kHz: 6.92/0.027
PWMFrequ36014KHz6670026 | 27 | PWM Frequ=360/1.4 kHz: 6.67/0.026
PWMFrequ36014KHz6430025 | 28 | PWM Frequ=360/1.4 kHz: 6.43/0.025
PWMFrequ36014KHz6210024 | 29 | PWM Frequ=360/1.4 kHz: 6.21/0.024
PWMFrequ36014KHz6000023 | 30 | PWM Frequ=360/1.4 kHz: 6.00/0.023
PWMFrequ36014KHz5810023 | 31 | PWM Frequ=360/1.4 kHz: 5.81/0.023
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDFANSPINUPCONFIRATIONREGISTER0 Enumeration

IRD

Lm64TYPIDFANSPINUPCONFIRATIONREGISTER0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFANSPINUPCONFIRATIONREGISTER0
Public Enumeration TYPIDFANSPINUPCONFIRATIONREGISTER0
public enum class TYPIDFANSPINUPCONFIRATIONREGISTER0
type TYPIDFANSPINUPCONFIRATIONREGISTER0
Members
Member name | Value | Description
SpinUpCycleBypassed | 0 | Spin-Up cycle bypassed
Value_005S | 1 | 0.05 s
Value_01S | 2 | 0.1 s
Value_02S | 3 | 0.2 s
Value_04S | 4 | 0.4 s
Value_08S | 5 | 0.8 s
Value_16S | 6 | 1.6 s
Value_32S | 7 | 3.2 s
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDFANSPINUPCONFIRATIONREGISTER1 Enumeration

IRD

Lm64TYPIDFANSPINUPCONFIRATIONREGISTER1 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFANSPINUPCONFIRATIONREGISTER1
Public Enumeration TYPIDFANSPINUPCONFIRATIONREGISTER1
public enum class TYPIDFANSPINUPCONFIRATIONREGISTER1
type TYPIDFANSPINUPCONFIRATIONREGISTER1
Members
Member name | Value | Description
SpinUpCycleBypassed | 0 | Spin-Up cycle bypassed
Value_50 | 1 | 50%
Value_7581DependsOnPWMFrequency | 2 | 75%..81% (Depends on PWM Frequency)
Value_100 | 3 | 100%
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDFANSPINUPCONFIRATIONREGISTER2 Enumeration

IRD

Lm64TYPIDFANSPINUPCONFIRATIONREGISTER2 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFANSPINUPCONFIRATIONREGISTER2
Public Enumeration TYPIDFANSPINUPCONFIRATIONREGISTER2
public enum class TYPIDFANSPINUPCONFIRATIONREGISTER2
type TYPIDFANSPINUPCONFIRATIONREGISTER2
Members
Member name | Value | Description
TheFanSpinUpUsesTheDutyCycleAndSpinUpTime | 0 | The fan spin-up uses the duty cycle and spin-up time
TheLM64SetsThePWMOutputTo100UntilTheSpinUpTimesOut | 1 | The LM64 sets the PWM output to 100% until the spin-up times out
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDPWMANDRPMREGISTER0 Enumeration

IRD

Lm64TYPIDPWMANDRPMREGISTER0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDPWMANDRPMREGISTER0
Public Enumeration TYPIDPWMANDRPMREGISTER0
public enum class TYPIDPWMANDRPMREGISTER0
type TYPIDPWMANDRPMREGISTER0
Members
Member name | Value | Description
TraditionalTachInputMonitorFalseReadingsWhenUnderMinimumDetectableRPM | 0 | Traditional tach input monitor, false readings when under minimum detectable RPM
TraditionalTachInputMonitorFFFFReadingWhenUnderMinimumDetectableRPM | 1 | Traditional tach input monitor, FFFF reading when under minimum detectable RPM
MostAccurateReadingsFFFFReadingWhenUnderMinimumDetectableRPM | 2 | Most accurate readings, FFFF reading when under minimum detectable RPM
LeastEffortOnProgrammedPWMOfFanFFFFReadingWhenUnderMinimumDetectableRPM | 3 | Least effort on programmed PWM of fan, FFFF reading when under minimum detectable RPM
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDPWMANDRPMREGISTER1 Enumeration

IRD

Lm64TYPIDPWMANDRPMREGISTER1 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDPWMANDRPMREGISTER1
Public Enumeration TYPIDPWMANDRPMREGISTER1
public enum class TYPIDPWMANDRPMREGISTER1
type TYPIDPWMANDRPMREGISTER1
Members
Member name | Value | Description
TheMasterPWMClockIs360KHz | 0 | The master PWM clock is 360 kHz
TheMasterPWMClockIs14KHz | 1 | The master PWM clock is 1.4 kHz
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDPWMANDRPMREGISTER2 Enumeration

IRD

Lm64TYPIDPWMANDRPMREGISTER2 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDPWMANDRPMREGISTER2
Public Enumeration TYPIDPWMANDRPMREGISTER2
public enum class TYPIDPWMANDRPMREGISTER2
type TYPIDPWMANDRPMREGISTER2
Members
Member name | Value | Description
ThePWMOutputPinWillBe0VForFanOFFAndOpenForFanON | 0 | The PWM output pin will be 0 V for fan OFF and open for fan ON
ThePWMOutputPinWillBeOpenForFanOFFAnd0VForFanON | 1 | The PWM output pin will be open for fan OFF and 0 V for fan ON
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDPWMANDRPMREGISTER3 Enumeration

IRD

Lm64TYPIDPWMANDRPMREGISTER3 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDPWMANDRPMREGISTER3
Public Enumeration TYPIDPWMANDRPMREGISTER3
public enum class TYPIDPWMANDRPMREGISTER3
type TYPIDPWMANDRPMREGISTER3
Members
Member name | Value | Description
PWMValueLookupTableReadOnly | 0 | PWM Value/Lookup Table: read-only
PWMValueLookupTableReadWriteEnabled | 1 | PWM Value/Lookup Table: read/write enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDREMOTEDIODETEMPPERATUREFILTER0 Enumeration

IRD

Lm64TYPIDREMOTEDIODETEMPPERATUREFILTER0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDREMOTEDIODETEMPPERATUREFILTER0
Public Enumeration TYPIDREMOTEDIODETEMPPERATUREFILTER0
public enum class TYPIDREMOTEDIODETEMPPERATUREFILTER0
type TYPIDREMOTEDIODETEMPPERATUREFILTER0
Members
Member name | Value | Description
ALERTPinFunctionsAsAndInterruptOrARAMode | 0 | ALERT pin functions as and Interrupt or ARA mode
ALERTTachPinBehavesAsAComparator | 1 | ALERT/Tach pin behaves as a comparator
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm64.TYPIDREMOTEDIODETEMPPERATUREFILTER1 Enumeration

IRD

Lm64TYPIDREMOTEDIODETEMPPERATUREFILTER1 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDREMOTEDIODETEMPPERATUREFILTER1
Public Enumeration TYPIDREMOTEDIODETEMPPERATUREFILTER1
public enum class TYPIDREMOTEDIODETEMPPERATUREFILTER1
type TYPIDREMOTEDIODETEMPPERATUREFILTER1
Members
Member name | Value | Description
FilterDisabled | 0 | Filter Disabled
FilterLevel1 | 1 | Filter Level 1
FilterLevel2 | 3 | Filter Level 2
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm73 Class

National Semiconductor: LM 73
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm73

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm73
Public Class Lm73
public ref class Lm73
type Lm73 =  class end

The Lm73 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm73 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationALERTEnable | Configuration: ALERT Enable
Public property | ConfigurationALERTPolarity | Configuration: ALERT Polarity
Public property | ConfigurationALERTReset | Configuration: ALERT Reset
Public property | ConfigurationFullPowerDown | Configuration: Full Power Down
Public property | ConfigurationOneShot | Configuration: One Shot
Public property | ControlStatusALERTPinStatus | Control/Status: ALERT Pin Status
Public property | ControlStatusDataAvailableFlag | Control/Status: Data Available Flag
Public property | ControlStatusTemperatureHighFlag | Control/Status: Temperature High Flag
Public property | ControlStatusTemperatureLowFlag | Control/Status: Temperature Low Flag
Public property | ControlStatusTemperatureResolution | Control/Status: Temperature Resolution
Public property | ControlStatusTimeOutDisable | Control/Status: Time-Out Disable
Public property | DieRevisionStep | Die Revision Step
Public property | ManufacturerIdentification | Manufacturer Identification
Public property | ProductIdentification | Product Identification
Public property | Temperature | Temperature (unit: °C)
Public property | THIGH | T_HIGH (unit: °C)
Public property | TLOW | T_LOW (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
11-To-14 Bit Digital Temperature Sensor With 2-Wire Interface
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm73 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm73(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm73(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm73

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73 Properties

The Lm73 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationALERTEnable | Configuration: ALERT Enable
Public property | ConfigurationALERTPolarity | Configuration: ALERT Polarity
Public property | ConfigurationALERTReset | Configuration: ALERT Reset
Public property | ConfigurationFullPowerDown | Configuration: Full Power Down
Public property | ConfigurationOneShot | Configuration: One Shot
Public property | ControlStatusALERTPinStatus | Control/Status: ALERT Pin Status
Public property | ControlStatusDataAvailableFlag | Control/Status: Data Available Flag
Public property | ControlStatusTemperatureHighFlag | Control/Status: Temperature High Flag
Public property | ControlStatusTemperatureLowFlag | Control/Status: Temperature Low Flag
Public property | ControlStatusTemperatureResolution | Control/Status: Temperature Resolution
Public property | ControlStatusTimeOutDisable | Control/Status: Time-Out Disable
Public property | DieRevisionStep | Die Revision Step
Public property | ManufacturerIdentification | Manufacturer Identification
Public property | ProductIdentification | Product Identification
Public property | Temperature | Temperature (unit: °C)
Public property | THIGH | T_HIGH (unit: °C)
Public property | TLOW | T_LOW (unit: °C)
Top
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.AutoFlush Property

IRD

Lm73AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.ConfigurationALERTEnable Property

IRD

Lm73ConfigurationALERTEnable Property

Configuration: ALERT Enable

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm73TypeConfigurationAlertEnable ConfigurationALERTEnable { get; set; }
Public Property ConfigurationALERTEnable As Lm73TypeConfigurationAlertEnable
    Get
    Set
public:
property Lm73TypeConfigurationAlertEnable ConfigurationALERTEnable {
    Lm73TypeConfigurationAlertEnable get ();
    void set (Lm73TypeConfigurationAlertEnable value);
}
member ConfigurationALERTEnable : Lm73TypeConfigurationAlertEnable with get, set

Property Value

Type: Lm73TypeConfigurationAlertEnable
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.ConfigurationALERTPolarity Property

IRD

Lm73ConfigurationALERTPolarity Property

Configuration: ALERT Polarity

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm73TypeConfigurationAlertPolarity ConfigurationALERTPolarity { get; set; }
Public Property ConfigurationALERTPolarity As Lm73TypeConfigurationAlertPolarity
    Get
    Set
public:
property Lm73TypeConfigurationAlertPolarity ConfigurationALERTPolarity {
    Lm73TypeConfigurationAlertPolarity get ();
    void set (Lm73TypeConfigurationAlertPolarity value);
}
member ConfigurationALERTPolarity : Lm73TypeConfigurationAlertPolarity with get, set

Property Value

Type: Lm73TypeConfigurationAlertPolarity
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.ConfigurationALERTReset Property

IRD

Lm73ConfigurationALERTReset Property

Configuration: ALERT Reset

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm73TypeConfigurationAlertReset ConfigurationALERTReset { set; }
Public WriteOnly Property ConfigurationALERTReset As Lm73TypeConfigurationAlertReset
    Set
public:
property Lm73TypeConfigurationAlertReset ConfigurationALERTReset {
    void set (Lm73TypeConfigurationAlertReset value);
}
member ConfigurationALERTReset : Lm73TypeConfigurationAlertReset with set

Property Value

Type: Lm73TypeConfigurationAlertReset
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.ConfigurationFullPowerDown Property

IRD

Lm73ConfigurationFullPowerDown Property

Configuration: Full Power Down

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm73TypeConfigurationFullPowerDown ConfigurationFullPowerDown { get; set; }
Public Property ConfigurationFullPowerDown As Lm73TypeConfigurationFullPowerDown
    Get
    Set
public:
property Lm73TypeConfigurationFullPowerDown ConfigurationFullPowerDown {
    Lm73TypeConfigurationFullPowerDown get ();
    void set (Lm73TypeConfigurationFullPowerDown value);
}
member ConfigurationFullPowerDown : Lm73TypeConfigurationFullPowerDown with get, set

Property Value

Type: Lm73TypeConfigurationFullPowerDown
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.ConfigurationOneShot Property

IRD

Lm73ConfigurationOneShot Property

Configuration: One Shot

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm73TypeConfigurationOneShot ConfigurationOneShot { set; }
Public WriteOnly Property ConfigurationOneShot As Lm73TypeConfigurationOneShot
    Set
public:
property Lm73TypeConfigurationOneShot ConfigurationOneShot {
    void set (Lm73TypeConfigurationOneShot value);
}
member ConfigurationOneShot : Lm73TypeConfigurationOneShot with set

Property Value

Type: Lm73TypeConfigurationOneShot
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.ControlStatusALERTPinStatus Property

IRD

Lm73ControlStatusALERTPinStatus Property

Control/Status: ALERT Pin Status

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm73TypeControlAlertStatus ControlStatusALERTPinStatus { get; }
Public ReadOnly Property ControlStatusALERTPinStatus As Lm73TypeControlAlertStatus
    Get
public:
property Lm73TypeControlAlertStatus ControlStatusALERTPinStatus {
    Lm73TypeControlAlertStatus get ();
}
member ControlStatusALERTPinStatus : Lm73TypeControlAlertStatus with get

Property Value

Type: Lm73TypeControlAlertStatus
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.ControlStatusDataAvailableFlag Property

IRD

Lm73ControlStatusDataAvailableFlag Property

Control/Status: Data Available Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm73TypeControlDataAvailableFlag ControlStatusDataAvailableFlag { get; }
Public ReadOnly Property ControlStatusDataAvailableFlag As Lm73TypeControlDataAvailableFlag
    Get
public:
property Lm73TypeControlDataAvailableFlag ControlStatusDataAvailableFlag {
    Lm73TypeControlDataAvailableFlag get ();
}
member ControlStatusDataAvailableFlag : Lm73TypeControlDataAvailableFlag with get

Property Value

Type: Lm73TypeControlDataAvailableFlag
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.ControlStatusTemperatureHighFlag Property

IRD

Lm73ControlStatusTemperatureHighFlag Property

Control/Status: Temperature High Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm73TypeControlTemperatureHighFlag ControlStatusTemperatureHighFlag { get; }
Public ReadOnly Property ControlStatusTemperatureHighFlag As Lm73TypeControlTemperatureHighFlag
    Get
public:
property Lm73TypeControlTemperatureHighFlag ControlStatusTemperatureHighFlag {
    Lm73TypeControlTemperatureHighFlag get ();
}
member ControlStatusTemperatureHighFlag : Lm73TypeControlTemperatureHighFlag with get

Property Value

Type: Lm73TypeControlTemperatureHighFlag
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.ControlStatusTemperatureLowFlag Property

IRD

Lm73ControlStatusTemperatureLowFlag Property

Control/Status: Temperature Low Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm73TypeControlTemperatureLowFlag ControlStatusTemperatureLowFlag { get; }
Public ReadOnly Property ControlStatusTemperatureLowFlag As Lm73TypeControlTemperatureLowFlag
    Get
public:
property Lm73TypeControlTemperatureLowFlag ControlStatusTemperatureLowFlag {
    Lm73TypeControlTemperatureLowFlag get ();
}
member ControlStatusTemperatureLowFlag : Lm73TypeControlTemperatureLowFlag with get

Property Value

Type: Lm73TypeControlTemperatureLowFlag
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.ControlStatusTemperatureResolution Property

IRD

Lm73ControlStatusTemperatureResolution Property

Control/Status: Temperature Resolution

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm73TypeControlTemperatureResolution ControlStatusTemperatureResolution { get; set; }
Public Property ControlStatusTemperatureResolution As Lm73TypeControlTemperatureResolution
    Get
    Set
public:
property Lm73TypeControlTemperatureResolution ControlStatusTemperatureResolution {
    Lm73TypeControlTemperatureResolution get ();
    void set (Lm73TypeControlTemperatureResolution value);
}
member ControlStatusTemperatureResolution : Lm73TypeControlTemperatureResolution with get, set

Property Value

Type: Lm73TypeControlTemperatureResolution
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.ControlStatusTimeOutDisable Property

IRD

Lm73ControlStatusTimeOutDisable Property

Control/Status: Time-Out Disable

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm73TypeControlTimeOutDisable ControlStatusTimeOutDisable { get; set; }
Public Property ControlStatusTimeOutDisable As Lm73TypeControlTimeOutDisable
    Get
    Set
public:
property Lm73TypeControlTimeOutDisable ControlStatusTimeOutDisable {
    Lm73TypeControlTimeOutDisable get ();
    void set (Lm73TypeControlTimeOutDisable value);
}
member ControlStatusTimeOutDisable : Lm73TypeControlTimeOutDisable with get, set

Property Value

Type: Lm73TypeControlTimeOutDisable
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.DieRevisionStep Property

IRD

Lm73DieRevisionStep Property

Die Revision Step

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DieRevisionStep { get; }
Public ReadOnly Property DieRevisionStep As Byte
    Get
public:
property unsigned char DieRevisionStep {
    unsigned char get ();
}
member DieRevisionStep : byte with get

Property Value

Type: Byte
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.ManufacturerIdentification Property

IRD

Lm73ManufacturerIdentification Property

Manufacturer Identification

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerIdentification { get; }
Public ReadOnly Property ManufacturerIdentification As Byte
    Get
public:
property unsigned char ManufacturerIdentification {
    unsigned char get ();
}
member ManufacturerIdentification : byte with get

Property Value

Type: Byte
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.ProductIdentification Property

IRD

Lm73ProductIdentification Property

Product Identification

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ProductIdentification { get; }
Public ReadOnly Property ProductIdentification As Byte
    Get
public:
property unsigned char ProductIdentification {
    unsigned char get ();
}
member ProductIdentification : byte with get

Property Value

Type: Byte
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.Temperature Property

IRD

Lm73Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.THIGH Property

IRD

Lm73THIGH Property

T_HIGH (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double THIGH { get; set; }
Public Property THIGH As Double
    Get
    Set
public:
property double THIGH {
    double get ();
    void set (double value);
}
member THIGH : float with get, set

Property Value

Type: Double
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.TLOW Property

IRD

Lm73TLOW Property

T_LOW (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TLOW { get; set; }
Public Property TLOW As Double
    Get
    Set
public:
property double TLOW {
    double get ();
    void set (double value);
}
member TLOW : float with get, set

Property Value

Type: Double
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73 Methods

The Lm73 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.Flush Method

IRD

Lm73Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm73 Class
telos.Ird.NationalSemiconductor Namespace


Lm73.TypeConfigurationAlertEnable Enumeration

IRD

Lm73TypeConfigurationAlertEnable Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationAlertEnable
Public Enumeration TypeConfigurationAlertEnable
public enum class TypeConfigurationAlertEnable
type TypeConfigurationAlertEnable
Members
Member name | Value | Description
ALERTEnabled | 0 | ALERT: Enabled
ALERTDisabled | 1 | ALERT: Disabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm73.TypeConfigurationAlertPolarity Enumeration

IRD

Lm73TypeConfigurationAlertPolarity Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationAlertPolarity
Public Enumeration TypeConfigurationAlertPolarity
public enum class TypeConfigurationAlertPolarity
type TypeConfigurationAlertPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active-Low
ActiveHigh | 1 | Active-High
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm73.TypeConfigurationAlertReset Enumeration

IRD

Lm73TypeConfigurationAlertReset Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationAlertReset
Public Enumeration TypeConfigurationAlertReset
public enum class TypeConfigurationAlertReset
type TypeConfigurationAlertReset
Members
Member name | Value | Description
Unmodified | 0 | Unmodified
ResetALERT | 1 | Reset ALERT
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm73.TypeConfigurationFullPowerDown Enumeration

IRD

Lm73TypeConfigurationFullPowerDown Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationFullPowerDown
Public Enumeration TypeConfigurationFullPowerDown
public enum class TypeConfigurationFullPowerDown
type TypeConfigurationFullPowerDown
Members
Member name | Value | Description
NormalMode | 0 | Normal Mode
ShutdownMode | 1 | Shutdown Mode
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm73.TypeConfigurationOneShot Enumeration

IRD

Lm73TypeConfigurationOneShot Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationOneShot
Public Enumeration TypeConfigurationOneShot
public enum class TypeConfigurationOneShot
type TypeConfigurationOneShot
Members
Member name | Value | Description
Unmodified | 0 | Unmodified
TriggerOneShot | 1 | Trigger One Shot
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm73.TypeControlAlertStatus Enumeration

IRD

Lm73TypeControlAlertStatus Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlAlertStatus
Public Enumeration TypeControlAlertStatus
public enum class TypeControlAlertStatus
type TypeControlAlertStatus
Members
Member name | Value | Description
Low | 0 | Low
High | 1 | High
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm73.TypeControlDataAvailableFlag Enumeration

IRD

Lm73TypeControlDataAvailableFlag Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlDataAvailableFlag
Public Enumeration TypeControlDataAvailableFlag
public enum class TypeControlDataAvailableFlag
type TypeControlDataAvailableFlag
Members
Member name | Value | Description
ConversionRunning | 0 | Conversion Running
ConversionCompleted | 1 | Conversion Completed
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm73.TypeControlTemperatureHighFlag Enumeration

IRD

Lm73TypeControlTemperatureHighFlag Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlTemperatureHighFlag
Public Enumeration TypeControlTemperatureHighFlag
public enum class TypeControlTemperatureHighFlag
type TypeControlTemperatureHighFlag
Members
Member name | Value | Description
TTHIGH | 0 | T <= T_HIGH
TTHIGH__1 | 1 | T > T_HIGH
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm73.TypeControlTemperatureLowFlag Enumeration

IRD

Lm73TypeControlTemperatureLowFlag Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlTemperatureLowFlag
Public Enumeration TypeControlTemperatureLowFlag
public enum class TypeControlTemperatureLowFlag
type TypeControlTemperatureLowFlag
Members
Member name | Value | Description
TTLOW | 0 | T >= T_LOW
TTLOW__1 | 1 | T < T_LOW
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm73.TypeControlTemperatureResolution Enumeration

IRD

Lm73TypeControlTemperatureResolution Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlTemperatureResolution
Public Enumeration TypeControlTemperatureResolution
public enum class TypeControlTemperatureResolution
type TypeControlTemperatureResolution
Members
Member name | Value | Description
Value_025CLSB | 0 | 0.25 °C/LSB
Value_0125CLSB | 1 | 0.125 °C/LSB
Value_00625CLSB | 2 | 0.0625 °C/LSB
Value_003125CLSB | 3 | 0.03125 °C/LSB
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm73.TypeControlTimeOutDisable Enumeration

IRD

Lm73TypeControlTimeOutDisable Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControlTimeOutDisable
Public Enumeration TypeControlTimeOutDisable
public enum class TypeControlTimeOutDisable
type TypeControlTimeOutDisable
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm75 Class

National Semiconductor: LM 75
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm75

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm75
Public Class Lm75
public ref class Lm75
type Lm75 =  class end

The Lm75 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm75 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ComparatorInterruptMode | Comparator/Interrupt Mode
Public property | FaultQueue | Fault Queue
Public property | OSPolarity | O.S. Polarity
Public property | Shutdown | Shutdown
Public property | Temperature | Temperature (unit: °C)
Public property | THYST | T_HYST (unit: °C)
Public property | TOS | T_OS (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Digital Temperature Sensor and Thermal Watchdog with Two-Wire Interface
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm75 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm75(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm75(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm75

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm75 Class
telos.Ird.NationalSemiconductor Namespace


Lm75 Properties

The Lm75 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ComparatorInterruptMode | Comparator/Interrupt Mode
Public property | FaultQueue | Fault Queue
Public property | OSPolarity | O.S. Polarity
Public property | Shutdown | Shutdown
Public property | Temperature | Temperature (unit: °C)
Public property | THYST | T_HYST (unit: °C)
Public property | TOS | T_OS (unit: °C)
Top
See Also

Reference

Lm75 Class
telos.Ird.NationalSemiconductor Namespace


Lm75.AutoFlush Property

IRD

Lm75AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm75 Class
telos.Ird.NationalSemiconductor Namespace


Lm75.ComparatorInterruptMode Property

IRD

Lm75ComparatorInterruptMode Property

Comparator/Interrupt Mode

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm75ConfigOpModeType ComparatorInterruptMode { get; set; }
Public Property ComparatorInterruptMode As Lm75ConfigOpModeType
    Get
    Set
public:
property Lm75ConfigOpModeType ComparatorInterruptMode {
    Lm75ConfigOpModeType get ();
    void set (Lm75ConfigOpModeType value);
}
member ComparatorInterruptMode : Lm75ConfigOpModeType with get, set

Property Value

Type: Lm75ConfigOpModeType
See Also

Reference

Lm75 Class
telos.Ird.NationalSemiconductor Namespace


Lm75.FaultQueue Property

IRD

Lm75FaultQueue Property

Fault Queue

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm75ConfigFaultType FaultQueue { get; set; }
Public Property FaultQueue As Lm75ConfigFaultType
    Get
    Set
public:
property Lm75ConfigFaultType FaultQueue {
    Lm75ConfigFaultType get ();
    void set (Lm75ConfigFaultType value);
}
member FaultQueue : Lm75ConfigFaultType with get, set

Property Value

Type: Lm75ConfigFaultType
See Also

Reference

Lm75 Class
telos.Ird.NationalSemiconductor Namespace


Lm75.OSPolarity Property

IRD

Lm75OSPolarity Property

O.S. Polarity

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm75ConfigPolType OSPolarity { get; set; }
Public Property OSPolarity As Lm75ConfigPolType
    Get
    Set
public:
property Lm75ConfigPolType OSPolarity {
    Lm75ConfigPolType get ();
    void set (Lm75ConfigPolType value);
}
member OSPolarity : Lm75ConfigPolType with get, set

Property Value

Type: Lm75ConfigPolType
See Also

Reference

Lm75 Class
telos.Ird.NationalSemiconductor Namespace


Lm75.Shutdown Property

IRD

Lm75Shutdown Property

Shutdown

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm75ConfigShutdownType Shutdown { get; set; }
Public Property Shutdown As Lm75ConfigShutdownType
    Get
    Set
public:
property Lm75ConfigShutdownType Shutdown {
    Lm75ConfigShutdownType get ();
    void set (Lm75ConfigShutdownType value);
}
member Shutdown : Lm75ConfigShutdownType with get, set

Property Value

Type: Lm75ConfigShutdownType
See Also

Reference

Lm75 Class
telos.Ird.NationalSemiconductor Namespace


Lm75.Temperature Property

IRD

Lm75Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Lm75 Class
telos.Ird.NationalSemiconductor Namespace


Lm75.THYST Property

IRD

Lm75THYST Property

T_HYST (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double THYST { get; set; }
Public Property THYST As Double
    Get
    Set
public:
property double THYST {
    double get ();
    void set (double value);
}
member THYST : float with get, set

Property Value

Type: Double
See Also

Reference

Lm75 Class
telos.Ird.NationalSemiconductor Namespace


Lm75.TOS Property

IRD

Lm75TOS Property

T_OS (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TOS { get; set; }
Public Property TOS As Double
    Get
    Set
public:
property double TOS {
    double get ();
    void set (double value);
}
member TOS : float with get, set

Property Value

Type: Double
See Also

Reference

Lm75 Class
telos.Ird.NationalSemiconductor Namespace


Lm75 Methods

The Lm75 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm75 Class
telos.Ird.NationalSemiconductor Namespace


Lm75.Flush Method

IRD

Lm75Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm75 Class
telos.Ird.NationalSemiconductor Namespace


Lm75.ConfigFaultType Enumeration

IRD

Lm75ConfigFaultType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigFaultType
Public Enumeration ConfigFaultType
public enum class ConfigFaultType
type ConfigFaultType
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_2 | 1 | 2
Value_4 | 2 | 4
Value_6 | 3 | 6
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm75.ConfigOpModeType Enumeration

IRD

Lm75ConfigOpModeType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigOpModeType
Public Enumeration ConfigOpModeType
public enum class ConfigOpModeType
type ConfigOpModeType
Members
Member name | Value | Description
ComparatorMode | 0 | Comparator Mode
InterruptMode | 1 | Interrupt Mode
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm75.ConfigPolType Enumeration

IRD

Lm75ConfigPolType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigPolType
Public Enumeration ConfigPolType
public enum class ConfigPolType
type ConfigPolType
Members
Member name | Value | Description
OSActiveLow | 0 | O.S.: Active Low
OSActiveHigh | 1 | O.S.: Active High
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm75.ConfigShutdownType Enumeration

IRD

Lm75ConfigShutdownType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigShutdownType
Public Enumeration ConfigShutdownType
public enum class ConfigShutdownType
type ConfigShutdownType
Members
Member name | Value | Description
ActiveMode | 0 | Active Mode
ShutdownMode | 1 | Shutdown Mode
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm76 Class

National Semiconductor: LM 76
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm76

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm76
Public Class Lm76
public ref class Lm76
type Lm76 =  class end

The Lm76 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm76 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationINTMode | Configuration: INT Mode
Public property | ConfigurationINTPolarity | Configuration: INT Polarity
Public property | ConfigurationShutdown | Configuration: Shutdown
Public property | ConfigurationTCRITAPolarity | Configuration: T_CRIT_A Polarity
Public property | StatusCRIT | Status: CRIT
Public property | StatusHIGH | Status: HIGH
Public property | StatusLOW | Status: LOW
Public property | TCRIT | T_CRIT (unit: °C)
Public property | Temperature | Temperature (unit: °C)
Public property | THIGH | T_HIGH (unit: °C)
Public property | THYST | T_HYST (unit: °C)
Public property | TLOW | T_LOW (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
±0.5°C, ±1°C, 12-Bit + Sign Digital Temperature Sensor and Thermal Window Comparator with Two-Wire Interface
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm76 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm76(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm76(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm76

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm76 Class
telos.Ird.NationalSemiconductor Namespace


Lm76 Properties

The Lm76 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationINTMode | Configuration: INT Mode
Public property | ConfigurationINTPolarity | Configuration: INT Polarity
Public property | ConfigurationShutdown | Configuration: Shutdown
Public property | ConfigurationTCRITAPolarity | Configuration: T_CRIT_A Polarity
Public property | StatusCRIT | Status: CRIT
Public property | StatusHIGH | Status: HIGH
Public property | StatusLOW | Status: LOW
Public property | TCRIT | T_CRIT (unit: °C)
Public property | Temperature | Temperature (unit: °C)
Public property | THIGH | T_HIGH (unit: °C)
Public property | THYST | T_HYST (unit: °C)
Public property | TLOW | T_LOW (unit: °C)
Top
See Also

Reference

Lm76 Class
telos.Ird.NationalSemiconductor Namespace


Lm76.AutoFlush Property

IRD

Lm76AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm76 Class
telos.Ird.NationalSemiconductor Namespace


Lm76.ConfigurationFaultQueue Property

IRD

Lm76ConfigurationFaultQueue Property

Configuration: Fault Queue

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm76TypeConfigFaultQueue ConfigurationFaultQueue { get; set; }
Public Property ConfigurationFaultQueue As Lm76TypeConfigFaultQueue
    Get
    Set
public:
property Lm76TypeConfigFaultQueue ConfigurationFaultQueue {
    Lm76TypeConfigFaultQueue get ();
    void set (Lm76TypeConfigFaultQueue value);
}
member ConfigurationFaultQueue : Lm76TypeConfigFaultQueue with get, set

Property Value

Type: Lm76TypeConfigFaultQueue
See Also

Reference

Lm76 Class
telos.Ird.NationalSemiconductor Namespace


Lm76.ConfigurationINTMode Property

IRD

Lm76ConfigurationINTMode Property

Configuration: INT Mode

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm76TypeConfigIntMode ConfigurationINTMode { get; set; }
Public Property ConfigurationINTMode As Lm76TypeConfigIntMode
    Get
    Set
public:
property Lm76TypeConfigIntMode ConfigurationINTMode {
    Lm76TypeConfigIntMode get ();
    void set (Lm76TypeConfigIntMode value);
}
member ConfigurationINTMode : Lm76TypeConfigIntMode with get, set

Property Value

Type: Lm76TypeConfigIntMode
See Also

Reference

Lm76 Class
telos.Ird.NationalSemiconductor Namespace


Lm76.ConfigurationINTPolarity Property

IRD

Lm76ConfigurationINTPolarity Property

Configuration: INT Polarity

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm76TypeConfigPolarity ConfigurationINTPolarity { get; set; }
Public Property ConfigurationINTPolarity As Lm76TypeConfigPolarity
    Get
    Set
public:
property Lm76TypeConfigPolarity ConfigurationINTPolarity {
    Lm76TypeConfigPolarity get ();
    void set (Lm76TypeConfigPolarity value);
}
member ConfigurationINTPolarity : Lm76TypeConfigPolarity with get, set

Property Value

Type: Lm76TypeConfigPolarity
See Also

Reference

Lm76 Class
telos.Ird.NationalSemiconductor Namespace


Lm76.ConfigurationShutdown Property

IRD

Lm76ConfigurationShutdown Property

Configuration: Shutdown

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm76TypeConfigShutdown ConfigurationShutdown { get; set; }
Public Property ConfigurationShutdown As Lm76TypeConfigShutdown
    Get
    Set
public:
property Lm76TypeConfigShutdown ConfigurationShutdown {
    Lm76TypeConfigShutdown get ();
    void set (Lm76TypeConfigShutdown value);
}
member ConfigurationShutdown : Lm76TypeConfigShutdown with get, set

Property Value

Type: Lm76TypeConfigShutdown
See Also

Reference

Lm76 Class
telos.Ird.NationalSemiconductor Namespace


Lm76.ConfigurationTCRITAPolarity Property

IRD

Lm76ConfigurationTCRITAPolarity Property

Configuration: T_CRIT_A Polarity

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm76TypeConfigPolarity ConfigurationTCRITAPolarity { get; set; }
Public Property ConfigurationTCRITAPolarity As Lm76TypeConfigPolarity
    Get
    Set
public:
property Lm76TypeConfigPolarity ConfigurationTCRITAPolarity {
    Lm76TypeConfigPolarity get ();
    void set (Lm76TypeConfigPolarity value);
}
member ConfigurationTCRITAPolarity : Lm76TypeConfigPolarity with get, set

Property Value

Type: Lm76TypeConfigPolarity
See Also

Reference

Lm76 Class
telos.Ird.NationalSemiconductor Namespace


Lm76.StatusCRIT Property

IRD

Lm76StatusCRIT Property

Status: CRIT

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm76TypeTriggered StatusCRIT { get; }
Public ReadOnly Property StatusCRIT As Lm76TypeTriggered
    Get
public:
property Lm76TypeTriggered StatusCRIT {
    Lm76TypeTriggered get ();
}
member StatusCRIT : Lm76TypeTriggered with get

Property Value

Type: Lm76TypeTriggered
See Also

Reference

Lm76 Class
telos.Ird.NationalSemiconductor Namespace


Lm76.StatusHIGH Property

IRD

Lm76StatusHIGH Property

Status: HIGH

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm76TypeTriggered StatusHIGH { get; }
Public ReadOnly Property StatusHIGH As Lm76TypeTriggered
    Get
public:
property Lm76TypeTriggered StatusHIGH {
    Lm76TypeTriggered get ();
}
member StatusHIGH : Lm76TypeTriggered with get

Property Value

Type: Lm76TypeTriggered
See Also

Reference

Lm76 Class
telos.Ird.NationalSemiconductor Namespace


Lm76.StatusLOW Property

IRD

Lm76StatusLOW Property

Status: LOW

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm76TypeTriggered StatusLOW { get; }
Public ReadOnly Property StatusLOW As Lm76TypeTriggered
    Get
public:
property Lm76TypeTriggered StatusLOW {
    Lm76TypeTriggered get ();
}
member StatusLOW : Lm76TypeTriggered with get

Property Value

Type: Lm76TypeTriggered
See Also

Reference

Lm76 Class
telos.Ird.NationalSemiconductor Namespace


Lm76.TCRIT Property

IRD

Lm76TCRIT Property

T_CRIT (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TCRIT { get; set; }
Public Property TCRIT As Double
    Get
    Set
public:
property double TCRIT {
    double get ();
    void set (double value);
}
member TCRIT : float with get, set

Property Value

Type: Double
See Also

Reference

Lm76 Class
telos.Ird.NationalSemiconductor Namespace


Lm76.Temperature Property

IRD

Lm76Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Lm76 Class
telos.Ird.NationalSemiconductor Namespace


Lm76.THIGH Property

IRD

Lm76THIGH Property

T_HIGH (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double THIGH { get; set; }
Public Property THIGH As Double
    Get
    Set
public:
property double THIGH {
    double get ();
    void set (double value);
}
member THIGH : float with get, set

Property Value

Type: Double
See Also

Reference

Lm76 Class
telos.Ird.NationalSemiconductor Namespace


Lm76.THYST Property

IRD

Lm76THYST Property

T_HYST (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double THYST { get; set; }
Public Property THYST As Double
    Get
    Set
public:
property double THYST {
    double get ();
    void set (double value);
}
member THYST : float with get, set

Property Value

Type: Double
See Also

Reference

Lm76 Class
telos.Ird.NationalSemiconductor Namespace


Lm76.TLOW Property

IRD

Lm76TLOW Property

T_LOW (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TLOW { get; set; }
Public Property TLOW As Double
    Get
    Set
public:
property double TLOW {
    double get ();
    void set (double value);
}
member TLOW : float with get, set

Property Value

Type: Double
See Also

Reference

Lm76 Class
telos.Ird.NationalSemiconductor Namespace


Lm76 Methods

The Lm76 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm76 Class
telos.Ird.NationalSemiconductor Namespace


Lm76.Flush Method

IRD

Lm76Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm76 Class
telos.Ird.NationalSemiconductor Namespace


Lm76.TypeConfigFaultQueue Enumeration

IRD

Lm76TypeConfigFaultQueue Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigFaultQueue
Public Enumeration TypeConfigFaultQueue
public enum class TypeConfigFaultQueue
type TypeConfigFaultQueue
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm76.TypeConfigIntMode Enumeration

IRD

Lm76TypeConfigIntMode Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigIntMode
Public Enumeration TypeConfigIntMode
public enum class TypeConfigIntMode
type TypeConfigIntMode
Members
Member name | Value | Description
ComparatorInterruptMode | 0 | Comparator Interrupt Mode
EventInterruptMode | 1 | Event Interrupt Mode
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm76.TypeConfigPolarity Enumeration

IRD

Lm76TypeConfigPolarity Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigPolarity
Public Enumeration TypeConfigPolarity
public enum class TypeConfigPolarity
type TypeConfigPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm76.TypeConfigShutdown Enumeration

IRD

Lm76TypeConfigShutdown Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigShutdown
Public Enumeration TypeConfigShutdown
public enum class TypeConfigShutdown
type TypeConfigShutdown
Members
Member name | Value | Description
NormalMode | 0 | Normal Mode
LowPowerShutdownMode | 1 | Low Power Shutdown Mode
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm76.TypeTriggered Enumeration

IRD

Lm76TypeTriggered Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTriggered
Public Enumeration TypeTriggered
public enum class TypeTriggered
type TypeTriggered
Members
Member name | Value | Description
NotTriggered | 0 | Not Triggered
Triggered | 1 | Triggered
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm77 Class

National Semiconductor: LM 77
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm77

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm77
Public Class Lm77
public ref class Lm77
type Lm77 =  class end

The Lm77 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm77 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationINTMode | Configuration: INT Mode
Public property | ConfigurationINTPolarity | Configuration: INT Polarity
Public property | ConfigurationShutdown | Configuration: Shutdown
Public property | ConfigurationTCRITAPolarity | Configuration: T_CRIT_A Polarity
Public property | StatusCRIT | Status: CRIT
Public property | StatusHIGH | Status: HIGH
Public property | StatusLOW | Status: LOW
Public property | TCRIT | T_CRIT (unit: °C)
Public property | Temperature | Temperature (unit: °C)
Public property | THIGH | T_HIGH (unit: °C)
Public property | THYST | T_HYST (unit: °C)
Public property | TLOW | T_LOW (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
9-Bit + Sign Digital Temperature Sensor and Thermal Window Comparator with Two-Wire Interface
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm77 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm77(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm77(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm77

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm77 Class
telos.Ird.NationalSemiconductor Namespace


Lm77 Properties

The Lm77 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationINTMode | Configuration: INT Mode
Public property | ConfigurationINTPolarity | Configuration: INT Polarity
Public property | ConfigurationShutdown | Configuration: Shutdown
Public property | ConfigurationTCRITAPolarity | Configuration: T_CRIT_A Polarity
Public property | StatusCRIT | Status: CRIT
Public property | StatusHIGH | Status: HIGH
Public property | StatusLOW | Status: LOW
Public property | TCRIT | T_CRIT (unit: °C)
Public property | Temperature | Temperature (unit: °C)
Public property | THIGH | T_HIGH (unit: °C)
Public property | THYST | T_HYST (unit: °C)
Public property | TLOW | T_LOW (unit: °C)
Top
See Also

Reference

Lm77 Class
telos.Ird.NationalSemiconductor Namespace


Lm77.AutoFlush Property

IRD

Lm77AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm77 Class
telos.Ird.NationalSemiconductor Namespace


Lm77.ConfigurationFaultQueue Property

IRD

Lm77ConfigurationFaultQueue Property

Configuration: Fault Queue

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm77TypeConfigFaultQueue ConfigurationFaultQueue { get; set; }
Public Property ConfigurationFaultQueue As Lm77TypeConfigFaultQueue
    Get
    Set
public:
property Lm77TypeConfigFaultQueue ConfigurationFaultQueue {
    Lm77TypeConfigFaultQueue get ();
    void set (Lm77TypeConfigFaultQueue value);
}
member ConfigurationFaultQueue : Lm77TypeConfigFaultQueue with get, set

Property Value

Type: Lm77TypeConfigFaultQueue
See Also

Reference

Lm77 Class
telos.Ird.NationalSemiconductor Namespace


Lm77.ConfigurationINTMode Property

IRD

Lm77ConfigurationINTMode Property

Configuration: INT Mode

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm77TypeConfigIntMode ConfigurationINTMode { get; set; }
Public Property ConfigurationINTMode As Lm77TypeConfigIntMode
    Get
    Set
public:
property Lm77TypeConfigIntMode ConfigurationINTMode {
    Lm77TypeConfigIntMode get ();
    void set (Lm77TypeConfigIntMode value);
}
member ConfigurationINTMode : Lm77TypeConfigIntMode with get, set

Property Value

Type: Lm77TypeConfigIntMode
See Also

Reference

Lm77 Class
telos.Ird.NationalSemiconductor Namespace


Lm77.ConfigurationINTPolarity Property

IRD

Lm77ConfigurationINTPolarity Property

Configuration: INT Polarity

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm77TypeConfigPolarity ConfigurationINTPolarity { get; set; }
Public Property ConfigurationINTPolarity As Lm77TypeConfigPolarity
    Get
    Set
public:
property Lm77TypeConfigPolarity ConfigurationINTPolarity {
    Lm77TypeConfigPolarity get ();
    void set (Lm77TypeConfigPolarity value);
}
member ConfigurationINTPolarity : Lm77TypeConfigPolarity with get, set

Property Value

Type: Lm77TypeConfigPolarity
See Also

Reference

Lm77 Class
telos.Ird.NationalSemiconductor Namespace


Lm77.ConfigurationShutdown Property

IRD

Lm77ConfigurationShutdown Property

Configuration: Shutdown

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm77TypeConfigShutdown ConfigurationShutdown { get; set; }
Public Property ConfigurationShutdown As Lm77TypeConfigShutdown
    Get
    Set
public:
property Lm77TypeConfigShutdown ConfigurationShutdown {
    Lm77TypeConfigShutdown get ();
    void set (Lm77TypeConfigShutdown value);
}
member ConfigurationShutdown : Lm77TypeConfigShutdown with get, set

Property Value

Type: Lm77TypeConfigShutdown
See Also

Reference

Lm77 Class
telos.Ird.NationalSemiconductor Namespace


Lm77.ConfigurationTCRITAPolarity Property

IRD

Lm77ConfigurationTCRITAPolarity Property

Configuration: T_CRIT_A Polarity

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm77TypeConfigPolarity ConfigurationTCRITAPolarity { get; set; }
Public Property ConfigurationTCRITAPolarity As Lm77TypeConfigPolarity
    Get
    Set
public:
property Lm77TypeConfigPolarity ConfigurationTCRITAPolarity {
    Lm77TypeConfigPolarity get ();
    void set (Lm77TypeConfigPolarity value);
}
member ConfigurationTCRITAPolarity : Lm77TypeConfigPolarity with get, set

Property Value

Type: Lm77TypeConfigPolarity
See Also

Reference

Lm77 Class
telos.Ird.NationalSemiconductor Namespace


Lm77.StatusCRIT Property

IRD

Lm77StatusCRIT Property

Status: CRIT

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm77TypeTriggered StatusCRIT { get; }
Public ReadOnly Property StatusCRIT As Lm77TypeTriggered
    Get
public:
property Lm77TypeTriggered StatusCRIT {
    Lm77TypeTriggered get ();
}
member StatusCRIT : Lm77TypeTriggered with get

Property Value

Type: Lm77TypeTriggered
See Also

Reference

Lm77 Class
telos.Ird.NationalSemiconductor Namespace


Lm77.StatusHIGH Property

IRD

Lm77StatusHIGH Property

Status: HIGH

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm77TypeTriggered StatusHIGH { get; }
Public ReadOnly Property StatusHIGH As Lm77TypeTriggered
    Get
public:
property Lm77TypeTriggered StatusHIGH {
    Lm77TypeTriggered get ();
}
member StatusHIGH : Lm77TypeTriggered with get

Property Value

Type: Lm77TypeTriggered
See Also

Reference

Lm77 Class
telos.Ird.NationalSemiconductor Namespace


Lm77.StatusLOW Property

IRD

Lm77StatusLOW Property

Status: LOW

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm77TypeTriggered StatusLOW { get; }
Public ReadOnly Property StatusLOW As Lm77TypeTriggered
    Get
public:
property Lm77TypeTriggered StatusLOW {
    Lm77TypeTriggered get ();
}
member StatusLOW : Lm77TypeTriggered with get

Property Value

Type: Lm77TypeTriggered
See Also

Reference

Lm77 Class
telos.Ird.NationalSemiconductor Namespace


Lm77.TCRIT Property

IRD

Lm77TCRIT Property

T_CRIT (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TCRIT { get; set; }
Public Property TCRIT As Double
    Get
    Set
public:
property double TCRIT {
    double get ();
    void set (double value);
}
member TCRIT : float with get, set

Property Value

Type: Double
See Also

Reference

Lm77 Class
telos.Ird.NationalSemiconductor Namespace


Lm77.Temperature Property

IRD

Lm77Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Lm77 Class
telos.Ird.NationalSemiconductor Namespace


Lm77.THIGH Property

IRD

Lm77THIGH Property

T_HIGH (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double THIGH { get; set; }
Public Property THIGH As Double
    Get
    Set
public:
property double THIGH {
    double get ();
    void set (double value);
}
member THIGH : float with get, set

Property Value

Type: Double
See Also

Reference

Lm77 Class
telos.Ird.NationalSemiconductor Namespace


Lm77.THYST Property

IRD

Lm77THYST Property

T_HYST (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double THYST { get; set; }
Public Property THYST As Double
    Get
    Set
public:
property double THYST {
    double get ();
    void set (double value);
}
member THYST : float with get, set

Property Value

Type: Double
See Also

Reference

Lm77 Class
telos.Ird.NationalSemiconductor Namespace


Lm77.TLOW Property

IRD

Lm77TLOW Property

T_LOW (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TLOW { get; set; }
Public Property TLOW As Double
    Get
    Set
public:
property double TLOW {
    double get ();
    void set (double value);
}
member TLOW : float with get, set

Property Value

Type: Double
See Also

Reference

Lm77 Class
telos.Ird.NationalSemiconductor Namespace


Lm77 Methods

The Lm77 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm77 Class
telos.Ird.NationalSemiconductor Namespace


Lm77.Flush Method

IRD

Lm77Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm77 Class
telos.Ird.NationalSemiconductor Namespace


Lm77.TypeConfigFaultQueue Enumeration

IRD

Lm77TypeConfigFaultQueue Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigFaultQueue
Public Enumeration TypeConfigFaultQueue
public enum class TypeConfigFaultQueue
type TypeConfigFaultQueue
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm77.TypeConfigIntMode Enumeration

IRD

Lm77TypeConfigIntMode Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigIntMode
Public Enumeration TypeConfigIntMode
public enum class TypeConfigIntMode
type TypeConfigIntMode
Members
Member name | Value | Description
ComparatorInterruptMode | 0 | Comparator Interrupt Mode
EventInterruptMode | 1 | Event Interrupt Mode
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm77.TypeConfigPolarity Enumeration

IRD

Lm77TypeConfigPolarity Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigPolarity
Public Enumeration TypeConfigPolarity
public enum class TypeConfigPolarity
type TypeConfigPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm77.TypeConfigShutdown Enumeration

IRD

Lm77TypeConfigShutdown Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigShutdown
Public Enumeration TypeConfigShutdown
public enum class TypeConfigShutdown
type TypeConfigShutdown
Members
Member name | Value | Description
NormalMode | 0 | Normal Mode
LowPowerShutdownMode | 1 | Low Power Shutdown Mode
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm77.TypeTriggered Enumeration

IRD

Lm77TypeTriggered Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTriggered
Public Enumeration TypeTriggered
public enum class TypeTriggered
type TypeTriggered
Members
Member name | Value | Description
NotTriggered | 0 | Not Triggered
Triggered | 1 | Triggered
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm82 Class

National Semiconductor: LM 82
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm82

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm82
Public Class Lm82
public ref class Lm82
type Lm82 =  class end

The Lm82 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm82 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationINTInversion | Configuration (INT Inversion)
Public property | ConfigurationINTMask | Configuration (INT Mask)
Public property | ConfigurationLocalTCRITAMask | Configuration (Local T_CRIT_A Mask)
Public property | ConfigurationRemoteTCRITAMaskD3 | Configuration (Remote T_CRIT_A Mask, D3)
Public property | ConfigurationRemoteTCRITAMaskD4 | Configuration (Remote T_CRIT_A Mask, D4)
Public property | ConfigurationRemoteTCRITAMaskD5 | Configuration (Remote T_CRIT_A Mask, D5)
Public property | LocalHIGHSetpoint | Local HIGH Setpoint (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | RemoteHIGHSetpoint | Remote HIGH Setpoint (unit: °C)
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | StatusLCRIT | Status (LCRIT)
Public property | StatusLHIGH | Status (LHIGH)
Public property | StatusOPEN | Status (OPEN)
Public property | StatusRCRIT | Status (RCRIT)
Public property | StatusRHIGH | Status (RHIGH)
Public property | SteppingDieRevisionCode | Stepping / Die Revision Code
Public property | TCRITSetpoint | T_CRIT Setpoint (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Remote-Diode And Local Digital Temperature Sensor
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm82 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm82(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm82(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm82

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82 Properties

The Lm82 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationINTInversion | Configuration (INT Inversion)
Public property | ConfigurationINTMask | Configuration (INT Mask)
Public property | ConfigurationLocalTCRITAMask | Configuration (Local T_CRIT_A Mask)
Public property | ConfigurationRemoteTCRITAMaskD3 | Configuration (Remote T_CRIT_A Mask, D3)
Public property | ConfigurationRemoteTCRITAMaskD4 | Configuration (Remote T_CRIT_A Mask, D4)
Public property | ConfigurationRemoteTCRITAMaskD5 | Configuration (Remote T_CRIT_A Mask, D5)
Public property | LocalHIGHSetpoint | Local HIGH Setpoint (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | RemoteHIGHSetpoint | Remote HIGH Setpoint (unit: °C)
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | StatusLCRIT | Status (LCRIT)
Public property | StatusLHIGH | Status (LHIGH)
Public property | StatusOPEN | Status (OPEN)
Public property | StatusRCRIT | Status (RCRIT)
Public property | StatusRHIGH | Status (RHIGH)
Public property | SteppingDieRevisionCode | Stepping / Die Revision Code
Public property | TCRITSetpoint | T_CRIT Setpoint (unit: °C)
Top
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.AutoFlush Property

IRD

Lm82AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.ConfigurationINTInversion Property

IRD

Lm82ConfigurationINTInversion Property

Configuration (INT Inversion)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm82ConfigIntInversionType ConfigurationINTInversion { get; set; }
Public Property ConfigurationINTInversion As Lm82ConfigIntInversionType
    Get
    Set
public:
property Lm82ConfigIntInversionType ConfigurationINTInversion {
    Lm82ConfigIntInversionType get ();
    void set (Lm82ConfigIntInversionType value);
}
member ConfigurationINTInversion : Lm82ConfigIntInversionType with get, set

Property Value

Type: Lm82ConfigIntInversionType
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.ConfigurationINTMask Property

IRD

Lm82ConfigurationINTMask Property

Configuration (INT Mask)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm82ConfigMaskType ConfigurationINTMask { get; set; }
Public Property ConfigurationINTMask As Lm82ConfigMaskType
    Get
    Set
public:
property Lm82ConfigMaskType ConfigurationINTMask {
    Lm82ConfigMaskType get ();
    void set (Lm82ConfigMaskType value);
}
member ConfigurationINTMask : Lm82ConfigMaskType with get, set

Property Value

Type: Lm82ConfigMaskType
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.ConfigurationLocalTCRITAMask Property

IRD

Lm82ConfigurationLocalTCRITAMask Property

Configuration (Local T_CRIT_A Mask)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm82ConfigMaskType ConfigurationLocalTCRITAMask { get; set; }
Public Property ConfigurationLocalTCRITAMask As Lm82ConfigMaskType
    Get
    Set
public:
property Lm82ConfigMaskType ConfigurationLocalTCRITAMask {
    Lm82ConfigMaskType get ();
    void set (Lm82ConfigMaskType value);
}
member ConfigurationLocalTCRITAMask : Lm82ConfigMaskType with get, set

Property Value

Type: Lm82ConfigMaskType
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.ConfigurationRemoteTCRITAMaskD3 Property

IRD

Lm82ConfigurationRemoteTCRITAMaskD3 Property

Configuration (Remote T_CRIT_A Mask, D3)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ConfigurationRemoteTCRITAMaskD3 { get; set; }
Public Property ConfigurationRemoteTCRITAMaskD3 As Byte
    Get
    Set
public:
property unsigned char ConfigurationRemoteTCRITAMaskD3 {
    unsigned char get ();
    void set (unsigned char value);
}
member ConfigurationRemoteTCRITAMaskD3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.ConfigurationRemoteTCRITAMaskD4 Property

IRD

Lm82ConfigurationRemoteTCRITAMaskD4 Property

Configuration (Remote T_CRIT_A Mask, D4)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm82ConfigMaskType ConfigurationRemoteTCRITAMaskD4 { get; set; }
Public Property ConfigurationRemoteTCRITAMaskD4 As Lm82ConfigMaskType
    Get
    Set
public:
property Lm82ConfigMaskType ConfigurationRemoteTCRITAMaskD4 {
    Lm82ConfigMaskType get ();
    void set (Lm82ConfigMaskType value);
}
member ConfigurationRemoteTCRITAMaskD4 : Lm82ConfigMaskType with get, set

Property Value

Type: Lm82ConfigMaskType
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.ConfigurationRemoteTCRITAMaskD5 Property

IRD

Lm82ConfigurationRemoteTCRITAMaskD5 Property

Configuration (Remote T_CRIT_A Mask, D5)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ConfigurationRemoteTCRITAMaskD5 { get; set; }
Public Property ConfigurationRemoteTCRITAMaskD5 As Byte
    Get
    Set
public:
property unsigned char ConfigurationRemoteTCRITAMaskD5 {
    unsigned char get ();
    void set (unsigned char value);
}
member ConfigurationRemoteTCRITAMaskD5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.LocalHIGHSetpoint Property

IRD

Lm82LocalHIGHSetpoint Property

Local HIGH Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalHIGHSetpoint { get; set; }
Public Property LocalHIGHSetpoint As SByte
    Get
    Set
public:
property signed char LocalHIGHSetpoint {
    signed char get ();
    void set (signed char value);
}
member LocalHIGHSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.LocalTemperature Property

IRD

Lm82LocalTemperature Property

Local Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTemperature { get; }
Public ReadOnly Property LocalTemperature As SByte
    Get
public:
property signed char LocalTemperature {
    signed char get ();
}
member LocalTemperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.ManufacturerID Property

IRD

Lm82ManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As Byte
    Get
public:
property unsigned char ManufacturerID {
    unsigned char get ();
}
member ManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.RemoteHIGHSetpoint Property

IRD

Lm82RemoteHIGHSetpoint Property

Remote HIGH Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteHIGHSetpoint { get; set; }
Public Property RemoteHIGHSetpoint As SByte
    Get
    Set
public:
property signed char RemoteHIGHSetpoint {
    signed char get ();
    void set (signed char value);
}
member RemoteHIGHSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.RemoteTemperature Property

IRD

Lm82RemoteTemperature Property

Remote Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTemperature { get; }
Public ReadOnly Property RemoteTemperature As SByte
    Get
public:
property signed char RemoteTemperature {
    signed char get ();
}
member RemoteTemperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.StatusLCRIT Property

IRD

Lm82StatusLCRIT Property

Status (LCRIT)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm82StatusTcritType StatusLCRIT { get; }
Public ReadOnly Property StatusLCRIT As Lm82StatusTcritType
    Get
public:
property Lm82StatusTcritType StatusLCRIT {
    Lm82StatusTcritType get ();
}
member StatusLCRIT : Lm82StatusTcritType with get

Property Value

Type: Lm82StatusTcritType
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.StatusLHIGH Property

IRD

Lm82StatusLHIGH Property

Status (LHIGH)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm82StatusThighType StatusLHIGH { get; }
Public ReadOnly Property StatusLHIGH As Lm82StatusThighType
    Get
public:
property Lm82StatusThighType StatusLHIGH {
    Lm82StatusThighType get ();
}
member StatusLHIGH : Lm82StatusThighType with get

Property Value

Type: Lm82StatusThighType
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.StatusOPEN Property

IRD

Lm82StatusOPEN Property

Status (OPEN)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm82StatusOpenType StatusOPEN { get; }
Public ReadOnly Property StatusOPEN As Lm82StatusOpenType
    Get
public:
property Lm82StatusOpenType StatusOPEN {
    Lm82StatusOpenType get ();
}
member StatusOPEN : Lm82StatusOpenType with get

Property Value

Type: Lm82StatusOpenType
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.StatusRCRIT Property

IRD

Lm82StatusRCRIT Property

Status (RCRIT)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm82StatusTcritType StatusRCRIT { get; }
Public ReadOnly Property StatusRCRIT As Lm82StatusTcritType
    Get
public:
property Lm82StatusTcritType StatusRCRIT {
    Lm82StatusTcritType get ();
}
member StatusRCRIT : Lm82StatusTcritType with get

Property Value

Type: Lm82StatusTcritType
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.StatusRHIGH Property

IRD

Lm82StatusRHIGH Property

Status (RHIGH)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm82StatusThighType StatusRHIGH { get; }
Public ReadOnly Property StatusRHIGH As Lm82StatusThighType
    Get
public:
property Lm82StatusThighType StatusRHIGH {
    Lm82StatusThighType get ();
}
member StatusRHIGH : Lm82StatusThighType with get

Property Value

Type: Lm82StatusThighType
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.SteppingDieRevisionCode Property

IRD

Lm82SteppingDieRevisionCode Property

Stepping / Die Revision Code

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SteppingDieRevisionCode { get; }
Public ReadOnly Property SteppingDieRevisionCode As Byte
    Get
public:
property unsigned char SteppingDieRevisionCode {
    unsigned char get ();
}
member SteppingDieRevisionCode : byte with get

Property Value

Type: Byte
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.TCRITSetpoint Property

IRD

Lm82TCRITSetpoint Property

T_CRIT Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte TCRITSetpoint { get; set; }
Public Property TCRITSetpoint As SByte
    Get
    Set
public:
property signed char TCRITSetpoint {
    signed char get ();
    void set (signed char value);
}
member TCRITSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82 Methods

The Lm82 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.Flush Method

IRD

Lm82Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm82 Class
telos.Ird.NationalSemiconductor Namespace


Lm82.ConfigIntInversionType Enumeration

IRD

Lm82ConfigIntInversionType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigIntInversionType
Public Enumeration ConfigIntInversionType
public enum class ConfigIntInversionType
type ConfigIntInversionType
Members
Member name | Value | Description
INTOutputActiveHigh | 1 | INT Output: Active High
INTOutputActiveLow | 0 | INT Output: Active Low
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm82.ConfigMaskType Enumeration

IRD

Lm82ConfigMaskType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigMaskType
Public Enumeration ConfigMaskType
public enum class ConfigMaskType
type ConfigMaskType
Members
Member name | Value | Description
Masked | 1 | Masked
NotMasked | 0 | Not Masked
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm82.StatusOpenType Enumeration

IRD

Lm82StatusOpenType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusOpenType
Public Enumeration StatusOpenType
public enum class StatusOpenType
type StatusOpenType
Members
Member name | Value | Description
RemoteDiodeDisconnected | 1 | Remote Diode: Disconnected
RemoteDiodeConnected | 0 | Remote Diode: Connected
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm82.StatusTcritType Enumeration

IRD

Lm82StatusTcritType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusTcritType
Public Enumeration StatusTcritType
public enum class StatusTcritType
type StatusTcritType
Members
Member name | Value | Description
CriticalTemperatureAlarmTrue | 1 | Critical Temperature Alarm: True
CriticalTemperatureAlarmFalse | 0 | Critical Temperature Alarm: False
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm82.StatusThighType Enumeration

IRD

Lm82StatusThighType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusThighType
Public Enumeration StatusThighType
public enum class StatusThighType
type StatusThighType
Members
Member name | Value | Description
HIGHTemperatureAlarmTrue | 1 | HIGH Temperature Alarm: True
HIGHTemperatureAlarmFalse | 0 | HIGH Temperature Alarm: False
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm83 Class

National Semiconductor: LM 83
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm83

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm83
Public Class Lm83
public ref class Lm83
type Lm83 =  class end

The Lm83 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm83 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationD1TCRITAMask | Configuration (D1 T_CRIT_A Mask)
Public property | ConfigurationD2TCRITAMask | Configuration (D2 T_CRIT_A Mask)
Public property | ConfigurationD3TCRITAMask | Configuration (D3 T_CRIT_A Mask)
Public property | ConfigurationINTInversion | Configuration (INT Inversion)
Public property | ConfigurationINTMask | Configuration (INT Mask)
Public property | ConfigurationLocalTCRITAMask | Configuration (Local T_CRIT_A Mask)
Public property | D1RemoteHIGHSetpoint | D1 Remote HIGH Setpoint (unit: °C)
Public property | D1RemoteTemperature | D1 Remote Temperature (unit: °C)
Public property | D2RemoteHIGHSetpoint | D2 Remote HIGH Setpoint (unit: °C)
Public property | D2RemoteTemperature | D2 Remote Temperature (unit: °C)
Public property | D3RemoteHIGHSetpoint | D3 Remote HIGH Setpoint (unit: °C)
Public property | D3RemoteTemperature | D3 Remote Temperature (unit: °C)
Public property | LocalHIGHSetpoint | Local HIGH Setpoint (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturersID | Manufacturers ID
Public property | Status1D2CRIT | Status 1 (D2CRIT)
Public property | Status1D2OPEN | Status 1 (D2OPEN)
Public property | Status1D2RHIGH | Status 1 (D2RHIGH)
Public property | Status1LCRIT | Status 1 (LCRIT)
Public property | Status1LHIGH | Status 1 (LHIGH)
Public property | Status2D1CRIT | Status 2 (D1CRIT)
Public property | Status2D1OPEN | Status 2 (D1OPEN)
Public property | Status2D1RHIGH | Status 2 (D1RHIGH)
Public property | Status2D3CRIT | Status 2 (D3CRIT)
Public property | Status2D3OPEN | Status 2 (D3OPEN)
Public property | Status2D3RHIGH | Status 2 (D3RHIGH)
Public property | SteppingDieRevisionCode | Stepping / Die Revision Code
Public property | TCRITSetpoint | T_CRIT Setpoint (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Triple-Diode Input And Local Digital Temperature Sensor
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm83 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm83(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm83(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm83

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83 Properties

The Lm83 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationD1TCRITAMask | Configuration (D1 T_CRIT_A Mask)
Public property | ConfigurationD2TCRITAMask | Configuration (D2 T_CRIT_A Mask)
Public property | ConfigurationD3TCRITAMask | Configuration (D3 T_CRIT_A Mask)
Public property | ConfigurationINTInversion | Configuration (INT Inversion)
Public property | ConfigurationINTMask | Configuration (INT Mask)
Public property | ConfigurationLocalTCRITAMask | Configuration (Local T_CRIT_A Mask)
Public property | D1RemoteHIGHSetpoint | D1 Remote HIGH Setpoint (unit: °C)
Public property | D1RemoteTemperature | D1 Remote Temperature (unit: °C)
Public property | D2RemoteHIGHSetpoint | D2 Remote HIGH Setpoint (unit: °C)
Public property | D2RemoteTemperature | D2 Remote Temperature (unit: °C)
Public property | D3RemoteHIGHSetpoint | D3 Remote HIGH Setpoint (unit: °C)
Public property | D3RemoteTemperature | D3 Remote Temperature (unit: °C)
Public property | LocalHIGHSetpoint | Local HIGH Setpoint (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturersID | Manufacturers ID
Public property | Status1D2CRIT | Status 1 (D2CRIT)
Public property | Status1D2OPEN | Status 1 (D2OPEN)
Public property | Status1D2RHIGH | Status 1 (D2RHIGH)
Public property | Status1LCRIT | Status 1 (LCRIT)
Public property | Status1LHIGH | Status 1 (LHIGH)
Public property | Status2D1CRIT | Status 2 (D1CRIT)
Public property | Status2D1OPEN | Status 2 (D1OPEN)
Public property | Status2D1RHIGH | Status 2 (D1RHIGH)
Public property | Status2D3CRIT | Status 2 (D3CRIT)
Public property | Status2D3OPEN | Status 2 (D3OPEN)
Public property | Status2D3RHIGH | Status 2 (D3RHIGH)
Public property | SteppingDieRevisionCode | Stepping / Die Revision Code
Public property | TCRITSetpoint | T_CRIT Setpoint (unit: °C)
Top
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.AutoFlush Property

IRD

Lm83AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.ConfigurationD1TCRITAMask Property

IRD

Lm83ConfigurationD1TCRITAMask Property

Configuration (D1 T_CRIT_A Mask)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm83ConfigTcritaType ConfigurationD1TCRITAMask { get; set; }
Public Property ConfigurationD1TCRITAMask As Lm83ConfigTcritaType
    Get
    Set
public:
property Lm83ConfigTcritaType ConfigurationD1TCRITAMask {
    Lm83ConfigTcritaType get ();
    void set (Lm83ConfigTcritaType value);
}
member ConfigurationD1TCRITAMask : Lm83ConfigTcritaType with get, set

Property Value

Type: Lm83ConfigTcritaType
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.ConfigurationD2TCRITAMask Property

IRD

Lm83ConfigurationD2TCRITAMask Property

Configuration (D2 T_CRIT_A Mask)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm83ConfigTcritaType ConfigurationD2TCRITAMask { get; set; }
Public Property ConfigurationD2TCRITAMask As Lm83ConfigTcritaType
    Get
    Set
public:
property Lm83ConfigTcritaType ConfigurationD2TCRITAMask {
    Lm83ConfigTcritaType get ();
    void set (Lm83ConfigTcritaType value);
}
member ConfigurationD2TCRITAMask : Lm83ConfigTcritaType with get, set

Property Value

Type: Lm83ConfigTcritaType
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.ConfigurationD3TCRITAMask Property

IRD

Lm83ConfigurationD3TCRITAMask Property

Configuration (D3 T_CRIT_A Mask)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm83ConfigTcritaType ConfigurationD3TCRITAMask { get; set; }
Public Property ConfigurationD3TCRITAMask As Lm83ConfigTcritaType
    Get
    Set
public:
property Lm83ConfigTcritaType ConfigurationD3TCRITAMask {
    Lm83ConfigTcritaType get ();
    void set (Lm83ConfigTcritaType value);
}
member ConfigurationD3TCRITAMask : Lm83ConfigTcritaType with get, set

Property Value

Type: Lm83ConfigTcritaType
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.ConfigurationINTInversion Property

IRD

Lm83ConfigurationINTInversion Property

Configuration (INT Inversion)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm83ConfigIntInvType ConfigurationINTInversion { get; set; }
Public Property ConfigurationINTInversion As Lm83ConfigIntInvType
    Get
    Set
public:
property Lm83ConfigIntInvType ConfigurationINTInversion {
    Lm83ConfigIntInvType get ();
    void set (Lm83ConfigIntInvType value);
}
member ConfigurationINTInversion : Lm83ConfigIntInvType with get, set

Property Value

Type: Lm83ConfigIntInvType
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.ConfigurationINTMask Property

IRD

Lm83ConfigurationINTMask Property

Configuration (INT Mask)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm83ConfigIntMaskType ConfigurationINTMask { get; set; }
Public Property ConfigurationINTMask As Lm83ConfigIntMaskType
    Get
    Set
public:
property Lm83ConfigIntMaskType ConfigurationINTMask {
    Lm83ConfigIntMaskType get ();
    void set (Lm83ConfigIntMaskType value);
}
member ConfigurationINTMask : Lm83ConfigIntMaskType with get, set

Property Value

Type: Lm83ConfigIntMaskType
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.ConfigurationLocalTCRITAMask Property

IRD

Lm83ConfigurationLocalTCRITAMask Property

Configuration (Local T_CRIT_A Mask)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm83ConfigTcritaType ConfigurationLocalTCRITAMask { get; set; }
Public Property ConfigurationLocalTCRITAMask As Lm83ConfigTcritaType
    Get
    Set
public:
property Lm83ConfigTcritaType ConfigurationLocalTCRITAMask {
    Lm83ConfigTcritaType get ();
    void set (Lm83ConfigTcritaType value);
}
member ConfigurationLocalTCRITAMask : Lm83ConfigTcritaType with get, set

Property Value

Type: Lm83ConfigTcritaType
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.D1RemoteHIGHSetpoint Property

IRD

Lm83D1RemoteHIGHSetpoint Property

D1 Remote HIGH Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte D1RemoteHIGHSetpoint { get; set; }
Public Property D1RemoteHIGHSetpoint As SByte
    Get
    Set
public:
property signed char D1RemoteHIGHSetpoint {
    signed char get ();
    void set (signed char value);
}
member D1RemoteHIGHSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.D1RemoteTemperature Property

IRD

Lm83D1RemoteTemperature Property

D1 Remote Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte D1RemoteTemperature { get; }
Public ReadOnly Property D1RemoteTemperature As SByte
    Get
public:
property signed char D1RemoteTemperature {
    signed char get ();
}
member D1RemoteTemperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.D2RemoteHIGHSetpoint Property

IRD

Lm83D2RemoteHIGHSetpoint Property

D2 Remote HIGH Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte D2RemoteHIGHSetpoint { get; set; }
Public Property D2RemoteHIGHSetpoint As SByte
    Get
    Set
public:
property signed char D2RemoteHIGHSetpoint {
    signed char get ();
    void set (signed char value);
}
member D2RemoteHIGHSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.D2RemoteTemperature Property

IRD

Lm83D2RemoteTemperature Property

D2 Remote Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte D2RemoteTemperature { get; }
Public ReadOnly Property D2RemoteTemperature As SByte
    Get
public:
property signed char D2RemoteTemperature {
    signed char get ();
}
member D2RemoteTemperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.D3RemoteHIGHSetpoint Property

IRD

Lm83D3RemoteHIGHSetpoint Property

D3 Remote HIGH Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte D3RemoteHIGHSetpoint { get; set; }
Public Property D3RemoteHIGHSetpoint As SByte
    Get
    Set
public:
property signed char D3RemoteHIGHSetpoint {
    signed char get ();
    void set (signed char value);
}
member D3RemoteHIGHSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.D3RemoteTemperature Property

IRD

Lm83D3RemoteTemperature Property

D3 Remote Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte D3RemoteTemperature { get; }
Public ReadOnly Property D3RemoteTemperature As SByte
    Get
public:
property signed char D3RemoteTemperature {
    signed char get ();
}
member D3RemoteTemperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.LocalHIGHSetpoint Property

IRD

Lm83LocalHIGHSetpoint Property

Local HIGH Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalHIGHSetpoint { get; set; }
Public Property LocalHIGHSetpoint As SByte
    Get
    Set
public:
property signed char LocalHIGHSetpoint {
    signed char get ();
    void set (signed char value);
}
member LocalHIGHSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.LocalTemperature Property

IRD

Lm83LocalTemperature Property

Local Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTemperature { get; }
Public ReadOnly Property LocalTemperature As SByte
    Get
public:
property signed char LocalTemperature {
    signed char get ();
}
member LocalTemperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.ManufacturersID Property

IRD

Lm83ManufacturersID Property

Manufacturers ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturersID { get; }
Public ReadOnly Property ManufacturersID As Byte
    Get
public:
property unsigned char ManufacturersID {
    unsigned char get ();
}
member ManufacturersID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.Status1D2CRIT Property

IRD

Lm83Status1D2CRIT Property

Status 1 (D2CRIT)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm83Status1TcritType Status1D2CRIT { get; }
Public ReadOnly Property Status1D2CRIT As Lm83Status1TcritType
    Get
public:
property Lm83Status1TcritType Status1D2CRIT {
    Lm83Status1TcritType get ();
}
member Status1D2CRIT : Lm83Status1TcritType with get

Property Value

Type: Lm83Status1TcritType
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.Status1D2OPEN Property

IRD

Lm83Status1D2OPEN Property

Status 1 (D2OPEN)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm83Status1OpenType Status1D2OPEN { get; }
Public ReadOnly Property Status1D2OPEN As Lm83Status1OpenType
    Get
public:
property Lm83Status1OpenType Status1D2OPEN {
    Lm83Status1OpenType get ();
}
member Status1D2OPEN : Lm83Status1OpenType with get

Property Value

Type: Lm83Status1OpenType
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.Status1D2RHIGH Property

IRD

Lm83Status1D2RHIGH Property

Status 1 (D2RHIGH)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm83Status1ThighType Status1D2RHIGH { get; }
Public ReadOnly Property Status1D2RHIGH As Lm83Status1ThighType
    Get
public:
property Lm83Status1ThighType Status1D2RHIGH {
    Lm83Status1ThighType get ();
}
member Status1D2RHIGH : Lm83Status1ThighType with get

Property Value

Type: Lm83Status1ThighType
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.Status1LCRIT Property

IRD

Lm83Status1LCRIT Property

Status 1 (LCRIT)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm83Status1TcritType Status1LCRIT { get; }
Public ReadOnly Property Status1LCRIT As Lm83Status1TcritType
    Get
public:
property Lm83Status1TcritType Status1LCRIT {
    Lm83Status1TcritType get ();
}
member Status1LCRIT : Lm83Status1TcritType with get

Property Value

Type: Lm83Status1TcritType
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.Status1LHIGH Property

IRD

Lm83Status1LHIGH Property

Status 1 (LHIGH)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm83Status1ThighType Status1LHIGH { get; }
Public ReadOnly Property Status1LHIGH As Lm83Status1ThighType
    Get
public:
property Lm83Status1ThighType Status1LHIGH {
    Lm83Status1ThighType get ();
}
member Status1LHIGH : Lm83Status1ThighType with get

Property Value

Type: Lm83Status1ThighType
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.Status2D1CRIT Property

IRD

Lm83Status2D1CRIT Property

Status 2 (D1CRIT)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm83Status1TcritType Status2D1CRIT { get; }
Public ReadOnly Property Status2D1CRIT As Lm83Status1TcritType
    Get
public:
property Lm83Status1TcritType Status2D1CRIT {
    Lm83Status1TcritType get ();
}
member Status2D1CRIT : Lm83Status1TcritType with get

Property Value

Type: Lm83Status1TcritType
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.Status2D1OPEN Property

IRD

Lm83Status2D1OPEN Property

Status 2 (D1OPEN)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm83Status1OpenType Status2D1OPEN { get; }
Public ReadOnly Property Status2D1OPEN As Lm83Status1OpenType
    Get
public:
property Lm83Status1OpenType Status2D1OPEN {
    Lm83Status1OpenType get ();
}
member Status2D1OPEN : Lm83Status1OpenType with get

Property Value

Type: Lm83Status1OpenType
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.Status2D1RHIGH Property

IRD

Lm83Status2D1RHIGH Property

Status 2 (D1RHIGH)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm83Status1ThighType Status2D1RHIGH { get; }
Public ReadOnly Property Status2D1RHIGH As Lm83Status1ThighType
    Get
public:
property Lm83Status1ThighType Status2D1RHIGH {
    Lm83Status1ThighType get ();
}
member Status2D1RHIGH : Lm83Status1ThighType with get

Property Value

Type: Lm83Status1ThighType
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.Status2D3CRIT Property

IRD

Lm83Status2D3CRIT Property

Status 2 (D3CRIT)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm83Status1TcritType Status2D3CRIT { get; }
Public ReadOnly Property Status2D3CRIT As Lm83Status1TcritType
    Get
public:
property Lm83Status1TcritType Status2D3CRIT {
    Lm83Status1TcritType get ();
}
member Status2D3CRIT : Lm83Status1TcritType with get

Property Value

Type: Lm83Status1TcritType
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.Status2D3OPEN Property

IRD

Lm83Status2D3OPEN Property

Status 2 (D3OPEN)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm83Status1OpenType Status2D3OPEN { get; }
Public ReadOnly Property Status2D3OPEN As Lm83Status1OpenType
    Get
public:
property Lm83Status1OpenType Status2D3OPEN {
    Lm83Status1OpenType get ();
}
member Status2D3OPEN : Lm83Status1OpenType with get

Property Value

Type: Lm83Status1OpenType
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.Status2D3RHIGH Property

IRD

Lm83Status2D3RHIGH Property

Status 2 (D3RHIGH)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm83Status1ThighType Status2D3RHIGH { get; }
Public ReadOnly Property Status2D3RHIGH As Lm83Status1ThighType
    Get
public:
property Lm83Status1ThighType Status2D3RHIGH {
    Lm83Status1ThighType get ();
}
member Status2D3RHIGH : Lm83Status1ThighType with get

Property Value

Type: Lm83Status1ThighType
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.SteppingDieRevisionCode Property

IRD

Lm83SteppingDieRevisionCode Property

Stepping / Die Revision Code

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SteppingDieRevisionCode { get; }
Public ReadOnly Property SteppingDieRevisionCode As Byte
    Get
public:
property unsigned char SteppingDieRevisionCode {
    unsigned char get ();
}
member SteppingDieRevisionCode : byte with get

Property Value

Type: Byte
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.TCRITSetpoint Property

IRD

Lm83TCRITSetpoint Property

T_CRIT Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte TCRITSetpoint { get; set; }
Public Property TCRITSetpoint As SByte
    Get
    Set
public:
property signed char TCRITSetpoint {
    signed char get ();
    void set (signed char value);
}
member TCRITSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83 Methods

The Lm83 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.Flush Method

IRD

Lm83Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm83 Class
telos.Ird.NationalSemiconductor Namespace


Lm83.ConfigIntInvType Enumeration

IRD

Lm83ConfigIntInvType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigIntInvType
Public Enumeration ConfigIntInvType
public enum class ConfigIntInvType
type ConfigIntInvType
Members
Member name | Value | Description
INTActiveStateLogicalHigh | 1 | INT Active State: Logical High
INTActiveStateLogicalLow | 0 | INT Active State: Logical Low
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm83.ConfigIntMaskType Enumeration

IRD

Lm83ConfigIntMaskType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigIntMaskType
Public Enumeration ConfigIntMaskType
public enum class ConfigIntMaskType
type ConfigIntMaskType
Members
Member name | Value | Description
INTInterruptsMasked | 1 | INT Interrupts: Masked
INTInterruptsNotMasked | 0 | INT Interrupts: Not Masked
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm83.ConfigTcritaType Enumeration

IRD

Lm83ConfigTcritaType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigTcritaType
Public Enumeration ConfigTcritaType
public enum class ConfigTcritaType
type ConfigTcritaType
Members
Member name | Value | Description
TCRITAInterruptsMasked | 1 | T_CRIT_A Interrupts: Masked
TCRITAInterruptsNotMasked | 0 | T_CRIT_A Interrupts: Not Masked
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm83.Status1OpenType Enumeration

IRD

Lm83Status1OpenType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Status1OpenType
Public Enumeration Status1OpenType
public enum class Status1OpenType
type Status1OpenType
Members
Member name | Value | Description
RemoteDiodeDisconnected | 1 | Remote Diode: Disconnected
RemoteDiodeConnected | 0 | Remote Diode: Connected
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm83.Status1TcritType Enumeration

IRD

Lm83Status1TcritType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Status1TcritType
Public Enumeration Status1TcritType
public enum class Status1TcritType
type Status1TcritType
Members
Member name | Value | Description
CriticalAlarmTrue | 1 | Critical Alarm: True
CriticalAlarmFalse | 0 | Critical Alarm: False
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm83.Status1ThighType Enumeration

IRD

Lm83Status1ThighType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Status1ThighType
Public Enumeration Status1ThighType
public enum class Status1ThighType
type Status1ThighType
Members
Member name | Value | Description
HighAlarmTrue | 1 | High Alarm: True
HighAlarmFalse | 0 | High Alarm: False
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm84 Class

National Semiconductor: LM 84
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm84

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm84
Public Class Lm84
public ref class Lm84
type Lm84 =  class end

The Lm84 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm84 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationTCRITA | Configuration (T_CRIT_A)
Public property | LocalTCRITTemperatureSetpoint | Local T_CRIT Temperature Setpoint (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | RemoteTCRITTemperatureSetpoint | Remote T_CRIT Temperature Setpoint (unit: °C)
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | StatusLTCRIT | Status (LTCRIT)
Public property | StatusOPEN | Status (OPEN)
Public property | StatusRTCRIT | Status (RTCRIT)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Diode Input Digital Temperature Sensor
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm84 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm84(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm84(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm84

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm84 Class
telos.Ird.NationalSemiconductor Namespace


Lm84 Properties

The Lm84 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationTCRITA | Configuration (T_CRIT_A)
Public property | LocalTCRITTemperatureSetpoint | Local T_CRIT Temperature Setpoint (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | RemoteTCRITTemperatureSetpoint | Remote T_CRIT Temperature Setpoint (unit: °C)
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | StatusLTCRIT | Status (LTCRIT)
Public property | StatusOPEN | Status (OPEN)
Public property | StatusRTCRIT | Status (RTCRIT)
Top
See Also

Reference

Lm84 Class
telos.Ird.NationalSemiconductor Namespace


Lm84.AutoFlush Property

IRD

Lm84AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm84 Class
telos.Ird.NationalSemiconductor Namespace


Lm84.ConfigurationTCRITA Property

IRD

Lm84ConfigurationTCRITA Property

Configuration (T_CRIT_A)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm84ConfigType ConfigurationTCRITA { get; set; }
Public Property ConfigurationTCRITA As Lm84ConfigType
    Get
    Set
public:
property Lm84ConfigType ConfigurationTCRITA {
    Lm84ConfigType get ();
    void set (Lm84ConfigType value);
}
member ConfigurationTCRITA : Lm84ConfigType with get, set

Property Value

Type: Lm84ConfigType
See Also

Reference

Lm84 Class
telos.Ird.NationalSemiconductor Namespace


Lm84.LocalTCRITTemperatureSetpoint Property

IRD

Lm84LocalTCRITTemperatureSetpoint Property

Local T_CRIT Temperature Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTCRITTemperatureSetpoint { get; set; }
Public Property LocalTCRITTemperatureSetpoint As SByte
    Get
    Set
public:
property signed char LocalTCRITTemperatureSetpoint {
    signed char get ();
    void set (signed char value);
}
member LocalTCRITTemperatureSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm84 Class
telos.Ird.NationalSemiconductor Namespace


Lm84.LocalTemperature Property

IRD

Lm84LocalTemperature Property

Local Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTemperature { get; }
Public ReadOnly Property LocalTemperature As SByte
    Get
public:
property signed char LocalTemperature {
    signed char get ();
}
member LocalTemperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Lm84 Class
telos.Ird.NationalSemiconductor Namespace


Lm84.ManufacturerID Property

IRD

Lm84ManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As Byte
    Get
public:
property unsigned char ManufacturerID {
    unsigned char get ();
}
member ManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm84 Class
telos.Ird.NationalSemiconductor Namespace


Lm84.RemoteTCRITTemperatureSetpoint Property

IRD

Lm84RemoteTCRITTemperatureSetpoint Property

Remote T_CRIT Temperature Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTCRITTemperatureSetpoint { get; set; }
Public Property RemoteTCRITTemperatureSetpoint As SByte
    Get
    Set
public:
property signed char RemoteTCRITTemperatureSetpoint {
    signed char get ();
    void set (signed char value);
}
member RemoteTCRITTemperatureSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm84 Class
telos.Ird.NationalSemiconductor Namespace


Lm84.RemoteTemperature Property

IRD

Lm84RemoteTemperature Property

Remote Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTemperature { get; }
Public ReadOnly Property RemoteTemperature As SByte
    Get
public:
property signed char RemoteTemperature {
    signed char get ();
}
member RemoteTemperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Lm84 Class
telos.Ird.NationalSemiconductor Namespace


Lm84.StatusLTCRIT Property

IRD

Lm84StatusLTCRIT Property

Status (LTCRIT)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm84StatusTcritType StatusLTCRIT { get; }
Public ReadOnly Property StatusLTCRIT As Lm84StatusTcritType
    Get
public:
property Lm84StatusTcritType StatusLTCRIT {
    Lm84StatusTcritType get ();
}
member StatusLTCRIT : Lm84StatusTcritType with get

Property Value

Type: Lm84StatusTcritType
See Also

Reference

Lm84 Class
telos.Ird.NationalSemiconductor Namespace


Lm84.StatusOPEN Property

IRD

Lm84StatusOPEN Property

Status (OPEN)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm84StatusOpenType StatusOPEN { get; }
Public ReadOnly Property StatusOPEN As Lm84StatusOpenType
    Get
public:
property Lm84StatusOpenType StatusOPEN {
    Lm84StatusOpenType get ();
}
member StatusOPEN : Lm84StatusOpenType with get

Property Value

Type: Lm84StatusOpenType
See Also

Reference

Lm84 Class
telos.Ird.NationalSemiconductor Namespace


Lm84.StatusRTCRIT Property

IRD

Lm84StatusRTCRIT Property

Status (RTCRIT)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm84StatusTcritType StatusRTCRIT { get; }
Public ReadOnly Property StatusRTCRIT As Lm84StatusTcritType
    Get
public:
property Lm84StatusTcritType StatusRTCRIT {
    Lm84StatusTcritType get ();
}
member StatusRTCRIT : Lm84StatusTcritType with get

Property Value

Type: Lm84StatusTcritType
See Also

Reference

Lm84 Class
telos.Ird.NationalSemiconductor Namespace


Lm84 Methods

The Lm84 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm84 Class
telos.Ird.NationalSemiconductor Namespace


Lm84.Flush Method

IRD

Lm84Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm84 Class
telos.Ird.NationalSemiconductor Namespace


Lm84.ConfigType Enumeration

IRD

Lm84ConfigType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigType
Public Enumeration ConfigType
public enum class ConfigType
type ConfigType
Members
Member name | Value | Description
TCRITAInterruptsMasked | 1 | T_CRIT_A Interrupts: Masked
TCRITAInterruptsNotMasked | 0 | T_CRIT_A Interrupts: Not Masked
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm84.StatusOpenType Enumeration

IRD

Lm84StatusOpenType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusOpenType
Public Enumeration StatusOpenType
public enum class StatusOpenType
type StatusOpenType
Members
Member name | Value | Description
RemoteDiodeDisconnected | 1 | Remote Diode: Disconnected
RemoteDiodeConnected | 0 | Remote Diode: Connected
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm84.StatusTcritType Enumeration

IRD

Lm84StatusTcritType Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusTcritType
Public Enumeration StatusTcritType
public enum class StatusTcritType
type StatusTcritType
Members
Member name | Value | Description
Alarm | 1 | Alarm
NoAlarm | 0 | No Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85 Class

National Semiconductor: LM 85
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm85

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm85
Public Class Lm85
public ref class Lm85
type Lm85 =  class end

The Lm85 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm85 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CompanyID | Company ID
Public property | EnableTemperatureSmoothing1 | Enable temperature smoothing 1
Public property | EnableTemperatureSmoothing2 | Enable temperature smoothing 2
Public property | EnableTemperatureSmoothing3 | Enable temperature smoothing 3
Public property | ErrorInStatusRegister2 | Error in Status Register 2
Public property | Fan1CurrentPWMDuty | Fan1 Current PWM Duty (unit: %)
Public property | Fan1PWMFrequency | Fan1: PWM Frequency (unit: Hz)
Public property | Fan1PWMInvert | Fan1: PWM Invert
Public property | Fan1PWMMinimum | Fan1 PWM Minimum (unit: %)
Public property | Fan1RangeSelection | Fan1: Range Selection (unit: °C)
Public property | Fan1SpinUp | Fan1: Spin-Up (unit: ms)
Public property | Fan1Stalled | Fan1 Stalled
Public property | Fan1Zone | Fan1: Zone
Public property | Fan2CurrentPWMDuty | Fan2 Current PWM Duty (unit: %)
Public property | Fan2PWMFrequency | Fan2: PWM Frequency
Public property | Fan2PWMInvert | Fan2: PWM Invert
Public property | Fan2PWMMinimum | Fan2 PWM Minimum (unit: %)
Public property | Fan2RangeSelection | Fan2: Range Selection
Public property | Fan2SpinUp | Fan2: Spin-Up
Public property | Fan2Stalled | Fan2 Stalled
Public property | Fan2Zone | Fan2: Zone
Public property | Fan3CurrentPWMDuty | Fan3 Current PWM Duty (unit: %)
Public property | Fan3PWMFrequency | Fan3: PWM Frequency
Public property | Fan3PWMInvert | Fan3: PWM Invert
Public property | Fan3PWMMinimum | Fan3 PWM Minimum (unit: %)
Public property | Fan3RangeSelection | Fan3: Range Selection
Public property | Fan3SpinUp | Fan3: Spin-Up
Public property | Fan3Stalled | Fan3 Stalled
Public property | Fan3Zone | Fan3: Zone
Public property | Fan4Stalled | Fan4 Stalled
Public property | InternalZone2HighTemp | Internal (Zone2) High Temp (unit: °C)
Public property | InternalZone2LowTemp | Internal (Zone2) Low Temp (unit: °C)
Public property | LOCK | LOCK
Public property | MonitorModeTach1 | Monitor Mode: Tach1
Public property | MonitorModeTach2 | Monitor Mode: Tach2
Public property | MonitorModeTach34 | Monitor Mode: Tach3/4
Public property | OVRID | OVRID
Public property | ProcessorZone1HighTemp | Processor (Zone1) High Temp (unit: °C)
Public property | ProcessorZone1LowTemp | Processor (Zone1) Low Temp (unit: °C)
Public property | ProcessorZone1Temp | Processor (Zone1) Temp (unit: °C)
Public property | ProcessorZone2Temp | Processor (Zone2) Temp (unit: °C)
Public property | ProcessorZone3Temp | Processor (Zone3) Temp (unit: °C)
Public property | Property_12V | 12 V
Public property | Property_12VError | +12V_Error
Public property | Property_12VHighLimit | 12 V High Limit (unit: V)
Public property | Property_12VLowLimit | 12 V Low Limit (unit: V)
Public property | Property_25V | 2.5 V (unit: V)
Public property | Property_25VError | 2.5V_Error
Public property | Property_25VHighLimit | 2.5 V High Limit (unit: V)
Public property | Property_25VLowLimit | 2.5 V Low Limit (unit: V)
Public property | Property_33V | 3.3 V
Public property | Property_33VError | 3.3V_Error
Public property | Property_33VHighLimit | 3.3 V High Limit (unit: V)
Public property | Property_33VLowLimit | 3.3 V Low Limit (unit: V)
Public property | Property_5V | 5 V
Public property | Property_5VError | 5V_Error
Public property | Property_5VHighLimit | 5 V High Limit (unit: V)
Public property | Property_5VLowLimit | 5 V Low Limit (unit: V)
Public property | PWM1SpinUpMode | PWM1 spin-up mode
Public property | PWM2SpinUpMode | PWM2 spin-up mode
Public property | PWM3SpinUpMode | PWM3 spin-up mode
Public property | READY | READY
Public property | RemoteDiode1Fault | Remote Diode 1 Fault
Public property | RemoteDiode2Fault | Remote Diode 2 Fault
Public property | RemoteZone3HighTemp | Remote (Zone3) High Temp (unit: °C)
Public property | RemoteZone3LowTemp | Remote (Zone3) Low Temp (unit: °C)
Public property | SpikeSmoothing1 | Spike Smoothing 1 (unit: s)
Public property | SpikeSmoothing1Off | Spike Smoothing 1 off
Public property | SpikeSmoothing2 | Spike Smoothing 2 (unit: s)
Public property | SpikeSmoothing2Off | Spike Smoothing 2 off
Public property | SpikeSmoothing3 | Spike Smoothing 3 (unit: s)
Public property | SpikeSmoothing3Off | Spike Smoothing 3 off
Public property | Start | Start
Public property | SteppingID | Stepping ID
Public property | Tach1 | Tach1 (unit: µs/Periode)
Public property | Tach1AccurateLevel | Tach1: Accurate Level
Public property | Tach1Fan | Tach1 Fan
Public property | Tach1Minimum | Tach1 Minimum (unit: µs/Periode)
Public property | Tach2 | Tach2 (unit: µs/Periode)
Public property | Tach2AccurateLevel | Tach2: Accurate Level
Public property | Tach2Fan | Tach2 Fan
Public property | Tach2Minimum | Tach2 Minimum (unit: µs/Periode)
Public property | Tach3 | Tach3 (unit: µs/Periode)
Public property | Tach3AccurateLevel | Tach3: Accurate Level
Public property | Tach3Fan | Tach3 Fan
Public property | Tach3Minimum | Tach3 Minimum (unit: µs/Periode)
Public property | Tach4 | Tach4 (unit: µs/Periode)
Public property | Tach4AccurateLevel | Tach4: Accurate Level
Public property | Tach4Fan | Tach4 Fan
Public property | Tach4Minimum | Tach4 Minimum (unit: µs/Periode)
Public property | VCCPError | VCCP_Error
Public property | VCCPHighLimit | VCCP High Limit (unit: V)
Public property | VCCPLowLimit | VCCP Low Limit (unit: V)
Public property | VCPP | VCPP (unit: V)
Public property | Version | Version
Public property | VID0 | VID0
Public property | VID1 | VID1
Public property | VID2 | VID2
Public property | VID3 | VID3
Public property | VID4 | VID4
Public property | XEN | XEN
Public property | Zone1 | Zone 1 (unit: °C)
Public property | Zone1FanTempLimit | Zone1 Fan Temp Limit (unit: °C)
Public property | Zone1LimitExceeded | Zone 1 Limit Exceeded
Public property | Zone1TempAbsoluteLimit | Zone1 Temp Absolute Limit (unit: °C)
Public property | Zone2 | Zone 2 (unit: °C)
Public property | Zone2FanTempLimit | Zone2 Fan Temp Limit (unit: °C)
Public property | Zone2LimitExceeded | Zone 2 Limit Exceeded
Public property | Zone2TempAbsoluteLimit | Zone2 Temp Absolute Limit (unit: °C)
Public property | Zone3 | Zone 3 (unit: °C)
Public property | Zone3FanTempLimit | Zone3 Fan Temp Limit (unit: °C)
Public property | Zone3LimitExceeded | Zone 3 Limit Exceeded
Public property | Zone3TempAbsoluteLimit | Zone3 Temp Absolute Limit (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Hardware Monitor with Integrated Fan Control
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm85(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm85

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85 Properties

The Lm85 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CompanyID | Company ID
Public property | EnableTemperatureSmoothing1 | Enable temperature smoothing 1
Public property | EnableTemperatureSmoothing2 | Enable temperature smoothing 2
Public property | EnableTemperatureSmoothing3 | Enable temperature smoothing 3
Public property | ErrorInStatusRegister2 | Error in Status Register 2
Public property | Fan1CurrentPWMDuty | Fan1 Current PWM Duty (unit: %)
Public property | Fan1PWMFrequency | Fan1: PWM Frequency (unit: Hz)
Public property | Fan1PWMInvert | Fan1: PWM Invert
Public property | Fan1PWMMinimum | Fan1 PWM Minimum (unit: %)
Public property | Fan1RangeSelection | Fan1: Range Selection (unit: °C)
Public property | Fan1SpinUp | Fan1: Spin-Up (unit: ms)
Public property | Fan1Stalled | Fan1 Stalled
Public property | Fan1Zone | Fan1: Zone
Public property | Fan2CurrentPWMDuty | Fan2 Current PWM Duty (unit: %)
Public property | Fan2PWMFrequency | Fan2: PWM Frequency
Public property | Fan2PWMInvert | Fan2: PWM Invert
Public property | Fan2PWMMinimum | Fan2 PWM Minimum (unit: %)
Public property | Fan2RangeSelection | Fan2: Range Selection
Public property | Fan2SpinUp | Fan2: Spin-Up
Public property | Fan2Stalled | Fan2 Stalled
Public property | Fan2Zone | Fan2: Zone
Public property | Fan3CurrentPWMDuty | Fan3 Current PWM Duty (unit: %)
Public property | Fan3PWMFrequency | Fan3: PWM Frequency
Public property | Fan3PWMInvert | Fan3: PWM Invert
Public property | Fan3PWMMinimum | Fan3 PWM Minimum (unit: %)
Public property | Fan3RangeSelection | Fan3: Range Selection
Public property | Fan3SpinUp | Fan3: Spin-Up
Public property | Fan3Stalled | Fan3 Stalled
Public property | Fan3Zone | Fan3: Zone
Public property | Fan4Stalled | Fan4 Stalled
Public property | InternalZone2HighTemp | Internal (Zone2) High Temp (unit: °C)
Public property | InternalZone2LowTemp | Internal (Zone2) Low Temp (unit: °C)
Public property | LOCK | LOCK
Public property | MonitorModeTach1 | Monitor Mode: Tach1
Public property | MonitorModeTach2 | Monitor Mode: Tach2
Public property | MonitorModeTach34 | Monitor Mode: Tach3/4
Public property | OVRID | OVRID
Public property | ProcessorZone1HighTemp | Processor (Zone1) High Temp (unit: °C)
Public property | ProcessorZone1LowTemp | Processor (Zone1) Low Temp (unit: °C)
Public property | ProcessorZone1Temp | Processor (Zone1) Temp (unit: °C)
Public property | ProcessorZone2Temp | Processor (Zone2) Temp (unit: °C)
Public property | ProcessorZone3Temp | Processor (Zone3) Temp (unit: °C)
Public property | Property_12V | 12 V
Public property | Property_12VError | +12V_Error
Public property | Property_12VHighLimit | 12 V High Limit (unit: V)
Public property | Property_12VLowLimit | 12 V Low Limit (unit: V)
Public property | Property_25V | 2.5 V (unit: V)
Public property | Property_25VError | 2.5V_Error
Public property | Property_25VHighLimit | 2.5 V High Limit (unit: V)
Public property | Property_25VLowLimit | 2.5 V Low Limit (unit: V)
Public property | Property_33V | 3.3 V
Public property | Property_33VError | 3.3V_Error
Public property | Property_33VHighLimit | 3.3 V High Limit (unit: V)
Public property | Property_33VLowLimit | 3.3 V Low Limit (unit: V)
Public property | Property_5V | 5 V
Public property | Property_5VError | 5V_Error
Public property | Property_5VHighLimit | 5 V High Limit (unit: V)
Public property | Property_5VLowLimit | 5 V Low Limit (unit: V)
Public property | PWM1SpinUpMode | PWM1 spin-up mode
Public property | PWM2SpinUpMode | PWM2 spin-up mode
Public property | PWM3SpinUpMode | PWM3 spin-up mode
Public property | READY | READY
Public property | RemoteDiode1Fault | Remote Diode 1 Fault
Public property | RemoteDiode2Fault | Remote Diode 2 Fault
Public property | RemoteZone3HighTemp | Remote (Zone3) High Temp (unit: °C)
Public property | RemoteZone3LowTemp | Remote (Zone3) Low Temp (unit: °C)
Public property | SpikeSmoothing1 | Spike Smoothing 1 (unit: s)
Public property | SpikeSmoothing1Off | Spike Smoothing 1 off
Public property | SpikeSmoothing2 | Spike Smoothing 2 (unit: s)
Public property | SpikeSmoothing2Off | Spike Smoothing 2 off
Public property | SpikeSmoothing3 | Spike Smoothing 3 (unit: s)
Public property | SpikeSmoothing3Off | Spike Smoothing 3 off
Public property | Start | Start
Public property | SteppingID | Stepping ID
Public property | Tach1 | Tach1 (unit: µs/Periode)
Public property | Tach1AccurateLevel | Tach1: Accurate Level
Public property | Tach1Fan | Tach1 Fan
Public property | Tach1Minimum | Tach1 Minimum (unit: µs/Periode)
Public property | Tach2 | Tach2 (unit: µs/Periode)
Public property | Tach2AccurateLevel | Tach2: Accurate Level
Public property | Tach2Fan | Tach2 Fan
Public property | Tach2Minimum | Tach2 Minimum (unit: µs/Periode)
Public property | Tach3 | Tach3 (unit: µs/Periode)
Public property | Tach3AccurateLevel | Tach3: Accurate Level
Public property | Tach3Fan | Tach3 Fan
Public property | Tach3Minimum | Tach3 Minimum (unit: µs/Periode)
Public property | Tach4 | Tach4 (unit: µs/Periode)
Public property | Tach4AccurateLevel | Tach4: Accurate Level
Public property | Tach4Fan | Tach4 Fan
Public property | Tach4Minimum | Tach4 Minimum (unit: µs/Periode)
Public property | VCCPError | VCCP_Error
Public property | VCCPHighLimit | VCCP High Limit (unit: V)
Public property | VCCPLowLimit | VCCP Low Limit (unit: V)
Public property | VCPP | VCPP (unit: V)
Public property | Version | Version
Public property | VID0 | VID0
Public property | VID1 | VID1
Public property | VID2 | VID2
Public property | VID3 | VID3
Public property | VID4 | VID4
Public property | XEN | XEN
Public property | Zone1 | Zone 1 (unit: °C)
Public property | Zone1FanTempLimit | Zone1 Fan Temp Limit (unit: °C)
Public property | Zone1LimitExceeded | Zone 1 Limit Exceeded
Public property | Zone1TempAbsoluteLimit | Zone1 Temp Absolute Limit (unit: °C)
Public property | Zone2 | Zone 2 (unit: °C)
Public property | Zone2FanTempLimit | Zone2 Fan Temp Limit (unit: °C)
Public property | Zone2LimitExceeded | Zone 2 Limit Exceeded
Public property | Zone2TempAbsoluteLimit | Zone2 Temp Absolute Limit (unit: °C)
Public property | Zone3 | Zone 3 (unit: °C)
Public property | Zone3FanTempLimit | Zone3 Fan Temp Limit (unit: °C)
Public property | Zone3LimitExceeded | Zone 3 Limit Exceeded
Public property | Zone3TempAbsoluteLimit | Zone3 Temp Absolute Limit (unit: °C)
Top
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.AutoFlush Property

IRD

Lm85AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.CompanyID Property

IRD

Lm85CompanyID Property

Company ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CompanyID { get; }
Public ReadOnly Property CompanyID As Byte
    Get
public:
property unsigned char CompanyID {
    unsigned char get ();
}
member CompanyID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.EnableTemperatureSmoothing1 Property

IRD

Lm85EnableTemperatureSmoothing1 Property

Enable temperature smoothing 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85IDEnableDisable EnableTemperatureSmoothing1 { get; set; }
Public Property EnableTemperatureSmoothing1 As Lm85IDEnableDisable
    Get
    Set
public:
property Lm85IDEnableDisable EnableTemperatureSmoothing1 {
    Lm85IDEnableDisable get ();
    void set (Lm85IDEnableDisable value);
}
member EnableTemperatureSmoothing1 : Lm85IDEnableDisable with get, set

Property Value

Type: Lm85IDEnableDisable
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.EnableTemperatureSmoothing2 Property

IRD

Lm85EnableTemperatureSmoothing2 Property

Enable temperature smoothing 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85IDEnableDisable EnableTemperatureSmoothing2 { get; set; }
Public Property EnableTemperatureSmoothing2 As Lm85IDEnableDisable
    Get
    Set
public:
property Lm85IDEnableDisable EnableTemperatureSmoothing2 {
    Lm85IDEnableDisable get ();
    void set (Lm85IDEnableDisable value);
}
member EnableTemperatureSmoothing2 : Lm85IDEnableDisable with get, set

Property Value

Type: Lm85IDEnableDisable
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.EnableTemperatureSmoothing3 Property

IRD

Lm85EnableTemperatureSmoothing3 Property

Enable temperature smoothing 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85IDEnableDisable EnableTemperatureSmoothing3 { get; set; }
Public Property EnableTemperatureSmoothing3 As Lm85IDEnableDisable
    Get
    Set
public:
property Lm85IDEnableDisable EnableTemperatureSmoothing3 {
    Lm85IDEnableDisable get ();
    void set (Lm85IDEnableDisable value);
}
member EnableTemperatureSmoothing3 : Lm85IDEnableDisable with get, set

Property Value

Type: Lm85IDEnableDisable
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.ErrorInStatusRegister2 Property

IRD

Lm85ErrorInStatusRegister2 Property

Error in Status Register 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDINTERRUPTSTATUSREGISTER17 ErrorInStatusRegister2 { get; }
Public ReadOnly Property ErrorInStatusRegister2 As Lm85TYPIDINTERRUPTSTATUSREGISTER17
    Get
public:
property Lm85TYPIDINTERRUPTSTATUSREGISTER17 ErrorInStatusRegister2 {
    Lm85TYPIDINTERRUPTSTATUSREGISTER17 get ();
}
member ErrorInStatusRegister2 : Lm85TYPIDINTERRUPTSTATUSREGISTER17 with get

Property Value

Type: Lm85TYPIDINTERRUPTSTATUSREGISTER17
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan1CurrentPWMDuty Property

IRD

Lm85Fan1CurrentPWMDuty Property

Fan1 Current PWM Duty (unit: %)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1CURRENTPWMDUTY0 Fan1CurrentPWMDuty { get; set; }
Public Property Fan1CurrentPWMDuty As Lm85TYPIDFAN1CURRENTPWMDUTY0
    Get
    Set
public:
property Lm85TYPIDFAN1CURRENTPWMDUTY0 Fan1CurrentPWMDuty {
    Lm85TYPIDFAN1CURRENTPWMDUTY0 get ();
    void set (Lm85TYPIDFAN1CURRENTPWMDUTY0 value);
}
member Fan1CurrentPWMDuty : Lm85TYPIDFAN1CURRENTPWMDUTY0 with get, set

Property Value

Type: Lm85TYPIDFAN1CURRENTPWMDUTY0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan1PWMFrequency Property

IRD

Lm85Fan1PWMFrequency Property

Fan1: PWM Frequency (unit: Hz)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1RANGEFREQUENCY0 Fan1PWMFrequency { get; set; }
Public Property Fan1PWMFrequency As Lm85TYPIDFAN1RANGEFREQUENCY0
    Get
    Set
public:
property Lm85TYPIDFAN1RANGEFREQUENCY0 Fan1PWMFrequency {
    Lm85TYPIDFAN1RANGEFREQUENCY0 get ();
    void set (Lm85TYPIDFAN1RANGEFREQUENCY0 value);
}
member Fan1PWMFrequency : Lm85TYPIDFAN1RANGEFREQUENCY0 with get, set

Property Value

Type: Lm85TYPIDFAN1RANGEFREQUENCY0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan1PWMInvert Property

IRD

Lm85Fan1PWMInvert Property

Fan1: PWM Invert

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1CONFIGURATION1 Fan1PWMInvert { get; set; }
Public Property Fan1PWMInvert As Lm85TYPIDFAN1CONFIGURATION1
    Get
    Set
public:
property Lm85TYPIDFAN1CONFIGURATION1 Fan1PWMInvert {
    Lm85TYPIDFAN1CONFIGURATION1 get ();
    void set (Lm85TYPIDFAN1CONFIGURATION1 value);
}
member Fan1PWMInvert : Lm85TYPIDFAN1CONFIGURATION1 with get, set

Property Value

Type: Lm85TYPIDFAN1CONFIGURATION1
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan1PWMMinimum Property

IRD

Lm85Fan1PWMMinimum Property

Fan1 PWM Minimum (unit: %)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1CURRENTPWMDUTY0 Fan1PWMMinimum { get; set; }
Public Property Fan1PWMMinimum As Lm85TYPIDFAN1CURRENTPWMDUTY0
    Get
    Set
public:
property Lm85TYPIDFAN1CURRENTPWMDUTY0 Fan1PWMMinimum {
    Lm85TYPIDFAN1CURRENTPWMDUTY0 get ();
    void set (Lm85TYPIDFAN1CURRENTPWMDUTY0 value);
}
member Fan1PWMMinimum : Lm85TYPIDFAN1CURRENTPWMDUTY0 with get, set

Property Value

Type: Lm85TYPIDFAN1CURRENTPWMDUTY0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan1RangeSelection Property

IRD

Lm85Fan1RangeSelection Property

Fan1: Range Selection (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1RANGEFREQUENCY1 Fan1RangeSelection { get; set; }
Public Property Fan1RangeSelection As Lm85TYPIDFAN1RANGEFREQUENCY1
    Get
    Set
public:
property Lm85TYPIDFAN1RANGEFREQUENCY1 Fan1RangeSelection {
    Lm85TYPIDFAN1RANGEFREQUENCY1 get ();
    void set (Lm85TYPIDFAN1RANGEFREQUENCY1 value);
}
member Fan1RangeSelection : Lm85TYPIDFAN1RANGEFREQUENCY1 with get, set

Property Value

Type: Lm85TYPIDFAN1RANGEFREQUENCY1
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan1SpinUp Property

IRD

Lm85Fan1SpinUp Property

Fan1: Spin-Up (unit: ms)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1CONFIGURATION0 Fan1SpinUp { get; set; }
Public Property Fan1SpinUp As Lm85TYPIDFAN1CONFIGURATION0
    Get
    Set
public:
property Lm85TYPIDFAN1CONFIGURATION0 Fan1SpinUp {
    Lm85TYPIDFAN1CONFIGURATION0 get ();
    void set (Lm85TYPIDFAN1CONFIGURATION0 value);
}
member Fan1SpinUp : Lm85TYPIDFAN1CONFIGURATION0 with get, set

Property Value

Type: Lm85TYPIDFAN1CONFIGURATION0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan1Stalled Property

IRD

Lm85Fan1Stalled Property

Fan1 Stalled

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDINTERRUPTSTATUSREGISTER21 Fan1Stalled { get; }
Public ReadOnly Property Fan1Stalled As Lm85TYPIDINTERRUPTSTATUSREGISTER21
    Get
public:
property Lm85TYPIDINTERRUPTSTATUSREGISTER21 Fan1Stalled {
    Lm85TYPIDINTERRUPTSTATUSREGISTER21 get ();
}
member Fan1Stalled : Lm85TYPIDINTERRUPTSTATUSREGISTER21 with get

Property Value

Type: Lm85TYPIDINTERRUPTSTATUSREGISTER21
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan1Zone Property

IRD

Lm85Fan1Zone Property

Fan1: Zone

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1CONFIGURATION2 Fan1Zone { get; set; }
Public Property Fan1Zone As Lm85TYPIDFAN1CONFIGURATION2
    Get
    Set
public:
property Lm85TYPIDFAN1CONFIGURATION2 Fan1Zone {
    Lm85TYPIDFAN1CONFIGURATION2 get ();
    void set (Lm85TYPIDFAN1CONFIGURATION2 value);
}
member Fan1Zone : Lm85TYPIDFAN1CONFIGURATION2 with get, set

Property Value

Type: Lm85TYPIDFAN1CONFIGURATION2
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan2CurrentPWMDuty Property

IRD

Lm85Fan2CurrentPWMDuty Property

Fan2 Current PWM Duty (unit: %)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1CURRENTPWMDUTY0 Fan2CurrentPWMDuty { get; set; }
Public Property Fan2CurrentPWMDuty As Lm85TYPIDFAN1CURRENTPWMDUTY0
    Get
    Set
public:
property Lm85TYPIDFAN1CURRENTPWMDUTY0 Fan2CurrentPWMDuty {
    Lm85TYPIDFAN1CURRENTPWMDUTY0 get ();
    void set (Lm85TYPIDFAN1CURRENTPWMDUTY0 value);
}
member Fan2CurrentPWMDuty : Lm85TYPIDFAN1CURRENTPWMDUTY0 with get, set

Property Value

Type: Lm85TYPIDFAN1CURRENTPWMDUTY0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan2PWMFrequency Property

IRD

Lm85Fan2PWMFrequency Property

Fan2: PWM Frequency

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1RANGEFREQUENCY0 Fan2PWMFrequency { get; set; }
Public Property Fan2PWMFrequency As Lm85TYPIDFAN1RANGEFREQUENCY0
    Get
    Set
public:
property Lm85TYPIDFAN1RANGEFREQUENCY0 Fan2PWMFrequency {
    Lm85TYPIDFAN1RANGEFREQUENCY0 get ();
    void set (Lm85TYPIDFAN1RANGEFREQUENCY0 value);
}
member Fan2PWMFrequency : Lm85TYPIDFAN1RANGEFREQUENCY0 with get, set

Property Value

Type: Lm85TYPIDFAN1RANGEFREQUENCY0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan2PWMInvert Property

IRD

Lm85Fan2PWMInvert Property

Fan2: PWM Invert

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1CONFIGURATION1 Fan2PWMInvert { get; set; }
Public Property Fan2PWMInvert As Lm85TYPIDFAN1CONFIGURATION1
    Get
    Set
public:
property Lm85TYPIDFAN1CONFIGURATION1 Fan2PWMInvert {
    Lm85TYPIDFAN1CONFIGURATION1 get ();
    void set (Lm85TYPIDFAN1CONFIGURATION1 value);
}
member Fan2PWMInvert : Lm85TYPIDFAN1CONFIGURATION1 with get, set

Property Value

Type: Lm85TYPIDFAN1CONFIGURATION1
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan2PWMMinimum Property

IRD

Lm85Fan2PWMMinimum Property

Fan2 PWM Minimum (unit: %)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1CURRENTPWMDUTY0 Fan2PWMMinimum { get; set; }
Public Property Fan2PWMMinimum As Lm85TYPIDFAN1CURRENTPWMDUTY0
    Get
    Set
public:
property Lm85TYPIDFAN1CURRENTPWMDUTY0 Fan2PWMMinimum {
    Lm85TYPIDFAN1CURRENTPWMDUTY0 get ();
    void set (Lm85TYPIDFAN1CURRENTPWMDUTY0 value);
}
member Fan2PWMMinimum : Lm85TYPIDFAN1CURRENTPWMDUTY0 with get, set

Property Value

Type: Lm85TYPIDFAN1CURRENTPWMDUTY0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan2RangeSelection Property

IRD

Lm85Fan2RangeSelection Property

Fan2: Range Selection

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1RANGEFREQUENCY1 Fan2RangeSelection { get; set; }
Public Property Fan2RangeSelection As Lm85TYPIDFAN1RANGEFREQUENCY1
    Get
    Set
public:
property Lm85TYPIDFAN1RANGEFREQUENCY1 Fan2RangeSelection {
    Lm85TYPIDFAN1RANGEFREQUENCY1 get ();
    void set (Lm85TYPIDFAN1RANGEFREQUENCY1 value);
}
member Fan2RangeSelection : Lm85TYPIDFAN1RANGEFREQUENCY1 with get, set

Property Value

Type: Lm85TYPIDFAN1RANGEFREQUENCY1
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan2SpinUp Property

IRD

Lm85Fan2SpinUp Property

Fan2: Spin-Up

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1CONFIGURATION0 Fan2SpinUp { get; set; }
Public Property Fan2SpinUp As Lm85TYPIDFAN1CONFIGURATION0
    Get
    Set
public:
property Lm85TYPIDFAN1CONFIGURATION0 Fan2SpinUp {
    Lm85TYPIDFAN1CONFIGURATION0 get ();
    void set (Lm85TYPIDFAN1CONFIGURATION0 value);
}
member Fan2SpinUp : Lm85TYPIDFAN1CONFIGURATION0 with get, set

Property Value

Type: Lm85TYPIDFAN1CONFIGURATION0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan2Stalled Property

IRD

Lm85Fan2Stalled Property

Fan2 Stalled

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDINTERRUPTSTATUSREGISTER22 Fan2Stalled { get; }
Public ReadOnly Property Fan2Stalled As Lm85TYPIDINTERRUPTSTATUSREGISTER22
    Get
public:
property Lm85TYPIDINTERRUPTSTATUSREGISTER22 Fan2Stalled {
    Lm85TYPIDINTERRUPTSTATUSREGISTER22 get ();
}
member Fan2Stalled : Lm85TYPIDINTERRUPTSTATUSREGISTER22 with get

Property Value

Type: Lm85TYPIDINTERRUPTSTATUSREGISTER22
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan2Zone Property

IRD

Lm85Fan2Zone Property

Fan2: Zone

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1CONFIGURATION2 Fan2Zone { get; set; }
Public Property Fan2Zone As Lm85TYPIDFAN1CONFIGURATION2
    Get
    Set
public:
property Lm85TYPIDFAN1CONFIGURATION2 Fan2Zone {
    Lm85TYPIDFAN1CONFIGURATION2 get ();
    void set (Lm85TYPIDFAN1CONFIGURATION2 value);
}
member Fan2Zone : Lm85TYPIDFAN1CONFIGURATION2 with get, set

Property Value

Type: Lm85TYPIDFAN1CONFIGURATION2
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan3CurrentPWMDuty Property

IRD

Lm85Fan3CurrentPWMDuty Property

Fan3 Current PWM Duty (unit: %)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1CURRENTPWMDUTY0 Fan3CurrentPWMDuty { get; set; }
Public Property Fan3CurrentPWMDuty As Lm85TYPIDFAN1CURRENTPWMDUTY0
    Get
    Set
public:
property Lm85TYPIDFAN1CURRENTPWMDUTY0 Fan3CurrentPWMDuty {
    Lm85TYPIDFAN1CURRENTPWMDUTY0 get ();
    void set (Lm85TYPIDFAN1CURRENTPWMDUTY0 value);
}
member Fan3CurrentPWMDuty : Lm85TYPIDFAN1CURRENTPWMDUTY0 with get, set

Property Value

Type: Lm85TYPIDFAN1CURRENTPWMDUTY0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan3PWMFrequency Property

IRD

Lm85Fan3PWMFrequency Property

Fan3: PWM Frequency

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1RANGEFREQUENCY0 Fan3PWMFrequency { get; set; }
Public Property Fan3PWMFrequency As Lm85TYPIDFAN1RANGEFREQUENCY0
    Get
    Set
public:
property Lm85TYPIDFAN1RANGEFREQUENCY0 Fan3PWMFrequency {
    Lm85TYPIDFAN1RANGEFREQUENCY0 get ();
    void set (Lm85TYPIDFAN1RANGEFREQUENCY0 value);
}
member Fan3PWMFrequency : Lm85TYPIDFAN1RANGEFREQUENCY0 with get, set

Property Value

Type: Lm85TYPIDFAN1RANGEFREQUENCY0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan3PWMInvert Property

IRD

Lm85Fan3PWMInvert Property

Fan3: PWM Invert

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1CONFIGURATION1 Fan3PWMInvert { get; set; }
Public Property Fan3PWMInvert As Lm85TYPIDFAN1CONFIGURATION1
    Get
    Set
public:
property Lm85TYPIDFAN1CONFIGURATION1 Fan3PWMInvert {
    Lm85TYPIDFAN1CONFIGURATION1 get ();
    void set (Lm85TYPIDFAN1CONFIGURATION1 value);
}
member Fan3PWMInvert : Lm85TYPIDFAN1CONFIGURATION1 with get, set

Property Value

Type: Lm85TYPIDFAN1CONFIGURATION1
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan3PWMMinimum Property

IRD

Lm85Fan3PWMMinimum Property

Fan3 PWM Minimum (unit: %)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1CURRENTPWMDUTY0 Fan3PWMMinimum { get; set; }
Public Property Fan3PWMMinimum As Lm85TYPIDFAN1CURRENTPWMDUTY0
    Get
    Set
public:
property Lm85TYPIDFAN1CURRENTPWMDUTY0 Fan3PWMMinimum {
    Lm85TYPIDFAN1CURRENTPWMDUTY0 get ();
    void set (Lm85TYPIDFAN1CURRENTPWMDUTY0 value);
}
member Fan3PWMMinimum : Lm85TYPIDFAN1CURRENTPWMDUTY0 with get, set

Property Value

Type: Lm85TYPIDFAN1CURRENTPWMDUTY0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan3RangeSelection Property

IRD

Lm85Fan3RangeSelection Property

Fan3: Range Selection

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1RANGEFREQUENCY1 Fan3RangeSelection { get; set; }
Public Property Fan3RangeSelection As Lm85TYPIDFAN1RANGEFREQUENCY1
    Get
    Set
public:
property Lm85TYPIDFAN1RANGEFREQUENCY1 Fan3RangeSelection {
    Lm85TYPIDFAN1RANGEFREQUENCY1 get ();
    void set (Lm85TYPIDFAN1RANGEFREQUENCY1 value);
}
member Fan3RangeSelection : Lm85TYPIDFAN1RANGEFREQUENCY1 with get, set

Property Value

Type: Lm85TYPIDFAN1RANGEFREQUENCY1
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan3SpinUp Property

IRD

Lm85Fan3SpinUp Property

Fan3: Spin-Up

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1CONFIGURATION0 Fan3SpinUp { get; set; }
Public Property Fan3SpinUp As Lm85TYPIDFAN1CONFIGURATION0
    Get
    Set
public:
property Lm85TYPIDFAN1CONFIGURATION0 Fan3SpinUp {
    Lm85TYPIDFAN1CONFIGURATION0 get ();
    void set (Lm85TYPIDFAN1CONFIGURATION0 value);
}
member Fan3SpinUp : Lm85TYPIDFAN1CONFIGURATION0 with get, set

Property Value

Type: Lm85TYPIDFAN1CONFIGURATION0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan3Stalled Property

IRD

Lm85Fan3Stalled Property

Fan3 Stalled

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDINTERRUPTSTATUSREGISTER23 Fan3Stalled { get; }
Public ReadOnly Property Fan3Stalled As Lm85TYPIDINTERRUPTSTATUSREGISTER23
    Get
public:
property Lm85TYPIDINTERRUPTSTATUSREGISTER23 Fan3Stalled {
    Lm85TYPIDINTERRUPTSTATUSREGISTER23 get ();
}
member Fan3Stalled : Lm85TYPIDINTERRUPTSTATUSREGISTER23 with get

Property Value

Type: Lm85TYPIDINTERRUPTSTATUSREGISTER23
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan3Zone Property

IRD

Lm85Fan3Zone Property

Fan3: Zone

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFAN1CONFIGURATION2 Fan3Zone { get; set; }
Public Property Fan3Zone As Lm85TYPIDFAN1CONFIGURATION2
    Get
    Set
public:
property Lm85TYPIDFAN1CONFIGURATION2 Fan3Zone {
    Lm85TYPIDFAN1CONFIGURATION2 get ();
    void set (Lm85TYPIDFAN1CONFIGURATION2 value);
}
member Fan3Zone : Lm85TYPIDFAN1CONFIGURATION2 with get, set

Property Value

Type: Lm85TYPIDFAN1CONFIGURATION2
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Fan4Stalled Property

IRD

Lm85Fan4Stalled Property

Fan4 Stalled

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDINTERRUPTSTATUSREGISTER24 Fan4Stalled { get; }
Public ReadOnly Property Fan4Stalled As Lm85TYPIDINTERRUPTSTATUSREGISTER24
    Get
public:
property Lm85TYPIDINTERRUPTSTATUSREGISTER24 Fan4Stalled {
    Lm85TYPIDINTERRUPTSTATUSREGISTER24 get ();
}
member Fan4Stalled : Lm85TYPIDINTERRUPTSTATUSREGISTER24 with get

Property Value

Type: Lm85TYPIDINTERRUPTSTATUSREGISTER24
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.InternalZone2HighTemp Property

IRD

Lm85InternalZone2HighTemp Property

Internal (Zone2) High Temp (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalZone2HighTemp { get; set; }
Public Property InternalZone2HighTemp As SByte
    Get
    Set
public:
property signed char InternalZone2HighTemp {
    signed char get ();
    void set (signed char value);
}
member InternalZone2HighTemp : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.InternalZone2LowTemp Property

IRD

Lm85InternalZone2LowTemp Property

Internal (Zone2) Low Temp (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalZone2LowTemp { get; set; }
Public Property InternalZone2LowTemp As SByte
    Get
    Set
public:
property signed char InternalZone2LowTemp {
    signed char get ();
    void set (signed char value);
}
member InternalZone2LowTemp : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.LOCK Property

IRD

Lm85LOCK Property

LOCK

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDREADYLOCKSTARTOVERRIDE1 LOCK { get; set; }
Public Property LOCK As Lm85TYPIDREADYLOCKSTARTOVERRIDE1
    Get
    Set
public:
property Lm85TYPIDREADYLOCKSTARTOVERRIDE1 LOCK {
    Lm85TYPIDREADYLOCKSTARTOVERRIDE1 get ();
    void set (Lm85TYPIDREADYLOCKSTARTOVERRIDE1 value);
}
member LOCK : Lm85TYPIDREADYLOCKSTARTOVERRIDE1 with get, set

Property Value

Type: Lm85TYPIDREADYLOCKSTARTOVERRIDE1
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.MonitorModeTach1 Property

IRD

Lm85MonitorModeTach1 Property

Monitor Mode: Tach1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDTACHMONITORMODE0 MonitorModeTach1 { get; set; }
Public Property MonitorModeTach1 As Lm85TYPIDTACHMONITORMODE0
    Get
    Set
public:
property Lm85TYPIDTACHMONITORMODE0 MonitorModeTach1 {
    Lm85TYPIDTACHMONITORMODE0 get ();
    void set (Lm85TYPIDTACHMONITORMODE0 value);
}
member MonitorModeTach1 : Lm85TYPIDTACHMONITORMODE0 with get, set

Property Value

Type: Lm85TYPIDTACHMONITORMODE0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.MonitorModeTach2 Property

IRD

Lm85MonitorModeTach2 Property

Monitor Mode: Tach2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDTACHMONITORMODE0 MonitorModeTach2 { get; set; }
Public Property MonitorModeTach2 As Lm85TYPIDTACHMONITORMODE0
    Get
    Set
public:
property Lm85TYPIDTACHMONITORMODE0 MonitorModeTach2 {
    Lm85TYPIDTACHMONITORMODE0 get ();
    void set (Lm85TYPIDTACHMONITORMODE0 value);
}
member MonitorModeTach2 : Lm85TYPIDTACHMONITORMODE0 with get, set

Property Value

Type: Lm85TYPIDTACHMONITORMODE0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.MonitorModeTach34 Property

IRD

Lm85MonitorModeTach34 Property

Monitor Mode: Tach3/4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDTACHMONITORMODE0 MonitorModeTach34 { get; set; }
Public Property MonitorModeTach34 As Lm85TYPIDTACHMONITORMODE0
    Get
    Set
public:
property Lm85TYPIDTACHMONITORMODE0 MonitorModeTach34 {
    Lm85TYPIDTACHMONITORMODE0 get ();
    void set (Lm85TYPIDTACHMONITORMODE0 value);
}
member MonitorModeTach34 : Lm85TYPIDTACHMONITORMODE0 with get, set

Property Value

Type: Lm85TYPIDTACHMONITORMODE0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.OVRID Property

IRD

Lm85OVRID Property

OVRID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDREADYLOCKSTARTOVERRIDE3 OVRID { get; set; }
Public Property OVRID As Lm85TYPIDREADYLOCKSTARTOVERRIDE3
    Get
    Set
public:
property Lm85TYPIDREADYLOCKSTARTOVERRIDE3 OVRID {
    Lm85TYPIDREADYLOCKSTARTOVERRIDE3 get ();
    void set (Lm85TYPIDREADYLOCKSTARTOVERRIDE3 value);
}
member OVRID : Lm85TYPIDREADYLOCKSTARTOVERRIDE3 with get, set

Property Value

Type: Lm85TYPIDREADYLOCKSTARTOVERRIDE3
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.ProcessorZone1HighTemp Property

IRD

Lm85ProcessorZone1HighTemp Property

Processor (Zone1) High Temp (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ProcessorZone1HighTemp { get; set; }
Public Property ProcessorZone1HighTemp As SByte
    Get
    Set
public:
property signed char ProcessorZone1HighTemp {
    signed char get ();
    void set (signed char value);
}
member ProcessorZone1HighTemp : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.ProcessorZone1LowTemp Property

IRD

Lm85ProcessorZone1LowTemp Property

Processor (Zone1) Low Temp (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ProcessorZone1LowTemp { get; set; }
Public Property ProcessorZone1LowTemp As SByte
    Get
    Set
public:
property signed char ProcessorZone1LowTemp {
    signed char get ();
    void set (signed char value);
}
member ProcessorZone1LowTemp : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.ProcessorZone1Temp Property

IRD

Lm85ProcessorZone1Temp Property

Processor (Zone1) Temp (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDPROCESSORZONE1TEMP0 ProcessorZone1Temp { get; }
Public ReadOnly Property ProcessorZone1Temp As Lm85TYPIDPROCESSORZONE1TEMP0
    Get
public:
property Lm85TYPIDPROCESSORZONE1TEMP0 ProcessorZone1Temp {
    Lm85TYPIDPROCESSORZONE1TEMP0 get ();
}
member ProcessorZone1Temp : Lm85TYPIDPROCESSORZONE1TEMP0 with get

Property Value

Type: Lm85TYPIDPROCESSORZONE1TEMP0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.ProcessorZone2Temp Property

IRD

Lm85ProcessorZone2Temp Property

Processor (Zone2) Temp (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDPROCESSORZONE1TEMP0 ProcessorZone2Temp { get; }
Public ReadOnly Property ProcessorZone2Temp As Lm85TYPIDPROCESSORZONE1TEMP0
    Get
public:
property Lm85TYPIDPROCESSORZONE1TEMP0 ProcessorZone2Temp {
    Lm85TYPIDPROCESSORZONE1TEMP0 get ();
}
member ProcessorZone2Temp : Lm85TYPIDPROCESSORZONE1TEMP0 with get

Property Value

Type: Lm85TYPIDPROCESSORZONE1TEMP0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.ProcessorZone3Temp Property

IRD

Lm85ProcessorZone3Temp Property

Processor (Zone3) Temp (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDPROCESSORZONE1TEMP0 ProcessorZone3Temp { get; }
Public ReadOnly Property ProcessorZone3Temp As Lm85TYPIDPROCESSORZONE1TEMP0
    Get
public:
property Lm85TYPIDPROCESSORZONE1TEMP0 ProcessorZone3Temp {
    Lm85TYPIDPROCESSORZONE1TEMP0 get ();
}
member ProcessorZone3Temp : Lm85TYPIDPROCESSORZONE1TEMP0 with get

Property Value

Type: Lm85TYPIDPROCESSORZONE1TEMP0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Property_12V Property

IRD

Lm85Property_12V Property

12 V

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPID12V0 Property_12V { get; }
Public ReadOnly Property Property_12V As Lm85TYPID12V0
    Get
public:
property Lm85TYPID12V0 Property_12V {
    Lm85TYPID12V0 get ();
}
member Property_12V : Lm85TYPID12V0 with get

Property Value

Type: Lm85TYPID12V0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Property_12VError Property

IRD

Lm85Property_12VError Property

+12V_Error

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDINTERRUPTSTATUSREGISTER20 Property_12VError { get; }
Public ReadOnly Property Property_12VError As Lm85TYPIDINTERRUPTSTATUSREGISTER20
    Get
public:
property Lm85TYPIDINTERRUPTSTATUSREGISTER20 Property_12VError {
    Lm85TYPIDINTERRUPTSTATUSREGISTER20 get ();
}
member Property_12VError : Lm85TYPIDINTERRUPTSTATUSREGISTER20 with get

Property Value

Type: Lm85TYPIDINTERRUPTSTATUSREGISTER20
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Property_12VHighLimit Property

IRD

Lm85Property_12VHighLimit Property

12 V High Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPID12VLOWLIMIT0 Property_12VHighLimit { get; set; }
Public Property Property_12VHighLimit As Lm85TYPID12VLOWLIMIT0
    Get
    Set
public:
property Lm85TYPID12VLOWLIMIT0 Property_12VHighLimit {
    Lm85TYPID12VLOWLIMIT0 get ();
    void set (Lm85TYPID12VLOWLIMIT0 value);
}
member Property_12VHighLimit : Lm85TYPID12VLOWLIMIT0 with get, set

Property Value

Type: Lm85TYPID12VLOWLIMIT0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Property_12VLowLimit Property

IRD

Lm85Property_12VLowLimit Property

12 V Low Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPID12VLOWLIMIT0 Property_12VLowLimit { get; set; }
Public Property Property_12VLowLimit As Lm85TYPID12VLOWLIMIT0
    Get
    Set
public:
property Lm85TYPID12VLOWLIMIT0 Property_12VLowLimit {
    Lm85TYPID12VLOWLIMIT0 get ();
    void set (Lm85TYPID12VLOWLIMIT0 value);
}
member Property_12VLowLimit : Lm85TYPID12VLOWLIMIT0 with get, set

Property Value

Type: Lm85TYPID12VLOWLIMIT0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Property_25V Property

IRD

Lm85Property_25V Property

2.5 V (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPID25V0 Property_25V { get; }
Public ReadOnly Property Property_25V As Lm85TYPID25V0
    Get
public:
property Lm85TYPID25V0 Property_25V {
    Lm85TYPID25V0 get ();
}
member Property_25V : Lm85TYPID25V0 with get

Property Value

Type: Lm85TYPID25V0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Property_25VError Property

IRD

Lm85Property_25VError Property

2.5V_Error

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDINTERRUPTSTATUSREGISTER10 Property_25VError { get; }
Public ReadOnly Property Property_25VError As Lm85TYPIDINTERRUPTSTATUSREGISTER10
    Get
public:
property Lm85TYPIDINTERRUPTSTATUSREGISTER10 Property_25VError {
    Lm85TYPIDINTERRUPTSTATUSREGISTER10 get ();
}
member Property_25VError : Lm85TYPIDINTERRUPTSTATUSREGISTER10 with get

Property Value

Type: Lm85TYPIDINTERRUPTSTATUSREGISTER10
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Property_25VHighLimit Property

IRD

Lm85Property_25VHighLimit Property

2.5 V High Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPID25V0 Property_25VHighLimit { get; set; }
Public Property Property_25VHighLimit As Lm85TYPID25V0
    Get
    Set
public:
property Lm85TYPID25V0 Property_25VHighLimit {
    Lm85TYPID25V0 get ();
    void set (Lm85TYPID25V0 value);
}
member Property_25VHighLimit : Lm85TYPID25V0 with get, set

Property Value

Type: Lm85TYPID25V0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Property_25VLowLimit Property

IRD

Lm85Property_25VLowLimit Property

2.5 V Low Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPID25V0 Property_25VLowLimit { get; set; }
Public Property Property_25VLowLimit As Lm85TYPID25V0
    Get
    Set
public:
property Lm85TYPID25V0 Property_25VLowLimit {
    Lm85TYPID25V0 get ();
    void set (Lm85TYPID25V0 value);
}
member Property_25VLowLimit : Lm85TYPID25V0 with get, set

Property Value

Type: Lm85TYPID25V0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Property_33V Property

IRD

Lm85Property_33V Property

3.3 V

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPID33V0 Property_33V { get; }
Public ReadOnly Property Property_33V As Lm85TYPID33V0
    Get
public:
property Lm85TYPID33V0 Property_33V {
    Lm85TYPID33V0 get ();
}
member Property_33V : Lm85TYPID33V0 with get

Property Value

Type: Lm85TYPID33V0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Property_33VError Property

IRD

Lm85Property_33VError Property

3.3V_Error

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDINTERRUPTSTATUSREGISTER10 Property_33VError { get; }
Public ReadOnly Property Property_33VError As Lm85TYPIDINTERRUPTSTATUSREGISTER10
    Get
public:
property Lm85TYPIDINTERRUPTSTATUSREGISTER10 Property_33VError {
    Lm85TYPIDINTERRUPTSTATUSREGISTER10 get ();
}
member Property_33VError : Lm85TYPIDINTERRUPTSTATUSREGISTER10 with get

Property Value

Type: Lm85TYPIDINTERRUPTSTATUSREGISTER10
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Property_33VHighLimit Property

IRD

Lm85Property_33VHighLimit Property

3.3 V High Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPID33V0 Property_33VHighLimit { get; set; }
Public Property Property_33VHighLimit As Lm85TYPID33V0
    Get
    Set
public:
property Lm85TYPID33V0 Property_33VHighLimit {
    Lm85TYPID33V0 get ();
    void set (Lm85TYPID33V0 value);
}
member Property_33VHighLimit : Lm85TYPID33V0 with get, set

Property Value

Type: Lm85TYPID33V0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Property_33VLowLimit Property

IRD

Lm85Property_33VLowLimit Property

3.3 V Low Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPID33V0 Property_33VLowLimit { get; set; }
Public Property Property_33VLowLimit As Lm85TYPID33V0
    Get
    Set
public:
property Lm85TYPID33V0 Property_33VLowLimit {
    Lm85TYPID33V0 get ();
    void set (Lm85TYPID33V0 value);
}
member Property_33VLowLimit : Lm85TYPID33V0 with get, set

Property Value

Type: Lm85TYPID33V0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Property_5V Property

IRD

Lm85Property_5V Property

5 V

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPID5V0 Property_5V { get; }
Public ReadOnly Property Property_5V As Lm85TYPID5V0
    Get
public:
property Lm85TYPID5V0 Property_5V {
    Lm85TYPID5V0 get ();
}
member Property_5V : Lm85TYPID5V0 with get

Property Value

Type: Lm85TYPID5V0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Property_5VError Property

IRD

Lm85Property_5VError Property

5V_Error

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDINTERRUPTSTATUSREGISTER10 Property_5VError { get; }
Public ReadOnly Property Property_5VError As Lm85TYPIDINTERRUPTSTATUSREGISTER10
    Get
public:
property Lm85TYPIDINTERRUPTSTATUSREGISTER10 Property_5VError {
    Lm85TYPIDINTERRUPTSTATUSREGISTER10 get ();
}
member Property_5VError : Lm85TYPIDINTERRUPTSTATUSREGISTER10 with get

Property Value

Type: Lm85TYPIDINTERRUPTSTATUSREGISTER10
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Property_5VHighLimit Property

IRD

Lm85Property_5VHighLimit Property

5 V High Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPID5V0 Property_5VHighLimit { get; set; }
Public Property Property_5VHighLimit As Lm85TYPID5V0
    Get
    Set
public:
property Lm85TYPID5V0 Property_5VHighLimit {
    Lm85TYPID5V0 get ();
    void set (Lm85TYPID5V0 value);
}
member Property_5VHighLimit : Lm85TYPID5V0 with get, set

Property Value

Type: Lm85TYPID5V0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Property_5VLowLimit Property

IRD

Lm85Property_5VLowLimit Property

5 V Low Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPID5V0 Property_5VLowLimit { get; set; }
Public Property Property_5VLowLimit As Lm85TYPID5V0
    Get
    Set
public:
property Lm85TYPID5V0 Property_5VLowLimit {
    Lm85TYPID5V0 get ();
    void set (Lm85TYPID5V0 value);
}
member Property_5VLowLimit : Lm85TYPID5V0 with get, set

Property Value

Type: Lm85TYPID5V0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.PWM1SpinUpMode Property

IRD

Lm85PWM1SpinUpMode Property

PWM1 spin-up mode

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFANSPINUPMODE0 PWM1SpinUpMode { get; set; }
Public Property PWM1SpinUpMode As Lm85TYPIDFANSPINUPMODE0
    Get
    Set
public:
property Lm85TYPIDFANSPINUPMODE0 PWM1SpinUpMode {
    Lm85TYPIDFANSPINUPMODE0 get ();
    void set (Lm85TYPIDFANSPINUPMODE0 value);
}
member PWM1SpinUpMode : Lm85TYPIDFANSPINUPMODE0 with get, set

Property Value

Type: Lm85TYPIDFANSPINUPMODE0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.PWM2SpinUpMode Property

IRD

Lm85PWM2SpinUpMode Property

PWM2 spin-up mode

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFANSPINUPMODE0 PWM2SpinUpMode { get; set; }
Public Property PWM2SpinUpMode As Lm85TYPIDFANSPINUPMODE0
    Get
    Set
public:
property Lm85TYPIDFANSPINUPMODE0 PWM2SpinUpMode {
    Lm85TYPIDFANSPINUPMODE0 get ();
    void set (Lm85TYPIDFANSPINUPMODE0 value);
}
member PWM2SpinUpMode : Lm85TYPIDFANSPINUPMODE0 with get, set

Property Value

Type: Lm85TYPIDFANSPINUPMODE0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.PWM3SpinUpMode Property

IRD

Lm85PWM3SpinUpMode Property

PWM3 spin-up mode

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDFANSPINUPMODE0 PWM3SpinUpMode { get; set; }
Public Property PWM3SpinUpMode As Lm85TYPIDFANSPINUPMODE0
    Get
    Set
public:
property Lm85TYPIDFANSPINUPMODE0 PWM3SpinUpMode {
    Lm85TYPIDFANSPINUPMODE0 get ();
    void set (Lm85TYPIDFANSPINUPMODE0 value);
}
member PWM3SpinUpMode : Lm85TYPIDFANSPINUPMODE0 with get, set

Property Value

Type: Lm85TYPIDFANSPINUPMODE0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.READY Property

IRD

Lm85READY Property

READY

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDREADYLOCKSTARTOVERRIDE2 READY { get; }
Public ReadOnly Property READY As Lm85TYPIDREADYLOCKSTARTOVERRIDE2
    Get
public:
property Lm85TYPIDREADYLOCKSTARTOVERRIDE2 READY {
    Lm85TYPIDREADYLOCKSTARTOVERRIDE2 get ();
}
member READY : Lm85TYPIDREADYLOCKSTARTOVERRIDE2 with get

Property Value

Type: Lm85TYPIDREADYLOCKSTARTOVERRIDE2
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.RemoteDiode1Fault Property

IRD

Lm85RemoteDiode1Fault Property

Remote Diode 1 Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDINTERRUPTSTATUSREGISTER25 RemoteDiode1Fault { get; }
Public ReadOnly Property RemoteDiode1Fault As Lm85TYPIDINTERRUPTSTATUSREGISTER25
    Get
public:
property Lm85TYPIDINTERRUPTSTATUSREGISTER25 RemoteDiode1Fault {
    Lm85TYPIDINTERRUPTSTATUSREGISTER25 get ();
}
member RemoteDiode1Fault : Lm85TYPIDINTERRUPTSTATUSREGISTER25 with get

Property Value

Type: Lm85TYPIDINTERRUPTSTATUSREGISTER25
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.RemoteDiode2Fault Property

IRD

Lm85RemoteDiode2Fault Property

Remote Diode 2 Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDINTERRUPTSTATUSREGISTER26 RemoteDiode2Fault { get; }
Public ReadOnly Property RemoteDiode2Fault As Lm85TYPIDINTERRUPTSTATUSREGISTER26
    Get
public:
property Lm85TYPIDINTERRUPTSTATUSREGISTER26 RemoteDiode2Fault {
    Lm85TYPIDINTERRUPTSTATUSREGISTER26 get ();
}
member RemoteDiode2Fault : Lm85TYPIDINTERRUPTSTATUSREGISTER26 with get

Property Value

Type: Lm85TYPIDINTERRUPTSTATUSREGISTER26
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.RemoteZone3HighTemp Property

IRD

Lm85RemoteZone3HighTemp Property

Remote (Zone3) High Temp (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteZone3HighTemp { get; set; }
Public Property RemoteZone3HighTemp As SByte
    Get
    Set
public:
property signed char RemoteZone3HighTemp {
    signed char get ();
    void set (signed char value);
}
member RemoteZone3HighTemp : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.RemoteZone3LowTemp Property

IRD

Lm85RemoteZone3LowTemp Property

Remote (Zone3) Low Temp (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteZone3LowTemp { get; set; }
Public Property RemoteZone3LowTemp As SByte
    Get
    Set
public:
property signed char RemoteZone3LowTemp {
    signed char get ();
    void set (signed char value);
}
member RemoteZone3LowTemp : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.SpikeSmoothing1 Property

IRD

Lm85SpikeSmoothing1 Property

Spike Smoothing 1 (unit: s)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0 SpikeSmoothing1 { get; set; }
Public Property SpikeSmoothing1 As Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0
    Get
    Set
public:
property Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0 SpikeSmoothing1 {
    Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0 get ();
    void set (Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0 value);
}
member SpikeSmoothing1 : Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0 with get, set

Property Value

Type: Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.SpikeSmoothing1Off Property

IRD

Lm85SpikeSmoothing1Off Property

Spike Smoothing 1 off

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2 SpikeSmoothing1Off { get; set; }
Public Property SpikeSmoothing1Off As Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2
    Get
    Set
public:
property Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2 SpikeSmoothing1Off {
    Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2 get ();
    void set (Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2 value);
}
member SpikeSmoothing1Off : Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2 with get, set

Property Value

Type: Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.SpikeSmoothing2 Property

IRD

Lm85SpikeSmoothing2 Property

Spike Smoothing 2 (unit: s)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0 SpikeSmoothing2 { get; set; }
Public Property SpikeSmoothing2 As Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0
    Get
    Set
public:
property Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0 SpikeSmoothing2 {
    Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0 get ();
    void set (Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0 value);
}
member SpikeSmoothing2 : Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0 with get, set

Property Value

Type: Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.SpikeSmoothing2Off Property

IRD

Lm85SpikeSmoothing2Off Property

Spike Smoothing 2 off

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2 SpikeSmoothing2Off { get; set; }
Public Property SpikeSmoothing2Off As Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2
    Get
    Set
public:
property Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2 SpikeSmoothing2Off {
    Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2 get ();
    void set (Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2 value);
}
member SpikeSmoothing2Off : Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2 with get, set

Property Value

Type: Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.SpikeSmoothing3 Property

IRD

Lm85SpikeSmoothing3 Property

Spike Smoothing 3 (unit: s)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0 SpikeSmoothing3 { get; set; }
Public Property SpikeSmoothing3 As Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0
    Get
    Set
public:
property Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0 SpikeSmoothing3 {
    Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0 get ();
    void set (Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0 value);
}
member SpikeSmoothing3 : Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0 with get, set

Property Value

Type: Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.SpikeSmoothing3Off Property

IRD

Lm85SpikeSmoothing3Off Property

Spike Smoothing 3 off

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2 SpikeSmoothing3Off { get; set; }
Public Property SpikeSmoothing3Off As Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2
    Get
    Set
public:
property Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2 SpikeSmoothing3Off {
    Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2 get ();
    void set (Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2 value);
}
member SpikeSmoothing3Off : Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2 with get, set

Property Value

Type: Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Start Property

IRD

Lm85Start Property

Start

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDREADYLOCKSTARTOVERRIDE0 Start { get; set; }
Public Property Start As Lm85TYPIDREADYLOCKSTARTOVERRIDE0
    Get
    Set
public:
property Lm85TYPIDREADYLOCKSTARTOVERRIDE0 Start {
    Lm85TYPIDREADYLOCKSTARTOVERRIDE0 get ();
    void set (Lm85TYPIDREADYLOCKSTARTOVERRIDE0 value);
}
member Start : Lm85TYPIDREADYLOCKSTARTOVERRIDE0 with get, set

Property Value

Type: Lm85TYPIDREADYLOCKSTARTOVERRIDE0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.SteppingID Property

IRD

Lm85SteppingID Property

Stepping ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SteppingID { get; }
Public ReadOnly Property SteppingID As Byte
    Get
public:
property unsigned char SteppingID {
    unsigned char get ();
}
member SteppingID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Tach1 Property

IRD

Lm85Tach1 Property

Tach1 (unit: µs/Periode)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Tach1 { get; }
Public ReadOnly Property Tach1 As Double
    Get
public:
property double Tach1 {
    double get ();
}
member Tach1 : float with get

Property Value

Type: Double
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Tach1AccurateLevel Property

IRD

Lm85Tach1AccurateLevel Property

Tach1: Accurate Level

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDTACH1LSB0 Tach1AccurateLevel { get; }
Public ReadOnly Property Tach1AccurateLevel As Lm85TYPIDTACH1LSB0
    Get
public:
property Lm85TYPIDTACH1LSB0 Tach1AccurateLevel {
    Lm85TYPIDTACH1LSB0 get ();
}
member Tach1AccurateLevel : Lm85TYPIDTACH1LSB0 with get

Property Value

Type: Lm85TYPIDTACH1LSB0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Tach1Fan Property

IRD

Lm85Tach1Fan Property

Tach1 Fan

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDTACH1MINIMUMLSB0 Tach1Fan { get; set; }
Public Property Tach1Fan As Lm85TYPIDTACH1MINIMUMLSB0
    Get
    Set
public:
property Lm85TYPIDTACH1MINIMUMLSB0 Tach1Fan {
    Lm85TYPIDTACH1MINIMUMLSB0 get ();
    void set (Lm85TYPIDTACH1MINIMUMLSB0 value);
}
member Tach1Fan : Lm85TYPIDTACH1MINIMUMLSB0 with get, set

Property Value

Type: Lm85TYPIDTACH1MINIMUMLSB0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Tach1Minimum Property

IRD

Lm85Tach1Minimum Property

Tach1 Minimum (unit: µs/Periode)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Tach1Minimum { get; set; }
Public Property Tach1Minimum As Double
    Get
    Set
public:
property double Tach1Minimum {
    double get ();
    void set (double value);
}
member Tach1Minimum : float with get, set

Property Value

Type: Double
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Tach2 Property

IRD

Lm85Tach2 Property

Tach2 (unit: µs/Periode)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Tach2 { get; }
Public ReadOnly Property Tach2 As Double
    Get
public:
property double Tach2 {
    double get ();
}
member Tach2 : float with get

Property Value

Type: Double
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Tach2AccurateLevel Property

IRD

Lm85Tach2AccurateLevel Property

Tach2: Accurate Level

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDTACH1LSB0 Tach2AccurateLevel { get; }
Public ReadOnly Property Tach2AccurateLevel As Lm85TYPIDTACH1LSB0
    Get
public:
property Lm85TYPIDTACH1LSB0 Tach2AccurateLevel {
    Lm85TYPIDTACH1LSB0 get ();
}
member Tach2AccurateLevel : Lm85TYPIDTACH1LSB0 with get

Property Value

Type: Lm85TYPIDTACH1LSB0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Tach2Fan Property

IRD

Lm85Tach2Fan Property

Tach2 Fan

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDTACH1MINIMUMLSB0 Tach2Fan { get; set; }
Public Property Tach2Fan As Lm85TYPIDTACH1MINIMUMLSB0
    Get
    Set
public:
property Lm85TYPIDTACH1MINIMUMLSB0 Tach2Fan {
    Lm85TYPIDTACH1MINIMUMLSB0 get ();
    void set (Lm85TYPIDTACH1MINIMUMLSB0 value);
}
member Tach2Fan : Lm85TYPIDTACH1MINIMUMLSB0 with get, set

Property Value

Type: Lm85TYPIDTACH1MINIMUMLSB0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Tach2Minimum Property

IRD

Lm85Tach2Minimum Property

Tach2 Minimum (unit: µs/Periode)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Tach2Minimum { get; set; }
Public Property Tach2Minimum As Double
    Get
    Set
public:
property double Tach2Minimum {
    double get ();
    void set (double value);
}
member Tach2Minimum : float with get, set

Property Value

Type: Double
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Tach3 Property

IRD

Lm85Tach3 Property

Tach3 (unit: µs/Periode)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Tach3 { get; }
Public ReadOnly Property Tach3 As Double
    Get
public:
property double Tach3 {
    double get ();
}
member Tach3 : float with get

Property Value

Type: Double
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Tach3AccurateLevel Property

IRD

Lm85Tach3AccurateLevel Property

Tach3: Accurate Level

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDTACH1LSB0 Tach3AccurateLevel { get; }
Public ReadOnly Property Tach3AccurateLevel As Lm85TYPIDTACH1LSB0
    Get
public:
property Lm85TYPIDTACH1LSB0 Tach3AccurateLevel {
    Lm85TYPIDTACH1LSB0 get ();
}
member Tach3AccurateLevel : Lm85TYPIDTACH1LSB0 with get

Property Value

Type: Lm85TYPIDTACH1LSB0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Tach3Fan Property

IRD

Lm85Tach3Fan Property

Tach3 Fan

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDTACH1MINIMUMLSB0 Tach3Fan { get; set; }
Public Property Tach3Fan As Lm85TYPIDTACH1MINIMUMLSB0
    Get
    Set
public:
property Lm85TYPIDTACH1MINIMUMLSB0 Tach3Fan {
    Lm85TYPIDTACH1MINIMUMLSB0 get ();
    void set (Lm85TYPIDTACH1MINIMUMLSB0 value);
}
member Tach3Fan : Lm85TYPIDTACH1MINIMUMLSB0 with get, set

Property Value

Type: Lm85TYPIDTACH1MINIMUMLSB0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Tach3Minimum Property

IRD

Lm85Tach3Minimum Property

Tach3 Minimum (unit: µs/Periode)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Tach3Minimum { get; set; }
Public Property Tach3Minimum As Double
    Get
    Set
public:
property double Tach3Minimum {
    double get ();
    void set (double value);
}
member Tach3Minimum : float with get, set

Property Value

Type: Double
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Tach4 Property

IRD

Lm85Tach4 Property

Tach4 (unit: µs/Periode)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Tach4 { get; }
Public ReadOnly Property Tach4 As Double
    Get
public:
property double Tach4 {
    double get ();
}
member Tach4 : float with get

Property Value

Type: Double
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Tach4AccurateLevel Property

IRD

Lm85Tach4AccurateLevel Property

Tach4: Accurate Level

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDTACH1LSB0 Tach4AccurateLevel { get; }
Public ReadOnly Property Tach4AccurateLevel As Lm85TYPIDTACH1LSB0
    Get
public:
property Lm85TYPIDTACH1LSB0 Tach4AccurateLevel {
    Lm85TYPIDTACH1LSB0 get ();
}
member Tach4AccurateLevel : Lm85TYPIDTACH1LSB0 with get

Property Value

Type: Lm85TYPIDTACH1LSB0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Tach4Fan Property

IRD

Lm85Tach4Fan Property

Tach4 Fan

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDTACH1MINIMUMLSB0 Tach4Fan { get; set; }
Public Property Tach4Fan As Lm85TYPIDTACH1MINIMUMLSB0
    Get
    Set
public:
property Lm85TYPIDTACH1MINIMUMLSB0 Tach4Fan {
    Lm85TYPIDTACH1MINIMUMLSB0 get ();
    void set (Lm85TYPIDTACH1MINIMUMLSB0 value);
}
member Tach4Fan : Lm85TYPIDTACH1MINIMUMLSB0 with get, set

Property Value

Type: Lm85TYPIDTACH1MINIMUMLSB0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Tach4Minimum Property

IRD

Lm85Tach4Minimum Property

Tach4 Minimum (unit: µs/Periode)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Tach4Minimum { get; set; }
Public Property Tach4Minimum As Double
    Get
    Set
public:
property double Tach4Minimum {
    double get ();
    void set (double value);
}
member Tach4Minimum : float with get, set

Property Value

Type: Double
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.VCCPError Property

IRD

Lm85VCCPError Property

VCCP_Error

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDINTERRUPTSTATUSREGISTER10 VCCPError { get; }
Public ReadOnly Property VCCPError As Lm85TYPIDINTERRUPTSTATUSREGISTER10
    Get
public:
property Lm85TYPIDINTERRUPTSTATUSREGISTER10 VCCPError {
    Lm85TYPIDINTERRUPTSTATUSREGISTER10 get ();
}
member VCCPError : Lm85TYPIDINTERRUPTSTATUSREGISTER10 with get

Property Value

Type: Lm85TYPIDINTERRUPTSTATUSREGISTER10
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.VCCPHighLimit Property

IRD

Lm85VCCPHighLimit Property

VCCP High Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDVCCP0 VCCPHighLimit { get; set; }
Public Property VCCPHighLimit As Lm85TYPIDVCCP0
    Get
    Set
public:
property Lm85TYPIDVCCP0 VCCPHighLimit {
    Lm85TYPIDVCCP0 get ();
    void set (Lm85TYPIDVCCP0 value);
}
member VCCPHighLimit : Lm85TYPIDVCCP0 with get, set

Property Value

Type: Lm85TYPIDVCCP0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.VCCPLowLimit Property

IRD

Lm85VCCPLowLimit Property

VCCP Low Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDVCCP0 VCCPLowLimit { get; set; }
Public Property VCCPLowLimit As Lm85TYPIDVCCP0
    Get
    Set
public:
property Lm85TYPIDVCCP0 VCCPLowLimit {
    Lm85TYPIDVCCP0 get ();
    void set (Lm85TYPIDVCCP0 value);
}
member VCCPLowLimit : Lm85TYPIDVCCP0 with get, set

Property Value

Type: Lm85TYPIDVCCP0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.VCPP Property

IRD

Lm85VCPP Property

VCPP (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDVCCP0 VCPP { get; }
Public ReadOnly Property VCPP As Lm85TYPIDVCCP0
    Get
public:
property Lm85TYPIDVCCP0 VCPP {
    Lm85TYPIDVCCP0 get ();
}
member VCPP : Lm85TYPIDVCCP0 with get

Property Value

Type: Lm85TYPIDVCCP0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Version Property

IRD

Lm85Version Property

Version

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Version { get; }
Public ReadOnly Property Version As Byte
    Get
public:
property unsigned char Version {
    unsigned char get ();
}
member Version : byte with get

Property Value

Type: Byte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.VID0 Property

IRD

Lm85VID0 Property

VID0

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VID0 { get; }
Public ReadOnly Property VID0 As Byte
    Get
public:
property unsigned char VID0 {
    unsigned char get ();
}
member VID0 : byte with get

Property Value

Type: Byte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.VID1 Property

IRD

Lm85VID1 Property

VID1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VID1 { get; }
Public ReadOnly Property VID1 As Byte
    Get
public:
property unsigned char VID1 {
    unsigned char get ();
}
member VID1 : byte with get

Property Value

Type: Byte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.VID2 Property

IRD

Lm85VID2 Property

VID2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VID2 { get; }
Public ReadOnly Property VID2 As Byte
    Get
public:
property unsigned char VID2 {
    unsigned char get ();
}
member VID2 : byte with get

Property Value

Type: Byte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.VID3 Property

IRD

Lm85VID3 Property

VID3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VID3 { get; }
Public ReadOnly Property VID3 As Byte
    Get
public:
property unsigned char VID3 {
    unsigned char get ();
}
member VID3 : byte with get

Property Value

Type: Byte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.VID4 Property

IRD

Lm85VID4 Property

VID4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VID4 { get; }
Public ReadOnly Property VID4 As Byte
    Get
public:
property unsigned char VID4 {
    unsigned char get ();
}
member VID4 : byte with get

Property Value

Type: Byte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.XEN Property

IRD

Lm85XEN Property

XEN

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDXORTESTTREEENABLE0 XEN { get; set; }
Public Property XEN As Lm85TYPIDXORTESTTREEENABLE0
    Get
    Set
public:
property Lm85TYPIDXORTESTTREEENABLE0 XEN {
    Lm85TYPIDXORTESTTREEENABLE0 get ();
    void set (Lm85TYPIDXORTESTTREEENABLE0 value);
}
member XEN : Lm85TYPIDXORTESTTREEENABLE0 with get, set

Property Value

Type: Lm85TYPIDXORTESTTREEENABLE0
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Zone1 Property

IRD

Lm85Zone1 Property

Zone 1 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Zone1 { get; set; }
Public Property Zone1 As Byte
    Get
    Set
public:
property unsigned char Zone1 {
    unsigned char get ();
    void set (unsigned char value);
}
member Zone1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Zone1FanTempLimit Property

IRD

Lm85Zone1FanTempLimit Property

Zone1 Fan Temp Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Zone1FanTempLimit { get; set; }
Public Property Zone1FanTempLimit As SByte
    Get
    Set
public:
property signed char Zone1FanTempLimit {
    signed char get ();
    void set (signed char value);
}
member Zone1FanTempLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Zone1LimitExceeded Property

IRD

Lm85Zone1LimitExceeded Property

Zone 1 Limit Exceeded

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDINTERRUPTSTATUSREGISTER14 Zone1LimitExceeded { get; }
Public ReadOnly Property Zone1LimitExceeded As Lm85TYPIDINTERRUPTSTATUSREGISTER14
    Get
public:
property Lm85TYPIDINTERRUPTSTATUSREGISTER14 Zone1LimitExceeded {
    Lm85TYPIDINTERRUPTSTATUSREGISTER14 get ();
}
member Zone1LimitExceeded : Lm85TYPIDINTERRUPTSTATUSREGISTER14 with get

Property Value

Type: Lm85TYPIDINTERRUPTSTATUSREGISTER14
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Zone1TempAbsoluteLimit Property

IRD

Lm85Zone1TempAbsoluteLimit Property

Zone1 Temp Absolute Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Zone1TempAbsoluteLimit { get; set; }
Public Property Zone1TempAbsoluteLimit As SByte
    Get
    Set
public:
property signed char Zone1TempAbsoluteLimit {
    signed char get ();
    void set (signed char value);
}
member Zone1TempAbsoluteLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Zone2 Property

IRD

Lm85Zone2 Property

Zone 2 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Zone2 { get; set; }
Public Property Zone2 As Byte
    Get
    Set
public:
property unsigned char Zone2 {
    unsigned char get ();
    void set (unsigned char value);
}
member Zone2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Zone2FanTempLimit Property

IRD

Lm85Zone2FanTempLimit Property

Zone2 Fan Temp Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Zone2FanTempLimit { get; set; }
Public Property Zone2FanTempLimit As SByte
    Get
    Set
public:
property signed char Zone2FanTempLimit {
    signed char get ();
    void set (signed char value);
}
member Zone2FanTempLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Zone2LimitExceeded Property

IRD

Lm85Zone2LimitExceeded Property

Zone 2 Limit Exceeded

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDINTERRUPTSTATUSREGISTER15 Zone2LimitExceeded { get; }
Public ReadOnly Property Zone2LimitExceeded As Lm85TYPIDINTERRUPTSTATUSREGISTER15
    Get
public:
property Lm85TYPIDINTERRUPTSTATUSREGISTER15 Zone2LimitExceeded {
    Lm85TYPIDINTERRUPTSTATUSREGISTER15 get ();
}
member Zone2LimitExceeded : Lm85TYPIDINTERRUPTSTATUSREGISTER15 with get

Property Value

Type: Lm85TYPIDINTERRUPTSTATUSREGISTER15
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Zone2TempAbsoluteLimit Property

IRD

Lm85Zone2TempAbsoluteLimit Property

Zone2 Temp Absolute Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Zone2TempAbsoluteLimit { get; set; }
Public Property Zone2TempAbsoluteLimit As SByte
    Get
    Set
public:
property signed char Zone2TempAbsoluteLimit {
    signed char get ();
    void set (signed char value);
}
member Zone2TempAbsoluteLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Zone3 Property

IRD

Lm85Zone3 Property

Zone 3 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Zone3 { get; set; }
Public Property Zone3 As Byte
    Get
    Set
public:
property unsigned char Zone3 {
    unsigned char get ();
    void set (unsigned char value);
}
member Zone3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Zone3FanTempLimit Property

IRD

Lm85Zone3FanTempLimit Property

Zone3 Fan Temp Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Zone3FanTempLimit { get; set; }
Public Property Zone3FanTempLimit As SByte
    Get
    Set
public:
property signed char Zone3FanTempLimit {
    signed char get ();
    void set (signed char value);
}
member Zone3FanTempLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Zone3LimitExceeded Property

IRD

Lm85Zone3LimitExceeded Property

Zone 3 Limit Exceeded

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm85TYPIDINTERRUPTSTATUSREGISTER16 Zone3LimitExceeded { get; }
Public ReadOnly Property Zone3LimitExceeded As Lm85TYPIDINTERRUPTSTATUSREGISTER16
    Get
public:
property Lm85TYPIDINTERRUPTSTATUSREGISTER16 Zone3LimitExceeded {
    Lm85TYPIDINTERRUPTSTATUSREGISTER16 get ();
}
member Zone3LimitExceeded : Lm85TYPIDINTERRUPTSTATUSREGISTER16 with get

Property Value

Type: Lm85TYPIDINTERRUPTSTATUSREGISTER16
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Zone3TempAbsoluteLimit Property

IRD

Lm85Zone3TempAbsoluteLimit Property

Zone3 Temp Absolute Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte Zone3TempAbsoluteLimit { get; set; }
Public Property Zone3TempAbsoluteLimit As SByte
    Get
    Set
public:
property signed char Zone3TempAbsoluteLimit {
    signed char get ();
    void set (signed char value);
}
member Zone3TempAbsoluteLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85 Methods

The Lm85 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.Flush Method

IRD

Lm85Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm85 Class
telos.Ird.NationalSemiconductor Namespace


Lm85.IDEnableDisable Enumeration

IRD

Lm85IDEnableDisable Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IDEnableDisable
Public Enumeration IDEnableDisable
public enum class IDEnableDisable
type IDEnableDisable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPID12V0 Enumeration

IRD

Lm85TYPID12V0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPID12V0
Public Enumeration TYPID12V0
public enum class TYPID12V0
type TYPID12V0
Members
Member name | Value | Description
Value_0_000 | 0 | 0.000
Value_0_063 | 1 | 0.063
Value_0_125 | 2 | 0.125
Value_0_188 | 3 | 0.188
Value_0_250 | 4 | 0.250
Value_0_313 | 5 | 0.313
Value_0_375 | 6 | 0.375
Value_0_438 | 7 | 0.438
Value_0_500 | 8 | 0.500
Value_0_563 | 9 | 0.563
Value_0_625 | 10 | 0.625
Value_0_688 | 11 | 0.688
Value_0_750 | 12 | 0.750
Value_0_813 | 13 | 0.813
Value_0_875 | 14 | 0.875
Value_0_938 | 15 | 0.938
Value_1_000 | 16 | 1.000
Value_1_063 | 17 | 1.063
Value_1_125 | 18 | 1.125
Value_1_188 | 19 | 1.188
Value_1_250 | 20 | 1.250
Value_1_313 | 21 | 1.313
Value_1_375 | 22 | 1.375
Value_1_438 | 23 | 1.438
Value_1_500 | 24 | 1.500
Value_1_563 | 25 | 1.563
Value_1_625 | 26 | 1.625
Value_1_688 | 27 | 1.688
Value_1_750 | 28 | 1.750
Value_1_813 | 29 | 1.813
Value_1_875 | 30 | 1.875
Value_1_938 | 31 | 1.938
Value_2_000 | 32 | 2.000
Value_2_063 | 33 | 2.063
Value_2_125 | 34 | 2.125
Value_2_188 | 35 | 2.188
Value_2_250 | 36 | 2.250
Value_2_313 | 37 | 2.313
Value_2_375 | 38 | 2.375
Value_2_438 | 39 | 2.438
Value_2_500 | 40 | 2.500
Value_2_563 | 41 | 2.563
Value_2_625 | 42 | 2.625
Value_2_688 | 43 | 2.688
Value_2_750 | 44 | 2.750
Value_2_813 | 45 | 2.813
Value_2_875 | 46 | 2.875
Value_2_938 | 47 | 2.938
Value_3_000 | 48 | 3.000
Value_3_063 | 49 | 3.063
Value_3_125 | 50 | 3.125
Value_3_188 | 51 | 3.188
Value_3_250 | 52 | 3.250
Value_3_313 | 53 | 3.313
Value_3_375 | 54 | 3.375
Value_3_438 | 55 | 3.438
Value_3_500 | 56 | 3.500
Value_3_563 | 57 | 3.563
Value_3_625 | 58 | 3.625
Value_3_688 | 59 | 3.688
Value_3_750 | 60 | 3.750
Value_3_813 | 61 | 3.813
Value_3_875 | 62 | 3.875
Value_3_938 | 63 | 3.938
Value_4_000 | 64 | 4.000
Value_4_063 | 65 | 4.063
Value_4_125 | 66 | 4.125
Value_4_188 | 67 | 4.188
Value_4_250 | 68 | 4.250
Value_4_313 | 69 | 4.313
Value_4_375 | 70 | 4.375
Value_4_438 | 71 | 4.438
Value_4_500 | 72 | 4.500
Value_4_563 | 73 | 4.563
Value_4_625 | 74 | 4.625
Value_4_688 | 75 | 4.688
Value_4_750 | 76 | 4.750
Value_4_813 | 77 | 4.813
Value_4_875 | 78 | 4.875
Value_4_938 | 79 | 4.938
Value_5_000 | 80 | 5.000
Value_5_063 | 81 | 5.063
Value_5_125 | 82 | 5.125
Value_5_188 | 83 | 5.188
Value_5_250 | 84 | 5.250
Value_5_313 | 85 | 5.313
Value_5_375 | 86 | 5.375
Value_5_438 | 87 | 5.438
Value_5_500 | 88 | 5.500
Value_5_563 | 89 | 5.563
Value_5_625 | 90 | 5.625
Value_5_688 | 91 | 5.688
Value_5_750 | 92 | 5.750
Value_5_813 | 93 | 5.813
Value_5_875 | 94 | 5.875
Value_5_938 | 95 | 5.938
Value_6_000 | 96 | 6.000
Value_6_063 | 97 | 6.063
Value_6_125 | 98 | 6.125
Value_6_188 | 99 | 6.188
Value_6_250 | 100 | 6.250
Value_6_313 | 101 | 6.313
Value_6_375 | 102 | 6.375
Value_6_438 | 103 | 6.438
Value_6_500 | 104 | 6.500
Value_6_563 | 105 | 6.563
Value_6_625 | 106 | 6.625
Value_6_688 | 107 | 6.688
Value_6_750 | 108 | 6.750
Value_6_813 | 109 | 6.813
Value_6_875 | 110 | 6.875
Value_6_938 | 111 | 6.938
Value_7_000 | 112 | 7.000
Value_7_063 | 113 | 7.063
Value_7_125 | 114 | 7.125
Value_7_188 | 115 | 7.188
Value_7_250 | 116 | 7.250
Value_7_313 | 117 | 7.313
Value_7_375 | 118 | 7.375
Value_7_438 | 119 | 7.438
Value_7_500 | 120 | 7.500
Value_7_563 | 121 | 7.563
Value_7_625 | 122 | 7.625
Value_7_688 | 123 | 7.688
Value_7_750 | 124 | 7.750
Value_7_813 | 125 | 7.813
Value_7_875 | 126 | 7.875
Value_7_938 | 127 | 7.938
Value_8_000 | 128 | 8.000
Value_8_063 | 129 | 8.063
Value_8_125 | 130 | 8.125
Value_8_188 | 131 | 8.188
Value_8_250 | 132 | 8.250
Value_8_313 | 133 | 8.313
Value_8_375 | 134 | 8.375
Value_8_438 | 135 | 8.438
Value_8_500 | 136 | 8.500
Value_8_563 | 137 | 8.563
Value_8_625 | 138 | 8.625
Value_8_688 | 139 | 8.688
Value_8_750 | 140 | 8.750
Value_8_813 | 141 | 8.813
Value_8_875 | 142 | 8.875
Value_8_938 | 143 | 8.938
Value_9_000 | 144 | 9.000
Value_9_063 | 145 | 9.063
Value_9_125 | 146 | 9.125
Value_9_188 | 147 | 9.188
Value_9_250 | 148 | 9.250
Value_9_313 | 149 | 9.313
Value_9_375 | 150 | 9.375
Value_9_438 | 151 | 9.438
Value_9_500 | 152 | 9.500
Value_9_563 | 153 | 9.563
Value_9_625 | 154 | 9.625
Value_9_688 | 155 | 9.688
Value_9_750 | 156 | 9.750
Value_9_813 | 157 | 9.813
Value_9_875 | 158 | 9.875
Value_9_938 | 159 | 9.938
Value_10_000 | 160 | 10.000
Value_10_063 | 161 | 10.063
Value_10_125 | 162 | 10.125
Value_10_188 | 163 | 10.188
Value_10_250 | 164 | 10.250
Value_10_313 | 165 | 10.313
Value_10_375 | 166 | 10.375
Value_10_438 | 167 | 10.438
Value_10_500 | 168 | 10.500
Value_10_563 | 169 | 10.563
Value_10_625 | 170 | 10.625
Value_10_688 | 171 | 10.688
Value_10_750 | 172 | 10.750
Value_10_813 | 173 | 10.813
Value_10_875 | 174 | 10.875
Value_10_938 | 175 | 10.938
Value_11_000 | 176 | 11.000
Value_11_063 | 177 | 11.063
Value_11_125 | 178 | 11.125
Value_11_188 | 179 | 11.188
Value_11_250 | 180 | 11.250
Value_11_313 | 181 | 11.313
Value_11_375 | 182 | 11.375
Value_11_438 | 183 | 11.438
Value_11_500 | 184 | 11.500
Value_11_563 | 185 | 11.563
Value_11_625 | 186 | 11.625
Value_11_688 | 187 | 11.688
Value_11_750 | 188 | 11.750
Value_11_813 | 189 | 11.813
Value_11_875 | 190 | 11.875
Value_11_938 | 191 | 11.938
Value_12_000 | 192 | 12.000
Value_12_063 | 193 | 12.063
Value_12_125 | 194 | 12.125
Value_12_188 | 195 | 12.188
Value_12_250 | 196 | 12.250
Value_12_313 | 197 | 12.313
Value_12_375 | 198 | 12.375
Value_12_438 | 199 | 12.438
Value_12_500 | 200 | 12.500
Value_12_563 | 201 | 12.563
Value_12_625 | 202 | 12.625
Value_12_688 | 203 | 12.688
Value_12_750 | 204 | 12.750
Value_12_813 | 205 | 12.813
Value_12_875 | 206 | 12.875
Value_12_938 | 207 | 12.938
Value_13_000 | 208 | 13.000
Value_13_063 | 209 | 13.063
Value_13_125 | 210 | 13.125
Value_13_188 | 211 | 13.188
Value_13_250 | 212 | 13.250
Value_13_313 | 213 | 13.313
Value_13_375 | 214 | 13.375
Value_13_438 | 215 | 13.438
Value_13_500 | 216 | 13.500
Value_13_563 | 217 | 13.563
Value_13_625 | 218 | 13.625
Value_13_688 | 219 | 13.688
Value_13_750 | 220 | 13.750
Value_13_813 | 221 | 13.813
Value_13_875 | 222 | 13.875
Value_13_938 | 223 | 13.938
Value_14_000 | 224 | 14.000
Value_14_063 | 225 | 14.063
Value_14_125 | 226 | 14.125
Value_14_188 | 227 | 14.188
Value_14_250 | 228 | 14.250
Value_14_313 | 229 | 14.313
Value_14_375 | 230 | 14.375
Value_14_438 | 231 | 14.438
Value_14_500 | 232 | 14.500
Value_14_563 | 233 | 14.563
Value_14_625 | 234 | 14.625
Value_14_688 | 235 | 14.688
Value_14_750 | 236 | 14.750
Value_14_813 | 237 | 14.813
Value_14_875 | 238 | 14.875
Value_14_938 | 239 | 14.938
Value_15_000 | 240 | 15.000
Value_15_063 | 241 | 15.063
Value_15_125 | 242 | 15.125
Value_15_188 | 243 | 15.188
Value_15_250 | 244 | 15.250
Value_15_313 | 245 | 15.313
Value_15_375 | 246 | 15.375
Value_15_438 | 247 | 15.438
Value_15_500 | 248 | 15.500
Value_15_563 | 249 | 15.563
Value_15_625 | 250 | 15.625
Value_15_688 | 251 | 15.688
Value_15_750 | 252 | 15.750
Value_15_813 | 253 | 15.813
Value_15_875 | 254 | 15.875
Value_15_938 | 255 | 15.938
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPID12VLOWLIMIT0 Enumeration

IRD

Lm85TYPID12VLOWLIMIT0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPID12VLOWLIMIT0
Public Enumeration TYPID12VLOWLIMIT0
public enum class TYPID12VLOWLIMIT0
type TYPID12VLOWLIMIT0
Members
Member name | Value | Description
Value_0_000 | 0 | 0.000
Value_0_063 | 1 | 0.063
Value_0_125 | 2 | 0.125
Value_0_188 | 3 | 0.188
Value_0_250 | 4 | 0.250
Value_0_313 | 5 | 0.313
Value_0_375 | 6 | 0.375
Value_0_438 | 7 | 0.438
Value_0_500 | 8 | 0.500
Value_0_563 | 9 | 0.563
Value_0_625 | 10 | 0.625
Value_0_688 | 11 | 0.688
Value_0_750 | 12 | 0.750
Value_0_813 | 13 | 0.813
Value_0_875 | 14 | 0.875
Value_0_938 | 15 | 0.938
Value_1_000 | 16 | 1.000
Value_1_063 | 17 | 1.063
Value_1_125 | 18 | 1.125
Value_1_188 | 19 | 1.188
Value_1_250 | 20 | 1.250
Value_1_313 | 21 | 1.313
Value_1_375 | 22 | 1.375
Value_1_438 | 23 | 1.438
Value_1_500 | 24 | 1.500
Value_1_563 | 25 | 1.563
Value_1_625 | 26 | 1.625
Value_1_688 | 27 | 1.688
Value_1_750 | 28 | 1.750
Value_1_813 | 29 | 1.813
Value_1_875 | 30 | 1.875
Value_1_938 | 31 | 1.938
Value_2_000 | 32 | 2.000
Value_2_063 | 33 | 2.063
Value_2_125 | 34 | 2.125
Value_2_188 | 35 | 2.188
Value_2_250 | 36 | 2.250
Value_2_313 | 37 | 2.313
Value_2_375 | 38 | 2.375
Value_2_438 | 39 | 2.438
Value_2_500 | 40 | 2.500
Value_2_563 | 41 | 2.563
Value_2_625 | 42 | 2.625
Value_2_688 | 43 | 2.688
Value_2_750 | 44 | 2.750
Value_2_813 | 45 | 2.813
Value_2_875 | 46 | 2.875
Value_2_938 | 47 | 2.938
Value_3_000 | 48 | 3.000
Value_3_063 | 49 | 3.063
Value_3_125 | 50 | 3.125
Value_3_188 | 51 | 3.188
Value_3_250 | 52 | 3.250
Value_3_313 | 53 | 3.313
Value_3_375 | 54 | 3.375
Value_3_438 | 55 | 3.438
Value_3_500 | 56 | 3.500
Value_3_563 | 57 | 3.563
Value_3_625 | 58 | 3.625
Value_3_688 | 59 | 3.688
Value_3_750 | 60 | 3.750
Value_3_813 | 61 | 3.813
Value_3_875 | 62 | 3.875
Value_3_938 | 63 | 3.938
Value_4_000 | 64 | 4.000
Value_4_063 | 65 | 4.063
Value_4_125 | 66 | 4.125
Value_4_188 | 67 | 4.188
Value_4_250 | 68 | 4.250
Value_4_313 | 69 | 4.313
Value_4_375 | 70 | 4.375
Value_4_438 | 71 | 4.438
Value_4_500 | 72 | 4.500
Value_4_563 | 73 | 4.563
Value_4_625 | 74 | 4.625
Value_4_688 | 75 | 4.688
Value_4_750 | 76 | 4.750
Value_4_813 | 77 | 4.813
Value_4_875 | 78 | 4.875
Value_4_938 | 79 | 4.938
Value_5_000 | 80 | 5.000
Value_5_063 | 81 | 5.063
Value_5_125 | 82 | 5.125
Value_5_188 | 83 | 5.188
Value_5_250 | 84 | 5.250
Value_5_313 | 85 | 5.313
Value_5_375 | 86 | 5.375
Value_5_438 | 87 | 5.438
Value_5_500 | 88 | 5.500
Value_5_563 | 89 | 5.563
Value_5_625 | 90 | 5.625
Value_5_688 | 91 | 5.688
Value_5_750 | 92 | 5.750
Value_5_813 | 93 | 5.813
Value_5_875 | 94 | 5.875
Value_5_938 | 95 | 5.938
Value_6_000 | 96 | 6.000
Value_6_063 | 97 | 6.063
Value_6_125 | 98 | 6.125
Value_6_188 | 99 | 6.188
Value_6_250 | 100 | 6.250
Value_6_313 | 101 | 6.313
Value_6_375 | 102 | 6.375
Value_6_438 | 103 | 6.438
Value_6_500 | 104 | 6.500
Value_6_563 | 105 | 6.563
Value_6_625 | 106 | 6.625
Value_6_688 | 107 | 6.688
Value_6_750 | 108 | 6.750
Value_6_813 | 109 | 6.813
Value_6_875 | 110 | 6.875
Value_6_938 | 111 | 6.938
Value_7_000 | 112 | 7.000
Value_7_063 | 113 | 7.063
Value_7_125 | 114 | 7.125
Value_7_188 | 115 | 7.188
Value_7_250 | 116 | 7.250
Value_7_313 | 117 | 7.313
Value_7_375 | 118 | 7.375
Value_7_438 | 119 | 7.438
Value_7_500 | 120 | 7.500
Value_7_563 | 121 | 7.563
Value_7_625 | 122 | 7.625
Value_7_688 | 123 | 7.688
Value_7_750 | 124 | 7.750
Value_7_813 | 125 | 7.813
Value_7_875 | 126 | 7.875
Value_7_938 | 127 | 7.938
Value_8_000 | 128 | 8.000
Value_8_063 | 129 | 8.063
Value_8_125 | 130 | 8.125
Value_8_188 | 131 | 8.188
Value_8_250 | 132 | 8.250
Value_8_313 | 133 | 8.313
Value_8_375 | 134 | 8.375
Value_8_438 | 135 | 8.438
Value_8_500 | 136 | 8.500
Value_8_563 | 137 | 8.563
Value_8_625 | 138 | 8.625
Value_8_688 | 139 | 8.688
Value_8_750 | 140 | 8.750
Value_8_813 | 141 | 8.813
Value_8_875 | 142 | 8.875
Value_8_938 | 143 | 8.938
Value_9_000 | 144 | 9.000
Value_9_063 | 145 | 9.063
Value_9_125 | 146 | 9.125
Value_9_188 | 147 | 9.188
Value_9_250 | 148 | 9.250
Value_9_313 | 149 | 9.313
Value_9_375 | 150 | 9.375
Value_9_438 | 151 | 9.438
Value_9_500 | 152 | 9.500
Value_9_563 | 153 | 9.563
Value_9_625 | 154 | 9.625
Value_9_688 | 155 | 9.688
Value_9_750 | 156 | 9.750
Value_9_813 | 157 | 9.813
Value_9_875 | 158 | 9.875
Value_9_938 | 159 | 9.938
Value_10_000 | 160 | 10.000
Value_10_063 | 161 | 10.063
Value_10_125 | 162 | 10.125
Value_10_188 | 163 | 10.188
Value_10_250 | 164 | 10.250
Value_10_313 | 165 | 10.313
Value_10_375 | 166 | 10.375
Value_10_438 | 167 | 10.438
Value_10_500 | 168 | 10.500
Value_10_563 | 169 | 10.563
Value_10_625 | 170 | 10.625
Value_10_688 | 171 | 10.688
Value_10_750 | 172 | 10.750
Value_10_813 | 173 | 10.813
Value_10_875 | 174 | 10.875
Value_10_938 | 175 | 10.938
Value_11_000 | 176 | 11.000
Value_11_063 | 177 | 11.063
Value_11_125 | 178 | 11.125
Value_11_188 | 179 | 11.188
Value_11_250 | 180 | 11.250
Value_11_313 | 181 | 11.313
Value_11_375 | 182 | 11.375
Value_11_438 | 183 | 11.438
Value_11_500 | 184 | 11.500
Value_11_563 | 185 | 11.563
Value_11_625 | 186 | 11.625
Value_11_688 | 187 | 11.688
Value_11_750 | 188 | 11.750
Value_11_813 | 189 | 11.813
Value_11_875 | 190 | 11.875
Value_11_938 | 191 | 11.938
Value_12_000 | 192 | 12.000
Value_12_063 | 193 | 12.063
Value_12_125 | 194 | 12.125
Value_12_188 | 195 | 12.188
Value_12_250 | 196 | 12.250
Value_12_313 | 197 | 12.313
Value_12_375 | 198 | 12.375
Value_12_438 | 199 | 12.438
Value_12_500 | 200 | 12.500
Value_12_563 | 201 | 12.563
Value_12_625 | 202 | 12.625
Value_12_688 | 203 | 12.688
Value_12_750 | 204 | 12.750
Value_12_813 | 205 | 12.813
Value_12_875 | 206 | 12.875
Value_12_938 | 207 | 12.938
Value_13_000 | 208 | 13.000
Value_13_063 | 209 | 13.063
Value_13_125 | 210 | 13.125
Value_13_188 | 211 | 13.188
Value_13_250 | 212 | 13.250
Value_13_313 | 213 | 13.313
Value_13_375 | 214 | 13.375
Value_13_438 | 215 | 13.438
Value_13_500 | 216 | 13.500
Value_13_563 | 217 | 13.563
Value_13_625 | 218 | 13.625
Value_13_688 | 219 | 13.688
Value_13_750 | 220 | 13.750
Value_13_813 | 221 | 13.813
Value_13_875 | 222 | 13.875
Value_13_938 | 223 | 13.938
Value_14_000 | 224 | 14.000
Value_14_063 | 225 | 14.063
Value_14_125 | 226 | 14.125
Value_14_188 | 227 | 14.188
Value_14_250 | 228 | 14.250
Value_14_313 | 229 | 14.313
Value_14_375 | 230 | 14.375
Value_14_438 | 231 | 14.438
Value_14_500 | 232 | 14.500
Value_14_563 | 233 | 14.563
Value_14_625 | 234 | 14.625
Value_14_688 | 235 | 14.688
Value_14_750 | 236 | 14.750
Value_14_813 | 237 | 14.813
Value_14_875 | 238 | 14.875
Value_14_938 | 239 | 14.938
Value_15_000 | 240 | 15.000
Value_15_063 | 241 | 15.063
Value_15_125 | 242 | 15.125
Value_15_188 | 243 | 15.188
Value_15_250 | 244 | 15.250
Value_15_313 | 245 | 15.313
Value_15_375 | 246 | 15.375
Value_15_438 | 247 | 15.438
Value_15_500 | 248 | 15.500
Value_15_563 | 249 | 15.563
Value_15_625 | 250 | 15.625
Value_15_688 | 251 | 15.688
Value_15_750 | 252 | 15.750
Value_15_813 | 253 | 15.813
Value_15_875 | 254 | 15.875
Value_15_938 | 255 | 15.938
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPID25V0 Enumeration

IRD

Lm85TYPID25V0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPID25V0
Public Enumeration TYPID25V0
public enum class TYPID25V0
type TYPID25V0
Members
Member name | Value | Description
Value_0_000 | 0 | 0.000
Value_0_013 | 1 | 0.013
Value_0_026 | 2 | 0.026
Value_0_039 | 3 | 0.039
Value_0_052 | 4 | 0.052
Value_0_065 | 5 | 0.065
Value_0_078 | 6 | 0.078
Value_0_091 | 7 | 0.091
Value_0_104 | 8 | 0.104
Value_0_117 | 9 | 0.117
Value_0_130 | 10 | 0.130
Value_0_143 | 11 | 0.143
Value_0_156 | 12 | 0.156
Value_0_169 | 13 | 0.169
Value_0_182 | 14 | 0.182
Value_0_195 | 15 | 0.195
Value_0_208 | 16 | 0.208
Value_0_221 | 17 | 0.221
Value_0_234 | 18 | 0.234
Value_0_247 | 19 | 0.247
Value_0_260 | 20 | 0.260
Value_0_273 | 21 | 0.273
Value_0_286 | 22 | 0.286
Value_0_299 | 23 | 0.299
Value_0_313 | 24 | 0.313
Value_0_326 | 25 | 0.326
Value_0_339 | 26 | 0.339
Value_0_352 | 27 | 0.352
Value_0_365 | 28 | 0.365
Value_0_378 | 29 | 0.378
Value_0_391 | 30 | 0.391
Value_0_404 | 31 | 0.404
Value_0_417 | 32 | 0.417
Value_0_430 | 33 | 0.430
Value_0_443 | 34 | 0.443
Value_0_456 | 35 | 0.456
Value_0_469 | 36 | 0.469
Value_0_482 | 37 | 0.482
Value_0_495 | 38 | 0.495
Value_0_508 | 39 | 0.508
Value_0_521 | 40 | 0.521
Value_0_534 | 41 | 0.534
Value_0_547 | 42 | 0.547
Value_0_560 | 43 | 0.560
Value_0_573 | 44 | 0.573
Value_0_586 | 45 | 0.586
Value_0_599 | 46 | 0.599
Value_0_612 | 47 | 0.612
Value_0_625 | 48 | 0.625
Value_0_638 | 49 | 0.638
Value_0_651 | 50 | 0.651
Value_0_664 | 51 | 0.664
Value_0_677 | 52 | 0.677
Value_0_690 | 53 | 0.690
Value_0_703 | 54 | 0.703
Value_0_716 | 55 | 0.716
Value_0_729 | 56 | 0.729
Value_0_742 | 57 | 0.742
Value_0_755 | 58 | 0.755
Value_0_768 | 59 | 0.768
Value_0_781 | 60 | 0.781
Value_0_794 | 61 | 0.794
Value_0_807 | 62 | 0.807
Value_0_820 | 63 | 0.820
Value_0_833 | 64 | 0.833
Value_0_846 | 65 | 0.846
Value_0_859 | 66 | 0.859
Value_0_872 | 67 | 0.872
Value_0_885 | 68 | 0.885
Value_0_898 | 69 | 0.898
Value_0_911 | 70 | 0.911
Value_0_924 | 71 | 0.924
Value_0_938 | 72 | 0.938
Value_0_951 | 73 | 0.951
Value_0_964 | 74 | 0.964
Value_0_977 | 75 | 0.977
Value_0_990 | 76 | 0.990
Value_1_003 | 77 | 1.003
Value_1_016 | 78 | 1.016
Value_1_029 | 79 | 1.029
Value_1_042 | 80 | 1.042
Value_1_055 | 81 | 1.055
Value_1_068 | 82 | 1.068
Value_1_081 | 83 | 1.081
Value_1_094 | 84 | 1.094
Value_1_107 | 85 | 1.107
Value_1_120 | 86 | 1.120
Value_1_133 | 87 | 1.133
Value_1_146 | 88 | 1.146
Value_1_159 | 89 | 1.159
Value_1_172 | 90 | 1.172
Value_1_185 | 91 | 1.185
Value_1_198 | 92 | 1.198
Value_1_211 | 93 | 1.211
Value_1_224 | 94 | 1.224
Value_1_237 | 95 | 1.237
Value_1_250 | 96 | 1.250
Value_1_263 | 97 | 1.263
Value_1_276 | 98 | 1.276
Value_1_289 | 99 | 1.289
Value_1_302 | 100 | 1.302
Value_1_315 | 101 | 1.315
Value_1_328 | 102 | 1.328
Value_1_341 | 103 | 1.341
Value_1_354 | 104 | 1.354
Value_1_367 | 105 | 1.367
Value_1_380 | 106 | 1.380
Value_1_393 | 107 | 1.393
Value_1_406 | 108 | 1.406
Value_1_419 | 109 | 1.419
Value_1_432 | 110 | 1.432
Value_1_445 | 111 | 1.445
Value_1_458 | 112 | 1.458
Value_1_471 | 113 | 1.471
Value_1_484 | 114 | 1.484
Value_1_497 | 115 | 1.497
Value_1_510 | 116 | 1.510
Value_1_523 | 117 | 1.523
Value_1_536 | 118 | 1.536
Value_1_549 | 119 | 1.549
Value_1_563 | 120 | 1.563
Value_1_576 | 121 | 1.576
Value_1_589 | 122 | 1.589
Value_1_602 | 123 | 1.602
Value_1_615 | 124 | 1.615
Value_1_628 | 125 | 1.628
Value_1_641 | 126 | 1.641
Value_1_654 | 127 | 1.654
Value_1_667 | 128 | 1.667
Value_1_680 | 129 | 1.680
Value_1_693 | 130 | 1.693
Value_1_706 | 131 | 1.706
Value_1_719 | 132 | 1.719
Value_1_732 | 133 | 1.732
Value_1_745 | 134 | 1.745
Value_1_758 | 135 | 1.758
Value_1_771 | 136 | 1.771
Value_1_784 | 137 | 1.784
Value_1_797 | 138 | 1.797
Value_1_810 | 139 | 1.810
Value_1_823 | 140 | 1.823
Value_1_836 | 141 | 1.836
Value_1_849 | 142 | 1.849
Value_1_862 | 143 | 1.862
Value_1_875 | 144 | 1.875
Value_1_888 | 145 | 1.888
Value_1_901 | 146 | 1.901
Value_1_914 | 147 | 1.914
Value_1_927 | 148 | 1.927
Value_1_940 | 149 | 1.940
Value_1_953 | 150 | 1.953
Value_1_966 | 151 | 1.966
Value_1_979 | 152 | 1.979
Value_1_992 | 153 | 1.992
Value_2_005 | 154 | 2.005
Value_2_018 | 155 | 2.018
Value_2_031 | 156 | 2.031
Value_2_044 | 157 | 2.044
Value_2_057 | 158 | 2.057
Value_2_070 | 159 | 2.070
Value_2_083 | 160 | 2.083
Value_2_096 | 161 | 2.096
Value_2_109 | 162 | 2.109
Value_2_122 | 163 | 2.122
Value_2_135 | 164 | 2.135
Value_2_148 | 165 | 2.148
Value_2_161 | 166 | 2.161
Value_2_174 | 167 | 2.174
Value_2_188 | 168 | 2.188
Value_2_201 | 169 | 2.201
Value_2_214 | 170 | 2.214
Value_2_227 | 171 | 2.227
Value_2_240 | 172 | 2.240
Value_2_253 | 173 | 2.253
Value_2_266 | 174 | 2.266
Value_2_279 | 175 | 2.279
Value_2_292 | 176 | 2.292
Value_2_305 | 177 | 2.305
Value_2_318 | 178 | 2.318
Value_2_331 | 179 | 2.331
Value_2_344 | 180 | 2.344
Value_2_357 | 181 | 2.357
Value_2_370 | 182 | 2.370
Value_2_383 | 183 | 2.383
Value_2_396 | 184 | 2.396
Value_2_409 | 185 | 2.409
Value_2_422 | 186 | 2.422
Value_2_435 | 187 | 2.435
Value_2_448 | 188 | 2.448
Value_2_461 | 189 | 2.461
Value_2_474 | 190 | 2.474
Value_2_487 | 191 | 2.487
Value_2_500 | 192 | 2.500
Value_2_513 | 193 | 2.513
Value_2_526 | 194 | 2.526
Value_2_539 | 195 | 2.539
Value_2_552 | 196 | 2.552
Value_2_565 | 197 | 2.565
Value_2_578 | 198 | 2.578
Value_2_591 | 199 | 2.591
Value_2_604 | 200 | 2.604
Value_2_617 | 201 | 2.617
Value_2_630 | 202 | 2.630
Value_2_643 | 203 | 2.643
Value_2_656 | 204 | 2.656
Value_2_669 | 205 | 2.669
Value_2_682 | 206 | 2.682
Value_2_695 | 207 | 2.695
Value_2_708 | 208 | 2.708
Value_2_721 | 209 | 2.721
Value_2_734 | 210 | 2.734
Value_2_747 | 211 | 2.747
Value_2_760 | 212 | 2.760
Value_2_773 | 213 | 2.773
Value_2_786 | 214 | 2.786
Value_2_799 | 215 | 2.799
Value_2_813 | 216 | 2.813
Value_2_826 | 217 | 2.826
Value_2_839 | 218 | 2.839
Value_2_852 | 219 | 2.852
Value_2_865 | 220 | 2.865
Value_2_878 | 221 | 2.878
Value_2_891 | 222 | 2.891
Value_2_904 | 223 | 2.904
Value_2_917 | 224 | 2.917
Value_2_930 | 225 | 2.930
Value_2_943 | 226 | 2.943
Value_2_956 | 227 | 2.956
Value_2_969 | 228 | 2.969
Value_2_982 | 229 | 2.982
Value_2_995 | 230 | 2.995
Value_3_008 | 231 | 3.008
Value_3_021 | 232 | 3.021
Value_3_034 | 233 | 3.034
Value_3_047 | 234 | 3.047
Value_3_060 | 235 | 3.060
Value_3_073 | 236 | 3.073
Value_3_086 | 237 | 3.086
Value_3_099 | 238 | 3.099
Value_3_112 | 239 | 3.112
Value_3_125 | 240 | 3.125
Value_3_138 | 241 | 3.138
Value_3_151 | 242 | 3.151
Value_3_164 | 243 | 3.164
Value_3_177 | 244 | 3.177
Value_3_190 | 245 | 3.190
Value_3_203 | 246 | 3.203
Value_3_216 | 247 | 3.216
Value_3_229 | 248 | 3.229
Value_3_242 | 249 | 3.242
Value_3_255 | 250 | 3.255
Value_3_268 | 251 | 3.268
Value_3_281 | 252 | 3.281
Value_3_294 | 253 | 3.294
Value_3_307 | 254 | 3.307
Value_3_320 | 255 | 3.320
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPID33V0 Enumeration

IRD

Lm85TYPID33V0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPID33V0
Public Enumeration TYPID33V0
public enum class TYPID33V0
type TYPID33V0
Members
Member name | Value | Description
Value_0_000 | 0 | 0.000
Value_0_017 | 1 | 0.017
Value_0_034 | 2 | 0.034
Value_0_052 | 3 | 0.052
Value_0_069 | 4 | 0.069
Value_0_086 | 5 | 0.086
Value_0_103 | 6 | 0.103
Value_0_120 | 7 | 0.120
Value_0_137 | 8 | 0.137
Value_0_155 | 9 | 0.155
Value_0_172 | 10 | 0.172
Value_0_189 | 11 | 0.189
Value_0_206 | 12 | 0.206
Value_0_223 | 13 | 0.223
Value_0_241 | 14 | 0.241
Value_0_258 | 15 | 0.258
Value_0_275 | 16 | 0.275
Value_0_292 | 17 | 0.292
Value_0_309 | 18 | 0.309
Value_0_327 | 19 | 0.327
Value_0_344 | 20 | 0.344
Value_0_361 | 21 | 0.361
Value_0_378 | 22 | 0.378
Value_0_395 | 23 | 0.395
Value_0_413 | 24 | 0.413
Value_0_430 | 25 | 0.430
Value_0_447 | 26 | 0.447
Value_0_464 | 27 | 0.464
Value_0_481 | 28 | 0.481
Value_0_498 | 29 | 0.498
Value_0_516 | 30 | 0.516
Value_0_533 | 31 | 0.533
Value_0_550 | 32 | 0.550
Value_0_567 | 33 | 0.567
Value_0_584 | 34 | 0.584
Value_0_602 | 35 | 0.602
Value_0_619 | 36 | 0.619
Value_0_636 | 37 | 0.636
Value_0_653 | 38 | 0.653
Value_0_670 | 39 | 0.670
Value_0_687 | 40 | 0.687
Value_0_705 | 41 | 0.705
Value_0_722 | 42 | 0.722
Value_0_739 | 43 | 0.739
Value_0_756 | 44 | 0.756
Value_0_773 | 45 | 0.773
Value_0_791 | 46 | 0.791
Value_0_808 | 47 | 0.808
Value_0_825 | 48 | 0.825
Value_0_842 | 49 | 0.842
Value_0_859 | 50 | 0.859
Value_0_877 | 51 | 0.877
Value_0_894 | 52 | 0.894
Value_0_911 | 53 | 0.911
Value_0_928 | 54 | 0.928
Value_0_945 | 55 | 0.945
Value_0_962 | 56 | 0.962
Value_0_980 | 57 | 0.980
Value_0_997 | 58 | 0.997
Value_1_014 | 59 | 1.014
Value_1_031 | 60 | 1.031
Value_1_048 | 61 | 1.048
Value_1_066 | 62 | 1.066
Value_1_083 | 63 | 1.083
Value_1_100 | 64 | 1.100
Value_1_117 | 65 | 1.117
Value_1_134 | 66 | 1.134
Value_1_152 | 67 | 1.152
Value_1_169 | 68 | 1.169
Value_1_186 | 69 | 1.186
Value_1_203 | 70 | 1.203
Value_1_220 | 71 | 1.220
Value_1_237 | 72 | 1.237
Value_1_255 | 73 | 1.255
Value_1_272 | 74 | 1.272
Value_1_289 | 75 | 1.289
Value_1_306 | 76 | 1.306
Value_1_323 | 77 | 1.323
Value_1_341 | 78 | 1.341
Value_1_358 | 79 | 1.358
Value_1_375 | 80 | 1.375
Value_1_392 | 81 | 1.392
Value_1_409 | 82 | 1.409
Value_1_427 | 83 | 1.427
Value_1_444 | 84 | 1.444
Value_1_461 | 85 | 1.461
Value_1_478 | 86 | 1.478
Value_1_495 | 87 | 1.495
Value_1_512 | 88 | 1.512
Value_1_530 | 89 | 1.530
Value_1_547 | 90 | 1.547
Value_1_564 | 91 | 1.564
Value_1_581 | 92 | 1.581
Value_1_598 | 93 | 1.598
Value_1_616 | 94 | 1.616
Value_1_633 | 95 | 1.633
Value_1_650 | 96 | 1.650
Value_1_667 | 97 | 1.667
Value_1_684 | 98 | 1.684
Value_1_702 | 99 | 1.702
Value_1_719 | 100 | 1.719
Value_1_736 | 101 | 1.736
Value_1_753 | 102 | 1.753
Value_1_770 | 103 | 1.770
Value_1_787 | 104 | 1.787
Value_1_805 | 105 | 1.805
Value_1_822 | 106 | 1.822
Value_1_839 | 107 | 1.839
Value_1_856 | 108 | 1.856
Value_1_873 | 109 | 1.873
Value_1_891 | 110 | 1.891
Value_1_908 | 111 | 1.908
Value_1_925 | 112 | 1.925
Value_1_942 | 113 | 1.942
Value_1_959 | 114 | 1.959
Value_1_977 | 115 | 1.977
Value_1_994 | 116 | 1.994
Value_2_011 | 117 | 2.011
Value_2_028 | 118 | 2.028
Value_2_045 | 119 | 2.045
Value_2_062 | 120 | 2.062
Value_2_080 | 121 | 2.080
Value_2_097 | 122 | 2.097
Value_2_114 | 123 | 2.114
Value_2_131 | 124 | 2.131
Value_2_148 | 125 | 2.148
Value_2_166 | 126 | 2.166
Value_2_183 | 127 | 2.183
Value_2_200 | 128 | 2.200
Value_2_217 | 129 | 2.217
Value_2_234 | 130 | 2.234
Value_2_252 | 131 | 2.252
Value_2_269 | 132 | 2.269
Value_2_286 | 133 | 2.286
Value_2_303 | 134 | 2.303
Value_2_320 | 135 | 2.320
Value_2_338 | 136 | 2.338
Value_2_355 | 137 | 2.355
Value_2_372 | 138 | 2.372
Value_2_389 | 139 | 2.389
Value_2_406 | 140 | 2.406
Value_2_423 | 141 | 2.423
Value_2_441 | 142 | 2.441
Value_2_458 | 143 | 2.458
Value_2_475 | 144 | 2.475
Value_2_492 | 145 | 2.492
Value_2_509 | 146 | 2.509
Value_2_527 | 147 | 2.527
Value_2_544 | 148 | 2.544
Value_2_561 | 149 | 2.561
Value_2_578 | 150 | 2.578
Value_2_595 | 151 | 2.595
Value_2_613 | 152 | 2.613
Value_2_630 | 153 | 2.630
Value_2_647 | 154 | 2.647
Value_2_664 | 155 | 2.664
Value_2_681 | 156 | 2.681
Value_2_698 | 157 | 2.698
Value_2_716 | 158 | 2.716
Value_2_733 | 159 | 2.733
Value_2_750 | 160 | 2.750
Value_2_767 | 161 | 2.767
Value_2_784 | 162 | 2.784
Value_2_802 | 163 | 2.802
Value_2_819 | 164 | 2.819
Value_2_836 | 165 | 2.836
Value_2_853 | 166 | 2.853
Value_2_870 | 167 | 2.870
Value_2_887 | 168 | 2.887
Value_2_905 | 169 | 2.905
Value_2_922 | 170 | 2.922
Value_2_939 | 171 | 2.939
Value_2_956 | 172 | 2.956
Value_2_973 | 173 | 2.973
Value_2_991 | 174 | 2.991
Value_3_008 | 175 | 3.008
Value_3_025 | 176 | 3.025
Value_3_042 | 177 | 3.042
Value_3_059 | 178 | 3.059
Value_3_077 | 179 | 3.077
Value_3_094 | 180 | 3.094
Value_3_111 | 181 | 3.111
Value_3_128 | 182 | 3.128
Value_3_145 | 183 | 3.145
Value_3_162 | 184 | 3.162
Value_3_180 | 185 | 3.180
Value_3_197 | 186 | 3.197
Value_3_214 | 187 | 3.214
Value_3_231 | 188 | 3.231
Value_3_248 | 189 | 3.248
Value_3_266 | 190 | 3.266
Value_3_283 | 191 | 3.283
Value_3_300 | 192 | 3.300
Value_3_317 | 193 | 3.317
Value_3_334 | 194 | 3.334
Value_3_352 | 195 | 3.352
Value_3_369 | 196 | 3.369
Value_3_386 | 197 | 3.386
Value_3_403 | 198 | 3.403
Value_3_420 | 199 | 3.420
Value_3_437 | 200 | 3.437
Value_3_455 | 201 | 3.455
Value_3_472 | 202 | 3.472
Value_3_489 | 203 | 3.489
Value_3_506 | 204 | 3.506
Value_3_523 | 205 | 3.523
Value_3_541 | 206 | 3.541
Value_3_558 | 207 | 3.558
Value_3_575 | 208 | 3.575
Value_3_592 | 209 | 3.592
Value_3_609 | 210 | 3.609
Value_3_627 | 211 | 3.627
Value_3_644 | 212 | 3.644
Value_3_661 | 213 | 3.661
Value_3_678 | 214 | 3.678
Value_3_695 | 215 | 3.695
Value_3_712 | 216 | 3.712
Value_3_730 | 217 | 3.730
Value_3_747 | 218 | 3.747
Value_3_764 | 219 | 3.764
Value_3_781 | 220 | 3.781
Value_3_798 | 221 | 3.798
Value_3_816 | 222 | 3.816
Value_3_833 | 223 | 3.833
Value_3_850 | 224 | 3.850
Value_3_867 | 225 | 3.867
Value_3_884 | 226 | 3.884
Value_3_902 | 227 | 3.902
Value_3_919 | 228 | 3.919
Value_3_936 | 229 | 3.936
Value_3_953 | 230 | 3.953
Value_3_970 | 231 | 3.970
Value_3_987 | 232 | 3.987
Value_4_005 | 233 | 4.005
Value_4_022 | 234 | 4.022
Value_4_039 | 235 | 4.039
Value_4_056 | 236 | 4.056
Value_4_073 | 237 | 4.073
Value_4_091 | 238 | 4.091
Value_4_108 | 239 | 4.108
Value_4_125 | 240 | 4.125
Value_4_142 | 241 | 4.142
Value_4_159 | 242 | 4.159
Value_4_177 | 243 | 4.177
Value_4_194 | 244 | 4.194
Value_4_211 | 245 | 4.211
Value_4_228 | 246 | 4.228
Value_4_245 | 247 | 4.245
Value_4_262 | 248 | 4.262
Value_4_280 | 249 | 4.280
Value_4_297 | 250 | 4.297
Value_4_314 | 251 | 4.314
Value_4_331 | 252 | 4.331
Value_4_348 | 253 | 4.348
Value_4_366 | 254 | 4.366
Value_4_383 | 255 | 4.383
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPID5V0 Enumeration

IRD

Lm85TYPID5V0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPID5V0
Public Enumeration TYPID5V0
public enum class TYPID5V0
type TYPID5V0
Members
Member name | Value | Description
Value_0_000 | 0 | 0.000
Value_0_026 | 1 | 0.026
Value_0_052 | 2 | 0.052
Value_0_078 | 3 | 0.078
Value_0_104 | 4 | 0.104
Value_0_130 | 5 | 0.130
Value_0_156 | 6 | 0.156
Value_0_182 | 7 | 0.182
Value_0_208 | 8 | 0.208
Value_0_234 | 9 | 0.234
Value_0_260 | 10 | 0.260
Value_0_286 | 11 | 0.286
Value_0_313 | 12 | 0.313
Value_0_339 | 13 | 0.339
Value_0_365 | 14 | 0.365
Value_0_391 | 15 | 0.391
Value_0_417 | 16 | 0.417
Value_0_443 | 17 | 0.443
Value_0_469 | 18 | 0.469
Value_0_495 | 19 | 0.495
Value_0_521 | 20 | 0.521
Value_0_547 | 21 | 0.547
Value_0_573 | 22 | 0.573
Value_0_599 | 23 | 0.599
Value_0_625 | 24 | 0.625
Value_0_651 | 25 | 0.651
Value_0_677 | 26 | 0.677
Value_0_703 | 27 | 0.703
Value_0_729 | 28 | 0.729
Value_0_755 | 29 | 0.755
Value_0_781 | 30 | 0.781
Value_0_807 | 31 | 0.807
Value_0_833 | 32 | 0.833
Value_0_859 | 33 | 0.859
Value_0_885 | 34 | 0.885
Value_0_911 | 35 | 0.911
Value_0_938 | 36 | 0.938
Value_0_964 | 37 | 0.964
Value_0_990 | 38 | 0.990
Value_1_016 | 39 | 1.016
Value_1_042 | 40 | 1.042
Value_1_068 | 41 | 1.068
Value_1_094 | 42 | 1.094
Value_1_120 | 43 | 1.120
Value_1_146 | 44 | 1.146
Value_1_172 | 45 | 1.172
Value_1_198 | 46 | 1.198
Value_1_224 | 47 | 1.224
Value_1_250 | 48 | 1.250
Value_1_276 | 49 | 1.276
Value_1_302 | 50 | 1.302
Value_1_328 | 51 | 1.328
Value_1_354 | 52 | 1.354
Value_1_380 | 53 | 1.380
Value_1_406 | 54 | 1.406
Value_1_432 | 55 | 1.432
Value_1_458 | 56 | 1.458
Value_1_484 | 57 | 1.484
Value_1_510 | 58 | 1.510
Value_1_536 | 59 | 1.536
Value_1_563 | 60 | 1.563
Value_1_589 | 61 | 1.589
Value_1_615 | 62 | 1.615
Value_1_641 | 63 | 1.641
Value_1_667 | 64 | 1.667
Value_1_693 | 65 | 1.693
Value_1_719 | 66 | 1.719
Value_1_745 | 67 | 1.745
Value_1_771 | 68 | 1.771
Value_1_797 | 69 | 1.797
Value_1_823 | 70 | 1.823
Value_1_849 | 71 | 1.849
Value_1_875 | 72 | 1.875
Value_1_901 | 73 | 1.901
Value_1_927 | 74 | 1.927
Value_1_953 | 75 | 1.953
Value_1_979 | 76 | 1.979
Value_2_005 | 77 | 2.005
Value_2_031 | 78 | 2.031
Value_2_057 | 79 | 2.057
Value_2_083 | 80 | 2.083
Value_2_109 | 81 | 2.109
Value_2_135 | 82 | 2.135
Value_2_161 | 83 | 2.161
Value_2_188 | 84 | 2.188
Value_2_214 | 85 | 2.214
Value_2_240 | 86 | 2.240
Value_2_266 | 87 | 2.266
Value_2_292 | 88 | 2.292
Value_2_318 | 89 | 2.318
Value_2_344 | 90 | 2.344
Value_2_370 | 91 | 2.370
Value_2_396 | 92 | 2.396
Value_2_422 | 93 | 2.422
Value_2_448 | 94 | 2.448
Value_2_474 | 95 | 2.474
Value_2_500 | 96 | 2.500
Value_2_526 | 97 | 2.526
Value_2_552 | 98 | 2.552
Value_2_578 | 99 | 2.578
Value_2_604 | 100 | 2.604
Value_2_630 | 101 | 2.630
Value_2_656 | 102 | 2.656
Value_2_682 | 103 | 2.682
Value_2_708 | 104 | 2.708
Value_2_734 | 105 | 2.734
Value_2_760 | 106 | 2.760
Value_2_786 | 107 | 2.786
Value_2_813 | 108 | 2.813
Value_2_839 | 109 | 2.839
Value_2_865 | 110 | 2.865
Value_2_891 | 111 | 2.891
Value_2_917 | 112 | 2.917
Value_2_943 | 113 | 2.943
Value_2_969 | 114 | 2.969
Value_2_995 | 115 | 2.995
Value_3_021 | 116 | 3.021
Value_3_047 | 117 | 3.047
Value_3_073 | 118 | 3.073
Value_3_099 | 119 | 3.099
Value_3_125 | 120 | 3.125
Value_3_151 | 121 | 3.151
Value_3_177 | 122 | 3.177
Value_3_203 | 123 | 3.203
Value_3_229 | 124 | 3.229
Value_3_255 | 125 | 3.255
Value_3_281 | 126 | 3.281
Value_3_307 | 127 | 3.307
Value_3_333 | 128 | 3.333
Value_3_359 | 129 | 3.359
Value_3_385 | 130 | 3.385
Value_3_411 | 131 | 3.411
Value_3_438 | 132 | 3.438
Value_3_464 | 133 | 3.464
Value_3_490 | 134 | 3.490
Value_3_516 | 135 | 3.516
Value_3_542 | 136 | 3.542
Value_3_568 | 137 | 3.568
Value_3_594 | 138 | 3.594
Value_3_620 | 139 | 3.620
Value_3_646 | 140 | 3.646
Value_3_672 | 141 | 3.672
Value_3_698 | 142 | 3.698
Value_3_724 | 143 | 3.724
Value_3_750 | 144 | 3.750
Value_3_776 | 145 | 3.776
Value_3_802 | 146 | 3.802
Value_3_828 | 147 | 3.828
Value_3_854 | 148 | 3.854
Value_3_880 | 149 | 3.880
Value_3_906 | 150 | 3.906
Value_3_932 | 151 | 3.932
Value_3_958 | 152 | 3.958
Value_3_984 | 153 | 3.984
Value_4_010 | 154 | 4.010
Value_4_036 | 155 | 4.036
Value_4_063 | 156 | 4.063
Value_4_089 | 157 | 4.089
Value_4_115 | 158 | 4.115
Value_4_141 | 159 | 4.141
Value_4_167 | 160 | 4.167
Value_4_193 | 161 | 4.193
Value_4_219 | 162 | 4.219
Value_4_245 | 163 | 4.245
Value_4_271 | 164 | 4.271
Value_4_297 | 165 | 4.297
Value_4_323 | 166 | 4.323
Value_4_349 | 167 | 4.349
Value_4_375 | 168 | 4.375
Value_4_401 | 169 | 4.401
Value_4_427 | 170 | 4.427
Value_4_453 | 171 | 4.453
Value_4_479 | 172 | 4.479
Value_4_505 | 173 | 4.505
Value_4_531 | 174 | 4.531
Value_4_557 | 175 | 4.557
Value_4_583 | 176 | 4.583
Value_4_609 | 177 | 4.609
Value_4_635 | 178 | 4.635
Value_4_661 | 179 | 4.661
Value_4_688 | 180 | 4.688
Value_4_714 | 181 | 4.714
Value_4_740 | 182 | 4.740
Value_4_766 | 183 | 4.766
Value_4_792 | 184 | 4.792
Value_4_818 | 185 | 4.818
Value_4_844 | 186 | 4.844
Value_4_870 | 187 | 4.870
Value_4_896 | 188 | 4.896
Value_4_922 | 189 | 4.922
Value_4_948 | 190 | 4.948
Value_4_974 | 191 | 4.974
Value_5_000 | 192 | 5.000
Value_5_026 | 193 | 5.026
Value_5_052 | 194 | 5.052
Value_5_078 | 195 | 5.078
Value_5_104 | 196 | 5.104
Value_5_130 | 197 | 5.130
Value_5_156 | 198 | 5.156
Value_5_182 | 199 | 5.182
Value_5_208 | 200 | 5.208
Value_5_234 | 201 | 5.234
Value_5_260 | 202 | 5.260
Value_5_286 | 203 | 5.286
Value_5_313 | 204 | 5.313
Value_5_339 | 205 | 5.339
Value_5_365 | 206 | 5.365
Value_5_391 | 207 | 5.391
Value_5_417 | 208 | 5.417
Value_5_443 | 209 | 5.443
Value_5_469 | 210 | 5.469
Value_5_495 | 211 | 5.495
Value_5_521 | 212 | 5.521
Value_5_547 | 213 | 5.547
Value_5_573 | 214 | 5.573
Value_5_599 | 215 | 5.599
Value_5_625 | 216 | 5.625
Value_5_651 | 217 | 5.651
Value_5_677 | 218 | 5.677
Value_5_703 | 219 | 5.703
Value_5_729 | 220 | 5.729
Value_5_755 | 221 | 5.755
Value_5_781 | 222 | 5.781
Value_5_807 | 223 | 5.807
Value_5_833 | 224 | 5.833
Value_5_859 | 225 | 5.859
Value_5_885 | 226 | 5.885
Value_5_911 | 227 | 5.911
Value_5_938 | 228 | 5.938
Value_5_964 | 229 | 5.964
Value_5_990 | 230 | 5.990
Value_6_016 | 231 | 6.016
Value_6_042 | 232 | 6.042
Value_6_068 | 233 | 6.068
Value_6_094 | 234 | 6.094
Value_6_120 | 235 | 6.120
Value_6_146 | 236 | 6.146
Value_6_172 | 237 | 6.172
Value_6_198 | 238 | 6.198
Value_6_224 | 239 | 6.224
Value_6_250 | 240 | 6.250
Value_6_276 | 241 | 6.276
Value_6_302 | 242 | 6.302
Value_6_328 | 243 | 6.328
Value_6_354 | 244 | 6.354
Value_6_380 | 245 | 6.380
Value_6_406 | 246 | 6.406
Value_6_432 | 247 | 6.432
Value_6_458 | 248 | 6.458
Value_6_484 | 249 | 6.484
Value_6_510 | 250 | 6.510
Value_6_536 | 251 | 6.536
Value_6_563 | 252 | 6.563
Value_6_589 | 253 | 6.589
Value_6_615 | 254 | 6.615
Value_6_641 | 255 | 6.641
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDFAN1CONFIGURATION0 Enumeration

IRD

Lm85TYPIDFAN1CONFIGURATION0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFAN1CONFIGURATION0
Public Enumeration TYPIDFAN1CONFIGURATION0
public enum class TYPIDFAN1CONFIGURATION0
type TYPIDFAN1CONFIGURATION0
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_100 | 1 | 100
Value_250 | 2 | 250
Value_400 | 3 | 400
Value_700 | 4 | 700
Value_1000 | 5 | 1000
Value_2000 | 6 | 2000
Value_4000 | 7 | 4000
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDFAN1CONFIGURATION1 Enumeration

IRD

Lm85TYPIDFAN1CONFIGURATION1 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFAN1CONFIGURATION1
Public Enumeration TYPIDFAN1CONFIGURATION1
public enum class TYPIDFAN1CONFIGURATION1
type TYPIDFAN1CONFIGURATION1
Members
Member name | Value | Description
Value_100DutyCycleWillYieldAnOutputThatIsAlwaysHigh | 0 | 100% duty cycle will yield an output that is always high
Value_100DutyCycleWillYieldAnOutputThatIsAlwaysLow | 1 | 100% duty cycle will yield an output that is always low
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDFAN1CONFIGURATION2 Enumeration

IRD

Lm85TYPIDFAN1CONFIGURATION2 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFAN1CONFIGURATION2
Public Enumeration TYPIDFAN1CONFIGURATION2
public enum class TYPIDFAN1CONFIGURATION2
type TYPIDFAN1CONFIGURATION2
Members
Member name | Value | Description
FanOnZone1Auto | 0 | Fan on zone 1 auto
FanOnZone2Auto | 1 | Fan on zone 2 auto
FanOnZone3Auto | 2 | Fan on zone 3 auto
FanAlwaysOnFull | 3 | Fan always on full
FanDisabled | 4 | Fan disabled
FanControlledByHottestOfZones23 | 5 | Fan controlled by hottest of zones 2, 3
FanControlledByHottestOfZones123 | 6 | Fan controlled by hottest of zones 1, 2, 3
FanManuallyControlledTestMode | 7 | Fan manually controlled (Test Mode)
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDFAN1CURRENTPWMDUTY0 Enumeration

IRD

Lm85TYPIDFAN1CURRENTPWMDUTY0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFAN1CURRENTPWMDUTY0
Public Enumeration TYPIDFAN1CURRENTPWMDUTY0
public enum class TYPIDFAN1CURRENTPWMDUTY0
type TYPIDFAN1CURRENTPWMDUTY0
Members
Member name | Value | Description
Value_0_00 | 0 | 0.00
Value_0_39 | 1 | 0.39
Value_0_78 | 2 | 0.78
Value_1_18 | 3 | 1.18
Value_1_57 | 4 | 1.57
Value_1_96 | 5 | 1.96
Value_2_35 | 6 | 2.35
Value_2_75 | 7 | 2.75
Value_3_14 | 8 | 3.14
Value_3_53 | 9 | 3.53
Value_3_92 | 10 | 3.92
Value_4_31 | 11 | 4.31
Value_4_71 | 12 | 4.71
Value_5_10 | 13 | 5.10
Value_5_49 | 14 | 5.49
Value_5_88 | 15 | 5.88
Value_6_27 | 16 | 6.27
Value_6_67 | 17 | 6.67
Value_7_06 | 18 | 7.06
Value_7_45 | 19 | 7.45
Value_7_84 | 20 | 7.84
Value_8_24 | 21 | 8.24
Value_8_63 | 22 | 8.63
Value_9_02 | 23 | 9.02
Value_9_41 | 24 | 9.41
Value_9_80 | 25 | 9.80
Value_10_20 | 26 | 10.20
Value_10_59 | 27 | 10.59
Value_10_98 | 28 | 10.98
Value_11_37 | 29 | 11.37
Value_11_76 | 30 | 11.76
Value_12_16 | 31 | 12.16
Value_12_55 | 32 | 12.55
Value_12_94 | 33 | 12.94
Value_13_33 | 34 | 13.33
Value_13_73 | 35 | 13.73
Value_14_12 | 36 | 14.12
Value_14_51 | 37 | 14.51
Value_14_90 | 38 | 14.90
Value_15_29 | 39 | 15.29
Value_15_69 | 40 | 15.69
Value_16_08 | 41 | 16.08
Value_16_47 | 42 | 16.47
Value_16_86 | 43 | 16.86
Value_17_25 | 44 | 17.25
Value_17_65 | 45 | 17.65
Value_18_04 | 46 | 18.04
Value_18_43 | 47 | 18.43
Value_18_82 | 48 | 18.82
Value_19_22 | 49 | 19.22
Value_19_61 | 50 | 19.61
Value_20_00 | 51 | 20.00
Value_20_39 | 52 | 20.39
Value_20_78 | 53 | 20.78
Value_21_18 | 54 | 21.18
Value_21_57 | 55 | 21.57
Value_21_96 | 56 | 21.96
Value_22_35 | 57 | 22.35
Value_22_75 | 58 | 22.75
Value_23_14 | 59 | 23.14
Value_23_53 | 60 | 23.53
Value_23_92 | 61 | 23.92
Value_24_31 | 62 | 24.31
Value_24_71 | 63 | 24.71
Value_25_10 | 64 | 25.10
Value_25_49 | 65 | 25.49
Value_25_88 | 66 | 25.88
Value_26_27 | 67 | 26.27
Value_26_67 | 68 | 26.67
Value_27_06 | 69 | 27.06
Value_27_45 | 70 | 27.45
Value_27_84 | 71 | 27.84
Value_28_24 | 72 | 28.24
Value_28_63 | 73 | 28.63
Value_29_02 | 74 | 29.02
Value_29_41 | 75 | 29.41
Value_29_80 | 76 | 29.80
Value_30_20 | 77 | 30.20
Value_30_59 | 78 | 30.59
Value_30_98 | 79 | 30.98
Value_31_37 | 80 | 31.37
Value_31_76 | 81 | 31.76
Value_32_16 | 82 | 32.16
Value_32_55 | 83 | 32.55
Value_32_94 | 84 | 32.94
Value_33_33 | 85 | 33.33
Value_33_73 | 86 | 33.73
Value_34_12 | 87 | 34.12
Value_34_51 | 88 | 34.51
Value_34_90 | 89 | 34.90
Value_35_29 | 90 | 35.29
Value_35_69 | 91 | 35.69
Value_36_08 | 92 | 36.08
Value_36_47 | 93 | 36.47
Value_36_86 | 94 | 36.86
Value_37_25 | 95 | 37.25
Value_37_65 | 96 | 37.65
Value_38_04 | 97 | 38.04
Value_38_43 | 98 | 38.43
Value_38_82 | 99 | 38.82
Value_39_22 | 100 | 39.22
Value_39_61 | 101 | 39.61
Value_40_00 | 102 | 40.00
Value_40_39 | 103 | 40.39
Value_40_78 | 104 | 40.78
Value_41_18 | 105 | 41.18
Value_41_57 | 106 | 41.57
Value_41_96 | 107 | 41.96
Value_42_35 | 108 | 42.35
Value_42_75 | 109 | 42.75
Value_43_14 | 110 | 43.14
Value_43_53 | 111 | 43.53
Value_43_92 | 112 | 43.92
Value_44_31 | 113 | 44.31
Value_44_71 | 114 | 44.71
Value_45_10 | 115 | 45.10
Value_45_49 | 116 | 45.49
Value_45_88 | 117 | 45.88
Value_46_27 | 118 | 46.27
Value_46_67 | 119 | 46.67
Value_47_06 | 120 | 47.06
Value_47_45 | 121 | 47.45
Value_47_84 | 122 | 47.84
Value_48_24 | 123 | 48.24
Value_48_63 | 124 | 48.63
Value_49_02 | 125 | 49.02
Value_49_41 | 126 | 49.41
Value_49_80 | 127 | 49.80
Value_50_20 | 128 | 50.20
Value_50_59 | 129 | 50.59
Value_50_98 | 130 | 50.98
Value_51_37 | 131 | 51.37
Value_51_76 | 132 | 51.76
Value_52_16 | 133 | 52.16
Value_52_55 | 134 | 52.55
Value_52_94 | 135 | 52.94
Value_53_33 | 136 | 53.33
Value_53_73 | 137 | 53.73
Value_54_12 | 138 | 54.12
Value_54_51 | 139 | 54.51
Value_54_90 | 140 | 54.90
Value_55_29 | 141 | 55.29
Value_55_69 | 142 | 55.69
Value_56_08 | 143 | 56.08
Value_56_47 | 144 | 56.47
Value_56_86 | 145 | 56.86
Value_57_25 | 146 | 57.25
Value_57_65 | 147 | 57.65
Value_58_04 | 148 | 58.04
Value_58_43 | 149 | 58.43
Value_58_82 | 150 | 58.82
Value_59_22 | 151 | 59.22
Value_59_61 | 152 | 59.61
Value_60_00 | 153 | 60.00
Value_60_39 | 154 | 60.39
Value_60_78 | 155 | 60.78
Value_61_18 | 156 | 61.18
Value_61_57 | 157 | 61.57
Value_61_96 | 158 | 61.96
Value_62_35 | 159 | 62.35
Value_62_75 | 160 | 62.75
Value_63_14 | 161 | 63.14
Value_63_53 | 162 | 63.53
Value_63_92 | 163 | 63.92
Value_64_31 | 164 | 64.31
Value_64_71 | 165 | 64.71
Value_65_10 | 166 | 65.10
Value_65_49 | 167 | 65.49
Value_65_88 | 168 | 65.88
Value_66_27 | 169 | 66.27
Value_66_67 | 170 | 66.67
Value_67_06 | 171 | 67.06
Value_67_45 | 172 | 67.45
Value_67_84 | 173 | 67.84
Value_68_24 | 174 | 68.24
Value_68_63 | 175 | 68.63
Value_69_02 | 176 | 69.02
Value_69_41 | 177 | 69.41
Value_69_80 | 178 | 69.80
Value_70_20 | 179 | 70.20
Value_70_59 | 180 | 70.59
Value_70_98 | 181 | 70.98
Value_71_37 | 182 | 71.37
Value_71_76 | 183 | 71.76
Value_72_16 | 184 | 72.16
Value_72_55 | 185 | 72.55
Value_72_94 | 186 | 72.94
Value_73_33 | 187 | 73.33
Value_73_73 | 188 | 73.73
Value_74_12 | 189 | 74.12
Value_74_51 | 190 | 74.51
Value_74_90 | 191 | 74.90
Value_75_29 | 192 | 75.29
Value_75_69 | 193 | 75.69
Value_76_08 | 194 | 76.08
Value_76_47 | 195 | 76.47
Value_76_86 | 196 | 76.86
Value_77_25 | 197 | 77.25
Value_77_65 | 198 | 77.65
Value_78_04 | 199 | 78.04
Value_78_43 | 200 | 78.43
Value_78_82 | 201 | 78.82
Value_79_22 | 202 | 79.22
Value_79_61 | 203 | 79.61
Value_80_00 | 204 | 80.00
Value_80_39 | 205 | 80.39
Value_80_78 | 206 | 80.78
Value_81_18 | 207 | 81.18
Value_81_57 | 208 | 81.57
Value_81_96 | 209 | 81.96
Value_82_35 | 210 | 82.35
Value_82_75 | 211 | 82.75
Value_83_14 | 212 | 83.14
Value_83_53 | 213 | 83.53
Value_83_92 | 214 | 83.92
Value_84_31 | 215 | 84.31
Value_84_71 | 216 | 84.71
Value_85_10 | 217 | 85.10
Value_85_49 | 218 | 85.49
Value_85_88 | 219 | 85.88
Value_86_27 | 220 | 86.27
Value_86_67 | 221 | 86.67
Value_87_06 | 222 | 87.06
Value_87_45 | 223 | 87.45
Value_87_84 | 224 | 87.84
Value_88_24 | 225 | 88.24
Value_88_63 | 226 | 88.63
Value_89_02 | 227 | 89.02
Value_89_41 | 228 | 89.41
Value_89_80 | 229 | 89.80
Value_90_20 | 230 | 90.20
Value_90_59 | 231 | 90.59
Value_90_98 | 232 | 90.98
Value_91_37 | 233 | 91.37
Value_91_76 | 234 | 91.76
Value_92_16 | 235 | 92.16
Value_92_55 | 236 | 92.55
Value_92_94 | 237 | 92.94
Value_93_33 | 238 | 93.33
Value_93_73 | 239 | 93.73
Value_94_12 | 240 | 94.12
Value_94_51 | 241 | 94.51
Value_94_90 | 242 | 94.90
Value_95_29 | 243 | 95.29
Value_95_69 | 244 | 95.69
Value_96_08 | 245 | 96.08
Value_96_47 | 246 | 96.47
Value_96_86 | 247 | 96.86
Value_97_25 | 248 | 97.25
Value_97_65 | 249 | 97.65
Value_98_04 | 250 | 98.04
Value_98_43 | 251 | 98.43
Value_98_82 | 252 | 98.82
Value_99_22 | 253 | 99.22
Value_99_61 | 254 | 99.61
Value_100_00 | 255 | 100.00
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDFAN1RANGEFREQUENCY0 Enumeration

IRD

Lm85TYPIDFAN1RANGEFREQUENCY0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFAN1RANGEFREQUENCY0
Public Enumeration TYPIDFAN1RANGEFREQUENCY0
public enum class TYPIDFAN1RANGEFREQUENCY0
type TYPIDFAN1RANGEFREQUENCY0
Members
Member name | Value | Description
Value_10 | 0 | 10
Value_15 | 1 | 15
Value_23 | 2 | 23
Value_30 | 3 | 30
Value_38 | 4 | 38
Value_47 | 5 | 47
Value_62 | 6 | 62
Value_94 | 7 | 94
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDFAN1RANGEFREQUENCY1 Enumeration

IRD

Lm85TYPIDFAN1RANGEFREQUENCY1 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFAN1RANGEFREQUENCY1
Public Enumeration TYPIDFAN1RANGEFREQUENCY1
public enum class TYPIDFAN1RANGEFREQUENCY1
type TYPIDFAN1RANGEFREQUENCY1
Members
Member name | Value | Description
Value_2 | 0 | 2
Value_2_5 | 1 | 2.5
Value_3_33 | 2 | 3.33
Value_4 | 3 | 4
Value_5 | 4 | 5
Value_6_67 | 5 | 6.67
Value_8 | 6 | 8
Value_10 | 7 | 10
Value_13_33 | 8 | 13.33
Value_16 | 9 | 16
Value_20 | 10 | 20
Value_26_67 | 11 | 26.67
Value_32 | 12 | 32
Value_40 | 13 | 40
Value_53_33 | 14 | 53.33
Value_80 | 15 | 80
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDFANSPINUPMODE0 Enumeration

IRD

Lm85TYPIDFANSPINUPMODE0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFANSPINUPMODE0
Public Enumeration TYPIDFANSPINUPMODE0
public enum class TYPIDFANSPINUPMODE0
type TYPIDFANSPINUPMODE0
Members
Member name | Value | Description
SpinUpTimeWillTerminateAfterTimeProgrammed | 0 | Spin-up time will terminate after time programmed
SpinUpTimeWillTerminateEarlyIfTheTACHReadingExceedsTheTachMinimumValue | 1 | Spin-up time will terminate early if the TACH reading exceeds the Tach Minimum value
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDINTERRUPTSTATUSREGISTER10 Enumeration

IRD

Lm85TYPIDINTERRUPTSTATUSREGISTER10 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINTERRUPTSTATUSREGISTER10
Public Enumeration TYPIDINTERRUPTSTATUSREGISTER10
public enum class TYPIDINTERRUPTSTATUSREGISTER10
type TYPIDINTERRUPTSTATUSREGISTER10
Members
Member name | Value | Description
VoltageIsInTheRangeOfTheLimits | 0 | Voltage is in the range of the limits
VoltageIsOutOfTheRangeOfOneLimit | 1 | Voltage is out of the range of one limit
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDINTERRUPTSTATUSREGISTER14 Enumeration

IRD

Lm85TYPIDINTERRUPTSTATUSREGISTER14 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINTERRUPTSTATUSREGISTER14
Public Enumeration TYPIDINTERRUPTSTATUSREGISTER14
public enum class TYPIDINTERRUPTSTATUSREGISTER14
type TYPIDINTERRUPTSTATUSREGISTER14
Members
Member name | Value | Description
MeasuredByTheRemote1AndRemote1InputsIsHigherThanTheLimit | 0 | Measured by the Remote1- and Remote1+ inputs is higher than the limit
MeasuredByTheRemote1AndRemote1InputsIsLessThanOrEqualToTheLimit | 1 | Measured by the Remote1- and Remote1+ inputs is less than or equal to the limit
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDINTERRUPTSTATUSREGISTER15 Enumeration

IRD

Lm85TYPIDINTERRUPTSTATUSREGISTER15 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINTERRUPTSTATUSREGISTER15
Public Enumeration TYPIDINTERRUPTSTATUSREGISTER15
public enum class TYPIDINTERRUPTSTATUSREGISTER15
type TYPIDINTERRUPTSTATUSREGISTER15
Members
Member name | Value | Description
MeasuredByTheInternalTemperatureSensorIsHigherThanTheLimit | 0 | Measured by the internal temperature sensor is higher than the limit
MeasuredByTheInternalTemperatureSensorIsLessThanOrEqualToTheLimit | 1 | Measured by the internal temperature sensor is less than or equal to the limit
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDINTERRUPTSTATUSREGISTER16 Enumeration

IRD

Lm85TYPIDINTERRUPTSTATUSREGISTER16 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINTERRUPTSTATUSREGISTER16
Public Enumeration TYPIDINTERRUPTSTATUSREGISTER16
public enum class TYPIDINTERRUPTSTATUSREGISTER16
type TYPIDINTERRUPTSTATUSREGISTER16
Members
Member name | Value | Description
MeasuredByTheRemote2AndRemote2InputsIsHigherThanTheLimit | 0 | Measured by the Remote2- and Remote2+ inputs is higher than the limit
MeasuredByTheRemote2AndRemote2InputsIsLessThanOrEqualToTheLimit | 1 | Measured by the Remote2- and Remote2+ inputs is less than or equal to the limit
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDINTERRUPTSTATUSREGISTER17 Enumeration

IRD

Lm85TYPIDINTERRUPTSTATUSREGISTER17 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINTERRUPTSTATUSREGISTER17
Public Enumeration TYPIDINTERRUPTSTATUSREGISTER17
public enum class TYPIDINTERRUPTSTATUSREGISTER17
type TYPIDINTERRUPTSTATUSREGISTER17
Members
Member name | Value | Description
NoBitsInStatusRegister2WereSet | 0 | No bits in Status Register 2 were set
OneOrMoreSetBitsInStatusRegister2WereSet | 1 | One or more set bits in Status Register 2 were set
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDINTERRUPTSTATUSREGISTER20 Enumeration

IRD

Lm85TYPIDINTERRUPTSTATUSREGISTER20 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINTERRUPTSTATUSREGISTER20
Public Enumeration TYPIDINTERRUPTSTATUSREGISTER20
public enum class TYPIDINTERRUPTSTATUSREGISTER20
type TYPIDINTERRUPTSTATUSREGISTER20
Members
Member name | Value | Description
VoltageInRange | 0 | Voltage in range
VoltageFallsBelowTheLowLimitExceedsTheHighLimitRegister | 1 | Voltage falls below the low limit/exceeds the high limit register
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDINTERRUPTSTATUSREGISTER21 Enumeration

IRD

Lm85TYPIDINTERRUPTSTATUSREGISTER21 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINTERRUPTSTATUSREGISTER21
Public Enumeration TYPIDINTERRUPTSTATUSREGISTER21
public enum class TYPIDINTERRUPTSTATUSREGISTER21
type TYPIDINTERRUPTSTATUSREGISTER21
Members
Member name | Value | Description
LowerOrEqualTheValueSetInTheTach1Minimum | 0 | Lower or equal the value set in the Tach1 Minimum
AboveTheValueSetInTheTach1Minimum | 1 | Above the value set in the Tach1 Minimum
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDINTERRUPTSTATUSREGISTER22 Enumeration

IRD

Lm85TYPIDINTERRUPTSTATUSREGISTER22 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINTERRUPTSTATUSREGISTER22
Public Enumeration TYPIDINTERRUPTSTATUSREGISTER22
public enum class TYPIDINTERRUPTSTATUSREGISTER22
type TYPIDINTERRUPTSTATUSREGISTER22
Members
Member name | Value | Description
LowerOrEqualTheValueSetInTheTach2Minimum | 0 | Lower or equal the value set in the Tach2 Minimum
AboveTheValueSetInTheTach2Minimum | 1 | Above the value set in the Tach2 Minimum
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDINTERRUPTSTATUSREGISTER23 Enumeration

IRD

Lm85TYPIDINTERRUPTSTATUSREGISTER23 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINTERRUPTSTATUSREGISTER23
Public Enumeration TYPIDINTERRUPTSTATUSREGISTER23
public enum class TYPIDINTERRUPTSTATUSREGISTER23
type TYPIDINTERRUPTSTATUSREGISTER23
Members
Member name | Value | Description
LowerOrEqualTheValueSetInTheTach3Minimum | 0 | Lower or equal the value set in the Tach3 Minimum
AboveTheValueSetInTheTach3Minimum | 1 | Above the value set in the Tach3 Minimum
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDINTERRUPTSTATUSREGISTER24 Enumeration

IRD

Lm85TYPIDINTERRUPTSTATUSREGISTER24 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINTERRUPTSTATUSREGISTER24
Public Enumeration TYPIDINTERRUPTSTATUSREGISTER24
public enum class TYPIDINTERRUPTSTATUSREGISTER24
type TYPIDINTERRUPTSTATUSREGISTER24
Members
Member name | Value | Description
LowerOrEqualTheValueSetInTheTach4Minimum | 0 | Lower or equal the value set in the Tach4 Minimum
AboveTheValueSetInTheTach4Minimum | 1 | Above the value set in the Tach4 Minimum
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDINTERRUPTSTATUSREGISTER25 Enumeration

IRD

Lm85TYPIDINTERRUPTSTATUSREGISTER25 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINTERRUPTSTATUSREGISTER25
Public Enumeration TYPIDINTERRUPTSTATUSREGISTER25
public enum class TYPIDINTERRUPTSTATUSREGISTER25
type TYPIDINTERRUPTSTATUSREGISTER25
Members
Member name | Value | Description
NoShortOpenCircuitFaultOnTheRemote1OrRemote1InputPins | 0 | No short/open circuit fault on the Remote1+ or Remote1- input pins
ShortOpenCircuitFaultOnTheRemote1OrRemote1InputPins | 1 | Short/open circuit fault on the Remote1+ or Remote1- input pins
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDINTERRUPTSTATUSREGISTER26 Enumeration

IRD

Lm85TYPIDINTERRUPTSTATUSREGISTER26 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINTERRUPTSTATUSREGISTER26
Public Enumeration TYPIDINTERRUPTSTATUSREGISTER26
public enum class TYPIDINTERRUPTSTATUSREGISTER26
type TYPIDINTERRUPTSTATUSREGISTER26
Members
Member name | Value | Description
NoShortOpenCircuitFaultOnTheRemote1OrRemote1InputPins | 0 | No short/open circuit fault on the Remote1+ or Remote1- input pins
ShortOpenCircuitFaultOnTheRemote1OrRemote1InputPins | 1 | Short/open circuit fault on the Remote1+ or Remote1- input pins
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDMINOFFZONE1SPSPIKESMOOTHING0 Enumeration

IRD

Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMINOFFZONE1SPSPIKESMOOTHING0
Public Enumeration TYPIDMINOFFZONE1SPSPIKESMOOTHING0
public enum class TYPIDMINOFFZONE1SPSPIKESMOOTHING0
type TYPIDMINOFFZONE1SPSPIKESMOOTHING0
Members
Member name | Value | Description
Value_35 | 0 | 35
Value_17_6 | 1 | 17.6
Value_11_8 | 2 | 11.8
Value_7_0 | 3 | 7.0
Value_4_4 | 4 | 4.4
Value_3_0 | 5 | 3.0
Value_1_6 | 6 | 1.6
Value_0_8 | 7 | 0.8
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDMINOFFZONE1SPSPIKESMOOTHING2 Enumeration

IRD

Lm85TYPIDMINOFFZONE1SPSPIKESMOOTHING2 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMINOFFZONE1SPSPIKESMOOTHING2
Public Enumeration TYPIDMINOFFZONE1SPSPIKESMOOTHING2
public enum class TYPIDMINOFFZONE1SPSPIKESMOOTHING2
type TYPIDMINOFFZONE1SPSPIKESMOOTHING2
Members
Member name | Value | Description
At0DutyBelowLIMIT | 0 | At 0% duty below LIMIT
AtMinPWMDutyBelowLIMIT | 1 | At Min PWM Duty below LIMIT
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDPROCESSORZONE1TEMP0 Enumeration

IRD

Lm85TYPIDPROCESSORZONE1TEMP0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDPROCESSORZONE1TEMP0
Public Enumeration TYPIDPROCESSORZONE1TEMP0
public enum class TYPIDPROCESSORZONE1TEMP0
type TYPIDPROCESSORZONE1TEMP0
Members
Member name | Value | Description
SensorError | -128 | Sensor Error! ??
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDREADYLOCKSTARTOVERRIDE0 Enumeration

IRD

Lm85TYPIDREADYLOCKSTARTOVERRIDE0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDREADYLOCKSTARTOVERRIDE0
Public Enumeration TYPIDREADYLOCKSTARTOVERRIDE0
public enum class TYPIDREADYLOCKSTARTOVERRIDE0
type TYPIDREADYLOCKSTARTOVERRIDE0
Members
Member name | Value | Description
LM85FanMonitoringPWMOutputUseTheDefaultValueLimit | 0 | LM85 fan monitoring/PWM output: Use the default value limit
LM85FanMonitoringPWMOutputUseTheValuesSetInTheFanControlLimit | 1 | LM85 fan monitoring/PWM output: Use the values set in the fan control limit
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDREADYLOCKSTARTOVERRIDE1 Enumeration

IRD

Lm85TYPIDREADYLOCKSTARTOVERRIDE1 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDREADYLOCKSTARTOVERRIDE1
Public Enumeration TYPIDREADYLOCKSTARTOVERRIDE1
public enum class TYPIDREADYLOCKSTARTOVERRIDE1
type TYPIDREADYLOCKSTARTOVERRIDE1
Members
Member name | Value | Description
SpecifiedLimitAndParameterRegistersNotLocked | 0 | Specified limit and parameter registers not locked
SpecifiedLimitAndParameterRegistersLocked | 1 | Specified limit and parameter registers locked
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDREADYLOCKSTARTOVERRIDE2 Enumeration

IRD

Lm85TYPIDREADYLOCKSTARTOVERRIDE2 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDREADYLOCKSTARTOVERRIDE2
Public Enumeration TYPIDREADYLOCKSTARTOVERRIDE2
public enum class TYPIDREADYLOCKSTARTOVERRIDE2
type TYPIDREADYLOCKSTARTOVERRIDE2
Members
Member name | Value | Description
LM85NotFullyPoweredUp | 0 | LM85 not fully powered up
LM85FullyPoweredUp | 1 | LM85 fully powered up
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDREADYLOCKSTARTOVERRIDE3 Enumeration

IRD

Lm85TYPIDREADYLOCKSTARTOVERRIDE3 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDREADYLOCKSTARTOVERRIDE3
Public Enumeration TYPIDREADYLOCKSTARTOVERRIDE3
public enum class TYPIDREADYLOCKSTARTOVERRIDE3
type TYPIDREADYLOCKSTARTOVERRIDE3
Members
Member name | Value | Description
PWMOutputsWillNotGoTo100 | 0 | PWM outputs will not go to 100%
PWMOutputsWillGoTo100RegardlessLOCK | 1 | PWM outputs will go to 100% (regardless LOCK)
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDTACH1LSB0 Enumeration

IRD

Lm85TYPIDTACH1LSB0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTACH1LSB0
Public Enumeration TYPIDTACH1LSB0
public enum class TYPIDTACH1LSB0
type TYPIDTACH1LSB0
Members
Member name | Value | Description
Value_1LeastAccurate | 1 | 1 - Least Accurate
Value_3MostAccurate | 3 | 3 - Most Accurate
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDTACH1MINIMUMLSB0 Enumeration

IRD

Lm85TYPIDTACH1MINIMUMLSB0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTACH1MINIMUMLSB0
Public Enumeration TYPIDTACH1MINIMUMLSB0
public enum class TYPIDTACH1MINIMUMLSB0
type TYPIDTACH1MINIMUMLSB0
Members
Member name | Value | Description
CPU | 0 | CPU
Memory | 1 | Memory
ChassisFront | 2 | Chassis Front
ChassisRear | 3 | Chassis Rear
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDTACHMONITORMODE0 Enumeration

IRD

Lm85TYPIDTACHMONITORMODE0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTACHMONITORMODE0
Public Enumeration TYPIDTACHMONITORMODE0
public enum class TYPIDTACHMONITORMODE0
type TYPIDTACHMONITORMODE0
Members
Member name | Value | Description
TraditionalTachInputMonitorFalseReadingsWhenUnderMinimumDetctableRPM | 0 | Traditional tach input monitor, false readings when under minimum detctable RPM
TraditionalTachInputMonitorFFFFhReadingWhenUnderMinimumDetectableRPM | 1 | Traditional tach input monitor, FFFFh reading when under minimum detectable RPM
MostAccurateReadingsFFFFhReadingWhenUnderMinimumDetectableRPM | 2 | Most accurate readings, FFFFh reading when under minimum detectable RPM
LeastEffectOnProgrammedPWMOfFanFFFFhReadingWhenUnderMinimumDetectableRPM | 3 | Least effect on programmed PWM of Fan, FFFFh reading when under minimum detectable RPM
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDVCCP0 Enumeration

IRD

Lm85TYPIDVCCP0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDVCCP0
Public Enumeration TYPIDVCCP0
public enum class TYPIDVCCP0
type TYPIDVCCP0
Members
Member name | Value | Description
Value_0000VCPP | 0 | 0.000*VCPP
Value_0005VCPP | 1 | 0.005*VCPP
Value_0010VCPP | 2 | 0.010*VCPP
Value_0016VCPP | 3 | 0.016*VCPP
Value_0021VCPP | 4 | 0.021*VCPP
Value_0026VCPP | 5 | 0.026*VCPP
Value_0031VCPP | 6 | 0.031*VCPP
Value_0036VCPP | 7 | 0.036*VCPP
Value_0042VCPP | 8 | 0.042*VCPP
Value_0047VCPP | 9 | 0.047*VCPP
Value_0052VCPP | 10 | 0.052*VCPP
Value_0057VCPP | 11 | 0.057*VCPP
Value_0063VCPP | 12 | 0.063*VCPP
Value_0068VCPP | 13 | 0.068*VCPP
Value_0073VCPP | 14 | 0.073*VCPP
Value_0078VCPP | 15 | 0.078*VCPP
Value_0083VCPP | 16 | 0.083*VCPP
Value_0089VCPP | 17 | 0.089*VCPP
Value_0094VCPP | 18 | 0.094*VCPP
Value_0099VCPP | 19 | 0.099*VCPP
Value_0104VCPP | 20 | 0.104*VCPP
Value_0109VCPP | 21 | 0.109*VCPP
Value_0115VCPP | 22 | 0.115*VCPP
Value_0120VCPP | 23 | 0.120*VCPP
Value_0125VCPP | 24 | 0.125*VCPP
Value_0130VCPP | 25 | 0.130*VCPP
Value_0135VCPP | 26 | 0.135*VCPP
Value_0141VCPP | 27 | 0.141*VCPP
Value_0146VCPP | 28 | 0.146*VCPP
Value_0151VCPP | 29 | 0.151*VCPP
Value_0156VCPP | 30 | 0.156*VCPP
Value_0161VCPP | 31 | 0.161*VCPP
Value_0167VCPP | 32 | 0.167*VCPP
Value_0172VCPP | 33 | 0.172*VCPP
Value_0177VCPP | 34 | 0.177*VCPP
Value_0182VCPP | 35 | 0.182*VCPP
Value_0188VCPP | 36 | 0.188*VCPP
Value_0193VCPP | 37 | 0.193*VCPP
Value_0198VCPP | 38 | 0.198*VCPP
Value_0203VCPP | 39 | 0.203*VCPP
Value_0208VCPP | 40 | 0.208*VCPP
Value_0214VCPP | 41 | 0.214*VCPP
Value_0219VCPP | 42 | 0.219*VCPP
Value_0224VCPP | 43 | 0.224*VCPP
Value_0229VCPP | 44 | 0.229*VCPP
Value_0234VCPP | 45 | 0.234*VCPP
Value_0240VCPP | 46 | 0.240*VCPP
Value_0245VCPP | 47 | 0.245*VCPP
Value_0250VCPP | 48 | 0.250*VCPP
Value_0255VCPP | 49 | 0.255*VCPP
Value_0260VCPP | 50 | 0.260*VCPP
Value_0266VCPP | 51 | 0.266*VCPP
Value_0271VCPP | 52 | 0.271*VCPP
Value_0276VCPP | 53 | 0.276*VCPP
Value_0281VCPP | 54 | 0.281*VCPP
Value_0286VCPP | 55 | 0.286*VCPP
Value_0292VCPP | 56 | 0.292*VCPP
Value_0297VCPP | 57 | 0.297*VCPP
Value_0302VCPP | 58 | 0.302*VCPP
Value_0307VCPP | 59 | 0.307*VCPP
Value_0313VCPP | 60 | 0.313*VCPP
Value_0318VCPP | 61 | 0.318*VCPP
Value_0323VCPP | 62 | 0.323*VCPP
Value_0328VCPP | 63 | 0.328*VCPP
Value_0333VCPP | 64 | 0.333*VCPP
Value_0339VCPP | 65 | 0.339*VCPP
Value_0344VCPP | 66 | 0.344*VCPP
Value_0349VCPP | 67 | 0.349*VCPP
Value_0354VCPP | 68 | 0.354*VCPP
Value_0359VCPP | 69 | 0.359*VCPP
Value_0365VCPP | 70 | 0.365*VCPP
Value_0370VCPP | 71 | 0.370*VCPP
Value_0375VCPP | 72 | 0.375*VCPP
Value_0380VCPP | 73 | 0.380*VCPP
Value_0385VCPP | 74 | 0.385*VCPP
Value_0391VCPP | 75 | 0.391*VCPP
Value_0396VCPP | 76 | 0.396*VCPP
Value_0401VCPP | 77 | 0.401*VCPP
Value_0406VCPP | 78 | 0.406*VCPP
Value_0411VCPP | 79 | 0.411*VCPP
Value_0417VCPP | 80 | 0.417*VCPP
Value_0422VCPP | 81 | 0.422*VCPP
Value_0427VCPP | 82 | 0.427*VCPP
Value_0432VCPP | 83 | 0.432*VCPP
Value_0438VCPP | 84 | 0.438*VCPP
Value_0443VCPP | 85 | 0.443*VCPP
Value_0448VCPP | 86 | 0.448*VCPP
Value_0453VCPP | 87 | 0.453*VCPP
Value_0458VCPP | 88 | 0.458*VCPP
Value_0464VCPP | 89 | 0.464*VCPP
Value_0469VCPP | 90 | 0.469*VCPP
Value_0474VCPP | 91 | 0.474*VCPP
Value_0479VCPP | 92 | 0.479*VCPP
Value_0484VCPP | 93 | 0.484*VCPP
Value_0490VCPP | 94 | 0.490*VCPP
Value_0495VCPP | 95 | 0.495*VCPP
Value_0500VCPP | 96 | 0.500*VCPP
Value_0505VCPP | 97 | 0.505*VCPP
Value_0510VCPP | 98 | 0.510*VCPP
Value_0516VCPP | 99 | 0.516*VCPP
Value_0521VCPP | 100 | 0.521*VCPP
Value_0526VCPP | 101 | 0.526*VCPP
Value_0531VCPP | 102 | 0.531*VCPP
Value_0536VCPP | 103 | 0.536*VCPP
Value_0542VCPP | 104 | 0.542*VCPP
Value_0547VCPP | 105 | 0.547*VCPP
Value_0552VCPP | 106 | 0.552*VCPP
Value_0557VCPP | 107 | 0.557*VCPP
Value_0563VCPP | 108 | 0.563*VCPP
Value_0568VCPP | 109 | 0.568*VCPP
Value_0573VCPP | 110 | 0.573*VCPP
Value_0578VCPP | 111 | 0.578*VCPP
Value_0583VCPP | 112 | 0.583*VCPP
Value_0589VCPP | 113 | 0.589*VCPP
Value_0594VCPP | 114 | 0.594*VCPP
Value_0599VCPP | 115 | 0.599*VCPP
Value_0604VCPP | 116 | 0.604*VCPP
Value_0609VCPP | 117 | 0.609*VCPP
Value_0615VCPP | 118 | 0.615*VCPP
Value_0620VCPP | 119 | 0.620*VCPP
Value_0625VCPP | 120 | 0.625*VCPP
Value_0630VCPP | 121 | 0.630*VCPP
Value_0635VCPP | 122 | 0.635*VCPP
Value_0641VCPP | 123 | 0.641*VCPP
Value_0646VCPP | 124 | 0.646*VCPP
Value_0651VCPP | 125 | 0.651*VCPP
Value_0656VCPP | 126 | 0.656*VCPP
Value_0661VCPP | 127 | 0.661*VCPP
Value_0667VCPP | 128 | 0.667*VCPP
Value_0672VCPP | 129 | 0.672*VCPP
Value_0677VCPP | 130 | 0.677*VCPP
Value_0682VCPP | 131 | 0.682*VCPP
Value_0688VCPP | 132 | 0.688*VCPP
Value_0693VCPP | 133 | 0.693*VCPP
Value_0698VCPP | 134 | 0.698*VCPP
Value_0703VCPP | 135 | 0.703*VCPP
Value_0708VCPP | 136 | 0.708*VCPP
Value_0714VCPP | 137 | 0.714*VCPP
Value_0719VCPP | 138 | 0.719*VCPP
Value_0724VCPP | 139 | 0.724*VCPP
Value_0729VCPP | 140 | 0.729*VCPP
Value_0734VCPP | 141 | 0.734*VCPP
Value_0740VCPP | 142 | 0.740*VCPP
Value_0745VCPP | 143 | 0.745*VCPP
Value_0750VCPP | 144 | 0.750*VCPP
Value_0755VCPP | 145 | 0.755*VCPP
Value_0760VCPP | 146 | 0.760*VCPP
Value_0766VCPP | 147 | 0.766*VCPP
Value_0771VCPP | 148 | 0.771*VCPP
Value_0776VCPP | 149 | 0.776*VCPP
Value_0781VCPP | 150 | 0.781*VCPP
Value_0786VCPP | 151 | 0.786*VCPP
Value_0792VCPP | 152 | 0.792*VCPP
Value_0797VCPP | 153 | 0.797*VCPP
Value_0802VCPP | 154 | 0.802*VCPP
Value_0807VCPP | 155 | 0.807*VCPP
Value_0813VCPP | 156 | 0.813*VCPP
Value_0818VCPP | 157 | 0.818*VCPP
Value_0823VCPP | 158 | 0.823*VCPP
Value_0828VCPP | 159 | 0.828*VCPP
Value_0833VCPP | 160 | 0.833*VCPP
Value_0839VCPP | 161 | 0.839*VCPP
Value_0844VCPP | 162 | 0.844*VCPP
Value_0849VCPP | 163 | 0.849*VCPP
Value_0854VCPP | 164 | 0.854*VCPP
Value_0859VCPP | 165 | 0.859*VCPP
Value_0865VCPP | 166 | 0.865*VCPP
Value_0870VCPP | 167 | 0.870*VCPP
Value_0875VCPP | 168 | 0.875*VCPP
Value_0880VCPP | 169 | 0.880*VCPP
Value_0885VCPP | 170 | 0.885*VCPP
Value_0891VCPP | 171 | 0.891*VCPP
Value_0896VCPP | 172 | 0.896*VCPP
Value_0901VCPP | 173 | 0.901*VCPP
Value_0906VCPP | 174 | 0.906*VCPP
Value_0911VCPP | 175 | 0.911*VCPP
Value_0917VCPP | 176 | 0.917*VCPP
Value_0922VCPP | 177 | 0.922*VCPP
Value_0927VCPP | 178 | 0.927*VCPP
Value_0932VCPP | 179 | 0.932*VCPP
Value_0938VCPP | 180 | 0.938*VCPP
Value_0943VCPP | 181 | 0.943*VCPP
Value_0948VCPP | 182 | 0.948*VCPP
Value_0953VCPP | 183 | 0.953*VCPP
Value_0958VCPP | 184 | 0.958*VCPP
Value_0964VCPP | 185 | 0.964*VCPP
Value_0969VCPP | 186 | 0.969*VCPP
Value_0974VCPP | 187 | 0.974*VCPP
Value_0979VCPP | 188 | 0.979*VCPP
Value_0984VCPP | 189 | 0.984*VCPP
Value_0990VCPP | 190 | 0.990*VCPP
Value_0995VCPP | 191 | 0.995*VCPP
Value_1000VCPP | 192 | 1.000*VCPP
Value_1005VCPP | 193 | 1.005*VCPP
Value_1010VCPP | 194 | 1.010*VCPP
Value_1016VCPP | 195 | 1.016*VCPP
Value_1021VCPP | 196 | 1.021*VCPP
Value_1026VCPP | 197 | 1.026*VCPP
Value_1031VCPP | 198 | 1.031*VCPP
Value_1036VCPP | 199 | 1.036*VCPP
Value_1042VCPP | 200 | 1.042*VCPP
Value_1047VCPP | 201 | 1.047*VCPP
Value_1052VCPP | 202 | 1.052*VCPP
Value_1057VCPP | 203 | 1.057*VCPP
Value_1063VCPP | 204 | 1.063*VCPP
Value_1068VCPP | 205 | 1.068*VCPP
Value_1073VCPP | 206 | 1.073*VCPP
Value_1078VCPP | 207 | 1.078*VCPP
Value_1083VCPP | 208 | 1.083*VCPP
Value_1089VCPP | 209 | 1.089*VCPP
Value_1094VCPP | 210 | 1.094*VCPP
Value_1099VCPP | 211 | 1.099*VCPP
Value_1104VCPP | 212 | 1.104*VCPP
Value_1109VCPP | 213 | 1.109*VCPP
Value_1115VCPP | 214 | 1.115*VCPP
Value_1120VCPP | 215 | 1.120*VCPP
Value_1125VCPP | 216 | 1.125*VCPP
Value_1130VCPP | 217 | 1.130*VCPP
Value_1135VCPP | 218 | 1.135*VCPP
Value_1141VCPP | 219 | 1.141*VCPP
Value_1146VCPP | 220 | 1.146*VCPP
Value_1151VCPP | 221 | 1.151*VCPP
Value_1156VCPP | 222 | 1.156*VCPP
Value_1161VCPP | 223 | 1.161*VCPP
Value_1167VCPP | 224 | 1.167*VCPP
Value_1172VCPP | 225 | 1.172*VCPP
Value_1177VCPP | 226 | 1.177*VCPP
Value_1182VCPP | 227 | 1.182*VCPP
Value_1188VCPP | 228 | 1.188*VCPP
Value_1193VCPP | 229 | 1.193*VCPP
Value_1198VCPP | 230 | 1.198*VCPP
Value_1203VCPP | 231 | 1.203*VCPP
Value_1208VCPP | 232 | 1.208*VCPP
Value_1214VCPP | 233 | 1.214*VCPP
Value_1219VCPP | 234 | 1.219*VCPP
Value_1224VCPP | 235 | 1.224*VCPP
Value_1229VCPP | 236 | 1.229*VCPP
Value_1234VCPP | 237 | 1.234*VCPP
Value_1240VCPP | 238 | 1.240*VCPP
Value_1245VCPP | 239 | 1.245*VCPP
Value_1250VCPP | 240 | 1.250*VCPP
Value_1255VCPP | 241 | 1.255*VCPP
Value_1260VCPP | 242 | 1.260*VCPP
Value_1266VCPP | 243 | 1.266*VCPP
Value_1271VCPP | 244 | 1.271*VCPP
Value_1276VCPP | 245 | 1.276*VCPP
Value_1281VCPP | 246 | 1.281*VCPP
Value_1286VCPP | 247 | 1.286*VCPP
Value_1292VCPP | 248 | 1.292*VCPP
Value_1297VCPP | 249 | 1.297*VCPP
Value_1302VCPP | 250 | 1.302*VCPP
Value_1307VCPP | 251 | 1.307*VCPP
Value_1313VCPP | 252 | 1.313*VCPP
Value_1318VCPP | 253 | 1.318*VCPP
Value_1323VCPP | 254 | 1.323*VCPP
Value_1328VCPP | 255 | 1.328*VCPP
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm85.TYPIDXORTESTTREEENABLE0 Enumeration

IRD

Lm85TYPIDXORTESTTREEENABLE0 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDXORTESTTREEENABLE0
Public Enumeration TYPIDXORTESTTREEENABLE0
public enum class TYPIDXORTESTTREEENABLE0
type TYPIDXORTESTTREEENABLE0
Members
Member name | Value | Description
BringsThePartOutOfXORTreeTestMode | 0 | Brings the part out of XOR tree test mode
PartWillBePlacedIntoXORTreeTestMode | 1 | Part will be placed into XOR tree test mode
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm86 Class

National Semiconductor: LM 86
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm86

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm86
Public Class Lm86
public ref class Lm86
type Lm86 =  class end

The Lm86 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm86 | Constructor
Top
Properties
 | Name | Description
Public property | ALERTConfigure | ALERT Configure
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationALERTMask | Configuration: ALERT Mask
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationLocalTCRITAMask | Configuration: Local T_CRIT_A Mask
Public property | ConfigurationRemoteTCRITAMask | Configuration: Remote T_CRIT_A Mask
Public property | ConfigurationRUNSTOP | Configuration: RUN/STOP
Public property | ConversionRate | Conversion Rate
Public property | FilterLevel | Filter Level
Public property | LocalHIGHSetpoint | Local HIGH Setpoint (unit: °C)
Public property | LocalLOWSetpoint | Local LOW Setpoint (unit: °C)
Public property | LocalTCRITSetpoint | Local T_CRIT Setpoint (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerSID | Manufacturer's ID
Public property | RemoteHIGHSetpoint | Remote HIGH Setpoint (unit: °C)
Public property | RemoteLOWSetpoint | Remote LOW Setpoint (unit: °C)
Public property | RemoteTCRITSetpoint | Remote T_CRIT Setpoint (unit: °C)
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | RemoteTemperatureOffset | Remote Temperature Offset (unit: °C)
Public property | StatusBusy | Status: Busy
Public property | StatusLCRIT | Status: LCRIT
Public property | StatusLHIGH | Status: LHIGH
Public property | StatusLLOW | Status: LLOW
Public property | StatusOPEN | Status: OPEN
Public property | StatusRCRIT | Status: RCRIT
Public property | StatusRHIGH | Status: RHIGH
Public property | StatusRLOW | Status: RLOW
Public property | SteppingOrDieRevisionCode | Stepping Or Die Revision Code
Public property | TCRITHysteresis | T_CRIT Hysteresis (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
±0.75°C Accurate, Remote Diode and Local Digital Temperature Sensor with Two-Wire Interface
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm86 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm86(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm86(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm86

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86 Properties

The Lm86 type exposes the following members.

Properties
 | Name | Description
Public property | ALERTConfigure | ALERT Configure
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationALERTMask | Configuration: ALERT Mask
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationLocalTCRITAMask | Configuration: Local T_CRIT_A Mask
Public property | ConfigurationRemoteTCRITAMask | Configuration: Remote T_CRIT_A Mask
Public property | ConfigurationRUNSTOP | Configuration: RUN/STOP
Public property | ConversionRate | Conversion Rate
Public property | FilterLevel | Filter Level
Public property | LocalHIGHSetpoint | Local HIGH Setpoint (unit: °C)
Public property | LocalLOWSetpoint | Local LOW Setpoint (unit: °C)
Public property | LocalTCRITSetpoint | Local T_CRIT Setpoint (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerSID | Manufacturer's ID
Public property | RemoteHIGHSetpoint | Remote HIGH Setpoint (unit: °C)
Public property | RemoteLOWSetpoint | Remote LOW Setpoint (unit: °C)
Public property | RemoteTCRITSetpoint | Remote T_CRIT Setpoint (unit: °C)
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | RemoteTemperatureOffset | Remote Temperature Offset (unit: °C)
Public property | StatusBusy | Status: Busy
Public property | StatusLCRIT | Status: LCRIT
Public property | StatusLHIGH | Status: LHIGH
Public property | StatusLLOW | Status: LLOW
Public property | StatusOPEN | Status: OPEN
Public property | StatusRCRIT | Status: RCRIT
Public property | StatusRHIGH | Status: RHIGH
Public property | StatusRLOW | Status: RLOW
Public property | SteppingOrDieRevisionCode | Stepping Or Die Revision Code
Public property | TCRITHysteresis | T_CRIT Hysteresis (unit: °C)
Top
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.ALERTConfigure Property

IRD

Lm86ALERTConfigure Property

ALERT Configure

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm86TypeAlertConfigure ALERTConfigure { get; set; }
Public Property ALERTConfigure As Lm86TypeAlertConfigure
    Get
    Set
public:
property Lm86TypeAlertConfigure ALERTConfigure {
    Lm86TypeAlertConfigure get ();
    void set (Lm86TypeAlertConfigure value);
}
member ALERTConfigure : Lm86TypeAlertConfigure with get, set

Property Value

Type: Lm86TypeAlertConfigure
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.AutoFlush Property

IRD

Lm86AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.ConfigurationALERTMask Property

IRD

Lm86ConfigurationALERTMask Property

Configuration: ALERT Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm86TypeConfigurationAlertMask ConfigurationALERTMask { get; set; }
Public Property ConfigurationALERTMask As Lm86TypeConfigurationAlertMask
    Get
    Set
public:
property Lm86TypeConfigurationAlertMask ConfigurationALERTMask {
    Lm86TypeConfigurationAlertMask get ();
    void set (Lm86TypeConfigurationAlertMask value);
}
member ConfigurationALERTMask : Lm86TypeConfigurationAlertMask with get, set

Property Value

Type: Lm86TypeConfigurationAlertMask
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.ConfigurationFaultQueue Property

IRD

Lm86ConfigurationFaultQueue Property

Configuration: Fault Queue

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm86TypeConfigurationFaultQueue ConfigurationFaultQueue { get; set; }
Public Property ConfigurationFaultQueue As Lm86TypeConfigurationFaultQueue
    Get
    Set
public:
property Lm86TypeConfigurationFaultQueue ConfigurationFaultQueue {
    Lm86TypeConfigurationFaultQueue get ();
    void set (Lm86TypeConfigurationFaultQueue value);
}
member ConfigurationFaultQueue : Lm86TypeConfigurationFaultQueue with get, set

Property Value

Type: Lm86TypeConfigurationFaultQueue
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.ConfigurationLocalTCRITAMask Property

IRD

Lm86ConfigurationLocalTCRITAMask Property

Configuration: Local T_CRIT_A Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm86TypeConfigurationLocalTCritMask ConfigurationLocalTCRITAMask { get; set; }
Public Property ConfigurationLocalTCRITAMask As Lm86TypeConfigurationLocalTCritMask
    Get
    Set
public:
property Lm86TypeConfigurationLocalTCritMask ConfigurationLocalTCRITAMask {
    Lm86TypeConfigurationLocalTCritMask get ();
    void set (Lm86TypeConfigurationLocalTCritMask value);
}
member ConfigurationLocalTCRITAMask : Lm86TypeConfigurationLocalTCritMask with get, set

Property Value

Type: Lm86TypeConfigurationLocalTCritMask
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.ConfigurationRemoteTCRITAMask Property

IRD

Lm86ConfigurationRemoteTCRITAMask Property

Configuration: Remote T_CRIT_A Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm86TypeConfigurationRemoteTCritMask ConfigurationRemoteTCRITAMask { get; set; }
Public Property ConfigurationRemoteTCRITAMask As Lm86TypeConfigurationRemoteTCritMask
    Get
    Set
public:
property Lm86TypeConfigurationRemoteTCritMask ConfigurationRemoteTCRITAMask {
    Lm86TypeConfigurationRemoteTCritMask get ();
    void set (Lm86TypeConfigurationRemoteTCritMask value);
}
member ConfigurationRemoteTCRITAMask : Lm86TypeConfigurationRemoteTCritMask with get, set

Property Value

Type: Lm86TypeConfigurationRemoteTCritMask
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.ConfigurationRUNSTOP Property

IRD

Lm86ConfigurationRUNSTOP Property

Configuration: RUN/STOP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm86TypeConfigurationRunStop ConfigurationRUNSTOP { get; set; }
Public Property ConfigurationRUNSTOP As Lm86TypeConfigurationRunStop
    Get
    Set
public:
property Lm86TypeConfigurationRunStop ConfigurationRUNSTOP {
    Lm86TypeConfigurationRunStop get ();
    void set (Lm86TypeConfigurationRunStop value);
}
member ConfigurationRUNSTOP : Lm86TypeConfigurationRunStop with get, set

Property Value

Type: Lm86TypeConfigurationRunStop
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.ConversionRate Property

IRD

Lm86ConversionRate Property

Conversion Rate

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm86TypeConversionRate ConversionRate { get; set; }
Public Property ConversionRate As Lm86TypeConversionRate
    Get
    Set
public:
property Lm86TypeConversionRate ConversionRate {
    Lm86TypeConversionRate get ();
    void set (Lm86TypeConversionRate value);
}
member ConversionRate : Lm86TypeConversionRate with get, set

Property Value

Type: Lm86TypeConversionRate
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.FilterLevel Property

IRD

Lm86FilterLevel Property

Filter Level

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm86TypeFilterLevel FilterLevel { get; set; }
Public Property FilterLevel As Lm86TypeFilterLevel
    Get
    Set
public:
property Lm86TypeFilterLevel FilterLevel {
    Lm86TypeFilterLevel get ();
    void set (Lm86TypeFilterLevel value);
}
member FilterLevel : Lm86TypeFilterLevel with get, set

Property Value

Type: Lm86TypeFilterLevel
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.LocalHIGHSetpoint Property

IRD

Lm86LocalHIGHSetpoint Property

Local HIGH Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalHIGHSetpoint { get; set; }
Public Property LocalHIGHSetpoint As SByte
    Get
    Set
public:
property signed char LocalHIGHSetpoint {
    signed char get ();
    void set (signed char value);
}
member LocalHIGHSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.LocalLOWSetpoint Property

IRD

Lm86LocalLOWSetpoint Property

Local LOW Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalLOWSetpoint { get; set; }
Public Property LocalLOWSetpoint As SByte
    Get
    Set
public:
property signed char LocalLOWSetpoint {
    signed char get ();
    void set (signed char value);
}
member LocalLOWSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.LocalTCRITSetpoint Property

IRD

Lm86LocalTCRITSetpoint Property

Local T_CRIT Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTCRITSetpoint { get; set; }
Public Property LocalTCRITSetpoint As SByte
    Get
    Set
public:
property signed char LocalTCRITSetpoint {
    signed char get ();
    void set (signed char value);
}
member LocalTCRITSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.LocalTemperature Property

IRD

Lm86LocalTemperature Property

Local Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTemperature { get; }
Public ReadOnly Property LocalTemperature As SByte
    Get
public:
property signed char LocalTemperature {
    signed char get ();
}
member LocalTemperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.ManufacturerSID Property

IRD

Lm86ManufacturerSID Property

Manufacturer's ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerSID { get; }
Public ReadOnly Property ManufacturerSID As Byte
    Get
public:
property unsigned char ManufacturerSID {
    unsigned char get ();
}
member ManufacturerSID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.RemoteHIGHSetpoint Property

IRD

Lm86RemoteHIGHSetpoint Property

Remote HIGH Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteHIGHSetpoint { get; set; }
Public Property RemoteHIGHSetpoint As Double
    Get
    Set
public:
property double RemoteHIGHSetpoint {
    double get ();
    void set (double value);
}
member RemoteHIGHSetpoint : float with get, set

Property Value

Type: Double
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.RemoteLOWSetpoint Property

IRD

Lm86RemoteLOWSetpoint Property

Remote LOW Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteLOWSetpoint { get; set; }
Public Property RemoteLOWSetpoint As Double
    Get
    Set
public:
property double RemoteLOWSetpoint {
    double get ();
    void set (double value);
}
member RemoteLOWSetpoint : float with get, set

Property Value

Type: Double
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.RemoteTCRITSetpoint Property

IRD

Lm86RemoteTCRITSetpoint Property

Remote T_CRIT Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTCRITSetpoint { get; set; }
Public Property RemoteTCRITSetpoint As SByte
    Get
    Set
public:
property signed char RemoteTCRITSetpoint {
    signed char get ();
    void set (signed char value);
}
member RemoteTCRITSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.RemoteTemperature Property

IRD

Lm86RemoteTemperature Property

Remote Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperature { get; }
Public ReadOnly Property RemoteTemperature As Double
    Get
public:
property double RemoteTemperature {
    double get ();
}
member RemoteTemperature : float with get

Property Value

Type: Double
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.RemoteTemperatureOffset Property

IRD

Lm86RemoteTemperatureOffset Property

Remote Temperature Offset (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperatureOffset { get; set; }
Public Property RemoteTemperatureOffset As Double
    Get
    Set
public:
property double RemoteTemperatureOffset {
    double get ();
    void set (double value);
}
member RemoteTemperatureOffset : float with get, set

Property Value

Type: Double
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.StatusBusy Property

IRD

Lm86StatusBusy Property

Status: Busy

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm86TypeStatusBusy StatusBusy { get; }
Public ReadOnly Property StatusBusy As Lm86TypeStatusBusy
    Get
public:
property Lm86TypeStatusBusy StatusBusy {
    Lm86TypeStatusBusy get ();
}
member StatusBusy : Lm86TypeStatusBusy with get

Property Value

Type: Lm86TypeStatusBusy
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.StatusLCRIT Property

IRD

Lm86StatusLCRIT Property

Status: LCRIT

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm86TypeStatusLcrit StatusLCRIT { get; }
Public ReadOnly Property StatusLCRIT As Lm86TypeStatusLcrit
    Get
public:
property Lm86TypeStatusLcrit StatusLCRIT {
    Lm86TypeStatusLcrit get ();
}
member StatusLCRIT : Lm86TypeStatusLcrit with get

Property Value

Type: Lm86TypeStatusLcrit
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.StatusLHIGH Property

IRD

Lm86StatusLHIGH Property

Status: LHIGH

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm86TypeStatusLhigh StatusLHIGH { get; }
Public ReadOnly Property StatusLHIGH As Lm86TypeStatusLhigh
    Get
public:
property Lm86TypeStatusLhigh StatusLHIGH {
    Lm86TypeStatusLhigh get ();
}
member StatusLHIGH : Lm86TypeStatusLhigh with get

Property Value

Type: Lm86TypeStatusLhigh
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.StatusLLOW Property

IRD

Lm86StatusLLOW Property

Status: LLOW

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm86TypeStatusLlow StatusLLOW { get; }
Public ReadOnly Property StatusLLOW As Lm86TypeStatusLlow
    Get
public:
property Lm86TypeStatusLlow StatusLLOW {
    Lm86TypeStatusLlow get ();
}
member StatusLLOW : Lm86TypeStatusLlow with get

Property Value

Type: Lm86TypeStatusLlow
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.StatusOPEN Property

IRD

Lm86StatusOPEN Property

Status: OPEN

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm86TypeStatusOpen StatusOPEN { get; }
Public ReadOnly Property StatusOPEN As Lm86TypeStatusOpen
    Get
public:
property Lm86TypeStatusOpen StatusOPEN {
    Lm86TypeStatusOpen get ();
}
member StatusOPEN : Lm86TypeStatusOpen with get

Property Value

Type: Lm86TypeStatusOpen
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.StatusRCRIT Property

IRD

Lm86StatusRCRIT Property

Status: RCRIT

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm86TypeStatusRcrit StatusRCRIT { get; }
Public ReadOnly Property StatusRCRIT As Lm86TypeStatusRcrit
    Get
public:
property Lm86TypeStatusRcrit StatusRCRIT {
    Lm86TypeStatusRcrit get ();
}
member StatusRCRIT : Lm86TypeStatusRcrit with get

Property Value

Type: Lm86TypeStatusRcrit
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.StatusRHIGH Property

IRD

Lm86StatusRHIGH Property

Status: RHIGH

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm86TypeStatusRhigh StatusRHIGH { get; }
Public ReadOnly Property StatusRHIGH As Lm86TypeStatusRhigh
    Get
public:
property Lm86TypeStatusRhigh StatusRHIGH {
    Lm86TypeStatusRhigh get ();
}
member StatusRHIGH : Lm86TypeStatusRhigh with get

Property Value

Type: Lm86TypeStatusRhigh
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.StatusRLOW Property

IRD

Lm86StatusRLOW Property

Status: RLOW

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm86TypeStatusRlow StatusRLOW { get; }
Public ReadOnly Property StatusRLOW As Lm86TypeStatusRlow
    Get
public:
property Lm86TypeStatusRlow StatusRLOW {
    Lm86TypeStatusRlow get ();
}
member StatusRLOW : Lm86TypeStatusRlow with get

Property Value

Type: Lm86TypeStatusRlow
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.SteppingOrDieRevisionCode Property

IRD

Lm86SteppingOrDieRevisionCode Property

Stepping Or Die Revision Code

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SteppingOrDieRevisionCode { get; }
Public ReadOnly Property SteppingOrDieRevisionCode As Byte
    Get
public:
property unsigned char SteppingOrDieRevisionCode {
    unsigned char get ();
}
member SteppingOrDieRevisionCode : byte with get

Property Value

Type: Byte
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.TCRITHysteresis Property

IRD

Lm86TCRITHysteresis Property

T_CRIT Hysteresis (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TCRITHysteresis { get; set; }
Public Property TCRITHysteresis As Byte
    Get
    Set
public:
property unsigned char TCRITHysteresis {
    unsigned char get ();
    void set (unsigned char value);
}
member TCRITHysteresis : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86 Methods

The Lm86 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.Flush Method

IRD

Lm86Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.OneShot Method

IRD

Lm86OneShot Method

One Shot

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void OneShot()
Public Sub OneShot
public:
void OneShot()
member OneShot : unit -> unit
See Also

Reference

Lm86 Class
telos.Ird.NationalSemiconductor Namespace


Lm86.TypeAlertConfigure Enumeration

IRD

Lm86TypeAlertConfigure Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlertConfigure
Public Enumeration TypeAlertConfigure
public enum class TypeAlertConfigure
type TypeAlertConfigure
Members
Member name | Value | Description
ComparatorModeDisabled | 0 | Comparator Mode: Disabled
ComparatorModeEnabled | 1 | Comparator Mode: Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm86.TypeConfigurationAlertMask Enumeration

IRD

Lm86TypeConfigurationAlertMask Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationAlertMask
Public Enumeration TypeConfigurationAlertMask
public enum class TypeConfigurationAlertMask
type TypeConfigurationAlertMask
Members
Member name | Value | Description
ALERTInterruptsNotMasked | 0 | ALERT Interrupts: Not Masked
ALERTInterruptsMasked | 1 | ALERT Interrupts: Masked
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm86.TypeConfigurationFaultQueue Enumeration

IRD

Lm86TypeConfigurationFaultQueue Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationFaultQueue
Public Enumeration TypeConfigurationFaultQueue
public enum class TypeConfigurationFaultQueue
type TypeConfigurationFaultQueue
Members
Member name | Value | Description
OutsideLimitDoNoTrigger | 0 | Outside Limit: Do No Trigger
OutsideLimitTrigger | 1 | Outside Limit: Trigger
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm86.TypeConfigurationLocalTCritMask Enumeration

IRD

Lm86TypeConfigurationLocalTCritMask Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationLocalTCritMask
Public Enumeration TypeConfigurationLocalTCritMask
public enum class TypeConfigurationLocalTCritMask
type TypeConfigurationLocalTCritMask
Members
Member name | Value | Description
TCRITADoNotTrigger | 0 | T_CRIT_A: Do Not Trigger
TCRITATrigger | 1 | T_CRIT_A: Trigger
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm86.TypeConfigurationRemoteTCritMask Enumeration

IRD

Lm86TypeConfigurationRemoteTCritMask Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationRemoteTCritMask
Public Enumeration TypeConfigurationRemoteTCritMask
public enum class TypeConfigurationRemoteTCritMask
type TypeConfigurationRemoteTCritMask
Members
Member name | Value | Description
TCRITADoNotTrigger | 0 | T_CRIT_A: Do Not Trigger
TCRITATrigger | 1 | T_CRIT_A: Trigger
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm86.TypeConfigurationRunStop Enumeration

IRD

Lm86TypeConfigurationRunStop Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationRunStop
Public Enumeration TypeConfigurationRunStop
public enum class TypeConfigurationRunStop
type TypeConfigurationRunStop
Members
Member name | Value | Description
Running | 0 | Running
Shutdown | 1 | Shutdown
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm86.TypeConversionRate Enumeration

IRD

Lm86TypeConversionRate Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConversionRate
Public Enumeration TypeConversionRate
public enum class TypeConversionRate
type TypeConversionRate
Members
Member name | Value | Description
Value_625MHz | 0 | 62.5 mHz
Value_125MHz | 1 | 125 mHz
Value_250MHz | 2 | 250 mHz
Value_500MHz | 3 | 500 mHz
Value_1Hz | 4 | 1 Hz
Value_2Hz | 5 | 2 Hz
Value_4Hz | 6 | 4 Hz
Value_8Hz | 7 | 8 Hz
Value_16Hz | 8 | 16 Hz
Value_32Hz | 9 | 32 Hz
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm86.TypeFilterLevel Enumeration

IRD

Lm86TypeFilterLevel Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFilterLevel
Public Enumeration TypeFilterLevel
public enum class TypeFilterLevel
type TypeFilterLevel
Members
Member name | Value | Description
NoFilter | 0 | No Filter
Level1 | 1 | Level 1
Level2 | 2 | Level 2
Level3 | 3 | Level 3
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm86.TypeStatusBusy Enumeration

IRD

Lm86TypeStatusBusy Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusBusy
Public Enumeration TypeStatusBusy
public enum class TypeStatusBusy
type TypeStatusBusy
Members
Member name | Value | Description
ADCNotBusy | 0 | ADC: Not Busy
ADCBusy | 1 | ADC: Busy
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm86.TypeStatusLcrit Enumeration

IRD

Lm86TypeStatusLcrit Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusLcrit
Public Enumeration TypeStatusLcrit
public enum class TypeStatusLcrit
type TypeStatusLcrit
Members
Member name | Value | Description
LocalCriticalTemperatureNoAlarm | 0 | Local Critical Temperature: No Alarm
LocalCriticalTemperatureAlarm | 1 | Local Critical Temperature: Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm86.TypeStatusLhigh Enumeration

IRD

Lm86TypeStatusLhigh Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusLhigh
Public Enumeration TypeStatusLhigh
public enum class TypeStatusLhigh
type TypeStatusLhigh
Members
Member name | Value | Description
LocalHIGHTemperatureNoAlarm | 0 | Local HIGH Temperature: No Alarm
LocalHIGHTemperatureAlarm | 1 | Local HIGH Temperature: Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm86.TypeStatusLlow Enumeration

IRD

Lm86TypeStatusLlow Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusLlow
Public Enumeration TypeStatusLlow
public enum class TypeStatusLlow
type TypeStatusLlow
Members
Member name | Value | Description
LocalLOWTemperatureNoAlarm | 0 | Local LOW Temperature: No Alarm
LocalLOWTemperatureAlarm | 1 | Local LOW Temperature: Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm86.TypeStatusOpen Enumeration

IRD

Lm86TypeStatusOpen Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusOpen
Public Enumeration TypeStatusOpen
public enum class TypeStatusOpen
type TypeStatusOpen
Members
Member name | Value | Description
RemoteDiodeConnected | 0 | Remote Diode: Connected
RemoteDiodeDisconnected | 1 | Remote Diode: Disconnected
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm86.TypeStatusRcrit Enumeration

IRD

Lm86TypeStatusRcrit Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusRcrit
Public Enumeration TypeStatusRcrit
public enum class TypeStatusRcrit
type TypeStatusRcrit
Members
Member name | Value | Description
RemoteDiodeCriticalTemperatureNoAlarm | 0 | Remote Diode Critical Temperature: No Alarm
RemoteDiodeCriticalTemperatureAlarm | 1 | Remote Diode Critical Temperature: Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm86.TypeStatusRhigh Enumeration

IRD

Lm86TypeStatusRhigh Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusRhigh
Public Enumeration TypeStatusRhigh
public enum class TypeStatusRhigh
type TypeStatusRhigh
Members
Member name | Value | Description
RemoteDiodeHighTemperatureNoAlarm | 0 | Remote Diode High Temperature: No Alarm
RemoteDiodeHighTemperatureAlarm | 1 | Remote Diode High Temperature: Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm86.TypeStatusRlow Enumeration

IRD

Lm86TypeStatusRlow Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusRlow
Public Enumeration TypeStatusRlow
public enum class TypeStatusRlow
type TypeStatusRlow
Members
Member name | Value | Description
RemoteDiodeLOWTemperatureNoAlarm | 0 | Remote Diode LOW Temperature: No Alarm
RemoteDiodeLOWTemperatureAlarm | 1 | Remote Diode LOW Temperature: Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87 Class

National Semiconductor: LM 87
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm87

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm87
Public Class Lm87
public ref class Lm87
type Lm87 =  class end

The Lm87 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm87 | Constructor
Top
Properties
 | Name | Description
Public property | AIN1LowLimit | AIN1 Low Limit (unit: V)
Public property | AIN2LowLimit | AIN2 Low Limit (unit: V)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelMode25VVCCP2D2 | Channel Mode: 2.5V, V_CCP2/D2
Public property | ChannelModeFAN1AIN1 | Channel Mode: FAN1/AIN1
Public property | ChannelModeFAN2AIN2 | Channel Mode: FAN2/AIN2
Public property | ChannelModeIntVCCRange | Channel Mode: Int. V_CC Range
Public property | ChannelModeIRQ0EN | Channel Mode: IRQ0 EN
Public property | ChannelModeIRQ1EN | Channel Mode: IRQ1 EN
Public property | ChannelModeIRQ2EN | Channel Mode: IRQ2 EN
Public property | ChannelModeVIDIRQ | Channel Mode: VID/IRQ
Public property | CIClear | CI Clear
Public property | CompanyIdentification | Company Identification
Public property | ConfigurationINITIALIZATION | Configuration: INITIALIZATION
Public property | ConfigurationINTClear | Configuration: INT# Clear
Public property | ConfigurationINTEnable | Configuration: INT# Enable
Public property | ConfigurationIRQ3Enable | Configuration: IRQ3 Enable
Public property | ConfigurationIRQ4Enable | Configuration: IRQ4 Enable
Public property | ConfigurationLocalTempRegisterWriteOnce | Configuration: Local Temp. Register Write Once
Public property | ConfigurationRemoteTempRegisterWriteOnce | Configuration: Remote Temp. Register Write Once
Public property | ConfigurationRESET | Configuration: RESET#
Public property | ConfigurationStart | Configuration: Start
Public property | ConfigurationThermalINTMask | Configuration: Thermal INT# Mask
Public property | ConfigurationTHERMClear | Configuration: THERM# Clear
Public property | ConfigurationTHERMEnable | Configuration: THERM# Enable
Public property | ConfigurationTHERMInterruptMode | Configuration: THERM# Interrupt Mode
Public property | DACData | DAC Data (unit: V)
Public property | ExternalTemperature1 | External Temperature 1 (unit: °C)
Public property | ExternalTemperature1HighLimit | External Temperature 1 High Limit (unit: °C)
Public property | ExternalTemperature1LowLimit | External Temperature 1 Low Limit (unit: °C)
Public property | ExternalTempHardwareHighLimit0x14 | External Temp. Hardware High Limit [0x14] (unit: °C)
Public property | ExternalTempHardwareHighLimit0x18 | External Temp. Hardware High Limit [0x18] (unit: °C)
Public property | FAN1AIN1 | FAN1/AIN1 (unit: V)
Public property | FAN1CountLimitAIN1HighLimit | FAN1 Count Limit/AIN1 High Limit (unit: V)
Public property | FAN1RPMControl | FAN1 RPM Control
Public property | FAN2AIN2 | FAN2/AIN2 (unit: V)
Public property | FAN2CountLimitAIN2HighLimit | FAN2 Count Limit/AIN2 High Limit (unit: V)
Public property | FAN2RPMControl | FAN2 RPM Control
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | InternalTemperatureHighLimit | Internal Temperature High Limit (unit: °C)
Public property | InternalTemperatureLowLimit | Internal Temperature Low Limit (unit: °C)
Public property | InternalTempHardwareHighLimit0x13 | Internal Temp. Hardware High Limit [0x13] (unit: °C)
Public property | InternalTempHardwareHighLimit0x17 | Internal Temp. Hardware High Limit [0x17] (unit: °C)
Public property | InterruptMask12Vin | Interrupt Mask: +12Vin
Public property | InterruptMask25VinD2 | Interrupt Mask: +2.5Vin/D2+
Public property | InterruptMask5Vin | Interrupt Mask: +5Vin
Public property | InterruptMaskChassisIntrusion | Interrupt Mask: Chassis Intrusion
Public property | InterruptMaskD1Fault | Interrupt Mask: D1 Fault
Public property | InterruptMaskD2Fault | Interrupt Mask: D2 Fault
Public property | InterruptMaskExtTemp | Interrupt Mask: Ext. Temp
Public property | InterruptMaskFAN1AIN1 | Interrupt Mask: FAN1/AIN1
Public property | InterruptMaskFAN2AIN2 | Interrupt Mask: FAN2/AIN2
Public property | InterruptMaskIntTemp | Interrupt Mask: Int. Temp
Public property | InterruptMaskTHERM | Interrupt Mask: THERM#
Public property | InterruptMaskVCC | Interrupt Mask: V_CC
Public property | InterruptMaskVCCP1 | Interrupt Mask: V_CCP1
Public property | InterruptMaskVCCP2 | Interrupt Mask: V_CCP2
Public property | InterruptStatus12Vin | Interrupt Status: +12Vin
Public property | InterruptStatus25Vin | Interrupt Status: +2.5Vin
Public property | InterruptStatus5Vin | Interrupt Status: +5Vin
Public property | InterruptStatusCI | Interrupt Status: CI
Public property | InterruptStatusD1Fault | Interrupt Status: D1 Fault
Public property | InterruptStatusD2Fault | Interrupt Status: D2 Fault
Public property | InterruptStatusExtTemp | Interrupt Status: Ext. Temp.
Public property | InterruptStatusFAN1AIN1 | Interrupt Status: FAN1/AIN1
Public property | InterruptStatusFAN2AIN2 | Interrupt Status: FAN2/AIN2
Public property | InterruptStatusIntTemp | Interrupt Status: Int. Temp.
Public property | InterruptStatusMirror12Vin | Interrupt Status Mirror: +12Vin
Public property | InterruptStatusMirror25Vin | Interrupt Status Mirror: +2.5Vin
Public property | InterruptStatusMirror5Vin | Interrupt Status Mirror: +5Vin
Public property | InterruptStatusMirrorCI | Interrupt Status Mirror: CI
Public property | InterruptStatusMirrorD1Fault | Interrupt Status Mirror: D1 Fault
Public property | InterruptStatusMirrorD2Fault | Interrupt Status Mirror: D2 Fault
Public property | InterruptStatusMirrorExtTemp | Interrupt Status Mirror: Ext. Temp
Public property | InterruptStatusMirrorFAN1AIN1 | Interrupt Status Mirror: FAN1/AIN1
Public property | InterruptStatusMirrorFAN2AIN2 | Interrupt Status Mirror: FAN2/AIN2
Public property | InterruptStatusMirrorIntTemp | Interrupt Status Mirror: Int. Temp.
Public property | InterruptStatusMirrorTHERM | Interrupt Status Mirror: THERM#
Public property | InterruptStatusMirrorVCC | Interrupt Status Mirror: V_CC
Public property | InterruptStatusMirrorVCCP1 | Interrupt Status Mirror: V_CCP1
Public property | InterruptStatusMirrorVCCP2 | Interrupt Status Mirror: V_CCP2
Public property | InterruptStatusTHERM | Interrupt Status: THERM#
Public property | InterruptStatusVCC | Interrupt Status: V_CC
Public property | InterruptStatusVCCP1 | Interrupt Status: V_CCP1
Public property | InterruptStatusVCCP2 | Interrupt Status: V_CCP2
Public property | Property_12V | +12V (unit: V)
Public property | Property_12VHighLimit | +12V High Limit (unit: V)
Public property | Property_12VLowLimit | +12V Low Limit (unit: V)
Public property | Property_25VExternalTemperature2 | +2.5V/External Temperature 2 (unit: V)
Public property | Property_25VHighLimitExternalTemperature2HighLimit | +2.5V High Limit/External Temperature 2 High Limit (unit: V)
Public property | Property_25VHighLimitExternalTemperature2LowLimit | +2.5V High Limit/External Temperature 2 Low Limit (unit: V)
Public property | Property_33VHighLimit | +3.3V High Limit (unit: V)
Public property | Property_33VLowLimit | +3.3V Low Limit (unit: V)
Public property | Property_5V | +5V (unit: V)
Public property | Property_5VHighLimit | +5V High Limit (unit: V)
Public property | Property_5VLowLimit | +5V Low Limit (unit: V)
Public property | Revision | Revision
Public property | Shutdown | Shutdown
Public property | SMBALERTEnable | SMBALERT# Enable
Public property | VCC | +V_CC (unit: V)
Public property | VCCP1 | V_CCP1 (unit: V)
Public property | VCCP1HighLimit | V_CCP1 High Limit (unit: V)
Public property | VCCP1LowLimit | V_CCP1 Low Limit (unit: V)
Public property | VCCP2 | V_CCP2 (unit: V)
Public property | VCCP2HighLimit | V_CCP2 High Limit (unit: V)
Public property | VCCP2LowLimit | V_CCP2 Low Limit (unit: V)
Public property | VID | VID
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Serial Interface System Hardware Monitor with Remote Diode Temperature Sensing
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm87(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm87

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87 Properties

The Lm87 type exposes the following members.

Properties
 | Name | Description
Public property | AIN1LowLimit | AIN1 Low Limit (unit: V)
Public property | AIN2LowLimit | AIN2 Low Limit (unit: V)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelMode25VVCCP2D2 | Channel Mode: 2.5V, V_CCP2/D2
Public property | ChannelModeFAN1AIN1 | Channel Mode: FAN1/AIN1
Public property | ChannelModeFAN2AIN2 | Channel Mode: FAN2/AIN2
Public property | ChannelModeIntVCCRange | Channel Mode: Int. V_CC Range
Public property | ChannelModeIRQ0EN | Channel Mode: IRQ0 EN
Public property | ChannelModeIRQ1EN | Channel Mode: IRQ1 EN
Public property | ChannelModeIRQ2EN | Channel Mode: IRQ2 EN
Public property | ChannelModeVIDIRQ | Channel Mode: VID/IRQ
Public property | CIClear | CI Clear
Public property | CompanyIdentification | Company Identification
Public property | ConfigurationINITIALIZATION | Configuration: INITIALIZATION
Public property | ConfigurationINTClear | Configuration: INT# Clear
Public property | ConfigurationINTEnable | Configuration: INT# Enable
Public property | ConfigurationIRQ3Enable | Configuration: IRQ3 Enable
Public property | ConfigurationIRQ4Enable | Configuration: IRQ4 Enable
Public property | ConfigurationLocalTempRegisterWriteOnce | Configuration: Local Temp. Register Write Once
Public property | ConfigurationRemoteTempRegisterWriteOnce | Configuration: Remote Temp. Register Write Once
Public property | ConfigurationRESET | Configuration: RESET#
Public property | ConfigurationStart | Configuration: Start
Public property | ConfigurationThermalINTMask | Configuration: Thermal INT# Mask
Public property | ConfigurationTHERMClear | Configuration: THERM# Clear
Public property | ConfigurationTHERMEnable | Configuration: THERM# Enable
Public property | ConfigurationTHERMInterruptMode | Configuration: THERM# Interrupt Mode
Public property | DACData | DAC Data (unit: V)
Public property | ExternalTemperature1 | External Temperature 1 (unit: °C)
Public property | ExternalTemperature1HighLimit | External Temperature 1 High Limit (unit: °C)
Public property | ExternalTemperature1LowLimit | External Temperature 1 Low Limit (unit: °C)
Public property | ExternalTempHardwareHighLimit0x14 | External Temp. Hardware High Limit [0x14] (unit: °C)
Public property | ExternalTempHardwareHighLimit0x18 | External Temp. Hardware High Limit [0x18] (unit: °C)
Public property | FAN1AIN1 | FAN1/AIN1 (unit: V)
Public property | FAN1CountLimitAIN1HighLimit | FAN1 Count Limit/AIN1 High Limit (unit: V)
Public property | FAN1RPMControl | FAN1 RPM Control
Public property | FAN2AIN2 | FAN2/AIN2 (unit: V)
Public property | FAN2CountLimitAIN2HighLimit | FAN2 Count Limit/AIN2 High Limit (unit: V)
Public property | FAN2RPMControl | FAN2 RPM Control
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | InternalTemperatureHighLimit | Internal Temperature High Limit (unit: °C)
Public property | InternalTemperatureLowLimit | Internal Temperature Low Limit (unit: °C)
Public property | InternalTempHardwareHighLimit0x13 | Internal Temp. Hardware High Limit [0x13] (unit: °C)
Public property | InternalTempHardwareHighLimit0x17 | Internal Temp. Hardware High Limit [0x17] (unit: °C)
Public property | InterruptMask12Vin | Interrupt Mask: +12Vin
Public property | InterruptMask25VinD2 | Interrupt Mask: +2.5Vin/D2+
Public property | InterruptMask5Vin | Interrupt Mask: +5Vin
Public property | InterruptMaskChassisIntrusion | Interrupt Mask: Chassis Intrusion
Public property | InterruptMaskD1Fault | Interrupt Mask: D1 Fault
Public property | InterruptMaskD2Fault | Interrupt Mask: D2 Fault
Public property | InterruptMaskExtTemp | Interrupt Mask: Ext. Temp
Public property | InterruptMaskFAN1AIN1 | Interrupt Mask: FAN1/AIN1
Public property | InterruptMaskFAN2AIN2 | Interrupt Mask: FAN2/AIN2
Public property | InterruptMaskIntTemp | Interrupt Mask: Int. Temp
Public property | InterruptMaskTHERM | Interrupt Mask: THERM#
Public property | InterruptMaskVCC | Interrupt Mask: V_CC
Public property | InterruptMaskVCCP1 | Interrupt Mask: V_CCP1
Public property | InterruptMaskVCCP2 | Interrupt Mask: V_CCP2
Public property | InterruptStatus12Vin | Interrupt Status: +12Vin
Public property | InterruptStatus25Vin | Interrupt Status: +2.5Vin
Public property | InterruptStatus5Vin | Interrupt Status: +5Vin
Public property | InterruptStatusCI | Interrupt Status: CI
Public property | InterruptStatusD1Fault | Interrupt Status: D1 Fault
Public property | InterruptStatusD2Fault | Interrupt Status: D2 Fault
Public property | InterruptStatusExtTemp | Interrupt Status: Ext. Temp.
Public property | InterruptStatusFAN1AIN1 | Interrupt Status: FAN1/AIN1
Public property | InterruptStatusFAN2AIN2 | Interrupt Status: FAN2/AIN2
Public property | InterruptStatusIntTemp | Interrupt Status: Int. Temp.
Public property | InterruptStatusMirror12Vin | Interrupt Status Mirror: +12Vin
Public property | InterruptStatusMirror25Vin | Interrupt Status Mirror: +2.5Vin
Public property | InterruptStatusMirror5Vin | Interrupt Status Mirror: +5Vin
Public property | InterruptStatusMirrorCI | Interrupt Status Mirror: CI
Public property | InterruptStatusMirrorD1Fault | Interrupt Status Mirror: D1 Fault
Public property | InterruptStatusMirrorD2Fault | Interrupt Status Mirror: D2 Fault
Public property | InterruptStatusMirrorExtTemp | Interrupt Status Mirror: Ext. Temp
Public property | InterruptStatusMirrorFAN1AIN1 | Interrupt Status Mirror: FAN1/AIN1
Public property | InterruptStatusMirrorFAN2AIN2 | Interrupt Status Mirror: FAN2/AIN2
Public property | InterruptStatusMirrorIntTemp | Interrupt Status Mirror: Int. Temp.
Public property | InterruptStatusMirrorTHERM | Interrupt Status Mirror: THERM#
Public property | InterruptStatusMirrorVCC | Interrupt Status Mirror: V_CC
Public property | InterruptStatusMirrorVCCP1 | Interrupt Status Mirror: V_CCP1
Public property | InterruptStatusMirrorVCCP2 | Interrupt Status Mirror: V_CCP2
Public property | InterruptStatusTHERM | Interrupt Status: THERM#
Public property | InterruptStatusVCC | Interrupt Status: V_CC
Public property | InterruptStatusVCCP1 | Interrupt Status: V_CCP1
Public property | InterruptStatusVCCP2 | Interrupt Status: V_CCP2
Public property | Property_12V | +12V (unit: V)
Public property | Property_12VHighLimit | +12V High Limit (unit: V)
Public property | Property_12VLowLimit | +12V Low Limit (unit: V)
Public property | Property_25VExternalTemperature2 | +2.5V/External Temperature 2 (unit: V)
Public property | Property_25VHighLimitExternalTemperature2HighLimit | +2.5V High Limit/External Temperature 2 High Limit (unit: V)
Public property | Property_25VHighLimitExternalTemperature2LowLimit | +2.5V High Limit/External Temperature 2 Low Limit (unit: V)
Public property | Property_33VHighLimit | +3.3V High Limit (unit: V)
Public property | Property_33VLowLimit | +3.3V Low Limit (unit: V)
Public property | Property_5V | +5V (unit: V)
Public property | Property_5VHighLimit | +5V High Limit (unit: V)
Public property | Property_5VLowLimit | +5V Low Limit (unit: V)
Public property | Revision | Revision
Public property | Shutdown | Shutdown
Public property | SMBALERTEnable | SMBALERT# Enable
Public property | VCC | +V_CC (unit: V)
Public property | VCCP1 | V_CCP1 (unit: V)
Public property | VCCP1HighLimit | V_CCP1 High Limit (unit: V)
Public property | VCCP1LowLimit | V_CCP1 Low Limit (unit: V)
Public property | VCCP2 | V_CCP2 (unit: V)
Public property | VCCP2HighLimit | V_CCP2 High Limit (unit: V)
Public property | VCCP2LowLimit | V_CCP2 Low Limit (unit: V)
Public property | VID | VID
Top
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.AIN1LowLimit Property

IRD

Lm87AIN1LowLimit Property

AIN1 Low Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AIN1LowLimit { get; set; }
Public Property AIN1LowLimit As Double
    Get
    Set
public:
property double AIN1LowLimit {
    double get ();
    void set (double value);
}
member AIN1LowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.AIN2LowLimit Property

IRD

Lm87AIN2LowLimit Property

AIN2 Low Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AIN2LowLimit { get; set; }
Public Property AIN2LowLimit As Double
    Get
    Set
public:
property double AIN2LowLimit {
    double get ();
    void set (double value);
}
member AIN2LowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.AutoFlush Property

IRD

Lm87AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ChannelMode25VVCCP2D2 Property

IRD

Lm87ChannelMode25VVCCP2D2 Property

Channel Mode: 2.5V, V_CCP2/D2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeChannelMode25vVccp2D2 ChannelMode25VVCCP2D2 { get; set; }
Public Property ChannelMode25VVCCP2D2 As Lm87TypeChannelMode25vVccp2D2
    Get
    Set
public:
property Lm87TypeChannelMode25vVccp2D2 ChannelMode25VVCCP2D2 {
    Lm87TypeChannelMode25vVccp2D2 get ();
    void set (Lm87TypeChannelMode25vVccp2D2 value);
}
member ChannelMode25VVCCP2D2 : Lm87TypeChannelMode25vVccp2D2 with get, set

Property Value

Type: Lm87TypeChannelMode25vVccp2D2
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ChannelModeFAN1AIN1 Property

IRD

Lm87ChannelModeFAN1AIN1 Property

Channel Mode: FAN1/AIN1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeChannelModeFanAin ChannelModeFAN1AIN1 { get; set; }
Public Property ChannelModeFAN1AIN1 As Lm87TypeChannelModeFanAin
    Get
    Set
public:
property Lm87TypeChannelModeFanAin ChannelModeFAN1AIN1 {
    Lm87TypeChannelModeFanAin get ();
    void set (Lm87TypeChannelModeFanAin value);
}
member ChannelModeFAN1AIN1 : Lm87TypeChannelModeFanAin with get, set

Property Value

Type: Lm87TypeChannelModeFanAin
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ChannelModeFAN2AIN2 Property

IRD

Lm87ChannelModeFAN2AIN2 Property

Channel Mode: FAN2/AIN2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeChannelModeFanAin ChannelModeFAN2AIN2 { get; set; }
Public Property ChannelModeFAN2AIN2 As Lm87TypeChannelModeFanAin
    Get
    Set
public:
property Lm87TypeChannelModeFanAin ChannelModeFAN2AIN2 {
    Lm87TypeChannelModeFanAin get ();
    void set (Lm87TypeChannelModeFanAin value);
}
member ChannelModeFAN2AIN2 : Lm87TypeChannelModeFanAin with get, set

Property Value

Type: Lm87TypeChannelModeFanAin
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ChannelModeIntVCCRange Property

IRD

Lm87ChannelModeIntVCCRange Property

Channel Mode: Int. V_CC Range

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeChannelModeIntVccRange ChannelModeIntVCCRange { get; set; }
Public Property ChannelModeIntVCCRange As Lm87TypeChannelModeIntVccRange
    Get
    Set
public:
property Lm87TypeChannelModeIntVccRange ChannelModeIntVCCRange {
    Lm87TypeChannelModeIntVccRange get ();
    void set (Lm87TypeChannelModeIntVccRange value);
}
member ChannelModeIntVCCRange : Lm87TypeChannelModeIntVccRange with get, set

Property Value

Type: Lm87TypeChannelModeIntVccRange
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ChannelModeIRQ0EN Property

IRD

Lm87ChannelModeIRQ0EN Property

Channel Mode: IRQ0 EN

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ChannelModeIRQ0EN { get; set; }
Public Property ChannelModeIRQ0EN As Byte
    Get
    Set
public:
property unsigned char ChannelModeIRQ0EN {
    unsigned char get ();
    void set (unsigned char value);
}
member ChannelModeIRQ0EN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ChannelModeIRQ1EN Property

IRD

Lm87ChannelModeIRQ1EN Property

Channel Mode: IRQ1 EN

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ChannelModeIRQ1EN { get; set; }
Public Property ChannelModeIRQ1EN As Byte
    Get
    Set
public:
property unsigned char ChannelModeIRQ1EN {
    unsigned char get ();
    void set (unsigned char value);
}
member ChannelModeIRQ1EN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ChannelModeIRQ2EN Property

IRD

Lm87ChannelModeIRQ2EN Property

Channel Mode: IRQ2 EN

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ChannelModeIRQ2EN { get; set; }
Public Property ChannelModeIRQ2EN As Byte
    Get
    Set
public:
property unsigned char ChannelModeIRQ2EN {
    unsigned char get ();
    void set (unsigned char value);
}
member ChannelModeIRQ2EN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ChannelModeVIDIRQ Property

IRD

Lm87ChannelModeVIDIRQ Property

Channel Mode: VID/IRQ

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeChannelVidIrq ChannelModeVIDIRQ { get; set; }
Public Property ChannelModeVIDIRQ As Lm87TypeChannelVidIrq
    Get
    Set
public:
property Lm87TypeChannelVidIrq ChannelModeVIDIRQ {
    Lm87TypeChannelVidIrq get ();
    void set (Lm87TypeChannelVidIrq value);
}
member ChannelModeVIDIRQ : Lm87TypeChannelVidIrq with get, set

Property Value

Type: Lm87TypeChannelVidIrq
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.CIClear Property

IRD

Lm87CIClear Property

CI Clear

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeCiClear CIClear { get; set; }
Public Property CIClear As Lm87TypeCiClear
    Get
    Set
public:
property Lm87TypeCiClear CIClear {
    Lm87TypeCiClear get ();
    void set (Lm87TypeCiClear value);
}
member CIClear : Lm87TypeCiClear with get, set

Property Value

Type: Lm87TypeCiClear
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.CompanyIdentification Property

IRD

Lm87CompanyIdentification Property

Company Identification

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CompanyIdentification { get; }
Public ReadOnly Property CompanyIdentification As Byte
    Get
public:
property unsigned char CompanyIdentification {
    unsigned char get ();
}
member CompanyIdentification : byte with get

Property Value

Type: Byte
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ConfigurationINITIALIZATION Property

IRD

Lm87ConfigurationINITIALIZATION Property

Configuration: INITIALIZATION

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeConfigurationInitialization ConfigurationINITIALIZATION { get; set; }
Public Property ConfigurationINITIALIZATION As Lm87TypeConfigurationInitialization
    Get
    Set
public:
property Lm87TypeConfigurationInitialization ConfigurationINITIALIZATION {
    Lm87TypeConfigurationInitialization get ();
    void set (Lm87TypeConfigurationInitialization value);
}
member ConfigurationINITIALIZATION : Lm87TypeConfigurationInitialization with get, set

Property Value

Type: Lm87TypeConfigurationInitialization
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ConfigurationINTClear Property

IRD

Lm87ConfigurationINTClear Property

Configuration: INT# Clear

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeConfigurationClear ConfigurationINTClear { get; set; }
Public Property ConfigurationINTClear As Lm87TypeConfigurationClear
    Get
    Set
public:
property Lm87TypeConfigurationClear ConfigurationINTClear {
    Lm87TypeConfigurationClear get ();
    void set (Lm87TypeConfigurationClear value);
}
member ConfigurationINTClear : Lm87TypeConfigurationClear with get, set

Property Value

Type: Lm87TypeConfigurationClear
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ConfigurationINTEnable Property

IRD

Lm87ConfigurationINTEnable Property

Configuration: INT# Enable

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeConfigurationEnable ConfigurationINTEnable { get; set; }
Public Property ConfigurationINTEnable As Lm87TypeConfigurationEnable
    Get
    Set
public:
property Lm87TypeConfigurationEnable ConfigurationINTEnable {
    Lm87TypeConfigurationEnable get ();
    void set (Lm87TypeConfigurationEnable value);
}
member ConfigurationINTEnable : Lm87TypeConfigurationEnable with get, set

Property Value

Type: Lm87TypeConfigurationEnable
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ConfigurationIRQ3Enable Property

IRD

Lm87ConfigurationIRQ3Enable Property

Configuration: IRQ3 Enable

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeConfigurationEnable ConfigurationIRQ3Enable { get; set; }
Public Property ConfigurationIRQ3Enable As Lm87TypeConfigurationEnable
    Get
    Set
public:
property Lm87TypeConfigurationEnable ConfigurationIRQ3Enable {
    Lm87TypeConfigurationEnable get ();
    void set (Lm87TypeConfigurationEnable value);
}
member ConfigurationIRQ3Enable : Lm87TypeConfigurationEnable with get, set

Property Value

Type: Lm87TypeConfigurationEnable
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ConfigurationIRQ4Enable Property

IRD

Lm87ConfigurationIRQ4Enable Property

Configuration: IRQ4 Enable

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeConfigurationEnable ConfigurationIRQ4Enable { get; set; }
Public Property ConfigurationIRQ4Enable As Lm87TypeConfigurationEnable
    Get
    Set
public:
property Lm87TypeConfigurationEnable ConfigurationIRQ4Enable {
    Lm87TypeConfigurationEnable get ();
    void set (Lm87TypeConfigurationEnable value);
}
member ConfigurationIRQ4Enable : Lm87TypeConfigurationEnable with get, set

Property Value

Type: Lm87TypeConfigurationEnable
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ConfigurationLocalTempRegisterWriteOnce Property

IRD

Lm87ConfigurationLocalTempRegisterWriteOnce Property

Configuration: Local Temp. Register Write Once

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeConfigurationTempLock ConfigurationLocalTempRegisterWriteOnce { get; set; }
Public Property ConfigurationLocalTempRegisterWriteOnce As Lm87TypeConfigurationTempLock
    Get
    Set
public:
property Lm87TypeConfigurationTempLock ConfigurationLocalTempRegisterWriteOnce {
    Lm87TypeConfigurationTempLock get ();
    void set (Lm87TypeConfigurationTempLock value);
}
member ConfigurationLocalTempRegisterWriteOnce : Lm87TypeConfigurationTempLock with get, set

Property Value

Type: Lm87TypeConfigurationTempLock
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ConfigurationRemoteTempRegisterWriteOnce Property

IRD

Lm87ConfigurationRemoteTempRegisterWriteOnce Property

Configuration: Remote Temp. Register Write Once

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeConfigurationTempLock ConfigurationRemoteTempRegisterWriteOnce { get; set; }
Public Property ConfigurationRemoteTempRegisterWriteOnce As Lm87TypeConfigurationTempLock
    Get
    Set
public:
property Lm87TypeConfigurationTempLock ConfigurationRemoteTempRegisterWriteOnce {
    Lm87TypeConfigurationTempLock get ();
    void set (Lm87TypeConfigurationTempLock value);
}
member ConfigurationRemoteTempRegisterWriteOnce : Lm87TypeConfigurationTempLock with get, set

Property Value

Type: Lm87TypeConfigurationTempLock
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ConfigurationRESET Property

IRD

Lm87ConfigurationRESET Property

Configuration: RESET#

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeConfigurationReset ConfigurationRESET { get; set; }
Public Property ConfigurationRESET As Lm87TypeConfigurationReset
    Get
    Set
public:
property Lm87TypeConfigurationReset ConfigurationRESET {
    Lm87TypeConfigurationReset get ();
    void set (Lm87TypeConfigurationReset value);
}
member ConfigurationRESET : Lm87TypeConfigurationReset with get, set

Property Value

Type: Lm87TypeConfigurationReset
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ConfigurationStart Property

IRD

Lm87ConfigurationStart Property

Configuration: Start

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeConfigurationStart ConfigurationStart { get; set; }
Public Property ConfigurationStart As Lm87TypeConfigurationStart
    Get
    Set
public:
property Lm87TypeConfigurationStart ConfigurationStart {
    Lm87TypeConfigurationStart get ();
    void set (Lm87TypeConfigurationStart value);
}
member ConfigurationStart : Lm87TypeConfigurationStart with get, set

Property Value

Type: Lm87TypeConfigurationStart
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ConfigurationThermalINTMask Property

IRD

Lm87ConfigurationThermalINTMask Property

Configuration: Thermal INT# Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeConfigurationThermalIntMask ConfigurationThermalINTMask { get; set; }
Public Property ConfigurationThermalINTMask As Lm87TypeConfigurationThermalIntMask
    Get
    Set
public:
property Lm87TypeConfigurationThermalIntMask ConfigurationThermalINTMask {
    Lm87TypeConfigurationThermalIntMask get ();
    void set (Lm87TypeConfigurationThermalIntMask value);
}
member ConfigurationThermalINTMask : Lm87TypeConfigurationThermalIntMask with get, set

Property Value

Type: Lm87TypeConfigurationThermalIntMask
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ConfigurationTHERMClear Property

IRD

Lm87ConfigurationTHERMClear Property

Configuration: THERM# Clear

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeConfigurationClear ConfigurationTHERMClear { get; set; }
Public Property ConfigurationTHERMClear As Lm87TypeConfigurationClear
    Get
    Set
public:
property Lm87TypeConfigurationClear ConfigurationTHERMClear {
    Lm87TypeConfigurationClear get ();
    void set (Lm87TypeConfigurationClear value);
}
member ConfigurationTHERMClear : Lm87TypeConfigurationClear with get, set

Property Value

Type: Lm87TypeConfigurationClear
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ConfigurationTHERMEnable Property

IRD

Lm87ConfigurationTHERMEnable Property

Configuration: THERM# Enable

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeConfigurationEnable ConfigurationTHERMEnable { get; set; }
Public Property ConfigurationTHERMEnable As Lm87TypeConfigurationEnable
    Get
    Set
public:
property Lm87TypeConfigurationEnable ConfigurationTHERMEnable {
    Lm87TypeConfigurationEnable get ();
    void set (Lm87TypeConfigurationEnable value);
}
member ConfigurationTHERMEnable : Lm87TypeConfigurationEnable with get, set

Property Value

Type: Lm87TypeConfigurationEnable
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ConfigurationTHERMInterruptMode Property

IRD

Lm87ConfigurationTHERMInterruptMode Property

Configuration: THERM# Interrupt Mode

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeConfigurationThermInterruptMode ConfigurationTHERMInterruptMode { get; set; }
Public Property ConfigurationTHERMInterruptMode As Lm87TypeConfigurationThermInterruptMode
    Get
    Set
public:
property Lm87TypeConfigurationThermInterruptMode ConfigurationTHERMInterruptMode {
    Lm87TypeConfigurationThermInterruptMode get ();
    void set (Lm87TypeConfigurationThermInterruptMode value);
}
member ConfigurationTHERMInterruptMode : Lm87TypeConfigurationThermInterruptMode with get, set

Property Value

Type: Lm87TypeConfigurationThermInterruptMode
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.DACData Property

IRD

Lm87DACData Property

DAC Data (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DACData { get; set; }
Public Property DACData As Double
    Get
    Set
public:
property double DACData {
    double get ();
    void set (double value);
}
member DACData : float with get, set

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ExternalTemperature1 Property

IRD

Lm87ExternalTemperature1 Property

External Temperature 1 (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperature1 { get; }
Public ReadOnly Property ExternalTemperature1 As SByte
    Get
public:
property signed char ExternalTemperature1 {
    signed char get ();
}
member ExternalTemperature1 : sbyte with get

Property Value

Type: SByte
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ExternalTemperature1HighLimit Property

IRD

Lm87ExternalTemperature1HighLimit Property

External Temperature 1 High Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperature1HighLimit { get; set; }
Public Property ExternalTemperature1HighLimit As SByte
    Get
    Set
public:
property signed char ExternalTemperature1HighLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalTemperature1HighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ExternalTemperature1LowLimit Property

IRD

Lm87ExternalTemperature1LowLimit Property

External Temperature 1 Low Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperature1LowLimit { get; set; }
Public Property ExternalTemperature1LowLimit As SByte
    Get
    Set
public:
property signed char ExternalTemperature1LowLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalTemperature1LowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ExternalTempHardwareHighLimit0x14 Property

IRD

Lm87ExternalTempHardwareHighLimit0x14 Property

External Temp. Hardware High Limit [0x14] (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTempHardwareHighLimit0x14 { get; set; }
Public Property ExternalTempHardwareHighLimit0x14 As SByte
    Get
    Set
public:
property signed char ExternalTempHardwareHighLimit0x14 {
    signed char get ();
    void set (signed char value);
}
member ExternalTempHardwareHighLimit0x14 : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.ExternalTempHardwareHighLimit0x18 Property

IRD

Lm87ExternalTempHardwareHighLimit0x18 Property

External Temp. Hardware High Limit [0x18] (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTempHardwareHighLimit0x18 { get; set; }
Public Property ExternalTempHardwareHighLimit0x18 As SByte
    Get
    Set
public:
property signed char ExternalTempHardwareHighLimit0x18 {
    signed char get ();
    void set (signed char value);
}
member ExternalTempHardwareHighLimit0x18 : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.FAN1AIN1 Property

IRD

Lm87FAN1AIN1 Property

FAN1/AIN1 (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double FAN1AIN1 { get; }
Public ReadOnly Property FAN1AIN1 As Double
    Get
public:
property double FAN1AIN1 {
    double get ();
}
member FAN1AIN1 : float with get

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.FAN1CountLimitAIN1HighLimit Property

IRD

Lm87FAN1CountLimitAIN1HighLimit Property

FAN1 Count Limit/AIN1 High Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double FAN1CountLimitAIN1HighLimit { get; set; }
Public Property FAN1CountLimitAIN1HighLimit As Double
    Get
    Set
public:
property double FAN1CountLimitAIN1HighLimit {
    double get ();
    void set (double value);
}
member FAN1CountLimitAIN1HighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.FAN1RPMControl Property

IRD

Lm87FAN1RPMControl Property

FAN1 RPM Control

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeFanRpmControl FAN1RPMControl { get; set; }
Public Property FAN1RPMControl As Lm87TypeFanRpmControl
    Get
    Set
public:
property Lm87TypeFanRpmControl FAN1RPMControl {
    Lm87TypeFanRpmControl get ();
    void set (Lm87TypeFanRpmControl value);
}
member FAN1RPMControl : Lm87TypeFanRpmControl with get, set

Property Value

Type: Lm87TypeFanRpmControl
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.FAN2AIN2 Property

IRD

Lm87FAN2AIN2 Property

FAN2/AIN2 (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double FAN2AIN2 { get; }
Public ReadOnly Property FAN2AIN2 As Double
    Get
public:
property double FAN2AIN2 {
    double get ();
}
member FAN2AIN2 : float with get

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.FAN2CountLimitAIN2HighLimit Property

IRD

Lm87FAN2CountLimitAIN2HighLimit Property

FAN2 Count Limit/AIN2 High Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double FAN2CountLimitAIN2HighLimit { get; set; }
Public Property FAN2CountLimitAIN2HighLimit As Double
    Get
    Set
public:
property double FAN2CountLimitAIN2HighLimit {
    double get ();
    void set (double value);
}
member FAN2CountLimitAIN2HighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.FAN2RPMControl Property

IRD

Lm87FAN2RPMControl Property

FAN2 RPM Control

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeFanRpmControl FAN2RPMControl { get; set; }
Public Property FAN2RPMControl As Lm87TypeFanRpmControl
    Get
    Set
public:
property Lm87TypeFanRpmControl FAN2RPMControl {
    Lm87TypeFanRpmControl get ();
    void set (Lm87TypeFanRpmControl value);
}
member FAN2RPMControl : Lm87TypeFanRpmControl with get, set

Property Value

Type: Lm87TypeFanRpmControl
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InternalTemperature Property

IRD

Lm87InternalTemperature Property

Internal Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperature { get; }
Public ReadOnly Property InternalTemperature As SByte
    Get
public:
property signed char InternalTemperature {
    signed char get ();
}
member InternalTemperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InternalTemperatureHighLimit Property

IRD

Lm87InternalTemperatureHighLimit Property

Internal Temperature High Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureHighLimit { get; set; }
Public Property InternalTemperatureHighLimit As SByte
    Get
    Set
public:
property signed char InternalTemperatureHighLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTemperatureHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InternalTemperatureLowLimit Property

IRD

Lm87InternalTemperatureLowLimit Property

Internal Temperature Low Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureLowLimit { get; set; }
Public Property InternalTemperatureLowLimit As SByte
    Get
    Set
public:
property signed char InternalTemperatureLowLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTemperatureLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InternalTempHardwareHighLimit0x13 Property

IRD

Lm87InternalTempHardwareHighLimit0x13 Property

Internal Temp. Hardware High Limit [0x13] (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTempHardwareHighLimit0x13 { get; set; }
Public Property InternalTempHardwareHighLimit0x13 As SByte
    Get
    Set
public:
property signed char InternalTempHardwareHighLimit0x13 {
    signed char get ();
    void set (signed char value);
}
member InternalTempHardwareHighLimit0x13 : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InternalTempHardwareHighLimit0x17 Property

IRD

Lm87InternalTempHardwareHighLimit0x17 Property

Internal Temp. Hardware High Limit [0x17] (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTempHardwareHighLimit0x17 { get; set; }
Public Property InternalTempHardwareHighLimit0x17 As SByte
    Get
    Set
public:
property signed char InternalTempHardwareHighLimit0x17 {
    signed char get ();
    void set (signed char value);
}
member InternalTempHardwareHighLimit0x17 : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptMask12Vin Property

IRD

Lm87InterruptMask12Vin Property

Interrupt Mask: +12Vin

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptMask InterruptMask12Vin { get; set; }
Public Property InterruptMask12Vin As Lm87TypeInterruptMask
    Get
    Set
public:
property Lm87TypeInterruptMask InterruptMask12Vin {
    Lm87TypeInterruptMask get ();
    void set (Lm87TypeInterruptMask value);
}
member InterruptMask12Vin : Lm87TypeInterruptMask with get, set

Property Value

Type: Lm87TypeInterruptMask
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptMask25VinD2 Property

IRD

Lm87InterruptMask25VinD2 Property

Interrupt Mask: +2.5Vin/D2+

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptMask InterruptMask25VinD2 { get; set; }
Public Property InterruptMask25VinD2 As Lm87TypeInterruptMask
    Get
    Set
public:
property Lm87TypeInterruptMask InterruptMask25VinD2 {
    Lm87TypeInterruptMask get ();
    void set (Lm87TypeInterruptMask value);
}
member InterruptMask25VinD2 : Lm87TypeInterruptMask with get, set

Property Value

Type: Lm87TypeInterruptMask
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptMask5Vin Property

IRD

Lm87InterruptMask5Vin Property

Interrupt Mask: +5Vin

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptMask InterruptMask5Vin { get; set; }
Public Property InterruptMask5Vin As Lm87TypeInterruptMask
    Get
    Set
public:
property Lm87TypeInterruptMask InterruptMask5Vin {
    Lm87TypeInterruptMask get ();
    void set (Lm87TypeInterruptMask value);
}
member InterruptMask5Vin : Lm87TypeInterruptMask with get, set

Property Value

Type: Lm87TypeInterruptMask
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptMaskChassisIntrusion Property

IRD

Lm87InterruptMaskChassisIntrusion Property

Interrupt Mask: Chassis Intrusion

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptMask InterruptMaskChassisIntrusion { get; set; }
Public Property InterruptMaskChassisIntrusion As Lm87TypeInterruptMask
    Get
    Set
public:
property Lm87TypeInterruptMask InterruptMaskChassisIntrusion {
    Lm87TypeInterruptMask get ();
    void set (Lm87TypeInterruptMask value);
}
member InterruptMaskChassisIntrusion : Lm87TypeInterruptMask with get, set

Property Value

Type: Lm87TypeInterruptMask
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptMaskD1Fault Property

IRD

Lm87InterruptMaskD1Fault Property

Interrupt Mask: D1 Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptMask InterruptMaskD1Fault { get; set; }
Public Property InterruptMaskD1Fault As Lm87TypeInterruptMask
    Get
    Set
public:
property Lm87TypeInterruptMask InterruptMaskD1Fault {
    Lm87TypeInterruptMask get ();
    void set (Lm87TypeInterruptMask value);
}
member InterruptMaskD1Fault : Lm87TypeInterruptMask with get, set

Property Value

Type: Lm87TypeInterruptMask
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptMaskD2Fault Property

IRD

Lm87InterruptMaskD2Fault Property

Interrupt Mask: D2 Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptMask InterruptMaskD2Fault { get; set; }
Public Property InterruptMaskD2Fault As Lm87TypeInterruptMask
    Get
    Set
public:
property Lm87TypeInterruptMask InterruptMaskD2Fault {
    Lm87TypeInterruptMask get ();
    void set (Lm87TypeInterruptMask value);
}
member InterruptMaskD2Fault : Lm87TypeInterruptMask with get, set

Property Value

Type: Lm87TypeInterruptMask
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptMaskExtTemp Property

IRD

Lm87InterruptMaskExtTemp Property

Interrupt Mask: Ext. Temp

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptMask InterruptMaskExtTemp { get; set; }
Public Property InterruptMaskExtTemp As Lm87TypeInterruptMask
    Get
    Set
public:
property Lm87TypeInterruptMask InterruptMaskExtTemp {
    Lm87TypeInterruptMask get ();
    void set (Lm87TypeInterruptMask value);
}
member InterruptMaskExtTemp : Lm87TypeInterruptMask with get, set

Property Value

Type: Lm87TypeInterruptMask
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptMaskFAN1AIN1 Property

IRD

Lm87InterruptMaskFAN1AIN1 Property

Interrupt Mask: FAN1/AIN1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptMask InterruptMaskFAN1AIN1 { get; set; }
Public Property InterruptMaskFAN1AIN1 As Lm87TypeInterruptMask
    Get
    Set
public:
property Lm87TypeInterruptMask InterruptMaskFAN1AIN1 {
    Lm87TypeInterruptMask get ();
    void set (Lm87TypeInterruptMask value);
}
member InterruptMaskFAN1AIN1 : Lm87TypeInterruptMask with get, set

Property Value

Type: Lm87TypeInterruptMask
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptMaskFAN2AIN2 Property

IRD

Lm87InterruptMaskFAN2AIN2 Property

Interrupt Mask: FAN2/AIN2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptMask InterruptMaskFAN2AIN2 { get; set; }
Public Property InterruptMaskFAN2AIN2 As Lm87TypeInterruptMask
    Get
    Set
public:
property Lm87TypeInterruptMask InterruptMaskFAN2AIN2 {
    Lm87TypeInterruptMask get ();
    void set (Lm87TypeInterruptMask value);
}
member InterruptMaskFAN2AIN2 : Lm87TypeInterruptMask with get, set

Property Value

Type: Lm87TypeInterruptMask
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptMaskIntTemp Property

IRD

Lm87InterruptMaskIntTemp Property

Interrupt Mask: Int. Temp

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptMask InterruptMaskIntTemp { get; set; }
Public Property InterruptMaskIntTemp As Lm87TypeInterruptMask
    Get
    Set
public:
property Lm87TypeInterruptMask InterruptMaskIntTemp {
    Lm87TypeInterruptMask get ();
    void set (Lm87TypeInterruptMask value);
}
member InterruptMaskIntTemp : Lm87TypeInterruptMask with get, set

Property Value

Type: Lm87TypeInterruptMask
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptMaskTHERM Property

IRD

Lm87InterruptMaskTHERM Property

Interrupt Mask: THERM#

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptMask InterruptMaskTHERM { get; set; }
Public Property InterruptMaskTHERM As Lm87TypeInterruptMask
    Get
    Set
public:
property Lm87TypeInterruptMask InterruptMaskTHERM {
    Lm87TypeInterruptMask get ();
    void set (Lm87TypeInterruptMask value);
}
member InterruptMaskTHERM : Lm87TypeInterruptMask with get, set

Property Value

Type: Lm87TypeInterruptMask
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptMaskVCC Property

IRD

Lm87InterruptMaskVCC Property

Interrupt Mask: V_CC

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptMask InterruptMaskVCC { get; set; }
Public Property InterruptMaskVCC As Lm87TypeInterruptMask
    Get
    Set
public:
property Lm87TypeInterruptMask InterruptMaskVCC {
    Lm87TypeInterruptMask get ();
    void set (Lm87TypeInterruptMask value);
}
member InterruptMaskVCC : Lm87TypeInterruptMask with get, set

Property Value

Type: Lm87TypeInterruptMask
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptMaskVCCP1 Property

IRD

Lm87InterruptMaskVCCP1 Property

Interrupt Mask: V_CCP1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptMask InterruptMaskVCCP1 { get; set; }
Public Property InterruptMaskVCCP1 As Lm87TypeInterruptMask
    Get
    Set
public:
property Lm87TypeInterruptMask InterruptMaskVCCP1 {
    Lm87TypeInterruptMask get ();
    void set (Lm87TypeInterruptMask value);
}
member InterruptMaskVCCP1 : Lm87TypeInterruptMask with get, set

Property Value

Type: Lm87TypeInterruptMask
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptMaskVCCP2 Property

IRD

Lm87InterruptMaskVCCP2 Property

Interrupt Mask: V_CCP2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptMask InterruptMaskVCCP2 { get; set; }
Public Property InterruptMaskVCCP2 As Lm87TypeInterruptMask
    Get
    Set
public:
property Lm87TypeInterruptMask InterruptMaskVCCP2 {
    Lm87TypeInterruptMask get ();
    void set (Lm87TypeInterruptMask value);
}
member InterruptMaskVCCP2 : Lm87TypeInterruptMask with get, set

Property Value

Type: Lm87TypeInterruptMask
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatus12Vin Property

IRD

Lm87InterruptStatus12Vin Property

Interrupt Status: +12Vin

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatus12Vin { get; }
Public ReadOnly Property InterruptStatus12Vin As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatus12Vin {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatus12Vin : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatus25Vin Property

IRD

Lm87InterruptStatus25Vin Property

Interrupt Status: +2.5Vin

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatus25Vin { get; }
Public ReadOnly Property InterruptStatus25Vin As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatus25Vin {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatus25Vin : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatus5Vin Property

IRD

Lm87InterruptStatus5Vin Property

Interrupt Status: +5Vin

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatus5Vin { get; }
Public ReadOnly Property InterruptStatus5Vin As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatus5Vin {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatus5Vin : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusCI Property

IRD

Lm87InterruptStatusCI Property

Interrupt Status: CI

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusCi InterruptStatusCI { get; }
Public ReadOnly Property InterruptStatusCI As Lm87TypeInterruptStatusCi
    Get
public:
property Lm87TypeInterruptStatusCi InterruptStatusCI {
    Lm87TypeInterruptStatusCi get ();
}
member InterruptStatusCI : Lm87TypeInterruptStatusCi with get

Property Value

Type: Lm87TypeInterruptStatusCi
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusD1Fault Property

IRD

Lm87InterruptStatusD1Fault Property

Interrupt Status: D1 Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusDFault InterruptStatusD1Fault { get; }
Public ReadOnly Property InterruptStatusD1Fault As Lm87TypeInterruptStatusDFault
    Get
public:
property Lm87TypeInterruptStatusDFault InterruptStatusD1Fault {
    Lm87TypeInterruptStatusDFault get ();
}
member InterruptStatusD1Fault : Lm87TypeInterruptStatusDFault with get

Property Value

Type: Lm87TypeInterruptStatusDFault
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusD2Fault Property

IRD

Lm87InterruptStatusD2Fault Property

Interrupt Status: D2 Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusDFault InterruptStatusD2Fault { get; }
Public ReadOnly Property InterruptStatusD2Fault As Lm87TypeInterruptStatusDFault
    Get
public:
property Lm87TypeInterruptStatusDFault InterruptStatusD2Fault {
    Lm87TypeInterruptStatusDFault get ();
}
member InterruptStatusD2Fault : Lm87TypeInterruptStatusDFault with get

Property Value

Type: Lm87TypeInterruptStatusDFault
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusExtTemp Property

IRD

Lm87InterruptStatusExtTemp Property

Interrupt Status: Ext. Temp.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusExtTemp { get; }
Public ReadOnly Property InterruptStatusExtTemp As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusExtTemp {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatusExtTemp : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusFAN1AIN1 Property

IRD

Lm87InterruptStatusFAN1AIN1 Property

Interrupt Status: FAN1/AIN1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusFAN1AIN1 { get; }
Public ReadOnly Property InterruptStatusFAN1AIN1 As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusFAN1AIN1 {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatusFAN1AIN1 : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusFAN2AIN2 Property

IRD

Lm87InterruptStatusFAN2AIN2 Property

Interrupt Status: FAN2/AIN2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusFAN2AIN2 { get; }
Public ReadOnly Property InterruptStatusFAN2AIN2 As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusFAN2AIN2 {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatusFAN2AIN2 : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusIntTemp Property

IRD

Lm87InterruptStatusIntTemp Property

Interrupt Status: Int. Temp.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusIntTemp { get; }
Public ReadOnly Property InterruptStatusIntTemp As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusIntTemp {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatusIntTemp : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusMirror12Vin Property

IRD

Lm87InterruptStatusMirror12Vin Property

Interrupt Status Mirror: +12Vin

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirror12Vin { get; }
Public ReadOnly Property InterruptStatusMirror12Vin As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirror12Vin {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatusMirror12Vin : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusMirror25Vin Property

IRD

Lm87InterruptStatusMirror25Vin Property

Interrupt Status Mirror: +2.5Vin

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirror25Vin { get; }
Public ReadOnly Property InterruptStatusMirror25Vin As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirror25Vin {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatusMirror25Vin : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusMirror5Vin Property

IRD

Lm87InterruptStatusMirror5Vin Property

Interrupt Status Mirror: +5Vin

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirror5Vin { get; }
Public ReadOnly Property InterruptStatusMirror5Vin As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirror5Vin {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatusMirror5Vin : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusMirrorCI Property

IRD

Lm87InterruptStatusMirrorCI Property

Interrupt Status Mirror: CI

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusCi InterruptStatusMirrorCI { get; }
Public ReadOnly Property InterruptStatusMirrorCI As Lm87TypeInterruptStatusCi
    Get
public:
property Lm87TypeInterruptStatusCi InterruptStatusMirrorCI {
    Lm87TypeInterruptStatusCi get ();
}
member InterruptStatusMirrorCI : Lm87TypeInterruptStatusCi with get

Property Value

Type: Lm87TypeInterruptStatusCi
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusMirrorD1Fault Property

IRD

Lm87InterruptStatusMirrorD1Fault Property

Interrupt Status Mirror: D1 Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusDFault InterruptStatusMirrorD1Fault { get; }
Public ReadOnly Property InterruptStatusMirrorD1Fault As Lm87TypeInterruptStatusDFault
    Get
public:
property Lm87TypeInterruptStatusDFault InterruptStatusMirrorD1Fault {
    Lm87TypeInterruptStatusDFault get ();
}
member InterruptStatusMirrorD1Fault : Lm87TypeInterruptStatusDFault with get

Property Value

Type: Lm87TypeInterruptStatusDFault
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusMirrorD2Fault Property

IRD

Lm87InterruptStatusMirrorD2Fault Property

Interrupt Status Mirror: D2 Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusDFault InterruptStatusMirrorD2Fault { get; }
Public ReadOnly Property InterruptStatusMirrorD2Fault As Lm87TypeInterruptStatusDFault
    Get
public:
property Lm87TypeInterruptStatusDFault InterruptStatusMirrorD2Fault {
    Lm87TypeInterruptStatusDFault get ();
}
member InterruptStatusMirrorD2Fault : Lm87TypeInterruptStatusDFault with get

Property Value

Type: Lm87TypeInterruptStatusDFault
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusMirrorExtTemp Property

IRD

Lm87InterruptStatusMirrorExtTemp Property

Interrupt Status Mirror: Ext. Temp

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirrorExtTemp { get; }
Public ReadOnly Property InterruptStatusMirrorExtTemp As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirrorExtTemp {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatusMirrorExtTemp : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusMirrorFAN1AIN1 Property

IRD

Lm87InterruptStatusMirrorFAN1AIN1 Property

Interrupt Status Mirror: FAN1/AIN1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirrorFAN1AIN1 { get; }
Public ReadOnly Property InterruptStatusMirrorFAN1AIN1 As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirrorFAN1AIN1 {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatusMirrorFAN1AIN1 : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusMirrorFAN2AIN2 Property

IRD

Lm87InterruptStatusMirrorFAN2AIN2 Property

Interrupt Status Mirror: FAN2/AIN2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirrorFAN2AIN2 { get; }
Public ReadOnly Property InterruptStatusMirrorFAN2AIN2 As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirrorFAN2AIN2 {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatusMirrorFAN2AIN2 : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusMirrorIntTemp Property

IRD

Lm87InterruptStatusMirrorIntTemp Property

Interrupt Status Mirror: Int. Temp.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirrorIntTemp { get; }
Public ReadOnly Property InterruptStatusMirrorIntTemp As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirrorIntTemp {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatusMirrorIntTemp : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusMirrorTHERM Property

IRD

Lm87InterruptStatusMirrorTHERM Property

Interrupt Status Mirror: THERM#

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusTherm InterruptStatusMirrorTHERM { get; }
Public ReadOnly Property InterruptStatusMirrorTHERM As Lm87TypeInterruptStatusTherm
    Get
public:
property Lm87TypeInterruptStatusTherm InterruptStatusMirrorTHERM {
    Lm87TypeInterruptStatusTherm get ();
}
member InterruptStatusMirrorTHERM : Lm87TypeInterruptStatusTherm with get

Property Value

Type: Lm87TypeInterruptStatusTherm
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusMirrorVCC Property

IRD

Lm87InterruptStatusMirrorVCC Property

Interrupt Status Mirror: V_CC

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirrorVCC { get; }
Public ReadOnly Property InterruptStatusMirrorVCC As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirrorVCC {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatusMirrorVCC : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusMirrorVCCP1 Property

IRD

Lm87InterruptStatusMirrorVCCP1 Property

Interrupt Status Mirror: V_CCP1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirrorVCCP1 { get; }
Public ReadOnly Property InterruptStatusMirrorVCCP1 As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirrorVCCP1 {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatusMirrorVCCP1 : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusMirrorVCCP2 Property

IRD

Lm87InterruptStatusMirrorVCCP2 Property

Interrupt Status Mirror: V_CCP2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirrorVCCP2 { get; }
Public ReadOnly Property InterruptStatusMirrorVCCP2 As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusMirrorVCCP2 {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatusMirrorVCCP2 : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusTHERM Property

IRD

Lm87InterruptStatusTHERM Property

Interrupt Status: THERM#

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusTherm InterruptStatusTHERM { get; }
Public ReadOnly Property InterruptStatusTHERM As Lm87TypeInterruptStatusTherm
    Get
public:
property Lm87TypeInterruptStatusTherm InterruptStatusTHERM {
    Lm87TypeInterruptStatusTherm get ();
}
member InterruptStatusTHERM : Lm87TypeInterruptStatusTherm with get

Property Value

Type: Lm87TypeInterruptStatusTherm
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusVCC Property

IRD

Lm87InterruptStatusVCC Property

Interrupt Status: V_CC

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusVCC { get; }
Public ReadOnly Property InterruptStatusVCC As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusVCC {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatusVCC : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusVCCP1 Property

IRD

Lm87InterruptStatusVCCP1 Property

Interrupt Status: V_CCP1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusVCCP1 { get; }
Public ReadOnly Property InterruptStatusVCCP1 As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusVCCP1 {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatusVCCP1 : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.InterruptStatusVCCP2 Property

IRD

Lm87InterruptStatusVCCP2 Property

Interrupt Status: V_CCP2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusVCCP2 { get; }
Public ReadOnly Property InterruptStatusVCCP2 As Lm87TypeInterruptStatusHighLowLimitExceeded
    Get
public:
property Lm87TypeInterruptStatusHighLowLimitExceeded InterruptStatusVCCP2 {
    Lm87TypeInterruptStatusHighLowLimitExceeded get ();
}
member InterruptStatusVCCP2 : Lm87TypeInterruptStatusHighLowLimitExceeded with get

Property Value

Type: Lm87TypeInterruptStatusHighLowLimitExceeded
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.Property_12V Property

IRD

Lm87Property_12V Property

+12V (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_12V { get; }
Public ReadOnly Property Property_12V As Double
    Get
public:
property double Property_12V {
    double get ();
}
member Property_12V : float with get

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.Property_12VHighLimit Property

IRD

Lm87Property_12VHighLimit Property

+12V High Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_12VHighLimit { get; set; }
Public Property Property_12VHighLimit As Double
    Get
    Set
public:
property double Property_12VHighLimit {
    double get ();
    void set (double value);
}
member Property_12VHighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.Property_12VLowLimit Property

IRD

Lm87Property_12VLowLimit Property

+12V Low Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_12VLowLimit { get; set; }
Public Property Property_12VLowLimit As Double
    Get
    Set
public:
property double Property_12VLowLimit {
    double get ();
    void set (double value);
}
member Property_12VLowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.Property_25VExternalTemperature2 Property

IRD

Lm87Property_25VExternalTemperature2 Property

+2.5V/External Temperature 2 (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_25VExternalTemperature2 { get; }
Public ReadOnly Property Property_25VExternalTemperature2 As Double
    Get
public:
property double Property_25VExternalTemperature2 {
    double get ();
}
member Property_25VExternalTemperature2 : float with get

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.Property_25VHighLimitExternalTemperature2HighLimit Property

IRD

Lm87Property_25VHighLimitExternalTemperature2HighLimit Property

+2.5V High Limit/External Temperature 2 High Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_25VHighLimitExternalTemperature2HighLimit { get; set; }
Public Property Property_25VHighLimitExternalTemperature2HighLimit As Double
    Get
    Set
public:
property double Property_25VHighLimitExternalTemperature2HighLimit {
    double get ();
    void set (double value);
}
member Property_25VHighLimitExternalTemperature2HighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.Property_25VHighLimitExternalTemperature2LowLimit Property

IRD

Lm87Property_25VHighLimitExternalTemperature2LowLimit Property

+2.5V High Limit/External Temperature 2 Low Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_25VHighLimitExternalTemperature2LowLimit { get; set; }
Public Property Property_25VHighLimitExternalTemperature2LowLimit As Double
    Get
    Set
public:
property double Property_25VHighLimitExternalTemperature2LowLimit {
    double get ();
    void set (double value);
}
member Property_25VHighLimitExternalTemperature2LowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.Property_33VHighLimit Property

IRD

Lm87Property_33VHighLimit Property

+3.3V High Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_33VHighLimit { get; set; }
Public Property Property_33VHighLimit As Double
    Get
    Set
public:
property double Property_33VHighLimit {
    double get ();
    void set (double value);
}
member Property_33VHighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.Property_33VLowLimit Property

IRD

Lm87Property_33VLowLimit Property

+3.3V Low Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_33VLowLimit { get; set; }
Public Property Property_33VLowLimit As Double
    Get
    Set
public:
property double Property_33VLowLimit {
    double get ();
    void set (double value);
}
member Property_33VLowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.Property_5V Property

IRD

Lm87Property_5V Property

+5V (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_5V { get; }
Public ReadOnly Property Property_5V As Double
    Get
public:
property double Property_5V {
    double get ();
}
member Property_5V : float with get

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.Property_5VHighLimit Property

IRD

Lm87Property_5VHighLimit Property

+5V High Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_5VHighLimit { get; set; }
Public Property Property_5VHighLimit As Double
    Get
    Set
public:
property double Property_5VHighLimit {
    double get ();
    void set (double value);
}
member Property_5VHighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.Property_5VLowLimit Property

IRD

Lm87Property_5VLowLimit Property

+5V Low Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Property_5VLowLimit { get; set; }
Public Property Property_5VLowLimit As Double
    Get
    Set
public:
property double Property_5VLowLimit {
    double get ();
    void set (double value);
}
member Property_5VLowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.Revision Property

IRD

Lm87Revision Property

Revision

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Revision { get; }
Public ReadOnly Property Revision As Byte
    Get
public:
property unsigned char Revision {
    unsigned char get ();
}
member Revision : byte with get

Property Value

Type: Byte
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.Shutdown Property

IRD

Lm87Shutdown Property

Shutdown

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeTestShutdown Shutdown { get; set; }
Public Property Shutdown As Lm87TypeTestShutdown
    Get
    Set
public:
property Lm87TypeTestShutdown Shutdown {
    Lm87TypeTestShutdown get ();
    void set (Lm87TypeTestShutdown value);
}
member Shutdown : Lm87TypeTestShutdown with get, set

Property Value

Type: Lm87TypeTestShutdown
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.SMBALERTEnable Property

IRD

Lm87SMBALERTEnable Property

SMBALERT# Enable

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm87TypeSmbalertEnable SMBALERTEnable { get; set; }
Public Property SMBALERTEnable As Lm87TypeSmbalertEnable
    Get
    Set
public:
property Lm87TypeSmbalertEnable SMBALERTEnable {
    Lm87TypeSmbalertEnable get ();
    void set (Lm87TypeSmbalertEnable value);
}
member SMBALERTEnable : Lm87TypeSmbalertEnable with get, set

Property Value

Type: Lm87TypeSmbalertEnable
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.VCC Property

IRD

Lm87VCC Property

+V_CC (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCC { get; }
Public ReadOnly Property VCC As Double
    Get
public:
property double VCC {
    double get ();
}
member VCC : float with get

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.VCCP1 Property

IRD

Lm87VCCP1 Property

V_CCP1 (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCP1 { get; }
Public ReadOnly Property VCCP1 As Double
    Get
public:
property double VCCP1 {
    double get ();
}
member VCCP1 : float with get

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.VCCP1HighLimit Property

IRD

Lm87VCCP1HighLimit Property

V_CCP1 High Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCP1HighLimit { get; set; }
Public Property VCCP1HighLimit As Double
    Get
    Set
public:
property double VCCP1HighLimit {
    double get ();
    void set (double value);
}
member VCCP1HighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.VCCP1LowLimit Property

IRD

Lm87VCCP1LowLimit Property

V_CCP1 Low Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCP1LowLimit { get; set; }
Public Property VCCP1LowLimit As Double
    Get
    Set
public:
property double VCCP1LowLimit {
    double get ();
    void set (double value);
}
member VCCP1LowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.VCCP2 Property

IRD

Lm87VCCP2 Property

V_CCP2 (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCP2 { get; }
Public ReadOnly Property VCCP2 As Double
    Get
public:
property double VCCP2 {
    double get ();
}
member VCCP2 : float with get

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.VCCP2HighLimit Property

IRD

Lm87VCCP2HighLimit Property

V_CCP2 High Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCP2HighLimit { get; set; }
Public Property VCCP2HighLimit As Double
    Get
    Set
public:
property double VCCP2HighLimit {
    double get ();
    void set (double value);
}
member VCCP2HighLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.VCCP2LowLimit Property

IRD

Lm87VCCP2LowLimit Property

V_CCP2 Low Limit (unit: V)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double VCCP2LowLimit { get; set; }
Public Property VCCP2LowLimit As Double
    Get
    Set
public:
property double VCCP2LowLimit {
    double get ();
    void set (double value);
}
member VCCP2LowLimit : float with get, set

Property Value

Type: Double
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.VID Property

IRD

Lm87VID Property

VID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VID { get; }
Public ReadOnly Property VID As Byte
    Get
public:
property unsigned char VID {
    unsigned char get ();
}
member VID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87 Methods

The Lm87 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.Flush Method

IRD

Lm87Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm87 Class
telos.Ird.NationalSemiconductor Namespace


Lm87.TypeChannelMode25vVccp2D2 Enumeration

IRD

Lm87TypeChannelMode25vVccp2D2 Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelMode25vVccp2D2
Public Enumeration TypeChannelMode25vVccp2D2
public enum class TypeChannelMode25vVccp2D2
type TypeChannelMode25vVccp2D2
Members
Member name | Value | Description
Value_25VVCCP2D2UsedAsDiodeInputNo | 0 | 2.5V, V_CCP2/D2 Used As Diode Input: No
Value_25VVCCP2D2UsedAsDiodeInputYes | 1 | 2.5V, V_CCP2/D2 Used As Diode Input: Yes
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeChannelModeFanAin Enumeration

IRD

Lm87TypeChannelModeFanAin Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelModeFanAin
Public Enumeration TypeChannelModeFanAin
public enum class TypeChannelModeFanAin
type TypeChannelModeFanAin
Members
Member name | Value | Description
FAN | 0 | FAN
AIN | 1 | AIN
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeChannelModeIntVccRange Enumeration

IRD

Lm87TypeChannelModeIntVccRange Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelModeIntVccRange
Public Enumeration TypeChannelModeIntVccRange
public enum class TypeChannelModeIntVccRange
type TypeChannelModeIntVccRange
Members
Member name | Value | Description
Value_33VVCC | 0 | 3.3V V_CC
Value_50VVCC | 1 | 5.0V V_CC
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeChannelVidIrq Enumeration

IRD

Lm87TypeChannelVidIrq Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelVidIrq
Public Enumeration TypeChannelVidIrq
public enum class TypeChannelVidIrq
type TypeChannelVidIrq
Members
Member name | Value | Description
VID | 0 | VID
IRQ | 1 | IRQ
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeCiClear Enumeration

IRD

Lm87TypeCiClear Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCiClear
Public Enumeration TypeCiClear
public enum class TypeCiClear
type TypeCiClear
Members
Member name | Value | Description
Unmodified | 0 | Unmodified
OutputPulse | 1 | Output Pulse
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeConfigurationClear Enumeration

IRD

Lm87TypeConfigurationClear Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationClear
Public Enumeration TypeConfigurationClear
public enum class TypeConfigurationClear
type TypeConfigurationClear
Members
Member name | Value | Description
Unmodified | 0 | Unmodified
Clear | 1 | Clear
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeConfigurationEnable Enumeration

IRD

Lm87TypeConfigurationEnable Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationEnable
Public Enumeration TypeConfigurationEnable
public enum class TypeConfigurationEnable
type TypeConfigurationEnable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeConfigurationInitialization Enumeration

IRD

Lm87TypeConfigurationInitialization Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationInitialization
Public Enumeration TypeConfigurationInitialization
public enum class TypeConfigurationInitialization
type TypeConfigurationInitialization
Members
Member name | Value | Description
Unmodified | 0 | Unmodified
RestoresPowerOnDefaultValues | 1 | Restores Power On Default Values
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeConfigurationReset Enumeration

IRD

Lm87TypeConfigurationReset Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationReset
Public Enumeration TypeConfigurationReset
public enum class TypeConfigurationReset
type TypeConfigurationReset
Members
Member name | Value | Description
Unmodified | 0 | Unmodified
Reset | 1 | Reset
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeConfigurationStart Enumeration

IRD

Lm87TypeConfigurationStart Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationStart
Public Enumeration TypeConfigurationStart
public enum class TypeConfigurationStart
type TypeConfigurationStart
Members
Member name | Value | Description
Standby | 0 | Standby
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeConfigurationTempLock Enumeration

IRD

Lm87TypeConfigurationTempLock Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationTempLock
Public Enumeration TypeConfigurationTempLock
public enum class TypeConfigurationTempLock
type TypeConfigurationTempLock
Members
Member name | Value | Description
Unlocked | 0 | Unlocked
Locked | 1 | Locked
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeConfigurationThermalIntMask Enumeration

IRD

Lm87TypeConfigurationThermalIntMask Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationThermalIntMask
Public Enumeration TypeConfigurationThermalIntMask
public enum class TypeConfigurationThermalIntMask
type TypeConfigurationThermalIntMask
Members
Member name | Value | Description
INTOutputAffectedByThermalErrorEventsEnabled | 0 | INT# Output Affected By Thermal Error Events: Enabled
INTOutputAffectedByThermalErrorEventsDisabled | 1 | INT# Output Affected By Thermal Error Events: Disabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeConfigurationThermInterruptMode Enumeration

IRD

Lm87TypeConfigurationThermInterruptMode Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationThermInterruptMode
Public Enumeration TypeConfigurationThermInterruptMode
public enum class TypeConfigurationThermInterruptMode
type TypeConfigurationThermInterruptMode
Members
Member name | Value | Description
DefaultMode | 0 | Default Mode
ACPIMode | 1 | ACPI Mode
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeFanRpmControl Enumeration

IRD

Lm87TypeFanRpmControl Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFanRpmControl
Public Enumeration TypeFanRpmControl
public enum class TypeFanRpmControl
type TypeFanRpmControl
Members
Member name | Value | Description
DivideBy1 | 0 | Divide By: 1
DivideBy2 | 1 | Divide By: 2
DivideBy4 | 2 | Divide By: 4
DivideBy8 | 3 | Divide By: 8
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeInterruptMask Enumeration

IRD

Lm87TypeInterruptMask Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptMask
Public Enumeration TypeInterruptMask
public enum class TypeInterruptMask
type TypeInterruptMask
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeInterruptStatusCi Enumeration

IRD

Lm87TypeInterruptStatusCi Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatusCi
Public Enumeration TypeInterruptStatusCi
public enum class TypeInterruptStatusCi
type TypeInterruptStatusCi
Members
Member name | Value | Description
Low | 0 | Low
High | 1 | High
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeInterruptStatusDFault Enumeration

IRD

Lm87TypeInterruptStatusDFault Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatusDFault
Public Enumeration TypeInterruptStatusDFault
public enum class TypeInterruptStatusDFault
type TypeInterruptStatusDFault
Members
Member name | Value | Description
Ok | 0 | Ok
ShortedToVCCOpenCircuit | 1 | Shorted To V_CC / Open Circuit
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeInterruptStatusHighLowLimitExceeded Enumeration

IRD

Lm87TypeInterruptStatusHighLowLimitExceeded Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatusHighLowLimitExceeded
Public Enumeration TypeInterruptStatusHighLowLimitExceeded
public enum class TypeInterruptStatusHighLowLimitExceeded
type TypeInterruptStatusHighLowLimitExceeded
Members
Member name | Value | Description
HighLowLimitsNotExceeded | 0 | High/Low Limits: Not Exceeded
HighLowLimitsExceeded | 1 | High/Low Limits: Exceeded
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeInterruptStatusTherm Enumeration

IRD

Lm87TypeInterruptStatusTherm Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatusTherm
Public Enumeration TypeInterruptStatusTherm
public enum class TypeInterruptStatusTherm
type TypeInterruptStatusTherm
Members
Member name | Value | Description
High | 0 | High
Low | 1 | Low
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeSmbalertEnable Enumeration

IRD

Lm87TypeSmbalertEnable Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSmbalertEnable
Public Enumeration TypeSmbalertEnable
public enum class TypeSmbalertEnable
type TypeSmbalertEnable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm87.TypeTestShutdown Enumeration

IRD

Lm87TypeTestShutdown Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTestShutdown
Public Enumeration TypeTestShutdown
public enum class TypeTestShutdown
type TypeTestShutdown
Members
Member name | Value | Description
Normal | 0 | Normal
Shutdown | 1 | Shutdown
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm89 Class

National Semiconductor: LM 89
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm89

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm89
Public Class Lm89
public ref class Lm89
type Lm89 =  class end

The Lm89 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm89 | Constructor
Top
Properties
 | Name | Description
Public property | ALERTConfigure | ALERT Configure
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationALERTMask | Configuration: ALERT Mask
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationLocalTCRITAMask | Configuration: Local T_CRIT_A Mask
Public property | ConfigurationRemoteTCRITAMask | Configuration: Remote T_CRIT_A Mask
Public property | ConfigurationRUNSTOP | Configuration: RUN/STOP
Public property | ConversionRate | Conversion Rate
Public property | FilterLevel | Filter Level
Public property | LocalHIGHSetpoint | Local HIGH Setpoint (unit: °C)
Public property | LocalLOWSetpoint | Local LOW Setpoint (unit: °C)
Public property | LocalTCRITSetpoint | Local T_CRIT Setpoint (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerSID | Manufacturer's ID
Public property | RemoteHIGHSetpoint | Remote HIGH Setpoint (unit: °C)
Public property | RemoteLOWSetpoint | Remote LOW Setpoint (unit: °C)
Public property | RemoteTCRITSetpoint | Remote T_CRIT Setpoint (unit: °C)
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | RemoteTemperatureOffset | Remote Temperature Offset (unit: °C)
Public property | StatusBusy | Status: Busy
Public property | StatusLCRIT | Status: LCRIT
Public property | StatusLHIGH | Status: LHIGH
Public property | StatusLLOW | Status: LLOW
Public property | StatusOPEN | Status: OPEN
Public property | StatusRCRIT | Status: RCRIT
Public property | StatusRHIGH | Status: RHIGH
Public property | StatusRLOW | Status: RLOW
Public property | SteppingOrDieRevisionCode | Stepping Or Die Revision Code
Public property | TCRITHysteresis | T_CRIT Hysteresis (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
±0.75°C Accurate, Remote Diode and Local Digital Temperature Sensor with Two-Wire Interface
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm89 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm89(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm89(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm89

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89 Properties

The Lm89 type exposes the following members.

Properties
 | Name | Description
Public property | ALERTConfigure | ALERT Configure
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationALERTMask | Configuration: ALERT Mask
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationLocalTCRITAMask | Configuration: Local T_CRIT_A Mask
Public property | ConfigurationRemoteTCRITAMask | Configuration: Remote T_CRIT_A Mask
Public property | ConfigurationRUNSTOP | Configuration: RUN/STOP
Public property | ConversionRate | Conversion Rate
Public property | FilterLevel | Filter Level
Public property | LocalHIGHSetpoint | Local HIGH Setpoint (unit: °C)
Public property | LocalLOWSetpoint | Local LOW Setpoint (unit: °C)
Public property | LocalTCRITSetpoint | Local T_CRIT Setpoint (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerSID | Manufacturer's ID
Public property | RemoteHIGHSetpoint | Remote HIGH Setpoint (unit: °C)
Public property | RemoteLOWSetpoint | Remote LOW Setpoint (unit: °C)
Public property | RemoteTCRITSetpoint | Remote T_CRIT Setpoint (unit: °C)
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | RemoteTemperatureOffset | Remote Temperature Offset (unit: °C)
Public property | StatusBusy | Status: Busy
Public property | StatusLCRIT | Status: LCRIT
Public property | StatusLHIGH | Status: LHIGH
Public property | StatusLLOW | Status: LLOW
Public property | StatusOPEN | Status: OPEN
Public property | StatusRCRIT | Status: RCRIT
Public property | StatusRHIGH | Status: RHIGH
Public property | StatusRLOW | Status: RLOW
Public property | SteppingOrDieRevisionCode | Stepping Or Die Revision Code
Public property | TCRITHysteresis | T_CRIT Hysteresis (unit: °C)
Top
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.ALERTConfigure Property

IRD

Lm89ALERTConfigure Property

ALERT Configure

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm89TypeAlertConfigure ALERTConfigure { get; set; }
Public Property ALERTConfigure As Lm89TypeAlertConfigure
    Get
    Set
public:
property Lm89TypeAlertConfigure ALERTConfigure {
    Lm89TypeAlertConfigure get ();
    void set (Lm89TypeAlertConfigure value);
}
member ALERTConfigure : Lm89TypeAlertConfigure with get, set

Property Value

Type: Lm89TypeAlertConfigure
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.AutoFlush Property

IRD

Lm89AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.ConfigurationALERTMask Property

IRD

Lm89ConfigurationALERTMask Property

Configuration: ALERT Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm89TypeConfigurationAlertMask ConfigurationALERTMask { get; set; }
Public Property ConfigurationALERTMask As Lm89TypeConfigurationAlertMask
    Get
    Set
public:
property Lm89TypeConfigurationAlertMask ConfigurationALERTMask {
    Lm89TypeConfigurationAlertMask get ();
    void set (Lm89TypeConfigurationAlertMask value);
}
member ConfigurationALERTMask : Lm89TypeConfigurationAlertMask with get, set

Property Value

Type: Lm89TypeConfigurationAlertMask
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.ConfigurationFaultQueue Property

IRD

Lm89ConfigurationFaultQueue Property

Configuration: Fault Queue

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm89TypeConfigurationFaultQueue ConfigurationFaultQueue { get; set; }
Public Property ConfigurationFaultQueue As Lm89TypeConfigurationFaultQueue
    Get
    Set
public:
property Lm89TypeConfigurationFaultQueue ConfigurationFaultQueue {
    Lm89TypeConfigurationFaultQueue get ();
    void set (Lm89TypeConfigurationFaultQueue value);
}
member ConfigurationFaultQueue : Lm89TypeConfigurationFaultQueue with get, set

Property Value

Type: Lm89TypeConfigurationFaultQueue
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.ConfigurationLocalTCRITAMask Property

IRD

Lm89ConfigurationLocalTCRITAMask Property

Configuration: Local T_CRIT_A Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm89TypeConfigurationLocalTCritMask ConfigurationLocalTCRITAMask { get; set; }
Public Property ConfigurationLocalTCRITAMask As Lm89TypeConfigurationLocalTCritMask
    Get
    Set
public:
property Lm89TypeConfigurationLocalTCritMask ConfigurationLocalTCRITAMask {
    Lm89TypeConfigurationLocalTCritMask get ();
    void set (Lm89TypeConfigurationLocalTCritMask value);
}
member ConfigurationLocalTCRITAMask : Lm89TypeConfigurationLocalTCritMask with get, set

Property Value

Type: Lm89TypeConfigurationLocalTCritMask
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.ConfigurationRemoteTCRITAMask Property

IRD

Lm89ConfigurationRemoteTCRITAMask Property

Configuration: Remote T_CRIT_A Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm89TypeConfigurationRemoteTCritMask ConfigurationRemoteTCRITAMask { get; set; }
Public Property ConfigurationRemoteTCRITAMask As Lm89TypeConfigurationRemoteTCritMask
    Get
    Set
public:
property Lm89TypeConfigurationRemoteTCritMask ConfigurationRemoteTCRITAMask {
    Lm89TypeConfigurationRemoteTCritMask get ();
    void set (Lm89TypeConfigurationRemoteTCritMask value);
}
member ConfigurationRemoteTCRITAMask : Lm89TypeConfigurationRemoteTCritMask with get, set

Property Value

Type: Lm89TypeConfigurationRemoteTCritMask
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.ConfigurationRUNSTOP Property

IRD

Lm89ConfigurationRUNSTOP Property

Configuration: RUN/STOP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm89TypeConfigurationRunStop ConfigurationRUNSTOP { get; set; }
Public Property ConfigurationRUNSTOP As Lm89TypeConfigurationRunStop
    Get
    Set
public:
property Lm89TypeConfigurationRunStop ConfigurationRUNSTOP {
    Lm89TypeConfigurationRunStop get ();
    void set (Lm89TypeConfigurationRunStop value);
}
member ConfigurationRUNSTOP : Lm89TypeConfigurationRunStop with get, set

Property Value

Type: Lm89TypeConfigurationRunStop
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.ConversionRate Property

IRD

Lm89ConversionRate Property

Conversion Rate

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm89TypeConversionRate ConversionRate { get; set; }
Public Property ConversionRate As Lm89TypeConversionRate
    Get
    Set
public:
property Lm89TypeConversionRate ConversionRate {
    Lm89TypeConversionRate get ();
    void set (Lm89TypeConversionRate value);
}
member ConversionRate : Lm89TypeConversionRate with get, set

Property Value

Type: Lm89TypeConversionRate
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.FilterLevel Property

IRD

Lm89FilterLevel Property

Filter Level

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm89TypeFilterLevel FilterLevel { get; set; }
Public Property FilterLevel As Lm89TypeFilterLevel
    Get
    Set
public:
property Lm89TypeFilterLevel FilterLevel {
    Lm89TypeFilterLevel get ();
    void set (Lm89TypeFilterLevel value);
}
member FilterLevel : Lm89TypeFilterLevel with get, set

Property Value

Type: Lm89TypeFilterLevel
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.LocalHIGHSetpoint Property

IRD

Lm89LocalHIGHSetpoint Property

Local HIGH Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalHIGHSetpoint { get; set; }
Public Property LocalHIGHSetpoint As SByte
    Get
    Set
public:
property signed char LocalHIGHSetpoint {
    signed char get ();
    void set (signed char value);
}
member LocalHIGHSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.LocalLOWSetpoint Property

IRD

Lm89LocalLOWSetpoint Property

Local LOW Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalLOWSetpoint { get; set; }
Public Property LocalLOWSetpoint As SByte
    Get
    Set
public:
property signed char LocalLOWSetpoint {
    signed char get ();
    void set (signed char value);
}
member LocalLOWSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.LocalTCRITSetpoint Property

IRD

Lm89LocalTCRITSetpoint Property

Local T_CRIT Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTCRITSetpoint { get; set; }
Public Property LocalTCRITSetpoint As SByte
    Get
    Set
public:
property signed char LocalTCRITSetpoint {
    signed char get ();
    void set (signed char value);
}
member LocalTCRITSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.LocalTemperature Property

IRD

Lm89LocalTemperature Property

Local Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTemperature { get; }
Public ReadOnly Property LocalTemperature As SByte
    Get
public:
property signed char LocalTemperature {
    signed char get ();
}
member LocalTemperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.ManufacturerSID Property

IRD

Lm89ManufacturerSID Property

Manufacturer's ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerSID { get; }
Public ReadOnly Property ManufacturerSID As Byte
    Get
public:
property unsigned char ManufacturerSID {
    unsigned char get ();
}
member ManufacturerSID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.RemoteHIGHSetpoint Property

IRD

Lm89RemoteHIGHSetpoint Property

Remote HIGH Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteHIGHSetpoint { get; set; }
Public Property RemoteHIGHSetpoint As Double
    Get
    Set
public:
property double RemoteHIGHSetpoint {
    double get ();
    void set (double value);
}
member RemoteHIGHSetpoint : float with get, set

Property Value

Type: Double
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.RemoteLOWSetpoint Property

IRD

Lm89RemoteLOWSetpoint Property

Remote LOW Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteLOWSetpoint { get; set; }
Public Property RemoteLOWSetpoint As Double
    Get
    Set
public:
property double RemoteLOWSetpoint {
    double get ();
    void set (double value);
}
member RemoteLOWSetpoint : float with get, set

Property Value

Type: Double
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.RemoteTCRITSetpoint Property

IRD

Lm89RemoteTCRITSetpoint Property

Remote T_CRIT Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTCRITSetpoint { get; set; }
Public Property RemoteTCRITSetpoint As SByte
    Get
    Set
public:
property signed char RemoteTCRITSetpoint {
    signed char get ();
    void set (signed char value);
}
member RemoteTCRITSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.RemoteTemperature Property

IRD

Lm89RemoteTemperature Property

Remote Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperature { get; }
Public ReadOnly Property RemoteTemperature As Double
    Get
public:
property double RemoteTemperature {
    double get ();
}
member RemoteTemperature : float with get

Property Value

Type: Double
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.RemoteTemperatureOffset Property

IRD

Lm89RemoteTemperatureOffset Property

Remote Temperature Offset (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperatureOffset { get; set; }
Public Property RemoteTemperatureOffset As Double
    Get
    Set
public:
property double RemoteTemperatureOffset {
    double get ();
    void set (double value);
}
member RemoteTemperatureOffset : float with get, set

Property Value

Type: Double
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.StatusBusy Property

IRD

Lm89StatusBusy Property

Status: Busy

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm89TypeStatusBusy StatusBusy { get; }
Public ReadOnly Property StatusBusy As Lm89TypeStatusBusy
    Get
public:
property Lm89TypeStatusBusy StatusBusy {
    Lm89TypeStatusBusy get ();
}
member StatusBusy : Lm89TypeStatusBusy with get

Property Value

Type: Lm89TypeStatusBusy
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.StatusLCRIT Property

IRD

Lm89StatusLCRIT Property

Status: LCRIT

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm89TypeStatusLcrit StatusLCRIT { get; }
Public ReadOnly Property StatusLCRIT As Lm89TypeStatusLcrit
    Get
public:
property Lm89TypeStatusLcrit StatusLCRIT {
    Lm89TypeStatusLcrit get ();
}
member StatusLCRIT : Lm89TypeStatusLcrit with get

Property Value

Type: Lm89TypeStatusLcrit
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.StatusLHIGH Property

IRD

Lm89StatusLHIGH Property

Status: LHIGH

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm89TypeStatusLhigh StatusLHIGH { get; }
Public ReadOnly Property StatusLHIGH As Lm89TypeStatusLhigh
    Get
public:
property Lm89TypeStatusLhigh StatusLHIGH {
    Lm89TypeStatusLhigh get ();
}
member StatusLHIGH : Lm89TypeStatusLhigh with get

Property Value

Type: Lm89TypeStatusLhigh
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.StatusLLOW Property

IRD

Lm89StatusLLOW Property

Status: LLOW

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm89TypeStatusLlow StatusLLOW { get; }
Public ReadOnly Property StatusLLOW As Lm89TypeStatusLlow
    Get
public:
property Lm89TypeStatusLlow StatusLLOW {
    Lm89TypeStatusLlow get ();
}
member StatusLLOW : Lm89TypeStatusLlow with get

Property Value

Type: Lm89TypeStatusLlow
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.StatusOPEN Property

IRD

Lm89StatusOPEN Property

Status: OPEN

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm89TypeStatusOpen StatusOPEN { get; }
Public ReadOnly Property StatusOPEN As Lm89TypeStatusOpen
    Get
public:
property Lm89TypeStatusOpen StatusOPEN {
    Lm89TypeStatusOpen get ();
}
member StatusOPEN : Lm89TypeStatusOpen with get

Property Value

Type: Lm89TypeStatusOpen
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.StatusRCRIT Property

IRD

Lm89StatusRCRIT Property

Status: RCRIT

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm89TypeStatusRcrit StatusRCRIT { get; }
Public ReadOnly Property StatusRCRIT As Lm89TypeStatusRcrit
    Get
public:
property Lm89TypeStatusRcrit StatusRCRIT {
    Lm89TypeStatusRcrit get ();
}
member StatusRCRIT : Lm89TypeStatusRcrit with get

Property Value

Type: Lm89TypeStatusRcrit
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.StatusRHIGH Property

IRD

Lm89StatusRHIGH Property

Status: RHIGH

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm89TypeStatusRhigh StatusRHIGH { get; }
Public ReadOnly Property StatusRHIGH As Lm89TypeStatusRhigh
    Get
public:
property Lm89TypeStatusRhigh StatusRHIGH {
    Lm89TypeStatusRhigh get ();
}
member StatusRHIGH : Lm89TypeStatusRhigh with get

Property Value

Type: Lm89TypeStatusRhigh
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.StatusRLOW Property

IRD

Lm89StatusRLOW Property

Status: RLOW

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm89TypeStatusRlow StatusRLOW { get; }
Public ReadOnly Property StatusRLOW As Lm89TypeStatusRlow
    Get
public:
property Lm89TypeStatusRlow StatusRLOW {
    Lm89TypeStatusRlow get ();
}
member StatusRLOW : Lm89TypeStatusRlow with get

Property Value

Type: Lm89TypeStatusRlow
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.SteppingOrDieRevisionCode Property

IRD

Lm89SteppingOrDieRevisionCode Property

Stepping Or Die Revision Code

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SteppingOrDieRevisionCode { get; }
Public ReadOnly Property SteppingOrDieRevisionCode As Byte
    Get
public:
property unsigned char SteppingOrDieRevisionCode {
    unsigned char get ();
}
member SteppingOrDieRevisionCode : byte with get

Property Value

Type: Byte
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.TCRITHysteresis Property

IRD

Lm89TCRITHysteresis Property

T_CRIT Hysteresis (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TCRITHysteresis { get; set; }
Public Property TCRITHysteresis As Byte
    Get
    Set
public:
property unsigned char TCRITHysteresis {
    unsigned char get ();
    void set (unsigned char value);
}
member TCRITHysteresis : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89 Methods

The Lm89 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.Flush Method

IRD

Lm89Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.OneShot Method

IRD

Lm89OneShot Method

One Shot

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void OneShot()
Public Sub OneShot
public:
void OneShot()
member OneShot : unit -> unit
See Also

Reference

Lm89 Class
telos.Ird.NationalSemiconductor Namespace


Lm89.TypeAlertConfigure Enumeration

IRD

Lm89TypeAlertConfigure Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlertConfigure
Public Enumeration TypeAlertConfigure
public enum class TypeAlertConfigure
type TypeAlertConfigure
Members
Member name | Value | Description
ComparatorModeDisabled | 0 | Comparator Mode: Disabled
ComparatorModeEnabled | 1 | Comparator Mode: Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm89.TypeConfigurationAlertMask Enumeration

IRD

Lm89TypeConfigurationAlertMask Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationAlertMask
Public Enumeration TypeConfigurationAlertMask
public enum class TypeConfigurationAlertMask
type TypeConfigurationAlertMask
Members
Member name | Value | Description
ALERTInterruptsNotMasked | 0 | ALERT Interrupts: Not Masked
ALERTInterruptsMasked | 1 | ALERT Interrupts: Masked
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm89.TypeConfigurationFaultQueue Enumeration

IRD

Lm89TypeConfigurationFaultQueue Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationFaultQueue
Public Enumeration TypeConfigurationFaultQueue
public enum class TypeConfigurationFaultQueue
type TypeConfigurationFaultQueue
Members
Member name | Value | Description
OutsideLimitDoNoTrigger | 0 | Outside Limit: Do No Trigger
OutsideLimitTrigger | 1 | Outside Limit: Trigger
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm89.TypeConfigurationLocalTCritMask Enumeration

IRD

Lm89TypeConfigurationLocalTCritMask Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationLocalTCritMask
Public Enumeration TypeConfigurationLocalTCritMask
public enum class TypeConfigurationLocalTCritMask
type TypeConfigurationLocalTCritMask
Members
Member name | Value | Description
TCRITADoNotTrigger | 0 | T_CRIT_A: Do Not Trigger
TCRITATrigger | 1 | T_CRIT_A: Trigger
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm89.TypeConfigurationRemoteTCritMask Enumeration

IRD

Lm89TypeConfigurationRemoteTCritMask Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationRemoteTCritMask
Public Enumeration TypeConfigurationRemoteTCritMask
public enum class TypeConfigurationRemoteTCritMask
type TypeConfigurationRemoteTCritMask
Members
Member name | Value | Description
TCRITADoNotTrigger | 0 | T_CRIT_A: Do Not Trigger
TCRITATrigger | 1 | T_CRIT_A: Trigger
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm89.TypeConfigurationRunStop Enumeration

IRD

Lm89TypeConfigurationRunStop Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationRunStop
Public Enumeration TypeConfigurationRunStop
public enum class TypeConfigurationRunStop
type TypeConfigurationRunStop
Members
Member name | Value | Description
Running | 0 | Running
Shutdown | 1 | Shutdown
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm89.TypeConversionRate Enumeration

IRD

Lm89TypeConversionRate Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConversionRate
Public Enumeration TypeConversionRate
public enum class TypeConversionRate
type TypeConversionRate
Members
Member name | Value | Description
Value_625MHz | 0 | 62.5 mHz
Value_125MHz | 1 | 125 mHz
Value_250MHz | 2 | 250 mHz
Value_500MHz | 3 | 500 mHz
Value_1Hz | 4 | 1 Hz
Value_2Hz | 5 | 2 Hz
Value_4Hz | 6 | 4 Hz
Value_8Hz | 7 | 8 Hz
Value_16Hz | 8 | 16 Hz
Value_32Hz | 9 | 32 Hz
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm89.TypeFilterLevel Enumeration

IRD

Lm89TypeFilterLevel Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFilterLevel
Public Enumeration TypeFilterLevel
public enum class TypeFilterLevel
type TypeFilterLevel
Members
Member name | Value | Description
NoFilter | 0 | No Filter
Level1 | 1 | Level 1
Level2 | 2 | Level 2
Level3 | 3 | Level 3
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm89.TypeStatusBusy Enumeration

IRD

Lm89TypeStatusBusy Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusBusy
Public Enumeration TypeStatusBusy
public enum class TypeStatusBusy
type TypeStatusBusy
Members
Member name | Value | Description
ADCNotBusy | 0 | ADC: Not Busy
ADCBusy | 1 | ADC: Busy
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm89.TypeStatusLcrit Enumeration

IRD

Lm89TypeStatusLcrit Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusLcrit
Public Enumeration TypeStatusLcrit
public enum class TypeStatusLcrit
type TypeStatusLcrit
Members
Member name | Value | Description
LocalCriticalTemperatureNoAlarm | 0 | Local Critical Temperature: No Alarm
LocalCriticalTemperatureAlarm | 1 | Local Critical Temperature: Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm89.TypeStatusLhigh Enumeration

IRD

Lm89TypeStatusLhigh Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusLhigh
Public Enumeration TypeStatusLhigh
public enum class TypeStatusLhigh
type TypeStatusLhigh
Members
Member name | Value | Description
LocalHIGHTemperatureNoAlarm | 0 | Local HIGH Temperature: No Alarm
LocalHIGHTemperatureAlarm | 1 | Local HIGH Temperature: Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm89.TypeStatusLlow Enumeration

IRD

Lm89TypeStatusLlow Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusLlow
Public Enumeration TypeStatusLlow
public enum class TypeStatusLlow
type TypeStatusLlow
Members
Member name | Value | Description
LocalLOWTemperatureNoAlarm | 0 | Local LOW Temperature: No Alarm
LocalLOWTemperatureAlarm | 1 | Local LOW Temperature: Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm89.TypeStatusOpen Enumeration

IRD

Lm89TypeStatusOpen Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusOpen
Public Enumeration TypeStatusOpen
public enum class TypeStatusOpen
type TypeStatusOpen
Members
Member name | Value | Description
RemoteDiodeConnected | 0 | Remote Diode: Connected
RemoteDiodeDisconnected | 1 | Remote Diode: Disconnected
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm89.TypeStatusRcrit Enumeration

IRD

Lm89TypeStatusRcrit Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusRcrit
Public Enumeration TypeStatusRcrit
public enum class TypeStatusRcrit
type TypeStatusRcrit
Members
Member name | Value | Description
RemoteDiodeCriticalTemperatureNoAlarm | 0 | Remote Diode Critical Temperature: No Alarm
RemoteDiodeCriticalTemperatureAlarm | 1 | Remote Diode Critical Temperature: Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm89.TypeStatusRhigh Enumeration

IRD

Lm89TypeStatusRhigh Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusRhigh
Public Enumeration TypeStatusRhigh
public enum class TypeStatusRhigh
type TypeStatusRhigh
Members
Member name | Value | Description
RemoteDiodeHighTemperatureNoAlarm | 0 | Remote Diode High Temperature: No Alarm
RemoteDiodeHighTemperatureAlarm | 1 | Remote Diode High Temperature: Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm89.TypeStatusRlow Enumeration

IRD

Lm89TypeStatusRlow Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusRlow
Public Enumeration TypeStatusRlow
public enum class TypeStatusRlow
type TypeStatusRlow
Members
Member name | Value | Description
RemoteDiodeLOWTemperatureNoAlarm | 0 | Remote Diode LOW Temperature: No Alarm
RemoteDiodeLOWTemperatureAlarm | 1 | Remote Diode LOW Temperature: Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm92 Class

National Semiconductor: LM 92
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm92

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm92
Public Class Lm92
public ref class Lm92
type Lm92 =  class end

The Lm92 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm92 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationINTMode | Configuration: INT Mode
Public property | ConfigurationINTPolarity | Configuration: INT Polarity
Public property | ConfigurationShutdown | Configuration: Shutdown
Public property | ConfigurationTCRITAPolarity | Configuration: T_CRIT_A Polarity
Public property | ManufacturerSID | Manufacturer's ID
Public property | StatusCRIT | Status: CRIT
Public property | StatusHIGH | Status: HIGH
Public property | StatusLOW | Status: LOW
Public property | TCRIT | T_CRIT (unit: °C)
Public property | Temperature | Temperature (unit: °C)
Public property | THIGH | T_HIGH (unit: °C)
Public property | THYST | T_HYST (unit: °C)
Public property | TLOW | T_LOW (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
±0.33°C Accurate, 12-Bit + Sign Temperature Sensor and Thermal Window Comparator with Two-Wire Interface
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm92 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm92(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm92(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm92

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92 Properties

The Lm92 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationINTMode | Configuration: INT Mode
Public property | ConfigurationINTPolarity | Configuration: INT Polarity
Public property | ConfigurationShutdown | Configuration: Shutdown
Public property | ConfigurationTCRITAPolarity | Configuration: T_CRIT_A Polarity
Public property | ManufacturerSID | Manufacturer's ID
Public property | StatusCRIT | Status: CRIT
Public property | StatusHIGH | Status: HIGH
Public property | StatusLOW | Status: LOW
Public property | TCRIT | T_CRIT (unit: °C)
Public property | Temperature | Temperature (unit: °C)
Public property | THIGH | T_HIGH (unit: °C)
Public property | THYST | T_HYST (unit: °C)
Public property | TLOW | T_LOW (unit: °C)
Top
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92.AutoFlush Property

IRD

Lm92AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92.ConfigurationFaultQueue Property

IRD

Lm92ConfigurationFaultQueue Property

Configuration: Fault Queue

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm92TypeConfigFaultQueue ConfigurationFaultQueue { get; set; }
Public Property ConfigurationFaultQueue As Lm92TypeConfigFaultQueue
    Get
    Set
public:
property Lm92TypeConfigFaultQueue ConfigurationFaultQueue {
    Lm92TypeConfigFaultQueue get ();
    void set (Lm92TypeConfigFaultQueue value);
}
member ConfigurationFaultQueue : Lm92TypeConfigFaultQueue with get, set

Property Value

Type: Lm92TypeConfigFaultQueue
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92.ConfigurationINTMode Property

IRD

Lm92ConfigurationINTMode Property

Configuration: INT Mode

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm92TypeConfigIntMode ConfigurationINTMode { get; set; }
Public Property ConfigurationINTMode As Lm92TypeConfigIntMode
    Get
    Set
public:
property Lm92TypeConfigIntMode ConfigurationINTMode {
    Lm92TypeConfigIntMode get ();
    void set (Lm92TypeConfigIntMode value);
}
member ConfigurationINTMode : Lm92TypeConfigIntMode with get, set

Property Value

Type: Lm92TypeConfigIntMode
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92.ConfigurationINTPolarity Property

IRD

Lm92ConfigurationINTPolarity Property

Configuration: INT Polarity

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm92TypeConfigPolarity ConfigurationINTPolarity { get; set; }
Public Property ConfigurationINTPolarity As Lm92TypeConfigPolarity
    Get
    Set
public:
property Lm92TypeConfigPolarity ConfigurationINTPolarity {
    Lm92TypeConfigPolarity get ();
    void set (Lm92TypeConfigPolarity value);
}
member ConfigurationINTPolarity : Lm92TypeConfigPolarity with get, set

Property Value

Type: Lm92TypeConfigPolarity
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92.ConfigurationShutdown Property

IRD

Lm92ConfigurationShutdown Property

Configuration: Shutdown

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm92TypeConfigShutdown ConfigurationShutdown { get; set; }
Public Property ConfigurationShutdown As Lm92TypeConfigShutdown
    Get
    Set
public:
property Lm92TypeConfigShutdown ConfigurationShutdown {
    Lm92TypeConfigShutdown get ();
    void set (Lm92TypeConfigShutdown value);
}
member ConfigurationShutdown : Lm92TypeConfigShutdown with get, set

Property Value

Type: Lm92TypeConfigShutdown
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92.ConfigurationTCRITAPolarity Property

IRD

Lm92ConfigurationTCRITAPolarity Property

Configuration: T_CRIT_A Polarity

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm92TypeConfigPolarity ConfigurationTCRITAPolarity { get; set; }
Public Property ConfigurationTCRITAPolarity As Lm92TypeConfigPolarity
    Get
    Set
public:
property Lm92TypeConfigPolarity ConfigurationTCRITAPolarity {
    Lm92TypeConfigPolarity get ();
    void set (Lm92TypeConfigPolarity value);
}
member ConfigurationTCRITAPolarity : Lm92TypeConfigPolarity with get, set

Property Value

Type: Lm92TypeConfigPolarity
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92.ManufacturerSID Property

IRD

Lm92ManufacturerSID Property

Manufacturer's ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ManufacturerSID { get; }
Public ReadOnly Property ManufacturerSID As UShort
    Get
public:
property unsigned short ManufacturerSID {
    unsigned short get ();
}
member ManufacturerSID : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92.StatusCRIT Property

IRD

Lm92StatusCRIT Property

Status: CRIT

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm92TypeTriggered StatusCRIT { get; }
Public ReadOnly Property StatusCRIT As Lm92TypeTriggered
    Get
public:
property Lm92TypeTriggered StatusCRIT {
    Lm92TypeTriggered get ();
}
member StatusCRIT : Lm92TypeTriggered with get

Property Value

Type: Lm92TypeTriggered
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92.StatusHIGH Property

IRD

Lm92StatusHIGH Property

Status: HIGH

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm92TypeTriggered StatusHIGH { get; }
Public ReadOnly Property StatusHIGH As Lm92TypeTriggered
    Get
public:
property Lm92TypeTriggered StatusHIGH {
    Lm92TypeTriggered get ();
}
member StatusHIGH : Lm92TypeTriggered with get

Property Value

Type: Lm92TypeTriggered
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92.StatusLOW Property

IRD

Lm92StatusLOW Property

Status: LOW

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm92TypeTriggered StatusLOW { get; }
Public ReadOnly Property StatusLOW As Lm92TypeTriggered
    Get
public:
property Lm92TypeTriggered StatusLOW {
    Lm92TypeTriggered get ();
}
member StatusLOW : Lm92TypeTriggered with get

Property Value

Type: Lm92TypeTriggered
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92.TCRIT Property

IRD

Lm92TCRIT Property

T_CRIT (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TCRIT { get; set; }
Public Property TCRIT As Double
    Get
    Set
public:
property double TCRIT {
    double get ();
    void set (double value);
}
member TCRIT : float with get, set

Property Value

Type: Double
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92.Temperature Property

IRD

Lm92Temperature Property

Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92.THIGH Property

IRD

Lm92THIGH Property

T_HIGH (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double THIGH { get; set; }
Public Property THIGH As Double
    Get
    Set
public:
property double THIGH {
    double get ();
    void set (double value);
}
member THIGH : float with get, set

Property Value

Type: Double
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92.THYST Property

IRD

Lm92THYST Property

T_HYST (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double THYST { get; set; }
Public Property THYST As Double
    Get
    Set
public:
property double THYST {
    double get ();
    void set (double value);
}
member THYST : float with get, set

Property Value

Type: Double
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92.TLOW Property

IRD

Lm92TLOW Property

T_LOW (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TLOW { get; set; }
Public Property TLOW As Double
    Get
    Set
public:
property double TLOW {
    double get ();
    void set (double value);
}
member TLOW : float with get, set

Property Value

Type: Double
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92 Methods

The Lm92 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92.Flush Method

IRD

Lm92Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm92 Class
telos.Ird.NationalSemiconductor Namespace


Lm92.TypeConfigFaultQueue Enumeration

IRD

Lm92TypeConfigFaultQueue Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigFaultQueue
Public Enumeration TypeConfigFaultQueue
public enum class TypeConfigFaultQueue
type TypeConfigFaultQueue
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm92.TypeConfigIntMode Enumeration

IRD

Lm92TypeConfigIntMode Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigIntMode
Public Enumeration TypeConfigIntMode
public enum class TypeConfigIntMode
type TypeConfigIntMode
Members
Member name | Value | Description
ComparatorInterruptMode | 0 | Comparator Interrupt Mode
EventInterruptMode | 1 | Event Interrupt Mode
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm92.TypeConfigPolarity Enumeration

IRD

Lm92TypeConfigPolarity Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigPolarity
Public Enumeration TypeConfigPolarity
public enum class TypeConfigPolarity
type TypeConfigPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm92.TypeConfigShutdown Enumeration

IRD

Lm92TypeConfigShutdown Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigShutdown
Public Enumeration TypeConfigShutdown
public enum class TypeConfigShutdown
type TypeConfigShutdown
Members
Member name | Value | Description
NormalMode | 0 | Normal Mode
LowPowerShutdownMode | 1 | Low Power Shutdown Mode
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm92.TypeTriggered Enumeration

IRD

Lm92TypeTriggered Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTriggered
Public Enumeration TypeTriggered
public enum class TypeTriggered
type TypeTriggered
Members
Member name | Value | Description
NotTriggered | 0 | Not Triggered
Triggered | 1 | Triggered
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95213 Class

National Semiconductor: LM 95213
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm95213

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm95213
Public Class Lm95213
public ref class Lm95213
type Lm95213 =  class end

The Lm95213 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm95213 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelConversionEnableLocal | Channel Conversion Enable: Local
Public property | ChannelConversionEnableRemote1 | Channel Conversion Enable: Remote 1
Public property | ChannelConversionEnableRemote2 | Channel Conversion Enable: Remote 2
Public property | CommonStatusBusy | Common Status: Busy
Public property | CommonStatusNR | Common Status: NR
Public property | CommonStatusStatusRegister1Flag | Common Status: Status Register 1 Flag
Public property | CommonStatusStatusRegister2Flag | Common Status: Status Register 2 Flag
Public property | CommonStatusStatusRegister3Flag | Common Status: Status Register 3 Flag
Public property | CommonStatusStatusRegister4Flag | Common Status: Status Register 4 Flag
Public property | CommonTCRITHysteresis | Common TCRIT Hysteresis (unit: °C)
Public property | ConfigurationStandby | Configuration: Standby
Public property | ConversionRate | Conversion Rate
Public property | FilterSettingRemote1 | Filter Setting: Remote 1
Public property | FilterSettingRemote2 | Filter Setting: Remote 2
Public property | LocalTCRITLimit | Local TCRIT Limit (unit: °C)
Public property | LocalTemp | Local Temp (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | Remote1Offset | Remote 1 Offset (unit: °C)
Public property | Remote1TCRIT1Limit | Remote 1 TCRIT-1 Limit (unit: °C)
Public property | Remote1TCRIT2AndTCRIT3Limit | Remote 1 TCRIT-2 and TCRIT-3 Limit (unit: °C)
Public property | Remote2Offset | Remote 2 Offset (unit: °C)
Public property | Remote2TCRIT1Limit | Remote 2 TCRIT-1 Limit (unit: °C)
Public property | Remote2TCRIT2AndTCRIT3Limit | Remote 2 TCRIT-2 and TCRIT-3 Limit (unit: °C)
Public property | RemoteTemp1Signed | Remote Temp 1 - Signed (unit: °C)
Public property | RemoteTemp1Unsigned | Remote Temp 1 - Unsigned (unit: °C)
Public property | RemoteTemp2Signed | Remote Temp 2 - Signed (unit: °C)
Public property | RemoteTemp2Unsigned | Remote Temp 2 - Unsigned (unit: °C)
Public property | RevisionID | Revision ID
Public property | StatusRemote1DiodeOpenFault | Status: Remote 1 Diode Open Fault
Public property | StatusRemote1DiodeShortFault | Status: Remote 1 Diode Short Fault
Public property | StatusRemote2DiodeOpenFault | Status: Remote 2 Diode Open Fault
Public property | StatusRemote2DiodeShortFault | Status: Remote 2 Diode Short Fault
Public property | StatusTCRIT1Local | Status TCRIT1: Local
Public property | StatusTCRIT1Remote1 | Status TCRIT1: Remote 1
Public property | StatusTCRIT1Remote2 | Status TCRIT1: Remote 2
Public property | StatusTCRIT2Local | Status TCRIT2: Local
Public property | StatusTCRIT2Remote1 | Status TCRIT2: Remote 1
Public property | StatusTCRIT2Remote2 | Status TCRIT2: Remote 2
Public property | StatusTCRIT3Local | Status TCRIT3: Local
Public property | StatusTCRIT3Remote1 | Status TCRIT3: Remote 1
Public property | StatusTCRIT3Remote2 | Status TCRIT3: Remote 2
Public property | TCRIT1MaskLocal | TCRIT1 Mask: Local
Public property | TCRIT1MaskRemote1 | TCRIT1 Mask: Remote 1
Public property | TCRIT1MaskRemote2 | TCRIT1 Mask: Remote 2
Public property | TCRIT2MaskLocal | TCRIT2 Mask: Local
Public property | TCRIT2MaskRemote1 | TCRIT2 Mask: Remote 1
Public property | TCRIT2MaskRemote2 | TCRIT2 Mask: Remote 2
Public property | TCRIT3MaskLocal | TCRIT3 Mask: Local
Public property | TCRIT3MaskRemote1 | TCRIT3 Mask: Remote 1
Public property | TCRIT3MaskRemote2 | TCRIT3 Mask: Remote 2
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Method_1Shot | 1-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
2-Diode Input and Local Digital Temperature Sensor with Two-Wire Interface and TCRIT Outputs
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95213 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm95213(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm95213

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213 Properties

The Lm95213 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelConversionEnableLocal | Channel Conversion Enable: Local
Public property | ChannelConversionEnableRemote1 | Channel Conversion Enable: Remote 1
Public property | ChannelConversionEnableRemote2 | Channel Conversion Enable: Remote 2
Public property | CommonStatusBusy | Common Status: Busy
Public property | CommonStatusNR | Common Status: NR
Public property | CommonStatusStatusRegister1Flag | Common Status: Status Register 1 Flag
Public property | CommonStatusStatusRegister2Flag | Common Status: Status Register 2 Flag
Public property | CommonStatusStatusRegister3Flag | Common Status: Status Register 3 Flag
Public property | CommonStatusStatusRegister4Flag | Common Status: Status Register 4 Flag
Public property | CommonTCRITHysteresis | Common TCRIT Hysteresis (unit: °C)
Public property | ConfigurationStandby | Configuration: Standby
Public property | ConversionRate | Conversion Rate
Public property | FilterSettingRemote1 | Filter Setting: Remote 1
Public property | FilterSettingRemote2 | Filter Setting: Remote 2
Public property | LocalTCRITLimit | Local TCRIT Limit (unit: °C)
Public property | LocalTemp | Local Temp (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | Remote1Offset | Remote 1 Offset (unit: °C)
Public property | Remote1TCRIT1Limit | Remote 1 TCRIT-1 Limit (unit: °C)
Public property | Remote1TCRIT2AndTCRIT3Limit | Remote 1 TCRIT-2 and TCRIT-3 Limit (unit: °C)
Public property | Remote2Offset | Remote 2 Offset (unit: °C)
Public property | Remote2TCRIT1Limit | Remote 2 TCRIT-1 Limit (unit: °C)
Public property | Remote2TCRIT2AndTCRIT3Limit | Remote 2 TCRIT-2 and TCRIT-3 Limit (unit: °C)
Public property | RemoteTemp1Signed | Remote Temp 1 - Signed (unit: °C)
Public property | RemoteTemp1Unsigned | Remote Temp 1 - Unsigned (unit: °C)
Public property | RemoteTemp2Signed | Remote Temp 2 - Signed (unit: °C)
Public property | RemoteTemp2Unsigned | Remote Temp 2 - Unsigned (unit: °C)
Public property | RevisionID | Revision ID
Public property | StatusRemote1DiodeOpenFault | Status: Remote 1 Diode Open Fault
Public property | StatusRemote1DiodeShortFault | Status: Remote 1 Diode Short Fault
Public property | StatusRemote2DiodeOpenFault | Status: Remote 2 Diode Open Fault
Public property | StatusRemote2DiodeShortFault | Status: Remote 2 Diode Short Fault
Public property | StatusTCRIT1Local | Status TCRIT1: Local
Public property | StatusTCRIT1Remote1 | Status TCRIT1: Remote 1
Public property | StatusTCRIT1Remote2 | Status TCRIT1: Remote 2
Public property | StatusTCRIT2Local | Status TCRIT2: Local
Public property | StatusTCRIT2Remote1 | Status TCRIT2: Remote 1
Public property | StatusTCRIT2Remote2 | Status TCRIT2: Remote 2
Public property | StatusTCRIT3Local | Status TCRIT3: Local
Public property | StatusTCRIT3Remote1 | Status TCRIT3: Remote 1
Public property | StatusTCRIT3Remote2 | Status TCRIT3: Remote 2
Public property | TCRIT1MaskLocal | TCRIT1 Mask: Local
Public property | TCRIT1MaskRemote1 | TCRIT1 Mask: Remote 1
Public property | TCRIT1MaskRemote2 | TCRIT1 Mask: Remote 2
Public property | TCRIT2MaskLocal | TCRIT2 Mask: Local
Public property | TCRIT2MaskRemote1 | TCRIT2 Mask: Remote 1
Public property | TCRIT2MaskRemote2 | TCRIT2 Mask: Remote 2
Public property | TCRIT3MaskLocal | TCRIT3 Mask: Local
Public property | TCRIT3MaskRemote1 | TCRIT3 Mask: Remote 1
Public property | TCRIT3MaskRemote2 | TCRIT3 Mask: Remote 2
Top
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.AutoFlush Property

IRD

Lm95213AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.ChannelConversionEnableLocal Property

IRD

Lm95213ChannelConversionEnableLocal Property

Channel Conversion Enable: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeChannelConversionEnable ChannelConversionEnableLocal { get; set; }
Public Property ChannelConversionEnableLocal As Lm95213TypeChannelConversionEnable
    Get
    Set
public:
property Lm95213TypeChannelConversionEnable ChannelConversionEnableLocal {
    Lm95213TypeChannelConversionEnable get ();
    void set (Lm95213TypeChannelConversionEnable value);
}
member ChannelConversionEnableLocal : Lm95213TypeChannelConversionEnable with get, set

Property Value

Type: Lm95213TypeChannelConversionEnable
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.ChannelConversionEnableRemote1 Property

IRD

Lm95213ChannelConversionEnableRemote1 Property

Channel Conversion Enable: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeChannelConversionEnable ChannelConversionEnableRemote1 { get; set; }
Public Property ChannelConversionEnableRemote1 As Lm95213TypeChannelConversionEnable
    Get
    Set
public:
property Lm95213TypeChannelConversionEnable ChannelConversionEnableRemote1 {
    Lm95213TypeChannelConversionEnable get ();
    void set (Lm95213TypeChannelConversionEnable value);
}
member ChannelConversionEnableRemote1 : Lm95213TypeChannelConversionEnable with get, set

Property Value

Type: Lm95213TypeChannelConversionEnable
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.ChannelConversionEnableRemote2 Property

IRD

Lm95213ChannelConversionEnableRemote2 Property

Channel Conversion Enable: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeChannelConversionEnable ChannelConversionEnableRemote2 { get; set; }
Public Property ChannelConversionEnableRemote2 As Lm95213TypeChannelConversionEnable
    Get
    Set
public:
property Lm95213TypeChannelConversionEnable ChannelConversionEnableRemote2 {
    Lm95213TypeChannelConversionEnable get ();
    void set (Lm95213TypeChannelConversionEnable value);
}
member ChannelConversionEnableRemote2 : Lm95213TypeChannelConversionEnable with get, set

Property Value

Type: Lm95213TypeChannelConversionEnable
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.CommonStatusBusy Property

IRD

Lm95213CommonStatusBusy Property

Common Status: Busy

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeCommonStatusBusy CommonStatusBusy { get; }
Public ReadOnly Property CommonStatusBusy As Lm95213TypeCommonStatusBusy
    Get
public:
property Lm95213TypeCommonStatusBusy CommonStatusBusy {
    Lm95213TypeCommonStatusBusy get ();
}
member CommonStatusBusy : Lm95213TypeCommonStatusBusy with get

Property Value

Type: Lm95213TypeCommonStatusBusy
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.CommonStatusNR Property

IRD

Lm95213CommonStatusNR Property

Common Status: NR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeCommonStatusNr CommonStatusNR { get; }
Public ReadOnly Property CommonStatusNR As Lm95213TypeCommonStatusNr
    Get
public:
property Lm95213TypeCommonStatusNr CommonStatusNR {
    Lm95213TypeCommonStatusNr get ();
}
member CommonStatusNR : Lm95213TypeCommonStatusNr with get

Property Value

Type: Lm95213TypeCommonStatusNr
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.CommonStatusStatusRegister1Flag Property

IRD

Lm95213CommonStatusStatusRegister1Flag Property

Common Status: Status Register 1 Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeCommonStatusSr CommonStatusStatusRegister1Flag { get; }
Public ReadOnly Property CommonStatusStatusRegister1Flag As Lm95213TypeCommonStatusSr
    Get
public:
property Lm95213TypeCommonStatusSr CommonStatusStatusRegister1Flag {
    Lm95213TypeCommonStatusSr get ();
}
member CommonStatusStatusRegister1Flag : Lm95213TypeCommonStatusSr with get

Property Value

Type: Lm95213TypeCommonStatusSr
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.CommonStatusStatusRegister2Flag Property

IRD

Lm95213CommonStatusStatusRegister2Flag Property

Common Status: Status Register 2 Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeCommonStatusSr CommonStatusStatusRegister2Flag { get; }
Public ReadOnly Property CommonStatusStatusRegister2Flag As Lm95213TypeCommonStatusSr
    Get
public:
property Lm95213TypeCommonStatusSr CommonStatusStatusRegister2Flag {
    Lm95213TypeCommonStatusSr get ();
}
member CommonStatusStatusRegister2Flag : Lm95213TypeCommonStatusSr with get

Property Value

Type: Lm95213TypeCommonStatusSr
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.CommonStatusStatusRegister3Flag Property

IRD

Lm95213CommonStatusStatusRegister3Flag Property

Common Status: Status Register 3 Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeCommonStatusSr CommonStatusStatusRegister3Flag { get; }
Public ReadOnly Property CommonStatusStatusRegister3Flag As Lm95213TypeCommonStatusSr
    Get
public:
property Lm95213TypeCommonStatusSr CommonStatusStatusRegister3Flag {
    Lm95213TypeCommonStatusSr get ();
}
member CommonStatusStatusRegister3Flag : Lm95213TypeCommonStatusSr with get

Property Value

Type: Lm95213TypeCommonStatusSr
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.CommonStatusStatusRegister4Flag Property

IRD

Lm95213CommonStatusStatusRegister4Flag Property

Common Status: Status Register 4 Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeCommonStatusSr CommonStatusStatusRegister4Flag { get; }
Public ReadOnly Property CommonStatusStatusRegister4Flag As Lm95213TypeCommonStatusSr
    Get
public:
property Lm95213TypeCommonStatusSr CommonStatusStatusRegister4Flag {
    Lm95213TypeCommonStatusSr get ();
}
member CommonStatusStatusRegister4Flag : Lm95213TypeCommonStatusSr with get

Property Value

Type: Lm95213TypeCommonStatusSr
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.CommonTCRITHysteresis Property

IRD

Lm95213CommonTCRITHysteresis Property

Common TCRIT Hysteresis (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CommonTCRITHysteresis { get; set; }
Public Property CommonTCRITHysteresis As Byte
    Get
    Set
public:
property unsigned char CommonTCRITHysteresis {
    unsigned char get ();
    void set (unsigned char value);
}
member CommonTCRITHysteresis : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.ConfigurationStandby Property

IRD

Lm95213ConfigurationStandby Property

Configuration: Standby

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeConfigurationStby ConfigurationStandby { get; set; }
Public Property ConfigurationStandby As Lm95213TypeConfigurationStby
    Get
    Set
public:
property Lm95213TypeConfigurationStby ConfigurationStandby {
    Lm95213TypeConfigurationStby get ();
    void set (Lm95213TypeConfigurationStby value);
}
member ConfigurationStandby : Lm95213TypeConfigurationStby with get, set

Property Value

Type: Lm95213TypeConfigurationStby
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.ConversionRate Property

IRD

Lm95213ConversionRate Property

Conversion Rate

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeConversionRate ConversionRate { get; set; }
Public Property ConversionRate As Lm95213TypeConversionRate
    Get
    Set
public:
property Lm95213TypeConversionRate ConversionRate {
    Lm95213TypeConversionRate get ();
    void set (Lm95213TypeConversionRate value);
}
member ConversionRate : Lm95213TypeConversionRate with get, set

Property Value

Type: Lm95213TypeConversionRate
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.FilterSettingRemote1 Property

IRD

Lm95213FilterSettingRemote1 Property

Filter Setting: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeFilterSetting FilterSettingRemote1 { get; set; }
Public Property FilterSettingRemote1 As Lm95213TypeFilterSetting
    Get
    Set
public:
property Lm95213TypeFilterSetting FilterSettingRemote1 {
    Lm95213TypeFilterSetting get ();
    void set (Lm95213TypeFilterSetting value);
}
member FilterSettingRemote1 : Lm95213TypeFilterSetting with get, set

Property Value

Type: Lm95213TypeFilterSetting
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.FilterSettingRemote2 Property

IRD

Lm95213FilterSettingRemote2 Property

Filter Setting: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeFilterSetting FilterSettingRemote2 { get; set; }
Public Property FilterSettingRemote2 As Lm95213TypeFilterSetting
    Get
    Set
public:
property Lm95213TypeFilterSetting FilterSettingRemote2 {
    Lm95213TypeFilterSetting get ();
    void set (Lm95213TypeFilterSetting value);
}
member FilterSettingRemote2 : Lm95213TypeFilterSetting with get, set

Property Value

Type: Lm95213TypeFilterSetting
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.LocalTCRITLimit Property

IRD

Lm95213LocalTCRITLimit Property

Local TCRIT Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalTCRITLimit { get; set; }
Public Property LocalTCRITLimit As Byte
    Get
    Set
public:
property unsigned char LocalTCRITLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member LocalTCRITLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.LocalTemp Property

IRD

Lm95213LocalTemp Property

Local Temp (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LocalTemp { get; }
Public ReadOnly Property LocalTemp As Double
    Get
public:
property double LocalTemp {
    double get ();
}
member LocalTemp : float with get

Property Value

Type: Double
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.ManufacturerID Property

IRD

Lm95213ManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As Byte
    Get
public:
property unsigned char ManufacturerID {
    unsigned char get ();
}
member ManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.Remote1Offset Property

IRD

Lm95213Remote1Offset Property

Remote 1 Offset (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote1Offset { get; set; }
Public Property Remote1Offset As Double
    Get
    Set
public:
property double Remote1Offset {
    double get ();
    void set (double value);
}
member Remote1Offset : float with get, set

Property Value

Type: Double
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.Remote1TCRIT1Limit Property

IRD

Lm95213Remote1TCRIT1Limit Property

Remote 1 TCRIT-1 Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote1TCRIT1Limit { get; set; }
Public Property Remote1TCRIT1Limit As Byte
    Get
    Set
public:
property unsigned char Remote1TCRIT1Limit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote1TCRIT1Limit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.Remote1TCRIT2AndTCRIT3Limit Property

IRD

Lm95213Remote1TCRIT2AndTCRIT3Limit Property

Remote 1 TCRIT-2 and TCRIT-3 Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote1TCRIT2AndTCRIT3Limit { get; set; }
Public Property Remote1TCRIT2AndTCRIT3Limit As Byte
    Get
    Set
public:
property unsigned char Remote1TCRIT2AndTCRIT3Limit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote1TCRIT2AndTCRIT3Limit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.Remote2Offset Property

IRD

Lm95213Remote2Offset Property

Remote 2 Offset (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote2Offset { get; set; }
Public Property Remote2Offset As Double
    Get
    Set
public:
property double Remote2Offset {
    double get ();
    void set (double value);
}
member Remote2Offset : float with get, set

Property Value

Type: Double
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.Remote2TCRIT1Limit Property

IRD

Lm95213Remote2TCRIT1Limit Property

Remote 2 TCRIT-1 Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote2TCRIT1Limit { get; set; }
Public Property Remote2TCRIT1Limit As Byte
    Get
    Set
public:
property unsigned char Remote2TCRIT1Limit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote2TCRIT1Limit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.Remote2TCRIT2AndTCRIT3Limit Property

IRD

Lm95213Remote2TCRIT2AndTCRIT3Limit Property

Remote 2 TCRIT-2 and TCRIT-3 Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote2TCRIT2AndTCRIT3Limit { get; set; }
Public Property Remote2TCRIT2AndTCRIT3Limit As Byte
    Get
    Set
public:
property unsigned char Remote2TCRIT2AndTCRIT3Limit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote2TCRIT2AndTCRIT3Limit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.RemoteTemp1Signed Property

IRD

Lm95213RemoteTemp1Signed Property

Remote Temp 1 - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp1Signed { get; }
Public ReadOnly Property RemoteTemp1Signed As Double
    Get
public:
property double RemoteTemp1Signed {
    double get ();
}
member RemoteTemp1Signed : float with get

Property Value

Type: Double
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.RemoteTemp1Unsigned Property

IRD

Lm95213RemoteTemp1Unsigned Property

Remote Temp 1 - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp1Unsigned { get; }
Public ReadOnly Property RemoteTemp1Unsigned As Double
    Get
public:
property double RemoteTemp1Unsigned {
    double get ();
}
member RemoteTemp1Unsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.RemoteTemp2Signed Property

IRD

Lm95213RemoteTemp2Signed Property

Remote Temp 2 - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp2Signed { get; }
Public ReadOnly Property RemoteTemp2Signed As Double
    Get
public:
property double RemoteTemp2Signed {
    double get ();
}
member RemoteTemp2Signed : float with get

Property Value

Type: Double
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.RemoteTemp2Unsigned Property

IRD

Lm95213RemoteTemp2Unsigned Property

Remote Temp 2 - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp2Unsigned { get; }
Public ReadOnly Property RemoteTemp2Unsigned As Double
    Get
public:
property double RemoteTemp2Unsigned {
    double get ();
}
member RemoteTemp2Unsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.RevisionID Property

IRD

Lm95213RevisionID Property

Revision ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionID { get; }
Public ReadOnly Property RevisionID As Byte
    Get
public:
property unsigned char RevisionID {
    unsigned char get ();
}
member RevisionID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.StatusRemote1DiodeOpenFault Property

IRD

Lm95213StatusRemote1DiodeOpenFault Property

Status: Remote 1 Diode Open Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeStatusFault StatusRemote1DiodeOpenFault { get; }
Public ReadOnly Property StatusRemote1DiodeOpenFault As Lm95213TypeStatusFault
    Get
public:
property Lm95213TypeStatusFault StatusRemote1DiodeOpenFault {
    Lm95213TypeStatusFault get ();
}
member StatusRemote1DiodeOpenFault : Lm95213TypeStatusFault with get

Property Value

Type: Lm95213TypeStatusFault
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.StatusRemote1DiodeShortFault Property

IRD

Lm95213StatusRemote1DiodeShortFault Property

Status: Remote 1 Diode Short Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeStatusFault StatusRemote1DiodeShortFault { get; }
Public ReadOnly Property StatusRemote1DiodeShortFault As Lm95213TypeStatusFault
    Get
public:
property Lm95213TypeStatusFault StatusRemote1DiodeShortFault {
    Lm95213TypeStatusFault get ();
}
member StatusRemote1DiodeShortFault : Lm95213TypeStatusFault with get

Property Value

Type: Lm95213TypeStatusFault
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.StatusRemote2DiodeOpenFault Property

IRD

Lm95213StatusRemote2DiodeOpenFault Property

Status: Remote 2 Diode Open Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeStatusFault StatusRemote2DiodeOpenFault { get; }
Public ReadOnly Property StatusRemote2DiodeOpenFault As Lm95213TypeStatusFault
    Get
public:
property Lm95213TypeStatusFault StatusRemote2DiodeOpenFault {
    Lm95213TypeStatusFault get ();
}
member StatusRemote2DiodeOpenFault : Lm95213TypeStatusFault with get

Property Value

Type: Lm95213TypeStatusFault
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.StatusRemote2DiodeShortFault Property

IRD

Lm95213StatusRemote2DiodeShortFault Property

Status: Remote 2 Diode Short Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeStatusFault StatusRemote2DiodeShortFault { get; }
Public ReadOnly Property StatusRemote2DiodeShortFault As Lm95213TypeStatusFault
    Get
public:
property Lm95213TypeStatusFault StatusRemote2DiodeShortFault {
    Lm95213TypeStatusFault get ();
}
member StatusRemote2DiodeShortFault : Lm95213TypeStatusFault with get

Property Value

Type: Lm95213TypeStatusFault
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.StatusTCRIT1Local Property

IRD

Lm95213StatusTCRIT1Local Property

Status TCRIT1: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeStatusTcrit StatusTCRIT1Local { get; }
Public ReadOnly Property StatusTCRIT1Local As Lm95213TypeStatusTcrit
    Get
public:
property Lm95213TypeStatusTcrit StatusTCRIT1Local {
    Lm95213TypeStatusTcrit get ();
}
member StatusTCRIT1Local : Lm95213TypeStatusTcrit with get

Property Value

Type: Lm95213TypeStatusTcrit
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.StatusTCRIT1Remote1 Property

IRD

Lm95213StatusTCRIT1Remote1 Property

Status TCRIT1: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeStatusTcrit StatusTCRIT1Remote1 { get; }
Public ReadOnly Property StatusTCRIT1Remote1 As Lm95213TypeStatusTcrit
    Get
public:
property Lm95213TypeStatusTcrit StatusTCRIT1Remote1 {
    Lm95213TypeStatusTcrit get ();
}
member StatusTCRIT1Remote1 : Lm95213TypeStatusTcrit with get

Property Value

Type: Lm95213TypeStatusTcrit
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.StatusTCRIT1Remote2 Property

IRD

Lm95213StatusTCRIT1Remote2 Property

Status TCRIT1: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeStatusTcrit StatusTCRIT1Remote2 { get; }
Public ReadOnly Property StatusTCRIT1Remote2 As Lm95213TypeStatusTcrit
    Get
public:
property Lm95213TypeStatusTcrit StatusTCRIT1Remote2 {
    Lm95213TypeStatusTcrit get ();
}
member StatusTCRIT1Remote2 : Lm95213TypeStatusTcrit with get

Property Value

Type: Lm95213TypeStatusTcrit
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.StatusTCRIT2Local Property

IRD

Lm95213StatusTCRIT2Local Property

Status TCRIT2: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeStatusTcrit StatusTCRIT2Local { get; }
Public ReadOnly Property StatusTCRIT2Local As Lm95213TypeStatusTcrit
    Get
public:
property Lm95213TypeStatusTcrit StatusTCRIT2Local {
    Lm95213TypeStatusTcrit get ();
}
member StatusTCRIT2Local : Lm95213TypeStatusTcrit with get

Property Value

Type: Lm95213TypeStatusTcrit
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.StatusTCRIT2Remote1 Property

IRD

Lm95213StatusTCRIT2Remote1 Property

Status TCRIT2: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeStatusTcrit StatusTCRIT2Remote1 { get; }
Public ReadOnly Property StatusTCRIT2Remote1 As Lm95213TypeStatusTcrit
    Get
public:
property Lm95213TypeStatusTcrit StatusTCRIT2Remote1 {
    Lm95213TypeStatusTcrit get ();
}
member StatusTCRIT2Remote1 : Lm95213TypeStatusTcrit with get

Property Value

Type: Lm95213TypeStatusTcrit
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.StatusTCRIT2Remote2 Property

IRD

Lm95213StatusTCRIT2Remote2 Property

Status TCRIT2: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeStatusTcrit StatusTCRIT2Remote2 { get; }
Public ReadOnly Property StatusTCRIT2Remote2 As Lm95213TypeStatusTcrit
    Get
public:
property Lm95213TypeStatusTcrit StatusTCRIT2Remote2 {
    Lm95213TypeStatusTcrit get ();
}
member StatusTCRIT2Remote2 : Lm95213TypeStatusTcrit with get

Property Value

Type: Lm95213TypeStatusTcrit
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.StatusTCRIT3Local Property

IRD

Lm95213StatusTCRIT3Local Property

Status TCRIT3: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeStatusTcrit StatusTCRIT3Local { get; }
Public ReadOnly Property StatusTCRIT3Local As Lm95213TypeStatusTcrit
    Get
public:
property Lm95213TypeStatusTcrit StatusTCRIT3Local {
    Lm95213TypeStatusTcrit get ();
}
member StatusTCRIT3Local : Lm95213TypeStatusTcrit with get

Property Value

Type: Lm95213TypeStatusTcrit
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.StatusTCRIT3Remote1 Property

IRD

Lm95213StatusTCRIT3Remote1 Property

Status TCRIT3: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeStatusTcrit StatusTCRIT3Remote1 { get; }
Public ReadOnly Property StatusTCRIT3Remote1 As Lm95213TypeStatusTcrit
    Get
public:
property Lm95213TypeStatusTcrit StatusTCRIT3Remote1 {
    Lm95213TypeStatusTcrit get ();
}
member StatusTCRIT3Remote1 : Lm95213TypeStatusTcrit with get

Property Value

Type: Lm95213TypeStatusTcrit
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.StatusTCRIT3Remote2 Property

IRD

Lm95213StatusTCRIT3Remote2 Property

Status TCRIT3: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeStatusTcrit StatusTCRIT3Remote2 { get; }
Public ReadOnly Property StatusTCRIT3Remote2 As Lm95213TypeStatusTcrit
    Get
public:
property Lm95213TypeStatusTcrit StatusTCRIT3Remote2 {
    Lm95213TypeStatusTcrit get ();
}
member StatusTCRIT3Remote2 : Lm95213TypeStatusTcrit with get

Property Value

Type: Lm95213TypeStatusTcrit
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.TCRIT1MaskLocal Property

IRD

Lm95213TCRIT1MaskLocal Property

TCRIT1 Mask: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeMask TCRIT1MaskLocal { get; set; }
Public Property TCRIT1MaskLocal As Lm95213TypeMask
    Get
    Set
public:
property Lm95213TypeMask TCRIT1MaskLocal {
    Lm95213TypeMask get ();
    void set (Lm95213TypeMask value);
}
member TCRIT1MaskLocal : Lm95213TypeMask with get, set

Property Value

Type: Lm95213TypeMask
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.TCRIT1MaskRemote1 Property

IRD

Lm95213TCRIT1MaskRemote1 Property

TCRIT1 Mask: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeMask TCRIT1MaskRemote1 { get; set; }
Public Property TCRIT1MaskRemote1 As Lm95213TypeMask
    Get
    Set
public:
property Lm95213TypeMask TCRIT1MaskRemote1 {
    Lm95213TypeMask get ();
    void set (Lm95213TypeMask value);
}
member TCRIT1MaskRemote1 : Lm95213TypeMask with get, set

Property Value

Type: Lm95213TypeMask
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.TCRIT1MaskRemote2 Property

IRD

Lm95213TCRIT1MaskRemote2 Property

TCRIT1 Mask: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeMask TCRIT1MaskRemote2 { get; set; }
Public Property TCRIT1MaskRemote2 As Lm95213TypeMask
    Get
    Set
public:
property Lm95213TypeMask TCRIT1MaskRemote2 {
    Lm95213TypeMask get ();
    void set (Lm95213TypeMask value);
}
member TCRIT1MaskRemote2 : Lm95213TypeMask with get, set

Property Value

Type: Lm95213TypeMask
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.TCRIT2MaskLocal Property

IRD

Lm95213TCRIT2MaskLocal Property

TCRIT2 Mask: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeMask TCRIT2MaskLocal { get; set; }
Public Property TCRIT2MaskLocal As Lm95213TypeMask
    Get
    Set
public:
property Lm95213TypeMask TCRIT2MaskLocal {
    Lm95213TypeMask get ();
    void set (Lm95213TypeMask value);
}
member TCRIT2MaskLocal : Lm95213TypeMask with get, set

Property Value

Type: Lm95213TypeMask
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.TCRIT2MaskRemote1 Property

IRD

Lm95213TCRIT2MaskRemote1 Property

TCRIT2 Mask: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeMask TCRIT2MaskRemote1 { get; set; }
Public Property TCRIT2MaskRemote1 As Lm95213TypeMask
    Get
    Set
public:
property Lm95213TypeMask TCRIT2MaskRemote1 {
    Lm95213TypeMask get ();
    void set (Lm95213TypeMask value);
}
member TCRIT2MaskRemote1 : Lm95213TypeMask with get, set

Property Value

Type: Lm95213TypeMask
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.TCRIT2MaskRemote2 Property

IRD

Lm95213TCRIT2MaskRemote2 Property

TCRIT2 Mask: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeMask TCRIT2MaskRemote2 { get; set; }
Public Property TCRIT2MaskRemote2 As Lm95213TypeMask
    Get
    Set
public:
property Lm95213TypeMask TCRIT2MaskRemote2 {
    Lm95213TypeMask get ();
    void set (Lm95213TypeMask value);
}
member TCRIT2MaskRemote2 : Lm95213TypeMask with get, set

Property Value

Type: Lm95213TypeMask
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.TCRIT3MaskLocal Property

IRD

Lm95213TCRIT3MaskLocal Property

TCRIT3 Mask: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeMask TCRIT3MaskLocal { get; set; }
Public Property TCRIT3MaskLocal As Lm95213TypeMask
    Get
    Set
public:
property Lm95213TypeMask TCRIT3MaskLocal {
    Lm95213TypeMask get ();
    void set (Lm95213TypeMask value);
}
member TCRIT3MaskLocal : Lm95213TypeMask with get, set

Property Value

Type: Lm95213TypeMask
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.TCRIT3MaskRemote1 Property

IRD

Lm95213TCRIT3MaskRemote1 Property

TCRIT3 Mask: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeMask TCRIT3MaskRemote1 { get; set; }
Public Property TCRIT3MaskRemote1 As Lm95213TypeMask
    Get
    Set
public:
property Lm95213TypeMask TCRIT3MaskRemote1 {
    Lm95213TypeMask get ();
    void set (Lm95213TypeMask value);
}
member TCRIT3MaskRemote1 : Lm95213TypeMask with get, set

Property Value

Type: Lm95213TypeMask
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.TCRIT3MaskRemote2 Property

IRD

Lm95213TCRIT3MaskRemote2 Property

TCRIT3 Mask: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95213TypeMask TCRIT3MaskRemote2 { get; set; }
Public Property TCRIT3MaskRemote2 As Lm95213TypeMask
    Get
    Set
public:
property Lm95213TypeMask TCRIT3MaskRemote2 {
    Lm95213TypeMask get ();
    void set (Lm95213TypeMask value);
}
member TCRIT3MaskRemote2 : Lm95213TypeMask with get, set

Property Value

Type: Lm95213TypeMask
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213 Methods

The Lm95213 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Method_1Shot | 1-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.Flush Method

IRD

Lm95213Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.Method_1Shot Method

IRD

Lm95213Method_1Shot Method

1-Shot

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Method_1Shot()
Public Sub Method_1Shot
public:
void Method_1Shot()
member Method_1Shot : unit -> unit
See Also

Reference

Lm95213 Class
telos.Ird.NationalSemiconductor Namespace


Lm95213.TypeChannelConversionEnable Enumeration

IRD

Lm95213TypeChannelConversionEnable Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelConversionEnable
Public Enumeration TypeChannelConversionEnable
public enum class TypeChannelConversionEnable
type TypeChannelConversionEnable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95213.TypeCommonStatusBusy Enumeration

IRD

Lm95213TypeCommonStatusBusy Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommonStatusBusy
Public Enumeration TypeCommonStatusBusy
public enum class TypeCommonStatusBusy
type TypeCommonStatusBusy
Members
Member name | Value | Description
NotBusy | 0 | Not Busy
Busy | 1 | Busy
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95213.TypeCommonStatusNr Enumeration

IRD

Lm95213TypeCommonStatusNr Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommonStatusNr
Public Enumeration TypeCommonStatusNr
public enum class TypeCommonStatusNr
type TypeCommonStatusNr
Members
Member name | Value | Description
Ready | 0 | Ready
NotReady | 1 | Not Ready
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95213.TypeCommonStatusSr Enumeration

IRD

Lm95213TypeCommonStatusSr Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommonStatusSr
Public Enumeration TypeCommonStatusSr
public enum class TypeCommonStatusSr
type TypeCommonStatusSr
Members
Member name | Value | Description
AllBitsAreCleared | 0 | All Bits Are Cleared
AtLeastOneBitSet | 1 | At Least One Bit Set
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95213.TypeConfigurationStby Enumeration

IRD

Lm95213TypeConfigurationStby Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationStby
Public Enumeration TypeConfigurationStby
public enum class TypeConfigurationStby
type TypeConfigurationStby
Members
Member name | Value | Description
ActiveConverting | 0 | Active/Converting
Standby | 1 | Standby
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95213.TypeConversionRate Enumeration

IRD

Lm95213TypeConversionRate Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConversionRate
Public Enumeration TypeConversionRate
public enum class TypeConversionRate
type TypeConversionRate
Members
Member name | Value | Description
Continuous30MsTo104Ms | 0 | Continuous (30 ms to 104 ms)
Value_0364S | 1 | 0.364 s
Value_1S | 2 | 1 s
Value_25S | 3 | 2.5 s
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95213.TypeFilterSetting Enumeration

IRD

Lm95213TypeFilterSetting Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFilterSetting
Public Enumeration TypeFilterSetting
public enum class TypeFilterSetting
type TypeFilterSetting
Members
Member name | Value | Description
DisableAllDigitalFiltering | 0 | Disable all digital filtering
EnableBasicFilter | 1 | Enable basic filter
Reserved | 2 | Reserved
EnableEnhancedFilter | 3 | Enable enhanced filter
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95213.TypeMask Enumeration

IRD

Lm95213TypeMask Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMask
Public Enumeration TypeMask
public enum class TypeMask
type TypeMask
Members
Member name | Value | Description
PinTriggered | 0 | Pin: Triggered
PinNotTriggered | 1 | Pin: Not Triggered
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95213.TypeStatusFault Enumeration

IRD

Lm95213TypeStatusFault Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusFault
Public Enumeration TypeStatusFault
public enum class TypeStatusFault
type TypeStatusFault
Members
Member name | Value | Description
NoFault | 0 | No Fault
Fault | 1 | Fault
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95213.TypeStatusTcrit Enumeration

IRD

Lm95213TypeStatusTcrit Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusTcrit
Public Enumeration TypeStatusTcrit
public enum class TypeStatusTcrit
type TypeStatusTcrit
Members
Member name | Value | Description
TTCRITTCRITHYSTERESIS | 0 | T < TCRIT - TCRIT_HYSTERESIS
TTCRIT | 1 | T >= TCRIT
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95214 Class

National Semiconductor: LM 95214
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm95214

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm95214
Public Class Lm95214
public ref class Lm95214
type Lm95214 =  class end

The Lm95214 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm95214 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelConversionEnableLocal | Channel Conversion Enable: Local
Public property | ChannelConversionEnableRemote1 | Channel Conversion Enable: Remote 1
Public property | ChannelConversionEnableRemote2 | Channel Conversion Enable: Remote 2
Public property | ChannelConversionEnableRemote3 | Channel Conversion Enable: Remote 3
Public property | ChannelConversionEnableRemote4 | Channel Conversion Enable: Remote 4
Public property | CommonStatusBusy | Common Status: Busy
Public property | CommonStatusNR | Common Status: NR
Public property | CommonStatusStatusRegister1Flag | Common Status: Status Register 1 Flag
Public property | CommonStatusStatusRegister2Flag | Common Status: Status Register 2 Flag
Public property | CommonStatusStatusRegister3Flag | Common Status: Status Register 3 Flag
Public property | CommonStatusStatusRegister4Flag | Common Status: Status Register 4 Flag
Public property | CommonTCRITHysteresis | Common TCRIT Hysteresis (unit: °C)
Public property | ConfigurationFaultQueueRemote3 | Configuration: Fault Queue Remote 3
Public property | ConfigurationFaultQueueRemote4 | Configuration: Fault Queue Remote 4
Public property | ConfigurationStandby | Configuration: Standby
Public property | ConversionRate | Conversion Rate
Public property | FilterSettingRemote1 | Filter Setting: Remote 1
Public property | FilterSettingRemote2 | Filter Setting: Remote 2
Public property | LocalTCRITLimit | Local TCRIT Limit (unit: °C)
Public property | LocalTemp | Local Temp (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | Remote1Offset | Remote 1 Offset (unit: °C)
Public property | Remote1TCRIT1Limit | Remote 1 TCRIT-1 Limit (unit: °C)
Public property | Remote1TCRIT2AndTCRIT3Limit | Remote 1 TCRIT-2 and TCRIT-3 Limit (unit: °C)
Public property | Remote2Offset | Remote 2 Offset (unit: °C)
Public property | Remote2TCRIT1Limit | Remote 2 TCRIT-1 Limit (unit: °C)
Public property | Remote2TCRIT2AndTCRIT3Limit | Remote 2 TCRIT-2 and TCRIT-3 Limit (unit: °C)
Public property | Remote3Offset | Remote 3 Offset (unit: °C)
Public property | Remote3TCRITLimit | Remote 3 TCRIT Limit (unit: °C)
Public property | Remote4Offset | Remote 4 Offset (unit: °C)
Public property | Remote4TCRITLimit | Remote 4 TCRIT Limit (unit: °C)
Public property | RemoteTemp1Signed | Remote Temp 1 - Signed (unit: °C)
Public property | RemoteTemp1Unsigned | Remote Temp 1 - Unsigned (unit: °C)
Public property | RemoteTemp2Signed | Remote Temp 2 - Signed (unit: °C)
Public property | RemoteTemp2Unsigned | Remote Temp 2 - Unsigned (unit: °C)
Public property | RemoteTemp3Signed | Remote Temp 3 - Signed (unit: °C)
Public property | RemoteTemp3Unsigned | Remote Temp 3 - Unsigned (unit: °C)
Public property | RemoteTemp4Signed | Remote Temp 4 - Signed (unit: °C)
Public property | RemoteTemp4Unsigned | Remote Temp 4 - Unsigned (unit: °C)
Public property | RevisionID | Revision ID
Public property | StatusRemote1DiodeOpenFault | Status: Remote 1 Diode Open Fault
Public property | StatusRemote1DiodeShortFault | Status: Remote 1 Diode Short Fault
Public property | StatusRemote2DiodeOpenFault | Status: Remote 2 Diode Open Fault
Public property | StatusRemote2DiodeShortFault | Status: Remote 2 Diode Short Fault
Public property | StatusRemote3DiodeOpenFault | Status: Remote 3 Diode Open Fault
Public property | StatusRemote3DiodeShortFault | Status: Remote 3 Diode Short Fault
Public property | StatusRemote4DiodeOpenFault | Status: Remote 4 Diode Open Fault
Public property | StatusRemote4DiodeShortFault | Status: Remote 4 Diode Short Fault
Public property | StatusTCRIT1Local | Status TCRIT1: Local
Public property | StatusTCRIT1Remote1 | Status TCRIT1: Remote 1
Public property | StatusTCRIT1Remote2 | Status TCRIT1: Remote 2
Public property | StatusTCRIT1Remote3 | Status TCRIT1: Remote 3
Public property | StatusTCRIT1Remote4 | Status TCRIT1: Remote 4
Public property | StatusTCRIT2Local | Status TCRIT2: Local
Public property | StatusTCRIT2Remote1 | Status TCRIT2: Remote 1
Public property | StatusTCRIT2Remote2 | Status TCRIT2: Remote 2
Public property | StatusTCRIT2Remote3 | Status TCRIT2: Remote 3
Public property | StatusTCRIT2Remote4 | Status TCRIT2: Remote 4
Public property | StatusTCRIT3Local | Status TCRIT3: Local
Public property | StatusTCRIT3Remote1 | Status TCRIT3: Remote 1
Public property | StatusTCRIT3Remote2 | Status TCRIT3: Remote 2
Public property | StatusTCRIT3Remote3 | Status TCRIT3: Remote 3
Public property | StatusTCRIT3Remote4 | Status TCRIT3: Remote 4
Public property | TCRIT1MaskLocal | TCRIT1 Mask: Local
Public property | TCRIT1MaskRemote1 | TCRIT1 Mask: Remote 1
Public property | TCRIT1MaskRemote2 | TCRIT1 Mask: Remote 2
Public property | TCRIT1MaskRemote3 | TCRIT1 Mask: Remote 3
Public property | TCRIT1MaskRemote4 | TCRIT1 Mask: Remote 4
Public property | TCRIT2MaskLocal | TCRIT2 Mask: Local
Public property | TCRIT2MaskRemote1 | TCRIT2 Mask: Remote 1
Public property | TCRIT2MaskRemote2 | TCRIT2 Mask: Remote 2
Public property | TCRIT2MaskRemote3 | TCRIT2 Mask: Remote 3
Public property | TCRIT2MaskRemote4 | TCRIT2 Mask: Remote 4
Public property | TCRIT3MaskLocal | TCRIT3 Mask: Local
Public property | TCRIT3MaskRemote1 | TCRIT3 Mask: Remote 1
Public property | TCRIT3MaskRemote2 | TCRIT3 Mask: Remote 2
Public property | TCRIT3MaskRemote3 | TCRIT3 Mask: Remote 3
Public property | TCRIT3MaskRemote4 | TCRIT3 Mask: Remote 4
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Method_1Shot | 1-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Quad Remote Diode and Local Temperature Sensor with SMBus Interface
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95214 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm95214(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm95214

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214 Properties

The Lm95214 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelConversionEnableLocal | Channel Conversion Enable: Local
Public property | ChannelConversionEnableRemote1 | Channel Conversion Enable: Remote 1
Public property | ChannelConversionEnableRemote2 | Channel Conversion Enable: Remote 2
Public property | ChannelConversionEnableRemote3 | Channel Conversion Enable: Remote 3
Public property | ChannelConversionEnableRemote4 | Channel Conversion Enable: Remote 4
Public property | CommonStatusBusy | Common Status: Busy
Public property | CommonStatusNR | Common Status: NR
Public property | CommonStatusStatusRegister1Flag | Common Status: Status Register 1 Flag
Public property | CommonStatusStatusRegister2Flag | Common Status: Status Register 2 Flag
Public property | CommonStatusStatusRegister3Flag | Common Status: Status Register 3 Flag
Public property | CommonStatusStatusRegister4Flag | Common Status: Status Register 4 Flag
Public property | CommonTCRITHysteresis | Common TCRIT Hysteresis (unit: °C)
Public property | ConfigurationFaultQueueRemote3 | Configuration: Fault Queue Remote 3
Public property | ConfigurationFaultQueueRemote4 | Configuration: Fault Queue Remote 4
Public property | ConfigurationStandby | Configuration: Standby
Public property | ConversionRate | Conversion Rate
Public property | FilterSettingRemote1 | Filter Setting: Remote 1
Public property | FilterSettingRemote2 | Filter Setting: Remote 2
Public property | LocalTCRITLimit | Local TCRIT Limit (unit: °C)
Public property | LocalTemp | Local Temp (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | Remote1Offset | Remote 1 Offset (unit: °C)
Public property | Remote1TCRIT1Limit | Remote 1 TCRIT-1 Limit (unit: °C)
Public property | Remote1TCRIT2AndTCRIT3Limit | Remote 1 TCRIT-2 and TCRIT-3 Limit (unit: °C)
Public property | Remote2Offset | Remote 2 Offset (unit: °C)
Public property | Remote2TCRIT1Limit | Remote 2 TCRIT-1 Limit (unit: °C)
Public property | Remote2TCRIT2AndTCRIT3Limit | Remote 2 TCRIT-2 and TCRIT-3 Limit (unit: °C)
Public property | Remote3Offset | Remote 3 Offset (unit: °C)
Public property | Remote3TCRITLimit | Remote 3 TCRIT Limit (unit: °C)
Public property | Remote4Offset | Remote 4 Offset (unit: °C)
Public property | Remote4TCRITLimit | Remote 4 TCRIT Limit (unit: °C)
Public property | RemoteTemp1Signed | Remote Temp 1 - Signed (unit: °C)
Public property | RemoteTemp1Unsigned | Remote Temp 1 - Unsigned (unit: °C)
Public property | RemoteTemp2Signed | Remote Temp 2 - Signed (unit: °C)
Public property | RemoteTemp2Unsigned | Remote Temp 2 - Unsigned (unit: °C)
Public property | RemoteTemp3Signed | Remote Temp 3 - Signed (unit: °C)
Public property | RemoteTemp3Unsigned | Remote Temp 3 - Unsigned (unit: °C)
Public property | RemoteTemp4Signed | Remote Temp 4 - Signed (unit: °C)
Public property | RemoteTemp4Unsigned | Remote Temp 4 - Unsigned (unit: °C)
Public property | RevisionID | Revision ID
Public property | StatusRemote1DiodeOpenFault | Status: Remote 1 Diode Open Fault
Public property | StatusRemote1DiodeShortFault | Status: Remote 1 Diode Short Fault
Public property | StatusRemote2DiodeOpenFault | Status: Remote 2 Diode Open Fault
Public property | StatusRemote2DiodeShortFault | Status: Remote 2 Diode Short Fault
Public property | StatusRemote3DiodeOpenFault | Status: Remote 3 Diode Open Fault
Public property | StatusRemote3DiodeShortFault | Status: Remote 3 Diode Short Fault
Public property | StatusRemote4DiodeOpenFault | Status: Remote 4 Diode Open Fault
Public property | StatusRemote4DiodeShortFault | Status: Remote 4 Diode Short Fault
Public property | StatusTCRIT1Local | Status TCRIT1: Local
Public property | StatusTCRIT1Remote1 | Status TCRIT1: Remote 1
Public property | StatusTCRIT1Remote2 | Status TCRIT1: Remote 2
Public property | StatusTCRIT1Remote3 | Status TCRIT1: Remote 3
Public property | StatusTCRIT1Remote4 | Status TCRIT1: Remote 4
Public property | StatusTCRIT2Local | Status TCRIT2: Local
Public property | StatusTCRIT2Remote1 | Status TCRIT2: Remote 1
Public property | StatusTCRIT2Remote2 | Status TCRIT2: Remote 2
Public property | StatusTCRIT2Remote3 | Status TCRIT2: Remote 3
Public property | StatusTCRIT2Remote4 | Status TCRIT2: Remote 4
Public property | StatusTCRIT3Local | Status TCRIT3: Local
Public property | StatusTCRIT3Remote1 | Status TCRIT3: Remote 1
Public property | StatusTCRIT3Remote2 | Status TCRIT3: Remote 2
Public property | StatusTCRIT3Remote3 | Status TCRIT3: Remote 3
Public property | StatusTCRIT3Remote4 | Status TCRIT3: Remote 4
Public property | TCRIT1MaskLocal | TCRIT1 Mask: Local
Public property | TCRIT1MaskRemote1 | TCRIT1 Mask: Remote 1
Public property | TCRIT1MaskRemote2 | TCRIT1 Mask: Remote 2
Public property | TCRIT1MaskRemote3 | TCRIT1 Mask: Remote 3
Public property | TCRIT1MaskRemote4 | TCRIT1 Mask: Remote 4
Public property | TCRIT2MaskLocal | TCRIT2 Mask: Local
Public property | TCRIT2MaskRemote1 | TCRIT2 Mask: Remote 1
Public property | TCRIT2MaskRemote2 | TCRIT2 Mask: Remote 2
Public property | TCRIT2MaskRemote3 | TCRIT2 Mask: Remote 3
Public property | TCRIT2MaskRemote4 | TCRIT2 Mask: Remote 4
Public property | TCRIT3MaskLocal | TCRIT3 Mask: Local
Public property | TCRIT3MaskRemote1 | TCRIT3 Mask: Remote 1
Public property | TCRIT3MaskRemote2 | TCRIT3 Mask: Remote 2
Public property | TCRIT3MaskRemote3 | TCRIT3 Mask: Remote 3
Public property | TCRIT3MaskRemote4 | TCRIT3 Mask: Remote 4
Top
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.AutoFlush Property

IRD

Lm95214AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.ChannelConversionEnableLocal Property

IRD

Lm95214ChannelConversionEnableLocal Property

Channel Conversion Enable: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeChannelConversionEnable ChannelConversionEnableLocal { get; set; }
Public Property ChannelConversionEnableLocal As Lm95214TypeChannelConversionEnable
    Get
    Set
public:
property Lm95214TypeChannelConversionEnable ChannelConversionEnableLocal {
    Lm95214TypeChannelConversionEnable get ();
    void set (Lm95214TypeChannelConversionEnable value);
}
member ChannelConversionEnableLocal : Lm95214TypeChannelConversionEnable with get, set

Property Value

Type: Lm95214TypeChannelConversionEnable
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.ChannelConversionEnableRemote1 Property

IRD

Lm95214ChannelConversionEnableRemote1 Property

Channel Conversion Enable: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeChannelConversionEnable ChannelConversionEnableRemote1 { get; set; }
Public Property ChannelConversionEnableRemote1 As Lm95214TypeChannelConversionEnable
    Get
    Set
public:
property Lm95214TypeChannelConversionEnable ChannelConversionEnableRemote1 {
    Lm95214TypeChannelConversionEnable get ();
    void set (Lm95214TypeChannelConversionEnable value);
}
member ChannelConversionEnableRemote1 : Lm95214TypeChannelConversionEnable with get, set

Property Value

Type: Lm95214TypeChannelConversionEnable
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.ChannelConversionEnableRemote2 Property

IRD

Lm95214ChannelConversionEnableRemote2 Property

Channel Conversion Enable: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeChannelConversionEnable ChannelConversionEnableRemote2 { get; set; }
Public Property ChannelConversionEnableRemote2 As Lm95214TypeChannelConversionEnable
    Get
    Set
public:
property Lm95214TypeChannelConversionEnable ChannelConversionEnableRemote2 {
    Lm95214TypeChannelConversionEnable get ();
    void set (Lm95214TypeChannelConversionEnable value);
}
member ChannelConversionEnableRemote2 : Lm95214TypeChannelConversionEnable with get, set

Property Value

Type: Lm95214TypeChannelConversionEnable
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.ChannelConversionEnableRemote3 Property

IRD

Lm95214ChannelConversionEnableRemote3 Property

Channel Conversion Enable: Remote 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeChannelConversionEnable ChannelConversionEnableRemote3 { get; set; }
Public Property ChannelConversionEnableRemote3 As Lm95214TypeChannelConversionEnable
    Get
    Set
public:
property Lm95214TypeChannelConversionEnable ChannelConversionEnableRemote3 {
    Lm95214TypeChannelConversionEnable get ();
    void set (Lm95214TypeChannelConversionEnable value);
}
member ChannelConversionEnableRemote3 : Lm95214TypeChannelConversionEnable with get, set

Property Value

Type: Lm95214TypeChannelConversionEnable
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.ChannelConversionEnableRemote4 Property

IRD

Lm95214ChannelConversionEnableRemote4 Property

Channel Conversion Enable: Remote 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeChannelConversionEnable ChannelConversionEnableRemote4 { get; set; }
Public Property ChannelConversionEnableRemote4 As Lm95214TypeChannelConversionEnable
    Get
    Set
public:
property Lm95214TypeChannelConversionEnable ChannelConversionEnableRemote4 {
    Lm95214TypeChannelConversionEnable get ();
    void set (Lm95214TypeChannelConversionEnable value);
}
member ChannelConversionEnableRemote4 : Lm95214TypeChannelConversionEnable with get, set

Property Value

Type: Lm95214TypeChannelConversionEnable
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.CommonStatusBusy Property

IRD

Lm95214CommonStatusBusy Property

Common Status: Busy

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeCommonStatusBusy CommonStatusBusy { get; }
Public ReadOnly Property CommonStatusBusy As Lm95214TypeCommonStatusBusy
    Get
public:
property Lm95214TypeCommonStatusBusy CommonStatusBusy {
    Lm95214TypeCommonStatusBusy get ();
}
member CommonStatusBusy : Lm95214TypeCommonStatusBusy with get

Property Value

Type: Lm95214TypeCommonStatusBusy
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.CommonStatusNR Property

IRD

Lm95214CommonStatusNR Property

Common Status: NR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeCommonStatusNr CommonStatusNR { get; }
Public ReadOnly Property CommonStatusNR As Lm95214TypeCommonStatusNr
    Get
public:
property Lm95214TypeCommonStatusNr CommonStatusNR {
    Lm95214TypeCommonStatusNr get ();
}
member CommonStatusNR : Lm95214TypeCommonStatusNr with get

Property Value

Type: Lm95214TypeCommonStatusNr
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.CommonStatusStatusRegister1Flag Property

IRD

Lm95214CommonStatusStatusRegister1Flag Property

Common Status: Status Register 1 Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeCommonStatusSr CommonStatusStatusRegister1Flag { get; }
Public ReadOnly Property CommonStatusStatusRegister1Flag As Lm95214TypeCommonStatusSr
    Get
public:
property Lm95214TypeCommonStatusSr CommonStatusStatusRegister1Flag {
    Lm95214TypeCommonStatusSr get ();
}
member CommonStatusStatusRegister1Flag : Lm95214TypeCommonStatusSr with get

Property Value

Type: Lm95214TypeCommonStatusSr
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.CommonStatusStatusRegister2Flag Property

IRD

Lm95214CommonStatusStatusRegister2Flag Property

Common Status: Status Register 2 Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeCommonStatusSr CommonStatusStatusRegister2Flag { get; }
Public ReadOnly Property CommonStatusStatusRegister2Flag As Lm95214TypeCommonStatusSr
    Get
public:
property Lm95214TypeCommonStatusSr CommonStatusStatusRegister2Flag {
    Lm95214TypeCommonStatusSr get ();
}
member CommonStatusStatusRegister2Flag : Lm95214TypeCommonStatusSr with get

Property Value

Type: Lm95214TypeCommonStatusSr
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.CommonStatusStatusRegister3Flag Property

IRD

Lm95214CommonStatusStatusRegister3Flag Property

Common Status: Status Register 3 Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeCommonStatusSr CommonStatusStatusRegister3Flag { get; }
Public ReadOnly Property CommonStatusStatusRegister3Flag As Lm95214TypeCommonStatusSr
    Get
public:
property Lm95214TypeCommonStatusSr CommonStatusStatusRegister3Flag {
    Lm95214TypeCommonStatusSr get ();
}
member CommonStatusStatusRegister3Flag : Lm95214TypeCommonStatusSr with get

Property Value

Type: Lm95214TypeCommonStatusSr
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.CommonStatusStatusRegister4Flag Property

IRD

Lm95214CommonStatusStatusRegister4Flag Property

Common Status: Status Register 4 Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeCommonStatusSr CommonStatusStatusRegister4Flag { get; }
Public ReadOnly Property CommonStatusStatusRegister4Flag As Lm95214TypeCommonStatusSr
    Get
public:
property Lm95214TypeCommonStatusSr CommonStatusStatusRegister4Flag {
    Lm95214TypeCommonStatusSr get ();
}
member CommonStatusStatusRegister4Flag : Lm95214TypeCommonStatusSr with get

Property Value

Type: Lm95214TypeCommonStatusSr
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.CommonTCRITHysteresis Property

IRD

Lm95214CommonTCRITHysteresis Property

Common TCRIT Hysteresis (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CommonTCRITHysteresis { get; set; }
Public Property CommonTCRITHysteresis As Byte
    Get
    Set
public:
property unsigned char CommonTCRITHysteresis {
    unsigned char get ();
    void set (unsigned char value);
}
member CommonTCRITHysteresis : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.ConfigurationFaultQueueRemote3 Property

IRD

Lm95214ConfigurationFaultQueueRemote3 Property

Configuration: Fault Queue Remote 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeConfigurationFaultQueue ConfigurationFaultQueueRemote3 { get; set; }
Public Property ConfigurationFaultQueueRemote3 As Lm95214TypeConfigurationFaultQueue
    Get
    Set
public:
property Lm95214TypeConfigurationFaultQueue ConfigurationFaultQueueRemote3 {
    Lm95214TypeConfigurationFaultQueue get ();
    void set (Lm95214TypeConfigurationFaultQueue value);
}
member ConfigurationFaultQueueRemote3 : Lm95214TypeConfigurationFaultQueue with get, set

Property Value

Type: Lm95214TypeConfigurationFaultQueue
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.ConfigurationFaultQueueRemote4 Property

IRD

Lm95214ConfigurationFaultQueueRemote4 Property

Configuration: Fault Queue Remote 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeConfigurationFaultQueue ConfigurationFaultQueueRemote4 { get; set; }
Public Property ConfigurationFaultQueueRemote4 As Lm95214TypeConfigurationFaultQueue
    Get
    Set
public:
property Lm95214TypeConfigurationFaultQueue ConfigurationFaultQueueRemote4 {
    Lm95214TypeConfigurationFaultQueue get ();
    void set (Lm95214TypeConfigurationFaultQueue value);
}
member ConfigurationFaultQueueRemote4 : Lm95214TypeConfigurationFaultQueue with get, set

Property Value

Type: Lm95214TypeConfigurationFaultQueue
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.ConfigurationStandby Property

IRD

Lm95214ConfigurationStandby Property

Configuration: Standby

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeConfigurationStby ConfigurationStandby { get; set; }
Public Property ConfigurationStandby As Lm95214TypeConfigurationStby
    Get
    Set
public:
property Lm95214TypeConfigurationStby ConfigurationStandby {
    Lm95214TypeConfigurationStby get ();
    void set (Lm95214TypeConfigurationStby value);
}
member ConfigurationStandby : Lm95214TypeConfigurationStby with get, set

Property Value

Type: Lm95214TypeConfigurationStby
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.ConversionRate Property

IRD

Lm95214ConversionRate Property

Conversion Rate

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeConversionRate ConversionRate { get; set; }
Public Property ConversionRate As Lm95214TypeConversionRate
    Get
    Set
public:
property Lm95214TypeConversionRate ConversionRate {
    Lm95214TypeConversionRate get ();
    void set (Lm95214TypeConversionRate value);
}
member ConversionRate : Lm95214TypeConversionRate with get, set

Property Value

Type: Lm95214TypeConversionRate
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.FilterSettingRemote1 Property

IRD

Lm95214FilterSettingRemote1 Property

Filter Setting: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeFilterSetting FilterSettingRemote1 { get; set; }
Public Property FilterSettingRemote1 As Lm95214TypeFilterSetting
    Get
    Set
public:
property Lm95214TypeFilterSetting FilterSettingRemote1 {
    Lm95214TypeFilterSetting get ();
    void set (Lm95214TypeFilterSetting value);
}
member FilterSettingRemote1 : Lm95214TypeFilterSetting with get, set

Property Value

Type: Lm95214TypeFilterSetting
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.FilterSettingRemote2 Property

IRD

Lm95214FilterSettingRemote2 Property

Filter Setting: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeFilterSetting FilterSettingRemote2 { get; set; }
Public Property FilterSettingRemote2 As Lm95214TypeFilterSetting
    Get
    Set
public:
property Lm95214TypeFilterSetting FilterSettingRemote2 {
    Lm95214TypeFilterSetting get ();
    void set (Lm95214TypeFilterSetting value);
}
member FilterSettingRemote2 : Lm95214TypeFilterSetting with get, set

Property Value

Type: Lm95214TypeFilterSetting
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.LocalTCRITLimit Property

IRD

Lm95214LocalTCRITLimit Property

Local TCRIT Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalTCRITLimit { get; set; }
Public Property LocalTCRITLimit As Byte
    Get
    Set
public:
property unsigned char LocalTCRITLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member LocalTCRITLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.LocalTemp Property

IRD

Lm95214LocalTemp Property

Local Temp (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LocalTemp { get; }
Public ReadOnly Property LocalTemp As Double
    Get
public:
property double LocalTemp {
    double get ();
}
member LocalTemp : float with get

Property Value

Type: Double
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.ManufacturerID Property

IRD

Lm95214ManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As Byte
    Get
public:
property unsigned char ManufacturerID {
    unsigned char get ();
}
member ManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.Remote1Offset Property

IRD

Lm95214Remote1Offset Property

Remote 1 Offset (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote1Offset { get; set; }
Public Property Remote1Offset As Double
    Get
    Set
public:
property double Remote1Offset {
    double get ();
    void set (double value);
}
member Remote1Offset : float with get, set

Property Value

Type: Double
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.Remote1TCRIT1Limit Property

IRD

Lm95214Remote1TCRIT1Limit Property

Remote 1 TCRIT-1 Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote1TCRIT1Limit { get; set; }
Public Property Remote1TCRIT1Limit As Byte
    Get
    Set
public:
property unsigned char Remote1TCRIT1Limit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote1TCRIT1Limit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.Remote1TCRIT2AndTCRIT3Limit Property

IRD

Lm95214Remote1TCRIT2AndTCRIT3Limit Property

Remote 1 TCRIT-2 and TCRIT-3 Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote1TCRIT2AndTCRIT3Limit { get; set; }
Public Property Remote1TCRIT2AndTCRIT3Limit As Byte
    Get
    Set
public:
property unsigned char Remote1TCRIT2AndTCRIT3Limit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote1TCRIT2AndTCRIT3Limit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.Remote2Offset Property

IRD

Lm95214Remote2Offset Property

Remote 2 Offset (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote2Offset { get; set; }
Public Property Remote2Offset As Double
    Get
    Set
public:
property double Remote2Offset {
    double get ();
    void set (double value);
}
member Remote2Offset : float with get, set

Property Value

Type: Double
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.Remote2TCRIT1Limit Property

IRD

Lm95214Remote2TCRIT1Limit Property

Remote 2 TCRIT-1 Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote2TCRIT1Limit { get; set; }
Public Property Remote2TCRIT1Limit As Byte
    Get
    Set
public:
property unsigned char Remote2TCRIT1Limit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote2TCRIT1Limit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.Remote2TCRIT2AndTCRIT3Limit Property

IRD

Lm95214Remote2TCRIT2AndTCRIT3Limit Property

Remote 2 TCRIT-2 and TCRIT-3 Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote2TCRIT2AndTCRIT3Limit { get; set; }
Public Property Remote2TCRIT2AndTCRIT3Limit As Byte
    Get
    Set
public:
property unsigned char Remote2TCRIT2AndTCRIT3Limit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote2TCRIT2AndTCRIT3Limit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.Remote3Offset Property

IRD

Lm95214Remote3Offset Property

Remote 3 Offset (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote3Offset { get; set; }
Public Property Remote3Offset As Double
    Get
    Set
public:
property double Remote3Offset {
    double get ();
    void set (double value);
}
member Remote3Offset : float with get, set

Property Value

Type: Double
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.Remote3TCRITLimit Property

IRD

Lm95214Remote3TCRITLimit Property

Remote 3 TCRIT Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote3TCRITLimit { get; set; }
Public Property Remote3TCRITLimit As Byte
    Get
    Set
public:
property unsigned char Remote3TCRITLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote3TCRITLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.Remote4Offset Property

IRD

Lm95214Remote4Offset Property

Remote 4 Offset (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote4Offset { get; set; }
Public Property Remote4Offset As Double
    Get
    Set
public:
property double Remote4Offset {
    double get ();
    void set (double value);
}
member Remote4Offset : float with get, set

Property Value

Type: Double
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.Remote4TCRITLimit Property

IRD

Lm95214Remote4TCRITLimit Property

Remote 4 TCRIT Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote4TCRITLimit { get; set; }
Public Property Remote4TCRITLimit As Byte
    Get
    Set
public:
property unsigned char Remote4TCRITLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote4TCRITLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.RemoteTemp1Signed Property

IRD

Lm95214RemoteTemp1Signed Property

Remote Temp 1 - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp1Signed { get; }
Public ReadOnly Property RemoteTemp1Signed As Double
    Get
public:
property double RemoteTemp1Signed {
    double get ();
}
member RemoteTemp1Signed : float with get

Property Value

Type: Double
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.RemoteTemp1Unsigned Property

IRD

Lm95214RemoteTemp1Unsigned Property

Remote Temp 1 - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp1Unsigned { get; }
Public ReadOnly Property RemoteTemp1Unsigned As Double
    Get
public:
property double RemoteTemp1Unsigned {
    double get ();
}
member RemoteTemp1Unsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.RemoteTemp2Signed Property

IRD

Lm95214RemoteTemp2Signed Property

Remote Temp 2 - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp2Signed { get; }
Public ReadOnly Property RemoteTemp2Signed As Double
    Get
public:
property double RemoteTemp2Signed {
    double get ();
}
member RemoteTemp2Signed : float with get

Property Value

Type: Double
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.RemoteTemp2Unsigned Property

IRD

Lm95214RemoteTemp2Unsigned Property

Remote Temp 2 - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp2Unsigned { get; }
Public ReadOnly Property RemoteTemp2Unsigned As Double
    Get
public:
property double RemoteTemp2Unsigned {
    double get ();
}
member RemoteTemp2Unsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.RemoteTemp3Signed Property

IRD

Lm95214RemoteTemp3Signed Property

Remote Temp 3 - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp3Signed { get; }
Public ReadOnly Property RemoteTemp3Signed As Double
    Get
public:
property double RemoteTemp3Signed {
    double get ();
}
member RemoteTemp3Signed : float with get

Property Value

Type: Double
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.RemoteTemp3Unsigned Property

IRD

Lm95214RemoteTemp3Unsigned Property

Remote Temp 3 - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp3Unsigned { get; }
Public ReadOnly Property RemoteTemp3Unsigned As Double
    Get
public:
property double RemoteTemp3Unsigned {
    double get ();
}
member RemoteTemp3Unsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.RemoteTemp4Signed Property

IRD

Lm95214RemoteTemp4Signed Property

Remote Temp 4 - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp4Signed { get; }
Public ReadOnly Property RemoteTemp4Signed As Double
    Get
public:
property double RemoteTemp4Signed {
    double get ();
}
member RemoteTemp4Signed : float with get

Property Value

Type: Double
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.RemoteTemp4Unsigned Property

IRD

Lm95214RemoteTemp4Unsigned Property

Remote Temp 4 - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp4Unsigned { get; }
Public ReadOnly Property RemoteTemp4Unsigned As Double
    Get
public:
property double RemoteTemp4Unsigned {
    double get ();
}
member RemoteTemp4Unsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.RevisionID Property

IRD

Lm95214RevisionID Property

Revision ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionID { get; }
Public ReadOnly Property RevisionID As Byte
    Get
public:
property unsigned char RevisionID {
    unsigned char get ();
}
member RevisionID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusRemote1DiodeOpenFault Property

IRD

Lm95214StatusRemote1DiodeOpenFault Property

Status: Remote 1 Diode Open Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusFault StatusRemote1DiodeOpenFault { get; }
Public ReadOnly Property StatusRemote1DiodeOpenFault As Lm95214TypeStatusFault
    Get
public:
property Lm95214TypeStatusFault StatusRemote1DiodeOpenFault {
    Lm95214TypeStatusFault get ();
}
member StatusRemote1DiodeOpenFault : Lm95214TypeStatusFault with get

Property Value

Type: Lm95214TypeStatusFault
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusRemote1DiodeShortFault Property

IRD

Lm95214StatusRemote1DiodeShortFault Property

Status: Remote 1 Diode Short Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusFault StatusRemote1DiodeShortFault { get; }
Public ReadOnly Property StatusRemote1DiodeShortFault As Lm95214TypeStatusFault
    Get
public:
property Lm95214TypeStatusFault StatusRemote1DiodeShortFault {
    Lm95214TypeStatusFault get ();
}
member StatusRemote1DiodeShortFault : Lm95214TypeStatusFault with get

Property Value

Type: Lm95214TypeStatusFault
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusRemote2DiodeOpenFault Property

IRD

Lm95214StatusRemote2DiodeOpenFault Property

Status: Remote 2 Diode Open Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusFault StatusRemote2DiodeOpenFault { get; }
Public ReadOnly Property StatusRemote2DiodeOpenFault As Lm95214TypeStatusFault
    Get
public:
property Lm95214TypeStatusFault StatusRemote2DiodeOpenFault {
    Lm95214TypeStatusFault get ();
}
member StatusRemote2DiodeOpenFault : Lm95214TypeStatusFault with get

Property Value

Type: Lm95214TypeStatusFault
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusRemote2DiodeShortFault Property

IRD

Lm95214StatusRemote2DiodeShortFault Property

Status: Remote 2 Diode Short Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusFault StatusRemote2DiodeShortFault { get; }
Public ReadOnly Property StatusRemote2DiodeShortFault As Lm95214TypeStatusFault
    Get
public:
property Lm95214TypeStatusFault StatusRemote2DiodeShortFault {
    Lm95214TypeStatusFault get ();
}
member StatusRemote2DiodeShortFault : Lm95214TypeStatusFault with get

Property Value

Type: Lm95214TypeStatusFault
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusRemote3DiodeOpenFault Property

IRD

Lm95214StatusRemote3DiodeOpenFault Property

Status: Remote 3 Diode Open Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusFault StatusRemote3DiodeOpenFault { get; }
Public ReadOnly Property StatusRemote3DiodeOpenFault As Lm95214TypeStatusFault
    Get
public:
property Lm95214TypeStatusFault StatusRemote3DiodeOpenFault {
    Lm95214TypeStatusFault get ();
}
member StatusRemote3DiodeOpenFault : Lm95214TypeStatusFault with get

Property Value

Type: Lm95214TypeStatusFault
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusRemote3DiodeShortFault Property

IRD

Lm95214StatusRemote3DiodeShortFault Property

Status: Remote 3 Diode Short Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusFault StatusRemote3DiodeShortFault { get; }
Public ReadOnly Property StatusRemote3DiodeShortFault As Lm95214TypeStatusFault
    Get
public:
property Lm95214TypeStatusFault StatusRemote3DiodeShortFault {
    Lm95214TypeStatusFault get ();
}
member StatusRemote3DiodeShortFault : Lm95214TypeStatusFault with get

Property Value

Type: Lm95214TypeStatusFault
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusRemote4DiodeOpenFault Property

IRD

Lm95214StatusRemote4DiodeOpenFault Property

Status: Remote 4 Diode Open Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusFault StatusRemote4DiodeOpenFault { get; }
Public ReadOnly Property StatusRemote4DiodeOpenFault As Lm95214TypeStatusFault
    Get
public:
property Lm95214TypeStatusFault StatusRemote4DiodeOpenFault {
    Lm95214TypeStatusFault get ();
}
member StatusRemote4DiodeOpenFault : Lm95214TypeStatusFault with get

Property Value

Type: Lm95214TypeStatusFault
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusRemote4DiodeShortFault Property

IRD

Lm95214StatusRemote4DiodeShortFault Property

Status: Remote 4 Diode Short Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusFault StatusRemote4DiodeShortFault { get; }
Public ReadOnly Property StatusRemote4DiodeShortFault As Lm95214TypeStatusFault
    Get
public:
property Lm95214TypeStatusFault StatusRemote4DiodeShortFault {
    Lm95214TypeStatusFault get ();
}
member StatusRemote4DiodeShortFault : Lm95214TypeStatusFault with get

Property Value

Type: Lm95214TypeStatusFault
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusTCRIT1Local Property

IRD

Lm95214StatusTCRIT1Local Property

Status TCRIT1: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusTcrit StatusTCRIT1Local { get; }
Public ReadOnly Property StatusTCRIT1Local As Lm95214TypeStatusTcrit
    Get
public:
property Lm95214TypeStatusTcrit StatusTCRIT1Local {
    Lm95214TypeStatusTcrit get ();
}
member StatusTCRIT1Local : Lm95214TypeStatusTcrit with get

Property Value

Type: Lm95214TypeStatusTcrit
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusTCRIT1Remote1 Property

IRD

Lm95214StatusTCRIT1Remote1 Property

Status TCRIT1: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusTcrit StatusTCRIT1Remote1 { get; }
Public ReadOnly Property StatusTCRIT1Remote1 As Lm95214TypeStatusTcrit
    Get
public:
property Lm95214TypeStatusTcrit StatusTCRIT1Remote1 {
    Lm95214TypeStatusTcrit get ();
}
member StatusTCRIT1Remote1 : Lm95214TypeStatusTcrit with get

Property Value

Type: Lm95214TypeStatusTcrit
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusTCRIT1Remote2 Property

IRD

Lm95214StatusTCRIT1Remote2 Property

Status TCRIT1: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusTcrit StatusTCRIT1Remote2 { get; }
Public ReadOnly Property StatusTCRIT1Remote2 As Lm95214TypeStatusTcrit
    Get
public:
property Lm95214TypeStatusTcrit StatusTCRIT1Remote2 {
    Lm95214TypeStatusTcrit get ();
}
member StatusTCRIT1Remote2 : Lm95214TypeStatusTcrit with get

Property Value

Type: Lm95214TypeStatusTcrit
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusTCRIT1Remote3 Property

IRD

Lm95214StatusTCRIT1Remote3 Property

Status TCRIT1: Remote 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusTcrit StatusTCRIT1Remote3 { get; }
Public ReadOnly Property StatusTCRIT1Remote3 As Lm95214TypeStatusTcrit
    Get
public:
property Lm95214TypeStatusTcrit StatusTCRIT1Remote3 {
    Lm95214TypeStatusTcrit get ();
}
member StatusTCRIT1Remote3 : Lm95214TypeStatusTcrit with get

Property Value

Type: Lm95214TypeStatusTcrit
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusTCRIT1Remote4 Property

IRD

Lm95214StatusTCRIT1Remote4 Property

Status TCRIT1: Remote 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusTcrit StatusTCRIT1Remote4 { get; }
Public ReadOnly Property StatusTCRIT1Remote4 As Lm95214TypeStatusTcrit
    Get
public:
property Lm95214TypeStatusTcrit StatusTCRIT1Remote4 {
    Lm95214TypeStatusTcrit get ();
}
member StatusTCRIT1Remote4 : Lm95214TypeStatusTcrit with get

Property Value

Type: Lm95214TypeStatusTcrit
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusTCRIT2Local Property

IRD

Lm95214StatusTCRIT2Local Property

Status TCRIT2: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusTcrit StatusTCRIT2Local { get; }
Public ReadOnly Property StatusTCRIT2Local As Lm95214TypeStatusTcrit
    Get
public:
property Lm95214TypeStatusTcrit StatusTCRIT2Local {
    Lm95214TypeStatusTcrit get ();
}
member StatusTCRIT2Local : Lm95214TypeStatusTcrit with get

Property Value

Type: Lm95214TypeStatusTcrit
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusTCRIT2Remote1 Property

IRD

Lm95214StatusTCRIT2Remote1 Property

Status TCRIT2: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusTcrit StatusTCRIT2Remote1 { get; }
Public ReadOnly Property StatusTCRIT2Remote1 As Lm95214TypeStatusTcrit
    Get
public:
property Lm95214TypeStatusTcrit StatusTCRIT2Remote1 {
    Lm95214TypeStatusTcrit get ();
}
member StatusTCRIT2Remote1 : Lm95214TypeStatusTcrit with get

Property Value

Type: Lm95214TypeStatusTcrit
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusTCRIT2Remote2 Property

IRD

Lm95214StatusTCRIT2Remote2 Property

Status TCRIT2: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusTcrit StatusTCRIT2Remote2 { get; }
Public ReadOnly Property StatusTCRIT2Remote2 As Lm95214TypeStatusTcrit
    Get
public:
property Lm95214TypeStatusTcrit StatusTCRIT2Remote2 {
    Lm95214TypeStatusTcrit get ();
}
member StatusTCRIT2Remote2 : Lm95214TypeStatusTcrit with get

Property Value

Type: Lm95214TypeStatusTcrit
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusTCRIT2Remote3 Property

IRD

Lm95214StatusTCRIT2Remote3 Property

Status TCRIT2: Remote 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusTcrit StatusTCRIT2Remote3 { get; }
Public ReadOnly Property StatusTCRIT2Remote3 As Lm95214TypeStatusTcrit
    Get
public:
property Lm95214TypeStatusTcrit StatusTCRIT2Remote3 {
    Lm95214TypeStatusTcrit get ();
}
member StatusTCRIT2Remote3 : Lm95214TypeStatusTcrit with get

Property Value

Type: Lm95214TypeStatusTcrit
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusTCRIT2Remote4 Property

IRD

Lm95214StatusTCRIT2Remote4 Property

Status TCRIT2: Remote 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusTcrit StatusTCRIT2Remote4 { get; }
Public ReadOnly Property StatusTCRIT2Remote4 As Lm95214TypeStatusTcrit
    Get
public:
property Lm95214TypeStatusTcrit StatusTCRIT2Remote4 {
    Lm95214TypeStatusTcrit get ();
}
member StatusTCRIT2Remote4 : Lm95214TypeStatusTcrit with get

Property Value

Type: Lm95214TypeStatusTcrit
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusTCRIT3Local Property

IRD

Lm95214StatusTCRIT3Local Property

Status TCRIT3: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusTcrit StatusTCRIT3Local { get; }
Public ReadOnly Property StatusTCRIT3Local As Lm95214TypeStatusTcrit
    Get
public:
property Lm95214TypeStatusTcrit StatusTCRIT3Local {
    Lm95214TypeStatusTcrit get ();
}
member StatusTCRIT3Local : Lm95214TypeStatusTcrit with get

Property Value

Type: Lm95214TypeStatusTcrit
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusTCRIT3Remote1 Property

IRD

Lm95214StatusTCRIT3Remote1 Property

Status TCRIT3: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusTcrit StatusTCRIT3Remote1 { get; }
Public ReadOnly Property StatusTCRIT3Remote1 As Lm95214TypeStatusTcrit
    Get
public:
property Lm95214TypeStatusTcrit StatusTCRIT3Remote1 {
    Lm95214TypeStatusTcrit get ();
}
member StatusTCRIT3Remote1 : Lm95214TypeStatusTcrit with get

Property Value

Type: Lm95214TypeStatusTcrit
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusTCRIT3Remote2 Property

IRD

Lm95214StatusTCRIT3Remote2 Property

Status TCRIT3: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusTcrit StatusTCRIT3Remote2 { get; }
Public ReadOnly Property StatusTCRIT3Remote2 As Lm95214TypeStatusTcrit
    Get
public:
property Lm95214TypeStatusTcrit StatusTCRIT3Remote2 {
    Lm95214TypeStatusTcrit get ();
}
member StatusTCRIT3Remote2 : Lm95214TypeStatusTcrit with get

Property Value

Type: Lm95214TypeStatusTcrit
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusTCRIT3Remote3 Property

IRD

Lm95214StatusTCRIT3Remote3 Property

Status TCRIT3: Remote 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusTcrit StatusTCRIT3Remote3 { get; }
Public ReadOnly Property StatusTCRIT3Remote3 As Lm95214TypeStatusTcrit
    Get
public:
property Lm95214TypeStatusTcrit StatusTCRIT3Remote3 {
    Lm95214TypeStatusTcrit get ();
}
member StatusTCRIT3Remote3 : Lm95214TypeStatusTcrit with get

Property Value

Type: Lm95214TypeStatusTcrit
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.StatusTCRIT3Remote4 Property

IRD

Lm95214StatusTCRIT3Remote4 Property

Status TCRIT3: Remote 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeStatusTcrit StatusTCRIT3Remote4 { get; }
Public ReadOnly Property StatusTCRIT3Remote4 As Lm95214TypeStatusTcrit
    Get
public:
property Lm95214TypeStatusTcrit StatusTCRIT3Remote4 {
    Lm95214TypeStatusTcrit get ();
}
member StatusTCRIT3Remote4 : Lm95214TypeStatusTcrit with get

Property Value

Type: Lm95214TypeStatusTcrit
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.TCRIT1MaskLocal Property

IRD

Lm95214TCRIT1MaskLocal Property

TCRIT1 Mask: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeMask TCRIT1MaskLocal { get; set; }
Public Property TCRIT1MaskLocal As Lm95214TypeMask
    Get
    Set
public:
property Lm95214TypeMask TCRIT1MaskLocal {
    Lm95214TypeMask get ();
    void set (Lm95214TypeMask value);
}
member TCRIT1MaskLocal : Lm95214TypeMask with get, set

Property Value

Type: Lm95214TypeMask
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.TCRIT1MaskRemote1 Property

IRD

Lm95214TCRIT1MaskRemote1 Property

TCRIT1 Mask: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeMask TCRIT1MaskRemote1 { get; set; }
Public Property TCRIT1MaskRemote1 As Lm95214TypeMask
    Get
    Set
public:
property Lm95214TypeMask TCRIT1MaskRemote1 {
    Lm95214TypeMask get ();
    void set (Lm95214TypeMask value);
}
member TCRIT1MaskRemote1 : Lm95214TypeMask with get, set

Property Value

Type: Lm95214TypeMask
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.TCRIT1MaskRemote2 Property

IRD

Lm95214TCRIT1MaskRemote2 Property

TCRIT1 Mask: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeMask TCRIT1MaskRemote2 { get; set; }
Public Property TCRIT1MaskRemote2 As Lm95214TypeMask
    Get
    Set
public:
property Lm95214TypeMask TCRIT1MaskRemote2 {
    Lm95214TypeMask get ();
    void set (Lm95214TypeMask value);
}
member TCRIT1MaskRemote2 : Lm95214TypeMask with get, set

Property Value

Type: Lm95214TypeMask
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.TCRIT1MaskRemote3 Property

IRD

Lm95214TCRIT1MaskRemote3 Property

TCRIT1 Mask: Remote 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeMask TCRIT1MaskRemote3 { get; set; }
Public Property TCRIT1MaskRemote3 As Lm95214TypeMask
    Get
    Set
public:
property Lm95214TypeMask TCRIT1MaskRemote3 {
    Lm95214TypeMask get ();
    void set (Lm95214TypeMask value);
}
member TCRIT1MaskRemote3 : Lm95214TypeMask with get, set

Property Value

Type: Lm95214TypeMask
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.TCRIT1MaskRemote4 Property

IRD

Lm95214TCRIT1MaskRemote4 Property

TCRIT1 Mask: Remote 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeMask TCRIT1MaskRemote4 { get; set; }
Public Property TCRIT1MaskRemote4 As Lm95214TypeMask
    Get
    Set
public:
property Lm95214TypeMask TCRIT1MaskRemote4 {
    Lm95214TypeMask get ();
    void set (Lm95214TypeMask value);
}
member TCRIT1MaskRemote4 : Lm95214TypeMask with get, set

Property Value

Type: Lm95214TypeMask
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.TCRIT2MaskLocal Property

IRD

Lm95214TCRIT2MaskLocal Property

TCRIT2 Mask: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeMask TCRIT2MaskLocal { get; set; }
Public Property TCRIT2MaskLocal As Lm95214TypeMask
    Get
    Set
public:
property Lm95214TypeMask TCRIT2MaskLocal {
    Lm95214TypeMask get ();
    void set (Lm95214TypeMask value);
}
member TCRIT2MaskLocal : Lm95214TypeMask with get, set

Property Value

Type: Lm95214TypeMask
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.TCRIT2MaskRemote1 Property

IRD

Lm95214TCRIT2MaskRemote1 Property

TCRIT2 Mask: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeMask TCRIT2MaskRemote1 { get; set; }
Public Property TCRIT2MaskRemote1 As Lm95214TypeMask
    Get
    Set
public:
property Lm95214TypeMask TCRIT2MaskRemote1 {
    Lm95214TypeMask get ();
    void set (Lm95214TypeMask value);
}
member TCRIT2MaskRemote1 : Lm95214TypeMask with get, set

Property Value

Type: Lm95214TypeMask
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.TCRIT2MaskRemote2 Property

IRD

Lm95214TCRIT2MaskRemote2 Property

TCRIT2 Mask: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeMask TCRIT2MaskRemote2 { get; set; }
Public Property TCRIT2MaskRemote2 As Lm95214TypeMask
    Get
    Set
public:
property Lm95214TypeMask TCRIT2MaskRemote2 {
    Lm95214TypeMask get ();
    void set (Lm95214TypeMask value);
}
member TCRIT2MaskRemote2 : Lm95214TypeMask with get, set

Property Value

Type: Lm95214TypeMask
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.TCRIT2MaskRemote3 Property

IRD

Lm95214TCRIT2MaskRemote3 Property

TCRIT2 Mask: Remote 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeMask TCRIT2MaskRemote3 { get; set; }
Public Property TCRIT2MaskRemote3 As Lm95214TypeMask
    Get
    Set
public:
property Lm95214TypeMask TCRIT2MaskRemote3 {
    Lm95214TypeMask get ();
    void set (Lm95214TypeMask value);
}
member TCRIT2MaskRemote3 : Lm95214TypeMask with get, set

Property Value

Type: Lm95214TypeMask
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.TCRIT2MaskRemote4 Property

IRD

Lm95214TCRIT2MaskRemote4 Property

TCRIT2 Mask: Remote 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeMask TCRIT2MaskRemote4 { get; set; }
Public Property TCRIT2MaskRemote4 As Lm95214TypeMask
    Get
    Set
public:
property Lm95214TypeMask TCRIT2MaskRemote4 {
    Lm95214TypeMask get ();
    void set (Lm95214TypeMask value);
}
member TCRIT2MaskRemote4 : Lm95214TypeMask with get, set

Property Value

Type: Lm95214TypeMask
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.TCRIT3MaskLocal Property

IRD

Lm95214TCRIT3MaskLocal Property

TCRIT3 Mask: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeMask TCRIT3MaskLocal { get; set; }
Public Property TCRIT3MaskLocal As Lm95214TypeMask
    Get
    Set
public:
property Lm95214TypeMask TCRIT3MaskLocal {
    Lm95214TypeMask get ();
    void set (Lm95214TypeMask value);
}
member TCRIT3MaskLocal : Lm95214TypeMask with get, set

Property Value

Type: Lm95214TypeMask
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.TCRIT3MaskRemote1 Property

IRD

Lm95214TCRIT3MaskRemote1 Property

TCRIT3 Mask: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeMask TCRIT3MaskRemote1 { get; set; }
Public Property TCRIT3MaskRemote1 As Lm95214TypeMask
    Get
    Set
public:
property Lm95214TypeMask TCRIT3MaskRemote1 {
    Lm95214TypeMask get ();
    void set (Lm95214TypeMask value);
}
member TCRIT3MaskRemote1 : Lm95214TypeMask with get, set

Property Value

Type: Lm95214TypeMask
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.TCRIT3MaskRemote2 Property

IRD

Lm95214TCRIT3MaskRemote2 Property

TCRIT3 Mask: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeMask TCRIT3MaskRemote2 { get; set; }
Public Property TCRIT3MaskRemote2 As Lm95214TypeMask
    Get
    Set
public:
property Lm95214TypeMask TCRIT3MaskRemote2 {
    Lm95214TypeMask get ();
    void set (Lm95214TypeMask value);
}
member TCRIT3MaskRemote2 : Lm95214TypeMask with get, set

Property Value

Type: Lm95214TypeMask
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.TCRIT3MaskRemote3 Property

IRD

Lm95214TCRIT3MaskRemote3 Property

TCRIT3 Mask: Remote 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeMask TCRIT3MaskRemote3 { get; set; }
Public Property TCRIT3MaskRemote3 As Lm95214TypeMask
    Get
    Set
public:
property Lm95214TypeMask TCRIT3MaskRemote3 {
    Lm95214TypeMask get ();
    void set (Lm95214TypeMask value);
}
member TCRIT3MaskRemote3 : Lm95214TypeMask with get, set

Property Value

Type: Lm95214TypeMask
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.TCRIT3MaskRemote4 Property

IRD

Lm95214TCRIT3MaskRemote4 Property

TCRIT3 Mask: Remote 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95214TypeMask TCRIT3MaskRemote4 { get; set; }
Public Property TCRIT3MaskRemote4 As Lm95214TypeMask
    Get
    Set
public:
property Lm95214TypeMask TCRIT3MaskRemote4 {
    Lm95214TypeMask get ();
    void set (Lm95214TypeMask value);
}
member TCRIT3MaskRemote4 : Lm95214TypeMask with get, set

Property Value

Type: Lm95214TypeMask
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214 Methods

The Lm95214 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Method_1Shot | 1-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.Flush Method

IRD

Lm95214Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.Method_1Shot Method

IRD

Lm95214Method_1Shot Method

1-Shot

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Method_1Shot()
Public Sub Method_1Shot
public:
void Method_1Shot()
member Method_1Shot : unit -> unit
See Also

Reference

Lm95214 Class
telos.Ird.NationalSemiconductor Namespace


Lm95214.TypeChannelConversionEnable Enumeration

IRD

Lm95214TypeChannelConversionEnable Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelConversionEnable
Public Enumeration TypeChannelConversionEnable
public enum class TypeChannelConversionEnable
type TypeChannelConversionEnable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95214.TypeCommonStatusBusy Enumeration

IRD

Lm95214TypeCommonStatusBusy Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommonStatusBusy
Public Enumeration TypeCommonStatusBusy
public enum class TypeCommonStatusBusy
type TypeCommonStatusBusy
Members
Member name | Value | Description
NotBusy | 0 | Not Busy
Busy | 1 | Busy
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95214.TypeCommonStatusNr Enumeration

IRD

Lm95214TypeCommonStatusNr Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommonStatusNr
Public Enumeration TypeCommonStatusNr
public enum class TypeCommonStatusNr
type TypeCommonStatusNr
Members
Member name | Value | Description
Ready | 0 | Ready
NotReady | 1 | Not Ready
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95214.TypeCommonStatusSr Enumeration

IRD

Lm95214TypeCommonStatusSr Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommonStatusSr
Public Enumeration TypeCommonStatusSr
public enum class TypeCommonStatusSr
type TypeCommonStatusSr
Members
Member name | Value | Description
AllBitsAreCleared | 0 | All Bits Are Cleared
AtLeastOneBitSet | 1 | At Least One Bit Set
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95214.TypeConfigurationFaultQueue Enumeration

IRD

Lm95214TypeConfigurationFaultQueue Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationFaultQueue
Public Enumeration TypeConfigurationFaultQueue
public enum class TypeConfigurationFaultQueue
type TypeConfigurationFaultQueue
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95214.TypeConfigurationStby Enumeration

IRD

Lm95214TypeConfigurationStby Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationStby
Public Enumeration TypeConfigurationStby
public enum class TypeConfigurationStby
type TypeConfigurationStby
Members
Member name | Value | Description
ActiveConverting | 0 | Active/Converting
Standby | 1 | Standby
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95214.TypeConversionRate Enumeration

IRD

Lm95214TypeConversionRate Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConversionRate
Public Enumeration TypeConversionRate
public enum class TypeConversionRate
type TypeConversionRate
Members
Member name | Value | Description
Continuous30MsTo104Ms | 0 | Continuous (30 ms to 104 ms)
Value_0364S | 1 | 0.364 s
Value_1S | 2 | 1 s
Value_25S | 3 | 2.5 s
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95214.TypeFilterSetting Enumeration

IRD

Lm95214TypeFilterSetting Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFilterSetting
Public Enumeration TypeFilterSetting
public enum class TypeFilterSetting
type TypeFilterSetting
Members
Member name | Value | Description
DisableAllDigitalFiltering | 0 | Disable all digital filtering
EnableBasicFilter | 1 | Enable basic filter
Reserved | 2 | Reserved
EnableEnhancedFilter | 3 | Enable enhanced filter
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95214.TypeMask Enumeration

IRD

Lm95214TypeMask Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMask
Public Enumeration TypeMask
public enum class TypeMask
type TypeMask
Members
Member name | Value | Description
PinTriggered | 0 | Pin: Triggered
PinNotTriggered | 1 | Pin: Not Triggered
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95214.TypeStatusFault Enumeration

IRD

Lm95214TypeStatusFault Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusFault
Public Enumeration TypeStatusFault
public enum class TypeStatusFault
type TypeStatusFault
Members
Member name | Value | Description
NoFault | 0 | No Fault
Fault | 1 | Fault
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95214.TypeStatusTcrit Enumeration

IRD

Lm95214TypeStatusTcrit Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusTcrit
Public Enumeration TypeStatusTcrit
public enum class TypeStatusTcrit
type TypeStatusTcrit
Members
Member name | Value | Description
TTCRITTCRITHYSTERESIS | 0 | T < TCRIT - TCRIT_HYSTERESIS
TTCRIT | 1 | T >= TCRIT
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95221 Class

National Semiconductor: LM 95221
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm95221

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm95221
Public Class Lm95221
public ref class Lm95221
type Lm95221 =  class end

The Lm95221 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm95221 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationConversionRate | Configuration: Conversion Rate
Public property | ConfigurationRemote1DataFormat | Configuration: Remote 1 Data Format
Public property | ConfigurationRemote2DataFormat | Configuration: Remote 2 Data Format
Public property | ConfigurationRUNSTOP | Configuration: RUN/STOP
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | RemoteTemperature1Signed | Remote Temperature 1 - Signed (unit: °C)
Public property | RemoteTemperature1Unsigned | Remote Temperature 1 - Unsigned (unit: °C)
Public property | RemoteTemperature2Signed | Remote Temperature 2 - Signed (unit: °C)
Public property | RemoteTemperature2Unsigned | Remote Temperature 2 - Unsigned (unit: °C)
Public property | RevisionID | Revision ID
Public property | StatusBusy | Status: Busy
Public property | StatusRemoteDiode1Missing | Status: Remote Diode 1 Missing
Public property | StatusRemoteDiode2Missing | Status: Remote Diode 2 Missing
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Dual Remote Diode Digital Temperature Sensor with SMBus Interface
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95221 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95221(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm95221(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm95221

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221 Properties

The Lm95221 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationConversionRate | Configuration: Conversion Rate
Public property | ConfigurationRemote1DataFormat | Configuration: Remote 1 Data Format
Public property | ConfigurationRemote2DataFormat | Configuration: Remote 2 Data Format
Public property | ConfigurationRUNSTOP | Configuration: RUN/STOP
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | RemoteTemperature1Signed | Remote Temperature 1 - Signed (unit: °C)
Public property | RemoteTemperature1Unsigned | Remote Temperature 1 - Unsigned (unit: °C)
Public property | RemoteTemperature2Signed | Remote Temperature 2 - Signed (unit: °C)
Public property | RemoteTemperature2Unsigned | Remote Temperature 2 - Unsigned (unit: °C)
Public property | RevisionID | Revision ID
Public property | StatusBusy | Status: Busy
Public property | StatusRemoteDiode1Missing | Status: Remote Diode 1 Missing
Public property | StatusRemoteDiode2Missing | Status: Remote Diode 2 Missing
Top
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221.AutoFlush Property

IRD

Lm95221AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221.ConfigurationConversionRate Property

IRD

Lm95221ConfigurationConversionRate Property

Configuration: Conversion Rate

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95221TypeConfigurationConversionRate ConfigurationConversionRate { get; set; }
Public Property ConfigurationConversionRate As Lm95221TypeConfigurationConversionRate
    Get
    Set
public:
property Lm95221TypeConfigurationConversionRate ConfigurationConversionRate {
    Lm95221TypeConfigurationConversionRate get ();
    void set (Lm95221TypeConfigurationConversionRate value);
}
member ConfigurationConversionRate : Lm95221TypeConfigurationConversionRate with get, set

Property Value

Type: Lm95221TypeConfigurationConversionRate
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221.ConfigurationRemote1DataFormat Property

IRD

Lm95221ConfigurationRemote1DataFormat Property

Configuration: Remote 1 Data Format

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95221TypeConfigurationDataFormat ConfigurationRemote1DataFormat { get; set; }
Public Property ConfigurationRemote1DataFormat As Lm95221TypeConfigurationDataFormat
    Get
    Set
public:
property Lm95221TypeConfigurationDataFormat ConfigurationRemote1DataFormat {
    Lm95221TypeConfigurationDataFormat get ();
    void set (Lm95221TypeConfigurationDataFormat value);
}
member ConfigurationRemote1DataFormat : Lm95221TypeConfigurationDataFormat with get, set

Property Value

Type: Lm95221TypeConfigurationDataFormat
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221.ConfigurationRemote2DataFormat Property

IRD

Lm95221ConfigurationRemote2DataFormat Property

Configuration: Remote 2 Data Format

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95221TypeConfigurationDataFormat ConfigurationRemote2DataFormat { get; set; }
Public Property ConfigurationRemote2DataFormat As Lm95221TypeConfigurationDataFormat
    Get
    Set
public:
property Lm95221TypeConfigurationDataFormat ConfigurationRemote2DataFormat {
    Lm95221TypeConfigurationDataFormat get ();
    void set (Lm95221TypeConfigurationDataFormat value);
}
member ConfigurationRemote2DataFormat : Lm95221TypeConfigurationDataFormat with get, set

Property Value

Type: Lm95221TypeConfigurationDataFormat
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221.ConfigurationRUNSTOP Property

IRD

Lm95221ConfigurationRUNSTOP Property

Configuration: RUN/STOP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95221TypeConfigurationRunStop ConfigurationRUNSTOP { get; set; }
Public Property ConfigurationRUNSTOP As Lm95221TypeConfigurationRunStop
    Get
    Set
public:
property Lm95221TypeConfigurationRunStop ConfigurationRUNSTOP {
    Lm95221TypeConfigurationRunStop get ();
    void set (Lm95221TypeConfigurationRunStop value);
}
member ConfigurationRUNSTOP : Lm95221TypeConfigurationRunStop with get, set

Property Value

Type: Lm95221TypeConfigurationRunStop
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221.LocalTemperature Property

IRD

Lm95221LocalTemperature Property

Local Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LocalTemperature { get; }
Public ReadOnly Property LocalTemperature As Double
    Get
public:
property double LocalTemperature {
    double get ();
}
member LocalTemperature : float with get

Property Value

Type: Double
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221.ManufacturerID Property

IRD

Lm95221ManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As Byte
    Get
public:
property unsigned char ManufacturerID {
    unsigned char get ();
}
member ManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221.RemoteTemperature1Signed Property

IRD

Lm95221RemoteTemperature1Signed Property

Remote Temperature 1 - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperature1Signed { get; }
Public ReadOnly Property RemoteTemperature1Signed As Double
    Get
public:
property double RemoteTemperature1Signed {
    double get ();
}
member RemoteTemperature1Signed : float with get

Property Value

Type: Double
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221.RemoteTemperature1Unsigned Property

IRD

Lm95221RemoteTemperature1Unsigned Property

Remote Temperature 1 - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperature1Unsigned { get; }
Public ReadOnly Property RemoteTemperature1Unsigned As Double
    Get
public:
property double RemoteTemperature1Unsigned {
    double get ();
}
member RemoteTemperature1Unsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221.RemoteTemperature2Signed Property

IRD

Lm95221RemoteTemperature2Signed Property

Remote Temperature 2 - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperature2Signed { get; }
Public ReadOnly Property RemoteTemperature2Signed As Double
    Get
public:
property double RemoteTemperature2Signed {
    double get ();
}
member RemoteTemperature2Signed : float with get

Property Value

Type: Double
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221.RemoteTemperature2Unsigned Property

IRD

Lm95221RemoteTemperature2Unsigned Property

Remote Temperature 2 - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperature2Unsigned { get; }
Public ReadOnly Property RemoteTemperature2Unsigned As Double
    Get
public:
property double RemoteTemperature2Unsigned {
    double get ();
}
member RemoteTemperature2Unsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221.RevisionID Property

IRD

Lm95221RevisionID Property

Revision ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionID { get; }
Public ReadOnly Property RevisionID As Byte
    Get
public:
property unsigned char RevisionID {
    unsigned char get ();
}
member RevisionID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221.StatusBusy Property

IRD

Lm95221StatusBusy Property

Status: Busy

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95221TypeStatusBusy StatusBusy { get; }
Public ReadOnly Property StatusBusy As Lm95221TypeStatusBusy
    Get
public:
property Lm95221TypeStatusBusy StatusBusy {
    Lm95221TypeStatusBusy get ();
}
member StatusBusy : Lm95221TypeStatusBusy with get

Property Value

Type: Lm95221TypeStatusBusy
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221.StatusRemoteDiode1Missing Property

IRD

Lm95221StatusRemoteDiode1Missing Property

Status: Remote Diode 1 Missing

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95221TypeStatusDiodeMissing StatusRemoteDiode1Missing { get; }
Public ReadOnly Property StatusRemoteDiode1Missing As Lm95221TypeStatusDiodeMissing
    Get
public:
property Lm95221TypeStatusDiodeMissing StatusRemoteDiode1Missing {
    Lm95221TypeStatusDiodeMissing get ();
}
member StatusRemoteDiode1Missing : Lm95221TypeStatusDiodeMissing with get

Property Value

Type: Lm95221TypeStatusDiodeMissing
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221.StatusRemoteDiode2Missing Property

IRD

Lm95221StatusRemoteDiode2Missing Property

Status: Remote Diode 2 Missing

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95221TypeStatusDiodeMissing StatusRemoteDiode2Missing { get; }
Public ReadOnly Property StatusRemoteDiode2Missing As Lm95221TypeStatusDiodeMissing
    Get
public:
property Lm95221TypeStatusDiodeMissing StatusRemoteDiode2Missing {
    Lm95221TypeStatusDiodeMissing get ();
}
member StatusRemoteDiode2Missing : Lm95221TypeStatusDiodeMissing with get

Property Value

Type: Lm95221TypeStatusDiodeMissing
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221 Methods

The Lm95221 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221.Flush Method

IRD

Lm95221Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm95221 Class
telos.Ird.NationalSemiconductor Namespace


Lm95221.TypeConfigurationConversionRate Enumeration

IRD

Lm95221TypeConfigurationConversionRate Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationConversionRate
Public Enumeration TypeConfigurationConversionRate
public enum class TypeConfigurationConversionRate
type TypeConfigurationConversionRate
Members
Member name | Value | Description
ContinuousMode66Ms15Hz | 0 | Continuous Mode 66 ms, 15 Hz
ConvertsEvery200Ms5Hz | 1 | Converts Every 200 ms, 5 Hz
ConvertsEvery1S1Hz | 2 | Converts Every 1 s, 1 Hz
ConvertsEvery3S13Hz | 3 | Converts Every 3 s, 1/3 Hz
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95221.TypeConfigurationDataFormat Enumeration

IRD

Lm95221TypeConfigurationDataFormat Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationDataFormat
Public Enumeration TypeConfigurationDataFormat
public enum class TypeConfigurationDataFormat
type TypeConfigurationDataFormat
Members
Member name | Value | Description
UnsignedFormat | 0 | Unsigned Format
SignedFormat | 1 | Signed Format
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95221.TypeConfigurationRunStop Enumeration

IRD

Lm95221TypeConfigurationRunStop Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationRunStop
Public Enumeration TypeConfigurationRunStop
public enum class TypeConfigurationRunStop
type TypeConfigurationRunStop
Members
Member name | Value | Description
Run | 0 | Run
Stop | 1 | Stop
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95221.TypeStatusBusy Enumeration

IRD

Lm95221TypeStatusBusy Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusBusy
Public Enumeration TypeStatusBusy
public enum class TypeStatusBusy
type TypeStatusBusy
Members
Member name | Value | Description
NotConverting | 0 | Not Converting
Converting | 1 | Converting
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95221.TypeStatusDiodeMissing Enumeration

IRD

Lm95221TypeStatusDiodeMissing Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusDiodeMissing
Public Enumeration TypeStatusDiodeMissing
public enum class TypeStatusDiodeMissing
type TypeStatusDiodeMissing
Members
Member name | Value | Description
DiodeOk | 0 | Diode Ok
DiodeMissing | 1 | Diode Missing
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95231 Class

National Semiconductor: LM 95231
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm95231

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm95231
Public Class Lm95231
public ref class Lm95231
type Lm95231 =  class end

The Lm95231 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm95231 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationConversionRate | Configuration: Conversion Rate
Public property | ConfigurationRemote1DataFormat | Configuration: Remote 1 Data Format
Public property | ConfigurationRemote2DataFormat | Configuration: Remote 2 Data Format
Public property | ConfigurationRUNSTOP | Configuration: RUN/STOP
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | Remote1TemperatureSigned | Remote 1 Temperature - Signed (unit: °C)
Public property | Remote1TemperatureUnsigned | Remote 1 Temperature - Unsigned (unit: °C)
Public property | Remote2TemperatureSigned | Remote 2 Temperature - Signed (unit: °C)
Public property | Remote2TemperatureUnsigned | Remote 2 Temperature - Unsigned (unit: °C)
Public property | RemoteDiodeFilterControlRemote1 | Remote Diode Filter Control: Remote 1
Public property | RemoteDiodeFilterControlRemote2 | Remote Diode Filter Control: Remote 2
Public property | RemoteDiodeModelTypeSelectRemote1 | Remote Diode Model Type Select: Remote 1
Public property | RemoteDiodeModelTypeSelectRemote2 | Remote Diode Model Type Select: Remote 2
Public property | RemoteTruThermModeControlRemote1 | Remote TruTherm Mode Control: Remote 1
Public property | RemoteTruThermModeControlRemote2 | Remote TruTherm Mode Control: Remote 2
Public property | RevisionID | Revision ID
Public property | StatusBusy | Status: Busy
Public property | StatusRemote1DiodeMissing | Status: Remote 1 Diode Missing
Public property | StatusRemote1TruThermModeEnable | Status: Remote 1 TruTherm Mode Enable
Public property | StatusRemote2DiodeMissing | Status: Remote 2 Diode Missing
Public property | StatusRemote2TruThermModeEnable | Status: Remote 2 TruTherm Mode Enable
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Method_1Shot | 1-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Precision Dual Remote Diode Temperature Sensor with SMBus Interface and TruTherm™ Technology
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95231 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95231(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm95231(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm95231

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231 Properties

The Lm95231 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationConversionRate | Configuration: Conversion Rate
Public property | ConfigurationRemote1DataFormat | Configuration: Remote 1 Data Format
Public property | ConfigurationRemote2DataFormat | Configuration: Remote 2 Data Format
Public property | ConfigurationRUNSTOP | Configuration: RUN/STOP
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | Remote1TemperatureSigned | Remote 1 Temperature - Signed (unit: °C)
Public property | Remote1TemperatureUnsigned | Remote 1 Temperature - Unsigned (unit: °C)
Public property | Remote2TemperatureSigned | Remote 2 Temperature - Signed (unit: °C)
Public property | Remote2TemperatureUnsigned | Remote 2 Temperature - Unsigned (unit: °C)
Public property | RemoteDiodeFilterControlRemote1 | Remote Diode Filter Control: Remote 1
Public property | RemoteDiodeFilterControlRemote2 | Remote Diode Filter Control: Remote 2
Public property | RemoteDiodeModelTypeSelectRemote1 | Remote Diode Model Type Select: Remote 1
Public property | RemoteDiodeModelTypeSelectRemote2 | Remote Diode Model Type Select: Remote 2
Public property | RemoteTruThermModeControlRemote1 | Remote TruTherm Mode Control: Remote 1
Public property | RemoteTruThermModeControlRemote2 | Remote TruTherm Mode Control: Remote 2
Public property | RevisionID | Revision ID
Public property | StatusBusy | Status: Busy
Public property | StatusRemote1DiodeMissing | Status: Remote 1 Diode Missing
Public property | StatusRemote1TruThermModeEnable | Status: Remote 1 TruTherm Mode Enable
Public property | StatusRemote2DiodeMissing | Status: Remote 2 Diode Missing
Public property | StatusRemote2TruThermModeEnable | Status: Remote 2 TruTherm Mode Enable
Top
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.AutoFlush Property

IRD

Lm95231AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.ConfigurationConversionRate Property

IRD

Lm95231ConfigurationConversionRate Property

Configuration: Conversion Rate

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95231TypeConfigurationConversionRate ConfigurationConversionRate { get; set; }
Public Property ConfigurationConversionRate As Lm95231TypeConfigurationConversionRate
    Get
    Set
public:
property Lm95231TypeConfigurationConversionRate ConfigurationConversionRate {
    Lm95231TypeConfigurationConversionRate get ();
    void set (Lm95231TypeConfigurationConversionRate value);
}
member ConfigurationConversionRate : Lm95231TypeConfigurationConversionRate with get, set

Property Value

Type: Lm95231TypeConfigurationConversionRate
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.ConfigurationRemote1DataFormat Property

IRD

Lm95231ConfigurationRemote1DataFormat Property

Configuration: Remote 1 Data Format

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95231TypeConfigurationDataFormat ConfigurationRemote1DataFormat { get; set; }
Public Property ConfigurationRemote1DataFormat As Lm95231TypeConfigurationDataFormat
    Get
    Set
public:
property Lm95231TypeConfigurationDataFormat ConfigurationRemote1DataFormat {
    Lm95231TypeConfigurationDataFormat get ();
    void set (Lm95231TypeConfigurationDataFormat value);
}
member ConfigurationRemote1DataFormat : Lm95231TypeConfigurationDataFormat with get, set

Property Value

Type: Lm95231TypeConfigurationDataFormat
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.ConfigurationRemote2DataFormat Property

IRD

Lm95231ConfigurationRemote2DataFormat Property

Configuration: Remote 2 Data Format

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95231TypeConfigurationDataFormat ConfigurationRemote2DataFormat { get; set; }
Public Property ConfigurationRemote2DataFormat As Lm95231TypeConfigurationDataFormat
    Get
    Set
public:
property Lm95231TypeConfigurationDataFormat ConfigurationRemote2DataFormat {
    Lm95231TypeConfigurationDataFormat get ();
    void set (Lm95231TypeConfigurationDataFormat value);
}
member ConfigurationRemote2DataFormat : Lm95231TypeConfigurationDataFormat with get, set

Property Value

Type: Lm95231TypeConfigurationDataFormat
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.ConfigurationRUNSTOP Property

IRD

Lm95231ConfigurationRUNSTOP Property

Configuration: RUN/STOP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95231TypeConfigurationRunStop ConfigurationRUNSTOP { get; set; }
Public Property ConfigurationRUNSTOP As Lm95231TypeConfigurationRunStop
    Get
    Set
public:
property Lm95231TypeConfigurationRunStop ConfigurationRUNSTOP {
    Lm95231TypeConfigurationRunStop get ();
    void set (Lm95231TypeConfigurationRunStop value);
}
member ConfigurationRUNSTOP : Lm95231TypeConfigurationRunStop with get, set

Property Value

Type: Lm95231TypeConfigurationRunStop
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.LocalTemperature Property

IRD

Lm95231LocalTemperature Property

Local Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LocalTemperature { get; }
Public ReadOnly Property LocalTemperature As Double
    Get
public:
property double LocalTemperature {
    double get ();
}
member LocalTemperature : float with get

Property Value

Type: Double
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.ManufacturerID Property

IRD

Lm95231ManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As Byte
    Get
public:
property unsigned char ManufacturerID {
    unsigned char get ();
}
member ManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.Remote1TemperatureSigned Property

IRD

Lm95231Remote1TemperatureSigned Property

Remote 1 Temperature - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote1TemperatureSigned { get; }
Public ReadOnly Property Remote1TemperatureSigned As Double
    Get
public:
property double Remote1TemperatureSigned {
    double get ();
}
member Remote1TemperatureSigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.Remote1TemperatureUnsigned Property

IRD

Lm95231Remote1TemperatureUnsigned Property

Remote 1 Temperature - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote1TemperatureUnsigned { get; }
Public ReadOnly Property Remote1TemperatureUnsigned As Double
    Get
public:
property double Remote1TemperatureUnsigned {
    double get ();
}
member Remote1TemperatureUnsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.Remote2TemperatureSigned Property

IRD

Lm95231Remote2TemperatureSigned Property

Remote 2 Temperature - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote2TemperatureSigned { get; }
Public ReadOnly Property Remote2TemperatureSigned As Double
    Get
public:
property double Remote2TemperatureSigned {
    double get ();
}
member Remote2TemperatureSigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.Remote2TemperatureUnsigned Property

IRD

Lm95231Remote2TemperatureUnsigned Property

Remote 2 Temperature - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote2TemperatureUnsigned { get; }
Public ReadOnly Property Remote2TemperatureUnsigned As Double
    Get
public:
property double Remote2TemperatureUnsigned {
    double get ();
}
member Remote2TemperatureUnsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.RemoteDiodeFilterControlRemote1 Property

IRD

Lm95231RemoteDiodeFilterControlRemote1 Property

Remote Diode Filter Control: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95231TypeRemoteDiodeFilterControl RemoteDiodeFilterControlRemote1 { get; set; }
Public Property RemoteDiodeFilterControlRemote1 As Lm95231TypeRemoteDiodeFilterControl
    Get
    Set
public:
property Lm95231TypeRemoteDiodeFilterControl RemoteDiodeFilterControlRemote1 {
    Lm95231TypeRemoteDiodeFilterControl get ();
    void set (Lm95231TypeRemoteDiodeFilterControl value);
}
member RemoteDiodeFilterControlRemote1 : Lm95231TypeRemoteDiodeFilterControl with get, set

Property Value

Type: Lm95231TypeRemoteDiodeFilterControl
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.RemoteDiodeFilterControlRemote2 Property

IRD

Lm95231RemoteDiodeFilterControlRemote2 Property

Remote Diode Filter Control: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95231TypeRemoteDiodeFilterControl RemoteDiodeFilterControlRemote2 { get; set; }
Public Property RemoteDiodeFilterControlRemote2 As Lm95231TypeRemoteDiodeFilterControl
    Get
    Set
public:
property Lm95231TypeRemoteDiodeFilterControl RemoteDiodeFilterControlRemote2 {
    Lm95231TypeRemoteDiodeFilterControl get ();
    void set (Lm95231TypeRemoteDiodeFilterControl value);
}
member RemoteDiodeFilterControlRemote2 : Lm95231TypeRemoteDiodeFilterControl with get, set

Property Value

Type: Lm95231TypeRemoteDiodeFilterControl
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.RemoteDiodeModelTypeSelectRemote1 Property

IRD

Lm95231RemoteDiodeModelTypeSelectRemote1 Property

Remote Diode Model Type Select: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95231TypeRemoteDiodeModelTypeSelect RemoteDiodeModelTypeSelectRemote1 { get; set; }
Public Property RemoteDiodeModelTypeSelectRemote1 As Lm95231TypeRemoteDiodeModelTypeSelect
    Get
    Set
public:
property Lm95231TypeRemoteDiodeModelTypeSelect RemoteDiodeModelTypeSelectRemote1 {
    Lm95231TypeRemoteDiodeModelTypeSelect get ();
    void set (Lm95231TypeRemoteDiodeModelTypeSelect value);
}
member RemoteDiodeModelTypeSelectRemote1 : Lm95231TypeRemoteDiodeModelTypeSelect with get, set

Property Value

Type: Lm95231TypeRemoteDiodeModelTypeSelect
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.RemoteDiodeModelTypeSelectRemote2 Property

IRD

Lm95231RemoteDiodeModelTypeSelectRemote2 Property

Remote Diode Model Type Select: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95231TypeRemoteDiodeModelTypeSelect RemoteDiodeModelTypeSelectRemote2 { get; set; }
Public Property RemoteDiodeModelTypeSelectRemote2 As Lm95231TypeRemoteDiodeModelTypeSelect
    Get
    Set
public:
property Lm95231TypeRemoteDiodeModelTypeSelect RemoteDiodeModelTypeSelectRemote2 {
    Lm95231TypeRemoteDiodeModelTypeSelect get ();
    void set (Lm95231TypeRemoteDiodeModelTypeSelect value);
}
member RemoteDiodeModelTypeSelectRemote2 : Lm95231TypeRemoteDiodeModelTypeSelect with get, set

Property Value

Type: Lm95231TypeRemoteDiodeModelTypeSelect
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.RemoteTruThermModeControlRemote1 Property

IRD

Lm95231RemoteTruThermModeControlRemote1 Property

Remote TruTherm Mode Control: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95231TypeRemoteTruthermModeControl RemoteTruThermModeControlRemote1 { get; set; }
Public Property RemoteTruThermModeControlRemote1 As Lm95231TypeRemoteTruthermModeControl
    Get
    Set
public:
property Lm95231TypeRemoteTruthermModeControl RemoteTruThermModeControlRemote1 {
    Lm95231TypeRemoteTruthermModeControl get ();
    void set (Lm95231TypeRemoteTruthermModeControl value);
}
member RemoteTruThermModeControlRemote1 : Lm95231TypeRemoteTruthermModeControl with get, set

Property Value

Type: Lm95231TypeRemoteTruthermModeControl
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.RemoteTruThermModeControlRemote2 Property

IRD

Lm95231RemoteTruThermModeControlRemote2 Property

Remote TruTherm Mode Control: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95231TypeRemoteTruthermModeControl RemoteTruThermModeControlRemote2 { get; set; }
Public Property RemoteTruThermModeControlRemote2 As Lm95231TypeRemoteTruthermModeControl
    Get
    Set
public:
property Lm95231TypeRemoteTruthermModeControl RemoteTruThermModeControlRemote2 {
    Lm95231TypeRemoteTruthermModeControl get ();
    void set (Lm95231TypeRemoteTruthermModeControl value);
}
member RemoteTruThermModeControlRemote2 : Lm95231TypeRemoteTruthermModeControl with get, set

Property Value

Type: Lm95231TypeRemoteTruthermModeControl
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.RevisionID Property

IRD

Lm95231RevisionID Property

Revision ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionID { get; }
Public ReadOnly Property RevisionID As Byte
    Get
public:
property unsigned char RevisionID {
    unsigned char get ();
}
member RevisionID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.StatusBusy Property

IRD

Lm95231StatusBusy Property

Status: Busy

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95231TypeStatusBusy StatusBusy { get; }
Public ReadOnly Property StatusBusy As Lm95231TypeStatusBusy
    Get
public:
property Lm95231TypeStatusBusy StatusBusy {
    Lm95231TypeStatusBusy get ();
}
member StatusBusy : Lm95231TypeStatusBusy with get

Property Value

Type: Lm95231TypeStatusBusy
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.StatusRemote1DiodeMissing Property

IRD

Lm95231StatusRemote1DiodeMissing Property

Status: Remote 1 Diode Missing

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95231TypeStatusDiodeMissing StatusRemote1DiodeMissing { get; }
Public ReadOnly Property StatusRemote1DiodeMissing As Lm95231TypeStatusDiodeMissing
    Get
public:
property Lm95231TypeStatusDiodeMissing StatusRemote1DiodeMissing {
    Lm95231TypeStatusDiodeMissing get ();
}
member StatusRemote1DiodeMissing : Lm95231TypeStatusDiodeMissing with get

Property Value

Type: Lm95231TypeStatusDiodeMissing
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.StatusRemote1TruThermModeEnable Property

IRD

Lm95231StatusRemote1TruThermModeEnable Property

Status: Remote 1 TruTherm Mode Enable

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95231TypeStatusTruthermMode StatusRemote1TruThermModeEnable { get; }
Public ReadOnly Property StatusRemote1TruThermModeEnable As Lm95231TypeStatusTruthermMode
    Get
public:
property Lm95231TypeStatusTruthermMode StatusRemote1TruThermModeEnable {
    Lm95231TypeStatusTruthermMode get ();
}
member StatusRemote1TruThermModeEnable : Lm95231TypeStatusTruthermMode with get

Property Value

Type: Lm95231TypeStatusTruthermMode
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.StatusRemote2DiodeMissing Property

IRD

Lm95231StatusRemote2DiodeMissing Property

Status: Remote 2 Diode Missing

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95231TypeStatusDiodeMissing StatusRemote2DiodeMissing { get; }
Public ReadOnly Property StatusRemote2DiodeMissing As Lm95231TypeStatusDiodeMissing
    Get
public:
property Lm95231TypeStatusDiodeMissing StatusRemote2DiodeMissing {
    Lm95231TypeStatusDiodeMissing get ();
}
member StatusRemote2DiodeMissing : Lm95231TypeStatusDiodeMissing with get

Property Value

Type: Lm95231TypeStatusDiodeMissing
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.StatusRemote2TruThermModeEnable Property

IRD

Lm95231StatusRemote2TruThermModeEnable Property

Status: Remote 2 TruTherm Mode Enable

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95231TypeStatusTruthermMode StatusRemote2TruThermModeEnable { get; }
Public ReadOnly Property StatusRemote2TruThermModeEnable As Lm95231TypeStatusTruthermMode
    Get
public:
property Lm95231TypeStatusTruthermMode StatusRemote2TruThermModeEnable {
    Lm95231TypeStatusTruthermMode get ();
}
member StatusRemote2TruThermModeEnable : Lm95231TypeStatusTruthermMode with get

Property Value

Type: Lm95231TypeStatusTruthermMode
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231 Methods

The Lm95231 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Method_1Shot | 1-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.Flush Method

IRD

Lm95231Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.Method_1Shot Method

IRD

Lm95231Method_1Shot Method

1-Shot

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Method_1Shot()
Public Sub Method_1Shot
public:
void Method_1Shot()
member Method_1Shot : unit -> unit
See Also

Reference

Lm95231 Class
telos.Ird.NationalSemiconductor Namespace


Lm95231.TypeConfigurationConversionRate Enumeration

IRD

Lm95231TypeConfigurationConversionRate Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationConversionRate
Public Enumeration TypeConfigurationConversionRate
public enum class TypeConfigurationConversionRate
type TypeConfigurationConversionRate
Members
Member name | Value | Description
ContinuousMode758Ms132Hz | 0 | Continuous Mode 75.8 ms, 13.2 Hz
ConvertsEvery128Ms55Hz | 1 | Converts Every 128 ms, 5.5 Hz
ConvertsEvery1S1Hz | 2 | Converts Every 1 s, 1 Hz
ConvertsEvery27S037Hz | 3 | Converts Every 2.7 s, 0.37 Hz
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95231.TypeConfigurationDataFormat Enumeration

IRD

Lm95231TypeConfigurationDataFormat Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationDataFormat
Public Enumeration TypeConfigurationDataFormat
public enum class TypeConfigurationDataFormat
type TypeConfigurationDataFormat
Members
Member name | Value | Description
Unsigned | 0 | Unsigned
Signed | 1 | Signed
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95231.TypeConfigurationRunStop Enumeration

IRD

Lm95231TypeConfigurationRunStop Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationRunStop
Public Enumeration TypeConfigurationRunStop
public enum class TypeConfigurationRunStop
type TypeConfigurationRunStop
Members
Member name | Value | Description
Run | 0 | Run
Stop | 1 | Stop
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95231.TypeRemoteDiodeFilterControl Enumeration

IRD

Lm95231TypeRemoteDiodeFilterControl Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRemoteDiodeFilterControl
Public Enumeration TypeRemoteDiodeFilterControl
public enum class TypeRemoteDiodeFilterControl
type TypeRemoteDiodeFilterControl
Members
Member name | Value | Description
FilterOff | 0 | Filter Off
NoiseFilterOn | 1 | Noise Filter On
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95231.TypeRemoteDiodeModelTypeSelect Enumeration

IRD

Lm95231TypeRemoteDiodeModelTypeSelect Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRemoteDiodeModelTypeSelect
Public Enumeration TypeRemoteDiodeModelTypeSelect
public enum class TypeRemoteDiodeModelTypeSelect
type TypeRemoteDiodeModelTypeSelect
Members
Member name | Value | Description
Value_2N3904 | 0 | 2N3904
Pentium4 | 1 | Pentium 4
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95231.TypeRemoteTruthermModeControl Enumeration

IRD

Lm95231TypeRemoteTruthermModeControl Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRemoteTruthermModeControl
Public Enumeration TypeRemoteTruthermModeControl
public enum class TypeRemoteTruthermModeControl
type TypeRemoteTruthermModeControl
Members
Member name | Value | Description
TruThermModeDisabled | 0 | TruTherm Mode: Disabled
TruThermModeEnabled | 1 | TruTherm Mode: Enabled
Reserved | 2 | Reserved
TruThermModeEnabled__1 | 7 | TruTherm Mode: Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95231.TypeStatusBusy Enumeration

IRD

Lm95231TypeStatusBusy Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusBusy
Public Enumeration TypeStatusBusy
public enum class TypeStatusBusy
type TypeStatusBusy
Members
Member name | Value | Description
NotConverting | 0 | Not Converting
Converting | 1 | Converting
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95231.TypeStatusDiodeMissing Enumeration

IRD

Lm95231TypeStatusDiodeMissing Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusDiodeMissing
Public Enumeration TypeStatusDiodeMissing
public enum class TypeStatusDiodeMissing
type TypeStatusDiodeMissing
Members
Member name | Value | Description
RemoteDiodeOk | 0 | Remote Diode: Ok
RemoteDiodeMissing | 1 | Remote Diode: Missing
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95231.TypeStatusTruthermMode Enumeration

IRD

Lm95231TypeStatusTruthermMode Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusTruthermMode
Public Enumeration TypeStatusTruthermMode
public enum class TypeStatusTruthermMode
type TypeStatusTruthermMode
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95233 Class

National Semiconductor: LM 95233
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm95233

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm95233
Public Class Lm95233
public ref class Lm95233
type Lm95233 =  class end

The Lm95233 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm95233 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelConversionEnableLocal | Channel Conversion Enable: Local
Public property | ChannelConversionEnableRemote1 | Channel Conversion Enable: Remote 1
Public property | ChannelConversionEnableRemote2 | Channel Conversion Enable: Remote 2
Public property | CommonStatusBusy | Common Status: Busy
Public property | CommonStatusNR | Common Status: NR
Public property | CommonStatusStatusRegister1Flag | Common Status: Status Register 1 Flag
Public property | CommonStatusStatusRegister2Flag | Common Status: Status Register 2 Flag
Public property | CommonStatusStatusRegister3Flag | Common Status: Status Register 3 Flag
Public property | CommonStatusStatusRegister4Flag | Common Status: Status Register 4 Flag
Public property | CommonTCRITHysteresis | Common TCRIT Hysteresis (unit: °C)
Public property | ConfigurationStandby | Configuration: Standby
Public property | ConversionRate | Conversion Rate
Public property | DiodeModelSelectRemote1TruTherm | Diode Model Select: Remote 1 TruTherm
Public property | DiodeModelSelectRemote2TruTherm | Diode Model Select: Remote 2 TruTherm
Public property | DiodeModelStatusRemote1 | Diode Model Status: Remote 1
Public property | DiodeModelStatusRemote2 | Diode Model Status: Remote 2
Public property | FilterSettingRemote1 | Filter Setting: Remote 1
Public property | FilterSettingRemote2 | Filter Setting: Remote 2
Public property | LocalTCRITLimit | Local TCRIT Limit (unit: °C)
Public property | LocalTemp | Local Temp (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | Remote1Offset | Remote 1 Offset (unit: °C)
Public property | Remote1TCRIT1Limit | Remote 1 TCRIT-1 Limit (unit: °C)
Public property | Remote1TCRIT2AndTCRIT3Limit | Remote 1 TCRIT-2 and TCRIT-3 Limit (unit: °C)
Public property | Remote2Offset | Remote 2 Offset (unit: °C)
Public property | Remote2TCRIT1Limit | Remote 2 TCRIT-1 Limit (unit: °C)
Public property | Remote2TCRIT2AndTCRIT3Limit | Remote 2 TCRIT-2 and TCRIT-3 Limit (unit: °C)
Public property | RemoteTemp1Signed | Remote Temp 1 - Signed (unit: °C)
Public property | RemoteTemp1Unsigned | Remote Temp 1 - Unsigned (unit: °C)
Public property | RemoteTemp2Signed | Remote Temp 2 - Signed (unit: °C)
Public property | RemoteTemp2Unsigned | Remote Temp 2 - Unsigned (unit: °C)
Public property | RevisionID | Revision ID
Public property | StatusRemote1DiodeOpenFault | Status: Remote 1 Diode Open Fault
Public property | StatusRemote1DiodeShortFault | Status: Remote 1 Diode Short Fault
Public property | StatusRemote2DiodeOpenFault | Status: Remote 2 Diode Open Fault
Public property | StatusRemote2DiodeShortFault | Status: Remote 2 Diode Short Fault
Public property | StatusTCRIT1Local | Status TCRIT1: Local
Public property | StatusTCRIT1Remote1 | Status TCRIT1: Remote 1
Public property | StatusTCRIT1Remote2 | Status TCRIT1: Remote 2
Public property | StatusTCRIT2Local | Status TCRIT2: Local
Public property | StatusTCRIT2Remote1 | Status TCRIT2: Remote 1
Public property | StatusTCRIT2Remote2 | Status TCRIT2: Remote 2
Public property | StatusTCRIT3Local | Status TCRIT3: Local
Public property | StatusTCRIT3Remote1 | Status TCRIT3: Remote 1
Public property | StatusTCRIT3Remote2 | Status TCRIT3: Remote 2
Public property | TCRIT1MaskLocal | TCRIT1 Mask: Local
Public property | TCRIT1MaskRemote1 | TCRIT1 Mask: Remote 1
Public property | TCRIT1MaskRemote2 | TCRIT1 Mask: Remote 2
Public property | TCRIT2MaskLocal | TCRIT2 Mask: Local
Public property | TCRIT2MaskRemote1 | TCRIT2 Mask: Remote 1
Public property | TCRIT2MaskRemote2 | TCRIT2 Mask: Remote 2
Public property | TCRIT3MaskLocal | TCRIT3 Mask: Local
Public property | TCRIT3MaskRemote1 | TCRIT3 Mask: Remote 1
Public property | TCRIT3MaskRemote2 | TCRIT3 Mask: Remote 2
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Method_1Shot | 1-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Dual Remote Diode and Local Temperature Sensor with SMBus Interface and TruTherm™ Technology
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95233 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm95233(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm95233

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233 Properties

The Lm95233 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelConversionEnableLocal | Channel Conversion Enable: Local
Public property | ChannelConversionEnableRemote1 | Channel Conversion Enable: Remote 1
Public property | ChannelConversionEnableRemote2 | Channel Conversion Enable: Remote 2
Public property | CommonStatusBusy | Common Status: Busy
Public property | CommonStatusNR | Common Status: NR
Public property | CommonStatusStatusRegister1Flag | Common Status: Status Register 1 Flag
Public property | CommonStatusStatusRegister2Flag | Common Status: Status Register 2 Flag
Public property | CommonStatusStatusRegister3Flag | Common Status: Status Register 3 Flag
Public property | CommonStatusStatusRegister4Flag | Common Status: Status Register 4 Flag
Public property | CommonTCRITHysteresis | Common TCRIT Hysteresis (unit: °C)
Public property | ConfigurationStandby | Configuration: Standby
Public property | ConversionRate | Conversion Rate
Public property | DiodeModelSelectRemote1TruTherm | Diode Model Select: Remote 1 TruTherm
Public property | DiodeModelSelectRemote2TruTherm | Diode Model Select: Remote 2 TruTherm
Public property | DiodeModelStatusRemote1 | Diode Model Status: Remote 1
Public property | DiodeModelStatusRemote2 | Diode Model Status: Remote 2
Public property | FilterSettingRemote1 | Filter Setting: Remote 1
Public property | FilterSettingRemote2 | Filter Setting: Remote 2
Public property | LocalTCRITLimit | Local TCRIT Limit (unit: °C)
Public property | LocalTemp | Local Temp (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | Remote1Offset | Remote 1 Offset (unit: °C)
Public property | Remote1TCRIT1Limit | Remote 1 TCRIT-1 Limit (unit: °C)
Public property | Remote1TCRIT2AndTCRIT3Limit | Remote 1 TCRIT-2 and TCRIT-3 Limit (unit: °C)
Public property | Remote2Offset | Remote 2 Offset (unit: °C)
Public property | Remote2TCRIT1Limit | Remote 2 TCRIT-1 Limit (unit: °C)
Public property | Remote2TCRIT2AndTCRIT3Limit | Remote 2 TCRIT-2 and TCRIT-3 Limit (unit: °C)
Public property | RemoteTemp1Signed | Remote Temp 1 - Signed (unit: °C)
Public property | RemoteTemp1Unsigned | Remote Temp 1 - Unsigned (unit: °C)
Public property | RemoteTemp2Signed | Remote Temp 2 - Signed (unit: °C)
Public property | RemoteTemp2Unsigned | Remote Temp 2 - Unsigned (unit: °C)
Public property | RevisionID | Revision ID
Public property | StatusRemote1DiodeOpenFault | Status: Remote 1 Diode Open Fault
Public property | StatusRemote1DiodeShortFault | Status: Remote 1 Diode Short Fault
Public property | StatusRemote2DiodeOpenFault | Status: Remote 2 Diode Open Fault
Public property | StatusRemote2DiodeShortFault | Status: Remote 2 Diode Short Fault
Public property | StatusTCRIT1Local | Status TCRIT1: Local
Public property | StatusTCRIT1Remote1 | Status TCRIT1: Remote 1
Public property | StatusTCRIT1Remote2 | Status TCRIT1: Remote 2
Public property | StatusTCRIT2Local | Status TCRIT2: Local
Public property | StatusTCRIT2Remote1 | Status TCRIT2: Remote 1
Public property | StatusTCRIT2Remote2 | Status TCRIT2: Remote 2
Public property | StatusTCRIT3Local | Status TCRIT3: Local
Public property | StatusTCRIT3Remote1 | Status TCRIT3: Remote 1
Public property | StatusTCRIT3Remote2 | Status TCRIT3: Remote 2
Public property | TCRIT1MaskLocal | TCRIT1 Mask: Local
Public property | TCRIT1MaskRemote1 | TCRIT1 Mask: Remote 1
Public property | TCRIT1MaskRemote2 | TCRIT1 Mask: Remote 2
Public property | TCRIT2MaskLocal | TCRIT2 Mask: Local
Public property | TCRIT2MaskRemote1 | TCRIT2 Mask: Remote 1
Public property | TCRIT2MaskRemote2 | TCRIT2 Mask: Remote 2
Public property | TCRIT3MaskLocal | TCRIT3 Mask: Local
Public property | TCRIT3MaskRemote1 | TCRIT3 Mask: Remote 1
Public property | TCRIT3MaskRemote2 | TCRIT3 Mask: Remote 2
Top
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.AutoFlush Property

IRD

Lm95233AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.ChannelConversionEnableLocal Property

IRD

Lm95233ChannelConversionEnableLocal Property

Channel Conversion Enable: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeChannelConversionEnable ChannelConversionEnableLocal { get; set; }
Public Property ChannelConversionEnableLocal As Lm95233TypeChannelConversionEnable
    Get
    Set
public:
property Lm95233TypeChannelConversionEnable ChannelConversionEnableLocal {
    Lm95233TypeChannelConversionEnable get ();
    void set (Lm95233TypeChannelConversionEnable value);
}
member ChannelConversionEnableLocal : Lm95233TypeChannelConversionEnable with get, set

Property Value

Type: Lm95233TypeChannelConversionEnable
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.ChannelConversionEnableRemote1 Property

IRD

Lm95233ChannelConversionEnableRemote1 Property

Channel Conversion Enable: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeChannelConversionEnable ChannelConversionEnableRemote1 { get; set; }
Public Property ChannelConversionEnableRemote1 As Lm95233TypeChannelConversionEnable
    Get
    Set
public:
property Lm95233TypeChannelConversionEnable ChannelConversionEnableRemote1 {
    Lm95233TypeChannelConversionEnable get ();
    void set (Lm95233TypeChannelConversionEnable value);
}
member ChannelConversionEnableRemote1 : Lm95233TypeChannelConversionEnable with get, set

Property Value

Type: Lm95233TypeChannelConversionEnable
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.ChannelConversionEnableRemote2 Property

IRD

Lm95233ChannelConversionEnableRemote2 Property

Channel Conversion Enable: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeChannelConversionEnable ChannelConversionEnableRemote2 { get; set; }
Public Property ChannelConversionEnableRemote2 As Lm95233TypeChannelConversionEnable
    Get
    Set
public:
property Lm95233TypeChannelConversionEnable ChannelConversionEnableRemote2 {
    Lm95233TypeChannelConversionEnable get ();
    void set (Lm95233TypeChannelConversionEnable value);
}
member ChannelConversionEnableRemote2 : Lm95233TypeChannelConversionEnable with get, set

Property Value

Type: Lm95233TypeChannelConversionEnable
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.CommonStatusBusy Property

IRD

Lm95233CommonStatusBusy Property

Common Status: Busy

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeCommonStatusBusy CommonStatusBusy { get; }
Public ReadOnly Property CommonStatusBusy As Lm95233TypeCommonStatusBusy
    Get
public:
property Lm95233TypeCommonStatusBusy CommonStatusBusy {
    Lm95233TypeCommonStatusBusy get ();
}
member CommonStatusBusy : Lm95233TypeCommonStatusBusy with get

Property Value

Type: Lm95233TypeCommonStatusBusy
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.CommonStatusNR Property

IRD

Lm95233CommonStatusNR Property

Common Status: NR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeCommonStatusNr CommonStatusNR { get; }
Public ReadOnly Property CommonStatusNR As Lm95233TypeCommonStatusNr
    Get
public:
property Lm95233TypeCommonStatusNr CommonStatusNR {
    Lm95233TypeCommonStatusNr get ();
}
member CommonStatusNR : Lm95233TypeCommonStatusNr with get

Property Value

Type: Lm95233TypeCommonStatusNr
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.CommonStatusStatusRegister1Flag Property

IRD

Lm95233CommonStatusStatusRegister1Flag Property

Common Status: Status Register 1 Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeCommonStatusSr CommonStatusStatusRegister1Flag { get; }
Public ReadOnly Property CommonStatusStatusRegister1Flag As Lm95233TypeCommonStatusSr
    Get
public:
property Lm95233TypeCommonStatusSr CommonStatusStatusRegister1Flag {
    Lm95233TypeCommonStatusSr get ();
}
member CommonStatusStatusRegister1Flag : Lm95233TypeCommonStatusSr with get

Property Value

Type: Lm95233TypeCommonStatusSr
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.CommonStatusStatusRegister2Flag Property

IRD

Lm95233CommonStatusStatusRegister2Flag Property

Common Status: Status Register 2 Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeCommonStatusSr CommonStatusStatusRegister2Flag { get; }
Public ReadOnly Property CommonStatusStatusRegister2Flag As Lm95233TypeCommonStatusSr
    Get
public:
property Lm95233TypeCommonStatusSr CommonStatusStatusRegister2Flag {
    Lm95233TypeCommonStatusSr get ();
}
member CommonStatusStatusRegister2Flag : Lm95233TypeCommonStatusSr with get

Property Value

Type: Lm95233TypeCommonStatusSr
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.CommonStatusStatusRegister3Flag Property

IRD

Lm95233CommonStatusStatusRegister3Flag Property

Common Status: Status Register 3 Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeCommonStatusSr CommonStatusStatusRegister3Flag { get; }
Public ReadOnly Property CommonStatusStatusRegister3Flag As Lm95233TypeCommonStatusSr
    Get
public:
property Lm95233TypeCommonStatusSr CommonStatusStatusRegister3Flag {
    Lm95233TypeCommonStatusSr get ();
}
member CommonStatusStatusRegister3Flag : Lm95233TypeCommonStatusSr with get

Property Value

Type: Lm95233TypeCommonStatusSr
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.CommonStatusStatusRegister4Flag Property

IRD

Lm95233CommonStatusStatusRegister4Flag Property

Common Status: Status Register 4 Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeCommonStatusSr CommonStatusStatusRegister4Flag { get; }
Public ReadOnly Property CommonStatusStatusRegister4Flag As Lm95233TypeCommonStatusSr
    Get
public:
property Lm95233TypeCommonStatusSr CommonStatusStatusRegister4Flag {
    Lm95233TypeCommonStatusSr get ();
}
member CommonStatusStatusRegister4Flag : Lm95233TypeCommonStatusSr with get

Property Value

Type: Lm95233TypeCommonStatusSr
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.CommonTCRITHysteresis Property

IRD

Lm95233CommonTCRITHysteresis Property

Common TCRIT Hysteresis (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CommonTCRITHysteresis { get; set; }
Public Property CommonTCRITHysteresis As Byte
    Get
    Set
public:
property unsigned char CommonTCRITHysteresis {
    unsigned char get ();
    void set (unsigned char value);
}
member CommonTCRITHysteresis : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.ConfigurationStandby Property

IRD

Lm95233ConfigurationStandby Property

Configuration: Standby

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeConfigurationStby ConfigurationStandby { get; set; }
Public Property ConfigurationStandby As Lm95233TypeConfigurationStby
    Get
    Set
public:
property Lm95233TypeConfigurationStby ConfigurationStandby {
    Lm95233TypeConfigurationStby get ();
    void set (Lm95233TypeConfigurationStby value);
}
member ConfigurationStandby : Lm95233TypeConfigurationStby with get, set

Property Value

Type: Lm95233TypeConfigurationStby
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.ConversionRate Property

IRD

Lm95233ConversionRate Property

Conversion Rate

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeConversionRate ConversionRate { get; set; }
Public Property ConversionRate As Lm95233TypeConversionRate
    Get
    Set
public:
property Lm95233TypeConversionRate ConversionRate {
    Lm95233TypeConversionRate get ();
    void set (Lm95233TypeConversionRate value);
}
member ConversionRate : Lm95233TypeConversionRate with get, set

Property Value

Type: Lm95233TypeConversionRate
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.DiodeModelSelectRemote1TruTherm Property

IRD

Lm95233DiodeModelSelectRemote1TruTherm Property

Diode Model Select: Remote 1 TruTherm

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeDiodeModelSelect DiodeModelSelectRemote1TruTherm { get; set; }
Public Property DiodeModelSelectRemote1TruTherm As Lm95233TypeDiodeModelSelect
    Get
    Set
public:
property Lm95233TypeDiodeModelSelect DiodeModelSelectRemote1TruTherm {
    Lm95233TypeDiodeModelSelect get ();
    void set (Lm95233TypeDiodeModelSelect value);
}
member DiodeModelSelectRemote1TruTherm : Lm95233TypeDiodeModelSelect with get, set

Property Value

Type: Lm95233TypeDiodeModelSelect
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.DiodeModelSelectRemote2TruTherm Property

IRD

Lm95233DiodeModelSelectRemote2TruTherm Property

Diode Model Select: Remote 2 TruTherm

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeDiodeModelSelect DiodeModelSelectRemote2TruTherm { get; set; }
Public Property DiodeModelSelectRemote2TruTherm As Lm95233TypeDiodeModelSelect
    Get
    Set
public:
property Lm95233TypeDiodeModelSelect DiodeModelSelectRemote2TruTherm {
    Lm95233TypeDiodeModelSelect get ();
    void set (Lm95233TypeDiodeModelSelect value);
}
member DiodeModelSelectRemote2TruTherm : Lm95233TypeDiodeModelSelect with get, set

Property Value

Type: Lm95233TypeDiodeModelSelect
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.DiodeModelStatusRemote1 Property

IRD

Lm95233DiodeModelStatusRemote1 Property

Diode Model Status: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeDiodeModelStatus DiodeModelStatusRemote1 { get; }
Public ReadOnly Property DiodeModelStatusRemote1 As Lm95233TypeDiodeModelStatus
    Get
public:
property Lm95233TypeDiodeModelStatus DiodeModelStatusRemote1 {
    Lm95233TypeDiodeModelStatus get ();
}
member DiodeModelStatusRemote1 : Lm95233TypeDiodeModelStatus with get

Property Value

Type: Lm95233TypeDiodeModelStatus
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.DiodeModelStatusRemote2 Property

IRD

Lm95233DiodeModelStatusRemote2 Property

Diode Model Status: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeDiodeModelStatus DiodeModelStatusRemote2 { get; }
Public ReadOnly Property DiodeModelStatusRemote2 As Lm95233TypeDiodeModelStatus
    Get
public:
property Lm95233TypeDiodeModelStatus DiodeModelStatusRemote2 {
    Lm95233TypeDiodeModelStatus get ();
}
member DiodeModelStatusRemote2 : Lm95233TypeDiodeModelStatus with get

Property Value

Type: Lm95233TypeDiodeModelStatus
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.FilterSettingRemote1 Property

IRD

Lm95233FilterSettingRemote1 Property

Filter Setting: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeFilterSetting FilterSettingRemote1 { get; set; }
Public Property FilterSettingRemote1 As Lm95233TypeFilterSetting
    Get
    Set
public:
property Lm95233TypeFilterSetting FilterSettingRemote1 {
    Lm95233TypeFilterSetting get ();
    void set (Lm95233TypeFilterSetting value);
}
member FilterSettingRemote1 : Lm95233TypeFilterSetting with get, set

Property Value

Type: Lm95233TypeFilterSetting
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.FilterSettingRemote2 Property

IRD

Lm95233FilterSettingRemote2 Property

Filter Setting: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeFilterSetting FilterSettingRemote2 { get; set; }
Public Property FilterSettingRemote2 As Lm95233TypeFilterSetting
    Get
    Set
public:
property Lm95233TypeFilterSetting FilterSettingRemote2 {
    Lm95233TypeFilterSetting get ();
    void set (Lm95233TypeFilterSetting value);
}
member FilterSettingRemote2 : Lm95233TypeFilterSetting with get, set

Property Value

Type: Lm95233TypeFilterSetting
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.LocalTCRITLimit Property

IRD

Lm95233LocalTCRITLimit Property

Local TCRIT Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalTCRITLimit { get; set; }
Public Property LocalTCRITLimit As Byte
    Get
    Set
public:
property unsigned char LocalTCRITLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member LocalTCRITLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.LocalTemp Property

IRD

Lm95233LocalTemp Property

Local Temp (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LocalTemp { get; }
Public ReadOnly Property LocalTemp As Double
    Get
public:
property double LocalTemp {
    double get ();
}
member LocalTemp : float with get

Property Value

Type: Double
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.ManufacturerID Property

IRD

Lm95233ManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As Byte
    Get
public:
property unsigned char ManufacturerID {
    unsigned char get ();
}
member ManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.Remote1Offset Property

IRD

Lm95233Remote1Offset Property

Remote 1 Offset (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote1Offset { get; set; }
Public Property Remote1Offset As Double
    Get
    Set
public:
property double Remote1Offset {
    double get ();
    void set (double value);
}
member Remote1Offset : float with get, set

Property Value

Type: Double
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.Remote1TCRIT1Limit Property

IRD

Lm95233Remote1TCRIT1Limit Property

Remote 1 TCRIT-1 Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote1TCRIT1Limit { get; set; }
Public Property Remote1TCRIT1Limit As Byte
    Get
    Set
public:
property unsigned char Remote1TCRIT1Limit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote1TCRIT1Limit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.Remote1TCRIT2AndTCRIT3Limit Property

IRD

Lm95233Remote1TCRIT2AndTCRIT3Limit Property

Remote 1 TCRIT-2 and TCRIT-3 Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote1TCRIT2AndTCRIT3Limit { get; set; }
Public Property Remote1TCRIT2AndTCRIT3Limit As Byte
    Get
    Set
public:
property unsigned char Remote1TCRIT2AndTCRIT3Limit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote1TCRIT2AndTCRIT3Limit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.Remote2Offset Property

IRD

Lm95233Remote2Offset Property

Remote 2 Offset (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote2Offset { get; set; }
Public Property Remote2Offset As Double
    Get
    Set
public:
property double Remote2Offset {
    double get ();
    void set (double value);
}
member Remote2Offset : float with get, set

Property Value

Type: Double
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.Remote2TCRIT1Limit Property

IRD

Lm95233Remote2TCRIT1Limit Property

Remote 2 TCRIT-1 Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote2TCRIT1Limit { get; set; }
Public Property Remote2TCRIT1Limit As Byte
    Get
    Set
public:
property unsigned char Remote2TCRIT1Limit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote2TCRIT1Limit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.Remote2TCRIT2AndTCRIT3Limit Property

IRD

Lm95233Remote2TCRIT2AndTCRIT3Limit Property

Remote 2 TCRIT-2 and TCRIT-3 Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote2TCRIT2AndTCRIT3Limit { get; set; }
Public Property Remote2TCRIT2AndTCRIT3Limit As Byte
    Get
    Set
public:
property unsigned char Remote2TCRIT2AndTCRIT3Limit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote2TCRIT2AndTCRIT3Limit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.RemoteTemp1Signed Property

IRD

Lm95233RemoteTemp1Signed Property

Remote Temp 1 - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp1Signed { get; }
Public ReadOnly Property RemoteTemp1Signed As Double
    Get
public:
property double RemoteTemp1Signed {
    double get ();
}
member RemoteTemp1Signed : float with get

Property Value

Type: Double
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.RemoteTemp1Unsigned Property

IRD

Lm95233RemoteTemp1Unsigned Property

Remote Temp 1 - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp1Unsigned { get; }
Public ReadOnly Property RemoteTemp1Unsigned As Double
    Get
public:
property double RemoteTemp1Unsigned {
    double get ();
}
member RemoteTemp1Unsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.RemoteTemp2Signed Property

IRD

Lm95233RemoteTemp2Signed Property

Remote Temp 2 - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp2Signed { get; }
Public ReadOnly Property RemoteTemp2Signed As Double
    Get
public:
property double RemoteTemp2Signed {
    double get ();
}
member RemoteTemp2Signed : float with get

Property Value

Type: Double
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.RemoteTemp2Unsigned Property

IRD

Lm95233RemoteTemp2Unsigned Property

Remote Temp 2 - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp2Unsigned { get; }
Public ReadOnly Property RemoteTemp2Unsigned As Double
    Get
public:
property double RemoteTemp2Unsigned {
    double get ();
}
member RemoteTemp2Unsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.RevisionID Property

IRD

Lm95233RevisionID Property

Revision ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionID { get; }
Public ReadOnly Property RevisionID As Byte
    Get
public:
property unsigned char RevisionID {
    unsigned char get ();
}
member RevisionID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.StatusRemote1DiodeOpenFault Property

IRD

Lm95233StatusRemote1DiodeOpenFault Property

Status: Remote 1 Diode Open Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeStatusFault StatusRemote1DiodeOpenFault { get; }
Public ReadOnly Property StatusRemote1DiodeOpenFault As Lm95233TypeStatusFault
    Get
public:
property Lm95233TypeStatusFault StatusRemote1DiodeOpenFault {
    Lm95233TypeStatusFault get ();
}
member StatusRemote1DiodeOpenFault : Lm95233TypeStatusFault with get

Property Value

Type: Lm95233TypeStatusFault
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.StatusRemote1DiodeShortFault Property

IRD

Lm95233StatusRemote1DiodeShortFault Property

Status: Remote 1 Diode Short Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeStatusFault StatusRemote1DiodeShortFault { get; }
Public ReadOnly Property StatusRemote1DiodeShortFault As Lm95233TypeStatusFault
    Get
public:
property Lm95233TypeStatusFault StatusRemote1DiodeShortFault {
    Lm95233TypeStatusFault get ();
}
member StatusRemote1DiodeShortFault : Lm95233TypeStatusFault with get

Property Value

Type: Lm95233TypeStatusFault
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.StatusRemote2DiodeOpenFault Property

IRD

Lm95233StatusRemote2DiodeOpenFault Property

Status: Remote 2 Diode Open Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeStatusFault StatusRemote2DiodeOpenFault { get; }
Public ReadOnly Property StatusRemote2DiodeOpenFault As Lm95233TypeStatusFault
    Get
public:
property Lm95233TypeStatusFault StatusRemote2DiodeOpenFault {
    Lm95233TypeStatusFault get ();
}
member StatusRemote2DiodeOpenFault : Lm95233TypeStatusFault with get

Property Value

Type: Lm95233TypeStatusFault
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.StatusRemote2DiodeShortFault Property

IRD

Lm95233StatusRemote2DiodeShortFault Property

Status: Remote 2 Diode Short Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeStatusFault StatusRemote2DiodeShortFault { get; }
Public ReadOnly Property StatusRemote2DiodeShortFault As Lm95233TypeStatusFault
    Get
public:
property Lm95233TypeStatusFault StatusRemote2DiodeShortFault {
    Lm95233TypeStatusFault get ();
}
member StatusRemote2DiodeShortFault : Lm95233TypeStatusFault with get

Property Value

Type: Lm95233TypeStatusFault
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.StatusTCRIT1Local Property

IRD

Lm95233StatusTCRIT1Local Property

Status TCRIT1: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeStatusTcrit StatusTCRIT1Local { get; }
Public ReadOnly Property StatusTCRIT1Local As Lm95233TypeStatusTcrit
    Get
public:
property Lm95233TypeStatusTcrit StatusTCRIT1Local {
    Lm95233TypeStatusTcrit get ();
}
member StatusTCRIT1Local : Lm95233TypeStatusTcrit with get

Property Value

Type: Lm95233TypeStatusTcrit
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.StatusTCRIT1Remote1 Property

IRD

Lm95233StatusTCRIT1Remote1 Property

Status TCRIT1: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeStatusTcrit StatusTCRIT1Remote1 { get; }
Public ReadOnly Property StatusTCRIT1Remote1 As Lm95233TypeStatusTcrit
    Get
public:
property Lm95233TypeStatusTcrit StatusTCRIT1Remote1 {
    Lm95233TypeStatusTcrit get ();
}
member StatusTCRIT1Remote1 : Lm95233TypeStatusTcrit with get

Property Value

Type: Lm95233TypeStatusTcrit
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.StatusTCRIT1Remote2 Property

IRD

Lm95233StatusTCRIT1Remote2 Property

Status TCRIT1: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeStatusTcrit StatusTCRIT1Remote2 { get; }
Public ReadOnly Property StatusTCRIT1Remote2 As Lm95233TypeStatusTcrit
    Get
public:
property Lm95233TypeStatusTcrit StatusTCRIT1Remote2 {
    Lm95233TypeStatusTcrit get ();
}
member StatusTCRIT1Remote2 : Lm95233TypeStatusTcrit with get

Property Value

Type: Lm95233TypeStatusTcrit
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.StatusTCRIT2Local Property

IRD

Lm95233StatusTCRIT2Local Property

Status TCRIT2: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeStatusTcrit StatusTCRIT2Local { get; }
Public ReadOnly Property StatusTCRIT2Local As Lm95233TypeStatusTcrit
    Get
public:
property Lm95233TypeStatusTcrit StatusTCRIT2Local {
    Lm95233TypeStatusTcrit get ();
}
member StatusTCRIT2Local : Lm95233TypeStatusTcrit with get

Property Value

Type: Lm95233TypeStatusTcrit
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.StatusTCRIT2Remote1 Property

IRD

Lm95233StatusTCRIT2Remote1 Property

Status TCRIT2: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeStatusTcrit StatusTCRIT2Remote1 { get; }
Public ReadOnly Property StatusTCRIT2Remote1 As Lm95233TypeStatusTcrit
    Get
public:
property Lm95233TypeStatusTcrit StatusTCRIT2Remote1 {
    Lm95233TypeStatusTcrit get ();
}
member StatusTCRIT2Remote1 : Lm95233TypeStatusTcrit with get

Property Value

Type: Lm95233TypeStatusTcrit
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.StatusTCRIT2Remote2 Property

IRD

Lm95233StatusTCRIT2Remote2 Property

Status TCRIT2: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeStatusTcrit StatusTCRIT2Remote2 { get; }
Public ReadOnly Property StatusTCRIT2Remote2 As Lm95233TypeStatusTcrit
    Get
public:
property Lm95233TypeStatusTcrit StatusTCRIT2Remote2 {
    Lm95233TypeStatusTcrit get ();
}
member StatusTCRIT2Remote2 : Lm95233TypeStatusTcrit with get

Property Value

Type: Lm95233TypeStatusTcrit
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.StatusTCRIT3Local Property

IRD

Lm95233StatusTCRIT3Local Property

Status TCRIT3: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeStatusTcrit StatusTCRIT3Local { get; }
Public ReadOnly Property StatusTCRIT3Local As Lm95233TypeStatusTcrit
    Get
public:
property Lm95233TypeStatusTcrit StatusTCRIT3Local {
    Lm95233TypeStatusTcrit get ();
}
member StatusTCRIT3Local : Lm95233TypeStatusTcrit with get

Property Value

Type: Lm95233TypeStatusTcrit
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.StatusTCRIT3Remote1 Property

IRD

Lm95233StatusTCRIT3Remote1 Property

Status TCRIT3: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeStatusTcrit StatusTCRIT3Remote1 { get; }
Public ReadOnly Property StatusTCRIT3Remote1 As Lm95233TypeStatusTcrit
    Get
public:
property Lm95233TypeStatusTcrit StatusTCRIT3Remote1 {
    Lm95233TypeStatusTcrit get ();
}
member StatusTCRIT3Remote1 : Lm95233TypeStatusTcrit with get

Property Value

Type: Lm95233TypeStatusTcrit
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.StatusTCRIT3Remote2 Property

IRD

Lm95233StatusTCRIT3Remote2 Property

Status TCRIT3: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeStatusTcrit StatusTCRIT3Remote2 { get; }
Public ReadOnly Property StatusTCRIT3Remote2 As Lm95233TypeStatusTcrit
    Get
public:
property Lm95233TypeStatusTcrit StatusTCRIT3Remote2 {
    Lm95233TypeStatusTcrit get ();
}
member StatusTCRIT3Remote2 : Lm95233TypeStatusTcrit with get

Property Value

Type: Lm95233TypeStatusTcrit
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.TCRIT1MaskLocal Property

IRD

Lm95233TCRIT1MaskLocal Property

TCRIT1 Mask: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeMask TCRIT1MaskLocal { get; set; }
Public Property TCRIT1MaskLocal As Lm95233TypeMask
    Get
    Set
public:
property Lm95233TypeMask TCRIT1MaskLocal {
    Lm95233TypeMask get ();
    void set (Lm95233TypeMask value);
}
member TCRIT1MaskLocal : Lm95233TypeMask with get, set

Property Value

Type: Lm95233TypeMask
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.TCRIT1MaskRemote1 Property

IRD

Lm95233TCRIT1MaskRemote1 Property

TCRIT1 Mask: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeMask TCRIT1MaskRemote1 { get; set; }
Public Property TCRIT1MaskRemote1 As Lm95233TypeMask
    Get
    Set
public:
property Lm95233TypeMask TCRIT1MaskRemote1 {
    Lm95233TypeMask get ();
    void set (Lm95233TypeMask value);
}
member TCRIT1MaskRemote1 : Lm95233TypeMask with get, set

Property Value

Type: Lm95233TypeMask
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.TCRIT1MaskRemote2 Property

IRD

Lm95233TCRIT1MaskRemote2 Property

TCRIT1 Mask: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeMask TCRIT1MaskRemote2 { get; set; }
Public Property TCRIT1MaskRemote2 As Lm95233TypeMask
    Get
    Set
public:
property Lm95233TypeMask TCRIT1MaskRemote2 {
    Lm95233TypeMask get ();
    void set (Lm95233TypeMask value);
}
member TCRIT1MaskRemote2 : Lm95233TypeMask with get, set

Property Value

Type: Lm95233TypeMask
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.TCRIT2MaskLocal Property

IRD

Lm95233TCRIT2MaskLocal Property

TCRIT2 Mask: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeMask TCRIT2MaskLocal { get; set; }
Public Property TCRIT2MaskLocal As Lm95233TypeMask
    Get
    Set
public:
property Lm95233TypeMask TCRIT2MaskLocal {
    Lm95233TypeMask get ();
    void set (Lm95233TypeMask value);
}
member TCRIT2MaskLocal : Lm95233TypeMask with get, set

Property Value

Type: Lm95233TypeMask
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.TCRIT2MaskRemote1 Property

IRD

Lm95233TCRIT2MaskRemote1 Property

TCRIT2 Mask: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeMask TCRIT2MaskRemote1 { get; set; }
Public Property TCRIT2MaskRemote1 As Lm95233TypeMask
    Get
    Set
public:
property Lm95233TypeMask TCRIT2MaskRemote1 {
    Lm95233TypeMask get ();
    void set (Lm95233TypeMask value);
}
member TCRIT2MaskRemote1 : Lm95233TypeMask with get, set

Property Value

Type: Lm95233TypeMask
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.TCRIT2MaskRemote2 Property

IRD

Lm95233TCRIT2MaskRemote2 Property

TCRIT2 Mask: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeMask TCRIT2MaskRemote2 { get; set; }
Public Property TCRIT2MaskRemote2 As Lm95233TypeMask
    Get
    Set
public:
property Lm95233TypeMask TCRIT2MaskRemote2 {
    Lm95233TypeMask get ();
    void set (Lm95233TypeMask value);
}
member TCRIT2MaskRemote2 : Lm95233TypeMask with get, set

Property Value

Type: Lm95233TypeMask
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.TCRIT3MaskLocal Property

IRD

Lm95233TCRIT3MaskLocal Property

TCRIT3 Mask: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeMask TCRIT3MaskLocal { get; set; }
Public Property TCRIT3MaskLocal As Lm95233TypeMask
    Get
    Set
public:
property Lm95233TypeMask TCRIT3MaskLocal {
    Lm95233TypeMask get ();
    void set (Lm95233TypeMask value);
}
member TCRIT3MaskLocal : Lm95233TypeMask with get, set

Property Value

Type: Lm95233TypeMask
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.TCRIT3MaskRemote1 Property

IRD

Lm95233TCRIT3MaskRemote1 Property

TCRIT3 Mask: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeMask TCRIT3MaskRemote1 { get; set; }
Public Property TCRIT3MaskRemote1 As Lm95233TypeMask
    Get
    Set
public:
property Lm95233TypeMask TCRIT3MaskRemote1 {
    Lm95233TypeMask get ();
    void set (Lm95233TypeMask value);
}
member TCRIT3MaskRemote1 : Lm95233TypeMask with get, set

Property Value

Type: Lm95233TypeMask
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.TCRIT3MaskRemote2 Property

IRD

Lm95233TCRIT3MaskRemote2 Property

TCRIT3 Mask: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95233TypeMask TCRIT3MaskRemote2 { get; set; }
Public Property TCRIT3MaskRemote2 As Lm95233TypeMask
    Get
    Set
public:
property Lm95233TypeMask TCRIT3MaskRemote2 {
    Lm95233TypeMask get ();
    void set (Lm95233TypeMask value);
}
member TCRIT3MaskRemote2 : Lm95233TypeMask with get, set

Property Value

Type: Lm95233TypeMask
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233 Methods

The Lm95233 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Method_1Shot | 1-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.Flush Method

IRD

Lm95233Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.Method_1Shot Method

IRD

Lm95233Method_1Shot Method

1-Shot

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Method_1Shot()
Public Sub Method_1Shot
public:
void Method_1Shot()
member Method_1Shot : unit -> unit
See Also

Reference

Lm95233 Class
telos.Ird.NationalSemiconductor Namespace


Lm95233.TypeChannelConversionEnable Enumeration

IRD

Lm95233TypeChannelConversionEnable Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelConversionEnable
Public Enumeration TypeChannelConversionEnable
public enum class TypeChannelConversionEnable
type TypeChannelConversionEnable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95233.TypeCommonStatusBusy Enumeration

IRD

Lm95233TypeCommonStatusBusy Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommonStatusBusy
Public Enumeration TypeCommonStatusBusy
public enum class TypeCommonStatusBusy
type TypeCommonStatusBusy
Members
Member name | Value | Description
NotBusy | 0 | Not Busy
Busy | 1 | Busy
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95233.TypeCommonStatusNr Enumeration

IRD

Lm95233TypeCommonStatusNr Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommonStatusNr
Public Enumeration TypeCommonStatusNr
public enum class TypeCommonStatusNr
type TypeCommonStatusNr
Members
Member name | Value | Description
Ready | 0 | Ready
NotReady | 1 | Not Ready
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95233.TypeCommonStatusSr Enumeration

IRD

Lm95233TypeCommonStatusSr Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommonStatusSr
Public Enumeration TypeCommonStatusSr
public enum class TypeCommonStatusSr
type TypeCommonStatusSr
Members
Member name | Value | Description
AllBitsAreCleared | 0 | All Bits Are Cleared
AtLeastOneBitSet | 1 | At Least One Bit Set
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95233.TypeConfigurationStby Enumeration

IRD

Lm95233TypeConfigurationStby Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationStby
Public Enumeration TypeConfigurationStby
public enum class TypeConfigurationStby
type TypeConfigurationStby
Members
Member name | Value | Description
ActiveConverting | 0 | Active/Converting
Standby | 1 | Standby
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95233.TypeConversionRate Enumeration

IRD

Lm95233TypeConversionRate Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConversionRate
Public Enumeration TypeConversionRate
public enum class TypeConversionRate
type TypeConversionRate
Members
Member name | Value | Description
Continuous30MsTo143Ms | 0 | Continuous (30 ms to 143 ms)
Value_0364S | 1 | 0.364 s
Value_1S | 2 | 1 s
Value_25S | 3 | 2.5 s
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95233.TypeDiodeModelSelect Enumeration

IRD

Lm95233TypeDiodeModelSelect Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDiodeModelSelect
Public Enumeration TypeDiodeModelSelect
public enum class TypeDiodeModelSelect
type TypeDiodeModelSelect
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95233.TypeDiodeModelStatus Enumeration

IRD

Lm95233TypeDiodeModelStatus Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDiodeModelStatus
Public Enumeration TypeDiodeModelStatus
public enum class TypeDiodeModelStatus
type TypeDiodeModelStatus
Members
Member name | Value | Description
ProperOperation | 0 | Proper Operation
TruThermOnAnd3904Connected | 1 | TruTherm On and 3904 Connected
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95233.TypeFilterSetting Enumeration

IRD

Lm95233TypeFilterSetting Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFilterSetting
Public Enumeration TypeFilterSetting
public enum class TypeFilterSetting
type TypeFilterSetting
Members
Member name | Value | Description
DisableAllDigitalFiltering | 0 | Disable all digital filtering
EnableBasicFilter | 1 | Enable basic filter
Reserved | 2 | Reserved
EnableEnhancedFilter | 3 | Enable enhanced filter
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95233.TypeMask Enumeration

IRD

Lm95233TypeMask Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMask
Public Enumeration TypeMask
public enum class TypeMask
type TypeMask
Members
Member name | Value | Description
PinTriggered | 0 | Pin: Triggered
PinNotTriggered | 1 | Pin: Not Triggered
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95233.TypeStatusFault Enumeration

IRD

Lm95233TypeStatusFault Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusFault
Public Enumeration TypeStatusFault
public enum class TypeStatusFault
type TypeStatusFault
Members
Member name | Value | Description
NoFault | 0 | No Fault
Fault | 1 | Fault
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95233.TypeStatusTcrit Enumeration

IRD

Lm95233TypeStatusTcrit Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusTcrit
Public Enumeration TypeStatusTcrit
public enum class TypeStatusTcrit
type TypeStatusTcrit
Members
Member name | Value | Description
TTCRITTCRITHYSTERESIS | 0 | T < TCRIT - TCRIT_HYSTERESIS
TTCRIT | 1 | T >= TCRIT
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95234 Class

National Semiconductor: LM 95234
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm95234

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm95234
Public Class Lm95234
public ref class Lm95234
type Lm95234 =  class end

The Lm95234 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm95234 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelConversionEnableLocal | Channel Conversion Enable: Local
Public property | ChannelConversionEnableRemote1 | Channel Conversion Enable: Remote 1
Public property | ChannelConversionEnableRemote2 | Channel Conversion Enable: Remote 2
Public property | ChannelConversionEnableRemote3 | Channel Conversion Enable: Remote 3
Public property | ChannelConversionEnableRemote4 | Channel Conversion Enable: Remote 4
Public property | CommonStatusBusy | Common Status: Busy
Public property | CommonStatusNR | Common Status: NR
Public property | CommonStatusStatusRegister1Flag | Common Status: Status Register 1 Flag
Public property | CommonStatusStatusRegister2Flag | Common Status: Status Register 2 Flag
Public property | CommonStatusStatusRegister3Flag | Common Status: Status Register 3 Flag
Public property | CommonStatusStatusRegister4Flag | Common Status: Status Register 4 Flag
Public property | CommonTCRITHysteresis | Common TCRIT Hysteresis (unit: °C)
Public property | ConfigurationFaultQueueRemote3 | Configuration: Fault Queue Remote 3
Public property | ConfigurationFaultQueueRemote4 | Configuration: Fault Queue Remote 4
Public property | ConfigurationStandby | Configuration: Standby
Public property | ConversionRate | Conversion Rate
Public property | DiodeModelSelectRemote1TruTherm | Diode Model Select: Remote 1 TruTherm
Public property | DiodeModelSelectRemote2TruTherm | Diode Model Select: Remote 2 TruTherm
Public property | DiodeModelSelectRemote3TruTherm | Diode Model Select: Remote 3 TruTherm
Public property | DiodeModelSelectRemote4TruTherm | Diode Model Select: Remote 4 TruTherm
Public property | DiodeModelStatusRemote1 | Diode Model Status: Remote 1
Public property | DiodeModelStatusRemote2 | Diode Model Status: Remote 2
Public property | DiodeModelStatusRemote3 | Diode Model Status: Remote 3
Public property | DiodeModelStatusRemote4 | Diode Model Status: Remote 4
Public property | FilterSettingRemote1 | Filter Setting: Remote 1
Public property | FilterSettingRemote2 | Filter Setting: Remote 2
Public property | LocalTCRITLimit | Local TCRIT Limit (unit: °C)
Public property | LocalTemp | Local Temp (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | Remote1Offset | Remote 1 Offset (unit: °C)
Public property | Remote1TCRIT1Limit | Remote 1 TCRIT-1 Limit (unit: °C)
Public property | Remote1TCRIT2AndTCRIT3Limit | Remote 1 TCRIT-2 and TCRIT-3 Limit (unit: °C)
Public property | Remote2Offset | Remote 2 Offset (unit: °C)
Public property | Remote2TCRIT1Limit | Remote 2 TCRIT-1 Limit (unit: °C)
Public property | Remote2TCRIT2AndTCRIT3Limit | Remote 2 TCRIT-2 and TCRIT-3 Limit (unit: °C)
Public property | Remote3Offset | Remote 3 Offset (unit: °C)
Public property | Remote3TCRITLimit | Remote 3 TCRIT Limit (unit: °C)
Public property | Remote4Offset | Remote 4 Offset (unit: °C)
Public property | Remote4TCRITLimit | Remote 4 TCRIT Limit (unit: °C)
Public property | RemoteTemp1Signed | Remote Temp 1 - Signed (unit: °C)
Public property | RemoteTemp1Unsigned | Remote Temp 1 - Unsigned (unit: °C)
Public property | RemoteTemp2Signed | Remote Temp 2 - Signed (unit: °C)
Public property | RemoteTemp2Unsigned | Remote Temp 2 - Unsigned (unit: °C)
Public property | RemoteTemp3Signed | Remote Temp 3 - Signed (unit: °C)
Public property | RemoteTemp3Unsigned | Remote Temp 3 - Unsigned (unit: °C)
Public property | RemoteTemp4Signed | Remote Temp 4 - Signed (unit: °C)
Public property | RemoteTemp4Unsigned | Remote Temp 4 - Unsigned (unit: °C)
Public property | RevisionID | Revision ID
Public property | StatusRemote1DiodeOpenFault | Status: Remote 1 Diode Open Fault
Public property | StatusRemote1DiodeShortFault | Status: Remote 1 Diode Short Fault
Public property | StatusRemote2DiodeOpenFault | Status: Remote 2 Diode Open Fault
Public property | StatusRemote2DiodeShortFault | Status: Remote 2 Diode Short Fault
Public property | StatusRemote3DiodeOpenFault | Status: Remote 3 Diode Open Fault
Public property | StatusRemote3DiodeShortFault | Status: Remote 3 Diode Short Fault
Public property | StatusRemote4DiodeOpenFault | Status: Remote 4 Diode Open Fault
Public property | StatusRemote4DiodeShortFault | Status: Remote 4 Diode Short Fault
Public property | StatusTCRIT1Local | Status TCRIT1: Local
Public property | StatusTCRIT1Remote1 | Status TCRIT1: Remote 1
Public property | StatusTCRIT1Remote2 | Status TCRIT1: Remote 2
Public property | StatusTCRIT1Remote3 | Status TCRIT1: Remote 3
Public property | StatusTCRIT1Remote4 | Status TCRIT1: Remote 4
Public property | StatusTCRIT2Local | Status TCRIT2: Local
Public property | StatusTCRIT2Remote1 | Status TCRIT2: Remote 1
Public property | StatusTCRIT2Remote2 | Status TCRIT2: Remote 2
Public property | StatusTCRIT2Remote3 | Status TCRIT2: Remote 3
Public property | StatusTCRIT2Remote4 | Status TCRIT2: Remote 4
Public property | StatusTCRIT3Local | Status TCRIT3: Local
Public property | StatusTCRIT3Remote1 | Status TCRIT3: Remote 1
Public property | StatusTCRIT3Remote2 | Status TCRIT3: Remote 2
Public property | StatusTCRIT3Remote3 | Status TCRIT3: Remote 3
Public property | StatusTCRIT3Remote4 | Status TCRIT3: Remote 4
Public property | TCRIT1MaskLocal | TCRIT1 Mask: Local
Public property | TCRIT1MaskRemote1 | TCRIT1 Mask: Remote 1
Public property | TCRIT1MaskRemote2 | TCRIT1 Mask: Remote 2
Public property | TCRIT1MaskRemote3 | TCRIT1 Mask: Remote 3
Public property | TCRIT1MaskRemote4 | TCRIT1 Mask: Remote 4
Public property | TCRIT2MaskLocal | TCRIT2 Mask: Local
Public property | TCRIT2MaskRemote1 | TCRIT2 Mask: Remote 1
Public property | TCRIT2MaskRemote2 | TCRIT2 Mask: Remote 2
Public property | TCRIT2MaskRemote3 | TCRIT2 Mask: Remote 3
Public property | TCRIT2MaskRemote4 | TCRIT2 Mask: Remote 4
Public property | TCRIT3MaskLocal | TCRIT3 Mask: Local
Public property | TCRIT3MaskRemote1 | TCRIT3 Mask: Remote 1
Public property | TCRIT3MaskRemote2 | TCRIT3 Mask: Remote 2
Public property | TCRIT3MaskRemote3 | TCRIT3 Mask: Remote 3
Public property | TCRIT3MaskRemote4 | TCRIT3 Mask: Remote 4
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Method_1Shot | 1-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Quad Remote Diode and Local Temperature Sensor with SMBus Interface and TruTherm™ Technology
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95234 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm95234(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm95234

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234 Properties

The Lm95234 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelConversionEnableLocal | Channel Conversion Enable: Local
Public property | ChannelConversionEnableRemote1 | Channel Conversion Enable: Remote 1
Public property | ChannelConversionEnableRemote2 | Channel Conversion Enable: Remote 2
Public property | ChannelConversionEnableRemote3 | Channel Conversion Enable: Remote 3
Public property | ChannelConversionEnableRemote4 | Channel Conversion Enable: Remote 4
Public property | CommonStatusBusy | Common Status: Busy
Public property | CommonStatusNR | Common Status: NR
Public property | CommonStatusStatusRegister1Flag | Common Status: Status Register 1 Flag
Public property | CommonStatusStatusRegister2Flag | Common Status: Status Register 2 Flag
Public property | CommonStatusStatusRegister3Flag | Common Status: Status Register 3 Flag
Public property | CommonStatusStatusRegister4Flag | Common Status: Status Register 4 Flag
Public property | CommonTCRITHysteresis | Common TCRIT Hysteresis (unit: °C)
Public property | ConfigurationFaultQueueRemote3 | Configuration: Fault Queue Remote 3
Public property | ConfigurationFaultQueueRemote4 | Configuration: Fault Queue Remote 4
Public property | ConfigurationStandby | Configuration: Standby
Public property | ConversionRate | Conversion Rate
Public property | DiodeModelSelectRemote1TruTherm | Diode Model Select: Remote 1 TruTherm
Public property | DiodeModelSelectRemote2TruTherm | Diode Model Select: Remote 2 TruTherm
Public property | DiodeModelSelectRemote3TruTherm | Diode Model Select: Remote 3 TruTherm
Public property | DiodeModelSelectRemote4TruTherm | Diode Model Select: Remote 4 TruTherm
Public property | DiodeModelStatusRemote1 | Diode Model Status: Remote 1
Public property | DiodeModelStatusRemote2 | Diode Model Status: Remote 2
Public property | DiodeModelStatusRemote3 | Diode Model Status: Remote 3
Public property | DiodeModelStatusRemote4 | Diode Model Status: Remote 4
Public property | FilterSettingRemote1 | Filter Setting: Remote 1
Public property | FilterSettingRemote2 | Filter Setting: Remote 2
Public property | LocalTCRITLimit | Local TCRIT Limit (unit: °C)
Public property | LocalTemp | Local Temp (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | Remote1Offset | Remote 1 Offset (unit: °C)
Public property | Remote1TCRIT1Limit | Remote 1 TCRIT-1 Limit (unit: °C)
Public property | Remote1TCRIT2AndTCRIT3Limit | Remote 1 TCRIT-2 and TCRIT-3 Limit (unit: °C)
Public property | Remote2Offset | Remote 2 Offset (unit: °C)
Public property | Remote2TCRIT1Limit | Remote 2 TCRIT-1 Limit (unit: °C)
Public property | Remote2TCRIT2AndTCRIT3Limit | Remote 2 TCRIT-2 and TCRIT-3 Limit (unit: °C)
Public property | Remote3Offset | Remote 3 Offset (unit: °C)
Public property | Remote3TCRITLimit | Remote 3 TCRIT Limit (unit: °C)
Public property | Remote4Offset | Remote 4 Offset (unit: °C)
Public property | Remote4TCRITLimit | Remote 4 TCRIT Limit (unit: °C)
Public property | RemoteTemp1Signed | Remote Temp 1 - Signed (unit: °C)
Public property | RemoteTemp1Unsigned | Remote Temp 1 - Unsigned (unit: °C)
Public property | RemoteTemp2Signed | Remote Temp 2 - Signed (unit: °C)
Public property | RemoteTemp2Unsigned | Remote Temp 2 - Unsigned (unit: °C)
Public property | RemoteTemp3Signed | Remote Temp 3 - Signed (unit: °C)
Public property | RemoteTemp3Unsigned | Remote Temp 3 - Unsigned (unit: °C)
Public property | RemoteTemp4Signed | Remote Temp 4 - Signed (unit: °C)
Public property | RemoteTemp4Unsigned | Remote Temp 4 - Unsigned (unit: °C)
Public property | RevisionID | Revision ID
Public property | StatusRemote1DiodeOpenFault | Status: Remote 1 Diode Open Fault
Public property | StatusRemote1DiodeShortFault | Status: Remote 1 Diode Short Fault
Public property | StatusRemote2DiodeOpenFault | Status: Remote 2 Diode Open Fault
Public property | StatusRemote2DiodeShortFault | Status: Remote 2 Diode Short Fault
Public property | StatusRemote3DiodeOpenFault | Status: Remote 3 Diode Open Fault
Public property | StatusRemote3DiodeShortFault | Status: Remote 3 Diode Short Fault
Public property | StatusRemote4DiodeOpenFault | Status: Remote 4 Diode Open Fault
Public property | StatusRemote4DiodeShortFault | Status: Remote 4 Diode Short Fault
Public property | StatusTCRIT1Local | Status TCRIT1: Local
Public property | StatusTCRIT1Remote1 | Status TCRIT1: Remote 1
Public property | StatusTCRIT1Remote2 | Status TCRIT1: Remote 2
Public property | StatusTCRIT1Remote3 | Status TCRIT1: Remote 3
Public property | StatusTCRIT1Remote4 | Status TCRIT1: Remote 4
Public property | StatusTCRIT2Local | Status TCRIT2: Local
Public property | StatusTCRIT2Remote1 | Status TCRIT2: Remote 1
Public property | StatusTCRIT2Remote2 | Status TCRIT2: Remote 2
Public property | StatusTCRIT2Remote3 | Status TCRIT2: Remote 3
Public property | StatusTCRIT2Remote4 | Status TCRIT2: Remote 4
Public property | StatusTCRIT3Local | Status TCRIT3: Local
Public property | StatusTCRIT3Remote1 | Status TCRIT3: Remote 1
Public property | StatusTCRIT3Remote2 | Status TCRIT3: Remote 2
Public property | StatusTCRIT3Remote3 | Status TCRIT3: Remote 3
Public property | StatusTCRIT3Remote4 | Status TCRIT3: Remote 4
Public property | TCRIT1MaskLocal | TCRIT1 Mask: Local
Public property | TCRIT1MaskRemote1 | TCRIT1 Mask: Remote 1
Public property | TCRIT1MaskRemote2 | TCRIT1 Mask: Remote 2
Public property | TCRIT1MaskRemote3 | TCRIT1 Mask: Remote 3
Public property | TCRIT1MaskRemote4 | TCRIT1 Mask: Remote 4
Public property | TCRIT2MaskLocal | TCRIT2 Mask: Local
Public property | TCRIT2MaskRemote1 | TCRIT2 Mask: Remote 1
Public property | TCRIT2MaskRemote2 | TCRIT2 Mask: Remote 2
Public property | TCRIT2MaskRemote3 | TCRIT2 Mask: Remote 3
Public property | TCRIT2MaskRemote4 | TCRIT2 Mask: Remote 4
Public property | TCRIT3MaskLocal | TCRIT3 Mask: Local
Public property | TCRIT3MaskRemote1 | TCRIT3 Mask: Remote 1
Public property | TCRIT3MaskRemote2 | TCRIT3 Mask: Remote 2
Public property | TCRIT3MaskRemote3 | TCRIT3 Mask: Remote 3
Public property | TCRIT3MaskRemote4 | TCRIT3 Mask: Remote 4
Top
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.AutoFlush Property

IRD

Lm95234AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.ChannelConversionEnableLocal Property

IRD

Lm95234ChannelConversionEnableLocal Property

Channel Conversion Enable: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeChannelConversionEnable ChannelConversionEnableLocal { get; set; }
Public Property ChannelConversionEnableLocal As Lm95234TypeChannelConversionEnable
    Get
    Set
public:
property Lm95234TypeChannelConversionEnable ChannelConversionEnableLocal {
    Lm95234TypeChannelConversionEnable get ();
    void set (Lm95234TypeChannelConversionEnable value);
}
member ChannelConversionEnableLocal : Lm95234TypeChannelConversionEnable with get, set

Property Value

Type: Lm95234TypeChannelConversionEnable
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.ChannelConversionEnableRemote1 Property

IRD

Lm95234ChannelConversionEnableRemote1 Property

Channel Conversion Enable: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeChannelConversionEnable ChannelConversionEnableRemote1 { get; set; }
Public Property ChannelConversionEnableRemote1 As Lm95234TypeChannelConversionEnable
    Get
    Set
public:
property Lm95234TypeChannelConversionEnable ChannelConversionEnableRemote1 {
    Lm95234TypeChannelConversionEnable get ();
    void set (Lm95234TypeChannelConversionEnable value);
}
member ChannelConversionEnableRemote1 : Lm95234TypeChannelConversionEnable with get, set

Property Value

Type: Lm95234TypeChannelConversionEnable
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.ChannelConversionEnableRemote2 Property

IRD

Lm95234ChannelConversionEnableRemote2 Property

Channel Conversion Enable: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeChannelConversionEnable ChannelConversionEnableRemote2 { get; set; }
Public Property ChannelConversionEnableRemote2 As Lm95234TypeChannelConversionEnable
    Get
    Set
public:
property Lm95234TypeChannelConversionEnable ChannelConversionEnableRemote2 {
    Lm95234TypeChannelConversionEnable get ();
    void set (Lm95234TypeChannelConversionEnable value);
}
member ChannelConversionEnableRemote2 : Lm95234TypeChannelConversionEnable with get, set

Property Value

Type: Lm95234TypeChannelConversionEnable
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.ChannelConversionEnableRemote3 Property

IRD

Lm95234ChannelConversionEnableRemote3 Property

Channel Conversion Enable: Remote 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeChannelConversionEnable ChannelConversionEnableRemote3 { get; set; }
Public Property ChannelConversionEnableRemote3 As Lm95234TypeChannelConversionEnable
    Get
    Set
public:
property Lm95234TypeChannelConversionEnable ChannelConversionEnableRemote3 {
    Lm95234TypeChannelConversionEnable get ();
    void set (Lm95234TypeChannelConversionEnable value);
}
member ChannelConversionEnableRemote3 : Lm95234TypeChannelConversionEnable with get, set

Property Value

Type: Lm95234TypeChannelConversionEnable
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.ChannelConversionEnableRemote4 Property

IRD

Lm95234ChannelConversionEnableRemote4 Property

Channel Conversion Enable: Remote 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeChannelConversionEnable ChannelConversionEnableRemote4 { get; set; }
Public Property ChannelConversionEnableRemote4 As Lm95234TypeChannelConversionEnable
    Get
    Set
public:
property Lm95234TypeChannelConversionEnable ChannelConversionEnableRemote4 {
    Lm95234TypeChannelConversionEnable get ();
    void set (Lm95234TypeChannelConversionEnable value);
}
member ChannelConversionEnableRemote4 : Lm95234TypeChannelConversionEnable with get, set

Property Value

Type: Lm95234TypeChannelConversionEnable
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.CommonStatusBusy Property

IRD

Lm95234CommonStatusBusy Property

Common Status: Busy

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeCommonStatusBusy CommonStatusBusy { get; }
Public ReadOnly Property CommonStatusBusy As Lm95234TypeCommonStatusBusy
    Get
public:
property Lm95234TypeCommonStatusBusy CommonStatusBusy {
    Lm95234TypeCommonStatusBusy get ();
}
member CommonStatusBusy : Lm95234TypeCommonStatusBusy with get

Property Value

Type: Lm95234TypeCommonStatusBusy
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.CommonStatusNR Property

IRD

Lm95234CommonStatusNR Property

Common Status: NR

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeCommonStatusNr CommonStatusNR { get; }
Public ReadOnly Property CommonStatusNR As Lm95234TypeCommonStatusNr
    Get
public:
property Lm95234TypeCommonStatusNr CommonStatusNR {
    Lm95234TypeCommonStatusNr get ();
}
member CommonStatusNR : Lm95234TypeCommonStatusNr with get

Property Value

Type: Lm95234TypeCommonStatusNr
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.CommonStatusStatusRegister1Flag Property

IRD

Lm95234CommonStatusStatusRegister1Flag Property

Common Status: Status Register 1 Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeCommonStatusSr CommonStatusStatusRegister1Flag { get; }
Public ReadOnly Property CommonStatusStatusRegister1Flag As Lm95234TypeCommonStatusSr
    Get
public:
property Lm95234TypeCommonStatusSr CommonStatusStatusRegister1Flag {
    Lm95234TypeCommonStatusSr get ();
}
member CommonStatusStatusRegister1Flag : Lm95234TypeCommonStatusSr with get

Property Value

Type: Lm95234TypeCommonStatusSr
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.CommonStatusStatusRegister2Flag Property

IRD

Lm95234CommonStatusStatusRegister2Flag Property

Common Status: Status Register 2 Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeCommonStatusSr CommonStatusStatusRegister2Flag { get; }
Public ReadOnly Property CommonStatusStatusRegister2Flag As Lm95234TypeCommonStatusSr
    Get
public:
property Lm95234TypeCommonStatusSr CommonStatusStatusRegister2Flag {
    Lm95234TypeCommonStatusSr get ();
}
member CommonStatusStatusRegister2Flag : Lm95234TypeCommonStatusSr with get

Property Value

Type: Lm95234TypeCommonStatusSr
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.CommonStatusStatusRegister3Flag Property

IRD

Lm95234CommonStatusStatusRegister3Flag Property

Common Status: Status Register 3 Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeCommonStatusSr CommonStatusStatusRegister3Flag { get; }
Public ReadOnly Property CommonStatusStatusRegister3Flag As Lm95234TypeCommonStatusSr
    Get
public:
property Lm95234TypeCommonStatusSr CommonStatusStatusRegister3Flag {
    Lm95234TypeCommonStatusSr get ();
}
member CommonStatusStatusRegister3Flag : Lm95234TypeCommonStatusSr with get

Property Value

Type: Lm95234TypeCommonStatusSr
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.CommonStatusStatusRegister4Flag Property

IRD

Lm95234CommonStatusStatusRegister4Flag Property

Common Status: Status Register 4 Flag

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeCommonStatusSr CommonStatusStatusRegister4Flag { get; }
Public ReadOnly Property CommonStatusStatusRegister4Flag As Lm95234TypeCommonStatusSr
    Get
public:
property Lm95234TypeCommonStatusSr CommonStatusStatusRegister4Flag {
    Lm95234TypeCommonStatusSr get ();
}
member CommonStatusStatusRegister4Flag : Lm95234TypeCommonStatusSr with get

Property Value

Type: Lm95234TypeCommonStatusSr
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.CommonTCRITHysteresis Property

IRD

Lm95234CommonTCRITHysteresis Property

Common TCRIT Hysteresis (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CommonTCRITHysteresis { get; set; }
Public Property CommonTCRITHysteresis As Byte
    Get
    Set
public:
property unsigned char CommonTCRITHysteresis {
    unsigned char get ();
    void set (unsigned char value);
}
member CommonTCRITHysteresis : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.ConfigurationFaultQueueRemote3 Property

IRD

Lm95234ConfigurationFaultQueueRemote3 Property

Configuration: Fault Queue Remote 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeConfigurationFaultQueue ConfigurationFaultQueueRemote3 { get; set; }
Public Property ConfigurationFaultQueueRemote3 As Lm95234TypeConfigurationFaultQueue
    Get
    Set
public:
property Lm95234TypeConfigurationFaultQueue ConfigurationFaultQueueRemote3 {
    Lm95234TypeConfigurationFaultQueue get ();
    void set (Lm95234TypeConfigurationFaultQueue value);
}
member ConfigurationFaultQueueRemote3 : Lm95234TypeConfigurationFaultQueue with get, set

Property Value

Type: Lm95234TypeConfigurationFaultQueue
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.ConfigurationFaultQueueRemote4 Property

IRD

Lm95234ConfigurationFaultQueueRemote4 Property

Configuration: Fault Queue Remote 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeConfigurationFaultQueue ConfigurationFaultQueueRemote4 { get; set; }
Public Property ConfigurationFaultQueueRemote4 As Lm95234TypeConfigurationFaultQueue
    Get
    Set
public:
property Lm95234TypeConfigurationFaultQueue ConfigurationFaultQueueRemote4 {
    Lm95234TypeConfigurationFaultQueue get ();
    void set (Lm95234TypeConfigurationFaultQueue value);
}
member ConfigurationFaultQueueRemote4 : Lm95234TypeConfigurationFaultQueue with get, set

Property Value

Type: Lm95234TypeConfigurationFaultQueue
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.ConfigurationStandby Property

IRD

Lm95234ConfigurationStandby Property

Configuration: Standby

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeConfigurationStby ConfigurationStandby { get; set; }
Public Property ConfigurationStandby As Lm95234TypeConfigurationStby
    Get
    Set
public:
property Lm95234TypeConfigurationStby ConfigurationStandby {
    Lm95234TypeConfigurationStby get ();
    void set (Lm95234TypeConfigurationStby value);
}
member ConfigurationStandby : Lm95234TypeConfigurationStby with get, set

Property Value

Type: Lm95234TypeConfigurationStby
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.ConversionRate Property

IRD

Lm95234ConversionRate Property

Conversion Rate

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeConversionRate ConversionRate { get; set; }
Public Property ConversionRate As Lm95234TypeConversionRate
    Get
    Set
public:
property Lm95234TypeConversionRate ConversionRate {
    Lm95234TypeConversionRate get ();
    void set (Lm95234TypeConversionRate value);
}
member ConversionRate : Lm95234TypeConversionRate with get, set

Property Value

Type: Lm95234TypeConversionRate
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.DiodeModelSelectRemote1TruTherm Property

IRD

Lm95234DiodeModelSelectRemote1TruTherm Property

Diode Model Select: Remote 1 TruTherm

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeDiodeModelSelect DiodeModelSelectRemote1TruTherm { get; set; }
Public Property DiodeModelSelectRemote1TruTherm As Lm95234TypeDiodeModelSelect
    Get
    Set
public:
property Lm95234TypeDiodeModelSelect DiodeModelSelectRemote1TruTherm {
    Lm95234TypeDiodeModelSelect get ();
    void set (Lm95234TypeDiodeModelSelect value);
}
member DiodeModelSelectRemote1TruTherm : Lm95234TypeDiodeModelSelect with get, set

Property Value

Type: Lm95234TypeDiodeModelSelect
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.DiodeModelSelectRemote2TruTherm Property

IRD

Lm95234DiodeModelSelectRemote2TruTherm Property

Diode Model Select: Remote 2 TruTherm

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeDiodeModelSelect DiodeModelSelectRemote2TruTherm { get; set; }
Public Property DiodeModelSelectRemote2TruTherm As Lm95234TypeDiodeModelSelect
    Get
    Set
public:
property Lm95234TypeDiodeModelSelect DiodeModelSelectRemote2TruTherm {
    Lm95234TypeDiodeModelSelect get ();
    void set (Lm95234TypeDiodeModelSelect value);
}
member DiodeModelSelectRemote2TruTherm : Lm95234TypeDiodeModelSelect with get, set

Property Value

Type: Lm95234TypeDiodeModelSelect
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.DiodeModelSelectRemote3TruTherm Property

IRD

Lm95234DiodeModelSelectRemote3TruTherm Property

Diode Model Select: Remote 3 TruTherm

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeDiodeModelSelect DiodeModelSelectRemote3TruTherm { get; set; }
Public Property DiodeModelSelectRemote3TruTherm As Lm95234TypeDiodeModelSelect
    Get
    Set
public:
property Lm95234TypeDiodeModelSelect DiodeModelSelectRemote3TruTherm {
    Lm95234TypeDiodeModelSelect get ();
    void set (Lm95234TypeDiodeModelSelect value);
}
member DiodeModelSelectRemote3TruTherm : Lm95234TypeDiodeModelSelect with get, set

Property Value

Type: Lm95234TypeDiodeModelSelect
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.DiodeModelSelectRemote4TruTherm Property

IRD

Lm95234DiodeModelSelectRemote4TruTherm Property

Diode Model Select: Remote 4 TruTherm

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeDiodeModelSelect DiodeModelSelectRemote4TruTherm { get; set; }
Public Property DiodeModelSelectRemote4TruTherm As Lm95234TypeDiodeModelSelect
    Get
    Set
public:
property Lm95234TypeDiodeModelSelect DiodeModelSelectRemote4TruTherm {
    Lm95234TypeDiodeModelSelect get ();
    void set (Lm95234TypeDiodeModelSelect value);
}
member DiodeModelSelectRemote4TruTherm : Lm95234TypeDiodeModelSelect with get, set

Property Value

Type: Lm95234TypeDiodeModelSelect
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.DiodeModelStatusRemote1 Property

IRD

Lm95234DiodeModelStatusRemote1 Property

Diode Model Status: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeDiodeModelStatus DiodeModelStatusRemote1 { get; }
Public ReadOnly Property DiodeModelStatusRemote1 As Lm95234TypeDiodeModelStatus
    Get
public:
property Lm95234TypeDiodeModelStatus DiodeModelStatusRemote1 {
    Lm95234TypeDiodeModelStatus get ();
}
member DiodeModelStatusRemote1 : Lm95234TypeDiodeModelStatus with get

Property Value

Type: Lm95234TypeDiodeModelStatus
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.DiodeModelStatusRemote2 Property

IRD

Lm95234DiodeModelStatusRemote2 Property

Diode Model Status: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeDiodeModelStatus DiodeModelStatusRemote2 { get; }
Public ReadOnly Property DiodeModelStatusRemote2 As Lm95234TypeDiodeModelStatus
    Get
public:
property Lm95234TypeDiodeModelStatus DiodeModelStatusRemote2 {
    Lm95234TypeDiodeModelStatus get ();
}
member DiodeModelStatusRemote2 : Lm95234TypeDiodeModelStatus with get

Property Value

Type: Lm95234TypeDiodeModelStatus
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.DiodeModelStatusRemote3 Property

IRD

Lm95234DiodeModelStatusRemote3 Property

Diode Model Status: Remote 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeDiodeModelStatus DiodeModelStatusRemote3 { get; }
Public ReadOnly Property DiodeModelStatusRemote3 As Lm95234TypeDiodeModelStatus
    Get
public:
property Lm95234TypeDiodeModelStatus DiodeModelStatusRemote3 {
    Lm95234TypeDiodeModelStatus get ();
}
member DiodeModelStatusRemote3 : Lm95234TypeDiodeModelStatus with get

Property Value

Type: Lm95234TypeDiodeModelStatus
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.DiodeModelStatusRemote4 Property

IRD

Lm95234DiodeModelStatusRemote4 Property

Diode Model Status: Remote 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeDiodeModelStatus DiodeModelStatusRemote4 { get; }
Public ReadOnly Property DiodeModelStatusRemote4 As Lm95234TypeDiodeModelStatus
    Get
public:
property Lm95234TypeDiodeModelStatus DiodeModelStatusRemote4 {
    Lm95234TypeDiodeModelStatus get ();
}
member DiodeModelStatusRemote4 : Lm95234TypeDiodeModelStatus with get

Property Value

Type: Lm95234TypeDiodeModelStatus
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.FilterSettingRemote1 Property

IRD

Lm95234FilterSettingRemote1 Property

Filter Setting: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeFilterSetting FilterSettingRemote1 { get; set; }
Public Property FilterSettingRemote1 As Lm95234TypeFilterSetting
    Get
    Set
public:
property Lm95234TypeFilterSetting FilterSettingRemote1 {
    Lm95234TypeFilterSetting get ();
    void set (Lm95234TypeFilterSetting value);
}
member FilterSettingRemote1 : Lm95234TypeFilterSetting with get, set

Property Value

Type: Lm95234TypeFilterSetting
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.FilterSettingRemote2 Property

IRD

Lm95234FilterSettingRemote2 Property

Filter Setting: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeFilterSetting FilterSettingRemote2 { get; set; }
Public Property FilterSettingRemote2 As Lm95234TypeFilterSetting
    Get
    Set
public:
property Lm95234TypeFilterSetting FilterSettingRemote2 {
    Lm95234TypeFilterSetting get ();
    void set (Lm95234TypeFilterSetting value);
}
member FilterSettingRemote2 : Lm95234TypeFilterSetting with get, set

Property Value

Type: Lm95234TypeFilterSetting
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.LocalTCRITLimit Property

IRD

Lm95234LocalTCRITLimit Property

Local TCRIT Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalTCRITLimit { get; set; }
Public Property LocalTCRITLimit As Byte
    Get
    Set
public:
property unsigned char LocalTCRITLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member LocalTCRITLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.LocalTemp Property

IRD

Lm95234LocalTemp Property

Local Temp (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LocalTemp { get; }
Public ReadOnly Property LocalTemp As Double
    Get
public:
property double LocalTemp {
    double get ();
}
member LocalTemp : float with get

Property Value

Type: Double
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.ManufacturerID Property

IRD

Lm95234ManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As Byte
    Get
public:
property unsigned char ManufacturerID {
    unsigned char get ();
}
member ManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.Remote1Offset Property

IRD

Lm95234Remote1Offset Property

Remote 1 Offset (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote1Offset { get; set; }
Public Property Remote1Offset As Double
    Get
    Set
public:
property double Remote1Offset {
    double get ();
    void set (double value);
}
member Remote1Offset : float with get, set

Property Value

Type: Double
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.Remote1TCRIT1Limit Property

IRD

Lm95234Remote1TCRIT1Limit Property

Remote 1 TCRIT-1 Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote1TCRIT1Limit { get; set; }
Public Property Remote1TCRIT1Limit As Byte
    Get
    Set
public:
property unsigned char Remote1TCRIT1Limit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote1TCRIT1Limit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.Remote1TCRIT2AndTCRIT3Limit Property

IRD

Lm95234Remote1TCRIT2AndTCRIT3Limit Property

Remote 1 TCRIT-2 and TCRIT-3 Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote1TCRIT2AndTCRIT3Limit { get; set; }
Public Property Remote1TCRIT2AndTCRIT3Limit As Byte
    Get
    Set
public:
property unsigned char Remote1TCRIT2AndTCRIT3Limit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote1TCRIT2AndTCRIT3Limit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.Remote2Offset Property

IRD

Lm95234Remote2Offset Property

Remote 2 Offset (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote2Offset { get; set; }
Public Property Remote2Offset As Double
    Get
    Set
public:
property double Remote2Offset {
    double get ();
    void set (double value);
}
member Remote2Offset : float with get, set

Property Value

Type: Double
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.Remote2TCRIT1Limit Property

IRD

Lm95234Remote2TCRIT1Limit Property

Remote 2 TCRIT-1 Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote2TCRIT1Limit { get; set; }
Public Property Remote2TCRIT1Limit As Byte
    Get
    Set
public:
property unsigned char Remote2TCRIT1Limit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote2TCRIT1Limit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.Remote2TCRIT2AndTCRIT3Limit Property

IRD

Lm95234Remote2TCRIT2AndTCRIT3Limit Property

Remote 2 TCRIT-2 and TCRIT-3 Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote2TCRIT2AndTCRIT3Limit { get; set; }
Public Property Remote2TCRIT2AndTCRIT3Limit As Byte
    Get
    Set
public:
property unsigned char Remote2TCRIT2AndTCRIT3Limit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote2TCRIT2AndTCRIT3Limit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.Remote3Offset Property

IRD

Lm95234Remote3Offset Property

Remote 3 Offset (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote3Offset { get; set; }
Public Property Remote3Offset As Double
    Get
    Set
public:
property double Remote3Offset {
    double get ();
    void set (double value);
}
member Remote3Offset : float with get, set

Property Value

Type: Double
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.Remote3TCRITLimit Property

IRD

Lm95234Remote3TCRITLimit Property

Remote 3 TCRIT Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote3TCRITLimit { get; set; }
Public Property Remote3TCRITLimit As Byte
    Get
    Set
public:
property unsigned char Remote3TCRITLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote3TCRITLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.Remote4Offset Property

IRD

Lm95234Remote4Offset Property

Remote 4 Offset (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote4Offset { get; set; }
Public Property Remote4Offset As Double
    Get
    Set
public:
property double Remote4Offset {
    double get ();
    void set (double value);
}
member Remote4Offset : float with get, set

Property Value

Type: Double
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.Remote4TCRITLimit Property

IRD

Lm95234Remote4TCRITLimit Property

Remote 4 TCRIT Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Remote4TCRITLimit { get; set; }
Public Property Remote4TCRITLimit As Byte
    Get
    Set
public:
property unsigned char Remote4TCRITLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member Remote4TCRITLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.RemoteTemp1Signed Property

IRD

Lm95234RemoteTemp1Signed Property

Remote Temp 1 - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp1Signed { get; }
Public ReadOnly Property RemoteTemp1Signed As Double
    Get
public:
property double RemoteTemp1Signed {
    double get ();
}
member RemoteTemp1Signed : float with get

Property Value

Type: Double
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.RemoteTemp1Unsigned Property

IRD

Lm95234RemoteTemp1Unsigned Property

Remote Temp 1 - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp1Unsigned { get; }
Public ReadOnly Property RemoteTemp1Unsigned As Double
    Get
public:
property double RemoteTemp1Unsigned {
    double get ();
}
member RemoteTemp1Unsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.RemoteTemp2Signed Property

IRD

Lm95234RemoteTemp2Signed Property

Remote Temp 2 - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp2Signed { get; }
Public ReadOnly Property RemoteTemp2Signed As Double
    Get
public:
property double RemoteTemp2Signed {
    double get ();
}
member RemoteTemp2Signed : float with get

Property Value

Type: Double
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.RemoteTemp2Unsigned Property

IRD

Lm95234RemoteTemp2Unsigned Property

Remote Temp 2 - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp2Unsigned { get; }
Public ReadOnly Property RemoteTemp2Unsigned As Double
    Get
public:
property double RemoteTemp2Unsigned {
    double get ();
}
member RemoteTemp2Unsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.RemoteTemp3Signed Property

IRD

Lm95234RemoteTemp3Signed Property

Remote Temp 3 - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp3Signed { get; }
Public ReadOnly Property RemoteTemp3Signed As Double
    Get
public:
property double RemoteTemp3Signed {
    double get ();
}
member RemoteTemp3Signed : float with get

Property Value

Type: Double
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.RemoteTemp3Unsigned Property

IRD

Lm95234RemoteTemp3Unsigned Property

Remote Temp 3 - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp3Unsigned { get; }
Public ReadOnly Property RemoteTemp3Unsigned As Double
    Get
public:
property double RemoteTemp3Unsigned {
    double get ();
}
member RemoteTemp3Unsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.RemoteTemp4Signed Property

IRD

Lm95234RemoteTemp4Signed Property

Remote Temp 4 - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp4Signed { get; }
Public ReadOnly Property RemoteTemp4Signed As Double
    Get
public:
property double RemoteTemp4Signed {
    double get ();
}
member RemoteTemp4Signed : float with get

Property Value

Type: Double
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.RemoteTemp4Unsigned Property

IRD

Lm95234RemoteTemp4Unsigned Property

Remote Temp 4 - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemp4Unsigned { get; }
Public ReadOnly Property RemoteTemp4Unsigned As Double
    Get
public:
property double RemoteTemp4Unsigned {
    double get ();
}
member RemoteTemp4Unsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.RevisionID Property

IRD

Lm95234RevisionID Property

Revision ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionID { get; }
Public ReadOnly Property RevisionID As Byte
    Get
public:
property unsigned char RevisionID {
    unsigned char get ();
}
member RevisionID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusRemote1DiodeOpenFault Property

IRD

Lm95234StatusRemote1DiodeOpenFault Property

Status: Remote 1 Diode Open Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusFault StatusRemote1DiodeOpenFault { get; }
Public ReadOnly Property StatusRemote1DiodeOpenFault As Lm95234TypeStatusFault
    Get
public:
property Lm95234TypeStatusFault StatusRemote1DiodeOpenFault {
    Lm95234TypeStatusFault get ();
}
member StatusRemote1DiodeOpenFault : Lm95234TypeStatusFault with get

Property Value

Type: Lm95234TypeStatusFault
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusRemote1DiodeShortFault Property

IRD

Lm95234StatusRemote1DiodeShortFault Property

Status: Remote 1 Diode Short Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusFault StatusRemote1DiodeShortFault { get; }
Public ReadOnly Property StatusRemote1DiodeShortFault As Lm95234TypeStatusFault
    Get
public:
property Lm95234TypeStatusFault StatusRemote1DiodeShortFault {
    Lm95234TypeStatusFault get ();
}
member StatusRemote1DiodeShortFault : Lm95234TypeStatusFault with get

Property Value

Type: Lm95234TypeStatusFault
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusRemote2DiodeOpenFault Property

IRD

Lm95234StatusRemote2DiodeOpenFault Property

Status: Remote 2 Diode Open Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusFault StatusRemote2DiodeOpenFault { get; }
Public ReadOnly Property StatusRemote2DiodeOpenFault As Lm95234TypeStatusFault
    Get
public:
property Lm95234TypeStatusFault StatusRemote2DiodeOpenFault {
    Lm95234TypeStatusFault get ();
}
member StatusRemote2DiodeOpenFault : Lm95234TypeStatusFault with get

Property Value

Type: Lm95234TypeStatusFault
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusRemote2DiodeShortFault Property

IRD

Lm95234StatusRemote2DiodeShortFault Property

Status: Remote 2 Diode Short Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusFault StatusRemote2DiodeShortFault { get; }
Public ReadOnly Property StatusRemote2DiodeShortFault As Lm95234TypeStatusFault
    Get
public:
property Lm95234TypeStatusFault StatusRemote2DiodeShortFault {
    Lm95234TypeStatusFault get ();
}
member StatusRemote2DiodeShortFault : Lm95234TypeStatusFault with get

Property Value

Type: Lm95234TypeStatusFault
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusRemote3DiodeOpenFault Property

IRD

Lm95234StatusRemote3DiodeOpenFault Property

Status: Remote 3 Diode Open Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusFault StatusRemote3DiodeOpenFault { get; }
Public ReadOnly Property StatusRemote3DiodeOpenFault As Lm95234TypeStatusFault
    Get
public:
property Lm95234TypeStatusFault StatusRemote3DiodeOpenFault {
    Lm95234TypeStatusFault get ();
}
member StatusRemote3DiodeOpenFault : Lm95234TypeStatusFault with get

Property Value

Type: Lm95234TypeStatusFault
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusRemote3DiodeShortFault Property

IRD

Lm95234StatusRemote3DiodeShortFault Property

Status: Remote 3 Diode Short Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusFault StatusRemote3DiodeShortFault { get; }
Public ReadOnly Property StatusRemote3DiodeShortFault As Lm95234TypeStatusFault
    Get
public:
property Lm95234TypeStatusFault StatusRemote3DiodeShortFault {
    Lm95234TypeStatusFault get ();
}
member StatusRemote3DiodeShortFault : Lm95234TypeStatusFault with get

Property Value

Type: Lm95234TypeStatusFault
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusRemote4DiodeOpenFault Property

IRD

Lm95234StatusRemote4DiodeOpenFault Property

Status: Remote 4 Diode Open Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusFault StatusRemote4DiodeOpenFault { get; }
Public ReadOnly Property StatusRemote4DiodeOpenFault As Lm95234TypeStatusFault
    Get
public:
property Lm95234TypeStatusFault StatusRemote4DiodeOpenFault {
    Lm95234TypeStatusFault get ();
}
member StatusRemote4DiodeOpenFault : Lm95234TypeStatusFault with get

Property Value

Type: Lm95234TypeStatusFault
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusRemote4DiodeShortFault Property

IRD

Lm95234StatusRemote4DiodeShortFault Property

Status: Remote 4 Diode Short Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusFault StatusRemote4DiodeShortFault { get; }
Public ReadOnly Property StatusRemote4DiodeShortFault As Lm95234TypeStatusFault
    Get
public:
property Lm95234TypeStatusFault StatusRemote4DiodeShortFault {
    Lm95234TypeStatusFault get ();
}
member StatusRemote4DiodeShortFault : Lm95234TypeStatusFault with get

Property Value

Type: Lm95234TypeStatusFault
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusTCRIT1Local Property

IRD

Lm95234StatusTCRIT1Local Property

Status TCRIT1: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusTcrit StatusTCRIT1Local { get; }
Public ReadOnly Property StatusTCRIT1Local As Lm95234TypeStatusTcrit
    Get
public:
property Lm95234TypeStatusTcrit StatusTCRIT1Local {
    Lm95234TypeStatusTcrit get ();
}
member StatusTCRIT1Local : Lm95234TypeStatusTcrit with get

Property Value

Type: Lm95234TypeStatusTcrit
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusTCRIT1Remote1 Property

IRD

Lm95234StatusTCRIT1Remote1 Property

Status TCRIT1: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusTcrit StatusTCRIT1Remote1 { get; }
Public ReadOnly Property StatusTCRIT1Remote1 As Lm95234TypeStatusTcrit
    Get
public:
property Lm95234TypeStatusTcrit StatusTCRIT1Remote1 {
    Lm95234TypeStatusTcrit get ();
}
member StatusTCRIT1Remote1 : Lm95234TypeStatusTcrit with get

Property Value

Type: Lm95234TypeStatusTcrit
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusTCRIT1Remote2 Property

IRD

Lm95234StatusTCRIT1Remote2 Property

Status TCRIT1: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusTcrit StatusTCRIT1Remote2 { get; }
Public ReadOnly Property StatusTCRIT1Remote2 As Lm95234TypeStatusTcrit
    Get
public:
property Lm95234TypeStatusTcrit StatusTCRIT1Remote2 {
    Lm95234TypeStatusTcrit get ();
}
member StatusTCRIT1Remote2 : Lm95234TypeStatusTcrit with get

Property Value

Type: Lm95234TypeStatusTcrit
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusTCRIT1Remote3 Property

IRD

Lm95234StatusTCRIT1Remote3 Property

Status TCRIT1: Remote 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusTcrit StatusTCRIT1Remote3 { get; }
Public ReadOnly Property StatusTCRIT1Remote3 As Lm95234TypeStatusTcrit
    Get
public:
property Lm95234TypeStatusTcrit StatusTCRIT1Remote3 {
    Lm95234TypeStatusTcrit get ();
}
member StatusTCRIT1Remote3 : Lm95234TypeStatusTcrit with get

Property Value

Type: Lm95234TypeStatusTcrit
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusTCRIT1Remote4 Property

IRD

Lm95234StatusTCRIT1Remote4 Property

Status TCRIT1: Remote 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusTcrit StatusTCRIT1Remote4 { get; }
Public ReadOnly Property StatusTCRIT1Remote4 As Lm95234TypeStatusTcrit
    Get
public:
property Lm95234TypeStatusTcrit StatusTCRIT1Remote4 {
    Lm95234TypeStatusTcrit get ();
}
member StatusTCRIT1Remote4 : Lm95234TypeStatusTcrit with get

Property Value

Type: Lm95234TypeStatusTcrit
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusTCRIT2Local Property

IRD

Lm95234StatusTCRIT2Local Property

Status TCRIT2: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusTcrit StatusTCRIT2Local { get; }
Public ReadOnly Property StatusTCRIT2Local As Lm95234TypeStatusTcrit
    Get
public:
property Lm95234TypeStatusTcrit StatusTCRIT2Local {
    Lm95234TypeStatusTcrit get ();
}
member StatusTCRIT2Local : Lm95234TypeStatusTcrit with get

Property Value

Type: Lm95234TypeStatusTcrit
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusTCRIT2Remote1 Property

IRD

Lm95234StatusTCRIT2Remote1 Property

Status TCRIT2: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusTcrit StatusTCRIT2Remote1 { get; }
Public ReadOnly Property StatusTCRIT2Remote1 As Lm95234TypeStatusTcrit
    Get
public:
property Lm95234TypeStatusTcrit StatusTCRIT2Remote1 {
    Lm95234TypeStatusTcrit get ();
}
member StatusTCRIT2Remote1 : Lm95234TypeStatusTcrit with get

Property Value

Type: Lm95234TypeStatusTcrit
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusTCRIT2Remote2 Property

IRD

Lm95234StatusTCRIT2Remote2 Property

Status TCRIT2: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusTcrit StatusTCRIT2Remote2 { get; }
Public ReadOnly Property StatusTCRIT2Remote2 As Lm95234TypeStatusTcrit
    Get
public:
property Lm95234TypeStatusTcrit StatusTCRIT2Remote2 {
    Lm95234TypeStatusTcrit get ();
}
member StatusTCRIT2Remote2 : Lm95234TypeStatusTcrit with get

Property Value

Type: Lm95234TypeStatusTcrit
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusTCRIT2Remote3 Property

IRD

Lm95234StatusTCRIT2Remote3 Property

Status TCRIT2: Remote 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusTcrit StatusTCRIT2Remote3 { get; }
Public ReadOnly Property StatusTCRIT2Remote3 As Lm95234TypeStatusTcrit
    Get
public:
property Lm95234TypeStatusTcrit StatusTCRIT2Remote3 {
    Lm95234TypeStatusTcrit get ();
}
member StatusTCRIT2Remote3 : Lm95234TypeStatusTcrit with get

Property Value

Type: Lm95234TypeStatusTcrit
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusTCRIT2Remote4 Property

IRD

Lm95234StatusTCRIT2Remote4 Property

Status TCRIT2: Remote 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusTcrit StatusTCRIT2Remote4 { get; }
Public ReadOnly Property StatusTCRIT2Remote4 As Lm95234TypeStatusTcrit
    Get
public:
property Lm95234TypeStatusTcrit StatusTCRIT2Remote4 {
    Lm95234TypeStatusTcrit get ();
}
member StatusTCRIT2Remote4 : Lm95234TypeStatusTcrit with get

Property Value

Type: Lm95234TypeStatusTcrit
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusTCRIT3Local Property

IRD

Lm95234StatusTCRIT3Local Property

Status TCRIT3: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusTcrit StatusTCRIT3Local { get; }
Public ReadOnly Property StatusTCRIT3Local As Lm95234TypeStatusTcrit
    Get
public:
property Lm95234TypeStatusTcrit StatusTCRIT3Local {
    Lm95234TypeStatusTcrit get ();
}
member StatusTCRIT3Local : Lm95234TypeStatusTcrit with get

Property Value

Type: Lm95234TypeStatusTcrit
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusTCRIT3Remote1 Property

IRD

Lm95234StatusTCRIT3Remote1 Property

Status TCRIT3: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusTcrit StatusTCRIT3Remote1 { get; }
Public ReadOnly Property StatusTCRIT3Remote1 As Lm95234TypeStatusTcrit
    Get
public:
property Lm95234TypeStatusTcrit StatusTCRIT3Remote1 {
    Lm95234TypeStatusTcrit get ();
}
member StatusTCRIT3Remote1 : Lm95234TypeStatusTcrit with get

Property Value

Type: Lm95234TypeStatusTcrit
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusTCRIT3Remote2 Property

IRD

Lm95234StatusTCRIT3Remote2 Property

Status TCRIT3: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusTcrit StatusTCRIT3Remote2 { get; }
Public ReadOnly Property StatusTCRIT3Remote2 As Lm95234TypeStatusTcrit
    Get
public:
property Lm95234TypeStatusTcrit StatusTCRIT3Remote2 {
    Lm95234TypeStatusTcrit get ();
}
member StatusTCRIT3Remote2 : Lm95234TypeStatusTcrit with get

Property Value

Type: Lm95234TypeStatusTcrit
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusTCRIT3Remote3 Property

IRD

Lm95234StatusTCRIT3Remote3 Property

Status TCRIT3: Remote 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusTcrit StatusTCRIT3Remote3 { get; }
Public ReadOnly Property StatusTCRIT3Remote3 As Lm95234TypeStatusTcrit
    Get
public:
property Lm95234TypeStatusTcrit StatusTCRIT3Remote3 {
    Lm95234TypeStatusTcrit get ();
}
member StatusTCRIT3Remote3 : Lm95234TypeStatusTcrit with get

Property Value

Type: Lm95234TypeStatusTcrit
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.StatusTCRIT3Remote4 Property

IRD

Lm95234StatusTCRIT3Remote4 Property

Status TCRIT3: Remote 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeStatusTcrit StatusTCRIT3Remote4 { get; }
Public ReadOnly Property StatusTCRIT3Remote4 As Lm95234TypeStatusTcrit
    Get
public:
property Lm95234TypeStatusTcrit StatusTCRIT3Remote4 {
    Lm95234TypeStatusTcrit get ();
}
member StatusTCRIT3Remote4 : Lm95234TypeStatusTcrit with get

Property Value

Type: Lm95234TypeStatusTcrit
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.TCRIT1MaskLocal Property

IRD

Lm95234TCRIT1MaskLocal Property

TCRIT1 Mask: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeMask TCRIT1MaskLocal { get; set; }
Public Property TCRIT1MaskLocal As Lm95234TypeMask
    Get
    Set
public:
property Lm95234TypeMask TCRIT1MaskLocal {
    Lm95234TypeMask get ();
    void set (Lm95234TypeMask value);
}
member TCRIT1MaskLocal : Lm95234TypeMask with get, set

Property Value

Type: Lm95234TypeMask
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.TCRIT1MaskRemote1 Property

IRD

Lm95234TCRIT1MaskRemote1 Property

TCRIT1 Mask: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeMask TCRIT1MaskRemote1 { get; set; }
Public Property TCRIT1MaskRemote1 As Lm95234TypeMask
    Get
    Set
public:
property Lm95234TypeMask TCRIT1MaskRemote1 {
    Lm95234TypeMask get ();
    void set (Lm95234TypeMask value);
}
member TCRIT1MaskRemote1 : Lm95234TypeMask with get, set

Property Value

Type: Lm95234TypeMask
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.TCRIT1MaskRemote2 Property

IRD

Lm95234TCRIT1MaskRemote2 Property

TCRIT1 Mask: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeMask TCRIT1MaskRemote2 { get; set; }
Public Property TCRIT1MaskRemote2 As Lm95234TypeMask
    Get
    Set
public:
property Lm95234TypeMask TCRIT1MaskRemote2 {
    Lm95234TypeMask get ();
    void set (Lm95234TypeMask value);
}
member TCRIT1MaskRemote2 : Lm95234TypeMask with get, set

Property Value

Type: Lm95234TypeMask
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.TCRIT1MaskRemote3 Property

IRD

Lm95234TCRIT1MaskRemote3 Property

TCRIT1 Mask: Remote 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeMask TCRIT1MaskRemote3 { get; set; }
Public Property TCRIT1MaskRemote3 As Lm95234TypeMask
    Get
    Set
public:
property Lm95234TypeMask TCRIT1MaskRemote3 {
    Lm95234TypeMask get ();
    void set (Lm95234TypeMask value);
}
member TCRIT1MaskRemote3 : Lm95234TypeMask with get, set

Property Value

Type: Lm95234TypeMask
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.TCRIT1MaskRemote4 Property

IRD

Lm95234TCRIT1MaskRemote4 Property

TCRIT1 Mask: Remote 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeMask TCRIT1MaskRemote4 { get; set; }
Public Property TCRIT1MaskRemote4 As Lm95234TypeMask
    Get
    Set
public:
property Lm95234TypeMask TCRIT1MaskRemote4 {
    Lm95234TypeMask get ();
    void set (Lm95234TypeMask value);
}
member TCRIT1MaskRemote4 : Lm95234TypeMask with get, set

Property Value

Type: Lm95234TypeMask
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.TCRIT2MaskLocal Property

IRD

Lm95234TCRIT2MaskLocal Property

TCRIT2 Mask: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeMask TCRIT2MaskLocal { get; set; }
Public Property TCRIT2MaskLocal As Lm95234TypeMask
    Get
    Set
public:
property Lm95234TypeMask TCRIT2MaskLocal {
    Lm95234TypeMask get ();
    void set (Lm95234TypeMask value);
}
member TCRIT2MaskLocal : Lm95234TypeMask with get, set

Property Value

Type: Lm95234TypeMask
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.TCRIT2MaskRemote1 Property

IRD

Lm95234TCRIT2MaskRemote1 Property

TCRIT2 Mask: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeMask TCRIT2MaskRemote1 { get; set; }
Public Property TCRIT2MaskRemote1 As Lm95234TypeMask
    Get
    Set
public:
property Lm95234TypeMask TCRIT2MaskRemote1 {
    Lm95234TypeMask get ();
    void set (Lm95234TypeMask value);
}
member TCRIT2MaskRemote1 : Lm95234TypeMask with get, set

Property Value

Type: Lm95234TypeMask
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.TCRIT2MaskRemote2 Property

IRD

Lm95234TCRIT2MaskRemote2 Property

TCRIT2 Mask: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeMask TCRIT2MaskRemote2 { get; set; }
Public Property TCRIT2MaskRemote2 As Lm95234TypeMask
    Get
    Set
public:
property Lm95234TypeMask TCRIT2MaskRemote2 {
    Lm95234TypeMask get ();
    void set (Lm95234TypeMask value);
}
member TCRIT2MaskRemote2 : Lm95234TypeMask with get, set

Property Value

Type: Lm95234TypeMask
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.TCRIT2MaskRemote3 Property

IRD

Lm95234TCRIT2MaskRemote3 Property

TCRIT2 Mask: Remote 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeMask TCRIT2MaskRemote3 { get; set; }
Public Property TCRIT2MaskRemote3 As Lm95234TypeMask
    Get
    Set
public:
property Lm95234TypeMask TCRIT2MaskRemote3 {
    Lm95234TypeMask get ();
    void set (Lm95234TypeMask value);
}
member TCRIT2MaskRemote3 : Lm95234TypeMask with get, set

Property Value

Type: Lm95234TypeMask
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.TCRIT2MaskRemote4 Property

IRD

Lm95234TCRIT2MaskRemote4 Property

TCRIT2 Mask: Remote 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeMask TCRIT2MaskRemote4 { get; set; }
Public Property TCRIT2MaskRemote4 As Lm95234TypeMask
    Get
    Set
public:
property Lm95234TypeMask TCRIT2MaskRemote4 {
    Lm95234TypeMask get ();
    void set (Lm95234TypeMask value);
}
member TCRIT2MaskRemote4 : Lm95234TypeMask with get, set

Property Value

Type: Lm95234TypeMask
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.TCRIT3MaskLocal Property

IRD

Lm95234TCRIT3MaskLocal Property

TCRIT3 Mask: Local

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeMask TCRIT3MaskLocal { get; set; }
Public Property TCRIT3MaskLocal As Lm95234TypeMask
    Get
    Set
public:
property Lm95234TypeMask TCRIT3MaskLocal {
    Lm95234TypeMask get ();
    void set (Lm95234TypeMask value);
}
member TCRIT3MaskLocal : Lm95234TypeMask with get, set

Property Value

Type: Lm95234TypeMask
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.TCRIT3MaskRemote1 Property

IRD

Lm95234TCRIT3MaskRemote1 Property

TCRIT3 Mask: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeMask TCRIT3MaskRemote1 { get; set; }
Public Property TCRIT3MaskRemote1 As Lm95234TypeMask
    Get
    Set
public:
property Lm95234TypeMask TCRIT3MaskRemote1 {
    Lm95234TypeMask get ();
    void set (Lm95234TypeMask value);
}
member TCRIT3MaskRemote1 : Lm95234TypeMask with get, set

Property Value

Type: Lm95234TypeMask
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.TCRIT3MaskRemote2 Property

IRD

Lm95234TCRIT3MaskRemote2 Property

TCRIT3 Mask: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeMask TCRIT3MaskRemote2 { get; set; }
Public Property TCRIT3MaskRemote2 As Lm95234TypeMask
    Get
    Set
public:
property Lm95234TypeMask TCRIT3MaskRemote2 {
    Lm95234TypeMask get ();
    void set (Lm95234TypeMask value);
}
member TCRIT3MaskRemote2 : Lm95234TypeMask with get, set

Property Value

Type: Lm95234TypeMask
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.TCRIT3MaskRemote3 Property

IRD

Lm95234TCRIT3MaskRemote3 Property

TCRIT3 Mask: Remote 3

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeMask TCRIT3MaskRemote3 { get; set; }
Public Property TCRIT3MaskRemote3 As Lm95234TypeMask
    Get
    Set
public:
property Lm95234TypeMask TCRIT3MaskRemote3 {
    Lm95234TypeMask get ();
    void set (Lm95234TypeMask value);
}
member TCRIT3MaskRemote3 : Lm95234TypeMask with get, set

Property Value

Type: Lm95234TypeMask
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.TCRIT3MaskRemote4 Property

IRD

Lm95234TCRIT3MaskRemote4 Property

TCRIT3 Mask: Remote 4

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95234TypeMask TCRIT3MaskRemote4 { get; set; }
Public Property TCRIT3MaskRemote4 As Lm95234TypeMask
    Get
    Set
public:
property Lm95234TypeMask TCRIT3MaskRemote4 {
    Lm95234TypeMask get ();
    void set (Lm95234TypeMask value);
}
member TCRIT3MaskRemote4 : Lm95234TypeMask with get, set

Property Value

Type: Lm95234TypeMask
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234 Methods

The Lm95234 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Method_1Shot | 1-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.Flush Method

IRD

Lm95234Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.Method_1Shot Method

IRD

Lm95234Method_1Shot Method

1-Shot

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Method_1Shot()
Public Sub Method_1Shot
public:
void Method_1Shot()
member Method_1Shot : unit -> unit
See Also

Reference

Lm95234 Class
telos.Ird.NationalSemiconductor Namespace


Lm95234.TypeChannelConversionEnable Enumeration

IRD

Lm95234TypeChannelConversionEnable Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelConversionEnable
Public Enumeration TypeChannelConversionEnable
public enum class TypeChannelConversionEnable
type TypeChannelConversionEnable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95234.TypeCommonStatusBusy Enumeration

IRD

Lm95234TypeCommonStatusBusy Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommonStatusBusy
Public Enumeration TypeCommonStatusBusy
public enum class TypeCommonStatusBusy
type TypeCommonStatusBusy
Members
Member name | Value | Description
NotBusy | 0 | Not Busy
Busy | 1 | Busy
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95234.TypeCommonStatusNr Enumeration

IRD

Lm95234TypeCommonStatusNr Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommonStatusNr
Public Enumeration TypeCommonStatusNr
public enum class TypeCommonStatusNr
type TypeCommonStatusNr
Members
Member name | Value | Description
Ready | 0 | Ready
NotReady | 1 | Not Ready
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95234.TypeCommonStatusSr Enumeration

IRD

Lm95234TypeCommonStatusSr Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCommonStatusSr
Public Enumeration TypeCommonStatusSr
public enum class TypeCommonStatusSr
type TypeCommonStatusSr
Members
Member name | Value | Description
AllBitsAreCleared | 0 | All Bits Are Cleared
AtLeastOneBitSet | 1 | At Least One Bit Set
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95234.TypeConfigurationFaultQueue Enumeration

IRD

Lm95234TypeConfigurationFaultQueue Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationFaultQueue
Public Enumeration TypeConfigurationFaultQueue
public enum class TypeConfigurationFaultQueue
type TypeConfigurationFaultQueue
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95234.TypeConfigurationStby Enumeration

IRD

Lm95234TypeConfigurationStby Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationStby
Public Enumeration TypeConfigurationStby
public enum class TypeConfigurationStby
type TypeConfigurationStby
Members
Member name | Value | Description
ActiveConverting | 0 | Active/Converting
Standby | 1 | Standby
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95234.TypeConversionRate Enumeration

IRD

Lm95234TypeConversionRate Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConversionRate
Public Enumeration TypeConversionRate
public enum class TypeConversionRate
type TypeConversionRate
Members
Member name | Value | Description
Continuous30MsTo143Ms | 0 | Continuous (30 ms to 143 ms)
Value_0364S | 1 | 0.364 s
Value_1S | 2 | 1 s
Value_25S | 3 | 2.5 s
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95234.TypeDiodeModelSelect Enumeration

IRD

Lm95234TypeDiodeModelSelect Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDiodeModelSelect
Public Enumeration TypeDiodeModelSelect
public enum class TypeDiodeModelSelect
type TypeDiodeModelSelect
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95234.TypeDiodeModelStatus Enumeration

IRD

Lm95234TypeDiodeModelStatus Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDiodeModelStatus
Public Enumeration TypeDiodeModelStatus
public enum class TypeDiodeModelStatus
type TypeDiodeModelStatus
Members
Member name | Value | Description
ProperOperation | 0 | Proper Operation
TruThermOnAnd3904Connected | 1 | TruTherm On and 3904 Connected
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95234.TypeFilterSetting Enumeration

IRD

Lm95234TypeFilterSetting Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFilterSetting
Public Enumeration TypeFilterSetting
public enum class TypeFilterSetting
type TypeFilterSetting
Members
Member name | Value | Description
DisableAllDigitalFiltering | 0 | Disable all digital filtering
EnableBasicFilter | 1 | Enable basic filter
Reserved | 2 | Reserved
EnableEnhancedFilter | 3 | Enable enhanced filter
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95234.TypeMask Enumeration

IRD

Lm95234TypeMask Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMask
Public Enumeration TypeMask
public enum class TypeMask
type TypeMask
Members
Member name | Value | Description
PinTriggered | 0 | Pin: Triggered
PinNotTriggered | 1 | Pin: Not Triggered
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95234.TypeStatusFault Enumeration

IRD

Lm95234TypeStatusFault Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusFault
Public Enumeration TypeStatusFault
public enum class TypeStatusFault
type TypeStatusFault
Members
Member name | Value | Description
NoFault | 0 | No Fault
Fault | 1 | Fault
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95234.TypeStatusTcrit Enumeration

IRD

Lm95234TypeStatusTcrit Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusTcrit
Public Enumeration TypeStatusTcrit
public enum class TypeStatusTcrit
type TypeStatusTcrit
Members
Member name | Value | Description
TTCRITTCRITHYSTERESIS | 0 | T < TCRIT - TCRIT_HYSTERESIS
TTCRIT | 1 | T >= TCRIT
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95235 Class

National Semiconductor: LM 95235
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm95235

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm95235
Public Class Lm95235
public ref class Lm95235
type Lm95235 =  class end

The Lm95235 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm95235 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CommonHysteresis | Common Hysteresis (unit: °C)
Public property | ConfigurationDiodeFaultMaskForOS | Configuration: Diode Fault Mask for OS
Public property | ConfigurationDiodeFaultMaskForTCRIT | Configuration: Diode Fault Mask for T_CRIT
Public property | ConfigurationLocalOSMask0x03 | Configuration: Local OS Mask [0x03]
Public property | ConfigurationLocalOSMask0x09 | Configuration: Local OS Mask [0x09]
Public property | ConfigurationLocalTCRITMask0x03 | Configuration: Local T_CRIT Mask [0x03]
Public property | ConfigurationLocalTCRITMask0x09 | Configuration: Local T_CRIT Mask [0x09]
Public property | ConfigurationOSA0FunctionSelect | Configuration: OS/A0 Function Select
Public property | ConfigurationRemoteDiodeTruThermModeSelect | Configuration: Remote Diode TruTherm Mode Select
Public property | ConfigurationRemoteFilterEnable | Configuration: Remote Filter Enable
Public property | ConfigurationRemoteOSMask0x03 | Configuration: Remote OS Mask [0x03]
Public property | ConfigurationRemoteOSMask0x09 | Configuration: Remote OS Mask [0x09]
Public property | ConfigurationRemoteTCRITMask0x03 | Configuration: Remote T_CRIT Mask [0x03]
Public property | ConfigurationRemoteTCRITMask0x09 | Configuration: Remote T_CRIT Mask [0x09]
Public property | ConfigurationSTOPRUN0x03 | Configuration: STOP/RUN [0x03]
Public property | ConfigurationSTOPRUN0x09 | Configuration: STOP/RUN [0x09]
Public property | ConversionRate0x04 | Conversion Rate [0x04]
Public property | ConversionRate0x0a | Conversion Rate [0x0a]
Public property | LocalSharedOSTCRITLimit | Local Shared OS / T_CRIT Limit (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | RemoteOffset | Remote Offset (unit: °C)
Public property | RemoteOSLimit0x07 | Remote OS Limit [0x07] (unit: °C)
Public property | RemoteOSLimit0x0d | Remote OS Limit [0x0d] (unit: °C)
Public property | RemoteTCRITLimit | Remote T_CRIT Limit (unit: °C)
Public property | RemoteTemperatureSigned | Remote Temperature - Signed (unit: °C)
Public property | RemoteTemperatureUnsigned | Remote Temperature - Unsigned (unit: °C)
Public property | RevisionID | Revision ID
Public property | StatusBusy | Status: Busy
Public property | StatusDiodeFault | Status: Diode Fault
Public property | StatusLocalOSTCRIT | Status: Local OS / T_CRIT
Public property | StatusNotReady | Status: Not Ready
Public property | StatusRemoteOS | Status: Remote OS
Public property | StatusRemoteTCRIT | Status: Remote T_CRIT
Public property | StatusTruTherm3904Detect | Status: TruTherm 3904 Detect
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Precision Remote Diode Temperature Sensor with SMBus Interface and TruTherm™ Technology
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95235 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm95235(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm95235

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235 Properties

The Lm95235 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CommonHysteresis | Common Hysteresis (unit: °C)
Public property | ConfigurationDiodeFaultMaskForOS | Configuration: Diode Fault Mask for OS
Public property | ConfigurationDiodeFaultMaskForTCRIT | Configuration: Diode Fault Mask for T_CRIT
Public property | ConfigurationLocalOSMask0x03 | Configuration: Local OS Mask [0x03]
Public property | ConfigurationLocalOSMask0x09 | Configuration: Local OS Mask [0x09]
Public property | ConfigurationLocalTCRITMask0x03 | Configuration: Local T_CRIT Mask [0x03]
Public property | ConfigurationLocalTCRITMask0x09 | Configuration: Local T_CRIT Mask [0x09]
Public property | ConfigurationOSA0FunctionSelect | Configuration: OS/A0 Function Select
Public property | ConfigurationRemoteDiodeTruThermModeSelect | Configuration: Remote Diode TruTherm Mode Select
Public property | ConfigurationRemoteFilterEnable | Configuration: Remote Filter Enable
Public property | ConfigurationRemoteOSMask0x03 | Configuration: Remote OS Mask [0x03]
Public property | ConfigurationRemoteOSMask0x09 | Configuration: Remote OS Mask [0x09]
Public property | ConfigurationRemoteTCRITMask0x03 | Configuration: Remote T_CRIT Mask [0x03]
Public property | ConfigurationRemoteTCRITMask0x09 | Configuration: Remote T_CRIT Mask [0x09]
Public property | ConfigurationSTOPRUN0x03 | Configuration: STOP/RUN [0x03]
Public property | ConfigurationSTOPRUN0x09 | Configuration: STOP/RUN [0x09]
Public property | ConversionRate0x04 | Conversion Rate [0x04]
Public property | ConversionRate0x0a | Conversion Rate [0x0a]
Public property | LocalSharedOSTCRITLimit | Local Shared OS / T_CRIT Limit (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | RemoteOffset | Remote Offset (unit: °C)
Public property | RemoteOSLimit0x07 | Remote OS Limit [0x07] (unit: °C)
Public property | RemoteOSLimit0x0d | Remote OS Limit [0x0d] (unit: °C)
Public property | RemoteTCRITLimit | Remote T_CRIT Limit (unit: °C)
Public property | RemoteTemperatureSigned | Remote Temperature - Signed (unit: °C)
Public property | RemoteTemperatureUnsigned | Remote Temperature - Unsigned (unit: °C)
Public property | RevisionID | Revision ID
Public property | StatusBusy | Status: Busy
Public property | StatusDiodeFault | Status: Diode Fault
Public property | StatusLocalOSTCRIT | Status: Local OS / T_CRIT
Public property | StatusNotReady | Status: Not Ready
Public property | StatusRemoteOS | Status: Remote OS
Public property | StatusRemoteTCRIT | Status: Remote T_CRIT
Public property | StatusTruTherm3904Detect | Status: TruTherm 3904 Detect
Top
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.AutoFlush Property

IRD

Lm95235AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.CommonHysteresis Property

IRD

Lm95235CommonHysteresis Property

Common Hysteresis (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CommonHysteresis { get; set; }
Public Property CommonHysteresis As Byte
    Get
    Set
public:
property unsigned char CommonHysteresis {
    unsigned char get ();
    void set (unsigned char value);
}
member CommonHysteresis : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.ConfigurationDiodeFaultMaskForOS Property

IRD

Lm95235ConfigurationDiodeFaultMaskForOS Property

Configuration: Diode Fault Mask for OS

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeConfigurationOnOff ConfigurationDiodeFaultMaskForOS { get; set; }
Public Property ConfigurationDiodeFaultMaskForOS As Lm95235TypeConfigurationOnOff
    Get
    Set
public:
property Lm95235TypeConfigurationOnOff ConfigurationDiodeFaultMaskForOS {
    Lm95235TypeConfigurationOnOff get ();
    void set (Lm95235TypeConfigurationOnOff value);
}
member ConfigurationDiodeFaultMaskForOS : Lm95235TypeConfigurationOnOff with get, set

Property Value

Type: Lm95235TypeConfigurationOnOff
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.ConfigurationDiodeFaultMaskForTCRIT Property

IRD

Lm95235ConfigurationDiodeFaultMaskForTCRIT Property

Configuration: Diode Fault Mask for T_CRIT

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeConfigurationOnOff ConfigurationDiodeFaultMaskForTCRIT { get; set; }
Public Property ConfigurationDiodeFaultMaskForTCRIT As Lm95235TypeConfigurationOnOff
    Get
    Set
public:
property Lm95235TypeConfigurationOnOff ConfigurationDiodeFaultMaskForTCRIT {
    Lm95235TypeConfigurationOnOff get ();
    void set (Lm95235TypeConfigurationOnOff value);
}
member ConfigurationDiodeFaultMaskForTCRIT : Lm95235TypeConfigurationOnOff with get, set

Property Value

Type: Lm95235TypeConfigurationOnOff
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.ConfigurationLocalOSMask0x03 Property

IRD

Lm95235ConfigurationLocalOSMask0x03 Property

Configuration: Local OS Mask [0x03]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeConfigurationOnOff ConfigurationLocalOSMask0x03 { get; set; }
Public Property ConfigurationLocalOSMask0x03 As Lm95235TypeConfigurationOnOff
    Get
    Set
public:
property Lm95235TypeConfigurationOnOff ConfigurationLocalOSMask0x03 {
    Lm95235TypeConfigurationOnOff get ();
    void set (Lm95235TypeConfigurationOnOff value);
}
member ConfigurationLocalOSMask0x03 : Lm95235TypeConfigurationOnOff with get, set

Property Value

Type: Lm95235TypeConfigurationOnOff
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.ConfigurationLocalOSMask0x09 Property

IRD

Lm95235ConfigurationLocalOSMask0x09 Property

Configuration: Local OS Mask [0x09]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeConfigurationOnOff ConfigurationLocalOSMask0x09 { get; set; }
Public Property ConfigurationLocalOSMask0x09 As Lm95235TypeConfigurationOnOff
    Get
    Set
public:
property Lm95235TypeConfigurationOnOff ConfigurationLocalOSMask0x09 {
    Lm95235TypeConfigurationOnOff get ();
    void set (Lm95235TypeConfigurationOnOff value);
}
member ConfigurationLocalOSMask0x09 : Lm95235TypeConfigurationOnOff with get, set

Property Value

Type: Lm95235TypeConfigurationOnOff
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.ConfigurationLocalTCRITMask0x03 Property

IRD

Lm95235ConfigurationLocalTCRITMask0x03 Property

Configuration: Local T_CRIT Mask [0x03]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeConfigurationOnOff ConfigurationLocalTCRITMask0x03 { get; set; }
Public Property ConfigurationLocalTCRITMask0x03 As Lm95235TypeConfigurationOnOff
    Get
    Set
public:
property Lm95235TypeConfigurationOnOff ConfigurationLocalTCRITMask0x03 {
    Lm95235TypeConfigurationOnOff get ();
    void set (Lm95235TypeConfigurationOnOff value);
}
member ConfigurationLocalTCRITMask0x03 : Lm95235TypeConfigurationOnOff with get, set

Property Value

Type: Lm95235TypeConfigurationOnOff
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.ConfigurationLocalTCRITMask0x09 Property

IRD

Lm95235ConfigurationLocalTCRITMask0x09 Property

Configuration: Local T_CRIT Mask [0x09]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeConfigurationOnOff ConfigurationLocalTCRITMask0x09 { get; set; }
Public Property ConfigurationLocalTCRITMask0x09 As Lm95235TypeConfigurationOnOff
    Get
    Set
public:
property Lm95235TypeConfigurationOnOff ConfigurationLocalTCRITMask0x09 {
    Lm95235TypeConfigurationOnOff get ();
    void set (Lm95235TypeConfigurationOnOff value);
}
member ConfigurationLocalTCRITMask0x09 : Lm95235TypeConfigurationOnOff with get, set

Property Value

Type: Lm95235TypeConfigurationOnOff
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.ConfigurationOSA0FunctionSelect Property

IRD

Lm95235ConfigurationOSA0FunctionSelect Property

Configuration: OS/A0 Function Select

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeConfigurationOsA0FunctionSelect ConfigurationOSA0FunctionSelect { get; set; }
Public Property ConfigurationOSA0FunctionSelect As Lm95235TypeConfigurationOsA0FunctionSelect
    Get
    Set
public:
property Lm95235TypeConfigurationOsA0FunctionSelect ConfigurationOSA0FunctionSelect {
    Lm95235TypeConfigurationOsA0FunctionSelect get ();
    void set (Lm95235TypeConfigurationOsA0FunctionSelect value);
}
member ConfigurationOSA0FunctionSelect : Lm95235TypeConfigurationOsA0FunctionSelect with get, set

Property Value

Type: Lm95235TypeConfigurationOsA0FunctionSelect
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.ConfigurationRemoteDiodeTruThermModeSelect Property

IRD

Lm95235ConfigurationRemoteDiodeTruThermModeSelect Property

Configuration: Remote Diode TruTherm Mode Select

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeConfigurationRemoteDiodeTruthermModeSelect ConfigurationRemoteDiodeTruThermModeSelect { get; set; }
Public Property ConfigurationRemoteDiodeTruThermModeSelect As Lm95235TypeConfigurationRemoteDiodeTruthermModeSelect
    Get
    Set
public:
property Lm95235TypeConfigurationRemoteDiodeTruthermModeSelect ConfigurationRemoteDiodeTruThermModeSelect {
    Lm95235TypeConfigurationRemoteDiodeTruthermModeSelect get ();
    void set (Lm95235TypeConfigurationRemoteDiodeTruthermModeSelect value);
}
member ConfigurationRemoteDiodeTruThermModeSelect : Lm95235TypeConfigurationRemoteDiodeTruthermModeSelect with get, set

Property Value

Type: Lm95235TypeConfigurationRemoteDiodeTruthermModeSelect
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.ConfigurationRemoteFilterEnable Property

IRD

Lm95235ConfigurationRemoteFilterEnable Property

Configuration: Remote Filter Enable

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeConfigurationRemoteFilterEnable ConfigurationRemoteFilterEnable { get; set; }
Public Property ConfigurationRemoteFilterEnable As Lm95235TypeConfigurationRemoteFilterEnable
    Get
    Set
public:
property Lm95235TypeConfigurationRemoteFilterEnable ConfigurationRemoteFilterEnable {
    Lm95235TypeConfigurationRemoteFilterEnable get ();
    void set (Lm95235TypeConfigurationRemoteFilterEnable value);
}
member ConfigurationRemoteFilterEnable : Lm95235TypeConfigurationRemoteFilterEnable with get, set

Property Value

Type: Lm95235TypeConfigurationRemoteFilterEnable
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.ConfigurationRemoteOSMask0x03 Property

IRD

Lm95235ConfigurationRemoteOSMask0x03 Property

Configuration: Remote OS Mask [0x03]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeConfigurationOnOff ConfigurationRemoteOSMask0x03 { get; set; }
Public Property ConfigurationRemoteOSMask0x03 As Lm95235TypeConfigurationOnOff
    Get
    Set
public:
property Lm95235TypeConfigurationOnOff ConfigurationRemoteOSMask0x03 {
    Lm95235TypeConfigurationOnOff get ();
    void set (Lm95235TypeConfigurationOnOff value);
}
member ConfigurationRemoteOSMask0x03 : Lm95235TypeConfigurationOnOff with get, set

Property Value

Type: Lm95235TypeConfigurationOnOff
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.ConfigurationRemoteOSMask0x09 Property

IRD

Lm95235ConfigurationRemoteOSMask0x09 Property

Configuration: Remote OS Mask [0x09]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeConfigurationOnOff ConfigurationRemoteOSMask0x09 { get; set; }
Public Property ConfigurationRemoteOSMask0x09 As Lm95235TypeConfigurationOnOff
    Get
    Set
public:
property Lm95235TypeConfigurationOnOff ConfigurationRemoteOSMask0x09 {
    Lm95235TypeConfigurationOnOff get ();
    void set (Lm95235TypeConfigurationOnOff value);
}
member ConfigurationRemoteOSMask0x09 : Lm95235TypeConfigurationOnOff with get, set

Property Value

Type: Lm95235TypeConfigurationOnOff
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.ConfigurationRemoteTCRITMask0x03 Property

IRD

Lm95235ConfigurationRemoteTCRITMask0x03 Property

Configuration: Remote T_CRIT Mask [0x03]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeConfigurationOnOff ConfigurationRemoteTCRITMask0x03 { get; set; }
Public Property ConfigurationRemoteTCRITMask0x03 As Lm95235TypeConfigurationOnOff
    Get
    Set
public:
property Lm95235TypeConfigurationOnOff ConfigurationRemoteTCRITMask0x03 {
    Lm95235TypeConfigurationOnOff get ();
    void set (Lm95235TypeConfigurationOnOff value);
}
member ConfigurationRemoteTCRITMask0x03 : Lm95235TypeConfigurationOnOff with get, set

Property Value

Type: Lm95235TypeConfigurationOnOff
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.ConfigurationRemoteTCRITMask0x09 Property

IRD

Lm95235ConfigurationRemoteTCRITMask0x09 Property

Configuration: Remote T_CRIT Mask [0x09]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeConfigurationOnOff ConfigurationRemoteTCRITMask0x09 { get; set; }
Public Property ConfigurationRemoteTCRITMask0x09 As Lm95235TypeConfigurationOnOff
    Get
    Set
public:
property Lm95235TypeConfigurationOnOff ConfigurationRemoteTCRITMask0x09 {
    Lm95235TypeConfigurationOnOff get ();
    void set (Lm95235TypeConfigurationOnOff value);
}
member ConfigurationRemoteTCRITMask0x09 : Lm95235TypeConfigurationOnOff with get, set

Property Value

Type: Lm95235TypeConfigurationOnOff
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.ConfigurationSTOPRUN0x03 Property

IRD

Lm95235ConfigurationSTOPRUN0x03 Property

Configuration: STOP/RUN [0x03]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeConfigurationStopRun ConfigurationSTOPRUN0x03 { get; set; }
Public Property ConfigurationSTOPRUN0x03 As Lm95235TypeConfigurationStopRun
    Get
    Set
public:
property Lm95235TypeConfigurationStopRun ConfigurationSTOPRUN0x03 {
    Lm95235TypeConfigurationStopRun get ();
    void set (Lm95235TypeConfigurationStopRun value);
}
member ConfigurationSTOPRUN0x03 : Lm95235TypeConfigurationStopRun with get, set

Property Value

Type: Lm95235TypeConfigurationStopRun
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.ConfigurationSTOPRUN0x09 Property

IRD

Lm95235ConfigurationSTOPRUN0x09 Property

Configuration: STOP/RUN [0x09]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeConfigurationStopRun ConfigurationSTOPRUN0x09 { get; set; }
Public Property ConfigurationSTOPRUN0x09 As Lm95235TypeConfigurationStopRun
    Get
    Set
public:
property Lm95235TypeConfigurationStopRun ConfigurationSTOPRUN0x09 {
    Lm95235TypeConfigurationStopRun get ();
    void set (Lm95235TypeConfigurationStopRun value);
}
member ConfigurationSTOPRUN0x09 : Lm95235TypeConfigurationStopRun with get, set

Property Value

Type: Lm95235TypeConfigurationStopRun
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.ConversionRate0x04 Property

IRD

Lm95235ConversionRate0x04 Property

Conversion Rate [0x04]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeConversionRate ConversionRate0x04 { get; set; }
Public Property ConversionRate0x04 As Lm95235TypeConversionRate
    Get
    Set
public:
property Lm95235TypeConversionRate ConversionRate0x04 {
    Lm95235TypeConversionRate get ();
    void set (Lm95235TypeConversionRate value);
}
member ConversionRate0x04 : Lm95235TypeConversionRate with get, set

Property Value

Type: Lm95235TypeConversionRate
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.ConversionRate0x0a Property

IRD

Lm95235ConversionRate0x0a Property

Conversion Rate [0x0a]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeConversionRate ConversionRate0x0a { get; set; }
Public Property ConversionRate0x0a As Lm95235TypeConversionRate
    Get
    Set
public:
property Lm95235TypeConversionRate ConversionRate0x0a {
    Lm95235TypeConversionRate get ();
    void set (Lm95235TypeConversionRate value);
}
member ConversionRate0x0a : Lm95235TypeConversionRate with get, set

Property Value

Type: Lm95235TypeConversionRate
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.LocalSharedOSTCRITLimit Property

IRD

Lm95235LocalSharedOSTCRITLimit Property

Local Shared OS / T_CRIT Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalSharedOSTCRITLimit { get; set; }
Public Property LocalSharedOSTCRITLimit As Byte
    Get
    Set
public:
property unsigned char LocalSharedOSTCRITLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member LocalSharedOSTCRITLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.LocalTemperature Property

IRD

Lm95235LocalTemperature Property

Local Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LocalTemperature { get; }
Public ReadOnly Property LocalTemperature As Double
    Get
public:
property double LocalTemperature {
    double get ();
}
member LocalTemperature : float with get

Property Value

Type: Double
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.ManufacturerID Property

IRD

Lm95235ManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As Byte
    Get
public:
property unsigned char ManufacturerID {
    unsigned char get ();
}
member ManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.RemoteOffset Property

IRD

Lm95235RemoteOffset Property

Remote Offset (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteOffset { get; set; }
Public Property RemoteOffset As Double
    Get
    Set
public:
property double RemoteOffset {
    double get ();
    void set (double value);
}
member RemoteOffset : float with get, set

Property Value

Type: Double
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.RemoteOSLimit0x07 Property

IRD

Lm95235RemoteOSLimit0x07 Property

Remote OS Limit [0x07] (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RemoteOSLimit0x07 { get; set; }
Public Property RemoteOSLimit0x07 As Byte
    Get
    Set
public:
property unsigned char RemoteOSLimit0x07 {
    unsigned char get ();
    void set (unsigned char value);
}
member RemoteOSLimit0x07 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.RemoteOSLimit0x0d Property

IRD

Lm95235RemoteOSLimit0x0d Property

Remote OS Limit [0x0d] (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RemoteOSLimit0x0d { get; set; }
Public Property RemoteOSLimit0x0d As Byte
    Get
    Set
public:
property unsigned char RemoteOSLimit0x0d {
    unsigned char get ();
    void set (unsigned char value);
}
member RemoteOSLimit0x0d : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.RemoteTCRITLimit Property

IRD

Lm95235RemoteTCRITLimit Property

Remote T_CRIT Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RemoteTCRITLimit { get; set; }
Public Property RemoteTCRITLimit As Byte
    Get
    Set
public:
property unsigned char RemoteTCRITLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member RemoteTCRITLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.RemoteTemperatureSigned Property

IRD

Lm95235RemoteTemperatureSigned Property

Remote Temperature - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperatureSigned { get; }
Public ReadOnly Property RemoteTemperatureSigned As Double
    Get
public:
property double RemoteTemperatureSigned {
    double get ();
}
member RemoteTemperatureSigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.RemoteTemperatureUnsigned Property

IRD

Lm95235RemoteTemperatureUnsigned Property

Remote Temperature - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperatureUnsigned { get; }
Public ReadOnly Property RemoteTemperatureUnsigned As Double
    Get
public:
property double RemoteTemperatureUnsigned {
    double get ();
}
member RemoteTemperatureUnsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.RevisionID Property

IRD

Lm95235RevisionID Property

Revision ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionID { get; }
Public ReadOnly Property RevisionID As Byte
    Get
public:
property unsigned char RevisionID {
    unsigned char get ();
}
member RevisionID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.StatusBusy Property

IRD

Lm95235StatusBusy Property

Status: Busy

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeStatusBusy StatusBusy { get; }
Public ReadOnly Property StatusBusy As Lm95235TypeStatusBusy
    Get
public:
property Lm95235TypeStatusBusy StatusBusy {
    Lm95235TypeStatusBusy get ();
}
member StatusBusy : Lm95235TypeStatusBusy with get

Property Value

Type: Lm95235TypeStatusBusy
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.StatusDiodeFault Property

IRD

Lm95235StatusDiodeFault Property

Status: Diode Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeStatusTriggered StatusDiodeFault { get; }
Public ReadOnly Property StatusDiodeFault As Lm95235TypeStatusTriggered
    Get
public:
property Lm95235TypeStatusTriggered StatusDiodeFault {
    Lm95235TypeStatusTriggered get ();
}
member StatusDiodeFault : Lm95235TypeStatusTriggered with get

Property Value

Type: Lm95235TypeStatusTriggered
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.StatusLocalOSTCRIT Property

IRD

Lm95235StatusLocalOSTCRIT Property

Status: Local OS / T_CRIT

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeStatusTriggered StatusLocalOSTCRIT { get; }
Public ReadOnly Property StatusLocalOSTCRIT As Lm95235TypeStatusTriggered
    Get
public:
property Lm95235TypeStatusTriggered StatusLocalOSTCRIT {
    Lm95235TypeStatusTriggered get ();
}
member StatusLocalOSTCRIT : Lm95235TypeStatusTriggered with get

Property Value

Type: Lm95235TypeStatusTriggered
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.StatusNotReady Property

IRD

Lm95235StatusNotReady Property

Status: Not Ready

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeStatusNotReady StatusNotReady { get; }
Public ReadOnly Property StatusNotReady As Lm95235TypeStatusNotReady
    Get
public:
property Lm95235TypeStatusNotReady StatusNotReady {
    Lm95235TypeStatusNotReady get ();
}
member StatusNotReady : Lm95235TypeStatusNotReady with get

Property Value

Type: Lm95235TypeStatusNotReady
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.StatusRemoteOS Property

IRD

Lm95235StatusRemoteOS Property

Status: Remote OS

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeStatusTriggered StatusRemoteOS { get; }
Public ReadOnly Property StatusRemoteOS As Lm95235TypeStatusTriggered
    Get
public:
property Lm95235TypeStatusTriggered StatusRemoteOS {
    Lm95235TypeStatusTriggered get ();
}
member StatusRemoteOS : Lm95235TypeStatusTriggered with get

Property Value

Type: Lm95235TypeStatusTriggered
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.StatusRemoteTCRIT Property

IRD

Lm95235StatusRemoteTCRIT Property

Status: Remote T_CRIT

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeStatusTriggered StatusRemoteTCRIT { get; }
Public ReadOnly Property StatusRemoteTCRIT As Lm95235TypeStatusTriggered
    Get
public:
property Lm95235TypeStatusTriggered StatusRemoteTCRIT {
    Lm95235TypeStatusTriggered get ();
}
member StatusRemoteTCRIT : Lm95235TypeStatusTriggered with get

Property Value

Type: Lm95235TypeStatusTriggered
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.StatusTruTherm3904Detect Property

IRD

Lm95235StatusTruTherm3904Detect Property

Status: TruTherm 3904 Detect

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95235TypeStatusTrutherm3904Detect StatusTruTherm3904Detect { get; }
Public ReadOnly Property StatusTruTherm3904Detect As Lm95235TypeStatusTrutherm3904Detect
    Get
public:
property Lm95235TypeStatusTrutherm3904Detect StatusTruTherm3904Detect {
    Lm95235TypeStatusTrutherm3904Detect get ();
}
member StatusTruTherm3904Detect : Lm95235TypeStatusTrutherm3904Detect with get

Property Value

Type: Lm95235TypeStatusTrutherm3904Detect
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235 Methods

The Lm95235 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.Flush Method

IRD

Lm95235Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.OneShot Method

IRD

Lm95235OneShot Method

One-Shot

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void OneShot()
Public Sub OneShot
public:
void OneShot()
member OneShot : unit -> unit
See Also

Reference

Lm95235 Class
telos.Ird.NationalSemiconductor Namespace


Lm95235.TypeConfigurationOnOff Enumeration

IRD

Lm95235TypeConfigurationOnOff Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationOnOff
Public Enumeration TypeConfigurationOnOff
public enum class TypeConfigurationOnOff
type TypeConfigurationOnOff
Members
Member name | Value | Description
Off | 0 | Off
On | 1 | On
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95235.TypeConfigurationOsA0FunctionSelect Enumeration

IRD

Lm95235TypeConfigurationOsA0FunctionSelect Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationOsA0FunctionSelect
Public Enumeration TypeConfigurationOsA0FunctionSelect
public enum class TypeConfigurationOsA0FunctionSelect
type TypeConfigurationOsA0FunctionSelect
Members
Member name | Value | Description
AddressA0FunctionEnabled | 0 | Address (A0) Function Enabled
OverTemperatureShutdownOSEnabled | 1 | Over-Temperature Shutdown (OS) Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95235.TypeConfigurationRemoteDiodeTruthermModeSelect Enumeration

IRD

Lm95235TypeConfigurationRemoteDiodeTruthermModeSelect Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationRemoteDiodeTruthermModeSelect
Public Enumeration TypeConfigurationRemoteDiodeTruthermModeSelect
public enum class TypeConfigurationRemoteDiodeTruthermModeSelect
type TypeConfigurationRemoteDiodeTruthermModeSelect
Members
Member name | Value | Description
DiodeModel2MMBT3904 | 0 | Diode Model 2, MMBT3904
DiodeModel1IntelProcessor | 1 | Diode Model 1, Intel Processor
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95235.TypeConfigurationRemoteFilterEnable Enumeration

IRD

Lm95235TypeConfigurationRemoteFilterEnable Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationRemoteFilterEnable
Public Enumeration TypeConfigurationRemoteFilterEnable
public enum class TypeConfigurationRemoteFilterEnable
type TypeConfigurationRemoteFilterEnable
Members
Member name | Value | Description
Disable | 0 | Disable
Reserved | 1 | Reserved
Enable | 3 | Enable
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95235.TypeConfigurationStopRun Enumeration

IRD

Lm95235TypeConfigurationStopRun Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationStopRun
Public Enumeration TypeConfigurationStopRun
public enum class TypeConfigurationStopRun
type TypeConfigurationStopRun
Members
Member name | Value | Description
ActiveConverting | 0 | Active/Converting
Standby | 1 | Standby
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95235.TypeConversionRate Enumeration

IRD

Lm95235TypeConversionRate Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConversionRate
Public Enumeration TypeConversionRate
public enum class TypeConversionRate
type TypeConversionRate
Members
Member name | Value | Description
Continuous | 0 | Continuous
Value_00364S | 1 | 0.0364 s
Value_1S | 2 | 1 s
Value_25S | 3 | 2.5 s
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95235.TypeStatusBusy Enumeration

IRD

Lm95235TypeStatusBusy Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusBusy
Public Enumeration TypeStatusBusy
public enum class TypeStatusBusy
type TypeStatusBusy
Members
Member name | Value | Description
NotConverting | 0 | Not Converting
Converting | 1 | Converting
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95235.TypeStatusNotReady Enumeration

IRD

Lm95235TypeStatusNotReady Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusNotReady
Public Enumeration TypeStatusNotReady
public enum class TypeStatusNotReady
type TypeStatusNotReady
Members
Member name | Value | Description
Ready | 0 | Ready
NotReady | 1 | Not Ready
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95235.TypeStatusTriggered Enumeration

IRD

Lm95235TypeStatusTriggered Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusTriggered
Public Enumeration TypeStatusTriggered
public enum class TypeStatusTriggered
type TypeStatusTriggered
Members
Member name | Value | Description
NotTriggered | 0 | Not Triggered
Triggered | 1 | Triggered
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95235.TypeStatusTrutherm3904Detect Enumeration

IRD

Lm95235TypeStatusTrutherm3904Detect Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusTrutherm3904Detect
Public Enumeration TypeStatusTrutherm3904Detect
public enum class TypeStatusTrutherm3904Detect
type TypeStatusTrutherm3904Detect
Members
Member name | Value | Description
MMBT3904ConnectedTruThermEnabled | 0 | MMBT3904 Connected / TruTherm Enabled
MMBT3904ConnectedTruThermDisabled | 1 | MMBT3904 Connected / TruTherm Disabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95241 Class

National Semiconductor: LM 95241
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm95241

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm95241
Public Class Lm95241
public ref class Lm95241
type Lm95241 =  class end

The Lm95241 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm95241 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationConversionRate | Configuration: Conversion Rate
Public property | ConfigurationRemote1DataFormat | Configuration: Remote 1 Data Format
Public property | ConfigurationRemote2DataFormat | Configuration: Remote 2 Data Format
Public property | ConfigurationRUNSTOP | Configuration: RUN/STOP
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | Remote1TemperatureSigned | Remote 1 Temperature - Signed (unit: °C)
Public property | Remote1TemperatureUnsigned | Remote 1 Temperature - Unsigned (unit: °C)
Public property | Remote2TemperatureSigned | Remote 2 Temperature - Signed (unit: °C)
Public property | Remote2TemperatureUnsigned | Remote 2 Temperature - Unsigned (unit: °C)
Public property | RemoteDiodeFilterControlRemote1 | Remote Diode Filter Control: Remote 1
Public property | RemoteDiodeFilterControlRemote2 | Remote Diode Filter Control: Remote 2
Public property | RemoteDiodeModelTypeSelectRemote1 | Remote Diode Model Type Select: Remote 1
Public property | RemoteDiodeModelTypeSelectRemote2 | Remote Diode Model Type Select: Remote 2
Public property | RemoteTruThermModeControlRemote1 | Remote TruTherm Mode Control: Remote 1
Public property | RemoteTruThermModeControlRemote2 | Remote TruTherm Mode Control: Remote 2
Public property | RevisionID | Revision ID
Public property | StatusBusy | Status: Busy
Public property | StatusRemote1DiodeMissing | Status: Remote 1 Diode Missing
Public property | StatusRemote1TruThermModeEnable | Status: Remote 1 TruTherm Mode Enable
Public property | StatusRemote2DiodeMissing | Status: Remote 2 Diode Missing
Public property | StatusRemote2TruThermModeEnable | Status: Remote 2 TruTherm Mode Enable
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Method_1Shot | 1-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Dual Remote Diode Temperature Sensor with SMBus Interface and TruTherm™ Technology (65nm/90nm)
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95241 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95241(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm95241(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm95241

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241 Properties

The Lm95241 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationConversionRate | Configuration: Conversion Rate
Public property | ConfigurationRemote1DataFormat | Configuration: Remote 1 Data Format
Public property | ConfigurationRemote2DataFormat | Configuration: Remote 2 Data Format
Public property | ConfigurationRUNSTOP | Configuration: RUN/STOP
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | Remote1TemperatureSigned | Remote 1 Temperature - Signed (unit: °C)
Public property | Remote1TemperatureUnsigned | Remote 1 Temperature - Unsigned (unit: °C)
Public property | Remote2TemperatureSigned | Remote 2 Temperature - Signed (unit: °C)
Public property | Remote2TemperatureUnsigned | Remote 2 Temperature - Unsigned (unit: °C)
Public property | RemoteDiodeFilterControlRemote1 | Remote Diode Filter Control: Remote 1
Public property | RemoteDiodeFilterControlRemote2 | Remote Diode Filter Control: Remote 2
Public property | RemoteDiodeModelTypeSelectRemote1 | Remote Diode Model Type Select: Remote 1
Public property | RemoteDiodeModelTypeSelectRemote2 | Remote Diode Model Type Select: Remote 2
Public property | RemoteTruThermModeControlRemote1 | Remote TruTherm Mode Control: Remote 1
Public property | RemoteTruThermModeControlRemote2 | Remote TruTherm Mode Control: Remote 2
Public property | RevisionID | Revision ID
Public property | StatusBusy | Status: Busy
Public property | StatusRemote1DiodeMissing | Status: Remote 1 Diode Missing
Public property | StatusRemote1TruThermModeEnable | Status: Remote 1 TruTherm Mode Enable
Public property | StatusRemote2DiodeMissing | Status: Remote 2 Diode Missing
Public property | StatusRemote2TruThermModeEnable | Status: Remote 2 TruTherm Mode Enable
Top
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.AutoFlush Property

IRD

Lm95241AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.ConfigurationConversionRate Property

IRD

Lm95241ConfigurationConversionRate Property

Configuration: Conversion Rate

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95241TypeConfigurationConversionRate ConfigurationConversionRate { get; set; }
Public Property ConfigurationConversionRate As Lm95241TypeConfigurationConversionRate
    Get
    Set
public:
property Lm95241TypeConfigurationConversionRate ConfigurationConversionRate {
    Lm95241TypeConfigurationConversionRate get ();
    void set (Lm95241TypeConfigurationConversionRate value);
}
member ConfigurationConversionRate : Lm95241TypeConfigurationConversionRate with get, set

Property Value

Type: Lm95241TypeConfigurationConversionRate
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.ConfigurationRemote1DataFormat Property

IRD

Lm95241ConfigurationRemote1DataFormat Property

Configuration: Remote 1 Data Format

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95241TypeConfigurationDataFormat ConfigurationRemote1DataFormat { get; set; }
Public Property ConfigurationRemote1DataFormat As Lm95241TypeConfigurationDataFormat
    Get
    Set
public:
property Lm95241TypeConfigurationDataFormat ConfigurationRemote1DataFormat {
    Lm95241TypeConfigurationDataFormat get ();
    void set (Lm95241TypeConfigurationDataFormat value);
}
member ConfigurationRemote1DataFormat : Lm95241TypeConfigurationDataFormat with get, set

Property Value

Type: Lm95241TypeConfigurationDataFormat
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.ConfigurationRemote2DataFormat Property

IRD

Lm95241ConfigurationRemote2DataFormat Property

Configuration: Remote 2 Data Format

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95241TypeConfigurationDataFormat ConfigurationRemote2DataFormat { get; set; }
Public Property ConfigurationRemote2DataFormat As Lm95241TypeConfigurationDataFormat
    Get
    Set
public:
property Lm95241TypeConfigurationDataFormat ConfigurationRemote2DataFormat {
    Lm95241TypeConfigurationDataFormat get ();
    void set (Lm95241TypeConfigurationDataFormat value);
}
member ConfigurationRemote2DataFormat : Lm95241TypeConfigurationDataFormat with get, set

Property Value

Type: Lm95241TypeConfigurationDataFormat
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.ConfigurationRUNSTOP Property

IRD

Lm95241ConfigurationRUNSTOP Property

Configuration: RUN/STOP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95241TypeConfigurationRunStop ConfigurationRUNSTOP { get; set; }
Public Property ConfigurationRUNSTOP As Lm95241TypeConfigurationRunStop
    Get
    Set
public:
property Lm95241TypeConfigurationRunStop ConfigurationRUNSTOP {
    Lm95241TypeConfigurationRunStop get ();
    void set (Lm95241TypeConfigurationRunStop value);
}
member ConfigurationRUNSTOP : Lm95241TypeConfigurationRunStop with get, set

Property Value

Type: Lm95241TypeConfigurationRunStop
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.LocalTemperature Property

IRD

Lm95241LocalTemperature Property

Local Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LocalTemperature { get; }
Public ReadOnly Property LocalTemperature As Double
    Get
public:
property double LocalTemperature {
    double get ();
}
member LocalTemperature : float with get

Property Value

Type: Double
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.ManufacturerID Property

IRD

Lm95241ManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As Byte
    Get
public:
property unsigned char ManufacturerID {
    unsigned char get ();
}
member ManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.Remote1TemperatureSigned Property

IRD

Lm95241Remote1TemperatureSigned Property

Remote 1 Temperature - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote1TemperatureSigned { get; }
Public ReadOnly Property Remote1TemperatureSigned As Double
    Get
public:
property double Remote1TemperatureSigned {
    double get ();
}
member Remote1TemperatureSigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.Remote1TemperatureUnsigned Property

IRD

Lm95241Remote1TemperatureUnsigned Property

Remote 1 Temperature - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote1TemperatureUnsigned { get; }
Public ReadOnly Property Remote1TemperatureUnsigned As Double
    Get
public:
property double Remote1TemperatureUnsigned {
    double get ();
}
member Remote1TemperatureUnsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.Remote2TemperatureSigned Property

IRD

Lm95241Remote2TemperatureSigned Property

Remote 2 Temperature - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote2TemperatureSigned { get; }
Public ReadOnly Property Remote2TemperatureSigned As Double
    Get
public:
property double Remote2TemperatureSigned {
    double get ();
}
member Remote2TemperatureSigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.Remote2TemperatureUnsigned Property

IRD

Lm95241Remote2TemperatureUnsigned Property

Remote 2 Temperature - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Remote2TemperatureUnsigned { get; }
Public ReadOnly Property Remote2TemperatureUnsigned As Double
    Get
public:
property double Remote2TemperatureUnsigned {
    double get ();
}
member Remote2TemperatureUnsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.RemoteDiodeFilterControlRemote1 Property

IRD

Lm95241RemoteDiodeFilterControlRemote1 Property

Remote Diode Filter Control: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95241TypeRemoteDiodeFilterControl RemoteDiodeFilterControlRemote1 { get; set; }
Public Property RemoteDiodeFilterControlRemote1 As Lm95241TypeRemoteDiodeFilterControl
    Get
    Set
public:
property Lm95241TypeRemoteDiodeFilterControl RemoteDiodeFilterControlRemote1 {
    Lm95241TypeRemoteDiodeFilterControl get ();
    void set (Lm95241TypeRemoteDiodeFilterControl value);
}
member RemoteDiodeFilterControlRemote1 : Lm95241TypeRemoteDiodeFilterControl with get, set

Property Value

Type: Lm95241TypeRemoteDiodeFilterControl
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.RemoteDiodeFilterControlRemote2 Property

IRD

Lm95241RemoteDiodeFilterControlRemote2 Property

Remote Diode Filter Control: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95241TypeRemoteDiodeFilterControl RemoteDiodeFilterControlRemote2 { get; set; }
Public Property RemoteDiodeFilterControlRemote2 As Lm95241TypeRemoteDiodeFilterControl
    Get
    Set
public:
property Lm95241TypeRemoteDiodeFilterControl RemoteDiodeFilterControlRemote2 {
    Lm95241TypeRemoteDiodeFilterControl get ();
    void set (Lm95241TypeRemoteDiodeFilterControl value);
}
member RemoteDiodeFilterControlRemote2 : Lm95241TypeRemoteDiodeFilterControl with get, set

Property Value

Type: Lm95241TypeRemoteDiodeFilterControl
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.RemoteDiodeModelTypeSelectRemote1 Property

IRD

Lm95241RemoteDiodeModelTypeSelectRemote1 Property

Remote Diode Model Type Select: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95241TypeRemoteDiodeModelTypeSelect RemoteDiodeModelTypeSelectRemote1 { get; set; }
Public Property RemoteDiodeModelTypeSelectRemote1 As Lm95241TypeRemoteDiodeModelTypeSelect
    Get
    Set
public:
property Lm95241TypeRemoteDiodeModelTypeSelect RemoteDiodeModelTypeSelectRemote1 {
    Lm95241TypeRemoteDiodeModelTypeSelect get ();
    void set (Lm95241TypeRemoteDiodeModelTypeSelect value);
}
member RemoteDiodeModelTypeSelectRemote1 : Lm95241TypeRemoteDiodeModelTypeSelect with get, set

Property Value

Type: Lm95241TypeRemoteDiodeModelTypeSelect
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.RemoteDiodeModelTypeSelectRemote2 Property

IRD

Lm95241RemoteDiodeModelTypeSelectRemote2 Property

Remote Diode Model Type Select: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95241TypeRemoteDiodeModelTypeSelect RemoteDiodeModelTypeSelectRemote2 { get; set; }
Public Property RemoteDiodeModelTypeSelectRemote2 As Lm95241TypeRemoteDiodeModelTypeSelect
    Get
    Set
public:
property Lm95241TypeRemoteDiodeModelTypeSelect RemoteDiodeModelTypeSelectRemote2 {
    Lm95241TypeRemoteDiodeModelTypeSelect get ();
    void set (Lm95241TypeRemoteDiodeModelTypeSelect value);
}
member RemoteDiodeModelTypeSelectRemote2 : Lm95241TypeRemoteDiodeModelTypeSelect with get, set

Property Value

Type: Lm95241TypeRemoteDiodeModelTypeSelect
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.RemoteTruThermModeControlRemote1 Property

IRD

Lm95241RemoteTruThermModeControlRemote1 Property

Remote TruTherm Mode Control: Remote 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95241TypeRemoteTruthermModeControl RemoteTruThermModeControlRemote1 { get; set; }
Public Property RemoteTruThermModeControlRemote1 As Lm95241TypeRemoteTruthermModeControl
    Get
    Set
public:
property Lm95241TypeRemoteTruthermModeControl RemoteTruThermModeControlRemote1 {
    Lm95241TypeRemoteTruthermModeControl get ();
    void set (Lm95241TypeRemoteTruthermModeControl value);
}
member RemoteTruThermModeControlRemote1 : Lm95241TypeRemoteTruthermModeControl with get, set

Property Value

Type: Lm95241TypeRemoteTruthermModeControl
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.RemoteTruThermModeControlRemote2 Property

IRD

Lm95241RemoteTruThermModeControlRemote2 Property

Remote TruTherm Mode Control: Remote 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95241TypeRemoteTruthermModeControl RemoteTruThermModeControlRemote2 { get; set; }
Public Property RemoteTruThermModeControlRemote2 As Lm95241TypeRemoteTruthermModeControl
    Get
    Set
public:
property Lm95241TypeRemoteTruthermModeControl RemoteTruThermModeControlRemote2 {
    Lm95241TypeRemoteTruthermModeControl get ();
    void set (Lm95241TypeRemoteTruthermModeControl value);
}
member RemoteTruThermModeControlRemote2 : Lm95241TypeRemoteTruthermModeControl with get, set

Property Value

Type: Lm95241TypeRemoteTruthermModeControl
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.RevisionID Property

IRD

Lm95241RevisionID Property

Revision ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionID { get; }
Public ReadOnly Property RevisionID As Byte
    Get
public:
property unsigned char RevisionID {
    unsigned char get ();
}
member RevisionID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.StatusBusy Property

IRD

Lm95241StatusBusy Property

Status: Busy

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95241TypeStatusBusy StatusBusy { get; }
Public ReadOnly Property StatusBusy As Lm95241TypeStatusBusy
    Get
public:
property Lm95241TypeStatusBusy StatusBusy {
    Lm95241TypeStatusBusy get ();
}
member StatusBusy : Lm95241TypeStatusBusy with get

Property Value

Type: Lm95241TypeStatusBusy
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.StatusRemote1DiodeMissing Property

IRD

Lm95241StatusRemote1DiodeMissing Property

Status: Remote 1 Diode Missing

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95241TypeStatusDiodeMissing StatusRemote1DiodeMissing { get; }
Public ReadOnly Property StatusRemote1DiodeMissing As Lm95241TypeStatusDiodeMissing
    Get
public:
property Lm95241TypeStatusDiodeMissing StatusRemote1DiodeMissing {
    Lm95241TypeStatusDiodeMissing get ();
}
member StatusRemote1DiodeMissing : Lm95241TypeStatusDiodeMissing with get

Property Value

Type: Lm95241TypeStatusDiodeMissing
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.StatusRemote1TruThermModeEnable Property

IRD

Lm95241StatusRemote1TruThermModeEnable Property

Status: Remote 1 TruTherm Mode Enable

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95241TypeStatusTruthermMode StatusRemote1TruThermModeEnable { get; }
Public ReadOnly Property StatusRemote1TruThermModeEnable As Lm95241TypeStatusTruthermMode
    Get
public:
property Lm95241TypeStatusTruthermMode StatusRemote1TruThermModeEnable {
    Lm95241TypeStatusTruthermMode get ();
}
member StatusRemote1TruThermModeEnable : Lm95241TypeStatusTruthermMode with get

Property Value

Type: Lm95241TypeStatusTruthermMode
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.StatusRemote2DiodeMissing Property

IRD

Lm95241StatusRemote2DiodeMissing Property

Status: Remote 2 Diode Missing

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95241TypeStatusDiodeMissing StatusRemote2DiodeMissing { get; }
Public ReadOnly Property StatusRemote2DiodeMissing As Lm95241TypeStatusDiodeMissing
    Get
public:
property Lm95241TypeStatusDiodeMissing StatusRemote2DiodeMissing {
    Lm95241TypeStatusDiodeMissing get ();
}
member StatusRemote2DiodeMissing : Lm95241TypeStatusDiodeMissing with get

Property Value

Type: Lm95241TypeStatusDiodeMissing
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.StatusRemote2TruThermModeEnable Property

IRD

Lm95241StatusRemote2TruThermModeEnable Property

Status: Remote 2 TruTherm Mode Enable

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95241TypeStatusTruthermMode StatusRemote2TruThermModeEnable { get; }
Public ReadOnly Property StatusRemote2TruThermModeEnable As Lm95241TypeStatusTruthermMode
    Get
public:
property Lm95241TypeStatusTruthermMode StatusRemote2TruThermModeEnable {
    Lm95241TypeStatusTruthermMode get ();
}
member StatusRemote2TruThermModeEnable : Lm95241TypeStatusTruthermMode with get

Property Value

Type: Lm95241TypeStatusTruthermMode
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241 Methods

The Lm95241 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Method_1Shot | 1-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.Flush Method

IRD

Lm95241Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.Method_1Shot Method

IRD

Lm95241Method_1Shot Method

1-Shot

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Method_1Shot()
Public Sub Method_1Shot
public:
void Method_1Shot()
member Method_1Shot : unit -> unit
See Also

Reference

Lm95241 Class
telos.Ird.NationalSemiconductor Namespace


Lm95241.TypeConfigurationConversionRate Enumeration

IRD

Lm95241TypeConfigurationConversionRate Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationConversionRate
Public Enumeration TypeConfigurationConversionRate
public enum class TypeConfigurationConversionRate
type TypeConfigurationConversionRate
Members
Member name | Value | Description
ContinuousMode765Ms131Hz | 0 | Continuous Mode 76.5 ms, 13.1 Hz
ConvertsEvery182Ms55Hz | 1 | Converts Every 182 ms, 5.5 Hz
ConvertsEvery1S1Hz | 2 | Converts Every 1 s, 1 Hz
ConvertsEvery27S037Hz | 3 | Converts Every 2.7 s, 0.37 Hz
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95241.TypeConfigurationDataFormat Enumeration

IRD

Lm95241TypeConfigurationDataFormat Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationDataFormat
Public Enumeration TypeConfigurationDataFormat
public enum class TypeConfigurationDataFormat
type TypeConfigurationDataFormat
Members
Member name | Value | Description
Unsigned | 0 | Unsigned
Signed | 1 | Signed
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95241.TypeConfigurationRunStop Enumeration

IRD

Lm95241TypeConfigurationRunStop Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationRunStop
Public Enumeration TypeConfigurationRunStop
public enum class TypeConfigurationRunStop
type TypeConfigurationRunStop
Members
Member name | Value | Description
Run | 0 | Run
Stop | 1 | Stop
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95241.TypeRemoteDiodeFilterControl Enumeration

IRD

Lm95241TypeRemoteDiodeFilterControl Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRemoteDiodeFilterControl
Public Enumeration TypeRemoteDiodeFilterControl
public enum class TypeRemoteDiodeFilterControl
type TypeRemoteDiodeFilterControl
Members
Member name | Value | Description
FilterOff | 0 | Filter Off
NoiseFilterOn | 1 | Noise Filter On
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95241.TypeRemoteDiodeModelTypeSelect Enumeration

IRD

Lm95241TypeRemoteDiodeModelTypeSelect Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRemoteDiodeModelTypeSelect
Public Enumeration TypeRemoteDiodeModelTypeSelect
public enum class TypeRemoteDiodeModelTypeSelect
type TypeRemoteDiodeModelTypeSelect
Members
Member name | Value | Description
Value_2N3904 | 0 | 2N3904
Pentium4 | 1 | Pentium 4
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95241.TypeRemoteTruthermModeControl Enumeration

IRD

Lm95241TypeRemoteTruthermModeControl Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRemoteTruthermModeControl
Public Enumeration TypeRemoteTruthermModeControl
public enum class TypeRemoteTruthermModeControl
type TypeRemoteTruthermModeControl
Members
Member name | Value | Description
TruThermModeDisabled | 0 | TruTherm Mode: Disabled
TruThermModeEnabled | 1 | TruTherm Mode: Enabled
Reserved | 2 | Reserved
TruThermModeEnabled__1 | 7 | TruTherm Mode: Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95241.TypeStatusBusy Enumeration

IRD

Lm95241TypeStatusBusy Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusBusy
Public Enumeration TypeStatusBusy
public enum class TypeStatusBusy
type TypeStatusBusy
Members
Member name | Value | Description
NotConverting | 0 | Not Converting
Converting | 1 | Converting
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95241.TypeStatusDiodeMissing Enumeration

IRD

Lm95241TypeStatusDiodeMissing Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusDiodeMissing
Public Enumeration TypeStatusDiodeMissing
public enum class TypeStatusDiodeMissing
type TypeStatusDiodeMissing
Members
Member name | Value | Description
RemoteDiodeOk | 0 | Remote Diode: Ok
RemoteDiodeMissing | 1 | Remote Diode: Missing
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95241.TypeStatusTruthermMode Enumeration

IRD

Lm95241TypeStatusTruthermMode Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusTruthermMode
Public Enumeration TypeStatusTruthermMode
public enum class TypeStatusTruthermMode
type TypeStatusTruthermMode
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95245 Class

National Semiconductor: LM 95245
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm95245

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm95245
Public Class Lm95245
public ref class Lm95245
type Lm95245 =  class end

The Lm95245 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm95245 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CommonHysteresis | Common Hysteresis (unit: °C)
Public property | ConfigurationDiodeFaultMaskForOS | Configuration: Diode Fault Mask for OS
Public property | ConfigurationDiodeFaultMaskForTCRIT | Configuration: Diode Fault Mask for T_CRIT
Public property | ConfigurationLocalOSMask0x03 | Configuration: Local OS Mask [0x03]
Public property | ConfigurationLocalOSMask0x09 | Configuration: Local OS Mask [0x09]
Public property | ConfigurationLocalTCRITMask0x03 | Configuration: Local T_CRIT Mask [0x03]
Public property | ConfigurationLocalTCRITMask0x09 | Configuration: Local T_CRIT Mask [0x09]
Public property | ConfigurationOSA0FunctionSelect | Configuration: OS/A0 Function Select
Public property | ConfigurationRemoteDiodeTruThermModeSelect | Configuration: Remote Diode TruTherm Mode Select
Public property | ConfigurationRemoteFilterEnable | Configuration: Remote Filter Enable
Public property | ConfigurationRemoteOSMask0x03 | Configuration: Remote OS Mask [0x03]
Public property | ConfigurationRemoteOSMask0x09 | Configuration: Remote OS Mask [0x09]
Public property | ConfigurationRemoteTCRITMask0x03 | Configuration: Remote T_CRIT Mask [0x03]
Public property | ConfigurationRemoteTCRITMask0x09 | Configuration: Remote T_CRIT Mask [0x09]
Public property | ConfigurationSTOPRUN0x03 | Configuration: STOP/RUN [0x03]
Public property | ConfigurationSTOPRUN0x09 | Configuration: STOP/RUN [0x09]
Public property | ConversionRate0x04 | Conversion Rate [0x04]
Public property | ConversionRate0x0a | Conversion Rate [0x0a]
Public property | LocalSharedOSTCRITLimit | Local Shared OS / T_CRIT Limit (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | RemoteOffset | Remote Offset (unit: °C)
Public property | RemoteOSLimit0x07 | Remote OS Limit [0x07] (unit: °C)
Public property | RemoteOSLimit0x0d | Remote OS Limit [0x0d] (unit: °C)
Public property | RemoteTCRITLimit | Remote T_CRIT Limit (unit: °C)
Public property | RemoteTemperatureSigned | Remote Temperature - Signed (unit: °C)
Public property | RemoteTemperatureUnsigned | Remote Temperature - Unsigned (unit: °C)
Public property | RevisionID | Revision ID
Public property | StatusBusy | Status: Busy
Public property | StatusDiodeFault | Status: Diode Fault
Public property | StatusLocalOSTCRIT | Status: Local OS / T_CRIT
Public property | StatusNotReady | Status: Not Ready
Public property | StatusRemoteOS | Status: Remote OS
Public property | StatusRemoteTCRIT | Status: Remote T_CRIT
Public property | StatusTruTherm3904Detect | Status: TruTherm 3904 Detect
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Precision Remote Diode Digital Temperature Sensor with TruTherm® BJT Beta Compensation Technology for 45nm Process
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95245 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm95245(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm95245

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245 Properties

The Lm95245 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CommonHysteresis | Common Hysteresis (unit: °C)
Public property | ConfigurationDiodeFaultMaskForOS | Configuration: Diode Fault Mask for OS
Public property | ConfigurationDiodeFaultMaskForTCRIT | Configuration: Diode Fault Mask for T_CRIT
Public property | ConfigurationLocalOSMask0x03 | Configuration: Local OS Mask [0x03]
Public property | ConfigurationLocalOSMask0x09 | Configuration: Local OS Mask [0x09]
Public property | ConfigurationLocalTCRITMask0x03 | Configuration: Local T_CRIT Mask [0x03]
Public property | ConfigurationLocalTCRITMask0x09 | Configuration: Local T_CRIT Mask [0x09]
Public property | ConfigurationOSA0FunctionSelect | Configuration: OS/A0 Function Select
Public property | ConfigurationRemoteDiodeTruThermModeSelect | Configuration: Remote Diode TruTherm Mode Select
Public property | ConfigurationRemoteFilterEnable | Configuration: Remote Filter Enable
Public property | ConfigurationRemoteOSMask0x03 | Configuration: Remote OS Mask [0x03]
Public property | ConfigurationRemoteOSMask0x09 | Configuration: Remote OS Mask [0x09]
Public property | ConfigurationRemoteTCRITMask0x03 | Configuration: Remote T_CRIT Mask [0x03]
Public property | ConfigurationRemoteTCRITMask0x09 | Configuration: Remote T_CRIT Mask [0x09]
Public property | ConfigurationSTOPRUN0x03 | Configuration: STOP/RUN [0x03]
Public property | ConfigurationSTOPRUN0x09 | Configuration: STOP/RUN [0x09]
Public property | ConversionRate0x04 | Conversion Rate [0x04]
Public property | ConversionRate0x0a | Conversion Rate [0x0a]
Public property | LocalSharedOSTCRITLimit | Local Shared OS / T_CRIT Limit (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerID | Manufacturer ID
Public property | RemoteOffset | Remote Offset (unit: °C)
Public property | RemoteOSLimit0x07 | Remote OS Limit [0x07] (unit: °C)
Public property | RemoteOSLimit0x0d | Remote OS Limit [0x0d] (unit: °C)
Public property | RemoteTCRITLimit | Remote T_CRIT Limit (unit: °C)
Public property | RemoteTemperatureSigned | Remote Temperature - Signed (unit: °C)
Public property | RemoteTemperatureUnsigned | Remote Temperature - Unsigned (unit: °C)
Public property | RevisionID | Revision ID
Public property | StatusBusy | Status: Busy
Public property | StatusDiodeFault | Status: Diode Fault
Public property | StatusLocalOSTCRIT | Status: Local OS / T_CRIT
Public property | StatusNotReady | Status: Not Ready
Public property | StatusRemoteOS | Status: Remote OS
Public property | StatusRemoteTCRIT | Status: Remote T_CRIT
Public property | StatusTruTherm3904Detect | Status: TruTherm 3904 Detect
Top
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.AutoFlush Property

IRD

Lm95245AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.CommonHysteresis Property

IRD

Lm95245CommonHysteresis Property

Common Hysteresis (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CommonHysteresis { get; set; }
Public Property CommonHysteresis As Byte
    Get
    Set
public:
property unsigned char CommonHysteresis {
    unsigned char get ();
    void set (unsigned char value);
}
member CommonHysteresis : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.ConfigurationDiodeFaultMaskForOS Property

IRD

Lm95245ConfigurationDiodeFaultMaskForOS Property

Configuration: Diode Fault Mask for OS

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeConfigurationOnOff ConfigurationDiodeFaultMaskForOS { get; set; }
Public Property ConfigurationDiodeFaultMaskForOS As Lm95245TypeConfigurationOnOff
    Get
    Set
public:
property Lm95245TypeConfigurationOnOff ConfigurationDiodeFaultMaskForOS {
    Lm95245TypeConfigurationOnOff get ();
    void set (Lm95245TypeConfigurationOnOff value);
}
member ConfigurationDiodeFaultMaskForOS : Lm95245TypeConfigurationOnOff with get, set

Property Value

Type: Lm95245TypeConfigurationOnOff
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.ConfigurationDiodeFaultMaskForTCRIT Property

IRD

Lm95245ConfigurationDiodeFaultMaskForTCRIT Property

Configuration: Diode Fault Mask for T_CRIT

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeConfigurationOnOff ConfigurationDiodeFaultMaskForTCRIT { get; set; }
Public Property ConfigurationDiodeFaultMaskForTCRIT As Lm95245TypeConfigurationOnOff
    Get
    Set
public:
property Lm95245TypeConfigurationOnOff ConfigurationDiodeFaultMaskForTCRIT {
    Lm95245TypeConfigurationOnOff get ();
    void set (Lm95245TypeConfigurationOnOff value);
}
member ConfigurationDiodeFaultMaskForTCRIT : Lm95245TypeConfigurationOnOff with get, set

Property Value

Type: Lm95245TypeConfigurationOnOff
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.ConfigurationLocalOSMask0x03 Property

IRD

Lm95245ConfigurationLocalOSMask0x03 Property

Configuration: Local OS Mask [0x03]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeConfigurationOnOff ConfigurationLocalOSMask0x03 { get; set; }
Public Property ConfigurationLocalOSMask0x03 As Lm95245TypeConfigurationOnOff
    Get
    Set
public:
property Lm95245TypeConfigurationOnOff ConfigurationLocalOSMask0x03 {
    Lm95245TypeConfigurationOnOff get ();
    void set (Lm95245TypeConfigurationOnOff value);
}
member ConfigurationLocalOSMask0x03 : Lm95245TypeConfigurationOnOff with get, set

Property Value

Type: Lm95245TypeConfigurationOnOff
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.ConfigurationLocalOSMask0x09 Property

IRD

Lm95245ConfigurationLocalOSMask0x09 Property

Configuration: Local OS Mask [0x09]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeConfigurationOnOff ConfigurationLocalOSMask0x09 { get; set; }
Public Property ConfigurationLocalOSMask0x09 As Lm95245TypeConfigurationOnOff
    Get
    Set
public:
property Lm95245TypeConfigurationOnOff ConfigurationLocalOSMask0x09 {
    Lm95245TypeConfigurationOnOff get ();
    void set (Lm95245TypeConfigurationOnOff value);
}
member ConfigurationLocalOSMask0x09 : Lm95245TypeConfigurationOnOff with get, set

Property Value

Type: Lm95245TypeConfigurationOnOff
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.ConfigurationLocalTCRITMask0x03 Property

IRD

Lm95245ConfigurationLocalTCRITMask0x03 Property

Configuration: Local T_CRIT Mask [0x03]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeConfigurationOnOff ConfigurationLocalTCRITMask0x03 { get; set; }
Public Property ConfigurationLocalTCRITMask0x03 As Lm95245TypeConfigurationOnOff
    Get
    Set
public:
property Lm95245TypeConfigurationOnOff ConfigurationLocalTCRITMask0x03 {
    Lm95245TypeConfigurationOnOff get ();
    void set (Lm95245TypeConfigurationOnOff value);
}
member ConfigurationLocalTCRITMask0x03 : Lm95245TypeConfigurationOnOff with get, set

Property Value

Type: Lm95245TypeConfigurationOnOff
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.ConfigurationLocalTCRITMask0x09 Property

IRD

Lm95245ConfigurationLocalTCRITMask0x09 Property

Configuration: Local T_CRIT Mask [0x09]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeConfigurationOnOff ConfigurationLocalTCRITMask0x09 { get; set; }
Public Property ConfigurationLocalTCRITMask0x09 As Lm95245TypeConfigurationOnOff
    Get
    Set
public:
property Lm95245TypeConfigurationOnOff ConfigurationLocalTCRITMask0x09 {
    Lm95245TypeConfigurationOnOff get ();
    void set (Lm95245TypeConfigurationOnOff value);
}
member ConfigurationLocalTCRITMask0x09 : Lm95245TypeConfigurationOnOff with get, set

Property Value

Type: Lm95245TypeConfigurationOnOff
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.ConfigurationOSA0FunctionSelect Property

IRD

Lm95245ConfigurationOSA0FunctionSelect Property

Configuration: OS/A0 Function Select

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeConfigurationOsA0FunctionSelect ConfigurationOSA0FunctionSelect { get; set; }
Public Property ConfigurationOSA0FunctionSelect As Lm95245TypeConfigurationOsA0FunctionSelect
    Get
    Set
public:
property Lm95245TypeConfigurationOsA0FunctionSelect ConfigurationOSA0FunctionSelect {
    Lm95245TypeConfigurationOsA0FunctionSelect get ();
    void set (Lm95245TypeConfigurationOsA0FunctionSelect value);
}
member ConfigurationOSA0FunctionSelect : Lm95245TypeConfigurationOsA0FunctionSelect with get, set

Property Value

Type: Lm95245TypeConfigurationOsA0FunctionSelect
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.ConfigurationRemoteDiodeTruThermModeSelect Property

IRD

Lm95245ConfigurationRemoteDiodeTruThermModeSelect Property

Configuration: Remote Diode TruTherm Mode Select

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeConfigurationRemoteDiodeTruthermModeSelect ConfigurationRemoteDiodeTruThermModeSelect { get; set; }
Public Property ConfigurationRemoteDiodeTruThermModeSelect As Lm95245TypeConfigurationRemoteDiodeTruthermModeSelect
    Get
    Set
public:
property Lm95245TypeConfigurationRemoteDiodeTruthermModeSelect ConfigurationRemoteDiodeTruThermModeSelect {
    Lm95245TypeConfigurationRemoteDiodeTruthermModeSelect get ();
    void set (Lm95245TypeConfigurationRemoteDiodeTruthermModeSelect value);
}
member ConfigurationRemoteDiodeTruThermModeSelect : Lm95245TypeConfigurationRemoteDiodeTruthermModeSelect with get, set

Property Value

Type: Lm95245TypeConfigurationRemoteDiodeTruthermModeSelect
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.ConfigurationRemoteFilterEnable Property

IRD

Lm95245ConfigurationRemoteFilterEnable Property

Configuration: Remote Filter Enable

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeConfigurationRemoteFilterEnable ConfigurationRemoteFilterEnable { get; set; }
Public Property ConfigurationRemoteFilterEnable As Lm95245TypeConfigurationRemoteFilterEnable
    Get
    Set
public:
property Lm95245TypeConfigurationRemoteFilterEnable ConfigurationRemoteFilterEnable {
    Lm95245TypeConfigurationRemoteFilterEnable get ();
    void set (Lm95245TypeConfigurationRemoteFilterEnable value);
}
member ConfigurationRemoteFilterEnable : Lm95245TypeConfigurationRemoteFilterEnable with get, set

Property Value

Type: Lm95245TypeConfigurationRemoteFilterEnable
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.ConfigurationRemoteOSMask0x03 Property

IRD

Lm95245ConfigurationRemoteOSMask0x03 Property

Configuration: Remote OS Mask [0x03]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeConfigurationOnOff ConfigurationRemoteOSMask0x03 { get; set; }
Public Property ConfigurationRemoteOSMask0x03 As Lm95245TypeConfigurationOnOff
    Get
    Set
public:
property Lm95245TypeConfigurationOnOff ConfigurationRemoteOSMask0x03 {
    Lm95245TypeConfigurationOnOff get ();
    void set (Lm95245TypeConfigurationOnOff value);
}
member ConfigurationRemoteOSMask0x03 : Lm95245TypeConfigurationOnOff with get, set

Property Value

Type: Lm95245TypeConfigurationOnOff
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.ConfigurationRemoteOSMask0x09 Property

IRD

Lm95245ConfigurationRemoteOSMask0x09 Property

Configuration: Remote OS Mask [0x09]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeConfigurationOnOff ConfigurationRemoteOSMask0x09 { get; set; }
Public Property ConfigurationRemoteOSMask0x09 As Lm95245TypeConfigurationOnOff
    Get
    Set
public:
property Lm95245TypeConfigurationOnOff ConfigurationRemoteOSMask0x09 {
    Lm95245TypeConfigurationOnOff get ();
    void set (Lm95245TypeConfigurationOnOff value);
}
member ConfigurationRemoteOSMask0x09 : Lm95245TypeConfigurationOnOff with get, set

Property Value

Type: Lm95245TypeConfigurationOnOff
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.ConfigurationRemoteTCRITMask0x03 Property

IRD

Lm95245ConfigurationRemoteTCRITMask0x03 Property

Configuration: Remote T_CRIT Mask [0x03]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeConfigurationOnOff ConfigurationRemoteTCRITMask0x03 { get; set; }
Public Property ConfigurationRemoteTCRITMask0x03 As Lm95245TypeConfigurationOnOff
    Get
    Set
public:
property Lm95245TypeConfigurationOnOff ConfigurationRemoteTCRITMask0x03 {
    Lm95245TypeConfigurationOnOff get ();
    void set (Lm95245TypeConfigurationOnOff value);
}
member ConfigurationRemoteTCRITMask0x03 : Lm95245TypeConfigurationOnOff with get, set

Property Value

Type: Lm95245TypeConfigurationOnOff
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.ConfigurationRemoteTCRITMask0x09 Property

IRD

Lm95245ConfigurationRemoteTCRITMask0x09 Property

Configuration: Remote T_CRIT Mask [0x09]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeConfigurationOnOff ConfigurationRemoteTCRITMask0x09 { get; set; }
Public Property ConfigurationRemoteTCRITMask0x09 As Lm95245TypeConfigurationOnOff
    Get
    Set
public:
property Lm95245TypeConfigurationOnOff ConfigurationRemoteTCRITMask0x09 {
    Lm95245TypeConfigurationOnOff get ();
    void set (Lm95245TypeConfigurationOnOff value);
}
member ConfigurationRemoteTCRITMask0x09 : Lm95245TypeConfigurationOnOff with get, set

Property Value

Type: Lm95245TypeConfigurationOnOff
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.ConfigurationSTOPRUN0x03 Property

IRD

Lm95245ConfigurationSTOPRUN0x03 Property

Configuration: STOP/RUN [0x03]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeConfigurationStopRun ConfigurationSTOPRUN0x03 { get; set; }
Public Property ConfigurationSTOPRUN0x03 As Lm95245TypeConfigurationStopRun
    Get
    Set
public:
property Lm95245TypeConfigurationStopRun ConfigurationSTOPRUN0x03 {
    Lm95245TypeConfigurationStopRun get ();
    void set (Lm95245TypeConfigurationStopRun value);
}
member ConfigurationSTOPRUN0x03 : Lm95245TypeConfigurationStopRun with get, set

Property Value

Type: Lm95245TypeConfigurationStopRun
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.ConfigurationSTOPRUN0x09 Property

IRD

Lm95245ConfigurationSTOPRUN0x09 Property

Configuration: STOP/RUN [0x09]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeConfigurationStopRun ConfigurationSTOPRUN0x09 { get; set; }
Public Property ConfigurationSTOPRUN0x09 As Lm95245TypeConfigurationStopRun
    Get
    Set
public:
property Lm95245TypeConfigurationStopRun ConfigurationSTOPRUN0x09 {
    Lm95245TypeConfigurationStopRun get ();
    void set (Lm95245TypeConfigurationStopRun value);
}
member ConfigurationSTOPRUN0x09 : Lm95245TypeConfigurationStopRun with get, set

Property Value

Type: Lm95245TypeConfigurationStopRun
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.ConversionRate0x04 Property

IRD

Lm95245ConversionRate0x04 Property

Conversion Rate [0x04]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeConversionRate ConversionRate0x04 { get; set; }
Public Property ConversionRate0x04 As Lm95245TypeConversionRate
    Get
    Set
public:
property Lm95245TypeConversionRate ConversionRate0x04 {
    Lm95245TypeConversionRate get ();
    void set (Lm95245TypeConversionRate value);
}
member ConversionRate0x04 : Lm95245TypeConversionRate with get, set

Property Value

Type: Lm95245TypeConversionRate
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.ConversionRate0x0a Property

IRD

Lm95245ConversionRate0x0a Property

Conversion Rate [0x0a]

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeConversionRate ConversionRate0x0a { get; set; }
Public Property ConversionRate0x0a As Lm95245TypeConversionRate
    Get
    Set
public:
property Lm95245TypeConversionRate ConversionRate0x0a {
    Lm95245TypeConversionRate get ();
    void set (Lm95245TypeConversionRate value);
}
member ConversionRate0x0a : Lm95245TypeConversionRate with get, set

Property Value

Type: Lm95245TypeConversionRate
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.LocalSharedOSTCRITLimit Property

IRD

Lm95245LocalSharedOSTCRITLimit Property

Local Shared OS / T_CRIT Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LocalSharedOSTCRITLimit { get; set; }
Public Property LocalSharedOSTCRITLimit As Byte
    Get
    Set
public:
property unsigned char LocalSharedOSTCRITLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member LocalSharedOSTCRITLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.LocalTemperature Property

IRD

Lm95245LocalTemperature Property

Local Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LocalTemperature { get; }
Public ReadOnly Property LocalTemperature As Double
    Get
public:
property double LocalTemperature {
    double get ();
}
member LocalTemperature : float with get

Property Value

Type: Double
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.ManufacturerID Property

IRD

Lm95245ManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As Byte
    Get
public:
property unsigned char ManufacturerID {
    unsigned char get ();
}
member ManufacturerID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.RemoteOffset Property

IRD

Lm95245RemoteOffset Property

Remote Offset (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteOffset { get; set; }
Public Property RemoteOffset As Double
    Get
    Set
public:
property double RemoteOffset {
    double get ();
    void set (double value);
}
member RemoteOffset : float with get, set

Property Value

Type: Double
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.RemoteOSLimit0x07 Property

IRD

Lm95245RemoteOSLimit0x07 Property

Remote OS Limit [0x07] (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RemoteOSLimit0x07 { get; set; }
Public Property RemoteOSLimit0x07 As Byte
    Get
    Set
public:
property unsigned char RemoteOSLimit0x07 {
    unsigned char get ();
    void set (unsigned char value);
}
member RemoteOSLimit0x07 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.RemoteOSLimit0x0d Property

IRD

Lm95245RemoteOSLimit0x0d Property

Remote OS Limit [0x0d] (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RemoteOSLimit0x0d { get; set; }
Public Property RemoteOSLimit0x0d As Byte
    Get
    Set
public:
property unsigned char RemoteOSLimit0x0d {
    unsigned char get ();
    void set (unsigned char value);
}
member RemoteOSLimit0x0d : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.RemoteTCRITLimit Property

IRD

Lm95245RemoteTCRITLimit Property

Remote T_CRIT Limit (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RemoteTCRITLimit { get; set; }
Public Property RemoteTCRITLimit As Byte
    Get
    Set
public:
property unsigned char RemoteTCRITLimit {
    unsigned char get ();
    void set (unsigned char value);
}
member RemoteTCRITLimit : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.RemoteTemperatureSigned Property

IRD

Lm95245RemoteTemperatureSigned Property

Remote Temperature - Signed (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperatureSigned { get; }
Public ReadOnly Property RemoteTemperatureSigned As Double
    Get
public:
property double RemoteTemperatureSigned {
    double get ();
}
member RemoteTemperatureSigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.RemoteTemperatureUnsigned Property

IRD

Lm95245RemoteTemperatureUnsigned Property

Remote Temperature - Unsigned (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperatureUnsigned { get; }
Public ReadOnly Property RemoteTemperatureUnsigned As Double
    Get
public:
property double RemoteTemperatureUnsigned {
    double get ();
}
member RemoteTemperatureUnsigned : float with get

Property Value

Type: Double
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.RevisionID Property

IRD

Lm95245RevisionID Property

Revision ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RevisionID { get; }
Public ReadOnly Property RevisionID As Byte
    Get
public:
property unsigned char RevisionID {
    unsigned char get ();
}
member RevisionID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.StatusBusy Property

IRD

Lm95245StatusBusy Property

Status: Busy

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeStatusBusy StatusBusy { get; }
Public ReadOnly Property StatusBusy As Lm95245TypeStatusBusy
    Get
public:
property Lm95245TypeStatusBusy StatusBusy {
    Lm95245TypeStatusBusy get ();
}
member StatusBusy : Lm95245TypeStatusBusy with get

Property Value

Type: Lm95245TypeStatusBusy
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.StatusDiodeFault Property

IRD

Lm95245StatusDiodeFault Property

Status: Diode Fault

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeStatusTriggered StatusDiodeFault { get; }
Public ReadOnly Property StatusDiodeFault As Lm95245TypeStatusTriggered
    Get
public:
property Lm95245TypeStatusTriggered StatusDiodeFault {
    Lm95245TypeStatusTriggered get ();
}
member StatusDiodeFault : Lm95245TypeStatusTriggered with get

Property Value

Type: Lm95245TypeStatusTriggered
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.StatusLocalOSTCRIT Property

IRD

Lm95245StatusLocalOSTCRIT Property

Status: Local OS / T_CRIT

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeStatusTriggered StatusLocalOSTCRIT { get; }
Public ReadOnly Property StatusLocalOSTCRIT As Lm95245TypeStatusTriggered
    Get
public:
property Lm95245TypeStatusTriggered StatusLocalOSTCRIT {
    Lm95245TypeStatusTriggered get ();
}
member StatusLocalOSTCRIT : Lm95245TypeStatusTriggered with get

Property Value

Type: Lm95245TypeStatusTriggered
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.StatusNotReady Property

IRD

Lm95245StatusNotReady Property

Status: Not Ready

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeStatusNotReady StatusNotReady { get; }
Public ReadOnly Property StatusNotReady As Lm95245TypeStatusNotReady
    Get
public:
property Lm95245TypeStatusNotReady StatusNotReady {
    Lm95245TypeStatusNotReady get ();
}
member StatusNotReady : Lm95245TypeStatusNotReady with get

Property Value

Type: Lm95245TypeStatusNotReady
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.StatusRemoteOS Property

IRD

Lm95245StatusRemoteOS Property

Status: Remote OS

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeStatusTriggered StatusRemoteOS { get; }
Public ReadOnly Property StatusRemoteOS As Lm95245TypeStatusTriggered
    Get
public:
property Lm95245TypeStatusTriggered StatusRemoteOS {
    Lm95245TypeStatusTriggered get ();
}
member StatusRemoteOS : Lm95245TypeStatusTriggered with get

Property Value

Type: Lm95245TypeStatusTriggered
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.StatusRemoteTCRIT Property

IRD

Lm95245StatusRemoteTCRIT Property

Status: Remote T_CRIT

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeStatusTriggered StatusRemoteTCRIT { get; }
Public ReadOnly Property StatusRemoteTCRIT As Lm95245TypeStatusTriggered
    Get
public:
property Lm95245TypeStatusTriggered StatusRemoteTCRIT {
    Lm95245TypeStatusTriggered get ();
}
member StatusRemoteTCRIT : Lm95245TypeStatusTriggered with get

Property Value

Type: Lm95245TypeStatusTriggered
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.StatusTruTherm3904Detect Property

IRD

Lm95245StatusTruTherm3904Detect Property

Status: TruTherm 3904 Detect

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm95245TypeStatusTrutherm3904Detect StatusTruTherm3904Detect { get; }
Public ReadOnly Property StatusTruTherm3904Detect As Lm95245TypeStatusTrutherm3904Detect
    Get
public:
property Lm95245TypeStatusTrutherm3904Detect StatusTruTherm3904Detect {
    Lm95245TypeStatusTrutherm3904Detect get ();
}
member StatusTruTherm3904Detect : Lm95245TypeStatusTrutherm3904Detect with get

Property Value

Type: Lm95245TypeStatusTrutherm3904Detect
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245 Methods

The Lm95245 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One-Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.Flush Method

IRD

Lm95245Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.OneShot Method

IRD

Lm95245OneShot Method

One-Shot

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void OneShot()
Public Sub OneShot
public:
void OneShot()
member OneShot : unit -> unit
See Also

Reference

Lm95245 Class
telos.Ird.NationalSemiconductor Namespace


Lm95245.TypeConfigurationOnOff Enumeration

IRD

Lm95245TypeConfigurationOnOff Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationOnOff
Public Enumeration TypeConfigurationOnOff
public enum class TypeConfigurationOnOff
type TypeConfigurationOnOff
Members
Member name | Value | Description
Off | 0 | Off
On | 1 | On
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95245.TypeConfigurationOsA0FunctionSelect Enumeration

IRD

Lm95245TypeConfigurationOsA0FunctionSelect Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationOsA0FunctionSelect
Public Enumeration TypeConfigurationOsA0FunctionSelect
public enum class TypeConfigurationOsA0FunctionSelect
type TypeConfigurationOsA0FunctionSelect
Members
Member name | Value | Description
AddressA0FunctionEnabled | 0 | Address (A0) Function Enabled
OverTemperatureShutdownOSEnabled | 1 | Over-Temperature Shutdown (OS) Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95245.TypeConfigurationRemoteDiodeTruthermModeSelect Enumeration

IRD

Lm95245TypeConfigurationRemoteDiodeTruthermModeSelect Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationRemoteDiodeTruthermModeSelect
Public Enumeration TypeConfigurationRemoteDiodeTruthermModeSelect
public enum class TypeConfigurationRemoteDiodeTruthermModeSelect
type TypeConfigurationRemoteDiodeTruthermModeSelect
Members
Member name | Value | Description
DiodeModel2MMBT3904 | 0 | Diode Model 2, MMBT3904
DiodeModel1IntelProcessor | 1 | Diode Model 1, Intel Processor
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95245.TypeConfigurationRemoteFilterEnable Enumeration

IRD

Lm95245TypeConfigurationRemoteFilterEnable Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationRemoteFilterEnable
Public Enumeration TypeConfigurationRemoteFilterEnable
public enum class TypeConfigurationRemoteFilterEnable
type TypeConfigurationRemoteFilterEnable
Members
Member name | Value | Description
Disable | 0 | Disable
Reserved | 1 | Reserved
Enable | 3 | Enable
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95245.TypeConfigurationStopRun Enumeration

IRD

Lm95245TypeConfigurationStopRun Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationStopRun
Public Enumeration TypeConfigurationStopRun
public enum class TypeConfigurationStopRun
type TypeConfigurationStopRun
Members
Member name | Value | Description
ActiveConverting | 0 | Active/Converting
Standby | 1 | Standby
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95245.TypeConversionRate Enumeration

IRD

Lm95245TypeConversionRate Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConversionRate
Public Enumeration TypeConversionRate
public enum class TypeConversionRate
type TypeConversionRate
Members
Member name | Value | Description
Continuous | 0 | Continuous
Value_0364S | 1 | 0.364 s
Value_1S | 2 | 1 s
Value_25S | 3 | 2.5 s
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95245.TypeStatusBusy Enumeration

IRD

Lm95245TypeStatusBusy Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusBusy
Public Enumeration TypeStatusBusy
public enum class TypeStatusBusy
type TypeStatusBusy
Members
Member name | Value | Description
NotConverting | 0 | Not Converting
Converting | 1 | Converting
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95245.TypeStatusNotReady Enumeration

IRD

Lm95245TypeStatusNotReady Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusNotReady
Public Enumeration TypeStatusNotReady
public enum class TypeStatusNotReady
type TypeStatusNotReady
Members
Member name | Value | Description
Ready | 0 | Ready
NotReady | 1 | Not Ready
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95245.TypeStatusTriggered Enumeration

IRD

Lm95245TypeStatusTriggered Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusTriggered
Public Enumeration TypeStatusTriggered
public enum class TypeStatusTriggered
type TypeStatusTriggered
Members
Member name | Value | Description
NotTriggered | 0 | Not Triggered
Triggered | 1 | Triggered
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm95245.TypeStatusTrutherm3904Detect Enumeration

IRD

Lm95245TypeStatusTrutherm3904Detect Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusTrutherm3904Detect
Public Enumeration TypeStatusTrutherm3904Detect
public enum class TypeStatusTrutherm3904Detect
type TypeStatusTrutherm3904Detect
Members
Member name | Value | Description
MMBT3904ConnectedTruThermEnabled | 0 | MMBT3904 Connected / TruTherm Enabled
MMBT3904ConnectedTruThermDisabled | 1 | MMBT3904 Connected / TruTherm Disabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm99 Class

National Semiconductor: LM 99
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLm99

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm99
Public Class Lm99
public ref class Lm99
type Lm99 =  class end

The Lm99 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm99 | Constructor
Top
Properties
 | Name | Description
Public property | ALERTConfigure | ALERT Configure
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationALERTMask | Configuration: ALERT Mask
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationLocalTCRITAMask | Configuration: Local T_CRIT_A Mask
Public property | ConfigurationRemoteTCRITAMask | Configuration: Remote T_CRIT_A Mask
Public property | ConfigurationRUNSTOP | Configuration: RUN/STOP
Public property | ConversionRate | Conversion Rate
Public property | FilterLevel | Filter Level
Public property | LocalHIGHSetpoint | Local HIGH Setpoint (unit: °C)
Public property | LocalLOWSetpoint | Local LOW Setpoint (unit: °C)
Public property | LocalTCRITSetpoint | Local T_CRIT Setpoint (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerSID | Manufacturer's ID
Public property | RemoteHIGHSetpoint | Remote HIGH Setpoint (unit: °C)
Public property | RemoteLOWSetpoint | Remote LOW Setpoint (unit: °C)
Public property | RemoteTCRITSetpoint | Remote T_CRIT Setpoint (unit: °C)
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | RemoteTemperatureOffset | Remote Temperature Offset (unit: °C)
Public property | StatusBusy | Status: Busy
Public property | StatusLCRIT | Status: LCRIT
Public property | StatusLHIGH | Status: LHIGH
Public property | StatusLLOW | Status: LLOW
Public property | StatusOPEN | Status: OPEN
Public property | StatusRCRIT | Status: RCRIT
Public property | StatusRHIGH | Status: RHIGH
Public property | StatusRLOW | Status: RLOW
Public property | SteppingOrDieRevisionCode | Stepping Or Die Revision Code
Public property | TCRITHysteresis | T_CRIT Hysteresis (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
±1°C Accurate, High Temperature, Remote Diode Temperature Sensor with Two-Wire Interface
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm99 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm99(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm99(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm99

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99 Properties

The Lm99 type exposes the following members.

Properties
 | Name | Description
Public property | ALERTConfigure | ALERT Configure
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationALERTMask | Configuration: ALERT Mask
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationLocalTCRITAMask | Configuration: Local T_CRIT_A Mask
Public property | ConfigurationRemoteTCRITAMask | Configuration: Remote T_CRIT_A Mask
Public property | ConfigurationRUNSTOP | Configuration: RUN/STOP
Public property | ConversionRate | Conversion Rate
Public property | FilterLevel | Filter Level
Public property | LocalHIGHSetpoint | Local HIGH Setpoint (unit: °C)
Public property | LocalLOWSetpoint | Local LOW Setpoint (unit: °C)
Public property | LocalTCRITSetpoint | Local T_CRIT Setpoint (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerSID | Manufacturer's ID
Public property | RemoteHIGHSetpoint | Remote HIGH Setpoint (unit: °C)
Public property | RemoteLOWSetpoint | Remote LOW Setpoint (unit: °C)
Public property | RemoteTCRITSetpoint | Remote T_CRIT Setpoint (unit: °C)
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | RemoteTemperatureOffset | Remote Temperature Offset (unit: °C)
Public property | StatusBusy | Status: Busy
Public property | StatusLCRIT | Status: LCRIT
Public property | StatusLHIGH | Status: LHIGH
Public property | StatusLLOW | Status: LLOW
Public property | StatusOPEN | Status: OPEN
Public property | StatusRCRIT | Status: RCRIT
Public property | StatusRHIGH | Status: RHIGH
Public property | StatusRLOW | Status: RLOW
Public property | SteppingOrDieRevisionCode | Stepping Or Die Revision Code
Public property | TCRITHysteresis | T_CRIT Hysteresis (unit: °C)
Top
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.ALERTConfigure Property

IRD

Lm99ALERTConfigure Property

ALERT Configure

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm99TypeAlertConfigure ALERTConfigure { get; set; }
Public Property ALERTConfigure As Lm99TypeAlertConfigure
    Get
    Set
public:
property Lm99TypeAlertConfigure ALERTConfigure {
    Lm99TypeAlertConfigure get ();
    void set (Lm99TypeAlertConfigure value);
}
member ALERTConfigure : Lm99TypeAlertConfigure with get, set

Property Value

Type: Lm99TypeAlertConfigure
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.AutoFlush Property

IRD

Lm99AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.ConfigurationALERTMask Property

IRD

Lm99ConfigurationALERTMask Property

Configuration: ALERT Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm99TypeConfigurationAlertMask ConfigurationALERTMask { get; set; }
Public Property ConfigurationALERTMask As Lm99TypeConfigurationAlertMask
    Get
    Set
public:
property Lm99TypeConfigurationAlertMask ConfigurationALERTMask {
    Lm99TypeConfigurationAlertMask get ();
    void set (Lm99TypeConfigurationAlertMask value);
}
member ConfigurationALERTMask : Lm99TypeConfigurationAlertMask with get, set

Property Value

Type: Lm99TypeConfigurationAlertMask
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.ConfigurationFaultQueue Property

IRD

Lm99ConfigurationFaultQueue Property

Configuration: Fault Queue

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm99TypeConfigurationFaultQueue ConfigurationFaultQueue { get; set; }
Public Property ConfigurationFaultQueue As Lm99TypeConfigurationFaultQueue
    Get
    Set
public:
property Lm99TypeConfigurationFaultQueue ConfigurationFaultQueue {
    Lm99TypeConfigurationFaultQueue get ();
    void set (Lm99TypeConfigurationFaultQueue value);
}
member ConfigurationFaultQueue : Lm99TypeConfigurationFaultQueue with get, set

Property Value

Type: Lm99TypeConfigurationFaultQueue
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.ConfigurationLocalTCRITAMask Property

IRD

Lm99ConfigurationLocalTCRITAMask Property

Configuration: Local T_CRIT_A Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm99TypeConfigurationLocalTCritMask ConfigurationLocalTCRITAMask { get; set; }
Public Property ConfigurationLocalTCRITAMask As Lm99TypeConfigurationLocalTCritMask
    Get
    Set
public:
property Lm99TypeConfigurationLocalTCritMask ConfigurationLocalTCRITAMask {
    Lm99TypeConfigurationLocalTCritMask get ();
    void set (Lm99TypeConfigurationLocalTCritMask value);
}
member ConfigurationLocalTCRITAMask : Lm99TypeConfigurationLocalTCritMask with get, set

Property Value

Type: Lm99TypeConfigurationLocalTCritMask
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.ConfigurationRemoteTCRITAMask Property

IRD

Lm99ConfigurationRemoteTCRITAMask Property

Configuration: Remote T_CRIT_A Mask

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm99TypeConfigurationRemoteTCritMask ConfigurationRemoteTCRITAMask { get; set; }
Public Property ConfigurationRemoteTCRITAMask As Lm99TypeConfigurationRemoteTCritMask
    Get
    Set
public:
property Lm99TypeConfigurationRemoteTCritMask ConfigurationRemoteTCRITAMask {
    Lm99TypeConfigurationRemoteTCritMask get ();
    void set (Lm99TypeConfigurationRemoteTCritMask value);
}
member ConfigurationRemoteTCRITAMask : Lm99TypeConfigurationRemoteTCritMask with get, set

Property Value

Type: Lm99TypeConfigurationRemoteTCritMask
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.ConfigurationRUNSTOP Property

IRD

Lm99ConfigurationRUNSTOP Property

Configuration: RUN/STOP

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm99TypeConfigurationRunStop ConfigurationRUNSTOP { get; set; }
Public Property ConfigurationRUNSTOP As Lm99TypeConfigurationRunStop
    Get
    Set
public:
property Lm99TypeConfigurationRunStop ConfigurationRUNSTOP {
    Lm99TypeConfigurationRunStop get ();
    void set (Lm99TypeConfigurationRunStop value);
}
member ConfigurationRUNSTOP : Lm99TypeConfigurationRunStop with get, set

Property Value

Type: Lm99TypeConfigurationRunStop
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.ConversionRate Property

IRD

Lm99ConversionRate Property

Conversion Rate

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm99TypeConversionRate ConversionRate { get; set; }
Public Property ConversionRate As Lm99TypeConversionRate
    Get
    Set
public:
property Lm99TypeConversionRate ConversionRate {
    Lm99TypeConversionRate get ();
    void set (Lm99TypeConversionRate value);
}
member ConversionRate : Lm99TypeConversionRate with get, set

Property Value

Type: Lm99TypeConversionRate
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.FilterLevel Property

IRD

Lm99FilterLevel Property

Filter Level

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm99TypeFilterLevel FilterLevel { get; set; }
Public Property FilterLevel As Lm99TypeFilterLevel
    Get
    Set
public:
property Lm99TypeFilterLevel FilterLevel {
    Lm99TypeFilterLevel get ();
    void set (Lm99TypeFilterLevel value);
}
member FilterLevel : Lm99TypeFilterLevel with get, set

Property Value

Type: Lm99TypeFilterLevel
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.LocalHIGHSetpoint Property

IRD

Lm99LocalHIGHSetpoint Property

Local HIGH Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalHIGHSetpoint { get; set; }
Public Property LocalHIGHSetpoint As SByte
    Get
    Set
public:
property signed char LocalHIGHSetpoint {
    signed char get ();
    void set (signed char value);
}
member LocalHIGHSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.LocalLOWSetpoint Property

IRD

Lm99LocalLOWSetpoint Property

Local LOW Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalLOWSetpoint { get; set; }
Public Property LocalLOWSetpoint As SByte
    Get
    Set
public:
property signed char LocalLOWSetpoint {
    signed char get ();
    void set (signed char value);
}
member LocalLOWSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.LocalTCRITSetpoint Property

IRD

Lm99LocalTCRITSetpoint Property

Local T_CRIT Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTCRITSetpoint { get; set; }
Public Property LocalTCRITSetpoint As SByte
    Get
    Set
public:
property signed char LocalTCRITSetpoint {
    signed char get ();
    void set (signed char value);
}
member LocalTCRITSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.LocalTemperature Property

IRD

Lm99LocalTemperature Property

Local Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTemperature { get; }
Public ReadOnly Property LocalTemperature As SByte
    Get
public:
property signed char LocalTemperature {
    signed char get ();
}
member LocalTemperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.ManufacturerSID Property

IRD

Lm99ManufacturerSID Property

Manufacturer's ID

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerSID { get; }
Public ReadOnly Property ManufacturerSID As Byte
    Get
public:
property unsigned char ManufacturerSID {
    unsigned char get ();
}
member ManufacturerSID : byte with get

Property Value

Type: Byte
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.RemoteHIGHSetpoint Property

IRD

Lm99RemoteHIGHSetpoint Property

Remote HIGH Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteHIGHSetpoint { get; set; }
Public Property RemoteHIGHSetpoint As Double
    Get
    Set
public:
property double RemoteHIGHSetpoint {
    double get ();
    void set (double value);
}
member RemoteHIGHSetpoint : float with get, set

Property Value

Type: Double
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.RemoteLOWSetpoint Property

IRD

Lm99RemoteLOWSetpoint Property

Remote LOW Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteLOWSetpoint { get; set; }
Public Property RemoteLOWSetpoint As Double
    Get
    Set
public:
property double RemoteLOWSetpoint {
    double get ();
    void set (double value);
}
member RemoteLOWSetpoint : float with get, set

Property Value

Type: Double
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.RemoteTCRITSetpoint Property

IRD

Lm99RemoteTCRITSetpoint Property

Remote T_CRIT Setpoint (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTCRITSetpoint { get; set; }
Public Property RemoteTCRITSetpoint As SByte
    Get
    Set
public:
property signed char RemoteTCRITSetpoint {
    signed char get ();
    void set (signed char value);
}
member RemoteTCRITSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.RemoteTemperature Property

IRD

Lm99RemoteTemperature Property

Remote Temperature (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperature { get; }
Public ReadOnly Property RemoteTemperature As Double
    Get
public:
property double RemoteTemperature {
    double get ();
}
member RemoteTemperature : float with get

Property Value

Type: Double
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.RemoteTemperatureOffset Property

IRD

Lm99RemoteTemperatureOffset Property

Remote Temperature Offset (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperatureOffset { get; set; }
Public Property RemoteTemperatureOffset As Double
    Get
    Set
public:
property double RemoteTemperatureOffset {
    double get ();
    void set (double value);
}
member RemoteTemperatureOffset : float with get, set

Property Value

Type: Double
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.StatusBusy Property

IRD

Lm99StatusBusy Property

Status: Busy

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm99TypeStatusBusy StatusBusy { get; }
Public ReadOnly Property StatusBusy As Lm99TypeStatusBusy
    Get
public:
property Lm99TypeStatusBusy StatusBusy {
    Lm99TypeStatusBusy get ();
}
member StatusBusy : Lm99TypeStatusBusy with get

Property Value

Type: Lm99TypeStatusBusy
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.StatusLCRIT Property

IRD

Lm99StatusLCRIT Property

Status: LCRIT

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm99TypeStatusLcrit StatusLCRIT { get; }
Public ReadOnly Property StatusLCRIT As Lm99TypeStatusLcrit
    Get
public:
property Lm99TypeStatusLcrit StatusLCRIT {
    Lm99TypeStatusLcrit get ();
}
member StatusLCRIT : Lm99TypeStatusLcrit with get

Property Value

Type: Lm99TypeStatusLcrit
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.StatusLHIGH Property

IRD

Lm99StatusLHIGH Property

Status: LHIGH

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm99TypeStatusLhigh StatusLHIGH { get; }
Public ReadOnly Property StatusLHIGH As Lm99TypeStatusLhigh
    Get
public:
property Lm99TypeStatusLhigh StatusLHIGH {
    Lm99TypeStatusLhigh get ();
}
member StatusLHIGH : Lm99TypeStatusLhigh with get

Property Value

Type: Lm99TypeStatusLhigh
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.StatusLLOW Property

IRD

Lm99StatusLLOW Property

Status: LLOW

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm99TypeStatusLlow StatusLLOW { get; }
Public ReadOnly Property StatusLLOW As Lm99TypeStatusLlow
    Get
public:
property Lm99TypeStatusLlow StatusLLOW {
    Lm99TypeStatusLlow get ();
}
member StatusLLOW : Lm99TypeStatusLlow with get

Property Value

Type: Lm99TypeStatusLlow
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.StatusOPEN Property

IRD

Lm99StatusOPEN Property

Status: OPEN

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm99TypeStatusOpen StatusOPEN { get; }
Public ReadOnly Property StatusOPEN As Lm99TypeStatusOpen
    Get
public:
property Lm99TypeStatusOpen StatusOPEN {
    Lm99TypeStatusOpen get ();
}
member StatusOPEN : Lm99TypeStatusOpen with get

Property Value

Type: Lm99TypeStatusOpen
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.StatusRCRIT Property

IRD

Lm99StatusRCRIT Property

Status: RCRIT

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm99TypeStatusRcrit StatusRCRIT { get; }
Public ReadOnly Property StatusRCRIT As Lm99TypeStatusRcrit
    Get
public:
property Lm99TypeStatusRcrit StatusRCRIT {
    Lm99TypeStatusRcrit get ();
}
member StatusRCRIT : Lm99TypeStatusRcrit with get

Property Value

Type: Lm99TypeStatusRcrit
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.StatusRHIGH Property

IRD

Lm99StatusRHIGH Property

Status: RHIGH

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm99TypeStatusRhigh StatusRHIGH { get; }
Public ReadOnly Property StatusRHIGH As Lm99TypeStatusRhigh
    Get
public:
property Lm99TypeStatusRhigh StatusRHIGH {
    Lm99TypeStatusRhigh get ();
}
member StatusRHIGH : Lm99TypeStatusRhigh with get

Property Value

Type: Lm99TypeStatusRhigh
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.StatusRLOW Property

IRD

Lm99StatusRLOW Property

Status: RLOW

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm99TypeStatusRlow StatusRLOW { get; }
Public ReadOnly Property StatusRLOW As Lm99TypeStatusRlow
    Get
public:
property Lm99TypeStatusRlow StatusRLOW {
    Lm99TypeStatusRlow get ();
}
member StatusRLOW : Lm99TypeStatusRlow with get

Property Value

Type: Lm99TypeStatusRlow
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.SteppingOrDieRevisionCode Property

IRD

Lm99SteppingOrDieRevisionCode Property

Stepping Or Die Revision Code

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SteppingOrDieRevisionCode { get; }
Public ReadOnly Property SteppingOrDieRevisionCode As Byte
    Get
public:
property unsigned char SteppingOrDieRevisionCode {
    unsigned char get ();
}
member SteppingOrDieRevisionCode : byte with get

Property Value

Type: Byte
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.TCRITHysteresis Property

IRD

Lm99TCRITHysteresis Property

T_CRIT Hysteresis (unit: °C)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TCRITHysteresis { get; set; }
Public Property TCRITHysteresis As Byte
    Get
    Set
public:
property unsigned char TCRITHysteresis {
    unsigned char get ();
    void set (unsigned char value);
}
member TCRITHysteresis : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99 Methods

The Lm99 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShot | One Shot
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.Flush Method

IRD

Lm99Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.OneShot Method

IRD

Lm99OneShot Method

One Shot

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void OneShot()
Public Sub OneShot
public:
void OneShot()
member OneShot : unit -> unit
See Also

Reference

Lm99 Class
telos.Ird.NationalSemiconductor Namespace


Lm99.TypeAlertConfigure Enumeration

IRD

Lm99TypeAlertConfigure Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlertConfigure
Public Enumeration TypeAlertConfigure
public enum class TypeAlertConfigure
type TypeAlertConfigure
Members
Member name | Value | Description
ComparatorModeDisabled | 0 | Comparator Mode: Disabled
ComparatorModeEnabled | 1 | Comparator Mode: Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm99.TypeConfigurationAlertMask Enumeration

IRD

Lm99TypeConfigurationAlertMask Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationAlertMask
Public Enumeration TypeConfigurationAlertMask
public enum class TypeConfigurationAlertMask
type TypeConfigurationAlertMask
Members
Member name | Value | Description
ALERTInterruptsNotMasked | 0 | ALERT Interrupts: Not Masked
ALERTInterruptsMasked | 1 | ALERT Interrupts: Masked
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm99.TypeConfigurationFaultQueue Enumeration

IRD

Lm99TypeConfigurationFaultQueue Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationFaultQueue
Public Enumeration TypeConfigurationFaultQueue
public enum class TypeConfigurationFaultQueue
type TypeConfigurationFaultQueue
Members
Member name | Value | Description
OutsideLimitDoNoTrigger | 0 | Outside Limit: Do No Trigger
OutsideLimitTrigger | 1 | Outside Limit: Trigger
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm99.TypeConfigurationLocalTCritMask Enumeration

IRD

Lm99TypeConfigurationLocalTCritMask Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationLocalTCritMask
Public Enumeration TypeConfigurationLocalTCritMask
public enum class TypeConfigurationLocalTCritMask
type TypeConfigurationLocalTCritMask
Members
Member name | Value | Description
TCRITADoNotTrigger | 0 | T_CRIT_A: Do Not Trigger
TCRITATrigger | 1 | T_CRIT_A: Trigger
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm99.TypeConfigurationRemoteTCritMask Enumeration

IRD

Lm99TypeConfigurationRemoteTCritMask Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationRemoteTCritMask
Public Enumeration TypeConfigurationRemoteTCritMask
public enum class TypeConfigurationRemoteTCritMask
type TypeConfigurationRemoteTCritMask
Members
Member name | Value | Description
TCRITADoNotTrigger | 0 | T_CRIT_A: Do Not Trigger
TCRITATrigger | 1 | T_CRIT_A: Trigger
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm99.TypeConfigurationRunStop Enumeration

IRD

Lm99TypeConfigurationRunStop Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationRunStop
Public Enumeration TypeConfigurationRunStop
public enum class TypeConfigurationRunStop
type TypeConfigurationRunStop
Members
Member name | Value | Description
Running | 0 | Running
Shutdown | 1 | Shutdown
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm99.TypeConversionRate Enumeration

IRD

Lm99TypeConversionRate Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConversionRate
Public Enumeration TypeConversionRate
public enum class TypeConversionRate
type TypeConversionRate
Members
Member name | Value | Description
Value_625MHz | 0 | 62.5 mHz
Value_125MHz | 1 | 125 mHz
Value_250MHz | 2 | 250 mHz
Value_500MHz | 3 | 500 mHz
Value_1Hz | 4 | 1 Hz
Value_2Hz | 5 | 2 Hz
Value_4Hz | 6 | 4 Hz
Value_8Hz | 7 | 8 Hz
Value_16Hz | 8 | 16 Hz
Value_32Hz | 9 | 32 Hz
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm99.TypeFilterLevel Enumeration

IRD

Lm99TypeFilterLevel Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFilterLevel
Public Enumeration TypeFilterLevel
public enum class TypeFilterLevel
type TypeFilterLevel
Members
Member name | Value | Description
NoFilter | 0 | No Filter
Level1 | 1 | Level 1
Level2 | 2 | Level 2
Level3 | 3 | Level 3
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm99.TypeStatusBusy Enumeration

IRD

Lm99TypeStatusBusy Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusBusy
Public Enumeration TypeStatusBusy
public enum class TypeStatusBusy
type TypeStatusBusy
Members
Member name | Value | Description
ADCNotBusy | 0 | ADC: Not Busy
ADCBusy | 1 | ADC: Busy
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm99.TypeStatusLcrit Enumeration

IRD

Lm99TypeStatusLcrit Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusLcrit
Public Enumeration TypeStatusLcrit
public enum class TypeStatusLcrit
type TypeStatusLcrit
Members
Member name | Value | Description
LocalCriticalTemperatureNoAlarm | 0 | Local Critical Temperature: No Alarm
LocalCriticalTemperatureAlarm | 1 | Local Critical Temperature: Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm99.TypeStatusLhigh Enumeration

IRD

Lm99TypeStatusLhigh Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusLhigh
Public Enumeration TypeStatusLhigh
public enum class TypeStatusLhigh
type TypeStatusLhigh
Members
Member name | Value | Description
LocalHIGHTemperatureNoAlarm | 0 | Local HIGH Temperature: No Alarm
LocalHIGHTemperatureAlarm | 1 | Local HIGH Temperature: Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm99.TypeStatusLlow Enumeration

IRD

Lm99TypeStatusLlow Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusLlow
Public Enumeration TypeStatusLlow
public enum class TypeStatusLlow
type TypeStatusLlow
Members
Member name | Value | Description
LocalLOWTemperatureNoAlarm | 0 | Local LOW Temperature: No Alarm
LocalLOWTemperatureAlarm | 1 | Local LOW Temperature: Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm99.TypeStatusOpen Enumeration

IRD

Lm99TypeStatusOpen Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusOpen
Public Enumeration TypeStatusOpen
public enum class TypeStatusOpen
type TypeStatusOpen
Members
Member name | Value | Description
RemoteDiodeConnected | 0 | Remote Diode: Connected
RemoteDiodeDisconnected | 1 | Remote Diode: Disconnected
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm99.TypeStatusRcrit Enumeration

IRD

Lm99TypeStatusRcrit Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusRcrit
Public Enumeration TypeStatusRcrit
public enum class TypeStatusRcrit
type TypeStatusRcrit
Members
Member name | Value | Description
RemoteDiodeCriticalTemperatureNoAlarm | 0 | Remote Diode Critical Temperature: No Alarm
RemoteDiodeCriticalTemperatureAlarm | 1 | Remote Diode Critical Temperature: Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm99.TypeStatusRhigh Enumeration

IRD

Lm99TypeStatusRhigh Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusRhigh
Public Enumeration TypeStatusRhigh
public enum class TypeStatusRhigh
type TypeStatusRhigh
Members
Member name | Value | Description
RemoteDiodeHighTemperatureNoAlarm | 0 | Remote Diode High Temperature: No Alarm
RemoteDiodeHighTemperatureAlarm | 1 | Remote Diode High Temperature: Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lm99.TypeStatusRlow Enumeration

IRD

Lm99TypeStatusRlow Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusRlow
Public Enumeration TypeStatusRlow
public enum class TypeStatusRlow
type TypeStatusRlow
Members
Member name | Value | Description
RemoteDiodeLOWTemperatureNoAlarm | 0 | Remote Diode LOW Temperature: No Alarm
RemoteDiodeLOWTemperatureAlarm | 1 | Remote Diode LOW Temperature: Alarm
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1088 Class

National Semiconductor: LMV 1088
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLmv1088

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lmv1088
Public Class Lmv1088
public ref class Lmv1088
type Lmv1088 =  class end

The Lmv1088 type exposes the following members.

Constructors
 | Name | Description
Public method | Lmv1088 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Calibration | Calibration
Public property | EEPROML | EEPROM (L)
Public property | EEPROMM | EEPROM (M)
Public property | EEPROMQ | EEPROM (Q)
Public property | EPPROMN | EPPROM (N)
Public property | GainCompensationBetweenTheTwoMics300KHz | Gain Compensation Between The Two Mics (300 kHz) (unit: dB)
Public property | GainCompensationBetweenTheTwoMics3KHz | Gain Compensation Between The Two Mics (3 kHz) (unit: dB)
Public property | GainCompensationMicrophone1Channel | Gain Compensation Microphone 1 Channel (unit: dB)
Public property | GainCompensationMicrophone2Channel | Gain Compensation Microphone 2 Channel (unit: dB)
Public property | Microphone1 | Microphone 1
Public property | Microphone2 | Microphone 2
Public property | MicrophonePreamplifierGain | Microphone Preamplifier Gain (unit: dB)
Public property | MicrophoneSelect | Microphone Select
Public property | MuteMicrophone1 | Mute Microphone 1
Public property | MuteMicrophone2 | Mute Microphone 2
Public property | PostAmplifierGain | Post Amplifier Gain (unit: dB)
Public property | Ready | Ready
Public property | StoreBar | Store Bar
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Dual Input, Far Field Noise Suppression Microphone Amplifier with Automatic Calibration Ability
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1088 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1088(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lmv1088(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lmv1088

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088 Properties

The Lmv1088 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Calibration | Calibration
Public property | EEPROML | EEPROM (L)
Public property | EEPROMM | EEPROM (M)
Public property | EEPROMQ | EEPROM (Q)
Public property | EPPROMN | EPPROM (N)
Public property | GainCompensationBetweenTheTwoMics300KHz | Gain Compensation Between The Two Mics (300 kHz) (unit: dB)
Public property | GainCompensationBetweenTheTwoMics3KHz | Gain Compensation Between The Two Mics (3 kHz) (unit: dB)
Public property | GainCompensationMicrophone1Channel | Gain Compensation Microphone 1 Channel (unit: dB)
Public property | GainCompensationMicrophone2Channel | Gain Compensation Microphone 2 Channel (unit: dB)
Public property | Microphone1 | Microphone 1
Public property | Microphone2 | Microphone 2
Public property | MicrophonePreamplifierGain | Microphone Preamplifier Gain (unit: dB)
Public property | MicrophoneSelect | Microphone Select
Public property | MuteMicrophone1 | Mute Microphone 1
Public property | MuteMicrophone2 | Mute Microphone 2
Public property | PostAmplifierGain | Post Amplifier Gain (unit: dB)
Public property | Ready | Ready
Public property | StoreBar | Store Bar
Top
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.AutoFlush Property

IRD

Lmv1088AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.Calibration Property

IRD

Lmv1088Calibration Property

Calibration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1088TypeRStartCalibration Calibration { get; set; }
Public Property Calibration As Lmv1088TypeRStartCalibration
    Get
    Set
public:
property Lmv1088TypeRStartCalibration Calibration {
    Lmv1088TypeRStartCalibration get ();
    void set (Lmv1088TypeRStartCalibration value);
}
member Calibration : Lmv1088TypeRStartCalibration with get, set

Property Value

Type: Lmv1088TypeRStartCalibration
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.EEPROML Property

IRD

Lmv1088EEPROML Property

EEPROM (L)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EEPROML { get; }
Public ReadOnly Property EEPROML As Byte
    Get
public:
property unsigned char EEPROML {
    unsigned char get ();
}
member EEPROML : byte with get

Property Value

Type: Byte
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.EEPROMM Property

IRD

Lmv1088EEPROMM Property

EEPROM (M)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EEPROMM { get; }
Public ReadOnly Property EEPROMM As Byte
    Get
public:
property unsigned char EEPROMM {
    unsigned char get ();
}
member EEPROMM : byte with get

Property Value

Type: Byte
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.EEPROMQ Property

IRD

Lmv1088EEPROMQ Property

EEPROM (Q)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EEPROMQ { set; }
Public WriteOnly Property EEPROMQ As Byte
    Set
public:
property unsigned char EEPROMQ {
    void set (unsigned char value);
}
member EEPROMQ : byte with set

Property Value

Type: Byte
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.EPPROMN Property

IRD

Lmv1088EPPROMN Property

EPPROM (N)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EPPROMN { get; }
Public ReadOnly Property EPPROMN As Byte
    Get
public:
property unsigned char EPPROMN {
    unsigned char get ();
}
member EPPROMN : byte with get

Property Value

Type: Byte
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.GainCompensationBetweenTheTwoMics300KHz Property

IRD

Lmv1088GainCompensationBetweenTheTwoMics300KHz Property

Gain Compensation Between The Two Mics (300 kHz) (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1088TypeOGainCompensation GainCompensationBetweenTheTwoMics300KHz { get; set; }
Public Property GainCompensationBetweenTheTwoMics300KHz As Lmv1088TypeOGainCompensation
    Get
    Set
public:
property Lmv1088TypeOGainCompensation GainCompensationBetweenTheTwoMics300KHz {
    Lmv1088TypeOGainCompensation get ();
    void set (Lmv1088TypeOGainCompensation value);
}
member GainCompensationBetweenTheTwoMics300KHz : Lmv1088TypeOGainCompensation with get, set

Property Value

Type: Lmv1088TypeOGainCompensation
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.GainCompensationBetweenTheTwoMics3KHz Property

IRD

Lmv1088GainCompensationBetweenTheTwoMics3KHz Property

Gain Compensation Between The Two Mics (3 kHz) (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1088TypeOGainCompensation GainCompensationBetweenTheTwoMics3KHz { get; set; }
Public Property GainCompensationBetweenTheTwoMics3KHz As Lmv1088TypeOGainCompensation
    Get
    Set
public:
property Lmv1088TypeOGainCompensation GainCompensationBetweenTheTwoMics3KHz {
    Lmv1088TypeOGainCompensation get ();
    void set (Lmv1088TypeOGainCompensation value);
}
member GainCompensationBetweenTheTwoMics3KHz : Lmv1088TypeOGainCompensation with get, set

Property Value

Type: Lmv1088TypeOGainCompensation
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.GainCompensationMicrophone1Channel Property

IRD

Lmv1088GainCompensationMicrophone1Channel Property

Gain Compensation Microphone 1 Channel (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1088TypePGainCompensation GainCompensationMicrophone1Channel { get; set; }
Public Property GainCompensationMicrophone1Channel As Lmv1088TypePGainCompensation
    Get
    Set
public:
property Lmv1088TypePGainCompensation GainCompensationMicrophone1Channel {
    Lmv1088TypePGainCompensation get ();
    void set (Lmv1088TypePGainCompensation value);
}
member GainCompensationMicrophone1Channel : Lmv1088TypePGainCompensation with get, set

Property Value

Type: Lmv1088TypePGainCompensation
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.GainCompensationMicrophone2Channel Property

IRD

Lmv1088GainCompensationMicrophone2Channel Property

Gain Compensation Microphone 2 Channel (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1088TypePGainCompensation GainCompensationMicrophone2Channel { get; set; }
Public Property GainCompensationMicrophone2Channel As Lmv1088TypePGainCompensation
    Get
    Set
public:
property Lmv1088TypePGainCompensation GainCompensationMicrophone2Channel {
    Lmv1088TypePGainCompensation get ();
    void set (Lmv1088TypePGainCompensation value);
}
member GainCompensationMicrophone2Channel : Lmv1088TypePGainCompensation with get, set

Property Value

Type: Lmv1088TypePGainCompensation
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.Microphone1 Property

IRD

Lmv1088Microphone1 Property

Microphone 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1088TypeEnabledDisabled Microphone1 { get; set; }
Public Property Microphone1 As Lmv1088TypeEnabledDisabled
    Get
    Set
public:
property Lmv1088TypeEnabledDisabled Microphone1 {
    Lmv1088TypeEnabledDisabled get ();
    void set (Lmv1088TypeEnabledDisabled value);
}
member Microphone1 : Lmv1088TypeEnabledDisabled with get, set

Property Value

Type: Lmv1088TypeEnabledDisabled
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.Microphone2 Property

IRD

Lmv1088Microphone2 Property

Microphone 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1088TypeEnabledDisabled Microphone2 { get; set; }
Public Property Microphone2 As Lmv1088TypeEnabledDisabled
    Get
    Set
public:
property Lmv1088TypeEnabledDisabled Microphone2 {
    Lmv1088TypeEnabledDisabled get ();
    void set (Lmv1088TypeEnabledDisabled value);
}
member Microphone2 : Lmv1088TypeEnabledDisabled with get, set

Property Value

Type: Lmv1088TypeEnabledDisabled
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.MicrophonePreamplifierGain Property

IRD

Lmv1088MicrophonePreamplifierGain Property

Microphone Preamplifier Gain (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1088TypeAGain MicrophonePreamplifierGain { get; set; }
Public Property MicrophonePreamplifierGain As Lmv1088TypeAGain
    Get
    Set
public:
property Lmv1088TypeAGain MicrophonePreamplifierGain {
    Lmv1088TypeAGain get ();
    void set (Lmv1088TypeAGain value);
}
member MicrophonePreamplifierGain : Lmv1088TypeAGain with get, set

Property Value

Type: Lmv1088TypeAGain
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.MicrophoneSelect Property

IRD

Lmv1088MicrophoneSelect Property

Microphone Select

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1088TypeBMicSelect MicrophoneSelect { get; set; }
Public Property MicrophoneSelect As Lmv1088TypeBMicSelect
    Get
    Set
public:
property Lmv1088TypeBMicSelect MicrophoneSelect {
    Lmv1088TypeBMicSelect get ();
    void set (Lmv1088TypeBMicSelect value);
}
member MicrophoneSelect : Lmv1088TypeBMicSelect with get, set

Property Value

Type: Lmv1088TypeBMicSelect
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.MuteMicrophone1 Property

IRD

Lmv1088MuteMicrophone1 Property

Mute Microphone 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1088TypeAMute MuteMicrophone1 { get; set; }
Public Property MuteMicrophone1 As Lmv1088TypeAMute
    Get
    Set
public:
property Lmv1088TypeAMute MuteMicrophone1 {
    Lmv1088TypeAMute get ();
    void set (Lmv1088TypeAMute value);
}
member MuteMicrophone1 : Lmv1088TypeAMute with get, set

Property Value

Type: Lmv1088TypeAMute
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.MuteMicrophone2 Property

IRD

Lmv1088MuteMicrophone2 Property

Mute Microphone 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1088TypeAMute MuteMicrophone2 { get; set; }
Public Property MuteMicrophone2 As Lmv1088TypeAMute
    Get
    Set
public:
property Lmv1088TypeAMute MuteMicrophone2 {
    Lmv1088TypeAMute get ();
    void set (Lmv1088TypeAMute value);
}
member MuteMicrophone2 : Lmv1088TypeAMute with get, set

Property Value

Type: Lmv1088TypeAMute
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.PostAmplifierGain Property

IRD

Lmv1088PostAmplifierGain Property

Post Amplifier Gain (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1088TypeBGain PostAmplifierGain { get; set; }
Public Property PostAmplifierGain As Lmv1088TypeBGain
    Get
    Set
public:
property Lmv1088TypeBGain PostAmplifierGain {
    Lmv1088TypeBGain get ();
    void set (Lmv1088TypeBGain value);
}
member PostAmplifierGain : Lmv1088TypeBGain with get, set

Property Value

Type: Lmv1088TypeBGain
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.Ready Property

IRD

Lmv1088Ready Property

Ready

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1088TypeNReady Ready { get; }
Public ReadOnly Property Ready As Lmv1088TypeNReady
    Get
public:
property Lmv1088TypeNReady Ready {
    Lmv1088TypeNReady get ();
}
member Ready : Lmv1088TypeNReady with get

Property Value

Type: Lmv1088TypeNReady
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.StoreBar Property

IRD

Lmv1088StoreBar Property

Store Bar

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1088TypeQStoreBar StoreBar { get; set; }
Public Property StoreBar As Lmv1088TypeQStoreBar
    Get
    Set
public:
property Lmv1088TypeQStoreBar StoreBar {
    Lmv1088TypeQStoreBar get ();
    void set (Lmv1088TypeQStoreBar value);
}
member StoreBar : Lmv1088TypeQStoreBar with get, set

Property Value

Type: Lmv1088TypeQStoreBar
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088 Methods

The Lmv1088 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.Flush Method

IRD

Lmv1088Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lmv1088 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1088.TypeAGain Enumeration

IRD

Lmv1088TypeAGain Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAGain
Public Enumeration TypeAGain
public enum class TypeAGain
type TypeAGain
Members
Member name | Value | Description
Value_6 | 0 | 6
Value_8 | 1 | 8
Value_10 | 2 | 10
Value_12 | 3 | 12
Value_14 | 4 | 14
Value_16 | 5 | 16
Value_18 | 6 | 18
Value_20 | 7 | 20
Value_22 | 8 | 22
Value_24 | 9 | 24
Value_26 | 10 | 26
Value_28 | 11 | 28
Value_30 | 12 | 30
Value_32 | 13 | 32
Value_34 | 14 | 34
Value_36 | 15 | 36
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1088.TypeAMute Enumeration

IRD

Lmv1088TypeAMute Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAMute
Public Enumeration TypeAMute
public enum class TypeAMute
type TypeAMute
Members
Member name | Value | Description
On | 0 | On
Mute | 1 | Mute
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1088.TypeBGain Enumeration

IRD

Lmv1088TypeBGain Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBGain
Public Enumeration TypeBGain
public enum class TypeBGain
type TypeBGain
Members
Member name | Value | Description
Value_25PassTrough0NoiseCanceling | 0 | -2.5 (Pass Trough) / 0 (Noise Canceling)
Value_05PassTrough3NoiseCanceling | 1 | 0.5 (Pass Trough) / 3 (Noise Canceling)
Value_35PassTrough6NoiseCanceling | 2 | 3.5 (Pass Trough) / 6 (Noise Canceling)
Value_65PassTrough9NoiseCanceling | 3 | 6.5 (Pass Trough) / 9 (Noise Canceling)
Value_95PassTrough12NoiseCanceling | 4 | 9.5 (Pass Trough) / 12 (Noise Canceling)
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1088.TypeBMicSelect Enumeration

IRD

Lmv1088TypeBMicSelect Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBMicSelect
Public Enumeration TypeBMicSelect
public enum class TypeBMicSelect
type TypeBMicSelect
Members
Member name | Value | Description
NoiseCancellingMode | 0 | Noise Cancelling Mode
OnlyMicrophone1Enabled | 1 | Only Microphone 1 Enabled
OnlyMicrophone2Enabled | 2 | Only Microphone 2 Enabled
Microphone12Enabled | 3 | Microphone 1 + 2 Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1088.TypeEnabledDisabled Enumeration

IRD

Lmv1088TypeEnabledDisabled Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeEnabledDisabled
Public Enumeration TypeEnabledDisabled
public enum class TypeEnabledDisabled
type TypeEnabledDisabled
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1088.TypeNReady Enumeration

IRD

Lmv1088TypeNReady Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeNReady
Public Enumeration TypeNReady
public enum class TypeNReady
type TypeNReady
Members
Member name | Value | Description
ProgramCycleInProgress | 0 | Program Cycle In Progress
Ready | 1 | Ready
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1088.TypeOGainCompensation Enumeration

IRD

Lmv1088TypeOGainCompensation Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOGainCompensation
Public Enumeration TypeOGainCompensation
public enum class TypeOGainCompensation
type TypeOGainCompensation
Members
Member name | Value | Description
Value_0_0 | 0 | 0.0
Value_0_5 | 1 | 0.5
Value_1_0 | 2 | 1.0
Value_1_5 | 3 | 1.5
Value_2_0 | 4 | 2.0
Value_2_5 | 5 | 2.5
Value_3_0 | 6 | 3.0
NotUsed | 7 | Not Used
Value_M_0_5 | 9 | -0.5
Value_M_1_0 | 10 | -1.0
Value_M_1_5 | 11 | -1.5
Value_M_2_0 | 12 | -2.0
Value_M_2_5 | 13 | -2.5
Value_M_3_0 | 14 | -3.0
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1088.TypePGainCompensation Enumeration

IRD

Lmv1088TypePGainCompensation Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePGainCompensation
Public Enumeration TypePGainCompensation
public enum class TypePGainCompensation
type TypePGainCompensation
Members
Member name | Value | Description
Value_M_3_0 | 0 | -3.0
Value_M_2_5 | 2 | -2.5
Value_M_2_0 | 3 | -2.0
Value_M_1_5 | 4 | -1.5
Value_M_1_0 | 5 | -1.0
Value_M_0_5 | 6 | -0.5
Value_0_0 | 8 | 0.0
Value_0_5 | 9 | 0.5
Value_1_0 | 10 | 1.0
Value_1_5 | 11 | 1.5
Value_2_0 | 12 | 2.0
Value_2_5 | 13 | 2.5
Value_3_0 | 14 | 3.0
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1088.TypeQStoreBar Enumeration

IRD

Lmv1088TypeQStoreBar Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeQStoreBar
Public Enumeration TypeQStoreBar
public enum class TypeQStoreBar
type TypeQStoreBar
Members
Member name | Value | Description
EEPROMProgrammingEnabled | 0 | EEPROM Programming Enabled
DataClockIntoEEPROMRegister | 1 | Data Clock Into EEPROM Register
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1088.TypeRStartCalibration Enumeration

IRD

Lmv1088TypeRStartCalibration Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRStartCalibration
Public Enumeration TypeRStartCalibration
public enum class TypeRStartCalibration
type TypeRStartCalibration
Members
Member name | Value | Description
Idle | 0 | Idle
Calibration | 1 | Calibration
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1089 Class

National Semiconductor: LMV 1089
Inheritance Hierarchy
SystemObject
telos.Ird.NationalSemiconductorLmv1089

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lmv1089
Public Class Lmv1089
public ref class Lmv1089
type Lmv1089 =  class end

The Lmv1089 type exposes the following members.

Constructors
 | Name | Description
Public method | Lmv1089 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Calibration | Calibration
Public property | EEPROML | EEPROM (L)
Public property | EEPROMM | EEPROM (M)
Public property | EEPROMQ | EEPROM (Q)
Public property | EPPROMN | EPPROM (N)
Public property | GainCompensationBetweenTheTwoMics300KHz | Gain Compensation Between The Two Mics (300 kHz) (unit: dB)
Public property | GainCompensationBetweenTheTwoMics3KHz | Gain Compensation Between The Two Mics (3 kHz) (unit: dB)
Public property | GainCompensationLeftChannel | Gain Compensation Left Channel (unit: dB)
Public property | GainCompensationRightChannel | Gain Compensation Right Channel (unit: dB)
Public property | Microphone1 | Microphone 1
Public property | Microphone2 | Microphone 2
Public property | MicrophonePreamplifierGain | Microphone Preamplifier Gain (unit: dB)
Public property | MicrophoneSelect | Microphone Select
Public property | MuteMicrophone1 | Mute Microphone 1
Public property | MuteMicrophone2 | Mute Microphone 2
Public property | PostAmplifierGain | Post Amplifier Gain (unit: dB)
Public property | Ready | Ready
Public property | StoreBar | Store Bar
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Dual Input, Far Field Noise Suppression Microphone Amplifier with Automatic Calibration Capability
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1089 Constructor

Constructor

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1089(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lmv1089(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lmv1089

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089 Properties

The Lmv1089 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Calibration | Calibration
Public property | EEPROML | EEPROM (L)
Public property | EEPROMM | EEPROM (M)
Public property | EEPROMQ | EEPROM (Q)
Public property | EPPROMN | EPPROM (N)
Public property | GainCompensationBetweenTheTwoMics300KHz | Gain Compensation Between The Two Mics (300 kHz) (unit: dB)
Public property | GainCompensationBetweenTheTwoMics3KHz | Gain Compensation Between The Two Mics (3 kHz) (unit: dB)
Public property | GainCompensationLeftChannel | Gain Compensation Left Channel (unit: dB)
Public property | GainCompensationRightChannel | Gain Compensation Right Channel (unit: dB)
Public property | Microphone1 | Microphone 1
Public property | Microphone2 | Microphone 2
Public property | MicrophonePreamplifierGain | Microphone Preamplifier Gain (unit: dB)
Public property | MicrophoneSelect | Microphone Select
Public property | MuteMicrophone1 | Mute Microphone 1
Public property | MuteMicrophone2 | Mute Microphone 2
Public property | PostAmplifierGain | Post Amplifier Gain (unit: dB)
Public property | Ready | Ready
Public property | StoreBar | Store Bar
Top
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.AutoFlush Property

IRD

Lmv1089AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.Calibration Property

IRD

Lmv1089Calibration Property

Calibration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1089TypeRStartCalibration Calibration { get; set; }
Public Property Calibration As Lmv1089TypeRStartCalibration
    Get
    Set
public:
property Lmv1089TypeRStartCalibration Calibration {
    Lmv1089TypeRStartCalibration get ();
    void set (Lmv1089TypeRStartCalibration value);
}
member Calibration : Lmv1089TypeRStartCalibration with get, set

Property Value

Type: Lmv1089TypeRStartCalibration
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.EEPROML Property

IRD

Lmv1089EEPROML Property

EEPROM (L)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EEPROML { get; }
Public ReadOnly Property EEPROML As Byte
    Get
public:
property unsigned char EEPROML {
    unsigned char get ();
}
member EEPROML : byte with get

Property Value

Type: Byte
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.EEPROMM Property

IRD

Lmv1089EEPROMM Property

EEPROM (M)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EEPROMM { get; }
Public ReadOnly Property EEPROMM As Byte
    Get
public:
property unsigned char EEPROMM {
    unsigned char get ();
}
member EEPROMM : byte with get

Property Value

Type: Byte
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.EEPROMQ Property

IRD

Lmv1089EEPROMQ Property

EEPROM (Q)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EEPROMQ { set; }
Public WriteOnly Property EEPROMQ As Byte
    Set
public:
property unsigned char EEPROMQ {
    void set (unsigned char value);
}
member EEPROMQ : byte with set

Property Value

Type: Byte
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.EPPROMN Property

IRD

Lmv1089EPPROMN Property

EPPROM (N)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EPPROMN { get; }
Public ReadOnly Property EPPROMN As Byte
    Get
public:
property unsigned char EPPROMN {
    unsigned char get ();
}
member EPPROMN : byte with get

Property Value

Type: Byte
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.GainCompensationBetweenTheTwoMics300KHz Property

IRD

Lmv1089GainCompensationBetweenTheTwoMics300KHz Property

Gain Compensation Between The Two Mics (300 kHz) (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1089TypeOpGainCompensation GainCompensationBetweenTheTwoMics300KHz { get; set; }
Public Property GainCompensationBetweenTheTwoMics300KHz As Lmv1089TypeOpGainCompensation
    Get
    Set
public:
property Lmv1089TypeOpGainCompensation GainCompensationBetweenTheTwoMics300KHz {
    Lmv1089TypeOpGainCompensation get ();
    void set (Lmv1089TypeOpGainCompensation value);
}
member GainCompensationBetweenTheTwoMics300KHz : Lmv1089TypeOpGainCompensation with get, set

Property Value

Type: Lmv1089TypeOpGainCompensation
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.GainCompensationBetweenTheTwoMics3KHz Property

IRD

Lmv1089GainCompensationBetweenTheTwoMics3KHz Property

Gain Compensation Between The Two Mics (3 kHz) (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1089TypeOpGainCompensation GainCompensationBetweenTheTwoMics3KHz { get; set; }
Public Property GainCompensationBetweenTheTwoMics3KHz As Lmv1089TypeOpGainCompensation
    Get
    Set
public:
property Lmv1089TypeOpGainCompensation GainCompensationBetweenTheTwoMics3KHz {
    Lmv1089TypeOpGainCompensation get ();
    void set (Lmv1089TypeOpGainCompensation value);
}
member GainCompensationBetweenTheTwoMics3KHz : Lmv1089TypeOpGainCompensation with get, set

Property Value

Type: Lmv1089TypeOpGainCompensation
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.GainCompensationLeftChannel Property

IRD

Lmv1089GainCompensationLeftChannel Property

Gain Compensation Left Channel (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1089TypeOpGainCompensation GainCompensationLeftChannel { get; set; }
Public Property GainCompensationLeftChannel As Lmv1089TypeOpGainCompensation
    Get
    Set
public:
property Lmv1089TypeOpGainCompensation GainCompensationLeftChannel {
    Lmv1089TypeOpGainCompensation get ();
    void set (Lmv1089TypeOpGainCompensation value);
}
member GainCompensationLeftChannel : Lmv1089TypeOpGainCompensation with get, set

Property Value

Type: Lmv1089TypeOpGainCompensation
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.GainCompensationRightChannel Property

IRD

Lmv1089GainCompensationRightChannel Property

Gain Compensation Right Channel (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1089TypeOpGainCompensation GainCompensationRightChannel { get; set; }
Public Property GainCompensationRightChannel As Lmv1089TypeOpGainCompensation
    Get
    Set
public:
property Lmv1089TypeOpGainCompensation GainCompensationRightChannel {
    Lmv1089TypeOpGainCompensation get ();
    void set (Lmv1089TypeOpGainCompensation value);
}
member GainCompensationRightChannel : Lmv1089TypeOpGainCompensation with get, set

Property Value

Type: Lmv1089TypeOpGainCompensation
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.Microphone1 Property

IRD

Lmv1089Microphone1 Property

Microphone 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1089TypeEnabledDisabled Microphone1 { get; set; }
Public Property Microphone1 As Lmv1089TypeEnabledDisabled
    Get
    Set
public:
property Lmv1089TypeEnabledDisabled Microphone1 {
    Lmv1089TypeEnabledDisabled get ();
    void set (Lmv1089TypeEnabledDisabled value);
}
member Microphone1 : Lmv1089TypeEnabledDisabled with get, set

Property Value

Type: Lmv1089TypeEnabledDisabled
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.Microphone2 Property

IRD

Lmv1089Microphone2 Property

Microphone 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1089TypeEnabledDisabled Microphone2 { get; set; }
Public Property Microphone2 As Lmv1089TypeEnabledDisabled
    Get
    Set
public:
property Lmv1089TypeEnabledDisabled Microphone2 {
    Lmv1089TypeEnabledDisabled get ();
    void set (Lmv1089TypeEnabledDisabled value);
}
member Microphone2 : Lmv1089TypeEnabledDisabled with get, set

Property Value

Type: Lmv1089TypeEnabledDisabled
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.MicrophonePreamplifierGain Property

IRD

Lmv1089MicrophonePreamplifierGain Property

Microphone Preamplifier Gain (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1089TypeAGain MicrophonePreamplifierGain { get; set; }
Public Property MicrophonePreamplifierGain As Lmv1089TypeAGain
    Get
    Set
public:
property Lmv1089TypeAGain MicrophonePreamplifierGain {
    Lmv1089TypeAGain get ();
    void set (Lmv1089TypeAGain value);
}
member MicrophonePreamplifierGain : Lmv1089TypeAGain with get, set

Property Value

Type: Lmv1089TypeAGain
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.MicrophoneSelect Property

IRD

Lmv1089MicrophoneSelect Property

Microphone Select

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1089TypeBMicSelect MicrophoneSelect { get; set; }
Public Property MicrophoneSelect As Lmv1089TypeBMicSelect
    Get
    Set
public:
property Lmv1089TypeBMicSelect MicrophoneSelect {
    Lmv1089TypeBMicSelect get ();
    void set (Lmv1089TypeBMicSelect value);
}
member MicrophoneSelect : Lmv1089TypeBMicSelect with get, set

Property Value

Type: Lmv1089TypeBMicSelect
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.MuteMicrophone1 Property

IRD

Lmv1089MuteMicrophone1 Property

Mute Microphone 1

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1089TypeAMute MuteMicrophone1 { get; set; }
Public Property MuteMicrophone1 As Lmv1089TypeAMute
    Get
    Set
public:
property Lmv1089TypeAMute MuteMicrophone1 {
    Lmv1089TypeAMute get ();
    void set (Lmv1089TypeAMute value);
}
member MuteMicrophone1 : Lmv1089TypeAMute with get, set

Property Value

Type: Lmv1089TypeAMute
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.MuteMicrophone2 Property

IRD

Lmv1089MuteMicrophone2 Property

Mute Microphone 2

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1089TypeAMute MuteMicrophone2 { get; set; }
Public Property MuteMicrophone2 As Lmv1089TypeAMute
    Get
    Set
public:
property Lmv1089TypeAMute MuteMicrophone2 {
    Lmv1089TypeAMute get ();
    void set (Lmv1089TypeAMute value);
}
member MuteMicrophone2 : Lmv1089TypeAMute with get, set

Property Value

Type: Lmv1089TypeAMute
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.PostAmplifierGain Property

IRD

Lmv1089PostAmplifierGain Property

Post Amplifier Gain (unit: dB)

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1089TypeBGain PostAmplifierGain { get; set; }
Public Property PostAmplifierGain As Lmv1089TypeBGain
    Get
    Set
public:
property Lmv1089TypeBGain PostAmplifierGain {
    Lmv1089TypeBGain get ();
    void set (Lmv1089TypeBGain value);
}
member PostAmplifierGain : Lmv1089TypeBGain with get, set

Property Value

Type: Lmv1089TypeBGain
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.Ready Property

IRD

Lmv1089Ready Property

Ready

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1089TypeNReady Ready { get; }
Public ReadOnly Property Ready As Lmv1089TypeNReady
    Get
public:
property Lmv1089TypeNReady Ready {
    Lmv1089TypeNReady get ();
}
member Ready : Lmv1089TypeNReady with get

Property Value

Type: Lmv1089TypeNReady
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.StoreBar Property

IRD

Lmv1089StoreBar Property

Store Bar

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lmv1089TypeQStoreBar StoreBar { get; set; }
Public Property StoreBar As Lmv1089TypeQStoreBar
    Get
    Set
public:
property Lmv1089TypeQStoreBar StoreBar {
    Lmv1089TypeQStoreBar get ();
    void set (Lmv1089TypeQStoreBar value);
}
member StoreBar : Lmv1089TypeQStoreBar with get, set

Property Value

Type: Lmv1089TypeQStoreBar
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089 Methods

The Lmv1089 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.Flush Method

IRD

Lmv1089Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lmv1089 Class
telos.Ird.NationalSemiconductor Namespace


Lmv1089.TypeAGain Enumeration

IRD

Lmv1089TypeAGain Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAGain
Public Enumeration TypeAGain
public enum class TypeAGain
type TypeAGain
Members
Member name | Value | Description
Value_6 | 0 | 6
Value_8 | 1 | 8
Value_10 | 2 | 10
Value_12 | 3 | 12
Value_14 | 4 | 14
Value_16 | 5 | 16
Value_18 | 6 | 18
Value_20 | 7 | 20
Value_22 | 8 | 22
Value_24 | 9 | 24
Value_26 | 10 | 26
Value_28 | 11 | 28
Value_30 | 12 | 30
Value_32 | 13 | 32
Value_34 | 14 | 34
Value_36 | 15 | 36
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1089.TypeAMute Enumeration

IRD

Lmv1089TypeAMute Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAMute
Public Enumeration TypeAMute
public enum class TypeAMute
type TypeAMute
Members
Member name | Value | Description
On | 0 | On
Mute | 1 | Mute
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1089.TypeBGain Enumeration

IRD

Lmv1089TypeBGain Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBGain
Public Enumeration TypeBGain
public enum class TypeBGain
type TypeBGain
Members
Member name | Value | Description
Value_6 | 0 | 6
Value_9 | 1 | 9
Value_12 | 2 | 12
Value_15 | 3 | 15
Value_18 | 4 | 18
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1089.TypeBMicSelect Enumeration

IRD

Lmv1089TypeBMicSelect Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBMicSelect
Public Enumeration TypeBMicSelect
public enum class TypeBMicSelect
type TypeBMicSelect
Members
Member name | Value | Description
NoiseCancellingMode | 0 | Noise Cancelling Mode
OnlyMicrophone1Enabled | 1 | Only Microphone 1 Enabled
OnlyMicrophone2Enabled | 2 | Only Microphone 2 Enabled
Microphone12Enabled | 3 | Microphone 1 + 2 Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1089.TypeEnabledDisabled Enumeration

IRD

Lmv1089TypeEnabledDisabled Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeEnabledDisabled
Public Enumeration TypeEnabledDisabled
public enum class TypeEnabledDisabled
type TypeEnabledDisabled
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1089.TypeNReady Enumeration

IRD

Lmv1089TypeNReady Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeNReady
Public Enumeration TypeNReady
public enum class TypeNReady
type TypeNReady
Members
Member name | Value | Description
ProgramCycleInProgress | 0 | Program Cycle In Progress
Ready | 1 | Ready
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1089.TypeOpGainCompensation Enumeration

IRD

Lmv1089TypeOpGainCompensation Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOpGainCompensation
Public Enumeration TypeOpGainCompensation
public enum class TypeOpGainCompensation
type TypeOpGainCompensation
Members
Member name | Value | Description
Value_0_0 | 0 | 0.0
Value_0_5 | 1 | 0.5
Value_1_0 | 2 | 1.0
Value_1_5 | 3 | 1.5
Value_2_0 | 4 | 2.0
Value_2_5 | 5 | 2.5
Value_3_0 | 6 | 3.0
Value_0_0__1 | 8 | 0.0
Value_M_0_5 | 9 | -0.5
Value_M_1_0 | 10 | -1.0
Value_M_1_5 | 11 | -1.5
Value_M_2_0 | 12 | -2.0
Value_M_2_5 | 13 | -2.5
Value_M_3_0 | 14 | -3.0
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1089.TypeQStoreBar Enumeration

IRD

Lmv1089TypeQStoreBar Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeQStoreBar
Public Enumeration TypeQStoreBar
public enum class TypeQStoreBar
type TypeQStoreBar
Members
Member name | Value | Description
EEPROMProgrammingEnabled | 0 | EEPROM Programming Enabled
DataClockIntoEEPROMRegister | 1 | Data Clock Into EEPROM Register
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


Lmv1089.TypeRStartCalibration Enumeration

IRD

Lmv1089TypeRStartCalibration Enumeration

Namespace: telos.Ird.NationalSemiconductor
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRStartCalibration
Public Enumeration TypeRStartCalibration
public enum class TypeRStartCalibration
type TypeRStartCalibration
Members
Member name | Value | Description
Idle | 0 | Idle
Calibration | 1 | Calibration
See Also

Reference

telos.Ird.NationalSemiconductor Namespace


telos.Ird.NXPSemiconductors Namespace

Classes
 | Class | Description
Public class | Lm75a | NXP Semiconductors: LM 75A
Public class | Ne1617a | NXP Semiconductors: NE 1617A
Public class | Pca6408a | NXP Semiconductors: PCA 6408A
Public class | Pca6416a | NXP Semiconductors: PCA 6416A
Public class | Pca8550 | NXP Semiconductors: PCA 8550
Public class | Pca9502 | NXP Semiconductors: PCA 9502
Public class | Pca95059506 | NXP Semiconductors: PCA 9505 / 9506
Public class | Pca9530 | NXP Semiconductors: PCA 9530
Public class | Pca9531 | NXP Semiconductors: PCA 9531
Public class | Pca9532 | NXP Semiconductors: PCA 9532
Public class | Pca9533 | NXP Semiconductors: PCA 9533
Public class | Pca9534 | NXP Semiconductors: PCA 9534
Public class | Pca9535 | NXP Semiconductors: PCA 9535
Public class | Pca9536 | NXP Semiconductors: PCA 9536
Public class | Pca9537 | NXP Semiconductors: PCA 9537
Public class | Pca9538 | NXP Semiconductors: PCA 9538
Public class | Pca9539 | NXP Semiconductors: PCA 9539
Public class | Pca9540b | NXP Semiconductors: PCA 9540 B
Public class | Pca9542a | NXP Semiconductors: PCA 9542 A
Public class | Pca9543a | NXP Semiconductors: PCA 9543 A
Public class | Pca9543c | NXP Semiconductors: PCA 9543 C
Public class | Pca9544a | NXP Semiconductors: PCA 9544 A
Public class | Pca9545a | NXP Semiconductors: PCA 9545 A
Public class | Pca9545b | NXP Semiconductors: PCA 9545 A
Public class | Pca9545c | NXP Semiconductors: PCA 9545 C
Public class | Pca9546a | NXP Semiconductors: PCA 9546 A
Public class | Pca9547 | NXP Semiconductors: PCA 9547
Public class | Pca9548a | NXP Semiconductors: PCA 9548 A
Public class | Pca9549 | NXP Semiconductors: PCA 9549
Public class | Pca9550 | NXP Semiconductors: PCA 9550
Public class | Pca9551 | NXP Semiconductors: PCA 9551
Public class | Pca9552 | NXP Semiconductors: PCA 9552
Public class | Pca9553 | NXP Semiconductors: PCA 9553
Public class | Pca9559 | NXP Semiconductors: PCA 9559
Public class | Pca9629 | NXP Semiconductors: PCA 9629
Public class | Pca9685 | NXP Semiconductors: PCA 9685
Public class | Pca9698 | NXP Semiconductors: PCA 9698
Public class | Pcal6408a | NXP Semiconductors: PCAL 6408A
Public class | Pcal6416a | NXP Semiconductors: PCAL 6416A
Public class | Pcal9535a | NXP Semiconductors: PCAL 9535A
Public class | Pcal9538a | NXP Semiconductors: PCAL 9538A
Public class | Pcal9539a | NXP Semiconductors: PCAL 9539A
Public class | Pcal9555a | NXP Semiconductors: PCAL 9555A
Public class | Pcf85063a | NXP Semiconductors: PCF 85063A
Public class | Pcf85063tp | NXP Semiconductors: PCF 85063TP
Public class | Pct2075 | NXP Semiconductors: PCT 2075
Public class | Sa56004x | NXP Semiconductors: SA 56004X
Public class | Saa7118 | NXP Semiconductors: SAA 7118
Public class | Saa7119 | NXP Semiconductors: SAA 7119
Public class | Se95 | NXP Semiconductors: SE 95
Public class | Se97b | NXP Semiconductors: SE 97B (Temperature)
Public class | Se98a | NXP Semiconductors: SE 98A
Public class | Tda10046 | NXP Semiconductors: TDA 10046 AHT
Enumerations
 | Enumeration | Description
Public enumeration | Lm75aTypeOperationMode |
Public enumeration | Lm75aTypeOsFaultQueue |
Public enumeration | Lm75aTypeOsOperationModeSelection |
Public enumeration | Lm75aTypeOsPolaritySelection |
Public enumeration | Ne1617aTypeConfigurationMask |
Public enumeration | Ne1617aTypeConfigurationRunStop |
Public enumeration | Ne1617aTypeConversionRate |
Public enumeration | Ne1617aTypeStatusBusy |
Public enumeration | Ne1617aTypeStatusExternalTempHighLimit |
Public enumeration | Ne1617aTypeStatusExternalTempLowLimit |
Public enumeration | Ne1617aTypeStatusInternalTempHighLimit |
Public enumeration | Ne1617aTypeStatusInternalTempLowLimit |
Public enumeration | Ne1617aTypeStatusOpen |
Public enumeration | Pca6408aTypeConfiguration |
Public enumeration | Pca6408aTypeInversion |
Public enumeration | Pca6416aTypeConfiguration |
Public enumeration | Pca6416aTypeInversion |
Public enumeration | Pca9502TypeIocontrolIolatch |
Public enumeration | Pca9502TypeIocontrolSreset |
Public enumeration | Pca9502TypeIodir |
Public enumeration | Pca9502TypeIointena |
Public enumeration | Pca95059506TypeIoc |
Public enumeration | Pca95059506TypeMsk |
Public enumeration | Pca95059506TypePi |
Public enumeration | Pca9530TypeInput |
Public enumeration | Pca9530TypeLedSelector |
Public enumeration | Pca9531TypeInput |
Public enumeration | Pca9531TypeLedSelector |
Public enumeration | Pca9532TypeInput |
Public enumeration | Pca9532TypeLedSelector |
Public enumeration | Pca9533TypeInput |
Public enumeration | Pca9533TypeLedSelector |
Public enumeration | Pca9534TypeConfiguration |
Public enumeration | Pca9534TypePolarityInversion |
Public enumeration | Pca9535TypeConfiguration |
Public enumeration | Pca9535TypePolarityInversion |
Public enumeration | Pca9536TypeConfiguration |
Public enumeration | Pca9536TypePolarityInversion |
Public enumeration | Pca9537TypeConfiguration |
Public enumeration | Pca9537TypePolarityInversion |
Public enumeration | Pca9538TypeConfiguration |
Public enumeration | Pca9538TypePolarityInversion |
Public enumeration | Pca9539TypeConfiguration |
Public enumeration | Pca9539TypePolarityInversion |
Public enumeration | Pca9540bTypeChannelSelection |
Public enumeration | Pca9542aTypeChannelSelection |
Public enumeration | Pca9542aTypeInt |
Public enumeration | Pca9543aTypeChannelSelection |
Public enumeration | Pca9543aTypeInt |
Public enumeration | Pca9543cTypeChannelSelection |
Public enumeration | Pca9543cTypeInt |
Public enumeration | Pca9544aTypeChannelSelection |
Public enumeration | Pca9544aTypeInt |
Public enumeration | Pca9545aTypeChannelSelection |
Public enumeration | Pca9545aTypeInt |
Public enumeration | Pca9545bTypeChannelSelection |
Public enumeration | Pca9545bTypeInt |
Public enumeration | Pca9545cTypeChannelSelection |
Public enumeration | Pca9545cTypeInt |
Public enumeration | Pca9546aTypeChannelSelection |
Public enumeration | Pca9547TypeChannelSelection |
Public enumeration | Pca9548aTypeChannelSelection |
Public enumeration | Pca9549TypeChannelSelection |
Public enumeration | Pca9550TypeInput |
Public enumeration | Pca9550TypeLedSelector |
Public enumeration | Pca9551TypeInput |
Public enumeration | Pca9551TypeLedSelector |
Public enumeration | Pca9552TypeInput |
Public enumeration | Pca9552TypeLedSelector |
Public enumeration | Pca9553TypeInput |
Public enumeration | Pca9553TypeLedSelector |
Public enumeration | Pca9629TypeClearIntP0 |
Public enumeration | Pca9629TypeClearIntP1 |
Public enumeration | Pca9629TypeClearIntP2 |
Public enumeration | Pca9629TypeClearIntP3 |
Public enumeration | Pca9629TypeIntActionInterruptMotorControl |
Public enumeration | Pca9629TypeIntActionUnitExtrasteps |
Public enumeration | Pca9629TypeIntAutoClr |
Public enumeration | Pca9629TypeIntExtraStep |
Public enumeration | Pca9629TypeIntModeP0 |
Public enumeration | Pca9629TypeIntModeP1 |
Public enumeration | Pca9629TypeIntModeP2 |
Public enumeration | Pca9629TypeIntModeP3 |
Public enumeration | Pca9629TypeIntMotorSetup |
Public enumeration | Pca9629TypeIntstatIntp0Flag |
Public enumeration | Pca9629TypeIntstatIntp1Flag |
Public enumeration | Pca9629TypeIntstatIntp2Flag |
Public enumeration | Pca9629TypeIntstatIntp3Flag |
Public enumeration | Pca9629TypeIoConfigP0 |
Public enumeration | Pca9629TypeIoConfigP1 |
Public enumeration | Pca9629TypeIoConfigP2 |
Public enumeration | Pca9629TypeIoConfigP3 |
Public enumeration | Pca9629TypeMaskInterruptP0 |
Public enumeration | Pca9629TypeMaskInterruptP1 |
Public enumeration | Pca9629TypeMaskInterruptP2 |
Public enumeration | Pca9629TypeMaskInterruptP3 |
Public enumeration | Pca9629TypeModeIntOutput |
Public enumeration | Pca9629TypeModeOutputChange |
Public enumeration | Pca9629TypeModeRespondAllCall |
Public enumeration | Pca9629TypeModeRespondSubadr1 |
Public enumeration | Pca9629TypeModeRespondSubadr2 |
Public enumeration | Pca9629TypeModeRespondSubadr3 |
Public enumeration | Pca9629TypeMotorControlDirection |
Public enumeration | Pca9629TypeMotorControlHardStop |
Public enumeration | Pca9629TypeMotorControlMode |
Public enumeration | Pca9629TypeMotorControlPerformAction |
Public enumeration | Pca9629TypeMotorControlStartStop |
Public enumeration | Pca9629TypePhaseControl |
Public enumeration | Pca9629TypeRampControlRampDown |
Public enumeration | Pca9629TypeRampControlRampStep |
Public enumeration | Pca9629TypeRampControlRampUp |
Public enumeration | Pca9629TypeSetmodeOutputCcwStop |
Public enumeration | Pca9629TypeSetmodeOutputCwStop |
Public enumeration | Pca9629TypeWdcntlWdEnableDisable |
Public enumeration | Pca9629TypeWdcntlWdInterruptFlag |
Public enumeration | Pca9629TypeWdcntlWdInterruptFlagControl |
Public enumeration | Pca9629TypeWdcntlWdMode |
Public enumeration | Pca9629TypeWdcntlWdResetFlag |
Public enumeration | Pca9685TypeLedxOffHLedFullOff |
Public enumeration | Pca9685TypeLedxOnHLedFullOn |
Public enumeration | Pca9685TypeMode1AllCall |
Public enumeration | Pca9685TypeMode1AutoIncrement |
Public enumeration | Pca9685TypeMode1ExtClock |
Public enumeration | Pca9685TypeMode1Restart |
Public enumeration | Pca9685TypeMode1Sleep |
Public enumeration | Pca9685TypeMode1Sub1 |
Public enumeration | Pca9685TypeMode1Sub2 |
Public enumeration | Pca9685TypeMode1Sub3 |
Public enumeration | Pca9685TypeMode2OutputChanged |
Public enumeration | Pca9685TypeMode2OutputDrive |
Public enumeration | Pca9685TypeMode2OutputInverted |
Public enumeration | Pca9685TypeMode2OutputNotEnable |
Public enumeration | Pca9698TypeIoc |
Public enumeration | Pca9698TypeModeIoac |
Public enumeration | Pca9698TypeModeOch |
Public enumeration | Pca9698TypeModeOepol |
Public enumeration | Pca9698TypeModeSmba |
Public enumeration | Pca9698TypeMsk |
Public enumeration | Pca9698TypeOutconf |
Public enumeration | Pca9698TypePi |
Public enumeration | Pcal6408aTypeConfiguration |
Public enumeration | Pcal6408aTypeInputLatch |
Public enumeration | Pcal6408aTypeInterruptMask |
Public enumeration | Pcal6408aTypeInterruptStatus |
Public enumeration | Pcal6408aTypeOutputDriveStrength |
Public enumeration | Pcal6408aTypeOutputPortConfiguration |
Public enumeration | Pcal6408aTypePolarityInversion |
Public enumeration | Pcal6408aTypePullUpPullDownEnable |
Public enumeration | Pcal6408aTypePullUpPullDownSelection |
Public enumeration | Pcal6416aTypeConfiguration |
Public enumeration | Pcal6416aTypeInputLatch |
Public enumeration | Pcal6416aTypeInterruptMask |
Public enumeration | Pcal6416aTypeInterruptStatus |
Public enumeration | Pcal6416aTypeOutputDriveStrength |
Public enumeration | Pcal6416aTypeOutputPortConfiguration |
Public enumeration | Pcal6416aTypePolarityInversion |
Public enumeration | Pcal6416aTypePullUpPullDownEnable |
Public enumeration | Pcal6416aTypePullUpPullDownSelection |
Public enumeration | Pcal9535aTypeConfiguration |
Public enumeration | Pcal9535aTypeInputLatch |
Public enumeration | Pcal9535aTypeInterruptMask |
Public enumeration | Pcal9535aTypeInterruptStatus |
Public enumeration | Pcal9535aTypeOutputDriveStrength |
Public enumeration | Pcal9535aTypeOutputPortConfiguration |
Public enumeration | Pcal9535aTypePolarityInversion |
Public enumeration | Pcal9535aTypePullUpPullDownEnable |
Public enumeration | Pcal9535aTypePullUpPullDownSelection |
Public enumeration | Pcal9538aTypeConfiguration |
Public enumeration | Pcal9538aTypeInputLatch |
Public enumeration | Pcal9538aTypeInterruptMask |
Public enumeration | Pcal9538aTypeInterruptStatus |
Public enumeration | Pcal9538aTypeOutputDriveStrength |
Public enumeration | Pcal9538aTypeOutputPortConfiguration |
Public enumeration | Pcal9538aTypePolarityInversion |
Public enumeration | Pcal9538aTypePullUpPullDownEnable |
Public enumeration | Pcal9538aTypePullUpPullDownSelection |
Public enumeration | Pcal9539aTypeConfiguration |
Public enumeration | Pcal9539aTypeInputLatch |
Public enumeration | Pcal9539aTypeInterruptMask |
Public enumeration | Pcal9539aTypeInterruptStatus |
Public enumeration | Pcal9539aTypeOutputDriveStrength |
Public enumeration | Pcal9539aTypeOutputPortConfiguration |
Public enumeration | Pcal9539aTypePolarityInversion |
Public enumeration | Pcal9539aTypePullUpPullDownEnable |
Public enumeration | Pcal9539aTypePullUpPullDownSelection |
Public enumeration | Pcal9555aTypeConfiguration |
Public enumeration | Pcal9555aTypeInputLatch |
Public enumeration | Pcal9555aTypeInterruptMask |
Public enumeration | Pcal9555aTypeInterruptStatus |
Public enumeration | Pcal9555aTypeOutputDriveStrength |
Public enumeration | Pcal9555aTypeOutputPortConfiguration |
Public enumeration | Pcal9555aTypePolarityInversion |
Public enumeration | Pcal9555aTypePullUpPullDownEnable |
Public enumeration | Pcal9555aTypePullUpPullDownSelection |
Public enumeration | Pcf85063aTypeAlarmEnabledDisabled |
Public enumeration | Pcf85063aTypeControl11224 |
Public enumeration | Pcf85063aTypeControl1CapSel |
Public enumeration | Pcf85063aTypeControl1Cie |
Public enumeration | Pcf85063aTypeControl1ExtTest |
Public enumeration | Pcf85063aTypeControl1Sr |
Public enumeration | Pcf85063aTypeControl1Stop |
Public enumeration | Pcf85063aTypeControl2Af |
Public enumeration | Pcf85063aTypeControl2Aie |
Public enumeration | Pcf85063aTypeControl2Cof |
Public enumeration | Pcf85063aTypeControl2Hmi |
Public enumeration | Pcf85063aTypeControl2Mi |
Public enumeration | Pcf85063aTypeControl2Tf |
Public enumeration | Pcf85063aTypeMonths |
Public enumeration | Pcf85063aTypeOffsetMode |
Public enumeration | Pcf85063aTypeSecondsOs |
Public enumeration | Pcf85063aTypeTimerModeTcf |
Public enumeration | Pcf85063aTypeTimerModeTe |
Public enumeration | Pcf85063aTypeTimerModeTie |
Public enumeration | Pcf85063aTypeTimerModeTiTp |
Public enumeration | Pcf85063aTypeWeekdays |
Public enumeration | Pcf85063tpTypeControl11224 |
Public enumeration | Pcf85063tpTypeControl1CapSel |
Public enumeration | Pcf85063tpTypeControl1Cie |
Public enumeration | Pcf85063tpTypeControl1ExtTest |
Public enumeration | Pcf85063tpTypeControl1Sr |
Public enumeration | Pcf85063tpTypeControl1Stop |
Public enumeration | Pcf85063tpTypeControl2Cof |
Public enumeration | Pcf85063tpTypeControl2Hmi |
Public enumeration | Pcf85063tpTypeControl2Mi |
Public enumeration | Pcf85063tpTypeControl2Tf |
Public enumeration | Pcf85063tpTypeMonths |
Public enumeration | Pcf85063tpTypeOffsetMode |
Public enumeration | Pcf85063tpTypeSecondsOs |
Public enumeration | Pcf85063tpTypeWeekdays |
Public enumeration | Pct2075TypeOperationMode |
Public enumeration | Pct2075TypeOsFaultQueue |
Public enumeration | Pct2075TypeOsOperationModeSelection |
Public enumeration | Pct2075TypeOsPolaritySelection |
Public enumeration | Sa56004xTypeAlertMode |
Public enumeration | Sa56004xTypeConfigurationEnabledDisabled |
Public enumeration | Sa56004xTypeConfigurationRunStop |
Public enumeration | Sa56004xTypeConversionRate |
Public enumeration | Sa56004xTypeStatusAlarm |
Public enumeration | Sa56004xTypeStatusBusy |
Public enumeration | Sa56004xTypeStatusOpen |
Public enumeration | Saa7118IDEnableDisable |
Public enumeration | Saa7118IDNotActiveActive |
Public enumeration | Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL0 |
Public enumeration | Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL1 |
Public enumeration | Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL2 |
Public enumeration | Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL3 |
Public enumeration | Saa7118TYPIDANALOGINPUTCONTROL10 |
Public enumeration | Saa7118TYPIDANALOGINPUTCONTROL11 |
Public enumeration | Saa7118TYPIDANALOGINPUTCONTROL20 |
Public enumeration | Saa7118TYPIDANALOGINPUTCONTROL21 |
Public enumeration | Saa7118TYPIDANALOGINPUTCONTROL22 |
Public enumeration | Saa7118TYPIDANALOGINPUTCONTROL23 |
Public enumeration | Saa7118TYPIDANALOGINPUTCONTROL24 |
Public enumeration | Saa7118TYPIDANALOGINPUTCONTROL51 |
Public enumeration | Saa7118TYPIDANALOGINPUTCONTROL52 |
Public enumeration | Saa7118TYPIDANALOGINPUTCONTROL53 |
Public enumeration | Saa7118TYPIDAUDIOCLOCKCONTROL0 |
Public enumeration | Saa7118TYPIDAUDIOCLOCKCONTROL1 |
Public enumeration | Saa7118TYPIDAUDIOCLOCKCONTROL2 |
Public enumeration | Saa7118TYPIDAUDIOCLOCKCONTROL3 |
Public enumeration | Saa7118TYPIDCHROMINANCECONTROL10 |
Public enumeration | Saa7118TYPIDCHROMINANCECONTROL101 |
Public enumeration | Saa7118TYPIDCHROMINANCECONTROL11 |
Public enumeration | Saa7118TYPIDCHROMINANCECONTROL12 |
Public enumeration | Saa7118TYPIDCHROMINANCECONTROL13 |
Public enumeration | Saa7118TYPIDCHROMINANCECONTROL14 |
Public enumeration | Saa7118TYPIDCHROMINANCECONTROL20 |
Public enumeration | Saa7118TYPIDCHROMINANCECONTROL21 |
Public enumeration | Saa7118TYPIDCHROMINANCECONTROL22 |
Public enumeration | Saa7118TYPIDCHROMINANCEGAINCONTROL0 |
Public enumeration | Saa7118TYPIDCHROMINANCEGAINCONTROL1 |
Public enumeration | Saa7118TYPIDCOMPONENTDELAYFSWITCHCONTROL3 |
Public enumeration | Saa7118TYPIDCOMPONENTDELAYFSWITCHCONTROL4 |
Public enumeration | Saa7118TYPIDFIELDOFFSETANDETSSLICERSET0 |
Public enumeration | Saa7118TYPIDFIELDOFFSETANDETSSLICERSET1 |
Public enumeration | Saa7118TYPIDGLOBALCONTROL10 |
Public enumeration | Saa7118TYPIDGLOBALCONTROL11 |
Public enumeration | Saa7118TYPIDGLOBALCONTROL12 |
Public enumeration | Saa7118TYPIDGLOBALCONTROL15 |
Public enumeration | Saa7118TYPIDHEADERANDDATAIONCODECONTROL1 |
Public enumeration | Saa7118TYPIDHORIZONTALINCREMENTDELAY0 |
Public enumeration | Saa7118TYPIDHORIZONTALINCREMENTDELAY1 |
Public enumeration | Saa7118TYPIDHORIZONTALINCREMENTDELAY2 |
Public enumeration | Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION0 |
Public enumeration | Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION1 |
Public enumeration | Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION2 |
Public enumeration | Saa7118TYPIDIPORTIOENABLEKPHASECONTROL0 |
Public enumeration | Saa7118TYPIDIPORTIOENABLEKPHASECONTROL1 |
Public enumeration | Saa7118TYPIDIPORTIOENABLEKPHASECONTROL2 |
Public enumeration | Saa7118TYPIDIPORTSIGNALDEFINITIONS0 |
Public enumeration | Saa7118TYPIDIPORTSIGNALDEFINITIONS01 |
Public enumeration | Saa7118TYPIDIPORTSIGNALDEFINITIONS02 |
Public enumeration | Saa7118TYPIDIPORTSIGNALDEFINITIONS1 |
Public enumeration | Saa7118TYPIDLINECONTROLREGISTERLCR20 |
Public enumeration | Saa7118TYPIDLUMINANCEBRIGHTNLDECODERPART0 |
Public enumeration | Saa7118TYPIDLUMINANCECONTRASCOMPONENTPART0 |
Public enumeration | Saa7118TYPIDLUMINANCECONTRASLDECODERPART0 |
Public enumeration | Saa7118TYPIDLUMINANCECONTROL0 |
Public enumeration | Saa7118TYPIDLUMINANCECONTROL1 |
Public enumeration | Saa7118TYPIDLUMINANCECONTROL2 |
Public enumeration | Saa7118TYPIDLUMINANCECONTROL3 |
Public enumeration | Saa7118TYPIDLUMINANCECONTROL4 |
Public enumeration | Saa7118TYPIDMISCELLANEOUSVGATEMSBS0 |
Public enumeration | Saa7118TYPIDMISCELLANEOUSVGATEMSBS1 |
Public enumeration | Saa7118TYPIDMISCELLANEOUSVGATEMSBS2 |
Public enumeration | Saa7118TYPIDMODEDELAYCONTROL1 |
Public enumeration | Saa7118TYPIDMODEDELAYCONTROL4 |
Public enumeration | Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL0 |
Public enumeration | Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL2 |
Public enumeration | Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL3 |
Public enumeration | Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL4 |
Public enumeration | Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL5 |
Public enumeration | Saa7118TYPIDRAWDATAGAINCONTROL0 |
Public enumeration | Saa7118TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 |
Public enumeration | Saa7118TYPIDRTXPORTOUTPUTCONTROL0 |
Public enumeration | Saa7118TYPIDRTXPORTOUTPUTCONTROL1 |
Public enumeration | Saa7118TYPIDRTXPORTOUTPUTCONTROL2 |
Public enumeration | Saa7118TYPIDRTXPORTOUTPUTCONTROL3 |
Public enumeration | Saa7118TYPIDRTXPORTOUTPUTCONTROL4 |
Public enumeration | Saa7118TYPIDSLICERBYTE20 |
Public enumeration | Saa7118TYPIDSLICERCONTROL10 |
Public enumeration | Saa7118TYPIDSLICERCONTROL11 |
Public enumeration | Saa7118TYPIDSLICERCONTROL12 |
Public enumeration | Saa7118TYPIDSLICERSTATUSBYTE00 |
Public enumeration | Saa7118TYPIDSLICERSTATUSBYTE01 |
Public enumeration | Saa7118TYPIDSLICERSTATUSBYTE02 |
Public enumeration | Saa7118TYPIDSLICERSTATUSBYTE03 |
Public enumeration | Saa7118TYPIDSLICERSTATUSBYTE04 |
Public enumeration | Saa7118TYPIDSTATUSBYTE1VIDEODECODER0 |
Public enumeration | Saa7118TYPIDSTATUSBYTE1VIDEODECODER5 |
Public enumeration | Saa7118TYPIDSTATUSBYTE2VIDEODECODER4 |
Public enumeration | Saa7118TYPIDSTATUSBYTE2VIDEODECODER5 |
Public enumeration | Saa7118TYPIDSTATUSBYTE2VIDEODECODER6 |
Public enumeration | Saa7118TYPIDSYNCCONTROL0 |
Public enumeration | Saa7118TYPIDSYNCCONTROL1 |
Public enumeration | Saa7118TYPIDSYNCCONTROL2 |
Public enumeration | Saa7118TYPIDSYNCCONTROL3 |
Public enumeration | Saa7118TYPIDSYNCCONTROL4 |
Public enumeration | Saa7118TYPIDSYNCCONTROL5 |
Public enumeration | Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0 |
Public enumeration | Saa7118TYPIDTAHORIZONTALINPWINDOWLENGTHL0 |
Public enumeration | Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 |
Public enumeration | Saa7118TYPIDTAHORIZONTALLUMLINGINCREMENTL0 |
Public enumeration | Saa7118TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 |
Public enumeration | Saa7118TYPIDTAHORIZONTALPRESCALING0 |
Public enumeration | Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION0 |
Public enumeration | Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION1 |
Public enumeration | Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION2 |
Public enumeration | Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION3 |
Public enumeration | Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION4 |
Public enumeration | Saa7118TYPIDTALUMINANCEBRIGGHTNESSCONTROL0 |
Public enumeration | Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 |
Public enumeration | Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL0 |
Public enumeration | Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL1 |
Public enumeration | Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL2 |
Public enumeration | Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL3 |
Public enumeration | Saa7118TYPIDTATASKHANDLINGCONTROL0 |
Public enumeration | Saa7118TYPIDTATASKHANDLINGCONTROL1 |
Public enumeration | Saa7118TYPIDTATASKHANDLINGCONTROL2 |
Public enumeration | Saa7118TYPIDTATASKHANDLINGCONTROL3 |
Public enumeration | Saa7118TYPIDTATASKHANDLINGCONTROL4 |
Public enumeration | Saa7118TYPIDTAVERTICALINPUTTWINDOWSTARTL0 |
Public enumeration | Saa7118TYPIDTAVERTICALINPUTWINDOWLENGTHL0 |
Public enumeration | Saa7118TYPIDTAVERTICALLUMINLINGINCREMENTL0 |
Public enumeration | Saa7118TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 |
Public enumeration | Saa7118TYPIDTAVERTICALSCALINGMODECONTROL0 |
Public enumeration | Saa7118TYPIDTAVERTICALSCALINGMODECONTROL1 |
Public enumeration | Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION0 |
Public enumeration | Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION1 |
Public enumeration | Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION2 |
Public enumeration | Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION3 |
Public enumeration | Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION4 |
Public enumeration | Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION5 |
Public enumeration | Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS0 |
Public enumeration | Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS1 |
Public enumeration | Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS2 |
Public enumeration | Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS3 |
Public enumeration | Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS4 |
Public enumeration | Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS5 |
Public enumeration | Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS6 |
Public enumeration | Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS7 |
Public enumeration | Saa7118TYPIDTBHORIZONTALLUMLINGINCREMENTL0 |
Public enumeration | Saa7118TYPIDTBVERTICALLUMINLINGINCREMENTL0 |
Public enumeration | Saa7118TYPIDVGATESTART0 |
Public enumeration | Saa7118TYPIDXPORTIOENABLEKPHASECONTROL0 |
Public enumeration | Saa7118TYPIDXPORTIOENABLEKPHASECONTROL1 |
Public enumeration | Saa7118TYPIDXPORTIOENABLEKPHASECONTROL2 |
Public enumeration | Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 |
Public enumeration | Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER5 |
Public enumeration | Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER6 |
Public enumeration | Saa7119IDEnableDisable |
Public enumeration | Saa7119IDNotActiveActive |
Public enumeration | Saa7119TYPIDADCPORTCONTROLGLOBALSET0 |
Public enumeration | Saa7119TYPIDADCPORTCONTROLGLOBALSET01 |
Public enumeration | Saa7119TYPIDADCPORTCONTROLGLOBALSET1 |
Public enumeration | Saa7119TYPIDADCPORTCONTROLGLOBALSET2 |
Public enumeration | Saa7119TYPIDADCPORTCONTROLGLOBALSET3 |
Public enumeration | Saa7119TYPIDADCPORTCONTROLGLOBALSET4 |
Public enumeration | Saa7119TYPIDANALOGADCAUTOCIBILITYCONTROL0 |
Public enumeration | Saa7119TYPIDANALOGADCAUTOCIBILITYCONTROL1 |
Public enumeration | Saa7119TYPIDANALOGINPUTCONTROL10 |
Public enumeration | Saa7119TYPIDANALOGINPUTCONTROL11 |
Public enumeration | Saa7119TYPIDANALOGINPUTCONTROL20 |
Public enumeration | Saa7119TYPIDANALOGINPUTCONTROL21 |
Public enumeration | Saa7119TYPIDANALOGINPUTCONTROL22 |
Public enumeration | Saa7119TYPIDANALOGINPUTCONTROL23 |
Public enumeration | Saa7119TYPIDANALOGINPUTCONTROL24 |
Public enumeration | Saa7119TYPIDANALOGINPUTCONTROL30 |
Public enumeration | Saa7119TYPIDANALOGINPUTCONTROL301 |
Public enumeration | Saa7119TYPIDAUDIOCLOCKCONTROL0 |
Public enumeration | Saa7119TYPIDAUDIOCLOCKCONTROL1 |
Public enumeration | Saa7119TYPIDAUDIOCLOCKCONTROL2 |
Public enumeration | Saa7119TYPIDAUDIOCLOCKCONTROL3 |
Public enumeration | Saa7119TYPIDAUDIOCLOCKCONTROL4 |
Public enumeration | Saa7119TYPIDCHROMINANCECONTROL10 |
Public enumeration | Saa7119TYPIDCHROMINANCECONTROL101 |
Public enumeration | Saa7119TYPIDCHROMINANCECONTROL11 |
Public enumeration | Saa7119TYPIDCHROMINANCECONTROL12 |
Public enumeration | Saa7119TYPIDCHROMINANCECONTROL13 |
Public enumeration | Saa7119TYPIDCHROMINANCECONTROL20 |
Public enumeration | Saa7119TYPIDCHROMINANCECONTROL21 |
Public enumeration | Saa7119TYPIDCHROMINANCECONTROL22 |
Public enumeration | Saa7119TYPIDCHROMINANCEGAINCONTROL0 |
Public enumeration | Saa7119TYPIDCHROMINANCESATURCOMPONENTPART0 |
Public enumeration | Saa7119TYPIDCHROMINANCESATURURATIONCONTROL0 |
Public enumeration | Saa7119TYPIDCOLORKILLERLEVELCONTROL0 |
Public enumeration | Saa7119TYPIDDITHERLUMA2 |
Public enumeration | Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL10 |
Public enumeration | Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL11 |
Public enumeration | Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL13 |
Public enumeration | Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL20 |
Public enumeration | Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL21 |
Public enumeration | Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL22 |
Public enumeration | Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL23 |
Public enumeration | Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL24 |
Public enumeration | Saa7119TYPIDFASTSWITCHCONTROL10 |
Public enumeration | Saa7119TYPIDFASTSWITCHCONTROL12 |
Public enumeration | Saa7119TYPIDFASTSWITCHCONTROL32 |
Public enumeration | Saa7119TYPIDFASTSWITCHCONTROL34 |
Public enumeration | Saa7119TYPIDFASTSWITCHSTATUS0 |
Public enumeration | Saa7119TYPIDFIELDOFFSETANDERTICALOFFSETS0 |
Public enumeration | Saa7119TYPIDFIELDOFFSETANDERTICALOFFSETS1 |
Public enumeration | Saa7119TYPIDGLOBALSETTINGS3 |
Public enumeration | Saa7119TYPIDHORIZONTALINCREMENTDELAY0 |
Public enumeration | Saa7119TYPIDHORIZONTALINCREMENTDELAY1 |
Public enumeration | Saa7119TYPIDHORIZONTALINCREMENTDELAY2 |
Public enumeration | Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS0 |
Public enumeration | Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS1 |
Public enumeration | Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS2 |
Public enumeration | Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS3 |
Public enumeration | Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS4 |
Public enumeration | Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS5 |
Public enumeration | Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION0 |
Public enumeration | Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION1 |
Public enumeration | Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION2 |
Public enumeration | Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION3 |
Public enumeration | Saa7119TYPIDIPORTIOENABLEKPHASECONTROL0 |
Public enumeration | Saa7119TYPIDIPORTIOENABLEKPHASECONTROL1 |
Public enumeration | Saa7119TYPIDIPORTIOENABLEKPHASECONTROL2 |
Public enumeration | Saa7119TYPIDIPORTSIGNALDEFINITIONS0 |
Public enumeration | Saa7119TYPIDIPORTSIGNALDEFINITIONS01 |
Public enumeration | Saa7119TYPIDIPORTSIGNALDEFINITIONS02 |
Public enumeration | Saa7119TYPIDIPORTSIGNALDEFINITIONS1 |
Public enumeration | Saa7119TYPIDLCRREGISTER20 |
Public enumeration | Saa7119TYPIDLUMINANCEBRIGHTNLDECODERPART0 |
Public enumeration | Saa7119TYPIDLUMINANCECONTRASCOMPONENTPART0 |
Public enumeration | Saa7119TYPIDLUMINANCECONTRASLDECODERPART0 |
Public enumeration | Saa7119TYPIDLUMINANCECONTROL0 |
Public enumeration | Saa7119TYPIDLUMINANCECONTROL1 |
Public enumeration | Saa7119TYPIDLUMINANCECONTROL2 |
Public enumeration | Saa7119TYPIDLUMINANCECONTROL3 |
Public enumeration | Saa7119TYPIDLUMINANCECONTROL4 |
Public enumeration | Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION0 |
Public enumeration | Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION1 |
Public enumeration | Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION2 |
Public enumeration | Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION3 |
Public enumeration | Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION4 |
Public enumeration | Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION5 |
Public enumeration | Saa7119TYPIDMISCELLANEOUSVGATEMSBS0 |
Public enumeration | Saa7119TYPIDMISCELLANEOUSVGATEMSBS1 |
Public enumeration | Saa7119TYPIDMISCELLANEOUSVGATEMSBS2 |
Public enumeration | Saa7119TYPIDMODEDELAYCONTROL1 |
Public enumeration | Saa7119TYPIDMODEDELAYCONTROL4 |
Public enumeration | Saa7119TYPIDOVERLAYCONTROL0 |
Public enumeration | Saa7119TYPIDPANORAMAANDKEYSTONING0 |
Public enumeration | Saa7119TYPIDPANORAMAANDKEYSTONING1 |
Public enumeration | Saa7119TYPIDPANORAMAANDKEYSTONING2 |
Public enumeration | Saa7119TYPIDPANORAMAANDKEYSTONING3 |
Public enumeration | Saa7119TYPIDPLL1DIGANNASTATUS0 |
Public enumeration | Saa7119TYPIDPLL1DIGANNASTATUS1 |
Public enumeration | Saa7119TYPIDRAWDATAGAINCONTROL0 |
Public enumeration | Saa7119TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 |
Public enumeration | Saa7119TYPIDRTXPORTOUTPUTCONTROL0 |
Public enumeration | Saa7119TYPIDRTXPORTOUTPUTCONTROL01 |
Public enumeration | Saa7119TYPIDRTXPORTOUTPUTCONTROL1 |
Public enumeration | Saa7119TYPIDRTXPORTOUTPUTCONTROL2 |
Public enumeration | Saa7119TYPIDRTXPORTOUTPUTCONTROL3 |
Public enumeration | Saa7119TYPIDSLICERSET0 |
Public enumeration | Saa7119TYPIDSLICERSET1 |
Public enumeration | Saa7119TYPIDSLICERSET2 |
Public enumeration | Saa7119TYPIDSLICERSET3 |
Public enumeration | Saa7119TYPIDSLICERSTATUSBITBITSDIDCODES1 |
Public enumeration | Saa7119TYPIDSLICERSTATUSBITBITSDIDCODES2 |
Public enumeration | Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 |
Public enumeration | Saa7119TYPIDSTATUSBYTE1VIDEODECODER0 |
Public enumeration | Saa7119TYPIDSTATUSBYTE1VIDEODECODER1 |
Public enumeration | Saa7119TYPIDSTATUSBYTE1VIDEODECODER2 |
Public enumeration | Saa7119TYPIDSTATUSBYTE1VIDEODECODER3 |
Public enumeration | Saa7119TYPIDSTATUSBYTE1VIDEODECODER4 |
Public enumeration | Saa7119TYPIDSTATUSBYTE1VIDEODECODER5 |
Public enumeration | Saa7119TYPIDSTATUSBYTE1VIDEODECODER6 |
Public enumeration | Saa7119TYPIDSTATUSBYTE2VIDEODECODER4 |
Public enumeration | Saa7119TYPIDSTATUSBYTE2VIDEODECODER5 |
Public enumeration | Saa7119TYPIDSTATUSBYTE2VIDEODECODER6 |
Public enumeration | Saa7119TYPIDSTATUSBYTE2VIDEODECODER7 |
Public enumeration | Saa7119TYPIDSTATUSINFORMATIOATIONEDGIPART0 |
Public enumeration | Saa7119TYPIDSYNCCONTROL0 |
Public enumeration | Saa7119TYPIDSYNCCONTROL1 |
Public enumeration | Saa7119TYPIDSYNCCONTROL2 |
Public enumeration | Saa7119TYPIDSYNCCONTROL3 |
Public enumeration | Saa7119TYPIDSYNCCONTROL4 |
Public enumeration | Saa7119TYPIDSYNCCONTROL5 |
Public enumeration | Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL0 |
Public enumeration | Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL3 |
Public enumeration | Saa7119TYPIDTAEDGICONTROL0 |
Public enumeration | Saa7119TYPIDTAEDGICONTROL1 |
Public enumeration | Saa7119TYPIDTAEDGICONTROL3 |
Public enumeration | Saa7119TYPIDTAHORIZONTALINPINITIONOFFSETL0 |
Public enumeration | Saa7119TYPIDTAHORIZONTALINPWINDOWLENGTHL0 |
Public enumeration | Saa7119TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 |
Public enumeration | Saa7119TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 |
Public enumeration | Saa7119TYPIDTAHORIZONTALPRESCALING0 |
Public enumeration | Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION0 |
Public enumeration | Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION1 |
Public enumeration | Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION2 |
Public enumeration | Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION3 |
Public enumeration | Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION4 |
Public enumeration | Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 |
Public enumeration | Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL0 |
Public enumeration | Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL3 |
Public enumeration | Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL0 |
Public enumeration | Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL2 |
Public enumeration | Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL3 |
Public enumeration | Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL0 |
Public enumeration | Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL1 |
Public enumeration | Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL2 |
Public enumeration | Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL3 |
Public enumeration | Saa7119TYPIDTATASKHANDLINGCONTROL0 |
Public enumeration | Saa7119TYPIDTATASKHANDLINGCONTROL1 |
Public enumeration | Saa7119TYPIDTATASKHANDLINGCONTROL2 |
Public enumeration | Saa7119TYPIDTATASKHANDLINGCONTROL3 |
Public enumeration | Saa7119TYPIDTATASKHANDLINGCONTROL4 |
Public enumeration | Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONH0 |
Public enumeration | Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONL0 |
Public enumeration | Saa7119TYPIDTAVERTICALINPUTINITIONOFFSETL0 |
Public enumeration | Saa7119TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 |
Public enumeration | Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 |
Public enumeration | Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION0 |
Public enumeration | Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION1 |
Public enumeration | Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION2 |
Public enumeration | Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION3 |
Public enumeration | Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION4 |
Public enumeration | Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION5 |
Public enumeration | Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS0 |
Public enumeration | Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS1 |
Public enumeration | Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS2 |
Public enumeration | Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS3 |
Public enumeration | Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS4 |
Public enumeration | Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS5 |
Public enumeration | Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS6 |
Public enumeration | Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS7 |
Public enumeration | Saa7119TYPIDVGATESTART0 |
Public enumeration | Saa7119TYPIDXPORTIOENABLEKPHASECONTROL0 |
Public enumeration | Saa7119TYPIDXPORTIOENABLEKPHASECONTROL1 |
Public enumeration | Saa7119TYPIDXPORTIOENABLEKPHASECONTROL2 |
Public enumeration | Saa7119TYPIDXPORTIOENABLEKPHASECONTROL3 |
Public enumeration | Saa7119TYPIDXPORTIOENABLEKPHASECONTROL4 |
Public enumeration | Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 |
Public enumeration | Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES5 |
Public enumeration | Se95TypeConversionRate |
Public enumeration | Se95TypeOperationMode |
Public enumeration | Se95TypeOsFaultQueue |
Public enumeration | Se95TypeOsOperationModeSelection |
Public enumeration | Se95TypeOsPolaritySelection |
Public enumeration | Se97bTypeCapabilityBasicCapability |
Public enumeration | Se97bTypeCapabilityBusTimeoutPeriod |
Public enumeration | Se97bTypeCapabilityEventShutdownAction |
Public enumeration | Se97bTypeCapabilityHigherAccuracy |
Public enumeration | Se97bTypeCapabilityHighVoltageStandoff |
Public enumeration | Se97bTypeCapabilityTemperatureResolution |
Public enumeration | Se97bTypeCapabilityWideRange |
Public enumeration | Se97bTypeConfigurationAlarmWindowLock |
Public enumeration | Se97bTypeConfigurationClearEvent |
Public enumeration | Se97bTypeConfigurationCriticalEventOnly |
Public enumeration | Se97bTypeConfigurationCriticalTripLock |
Public enumeration | Se97bTypeConfigurationEventMode |
Public enumeration | Se97bTypeConfigurationEventOutputControl |
Public enumeration | Se97bTypeConfigurationEventPolarity |
Public enumeration | Se97bTypeConfigurationEventStatus |
Public enumeration | Se97bTypeConfigurationHysteresisEnable |
Public enumeration | Se97bTypeConfigurationShutdownMode |
Public enumeration | Se97bTypeSmbusAlertResponseAddress |
Public enumeration | Se97bTypeSmbusEventSleepState |
Public enumeration | Se97bTypeSmbusFlagUpdateMode |
Public enumeration | Se97bTypeSmbusInterruptFlopClearingMode |
Public enumeration | Se97bTypeSmbusTimeout |
Public enumeration | Se97bTypeSmbusTimeoutDuringShutdown |
Public enumeration | Se97bTypeTemperatureAboveAlarmWindow |
Public enumeration | Se97bTypeTemperatureAboveCriticalTrip |
Public enumeration | Se97bTypeTemperatureBelowAlarmWindow |
Public enumeration | Se98aTypeCapabilityBasicCapability |
Public enumeration | Se98aTypeCapabilityHigherAccuracy |
Public enumeration | Se98aTypeCapabilityHighVoltageStandoff |
Public enumeration | Se98aTypeCapabilityTemperatureResolution |
Public enumeration | Se98aTypeCapabilityWideRange |
Public enumeration | Se98aTypeConfigurationAlarmWindowLock |
Public enumeration | Se98aTypeConfigurationClearEvent |
Public enumeration | Se98aTypeConfigurationCriticalEventOnly |
Public enumeration | Se98aTypeConfigurationCriticalTripLock |
Public enumeration | Se98aTypeConfigurationEventMode |
Public enumeration | Se98aTypeConfigurationEventOutputControl |
Public enumeration | Se98aTypeConfigurationEventPolarity |
Public enumeration | Se98aTypeConfigurationEventStatus |
Public enumeration | Se98aTypeConfigurationHysteresisEnable |
Public enumeration | Se98aTypeConfigurationShutdownMode |
Public enumeration | Se98aTypeSmbusAlert |
Public enumeration | Se98aTypeSmbusTimeout |
Public enumeration | Se98aTypeTemperatureAboveAlarmWindow |
Public enumeration | Se98aTypeTemperatureAboveCriticalTrip |
Public enumeration | Se98aTypeTemperatureBelowAlarmWindow |
Public enumeration | Tda10046TYPIDACTIVATEDNOTACTIVATED |
Public enumeration | Tda10046TYPIDAGCLOOPGAINAGCGAINS0 |
Public enumeration | Tda10046TYPIDAUTOMATICLOCKAUTO0 |
Public enumeration | Tda10046TYPIDAUTOMATICLOCKAUTO1 |
Public enumeration | Tda10046TYPIDAUTOMATICLOCKAUTO2 |
Public enumeration | Tda10046TYPIDAUTOMATICLOCKAUTO3 |
Public enumeration | Tda10046TYPIDAUTOMATICLOCKAUTO4 |
Public enumeration | Tda10046TYPIDAUTOMATICLOCKAUTO5 |
Public enumeration | Tda10046TYPIDAUTOMATICLOCKAUTO6 |
Public enumeration | Tda10046TYPIDAUTOMATICLOCKAUTO7 |
Public enumeration | Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10 |
Public enumeration | Tda10046TYPIDBYPASSIFINTERNAONS3CONFC41 |
Public enumeration | Tda10046TYPIDBYPASSIFINTERNAONS3CONFC42 |
Public enumeration | Tda10046TYPIDBYPASSIFINTERNAONS3CONFC44 |
Public enumeration | Tda10046TYPIDBYPASSIFINTERNAONS3CONFC45 |
Public enumeration | Tda10046TYPIDBYPASSIFINTERNAONS3CONFC46 |
Public enumeration | Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C30 |
Public enumeration | Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C34 |
Public enumeration | Tda10046TYPIDCHANNELBITERROROLCVBERCTRL0 |
Public enumeration | Tda10046TYPIDCHANNELBITERROROLCVBERCTRL2 |
Public enumeration | Tda10046TYPIDCHANNELBITERROROLCVBERCTRL4 |
Public enumeration | Tda10046TYPIDCHANNELBITERRORPUTCVBERLUT0 |
Public enumeration | Tda10046TYPIDCHANNELBITERRORPUTCVBERLUT1 |
Public enumeration | Tda10046TYPIDCHANNELINFORMATICHANNELINFO10 |
Public enumeration | Tda10046TYPIDCHANNELINFORMATICHANNELINFO11 |
Public enumeration | Tda10046TYPIDCONFIGURATIONADCADCCONFADC0 |
Public enumeration | Tda10046TYPIDCONFIGURATIONADCADCCONFADC1 |
Public enumeration | Tda10046TYPIDCONFIGURATIONADCADCCONFADC2 |
Public enumeration | Tda10046TYPIDCONFIGURATIONADCADCCONFADC3 |
Public enumeration | Tda10046TYPIDCONFIGURATIONADCADCCONFADC4 |
Public enumeration | Tda10046TYPIDCONFIGURATIONADCADCCONFADC5 |
Public enumeration | Tda10046TYPIDCONFIGURATIONMISISCCONFMISC0 |
Public enumeration | Tda10046TYPIDCONFIGURATIONMISISCCONFMISC1 |
Public enumeration | Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL10 |
Public enumeration | Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL11 |
Public enumeration | Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL12 |
Public enumeration | Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL13 |
Public enumeration | Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 |
Public enumeration | Tda10046TYPIDCONFIGURATIONTRAAM1CONFTS11 |
Public enumeration | Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS20 |
Public enumeration | Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS21 |
Public enumeration | Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS23 |
Public enumeration | Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS24 |
Public enumeration | Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS25 |
Public enumeration | Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS26 |
Public enumeration | Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS27 |
Public enumeration | Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE10 |
Public enumeration | Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE11 |
Public enumeration | Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13 |
Public enumeration | Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20 |
Public enumeration | Tda10046TYPIDDIGITALAGCLEVELDIGAGCLEVEL0 |
Public enumeration | Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF0 |
Public enumeration | Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF1 |
Public enumeration | Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF2 |
Public enumeration | Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00 |
Public enumeration | Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL0 |
Public enumeration | Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL1 |
Public enumeration | Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL2 |
Public enumeration | Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL3 |
Public enumeration | Tda10046TYPIDGPIOSELECTGPIOSELECT0 |
Public enumeration | Tda10046TYPIDICFUNCTIONALITYICMODE0 |
Public enumeration | Tda10046TYPIDICFUNCTIONALITYICMODE1 |
Public enumeration | Tda10046TYPIDINPUTCONFIGURATION1INCONF10 |
Public enumeration | Tda10046TYPIDINPUTCONFIGURATION1INCONF11 |
Public enumeration | Tda10046TYPIDINPUTCONFIGURATION1INCONF12 |
Public enumeration | Tda10046TYPIDINPUTCONFIGURATION1INCONF13 |
Public enumeration | Tda10046TYPIDINPUTCONFIGURATION2INCONF20 |
Public enumeration | Tda10046TYPIDINPUTCONFIGURATION2INCONF201 |
Public enumeration | Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 |
Public enumeration | Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 |
Public enumeration | Tda10046TYPIDMINMAXSIGNALATTENUATION |
Public enumeration | Tda10046TYPIDMULTIPURPOSEACCBDSPADLSB0 |
Public enumeration | Tda10046TYPIDNOISEPOWERESTIMMATIONNPOUT0 |
Public enumeration | Tda10046TYPIDOFFSETRELATIVELYYFREQOFFSET0 |
Public enumeration | Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS0 |
Public enumeration | Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS1 |
Public enumeration | Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS3 |
Public enumeration | Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS4 |
Public enumeration | Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS5 |
Public enumeration | Tda10046TYPIDTIMEERRORTIMEERROR0 |


Lm75a Class

NXP Semiconductors: LM 75A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsLm75a

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm75a
Public Class Lm75a
public ref class Lm75a
type Lm75a =  class end

The Lm75a type exposes the following members.

Constructors
 | Name | Description
Public method | Lm75a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DeviceOperationSHUTDOWN | Device Operation (SHUTDOWN)
Public property | FaultQueueOSFQUE | Fault Queue (OS_F_QUE)
Public property | HysteresisTHYST | Hysteresis (THYST) (unit: °C)
Public property | OSOperationOSCOMPINT | OS Operation (OS_COMP_INT)
Public property | OverTemperatureTOS | Over-Temperature (TOS) (unit: °C)
Public property | PolarityOSPOL | Polarity (OS_POL)
Public property | TemperatureTEMP | Temperature (TEMP) (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Digital Temperature Sensor And Thermal Watchdog
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Lm75a Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm75a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm75a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm75a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm75a Class
telos.Ird.NXPSemiconductors Namespace


Lm75a Properties

The Lm75a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DeviceOperationSHUTDOWN | Device Operation (SHUTDOWN)
Public property | FaultQueueOSFQUE | Fault Queue (OS_F_QUE)
Public property | HysteresisTHYST | Hysteresis (THYST) (unit: °C)
Public property | OSOperationOSCOMPINT | OS Operation (OS_COMP_INT)
Public property | OverTemperatureTOS | Over-Temperature (TOS) (unit: °C)
Public property | PolarityOSPOL | Polarity (OS_POL)
Public property | TemperatureTEMP | Temperature (TEMP) (unit: °C)
Top
See Also

Reference

Lm75a Class
telos.Ird.NXPSemiconductors Namespace


Lm75a.AutoFlush Property

IRD

Lm75aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm75a Class
telos.Ird.NXPSemiconductors Namespace


Lm75a.DeviceOperationSHUTDOWN Property

IRD

Lm75aDeviceOperationSHUTDOWN Property

Device Operation (SHUTDOWN)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm75aTypeOperationMode DeviceOperationSHUTDOWN { get; set; }
Public Property DeviceOperationSHUTDOWN As Lm75aTypeOperationMode
    Get
    Set
public:
property Lm75aTypeOperationMode DeviceOperationSHUTDOWN {
    Lm75aTypeOperationMode get ();
    void set (Lm75aTypeOperationMode value);
}
member DeviceOperationSHUTDOWN : Lm75aTypeOperationMode with get, set

Property Value

Type: Lm75aTypeOperationMode
See Also

Reference

Lm75a Class
telos.Ird.NXPSemiconductors Namespace


Lm75a.FaultQueueOSFQUE Property

IRD

Lm75aFaultQueueOSFQUE Property

Fault Queue (OS_F_QUE)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm75aTypeOsFaultQueue FaultQueueOSFQUE { get; set; }
Public Property FaultQueueOSFQUE As Lm75aTypeOsFaultQueue
    Get
    Set
public:
property Lm75aTypeOsFaultQueue FaultQueueOSFQUE {
    Lm75aTypeOsFaultQueue get ();
    void set (Lm75aTypeOsFaultQueue value);
}
member FaultQueueOSFQUE : Lm75aTypeOsFaultQueue with get, set

Property Value

Type: Lm75aTypeOsFaultQueue
See Also

Reference

Lm75a Class
telos.Ird.NXPSemiconductors Namespace


Lm75a.HysteresisTHYST Property

IRD

Lm75aHysteresisTHYST Property

Hysteresis (THYST) (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double HysteresisTHYST { get; set; }
Public Property HysteresisTHYST As Double
    Get
    Set
public:
property double HysteresisTHYST {
    double get ();
    void set (double value);
}
member HysteresisTHYST : float with get, set

Property Value

Type: Double
See Also

Reference

Lm75a Class
telos.Ird.NXPSemiconductors Namespace


Lm75a.OSOperationOSCOMPINT Property

IRD

Lm75aOSOperationOSCOMPINT Property

OS Operation (OS_COMP_INT)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm75aTypeOsOperationModeSelection OSOperationOSCOMPINT { get; set; }
Public Property OSOperationOSCOMPINT As Lm75aTypeOsOperationModeSelection
    Get
    Set
public:
property Lm75aTypeOsOperationModeSelection OSOperationOSCOMPINT {
    Lm75aTypeOsOperationModeSelection get ();
    void set (Lm75aTypeOsOperationModeSelection value);
}
member OSOperationOSCOMPINT : Lm75aTypeOsOperationModeSelection with get, set

Property Value

Type: Lm75aTypeOsOperationModeSelection
See Also

Reference

Lm75a Class
telos.Ird.NXPSemiconductors Namespace


Lm75a.OverTemperatureTOS Property

IRD

Lm75aOverTemperatureTOS Property

Over-Temperature (TOS) (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double OverTemperatureTOS { get; set; }
Public Property OverTemperatureTOS As Double
    Get
    Set
public:
property double OverTemperatureTOS {
    double get ();
    void set (double value);
}
member OverTemperatureTOS : float with get, set

Property Value

Type: Double
See Also

Reference

Lm75a Class
telos.Ird.NXPSemiconductors Namespace


Lm75a.PolarityOSPOL Property

IRD

Lm75aPolarityOSPOL Property

Polarity (OS_POL)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm75aTypeOsPolaritySelection PolarityOSPOL { get; set; }
Public Property PolarityOSPOL As Lm75aTypeOsPolaritySelection
    Get
    Set
public:
property Lm75aTypeOsPolaritySelection PolarityOSPOL {
    Lm75aTypeOsPolaritySelection get ();
    void set (Lm75aTypeOsPolaritySelection value);
}
member PolarityOSPOL : Lm75aTypeOsPolaritySelection with get, set

Property Value

Type: Lm75aTypeOsPolaritySelection
See Also

Reference

Lm75a Class
telos.Ird.NXPSemiconductors Namespace


Lm75a.TemperatureTEMP Property

IRD

Lm75aTemperatureTEMP Property

Temperature (TEMP) (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TemperatureTEMP { get; }
Public ReadOnly Property TemperatureTEMP As Double
    Get
public:
property double TemperatureTEMP {
    double get ();
}
member TemperatureTEMP : float with get

Property Value

Type: Double
See Also

Reference

Lm75a Class
telos.Ird.NXPSemiconductors Namespace


Lm75a Methods

The Lm75a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm75a Class
telos.Ird.NXPSemiconductors Namespace


Lm75a.Flush Method

IRD

Lm75aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm75a Class
telos.Ird.NXPSemiconductors Namespace


Lm75a.TypeOperationMode Enumeration

IRD

Lm75aTypeOperationMode Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationMode
Public Enumeration TypeOperationMode
public enum class TypeOperationMode
type TypeOperationMode
Members
Member name | Value | Description
Normal | 0 | Normal
Shutdown | 1 | Shutdown
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Lm75a.TypeOsFaultQueue Enumeration

IRD

Lm75aTypeOsFaultQueue Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOsFaultQueue
Public Enumeration TypeOsFaultQueue
public enum class TypeOsFaultQueue
type TypeOsFaultQueue
Members
Member name | Value | Description
QueueValue1 | 0 | Queue Value = 1
QueueValue2 | 1 | Queue Value = 2
QueueValue4 | 2 | Queue Value = 4
QueueValue6 | 3 | Queue Value = 6
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Lm75a.TypeOsOperationModeSelection Enumeration

IRD

Lm75aTypeOsOperationModeSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOsOperationModeSelection
Public Enumeration TypeOsOperationModeSelection
public enum class TypeOsOperationModeSelection
type TypeOsOperationModeSelection
Members
Member name | Value | Description
OSComparator | 0 | OS Comparator
OSInterrupt | 1 | OS Interrupt
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Lm75a.TypeOsPolaritySelection Enumeration

IRD

Lm75aTypeOsPolaritySelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOsPolaritySelection
Public Enumeration TypeOsPolaritySelection
public enum class TypeOsPolaritySelection
type TypeOsPolaritySelection
Members
Member name | Value | Description
OSActiveLow | 0 | OS Active: Low
OSActiveHigh | 1 | OS Active: High
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Ne1617a Class

NXP Semiconductors: NE 1617A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsNe1617a

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Ne1617a
Public Class Ne1617a
public ref class Ne1617a
type Ne1617a =  class end

The Ne1617a type exposes the following members.

Constructors
 | Name | Description
Public method | Ne1617a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationMASK | Configuration: MASK
Public property | ConfigurationRUNSTOP | Configuration: RUN/STOP
Public property | ConversionRate | Conversion Rate (unit: Hz)
Public property | ExternalTemperature | External Temperature (unit: °C)
Public property | ExternalTemperatureHighLimit | External Temperature High Limit (unit: °C)
Public property | ExternalTemperatureLowLimit | External Temperature Low Limit (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | InternalTemperatureHighLimit | Internal Temperature High Limit (unit: °C)
Public property | InternalTemperatureLowLimit | Internal Temperature Low Limit (unit: °C)
Public property | StatusBUSY | Status: BUSY
Public property | StatusEHLF | Status: EHLF
Public property | StatusELLF | Status: ELLF
Public property | StatusIHLF | Status: IHLF
Public property | StatusILLF | Status: ILLF
Public property | StatusOPEN | Status: OPEN
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShotCommand | One Shot Command
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Temperature Monitor For Microprocessor Systems
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Ne1617a Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ne1617a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Ne1617a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Ne1617a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a Properties

The Ne1617a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationMASK | Configuration: MASK
Public property | ConfigurationRUNSTOP | Configuration: RUN/STOP
Public property | ConversionRate | Conversion Rate (unit: Hz)
Public property | ExternalTemperature | External Temperature (unit: °C)
Public property | ExternalTemperatureHighLimit | External Temperature High Limit (unit: °C)
Public property | ExternalTemperatureLowLimit | External Temperature Low Limit (unit: °C)
Public property | InternalTemperature | Internal Temperature (unit: °C)
Public property | InternalTemperatureHighLimit | Internal Temperature High Limit (unit: °C)
Public property | InternalTemperatureLowLimit | Internal Temperature Low Limit (unit: °C)
Public property | StatusBUSY | Status: BUSY
Public property | StatusEHLF | Status: EHLF
Public property | StatusELLF | Status: ELLF
Public property | StatusIHLF | Status: IHLF
Public property | StatusILLF | Status: ILLF
Public property | StatusOPEN | Status: OPEN
Top
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.AutoFlush Property

IRD

Ne1617aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.ConfigurationMASK Property

IRD

Ne1617aConfigurationMASK Property

Configuration: MASK

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ne1617aTypeConfigurationMask ConfigurationMASK { get; set; }
Public Property ConfigurationMASK As Ne1617aTypeConfigurationMask
    Get
    Set
public:
property Ne1617aTypeConfigurationMask ConfigurationMASK {
    Ne1617aTypeConfigurationMask get ();
    void set (Ne1617aTypeConfigurationMask value);
}
member ConfigurationMASK : Ne1617aTypeConfigurationMask with get, set

Property Value

Type: Ne1617aTypeConfigurationMask
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.ConfigurationRUNSTOP Property

IRD

Ne1617aConfigurationRUNSTOP Property

Configuration: RUN/STOP

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ne1617aTypeConfigurationRunStop ConfigurationRUNSTOP { get; set; }
Public Property ConfigurationRUNSTOP As Ne1617aTypeConfigurationRunStop
    Get
    Set
public:
property Ne1617aTypeConfigurationRunStop ConfigurationRUNSTOP {
    Ne1617aTypeConfigurationRunStop get ();
    void set (Ne1617aTypeConfigurationRunStop value);
}
member ConfigurationRUNSTOP : Ne1617aTypeConfigurationRunStop with get, set

Property Value

Type: Ne1617aTypeConfigurationRunStop
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.ConversionRate Property

IRD

Ne1617aConversionRate Property

Conversion Rate (unit: Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ne1617aTypeConversionRate ConversionRate { get; set; }
Public Property ConversionRate As Ne1617aTypeConversionRate
    Get
    Set
public:
property Ne1617aTypeConversionRate ConversionRate {
    Ne1617aTypeConversionRate get ();
    void set (Ne1617aTypeConversionRate value);
}
member ConversionRate : Ne1617aTypeConversionRate with get, set

Property Value

Type: Ne1617aTypeConversionRate
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.ExternalTemperature Property

IRD

Ne1617aExternalTemperature Property

External Temperature (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperature { get; }
Public ReadOnly Property ExternalTemperature As SByte
    Get
public:
property signed char ExternalTemperature {
    signed char get ();
}
member ExternalTemperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.ExternalTemperatureHighLimit Property

IRD

Ne1617aExternalTemperatureHighLimit Property

External Temperature High Limit (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperatureHighLimit { get; set; }
Public Property ExternalTemperatureHighLimit As SByte
    Get
    Set
public:
property signed char ExternalTemperatureHighLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalTemperatureHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.ExternalTemperatureLowLimit Property

IRD

Ne1617aExternalTemperatureLowLimit Property

External Temperature Low Limit (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ExternalTemperatureLowLimit { get; set; }
Public Property ExternalTemperatureLowLimit As SByte
    Get
    Set
public:
property signed char ExternalTemperatureLowLimit {
    signed char get ();
    void set (signed char value);
}
member ExternalTemperatureLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.InternalTemperature Property

IRD

Ne1617aInternalTemperature Property

Internal Temperature (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperature { get; }
Public ReadOnly Property InternalTemperature As SByte
    Get
public:
property signed char InternalTemperature {
    signed char get ();
}
member InternalTemperature : sbyte with get

Property Value

Type: SByte
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.InternalTemperatureHighLimit Property

IRD

Ne1617aInternalTemperatureHighLimit Property

Internal Temperature High Limit (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureHighLimit { get; set; }
Public Property InternalTemperatureHighLimit As SByte
    Get
    Set
public:
property signed char InternalTemperatureHighLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTemperatureHighLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.InternalTemperatureLowLimit Property

IRD

Ne1617aInternalTemperatureLowLimit Property

Internal Temperature Low Limit (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte InternalTemperatureLowLimit { get; set; }
Public Property InternalTemperatureLowLimit As SByte
    Get
    Set
public:
property signed char InternalTemperatureLowLimit {
    signed char get ();
    void set (signed char value);
}
member InternalTemperatureLowLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.StatusBUSY Property

IRD

Ne1617aStatusBUSY Property

Status: BUSY

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ne1617aTypeStatusBusy StatusBUSY { get; }
Public ReadOnly Property StatusBUSY As Ne1617aTypeStatusBusy
    Get
public:
property Ne1617aTypeStatusBusy StatusBUSY {
    Ne1617aTypeStatusBusy get ();
}
member StatusBUSY : Ne1617aTypeStatusBusy with get

Property Value

Type: Ne1617aTypeStatusBusy
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.StatusEHLF Property

IRD

Ne1617aStatusEHLF Property

Status: EHLF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ne1617aTypeStatusExternalTempHighLimit StatusEHLF { get; }
Public ReadOnly Property StatusEHLF As Ne1617aTypeStatusExternalTempHighLimit
    Get
public:
property Ne1617aTypeStatusExternalTempHighLimit StatusEHLF {
    Ne1617aTypeStatusExternalTempHighLimit get ();
}
member StatusEHLF : Ne1617aTypeStatusExternalTempHighLimit with get

Property Value

Type: Ne1617aTypeStatusExternalTempHighLimit
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.StatusELLF Property

IRD

Ne1617aStatusELLF Property

Status: ELLF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ne1617aTypeStatusExternalTempLowLimit StatusELLF { get; }
Public ReadOnly Property StatusELLF As Ne1617aTypeStatusExternalTempLowLimit
    Get
public:
property Ne1617aTypeStatusExternalTempLowLimit StatusELLF {
    Ne1617aTypeStatusExternalTempLowLimit get ();
}
member StatusELLF : Ne1617aTypeStatusExternalTempLowLimit with get

Property Value

Type: Ne1617aTypeStatusExternalTempLowLimit
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.StatusIHLF Property

IRD

Ne1617aStatusIHLF Property

Status: IHLF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ne1617aTypeStatusInternalTempHighLimit StatusIHLF { get; }
Public ReadOnly Property StatusIHLF As Ne1617aTypeStatusInternalTempHighLimit
    Get
public:
property Ne1617aTypeStatusInternalTempHighLimit StatusIHLF {
    Ne1617aTypeStatusInternalTempHighLimit get ();
}
member StatusIHLF : Ne1617aTypeStatusInternalTempHighLimit with get

Property Value

Type: Ne1617aTypeStatusInternalTempHighLimit
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.StatusILLF Property

IRD

Ne1617aStatusILLF Property

Status: ILLF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ne1617aTypeStatusInternalTempLowLimit StatusILLF { get; }
Public ReadOnly Property StatusILLF As Ne1617aTypeStatusInternalTempLowLimit
    Get
public:
property Ne1617aTypeStatusInternalTempLowLimit StatusILLF {
    Ne1617aTypeStatusInternalTempLowLimit get ();
}
member StatusILLF : Ne1617aTypeStatusInternalTempLowLimit with get

Property Value

Type: Ne1617aTypeStatusInternalTempLowLimit
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.StatusOPEN Property

IRD

Ne1617aStatusOPEN Property

Status: OPEN

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Ne1617aTypeStatusOpen StatusOPEN { get; }
Public ReadOnly Property StatusOPEN As Ne1617aTypeStatusOpen
    Get
public:
property Ne1617aTypeStatusOpen StatusOPEN {
    Ne1617aTypeStatusOpen get ();
}
member StatusOPEN : Ne1617aTypeStatusOpen with get

Property Value

Type: Ne1617aTypeStatusOpen
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a Methods

The Ne1617a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShotCommand | One Shot Command
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.Flush Method

IRD

Ne1617aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.OneShotCommand Method

IRD

Ne1617aOneShotCommand Method

One Shot Command

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void OneShotCommand()
Public Sub OneShotCommand
public:
void OneShotCommand()
member OneShotCommand : unit -> unit
See Also

Reference

Ne1617a Class
telos.Ird.NXPSemiconductors Namespace


Ne1617a.TypeConfigurationMask Enumeration

IRD

Ne1617aTypeConfigurationMask Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationMask
Public Enumeration TypeConfigurationMask
public enum class TypeConfigurationMask
type TypeConfigurationMask
Members
Member name | Value | Description
MaskAlertInterruptEnabled | 0 | Mask Alert Interrupt: Enabled
MaskAlertInterruptDisabled | 1 | Mask Alert Interrupt: Disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Ne1617a.TypeConfigurationRunStop Enumeration

IRD

Ne1617aTypeConfigurationRunStop Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationRunStop
Public Enumeration TypeConfigurationRunStop
public enum class TypeConfigurationRunStop
type TypeConfigurationRunStop
Members
Member name | Value | Description
RunningModeEnabled | 0 | Running Mode Enabled
StandbyModeInitiated | 1 | Standby Mode Initiated
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Ne1617a.TypeConversionRate Enumeration

IRD

Ne1617aTypeConversionRate Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConversionRate
Public Enumeration TypeConversionRate
public enum class TypeConversionRate
type TypeConversionRate
Members
Member name | Value | Description
ConversionRate00625 | 0 | Conversion-Rate: 0.0625
ConversionRate0125 | 1 | Conversion-Rate: 0.125
ConversionRate025 | 2 | Conversion-Rate: 0.25
ConversionRate05 | 3 | Conversion-Rate: 0.5
ConversionRate1 | 4 | Conversion-Rate: 1
ConversionRate2 | 5 | Conversion-Rate: 2
ConversionRate4 | 6 | Conversion-Rate: 4
ConversionRate8 | 7 | Conversion-Rate: 8
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Ne1617a.TypeStatusBusy Enumeration

IRD

Ne1617aTypeStatusBusy Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusBusy
Public Enumeration TypeStatusBusy
public enum class TypeStatusBusy
type TypeStatusBusy
Members
Member name | Value | Description
ADCConvertingNotBusy | 0 | ADC Converting: Not Busy
ADCConvertingBusy | 1 | ADC Converting: Busy
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Ne1617a.TypeStatusExternalTempHighLimit Enumeration

IRD

Ne1617aTypeStatusExternalTempHighLimit Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusExternalTempHighLimit
Public Enumeration TypeStatusExternalTempHighLimit
public enum class TypeStatusExternalTempHighLimit
type TypeStatusExternalTempHighLimit
Members
Member name | Value | Description
ExternalTemperatureHighLimitNotExceeded | 0 | External Temperature High Limit: Not Exceeded
ExternalTemperatureHighLimitExceeded | 1 | External Temperature High Limit: Exceeded
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Ne1617a.TypeStatusExternalTempLowLimit Enumeration

IRD

Ne1617aTypeStatusExternalTempLowLimit Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusExternalTempLowLimit
Public Enumeration TypeStatusExternalTempLowLimit
public enum class TypeStatusExternalTempLowLimit
type TypeStatusExternalTempLowLimit
Members
Member name | Value | Description
ExternalTemperatureLowLimitNotExceeded | 0 | External Temperature Low Limit: Not Exceeded
ExternalTemperatureLowLimitExceeded | 1 | External Temperature Low Limit: Exceeded
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Ne1617a.TypeStatusInternalTempHighLimit Enumeration

IRD

Ne1617aTypeStatusInternalTempHighLimit Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusInternalTempHighLimit
Public Enumeration TypeStatusInternalTempHighLimit
public enum class TypeStatusInternalTempHighLimit
type TypeStatusInternalTempHighLimit
Members
Member name | Value | Description
InternalTemperatureHighLimitNotExceeded | 0 | Internal Temperature High Limit: Not Exceeded
InternalTemperatureHighLimitExceeded | 1 | Internal Temperature High Limit: Exceeded
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Ne1617a.TypeStatusInternalTempLowLimit Enumeration

IRD

Ne1617aTypeStatusInternalTempLowLimit Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusInternalTempLowLimit
Public Enumeration TypeStatusInternalTempLowLimit
public enum class TypeStatusInternalTempLowLimit
type TypeStatusInternalTempLowLimit
Members
Member name | Value | Description
InternalTemperatureLowLimitNotExceeded | 0 | Internal Temperature Low Limit: Not Exceeded
InternalTemperatureLowLimitExceeded | 1 | Internal Temperature Low Limit: Exceeded
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Ne1617a.TypeStatusOpen Enumeration

IRD

Ne1617aTypeStatusOpen Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusOpen
Public Enumeration TypeStatusOpen
public enum class TypeStatusOpen
type TypeStatusOpen
Members
Member name | Value | Description
ExternalDiodesNotOpen | 0 | External Diodes: Not Open
ExternalDiodesOpen | 1 | External Diodes: Open
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca6408a Class

NXP Semiconductors: PCA 6408A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca6408a

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca6408a
Public Class Pca6408a
public ref class Pca6408a
type Pca6408a =  class end

The Pca6408a type exposes the following members.

Constructors
 | Name | Description
Public method | Pca6408a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC0 | Configuration: C0
Public property | ConfigurationC1 | Configuration: C1
Public property | ConfigurationC2 | Configuration: C2
Public property | ConfigurationC3 | Configuration: C3
Public property | ConfigurationC4 | Configuration: C4
Public property | ConfigurationC5 | Configuration: C5
Public property | ConfigurationC6 | Configuration: C6
Public property | ConfigurationC7 | Configuration: C7
Public property | InputI0 | Input: I0
Public property | InputI1 | Input: I1
Public property | InputI2 | Input: I2
Public property | InputI3 | Input: I3
Public property | InputI4 | Input: I4
Public property | InputI5 | Input: I5
Public property | InputI6 | Input: I6
Public property | InputI7 | Input: I7
Public property | OutputO0 | Output: O0
Public property | OutputO1 | Output: O1
Public property | OutputO2 | Output: O2
Public property | OutputO3 | Output: O3
Public property | OutputO4 | Output: O4
Public property | OutputO5 | Output: O5
Public property | OutputO6 | Output: O6
Public property | OutputO7 | Output: O7
Public property | PolarityInversionN0 | Polarity Inversion: N0
Public property | PolarityInversionN1 | Polarity Inversion: N1
Public property | PolarityInversionN2 | Polarity Inversion: N2
Public property | PolarityInversionN3 | Polarity Inversion: N3
Public property | PolarityInversionN4 | Polarity Inversion: N4
Public property | PolarityInversionN5 | Polarity Inversion: N5
Public property | PolarityInversionN6 | Polarity Inversion: N6
Public property | PolarityInversionN7 | Polarity Inversion: N7
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Voltage, 8-Bit I2C-Bus And SMBus I/O Expander With Interrupt Output, Reset, And Configuration Registers
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca6408a Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6408a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca6408a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca6408a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a Properties

The Pca6408a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC0 | Configuration: C0
Public property | ConfigurationC1 | Configuration: C1
Public property | ConfigurationC2 | Configuration: C2
Public property | ConfigurationC3 | Configuration: C3
Public property | ConfigurationC4 | Configuration: C4
Public property | ConfigurationC5 | Configuration: C5
Public property | ConfigurationC6 | Configuration: C6
Public property | ConfigurationC7 | Configuration: C7
Public property | InputI0 | Input: I0
Public property | InputI1 | Input: I1
Public property | InputI2 | Input: I2
Public property | InputI3 | Input: I3
Public property | InputI4 | Input: I4
Public property | InputI5 | Input: I5
Public property | InputI6 | Input: I6
Public property | InputI7 | Input: I7
Public property | OutputO0 | Output: O0
Public property | OutputO1 | Output: O1
Public property | OutputO2 | Output: O2
Public property | OutputO3 | Output: O3
Public property | OutputO4 | Output: O4
Public property | OutputO5 | Output: O5
Public property | OutputO6 | Output: O6
Public property | OutputO7 | Output: O7
Public property | PolarityInversionN0 | Polarity Inversion: N0
Public property | PolarityInversionN1 | Polarity Inversion: N1
Public property | PolarityInversionN2 | Polarity Inversion: N2
Public property | PolarityInversionN3 | Polarity Inversion: N3
Public property | PolarityInversionN4 | Polarity Inversion: N4
Public property | PolarityInversionN5 | Polarity Inversion: N5
Public property | PolarityInversionN6 | Polarity Inversion: N6
Public property | PolarityInversionN7 | Polarity Inversion: N7
Top
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.AutoFlush Property

IRD

Pca6408aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.ConfigurationC0 Property

IRD

Pca6408aConfigurationC0 Property

Configuration: C0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6408aTypeConfiguration ConfigurationC0 { get; set; }
Public Property ConfigurationC0 As Pca6408aTypeConfiguration
    Get
    Set
public:
property Pca6408aTypeConfiguration ConfigurationC0 {
    Pca6408aTypeConfiguration get ();
    void set (Pca6408aTypeConfiguration value);
}
member ConfigurationC0 : Pca6408aTypeConfiguration with get, set

Property Value

Type: Pca6408aTypeConfiguration
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.ConfigurationC1 Property

IRD

Pca6408aConfigurationC1 Property

Configuration: C1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6408aTypeConfiguration ConfigurationC1 { get; set; }
Public Property ConfigurationC1 As Pca6408aTypeConfiguration
    Get
    Set
public:
property Pca6408aTypeConfiguration ConfigurationC1 {
    Pca6408aTypeConfiguration get ();
    void set (Pca6408aTypeConfiguration value);
}
member ConfigurationC1 : Pca6408aTypeConfiguration with get, set

Property Value

Type: Pca6408aTypeConfiguration
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.ConfigurationC2 Property

IRD

Pca6408aConfigurationC2 Property

Configuration: C2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6408aTypeConfiguration ConfigurationC2 { get; set; }
Public Property ConfigurationC2 As Pca6408aTypeConfiguration
    Get
    Set
public:
property Pca6408aTypeConfiguration ConfigurationC2 {
    Pca6408aTypeConfiguration get ();
    void set (Pca6408aTypeConfiguration value);
}
member ConfigurationC2 : Pca6408aTypeConfiguration with get, set

Property Value

Type: Pca6408aTypeConfiguration
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.ConfigurationC3 Property

IRD

Pca6408aConfigurationC3 Property

Configuration: C3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6408aTypeConfiguration ConfigurationC3 { get; set; }
Public Property ConfigurationC3 As Pca6408aTypeConfiguration
    Get
    Set
public:
property Pca6408aTypeConfiguration ConfigurationC3 {
    Pca6408aTypeConfiguration get ();
    void set (Pca6408aTypeConfiguration value);
}
member ConfigurationC3 : Pca6408aTypeConfiguration with get, set

Property Value

Type: Pca6408aTypeConfiguration
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.ConfigurationC4 Property

IRD

Pca6408aConfigurationC4 Property

Configuration: C4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6408aTypeConfiguration ConfigurationC4 { get; set; }
Public Property ConfigurationC4 As Pca6408aTypeConfiguration
    Get
    Set
public:
property Pca6408aTypeConfiguration ConfigurationC4 {
    Pca6408aTypeConfiguration get ();
    void set (Pca6408aTypeConfiguration value);
}
member ConfigurationC4 : Pca6408aTypeConfiguration with get, set

Property Value

Type: Pca6408aTypeConfiguration
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.ConfigurationC5 Property

IRD

Pca6408aConfigurationC5 Property

Configuration: C5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6408aTypeConfiguration ConfigurationC5 { get; set; }
Public Property ConfigurationC5 As Pca6408aTypeConfiguration
    Get
    Set
public:
property Pca6408aTypeConfiguration ConfigurationC5 {
    Pca6408aTypeConfiguration get ();
    void set (Pca6408aTypeConfiguration value);
}
member ConfigurationC5 : Pca6408aTypeConfiguration with get, set

Property Value

Type: Pca6408aTypeConfiguration
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.ConfigurationC6 Property

IRD

Pca6408aConfigurationC6 Property

Configuration: C6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6408aTypeConfiguration ConfigurationC6 { get; set; }
Public Property ConfigurationC6 As Pca6408aTypeConfiguration
    Get
    Set
public:
property Pca6408aTypeConfiguration ConfigurationC6 {
    Pca6408aTypeConfiguration get ();
    void set (Pca6408aTypeConfiguration value);
}
member ConfigurationC6 : Pca6408aTypeConfiguration with get, set

Property Value

Type: Pca6408aTypeConfiguration
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.ConfigurationC7 Property

IRD

Pca6408aConfigurationC7 Property

Configuration: C7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6408aTypeConfiguration ConfigurationC7 { get; set; }
Public Property ConfigurationC7 As Pca6408aTypeConfiguration
    Get
    Set
public:
property Pca6408aTypeConfiguration ConfigurationC7 {
    Pca6408aTypeConfiguration get ();
    void set (Pca6408aTypeConfiguration value);
}
member ConfigurationC7 : Pca6408aTypeConfiguration with get, set

Property Value

Type: Pca6408aTypeConfiguration
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.InputI0 Property

IRD

Pca6408aInputI0 Property

Input: I0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI0 { get; }
Public ReadOnly Property InputI0 As Byte
    Get
public:
property unsigned char InputI0 {
    unsigned char get ();
}
member InputI0 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.InputI1 Property

IRD

Pca6408aInputI1 Property

Input: I1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI1 { get; }
Public ReadOnly Property InputI1 As Byte
    Get
public:
property unsigned char InputI1 {
    unsigned char get ();
}
member InputI1 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.InputI2 Property

IRD

Pca6408aInputI2 Property

Input: I2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI2 { get; }
Public ReadOnly Property InputI2 As Byte
    Get
public:
property unsigned char InputI2 {
    unsigned char get ();
}
member InputI2 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.InputI3 Property

IRD

Pca6408aInputI3 Property

Input: I3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI3 { get; }
Public ReadOnly Property InputI3 As Byte
    Get
public:
property unsigned char InputI3 {
    unsigned char get ();
}
member InputI3 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.InputI4 Property

IRD

Pca6408aInputI4 Property

Input: I4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI4 { get; }
Public ReadOnly Property InputI4 As Byte
    Get
public:
property unsigned char InputI4 {
    unsigned char get ();
}
member InputI4 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.InputI5 Property

IRD

Pca6408aInputI5 Property

Input: I5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI5 { get; }
Public ReadOnly Property InputI5 As Byte
    Get
public:
property unsigned char InputI5 {
    unsigned char get ();
}
member InputI5 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.InputI6 Property

IRD

Pca6408aInputI6 Property

Input: I6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI6 { get; }
Public ReadOnly Property InputI6 As Byte
    Get
public:
property unsigned char InputI6 {
    unsigned char get ();
}
member InputI6 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.InputI7 Property

IRD

Pca6408aInputI7 Property

Input: I7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI7 { get; }
Public ReadOnly Property InputI7 As Byte
    Get
public:
property unsigned char InputI7 {
    unsigned char get ();
}
member InputI7 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.OutputO0 Property

IRD

Pca6408aOutputO0 Property

Output: O0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO0 { get; set; }
Public Property OutputO0 As Byte
    Get
    Set
public:
property unsigned char OutputO0 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.OutputO1 Property

IRD

Pca6408aOutputO1 Property

Output: O1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO1 { get; set; }
Public Property OutputO1 As Byte
    Get
    Set
public:
property unsigned char OutputO1 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.OutputO2 Property

IRD

Pca6408aOutputO2 Property

Output: O2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO2 { get; set; }
Public Property OutputO2 As Byte
    Get
    Set
public:
property unsigned char OutputO2 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.OutputO3 Property

IRD

Pca6408aOutputO3 Property

Output: O3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO3 { get; set; }
Public Property OutputO3 As Byte
    Get
    Set
public:
property unsigned char OutputO3 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.OutputO4 Property

IRD

Pca6408aOutputO4 Property

Output: O4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO4 { get; set; }
Public Property OutputO4 As Byte
    Get
    Set
public:
property unsigned char OutputO4 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.OutputO5 Property

IRD

Pca6408aOutputO5 Property

Output: O5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO5 { get; set; }
Public Property OutputO5 As Byte
    Get
    Set
public:
property unsigned char OutputO5 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.OutputO6 Property

IRD

Pca6408aOutputO6 Property

Output: O6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO6 { get; set; }
Public Property OutputO6 As Byte
    Get
    Set
public:
property unsigned char OutputO6 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.OutputO7 Property

IRD

Pca6408aOutputO7 Property

Output: O7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO7 { get; set; }
Public Property OutputO7 As Byte
    Get
    Set
public:
property unsigned char OutputO7 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.PolarityInversionN0 Property

IRD

Pca6408aPolarityInversionN0 Property

Polarity Inversion: N0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6408aTypeInversion PolarityInversionN0 { get; set; }
Public Property PolarityInversionN0 As Pca6408aTypeInversion
    Get
    Set
public:
property Pca6408aTypeInversion PolarityInversionN0 {
    Pca6408aTypeInversion get ();
    void set (Pca6408aTypeInversion value);
}
member PolarityInversionN0 : Pca6408aTypeInversion with get, set

Property Value

Type: Pca6408aTypeInversion
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.PolarityInversionN1 Property

IRD

Pca6408aPolarityInversionN1 Property

Polarity Inversion: N1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6408aTypeInversion PolarityInversionN1 { get; set; }
Public Property PolarityInversionN1 As Pca6408aTypeInversion
    Get
    Set
public:
property Pca6408aTypeInversion PolarityInversionN1 {
    Pca6408aTypeInversion get ();
    void set (Pca6408aTypeInversion value);
}
member PolarityInversionN1 : Pca6408aTypeInversion with get, set

Property Value

Type: Pca6408aTypeInversion
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.PolarityInversionN2 Property

IRD

Pca6408aPolarityInversionN2 Property

Polarity Inversion: N2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6408aTypeInversion PolarityInversionN2 { get; set; }
Public Property PolarityInversionN2 As Pca6408aTypeInversion
    Get
    Set
public:
property Pca6408aTypeInversion PolarityInversionN2 {
    Pca6408aTypeInversion get ();
    void set (Pca6408aTypeInversion value);
}
member PolarityInversionN2 : Pca6408aTypeInversion with get, set

Property Value

Type: Pca6408aTypeInversion
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.PolarityInversionN3 Property

IRD

Pca6408aPolarityInversionN3 Property

Polarity Inversion: N3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6408aTypeInversion PolarityInversionN3 { get; set; }
Public Property PolarityInversionN3 As Pca6408aTypeInversion
    Get
    Set
public:
property Pca6408aTypeInversion PolarityInversionN3 {
    Pca6408aTypeInversion get ();
    void set (Pca6408aTypeInversion value);
}
member PolarityInversionN3 : Pca6408aTypeInversion with get, set

Property Value

Type: Pca6408aTypeInversion
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.PolarityInversionN4 Property

IRD

Pca6408aPolarityInversionN4 Property

Polarity Inversion: N4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6408aTypeInversion PolarityInversionN4 { get; set; }
Public Property PolarityInversionN4 As Pca6408aTypeInversion
    Get
    Set
public:
property Pca6408aTypeInversion PolarityInversionN4 {
    Pca6408aTypeInversion get ();
    void set (Pca6408aTypeInversion value);
}
member PolarityInversionN4 : Pca6408aTypeInversion with get, set

Property Value

Type: Pca6408aTypeInversion
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.PolarityInversionN5 Property

IRD

Pca6408aPolarityInversionN5 Property

Polarity Inversion: N5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6408aTypeInversion PolarityInversionN5 { get; set; }
Public Property PolarityInversionN5 As Pca6408aTypeInversion
    Get
    Set
public:
property Pca6408aTypeInversion PolarityInversionN5 {
    Pca6408aTypeInversion get ();
    void set (Pca6408aTypeInversion value);
}
member PolarityInversionN5 : Pca6408aTypeInversion with get, set

Property Value

Type: Pca6408aTypeInversion
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.PolarityInversionN6 Property

IRD

Pca6408aPolarityInversionN6 Property

Polarity Inversion: N6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6408aTypeInversion PolarityInversionN6 { get; set; }
Public Property PolarityInversionN6 As Pca6408aTypeInversion
    Get
    Set
public:
property Pca6408aTypeInversion PolarityInversionN6 {
    Pca6408aTypeInversion get ();
    void set (Pca6408aTypeInversion value);
}
member PolarityInversionN6 : Pca6408aTypeInversion with get, set

Property Value

Type: Pca6408aTypeInversion
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.PolarityInversionN7 Property

IRD

Pca6408aPolarityInversionN7 Property

Polarity Inversion: N7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6408aTypeInversion PolarityInversionN7 { get; set; }
Public Property PolarityInversionN7 As Pca6408aTypeInversion
    Get
    Set
public:
property Pca6408aTypeInversion PolarityInversionN7 {
    Pca6408aTypeInversion get ();
    void set (Pca6408aTypeInversion value);
}
member PolarityInversionN7 : Pca6408aTypeInversion with get, set

Property Value

Type: Pca6408aTypeInversion
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a Methods

The Pca6408a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.Flush Method

IRD

Pca6408aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca6408a Class
telos.Ird.NXPSemiconductors Namespace


Pca6408a.TypeConfiguration Enumeration

IRD

Pca6408aTypeConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Output | 0 | Output
Input | 1 | Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca6408a.TypeInversion Enumeration

IRD

Pca6408aTypeInversion Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInversion
Public Enumeration TypeInversion
public enum class TypeInversion
type TypeInversion
Members
Member name | Value | Description
NotInverted | 0 | Not Inverted
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca6416a Class

NXP Semiconductors: PCA 6416A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca6416a

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca6416a
Public Class Pca6416a
public ref class Pca6416a
type Pca6416a =  class end

The Pca6416a type exposes the following members.

Constructors
 | Name | Description
Public method | Pca6416a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration: C0.0
Public property | ConfigurationC01 | Configuration: C0.1
Public property | ConfigurationC02 | Configuration: C0.2
Public property | ConfigurationC03 | Configuration: C0.3
Public property | ConfigurationC04 | Configuration: C0.4
Public property | ConfigurationC05 | Configuration: C0.5
Public property | ConfigurationC06 | Configuration: C0.6
Public property | ConfigurationC07 | Configuration: C0.7
Public property | ConfigurationC10 | Configuration: C1.0
Public property | ConfigurationC11 | Configuration: C1.1
Public property | ConfigurationC12 | Configuration: C1.2
Public property | ConfigurationC13 | Configuration: C1.3
Public property | ConfigurationC14 | Configuration: C1.4
Public property | ConfigurationC15 | Configuration: C1.5
Public property | ConfigurationC16 | Configuration: C1.6
Public property | ConfigurationC17 | Configuration: C1.7
Public property | InputI00 | Input: I0.0
Public property | InputI01 | Input: I0.1
Public property | InputI02 | Input: I0.2
Public property | InputI03 | Input: I0.3
Public property | InputI04 | Input: I0.4
Public property | InputI05 | Input: I0.5
Public property | InputI06 | Input: I0.6
Public property | InputI07 | Input: I0.7
Public property | InputI10 | Input: I1.0
Public property | InputI11 | Input: I1.1
Public property | InputI12 | Input: I1.2
Public property | InputI13 | Input: I1.3
Public property | InputI14 | Input: I1.4
Public property | InputI15 | Input: I1.5
Public property | InputI16 | Input: I1.6
Public property | InputI17 | Input: I1.7
Public property | OutputO00 | Output: O0.0
Public property | OutputO01 | Output: O0.1
Public property | OutputO02 | Output: O0.2
Public property | OutputO03 | Output: O0.3
Public property | OutputO04 | Output: O0.4
Public property | OutputO05 | Output: O0.5
Public property | OutputO06 | Output: O0.6
Public property | OutputO07 | Output: O0.7
Public property | OutputO10 | Output: O1.0
Public property | OutputO11 | Output: O1.1
Public property | OutputO12 | Output: O1.2
Public property | OutputO13 | Output: O1.3
Public property | OutputO14 | Output: O1.4
Public property | OutputO15 | Output: O1.5
Public property | OutputO16 | Output: O1.6
Public property | OutputO17 | Output: O1.7
Public property | PolarityInversionN00 | Polarity Inversion: N0.0
Public property | PolarityInversionN01 | Polarity Inversion: N0.1
Public property | PolarityInversionN02 | Polarity Inversion: N0.2
Public property | PolarityInversionN03 | Polarity Inversion: N0.3
Public property | PolarityInversionN04 | Polarity Inversion: N0.4
Public property | PolarityInversionN05 | Polarity Inversion: N0.5
Public property | PolarityInversionN06 | Polarity Inversion: N0.6
Public property | PolarityInversionN07 | Polarity Inversion: N0.7
Public property | PolarityInversionN10 | Polarity Inversion: N1.0
Public property | PolarityInversionN11 | Polarity Inversion: N1.1
Public property | PolarityInversionN12 | Polarity Inversion: N1.2
Public property | PolarityInversionN13 | Polarity Inversion: N1.3
Public property | PolarityInversionN14 | Polarity Inversion: N1.4
Public property | PolarityInversionN15 | Polarity Inversion: N1.5
Public property | PolarityInversionN16 | Polarity Inversion: N1.6
Public property | PolarityInversionN17 | Polarity Inversion: N1.7
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Voltage Translating 16-Bit I2C-Bus/SMBus I/O Expander With Interrupt Output, Reset, And Configuration Registers
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca6416a Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca6416a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca6416a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a Properties

The Pca6416a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration: C0.0
Public property | ConfigurationC01 | Configuration: C0.1
Public property | ConfigurationC02 | Configuration: C0.2
Public property | ConfigurationC03 | Configuration: C0.3
Public property | ConfigurationC04 | Configuration: C0.4
Public property | ConfigurationC05 | Configuration: C0.5
Public property | ConfigurationC06 | Configuration: C0.6
Public property | ConfigurationC07 | Configuration: C0.7
Public property | ConfigurationC10 | Configuration: C1.0
Public property | ConfigurationC11 | Configuration: C1.1
Public property | ConfigurationC12 | Configuration: C1.2
Public property | ConfigurationC13 | Configuration: C1.3
Public property | ConfigurationC14 | Configuration: C1.4
Public property | ConfigurationC15 | Configuration: C1.5
Public property | ConfigurationC16 | Configuration: C1.6
Public property | ConfigurationC17 | Configuration: C1.7
Public property | InputI00 | Input: I0.0
Public property | InputI01 | Input: I0.1
Public property | InputI02 | Input: I0.2
Public property | InputI03 | Input: I0.3
Public property | InputI04 | Input: I0.4
Public property | InputI05 | Input: I0.5
Public property | InputI06 | Input: I0.6
Public property | InputI07 | Input: I0.7
Public property | InputI10 | Input: I1.0
Public property | InputI11 | Input: I1.1
Public property | InputI12 | Input: I1.2
Public property | InputI13 | Input: I1.3
Public property | InputI14 | Input: I1.4
Public property | InputI15 | Input: I1.5
Public property | InputI16 | Input: I1.6
Public property | InputI17 | Input: I1.7
Public property | OutputO00 | Output: O0.0
Public property | OutputO01 | Output: O0.1
Public property | OutputO02 | Output: O0.2
Public property | OutputO03 | Output: O0.3
Public property | OutputO04 | Output: O0.4
Public property | OutputO05 | Output: O0.5
Public property | OutputO06 | Output: O0.6
Public property | OutputO07 | Output: O0.7
Public property | OutputO10 | Output: O1.0
Public property | OutputO11 | Output: O1.1
Public property | OutputO12 | Output: O1.2
Public property | OutputO13 | Output: O1.3
Public property | OutputO14 | Output: O1.4
Public property | OutputO15 | Output: O1.5
Public property | OutputO16 | Output: O1.6
Public property | OutputO17 | Output: O1.7
Public property | PolarityInversionN00 | Polarity Inversion: N0.0
Public property | PolarityInversionN01 | Polarity Inversion: N0.1
Public property | PolarityInversionN02 | Polarity Inversion: N0.2
Public property | PolarityInversionN03 | Polarity Inversion: N0.3
Public property | PolarityInversionN04 | Polarity Inversion: N0.4
Public property | PolarityInversionN05 | Polarity Inversion: N0.5
Public property | PolarityInversionN06 | Polarity Inversion: N0.6
Public property | PolarityInversionN07 | Polarity Inversion: N0.7
Public property | PolarityInversionN10 | Polarity Inversion: N1.0
Public property | PolarityInversionN11 | Polarity Inversion: N1.1
Public property | PolarityInversionN12 | Polarity Inversion: N1.2
Public property | PolarityInversionN13 | Polarity Inversion: N1.3
Public property | PolarityInversionN14 | Polarity Inversion: N1.4
Public property | PolarityInversionN15 | Polarity Inversion: N1.5
Public property | PolarityInversionN16 | Polarity Inversion: N1.6
Public property | PolarityInversionN17 | Polarity Inversion: N1.7
Top
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.AutoFlush Property

IRD

Pca6416aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.ConfigurationC00 Property

IRD

Pca6416aConfigurationC00 Property

Configuration: C0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeConfiguration ConfigurationC00 { get; set; }
Public Property ConfigurationC00 As Pca6416aTypeConfiguration
    Get
    Set
public:
property Pca6416aTypeConfiguration ConfigurationC00 {
    Pca6416aTypeConfiguration get ();
    void set (Pca6416aTypeConfiguration value);
}
member ConfigurationC00 : Pca6416aTypeConfiguration with get, set

Property Value

Type: Pca6416aTypeConfiguration
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.ConfigurationC01 Property

IRD

Pca6416aConfigurationC01 Property

Configuration: C0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeConfiguration ConfigurationC01 { get; set; }
Public Property ConfigurationC01 As Pca6416aTypeConfiguration
    Get
    Set
public:
property Pca6416aTypeConfiguration ConfigurationC01 {
    Pca6416aTypeConfiguration get ();
    void set (Pca6416aTypeConfiguration value);
}
member ConfigurationC01 : Pca6416aTypeConfiguration with get, set

Property Value

Type: Pca6416aTypeConfiguration
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.ConfigurationC02 Property

IRD

Pca6416aConfigurationC02 Property

Configuration: C0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeConfiguration ConfigurationC02 { get; set; }
Public Property ConfigurationC02 As Pca6416aTypeConfiguration
    Get
    Set
public:
property Pca6416aTypeConfiguration ConfigurationC02 {
    Pca6416aTypeConfiguration get ();
    void set (Pca6416aTypeConfiguration value);
}
member ConfigurationC02 : Pca6416aTypeConfiguration with get, set

Property Value

Type: Pca6416aTypeConfiguration
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.ConfigurationC03 Property

IRD

Pca6416aConfigurationC03 Property

Configuration: C0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeConfiguration ConfigurationC03 { get; set; }
Public Property ConfigurationC03 As Pca6416aTypeConfiguration
    Get
    Set
public:
property Pca6416aTypeConfiguration ConfigurationC03 {
    Pca6416aTypeConfiguration get ();
    void set (Pca6416aTypeConfiguration value);
}
member ConfigurationC03 : Pca6416aTypeConfiguration with get, set

Property Value

Type: Pca6416aTypeConfiguration
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.ConfigurationC04 Property

IRD

Pca6416aConfigurationC04 Property

Configuration: C0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeConfiguration ConfigurationC04 { get; set; }
Public Property ConfigurationC04 As Pca6416aTypeConfiguration
    Get
    Set
public:
property Pca6416aTypeConfiguration ConfigurationC04 {
    Pca6416aTypeConfiguration get ();
    void set (Pca6416aTypeConfiguration value);
}
member ConfigurationC04 : Pca6416aTypeConfiguration with get, set

Property Value

Type: Pca6416aTypeConfiguration
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.ConfigurationC05 Property

IRD

Pca6416aConfigurationC05 Property

Configuration: C0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeConfiguration ConfigurationC05 { get; set; }
Public Property ConfigurationC05 As Pca6416aTypeConfiguration
    Get
    Set
public:
property Pca6416aTypeConfiguration ConfigurationC05 {
    Pca6416aTypeConfiguration get ();
    void set (Pca6416aTypeConfiguration value);
}
member ConfigurationC05 : Pca6416aTypeConfiguration with get, set

Property Value

Type: Pca6416aTypeConfiguration
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.ConfigurationC06 Property

IRD

Pca6416aConfigurationC06 Property

Configuration: C0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeConfiguration ConfigurationC06 { get; set; }
Public Property ConfigurationC06 As Pca6416aTypeConfiguration
    Get
    Set
public:
property Pca6416aTypeConfiguration ConfigurationC06 {
    Pca6416aTypeConfiguration get ();
    void set (Pca6416aTypeConfiguration value);
}
member ConfigurationC06 : Pca6416aTypeConfiguration with get, set

Property Value

Type: Pca6416aTypeConfiguration
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.ConfigurationC07 Property

IRD

Pca6416aConfigurationC07 Property

Configuration: C0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeConfiguration ConfigurationC07 { get; set; }
Public Property ConfigurationC07 As Pca6416aTypeConfiguration
    Get
    Set
public:
property Pca6416aTypeConfiguration ConfigurationC07 {
    Pca6416aTypeConfiguration get ();
    void set (Pca6416aTypeConfiguration value);
}
member ConfigurationC07 : Pca6416aTypeConfiguration with get, set

Property Value

Type: Pca6416aTypeConfiguration
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.ConfigurationC10 Property

IRD

Pca6416aConfigurationC10 Property

Configuration: C1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeConfiguration ConfigurationC10 { get; set; }
Public Property ConfigurationC10 As Pca6416aTypeConfiguration
    Get
    Set
public:
property Pca6416aTypeConfiguration ConfigurationC10 {
    Pca6416aTypeConfiguration get ();
    void set (Pca6416aTypeConfiguration value);
}
member ConfigurationC10 : Pca6416aTypeConfiguration with get, set

Property Value

Type: Pca6416aTypeConfiguration
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.ConfigurationC11 Property

IRD

Pca6416aConfigurationC11 Property

Configuration: C1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeConfiguration ConfigurationC11 { get; set; }
Public Property ConfigurationC11 As Pca6416aTypeConfiguration
    Get
    Set
public:
property Pca6416aTypeConfiguration ConfigurationC11 {
    Pca6416aTypeConfiguration get ();
    void set (Pca6416aTypeConfiguration value);
}
member ConfigurationC11 : Pca6416aTypeConfiguration with get, set

Property Value

Type: Pca6416aTypeConfiguration
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.ConfigurationC12 Property

IRD

Pca6416aConfigurationC12 Property

Configuration: C1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeConfiguration ConfigurationC12 { get; set; }
Public Property ConfigurationC12 As Pca6416aTypeConfiguration
    Get
    Set
public:
property Pca6416aTypeConfiguration ConfigurationC12 {
    Pca6416aTypeConfiguration get ();
    void set (Pca6416aTypeConfiguration value);
}
member ConfigurationC12 : Pca6416aTypeConfiguration with get, set

Property Value

Type: Pca6416aTypeConfiguration
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.ConfigurationC13 Property

IRD

Pca6416aConfigurationC13 Property

Configuration: C1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeConfiguration ConfigurationC13 { get; set; }
Public Property ConfigurationC13 As Pca6416aTypeConfiguration
    Get
    Set
public:
property Pca6416aTypeConfiguration ConfigurationC13 {
    Pca6416aTypeConfiguration get ();
    void set (Pca6416aTypeConfiguration value);
}
member ConfigurationC13 : Pca6416aTypeConfiguration with get, set

Property Value

Type: Pca6416aTypeConfiguration
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.ConfigurationC14 Property

IRD

Pca6416aConfigurationC14 Property

Configuration: C1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeConfiguration ConfigurationC14 { get; set; }
Public Property ConfigurationC14 As Pca6416aTypeConfiguration
    Get
    Set
public:
property Pca6416aTypeConfiguration ConfigurationC14 {
    Pca6416aTypeConfiguration get ();
    void set (Pca6416aTypeConfiguration value);
}
member ConfigurationC14 : Pca6416aTypeConfiguration with get, set

Property Value

Type: Pca6416aTypeConfiguration
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.ConfigurationC15 Property

IRD

Pca6416aConfigurationC15 Property

Configuration: C1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeConfiguration ConfigurationC15 { get; set; }
Public Property ConfigurationC15 As Pca6416aTypeConfiguration
    Get
    Set
public:
property Pca6416aTypeConfiguration ConfigurationC15 {
    Pca6416aTypeConfiguration get ();
    void set (Pca6416aTypeConfiguration value);
}
member ConfigurationC15 : Pca6416aTypeConfiguration with get, set

Property Value

Type: Pca6416aTypeConfiguration
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.ConfigurationC16 Property

IRD

Pca6416aConfigurationC16 Property

Configuration: C1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeConfiguration ConfigurationC16 { get; set; }
Public Property ConfigurationC16 As Pca6416aTypeConfiguration
    Get
    Set
public:
property Pca6416aTypeConfiguration ConfigurationC16 {
    Pca6416aTypeConfiguration get ();
    void set (Pca6416aTypeConfiguration value);
}
member ConfigurationC16 : Pca6416aTypeConfiguration with get, set

Property Value

Type: Pca6416aTypeConfiguration
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.ConfigurationC17 Property

IRD

Pca6416aConfigurationC17 Property

Configuration: C1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeConfiguration ConfigurationC17 { get; set; }
Public Property ConfigurationC17 As Pca6416aTypeConfiguration
    Get
    Set
public:
property Pca6416aTypeConfiguration ConfigurationC17 {
    Pca6416aTypeConfiguration get ();
    void set (Pca6416aTypeConfiguration value);
}
member ConfigurationC17 : Pca6416aTypeConfiguration with get, set

Property Value

Type: Pca6416aTypeConfiguration
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.InputI00 Property

IRD

Pca6416aInputI00 Property

Input: I0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI00 { get; }
Public ReadOnly Property InputI00 As Byte
    Get
public:
property unsigned char InputI00 {
    unsigned char get ();
}
member InputI00 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.InputI01 Property

IRD

Pca6416aInputI01 Property

Input: I0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI01 { get; }
Public ReadOnly Property InputI01 As Byte
    Get
public:
property unsigned char InputI01 {
    unsigned char get ();
}
member InputI01 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.InputI02 Property

IRD

Pca6416aInputI02 Property

Input: I0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI02 { get; }
Public ReadOnly Property InputI02 As Byte
    Get
public:
property unsigned char InputI02 {
    unsigned char get ();
}
member InputI02 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.InputI03 Property

IRD

Pca6416aInputI03 Property

Input: I0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI03 { get; }
Public ReadOnly Property InputI03 As Byte
    Get
public:
property unsigned char InputI03 {
    unsigned char get ();
}
member InputI03 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.InputI04 Property

IRD

Pca6416aInputI04 Property

Input: I0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI04 { get; }
Public ReadOnly Property InputI04 As Byte
    Get
public:
property unsigned char InputI04 {
    unsigned char get ();
}
member InputI04 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.InputI05 Property

IRD

Pca6416aInputI05 Property

Input: I0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI05 { get; }
Public ReadOnly Property InputI05 As Byte
    Get
public:
property unsigned char InputI05 {
    unsigned char get ();
}
member InputI05 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.InputI06 Property

IRD

Pca6416aInputI06 Property

Input: I0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI06 { get; }
Public ReadOnly Property InputI06 As Byte
    Get
public:
property unsigned char InputI06 {
    unsigned char get ();
}
member InputI06 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.InputI07 Property

IRD

Pca6416aInputI07 Property

Input: I0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI07 { get; }
Public ReadOnly Property InputI07 As Byte
    Get
public:
property unsigned char InputI07 {
    unsigned char get ();
}
member InputI07 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.InputI10 Property

IRD

Pca6416aInputI10 Property

Input: I1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI10 { get; }
Public ReadOnly Property InputI10 As Byte
    Get
public:
property unsigned char InputI10 {
    unsigned char get ();
}
member InputI10 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.InputI11 Property

IRD

Pca6416aInputI11 Property

Input: I1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI11 { get; }
Public ReadOnly Property InputI11 As Byte
    Get
public:
property unsigned char InputI11 {
    unsigned char get ();
}
member InputI11 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.InputI12 Property

IRD

Pca6416aInputI12 Property

Input: I1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI12 { get; }
Public ReadOnly Property InputI12 As Byte
    Get
public:
property unsigned char InputI12 {
    unsigned char get ();
}
member InputI12 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.InputI13 Property

IRD

Pca6416aInputI13 Property

Input: I1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI13 { get; }
Public ReadOnly Property InputI13 As Byte
    Get
public:
property unsigned char InputI13 {
    unsigned char get ();
}
member InputI13 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.InputI14 Property

IRD

Pca6416aInputI14 Property

Input: I1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI14 { get; }
Public ReadOnly Property InputI14 As Byte
    Get
public:
property unsigned char InputI14 {
    unsigned char get ();
}
member InputI14 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.InputI15 Property

IRD

Pca6416aInputI15 Property

Input: I1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI15 { get; }
Public ReadOnly Property InputI15 As Byte
    Get
public:
property unsigned char InputI15 {
    unsigned char get ();
}
member InputI15 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.InputI16 Property

IRD

Pca6416aInputI16 Property

Input: I1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI16 { get; }
Public ReadOnly Property InputI16 As Byte
    Get
public:
property unsigned char InputI16 {
    unsigned char get ();
}
member InputI16 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.InputI17 Property

IRD

Pca6416aInputI17 Property

Input: I1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputI17 { get; }
Public ReadOnly Property InputI17 As Byte
    Get
public:
property unsigned char InputI17 {
    unsigned char get ();
}
member InputI17 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.OutputO00 Property

IRD

Pca6416aOutputO00 Property

Output: O0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO00 { get; set; }
Public Property OutputO00 As Byte
    Get
    Set
public:
property unsigned char OutputO00 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO00 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.OutputO01 Property

IRD

Pca6416aOutputO01 Property

Output: O0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO01 { get; set; }
Public Property OutputO01 As Byte
    Get
    Set
public:
property unsigned char OutputO01 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO01 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.OutputO02 Property

IRD

Pca6416aOutputO02 Property

Output: O0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO02 { get; set; }
Public Property OutputO02 As Byte
    Get
    Set
public:
property unsigned char OutputO02 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO02 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.OutputO03 Property

IRD

Pca6416aOutputO03 Property

Output: O0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO03 { get; set; }
Public Property OutputO03 As Byte
    Get
    Set
public:
property unsigned char OutputO03 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO03 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.OutputO04 Property

IRD

Pca6416aOutputO04 Property

Output: O0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO04 { get; set; }
Public Property OutputO04 As Byte
    Get
    Set
public:
property unsigned char OutputO04 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO04 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.OutputO05 Property

IRD

Pca6416aOutputO05 Property

Output: O0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO05 { get; set; }
Public Property OutputO05 As Byte
    Get
    Set
public:
property unsigned char OutputO05 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO05 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.OutputO06 Property

IRD

Pca6416aOutputO06 Property

Output: O0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO06 { get; set; }
Public Property OutputO06 As Byte
    Get
    Set
public:
property unsigned char OutputO06 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO06 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.OutputO07 Property

IRD

Pca6416aOutputO07 Property

Output: O0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO07 { get; set; }
Public Property OutputO07 As Byte
    Get
    Set
public:
property unsigned char OutputO07 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO07 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.OutputO10 Property

IRD

Pca6416aOutputO10 Property

Output: O1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO10 { get; set; }
Public Property OutputO10 As Byte
    Get
    Set
public:
property unsigned char OutputO10 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO10 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.OutputO11 Property

IRD

Pca6416aOutputO11 Property

Output: O1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO11 { get; set; }
Public Property OutputO11 As Byte
    Get
    Set
public:
property unsigned char OutputO11 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO11 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.OutputO12 Property

IRD

Pca6416aOutputO12 Property

Output: O1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO12 { get; set; }
Public Property OutputO12 As Byte
    Get
    Set
public:
property unsigned char OutputO12 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO12 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.OutputO13 Property

IRD

Pca6416aOutputO13 Property

Output: O1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO13 { get; set; }
Public Property OutputO13 As Byte
    Get
    Set
public:
property unsigned char OutputO13 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO13 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.OutputO14 Property

IRD

Pca6416aOutputO14 Property

Output: O1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO14 { get; set; }
Public Property OutputO14 As Byte
    Get
    Set
public:
property unsigned char OutputO14 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO14 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.OutputO15 Property

IRD

Pca6416aOutputO15 Property

Output: O1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO15 { get; set; }
Public Property OutputO15 As Byte
    Get
    Set
public:
property unsigned char OutputO15 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO15 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.OutputO16 Property

IRD

Pca6416aOutputO16 Property

Output: O1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO16 { get; set; }
Public Property OutputO16 As Byte
    Get
    Set
public:
property unsigned char OutputO16 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO16 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.OutputO17 Property

IRD

Pca6416aOutputO17 Property

Output: O1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputO17 { get; set; }
Public Property OutputO17 As Byte
    Get
    Set
public:
property unsigned char OutputO17 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputO17 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.PolarityInversionN00 Property

IRD

Pca6416aPolarityInversionN00 Property

Polarity Inversion: N0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeInversion PolarityInversionN00 { get; set; }
Public Property PolarityInversionN00 As Pca6416aTypeInversion
    Get
    Set
public:
property Pca6416aTypeInversion PolarityInversionN00 {
    Pca6416aTypeInversion get ();
    void set (Pca6416aTypeInversion value);
}
member PolarityInversionN00 : Pca6416aTypeInversion with get, set

Property Value

Type: Pca6416aTypeInversion
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.PolarityInversionN01 Property

IRD

Pca6416aPolarityInversionN01 Property

Polarity Inversion: N0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeInversion PolarityInversionN01 { get; set; }
Public Property PolarityInversionN01 As Pca6416aTypeInversion
    Get
    Set
public:
property Pca6416aTypeInversion PolarityInversionN01 {
    Pca6416aTypeInversion get ();
    void set (Pca6416aTypeInversion value);
}
member PolarityInversionN01 : Pca6416aTypeInversion with get, set

Property Value

Type: Pca6416aTypeInversion
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.PolarityInversionN02 Property

IRD

Pca6416aPolarityInversionN02 Property

Polarity Inversion: N0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeInversion PolarityInversionN02 { get; set; }
Public Property PolarityInversionN02 As Pca6416aTypeInversion
    Get
    Set
public:
property Pca6416aTypeInversion PolarityInversionN02 {
    Pca6416aTypeInversion get ();
    void set (Pca6416aTypeInversion value);
}
member PolarityInversionN02 : Pca6416aTypeInversion with get, set

Property Value

Type: Pca6416aTypeInversion
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.PolarityInversionN03 Property

IRD

Pca6416aPolarityInversionN03 Property

Polarity Inversion: N0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeInversion PolarityInversionN03 { get; set; }
Public Property PolarityInversionN03 As Pca6416aTypeInversion
    Get
    Set
public:
property Pca6416aTypeInversion PolarityInversionN03 {
    Pca6416aTypeInversion get ();
    void set (Pca6416aTypeInversion value);
}
member PolarityInversionN03 : Pca6416aTypeInversion with get, set

Property Value

Type: Pca6416aTypeInversion
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.PolarityInversionN04 Property

IRD

Pca6416aPolarityInversionN04 Property

Polarity Inversion: N0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeInversion PolarityInversionN04 { get; set; }
Public Property PolarityInversionN04 As Pca6416aTypeInversion
    Get
    Set
public:
property Pca6416aTypeInversion PolarityInversionN04 {
    Pca6416aTypeInversion get ();
    void set (Pca6416aTypeInversion value);
}
member PolarityInversionN04 : Pca6416aTypeInversion with get, set

Property Value

Type: Pca6416aTypeInversion
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.PolarityInversionN05 Property

IRD

Pca6416aPolarityInversionN05 Property

Polarity Inversion: N0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeInversion PolarityInversionN05 { get; set; }
Public Property PolarityInversionN05 As Pca6416aTypeInversion
    Get
    Set
public:
property Pca6416aTypeInversion PolarityInversionN05 {
    Pca6416aTypeInversion get ();
    void set (Pca6416aTypeInversion value);
}
member PolarityInversionN05 : Pca6416aTypeInversion with get, set

Property Value

Type: Pca6416aTypeInversion
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.PolarityInversionN06 Property

IRD

Pca6416aPolarityInversionN06 Property

Polarity Inversion: N0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeInversion PolarityInversionN06 { get; set; }
Public Property PolarityInversionN06 As Pca6416aTypeInversion
    Get
    Set
public:
property Pca6416aTypeInversion PolarityInversionN06 {
    Pca6416aTypeInversion get ();
    void set (Pca6416aTypeInversion value);
}
member PolarityInversionN06 : Pca6416aTypeInversion with get, set

Property Value

Type: Pca6416aTypeInversion
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.PolarityInversionN07 Property

IRD

Pca6416aPolarityInversionN07 Property

Polarity Inversion: N0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeInversion PolarityInversionN07 { get; set; }
Public Property PolarityInversionN07 As Pca6416aTypeInversion
    Get
    Set
public:
property Pca6416aTypeInversion PolarityInversionN07 {
    Pca6416aTypeInversion get ();
    void set (Pca6416aTypeInversion value);
}
member PolarityInversionN07 : Pca6416aTypeInversion with get, set

Property Value

Type: Pca6416aTypeInversion
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.PolarityInversionN10 Property

IRD

Pca6416aPolarityInversionN10 Property

Polarity Inversion: N1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeInversion PolarityInversionN10 { get; set; }
Public Property PolarityInversionN10 As Pca6416aTypeInversion
    Get
    Set
public:
property Pca6416aTypeInversion PolarityInversionN10 {
    Pca6416aTypeInversion get ();
    void set (Pca6416aTypeInversion value);
}
member PolarityInversionN10 : Pca6416aTypeInversion with get, set

Property Value

Type: Pca6416aTypeInversion
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.PolarityInversionN11 Property

IRD

Pca6416aPolarityInversionN11 Property

Polarity Inversion: N1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeInversion PolarityInversionN11 { get; set; }
Public Property PolarityInversionN11 As Pca6416aTypeInversion
    Get
    Set
public:
property Pca6416aTypeInversion PolarityInversionN11 {
    Pca6416aTypeInversion get ();
    void set (Pca6416aTypeInversion value);
}
member PolarityInversionN11 : Pca6416aTypeInversion with get, set

Property Value

Type: Pca6416aTypeInversion
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.PolarityInversionN12 Property

IRD

Pca6416aPolarityInversionN12 Property

Polarity Inversion: N1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeInversion PolarityInversionN12 { get; set; }
Public Property PolarityInversionN12 As Pca6416aTypeInversion
    Get
    Set
public:
property Pca6416aTypeInversion PolarityInversionN12 {
    Pca6416aTypeInversion get ();
    void set (Pca6416aTypeInversion value);
}
member PolarityInversionN12 : Pca6416aTypeInversion with get, set

Property Value

Type: Pca6416aTypeInversion
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.PolarityInversionN13 Property

IRD

Pca6416aPolarityInversionN13 Property

Polarity Inversion: N1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeInversion PolarityInversionN13 { get; set; }
Public Property PolarityInversionN13 As Pca6416aTypeInversion
    Get
    Set
public:
property Pca6416aTypeInversion PolarityInversionN13 {
    Pca6416aTypeInversion get ();
    void set (Pca6416aTypeInversion value);
}
member PolarityInversionN13 : Pca6416aTypeInversion with get, set

Property Value

Type: Pca6416aTypeInversion
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.PolarityInversionN14 Property

IRD

Pca6416aPolarityInversionN14 Property

Polarity Inversion: N1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeInversion PolarityInversionN14 { get; set; }
Public Property PolarityInversionN14 As Pca6416aTypeInversion
    Get
    Set
public:
property Pca6416aTypeInversion PolarityInversionN14 {
    Pca6416aTypeInversion get ();
    void set (Pca6416aTypeInversion value);
}
member PolarityInversionN14 : Pca6416aTypeInversion with get, set

Property Value

Type: Pca6416aTypeInversion
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.PolarityInversionN15 Property

IRD

Pca6416aPolarityInversionN15 Property

Polarity Inversion: N1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeInversion PolarityInversionN15 { get; set; }
Public Property PolarityInversionN15 As Pca6416aTypeInversion
    Get
    Set
public:
property Pca6416aTypeInversion PolarityInversionN15 {
    Pca6416aTypeInversion get ();
    void set (Pca6416aTypeInversion value);
}
member PolarityInversionN15 : Pca6416aTypeInversion with get, set

Property Value

Type: Pca6416aTypeInversion
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.PolarityInversionN16 Property

IRD

Pca6416aPolarityInversionN16 Property

Polarity Inversion: N1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeInversion PolarityInversionN16 { get; set; }
Public Property PolarityInversionN16 As Pca6416aTypeInversion
    Get
    Set
public:
property Pca6416aTypeInversion PolarityInversionN16 {
    Pca6416aTypeInversion get ();
    void set (Pca6416aTypeInversion value);
}
member PolarityInversionN16 : Pca6416aTypeInversion with get, set

Property Value

Type: Pca6416aTypeInversion
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.PolarityInversionN17 Property

IRD

Pca6416aPolarityInversionN17 Property

Polarity Inversion: N1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca6416aTypeInversion PolarityInversionN17 { get; set; }
Public Property PolarityInversionN17 As Pca6416aTypeInversion
    Get
    Set
public:
property Pca6416aTypeInversion PolarityInversionN17 {
    Pca6416aTypeInversion get ();
    void set (Pca6416aTypeInversion value);
}
member PolarityInversionN17 : Pca6416aTypeInversion with get, set

Property Value

Type: Pca6416aTypeInversion
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a Methods

The Pca6416a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.Flush Method

IRD

Pca6416aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca6416a Class
telos.Ird.NXPSemiconductors Namespace


Pca6416a.TypeConfiguration Enumeration

IRD

Pca6416aTypeConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Output | 0 | Output
Input | 1 | Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca6416a.TypeInversion Enumeration

IRD

Pca6416aTypeInversion Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInversion
Public Enumeration TypeInversion
public enum class TypeInversion
type TypeInversion
Members
Member name | Value | Description
NotInverted | 0 | Not Inverted
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca8550 Class

NXP Semiconductors: PCA 8550
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca8550

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca8550
Public Class Pca8550
public ref class Pca8550
type Pca8550 =  class end

The Pca8550 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca8550 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | MuxDataA | Mux Data A
Public property | MuxDataB | Mux Data B
Public property | MuxDataC | Mux Data C
Public property | MuxDataD | Mux Data D
Public property | NonMuxedData | Non-Muxed Data
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
4-Bit Multiplexed/1-Bit Latched 5-Bit I2C EEPROM DIP Switch
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca8550 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca8550(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca8550(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca8550

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca8550 Class
telos.Ird.NXPSemiconductors Namespace


Pca8550 Properties

The Pca8550 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | MuxDataA | Mux Data A
Public property | MuxDataB | Mux Data B
Public property | MuxDataC | Mux Data C
Public property | MuxDataD | Mux Data D
Public property | NonMuxedData | Non-Muxed Data
Top
See Also

Reference

Pca8550 Class
telos.Ird.NXPSemiconductors Namespace


Pca8550.AutoFlush Property

IRD

Pca8550AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca8550 Class
telos.Ird.NXPSemiconductors Namespace


Pca8550.MuxDataA Property

IRD

Pca8550MuxDataA Property

Mux Data A

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MuxDataA { get; set; }
Public Property MuxDataA As Byte
    Get
    Set
public:
property unsigned char MuxDataA {
    unsigned char get ();
    void set (unsigned char value);
}
member MuxDataA : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca8550 Class
telos.Ird.NXPSemiconductors Namespace


Pca8550.MuxDataB Property

IRD

Pca8550MuxDataB Property

Mux Data B

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MuxDataB { get; set; }
Public Property MuxDataB As Byte
    Get
    Set
public:
property unsigned char MuxDataB {
    unsigned char get ();
    void set (unsigned char value);
}
member MuxDataB : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca8550 Class
telos.Ird.NXPSemiconductors Namespace


Pca8550.MuxDataC Property

IRD

Pca8550MuxDataC Property

Mux Data C

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MuxDataC { get; set; }
Public Property MuxDataC As Byte
    Get
    Set
public:
property unsigned char MuxDataC {
    unsigned char get ();
    void set (unsigned char value);
}
member MuxDataC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca8550 Class
telos.Ird.NXPSemiconductors Namespace


Pca8550.MuxDataD Property

IRD

Pca8550MuxDataD Property

Mux Data D

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MuxDataD { get; set; }
Public Property MuxDataD As Byte
    Get
    Set
public:
property unsigned char MuxDataD {
    unsigned char get ();
    void set (unsigned char value);
}
member MuxDataD : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca8550 Class
telos.Ird.NXPSemiconductors Namespace


Pca8550.NonMuxedData Property

IRD

Pca8550NonMuxedData Property

Non-Muxed Data

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte NonMuxedData { get; set; }
Public Property NonMuxedData As Byte
    Get
    Set
public:
property unsigned char NonMuxedData {
    unsigned char get ();
    void set (unsigned char value);
}
member NonMuxedData : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca8550 Class
telos.Ird.NXPSemiconductors Namespace


Pca8550 Methods

The Pca8550 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca8550 Class
telos.Ird.NXPSemiconductors Namespace


Pca8550.Flush Method

IRD

Pca8550Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca8550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502 Class

NXP Semiconductors: PCA 9502
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9502

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9502
Public Class Pca9502
public ref class Pca9502
type Pca9502 =  class end

The Pca9502 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9502 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | InputsLatching | Inputs Latching
Public property | IOInterruptEnableGPIO0 | I/O Interrupt Enable (GPIO 0)
Public property | IOInterruptEnableGPIO1 | I/O Interrupt Enable (GPIO 1)
Public property | IOInterruptEnableGPIO2 | I/O Interrupt Enable (GPIO 2)
Public property | IOInterruptEnableGPIO3 | I/O Interrupt Enable (GPIO 3)
Public property | IOInterruptEnableGPIO4 | I/O Interrupt Enable (GPIO 4)
Public property | IOInterruptEnableGPIO5 | I/O Interrupt Enable (GPIO 5)
Public property | IOInterruptEnableGPIO6 | I/O Interrupt Enable (GPIO 6)
Public property | IOInterruptEnableGPIO7 | I/O Interrupt Enable (GPIO 7)
Public property | IOPinDirectionGPIO0 | I/O Pin Direction (GPIO 0)
Public property | IOPinDirectionGPIO1 | I/O Pin Direction (GPIO 1)
Public property | IOPinDirectionGPIO2 | I/O Pin Direction (GPIO 2)
Public property | IOPinDirectionGPIO3 | I/O Pin Direction (GPIO 3)
Public property | IOPinDirectionGPIO4 | I/O Pin Direction (GPIO 4)
Public property | IOPinDirectionGPIO5 | I/O Pin Direction (GPIO 5)
Public property | IOPinDirectionGPIO6 | I/O Pin Direction (GPIO 6)
Public property | IOPinDirectionGPIO7 | I/O Pin Direction (GPIO 7)
Public property | IOPinStateGPIO0 | I/O Pin State (GPIO 0)
Public property | IOPinStateGPIO1 | I/O Pin State (GPIO 1)
Public property | IOPinStateGPIO2 | I/O Pin State (GPIO 2)
Public property | IOPinStateGPIO3 | I/O Pin State (GPIO 3)
Public property | IOPinStateGPIO4 | I/O Pin State (GPIO 4)
Public property | IOPinStateGPIO5 | I/O Pin State (GPIO 5)
Public property | IOPinStateGPIO6 | I/O Pin State (GPIO 6)
Public property | IOPinStateGPIO7 | I/O Pin State (GPIO 7)
Public property | SoftwareReset | Software Reset
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
8-Bit I/O Expander With I2C-Bus/SPI Interface
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9502 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9502(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9502

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502 Properties

The Pca9502 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | InputsLatching | Inputs Latching
Public property | IOInterruptEnableGPIO0 | I/O Interrupt Enable (GPIO 0)
Public property | IOInterruptEnableGPIO1 | I/O Interrupt Enable (GPIO 1)
Public property | IOInterruptEnableGPIO2 | I/O Interrupt Enable (GPIO 2)
Public property | IOInterruptEnableGPIO3 | I/O Interrupt Enable (GPIO 3)
Public property | IOInterruptEnableGPIO4 | I/O Interrupt Enable (GPIO 4)
Public property | IOInterruptEnableGPIO5 | I/O Interrupt Enable (GPIO 5)
Public property | IOInterruptEnableGPIO6 | I/O Interrupt Enable (GPIO 6)
Public property | IOInterruptEnableGPIO7 | I/O Interrupt Enable (GPIO 7)
Public property | IOPinDirectionGPIO0 | I/O Pin Direction (GPIO 0)
Public property | IOPinDirectionGPIO1 | I/O Pin Direction (GPIO 1)
Public property | IOPinDirectionGPIO2 | I/O Pin Direction (GPIO 2)
Public property | IOPinDirectionGPIO3 | I/O Pin Direction (GPIO 3)
Public property | IOPinDirectionGPIO4 | I/O Pin Direction (GPIO 4)
Public property | IOPinDirectionGPIO5 | I/O Pin Direction (GPIO 5)
Public property | IOPinDirectionGPIO6 | I/O Pin Direction (GPIO 6)
Public property | IOPinDirectionGPIO7 | I/O Pin Direction (GPIO 7)
Public property | IOPinStateGPIO0 | I/O Pin State (GPIO 0)
Public property | IOPinStateGPIO1 | I/O Pin State (GPIO 1)
Public property | IOPinStateGPIO2 | I/O Pin State (GPIO 2)
Public property | IOPinStateGPIO3 | I/O Pin State (GPIO 3)
Public property | IOPinStateGPIO4 | I/O Pin State (GPIO 4)
Public property | IOPinStateGPIO5 | I/O Pin State (GPIO 5)
Public property | IOPinStateGPIO6 | I/O Pin State (GPIO 6)
Public property | IOPinStateGPIO7 | I/O Pin State (GPIO 7)
Public property | SoftwareReset | Software Reset
Top
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.AutoFlush Property

IRD

Pca9502AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.InputsLatching Property

IRD

Pca9502InputsLatching Property

Inputs Latching

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502TypeIocontrolIolatch InputsLatching { get; set; }
Public Property InputsLatching As Pca9502TypeIocontrolIolatch
    Get
    Set
public:
property Pca9502TypeIocontrolIolatch InputsLatching {
    Pca9502TypeIocontrolIolatch get ();
    void set (Pca9502TypeIocontrolIolatch value);
}
member InputsLatching : Pca9502TypeIocontrolIolatch with get, set

Property Value

Type: Pca9502TypeIocontrolIolatch
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOInterruptEnableGPIO0 Property

IRD

Pca9502IOInterruptEnableGPIO0 Property

I/O Interrupt Enable (GPIO 0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502TypeIointena IOInterruptEnableGPIO0 { get; set; }
Public Property IOInterruptEnableGPIO0 As Pca9502TypeIointena
    Get
    Set
public:
property Pca9502TypeIointena IOInterruptEnableGPIO0 {
    Pca9502TypeIointena get ();
    void set (Pca9502TypeIointena value);
}
member IOInterruptEnableGPIO0 : Pca9502TypeIointena with get, set

Property Value

Type: Pca9502TypeIointena
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOInterruptEnableGPIO1 Property

IRD

Pca9502IOInterruptEnableGPIO1 Property

I/O Interrupt Enable (GPIO 1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502TypeIointena IOInterruptEnableGPIO1 { get; set; }
Public Property IOInterruptEnableGPIO1 As Pca9502TypeIointena
    Get
    Set
public:
property Pca9502TypeIointena IOInterruptEnableGPIO1 {
    Pca9502TypeIointena get ();
    void set (Pca9502TypeIointena value);
}
member IOInterruptEnableGPIO1 : Pca9502TypeIointena with get, set

Property Value

Type: Pca9502TypeIointena
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOInterruptEnableGPIO2 Property

IRD

Pca9502IOInterruptEnableGPIO2 Property

I/O Interrupt Enable (GPIO 2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502TypeIointena IOInterruptEnableGPIO2 { get; set; }
Public Property IOInterruptEnableGPIO2 As Pca9502TypeIointena
    Get
    Set
public:
property Pca9502TypeIointena IOInterruptEnableGPIO2 {
    Pca9502TypeIointena get ();
    void set (Pca9502TypeIointena value);
}
member IOInterruptEnableGPIO2 : Pca9502TypeIointena with get, set

Property Value

Type: Pca9502TypeIointena
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOInterruptEnableGPIO3 Property

IRD

Pca9502IOInterruptEnableGPIO3 Property

I/O Interrupt Enable (GPIO 3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502TypeIointena IOInterruptEnableGPIO3 { get; set; }
Public Property IOInterruptEnableGPIO3 As Pca9502TypeIointena
    Get
    Set
public:
property Pca9502TypeIointena IOInterruptEnableGPIO3 {
    Pca9502TypeIointena get ();
    void set (Pca9502TypeIointena value);
}
member IOInterruptEnableGPIO3 : Pca9502TypeIointena with get, set

Property Value

Type: Pca9502TypeIointena
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOInterruptEnableGPIO4 Property

IRD

Pca9502IOInterruptEnableGPIO4 Property

I/O Interrupt Enable (GPIO 4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502TypeIointena IOInterruptEnableGPIO4 { get; set; }
Public Property IOInterruptEnableGPIO4 As Pca9502TypeIointena
    Get
    Set
public:
property Pca9502TypeIointena IOInterruptEnableGPIO4 {
    Pca9502TypeIointena get ();
    void set (Pca9502TypeIointena value);
}
member IOInterruptEnableGPIO4 : Pca9502TypeIointena with get, set

Property Value

Type: Pca9502TypeIointena
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOInterruptEnableGPIO5 Property

IRD

Pca9502IOInterruptEnableGPIO5 Property

I/O Interrupt Enable (GPIO 5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502TypeIointena IOInterruptEnableGPIO5 { get; set; }
Public Property IOInterruptEnableGPIO5 As Pca9502TypeIointena
    Get
    Set
public:
property Pca9502TypeIointena IOInterruptEnableGPIO5 {
    Pca9502TypeIointena get ();
    void set (Pca9502TypeIointena value);
}
member IOInterruptEnableGPIO5 : Pca9502TypeIointena with get, set

Property Value

Type: Pca9502TypeIointena
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOInterruptEnableGPIO6 Property

IRD

Pca9502IOInterruptEnableGPIO6 Property

I/O Interrupt Enable (GPIO 6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502TypeIointena IOInterruptEnableGPIO6 { get; set; }
Public Property IOInterruptEnableGPIO6 As Pca9502TypeIointena
    Get
    Set
public:
property Pca9502TypeIointena IOInterruptEnableGPIO6 {
    Pca9502TypeIointena get ();
    void set (Pca9502TypeIointena value);
}
member IOInterruptEnableGPIO6 : Pca9502TypeIointena with get, set

Property Value

Type: Pca9502TypeIointena
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOInterruptEnableGPIO7 Property

IRD

Pca9502IOInterruptEnableGPIO7 Property

I/O Interrupt Enable (GPIO 7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502TypeIointena IOInterruptEnableGPIO7 { get; set; }
Public Property IOInterruptEnableGPIO7 As Pca9502TypeIointena
    Get
    Set
public:
property Pca9502TypeIointena IOInterruptEnableGPIO7 {
    Pca9502TypeIointena get ();
    void set (Pca9502TypeIointena value);
}
member IOInterruptEnableGPIO7 : Pca9502TypeIointena with get, set

Property Value

Type: Pca9502TypeIointena
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOPinDirectionGPIO0 Property

IRD

Pca9502IOPinDirectionGPIO0 Property

I/O Pin Direction (GPIO 0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502TypeIodir IOPinDirectionGPIO0 { get; set; }
Public Property IOPinDirectionGPIO0 As Pca9502TypeIodir
    Get
    Set
public:
property Pca9502TypeIodir IOPinDirectionGPIO0 {
    Pca9502TypeIodir get ();
    void set (Pca9502TypeIodir value);
}
member IOPinDirectionGPIO0 : Pca9502TypeIodir with get, set

Property Value

Type: Pca9502TypeIodir
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOPinDirectionGPIO1 Property

IRD

Pca9502IOPinDirectionGPIO1 Property

I/O Pin Direction (GPIO 1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502TypeIodir IOPinDirectionGPIO1 { get; set; }
Public Property IOPinDirectionGPIO1 As Pca9502TypeIodir
    Get
    Set
public:
property Pca9502TypeIodir IOPinDirectionGPIO1 {
    Pca9502TypeIodir get ();
    void set (Pca9502TypeIodir value);
}
member IOPinDirectionGPIO1 : Pca9502TypeIodir with get, set

Property Value

Type: Pca9502TypeIodir
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOPinDirectionGPIO2 Property

IRD

Pca9502IOPinDirectionGPIO2 Property

I/O Pin Direction (GPIO 2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502TypeIodir IOPinDirectionGPIO2 { get; set; }
Public Property IOPinDirectionGPIO2 As Pca9502TypeIodir
    Get
    Set
public:
property Pca9502TypeIodir IOPinDirectionGPIO2 {
    Pca9502TypeIodir get ();
    void set (Pca9502TypeIodir value);
}
member IOPinDirectionGPIO2 : Pca9502TypeIodir with get, set

Property Value

Type: Pca9502TypeIodir
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOPinDirectionGPIO3 Property

IRD

Pca9502IOPinDirectionGPIO3 Property

I/O Pin Direction (GPIO 3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502TypeIodir IOPinDirectionGPIO3 { get; set; }
Public Property IOPinDirectionGPIO3 As Pca9502TypeIodir
    Get
    Set
public:
property Pca9502TypeIodir IOPinDirectionGPIO3 {
    Pca9502TypeIodir get ();
    void set (Pca9502TypeIodir value);
}
member IOPinDirectionGPIO3 : Pca9502TypeIodir with get, set

Property Value

Type: Pca9502TypeIodir
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOPinDirectionGPIO4 Property

IRD

Pca9502IOPinDirectionGPIO4 Property

I/O Pin Direction (GPIO 4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502TypeIodir IOPinDirectionGPIO4 { get; set; }
Public Property IOPinDirectionGPIO4 As Pca9502TypeIodir
    Get
    Set
public:
property Pca9502TypeIodir IOPinDirectionGPIO4 {
    Pca9502TypeIodir get ();
    void set (Pca9502TypeIodir value);
}
member IOPinDirectionGPIO4 : Pca9502TypeIodir with get, set

Property Value

Type: Pca9502TypeIodir
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOPinDirectionGPIO5 Property

IRD

Pca9502IOPinDirectionGPIO5 Property

I/O Pin Direction (GPIO 5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502TypeIodir IOPinDirectionGPIO5 { get; set; }
Public Property IOPinDirectionGPIO5 As Pca9502TypeIodir
    Get
    Set
public:
property Pca9502TypeIodir IOPinDirectionGPIO5 {
    Pca9502TypeIodir get ();
    void set (Pca9502TypeIodir value);
}
member IOPinDirectionGPIO5 : Pca9502TypeIodir with get, set

Property Value

Type: Pca9502TypeIodir
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOPinDirectionGPIO6 Property

IRD

Pca9502IOPinDirectionGPIO6 Property

I/O Pin Direction (GPIO 6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502TypeIodir IOPinDirectionGPIO6 { get; set; }
Public Property IOPinDirectionGPIO6 As Pca9502TypeIodir
    Get
    Set
public:
property Pca9502TypeIodir IOPinDirectionGPIO6 {
    Pca9502TypeIodir get ();
    void set (Pca9502TypeIodir value);
}
member IOPinDirectionGPIO6 : Pca9502TypeIodir with get, set

Property Value

Type: Pca9502TypeIodir
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOPinDirectionGPIO7 Property

IRD

Pca9502IOPinDirectionGPIO7 Property

I/O Pin Direction (GPIO 7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502TypeIodir IOPinDirectionGPIO7 { get; set; }
Public Property IOPinDirectionGPIO7 As Pca9502TypeIodir
    Get
    Set
public:
property Pca9502TypeIodir IOPinDirectionGPIO7 {
    Pca9502TypeIodir get ();
    void set (Pca9502TypeIodir value);
}
member IOPinDirectionGPIO7 : Pca9502TypeIodir with get, set

Property Value

Type: Pca9502TypeIodir
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOPinStateGPIO0 Property

IRD

Pca9502IOPinStateGPIO0 Property

I/O Pin State (GPIO 0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IOPinStateGPIO0 { get; set; }
Public Property IOPinStateGPIO0 As Byte
    Get
    Set
public:
property unsigned char IOPinStateGPIO0 {
    unsigned char get ();
    void set (unsigned char value);
}
member IOPinStateGPIO0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOPinStateGPIO1 Property

IRD

Pca9502IOPinStateGPIO1 Property

I/O Pin State (GPIO 1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IOPinStateGPIO1 { get; set; }
Public Property IOPinStateGPIO1 As Byte
    Get
    Set
public:
property unsigned char IOPinStateGPIO1 {
    unsigned char get ();
    void set (unsigned char value);
}
member IOPinStateGPIO1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOPinStateGPIO2 Property

IRD

Pca9502IOPinStateGPIO2 Property

I/O Pin State (GPIO 2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IOPinStateGPIO2 { get; set; }
Public Property IOPinStateGPIO2 As Byte
    Get
    Set
public:
property unsigned char IOPinStateGPIO2 {
    unsigned char get ();
    void set (unsigned char value);
}
member IOPinStateGPIO2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOPinStateGPIO3 Property

IRD

Pca9502IOPinStateGPIO3 Property

I/O Pin State (GPIO 3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IOPinStateGPIO3 { get; set; }
Public Property IOPinStateGPIO3 As Byte
    Get
    Set
public:
property unsigned char IOPinStateGPIO3 {
    unsigned char get ();
    void set (unsigned char value);
}
member IOPinStateGPIO3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOPinStateGPIO4 Property

IRD

Pca9502IOPinStateGPIO4 Property

I/O Pin State (GPIO 4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IOPinStateGPIO4 { get; set; }
Public Property IOPinStateGPIO4 As Byte
    Get
    Set
public:
property unsigned char IOPinStateGPIO4 {
    unsigned char get ();
    void set (unsigned char value);
}
member IOPinStateGPIO4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOPinStateGPIO5 Property

IRD

Pca9502IOPinStateGPIO5 Property

I/O Pin State (GPIO 5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IOPinStateGPIO5 { get; set; }
Public Property IOPinStateGPIO5 As Byte
    Get
    Set
public:
property unsigned char IOPinStateGPIO5 {
    unsigned char get ();
    void set (unsigned char value);
}
member IOPinStateGPIO5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOPinStateGPIO6 Property

IRD

Pca9502IOPinStateGPIO6 Property

I/O Pin State (GPIO 6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IOPinStateGPIO6 { get; set; }
Public Property IOPinStateGPIO6 As Byte
    Get
    Set
public:
property unsigned char IOPinStateGPIO6 {
    unsigned char get ();
    void set (unsigned char value);
}
member IOPinStateGPIO6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.IOPinStateGPIO7 Property

IRD

Pca9502IOPinStateGPIO7 Property

I/O Pin State (GPIO 7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IOPinStateGPIO7 { get; set; }
Public Property IOPinStateGPIO7 As Byte
    Get
    Set
public:
property unsigned char IOPinStateGPIO7 {
    unsigned char get ();
    void set (unsigned char value);
}
member IOPinStateGPIO7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.SoftwareReset Property

IRD

Pca9502SoftwareReset Property

Software Reset

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9502TypeIocontrolSreset SoftwareReset { set; }
Public WriteOnly Property SoftwareReset As Pca9502TypeIocontrolSreset
    Set
public:
property Pca9502TypeIocontrolSreset SoftwareReset {
    void set (Pca9502TypeIocontrolSreset value);
}
member SoftwareReset : Pca9502TypeIocontrolSreset with set

Property Value

Type: Pca9502TypeIocontrolSreset
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502 Methods

The Pca9502 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.Flush Method

IRD

Pca9502Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9502 Class
telos.Ird.NXPSemiconductors Namespace


Pca9502.TypeIocontrolIolatch Enumeration

IRD

Pca9502TypeIocontrolIolatch Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIocontrolIolatch
Public Enumeration TypeIocontrolIolatch
public enum class TypeIocontrolIolatch
type TypeIocontrolIolatch
Members
Member name | Value | Description
NotLatched | 0 | Not latched
Latched | 1 | Latched
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9502.TypeIocontrolSreset Enumeration

IRD

Pca9502TypeIocontrolSreset Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIocontrolSreset
Public Enumeration TypeIocontrolSreset
public enum class TypeIocontrolSreset
type TypeIocontrolSreset
Members
Member name | Value | Description
Unmodified | 0 | Unmodified
Reset | 1 | Reset
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9502.TypeIodir Enumeration

IRD

Pca9502TypeIodir Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIodir
Public Enumeration TypeIodir
public enum class TypeIodir
type TypeIodir
Members
Member name | Value | Description
Input | 0 | Input
Output | 1 | Output
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9502.TypeIointena Enumeration

IRD

Pca9502TypeIointena Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIointena
Public Enumeration TypeIointena
public enum class TypeIointena
type TypeIointena
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca95059506 Class

NXP Semiconductors: PCA 9505 / 9506
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca95059506

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca95059506
Public Class Pca95059506
public ref class Pca95059506
type Pca95059506 =  class end

The Pca95059506 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca95059506 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | InputPortIO00 | Input Port (IO0_0)
Public property | InputPortIO00AI | Input Port (IO0_0) [AI]
Public property | InputPortIO01 | Input Port (IO0_1)
Public property | InputPortIO01AI | Input Port (IO0_1) [AI]
Public property | InputPortIO02 | Input Port (IO0_2)
Public property | InputPortIO02AI | Input Port (IO0_2) [AI]
Public property | InputPortIO03 | Input Port (IO0_3)
Public property | InputPortIO03AI | Input Port (IO0_3) [AI]
Public property | InputPortIO04 | Input Port (IO0_4)
Public property | InputPortIO04AI | Input Port (IO0_4) [AI]
Public property | InputPortIO05 | Input Port (IO0_5)
Public property | InputPortIO05AI | Input Port (IO0_5) [AI]
Public property | InputPortIO06 | Input Port (IO0_6)
Public property | InputPortIO06AI | Input Port (IO0_6) [AI]
Public property | InputPortIO07 | Input Port (IO0_7)
Public property | InputPortIO07AI | Input Port (IO0_7) [AI]
Public property | InputPortIO10 | Input Port (IO1_0)
Public property | InputPortIO10AI | Input Port (IO1_0) [AI]
Public property | InputPortIO11 | Input Port (IO1_1)
Public property | InputPortIO11AI | Input Port (IO1_1) [AI]
Public property | InputPortIO12 | Input Port (IO1_2)
Public property | InputPortIO12AI | Input Port (IO1_2) [AI]
Public property | InputPortIO13 | Input Port (IO1_3)
Public property | InputPortIO13AI | Input Port (IO1_3) [AI]
Public property | InputPortIO14 | Input Port (IO1_4)
Public property | InputPortIO14AI | Input Port (IO1_4) [AI]
Public property | InputPortIO15 | Input Port (IO1_5)
Public property | InputPortIO15AI | Input Port (IO1_5) [AI]
Public property | InputPortIO16 | Input Port (IO1_6)
Public property | InputPortIO16AI | Input Port (IO1_6) [AI]
Public property | InputPortIO17 | Input Port (IO1_7)
Public property | InputPortIO17AI | Input Port (IO1_7) [AI]
Public property | InputPortIO20 | Input Port (IO2_0)
Public property | InputPortIO20AI | Input Port (IO2_0) [AI]
Public property | InputPortIO21 | Input Port (IO2_1)
Public property | InputPortIO21AI | Input Port (IO2_1) [AI]
Public property | InputPortIO22 | Input Port (IO2_2)
Public property | InputPortIO22AI | Input Port (IO2_2) [AI]
Public property | InputPortIO23 | Input Port (IO2_3)
Public property | InputPortIO23AI | Input Port (IO2_3) [AI]
Public property | InputPortIO24 | Input Port (IO2_4)
Public property | InputPortIO24AI | Input Port (IO2_4) [AI]
Public property | InputPortIO25 | Input Port (IO2_5)
Public property | InputPortIO25AI | Input Port (IO2_5) [AI]
Public property | InputPortIO26 | Input Port (IO2_6)
Public property | InputPortIO26AI | Input Port (IO2_6) [AI]
Public property | InputPortIO27 | Input Port (IO2_7)
Public property | InputPortIO27AI | Input Port (IO2_7) [AI]
Public property | InputPortIO30 | Input Port (IO3_0)
Public property | InputPortIO30AI | Input Port (IO3_0) [AI]
Public property | InputPortIO31 | Input Port (IO3_1)
Public property | InputPortIO31AI | Input Port (IO3_1) [AI]
Public property | InputPortIO32 | Input Port (IO3_2)
Public property | InputPortIO32AI | Input Port (IO3_2) [AI]
Public property | InputPortIO33 | Input Port (IO3_3)
Public property | InputPortIO33AI | Input Port (IO3_3) [AI]
Public property | InputPortIO34 | Input Port (IO3_4)
Public property | InputPortIO34AI | Input Port (IO3_4) [AI]
Public property | InputPortIO35 | Input Port (IO3_5)
Public property | InputPortIO35AI | Input Port (IO3_5) [AI]
Public property | InputPortIO36 | Input Port (IO3_6)
Public property | InputPortIO36AI | Input Port (IO3_6) [AI]
Public property | InputPortIO37 | Input Port (IO3_7)
Public property | InputPortIO37AI | Input Port (IO3_7) [AI]
Public property | IOConfigurationIO00 | I/O Configuration (IO0_0)
Public property | IOConfigurationIO00AI | I/O Configuration (IO0_0) [AI]
Public property | IOConfigurationIO01 | I/O Configuration (IO0_1)
Public property | IOConfigurationIO01AI | I/O Configuration (IO0_1) [AI]
Public property | IOConfigurationIO02 | I/O Configuration (IO0_2)
Public property | IOConfigurationIO02AI | I/O Configuration (IO0_2) [AI]
Public property | IOConfigurationIO03 | I/O Configuration (IO0_3)
Public property | IOConfigurationIO03AI | I/O Configuration (IO0_3) [AI]
Public property | IOConfigurationIO04 | I/O Configuration (IO0_4)
Public property | IOConfigurationIO04AI | I/O Configuration (IO0_4) [AI]
Public property | IOConfigurationIO05 | I/O Configuration (IO0_5)
Public property | IOConfigurationIO05AI | I/O Configuration (IO0_5) [AI]
Public property | IOConfigurationIO06 | I/O Configuration (IO0_6)
Public property | IOConfigurationIO06AI | I/O Configuration (IO0_6) [AI]
Public property | IOConfigurationIO07 | I/O Configuration (IO0_7)
Public property | IOConfigurationIO07AI | I/O Configuration (IO0_7) [AI]
Public property | IOConfigurationIO10 | I/O Configuration (IO1_0)
Public property | IOConfigurationIO10AI | I/O Configuration (IO1_0) [AI]
Public property | IOConfigurationIO11 | I/O Configuration (IO1_1)
Public property | IOConfigurationIO11AI | I/O Configuration (IO1_1) [AI]
Public property | IOConfigurationIO12 | I/O Configuration (IO1_2)
Public property | IOConfigurationIO12AI | I/O Configuration (IO1_2) [AI]
Public property | IOConfigurationIO13 | I/O Configuration (IO1_3)
Public property | IOConfigurationIO13AI | I/O Configuration (IO1_3) [AI]
Public property | IOConfigurationIO14 | I/O Configuration (IO1_4)
Public property | IOConfigurationIO14AI | I/O Configuration (IO1_4) [AI]
Public property | IOConfigurationIO15 | I/O Configuration (IO1_5)
Public property | IOConfigurationIO15AI | I/O Configuration (IO1_5) [AI]
Public property | IOConfigurationIO16 | I/O Configuration (IO1_6)
Public property | IOConfigurationIO16AI | I/O Configuration (IO1_6) [AI]
Public property | IOConfigurationIO17 | I/O Configuration (IO1_7)
Public property | IOConfigurationIO17AI | I/O Configuration (IO1_7) [AI]
Public property | IOConfigurationIO20 | I/O Configuration (IO2_0)
Public property | IOConfigurationIO20AI | I/O Configuration (IO2_0) [AI]
Public property | IOConfigurationIO21 | I/O Configuration (IO2_1)
Public property | IOConfigurationIO21AI | I/O Configuration (IO2_1) [AI]
Public property | IOConfigurationIO22 | I/O Configuration (IO2_2)
Public property | IOConfigurationIO22AI | I/O Configuration (IO2_2) [AI]
Public property | IOConfigurationIO23 | I/O Configuration (IO2_3)
Public property | IOConfigurationIO23AI | I/O Configuration (IO2_3) [AI]
Public property | IOConfigurationIO24 | I/O Configuration (IO2_4)
Public property | IOConfigurationIO24AI | I/O Configuration (IO2_4) [AI]
Public property | IOConfigurationIO25 | I/O Configuration (IO2_5)
Public property | IOConfigurationIO25AI | I/O Configuration (IO2_5) [AI]
Public property | IOConfigurationIO26 | I/O Configuration (IO2_6)
Public property | IOConfigurationIO26AI | I/O Configuration (IO2_6) [AI]
Public property | IOConfigurationIO27 | I/O Configuration (IO2_7)
Public property | IOConfigurationIO27AI | I/O Configuration (IO2_7) [AI]
Public property | IOConfigurationIO30 | I/O Configuration (IO3_0)
Public property | IOConfigurationIO30AI | I/O Configuration (IO3_0) [AI]
Public property | IOConfigurationIO31 | I/O Configuration (IO3_1)
Public property | IOConfigurationIO31AI | I/O Configuration (IO3_1) [AI]
Public property | IOConfigurationIO32 | I/O Configuration (IO3_2)
Public property | IOConfigurationIO32AI | I/O Configuration (IO3_2) [AI]
Public property | IOConfigurationIO33 | I/O Configuration (IO3_3)
Public property | IOConfigurationIO33AI | I/O Configuration (IO3_3) [AI]
Public property | IOConfigurationIO34 | I/O Configuration (IO3_4)
Public property | IOConfigurationIO34AI | I/O Configuration (IO3_4) [AI]
Public property | IOConfigurationIO35 | I/O Configuration (IO3_5)
Public property | IOConfigurationIO35AI | I/O Configuration (IO3_5) [AI]
Public property | IOConfigurationIO36 | I/O Configuration (IO3_6)
Public property | IOConfigurationIO36AI | I/O Configuration (IO3_6) [AI]
Public property | IOConfigurationIO37 | I/O Configuration (IO3_7)
Public property | IOConfigurationIO37AI | I/O Configuration (IO3_7) [AI]
Public property | MaskInterruptIO00 | Mask Interrupt (IO0_0)
Public property | MaskInterruptIO00AI | Mask Interrupt (IO0_0) [AI]
Public property | MaskInterruptIO01 | Mask Interrupt (IO0_1)
Public property | MaskInterruptIO01AI | Mask Interrupt (IO0_1) [AI]
Public property | MaskInterruptIO02 | Mask Interrupt (IO0_2)
Public property | MaskInterruptIO02AI | Mask Interrupt (IO0_2) [AI]
Public property | MaskInterruptIO03 | Mask Interrupt (IO0_3)
Public property | MaskInterruptIO03AI | Mask Interrupt (IO0_3) [AI]
Public property | MaskInterruptIO04 | Mask Interrupt (IO0_4)
Public property | MaskInterruptIO04AI | Mask Interrupt (IO0_4) [AI]
Public property | MaskInterruptIO05 | Mask Interrupt (IO0_5)
Public property | MaskInterruptIO05AI | Mask Interrupt (IO0_5) [AI]
Public property | MaskInterruptIO06 | Mask Interrupt (IO0_6)
Public property | MaskInterruptIO06AI | Mask Interrupt (IO0_6) [AI]
Public property | MaskInterruptIO07 | Mask Interrupt (IO0_7)
Public property | MaskInterruptIO07AI | Mask Interrupt (IO0_7) [AI]
Public property | MaskInterruptIO10 | Mask Interrupt (IO1_0)
Public property | MaskInterruptIO10AI | Mask Interrupt (IO1_0) [AI]
Public property | MaskInterruptIO11 | Mask Interrupt (IO1_1)
Public property | MaskInterruptIO11AI | Mask Interrupt (IO1_1) [AI]
Public property | MaskInterruptIO12 | Mask Interrupt (IO1_2)
Public property | MaskInterruptIO12AI | Mask Interrupt (IO1_2) [AI]
Public property | MaskInterruptIO13 | Mask Interrupt (IO1_3)
Public property | MaskInterruptIO13AI | Mask Interrupt (IO1_3) [AI]
Public property | MaskInterruptIO14 | Mask Interrupt (IO1_4)
Public property | MaskInterruptIO14AI | Mask Interrupt (IO1_4) [AI]
Public property | MaskInterruptIO15 | Mask Interrupt (IO1_5)
Public property | MaskInterruptIO15AI | Mask Interrupt (IO1_5) [AI]
Public property | MaskInterruptIO16 | Mask Interrupt (IO1_6)
Public property | MaskInterruptIO16AI | Mask Interrupt (IO1_6) [AI]
Public property | MaskInterruptIO17 | Mask Interrupt (IO1_7)
Public property | MaskInterruptIO17AI | Mask Interrupt (IO1_7) [AI]
Public property | MaskInterruptIO20 | Mask Interrupt (IO2_0)
Public property | MaskInterruptIO20AI | Mask Interrupt (IO2_0) [AI]
Public property | MaskInterruptIO21 | Mask Interrupt (IO2_1)
Public property | MaskInterruptIO21AI | Mask Interrupt (IO2_1) [AI]
Public property | MaskInterruptIO22 | Mask Interrupt (IO2_2)
Public property | MaskInterruptIO22AI | Mask Interrupt (IO2_2) [AI]
Public property | MaskInterruptIO23 | Mask Interrupt (IO2_3)
Public property | MaskInterruptIO23AI | Mask Interrupt (IO2_3) [AI]
Public property | MaskInterruptIO24 | Mask Interrupt (IO2_4)
Public property | MaskInterruptIO24AI | Mask Interrupt (IO2_4) [AI]
Public property | MaskInterruptIO25 | Mask Interrupt (IO2_5)
Public property | MaskInterruptIO25AI | Mask Interrupt (IO2_5) [AI]
Public property | MaskInterruptIO26 | Mask Interrupt (IO2_6)
Public property | MaskInterruptIO26AI | Mask Interrupt (IO2_6) [AI]
Public property | MaskInterruptIO27 | Mask Interrupt (IO2_7)
Public property | MaskInterruptIO27AI | Mask Interrupt (IO2_7) [AI]
Public property | MaskInterruptIO30 | Mask Interrupt (IO3_0)
Public property | MaskInterruptIO30AI | Mask Interrupt (IO3_0) [AI]
Public property | MaskInterruptIO31 | Mask Interrupt (IO3_1)
Public property | MaskInterruptIO31AI | Mask Interrupt (IO3_1) [AI]
Public property | MaskInterruptIO32 | Mask Interrupt (IO3_2)
Public property | MaskInterruptIO32AI | Mask Interrupt (IO3_2) [AI]
Public property | MaskInterruptIO33 | Mask Interrupt (IO3_3)
Public property | MaskInterruptIO33AI | Mask Interrupt (IO3_3) [AI]
Public property | MaskInterruptIO34 | Mask Interrupt (IO3_4)
Public property | MaskInterruptIO34AI | Mask Interrupt (IO3_4) [AI]
Public property | MaskInterruptIO35 | Mask Interrupt (IO3_5)
Public property | MaskInterruptIO35AI | Mask Interrupt (IO3_5) [AI]
Public property | MaskInterruptIO36 | Mask Interrupt (IO3_6)
Public property | MaskInterruptIO36AI | Mask Interrupt (IO3_6) [AI]
Public property | MaskInterruptIO37 | Mask Interrupt (IO3_7)
Public property | MaskInterruptIO37AI | Mask Interrupt (IO3_7) [AI]
Public property | OutputPortIO00 | Output Port (IO0_0)
Public property | OutputPortIO00AI | Output Port (IO0_0) [AI]
Public property | OutputPortIO01 | Output Port (IO0_1)
Public property | OutputPortIO01AI | Output Port (IO0_1) [AI]
Public property | OutputPortIO02 | Output Port (IO0_2)
Public property | OutputPortIO02AI | Output Port (IO0_2) [AI]
Public property | OutputPortIO03 | Output Port (IO0_3)
Public property | OutputPortIO03AI | Output Port (IO0_3) [AI]
Public property | OutputPortIO04 | Output Port (IO0_4)
Public property | OutputPortIO04AI | Output Port (IO0_4) [AI]
Public property | OutputPortIO05 | Output Port (IO0_5)
Public property | OutputPortIO05AI | Output Port (IO0_5) [AI]
Public property | OutputPortIO06 | Output Port (IO0_6)
Public property | OutputPortIO06AI | Output Port (IO0_6) [AI]
Public property | OutputPortIO07 | Output Port (IO0_7)
Public property | OutputPortIO07AI | Output Port (IO0_7) [AI]
Public property | OutputPortIO10 | Output Port (IO1_0)
Public property | OutputPortIO10AI | Output Port (IO1_0) [AI]
Public property | OutputPortIO11 | Output Port (IO1_1)
Public property | OutputPortIO11AI | Output Port (IO1_1) [AI]
Public property | OutputPortIO12 | Output Port (IO1_2)
Public property | OutputPortIO12AI | Output Port (IO1_2) [AI]
Public property | OutputPortIO13 | Output Port (IO1_3)
Public property | OutputPortIO13AI | Output Port (IO1_3) [AI]
Public property | OutputPortIO14 | Output Port (IO1_4)
Public property | OutputPortIO14AI | Output Port (IO1_4) [AI]
Public property | OutputPortIO15 | Output Port (IO1_5)
Public property | OutputPortIO15AI | Output Port (IO1_5) [AI]
Public property | OutputPortIO16 | Output Port (IO1_6)
Public property | OutputPortIO16AI | Output Port (IO1_6) [AI]
Public property | OutputPortIO17 | Output Port (IO1_7)
Public property | OutputPortIO17AI | Output Port (IO1_7) [AI]
Public property | OutputPortIO20 | Output Port (IO2_0)
Public property | OutputPortIO20AI | Output Port (IO2_0) [AI]
Public property | OutputPortIO21 | Output Port (IO2_1)
Public property | OutputPortIO21AI | Output Port (IO2_1) [AI]
Public property | OutputPortIO22 | Output Port (IO2_2)
Public property | OutputPortIO22AI | Output Port (IO2_2) [AI]
Public property | OutputPortIO23 | Output Port (IO2_3)
Public property | OutputPortIO23AI | Output Port (IO2_3) [AI]
Public property | OutputPortIO24 | Output Port (IO2_4)
Public property | OutputPortIO24AI | Output Port (IO2_4) [AI]
Public property | OutputPortIO25 | Output Port (IO2_5)
Public property | OutputPortIO25AI | Output Port (IO2_5) [AI]
Public property | OutputPortIO26 | Output Port (IO2_6)
Public property | OutputPortIO26AI | Output Port (IO2_6) [AI]
Public property | OutputPortIO27 | Output Port (IO2_7)
Public property | OutputPortIO27AI | Output Port (IO2_7) [AI]
Public property | OutputPortIO30 | Output Port (IO3_0)
Public property | OutputPortIO30AI | Output Port (IO3_0) [AI]
Public property | OutputPortIO31 | Output Port (IO3_1)
Public property | OutputPortIO31AI | Output Port (IO3_1) [AI]
Public property | OutputPortIO32 | Output Port (IO3_2)
Public property | OutputPortIO32AI | Output Port (IO3_2) [AI]
Public property | OutputPortIO33 | Output Port (IO3_3)
Public property | OutputPortIO33AI | Output Port (IO3_3) [AI]
Public property | OutputPortIO34 | Output Port (IO3_4)
Public property | OutputPortIO34AI | Output Port (IO3_4) [AI]
Public property | OutputPortIO35 | Output Port (IO3_5)
Public property | OutputPortIO35AI | Output Port (IO3_5) [AI]
Public property | OutputPortIO36 | Output Port (IO3_6)
Public property | OutputPortIO36AI | Output Port (IO3_6) [AI]
Public property | OutputPortIO37 | Output Port (IO3_7)
Public property | OutputPortIO37AI | Output Port (IO3_7) [AI]
Public property | PolarityInversionIO00 | Polarity Inversion (IO0_0)
Public property | PolarityInversionIO00AI | Polarity Inversion (IO0_0) [AI]
Public property | PolarityInversionIO01 | Polarity Inversion (IO0_1)
Public property | PolarityInversionIO01AI | Polarity Inversion (IO0_1) [AI]
Public property | PolarityInversionIO02 | Polarity Inversion (IO0_2)
Public property | PolarityInversionIO02AI | Polarity Inversion (IO0_2) [AI]
Public property | PolarityInversionIO03 | Polarity Inversion (IO0_3)
Public property | PolarityInversionIO03AI | Polarity Inversion (IO0_3) [AI]
Public property | PolarityInversionIO04 | Polarity Inversion (IO0_4)
Public property | PolarityInversionIO04AI | Polarity Inversion (IO0_4) [AI]
Public property | PolarityInversionIO05 | Polarity Inversion (IO0_5)
Public property | PolarityInversionIO05AI | Polarity Inversion (IO0_5) [AI]
Public property | PolarityInversionIO06 | Polarity Inversion (IO0_6)
Public property | PolarityInversionIO06AI | Polarity Inversion (IO0_6) [AI]
Public property | PolarityInversionIO07 | Polarity Inversion (IO0_7)
Public property | PolarityInversionIO07AI | Polarity Inversion (IO0_7) [AI]
Public property | PolarityInversionIO10 | Polarity Inversion (IO1_0)
Public property | PolarityInversionIO10AI | Polarity Inversion (IO1_0) [AI]
Public property | PolarityInversionIO11 | Polarity Inversion (IO1_1)
Public property | PolarityInversionIO11AI | Polarity Inversion (IO1_1) [AI]
Public property | PolarityInversionIO12 | Polarity Inversion (IO1_2)
Public property | PolarityInversionIO12AI | Polarity Inversion (IO1_2) [AI]
Public property | PolarityInversionIO13 | Polarity Inversion (IO1_3)
Public property | PolarityInversionIO13AI | Polarity Inversion (IO1_3) [AI]
Public property | PolarityInversionIO14 | Polarity Inversion (IO1_4)
Public property | PolarityInversionIO14AI | Polarity Inversion (IO1_4) [AI]
Public property | PolarityInversionIO15 | Polarity Inversion (IO1_5)
Public property | PolarityInversionIO15AI | Polarity Inversion (IO1_5) [AI]
Public property | PolarityInversionIO16 | Polarity Inversion (IO1_6)
Public property | PolarityInversionIO16AI | Polarity Inversion (IO1_6) [AI]
Public property | PolarityInversionIO17 | Polarity Inversion (IO1_7)
Public property | PolarityInversionIO17AI | Polarity Inversion (IO1_7) [AI]
Public property | PolarityInversionIO20 | Polarity Inversion (IO2_0)
Public property | PolarityInversionIO20AI | Polarity Inversion (IO2_0) [AI]
Public property | PolarityInversionIO21 | Polarity Inversion (IO2_1)
Public property | PolarityInversionIO21AI | Polarity Inversion (IO2_1) [AI]
Public property | PolarityInversionIO22 | Polarity Inversion (IO2_2)
Public property | PolarityInversionIO22AI | Polarity Inversion (IO2_2) [AI]
Public property | PolarityInversionIO23 | Polarity Inversion (IO2_3)
Public property | PolarityInversionIO23AI | Polarity Inversion (IO2_3) [AI]
Public property | PolarityInversionIO24 | Polarity Inversion (IO2_4)
Public property | PolarityInversionIO24AI | Polarity Inversion (IO2_4) [AI]
Public property | PolarityInversionIO25 | Polarity Inversion (IO2_5)
Public property | PolarityInversionIO25AI | Polarity Inversion (IO2_5) [AI]
Public property | PolarityInversionIO26 | Polarity Inversion (IO2_6)
Public property | PolarityInversionIO26AI | Polarity Inversion (IO2_6) [AI]
Public property | PolarityInversionIO27 | Polarity Inversion (IO2_7)
Public property | PolarityInversionIO27AI | Polarity Inversion (IO2_7) [AI]
Public property | PolarityInversionIO30 | Polarity Inversion (IO3_0)
Public property | PolarityInversionIO30AI | Polarity Inversion (IO3_0) [AI]
Public property | PolarityInversionIO31 | Polarity Inversion (IO3_1)
Public property | PolarityInversionIO31AI | Polarity Inversion (IO3_1) [AI]
Public property | PolarityInversionIO32 | Polarity Inversion (IO3_2)
Public property | PolarityInversionIO32AI | Polarity Inversion (IO3_2) [AI]
Public property | PolarityInversionIO33 | Polarity Inversion (IO3_3)
Public property | PolarityInversionIO33AI | Polarity Inversion (IO3_3) [AI]
Public property | PolarityInversionIO34 | Polarity Inversion (IO3_4)
Public property | PolarityInversionIO34AI | Polarity Inversion (IO3_4) [AI]
Public property | PolarityInversionIO35 | Polarity Inversion (IO3_5)
Public property | PolarityInversionIO35AI | Polarity Inversion (IO3_5) [AI]
Public property | PolarityInversionIO36 | Polarity Inversion (IO3_6)
Public property | PolarityInversionIO36AI | Polarity Inversion (IO3_6) [AI]
Public property | PolarityInversionIO37 | Polarity Inversion (IO3_7)
Public property | PolarityInversionIO37AI | Polarity Inversion (IO3_7) [AI]
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
40-Bit I2C-Bus I/O Port With RESET, OE And INT
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca95059506 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca95059506(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca95059506

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506 Properties

The Pca95059506 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | InputPortIO00 | Input Port (IO0_0)
Public property | InputPortIO00AI | Input Port (IO0_0) [AI]
Public property | InputPortIO01 | Input Port (IO0_1)
Public property | InputPortIO01AI | Input Port (IO0_1) [AI]
Public property | InputPortIO02 | Input Port (IO0_2)
Public property | InputPortIO02AI | Input Port (IO0_2) [AI]
Public property | InputPortIO03 | Input Port (IO0_3)
Public property | InputPortIO03AI | Input Port (IO0_3) [AI]
Public property | InputPortIO04 | Input Port (IO0_4)
Public property | InputPortIO04AI | Input Port (IO0_4) [AI]
Public property | InputPortIO05 | Input Port (IO0_5)
Public property | InputPortIO05AI | Input Port (IO0_5) [AI]
Public property | InputPortIO06 | Input Port (IO0_6)
Public property | InputPortIO06AI | Input Port (IO0_6) [AI]
Public property | InputPortIO07 | Input Port (IO0_7)
Public property | InputPortIO07AI | Input Port (IO0_7) [AI]
Public property | InputPortIO10 | Input Port (IO1_0)
Public property | InputPortIO10AI | Input Port (IO1_0) [AI]
Public property | InputPortIO11 | Input Port (IO1_1)
Public property | InputPortIO11AI | Input Port (IO1_1) [AI]
Public property | InputPortIO12 | Input Port (IO1_2)
Public property | InputPortIO12AI | Input Port (IO1_2) [AI]
Public property | InputPortIO13 | Input Port (IO1_3)
Public property | InputPortIO13AI | Input Port (IO1_3) [AI]
Public property | InputPortIO14 | Input Port (IO1_4)
Public property | InputPortIO14AI | Input Port (IO1_4) [AI]
Public property | InputPortIO15 | Input Port (IO1_5)
Public property | InputPortIO15AI | Input Port (IO1_5) [AI]
Public property | InputPortIO16 | Input Port (IO1_6)
Public property | InputPortIO16AI | Input Port (IO1_6) [AI]
Public property | InputPortIO17 | Input Port (IO1_7)
Public property | InputPortIO17AI | Input Port (IO1_7) [AI]
Public property | InputPortIO20 | Input Port (IO2_0)
Public property | InputPortIO20AI | Input Port (IO2_0) [AI]
Public property | InputPortIO21 | Input Port (IO2_1)
Public property | InputPortIO21AI | Input Port (IO2_1) [AI]
Public property | InputPortIO22 | Input Port (IO2_2)
Public property | InputPortIO22AI | Input Port (IO2_2) [AI]
Public property | InputPortIO23 | Input Port (IO2_3)
Public property | InputPortIO23AI | Input Port (IO2_3) [AI]
Public property | InputPortIO24 | Input Port (IO2_4)
Public property | InputPortIO24AI | Input Port (IO2_4) [AI]
Public property | InputPortIO25 | Input Port (IO2_5)
Public property | InputPortIO25AI | Input Port (IO2_5) [AI]
Public property | InputPortIO26 | Input Port (IO2_6)
Public property | InputPortIO26AI | Input Port (IO2_6) [AI]
Public property | InputPortIO27 | Input Port (IO2_7)
Public property | InputPortIO27AI | Input Port (IO2_7) [AI]
Public property | InputPortIO30 | Input Port (IO3_0)
Public property | InputPortIO30AI | Input Port (IO3_0) [AI]
Public property | InputPortIO31 | Input Port (IO3_1)
Public property | InputPortIO31AI | Input Port (IO3_1) [AI]
Public property | InputPortIO32 | Input Port (IO3_2)
Public property | InputPortIO32AI | Input Port (IO3_2) [AI]
Public property | InputPortIO33 | Input Port (IO3_3)
Public property | InputPortIO33AI | Input Port (IO3_3) [AI]
Public property | InputPortIO34 | Input Port (IO3_4)
Public property | InputPortIO34AI | Input Port (IO3_4) [AI]
Public property | InputPortIO35 | Input Port (IO3_5)
Public property | InputPortIO35AI | Input Port (IO3_5) [AI]
Public property | InputPortIO36 | Input Port (IO3_6)
Public property | InputPortIO36AI | Input Port (IO3_6) [AI]
Public property | InputPortIO37 | Input Port (IO3_7)
Public property | InputPortIO37AI | Input Port (IO3_7) [AI]
Public property | IOConfigurationIO00 | I/O Configuration (IO0_0)
Public property | IOConfigurationIO00AI | I/O Configuration (IO0_0) [AI]
Public property | IOConfigurationIO01 | I/O Configuration (IO0_1)
Public property | IOConfigurationIO01AI | I/O Configuration (IO0_1) [AI]
Public property | IOConfigurationIO02 | I/O Configuration (IO0_2)
Public property | IOConfigurationIO02AI | I/O Configuration (IO0_2) [AI]
Public property | IOConfigurationIO03 | I/O Configuration (IO0_3)
Public property | IOConfigurationIO03AI | I/O Configuration (IO0_3) [AI]
Public property | IOConfigurationIO04 | I/O Configuration (IO0_4)
Public property | IOConfigurationIO04AI | I/O Configuration (IO0_4) [AI]
Public property | IOConfigurationIO05 | I/O Configuration (IO0_5)
Public property | IOConfigurationIO05AI | I/O Configuration (IO0_5) [AI]
Public property | IOConfigurationIO06 | I/O Configuration (IO0_6)
Public property | IOConfigurationIO06AI | I/O Configuration (IO0_6) [AI]
Public property | IOConfigurationIO07 | I/O Configuration (IO0_7)
Public property | IOConfigurationIO07AI | I/O Configuration (IO0_7) [AI]
Public property | IOConfigurationIO10 | I/O Configuration (IO1_0)
Public property | IOConfigurationIO10AI | I/O Configuration (IO1_0) [AI]
Public property | IOConfigurationIO11 | I/O Configuration (IO1_1)
Public property | IOConfigurationIO11AI | I/O Configuration (IO1_1) [AI]
Public property | IOConfigurationIO12 | I/O Configuration (IO1_2)
Public property | IOConfigurationIO12AI | I/O Configuration (IO1_2) [AI]
Public property | IOConfigurationIO13 | I/O Configuration (IO1_3)
Public property | IOConfigurationIO13AI | I/O Configuration (IO1_3) [AI]
Public property | IOConfigurationIO14 | I/O Configuration (IO1_4)
Public property | IOConfigurationIO14AI | I/O Configuration (IO1_4) [AI]
Public property | IOConfigurationIO15 | I/O Configuration (IO1_5)
Public property | IOConfigurationIO15AI | I/O Configuration (IO1_5) [AI]
Public property | IOConfigurationIO16 | I/O Configuration (IO1_6)
Public property | IOConfigurationIO16AI | I/O Configuration (IO1_6) [AI]
Public property | IOConfigurationIO17 | I/O Configuration (IO1_7)
Public property | IOConfigurationIO17AI | I/O Configuration (IO1_7) [AI]
Public property | IOConfigurationIO20 | I/O Configuration (IO2_0)
Public property | IOConfigurationIO20AI | I/O Configuration (IO2_0) [AI]
Public property | IOConfigurationIO21 | I/O Configuration (IO2_1)
Public property | IOConfigurationIO21AI | I/O Configuration (IO2_1) [AI]
Public property | IOConfigurationIO22 | I/O Configuration (IO2_2)
Public property | IOConfigurationIO22AI | I/O Configuration (IO2_2) [AI]
Public property | IOConfigurationIO23 | I/O Configuration (IO2_3)
Public property | IOConfigurationIO23AI | I/O Configuration (IO2_3) [AI]
Public property | IOConfigurationIO24 | I/O Configuration (IO2_4)
Public property | IOConfigurationIO24AI | I/O Configuration (IO2_4) [AI]
Public property | IOConfigurationIO25 | I/O Configuration (IO2_5)
Public property | IOConfigurationIO25AI | I/O Configuration (IO2_5) [AI]
Public property | IOConfigurationIO26 | I/O Configuration (IO2_6)
Public property | IOConfigurationIO26AI | I/O Configuration (IO2_6) [AI]
Public property | IOConfigurationIO27 | I/O Configuration (IO2_7)
Public property | IOConfigurationIO27AI | I/O Configuration (IO2_7) [AI]
Public property | IOConfigurationIO30 | I/O Configuration (IO3_0)
Public property | IOConfigurationIO30AI | I/O Configuration (IO3_0) [AI]
Public property | IOConfigurationIO31 | I/O Configuration (IO3_1)
Public property | IOConfigurationIO31AI | I/O Configuration (IO3_1) [AI]
Public property | IOConfigurationIO32 | I/O Configuration (IO3_2)
Public property | IOConfigurationIO32AI | I/O Configuration (IO3_2) [AI]
Public property | IOConfigurationIO33 | I/O Configuration (IO3_3)
Public property | IOConfigurationIO33AI | I/O Configuration (IO3_3) [AI]
Public property | IOConfigurationIO34 | I/O Configuration (IO3_4)
Public property | IOConfigurationIO34AI | I/O Configuration (IO3_4) [AI]
Public property | IOConfigurationIO35 | I/O Configuration (IO3_5)
Public property | IOConfigurationIO35AI | I/O Configuration (IO3_5) [AI]
Public property | IOConfigurationIO36 | I/O Configuration (IO3_6)
Public property | IOConfigurationIO36AI | I/O Configuration (IO3_6) [AI]
Public property | IOConfigurationIO37 | I/O Configuration (IO3_7)
Public property | IOConfigurationIO37AI | I/O Configuration (IO3_7) [AI]
Public property | MaskInterruptIO00 | Mask Interrupt (IO0_0)
Public property | MaskInterruptIO00AI | Mask Interrupt (IO0_0) [AI]
Public property | MaskInterruptIO01 | Mask Interrupt (IO0_1)
Public property | MaskInterruptIO01AI | Mask Interrupt (IO0_1) [AI]
Public property | MaskInterruptIO02 | Mask Interrupt (IO0_2)
Public property | MaskInterruptIO02AI | Mask Interrupt (IO0_2) [AI]
Public property | MaskInterruptIO03 | Mask Interrupt (IO0_3)
Public property | MaskInterruptIO03AI | Mask Interrupt (IO0_3) [AI]
Public property | MaskInterruptIO04 | Mask Interrupt (IO0_4)
Public property | MaskInterruptIO04AI | Mask Interrupt (IO0_4) [AI]
Public property | MaskInterruptIO05 | Mask Interrupt (IO0_5)
Public property | MaskInterruptIO05AI | Mask Interrupt (IO0_5) [AI]
Public property | MaskInterruptIO06 | Mask Interrupt (IO0_6)
Public property | MaskInterruptIO06AI | Mask Interrupt (IO0_6) [AI]
Public property | MaskInterruptIO07 | Mask Interrupt (IO0_7)
Public property | MaskInterruptIO07AI | Mask Interrupt (IO0_7) [AI]
Public property | MaskInterruptIO10 | Mask Interrupt (IO1_0)
Public property | MaskInterruptIO10AI | Mask Interrupt (IO1_0) [AI]
Public property | MaskInterruptIO11 | Mask Interrupt (IO1_1)
Public property | MaskInterruptIO11AI | Mask Interrupt (IO1_1) [AI]
Public property | MaskInterruptIO12 | Mask Interrupt (IO1_2)
Public property | MaskInterruptIO12AI | Mask Interrupt (IO1_2) [AI]
Public property | MaskInterruptIO13 | Mask Interrupt (IO1_3)
Public property | MaskInterruptIO13AI | Mask Interrupt (IO1_3) [AI]
Public property | MaskInterruptIO14 | Mask Interrupt (IO1_4)
Public property | MaskInterruptIO14AI | Mask Interrupt (IO1_4) [AI]
Public property | MaskInterruptIO15 | Mask Interrupt (IO1_5)
Public property | MaskInterruptIO15AI | Mask Interrupt (IO1_5) [AI]
Public property | MaskInterruptIO16 | Mask Interrupt (IO1_6)
Public property | MaskInterruptIO16AI | Mask Interrupt (IO1_6) [AI]
Public property | MaskInterruptIO17 | Mask Interrupt (IO1_7)
Public property | MaskInterruptIO17AI | Mask Interrupt (IO1_7) [AI]
Public property | MaskInterruptIO20 | Mask Interrupt (IO2_0)
Public property | MaskInterruptIO20AI | Mask Interrupt (IO2_0) [AI]
Public property | MaskInterruptIO21 | Mask Interrupt (IO2_1)
Public property | MaskInterruptIO21AI | Mask Interrupt (IO2_1) [AI]
Public property | MaskInterruptIO22 | Mask Interrupt (IO2_2)
Public property | MaskInterruptIO22AI | Mask Interrupt (IO2_2) [AI]
Public property | MaskInterruptIO23 | Mask Interrupt (IO2_3)
Public property | MaskInterruptIO23AI | Mask Interrupt (IO2_3) [AI]
Public property | MaskInterruptIO24 | Mask Interrupt (IO2_4)
Public property | MaskInterruptIO24AI | Mask Interrupt (IO2_4) [AI]
Public property | MaskInterruptIO25 | Mask Interrupt (IO2_5)
Public property | MaskInterruptIO25AI | Mask Interrupt (IO2_5) [AI]
Public property | MaskInterruptIO26 | Mask Interrupt (IO2_6)
Public property | MaskInterruptIO26AI | Mask Interrupt (IO2_6) [AI]
Public property | MaskInterruptIO27 | Mask Interrupt (IO2_7)
Public property | MaskInterruptIO27AI | Mask Interrupt (IO2_7) [AI]
Public property | MaskInterruptIO30 | Mask Interrupt (IO3_0)
Public property | MaskInterruptIO30AI | Mask Interrupt (IO3_0) [AI]
Public property | MaskInterruptIO31 | Mask Interrupt (IO3_1)
Public property | MaskInterruptIO31AI | Mask Interrupt (IO3_1) [AI]
Public property | MaskInterruptIO32 | Mask Interrupt (IO3_2)
Public property | MaskInterruptIO32AI | Mask Interrupt (IO3_2) [AI]
Public property | MaskInterruptIO33 | Mask Interrupt (IO3_3)
Public property | MaskInterruptIO33AI | Mask Interrupt (IO3_3) [AI]
Public property | MaskInterruptIO34 | Mask Interrupt (IO3_4)
Public property | MaskInterruptIO34AI | Mask Interrupt (IO3_4) [AI]
Public property | MaskInterruptIO35 | Mask Interrupt (IO3_5)
Public property | MaskInterruptIO35AI | Mask Interrupt (IO3_5) [AI]
Public property | MaskInterruptIO36 | Mask Interrupt (IO3_6)
Public property | MaskInterruptIO36AI | Mask Interrupt (IO3_6) [AI]
Public property | MaskInterruptIO37 | Mask Interrupt (IO3_7)
Public property | MaskInterruptIO37AI | Mask Interrupt (IO3_7) [AI]
Public property | OutputPortIO00 | Output Port (IO0_0)
Public property | OutputPortIO00AI | Output Port (IO0_0) [AI]
Public property | OutputPortIO01 | Output Port (IO0_1)
Public property | OutputPortIO01AI | Output Port (IO0_1) [AI]
Public property | OutputPortIO02 | Output Port (IO0_2)
Public property | OutputPortIO02AI | Output Port (IO0_2) [AI]
Public property | OutputPortIO03 | Output Port (IO0_3)
Public property | OutputPortIO03AI | Output Port (IO0_3) [AI]
Public property | OutputPortIO04 | Output Port (IO0_4)
Public property | OutputPortIO04AI | Output Port (IO0_4) [AI]
Public property | OutputPortIO05 | Output Port (IO0_5)
Public property | OutputPortIO05AI | Output Port (IO0_5) [AI]
Public property | OutputPortIO06 | Output Port (IO0_6)
Public property | OutputPortIO06AI | Output Port (IO0_6) [AI]
Public property | OutputPortIO07 | Output Port (IO0_7)
Public property | OutputPortIO07AI | Output Port (IO0_7) [AI]
Public property | OutputPortIO10 | Output Port (IO1_0)
Public property | OutputPortIO10AI | Output Port (IO1_0) [AI]
Public property | OutputPortIO11 | Output Port (IO1_1)
Public property | OutputPortIO11AI | Output Port (IO1_1) [AI]
Public property | OutputPortIO12 | Output Port (IO1_2)
Public property | OutputPortIO12AI | Output Port (IO1_2) [AI]
Public property | OutputPortIO13 | Output Port (IO1_3)
Public property | OutputPortIO13AI | Output Port (IO1_3) [AI]
Public property | OutputPortIO14 | Output Port (IO1_4)
Public property | OutputPortIO14AI | Output Port (IO1_4) [AI]
Public property | OutputPortIO15 | Output Port (IO1_5)
Public property | OutputPortIO15AI | Output Port (IO1_5) [AI]
Public property | OutputPortIO16 | Output Port (IO1_6)
Public property | OutputPortIO16AI | Output Port (IO1_6) [AI]
Public property | OutputPortIO17 | Output Port (IO1_7)
Public property | OutputPortIO17AI | Output Port (IO1_7) [AI]
Public property | OutputPortIO20 | Output Port (IO2_0)
Public property | OutputPortIO20AI | Output Port (IO2_0) [AI]
Public property | OutputPortIO21 | Output Port (IO2_1)
Public property | OutputPortIO21AI | Output Port (IO2_1) [AI]
Public property | OutputPortIO22 | Output Port (IO2_2)
Public property | OutputPortIO22AI | Output Port (IO2_2) [AI]
Public property | OutputPortIO23 | Output Port (IO2_3)
Public property | OutputPortIO23AI | Output Port (IO2_3) [AI]
Public property | OutputPortIO24 | Output Port (IO2_4)
Public property | OutputPortIO24AI | Output Port (IO2_4) [AI]
Public property | OutputPortIO25 | Output Port (IO2_5)
Public property | OutputPortIO25AI | Output Port (IO2_5) [AI]
Public property | OutputPortIO26 | Output Port (IO2_6)
Public property | OutputPortIO26AI | Output Port (IO2_6) [AI]
Public property | OutputPortIO27 | Output Port (IO2_7)
Public property | OutputPortIO27AI | Output Port (IO2_7) [AI]
Public property | OutputPortIO30 | Output Port (IO3_0)
Public property | OutputPortIO30AI | Output Port (IO3_0) [AI]
Public property | OutputPortIO31 | Output Port (IO3_1)
Public property | OutputPortIO31AI | Output Port (IO3_1) [AI]
Public property | OutputPortIO32 | Output Port (IO3_2)
Public property | OutputPortIO32AI | Output Port (IO3_2) [AI]
Public property | OutputPortIO33 | Output Port (IO3_3)
Public property | OutputPortIO33AI | Output Port (IO3_3) [AI]
Public property | OutputPortIO34 | Output Port (IO3_4)
Public property | OutputPortIO34AI | Output Port (IO3_4) [AI]
Public property | OutputPortIO35 | Output Port (IO3_5)
Public property | OutputPortIO35AI | Output Port (IO3_5) [AI]
Public property | OutputPortIO36 | Output Port (IO3_6)
Public property | OutputPortIO36AI | Output Port (IO3_6) [AI]
Public property | OutputPortIO37 | Output Port (IO3_7)
Public property | OutputPortIO37AI | Output Port (IO3_7) [AI]
Public property | PolarityInversionIO00 | Polarity Inversion (IO0_0)
Public property | PolarityInversionIO00AI | Polarity Inversion (IO0_0) [AI]
Public property | PolarityInversionIO01 | Polarity Inversion (IO0_1)
Public property | PolarityInversionIO01AI | Polarity Inversion (IO0_1) [AI]
Public property | PolarityInversionIO02 | Polarity Inversion (IO0_2)
Public property | PolarityInversionIO02AI | Polarity Inversion (IO0_2) [AI]
Public property | PolarityInversionIO03 | Polarity Inversion (IO0_3)
Public property | PolarityInversionIO03AI | Polarity Inversion (IO0_3) [AI]
Public property | PolarityInversionIO04 | Polarity Inversion (IO0_4)
Public property | PolarityInversionIO04AI | Polarity Inversion (IO0_4) [AI]
Public property | PolarityInversionIO05 | Polarity Inversion (IO0_5)
Public property | PolarityInversionIO05AI | Polarity Inversion (IO0_5) [AI]
Public property | PolarityInversionIO06 | Polarity Inversion (IO0_6)
Public property | PolarityInversionIO06AI | Polarity Inversion (IO0_6) [AI]
Public property | PolarityInversionIO07 | Polarity Inversion (IO0_7)
Public property | PolarityInversionIO07AI | Polarity Inversion (IO0_7) [AI]
Public property | PolarityInversionIO10 | Polarity Inversion (IO1_0)
Public property | PolarityInversionIO10AI | Polarity Inversion (IO1_0) [AI]
Public property | PolarityInversionIO11 | Polarity Inversion (IO1_1)
Public property | PolarityInversionIO11AI | Polarity Inversion (IO1_1) [AI]
Public property | PolarityInversionIO12 | Polarity Inversion (IO1_2)
Public property | PolarityInversionIO12AI | Polarity Inversion (IO1_2) [AI]
Public property | PolarityInversionIO13 | Polarity Inversion (IO1_3)
Public property | PolarityInversionIO13AI | Polarity Inversion (IO1_3) [AI]
Public property | PolarityInversionIO14 | Polarity Inversion (IO1_4)
Public property | PolarityInversionIO14AI | Polarity Inversion (IO1_4) [AI]
Public property | PolarityInversionIO15 | Polarity Inversion (IO1_5)
Public property | PolarityInversionIO15AI | Polarity Inversion (IO1_5) [AI]
Public property | PolarityInversionIO16 | Polarity Inversion (IO1_6)
Public property | PolarityInversionIO16AI | Polarity Inversion (IO1_6) [AI]
Public property | PolarityInversionIO17 | Polarity Inversion (IO1_7)
Public property | PolarityInversionIO17AI | Polarity Inversion (IO1_7) [AI]
Public property | PolarityInversionIO20 | Polarity Inversion (IO2_0)
Public property | PolarityInversionIO20AI | Polarity Inversion (IO2_0) [AI]
Public property | PolarityInversionIO21 | Polarity Inversion (IO2_1)
Public property | PolarityInversionIO21AI | Polarity Inversion (IO2_1) [AI]
Public property | PolarityInversionIO22 | Polarity Inversion (IO2_2)
Public property | PolarityInversionIO22AI | Polarity Inversion (IO2_2) [AI]
Public property | PolarityInversionIO23 | Polarity Inversion (IO2_3)
Public property | PolarityInversionIO23AI | Polarity Inversion (IO2_3) [AI]
Public property | PolarityInversionIO24 | Polarity Inversion (IO2_4)
Public property | PolarityInversionIO24AI | Polarity Inversion (IO2_4) [AI]
Public property | PolarityInversionIO25 | Polarity Inversion (IO2_5)
Public property | PolarityInversionIO25AI | Polarity Inversion (IO2_5) [AI]
Public property | PolarityInversionIO26 | Polarity Inversion (IO2_6)
Public property | PolarityInversionIO26AI | Polarity Inversion (IO2_6) [AI]
Public property | PolarityInversionIO27 | Polarity Inversion (IO2_7)
Public property | PolarityInversionIO27AI | Polarity Inversion (IO2_7) [AI]
Public property | PolarityInversionIO30 | Polarity Inversion (IO3_0)
Public property | PolarityInversionIO30AI | Polarity Inversion (IO3_0) [AI]
Public property | PolarityInversionIO31 | Polarity Inversion (IO3_1)
Public property | PolarityInversionIO31AI | Polarity Inversion (IO3_1) [AI]
Public property | PolarityInversionIO32 | Polarity Inversion (IO3_2)
Public property | PolarityInversionIO32AI | Polarity Inversion (IO3_2) [AI]
Public property | PolarityInversionIO33 | Polarity Inversion (IO3_3)
Public property | PolarityInversionIO33AI | Polarity Inversion (IO3_3) [AI]
Public property | PolarityInversionIO34 | Polarity Inversion (IO3_4)
Public property | PolarityInversionIO34AI | Polarity Inversion (IO3_4) [AI]
Public property | PolarityInversionIO35 | Polarity Inversion (IO3_5)
Public property | PolarityInversionIO35AI | Polarity Inversion (IO3_5) [AI]
Public property | PolarityInversionIO36 | Polarity Inversion (IO3_6)
Public property | PolarityInversionIO36AI | Polarity Inversion (IO3_6) [AI]
Public property | PolarityInversionIO37 | Polarity Inversion (IO3_7)
Public property | PolarityInversionIO37AI | Polarity Inversion (IO3_7) [AI]
Top
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.AutoFlush Property

IRD

Pca95059506AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO00 Property

IRD

Pca95059506InputPortIO00 Property

Input Port (IO0_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO00 { get; }
Public ReadOnly Property InputPortIO00 As Byte
    Get
public:
property unsigned char InputPortIO00 {
    unsigned char get ();
}
member InputPortIO00 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO00AI Property

IRD

Pca95059506InputPortIO00AI Property

Input Port (IO0_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO00AI { get; }
Public ReadOnly Property InputPortIO00AI As Byte
    Get
public:
property unsigned char InputPortIO00AI {
    unsigned char get ();
}
member InputPortIO00AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO01 Property

IRD

Pca95059506InputPortIO01 Property

Input Port (IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO01 { get; }
Public ReadOnly Property InputPortIO01 As Byte
    Get
public:
property unsigned char InputPortIO01 {
    unsigned char get ();
}
member InputPortIO01 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO01AI Property

IRD

Pca95059506InputPortIO01AI Property

Input Port (IO0_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO01AI { get; }
Public ReadOnly Property InputPortIO01AI As Byte
    Get
public:
property unsigned char InputPortIO01AI {
    unsigned char get ();
}
member InputPortIO01AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO02 Property

IRD

Pca95059506InputPortIO02 Property

Input Port (IO0_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO02 { get; }
Public ReadOnly Property InputPortIO02 As Byte
    Get
public:
property unsigned char InputPortIO02 {
    unsigned char get ();
}
member InputPortIO02 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO02AI Property

IRD

Pca95059506InputPortIO02AI Property

Input Port (IO0_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO02AI { get; }
Public ReadOnly Property InputPortIO02AI As Byte
    Get
public:
property unsigned char InputPortIO02AI {
    unsigned char get ();
}
member InputPortIO02AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO03 Property

IRD

Pca95059506InputPortIO03 Property

Input Port (IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO03 { get; }
Public ReadOnly Property InputPortIO03 As Byte
    Get
public:
property unsigned char InputPortIO03 {
    unsigned char get ();
}
member InputPortIO03 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO03AI Property

IRD

Pca95059506InputPortIO03AI Property

Input Port (IO0_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO03AI { get; }
Public ReadOnly Property InputPortIO03AI As Byte
    Get
public:
property unsigned char InputPortIO03AI {
    unsigned char get ();
}
member InputPortIO03AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO04 Property

IRD

Pca95059506InputPortIO04 Property

Input Port (IO0_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO04 { get; }
Public ReadOnly Property InputPortIO04 As Byte
    Get
public:
property unsigned char InputPortIO04 {
    unsigned char get ();
}
member InputPortIO04 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO04AI Property

IRD

Pca95059506InputPortIO04AI Property

Input Port (IO0_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO04AI { get; }
Public ReadOnly Property InputPortIO04AI As Byte
    Get
public:
property unsigned char InputPortIO04AI {
    unsigned char get ();
}
member InputPortIO04AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO05 Property

IRD

Pca95059506InputPortIO05 Property

Input Port (IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO05 { get; }
Public ReadOnly Property InputPortIO05 As Byte
    Get
public:
property unsigned char InputPortIO05 {
    unsigned char get ();
}
member InputPortIO05 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO05AI Property

IRD

Pca95059506InputPortIO05AI Property

Input Port (IO0_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO05AI { get; }
Public ReadOnly Property InputPortIO05AI As Byte
    Get
public:
property unsigned char InputPortIO05AI {
    unsigned char get ();
}
member InputPortIO05AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO06 Property

IRD

Pca95059506InputPortIO06 Property

Input Port (IO0_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO06 { get; }
Public ReadOnly Property InputPortIO06 As Byte
    Get
public:
property unsigned char InputPortIO06 {
    unsigned char get ();
}
member InputPortIO06 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO06AI Property

IRD

Pca95059506InputPortIO06AI Property

Input Port (IO0_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO06AI { get; }
Public ReadOnly Property InputPortIO06AI As Byte
    Get
public:
property unsigned char InputPortIO06AI {
    unsigned char get ();
}
member InputPortIO06AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO07 Property

IRD

Pca95059506InputPortIO07 Property

Input Port (IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO07 { get; }
Public ReadOnly Property InputPortIO07 As Byte
    Get
public:
property unsigned char InputPortIO07 {
    unsigned char get ();
}
member InputPortIO07 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO07AI Property

IRD

Pca95059506InputPortIO07AI Property

Input Port (IO0_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO07AI { get; }
Public ReadOnly Property InputPortIO07AI As Byte
    Get
public:
property unsigned char InputPortIO07AI {
    unsigned char get ();
}
member InputPortIO07AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO10 Property

IRD

Pca95059506InputPortIO10 Property

Input Port (IO1_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO10 { get; }
Public ReadOnly Property InputPortIO10 As Byte
    Get
public:
property unsigned char InputPortIO10 {
    unsigned char get ();
}
member InputPortIO10 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO10AI Property

IRD

Pca95059506InputPortIO10AI Property

Input Port (IO1_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO10AI { get; }
Public ReadOnly Property InputPortIO10AI As Byte
    Get
public:
property unsigned char InputPortIO10AI {
    unsigned char get ();
}
member InputPortIO10AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO11 Property

IRD

Pca95059506InputPortIO11 Property

Input Port (IO1_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO11 { get; }
Public ReadOnly Property InputPortIO11 As Byte
    Get
public:
property unsigned char InputPortIO11 {
    unsigned char get ();
}
member InputPortIO11 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO11AI Property

IRD

Pca95059506InputPortIO11AI Property

Input Port (IO1_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO11AI { get; }
Public ReadOnly Property InputPortIO11AI As Byte
    Get
public:
property unsigned char InputPortIO11AI {
    unsigned char get ();
}
member InputPortIO11AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO12 Property

IRD

Pca95059506InputPortIO12 Property

Input Port (IO1_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO12 { get; }
Public ReadOnly Property InputPortIO12 As Byte
    Get
public:
property unsigned char InputPortIO12 {
    unsigned char get ();
}
member InputPortIO12 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO12AI Property

IRD

Pca95059506InputPortIO12AI Property

Input Port (IO1_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO12AI { get; }
Public ReadOnly Property InputPortIO12AI As Byte
    Get
public:
property unsigned char InputPortIO12AI {
    unsigned char get ();
}
member InputPortIO12AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO13 Property

IRD

Pca95059506InputPortIO13 Property

Input Port (IO1_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO13 { get; }
Public ReadOnly Property InputPortIO13 As Byte
    Get
public:
property unsigned char InputPortIO13 {
    unsigned char get ();
}
member InputPortIO13 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO13AI Property

IRD

Pca95059506InputPortIO13AI Property

Input Port (IO1_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO13AI { get; }
Public ReadOnly Property InputPortIO13AI As Byte
    Get
public:
property unsigned char InputPortIO13AI {
    unsigned char get ();
}
member InputPortIO13AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO14 Property

IRD

Pca95059506InputPortIO14 Property

Input Port (IO1_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO14 { get; }
Public ReadOnly Property InputPortIO14 As Byte
    Get
public:
property unsigned char InputPortIO14 {
    unsigned char get ();
}
member InputPortIO14 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO14AI Property

IRD

Pca95059506InputPortIO14AI Property

Input Port (IO1_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO14AI { get; }
Public ReadOnly Property InputPortIO14AI As Byte
    Get
public:
property unsigned char InputPortIO14AI {
    unsigned char get ();
}
member InputPortIO14AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO15 Property

IRD

Pca95059506InputPortIO15 Property

Input Port (IO1_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO15 { get; }
Public ReadOnly Property InputPortIO15 As Byte
    Get
public:
property unsigned char InputPortIO15 {
    unsigned char get ();
}
member InputPortIO15 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO15AI Property

IRD

Pca95059506InputPortIO15AI Property

Input Port (IO1_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO15AI { get; }
Public ReadOnly Property InputPortIO15AI As Byte
    Get
public:
property unsigned char InputPortIO15AI {
    unsigned char get ();
}
member InputPortIO15AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO16 Property

IRD

Pca95059506InputPortIO16 Property

Input Port (IO1_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO16 { get; }
Public ReadOnly Property InputPortIO16 As Byte
    Get
public:
property unsigned char InputPortIO16 {
    unsigned char get ();
}
member InputPortIO16 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO16AI Property

IRD

Pca95059506InputPortIO16AI Property

Input Port (IO1_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO16AI { get; }
Public ReadOnly Property InputPortIO16AI As Byte
    Get
public:
property unsigned char InputPortIO16AI {
    unsigned char get ();
}
member InputPortIO16AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO17 Property

IRD

Pca95059506InputPortIO17 Property

Input Port (IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO17 { get; }
Public ReadOnly Property InputPortIO17 As Byte
    Get
public:
property unsigned char InputPortIO17 {
    unsigned char get ();
}
member InputPortIO17 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO17AI Property

IRD

Pca95059506InputPortIO17AI Property

Input Port (IO1_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO17AI { get; }
Public ReadOnly Property InputPortIO17AI As Byte
    Get
public:
property unsigned char InputPortIO17AI {
    unsigned char get ();
}
member InputPortIO17AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO20 Property

IRD

Pca95059506InputPortIO20 Property

Input Port (IO2_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO20 { get; }
Public ReadOnly Property InputPortIO20 As Byte
    Get
public:
property unsigned char InputPortIO20 {
    unsigned char get ();
}
member InputPortIO20 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO20AI Property

IRD

Pca95059506InputPortIO20AI Property

Input Port (IO2_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO20AI { get; }
Public ReadOnly Property InputPortIO20AI As Byte
    Get
public:
property unsigned char InputPortIO20AI {
    unsigned char get ();
}
member InputPortIO20AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO21 Property

IRD

Pca95059506InputPortIO21 Property

Input Port (IO2_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO21 { get; }
Public ReadOnly Property InputPortIO21 As Byte
    Get
public:
property unsigned char InputPortIO21 {
    unsigned char get ();
}
member InputPortIO21 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO21AI Property

IRD

Pca95059506InputPortIO21AI Property

Input Port (IO2_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO21AI { get; }
Public ReadOnly Property InputPortIO21AI As Byte
    Get
public:
property unsigned char InputPortIO21AI {
    unsigned char get ();
}
member InputPortIO21AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO22 Property

IRD

Pca95059506InputPortIO22 Property

Input Port (IO2_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO22 { get; }
Public ReadOnly Property InputPortIO22 As Byte
    Get
public:
property unsigned char InputPortIO22 {
    unsigned char get ();
}
member InputPortIO22 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO22AI Property

IRD

Pca95059506InputPortIO22AI Property

Input Port (IO2_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO22AI { get; }
Public ReadOnly Property InputPortIO22AI As Byte
    Get
public:
property unsigned char InputPortIO22AI {
    unsigned char get ();
}
member InputPortIO22AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO23 Property

IRD

Pca95059506InputPortIO23 Property

Input Port (IO2_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO23 { get; }
Public ReadOnly Property InputPortIO23 As Byte
    Get
public:
property unsigned char InputPortIO23 {
    unsigned char get ();
}
member InputPortIO23 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO23AI Property

IRD

Pca95059506InputPortIO23AI Property

Input Port (IO2_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO23AI { get; }
Public ReadOnly Property InputPortIO23AI As Byte
    Get
public:
property unsigned char InputPortIO23AI {
    unsigned char get ();
}
member InputPortIO23AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO24 Property

IRD

Pca95059506InputPortIO24 Property

Input Port (IO2_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO24 { get; }
Public ReadOnly Property InputPortIO24 As Byte
    Get
public:
property unsigned char InputPortIO24 {
    unsigned char get ();
}
member InputPortIO24 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO24AI Property

IRD

Pca95059506InputPortIO24AI Property

Input Port (IO2_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO24AI { get; }
Public ReadOnly Property InputPortIO24AI As Byte
    Get
public:
property unsigned char InputPortIO24AI {
    unsigned char get ();
}
member InputPortIO24AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO25 Property

IRD

Pca95059506InputPortIO25 Property

Input Port (IO2_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO25 { get; }
Public ReadOnly Property InputPortIO25 As Byte
    Get
public:
property unsigned char InputPortIO25 {
    unsigned char get ();
}
member InputPortIO25 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO25AI Property

IRD

Pca95059506InputPortIO25AI Property

Input Port (IO2_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO25AI { get; }
Public ReadOnly Property InputPortIO25AI As Byte
    Get
public:
property unsigned char InputPortIO25AI {
    unsigned char get ();
}
member InputPortIO25AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO26 Property

IRD

Pca95059506InputPortIO26 Property

Input Port (IO2_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO26 { get; }
Public ReadOnly Property InputPortIO26 As Byte
    Get
public:
property unsigned char InputPortIO26 {
    unsigned char get ();
}
member InputPortIO26 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO26AI Property

IRD

Pca95059506InputPortIO26AI Property

Input Port (IO2_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO26AI { get; }
Public ReadOnly Property InputPortIO26AI As Byte
    Get
public:
property unsigned char InputPortIO26AI {
    unsigned char get ();
}
member InputPortIO26AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO27 Property

IRD

Pca95059506InputPortIO27 Property

Input Port (IO2_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO27 { get; }
Public ReadOnly Property InputPortIO27 As Byte
    Get
public:
property unsigned char InputPortIO27 {
    unsigned char get ();
}
member InputPortIO27 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO27AI Property

IRD

Pca95059506InputPortIO27AI Property

Input Port (IO2_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO27AI { get; }
Public ReadOnly Property InputPortIO27AI As Byte
    Get
public:
property unsigned char InputPortIO27AI {
    unsigned char get ();
}
member InputPortIO27AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO30 Property

IRD

Pca95059506InputPortIO30 Property

Input Port (IO3_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO30 { get; }
Public ReadOnly Property InputPortIO30 As Byte
    Get
public:
property unsigned char InputPortIO30 {
    unsigned char get ();
}
member InputPortIO30 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO30AI Property

IRD

Pca95059506InputPortIO30AI Property

Input Port (IO3_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO30AI { get; }
Public ReadOnly Property InputPortIO30AI As Byte
    Get
public:
property unsigned char InputPortIO30AI {
    unsigned char get ();
}
member InputPortIO30AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO31 Property

IRD

Pca95059506InputPortIO31 Property

Input Port (IO3_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO31 { get; }
Public ReadOnly Property InputPortIO31 As Byte
    Get
public:
property unsigned char InputPortIO31 {
    unsigned char get ();
}
member InputPortIO31 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO31AI Property

IRD

Pca95059506InputPortIO31AI Property

Input Port (IO3_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO31AI { get; }
Public ReadOnly Property InputPortIO31AI As Byte
    Get
public:
property unsigned char InputPortIO31AI {
    unsigned char get ();
}
member InputPortIO31AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO32 Property

IRD

Pca95059506InputPortIO32 Property

Input Port (IO3_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO32 { get; }
Public ReadOnly Property InputPortIO32 As Byte
    Get
public:
property unsigned char InputPortIO32 {
    unsigned char get ();
}
member InputPortIO32 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO32AI Property

IRD

Pca95059506InputPortIO32AI Property

Input Port (IO3_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO32AI { get; }
Public ReadOnly Property InputPortIO32AI As Byte
    Get
public:
property unsigned char InputPortIO32AI {
    unsigned char get ();
}
member InputPortIO32AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO33 Property

IRD

Pca95059506InputPortIO33 Property

Input Port (IO3_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO33 { get; }
Public ReadOnly Property InputPortIO33 As Byte
    Get
public:
property unsigned char InputPortIO33 {
    unsigned char get ();
}
member InputPortIO33 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO33AI Property

IRD

Pca95059506InputPortIO33AI Property

Input Port (IO3_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO33AI { get; }
Public ReadOnly Property InputPortIO33AI As Byte
    Get
public:
property unsigned char InputPortIO33AI {
    unsigned char get ();
}
member InputPortIO33AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO34 Property

IRD

Pca95059506InputPortIO34 Property

Input Port (IO3_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO34 { get; }
Public ReadOnly Property InputPortIO34 As Byte
    Get
public:
property unsigned char InputPortIO34 {
    unsigned char get ();
}
member InputPortIO34 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO34AI Property

IRD

Pca95059506InputPortIO34AI Property

Input Port (IO3_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO34AI { get; }
Public ReadOnly Property InputPortIO34AI As Byte
    Get
public:
property unsigned char InputPortIO34AI {
    unsigned char get ();
}
member InputPortIO34AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO35 Property

IRD

Pca95059506InputPortIO35 Property

Input Port (IO3_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO35 { get; }
Public ReadOnly Property InputPortIO35 As Byte
    Get
public:
property unsigned char InputPortIO35 {
    unsigned char get ();
}
member InputPortIO35 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO35AI Property

IRD

Pca95059506InputPortIO35AI Property

Input Port (IO3_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO35AI { get; }
Public ReadOnly Property InputPortIO35AI As Byte
    Get
public:
property unsigned char InputPortIO35AI {
    unsigned char get ();
}
member InputPortIO35AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO36 Property

IRD

Pca95059506InputPortIO36 Property

Input Port (IO3_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO36 { get; }
Public ReadOnly Property InputPortIO36 As Byte
    Get
public:
property unsigned char InputPortIO36 {
    unsigned char get ();
}
member InputPortIO36 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO36AI Property

IRD

Pca95059506InputPortIO36AI Property

Input Port (IO3_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO36AI { get; }
Public ReadOnly Property InputPortIO36AI As Byte
    Get
public:
property unsigned char InputPortIO36AI {
    unsigned char get ();
}
member InputPortIO36AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO37 Property

IRD

Pca95059506InputPortIO37 Property

Input Port (IO3_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO37 { get; }
Public ReadOnly Property InputPortIO37 As Byte
    Get
public:
property unsigned char InputPortIO37 {
    unsigned char get ();
}
member InputPortIO37 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.InputPortIO37AI Property

IRD

Pca95059506InputPortIO37AI Property

Input Port (IO3_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO37AI { get; }
Public ReadOnly Property InputPortIO37AI As Byte
    Get
public:
property unsigned char InputPortIO37AI {
    unsigned char get ();
}
member InputPortIO37AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO00 Property

IRD

Pca95059506IOConfigurationIO00 Property

I/O Configuration (IO0_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO00 { get; set; }
Public Property IOConfigurationIO00 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO00 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO00 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO00AI Property

IRD

Pca95059506IOConfigurationIO00AI Property

I/O Configuration (IO0_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO00AI { get; set; }
Public Property IOConfigurationIO00AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO00AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO00AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO01 Property

IRD

Pca95059506IOConfigurationIO01 Property

I/O Configuration (IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO01 { get; set; }
Public Property IOConfigurationIO01 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO01 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO01 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO01AI Property

IRD

Pca95059506IOConfigurationIO01AI Property

I/O Configuration (IO0_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO01AI { get; set; }
Public Property IOConfigurationIO01AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO01AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO01AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO02 Property

IRD

Pca95059506IOConfigurationIO02 Property

I/O Configuration (IO0_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO02 { get; set; }
Public Property IOConfigurationIO02 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO02 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO02 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO02AI Property

IRD

Pca95059506IOConfigurationIO02AI Property

I/O Configuration (IO0_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO02AI { get; set; }
Public Property IOConfigurationIO02AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO02AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO02AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO03 Property

IRD

Pca95059506IOConfigurationIO03 Property

I/O Configuration (IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO03 { get; set; }
Public Property IOConfigurationIO03 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO03 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO03 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO03AI Property

IRD

Pca95059506IOConfigurationIO03AI Property

I/O Configuration (IO0_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO03AI { get; set; }
Public Property IOConfigurationIO03AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO03AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO03AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO04 Property

IRD

Pca95059506IOConfigurationIO04 Property

I/O Configuration (IO0_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO04 { get; set; }
Public Property IOConfigurationIO04 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO04 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO04 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO04AI Property

IRD

Pca95059506IOConfigurationIO04AI Property

I/O Configuration (IO0_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO04AI { get; set; }
Public Property IOConfigurationIO04AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO04AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO04AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO05 Property

IRD

Pca95059506IOConfigurationIO05 Property

I/O Configuration (IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO05 { get; set; }
Public Property IOConfigurationIO05 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO05 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO05 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO05AI Property

IRD

Pca95059506IOConfigurationIO05AI Property

I/O Configuration (IO0_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO05AI { get; set; }
Public Property IOConfigurationIO05AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO05AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO05AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO06 Property

IRD

Pca95059506IOConfigurationIO06 Property

I/O Configuration (IO0_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO06 { get; set; }
Public Property IOConfigurationIO06 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO06 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO06 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO06AI Property

IRD

Pca95059506IOConfigurationIO06AI Property

I/O Configuration (IO0_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO06AI { get; set; }
Public Property IOConfigurationIO06AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO06AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO06AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO07 Property

IRD

Pca95059506IOConfigurationIO07 Property

I/O Configuration (IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO07 { get; set; }
Public Property IOConfigurationIO07 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO07 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO07 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO07AI Property

IRD

Pca95059506IOConfigurationIO07AI Property

I/O Configuration (IO0_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO07AI { get; set; }
Public Property IOConfigurationIO07AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO07AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO07AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO10 Property

IRD

Pca95059506IOConfigurationIO10 Property

I/O Configuration (IO1_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO10 { get; set; }
Public Property IOConfigurationIO10 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO10 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO10 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO10AI Property

IRD

Pca95059506IOConfigurationIO10AI Property

I/O Configuration (IO1_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO10AI { get; set; }
Public Property IOConfigurationIO10AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO10AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO10AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO11 Property

IRD

Pca95059506IOConfigurationIO11 Property

I/O Configuration (IO1_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO11 { get; set; }
Public Property IOConfigurationIO11 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO11 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO11 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO11AI Property

IRD

Pca95059506IOConfigurationIO11AI Property

I/O Configuration (IO1_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO11AI { get; set; }
Public Property IOConfigurationIO11AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO11AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO11AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO12 Property

IRD

Pca95059506IOConfigurationIO12 Property

I/O Configuration (IO1_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO12 { get; set; }
Public Property IOConfigurationIO12 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO12 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO12 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO12AI Property

IRD

Pca95059506IOConfigurationIO12AI Property

I/O Configuration (IO1_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO12AI { get; set; }
Public Property IOConfigurationIO12AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO12AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO12AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO13 Property

IRD

Pca95059506IOConfigurationIO13 Property

I/O Configuration (IO1_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO13 { get; set; }
Public Property IOConfigurationIO13 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO13 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO13 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO13AI Property

IRD

Pca95059506IOConfigurationIO13AI Property

I/O Configuration (IO1_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO13AI { get; set; }
Public Property IOConfigurationIO13AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO13AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO13AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO14 Property

IRD

Pca95059506IOConfigurationIO14 Property

I/O Configuration (IO1_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO14 { get; set; }
Public Property IOConfigurationIO14 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO14 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO14 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO14AI Property

IRD

Pca95059506IOConfigurationIO14AI Property

I/O Configuration (IO1_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO14AI { get; set; }
Public Property IOConfigurationIO14AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO14AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO14AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO15 Property

IRD

Pca95059506IOConfigurationIO15 Property

I/O Configuration (IO1_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO15 { get; set; }
Public Property IOConfigurationIO15 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO15 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO15 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO15AI Property

IRD

Pca95059506IOConfigurationIO15AI Property

I/O Configuration (IO1_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO15AI { get; set; }
Public Property IOConfigurationIO15AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO15AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO15AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO16 Property

IRD

Pca95059506IOConfigurationIO16 Property

I/O Configuration (IO1_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO16 { get; set; }
Public Property IOConfigurationIO16 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO16 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO16 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO16AI Property

IRD

Pca95059506IOConfigurationIO16AI Property

I/O Configuration (IO1_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO16AI { get; set; }
Public Property IOConfigurationIO16AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO16AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO16AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO17 Property

IRD

Pca95059506IOConfigurationIO17 Property

I/O Configuration (IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO17 { get; set; }
Public Property IOConfigurationIO17 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO17 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO17 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO17AI Property

IRD

Pca95059506IOConfigurationIO17AI Property

I/O Configuration (IO1_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO17AI { get; set; }
Public Property IOConfigurationIO17AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO17AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO17AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO20 Property

IRD

Pca95059506IOConfigurationIO20 Property

I/O Configuration (IO2_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO20 { get; set; }
Public Property IOConfigurationIO20 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO20 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO20 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO20AI Property

IRD

Pca95059506IOConfigurationIO20AI Property

I/O Configuration (IO2_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO20AI { get; set; }
Public Property IOConfigurationIO20AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO20AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO20AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO21 Property

IRD

Pca95059506IOConfigurationIO21 Property

I/O Configuration (IO2_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO21 { get; set; }
Public Property IOConfigurationIO21 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO21 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO21 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO21AI Property

IRD

Pca95059506IOConfigurationIO21AI Property

I/O Configuration (IO2_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO21AI { get; set; }
Public Property IOConfigurationIO21AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO21AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO21AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO22 Property

IRD

Pca95059506IOConfigurationIO22 Property

I/O Configuration (IO2_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO22 { get; set; }
Public Property IOConfigurationIO22 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO22 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO22 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO22AI Property

IRD

Pca95059506IOConfigurationIO22AI Property

I/O Configuration (IO2_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO22AI { get; set; }
Public Property IOConfigurationIO22AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO22AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO22AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO23 Property

IRD

Pca95059506IOConfigurationIO23 Property

I/O Configuration (IO2_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO23 { get; set; }
Public Property IOConfigurationIO23 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO23 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO23 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO23AI Property

IRD

Pca95059506IOConfigurationIO23AI Property

I/O Configuration (IO2_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO23AI { get; set; }
Public Property IOConfigurationIO23AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO23AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO23AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO24 Property

IRD

Pca95059506IOConfigurationIO24 Property

I/O Configuration (IO2_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO24 { get; set; }
Public Property IOConfigurationIO24 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO24 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO24 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO24AI Property

IRD

Pca95059506IOConfigurationIO24AI Property

I/O Configuration (IO2_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO24AI { get; set; }
Public Property IOConfigurationIO24AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO24AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO24AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO25 Property

IRD

Pca95059506IOConfigurationIO25 Property

I/O Configuration (IO2_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO25 { get; set; }
Public Property IOConfigurationIO25 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO25 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO25 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO25AI Property

IRD

Pca95059506IOConfigurationIO25AI Property

I/O Configuration (IO2_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO25AI { get; set; }
Public Property IOConfigurationIO25AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO25AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO25AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO26 Property

IRD

Pca95059506IOConfigurationIO26 Property

I/O Configuration (IO2_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO26 { get; set; }
Public Property IOConfigurationIO26 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO26 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO26 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO26AI Property

IRD

Pca95059506IOConfigurationIO26AI Property

I/O Configuration (IO2_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO26AI { get; set; }
Public Property IOConfigurationIO26AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO26AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO26AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO27 Property

IRD

Pca95059506IOConfigurationIO27 Property

I/O Configuration (IO2_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO27 { get; set; }
Public Property IOConfigurationIO27 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO27 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO27 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO27AI Property

IRD

Pca95059506IOConfigurationIO27AI Property

I/O Configuration (IO2_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO27AI { get; set; }
Public Property IOConfigurationIO27AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO27AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO27AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO30 Property

IRD

Pca95059506IOConfigurationIO30 Property

I/O Configuration (IO3_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO30 { get; set; }
Public Property IOConfigurationIO30 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO30 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO30 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO30AI Property

IRD

Pca95059506IOConfigurationIO30AI Property

I/O Configuration (IO3_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO30AI { get; set; }
Public Property IOConfigurationIO30AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO30AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO30AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO31 Property

IRD

Pca95059506IOConfigurationIO31 Property

I/O Configuration (IO3_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO31 { get; set; }
Public Property IOConfigurationIO31 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO31 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO31 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO31AI Property

IRD

Pca95059506IOConfigurationIO31AI Property

I/O Configuration (IO3_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO31AI { get; set; }
Public Property IOConfigurationIO31AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO31AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO31AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO32 Property

IRD

Pca95059506IOConfigurationIO32 Property

I/O Configuration (IO3_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO32 { get; set; }
Public Property IOConfigurationIO32 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO32 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO32 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO32AI Property

IRD

Pca95059506IOConfigurationIO32AI Property

I/O Configuration (IO3_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO32AI { get; set; }
Public Property IOConfigurationIO32AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO32AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO32AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO33 Property

IRD

Pca95059506IOConfigurationIO33 Property

I/O Configuration (IO3_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO33 { get; set; }
Public Property IOConfigurationIO33 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO33 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO33 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO33AI Property

IRD

Pca95059506IOConfigurationIO33AI Property

I/O Configuration (IO3_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO33AI { get; set; }
Public Property IOConfigurationIO33AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO33AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO33AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO34 Property

IRD

Pca95059506IOConfigurationIO34 Property

I/O Configuration (IO3_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO34 { get; set; }
Public Property IOConfigurationIO34 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO34 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO34 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO34AI Property

IRD

Pca95059506IOConfigurationIO34AI Property

I/O Configuration (IO3_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO34AI { get; set; }
Public Property IOConfigurationIO34AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO34AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO34AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO35 Property

IRD

Pca95059506IOConfigurationIO35 Property

I/O Configuration (IO3_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO35 { get; set; }
Public Property IOConfigurationIO35 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO35 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO35 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO35AI Property

IRD

Pca95059506IOConfigurationIO35AI Property

I/O Configuration (IO3_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO35AI { get; set; }
Public Property IOConfigurationIO35AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO35AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO35AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO36 Property

IRD

Pca95059506IOConfigurationIO36 Property

I/O Configuration (IO3_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO36 { get; set; }
Public Property IOConfigurationIO36 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO36 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO36 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO36AI Property

IRD

Pca95059506IOConfigurationIO36AI Property

I/O Configuration (IO3_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO36AI { get; set; }
Public Property IOConfigurationIO36AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO36AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO36AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO37 Property

IRD

Pca95059506IOConfigurationIO37 Property

I/O Configuration (IO3_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO37 { get; set; }
Public Property IOConfigurationIO37 As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO37 {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO37 : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.IOConfigurationIO37AI Property

IRD

Pca95059506IOConfigurationIO37AI Property

I/O Configuration (IO3_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeIoc IOConfigurationIO37AI { get; set; }
Public Property IOConfigurationIO37AI As Pca95059506TypeIoc
    Get
    Set
public:
property Pca95059506TypeIoc IOConfigurationIO37AI {
    Pca95059506TypeIoc get ();
    void set (Pca95059506TypeIoc value);
}
member IOConfigurationIO37AI : Pca95059506TypeIoc with get, set

Property Value

Type: Pca95059506TypeIoc
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO00 Property

IRD

Pca95059506MaskInterruptIO00 Property

Mask Interrupt (IO0_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO00 { get; set; }
Public Property MaskInterruptIO00 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO00 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO00 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO00AI Property

IRD

Pca95059506MaskInterruptIO00AI Property

Mask Interrupt (IO0_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO00AI { get; set; }
Public Property MaskInterruptIO00AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO00AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO00AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO01 Property

IRD

Pca95059506MaskInterruptIO01 Property

Mask Interrupt (IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO01 { get; set; }
Public Property MaskInterruptIO01 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO01 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO01 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO01AI Property

IRD

Pca95059506MaskInterruptIO01AI Property

Mask Interrupt (IO0_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO01AI { get; set; }
Public Property MaskInterruptIO01AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO01AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO01AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO02 Property

IRD

Pca95059506MaskInterruptIO02 Property

Mask Interrupt (IO0_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO02 { get; set; }
Public Property MaskInterruptIO02 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO02 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO02 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO02AI Property

IRD

Pca95059506MaskInterruptIO02AI Property

Mask Interrupt (IO0_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO02AI { get; set; }
Public Property MaskInterruptIO02AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO02AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO02AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO03 Property

IRD

Pca95059506MaskInterruptIO03 Property

Mask Interrupt (IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO03 { get; set; }
Public Property MaskInterruptIO03 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO03 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO03 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO03AI Property

IRD

Pca95059506MaskInterruptIO03AI Property

Mask Interrupt (IO0_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO03AI { get; set; }
Public Property MaskInterruptIO03AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO03AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO03AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO04 Property

IRD

Pca95059506MaskInterruptIO04 Property

Mask Interrupt (IO0_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO04 { get; set; }
Public Property MaskInterruptIO04 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO04 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO04 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO04AI Property

IRD

Pca95059506MaskInterruptIO04AI Property

Mask Interrupt (IO0_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO04AI { get; set; }
Public Property MaskInterruptIO04AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO04AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO04AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO05 Property

IRD

Pca95059506MaskInterruptIO05 Property

Mask Interrupt (IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO05 { get; set; }
Public Property MaskInterruptIO05 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO05 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO05 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO05AI Property

IRD

Pca95059506MaskInterruptIO05AI Property

Mask Interrupt (IO0_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO05AI { get; set; }
Public Property MaskInterruptIO05AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO05AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO05AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO06 Property

IRD

Pca95059506MaskInterruptIO06 Property

Mask Interrupt (IO0_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO06 { get; set; }
Public Property MaskInterruptIO06 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO06 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO06 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO06AI Property

IRD

Pca95059506MaskInterruptIO06AI Property

Mask Interrupt (IO0_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO06AI { get; set; }
Public Property MaskInterruptIO06AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO06AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO06AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO07 Property

IRD

Pca95059506MaskInterruptIO07 Property

Mask Interrupt (IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO07 { get; set; }
Public Property MaskInterruptIO07 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO07 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO07 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO07AI Property

IRD

Pca95059506MaskInterruptIO07AI Property

Mask Interrupt (IO0_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO07AI { get; set; }
Public Property MaskInterruptIO07AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO07AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO07AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO10 Property

IRD

Pca95059506MaskInterruptIO10 Property

Mask Interrupt (IO1_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO10 { get; set; }
Public Property MaskInterruptIO10 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO10 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO10 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO10AI Property

IRD

Pca95059506MaskInterruptIO10AI Property

Mask Interrupt (IO1_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO10AI { get; set; }
Public Property MaskInterruptIO10AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO10AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO10AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO11 Property

IRD

Pca95059506MaskInterruptIO11 Property

Mask Interrupt (IO1_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO11 { get; set; }
Public Property MaskInterruptIO11 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO11 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO11 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO11AI Property

IRD

Pca95059506MaskInterruptIO11AI Property

Mask Interrupt (IO1_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO11AI { get; set; }
Public Property MaskInterruptIO11AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO11AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO11AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO12 Property

IRD

Pca95059506MaskInterruptIO12 Property

Mask Interrupt (IO1_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO12 { get; set; }
Public Property MaskInterruptIO12 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO12 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO12 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO12AI Property

IRD

Pca95059506MaskInterruptIO12AI Property

Mask Interrupt (IO1_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO12AI { get; set; }
Public Property MaskInterruptIO12AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO12AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO12AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO13 Property

IRD

Pca95059506MaskInterruptIO13 Property

Mask Interrupt (IO1_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO13 { get; set; }
Public Property MaskInterruptIO13 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO13 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO13 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO13AI Property

IRD

Pca95059506MaskInterruptIO13AI Property

Mask Interrupt (IO1_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO13AI { get; set; }
Public Property MaskInterruptIO13AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO13AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO13AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO14 Property

IRD

Pca95059506MaskInterruptIO14 Property

Mask Interrupt (IO1_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO14 { get; set; }
Public Property MaskInterruptIO14 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO14 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO14 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO14AI Property

IRD

Pca95059506MaskInterruptIO14AI Property

Mask Interrupt (IO1_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO14AI { get; set; }
Public Property MaskInterruptIO14AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO14AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO14AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO15 Property

IRD

Pca95059506MaskInterruptIO15 Property

Mask Interrupt (IO1_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO15 { get; set; }
Public Property MaskInterruptIO15 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO15 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO15 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO15AI Property

IRD

Pca95059506MaskInterruptIO15AI Property

Mask Interrupt (IO1_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO15AI { get; set; }
Public Property MaskInterruptIO15AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO15AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO15AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO16 Property

IRD

Pca95059506MaskInterruptIO16 Property

Mask Interrupt (IO1_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO16 { get; set; }
Public Property MaskInterruptIO16 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO16 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO16 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO16AI Property

IRD

Pca95059506MaskInterruptIO16AI Property

Mask Interrupt (IO1_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO16AI { get; set; }
Public Property MaskInterruptIO16AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO16AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO16AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO17 Property

IRD

Pca95059506MaskInterruptIO17 Property

Mask Interrupt (IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO17 { get; set; }
Public Property MaskInterruptIO17 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO17 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO17 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO17AI Property

IRD

Pca95059506MaskInterruptIO17AI Property

Mask Interrupt (IO1_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO17AI { get; set; }
Public Property MaskInterruptIO17AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO17AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO17AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO20 Property

IRD

Pca95059506MaskInterruptIO20 Property

Mask Interrupt (IO2_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO20 { get; set; }
Public Property MaskInterruptIO20 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO20 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO20 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO20AI Property

IRD

Pca95059506MaskInterruptIO20AI Property

Mask Interrupt (IO2_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO20AI { get; set; }
Public Property MaskInterruptIO20AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO20AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO20AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO21 Property

IRD

Pca95059506MaskInterruptIO21 Property

Mask Interrupt (IO2_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO21 { get; set; }
Public Property MaskInterruptIO21 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO21 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO21 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO21AI Property

IRD

Pca95059506MaskInterruptIO21AI Property

Mask Interrupt (IO2_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO21AI { get; set; }
Public Property MaskInterruptIO21AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO21AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO21AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO22 Property

IRD

Pca95059506MaskInterruptIO22 Property

Mask Interrupt (IO2_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO22 { get; set; }
Public Property MaskInterruptIO22 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO22 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO22 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO22AI Property

IRD

Pca95059506MaskInterruptIO22AI Property

Mask Interrupt (IO2_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO22AI { get; set; }
Public Property MaskInterruptIO22AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO22AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO22AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO23 Property

IRD

Pca95059506MaskInterruptIO23 Property

Mask Interrupt (IO2_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO23 { get; set; }
Public Property MaskInterruptIO23 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO23 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO23 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO23AI Property

IRD

Pca95059506MaskInterruptIO23AI Property

Mask Interrupt (IO2_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO23AI { get; set; }
Public Property MaskInterruptIO23AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO23AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO23AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO24 Property

IRD

Pca95059506MaskInterruptIO24 Property

Mask Interrupt (IO2_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO24 { get; set; }
Public Property MaskInterruptIO24 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO24 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO24 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO24AI Property

IRD

Pca95059506MaskInterruptIO24AI Property

Mask Interrupt (IO2_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO24AI { get; set; }
Public Property MaskInterruptIO24AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO24AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO24AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO25 Property

IRD

Pca95059506MaskInterruptIO25 Property

Mask Interrupt (IO2_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO25 { get; set; }
Public Property MaskInterruptIO25 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO25 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO25 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO25AI Property

IRD

Pca95059506MaskInterruptIO25AI Property

Mask Interrupt (IO2_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO25AI { get; set; }
Public Property MaskInterruptIO25AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO25AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO25AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO26 Property

IRD

Pca95059506MaskInterruptIO26 Property

Mask Interrupt (IO2_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO26 { get; set; }
Public Property MaskInterruptIO26 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO26 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO26 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO26AI Property

IRD

Pca95059506MaskInterruptIO26AI Property

Mask Interrupt (IO2_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO26AI { get; set; }
Public Property MaskInterruptIO26AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO26AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO26AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO27 Property

IRD

Pca95059506MaskInterruptIO27 Property

Mask Interrupt (IO2_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO27 { get; set; }
Public Property MaskInterruptIO27 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO27 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO27 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO27AI Property

IRD

Pca95059506MaskInterruptIO27AI Property

Mask Interrupt (IO2_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO27AI { get; set; }
Public Property MaskInterruptIO27AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO27AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO27AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO30 Property

IRD

Pca95059506MaskInterruptIO30 Property

Mask Interrupt (IO3_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO30 { get; set; }
Public Property MaskInterruptIO30 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO30 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO30 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO30AI Property

IRD

Pca95059506MaskInterruptIO30AI Property

Mask Interrupt (IO3_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO30AI { get; set; }
Public Property MaskInterruptIO30AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO30AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO30AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO31 Property

IRD

Pca95059506MaskInterruptIO31 Property

Mask Interrupt (IO3_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO31 { get; set; }
Public Property MaskInterruptIO31 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO31 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO31 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO31AI Property

IRD

Pca95059506MaskInterruptIO31AI Property

Mask Interrupt (IO3_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO31AI { get; set; }
Public Property MaskInterruptIO31AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO31AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO31AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO32 Property

IRD

Pca95059506MaskInterruptIO32 Property

Mask Interrupt (IO3_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO32 { get; set; }
Public Property MaskInterruptIO32 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO32 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO32 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO32AI Property

IRD

Pca95059506MaskInterruptIO32AI Property

Mask Interrupt (IO3_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO32AI { get; set; }
Public Property MaskInterruptIO32AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO32AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO32AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO33 Property

IRD

Pca95059506MaskInterruptIO33 Property

Mask Interrupt (IO3_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO33 { get; set; }
Public Property MaskInterruptIO33 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO33 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO33 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO33AI Property

IRD

Pca95059506MaskInterruptIO33AI Property

Mask Interrupt (IO3_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO33AI { get; set; }
Public Property MaskInterruptIO33AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO33AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO33AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO34 Property

IRD

Pca95059506MaskInterruptIO34 Property

Mask Interrupt (IO3_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO34 { get; set; }
Public Property MaskInterruptIO34 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO34 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO34 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO34AI Property

IRD

Pca95059506MaskInterruptIO34AI Property

Mask Interrupt (IO3_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO34AI { get; set; }
Public Property MaskInterruptIO34AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO34AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO34AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO35 Property

IRD

Pca95059506MaskInterruptIO35 Property

Mask Interrupt (IO3_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO35 { get; set; }
Public Property MaskInterruptIO35 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO35 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO35 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO35AI Property

IRD

Pca95059506MaskInterruptIO35AI Property

Mask Interrupt (IO3_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO35AI { get; set; }
Public Property MaskInterruptIO35AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO35AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO35AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO36 Property

IRD

Pca95059506MaskInterruptIO36 Property

Mask Interrupt (IO3_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO36 { get; set; }
Public Property MaskInterruptIO36 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO36 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO36 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO36AI Property

IRD

Pca95059506MaskInterruptIO36AI Property

Mask Interrupt (IO3_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO36AI { get; set; }
Public Property MaskInterruptIO36AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO36AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO36AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO37 Property

IRD

Pca95059506MaskInterruptIO37 Property

Mask Interrupt (IO3_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO37 { get; set; }
Public Property MaskInterruptIO37 As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO37 {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO37 : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.MaskInterruptIO37AI Property

IRD

Pca95059506MaskInterruptIO37AI Property

Mask Interrupt (IO3_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypeMsk MaskInterruptIO37AI { get; set; }
Public Property MaskInterruptIO37AI As Pca95059506TypeMsk
    Get
    Set
public:
property Pca95059506TypeMsk MaskInterruptIO37AI {
    Pca95059506TypeMsk get ();
    void set (Pca95059506TypeMsk value);
}
member MaskInterruptIO37AI : Pca95059506TypeMsk with get, set

Property Value

Type: Pca95059506TypeMsk
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO00 Property

IRD

Pca95059506OutputPortIO00 Property

Output Port (IO0_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO00 { get; set; }
Public Property OutputPortIO00 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO00 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO00 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO00AI Property

IRD

Pca95059506OutputPortIO00AI Property

Output Port (IO0_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO00AI { get; set; }
Public Property OutputPortIO00AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO00AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO00AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO01 Property

IRD

Pca95059506OutputPortIO01 Property

Output Port (IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO01 { get; set; }
Public Property OutputPortIO01 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO01 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO01 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO01AI Property

IRD

Pca95059506OutputPortIO01AI Property

Output Port (IO0_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO01AI { get; set; }
Public Property OutputPortIO01AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO01AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO01AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO02 Property

IRD

Pca95059506OutputPortIO02 Property

Output Port (IO0_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO02 { get; set; }
Public Property OutputPortIO02 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO02 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO02 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO02AI Property

IRD

Pca95059506OutputPortIO02AI Property

Output Port (IO0_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO02AI { get; set; }
Public Property OutputPortIO02AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO02AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO02AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO03 Property

IRD

Pca95059506OutputPortIO03 Property

Output Port (IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO03 { get; set; }
Public Property OutputPortIO03 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO03 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO03 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO03AI Property

IRD

Pca95059506OutputPortIO03AI Property

Output Port (IO0_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO03AI { get; set; }
Public Property OutputPortIO03AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO03AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO03AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO04 Property

IRD

Pca95059506OutputPortIO04 Property

Output Port (IO0_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO04 { get; set; }
Public Property OutputPortIO04 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO04 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO04 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO04AI Property

IRD

Pca95059506OutputPortIO04AI Property

Output Port (IO0_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO04AI { get; set; }
Public Property OutputPortIO04AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO04AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO04AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO05 Property

IRD

Pca95059506OutputPortIO05 Property

Output Port (IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO05 { get; set; }
Public Property OutputPortIO05 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO05 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO05 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO05AI Property

IRD

Pca95059506OutputPortIO05AI Property

Output Port (IO0_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO05AI { get; set; }
Public Property OutputPortIO05AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO05AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO05AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO06 Property

IRD

Pca95059506OutputPortIO06 Property

Output Port (IO0_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO06 { get; set; }
Public Property OutputPortIO06 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO06 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO06 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO06AI Property

IRD

Pca95059506OutputPortIO06AI Property

Output Port (IO0_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO06AI { get; set; }
Public Property OutputPortIO06AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO06AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO06AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO07 Property

IRD

Pca95059506OutputPortIO07 Property

Output Port (IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO07 { get; set; }
Public Property OutputPortIO07 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO07 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO07 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO07AI Property

IRD

Pca95059506OutputPortIO07AI Property

Output Port (IO0_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO07AI { get; set; }
Public Property OutputPortIO07AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO07AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO07AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO10 Property

IRD

Pca95059506OutputPortIO10 Property

Output Port (IO1_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO10 { get; set; }
Public Property OutputPortIO10 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO10 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO10 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO10AI Property

IRD

Pca95059506OutputPortIO10AI Property

Output Port (IO1_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO10AI { get; set; }
Public Property OutputPortIO10AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO10AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO10AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO11 Property

IRD

Pca95059506OutputPortIO11 Property

Output Port (IO1_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO11 { get; set; }
Public Property OutputPortIO11 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO11 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO11 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO11AI Property

IRD

Pca95059506OutputPortIO11AI Property

Output Port (IO1_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO11AI { get; set; }
Public Property OutputPortIO11AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO11AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO11AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO12 Property

IRD

Pca95059506OutputPortIO12 Property

Output Port (IO1_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO12 { get; set; }
Public Property OutputPortIO12 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO12 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO12 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO12AI Property

IRD

Pca95059506OutputPortIO12AI Property

Output Port (IO1_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO12AI { get; set; }
Public Property OutputPortIO12AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO12AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO12AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO13 Property

IRD

Pca95059506OutputPortIO13 Property

Output Port (IO1_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO13 { get; set; }
Public Property OutputPortIO13 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO13 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO13 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO13AI Property

IRD

Pca95059506OutputPortIO13AI Property

Output Port (IO1_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO13AI { get; set; }
Public Property OutputPortIO13AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO13AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO13AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO14 Property

IRD

Pca95059506OutputPortIO14 Property

Output Port (IO1_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO14 { get; set; }
Public Property OutputPortIO14 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO14 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO14 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO14AI Property

IRD

Pca95059506OutputPortIO14AI Property

Output Port (IO1_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO14AI { get; set; }
Public Property OutputPortIO14AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO14AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO14AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO15 Property

IRD

Pca95059506OutputPortIO15 Property

Output Port (IO1_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO15 { get; set; }
Public Property OutputPortIO15 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO15 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO15 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO15AI Property

IRD

Pca95059506OutputPortIO15AI Property

Output Port (IO1_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO15AI { get; set; }
Public Property OutputPortIO15AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO15AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO15AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO16 Property

IRD

Pca95059506OutputPortIO16 Property

Output Port (IO1_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO16 { get; set; }
Public Property OutputPortIO16 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO16 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO16 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO16AI Property

IRD

Pca95059506OutputPortIO16AI Property

Output Port (IO1_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO16AI { get; set; }
Public Property OutputPortIO16AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO16AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO16AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO17 Property

IRD

Pca95059506OutputPortIO17 Property

Output Port (IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO17 { get; set; }
Public Property OutputPortIO17 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO17 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO17 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO17AI Property

IRD

Pca95059506OutputPortIO17AI Property

Output Port (IO1_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO17AI { get; set; }
Public Property OutputPortIO17AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO17AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO17AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO20 Property

IRD

Pca95059506OutputPortIO20 Property

Output Port (IO2_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO20 { get; set; }
Public Property OutputPortIO20 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO20 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO20 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO20AI Property

IRD

Pca95059506OutputPortIO20AI Property

Output Port (IO2_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO20AI { get; set; }
Public Property OutputPortIO20AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO20AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO20AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO21 Property

IRD

Pca95059506OutputPortIO21 Property

Output Port (IO2_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO21 { get; set; }
Public Property OutputPortIO21 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO21 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO21 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO21AI Property

IRD

Pca95059506OutputPortIO21AI Property

Output Port (IO2_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO21AI { get; set; }
Public Property OutputPortIO21AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO21AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO21AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO22 Property

IRD

Pca95059506OutputPortIO22 Property

Output Port (IO2_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO22 { get; set; }
Public Property OutputPortIO22 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO22 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO22 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO22AI Property

IRD

Pca95059506OutputPortIO22AI Property

Output Port (IO2_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO22AI { get; set; }
Public Property OutputPortIO22AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO22AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO22AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO23 Property

IRD

Pca95059506OutputPortIO23 Property

Output Port (IO2_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO23 { get; set; }
Public Property OutputPortIO23 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO23 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO23 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO23AI Property

IRD

Pca95059506OutputPortIO23AI Property

Output Port (IO2_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO23AI { get; set; }
Public Property OutputPortIO23AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO23AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO23AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO24 Property

IRD

Pca95059506OutputPortIO24 Property

Output Port (IO2_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO24 { get; set; }
Public Property OutputPortIO24 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO24 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO24 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO24AI Property

IRD

Pca95059506OutputPortIO24AI Property

Output Port (IO2_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO24AI { get; set; }
Public Property OutputPortIO24AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO24AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO24AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO25 Property

IRD

Pca95059506OutputPortIO25 Property

Output Port (IO2_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO25 { get; set; }
Public Property OutputPortIO25 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO25 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO25 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO25AI Property

IRD

Pca95059506OutputPortIO25AI Property

Output Port (IO2_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO25AI { get; set; }
Public Property OutputPortIO25AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO25AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO25AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO26 Property

IRD

Pca95059506OutputPortIO26 Property

Output Port (IO2_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO26 { get; set; }
Public Property OutputPortIO26 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO26 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO26 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO26AI Property

IRD

Pca95059506OutputPortIO26AI Property

Output Port (IO2_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO26AI { get; set; }
Public Property OutputPortIO26AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO26AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO26AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO27 Property

IRD

Pca95059506OutputPortIO27 Property

Output Port (IO2_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO27 { get; set; }
Public Property OutputPortIO27 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO27 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO27 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO27AI Property

IRD

Pca95059506OutputPortIO27AI Property

Output Port (IO2_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO27AI { get; set; }
Public Property OutputPortIO27AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO27AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO27AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO30 Property

IRD

Pca95059506OutputPortIO30 Property

Output Port (IO3_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO30 { get; set; }
Public Property OutputPortIO30 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO30 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO30 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO30AI Property

IRD

Pca95059506OutputPortIO30AI Property

Output Port (IO3_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO30AI { get; set; }
Public Property OutputPortIO30AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO30AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO30AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO31 Property

IRD

Pca95059506OutputPortIO31 Property

Output Port (IO3_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO31 { get; set; }
Public Property OutputPortIO31 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO31 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO31 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO31AI Property

IRD

Pca95059506OutputPortIO31AI Property

Output Port (IO3_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO31AI { get; set; }
Public Property OutputPortIO31AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO31AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO31AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO32 Property

IRD

Pca95059506OutputPortIO32 Property

Output Port (IO3_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO32 { get; set; }
Public Property OutputPortIO32 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO32 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO32 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO32AI Property

IRD

Pca95059506OutputPortIO32AI Property

Output Port (IO3_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO32AI { get; set; }
Public Property OutputPortIO32AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO32AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO32AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO33 Property

IRD

Pca95059506OutputPortIO33 Property

Output Port (IO3_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO33 { get; set; }
Public Property OutputPortIO33 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO33 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO33 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO33AI Property

IRD

Pca95059506OutputPortIO33AI Property

Output Port (IO3_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO33AI { get; set; }
Public Property OutputPortIO33AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO33AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO33AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO34 Property

IRD

Pca95059506OutputPortIO34 Property

Output Port (IO3_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO34 { get; set; }
Public Property OutputPortIO34 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO34 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO34 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO34AI Property

IRD

Pca95059506OutputPortIO34AI Property

Output Port (IO3_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO34AI { get; set; }
Public Property OutputPortIO34AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO34AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO34AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO35 Property

IRD

Pca95059506OutputPortIO35 Property

Output Port (IO3_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO35 { get; set; }
Public Property OutputPortIO35 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO35 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO35 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO35AI Property

IRD

Pca95059506OutputPortIO35AI Property

Output Port (IO3_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO35AI { get; set; }
Public Property OutputPortIO35AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO35AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO35AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO36 Property

IRD

Pca95059506OutputPortIO36 Property

Output Port (IO3_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO36 { get; set; }
Public Property OutputPortIO36 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO36 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO36 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO36AI Property

IRD

Pca95059506OutputPortIO36AI Property

Output Port (IO3_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO36AI { get; set; }
Public Property OutputPortIO36AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO36AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO36AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO37 Property

IRD

Pca95059506OutputPortIO37 Property

Output Port (IO3_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO37 { get; set; }
Public Property OutputPortIO37 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO37 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO37 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.OutputPortIO37AI Property

IRD

Pca95059506OutputPortIO37AI Property

Output Port (IO3_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO37AI { get; set; }
Public Property OutputPortIO37AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO37AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO37AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO00 Property

IRD

Pca95059506PolarityInversionIO00 Property

Polarity Inversion (IO0_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO00 { get; set; }
Public Property PolarityInversionIO00 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO00 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO00 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO00AI Property

IRD

Pca95059506PolarityInversionIO00AI Property

Polarity Inversion (IO0_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO00AI { get; set; }
Public Property PolarityInversionIO00AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO00AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO00AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO01 Property

IRD

Pca95059506PolarityInversionIO01 Property

Polarity Inversion (IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO01 { get; set; }
Public Property PolarityInversionIO01 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO01 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO01 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO01AI Property

IRD

Pca95059506PolarityInversionIO01AI Property

Polarity Inversion (IO0_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO01AI { get; set; }
Public Property PolarityInversionIO01AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO01AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO01AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO02 Property

IRD

Pca95059506PolarityInversionIO02 Property

Polarity Inversion (IO0_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO02 { get; set; }
Public Property PolarityInversionIO02 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO02 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO02 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO02AI Property

IRD

Pca95059506PolarityInversionIO02AI Property

Polarity Inversion (IO0_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO02AI { get; set; }
Public Property PolarityInversionIO02AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO02AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO02AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO03 Property

IRD

Pca95059506PolarityInversionIO03 Property

Polarity Inversion (IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO03 { get; set; }
Public Property PolarityInversionIO03 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO03 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO03 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO03AI Property

IRD

Pca95059506PolarityInversionIO03AI Property

Polarity Inversion (IO0_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO03AI { get; set; }
Public Property PolarityInversionIO03AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO03AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO03AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO04 Property

IRD

Pca95059506PolarityInversionIO04 Property

Polarity Inversion (IO0_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO04 { get; set; }
Public Property PolarityInversionIO04 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO04 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO04 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO04AI Property

IRD

Pca95059506PolarityInversionIO04AI Property

Polarity Inversion (IO0_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO04AI { get; set; }
Public Property PolarityInversionIO04AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO04AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO04AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO05 Property

IRD

Pca95059506PolarityInversionIO05 Property

Polarity Inversion (IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO05 { get; set; }
Public Property PolarityInversionIO05 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO05 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO05 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO05AI Property

IRD

Pca95059506PolarityInversionIO05AI Property

Polarity Inversion (IO0_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO05AI { get; set; }
Public Property PolarityInversionIO05AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO05AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO05AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO06 Property

IRD

Pca95059506PolarityInversionIO06 Property

Polarity Inversion (IO0_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO06 { get; set; }
Public Property PolarityInversionIO06 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO06 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO06 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO06AI Property

IRD

Pca95059506PolarityInversionIO06AI Property

Polarity Inversion (IO0_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO06AI { get; set; }
Public Property PolarityInversionIO06AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO06AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO06AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO07 Property

IRD

Pca95059506PolarityInversionIO07 Property

Polarity Inversion (IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO07 { get; set; }
Public Property PolarityInversionIO07 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO07 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO07 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO07AI Property

IRD

Pca95059506PolarityInversionIO07AI Property

Polarity Inversion (IO0_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO07AI { get; set; }
Public Property PolarityInversionIO07AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO07AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO07AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO10 Property

IRD

Pca95059506PolarityInversionIO10 Property

Polarity Inversion (IO1_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO10 { get; set; }
Public Property PolarityInversionIO10 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO10 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO10 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO10AI Property

IRD

Pca95059506PolarityInversionIO10AI Property

Polarity Inversion (IO1_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO10AI { get; set; }
Public Property PolarityInversionIO10AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO10AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO10AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO11 Property

IRD

Pca95059506PolarityInversionIO11 Property

Polarity Inversion (IO1_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO11 { get; set; }
Public Property PolarityInversionIO11 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO11 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO11 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO11AI Property

IRD

Pca95059506PolarityInversionIO11AI Property

Polarity Inversion (IO1_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO11AI { get; set; }
Public Property PolarityInversionIO11AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO11AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO11AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO12 Property

IRD

Pca95059506PolarityInversionIO12 Property

Polarity Inversion (IO1_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO12 { get; set; }
Public Property PolarityInversionIO12 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO12 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO12 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO12AI Property

IRD

Pca95059506PolarityInversionIO12AI Property

Polarity Inversion (IO1_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO12AI { get; set; }
Public Property PolarityInversionIO12AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO12AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO12AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO13 Property

IRD

Pca95059506PolarityInversionIO13 Property

Polarity Inversion (IO1_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO13 { get; set; }
Public Property PolarityInversionIO13 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO13 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO13 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO13AI Property

IRD

Pca95059506PolarityInversionIO13AI Property

Polarity Inversion (IO1_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO13AI { get; set; }
Public Property PolarityInversionIO13AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO13AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO13AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO14 Property

IRD

Pca95059506PolarityInversionIO14 Property

Polarity Inversion (IO1_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO14 { get; set; }
Public Property PolarityInversionIO14 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO14 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO14 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO14AI Property

IRD

Pca95059506PolarityInversionIO14AI Property

Polarity Inversion (IO1_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO14AI { get; set; }
Public Property PolarityInversionIO14AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO14AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO14AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO15 Property

IRD

Pca95059506PolarityInversionIO15 Property

Polarity Inversion (IO1_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO15 { get; set; }
Public Property PolarityInversionIO15 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO15 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO15 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO15AI Property

IRD

Pca95059506PolarityInversionIO15AI Property

Polarity Inversion (IO1_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO15AI { get; set; }
Public Property PolarityInversionIO15AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO15AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO15AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO16 Property

IRD

Pca95059506PolarityInversionIO16 Property

Polarity Inversion (IO1_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO16 { get; set; }
Public Property PolarityInversionIO16 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO16 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO16 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO16AI Property

IRD

Pca95059506PolarityInversionIO16AI Property

Polarity Inversion (IO1_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO16AI { get; set; }
Public Property PolarityInversionIO16AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO16AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO16AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO17 Property

IRD

Pca95059506PolarityInversionIO17 Property

Polarity Inversion (IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO17 { get; set; }
Public Property PolarityInversionIO17 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO17 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO17 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO17AI Property

IRD

Pca95059506PolarityInversionIO17AI Property

Polarity Inversion (IO1_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO17AI { get; set; }
Public Property PolarityInversionIO17AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO17AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO17AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO20 Property

IRD

Pca95059506PolarityInversionIO20 Property

Polarity Inversion (IO2_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO20 { get; set; }
Public Property PolarityInversionIO20 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO20 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO20 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO20AI Property

IRD

Pca95059506PolarityInversionIO20AI Property

Polarity Inversion (IO2_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO20AI { get; set; }
Public Property PolarityInversionIO20AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO20AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO20AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO21 Property

IRD

Pca95059506PolarityInversionIO21 Property

Polarity Inversion (IO2_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO21 { get; set; }
Public Property PolarityInversionIO21 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO21 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO21 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO21AI Property

IRD

Pca95059506PolarityInversionIO21AI Property

Polarity Inversion (IO2_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO21AI { get; set; }
Public Property PolarityInversionIO21AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO21AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO21AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO22 Property

IRD

Pca95059506PolarityInversionIO22 Property

Polarity Inversion (IO2_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO22 { get; set; }
Public Property PolarityInversionIO22 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO22 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO22 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO22AI Property

IRD

Pca95059506PolarityInversionIO22AI Property

Polarity Inversion (IO2_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO22AI { get; set; }
Public Property PolarityInversionIO22AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO22AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO22AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO23 Property

IRD

Pca95059506PolarityInversionIO23 Property

Polarity Inversion (IO2_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO23 { get; set; }
Public Property PolarityInversionIO23 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO23 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO23 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO23AI Property

IRD

Pca95059506PolarityInversionIO23AI Property

Polarity Inversion (IO2_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO23AI { get; set; }
Public Property PolarityInversionIO23AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO23AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO23AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO24 Property

IRD

Pca95059506PolarityInversionIO24 Property

Polarity Inversion (IO2_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO24 { get; set; }
Public Property PolarityInversionIO24 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO24 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO24 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO24AI Property

IRD

Pca95059506PolarityInversionIO24AI Property

Polarity Inversion (IO2_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO24AI { get; set; }
Public Property PolarityInversionIO24AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO24AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO24AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO25 Property

IRD

Pca95059506PolarityInversionIO25 Property

Polarity Inversion (IO2_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO25 { get; set; }
Public Property PolarityInversionIO25 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO25 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO25 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO25AI Property

IRD

Pca95059506PolarityInversionIO25AI Property

Polarity Inversion (IO2_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO25AI { get; set; }
Public Property PolarityInversionIO25AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO25AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO25AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO26 Property

IRD

Pca95059506PolarityInversionIO26 Property

Polarity Inversion (IO2_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO26 { get; set; }
Public Property PolarityInversionIO26 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO26 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO26 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO26AI Property

IRD

Pca95059506PolarityInversionIO26AI Property

Polarity Inversion (IO2_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO26AI { get; set; }
Public Property PolarityInversionIO26AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO26AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO26AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO27 Property

IRD

Pca95059506PolarityInversionIO27 Property

Polarity Inversion (IO2_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO27 { get; set; }
Public Property PolarityInversionIO27 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO27 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO27 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO27AI Property

IRD

Pca95059506PolarityInversionIO27AI Property

Polarity Inversion (IO2_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO27AI { get; set; }
Public Property PolarityInversionIO27AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO27AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO27AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO30 Property

IRD

Pca95059506PolarityInversionIO30 Property

Polarity Inversion (IO3_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO30 { get; set; }
Public Property PolarityInversionIO30 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO30 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO30 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO30AI Property

IRD

Pca95059506PolarityInversionIO30AI Property

Polarity Inversion (IO3_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO30AI { get; set; }
Public Property PolarityInversionIO30AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO30AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO30AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO31 Property

IRD

Pca95059506PolarityInversionIO31 Property

Polarity Inversion (IO3_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO31 { get; set; }
Public Property PolarityInversionIO31 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO31 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO31 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO31AI Property

IRD

Pca95059506PolarityInversionIO31AI Property

Polarity Inversion (IO3_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO31AI { get; set; }
Public Property PolarityInversionIO31AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO31AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO31AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO32 Property

IRD

Pca95059506PolarityInversionIO32 Property

Polarity Inversion (IO3_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO32 { get; set; }
Public Property PolarityInversionIO32 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO32 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO32 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO32AI Property

IRD

Pca95059506PolarityInversionIO32AI Property

Polarity Inversion (IO3_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO32AI { get; set; }
Public Property PolarityInversionIO32AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO32AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO32AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO33 Property

IRD

Pca95059506PolarityInversionIO33 Property

Polarity Inversion (IO3_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO33 { get; set; }
Public Property PolarityInversionIO33 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO33 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO33 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO33AI Property

IRD

Pca95059506PolarityInversionIO33AI Property

Polarity Inversion (IO3_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO33AI { get; set; }
Public Property PolarityInversionIO33AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO33AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO33AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO34 Property

IRD

Pca95059506PolarityInversionIO34 Property

Polarity Inversion (IO3_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO34 { get; set; }
Public Property PolarityInversionIO34 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO34 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO34 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO34AI Property

IRD

Pca95059506PolarityInversionIO34AI Property

Polarity Inversion (IO3_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO34AI { get; set; }
Public Property PolarityInversionIO34AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO34AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO34AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO35 Property

IRD

Pca95059506PolarityInversionIO35 Property

Polarity Inversion (IO3_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO35 { get; set; }
Public Property PolarityInversionIO35 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO35 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO35 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO35AI Property

IRD

Pca95059506PolarityInversionIO35AI Property

Polarity Inversion (IO3_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO35AI { get; set; }
Public Property PolarityInversionIO35AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO35AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO35AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO36 Property

IRD

Pca95059506PolarityInversionIO36 Property

Polarity Inversion (IO3_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO36 { get; set; }
Public Property PolarityInversionIO36 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO36 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO36 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO36AI Property

IRD

Pca95059506PolarityInversionIO36AI Property

Polarity Inversion (IO3_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO36AI { get; set; }
Public Property PolarityInversionIO36AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO36AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO36AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO37 Property

IRD

Pca95059506PolarityInversionIO37 Property

Polarity Inversion (IO3_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO37 { get; set; }
Public Property PolarityInversionIO37 As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO37 {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO37 : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.PolarityInversionIO37AI Property

IRD

Pca95059506PolarityInversionIO37AI Property

Polarity Inversion (IO3_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca95059506TypePi PolarityInversionIO37AI { get; set; }
Public Property PolarityInversionIO37AI As Pca95059506TypePi
    Get
    Set
public:
property Pca95059506TypePi PolarityInversionIO37AI {
    Pca95059506TypePi get ();
    void set (Pca95059506TypePi value);
}
member PolarityInversionIO37AI : Pca95059506TypePi with get, set

Property Value

Type: Pca95059506TypePi
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506 Methods

The Pca95059506 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.Flush Method

IRD

Pca95059506Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca95059506 Class
telos.Ird.NXPSemiconductors Namespace


Pca95059506.TypeIoc Enumeration

IRD

Pca95059506TypeIoc Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIoc
Public Enumeration TypeIoc
public enum class TypeIoc
type TypeIoc
Members
Member name | Value | Description
Output | 0 | Output
Input | 1 | Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca95059506.TypeMsk Enumeration

IRD

Pca95059506TypeMsk Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMsk
Public Enumeration TypeMsk
public enum class TypeMsk
type TypeMsk
Members
Member name | Value | Description
InterruptEnabled | 0 | Interrupt Enabled
InterruptDisabled | 1 | Interrupt Disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca95059506.TypePi Enumeration

IRD

Pca95059506TypePi Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePi
Public Enumeration TypePi
public enum class TypePi
type TypePi
Members
Member name | Value | Description
Retained | 0 | Retained
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9530 Class

NXP Semiconductors: PCA 9530
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9530

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9530
Public Class Pca9530
public ref class Pca9530
type Pca9530 =  class end

The Pca9530 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9530 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FrequencyPrescaler0 | Frequency Prescaler 0
Public property | FrequencyPrescaler0AI | Frequency Prescaler 0 [AI]
Public property | FrequencyPrescaler1 | Frequency Prescaler 1
Public property | FrequencyPrescaler1AI | Frequency Prescaler 1 [AI]
Public property | InputLED0 | Input (LED0)
Public property | InputLED0AI | Input (LED0) [AI]
Public property | InputLED1 | Input (LED1)
Public property | InputLED1AI | Input (LED1) [AI]
Public property | LEDSelectorLED0 | LED Selector (LED 0)
Public property | LEDSelectorLED0AI | LED Selector (LED 0) [AI]
Public property | LEDSelectorLED1 | LED Selector (LED 1)
Public property | LEDSelectorLED1AI | LED Selector (LED 1) [AI]
Public property | PWM0 | PWM 0
Public property | PWM0AI | PWM 0 [AI]
Public property | PWM1 | PWM 1
Public property | PWM1AI | PWM 1 [AI]
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
2-Bit I2C LED Dimmer
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9530 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9530(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9530(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9530

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530 Properties

The Pca9530 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FrequencyPrescaler0 | Frequency Prescaler 0
Public property | FrequencyPrescaler0AI | Frequency Prescaler 0 [AI]
Public property | FrequencyPrescaler1 | Frequency Prescaler 1
Public property | FrequencyPrescaler1AI | Frequency Prescaler 1 [AI]
Public property | InputLED0 | Input (LED0)
Public property | InputLED0AI | Input (LED0) [AI]
Public property | InputLED1 | Input (LED1)
Public property | InputLED1AI | Input (LED1) [AI]
Public property | LEDSelectorLED0 | LED Selector (LED 0)
Public property | LEDSelectorLED0AI | LED Selector (LED 0) [AI]
Public property | LEDSelectorLED1 | LED Selector (LED 1)
Public property | LEDSelectorLED1AI | LED Selector (LED 1) [AI]
Public property | PWM0 | PWM 0
Public property | PWM0AI | PWM 0 [AI]
Public property | PWM1 | PWM 1
Public property | PWM1AI | PWM 1 [AI]
Top
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.AutoFlush Property

IRD

Pca9530AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.FrequencyPrescaler0 Property

IRD

Pca9530FrequencyPrescaler0 Property

Frequency Prescaler 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler0 { get; set; }
Public Property FrequencyPrescaler0 As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler0 {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.FrequencyPrescaler0AI Property

IRD

Pca9530FrequencyPrescaler0AI Property

Frequency Prescaler 0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler0AI { get; set; }
Public Property FrequencyPrescaler0AI As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.FrequencyPrescaler1 Property

IRD

Pca9530FrequencyPrescaler1 Property

Frequency Prescaler 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler1 { get; set; }
Public Property FrequencyPrescaler1 As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler1 {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.FrequencyPrescaler1AI Property

IRD

Pca9530FrequencyPrescaler1AI Property

Frequency Prescaler 1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler1AI { get; set; }
Public Property FrequencyPrescaler1AI As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.InputLED0 Property

IRD

Pca9530InputLED0 Property

Input (LED0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9530TypeInput InputLED0 { get; }
Public ReadOnly Property InputLED0 As Pca9530TypeInput
    Get
public:
property Pca9530TypeInput InputLED0 {
    Pca9530TypeInput get ();
}
member InputLED0 : Pca9530TypeInput with get

Property Value

Type: Pca9530TypeInput
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.InputLED0AI Property

IRD

Pca9530InputLED0AI Property

Input (LED0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9530TypeInput InputLED0AI { get; }
Public ReadOnly Property InputLED0AI As Pca9530TypeInput
    Get
public:
property Pca9530TypeInput InputLED0AI {
    Pca9530TypeInput get ();
}
member InputLED0AI : Pca9530TypeInput with get

Property Value

Type: Pca9530TypeInput
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.InputLED1 Property

IRD

Pca9530InputLED1 Property

Input (LED1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9530TypeInput InputLED1 { get; }
Public ReadOnly Property InputLED1 As Pca9530TypeInput
    Get
public:
property Pca9530TypeInput InputLED1 {
    Pca9530TypeInput get ();
}
member InputLED1 : Pca9530TypeInput with get

Property Value

Type: Pca9530TypeInput
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.InputLED1AI Property

IRD

Pca9530InputLED1AI Property

Input (LED1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9530TypeInput InputLED1AI { get; }
Public ReadOnly Property InputLED1AI As Pca9530TypeInput
    Get
public:
property Pca9530TypeInput InputLED1AI {
    Pca9530TypeInput get ();
}
member InputLED1AI : Pca9530TypeInput with get

Property Value

Type: Pca9530TypeInput
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.LEDSelectorLED0 Property

IRD

Pca9530LEDSelectorLED0 Property

LED Selector (LED 0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9530TypeLedSelector LEDSelectorLED0 { get; set; }
Public Property LEDSelectorLED0 As Pca9530TypeLedSelector
    Get
    Set
public:
property Pca9530TypeLedSelector LEDSelectorLED0 {
    Pca9530TypeLedSelector get ();
    void set (Pca9530TypeLedSelector value);
}
member LEDSelectorLED0 : Pca9530TypeLedSelector with get, set

Property Value

Type: Pca9530TypeLedSelector
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.LEDSelectorLED0AI Property

IRD

Pca9530LEDSelectorLED0AI Property

LED Selector (LED 0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9530TypeLedSelector LEDSelectorLED0AI { get; set; }
Public Property LEDSelectorLED0AI As Pca9530TypeLedSelector
    Get
    Set
public:
property Pca9530TypeLedSelector LEDSelectorLED0AI {
    Pca9530TypeLedSelector get ();
    void set (Pca9530TypeLedSelector value);
}
member LEDSelectorLED0AI : Pca9530TypeLedSelector with get, set

Property Value

Type: Pca9530TypeLedSelector
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.LEDSelectorLED1 Property

IRD

Pca9530LEDSelectorLED1 Property

LED Selector (LED 1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9530TypeLedSelector LEDSelectorLED1 { get; set; }
Public Property LEDSelectorLED1 As Pca9530TypeLedSelector
    Get
    Set
public:
property Pca9530TypeLedSelector LEDSelectorLED1 {
    Pca9530TypeLedSelector get ();
    void set (Pca9530TypeLedSelector value);
}
member LEDSelectorLED1 : Pca9530TypeLedSelector with get, set

Property Value

Type: Pca9530TypeLedSelector
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.LEDSelectorLED1AI Property

IRD

Pca9530LEDSelectorLED1AI Property

LED Selector (LED 1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9530TypeLedSelector LEDSelectorLED1AI { get; set; }
Public Property LEDSelectorLED1AI As Pca9530TypeLedSelector
    Get
    Set
public:
property Pca9530TypeLedSelector LEDSelectorLED1AI {
    Pca9530TypeLedSelector get ();
    void set (Pca9530TypeLedSelector value);
}
member LEDSelectorLED1AI : Pca9530TypeLedSelector with get, set

Property Value

Type: Pca9530TypeLedSelector
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.PWM0 Property

IRD

Pca9530PWM0 Property

PWM 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM0 { get; set; }
Public Property PWM0 As Byte
    Get
    Set
public:
property unsigned char PWM0 {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.PWM0AI Property

IRD

Pca9530PWM0AI Property

PWM 0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM0AI { get; set; }
Public Property PWM0AI As Byte
    Get
    Set
public:
property unsigned char PWM0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.PWM1 Property

IRD

Pca9530PWM1 Property

PWM 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM1 { get; set; }
Public Property PWM1 As Byte
    Get
    Set
public:
property unsigned char PWM1 {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.PWM1AI Property

IRD

Pca9530PWM1AI Property

PWM 1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM1AI { get; set; }
Public Property PWM1AI As Byte
    Get
    Set
public:
property unsigned char PWM1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530 Methods

The Pca9530 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.Flush Method

IRD

Pca9530Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9530 Class
telos.Ird.NXPSemiconductors Namespace


Pca9530.TypeInput Enumeration

IRD

Pca9530TypeInput Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInput
Public Enumeration TypeInput
public enum class TypeInput
type TypeInput
Members
Member name | Value | Description
High | 1 | High
Low | 0 | Low
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9530.TypeLedSelector Enumeration

IRD

Pca9530TypeLedSelector Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedSelector
Public Enumeration TypeLedSelector
public enum class TypeLedSelector
type TypeLedSelector
Members
Member name | Value | Description
OutputIsSetHiZLEDOff | 0 | Output is set Hi-Z (LED off)
OutputIsSetLOWLEDOn | 1 | Output is set LOW (LED on)
OutputBlinksAtPWM0Rate | 2 | Output blinks at PWM0 rate
OutputBlinksAtPWM1Rate | 3 | Output blinks at PWM1 rate
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9531 Class

NXP Semiconductors: PCA 9531
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9531

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9531
Public Class Pca9531
public ref class Pca9531
type Pca9531 =  class end

The Pca9531 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9531 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FrequencyPrescaler0 | Frequency Prescaler 0
Public property | FrequencyPrescaler0AI | Frequency Prescaler 0 [AI]
Public property | FrequencyPrescaler1 | Frequency Prescaler 1
Public property | FrequencyPrescaler1AI | Frequency Prescaler 1 [AI]
Public property | InputLED0 | Input (LED0)
Public property | InputLED0AI | Input (LED0) [AI]
Public property | InputLED1 | Input (LED1)
Public property | InputLED1AI | Input (LED1) [AI]
Public property | InputLED2 | Input (LED2)
Public property | InputLED2AI | Input (LED2) [AI]
Public property | InputLED3 | Input (LED3)
Public property | InputLED3AI | Input (LED3) [AI]
Public property | InputLED4 | Input (LED4)
Public property | InputLED4AI | Input (LED4) [AI]
Public property | InputLED5 | Input (LED5)
Public property | InputLED5AI | Input (LED5) [AI]
Public property | InputLED6 | Input (LED6)
Public property | InputLED6AI | Input (LED6) [AI]
Public property | InputLED7 | Input (LED7)
Public property | InputLED7AI | Input (LED7) [AI]
Public property | LEDSelectorLED0 | LED Selector (LED 0)
Public property | LEDSelectorLED0AI | LED Selector (LED 0) [AI]
Public property | LEDSelectorLED1 | LED Selector (LED 1)
Public property | LEDSelectorLED1AI | LED Selector (LED 1) [AI]
Public property | LEDSelectorLED2 | LED Selector (LED 2)
Public property | LEDSelectorLED2AI | LED Selector (LED 2) [AI]
Public property | LEDSelectorLED3 | LED Selector (LED 3)
Public property | LEDSelectorLED3AI | LED Selector (LED 3) [AI]
Public property | LEDSelectorLED4 | LED Selector (LED 4)
Public property | LEDSelectorLED4AI | LED Selector (LED 4) [AI]
Public property | LEDSelectorLED5 | LED Selector (LED 5)
Public property | LEDSelectorLED5AI | LED Selector (LED 5) [AI]
Public property | LEDSelectorLED6 | LED Selector (LED 6)
Public property | LEDSelectorLED6AI | LED Selector (LED 6) [AI]
Public property | LEDSelectorLED7 | LED Selector (LED 7)
Public property | LEDSelectorLED7AI | LED Selector (LED 7) [AI]
Public property | PWM0 | PWM 0
Public property | PWM0AI | PWM 0 [AI]
Public property | PWM1 | PWM 1
Public property | PWM1AI | PWM 1 [AI]
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
8-Bit I2C-Bus LED Dimmer
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9531 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9531(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9531

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531 Properties

The Pca9531 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FrequencyPrescaler0 | Frequency Prescaler 0
Public property | FrequencyPrescaler0AI | Frequency Prescaler 0 [AI]
Public property | FrequencyPrescaler1 | Frequency Prescaler 1
Public property | FrequencyPrescaler1AI | Frequency Prescaler 1 [AI]
Public property | InputLED0 | Input (LED0)
Public property | InputLED0AI | Input (LED0) [AI]
Public property | InputLED1 | Input (LED1)
Public property | InputLED1AI | Input (LED1) [AI]
Public property | InputLED2 | Input (LED2)
Public property | InputLED2AI | Input (LED2) [AI]
Public property | InputLED3 | Input (LED3)
Public property | InputLED3AI | Input (LED3) [AI]
Public property | InputLED4 | Input (LED4)
Public property | InputLED4AI | Input (LED4) [AI]
Public property | InputLED5 | Input (LED5)
Public property | InputLED5AI | Input (LED5) [AI]
Public property | InputLED6 | Input (LED6)
Public property | InputLED6AI | Input (LED6) [AI]
Public property | InputLED7 | Input (LED7)
Public property | InputLED7AI | Input (LED7) [AI]
Public property | LEDSelectorLED0 | LED Selector (LED 0)
Public property | LEDSelectorLED0AI | LED Selector (LED 0) [AI]
Public property | LEDSelectorLED1 | LED Selector (LED 1)
Public property | LEDSelectorLED1AI | LED Selector (LED 1) [AI]
Public property | LEDSelectorLED2 | LED Selector (LED 2)
Public property | LEDSelectorLED2AI | LED Selector (LED 2) [AI]
Public property | LEDSelectorLED3 | LED Selector (LED 3)
Public property | LEDSelectorLED3AI | LED Selector (LED 3) [AI]
Public property | LEDSelectorLED4 | LED Selector (LED 4)
Public property | LEDSelectorLED4AI | LED Selector (LED 4) [AI]
Public property | LEDSelectorLED5 | LED Selector (LED 5)
Public property | LEDSelectorLED5AI | LED Selector (LED 5) [AI]
Public property | LEDSelectorLED6 | LED Selector (LED 6)
Public property | LEDSelectorLED6AI | LED Selector (LED 6) [AI]
Public property | LEDSelectorLED7 | LED Selector (LED 7)
Public property | LEDSelectorLED7AI | LED Selector (LED 7) [AI]
Public property | PWM0 | PWM 0
Public property | PWM0AI | PWM 0 [AI]
Public property | PWM1 | PWM 1
Public property | PWM1AI | PWM 1 [AI]
Top
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.AutoFlush Property

IRD

Pca9531AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.FrequencyPrescaler0 Property

IRD

Pca9531FrequencyPrescaler0 Property

Frequency Prescaler 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler0 { get; set; }
Public Property FrequencyPrescaler0 As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler0 {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.FrequencyPrescaler0AI Property

IRD

Pca9531FrequencyPrescaler0AI Property

Frequency Prescaler 0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler0AI { get; set; }
Public Property FrequencyPrescaler0AI As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.FrequencyPrescaler1 Property

IRD

Pca9531FrequencyPrescaler1 Property

Frequency Prescaler 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler1 { get; set; }
Public Property FrequencyPrescaler1 As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler1 {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.FrequencyPrescaler1AI Property

IRD

Pca9531FrequencyPrescaler1AI Property

Frequency Prescaler 1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler1AI { get; set; }
Public Property FrequencyPrescaler1AI As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.InputLED0 Property

IRD

Pca9531InputLED0 Property

Input (LED0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeInput InputLED0 { get; }
Public ReadOnly Property InputLED0 As Pca9531TypeInput
    Get
public:
property Pca9531TypeInput InputLED0 {
    Pca9531TypeInput get ();
}
member InputLED0 : Pca9531TypeInput with get

Property Value

Type: Pca9531TypeInput
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.InputLED0AI Property

IRD

Pca9531InputLED0AI Property

Input (LED0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeInput InputLED0AI { get; }
Public ReadOnly Property InputLED0AI As Pca9531TypeInput
    Get
public:
property Pca9531TypeInput InputLED0AI {
    Pca9531TypeInput get ();
}
member InputLED0AI : Pca9531TypeInput with get

Property Value

Type: Pca9531TypeInput
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.InputLED1 Property

IRD

Pca9531InputLED1 Property

Input (LED1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeInput InputLED1 { get; }
Public ReadOnly Property InputLED1 As Pca9531TypeInput
    Get
public:
property Pca9531TypeInput InputLED1 {
    Pca9531TypeInput get ();
}
member InputLED1 : Pca9531TypeInput with get

Property Value

Type: Pca9531TypeInput
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.InputLED1AI Property

IRD

Pca9531InputLED1AI Property

Input (LED1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeInput InputLED1AI { get; }
Public ReadOnly Property InputLED1AI As Pca9531TypeInput
    Get
public:
property Pca9531TypeInput InputLED1AI {
    Pca9531TypeInput get ();
}
member InputLED1AI : Pca9531TypeInput with get

Property Value

Type: Pca9531TypeInput
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.InputLED2 Property

IRD

Pca9531InputLED2 Property

Input (LED2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeInput InputLED2 { get; }
Public ReadOnly Property InputLED2 As Pca9531TypeInput
    Get
public:
property Pca9531TypeInput InputLED2 {
    Pca9531TypeInput get ();
}
member InputLED2 : Pca9531TypeInput with get

Property Value

Type: Pca9531TypeInput
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.InputLED2AI Property

IRD

Pca9531InputLED2AI Property

Input (LED2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeInput InputLED2AI { get; }
Public ReadOnly Property InputLED2AI As Pca9531TypeInput
    Get
public:
property Pca9531TypeInput InputLED2AI {
    Pca9531TypeInput get ();
}
member InputLED2AI : Pca9531TypeInput with get

Property Value

Type: Pca9531TypeInput
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.InputLED3 Property

IRD

Pca9531InputLED3 Property

Input (LED3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeInput InputLED3 { get; }
Public ReadOnly Property InputLED3 As Pca9531TypeInput
    Get
public:
property Pca9531TypeInput InputLED3 {
    Pca9531TypeInput get ();
}
member InputLED3 : Pca9531TypeInput with get

Property Value

Type: Pca9531TypeInput
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.InputLED3AI Property

IRD

Pca9531InputLED3AI Property

Input (LED3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeInput InputLED3AI { get; }
Public ReadOnly Property InputLED3AI As Pca9531TypeInput
    Get
public:
property Pca9531TypeInput InputLED3AI {
    Pca9531TypeInput get ();
}
member InputLED3AI : Pca9531TypeInput with get

Property Value

Type: Pca9531TypeInput
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.InputLED4 Property

IRD

Pca9531InputLED4 Property

Input (LED4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeInput InputLED4 { get; }
Public ReadOnly Property InputLED4 As Pca9531TypeInput
    Get
public:
property Pca9531TypeInput InputLED4 {
    Pca9531TypeInput get ();
}
member InputLED4 : Pca9531TypeInput with get

Property Value

Type: Pca9531TypeInput
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.InputLED4AI Property

IRD

Pca9531InputLED4AI Property

Input (LED4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeInput InputLED4AI { get; }
Public ReadOnly Property InputLED4AI As Pca9531TypeInput
    Get
public:
property Pca9531TypeInput InputLED4AI {
    Pca9531TypeInput get ();
}
member InputLED4AI : Pca9531TypeInput with get

Property Value

Type: Pca9531TypeInput
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.InputLED5 Property

IRD

Pca9531InputLED5 Property

Input (LED5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeInput InputLED5 { get; }
Public ReadOnly Property InputLED5 As Pca9531TypeInput
    Get
public:
property Pca9531TypeInput InputLED5 {
    Pca9531TypeInput get ();
}
member InputLED5 : Pca9531TypeInput with get

Property Value

Type: Pca9531TypeInput
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.InputLED5AI Property

IRD

Pca9531InputLED5AI Property

Input (LED5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeInput InputLED5AI { get; }
Public ReadOnly Property InputLED5AI As Pca9531TypeInput
    Get
public:
property Pca9531TypeInput InputLED5AI {
    Pca9531TypeInput get ();
}
member InputLED5AI : Pca9531TypeInput with get

Property Value

Type: Pca9531TypeInput
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.InputLED6 Property

IRD

Pca9531InputLED6 Property

Input (LED6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeInput InputLED6 { get; }
Public ReadOnly Property InputLED6 As Pca9531TypeInput
    Get
public:
property Pca9531TypeInput InputLED6 {
    Pca9531TypeInput get ();
}
member InputLED6 : Pca9531TypeInput with get

Property Value

Type: Pca9531TypeInput
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.InputLED6AI Property

IRD

Pca9531InputLED6AI Property

Input (LED6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeInput InputLED6AI { get; }
Public ReadOnly Property InputLED6AI As Pca9531TypeInput
    Get
public:
property Pca9531TypeInput InputLED6AI {
    Pca9531TypeInput get ();
}
member InputLED6AI : Pca9531TypeInput with get

Property Value

Type: Pca9531TypeInput
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.InputLED7 Property

IRD

Pca9531InputLED7 Property

Input (LED7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeInput InputLED7 { get; }
Public ReadOnly Property InputLED7 As Pca9531TypeInput
    Get
public:
property Pca9531TypeInput InputLED7 {
    Pca9531TypeInput get ();
}
member InputLED7 : Pca9531TypeInput with get

Property Value

Type: Pca9531TypeInput
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.InputLED7AI Property

IRD

Pca9531InputLED7AI Property

Input (LED7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeInput InputLED7AI { get; }
Public ReadOnly Property InputLED7AI As Pca9531TypeInput
    Get
public:
property Pca9531TypeInput InputLED7AI {
    Pca9531TypeInput get ();
}
member InputLED7AI : Pca9531TypeInput with get

Property Value

Type: Pca9531TypeInput
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.LEDSelectorLED0 Property

IRD

Pca9531LEDSelectorLED0 Property

LED Selector (LED 0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeLedSelector LEDSelectorLED0 { get; set; }
Public Property LEDSelectorLED0 As Pca9531TypeLedSelector
    Get
    Set
public:
property Pca9531TypeLedSelector LEDSelectorLED0 {
    Pca9531TypeLedSelector get ();
    void set (Pca9531TypeLedSelector value);
}
member LEDSelectorLED0 : Pca9531TypeLedSelector with get, set

Property Value

Type: Pca9531TypeLedSelector
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.LEDSelectorLED0AI Property

IRD

Pca9531LEDSelectorLED0AI Property

LED Selector (LED 0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeLedSelector LEDSelectorLED0AI { get; set; }
Public Property LEDSelectorLED0AI As Pca9531TypeLedSelector
    Get
    Set
public:
property Pca9531TypeLedSelector LEDSelectorLED0AI {
    Pca9531TypeLedSelector get ();
    void set (Pca9531TypeLedSelector value);
}
member LEDSelectorLED0AI : Pca9531TypeLedSelector with get, set

Property Value

Type: Pca9531TypeLedSelector
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.LEDSelectorLED1 Property

IRD

Pca9531LEDSelectorLED1 Property

LED Selector (LED 1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeLedSelector LEDSelectorLED1 { get; set; }
Public Property LEDSelectorLED1 As Pca9531TypeLedSelector
    Get
    Set
public:
property Pca9531TypeLedSelector LEDSelectorLED1 {
    Pca9531TypeLedSelector get ();
    void set (Pca9531TypeLedSelector value);
}
member LEDSelectorLED1 : Pca9531TypeLedSelector with get, set

Property Value

Type: Pca9531TypeLedSelector
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.LEDSelectorLED1AI Property

IRD

Pca9531LEDSelectorLED1AI Property

LED Selector (LED 1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeLedSelector LEDSelectorLED1AI { get; set; }
Public Property LEDSelectorLED1AI As Pca9531TypeLedSelector
    Get
    Set
public:
property Pca9531TypeLedSelector LEDSelectorLED1AI {
    Pca9531TypeLedSelector get ();
    void set (Pca9531TypeLedSelector value);
}
member LEDSelectorLED1AI : Pca9531TypeLedSelector with get, set

Property Value

Type: Pca9531TypeLedSelector
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.LEDSelectorLED2 Property

IRD

Pca9531LEDSelectorLED2 Property

LED Selector (LED 2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeLedSelector LEDSelectorLED2 { get; set; }
Public Property LEDSelectorLED2 As Pca9531TypeLedSelector
    Get
    Set
public:
property Pca9531TypeLedSelector LEDSelectorLED2 {
    Pca9531TypeLedSelector get ();
    void set (Pca9531TypeLedSelector value);
}
member LEDSelectorLED2 : Pca9531TypeLedSelector with get, set

Property Value

Type: Pca9531TypeLedSelector
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.LEDSelectorLED2AI Property

IRD

Pca9531LEDSelectorLED2AI Property

LED Selector (LED 2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeLedSelector LEDSelectorLED2AI { get; set; }
Public Property LEDSelectorLED2AI As Pca9531TypeLedSelector
    Get
    Set
public:
property Pca9531TypeLedSelector LEDSelectorLED2AI {
    Pca9531TypeLedSelector get ();
    void set (Pca9531TypeLedSelector value);
}
member LEDSelectorLED2AI : Pca9531TypeLedSelector with get, set

Property Value

Type: Pca9531TypeLedSelector
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.LEDSelectorLED3 Property

IRD

Pca9531LEDSelectorLED3 Property

LED Selector (LED 3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeLedSelector LEDSelectorLED3 { get; set; }
Public Property LEDSelectorLED3 As Pca9531TypeLedSelector
    Get
    Set
public:
property Pca9531TypeLedSelector LEDSelectorLED3 {
    Pca9531TypeLedSelector get ();
    void set (Pca9531TypeLedSelector value);
}
member LEDSelectorLED3 : Pca9531TypeLedSelector with get, set

Property Value

Type: Pca9531TypeLedSelector
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.LEDSelectorLED3AI Property

IRD

Pca9531LEDSelectorLED3AI Property

LED Selector (LED 3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeLedSelector LEDSelectorLED3AI { get; set; }
Public Property LEDSelectorLED3AI As Pca9531TypeLedSelector
    Get
    Set
public:
property Pca9531TypeLedSelector LEDSelectorLED3AI {
    Pca9531TypeLedSelector get ();
    void set (Pca9531TypeLedSelector value);
}
member LEDSelectorLED3AI : Pca9531TypeLedSelector with get, set

Property Value

Type: Pca9531TypeLedSelector
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.LEDSelectorLED4 Property

IRD

Pca9531LEDSelectorLED4 Property

LED Selector (LED 4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeLedSelector LEDSelectorLED4 { get; set; }
Public Property LEDSelectorLED4 As Pca9531TypeLedSelector
    Get
    Set
public:
property Pca9531TypeLedSelector LEDSelectorLED4 {
    Pca9531TypeLedSelector get ();
    void set (Pca9531TypeLedSelector value);
}
member LEDSelectorLED4 : Pca9531TypeLedSelector with get, set

Property Value

Type: Pca9531TypeLedSelector
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.LEDSelectorLED4AI Property

IRD

Pca9531LEDSelectorLED4AI Property

LED Selector (LED 4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeLedSelector LEDSelectorLED4AI { get; set; }
Public Property LEDSelectorLED4AI As Pca9531TypeLedSelector
    Get
    Set
public:
property Pca9531TypeLedSelector LEDSelectorLED4AI {
    Pca9531TypeLedSelector get ();
    void set (Pca9531TypeLedSelector value);
}
member LEDSelectorLED4AI : Pca9531TypeLedSelector with get, set

Property Value

Type: Pca9531TypeLedSelector
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.LEDSelectorLED5 Property

IRD

Pca9531LEDSelectorLED5 Property

LED Selector (LED 5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeLedSelector LEDSelectorLED5 { get; set; }
Public Property LEDSelectorLED5 As Pca9531TypeLedSelector
    Get
    Set
public:
property Pca9531TypeLedSelector LEDSelectorLED5 {
    Pca9531TypeLedSelector get ();
    void set (Pca9531TypeLedSelector value);
}
member LEDSelectorLED5 : Pca9531TypeLedSelector with get, set

Property Value

Type: Pca9531TypeLedSelector
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.LEDSelectorLED5AI Property

IRD

Pca9531LEDSelectorLED5AI Property

LED Selector (LED 5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeLedSelector LEDSelectorLED5AI { get; set; }
Public Property LEDSelectorLED5AI As Pca9531TypeLedSelector
    Get
    Set
public:
property Pca9531TypeLedSelector LEDSelectorLED5AI {
    Pca9531TypeLedSelector get ();
    void set (Pca9531TypeLedSelector value);
}
member LEDSelectorLED5AI : Pca9531TypeLedSelector with get, set

Property Value

Type: Pca9531TypeLedSelector
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.LEDSelectorLED6 Property

IRD

Pca9531LEDSelectorLED6 Property

LED Selector (LED 6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeLedSelector LEDSelectorLED6 { get; set; }
Public Property LEDSelectorLED6 As Pca9531TypeLedSelector
    Get
    Set
public:
property Pca9531TypeLedSelector LEDSelectorLED6 {
    Pca9531TypeLedSelector get ();
    void set (Pca9531TypeLedSelector value);
}
member LEDSelectorLED6 : Pca9531TypeLedSelector with get, set

Property Value

Type: Pca9531TypeLedSelector
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.LEDSelectorLED6AI Property

IRD

Pca9531LEDSelectorLED6AI Property

LED Selector (LED 6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeLedSelector LEDSelectorLED6AI { get; set; }
Public Property LEDSelectorLED6AI As Pca9531TypeLedSelector
    Get
    Set
public:
property Pca9531TypeLedSelector LEDSelectorLED6AI {
    Pca9531TypeLedSelector get ();
    void set (Pca9531TypeLedSelector value);
}
member LEDSelectorLED6AI : Pca9531TypeLedSelector with get, set

Property Value

Type: Pca9531TypeLedSelector
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.LEDSelectorLED7 Property

IRD

Pca9531LEDSelectorLED7 Property

LED Selector (LED 7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeLedSelector LEDSelectorLED7 { get; set; }
Public Property LEDSelectorLED7 As Pca9531TypeLedSelector
    Get
    Set
public:
property Pca9531TypeLedSelector LEDSelectorLED7 {
    Pca9531TypeLedSelector get ();
    void set (Pca9531TypeLedSelector value);
}
member LEDSelectorLED7 : Pca9531TypeLedSelector with get, set

Property Value

Type: Pca9531TypeLedSelector
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.LEDSelectorLED7AI Property

IRD

Pca9531LEDSelectorLED7AI Property

LED Selector (LED 7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9531TypeLedSelector LEDSelectorLED7AI { get; set; }
Public Property LEDSelectorLED7AI As Pca9531TypeLedSelector
    Get
    Set
public:
property Pca9531TypeLedSelector LEDSelectorLED7AI {
    Pca9531TypeLedSelector get ();
    void set (Pca9531TypeLedSelector value);
}
member LEDSelectorLED7AI : Pca9531TypeLedSelector with get, set

Property Value

Type: Pca9531TypeLedSelector
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.PWM0 Property

IRD

Pca9531PWM0 Property

PWM 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM0 { get; set; }
Public Property PWM0 As Byte
    Get
    Set
public:
property unsigned char PWM0 {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.PWM0AI Property

IRD

Pca9531PWM0AI Property

PWM 0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM0AI { get; set; }
Public Property PWM0AI As Byte
    Get
    Set
public:
property unsigned char PWM0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.PWM1 Property

IRD

Pca9531PWM1 Property

PWM 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM1 { get; set; }
Public Property PWM1 As Byte
    Get
    Set
public:
property unsigned char PWM1 {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.PWM1AI Property

IRD

Pca9531PWM1AI Property

PWM 1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM1AI { get; set; }
Public Property PWM1AI As Byte
    Get
    Set
public:
property unsigned char PWM1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531 Methods

The Pca9531 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.Flush Method

IRD

Pca9531Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9531 Class
telos.Ird.NXPSemiconductors Namespace


Pca9531.TypeInput Enumeration

IRD

Pca9531TypeInput Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInput
Public Enumeration TypeInput
public enum class TypeInput
type TypeInput
Members
Member name | Value | Description
High | 1 | High
Low | 0 | Low
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9531.TypeLedSelector Enumeration

IRD

Pca9531TypeLedSelector Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedSelector
Public Enumeration TypeLedSelector
public enum class TypeLedSelector
type TypeLedSelector
Members
Member name | Value | Description
OutputIsSetHiZLEDOff | 0 | Output is set Hi-Z (LED off)
OutputIsSetLOWLEDOn | 1 | Output is set LOW (LED on)
OutputBlinksAtPWM0Rate | 2 | Output blinks at PWM0 rate
OutputBlinksAtPWM1Rate | 3 | Output blinks at PWM1 rate
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9532 Class

NXP Semiconductors: PCA 9532
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9532

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9532
Public Class Pca9532
public ref class Pca9532
type Pca9532 =  class end

The Pca9532 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9532 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FrequencyPrescaler0 | Frequency Prescaler 0
Public property | FrequencyPrescaler0AI | Frequency Prescaler 0 [AI]
Public property | FrequencyPrescaler1 | Frequency Prescaler 1
Public property | FrequencyPrescaler1AI | Frequency Prescaler 1 [AI]
Public property | InputLED0 | Input (LED0)
Public property | InputLED0AI | Input (LED0) [AI]
Public property | InputLED1 | Input (LED1)
Public property | InputLED10 | Input (LED10)
Public property | InputLED10AI | Input (LED10) [AI]
Public property | InputLED11 | Input (LED11)
Public property | InputLED11AI | Input (LED11) [AI]
Public property | InputLED12 | Input (LED12)
Public property | InputLED12AI | Input (LED12) [AI]
Public property | InputLED13 | Input (LED13)
Public property | InputLED13AI | Input (LED13) [AI]
Public property | InputLED14 | Input (LED14)
Public property | InputLED14AI | Input (LED14) [AI]
Public property | InputLED15 | Input (LED15)
Public property | InputLED15AI | Input (LED15) [AI]
Public property | InputLED1AI | Input (LED1) [AI]
Public property | InputLED2 | Input (LED2)
Public property | InputLED2AI | Input (LED2) [AI]
Public property | InputLED3 | Input (LED3)
Public property | InputLED3AI | Input (LED3) [AI]
Public property | InputLED4 | Input (LED4)
Public property | InputLED4AI | Input (LED4) [AI]
Public property | InputLED5 | Input (LED5)
Public property | InputLED5AI | Input (LED5) [AI]
Public property | InputLED6 | Input (LED6)
Public property | InputLED6AI | Input (LED6) [AI]
Public property | InputLED7 | Input (LED7)
Public property | InputLED7AI | Input (LED7) [AI]
Public property | InputLED8 | Input (LED8)
Public property | InputLED8AI | Input (LED8) [AI]
Public property | InputLED9 | Input (LED9)
Public property | InputLED9AI | Input (LED9) [AI]
Public property | LEDSelectorLED0 | LED Selector (LED 0)
Public property | LEDSelectorLED0AI | LED Selector (LED 0) [AI]
Public property | LEDSelectorLED1 | LED Selector (LED 1)
Public property | LEDSelectorLED10 | LED Selector (LED 10)
Public property | LEDSelectorLED10AI | LED Selector (LED 10) [AI]
Public property | LEDSelectorLED11 | LED Selector (LED 11)
Public property | LEDSelectorLED11AI | LED Selector (LED 11) [AI]
Public property | LEDSelectorLED12 | LED Selector (LED 12)
Public property | LEDSelectorLED12AI | LED Selector (LED 12) [AI]
Public property | LEDSelectorLED13 | LED Selector (LED 13)
Public property | LEDSelectorLED13AI | LED Selector (LED 13) [AI]
Public property | LEDSelectorLED14 | LED Selector (LED 14)
Public property | LEDSelectorLED14AI | LED Selector (LED 14) [AI]
Public property | LEDSelectorLED15 | LED Selector (LED 15)
Public property | LEDSelectorLED15AI | LED Selector (LED 15) [AI]
Public property | LEDSelectorLED1AI | LED Selector (LED 1) [AI]
Public property | LEDSelectorLED2 | LED Selector (LED 2)
Public property | LEDSelectorLED2AI | LED Selector (LED 2) [AI]
Public property | LEDSelectorLED3 | LED Selector (LED 3)
Public property | LEDSelectorLED3AI | LED Selector (LED 3) [AI]
Public property | LEDSelectorLED4 | LED Selector (LED 4)
Public property | LEDSelectorLED4AI | LED Selector (LED 4) [AI]
Public property | LEDSelectorLED5 | LED Selector (LED 5)
Public property | LEDSelectorLED5AI | LED Selector (LED 5) [AI]
Public property | LEDSelectorLED6 | LED Selector (LED 6)
Public property | LEDSelectorLED6AI | LED Selector (LED 6) [AI]
Public property | LEDSelectorLED7 | LED Selector (LED 7)
Public property | LEDSelectorLED7AI | LED Selector (LED 7) [AI]
Public property | LEDSelectorLED8 | LED Selector (LED 8)
Public property | LEDSelectorLED8AI | LED Selector (LED 8) [AI]
Public property | LEDSelectorLED9 | LED Selector (LED 9)
Public property | LEDSelectorLED9AI | LED Selector (LED 9) [AI]
Public property | PWM0 | PWM 0
Public property | PWM0AI | PWM 0 [AI]
Public property | PWM1 | PWM 1
Public property | PWM1AI | PWM 1 [AI]
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
16-Bit I2C LED Dimmer
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9532 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9532(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9532

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532 Properties

The Pca9532 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FrequencyPrescaler0 | Frequency Prescaler 0
Public property | FrequencyPrescaler0AI | Frequency Prescaler 0 [AI]
Public property | FrequencyPrescaler1 | Frequency Prescaler 1
Public property | FrequencyPrescaler1AI | Frequency Prescaler 1 [AI]
Public property | InputLED0 | Input (LED0)
Public property | InputLED0AI | Input (LED0) [AI]
Public property | InputLED1 | Input (LED1)
Public property | InputLED10 | Input (LED10)
Public property | InputLED10AI | Input (LED10) [AI]
Public property | InputLED11 | Input (LED11)
Public property | InputLED11AI | Input (LED11) [AI]
Public property | InputLED12 | Input (LED12)
Public property | InputLED12AI | Input (LED12) [AI]
Public property | InputLED13 | Input (LED13)
Public property | InputLED13AI | Input (LED13) [AI]
Public property | InputLED14 | Input (LED14)
Public property | InputLED14AI | Input (LED14) [AI]
Public property | InputLED15 | Input (LED15)
Public property | InputLED15AI | Input (LED15) [AI]
Public property | InputLED1AI | Input (LED1) [AI]
Public property | InputLED2 | Input (LED2)
Public property | InputLED2AI | Input (LED2) [AI]
Public property | InputLED3 | Input (LED3)
Public property | InputLED3AI | Input (LED3) [AI]
Public property | InputLED4 | Input (LED4)
Public property | InputLED4AI | Input (LED4) [AI]
Public property | InputLED5 | Input (LED5)
Public property | InputLED5AI | Input (LED5) [AI]
Public property | InputLED6 | Input (LED6)
Public property | InputLED6AI | Input (LED6) [AI]
Public property | InputLED7 | Input (LED7)
Public property | InputLED7AI | Input (LED7) [AI]
Public property | InputLED8 | Input (LED8)
Public property | InputLED8AI | Input (LED8) [AI]
Public property | InputLED9 | Input (LED9)
Public property | InputLED9AI | Input (LED9) [AI]
Public property | LEDSelectorLED0 | LED Selector (LED 0)
Public property | LEDSelectorLED0AI | LED Selector (LED 0) [AI]
Public property | LEDSelectorLED1 | LED Selector (LED 1)
Public property | LEDSelectorLED10 | LED Selector (LED 10)
Public property | LEDSelectorLED10AI | LED Selector (LED 10) [AI]
Public property | LEDSelectorLED11 | LED Selector (LED 11)
Public property | LEDSelectorLED11AI | LED Selector (LED 11) [AI]
Public property | LEDSelectorLED12 | LED Selector (LED 12)
Public property | LEDSelectorLED12AI | LED Selector (LED 12) [AI]
Public property | LEDSelectorLED13 | LED Selector (LED 13)
Public property | LEDSelectorLED13AI | LED Selector (LED 13) [AI]
Public property | LEDSelectorLED14 | LED Selector (LED 14)
Public property | LEDSelectorLED14AI | LED Selector (LED 14) [AI]
Public property | LEDSelectorLED15 | LED Selector (LED 15)
Public property | LEDSelectorLED15AI | LED Selector (LED 15) [AI]
Public property | LEDSelectorLED1AI | LED Selector (LED 1) [AI]
Public property | LEDSelectorLED2 | LED Selector (LED 2)
Public property | LEDSelectorLED2AI | LED Selector (LED 2) [AI]
Public property | LEDSelectorLED3 | LED Selector (LED 3)
Public property | LEDSelectorLED3AI | LED Selector (LED 3) [AI]
Public property | LEDSelectorLED4 | LED Selector (LED 4)
Public property | LEDSelectorLED4AI | LED Selector (LED 4) [AI]
Public property | LEDSelectorLED5 | LED Selector (LED 5)
Public property | LEDSelectorLED5AI | LED Selector (LED 5) [AI]
Public property | LEDSelectorLED6 | LED Selector (LED 6)
Public property | LEDSelectorLED6AI | LED Selector (LED 6) [AI]
Public property | LEDSelectorLED7 | LED Selector (LED 7)
Public property | LEDSelectorLED7AI | LED Selector (LED 7) [AI]
Public property | LEDSelectorLED8 | LED Selector (LED 8)
Public property | LEDSelectorLED8AI | LED Selector (LED 8) [AI]
Public property | LEDSelectorLED9 | LED Selector (LED 9)
Public property | LEDSelectorLED9AI | LED Selector (LED 9) [AI]
Public property | PWM0 | PWM 0
Public property | PWM0AI | PWM 0 [AI]
Public property | PWM1 | PWM 1
Public property | PWM1AI | PWM 1 [AI]
Top
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.AutoFlush Property

IRD

Pca9532AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.FrequencyPrescaler0 Property

IRD

Pca9532FrequencyPrescaler0 Property

Frequency Prescaler 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler0 { get; set; }
Public Property FrequencyPrescaler0 As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler0 {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.FrequencyPrescaler0AI Property

IRD

Pca9532FrequencyPrescaler0AI Property

Frequency Prescaler 0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler0AI { get; set; }
Public Property FrequencyPrescaler0AI As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.FrequencyPrescaler1 Property

IRD

Pca9532FrequencyPrescaler1 Property

Frequency Prescaler 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler1 { get; set; }
Public Property FrequencyPrescaler1 As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler1 {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.FrequencyPrescaler1AI Property

IRD

Pca9532FrequencyPrescaler1AI Property

Frequency Prescaler 1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler1AI { get; set; }
Public Property FrequencyPrescaler1AI As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED0 Property

IRD

Pca9532InputLED0 Property

Input (LED0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED0 { get; }
Public ReadOnly Property InputLED0 As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED0 {
    Pca9532TypeInput get ();
}
member InputLED0 : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED0AI Property

IRD

Pca9532InputLED0AI Property

Input (LED0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED0AI { get; }
Public ReadOnly Property InputLED0AI As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED0AI {
    Pca9532TypeInput get ();
}
member InputLED0AI : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED1 Property

IRD

Pca9532InputLED1 Property

Input (LED1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED1 { get; }
Public ReadOnly Property InputLED1 As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED1 {
    Pca9532TypeInput get ();
}
member InputLED1 : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED10 Property

IRD

Pca9532InputLED10 Property

Input (LED10)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED10 { get; }
Public ReadOnly Property InputLED10 As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED10 {
    Pca9532TypeInput get ();
}
member InputLED10 : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED10AI Property

IRD

Pca9532InputLED10AI Property

Input (LED10) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED10AI { get; }
Public ReadOnly Property InputLED10AI As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED10AI {
    Pca9532TypeInput get ();
}
member InputLED10AI : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED11 Property

IRD

Pca9532InputLED11 Property

Input (LED11)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED11 { get; }
Public ReadOnly Property InputLED11 As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED11 {
    Pca9532TypeInput get ();
}
member InputLED11 : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED11AI Property

IRD

Pca9532InputLED11AI Property

Input (LED11) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED11AI { get; }
Public ReadOnly Property InputLED11AI As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED11AI {
    Pca9532TypeInput get ();
}
member InputLED11AI : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED12 Property

IRD

Pca9532InputLED12 Property

Input (LED12)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED12 { get; }
Public ReadOnly Property InputLED12 As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED12 {
    Pca9532TypeInput get ();
}
member InputLED12 : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED12AI Property

IRD

Pca9532InputLED12AI Property

Input (LED12) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED12AI { get; }
Public ReadOnly Property InputLED12AI As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED12AI {
    Pca9532TypeInput get ();
}
member InputLED12AI : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED13 Property

IRD

Pca9532InputLED13 Property

Input (LED13)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED13 { get; }
Public ReadOnly Property InputLED13 As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED13 {
    Pca9532TypeInput get ();
}
member InputLED13 : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED13AI Property

IRD

Pca9532InputLED13AI Property

Input (LED13) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED13AI { get; }
Public ReadOnly Property InputLED13AI As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED13AI {
    Pca9532TypeInput get ();
}
member InputLED13AI : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED14 Property

IRD

Pca9532InputLED14 Property

Input (LED14)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED14 { get; }
Public ReadOnly Property InputLED14 As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED14 {
    Pca9532TypeInput get ();
}
member InputLED14 : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED14AI Property

IRD

Pca9532InputLED14AI Property

Input (LED14) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED14AI { get; }
Public ReadOnly Property InputLED14AI As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED14AI {
    Pca9532TypeInput get ();
}
member InputLED14AI : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED15 Property

IRD

Pca9532InputLED15 Property

Input (LED15)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED15 { get; }
Public ReadOnly Property InputLED15 As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED15 {
    Pca9532TypeInput get ();
}
member InputLED15 : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED15AI Property

IRD

Pca9532InputLED15AI Property

Input (LED15) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED15AI { get; }
Public ReadOnly Property InputLED15AI As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED15AI {
    Pca9532TypeInput get ();
}
member InputLED15AI : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED1AI Property

IRD

Pca9532InputLED1AI Property

Input (LED1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED1AI { get; }
Public ReadOnly Property InputLED1AI As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED1AI {
    Pca9532TypeInput get ();
}
member InputLED1AI : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED2 Property

IRD

Pca9532InputLED2 Property

Input (LED2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED2 { get; }
Public ReadOnly Property InputLED2 As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED2 {
    Pca9532TypeInput get ();
}
member InputLED2 : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED2AI Property

IRD

Pca9532InputLED2AI Property

Input (LED2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED2AI { get; }
Public ReadOnly Property InputLED2AI As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED2AI {
    Pca9532TypeInput get ();
}
member InputLED2AI : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED3 Property

IRD

Pca9532InputLED3 Property

Input (LED3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED3 { get; }
Public ReadOnly Property InputLED3 As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED3 {
    Pca9532TypeInput get ();
}
member InputLED3 : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED3AI Property

IRD

Pca9532InputLED3AI Property

Input (LED3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED3AI { get; }
Public ReadOnly Property InputLED3AI As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED3AI {
    Pca9532TypeInput get ();
}
member InputLED3AI : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED4 Property

IRD

Pca9532InputLED4 Property

Input (LED4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED4 { get; }
Public ReadOnly Property InputLED4 As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED4 {
    Pca9532TypeInput get ();
}
member InputLED4 : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED4AI Property

IRD

Pca9532InputLED4AI Property

Input (LED4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED4AI { get; }
Public ReadOnly Property InputLED4AI As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED4AI {
    Pca9532TypeInput get ();
}
member InputLED4AI : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED5 Property

IRD

Pca9532InputLED5 Property

Input (LED5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED5 { get; }
Public ReadOnly Property InputLED5 As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED5 {
    Pca9532TypeInput get ();
}
member InputLED5 : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED5AI Property

IRD

Pca9532InputLED5AI Property

Input (LED5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED5AI { get; }
Public ReadOnly Property InputLED5AI As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED5AI {
    Pca9532TypeInput get ();
}
member InputLED5AI : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED6 Property

IRD

Pca9532InputLED6 Property

Input (LED6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED6 { get; }
Public ReadOnly Property InputLED6 As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED6 {
    Pca9532TypeInput get ();
}
member InputLED6 : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED6AI Property

IRD

Pca9532InputLED6AI Property

Input (LED6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED6AI { get; }
Public ReadOnly Property InputLED6AI As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED6AI {
    Pca9532TypeInput get ();
}
member InputLED6AI : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED7 Property

IRD

Pca9532InputLED7 Property

Input (LED7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED7 { get; }
Public ReadOnly Property InputLED7 As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED7 {
    Pca9532TypeInput get ();
}
member InputLED7 : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED7AI Property

IRD

Pca9532InputLED7AI Property

Input (LED7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED7AI { get; }
Public ReadOnly Property InputLED7AI As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED7AI {
    Pca9532TypeInput get ();
}
member InputLED7AI : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED8 Property

IRD

Pca9532InputLED8 Property

Input (LED8)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED8 { get; }
Public ReadOnly Property InputLED8 As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED8 {
    Pca9532TypeInput get ();
}
member InputLED8 : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED8AI Property

IRD

Pca9532InputLED8AI Property

Input (LED8) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED8AI { get; }
Public ReadOnly Property InputLED8AI As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED8AI {
    Pca9532TypeInput get ();
}
member InputLED8AI : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED9 Property

IRD

Pca9532InputLED9 Property

Input (LED9)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED9 { get; }
Public ReadOnly Property InputLED9 As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED9 {
    Pca9532TypeInput get ();
}
member InputLED9 : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.InputLED9AI Property

IRD

Pca9532InputLED9AI Property

Input (LED9) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeInput InputLED9AI { get; }
Public ReadOnly Property InputLED9AI As Pca9532TypeInput
    Get
public:
property Pca9532TypeInput InputLED9AI {
    Pca9532TypeInput get ();
}
member InputLED9AI : Pca9532TypeInput with get

Property Value

Type: Pca9532TypeInput
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED0 Property

IRD

Pca9532LEDSelectorLED0 Property

LED Selector (LED 0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED0 { get; set; }
Public Property LEDSelectorLED0 As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED0 {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED0 : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED0AI Property

IRD

Pca9532LEDSelectorLED0AI Property

LED Selector (LED 0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED0AI { get; set; }
Public Property LEDSelectorLED0AI As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED0AI {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED0AI : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED1 Property

IRD

Pca9532LEDSelectorLED1 Property

LED Selector (LED 1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED1 { get; set; }
Public Property LEDSelectorLED1 As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED1 {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED1 : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED10 Property

IRD

Pca9532LEDSelectorLED10 Property

LED Selector (LED 10)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED10 { get; set; }
Public Property LEDSelectorLED10 As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED10 {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED10 : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED10AI Property

IRD

Pca9532LEDSelectorLED10AI Property

LED Selector (LED 10) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED10AI { get; set; }
Public Property LEDSelectorLED10AI As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED10AI {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED10AI : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED11 Property

IRD

Pca9532LEDSelectorLED11 Property

LED Selector (LED 11)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED11 { get; set; }
Public Property LEDSelectorLED11 As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED11 {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED11 : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED11AI Property

IRD

Pca9532LEDSelectorLED11AI Property

LED Selector (LED 11) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED11AI { get; set; }
Public Property LEDSelectorLED11AI As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED11AI {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED11AI : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED12 Property

IRD

Pca9532LEDSelectorLED12 Property

LED Selector (LED 12)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED12 { get; set; }
Public Property LEDSelectorLED12 As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED12 {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED12 : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED12AI Property

IRD

Pca9532LEDSelectorLED12AI Property

LED Selector (LED 12) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED12AI { get; set; }
Public Property LEDSelectorLED12AI As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED12AI {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED12AI : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED13 Property

IRD

Pca9532LEDSelectorLED13 Property

LED Selector (LED 13)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED13 { get; set; }
Public Property LEDSelectorLED13 As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED13 {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED13 : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED13AI Property

IRD

Pca9532LEDSelectorLED13AI Property

LED Selector (LED 13) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED13AI { get; set; }
Public Property LEDSelectorLED13AI As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED13AI {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED13AI : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED14 Property

IRD

Pca9532LEDSelectorLED14 Property

LED Selector (LED 14)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED14 { get; set; }
Public Property LEDSelectorLED14 As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED14 {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED14 : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED14AI Property

IRD

Pca9532LEDSelectorLED14AI Property

LED Selector (LED 14) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED14AI { get; set; }
Public Property LEDSelectorLED14AI As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED14AI {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED14AI : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED15 Property

IRD

Pca9532LEDSelectorLED15 Property

LED Selector (LED 15)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED15 { get; set; }
Public Property LEDSelectorLED15 As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED15 {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED15 : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED15AI Property

IRD

Pca9532LEDSelectorLED15AI Property

LED Selector (LED 15) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED15AI { get; set; }
Public Property LEDSelectorLED15AI As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED15AI {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED15AI : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED1AI Property

IRD

Pca9532LEDSelectorLED1AI Property

LED Selector (LED 1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED1AI { get; set; }
Public Property LEDSelectorLED1AI As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED1AI {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED1AI : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED2 Property

IRD

Pca9532LEDSelectorLED2 Property

LED Selector (LED 2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED2 { get; set; }
Public Property LEDSelectorLED2 As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED2 {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED2 : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED2AI Property

IRD

Pca9532LEDSelectorLED2AI Property

LED Selector (LED 2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED2AI { get; set; }
Public Property LEDSelectorLED2AI As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED2AI {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED2AI : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED3 Property

IRD

Pca9532LEDSelectorLED3 Property

LED Selector (LED 3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED3 { get; set; }
Public Property LEDSelectorLED3 As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED3 {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED3 : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED3AI Property

IRD

Pca9532LEDSelectorLED3AI Property

LED Selector (LED 3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED3AI { get; set; }
Public Property LEDSelectorLED3AI As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED3AI {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED3AI : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED4 Property

IRD

Pca9532LEDSelectorLED4 Property

LED Selector (LED 4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED4 { get; set; }
Public Property LEDSelectorLED4 As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED4 {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED4 : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED4AI Property

IRD

Pca9532LEDSelectorLED4AI Property

LED Selector (LED 4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED4AI { get; set; }
Public Property LEDSelectorLED4AI As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED4AI {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED4AI : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED5 Property

IRD

Pca9532LEDSelectorLED5 Property

LED Selector (LED 5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED5 { get; set; }
Public Property LEDSelectorLED5 As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED5 {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED5 : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED5AI Property

IRD

Pca9532LEDSelectorLED5AI Property

LED Selector (LED 5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED5AI { get; set; }
Public Property LEDSelectorLED5AI As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED5AI {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED5AI : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED6 Property

IRD

Pca9532LEDSelectorLED6 Property

LED Selector (LED 6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED6 { get; set; }
Public Property LEDSelectorLED6 As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED6 {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED6 : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED6AI Property

IRD

Pca9532LEDSelectorLED6AI Property

LED Selector (LED 6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED6AI { get; set; }
Public Property LEDSelectorLED6AI As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED6AI {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED6AI : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED7 Property

IRD

Pca9532LEDSelectorLED7 Property

LED Selector (LED 7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED7 { get; set; }
Public Property LEDSelectorLED7 As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED7 {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED7 : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED7AI Property

IRD

Pca9532LEDSelectorLED7AI Property

LED Selector (LED 7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED7AI { get; set; }
Public Property LEDSelectorLED7AI As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED7AI {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED7AI : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED8 Property

IRD

Pca9532LEDSelectorLED8 Property

LED Selector (LED 8)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED8 { get; set; }
Public Property LEDSelectorLED8 As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED8 {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED8 : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED8AI Property

IRD

Pca9532LEDSelectorLED8AI Property

LED Selector (LED 8) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED8AI { get; set; }
Public Property LEDSelectorLED8AI As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED8AI {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED8AI : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED9 Property

IRD

Pca9532LEDSelectorLED9 Property

LED Selector (LED 9)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED9 { get; set; }
Public Property LEDSelectorLED9 As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED9 {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED9 : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.LEDSelectorLED9AI Property

IRD

Pca9532LEDSelectorLED9AI Property

LED Selector (LED 9) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9532TypeLedSelector LEDSelectorLED9AI { get; set; }
Public Property LEDSelectorLED9AI As Pca9532TypeLedSelector
    Get
    Set
public:
property Pca9532TypeLedSelector LEDSelectorLED9AI {
    Pca9532TypeLedSelector get ();
    void set (Pca9532TypeLedSelector value);
}
member LEDSelectorLED9AI : Pca9532TypeLedSelector with get, set

Property Value

Type: Pca9532TypeLedSelector
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.PWM0 Property

IRD

Pca9532PWM0 Property

PWM 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM0 { get; set; }
Public Property PWM0 As Byte
    Get
    Set
public:
property unsigned char PWM0 {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.PWM0AI Property

IRD

Pca9532PWM0AI Property

PWM 0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM0AI { get; set; }
Public Property PWM0AI As Byte
    Get
    Set
public:
property unsigned char PWM0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.PWM1 Property

IRD

Pca9532PWM1 Property

PWM 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM1 { get; set; }
Public Property PWM1 As Byte
    Get
    Set
public:
property unsigned char PWM1 {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.PWM1AI Property

IRD

Pca9532PWM1AI Property

PWM 1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM1AI { get; set; }
Public Property PWM1AI As Byte
    Get
    Set
public:
property unsigned char PWM1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532 Methods

The Pca9532 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.Flush Method

IRD

Pca9532Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9532 Class
telos.Ird.NXPSemiconductors Namespace


Pca9532.TypeInput Enumeration

IRD

Pca9532TypeInput Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInput
Public Enumeration TypeInput
public enum class TypeInput
type TypeInput
Members
Member name | Value | Description
High | 1 | High
Low | 0 | Low
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9532.TypeLedSelector Enumeration

IRD

Pca9532TypeLedSelector Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedSelector
Public Enumeration TypeLedSelector
public enum class TypeLedSelector
type TypeLedSelector
Members
Member name | Value | Description
OutputIsSetHiZLEDOff | 0 | Output is set Hi-Z (LED off)
OutputIsSetLOWLEDOn | 1 | Output is set LOW (LED on)
OutputBlinksAtPWM0Rate | 2 | Output blinks at PWM0 rate
OutputBlinksAtPWM1Rate | 3 | Output blinks at PWM1 rate
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9533 Class

NXP Semiconductors: PCA 9533
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9533

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9533
Public Class Pca9533
public ref class Pca9533
type Pca9533 =  class end

The Pca9533 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9533 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FrequencyPrescaler0 | Frequency Prescaler 0
Public property | FrequencyPrescaler0AI | Frequency Prescaler 0 [AI]
Public property | FrequencyPrescaler1 | Frequency Prescaler 1
Public property | FrequencyPrescaler1AI | Frequency Prescaler 1 [AI]
Public property | InputLED0 | Input (LED0)
Public property | InputLED0AI | Input (LED0) [AI]
Public property | InputLED1 | Input (LED1)
Public property | InputLED1AI | Input (LED1) [AI]
Public property | InputLED2 | Input (LED2)
Public property | InputLED2AI | Input (LED2) [AI]
Public property | InputLED3 | Input (LED3)
Public property | InputLED3AI | Input (LED3) [AI]
Public property | LEDSelectorLED0 | LED Selector (LED 0)
Public property | LEDSelectorLED0AI | LED Selector (LED 0) [AI]
Public property | LEDSelectorLED1 | LED Selector (LED 1)
Public property | LEDSelectorLED1AI | LED Selector (LED 1) [AI]
Public property | LEDSelectorLED2 | LED Selector (LED 2)
Public property | LEDSelectorLED2AI | LED Selector (LED 2) [AI]
Public property | LEDSelectorLED3 | LED Selector (LED 3)
Public property | LEDSelectorLED3AI | LED Selector (LED 3) [AI]
Public property | PWM0 | PWM 0
Public property | PWM0AI | PWM 0 [AI]
Public property | PWM1 | PWM 1
Public property | PWM1AI | PWM 1 [AI]
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
4-Bit I2C LED Dimmer
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9533 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9533(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9533(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9533

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533 Properties

The Pca9533 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FrequencyPrescaler0 | Frequency Prescaler 0
Public property | FrequencyPrescaler0AI | Frequency Prescaler 0 [AI]
Public property | FrequencyPrescaler1 | Frequency Prescaler 1
Public property | FrequencyPrescaler1AI | Frequency Prescaler 1 [AI]
Public property | InputLED0 | Input (LED0)
Public property | InputLED0AI | Input (LED0) [AI]
Public property | InputLED1 | Input (LED1)
Public property | InputLED1AI | Input (LED1) [AI]
Public property | InputLED2 | Input (LED2)
Public property | InputLED2AI | Input (LED2) [AI]
Public property | InputLED3 | Input (LED3)
Public property | InputLED3AI | Input (LED3) [AI]
Public property | LEDSelectorLED0 | LED Selector (LED 0)
Public property | LEDSelectorLED0AI | LED Selector (LED 0) [AI]
Public property | LEDSelectorLED1 | LED Selector (LED 1)
Public property | LEDSelectorLED1AI | LED Selector (LED 1) [AI]
Public property | LEDSelectorLED2 | LED Selector (LED 2)
Public property | LEDSelectorLED2AI | LED Selector (LED 2) [AI]
Public property | LEDSelectorLED3 | LED Selector (LED 3)
Public property | LEDSelectorLED3AI | LED Selector (LED 3) [AI]
Public property | PWM0 | PWM 0
Public property | PWM0AI | PWM 0 [AI]
Public property | PWM1 | PWM 1
Public property | PWM1AI | PWM 1 [AI]
Top
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.AutoFlush Property

IRD

Pca9533AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.FrequencyPrescaler0 Property

IRD

Pca9533FrequencyPrescaler0 Property

Frequency Prescaler 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler0 { get; set; }
Public Property FrequencyPrescaler0 As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler0 {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.FrequencyPrescaler0AI Property

IRD

Pca9533FrequencyPrescaler0AI Property

Frequency Prescaler 0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler0AI { get; set; }
Public Property FrequencyPrescaler0AI As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.FrequencyPrescaler1 Property

IRD

Pca9533FrequencyPrescaler1 Property

Frequency Prescaler 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler1 { get; set; }
Public Property FrequencyPrescaler1 As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler1 {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.FrequencyPrescaler1AI Property

IRD

Pca9533FrequencyPrescaler1AI Property

Frequency Prescaler 1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler1AI { get; set; }
Public Property FrequencyPrescaler1AI As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.InputLED0 Property

IRD

Pca9533InputLED0 Property

Input (LED0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9533TypeInput InputLED0 { get; }
Public ReadOnly Property InputLED0 As Pca9533TypeInput
    Get
public:
property Pca9533TypeInput InputLED0 {
    Pca9533TypeInput get ();
}
member InputLED0 : Pca9533TypeInput with get

Property Value

Type: Pca9533TypeInput
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.InputLED0AI Property

IRD

Pca9533InputLED0AI Property

Input (LED0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9533TypeInput InputLED0AI { get; }
Public ReadOnly Property InputLED0AI As Pca9533TypeInput
    Get
public:
property Pca9533TypeInput InputLED0AI {
    Pca9533TypeInput get ();
}
member InputLED0AI : Pca9533TypeInput with get

Property Value

Type: Pca9533TypeInput
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.InputLED1 Property

IRD

Pca9533InputLED1 Property

Input (LED1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9533TypeInput InputLED1 { get; }
Public ReadOnly Property InputLED1 As Pca9533TypeInput
    Get
public:
property Pca9533TypeInput InputLED1 {
    Pca9533TypeInput get ();
}
member InputLED1 : Pca9533TypeInput with get

Property Value

Type: Pca9533TypeInput
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.InputLED1AI Property

IRD

Pca9533InputLED1AI Property

Input (LED1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9533TypeInput InputLED1AI { get; }
Public ReadOnly Property InputLED1AI As Pca9533TypeInput
    Get
public:
property Pca9533TypeInput InputLED1AI {
    Pca9533TypeInput get ();
}
member InputLED1AI : Pca9533TypeInput with get

Property Value

Type: Pca9533TypeInput
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.InputLED2 Property

IRD

Pca9533InputLED2 Property

Input (LED2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9533TypeInput InputLED2 { get; }
Public ReadOnly Property InputLED2 As Pca9533TypeInput
    Get
public:
property Pca9533TypeInput InputLED2 {
    Pca9533TypeInput get ();
}
member InputLED2 : Pca9533TypeInput with get

Property Value

Type: Pca9533TypeInput
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.InputLED2AI Property

IRD

Pca9533InputLED2AI Property

Input (LED2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9533TypeInput InputLED2AI { get; }
Public ReadOnly Property InputLED2AI As Pca9533TypeInput
    Get
public:
property Pca9533TypeInput InputLED2AI {
    Pca9533TypeInput get ();
}
member InputLED2AI : Pca9533TypeInput with get

Property Value

Type: Pca9533TypeInput
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.InputLED3 Property

IRD

Pca9533InputLED3 Property

Input (LED3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9533TypeInput InputLED3 { get; }
Public ReadOnly Property InputLED3 As Pca9533TypeInput
    Get
public:
property Pca9533TypeInput InputLED3 {
    Pca9533TypeInput get ();
}
member InputLED3 : Pca9533TypeInput with get

Property Value

Type: Pca9533TypeInput
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.InputLED3AI Property

IRD

Pca9533InputLED3AI Property

Input (LED3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9533TypeInput InputLED3AI { get; }
Public ReadOnly Property InputLED3AI As Pca9533TypeInput
    Get
public:
property Pca9533TypeInput InputLED3AI {
    Pca9533TypeInput get ();
}
member InputLED3AI : Pca9533TypeInput with get

Property Value

Type: Pca9533TypeInput
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.LEDSelectorLED0 Property

IRD

Pca9533LEDSelectorLED0 Property

LED Selector (LED 0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9533TypeLedSelector LEDSelectorLED0 { get; set; }
Public Property LEDSelectorLED0 As Pca9533TypeLedSelector
    Get
    Set
public:
property Pca9533TypeLedSelector LEDSelectorLED0 {
    Pca9533TypeLedSelector get ();
    void set (Pca9533TypeLedSelector value);
}
member LEDSelectorLED0 : Pca9533TypeLedSelector with get, set

Property Value

Type: Pca9533TypeLedSelector
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.LEDSelectorLED0AI Property

IRD

Pca9533LEDSelectorLED0AI Property

LED Selector (LED 0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9533TypeLedSelector LEDSelectorLED0AI { get; set; }
Public Property LEDSelectorLED0AI As Pca9533TypeLedSelector
    Get
    Set
public:
property Pca9533TypeLedSelector LEDSelectorLED0AI {
    Pca9533TypeLedSelector get ();
    void set (Pca9533TypeLedSelector value);
}
member LEDSelectorLED0AI : Pca9533TypeLedSelector with get, set

Property Value

Type: Pca9533TypeLedSelector
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.LEDSelectorLED1 Property

IRD

Pca9533LEDSelectorLED1 Property

LED Selector (LED 1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9533TypeLedSelector LEDSelectorLED1 { get; set; }
Public Property LEDSelectorLED1 As Pca9533TypeLedSelector
    Get
    Set
public:
property Pca9533TypeLedSelector LEDSelectorLED1 {
    Pca9533TypeLedSelector get ();
    void set (Pca9533TypeLedSelector value);
}
member LEDSelectorLED1 : Pca9533TypeLedSelector with get, set

Property Value

Type: Pca9533TypeLedSelector
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.LEDSelectorLED1AI Property

IRD

Pca9533LEDSelectorLED1AI Property

LED Selector (LED 1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9533TypeLedSelector LEDSelectorLED1AI { get; set; }
Public Property LEDSelectorLED1AI As Pca9533TypeLedSelector
    Get
    Set
public:
property Pca9533TypeLedSelector LEDSelectorLED1AI {
    Pca9533TypeLedSelector get ();
    void set (Pca9533TypeLedSelector value);
}
member LEDSelectorLED1AI : Pca9533TypeLedSelector with get, set

Property Value

Type: Pca9533TypeLedSelector
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.LEDSelectorLED2 Property

IRD

Pca9533LEDSelectorLED2 Property

LED Selector (LED 2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9533TypeLedSelector LEDSelectorLED2 { get; set; }
Public Property LEDSelectorLED2 As Pca9533TypeLedSelector
    Get
    Set
public:
property Pca9533TypeLedSelector LEDSelectorLED2 {
    Pca9533TypeLedSelector get ();
    void set (Pca9533TypeLedSelector value);
}
member LEDSelectorLED2 : Pca9533TypeLedSelector with get, set

Property Value

Type: Pca9533TypeLedSelector
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.LEDSelectorLED2AI Property

IRD

Pca9533LEDSelectorLED2AI Property

LED Selector (LED 2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9533TypeLedSelector LEDSelectorLED2AI { get; set; }
Public Property LEDSelectorLED2AI As Pca9533TypeLedSelector
    Get
    Set
public:
property Pca9533TypeLedSelector LEDSelectorLED2AI {
    Pca9533TypeLedSelector get ();
    void set (Pca9533TypeLedSelector value);
}
member LEDSelectorLED2AI : Pca9533TypeLedSelector with get, set

Property Value

Type: Pca9533TypeLedSelector
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.LEDSelectorLED3 Property

IRD

Pca9533LEDSelectorLED3 Property

LED Selector (LED 3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9533TypeLedSelector LEDSelectorLED3 { get; set; }
Public Property LEDSelectorLED3 As Pca9533TypeLedSelector
    Get
    Set
public:
property Pca9533TypeLedSelector LEDSelectorLED3 {
    Pca9533TypeLedSelector get ();
    void set (Pca9533TypeLedSelector value);
}
member LEDSelectorLED3 : Pca9533TypeLedSelector with get, set

Property Value

Type: Pca9533TypeLedSelector
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.LEDSelectorLED3AI Property

IRD

Pca9533LEDSelectorLED3AI Property

LED Selector (LED 3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9533TypeLedSelector LEDSelectorLED3AI { get; set; }
Public Property LEDSelectorLED3AI As Pca9533TypeLedSelector
    Get
    Set
public:
property Pca9533TypeLedSelector LEDSelectorLED3AI {
    Pca9533TypeLedSelector get ();
    void set (Pca9533TypeLedSelector value);
}
member LEDSelectorLED3AI : Pca9533TypeLedSelector with get, set

Property Value

Type: Pca9533TypeLedSelector
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.PWM0 Property

IRD

Pca9533PWM0 Property

PWM 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM0 { get; set; }
Public Property PWM0 As Byte
    Get
    Set
public:
property unsigned char PWM0 {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.PWM0AI Property

IRD

Pca9533PWM0AI Property

PWM 0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM0AI { get; set; }
Public Property PWM0AI As Byte
    Get
    Set
public:
property unsigned char PWM0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.PWM1 Property

IRD

Pca9533PWM1 Property

PWM 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM1 { get; set; }
Public Property PWM1 As Byte
    Get
    Set
public:
property unsigned char PWM1 {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.PWM1AI Property

IRD

Pca9533PWM1AI Property

PWM 1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM1AI { get; set; }
Public Property PWM1AI As Byte
    Get
    Set
public:
property unsigned char PWM1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533 Methods

The Pca9533 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.Flush Method

IRD

Pca9533Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9533 Class
telos.Ird.NXPSemiconductors Namespace


Pca9533.TypeInput Enumeration

IRD

Pca9533TypeInput Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInput
Public Enumeration TypeInput
public enum class TypeInput
type TypeInput
Members
Member name | Value | Description
High | 1 | High
Low | 0 | Low
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9533.TypeLedSelector Enumeration

IRD

Pca9533TypeLedSelector Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedSelector
Public Enumeration TypeLedSelector
public enum class TypeLedSelector
type TypeLedSelector
Members
Member name | Value | Description
OutputIsSetHiZLEDOff | 0 | Output is set Hi-Z (LED off)
OutputIsSetLOWLEDOn | 1 | Output is set LOW (LED on)
OutputBlinksAtPWM0Rate | 2 | Output blinks at PWM0 rate
OutputBlinksAtPWM1Rate | 3 | Output blinks at PWM1 rate
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9534 Class

NXP Semiconductors: PCA 9534
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9534

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9534
Public Class Pca9534
public ref class Pca9534
type Pca9534 =  class end

The Pca9534 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9534 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationIO0 | Configuration (IO0)
Public property | ConfigurationIO1 | Configuration (IO1)
Public property | ConfigurationIO2 | Configuration (IO2)
Public property | ConfigurationIO3 | Configuration (IO3)
Public property | ConfigurationIO4 | Configuration (IO4)
Public property | ConfigurationIO5 | Configuration (IO5)
Public property | ConfigurationIO6 | Configuration (IO6)
Public property | ConfigurationIO7 | Configuration (IO7)
Public property | InputPortIO0 | Input Port (IO0)
Public property | InputPortIO1 | Input Port (IO1)
Public property | InputPortIO2 | Input Port (IO2)
Public property | InputPortIO3 | Input Port (IO3)
Public property | InputPortIO4 | Input Port (IO4)
Public property | InputPortIO5 | Input Port (IO5)
Public property | InputPortIO6 | Input Port (IO6)
Public property | InputPortIO7 | Input Port (IO7)
Public property | OutputPortIO0 | Output Port (IO0)
Public property | OutputPortIO1 | Output Port (IO1)
Public property | OutputPortIO2 | Output Port (IO2)
Public property | OutputPortIO3 | Output Port (IO3)
Public property | OutputPortIO4 | Output Port (IO4)
Public property | OutputPortIO5 | Output Port (IO5)
Public property | OutputPortIO6 | Output Port (IO6)
Public property | OutputPortIO7 | Output Port (IO7)
Public property | PolarityInversionIO0 | Polarity Inversion (IO0)
Public property | PolarityInversionIO1 | Polarity Inversion (IO1)
Public property | PolarityInversionIO2 | Polarity Inversion (IO2)
Public property | PolarityInversionIO3 | Polarity Inversion (IO3)
Public property | PolarityInversionIO4 | Polarity Inversion (IO4)
Public property | PolarityInversionIO5 | Polarity Inversion (IO5)
Public property | PolarityInversionIO6 | Polarity Inversion (IO6)
Public property | PolarityInversionIO7 | Polarity Inversion (IO7)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
8-Bit I2C-Bus And SMBus Low Power I/O Port With Interrupt
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9534 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9534(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9534

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534 Properties

The Pca9534 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationIO0 | Configuration (IO0)
Public property | ConfigurationIO1 | Configuration (IO1)
Public property | ConfigurationIO2 | Configuration (IO2)
Public property | ConfigurationIO3 | Configuration (IO3)
Public property | ConfigurationIO4 | Configuration (IO4)
Public property | ConfigurationIO5 | Configuration (IO5)
Public property | ConfigurationIO6 | Configuration (IO6)
Public property | ConfigurationIO7 | Configuration (IO7)
Public property | InputPortIO0 | Input Port (IO0)
Public property | InputPortIO1 | Input Port (IO1)
Public property | InputPortIO2 | Input Port (IO2)
Public property | InputPortIO3 | Input Port (IO3)
Public property | InputPortIO4 | Input Port (IO4)
Public property | InputPortIO5 | Input Port (IO5)
Public property | InputPortIO6 | Input Port (IO6)
Public property | InputPortIO7 | Input Port (IO7)
Public property | OutputPortIO0 | Output Port (IO0)
Public property | OutputPortIO1 | Output Port (IO1)
Public property | OutputPortIO2 | Output Port (IO2)
Public property | OutputPortIO3 | Output Port (IO3)
Public property | OutputPortIO4 | Output Port (IO4)
Public property | OutputPortIO5 | Output Port (IO5)
Public property | OutputPortIO6 | Output Port (IO6)
Public property | OutputPortIO7 | Output Port (IO7)
Public property | PolarityInversionIO0 | Polarity Inversion (IO0)
Public property | PolarityInversionIO1 | Polarity Inversion (IO1)
Public property | PolarityInversionIO2 | Polarity Inversion (IO2)
Public property | PolarityInversionIO3 | Polarity Inversion (IO3)
Public property | PolarityInversionIO4 | Polarity Inversion (IO4)
Public property | PolarityInversionIO5 | Polarity Inversion (IO5)
Public property | PolarityInversionIO6 | Polarity Inversion (IO6)
Public property | PolarityInversionIO7 | Polarity Inversion (IO7)
Top
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.AutoFlush Property

IRD

Pca9534AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.ConfigurationIO0 Property

IRD

Pca9534ConfigurationIO0 Property

Configuration (IO0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeConfiguration ConfigurationIO0 { get; set; }
Public Property ConfigurationIO0 As Pca9534TypeConfiguration
    Get
    Set
public:
property Pca9534TypeConfiguration ConfigurationIO0 {
    Pca9534TypeConfiguration get ();
    void set (Pca9534TypeConfiguration value);
}
member ConfigurationIO0 : Pca9534TypeConfiguration with get, set

Property Value

Type: Pca9534TypeConfiguration
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.ConfigurationIO1 Property

IRD

Pca9534ConfigurationIO1 Property

Configuration (IO1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeConfiguration ConfigurationIO1 { get; set; }
Public Property ConfigurationIO1 As Pca9534TypeConfiguration
    Get
    Set
public:
property Pca9534TypeConfiguration ConfigurationIO1 {
    Pca9534TypeConfiguration get ();
    void set (Pca9534TypeConfiguration value);
}
member ConfigurationIO1 : Pca9534TypeConfiguration with get, set

Property Value

Type: Pca9534TypeConfiguration
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.ConfigurationIO2 Property

IRD

Pca9534ConfigurationIO2 Property

Configuration (IO2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeConfiguration ConfigurationIO2 { get; set; }
Public Property ConfigurationIO2 As Pca9534TypeConfiguration
    Get
    Set
public:
property Pca9534TypeConfiguration ConfigurationIO2 {
    Pca9534TypeConfiguration get ();
    void set (Pca9534TypeConfiguration value);
}
member ConfigurationIO2 : Pca9534TypeConfiguration with get, set

Property Value

Type: Pca9534TypeConfiguration
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.ConfigurationIO3 Property

IRD

Pca9534ConfigurationIO3 Property

Configuration (IO3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeConfiguration ConfigurationIO3 { get; set; }
Public Property ConfigurationIO3 As Pca9534TypeConfiguration
    Get
    Set
public:
property Pca9534TypeConfiguration ConfigurationIO3 {
    Pca9534TypeConfiguration get ();
    void set (Pca9534TypeConfiguration value);
}
member ConfigurationIO3 : Pca9534TypeConfiguration with get, set

Property Value

Type: Pca9534TypeConfiguration
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.ConfigurationIO4 Property

IRD

Pca9534ConfigurationIO4 Property

Configuration (IO4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeConfiguration ConfigurationIO4 { get; set; }
Public Property ConfigurationIO4 As Pca9534TypeConfiguration
    Get
    Set
public:
property Pca9534TypeConfiguration ConfigurationIO4 {
    Pca9534TypeConfiguration get ();
    void set (Pca9534TypeConfiguration value);
}
member ConfigurationIO4 : Pca9534TypeConfiguration with get, set

Property Value

Type: Pca9534TypeConfiguration
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.ConfigurationIO5 Property

IRD

Pca9534ConfigurationIO5 Property

Configuration (IO5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeConfiguration ConfigurationIO5 { get; set; }
Public Property ConfigurationIO5 As Pca9534TypeConfiguration
    Get
    Set
public:
property Pca9534TypeConfiguration ConfigurationIO5 {
    Pca9534TypeConfiguration get ();
    void set (Pca9534TypeConfiguration value);
}
member ConfigurationIO5 : Pca9534TypeConfiguration with get, set

Property Value

Type: Pca9534TypeConfiguration
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.ConfigurationIO6 Property

IRD

Pca9534ConfigurationIO6 Property

Configuration (IO6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeConfiguration ConfigurationIO6 { get; set; }
Public Property ConfigurationIO6 As Pca9534TypeConfiguration
    Get
    Set
public:
property Pca9534TypeConfiguration ConfigurationIO6 {
    Pca9534TypeConfiguration get ();
    void set (Pca9534TypeConfiguration value);
}
member ConfigurationIO6 : Pca9534TypeConfiguration with get, set

Property Value

Type: Pca9534TypeConfiguration
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.ConfigurationIO7 Property

IRD

Pca9534ConfigurationIO7 Property

Configuration (IO7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeConfiguration ConfigurationIO7 { get; set; }
Public Property ConfigurationIO7 As Pca9534TypeConfiguration
    Get
    Set
public:
property Pca9534TypeConfiguration ConfigurationIO7 {
    Pca9534TypeConfiguration get ();
    void set (Pca9534TypeConfiguration value);
}
member ConfigurationIO7 : Pca9534TypeConfiguration with get, set

Property Value

Type: Pca9534TypeConfiguration
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.InputPortIO0 Property

IRD

Pca9534InputPortIO0 Property

Input Port (IO0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO0 { get; }
Public ReadOnly Property InputPortIO0 As Byte
    Get
public:
property unsigned char InputPortIO0 {
    unsigned char get ();
}
member InputPortIO0 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.InputPortIO1 Property

IRD

Pca9534InputPortIO1 Property

Input Port (IO1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO1 { get; }
Public ReadOnly Property InputPortIO1 As Byte
    Get
public:
property unsigned char InputPortIO1 {
    unsigned char get ();
}
member InputPortIO1 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.InputPortIO2 Property

IRD

Pca9534InputPortIO2 Property

Input Port (IO2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO2 { get; }
Public ReadOnly Property InputPortIO2 As Byte
    Get
public:
property unsigned char InputPortIO2 {
    unsigned char get ();
}
member InputPortIO2 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.InputPortIO3 Property

IRD

Pca9534InputPortIO3 Property

Input Port (IO3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO3 { get; }
Public ReadOnly Property InputPortIO3 As Byte
    Get
public:
property unsigned char InputPortIO3 {
    unsigned char get ();
}
member InputPortIO3 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.InputPortIO4 Property

IRD

Pca9534InputPortIO4 Property

Input Port (IO4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO4 { get; }
Public ReadOnly Property InputPortIO4 As Byte
    Get
public:
property unsigned char InputPortIO4 {
    unsigned char get ();
}
member InputPortIO4 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.InputPortIO5 Property

IRD

Pca9534InputPortIO5 Property

Input Port (IO5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO5 { get; }
Public ReadOnly Property InputPortIO5 As Byte
    Get
public:
property unsigned char InputPortIO5 {
    unsigned char get ();
}
member InputPortIO5 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.InputPortIO6 Property

IRD

Pca9534InputPortIO6 Property

Input Port (IO6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO6 { get; }
Public ReadOnly Property InputPortIO6 As Byte
    Get
public:
property unsigned char InputPortIO6 {
    unsigned char get ();
}
member InputPortIO6 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.InputPortIO7 Property

IRD

Pca9534InputPortIO7 Property

Input Port (IO7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO7 { get; }
Public ReadOnly Property InputPortIO7 As Byte
    Get
public:
property unsigned char InputPortIO7 {
    unsigned char get ();
}
member InputPortIO7 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.OutputPortIO0 Property

IRD

Pca9534OutputPortIO0 Property

Output Port (IO0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO0 { get; set; }
Public Property OutputPortIO0 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO0 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.OutputPortIO1 Property

IRD

Pca9534OutputPortIO1 Property

Output Port (IO1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO1 { get; set; }
Public Property OutputPortIO1 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO1 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.OutputPortIO2 Property

IRD

Pca9534OutputPortIO2 Property

Output Port (IO2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO2 { get; set; }
Public Property OutputPortIO2 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO2 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.OutputPortIO3 Property

IRD

Pca9534OutputPortIO3 Property

Output Port (IO3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO3 { get; set; }
Public Property OutputPortIO3 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO3 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.OutputPortIO4 Property

IRD

Pca9534OutputPortIO4 Property

Output Port (IO4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO4 { get; set; }
Public Property OutputPortIO4 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO4 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.OutputPortIO5 Property

IRD

Pca9534OutputPortIO5 Property

Output Port (IO5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO5 { get; set; }
Public Property OutputPortIO5 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO5 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.OutputPortIO6 Property

IRD

Pca9534OutputPortIO6 Property

Output Port (IO6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO6 { get; set; }
Public Property OutputPortIO6 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO6 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.OutputPortIO7 Property

IRD

Pca9534OutputPortIO7 Property

Output Port (IO7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO7 { get; set; }
Public Property OutputPortIO7 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO7 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.PolarityInversionIO0 Property

IRD

Pca9534PolarityInversionIO0 Property

Polarity Inversion (IO0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypePolarityInversion PolarityInversionIO0 { get; set; }
Public Property PolarityInversionIO0 As Pca9534TypePolarityInversion
    Get
    Set
public:
property Pca9534TypePolarityInversion PolarityInversionIO0 {
    Pca9534TypePolarityInversion get ();
    void set (Pca9534TypePolarityInversion value);
}
member PolarityInversionIO0 : Pca9534TypePolarityInversion with get, set

Property Value

Type: Pca9534TypePolarityInversion
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.PolarityInversionIO1 Property

IRD

Pca9534PolarityInversionIO1 Property

Polarity Inversion (IO1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypePolarityInversion PolarityInversionIO1 { get; set; }
Public Property PolarityInversionIO1 As Pca9534TypePolarityInversion
    Get
    Set
public:
property Pca9534TypePolarityInversion PolarityInversionIO1 {
    Pca9534TypePolarityInversion get ();
    void set (Pca9534TypePolarityInversion value);
}
member PolarityInversionIO1 : Pca9534TypePolarityInversion with get, set

Property Value

Type: Pca9534TypePolarityInversion
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.PolarityInversionIO2 Property

IRD

Pca9534PolarityInversionIO2 Property

Polarity Inversion (IO2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypePolarityInversion PolarityInversionIO2 { get; set; }
Public Property PolarityInversionIO2 As Pca9534TypePolarityInversion
    Get
    Set
public:
property Pca9534TypePolarityInversion PolarityInversionIO2 {
    Pca9534TypePolarityInversion get ();
    void set (Pca9534TypePolarityInversion value);
}
member PolarityInversionIO2 : Pca9534TypePolarityInversion with get, set

Property Value

Type: Pca9534TypePolarityInversion
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.PolarityInversionIO3 Property

IRD

Pca9534PolarityInversionIO3 Property

Polarity Inversion (IO3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypePolarityInversion PolarityInversionIO3 { get; set; }
Public Property PolarityInversionIO3 As Pca9534TypePolarityInversion
    Get
    Set
public:
property Pca9534TypePolarityInversion PolarityInversionIO3 {
    Pca9534TypePolarityInversion get ();
    void set (Pca9534TypePolarityInversion value);
}
member PolarityInversionIO3 : Pca9534TypePolarityInversion with get, set

Property Value

Type: Pca9534TypePolarityInversion
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.PolarityInversionIO4 Property

IRD

Pca9534PolarityInversionIO4 Property

Polarity Inversion (IO4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypePolarityInversion PolarityInversionIO4 { get; set; }
Public Property PolarityInversionIO4 As Pca9534TypePolarityInversion
    Get
    Set
public:
property Pca9534TypePolarityInversion PolarityInversionIO4 {
    Pca9534TypePolarityInversion get ();
    void set (Pca9534TypePolarityInversion value);
}
member PolarityInversionIO4 : Pca9534TypePolarityInversion with get, set

Property Value

Type: Pca9534TypePolarityInversion
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.PolarityInversionIO5 Property

IRD

Pca9534PolarityInversionIO5 Property

Polarity Inversion (IO5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypePolarityInversion PolarityInversionIO5 { get; set; }
Public Property PolarityInversionIO5 As Pca9534TypePolarityInversion
    Get
    Set
public:
property Pca9534TypePolarityInversion PolarityInversionIO5 {
    Pca9534TypePolarityInversion get ();
    void set (Pca9534TypePolarityInversion value);
}
member PolarityInversionIO5 : Pca9534TypePolarityInversion with get, set

Property Value

Type: Pca9534TypePolarityInversion
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.PolarityInversionIO6 Property

IRD

Pca9534PolarityInversionIO6 Property

Polarity Inversion (IO6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypePolarityInversion PolarityInversionIO6 { get; set; }
Public Property PolarityInversionIO6 As Pca9534TypePolarityInversion
    Get
    Set
public:
property Pca9534TypePolarityInversion PolarityInversionIO6 {
    Pca9534TypePolarityInversion get ();
    void set (Pca9534TypePolarityInversion value);
}
member PolarityInversionIO6 : Pca9534TypePolarityInversion with get, set

Property Value

Type: Pca9534TypePolarityInversion
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.PolarityInversionIO7 Property

IRD

Pca9534PolarityInversionIO7 Property

Polarity Inversion (IO7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypePolarityInversion PolarityInversionIO7 { get; set; }
Public Property PolarityInversionIO7 As Pca9534TypePolarityInversion
    Get
    Set
public:
property Pca9534TypePolarityInversion PolarityInversionIO7 {
    Pca9534TypePolarityInversion get ();
    void set (Pca9534TypePolarityInversion value);
}
member PolarityInversionIO7 : Pca9534TypePolarityInversion with get, set

Property Value

Type: Pca9534TypePolarityInversion
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534 Methods

The Pca9534 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.Flush Method

IRD

Pca9534Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9534 Class
telos.Ird.NXPSemiconductors Namespace


Pca9534.TypeConfiguration Enumeration

IRD

Pca9534TypeConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Output | 0 | Output
Input | 1 | Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9534.TypePolarityInversion Enumeration

IRD

Pca9534TypePolarityInversion Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarityInversion
Public Enumeration TypePolarityInversion
public enum class TypePolarityInversion
type TypePolarityInversion
Members
Member name | Value | Description
Retained | 0 | Retained
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9535 Class

NXP Semiconductors: PCA 9535
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9535

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9535
Public Class Pca9535
public ref class Pca9535
type Pca9535 =  class end

The Pca9535 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9535 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationIO00 | Configuration (IO0_0)
Public property | ConfigurationIO01 | Configuration (IO0_1)
Public property | ConfigurationIO02 | Configuration (IO0_2)
Public property | ConfigurationIO03 | Configuration (IO0_3)
Public property | ConfigurationIO04 | Configuration (IO0_4)
Public property | ConfigurationIO05 | Configuration (IO0_5)
Public property | ConfigurationIO06 | Configuration (IO0_6)
Public property | ConfigurationIO07 | Configuration (IO0_7)
Public property | ConfigurationIO10 | Configuration (IO1_0)
Public property | ConfigurationIO11 | Configuration (IO1_1)
Public property | ConfigurationIO12 | Configuration (IO1_2)
Public property | ConfigurationIO13 | Configuration (IO1_3)
Public property | ConfigurationIO14 | Configuration (IO1_4)
Public property | ConfigurationIO15 | Configuration (IO1_5)
Public property | ConfigurationIO16 | Configuration (IO1_6)
Public property | ConfigurationIO17 | Configuration (IO1_7)
Public property | InputPortIO00 | Input Port (IO0_0)
Public property | InputPortIO01 | Input Port (IO0_1)
Public property | InputPortIO02 | Input Port (IO0_2)
Public property | InputPortIO03 | Input Port (IO0_3)
Public property | InputPortIO04 | Input Port (IO0_4)
Public property | InputPortIO05 | Input Port (IO0_5)
Public property | InputPortIO06 | Input Port (IO0_6)
Public property | InputPortIO07 | Input Port (IO0_7)
Public property | InputPortIO10 | Input Port (IO1_0)
Public property | InputPortIO11 | Input Port (IO1_1)
Public property | InputPortIO12 | Input Port (IO1_2)
Public property | InputPortIO13 | Input Port (IO1_3)
Public property | InputPortIO14 | Input Port (IO1_4)
Public property | InputPortIO15 | Input Port (IO1_5)
Public property | InputPortIO16 | Input Port (IO1_6)
Public property | InputPortIO17 | Input Port (IO1_7)
Public property | OutputPortIO00 | Output Port (IO0_0)
Public property | OutputPortIO01 | Output Port (IO0_1)
Public property | OutputPortIO02 | Output Port (IO0_2)
Public property | OutputPortIO03 | Output Port (IO0_3)
Public property | OutputPortIO04 | Output Port (IO0_4)
Public property | OutputPortIO05 | Output Port (IO0_5)
Public property | OutputPortIO06 | Output Port (IO0_6)
Public property | OutputPortIO07 | Output Port (IO0_7)
Public property | OutputPortIO10 | Output Port (IO1_0)
Public property | OutputPortIO11 | Output Port (IO1_1)
Public property | OutputPortIO12 | Output Port (IO1_2)
Public property | OutputPortIO13 | Output Port (IO1_3)
Public property | OutputPortIO14 | Output Port (IO1_4)
Public property | OutputPortIO15 | Output Port (IO1_5)
Public property | OutputPortIO16 | Output Port (IO1_6)
Public property | OutputPortIO17 | Output Port (IO1_7)
Public property | PolarityInversionIO00 | Polarity Inversion (IO0_0)
Public property | PolarityInversionIO01 | Polarity Inversion (IO0_1)
Public property | PolarityInversionIO02 | Polarity Inversion (IO0_2)
Public property | PolarityInversionIO03 | Polarity Inversion (IO0_3)
Public property | PolarityInversionIO04 | Polarity Inversion (IO0_4)
Public property | PolarityInversionIO05 | Polarity Inversion (IO0_5)
Public property | PolarityInversionIO06 | Polarity Inversion (IO0_6)
Public property | PolarityInversionIO07 | Polarity Inversion (IO0_7)
Public property | PolarityInversionIO10 | Polarity Inversion (IO1_0)
Public property | PolarityInversionIO11 | Polarity Inversion (IO1_1)
Public property | PolarityInversionIO12 | Polarity Inversion (IO1_2)
Public property | PolarityInversionIO13 | Polarity Inversion (IO1_3)
Public property | PolarityInversionIO14 | Polarity Inversion (IO1_4)
Public property | PolarityInversionIO15 | Polarity Inversion (IO1_5)
Public property | PolarityInversionIO16 | Polarity Inversion (IO1_6)
Public property | PolarityInversionIO17 | Polarity Inversion (IO1_7)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
16-Bit I2C-Bus And SMBus, Low Power I/O Port With Interrupt
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9535 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9535(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9535

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535 Properties

The Pca9535 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationIO00 | Configuration (IO0_0)
Public property | ConfigurationIO01 | Configuration (IO0_1)
Public property | ConfigurationIO02 | Configuration (IO0_2)
Public property | ConfigurationIO03 | Configuration (IO0_3)
Public property | ConfigurationIO04 | Configuration (IO0_4)
Public property | ConfigurationIO05 | Configuration (IO0_5)
Public property | ConfigurationIO06 | Configuration (IO0_6)
Public property | ConfigurationIO07 | Configuration (IO0_7)
Public property | ConfigurationIO10 | Configuration (IO1_0)
Public property | ConfigurationIO11 | Configuration (IO1_1)
Public property | ConfigurationIO12 | Configuration (IO1_2)
Public property | ConfigurationIO13 | Configuration (IO1_3)
Public property | ConfigurationIO14 | Configuration (IO1_4)
Public property | ConfigurationIO15 | Configuration (IO1_5)
Public property | ConfigurationIO16 | Configuration (IO1_6)
Public property | ConfigurationIO17 | Configuration (IO1_7)
Public property | InputPortIO00 | Input Port (IO0_0)
Public property | InputPortIO01 | Input Port (IO0_1)
Public property | InputPortIO02 | Input Port (IO0_2)
Public property | InputPortIO03 | Input Port (IO0_3)
Public property | InputPortIO04 | Input Port (IO0_4)
Public property | InputPortIO05 | Input Port (IO0_5)
Public property | InputPortIO06 | Input Port (IO0_6)
Public property | InputPortIO07 | Input Port (IO0_7)
Public property | InputPortIO10 | Input Port (IO1_0)
Public property | InputPortIO11 | Input Port (IO1_1)
Public property | InputPortIO12 | Input Port (IO1_2)
Public property | InputPortIO13 | Input Port (IO1_3)
Public property | InputPortIO14 | Input Port (IO1_4)
Public property | InputPortIO15 | Input Port (IO1_5)
Public property | InputPortIO16 | Input Port (IO1_6)
Public property | InputPortIO17 | Input Port (IO1_7)
Public property | OutputPortIO00 | Output Port (IO0_0)
Public property | OutputPortIO01 | Output Port (IO0_1)
Public property | OutputPortIO02 | Output Port (IO0_2)
Public property | OutputPortIO03 | Output Port (IO0_3)
Public property | OutputPortIO04 | Output Port (IO0_4)
Public property | OutputPortIO05 | Output Port (IO0_5)
Public property | OutputPortIO06 | Output Port (IO0_6)
Public property | OutputPortIO07 | Output Port (IO0_7)
Public property | OutputPortIO10 | Output Port (IO1_0)
Public property | OutputPortIO11 | Output Port (IO1_1)
Public property | OutputPortIO12 | Output Port (IO1_2)
Public property | OutputPortIO13 | Output Port (IO1_3)
Public property | OutputPortIO14 | Output Port (IO1_4)
Public property | OutputPortIO15 | Output Port (IO1_5)
Public property | OutputPortIO16 | Output Port (IO1_6)
Public property | OutputPortIO17 | Output Port (IO1_7)
Public property | PolarityInversionIO00 | Polarity Inversion (IO0_0)
Public property | PolarityInversionIO01 | Polarity Inversion (IO0_1)
Public property | PolarityInversionIO02 | Polarity Inversion (IO0_2)
Public property | PolarityInversionIO03 | Polarity Inversion (IO0_3)
Public property | PolarityInversionIO04 | Polarity Inversion (IO0_4)
Public property | PolarityInversionIO05 | Polarity Inversion (IO0_5)
Public property | PolarityInversionIO06 | Polarity Inversion (IO0_6)
Public property | PolarityInversionIO07 | Polarity Inversion (IO0_7)
Public property | PolarityInversionIO10 | Polarity Inversion (IO1_0)
Public property | PolarityInversionIO11 | Polarity Inversion (IO1_1)
Public property | PolarityInversionIO12 | Polarity Inversion (IO1_2)
Public property | PolarityInversionIO13 | Polarity Inversion (IO1_3)
Public property | PolarityInversionIO14 | Polarity Inversion (IO1_4)
Public property | PolarityInversionIO15 | Polarity Inversion (IO1_5)
Public property | PolarityInversionIO16 | Polarity Inversion (IO1_6)
Public property | PolarityInversionIO17 | Polarity Inversion (IO1_7)
Top
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.AutoFlush Property

IRD

Pca9535AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.ConfigurationIO00 Property

IRD

Pca9535ConfigurationIO00 Property

Configuration (IO0_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationIO00 { get; set; }
Public Property ConfigurationIO00 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationIO00 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationIO00 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.ConfigurationIO01 Property

IRD

Pca9535ConfigurationIO01 Property

Configuration (IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationIO01 { get; set; }
Public Property ConfigurationIO01 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationIO01 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationIO01 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.ConfigurationIO02 Property

IRD

Pca9535ConfigurationIO02 Property

Configuration (IO0_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationIO02 { get; set; }
Public Property ConfigurationIO02 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationIO02 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationIO02 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.ConfigurationIO03 Property

IRD

Pca9535ConfigurationIO03 Property

Configuration (IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationIO03 { get; set; }
Public Property ConfigurationIO03 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationIO03 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationIO03 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.ConfigurationIO04 Property

IRD

Pca9535ConfigurationIO04 Property

Configuration (IO0_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationIO04 { get; set; }
Public Property ConfigurationIO04 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationIO04 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationIO04 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.ConfigurationIO05 Property

IRD

Pca9535ConfigurationIO05 Property

Configuration (IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationIO05 { get; set; }
Public Property ConfigurationIO05 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationIO05 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationIO05 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.ConfigurationIO06 Property

IRD

Pca9535ConfigurationIO06 Property

Configuration (IO0_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationIO06 { get; set; }
Public Property ConfigurationIO06 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationIO06 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationIO06 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.ConfigurationIO07 Property

IRD

Pca9535ConfigurationIO07 Property

Configuration (IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationIO07 { get; set; }
Public Property ConfigurationIO07 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationIO07 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationIO07 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.ConfigurationIO10 Property

IRD

Pca9535ConfigurationIO10 Property

Configuration (IO1_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationIO10 { get; set; }
Public Property ConfigurationIO10 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationIO10 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationIO10 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.ConfigurationIO11 Property

IRD

Pca9535ConfigurationIO11 Property

Configuration (IO1_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationIO11 { get; set; }
Public Property ConfigurationIO11 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationIO11 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationIO11 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.ConfigurationIO12 Property

IRD

Pca9535ConfigurationIO12 Property

Configuration (IO1_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationIO12 { get; set; }
Public Property ConfigurationIO12 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationIO12 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationIO12 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.ConfigurationIO13 Property

IRD

Pca9535ConfigurationIO13 Property

Configuration (IO1_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationIO13 { get; set; }
Public Property ConfigurationIO13 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationIO13 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationIO13 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.ConfigurationIO14 Property

IRD

Pca9535ConfigurationIO14 Property

Configuration (IO1_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationIO14 { get; set; }
Public Property ConfigurationIO14 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationIO14 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationIO14 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.ConfigurationIO15 Property

IRD

Pca9535ConfigurationIO15 Property

Configuration (IO1_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationIO15 { get; set; }
Public Property ConfigurationIO15 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationIO15 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationIO15 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.ConfigurationIO16 Property

IRD

Pca9535ConfigurationIO16 Property

Configuration (IO1_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationIO16 { get; set; }
Public Property ConfigurationIO16 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationIO16 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationIO16 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.ConfigurationIO17 Property

IRD

Pca9535ConfigurationIO17 Property

Configuration (IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationIO17 { get; set; }
Public Property ConfigurationIO17 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationIO17 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationIO17 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.InputPortIO00 Property

IRD

Pca9535InputPortIO00 Property

Input Port (IO0_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO00 { get; }
Public ReadOnly Property InputPortIO00 As Byte
    Get
public:
property unsigned char InputPortIO00 {
    unsigned char get ();
}
member InputPortIO00 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.InputPortIO01 Property

IRD

Pca9535InputPortIO01 Property

Input Port (IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO01 { get; }
Public ReadOnly Property InputPortIO01 As Byte
    Get
public:
property unsigned char InputPortIO01 {
    unsigned char get ();
}
member InputPortIO01 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.InputPortIO02 Property

IRD

Pca9535InputPortIO02 Property

Input Port (IO0_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO02 { get; }
Public ReadOnly Property InputPortIO02 As Byte
    Get
public:
property unsigned char InputPortIO02 {
    unsigned char get ();
}
member InputPortIO02 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.InputPortIO03 Property

IRD

Pca9535InputPortIO03 Property

Input Port (IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO03 { get; }
Public ReadOnly Property InputPortIO03 As Byte
    Get
public:
property unsigned char InputPortIO03 {
    unsigned char get ();
}
member InputPortIO03 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.InputPortIO04 Property

IRD

Pca9535InputPortIO04 Property

Input Port (IO0_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO04 { get; }
Public ReadOnly Property InputPortIO04 As Byte
    Get
public:
property unsigned char InputPortIO04 {
    unsigned char get ();
}
member InputPortIO04 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.InputPortIO05 Property

IRD

Pca9535InputPortIO05 Property

Input Port (IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO05 { get; }
Public ReadOnly Property InputPortIO05 As Byte
    Get
public:
property unsigned char InputPortIO05 {
    unsigned char get ();
}
member InputPortIO05 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.InputPortIO06 Property

IRD

Pca9535InputPortIO06 Property

Input Port (IO0_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO06 { get; }
Public ReadOnly Property InputPortIO06 As Byte
    Get
public:
property unsigned char InputPortIO06 {
    unsigned char get ();
}
member InputPortIO06 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.InputPortIO07 Property

IRD

Pca9535InputPortIO07 Property

Input Port (IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO07 { get; }
Public ReadOnly Property InputPortIO07 As Byte
    Get
public:
property unsigned char InputPortIO07 {
    unsigned char get ();
}
member InputPortIO07 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.InputPortIO10 Property

IRD

Pca9535InputPortIO10 Property

Input Port (IO1_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO10 { get; }
Public ReadOnly Property InputPortIO10 As Byte
    Get
public:
property unsigned char InputPortIO10 {
    unsigned char get ();
}
member InputPortIO10 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.InputPortIO11 Property

IRD

Pca9535InputPortIO11 Property

Input Port (IO1_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO11 { get; }
Public ReadOnly Property InputPortIO11 As Byte
    Get
public:
property unsigned char InputPortIO11 {
    unsigned char get ();
}
member InputPortIO11 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.InputPortIO12 Property

IRD

Pca9535InputPortIO12 Property

Input Port (IO1_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO12 { get; }
Public ReadOnly Property InputPortIO12 As Byte
    Get
public:
property unsigned char InputPortIO12 {
    unsigned char get ();
}
member InputPortIO12 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.InputPortIO13 Property

IRD

Pca9535InputPortIO13 Property

Input Port (IO1_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO13 { get; }
Public ReadOnly Property InputPortIO13 As Byte
    Get
public:
property unsigned char InputPortIO13 {
    unsigned char get ();
}
member InputPortIO13 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.InputPortIO14 Property

IRD

Pca9535InputPortIO14 Property

Input Port (IO1_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO14 { get; }
Public ReadOnly Property InputPortIO14 As Byte
    Get
public:
property unsigned char InputPortIO14 {
    unsigned char get ();
}
member InputPortIO14 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.InputPortIO15 Property

IRD

Pca9535InputPortIO15 Property

Input Port (IO1_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO15 { get; }
Public ReadOnly Property InputPortIO15 As Byte
    Get
public:
property unsigned char InputPortIO15 {
    unsigned char get ();
}
member InputPortIO15 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.InputPortIO16 Property

IRD

Pca9535InputPortIO16 Property

Input Port (IO1_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO16 { get; }
Public ReadOnly Property InputPortIO16 As Byte
    Get
public:
property unsigned char InputPortIO16 {
    unsigned char get ();
}
member InputPortIO16 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.InputPortIO17 Property

IRD

Pca9535InputPortIO17 Property

Input Port (IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO17 { get; }
Public ReadOnly Property InputPortIO17 As Byte
    Get
public:
property unsigned char InputPortIO17 {
    unsigned char get ();
}
member InputPortIO17 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.OutputPortIO00 Property

IRD

Pca9535OutputPortIO00 Property

Output Port (IO0_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO00 { get; set; }
Public Property OutputPortIO00 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO00 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO00 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.OutputPortIO01 Property

IRD

Pca9535OutputPortIO01 Property

Output Port (IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO01 { get; set; }
Public Property OutputPortIO01 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO01 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO01 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.OutputPortIO02 Property

IRD

Pca9535OutputPortIO02 Property

Output Port (IO0_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO02 { get; set; }
Public Property OutputPortIO02 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO02 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO02 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.OutputPortIO03 Property

IRD

Pca9535OutputPortIO03 Property

Output Port (IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO03 { get; set; }
Public Property OutputPortIO03 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO03 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO03 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.OutputPortIO04 Property

IRD

Pca9535OutputPortIO04 Property

Output Port (IO0_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO04 { get; set; }
Public Property OutputPortIO04 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO04 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO04 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.OutputPortIO05 Property

IRD

Pca9535OutputPortIO05 Property

Output Port (IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO05 { get; set; }
Public Property OutputPortIO05 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO05 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO05 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.OutputPortIO06 Property

IRD

Pca9535OutputPortIO06 Property

Output Port (IO0_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO06 { get; set; }
Public Property OutputPortIO06 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO06 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO06 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.OutputPortIO07 Property

IRD

Pca9535OutputPortIO07 Property

Output Port (IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO07 { get; set; }
Public Property OutputPortIO07 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO07 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO07 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.OutputPortIO10 Property

IRD

Pca9535OutputPortIO10 Property

Output Port (IO1_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO10 { get; set; }
Public Property OutputPortIO10 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO10 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO10 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.OutputPortIO11 Property

IRD

Pca9535OutputPortIO11 Property

Output Port (IO1_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO11 { get; set; }
Public Property OutputPortIO11 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO11 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO11 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.OutputPortIO12 Property

IRD

Pca9535OutputPortIO12 Property

Output Port (IO1_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO12 { get; set; }
Public Property OutputPortIO12 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO12 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO12 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.OutputPortIO13 Property

IRD

Pca9535OutputPortIO13 Property

Output Port (IO1_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO13 { get; set; }
Public Property OutputPortIO13 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO13 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO13 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.OutputPortIO14 Property

IRD

Pca9535OutputPortIO14 Property

Output Port (IO1_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO14 { get; set; }
Public Property OutputPortIO14 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO14 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO14 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.OutputPortIO15 Property

IRD

Pca9535OutputPortIO15 Property

Output Port (IO1_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO15 { get; set; }
Public Property OutputPortIO15 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO15 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO15 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.OutputPortIO16 Property

IRD

Pca9535OutputPortIO16 Property

Output Port (IO1_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO16 { get; set; }
Public Property OutputPortIO16 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO16 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO16 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.OutputPortIO17 Property

IRD

Pca9535OutputPortIO17 Property

Output Port (IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO17 { get; set; }
Public Property OutputPortIO17 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO17 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO17 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.PolarityInversionIO00 Property

IRD

Pca9535PolarityInversionIO00 Property

Polarity Inversion (IO0_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarityInversion PolarityInversionIO00 { get; set; }
Public Property PolarityInversionIO00 As Pca9535TypePolarityInversion
    Get
    Set
public:
property Pca9535TypePolarityInversion PolarityInversionIO00 {
    Pca9535TypePolarityInversion get ();
    void set (Pca9535TypePolarityInversion value);
}
member PolarityInversionIO00 : Pca9535TypePolarityInversion with get, set

Property Value

Type: Pca9535TypePolarityInversion
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.PolarityInversionIO01 Property

IRD

Pca9535PolarityInversionIO01 Property

Polarity Inversion (IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarityInversion PolarityInversionIO01 { get; set; }
Public Property PolarityInversionIO01 As Pca9535TypePolarityInversion
    Get
    Set
public:
property Pca9535TypePolarityInversion PolarityInversionIO01 {
    Pca9535TypePolarityInversion get ();
    void set (Pca9535TypePolarityInversion value);
}
member PolarityInversionIO01 : Pca9535TypePolarityInversion with get, set

Property Value

Type: Pca9535TypePolarityInversion
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.PolarityInversionIO02 Property

IRD

Pca9535PolarityInversionIO02 Property

Polarity Inversion (IO0_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarityInversion PolarityInversionIO02 { get; set; }
Public Property PolarityInversionIO02 As Pca9535TypePolarityInversion
    Get
    Set
public:
property Pca9535TypePolarityInversion PolarityInversionIO02 {
    Pca9535TypePolarityInversion get ();
    void set (Pca9535TypePolarityInversion value);
}
member PolarityInversionIO02 : Pca9535TypePolarityInversion with get, set

Property Value

Type: Pca9535TypePolarityInversion
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.PolarityInversionIO03 Property

IRD

Pca9535PolarityInversionIO03 Property

Polarity Inversion (IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarityInversion PolarityInversionIO03 { get; set; }
Public Property PolarityInversionIO03 As Pca9535TypePolarityInversion
    Get
    Set
public:
property Pca9535TypePolarityInversion PolarityInversionIO03 {
    Pca9535TypePolarityInversion get ();
    void set (Pca9535TypePolarityInversion value);
}
member PolarityInversionIO03 : Pca9535TypePolarityInversion with get, set

Property Value

Type: Pca9535TypePolarityInversion
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.PolarityInversionIO04 Property

IRD

Pca9535PolarityInversionIO04 Property

Polarity Inversion (IO0_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarityInversion PolarityInversionIO04 { get; set; }
Public Property PolarityInversionIO04 As Pca9535TypePolarityInversion
    Get
    Set
public:
property Pca9535TypePolarityInversion PolarityInversionIO04 {
    Pca9535TypePolarityInversion get ();
    void set (Pca9535TypePolarityInversion value);
}
member PolarityInversionIO04 : Pca9535TypePolarityInversion with get, set

Property Value

Type: Pca9535TypePolarityInversion
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.PolarityInversionIO05 Property

IRD

Pca9535PolarityInversionIO05 Property

Polarity Inversion (IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarityInversion PolarityInversionIO05 { get; set; }
Public Property PolarityInversionIO05 As Pca9535TypePolarityInversion
    Get
    Set
public:
property Pca9535TypePolarityInversion PolarityInversionIO05 {
    Pca9535TypePolarityInversion get ();
    void set (Pca9535TypePolarityInversion value);
}
member PolarityInversionIO05 : Pca9535TypePolarityInversion with get, set

Property Value

Type: Pca9535TypePolarityInversion
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.PolarityInversionIO06 Property

IRD

Pca9535PolarityInversionIO06 Property

Polarity Inversion (IO0_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarityInversion PolarityInversionIO06 { get; set; }
Public Property PolarityInversionIO06 As Pca9535TypePolarityInversion
    Get
    Set
public:
property Pca9535TypePolarityInversion PolarityInversionIO06 {
    Pca9535TypePolarityInversion get ();
    void set (Pca9535TypePolarityInversion value);
}
member PolarityInversionIO06 : Pca9535TypePolarityInversion with get, set

Property Value

Type: Pca9535TypePolarityInversion
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.PolarityInversionIO07 Property

IRD

Pca9535PolarityInversionIO07 Property

Polarity Inversion (IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarityInversion PolarityInversionIO07 { get; set; }
Public Property PolarityInversionIO07 As Pca9535TypePolarityInversion
    Get
    Set
public:
property Pca9535TypePolarityInversion PolarityInversionIO07 {
    Pca9535TypePolarityInversion get ();
    void set (Pca9535TypePolarityInversion value);
}
member PolarityInversionIO07 : Pca9535TypePolarityInversion with get, set

Property Value

Type: Pca9535TypePolarityInversion
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.PolarityInversionIO10 Property

IRD

Pca9535PolarityInversionIO10 Property

Polarity Inversion (IO1_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarityInversion PolarityInversionIO10 { get; set; }
Public Property PolarityInversionIO10 As Pca9535TypePolarityInversion
    Get
    Set
public:
property Pca9535TypePolarityInversion PolarityInversionIO10 {
    Pca9535TypePolarityInversion get ();
    void set (Pca9535TypePolarityInversion value);
}
member PolarityInversionIO10 : Pca9535TypePolarityInversion with get, set

Property Value

Type: Pca9535TypePolarityInversion
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.PolarityInversionIO11 Property

IRD

Pca9535PolarityInversionIO11 Property

Polarity Inversion (IO1_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarityInversion PolarityInversionIO11 { get; set; }
Public Property PolarityInversionIO11 As Pca9535TypePolarityInversion
    Get
    Set
public:
property Pca9535TypePolarityInversion PolarityInversionIO11 {
    Pca9535TypePolarityInversion get ();
    void set (Pca9535TypePolarityInversion value);
}
member PolarityInversionIO11 : Pca9535TypePolarityInversion with get, set

Property Value

Type: Pca9535TypePolarityInversion
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.PolarityInversionIO12 Property

IRD

Pca9535PolarityInversionIO12 Property

Polarity Inversion (IO1_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarityInversion PolarityInversionIO12 { get; set; }
Public Property PolarityInversionIO12 As Pca9535TypePolarityInversion
    Get
    Set
public:
property Pca9535TypePolarityInversion PolarityInversionIO12 {
    Pca9535TypePolarityInversion get ();
    void set (Pca9535TypePolarityInversion value);
}
member PolarityInversionIO12 : Pca9535TypePolarityInversion with get, set

Property Value

Type: Pca9535TypePolarityInversion
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.PolarityInversionIO13 Property

IRD

Pca9535PolarityInversionIO13 Property

Polarity Inversion (IO1_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarityInversion PolarityInversionIO13 { get; set; }
Public Property PolarityInversionIO13 As Pca9535TypePolarityInversion
    Get
    Set
public:
property Pca9535TypePolarityInversion PolarityInversionIO13 {
    Pca9535TypePolarityInversion get ();
    void set (Pca9535TypePolarityInversion value);
}
member PolarityInversionIO13 : Pca9535TypePolarityInversion with get, set

Property Value

Type: Pca9535TypePolarityInversion
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.PolarityInversionIO14 Property

IRD

Pca9535PolarityInversionIO14 Property

Polarity Inversion (IO1_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarityInversion PolarityInversionIO14 { get; set; }
Public Property PolarityInversionIO14 As Pca9535TypePolarityInversion
    Get
    Set
public:
property Pca9535TypePolarityInversion PolarityInversionIO14 {
    Pca9535TypePolarityInversion get ();
    void set (Pca9535TypePolarityInversion value);
}
member PolarityInversionIO14 : Pca9535TypePolarityInversion with get, set

Property Value

Type: Pca9535TypePolarityInversion
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.PolarityInversionIO15 Property

IRD

Pca9535PolarityInversionIO15 Property

Polarity Inversion (IO1_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarityInversion PolarityInversionIO15 { get; set; }
Public Property PolarityInversionIO15 As Pca9535TypePolarityInversion
    Get
    Set
public:
property Pca9535TypePolarityInversion PolarityInversionIO15 {
    Pca9535TypePolarityInversion get ();
    void set (Pca9535TypePolarityInversion value);
}
member PolarityInversionIO15 : Pca9535TypePolarityInversion with get, set

Property Value

Type: Pca9535TypePolarityInversion
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.PolarityInversionIO16 Property

IRD

Pca9535PolarityInversionIO16 Property

Polarity Inversion (IO1_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarityInversion PolarityInversionIO16 { get; set; }
Public Property PolarityInversionIO16 As Pca9535TypePolarityInversion
    Get
    Set
public:
property Pca9535TypePolarityInversion PolarityInversionIO16 {
    Pca9535TypePolarityInversion get ();
    void set (Pca9535TypePolarityInversion value);
}
member PolarityInversionIO16 : Pca9535TypePolarityInversion with get, set

Property Value

Type: Pca9535TypePolarityInversion
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.PolarityInversionIO17 Property

IRD

Pca9535PolarityInversionIO17 Property

Polarity Inversion (IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarityInversion PolarityInversionIO17 { get; set; }
Public Property PolarityInversionIO17 As Pca9535TypePolarityInversion
    Get
    Set
public:
property Pca9535TypePolarityInversion PolarityInversionIO17 {
    Pca9535TypePolarityInversion get ();
    void set (Pca9535TypePolarityInversion value);
}
member PolarityInversionIO17 : Pca9535TypePolarityInversion with get, set

Property Value

Type: Pca9535TypePolarityInversion
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535 Methods

The Pca9535 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.Flush Method

IRD

Pca9535Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9535 Class
telos.Ird.NXPSemiconductors Namespace


Pca9535.TypeConfiguration Enumeration

IRD

Pca9535TypeConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Output | 0 | Output
Input | 1 | Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9535.TypePolarityInversion Enumeration

IRD

Pca9535TypePolarityInversion Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarityInversion
Public Enumeration TypePolarityInversion
public enum class TypePolarityInversion
type TypePolarityInversion
Members
Member name | Value | Description
Retained | 0 | Retained
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9536 Class

NXP Semiconductors: PCA 9536
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9536

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9536
Public Class Pca9536
public ref class Pca9536
type Pca9536 =  class end

The Pca9536 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9536 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationIO0 | Configuration (IO0)
Public property | ConfigurationIO1 | Configuration (IO1)
Public property | ConfigurationIO2 | Configuration (IO2)
Public property | ConfigurationIO3 | Configuration (IO3)
Public property | InputPortIO0 | Input Port (IO0)
Public property | InputPortIO1 | Input Port (IO1)
Public property | InputPortIO2 | Input Port (IO2)
Public property | InputPortIO3 | Input Port (IO3)
Public property | OutputPortIO0 | Output Port (IO0)
Public property | OutputPortIO1 | Output Port (IO1)
Public property | OutputPortIO2 | Output Port (IO2)
Public property | OutputPortIO3 | Output Port (IO3)
Public property | PolarityInversionIO0 | Polarity Inversion (IO0)
Public property | PolarityInversionIO1 | Polarity Inversion (IO1)
Public property | PolarityInversionIO2 | Polarity Inversion (IO2)
Public property | PolarityInversionIO3 | Polarity Inversion (IO3)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
4-Bit I2C-Bus And SMBus I/O Port
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9536 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9536(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9536

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536 Properties

The Pca9536 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationIO0 | Configuration (IO0)
Public property | ConfigurationIO1 | Configuration (IO1)
Public property | ConfigurationIO2 | Configuration (IO2)
Public property | ConfigurationIO3 | Configuration (IO3)
Public property | InputPortIO0 | Input Port (IO0)
Public property | InputPortIO1 | Input Port (IO1)
Public property | InputPortIO2 | Input Port (IO2)
Public property | InputPortIO3 | Input Port (IO3)
Public property | OutputPortIO0 | Output Port (IO0)
Public property | OutputPortIO1 | Output Port (IO1)
Public property | OutputPortIO2 | Output Port (IO2)
Public property | OutputPortIO3 | Output Port (IO3)
Public property | PolarityInversionIO0 | Polarity Inversion (IO0)
Public property | PolarityInversionIO1 | Polarity Inversion (IO1)
Public property | PolarityInversionIO2 | Polarity Inversion (IO2)
Public property | PolarityInversionIO3 | Polarity Inversion (IO3)
Top
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.AutoFlush Property

IRD

Pca9536AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.ConfigurationIO0 Property

IRD

Pca9536ConfigurationIO0 Property

Configuration (IO0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypeConfiguration ConfigurationIO0 { get; set; }
Public Property ConfigurationIO0 As Pca9536TypeConfiguration
    Get
    Set
public:
property Pca9536TypeConfiguration ConfigurationIO0 {
    Pca9536TypeConfiguration get ();
    void set (Pca9536TypeConfiguration value);
}
member ConfigurationIO0 : Pca9536TypeConfiguration with get, set

Property Value

Type: Pca9536TypeConfiguration
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.ConfigurationIO1 Property

IRD

Pca9536ConfigurationIO1 Property

Configuration (IO1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypeConfiguration ConfigurationIO1 { get; set; }
Public Property ConfigurationIO1 As Pca9536TypeConfiguration
    Get
    Set
public:
property Pca9536TypeConfiguration ConfigurationIO1 {
    Pca9536TypeConfiguration get ();
    void set (Pca9536TypeConfiguration value);
}
member ConfigurationIO1 : Pca9536TypeConfiguration with get, set

Property Value

Type: Pca9536TypeConfiguration
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.ConfigurationIO2 Property

IRD

Pca9536ConfigurationIO2 Property

Configuration (IO2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypeConfiguration ConfigurationIO2 { get; set; }
Public Property ConfigurationIO2 As Pca9536TypeConfiguration
    Get
    Set
public:
property Pca9536TypeConfiguration ConfigurationIO2 {
    Pca9536TypeConfiguration get ();
    void set (Pca9536TypeConfiguration value);
}
member ConfigurationIO2 : Pca9536TypeConfiguration with get, set

Property Value

Type: Pca9536TypeConfiguration
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.ConfigurationIO3 Property

IRD

Pca9536ConfigurationIO3 Property

Configuration (IO3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypeConfiguration ConfigurationIO3 { get; set; }
Public Property ConfigurationIO3 As Pca9536TypeConfiguration
    Get
    Set
public:
property Pca9536TypeConfiguration ConfigurationIO3 {
    Pca9536TypeConfiguration get ();
    void set (Pca9536TypeConfiguration value);
}
member ConfigurationIO3 : Pca9536TypeConfiguration with get, set

Property Value

Type: Pca9536TypeConfiguration
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.InputPortIO0 Property

IRD

Pca9536InputPortIO0 Property

Input Port (IO0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO0 { get; }
Public ReadOnly Property InputPortIO0 As Byte
    Get
public:
property unsigned char InputPortIO0 {
    unsigned char get ();
}
member InputPortIO0 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.InputPortIO1 Property

IRD

Pca9536InputPortIO1 Property

Input Port (IO1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO1 { get; }
Public ReadOnly Property InputPortIO1 As Byte
    Get
public:
property unsigned char InputPortIO1 {
    unsigned char get ();
}
member InputPortIO1 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.InputPortIO2 Property

IRD

Pca9536InputPortIO2 Property

Input Port (IO2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO2 { get; }
Public ReadOnly Property InputPortIO2 As Byte
    Get
public:
property unsigned char InputPortIO2 {
    unsigned char get ();
}
member InputPortIO2 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.InputPortIO3 Property

IRD

Pca9536InputPortIO3 Property

Input Port (IO3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO3 { get; }
Public ReadOnly Property InputPortIO3 As Byte
    Get
public:
property unsigned char InputPortIO3 {
    unsigned char get ();
}
member InputPortIO3 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.OutputPortIO0 Property

IRD

Pca9536OutputPortIO0 Property

Output Port (IO0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO0 { get; set; }
Public Property OutputPortIO0 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO0 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.OutputPortIO1 Property

IRD

Pca9536OutputPortIO1 Property

Output Port (IO1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO1 { get; set; }
Public Property OutputPortIO1 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO1 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.OutputPortIO2 Property

IRD

Pca9536OutputPortIO2 Property

Output Port (IO2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO2 { get; set; }
Public Property OutputPortIO2 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO2 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.OutputPortIO3 Property

IRD

Pca9536OutputPortIO3 Property

Output Port (IO3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO3 { get; set; }
Public Property OutputPortIO3 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO3 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.PolarityInversionIO0 Property

IRD

Pca9536PolarityInversionIO0 Property

Polarity Inversion (IO0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypePolarityInversion PolarityInversionIO0 { get; set; }
Public Property PolarityInversionIO0 As Pca9536TypePolarityInversion
    Get
    Set
public:
property Pca9536TypePolarityInversion PolarityInversionIO0 {
    Pca9536TypePolarityInversion get ();
    void set (Pca9536TypePolarityInversion value);
}
member PolarityInversionIO0 : Pca9536TypePolarityInversion with get, set

Property Value

Type: Pca9536TypePolarityInversion
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.PolarityInversionIO1 Property

IRD

Pca9536PolarityInversionIO1 Property

Polarity Inversion (IO1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypePolarityInversion PolarityInversionIO1 { get; set; }
Public Property PolarityInversionIO1 As Pca9536TypePolarityInversion
    Get
    Set
public:
property Pca9536TypePolarityInversion PolarityInversionIO1 {
    Pca9536TypePolarityInversion get ();
    void set (Pca9536TypePolarityInversion value);
}
member PolarityInversionIO1 : Pca9536TypePolarityInversion with get, set

Property Value

Type: Pca9536TypePolarityInversion
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.PolarityInversionIO2 Property

IRD

Pca9536PolarityInversionIO2 Property

Polarity Inversion (IO2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypePolarityInversion PolarityInversionIO2 { get; set; }
Public Property PolarityInversionIO2 As Pca9536TypePolarityInversion
    Get
    Set
public:
property Pca9536TypePolarityInversion PolarityInversionIO2 {
    Pca9536TypePolarityInversion get ();
    void set (Pca9536TypePolarityInversion value);
}
member PolarityInversionIO2 : Pca9536TypePolarityInversion with get, set

Property Value

Type: Pca9536TypePolarityInversion
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.PolarityInversionIO3 Property

IRD

Pca9536PolarityInversionIO3 Property

Polarity Inversion (IO3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypePolarityInversion PolarityInversionIO3 { get; set; }
Public Property PolarityInversionIO3 As Pca9536TypePolarityInversion
    Get
    Set
public:
property Pca9536TypePolarityInversion PolarityInversionIO3 {
    Pca9536TypePolarityInversion get ();
    void set (Pca9536TypePolarityInversion value);
}
member PolarityInversionIO3 : Pca9536TypePolarityInversion with get, set

Property Value

Type: Pca9536TypePolarityInversion
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536 Methods

The Pca9536 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.Flush Method

IRD

Pca9536Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9536 Class
telos.Ird.NXPSemiconductors Namespace


Pca9536.TypeConfiguration Enumeration

IRD

Pca9536TypeConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Output | 0 | Output
Input | 1 | Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9536.TypePolarityInversion Enumeration

IRD

Pca9536TypePolarityInversion Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarityInversion
Public Enumeration TypePolarityInversion
public enum class TypePolarityInversion
type TypePolarityInversion
Members
Member name | Value | Description
Retained | 0 | Retained
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9537 Class

NXP Semiconductors: PCA 9537
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9537

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9537
Public Class Pca9537
public ref class Pca9537
type Pca9537 =  class end

The Pca9537 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9537 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationIO0 | Configuration (IO0)
Public property | ConfigurationIO1 | Configuration (IO1)
Public property | ConfigurationIO2 | Configuration (IO2)
Public property | ConfigurationIO3 | Configuration (IO3)
Public property | InputPortIO0 | Input Port (IO0)
Public property | InputPortIO1 | Input Port (IO1)
Public property | InputPortIO2 | Input Port (IO2)
Public property | InputPortIO3 | Input Port (IO3)
Public property | OutputPortIO0 | Output Port (IO0)
Public property | OutputPortIO1 | Output Port (IO1)
Public property | OutputPortIO2 | Output Port (IO2)
Public property | OutputPortIO3 | Output Port (IO3)
Public property | PolarityInversionIO0 | Polarity Inversion (IO0)
Public property | PolarityInversionIO1 | Polarity Inversion (IO1)
Public property | PolarityInversionIO2 | Polarity Inversion (IO2)
Public property | PolarityInversionIO3 | Polarity Inversion (IO3)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
4-Bit I2C-Bus And SMBus Low Power I/O Port With Interrupt And Reset
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9537 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9537(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9537(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9537

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537 Properties

The Pca9537 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationIO0 | Configuration (IO0)
Public property | ConfigurationIO1 | Configuration (IO1)
Public property | ConfigurationIO2 | Configuration (IO2)
Public property | ConfigurationIO3 | Configuration (IO3)
Public property | InputPortIO0 | Input Port (IO0)
Public property | InputPortIO1 | Input Port (IO1)
Public property | InputPortIO2 | Input Port (IO2)
Public property | InputPortIO3 | Input Port (IO3)
Public property | OutputPortIO0 | Output Port (IO0)
Public property | OutputPortIO1 | Output Port (IO1)
Public property | OutputPortIO2 | Output Port (IO2)
Public property | OutputPortIO3 | Output Port (IO3)
Public property | PolarityInversionIO0 | Polarity Inversion (IO0)
Public property | PolarityInversionIO1 | Polarity Inversion (IO1)
Public property | PolarityInversionIO2 | Polarity Inversion (IO2)
Public property | PolarityInversionIO3 | Polarity Inversion (IO3)
Top
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.AutoFlush Property

IRD

Pca9537AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.ConfigurationIO0 Property

IRD

Pca9537ConfigurationIO0 Property

Configuration (IO0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9537TypeConfiguration ConfigurationIO0 { get; set; }
Public Property ConfigurationIO0 As Pca9537TypeConfiguration
    Get
    Set
public:
property Pca9537TypeConfiguration ConfigurationIO0 {
    Pca9537TypeConfiguration get ();
    void set (Pca9537TypeConfiguration value);
}
member ConfigurationIO0 : Pca9537TypeConfiguration with get, set

Property Value

Type: Pca9537TypeConfiguration
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.ConfigurationIO1 Property

IRD

Pca9537ConfigurationIO1 Property

Configuration (IO1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9537TypeConfiguration ConfigurationIO1 { get; set; }
Public Property ConfigurationIO1 As Pca9537TypeConfiguration
    Get
    Set
public:
property Pca9537TypeConfiguration ConfigurationIO1 {
    Pca9537TypeConfiguration get ();
    void set (Pca9537TypeConfiguration value);
}
member ConfigurationIO1 : Pca9537TypeConfiguration with get, set

Property Value

Type: Pca9537TypeConfiguration
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.ConfigurationIO2 Property

IRD

Pca9537ConfigurationIO2 Property

Configuration (IO2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9537TypeConfiguration ConfigurationIO2 { get; set; }
Public Property ConfigurationIO2 As Pca9537TypeConfiguration
    Get
    Set
public:
property Pca9537TypeConfiguration ConfigurationIO2 {
    Pca9537TypeConfiguration get ();
    void set (Pca9537TypeConfiguration value);
}
member ConfigurationIO2 : Pca9537TypeConfiguration with get, set

Property Value

Type: Pca9537TypeConfiguration
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.ConfigurationIO3 Property

IRD

Pca9537ConfigurationIO3 Property

Configuration (IO3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9537TypeConfiguration ConfigurationIO3 { get; set; }
Public Property ConfigurationIO3 As Pca9537TypeConfiguration
    Get
    Set
public:
property Pca9537TypeConfiguration ConfigurationIO3 {
    Pca9537TypeConfiguration get ();
    void set (Pca9537TypeConfiguration value);
}
member ConfigurationIO3 : Pca9537TypeConfiguration with get, set

Property Value

Type: Pca9537TypeConfiguration
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.InputPortIO0 Property

IRD

Pca9537InputPortIO0 Property

Input Port (IO0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO0 { get; }
Public ReadOnly Property InputPortIO0 As Byte
    Get
public:
property unsigned char InputPortIO0 {
    unsigned char get ();
}
member InputPortIO0 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.InputPortIO1 Property

IRD

Pca9537InputPortIO1 Property

Input Port (IO1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO1 { get; }
Public ReadOnly Property InputPortIO1 As Byte
    Get
public:
property unsigned char InputPortIO1 {
    unsigned char get ();
}
member InputPortIO1 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.InputPortIO2 Property

IRD

Pca9537InputPortIO2 Property

Input Port (IO2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO2 { get; }
Public ReadOnly Property InputPortIO2 As Byte
    Get
public:
property unsigned char InputPortIO2 {
    unsigned char get ();
}
member InputPortIO2 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.InputPortIO3 Property

IRD

Pca9537InputPortIO3 Property

Input Port (IO3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO3 { get; }
Public ReadOnly Property InputPortIO3 As Byte
    Get
public:
property unsigned char InputPortIO3 {
    unsigned char get ();
}
member InputPortIO3 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.OutputPortIO0 Property

IRD

Pca9537OutputPortIO0 Property

Output Port (IO0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO0 { get; set; }
Public Property OutputPortIO0 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO0 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.OutputPortIO1 Property

IRD

Pca9537OutputPortIO1 Property

Output Port (IO1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO1 { get; set; }
Public Property OutputPortIO1 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO1 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.OutputPortIO2 Property

IRD

Pca9537OutputPortIO2 Property

Output Port (IO2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO2 { get; set; }
Public Property OutputPortIO2 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO2 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.OutputPortIO3 Property

IRD

Pca9537OutputPortIO3 Property

Output Port (IO3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO3 { get; set; }
Public Property OutputPortIO3 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO3 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.PolarityInversionIO0 Property

IRD

Pca9537PolarityInversionIO0 Property

Polarity Inversion (IO0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9537TypePolarityInversion PolarityInversionIO0 { get; set; }
Public Property PolarityInversionIO0 As Pca9537TypePolarityInversion
    Get
    Set
public:
property Pca9537TypePolarityInversion PolarityInversionIO0 {
    Pca9537TypePolarityInversion get ();
    void set (Pca9537TypePolarityInversion value);
}
member PolarityInversionIO0 : Pca9537TypePolarityInversion with get, set

Property Value

Type: Pca9537TypePolarityInversion
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.PolarityInversionIO1 Property

IRD

Pca9537PolarityInversionIO1 Property

Polarity Inversion (IO1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9537TypePolarityInversion PolarityInversionIO1 { get; set; }
Public Property PolarityInversionIO1 As Pca9537TypePolarityInversion
    Get
    Set
public:
property Pca9537TypePolarityInversion PolarityInversionIO1 {
    Pca9537TypePolarityInversion get ();
    void set (Pca9537TypePolarityInversion value);
}
member PolarityInversionIO1 : Pca9537TypePolarityInversion with get, set

Property Value

Type: Pca9537TypePolarityInversion
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.PolarityInversionIO2 Property

IRD

Pca9537PolarityInversionIO2 Property

Polarity Inversion (IO2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9537TypePolarityInversion PolarityInversionIO2 { get; set; }
Public Property PolarityInversionIO2 As Pca9537TypePolarityInversion
    Get
    Set
public:
property Pca9537TypePolarityInversion PolarityInversionIO2 {
    Pca9537TypePolarityInversion get ();
    void set (Pca9537TypePolarityInversion value);
}
member PolarityInversionIO2 : Pca9537TypePolarityInversion with get, set

Property Value

Type: Pca9537TypePolarityInversion
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.PolarityInversionIO3 Property

IRD

Pca9537PolarityInversionIO3 Property

Polarity Inversion (IO3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9537TypePolarityInversion PolarityInversionIO3 { get; set; }
Public Property PolarityInversionIO3 As Pca9537TypePolarityInversion
    Get
    Set
public:
property Pca9537TypePolarityInversion PolarityInversionIO3 {
    Pca9537TypePolarityInversion get ();
    void set (Pca9537TypePolarityInversion value);
}
member PolarityInversionIO3 : Pca9537TypePolarityInversion with get, set

Property Value

Type: Pca9537TypePolarityInversion
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537 Methods

The Pca9537 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.Flush Method

IRD

Pca9537Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9537 Class
telos.Ird.NXPSemiconductors Namespace


Pca9537.TypeConfiguration Enumeration

IRD

Pca9537TypeConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Output | 0 | Output
Input | 1 | Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9537.TypePolarityInversion Enumeration

IRD

Pca9537TypePolarityInversion Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarityInversion
Public Enumeration TypePolarityInversion
public enum class TypePolarityInversion
type TypePolarityInversion
Members
Member name | Value | Description
Retained | 0 | Retained
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9538 Class

NXP Semiconductors: PCA 9538
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9538

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9538
Public Class Pca9538
public ref class Pca9538
type Pca9538 =  class end

The Pca9538 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9538 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationIO0 | Configuration (IO0)
Public property | ConfigurationIO1 | Configuration (IO1)
Public property | ConfigurationIO2 | Configuration (IO2)
Public property | ConfigurationIO3 | Configuration (IO3)
Public property | ConfigurationIO4 | Configuration (IO4)
Public property | ConfigurationIO5 | Configuration (IO5)
Public property | ConfigurationIO6 | Configuration (IO6)
Public property | ConfigurationIO7 | Configuration (IO7)
Public property | InputPortIO0 | Input Port (IO0)
Public property | InputPortIO1 | Input Port (IO1)
Public property | InputPortIO2 | Input Port (IO2)
Public property | InputPortIO3 | Input Port (IO3)
Public property | InputPortIO4 | Input Port (IO4)
Public property | InputPortIO5 | Input Port (IO5)
Public property | InputPortIO6 | Input Port (IO6)
Public property | InputPortIO7 | Input Port (IO7)
Public property | OutputPortIO0 | Output Port (IO0)
Public property | OutputPortIO1 | Output Port (IO1)
Public property | OutputPortIO2 | Output Port (IO2)
Public property | OutputPortIO3 | Output Port (IO3)
Public property | OutputPortIO4 | Output Port (IO4)
Public property | OutputPortIO5 | Output Port (IO5)
Public property | OutputPortIO6 | Output Port (IO6)
Public property | OutputPortIO7 | Output Port (IO7)
Public property | PolarityInversionIO0 | Polarity Inversion (IO0)
Public property | PolarityInversionIO1 | Polarity Inversion (IO1)
Public property | PolarityInversionIO2 | Polarity Inversion (IO2)
Public property | PolarityInversionIO3 | Polarity Inversion (IO3)
Public property | PolarityInversionIO4 | Polarity Inversion (IO4)
Public property | PolarityInversionIO5 | Polarity Inversion (IO5)
Public property | PolarityInversionIO6 | Polarity Inversion (IO6)
Public property | PolarityInversionIO7 | Polarity Inversion (IO7)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
8-Bit I2C-Bus And SMBus Low Power I/O Port With Interrupt And Reset
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9538 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9538(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9538(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9538

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538 Properties

The Pca9538 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationIO0 | Configuration (IO0)
Public property | ConfigurationIO1 | Configuration (IO1)
Public property | ConfigurationIO2 | Configuration (IO2)
Public property | ConfigurationIO3 | Configuration (IO3)
Public property | ConfigurationIO4 | Configuration (IO4)
Public property | ConfigurationIO5 | Configuration (IO5)
Public property | ConfigurationIO6 | Configuration (IO6)
Public property | ConfigurationIO7 | Configuration (IO7)
Public property | InputPortIO0 | Input Port (IO0)
Public property | InputPortIO1 | Input Port (IO1)
Public property | InputPortIO2 | Input Port (IO2)
Public property | InputPortIO3 | Input Port (IO3)
Public property | InputPortIO4 | Input Port (IO4)
Public property | InputPortIO5 | Input Port (IO5)
Public property | InputPortIO6 | Input Port (IO6)
Public property | InputPortIO7 | Input Port (IO7)
Public property | OutputPortIO0 | Output Port (IO0)
Public property | OutputPortIO1 | Output Port (IO1)
Public property | OutputPortIO2 | Output Port (IO2)
Public property | OutputPortIO3 | Output Port (IO3)
Public property | OutputPortIO4 | Output Port (IO4)
Public property | OutputPortIO5 | Output Port (IO5)
Public property | OutputPortIO6 | Output Port (IO6)
Public property | OutputPortIO7 | Output Port (IO7)
Public property | PolarityInversionIO0 | Polarity Inversion (IO0)
Public property | PolarityInversionIO1 | Polarity Inversion (IO1)
Public property | PolarityInversionIO2 | Polarity Inversion (IO2)
Public property | PolarityInversionIO3 | Polarity Inversion (IO3)
Public property | PolarityInversionIO4 | Polarity Inversion (IO4)
Public property | PolarityInversionIO5 | Polarity Inversion (IO5)
Public property | PolarityInversionIO6 | Polarity Inversion (IO6)
Public property | PolarityInversionIO7 | Polarity Inversion (IO7)
Top
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.AutoFlush Property

IRD

Pca9538AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.ConfigurationIO0 Property

IRD

Pca9538ConfigurationIO0 Property

Configuration (IO0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9538TypeConfiguration ConfigurationIO0 { get; set; }
Public Property ConfigurationIO0 As Pca9538TypeConfiguration
    Get
    Set
public:
property Pca9538TypeConfiguration ConfigurationIO0 {
    Pca9538TypeConfiguration get ();
    void set (Pca9538TypeConfiguration value);
}
member ConfigurationIO0 : Pca9538TypeConfiguration with get, set

Property Value

Type: Pca9538TypeConfiguration
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.ConfigurationIO1 Property

IRD

Pca9538ConfigurationIO1 Property

Configuration (IO1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9538TypeConfiguration ConfigurationIO1 { get; set; }
Public Property ConfigurationIO1 As Pca9538TypeConfiguration
    Get
    Set
public:
property Pca9538TypeConfiguration ConfigurationIO1 {
    Pca9538TypeConfiguration get ();
    void set (Pca9538TypeConfiguration value);
}
member ConfigurationIO1 : Pca9538TypeConfiguration with get, set

Property Value

Type: Pca9538TypeConfiguration
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.ConfigurationIO2 Property

IRD

Pca9538ConfigurationIO2 Property

Configuration (IO2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9538TypeConfiguration ConfigurationIO2 { get; set; }
Public Property ConfigurationIO2 As Pca9538TypeConfiguration
    Get
    Set
public:
property Pca9538TypeConfiguration ConfigurationIO2 {
    Pca9538TypeConfiguration get ();
    void set (Pca9538TypeConfiguration value);
}
member ConfigurationIO2 : Pca9538TypeConfiguration with get, set

Property Value

Type: Pca9538TypeConfiguration
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.ConfigurationIO3 Property

IRD

Pca9538ConfigurationIO3 Property

Configuration (IO3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9538TypeConfiguration ConfigurationIO3 { get; set; }
Public Property ConfigurationIO3 As Pca9538TypeConfiguration
    Get
    Set
public:
property Pca9538TypeConfiguration ConfigurationIO3 {
    Pca9538TypeConfiguration get ();
    void set (Pca9538TypeConfiguration value);
}
member ConfigurationIO3 : Pca9538TypeConfiguration with get, set

Property Value

Type: Pca9538TypeConfiguration
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.ConfigurationIO4 Property

IRD

Pca9538ConfigurationIO4 Property

Configuration (IO4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9538TypeConfiguration ConfigurationIO4 { get; set; }
Public Property ConfigurationIO4 As Pca9538TypeConfiguration
    Get
    Set
public:
property Pca9538TypeConfiguration ConfigurationIO4 {
    Pca9538TypeConfiguration get ();
    void set (Pca9538TypeConfiguration value);
}
member ConfigurationIO4 : Pca9538TypeConfiguration with get, set

Property Value

Type: Pca9538TypeConfiguration
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.ConfigurationIO5 Property

IRD

Pca9538ConfigurationIO5 Property

Configuration (IO5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9538TypeConfiguration ConfigurationIO5 { get; set; }
Public Property ConfigurationIO5 As Pca9538TypeConfiguration
    Get
    Set
public:
property Pca9538TypeConfiguration ConfigurationIO5 {
    Pca9538TypeConfiguration get ();
    void set (Pca9538TypeConfiguration value);
}
member ConfigurationIO5 : Pca9538TypeConfiguration with get, set

Property Value

Type: Pca9538TypeConfiguration
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.ConfigurationIO6 Property

IRD

Pca9538ConfigurationIO6 Property

Configuration (IO6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9538TypeConfiguration ConfigurationIO6 { get; set; }
Public Property ConfigurationIO6 As Pca9538TypeConfiguration
    Get
    Set
public:
property Pca9538TypeConfiguration ConfigurationIO6 {
    Pca9538TypeConfiguration get ();
    void set (Pca9538TypeConfiguration value);
}
member ConfigurationIO6 : Pca9538TypeConfiguration with get, set

Property Value

Type: Pca9538TypeConfiguration
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.ConfigurationIO7 Property

IRD

Pca9538ConfigurationIO7 Property

Configuration (IO7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9538TypeConfiguration ConfigurationIO7 { get; set; }
Public Property ConfigurationIO7 As Pca9538TypeConfiguration
    Get
    Set
public:
property Pca9538TypeConfiguration ConfigurationIO7 {
    Pca9538TypeConfiguration get ();
    void set (Pca9538TypeConfiguration value);
}
member ConfigurationIO7 : Pca9538TypeConfiguration with get, set

Property Value

Type: Pca9538TypeConfiguration
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.InputPortIO0 Property

IRD

Pca9538InputPortIO0 Property

Input Port (IO0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO0 { get; }
Public ReadOnly Property InputPortIO0 As Byte
    Get
public:
property unsigned char InputPortIO0 {
    unsigned char get ();
}
member InputPortIO0 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.InputPortIO1 Property

IRD

Pca9538InputPortIO1 Property

Input Port (IO1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO1 { get; }
Public ReadOnly Property InputPortIO1 As Byte
    Get
public:
property unsigned char InputPortIO1 {
    unsigned char get ();
}
member InputPortIO1 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.InputPortIO2 Property

IRD

Pca9538InputPortIO2 Property

Input Port (IO2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO2 { get; }
Public ReadOnly Property InputPortIO2 As Byte
    Get
public:
property unsigned char InputPortIO2 {
    unsigned char get ();
}
member InputPortIO2 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.InputPortIO3 Property

IRD

Pca9538InputPortIO3 Property

Input Port (IO3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO3 { get; }
Public ReadOnly Property InputPortIO3 As Byte
    Get
public:
property unsigned char InputPortIO3 {
    unsigned char get ();
}
member InputPortIO3 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.InputPortIO4 Property

IRD

Pca9538InputPortIO4 Property

Input Port (IO4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO4 { get; }
Public ReadOnly Property InputPortIO4 As Byte
    Get
public:
property unsigned char InputPortIO4 {
    unsigned char get ();
}
member InputPortIO4 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.InputPortIO5 Property

IRD

Pca9538InputPortIO5 Property

Input Port (IO5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO5 { get; }
Public ReadOnly Property InputPortIO5 As Byte
    Get
public:
property unsigned char InputPortIO5 {
    unsigned char get ();
}
member InputPortIO5 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.InputPortIO6 Property

IRD

Pca9538InputPortIO6 Property

Input Port (IO6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO6 { get; }
Public ReadOnly Property InputPortIO6 As Byte
    Get
public:
property unsigned char InputPortIO6 {
    unsigned char get ();
}
member InputPortIO6 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.InputPortIO7 Property

IRD

Pca9538InputPortIO7 Property

Input Port (IO7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO7 { get; }
Public ReadOnly Property InputPortIO7 As Byte
    Get
public:
property unsigned char InputPortIO7 {
    unsigned char get ();
}
member InputPortIO7 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.OutputPortIO0 Property

IRD

Pca9538OutputPortIO0 Property

Output Port (IO0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO0 { get; set; }
Public Property OutputPortIO0 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO0 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.OutputPortIO1 Property

IRD

Pca9538OutputPortIO1 Property

Output Port (IO1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO1 { get; set; }
Public Property OutputPortIO1 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO1 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.OutputPortIO2 Property

IRD

Pca9538OutputPortIO2 Property

Output Port (IO2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO2 { get; set; }
Public Property OutputPortIO2 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO2 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.OutputPortIO3 Property

IRD

Pca9538OutputPortIO3 Property

Output Port (IO3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO3 { get; set; }
Public Property OutputPortIO3 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO3 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.OutputPortIO4 Property

IRD

Pca9538OutputPortIO4 Property

Output Port (IO4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO4 { get; set; }
Public Property OutputPortIO4 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO4 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.OutputPortIO5 Property

IRD

Pca9538OutputPortIO5 Property

Output Port (IO5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO5 { get; set; }
Public Property OutputPortIO5 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO5 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.OutputPortIO6 Property

IRD

Pca9538OutputPortIO6 Property

Output Port (IO6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO6 { get; set; }
Public Property OutputPortIO6 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO6 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.OutputPortIO7 Property

IRD

Pca9538OutputPortIO7 Property

Output Port (IO7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO7 { get; set; }
Public Property OutputPortIO7 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO7 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.PolarityInversionIO0 Property

IRD

Pca9538PolarityInversionIO0 Property

Polarity Inversion (IO0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9538TypePolarityInversion PolarityInversionIO0 { get; set; }
Public Property PolarityInversionIO0 As Pca9538TypePolarityInversion
    Get
    Set
public:
property Pca9538TypePolarityInversion PolarityInversionIO0 {
    Pca9538TypePolarityInversion get ();
    void set (Pca9538TypePolarityInversion value);
}
member PolarityInversionIO0 : Pca9538TypePolarityInversion with get, set

Property Value

Type: Pca9538TypePolarityInversion
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.PolarityInversionIO1 Property

IRD

Pca9538PolarityInversionIO1 Property

Polarity Inversion (IO1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9538TypePolarityInversion PolarityInversionIO1 { get; set; }
Public Property PolarityInversionIO1 As Pca9538TypePolarityInversion
    Get
    Set
public:
property Pca9538TypePolarityInversion PolarityInversionIO1 {
    Pca9538TypePolarityInversion get ();
    void set (Pca9538TypePolarityInversion value);
}
member PolarityInversionIO1 : Pca9538TypePolarityInversion with get, set

Property Value

Type: Pca9538TypePolarityInversion
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.PolarityInversionIO2 Property

IRD

Pca9538PolarityInversionIO2 Property

Polarity Inversion (IO2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9538TypePolarityInversion PolarityInversionIO2 { get; set; }
Public Property PolarityInversionIO2 As Pca9538TypePolarityInversion
    Get
    Set
public:
property Pca9538TypePolarityInversion PolarityInversionIO2 {
    Pca9538TypePolarityInversion get ();
    void set (Pca9538TypePolarityInversion value);
}
member PolarityInversionIO2 : Pca9538TypePolarityInversion with get, set

Property Value

Type: Pca9538TypePolarityInversion
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.PolarityInversionIO3 Property

IRD

Pca9538PolarityInversionIO3 Property

Polarity Inversion (IO3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9538TypePolarityInversion PolarityInversionIO3 { get; set; }
Public Property PolarityInversionIO3 As Pca9538TypePolarityInversion
    Get
    Set
public:
property Pca9538TypePolarityInversion PolarityInversionIO3 {
    Pca9538TypePolarityInversion get ();
    void set (Pca9538TypePolarityInversion value);
}
member PolarityInversionIO3 : Pca9538TypePolarityInversion with get, set

Property Value

Type: Pca9538TypePolarityInversion
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.PolarityInversionIO4 Property

IRD

Pca9538PolarityInversionIO4 Property

Polarity Inversion (IO4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9538TypePolarityInversion PolarityInversionIO4 { get; set; }
Public Property PolarityInversionIO4 As Pca9538TypePolarityInversion
    Get
    Set
public:
property Pca9538TypePolarityInversion PolarityInversionIO4 {
    Pca9538TypePolarityInversion get ();
    void set (Pca9538TypePolarityInversion value);
}
member PolarityInversionIO4 : Pca9538TypePolarityInversion with get, set

Property Value

Type: Pca9538TypePolarityInversion
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.PolarityInversionIO5 Property

IRD

Pca9538PolarityInversionIO5 Property

Polarity Inversion (IO5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9538TypePolarityInversion PolarityInversionIO5 { get; set; }
Public Property PolarityInversionIO5 As Pca9538TypePolarityInversion
    Get
    Set
public:
property Pca9538TypePolarityInversion PolarityInversionIO5 {
    Pca9538TypePolarityInversion get ();
    void set (Pca9538TypePolarityInversion value);
}
member PolarityInversionIO5 : Pca9538TypePolarityInversion with get, set

Property Value

Type: Pca9538TypePolarityInversion
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.PolarityInversionIO6 Property

IRD

Pca9538PolarityInversionIO6 Property

Polarity Inversion (IO6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9538TypePolarityInversion PolarityInversionIO6 { get; set; }
Public Property PolarityInversionIO6 As Pca9538TypePolarityInversion
    Get
    Set
public:
property Pca9538TypePolarityInversion PolarityInversionIO6 {
    Pca9538TypePolarityInversion get ();
    void set (Pca9538TypePolarityInversion value);
}
member PolarityInversionIO6 : Pca9538TypePolarityInversion with get, set

Property Value

Type: Pca9538TypePolarityInversion
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.PolarityInversionIO7 Property

IRD

Pca9538PolarityInversionIO7 Property

Polarity Inversion (IO7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9538TypePolarityInversion PolarityInversionIO7 { get; set; }
Public Property PolarityInversionIO7 As Pca9538TypePolarityInversion
    Get
    Set
public:
property Pca9538TypePolarityInversion PolarityInversionIO7 {
    Pca9538TypePolarityInversion get ();
    void set (Pca9538TypePolarityInversion value);
}
member PolarityInversionIO7 : Pca9538TypePolarityInversion with get, set

Property Value

Type: Pca9538TypePolarityInversion
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538 Methods

The Pca9538 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.Flush Method

IRD

Pca9538Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9538 Class
telos.Ird.NXPSemiconductors Namespace


Pca9538.TypeConfiguration Enumeration

IRD

Pca9538TypeConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Output | 0 | Output
Input | 1 | Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9538.TypePolarityInversion Enumeration

IRD

Pca9538TypePolarityInversion Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarityInversion
Public Enumeration TypePolarityInversion
public enum class TypePolarityInversion
type TypePolarityInversion
Members
Member name | Value | Description
Retained | 0 | Retained
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9539 Class

NXP Semiconductors: PCA 9539
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9539

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9539
Public Class Pca9539
public ref class Pca9539
type Pca9539 =  class end

The Pca9539 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9539 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationIO00 | Configuration (IO0_0)
Public property | ConfigurationIO01 | Configuration (IO0_1)
Public property | ConfigurationIO02 | Configuration (IO0_2)
Public property | ConfigurationIO03 | Configuration (IO0_3)
Public property | ConfigurationIO04 | Configuration (IO0_4)
Public property | ConfigurationIO05 | Configuration (IO0_5)
Public property | ConfigurationIO06 | Configuration (IO0_6)
Public property | ConfigurationIO07 | Configuration (IO0_7)
Public property | ConfigurationIO10 | Configuration (IO1_0)
Public property | ConfigurationIO11 | Configuration (IO1_1)
Public property | ConfigurationIO12 | Configuration (IO1_2)
Public property | ConfigurationIO13 | Configuration (IO1_3)
Public property | ConfigurationIO14 | Configuration (IO1_4)
Public property | ConfigurationIO15 | Configuration (IO1_5)
Public property | ConfigurationIO16 | Configuration (IO1_6)
Public property | ConfigurationIO17 | Configuration (IO1_7)
Public property | InputPortIO00 | Input Port (IO0_0)
Public property | InputPortIO01 | Input Port (IO0_1)
Public property | InputPortIO02 | Input Port (IO0_2)
Public property | InputPortIO03 | Input Port (IO0_3)
Public property | InputPortIO04 | Input Port (IO0_4)
Public property | InputPortIO05 | Input Port (IO0_5)
Public property | InputPortIO06 | Input Port (IO0_6)
Public property | InputPortIO07 | Input Port (IO0_7)
Public property | InputPortIO10 | Input Port (IO1_0)
Public property | InputPortIO11 | Input Port (IO1_1)
Public property | InputPortIO12 | Input Port (IO1_2)
Public property | InputPortIO13 | Input Port (IO1_3)
Public property | InputPortIO14 | Input Port (IO1_4)
Public property | InputPortIO15 | Input Port (IO1_5)
Public property | InputPortIO16 | Input Port (IO1_6)
Public property | InputPortIO17 | Input Port (IO1_7)
Public property | OutputPortIO00 | Output Port (IO0_0)
Public property | OutputPortIO01 | Output Port (IO0_1)
Public property | OutputPortIO02 | Output Port (IO0_2)
Public property | OutputPortIO03 | Output Port (IO0_3)
Public property | OutputPortIO04 | Output Port (IO0_4)
Public property | OutputPortIO05 | Output Port (IO0_5)
Public property | OutputPortIO06 | Output Port (IO0_6)
Public property | OutputPortIO07 | Output Port (IO0_7)
Public property | OutputPortIO10 | Output Port (IO1_0)
Public property | OutputPortIO11 | Output Port (IO1_1)
Public property | OutputPortIO12 | Output Port (IO1_2)
Public property | OutputPortIO13 | Output Port (IO1_3)
Public property | OutputPortIO14 | Output Port (IO1_4)
Public property | OutputPortIO15 | Output Port (IO1_5)
Public property | OutputPortIO16 | Output Port (IO1_6)
Public property | OutputPortIO17 | Output Port (IO1_7)
Public property | PolarityInversionIO00 | Polarity Inversion (IO0_0)
Public property | PolarityInversionIO01 | Polarity Inversion (IO0_1)
Public property | PolarityInversionIO02 | Polarity Inversion (IO0_2)
Public property | PolarityInversionIO03 | Polarity Inversion (IO0_3)
Public property | PolarityInversionIO04 | Polarity Inversion (IO0_4)
Public property | PolarityInversionIO05 | Polarity Inversion (IO0_5)
Public property | PolarityInversionIO06 | Polarity Inversion (IO0_6)
Public property | PolarityInversionIO07 | Polarity Inversion (IO0_7)
Public property | PolarityInversionIO10 | Polarity Inversion (IO1_0)
Public property | PolarityInversionIO11 | Polarity Inversion (IO1_1)
Public property | PolarityInversionIO12 | Polarity Inversion (IO1_2)
Public property | PolarityInversionIO13 | Polarity Inversion (IO1_3)
Public property | PolarityInversionIO14 | Polarity Inversion (IO1_4)
Public property | PolarityInversionIO15 | Polarity Inversion (IO1_5)
Public property | PolarityInversionIO16 | Polarity Inversion (IO1_6)
Public property | PolarityInversionIO17 | Polarity Inversion (IO1_7)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
16-Bit I2C-Bus And SMBus Low Power I/O Port With Interrupt And Reset
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9539 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9539(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9539

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539 Properties

The Pca9539 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationIO00 | Configuration (IO0_0)
Public property | ConfigurationIO01 | Configuration (IO0_1)
Public property | ConfigurationIO02 | Configuration (IO0_2)
Public property | ConfigurationIO03 | Configuration (IO0_3)
Public property | ConfigurationIO04 | Configuration (IO0_4)
Public property | ConfigurationIO05 | Configuration (IO0_5)
Public property | ConfigurationIO06 | Configuration (IO0_6)
Public property | ConfigurationIO07 | Configuration (IO0_7)
Public property | ConfigurationIO10 | Configuration (IO1_0)
Public property | ConfigurationIO11 | Configuration (IO1_1)
Public property | ConfigurationIO12 | Configuration (IO1_2)
Public property | ConfigurationIO13 | Configuration (IO1_3)
Public property | ConfigurationIO14 | Configuration (IO1_4)
Public property | ConfigurationIO15 | Configuration (IO1_5)
Public property | ConfigurationIO16 | Configuration (IO1_6)
Public property | ConfigurationIO17 | Configuration (IO1_7)
Public property | InputPortIO00 | Input Port (IO0_0)
Public property | InputPortIO01 | Input Port (IO0_1)
Public property | InputPortIO02 | Input Port (IO0_2)
Public property | InputPortIO03 | Input Port (IO0_3)
Public property | InputPortIO04 | Input Port (IO0_4)
Public property | InputPortIO05 | Input Port (IO0_5)
Public property | InputPortIO06 | Input Port (IO0_6)
Public property | InputPortIO07 | Input Port (IO0_7)
Public property | InputPortIO10 | Input Port (IO1_0)
Public property | InputPortIO11 | Input Port (IO1_1)
Public property | InputPortIO12 | Input Port (IO1_2)
Public property | InputPortIO13 | Input Port (IO1_3)
Public property | InputPortIO14 | Input Port (IO1_4)
Public property | InputPortIO15 | Input Port (IO1_5)
Public property | InputPortIO16 | Input Port (IO1_6)
Public property | InputPortIO17 | Input Port (IO1_7)
Public property | OutputPortIO00 | Output Port (IO0_0)
Public property | OutputPortIO01 | Output Port (IO0_1)
Public property | OutputPortIO02 | Output Port (IO0_2)
Public property | OutputPortIO03 | Output Port (IO0_3)
Public property | OutputPortIO04 | Output Port (IO0_4)
Public property | OutputPortIO05 | Output Port (IO0_5)
Public property | OutputPortIO06 | Output Port (IO0_6)
Public property | OutputPortIO07 | Output Port (IO0_7)
Public property | OutputPortIO10 | Output Port (IO1_0)
Public property | OutputPortIO11 | Output Port (IO1_1)
Public property | OutputPortIO12 | Output Port (IO1_2)
Public property | OutputPortIO13 | Output Port (IO1_3)
Public property | OutputPortIO14 | Output Port (IO1_4)
Public property | OutputPortIO15 | Output Port (IO1_5)
Public property | OutputPortIO16 | Output Port (IO1_6)
Public property | OutputPortIO17 | Output Port (IO1_7)
Public property | PolarityInversionIO00 | Polarity Inversion (IO0_0)
Public property | PolarityInversionIO01 | Polarity Inversion (IO0_1)
Public property | PolarityInversionIO02 | Polarity Inversion (IO0_2)
Public property | PolarityInversionIO03 | Polarity Inversion (IO0_3)
Public property | PolarityInversionIO04 | Polarity Inversion (IO0_4)
Public property | PolarityInversionIO05 | Polarity Inversion (IO0_5)
Public property | PolarityInversionIO06 | Polarity Inversion (IO0_6)
Public property | PolarityInversionIO07 | Polarity Inversion (IO0_7)
Public property | PolarityInversionIO10 | Polarity Inversion (IO1_0)
Public property | PolarityInversionIO11 | Polarity Inversion (IO1_1)
Public property | PolarityInversionIO12 | Polarity Inversion (IO1_2)
Public property | PolarityInversionIO13 | Polarity Inversion (IO1_3)
Public property | PolarityInversionIO14 | Polarity Inversion (IO1_4)
Public property | PolarityInversionIO15 | Polarity Inversion (IO1_5)
Public property | PolarityInversionIO16 | Polarity Inversion (IO1_6)
Public property | PolarityInversionIO17 | Polarity Inversion (IO1_7)
Top
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.AutoFlush Property

IRD

Pca9539AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.ConfigurationIO00 Property

IRD

Pca9539ConfigurationIO00 Property

Configuration (IO0_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationIO00 { get; set; }
Public Property ConfigurationIO00 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationIO00 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationIO00 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.ConfigurationIO01 Property

IRD

Pca9539ConfigurationIO01 Property

Configuration (IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationIO01 { get; set; }
Public Property ConfigurationIO01 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationIO01 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationIO01 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.ConfigurationIO02 Property

IRD

Pca9539ConfigurationIO02 Property

Configuration (IO0_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationIO02 { get; set; }
Public Property ConfigurationIO02 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationIO02 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationIO02 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.ConfigurationIO03 Property

IRD

Pca9539ConfigurationIO03 Property

Configuration (IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationIO03 { get; set; }
Public Property ConfigurationIO03 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationIO03 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationIO03 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.ConfigurationIO04 Property

IRD

Pca9539ConfigurationIO04 Property

Configuration (IO0_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationIO04 { get; set; }
Public Property ConfigurationIO04 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationIO04 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationIO04 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.ConfigurationIO05 Property

IRD

Pca9539ConfigurationIO05 Property

Configuration (IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationIO05 { get; set; }
Public Property ConfigurationIO05 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationIO05 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationIO05 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.ConfigurationIO06 Property

IRD

Pca9539ConfigurationIO06 Property

Configuration (IO0_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationIO06 { get; set; }
Public Property ConfigurationIO06 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationIO06 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationIO06 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.ConfigurationIO07 Property

IRD

Pca9539ConfigurationIO07 Property

Configuration (IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationIO07 { get; set; }
Public Property ConfigurationIO07 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationIO07 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationIO07 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.ConfigurationIO10 Property

IRD

Pca9539ConfigurationIO10 Property

Configuration (IO1_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationIO10 { get; set; }
Public Property ConfigurationIO10 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationIO10 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationIO10 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.ConfigurationIO11 Property

IRD

Pca9539ConfigurationIO11 Property

Configuration (IO1_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationIO11 { get; set; }
Public Property ConfigurationIO11 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationIO11 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationIO11 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.ConfigurationIO12 Property

IRD

Pca9539ConfigurationIO12 Property

Configuration (IO1_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationIO12 { get; set; }
Public Property ConfigurationIO12 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationIO12 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationIO12 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.ConfigurationIO13 Property

IRD

Pca9539ConfigurationIO13 Property

Configuration (IO1_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationIO13 { get; set; }
Public Property ConfigurationIO13 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationIO13 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationIO13 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.ConfigurationIO14 Property

IRD

Pca9539ConfigurationIO14 Property

Configuration (IO1_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationIO14 { get; set; }
Public Property ConfigurationIO14 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationIO14 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationIO14 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.ConfigurationIO15 Property

IRD

Pca9539ConfigurationIO15 Property

Configuration (IO1_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationIO15 { get; set; }
Public Property ConfigurationIO15 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationIO15 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationIO15 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.ConfigurationIO16 Property

IRD

Pca9539ConfigurationIO16 Property

Configuration (IO1_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationIO16 { get; set; }
Public Property ConfigurationIO16 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationIO16 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationIO16 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.ConfigurationIO17 Property

IRD

Pca9539ConfigurationIO17 Property

Configuration (IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationIO17 { get; set; }
Public Property ConfigurationIO17 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationIO17 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationIO17 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.InputPortIO00 Property

IRD

Pca9539InputPortIO00 Property

Input Port (IO0_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO00 { get; }
Public ReadOnly Property InputPortIO00 As Byte
    Get
public:
property unsigned char InputPortIO00 {
    unsigned char get ();
}
member InputPortIO00 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.InputPortIO01 Property

IRD

Pca9539InputPortIO01 Property

Input Port (IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO01 { get; }
Public ReadOnly Property InputPortIO01 As Byte
    Get
public:
property unsigned char InputPortIO01 {
    unsigned char get ();
}
member InputPortIO01 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.InputPortIO02 Property

IRD

Pca9539InputPortIO02 Property

Input Port (IO0_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO02 { get; }
Public ReadOnly Property InputPortIO02 As Byte
    Get
public:
property unsigned char InputPortIO02 {
    unsigned char get ();
}
member InputPortIO02 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.InputPortIO03 Property

IRD

Pca9539InputPortIO03 Property

Input Port (IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO03 { get; }
Public ReadOnly Property InputPortIO03 As Byte
    Get
public:
property unsigned char InputPortIO03 {
    unsigned char get ();
}
member InputPortIO03 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.InputPortIO04 Property

IRD

Pca9539InputPortIO04 Property

Input Port (IO0_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO04 { get; }
Public ReadOnly Property InputPortIO04 As Byte
    Get
public:
property unsigned char InputPortIO04 {
    unsigned char get ();
}
member InputPortIO04 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.InputPortIO05 Property

IRD

Pca9539InputPortIO05 Property

Input Port (IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO05 { get; }
Public ReadOnly Property InputPortIO05 As Byte
    Get
public:
property unsigned char InputPortIO05 {
    unsigned char get ();
}
member InputPortIO05 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.InputPortIO06 Property

IRD

Pca9539InputPortIO06 Property

Input Port (IO0_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO06 { get; }
Public ReadOnly Property InputPortIO06 As Byte
    Get
public:
property unsigned char InputPortIO06 {
    unsigned char get ();
}
member InputPortIO06 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.InputPortIO07 Property

IRD

Pca9539InputPortIO07 Property

Input Port (IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO07 { get; }
Public ReadOnly Property InputPortIO07 As Byte
    Get
public:
property unsigned char InputPortIO07 {
    unsigned char get ();
}
member InputPortIO07 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.InputPortIO10 Property

IRD

Pca9539InputPortIO10 Property

Input Port (IO1_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO10 { get; }
Public ReadOnly Property InputPortIO10 As Byte
    Get
public:
property unsigned char InputPortIO10 {
    unsigned char get ();
}
member InputPortIO10 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.InputPortIO11 Property

IRD

Pca9539InputPortIO11 Property

Input Port (IO1_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO11 { get; }
Public ReadOnly Property InputPortIO11 As Byte
    Get
public:
property unsigned char InputPortIO11 {
    unsigned char get ();
}
member InputPortIO11 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.InputPortIO12 Property

IRD

Pca9539InputPortIO12 Property

Input Port (IO1_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO12 { get; }
Public ReadOnly Property InputPortIO12 As Byte
    Get
public:
property unsigned char InputPortIO12 {
    unsigned char get ();
}
member InputPortIO12 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.InputPortIO13 Property

IRD

Pca9539InputPortIO13 Property

Input Port (IO1_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO13 { get; }
Public ReadOnly Property InputPortIO13 As Byte
    Get
public:
property unsigned char InputPortIO13 {
    unsigned char get ();
}
member InputPortIO13 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.InputPortIO14 Property

IRD

Pca9539InputPortIO14 Property

Input Port (IO1_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO14 { get; }
Public ReadOnly Property InputPortIO14 As Byte
    Get
public:
property unsigned char InputPortIO14 {
    unsigned char get ();
}
member InputPortIO14 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.InputPortIO15 Property

IRD

Pca9539InputPortIO15 Property

Input Port (IO1_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO15 { get; }
Public ReadOnly Property InputPortIO15 As Byte
    Get
public:
property unsigned char InputPortIO15 {
    unsigned char get ();
}
member InputPortIO15 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.InputPortIO16 Property

IRD

Pca9539InputPortIO16 Property

Input Port (IO1_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO16 { get; }
Public ReadOnly Property InputPortIO16 As Byte
    Get
public:
property unsigned char InputPortIO16 {
    unsigned char get ();
}
member InputPortIO16 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.InputPortIO17 Property

IRD

Pca9539InputPortIO17 Property

Input Port (IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO17 { get; }
Public ReadOnly Property InputPortIO17 As Byte
    Get
public:
property unsigned char InputPortIO17 {
    unsigned char get ();
}
member InputPortIO17 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.OutputPortIO00 Property

IRD

Pca9539OutputPortIO00 Property

Output Port (IO0_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO00 { get; set; }
Public Property OutputPortIO00 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO00 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO00 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.OutputPortIO01 Property

IRD

Pca9539OutputPortIO01 Property

Output Port (IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO01 { get; set; }
Public Property OutputPortIO01 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO01 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO01 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.OutputPortIO02 Property

IRD

Pca9539OutputPortIO02 Property

Output Port (IO0_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO02 { get; set; }
Public Property OutputPortIO02 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO02 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO02 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.OutputPortIO03 Property

IRD

Pca9539OutputPortIO03 Property

Output Port (IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO03 { get; set; }
Public Property OutputPortIO03 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO03 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO03 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.OutputPortIO04 Property

IRD

Pca9539OutputPortIO04 Property

Output Port (IO0_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO04 { get; set; }
Public Property OutputPortIO04 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO04 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO04 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.OutputPortIO05 Property

IRD

Pca9539OutputPortIO05 Property

Output Port (IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO05 { get; set; }
Public Property OutputPortIO05 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO05 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO05 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.OutputPortIO06 Property

IRD

Pca9539OutputPortIO06 Property

Output Port (IO0_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO06 { get; set; }
Public Property OutputPortIO06 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO06 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO06 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.OutputPortIO07 Property

IRD

Pca9539OutputPortIO07 Property

Output Port (IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO07 { get; set; }
Public Property OutputPortIO07 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO07 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO07 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.OutputPortIO10 Property

IRD

Pca9539OutputPortIO10 Property

Output Port (IO1_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO10 { get; set; }
Public Property OutputPortIO10 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO10 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO10 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.OutputPortIO11 Property

IRD

Pca9539OutputPortIO11 Property

Output Port (IO1_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO11 { get; set; }
Public Property OutputPortIO11 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO11 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO11 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.OutputPortIO12 Property

IRD

Pca9539OutputPortIO12 Property

Output Port (IO1_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO12 { get; set; }
Public Property OutputPortIO12 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO12 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO12 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.OutputPortIO13 Property

IRD

Pca9539OutputPortIO13 Property

Output Port (IO1_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO13 { get; set; }
Public Property OutputPortIO13 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO13 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO13 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.OutputPortIO14 Property

IRD

Pca9539OutputPortIO14 Property

Output Port (IO1_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO14 { get; set; }
Public Property OutputPortIO14 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO14 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO14 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.OutputPortIO15 Property

IRD

Pca9539OutputPortIO15 Property

Output Port (IO1_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO15 { get; set; }
Public Property OutputPortIO15 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO15 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO15 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.OutputPortIO16 Property

IRD

Pca9539OutputPortIO16 Property

Output Port (IO1_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO16 { get; set; }
Public Property OutputPortIO16 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO16 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO16 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.OutputPortIO17 Property

IRD

Pca9539OutputPortIO17 Property

Output Port (IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO17 { get; set; }
Public Property OutputPortIO17 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO17 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO17 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.PolarityInversionIO00 Property

IRD

Pca9539PolarityInversionIO00 Property

Polarity Inversion (IO0_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarityInversion PolarityInversionIO00 { get; set; }
Public Property PolarityInversionIO00 As Pca9539TypePolarityInversion
    Get
    Set
public:
property Pca9539TypePolarityInversion PolarityInversionIO00 {
    Pca9539TypePolarityInversion get ();
    void set (Pca9539TypePolarityInversion value);
}
member PolarityInversionIO00 : Pca9539TypePolarityInversion with get, set

Property Value

Type: Pca9539TypePolarityInversion
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.PolarityInversionIO01 Property

IRD

Pca9539PolarityInversionIO01 Property

Polarity Inversion (IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarityInversion PolarityInversionIO01 { get; set; }
Public Property PolarityInversionIO01 As Pca9539TypePolarityInversion
    Get
    Set
public:
property Pca9539TypePolarityInversion PolarityInversionIO01 {
    Pca9539TypePolarityInversion get ();
    void set (Pca9539TypePolarityInversion value);
}
member PolarityInversionIO01 : Pca9539TypePolarityInversion with get, set

Property Value

Type: Pca9539TypePolarityInversion
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.PolarityInversionIO02 Property

IRD

Pca9539PolarityInversionIO02 Property

Polarity Inversion (IO0_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarityInversion PolarityInversionIO02 { get; set; }
Public Property PolarityInversionIO02 As Pca9539TypePolarityInversion
    Get
    Set
public:
property Pca9539TypePolarityInversion PolarityInversionIO02 {
    Pca9539TypePolarityInversion get ();
    void set (Pca9539TypePolarityInversion value);
}
member PolarityInversionIO02 : Pca9539TypePolarityInversion with get, set

Property Value

Type: Pca9539TypePolarityInversion
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.PolarityInversionIO03 Property

IRD

Pca9539PolarityInversionIO03 Property

Polarity Inversion (IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarityInversion PolarityInversionIO03 { get; set; }
Public Property PolarityInversionIO03 As Pca9539TypePolarityInversion
    Get
    Set
public:
property Pca9539TypePolarityInversion PolarityInversionIO03 {
    Pca9539TypePolarityInversion get ();
    void set (Pca9539TypePolarityInversion value);
}
member PolarityInversionIO03 : Pca9539TypePolarityInversion with get, set

Property Value

Type: Pca9539TypePolarityInversion
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.PolarityInversionIO04 Property

IRD

Pca9539PolarityInversionIO04 Property

Polarity Inversion (IO0_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarityInversion PolarityInversionIO04 { get; set; }
Public Property PolarityInversionIO04 As Pca9539TypePolarityInversion
    Get
    Set
public:
property Pca9539TypePolarityInversion PolarityInversionIO04 {
    Pca9539TypePolarityInversion get ();
    void set (Pca9539TypePolarityInversion value);
}
member PolarityInversionIO04 : Pca9539TypePolarityInversion with get, set

Property Value

Type: Pca9539TypePolarityInversion
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.PolarityInversionIO05 Property

IRD

Pca9539PolarityInversionIO05 Property

Polarity Inversion (IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarityInversion PolarityInversionIO05 { get; set; }
Public Property PolarityInversionIO05 As Pca9539TypePolarityInversion
    Get
    Set
public:
property Pca9539TypePolarityInversion PolarityInversionIO05 {
    Pca9539TypePolarityInversion get ();
    void set (Pca9539TypePolarityInversion value);
}
member PolarityInversionIO05 : Pca9539TypePolarityInversion with get, set

Property Value

Type: Pca9539TypePolarityInversion
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.PolarityInversionIO06 Property

IRD

Pca9539PolarityInversionIO06 Property

Polarity Inversion (IO0_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarityInversion PolarityInversionIO06 { get; set; }
Public Property PolarityInversionIO06 As Pca9539TypePolarityInversion
    Get
    Set
public:
property Pca9539TypePolarityInversion PolarityInversionIO06 {
    Pca9539TypePolarityInversion get ();
    void set (Pca9539TypePolarityInversion value);
}
member PolarityInversionIO06 : Pca9539TypePolarityInversion with get, set

Property Value

Type: Pca9539TypePolarityInversion
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.PolarityInversionIO07 Property

IRD

Pca9539PolarityInversionIO07 Property

Polarity Inversion (IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarityInversion PolarityInversionIO07 { get; set; }
Public Property PolarityInversionIO07 As Pca9539TypePolarityInversion
    Get
    Set
public:
property Pca9539TypePolarityInversion PolarityInversionIO07 {
    Pca9539TypePolarityInversion get ();
    void set (Pca9539TypePolarityInversion value);
}
member PolarityInversionIO07 : Pca9539TypePolarityInversion with get, set

Property Value

Type: Pca9539TypePolarityInversion
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.PolarityInversionIO10 Property

IRD

Pca9539PolarityInversionIO10 Property

Polarity Inversion (IO1_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarityInversion PolarityInversionIO10 { get; set; }
Public Property PolarityInversionIO10 As Pca9539TypePolarityInversion
    Get
    Set
public:
property Pca9539TypePolarityInversion PolarityInversionIO10 {
    Pca9539TypePolarityInversion get ();
    void set (Pca9539TypePolarityInversion value);
}
member PolarityInversionIO10 : Pca9539TypePolarityInversion with get, set

Property Value

Type: Pca9539TypePolarityInversion
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.PolarityInversionIO11 Property

IRD

Pca9539PolarityInversionIO11 Property

Polarity Inversion (IO1_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarityInversion PolarityInversionIO11 { get; set; }
Public Property PolarityInversionIO11 As Pca9539TypePolarityInversion
    Get
    Set
public:
property Pca9539TypePolarityInversion PolarityInversionIO11 {
    Pca9539TypePolarityInversion get ();
    void set (Pca9539TypePolarityInversion value);
}
member PolarityInversionIO11 : Pca9539TypePolarityInversion with get, set

Property Value

Type: Pca9539TypePolarityInversion
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.PolarityInversionIO12 Property

IRD

Pca9539PolarityInversionIO12 Property

Polarity Inversion (IO1_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarityInversion PolarityInversionIO12 { get; set; }
Public Property PolarityInversionIO12 As Pca9539TypePolarityInversion
    Get
    Set
public:
property Pca9539TypePolarityInversion PolarityInversionIO12 {
    Pca9539TypePolarityInversion get ();
    void set (Pca9539TypePolarityInversion value);
}
member PolarityInversionIO12 : Pca9539TypePolarityInversion with get, set

Property Value

Type: Pca9539TypePolarityInversion
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.PolarityInversionIO13 Property

IRD

Pca9539PolarityInversionIO13 Property

Polarity Inversion (IO1_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarityInversion PolarityInversionIO13 { get; set; }
Public Property PolarityInversionIO13 As Pca9539TypePolarityInversion
    Get
    Set
public:
property Pca9539TypePolarityInversion PolarityInversionIO13 {
    Pca9539TypePolarityInversion get ();
    void set (Pca9539TypePolarityInversion value);
}
member PolarityInversionIO13 : Pca9539TypePolarityInversion with get, set

Property Value

Type: Pca9539TypePolarityInversion
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.PolarityInversionIO14 Property

IRD

Pca9539PolarityInversionIO14 Property

Polarity Inversion (IO1_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarityInversion PolarityInversionIO14 { get; set; }
Public Property PolarityInversionIO14 As Pca9539TypePolarityInversion
    Get
    Set
public:
property Pca9539TypePolarityInversion PolarityInversionIO14 {
    Pca9539TypePolarityInversion get ();
    void set (Pca9539TypePolarityInversion value);
}
member PolarityInversionIO14 : Pca9539TypePolarityInversion with get, set

Property Value

Type: Pca9539TypePolarityInversion
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.PolarityInversionIO15 Property

IRD

Pca9539PolarityInversionIO15 Property

Polarity Inversion (IO1_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarityInversion PolarityInversionIO15 { get; set; }
Public Property PolarityInversionIO15 As Pca9539TypePolarityInversion
    Get
    Set
public:
property Pca9539TypePolarityInversion PolarityInversionIO15 {
    Pca9539TypePolarityInversion get ();
    void set (Pca9539TypePolarityInversion value);
}
member PolarityInversionIO15 : Pca9539TypePolarityInversion with get, set

Property Value

Type: Pca9539TypePolarityInversion
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.PolarityInversionIO16 Property

IRD

Pca9539PolarityInversionIO16 Property

Polarity Inversion (IO1_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarityInversion PolarityInversionIO16 { get; set; }
Public Property PolarityInversionIO16 As Pca9539TypePolarityInversion
    Get
    Set
public:
property Pca9539TypePolarityInversion PolarityInversionIO16 {
    Pca9539TypePolarityInversion get ();
    void set (Pca9539TypePolarityInversion value);
}
member PolarityInversionIO16 : Pca9539TypePolarityInversion with get, set

Property Value

Type: Pca9539TypePolarityInversion
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.PolarityInversionIO17 Property

IRD

Pca9539PolarityInversionIO17 Property

Polarity Inversion (IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarityInversion PolarityInversionIO17 { get; set; }
Public Property PolarityInversionIO17 As Pca9539TypePolarityInversion
    Get
    Set
public:
property Pca9539TypePolarityInversion PolarityInversionIO17 {
    Pca9539TypePolarityInversion get ();
    void set (Pca9539TypePolarityInversion value);
}
member PolarityInversionIO17 : Pca9539TypePolarityInversion with get, set

Property Value

Type: Pca9539TypePolarityInversion
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539 Methods

The Pca9539 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.Flush Method

IRD

Pca9539Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9539 Class
telos.Ird.NXPSemiconductors Namespace


Pca9539.TypeConfiguration Enumeration

IRD

Pca9539TypeConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Output | 0 | Output
Input | 1 | Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9539.TypePolarityInversion Enumeration

IRD

Pca9539TypePolarityInversion Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarityInversion
Public Enumeration TypePolarityInversion
public enum class TypePolarityInversion
type TypePolarityInversion
Members
Member name | Value | Description
Retained | 0 | Retained
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9540b Class

NXP Semiconductors: PCA 9540 B
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9540b

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9540b
Public Class Pca9540b
public ref class Pca9540b
type Pca9540b =  class end

The Pca9540b type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9540b | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelSelection | Channel Selection
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
2-Channel I2C Multiplexer
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9540b Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9540b(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9540b(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9540b

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9540b Class
telos.Ird.NXPSemiconductors Namespace


Pca9540b Properties

The Pca9540b type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelSelection | Channel Selection
Top
See Also

Reference

Pca9540b Class
telos.Ird.NXPSemiconductors Namespace


Pca9540b.AutoFlush Property

IRD

Pca9540bAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9540b Class
telos.Ird.NXPSemiconductors Namespace


Pca9540b.ChannelSelection Property

IRD

Pca9540bChannelSelection Property

Channel Selection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9540bTypeChannelSelection ChannelSelection { get; set; }
Public Property ChannelSelection As Pca9540bTypeChannelSelection
    Get
    Set
public:
property Pca9540bTypeChannelSelection ChannelSelection {
    Pca9540bTypeChannelSelection get ();
    void set (Pca9540bTypeChannelSelection value);
}
member ChannelSelection : Pca9540bTypeChannelSelection with get, set

Property Value

Type: Pca9540bTypeChannelSelection
See Also

Reference

Pca9540b Class
telos.Ird.NXPSemiconductors Namespace


Pca9540b Methods

The Pca9540b type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9540b Class
telos.Ird.NXPSemiconductors Namespace


Pca9540b.Flush Method

IRD

Pca9540bFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9540b Class
telos.Ird.NXPSemiconductors Namespace


Pca9540b.TypeChannelSelection Enumeration

IRD

Pca9540bTypeChannelSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelSelection
Public Enumeration TypeChannelSelection
public enum class TypeChannelSelection
type TypeChannelSelection
Members
Member name | Value | Description
NoChannelSelected | 0 | No channel selected
Channel0Enabled | 4 | Channel 0 enabled
Channel1Enabled | 5 | Channel 1 enabled
NoChannelSelected__1 | 6 | No channel selected
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9542a Class

NXP Semiconductors: PCA 9542 A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9542a

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9542a
Public Class Pca9542a
public ref class Pca9542a
type Pca9542a =  class end

The Pca9542a type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9542a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelSelection | Channel Selection
Public property | Interrupt0 | Interrupt 0
Public property | Interrupt1 | Interrupt 1
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
2-Channel I2C Multiplexer And Interrupt Logic
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9542a Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9542a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9542a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9542a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9542a Class
telos.Ird.NXPSemiconductors Namespace


Pca9542a Properties

The Pca9542a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelSelection | Channel Selection
Public property | Interrupt0 | Interrupt 0
Public property | Interrupt1 | Interrupt 1
Top
See Also

Reference

Pca9542a Class
telos.Ird.NXPSemiconductors Namespace


Pca9542a.AutoFlush Property

IRD

Pca9542aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9542a Class
telos.Ird.NXPSemiconductors Namespace


Pca9542a.ChannelSelection Property

IRD

Pca9542aChannelSelection Property

Channel Selection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9542aTypeChannelSelection ChannelSelection { get; set; }
Public Property ChannelSelection As Pca9542aTypeChannelSelection
    Get
    Set
public:
property Pca9542aTypeChannelSelection ChannelSelection {
    Pca9542aTypeChannelSelection get ();
    void set (Pca9542aTypeChannelSelection value);
}
member ChannelSelection : Pca9542aTypeChannelSelection with get, set

Property Value

Type: Pca9542aTypeChannelSelection
See Also

Reference

Pca9542a Class
telos.Ird.NXPSemiconductors Namespace


Pca9542a.Interrupt0 Property

IRD

Pca9542aInterrupt0 Property

Interrupt 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9542aTypeInt Interrupt0 { get; }
Public ReadOnly Property Interrupt0 As Pca9542aTypeInt
    Get
public:
property Pca9542aTypeInt Interrupt0 {
    Pca9542aTypeInt get ();
}
member Interrupt0 : Pca9542aTypeInt with get

Property Value

Type: Pca9542aTypeInt
See Also

Reference

Pca9542a Class
telos.Ird.NXPSemiconductors Namespace


Pca9542a.Interrupt1 Property

IRD

Pca9542aInterrupt1 Property

Interrupt 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9542aTypeInt Interrupt1 { get; }
Public ReadOnly Property Interrupt1 As Pca9542aTypeInt
    Get
public:
property Pca9542aTypeInt Interrupt1 {
    Pca9542aTypeInt get ();
}
member Interrupt1 : Pca9542aTypeInt with get

Property Value

Type: Pca9542aTypeInt
See Also

Reference

Pca9542a Class
telos.Ird.NXPSemiconductors Namespace


Pca9542a Methods

The Pca9542a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9542a Class
telos.Ird.NXPSemiconductors Namespace


Pca9542a.Flush Method

IRD

Pca9542aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9542a Class
telos.Ird.NXPSemiconductors Namespace


Pca9542a.TypeChannelSelection Enumeration

IRD

Pca9542aTypeChannelSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelSelection
Public Enumeration TypeChannelSelection
public enum class TypeChannelSelection
type TypeChannelSelection
Members
Member name | Value | Description
NoChannelSelected | 0 | No channel selected
Channel0Enabled | 4 | Channel 0 enabled
Channel1Enabled | 5 | Channel 1 enabled
NoChannelSelected__1 | 6 | No channel selected
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9542a.TypeInt Enumeration

IRD

Pca9542aTypeInt Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInt
Public Enumeration TypeInt
public enum class TypeInt
type TypeInt
Members
Member name | Value | Description
NoInterrupt | 0 | No interrupt
Interrupt | 1 | Interrupt
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9543a Class

NXP Semiconductors: PCA 9543 A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9543a

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9543a
Public Class Pca9543a
public ref class Pca9543a
type Pca9543a =  class end

The Pca9543a type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9543a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | Interrupt0 | Interrupt 0
Public property | Interrupt1 | Interrupt 1
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
2-Channel I2C-Bus Switch With Interrupt Logic And Reset
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9543a Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9543a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9543a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9543a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9543a Class
telos.Ird.NXPSemiconductors Namespace


Pca9543a Properties

The Pca9543a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | Interrupt0 | Interrupt 0
Public property | Interrupt1 | Interrupt 1
Top
See Also

Reference

Pca9543a Class
telos.Ird.NXPSemiconductors Namespace


Pca9543a.AutoFlush Property

IRD

Pca9543aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9543a Class
telos.Ird.NXPSemiconductors Namespace


Pca9543a.Channel0 Property

IRD

Pca9543aChannel0 Property

Channel 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9543aTypeChannelSelection Channel0 { get; set; }
Public Property Channel0 As Pca9543aTypeChannelSelection
    Get
    Set
public:
property Pca9543aTypeChannelSelection Channel0 {
    Pca9543aTypeChannelSelection get ();
    void set (Pca9543aTypeChannelSelection value);
}
member Channel0 : Pca9543aTypeChannelSelection with get, set

Property Value

Type: Pca9543aTypeChannelSelection
See Also

Reference

Pca9543a Class
telos.Ird.NXPSemiconductors Namespace


Pca9543a.Channel1 Property

IRD

Pca9543aChannel1 Property

Channel 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9543aTypeChannelSelection Channel1 { get; set; }
Public Property Channel1 As Pca9543aTypeChannelSelection
    Get
    Set
public:
property Pca9543aTypeChannelSelection Channel1 {
    Pca9543aTypeChannelSelection get ();
    void set (Pca9543aTypeChannelSelection value);
}
member Channel1 : Pca9543aTypeChannelSelection with get, set

Property Value

Type: Pca9543aTypeChannelSelection
See Also

Reference

Pca9543a Class
telos.Ird.NXPSemiconductors Namespace


Pca9543a.Interrupt0 Property

IRD

Pca9543aInterrupt0 Property

Interrupt 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9543aTypeInt Interrupt0 { get; }
Public ReadOnly Property Interrupt0 As Pca9543aTypeInt
    Get
public:
property Pca9543aTypeInt Interrupt0 {
    Pca9543aTypeInt get ();
}
member Interrupt0 : Pca9543aTypeInt with get

Property Value

Type: Pca9543aTypeInt
See Also

Reference

Pca9543a Class
telos.Ird.NXPSemiconductors Namespace


Pca9543a.Interrupt1 Property

IRD

Pca9543aInterrupt1 Property

Interrupt 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9543aTypeInt Interrupt1 { get; }
Public ReadOnly Property Interrupt1 As Pca9543aTypeInt
    Get
public:
property Pca9543aTypeInt Interrupt1 {
    Pca9543aTypeInt get ();
}
member Interrupt1 : Pca9543aTypeInt with get

Property Value

Type: Pca9543aTypeInt
See Also

Reference

Pca9543a Class
telos.Ird.NXPSemiconductors Namespace


Pca9543a Methods

The Pca9543a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9543a Class
telos.Ird.NXPSemiconductors Namespace


Pca9543a.Flush Method

IRD

Pca9543aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9543a Class
telos.Ird.NXPSemiconductors Namespace


Pca9543a.TypeChannelSelection Enumeration

IRD

Pca9543aTypeChannelSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelSelection
Public Enumeration TypeChannelSelection
public enum class TypeChannelSelection
type TypeChannelSelection
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9543a.TypeInt Enumeration

IRD

Pca9543aTypeInt Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInt
Public Enumeration TypeInt
public enum class TypeInt
type TypeInt
Members
Member name | Value | Description
NoInterrupt | 0 | No interrupt
Interrupt | 1 | Interrupt
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9543c Class

NXP Semiconductors: PCA 9543 C
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9543c

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9543c
Public Class Pca9543c
public ref class Pca9543c
type Pca9543c =  class end

The Pca9543c type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9543c | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | Interrupt0 | Interrupt 0
Public property | Interrupt1 | Interrupt 1
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
2-Channel I2C-Bus Switch With Interrupt Logic And Reset
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9543c Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9543c(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9543c(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9543c

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9543c Class
telos.Ird.NXPSemiconductors Namespace


Pca9543c Properties

The Pca9543c type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | Interrupt0 | Interrupt 0
Public property | Interrupt1 | Interrupt 1
Top
See Also

Reference

Pca9543c Class
telos.Ird.NXPSemiconductors Namespace


Pca9543c.AutoFlush Property

IRD

Pca9543cAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9543c Class
telos.Ird.NXPSemiconductors Namespace


Pca9543c.Channel0 Property

IRD

Pca9543cChannel0 Property

Channel 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9543cTypeChannelSelection Channel0 { get; set; }
Public Property Channel0 As Pca9543cTypeChannelSelection
    Get
    Set
public:
property Pca9543cTypeChannelSelection Channel0 {
    Pca9543cTypeChannelSelection get ();
    void set (Pca9543cTypeChannelSelection value);
}
member Channel0 : Pca9543cTypeChannelSelection with get, set

Property Value

Type: Pca9543cTypeChannelSelection
See Also

Reference

Pca9543c Class
telos.Ird.NXPSemiconductors Namespace


Pca9543c.Channel1 Property

IRD

Pca9543cChannel1 Property

Channel 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9543cTypeChannelSelection Channel1 { get; set; }
Public Property Channel1 As Pca9543cTypeChannelSelection
    Get
    Set
public:
property Pca9543cTypeChannelSelection Channel1 {
    Pca9543cTypeChannelSelection get ();
    void set (Pca9543cTypeChannelSelection value);
}
member Channel1 : Pca9543cTypeChannelSelection with get, set

Property Value

Type: Pca9543cTypeChannelSelection
See Also

Reference

Pca9543c Class
telos.Ird.NXPSemiconductors Namespace


Pca9543c.Interrupt0 Property

IRD

Pca9543cInterrupt0 Property

Interrupt 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9543cTypeInt Interrupt0 { get; }
Public ReadOnly Property Interrupt0 As Pca9543cTypeInt
    Get
public:
property Pca9543cTypeInt Interrupt0 {
    Pca9543cTypeInt get ();
}
member Interrupt0 : Pca9543cTypeInt with get

Property Value

Type: Pca9543cTypeInt
See Also

Reference

Pca9543c Class
telos.Ird.NXPSemiconductors Namespace


Pca9543c.Interrupt1 Property

IRD

Pca9543cInterrupt1 Property

Interrupt 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9543cTypeInt Interrupt1 { get; }
Public ReadOnly Property Interrupt1 As Pca9543cTypeInt
    Get
public:
property Pca9543cTypeInt Interrupt1 {
    Pca9543cTypeInt get ();
}
member Interrupt1 : Pca9543cTypeInt with get

Property Value

Type: Pca9543cTypeInt
See Also

Reference

Pca9543c Class
telos.Ird.NXPSemiconductors Namespace


Pca9543c Methods

The Pca9543c type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9543c Class
telos.Ird.NXPSemiconductors Namespace


Pca9543c.Flush Method

IRD

Pca9543cFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9543c Class
telos.Ird.NXPSemiconductors Namespace


Pca9543c.TypeChannelSelection Enumeration

IRD

Pca9543cTypeChannelSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelSelection
Public Enumeration TypeChannelSelection
public enum class TypeChannelSelection
type TypeChannelSelection
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9543c.TypeInt Enumeration

IRD

Pca9543cTypeInt Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInt
Public Enumeration TypeInt
public enum class TypeInt
type TypeInt
Members
Member name | Value | Description
NoInterrupt | 0 | No interrupt
Interrupt | 1 | Interrupt
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9544a Class

NXP Semiconductors: PCA 9544 A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9544a

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9544a
Public Class Pca9544a
public ref class Pca9544a
type Pca9544a =  class end

The Pca9544a type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9544a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelSelection | Channel Selection
Public property | Interrupt0 | Interrupt 0
Public property | Interrupt1 | Interrupt 1
Public property | Interrupt2 | Interrupt 2
Public property | Interrupt3 | Interrupt 3
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
4-Channel I2C Multiplexer With Interrupt Logic
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9544a Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9544a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9544a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9544a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9544a Class
telos.Ird.NXPSemiconductors Namespace


Pca9544a Properties

The Pca9544a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelSelection | Channel Selection
Public property | Interrupt0 | Interrupt 0
Public property | Interrupt1 | Interrupt 1
Public property | Interrupt2 | Interrupt 2
Public property | Interrupt3 | Interrupt 3
Top
See Also

Reference

Pca9544a Class
telos.Ird.NXPSemiconductors Namespace


Pca9544a.AutoFlush Property

IRD

Pca9544aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9544a Class
telos.Ird.NXPSemiconductors Namespace


Pca9544a.ChannelSelection Property

IRD

Pca9544aChannelSelection Property

Channel Selection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9544aTypeChannelSelection ChannelSelection { get; set; }
Public Property ChannelSelection As Pca9544aTypeChannelSelection
    Get
    Set
public:
property Pca9544aTypeChannelSelection ChannelSelection {
    Pca9544aTypeChannelSelection get ();
    void set (Pca9544aTypeChannelSelection value);
}
member ChannelSelection : Pca9544aTypeChannelSelection with get, set

Property Value

Type: Pca9544aTypeChannelSelection
See Also

Reference

Pca9544a Class
telos.Ird.NXPSemiconductors Namespace


Pca9544a.Interrupt0 Property

IRD

Pca9544aInterrupt0 Property

Interrupt 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9544aTypeInt Interrupt0 { get; }
Public ReadOnly Property Interrupt0 As Pca9544aTypeInt
    Get
public:
property Pca9544aTypeInt Interrupt0 {
    Pca9544aTypeInt get ();
}
member Interrupt0 : Pca9544aTypeInt with get

Property Value

Type: Pca9544aTypeInt
See Also

Reference

Pca9544a Class
telos.Ird.NXPSemiconductors Namespace


Pca9544a.Interrupt1 Property

IRD

Pca9544aInterrupt1 Property

Interrupt 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9544aTypeInt Interrupt1 { get; }
Public ReadOnly Property Interrupt1 As Pca9544aTypeInt
    Get
public:
property Pca9544aTypeInt Interrupt1 {
    Pca9544aTypeInt get ();
}
member Interrupt1 : Pca9544aTypeInt with get

Property Value

Type: Pca9544aTypeInt
See Also

Reference

Pca9544a Class
telos.Ird.NXPSemiconductors Namespace


Pca9544a.Interrupt2 Property

IRD

Pca9544aInterrupt2 Property

Interrupt 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9544aTypeInt Interrupt2 { get; }
Public ReadOnly Property Interrupt2 As Pca9544aTypeInt
    Get
public:
property Pca9544aTypeInt Interrupt2 {
    Pca9544aTypeInt get ();
}
member Interrupt2 : Pca9544aTypeInt with get

Property Value

Type: Pca9544aTypeInt
See Also

Reference

Pca9544a Class
telos.Ird.NXPSemiconductors Namespace


Pca9544a.Interrupt3 Property

IRD

Pca9544aInterrupt3 Property

Interrupt 3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9544aTypeInt Interrupt3 { get; }
Public ReadOnly Property Interrupt3 As Pca9544aTypeInt
    Get
public:
property Pca9544aTypeInt Interrupt3 {
    Pca9544aTypeInt get ();
}
member Interrupt3 : Pca9544aTypeInt with get

Property Value

Type: Pca9544aTypeInt
See Also

Reference

Pca9544a Class
telos.Ird.NXPSemiconductors Namespace


Pca9544a Methods

The Pca9544a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9544a Class
telos.Ird.NXPSemiconductors Namespace


Pca9544a.Flush Method

IRD

Pca9544aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9544a Class
telos.Ird.NXPSemiconductors Namespace


Pca9544a.TypeChannelSelection Enumeration

IRD

Pca9544aTypeChannelSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelSelection
Public Enumeration TypeChannelSelection
public enum class TypeChannelSelection
type TypeChannelSelection
Members
Member name | Value | Description
NoChannelSelected | 0 | No channel selected
Channel0Enabled | 4 | Channel 0 enabled
Channel1Enabled | 5 | Channel 1 enabled
Channel2Enabled | 6 | Channel 2 enabled
Channel3Enabled | 7 | Channel 3 enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9544a.TypeInt Enumeration

IRD

Pca9544aTypeInt Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInt
Public Enumeration TypeInt
public enum class TypeInt
type TypeInt
Members
Member name | Value | Description
NoInterrupt | 0 | No interrupt
Interrupt | 1 | Interrupt
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9545a Class

NXP Semiconductors: PCA 9545 A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9545a

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9545a
Public Class Pca9545a
public ref class Pca9545a
type Pca9545a =  class end

The Pca9545a type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9545a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | Channel2 | Channel 2
Public property | Channel3 | Channel 3
Public property | Interrupt0 | Interrupt 0
Public property | Interrupt1 | Interrupt 1
Public property | Interrupt2 | Interrupt 2
Public property | Interrupt3 | Interrupt 3
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
4-Channel I2C-Bus Switch With Interrupt Logic And Reset
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9545a Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9545a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9545a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9545a Class
telos.Ird.NXPSemiconductors Namespace


Pca9545a Properties

The Pca9545a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | Channel2 | Channel 2
Public property | Channel3 | Channel 3
Public property | Interrupt0 | Interrupt 0
Public property | Interrupt1 | Interrupt 1
Public property | Interrupt2 | Interrupt 2
Public property | Interrupt3 | Interrupt 3
Top
See Also

Reference

Pca9545a Class
telos.Ird.NXPSemiconductors Namespace


Pca9545a.AutoFlush Property

IRD

Pca9545aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9545a Class
telos.Ird.NXPSemiconductors Namespace


Pca9545a.Channel0 Property

IRD

Pca9545aChannel0 Property

Channel 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545aTypeChannelSelection Channel0 { get; set; }
Public Property Channel0 As Pca9545aTypeChannelSelection
    Get
    Set
public:
property Pca9545aTypeChannelSelection Channel0 {
    Pca9545aTypeChannelSelection get ();
    void set (Pca9545aTypeChannelSelection value);
}
member Channel0 : Pca9545aTypeChannelSelection with get, set

Property Value

Type: Pca9545aTypeChannelSelection
See Also

Reference

Pca9545a Class
telos.Ird.NXPSemiconductors Namespace


Pca9545a.Channel1 Property

IRD

Pca9545aChannel1 Property

Channel 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545aTypeChannelSelection Channel1 { get; set; }
Public Property Channel1 As Pca9545aTypeChannelSelection
    Get
    Set
public:
property Pca9545aTypeChannelSelection Channel1 {
    Pca9545aTypeChannelSelection get ();
    void set (Pca9545aTypeChannelSelection value);
}
member Channel1 : Pca9545aTypeChannelSelection with get, set

Property Value

Type: Pca9545aTypeChannelSelection
See Also

Reference

Pca9545a Class
telos.Ird.NXPSemiconductors Namespace


Pca9545a.Channel2 Property

IRD

Pca9545aChannel2 Property

Channel 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545aTypeChannelSelection Channel2 { get; set; }
Public Property Channel2 As Pca9545aTypeChannelSelection
    Get
    Set
public:
property Pca9545aTypeChannelSelection Channel2 {
    Pca9545aTypeChannelSelection get ();
    void set (Pca9545aTypeChannelSelection value);
}
member Channel2 : Pca9545aTypeChannelSelection with get, set

Property Value

Type: Pca9545aTypeChannelSelection
See Also

Reference

Pca9545a Class
telos.Ird.NXPSemiconductors Namespace


Pca9545a.Channel3 Property

IRD

Pca9545aChannel3 Property

Channel 3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545aTypeChannelSelection Channel3 { get; set; }
Public Property Channel3 As Pca9545aTypeChannelSelection
    Get
    Set
public:
property Pca9545aTypeChannelSelection Channel3 {
    Pca9545aTypeChannelSelection get ();
    void set (Pca9545aTypeChannelSelection value);
}
member Channel3 : Pca9545aTypeChannelSelection with get, set

Property Value

Type: Pca9545aTypeChannelSelection
See Also

Reference

Pca9545a Class
telos.Ird.NXPSemiconductors Namespace


Pca9545a.Interrupt0 Property

IRD

Pca9545aInterrupt0 Property

Interrupt 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545aTypeInt Interrupt0 { get; }
Public ReadOnly Property Interrupt0 As Pca9545aTypeInt
    Get
public:
property Pca9545aTypeInt Interrupt0 {
    Pca9545aTypeInt get ();
}
member Interrupt0 : Pca9545aTypeInt with get

Property Value

Type: Pca9545aTypeInt
See Also

Reference

Pca9545a Class
telos.Ird.NXPSemiconductors Namespace


Pca9545a.Interrupt1 Property

IRD

Pca9545aInterrupt1 Property

Interrupt 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545aTypeInt Interrupt1 { get; }
Public ReadOnly Property Interrupt1 As Pca9545aTypeInt
    Get
public:
property Pca9545aTypeInt Interrupt1 {
    Pca9545aTypeInt get ();
}
member Interrupt1 : Pca9545aTypeInt with get

Property Value

Type: Pca9545aTypeInt
See Also

Reference

Pca9545a Class
telos.Ird.NXPSemiconductors Namespace


Pca9545a.Interrupt2 Property

IRD

Pca9545aInterrupt2 Property

Interrupt 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545aTypeInt Interrupt2 { get; }
Public ReadOnly Property Interrupt2 As Pca9545aTypeInt
    Get
public:
property Pca9545aTypeInt Interrupt2 {
    Pca9545aTypeInt get ();
}
member Interrupt2 : Pca9545aTypeInt with get

Property Value

Type: Pca9545aTypeInt
See Also

Reference

Pca9545a Class
telos.Ird.NXPSemiconductors Namespace


Pca9545a.Interrupt3 Property

IRD

Pca9545aInterrupt3 Property

Interrupt 3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545aTypeInt Interrupt3 { get; }
Public ReadOnly Property Interrupt3 As Pca9545aTypeInt
    Get
public:
property Pca9545aTypeInt Interrupt3 {
    Pca9545aTypeInt get ();
}
member Interrupt3 : Pca9545aTypeInt with get

Property Value

Type: Pca9545aTypeInt
See Also

Reference

Pca9545a Class
telos.Ird.NXPSemiconductors Namespace


Pca9545a Methods

The Pca9545a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9545a Class
telos.Ird.NXPSemiconductors Namespace


Pca9545a.Flush Method

IRD

Pca9545aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9545a Class
telos.Ird.NXPSemiconductors Namespace


Pca9545a.TypeChannelSelection Enumeration

IRD

Pca9545aTypeChannelSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelSelection
Public Enumeration TypeChannelSelection
public enum class TypeChannelSelection
type TypeChannelSelection
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9545a.TypeInt Enumeration

IRD

Pca9545aTypeInt Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInt
Public Enumeration TypeInt
public enum class TypeInt
type TypeInt
Members
Member name | Value | Description
NoInterrupt | 0 | No interrupt
Interrupt | 1 | Interrupt
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9545b Class

NXP Semiconductors: PCA 9545 A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9545b

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9545b
Public Class Pca9545b
public ref class Pca9545b
type Pca9545b =  class end

The Pca9545b type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9545b | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | Channel2 | Channel 2
Public property | Channel3 | Channel 3
Public property | Interrupt0 | Interrupt 0
Public property | Interrupt1 | Interrupt 1
Public property | Interrupt2 | Interrupt 2
Public property | Interrupt3 | Interrupt 3
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
4-Channel I2C-Bus Switch With Interrupt Logic And Reset
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9545b Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545b(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9545b(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9545b

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9545b Class
telos.Ird.NXPSemiconductors Namespace


Pca9545b Properties

The Pca9545b type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | Channel2 | Channel 2
Public property | Channel3 | Channel 3
Public property | Interrupt0 | Interrupt 0
Public property | Interrupt1 | Interrupt 1
Public property | Interrupt2 | Interrupt 2
Public property | Interrupt3 | Interrupt 3
Top
See Also

Reference

Pca9545b Class
telos.Ird.NXPSemiconductors Namespace


Pca9545b.AutoFlush Property

IRD

Pca9545bAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9545b Class
telos.Ird.NXPSemiconductors Namespace


Pca9545b.Channel0 Property

IRD

Pca9545bChannel0 Property

Channel 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545bTypeChannelSelection Channel0 { get; set; }
Public Property Channel0 As Pca9545bTypeChannelSelection
    Get
    Set
public:
property Pca9545bTypeChannelSelection Channel0 {
    Pca9545bTypeChannelSelection get ();
    void set (Pca9545bTypeChannelSelection value);
}
member Channel0 : Pca9545bTypeChannelSelection with get, set

Property Value

Type: Pca9545bTypeChannelSelection
See Also

Reference

Pca9545b Class
telos.Ird.NXPSemiconductors Namespace


Pca9545b.Channel1 Property

IRD

Pca9545bChannel1 Property

Channel 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545bTypeChannelSelection Channel1 { get; set; }
Public Property Channel1 As Pca9545bTypeChannelSelection
    Get
    Set
public:
property Pca9545bTypeChannelSelection Channel1 {
    Pca9545bTypeChannelSelection get ();
    void set (Pca9545bTypeChannelSelection value);
}
member Channel1 : Pca9545bTypeChannelSelection with get, set

Property Value

Type: Pca9545bTypeChannelSelection
See Also

Reference

Pca9545b Class
telos.Ird.NXPSemiconductors Namespace


Pca9545b.Channel2 Property

IRD

Pca9545bChannel2 Property

Channel 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545bTypeChannelSelection Channel2 { get; set; }
Public Property Channel2 As Pca9545bTypeChannelSelection
    Get
    Set
public:
property Pca9545bTypeChannelSelection Channel2 {
    Pca9545bTypeChannelSelection get ();
    void set (Pca9545bTypeChannelSelection value);
}
member Channel2 : Pca9545bTypeChannelSelection with get, set

Property Value

Type: Pca9545bTypeChannelSelection
See Also

Reference

Pca9545b Class
telos.Ird.NXPSemiconductors Namespace


Pca9545b.Channel3 Property

IRD

Pca9545bChannel3 Property

Channel 3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545bTypeChannelSelection Channel3 { get; set; }
Public Property Channel3 As Pca9545bTypeChannelSelection
    Get
    Set
public:
property Pca9545bTypeChannelSelection Channel3 {
    Pca9545bTypeChannelSelection get ();
    void set (Pca9545bTypeChannelSelection value);
}
member Channel3 : Pca9545bTypeChannelSelection with get, set

Property Value

Type: Pca9545bTypeChannelSelection
See Also

Reference

Pca9545b Class
telos.Ird.NXPSemiconductors Namespace


Pca9545b.Interrupt0 Property

IRD

Pca9545bInterrupt0 Property

Interrupt 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545bTypeInt Interrupt0 { get; }
Public ReadOnly Property Interrupt0 As Pca9545bTypeInt
    Get
public:
property Pca9545bTypeInt Interrupt0 {
    Pca9545bTypeInt get ();
}
member Interrupt0 : Pca9545bTypeInt with get

Property Value

Type: Pca9545bTypeInt
See Also

Reference

Pca9545b Class
telos.Ird.NXPSemiconductors Namespace


Pca9545b.Interrupt1 Property

IRD

Pca9545bInterrupt1 Property

Interrupt 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545bTypeInt Interrupt1 { get; }
Public ReadOnly Property Interrupt1 As Pca9545bTypeInt
    Get
public:
property Pca9545bTypeInt Interrupt1 {
    Pca9545bTypeInt get ();
}
member Interrupt1 : Pca9545bTypeInt with get

Property Value

Type: Pca9545bTypeInt
See Also

Reference

Pca9545b Class
telos.Ird.NXPSemiconductors Namespace


Pca9545b.Interrupt2 Property

IRD

Pca9545bInterrupt2 Property

Interrupt 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545bTypeInt Interrupt2 { get; }
Public ReadOnly Property Interrupt2 As Pca9545bTypeInt
    Get
public:
property Pca9545bTypeInt Interrupt2 {
    Pca9545bTypeInt get ();
}
member Interrupt2 : Pca9545bTypeInt with get

Property Value

Type: Pca9545bTypeInt
See Also

Reference

Pca9545b Class
telos.Ird.NXPSemiconductors Namespace


Pca9545b.Interrupt3 Property

IRD

Pca9545bInterrupt3 Property

Interrupt 3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545bTypeInt Interrupt3 { get; }
Public ReadOnly Property Interrupt3 As Pca9545bTypeInt
    Get
public:
property Pca9545bTypeInt Interrupt3 {
    Pca9545bTypeInt get ();
}
member Interrupt3 : Pca9545bTypeInt with get

Property Value

Type: Pca9545bTypeInt
See Also

Reference

Pca9545b Class
telos.Ird.NXPSemiconductors Namespace


Pca9545b Methods

The Pca9545b type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9545b Class
telos.Ird.NXPSemiconductors Namespace


Pca9545b.Flush Method

IRD

Pca9545bFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9545b Class
telos.Ird.NXPSemiconductors Namespace


Pca9545b.TypeChannelSelection Enumeration

IRD

Pca9545bTypeChannelSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelSelection
Public Enumeration TypeChannelSelection
public enum class TypeChannelSelection
type TypeChannelSelection
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9545b.TypeInt Enumeration

IRD

Pca9545bTypeInt Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInt
Public Enumeration TypeInt
public enum class TypeInt
type TypeInt
Members
Member name | Value | Description
NoInterrupt | 0 | No interrupt
Interrupt | 1 | Interrupt
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9545c Class

NXP Semiconductors: PCA 9545 C
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9545c

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9545c
Public Class Pca9545c
public ref class Pca9545c
type Pca9545c =  class end

The Pca9545c type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9545c | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | Channel2 | Channel 2
Public property | Channel3 | Channel 3
Public property | Interrupt0 | Interrupt 0
Public property | Interrupt1 | Interrupt 1
Public property | Interrupt2 | Interrupt 2
Public property | Interrupt3 | Interrupt 3
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
4-Channel I2C-Bus Switch With Interrupt Logic And Reset
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9545c Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545c(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9545c(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9545c

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9545c Class
telos.Ird.NXPSemiconductors Namespace


Pca9545c Properties

The Pca9545c type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | Channel2 | Channel 2
Public property | Channel3 | Channel 3
Public property | Interrupt0 | Interrupt 0
Public property | Interrupt1 | Interrupt 1
Public property | Interrupt2 | Interrupt 2
Public property | Interrupt3 | Interrupt 3
Top
See Also

Reference

Pca9545c Class
telos.Ird.NXPSemiconductors Namespace


Pca9545c.AutoFlush Property

IRD

Pca9545cAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9545c Class
telos.Ird.NXPSemiconductors Namespace


Pca9545c.Channel0 Property

IRD

Pca9545cChannel0 Property

Channel 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545cTypeChannelSelection Channel0 { get; set; }
Public Property Channel0 As Pca9545cTypeChannelSelection
    Get
    Set
public:
property Pca9545cTypeChannelSelection Channel0 {
    Pca9545cTypeChannelSelection get ();
    void set (Pca9545cTypeChannelSelection value);
}
member Channel0 : Pca9545cTypeChannelSelection with get, set

Property Value

Type: Pca9545cTypeChannelSelection
See Also

Reference

Pca9545c Class
telos.Ird.NXPSemiconductors Namespace


Pca9545c.Channel1 Property

IRD

Pca9545cChannel1 Property

Channel 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545cTypeChannelSelection Channel1 { get; set; }
Public Property Channel1 As Pca9545cTypeChannelSelection
    Get
    Set
public:
property Pca9545cTypeChannelSelection Channel1 {
    Pca9545cTypeChannelSelection get ();
    void set (Pca9545cTypeChannelSelection value);
}
member Channel1 : Pca9545cTypeChannelSelection with get, set

Property Value

Type: Pca9545cTypeChannelSelection
See Also

Reference

Pca9545c Class
telos.Ird.NXPSemiconductors Namespace


Pca9545c.Channel2 Property

IRD

Pca9545cChannel2 Property

Channel 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545cTypeChannelSelection Channel2 { get; set; }
Public Property Channel2 As Pca9545cTypeChannelSelection
    Get
    Set
public:
property Pca9545cTypeChannelSelection Channel2 {
    Pca9545cTypeChannelSelection get ();
    void set (Pca9545cTypeChannelSelection value);
}
member Channel2 : Pca9545cTypeChannelSelection with get, set

Property Value

Type: Pca9545cTypeChannelSelection
See Also

Reference

Pca9545c Class
telos.Ird.NXPSemiconductors Namespace


Pca9545c.Channel3 Property

IRD

Pca9545cChannel3 Property

Channel 3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545cTypeChannelSelection Channel3 { get; set; }
Public Property Channel3 As Pca9545cTypeChannelSelection
    Get
    Set
public:
property Pca9545cTypeChannelSelection Channel3 {
    Pca9545cTypeChannelSelection get ();
    void set (Pca9545cTypeChannelSelection value);
}
member Channel3 : Pca9545cTypeChannelSelection with get, set

Property Value

Type: Pca9545cTypeChannelSelection
See Also

Reference

Pca9545c Class
telos.Ird.NXPSemiconductors Namespace


Pca9545c.Interrupt0 Property

IRD

Pca9545cInterrupt0 Property

Interrupt 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545cTypeInt Interrupt0 { get; }
Public ReadOnly Property Interrupt0 As Pca9545cTypeInt
    Get
public:
property Pca9545cTypeInt Interrupt0 {
    Pca9545cTypeInt get ();
}
member Interrupt0 : Pca9545cTypeInt with get

Property Value

Type: Pca9545cTypeInt
See Also

Reference

Pca9545c Class
telos.Ird.NXPSemiconductors Namespace


Pca9545c.Interrupt1 Property

IRD

Pca9545cInterrupt1 Property

Interrupt 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545cTypeInt Interrupt1 { get; }
Public ReadOnly Property Interrupt1 As Pca9545cTypeInt
    Get
public:
property Pca9545cTypeInt Interrupt1 {
    Pca9545cTypeInt get ();
}
member Interrupt1 : Pca9545cTypeInt with get

Property Value

Type: Pca9545cTypeInt
See Also

Reference

Pca9545c Class
telos.Ird.NXPSemiconductors Namespace


Pca9545c.Interrupt2 Property

IRD

Pca9545cInterrupt2 Property

Interrupt 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545cTypeInt Interrupt2 { get; }
Public ReadOnly Property Interrupt2 As Pca9545cTypeInt
    Get
public:
property Pca9545cTypeInt Interrupt2 {
    Pca9545cTypeInt get ();
}
member Interrupt2 : Pca9545cTypeInt with get

Property Value

Type: Pca9545cTypeInt
See Also

Reference

Pca9545c Class
telos.Ird.NXPSemiconductors Namespace


Pca9545c.Interrupt3 Property

IRD

Pca9545cInterrupt3 Property

Interrupt 3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545cTypeInt Interrupt3 { get; }
Public ReadOnly Property Interrupt3 As Pca9545cTypeInt
    Get
public:
property Pca9545cTypeInt Interrupt3 {
    Pca9545cTypeInt get ();
}
member Interrupt3 : Pca9545cTypeInt with get

Property Value

Type: Pca9545cTypeInt
See Also

Reference

Pca9545c Class
telos.Ird.NXPSemiconductors Namespace


Pca9545c Methods

The Pca9545c type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9545c Class
telos.Ird.NXPSemiconductors Namespace


Pca9545c.Flush Method

IRD

Pca9545cFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9545c Class
telos.Ird.NXPSemiconductors Namespace


Pca9545c.TypeChannelSelection Enumeration

IRD

Pca9545cTypeChannelSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelSelection
Public Enumeration TypeChannelSelection
public enum class TypeChannelSelection
type TypeChannelSelection
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9545c.TypeInt Enumeration

IRD

Pca9545cTypeInt Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInt
Public Enumeration TypeInt
public enum class TypeInt
type TypeInt
Members
Member name | Value | Description
NoInterrupt | 0 | No interrupt
Interrupt | 1 | Interrupt
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9546a Class

NXP Semiconductors: PCA 9546 A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9546a

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9546a
Public Class Pca9546a
public ref class Pca9546a
type Pca9546a =  class end

The Pca9546a type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9546a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | Channel2 | Channel 2
Public property | Channel3 | Channel 3
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
4-Channel I2C-Bus Switch With Reset
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9546a Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9546a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9546a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9546a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9546a Class
telos.Ird.NXPSemiconductors Namespace


Pca9546a Properties

The Pca9546a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | Channel2 | Channel 2
Public property | Channel3 | Channel 3
Top
See Also

Reference

Pca9546a Class
telos.Ird.NXPSemiconductors Namespace


Pca9546a.AutoFlush Property

IRD

Pca9546aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9546a Class
telos.Ird.NXPSemiconductors Namespace


Pca9546a.Channel0 Property

IRD

Pca9546aChannel0 Property

Channel 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9546aTypeChannelSelection Channel0 { get; set; }
Public Property Channel0 As Pca9546aTypeChannelSelection
    Get
    Set
public:
property Pca9546aTypeChannelSelection Channel0 {
    Pca9546aTypeChannelSelection get ();
    void set (Pca9546aTypeChannelSelection value);
}
member Channel0 : Pca9546aTypeChannelSelection with get, set

Property Value

Type: Pca9546aTypeChannelSelection
See Also

Reference

Pca9546a Class
telos.Ird.NXPSemiconductors Namespace


Pca9546a.Channel1 Property

IRD

Pca9546aChannel1 Property

Channel 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9546aTypeChannelSelection Channel1 { get; set; }
Public Property Channel1 As Pca9546aTypeChannelSelection
    Get
    Set
public:
property Pca9546aTypeChannelSelection Channel1 {
    Pca9546aTypeChannelSelection get ();
    void set (Pca9546aTypeChannelSelection value);
}
member Channel1 : Pca9546aTypeChannelSelection with get, set

Property Value

Type: Pca9546aTypeChannelSelection
See Also

Reference

Pca9546a Class
telos.Ird.NXPSemiconductors Namespace


Pca9546a.Channel2 Property

IRD

Pca9546aChannel2 Property

Channel 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9546aTypeChannelSelection Channel2 { get; set; }
Public Property Channel2 As Pca9546aTypeChannelSelection
    Get
    Set
public:
property Pca9546aTypeChannelSelection Channel2 {
    Pca9546aTypeChannelSelection get ();
    void set (Pca9546aTypeChannelSelection value);
}
member Channel2 : Pca9546aTypeChannelSelection with get, set

Property Value

Type: Pca9546aTypeChannelSelection
See Also

Reference

Pca9546a Class
telos.Ird.NXPSemiconductors Namespace


Pca9546a.Channel3 Property

IRD

Pca9546aChannel3 Property

Channel 3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9546aTypeChannelSelection Channel3 { get; set; }
Public Property Channel3 As Pca9546aTypeChannelSelection
    Get
    Set
public:
property Pca9546aTypeChannelSelection Channel3 {
    Pca9546aTypeChannelSelection get ();
    void set (Pca9546aTypeChannelSelection value);
}
member Channel3 : Pca9546aTypeChannelSelection with get, set

Property Value

Type: Pca9546aTypeChannelSelection
See Also

Reference

Pca9546a Class
telos.Ird.NXPSemiconductors Namespace


Pca9546a Methods

The Pca9546a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9546a Class
telos.Ird.NXPSemiconductors Namespace


Pca9546a.Flush Method

IRD

Pca9546aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9546a Class
telos.Ird.NXPSemiconductors Namespace


Pca9546a.TypeChannelSelection Enumeration

IRD

Pca9546aTypeChannelSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelSelection
Public Enumeration TypeChannelSelection
public enum class TypeChannelSelection
type TypeChannelSelection
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9547 Class

NXP Semiconductors: PCA 9547
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9547

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9547
Public Class Pca9547
public ref class Pca9547
type Pca9547 =  class end

The Pca9547 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9547 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelSelection | Channel Selection
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
8-Channel I2C-Bus Multiplexer With Reset
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9547 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9547(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9547(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9547

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9547 Class
telos.Ird.NXPSemiconductors Namespace


Pca9547 Properties

The Pca9547 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelSelection | Channel Selection
Top
See Also

Reference

Pca9547 Class
telos.Ird.NXPSemiconductors Namespace


Pca9547.AutoFlush Property

IRD

Pca9547AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9547 Class
telos.Ird.NXPSemiconductors Namespace


Pca9547.ChannelSelection Property

IRD

Pca9547ChannelSelection Property

Channel Selection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9547TypeChannelSelection ChannelSelection { get; set; }
Public Property ChannelSelection As Pca9547TypeChannelSelection
    Get
    Set
public:
property Pca9547TypeChannelSelection ChannelSelection {
    Pca9547TypeChannelSelection get ();
    void set (Pca9547TypeChannelSelection value);
}
member ChannelSelection : Pca9547TypeChannelSelection with get, set

Property Value

Type: Pca9547TypeChannelSelection
See Also

Reference

Pca9547 Class
telos.Ird.NXPSemiconductors Namespace


Pca9547 Methods

The Pca9547 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9547 Class
telos.Ird.NXPSemiconductors Namespace


Pca9547.Flush Method

IRD

Pca9547Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9547 Class
telos.Ird.NXPSemiconductors Namespace


Pca9547.TypeChannelSelection Enumeration

IRD

Pca9547TypeChannelSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelSelection
Public Enumeration TypeChannelSelection
public enum class TypeChannelSelection
type TypeChannelSelection
Members
Member name | Value | Description
NoChannelSelected | 0 | No channel selected
Channel0Enabled | 8 | Channel 0 enabled
Channel1Enabled | 9 | Channel 1 enabled
Channel2Enabled | 10 | Channel 2 enabled
Channel3Enabled | 11 | Channel 3 enabled
Channel4Enabled | 12 | Channel 4 enabled
Channel5Enabled | 13 | Channel 5 enabled
Channel6Enabled | 14 | Channel 6 enabled
Channel7Enabled | 15 | Channel 7 enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9548a Class

NXP Semiconductors: PCA 9548 A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9548a

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9548a
Public Class Pca9548a
public ref class Pca9548a
type Pca9548a =  class end

The Pca9548a type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9548a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | Channel2 | Channel 2
Public property | Channel3 | Channel 3
Public property | Channel4 | Channel 4
Public property | Channel5 | Channel 5
Public property | Channel6 | Channel 6
Public property | Channel7 | Channel 7
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
8-Channel I2C-Bus Switch With Reset
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9548a Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9548a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9548a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9548a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9548a Class
telos.Ird.NXPSemiconductors Namespace


Pca9548a Properties

The Pca9548a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | Channel2 | Channel 2
Public property | Channel3 | Channel 3
Public property | Channel4 | Channel 4
Public property | Channel5 | Channel 5
Public property | Channel6 | Channel 6
Public property | Channel7 | Channel 7
Top
See Also

Reference

Pca9548a Class
telos.Ird.NXPSemiconductors Namespace


Pca9548a.AutoFlush Property

IRD

Pca9548aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9548a Class
telos.Ird.NXPSemiconductors Namespace


Pca9548a.Channel0 Property

IRD

Pca9548aChannel0 Property

Channel 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9548aTypeChannelSelection Channel0 { get; set; }
Public Property Channel0 As Pca9548aTypeChannelSelection
    Get
    Set
public:
property Pca9548aTypeChannelSelection Channel0 {
    Pca9548aTypeChannelSelection get ();
    void set (Pca9548aTypeChannelSelection value);
}
member Channel0 : Pca9548aTypeChannelSelection with get, set

Property Value

Type: Pca9548aTypeChannelSelection
See Also

Reference

Pca9548a Class
telos.Ird.NXPSemiconductors Namespace


Pca9548a.Channel1 Property

IRD

Pca9548aChannel1 Property

Channel 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9548aTypeChannelSelection Channel1 { get; set; }
Public Property Channel1 As Pca9548aTypeChannelSelection
    Get
    Set
public:
property Pca9548aTypeChannelSelection Channel1 {
    Pca9548aTypeChannelSelection get ();
    void set (Pca9548aTypeChannelSelection value);
}
member Channel1 : Pca9548aTypeChannelSelection with get, set

Property Value

Type: Pca9548aTypeChannelSelection
See Also

Reference

Pca9548a Class
telos.Ird.NXPSemiconductors Namespace


Pca9548a.Channel2 Property

IRD

Pca9548aChannel2 Property

Channel 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9548aTypeChannelSelection Channel2 { get; set; }
Public Property Channel2 As Pca9548aTypeChannelSelection
    Get
    Set
public:
property Pca9548aTypeChannelSelection Channel2 {
    Pca9548aTypeChannelSelection get ();
    void set (Pca9548aTypeChannelSelection value);
}
member Channel2 : Pca9548aTypeChannelSelection with get, set

Property Value

Type: Pca9548aTypeChannelSelection
See Also

Reference

Pca9548a Class
telos.Ird.NXPSemiconductors Namespace


Pca9548a.Channel3 Property

IRD

Pca9548aChannel3 Property

Channel 3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9548aTypeChannelSelection Channel3 { get; set; }
Public Property Channel3 As Pca9548aTypeChannelSelection
    Get
    Set
public:
property Pca9548aTypeChannelSelection Channel3 {
    Pca9548aTypeChannelSelection get ();
    void set (Pca9548aTypeChannelSelection value);
}
member Channel3 : Pca9548aTypeChannelSelection with get, set

Property Value

Type: Pca9548aTypeChannelSelection
See Also

Reference

Pca9548a Class
telos.Ird.NXPSemiconductors Namespace


Pca9548a.Channel4 Property

IRD

Pca9548aChannel4 Property

Channel 4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9548aTypeChannelSelection Channel4 { get; set; }
Public Property Channel4 As Pca9548aTypeChannelSelection
    Get
    Set
public:
property Pca9548aTypeChannelSelection Channel4 {
    Pca9548aTypeChannelSelection get ();
    void set (Pca9548aTypeChannelSelection value);
}
member Channel4 : Pca9548aTypeChannelSelection with get, set

Property Value

Type: Pca9548aTypeChannelSelection
See Also

Reference

Pca9548a Class
telos.Ird.NXPSemiconductors Namespace


Pca9548a.Channel5 Property

IRD

Pca9548aChannel5 Property

Channel 5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9548aTypeChannelSelection Channel5 { get; set; }
Public Property Channel5 As Pca9548aTypeChannelSelection
    Get
    Set
public:
property Pca9548aTypeChannelSelection Channel5 {
    Pca9548aTypeChannelSelection get ();
    void set (Pca9548aTypeChannelSelection value);
}
member Channel5 : Pca9548aTypeChannelSelection with get, set

Property Value

Type: Pca9548aTypeChannelSelection
See Also

Reference

Pca9548a Class
telos.Ird.NXPSemiconductors Namespace


Pca9548a.Channel6 Property

IRD

Pca9548aChannel6 Property

Channel 6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9548aTypeChannelSelection Channel6 { get; set; }
Public Property Channel6 As Pca9548aTypeChannelSelection
    Get
    Set
public:
property Pca9548aTypeChannelSelection Channel6 {
    Pca9548aTypeChannelSelection get ();
    void set (Pca9548aTypeChannelSelection value);
}
member Channel6 : Pca9548aTypeChannelSelection with get, set

Property Value

Type: Pca9548aTypeChannelSelection
See Also

Reference

Pca9548a Class
telos.Ird.NXPSemiconductors Namespace


Pca9548a.Channel7 Property

IRD

Pca9548aChannel7 Property

Channel 7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9548aTypeChannelSelection Channel7 { get; set; }
Public Property Channel7 As Pca9548aTypeChannelSelection
    Get
    Set
public:
property Pca9548aTypeChannelSelection Channel7 {
    Pca9548aTypeChannelSelection get ();
    void set (Pca9548aTypeChannelSelection value);
}
member Channel7 : Pca9548aTypeChannelSelection with get, set

Property Value

Type: Pca9548aTypeChannelSelection
See Also

Reference

Pca9548a Class
telos.Ird.NXPSemiconductors Namespace


Pca9548a Methods

The Pca9548a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9548a Class
telos.Ird.NXPSemiconductors Namespace


Pca9548a.Flush Method

IRD

Pca9548aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9548a Class
telos.Ird.NXPSemiconductors Namespace


Pca9548a.TypeChannelSelection Enumeration

IRD

Pca9548aTypeChannelSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelSelection
Public Enumeration TypeChannelSelection
public enum class TypeChannelSelection
type TypeChannelSelection
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9549 Class

NXP Semiconductors: PCA 9549
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9549

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9549
Public Class Pca9549
public ref class Pca9549
type Pca9549 =  class end

The Pca9549 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9549 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel1 | Channel 1
Public property | Channel2 | Channel 2
Public property | Channel3 | Channel 3
Public property | Channel4 | Channel 4
Public property | Channel5 | Channel 5
Public property | Channel6 | Channel 6
Public property | Channel7 | Channel 7
Public property | Channel8 | Channel 8
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Octal Bus Switch With Individually I2C-Bus Controlled Enables
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9549 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9549(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9549(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9549

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9549 Class
telos.Ird.NXPSemiconductors Namespace


Pca9549 Properties

The Pca9549 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel1 | Channel 1
Public property | Channel2 | Channel 2
Public property | Channel3 | Channel 3
Public property | Channel4 | Channel 4
Public property | Channel5 | Channel 5
Public property | Channel6 | Channel 6
Public property | Channel7 | Channel 7
Public property | Channel8 | Channel 8
Top
See Also

Reference

Pca9549 Class
telos.Ird.NXPSemiconductors Namespace


Pca9549.AutoFlush Property

IRD

Pca9549AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9549 Class
telos.Ird.NXPSemiconductors Namespace


Pca9549.Channel1 Property

IRD

Pca9549Channel1 Property

Channel 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9549TypeChannelSelection Channel1 { get; set; }
Public Property Channel1 As Pca9549TypeChannelSelection
    Get
    Set
public:
property Pca9549TypeChannelSelection Channel1 {
    Pca9549TypeChannelSelection get ();
    void set (Pca9549TypeChannelSelection value);
}
member Channel1 : Pca9549TypeChannelSelection with get, set

Property Value

Type: Pca9549TypeChannelSelection
See Also

Reference

Pca9549 Class
telos.Ird.NXPSemiconductors Namespace


Pca9549.Channel2 Property

IRD

Pca9549Channel2 Property

Channel 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9549TypeChannelSelection Channel2 { get; set; }
Public Property Channel2 As Pca9549TypeChannelSelection
    Get
    Set
public:
property Pca9549TypeChannelSelection Channel2 {
    Pca9549TypeChannelSelection get ();
    void set (Pca9549TypeChannelSelection value);
}
member Channel2 : Pca9549TypeChannelSelection with get, set

Property Value

Type: Pca9549TypeChannelSelection
See Also

Reference

Pca9549 Class
telos.Ird.NXPSemiconductors Namespace


Pca9549.Channel3 Property

IRD

Pca9549Channel3 Property

Channel 3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9549TypeChannelSelection Channel3 { get; set; }
Public Property Channel3 As Pca9549TypeChannelSelection
    Get
    Set
public:
property Pca9549TypeChannelSelection Channel3 {
    Pca9549TypeChannelSelection get ();
    void set (Pca9549TypeChannelSelection value);
}
member Channel3 : Pca9549TypeChannelSelection with get, set

Property Value

Type: Pca9549TypeChannelSelection
See Also

Reference

Pca9549 Class
telos.Ird.NXPSemiconductors Namespace


Pca9549.Channel4 Property

IRD

Pca9549Channel4 Property

Channel 4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9549TypeChannelSelection Channel4 { get; set; }
Public Property Channel4 As Pca9549TypeChannelSelection
    Get
    Set
public:
property Pca9549TypeChannelSelection Channel4 {
    Pca9549TypeChannelSelection get ();
    void set (Pca9549TypeChannelSelection value);
}
member Channel4 : Pca9549TypeChannelSelection with get, set

Property Value

Type: Pca9549TypeChannelSelection
See Also

Reference

Pca9549 Class
telos.Ird.NXPSemiconductors Namespace


Pca9549.Channel5 Property

IRD

Pca9549Channel5 Property

Channel 5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9549TypeChannelSelection Channel5 { get; set; }
Public Property Channel5 As Pca9549TypeChannelSelection
    Get
    Set
public:
property Pca9549TypeChannelSelection Channel5 {
    Pca9549TypeChannelSelection get ();
    void set (Pca9549TypeChannelSelection value);
}
member Channel5 : Pca9549TypeChannelSelection with get, set

Property Value

Type: Pca9549TypeChannelSelection
See Also

Reference

Pca9549 Class
telos.Ird.NXPSemiconductors Namespace


Pca9549.Channel6 Property

IRD

Pca9549Channel6 Property

Channel 6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9549TypeChannelSelection Channel6 { get; set; }
Public Property Channel6 As Pca9549TypeChannelSelection
    Get
    Set
public:
property Pca9549TypeChannelSelection Channel6 {
    Pca9549TypeChannelSelection get ();
    void set (Pca9549TypeChannelSelection value);
}
member Channel6 : Pca9549TypeChannelSelection with get, set

Property Value

Type: Pca9549TypeChannelSelection
See Also

Reference

Pca9549 Class
telos.Ird.NXPSemiconductors Namespace


Pca9549.Channel7 Property

IRD

Pca9549Channel7 Property

Channel 7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9549TypeChannelSelection Channel7 { get; set; }
Public Property Channel7 As Pca9549TypeChannelSelection
    Get
    Set
public:
property Pca9549TypeChannelSelection Channel7 {
    Pca9549TypeChannelSelection get ();
    void set (Pca9549TypeChannelSelection value);
}
member Channel7 : Pca9549TypeChannelSelection with get, set

Property Value

Type: Pca9549TypeChannelSelection
See Also

Reference

Pca9549 Class
telos.Ird.NXPSemiconductors Namespace


Pca9549.Channel8 Property

IRD

Pca9549Channel8 Property

Channel 8

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9549TypeChannelSelection Channel8 { get; set; }
Public Property Channel8 As Pca9549TypeChannelSelection
    Get
    Set
public:
property Pca9549TypeChannelSelection Channel8 {
    Pca9549TypeChannelSelection get ();
    void set (Pca9549TypeChannelSelection value);
}
member Channel8 : Pca9549TypeChannelSelection with get, set

Property Value

Type: Pca9549TypeChannelSelection
See Also

Reference

Pca9549 Class
telos.Ird.NXPSemiconductors Namespace


Pca9549 Methods

The Pca9549 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9549 Class
telos.Ird.NXPSemiconductors Namespace


Pca9549.Flush Method

IRD

Pca9549Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9549 Class
telos.Ird.NXPSemiconductors Namespace


Pca9549.TypeChannelSelection Enumeration

IRD

Pca9549TypeChannelSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelSelection
Public Enumeration TypeChannelSelection
public enum class TypeChannelSelection
type TypeChannelSelection
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9550 Class

NXP Semiconductors: PCA 9550
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9550

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9550
Public Class Pca9550
public ref class Pca9550
type Pca9550 =  class end

The Pca9550 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9550 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FrequencyPrescaler0 | Frequency Prescaler 0
Public property | FrequencyPrescaler0AI | Frequency Prescaler 0 [AI]
Public property | FrequencyPrescaler1 | Frequency Prescaler 1
Public property | FrequencyPrescaler1AI | Frequency Prescaler 1 [AI]
Public property | InputLED0 | Input (LED0)
Public property | InputLED0AI | Input (LED0) [AI]
Public property | InputLED1 | Input (LED1)
Public property | InputLED1AI | Input (LED1) [AI]
Public property | LEDSelectorLED0 | LED Selector (LED 0)
Public property | LEDSelectorLED0AI | LED Selector (LED 0) [AI]
Public property | LEDSelectorLED1 | LED Selector (LED 1)
Public property | LEDSelectorLED1AI | LED Selector (LED 1) [AI]
Public property | PWM0 | PWM 0
Public property | PWM0AI | PWM 0 [AI]
Public property | PWM1 | PWM 1
Public property | PWM1AI | PWM 1 [AI]
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
2-Bit I2C-Bus LED Driver With Programmable Blink Rates
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9550 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9550(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9550(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9550

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550 Properties

The Pca9550 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FrequencyPrescaler0 | Frequency Prescaler 0
Public property | FrequencyPrescaler0AI | Frequency Prescaler 0 [AI]
Public property | FrequencyPrescaler1 | Frequency Prescaler 1
Public property | FrequencyPrescaler1AI | Frequency Prescaler 1 [AI]
Public property | InputLED0 | Input (LED0)
Public property | InputLED0AI | Input (LED0) [AI]
Public property | InputLED1 | Input (LED1)
Public property | InputLED1AI | Input (LED1) [AI]
Public property | LEDSelectorLED0 | LED Selector (LED 0)
Public property | LEDSelectorLED0AI | LED Selector (LED 0) [AI]
Public property | LEDSelectorLED1 | LED Selector (LED 1)
Public property | LEDSelectorLED1AI | LED Selector (LED 1) [AI]
Public property | PWM0 | PWM 0
Public property | PWM0AI | PWM 0 [AI]
Public property | PWM1 | PWM 1
Public property | PWM1AI | PWM 1 [AI]
Top
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.AutoFlush Property

IRD

Pca9550AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.FrequencyPrescaler0 Property

IRD

Pca9550FrequencyPrescaler0 Property

Frequency Prescaler 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler0 { get; set; }
Public Property FrequencyPrescaler0 As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler0 {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.FrequencyPrescaler0AI Property

IRD

Pca9550FrequencyPrescaler0AI Property

Frequency Prescaler 0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler0AI { get; set; }
Public Property FrequencyPrescaler0AI As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.FrequencyPrescaler1 Property

IRD

Pca9550FrequencyPrescaler1 Property

Frequency Prescaler 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler1 { get; set; }
Public Property FrequencyPrescaler1 As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler1 {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.FrequencyPrescaler1AI Property

IRD

Pca9550FrequencyPrescaler1AI Property

Frequency Prescaler 1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler1AI { get; set; }
Public Property FrequencyPrescaler1AI As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.InputLED0 Property

IRD

Pca9550InputLED0 Property

Input (LED0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9550TypeInput InputLED0 { get; }
Public ReadOnly Property InputLED0 As Pca9550TypeInput
    Get
public:
property Pca9550TypeInput InputLED0 {
    Pca9550TypeInput get ();
}
member InputLED0 : Pca9550TypeInput with get

Property Value

Type: Pca9550TypeInput
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.InputLED0AI Property

IRD

Pca9550InputLED0AI Property

Input (LED0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9550TypeInput InputLED0AI { get; }
Public ReadOnly Property InputLED0AI As Pca9550TypeInput
    Get
public:
property Pca9550TypeInput InputLED0AI {
    Pca9550TypeInput get ();
}
member InputLED0AI : Pca9550TypeInput with get

Property Value

Type: Pca9550TypeInput
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.InputLED1 Property

IRD

Pca9550InputLED1 Property

Input (LED1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9550TypeInput InputLED1 { get; }
Public ReadOnly Property InputLED1 As Pca9550TypeInput
    Get
public:
property Pca9550TypeInput InputLED1 {
    Pca9550TypeInput get ();
}
member InputLED1 : Pca9550TypeInput with get

Property Value

Type: Pca9550TypeInput
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.InputLED1AI Property

IRD

Pca9550InputLED1AI Property

Input (LED1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9550TypeInput InputLED1AI { get; }
Public ReadOnly Property InputLED1AI As Pca9550TypeInput
    Get
public:
property Pca9550TypeInput InputLED1AI {
    Pca9550TypeInput get ();
}
member InputLED1AI : Pca9550TypeInput with get

Property Value

Type: Pca9550TypeInput
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.LEDSelectorLED0 Property

IRD

Pca9550LEDSelectorLED0 Property

LED Selector (LED 0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9550TypeLedSelector LEDSelectorLED0 { get; set; }
Public Property LEDSelectorLED0 As Pca9550TypeLedSelector
    Get
    Set
public:
property Pca9550TypeLedSelector LEDSelectorLED0 {
    Pca9550TypeLedSelector get ();
    void set (Pca9550TypeLedSelector value);
}
member LEDSelectorLED0 : Pca9550TypeLedSelector with get, set

Property Value

Type: Pca9550TypeLedSelector
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.LEDSelectorLED0AI Property

IRD

Pca9550LEDSelectorLED0AI Property

LED Selector (LED 0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9550TypeLedSelector LEDSelectorLED0AI { get; set; }
Public Property LEDSelectorLED0AI As Pca9550TypeLedSelector
    Get
    Set
public:
property Pca9550TypeLedSelector LEDSelectorLED0AI {
    Pca9550TypeLedSelector get ();
    void set (Pca9550TypeLedSelector value);
}
member LEDSelectorLED0AI : Pca9550TypeLedSelector with get, set

Property Value

Type: Pca9550TypeLedSelector
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.LEDSelectorLED1 Property

IRD

Pca9550LEDSelectorLED1 Property

LED Selector (LED 1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9550TypeLedSelector LEDSelectorLED1 { get; set; }
Public Property LEDSelectorLED1 As Pca9550TypeLedSelector
    Get
    Set
public:
property Pca9550TypeLedSelector LEDSelectorLED1 {
    Pca9550TypeLedSelector get ();
    void set (Pca9550TypeLedSelector value);
}
member LEDSelectorLED1 : Pca9550TypeLedSelector with get, set

Property Value

Type: Pca9550TypeLedSelector
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.LEDSelectorLED1AI Property

IRD

Pca9550LEDSelectorLED1AI Property

LED Selector (LED 1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9550TypeLedSelector LEDSelectorLED1AI { get; set; }
Public Property LEDSelectorLED1AI As Pca9550TypeLedSelector
    Get
    Set
public:
property Pca9550TypeLedSelector LEDSelectorLED1AI {
    Pca9550TypeLedSelector get ();
    void set (Pca9550TypeLedSelector value);
}
member LEDSelectorLED1AI : Pca9550TypeLedSelector with get, set

Property Value

Type: Pca9550TypeLedSelector
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.PWM0 Property

IRD

Pca9550PWM0 Property

PWM 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM0 { get; set; }
Public Property PWM0 As Byte
    Get
    Set
public:
property unsigned char PWM0 {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.PWM0AI Property

IRD

Pca9550PWM0AI Property

PWM 0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM0AI { get; set; }
Public Property PWM0AI As Byte
    Get
    Set
public:
property unsigned char PWM0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.PWM1 Property

IRD

Pca9550PWM1 Property

PWM 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM1 { get; set; }
Public Property PWM1 As Byte
    Get
    Set
public:
property unsigned char PWM1 {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.PWM1AI Property

IRD

Pca9550PWM1AI Property

PWM 1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM1AI { get; set; }
Public Property PWM1AI As Byte
    Get
    Set
public:
property unsigned char PWM1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550 Methods

The Pca9550 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.Flush Method

IRD

Pca9550Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9550 Class
telos.Ird.NXPSemiconductors Namespace


Pca9550.TypeInput Enumeration

IRD

Pca9550TypeInput Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInput
Public Enumeration TypeInput
public enum class TypeInput
type TypeInput
Members
Member name | Value | Description
High | 1 | High
Low | 0 | Low
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9550.TypeLedSelector Enumeration

IRD

Pca9550TypeLedSelector Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedSelector
Public Enumeration TypeLedSelector
public enum class TypeLedSelector
type TypeLedSelector
Members
Member name | Value | Description
OutputIsSetLOWLEDOn | 0 | Output is set LOW (LED on)
OutputIsSetHighImpedanceLEDOff | 1 | Output is set high-impedance (LED off)
OutputBlinksAtPWM0Rate | 2 | Output blinks at PWM0 rate
OutputBlinksAtPWM1Rate | 3 | Output blinks at PWM1 rate
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9551 Class

NXP Semiconductors: PCA 9551
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9551

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9551
Public Class Pca9551
public ref class Pca9551
type Pca9551 =  class end

The Pca9551 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9551 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FrequencyPrescaler0 | Frequency Prescaler 0
Public property | FrequencyPrescaler0AI | Frequency Prescaler 0 [AI]
Public property | FrequencyPrescaler1 | Frequency Prescaler 1
Public property | FrequencyPrescaler1AI | Frequency Prescaler 1 [AI]
Public property | InputLED0 | Input (LED0)
Public property | InputLED0AI | Input (LED0) [AI]
Public property | InputLED1 | Input (LED1)
Public property | InputLED1AI | Input (LED1) [AI]
Public property | InputLED2 | Input (LED2)
Public property | InputLED2AI | Input (LED2) [AI]
Public property | InputLED3 | Input (LED3)
Public property | InputLED3AI | Input (LED3) [AI]
Public property | InputLED4 | Input (LED4)
Public property | InputLED4AI | Input (LED4) [AI]
Public property | InputLED5 | Input (LED5)
Public property | InputLED5AI | Input (LED5) [AI]
Public property | InputLED6 | Input (LED6)
Public property | InputLED6AI | Input (LED6) [AI]
Public property | InputLED7 | Input (LED7)
Public property | InputLED7AI | Input (LED7) [AI]
Public property | LEDSelectorLED0 | LED Selector (LED 0)
Public property | LEDSelectorLED0AI | LED Selector (LED 0) [AI]
Public property | LEDSelectorLED1 | LED Selector (LED 1)
Public property | LEDSelectorLED1AI | LED Selector (LED 1) [AI]
Public property | LEDSelectorLED2 | LED Selector (LED 2)
Public property | LEDSelectorLED2AI | LED Selector (LED 2) [AI]
Public property | LEDSelectorLED3 | LED Selector (LED 3)
Public property | LEDSelectorLED3AI | LED Selector (LED 3) [AI]
Public property | LEDSelectorLED4 | LED Selector (LED 4)
Public property | LEDSelectorLED4AI | LED Selector (LED 4) [AI]
Public property | LEDSelectorLED5 | LED Selector (LED 5)
Public property | LEDSelectorLED5AI | LED Selector (LED 5) [AI]
Public property | LEDSelectorLED6 | LED Selector (LED 6)
Public property | LEDSelectorLED6AI | LED Selector (LED 6) [AI]
Public property | LEDSelectorLED7 | LED Selector (LED 7)
Public property | LEDSelectorLED7AI | LED Selector (LED 7) [AI]
Public property | PWM0 | PWM 0
Public property | PWM0AI | PWM 0 [AI]
Public property | PWM1 | PWM 1
Public property | PWM1AI | PWM 1 [AI]
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
8-Bit I2C-Bus LED Driver With Programmable Blink Rates
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9551 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9551(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9551

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551 Properties

The Pca9551 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FrequencyPrescaler0 | Frequency Prescaler 0
Public property | FrequencyPrescaler0AI | Frequency Prescaler 0 [AI]
Public property | FrequencyPrescaler1 | Frequency Prescaler 1
Public property | FrequencyPrescaler1AI | Frequency Prescaler 1 [AI]
Public property | InputLED0 | Input (LED0)
Public property | InputLED0AI | Input (LED0) [AI]
Public property | InputLED1 | Input (LED1)
Public property | InputLED1AI | Input (LED1) [AI]
Public property | InputLED2 | Input (LED2)
Public property | InputLED2AI | Input (LED2) [AI]
Public property | InputLED3 | Input (LED3)
Public property | InputLED3AI | Input (LED3) [AI]
Public property | InputLED4 | Input (LED4)
Public property | InputLED4AI | Input (LED4) [AI]
Public property | InputLED5 | Input (LED5)
Public property | InputLED5AI | Input (LED5) [AI]
Public property | InputLED6 | Input (LED6)
Public property | InputLED6AI | Input (LED6) [AI]
Public property | InputLED7 | Input (LED7)
Public property | InputLED7AI | Input (LED7) [AI]
Public property | LEDSelectorLED0 | LED Selector (LED 0)
Public property | LEDSelectorLED0AI | LED Selector (LED 0) [AI]
Public property | LEDSelectorLED1 | LED Selector (LED 1)
Public property | LEDSelectorLED1AI | LED Selector (LED 1) [AI]
Public property | LEDSelectorLED2 | LED Selector (LED 2)
Public property | LEDSelectorLED2AI | LED Selector (LED 2) [AI]
Public property | LEDSelectorLED3 | LED Selector (LED 3)
Public property | LEDSelectorLED3AI | LED Selector (LED 3) [AI]
Public property | LEDSelectorLED4 | LED Selector (LED 4)
Public property | LEDSelectorLED4AI | LED Selector (LED 4) [AI]
Public property | LEDSelectorLED5 | LED Selector (LED 5)
Public property | LEDSelectorLED5AI | LED Selector (LED 5) [AI]
Public property | LEDSelectorLED6 | LED Selector (LED 6)
Public property | LEDSelectorLED6AI | LED Selector (LED 6) [AI]
Public property | LEDSelectorLED7 | LED Selector (LED 7)
Public property | LEDSelectorLED7AI | LED Selector (LED 7) [AI]
Public property | PWM0 | PWM 0
Public property | PWM0AI | PWM 0 [AI]
Public property | PWM1 | PWM 1
Public property | PWM1AI | PWM 1 [AI]
Top
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.AutoFlush Property

IRD

Pca9551AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.FrequencyPrescaler0 Property

IRD

Pca9551FrequencyPrescaler0 Property

Frequency Prescaler 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler0 { get; set; }
Public Property FrequencyPrescaler0 As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler0 {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.FrequencyPrescaler0AI Property

IRD

Pca9551FrequencyPrescaler0AI Property

Frequency Prescaler 0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler0AI { get; set; }
Public Property FrequencyPrescaler0AI As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.FrequencyPrescaler1 Property

IRD

Pca9551FrequencyPrescaler1 Property

Frequency Prescaler 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler1 { get; set; }
Public Property FrequencyPrescaler1 As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler1 {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.FrequencyPrescaler1AI Property

IRD

Pca9551FrequencyPrescaler1AI Property

Frequency Prescaler 1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler1AI { get; set; }
Public Property FrequencyPrescaler1AI As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.InputLED0 Property

IRD

Pca9551InputLED0 Property

Input (LED0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeInput InputLED0 { get; }
Public ReadOnly Property InputLED0 As Pca9551TypeInput
    Get
public:
property Pca9551TypeInput InputLED0 {
    Pca9551TypeInput get ();
}
member InputLED0 : Pca9551TypeInput with get

Property Value

Type: Pca9551TypeInput
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.InputLED0AI Property

IRD

Pca9551InputLED0AI Property

Input (LED0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeInput InputLED0AI { get; }
Public ReadOnly Property InputLED0AI As Pca9551TypeInput
    Get
public:
property Pca9551TypeInput InputLED0AI {
    Pca9551TypeInput get ();
}
member InputLED0AI : Pca9551TypeInput with get

Property Value

Type: Pca9551TypeInput
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.InputLED1 Property

IRD

Pca9551InputLED1 Property

Input (LED1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeInput InputLED1 { get; }
Public ReadOnly Property InputLED1 As Pca9551TypeInput
    Get
public:
property Pca9551TypeInput InputLED1 {
    Pca9551TypeInput get ();
}
member InputLED1 : Pca9551TypeInput with get

Property Value

Type: Pca9551TypeInput
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.InputLED1AI Property

IRD

Pca9551InputLED1AI Property

Input (LED1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeInput InputLED1AI { get; }
Public ReadOnly Property InputLED1AI As Pca9551TypeInput
    Get
public:
property Pca9551TypeInput InputLED1AI {
    Pca9551TypeInput get ();
}
member InputLED1AI : Pca9551TypeInput with get

Property Value

Type: Pca9551TypeInput
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.InputLED2 Property

IRD

Pca9551InputLED2 Property

Input (LED2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeInput InputLED2 { get; }
Public ReadOnly Property InputLED2 As Pca9551TypeInput
    Get
public:
property Pca9551TypeInput InputLED2 {
    Pca9551TypeInput get ();
}
member InputLED2 : Pca9551TypeInput with get

Property Value

Type: Pca9551TypeInput
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.InputLED2AI Property

IRD

Pca9551InputLED2AI Property

Input (LED2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeInput InputLED2AI { get; }
Public ReadOnly Property InputLED2AI As Pca9551TypeInput
    Get
public:
property Pca9551TypeInput InputLED2AI {
    Pca9551TypeInput get ();
}
member InputLED2AI : Pca9551TypeInput with get

Property Value

Type: Pca9551TypeInput
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.InputLED3 Property

IRD

Pca9551InputLED3 Property

Input (LED3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeInput InputLED3 { get; }
Public ReadOnly Property InputLED3 As Pca9551TypeInput
    Get
public:
property Pca9551TypeInput InputLED3 {
    Pca9551TypeInput get ();
}
member InputLED3 : Pca9551TypeInput with get

Property Value

Type: Pca9551TypeInput
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.InputLED3AI Property

IRD

Pca9551InputLED3AI Property

Input (LED3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeInput InputLED3AI { get; }
Public ReadOnly Property InputLED3AI As Pca9551TypeInput
    Get
public:
property Pca9551TypeInput InputLED3AI {
    Pca9551TypeInput get ();
}
member InputLED3AI : Pca9551TypeInput with get

Property Value

Type: Pca9551TypeInput
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.InputLED4 Property

IRD

Pca9551InputLED4 Property

Input (LED4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeInput InputLED4 { get; }
Public ReadOnly Property InputLED4 As Pca9551TypeInput
    Get
public:
property Pca9551TypeInput InputLED4 {
    Pca9551TypeInput get ();
}
member InputLED4 : Pca9551TypeInput with get

Property Value

Type: Pca9551TypeInput
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.InputLED4AI Property

IRD

Pca9551InputLED4AI Property

Input (LED4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeInput InputLED4AI { get; }
Public ReadOnly Property InputLED4AI As Pca9551TypeInput
    Get
public:
property Pca9551TypeInput InputLED4AI {
    Pca9551TypeInput get ();
}
member InputLED4AI : Pca9551TypeInput with get

Property Value

Type: Pca9551TypeInput
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.InputLED5 Property

IRD

Pca9551InputLED5 Property

Input (LED5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeInput InputLED5 { get; }
Public ReadOnly Property InputLED5 As Pca9551TypeInput
    Get
public:
property Pca9551TypeInput InputLED5 {
    Pca9551TypeInput get ();
}
member InputLED5 : Pca9551TypeInput with get

Property Value

Type: Pca9551TypeInput
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.InputLED5AI Property

IRD

Pca9551InputLED5AI Property

Input (LED5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeInput InputLED5AI { get; }
Public ReadOnly Property InputLED5AI As Pca9551TypeInput
    Get
public:
property Pca9551TypeInput InputLED5AI {
    Pca9551TypeInput get ();
}
member InputLED5AI : Pca9551TypeInput with get

Property Value

Type: Pca9551TypeInput
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.InputLED6 Property

IRD

Pca9551InputLED6 Property

Input (LED6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeInput InputLED6 { get; }
Public ReadOnly Property InputLED6 As Pca9551TypeInput
    Get
public:
property Pca9551TypeInput InputLED6 {
    Pca9551TypeInput get ();
}
member InputLED6 : Pca9551TypeInput with get

Property Value

Type: Pca9551TypeInput
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.InputLED6AI Property

IRD

Pca9551InputLED6AI Property

Input (LED6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeInput InputLED6AI { get; }
Public ReadOnly Property InputLED6AI As Pca9551TypeInput
    Get
public:
property Pca9551TypeInput InputLED6AI {
    Pca9551TypeInput get ();
}
member InputLED6AI : Pca9551TypeInput with get

Property Value

Type: Pca9551TypeInput
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.InputLED7 Property

IRD

Pca9551InputLED7 Property

Input (LED7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeInput InputLED7 { get; }
Public ReadOnly Property InputLED7 As Pca9551TypeInput
    Get
public:
property Pca9551TypeInput InputLED7 {
    Pca9551TypeInput get ();
}
member InputLED7 : Pca9551TypeInput with get

Property Value

Type: Pca9551TypeInput
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.InputLED7AI Property

IRD

Pca9551InputLED7AI Property

Input (LED7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeInput InputLED7AI { get; }
Public ReadOnly Property InputLED7AI As Pca9551TypeInput
    Get
public:
property Pca9551TypeInput InputLED7AI {
    Pca9551TypeInput get ();
}
member InputLED7AI : Pca9551TypeInput with get

Property Value

Type: Pca9551TypeInput
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.LEDSelectorLED0 Property

IRD

Pca9551LEDSelectorLED0 Property

LED Selector (LED 0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeLedSelector LEDSelectorLED0 { get; set; }
Public Property LEDSelectorLED0 As Pca9551TypeLedSelector
    Get
    Set
public:
property Pca9551TypeLedSelector LEDSelectorLED0 {
    Pca9551TypeLedSelector get ();
    void set (Pca9551TypeLedSelector value);
}
member LEDSelectorLED0 : Pca9551TypeLedSelector with get, set

Property Value

Type: Pca9551TypeLedSelector
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.LEDSelectorLED0AI Property

IRD

Pca9551LEDSelectorLED0AI Property

LED Selector (LED 0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeLedSelector LEDSelectorLED0AI { get; set; }
Public Property LEDSelectorLED0AI As Pca9551TypeLedSelector
    Get
    Set
public:
property Pca9551TypeLedSelector LEDSelectorLED0AI {
    Pca9551TypeLedSelector get ();
    void set (Pca9551TypeLedSelector value);
}
member LEDSelectorLED0AI : Pca9551TypeLedSelector with get, set

Property Value

Type: Pca9551TypeLedSelector
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.LEDSelectorLED1 Property

IRD

Pca9551LEDSelectorLED1 Property

LED Selector (LED 1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeLedSelector LEDSelectorLED1 { get; set; }
Public Property LEDSelectorLED1 As Pca9551TypeLedSelector
    Get
    Set
public:
property Pca9551TypeLedSelector LEDSelectorLED1 {
    Pca9551TypeLedSelector get ();
    void set (Pca9551TypeLedSelector value);
}
member LEDSelectorLED1 : Pca9551TypeLedSelector with get, set

Property Value

Type: Pca9551TypeLedSelector
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.LEDSelectorLED1AI Property

IRD

Pca9551LEDSelectorLED1AI Property

LED Selector (LED 1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeLedSelector LEDSelectorLED1AI { get; set; }
Public Property LEDSelectorLED1AI As Pca9551TypeLedSelector
    Get
    Set
public:
property Pca9551TypeLedSelector LEDSelectorLED1AI {
    Pca9551TypeLedSelector get ();
    void set (Pca9551TypeLedSelector value);
}
member LEDSelectorLED1AI : Pca9551TypeLedSelector with get, set

Property Value

Type: Pca9551TypeLedSelector
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.LEDSelectorLED2 Property

IRD

Pca9551LEDSelectorLED2 Property

LED Selector (LED 2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeLedSelector LEDSelectorLED2 { get; set; }
Public Property LEDSelectorLED2 As Pca9551TypeLedSelector
    Get
    Set
public:
property Pca9551TypeLedSelector LEDSelectorLED2 {
    Pca9551TypeLedSelector get ();
    void set (Pca9551TypeLedSelector value);
}
member LEDSelectorLED2 : Pca9551TypeLedSelector with get, set

Property Value

Type: Pca9551TypeLedSelector
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.LEDSelectorLED2AI Property

IRD

Pca9551LEDSelectorLED2AI Property

LED Selector (LED 2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeLedSelector LEDSelectorLED2AI { get; set; }
Public Property LEDSelectorLED2AI As Pca9551TypeLedSelector
    Get
    Set
public:
property Pca9551TypeLedSelector LEDSelectorLED2AI {
    Pca9551TypeLedSelector get ();
    void set (Pca9551TypeLedSelector value);
}
member LEDSelectorLED2AI : Pca9551TypeLedSelector with get, set

Property Value

Type: Pca9551TypeLedSelector
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.LEDSelectorLED3 Property

IRD

Pca9551LEDSelectorLED3 Property

LED Selector (LED 3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeLedSelector LEDSelectorLED3 { get; set; }
Public Property LEDSelectorLED3 As Pca9551TypeLedSelector
    Get
    Set
public:
property Pca9551TypeLedSelector LEDSelectorLED3 {
    Pca9551TypeLedSelector get ();
    void set (Pca9551TypeLedSelector value);
}
member LEDSelectorLED3 : Pca9551TypeLedSelector with get, set

Property Value

Type: Pca9551TypeLedSelector
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.LEDSelectorLED3AI Property

IRD

Pca9551LEDSelectorLED3AI Property

LED Selector (LED 3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeLedSelector LEDSelectorLED3AI { get; set; }
Public Property LEDSelectorLED3AI As Pca9551TypeLedSelector
    Get
    Set
public:
property Pca9551TypeLedSelector LEDSelectorLED3AI {
    Pca9551TypeLedSelector get ();
    void set (Pca9551TypeLedSelector value);
}
member LEDSelectorLED3AI : Pca9551TypeLedSelector with get, set

Property Value

Type: Pca9551TypeLedSelector
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.LEDSelectorLED4 Property

IRD

Pca9551LEDSelectorLED4 Property

LED Selector (LED 4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeLedSelector LEDSelectorLED4 { get; set; }
Public Property LEDSelectorLED4 As Pca9551TypeLedSelector
    Get
    Set
public:
property Pca9551TypeLedSelector LEDSelectorLED4 {
    Pca9551TypeLedSelector get ();
    void set (Pca9551TypeLedSelector value);
}
member LEDSelectorLED4 : Pca9551TypeLedSelector with get, set

Property Value

Type: Pca9551TypeLedSelector
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.LEDSelectorLED4AI Property

IRD

Pca9551LEDSelectorLED4AI Property

LED Selector (LED 4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeLedSelector LEDSelectorLED4AI { get; set; }
Public Property LEDSelectorLED4AI As Pca9551TypeLedSelector
    Get
    Set
public:
property Pca9551TypeLedSelector LEDSelectorLED4AI {
    Pca9551TypeLedSelector get ();
    void set (Pca9551TypeLedSelector value);
}
member LEDSelectorLED4AI : Pca9551TypeLedSelector with get, set

Property Value

Type: Pca9551TypeLedSelector
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.LEDSelectorLED5 Property

IRD

Pca9551LEDSelectorLED5 Property

LED Selector (LED 5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeLedSelector LEDSelectorLED5 { get; set; }
Public Property LEDSelectorLED5 As Pca9551TypeLedSelector
    Get
    Set
public:
property Pca9551TypeLedSelector LEDSelectorLED5 {
    Pca9551TypeLedSelector get ();
    void set (Pca9551TypeLedSelector value);
}
member LEDSelectorLED5 : Pca9551TypeLedSelector with get, set

Property Value

Type: Pca9551TypeLedSelector
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.LEDSelectorLED5AI Property

IRD

Pca9551LEDSelectorLED5AI Property

LED Selector (LED 5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeLedSelector LEDSelectorLED5AI { get; set; }
Public Property LEDSelectorLED5AI As Pca9551TypeLedSelector
    Get
    Set
public:
property Pca9551TypeLedSelector LEDSelectorLED5AI {
    Pca9551TypeLedSelector get ();
    void set (Pca9551TypeLedSelector value);
}
member LEDSelectorLED5AI : Pca9551TypeLedSelector with get, set

Property Value

Type: Pca9551TypeLedSelector
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.LEDSelectorLED6 Property

IRD

Pca9551LEDSelectorLED6 Property

LED Selector (LED 6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeLedSelector LEDSelectorLED6 { get; set; }
Public Property LEDSelectorLED6 As Pca9551TypeLedSelector
    Get
    Set
public:
property Pca9551TypeLedSelector LEDSelectorLED6 {
    Pca9551TypeLedSelector get ();
    void set (Pca9551TypeLedSelector value);
}
member LEDSelectorLED6 : Pca9551TypeLedSelector with get, set

Property Value

Type: Pca9551TypeLedSelector
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.LEDSelectorLED6AI Property

IRD

Pca9551LEDSelectorLED6AI Property

LED Selector (LED 6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeLedSelector LEDSelectorLED6AI { get; set; }
Public Property LEDSelectorLED6AI As Pca9551TypeLedSelector
    Get
    Set
public:
property Pca9551TypeLedSelector LEDSelectorLED6AI {
    Pca9551TypeLedSelector get ();
    void set (Pca9551TypeLedSelector value);
}
member LEDSelectorLED6AI : Pca9551TypeLedSelector with get, set

Property Value

Type: Pca9551TypeLedSelector
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.LEDSelectorLED7 Property

IRD

Pca9551LEDSelectorLED7 Property

LED Selector (LED 7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeLedSelector LEDSelectorLED7 { get; set; }
Public Property LEDSelectorLED7 As Pca9551TypeLedSelector
    Get
    Set
public:
property Pca9551TypeLedSelector LEDSelectorLED7 {
    Pca9551TypeLedSelector get ();
    void set (Pca9551TypeLedSelector value);
}
member LEDSelectorLED7 : Pca9551TypeLedSelector with get, set

Property Value

Type: Pca9551TypeLedSelector
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.LEDSelectorLED7AI Property

IRD

Pca9551LEDSelectorLED7AI Property

LED Selector (LED 7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9551TypeLedSelector LEDSelectorLED7AI { get; set; }
Public Property LEDSelectorLED7AI As Pca9551TypeLedSelector
    Get
    Set
public:
property Pca9551TypeLedSelector LEDSelectorLED7AI {
    Pca9551TypeLedSelector get ();
    void set (Pca9551TypeLedSelector value);
}
member LEDSelectorLED7AI : Pca9551TypeLedSelector with get, set

Property Value

Type: Pca9551TypeLedSelector
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.PWM0 Property

IRD

Pca9551PWM0 Property

PWM 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM0 { get; set; }
Public Property PWM0 As Byte
    Get
    Set
public:
property unsigned char PWM0 {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.PWM0AI Property

IRD

Pca9551PWM0AI Property

PWM 0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM0AI { get; set; }
Public Property PWM0AI As Byte
    Get
    Set
public:
property unsigned char PWM0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.PWM1 Property

IRD

Pca9551PWM1 Property

PWM 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM1 { get; set; }
Public Property PWM1 As Byte
    Get
    Set
public:
property unsigned char PWM1 {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.PWM1AI Property

IRD

Pca9551PWM1AI Property

PWM 1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM1AI { get; set; }
Public Property PWM1AI As Byte
    Get
    Set
public:
property unsigned char PWM1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551 Methods

The Pca9551 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.Flush Method

IRD

Pca9551Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9551 Class
telos.Ird.NXPSemiconductors Namespace


Pca9551.TypeInput Enumeration

IRD

Pca9551TypeInput Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInput
Public Enumeration TypeInput
public enum class TypeInput
type TypeInput
Members
Member name | Value | Description
High | 1 | High
Low | 0 | Low
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9551.TypeLedSelector Enumeration

IRD

Pca9551TypeLedSelector Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedSelector
Public Enumeration TypeLedSelector
public enum class TypeLedSelector
type TypeLedSelector
Members
Member name | Value | Description
OutputIsSetLOWLEDOn | 0 | Output is set LOW (LED on)
OutputIsSetHighImpedanceLEDOff | 1 | Output is set high-impedance (LED off)
OutputBlinksAtPWM0Rate | 2 | Output blinks at PWM0 rate
OutputBlinksAtPWM1Rate | 3 | Output blinks at PWM1 rate
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9552 Class

NXP Semiconductors: PCA 9552
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9552

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9552
Public Class Pca9552
public ref class Pca9552
type Pca9552 =  class end

The Pca9552 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9552 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FrequencyPrescaler0 | Frequency Prescaler 0
Public property | FrequencyPrescaler0AI | Frequency Prescaler 0 [AI]
Public property | FrequencyPrescaler1 | Frequency Prescaler 1
Public property | FrequencyPrescaler1AI | Frequency Prescaler 1 [AI]
Public property | InputLED0 | Input (LED0)
Public property | InputLED0AI | Input (LED0) [AI]
Public property | InputLED1 | Input (LED1)
Public property | InputLED10 | Input (LED10)
Public property | InputLED10AI | Input (LED10) [AI]
Public property | InputLED11 | Input (LED11)
Public property | InputLED11AI | Input (LED11) [AI]
Public property | InputLED12 | Input (LED12)
Public property | InputLED12AI | Input (LED12) [AI]
Public property | InputLED13 | Input (LED13)
Public property | InputLED13AI | Input (LED13) [AI]
Public property | InputLED14 | Input (LED14)
Public property | InputLED14AI | Input (LED14) [AI]
Public property | InputLED15 | Input (LED15)
Public property | InputLED15AI | Input (LED15) [AI]
Public property | InputLED1AI | Input (LED1) [AI]
Public property | InputLED2 | Input (LED2)
Public property | InputLED2AI | Input (LED2) [AI]
Public property | InputLED3 | Input (LED3)
Public property | InputLED3AI | Input (LED3) [AI]
Public property | InputLED4 | Input (LED4)
Public property | InputLED4AI | Input (LED4) [AI]
Public property | InputLED5 | Input (LED5)
Public property | InputLED5AI | Input (LED5) [AI]
Public property | InputLED6 | Input (LED6)
Public property | InputLED6AI | Input (LED6) [AI]
Public property | InputLED7 | Input (LED7)
Public property | InputLED7AI | Input (LED7) [AI]
Public property | InputLED8 | Input (LED8)
Public property | InputLED8AI | Input (LED8) [AI]
Public property | InputLED9 | Input (LED9)
Public property | InputLED9AI | Input (LED9) [AI]
Public property | LEDSelectorLED0 | LED Selector (LED 0)
Public property | LEDSelectorLED0AI | LED Selector (LED 0) [AI]
Public property | LEDSelectorLED1 | LED Selector (LED 1)
Public property | LEDSelectorLED10 | LED Selector (LED 10)
Public property | LEDSelectorLED10AI | LED Selector (LED 10) [AI]
Public property | LEDSelectorLED11 | LED Selector (LED 11)
Public property | LEDSelectorLED11AI | LED Selector (LED 11) [AI]
Public property | LEDSelectorLED12 | LED Selector (LED 12)
Public property | LEDSelectorLED12AI | LED Selector (LED 12) [AI]
Public property | LEDSelectorLED13 | LED Selector (LED 13)
Public property | LEDSelectorLED13AI | LED Selector (LED 13) [AI]
Public property | LEDSelectorLED14 | LED Selector (LED 14)
Public property | LEDSelectorLED14AI | LED Selector (LED 14) [AI]
Public property | LEDSelectorLED15 | LED Selector (LED 15)
Public property | LEDSelectorLED15AI | LED Selector (LED 15) [AI]
Public property | LEDSelectorLED1AI | LED Selector (LED 1) [AI]
Public property | LEDSelectorLED2 | LED Selector (LED 2)
Public property | LEDSelectorLED2AI | LED Selector (LED 2) [AI]
Public property | LEDSelectorLED3 | LED Selector (LED 3)
Public property | LEDSelectorLED3AI | LED Selector (LED 3) [AI]
Public property | LEDSelectorLED4 | LED Selector (LED 4)
Public property | LEDSelectorLED4AI | LED Selector (LED 4) [AI]
Public property | LEDSelectorLED5 | LED Selector (LED 5)
Public property | LEDSelectorLED5AI | LED Selector (LED 5) [AI]
Public property | LEDSelectorLED6 | LED Selector (LED 6)
Public property | LEDSelectorLED6AI | LED Selector (LED 6) [AI]
Public property | LEDSelectorLED7 | LED Selector (LED 7)
Public property | LEDSelectorLED7AI | LED Selector (LED 7) [AI]
Public property | LEDSelectorLED8 | LED Selector (LED 8)
Public property | LEDSelectorLED8AI | LED Selector (LED 8) [AI]
Public property | LEDSelectorLED9 | LED Selector (LED 9)
Public property | LEDSelectorLED9AI | LED Selector (LED 9) [AI]
Public property | PWM0 | PWM 0
Public property | PWM0AI | PWM 0 [AI]
Public property | PWM1 | PWM 1
Public property | PWM1AI | PWM 1 [AI]
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
16-Bit I2C-Bus LED Driver With Programmable Blink Rates
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9552 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9552(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9552

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552 Properties

The Pca9552 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FrequencyPrescaler0 | Frequency Prescaler 0
Public property | FrequencyPrescaler0AI | Frequency Prescaler 0 [AI]
Public property | FrequencyPrescaler1 | Frequency Prescaler 1
Public property | FrequencyPrescaler1AI | Frequency Prescaler 1 [AI]
Public property | InputLED0 | Input (LED0)
Public property | InputLED0AI | Input (LED0) [AI]
Public property | InputLED1 | Input (LED1)
Public property | InputLED10 | Input (LED10)
Public property | InputLED10AI | Input (LED10) [AI]
Public property | InputLED11 | Input (LED11)
Public property | InputLED11AI | Input (LED11) [AI]
Public property | InputLED12 | Input (LED12)
Public property | InputLED12AI | Input (LED12) [AI]
Public property | InputLED13 | Input (LED13)
Public property | InputLED13AI | Input (LED13) [AI]
Public property | InputLED14 | Input (LED14)
Public property | InputLED14AI | Input (LED14) [AI]
Public property | InputLED15 | Input (LED15)
Public property | InputLED15AI | Input (LED15) [AI]
Public property | InputLED1AI | Input (LED1) [AI]
Public property | InputLED2 | Input (LED2)
Public property | InputLED2AI | Input (LED2) [AI]
Public property | InputLED3 | Input (LED3)
Public property | InputLED3AI | Input (LED3) [AI]
Public property | InputLED4 | Input (LED4)
Public property | InputLED4AI | Input (LED4) [AI]
Public property | InputLED5 | Input (LED5)
Public property | InputLED5AI | Input (LED5) [AI]
Public property | InputLED6 | Input (LED6)
Public property | InputLED6AI | Input (LED6) [AI]
Public property | InputLED7 | Input (LED7)
Public property | InputLED7AI | Input (LED7) [AI]
Public property | InputLED8 | Input (LED8)
Public property | InputLED8AI | Input (LED8) [AI]
Public property | InputLED9 | Input (LED9)
Public property | InputLED9AI | Input (LED9) [AI]
Public property | LEDSelectorLED0 | LED Selector (LED 0)
Public property | LEDSelectorLED0AI | LED Selector (LED 0) [AI]
Public property | LEDSelectorLED1 | LED Selector (LED 1)
Public property | LEDSelectorLED10 | LED Selector (LED 10)
Public property | LEDSelectorLED10AI | LED Selector (LED 10) [AI]
Public property | LEDSelectorLED11 | LED Selector (LED 11)
Public property | LEDSelectorLED11AI | LED Selector (LED 11) [AI]
Public property | LEDSelectorLED12 | LED Selector (LED 12)
Public property | LEDSelectorLED12AI | LED Selector (LED 12) [AI]
Public property | LEDSelectorLED13 | LED Selector (LED 13)
Public property | LEDSelectorLED13AI | LED Selector (LED 13) [AI]
Public property | LEDSelectorLED14 | LED Selector (LED 14)
Public property | LEDSelectorLED14AI | LED Selector (LED 14) [AI]
Public property | LEDSelectorLED15 | LED Selector (LED 15)
Public property | LEDSelectorLED15AI | LED Selector (LED 15) [AI]
Public property | LEDSelectorLED1AI | LED Selector (LED 1) [AI]
Public property | LEDSelectorLED2 | LED Selector (LED 2)
Public property | LEDSelectorLED2AI | LED Selector (LED 2) [AI]
Public property | LEDSelectorLED3 | LED Selector (LED 3)
Public property | LEDSelectorLED3AI | LED Selector (LED 3) [AI]
Public property | LEDSelectorLED4 | LED Selector (LED 4)
Public property | LEDSelectorLED4AI | LED Selector (LED 4) [AI]
Public property | LEDSelectorLED5 | LED Selector (LED 5)
Public property | LEDSelectorLED5AI | LED Selector (LED 5) [AI]
Public property | LEDSelectorLED6 | LED Selector (LED 6)
Public property | LEDSelectorLED6AI | LED Selector (LED 6) [AI]
Public property | LEDSelectorLED7 | LED Selector (LED 7)
Public property | LEDSelectorLED7AI | LED Selector (LED 7) [AI]
Public property | LEDSelectorLED8 | LED Selector (LED 8)
Public property | LEDSelectorLED8AI | LED Selector (LED 8) [AI]
Public property | LEDSelectorLED9 | LED Selector (LED 9)
Public property | LEDSelectorLED9AI | LED Selector (LED 9) [AI]
Public property | PWM0 | PWM 0
Public property | PWM0AI | PWM 0 [AI]
Public property | PWM1 | PWM 1
Public property | PWM1AI | PWM 1 [AI]
Top
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.AutoFlush Property

IRD

Pca9552AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.FrequencyPrescaler0 Property

IRD

Pca9552FrequencyPrescaler0 Property

Frequency Prescaler 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler0 { get; set; }
Public Property FrequencyPrescaler0 As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler0 {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.FrequencyPrescaler0AI Property

IRD

Pca9552FrequencyPrescaler0AI Property

Frequency Prescaler 0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler0AI { get; set; }
Public Property FrequencyPrescaler0AI As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.FrequencyPrescaler1 Property

IRD

Pca9552FrequencyPrescaler1 Property

Frequency Prescaler 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler1 { get; set; }
Public Property FrequencyPrescaler1 As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler1 {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.FrequencyPrescaler1AI Property

IRD

Pca9552FrequencyPrescaler1AI Property

Frequency Prescaler 1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler1AI { get; set; }
Public Property FrequencyPrescaler1AI As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED0 Property

IRD

Pca9552InputLED0 Property

Input (LED0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED0 { get; }
Public ReadOnly Property InputLED0 As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED0 {
    Pca9552TypeInput get ();
}
member InputLED0 : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED0AI Property

IRD

Pca9552InputLED0AI Property

Input (LED0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED0AI { get; }
Public ReadOnly Property InputLED0AI As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED0AI {
    Pca9552TypeInput get ();
}
member InputLED0AI : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED1 Property

IRD

Pca9552InputLED1 Property

Input (LED1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED1 { get; }
Public ReadOnly Property InputLED1 As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED1 {
    Pca9552TypeInput get ();
}
member InputLED1 : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED10 Property

IRD

Pca9552InputLED10 Property

Input (LED10)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED10 { get; }
Public ReadOnly Property InputLED10 As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED10 {
    Pca9552TypeInput get ();
}
member InputLED10 : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED10AI Property

IRD

Pca9552InputLED10AI Property

Input (LED10) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED10AI { get; }
Public ReadOnly Property InputLED10AI As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED10AI {
    Pca9552TypeInput get ();
}
member InputLED10AI : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED11 Property

IRD

Pca9552InputLED11 Property

Input (LED11)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED11 { get; }
Public ReadOnly Property InputLED11 As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED11 {
    Pca9552TypeInput get ();
}
member InputLED11 : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED11AI Property

IRD

Pca9552InputLED11AI Property

Input (LED11) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED11AI { get; }
Public ReadOnly Property InputLED11AI As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED11AI {
    Pca9552TypeInput get ();
}
member InputLED11AI : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED12 Property

IRD

Pca9552InputLED12 Property

Input (LED12)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED12 { get; }
Public ReadOnly Property InputLED12 As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED12 {
    Pca9552TypeInput get ();
}
member InputLED12 : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED12AI Property

IRD

Pca9552InputLED12AI Property

Input (LED12) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED12AI { get; }
Public ReadOnly Property InputLED12AI As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED12AI {
    Pca9552TypeInput get ();
}
member InputLED12AI : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED13 Property

IRD

Pca9552InputLED13 Property

Input (LED13)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED13 { get; }
Public ReadOnly Property InputLED13 As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED13 {
    Pca9552TypeInput get ();
}
member InputLED13 : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED13AI Property

IRD

Pca9552InputLED13AI Property

Input (LED13) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED13AI { get; }
Public ReadOnly Property InputLED13AI As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED13AI {
    Pca9552TypeInput get ();
}
member InputLED13AI : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED14 Property

IRD

Pca9552InputLED14 Property

Input (LED14)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED14 { get; }
Public ReadOnly Property InputLED14 As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED14 {
    Pca9552TypeInput get ();
}
member InputLED14 : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED14AI Property

IRD

Pca9552InputLED14AI Property

Input (LED14) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED14AI { get; }
Public ReadOnly Property InputLED14AI As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED14AI {
    Pca9552TypeInput get ();
}
member InputLED14AI : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED15 Property

IRD

Pca9552InputLED15 Property

Input (LED15)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED15 { get; }
Public ReadOnly Property InputLED15 As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED15 {
    Pca9552TypeInput get ();
}
member InputLED15 : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED15AI Property

IRD

Pca9552InputLED15AI Property

Input (LED15) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED15AI { get; }
Public ReadOnly Property InputLED15AI As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED15AI {
    Pca9552TypeInput get ();
}
member InputLED15AI : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED1AI Property

IRD

Pca9552InputLED1AI Property

Input (LED1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED1AI { get; }
Public ReadOnly Property InputLED1AI As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED1AI {
    Pca9552TypeInput get ();
}
member InputLED1AI : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED2 Property

IRD

Pca9552InputLED2 Property

Input (LED2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED2 { get; }
Public ReadOnly Property InputLED2 As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED2 {
    Pca9552TypeInput get ();
}
member InputLED2 : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED2AI Property

IRD

Pca9552InputLED2AI Property

Input (LED2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED2AI { get; }
Public ReadOnly Property InputLED2AI As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED2AI {
    Pca9552TypeInput get ();
}
member InputLED2AI : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED3 Property

IRD

Pca9552InputLED3 Property

Input (LED3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED3 { get; }
Public ReadOnly Property InputLED3 As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED3 {
    Pca9552TypeInput get ();
}
member InputLED3 : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED3AI Property

IRD

Pca9552InputLED3AI Property

Input (LED3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED3AI { get; }
Public ReadOnly Property InputLED3AI As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED3AI {
    Pca9552TypeInput get ();
}
member InputLED3AI : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED4 Property

IRD

Pca9552InputLED4 Property

Input (LED4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED4 { get; }
Public ReadOnly Property InputLED4 As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED4 {
    Pca9552TypeInput get ();
}
member InputLED4 : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED4AI Property

IRD

Pca9552InputLED4AI Property

Input (LED4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED4AI { get; }
Public ReadOnly Property InputLED4AI As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED4AI {
    Pca9552TypeInput get ();
}
member InputLED4AI : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED5 Property

IRD

Pca9552InputLED5 Property

Input (LED5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED5 { get; }
Public ReadOnly Property InputLED5 As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED5 {
    Pca9552TypeInput get ();
}
member InputLED5 : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED5AI Property

IRD

Pca9552InputLED5AI Property

Input (LED5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED5AI { get; }
Public ReadOnly Property InputLED5AI As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED5AI {
    Pca9552TypeInput get ();
}
member InputLED5AI : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED6 Property

IRD

Pca9552InputLED6 Property

Input (LED6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED6 { get; }
Public ReadOnly Property InputLED6 As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED6 {
    Pca9552TypeInput get ();
}
member InputLED6 : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED6AI Property

IRD

Pca9552InputLED6AI Property

Input (LED6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED6AI { get; }
Public ReadOnly Property InputLED6AI As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED6AI {
    Pca9552TypeInput get ();
}
member InputLED6AI : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED7 Property

IRD

Pca9552InputLED7 Property

Input (LED7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED7 { get; }
Public ReadOnly Property InputLED7 As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED7 {
    Pca9552TypeInput get ();
}
member InputLED7 : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED7AI Property

IRD

Pca9552InputLED7AI Property

Input (LED7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED7AI { get; }
Public ReadOnly Property InputLED7AI As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED7AI {
    Pca9552TypeInput get ();
}
member InputLED7AI : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED8 Property

IRD

Pca9552InputLED8 Property

Input (LED8)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED8 { get; }
Public ReadOnly Property InputLED8 As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED8 {
    Pca9552TypeInput get ();
}
member InputLED8 : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED8AI Property

IRD

Pca9552InputLED8AI Property

Input (LED8) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED8AI { get; }
Public ReadOnly Property InputLED8AI As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED8AI {
    Pca9552TypeInput get ();
}
member InputLED8AI : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED9 Property

IRD

Pca9552InputLED9 Property

Input (LED9)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED9 { get; }
Public ReadOnly Property InputLED9 As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED9 {
    Pca9552TypeInput get ();
}
member InputLED9 : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.InputLED9AI Property

IRD

Pca9552InputLED9AI Property

Input (LED9) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeInput InputLED9AI { get; }
Public ReadOnly Property InputLED9AI As Pca9552TypeInput
    Get
public:
property Pca9552TypeInput InputLED9AI {
    Pca9552TypeInput get ();
}
member InputLED9AI : Pca9552TypeInput with get

Property Value

Type: Pca9552TypeInput
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED0 Property

IRD

Pca9552LEDSelectorLED0 Property

LED Selector (LED 0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED0 { get; set; }
Public Property LEDSelectorLED0 As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED0 {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED0 : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED0AI Property

IRD

Pca9552LEDSelectorLED0AI Property

LED Selector (LED 0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED0AI { get; set; }
Public Property LEDSelectorLED0AI As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED0AI {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED0AI : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED1 Property

IRD

Pca9552LEDSelectorLED1 Property

LED Selector (LED 1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED1 { get; set; }
Public Property LEDSelectorLED1 As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED1 {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED1 : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED10 Property

IRD

Pca9552LEDSelectorLED10 Property

LED Selector (LED 10)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED10 { get; set; }
Public Property LEDSelectorLED10 As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED10 {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED10 : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED10AI Property

IRD

Pca9552LEDSelectorLED10AI Property

LED Selector (LED 10) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED10AI { get; set; }
Public Property LEDSelectorLED10AI As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED10AI {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED10AI : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED11 Property

IRD

Pca9552LEDSelectorLED11 Property

LED Selector (LED 11)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED11 { get; set; }
Public Property LEDSelectorLED11 As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED11 {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED11 : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED11AI Property

IRD

Pca9552LEDSelectorLED11AI Property

LED Selector (LED 11) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED11AI { get; set; }
Public Property LEDSelectorLED11AI As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED11AI {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED11AI : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED12 Property

IRD

Pca9552LEDSelectorLED12 Property

LED Selector (LED 12)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED12 { get; set; }
Public Property LEDSelectorLED12 As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED12 {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED12 : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED12AI Property

IRD

Pca9552LEDSelectorLED12AI Property

LED Selector (LED 12) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED12AI { get; set; }
Public Property LEDSelectorLED12AI As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED12AI {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED12AI : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED13 Property

IRD

Pca9552LEDSelectorLED13 Property

LED Selector (LED 13)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED13 { get; set; }
Public Property LEDSelectorLED13 As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED13 {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED13 : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED13AI Property

IRD

Pca9552LEDSelectorLED13AI Property

LED Selector (LED 13) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED13AI { get; set; }
Public Property LEDSelectorLED13AI As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED13AI {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED13AI : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED14 Property

IRD

Pca9552LEDSelectorLED14 Property

LED Selector (LED 14)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED14 { get; set; }
Public Property LEDSelectorLED14 As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED14 {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED14 : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED14AI Property

IRD

Pca9552LEDSelectorLED14AI Property

LED Selector (LED 14) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED14AI { get; set; }
Public Property LEDSelectorLED14AI As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED14AI {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED14AI : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED15 Property

IRD

Pca9552LEDSelectorLED15 Property

LED Selector (LED 15)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED15 { get; set; }
Public Property LEDSelectorLED15 As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED15 {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED15 : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED15AI Property

IRD

Pca9552LEDSelectorLED15AI Property

LED Selector (LED 15) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED15AI { get; set; }
Public Property LEDSelectorLED15AI As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED15AI {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED15AI : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED1AI Property

IRD

Pca9552LEDSelectorLED1AI Property

LED Selector (LED 1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED1AI { get; set; }
Public Property LEDSelectorLED1AI As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED1AI {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED1AI : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED2 Property

IRD

Pca9552LEDSelectorLED2 Property

LED Selector (LED 2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED2 { get; set; }
Public Property LEDSelectorLED2 As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED2 {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED2 : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED2AI Property

IRD

Pca9552LEDSelectorLED2AI Property

LED Selector (LED 2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED2AI { get; set; }
Public Property LEDSelectorLED2AI As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED2AI {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED2AI : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED3 Property

IRD

Pca9552LEDSelectorLED3 Property

LED Selector (LED 3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED3 { get; set; }
Public Property LEDSelectorLED3 As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED3 {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED3 : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED3AI Property

IRD

Pca9552LEDSelectorLED3AI Property

LED Selector (LED 3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED3AI { get; set; }
Public Property LEDSelectorLED3AI As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED3AI {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED3AI : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED4 Property

IRD

Pca9552LEDSelectorLED4 Property

LED Selector (LED 4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED4 { get; set; }
Public Property LEDSelectorLED4 As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED4 {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED4 : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED4AI Property

IRD

Pca9552LEDSelectorLED4AI Property

LED Selector (LED 4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED4AI { get; set; }
Public Property LEDSelectorLED4AI As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED4AI {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED4AI : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED5 Property

IRD

Pca9552LEDSelectorLED5 Property

LED Selector (LED 5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED5 { get; set; }
Public Property LEDSelectorLED5 As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED5 {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED5 : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED5AI Property

IRD

Pca9552LEDSelectorLED5AI Property

LED Selector (LED 5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED5AI { get; set; }
Public Property LEDSelectorLED5AI As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED5AI {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED5AI : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED6 Property

IRD

Pca9552LEDSelectorLED6 Property

LED Selector (LED 6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED6 { get; set; }
Public Property LEDSelectorLED6 As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED6 {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED6 : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED6AI Property

IRD

Pca9552LEDSelectorLED6AI Property

LED Selector (LED 6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED6AI { get; set; }
Public Property LEDSelectorLED6AI As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED6AI {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED6AI : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED7 Property

IRD

Pca9552LEDSelectorLED7 Property

LED Selector (LED 7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED7 { get; set; }
Public Property LEDSelectorLED7 As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED7 {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED7 : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED7AI Property

IRD

Pca9552LEDSelectorLED7AI Property

LED Selector (LED 7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED7AI { get; set; }
Public Property LEDSelectorLED7AI As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED7AI {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED7AI : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED8 Property

IRD

Pca9552LEDSelectorLED8 Property

LED Selector (LED 8)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED8 { get; set; }
Public Property LEDSelectorLED8 As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED8 {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED8 : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED8AI Property

IRD

Pca9552LEDSelectorLED8AI Property

LED Selector (LED 8) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED8AI { get; set; }
Public Property LEDSelectorLED8AI As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED8AI {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED8AI : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED9 Property

IRD

Pca9552LEDSelectorLED9 Property

LED Selector (LED 9)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED9 { get; set; }
Public Property LEDSelectorLED9 As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED9 {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED9 : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.LEDSelectorLED9AI Property

IRD

Pca9552LEDSelectorLED9AI Property

LED Selector (LED 9) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9552TypeLedSelector LEDSelectorLED9AI { get; set; }
Public Property LEDSelectorLED9AI As Pca9552TypeLedSelector
    Get
    Set
public:
property Pca9552TypeLedSelector LEDSelectorLED9AI {
    Pca9552TypeLedSelector get ();
    void set (Pca9552TypeLedSelector value);
}
member LEDSelectorLED9AI : Pca9552TypeLedSelector with get, set

Property Value

Type: Pca9552TypeLedSelector
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.PWM0 Property

IRD

Pca9552PWM0 Property

PWM 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM0 { get; set; }
Public Property PWM0 As Byte
    Get
    Set
public:
property unsigned char PWM0 {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.PWM0AI Property

IRD

Pca9552PWM0AI Property

PWM 0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM0AI { get; set; }
Public Property PWM0AI As Byte
    Get
    Set
public:
property unsigned char PWM0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.PWM1 Property

IRD

Pca9552PWM1 Property

PWM 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM1 { get; set; }
Public Property PWM1 As Byte
    Get
    Set
public:
property unsigned char PWM1 {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.PWM1AI Property

IRD

Pca9552PWM1AI Property

PWM 1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM1AI { get; set; }
Public Property PWM1AI As Byte
    Get
    Set
public:
property unsigned char PWM1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552 Methods

The Pca9552 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.Flush Method

IRD

Pca9552Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9552 Class
telos.Ird.NXPSemiconductors Namespace


Pca9552.TypeInput Enumeration

IRD

Pca9552TypeInput Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInput
Public Enumeration TypeInput
public enum class TypeInput
type TypeInput
Members
Member name | Value | Description
High | 1 | High
Low | 0 | Low
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9552.TypeLedSelector Enumeration

IRD

Pca9552TypeLedSelector Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedSelector
Public Enumeration TypeLedSelector
public enum class TypeLedSelector
type TypeLedSelector
Members
Member name | Value | Description
OutputIsSetLOWLEDOn | 0 | Output is set LOW (LED on)
OutputIsSetHighImpedanceLEDOff | 1 | Output is set high-impedance (LED off)
OutputBlinksAtPWM0Rate | 2 | Output blinks at PWM0 rate
OutputBlinksAtPWM1Rate | 3 | Output blinks at PWM1 rate
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9553 Class

NXP Semiconductors: PCA 9553
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9553

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9553
Public Class Pca9553
public ref class Pca9553
type Pca9553 =  class end

The Pca9553 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9553 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FrequencyPrescaler0 | Frequency Prescaler 0
Public property | FrequencyPrescaler0AI | Frequency Prescaler 0 [AI]
Public property | FrequencyPrescaler1 | Frequency Prescaler 1
Public property | FrequencyPrescaler1AI | Frequency Prescaler 1 [AI]
Public property | InputLED0 | Input (LED0)
Public property | InputLED1 | Input (LED1)
Public property | InputLED2 | Input (LED2)
Public property | InputLED3 | Input (LED3)
Public property | LEDSelectorLED0 | LED Selector (LED 0)
Public property | LEDSelectorLED0AI | LED Selector (LED 0) [AI]
Public property | LEDSelectorLED1 | LED Selector (LED 1)
Public property | LEDSelectorLED1AI | LED Selector (LED 1) [AI]
Public property | LEDSelectorLED2 | LED Selector (LED 2)
Public property | LEDSelectorLED2AI | LED Selector (LED 2) [AI]
Public property | LEDSelectorLED3 | LED Selector (LED 3)
Public property | LEDSelectorLED3AI | LED Selector (LED 3) [AI]
Public property | PWM0 | PWM 0
Public property | PWM0AI | PWM 0 [AI]
Public property | PWM1 | PWM 1
Public property | PWM1AI | PWM 1 [AI]
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
8-Bit I2C-Bus LED Driver With Programmable Blink Rates
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9553 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9553(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9553(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9553

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553 Properties

The Pca9553 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FrequencyPrescaler0 | Frequency Prescaler 0
Public property | FrequencyPrescaler0AI | Frequency Prescaler 0 [AI]
Public property | FrequencyPrescaler1 | Frequency Prescaler 1
Public property | FrequencyPrescaler1AI | Frequency Prescaler 1 [AI]
Public property | InputLED0 | Input (LED0)
Public property | InputLED1 | Input (LED1)
Public property | InputLED2 | Input (LED2)
Public property | InputLED3 | Input (LED3)
Public property | LEDSelectorLED0 | LED Selector (LED 0)
Public property | LEDSelectorLED0AI | LED Selector (LED 0) [AI]
Public property | LEDSelectorLED1 | LED Selector (LED 1)
Public property | LEDSelectorLED1AI | LED Selector (LED 1) [AI]
Public property | LEDSelectorLED2 | LED Selector (LED 2)
Public property | LEDSelectorLED2AI | LED Selector (LED 2) [AI]
Public property | LEDSelectorLED3 | LED Selector (LED 3)
Public property | LEDSelectorLED3AI | LED Selector (LED 3) [AI]
Public property | PWM0 | PWM 0
Public property | PWM0AI | PWM 0 [AI]
Public property | PWM1 | PWM 1
Public property | PWM1AI | PWM 1 [AI]
Top
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.AutoFlush Property

IRD

Pca9553AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.FrequencyPrescaler0 Property

IRD

Pca9553FrequencyPrescaler0 Property

Frequency Prescaler 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler0 { get; set; }
Public Property FrequencyPrescaler0 As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler0 {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.FrequencyPrescaler0AI Property

IRD

Pca9553FrequencyPrescaler0AI Property

Frequency Prescaler 0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler0AI { get; set; }
Public Property FrequencyPrescaler0AI As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.FrequencyPrescaler1 Property

IRD

Pca9553FrequencyPrescaler1 Property

Frequency Prescaler 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler1 { get; set; }
Public Property FrequencyPrescaler1 As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler1 {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.FrequencyPrescaler1AI Property

IRD

Pca9553FrequencyPrescaler1AI Property

Frequency Prescaler 1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyPrescaler1AI { get; set; }
Public Property FrequencyPrescaler1AI As Byte
    Get
    Set
public:
property unsigned char FrequencyPrescaler1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyPrescaler1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.InputLED0 Property

IRD

Pca9553InputLED0 Property

Input (LED0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9553TypeInput InputLED0 { get; }
Public ReadOnly Property InputLED0 As Pca9553TypeInput
    Get
public:
property Pca9553TypeInput InputLED0 {
    Pca9553TypeInput get ();
}
member InputLED0 : Pca9553TypeInput with get

Property Value

Type: Pca9553TypeInput
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.InputLED1 Property

IRD

Pca9553InputLED1 Property

Input (LED1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9553TypeInput InputLED1 { get; }
Public ReadOnly Property InputLED1 As Pca9553TypeInput
    Get
public:
property Pca9553TypeInput InputLED1 {
    Pca9553TypeInput get ();
}
member InputLED1 : Pca9553TypeInput with get

Property Value

Type: Pca9553TypeInput
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.InputLED2 Property

IRD

Pca9553InputLED2 Property

Input (LED2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9553TypeInput InputLED2 { get; }
Public ReadOnly Property InputLED2 As Pca9553TypeInput
    Get
public:
property Pca9553TypeInput InputLED2 {
    Pca9553TypeInput get ();
}
member InputLED2 : Pca9553TypeInput with get

Property Value

Type: Pca9553TypeInput
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.InputLED3 Property

IRD

Pca9553InputLED3 Property

Input (LED3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9553TypeInput InputLED3 { get; }
Public ReadOnly Property InputLED3 As Pca9553TypeInput
    Get
public:
property Pca9553TypeInput InputLED3 {
    Pca9553TypeInput get ();
}
member InputLED3 : Pca9553TypeInput with get

Property Value

Type: Pca9553TypeInput
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.LEDSelectorLED0 Property

IRD

Pca9553LEDSelectorLED0 Property

LED Selector (LED 0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9553TypeLedSelector LEDSelectorLED0 { get; set; }
Public Property LEDSelectorLED0 As Pca9553TypeLedSelector
    Get
    Set
public:
property Pca9553TypeLedSelector LEDSelectorLED0 {
    Pca9553TypeLedSelector get ();
    void set (Pca9553TypeLedSelector value);
}
member LEDSelectorLED0 : Pca9553TypeLedSelector with get, set

Property Value

Type: Pca9553TypeLedSelector
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.LEDSelectorLED0AI Property

IRD

Pca9553LEDSelectorLED0AI Property

LED Selector (LED 0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9553TypeLedSelector LEDSelectorLED0AI { get; set; }
Public Property LEDSelectorLED0AI As Pca9553TypeLedSelector
    Get
    Set
public:
property Pca9553TypeLedSelector LEDSelectorLED0AI {
    Pca9553TypeLedSelector get ();
    void set (Pca9553TypeLedSelector value);
}
member LEDSelectorLED0AI : Pca9553TypeLedSelector with get, set

Property Value

Type: Pca9553TypeLedSelector
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.LEDSelectorLED1 Property

IRD

Pca9553LEDSelectorLED1 Property

LED Selector (LED 1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9553TypeLedSelector LEDSelectorLED1 { get; set; }
Public Property LEDSelectorLED1 As Pca9553TypeLedSelector
    Get
    Set
public:
property Pca9553TypeLedSelector LEDSelectorLED1 {
    Pca9553TypeLedSelector get ();
    void set (Pca9553TypeLedSelector value);
}
member LEDSelectorLED1 : Pca9553TypeLedSelector with get, set

Property Value

Type: Pca9553TypeLedSelector
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.LEDSelectorLED1AI Property

IRD

Pca9553LEDSelectorLED1AI Property

LED Selector (LED 1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9553TypeLedSelector LEDSelectorLED1AI { get; set; }
Public Property LEDSelectorLED1AI As Pca9553TypeLedSelector
    Get
    Set
public:
property Pca9553TypeLedSelector LEDSelectorLED1AI {
    Pca9553TypeLedSelector get ();
    void set (Pca9553TypeLedSelector value);
}
member LEDSelectorLED1AI : Pca9553TypeLedSelector with get, set

Property Value

Type: Pca9553TypeLedSelector
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.LEDSelectorLED2 Property

IRD

Pca9553LEDSelectorLED2 Property

LED Selector (LED 2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9553TypeLedSelector LEDSelectorLED2 { get; set; }
Public Property LEDSelectorLED2 As Pca9553TypeLedSelector
    Get
    Set
public:
property Pca9553TypeLedSelector LEDSelectorLED2 {
    Pca9553TypeLedSelector get ();
    void set (Pca9553TypeLedSelector value);
}
member LEDSelectorLED2 : Pca9553TypeLedSelector with get, set

Property Value

Type: Pca9553TypeLedSelector
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.LEDSelectorLED2AI Property

IRD

Pca9553LEDSelectorLED2AI Property

LED Selector (LED 2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9553TypeLedSelector LEDSelectorLED2AI { get; set; }
Public Property LEDSelectorLED2AI As Pca9553TypeLedSelector
    Get
    Set
public:
property Pca9553TypeLedSelector LEDSelectorLED2AI {
    Pca9553TypeLedSelector get ();
    void set (Pca9553TypeLedSelector value);
}
member LEDSelectorLED2AI : Pca9553TypeLedSelector with get, set

Property Value

Type: Pca9553TypeLedSelector
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.LEDSelectorLED3 Property

IRD

Pca9553LEDSelectorLED3 Property

LED Selector (LED 3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9553TypeLedSelector LEDSelectorLED3 { get; set; }
Public Property LEDSelectorLED3 As Pca9553TypeLedSelector
    Get
    Set
public:
property Pca9553TypeLedSelector LEDSelectorLED3 {
    Pca9553TypeLedSelector get ();
    void set (Pca9553TypeLedSelector value);
}
member LEDSelectorLED3 : Pca9553TypeLedSelector with get, set

Property Value

Type: Pca9553TypeLedSelector
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.LEDSelectorLED3AI Property

IRD

Pca9553LEDSelectorLED3AI Property

LED Selector (LED 3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9553TypeLedSelector LEDSelectorLED3AI { get; set; }
Public Property LEDSelectorLED3AI As Pca9553TypeLedSelector
    Get
    Set
public:
property Pca9553TypeLedSelector LEDSelectorLED3AI {
    Pca9553TypeLedSelector get ();
    void set (Pca9553TypeLedSelector value);
}
member LEDSelectorLED3AI : Pca9553TypeLedSelector with get, set

Property Value

Type: Pca9553TypeLedSelector
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.PWM0 Property

IRD

Pca9553PWM0 Property

PWM 0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM0 { get; set; }
Public Property PWM0 As Byte
    Get
    Set
public:
property unsigned char PWM0 {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.PWM0AI Property

IRD

Pca9553PWM0AI Property

PWM 0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM0AI { get; set; }
Public Property PWM0AI As Byte
    Get
    Set
public:
property unsigned char PWM0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.PWM1 Property

IRD

Pca9553PWM1 Property

PWM 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM1 { get; set; }
Public Property PWM1 As Byte
    Get
    Set
public:
property unsigned char PWM1 {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.PWM1AI Property

IRD

Pca9553PWM1AI Property

PWM 1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM1AI { get; set; }
Public Property PWM1AI As Byte
    Get
    Set
public:
property unsigned char PWM1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553 Methods

The Pca9553 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.Flush Method

IRD

Pca9553Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9553 Class
telos.Ird.NXPSemiconductors Namespace


Pca9553.TypeInput Enumeration

IRD

Pca9553TypeInput Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInput
Public Enumeration TypeInput
public enum class TypeInput
type TypeInput
Members
Member name | Value | Description
High | 1 | High
Low | 0 | Low
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9553.TypeLedSelector Enumeration

IRD

Pca9553TypeLedSelector Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedSelector
Public Enumeration TypeLedSelector
public enum class TypeLedSelector
type TypeLedSelector
Members
Member name | Value | Description
OutputIsSetLOWLEDOn | 0 | Output is set LOW (LED on)
OutputIsSetHighImpedanceLEDOff | 1 | Output is set high-impedance (LED off)
OutputBlinksAtPWM0Rate | 2 | Output blinks at PWM0 rate
OutputBlinksAtPWM1Rate | 3 | Output blinks at PWM1 rate
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9559 Class

NXP Semiconductors: PCA 9559
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9559

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9559
Public Class Pca9559
public ref class Pca9559
type Pca9559 =  class end

The Pca9559 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9559 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | MuxDataA | Mux Data A
Public property | MuxDataB | Mux Data B
Public property | MuxDataC | Mux Data C
Public property | MuxDataD | Mux Data D
Public property | MuxDataE | Mux Data E
Public property | NonMuxedData | Non-Muxed Data
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
5-Bit Multiplexed/1-Bit Latched 6-Bit I2C EEPROM DIP Switch
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9559 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9559(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9559(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9559

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9559 Class
telos.Ird.NXPSemiconductors Namespace


Pca9559 Properties

The Pca9559 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | MuxDataA | Mux Data A
Public property | MuxDataB | Mux Data B
Public property | MuxDataC | Mux Data C
Public property | MuxDataD | Mux Data D
Public property | MuxDataE | Mux Data E
Public property | NonMuxedData | Non-Muxed Data
Top
See Also

Reference

Pca9559 Class
telos.Ird.NXPSemiconductors Namespace


Pca9559.AutoFlush Property

IRD

Pca9559AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9559 Class
telos.Ird.NXPSemiconductors Namespace


Pca9559.MuxDataA Property

IRD

Pca9559MuxDataA Property

Mux Data A

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MuxDataA { get; set; }
Public Property MuxDataA As Byte
    Get
    Set
public:
property unsigned char MuxDataA {
    unsigned char get ();
    void set (unsigned char value);
}
member MuxDataA : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9559 Class
telos.Ird.NXPSemiconductors Namespace


Pca9559.MuxDataB Property

IRD

Pca9559MuxDataB Property

Mux Data B

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MuxDataB { get; set; }
Public Property MuxDataB As Byte
    Get
    Set
public:
property unsigned char MuxDataB {
    unsigned char get ();
    void set (unsigned char value);
}
member MuxDataB : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9559 Class
telos.Ird.NXPSemiconductors Namespace


Pca9559.MuxDataC Property

IRD

Pca9559MuxDataC Property

Mux Data C

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MuxDataC { get; set; }
Public Property MuxDataC As Byte
    Get
    Set
public:
property unsigned char MuxDataC {
    unsigned char get ();
    void set (unsigned char value);
}
member MuxDataC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9559 Class
telos.Ird.NXPSemiconductors Namespace


Pca9559.MuxDataD Property

IRD

Pca9559MuxDataD Property

Mux Data D

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MuxDataD { get; set; }
Public Property MuxDataD As Byte
    Get
    Set
public:
property unsigned char MuxDataD {
    unsigned char get ();
    void set (unsigned char value);
}
member MuxDataD : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9559 Class
telos.Ird.NXPSemiconductors Namespace


Pca9559.MuxDataE Property

IRD

Pca9559MuxDataE Property

Mux Data E

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MuxDataE { get; set; }
Public Property MuxDataE As Byte
    Get
    Set
public:
property unsigned char MuxDataE {
    unsigned char get ();
    void set (unsigned char value);
}
member MuxDataE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9559 Class
telos.Ird.NXPSemiconductors Namespace


Pca9559.NonMuxedData Property

IRD

Pca9559NonMuxedData Property

Non-Muxed Data

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte NonMuxedData { get; set; }
Public Property NonMuxedData As Byte
    Get
    Set
public:
property unsigned char NonMuxedData {
    unsigned char get ();
    void set (unsigned char value);
}
member NonMuxedData : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9559 Class
telos.Ird.NXPSemiconductors Namespace


Pca9559 Methods

The Pca9559 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9559 Class
telos.Ird.NXPSemiconductors Namespace


Pca9559.Flush Method

IRD

Pca9559Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9559 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629 Class

NXP Semiconductors: PCA 9629
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9629

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9629
Public Class Pca9629
public ref class Pca9629
type Pca9629 =  class end

The Pca9629 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9629 | Constructor
Top
Properties
 | Name | Description
Public property | ALLCALLADR | ALLCALLADR
Public property | ALLCALLADRAI | ALLCALLADR [AI]
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CCWPWH | CCWPWH
Public property | CCWPWHAI | CCWPWH [AI]
Public property | CCWPWL | CCWPWL
Public property | CCWPWLAI | CCWPWL [AI]
Public property | CCWRCOUNTH | CCWRCOUNTH
Public property | CCWRCOUNTHAI | CCWRCOUNTH [AI]
Public property | CCWRCOUNTL | CCWRCOUNTL
Public property | CCWRCOUNTLAI | CCWRCOUNTL [AI]
Public property | CCWSCOUNTH | CCWSCOUNTH
Public property | CCWSCOUNTHAI | CCWSCOUNTH [AI]
Public property | CCWSCOUNTL | CCWSCOUNTL
Public property | CCWSCOUNTLAI | CCWSCOUNTL [AI]
Public property | CLRINTINTP0 | CLRINT: INTP0
Public property | CLRINTINTP0AI | CLRINT: INTP0 [AI]
Public property | CLRINTINTP1 | CLRINT: INTP1
Public property | CLRINTINTP1AI | CLRINT: INTP1 [AI]
Public property | CLRINTINTP2 | CLRINT: INTP2
Public property | CLRINTINTP2AI | CLRINT: INTP2 [AI]
Public property | CLRINTINTP3 | CLRINT: INTP3
Public property | CLRINTINTP3AI | CLRINT: INTP3 [AI]
Public property | CWPWH | CWPWH
Public property | CWPWHAI | CWPWH [AI]
Public property | CWPWL | CWPWL
Public property | CWPWLAI | CWPWL [AI]
Public property | CWRCOUNTH | CWRCOUNTH
Public property | CWRCOUNTHAI | CWRCOUNTH [AI]
Public property | CWRCOUNTL | CWRCOUNTL
Public property | CWRCOUNTLAI | CWRCOUNTL [AI]
Public property | CWSCOUNTH | CWSCOUNTH
Public property | CWSCOUNTHAI | CWSCOUNTH [AI]
Public property | CWSCOUNTL | CWSCOUNTL
Public property | CWSCOUNTLAI | CWSCOUNTL [AI]
Public property | EXTRASTEPS0 | EXTRASTEPS0
Public property | EXTRASTEPS0AI | EXTRASTEPS0 [AI]
Public property | EXTRASTEPS1 | EXTRASTEPS1
Public property | EXTRASTEPS1AI | EXTRASTEPS1 [AI]
Public property | INTACSETUPCounterUnit | INT_AC_SETUP: Counter Unit
Public property | INTACSETUPCounterUnitAI | INT_AC_SETUP: Counter Unit [AI]
Public property | INTACSETUPMotorControlInterrupt | INT_AC_SETUP: Motor Control Interrupt
Public property | INTACSETUPMotorControlInterruptAI | INT_AC_SETUP: Motor Control Interrupt [AI]
Public property | INTAUTOCLR | INT_AUTO_CLR
Public property | INTAUTOCLRAI | INT_AUTO_CLR [AI]
Public property | INTESSETUP | INT_ES_SETUP
Public property | INTESSETUPAI | INT_ES_SETUP [AI]
Public property | INTMODEP0 | INTMODE: P0
Public property | INTMODEP0AI | INTMODE: P0 [AI]
Public property | INTMODEP1 | INTMODE: P1
Public property | INTMODEP1AI | INTMODE: P1 [AI]
Public property | INTMODEP2 | INTMODE: P2
Public property | INTMODEP2AI | INTMODE: P2 [AI]
Public property | INTMODEP3 | INTMODE: P3
Public property | INTMODEP3AI | INTMODE: P3 [AI]
Public property | INTMTRSETUP | INT_MTR_SETUP
Public property | INTMTRSETUPAI | INT_MTR_SETUP [AI]
Public property | INTSTATINTP0 | INTSTAT: INTP0
Public property | INTSTATINTP0AI | INTSTAT: INTP0 [AI]
Public property | INTSTATINTP1 | INTSTAT: INTP1
Public property | INTSTATINTP1AI | INTSTAT: INTP1 [AI]
Public property | INTSTATINTP2 | INTSTAT: INTP2
Public property | INTSTATINTP2AI | INTSTAT: INTP2 [AI]
Public property | INTSTATINTP3 | INTSTAT: INTP3
Public property | INTSTATINTP3AI | INTSTAT: INTP3 [AI]
Public property | IOCP0 | IOC: P0
Public property | IOCP0AI | IOC: P0 [AI]
Public property | IOCP1 | IOC: P1
Public property | IOCP1AI | IOC: P1 [AI]
Public property | IOCP2 | IOC: P2
Public property | IOCP2AI | IOC: P2 [AI]
Public property | IOCP3 | IOC: P3
Public property | IOCP3AI | IOC: P3 [AI]
Public property | IP | IP
Public property | IPAI | IP [AI]
Public property | LOOPDLY | LOOPDLY
Public property | LOOPDLYAI | LOOPDLY [AI]
Public property | MCNTLDirection | MCNTL: Direction
Public property | MCNTLDirectionAI | MCNTL: Direction [AI]
Public property | MCNTLHardStop | MCNTL: Hard Stop
Public property | MCNTLHardStopAI | MCNTL: Hard Stop [AI]
Public property | MCNTLMode | MCNTL: Mode
Public property | MCNTLModeAI | MCNTL: Mode [AI]
Public property | MCNTLPerformAction | MCNTL: Perform Action
Public property | MCNTLPerformActionAI | MCNTL: Perform Action [AI]
Public property | MCNTLStartStop | MCNTL: Start Stop
Public property | MCNTLStartStopAI | MCNTL: Start Stop [AI]
Public property | MODEEnableDisableINT | MODE: Enable Disable INT
Public property | MODEEnableDisableINTAI | MODE: Enable Disable INT [AI]
Public property | MODEOutputChangeACKSTOP | MODE: Output Change ACK STOP
Public property | MODEOutputChangeACKSTOPAI | MODE: Output Change ACK STOP [AI]
Public property | MODERespondAllCall | MODE: Respond All Call
Public property | MODERespondAllCallAI | MODE: Respond All Call [AI]
Public property | MODERespondSubaddress1 | MODE: Respond Subaddress 1
Public property | MODERespondSubaddress1AI | MODE: Respond Subaddress 1 [AI]
Public property | MODERespondSubaddress2 | MODE: Respond Subaddress 2
Public property | MODERespondSubaddress2AI | MODE: Respond Subaddress 2 [AI]
Public property | MODERespondSubaddress3 | MODE: Respond Subaddress 3
Public property | MODERespondSubaddress3AI | MODE: Respond Subaddress 3 [AI]
Public property | MSKP0 | MSK: P0
Public property | MSKP0AI | MSK: P0 [AI]
Public property | MSKP1 | MSK: P1
Public property | MSKP1AI | MSK: P1 [AI]
Public property | MSKP2 | MSK: P2
Public property | MSKP2AI | MSK: P2 [AI]
Public property | MSKP3 | MSK: P3
Public property | MSKP3AI | MSK: P3 [AI]
Public property | OP | OP
Public property | OPAI | OP [AI]
Public property | PHCNTLOutputDriveAI | PHCNTL: Output Drive [AI]
Public property | PHCNTLPhaseControlOutputDrive | PHCNTL: Phase Control Output Drive
Public property | RMPCNTLRampDown | RMPCNTL: Ramp Down
Public property | RMPCNTLRampDownAI | RMPCNTL: Ramp Down [AI]
Public property | RMPCNTLRampUp | RMPCNTL: Ramp Up
Public property | RMPCNTLRampUpAI | RMPCNTL: Ramp Up [AI]
Public property | RMPCNTLStepFactor | RMPCNTL: Step Factor
Public property | RMPCNTLStepFactorAI | RMPCNTL: Step Factor [AI]
Public property | SETMODECCWStop | SETMODE: CCW Stop
Public property | SETMODECCWStopAI | SETMODE: CCW Stop [AI]
Public property | SETMODECWStop | SETMODE: CW Stop
Public property | SETMODECWStopAI | SETMODE: CW Stop [AI]
Public property | SROTNH | SROTNH
Public property | SROTNHAI | SROTNH [AI]
Public property | SROTNL | SROTNL
Public property | SROTNLAI | SROTNL [AI]
Public property | SUBADR1 | SUBADR1
Public property | SUBADR1AI | SUBADR1 [AI]
Public property | SUBADR2 | SUBADR2
Public property | SUBADR2AI | SUBADR2 [AI]
Public property | SUBADR3 | SUBADR3
Public property | SUBADR3AI | SUBADR3 [AI]
Public property | WDCNTLWDEN | WDCNTL: WDEN
Public property | WDCNTLWDENAI | WDCNTL: WDEN [AI]
Public property | WDCNTLWDINTFlag | WDCNTL: WDINT Flag
Public property | WDCNTLWDINTFlagAI | WDCNTL: WDINT Flag [AI]
Public property | WDCNTLWDINTFlagControl | WDCNTL: WDINT Flag Control
Public property | WDCNTLWDINTFlagControlAI | WDCNTL: WDINT Flag Control [AI]
Public property | WDCNTLWDMOD | WDCNTL: WDMOD
Public property | WDCNTLWDMODAI | WDCNTL: WDMOD [AI]
Public property | WDCNTLWDRSTFlag | WDCNTL: WDRST Flag
Public property | WDCNTLWDRSTFlagAI | WDCNTL: WDRST Flag [AI]
Public property | WDTOI | WDTOI
Public property | WDTOIAI | WDTOI [AI]
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Stepper Motor Controller
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9629(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9629

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629 Properties

The Pca9629 type exposes the following members.

Properties
 | Name | Description
Public property | ALLCALLADR | ALLCALLADR
Public property | ALLCALLADRAI | ALLCALLADR [AI]
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CCWPWH | CCWPWH
Public property | CCWPWHAI | CCWPWH [AI]
Public property | CCWPWL | CCWPWL
Public property | CCWPWLAI | CCWPWL [AI]
Public property | CCWRCOUNTH | CCWRCOUNTH
Public property | CCWRCOUNTHAI | CCWRCOUNTH [AI]
Public property | CCWRCOUNTL | CCWRCOUNTL
Public property | CCWRCOUNTLAI | CCWRCOUNTL [AI]
Public property | CCWSCOUNTH | CCWSCOUNTH
Public property | CCWSCOUNTHAI | CCWSCOUNTH [AI]
Public property | CCWSCOUNTL | CCWSCOUNTL
Public property | CCWSCOUNTLAI | CCWSCOUNTL [AI]
Public property | CLRINTINTP0 | CLRINT: INTP0
Public property | CLRINTINTP0AI | CLRINT: INTP0 [AI]
Public property | CLRINTINTP1 | CLRINT: INTP1
Public property | CLRINTINTP1AI | CLRINT: INTP1 [AI]
Public property | CLRINTINTP2 | CLRINT: INTP2
Public property | CLRINTINTP2AI | CLRINT: INTP2 [AI]
Public property | CLRINTINTP3 | CLRINT: INTP3
Public property | CLRINTINTP3AI | CLRINT: INTP3 [AI]
Public property | CWPWH | CWPWH
Public property | CWPWHAI | CWPWH [AI]
Public property | CWPWL | CWPWL
Public property | CWPWLAI | CWPWL [AI]
Public property | CWRCOUNTH | CWRCOUNTH
Public property | CWRCOUNTHAI | CWRCOUNTH [AI]
Public property | CWRCOUNTL | CWRCOUNTL
Public property | CWRCOUNTLAI | CWRCOUNTL [AI]
Public property | CWSCOUNTH | CWSCOUNTH
Public property | CWSCOUNTHAI | CWSCOUNTH [AI]
Public property | CWSCOUNTL | CWSCOUNTL
Public property | CWSCOUNTLAI | CWSCOUNTL [AI]
Public property | EXTRASTEPS0 | EXTRASTEPS0
Public property | EXTRASTEPS0AI | EXTRASTEPS0 [AI]
Public property | EXTRASTEPS1 | EXTRASTEPS1
Public property | EXTRASTEPS1AI | EXTRASTEPS1 [AI]
Public property | INTACSETUPCounterUnit | INT_AC_SETUP: Counter Unit
Public property | INTACSETUPCounterUnitAI | INT_AC_SETUP: Counter Unit [AI]
Public property | INTACSETUPMotorControlInterrupt | INT_AC_SETUP: Motor Control Interrupt
Public property | INTACSETUPMotorControlInterruptAI | INT_AC_SETUP: Motor Control Interrupt [AI]
Public property | INTAUTOCLR | INT_AUTO_CLR
Public property | INTAUTOCLRAI | INT_AUTO_CLR [AI]
Public property | INTESSETUP | INT_ES_SETUP
Public property | INTESSETUPAI | INT_ES_SETUP [AI]
Public property | INTMODEP0 | INTMODE: P0
Public property | INTMODEP0AI | INTMODE: P0 [AI]
Public property | INTMODEP1 | INTMODE: P1
Public property | INTMODEP1AI | INTMODE: P1 [AI]
Public property | INTMODEP2 | INTMODE: P2
Public property | INTMODEP2AI | INTMODE: P2 [AI]
Public property | INTMODEP3 | INTMODE: P3
Public property | INTMODEP3AI | INTMODE: P3 [AI]
Public property | INTMTRSETUP | INT_MTR_SETUP
Public property | INTMTRSETUPAI | INT_MTR_SETUP [AI]
Public property | INTSTATINTP0 | INTSTAT: INTP0
Public property | INTSTATINTP0AI | INTSTAT: INTP0 [AI]
Public property | INTSTATINTP1 | INTSTAT: INTP1
Public property | INTSTATINTP1AI | INTSTAT: INTP1 [AI]
Public property | INTSTATINTP2 | INTSTAT: INTP2
Public property | INTSTATINTP2AI | INTSTAT: INTP2 [AI]
Public property | INTSTATINTP3 | INTSTAT: INTP3
Public property | INTSTATINTP3AI | INTSTAT: INTP3 [AI]
Public property | IOCP0 | IOC: P0
Public property | IOCP0AI | IOC: P0 [AI]
Public property | IOCP1 | IOC: P1
Public property | IOCP1AI | IOC: P1 [AI]
Public property | IOCP2 | IOC: P2
Public property | IOCP2AI | IOC: P2 [AI]
Public property | IOCP3 | IOC: P3
Public property | IOCP3AI | IOC: P3 [AI]
Public property | IP | IP
Public property | IPAI | IP [AI]
Public property | LOOPDLY | LOOPDLY
Public property | LOOPDLYAI | LOOPDLY [AI]
Public property | MCNTLDirection | MCNTL: Direction
Public property | MCNTLDirectionAI | MCNTL: Direction [AI]
Public property | MCNTLHardStop | MCNTL: Hard Stop
Public property | MCNTLHardStopAI | MCNTL: Hard Stop [AI]
Public property | MCNTLMode | MCNTL: Mode
Public property | MCNTLModeAI | MCNTL: Mode [AI]
Public property | MCNTLPerformAction | MCNTL: Perform Action
Public property | MCNTLPerformActionAI | MCNTL: Perform Action [AI]
Public property | MCNTLStartStop | MCNTL: Start Stop
Public property | MCNTLStartStopAI | MCNTL: Start Stop [AI]
Public property | MODEEnableDisableINT | MODE: Enable Disable INT
Public property | MODEEnableDisableINTAI | MODE: Enable Disable INT [AI]
Public property | MODEOutputChangeACKSTOP | MODE: Output Change ACK STOP
Public property | MODEOutputChangeACKSTOPAI | MODE: Output Change ACK STOP [AI]
Public property | MODERespondAllCall | MODE: Respond All Call
Public property | MODERespondAllCallAI | MODE: Respond All Call [AI]
Public property | MODERespondSubaddress1 | MODE: Respond Subaddress 1
Public property | MODERespondSubaddress1AI | MODE: Respond Subaddress 1 [AI]
Public property | MODERespondSubaddress2 | MODE: Respond Subaddress 2
Public property | MODERespondSubaddress2AI | MODE: Respond Subaddress 2 [AI]
Public property | MODERespondSubaddress3 | MODE: Respond Subaddress 3
Public property | MODERespondSubaddress3AI | MODE: Respond Subaddress 3 [AI]
Public property | MSKP0 | MSK: P0
Public property | MSKP0AI | MSK: P0 [AI]
Public property | MSKP1 | MSK: P1
Public property | MSKP1AI | MSK: P1 [AI]
Public property | MSKP2 | MSK: P2
Public property | MSKP2AI | MSK: P2 [AI]
Public property | MSKP3 | MSK: P3
Public property | MSKP3AI | MSK: P3 [AI]
Public property | OP | OP
Public property | OPAI | OP [AI]
Public property | PHCNTLOutputDriveAI | PHCNTL: Output Drive [AI]
Public property | PHCNTLPhaseControlOutputDrive | PHCNTL: Phase Control Output Drive
Public property | RMPCNTLRampDown | RMPCNTL: Ramp Down
Public property | RMPCNTLRampDownAI | RMPCNTL: Ramp Down [AI]
Public property | RMPCNTLRampUp | RMPCNTL: Ramp Up
Public property | RMPCNTLRampUpAI | RMPCNTL: Ramp Up [AI]
Public property | RMPCNTLStepFactor | RMPCNTL: Step Factor
Public property | RMPCNTLStepFactorAI | RMPCNTL: Step Factor [AI]
Public property | SETMODECCWStop | SETMODE: CCW Stop
Public property | SETMODECCWStopAI | SETMODE: CCW Stop [AI]
Public property | SETMODECWStop | SETMODE: CW Stop
Public property | SETMODECWStopAI | SETMODE: CW Stop [AI]
Public property | SROTNH | SROTNH
Public property | SROTNHAI | SROTNH [AI]
Public property | SROTNL | SROTNL
Public property | SROTNLAI | SROTNL [AI]
Public property | SUBADR1 | SUBADR1
Public property | SUBADR1AI | SUBADR1 [AI]
Public property | SUBADR2 | SUBADR2
Public property | SUBADR2AI | SUBADR2 [AI]
Public property | SUBADR3 | SUBADR3
Public property | SUBADR3AI | SUBADR3 [AI]
Public property | WDCNTLWDEN | WDCNTL: WDEN
Public property | WDCNTLWDENAI | WDCNTL: WDEN [AI]
Public property | WDCNTLWDINTFlag | WDCNTL: WDINT Flag
Public property | WDCNTLWDINTFlagAI | WDCNTL: WDINT Flag [AI]
Public property | WDCNTLWDINTFlagControl | WDCNTL: WDINT Flag Control
Public property | WDCNTLWDINTFlagControlAI | WDCNTL: WDINT Flag Control [AI]
Public property | WDCNTLWDMOD | WDCNTL: WDMOD
Public property | WDCNTLWDMODAI | WDCNTL: WDMOD [AI]
Public property | WDCNTLWDRSTFlag | WDCNTL: WDRST Flag
Public property | WDCNTLWDRSTFlagAI | WDCNTL: WDRST Flag [AI]
Public property | WDTOI | WDTOI
Public property | WDTOIAI | WDTOI [AI]
Top
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.ALLCALLADR Property

IRD

Pca9629ALLCALLADR Property

ALLCALLADR

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ALLCALLADR { get; set; }
Public Property ALLCALLADR As Byte
    Get
    Set
public:
property unsigned char ALLCALLADR {
    unsigned char get ();
    void set (unsigned char value);
}
member ALLCALLADR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.ALLCALLADRAI Property

IRD

Pca9629ALLCALLADRAI Property

ALLCALLADR [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ALLCALLADRAI { get; set; }
Public Property ALLCALLADRAI As Byte
    Get
    Set
public:
property unsigned char ALLCALLADRAI {
    unsigned char get ();
    void set (unsigned char value);
}
member ALLCALLADRAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.AutoFlush Property

IRD

Pca9629AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CCWPWH Property

IRD

Pca9629CCWPWH Property

CCWPWH

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCWPWH { get; set; }
Public Property CCWPWH As Byte
    Get
    Set
public:
property unsigned char CCWPWH {
    unsigned char get ();
    void set (unsigned char value);
}
member CCWPWH : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CCWPWHAI Property

IRD

Pca9629CCWPWHAI Property

CCWPWH [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCWPWHAI { get; set; }
Public Property CCWPWHAI As Byte
    Get
    Set
public:
property unsigned char CCWPWHAI {
    unsigned char get ();
    void set (unsigned char value);
}
member CCWPWHAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CCWPWL Property

IRD

Pca9629CCWPWL Property

CCWPWL

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCWPWL { get; set; }
Public Property CCWPWL As Byte
    Get
    Set
public:
property unsigned char CCWPWL {
    unsigned char get ();
    void set (unsigned char value);
}
member CCWPWL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CCWPWLAI Property

IRD

Pca9629CCWPWLAI Property

CCWPWL [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCWPWLAI { get; set; }
Public Property CCWPWLAI As Byte
    Get
    Set
public:
property unsigned char CCWPWLAI {
    unsigned char get ();
    void set (unsigned char value);
}
member CCWPWLAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CCWRCOUNTH Property

IRD

Pca9629CCWRCOUNTH Property

CCWRCOUNTH

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCWRCOUNTH { get; set; }
Public Property CCWRCOUNTH As Byte
    Get
    Set
public:
property unsigned char CCWRCOUNTH {
    unsigned char get ();
    void set (unsigned char value);
}
member CCWRCOUNTH : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CCWRCOUNTHAI Property

IRD

Pca9629CCWRCOUNTHAI Property

CCWRCOUNTH [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCWRCOUNTHAI { get; set; }
Public Property CCWRCOUNTHAI As Byte
    Get
    Set
public:
property unsigned char CCWRCOUNTHAI {
    unsigned char get ();
    void set (unsigned char value);
}
member CCWRCOUNTHAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CCWRCOUNTL Property

IRD

Pca9629CCWRCOUNTL Property

CCWRCOUNTL

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCWRCOUNTL { get; set; }
Public Property CCWRCOUNTL As Byte
    Get
    Set
public:
property unsigned char CCWRCOUNTL {
    unsigned char get ();
    void set (unsigned char value);
}
member CCWRCOUNTL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CCWRCOUNTLAI Property

IRD

Pca9629CCWRCOUNTLAI Property

CCWRCOUNTL [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCWRCOUNTLAI { get; set; }
Public Property CCWRCOUNTLAI As Byte
    Get
    Set
public:
property unsigned char CCWRCOUNTLAI {
    unsigned char get ();
    void set (unsigned char value);
}
member CCWRCOUNTLAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CCWSCOUNTH Property

IRD

Pca9629CCWSCOUNTH Property

CCWSCOUNTH

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCWSCOUNTH { get; set; }
Public Property CCWSCOUNTH As Byte
    Get
    Set
public:
property unsigned char CCWSCOUNTH {
    unsigned char get ();
    void set (unsigned char value);
}
member CCWSCOUNTH : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CCWSCOUNTHAI Property

IRD

Pca9629CCWSCOUNTHAI Property

CCWSCOUNTH [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCWSCOUNTHAI { get; set; }
Public Property CCWSCOUNTHAI As Byte
    Get
    Set
public:
property unsigned char CCWSCOUNTHAI {
    unsigned char get ();
    void set (unsigned char value);
}
member CCWSCOUNTHAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CCWSCOUNTL Property

IRD

Pca9629CCWSCOUNTL Property

CCWSCOUNTL

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCWSCOUNTL { get; set; }
Public Property CCWSCOUNTL As Byte
    Get
    Set
public:
property unsigned char CCWSCOUNTL {
    unsigned char get ();
    void set (unsigned char value);
}
member CCWSCOUNTL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CCWSCOUNTLAI Property

IRD

Pca9629CCWSCOUNTLAI Property

CCWSCOUNTL [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCWSCOUNTLAI { get; set; }
Public Property CCWSCOUNTLAI As Byte
    Get
    Set
public:
property unsigned char CCWSCOUNTLAI {
    unsigned char get ();
    void set (unsigned char value);
}
member CCWSCOUNTLAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CLRINTINTP0 Property

IRD

Pca9629CLRINTINTP0 Property

CLRINT: INTP0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeClearIntP0 CLRINTINTP0 { set; }
Public WriteOnly Property CLRINTINTP0 As Pca9629TypeClearIntP0
    Set
public:
property Pca9629TypeClearIntP0 CLRINTINTP0 {
    void set (Pca9629TypeClearIntP0 value);
}
member CLRINTINTP0 : Pca9629TypeClearIntP0 with set

Property Value

Type: Pca9629TypeClearIntP0
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CLRINTINTP0AI Property

IRD

Pca9629CLRINTINTP0AI Property

CLRINT: INTP0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeClearIntP0 CLRINTINTP0AI { set; }
Public WriteOnly Property CLRINTINTP0AI As Pca9629TypeClearIntP0
    Set
public:
property Pca9629TypeClearIntP0 CLRINTINTP0AI {
    void set (Pca9629TypeClearIntP0 value);
}
member CLRINTINTP0AI : Pca9629TypeClearIntP0 with set

Property Value

Type: Pca9629TypeClearIntP0
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CLRINTINTP1 Property

IRD

Pca9629CLRINTINTP1 Property

CLRINT: INTP1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeClearIntP1 CLRINTINTP1 { set; }
Public WriteOnly Property CLRINTINTP1 As Pca9629TypeClearIntP1
    Set
public:
property Pca9629TypeClearIntP1 CLRINTINTP1 {
    void set (Pca9629TypeClearIntP1 value);
}
member CLRINTINTP1 : Pca9629TypeClearIntP1 with set

Property Value

Type: Pca9629TypeClearIntP1
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CLRINTINTP1AI Property

IRD

Pca9629CLRINTINTP1AI Property

CLRINT: INTP1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeClearIntP1 CLRINTINTP1AI { set; }
Public WriteOnly Property CLRINTINTP1AI As Pca9629TypeClearIntP1
    Set
public:
property Pca9629TypeClearIntP1 CLRINTINTP1AI {
    void set (Pca9629TypeClearIntP1 value);
}
member CLRINTINTP1AI : Pca9629TypeClearIntP1 with set

Property Value

Type: Pca9629TypeClearIntP1
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CLRINTINTP2 Property

IRD

Pca9629CLRINTINTP2 Property

CLRINT: INTP2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeClearIntP2 CLRINTINTP2 { set; }
Public WriteOnly Property CLRINTINTP2 As Pca9629TypeClearIntP2
    Set
public:
property Pca9629TypeClearIntP2 CLRINTINTP2 {
    void set (Pca9629TypeClearIntP2 value);
}
member CLRINTINTP2 : Pca9629TypeClearIntP2 with set

Property Value

Type: Pca9629TypeClearIntP2
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CLRINTINTP2AI Property

IRD

Pca9629CLRINTINTP2AI Property

CLRINT: INTP2 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeClearIntP2 CLRINTINTP2AI { set; }
Public WriteOnly Property CLRINTINTP2AI As Pca9629TypeClearIntP2
    Set
public:
property Pca9629TypeClearIntP2 CLRINTINTP2AI {
    void set (Pca9629TypeClearIntP2 value);
}
member CLRINTINTP2AI : Pca9629TypeClearIntP2 with set

Property Value

Type: Pca9629TypeClearIntP2
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CLRINTINTP3 Property

IRD

Pca9629CLRINTINTP3 Property

CLRINT: INTP3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeClearIntP3 CLRINTINTP3 { set; }
Public WriteOnly Property CLRINTINTP3 As Pca9629TypeClearIntP3
    Set
public:
property Pca9629TypeClearIntP3 CLRINTINTP3 {
    void set (Pca9629TypeClearIntP3 value);
}
member CLRINTINTP3 : Pca9629TypeClearIntP3 with set

Property Value

Type: Pca9629TypeClearIntP3
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CLRINTINTP3AI Property

IRD

Pca9629CLRINTINTP3AI Property

CLRINT: INTP3 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeClearIntP3 CLRINTINTP3AI { set; }
Public WriteOnly Property CLRINTINTP3AI As Pca9629TypeClearIntP3
    Set
public:
property Pca9629TypeClearIntP3 CLRINTINTP3AI {
    void set (Pca9629TypeClearIntP3 value);
}
member CLRINTINTP3AI : Pca9629TypeClearIntP3 with set

Property Value

Type: Pca9629TypeClearIntP3
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CWPWH Property

IRD

Pca9629CWPWH Property

CWPWH

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CWPWH { get; set; }
Public Property CWPWH As Byte
    Get
    Set
public:
property unsigned char CWPWH {
    unsigned char get ();
    void set (unsigned char value);
}
member CWPWH : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CWPWHAI Property

IRD

Pca9629CWPWHAI Property

CWPWH [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CWPWHAI { get; set; }
Public Property CWPWHAI As Byte
    Get
    Set
public:
property unsigned char CWPWHAI {
    unsigned char get ();
    void set (unsigned char value);
}
member CWPWHAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CWPWL Property

IRD

Pca9629CWPWL Property

CWPWL

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CWPWL { get; set; }
Public Property CWPWL As Byte
    Get
    Set
public:
property unsigned char CWPWL {
    unsigned char get ();
    void set (unsigned char value);
}
member CWPWL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CWPWLAI Property

IRD

Pca9629CWPWLAI Property

CWPWL [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CWPWLAI { get; set; }
Public Property CWPWLAI As Byte
    Get
    Set
public:
property unsigned char CWPWLAI {
    unsigned char get ();
    void set (unsigned char value);
}
member CWPWLAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CWRCOUNTH Property

IRD

Pca9629CWRCOUNTH Property

CWRCOUNTH

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CWRCOUNTH { get; set; }
Public Property CWRCOUNTH As Byte
    Get
    Set
public:
property unsigned char CWRCOUNTH {
    unsigned char get ();
    void set (unsigned char value);
}
member CWRCOUNTH : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CWRCOUNTHAI Property

IRD

Pca9629CWRCOUNTHAI Property

CWRCOUNTH [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CWRCOUNTHAI { get; set; }
Public Property CWRCOUNTHAI As Byte
    Get
    Set
public:
property unsigned char CWRCOUNTHAI {
    unsigned char get ();
    void set (unsigned char value);
}
member CWRCOUNTHAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CWRCOUNTL Property

IRD

Pca9629CWRCOUNTL Property

CWRCOUNTL

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CWRCOUNTL { get; set; }
Public Property CWRCOUNTL As Byte
    Get
    Set
public:
property unsigned char CWRCOUNTL {
    unsigned char get ();
    void set (unsigned char value);
}
member CWRCOUNTL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CWRCOUNTLAI Property

IRD

Pca9629CWRCOUNTLAI Property

CWRCOUNTL [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CWRCOUNTLAI { get; set; }
Public Property CWRCOUNTLAI As Byte
    Get
    Set
public:
property unsigned char CWRCOUNTLAI {
    unsigned char get ();
    void set (unsigned char value);
}
member CWRCOUNTLAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CWSCOUNTH Property

IRD

Pca9629CWSCOUNTH Property

CWSCOUNTH

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CWSCOUNTH { get; set; }
Public Property CWSCOUNTH As Byte
    Get
    Set
public:
property unsigned char CWSCOUNTH {
    unsigned char get ();
    void set (unsigned char value);
}
member CWSCOUNTH : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CWSCOUNTHAI Property

IRD

Pca9629CWSCOUNTHAI Property

CWSCOUNTH [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CWSCOUNTHAI { get; set; }
Public Property CWSCOUNTHAI As Byte
    Get
    Set
public:
property unsigned char CWSCOUNTHAI {
    unsigned char get ();
    void set (unsigned char value);
}
member CWSCOUNTHAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CWSCOUNTL Property

IRD

Pca9629CWSCOUNTL Property

CWSCOUNTL

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CWSCOUNTL { get; set; }
Public Property CWSCOUNTL As Byte
    Get
    Set
public:
property unsigned char CWSCOUNTL {
    unsigned char get ();
    void set (unsigned char value);
}
member CWSCOUNTL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.CWSCOUNTLAI Property

IRD

Pca9629CWSCOUNTLAI Property

CWSCOUNTL [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CWSCOUNTLAI { get; set; }
Public Property CWSCOUNTLAI As Byte
    Get
    Set
public:
property unsigned char CWSCOUNTLAI {
    unsigned char get ();
    void set (unsigned char value);
}
member CWSCOUNTLAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.EXTRASTEPS0 Property

IRD

Pca9629EXTRASTEPS0 Property

EXTRASTEPS0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EXTRASTEPS0 { get; set; }
Public Property EXTRASTEPS0 As Byte
    Get
    Set
public:
property unsigned char EXTRASTEPS0 {
    unsigned char get ();
    void set (unsigned char value);
}
member EXTRASTEPS0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.EXTRASTEPS0AI Property

IRD

Pca9629EXTRASTEPS0AI Property

EXTRASTEPS0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EXTRASTEPS0AI { get; set; }
Public Property EXTRASTEPS0AI As Byte
    Get
    Set
public:
property unsigned char EXTRASTEPS0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member EXTRASTEPS0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.EXTRASTEPS1 Property

IRD

Pca9629EXTRASTEPS1 Property

EXTRASTEPS1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EXTRASTEPS1 { get; set; }
Public Property EXTRASTEPS1 As Byte
    Get
    Set
public:
property unsigned char EXTRASTEPS1 {
    unsigned char get ();
    void set (unsigned char value);
}
member EXTRASTEPS1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.EXTRASTEPS1AI Property

IRD

Pca9629EXTRASTEPS1AI Property

EXTRASTEPS1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EXTRASTEPS1AI { get; set; }
Public Property EXTRASTEPS1AI As Byte
    Get
    Set
public:
property unsigned char EXTRASTEPS1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member EXTRASTEPS1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTACSETUPCounterUnit Property

IRD

Pca9629INTACSETUPCounterUnit Property

INT_AC_SETUP: Counter Unit

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntActionUnitExtrasteps INTACSETUPCounterUnit { get; set; }
Public Property INTACSETUPCounterUnit As Pca9629TypeIntActionUnitExtrasteps
    Get
    Set
public:
property Pca9629TypeIntActionUnitExtrasteps INTACSETUPCounterUnit {
    Pca9629TypeIntActionUnitExtrasteps get ();
    void set (Pca9629TypeIntActionUnitExtrasteps value);
}
member INTACSETUPCounterUnit : Pca9629TypeIntActionUnitExtrasteps with get, set

Property Value

Type: Pca9629TypeIntActionUnitExtrasteps
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTACSETUPCounterUnitAI Property

IRD

Pca9629INTACSETUPCounterUnitAI Property

INT_AC_SETUP: Counter Unit [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntActionUnitExtrasteps INTACSETUPCounterUnitAI { get; set; }
Public Property INTACSETUPCounterUnitAI As Pca9629TypeIntActionUnitExtrasteps
    Get
    Set
public:
property Pca9629TypeIntActionUnitExtrasteps INTACSETUPCounterUnitAI {
    Pca9629TypeIntActionUnitExtrasteps get ();
    void set (Pca9629TypeIntActionUnitExtrasteps value);
}
member INTACSETUPCounterUnitAI : Pca9629TypeIntActionUnitExtrasteps with get, set

Property Value

Type: Pca9629TypeIntActionUnitExtrasteps
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTACSETUPMotorControlInterrupt Property

IRD

Pca9629INTACSETUPMotorControlInterrupt Property

INT_AC_SETUP: Motor Control Interrupt

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntActionInterruptMotorControl INTACSETUPMotorControlInterrupt { get; set; }
Public Property INTACSETUPMotorControlInterrupt As Pca9629TypeIntActionInterruptMotorControl
    Get
    Set
public:
property Pca9629TypeIntActionInterruptMotorControl INTACSETUPMotorControlInterrupt {
    Pca9629TypeIntActionInterruptMotorControl get ();
    void set (Pca9629TypeIntActionInterruptMotorControl value);
}
member INTACSETUPMotorControlInterrupt : Pca9629TypeIntActionInterruptMotorControl with get, set

Property Value

Type: Pca9629TypeIntActionInterruptMotorControl
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTACSETUPMotorControlInterruptAI Property

IRD

Pca9629INTACSETUPMotorControlInterruptAI Property

INT_AC_SETUP: Motor Control Interrupt [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntActionInterruptMotorControl INTACSETUPMotorControlInterruptAI { get; set; }
Public Property INTACSETUPMotorControlInterruptAI As Pca9629TypeIntActionInterruptMotorControl
    Get
    Set
public:
property Pca9629TypeIntActionInterruptMotorControl INTACSETUPMotorControlInterruptAI {
    Pca9629TypeIntActionInterruptMotorControl get ();
    void set (Pca9629TypeIntActionInterruptMotorControl value);
}
member INTACSETUPMotorControlInterruptAI : Pca9629TypeIntActionInterruptMotorControl with get, set

Property Value

Type: Pca9629TypeIntActionInterruptMotorControl
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTAUTOCLR Property

IRD

Pca9629INTAUTOCLR Property

INT_AUTO_CLR

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntAutoClr INTAUTOCLR { get; set; }
Public Property INTAUTOCLR As Pca9629TypeIntAutoClr
    Get
    Set
public:
property Pca9629TypeIntAutoClr INTAUTOCLR {
    Pca9629TypeIntAutoClr get ();
    void set (Pca9629TypeIntAutoClr value);
}
member INTAUTOCLR : Pca9629TypeIntAutoClr with get, set

Property Value

Type: Pca9629TypeIntAutoClr
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTAUTOCLRAI Property

IRD

Pca9629INTAUTOCLRAI Property

INT_AUTO_CLR [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntAutoClr INTAUTOCLRAI { get; set; }
Public Property INTAUTOCLRAI As Pca9629TypeIntAutoClr
    Get
    Set
public:
property Pca9629TypeIntAutoClr INTAUTOCLRAI {
    Pca9629TypeIntAutoClr get ();
    void set (Pca9629TypeIntAutoClr value);
}
member INTAUTOCLRAI : Pca9629TypeIntAutoClr with get, set

Property Value

Type: Pca9629TypeIntAutoClr
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTESSETUP Property

IRD

Pca9629INTESSETUP Property

INT_ES_SETUP

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntExtraStep INTESSETUP { get; set; }
Public Property INTESSETUP As Pca9629TypeIntExtraStep
    Get
    Set
public:
property Pca9629TypeIntExtraStep INTESSETUP {
    Pca9629TypeIntExtraStep get ();
    void set (Pca9629TypeIntExtraStep value);
}
member INTESSETUP : Pca9629TypeIntExtraStep with get, set

Property Value

Type: Pca9629TypeIntExtraStep
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTESSETUPAI Property

IRD

Pca9629INTESSETUPAI Property

INT_ES_SETUP [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntExtraStep INTESSETUPAI { get; set; }
Public Property INTESSETUPAI As Pca9629TypeIntExtraStep
    Get
    Set
public:
property Pca9629TypeIntExtraStep INTESSETUPAI {
    Pca9629TypeIntExtraStep get ();
    void set (Pca9629TypeIntExtraStep value);
}
member INTESSETUPAI : Pca9629TypeIntExtraStep with get, set

Property Value

Type: Pca9629TypeIntExtraStep
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTMODEP0 Property

IRD

Pca9629INTMODEP0 Property

INTMODE: P0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntModeP0 INTMODEP0 { get; set; }
Public Property INTMODEP0 As Pca9629TypeIntModeP0
    Get
    Set
public:
property Pca9629TypeIntModeP0 INTMODEP0 {
    Pca9629TypeIntModeP0 get ();
    void set (Pca9629TypeIntModeP0 value);
}
member INTMODEP0 : Pca9629TypeIntModeP0 with get, set

Property Value

Type: Pca9629TypeIntModeP0
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTMODEP0AI Property

IRD

Pca9629INTMODEP0AI Property

INTMODE: P0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntModeP0 INTMODEP0AI { get; set; }
Public Property INTMODEP0AI As Pca9629TypeIntModeP0
    Get
    Set
public:
property Pca9629TypeIntModeP0 INTMODEP0AI {
    Pca9629TypeIntModeP0 get ();
    void set (Pca9629TypeIntModeP0 value);
}
member INTMODEP0AI : Pca9629TypeIntModeP0 with get, set

Property Value

Type: Pca9629TypeIntModeP0
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTMODEP1 Property

IRD

Pca9629INTMODEP1 Property

INTMODE: P1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntModeP1 INTMODEP1 { get; set; }
Public Property INTMODEP1 As Pca9629TypeIntModeP1
    Get
    Set
public:
property Pca9629TypeIntModeP1 INTMODEP1 {
    Pca9629TypeIntModeP1 get ();
    void set (Pca9629TypeIntModeP1 value);
}
member INTMODEP1 : Pca9629TypeIntModeP1 with get, set

Property Value

Type: Pca9629TypeIntModeP1
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTMODEP1AI Property

IRD

Pca9629INTMODEP1AI Property

INTMODE: P1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntModeP1 INTMODEP1AI { get; set; }
Public Property INTMODEP1AI As Pca9629TypeIntModeP1
    Get
    Set
public:
property Pca9629TypeIntModeP1 INTMODEP1AI {
    Pca9629TypeIntModeP1 get ();
    void set (Pca9629TypeIntModeP1 value);
}
member INTMODEP1AI : Pca9629TypeIntModeP1 with get, set

Property Value

Type: Pca9629TypeIntModeP1
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTMODEP2 Property

IRD

Pca9629INTMODEP2 Property

INTMODE: P2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntModeP2 INTMODEP2 { get; set; }
Public Property INTMODEP2 As Pca9629TypeIntModeP2
    Get
    Set
public:
property Pca9629TypeIntModeP2 INTMODEP2 {
    Pca9629TypeIntModeP2 get ();
    void set (Pca9629TypeIntModeP2 value);
}
member INTMODEP2 : Pca9629TypeIntModeP2 with get, set

Property Value

Type: Pca9629TypeIntModeP2
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTMODEP2AI Property

IRD

Pca9629INTMODEP2AI Property

INTMODE: P2 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntModeP2 INTMODEP2AI { get; set; }
Public Property INTMODEP2AI As Pca9629TypeIntModeP2
    Get
    Set
public:
property Pca9629TypeIntModeP2 INTMODEP2AI {
    Pca9629TypeIntModeP2 get ();
    void set (Pca9629TypeIntModeP2 value);
}
member INTMODEP2AI : Pca9629TypeIntModeP2 with get, set

Property Value

Type: Pca9629TypeIntModeP2
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTMODEP3 Property

IRD

Pca9629INTMODEP3 Property

INTMODE: P3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntModeP3 INTMODEP3 { get; set; }
Public Property INTMODEP3 As Pca9629TypeIntModeP3
    Get
    Set
public:
property Pca9629TypeIntModeP3 INTMODEP3 {
    Pca9629TypeIntModeP3 get ();
    void set (Pca9629TypeIntModeP3 value);
}
member INTMODEP3 : Pca9629TypeIntModeP3 with get, set

Property Value

Type: Pca9629TypeIntModeP3
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTMODEP3AI Property

IRD

Pca9629INTMODEP3AI Property

INTMODE: P3 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntModeP3 INTMODEP3AI { get; set; }
Public Property INTMODEP3AI As Pca9629TypeIntModeP3
    Get
    Set
public:
property Pca9629TypeIntModeP3 INTMODEP3AI {
    Pca9629TypeIntModeP3 get ();
    void set (Pca9629TypeIntModeP3 value);
}
member INTMODEP3AI : Pca9629TypeIntModeP3 with get, set

Property Value

Type: Pca9629TypeIntModeP3
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTMTRSETUP Property

IRD

Pca9629INTMTRSETUP Property

INT_MTR_SETUP

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntMotorSetup INTMTRSETUP { get; set; }
Public Property INTMTRSETUP As Pca9629TypeIntMotorSetup
    Get
    Set
public:
property Pca9629TypeIntMotorSetup INTMTRSETUP {
    Pca9629TypeIntMotorSetup get ();
    void set (Pca9629TypeIntMotorSetup value);
}
member INTMTRSETUP : Pca9629TypeIntMotorSetup with get, set

Property Value

Type: Pca9629TypeIntMotorSetup
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTMTRSETUPAI Property

IRD

Pca9629INTMTRSETUPAI Property

INT_MTR_SETUP [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntMotorSetup INTMTRSETUPAI { get; set; }
Public Property INTMTRSETUPAI As Pca9629TypeIntMotorSetup
    Get
    Set
public:
property Pca9629TypeIntMotorSetup INTMTRSETUPAI {
    Pca9629TypeIntMotorSetup get ();
    void set (Pca9629TypeIntMotorSetup value);
}
member INTMTRSETUPAI : Pca9629TypeIntMotorSetup with get, set

Property Value

Type: Pca9629TypeIntMotorSetup
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTSTATINTP0 Property

IRD

Pca9629INTSTATINTP0 Property

INTSTAT: INTP0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntstatIntp0Flag INTSTATINTP0 { get; }
Public ReadOnly Property INTSTATINTP0 As Pca9629TypeIntstatIntp0Flag
    Get
public:
property Pca9629TypeIntstatIntp0Flag INTSTATINTP0 {
    Pca9629TypeIntstatIntp0Flag get ();
}
member INTSTATINTP0 : Pca9629TypeIntstatIntp0Flag with get

Property Value

Type: Pca9629TypeIntstatIntp0Flag
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTSTATINTP0AI Property

IRD

Pca9629INTSTATINTP0AI Property

INTSTAT: INTP0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntstatIntp0Flag INTSTATINTP0AI { get; }
Public ReadOnly Property INTSTATINTP0AI As Pca9629TypeIntstatIntp0Flag
    Get
public:
property Pca9629TypeIntstatIntp0Flag INTSTATINTP0AI {
    Pca9629TypeIntstatIntp0Flag get ();
}
member INTSTATINTP0AI : Pca9629TypeIntstatIntp0Flag with get

Property Value

Type: Pca9629TypeIntstatIntp0Flag
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTSTATINTP1 Property

IRD

Pca9629INTSTATINTP1 Property

INTSTAT: INTP1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntstatIntp1Flag INTSTATINTP1 { get; }
Public ReadOnly Property INTSTATINTP1 As Pca9629TypeIntstatIntp1Flag
    Get
public:
property Pca9629TypeIntstatIntp1Flag INTSTATINTP1 {
    Pca9629TypeIntstatIntp1Flag get ();
}
member INTSTATINTP1 : Pca9629TypeIntstatIntp1Flag with get

Property Value

Type: Pca9629TypeIntstatIntp1Flag
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTSTATINTP1AI Property

IRD

Pca9629INTSTATINTP1AI Property

INTSTAT: INTP1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntstatIntp1Flag INTSTATINTP1AI { get; }
Public ReadOnly Property INTSTATINTP1AI As Pca9629TypeIntstatIntp1Flag
    Get
public:
property Pca9629TypeIntstatIntp1Flag INTSTATINTP1AI {
    Pca9629TypeIntstatIntp1Flag get ();
}
member INTSTATINTP1AI : Pca9629TypeIntstatIntp1Flag with get

Property Value

Type: Pca9629TypeIntstatIntp1Flag
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTSTATINTP2 Property

IRD

Pca9629INTSTATINTP2 Property

INTSTAT: INTP2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntstatIntp2Flag INTSTATINTP2 { get; }
Public ReadOnly Property INTSTATINTP2 As Pca9629TypeIntstatIntp2Flag
    Get
public:
property Pca9629TypeIntstatIntp2Flag INTSTATINTP2 {
    Pca9629TypeIntstatIntp2Flag get ();
}
member INTSTATINTP2 : Pca9629TypeIntstatIntp2Flag with get

Property Value

Type: Pca9629TypeIntstatIntp2Flag
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTSTATINTP2AI Property

IRD

Pca9629INTSTATINTP2AI Property

INTSTAT: INTP2 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntstatIntp2Flag INTSTATINTP2AI { get; }
Public ReadOnly Property INTSTATINTP2AI As Pca9629TypeIntstatIntp2Flag
    Get
public:
property Pca9629TypeIntstatIntp2Flag INTSTATINTP2AI {
    Pca9629TypeIntstatIntp2Flag get ();
}
member INTSTATINTP2AI : Pca9629TypeIntstatIntp2Flag with get

Property Value

Type: Pca9629TypeIntstatIntp2Flag
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTSTATINTP3 Property

IRD

Pca9629INTSTATINTP3 Property

INTSTAT: INTP3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntstatIntp3Flag INTSTATINTP3 { get; }
Public ReadOnly Property INTSTATINTP3 As Pca9629TypeIntstatIntp3Flag
    Get
public:
property Pca9629TypeIntstatIntp3Flag INTSTATINTP3 {
    Pca9629TypeIntstatIntp3Flag get ();
}
member INTSTATINTP3 : Pca9629TypeIntstatIntp3Flag with get

Property Value

Type: Pca9629TypeIntstatIntp3Flag
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.INTSTATINTP3AI Property

IRD

Pca9629INTSTATINTP3AI Property

INTSTAT: INTP3 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIntstatIntp3Flag INTSTATINTP3AI { get; }
Public ReadOnly Property INTSTATINTP3AI As Pca9629TypeIntstatIntp3Flag
    Get
public:
property Pca9629TypeIntstatIntp3Flag INTSTATINTP3AI {
    Pca9629TypeIntstatIntp3Flag get ();
}
member INTSTATINTP3AI : Pca9629TypeIntstatIntp3Flag with get

Property Value

Type: Pca9629TypeIntstatIntp3Flag
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.IOCP0 Property

IRD

Pca9629IOCP0 Property

IOC: P0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIoConfigP0 IOCP0 { get; set; }
Public Property IOCP0 As Pca9629TypeIoConfigP0
    Get
    Set
public:
property Pca9629TypeIoConfigP0 IOCP0 {
    Pca9629TypeIoConfigP0 get ();
    void set (Pca9629TypeIoConfigP0 value);
}
member IOCP0 : Pca9629TypeIoConfigP0 with get, set

Property Value

Type: Pca9629TypeIoConfigP0
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.IOCP0AI Property

IRD

Pca9629IOCP0AI Property

IOC: P0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIoConfigP0 IOCP0AI { get; set; }
Public Property IOCP0AI As Pca9629TypeIoConfigP0
    Get
    Set
public:
property Pca9629TypeIoConfigP0 IOCP0AI {
    Pca9629TypeIoConfigP0 get ();
    void set (Pca9629TypeIoConfigP0 value);
}
member IOCP0AI : Pca9629TypeIoConfigP0 with get, set

Property Value

Type: Pca9629TypeIoConfigP0
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.IOCP1 Property

IRD

Pca9629IOCP1 Property

IOC: P1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIoConfigP1 IOCP1 { get; set; }
Public Property IOCP1 As Pca9629TypeIoConfigP1
    Get
    Set
public:
property Pca9629TypeIoConfigP1 IOCP1 {
    Pca9629TypeIoConfigP1 get ();
    void set (Pca9629TypeIoConfigP1 value);
}
member IOCP1 : Pca9629TypeIoConfigP1 with get, set

Property Value

Type: Pca9629TypeIoConfigP1
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.IOCP1AI Property

IRD

Pca9629IOCP1AI Property

IOC: P1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIoConfigP1 IOCP1AI { get; set; }
Public Property IOCP1AI As Pca9629TypeIoConfigP1
    Get
    Set
public:
property Pca9629TypeIoConfigP1 IOCP1AI {
    Pca9629TypeIoConfigP1 get ();
    void set (Pca9629TypeIoConfigP1 value);
}
member IOCP1AI : Pca9629TypeIoConfigP1 with get, set

Property Value

Type: Pca9629TypeIoConfigP1
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.IOCP2 Property

IRD

Pca9629IOCP2 Property

IOC: P2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIoConfigP2 IOCP2 { get; set; }
Public Property IOCP2 As Pca9629TypeIoConfigP2
    Get
    Set
public:
property Pca9629TypeIoConfigP2 IOCP2 {
    Pca9629TypeIoConfigP2 get ();
    void set (Pca9629TypeIoConfigP2 value);
}
member IOCP2 : Pca9629TypeIoConfigP2 with get, set

Property Value

Type: Pca9629TypeIoConfigP2
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.IOCP2AI Property

IRD

Pca9629IOCP2AI Property

IOC: P2 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIoConfigP2 IOCP2AI { get; set; }
Public Property IOCP2AI As Pca9629TypeIoConfigP2
    Get
    Set
public:
property Pca9629TypeIoConfigP2 IOCP2AI {
    Pca9629TypeIoConfigP2 get ();
    void set (Pca9629TypeIoConfigP2 value);
}
member IOCP2AI : Pca9629TypeIoConfigP2 with get, set

Property Value

Type: Pca9629TypeIoConfigP2
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.IOCP3 Property

IRD

Pca9629IOCP3 Property

IOC: P3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIoConfigP3 IOCP3 { get; set; }
Public Property IOCP3 As Pca9629TypeIoConfigP3
    Get
    Set
public:
property Pca9629TypeIoConfigP3 IOCP3 {
    Pca9629TypeIoConfigP3 get ();
    void set (Pca9629TypeIoConfigP3 value);
}
member IOCP3 : Pca9629TypeIoConfigP3 with get, set

Property Value

Type: Pca9629TypeIoConfigP3
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.IOCP3AI Property

IRD

Pca9629IOCP3AI Property

IOC: P3 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeIoConfigP3 IOCP3AI { get; set; }
Public Property IOCP3AI As Pca9629TypeIoConfigP3
    Get
    Set
public:
property Pca9629TypeIoConfigP3 IOCP3AI {
    Pca9629TypeIoConfigP3 get ();
    void set (Pca9629TypeIoConfigP3 value);
}
member IOCP3AI : Pca9629TypeIoConfigP3 with get, set

Property Value

Type: Pca9629TypeIoConfigP3
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.IP Property

IRD

Pca9629IP Property

IP

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IP { get; }
Public ReadOnly Property IP As Byte
    Get
public:
property unsigned char IP {
    unsigned char get ();
}
member IP : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.IPAI Property

IRD

Pca9629IPAI Property

IP [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IPAI { get; }
Public ReadOnly Property IPAI As Byte
    Get
public:
property unsigned char IPAI {
    unsigned char get ();
}
member IPAI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.LOOPDLY Property

IRD

Pca9629LOOPDLY Property

LOOPDLY

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LOOPDLY { get; set; }
Public Property LOOPDLY As Byte
    Get
    Set
public:
property unsigned char LOOPDLY {
    unsigned char get ();
    void set (unsigned char value);
}
member LOOPDLY : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.LOOPDLYAI Property

IRD

Pca9629LOOPDLYAI Property

LOOPDLY [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LOOPDLYAI { get; set; }
Public Property LOOPDLYAI As Byte
    Get
    Set
public:
property unsigned char LOOPDLYAI {
    unsigned char get ();
    void set (unsigned char value);
}
member LOOPDLYAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MCNTLDirection Property

IRD

Pca9629MCNTLDirection Property

MCNTL: Direction

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeMotorControlDirection MCNTLDirection { get; set; }
Public Property MCNTLDirection As Pca9629TypeMotorControlDirection
    Get
    Set
public:
property Pca9629TypeMotorControlDirection MCNTLDirection {
    Pca9629TypeMotorControlDirection get ();
    void set (Pca9629TypeMotorControlDirection value);
}
member MCNTLDirection : Pca9629TypeMotorControlDirection with get, set

Property Value

Type: Pca9629TypeMotorControlDirection
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MCNTLDirectionAI Property

IRD

Pca9629MCNTLDirectionAI Property

MCNTL: Direction [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeMotorControlDirection MCNTLDirectionAI { get; set; }
Public Property MCNTLDirectionAI As Pca9629TypeMotorControlDirection
    Get
    Set
public:
property Pca9629TypeMotorControlDirection MCNTLDirectionAI {
    Pca9629TypeMotorControlDirection get ();
    void set (Pca9629TypeMotorControlDirection value);
}
member MCNTLDirectionAI : Pca9629TypeMotorControlDirection with get, set

Property Value

Type: Pca9629TypeMotorControlDirection
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MCNTLHardStop Property

IRD

Pca9629MCNTLHardStop Property

MCNTL: Hard Stop

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeMotorControlHardStop MCNTLHardStop { get; set; }
Public Property MCNTLHardStop As Pca9629TypeMotorControlHardStop
    Get
    Set
public:
property Pca9629TypeMotorControlHardStop MCNTLHardStop {
    Pca9629TypeMotorControlHardStop get ();
    void set (Pca9629TypeMotorControlHardStop value);
}
member MCNTLHardStop : Pca9629TypeMotorControlHardStop with get, set

Property Value

Type: Pca9629TypeMotorControlHardStop
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MCNTLHardStopAI Property

IRD

Pca9629MCNTLHardStopAI Property

MCNTL: Hard Stop [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeMotorControlHardStop MCNTLHardStopAI { get; set; }
Public Property MCNTLHardStopAI As Pca9629TypeMotorControlHardStop
    Get
    Set
public:
property Pca9629TypeMotorControlHardStop MCNTLHardStopAI {
    Pca9629TypeMotorControlHardStop get ();
    void set (Pca9629TypeMotorControlHardStop value);
}
member MCNTLHardStopAI : Pca9629TypeMotorControlHardStop with get, set

Property Value

Type: Pca9629TypeMotorControlHardStop
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MCNTLMode Property

IRD

Pca9629MCNTLMode Property

MCNTL: Mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeMotorControlMode MCNTLMode { get; set; }
Public Property MCNTLMode As Pca9629TypeMotorControlMode
    Get
    Set
public:
property Pca9629TypeMotorControlMode MCNTLMode {
    Pca9629TypeMotorControlMode get ();
    void set (Pca9629TypeMotorControlMode value);
}
member MCNTLMode : Pca9629TypeMotorControlMode with get, set

Property Value

Type: Pca9629TypeMotorControlMode
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MCNTLModeAI Property

IRD

Pca9629MCNTLModeAI Property

MCNTL: Mode [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeMotorControlMode MCNTLModeAI { get; set; }
Public Property MCNTLModeAI As Pca9629TypeMotorControlMode
    Get
    Set
public:
property Pca9629TypeMotorControlMode MCNTLModeAI {
    Pca9629TypeMotorControlMode get ();
    void set (Pca9629TypeMotorControlMode value);
}
member MCNTLModeAI : Pca9629TypeMotorControlMode with get, set

Property Value

Type: Pca9629TypeMotorControlMode
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MCNTLPerformAction Property

IRD

Pca9629MCNTLPerformAction Property

MCNTL: Perform Action

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeMotorControlPerformAction MCNTLPerformAction { get; set; }
Public Property MCNTLPerformAction As Pca9629TypeMotorControlPerformAction
    Get
    Set
public:
property Pca9629TypeMotorControlPerformAction MCNTLPerformAction {
    Pca9629TypeMotorControlPerformAction get ();
    void set (Pca9629TypeMotorControlPerformAction value);
}
member MCNTLPerformAction : Pca9629TypeMotorControlPerformAction with get, set

Property Value

Type: Pca9629TypeMotorControlPerformAction
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MCNTLPerformActionAI Property

IRD

Pca9629MCNTLPerformActionAI Property

MCNTL: Perform Action [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeMotorControlPerformAction MCNTLPerformActionAI { get; set; }
Public Property MCNTLPerformActionAI As Pca9629TypeMotorControlPerformAction
    Get
    Set
public:
property Pca9629TypeMotorControlPerformAction MCNTLPerformActionAI {
    Pca9629TypeMotorControlPerformAction get ();
    void set (Pca9629TypeMotorControlPerformAction value);
}
member MCNTLPerformActionAI : Pca9629TypeMotorControlPerformAction with get, set

Property Value

Type: Pca9629TypeMotorControlPerformAction
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MCNTLStartStop Property

IRD

Pca9629MCNTLStartStop Property

MCNTL: Start Stop

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeMotorControlStartStop MCNTLStartStop { get; set; }
Public Property MCNTLStartStop As Pca9629TypeMotorControlStartStop
    Get
    Set
public:
property Pca9629TypeMotorControlStartStop MCNTLStartStop {
    Pca9629TypeMotorControlStartStop get ();
    void set (Pca9629TypeMotorControlStartStop value);
}
member MCNTLStartStop : Pca9629TypeMotorControlStartStop with get, set

Property Value

Type: Pca9629TypeMotorControlStartStop
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MCNTLStartStopAI Property

IRD

Pca9629MCNTLStartStopAI Property

MCNTL: Start Stop [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeMotorControlStartStop MCNTLStartStopAI { get; set; }
Public Property MCNTLStartStopAI As Pca9629TypeMotorControlStartStop
    Get
    Set
public:
property Pca9629TypeMotorControlStartStop MCNTLStartStopAI {
    Pca9629TypeMotorControlStartStop get ();
    void set (Pca9629TypeMotorControlStartStop value);
}
member MCNTLStartStopAI : Pca9629TypeMotorControlStartStop with get, set

Property Value

Type: Pca9629TypeMotorControlStartStop
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MODEEnableDisableINT Property

IRD

Pca9629MODEEnableDisableINT Property

MODE: Enable Disable INT

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeModeIntOutput MODEEnableDisableINT { get; set; }
Public Property MODEEnableDisableINT As Pca9629TypeModeIntOutput
    Get
    Set
public:
property Pca9629TypeModeIntOutput MODEEnableDisableINT {
    Pca9629TypeModeIntOutput get ();
    void set (Pca9629TypeModeIntOutput value);
}
member MODEEnableDisableINT : Pca9629TypeModeIntOutput with get, set

Property Value

Type: Pca9629TypeModeIntOutput
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MODEEnableDisableINTAI Property

IRD

Pca9629MODEEnableDisableINTAI Property

MODE: Enable Disable INT [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeModeIntOutput MODEEnableDisableINTAI { get; set; }
Public Property MODEEnableDisableINTAI As Pca9629TypeModeIntOutput
    Get
    Set
public:
property Pca9629TypeModeIntOutput MODEEnableDisableINTAI {
    Pca9629TypeModeIntOutput get ();
    void set (Pca9629TypeModeIntOutput value);
}
member MODEEnableDisableINTAI : Pca9629TypeModeIntOutput with get, set

Property Value

Type: Pca9629TypeModeIntOutput
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MODEOutputChangeACKSTOP Property

IRD

Pca9629MODEOutputChangeACKSTOP Property

MODE: Output Change ACK STOP

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeModeOutputChange MODEOutputChangeACKSTOP { get; set; }
Public Property MODEOutputChangeACKSTOP As Pca9629TypeModeOutputChange
    Get
    Set
public:
property Pca9629TypeModeOutputChange MODEOutputChangeACKSTOP {
    Pca9629TypeModeOutputChange get ();
    void set (Pca9629TypeModeOutputChange value);
}
member MODEOutputChangeACKSTOP : Pca9629TypeModeOutputChange with get, set

Property Value

Type: Pca9629TypeModeOutputChange
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MODEOutputChangeACKSTOPAI Property

IRD

Pca9629MODEOutputChangeACKSTOPAI Property

MODE: Output Change ACK STOP [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeModeOutputChange MODEOutputChangeACKSTOPAI { get; set; }
Public Property MODEOutputChangeACKSTOPAI As Pca9629TypeModeOutputChange
    Get
    Set
public:
property Pca9629TypeModeOutputChange MODEOutputChangeACKSTOPAI {
    Pca9629TypeModeOutputChange get ();
    void set (Pca9629TypeModeOutputChange value);
}
member MODEOutputChangeACKSTOPAI : Pca9629TypeModeOutputChange with get, set

Property Value

Type: Pca9629TypeModeOutputChange
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MODERespondAllCall Property

IRD

Pca9629MODERespondAllCall Property

MODE: Respond All Call

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeModeRespondAllCall MODERespondAllCall { get; set; }
Public Property MODERespondAllCall As Pca9629TypeModeRespondAllCall
    Get
    Set
public:
property Pca9629TypeModeRespondAllCall MODERespondAllCall {
    Pca9629TypeModeRespondAllCall get ();
    void set (Pca9629TypeModeRespondAllCall value);
}
member MODERespondAllCall : Pca9629TypeModeRespondAllCall with get, set

Property Value

Type: Pca9629TypeModeRespondAllCall
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MODERespondAllCallAI Property

IRD

Pca9629MODERespondAllCallAI Property

MODE: Respond All Call [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeModeRespondAllCall MODERespondAllCallAI { get; set; }
Public Property MODERespondAllCallAI As Pca9629TypeModeRespondAllCall
    Get
    Set
public:
property Pca9629TypeModeRespondAllCall MODERespondAllCallAI {
    Pca9629TypeModeRespondAllCall get ();
    void set (Pca9629TypeModeRespondAllCall value);
}
member MODERespondAllCallAI : Pca9629TypeModeRespondAllCall with get, set

Property Value

Type: Pca9629TypeModeRespondAllCall
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MODERespondSubaddress1 Property

IRD

Pca9629MODERespondSubaddress1 Property

MODE: Respond Subaddress 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeModeRespondSubadr1 MODERespondSubaddress1 { get; set; }
Public Property MODERespondSubaddress1 As Pca9629TypeModeRespondSubadr1
    Get
    Set
public:
property Pca9629TypeModeRespondSubadr1 MODERespondSubaddress1 {
    Pca9629TypeModeRespondSubadr1 get ();
    void set (Pca9629TypeModeRespondSubadr1 value);
}
member MODERespondSubaddress1 : Pca9629TypeModeRespondSubadr1 with get, set

Property Value

Type: Pca9629TypeModeRespondSubadr1
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MODERespondSubaddress1AI Property

IRD

Pca9629MODERespondSubaddress1AI Property

MODE: Respond Subaddress 1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeModeRespondSubadr1 MODERespondSubaddress1AI { get; set; }
Public Property MODERespondSubaddress1AI As Pca9629TypeModeRespondSubadr1
    Get
    Set
public:
property Pca9629TypeModeRespondSubadr1 MODERespondSubaddress1AI {
    Pca9629TypeModeRespondSubadr1 get ();
    void set (Pca9629TypeModeRespondSubadr1 value);
}
member MODERespondSubaddress1AI : Pca9629TypeModeRespondSubadr1 with get, set

Property Value

Type: Pca9629TypeModeRespondSubadr1
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MODERespondSubaddress2 Property

IRD

Pca9629MODERespondSubaddress2 Property

MODE: Respond Subaddress 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeModeRespondSubadr2 MODERespondSubaddress2 { get; set; }
Public Property MODERespondSubaddress2 As Pca9629TypeModeRespondSubadr2
    Get
    Set
public:
property Pca9629TypeModeRespondSubadr2 MODERespondSubaddress2 {
    Pca9629TypeModeRespondSubadr2 get ();
    void set (Pca9629TypeModeRespondSubadr2 value);
}
member MODERespondSubaddress2 : Pca9629TypeModeRespondSubadr2 with get, set

Property Value

Type: Pca9629TypeModeRespondSubadr2
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MODERespondSubaddress2AI Property

IRD

Pca9629MODERespondSubaddress2AI Property

MODE: Respond Subaddress 2 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeModeRespondSubadr2 MODERespondSubaddress2AI { get; set; }
Public Property MODERespondSubaddress2AI As Pca9629TypeModeRespondSubadr2
    Get
    Set
public:
property Pca9629TypeModeRespondSubadr2 MODERespondSubaddress2AI {
    Pca9629TypeModeRespondSubadr2 get ();
    void set (Pca9629TypeModeRespondSubadr2 value);
}
member MODERespondSubaddress2AI : Pca9629TypeModeRespondSubadr2 with get, set

Property Value

Type: Pca9629TypeModeRespondSubadr2
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MODERespondSubaddress3 Property

IRD

Pca9629MODERespondSubaddress3 Property

MODE: Respond Subaddress 3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeModeRespondSubadr3 MODERespondSubaddress3 { get; set; }
Public Property MODERespondSubaddress3 As Pca9629TypeModeRespondSubadr3
    Get
    Set
public:
property Pca9629TypeModeRespondSubadr3 MODERespondSubaddress3 {
    Pca9629TypeModeRespondSubadr3 get ();
    void set (Pca9629TypeModeRespondSubadr3 value);
}
member MODERespondSubaddress3 : Pca9629TypeModeRespondSubadr3 with get, set

Property Value

Type: Pca9629TypeModeRespondSubadr3
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MODERespondSubaddress3AI Property

IRD

Pca9629MODERespondSubaddress3AI Property

MODE: Respond Subaddress 3 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeModeRespondSubadr3 MODERespondSubaddress3AI { get; set; }
Public Property MODERespondSubaddress3AI As Pca9629TypeModeRespondSubadr3
    Get
    Set
public:
property Pca9629TypeModeRespondSubadr3 MODERespondSubaddress3AI {
    Pca9629TypeModeRespondSubadr3 get ();
    void set (Pca9629TypeModeRespondSubadr3 value);
}
member MODERespondSubaddress3AI : Pca9629TypeModeRespondSubadr3 with get, set

Property Value

Type: Pca9629TypeModeRespondSubadr3
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MSKP0 Property

IRD

Pca9629MSKP0 Property

MSK: P0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeMaskInterruptP0 MSKP0 { get; set; }
Public Property MSKP0 As Pca9629TypeMaskInterruptP0
    Get
    Set
public:
property Pca9629TypeMaskInterruptP0 MSKP0 {
    Pca9629TypeMaskInterruptP0 get ();
    void set (Pca9629TypeMaskInterruptP0 value);
}
member MSKP0 : Pca9629TypeMaskInterruptP0 with get, set

Property Value

Type: Pca9629TypeMaskInterruptP0
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MSKP0AI Property

IRD

Pca9629MSKP0AI Property

MSK: P0 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeMaskInterruptP0 MSKP0AI { get; set; }
Public Property MSKP0AI As Pca9629TypeMaskInterruptP0
    Get
    Set
public:
property Pca9629TypeMaskInterruptP0 MSKP0AI {
    Pca9629TypeMaskInterruptP0 get ();
    void set (Pca9629TypeMaskInterruptP0 value);
}
member MSKP0AI : Pca9629TypeMaskInterruptP0 with get, set

Property Value

Type: Pca9629TypeMaskInterruptP0
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MSKP1 Property

IRD

Pca9629MSKP1 Property

MSK: P1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeMaskInterruptP1 MSKP1 { get; set; }
Public Property MSKP1 As Pca9629TypeMaskInterruptP1
    Get
    Set
public:
property Pca9629TypeMaskInterruptP1 MSKP1 {
    Pca9629TypeMaskInterruptP1 get ();
    void set (Pca9629TypeMaskInterruptP1 value);
}
member MSKP1 : Pca9629TypeMaskInterruptP1 with get, set

Property Value

Type: Pca9629TypeMaskInterruptP1
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MSKP1AI Property

IRD

Pca9629MSKP1AI Property

MSK: P1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeMaskInterruptP1 MSKP1AI { get; set; }
Public Property MSKP1AI As Pca9629TypeMaskInterruptP1
    Get
    Set
public:
property Pca9629TypeMaskInterruptP1 MSKP1AI {
    Pca9629TypeMaskInterruptP1 get ();
    void set (Pca9629TypeMaskInterruptP1 value);
}
member MSKP1AI : Pca9629TypeMaskInterruptP1 with get, set

Property Value

Type: Pca9629TypeMaskInterruptP1
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MSKP2 Property

IRD

Pca9629MSKP2 Property

MSK: P2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeMaskInterruptP2 MSKP2 { get; set; }
Public Property MSKP2 As Pca9629TypeMaskInterruptP2
    Get
    Set
public:
property Pca9629TypeMaskInterruptP2 MSKP2 {
    Pca9629TypeMaskInterruptP2 get ();
    void set (Pca9629TypeMaskInterruptP2 value);
}
member MSKP2 : Pca9629TypeMaskInterruptP2 with get, set

Property Value

Type: Pca9629TypeMaskInterruptP2
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MSKP2AI Property

IRD

Pca9629MSKP2AI Property

MSK: P2 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeMaskInterruptP2 MSKP2AI { get; set; }
Public Property MSKP2AI As Pca9629TypeMaskInterruptP2
    Get
    Set
public:
property Pca9629TypeMaskInterruptP2 MSKP2AI {
    Pca9629TypeMaskInterruptP2 get ();
    void set (Pca9629TypeMaskInterruptP2 value);
}
member MSKP2AI : Pca9629TypeMaskInterruptP2 with get, set

Property Value

Type: Pca9629TypeMaskInterruptP2
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MSKP3 Property

IRD

Pca9629MSKP3 Property

MSK: P3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeMaskInterruptP3 MSKP3 { get; set; }
Public Property MSKP3 As Pca9629TypeMaskInterruptP3
    Get
    Set
public:
property Pca9629TypeMaskInterruptP3 MSKP3 {
    Pca9629TypeMaskInterruptP3 get ();
    void set (Pca9629TypeMaskInterruptP3 value);
}
member MSKP3 : Pca9629TypeMaskInterruptP3 with get, set

Property Value

Type: Pca9629TypeMaskInterruptP3
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.MSKP3AI Property

IRD

Pca9629MSKP3AI Property

MSK: P3 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeMaskInterruptP3 MSKP3AI { get; set; }
Public Property MSKP3AI As Pca9629TypeMaskInterruptP3
    Get
    Set
public:
property Pca9629TypeMaskInterruptP3 MSKP3AI {
    Pca9629TypeMaskInterruptP3 get ();
    void set (Pca9629TypeMaskInterruptP3 value);
}
member MSKP3AI : Pca9629TypeMaskInterruptP3 with get, set

Property Value

Type: Pca9629TypeMaskInterruptP3
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.OP Property

IRD

Pca9629OP Property

OP

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OP { get; set; }
Public Property OP As Byte
    Get
    Set
public:
property unsigned char OP {
    unsigned char get ();
    void set (unsigned char value);
}
member OP : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.OPAI Property

IRD

Pca9629OPAI Property

OP [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OPAI { get; set; }
Public Property OPAI As Byte
    Get
    Set
public:
property unsigned char OPAI {
    unsigned char get ();
    void set (unsigned char value);
}
member OPAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.PHCNTLOutputDriveAI Property

IRD

Pca9629PHCNTLOutputDriveAI Property

PHCNTL: Output Drive [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypePhaseControl PHCNTLOutputDriveAI { get; set; }
Public Property PHCNTLOutputDriveAI As Pca9629TypePhaseControl
    Get
    Set
public:
property Pca9629TypePhaseControl PHCNTLOutputDriveAI {
    Pca9629TypePhaseControl get ();
    void set (Pca9629TypePhaseControl value);
}
member PHCNTLOutputDriveAI : Pca9629TypePhaseControl with get, set

Property Value

Type: Pca9629TypePhaseControl
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.PHCNTLPhaseControlOutputDrive Property

IRD

Pca9629PHCNTLPhaseControlOutputDrive Property

PHCNTL: Phase Control Output Drive

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypePhaseControl PHCNTLPhaseControlOutputDrive { get; set; }
Public Property PHCNTLPhaseControlOutputDrive As Pca9629TypePhaseControl
    Get
    Set
public:
property Pca9629TypePhaseControl PHCNTLPhaseControlOutputDrive {
    Pca9629TypePhaseControl get ();
    void set (Pca9629TypePhaseControl value);
}
member PHCNTLPhaseControlOutputDrive : Pca9629TypePhaseControl with get, set

Property Value

Type: Pca9629TypePhaseControl
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.RMPCNTLRampDown Property

IRD

Pca9629RMPCNTLRampDown Property

RMPCNTL: Ramp Down

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeRampControlRampDown RMPCNTLRampDown { get; set; }
Public Property RMPCNTLRampDown As Pca9629TypeRampControlRampDown
    Get
    Set
public:
property Pca9629TypeRampControlRampDown RMPCNTLRampDown {
    Pca9629TypeRampControlRampDown get ();
    void set (Pca9629TypeRampControlRampDown value);
}
member RMPCNTLRampDown : Pca9629TypeRampControlRampDown with get, set

Property Value

Type: Pca9629TypeRampControlRampDown
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.RMPCNTLRampDownAI Property

IRD

Pca9629RMPCNTLRampDownAI Property

RMPCNTL: Ramp Down [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeRampControlRampDown RMPCNTLRampDownAI { get; set; }
Public Property RMPCNTLRampDownAI As Pca9629TypeRampControlRampDown
    Get
    Set
public:
property Pca9629TypeRampControlRampDown RMPCNTLRampDownAI {
    Pca9629TypeRampControlRampDown get ();
    void set (Pca9629TypeRampControlRampDown value);
}
member RMPCNTLRampDownAI : Pca9629TypeRampControlRampDown with get, set

Property Value

Type: Pca9629TypeRampControlRampDown
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.RMPCNTLRampUp Property

IRD

Pca9629RMPCNTLRampUp Property

RMPCNTL: Ramp Up

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeRampControlRampUp RMPCNTLRampUp { get; set; }
Public Property RMPCNTLRampUp As Pca9629TypeRampControlRampUp
    Get
    Set
public:
property Pca9629TypeRampControlRampUp RMPCNTLRampUp {
    Pca9629TypeRampControlRampUp get ();
    void set (Pca9629TypeRampControlRampUp value);
}
member RMPCNTLRampUp : Pca9629TypeRampControlRampUp with get, set

Property Value

Type: Pca9629TypeRampControlRampUp
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.RMPCNTLRampUpAI Property

IRD

Pca9629RMPCNTLRampUpAI Property

RMPCNTL: Ramp Up [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeRampControlRampUp RMPCNTLRampUpAI { get; set; }
Public Property RMPCNTLRampUpAI As Pca9629TypeRampControlRampUp
    Get
    Set
public:
property Pca9629TypeRampControlRampUp RMPCNTLRampUpAI {
    Pca9629TypeRampControlRampUp get ();
    void set (Pca9629TypeRampControlRampUp value);
}
member RMPCNTLRampUpAI : Pca9629TypeRampControlRampUp with get, set

Property Value

Type: Pca9629TypeRampControlRampUp
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.RMPCNTLStepFactor Property

IRD

Pca9629RMPCNTLStepFactor Property

RMPCNTL: Step Factor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeRampControlRampStep RMPCNTLStepFactor { get; set; }
Public Property RMPCNTLStepFactor As Pca9629TypeRampControlRampStep
    Get
    Set
public:
property Pca9629TypeRampControlRampStep RMPCNTLStepFactor {
    Pca9629TypeRampControlRampStep get ();
    void set (Pca9629TypeRampControlRampStep value);
}
member RMPCNTLStepFactor : Pca9629TypeRampControlRampStep with get, set

Property Value

Type: Pca9629TypeRampControlRampStep
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.RMPCNTLStepFactorAI Property

IRD

Pca9629RMPCNTLStepFactorAI Property

RMPCNTL: Step Factor [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeRampControlRampStep RMPCNTLStepFactorAI { get; set; }
Public Property RMPCNTLStepFactorAI As Pca9629TypeRampControlRampStep
    Get
    Set
public:
property Pca9629TypeRampControlRampStep RMPCNTLStepFactorAI {
    Pca9629TypeRampControlRampStep get ();
    void set (Pca9629TypeRampControlRampStep value);
}
member RMPCNTLStepFactorAI : Pca9629TypeRampControlRampStep with get, set

Property Value

Type: Pca9629TypeRampControlRampStep
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.SETMODECCWStop Property

IRD

Pca9629SETMODECCWStop Property

SETMODE: CCW Stop

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeSetmodeOutputCcwStop SETMODECCWStop { get; set; }
Public Property SETMODECCWStop As Pca9629TypeSetmodeOutputCcwStop
    Get
    Set
public:
property Pca9629TypeSetmodeOutputCcwStop SETMODECCWStop {
    Pca9629TypeSetmodeOutputCcwStop get ();
    void set (Pca9629TypeSetmodeOutputCcwStop value);
}
member SETMODECCWStop : Pca9629TypeSetmodeOutputCcwStop with get, set

Property Value

Type: Pca9629TypeSetmodeOutputCcwStop
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.SETMODECCWStopAI Property

IRD

Pca9629SETMODECCWStopAI Property

SETMODE: CCW Stop [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeSetmodeOutputCcwStop SETMODECCWStopAI { get; set; }
Public Property SETMODECCWStopAI As Pca9629TypeSetmodeOutputCcwStop
    Get
    Set
public:
property Pca9629TypeSetmodeOutputCcwStop SETMODECCWStopAI {
    Pca9629TypeSetmodeOutputCcwStop get ();
    void set (Pca9629TypeSetmodeOutputCcwStop value);
}
member SETMODECCWStopAI : Pca9629TypeSetmodeOutputCcwStop with get, set

Property Value

Type: Pca9629TypeSetmodeOutputCcwStop
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.SETMODECWStop Property

IRD

Pca9629SETMODECWStop Property

SETMODE: CW Stop

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeSetmodeOutputCwStop SETMODECWStop { get; set; }
Public Property SETMODECWStop As Pca9629TypeSetmodeOutputCwStop
    Get
    Set
public:
property Pca9629TypeSetmodeOutputCwStop SETMODECWStop {
    Pca9629TypeSetmodeOutputCwStop get ();
    void set (Pca9629TypeSetmodeOutputCwStop value);
}
member SETMODECWStop : Pca9629TypeSetmodeOutputCwStop with get, set

Property Value

Type: Pca9629TypeSetmodeOutputCwStop
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.SETMODECWStopAI Property

IRD

Pca9629SETMODECWStopAI Property

SETMODE: CW Stop [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeSetmodeOutputCwStop SETMODECWStopAI { get; set; }
Public Property SETMODECWStopAI As Pca9629TypeSetmodeOutputCwStop
    Get
    Set
public:
property Pca9629TypeSetmodeOutputCwStop SETMODECWStopAI {
    Pca9629TypeSetmodeOutputCwStop get ();
    void set (Pca9629TypeSetmodeOutputCwStop value);
}
member SETMODECWStopAI : Pca9629TypeSetmodeOutputCwStop with get, set

Property Value

Type: Pca9629TypeSetmodeOutputCwStop
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.SROTNH Property

IRD

Pca9629SROTNH Property

SROTNH

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SROTNH { get; set; }
Public Property SROTNH As Byte
    Get
    Set
public:
property unsigned char SROTNH {
    unsigned char get ();
    void set (unsigned char value);
}
member SROTNH : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.SROTNHAI Property

IRD

Pca9629SROTNHAI Property

SROTNH [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SROTNHAI { get; set; }
Public Property SROTNHAI As Byte
    Get
    Set
public:
property unsigned char SROTNHAI {
    unsigned char get ();
    void set (unsigned char value);
}
member SROTNHAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.SROTNL Property

IRD

Pca9629SROTNL Property

SROTNL

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SROTNL { get; set; }
Public Property SROTNL As Byte
    Get
    Set
public:
property unsigned char SROTNL {
    unsigned char get ();
    void set (unsigned char value);
}
member SROTNL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.SROTNLAI Property

IRD

Pca9629SROTNLAI Property

SROTNL [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SROTNLAI { get; set; }
Public Property SROTNLAI As Byte
    Get
    Set
public:
property unsigned char SROTNLAI {
    unsigned char get ();
    void set (unsigned char value);
}
member SROTNLAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.SUBADR1 Property

IRD

Pca9629SUBADR1 Property

SUBADR1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SUBADR1 { get; set; }
Public Property SUBADR1 As Byte
    Get
    Set
public:
property unsigned char SUBADR1 {
    unsigned char get ();
    void set (unsigned char value);
}
member SUBADR1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.SUBADR1AI Property

IRD

Pca9629SUBADR1AI Property

SUBADR1 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SUBADR1AI { get; set; }
Public Property SUBADR1AI As Byte
    Get
    Set
public:
property unsigned char SUBADR1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member SUBADR1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.SUBADR2 Property

IRD

Pca9629SUBADR2 Property

SUBADR2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SUBADR2 { get; set; }
Public Property SUBADR2 As Byte
    Get
    Set
public:
property unsigned char SUBADR2 {
    unsigned char get ();
    void set (unsigned char value);
}
member SUBADR2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.SUBADR2AI Property

IRD

Pca9629SUBADR2AI Property

SUBADR2 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SUBADR2AI { get; set; }
Public Property SUBADR2AI As Byte
    Get
    Set
public:
property unsigned char SUBADR2AI {
    unsigned char get ();
    void set (unsigned char value);
}
member SUBADR2AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.SUBADR3 Property

IRD

Pca9629SUBADR3 Property

SUBADR3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SUBADR3 { get; set; }
Public Property SUBADR3 As Byte
    Get
    Set
public:
property unsigned char SUBADR3 {
    unsigned char get ();
    void set (unsigned char value);
}
member SUBADR3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.SUBADR3AI Property

IRD

Pca9629SUBADR3AI Property

SUBADR3 [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SUBADR3AI { get; set; }
Public Property SUBADR3AI As Byte
    Get
    Set
public:
property unsigned char SUBADR3AI {
    unsigned char get ();
    void set (unsigned char value);
}
member SUBADR3AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.WDCNTLWDEN Property

IRD

Pca9629WDCNTLWDEN Property

WDCNTL: WDEN

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeWdcntlWdEnableDisable WDCNTLWDEN { get; set; }
Public Property WDCNTLWDEN As Pca9629TypeWdcntlWdEnableDisable
    Get
    Set
public:
property Pca9629TypeWdcntlWdEnableDisable WDCNTLWDEN {
    Pca9629TypeWdcntlWdEnableDisable get ();
    void set (Pca9629TypeWdcntlWdEnableDisable value);
}
member WDCNTLWDEN : Pca9629TypeWdcntlWdEnableDisable with get, set

Property Value

Type: Pca9629TypeWdcntlWdEnableDisable
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.WDCNTLWDENAI Property

IRD

Pca9629WDCNTLWDENAI Property

WDCNTL: WDEN [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeWdcntlWdEnableDisable WDCNTLWDENAI { get; set; }
Public Property WDCNTLWDENAI As Pca9629TypeWdcntlWdEnableDisable
    Get
    Set
public:
property Pca9629TypeWdcntlWdEnableDisable WDCNTLWDENAI {
    Pca9629TypeWdcntlWdEnableDisable get ();
    void set (Pca9629TypeWdcntlWdEnableDisable value);
}
member WDCNTLWDENAI : Pca9629TypeWdcntlWdEnableDisable with get, set

Property Value

Type: Pca9629TypeWdcntlWdEnableDisable
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.WDCNTLWDINTFlag Property

IRD

Pca9629WDCNTLWDINTFlag Property

WDCNTL: WDINT Flag

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeWdcntlWdInterruptFlag WDCNTLWDINTFlag { get; }
Public ReadOnly Property WDCNTLWDINTFlag As Pca9629TypeWdcntlWdInterruptFlag
    Get
public:
property Pca9629TypeWdcntlWdInterruptFlag WDCNTLWDINTFlag {
    Pca9629TypeWdcntlWdInterruptFlag get ();
}
member WDCNTLWDINTFlag : Pca9629TypeWdcntlWdInterruptFlag with get

Property Value

Type: Pca9629TypeWdcntlWdInterruptFlag
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.WDCNTLWDINTFlagAI Property

IRD

Pca9629WDCNTLWDINTFlagAI Property

WDCNTL: WDINT Flag [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeWdcntlWdInterruptFlag WDCNTLWDINTFlagAI { get; }
Public ReadOnly Property WDCNTLWDINTFlagAI As Pca9629TypeWdcntlWdInterruptFlag
    Get
public:
property Pca9629TypeWdcntlWdInterruptFlag WDCNTLWDINTFlagAI {
    Pca9629TypeWdcntlWdInterruptFlag get ();
}
member WDCNTLWDINTFlagAI : Pca9629TypeWdcntlWdInterruptFlag with get

Property Value

Type: Pca9629TypeWdcntlWdInterruptFlag
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.WDCNTLWDINTFlagControl Property

IRD

Pca9629WDCNTLWDINTFlagControl Property

WDCNTL: WDINT Flag Control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeWdcntlWdInterruptFlagControl WDCNTLWDINTFlagControl { set; }
Public WriteOnly Property WDCNTLWDINTFlagControl As Pca9629TypeWdcntlWdInterruptFlagControl
    Set
public:
property Pca9629TypeWdcntlWdInterruptFlagControl WDCNTLWDINTFlagControl {
    void set (Pca9629TypeWdcntlWdInterruptFlagControl value);
}
member WDCNTLWDINTFlagControl : Pca9629TypeWdcntlWdInterruptFlagControl with set

Property Value

Type: Pca9629TypeWdcntlWdInterruptFlagControl
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.WDCNTLWDINTFlagControlAI Property

IRD

Pca9629WDCNTLWDINTFlagControlAI Property

WDCNTL: WDINT Flag Control [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeWdcntlWdInterruptFlagControl WDCNTLWDINTFlagControlAI { set; }
Public WriteOnly Property WDCNTLWDINTFlagControlAI As Pca9629TypeWdcntlWdInterruptFlagControl
    Set
public:
property Pca9629TypeWdcntlWdInterruptFlagControl WDCNTLWDINTFlagControlAI {
    void set (Pca9629TypeWdcntlWdInterruptFlagControl value);
}
member WDCNTLWDINTFlagControlAI : Pca9629TypeWdcntlWdInterruptFlagControl with set

Property Value

Type: Pca9629TypeWdcntlWdInterruptFlagControl
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.WDCNTLWDMOD Property

IRD

Pca9629WDCNTLWDMOD Property

WDCNTL: WDMOD

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeWdcntlWdMode WDCNTLWDMOD { get; set; }
Public Property WDCNTLWDMOD As Pca9629TypeWdcntlWdMode
    Get
    Set
public:
property Pca9629TypeWdcntlWdMode WDCNTLWDMOD {
    Pca9629TypeWdcntlWdMode get ();
    void set (Pca9629TypeWdcntlWdMode value);
}
member WDCNTLWDMOD : Pca9629TypeWdcntlWdMode with get, set

Property Value

Type: Pca9629TypeWdcntlWdMode
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.WDCNTLWDMODAI Property

IRD

Pca9629WDCNTLWDMODAI Property

WDCNTL: WDMOD [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeWdcntlWdMode WDCNTLWDMODAI { get; set; }
Public Property WDCNTLWDMODAI As Pca9629TypeWdcntlWdMode
    Get
    Set
public:
property Pca9629TypeWdcntlWdMode WDCNTLWDMODAI {
    Pca9629TypeWdcntlWdMode get ();
    void set (Pca9629TypeWdcntlWdMode value);
}
member WDCNTLWDMODAI : Pca9629TypeWdcntlWdMode with get, set

Property Value

Type: Pca9629TypeWdcntlWdMode
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.WDCNTLWDRSTFlag Property

IRD

Pca9629WDCNTLWDRSTFlag Property

WDCNTL: WDRST Flag

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeWdcntlWdResetFlag WDCNTLWDRSTFlag { get; set; }
Public Property WDCNTLWDRSTFlag As Pca9629TypeWdcntlWdResetFlag
    Get
    Set
public:
property Pca9629TypeWdcntlWdResetFlag WDCNTLWDRSTFlag {
    Pca9629TypeWdcntlWdResetFlag get ();
    void set (Pca9629TypeWdcntlWdResetFlag value);
}
member WDCNTLWDRSTFlag : Pca9629TypeWdcntlWdResetFlag with get, set

Property Value

Type: Pca9629TypeWdcntlWdResetFlag
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.WDCNTLWDRSTFlagAI Property

IRD

Pca9629WDCNTLWDRSTFlagAI Property

WDCNTL: WDRST Flag [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9629TypeWdcntlWdResetFlag WDCNTLWDRSTFlagAI { get; set; }
Public Property WDCNTLWDRSTFlagAI As Pca9629TypeWdcntlWdResetFlag
    Get
    Set
public:
property Pca9629TypeWdcntlWdResetFlag WDCNTLWDRSTFlagAI {
    Pca9629TypeWdcntlWdResetFlag get ();
    void set (Pca9629TypeWdcntlWdResetFlag value);
}
member WDCNTLWDRSTFlagAI : Pca9629TypeWdcntlWdResetFlag with get, set

Property Value

Type: Pca9629TypeWdcntlWdResetFlag
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.WDTOI Property

IRD

Pca9629WDTOI Property

WDTOI

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WDTOI { get; set; }
Public Property WDTOI As Byte
    Get
    Set
public:
property unsigned char WDTOI {
    unsigned char get ();
    void set (unsigned char value);
}
member WDTOI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.WDTOIAI Property

IRD

Pca9629WDTOIAI Property

WDTOI [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WDTOIAI { get; set; }
Public Property WDTOIAI As Byte
    Get
    Set
public:
property unsigned char WDTOIAI {
    unsigned char get ();
    void set (unsigned char value);
}
member WDTOIAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629 Methods

The Pca9629 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.Flush Method

IRD

Pca9629Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9629 Class
telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeClearIntP0 Enumeration

IRD

Pca9629TypeClearIntP0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClearIntP0
Public Enumeration TypeClearIntP0
public enum class TypeClearIntP0
type TypeClearIntP0
Members
Member name | Value | Description
INTP0ReadValue | 0 | INTP0: Read Value
INTP0ClearFlag | 1 | INTP0: Clear Flag
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeClearIntP1 Enumeration

IRD

Pca9629TypeClearIntP1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClearIntP1
Public Enumeration TypeClearIntP1
public enum class TypeClearIntP1
type TypeClearIntP1
Members
Member name | Value | Description
INTP1ReadValue | 0 | INTP1: Read Value
INTP1ClearFlag | 1 | INTP1: Clear Flag
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeClearIntP2 Enumeration

IRD

Pca9629TypeClearIntP2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClearIntP2
Public Enumeration TypeClearIntP2
public enum class TypeClearIntP2
type TypeClearIntP2
Members
Member name | Value | Description
INTP2ReadValue | 0 | INTP2: Read Value
INTP2ClearFlag | 1 | INTP2: Clear Flag
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeClearIntP3 Enumeration

IRD

Pca9629TypeClearIntP3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClearIntP3
Public Enumeration TypeClearIntP3
public enum class TypeClearIntP3
type TypeClearIntP3
Members
Member name | Value | Description
INTP3ReadValue | 0 | INTP3: Read Value
INTP3ClearFlag | 1 | INTP3: Clear Flag
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeIntActionInterruptMotorControl Enumeration

IRD

Pca9629TypeIntActionInterruptMotorControl Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntActionInterruptMotorControl
Public Enumeration TypeIntActionInterruptMotorControl
public enum class TypeIntActionInterruptMotorControl
type TypeIntActionInterruptMotorControl
Members
Member name | Value | Description
InterruptMotorControlDisable | 0 | Interrupt Motor Control: Disable
InterruptMotorControlEnable | 1 | Interrupt Motor Control: Enable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeIntActionUnitExtrasteps Enumeration

IRD

Pca9629TypeIntActionUnitExtrasteps Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntActionUnitExtrasteps
Public Enumeration TypeIntActionUnitExtrasteps
public enum class TypeIntActionUnitExtrasteps
type TypeIntActionUnitExtrasteps
Members
Member name | Value | Description
P0AndP1CounterUnitIsNumberOfSteps | 0 | P0 and P1 Counter Unit Is Number Of: Steps
P0AndP1CounterUnitIsNumberOfFullRotations | 1 | P0 and P1 Counter Unit Is Number Of: Full Rotations
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeIntAutoClr Enumeration

IRD

Pca9629TypeIntAutoClr Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntAutoClr
Public Enumeration TypeIntAutoClr
public enum class TypeIntAutoClr
type TypeIntAutoClr
Members
Member name | Value | Description
DisableAutoClearForINTP0AndINTP1 | 0 | Disable Auto Clear For INTP0 And INTP1
INTP0ClearsINTP1INTP1ClearsINTP0 | 1 | INTP0 Clears INTP1, INTP1 Clears INTP0
INTP1ClearsINTP0 | 2 | INTP1 Clears INTP0
INTP0ClearsINTP1 | 3 | INTP0 Clears INTP1
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeIntExtraStep Enumeration

IRD

Pca9629TypeIntExtraStep Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntExtraStep
Public Enumeration TypeIntExtraStep
public enum class TypeIntExtraStep
type TypeIntExtraStep
Members
Member name | Value | Description
DisableExtrastepsForINTP0AndINTP1 | 0 | Disable Extrasteps For INTP0 And INTP1
EnableExtrastepsForINTP0 | 1 | Enable Extrasteps For INTP0
EnableExtrastepsForINTP1 | 2 | Enable Extrasteps For INTP1
EnableExtrastepsForINTP0AndINTP1 | 3 | Enable Extrasteps For INTP0 And INTP1
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeIntModeP0 Enumeration

IRD

Pca9629TypeIntModeP0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntModeP0
Public Enumeration TypeIntModeP0
public enum class TypeIntModeP0
type TypeIntModeP0
Members
Member name | Value | Description
P0InterruptOccursOnRisingEdge | 0 | P0 Interrupt Occurs: On Rising Edge
P0InterruptOccursOnFallingEdge | 1 | P0 Interrupt Occurs: On Falling Edge
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeIntModeP1 Enumeration

IRD

Pca9629TypeIntModeP1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntModeP1
Public Enumeration TypeIntModeP1
public enum class TypeIntModeP1
type TypeIntModeP1
Members
Member name | Value | Description
P1InterruptOccursOnRisingEdge | 0 | P1 Interrupt Occurs: On Rising Edge
P1InterruptOccursOnFallingEdge | 1 | P1 Interrupt Occurs: On Falling Edge
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeIntModeP2 Enumeration

IRD

Pca9629TypeIntModeP2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntModeP2
Public Enumeration TypeIntModeP2
public enum class TypeIntModeP2
type TypeIntModeP2
Members
Member name | Value | Description
P2InterruptOccursOnRisingEdge | 0 | P2 Interrupt Occurs: On Rising Edge
P2InterruptOccursOnFallingEdge | 1 | P2 Interrupt Occurs: On Falling Edge
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeIntModeP3 Enumeration

IRD

Pca9629TypeIntModeP3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntModeP3
Public Enumeration TypeIntModeP3
public enum class TypeIntModeP3
type TypeIntModeP3
Members
Member name | Value | Description
P3InterruptOccursOnRisingEdge | 0 | P3 Interrupt Occurs: On Rising Edge
P3InterruptOccursOnFallingEdge | 1 | P3 Interrupt Occurs: On Falling Edge
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeIntMotorSetup Enumeration

IRD

Pca9629TypeIntMotorSetup Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntMotorSetup
Public Enumeration TypeIntMotorSetup
public enum class TypeIntMotorSetup
type TypeIntMotorSetup
Members
Member name | Value | Description
StopMotorOnINTCausedByP0 | 0 | Stop Motor On INT Caused By: P0
StopMotorOnINTCausedByP1 | 1 | Stop Motor On INT Caused By: P1
StopMotorOnINTCausedByP0OrP1 | 2 | Stop Motor On INT Caused By: P0 Or P1
ReserveMotorOnINTCausedByP0OrP1 | 3 | Reserve Motor On INT Caused By: P0 Or P1
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeIntstatIntp0Flag Enumeration

IRD

Pca9629TypeIntstatIntp0Flag Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntstatIntp0Flag
Public Enumeration TypeIntstatIntp0Flag
public enum class TypeIntstatIntp0Flag
type TypeIntstatIntp0Flag
Members
Member name | Value | Description
INTP0FlagClear | 0 | INTP0: Flag Clear
INTP0FlagSet | 1 | INTP0: Flag Set
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeIntstatIntp1Flag Enumeration

IRD

Pca9629TypeIntstatIntp1Flag Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntstatIntp1Flag
Public Enumeration TypeIntstatIntp1Flag
public enum class TypeIntstatIntp1Flag
type TypeIntstatIntp1Flag
Members
Member name | Value | Description
INTP1FlagClear | 0 | INTP1: Flag Clear
INTP1FlagSet | 1 | INTP1: Flag Set
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeIntstatIntp2Flag Enumeration

IRD

Pca9629TypeIntstatIntp2Flag Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntstatIntp2Flag
Public Enumeration TypeIntstatIntp2Flag
public enum class TypeIntstatIntp2Flag
type TypeIntstatIntp2Flag
Members
Member name | Value | Description
INTP2FlagClear | 0 | INTP2: Flag Clear
INTP2FlagSet | 1 | INTP2: Flag Set
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeIntstatIntp3Flag Enumeration

IRD

Pca9629TypeIntstatIntp3Flag Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIntstatIntp3Flag
Public Enumeration TypeIntstatIntp3Flag
public enum class TypeIntstatIntp3Flag
type TypeIntstatIntp3Flag
Members
Member name | Value | Description
INTP3FlagClear | 0 | INTP3: Flag Clear
INTP3FlagSet | 1 | INTP3: Flag Set
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeIoConfigP0 Enumeration

IRD

Pca9629TypeIoConfigP0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIoConfigP0
Public Enumeration TypeIoConfigP0
public enum class TypeIoConfigP0
type TypeIoConfigP0
Members
Member name | Value | Description
P0ConfiguredAsOutput | 0 | P0 Configured As: Output
P0ConfiguredAsInput | 1 | P0 Configured As: Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeIoConfigP1 Enumeration

IRD

Pca9629TypeIoConfigP1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIoConfigP1
Public Enumeration TypeIoConfigP1
public enum class TypeIoConfigP1
type TypeIoConfigP1
Members
Member name | Value | Description
P1ConfiguredAsOutput | 0 | P1 Configured As: Output
P1ConfiguredAsInput | 1 | P1 Configured As: Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeIoConfigP2 Enumeration

IRD

Pca9629TypeIoConfigP2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIoConfigP2
Public Enumeration TypeIoConfigP2
public enum class TypeIoConfigP2
type TypeIoConfigP2
Members
Member name | Value | Description
P2ConfiguredAsOutput | 0 | P2 Configured As: Output
P2ConfiguredAsInput | 1 | P2 Configured As: Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeIoConfigP3 Enumeration

IRD

Pca9629TypeIoConfigP3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIoConfigP3
Public Enumeration TypeIoConfigP3
public enum class TypeIoConfigP3
type TypeIoConfigP3
Members
Member name | Value | Description
P3ConfiguredAsOutput | 0 | P3 Configured As: Output
P3ConfiguredAsInput | 1 | P3 Configured As: Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeMaskInterruptP0 Enumeration

IRD

Pca9629TypeMaskInterruptP0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMaskInterruptP0
Public Enumeration TypeMaskInterruptP0
public enum class TypeMaskInterruptP0
type TypeMaskInterruptP0
Members
Member name | Value | Description
P0InterruptEnable | 0 | P0 Interrupt: Enable
P0InterruptDisable | 1 | P0 Interrupt: Disable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeMaskInterruptP1 Enumeration

IRD

Pca9629TypeMaskInterruptP1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMaskInterruptP1
Public Enumeration TypeMaskInterruptP1
public enum class TypeMaskInterruptP1
type TypeMaskInterruptP1
Members
Member name | Value | Description
P1InterruptEnable | 0 | P1 Interrupt: Enable
P1InterruptDisable | 1 | P1 Interrupt: Disable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeMaskInterruptP2 Enumeration

IRD

Pca9629TypeMaskInterruptP2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMaskInterruptP2
Public Enumeration TypeMaskInterruptP2
public enum class TypeMaskInterruptP2
type TypeMaskInterruptP2
Members
Member name | Value | Description
P2InterruptEnable | 0 | P2 Interrupt: Enable
P2InterruptDisable | 1 | P2 Interrupt: Disable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeMaskInterruptP3 Enumeration

IRD

Pca9629TypeMaskInterruptP3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMaskInterruptP3
Public Enumeration TypeMaskInterruptP3
public enum class TypeMaskInterruptP3
type TypeMaskInterruptP3
Members
Member name | Value | Description
P3InterruptEnable | 0 | P3 Interrupt: Enable
P3InterruptDisable | 1 | P3 Interrupt: Disable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeModeIntOutput Enumeration

IRD

Pca9629TypeModeIntOutput Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeIntOutput
Public Enumeration TypeModeIntOutput
public enum class TypeModeIntOutput
type TypeModeIntOutput
Members
Member name | Value | Description
INTOutputPinEnable | 0 | INT Output Pin: Enable
DisableOutputPin | 1 | Disable Output Pin
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeModeOutputChange Enumeration

IRD

Pca9629TypeModeOutputChange Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeOutputChange
Public Enumeration TypeModeOutputChange
public enum class TypeModeOutputChange
type TypeModeOutputChange
Members
Member name | Value | Description
OutputChangeOnI2CSTOP | 0 | Output Change On I2C: STOP
OutputChangeOnI2CSTOP__1 | 1 | Output Change On I2C: STOP
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeModeRespondAllCall Enumeration

IRD

Pca9629TypeModeRespondAllCall Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeRespondAllCall
Public Enumeration TypeModeRespondAllCall
public enum class TypeModeRespondAllCall
type TypeModeRespondAllCall
Members
Member name | Value | Description
ICNotRespondingToAllCallAddress | 0 | IC Not Responding To All Call Address
ICRespondingToAllCallAddress | 1 | IC Responding To All Call Address
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeModeRespondSubadr1 Enumeration

IRD

Pca9629TypeModeRespondSubadr1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeRespondSubadr1
Public Enumeration TypeModeRespondSubadr1
public enum class TypeModeRespondSubadr1
type TypeModeRespondSubadr1
Members
Member name | Value | Description
ICNotRespondingToSubaddress1 | 0 | IC Not Responding To Subaddress 1
ICRespondingToSubaddress1 | 1 | IC Responding To Subaddress 1
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeModeRespondSubadr2 Enumeration

IRD

Pca9629TypeModeRespondSubadr2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeRespondSubadr2
Public Enumeration TypeModeRespondSubadr2
public enum class TypeModeRespondSubadr2
type TypeModeRespondSubadr2
Members
Member name | Value | Description
ICNotRespondingToSubaddress2 | 0 | IC Not Responding To Subaddress 2
ICRespondingToSubaddress2 | 1 | IC Responding To Subaddress 2
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeModeRespondSubadr3 Enumeration

IRD

Pca9629TypeModeRespondSubadr3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeRespondSubadr3
Public Enumeration TypeModeRespondSubadr3
public enum class TypeModeRespondSubadr3
type TypeModeRespondSubadr3
Members
Member name | Value | Description
ICNotRespondingToSubaddress3 | 0 | IC Not Responding To Subaddress 3
ICRespondingToSubaddress3 | 1 | IC Responding To Subaddress 3
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeMotorControlDirection Enumeration

IRD

Pca9629TypeMotorControlDirection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMotorControlDirection
Public Enumeration TypeMotorControlDirection
public enum class TypeMotorControlDirection
type TypeMotorControlDirection
Members
Member name | Value | Description
RotateClockwise | 0 | Rotate Clockwise
RotateCounterClockwise | 1 | Rotate Counter-Clockwise
RotateClockwiseFirstThenCounterClockwise | 2 | Rotate Clockwise First, Then Counter-Clockwise
RotateCounterClockwiseFirstThenClockwise | 3 | Rotate Counter-Clockwise First, Then Clockwise
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeMotorControlHardStop Enumeration

IRD

Pca9629TypeMotorControlHardStop Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMotorControlHardStop
Public Enumeration TypeMotorControlHardStop
public enum class TypeMotorControlHardStop
type TypeMotorControlHardStop
Members
Member name | Value | Description
HardStopDisable | 0 | Hard Stop: Disable
HardStopEnable | 1 | Hard Stop: Enable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeMotorControlMode Enumeration

IRD

Pca9629TypeMotorControlMode Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMotorControlMode
Public Enumeration TypeMotorControlMode
public enum class TypeMotorControlMode
type TypeMotorControlMode
Members
Member name | Value | Description
SendSpecifiedNumberOfStepPulses | 0 | Send Specified Number Of Step Pulses
RotateForSpecifiedNumberOfRotations | 1 | Rotate For Specified Number Of Rotations
StepPulsesAndThenRotate | 2 | Step Pulses And Then Rotate
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeMotorControlPerformAction Enumeration

IRD

Pca9629TypeMotorControlPerformAction Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMotorControlPerformAction
Public Enumeration TypeMotorControlPerformAction
public enum class TypeMotorControlPerformAction
type TypeMotorControlPerformAction
Members
Member name | Value | Description
PerformActionOnce | 0 | Perform Action: Once
PerformActionContinuously | 1 | Perform Action: Continuously
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeMotorControlStartStop Enumeration

IRD

Pca9629TypeMotorControlStartStop Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMotorControlStartStop
Public Enumeration TypeMotorControlStartStop
public enum class TypeMotorControlStartStop
type TypeMotorControlStartStop
Members
Member name | Value | Description
StopMotor | 0 | Stop Motor
StartMotor | 1 | Start Motor
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypePhaseControl Enumeration

IRD

Pca9629TypePhaseControl Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePhaseControl
Public Enumeration TypePhaseControl
public enum class TypePhaseControl
type TypePhaseControl
Members
Member name | Value | Description
OnePhaseDriveOutputs | 0 | One Phase Drive Outputs
TwoPhaseDriveOutputs | 1 | Two Phase Drive Outputs
HalfStepDriveOutputs | 2 | Half Step Drive Outputs
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeRampControlRampDown Enumeration

IRD

Pca9629TypeRampControlRampDown Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRampControlRampDown
Public Enumeration TypeRampControlRampDown
public enum class TypeRampControlRampDown
type TypeRampControlRampDown
Members
Member name | Value | Description
RampDownToStopDisable | 0 | Ramp-Down To Stop: Disable
RampDownToStopEnable | 1 | Ramp-Down To Stop: Enable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeRampControlRampStep Enumeration

IRD

Pca9629TypeRampControlRampStep Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRampControlRampStep
Public Enumeration TypeRampControlRampStep
public enum class TypeRampControlRampStep
type TypeRampControlRampStep
Members
Member name | Value | Description
RampStepMultiplicatorFactor | 0 | Ramp Step Multiplicator Factor
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeRampControlRampUp Enumeration

IRD

Pca9629TypeRampControlRampUp Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRampControlRampUp
Public Enumeration TypeRampControlRampUp
public enum class TypeRampControlRampUp
type TypeRampControlRampUp
Members
Member name | Value | Description
RampUpDuringStartDisable | 0 | Ramp-Up During Start: Disable
RampUpDuringStartEnable | 1 | Ramp-Up During Start: Enable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeSetmodeOutputCcwStop Enumeration

IRD

Pca9629TypeSetmodeOutputCcwStop Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSetmodeOutputCcwStop
Public Enumeration TypeSetmodeOutputCcwStop
public enum class TypeSetmodeOutputCcwStop
type TypeSetmodeOutputCcwStop
Members
Member name | Value | Description
OutputAfterCCWStopLogic0 | 0 | Output After CCW Stop: Logic 0
OutputAfterCCWStopHold | 1 | Output After CCW Stop: Hold
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeSetmodeOutputCwStop Enumeration

IRD

Pca9629TypeSetmodeOutputCwStop Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSetmodeOutputCwStop
Public Enumeration TypeSetmodeOutputCwStop
public enum class TypeSetmodeOutputCwStop
type TypeSetmodeOutputCwStop
Members
Member name | Value | Description
OutputAfterCWStopLogic0 | 0 | Output After CW Stop: Logic 0
OutputAfterCWStopHold | 1 | Output After CW Stop: Hold
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeWdcntlWdEnableDisable Enumeration

IRD

Pca9629TypeWdcntlWdEnableDisable Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeWdcntlWdEnableDisable
Public Enumeration TypeWdcntlWdEnableDisable
public enum class TypeWdcntlWdEnableDisable
type TypeWdcntlWdEnableDisable
Members
Member name | Value | Description
WatchdogDisable | 0 | Watchdog: Disable
WatchdogEnable | 1 | Watchdog Enable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeWdcntlWdInterruptFlag Enumeration

IRD

Pca9629TypeWdcntlWdInterruptFlag Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeWdcntlWdInterruptFlag
Public Enumeration TypeWdcntlWdInterruptFlag
public enum class TypeWdcntlWdInterruptFlag
type TypeWdcntlWdInterruptFlag
Members
Member name | Value | Description
WatchdogInterruptFlagWDINTNotSet | 0 | Watchdog Interrupt Flag (WDINT): Not Set
WatchdogInterruptFlagWDINTSet | 1 | Watchdog Interrupt Flag (WDINT): Set
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeWdcntlWdInterruptFlagControl Enumeration

IRD

Pca9629TypeWdcntlWdInterruptFlagControl Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeWdcntlWdInterruptFlagControl
Public Enumeration TypeWdcntlWdInterruptFlagControl
public enum class TypeWdcntlWdInterruptFlagControl
type TypeWdcntlWdInterruptFlagControl
Members
Member name | Value | Description
WDINTFlagReadValue | 0 | WDINT Flag: Read Value
WDINTFlagClear | 1 | WDINT Flag: Clear
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeWdcntlWdMode Enumeration

IRD

Pca9629TypeWdcntlWdMode Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeWdcntlWdMode
Public Enumeration TypeWdcntlWdMode
public enum class TypeWdcntlWdMode
type TypeWdcntlWdMode
Members
Member name | Value | Description
WDMODWatchdogInterruptOnlyMode | 0 | WDMOD: Watchdog Interrupt Only Mode
WDMODWatchdogInterruptAndResetMode | 1 | WDMOD: Watchdog Interrupt And Reset Mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9629.TypeWdcntlWdResetFlag Enumeration

IRD

Pca9629TypeWdcntlWdResetFlag Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeWdcntlWdResetFlag
Public Enumeration TypeWdcntlWdResetFlag
public enum class TypeWdcntlWdResetFlag
type TypeWdcntlWdResetFlag
Members
Member name | Value | Description
WatchdogResetFlagWDRSTNotSet | 0 | Watchdog Reset Flag (WDRST): Not Set
WatchdogResetFlagWDRSTSet | 1 | Watchdog Reset Flag (WDRST): Set
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9685 Class

NXP Semiconductors: PCA 9685
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9685

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9685
Public Class Pca9685
public ref class Pca9685
type Pca9685 =  class end

The Pca9685 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9685 | Constructor
Top
Properties
 | Name | Description
Public property | ALLCALLADR | ALLCALLADR
Public property | ALLLEDOFF | ALL_LED_OFF
Public property | ALLLEDOFFHALLLEDFULLOFF | ALL_LED_OFF_H: ALL_LED_FULL_OFF
Public property | ALLLEDON | ALL_LED_ON
Public property | ALLLEDONHALLLEDFULLON | ALL_LED_ON_H: ALL_LED_FULL_ON
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | LED0OFF | LED0_OFF
Public property | LED0OFFHLED0FULLOFF | LED0_OFF_H: LED0_FULL_OFF
Public property | LED0ON | LED0_ON
Public property | LED0ONHLED0FULLON | LED0_ON_H: LED0_FULL_ON
Public property | LED10OFF | LED10_OFF
Public property | LED10OFFHLED10FULLOFF | LED10_OFF_H: LED10_FULL_OFF
Public property | LED10ON | LED10_ON
Public property | LED10ONHLED10FULLON | LED10_ON_H: LED10_FULL_ON
Public property | LED11OFF | LED11_OFF
Public property | LED11OFFHLED11FULLOFF | LED11_OFF_H: LED11_FULL_OFF
Public property | LED11ON | LED11_ON
Public property | LED11ONHLED11FULLON | LED11_ON_H: LED11_FULL_ON
Public property | LED12OFF | LED12_OFF
Public property | LED12OFFHLED12FULLOFF | LED12_OFF_H: LED12_FULL_OFF
Public property | LED12ON | LED12_ON
Public property | LED12ONHLED12FULLON | LED12_ON_H: LED12_FULL_ON
Public property | LED13OFF | LED13_OFF
Public property | LED13OFFHLED13FULLOFF | LED13_OFF_H: LED13_FULL_OFF
Public property | LED13ON | LED13_ON
Public property | LED13ONHLED13FULLON | LED13_ON_H: LED13_FULL_ON
Public property | LED14OFF | LED14_OFF
Public property | LED14OFFHLED14FULLOFF | LED14_OFF_H: LED14_FULL_OFF
Public property | LED14ON | LED14_ON
Public property | LED14ONHLED14FULLON | LED14_ON_H: LED14_FULL_ON
Public property | LED15OFF | LED15_OFF
Public property | LED15OFFHLED15FULLOFF | LED15_OFF_H: LED15_FULL_OFF
Public property | LED15ON | LED15_ON
Public property | LED15ONHLED15FULLON | LED15_ON_H: LED15_FULL_ON
Public property | LED1OFF | LED1_OFF
Public property | LED1OFFHLED1FULLOFF | LED1_OFF_H: LED1_FULL_OFF
Public property | LED1ON | LED1_ON
Public property | LED1ONHLED1FULLON | LED1_ON_H: LED1_FULL_ON
Public property | LED2OFF | LED2_OFF
Public property | LED2OFFHLED2FULLOFF | LED2_OFF_H: LED2_FULL_OFF
Public property | LED2ON | LED2_ON
Public property | LED2ONHLED2FULLON | LED2_ON_H: LED2_FULL_ON
Public property | LED3OFF | LED3_OFF
Public property | LED3OFFHLED3FULLOFF | LED3_OFF_H: LED3_FULL_OFF
Public property | LED3ON | LED3_ON
Public property | LED3ONHLED3FULLON | LED3_ON_H: LED3_FULL_ON
Public property | LED4OFF | LED4_OFF
Public property | LED4OFFHLED4FULLOFF | LED4_OFF_H: LED4_FULL_OFF
Public property | LED4ON | LED4_ON
Public property | LED4ONHLED4FULLON | LED4_ON_H: LED4_FULL_ON
Public property | LED5OFF | LED5_OFF
Public property | LED5OFFHLED5FULLOFF | LED5_OFF_H: LED5_FULL_OFF
Public property | LED5ON | LED5_ON
Public property | LED5ONHLED5FULLON | LED5_ON_H: LED5_FULL_ON
Public property | LED6OFF | LED6_OFF
Public property | LED6OFFHLED6FULLOFF | LED6_OFF_H: LED6_FULL_OFF
Public property | LED6ON | LED6_ON
Public property | LED6ONHLED6FULLON | LED6_ON_H: LED6_FULL_ON
Public property | LED7OFF | LED7_OFF
Public property | LED7OFFHLED7FULLOFF | LED7_OFF_H: LED7_FULL_OFF
Public property | LED7ON | LED7_ON
Public property | LED7ONHLED7FULLON | LED7_ON_H: LED7_FULL_ON
Public property | LED8OFF | LED8_OFF
Public property | LED8OFFHLED8FULLOFF | LED8_OFF_H: LED8_FULL_OFF
Public property | LED8ON | LED8_ON
Public property | LED8ONHLED8FULLON | LED8_ON_H: LED8_FULL_ON
Public property | LED9OFF | LED9_OFF
Public property | LED9OFFHLED9FULLOFF | LED9_OFF_H: LED9_FULL_OFF
Public property | LED9ON | LED9_ON
Public property | LED9ONHLED9FULLON | LED9_ON_H: LED9_FULL_ON
Public property | Mode1AI | Mode 1: AI
Public property | Mode1ALLCALL | Mode 1: ALLCALL
Public property | Mode1EXTCLK | Mode 1: EXTCLK
Public property | Mode1RESTART | Mode 1: RESTART
Public property | Mode1SLEEP | Mode 1: SLEEP
Public property | Mode1SUB1 | Mode 1: SUB1
Public property | Mode1SUB2 | Mode 1: SUB2
Public property | Mode1SUB3 | Mode 1: SUB3
Public property | Mode2INVRT | Mode 2: INVRT
Public property | Mode2OCH | Mode 2: OCH
Public property | Mode2OUTDRV | Mode 2: OUTDRV
Public property | Mode2OUTNE | Mode 2: OUTNE
Public property | PRESCALE | PRE_SCALE
Public property | SUBADR1 | SUBADR1
Public property | SUBADR2 | SUBADR2
Public property | SUBADR3 | SUBADR3
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
16 Channel LED Controller
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9685 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9685(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9685

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685 Properties

The Pca9685 type exposes the following members.

Properties
 | Name | Description
Public property | ALLCALLADR | ALLCALLADR
Public property | ALLLEDOFF | ALL_LED_OFF
Public property | ALLLEDOFFHALLLEDFULLOFF | ALL_LED_OFF_H: ALL_LED_FULL_OFF
Public property | ALLLEDON | ALL_LED_ON
Public property | ALLLEDONHALLLEDFULLON | ALL_LED_ON_H: ALL_LED_FULL_ON
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | LED0OFF | LED0_OFF
Public property | LED0OFFHLED0FULLOFF | LED0_OFF_H: LED0_FULL_OFF
Public property | LED0ON | LED0_ON
Public property | LED0ONHLED0FULLON | LED0_ON_H: LED0_FULL_ON
Public property | LED10OFF | LED10_OFF
Public property | LED10OFFHLED10FULLOFF | LED10_OFF_H: LED10_FULL_OFF
Public property | LED10ON | LED10_ON
Public property | LED10ONHLED10FULLON | LED10_ON_H: LED10_FULL_ON
Public property | LED11OFF | LED11_OFF
Public property | LED11OFFHLED11FULLOFF | LED11_OFF_H: LED11_FULL_OFF
Public property | LED11ON | LED11_ON
Public property | LED11ONHLED11FULLON | LED11_ON_H: LED11_FULL_ON
Public property | LED12OFF | LED12_OFF
Public property | LED12OFFHLED12FULLOFF | LED12_OFF_H: LED12_FULL_OFF
Public property | LED12ON | LED12_ON
Public property | LED12ONHLED12FULLON | LED12_ON_H: LED12_FULL_ON
Public property | LED13OFF | LED13_OFF
Public property | LED13OFFHLED13FULLOFF | LED13_OFF_H: LED13_FULL_OFF
Public property | LED13ON | LED13_ON
Public property | LED13ONHLED13FULLON | LED13_ON_H: LED13_FULL_ON
Public property | LED14OFF | LED14_OFF
Public property | LED14OFFHLED14FULLOFF | LED14_OFF_H: LED14_FULL_OFF
Public property | LED14ON | LED14_ON
Public property | LED14ONHLED14FULLON | LED14_ON_H: LED14_FULL_ON
Public property | LED15OFF | LED15_OFF
Public property | LED15OFFHLED15FULLOFF | LED15_OFF_H: LED15_FULL_OFF
Public property | LED15ON | LED15_ON
Public property | LED15ONHLED15FULLON | LED15_ON_H: LED15_FULL_ON
Public property | LED1OFF | LED1_OFF
Public property | LED1OFFHLED1FULLOFF | LED1_OFF_H: LED1_FULL_OFF
Public property | LED1ON | LED1_ON
Public property | LED1ONHLED1FULLON | LED1_ON_H: LED1_FULL_ON
Public property | LED2OFF | LED2_OFF
Public property | LED2OFFHLED2FULLOFF | LED2_OFF_H: LED2_FULL_OFF
Public property | LED2ON | LED2_ON
Public property | LED2ONHLED2FULLON | LED2_ON_H: LED2_FULL_ON
Public property | LED3OFF | LED3_OFF
Public property | LED3OFFHLED3FULLOFF | LED3_OFF_H: LED3_FULL_OFF
Public property | LED3ON | LED3_ON
Public property | LED3ONHLED3FULLON | LED3_ON_H: LED3_FULL_ON
Public property | LED4OFF | LED4_OFF
Public property | LED4OFFHLED4FULLOFF | LED4_OFF_H: LED4_FULL_OFF
Public property | LED4ON | LED4_ON
Public property | LED4ONHLED4FULLON | LED4_ON_H: LED4_FULL_ON
Public property | LED5OFF | LED5_OFF
Public property | LED5OFFHLED5FULLOFF | LED5_OFF_H: LED5_FULL_OFF
Public property | LED5ON | LED5_ON
Public property | LED5ONHLED5FULLON | LED5_ON_H: LED5_FULL_ON
Public property | LED6OFF | LED6_OFF
Public property | LED6OFFHLED6FULLOFF | LED6_OFF_H: LED6_FULL_OFF
Public property | LED6ON | LED6_ON
Public property | LED6ONHLED6FULLON | LED6_ON_H: LED6_FULL_ON
Public property | LED7OFF | LED7_OFF
Public property | LED7OFFHLED7FULLOFF | LED7_OFF_H: LED7_FULL_OFF
Public property | LED7ON | LED7_ON
Public property | LED7ONHLED7FULLON | LED7_ON_H: LED7_FULL_ON
Public property | LED8OFF | LED8_OFF
Public property | LED8OFFHLED8FULLOFF | LED8_OFF_H: LED8_FULL_OFF
Public property | LED8ON | LED8_ON
Public property | LED8ONHLED8FULLON | LED8_ON_H: LED8_FULL_ON
Public property | LED9OFF | LED9_OFF
Public property | LED9OFFHLED9FULLOFF | LED9_OFF_H: LED9_FULL_OFF
Public property | LED9ON | LED9_ON
Public property | LED9ONHLED9FULLON | LED9_ON_H: LED9_FULL_ON
Public property | Mode1AI | Mode 1: AI
Public property | Mode1ALLCALL | Mode 1: ALLCALL
Public property | Mode1EXTCLK | Mode 1: EXTCLK
Public property | Mode1RESTART | Mode 1: RESTART
Public property | Mode1SLEEP | Mode 1: SLEEP
Public property | Mode1SUB1 | Mode 1: SUB1
Public property | Mode1SUB2 | Mode 1: SUB2
Public property | Mode1SUB3 | Mode 1: SUB3
Public property | Mode2INVRT | Mode 2: INVRT
Public property | Mode2OCH | Mode 2: OCH
Public property | Mode2OUTDRV | Mode 2: OUTDRV
Public property | Mode2OUTNE | Mode 2: OUTNE
Public property | PRESCALE | PRE_SCALE
Public property | SUBADR1 | SUBADR1
Public property | SUBADR2 | SUBADR2
Public property | SUBADR3 | SUBADR3
Top
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.ALLCALLADR Property

IRD

Pca9685ALLCALLADR Property

ALLCALLADR

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ALLCALLADR { get; set; }
Public Property ALLCALLADR As Byte
    Get
    Set
public:
property unsigned char ALLCALLADR {
    unsigned char get ();
    void set (unsigned char value);
}
member ALLCALLADR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.ALLLEDOFF Property

IRD

Pca9685ALLLEDOFF Property

ALL_LED_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ALLLEDOFF { set; }
Public WriteOnly Property ALLLEDOFF As UShort
    Set
public:
property unsigned short ALLLEDOFF {
    void set (unsigned short value);
}
member ALLLEDOFF : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.ALLLEDOFFHALLLEDFULLOFF Property

IRD

Pca9685ALLLEDOFFHALLLEDFULLOFF Property

ALL_LED_OFF_H: ALL_LED_FULL_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOffHLedFullOff ALLLEDOFFHALLLEDFULLOFF { set; }
Public WriteOnly Property ALLLEDOFFHALLLEDFULLOFF As Pca9685TypeLedxOffHLedFullOff
    Set
public:
property Pca9685TypeLedxOffHLedFullOff ALLLEDOFFHALLLEDFULLOFF {
    void set (Pca9685TypeLedxOffHLedFullOff value);
}
member ALLLEDOFFHALLLEDFULLOFF : Pca9685TypeLedxOffHLedFullOff with set

Property Value

Type: Pca9685TypeLedxOffHLedFullOff
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.ALLLEDON Property

IRD

Pca9685ALLLEDON Property

ALL_LED_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ALLLEDON { set; }
Public WriteOnly Property ALLLEDON As UShort
    Set
public:
property unsigned short ALLLEDON {
    void set (unsigned short value);
}
member ALLLEDON : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.ALLLEDONHALLLEDFULLON Property

IRD

Pca9685ALLLEDONHALLLEDFULLON Property

ALL_LED_ON_H: ALL_LED_FULL_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOnHLedFullOn ALLLEDONHALLLEDFULLON { set; }
Public WriteOnly Property ALLLEDONHALLLEDFULLON As Pca9685TypeLedxOnHLedFullOn
    Set
public:
property Pca9685TypeLedxOnHLedFullOn ALLLEDONHALLLEDFULLON {
    void set (Pca9685TypeLedxOnHLedFullOn value);
}
member ALLLEDONHALLLEDFULLON : Pca9685TypeLedxOnHLedFullOn with set

Property Value

Type: Pca9685TypeLedxOnHLedFullOn
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.AutoFlush Property

IRD

Pca9685AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED0OFF Property

IRD

Pca9685LED0OFF Property

LED0_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED0OFF { get; set; }
Public Property LED0OFF As UShort
    Get
    Set
public:
property unsigned short LED0OFF {
    unsigned short get ();
    void set (unsigned short value);
}
member LED0OFF : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED0OFFHLED0FULLOFF Property

IRD

Pca9685LED0OFFHLED0FULLOFF Property

LED0_OFF_H: LED0_FULL_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOffHLedFullOff LED0OFFHLED0FULLOFF { get; set; }
Public Property LED0OFFHLED0FULLOFF As Pca9685TypeLedxOffHLedFullOff
    Get
    Set
public:
property Pca9685TypeLedxOffHLedFullOff LED0OFFHLED0FULLOFF {
    Pca9685TypeLedxOffHLedFullOff get ();
    void set (Pca9685TypeLedxOffHLedFullOff value);
}
member LED0OFFHLED0FULLOFF : Pca9685TypeLedxOffHLedFullOff with get, set

Property Value

Type: Pca9685TypeLedxOffHLedFullOff
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED0ON Property

IRD

Pca9685LED0ON Property

LED0_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED0ON { get; set; }
Public Property LED0ON As UShort
    Get
    Set
public:
property unsigned short LED0ON {
    unsigned short get ();
    void set (unsigned short value);
}
member LED0ON : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED0ONHLED0FULLON Property

IRD

Pca9685LED0ONHLED0FULLON Property

LED0_ON_H: LED0_FULL_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOnHLedFullOn LED0ONHLED0FULLON { get; set; }
Public Property LED0ONHLED0FULLON As Pca9685TypeLedxOnHLedFullOn
    Get
    Set
public:
property Pca9685TypeLedxOnHLedFullOn LED0ONHLED0FULLON {
    Pca9685TypeLedxOnHLedFullOn get ();
    void set (Pca9685TypeLedxOnHLedFullOn value);
}
member LED0ONHLED0FULLON : Pca9685TypeLedxOnHLedFullOn with get, set

Property Value

Type: Pca9685TypeLedxOnHLedFullOn
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED10OFF Property

IRD

Pca9685LED10OFF Property

LED10_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED10OFF { get; set; }
Public Property LED10OFF As UShort
    Get
    Set
public:
property unsigned short LED10OFF {
    unsigned short get ();
    void set (unsigned short value);
}
member LED10OFF : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED10OFFHLED10FULLOFF Property

IRD

Pca9685LED10OFFHLED10FULLOFF Property

LED10_OFF_H: LED10_FULL_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOffHLedFullOff LED10OFFHLED10FULLOFF { get; set; }
Public Property LED10OFFHLED10FULLOFF As Pca9685TypeLedxOffHLedFullOff
    Get
    Set
public:
property Pca9685TypeLedxOffHLedFullOff LED10OFFHLED10FULLOFF {
    Pca9685TypeLedxOffHLedFullOff get ();
    void set (Pca9685TypeLedxOffHLedFullOff value);
}
member LED10OFFHLED10FULLOFF : Pca9685TypeLedxOffHLedFullOff with get, set

Property Value

Type: Pca9685TypeLedxOffHLedFullOff
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED10ON Property

IRD

Pca9685LED10ON Property

LED10_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED10ON { get; set; }
Public Property LED10ON As UShort
    Get
    Set
public:
property unsigned short LED10ON {
    unsigned short get ();
    void set (unsigned short value);
}
member LED10ON : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED10ONHLED10FULLON Property

IRD

Pca9685LED10ONHLED10FULLON Property

LED10_ON_H: LED10_FULL_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOnHLedFullOn LED10ONHLED10FULLON { get; set; }
Public Property LED10ONHLED10FULLON As Pca9685TypeLedxOnHLedFullOn
    Get
    Set
public:
property Pca9685TypeLedxOnHLedFullOn LED10ONHLED10FULLON {
    Pca9685TypeLedxOnHLedFullOn get ();
    void set (Pca9685TypeLedxOnHLedFullOn value);
}
member LED10ONHLED10FULLON : Pca9685TypeLedxOnHLedFullOn with get, set

Property Value

Type: Pca9685TypeLedxOnHLedFullOn
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED11OFF Property

IRD

Pca9685LED11OFF Property

LED11_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED11OFF { get; set; }
Public Property LED11OFF As UShort
    Get
    Set
public:
property unsigned short LED11OFF {
    unsigned short get ();
    void set (unsigned short value);
}
member LED11OFF : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED11OFFHLED11FULLOFF Property

IRD

Pca9685LED11OFFHLED11FULLOFF Property

LED11_OFF_H: LED11_FULL_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOffHLedFullOff LED11OFFHLED11FULLOFF { get; set; }
Public Property LED11OFFHLED11FULLOFF As Pca9685TypeLedxOffHLedFullOff
    Get
    Set
public:
property Pca9685TypeLedxOffHLedFullOff LED11OFFHLED11FULLOFF {
    Pca9685TypeLedxOffHLedFullOff get ();
    void set (Pca9685TypeLedxOffHLedFullOff value);
}
member LED11OFFHLED11FULLOFF : Pca9685TypeLedxOffHLedFullOff with get, set

Property Value

Type: Pca9685TypeLedxOffHLedFullOff
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED11ON Property

IRD

Pca9685LED11ON Property

LED11_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED11ON { get; set; }
Public Property LED11ON As UShort
    Get
    Set
public:
property unsigned short LED11ON {
    unsigned short get ();
    void set (unsigned short value);
}
member LED11ON : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED11ONHLED11FULLON Property

IRD

Pca9685LED11ONHLED11FULLON Property

LED11_ON_H: LED11_FULL_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOnHLedFullOn LED11ONHLED11FULLON { get; set; }
Public Property LED11ONHLED11FULLON As Pca9685TypeLedxOnHLedFullOn
    Get
    Set
public:
property Pca9685TypeLedxOnHLedFullOn LED11ONHLED11FULLON {
    Pca9685TypeLedxOnHLedFullOn get ();
    void set (Pca9685TypeLedxOnHLedFullOn value);
}
member LED11ONHLED11FULLON : Pca9685TypeLedxOnHLedFullOn with get, set

Property Value

Type: Pca9685TypeLedxOnHLedFullOn
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED12OFF Property

IRD

Pca9685LED12OFF Property

LED12_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED12OFF { get; set; }
Public Property LED12OFF As UShort
    Get
    Set
public:
property unsigned short LED12OFF {
    unsigned short get ();
    void set (unsigned short value);
}
member LED12OFF : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED12OFFHLED12FULLOFF Property

IRD

Pca9685LED12OFFHLED12FULLOFF Property

LED12_OFF_H: LED12_FULL_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOffHLedFullOff LED12OFFHLED12FULLOFF { get; set; }
Public Property LED12OFFHLED12FULLOFF As Pca9685TypeLedxOffHLedFullOff
    Get
    Set
public:
property Pca9685TypeLedxOffHLedFullOff LED12OFFHLED12FULLOFF {
    Pca9685TypeLedxOffHLedFullOff get ();
    void set (Pca9685TypeLedxOffHLedFullOff value);
}
member LED12OFFHLED12FULLOFF : Pca9685TypeLedxOffHLedFullOff with get, set

Property Value

Type: Pca9685TypeLedxOffHLedFullOff
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED12ON Property

IRD

Pca9685LED12ON Property

LED12_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED12ON { get; set; }
Public Property LED12ON As UShort
    Get
    Set
public:
property unsigned short LED12ON {
    unsigned short get ();
    void set (unsigned short value);
}
member LED12ON : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED12ONHLED12FULLON Property

IRD

Pca9685LED12ONHLED12FULLON Property

LED12_ON_H: LED12_FULL_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOnHLedFullOn LED12ONHLED12FULLON { get; set; }
Public Property LED12ONHLED12FULLON As Pca9685TypeLedxOnHLedFullOn
    Get
    Set
public:
property Pca9685TypeLedxOnHLedFullOn LED12ONHLED12FULLON {
    Pca9685TypeLedxOnHLedFullOn get ();
    void set (Pca9685TypeLedxOnHLedFullOn value);
}
member LED12ONHLED12FULLON : Pca9685TypeLedxOnHLedFullOn with get, set

Property Value

Type: Pca9685TypeLedxOnHLedFullOn
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED13OFF Property

IRD

Pca9685LED13OFF Property

LED13_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED13OFF { get; set; }
Public Property LED13OFF As UShort
    Get
    Set
public:
property unsigned short LED13OFF {
    unsigned short get ();
    void set (unsigned short value);
}
member LED13OFF : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED13OFFHLED13FULLOFF Property

IRD

Pca9685LED13OFFHLED13FULLOFF Property

LED13_OFF_H: LED13_FULL_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOffHLedFullOff LED13OFFHLED13FULLOFF { get; set; }
Public Property LED13OFFHLED13FULLOFF As Pca9685TypeLedxOffHLedFullOff
    Get
    Set
public:
property Pca9685TypeLedxOffHLedFullOff LED13OFFHLED13FULLOFF {
    Pca9685TypeLedxOffHLedFullOff get ();
    void set (Pca9685TypeLedxOffHLedFullOff value);
}
member LED13OFFHLED13FULLOFF : Pca9685TypeLedxOffHLedFullOff with get, set

Property Value

Type: Pca9685TypeLedxOffHLedFullOff
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED13ON Property

IRD

Pca9685LED13ON Property

LED13_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED13ON { get; set; }
Public Property LED13ON As UShort
    Get
    Set
public:
property unsigned short LED13ON {
    unsigned short get ();
    void set (unsigned short value);
}
member LED13ON : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED13ONHLED13FULLON Property

IRD

Pca9685LED13ONHLED13FULLON Property

LED13_ON_H: LED13_FULL_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOnHLedFullOn LED13ONHLED13FULLON { get; set; }
Public Property LED13ONHLED13FULLON As Pca9685TypeLedxOnHLedFullOn
    Get
    Set
public:
property Pca9685TypeLedxOnHLedFullOn LED13ONHLED13FULLON {
    Pca9685TypeLedxOnHLedFullOn get ();
    void set (Pca9685TypeLedxOnHLedFullOn value);
}
member LED13ONHLED13FULLON : Pca9685TypeLedxOnHLedFullOn with get, set

Property Value

Type: Pca9685TypeLedxOnHLedFullOn
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED14OFF Property

IRD

Pca9685LED14OFF Property

LED14_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED14OFF { get; set; }
Public Property LED14OFF As UShort
    Get
    Set
public:
property unsigned short LED14OFF {
    unsigned short get ();
    void set (unsigned short value);
}
member LED14OFF : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED14OFFHLED14FULLOFF Property

IRD

Pca9685LED14OFFHLED14FULLOFF Property

LED14_OFF_H: LED14_FULL_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOffHLedFullOff LED14OFFHLED14FULLOFF { get; set; }
Public Property LED14OFFHLED14FULLOFF As Pca9685TypeLedxOffHLedFullOff
    Get
    Set
public:
property Pca9685TypeLedxOffHLedFullOff LED14OFFHLED14FULLOFF {
    Pca9685TypeLedxOffHLedFullOff get ();
    void set (Pca9685TypeLedxOffHLedFullOff value);
}
member LED14OFFHLED14FULLOFF : Pca9685TypeLedxOffHLedFullOff with get, set

Property Value

Type: Pca9685TypeLedxOffHLedFullOff
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED14ON Property

IRD

Pca9685LED14ON Property

LED14_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED14ON { get; set; }
Public Property LED14ON As UShort
    Get
    Set
public:
property unsigned short LED14ON {
    unsigned short get ();
    void set (unsigned short value);
}
member LED14ON : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED14ONHLED14FULLON Property

IRD

Pca9685LED14ONHLED14FULLON Property

LED14_ON_H: LED14_FULL_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOnHLedFullOn LED14ONHLED14FULLON { get; set; }
Public Property LED14ONHLED14FULLON As Pca9685TypeLedxOnHLedFullOn
    Get
    Set
public:
property Pca9685TypeLedxOnHLedFullOn LED14ONHLED14FULLON {
    Pca9685TypeLedxOnHLedFullOn get ();
    void set (Pca9685TypeLedxOnHLedFullOn value);
}
member LED14ONHLED14FULLON : Pca9685TypeLedxOnHLedFullOn with get, set

Property Value

Type: Pca9685TypeLedxOnHLedFullOn
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED15OFF Property

IRD

Pca9685LED15OFF Property

LED15_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED15OFF { get; set; }
Public Property LED15OFF As UShort
    Get
    Set
public:
property unsigned short LED15OFF {
    unsigned short get ();
    void set (unsigned short value);
}
member LED15OFF : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED15OFFHLED15FULLOFF Property

IRD

Pca9685LED15OFFHLED15FULLOFF Property

LED15_OFF_H: LED15_FULL_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOffHLedFullOff LED15OFFHLED15FULLOFF { get; set; }
Public Property LED15OFFHLED15FULLOFF As Pca9685TypeLedxOffHLedFullOff
    Get
    Set
public:
property Pca9685TypeLedxOffHLedFullOff LED15OFFHLED15FULLOFF {
    Pca9685TypeLedxOffHLedFullOff get ();
    void set (Pca9685TypeLedxOffHLedFullOff value);
}
member LED15OFFHLED15FULLOFF : Pca9685TypeLedxOffHLedFullOff with get, set

Property Value

Type: Pca9685TypeLedxOffHLedFullOff
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED15ON Property

IRD

Pca9685LED15ON Property

LED15_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED15ON { get; set; }
Public Property LED15ON As UShort
    Get
    Set
public:
property unsigned short LED15ON {
    unsigned short get ();
    void set (unsigned short value);
}
member LED15ON : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED15ONHLED15FULLON Property

IRD

Pca9685LED15ONHLED15FULLON Property

LED15_ON_H: LED15_FULL_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOnHLedFullOn LED15ONHLED15FULLON { get; set; }
Public Property LED15ONHLED15FULLON As Pca9685TypeLedxOnHLedFullOn
    Get
    Set
public:
property Pca9685TypeLedxOnHLedFullOn LED15ONHLED15FULLON {
    Pca9685TypeLedxOnHLedFullOn get ();
    void set (Pca9685TypeLedxOnHLedFullOn value);
}
member LED15ONHLED15FULLON : Pca9685TypeLedxOnHLedFullOn with get, set

Property Value

Type: Pca9685TypeLedxOnHLedFullOn
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED1OFF Property

IRD

Pca9685LED1OFF Property

LED1_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED1OFF { get; set; }
Public Property LED1OFF As UShort
    Get
    Set
public:
property unsigned short LED1OFF {
    unsigned short get ();
    void set (unsigned short value);
}
member LED1OFF : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED1OFFHLED1FULLOFF Property

IRD

Pca9685LED1OFFHLED1FULLOFF Property

LED1_OFF_H: LED1_FULL_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOffHLedFullOff LED1OFFHLED1FULLOFF { get; set; }
Public Property LED1OFFHLED1FULLOFF As Pca9685TypeLedxOffHLedFullOff
    Get
    Set
public:
property Pca9685TypeLedxOffHLedFullOff LED1OFFHLED1FULLOFF {
    Pca9685TypeLedxOffHLedFullOff get ();
    void set (Pca9685TypeLedxOffHLedFullOff value);
}
member LED1OFFHLED1FULLOFF : Pca9685TypeLedxOffHLedFullOff with get, set

Property Value

Type: Pca9685TypeLedxOffHLedFullOff
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED1ON Property

IRD

Pca9685LED1ON Property

LED1_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED1ON { get; set; }
Public Property LED1ON As UShort
    Get
    Set
public:
property unsigned short LED1ON {
    unsigned short get ();
    void set (unsigned short value);
}
member LED1ON : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED1ONHLED1FULLON Property

IRD

Pca9685LED1ONHLED1FULLON Property

LED1_ON_H: LED1_FULL_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOnHLedFullOn LED1ONHLED1FULLON { get; set; }
Public Property LED1ONHLED1FULLON As Pca9685TypeLedxOnHLedFullOn
    Get
    Set
public:
property Pca9685TypeLedxOnHLedFullOn LED1ONHLED1FULLON {
    Pca9685TypeLedxOnHLedFullOn get ();
    void set (Pca9685TypeLedxOnHLedFullOn value);
}
member LED1ONHLED1FULLON : Pca9685TypeLedxOnHLedFullOn with get, set

Property Value

Type: Pca9685TypeLedxOnHLedFullOn
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED2OFF Property

IRD

Pca9685LED2OFF Property

LED2_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED2OFF { get; set; }
Public Property LED2OFF As UShort
    Get
    Set
public:
property unsigned short LED2OFF {
    unsigned short get ();
    void set (unsigned short value);
}
member LED2OFF : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED2OFFHLED2FULLOFF Property

IRD

Pca9685LED2OFFHLED2FULLOFF Property

LED2_OFF_H: LED2_FULL_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOffHLedFullOff LED2OFFHLED2FULLOFF { get; set; }
Public Property LED2OFFHLED2FULLOFF As Pca9685TypeLedxOffHLedFullOff
    Get
    Set
public:
property Pca9685TypeLedxOffHLedFullOff LED2OFFHLED2FULLOFF {
    Pca9685TypeLedxOffHLedFullOff get ();
    void set (Pca9685TypeLedxOffHLedFullOff value);
}
member LED2OFFHLED2FULLOFF : Pca9685TypeLedxOffHLedFullOff with get, set

Property Value

Type: Pca9685TypeLedxOffHLedFullOff
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED2ON Property

IRD

Pca9685LED2ON Property

LED2_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED2ON { get; set; }
Public Property LED2ON As UShort
    Get
    Set
public:
property unsigned short LED2ON {
    unsigned short get ();
    void set (unsigned short value);
}
member LED2ON : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED2ONHLED2FULLON Property

IRD

Pca9685LED2ONHLED2FULLON Property

LED2_ON_H: LED2_FULL_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOnHLedFullOn LED2ONHLED2FULLON { get; set; }
Public Property LED2ONHLED2FULLON As Pca9685TypeLedxOnHLedFullOn
    Get
    Set
public:
property Pca9685TypeLedxOnHLedFullOn LED2ONHLED2FULLON {
    Pca9685TypeLedxOnHLedFullOn get ();
    void set (Pca9685TypeLedxOnHLedFullOn value);
}
member LED2ONHLED2FULLON : Pca9685TypeLedxOnHLedFullOn with get, set

Property Value

Type: Pca9685TypeLedxOnHLedFullOn
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED3OFF Property

IRD

Pca9685LED3OFF Property

LED3_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED3OFF { get; set; }
Public Property LED3OFF As UShort
    Get
    Set
public:
property unsigned short LED3OFF {
    unsigned short get ();
    void set (unsigned short value);
}
member LED3OFF : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED3OFFHLED3FULLOFF Property

IRD

Pca9685LED3OFFHLED3FULLOFF Property

LED3_OFF_H: LED3_FULL_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOffHLedFullOff LED3OFFHLED3FULLOFF { get; set; }
Public Property LED3OFFHLED3FULLOFF As Pca9685TypeLedxOffHLedFullOff
    Get
    Set
public:
property Pca9685TypeLedxOffHLedFullOff LED3OFFHLED3FULLOFF {
    Pca9685TypeLedxOffHLedFullOff get ();
    void set (Pca9685TypeLedxOffHLedFullOff value);
}
member LED3OFFHLED3FULLOFF : Pca9685TypeLedxOffHLedFullOff with get, set

Property Value

Type: Pca9685TypeLedxOffHLedFullOff
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED3ON Property

IRD

Pca9685LED3ON Property

LED3_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED3ON { get; set; }
Public Property LED3ON As UShort
    Get
    Set
public:
property unsigned short LED3ON {
    unsigned short get ();
    void set (unsigned short value);
}
member LED3ON : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED3ONHLED3FULLON Property

IRD

Pca9685LED3ONHLED3FULLON Property

LED3_ON_H: LED3_FULL_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOnHLedFullOn LED3ONHLED3FULLON { get; set; }
Public Property LED3ONHLED3FULLON As Pca9685TypeLedxOnHLedFullOn
    Get
    Set
public:
property Pca9685TypeLedxOnHLedFullOn LED3ONHLED3FULLON {
    Pca9685TypeLedxOnHLedFullOn get ();
    void set (Pca9685TypeLedxOnHLedFullOn value);
}
member LED3ONHLED3FULLON : Pca9685TypeLedxOnHLedFullOn with get, set

Property Value

Type: Pca9685TypeLedxOnHLedFullOn
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED4OFF Property

IRD

Pca9685LED4OFF Property

LED4_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED4OFF { get; set; }
Public Property LED4OFF As UShort
    Get
    Set
public:
property unsigned short LED4OFF {
    unsigned short get ();
    void set (unsigned short value);
}
member LED4OFF : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED4OFFHLED4FULLOFF Property

IRD

Pca9685LED4OFFHLED4FULLOFF Property

LED4_OFF_H: LED4_FULL_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOffHLedFullOff LED4OFFHLED4FULLOFF { get; set; }
Public Property LED4OFFHLED4FULLOFF As Pca9685TypeLedxOffHLedFullOff
    Get
    Set
public:
property Pca9685TypeLedxOffHLedFullOff LED4OFFHLED4FULLOFF {
    Pca9685TypeLedxOffHLedFullOff get ();
    void set (Pca9685TypeLedxOffHLedFullOff value);
}
member LED4OFFHLED4FULLOFF : Pca9685TypeLedxOffHLedFullOff with get, set

Property Value

Type: Pca9685TypeLedxOffHLedFullOff
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED4ON Property

IRD

Pca9685LED4ON Property

LED4_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED4ON { get; set; }
Public Property LED4ON As UShort
    Get
    Set
public:
property unsigned short LED4ON {
    unsigned short get ();
    void set (unsigned short value);
}
member LED4ON : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED4ONHLED4FULLON Property

IRD

Pca9685LED4ONHLED4FULLON Property

LED4_ON_H: LED4_FULL_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOnHLedFullOn LED4ONHLED4FULLON { get; set; }
Public Property LED4ONHLED4FULLON As Pca9685TypeLedxOnHLedFullOn
    Get
    Set
public:
property Pca9685TypeLedxOnHLedFullOn LED4ONHLED4FULLON {
    Pca9685TypeLedxOnHLedFullOn get ();
    void set (Pca9685TypeLedxOnHLedFullOn value);
}
member LED4ONHLED4FULLON : Pca9685TypeLedxOnHLedFullOn with get, set

Property Value

Type: Pca9685TypeLedxOnHLedFullOn
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED5OFF Property

IRD

Pca9685LED5OFF Property

LED5_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED5OFF { get; set; }
Public Property LED5OFF As UShort
    Get
    Set
public:
property unsigned short LED5OFF {
    unsigned short get ();
    void set (unsigned short value);
}
member LED5OFF : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED5OFFHLED5FULLOFF Property

IRD

Pca9685LED5OFFHLED5FULLOFF Property

LED5_OFF_H: LED5_FULL_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOffHLedFullOff LED5OFFHLED5FULLOFF { get; set; }
Public Property LED5OFFHLED5FULLOFF As Pca9685TypeLedxOffHLedFullOff
    Get
    Set
public:
property Pca9685TypeLedxOffHLedFullOff LED5OFFHLED5FULLOFF {
    Pca9685TypeLedxOffHLedFullOff get ();
    void set (Pca9685TypeLedxOffHLedFullOff value);
}
member LED5OFFHLED5FULLOFF : Pca9685TypeLedxOffHLedFullOff with get, set

Property Value

Type: Pca9685TypeLedxOffHLedFullOff
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED5ON Property

IRD

Pca9685LED5ON Property

LED5_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED5ON { get; set; }
Public Property LED5ON As UShort
    Get
    Set
public:
property unsigned short LED5ON {
    unsigned short get ();
    void set (unsigned short value);
}
member LED5ON : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED5ONHLED5FULLON Property

IRD

Pca9685LED5ONHLED5FULLON Property

LED5_ON_H: LED5_FULL_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOnHLedFullOn LED5ONHLED5FULLON { get; set; }
Public Property LED5ONHLED5FULLON As Pca9685TypeLedxOnHLedFullOn
    Get
    Set
public:
property Pca9685TypeLedxOnHLedFullOn LED5ONHLED5FULLON {
    Pca9685TypeLedxOnHLedFullOn get ();
    void set (Pca9685TypeLedxOnHLedFullOn value);
}
member LED5ONHLED5FULLON : Pca9685TypeLedxOnHLedFullOn with get, set

Property Value

Type: Pca9685TypeLedxOnHLedFullOn
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED6OFF Property

IRD

Pca9685LED6OFF Property

LED6_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED6OFF { get; set; }
Public Property LED6OFF As UShort
    Get
    Set
public:
property unsigned short LED6OFF {
    unsigned short get ();
    void set (unsigned short value);
}
member LED6OFF : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED6OFFHLED6FULLOFF Property

IRD

Pca9685LED6OFFHLED6FULLOFF Property

LED6_OFF_H: LED6_FULL_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOffHLedFullOff LED6OFFHLED6FULLOFF { get; set; }
Public Property LED6OFFHLED6FULLOFF As Pca9685TypeLedxOffHLedFullOff
    Get
    Set
public:
property Pca9685TypeLedxOffHLedFullOff LED6OFFHLED6FULLOFF {
    Pca9685TypeLedxOffHLedFullOff get ();
    void set (Pca9685TypeLedxOffHLedFullOff value);
}
member LED6OFFHLED6FULLOFF : Pca9685TypeLedxOffHLedFullOff with get, set

Property Value

Type: Pca9685TypeLedxOffHLedFullOff
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED6ON Property

IRD

Pca9685LED6ON Property

LED6_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED6ON { get; set; }
Public Property LED6ON As UShort
    Get
    Set
public:
property unsigned short LED6ON {
    unsigned short get ();
    void set (unsigned short value);
}
member LED6ON : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED6ONHLED6FULLON Property

IRD

Pca9685LED6ONHLED6FULLON Property

LED6_ON_H: LED6_FULL_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOnHLedFullOn LED6ONHLED6FULLON { get; set; }
Public Property LED6ONHLED6FULLON As Pca9685TypeLedxOnHLedFullOn
    Get
    Set
public:
property Pca9685TypeLedxOnHLedFullOn LED6ONHLED6FULLON {
    Pca9685TypeLedxOnHLedFullOn get ();
    void set (Pca9685TypeLedxOnHLedFullOn value);
}
member LED6ONHLED6FULLON : Pca9685TypeLedxOnHLedFullOn with get, set

Property Value

Type: Pca9685TypeLedxOnHLedFullOn
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED7OFF Property

IRD

Pca9685LED7OFF Property

LED7_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED7OFF { get; set; }
Public Property LED7OFF As UShort
    Get
    Set
public:
property unsigned short LED7OFF {
    unsigned short get ();
    void set (unsigned short value);
}
member LED7OFF : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED7OFFHLED7FULLOFF Property

IRD

Pca9685LED7OFFHLED7FULLOFF Property

LED7_OFF_H: LED7_FULL_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOffHLedFullOff LED7OFFHLED7FULLOFF { get; set; }
Public Property LED7OFFHLED7FULLOFF As Pca9685TypeLedxOffHLedFullOff
    Get
    Set
public:
property Pca9685TypeLedxOffHLedFullOff LED7OFFHLED7FULLOFF {
    Pca9685TypeLedxOffHLedFullOff get ();
    void set (Pca9685TypeLedxOffHLedFullOff value);
}
member LED7OFFHLED7FULLOFF : Pca9685TypeLedxOffHLedFullOff with get, set

Property Value

Type: Pca9685TypeLedxOffHLedFullOff
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED7ON Property

IRD

Pca9685LED7ON Property

LED7_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED7ON { get; set; }
Public Property LED7ON As UShort
    Get
    Set
public:
property unsigned short LED7ON {
    unsigned short get ();
    void set (unsigned short value);
}
member LED7ON : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED7ONHLED7FULLON Property

IRD

Pca9685LED7ONHLED7FULLON Property

LED7_ON_H: LED7_FULL_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOnHLedFullOn LED7ONHLED7FULLON { get; set; }
Public Property LED7ONHLED7FULLON As Pca9685TypeLedxOnHLedFullOn
    Get
    Set
public:
property Pca9685TypeLedxOnHLedFullOn LED7ONHLED7FULLON {
    Pca9685TypeLedxOnHLedFullOn get ();
    void set (Pca9685TypeLedxOnHLedFullOn value);
}
member LED7ONHLED7FULLON : Pca9685TypeLedxOnHLedFullOn with get, set

Property Value

Type: Pca9685TypeLedxOnHLedFullOn
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED8OFF Property

IRD

Pca9685LED8OFF Property

LED8_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED8OFF { get; set; }
Public Property LED8OFF As UShort
    Get
    Set
public:
property unsigned short LED8OFF {
    unsigned short get ();
    void set (unsigned short value);
}
member LED8OFF : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED8OFFHLED8FULLOFF Property

IRD

Pca9685LED8OFFHLED8FULLOFF Property

LED8_OFF_H: LED8_FULL_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOffHLedFullOff LED8OFFHLED8FULLOFF { get; set; }
Public Property LED8OFFHLED8FULLOFF As Pca9685TypeLedxOffHLedFullOff
    Get
    Set
public:
property Pca9685TypeLedxOffHLedFullOff LED8OFFHLED8FULLOFF {
    Pca9685TypeLedxOffHLedFullOff get ();
    void set (Pca9685TypeLedxOffHLedFullOff value);
}
member LED8OFFHLED8FULLOFF : Pca9685TypeLedxOffHLedFullOff with get, set

Property Value

Type: Pca9685TypeLedxOffHLedFullOff
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED8ON Property

IRD

Pca9685LED8ON Property

LED8_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED8ON { get; set; }
Public Property LED8ON As UShort
    Get
    Set
public:
property unsigned short LED8ON {
    unsigned short get ();
    void set (unsigned short value);
}
member LED8ON : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED8ONHLED8FULLON Property

IRD

Pca9685LED8ONHLED8FULLON Property

LED8_ON_H: LED8_FULL_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOnHLedFullOn LED8ONHLED8FULLON { get; set; }
Public Property LED8ONHLED8FULLON As Pca9685TypeLedxOnHLedFullOn
    Get
    Set
public:
property Pca9685TypeLedxOnHLedFullOn LED8ONHLED8FULLON {
    Pca9685TypeLedxOnHLedFullOn get ();
    void set (Pca9685TypeLedxOnHLedFullOn value);
}
member LED8ONHLED8FULLON : Pca9685TypeLedxOnHLedFullOn with get, set

Property Value

Type: Pca9685TypeLedxOnHLedFullOn
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED9OFF Property

IRD

Pca9685LED9OFF Property

LED9_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED9OFF { get; set; }
Public Property LED9OFF As UShort
    Get
    Set
public:
property unsigned short LED9OFF {
    unsigned short get ();
    void set (unsigned short value);
}
member LED9OFF : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED9OFFHLED9FULLOFF Property

IRD

Pca9685LED9OFFHLED9FULLOFF Property

LED9_OFF_H: LED9_FULL_OFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOffHLedFullOff LED9OFFHLED9FULLOFF { get; set; }
Public Property LED9OFFHLED9FULLOFF As Pca9685TypeLedxOffHLedFullOff
    Get
    Set
public:
property Pca9685TypeLedxOffHLedFullOff LED9OFFHLED9FULLOFF {
    Pca9685TypeLedxOffHLedFullOff get ();
    void set (Pca9685TypeLedxOffHLedFullOff value);
}
member LED9OFFHLED9FULLOFF : Pca9685TypeLedxOffHLedFullOff with get, set

Property Value

Type: Pca9685TypeLedxOffHLedFullOff
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED9ON Property

IRD

Pca9685LED9ON Property

LED9_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LED9ON { get; set; }
Public Property LED9ON As UShort
    Get
    Set
public:
property unsigned short LED9ON {
    unsigned short get ();
    void set (unsigned short value);
}
member LED9ON : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.LED9ONHLED9FULLON Property

IRD

Pca9685LED9ONHLED9FULLON Property

LED9_ON_H: LED9_FULL_ON

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeLedxOnHLedFullOn LED9ONHLED9FULLON { get; set; }
Public Property LED9ONHLED9FULLON As Pca9685TypeLedxOnHLedFullOn
    Get
    Set
public:
property Pca9685TypeLedxOnHLedFullOn LED9ONHLED9FULLON {
    Pca9685TypeLedxOnHLedFullOn get ();
    void set (Pca9685TypeLedxOnHLedFullOn value);
}
member LED9ONHLED9FULLON : Pca9685TypeLedxOnHLedFullOn with get, set

Property Value

Type: Pca9685TypeLedxOnHLedFullOn
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.Mode1AI Property

IRD

Pca9685Mode1AI Property

Mode 1: AI

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeMode1AutoIncrement Mode1AI { get; set; }
Public Property Mode1AI As Pca9685TypeMode1AutoIncrement
    Get
    Set
public:
property Pca9685TypeMode1AutoIncrement Mode1AI {
    Pca9685TypeMode1AutoIncrement get ();
    void set (Pca9685TypeMode1AutoIncrement value);
}
member Mode1AI : Pca9685TypeMode1AutoIncrement with get, set

Property Value

Type: Pca9685TypeMode1AutoIncrement
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.Mode1ALLCALL Property

IRD

Pca9685Mode1ALLCALL Property

Mode 1: ALLCALL

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeMode1AllCall Mode1ALLCALL { get; set; }
Public Property Mode1ALLCALL As Pca9685TypeMode1AllCall
    Get
    Set
public:
property Pca9685TypeMode1AllCall Mode1ALLCALL {
    Pca9685TypeMode1AllCall get ();
    void set (Pca9685TypeMode1AllCall value);
}
member Mode1ALLCALL : Pca9685TypeMode1AllCall with get, set

Property Value

Type: Pca9685TypeMode1AllCall
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.Mode1EXTCLK Property

IRD

Pca9685Mode1EXTCLK Property

Mode 1: EXTCLK

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeMode1ExtClock Mode1EXTCLK { get; set; }
Public Property Mode1EXTCLK As Pca9685TypeMode1ExtClock
    Get
    Set
public:
property Pca9685TypeMode1ExtClock Mode1EXTCLK {
    Pca9685TypeMode1ExtClock get ();
    void set (Pca9685TypeMode1ExtClock value);
}
member Mode1EXTCLK : Pca9685TypeMode1ExtClock with get, set

Property Value

Type: Pca9685TypeMode1ExtClock
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.Mode1RESTART Property

IRD

Pca9685Mode1RESTART Property

Mode 1: RESTART

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeMode1Restart Mode1RESTART { get; set; }
Public Property Mode1RESTART As Pca9685TypeMode1Restart
    Get
    Set
public:
property Pca9685TypeMode1Restart Mode1RESTART {
    Pca9685TypeMode1Restart get ();
    void set (Pca9685TypeMode1Restart value);
}
member Mode1RESTART : Pca9685TypeMode1Restart with get, set

Property Value

Type: Pca9685TypeMode1Restart
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.Mode1SLEEP Property

IRD

Pca9685Mode1SLEEP Property

Mode 1: SLEEP

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeMode1Sleep Mode1SLEEP { get; set; }
Public Property Mode1SLEEP As Pca9685TypeMode1Sleep
    Get
    Set
public:
property Pca9685TypeMode1Sleep Mode1SLEEP {
    Pca9685TypeMode1Sleep get ();
    void set (Pca9685TypeMode1Sleep value);
}
member Mode1SLEEP : Pca9685TypeMode1Sleep with get, set

Property Value

Type: Pca9685TypeMode1Sleep
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.Mode1SUB1 Property

IRD

Pca9685Mode1SUB1 Property

Mode 1: SUB1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeMode1Sub1 Mode1SUB1 { get; set; }
Public Property Mode1SUB1 As Pca9685TypeMode1Sub1
    Get
    Set
public:
property Pca9685TypeMode1Sub1 Mode1SUB1 {
    Pca9685TypeMode1Sub1 get ();
    void set (Pca9685TypeMode1Sub1 value);
}
member Mode1SUB1 : Pca9685TypeMode1Sub1 with get, set

Property Value

Type: Pca9685TypeMode1Sub1
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.Mode1SUB2 Property

IRD

Pca9685Mode1SUB2 Property

Mode 1: SUB2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeMode1Sub2 Mode1SUB2 { get; set; }
Public Property Mode1SUB2 As Pca9685TypeMode1Sub2
    Get
    Set
public:
property Pca9685TypeMode1Sub2 Mode1SUB2 {
    Pca9685TypeMode1Sub2 get ();
    void set (Pca9685TypeMode1Sub2 value);
}
member Mode1SUB2 : Pca9685TypeMode1Sub2 with get, set

Property Value

Type: Pca9685TypeMode1Sub2
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.Mode1SUB3 Property

IRD

Pca9685Mode1SUB3 Property

Mode 1: SUB3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeMode1Sub1 Mode1SUB3 { get; set; }
Public Property Mode1SUB3 As Pca9685TypeMode1Sub1
    Get
    Set
public:
property Pca9685TypeMode1Sub1 Mode1SUB3 {
    Pca9685TypeMode1Sub1 get ();
    void set (Pca9685TypeMode1Sub1 value);
}
member Mode1SUB3 : Pca9685TypeMode1Sub1 with get, set

Property Value

Type: Pca9685TypeMode1Sub1
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.Mode2INVRT Property

IRD

Pca9685Mode2INVRT Property

Mode 2: INVRT

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeMode2OutputInverted Mode2INVRT { get; set; }
Public Property Mode2INVRT As Pca9685TypeMode2OutputInverted
    Get
    Set
public:
property Pca9685TypeMode2OutputInverted Mode2INVRT {
    Pca9685TypeMode2OutputInverted get ();
    void set (Pca9685TypeMode2OutputInverted value);
}
member Mode2INVRT : Pca9685TypeMode2OutputInverted with get, set

Property Value

Type: Pca9685TypeMode2OutputInverted
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.Mode2OCH Property

IRD

Pca9685Mode2OCH Property

Mode 2: OCH

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeMode2OutputChanged Mode2OCH { get; set; }
Public Property Mode2OCH As Pca9685TypeMode2OutputChanged
    Get
    Set
public:
property Pca9685TypeMode2OutputChanged Mode2OCH {
    Pca9685TypeMode2OutputChanged get ();
    void set (Pca9685TypeMode2OutputChanged value);
}
member Mode2OCH : Pca9685TypeMode2OutputChanged with get, set

Property Value

Type: Pca9685TypeMode2OutputChanged
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.Mode2OUTDRV Property

IRD

Pca9685Mode2OUTDRV Property

Mode 2: OUTDRV

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeMode2OutputDrive Mode2OUTDRV { get; set; }
Public Property Mode2OUTDRV As Pca9685TypeMode2OutputDrive
    Get
    Set
public:
property Pca9685TypeMode2OutputDrive Mode2OUTDRV {
    Pca9685TypeMode2OutputDrive get ();
    void set (Pca9685TypeMode2OutputDrive value);
}
member Mode2OUTDRV : Pca9685TypeMode2OutputDrive with get, set

Property Value

Type: Pca9685TypeMode2OutputDrive
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.Mode2OUTNE Property

IRD

Pca9685Mode2OUTNE Property

Mode 2: OUTNE

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9685TypeMode2OutputNotEnable Mode2OUTNE { get; set; }
Public Property Mode2OUTNE As Pca9685TypeMode2OutputNotEnable
    Get
    Set
public:
property Pca9685TypeMode2OutputNotEnable Mode2OUTNE {
    Pca9685TypeMode2OutputNotEnable get ();
    void set (Pca9685TypeMode2OutputNotEnable value);
}
member Mode2OUTNE : Pca9685TypeMode2OutputNotEnable with get, set

Property Value

Type: Pca9685TypeMode2OutputNotEnable
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.PRESCALE Property

IRD

Pca9685PRESCALE Property

PRE_SCALE

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PRESCALE { get; set; }
Public Property PRESCALE As Byte
    Get
    Set
public:
property unsigned char PRESCALE {
    unsigned char get ();
    void set (unsigned char value);
}
member PRESCALE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.SUBADR1 Property

IRD

Pca9685SUBADR1 Property

SUBADR1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SUBADR1 { get; set; }
Public Property SUBADR1 As Byte
    Get
    Set
public:
property unsigned char SUBADR1 {
    unsigned char get ();
    void set (unsigned char value);
}
member SUBADR1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.SUBADR2 Property

IRD

Pca9685SUBADR2 Property

SUBADR2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SUBADR2 { get; set; }
Public Property SUBADR2 As Byte
    Get
    Set
public:
property unsigned char SUBADR2 {
    unsigned char get ();
    void set (unsigned char value);
}
member SUBADR2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.SUBADR3 Property

IRD

Pca9685SUBADR3 Property

SUBADR3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SUBADR3 { get; set; }
Public Property SUBADR3 As Byte
    Get
    Set
public:
property unsigned char SUBADR3 {
    unsigned char get ();
    void set (unsigned char value);
}
member SUBADR3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685 Methods

The Pca9685 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.Flush Method

IRD

Pca9685Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9685 Class
telos.Ird.NXPSemiconductors Namespace


Pca9685.TypeLedxOffHLedFullOff Enumeration

IRD

Pca9685TypeLedxOffHLedFullOff Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedxOffHLedFullOff
Public Enumeration TypeLedxOffHLedFullOff
public enum class TypeLedxOffHLedFullOff
type TypeLedxOffHLedFullOff
Members
Member name | Value | Description
OFFRegisterDefinesDelayUntilLEDOFF | 1 | OFF Register Defines Delay Until LED OFF
ONDefinesLEDOnOFFDefinesLEDOffTime | 0 | ON Defines LED On, OFF Defines LED Off Time
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9685.TypeLedxOnHLedFullOn Enumeration

IRD

Pca9685TypeLedxOnHLedFullOn Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLedxOnHLedFullOn
Public Enumeration TypeLedxOnHLedFullOn
public enum class TypeLedxOnHLedFullOn
type TypeLedxOnHLedFullOn
Members
Member name | Value | Description
ONRegisterDefinesDelayUntilLEDOn | 1 | ON Register Defines Delay Until LED On
ONDefinesLEDOnOFFDefinesLEDOffTime | 0 | ON Defines LED On, OFF Defines LED Off Time
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9685.TypeMode1AllCall Enumeration

IRD

Pca9685TypeMode1AllCall Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMode1AllCall
Public Enumeration TypeMode1AllCall
public enum class TypeMode1AllCall
type TypeMode1AllCall
Members
Member name | Value | Description
ResponseToLEDAllCall | 1 | Response To LED All Call
NoResponseToLEDAllCall | 0 | No Response To LED All Call
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9685.TypeMode1AutoIncrement Enumeration

IRD

Pca9685TypeMode1AutoIncrement Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMode1AutoIncrement
Public Enumeration TypeMode1AutoIncrement
public enum class TypeMode1AutoIncrement
type TypeMode1AutoIncrement
Members
Member name | Value | Description
AutoIncrementEnable | 1 | Auto Increment: Enable
AutoIncrementDisable | 0 | Auto Increment: Disable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9685.TypeMode1ExtClock Enumeration

IRD

Pca9685TypeMode1ExtClock Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMode1ExtClock
Public Enumeration TypeMode1ExtClock
public enum class TypeMode1ExtClock
type TypeMode1ExtClock
Members
Member name | Value | Description
UseEXTClockPin | 1 | Use EXT Clock Pin
UseInternalClock | 0 | Use Internal Clock
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9685.TypeMode1Restart Enumeration

IRD

Pca9685TypeMode1Restart Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMode1Restart
Public Enumeration TypeMode1Restart
public enum class TypeMode1Restart
type TypeMode1Restart
Members
Member name | Value | Description
RestartEnable | 1 | Restart Enable
Low | 0 | Low
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9685.TypeMode1Sleep Enumeration

IRD

Pca9685TypeMode1Sleep Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMode1Sleep
Public Enumeration TypeMode1Sleep
public enum class TypeMode1Sleep
type TypeMode1Sleep
Members
Member name | Value | Description
LowPowerMode | 1 | Low Power Mode
NormalMode | 0 | Normal Mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9685.TypeMode1Sub1 Enumeration

IRD

Pca9685TypeMode1Sub1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMode1Sub1
Public Enumeration TypeMode1Sub1
public enum class TypeMode1Sub1
type TypeMode1Sub1
Members
Member name | Value | Description
ResponseToSubaddress1 | 1 | Response To Subaddress 1
NoResponseToSubaddress1 | 0 | No Response To Subaddress 1
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9685.TypeMode1Sub2 Enumeration

IRD

Pca9685TypeMode1Sub2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMode1Sub2
Public Enumeration TypeMode1Sub2
public enum class TypeMode1Sub2
type TypeMode1Sub2
Members
Member name | Value | Description
ResponseToSubaddress2 | 1 | Response To Subaddress 2
NoResponseToSubaddress2 | 0 | No Response To Subaddress 2
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9685.TypeMode1Sub3 Enumeration

IRD

Pca9685TypeMode1Sub3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMode1Sub3
Public Enumeration TypeMode1Sub3
public enum class TypeMode1Sub3
type TypeMode1Sub3
Members
Member name | Value | Description
ResponseToSubaddress3 | 1 | Response To Subaddress 3
NoResponseToSubaddress3 | 0 | No Response To Subaddress 3
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9685.TypeMode2OutputChanged Enumeration

IRD

Pca9685TypeMode2OutputChanged Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMode2OutputChanged
Public Enumeration TypeMode2OutputChanged
public enum class TypeMode2OutputChanged
type TypeMode2OutputChanged
Members
Member name | Value | Description
OutputChangedOnACK | 1 | Output Changed On: ACK
OutputChangedOnSTOP | 0 | Output Changed On: STOP
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9685.TypeMode2OutputDrive Enumeration

IRD

Pca9685TypeMode2OutputDrive Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMode2OutputDrive
Public Enumeration TypeMode2OutputDrive
public enum class TypeMode2OutputDrive
type TypeMode2OutputDrive
Members
Member name | Value | Description
LEDOutputConfiguredTotemPole | 1 | LED Output Configured: Totem Pole
LEDOutputConfiguredOpenDrain | 0 | LED Output Configured: Open Drain
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9685.TypeMode2OutputInverted Enumeration

IRD

Pca9685TypeMode2OutputInverted Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMode2OutputInverted
Public Enumeration TypeMode2OutputInverted
public enum class TypeMode2OutputInverted
type TypeMode2OutputInverted
Members
Member name | Value | Description
OutputInverted | 1 | Output: Inverted
OutputNotInverted | 0 | Output: Not Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9685.TypeMode2OutputNotEnable Enumeration

IRD

Pca9685TypeMode2OutputNotEnable Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMode2OutputNotEnable
Public Enumeration TypeMode2OutputNotEnable
public enum class TypeMode2OutputNotEnable
type TypeMode2OutputNotEnable
Members
Member name | Value | Description
LEDHighImpedance | 2 | LED High Impedance
LED1AtOutputDrive1LED0AtOutputDrive0 | 1 | LED=1 At Output Drive=1 / LED=0 At Output Drive=0
LED0 | 0 | LED=0
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9698 Class

NXP Semiconductors: PCA 9698
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPca9698

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9698
Public Class Pca9698
public ref class Pca9698
type Pca9698 =  class end

The Pca9698 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9698 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlAllBanksBank0 | Control All Banks (Bank 0)
Public property | ControlAllBanksBank0AI | Control All Banks (Bank 0) [AI]
Public property | ControlAllBanksBank1 | Control All Banks (Bank 1)
Public property | ControlAllBanksBank1AI | Control All Banks (Bank 1) [AI]
Public property | ControlAllBanksBank2 | Control All Banks (Bank 2)
Public property | ControlAllBanksBank2AI | Control All Banks (Bank 2) [AI]
Public property | ControlAllBanksBank3 | Control All Banks (Bank 3)
Public property | ControlAllBanksBank3AI | Control All Banks (Bank 3) [AI]
Public property | ControlAllBanksBank4 | Control All Banks (Bank 4)
Public property | ControlAllBanksBank4AI | Control All Banks (Bank 4) [AI]
Public property | ControlAllBanksBSEL | Control All Banks (BSEL)
Public property | ControlAllBanksBSELAI | Control All Banks (BSEL) [AI]
Public property | InputPortIO00 | Input Port (IO0_0)
Public property | InputPortIO00AI | Input Port (IO0_0) [AI]
Public property | InputPortIO01 | Input Port (IO0_1)
Public property | InputPortIO01AI | Input Port (IO0_1) [AI]
Public property | InputPortIO02 | Input Port (IO0_2)
Public property | InputPortIO02AI | Input Port (IO0_2) [AI]
Public property | InputPortIO03 | Input Port (IO0_3)
Public property | InputPortIO03AI | Input Port (IO0_3) [AI]
Public property | InputPortIO04 | Input Port (IO0_4)
Public property | InputPortIO04AI | Input Port (IO0_4) [AI]
Public property | InputPortIO05 | Input Port (IO0_5)
Public property | InputPortIO05AI | Input Port (IO0_5) [AI]
Public property | InputPortIO06 | Input Port (IO0_6)
Public property | InputPortIO06AI | Input Port (IO0_6) [AI]
Public property | InputPortIO07 | Input Port (IO0_7)
Public property | InputPortIO07AI | Input Port (IO0_7) [AI]
Public property | InputPortIO10 | Input Port (IO1_0)
Public property | InputPortIO10AI | Input Port (IO1_0) [AI]
Public property | InputPortIO11 | Input Port (IO1_1)
Public property | InputPortIO11AI | Input Port (IO1_1) [AI]
Public property | InputPortIO12 | Input Port (IO1_2)
Public property | InputPortIO12AI | Input Port (IO1_2) [AI]
Public property | InputPortIO13 | Input Port (IO1_3)
Public property | InputPortIO13AI | Input Port (IO1_3) [AI]
Public property | InputPortIO14 | Input Port (IO1_4)
Public property | InputPortIO14AI | Input Port (IO1_4) [AI]
Public property | InputPortIO15 | Input Port (IO1_5)
Public property | InputPortIO15AI | Input Port (IO1_5) [AI]
Public property | InputPortIO16 | Input Port (IO1_6)
Public property | InputPortIO16AI | Input Port (IO1_6) [AI]
Public property | InputPortIO17 | Input Port (IO1_7)
Public property | InputPortIO17AI | Input Port (IO1_7) [AI]
Public property | InputPortIO20 | Input Port (IO2_0)
Public property | InputPortIO20AI | Input Port (IO2_0) [AI]
Public property | InputPortIO21 | Input Port (IO2_1)
Public property | InputPortIO21AI | Input Port (IO2_1) [AI]
Public property | InputPortIO22 | Input Port (IO2_2)
Public property | InputPortIO22AI | Input Port (IO2_2) [AI]
Public property | InputPortIO23 | Input Port (IO2_3)
Public property | InputPortIO23AI | Input Port (IO2_3) [AI]
Public property | InputPortIO24 | Input Port (IO2_4)
Public property | InputPortIO24AI | Input Port (IO2_4) [AI]
Public property | InputPortIO25 | Input Port (IO2_5)
Public property | InputPortIO25AI | Input Port (IO2_5) [AI]
Public property | InputPortIO26 | Input Port (IO2_6)
Public property | InputPortIO26AI | Input Port (IO2_6) [AI]
Public property | InputPortIO27 | Input Port (IO2_7)
Public property | InputPortIO27AI | Input Port (IO2_7) [AI]
Public property | InputPortIO30 | Input Port (IO3_0)
Public property | InputPortIO30AI | Input Port (IO3_0) [AI]
Public property | InputPortIO31 | Input Port (IO3_1)
Public property | InputPortIO31AI | Input Port (IO3_1) [AI]
Public property | InputPortIO32 | Input Port (IO3_2)
Public property | InputPortIO32AI | Input Port (IO3_2) [AI]
Public property | InputPortIO33 | Input Port (IO3_3)
Public property | InputPortIO33AI | Input Port (IO3_3) [AI]
Public property | InputPortIO34 | Input Port (IO3_4)
Public property | InputPortIO34AI | Input Port (IO3_4) [AI]
Public property | InputPortIO35 | Input Port (IO3_5)
Public property | InputPortIO35AI | Input Port (IO3_5) [AI]
Public property | InputPortIO36 | Input Port (IO3_6)
Public property | InputPortIO36AI | Input Port (IO3_6) [AI]
Public property | InputPortIO37 | Input Port (IO3_7)
Public property | InputPortIO37AI | Input Port (IO3_7) [AI]
Public property | IOConfigurationIO00 | I/O Configuration (IO0_0)
Public property | IOConfigurationIO00AI | I/O Configuration (IO0_0) [AI]
Public property | IOConfigurationIO01 | I/O Configuration (IO0_1)
Public property | IOConfigurationIO01AI | I/O Configuration (IO0_1) [AI]
Public property | IOConfigurationIO02 | I/O Configuration (IO0_2)
Public property | IOConfigurationIO02AI | I/O Configuration (IO0_2) [AI]
Public property | IOConfigurationIO03 | I/O Configuration (IO0_3)
Public property | IOConfigurationIO03AI | I/O Configuration (IO0_3) [AI]
Public property | IOConfigurationIO04 | I/O Configuration (IO0_4)
Public property | IOConfigurationIO04AI | I/O Configuration (IO0_4) [AI]
Public property | IOConfigurationIO05 | I/O Configuration (IO0_5)
Public property | IOConfigurationIO05AI | I/O Configuration (IO0_5) [AI]
Public property | IOConfigurationIO06 | I/O Configuration (IO0_6)
Public property | IOConfigurationIO06AI | I/O Configuration (IO0_6) [AI]
Public property | IOConfigurationIO07 | I/O Configuration (IO0_7)
Public property | IOConfigurationIO07AI | I/O Configuration (IO0_7) [AI]
Public property | IOConfigurationIO10 | I/O Configuration (IO1_0)
Public property | IOConfigurationIO10AI | I/O Configuration (IO1_0) [AI]
Public property | IOConfigurationIO11 | I/O Configuration (IO1_1)
Public property | IOConfigurationIO11AI | I/O Configuration (IO1_1) [AI]
Public property | IOConfigurationIO12 | I/O Configuration (IO1_2)
Public property | IOConfigurationIO12AI | I/O Configuration (IO1_2) [AI]
Public property | IOConfigurationIO13 | I/O Configuration (IO1_3)
Public property | IOConfigurationIO13AI | I/O Configuration (IO1_3) [AI]
Public property | IOConfigurationIO14 | I/O Configuration (IO1_4)
Public property | IOConfigurationIO14AI | I/O Configuration (IO1_4) [AI]
Public property | IOConfigurationIO15 | I/O Configuration (IO1_5)
Public property | IOConfigurationIO15AI | I/O Configuration (IO1_5) [AI]
Public property | IOConfigurationIO16 | I/O Configuration (IO1_6)
Public property | IOConfigurationIO16AI | I/O Configuration (IO1_6) [AI]
Public property | IOConfigurationIO17 | I/O Configuration (IO1_7)
Public property | IOConfigurationIO17AI | I/O Configuration (IO1_7) [AI]
Public property | IOConfigurationIO20 | I/O Configuration (IO2_0)
Public property | IOConfigurationIO20AI | I/O Configuration (IO2_0) [AI]
Public property | IOConfigurationIO21 | I/O Configuration (IO2_1)
Public property | IOConfigurationIO21AI | I/O Configuration (IO2_1) [AI]
Public property | IOConfigurationIO22 | I/O Configuration (IO2_2)
Public property | IOConfigurationIO22AI | I/O Configuration (IO2_2) [AI]
Public property | IOConfigurationIO23 | I/O Configuration (IO2_3)
Public property | IOConfigurationIO23AI | I/O Configuration (IO2_3) [AI]
Public property | IOConfigurationIO24 | I/O Configuration (IO2_4)
Public property | IOConfigurationIO24AI | I/O Configuration (IO2_4) [AI]
Public property | IOConfigurationIO25 | I/O Configuration (IO2_5)
Public property | IOConfigurationIO25AI | I/O Configuration (IO2_5) [AI]
Public property | IOConfigurationIO26 | I/O Configuration (IO2_6)
Public property | IOConfigurationIO26AI | I/O Configuration (IO2_6) [AI]
Public property | IOConfigurationIO27 | I/O Configuration (IO2_7)
Public property | IOConfigurationIO27AI | I/O Configuration (IO2_7) [AI]
Public property | IOConfigurationIO30 | I/O Configuration (IO3_0)
Public property | IOConfigurationIO30AI | I/O Configuration (IO3_0) [AI]
Public property | IOConfigurationIO31 | I/O Configuration (IO3_1)
Public property | IOConfigurationIO31AI | I/O Configuration (IO3_1) [AI]
Public property | IOConfigurationIO32 | I/O Configuration (IO3_2)
Public property | IOConfigurationIO32AI | I/O Configuration (IO3_2) [AI]
Public property | IOConfigurationIO33 | I/O Configuration (IO3_3)
Public property | IOConfigurationIO33AI | I/O Configuration (IO3_3) [AI]
Public property | IOConfigurationIO34 | I/O Configuration (IO3_4)
Public property | IOConfigurationIO34AI | I/O Configuration (IO3_4) [AI]
Public property | IOConfigurationIO35 | I/O Configuration (IO3_5)
Public property | IOConfigurationIO35AI | I/O Configuration (IO3_5) [AI]
Public property | IOConfigurationIO36 | I/O Configuration (IO3_6)
Public property | IOConfigurationIO36AI | I/O Configuration (IO3_6) [AI]
Public property | IOConfigurationIO37 | I/O Configuration (IO3_7)
Public property | IOConfigurationIO37AI | I/O Configuration (IO3_7) [AI]
Public property | MaskInterruptIO00 | Mask Interrupt (IO0_0)
Public property | MaskInterruptIO00AI | Mask Interrupt (IO0_0) [AI]
Public property | MaskInterruptIO01 | Mask Interrupt (IO0_1)
Public property | MaskInterruptIO01AI | Mask Interrupt (IO0_1) [AI]
Public property | MaskInterruptIO02 | Mask Interrupt (IO0_2)
Public property | MaskInterruptIO02AI | Mask Interrupt (IO0_2) [AI]
Public property | MaskInterruptIO03 | Mask Interrupt (IO0_3)
Public property | MaskInterruptIO03AI | Mask Interrupt (IO0_3) [AI]
Public property | MaskInterruptIO04 | Mask Interrupt (IO0_4)
Public property | MaskInterruptIO04AI | Mask Interrupt (IO0_4) [AI]
Public property | MaskInterruptIO05 | Mask Interrupt (IO0_5)
Public property | MaskInterruptIO05AI | Mask Interrupt (IO0_5) [AI]
Public property | MaskInterruptIO06 | Mask Interrupt (IO0_6)
Public property | MaskInterruptIO06AI | Mask Interrupt (IO0_6) [AI]
Public property | MaskInterruptIO07 | Mask Interrupt (IO0_7)
Public property | MaskInterruptIO07AI | Mask Interrupt (IO0_7) [AI]
Public property | MaskInterruptIO10 | Mask Interrupt (IO1_0)
Public property | MaskInterruptIO10AI | Mask Interrupt (IO1_0) [AI]
Public property | MaskInterruptIO11 | Mask Interrupt (IO1_1)
Public property | MaskInterruptIO11AI | Mask Interrupt (IO1_1) [AI]
Public property | MaskInterruptIO12 | Mask Interrupt (IO1_2)
Public property | MaskInterruptIO12AI | Mask Interrupt (IO1_2) [AI]
Public property | MaskInterruptIO13 | Mask Interrupt (IO1_3)
Public property | MaskInterruptIO13AI | Mask Interrupt (IO1_3) [AI]
Public property | MaskInterruptIO14 | Mask Interrupt (IO1_4)
Public property | MaskInterruptIO14AI | Mask Interrupt (IO1_4) [AI]
Public property | MaskInterruptIO15 | Mask Interrupt (IO1_5)
Public property | MaskInterruptIO15AI | Mask Interrupt (IO1_5) [AI]
Public property | MaskInterruptIO16 | Mask Interrupt (IO1_6)
Public property | MaskInterruptIO16AI | Mask Interrupt (IO1_6) [AI]
Public property | MaskInterruptIO17 | Mask Interrupt (IO1_7)
Public property | MaskInterruptIO17AI | Mask Interrupt (IO1_7) [AI]
Public property | MaskInterruptIO20 | Mask Interrupt (IO2_0)
Public property | MaskInterruptIO20AI | Mask Interrupt (IO2_0) [AI]
Public property | MaskInterruptIO21 | Mask Interrupt (IO2_1)
Public property | MaskInterruptIO21AI | Mask Interrupt (IO2_1) [AI]
Public property | MaskInterruptIO22 | Mask Interrupt (IO2_2)
Public property | MaskInterruptIO22AI | Mask Interrupt (IO2_2) [AI]
Public property | MaskInterruptIO23 | Mask Interrupt (IO2_3)
Public property | MaskInterruptIO23AI | Mask Interrupt (IO2_3) [AI]
Public property | MaskInterruptIO24 | Mask Interrupt (IO2_4)
Public property | MaskInterruptIO24AI | Mask Interrupt (IO2_4) [AI]
Public property | MaskInterruptIO25 | Mask Interrupt (IO2_5)
Public property | MaskInterruptIO25AI | Mask Interrupt (IO2_5) [AI]
Public property | MaskInterruptIO26 | Mask Interrupt (IO2_6)
Public property | MaskInterruptIO26AI | Mask Interrupt (IO2_6) [AI]
Public property | MaskInterruptIO27 | Mask Interrupt (IO2_7)
Public property | MaskInterruptIO27AI | Mask Interrupt (IO2_7) [AI]
Public property | MaskInterruptIO30 | Mask Interrupt (IO3_0)
Public property | MaskInterruptIO30AI | Mask Interrupt (IO3_0) [AI]
Public property | MaskInterruptIO31 | Mask Interrupt (IO3_1)
Public property | MaskInterruptIO31AI | Mask Interrupt (IO3_1) [AI]
Public property | MaskInterruptIO32 | Mask Interrupt (IO3_2)
Public property | MaskInterruptIO32AI | Mask Interrupt (IO3_2) [AI]
Public property | MaskInterruptIO33 | Mask Interrupt (IO3_3)
Public property | MaskInterruptIO33AI | Mask Interrupt (IO3_3) [AI]
Public property | MaskInterruptIO34 | Mask Interrupt (IO3_4)
Public property | MaskInterruptIO34AI | Mask Interrupt (IO3_4) [AI]
Public property | MaskInterruptIO35 | Mask Interrupt (IO3_5)
Public property | MaskInterruptIO35AI | Mask Interrupt (IO3_5) [AI]
Public property | MaskInterruptIO36 | Mask Interrupt (IO3_6)
Public property | MaskInterruptIO36AI | Mask Interrupt (IO3_6) [AI]
Public property | MaskInterruptIO37 | Mask Interrupt (IO3_7)
Public property | MaskInterruptIO37AI | Mask Interrupt (IO3_7) [AI]
Public property | ModeIOAC | Mode (IOAC)
Public property | ModeIOACAI | Mode (IOAC) [AI]
Public property | ModeOCH | Mode (OCH)
Public property | ModeOCHAI | Mode (OCH) [AI]
Public property | ModeOEPOL | Mode (OEPOL)
Public property | ModeOEPOLAI | Mode (OEPOL) [AI]
Public property | ModeSMBA | Mode (SMBA)
Public property | ModeSMBAAI | Mode (SMBA) [AI]
Public property | OutputPortIO00 | Output Port (IO0_0)
Public property | OutputPortIO00AI | Output Port (IO0_0) [AI]
Public property | OutputPortIO01 | Output Port (IO0_1)
Public property | OutputPortIO01AI | Output Port (IO0_1) [AI]
Public property | OutputPortIO02 | Output Port (IO0_2)
Public property | OutputPortIO02AI | Output Port (IO0_2) [AI]
Public property | OutputPortIO03 | Output Port (IO0_3)
Public property | OutputPortIO03AI | Output Port (IO0_3) [AI]
Public property | OutputPortIO04 | Output Port (IO0_4)
Public property | OutputPortIO04AI | Output Port (IO0_4) [AI]
Public property | OutputPortIO05 | Output Port (IO0_5)
Public property | OutputPortIO05AI | Output Port (IO0_5) [AI]
Public property | OutputPortIO06 | Output Port (IO0_6)
Public property | OutputPortIO06AI | Output Port (IO0_6) [AI]
Public property | OutputPortIO07 | Output Port (IO0_7)
Public property | OutputPortIO07AI | Output Port (IO0_7) [AI]
Public property | OutputPortIO10 | Output Port (IO1_0)
Public property | OutputPortIO10AI | Output Port (IO1_0) [AI]
Public property | OutputPortIO11 | Output Port (IO1_1)
Public property | OutputPortIO11AI | Output Port (IO1_1) [AI]
Public property | OutputPortIO12 | Output Port (IO1_2)
Public property | OutputPortIO12AI | Output Port (IO1_2) [AI]
Public property | OutputPortIO13 | Output Port (IO1_3)
Public property | OutputPortIO13AI | Output Port (IO1_3) [AI]
Public property | OutputPortIO14 | Output Port (IO1_4)
Public property | OutputPortIO14AI | Output Port (IO1_4) [AI]
Public property | OutputPortIO15 | Output Port (IO1_5)
Public property | OutputPortIO15AI | Output Port (IO1_5) [AI]
Public property | OutputPortIO16 | Output Port (IO1_6)
Public property | OutputPortIO16AI | Output Port (IO1_6) [AI]
Public property | OutputPortIO17 | Output Port (IO1_7)
Public property | OutputPortIO17AI | Output Port (IO1_7) [AI]
Public property | OutputPortIO20 | Output Port (IO2_0)
Public property | OutputPortIO20AI | Output Port (IO2_0) [AI]
Public property | OutputPortIO21 | Output Port (IO2_1)
Public property | OutputPortIO21AI | Output Port (IO2_1) [AI]
Public property | OutputPortIO22 | Output Port (IO2_2)
Public property | OutputPortIO22AI | Output Port (IO2_2) [AI]
Public property | OutputPortIO23 | Output Port (IO2_3)
Public property | OutputPortIO23AI | Output Port (IO2_3) [AI]
Public property | OutputPortIO24 | Output Port (IO2_4)
Public property | OutputPortIO24AI | Output Port (IO2_4) [AI]
Public property | OutputPortIO25 | Output Port (IO2_5)
Public property | OutputPortIO25AI | Output Port (IO2_5) [AI]
Public property | OutputPortIO26 | Output Port (IO2_6)
Public property | OutputPortIO26AI | Output Port (IO2_6) [AI]
Public property | OutputPortIO27 | Output Port (IO2_7)
Public property | OutputPortIO27AI | Output Port (IO2_7) [AI]
Public property | OutputPortIO30 | Output Port (IO3_0)
Public property | OutputPortIO30AI | Output Port (IO3_0) [AI]
Public property | OutputPortIO31 | Output Port (IO3_1)
Public property | OutputPortIO31AI | Output Port (IO3_1) [AI]
Public property | OutputPortIO32 | Output Port (IO3_2)
Public property | OutputPortIO32AI | Output Port (IO3_2) [AI]
Public property | OutputPortIO33 | Output Port (IO3_3)
Public property | OutputPortIO33AI | Output Port (IO3_3) [AI]
Public property | OutputPortIO34 | Output Port (IO3_4)
Public property | OutputPortIO34AI | Output Port (IO3_4) [AI]
Public property | OutputPortIO35 | Output Port (IO3_5)
Public property | OutputPortIO35AI | Output Port (IO3_5) [AI]
Public property | OutputPortIO36 | Output Port (IO3_6)
Public property | OutputPortIO36AI | Output Port (IO3_6) [AI]
Public property | OutputPortIO37 | Output Port (IO3_7)
Public property | OutputPortIO37AI | Output Port (IO3_7) [AI]
Public property | OutputStructureConfigurationIO00IO01 | Output Structure Configuration (IO0_0 & IO0_1)
Public property | OutputStructureConfigurationIO00IO01AI | Output Structure Configuration (IO0_0 & IO0_1) [AI]
Public property | OutputStructureConfigurationIO02IO03 | Output Structure Configuration (IO0_2 & IO0_3)
Public property | OutputStructureConfigurationIO02IO03AI | Output Structure Configuration (IO0_2 & IO0_3) [AI]
Public property | OutputStructureConfigurationIO04IO05 | Output Structure Configuration (IO0_4 & IO0_5)
Public property | OutputStructureConfigurationIO04IO05AI | Output Structure Configuration (IO0_4 & IO0_5) [AI]
Public property | OutputStructureConfigurationIO06IO07 | Output Structure Configuration (IO0_6 & IO0_7)
Public property | OutputStructureConfigurationIO06IO07AI | Output Structure Configuration (IO0_6 & IO0_7) [AI]
Public property | OutputStructureConfigurationIO10IO17 | Output Structure Configuration (IO1_0 .. IO1_7)
Public property | OutputStructureConfigurationIO10IO17AI | Output Structure Configuration (IO1_0 .. IO1_7) [AI]
Public property | OutputStructureConfigurationIO20IO27 | Output Structure Configuration (IO2_0 .. IO2_7)
Public property | OutputStructureConfigurationIO20IO27AI | Output Structure Configuration (IO2_0 .. IO2_7) [AI]
Public property | OutputStructureConfigurationIO30IO37 | Output Structure Configuration (IO3_0 .. IO3_7)
Public property | OutputStructureConfigurationIO30IO37AI | Output Structure Configuration (IO3_0 .. IO3_7) [AI]
Public property | OutputStructureConfigurationIO40IO47 | Output Structure Configuration (IO4_0 .. IO4_7)
Public property | OutputStructureConfigurationIO40IO47AI | Output Structure Configuration (IO4_0 .. IO4_7) [AI]
Public property | PolarityInversionIO00 | Polarity Inversion (IO0_0)
Public property | PolarityInversionIO00AI | Polarity Inversion (IO0_0) [AI]
Public property | PolarityInversionIO01 | Polarity Inversion (IO0_1)
Public property | PolarityInversionIO01AI | Polarity Inversion (IO0_1) [AI]
Public property | PolarityInversionIO02 | Polarity Inversion (IO0_2)
Public property | PolarityInversionIO02AI | Polarity Inversion (IO0_2) [AI]
Public property | PolarityInversionIO03 | Polarity Inversion (IO0_3)
Public property | PolarityInversionIO03AI | Polarity Inversion (IO0_3) [AI]
Public property | PolarityInversionIO04 | Polarity Inversion (IO0_4)
Public property | PolarityInversionIO04AI | Polarity Inversion (IO0_4) [AI]
Public property | PolarityInversionIO05 | Polarity Inversion (IO0_5)
Public property | PolarityInversionIO05AI | Polarity Inversion (IO0_5) [AI]
Public property | PolarityInversionIO06 | Polarity Inversion (IO0_6)
Public property | PolarityInversionIO06AI | Polarity Inversion (IO0_6) [AI]
Public property | PolarityInversionIO07 | Polarity Inversion (IO0_7)
Public property | PolarityInversionIO07AI | Polarity Inversion (IO0_7) [AI]
Public property | PolarityInversionIO10 | Polarity Inversion (IO1_0)
Public property | PolarityInversionIO10AI | Polarity Inversion (IO1_0) [AI]
Public property | PolarityInversionIO11 | Polarity Inversion (IO1_1)
Public property | PolarityInversionIO11AI | Polarity Inversion (IO1_1) [AI]
Public property | PolarityInversionIO12 | Polarity Inversion (IO1_2)
Public property | PolarityInversionIO12AI | Polarity Inversion (IO1_2) [AI]
Public property | PolarityInversionIO13 | Polarity Inversion (IO1_3)
Public property | PolarityInversionIO13AI | Polarity Inversion (IO1_3) [AI]
Public property | PolarityInversionIO14 | Polarity Inversion (IO1_4)
Public property | PolarityInversionIO14AI | Polarity Inversion (IO1_4) [AI]
Public property | PolarityInversionIO15 | Polarity Inversion (IO1_5)
Public property | PolarityInversionIO15AI | Polarity Inversion (IO1_5) [AI]
Public property | PolarityInversionIO16 | Polarity Inversion (IO1_6)
Public property | PolarityInversionIO16AI | Polarity Inversion (IO1_6) [AI]
Public property | PolarityInversionIO17 | Polarity Inversion (IO1_7)
Public property | PolarityInversionIO17AI | Polarity Inversion (IO1_7) [AI]
Public property | PolarityInversionIO20 | Polarity Inversion (IO2_0)
Public property | PolarityInversionIO20AI | Polarity Inversion (IO2_0) [AI]
Public property | PolarityInversionIO21 | Polarity Inversion (IO2_1)
Public property | PolarityInversionIO21AI | Polarity Inversion (IO2_1) [AI]
Public property | PolarityInversionIO22 | Polarity Inversion (IO2_2)
Public property | PolarityInversionIO22AI | Polarity Inversion (IO2_2) [AI]
Public property | PolarityInversionIO23 | Polarity Inversion (IO2_3)
Public property | PolarityInversionIO23AI | Polarity Inversion (IO2_3) [AI]
Public property | PolarityInversionIO24 | Polarity Inversion (IO2_4)
Public property | PolarityInversionIO24AI | Polarity Inversion (IO2_4) [AI]
Public property | PolarityInversionIO25 | Polarity Inversion (IO2_5)
Public property | PolarityInversionIO25AI | Polarity Inversion (IO2_5) [AI]
Public property | PolarityInversionIO26 | Polarity Inversion (IO2_6)
Public property | PolarityInversionIO26AI | Polarity Inversion (IO2_6) [AI]
Public property | PolarityInversionIO27 | Polarity Inversion (IO2_7)
Public property | PolarityInversionIO27AI | Polarity Inversion (IO2_7) [AI]
Public property | PolarityInversionIO30 | Polarity Inversion (IO3_0)
Public property | PolarityInversionIO30AI | Polarity Inversion (IO3_0) [AI]
Public property | PolarityInversionIO31 | Polarity Inversion (IO3_1)
Public property | PolarityInversionIO31AI | Polarity Inversion (IO3_1) [AI]
Public property | PolarityInversionIO32 | Polarity Inversion (IO3_2)
Public property | PolarityInversionIO32AI | Polarity Inversion (IO3_2) [AI]
Public property | PolarityInversionIO33 | Polarity Inversion (IO3_3)
Public property | PolarityInversionIO33AI | Polarity Inversion (IO3_3) [AI]
Public property | PolarityInversionIO34 | Polarity Inversion (IO3_4)
Public property | PolarityInversionIO34AI | Polarity Inversion (IO3_4) [AI]
Public property | PolarityInversionIO35 | Polarity Inversion (IO3_5)
Public property | PolarityInversionIO35AI | Polarity Inversion (IO3_5) [AI]
Public property | PolarityInversionIO36 | Polarity Inversion (IO3_6)
Public property | PolarityInversionIO36AI | Polarity Inversion (IO3_6) [AI]
Public property | PolarityInversionIO37 | Polarity Inversion (IO3_7)
Public property | PolarityInversionIO37AI | Polarity Inversion (IO3_7) [AI]
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
40-Bit Fm+ I2C-Bus Advanced I/O Port With RESET, OE And INT
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9698 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9698(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9698

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698 Properties

The Pca9698 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ControlAllBanksBank0 | Control All Banks (Bank 0)
Public property | ControlAllBanksBank0AI | Control All Banks (Bank 0) [AI]
Public property | ControlAllBanksBank1 | Control All Banks (Bank 1)
Public property | ControlAllBanksBank1AI | Control All Banks (Bank 1) [AI]
Public property | ControlAllBanksBank2 | Control All Banks (Bank 2)
Public property | ControlAllBanksBank2AI | Control All Banks (Bank 2) [AI]
Public property | ControlAllBanksBank3 | Control All Banks (Bank 3)
Public property | ControlAllBanksBank3AI | Control All Banks (Bank 3) [AI]
Public property | ControlAllBanksBank4 | Control All Banks (Bank 4)
Public property | ControlAllBanksBank4AI | Control All Banks (Bank 4) [AI]
Public property | ControlAllBanksBSEL | Control All Banks (BSEL)
Public property | ControlAllBanksBSELAI | Control All Banks (BSEL) [AI]
Public property | InputPortIO00 | Input Port (IO0_0)
Public property | InputPortIO00AI | Input Port (IO0_0) [AI]
Public property | InputPortIO01 | Input Port (IO0_1)
Public property | InputPortIO01AI | Input Port (IO0_1) [AI]
Public property | InputPortIO02 | Input Port (IO0_2)
Public property | InputPortIO02AI | Input Port (IO0_2) [AI]
Public property | InputPortIO03 | Input Port (IO0_3)
Public property | InputPortIO03AI | Input Port (IO0_3) [AI]
Public property | InputPortIO04 | Input Port (IO0_4)
Public property | InputPortIO04AI | Input Port (IO0_4) [AI]
Public property | InputPortIO05 | Input Port (IO0_5)
Public property | InputPortIO05AI | Input Port (IO0_5) [AI]
Public property | InputPortIO06 | Input Port (IO0_6)
Public property | InputPortIO06AI | Input Port (IO0_6) [AI]
Public property | InputPortIO07 | Input Port (IO0_7)
Public property | InputPortIO07AI | Input Port (IO0_7) [AI]
Public property | InputPortIO10 | Input Port (IO1_0)
Public property | InputPortIO10AI | Input Port (IO1_0) [AI]
Public property | InputPortIO11 | Input Port (IO1_1)
Public property | InputPortIO11AI | Input Port (IO1_1) [AI]
Public property | InputPortIO12 | Input Port (IO1_2)
Public property | InputPortIO12AI | Input Port (IO1_2) [AI]
Public property | InputPortIO13 | Input Port (IO1_3)
Public property | InputPortIO13AI | Input Port (IO1_3) [AI]
Public property | InputPortIO14 | Input Port (IO1_4)
Public property | InputPortIO14AI | Input Port (IO1_4) [AI]
Public property | InputPortIO15 | Input Port (IO1_5)
Public property | InputPortIO15AI | Input Port (IO1_5) [AI]
Public property | InputPortIO16 | Input Port (IO1_6)
Public property | InputPortIO16AI | Input Port (IO1_6) [AI]
Public property | InputPortIO17 | Input Port (IO1_7)
Public property | InputPortIO17AI | Input Port (IO1_7) [AI]
Public property | InputPortIO20 | Input Port (IO2_0)
Public property | InputPortIO20AI | Input Port (IO2_0) [AI]
Public property | InputPortIO21 | Input Port (IO2_1)
Public property | InputPortIO21AI | Input Port (IO2_1) [AI]
Public property | InputPortIO22 | Input Port (IO2_2)
Public property | InputPortIO22AI | Input Port (IO2_2) [AI]
Public property | InputPortIO23 | Input Port (IO2_3)
Public property | InputPortIO23AI | Input Port (IO2_3) [AI]
Public property | InputPortIO24 | Input Port (IO2_4)
Public property | InputPortIO24AI | Input Port (IO2_4) [AI]
Public property | InputPortIO25 | Input Port (IO2_5)
Public property | InputPortIO25AI | Input Port (IO2_5) [AI]
Public property | InputPortIO26 | Input Port (IO2_6)
Public property | InputPortIO26AI | Input Port (IO2_6) [AI]
Public property | InputPortIO27 | Input Port (IO2_7)
Public property | InputPortIO27AI | Input Port (IO2_7) [AI]
Public property | InputPortIO30 | Input Port (IO3_0)
Public property | InputPortIO30AI | Input Port (IO3_0) [AI]
Public property | InputPortIO31 | Input Port (IO3_1)
Public property | InputPortIO31AI | Input Port (IO3_1) [AI]
Public property | InputPortIO32 | Input Port (IO3_2)
Public property | InputPortIO32AI | Input Port (IO3_2) [AI]
Public property | InputPortIO33 | Input Port (IO3_3)
Public property | InputPortIO33AI | Input Port (IO3_3) [AI]
Public property | InputPortIO34 | Input Port (IO3_4)
Public property | InputPortIO34AI | Input Port (IO3_4) [AI]
Public property | InputPortIO35 | Input Port (IO3_5)
Public property | InputPortIO35AI | Input Port (IO3_5) [AI]
Public property | InputPortIO36 | Input Port (IO3_6)
Public property | InputPortIO36AI | Input Port (IO3_6) [AI]
Public property | InputPortIO37 | Input Port (IO3_7)
Public property | InputPortIO37AI | Input Port (IO3_7) [AI]
Public property | IOConfigurationIO00 | I/O Configuration (IO0_0)
Public property | IOConfigurationIO00AI | I/O Configuration (IO0_0) [AI]
Public property | IOConfigurationIO01 | I/O Configuration (IO0_1)
Public property | IOConfigurationIO01AI | I/O Configuration (IO0_1) [AI]
Public property | IOConfigurationIO02 | I/O Configuration (IO0_2)
Public property | IOConfigurationIO02AI | I/O Configuration (IO0_2) [AI]
Public property | IOConfigurationIO03 | I/O Configuration (IO0_3)
Public property | IOConfigurationIO03AI | I/O Configuration (IO0_3) [AI]
Public property | IOConfigurationIO04 | I/O Configuration (IO0_4)
Public property | IOConfigurationIO04AI | I/O Configuration (IO0_4) [AI]
Public property | IOConfigurationIO05 | I/O Configuration (IO0_5)
Public property | IOConfigurationIO05AI | I/O Configuration (IO0_5) [AI]
Public property | IOConfigurationIO06 | I/O Configuration (IO0_6)
Public property | IOConfigurationIO06AI | I/O Configuration (IO0_6) [AI]
Public property | IOConfigurationIO07 | I/O Configuration (IO0_7)
Public property | IOConfigurationIO07AI | I/O Configuration (IO0_7) [AI]
Public property | IOConfigurationIO10 | I/O Configuration (IO1_0)
Public property | IOConfigurationIO10AI | I/O Configuration (IO1_0) [AI]
Public property | IOConfigurationIO11 | I/O Configuration (IO1_1)
Public property | IOConfigurationIO11AI | I/O Configuration (IO1_1) [AI]
Public property | IOConfigurationIO12 | I/O Configuration (IO1_2)
Public property | IOConfigurationIO12AI | I/O Configuration (IO1_2) [AI]
Public property | IOConfigurationIO13 | I/O Configuration (IO1_3)
Public property | IOConfigurationIO13AI | I/O Configuration (IO1_3) [AI]
Public property | IOConfigurationIO14 | I/O Configuration (IO1_4)
Public property | IOConfigurationIO14AI | I/O Configuration (IO1_4) [AI]
Public property | IOConfigurationIO15 | I/O Configuration (IO1_5)
Public property | IOConfigurationIO15AI | I/O Configuration (IO1_5) [AI]
Public property | IOConfigurationIO16 | I/O Configuration (IO1_6)
Public property | IOConfigurationIO16AI | I/O Configuration (IO1_6) [AI]
Public property | IOConfigurationIO17 | I/O Configuration (IO1_7)
Public property | IOConfigurationIO17AI | I/O Configuration (IO1_7) [AI]
Public property | IOConfigurationIO20 | I/O Configuration (IO2_0)
Public property | IOConfigurationIO20AI | I/O Configuration (IO2_0) [AI]
Public property | IOConfigurationIO21 | I/O Configuration (IO2_1)
Public property | IOConfigurationIO21AI | I/O Configuration (IO2_1) [AI]
Public property | IOConfigurationIO22 | I/O Configuration (IO2_2)
Public property | IOConfigurationIO22AI | I/O Configuration (IO2_2) [AI]
Public property | IOConfigurationIO23 | I/O Configuration (IO2_3)
Public property | IOConfigurationIO23AI | I/O Configuration (IO2_3) [AI]
Public property | IOConfigurationIO24 | I/O Configuration (IO2_4)
Public property | IOConfigurationIO24AI | I/O Configuration (IO2_4) [AI]
Public property | IOConfigurationIO25 | I/O Configuration (IO2_5)
Public property | IOConfigurationIO25AI | I/O Configuration (IO2_5) [AI]
Public property | IOConfigurationIO26 | I/O Configuration (IO2_6)
Public property | IOConfigurationIO26AI | I/O Configuration (IO2_6) [AI]
Public property | IOConfigurationIO27 | I/O Configuration (IO2_7)
Public property | IOConfigurationIO27AI | I/O Configuration (IO2_7) [AI]
Public property | IOConfigurationIO30 | I/O Configuration (IO3_0)
Public property | IOConfigurationIO30AI | I/O Configuration (IO3_0) [AI]
Public property | IOConfigurationIO31 | I/O Configuration (IO3_1)
Public property | IOConfigurationIO31AI | I/O Configuration (IO3_1) [AI]
Public property | IOConfigurationIO32 | I/O Configuration (IO3_2)
Public property | IOConfigurationIO32AI | I/O Configuration (IO3_2) [AI]
Public property | IOConfigurationIO33 | I/O Configuration (IO3_3)
Public property | IOConfigurationIO33AI | I/O Configuration (IO3_3) [AI]
Public property | IOConfigurationIO34 | I/O Configuration (IO3_4)
Public property | IOConfigurationIO34AI | I/O Configuration (IO3_4) [AI]
Public property | IOConfigurationIO35 | I/O Configuration (IO3_5)
Public property | IOConfigurationIO35AI | I/O Configuration (IO3_5) [AI]
Public property | IOConfigurationIO36 | I/O Configuration (IO3_6)
Public property | IOConfigurationIO36AI | I/O Configuration (IO3_6) [AI]
Public property | IOConfigurationIO37 | I/O Configuration (IO3_7)
Public property | IOConfigurationIO37AI | I/O Configuration (IO3_7) [AI]
Public property | MaskInterruptIO00 | Mask Interrupt (IO0_0)
Public property | MaskInterruptIO00AI | Mask Interrupt (IO0_0) [AI]
Public property | MaskInterruptIO01 | Mask Interrupt (IO0_1)
Public property | MaskInterruptIO01AI | Mask Interrupt (IO0_1) [AI]
Public property | MaskInterruptIO02 | Mask Interrupt (IO0_2)
Public property | MaskInterruptIO02AI | Mask Interrupt (IO0_2) [AI]
Public property | MaskInterruptIO03 | Mask Interrupt (IO0_3)
Public property | MaskInterruptIO03AI | Mask Interrupt (IO0_3) [AI]
Public property | MaskInterruptIO04 | Mask Interrupt (IO0_4)
Public property | MaskInterruptIO04AI | Mask Interrupt (IO0_4) [AI]
Public property | MaskInterruptIO05 | Mask Interrupt (IO0_5)
Public property | MaskInterruptIO05AI | Mask Interrupt (IO0_5) [AI]
Public property | MaskInterruptIO06 | Mask Interrupt (IO0_6)
Public property | MaskInterruptIO06AI | Mask Interrupt (IO0_6) [AI]
Public property | MaskInterruptIO07 | Mask Interrupt (IO0_7)
Public property | MaskInterruptIO07AI | Mask Interrupt (IO0_7) [AI]
Public property | MaskInterruptIO10 | Mask Interrupt (IO1_0)
Public property | MaskInterruptIO10AI | Mask Interrupt (IO1_0) [AI]
Public property | MaskInterruptIO11 | Mask Interrupt (IO1_1)
Public property | MaskInterruptIO11AI | Mask Interrupt (IO1_1) [AI]
Public property | MaskInterruptIO12 | Mask Interrupt (IO1_2)
Public property | MaskInterruptIO12AI | Mask Interrupt (IO1_2) [AI]
Public property | MaskInterruptIO13 | Mask Interrupt (IO1_3)
Public property | MaskInterruptIO13AI | Mask Interrupt (IO1_3) [AI]
Public property | MaskInterruptIO14 | Mask Interrupt (IO1_4)
Public property | MaskInterruptIO14AI | Mask Interrupt (IO1_4) [AI]
Public property | MaskInterruptIO15 | Mask Interrupt (IO1_5)
Public property | MaskInterruptIO15AI | Mask Interrupt (IO1_5) [AI]
Public property | MaskInterruptIO16 | Mask Interrupt (IO1_6)
Public property | MaskInterruptIO16AI | Mask Interrupt (IO1_6) [AI]
Public property | MaskInterruptIO17 | Mask Interrupt (IO1_7)
Public property | MaskInterruptIO17AI | Mask Interrupt (IO1_7) [AI]
Public property | MaskInterruptIO20 | Mask Interrupt (IO2_0)
Public property | MaskInterruptIO20AI | Mask Interrupt (IO2_0) [AI]
Public property | MaskInterruptIO21 | Mask Interrupt (IO2_1)
Public property | MaskInterruptIO21AI | Mask Interrupt (IO2_1) [AI]
Public property | MaskInterruptIO22 | Mask Interrupt (IO2_2)
Public property | MaskInterruptIO22AI | Mask Interrupt (IO2_2) [AI]
Public property | MaskInterruptIO23 | Mask Interrupt (IO2_3)
Public property | MaskInterruptIO23AI | Mask Interrupt (IO2_3) [AI]
Public property | MaskInterruptIO24 | Mask Interrupt (IO2_4)
Public property | MaskInterruptIO24AI | Mask Interrupt (IO2_4) [AI]
Public property | MaskInterruptIO25 | Mask Interrupt (IO2_5)
Public property | MaskInterruptIO25AI | Mask Interrupt (IO2_5) [AI]
Public property | MaskInterruptIO26 | Mask Interrupt (IO2_6)
Public property | MaskInterruptIO26AI | Mask Interrupt (IO2_6) [AI]
Public property | MaskInterruptIO27 | Mask Interrupt (IO2_7)
Public property | MaskInterruptIO27AI | Mask Interrupt (IO2_7) [AI]
Public property | MaskInterruptIO30 | Mask Interrupt (IO3_0)
Public property | MaskInterruptIO30AI | Mask Interrupt (IO3_0) [AI]
Public property | MaskInterruptIO31 | Mask Interrupt (IO3_1)
Public property | MaskInterruptIO31AI | Mask Interrupt (IO3_1) [AI]
Public property | MaskInterruptIO32 | Mask Interrupt (IO3_2)
Public property | MaskInterruptIO32AI | Mask Interrupt (IO3_2) [AI]
Public property | MaskInterruptIO33 | Mask Interrupt (IO3_3)
Public property | MaskInterruptIO33AI | Mask Interrupt (IO3_3) [AI]
Public property | MaskInterruptIO34 | Mask Interrupt (IO3_4)
Public property | MaskInterruptIO34AI | Mask Interrupt (IO3_4) [AI]
Public property | MaskInterruptIO35 | Mask Interrupt (IO3_5)
Public property | MaskInterruptIO35AI | Mask Interrupt (IO3_5) [AI]
Public property | MaskInterruptIO36 | Mask Interrupt (IO3_6)
Public property | MaskInterruptIO36AI | Mask Interrupt (IO3_6) [AI]
Public property | MaskInterruptIO37 | Mask Interrupt (IO3_7)
Public property | MaskInterruptIO37AI | Mask Interrupt (IO3_7) [AI]
Public property | ModeIOAC | Mode (IOAC)
Public property | ModeIOACAI | Mode (IOAC) [AI]
Public property | ModeOCH | Mode (OCH)
Public property | ModeOCHAI | Mode (OCH) [AI]
Public property | ModeOEPOL | Mode (OEPOL)
Public property | ModeOEPOLAI | Mode (OEPOL) [AI]
Public property | ModeSMBA | Mode (SMBA)
Public property | ModeSMBAAI | Mode (SMBA) [AI]
Public property | OutputPortIO00 | Output Port (IO0_0)
Public property | OutputPortIO00AI | Output Port (IO0_0) [AI]
Public property | OutputPortIO01 | Output Port (IO0_1)
Public property | OutputPortIO01AI | Output Port (IO0_1) [AI]
Public property | OutputPortIO02 | Output Port (IO0_2)
Public property | OutputPortIO02AI | Output Port (IO0_2) [AI]
Public property | OutputPortIO03 | Output Port (IO0_3)
Public property | OutputPortIO03AI | Output Port (IO0_3) [AI]
Public property | OutputPortIO04 | Output Port (IO0_4)
Public property | OutputPortIO04AI | Output Port (IO0_4) [AI]
Public property | OutputPortIO05 | Output Port (IO0_5)
Public property | OutputPortIO05AI | Output Port (IO0_5) [AI]
Public property | OutputPortIO06 | Output Port (IO0_6)
Public property | OutputPortIO06AI | Output Port (IO0_6) [AI]
Public property | OutputPortIO07 | Output Port (IO0_7)
Public property | OutputPortIO07AI | Output Port (IO0_7) [AI]
Public property | OutputPortIO10 | Output Port (IO1_0)
Public property | OutputPortIO10AI | Output Port (IO1_0) [AI]
Public property | OutputPortIO11 | Output Port (IO1_1)
Public property | OutputPortIO11AI | Output Port (IO1_1) [AI]
Public property | OutputPortIO12 | Output Port (IO1_2)
Public property | OutputPortIO12AI | Output Port (IO1_2) [AI]
Public property | OutputPortIO13 | Output Port (IO1_3)
Public property | OutputPortIO13AI | Output Port (IO1_3) [AI]
Public property | OutputPortIO14 | Output Port (IO1_4)
Public property | OutputPortIO14AI | Output Port (IO1_4) [AI]
Public property | OutputPortIO15 | Output Port (IO1_5)
Public property | OutputPortIO15AI | Output Port (IO1_5) [AI]
Public property | OutputPortIO16 | Output Port (IO1_6)
Public property | OutputPortIO16AI | Output Port (IO1_6) [AI]
Public property | OutputPortIO17 | Output Port (IO1_7)
Public property | OutputPortIO17AI | Output Port (IO1_7) [AI]
Public property | OutputPortIO20 | Output Port (IO2_0)
Public property | OutputPortIO20AI | Output Port (IO2_0) [AI]
Public property | OutputPortIO21 | Output Port (IO2_1)
Public property | OutputPortIO21AI | Output Port (IO2_1) [AI]
Public property | OutputPortIO22 | Output Port (IO2_2)
Public property | OutputPortIO22AI | Output Port (IO2_2) [AI]
Public property | OutputPortIO23 | Output Port (IO2_3)
Public property | OutputPortIO23AI | Output Port (IO2_3) [AI]
Public property | OutputPortIO24 | Output Port (IO2_4)
Public property | OutputPortIO24AI | Output Port (IO2_4) [AI]
Public property | OutputPortIO25 | Output Port (IO2_5)
Public property | OutputPortIO25AI | Output Port (IO2_5) [AI]
Public property | OutputPortIO26 | Output Port (IO2_6)
Public property | OutputPortIO26AI | Output Port (IO2_6) [AI]
Public property | OutputPortIO27 | Output Port (IO2_7)
Public property | OutputPortIO27AI | Output Port (IO2_7) [AI]
Public property | OutputPortIO30 | Output Port (IO3_0)
Public property | OutputPortIO30AI | Output Port (IO3_0) [AI]
Public property | OutputPortIO31 | Output Port (IO3_1)
Public property | OutputPortIO31AI | Output Port (IO3_1) [AI]
Public property | OutputPortIO32 | Output Port (IO3_2)
Public property | OutputPortIO32AI | Output Port (IO3_2) [AI]
Public property | OutputPortIO33 | Output Port (IO3_3)
Public property | OutputPortIO33AI | Output Port (IO3_3) [AI]
Public property | OutputPortIO34 | Output Port (IO3_4)
Public property | OutputPortIO34AI | Output Port (IO3_4) [AI]
Public property | OutputPortIO35 | Output Port (IO3_5)
Public property | OutputPortIO35AI | Output Port (IO3_5) [AI]
Public property | OutputPortIO36 | Output Port (IO3_6)
Public property | OutputPortIO36AI | Output Port (IO3_6) [AI]
Public property | OutputPortIO37 | Output Port (IO3_7)
Public property | OutputPortIO37AI | Output Port (IO3_7) [AI]
Public property | OutputStructureConfigurationIO00IO01 | Output Structure Configuration (IO0_0 & IO0_1)
Public property | OutputStructureConfigurationIO00IO01AI | Output Structure Configuration (IO0_0 & IO0_1) [AI]
Public property | OutputStructureConfigurationIO02IO03 | Output Structure Configuration (IO0_2 & IO0_3)
Public property | OutputStructureConfigurationIO02IO03AI | Output Structure Configuration (IO0_2 & IO0_3) [AI]
Public property | OutputStructureConfigurationIO04IO05 | Output Structure Configuration (IO0_4 & IO0_5)
Public property | OutputStructureConfigurationIO04IO05AI | Output Structure Configuration (IO0_4 & IO0_5) [AI]
Public property | OutputStructureConfigurationIO06IO07 | Output Structure Configuration (IO0_6 & IO0_7)
Public property | OutputStructureConfigurationIO06IO07AI | Output Structure Configuration (IO0_6 & IO0_7) [AI]
Public property | OutputStructureConfigurationIO10IO17 | Output Structure Configuration (IO1_0 .. IO1_7)
Public property | OutputStructureConfigurationIO10IO17AI | Output Structure Configuration (IO1_0 .. IO1_7) [AI]
Public property | OutputStructureConfigurationIO20IO27 | Output Structure Configuration (IO2_0 .. IO2_7)
Public property | OutputStructureConfigurationIO20IO27AI | Output Structure Configuration (IO2_0 .. IO2_7) [AI]
Public property | OutputStructureConfigurationIO30IO37 | Output Structure Configuration (IO3_0 .. IO3_7)
Public property | OutputStructureConfigurationIO30IO37AI | Output Structure Configuration (IO3_0 .. IO3_7) [AI]
Public property | OutputStructureConfigurationIO40IO47 | Output Structure Configuration (IO4_0 .. IO4_7)
Public property | OutputStructureConfigurationIO40IO47AI | Output Structure Configuration (IO4_0 .. IO4_7) [AI]
Public property | PolarityInversionIO00 | Polarity Inversion (IO0_0)
Public property | PolarityInversionIO00AI | Polarity Inversion (IO0_0) [AI]
Public property | PolarityInversionIO01 | Polarity Inversion (IO0_1)
Public property | PolarityInversionIO01AI | Polarity Inversion (IO0_1) [AI]
Public property | PolarityInversionIO02 | Polarity Inversion (IO0_2)
Public property | PolarityInversionIO02AI | Polarity Inversion (IO0_2) [AI]
Public property | PolarityInversionIO03 | Polarity Inversion (IO0_3)
Public property | PolarityInversionIO03AI | Polarity Inversion (IO0_3) [AI]
Public property | PolarityInversionIO04 | Polarity Inversion (IO0_4)
Public property | PolarityInversionIO04AI | Polarity Inversion (IO0_4) [AI]
Public property | PolarityInversionIO05 | Polarity Inversion (IO0_5)
Public property | PolarityInversionIO05AI | Polarity Inversion (IO0_5) [AI]
Public property | PolarityInversionIO06 | Polarity Inversion (IO0_6)
Public property | PolarityInversionIO06AI | Polarity Inversion (IO0_6) [AI]
Public property | PolarityInversionIO07 | Polarity Inversion (IO0_7)
Public property | PolarityInversionIO07AI | Polarity Inversion (IO0_7) [AI]
Public property | PolarityInversionIO10 | Polarity Inversion (IO1_0)
Public property | PolarityInversionIO10AI | Polarity Inversion (IO1_0) [AI]
Public property | PolarityInversionIO11 | Polarity Inversion (IO1_1)
Public property | PolarityInversionIO11AI | Polarity Inversion (IO1_1) [AI]
Public property | PolarityInversionIO12 | Polarity Inversion (IO1_2)
Public property | PolarityInversionIO12AI | Polarity Inversion (IO1_2) [AI]
Public property | PolarityInversionIO13 | Polarity Inversion (IO1_3)
Public property | PolarityInversionIO13AI | Polarity Inversion (IO1_3) [AI]
Public property | PolarityInversionIO14 | Polarity Inversion (IO1_4)
Public property | PolarityInversionIO14AI | Polarity Inversion (IO1_4) [AI]
Public property | PolarityInversionIO15 | Polarity Inversion (IO1_5)
Public property | PolarityInversionIO15AI | Polarity Inversion (IO1_5) [AI]
Public property | PolarityInversionIO16 | Polarity Inversion (IO1_6)
Public property | PolarityInversionIO16AI | Polarity Inversion (IO1_6) [AI]
Public property | PolarityInversionIO17 | Polarity Inversion (IO1_7)
Public property | PolarityInversionIO17AI | Polarity Inversion (IO1_7) [AI]
Public property | PolarityInversionIO20 | Polarity Inversion (IO2_0)
Public property | PolarityInversionIO20AI | Polarity Inversion (IO2_0) [AI]
Public property | PolarityInversionIO21 | Polarity Inversion (IO2_1)
Public property | PolarityInversionIO21AI | Polarity Inversion (IO2_1) [AI]
Public property | PolarityInversionIO22 | Polarity Inversion (IO2_2)
Public property | PolarityInversionIO22AI | Polarity Inversion (IO2_2) [AI]
Public property | PolarityInversionIO23 | Polarity Inversion (IO2_3)
Public property | PolarityInversionIO23AI | Polarity Inversion (IO2_3) [AI]
Public property | PolarityInversionIO24 | Polarity Inversion (IO2_4)
Public property | PolarityInversionIO24AI | Polarity Inversion (IO2_4) [AI]
Public property | PolarityInversionIO25 | Polarity Inversion (IO2_5)
Public property | PolarityInversionIO25AI | Polarity Inversion (IO2_5) [AI]
Public property | PolarityInversionIO26 | Polarity Inversion (IO2_6)
Public property | PolarityInversionIO26AI | Polarity Inversion (IO2_6) [AI]
Public property | PolarityInversionIO27 | Polarity Inversion (IO2_7)
Public property | PolarityInversionIO27AI | Polarity Inversion (IO2_7) [AI]
Public property | PolarityInversionIO30 | Polarity Inversion (IO3_0)
Public property | PolarityInversionIO30AI | Polarity Inversion (IO3_0) [AI]
Public property | PolarityInversionIO31 | Polarity Inversion (IO3_1)
Public property | PolarityInversionIO31AI | Polarity Inversion (IO3_1) [AI]
Public property | PolarityInversionIO32 | Polarity Inversion (IO3_2)
Public property | PolarityInversionIO32AI | Polarity Inversion (IO3_2) [AI]
Public property | PolarityInversionIO33 | Polarity Inversion (IO3_3)
Public property | PolarityInversionIO33AI | Polarity Inversion (IO3_3) [AI]
Public property | PolarityInversionIO34 | Polarity Inversion (IO3_4)
Public property | PolarityInversionIO34AI | Polarity Inversion (IO3_4) [AI]
Public property | PolarityInversionIO35 | Polarity Inversion (IO3_5)
Public property | PolarityInversionIO35AI | Polarity Inversion (IO3_5) [AI]
Public property | PolarityInversionIO36 | Polarity Inversion (IO3_6)
Public property | PolarityInversionIO36AI | Polarity Inversion (IO3_6) [AI]
Public property | PolarityInversionIO37 | Polarity Inversion (IO3_7)
Public property | PolarityInversionIO37AI | Polarity Inversion (IO3_7) [AI]
Top
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.AutoFlush Property

IRD

Pca9698AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ControlAllBanksBank0 Property

IRD

Pca9698ControlAllBanksBank0 Property

Control All Banks (Bank 0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ControlAllBanksBank0 { get; set; }
Public Property ControlAllBanksBank0 As Byte
    Get
    Set
public:
property unsigned char ControlAllBanksBank0 {
    unsigned char get ();
    void set (unsigned char value);
}
member ControlAllBanksBank0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ControlAllBanksBank0AI Property

IRD

Pca9698ControlAllBanksBank0AI Property

Control All Banks (Bank 0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ControlAllBanksBank0AI { get; set; }
Public Property ControlAllBanksBank0AI As Byte
    Get
    Set
public:
property unsigned char ControlAllBanksBank0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member ControlAllBanksBank0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ControlAllBanksBank1 Property

IRD

Pca9698ControlAllBanksBank1 Property

Control All Banks (Bank 1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ControlAllBanksBank1 { get; set; }
Public Property ControlAllBanksBank1 As Byte
    Get
    Set
public:
property unsigned char ControlAllBanksBank1 {
    unsigned char get ();
    void set (unsigned char value);
}
member ControlAllBanksBank1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ControlAllBanksBank1AI Property

IRD

Pca9698ControlAllBanksBank1AI Property

Control All Banks (Bank 1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ControlAllBanksBank1AI { get; set; }
Public Property ControlAllBanksBank1AI As Byte
    Get
    Set
public:
property unsigned char ControlAllBanksBank1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member ControlAllBanksBank1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ControlAllBanksBank2 Property

IRD

Pca9698ControlAllBanksBank2 Property

Control All Banks (Bank 2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ControlAllBanksBank2 { get; set; }
Public Property ControlAllBanksBank2 As Byte
    Get
    Set
public:
property unsigned char ControlAllBanksBank2 {
    unsigned char get ();
    void set (unsigned char value);
}
member ControlAllBanksBank2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ControlAllBanksBank2AI Property

IRD

Pca9698ControlAllBanksBank2AI Property

Control All Banks (Bank 2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ControlAllBanksBank2AI { get; set; }
Public Property ControlAllBanksBank2AI As Byte
    Get
    Set
public:
property unsigned char ControlAllBanksBank2AI {
    unsigned char get ();
    void set (unsigned char value);
}
member ControlAllBanksBank2AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ControlAllBanksBank3 Property

IRD

Pca9698ControlAllBanksBank3 Property

Control All Banks (Bank 3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ControlAllBanksBank3 { get; set; }
Public Property ControlAllBanksBank3 As Byte
    Get
    Set
public:
property unsigned char ControlAllBanksBank3 {
    unsigned char get ();
    void set (unsigned char value);
}
member ControlAllBanksBank3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ControlAllBanksBank3AI Property

IRD

Pca9698ControlAllBanksBank3AI Property

Control All Banks (Bank 3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ControlAllBanksBank3AI { get; set; }
Public Property ControlAllBanksBank3AI As Byte
    Get
    Set
public:
property unsigned char ControlAllBanksBank3AI {
    unsigned char get ();
    void set (unsigned char value);
}
member ControlAllBanksBank3AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ControlAllBanksBank4 Property

IRD

Pca9698ControlAllBanksBank4 Property

Control All Banks (Bank 4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ControlAllBanksBank4 { get; set; }
Public Property ControlAllBanksBank4 As Byte
    Get
    Set
public:
property unsigned char ControlAllBanksBank4 {
    unsigned char get ();
    void set (unsigned char value);
}
member ControlAllBanksBank4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ControlAllBanksBank4AI Property

IRD

Pca9698ControlAllBanksBank4AI Property

Control All Banks (Bank 4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ControlAllBanksBank4AI { get; set; }
Public Property ControlAllBanksBank4AI As Byte
    Get
    Set
public:
property unsigned char ControlAllBanksBank4AI {
    unsigned char get ();
    void set (unsigned char value);
}
member ControlAllBanksBank4AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ControlAllBanksBSEL Property

IRD

Pca9698ControlAllBanksBSEL Property

Control All Banks (BSEL)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ControlAllBanksBSEL { get; set; }
Public Property ControlAllBanksBSEL As Byte
    Get
    Set
public:
property unsigned char ControlAllBanksBSEL {
    unsigned char get ();
    void set (unsigned char value);
}
member ControlAllBanksBSEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ControlAllBanksBSELAI Property

IRD

Pca9698ControlAllBanksBSELAI Property

Control All Banks (BSEL) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ControlAllBanksBSELAI { get; set; }
Public Property ControlAllBanksBSELAI As Byte
    Get
    Set
public:
property unsigned char ControlAllBanksBSELAI {
    unsigned char get ();
    void set (unsigned char value);
}
member ControlAllBanksBSELAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO00 Property

IRD

Pca9698InputPortIO00 Property

Input Port (IO0_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO00 { get; }
Public ReadOnly Property InputPortIO00 As Byte
    Get
public:
property unsigned char InputPortIO00 {
    unsigned char get ();
}
member InputPortIO00 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO00AI Property

IRD

Pca9698InputPortIO00AI Property

Input Port (IO0_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO00AI { get; }
Public ReadOnly Property InputPortIO00AI As Byte
    Get
public:
property unsigned char InputPortIO00AI {
    unsigned char get ();
}
member InputPortIO00AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO01 Property

IRD

Pca9698InputPortIO01 Property

Input Port (IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO01 { get; }
Public ReadOnly Property InputPortIO01 As Byte
    Get
public:
property unsigned char InputPortIO01 {
    unsigned char get ();
}
member InputPortIO01 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO01AI Property

IRD

Pca9698InputPortIO01AI Property

Input Port (IO0_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO01AI { get; }
Public ReadOnly Property InputPortIO01AI As Byte
    Get
public:
property unsigned char InputPortIO01AI {
    unsigned char get ();
}
member InputPortIO01AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO02 Property

IRD

Pca9698InputPortIO02 Property

Input Port (IO0_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO02 { get; }
Public ReadOnly Property InputPortIO02 As Byte
    Get
public:
property unsigned char InputPortIO02 {
    unsigned char get ();
}
member InputPortIO02 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO02AI Property

IRD

Pca9698InputPortIO02AI Property

Input Port (IO0_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO02AI { get; }
Public ReadOnly Property InputPortIO02AI As Byte
    Get
public:
property unsigned char InputPortIO02AI {
    unsigned char get ();
}
member InputPortIO02AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO03 Property

IRD

Pca9698InputPortIO03 Property

Input Port (IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO03 { get; }
Public ReadOnly Property InputPortIO03 As Byte
    Get
public:
property unsigned char InputPortIO03 {
    unsigned char get ();
}
member InputPortIO03 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO03AI Property

IRD

Pca9698InputPortIO03AI Property

Input Port (IO0_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO03AI { get; }
Public ReadOnly Property InputPortIO03AI As Byte
    Get
public:
property unsigned char InputPortIO03AI {
    unsigned char get ();
}
member InputPortIO03AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO04 Property

IRD

Pca9698InputPortIO04 Property

Input Port (IO0_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO04 { get; }
Public ReadOnly Property InputPortIO04 As Byte
    Get
public:
property unsigned char InputPortIO04 {
    unsigned char get ();
}
member InputPortIO04 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO04AI Property

IRD

Pca9698InputPortIO04AI Property

Input Port (IO0_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO04AI { get; }
Public ReadOnly Property InputPortIO04AI As Byte
    Get
public:
property unsigned char InputPortIO04AI {
    unsigned char get ();
}
member InputPortIO04AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO05 Property

IRD

Pca9698InputPortIO05 Property

Input Port (IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO05 { get; }
Public ReadOnly Property InputPortIO05 As Byte
    Get
public:
property unsigned char InputPortIO05 {
    unsigned char get ();
}
member InputPortIO05 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO05AI Property

IRD

Pca9698InputPortIO05AI Property

Input Port (IO0_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO05AI { get; }
Public ReadOnly Property InputPortIO05AI As Byte
    Get
public:
property unsigned char InputPortIO05AI {
    unsigned char get ();
}
member InputPortIO05AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO06 Property

IRD

Pca9698InputPortIO06 Property

Input Port (IO0_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO06 { get; }
Public ReadOnly Property InputPortIO06 As Byte
    Get
public:
property unsigned char InputPortIO06 {
    unsigned char get ();
}
member InputPortIO06 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO06AI Property

IRD

Pca9698InputPortIO06AI Property

Input Port (IO0_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO06AI { get; }
Public ReadOnly Property InputPortIO06AI As Byte
    Get
public:
property unsigned char InputPortIO06AI {
    unsigned char get ();
}
member InputPortIO06AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO07 Property

IRD

Pca9698InputPortIO07 Property

Input Port (IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO07 { get; }
Public ReadOnly Property InputPortIO07 As Byte
    Get
public:
property unsigned char InputPortIO07 {
    unsigned char get ();
}
member InputPortIO07 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO07AI Property

IRD

Pca9698InputPortIO07AI Property

Input Port (IO0_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO07AI { get; }
Public ReadOnly Property InputPortIO07AI As Byte
    Get
public:
property unsigned char InputPortIO07AI {
    unsigned char get ();
}
member InputPortIO07AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO10 Property

IRD

Pca9698InputPortIO10 Property

Input Port (IO1_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO10 { get; }
Public ReadOnly Property InputPortIO10 As Byte
    Get
public:
property unsigned char InputPortIO10 {
    unsigned char get ();
}
member InputPortIO10 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO10AI Property

IRD

Pca9698InputPortIO10AI Property

Input Port (IO1_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO10AI { get; }
Public ReadOnly Property InputPortIO10AI As Byte
    Get
public:
property unsigned char InputPortIO10AI {
    unsigned char get ();
}
member InputPortIO10AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO11 Property

IRD

Pca9698InputPortIO11 Property

Input Port (IO1_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO11 { get; }
Public ReadOnly Property InputPortIO11 As Byte
    Get
public:
property unsigned char InputPortIO11 {
    unsigned char get ();
}
member InputPortIO11 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO11AI Property

IRD

Pca9698InputPortIO11AI Property

Input Port (IO1_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO11AI { get; }
Public ReadOnly Property InputPortIO11AI As Byte
    Get
public:
property unsigned char InputPortIO11AI {
    unsigned char get ();
}
member InputPortIO11AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO12 Property

IRD

Pca9698InputPortIO12 Property

Input Port (IO1_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO12 { get; }
Public ReadOnly Property InputPortIO12 As Byte
    Get
public:
property unsigned char InputPortIO12 {
    unsigned char get ();
}
member InputPortIO12 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO12AI Property

IRD

Pca9698InputPortIO12AI Property

Input Port (IO1_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO12AI { get; }
Public ReadOnly Property InputPortIO12AI As Byte
    Get
public:
property unsigned char InputPortIO12AI {
    unsigned char get ();
}
member InputPortIO12AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO13 Property

IRD

Pca9698InputPortIO13 Property

Input Port (IO1_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO13 { get; }
Public ReadOnly Property InputPortIO13 As Byte
    Get
public:
property unsigned char InputPortIO13 {
    unsigned char get ();
}
member InputPortIO13 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO13AI Property

IRD

Pca9698InputPortIO13AI Property

Input Port (IO1_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO13AI { get; }
Public ReadOnly Property InputPortIO13AI As Byte
    Get
public:
property unsigned char InputPortIO13AI {
    unsigned char get ();
}
member InputPortIO13AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO14 Property

IRD

Pca9698InputPortIO14 Property

Input Port (IO1_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO14 { get; }
Public ReadOnly Property InputPortIO14 As Byte
    Get
public:
property unsigned char InputPortIO14 {
    unsigned char get ();
}
member InputPortIO14 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO14AI Property

IRD

Pca9698InputPortIO14AI Property

Input Port (IO1_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO14AI { get; }
Public ReadOnly Property InputPortIO14AI As Byte
    Get
public:
property unsigned char InputPortIO14AI {
    unsigned char get ();
}
member InputPortIO14AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO15 Property

IRD

Pca9698InputPortIO15 Property

Input Port (IO1_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO15 { get; }
Public ReadOnly Property InputPortIO15 As Byte
    Get
public:
property unsigned char InputPortIO15 {
    unsigned char get ();
}
member InputPortIO15 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO15AI Property

IRD

Pca9698InputPortIO15AI Property

Input Port (IO1_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO15AI { get; }
Public ReadOnly Property InputPortIO15AI As Byte
    Get
public:
property unsigned char InputPortIO15AI {
    unsigned char get ();
}
member InputPortIO15AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO16 Property

IRD

Pca9698InputPortIO16 Property

Input Port (IO1_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO16 { get; }
Public ReadOnly Property InputPortIO16 As Byte
    Get
public:
property unsigned char InputPortIO16 {
    unsigned char get ();
}
member InputPortIO16 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO16AI Property

IRD

Pca9698InputPortIO16AI Property

Input Port (IO1_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO16AI { get; }
Public ReadOnly Property InputPortIO16AI As Byte
    Get
public:
property unsigned char InputPortIO16AI {
    unsigned char get ();
}
member InputPortIO16AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO17 Property

IRD

Pca9698InputPortIO17 Property

Input Port (IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO17 { get; }
Public ReadOnly Property InputPortIO17 As Byte
    Get
public:
property unsigned char InputPortIO17 {
    unsigned char get ();
}
member InputPortIO17 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO17AI Property

IRD

Pca9698InputPortIO17AI Property

Input Port (IO1_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO17AI { get; }
Public ReadOnly Property InputPortIO17AI As Byte
    Get
public:
property unsigned char InputPortIO17AI {
    unsigned char get ();
}
member InputPortIO17AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO20 Property

IRD

Pca9698InputPortIO20 Property

Input Port (IO2_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO20 { get; }
Public ReadOnly Property InputPortIO20 As Byte
    Get
public:
property unsigned char InputPortIO20 {
    unsigned char get ();
}
member InputPortIO20 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO20AI Property

IRD

Pca9698InputPortIO20AI Property

Input Port (IO2_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO20AI { get; }
Public ReadOnly Property InputPortIO20AI As Byte
    Get
public:
property unsigned char InputPortIO20AI {
    unsigned char get ();
}
member InputPortIO20AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO21 Property

IRD

Pca9698InputPortIO21 Property

Input Port (IO2_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO21 { get; }
Public ReadOnly Property InputPortIO21 As Byte
    Get
public:
property unsigned char InputPortIO21 {
    unsigned char get ();
}
member InputPortIO21 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO21AI Property

IRD

Pca9698InputPortIO21AI Property

Input Port (IO2_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO21AI { get; }
Public ReadOnly Property InputPortIO21AI As Byte
    Get
public:
property unsigned char InputPortIO21AI {
    unsigned char get ();
}
member InputPortIO21AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO22 Property

IRD

Pca9698InputPortIO22 Property

Input Port (IO2_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO22 { get; }
Public ReadOnly Property InputPortIO22 As Byte
    Get
public:
property unsigned char InputPortIO22 {
    unsigned char get ();
}
member InputPortIO22 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO22AI Property

IRD

Pca9698InputPortIO22AI Property

Input Port (IO2_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO22AI { get; }
Public ReadOnly Property InputPortIO22AI As Byte
    Get
public:
property unsigned char InputPortIO22AI {
    unsigned char get ();
}
member InputPortIO22AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO23 Property

IRD

Pca9698InputPortIO23 Property

Input Port (IO2_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO23 { get; }
Public ReadOnly Property InputPortIO23 As Byte
    Get
public:
property unsigned char InputPortIO23 {
    unsigned char get ();
}
member InputPortIO23 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO23AI Property

IRD

Pca9698InputPortIO23AI Property

Input Port (IO2_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO23AI { get; }
Public ReadOnly Property InputPortIO23AI As Byte
    Get
public:
property unsigned char InputPortIO23AI {
    unsigned char get ();
}
member InputPortIO23AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO24 Property

IRD

Pca9698InputPortIO24 Property

Input Port (IO2_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO24 { get; }
Public ReadOnly Property InputPortIO24 As Byte
    Get
public:
property unsigned char InputPortIO24 {
    unsigned char get ();
}
member InputPortIO24 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO24AI Property

IRD

Pca9698InputPortIO24AI Property

Input Port (IO2_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO24AI { get; }
Public ReadOnly Property InputPortIO24AI As Byte
    Get
public:
property unsigned char InputPortIO24AI {
    unsigned char get ();
}
member InputPortIO24AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO25 Property

IRD

Pca9698InputPortIO25 Property

Input Port (IO2_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO25 { get; }
Public ReadOnly Property InputPortIO25 As Byte
    Get
public:
property unsigned char InputPortIO25 {
    unsigned char get ();
}
member InputPortIO25 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO25AI Property

IRD

Pca9698InputPortIO25AI Property

Input Port (IO2_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO25AI { get; }
Public ReadOnly Property InputPortIO25AI As Byte
    Get
public:
property unsigned char InputPortIO25AI {
    unsigned char get ();
}
member InputPortIO25AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO26 Property

IRD

Pca9698InputPortIO26 Property

Input Port (IO2_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO26 { get; }
Public ReadOnly Property InputPortIO26 As Byte
    Get
public:
property unsigned char InputPortIO26 {
    unsigned char get ();
}
member InputPortIO26 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO26AI Property

IRD

Pca9698InputPortIO26AI Property

Input Port (IO2_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO26AI { get; }
Public ReadOnly Property InputPortIO26AI As Byte
    Get
public:
property unsigned char InputPortIO26AI {
    unsigned char get ();
}
member InputPortIO26AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO27 Property

IRD

Pca9698InputPortIO27 Property

Input Port (IO2_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO27 { get; }
Public ReadOnly Property InputPortIO27 As Byte
    Get
public:
property unsigned char InputPortIO27 {
    unsigned char get ();
}
member InputPortIO27 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO27AI Property

IRD

Pca9698InputPortIO27AI Property

Input Port (IO2_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO27AI { get; }
Public ReadOnly Property InputPortIO27AI As Byte
    Get
public:
property unsigned char InputPortIO27AI {
    unsigned char get ();
}
member InputPortIO27AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO30 Property

IRD

Pca9698InputPortIO30 Property

Input Port (IO3_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO30 { get; }
Public ReadOnly Property InputPortIO30 As Byte
    Get
public:
property unsigned char InputPortIO30 {
    unsigned char get ();
}
member InputPortIO30 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO30AI Property

IRD

Pca9698InputPortIO30AI Property

Input Port (IO3_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO30AI { get; }
Public ReadOnly Property InputPortIO30AI As Byte
    Get
public:
property unsigned char InputPortIO30AI {
    unsigned char get ();
}
member InputPortIO30AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO31 Property

IRD

Pca9698InputPortIO31 Property

Input Port (IO3_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO31 { get; }
Public ReadOnly Property InputPortIO31 As Byte
    Get
public:
property unsigned char InputPortIO31 {
    unsigned char get ();
}
member InputPortIO31 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO31AI Property

IRD

Pca9698InputPortIO31AI Property

Input Port (IO3_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO31AI { get; }
Public ReadOnly Property InputPortIO31AI As Byte
    Get
public:
property unsigned char InputPortIO31AI {
    unsigned char get ();
}
member InputPortIO31AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO32 Property

IRD

Pca9698InputPortIO32 Property

Input Port (IO3_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO32 { get; }
Public ReadOnly Property InputPortIO32 As Byte
    Get
public:
property unsigned char InputPortIO32 {
    unsigned char get ();
}
member InputPortIO32 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO32AI Property

IRD

Pca9698InputPortIO32AI Property

Input Port (IO3_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO32AI { get; }
Public ReadOnly Property InputPortIO32AI As Byte
    Get
public:
property unsigned char InputPortIO32AI {
    unsigned char get ();
}
member InputPortIO32AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO33 Property

IRD

Pca9698InputPortIO33 Property

Input Port (IO3_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO33 { get; }
Public ReadOnly Property InputPortIO33 As Byte
    Get
public:
property unsigned char InputPortIO33 {
    unsigned char get ();
}
member InputPortIO33 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO33AI Property

IRD

Pca9698InputPortIO33AI Property

Input Port (IO3_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO33AI { get; }
Public ReadOnly Property InputPortIO33AI As Byte
    Get
public:
property unsigned char InputPortIO33AI {
    unsigned char get ();
}
member InputPortIO33AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO34 Property

IRD

Pca9698InputPortIO34 Property

Input Port (IO3_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO34 { get; }
Public ReadOnly Property InputPortIO34 As Byte
    Get
public:
property unsigned char InputPortIO34 {
    unsigned char get ();
}
member InputPortIO34 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO34AI Property

IRD

Pca9698InputPortIO34AI Property

Input Port (IO3_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO34AI { get; }
Public ReadOnly Property InputPortIO34AI As Byte
    Get
public:
property unsigned char InputPortIO34AI {
    unsigned char get ();
}
member InputPortIO34AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO35 Property

IRD

Pca9698InputPortIO35 Property

Input Port (IO3_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO35 { get; }
Public ReadOnly Property InputPortIO35 As Byte
    Get
public:
property unsigned char InputPortIO35 {
    unsigned char get ();
}
member InputPortIO35 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO35AI Property

IRD

Pca9698InputPortIO35AI Property

Input Port (IO3_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO35AI { get; }
Public ReadOnly Property InputPortIO35AI As Byte
    Get
public:
property unsigned char InputPortIO35AI {
    unsigned char get ();
}
member InputPortIO35AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO36 Property

IRD

Pca9698InputPortIO36 Property

Input Port (IO3_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO36 { get; }
Public ReadOnly Property InputPortIO36 As Byte
    Get
public:
property unsigned char InputPortIO36 {
    unsigned char get ();
}
member InputPortIO36 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO36AI Property

IRD

Pca9698InputPortIO36AI Property

Input Port (IO3_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO36AI { get; }
Public ReadOnly Property InputPortIO36AI As Byte
    Get
public:
property unsigned char InputPortIO36AI {
    unsigned char get ();
}
member InputPortIO36AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO37 Property

IRD

Pca9698InputPortIO37 Property

Input Port (IO3_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO37 { get; }
Public ReadOnly Property InputPortIO37 As Byte
    Get
public:
property unsigned char InputPortIO37 {
    unsigned char get ();
}
member InputPortIO37 : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.InputPortIO37AI Property

IRD

Pca9698InputPortIO37AI Property

Input Port (IO3_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortIO37AI { get; }
Public ReadOnly Property InputPortIO37AI As Byte
    Get
public:
property unsigned char InputPortIO37AI {
    unsigned char get ();
}
member InputPortIO37AI : byte with get

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO00 Property

IRD

Pca9698IOConfigurationIO00 Property

I/O Configuration (IO0_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO00 { get; set; }
Public Property IOConfigurationIO00 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO00 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO00 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO00AI Property

IRD

Pca9698IOConfigurationIO00AI Property

I/O Configuration (IO0_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO00AI { get; set; }
Public Property IOConfigurationIO00AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO00AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO00AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO01 Property

IRD

Pca9698IOConfigurationIO01 Property

I/O Configuration (IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO01 { get; set; }
Public Property IOConfigurationIO01 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO01 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO01 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO01AI Property

IRD

Pca9698IOConfigurationIO01AI Property

I/O Configuration (IO0_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO01AI { get; set; }
Public Property IOConfigurationIO01AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO01AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO01AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO02 Property

IRD

Pca9698IOConfigurationIO02 Property

I/O Configuration (IO0_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO02 { get; set; }
Public Property IOConfigurationIO02 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO02 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO02 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO02AI Property

IRD

Pca9698IOConfigurationIO02AI Property

I/O Configuration (IO0_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO02AI { get; set; }
Public Property IOConfigurationIO02AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO02AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO02AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO03 Property

IRD

Pca9698IOConfigurationIO03 Property

I/O Configuration (IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO03 { get; set; }
Public Property IOConfigurationIO03 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO03 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO03 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO03AI Property

IRD

Pca9698IOConfigurationIO03AI Property

I/O Configuration (IO0_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO03AI { get; set; }
Public Property IOConfigurationIO03AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO03AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO03AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO04 Property

IRD

Pca9698IOConfigurationIO04 Property

I/O Configuration (IO0_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO04 { get; set; }
Public Property IOConfigurationIO04 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO04 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO04 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO04AI Property

IRD

Pca9698IOConfigurationIO04AI Property

I/O Configuration (IO0_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO04AI { get; set; }
Public Property IOConfigurationIO04AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO04AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO04AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO05 Property

IRD

Pca9698IOConfigurationIO05 Property

I/O Configuration (IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO05 { get; set; }
Public Property IOConfigurationIO05 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO05 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO05 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO05AI Property

IRD

Pca9698IOConfigurationIO05AI Property

I/O Configuration (IO0_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO05AI { get; set; }
Public Property IOConfigurationIO05AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO05AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO05AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO06 Property

IRD

Pca9698IOConfigurationIO06 Property

I/O Configuration (IO0_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO06 { get; set; }
Public Property IOConfigurationIO06 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO06 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO06 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO06AI Property

IRD

Pca9698IOConfigurationIO06AI Property

I/O Configuration (IO0_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO06AI { get; set; }
Public Property IOConfigurationIO06AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO06AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO06AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO07 Property

IRD

Pca9698IOConfigurationIO07 Property

I/O Configuration (IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO07 { get; set; }
Public Property IOConfigurationIO07 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO07 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO07 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO07AI Property

IRD

Pca9698IOConfigurationIO07AI Property

I/O Configuration (IO0_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO07AI { get; set; }
Public Property IOConfigurationIO07AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO07AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO07AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO10 Property

IRD

Pca9698IOConfigurationIO10 Property

I/O Configuration (IO1_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO10 { get; set; }
Public Property IOConfigurationIO10 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO10 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO10 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO10AI Property

IRD

Pca9698IOConfigurationIO10AI Property

I/O Configuration (IO1_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO10AI { get; set; }
Public Property IOConfigurationIO10AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO10AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO10AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO11 Property

IRD

Pca9698IOConfigurationIO11 Property

I/O Configuration (IO1_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO11 { get; set; }
Public Property IOConfigurationIO11 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO11 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO11 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO11AI Property

IRD

Pca9698IOConfigurationIO11AI Property

I/O Configuration (IO1_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO11AI { get; set; }
Public Property IOConfigurationIO11AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO11AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO11AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO12 Property

IRD

Pca9698IOConfigurationIO12 Property

I/O Configuration (IO1_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO12 { get; set; }
Public Property IOConfigurationIO12 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO12 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO12 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO12AI Property

IRD

Pca9698IOConfigurationIO12AI Property

I/O Configuration (IO1_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO12AI { get; set; }
Public Property IOConfigurationIO12AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO12AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO12AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO13 Property

IRD

Pca9698IOConfigurationIO13 Property

I/O Configuration (IO1_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO13 { get; set; }
Public Property IOConfigurationIO13 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO13 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO13 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO13AI Property

IRD

Pca9698IOConfigurationIO13AI Property

I/O Configuration (IO1_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO13AI { get; set; }
Public Property IOConfigurationIO13AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO13AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO13AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO14 Property

IRD

Pca9698IOConfigurationIO14 Property

I/O Configuration (IO1_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO14 { get; set; }
Public Property IOConfigurationIO14 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO14 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO14 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO14AI Property

IRD

Pca9698IOConfigurationIO14AI Property

I/O Configuration (IO1_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO14AI { get; set; }
Public Property IOConfigurationIO14AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO14AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO14AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO15 Property

IRD

Pca9698IOConfigurationIO15 Property

I/O Configuration (IO1_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO15 { get; set; }
Public Property IOConfigurationIO15 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO15 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO15 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO15AI Property

IRD

Pca9698IOConfigurationIO15AI Property

I/O Configuration (IO1_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO15AI { get; set; }
Public Property IOConfigurationIO15AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO15AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO15AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO16 Property

IRD

Pca9698IOConfigurationIO16 Property

I/O Configuration (IO1_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO16 { get; set; }
Public Property IOConfigurationIO16 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO16 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO16 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO16AI Property

IRD

Pca9698IOConfigurationIO16AI Property

I/O Configuration (IO1_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO16AI { get; set; }
Public Property IOConfigurationIO16AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO16AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO16AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO17 Property

IRD

Pca9698IOConfigurationIO17 Property

I/O Configuration (IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO17 { get; set; }
Public Property IOConfigurationIO17 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO17 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO17 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO17AI Property

IRD

Pca9698IOConfigurationIO17AI Property

I/O Configuration (IO1_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO17AI { get; set; }
Public Property IOConfigurationIO17AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO17AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO17AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO20 Property

IRD

Pca9698IOConfigurationIO20 Property

I/O Configuration (IO2_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO20 { get; set; }
Public Property IOConfigurationIO20 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO20 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO20 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO20AI Property

IRD

Pca9698IOConfigurationIO20AI Property

I/O Configuration (IO2_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO20AI { get; set; }
Public Property IOConfigurationIO20AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO20AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO20AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO21 Property

IRD

Pca9698IOConfigurationIO21 Property

I/O Configuration (IO2_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO21 { get; set; }
Public Property IOConfigurationIO21 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO21 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO21 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO21AI Property

IRD

Pca9698IOConfigurationIO21AI Property

I/O Configuration (IO2_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO21AI { get; set; }
Public Property IOConfigurationIO21AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO21AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO21AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO22 Property

IRD

Pca9698IOConfigurationIO22 Property

I/O Configuration (IO2_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO22 { get; set; }
Public Property IOConfigurationIO22 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO22 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO22 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO22AI Property

IRD

Pca9698IOConfigurationIO22AI Property

I/O Configuration (IO2_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO22AI { get; set; }
Public Property IOConfigurationIO22AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO22AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO22AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO23 Property

IRD

Pca9698IOConfigurationIO23 Property

I/O Configuration (IO2_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO23 { get; set; }
Public Property IOConfigurationIO23 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO23 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO23 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO23AI Property

IRD

Pca9698IOConfigurationIO23AI Property

I/O Configuration (IO2_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO23AI { get; set; }
Public Property IOConfigurationIO23AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO23AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO23AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO24 Property

IRD

Pca9698IOConfigurationIO24 Property

I/O Configuration (IO2_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO24 { get; set; }
Public Property IOConfigurationIO24 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO24 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO24 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO24AI Property

IRD

Pca9698IOConfigurationIO24AI Property

I/O Configuration (IO2_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO24AI { get; set; }
Public Property IOConfigurationIO24AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO24AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO24AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO25 Property

IRD

Pca9698IOConfigurationIO25 Property

I/O Configuration (IO2_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO25 { get; set; }
Public Property IOConfigurationIO25 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO25 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO25 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO25AI Property

IRD

Pca9698IOConfigurationIO25AI Property

I/O Configuration (IO2_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO25AI { get; set; }
Public Property IOConfigurationIO25AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO25AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO25AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO26 Property

IRD

Pca9698IOConfigurationIO26 Property

I/O Configuration (IO2_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO26 { get; set; }
Public Property IOConfigurationIO26 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO26 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO26 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO26AI Property

IRD

Pca9698IOConfigurationIO26AI Property

I/O Configuration (IO2_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO26AI { get; set; }
Public Property IOConfigurationIO26AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO26AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO26AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO27 Property

IRD

Pca9698IOConfigurationIO27 Property

I/O Configuration (IO2_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO27 { get; set; }
Public Property IOConfigurationIO27 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO27 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO27 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO27AI Property

IRD

Pca9698IOConfigurationIO27AI Property

I/O Configuration (IO2_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO27AI { get; set; }
Public Property IOConfigurationIO27AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO27AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO27AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO30 Property

IRD

Pca9698IOConfigurationIO30 Property

I/O Configuration (IO3_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO30 { get; set; }
Public Property IOConfigurationIO30 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO30 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO30 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO30AI Property

IRD

Pca9698IOConfigurationIO30AI Property

I/O Configuration (IO3_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO30AI { get; set; }
Public Property IOConfigurationIO30AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO30AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO30AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO31 Property

IRD

Pca9698IOConfigurationIO31 Property

I/O Configuration (IO3_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO31 { get; set; }
Public Property IOConfigurationIO31 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO31 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO31 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO31AI Property

IRD

Pca9698IOConfigurationIO31AI Property

I/O Configuration (IO3_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO31AI { get; set; }
Public Property IOConfigurationIO31AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO31AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO31AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO32 Property

IRD

Pca9698IOConfigurationIO32 Property

I/O Configuration (IO3_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO32 { get; set; }
Public Property IOConfigurationIO32 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO32 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO32 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO32AI Property

IRD

Pca9698IOConfigurationIO32AI Property

I/O Configuration (IO3_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO32AI { get; set; }
Public Property IOConfigurationIO32AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO32AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO32AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO33 Property

IRD

Pca9698IOConfigurationIO33 Property

I/O Configuration (IO3_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO33 { get; set; }
Public Property IOConfigurationIO33 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO33 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO33 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO33AI Property

IRD

Pca9698IOConfigurationIO33AI Property

I/O Configuration (IO3_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO33AI { get; set; }
Public Property IOConfigurationIO33AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO33AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO33AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO34 Property

IRD

Pca9698IOConfigurationIO34 Property

I/O Configuration (IO3_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO34 { get; set; }
Public Property IOConfigurationIO34 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO34 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO34 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO34AI Property

IRD

Pca9698IOConfigurationIO34AI Property

I/O Configuration (IO3_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO34AI { get; set; }
Public Property IOConfigurationIO34AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO34AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO34AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO35 Property

IRD

Pca9698IOConfigurationIO35 Property

I/O Configuration (IO3_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO35 { get; set; }
Public Property IOConfigurationIO35 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO35 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO35 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO35AI Property

IRD

Pca9698IOConfigurationIO35AI Property

I/O Configuration (IO3_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO35AI { get; set; }
Public Property IOConfigurationIO35AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO35AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO35AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO36 Property

IRD

Pca9698IOConfigurationIO36 Property

I/O Configuration (IO3_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO36 { get; set; }
Public Property IOConfigurationIO36 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO36 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO36 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO36AI Property

IRD

Pca9698IOConfigurationIO36AI Property

I/O Configuration (IO3_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO36AI { get; set; }
Public Property IOConfigurationIO36AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO36AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO36AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO37 Property

IRD

Pca9698IOConfigurationIO37 Property

I/O Configuration (IO3_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO37 { get; set; }
Public Property IOConfigurationIO37 As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO37 {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO37 : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.IOConfigurationIO37AI Property

IRD

Pca9698IOConfigurationIO37AI Property

I/O Configuration (IO3_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeIoc IOConfigurationIO37AI { get; set; }
Public Property IOConfigurationIO37AI As Pca9698TypeIoc
    Get
    Set
public:
property Pca9698TypeIoc IOConfigurationIO37AI {
    Pca9698TypeIoc get ();
    void set (Pca9698TypeIoc value);
}
member IOConfigurationIO37AI : Pca9698TypeIoc with get, set

Property Value

Type: Pca9698TypeIoc
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO00 Property

IRD

Pca9698MaskInterruptIO00 Property

Mask Interrupt (IO0_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO00 { get; set; }
Public Property MaskInterruptIO00 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO00 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO00 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO00AI Property

IRD

Pca9698MaskInterruptIO00AI Property

Mask Interrupt (IO0_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO00AI { get; set; }
Public Property MaskInterruptIO00AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO00AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO00AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO01 Property

IRD

Pca9698MaskInterruptIO01 Property

Mask Interrupt (IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO01 { get; set; }
Public Property MaskInterruptIO01 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO01 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO01 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO01AI Property

IRD

Pca9698MaskInterruptIO01AI Property

Mask Interrupt (IO0_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO01AI { get; set; }
Public Property MaskInterruptIO01AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO01AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO01AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO02 Property

IRD

Pca9698MaskInterruptIO02 Property

Mask Interrupt (IO0_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO02 { get; set; }
Public Property MaskInterruptIO02 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO02 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO02 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO02AI Property

IRD

Pca9698MaskInterruptIO02AI Property

Mask Interrupt (IO0_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO02AI { get; set; }
Public Property MaskInterruptIO02AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO02AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO02AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO03 Property

IRD

Pca9698MaskInterruptIO03 Property

Mask Interrupt (IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO03 { get; set; }
Public Property MaskInterruptIO03 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO03 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO03 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO03AI Property

IRD

Pca9698MaskInterruptIO03AI Property

Mask Interrupt (IO0_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO03AI { get; set; }
Public Property MaskInterruptIO03AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO03AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO03AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO04 Property

IRD

Pca9698MaskInterruptIO04 Property

Mask Interrupt (IO0_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO04 { get; set; }
Public Property MaskInterruptIO04 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO04 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO04 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO04AI Property

IRD

Pca9698MaskInterruptIO04AI Property

Mask Interrupt (IO0_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO04AI { get; set; }
Public Property MaskInterruptIO04AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO04AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO04AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO05 Property

IRD

Pca9698MaskInterruptIO05 Property

Mask Interrupt (IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO05 { get; set; }
Public Property MaskInterruptIO05 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO05 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO05 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO05AI Property

IRD

Pca9698MaskInterruptIO05AI Property

Mask Interrupt (IO0_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO05AI { get; set; }
Public Property MaskInterruptIO05AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO05AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO05AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO06 Property

IRD

Pca9698MaskInterruptIO06 Property

Mask Interrupt (IO0_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO06 { get; set; }
Public Property MaskInterruptIO06 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO06 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO06 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO06AI Property

IRD

Pca9698MaskInterruptIO06AI Property

Mask Interrupt (IO0_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO06AI { get; set; }
Public Property MaskInterruptIO06AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO06AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO06AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO07 Property

IRD

Pca9698MaskInterruptIO07 Property

Mask Interrupt (IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO07 { get; set; }
Public Property MaskInterruptIO07 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO07 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO07 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO07AI Property

IRD

Pca9698MaskInterruptIO07AI Property

Mask Interrupt (IO0_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO07AI { get; set; }
Public Property MaskInterruptIO07AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO07AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO07AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO10 Property

IRD

Pca9698MaskInterruptIO10 Property

Mask Interrupt (IO1_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO10 { get; set; }
Public Property MaskInterruptIO10 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO10 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO10 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO10AI Property

IRD

Pca9698MaskInterruptIO10AI Property

Mask Interrupt (IO1_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO10AI { get; set; }
Public Property MaskInterruptIO10AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO10AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO10AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO11 Property

IRD

Pca9698MaskInterruptIO11 Property

Mask Interrupt (IO1_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO11 { get; set; }
Public Property MaskInterruptIO11 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO11 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO11 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO11AI Property

IRD

Pca9698MaskInterruptIO11AI Property

Mask Interrupt (IO1_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO11AI { get; set; }
Public Property MaskInterruptIO11AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO11AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO11AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO12 Property

IRD

Pca9698MaskInterruptIO12 Property

Mask Interrupt (IO1_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO12 { get; set; }
Public Property MaskInterruptIO12 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO12 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO12 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO12AI Property

IRD

Pca9698MaskInterruptIO12AI Property

Mask Interrupt (IO1_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO12AI { get; set; }
Public Property MaskInterruptIO12AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO12AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO12AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO13 Property

IRD

Pca9698MaskInterruptIO13 Property

Mask Interrupt (IO1_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO13 { get; set; }
Public Property MaskInterruptIO13 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO13 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO13 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO13AI Property

IRD

Pca9698MaskInterruptIO13AI Property

Mask Interrupt (IO1_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO13AI { get; set; }
Public Property MaskInterruptIO13AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO13AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO13AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO14 Property

IRD

Pca9698MaskInterruptIO14 Property

Mask Interrupt (IO1_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO14 { get; set; }
Public Property MaskInterruptIO14 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO14 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO14 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO14AI Property

IRD

Pca9698MaskInterruptIO14AI Property

Mask Interrupt (IO1_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO14AI { get; set; }
Public Property MaskInterruptIO14AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO14AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO14AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO15 Property

IRD

Pca9698MaskInterruptIO15 Property

Mask Interrupt (IO1_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO15 { get; set; }
Public Property MaskInterruptIO15 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO15 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO15 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO15AI Property

IRD

Pca9698MaskInterruptIO15AI Property

Mask Interrupt (IO1_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO15AI { get; set; }
Public Property MaskInterruptIO15AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO15AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO15AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO16 Property

IRD

Pca9698MaskInterruptIO16 Property

Mask Interrupt (IO1_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO16 { get; set; }
Public Property MaskInterruptIO16 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO16 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO16 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO16AI Property

IRD

Pca9698MaskInterruptIO16AI Property

Mask Interrupt (IO1_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO16AI { get; set; }
Public Property MaskInterruptIO16AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO16AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO16AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO17 Property

IRD

Pca9698MaskInterruptIO17 Property

Mask Interrupt (IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO17 { get; set; }
Public Property MaskInterruptIO17 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO17 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO17 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO17AI Property

IRD

Pca9698MaskInterruptIO17AI Property

Mask Interrupt (IO1_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO17AI { get; set; }
Public Property MaskInterruptIO17AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO17AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO17AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO20 Property

IRD

Pca9698MaskInterruptIO20 Property

Mask Interrupt (IO2_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO20 { get; set; }
Public Property MaskInterruptIO20 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO20 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO20 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO20AI Property

IRD

Pca9698MaskInterruptIO20AI Property

Mask Interrupt (IO2_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO20AI { get; set; }
Public Property MaskInterruptIO20AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO20AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO20AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO21 Property

IRD

Pca9698MaskInterruptIO21 Property

Mask Interrupt (IO2_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO21 { get; set; }
Public Property MaskInterruptIO21 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO21 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO21 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO21AI Property

IRD

Pca9698MaskInterruptIO21AI Property

Mask Interrupt (IO2_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO21AI { get; set; }
Public Property MaskInterruptIO21AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO21AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO21AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO22 Property

IRD

Pca9698MaskInterruptIO22 Property

Mask Interrupt (IO2_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO22 { get; set; }
Public Property MaskInterruptIO22 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO22 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO22 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO22AI Property

IRD

Pca9698MaskInterruptIO22AI Property

Mask Interrupt (IO2_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO22AI { get; set; }
Public Property MaskInterruptIO22AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO22AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO22AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO23 Property

IRD

Pca9698MaskInterruptIO23 Property

Mask Interrupt (IO2_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO23 { get; set; }
Public Property MaskInterruptIO23 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO23 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO23 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO23AI Property

IRD

Pca9698MaskInterruptIO23AI Property

Mask Interrupt (IO2_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO23AI { get; set; }
Public Property MaskInterruptIO23AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO23AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO23AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO24 Property

IRD

Pca9698MaskInterruptIO24 Property

Mask Interrupt (IO2_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO24 { get; set; }
Public Property MaskInterruptIO24 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO24 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO24 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO24AI Property

IRD

Pca9698MaskInterruptIO24AI Property

Mask Interrupt (IO2_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO24AI { get; set; }
Public Property MaskInterruptIO24AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO24AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO24AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO25 Property

IRD

Pca9698MaskInterruptIO25 Property

Mask Interrupt (IO2_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO25 { get; set; }
Public Property MaskInterruptIO25 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO25 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO25 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO25AI Property

IRD

Pca9698MaskInterruptIO25AI Property

Mask Interrupt (IO2_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO25AI { get; set; }
Public Property MaskInterruptIO25AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO25AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO25AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO26 Property

IRD

Pca9698MaskInterruptIO26 Property

Mask Interrupt (IO2_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO26 { get; set; }
Public Property MaskInterruptIO26 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO26 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO26 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO26AI Property

IRD

Pca9698MaskInterruptIO26AI Property

Mask Interrupt (IO2_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO26AI { get; set; }
Public Property MaskInterruptIO26AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO26AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO26AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO27 Property

IRD

Pca9698MaskInterruptIO27 Property

Mask Interrupt (IO2_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO27 { get; set; }
Public Property MaskInterruptIO27 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO27 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO27 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO27AI Property

IRD

Pca9698MaskInterruptIO27AI Property

Mask Interrupt (IO2_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO27AI { get; set; }
Public Property MaskInterruptIO27AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO27AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO27AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO30 Property

IRD

Pca9698MaskInterruptIO30 Property

Mask Interrupt (IO3_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO30 { get; set; }
Public Property MaskInterruptIO30 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO30 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO30 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO30AI Property

IRD

Pca9698MaskInterruptIO30AI Property

Mask Interrupt (IO3_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO30AI { get; set; }
Public Property MaskInterruptIO30AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO30AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO30AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO31 Property

IRD

Pca9698MaskInterruptIO31 Property

Mask Interrupt (IO3_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO31 { get; set; }
Public Property MaskInterruptIO31 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO31 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO31 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO31AI Property

IRD

Pca9698MaskInterruptIO31AI Property

Mask Interrupt (IO3_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO31AI { get; set; }
Public Property MaskInterruptIO31AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO31AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO31AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO32 Property

IRD

Pca9698MaskInterruptIO32 Property

Mask Interrupt (IO3_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO32 { get; set; }
Public Property MaskInterruptIO32 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO32 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO32 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO32AI Property

IRD

Pca9698MaskInterruptIO32AI Property

Mask Interrupt (IO3_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO32AI { get; set; }
Public Property MaskInterruptIO32AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO32AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO32AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO33 Property

IRD

Pca9698MaskInterruptIO33 Property

Mask Interrupt (IO3_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO33 { get; set; }
Public Property MaskInterruptIO33 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO33 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO33 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO33AI Property

IRD

Pca9698MaskInterruptIO33AI Property

Mask Interrupt (IO3_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO33AI { get; set; }
Public Property MaskInterruptIO33AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO33AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO33AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO34 Property

IRD

Pca9698MaskInterruptIO34 Property

Mask Interrupt (IO3_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO34 { get; set; }
Public Property MaskInterruptIO34 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO34 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO34 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO34AI Property

IRD

Pca9698MaskInterruptIO34AI Property

Mask Interrupt (IO3_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO34AI { get; set; }
Public Property MaskInterruptIO34AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO34AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO34AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO35 Property

IRD

Pca9698MaskInterruptIO35 Property

Mask Interrupt (IO3_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO35 { get; set; }
Public Property MaskInterruptIO35 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO35 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO35 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO35AI Property

IRD

Pca9698MaskInterruptIO35AI Property

Mask Interrupt (IO3_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO35AI { get; set; }
Public Property MaskInterruptIO35AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO35AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO35AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO36 Property

IRD

Pca9698MaskInterruptIO36 Property

Mask Interrupt (IO3_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO36 { get; set; }
Public Property MaskInterruptIO36 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO36 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO36 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO36AI Property

IRD

Pca9698MaskInterruptIO36AI Property

Mask Interrupt (IO3_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO36AI { get; set; }
Public Property MaskInterruptIO36AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO36AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO36AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO37 Property

IRD

Pca9698MaskInterruptIO37 Property

Mask Interrupt (IO3_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO37 { get; set; }
Public Property MaskInterruptIO37 As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO37 {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO37 : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.MaskInterruptIO37AI Property

IRD

Pca9698MaskInterruptIO37AI Property

Mask Interrupt (IO3_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeMsk MaskInterruptIO37AI { get; set; }
Public Property MaskInterruptIO37AI As Pca9698TypeMsk
    Get
    Set
public:
property Pca9698TypeMsk MaskInterruptIO37AI {
    Pca9698TypeMsk get ();
    void set (Pca9698TypeMsk value);
}
member MaskInterruptIO37AI : Pca9698TypeMsk with get, set

Property Value

Type: Pca9698TypeMsk
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ModeIOAC Property

IRD

Pca9698ModeIOAC Property

Mode (IOAC)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeModeIoac ModeIOAC { get; set; }
Public Property ModeIOAC As Pca9698TypeModeIoac
    Get
    Set
public:
property Pca9698TypeModeIoac ModeIOAC {
    Pca9698TypeModeIoac get ();
    void set (Pca9698TypeModeIoac value);
}
member ModeIOAC : Pca9698TypeModeIoac with get, set

Property Value

Type: Pca9698TypeModeIoac
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ModeIOACAI Property

IRD

Pca9698ModeIOACAI Property

Mode (IOAC) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeModeIoac ModeIOACAI { get; set; }
Public Property ModeIOACAI As Pca9698TypeModeIoac
    Get
    Set
public:
property Pca9698TypeModeIoac ModeIOACAI {
    Pca9698TypeModeIoac get ();
    void set (Pca9698TypeModeIoac value);
}
member ModeIOACAI : Pca9698TypeModeIoac with get, set

Property Value

Type: Pca9698TypeModeIoac
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ModeOCH Property

IRD

Pca9698ModeOCH Property

Mode (OCH)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeModeOch ModeOCH { get; set; }
Public Property ModeOCH As Pca9698TypeModeOch
    Get
    Set
public:
property Pca9698TypeModeOch ModeOCH {
    Pca9698TypeModeOch get ();
    void set (Pca9698TypeModeOch value);
}
member ModeOCH : Pca9698TypeModeOch with get, set

Property Value

Type: Pca9698TypeModeOch
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ModeOCHAI Property

IRD

Pca9698ModeOCHAI Property

Mode (OCH) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeModeOch ModeOCHAI { get; set; }
Public Property ModeOCHAI As Pca9698TypeModeOch
    Get
    Set
public:
property Pca9698TypeModeOch ModeOCHAI {
    Pca9698TypeModeOch get ();
    void set (Pca9698TypeModeOch value);
}
member ModeOCHAI : Pca9698TypeModeOch with get, set

Property Value

Type: Pca9698TypeModeOch
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ModeOEPOL Property

IRD

Pca9698ModeOEPOL Property

Mode (OEPOL)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeModeOepol ModeOEPOL { get; set; }
Public Property ModeOEPOL As Pca9698TypeModeOepol
    Get
    Set
public:
property Pca9698TypeModeOepol ModeOEPOL {
    Pca9698TypeModeOepol get ();
    void set (Pca9698TypeModeOepol value);
}
member ModeOEPOL : Pca9698TypeModeOepol with get, set

Property Value

Type: Pca9698TypeModeOepol
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ModeOEPOLAI Property

IRD

Pca9698ModeOEPOLAI Property

Mode (OEPOL) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeModeOepol ModeOEPOLAI { get; set; }
Public Property ModeOEPOLAI As Pca9698TypeModeOepol
    Get
    Set
public:
property Pca9698TypeModeOepol ModeOEPOLAI {
    Pca9698TypeModeOepol get ();
    void set (Pca9698TypeModeOepol value);
}
member ModeOEPOLAI : Pca9698TypeModeOepol with get, set

Property Value

Type: Pca9698TypeModeOepol
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ModeSMBA Property

IRD

Pca9698ModeSMBA Property

Mode (SMBA)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeModeSmba ModeSMBA { get; set; }
Public Property ModeSMBA As Pca9698TypeModeSmba
    Get
    Set
public:
property Pca9698TypeModeSmba ModeSMBA {
    Pca9698TypeModeSmba get ();
    void set (Pca9698TypeModeSmba value);
}
member ModeSMBA : Pca9698TypeModeSmba with get, set

Property Value

Type: Pca9698TypeModeSmba
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.ModeSMBAAI Property

IRD

Pca9698ModeSMBAAI Property

Mode (SMBA) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeModeSmba ModeSMBAAI { get; set; }
Public Property ModeSMBAAI As Pca9698TypeModeSmba
    Get
    Set
public:
property Pca9698TypeModeSmba ModeSMBAAI {
    Pca9698TypeModeSmba get ();
    void set (Pca9698TypeModeSmba value);
}
member ModeSMBAAI : Pca9698TypeModeSmba with get, set

Property Value

Type: Pca9698TypeModeSmba
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO00 Property

IRD

Pca9698OutputPortIO00 Property

Output Port (IO0_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO00 { get; set; }
Public Property OutputPortIO00 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO00 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO00 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO00AI Property

IRD

Pca9698OutputPortIO00AI Property

Output Port (IO0_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO00AI { get; set; }
Public Property OutputPortIO00AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO00AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO00AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO01 Property

IRD

Pca9698OutputPortIO01 Property

Output Port (IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO01 { get; set; }
Public Property OutputPortIO01 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO01 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO01 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO01AI Property

IRD

Pca9698OutputPortIO01AI Property

Output Port (IO0_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO01AI { get; set; }
Public Property OutputPortIO01AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO01AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO01AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO02 Property

IRD

Pca9698OutputPortIO02 Property

Output Port (IO0_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO02 { get; set; }
Public Property OutputPortIO02 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO02 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO02 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO02AI Property

IRD

Pca9698OutputPortIO02AI Property

Output Port (IO0_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO02AI { get; set; }
Public Property OutputPortIO02AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO02AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO02AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO03 Property

IRD

Pca9698OutputPortIO03 Property

Output Port (IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO03 { get; set; }
Public Property OutputPortIO03 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO03 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO03 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO03AI Property

IRD

Pca9698OutputPortIO03AI Property

Output Port (IO0_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO03AI { get; set; }
Public Property OutputPortIO03AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO03AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO03AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO04 Property

IRD

Pca9698OutputPortIO04 Property

Output Port (IO0_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO04 { get; set; }
Public Property OutputPortIO04 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO04 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO04 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO04AI Property

IRD

Pca9698OutputPortIO04AI Property

Output Port (IO0_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO04AI { get; set; }
Public Property OutputPortIO04AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO04AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO04AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO05 Property

IRD

Pca9698OutputPortIO05 Property

Output Port (IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO05 { get; set; }
Public Property OutputPortIO05 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO05 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO05 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO05AI Property

IRD

Pca9698OutputPortIO05AI Property

Output Port (IO0_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO05AI { get; set; }
Public Property OutputPortIO05AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO05AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO05AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO06 Property

IRD

Pca9698OutputPortIO06 Property

Output Port (IO0_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO06 { get; set; }
Public Property OutputPortIO06 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO06 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO06 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO06AI Property

IRD

Pca9698OutputPortIO06AI Property

Output Port (IO0_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO06AI { get; set; }
Public Property OutputPortIO06AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO06AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO06AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO07 Property

IRD

Pca9698OutputPortIO07 Property

Output Port (IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO07 { get; set; }
Public Property OutputPortIO07 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO07 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO07 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO07AI Property

IRD

Pca9698OutputPortIO07AI Property

Output Port (IO0_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO07AI { get; set; }
Public Property OutputPortIO07AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO07AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO07AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO10 Property

IRD

Pca9698OutputPortIO10 Property

Output Port (IO1_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO10 { get; set; }
Public Property OutputPortIO10 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO10 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO10 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO10AI Property

IRD

Pca9698OutputPortIO10AI Property

Output Port (IO1_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO10AI { get; set; }
Public Property OutputPortIO10AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO10AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO10AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO11 Property

IRD

Pca9698OutputPortIO11 Property

Output Port (IO1_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO11 { get; set; }
Public Property OutputPortIO11 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO11 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO11 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO11AI Property

IRD

Pca9698OutputPortIO11AI Property

Output Port (IO1_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO11AI { get; set; }
Public Property OutputPortIO11AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO11AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO11AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO12 Property

IRD

Pca9698OutputPortIO12 Property

Output Port (IO1_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO12 { get; set; }
Public Property OutputPortIO12 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO12 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO12 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO12AI Property

IRD

Pca9698OutputPortIO12AI Property

Output Port (IO1_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO12AI { get; set; }
Public Property OutputPortIO12AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO12AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO12AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO13 Property

IRD

Pca9698OutputPortIO13 Property

Output Port (IO1_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO13 { get; set; }
Public Property OutputPortIO13 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO13 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO13 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO13AI Property

IRD

Pca9698OutputPortIO13AI Property

Output Port (IO1_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO13AI { get; set; }
Public Property OutputPortIO13AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO13AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO13AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO14 Property

IRD

Pca9698OutputPortIO14 Property

Output Port (IO1_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO14 { get; set; }
Public Property OutputPortIO14 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO14 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO14 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO14AI Property

IRD

Pca9698OutputPortIO14AI Property

Output Port (IO1_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO14AI { get; set; }
Public Property OutputPortIO14AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO14AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO14AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO15 Property

IRD

Pca9698OutputPortIO15 Property

Output Port (IO1_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO15 { get; set; }
Public Property OutputPortIO15 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO15 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO15 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO15AI Property

IRD

Pca9698OutputPortIO15AI Property

Output Port (IO1_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO15AI { get; set; }
Public Property OutputPortIO15AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO15AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO15AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO16 Property

IRD

Pca9698OutputPortIO16 Property

Output Port (IO1_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO16 { get; set; }
Public Property OutputPortIO16 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO16 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO16 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO16AI Property

IRD

Pca9698OutputPortIO16AI Property

Output Port (IO1_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO16AI { get; set; }
Public Property OutputPortIO16AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO16AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO16AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO17 Property

IRD

Pca9698OutputPortIO17 Property

Output Port (IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO17 { get; set; }
Public Property OutputPortIO17 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO17 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO17 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO17AI Property

IRD

Pca9698OutputPortIO17AI Property

Output Port (IO1_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO17AI { get; set; }
Public Property OutputPortIO17AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO17AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO17AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO20 Property

IRD

Pca9698OutputPortIO20 Property

Output Port (IO2_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO20 { get; set; }
Public Property OutputPortIO20 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO20 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO20 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO20AI Property

IRD

Pca9698OutputPortIO20AI Property

Output Port (IO2_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO20AI { get; set; }
Public Property OutputPortIO20AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO20AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO20AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO21 Property

IRD

Pca9698OutputPortIO21 Property

Output Port (IO2_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO21 { get; set; }
Public Property OutputPortIO21 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO21 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO21 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO21AI Property

IRD

Pca9698OutputPortIO21AI Property

Output Port (IO2_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO21AI { get; set; }
Public Property OutputPortIO21AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO21AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO21AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO22 Property

IRD

Pca9698OutputPortIO22 Property

Output Port (IO2_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO22 { get; set; }
Public Property OutputPortIO22 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO22 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO22 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO22AI Property

IRD

Pca9698OutputPortIO22AI Property

Output Port (IO2_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO22AI { get; set; }
Public Property OutputPortIO22AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO22AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO22AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO23 Property

IRD

Pca9698OutputPortIO23 Property

Output Port (IO2_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO23 { get; set; }
Public Property OutputPortIO23 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO23 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO23 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO23AI Property

IRD

Pca9698OutputPortIO23AI Property

Output Port (IO2_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO23AI { get; set; }
Public Property OutputPortIO23AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO23AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO23AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO24 Property

IRD

Pca9698OutputPortIO24 Property

Output Port (IO2_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO24 { get; set; }
Public Property OutputPortIO24 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO24 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO24 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO24AI Property

IRD

Pca9698OutputPortIO24AI Property

Output Port (IO2_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO24AI { get; set; }
Public Property OutputPortIO24AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO24AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO24AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO25 Property

IRD

Pca9698OutputPortIO25 Property

Output Port (IO2_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO25 { get; set; }
Public Property OutputPortIO25 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO25 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO25 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO25AI Property

IRD

Pca9698OutputPortIO25AI Property

Output Port (IO2_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO25AI { get; set; }
Public Property OutputPortIO25AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO25AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO25AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO26 Property

IRD

Pca9698OutputPortIO26 Property

Output Port (IO2_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO26 { get; set; }
Public Property OutputPortIO26 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO26 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO26 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO26AI Property

IRD

Pca9698OutputPortIO26AI Property

Output Port (IO2_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO26AI { get; set; }
Public Property OutputPortIO26AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO26AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO26AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO27 Property

IRD

Pca9698OutputPortIO27 Property

Output Port (IO2_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO27 { get; set; }
Public Property OutputPortIO27 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO27 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO27 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO27AI Property

IRD

Pca9698OutputPortIO27AI Property

Output Port (IO2_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO27AI { get; set; }
Public Property OutputPortIO27AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO27AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO27AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO30 Property

IRD

Pca9698OutputPortIO30 Property

Output Port (IO3_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO30 { get; set; }
Public Property OutputPortIO30 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO30 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO30 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO30AI Property

IRD

Pca9698OutputPortIO30AI Property

Output Port (IO3_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO30AI { get; set; }
Public Property OutputPortIO30AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO30AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO30AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO31 Property

IRD

Pca9698OutputPortIO31 Property

Output Port (IO3_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO31 { get; set; }
Public Property OutputPortIO31 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO31 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO31 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO31AI Property

IRD

Pca9698OutputPortIO31AI Property

Output Port (IO3_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO31AI { get; set; }
Public Property OutputPortIO31AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO31AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO31AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO32 Property

IRD

Pca9698OutputPortIO32 Property

Output Port (IO3_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO32 { get; set; }
Public Property OutputPortIO32 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO32 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO32 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO32AI Property

IRD

Pca9698OutputPortIO32AI Property

Output Port (IO3_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO32AI { get; set; }
Public Property OutputPortIO32AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO32AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO32AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO33 Property

IRD

Pca9698OutputPortIO33 Property

Output Port (IO3_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO33 { get; set; }
Public Property OutputPortIO33 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO33 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO33 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO33AI Property

IRD

Pca9698OutputPortIO33AI Property

Output Port (IO3_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO33AI { get; set; }
Public Property OutputPortIO33AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO33AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO33AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO34 Property

IRD

Pca9698OutputPortIO34 Property

Output Port (IO3_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO34 { get; set; }
Public Property OutputPortIO34 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO34 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO34 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO34AI Property

IRD

Pca9698OutputPortIO34AI Property

Output Port (IO3_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO34AI { get; set; }
Public Property OutputPortIO34AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO34AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO34AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO35 Property

IRD

Pca9698OutputPortIO35 Property

Output Port (IO3_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO35 { get; set; }
Public Property OutputPortIO35 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO35 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO35 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO35AI Property

IRD

Pca9698OutputPortIO35AI Property

Output Port (IO3_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO35AI { get; set; }
Public Property OutputPortIO35AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO35AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO35AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO36 Property

IRD

Pca9698OutputPortIO36 Property

Output Port (IO3_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO36 { get; set; }
Public Property OutputPortIO36 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO36 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO36 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO36AI Property

IRD

Pca9698OutputPortIO36AI Property

Output Port (IO3_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO36AI { get; set; }
Public Property OutputPortIO36AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO36AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO36AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO37 Property

IRD

Pca9698OutputPortIO37 Property

Output Port (IO3_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO37 { get; set; }
Public Property OutputPortIO37 As Byte
    Get
    Set
public:
property unsigned char OutputPortIO37 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO37 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputPortIO37AI Property

IRD

Pca9698OutputPortIO37AI Property

Output Port (IO3_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortIO37AI { get; set; }
Public Property OutputPortIO37AI As Byte
    Get
    Set
public:
property unsigned char OutputPortIO37AI {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortIO37AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputStructureConfigurationIO00IO01 Property

IRD

Pca9698OutputStructureConfigurationIO00IO01 Property

Output Structure Configuration (IO0_0 & IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeOutconf OutputStructureConfigurationIO00IO01 { get; set; }
Public Property OutputStructureConfigurationIO00IO01 As Pca9698TypeOutconf
    Get
    Set
public:
property Pca9698TypeOutconf OutputStructureConfigurationIO00IO01 {
    Pca9698TypeOutconf get ();
    void set (Pca9698TypeOutconf value);
}
member OutputStructureConfigurationIO00IO01 : Pca9698TypeOutconf with get, set

Property Value

Type: Pca9698TypeOutconf
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputStructureConfigurationIO00IO01AI Property

IRD

Pca9698OutputStructureConfigurationIO00IO01AI Property

Output Structure Configuration (IO0_0 & IO0_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeOutconf OutputStructureConfigurationIO00IO01AI { get; set; }
Public Property OutputStructureConfigurationIO00IO01AI As Pca9698TypeOutconf
    Get
    Set
public:
property Pca9698TypeOutconf OutputStructureConfigurationIO00IO01AI {
    Pca9698TypeOutconf get ();
    void set (Pca9698TypeOutconf value);
}
member OutputStructureConfigurationIO00IO01AI : Pca9698TypeOutconf with get, set

Property Value

Type: Pca9698TypeOutconf
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputStructureConfigurationIO02IO03 Property

IRD

Pca9698OutputStructureConfigurationIO02IO03 Property

Output Structure Configuration (IO0_2 & IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeOutconf OutputStructureConfigurationIO02IO03 { get; set; }
Public Property OutputStructureConfigurationIO02IO03 As Pca9698TypeOutconf
    Get
    Set
public:
property Pca9698TypeOutconf OutputStructureConfigurationIO02IO03 {
    Pca9698TypeOutconf get ();
    void set (Pca9698TypeOutconf value);
}
member OutputStructureConfigurationIO02IO03 : Pca9698TypeOutconf with get, set

Property Value

Type: Pca9698TypeOutconf
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputStructureConfigurationIO02IO03AI Property

IRD

Pca9698OutputStructureConfigurationIO02IO03AI Property

Output Structure Configuration (IO0_2 & IO0_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeOutconf OutputStructureConfigurationIO02IO03AI { get; set; }
Public Property OutputStructureConfigurationIO02IO03AI As Pca9698TypeOutconf
    Get
    Set
public:
property Pca9698TypeOutconf OutputStructureConfigurationIO02IO03AI {
    Pca9698TypeOutconf get ();
    void set (Pca9698TypeOutconf value);
}
member OutputStructureConfigurationIO02IO03AI : Pca9698TypeOutconf with get, set

Property Value

Type: Pca9698TypeOutconf
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputStructureConfigurationIO04IO05 Property

IRD

Pca9698OutputStructureConfigurationIO04IO05 Property

Output Structure Configuration (IO0_4 & IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeOutconf OutputStructureConfigurationIO04IO05 { get; set; }
Public Property OutputStructureConfigurationIO04IO05 As Pca9698TypeOutconf
    Get
    Set
public:
property Pca9698TypeOutconf OutputStructureConfigurationIO04IO05 {
    Pca9698TypeOutconf get ();
    void set (Pca9698TypeOutconf value);
}
member OutputStructureConfigurationIO04IO05 : Pca9698TypeOutconf with get, set

Property Value

Type: Pca9698TypeOutconf
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputStructureConfigurationIO04IO05AI Property

IRD

Pca9698OutputStructureConfigurationIO04IO05AI Property

Output Structure Configuration (IO0_4 & IO0_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeOutconf OutputStructureConfigurationIO04IO05AI { get; set; }
Public Property OutputStructureConfigurationIO04IO05AI As Pca9698TypeOutconf
    Get
    Set
public:
property Pca9698TypeOutconf OutputStructureConfigurationIO04IO05AI {
    Pca9698TypeOutconf get ();
    void set (Pca9698TypeOutconf value);
}
member OutputStructureConfigurationIO04IO05AI : Pca9698TypeOutconf with get, set

Property Value

Type: Pca9698TypeOutconf
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputStructureConfigurationIO06IO07 Property

IRD

Pca9698OutputStructureConfigurationIO06IO07 Property

Output Structure Configuration (IO0_6 & IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeOutconf OutputStructureConfigurationIO06IO07 { get; set; }
Public Property OutputStructureConfigurationIO06IO07 As Pca9698TypeOutconf
    Get
    Set
public:
property Pca9698TypeOutconf OutputStructureConfigurationIO06IO07 {
    Pca9698TypeOutconf get ();
    void set (Pca9698TypeOutconf value);
}
member OutputStructureConfigurationIO06IO07 : Pca9698TypeOutconf with get, set

Property Value

Type: Pca9698TypeOutconf
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputStructureConfigurationIO06IO07AI Property

IRD

Pca9698OutputStructureConfigurationIO06IO07AI Property

Output Structure Configuration (IO0_6 & IO0_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeOutconf OutputStructureConfigurationIO06IO07AI { get; set; }
Public Property OutputStructureConfigurationIO06IO07AI As Pca9698TypeOutconf
    Get
    Set
public:
property Pca9698TypeOutconf OutputStructureConfigurationIO06IO07AI {
    Pca9698TypeOutconf get ();
    void set (Pca9698TypeOutconf value);
}
member OutputStructureConfigurationIO06IO07AI : Pca9698TypeOutconf with get, set

Property Value

Type: Pca9698TypeOutconf
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputStructureConfigurationIO10IO17 Property

IRD

Pca9698OutputStructureConfigurationIO10IO17 Property

Output Structure Configuration (IO1_0 .. IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeOutconf OutputStructureConfigurationIO10IO17 { get; set; }
Public Property OutputStructureConfigurationIO10IO17 As Pca9698TypeOutconf
    Get
    Set
public:
property Pca9698TypeOutconf OutputStructureConfigurationIO10IO17 {
    Pca9698TypeOutconf get ();
    void set (Pca9698TypeOutconf value);
}
member OutputStructureConfigurationIO10IO17 : Pca9698TypeOutconf with get, set

Property Value

Type: Pca9698TypeOutconf
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputStructureConfigurationIO10IO17AI Property

IRD

Pca9698OutputStructureConfigurationIO10IO17AI Property

Output Structure Configuration (IO1_0 .. IO1_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeOutconf OutputStructureConfigurationIO10IO17AI { get; set; }
Public Property OutputStructureConfigurationIO10IO17AI As Pca9698TypeOutconf
    Get
    Set
public:
property Pca9698TypeOutconf OutputStructureConfigurationIO10IO17AI {
    Pca9698TypeOutconf get ();
    void set (Pca9698TypeOutconf value);
}
member OutputStructureConfigurationIO10IO17AI : Pca9698TypeOutconf with get, set

Property Value

Type: Pca9698TypeOutconf
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputStructureConfigurationIO20IO27 Property

IRD

Pca9698OutputStructureConfigurationIO20IO27 Property

Output Structure Configuration (IO2_0 .. IO2_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeOutconf OutputStructureConfigurationIO20IO27 { get; set; }
Public Property OutputStructureConfigurationIO20IO27 As Pca9698TypeOutconf
    Get
    Set
public:
property Pca9698TypeOutconf OutputStructureConfigurationIO20IO27 {
    Pca9698TypeOutconf get ();
    void set (Pca9698TypeOutconf value);
}
member OutputStructureConfigurationIO20IO27 : Pca9698TypeOutconf with get, set

Property Value

Type: Pca9698TypeOutconf
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputStructureConfigurationIO20IO27AI Property

IRD

Pca9698OutputStructureConfigurationIO20IO27AI Property

Output Structure Configuration (IO2_0 .. IO2_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeOutconf OutputStructureConfigurationIO20IO27AI { get; set; }
Public Property OutputStructureConfigurationIO20IO27AI As Pca9698TypeOutconf
    Get
    Set
public:
property Pca9698TypeOutconf OutputStructureConfigurationIO20IO27AI {
    Pca9698TypeOutconf get ();
    void set (Pca9698TypeOutconf value);
}
member OutputStructureConfigurationIO20IO27AI : Pca9698TypeOutconf with get, set

Property Value

Type: Pca9698TypeOutconf
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputStructureConfigurationIO30IO37 Property

IRD

Pca9698OutputStructureConfigurationIO30IO37 Property

Output Structure Configuration (IO3_0 .. IO3_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeOutconf OutputStructureConfigurationIO30IO37 { get; set; }
Public Property OutputStructureConfigurationIO30IO37 As Pca9698TypeOutconf
    Get
    Set
public:
property Pca9698TypeOutconf OutputStructureConfigurationIO30IO37 {
    Pca9698TypeOutconf get ();
    void set (Pca9698TypeOutconf value);
}
member OutputStructureConfigurationIO30IO37 : Pca9698TypeOutconf with get, set

Property Value

Type: Pca9698TypeOutconf
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputStructureConfigurationIO30IO37AI Property

IRD

Pca9698OutputStructureConfigurationIO30IO37AI Property

Output Structure Configuration (IO3_0 .. IO3_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeOutconf OutputStructureConfigurationIO30IO37AI { get; set; }
Public Property OutputStructureConfigurationIO30IO37AI As Pca9698TypeOutconf
    Get
    Set
public:
property Pca9698TypeOutconf OutputStructureConfigurationIO30IO37AI {
    Pca9698TypeOutconf get ();
    void set (Pca9698TypeOutconf value);
}
member OutputStructureConfigurationIO30IO37AI : Pca9698TypeOutconf with get, set

Property Value

Type: Pca9698TypeOutconf
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputStructureConfigurationIO40IO47 Property

IRD

Pca9698OutputStructureConfigurationIO40IO47 Property

Output Structure Configuration (IO4_0 .. IO4_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeOutconf OutputStructureConfigurationIO40IO47 { get; set; }
Public Property OutputStructureConfigurationIO40IO47 As Pca9698TypeOutconf
    Get
    Set
public:
property Pca9698TypeOutconf OutputStructureConfigurationIO40IO47 {
    Pca9698TypeOutconf get ();
    void set (Pca9698TypeOutconf value);
}
member OutputStructureConfigurationIO40IO47 : Pca9698TypeOutconf with get, set

Property Value

Type: Pca9698TypeOutconf
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.OutputStructureConfigurationIO40IO47AI Property

IRD

Pca9698OutputStructureConfigurationIO40IO47AI Property

Output Structure Configuration (IO4_0 .. IO4_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypeOutconf OutputStructureConfigurationIO40IO47AI { get; set; }
Public Property OutputStructureConfigurationIO40IO47AI As Pca9698TypeOutconf
    Get
    Set
public:
property Pca9698TypeOutconf OutputStructureConfigurationIO40IO47AI {
    Pca9698TypeOutconf get ();
    void set (Pca9698TypeOutconf value);
}
member OutputStructureConfigurationIO40IO47AI : Pca9698TypeOutconf with get, set

Property Value

Type: Pca9698TypeOutconf
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO00 Property

IRD

Pca9698PolarityInversionIO00 Property

Polarity Inversion (IO0_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO00 { get; set; }
Public Property PolarityInversionIO00 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO00 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO00 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO00AI Property

IRD

Pca9698PolarityInversionIO00AI Property

Polarity Inversion (IO0_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO00AI { get; set; }
Public Property PolarityInversionIO00AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO00AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO00AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO01 Property

IRD

Pca9698PolarityInversionIO01 Property

Polarity Inversion (IO0_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO01 { get; set; }
Public Property PolarityInversionIO01 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO01 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO01 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO01AI Property

IRD

Pca9698PolarityInversionIO01AI Property

Polarity Inversion (IO0_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO01AI { get; set; }
Public Property PolarityInversionIO01AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO01AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO01AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO02 Property

IRD

Pca9698PolarityInversionIO02 Property

Polarity Inversion (IO0_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO02 { get; set; }
Public Property PolarityInversionIO02 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO02 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO02 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO02AI Property

IRD

Pca9698PolarityInversionIO02AI Property

Polarity Inversion (IO0_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO02AI { get; set; }
Public Property PolarityInversionIO02AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO02AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO02AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO03 Property

IRD

Pca9698PolarityInversionIO03 Property

Polarity Inversion (IO0_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO03 { get; set; }
Public Property PolarityInversionIO03 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO03 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO03 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO03AI Property

IRD

Pca9698PolarityInversionIO03AI Property

Polarity Inversion (IO0_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO03AI { get; set; }
Public Property PolarityInversionIO03AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO03AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO03AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO04 Property

IRD

Pca9698PolarityInversionIO04 Property

Polarity Inversion (IO0_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO04 { get; set; }
Public Property PolarityInversionIO04 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO04 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO04 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO04AI Property

IRD

Pca9698PolarityInversionIO04AI Property

Polarity Inversion (IO0_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO04AI { get; set; }
Public Property PolarityInversionIO04AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO04AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO04AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO05 Property

IRD

Pca9698PolarityInversionIO05 Property

Polarity Inversion (IO0_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO05 { get; set; }
Public Property PolarityInversionIO05 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO05 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO05 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO05AI Property

IRD

Pca9698PolarityInversionIO05AI Property

Polarity Inversion (IO0_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO05AI { get; set; }
Public Property PolarityInversionIO05AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO05AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO05AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO06 Property

IRD

Pca9698PolarityInversionIO06 Property

Polarity Inversion (IO0_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO06 { get; set; }
Public Property PolarityInversionIO06 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO06 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO06 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO06AI Property

IRD

Pca9698PolarityInversionIO06AI Property

Polarity Inversion (IO0_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO06AI { get; set; }
Public Property PolarityInversionIO06AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO06AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO06AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO07 Property

IRD

Pca9698PolarityInversionIO07 Property

Polarity Inversion (IO0_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO07 { get; set; }
Public Property PolarityInversionIO07 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO07 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO07 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO07AI Property

IRD

Pca9698PolarityInversionIO07AI Property

Polarity Inversion (IO0_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO07AI { get; set; }
Public Property PolarityInversionIO07AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO07AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO07AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO10 Property

IRD

Pca9698PolarityInversionIO10 Property

Polarity Inversion (IO1_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO10 { get; set; }
Public Property PolarityInversionIO10 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO10 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO10 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO10AI Property

IRD

Pca9698PolarityInversionIO10AI Property

Polarity Inversion (IO1_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO10AI { get; set; }
Public Property PolarityInversionIO10AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO10AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO10AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO11 Property

IRD

Pca9698PolarityInversionIO11 Property

Polarity Inversion (IO1_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO11 { get; set; }
Public Property PolarityInversionIO11 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO11 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO11 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO11AI Property

IRD

Pca9698PolarityInversionIO11AI Property

Polarity Inversion (IO1_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO11AI { get; set; }
Public Property PolarityInversionIO11AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO11AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO11AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO12 Property

IRD

Pca9698PolarityInversionIO12 Property

Polarity Inversion (IO1_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO12 { get; set; }
Public Property PolarityInversionIO12 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO12 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO12 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO12AI Property

IRD

Pca9698PolarityInversionIO12AI Property

Polarity Inversion (IO1_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO12AI { get; set; }
Public Property PolarityInversionIO12AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO12AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO12AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO13 Property

IRD

Pca9698PolarityInversionIO13 Property

Polarity Inversion (IO1_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO13 { get; set; }
Public Property PolarityInversionIO13 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO13 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO13 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO13AI Property

IRD

Pca9698PolarityInversionIO13AI Property

Polarity Inversion (IO1_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO13AI { get; set; }
Public Property PolarityInversionIO13AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO13AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO13AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO14 Property

IRD

Pca9698PolarityInversionIO14 Property

Polarity Inversion (IO1_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO14 { get; set; }
Public Property PolarityInversionIO14 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO14 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO14 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO14AI Property

IRD

Pca9698PolarityInversionIO14AI Property

Polarity Inversion (IO1_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO14AI { get; set; }
Public Property PolarityInversionIO14AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO14AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO14AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO15 Property

IRD

Pca9698PolarityInversionIO15 Property

Polarity Inversion (IO1_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO15 { get; set; }
Public Property PolarityInversionIO15 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO15 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO15 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO15AI Property

IRD

Pca9698PolarityInversionIO15AI Property

Polarity Inversion (IO1_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO15AI { get; set; }
Public Property PolarityInversionIO15AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO15AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO15AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO16 Property

IRD

Pca9698PolarityInversionIO16 Property

Polarity Inversion (IO1_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO16 { get; set; }
Public Property PolarityInversionIO16 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO16 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO16 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO16AI Property

IRD

Pca9698PolarityInversionIO16AI Property

Polarity Inversion (IO1_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO16AI { get; set; }
Public Property PolarityInversionIO16AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO16AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO16AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO17 Property

IRD

Pca9698PolarityInversionIO17 Property

Polarity Inversion (IO1_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO17 { get; set; }
Public Property PolarityInversionIO17 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO17 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO17 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO17AI Property

IRD

Pca9698PolarityInversionIO17AI Property

Polarity Inversion (IO1_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO17AI { get; set; }
Public Property PolarityInversionIO17AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO17AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO17AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO20 Property

IRD

Pca9698PolarityInversionIO20 Property

Polarity Inversion (IO2_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO20 { get; set; }
Public Property PolarityInversionIO20 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO20 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO20 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO20AI Property

IRD

Pca9698PolarityInversionIO20AI Property

Polarity Inversion (IO2_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO20AI { get; set; }
Public Property PolarityInversionIO20AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO20AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO20AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO21 Property

IRD

Pca9698PolarityInversionIO21 Property

Polarity Inversion (IO2_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO21 { get; set; }
Public Property PolarityInversionIO21 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO21 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO21 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO21AI Property

IRD

Pca9698PolarityInversionIO21AI Property

Polarity Inversion (IO2_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO21AI { get; set; }
Public Property PolarityInversionIO21AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO21AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO21AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO22 Property

IRD

Pca9698PolarityInversionIO22 Property

Polarity Inversion (IO2_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO22 { get; set; }
Public Property PolarityInversionIO22 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO22 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO22 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO22AI Property

IRD

Pca9698PolarityInversionIO22AI Property

Polarity Inversion (IO2_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO22AI { get; set; }
Public Property PolarityInversionIO22AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO22AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO22AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO23 Property

IRD

Pca9698PolarityInversionIO23 Property

Polarity Inversion (IO2_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO23 { get; set; }
Public Property PolarityInversionIO23 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO23 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO23 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO23AI Property

IRD

Pca9698PolarityInversionIO23AI Property

Polarity Inversion (IO2_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO23AI { get; set; }
Public Property PolarityInversionIO23AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO23AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO23AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO24 Property

IRD

Pca9698PolarityInversionIO24 Property

Polarity Inversion (IO2_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO24 { get; set; }
Public Property PolarityInversionIO24 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO24 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO24 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO24AI Property

IRD

Pca9698PolarityInversionIO24AI Property

Polarity Inversion (IO2_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO24AI { get; set; }
Public Property PolarityInversionIO24AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO24AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO24AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO25 Property

IRD

Pca9698PolarityInversionIO25 Property

Polarity Inversion (IO2_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO25 { get; set; }
Public Property PolarityInversionIO25 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO25 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO25 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO25AI Property

IRD

Pca9698PolarityInversionIO25AI Property

Polarity Inversion (IO2_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO25AI { get; set; }
Public Property PolarityInversionIO25AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO25AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO25AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO26 Property

IRD

Pca9698PolarityInversionIO26 Property

Polarity Inversion (IO2_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO26 { get; set; }
Public Property PolarityInversionIO26 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO26 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO26 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO26AI Property

IRD

Pca9698PolarityInversionIO26AI Property

Polarity Inversion (IO2_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO26AI { get; set; }
Public Property PolarityInversionIO26AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO26AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO26AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO27 Property

IRD

Pca9698PolarityInversionIO27 Property

Polarity Inversion (IO2_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO27 { get; set; }
Public Property PolarityInversionIO27 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO27 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO27 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO27AI Property

IRD

Pca9698PolarityInversionIO27AI Property

Polarity Inversion (IO2_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO27AI { get; set; }
Public Property PolarityInversionIO27AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO27AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO27AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO30 Property

IRD

Pca9698PolarityInversionIO30 Property

Polarity Inversion (IO3_0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO30 { get; set; }
Public Property PolarityInversionIO30 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO30 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO30 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO30AI Property

IRD

Pca9698PolarityInversionIO30AI Property

Polarity Inversion (IO3_0) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO30AI { get; set; }
Public Property PolarityInversionIO30AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO30AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO30AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO31 Property

IRD

Pca9698PolarityInversionIO31 Property

Polarity Inversion (IO3_1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO31 { get; set; }
Public Property PolarityInversionIO31 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO31 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO31 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO31AI Property

IRD

Pca9698PolarityInversionIO31AI Property

Polarity Inversion (IO3_1) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO31AI { get; set; }
Public Property PolarityInversionIO31AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO31AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO31AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO32 Property

IRD

Pca9698PolarityInversionIO32 Property

Polarity Inversion (IO3_2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO32 { get; set; }
Public Property PolarityInversionIO32 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO32 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO32 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO32AI Property

IRD

Pca9698PolarityInversionIO32AI Property

Polarity Inversion (IO3_2) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO32AI { get; set; }
Public Property PolarityInversionIO32AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO32AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO32AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO33 Property

IRD

Pca9698PolarityInversionIO33 Property

Polarity Inversion (IO3_3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO33 { get; set; }
Public Property PolarityInversionIO33 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO33 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO33 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO33AI Property

IRD

Pca9698PolarityInversionIO33AI Property

Polarity Inversion (IO3_3) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO33AI { get; set; }
Public Property PolarityInversionIO33AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO33AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO33AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO34 Property

IRD

Pca9698PolarityInversionIO34 Property

Polarity Inversion (IO3_4)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO34 { get; set; }
Public Property PolarityInversionIO34 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO34 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO34 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO34AI Property

IRD

Pca9698PolarityInversionIO34AI Property

Polarity Inversion (IO3_4) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO34AI { get; set; }
Public Property PolarityInversionIO34AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO34AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO34AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO35 Property

IRD

Pca9698PolarityInversionIO35 Property

Polarity Inversion (IO3_5)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO35 { get; set; }
Public Property PolarityInversionIO35 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO35 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO35 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO35AI Property

IRD

Pca9698PolarityInversionIO35AI Property

Polarity Inversion (IO3_5) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO35AI { get; set; }
Public Property PolarityInversionIO35AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO35AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO35AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO36 Property

IRD

Pca9698PolarityInversionIO36 Property

Polarity Inversion (IO3_6)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO36 { get; set; }
Public Property PolarityInversionIO36 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO36 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO36 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO36AI Property

IRD

Pca9698PolarityInversionIO36AI Property

Polarity Inversion (IO3_6) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO36AI { get; set; }
Public Property PolarityInversionIO36AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO36AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO36AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO37 Property

IRD

Pca9698PolarityInversionIO37 Property

Polarity Inversion (IO3_7)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO37 { get; set; }
Public Property PolarityInversionIO37 As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO37 {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO37 : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.PolarityInversionIO37AI Property

IRD

Pca9698PolarityInversionIO37AI Property

Polarity Inversion (IO3_7) [AI]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9698TypePi PolarityInversionIO37AI { get; set; }
Public Property PolarityInversionIO37AI As Pca9698TypePi
    Get
    Set
public:
property Pca9698TypePi PolarityInversionIO37AI {
    Pca9698TypePi get ();
    void set (Pca9698TypePi value);
}
member PolarityInversionIO37AI : Pca9698TypePi with get, set

Property Value

Type: Pca9698TypePi
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698 Methods

The Pca9698 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.Flush Method

IRD

Pca9698Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9698 Class
telos.Ird.NXPSemiconductors Namespace


Pca9698.TypeIoc Enumeration

IRD

Pca9698TypeIoc Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeIoc
Public Enumeration TypeIoc
public enum class TypeIoc
type TypeIoc
Members
Member name | Value | Description
Output | 0 | Output
Input | 1 | Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9698.TypeModeIoac Enumeration

IRD

Pca9698TypeModeIoac Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeIoac
Public Enumeration TypeModeIoac
public enum class TypeModeIoac
type TypeModeIoac
Members
Member name | Value | Description
GPIOAllCallNotAnswered | 0 | GPIO All Call: not answered
GPIOAllCallAnswered | 1 | GPIO All Call: answered
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9698.TypeModeOch Enumeration

IRD

Pca9698TypeModeOch Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeOch
Public Enumeration TypeModeOch
public enum class TypeModeOch
type TypeModeOch
Members
Member name | Value | Description
OutputsChangeOnSTOPCondition | 0 | Outputs change: on STOP condition
OutputsChangeOnACK | 1 | Outputs change: on ACK
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9698.TypeModeOepol Enumeration

IRD

Pca9698TypeModeOepol Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeOepol
Public Enumeration TypeModeOepol
public enum class TypeModeOepol
type TypeModeOepol
Members
Member name | Value | Description
OEPinActiveLOW | 0 | OE pin: active LOW
OEPinActiveHIGH | 1 | OE pin: active HIGH
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9698.TypeModeSmba Enumeration

IRD

Pca9698TypeModeSmba Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeSmba
Public Enumeration TypeModeSmba
public enum class TypeModeSmba
type TypeModeSmba
Members
Member name | Value | Description
AlertResponseAddressNotAnswered | 0 | Alert Response Address: not answered
AlertResponseAddressAnswered | 1 | Alert Response Address: answered
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9698.TypeMsk Enumeration

IRD

Pca9698TypeMsk Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMsk
Public Enumeration TypeMsk
public enum class TypeMsk
type TypeMsk
Members
Member name | Value | Description
InterruptEnabled | 0 | Interrupt Enabled
InterruptDisabled | 1 | Interrupt Disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9698.TypeOutconf Enumeration

IRD

Pca9698TypeOutconf Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutconf
Public Enumeration TypeOutconf
public enum class TypeOutconf
type TypeOutconf
Members
Member name | Value | Description
OpenDrain | 0 | Open-Drain
TotemPole | 1 | Totem-Pole
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pca9698.TypePi Enumeration

IRD

Pca9698TypePi Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePi
Public Enumeration TypePi
public enum class TypePi
type TypePi
Members
Member name | Value | Description
Retained | 0 | Retained
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6408a Class

NXP Semiconductors: PCAL 6408A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPcal6408a

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcal6408a
Public Class Pcal6408a
public ref class Pcal6408a
type Pcal6408a =  class end

The Pcal6408a type exposes the following members.

Constructors
 | Name | Description
Public method | Pcal6408a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC0 | Configuration: C0
Public property | ConfigurationC1 | Configuration: C1
Public property | ConfigurationC2 | Configuration: C2
Public property | ConfigurationC3 | Configuration: C3
Public property | ConfigurationC4 | Configuration: C4
Public property | ConfigurationC5 | Configuration: C5
Public property | ConfigurationC6 | Configuration: C6
Public property | ConfigurationC7 | Configuration: C7
Public property | InputLatchL0 | Input Latch: L0
Public property | InputLatchL1 | Input Latch: L1
Public property | InputLatchL2 | Input Latch: L2
Public property | InputLatchL3 | Input Latch: L3
Public property | InputLatchL4 | Input Latch: L4
Public property | InputLatchL5 | Input Latch: L5
Public property | InputLatchL6 | Input Latch: L6
Public property | InputLatchL7 | Input Latch: L7
Public property | InputPortI0 | Input Port: I0
Public property | InputPortI1 | Input Port: I1
Public property | InputPortI2 | Input Port: I2
Public property | InputPortI3 | Input Port: I3
Public property | InputPortI4 | Input Port: I4
Public property | InputPortI5 | Input Port: I5
Public property | InputPortI6 | Input Port: I6
Public property | InputPortI7 | Input Port: I7
Public property | InterruptMaskM0 | Interrupt Mask: M0
Public property | InterruptMaskM1 | Interrupt Mask: M1
Public property | InterruptMaskM2 | Interrupt Mask: M2
Public property | InterruptMaskM3 | Interrupt Mask: M3
Public property | InterruptMaskM4 | Interrupt Mask: M4
Public property | InterruptMaskM5 | Interrupt Mask: M5
Public property | InterruptMaskM6 | Interrupt Mask: M6
Public property | InterruptMaskM7 | Interrupt Mask: M7
Public property | InterruptStatusS0 | Interrupt Status: S0
Public property | InterruptStatusS1 | Interrupt Status: S1
Public property | InterruptStatusS2 | Interrupt Status: S2
Public property | InterruptStatusS3 | Interrupt Status: S3
Public property | InterruptStatusS4 | Interrupt Status: S4
Public property | InterruptStatusS5 | Interrupt Status: S5
Public property | InterruptStatusS6 | Interrupt Status: S6
Public property | InterruptStatusS7 | Interrupt Status: S7
Public property | OutputDriveStrengthCC0 | Output Drive Strength: CC0
Public property | OutputDriveStrengthCC1 | Output Drive Strength: CC1
Public property | OutputDriveStrengthCC2 | Output Drive Strength: CC2
Public property | OutputDriveStrengthCC3 | Output Drive Strength: CC3
Public property | OutputDriveStrengthCC4 | Output Drive Strength: CC4
Public property | OutputDriveStrengthCC5 | Output Drive Strength: CC5
Public property | OutputDriveStrengthCC6 | Output Drive Strength: CC6
Public property | OutputDriveStrengthCC7 | Output Drive Strength: CC7
Public property | OutputPortConfigurationODEN | Output Port Configuration: ODEN
Public property | OutputPortO0 | Output Port: O0
Public property | OutputPortO1 | Output Port: O1
Public property | OutputPortO2 | Output Port: O2
Public property | OutputPortO3 | Output Port: O3
Public property | OutputPortO4 | Output Port: O4
Public property | OutputPortO5 | Output Port: O5
Public property | OutputPortO6 | Output Port: O6
Public property | OutputPortO7 | Output Port: O7
Public property | PolarityInversionN0 | Polarity Inversion: N0
Public property | PolarityInversionN1 | Polarity Inversion: N1
Public property | PolarityInversionN2 | Polarity Inversion: N2
Public property | PolarityInversionN3 | Polarity Inversion: N3
Public property | PolarityInversionN4 | Polarity Inversion: N4
Public property | PolarityInversionN5 | Polarity Inversion: N5
Public property | PolarityInversionN6 | Polarity Inversion: N6
Public property | PolarityInversionN7 | Polarity Inversion: N7
Public property | PullUpPullDownEnablePE0 | Pull-Up/Pull-Down Enable: PE0
Public property | PullUpPullDownEnablePE1 | Pull-Up/Pull-Down Enable: PE1
Public property | PullUpPullDownEnablePE2 | Pull-Up/Pull-Down Enable: PE2
Public property | PullUpPullDownEnablePE3 | Pull-Up/Pull-Down Enable: PE3
Public property | PullUpPullDownEnablePE4 | Pull-Up/Pull-Down Enable: PE4
Public property | PullUpPullDownEnablePE5 | Pull-Up/Pull-Down Enable: PE5
Public property | PullUpPullDownEnablePE6 | Pull-Up/Pull-Down Enable: PE6
Public property | PullUpPullDownEnablePE7 | Pull-Up/Pull-Down Enable: PE7
Public property | PullUpPullDownSelectionPUD0 | Pull-Up/Pull-Down Selection: PUD0
Public property | PullUpPullDownSelectionPUD1 | Pull-Up/Pull-Down Selection: PUD1
Public property | PullUpPullDownSelectionPUD2 | Pull-Up/Pull-Down Selection: PUD2
Public property | PullUpPullDownSelectionPUD3 | Pull-Up/Pull-Down Selection: PUD3
Public property | PullUpPullDownSelectionPUD4 | Pull-Up/Pull-Down Selection: PUD4
Public property | PullUpPullDownSelectionPUD5 | Pull-Up/Pull-Down Selection: PUD5
Public property | PullUpPullDownSelectionPUD6 | Pull-Up/Pull-Down Selection: PUD6
Public property | PullUpPullDownSelectionPUD7 | Pull-Up/Pull-Down Selection: PUD7
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Voltage Translating 8-Bit I2C-Bus/SMBus I/O Expander With Interrupt Output, Reset, And Configuration Registers
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6408a Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcal6408a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcal6408a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a Properties

The Pcal6408a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC0 | Configuration: C0
Public property | ConfigurationC1 | Configuration: C1
Public property | ConfigurationC2 | Configuration: C2
Public property | ConfigurationC3 | Configuration: C3
Public property | ConfigurationC4 | Configuration: C4
Public property | ConfigurationC5 | Configuration: C5
Public property | ConfigurationC6 | Configuration: C6
Public property | ConfigurationC7 | Configuration: C7
Public property | InputLatchL0 | Input Latch: L0
Public property | InputLatchL1 | Input Latch: L1
Public property | InputLatchL2 | Input Latch: L2
Public property | InputLatchL3 | Input Latch: L3
Public property | InputLatchL4 | Input Latch: L4
Public property | InputLatchL5 | Input Latch: L5
Public property | InputLatchL6 | Input Latch: L6
Public property | InputLatchL7 | Input Latch: L7
Public property | InputPortI0 | Input Port: I0
Public property | InputPortI1 | Input Port: I1
Public property | InputPortI2 | Input Port: I2
Public property | InputPortI3 | Input Port: I3
Public property | InputPortI4 | Input Port: I4
Public property | InputPortI5 | Input Port: I5
Public property | InputPortI6 | Input Port: I6
Public property | InputPortI7 | Input Port: I7
Public property | InterruptMaskM0 | Interrupt Mask: M0
Public property | InterruptMaskM1 | Interrupt Mask: M1
Public property | InterruptMaskM2 | Interrupt Mask: M2
Public property | InterruptMaskM3 | Interrupt Mask: M3
Public property | InterruptMaskM4 | Interrupt Mask: M4
Public property | InterruptMaskM5 | Interrupt Mask: M5
Public property | InterruptMaskM6 | Interrupt Mask: M6
Public property | InterruptMaskM7 | Interrupt Mask: M7
Public property | InterruptStatusS0 | Interrupt Status: S0
Public property | InterruptStatusS1 | Interrupt Status: S1
Public property | InterruptStatusS2 | Interrupt Status: S2
Public property | InterruptStatusS3 | Interrupt Status: S3
Public property | InterruptStatusS4 | Interrupt Status: S4
Public property | InterruptStatusS5 | Interrupt Status: S5
Public property | InterruptStatusS6 | Interrupt Status: S6
Public property | InterruptStatusS7 | Interrupt Status: S7
Public property | OutputDriveStrengthCC0 | Output Drive Strength: CC0
Public property | OutputDriveStrengthCC1 | Output Drive Strength: CC1
Public property | OutputDriveStrengthCC2 | Output Drive Strength: CC2
Public property | OutputDriveStrengthCC3 | Output Drive Strength: CC3
Public property | OutputDriveStrengthCC4 | Output Drive Strength: CC4
Public property | OutputDriveStrengthCC5 | Output Drive Strength: CC5
Public property | OutputDriveStrengthCC6 | Output Drive Strength: CC6
Public property | OutputDriveStrengthCC7 | Output Drive Strength: CC7
Public property | OutputPortConfigurationODEN | Output Port Configuration: ODEN
Public property | OutputPortO0 | Output Port: O0
Public property | OutputPortO1 | Output Port: O1
Public property | OutputPortO2 | Output Port: O2
Public property | OutputPortO3 | Output Port: O3
Public property | OutputPortO4 | Output Port: O4
Public property | OutputPortO5 | Output Port: O5
Public property | OutputPortO6 | Output Port: O6
Public property | OutputPortO7 | Output Port: O7
Public property | PolarityInversionN0 | Polarity Inversion: N0
Public property | PolarityInversionN1 | Polarity Inversion: N1
Public property | PolarityInversionN2 | Polarity Inversion: N2
Public property | PolarityInversionN3 | Polarity Inversion: N3
Public property | PolarityInversionN4 | Polarity Inversion: N4
Public property | PolarityInversionN5 | Polarity Inversion: N5
Public property | PolarityInversionN6 | Polarity Inversion: N6
Public property | PolarityInversionN7 | Polarity Inversion: N7
Public property | PullUpPullDownEnablePE0 | Pull-Up/Pull-Down Enable: PE0
Public property | PullUpPullDownEnablePE1 | Pull-Up/Pull-Down Enable: PE1
Public property | PullUpPullDownEnablePE2 | Pull-Up/Pull-Down Enable: PE2
Public property | PullUpPullDownEnablePE3 | Pull-Up/Pull-Down Enable: PE3
Public property | PullUpPullDownEnablePE4 | Pull-Up/Pull-Down Enable: PE4
Public property | PullUpPullDownEnablePE5 | Pull-Up/Pull-Down Enable: PE5
Public property | PullUpPullDownEnablePE6 | Pull-Up/Pull-Down Enable: PE6
Public property | PullUpPullDownEnablePE7 | Pull-Up/Pull-Down Enable: PE7
Public property | PullUpPullDownSelectionPUD0 | Pull-Up/Pull-Down Selection: PUD0
Public property | PullUpPullDownSelectionPUD1 | Pull-Up/Pull-Down Selection: PUD1
Public property | PullUpPullDownSelectionPUD2 | Pull-Up/Pull-Down Selection: PUD2
Public property | PullUpPullDownSelectionPUD3 | Pull-Up/Pull-Down Selection: PUD3
Public property | PullUpPullDownSelectionPUD4 | Pull-Up/Pull-Down Selection: PUD4
Public property | PullUpPullDownSelectionPUD5 | Pull-Up/Pull-Down Selection: PUD5
Public property | PullUpPullDownSelectionPUD6 | Pull-Up/Pull-Down Selection: PUD6
Public property | PullUpPullDownSelectionPUD7 | Pull-Up/Pull-Down Selection: PUD7
Top
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.AutoFlush Property

IRD

Pcal6408aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.ConfigurationC0 Property

IRD

Pcal6408aConfigurationC0 Property

Configuration: C0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeConfiguration ConfigurationC0 { get; set; }
Public Property ConfigurationC0 As Pcal6408aTypeConfiguration
    Get
    Set
public:
property Pcal6408aTypeConfiguration ConfigurationC0 {
    Pcal6408aTypeConfiguration get ();
    void set (Pcal6408aTypeConfiguration value);
}
member ConfigurationC0 : Pcal6408aTypeConfiguration with get, set

Property Value

Type: Pcal6408aTypeConfiguration
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.ConfigurationC1 Property

IRD

Pcal6408aConfigurationC1 Property

Configuration: C1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeConfiguration ConfigurationC1 { get; set; }
Public Property ConfigurationC1 As Pcal6408aTypeConfiguration
    Get
    Set
public:
property Pcal6408aTypeConfiguration ConfigurationC1 {
    Pcal6408aTypeConfiguration get ();
    void set (Pcal6408aTypeConfiguration value);
}
member ConfigurationC1 : Pcal6408aTypeConfiguration with get, set

Property Value

Type: Pcal6408aTypeConfiguration
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.ConfigurationC2 Property

IRD

Pcal6408aConfigurationC2 Property

Configuration: C2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeConfiguration ConfigurationC2 { get; set; }
Public Property ConfigurationC2 As Pcal6408aTypeConfiguration
    Get
    Set
public:
property Pcal6408aTypeConfiguration ConfigurationC2 {
    Pcal6408aTypeConfiguration get ();
    void set (Pcal6408aTypeConfiguration value);
}
member ConfigurationC2 : Pcal6408aTypeConfiguration with get, set

Property Value

Type: Pcal6408aTypeConfiguration
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.ConfigurationC3 Property

IRD

Pcal6408aConfigurationC3 Property

Configuration: C3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeConfiguration ConfigurationC3 { get; set; }
Public Property ConfigurationC3 As Pcal6408aTypeConfiguration
    Get
    Set
public:
property Pcal6408aTypeConfiguration ConfigurationC3 {
    Pcal6408aTypeConfiguration get ();
    void set (Pcal6408aTypeConfiguration value);
}
member ConfigurationC3 : Pcal6408aTypeConfiguration with get, set

Property Value

Type: Pcal6408aTypeConfiguration
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.ConfigurationC4 Property

IRD

Pcal6408aConfigurationC4 Property

Configuration: C4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeConfiguration ConfigurationC4 { get; set; }
Public Property ConfigurationC4 As Pcal6408aTypeConfiguration
    Get
    Set
public:
property Pcal6408aTypeConfiguration ConfigurationC4 {
    Pcal6408aTypeConfiguration get ();
    void set (Pcal6408aTypeConfiguration value);
}
member ConfigurationC4 : Pcal6408aTypeConfiguration with get, set

Property Value

Type: Pcal6408aTypeConfiguration
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.ConfigurationC5 Property

IRD

Pcal6408aConfigurationC5 Property

Configuration: C5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeConfiguration ConfigurationC5 { get; set; }
Public Property ConfigurationC5 As Pcal6408aTypeConfiguration
    Get
    Set
public:
property Pcal6408aTypeConfiguration ConfigurationC5 {
    Pcal6408aTypeConfiguration get ();
    void set (Pcal6408aTypeConfiguration value);
}
member ConfigurationC5 : Pcal6408aTypeConfiguration with get, set

Property Value

Type: Pcal6408aTypeConfiguration
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.ConfigurationC6 Property

IRD

Pcal6408aConfigurationC6 Property

Configuration: C6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeConfiguration ConfigurationC6 { get; set; }
Public Property ConfigurationC6 As Pcal6408aTypeConfiguration
    Get
    Set
public:
property Pcal6408aTypeConfiguration ConfigurationC6 {
    Pcal6408aTypeConfiguration get ();
    void set (Pcal6408aTypeConfiguration value);
}
member ConfigurationC6 : Pcal6408aTypeConfiguration with get, set

Property Value

Type: Pcal6408aTypeConfiguration
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.ConfigurationC7 Property

IRD

Pcal6408aConfigurationC7 Property

Configuration: C7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeConfiguration ConfigurationC7 { get; set; }
Public Property ConfigurationC7 As Pcal6408aTypeConfiguration
    Get
    Set
public:
property Pcal6408aTypeConfiguration ConfigurationC7 {
    Pcal6408aTypeConfiguration get ();
    void set (Pcal6408aTypeConfiguration value);
}
member ConfigurationC7 : Pcal6408aTypeConfiguration with get, set

Property Value

Type: Pcal6408aTypeConfiguration
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InputLatchL0 Property

IRD

Pcal6408aInputLatchL0 Property

Input Latch: L0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInputLatch InputLatchL0 { get; set; }
Public Property InputLatchL0 As Pcal6408aTypeInputLatch
    Get
    Set
public:
property Pcal6408aTypeInputLatch InputLatchL0 {
    Pcal6408aTypeInputLatch get ();
    void set (Pcal6408aTypeInputLatch value);
}
member InputLatchL0 : Pcal6408aTypeInputLatch with get, set

Property Value

Type: Pcal6408aTypeInputLatch
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InputLatchL1 Property

IRD

Pcal6408aInputLatchL1 Property

Input Latch: L1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInputLatch InputLatchL1 { get; set; }
Public Property InputLatchL1 As Pcal6408aTypeInputLatch
    Get
    Set
public:
property Pcal6408aTypeInputLatch InputLatchL1 {
    Pcal6408aTypeInputLatch get ();
    void set (Pcal6408aTypeInputLatch value);
}
member InputLatchL1 : Pcal6408aTypeInputLatch with get, set

Property Value

Type: Pcal6408aTypeInputLatch
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InputLatchL2 Property

IRD

Pcal6408aInputLatchL2 Property

Input Latch: L2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInputLatch InputLatchL2 { get; set; }
Public Property InputLatchL2 As Pcal6408aTypeInputLatch
    Get
    Set
public:
property Pcal6408aTypeInputLatch InputLatchL2 {
    Pcal6408aTypeInputLatch get ();
    void set (Pcal6408aTypeInputLatch value);
}
member InputLatchL2 : Pcal6408aTypeInputLatch with get, set

Property Value

Type: Pcal6408aTypeInputLatch
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InputLatchL3 Property

IRD

Pcal6408aInputLatchL3 Property

Input Latch: L3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInputLatch InputLatchL3 { get; set; }
Public Property InputLatchL3 As Pcal6408aTypeInputLatch
    Get
    Set
public:
property Pcal6408aTypeInputLatch InputLatchL3 {
    Pcal6408aTypeInputLatch get ();
    void set (Pcal6408aTypeInputLatch value);
}
member InputLatchL3 : Pcal6408aTypeInputLatch with get, set

Property Value

Type: Pcal6408aTypeInputLatch
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InputLatchL4 Property

IRD

Pcal6408aInputLatchL4 Property

Input Latch: L4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInputLatch InputLatchL4 { get; set; }
Public Property InputLatchL4 As Pcal6408aTypeInputLatch
    Get
    Set
public:
property Pcal6408aTypeInputLatch InputLatchL4 {
    Pcal6408aTypeInputLatch get ();
    void set (Pcal6408aTypeInputLatch value);
}
member InputLatchL4 : Pcal6408aTypeInputLatch with get, set

Property Value

Type: Pcal6408aTypeInputLatch
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InputLatchL5 Property

IRD

Pcal6408aInputLatchL5 Property

Input Latch: L5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInputLatch InputLatchL5 { get; set; }
Public Property InputLatchL5 As Pcal6408aTypeInputLatch
    Get
    Set
public:
property Pcal6408aTypeInputLatch InputLatchL5 {
    Pcal6408aTypeInputLatch get ();
    void set (Pcal6408aTypeInputLatch value);
}
member InputLatchL5 : Pcal6408aTypeInputLatch with get, set

Property Value

Type: Pcal6408aTypeInputLatch
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InputLatchL6 Property

IRD

Pcal6408aInputLatchL6 Property

Input Latch: L6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInputLatch InputLatchL6 { get; set; }
Public Property InputLatchL6 As Pcal6408aTypeInputLatch
    Get
    Set
public:
property Pcal6408aTypeInputLatch InputLatchL6 {
    Pcal6408aTypeInputLatch get ();
    void set (Pcal6408aTypeInputLatch value);
}
member InputLatchL6 : Pcal6408aTypeInputLatch with get, set

Property Value

Type: Pcal6408aTypeInputLatch
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InputLatchL7 Property

IRD

Pcal6408aInputLatchL7 Property

Input Latch: L7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInputLatch InputLatchL7 { get; set; }
Public Property InputLatchL7 As Pcal6408aTypeInputLatch
    Get
    Set
public:
property Pcal6408aTypeInputLatch InputLatchL7 {
    Pcal6408aTypeInputLatch get ();
    void set (Pcal6408aTypeInputLatch value);
}
member InputLatchL7 : Pcal6408aTypeInputLatch with get, set

Property Value

Type: Pcal6408aTypeInputLatch
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InputPortI0 Property

IRD

Pcal6408aInputPortI0 Property

Input Port: I0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI0 { get; }
Public ReadOnly Property InputPortI0 As Byte
    Get
public:
property unsigned char InputPortI0 {
    unsigned char get ();
}
member InputPortI0 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InputPortI1 Property

IRD

Pcal6408aInputPortI1 Property

Input Port: I1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI1 { get; }
Public ReadOnly Property InputPortI1 As Byte
    Get
public:
property unsigned char InputPortI1 {
    unsigned char get ();
}
member InputPortI1 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InputPortI2 Property

IRD

Pcal6408aInputPortI2 Property

Input Port: I2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI2 { get; }
Public ReadOnly Property InputPortI2 As Byte
    Get
public:
property unsigned char InputPortI2 {
    unsigned char get ();
}
member InputPortI2 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InputPortI3 Property

IRD

Pcal6408aInputPortI3 Property

Input Port: I3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI3 { get; }
Public ReadOnly Property InputPortI3 As Byte
    Get
public:
property unsigned char InputPortI3 {
    unsigned char get ();
}
member InputPortI3 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InputPortI4 Property

IRD

Pcal6408aInputPortI4 Property

Input Port: I4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI4 { get; }
Public ReadOnly Property InputPortI4 As Byte
    Get
public:
property unsigned char InputPortI4 {
    unsigned char get ();
}
member InputPortI4 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InputPortI5 Property

IRD

Pcal6408aInputPortI5 Property

Input Port: I5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI5 { get; }
Public ReadOnly Property InputPortI5 As Byte
    Get
public:
property unsigned char InputPortI5 {
    unsigned char get ();
}
member InputPortI5 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InputPortI6 Property

IRD

Pcal6408aInputPortI6 Property

Input Port: I6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI6 { get; }
Public ReadOnly Property InputPortI6 As Byte
    Get
public:
property unsigned char InputPortI6 {
    unsigned char get ();
}
member InputPortI6 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InputPortI7 Property

IRD

Pcal6408aInputPortI7 Property

Input Port: I7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI7 { get; }
Public ReadOnly Property InputPortI7 As Byte
    Get
public:
property unsigned char InputPortI7 {
    unsigned char get ();
}
member InputPortI7 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InterruptMaskM0 Property

IRD

Pcal6408aInterruptMaskM0 Property

Interrupt Mask: M0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInterruptMask InterruptMaskM0 { get; set; }
Public Property InterruptMaskM0 As Pcal6408aTypeInterruptMask
    Get
    Set
public:
property Pcal6408aTypeInterruptMask InterruptMaskM0 {
    Pcal6408aTypeInterruptMask get ();
    void set (Pcal6408aTypeInterruptMask value);
}
member InterruptMaskM0 : Pcal6408aTypeInterruptMask with get, set

Property Value

Type: Pcal6408aTypeInterruptMask
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InterruptMaskM1 Property

IRD

Pcal6408aInterruptMaskM1 Property

Interrupt Mask: M1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInterruptMask InterruptMaskM1 { get; set; }
Public Property InterruptMaskM1 As Pcal6408aTypeInterruptMask
    Get
    Set
public:
property Pcal6408aTypeInterruptMask InterruptMaskM1 {
    Pcal6408aTypeInterruptMask get ();
    void set (Pcal6408aTypeInterruptMask value);
}
member InterruptMaskM1 : Pcal6408aTypeInterruptMask with get, set

Property Value

Type: Pcal6408aTypeInterruptMask
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InterruptMaskM2 Property

IRD

Pcal6408aInterruptMaskM2 Property

Interrupt Mask: M2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInterruptMask InterruptMaskM2 { get; set; }
Public Property InterruptMaskM2 As Pcal6408aTypeInterruptMask
    Get
    Set
public:
property Pcal6408aTypeInterruptMask InterruptMaskM2 {
    Pcal6408aTypeInterruptMask get ();
    void set (Pcal6408aTypeInterruptMask value);
}
member InterruptMaskM2 : Pcal6408aTypeInterruptMask with get, set

Property Value

Type: Pcal6408aTypeInterruptMask
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InterruptMaskM3 Property

IRD

Pcal6408aInterruptMaskM3 Property

Interrupt Mask: M3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInterruptMask InterruptMaskM3 { get; set; }
Public Property InterruptMaskM3 As Pcal6408aTypeInterruptMask
    Get
    Set
public:
property Pcal6408aTypeInterruptMask InterruptMaskM3 {
    Pcal6408aTypeInterruptMask get ();
    void set (Pcal6408aTypeInterruptMask value);
}
member InterruptMaskM3 : Pcal6408aTypeInterruptMask with get, set

Property Value

Type: Pcal6408aTypeInterruptMask
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InterruptMaskM4 Property

IRD

Pcal6408aInterruptMaskM4 Property

Interrupt Mask: M4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInterruptMask InterruptMaskM4 { get; set; }
Public Property InterruptMaskM4 As Pcal6408aTypeInterruptMask
    Get
    Set
public:
property Pcal6408aTypeInterruptMask InterruptMaskM4 {
    Pcal6408aTypeInterruptMask get ();
    void set (Pcal6408aTypeInterruptMask value);
}
member InterruptMaskM4 : Pcal6408aTypeInterruptMask with get, set

Property Value

Type: Pcal6408aTypeInterruptMask
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InterruptMaskM5 Property

IRD

Pcal6408aInterruptMaskM5 Property

Interrupt Mask: M5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInterruptMask InterruptMaskM5 { get; set; }
Public Property InterruptMaskM5 As Pcal6408aTypeInterruptMask
    Get
    Set
public:
property Pcal6408aTypeInterruptMask InterruptMaskM5 {
    Pcal6408aTypeInterruptMask get ();
    void set (Pcal6408aTypeInterruptMask value);
}
member InterruptMaskM5 : Pcal6408aTypeInterruptMask with get, set

Property Value

Type: Pcal6408aTypeInterruptMask
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InterruptMaskM6 Property

IRD

Pcal6408aInterruptMaskM6 Property

Interrupt Mask: M6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInterruptMask InterruptMaskM6 { get; set; }
Public Property InterruptMaskM6 As Pcal6408aTypeInterruptMask
    Get
    Set
public:
property Pcal6408aTypeInterruptMask InterruptMaskM6 {
    Pcal6408aTypeInterruptMask get ();
    void set (Pcal6408aTypeInterruptMask value);
}
member InterruptMaskM6 : Pcal6408aTypeInterruptMask with get, set

Property Value

Type: Pcal6408aTypeInterruptMask
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InterruptMaskM7 Property

IRD

Pcal6408aInterruptMaskM7 Property

Interrupt Mask: M7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInterruptMask InterruptMaskM7 { get; set; }
Public Property InterruptMaskM7 As Pcal6408aTypeInterruptMask
    Get
    Set
public:
property Pcal6408aTypeInterruptMask InterruptMaskM7 {
    Pcal6408aTypeInterruptMask get ();
    void set (Pcal6408aTypeInterruptMask value);
}
member InterruptMaskM7 : Pcal6408aTypeInterruptMask with get, set

Property Value

Type: Pcal6408aTypeInterruptMask
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InterruptStatusS0 Property

IRD

Pcal6408aInterruptStatusS0 Property

Interrupt Status: S0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInterruptStatus InterruptStatusS0 { get; }
Public ReadOnly Property InterruptStatusS0 As Pcal6408aTypeInterruptStatus
    Get
public:
property Pcal6408aTypeInterruptStatus InterruptStatusS0 {
    Pcal6408aTypeInterruptStatus get ();
}
member InterruptStatusS0 : Pcal6408aTypeInterruptStatus with get

Property Value

Type: Pcal6408aTypeInterruptStatus
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InterruptStatusS1 Property

IRD

Pcal6408aInterruptStatusS1 Property

Interrupt Status: S1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInterruptStatus InterruptStatusS1 { get; }
Public ReadOnly Property InterruptStatusS1 As Pcal6408aTypeInterruptStatus
    Get
public:
property Pcal6408aTypeInterruptStatus InterruptStatusS1 {
    Pcal6408aTypeInterruptStatus get ();
}
member InterruptStatusS1 : Pcal6408aTypeInterruptStatus with get

Property Value

Type: Pcal6408aTypeInterruptStatus
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InterruptStatusS2 Property

IRD

Pcal6408aInterruptStatusS2 Property

Interrupt Status: S2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInterruptStatus InterruptStatusS2 { get; }
Public ReadOnly Property InterruptStatusS2 As Pcal6408aTypeInterruptStatus
    Get
public:
property Pcal6408aTypeInterruptStatus InterruptStatusS2 {
    Pcal6408aTypeInterruptStatus get ();
}
member InterruptStatusS2 : Pcal6408aTypeInterruptStatus with get

Property Value

Type: Pcal6408aTypeInterruptStatus
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InterruptStatusS3 Property

IRD

Pcal6408aInterruptStatusS3 Property

Interrupt Status: S3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInterruptStatus InterruptStatusS3 { get; }
Public ReadOnly Property InterruptStatusS3 As Pcal6408aTypeInterruptStatus
    Get
public:
property Pcal6408aTypeInterruptStatus InterruptStatusS3 {
    Pcal6408aTypeInterruptStatus get ();
}
member InterruptStatusS3 : Pcal6408aTypeInterruptStatus with get

Property Value

Type: Pcal6408aTypeInterruptStatus
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InterruptStatusS4 Property

IRD

Pcal6408aInterruptStatusS4 Property

Interrupt Status: S4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInterruptStatus InterruptStatusS4 { get; }
Public ReadOnly Property InterruptStatusS4 As Pcal6408aTypeInterruptStatus
    Get
public:
property Pcal6408aTypeInterruptStatus InterruptStatusS4 {
    Pcal6408aTypeInterruptStatus get ();
}
member InterruptStatusS4 : Pcal6408aTypeInterruptStatus with get

Property Value

Type: Pcal6408aTypeInterruptStatus
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InterruptStatusS5 Property

IRD

Pcal6408aInterruptStatusS5 Property

Interrupt Status: S5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInterruptStatus InterruptStatusS5 { get; }
Public ReadOnly Property InterruptStatusS5 As Pcal6408aTypeInterruptStatus
    Get
public:
property Pcal6408aTypeInterruptStatus InterruptStatusS5 {
    Pcal6408aTypeInterruptStatus get ();
}
member InterruptStatusS5 : Pcal6408aTypeInterruptStatus with get

Property Value

Type: Pcal6408aTypeInterruptStatus
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InterruptStatusS6 Property

IRD

Pcal6408aInterruptStatusS6 Property

Interrupt Status: S6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInterruptStatus InterruptStatusS6 { get; }
Public ReadOnly Property InterruptStatusS6 As Pcal6408aTypeInterruptStatus
    Get
public:
property Pcal6408aTypeInterruptStatus InterruptStatusS6 {
    Pcal6408aTypeInterruptStatus get ();
}
member InterruptStatusS6 : Pcal6408aTypeInterruptStatus with get

Property Value

Type: Pcal6408aTypeInterruptStatus
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.InterruptStatusS7 Property

IRD

Pcal6408aInterruptStatusS7 Property

Interrupt Status: S7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeInterruptStatus InterruptStatusS7 { get; }
Public ReadOnly Property InterruptStatusS7 As Pcal6408aTypeInterruptStatus
    Get
public:
property Pcal6408aTypeInterruptStatus InterruptStatusS7 {
    Pcal6408aTypeInterruptStatus get ();
}
member InterruptStatusS7 : Pcal6408aTypeInterruptStatus with get

Property Value

Type: Pcal6408aTypeInterruptStatus
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.OutputDriveStrengthCC0 Property

IRD

Pcal6408aOutputDriveStrengthCC0 Property

Output Drive Strength: CC0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeOutputDriveStrength OutputDriveStrengthCC0 { get; set; }
Public Property OutputDriveStrengthCC0 As Pcal6408aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6408aTypeOutputDriveStrength OutputDriveStrengthCC0 {
    Pcal6408aTypeOutputDriveStrength get ();
    void set (Pcal6408aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC0 : Pcal6408aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6408aTypeOutputDriveStrength
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.OutputDriveStrengthCC1 Property

IRD

Pcal6408aOutputDriveStrengthCC1 Property

Output Drive Strength: CC1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeOutputDriveStrength OutputDriveStrengthCC1 { get; set; }
Public Property OutputDriveStrengthCC1 As Pcal6408aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6408aTypeOutputDriveStrength OutputDriveStrengthCC1 {
    Pcal6408aTypeOutputDriveStrength get ();
    void set (Pcal6408aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC1 : Pcal6408aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6408aTypeOutputDriveStrength
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.OutputDriveStrengthCC2 Property

IRD

Pcal6408aOutputDriveStrengthCC2 Property

Output Drive Strength: CC2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeOutputDriveStrength OutputDriveStrengthCC2 { get; set; }
Public Property OutputDriveStrengthCC2 As Pcal6408aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6408aTypeOutputDriveStrength OutputDriveStrengthCC2 {
    Pcal6408aTypeOutputDriveStrength get ();
    void set (Pcal6408aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC2 : Pcal6408aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6408aTypeOutputDriveStrength
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.OutputDriveStrengthCC3 Property

IRD

Pcal6408aOutputDriveStrengthCC3 Property

Output Drive Strength: CC3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeOutputDriveStrength OutputDriveStrengthCC3 { get; set; }
Public Property OutputDriveStrengthCC3 As Pcal6408aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6408aTypeOutputDriveStrength OutputDriveStrengthCC3 {
    Pcal6408aTypeOutputDriveStrength get ();
    void set (Pcal6408aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC3 : Pcal6408aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6408aTypeOutputDriveStrength
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.OutputDriveStrengthCC4 Property

IRD

Pcal6408aOutputDriveStrengthCC4 Property

Output Drive Strength: CC4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeOutputDriveStrength OutputDriveStrengthCC4 { get; set; }
Public Property OutputDriveStrengthCC4 As Pcal6408aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6408aTypeOutputDriveStrength OutputDriveStrengthCC4 {
    Pcal6408aTypeOutputDriveStrength get ();
    void set (Pcal6408aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC4 : Pcal6408aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6408aTypeOutputDriveStrength
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.OutputDriveStrengthCC5 Property

IRD

Pcal6408aOutputDriveStrengthCC5 Property

Output Drive Strength: CC5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeOutputDriveStrength OutputDriveStrengthCC5 { get; set; }
Public Property OutputDriveStrengthCC5 As Pcal6408aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6408aTypeOutputDriveStrength OutputDriveStrengthCC5 {
    Pcal6408aTypeOutputDriveStrength get ();
    void set (Pcal6408aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC5 : Pcal6408aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6408aTypeOutputDriveStrength
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.OutputDriveStrengthCC6 Property

IRD

Pcal6408aOutputDriveStrengthCC6 Property

Output Drive Strength: CC6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeOutputDriveStrength OutputDriveStrengthCC6 { get; set; }
Public Property OutputDriveStrengthCC6 As Pcal6408aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6408aTypeOutputDriveStrength OutputDriveStrengthCC6 {
    Pcal6408aTypeOutputDriveStrength get ();
    void set (Pcal6408aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC6 : Pcal6408aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6408aTypeOutputDriveStrength
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.OutputDriveStrengthCC7 Property

IRD

Pcal6408aOutputDriveStrengthCC7 Property

Output Drive Strength: CC7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeOutputDriveStrength OutputDriveStrengthCC7 { get; set; }
Public Property OutputDriveStrengthCC7 As Pcal6408aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6408aTypeOutputDriveStrength OutputDriveStrengthCC7 {
    Pcal6408aTypeOutputDriveStrength get ();
    void set (Pcal6408aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC7 : Pcal6408aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6408aTypeOutputDriveStrength
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.OutputPortConfigurationODEN Property

IRD

Pcal6408aOutputPortConfigurationODEN Property

Output Port Configuration: ODEN

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypeOutputPortConfiguration OutputPortConfigurationODEN { get; set; }
Public Property OutputPortConfigurationODEN As Pcal6408aTypeOutputPortConfiguration
    Get
    Set
public:
property Pcal6408aTypeOutputPortConfiguration OutputPortConfigurationODEN {
    Pcal6408aTypeOutputPortConfiguration get ();
    void set (Pcal6408aTypeOutputPortConfiguration value);
}
member OutputPortConfigurationODEN : Pcal6408aTypeOutputPortConfiguration with get, set

Property Value

Type: Pcal6408aTypeOutputPortConfiguration
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.OutputPortO0 Property

IRD

Pcal6408aOutputPortO0 Property

Output Port: O0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO0 { get; set; }
Public Property OutputPortO0 As Byte
    Get
    Set
public:
property unsigned char OutputPortO0 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.OutputPortO1 Property

IRD

Pcal6408aOutputPortO1 Property

Output Port: O1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO1 { get; set; }
Public Property OutputPortO1 As Byte
    Get
    Set
public:
property unsigned char OutputPortO1 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.OutputPortO2 Property

IRD

Pcal6408aOutputPortO2 Property

Output Port: O2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO2 { get; set; }
Public Property OutputPortO2 As Byte
    Get
    Set
public:
property unsigned char OutputPortO2 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.OutputPortO3 Property

IRD

Pcal6408aOutputPortO3 Property

Output Port: O3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO3 { get; set; }
Public Property OutputPortO3 As Byte
    Get
    Set
public:
property unsigned char OutputPortO3 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.OutputPortO4 Property

IRD

Pcal6408aOutputPortO4 Property

Output Port: O4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO4 { get; set; }
Public Property OutputPortO4 As Byte
    Get
    Set
public:
property unsigned char OutputPortO4 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.OutputPortO5 Property

IRD

Pcal6408aOutputPortO5 Property

Output Port: O5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO5 { get; set; }
Public Property OutputPortO5 As Byte
    Get
    Set
public:
property unsigned char OutputPortO5 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.OutputPortO6 Property

IRD

Pcal6408aOutputPortO6 Property

Output Port: O6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO6 { get; set; }
Public Property OutputPortO6 As Byte
    Get
    Set
public:
property unsigned char OutputPortO6 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.OutputPortO7 Property

IRD

Pcal6408aOutputPortO7 Property

Output Port: O7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO7 { get; set; }
Public Property OutputPortO7 As Byte
    Get
    Set
public:
property unsigned char OutputPortO7 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PolarityInversionN0 Property

IRD

Pcal6408aPolarityInversionN0 Property

Polarity Inversion: N0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePolarityInversion PolarityInversionN0 { get; set; }
Public Property PolarityInversionN0 As Pcal6408aTypePolarityInversion
    Get
    Set
public:
property Pcal6408aTypePolarityInversion PolarityInversionN0 {
    Pcal6408aTypePolarityInversion get ();
    void set (Pcal6408aTypePolarityInversion value);
}
member PolarityInversionN0 : Pcal6408aTypePolarityInversion with get, set

Property Value

Type: Pcal6408aTypePolarityInversion
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PolarityInversionN1 Property

IRD

Pcal6408aPolarityInversionN1 Property

Polarity Inversion: N1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePolarityInversion PolarityInversionN1 { get; set; }
Public Property PolarityInversionN1 As Pcal6408aTypePolarityInversion
    Get
    Set
public:
property Pcal6408aTypePolarityInversion PolarityInversionN1 {
    Pcal6408aTypePolarityInversion get ();
    void set (Pcal6408aTypePolarityInversion value);
}
member PolarityInversionN1 : Pcal6408aTypePolarityInversion with get, set

Property Value

Type: Pcal6408aTypePolarityInversion
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PolarityInversionN2 Property

IRD

Pcal6408aPolarityInversionN2 Property

Polarity Inversion: N2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePolarityInversion PolarityInversionN2 { get; set; }
Public Property PolarityInversionN2 As Pcal6408aTypePolarityInversion
    Get
    Set
public:
property Pcal6408aTypePolarityInversion PolarityInversionN2 {
    Pcal6408aTypePolarityInversion get ();
    void set (Pcal6408aTypePolarityInversion value);
}
member PolarityInversionN2 : Pcal6408aTypePolarityInversion with get, set

Property Value

Type: Pcal6408aTypePolarityInversion
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PolarityInversionN3 Property

IRD

Pcal6408aPolarityInversionN3 Property

Polarity Inversion: N3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePolarityInversion PolarityInversionN3 { get; set; }
Public Property PolarityInversionN3 As Pcal6408aTypePolarityInversion
    Get
    Set
public:
property Pcal6408aTypePolarityInversion PolarityInversionN3 {
    Pcal6408aTypePolarityInversion get ();
    void set (Pcal6408aTypePolarityInversion value);
}
member PolarityInversionN3 : Pcal6408aTypePolarityInversion with get, set

Property Value

Type: Pcal6408aTypePolarityInversion
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PolarityInversionN4 Property

IRD

Pcal6408aPolarityInversionN4 Property

Polarity Inversion: N4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePolarityInversion PolarityInversionN4 { get; set; }
Public Property PolarityInversionN4 As Pcal6408aTypePolarityInversion
    Get
    Set
public:
property Pcal6408aTypePolarityInversion PolarityInversionN4 {
    Pcal6408aTypePolarityInversion get ();
    void set (Pcal6408aTypePolarityInversion value);
}
member PolarityInversionN4 : Pcal6408aTypePolarityInversion with get, set

Property Value

Type: Pcal6408aTypePolarityInversion
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PolarityInversionN5 Property

IRD

Pcal6408aPolarityInversionN5 Property

Polarity Inversion: N5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePolarityInversion PolarityInversionN5 { get; set; }
Public Property PolarityInversionN5 As Pcal6408aTypePolarityInversion
    Get
    Set
public:
property Pcal6408aTypePolarityInversion PolarityInversionN5 {
    Pcal6408aTypePolarityInversion get ();
    void set (Pcal6408aTypePolarityInversion value);
}
member PolarityInversionN5 : Pcal6408aTypePolarityInversion with get, set

Property Value

Type: Pcal6408aTypePolarityInversion
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PolarityInversionN6 Property

IRD

Pcal6408aPolarityInversionN6 Property

Polarity Inversion: N6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePolarityInversion PolarityInversionN6 { get; set; }
Public Property PolarityInversionN6 As Pcal6408aTypePolarityInversion
    Get
    Set
public:
property Pcal6408aTypePolarityInversion PolarityInversionN6 {
    Pcal6408aTypePolarityInversion get ();
    void set (Pcal6408aTypePolarityInversion value);
}
member PolarityInversionN6 : Pcal6408aTypePolarityInversion with get, set

Property Value

Type: Pcal6408aTypePolarityInversion
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PolarityInversionN7 Property

IRD

Pcal6408aPolarityInversionN7 Property

Polarity Inversion: N7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePolarityInversion PolarityInversionN7 { get; set; }
Public Property PolarityInversionN7 As Pcal6408aTypePolarityInversion
    Get
    Set
public:
property Pcal6408aTypePolarityInversion PolarityInversionN7 {
    Pcal6408aTypePolarityInversion get ();
    void set (Pcal6408aTypePolarityInversion value);
}
member PolarityInversionN7 : Pcal6408aTypePolarityInversion with get, set

Property Value

Type: Pcal6408aTypePolarityInversion
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PullUpPullDownEnablePE0 Property

IRD

Pcal6408aPullUpPullDownEnablePE0 Property

Pull-Up/Pull-Down Enable: PE0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePullUpPullDownEnable PullUpPullDownEnablePE0 { get; set; }
Public Property PullUpPullDownEnablePE0 As Pcal6408aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6408aTypePullUpPullDownEnable PullUpPullDownEnablePE0 {
    Pcal6408aTypePullUpPullDownEnable get ();
    void set (Pcal6408aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE0 : Pcal6408aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6408aTypePullUpPullDownEnable
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PullUpPullDownEnablePE1 Property

IRD

Pcal6408aPullUpPullDownEnablePE1 Property

Pull-Up/Pull-Down Enable: PE1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePullUpPullDownEnable PullUpPullDownEnablePE1 { get; set; }
Public Property PullUpPullDownEnablePE1 As Pcal6408aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6408aTypePullUpPullDownEnable PullUpPullDownEnablePE1 {
    Pcal6408aTypePullUpPullDownEnable get ();
    void set (Pcal6408aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE1 : Pcal6408aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6408aTypePullUpPullDownEnable
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PullUpPullDownEnablePE2 Property

IRD

Pcal6408aPullUpPullDownEnablePE2 Property

Pull-Up/Pull-Down Enable: PE2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePullUpPullDownEnable PullUpPullDownEnablePE2 { get; set; }
Public Property PullUpPullDownEnablePE2 As Pcal6408aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6408aTypePullUpPullDownEnable PullUpPullDownEnablePE2 {
    Pcal6408aTypePullUpPullDownEnable get ();
    void set (Pcal6408aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE2 : Pcal6408aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6408aTypePullUpPullDownEnable
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PullUpPullDownEnablePE3 Property

IRD

Pcal6408aPullUpPullDownEnablePE3 Property

Pull-Up/Pull-Down Enable: PE3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePullUpPullDownEnable PullUpPullDownEnablePE3 { get; set; }
Public Property PullUpPullDownEnablePE3 As Pcal6408aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6408aTypePullUpPullDownEnable PullUpPullDownEnablePE3 {
    Pcal6408aTypePullUpPullDownEnable get ();
    void set (Pcal6408aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE3 : Pcal6408aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6408aTypePullUpPullDownEnable
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PullUpPullDownEnablePE4 Property

IRD

Pcal6408aPullUpPullDownEnablePE4 Property

Pull-Up/Pull-Down Enable: PE4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePullUpPullDownEnable PullUpPullDownEnablePE4 { get; set; }
Public Property PullUpPullDownEnablePE4 As Pcal6408aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6408aTypePullUpPullDownEnable PullUpPullDownEnablePE4 {
    Pcal6408aTypePullUpPullDownEnable get ();
    void set (Pcal6408aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE4 : Pcal6408aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6408aTypePullUpPullDownEnable
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PullUpPullDownEnablePE5 Property

IRD

Pcal6408aPullUpPullDownEnablePE5 Property

Pull-Up/Pull-Down Enable: PE5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePullUpPullDownEnable PullUpPullDownEnablePE5 { get; set; }
Public Property PullUpPullDownEnablePE5 As Pcal6408aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6408aTypePullUpPullDownEnable PullUpPullDownEnablePE5 {
    Pcal6408aTypePullUpPullDownEnable get ();
    void set (Pcal6408aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE5 : Pcal6408aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6408aTypePullUpPullDownEnable
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PullUpPullDownEnablePE6 Property

IRD

Pcal6408aPullUpPullDownEnablePE6 Property

Pull-Up/Pull-Down Enable: PE6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePullUpPullDownEnable PullUpPullDownEnablePE6 { get; set; }
Public Property PullUpPullDownEnablePE6 As Pcal6408aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6408aTypePullUpPullDownEnable PullUpPullDownEnablePE6 {
    Pcal6408aTypePullUpPullDownEnable get ();
    void set (Pcal6408aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE6 : Pcal6408aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6408aTypePullUpPullDownEnable
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PullUpPullDownEnablePE7 Property

IRD

Pcal6408aPullUpPullDownEnablePE7 Property

Pull-Up/Pull-Down Enable: PE7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePullUpPullDownEnable PullUpPullDownEnablePE7 { get; set; }
Public Property PullUpPullDownEnablePE7 As Pcal6408aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6408aTypePullUpPullDownEnable PullUpPullDownEnablePE7 {
    Pcal6408aTypePullUpPullDownEnable get ();
    void set (Pcal6408aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE7 : Pcal6408aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6408aTypePullUpPullDownEnable
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PullUpPullDownSelectionPUD0 Property

IRD

Pcal6408aPullUpPullDownSelectionPUD0 Property

Pull-Up/Pull-Down Selection: PUD0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePullUpPullDownSelection PullUpPullDownSelectionPUD0 { get; set; }
Public Property PullUpPullDownSelectionPUD0 As Pcal6408aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6408aTypePullUpPullDownSelection PullUpPullDownSelectionPUD0 {
    Pcal6408aTypePullUpPullDownSelection get ();
    void set (Pcal6408aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD0 : Pcal6408aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6408aTypePullUpPullDownSelection
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PullUpPullDownSelectionPUD1 Property

IRD

Pcal6408aPullUpPullDownSelectionPUD1 Property

Pull-Up/Pull-Down Selection: PUD1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePullUpPullDownSelection PullUpPullDownSelectionPUD1 { get; set; }
Public Property PullUpPullDownSelectionPUD1 As Pcal6408aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6408aTypePullUpPullDownSelection PullUpPullDownSelectionPUD1 {
    Pcal6408aTypePullUpPullDownSelection get ();
    void set (Pcal6408aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD1 : Pcal6408aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6408aTypePullUpPullDownSelection
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PullUpPullDownSelectionPUD2 Property

IRD

Pcal6408aPullUpPullDownSelectionPUD2 Property

Pull-Up/Pull-Down Selection: PUD2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePullUpPullDownSelection PullUpPullDownSelectionPUD2 { get; set; }
Public Property PullUpPullDownSelectionPUD2 As Pcal6408aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6408aTypePullUpPullDownSelection PullUpPullDownSelectionPUD2 {
    Pcal6408aTypePullUpPullDownSelection get ();
    void set (Pcal6408aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD2 : Pcal6408aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6408aTypePullUpPullDownSelection
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PullUpPullDownSelectionPUD3 Property

IRD

Pcal6408aPullUpPullDownSelectionPUD3 Property

Pull-Up/Pull-Down Selection: PUD3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePullUpPullDownSelection PullUpPullDownSelectionPUD3 { get; set; }
Public Property PullUpPullDownSelectionPUD3 As Pcal6408aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6408aTypePullUpPullDownSelection PullUpPullDownSelectionPUD3 {
    Pcal6408aTypePullUpPullDownSelection get ();
    void set (Pcal6408aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD3 : Pcal6408aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6408aTypePullUpPullDownSelection
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PullUpPullDownSelectionPUD4 Property

IRD

Pcal6408aPullUpPullDownSelectionPUD4 Property

Pull-Up/Pull-Down Selection: PUD4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePullUpPullDownSelection PullUpPullDownSelectionPUD4 { get; set; }
Public Property PullUpPullDownSelectionPUD4 As Pcal6408aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6408aTypePullUpPullDownSelection PullUpPullDownSelectionPUD4 {
    Pcal6408aTypePullUpPullDownSelection get ();
    void set (Pcal6408aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD4 : Pcal6408aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6408aTypePullUpPullDownSelection
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PullUpPullDownSelectionPUD5 Property

IRD

Pcal6408aPullUpPullDownSelectionPUD5 Property

Pull-Up/Pull-Down Selection: PUD5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePullUpPullDownSelection PullUpPullDownSelectionPUD5 { get; set; }
Public Property PullUpPullDownSelectionPUD5 As Pcal6408aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6408aTypePullUpPullDownSelection PullUpPullDownSelectionPUD5 {
    Pcal6408aTypePullUpPullDownSelection get ();
    void set (Pcal6408aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD5 : Pcal6408aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6408aTypePullUpPullDownSelection
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PullUpPullDownSelectionPUD6 Property

IRD

Pcal6408aPullUpPullDownSelectionPUD6 Property

Pull-Up/Pull-Down Selection: PUD6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePullUpPullDownSelection PullUpPullDownSelectionPUD6 { get; set; }
Public Property PullUpPullDownSelectionPUD6 As Pcal6408aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6408aTypePullUpPullDownSelection PullUpPullDownSelectionPUD6 {
    Pcal6408aTypePullUpPullDownSelection get ();
    void set (Pcal6408aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD6 : Pcal6408aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6408aTypePullUpPullDownSelection
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.PullUpPullDownSelectionPUD7 Property

IRD

Pcal6408aPullUpPullDownSelectionPUD7 Property

Pull-Up/Pull-Down Selection: PUD7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6408aTypePullUpPullDownSelection PullUpPullDownSelectionPUD7 { get; set; }
Public Property PullUpPullDownSelectionPUD7 As Pcal6408aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6408aTypePullUpPullDownSelection PullUpPullDownSelectionPUD7 {
    Pcal6408aTypePullUpPullDownSelection get ();
    void set (Pcal6408aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD7 : Pcal6408aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6408aTypePullUpPullDownSelection
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a Methods

The Pcal6408a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.Flush Method

IRD

Pcal6408aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcal6408a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6408a.TypeConfiguration Enumeration

IRD

Pcal6408aTypeConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Output | 0 | Output
Input | 1 | Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6408a.TypeInputLatch Enumeration

IRD

Pcal6408aTypeInputLatch Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInputLatch
Public Enumeration TypeInputLatch
public enum class TypeInputLatch
type TypeInputLatch
Members
Member name | Value | Description
NotLatched | 0 | Not Latched
Latched | 1 | Latched
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6408a.TypeInterruptMask Enumeration

IRD

Pcal6408aTypeInterruptMask Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptMask
Public Enumeration TypeInterruptMask
public enum class TypeInterruptMask
type TypeInterruptMask
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6408a.TypeInterruptStatus Enumeration

IRD

Pcal6408aTypeInterruptStatus Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatus
Public Enumeration TypeInterruptStatus
public enum class TypeInterruptStatus
type TypeInterruptStatus
Members
Member name | Value | Description
NotSource | 0 | Not Source
Source | 1 | Source
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6408a.TypeOutputDriveStrength Enumeration

IRD

Pcal6408aTypeOutputDriveStrength Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputDriveStrength
Public Enumeration TypeOutputDriveStrength
public enum class TypeOutputDriveStrength
type TypeOutputDriveStrength
Members
Member name | Value | Description
Value_025x | 0 | 0.25x
Value_05x | 1 | 0.5x
Value_075x | 2 | 0.75x
Value_10x | 3 | 1.0x
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6408a.TypeOutputPortConfiguration Enumeration

IRD

Pcal6408aTypeOutputPortConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputPortConfiguration
Public Enumeration TypeOutputPortConfiguration
public enum class TypeOutputPortConfiguration
type TypeOutputPortConfiguration
Members
Member name | Value | Description
PushPull | 0 | Push-Pull
OpenDrain | 1 | Open-Drain
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6408a.TypePolarityInversion Enumeration

IRD

Pcal6408aTypePolarityInversion Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarityInversion
Public Enumeration TypePolarityInversion
public enum class TypePolarityInversion
type TypePolarityInversion
Members
Member name | Value | Description
NotInverted | 0 | Not Inverted
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6408a.TypePullUpPullDownEnable Enumeration

IRD

Pcal6408aTypePullUpPullDownEnable Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePullUpPullDownEnable
Public Enumeration TypePullUpPullDownEnable
public enum class TypePullUpPullDownEnable
type TypePullUpPullDownEnable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6408a.TypePullUpPullDownSelection Enumeration

IRD

Pcal6408aTypePullUpPullDownSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePullUpPullDownSelection
Public Enumeration TypePullUpPullDownSelection
public enum class TypePullUpPullDownSelection
type TypePullUpPullDownSelection
Members
Member name | Value | Description
Value_100KΩPullDown | 0 | 100 kΩ Pull-Down
Value_100KΩPullUp | 1 | 100 kΩ Pull-Up
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6416a Class

NXP Semiconductors: PCAL 6416A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPcal6416a

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcal6416a
Public Class Pcal6416a
public ref class Pcal6416a
type Pcal6416a =  class end

The Pcal6416a type exposes the following members.

Constructors
 | Name | Description
Public method | Pcal6416a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration: C0.0
Public property | ConfigurationC01 | Configuration: C0.1
Public property | ConfigurationC02 | Configuration: C0.2
Public property | ConfigurationC03 | Configuration: C0.3
Public property | ConfigurationC04 | Configuration: C0.4
Public property | ConfigurationC05 | Configuration: C0.5
Public property | ConfigurationC06 | Configuration: C0.6
Public property | ConfigurationC07 | Configuration: C0.7
Public property | ConfigurationC10 | Configuration: C1.0
Public property | ConfigurationC11 | Configuration: C1.1
Public property | ConfigurationC12 | Configuration: C1.2
Public property | ConfigurationC13 | Configuration: C1.3
Public property | ConfigurationC14 | Configuration: C1.4
Public property | ConfigurationC15 | Configuration: C1.5
Public property | ConfigurationC16 | Configuration: C1.6
Public property | ConfigurationC17 | Configuration: C1.7
Public property | InputLatchL00 | Input Latch: L0.0
Public property | InputLatchL01 | Input Latch: L0.1
Public property | InputLatchL02 | Input Latch: L0.2
Public property | InputLatchL03 | Input Latch: L0.3
Public property | InputLatchL04 | Input Latch: L0.4
Public property | InputLatchL05 | Input Latch: L0.5
Public property | InputLatchL06 | Input Latch: L0.6
Public property | InputLatchL07 | Input Latch: L0.7
Public property | InputLatchL10 | Input Latch: L1.0
Public property | InputLatchL11 | Input Latch: L1.1
Public property | InputLatchL12 | Input Latch: L1.2
Public property | InputLatchL13 | Input Latch: L1.3
Public property | InputLatchL14 | Input Latch: L1.4
Public property | InputLatchL15 | Input Latch: L1.5
Public property | InputLatchL16 | Input Latch: L1.6
Public property | InputLatchL17 | Input Latch: L1.7
Public property | InputPortI00 | Input Port: I0.0
Public property | InputPortI01 | Input Port: I0.1
Public property | InputPortI02 | Input Port: I0.2
Public property | InputPortI03 | Input Port: I0.3
Public property | InputPortI04 | Input Port: I0.4
Public property | InputPortI05 | Input Port: I0.5
Public property | InputPortI06 | Input Port: I0.6
Public property | InputPortI07 | Input Port: I0.7
Public property | InputPortI10 | Input Port: I1.0
Public property | InputPortI11 | Input Port: I1.1
Public property | InputPortI12 | Input Port: I1.2
Public property | InputPortI13 | Input Port: I1.3
Public property | InputPortI14 | Input Port: I1.4
Public property | InputPortI15 | Input Port: I1.5
Public property | InputPortI16 | Input Port: I1.6
Public property | InputPortI17 | Input Port: I1.7
Public property | InterruptMaskM00 | Interrupt Mask: M0.0
Public property | InterruptMaskM01 | Interrupt Mask: M0.1
Public property | InterruptMaskM02 | Interrupt Mask: M0.2
Public property | InterruptMaskM03 | Interrupt Mask: M0.3
Public property | InterruptMaskM04 | Interrupt Mask: M0.4
Public property | InterruptMaskM05 | Interrupt Mask: M0.5
Public property | InterruptMaskM06 | Interrupt Mask: M0.6
Public property | InterruptMaskM07 | Interrupt Mask: M0.7
Public property | InterruptMaskM10 | Interrupt Mask: M1.0
Public property | InterruptMaskM11 | Interrupt Mask: M1.1
Public property | InterruptMaskM12 | Interrupt Mask: M1.2
Public property | InterruptMaskM13 | Interrupt Mask: M1.3
Public property | InterruptMaskM14 | Interrupt Mask: M1.4
Public property | InterruptMaskM15 | Interrupt Mask: M1.5
Public property | InterruptMaskM16 | Interrupt Mask: M1.6
Public property | InterruptMaskM17 | Interrupt Mask: M1.7
Public property | InterruptStatusS00 | Interrupt Status: S0.0
Public property | InterruptStatusS01 | Interrupt Status: S0.1
Public property | InterruptStatusS02 | Interrupt Status: S0.2
Public property | InterruptStatusS03 | Interrupt Status: S0.3
Public property | InterruptStatusS04 | Interrupt Status: S0.4
Public property | InterruptStatusS05 | Interrupt Status: S0.5
Public property | InterruptStatusS06 | Interrupt Status: S0.6
Public property | InterruptStatusS07 | Interrupt Status: S0.7
Public property | InterruptStatusS10 | Interrupt Status: S1.0
Public property | InterruptStatusS11 | Interrupt Status: S1.1
Public property | InterruptStatusS12 | Interrupt Status: S1.2
Public property | InterruptStatusS13 | Interrupt Status: S1.3
Public property | InterruptStatusS14 | Interrupt Status: S1.4
Public property | InterruptStatusS15 | Interrupt Status: S1.5
Public property | InterruptStatusS16 | Interrupt Status: S1.6
Public property | InterruptStatusS17 | Interrupt Status: S1.7
Public property | OutputDriveStrengthCC00 | Output Drive Strength: CC0.0
Public property | OutputDriveStrengthCC01 | Output Drive Strength: CC0.1
Public property | OutputDriveStrengthCC02 | Output Drive Strength: CC0.2
Public property | OutputDriveStrengthCC03 | Output Drive Strength: CC0.3
Public property | OutputDriveStrengthCC04 | Output Drive Strength: CC0.4
Public property | OutputDriveStrengthCC05 | Output Drive Strength: CC0.5
Public property | OutputDriveStrengthCC06 | Output Drive Strength: CC0.6
Public property | OutputDriveStrengthCC07 | Output Drive Strength: CC0.7
Public property | OutputDriveStrengthCC10 | Output Drive Strength: CC1.0
Public property | OutputDriveStrengthCC11 | Output Drive Strength: CC1.1
Public property | OutputDriveStrengthCC12 | Output Drive Strength: CC1.2
Public property | OutputDriveStrengthCC13 | Output Drive Strength: CC1.3
Public property | OutputDriveStrengthCC14 | Output Drive Strength: CC1.4
Public property | OutputDriveStrengthCC15 | Output Drive Strength: CC1.5
Public property | OutputDriveStrengthCC16 | Output Drive Strength: CC1.6
Public property | OutputDriveStrengthCC17 | Output Drive Strength: CC1.7
Public property | OutputPortConfigurationODEN0 | Output Port Configuration: ODEN0
Public property | OutputPortConfigurationODEN1 | Output Port Configuration: ODEN1
Public property | OutputPortO00 | Output Port: O0.0
Public property | OutputPortO01 | Output Port: O0.1
Public property | OutputPortO02 | Output Port: O0.2
Public property | OutputPortO03 | Output Port: O0.3
Public property | OutputPortO04 | Output Port: O0.4
Public property | OutputPortO05 | Output Port: O0.5
Public property | OutputPortO06 | Output Port: O0.6
Public property | OutputPortO07 | Output Port: O0.7
Public property | OutputPortO10 | Output Port: O1.0
Public property | OutputPortO11 | Output Port: O1.1
Public property | OutputPortO12 | Output Port: O1.2
Public property | OutputPortO13 | Output Port: O1.3
Public property | OutputPortO14 | Output Port: O1.4
Public property | OutputPortO15 | Output Port: O1.5
Public property | OutputPortO16 | Output Port: O1.6
Public property | OutputPortO17 | Output Port: O1.7
Public property | PolarityInversionN00 | Polarity Inversion: N0.0
Public property | PolarityInversionN01 | Polarity Inversion: N0.1
Public property | PolarityInversionN02 | Polarity Inversion: N0.2
Public property | PolarityInversionN03 | Polarity Inversion: N0.3
Public property | PolarityInversionN04 | Polarity Inversion: N0.4
Public property | PolarityInversionN05 | Polarity Inversion: N0.5
Public property | PolarityInversionN06 | Polarity Inversion: N0.6
Public property | PolarityInversionN07 | Polarity Inversion: N0.7
Public property | PolarityInversionN10 | Polarity Inversion: N1.0
Public property | PolarityInversionN11 | Polarity Inversion: N1.1
Public property | PolarityInversionN12 | Polarity Inversion: N1.2
Public property | PolarityInversionN13 | Polarity Inversion: N1.3
Public property | PolarityInversionN14 | Polarity Inversion: N1.4
Public property | PolarityInversionN15 | Polarity Inversion: N1.5
Public property | PolarityInversionN16 | Polarity Inversion: N1.6
Public property | PolarityInversionN17 | Polarity Inversion: N1.7
Public property | PullUpPullDownEnablePE00 | Pull-Up/Pull-Down Enable: PE0.0
Public property | PullUpPullDownEnablePE01 | Pull-Up/Pull-Down Enable: PE0.1
Public property | PullUpPullDownEnablePE02 | Pull-Up/Pull-Down Enable: PE0.2
Public property | PullUpPullDownEnablePE03 | Pull-Up/Pull-Down Enable: PE0.3
Public property | PullUpPullDownEnablePE04 | Pull-Up/Pull-Down Enable: PE0.4
Public property | PullUpPullDownEnablePE05 | Pull-Up/Pull-Down Enable: PE0.5
Public property | PullUpPullDownEnablePE06 | Pull-Up/Pull-Down Enable: PE0.6
Public property | PullUpPullDownEnablePE07 | Pull-Up/Pull-Down Enable: PE0.7
Public property | PullUpPullDownEnablePE10 | Pull-Up/Pull-Down Enable: PE1.0
Public property | PullUpPullDownEnablePE11 | Pull-Up/Pull-Down Enable: PE1.1
Public property | PullUpPullDownEnablePE12 | Pull-Up/Pull-Down Enable: PE1.2
Public property | PullUpPullDownEnablePE13 | Pull-Up/Pull-Down Enable: PE1.3
Public property | PullUpPullDownEnablePE14 | Pull-Up/Pull-Down Enable: PE1.4
Public property | PullUpPullDownEnablePE15 | Pull-Up/Pull-Down Enable: PE1.5
Public property | PullUpPullDownEnablePE16 | Pull-Up/Pull-Down Enable: PE1.6
Public property | PullUpPullDownEnablePE17 | Pull-Up/Pull-Down Enable: PE1.7
Public property | PullUpPullDownSelectionPUD00 | Pull-Up/Pull-Down Selection: PUD0.0
Public property | PullUpPullDownSelectionPUD01 | Pull-Up/Pull-Down Selection: PUD0.1
Public property | PullUpPullDownSelectionPUD02 | Pull-Up/Pull-Down Selection: PUD0.2
Public property | PullUpPullDownSelectionPUD03 | Pull-Up/Pull-Down Selection: PUD0.3
Public property | PullUpPullDownSelectionPUD04 | Pull-Up/Pull-Down Selection: PUD0.4
Public property | PullUpPullDownSelectionPUD05 | Pull-Up/Pull-Down Selection: PUD0.5
Public property | PullUpPullDownSelectionPUD06 | Pull-Up/Pull-Down Selection: PUD0.6
Public property | PullUpPullDownSelectionPUD07 | Pull-Up/Pull-Down Selection: PUD0.7
Public property | PullUpPullDownSelectionPUD10 | Pull-Up/Pull-Down Selection: PUD1.0
Public property | PullUpPullDownSelectionPUD11 | Pull-Up/Pull-Down Selection: PUD1.1
Public property | PullUpPullDownSelectionPUD12 | Pull-Up/Pull-Down Selection: PUD1.2
Public property | PullUpPullDownSelectionPUD13 | Pull-Up/Pull-Down Selection: PUD1.3
Public property | PullUpPullDownSelectionPUD14 | Pull-Up/Pull-Down Selection: PUD1.4
Public property | PullUpPullDownSelectionPUD15 | Pull-Up/Pull-Down Selection: PUD1.5
Public property | PullUpPullDownSelectionPUD16 | Pull-Up/Pull-Down Selection: PUD1.6
Public property | PullUpPullDownSelectionPUD17 | Pull-Up/Pull-Down Selection: PUD1.7
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Voltage Translating 16-Bit I2C-Bus/SMBus I/O Expander With Interrupt Output, Reset, And Configuration Registers
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6416a Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcal6416a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcal6416a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a Properties

The Pcal6416a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration: C0.0
Public property | ConfigurationC01 | Configuration: C0.1
Public property | ConfigurationC02 | Configuration: C0.2
Public property | ConfigurationC03 | Configuration: C0.3
Public property | ConfigurationC04 | Configuration: C0.4
Public property | ConfigurationC05 | Configuration: C0.5
Public property | ConfigurationC06 | Configuration: C0.6
Public property | ConfigurationC07 | Configuration: C0.7
Public property | ConfigurationC10 | Configuration: C1.0
Public property | ConfigurationC11 | Configuration: C1.1
Public property | ConfigurationC12 | Configuration: C1.2
Public property | ConfigurationC13 | Configuration: C1.3
Public property | ConfigurationC14 | Configuration: C1.4
Public property | ConfigurationC15 | Configuration: C1.5
Public property | ConfigurationC16 | Configuration: C1.6
Public property | ConfigurationC17 | Configuration: C1.7
Public property | InputLatchL00 | Input Latch: L0.0
Public property | InputLatchL01 | Input Latch: L0.1
Public property | InputLatchL02 | Input Latch: L0.2
Public property | InputLatchL03 | Input Latch: L0.3
Public property | InputLatchL04 | Input Latch: L0.4
Public property | InputLatchL05 | Input Latch: L0.5
Public property | InputLatchL06 | Input Latch: L0.6
Public property | InputLatchL07 | Input Latch: L0.7
Public property | InputLatchL10 | Input Latch: L1.0
Public property | InputLatchL11 | Input Latch: L1.1
Public property | InputLatchL12 | Input Latch: L1.2
Public property | InputLatchL13 | Input Latch: L1.3
Public property | InputLatchL14 | Input Latch: L1.4
Public property | InputLatchL15 | Input Latch: L1.5
Public property | InputLatchL16 | Input Latch: L1.6
Public property | InputLatchL17 | Input Latch: L1.7
Public property | InputPortI00 | Input Port: I0.0
Public property | InputPortI01 | Input Port: I0.1
Public property | InputPortI02 | Input Port: I0.2
Public property | InputPortI03 | Input Port: I0.3
Public property | InputPortI04 | Input Port: I0.4
Public property | InputPortI05 | Input Port: I0.5
Public property | InputPortI06 | Input Port: I0.6
Public property | InputPortI07 | Input Port: I0.7
Public property | InputPortI10 | Input Port: I1.0
Public property | InputPortI11 | Input Port: I1.1
Public property | InputPortI12 | Input Port: I1.2
Public property | InputPortI13 | Input Port: I1.3
Public property | InputPortI14 | Input Port: I1.4
Public property | InputPortI15 | Input Port: I1.5
Public property | InputPortI16 | Input Port: I1.6
Public property | InputPortI17 | Input Port: I1.7
Public property | InterruptMaskM00 | Interrupt Mask: M0.0
Public property | InterruptMaskM01 | Interrupt Mask: M0.1
Public property | InterruptMaskM02 | Interrupt Mask: M0.2
Public property | InterruptMaskM03 | Interrupt Mask: M0.3
Public property | InterruptMaskM04 | Interrupt Mask: M0.4
Public property | InterruptMaskM05 | Interrupt Mask: M0.5
Public property | InterruptMaskM06 | Interrupt Mask: M0.6
Public property | InterruptMaskM07 | Interrupt Mask: M0.7
Public property | InterruptMaskM10 | Interrupt Mask: M1.0
Public property | InterruptMaskM11 | Interrupt Mask: M1.1
Public property | InterruptMaskM12 | Interrupt Mask: M1.2
Public property | InterruptMaskM13 | Interrupt Mask: M1.3
Public property | InterruptMaskM14 | Interrupt Mask: M1.4
Public property | InterruptMaskM15 | Interrupt Mask: M1.5
Public property | InterruptMaskM16 | Interrupt Mask: M1.6
Public property | InterruptMaskM17 | Interrupt Mask: M1.7
Public property | InterruptStatusS00 | Interrupt Status: S0.0
Public property | InterruptStatusS01 | Interrupt Status: S0.1
Public property | InterruptStatusS02 | Interrupt Status: S0.2
Public property | InterruptStatusS03 | Interrupt Status: S0.3
Public property | InterruptStatusS04 | Interrupt Status: S0.4
Public property | InterruptStatusS05 | Interrupt Status: S0.5
Public property | InterruptStatusS06 | Interrupt Status: S0.6
Public property | InterruptStatusS07 | Interrupt Status: S0.7
Public property | InterruptStatusS10 | Interrupt Status: S1.0
Public property | InterruptStatusS11 | Interrupt Status: S1.1
Public property | InterruptStatusS12 | Interrupt Status: S1.2
Public property | InterruptStatusS13 | Interrupt Status: S1.3
Public property | InterruptStatusS14 | Interrupt Status: S1.4
Public property | InterruptStatusS15 | Interrupt Status: S1.5
Public property | InterruptStatusS16 | Interrupt Status: S1.6
Public property | InterruptStatusS17 | Interrupt Status: S1.7
Public property | OutputDriveStrengthCC00 | Output Drive Strength: CC0.0
Public property | OutputDriveStrengthCC01 | Output Drive Strength: CC0.1
Public property | OutputDriveStrengthCC02 | Output Drive Strength: CC0.2
Public property | OutputDriveStrengthCC03 | Output Drive Strength: CC0.3
Public property | OutputDriveStrengthCC04 | Output Drive Strength: CC0.4
Public property | OutputDriveStrengthCC05 | Output Drive Strength: CC0.5
Public property | OutputDriveStrengthCC06 | Output Drive Strength: CC0.6
Public property | OutputDriveStrengthCC07 | Output Drive Strength: CC0.7
Public property | OutputDriveStrengthCC10 | Output Drive Strength: CC1.0
Public property | OutputDriveStrengthCC11 | Output Drive Strength: CC1.1
Public property | OutputDriveStrengthCC12 | Output Drive Strength: CC1.2
Public property | OutputDriveStrengthCC13 | Output Drive Strength: CC1.3
Public property | OutputDriveStrengthCC14 | Output Drive Strength: CC1.4
Public property | OutputDriveStrengthCC15 | Output Drive Strength: CC1.5
Public property | OutputDriveStrengthCC16 | Output Drive Strength: CC1.6
Public property | OutputDriveStrengthCC17 | Output Drive Strength: CC1.7
Public property | OutputPortConfigurationODEN0 | Output Port Configuration: ODEN0
Public property | OutputPortConfigurationODEN1 | Output Port Configuration: ODEN1
Public property | OutputPortO00 | Output Port: O0.0
Public property | OutputPortO01 | Output Port: O0.1
Public property | OutputPortO02 | Output Port: O0.2
Public property | OutputPortO03 | Output Port: O0.3
Public property | OutputPortO04 | Output Port: O0.4
Public property | OutputPortO05 | Output Port: O0.5
Public property | OutputPortO06 | Output Port: O0.6
Public property | OutputPortO07 | Output Port: O0.7
Public property | OutputPortO10 | Output Port: O1.0
Public property | OutputPortO11 | Output Port: O1.1
Public property | OutputPortO12 | Output Port: O1.2
Public property | OutputPortO13 | Output Port: O1.3
Public property | OutputPortO14 | Output Port: O1.4
Public property | OutputPortO15 | Output Port: O1.5
Public property | OutputPortO16 | Output Port: O1.6
Public property | OutputPortO17 | Output Port: O1.7
Public property | PolarityInversionN00 | Polarity Inversion: N0.0
Public property | PolarityInversionN01 | Polarity Inversion: N0.1
Public property | PolarityInversionN02 | Polarity Inversion: N0.2
Public property | PolarityInversionN03 | Polarity Inversion: N0.3
Public property | PolarityInversionN04 | Polarity Inversion: N0.4
Public property | PolarityInversionN05 | Polarity Inversion: N0.5
Public property | PolarityInversionN06 | Polarity Inversion: N0.6
Public property | PolarityInversionN07 | Polarity Inversion: N0.7
Public property | PolarityInversionN10 | Polarity Inversion: N1.0
Public property | PolarityInversionN11 | Polarity Inversion: N1.1
Public property | PolarityInversionN12 | Polarity Inversion: N1.2
Public property | PolarityInversionN13 | Polarity Inversion: N1.3
Public property | PolarityInversionN14 | Polarity Inversion: N1.4
Public property | PolarityInversionN15 | Polarity Inversion: N1.5
Public property | PolarityInversionN16 | Polarity Inversion: N1.6
Public property | PolarityInversionN17 | Polarity Inversion: N1.7
Public property | PullUpPullDownEnablePE00 | Pull-Up/Pull-Down Enable: PE0.0
Public property | PullUpPullDownEnablePE01 | Pull-Up/Pull-Down Enable: PE0.1
Public property | PullUpPullDownEnablePE02 | Pull-Up/Pull-Down Enable: PE0.2
Public property | PullUpPullDownEnablePE03 | Pull-Up/Pull-Down Enable: PE0.3
Public property | PullUpPullDownEnablePE04 | Pull-Up/Pull-Down Enable: PE0.4
Public property | PullUpPullDownEnablePE05 | Pull-Up/Pull-Down Enable: PE0.5
Public property | PullUpPullDownEnablePE06 | Pull-Up/Pull-Down Enable: PE0.6
Public property | PullUpPullDownEnablePE07 | Pull-Up/Pull-Down Enable: PE0.7
Public property | PullUpPullDownEnablePE10 | Pull-Up/Pull-Down Enable: PE1.0
Public property | PullUpPullDownEnablePE11 | Pull-Up/Pull-Down Enable: PE1.1
Public property | PullUpPullDownEnablePE12 | Pull-Up/Pull-Down Enable: PE1.2
Public property | PullUpPullDownEnablePE13 | Pull-Up/Pull-Down Enable: PE1.3
Public property | PullUpPullDownEnablePE14 | Pull-Up/Pull-Down Enable: PE1.4
Public property | PullUpPullDownEnablePE15 | Pull-Up/Pull-Down Enable: PE1.5
Public property | PullUpPullDownEnablePE16 | Pull-Up/Pull-Down Enable: PE1.6
Public property | PullUpPullDownEnablePE17 | Pull-Up/Pull-Down Enable: PE1.7
Public property | PullUpPullDownSelectionPUD00 | Pull-Up/Pull-Down Selection: PUD0.0
Public property | PullUpPullDownSelectionPUD01 | Pull-Up/Pull-Down Selection: PUD0.1
Public property | PullUpPullDownSelectionPUD02 | Pull-Up/Pull-Down Selection: PUD0.2
Public property | PullUpPullDownSelectionPUD03 | Pull-Up/Pull-Down Selection: PUD0.3
Public property | PullUpPullDownSelectionPUD04 | Pull-Up/Pull-Down Selection: PUD0.4
Public property | PullUpPullDownSelectionPUD05 | Pull-Up/Pull-Down Selection: PUD0.5
Public property | PullUpPullDownSelectionPUD06 | Pull-Up/Pull-Down Selection: PUD0.6
Public property | PullUpPullDownSelectionPUD07 | Pull-Up/Pull-Down Selection: PUD0.7
Public property | PullUpPullDownSelectionPUD10 | Pull-Up/Pull-Down Selection: PUD1.0
Public property | PullUpPullDownSelectionPUD11 | Pull-Up/Pull-Down Selection: PUD1.1
Public property | PullUpPullDownSelectionPUD12 | Pull-Up/Pull-Down Selection: PUD1.2
Public property | PullUpPullDownSelectionPUD13 | Pull-Up/Pull-Down Selection: PUD1.3
Public property | PullUpPullDownSelectionPUD14 | Pull-Up/Pull-Down Selection: PUD1.4
Public property | PullUpPullDownSelectionPUD15 | Pull-Up/Pull-Down Selection: PUD1.5
Public property | PullUpPullDownSelectionPUD16 | Pull-Up/Pull-Down Selection: PUD1.6
Public property | PullUpPullDownSelectionPUD17 | Pull-Up/Pull-Down Selection: PUD1.7
Top
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.AutoFlush Property

IRD

Pcal6416aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.ConfigurationC00 Property

IRD

Pcal6416aConfigurationC00 Property

Configuration: C0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeConfiguration ConfigurationC00 { get; set; }
Public Property ConfigurationC00 As Pcal6416aTypeConfiguration
    Get
    Set
public:
property Pcal6416aTypeConfiguration ConfigurationC00 {
    Pcal6416aTypeConfiguration get ();
    void set (Pcal6416aTypeConfiguration value);
}
member ConfigurationC00 : Pcal6416aTypeConfiguration with get, set

Property Value

Type: Pcal6416aTypeConfiguration
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.ConfigurationC01 Property

IRD

Pcal6416aConfigurationC01 Property

Configuration: C0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeConfiguration ConfigurationC01 { get; set; }
Public Property ConfigurationC01 As Pcal6416aTypeConfiguration
    Get
    Set
public:
property Pcal6416aTypeConfiguration ConfigurationC01 {
    Pcal6416aTypeConfiguration get ();
    void set (Pcal6416aTypeConfiguration value);
}
member ConfigurationC01 : Pcal6416aTypeConfiguration with get, set

Property Value

Type: Pcal6416aTypeConfiguration
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.ConfigurationC02 Property

IRD

Pcal6416aConfigurationC02 Property

Configuration: C0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeConfiguration ConfigurationC02 { get; set; }
Public Property ConfigurationC02 As Pcal6416aTypeConfiguration
    Get
    Set
public:
property Pcal6416aTypeConfiguration ConfigurationC02 {
    Pcal6416aTypeConfiguration get ();
    void set (Pcal6416aTypeConfiguration value);
}
member ConfigurationC02 : Pcal6416aTypeConfiguration with get, set

Property Value

Type: Pcal6416aTypeConfiguration
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.ConfigurationC03 Property

IRD

Pcal6416aConfigurationC03 Property

Configuration: C0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeConfiguration ConfigurationC03 { get; set; }
Public Property ConfigurationC03 As Pcal6416aTypeConfiguration
    Get
    Set
public:
property Pcal6416aTypeConfiguration ConfigurationC03 {
    Pcal6416aTypeConfiguration get ();
    void set (Pcal6416aTypeConfiguration value);
}
member ConfigurationC03 : Pcal6416aTypeConfiguration with get, set

Property Value

Type: Pcal6416aTypeConfiguration
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.ConfigurationC04 Property

IRD

Pcal6416aConfigurationC04 Property

Configuration: C0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeConfiguration ConfigurationC04 { get; set; }
Public Property ConfigurationC04 As Pcal6416aTypeConfiguration
    Get
    Set
public:
property Pcal6416aTypeConfiguration ConfigurationC04 {
    Pcal6416aTypeConfiguration get ();
    void set (Pcal6416aTypeConfiguration value);
}
member ConfigurationC04 : Pcal6416aTypeConfiguration with get, set

Property Value

Type: Pcal6416aTypeConfiguration
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.ConfigurationC05 Property

IRD

Pcal6416aConfigurationC05 Property

Configuration: C0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeConfiguration ConfigurationC05 { get; set; }
Public Property ConfigurationC05 As Pcal6416aTypeConfiguration
    Get
    Set
public:
property Pcal6416aTypeConfiguration ConfigurationC05 {
    Pcal6416aTypeConfiguration get ();
    void set (Pcal6416aTypeConfiguration value);
}
member ConfigurationC05 : Pcal6416aTypeConfiguration with get, set

Property Value

Type: Pcal6416aTypeConfiguration
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.ConfigurationC06 Property

IRD

Pcal6416aConfigurationC06 Property

Configuration: C0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeConfiguration ConfigurationC06 { get; set; }
Public Property ConfigurationC06 As Pcal6416aTypeConfiguration
    Get
    Set
public:
property Pcal6416aTypeConfiguration ConfigurationC06 {
    Pcal6416aTypeConfiguration get ();
    void set (Pcal6416aTypeConfiguration value);
}
member ConfigurationC06 : Pcal6416aTypeConfiguration with get, set

Property Value

Type: Pcal6416aTypeConfiguration
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.ConfigurationC07 Property

IRD

Pcal6416aConfigurationC07 Property

Configuration: C0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeConfiguration ConfigurationC07 { get; set; }
Public Property ConfigurationC07 As Pcal6416aTypeConfiguration
    Get
    Set
public:
property Pcal6416aTypeConfiguration ConfigurationC07 {
    Pcal6416aTypeConfiguration get ();
    void set (Pcal6416aTypeConfiguration value);
}
member ConfigurationC07 : Pcal6416aTypeConfiguration with get, set

Property Value

Type: Pcal6416aTypeConfiguration
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.ConfigurationC10 Property

IRD

Pcal6416aConfigurationC10 Property

Configuration: C1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeConfiguration ConfigurationC10 { get; set; }
Public Property ConfigurationC10 As Pcal6416aTypeConfiguration
    Get
    Set
public:
property Pcal6416aTypeConfiguration ConfigurationC10 {
    Pcal6416aTypeConfiguration get ();
    void set (Pcal6416aTypeConfiguration value);
}
member ConfigurationC10 : Pcal6416aTypeConfiguration with get, set

Property Value

Type: Pcal6416aTypeConfiguration
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.ConfigurationC11 Property

IRD

Pcal6416aConfigurationC11 Property

Configuration: C1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeConfiguration ConfigurationC11 { get; set; }
Public Property ConfigurationC11 As Pcal6416aTypeConfiguration
    Get
    Set
public:
property Pcal6416aTypeConfiguration ConfigurationC11 {
    Pcal6416aTypeConfiguration get ();
    void set (Pcal6416aTypeConfiguration value);
}
member ConfigurationC11 : Pcal6416aTypeConfiguration with get, set

Property Value

Type: Pcal6416aTypeConfiguration
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.ConfigurationC12 Property

IRD

Pcal6416aConfigurationC12 Property

Configuration: C1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeConfiguration ConfigurationC12 { get; set; }
Public Property ConfigurationC12 As Pcal6416aTypeConfiguration
    Get
    Set
public:
property Pcal6416aTypeConfiguration ConfigurationC12 {
    Pcal6416aTypeConfiguration get ();
    void set (Pcal6416aTypeConfiguration value);
}
member ConfigurationC12 : Pcal6416aTypeConfiguration with get, set

Property Value

Type: Pcal6416aTypeConfiguration
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.ConfigurationC13 Property

IRD

Pcal6416aConfigurationC13 Property

Configuration: C1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeConfiguration ConfigurationC13 { get; set; }
Public Property ConfigurationC13 As Pcal6416aTypeConfiguration
    Get
    Set
public:
property Pcal6416aTypeConfiguration ConfigurationC13 {
    Pcal6416aTypeConfiguration get ();
    void set (Pcal6416aTypeConfiguration value);
}
member ConfigurationC13 : Pcal6416aTypeConfiguration with get, set

Property Value

Type: Pcal6416aTypeConfiguration
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.ConfigurationC14 Property

IRD

Pcal6416aConfigurationC14 Property

Configuration: C1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeConfiguration ConfigurationC14 { get; set; }
Public Property ConfigurationC14 As Pcal6416aTypeConfiguration
    Get
    Set
public:
property Pcal6416aTypeConfiguration ConfigurationC14 {
    Pcal6416aTypeConfiguration get ();
    void set (Pcal6416aTypeConfiguration value);
}
member ConfigurationC14 : Pcal6416aTypeConfiguration with get, set

Property Value

Type: Pcal6416aTypeConfiguration
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.ConfigurationC15 Property

IRD

Pcal6416aConfigurationC15 Property

Configuration: C1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeConfiguration ConfigurationC15 { get; set; }
Public Property ConfigurationC15 As Pcal6416aTypeConfiguration
    Get
    Set
public:
property Pcal6416aTypeConfiguration ConfigurationC15 {
    Pcal6416aTypeConfiguration get ();
    void set (Pcal6416aTypeConfiguration value);
}
member ConfigurationC15 : Pcal6416aTypeConfiguration with get, set

Property Value

Type: Pcal6416aTypeConfiguration
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.ConfigurationC16 Property

IRD

Pcal6416aConfigurationC16 Property

Configuration: C1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeConfiguration ConfigurationC16 { get; set; }
Public Property ConfigurationC16 As Pcal6416aTypeConfiguration
    Get
    Set
public:
property Pcal6416aTypeConfiguration ConfigurationC16 {
    Pcal6416aTypeConfiguration get ();
    void set (Pcal6416aTypeConfiguration value);
}
member ConfigurationC16 : Pcal6416aTypeConfiguration with get, set

Property Value

Type: Pcal6416aTypeConfiguration
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.ConfigurationC17 Property

IRD

Pcal6416aConfigurationC17 Property

Configuration: C1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeConfiguration ConfigurationC17 { get; set; }
Public Property ConfigurationC17 As Pcal6416aTypeConfiguration
    Get
    Set
public:
property Pcal6416aTypeConfiguration ConfigurationC17 {
    Pcal6416aTypeConfiguration get ();
    void set (Pcal6416aTypeConfiguration value);
}
member ConfigurationC17 : Pcal6416aTypeConfiguration with get, set

Property Value

Type: Pcal6416aTypeConfiguration
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputLatchL00 Property

IRD

Pcal6416aInputLatchL00 Property

Input Latch: L0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInputLatch InputLatchL00 { get; set; }
Public Property InputLatchL00 As Pcal6416aTypeInputLatch
    Get
    Set
public:
property Pcal6416aTypeInputLatch InputLatchL00 {
    Pcal6416aTypeInputLatch get ();
    void set (Pcal6416aTypeInputLatch value);
}
member InputLatchL00 : Pcal6416aTypeInputLatch with get, set

Property Value

Type: Pcal6416aTypeInputLatch
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputLatchL01 Property

IRD

Pcal6416aInputLatchL01 Property

Input Latch: L0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInputLatch InputLatchL01 { get; set; }
Public Property InputLatchL01 As Pcal6416aTypeInputLatch
    Get
    Set
public:
property Pcal6416aTypeInputLatch InputLatchL01 {
    Pcal6416aTypeInputLatch get ();
    void set (Pcal6416aTypeInputLatch value);
}
member InputLatchL01 : Pcal6416aTypeInputLatch with get, set

Property Value

Type: Pcal6416aTypeInputLatch
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputLatchL02 Property

IRD

Pcal6416aInputLatchL02 Property

Input Latch: L0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInputLatch InputLatchL02 { get; set; }
Public Property InputLatchL02 As Pcal6416aTypeInputLatch
    Get
    Set
public:
property Pcal6416aTypeInputLatch InputLatchL02 {
    Pcal6416aTypeInputLatch get ();
    void set (Pcal6416aTypeInputLatch value);
}
member InputLatchL02 : Pcal6416aTypeInputLatch with get, set

Property Value

Type: Pcal6416aTypeInputLatch
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputLatchL03 Property

IRD

Pcal6416aInputLatchL03 Property

Input Latch: L0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInputLatch InputLatchL03 { get; set; }
Public Property InputLatchL03 As Pcal6416aTypeInputLatch
    Get
    Set
public:
property Pcal6416aTypeInputLatch InputLatchL03 {
    Pcal6416aTypeInputLatch get ();
    void set (Pcal6416aTypeInputLatch value);
}
member InputLatchL03 : Pcal6416aTypeInputLatch with get, set

Property Value

Type: Pcal6416aTypeInputLatch
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputLatchL04 Property

IRD

Pcal6416aInputLatchL04 Property

Input Latch: L0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInputLatch InputLatchL04 { get; set; }
Public Property InputLatchL04 As Pcal6416aTypeInputLatch
    Get
    Set
public:
property Pcal6416aTypeInputLatch InputLatchL04 {
    Pcal6416aTypeInputLatch get ();
    void set (Pcal6416aTypeInputLatch value);
}
member InputLatchL04 : Pcal6416aTypeInputLatch with get, set

Property Value

Type: Pcal6416aTypeInputLatch
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputLatchL05 Property

IRD

Pcal6416aInputLatchL05 Property

Input Latch: L0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInputLatch InputLatchL05 { get; set; }
Public Property InputLatchL05 As Pcal6416aTypeInputLatch
    Get
    Set
public:
property Pcal6416aTypeInputLatch InputLatchL05 {
    Pcal6416aTypeInputLatch get ();
    void set (Pcal6416aTypeInputLatch value);
}
member InputLatchL05 : Pcal6416aTypeInputLatch with get, set

Property Value

Type: Pcal6416aTypeInputLatch
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputLatchL06 Property

IRD

Pcal6416aInputLatchL06 Property

Input Latch: L0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInputLatch InputLatchL06 { get; set; }
Public Property InputLatchL06 As Pcal6416aTypeInputLatch
    Get
    Set
public:
property Pcal6416aTypeInputLatch InputLatchL06 {
    Pcal6416aTypeInputLatch get ();
    void set (Pcal6416aTypeInputLatch value);
}
member InputLatchL06 : Pcal6416aTypeInputLatch with get, set

Property Value

Type: Pcal6416aTypeInputLatch
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputLatchL07 Property

IRD

Pcal6416aInputLatchL07 Property

Input Latch: L0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInputLatch InputLatchL07 { get; set; }
Public Property InputLatchL07 As Pcal6416aTypeInputLatch
    Get
    Set
public:
property Pcal6416aTypeInputLatch InputLatchL07 {
    Pcal6416aTypeInputLatch get ();
    void set (Pcal6416aTypeInputLatch value);
}
member InputLatchL07 : Pcal6416aTypeInputLatch with get, set

Property Value

Type: Pcal6416aTypeInputLatch
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputLatchL10 Property

IRD

Pcal6416aInputLatchL10 Property

Input Latch: L1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInputLatch InputLatchL10 { get; set; }
Public Property InputLatchL10 As Pcal6416aTypeInputLatch
    Get
    Set
public:
property Pcal6416aTypeInputLatch InputLatchL10 {
    Pcal6416aTypeInputLatch get ();
    void set (Pcal6416aTypeInputLatch value);
}
member InputLatchL10 : Pcal6416aTypeInputLatch with get, set

Property Value

Type: Pcal6416aTypeInputLatch
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputLatchL11 Property

IRD

Pcal6416aInputLatchL11 Property

Input Latch: L1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInputLatch InputLatchL11 { get; set; }
Public Property InputLatchL11 As Pcal6416aTypeInputLatch
    Get
    Set
public:
property Pcal6416aTypeInputLatch InputLatchL11 {
    Pcal6416aTypeInputLatch get ();
    void set (Pcal6416aTypeInputLatch value);
}
member InputLatchL11 : Pcal6416aTypeInputLatch with get, set

Property Value

Type: Pcal6416aTypeInputLatch
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputLatchL12 Property

IRD

Pcal6416aInputLatchL12 Property

Input Latch: L1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInputLatch InputLatchL12 { get; set; }
Public Property InputLatchL12 As Pcal6416aTypeInputLatch
    Get
    Set
public:
property Pcal6416aTypeInputLatch InputLatchL12 {
    Pcal6416aTypeInputLatch get ();
    void set (Pcal6416aTypeInputLatch value);
}
member InputLatchL12 : Pcal6416aTypeInputLatch with get, set

Property Value

Type: Pcal6416aTypeInputLatch
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputLatchL13 Property

IRD

Pcal6416aInputLatchL13 Property

Input Latch: L1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInputLatch InputLatchL13 { get; set; }
Public Property InputLatchL13 As Pcal6416aTypeInputLatch
    Get
    Set
public:
property Pcal6416aTypeInputLatch InputLatchL13 {
    Pcal6416aTypeInputLatch get ();
    void set (Pcal6416aTypeInputLatch value);
}
member InputLatchL13 : Pcal6416aTypeInputLatch with get, set

Property Value

Type: Pcal6416aTypeInputLatch
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputLatchL14 Property

IRD

Pcal6416aInputLatchL14 Property

Input Latch: L1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInputLatch InputLatchL14 { get; set; }
Public Property InputLatchL14 As Pcal6416aTypeInputLatch
    Get
    Set
public:
property Pcal6416aTypeInputLatch InputLatchL14 {
    Pcal6416aTypeInputLatch get ();
    void set (Pcal6416aTypeInputLatch value);
}
member InputLatchL14 : Pcal6416aTypeInputLatch with get, set

Property Value

Type: Pcal6416aTypeInputLatch
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputLatchL15 Property

IRD

Pcal6416aInputLatchL15 Property

Input Latch: L1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInputLatch InputLatchL15 { get; set; }
Public Property InputLatchL15 As Pcal6416aTypeInputLatch
    Get
    Set
public:
property Pcal6416aTypeInputLatch InputLatchL15 {
    Pcal6416aTypeInputLatch get ();
    void set (Pcal6416aTypeInputLatch value);
}
member InputLatchL15 : Pcal6416aTypeInputLatch with get, set

Property Value

Type: Pcal6416aTypeInputLatch
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputLatchL16 Property

IRD

Pcal6416aInputLatchL16 Property

Input Latch: L1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInputLatch InputLatchL16 { get; set; }
Public Property InputLatchL16 As Pcal6416aTypeInputLatch
    Get
    Set
public:
property Pcal6416aTypeInputLatch InputLatchL16 {
    Pcal6416aTypeInputLatch get ();
    void set (Pcal6416aTypeInputLatch value);
}
member InputLatchL16 : Pcal6416aTypeInputLatch with get, set

Property Value

Type: Pcal6416aTypeInputLatch
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputLatchL17 Property

IRD

Pcal6416aInputLatchL17 Property

Input Latch: L1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInputLatch InputLatchL17 { get; set; }
Public Property InputLatchL17 As Pcal6416aTypeInputLatch
    Get
    Set
public:
property Pcal6416aTypeInputLatch InputLatchL17 {
    Pcal6416aTypeInputLatch get ();
    void set (Pcal6416aTypeInputLatch value);
}
member InputLatchL17 : Pcal6416aTypeInputLatch with get, set

Property Value

Type: Pcal6416aTypeInputLatch
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputPortI00 Property

IRD

Pcal6416aInputPortI00 Property

Input Port: I0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI00 { get; }
Public ReadOnly Property InputPortI00 As Byte
    Get
public:
property unsigned char InputPortI00 {
    unsigned char get ();
}
member InputPortI00 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputPortI01 Property

IRD

Pcal6416aInputPortI01 Property

Input Port: I0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI01 { get; }
Public ReadOnly Property InputPortI01 As Byte
    Get
public:
property unsigned char InputPortI01 {
    unsigned char get ();
}
member InputPortI01 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputPortI02 Property

IRD

Pcal6416aInputPortI02 Property

Input Port: I0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI02 { get; }
Public ReadOnly Property InputPortI02 As Byte
    Get
public:
property unsigned char InputPortI02 {
    unsigned char get ();
}
member InputPortI02 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputPortI03 Property

IRD

Pcal6416aInputPortI03 Property

Input Port: I0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI03 { get; }
Public ReadOnly Property InputPortI03 As Byte
    Get
public:
property unsigned char InputPortI03 {
    unsigned char get ();
}
member InputPortI03 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputPortI04 Property

IRD

Pcal6416aInputPortI04 Property

Input Port: I0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI04 { get; }
Public ReadOnly Property InputPortI04 As Byte
    Get
public:
property unsigned char InputPortI04 {
    unsigned char get ();
}
member InputPortI04 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputPortI05 Property

IRD

Pcal6416aInputPortI05 Property

Input Port: I0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI05 { get; }
Public ReadOnly Property InputPortI05 As Byte
    Get
public:
property unsigned char InputPortI05 {
    unsigned char get ();
}
member InputPortI05 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputPortI06 Property

IRD

Pcal6416aInputPortI06 Property

Input Port: I0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI06 { get; }
Public ReadOnly Property InputPortI06 As Byte
    Get
public:
property unsigned char InputPortI06 {
    unsigned char get ();
}
member InputPortI06 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputPortI07 Property

IRD

Pcal6416aInputPortI07 Property

Input Port: I0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI07 { get; }
Public ReadOnly Property InputPortI07 As Byte
    Get
public:
property unsigned char InputPortI07 {
    unsigned char get ();
}
member InputPortI07 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputPortI10 Property

IRD

Pcal6416aInputPortI10 Property

Input Port: I1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI10 { get; }
Public ReadOnly Property InputPortI10 As Byte
    Get
public:
property unsigned char InputPortI10 {
    unsigned char get ();
}
member InputPortI10 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputPortI11 Property

IRD

Pcal6416aInputPortI11 Property

Input Port: I1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI11 { get; }
Public ReadOnly Property InputPortI11 As Byte
    Get
public:
property unsigned char InputPortI11 {
    unsigned char get ();
}
member InputPortI11 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputPortI12 Property

IRD

Pcal6416aInputPortI12 Property

Input Port: I1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI12 { get; }
Public ReadOnly Property InputPortI12 As Byte
    Get
public:
property unsigned char InputPortI12 {
    unsigned char get ();
}
member InputPortI12 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputPortI13 Property

IRD

Pcal6416aInputPortI13 Property

Input Port: I1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI13 { get; }
Public ReadOnly Property InputPortI13 As Byte
    Get
public:
property unsigned char InputPortI13 {
    unsigned char get ();
}
member InputPortI13 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputPortI14 Property

IRD

Pcal6416aInputPortI14 Property

Input Port: I1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI14 { get; }
Public ReadOnly Property InputPortI14 As Byte
    Get
public:
property unsigned char InputPortI14 {
    unsigned char get ();
}
member InputPortI14 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputPortI15 Property

IRD

Pcal6416aInputPortI15 Property

Input Port: I1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI15 { get; }
Public ReadOnly Property InputPortI15 As Byte
    Get
public:
property unsigned char InputPortI15 {
    unsigned char get ();
}
member InputPortI15 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputPortI16 Property

IRD

Pcal6416aInputPortI16 Property

Input Port: I1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI16 { get; }
Public ReadOnly Property InputPortI16 As Byte
    Get
public:
property unsigned char InputPortI16 {
    unsigned char get ();
}
member InputPortI16 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InputPortI17 Property

IRD

Pcal6416aInputPortI17 Property

Input Port: I1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI17 { get; }
Public ReadOnly Property InputPortI17 As Byte
    Get
public:
property unsigned char InputPortI17 {
    unsigned char get ();
}
member InputPortI17 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptMaskM00 Property

IRD

Pcal6416aInterruptMaskM00 Property

Interrupt Mask: M0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptMask InterruptMaskM00 { get; set; }
Public Property InterruptMaskM00 As Pcal6416aTypeInterruptMask
    Get
    Set
public:
property Pcal6416aTypeInterruptMask InterruptMaskM00 {
    Pcal6416aTypeInterruptMask get ();
    void set (Pcal6416aTypeInterruptMask value);
}
member InterruptMaskM00 : Pcal6416aTypeInterruptMask with get, set

Property Value

Type: Pcal6416aTypeInterruptMask
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptMaskM01 Property

IRD

Pcal6416aInterruptMaskM01 Property

Interrupt Mask: M0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptMask InterruptMaskM01 { get; set; }
Public Property InterruptMaskM01 As Pcal6416aTypeInterruptMask
    Get
    Set
public:
property Pcal6416aTypeInterruptMask InterruptMaskM01 {
    Pcal6416aTypeInterruptMask get ();
    void set (Pcal6416aTypeInterruptMask value);
}
member InterruptMaskM01 : Pcal6416aTypeInterruptMask with get, set

Property Value

Type: Pcal6416aTypeInterruptMask
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptMaskM02 Property

IRD

Pcal6416aInterruptMaskM02 Property

Interrupt Mask: M0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptMask InterruptMaskM02 { get; set; }
Public Property InterruptMaskM02 As Pcal6416aTypeInterruptMask
    Get
    Set
public:
property Pcal6416aTypeInterruptMask InterruptMaskM02 {
    Pcal6416aTypeInterruptMask get ();
    void set (Pcal6416aTypeInterruptMask value);
}
member InterruptMaskM02 : Pcal6416aTypeInterruptMask with get, set

Property Value

Type: Pcal6416aTypeInterruptMask
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptMaskM03 Property

IRD

Pcal6416aInterruptMaskM03 Property

Interrupt Mask: M0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptMask InterruptMaskM03 { get; set; }
Public Property InterruptMaskM03 As Pcal6416aTypeInterruptMask
    Get
    Set
public:
property Pcal6416aTypeInterruptMask InterruptMaskM03 {
    Pcal6416aTypeInterruptMask get ();
    void set (Pcal6416aTypeInterruptMask value);
}
member InterruptMaskM03 : Pcal6416aTypeInterruptMask with get, set

Property Value

Type: Pcal6416aTypeInterruptMask
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptMaskM04 Property

IRD

Pcal6416aInterruptMaskM04 Property

Interrupt Mask: M0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptMask InterruptMaskM04 { get; set; }
Public Property InterruptMaskM04 As Pcal6416aTypeInterruptMask
    Get
    Set
public:
property Pcal6416aTypeInterruptMask InterruptMaskM04 {
    Pcal6416aTypeInterruptMask get ();
    void set (Pcal6416aTypeInterruptMask value);
}
member InterruptMaskM04 : Pcal6416aTypeInterruptMask with get, set

Property Value

Type: Pcal6416aTypeInterruptMask
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptMaskM05 Property

IRD

Pcal6416aInterruptMaskM05 Property

Interrupt Mask: M0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptMask InterruptMaskM05 { get; set; }
Public Property InterruptMaskM05 As Pcal6416aTypeInterruptMask
    Get
    Set
public:
property Pcal6416aTypeInterruptMask InterruptMaskM05 {
    Pcal6416aTypeInterruptMask get ();
    void set (Pcal6416aTypeInterruptMask value);
}
member InterruptMaskM05 : Pcal6416aTypeInterruptMask with get, set

Property Value

Type: Pcal6416aTypeInterruptMask
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptMaskM06 Property

IRD

Pcal6416aInterruptMaskM06 Property

Interrupt Mask: M0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptMask InterruptMaskM06 { get; set; }
Public Property InterruptMaskM06 As Pcal6416aTypeInterruptMask
    Get
    Set
public:
property Pcal6416aTypeInterruptMask InterruptMaskM06 {
    Pcal6416aTypeInterruptMask get ();
    void set (Pcal6416aTypeInterruptMask value);
}
member InterruptMaskM06 : Pcal6416aTypeInterruptMask with get, set

Property Value

Type: Pcal6416aTypeInterruptMask
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptMaskM07 Property

IRD

Pcal6416aInterruptMaskM07 Property

Interrupt Mask: M0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptMask InterruptMaskM07 { get; set; }
Public Property InterruptMaskM07 As Pcal6416aTypeInterruptMask
    Get
    Set
public:
property Pcal6416aTypeInterruptMask InterruptMaskM07 {
    Pcal6416aTypeInterruptMask get ();
    void set (Pcal6416aTypeInterruptMask value);
}
member InterruptMaskM07 : Pcal6416aTypeInterruptMask with get, set

Property Value

Type: Pcal6416aTypeInterruptMask
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptMaskM10 Property

IRD

Pcal6416aInterruptMaskM10 Property

Interrupt Mask: M1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptMask InterruptMaskM10 { get; set; }
Public Property InterruptMaskM10 As Pcal6416aTypeInterruptMask
    Get
    Set
public:
property Pcal6416aTypeInterruptMask InterruptMaskM10 {
    Pcal6416aTypeInterruptMask get ();
    void set (Pcal6416aTypeInterruptMask value);
}
member InterruptMaskM10 : Pcal6416aTypeInterruptMask with get, set

Property Value

Type: Pcal6416aTypeInterruptMask
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptMaskM11 Property

IRD

Pcal6416aInterruptMaskM11 Property

Interrupt Mask: M1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptMask InterruptMaskM11 { get; set; }
Public Property InterruptMaskM11 As Pcal6416aTypeInterruptMask
    Get
    Set
public:
property Pcal6416aTypeInterruptMask InterruptMaskM11 {
    Pcal6416aTypeInterruptMask get ();
    void set (Pcal6416aTypeInterruptMask value);
}
member InterruptMaskM11 : Pcal6416aTypeInterruptMask with get, set

Property Value

Type: Pcal6416aTypeInterruptMask
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptMaskM12 Property

IRD

Pcal6416aInterruptMaskM12 Property

Interrupt Mask: M1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptMask InterruptMaskM12 { get; set; }
Public Property InterruptMaskM12 As Pcal6416aTypeInterruptMask
    Get
    Set
public:
property Pcal6416aTypeInterruptMask InterruptMaskM12 {
    Pcal6416aTypeInterruptMask get ();
    void set (Pcal6416aTypeInterruptMask value);
}
member InterruptMaskM12 : Pcal6416aTypeInterruptMask with get, set

Property Value

Type: Pcal6416aTypeInterruptMask
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptMaskM13 Property

IRD

Pcal6416aInterruptMaskM13 Property

Interrupt Mask: M1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptMask InterruptMaskM13 { get; set; }
Public Property InterruptMaskM13 As Pcal6416aTypeInterruptMask
    Get
    Set
public:
property Pcal6416aTypeInterruptMask InterruptMaskM13 {
    Pcal6416aTypeInterruptMask get ();
    void set (Pcal6416aTypeInterruptMask value);
}
member InterruptMaskM13 : Pcal6416aTypeInterruptMask with get, set

Property Value

Type: Pcal6416aTypeInterruptMask
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptMaskM14 Property

IRD

Pcal6416aInterruptMaskM14 Property

Interrupt Mask: M1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptMask InterruptMaskM14 { get; set; }
Public Property InterruptMaskM14 As Pcal6416aTypeInterruptMask
    Get
    Set
public:
property Pcal6416aTypeInterruptMask InterruptMaskM14 {
    Pcal6416aTypeInterruptMask get ();
    void set (Pcal6416aTypeInterruptMask value);
}
member InterruptMaskM14 : Pcal6416aTypeInterruptMask with get, set

Property Value

Type: Pcal6416aTypeInterruptMask
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptMaskM15 Property

IRD

Pcal6416aInterruptMaskM15 Property

Interrupt Mask: M1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptMask InterruptMaskM15 { get; set; }
Public Property InterruptMaskM15 As Pcal6416aTypeInterruptMask
    Get
    Set
public:
property Pcal6416aTypeInterruptMask InterruptMaskM15 {
    Pcal6416aTypeInterruptMask get ();
    void set (Pcal6416aTypeInterruptMask value);
}
member InterruptMaskM15 : Pcal6416aTypeInterruptMask with get, set

Property Value

Type: Pcal6416aTypeInterruptMask
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptMaskM16 Property

IRD

Pcal6416aInterruptMaskM16 Property

Interrupt Mask: M1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptMask InterruptMaskM16 { get; set; }
Public Property InterruptMaskM16 As Pcal6416aTypeInterruptMask
    Get
    Set
public:
property Pcal6416aTypeInterruptMask InterruptMaskM16 {
    Pcal6416aTypeInterruptMask get ();
    void set (Pcal6416aTypeInterruptMask value);
}
member InterruptMaskM16 : Pcal6416aTypeInterruptMask with get, set

Property Value

Type: Pcal6416aTypeInterruptMask
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptMaskM17 Property

IRD

Pcal6416aInterruptMaskM17 Property

Interrupt Mask: M1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptMask InterruptMaskM17 { get; set; }
Public Property InterruptMaskM17 As Pcal6416aTypeInterruptMask
    Get
    Set
public:
property Pcal6416aTypeInterruptMask InterruptMaskM17 {
    Pcal6416aTypeInterruptMask get ();
    void set (Pcal6416aTypeInterruptMask value);
}
member InterruptMaskM17 : Pcal6416aTypeInterruptMask with get, set

Property Value

Type: Pcal6416aTypeInterruptMask
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptStatusS00 Property

IRD

Pcal6416aInterruptStatusS00 Property

Interrupt Status: S0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptStatus InterruptStatusS00 { get; }
Public ReadOnly Property InterruptStatusS00 As Pcal6416aTypeInterruptStatus
    Get
public:
property Pcal6416aTypeInterruptStatus InterruptStatusS00 {
    Pcal6416aTypeInterruptStatus get ();
}
member InterruptStatusS00 : Pcal6416aTypeInterruptStatus with get

Property Value

Type: Pcal6416aTypeInterruptStatus
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptStatusS01 Property

IRD

Pcal6416aInterruptStatusS01 Property

Interrupt Status: S0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptStatus InterruptStatusS01 { get; }
Public ReadOnly Property InterruptStatusS01 As Pcal6416aTypeInterruptStatus
    Get
public:
property Pcal6416aTypeInterruptStatus InterruptStatusS01 {
    Pcal6416aTypeInterruptStatus get ();
}
member InterruptStatusS01 : Pcal6416aTypeInterruptStatus with get

Property Value

Type: Pcal6416aTypeInterruptStatus
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptStatusS02 Property

IRD

Pcal6416aInterruptStatusS02 Property

Interrupt Status: S0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptStatus InterruptStatusS02 { get; }
Public ReadOnly Property InterruptStatusS02 As Pcal6416aTypeInterruptStatus
    Get
public:
property Pcal6416aTypeInterruptStatus InterruptStatusS02 {
    Pcal6416aTypeInterruptStatus get ();
}
member InterruptStatusS02 : Pcal6416aTypeInterruptStatus with get

Property Value

Type: Pcal6416aTypeInterruptStatus
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptStatusS03 Property

IRD

Pcal6416aInterruptStatusS03 Property

Interrupt Status: S0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptStatus InterruptStatusS03 { get; }
Public ReadOnly Property InterruptStatusS03 As Pcal6416aTypeInterruptStatus
    Get
public:
property Pcal6416aTypeInterruptStatus InterruptStatusS03 {
    Pcal6416aTypeInterruptStatus get ();
}
member InterruptStatusS03 : Pcal6416aTypeInterruptStatus with get

Property Value

Type: Pcal6416aTypeInterruptStatus
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptStatusS04 Property

IRD

Pcal6416aInterruptStatusS04 Property

Interrupt Status: S0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptStatus InterruptStatusS04 { get; }
Public ReadOnly Property InterruptStatusS04 As Pcal6416aTypeInterruptStatus
    Get
public:
property Pcal6416aTypeInterruptStatus InterruptStatusS04 {
    Pcal6416aTypeInterruptStatus get ();
}
member InterruptStatusS04 : Pcal6416aTypeInterruptStatus with get

Property Value

Type: Pcal6416aTypeInterruptStatus
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptStatusS05 Property

IRD

Pcal6416aInterruptStatusS05 Property

Interrupt Status: S0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptStatus InterruptStatusS05 { get; }
Public ReadOnly Property InterruptStatusS05 As Pcal6416aTypeInterruptStatus
    Get
public:
property Pcal6416aTypeInterruptStatus InterruptStatusS05 {
    Pcal6416aTypeInterruptStatus get ();
}
member InterruptStatusS05 : Pcal6416aTypeInterruptStatus with get

Property Value

Type: Pcal6416aTypeInterruptStatus
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptStatusS06 Property

IRD

Pcal6416aInterruptStatusS06 Property

Interrupt Status: S0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptStatus InterruptStatusS06 { get; }
Public ReadOnly Property InterruptStatusS06 As Pcal6416aTypeInterruptStatus
    Get
public:
property Pcal6416aTypeInterruptStatus InterruptStatusS06 {
    Pcal6416aTypeInterruptStatus get ();
}
member InterruptStatusS06 : Pcal6416aTypeInterruptStatus with get

Property Value

Type: Pcal6416aTypeInterruptStatus
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptStatusS07 Property

IRD

Pcal6416aInterruptStatusS07 Property

Interrupt Status: S0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptStatus InterruptStatusS07 { get; }
Public ReadOnly Property InterruptStatusS07 As Pcal6416aTypeInterruptStatus
    Get
public:
property Pcal6416aTypeInterruptStatus InterruptStatusS07 {
    Pcal6416aTypeInterruptStatus get ();
}
member InterruptStatusS07 : Pcal6416aTypeInterruptStatus with get

Property Value

Type: Pcal6416aTypeInterruptStatus
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptStatusS10 Property

IRD

Pcal6416aInterruptStatusS10 Property

Interrupt Status: S1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptStatus InterruptStatusS10 { get; }
Public ReadOnly Property InterruptStatusS10 As Pcal6416aTypeInterruptStatus
    Get
public:
property Pcal6416aTypeInterruptStatus InterruptStatusS10 {
    Pcal6416aTypeInterruptStatus get ();
}
member InterruptStatusS10 : Pcal6416aTypeInterruptStatus with get

Property Value

Type: Pcal6416aTypeInterruptStatus
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptStatusS11 Property

IRD

Pcal6416aInterruptStatusS11 Property

Interrupt Status: S1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptStatus InterruptStatusS11 { get; }
Public ReadOnly Property InterruptStatusS11 As Pcal6416aTypeInterruptStatus
    Get
public:
property Pcal6416aTypeInterruptStatus InterruptStatusS11 {
    Pcal6416aTypeInterruptStatus get ();
}
member InterruptStatusS11 : Pcal6416aTypeInterruptStatus with get

Property Value

Type: Pcal6416aTypeInterruptStatus
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptStatusS12 Property

IRD

Pcal6416aInterruptStatusS12 Property

Interrupt Status: S1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptStatus InterruptStatusS12 { get; }
Public ReadOnly Property InterruptStatusS12 As Pcal6416aTypeInterruptStatus
    Get
public:
property Pcal6416aTypeInterruptStatus InterruptStatusS12 {
    Pcal6416aTypeInterruptStatus get ();
}
member InterruptStatusS12 : Pcal6416aTypeInterruptStatus with get

Property Value

Type: Pcal6416aTypeInterruptStatus
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptStatusS13 Property

IRD

Pcal6416aInterruptStatusS13 Property

Interrupt Status: S1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptStatus InterruptStatusS13 { get; }
Public ReadOnly Property InterruptStatusS13 As Pcal6416aTypeInterruptStatus
    Get
public:
property Pcal6416aTypeInterruptStatus InterruptStatusS13 {
    Pcal6416aTypeInterruptStatus get ();
}
member InterruptStatusS13 : Pcal6416aTypeInterruptStatus with get

Property Value

Type: Pcal6416aTypeInterruptStatus
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptStatusS14 Property

IRD

Pcal6416aInterruptStatusS14 Property

Interrupt Status: S1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptStatus InterruptStatusS14 { get; }
Public ReadOnly Property InterruptStatusS14 As Pcal6416aTypeInterruptStatus
    Get
public:
property Pcal6416aTypeInterruptStatus InterruptStatusS14 {
    Pcal6416aTypeInterruptStatus get ();
}
member InterruptStatusS14 : Pcal6416aTypeInterruptStatus with get

Property Value

Type: Pcal6416aTypeInterruptStatus
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptStatusS15 Property

IRD

Pcal6416aInterruptStatusS15 Property

Interrupt Status: S1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptStatus InterruptStatusS15 { get; }
Public ReadOnly Property InterruptStatusS15 As Pcal6416aTypeInterruptStatus
    Get
public:
property Pcal6416aTypeInterruptStatus InterruptStatusS15 {
    Pcal6416aTypeInterruptStatus get ();
}
member InterruptStatusS15 : Pcal6416aTypeInterruptStatus with get

Property Value

Type: Pcal6416aTypeInterruptStatus
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptStatusS16 Property

IRD

Pcal6416aInterruptStatusS16 Property

Interrupt Status: S1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptStatus InterruptStatusS16 { get; }
Public ReadOnly Property InterruptStatusS16 As Pcal6416aTypeInterruptStatus
    Get
public:
property Pcal6416aTypeInterruptStatus InterruptStatusS16 {
    Pcal6416aTypeInterruptStatus get ();
}
member InterruptStatusS16 : Pcal6416aTypeInterruptStatus with get

Property Value

Type: Pcal6416aTypeInterruptStatus
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.InterruptStatusS17 Property

IRD

Pcal6416aInterruptStatusS17 Property

Interrupt Status: S1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeInterruptStatus InterruptStatusS17 { get; }
Public ReadOnly Property InterruptStatusS17 As Pcal6416aTypeInterruptStatus
    Get
public:
property Pcal6416aTypeInterruptStatus InterruptStatusS17 {
    Pcal6416aTypeInterruptStatus get ();
}
member InterruptStatusS17 : Pcal6416aTypeInterruptStatus with get

Property Value

Type: Pcal6416aTypeInterruptStatus
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputDriveStrengthCC00 Property

IRD

Pcal6416aOutputDriveStrengthCC00 Property

Output Drive Strength: CC0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC00 { get; set; }
Public Property OutputDriveStrengthCC00 As Pcal6416aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC00 {
    Pcal6416aTypeOutputDriveStrength get ();
    void set (Pcal6416aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC00 : Pcal6416aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6416aTypeOutputDriveStrength
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputDriveStrengthCC01 Property

IRD

Pcal6416aOutputDriveStrengthCC01 Property

Output Drive Strength: CC0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC01 { get; set; }
Public Property OutputDriveStrengthCC01 As Pcal6416aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC01 {
    Pcal6416aTypeOutputDriveStrength get ();
    void set (Pcal6416aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC01 : Pcal6416aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6416aTypeOutputDriveStrength
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputDriveStrengthCC02 Property

IRD

Pcal6416aOutputDriveStrengthCC02 Property

Output Drive Strength: CC0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC02 { get; set; }
Public Property OutputDriveStrengthCC02 As Pcal6416aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC02 {
    Pcal6416aTypeOutputDriveStrength get ();
    void set (Pcal6416aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC02 : Pcal6416aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6416aTypeOutputDriveStrength
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputDriveStrengthCC03 Property

IRD

Pcal6416aOutputDriveStrengthCC03 Property

Output Drive Strength: CC0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC03 { get; set; }
Public Property OutputDriveStrengthCC03 As Pcal6416aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC03 {
    Pcal6416aTypeOutputDriveStrength get ();
    void set (Pcal6416aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC03 : Pcal6416aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6416aTypeOutputDriveStrength
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputDriveStrengthCC04 Property

IRD

Pcal6416aOutputDriveStrengthCC04 Property

Output Drive Strength: CC0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC04 { get; set; }
Public Property OutputDriveStrengthCC04 As Pcal6416aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC04 {
    Pcal6416aTypeOutputDriveStrength get ();
    void set (Pcal6416aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC04 : Pcal6416aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6416aTypeOutputDriveStrength
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputDriveStrengthCC05 Property

IRD

Pcal6416aOutputDriveStrengthCC05 Property

Output Drive Strength: CC0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC05 { get; set; }
Public Property OutputDriveStrengthCC05 As Pcal6416aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC05 {
    Pcal6416aTypeOutputDriveStrength get ();
    void set (Pcal6416aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC05 : Pcal6416aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6416aTypeOutputDriveStrength
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputDriveStrengthCC06 Property

IRD

Pcal6416aOutputDriveStrengthCC06 Property

Output Drive Strength: CC0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC06 { get; set; }
Public Property OutputDriveStrengthCC06 As Pcal6416aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC06 {
    Pcal6416aTypeOutputDriveStrength get ();
    void set (Pcal6416aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC06 : Pcal6416aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6416aTypeOutputDriveStrength
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputDriveStrengthCC07 Property

IRD

Pcal6416aOutputDriveStrengthCC07 Property

Output Drive Strength: CC0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC07 { get; set; }
Public Property OutputDriveStrengthCC07 As Pcal6416aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC07 {
    Pcal6416aTypeOutputDriveStrength get ();
    void set (Pcal6416aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC07 : Pcal6416aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6416aTypeOutputDriveStrength
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputDriveStrengthCC10 Property

IRD

Pcal6416aOutputDriveStrengthCC10 Property

Output Drive Strength: CC1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC10 { get; set; }
Public Property OutputDriveStrengthCC10 As Pcal6416aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC10 {
    Pcal6416aTypeOutputDriveStrength get ();
    void set (Pcal6416aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC10 : Pcal6416aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6416aTypeOutputDriveStrength
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputDriveStrengthCC11 Property

IRD

Pcal6416aOutputDriveStrengthCC11 Property

Output Drive Strength: CC1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC11 { get; set; }
Public Property OutputDriveStrengthCC11 As Pcal6416aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC11 {
    Pcal6416aTypeOutputDriveStrength get ();
    void set (Pcal6416aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC11 : Pcal6416aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6416aTypeOutputDriveStrength
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputDriveStrengthCC12 Property

IRD

Pcal6416aOutputDriveStrengthCC12 Property

Output Drive Strength: CC1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC12 { get; set; }
Public Property OutputDriveStrengthCC12 As Pcal6416aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC12 {
    Pcal6416aTypeOutputDriveStrength get ();
    void set (Pcal6416aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC12 : Pcal6416aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6416aTypeOutputDriveStrength
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputDriveStrengthCC13 Property

IRD

Pcal6416aOutputDriveStrengthCC13 Property

Output Drive Strength: CC1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC13 { get; set; }
Public Property OutputDriveStrengthCC13 As Pcal6416aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC13 {
    Pcal6416aTypeOutputDriveStrength get ();
    void set (Pcal6416aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC13 : Pcal6416aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6416aTypeOutputDriveStrength
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputDriveStrengthCC14 Property

IRD

Pcal6416aOutputDriveStrengthCC14 Property

Output Drive Strength: CC1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC14 { get; set; }
Public Property OutputDriveStrengthCC14 As Pcal6416aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC14 {
    Pcal6416aTypeOutputDriveStrength get ();
    void set (Pcal6416aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC14 : Pcal6416aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6416aTypeOutputDriveStrength
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputDriveStrengthCC15 Property

IRD

Pcal6416aOutputDriveStrengthCC15 Property

Output Drive Strength: CC1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC15 { get; set; }
Public Property OutputDriveStrengthCC15 As Pcal6416aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC15 {
    Pcal6416aTypeOutputDriveStrength get ();
    void set (Pcal6416aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC15 : Pcal6416aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6416aTypeOutputDriveStrength
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputDriveStrengthCC16 Property

IRD

Pcal6416aOutputDriveStrengthCC16 Property

Output Drive Strength: CC1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC16 { get; set; }
Public Property OutputDriveStrengthCC16 As Pcal6416aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC16 {
    Pcal6416aTypeOutputDriveStrength get ();
    void set (Pcal6416aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC16 : Pcal6416aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6416aTypeOutputDriveStrength
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputDriveStrengthCC17 Property

IRD

Pcal6416aOutputDriveStrengthCC17 Property

Output Drive Strength: CC1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC17 { get; set; }
Public Property OutputDriveStrengthCC17 As Pcal6416aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal6416aTypeOutputDriveStrength OutputDriveStrengthCC17 {
    Pcal6416aTypeOutputDriveStrength get ();
    void set (Pcal6416aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC17 : Pcal6416aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal6416aTypeOutputDriveStrength
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputPortConfigurationODEN0 Property

IRD

Pcal6416aOutputPortConfigurationODEN0 Property

Output Port Configuration: ODEN0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeOutputPortConfiguration OutputPortConfigurationODEN0 { get; set; }
Public Property OutputPortConfigurationODEN0 As Pcal6416aTypeOutputPortConfiguration
    Get
    Set
public:
property Pcal6416aTypeOutputPortConfiguration OutputPortConfigurationODEN0 {
    Pcal6416aTypeOutputPortConfiguration get ();
    void set (Pcal6416aTypeOutputPortConfiguration value);
}
member OutputPortConfigurationODEN0 : Pcal6416aTypeOutputPortConfiguration with get, set

Property Value

Type: Pcal6416aTypeOutputPortConfiguration
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputPortConfigurationODEN1 Property

IRD

Pcal6416aOutputPortConfigurationODEN1 Property

Output Port Configuration: ODEN1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypeOutputPortConfiguration OutputPortConfigurationODEN1 { get; set; }
Public Property OutputPortConfigurationODEN1 As Pcal6416aTypeOutputPortConfiguration
    Get
    Set
public:
property Pcal6416aTypeOutputPortConfiguration OutputPortConfigurationODEN1 {
    Pcal6416aTypeOutputPortConfiguration get ();
    void set (Pcal6416aTypeOutputPortConfiguration value);
}
member OutputPortConfigurationODEN1 : Pcal6416aTypeOutputPortConfiguration with get, set

Property Value

Type: Pcal6416aTypeOutputPortConfiguration
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputPortO00 Property

IRD

Pcal6416aOutputPortO00 Property

Output Port: O0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO00 { get; set; }
Public Property OutputPortO00 As Byte
    Get
    Set
public:
property unsigned char OutputPortO00 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO00 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputPortO01 Property

IRD

Pcal6416aOutputPortO01 Property

Output Port: O0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO01 { get; set; }
Public Property OutputPortO01 As Byte
    Get
    Set
public:
property unsigned char OutputPortO01 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO01 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputPortO02 Property

IRD

Pcal6416aOutputPortO02 Property

Output Port: O0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO02 { get; set; }
Public Property OutputPortO02 As Byte
    Get
    Set
public:
property unsigned char OutputPortO02 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO02 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputPortO03 Property

IRD

Pcal6416aOutputPortO03 Property

Output Port: O0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO03 { get; set; }
Public Property OutputPortO03 As Byte
    Get
    Set
public:
property unsigned char OutputPortO03 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO03 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputPortO04 Property

IRD

Pcal6416aOutputPortO04 Property

Output Port: O0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO04 { get; set; }
Public Property OutputPortO04 As Byte
    Get
    Set
public:
property unsigned char OutputPortO04 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO04 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputPortO05 Property

IRD

Pcal6416aOutputPortO05 Property

Output Port: O0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO05 { get; set; }
Public Property OutputPortO05 As Byte
    Get
    Set
public:
property unsigned char OutputPortO05 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO05 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputPortO06 Property

IRD

Pcal6416aOutputPortO06 Property

Output Port: O0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO06 { get; set; }
Public Property OutputPortO06 As Byte
    Get
    Set
public:
property unsigned char OutputPortO06 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO06 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputPortO07 Property

IRD

Pcal6416aOutputPortO07 Property

Output Port: O0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO07 { get; set; }
Public Property OutputPortO07 As Byte
    Get
    Set
public:
property unsigned char OutputPortO07 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO07 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputPortO10 Property

IRD

Pcal6416aOutputPortO10 Property

Output Port: O1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO10 { get; set; }
Public Property OutputPortO10 As Byte
    Get
    Set
public:
property unsigned char OutputPortO10 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO10 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputPortO11 Property

IRD

Pcal6416aOutputPortO11 Property

Output Port: O1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO11 { get; set; }
Public Property OutputPortO11 As Byte
    Get
    Set
public:
property unsigned char OutputPortO11 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO11 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputPortO12 Property

IRD

Pcal6416aOutputPortO12 Property

Output Port: O1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO12 { get; set; }
Public Property OutputPortO12 As Byte
    Get
    Set
public:
property unsigned char OutputPortO12 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO12 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputPortO13 Property

IRD

Pcal6416aOutputPortO13 Property

Output Port: O1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO13 { get; set; }
Public Property OutputPortO13 As Byte
    Get
    Set
public:
property unsigned char OutputPortO13 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO13 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputPortO14 Property

IRD

Pcal6416aOutputPortO14 Property

Output Port: O1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO14 { get; set; }
Public Property OutputPortO14 As Byte
    Get
    Set
public:
property unsigned char OutputPortO14 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO14 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputPortO15 Property

IRD

Pcal6416aOutputPortO15 Property

Output Port: O1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO15 { get; set; }
Public Property OutputPortO15 As Byte
    Get
    Set
public:
property unsigned char OutputPortO15 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO15 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputPortO16 Property

IRD

Pcal6416aOutputPortO16 Property

Output Port: O1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO16 { get; set; }
Public Property OutputPortO16 As Byte
    Get
    Set
public:
property unsigned char OutputPortO16 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO16 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.OutputPortO17 Property

IRD

Pcal6416aOutputPortO17 Property

Output Port: O1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO17 { get; set; }
Public Property OutputPortO17 As Byte
    Get
    Set
public:
property unsigned char OutputPortO17 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO17 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PolarityInversionN00 Property

IRD

Pcal6416aPolarityInversionN00 Property

Polarity Inversion: N0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePolarityInversion PolarityInversionN00 { get; set; }
Public Property PolarityInversionN00 As Pcal6416aTypePolarityInversion
    Get
    Set
public:
property Pcal6416aTypePolarityInversion PolarityInversionN00 {
    Pcal6416aTypePolarityInversion get ();
    void set (Pcal6416aTypePolarityInversion value);
}
member PolarityInversionN00 : Pcal6416aTypePolarityInversion with get, set

Property Value

Type: Pcal6416aTypePolarityInversion
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PolarityInversionN01 Property

IRD

Pcal6416aPolarityInversionN01 Property

Polarity Inversion: N0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePolarityInversion PolarityInversionN01 { get; set; }
Public Property PolarityInversionN01 As Pcal6416aTypePolarityInversion
    Get
    Set
public:
property Pcal6416aTypePolarityInversion PolarityInversionN01 {
    Pcal6416aTypePolarityInversion get ();
    void set (Pcal6416aTypePolarityInversion value);
}
member PolarityInversionN01 : Pcal6416aTypePolarityInversion with get, set

Property Value

Type: Pcal6416aTypePolarityInversion
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PolarityInversionN02 Property

IRD

Pcal6416aPolarityInversionN02 Property

Polarity Inversion: N0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePolarityInversion PolarityInversionN02 { get; set; }
Public Property PolarityInversionN02 As Pcal6416aTypePolarityInversion
    Get
    Set
public:
property Pcal6416aTypePolarityInversion PolarityInversionN02 {
    Pcal6416aTypePolarityInversion get ();
    void set (Pcal6416aTypePolarityInversion value);
}
member PolarityInversionN02 : Pcal6416aTypePolarityInversion with get, set

Property Value

Type: Pcal6416aTypePolarityInversion
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PolarityInversionN03 Property

IRD

Pcal6416aPolarityInversionN03 Property

Polarity Inversion: N0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePolarityInversion PolarityInversionN03 { get; set; }
Public Property PolarityInversionN03 As Pcal6416aTypePolarityInversion
    Get
    Set
public:
property Pcal6416aTypePolarityInversion PolarityInversionN03 {
    Pcal6416aTypePolarityInversion get ();
    void set (Pcal6416aTypePolarityInversion value);
}
member PolarityInversionN03 : Pcal6416aTypePolarityInversion with get, set

Property Value

Type: Pcal6416aTypePolarityInversion
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PolarityInversionN04 Property

IRD

Pcal6416aPolarityInversionN04 Property

Polarity Inversion: N0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePolarityInversion PolarityInversionN04 { get; set; }
Public Property PolarityInversionN04 As Pcal6416aTypePolarityInversion
    Get
    Set
public:
property Pcal6416aTypePolarityInversion PolarityInversionN04 {
    Pcal6416aTypePolarityInversion get ();
    void set (Pcal6416aTypePolarityInversion value);
}
member PolarityInversionN04 : Pcal6416aTypePolarityInversion with get, set

Property Value

Type: Pcal6416aTypePolarityInversion
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PolarityInversionN05 Property

IRD

Pcal6416aPolarityInversionN05 Property

Polarity Inversion: N0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePolarityInversion PolarityInversionN05 { get; set; }
Public Property PolarityInversionN05 As Pcal6416aTypePolarityInversion
    Get
    Set
public:
property Pcal6416aTypePolarityInversion PolarityInversionN05 {
    Pcal6416aTypePolarityInversion get ();
    void set (Pcal6416aTypePolarityInversion value);
}
member PolarityInversionN05 : Pcal6416aTypePolarityInversion with get, set

Property Value

Type: Pcal6416aTypePolarityInversion
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PolarityInversionN06 Property

IRD

Pcal6416aPolarityInversionN06 Property

Polarity Inversion: N0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePolarityInversion PolarityInversionN06 { get; set; }
Public Property PolarityInversionN06 As Pcal6416aTypePolarityInversion
    Get
    Set
public:
property Pcal6416aTypePolarityInversion PolarityInversionN06 {
    Pcal6416aTypePolarityInversion get ();
    void set (Pcal6416aTypePolarityInversion value);
}
member PolarityInversionN06 : Pcal6416aTypePolarityInversion with get, set

Property Value

Type: Pcal6416aTypePolarityInversion
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PolarityInversionN07 Property

IRD

Pcal6416aPolarityInversionN07 Property

Polarity Inversion: N0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePolarityInversion PolarityInversionN07 { get; set; }
Public Property PolarityInversionN07 As Pcal6416aTypePolarityInversion
    Get
    Set
public:
property Pcal6416aTypePolarityInversion PolarityInversionN07 {
    Pcal6416aTypePolarityInversion get ();
    void set (Pcal6416aTypePolarityInversion value);
}
member PolarityInversionN07 : Pcal6416aTypePolarityInversion with get, set

Property Value

Type: Pcal6416aTypePolarityInversion
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PolarityInversionN10 Property

IRD

Pcal6416aPolarityInversionN10 Property

Polarity Inversion: N1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePolarityInversion PolarityInversionN10 { get; set; }
Public Property PolarityInversionN10 As Pcal6416aTypePolarityInversion
    Get
    Set
public:
property Pcal6416aTypePolarityInversion PolarityInversionN10 {
    Pcal6416aTypePolarityInversion get ();
    void set (Pcal6416aTypePolarityInversion value);
}
member PolarityInversionN10 : Pcal6416aTypePolarityInversion with get, set

Property Value

Type: Pcal6416aTypePolarityInversion
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PolarityInversionN11 Property

IRD

Pcal6416aPolarityInversionN11 Property

Polarity Inversion: N1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePolarityInversion PolarityInversionN11 { get; set; }
Public Property PolarityInversionN11 As Pcal6416aTypePolarityInversion
    Get
    Set
public:
property Pcal6416aTypePolarityInversion PolarityInversionN11 {
    Pcal6416aTypePolarityInversion get ();
    void set (Pcal6416aTypePolarityInversion value);
}
member PolarityInversionN11 : Pcal6416aTypePolarityInversion with get, set

Property Value

Type: Pcal6416aTypePolarityInversion
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PolarityInversionN12 Property

IRD

Pcal6416aPolarityInversionN12 Property

Polarity Inversion: N1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePolarityInversion PolarityInversionN12 { get; set; }
Public Property PolarityInversionN12 As Pcal6416aTypePolarityInversion
    Get
    Set
public:
property Pcal6416aTypePolarityInversion PolarityInversionN12 {
    Pcal6416aTypePolarityInversion get ();
    void set (Pcal6416aTypePolarityInversion value);
}
member PolarityInversionN12 : Pcal6416aTypePolarityInversion with get, set

Property Value

Type: Pcal6416aTypePolarityInversion
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PolarityInversionN13 Property

IRD

Pcal6416aPolarityInversionN13 Property

Polarity Inversion: N1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePolarityInversion PolarityInversionN13 { get; set; }
Public Property PolarityInversionN13 As Pcal6416aTypePolarityInversion
    Get
    Set
public:
property Pcal6416aTypePolarityInversion PolarityInversionN13 {
    Pcal6416aTypePolarityInversion get ();
    void set (Pcal6416aTypePolarityInversion value);
}
member PolarityInversionN13 : Pcal6416aTypePolarityInversion with get, set

Property Value

Type: Pcal6416aTypePolarityInversion
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PolarityInversionN14 Property

IRD

Pcal6416aPolarityInversionN14 Property

Polarity Inversion: N1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePolarityInversion PolarityInversionN14 { get; set; }
Public Property PolarityInversionN14 As Pcal6416aTypePolarityInversion
    Get
    Set
public:
property Pcal6416aTypePolarityInversion PolarityInversionN14 {
    Pcal6416aTypePolarityInversion get ();
    void set (Pcal6416aTypePolarityInversion value);
}
member PolarityInversionN14 : Pcal6416aTypePolarityInversion with get, set

Property Value

Type: Pcal6416aTypePolarityInversion
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PolarityInversionN15 Property

IRD

Pcal6416aPolarityInversionN15 Property

Polarity Inversion: N1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePolarityInversion PolarityInversionN15 { get; set; }
Public Property PolarityInversionN15 As Pcal6416aTypePolarityInversion
    Get
    Set
public:
property Pcal6416aTypePolarityInversion PolarityInversionN15 {
    Pcal6416aTypePolarityInversion get ();
    void set (Pcal6416aTypePolarityInversion value);
}
member PolarityInversionN15 : Pcal6416aTypePolarityInversion with get, set

Property Value

Type: Pcal6416aTypePolarityInversion
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PolarityInversionN16 Property

IRD

Pcal6416aPolarityInversionN16 Property

Polarity Inversion: N1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePolarityInversion PolarityInversionN16 { get; set; }
Public Property PolarityInversionN16 As Pcal6416aTypePolarityInversion
    Get
    Set
public:
property Pcal6416aTypePolarityInversion PolarityInversionN16 {
    Pcal6416aTypePolarityInversion get ();
    void set (Pcal6416aTypePolarityInversion value);
}
member PolarityInversionN16 : Pcal6416aTypePolarityInversion with get, set

Property Value

Type: Pcal6416aTypePolarityInversion
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PolarityInversionN17 Property

IRD

Pcal6416aPolarityInversionN17 Property

Polarity Inversion: N1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePolarityInversion PolarityInversionN17 { get; set; }
Public Property PolarityInversionN17 As Pcal6416aTypePolarityInversion
    Get
    Set
public:
property Pcal6416aTypePolarityInversion PolarityInversionN17 {
    Pcal6416aTypePolarityInversion get ();
    void set (Pcal6416aTypePolarityInversion value);
}
member PolarityInversionN17 : Pcal6416aTypePolarityInversion with get, set

Property Value

Type: Pcal6416aTypePolarityInversion
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownEnablePE00 Property

IRD

Pcal6416aPullUpPullDownEnablePE00 Property

Pull-Up/Pull-Down Enable: PE0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE00 { get; set; }
Public Property PullUpPullDownEnablePE00 As Pcal6416aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE00 {
    Pcal6416aTypePullUpPullDownEnable get ();
    void set (Pcal6416aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE00 : Pcal6416aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownEnable
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownEnablePE01 Property

IRD

Pcal6416aPullUpPullDownEnablePE01 Property

Pull-Up/Pull-Down Enable: PE0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE01 { get; set; }
Public Property PullUpPullDownEnablePE01 As Pcal6416aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE01 {
    Pcal6416aTypePullUpPullDownEnable get ();
    void set (Pcal6416aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE01 : Pcal6416aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownEnable
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownEnablePE02 Property

IRD

Pcal6416aPullUpPullDownEnablePE02 Property

Pull-Up/Pull-Down Enable: PE0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE02 { get; set; }
Public Property PullUpPullDownEnablePE02 As Pcal6416aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE02 {
    Pcal6416aTypePullUpPullDownEnable get ();
    void set (Pcal6416aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE02 : Pcal6416aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownEnable
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownEnablePE03 Property

IRD

Pcal6416aPullUpPullDownEnablePE03 Property

Pull-Up/Pull-Down Enable: PE0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE03 { get; set; }
Public Property PullUpPullDownEnablePE03 As Pcal6416aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE03 {
    Pcal6416aTypePullUpPullDownEnable get ();
    void set (Pcal6416aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE03 : Pcal6416aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownEnable
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownEnablePE04 Property

IRD

Pcal6416aPullUpPullDownEnablePE04 Property

Pull-Up/Pull-Down Enable: PE0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE04 { get; set; }
Public Property PullUpPullDownEnablePE04 As Pcal6416aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE04 {
    Pcal6416aTypePullUpPullDownEnable get ();
    void set (Pcal6416aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE04 : Pcal6416aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownEnable
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownEnablePE05 Property

IRD

Pcal6416aPullUpPullDownEnablePE05 Property

Pull-Up/Pull-Down Enable: PE0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE05 { get; set; }
Public Property PullUpPullDownEnablePE05 As Pcal6416aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE05 {
    Pcal6416aTypePullUpPullDownEnable get ();
    void set (Pcal6416aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE05 : Pcal6416aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownEnable
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownEnablePE06 Property

IRD

Pcal6416aPullUpPullDownEnablePE06 Property

Pull-Up/Pull-Down Enable: PE0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE06 { get; set; }
Public Property PullUpPullDownEnablePE06 As Pcal6416aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE06 {
    Pcal6416aTypePullUpPullDownEnable get ();
    void set (Pcal6416aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE06 : Pcal6416aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownEnable
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownEnablePE07 Property

IRD

Pcal6416aPullUpPullDownEnablePE07 Property

Pull-Up/Pull-Down Enable: PE0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE07 { get; set; }
Public Property PullUpPullDownEnablePE07 As Pcal6416aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE07 {
    Pcal6416aTypePullUpPullDownEnable get ();
    void set (Pcal6416aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE07 : Pcal6416aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownEnable
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownEnablePE10 Property

IRD

Pcal6416aPullUpPullDownEnablePE10 Property

Pull-Up/Pull-Down Enable: PE1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE10 { get; set; }
Public Property PullUpPullDownEnablePE10 As Pcal6416aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE10 {
    Pcal6416aTypePullUpPullDownEnable get ();
    void set (Pcal6416aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE10 : Pcal6416aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownEnable
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownEnablePE11 Property

IRD

Pcal6416aPullUpPullDownEnablePE11 Property

Pull-Up/Pull-Down Enable: PE1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE11 { get; set; }
Public Property PullUpPullDownEnablePE11 As Pcal6416aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE11 {
    Pcal6416aTypePullUpPullDownEnable get ();
    void set (Pcal6416aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE11 : Pcal6416aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownEnable
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownEnablePE12 Property

IRD

Pcal6416aPullUpPullDownEnablePE12 Property

Pull-Up/Pull-Down Enable: PE1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE12 { get; set; }
Public Property PullUpPullDownEnablePE12 As Pcal6416aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE12 {
    Pcal6416aTypePullUpPullDownEnable get ();
    void set (Pcal6416aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE12 : Pcal6416aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownEnable
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownEnablePE13 Property

IRD

Pcal6416aPullUpPullDownEnablePE13 Property

Pull-Up/Pull-Down Enable: PE1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE13 { get; set; }
Public Property PullUpPullDownEnablePE13 As Pcal6416aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE13 {
    Pcal6416aTypePullUpPullDownEnable get ();
    void set (Pcal6416aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE13 : Pcal6416aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownEnable
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownEnablePE14 Property

IRD

Pcal6416aPullUpPullDownEnablePE14 Property

Pull-Up/Pull-Down Enable: PE1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE14 { get; set; }
Public Property PullUpPullDownEnablePE14 As Pcal6416aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE14 {
    Pcal6416aTypePullUpPullDownEnable get ();
    void set (Pcal6416aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE14 : Pcal6416aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownEnable
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownEnablePE15 Property

IRD

Pcal6416aPullUpPullDownEnablePE15 Property

Pull-Up/Pull-Down Enable: PE1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE15 { get; set; }
Public Property PullUpPullDownEnablePE15 As Pcal6416aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE15 {
    Pcal6416aTypePullUpPullDownEnable get ();
    void set (Pcal6416aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE15 : Pcal6416aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownEnable
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownEnablePE16 Property

IRD

Pcal6416aPullUpPullDownEnablePE16 Property

Pull-Up/Pull-Down Enable: PE1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE16 { get; set; }
Public Property PullUpPullDownEnablePE16 As Pcal6416aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE16 {
    Pcal6416aTypePullUpPullDownEnable get ();
    void set (Pcal6416aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE16 : Pcal6416aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownEnable
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownEnablePE17 Property

IRD

Pcal6416aPullUpPullDownEnablePE17 Property

Pull-Up/Pull-Down Enable: PE1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE17 { get; set; }
Public Property PullUpPullDownEnablePE17 As Pcal6416aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownEnable PullUpPullDownEnablePE17 {
    Pcal6416aTypePullUpPullDownEnable get ();
    void set (Pcal6416aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE17 : Pcal6416aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownEnable
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownSelectionPUD00 Property

IRD

Pcal6416aPullUpPullDownSelectionPUD00 Property

Pull-Up/Pull-Down Selection: PUD0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD00 { get; set; }
Public Property PullUpPullDownSelectionPUD00 As Pcal6416aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD00 {
    Pcal6416aTypePullUpPullDownSelection get ();
    void set (Pcal6416aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD00 : Pcal6416aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownSelection
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownSelectionPUD01 Property

IRD

Pcal6416aPullUpPullDownSelectionPUD01 Property

Pull-Up/Pull-Down Selection: PUD0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD01 { get; set; }
Public Property PullUpPullDownSelectionPUD01 As Pcal6416aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD01 {
    Pcal6416aTypePullUpPullDownSelection get ();
    void set (Pcal6416aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD01 : Pcal6416aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownSelection
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownSelectionPUD02 Property

IRD

Pcal6416aPullUpPullDownSelectionPUD02 Property

Pull-Up/Pull-Down Selection: PUD0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD02 { get; set; }
Public Property PullUpPullDownSelectionPUD02 As Pcal6416aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD02 {
    Pcal6416aTypePullUpPullDownSelection get ();
    void set (Pcal6416aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD02 : Pcal6416aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownSelection
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownSelectionPUD03 Property

IRD

Pcal6416aPullUpPullDownSelectionPUD03 Property

Pull-Up/Pull-Down Selection: PUD0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD03 { get; set; }
Public Property PullUpPullDownSelectionPUD03 As Pcal6416aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD03 {
    Pcal6416aTypePullUpPullDownSelection get ();
    void set (Pcal6416aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD03 : Pcal6416aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownSelection
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownSelectionPUD04 Property

IRD

Pcal6416aPullUpPullDownSelectionPUD04 Property

Pull-Up/Pull-Down Selection: PUD0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD04 { get; set; }
Public Property PullUpPullDownSelectionPUD04 As Pcal6416aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD04 {
    Pcal6416aTypePullUpPullDownSelection get ();
    void set (Pcal6416aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD04 : Pcal6416aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownSelection
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownSelectionPUD05 Property

IRD

Pcal6416aPullUpPullDownSelectionPUD05 Property

Pull-Up/Pull-Down Selection: PUD0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD05 { get; set; }
Public Property PullUpPullDownSelectionPUD05 As Pcal6416aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD05 {
    Pcal6416aTypePullUpPullDownSelection get ();
    void set (Pcal6416aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD05 : Pcal6416aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownSelection
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownSelectionPUD06 Property

IRD

Pcal6416aPullUpPullDownSelectionPUD06 Property

Pull-Up/Pull-Down Selection: PUD0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD06 { get; set; }
Public Property PullUpPullDownSelectionPUD06 As Pcal6416aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD06 {
    Pcal6416aTypePullUpPullDownSelection get ();
    void set (Pcal6416aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD06 : Pcal6416aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownSelection
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownSelectionPUD07 Property

IRD

Pcal6416aPullUpPullDownSelectionPUD07 Property

Pull-Up/Pull-Down Selection: PUD0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD07 { get; set; }
Public Property PullUpPullDownSelectionPUD07 As Pcal6416aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD07 {
    Pcal6416aTypePullUpPullDownSelection get ();
    void set (Pcal6416aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD07 : Pcal6416aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownSelection
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownSelectionPUD10 Property

IRD

Pcal6416aPullUpPullDownSelectionPUD10 Property

Pull-Up/Pull-Down Selection: PUD1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD10 { get; set; }
Public Property PullUpPullDownSelectionPUD10 As Pcal6416aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD10 {
    Pcal6416aTypePullUpPullDownSelection get ();
    void set (Pcal6416aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD10 : Pcal6416aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownSelection
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownSelectionPUD11 Property

IRD

Pcal6416aPullUpPullDownSelectionPUD11 Property

Pull-Up/Pull-Down Selection: PUD1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD11 { get; set; }
Public Property PullUpPullDownSelectionPUD11 As Pcal6416aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD11 {
    Pcal6416aTypePullUpPullDownSelection get ();
    void set (Pcal6416aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD11 : Pcal6416aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownSelection
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownSelectionPUD12 Property

IRD

Pcal6416aPullUpPullDownSelectionPUD12 Property

Pull-Up/Pull-Down Selection: PUD1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD12 { get; set; }
Public Property PullUpPullDownSelectionPUD12 As Pcal6416aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD12 {
    Pcal6416aTypePullUpPullDownSelection get ();
    void set (Pcal6416aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD12 : Pcal6416aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownSelection
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownSelectionPUD13 Property

IRD

Pcal6416aPullUpPullDownSelectionPUD13 Property

Pull-Up/Pull-Down Selection: PUD1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD13 { get; set; }
Public Property PullUpPullDownSelectionPUD13 As Pcal6416aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD13 {
    Pcal6416aTypePullUpPullDownSelection get ();
    void set (Pcal6416aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD13 : Pcal6416aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownSelection
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownSelectionPUD14 Property

IRD

Pcal6416aPullUpPullDownSelectionPUD14 Property

Pull-Up/Pull-Down Selection: PUD1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD14 { get; set; }
Public Property PullUpPullDownSelectionPUD14 As Pcal6416aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD14 {
    Pcal6416aTypePullUpPullDownSelection get ();
    void set (Pcal6416aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD14 : Pcal6416aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownSelection
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownSelectionPUD15 Property

IRD

Pcal6416aPullUpPullDownSelectionPUD15 Property

Pull-Up/Pull-Down Selection: PUD1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD15 { get; set; }
Public Property PullUpPullDownSelectionPUD15 As Pcal6416aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD15 {
    Pcal6416aTypePullUpPullDownSelection get ();
    void set (Pcal6416aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD15 : Pcal6416aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownSelection
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownSelectionPUD16 Property

IRD

Pcal6416aPullUpPullDownSelectionPUD16 Property

Pull-Up/Pull-Down Selection: PUD1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD16 { get; set; }
Public Property PullUpPullDownSelectionPUD16 As Pcal6416aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD16 {
    Pcal6416aTypePullUpPullDownSelection get ();
    void set (Pcal6416aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD16 : Pcal6416aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownSelection
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.PullUpPullDownSelectionPUD17 Property

IRD

Pcal6416aPullUpPullDownSelectionPUD17 Property

Pull-Up/Pull-Down Selection: PUD1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD17 { get; set; }
Public Property PullUpPullDownSelectionPUD17 As Pcal6416aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal6416aTypePullUpPullDownSelection PullUpPullDownSelectionPUD17 {
    Pcal6416aTypePullUpPullDownSelection get ();
    void set (Pcal6416aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD17 : Pcal6416aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal6416aTypePullUpPullDownSelection
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a Methods

The Pcal6416a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.Flush Method

IRD

Pcal6416aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcal6416a Class
telos.Ird.NXPSemiconductors Namespace


Pcal6416a.TypeConfiguration Enumeration

IRD

Pcal6416aTypeConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Output | 0 | Output
Input | 1 | Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6416a.TypeInputLatch Enumeration

IRD

Pcal6416aTypeInputLatch Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInputLatch
Public Enumeration TypeInputLatch
public enum class TypeInputLatch
type TypeInputLatch
Members
Member name | Value | Description
NotLatched | 0 | Not Latched
Latched | 1 | Latched
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6416a.TypeInterruptMask Enumeration

IRD

Pcal6416aTypeInterruptMask Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptMask
Public Enumeration TypeInterruptMask
public enum class TypeInterruptMask
type TypeInterruptMask
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6416a.TypeInterruptStatus Enumeration

IRD

Pcal6416aTypeInterruptStatus Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatus
Public Enumeration TypeInterruptStatus
public enum class TypeInterruptStatus
type TypeInterruptStatus
Members
Member name | Value | Description
NotSource | 0 | Not Source
Source | 1 | Source
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6416a.TypeOutputDriveStrength Enumeration

IRD

Pcal6416aTypeOutputDriveStrength Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputDriveStrength
Public Enumeration TypeOutputDriveStrength
public enum class TypeOutputDriveStrength
type TypeOutputDriveStrength
Members
Member name | Value | Description
Value_025x | 0 | 0.25x
Value_05x | 1 | 0.5x
Value_075x | 2 | 0.75x
Value_10x | 3 | 1.0x
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6416a.TypeOutputPortConfiguration Enumeration

IRD

Pcal6416aTypeOutputPortConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputPortConfiguration
Public Enumeration TypeOutputPortConfiguration
public enum class TypeOutputPortConfiguration
type TypeOutputPortConfiguration
Members
Member name | Value | Description
PushPull | 0 | Push-Pull
OpenDrain | 1 | Open-Drain
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6416a.TypePolarityInversion Enumeration

IRD

Pcal6416aTypePolarityInversion Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarityInversion
Public Enumeration TypePolarityInversion
public enum class TypePolarityInversion
type TypePolarityInversion
Members
Member name | Value | Description
NotInverted | 0 | Not Inverted
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6416a.TypePullUpPullDownEnable Enumeration

IRD

Pcal6416aTypePullUpPullDownEnable Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePullUpPullDownEnable
Public Enumeration TypePullUpPullDownEnable
public enum class TypePullUpPullDownEnable
type TypePullUpPullDownEnable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal6416a.TypePullUpPullDownSelection Enumeration

IRD

Pcal6416aTypePullUpPullDownSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePullUpPullDownSelection
Public Enumeration TypePullUpPullDownSelection
public enum class TypePullUpPullDownSelection
type TypePullUpPullDownSelection
Members
Member name | Value | Description
Value_100KΩPullDown | 0 | 100 kΩ Pull-Down
Value_100KΩPullUp | 1 | 100 kΩ Pull-Up
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9535a Class

NXP Semiconductors: PCAL 9535A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPcal9535a

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcal9535a
Public Class Pcal9535a
public ref class Pcal9535a
type Pcal9535a =  class end

The Pcal9535a type exposes the following members.

Constructors
 | Name | Description
Public method | Pcal9535a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration: C0.0
Public property | ConfigurationC01 | Configuration: C0.1
Public property | ConfigurationC02 | Configuration: C0.2
Public property | ConfigurationC03 | Configuration: C0.3
Public property | ConfigurationC04 | Configuration: C0.4
Public property | ConfigurationC05 | Configuration: C0.5
Public property | ConfigurationC06 | Configuration: C0.6
Public property | ConfigurationC07 | Configuration: C0.7
Public property | ConfigurationC10 | Configuration: C1.0
Public property | ConfigurationC11 | Configuration: C1.1
Public property | ConfigurationC12 | Configuration: C1.2
Public property | ConfigurationC13 | Configuration: C1.3
Public property | ConfigurationC14 | Configuration: C1.4
Public property | ConfigurationC15 | Configuration: C1.5
Public property | ConfigurationC16 | Configuration: C1.6
Public property | ConfigurationC17 | Configuration: C1.7
Public property | InputLatchL00 | Input Latch: L0.0
Public property | InputLatchL01 | Input Latch: L0.1
Public property | InputLatchL02 | Input Latch: L0.2
Public property | InputLatchL03 | Input Latch: L0.3
Public property | InputLatchL04 | Input Latch: L0.4
Public property | InputLatchL05 | Input Latch: L0.5
Public property | InputLatchL06 | Input Latch: L0.6
Public property | InputLatchL07 | Input Latch: L0.7
Public property | InputLatchL10 | Input Latch: L1.0
Public property | InputLatchL11 | Input Latch: L1.1
Public property | InputLatchL12 | Input Latch: L1.2
Public property | InputLatchL13 | Input Latch: L1.3
Public property | InputLatchL14 | Input Latch: L1.4
Public property | InputLatchL15 | Input Latch: L1.5
Public property | InputLatchL16 | Input Latch: L1.6
Public property | InputLatchL17 | Input Latch: L1.7
Public property | InputPortI00 | Input Port: I0.0
Public property | InputPortI01 | Input Port: I0.1
Public property | InputPortI02 | Input Port: I0.2
Public property | InputPortI03 | Input Port: I0.3
Public property | InputPortI04 | Input Port: I0.4
Public property | InputPortI05 | Input Port: I0.5
Public property | InputPortI06 | Input Port: I0.6
Public property | InputPortI07 | Input Port: I0.7
Public property | InputPortI10 | Input Port: I1.0
Public property | InputPortI11 | Input Port: I1.1
Public property | InputPortI12 | Input Port: I1.2
Public property | InputPortI13 | Input Port: I1.3
Public property | InputPortI14 | Input Port: I1.4
Public property | InputPortI15 | Input Port: I1.5
Public property | InputPortI16 | Input Port: I1.6
Public property | InputPortI17 | Input Port: I1.7
Public property | InterruptMaskM00 | Interrupt Mask: M0.0
Public property | InterruptMaskM01 | Interrupt Mask: M0.1
Public property | InterruptMaskM02 | Interrupt Mask: M0.2
Public property | InterruptMaskM03 | Interrupt Mask: M0.3
Public property | InterruptMaskM04 | Interrupt Mask: M0.4
Public property | InterruptMaskM05 | Interrupt Mask: M0.5
Public property | InterruptMaskM06 | Interrupt Mask: M0.6
Public property | InterruptMaskM07 | Interrupt Mask: M0.7
Public property | InterruptMaskM10 | Interrupt Mask: M1.0
Public property | InterruptMaskM11 | Interrupt Mask: M1.1
Public property | InterruptMaskM12 | Interrupt Mask: M1.2
Public property | InterruptMaskM13 | Interrupt Mask: M1.3
Public property | InterruptMaskM14 | Interrupt Mask: M1.4
Public property | InterruptMaskM15 | Interrupt Mask: M1.5
Public property | InterruptMaskM16 | Interrupt Mask: M1.6
Public property | InterruptMaskM17 | Interrupt Mask: M1.7
Public property | InterruptStatusS00 | Interrupt Status: S0.0
Public property | InterruptStatusS01 | Interrupt Status: S0.1
Public property | InterruptStatusS02 | Interrupt Status: S0.2
Public property | InterruptStatusS03 | Interrupt Status: S0.3
Public property | InterruptStatusS04 | Interrupt Status: S0.4
Public property | InterruptStatusS05 | Interrupt Status: S0.5
Public property | InterruptStatusS06 | Interrupt Status: S0.6
Public property | InterruptStatusS07 | Interrupt Status: S0.7
Public property | InterruptStatusS10 | Interrupt Status: S1.0
Public property | InterruptStatusS11 | Interrupt Status: S1.1
Public property | InterruptStatusS12 | Interrupt Status: S1.2
Public property | InterruptStatusS13 | Interrupt Status: S1.3
Public property | InterruptStatusS14 | Interrupt Status: S1.4
Public property | InterruptStatusS15 | Interrupt Status: S1.5
Public property | InterruptStatusS16 | Interrupt Status: S1.6
Public property | InterruptStatusS17 | Interrupt Status: S1.7
Public property | OutputDriveStrengthCC00 | Output Drive Strength: CC0.0
Public property | OutputDriveStrengthCC01 | Output Drive Strength: CC0.1
Public property | OutputDriveStrengthCC02 | Output Drive Strength: CC0.2
Public property | OutputDriveStrengthCC03 | Output Drive Strength: CC0.3
Public property | OutputDriveStrengthCC04 | Output Drive Strength: CC0.4
Public property | OutputDriveStrengthCC05 | Output Drive Strength: CC0.5
Public property | OutputDriveStrengthCC06 | Output Drive Strength: CC0.6
Public property | OutputDriveStrengthCC07 | Output Drive Strength: CC0.7
Public property | OutputDriveStrengthCC10 | Output Drive Strength: CC1.0
Public property | OutputDriveStrengthCC11 | Output Drive Strength: CC1.1
Public property | OutputDriveStrengthCC12 | Output Drive Strength: CC1.2
Public property | OutputDriveStrengthCC13 | Output Drive Strength: CC1.3
Public property | OutputDriveStrengthCC14 | Output Drive Strength: CC1.4
Public property | OutputDriveStrengthCC15 | Output Drive Strength: CC1.5
Public property | OutputDriveStrengthCC16 | Output Drive Strength: CC1.6
Public property | OutputDriveStrengthCC17 | Output Drive Strength: CC1.7
Public property | OutputPortConfigurationODEN0 | Output Port Configuration: ODEN0
Public property | OutputPortConfigurationODEN1 | Output Port Configuration: ODEN1
Public property | OutputPortO00 | Output Port: O0.0
Public property | OutputPortO01 | Output Port: O0.1
Public property | OutputPortO02 | Output Port: O0.2
Public property | OutputPortO03 | Output Port: O0.3
Public property | OutputPortO04 | Output Port: O0.4
Public property | OutputPortO05 | Output Port: O0.5
Public property | OutputPortO06 | Output Port: O0.6
Public property | OutputPortO07 | Output Port: O0.7
Public property | OutputPortO10 | Output Port: O1.0
Public property | OutputPortO11 | Output Port: O1.1
Public property | OutputPortO12 | Output Port: O1.2
Public property | OutputPortO13 | Output Port: O1.3
Public property | OutputPortO14 | Output Port: O1.4
Public property | OutputPortO15 | Output Port: O1.5
Public property | OutputPortO16 | Output Port: O1.6
Public property | OutputPortO17 | Output Port: O1.7
Public property | PolarityInversionN00 | Polarity Inversion: N0.0
Public property | PolarityInversionN01 | Polarity Inversion: N0.1
Public property | PolarityInversionN02 | Polarity Inversion: N0.2
Public property | PolarityInversionN03 | Polarity Inversion: N0.3
Public property | PolarityInversionN04 | Polarity Inversion: N0.4
Public property | PolarityInversionN05 | Polarity Inversion: N0.5
Public property | PolarityInversionN06 | Polarity Inversion: N0.6
Public property | PolarityInversionN07 | Polarity Inversion: N0.7
Public property | PolarityInversionN10 | Polarity Inversion: N1.0
Public property | PolarityInversionN11 | Polarity Inversion: N1.1
Public property | PolarityInversionN12 | Polarity Inversion: N1.2
Public property | PolarityInversionN13 | Polarity Inversion: N1.3
Public property | PolarityInversionN14 | Polarity Inversion: N1.4
Public property | PolarityInversionN15 | Polarity Inversion: N1.5
Public property | PolarityInversionN16 | Polarity Inversion: N1.6
Public property | PolarityInversionN17 | Polarity Inversion: N1.7
Public property | PullUpPullDownEnablePE00 | Pull-Up/Pull-Down Enable: PE0.0
Public property | PullUpPullDownEnablePE01 | Pull-Up/Pull-Down Enable: PE0.1
Public property | PullUpPullDownEnablePE02 | Pull-Up/Pull-Down Enable: PE0.2
Public property | PullUpPullDownEnablePE03 | Pull-Up/Pull-Down Enable: PE0.3
Public property | PullUpPullDownEnablePE04 | Pull-Up/Pull-Down Enable: PE0.4
Public property | PullUpPullDownEnablePE05 | Pull-Up/Pull-Down Enable: PE0.5
Public property | PullUpPullDownEnablePE06 | Pull-Up/Pull-Down Enable: PE0.6
Public property | PullUpPullDownEnablePE07 | Pull-Up/Pull-Down Enable: PE0.7
Public property | PullUpPullDownEnablePE10 | Pull-Up/Pull-Down Enable: PE1.0
Public property | PullUpPullDownEnablePE11 | Pull-Up/Pull-Down Enable: PE1.1
Public property | PullUpPullDownEnablePE12 | Pull-Up/Pull-Down Enable: PE1.2
Public property | PullUpPullDownEnablePE13 | Pull-Up/Pull-Down Enable: PE1.3
Public property | PullUpPullDownEnablePE14 | Pull-Up/Pull-Down Enable: PE1.4
Public property | PullUpPullDownEnablePE15 | Pull-Up/Pull-Down Enable: PE1.5
Public property | PullUpPullDownEnablePE16 | Pull-Up/Pull-Down Enable: PE1.6
Public property | PullUpPullDownEnablePE17 | Pull-Up/Pull-Down Enable: PE1.7
Public property | PullUpPullDownSelectionPUD00 | Pull-Up/Pull-Down Selection: PUD0.0
Public property | PullUpPullDownSelectionPUD01 | Pull-Up/Pull-Down Selection: PUD0.1
Public property | PullUpPullDownSelectionPUD02 | Pull-Up/Pull-Down Selection: PUD0.2
Public property | PullUpPullDownSelectionPUD03 | Pull-Up/Pull-Down Selection: PUD0.3
Public property | PullUpPullDownSelectionPUD04 | Pull-Up/Pull-Down Selection: PUD0.4
Public property | PullUpPullDownSelectionPUD05 | Pull-Up/Pull-Down Selection: PUD0.5
Public property | PullUpPullDownSelectionPUD06 | Pull-Up/Pull-Down Selection: PUD0.6
Public property | PullUpPullDownSelectionPUD07 | Pull-Up/Pull-Down Selection: PUD0.7
Public property | PullUpPullDownSelectionPUD10 | Pull-Up/Pull-Down Selection: PUD1.0
Public property | PullUpPullDownSelectionPUD11 | Pull-Up/Pull-Down Selection: PUD1.1
Public property | PullUpPullDownSelectionPUD12 | Pull-Up/Pull-Down Selection: PUD1.2
Public property | PullUpPullDownSelectionPUD13 | Pull-Up/Pull-Down Selection: PUD1.3
Public property | PullUpPullDownSelectionPUD14 | Pull-Up/Pull-Down Selection: PUD1.4
Public property | PullUpPullDownSelectionPUD15 | Pull-Up/Pull-Down Selection: PUD1.5
Public property | PullUpPullDownSelectionPUD16 | Pull-Up/Pull-Down Selection: PUD1.6
Public property | PullUpPullDownSelectionPUD17 | Pull-Up/Pull-Down Selection: PUD1.7
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Voltage Translating 16-Bit I2C-Bus I/O Port With Interrupt And Agile I/O
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9535a Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcal9535a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcal9535a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a Properties

The Pcal9535a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration: C0.0
Public property | ConfigurationC01 | Configuration: C0.1
Public property | ConfigurationC02 | Configuration: C0.2
Public property | ConfigurationC03 | Configuration: C0.3
Public property | ConfigurationC04 | Configuration: C0.4
Public property | ConfigurationC05 | Configuration: C0.5
Public property | ConfigurationC06 | Configuration: C0.6
Public property | ConfigurationC07 | Configuration: C0.7
Public property | ConfigurationC10 | Configuration: C1.0
Public property | ConfigurationC11 | Configuration: C1.1
Public property | ConfigurationC12 | Configuration: C1.2
Public property | ConfigurationC13 | Configuration: C1.3
Public property | ConfigurationC14 | Configuration: C1.4
Public property | ConfigurationC15 | Configuration: C1.5
Public property | ConfigurationC16 | Configuration: C1.6
Public property | ConfigurationC17 | Configuration: C1.7
Public property | InputLatchL00 | Input Latch: L0.0
Public property | InputLatchL01 | Input Latch: L0.1
Public property | InputLatchL02 | Input Latch: L0.2
Public property | InputLatchL03 | Input Latch: L0.3
Public property | InputLatchL04 | Input Latch: L0.4
Public property | InputLatchL05 | Input Latch: L0.5
Public property | InputLatchL06 | Input Latch: L0.6
Public property | InputLatchL07 | Input Latch: L0.7
Public property | InputLatchL10 | Input Latch: L1.0
Public property | InputLatchL11 | Input Latch: L1.1
Public property | InputLatchL12 | Input Latch: L1.2
Public property | InputLatchL13 | Input Latch: L1.3
Public property | InputLatchL14 | Input Latch: L1.4
Public property | InputLatchL15 | Input Latch: L1.5
Public property | InputLatchL16 | Input Latch: L1.6
Public property | InputLatchL17 | Input Latch: L1.7
Public property | InputPortI00 | Input Port: I0.0
Public property | InputPortI01 | Input Port: I0.1
Public property | InputPortI02 | Input Port: I0.2
Public property | InputPortI03 | Input Port: I0.3
Public property | InputPortI04 | Input Port: I0.4
Public property | InputPortI05 | Input Port: I0.5
Public property | InputPortI06 | Input Port: I0.6
Public property | InputPortI07 | Input Port: I0.7
Public property | InputPortI10 | Input Port: I1.0
Public property | InputPortI11 | Input Port: I1.1
Public property | InputPortI12 | Input Port: I1.2
Public property | InputPortI13 | Input Port: I1.3
Public property | InputPortI14 | Input Port: I1.4
Public property | InputPortI15 | Input Port: I1.5
Public property | InputPortI16 | Input Port: I1.6
Public property | InputPortI17 | Input Port: I1.7
Public property | InterruptMaskM00 | Interrupt Mask: M0.0
Public property | InterruptMaskM01 | Interrupt Mask: M0.1
Public property | InterruptMaskM02 | Interrupt Mask: M0.2
Public property | InterruptMaskM03 | Interrupt Mask: M0.3
Public property | InterruptMaskM04 | Interrupt Mask: M0.4
Public property | InterruptMaskM05 | Interrupt Mask: M0.5
Public property | InterruptMaskM06 | Interrupt Mask: M0.6
Public property | InterruptMaskM07 | Interrupt Mask: M0.7
Public property | InterruptMaskM10 | Interrupt Mask: M1.0
Public property | InterruptMaskM11 | Interrupt Mask: M1.1
Public property | InterruptMaskM12 | Interrupt Mask: M1.2
Public property | InterruptMaskM13 | Interrupt Mask: M1.3
Public property | InterruptMaskM14 | Interrupt Mask: M1.4
Public property | InterruptMaskM15 | Interrupt Mask: M1.5
Public property | InterruptMaskM16 | Interrupt Mask: M1.6
Public property | InterruptMaskM17 | Interrupt Mask: M1.7
Public property | InterruptStatusS00 | Interrupt Status: S0.0
Public property | InterruptStatusS01 | Interrupt Status: S0.1
Public property | InterruptStatusS02 | Interrupt Status: S0.2
Public property | InterruptStatusS03 | Interrupt Status: S0.3
Public property | InterruptStatusS04 | Interrupt Status: S0.4
Public property | InterruptStatusS05 | Interrupt Status: S0.5
Public property | InterruptStatusS06 | Interrupt Status: S0.6
Public property | InterruptStatusS07 | Interrupt Status: S0.7
Public property | InterruptStatusS10 | Interrupt Status: S1.0
Public property | InterruptStatusS11 | Interrupt Status: S1.1
Public property | InterruptStatusS12 | Interrupt Status: S1.2
Public property | InterruptStatusS13 | Interrupt Status: S1.3
Public property | InterruptStatusS14 | Interrupt Status: S1.4
Public property | InterruptStatusS15 | Interrupt Status: S1.5
Public property | InterruptStatusS16 | Interrupt Status: S1.6
Public property | InterruptStatusS17 | Interrupt Status: S1.7
Public property | OutputDriveStrengthCC00 | Output Drive Strength: CC0.0
Public property | OutputDriveStrengthCC01 | Output Drive Strength: CC0.1
Public property | OutputDriveStrengthCC02 | Output Drive Strength: CC0.2
Public property | OutputDriveStrengthCC03 | Output Drive Strength: CC0.3
Public property | OutputDriveStrengthCC04 | Output Drive Strength: CC0.4
Public property | OutputDriveStrengthCC05 | Output Drive Strength: CC0.5
Public property | OutputDriveStrengthCC06 | Output Drive Strength: CC0.6
Public property | OutputDriveStrengthCC07 | Output Drive Strength: CC0.7
Public property | OutputDriveStrengthCC10 | Output Drive Strength: CC1.0
Public property | OutputDriveStrengthCC11 | Output Drive Strength: CC1.1
Public property | OutputDriveStrengthCC12 | Output Drive Strength: CC1.2
Public property | OutputDriveStrengthCC13 | Output Drive Strength: CC1.3
Public property | OutputDriveStrengthCC14 | Output Drive Strength: CC1.4
Public property | OutputDriveStrengthCC15 | Output Drive Strength: CC1.5
Public property | OutputDriveStrengthCC16 | Output Drive Strength: CC1.6
Public property | OutputDriveStrengthCC17 | Output Drive Strength: CC1.7
Public property | OutputPortConfigurationODEN0 | Output Port Configuration: ODEN0
Public property | OutputPortConfigurationODEN1 | Output Port Configuration: ODEN1
Public property | OutputPortO00 | Output Port: O0.0
Public property | OutputPortO01 | Output Port: O0.1
Public property | OutputPortO02 | Output Port: O0.2
Public property | OutputPortO03 | Output Port: O0.3
Public property | OutputPortO04 | Output Port: O0.4
Public property | OutputPortO05 | Output Port: O0.5
Public property | OutputPortO06 | Output Port: O0.6
Public property | OutputPortO07 | Output Port: O0.7
Public property | OutputPortO10 | Output Port: O1.0
Public property | OutputPortO11 | Output Port: O1.1
Public property | OutputPortO12 | Output Port: O1.2
Public property | OutputPortO13 | Output Port: O1.3
Public property | OutputPortO14 | Output Port: O1.4
Public property | OutputPortO15 | Output Port: O1.5
Public property | OutputPortO16 | Output Port: O1.6
Public property | OutputPortO17 | Output Port: O1.7
Public property | PolarityInversionN00 | Polarity Inversion: N0.0
Public property | PolarityInversionN01 | Polarity Inversion: N0.1
Public property | PolarityInversionN02 | Polarity Inversion: N0.2
Public property | PolarityInversionN03 | Polarity Inversion: N0.3
Public property | PolarityInversionN04 | Polarity Inversion: N0.4
Public property | PolarityInversionN05 | Polarity Inversion: N0.5
Public property | PolarityInversionN06 | Polarity Inversion: N0.6
Public property | PolarityInversionN07 | Polarity Inversion: N0.7
Public property | PolarityInversionN10 | Polarity Inversion: N1.0
Public property | PolarityInversionN11 | Polarity Inversion: N1.1
Public property | PolarityInversionN12 | Polarity Inversion: N1.2
Public property | PolarityInversionN13 | Polarity Inversion: N1.3
Public property | PolarityInversionN14 | Polarity Inversion: N1.4
Public property | PolarityInversionN15 | Polarity Inversion: N1.5
Public property | PolarityInversionN16 | Polarity Inversion: N1.6
Public property | PolarityInversionN17 | Polarity Inversion: N1.7
Public property | PullUpPullDownEnablePE00 | Pull-Up/Pull-Down Enable: PE0.0
Public property | PullUpPullDownEnablePE01 | Pull-Up/Pull-Down Enable: PE0.1
Public property | PullUpPullDownEnablePE02 | Pull-Up/Pull-Down Enable: PE0.2
Public property | PullUpPullDownEnablePE03 | Pull-Up/Pull-Down Enable: PE0.3
Public property | PullUpPullDownEnablePE04 | Pull-Up/Pull-Down Enable: PE0.4
Public property | PullUpPullDownEnablePE05 | Pull-Up/Pull-Down Enable: PE0.5
Public property | PullUpPullDownEnablePE06 | Pull-Up/Pull-Down Enable: PE0.6
Public property | PullUpPullDownEnablePE07 | Pull-Up/Pull-Down Enable: PE0.7
Public property | PullUpPullDownEnablePE10 | Pull-Up/Pull-Down Enable: PE1.0
Public property | PullUpPullDownEnablePE11 | Pull-Up/Pull-Down Enable: PE1.1
Public property | PullUpPullDownEnablePE12 | Pull-Up/Pull-Down Enable: PE1.2
Public property | PullUpPullDownEnablePE13 | Pull-Up/Pull-Down Enable: PE1.3
Public property | PullUpPullDownEnablePE14 | Pull-Up/Pull-Down Enable: PE1.4
Public property | PullUpPullDownEnablePE15 | Pull-Up/Pull-Down Enable: PE1.5
Public property | PullUpPullDownEnablePE16 | Pull-Up/Pull-Down Enable: PE1.6
Public property | PullUpPullDownEnablePE17 | Pull-Up/Pull-Down Enable: PE1.7
Public property | PullUpPullDownSelectionPUD00 | Pull-Up/Pull-Down Selection: PUD0.0
Public property | PullUpPullDownSelectionPUD01 | Pull-Up/Pull-Down Selection: PUD0.1
Public property | PullUpPullDownSelectionPUD02 | Pull-Up/Pull-Down Selection: PUD0.2
Public property | PullUpPullDownSelectionPUD03 | Pull-Up/Pull-Down Selection: PUD0.3
Public property | PullUpPullDownSelectionPUD04 | Pull-Up/Pull-Down Selection: PUD0.4
Public property | PullUpPullDownSelectionPUD05 | Pull-Up/Pull-Down Selection: PUD0.5
Public property | PullUpPullDownSelectionPUD06 | Pull-Up/Pull-Down Selection: PUD0.6
Public property | PullUpPullDownSelectionPUD07 | Pull-Up/Pull-Down Selection: PUD0.7
Public property | PullUpPullDownSelectionPUD10 | Pull-Up/Pull-Down Selection: PUD1.0
Public property | PullUpPullDownSelectionPUD11 | Pull-Up/Pull-Down Selection: PUD1.1
Public property | PullUpPullDownSelectionPUD12 | Pull-Up/Pull-Down Selection: PUD1.2
Public property | PullUpPullDownSelectionPUD13 | Pull-Up/Pull-Down Selection: PUD1.3
Public property | PullUpPullDownSelectionPUD14 | Pull-Up/Pull-Down Selection: PUD1.4
Public property | PullUpPullDownSelectionPUD15 | Pull-Up/Pull-Down Selection: PUD1.5
Public property | PullUpPullDownSelectionPUD16 | Pull-Up/Pull-Down Selection: PUD1.6
Public property | PullUpPullDownSelectionPUD17 | Pull-Up/Pull-Down Selection: PUD1.7
Top
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.AutoFlush Property

IRD

Pcal9535aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.ConfigurationC00 Property

IRD

Pcal9535aConfigurationC00 Property

Configuration: C0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeConfiguration ConfigurationC00 { get; set; }
Public Property ConfigurationC00 As Pcal9535aTypeConfiguration
    Get
    Set
public:
property Pcal9535aTypeConfiguration ConfigurationC00 {
    Pcal9535aTypeConfiguration get ();
    void set (Pcal9535aTypeConfiguration value);
}
member ConfigurationC00 : Pcal9535aTypeConfiguration with get, set

Property Value

Type: Pcal9535aTypeConfiguration
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.ConfigurationC01 Property

IRD

Pcal9535aConfigurationC01 Property

Configuration: C0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeConfiguration ConfigurationC01 { get; set; }
Public Property ConfigurationC01 As Pcal9535aTypeConfiguration
    Get
    Set
public:
property Pcal9535aTypeConfiguration ConfigurationC01 {
    Pcal9535aTypeConfiguration get ();
    void set (Pcal9535aTypeConfiguration value);
}
member ConfigurationC01 : Pcal9535aTypeConfiguration with get, set

Property Value

Type: Pcal9535aTypeConfiguration
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.ConfigurationC02 Property

IRD

Pcal9535aConfigurationC02 Property

Configuration: C0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeConfiguration ConfigurationC02 { get; set; }
Public Property ConfigurationC02 As Pcal9535aTypeConfiguration
    Get
    Set
public:
property Pcal9535aTypeConfiguration ConfigurationC02 {
    Pcal9535aTypeConfiguration get ();
    void set (Pcal9535aTypeConfiguration value);
}
member ConfigurationC02 : Pcal9535aTypeConfiguration with get, set

Property Value

Type: Pcal9535aTypeConfiguration
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.ConfigurationC03 Property

IRD

Pcal9535aConfigurationC03 Property

Configuration: C0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeConfiguration ConfigurationC03 { get; set; }
Public Property ConfigurationC03 As Pcal9535aTypeConfiguration
    Get
    Set
public:
property Pcal9535aTypeConfiguration ConfigurationC03 {
    Pcal9535aTypeConfiguration get ();
    void set (Pcal9535aTypeConfiguration value);
}
member ConfigurationC03 : Pcal9535aTypeConfiguration with get, set

Property Value

Type: Pcal9535aTypeConfiguration
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.ConfigurationC04 Property

IRD

Pcal9535aConfigurationC04 Property

Configuration: C0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeConfiguration ConfigurationC04 { get; set; }
Public Property ConfigurationC04 As Pcal9535aTypeConfiguration
    Get
    Set
public:
property Pcal9535aTypeConfiguration ConfigurationC04 {
    Pcal9535aTypeConfiguration get ();
    void set (Pcal9535aTypeConfiguration value);
}
member ConfigurationC04 : Pcal9535aTypeConfiguration with get, set

Property Value

Type: Pcal9535aTypeConfiguration
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.ConfigurationC05 Property

IRD

Pcal9535aConfigurationC05 Property

Configuration: C0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeConfiguration ConfigurationC05 { get; set; }
Public Property ConfigurationC05 As Pcal9535aTypeConfiguration
    Get
    Set
public:
property Pcal9535aTypeConfiguration ConfigurationC05 {
    Pcal9535aTypeConfiguration get ();
    void set (Pcal9535aTypeConfiguration value);
}
member ConfigurationC05 : Pcal9535aTypeConfiguration with get, set

Property Value

Type: Pcal9535aTypeConfiguration
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.ConfigurationC06 Property

IRD

Pcal9535aConfigurationC06 Property

Configuration: C0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeConfiguration ConfigurationC06 { get; set; }
Public Property ConfigurationC06 As Pcal9535aTypeConfiguration
    Get
    Set
public:
property Pcal9535aTypeConfiguration ConfigurationC06 {
    Pcal9535aTypeConfiguration get ();
    void set (Pcal9535aTypeConfiguration value);
}
member ConfigurationC06 : Pcal9535aTypeConfiguration with get, set

Property Value

Type: Pcal9535aTypeConfiguration
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.ConfigurationC07 Property

IRD

Pcal9535aConfigurationC07 Property

Configuration: C0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeConfiguration ConfigurationC07 { get; set; }
Public Property ConfigurationC07 As Pcal9535aTypeConfiguration
    Get
    Set
public:
property Pcal9535aTypeConfiguration ConfigurationC07 {
    Pcal9535aTypeConfiguration get ();
    void set (Pcal9535aTypeConfiguration value);
}
member ConfigurationC07 : Pcal9535aTypeConfiguration with get, set

Property Value

Type: Pcal9535aTypeConfiguration
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.ConfigurationC10 Property

IRD

Pcal9535aConfigurationC10 Property

Configuration: C1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeConfiguration ConfigurationC10 { get; set; }
Public Property ConfigurationC10 As Pcal9535aTypeConfiguration
    Get
    Set
public:
property Pcal9535aTypeConfiguration ConfigurationC10 {
    Pcal9535aTypeConfiguration get ();
    void set (Pcal9535aTypeConfiguration value);
}
member ConfigurationC10 : Pcal9535aTypeConfiguration with get, set

Property Value

Type: Pcal9535aTypeConfiguration
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.ConfigurationC11 Property

IRD

Pcal9535aConfigurationC11 Property

Configuration: C1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeConfiguration ConfigurationC11 { get; set; }
Public Property ConfigurationC11 As Pcal9535aTypeConfiguration
    Get
    Set
public:
property Pcal9535aTypeConfiguration ConfigurationC11 {
    Pcal9535aTypeConfiguration get ();
    void set (Pcal9535aTypeConfiguration value);
}
member ConfigurationC11 : Pcal9535aTypeConfiguration with get, set

Property Value

Type: Pcal9535aTypeConfiguration
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.ConfigurationC12 Property

IRD

Pcal9535aConfigurationC12 Property

Configuration: C1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeConfiguration ConfigurationC12 { get; set; }
Public Property ConfigurationC12 As Pcal9535aTypeConfiguration
    Get
    Set
public:
property Pcal9535aTypeConfiguration ConfigurationC12 {
    Pcal9535aTypeConfiguration get ();
    void set (Pcal9535aTypeConfiguration value);
}
member ConfigurationC12 : Pcal9535aTypeConfiguration with get, set

Property Value

Type: Pcal9535aTypeConfiguration
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.ConfigurationC13 Property

IRD

Pcal9535aConfigurationC13 Property

Configuration: C1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeConfiguration ConfigurationC13 { get; set; }
Public Property ConfigurationC13 As Pcal9535aTypeConfiguration
    Get
    Set
public:
property Pcal9535aTypeConfiguration ConfigurationC13 {
    Pcal9535aTypeConfiguration get ();
    void set (Pcal9535aTypeConfiguration value);
}
member ConfigurationC13 : Pcal9535aTypeConfiguration with get, set

Property Value

Type: Pcal9535aTypeConfiguration
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.ConfigurationC14 Property

IRD

Pcal9535aConfigurationC14 Property

Configuration: C1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeConfiguration ConfigurationC14 { get; set; }
Public Property ConfigurationC14 As Pcal9535aTypeConfiguration
    Get
    Set
public:
property Pcal9535aTypeConfiguration ConfigurationC14 {
    Pcal9535aTypeConfiguration get ();
    void set (Pcal9535aTypeConfiguration value);
}
member ConfigurationC14 : Pcal9535aTypeConfiguration with get, set

Property Value

Type: Pcal9535aTypeConfiguration
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.ConfigurationC15 Property

IRD

Pcal9535aConfigurationC15 Property

Configuration: C1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeConfiguration ConfigurationC15 { get; set; }
Public Property ConfigurationC15 As Pcal9535aTypeConfiguration
    Get
    Set
public:
property Pcal9535aTypeConfiguration ConfigurationC15 {
    Pcal9535aTypeConfiguration get ();
    void set (Pcal9535aTypeConfiguration value);
}
member ConfigurationC15 : Pcal9535aTypeConfiguration with get, set

Property Value

Type: Pcal9535aTypeConfiguration
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.ConfigurationC16 Property

IRD

Pcal9535aConfigurationC16 Property

Configuration: C1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeConfiguration ConfigurationC16 { get; set; }
Public Property ConfigurationC16 As Pcal9535aTypeConfiguration
    Get
    Set
public:
property Pcal9535aTypeConfiguration ConfigurationC16 {
    Pcal9535aTypeConfiguration get ();
    void set (Pcal9535aTypeConfiguration value);
}
member ConfigurationC16 : Pcal9535aTypeConfiguration with get, set

Property Value

Type: Pcal9535aTypeConfiguration
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.ConfigurationC17 Property

IRD

Pcal9535aConfigurationC17 Property

Configuration: C1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeConfiguration ConfigurationC17 { get; set; }
Public Property ConfigurationC17 As Pcal9535aTypeConfiguration
    Get
    Set
public:
property Pcal9535aTypeConfiguration ConfigurationC17 {
    Pcal9535aTypeConfiguration get ();
    void set (Pcal9535aTypeConfiguration value);
}
member ConfigurationC17 : Pcal9535aTypeConfiguration with get, set

Property Value

Type: Pcal9535aTypeConfiguration
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputLatchL00 Property

IRD

Pcal9535aInputLatchL00 Property

Input Latch: L0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInputLatch InputLatchL00 { get; set; }
Public Property InputLatchL00 As Pcal9535aTypeInputLatch
    Get
    Set
public:
property Pcal9535aTypeInputLatch InputLatchL00 {
    Pcal9535aTypeInputLatch get ();
    void set (Pcal9535aTypeInputLatch value);
}
member InputLatchL00 : Pcal9535aTypeInputLatch with get, set

Property Value

Type: Pcal9535aTypeInputLatch
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputLatchL01 Property

IRD

Pcal9535aInputLatchL01 Property

Input Latch: L0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInputLatch InputLatchL01 { get; set; }
Public Property InputLatchL01 As Pcal9535aTypeInputLatch
    Get
    Set
public:
property Pcal9535aTypeInputLatch InputLatchL01 {
    Pcal9535aTypeInputLatch get ();
    void set (Pcal9535aTypeInputLatch value);
}
member InputLatchL01 : Pcal9535aTypeInputLatch with get, set

Property Value

Type: Pcal9535aTypeInputLatch
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputLatchL02 Property

IRD

Pcal9535aInputLatchL02 Property

Input Latch: L0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInputLatch InputLatchL02 { get; set; }
Public Property InputLatchL02 As Pcal9535aTypeInputLatch
    Get
    Set
public:
property Pcal9535aTypeInputLatch InputLatchL02 {
    Pcal9535aTypeInputLatch get ();
    void set (Pcal9535aTypeInputLatch value);
}
member InputLatchL02 : Pcal9535aTypeInputLatch with get, set

Property Value

Type: Pcal9535aTypeInputLatch
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputLatchL03 Property

IRD

Pcal9535aInputLatchL03 Property

Input Latch: L0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInputLatch InputLatchL03 { get; set; }
Public Property InputLatchL03 As Pcal9535aTypeInputLatch
    Get
    Set
public:
property Pcal9535aTypeInputLatch InputLatchL03 {
    Pcal9535aTypeInputLatch get ();
    void set (Pcal9535aTypeInputLatch value);
}
member InputLatchL03 : Pcal9535aTypeInputLatch with get, set

Property Value

Type: Pcal9535aTypeInputLatch
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputLatchL04 Property

IRD

Pcal9535aInputLatchL04 Property

Input Latch: L0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInputLatch InputLatchL04 { get; set; }
Public Property InputLatchL04 As Pcal9535aTypeInputLatch
    Get
    Set
public:
property Pcal9535aTypeInputLatch InputLatchL04 {
    Pcal9535aTypeInputLatch get ();
    void set (Pcal9535aTypeInputLatch value);
}
member InputLatchL04 : Pcal9535aTypeInputLatch with get, set

Property Value

Type: Pcal9535aTypeInputLatch
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputLatchL05 Property

IRD

Pcal9535aInputLatchL05 Property

Input Latch: L0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInputLatch InputLatchL05 { get; set; }
Public Property InputLatchL05 As Pcal9535aTypeInputLatch
    Get
    Set
public:
property Pcal9535aTypeInputLatch InputLatchL05 {
    Pcal9535aTypeInputLatch get ();
    void set (Pcal9535aTypeInputLatch value);
}
member InputLatchL05 : Pcal9535aTypeInputLatch with get, set

Property Value

Type: Pcal9535aTypeInputLatch
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputLatchL06 Property

IRD

Pcal9535aInputLatchL06 Property

Input Latch: L0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInputLatch InputLatchL06 { get; set; }
Public Property InputLatchL06 As Pcal9535aTypeInputLatch
    Get
    Set
public:
property Pcal9535aTypeInputLatch InputLatchL06 {
    Pcal9535aTypeInputLatch get ();
    void set (Pcal9535aTypeInputLatch value);
}
member InputLatchL06 : Pcal9535aTypeInputLatch with get, set

Property Value

Type: Pcal9535aTypeInputLatch
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputLatchL07 Property

IRD

Pcal9535aInputLatchL07 Property

Input Latch: L0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInputLatch InputLatchL07 { get; set; }
Public Property InputLatchL07 As Pcal9535aTypeInputLatch
    Get
    Set
public:
property Pcal9535aTypeInputLatch InputLatchL07 {
    Pcal9535aTypeInputLatch get ();
    void set (Pcal9535aTypeInputLatch value);
}
member InputLatchL07 : Pcal9535aTypeInputLatch with get, set

Property Value

Type: Pcal9535aTypeInputLatch
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputLatchL10 Property

IRD

Pcal9535aInputLatchL10 Property

Input Latch: L1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInputLatch InputLatchL10 { get; set; }
Public Property InputLatchL10 As Pcal9535aTypeInputLatch
    Get
    Set
public:
property Pcal9535aTypeInputLatch InputLatchL10 {
    Pcal9535aTypeInputLatch get ();
    void set (Pcal9535aTypeInputLatch value);
}
member InputLatchL10 : Pcal9535aTypeInputLatch with get, set

Property Value

Type: Pcal9535aTypeInputLatch
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputLatchL11 Property

IRD

Pcal9535aInputLatchL11 Property

Input Latch: L1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInputLatch InputLatchL11 { get; set; }
Public Property InputLatchL11 As Pcal9535aTypeInputLatch
    Get
    Set
public:
property Pcal9535aTypeInputLatch InputLatchL11 {
    Pcal9535aTypeInputLatch get ();
    void set (Pcal9535aTypeInputLatch value);
}
member InputLatchL11 : Pcal9535aTypeInputLatch with get, set

Property Value

Type: Pcal9535aTypeInputLatch
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputLatchL12 Property

IRD

Pcal9535aInputLatchL12 Property

Input Latch: L1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInputLatch InputLatchL12 { get; set; }
Public Property InputLatchL12 As Pcal9535aTypeInputLatch
    Get
    Set
public:
property Pcal9535aTypeInputLatch InputLatchL12 {
    Pcal9535aTypeInputLatch get ();
    void set (Pcal9535aTypeInputLatch value);
}
member InputLatchL12 : Pcal9535aTypeInputLatch with get, set

Property Value

Type: Pcal9535aTypeInputLatch
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputLatchL13 Property

IRD

Pcal9535aInputLatchL13 Property

Input Latch: L1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInputLatch InputLatchL13 { get; set; }
Public Property InputLatchL13 As Pcal9535aTypeInputLatch
    Get
    Set
public:
property Pcal9535aTypeInputLatch InputLatchL13 {
    Pcal9535aTypeInputLatch get ();
    void set (Pcal9535aTypeInputLatch value);
}
member InputLatchL13 : Pcal9535aTypeInputLatch with get, set

Property Value

Type: Pcal9535aTypeInputLatch
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputLatchL14 Property

IRD

Pcal9535aInputLatchL14 Property

Input Latch: L1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInputLatch InputLatchL14 { get; set; }
Public Property InputLatchL14 As Pcal9535aTypeInputLatch
    Get
    Set
public:
property Pcal9535aTypeInputLatch InputLatchL14 {
    Pcal9535aTypeInputLatch get ();
    void set (Pcal9535aTypeInputLatch value);
}
member InputLatchL14 : Pcal9535aTypeInputLatch with get, set

Property Value

Type: Pcal9535aTypeInputLatch
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputLatchL15 Property

IRD

Pcal9535aInputLatchL15 Property

Input Latch: L1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInputLatch InputLatchL15 { get; set; }
Public Property InputLatchL15 As Pcal9535aTypeInputLatch
    Get
    Set
public:
property Pcal9535aTypeInputLatch InputLatchL15 {
    Pcal9535aTypeInputLatch get ();
    void set (Pcal9535aTypeInputLatch value);
}
member InputLatchL15 : Pcal9535aTypeInputLatch with get, set

Property Value

Type: Pcal9535aTypeInputLatch
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputLatchL16 Property

IRD

Pcal9535aInputLatchL16 Property

Input Latch: L1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInputLatch InputLatchL16 { get; set; }
Public Property InputLatchL16 As Pcal9535aTypeInputLatch
    Get
    Set
public:
property Pcal9535aTypeInputLatch InputLatchL16 {
    Pcal9535aTypeInputLatch get ();
    void set (Pcal9535aTypeInputLatch value);
}
member InputLatchL16 : Pcal9535aTypeInputLatch with get, set

Property Value

Type: Pcal9535aTypeInputLatch
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputLatchL17 Property

IRD

Pcal9535aInputLatchL17 Property

Input Latch: L1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInputLatch InputLatchL17 { get; set; }
Public Property InputLatchL17 As Pcal9535aTypeInputLatch
    Get
    Set
public:
property Pcal9535aTypeInputLatch InputLatchL17 {
    Pcal9535aTypeInputLatch get ();
    void set (Pcal9535aTypeInputLatch value);
}
member InputLatchL17 : Pcal9535aTypeInputLatch with get, set

Property Value

Type: Pcal9535aTypeInputLatch
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputPortI00 Property

IRD

Pcal9535aInputPortI00 Property

Input Port: I0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI00 { get; }
Public ReadOnly Property InputPortI00 As Byte
    Get
public:
property unsigned char InputPortI00 {
    unsigned char get ();
}
member InputPortI00 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputPortI01 Property

IRD

Pcal9535aInputPortI01 Property

Input Port: I0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI01 { get; }
Public ReadOnly Property InputPortI01 As Byte
    Get
public:
property unsigned char InputPortI01 {
    unsigned char get ();
}
member InputPortI01 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputPortI02 Property

IRD

Pcal9535aInputPortI02 Property

Input Port: I0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI02 { get; }
Public ReadOnly Property InputPortI02 As Byte
    Get
public:
property unsigned char InputPortI02 {
    unsigned char get ();
}
member InputPortI02 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputPortI03 Property

IRD

Pcal9535aInputPortI03 Property

Input Port: I0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI03 { get; }
Public ReadOnly Property InputPortI03 As Byte
    Get
public:
property unsigned char InputPortI03 {
    unsigned char get ();
}
member InputPortI03 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputPortI04 Property

IRD

Pcal9535aInputPortI04 Property

Input Port: I0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI04 { get; }
Public ReadOnly Property InputPortI04 As Byte
    Get
public:
property unsigned char InputPortI04 {
    unsigned char get ();
}
member InputPortI04 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputPortI05 Property

IRD

Pcal9535aInputPortI05 Property

Input Port: I0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI05 { get; }
Public ReadOnly Property InputPortI05 As Byte
    Get
public:
property unsigned char InputPortI05 {
    unsigned char get ();
}
member InputPortI05 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputPortI06 Property

IRD

Pcal9535aInputPortI06 Property

Input Port: I0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI06 { get; }
Public ReadOnly Property InputPortI06 As Byte
    Get
public:
property unsigned char InputPortI06 {
    unsigned char get ();
}
member InputPortI06 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputPortI07 Property

IRD

Pcal9535aInputPortI07 Property

Input Port: I0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI07 { get; }
Public ReadOnly Property InputPortI07 As Byte
    Get
public:
property unsigned char InputPortI07 {
    unsigned char get ();
}
member InputPortI07 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputPortI10 Property

IRD

Pcal9535aInputPortI10 Property

Input Port: I1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI10 { get; }
Public ReadOnly Property InputPortI10 As Byte
    Get
public:
property unsigned char InputPortI10 {
    unsigned char get ();
}
member InputPortI10 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputPortI11 Property

IRD

Pcal9535aInputPortI11 Property

Input Port: I1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI11 { get; }
Public ReadOnly Property InputPortI11 As Byte
    Get
public:
property unsigned char InputPortI11 {
    unsigned char get ();
}
member InputPortI11 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputPortI12 Property

IRD

Pcal9535aInputPortI12 Property

Input Port: I1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI12 { get; }
Public ReadOnly Property InputPortI12 As Byte
    Get
public:
property unsigned char InputPortI12 {
    unsigned char get ();
}
member InputPortI12 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputPortI13 Property

IRD

Pcal9535aInputPortI13 Property

Input Port: I1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI13 { get; }
Public ReadOnly Property InputPortI13 As Byte
    Get
public:
property unsigned char InputPortI13 {
    unsigned char get ();
}
member InputPortI13 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputPortI14 Property

IRD

Pcal9535aInputPortI14 Property

Input Port: I1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI14 { get; }
Public ReadOnly Property InputPortI14 As Byte
    Get
public:
property unsigned char InputPortI14 {
    unsigned char get ();
}
member InputPortI14 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputPortI15 Property

IRD

Pcal9535aInputPortI15 Property

Input Port: I1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI15 { get; }
Public ReadOnly Property InputPortI15 As Byte
    Get
public:
property unsigned char InputPortI15 {
    unsigned char get ();
}
member InputPortI15 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputPortI16 Property

IRD

Pcal9535aInputPortI16 Property

Input Port: I1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI16 { get; }
Public ReadOnly Property InputPortI16 As Byte
    Get
public:
property unsigned char InputPortI16 {
    unsigned char get ();
}
member InputPortI16 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InputPortI17 Property

IRD

Pcal9535aInputPortI17 Property

Input Port: I1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI17 { get; }
Public ReadOnly Property InputPortI17 As Byte
    Get
public:
property unsigned char InputPortI17 {
    unsigned char get ();
}
member InputPortI17 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptMaskM00 Property

IRD

Pcal9535aInterruptMaskM00 Property

Interrupt Mask: M0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptMask InterruptMaskM00 { get; set; }
Public Property InterruptMaskM00 As Pcal9535aTypeInterruptMask
    Get
    Set
public:
property Pcal9535aTypeInterruptMask InterruptMaskM00 {
    Pcal9535aTypeInterruptMask get ();
    void set (Pcal9535aTypeInterruptMask value);
}
member InterruptMaskM00 : Pcal9535aTypeInterruptMask with get, set

Property Value

Type: Pcal9535aTypeInterruptMask
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptMaskM01 Property

IRD

Pcal9535aInterruptMaskM01 Property

Interrupt Mask: M0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptMask InterruptMaskM01 { get; set; }
Public Property InterruptMaskM01 As Pcal9535aTypeInterruptMask
    Get
    Set
public:
property Pcal9535aTypeInterruptMask InterruptMaskM01 {
    Pcal9535aTypeInterruptMask get ();
    void set (Pcal9535aTypeInterruptMask value);
}
member InterruptMaskM01 : Pcal9535aTypeInterruptMask with get, set

Property Value

Type: Pcal9535aTypeInterruptMask
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptMaskM02 Property

IRD

Pcal9535aInterruptMaskM02 Property

Interrupt Mask: M0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptMask InterruptMaskM02 { get; set; }
Public Property InterruptMaskM02 As Pcal9535aTypeInterruptMask
    Get
    Set
public:
property Pcal9535aTypeInterruptMask InterruptMaskM02 {
    Pcal9535aTypeInterruptMask get ();
    void set (Pcal9535aTypeInterruptMask value);
}
member InterruptMaskM02 : Pcal9535aTypeInterruptMask with get, set

Property Value

Type: Pcal9535aTypeInterruptMask
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptMaskM03 Property

IRD

Pcal9535aInterruptMaskM03 Property

Interrupt Mask: M0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptMask InterruptMaskM03 { get; set; }
Public Property InterruptMaskM03 As Pcal9535aTypeInterruptMask
    Get
    Set
public:
property Pcal9535aTypeInterruptMask InterruptMaskM03 {
    Pcal9535aTypeInterruptMask get ();
    void set (Pcal9535aTypeInterruptMask value);
}
member InterruptMaskM03 : Pcal9535aTypeInterruptMask with get, set

Property Value

Type: Pcal9535aTypeInterruptMask
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptMaskM04 Property

IRD

Pcal9535aInterruptMaskM04 Property

Interrupt Mask: M0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptMask InterruptMaskM04 { get; set; }
Public Property InterruptMaskM04 As Pcal9535aTypeInterruptMask
    Get
    Set
public:
property Pcal9535aTypeInterruptMask InterruptMaskM04 {
    Pcal9535aTypeInterruptMask get ();
    void set (Pcal9535aTypeInterruptMask value);
}
member InterruptMaskM04 : Pcal9535aTypeInterruptMask with get, set

Property Value

Type: Pcal9535aTypeInterruptMask
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptMaskM05 Property

IRD

Pcal9535aInterruptMaskM05 Property

Interrupt Mask: M0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptMask InterruptMaskM05 { get; set; }
Public Property InterruptMaskM05 As Pcal9535aTypeInterruptMask
    Get
    Set
public:
property Pcal9535aTypeInterruptMask InterruptMaskM05 {
    Pcal9535aTypeInterruptMask get ();
    void set (Pcal9535aTypeInterruptMask value);
}
member InterruptMaskM05 : Pcal9535aTypeInterruptMask with get, set

Property Value

Type: Pcal9535aTypeInterruptMask
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptMaskM06 Property

IRD

Pcal9535aInterruptMaskM06 Property

Interrupt Mask: M0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptMask InterruptMaskM06 { get; set; }
Public Property InterruptMaskM06 As Pcal9535aTypeInterruptMask
    Get
    Set
public:
property Pcal9535aTypeInterruptMask InterruptMaskM06 {
    Pcal9535aTypeInterruptMask get ();
    void set (Pcal9535aTypeInterruptMask value);
}
member InterruptMaskM06 : Pcal9535aTypeInterruptMask with get, set

Property Value

Type: Pcal9535aTypeInterruptMask
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptMaskM07 Property

IRD

Pcal9535aInterruptMaskM07 Property

Interrupt Mask: M0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptMask InterruptMaskM07 { get; set; }
Public Property InterruptMaskM07 As Pcal9535aTypeInterruptMask
    Get
    Set
public:
property Pcal9535aTypeInterruptMask InterruptMaskM07 {
    Pcal9535aTypeInterruptMask get ();
    void set (Pcal9535aTypeInterruptMask value);
}
member InterruptMaskM07 : Pcal9535aTypeInterruptMask with get, set

Property Value

Type: Pcal9535aTypeInterruptMask
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptMaskM10 Property

IRD

Pcal9535aInterruptMaskM10 Property

Interrupt Mask: M1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptMask InterruptMaskM10 { get; set; }
Public Property InterruptMaskM10 As Pcal9535aTypeInterruptMask
    Get
    Set
public:
property Pcal9535aTypeInterruptMask InterruptMaskM10 {
    Pcal9535aTypeInterruptMask get ();
    void set (Pcal9535aTypeInterruptMask value);
}
member InterruptMaskM10 : Pcal9535aTypeInterruptMask with get, set

Property Value

Type: Pcal9535aTypeInterruptMask
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptMaskM11 Property

IRD

Pcal9535aInterruptMaskM11 Property

Interrupt Mask: M1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptMask InterruptMaskM11 { get; set; }
Public Property InterruptMaskM11 As Pcal9535aTypeInterruptMask
    Get
    Set
public:
property Pcal9535aTypeInterruptMask InterruptMaskM11 {
    Pcal9535aTypeInterruptMask get ();
    void set (Pcal9535aTypeInterruptMask value);
}
member InterruptMaskM11 : Pcal9535aTypeInterruptMask with get, set

Property Value

Type: Pcal9535aTypeInterruptMask
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptMaskM12 Property

IRD

Pcal9535aInterruptMaskM12 Property

Interrupt Mask: M1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptMask InterruptMaskM12 { get; set; }
Public Property InterruptMaskM12 As Pcal9535aTypeInterruptMask
    Get
    Set
public:
property Pcal9535aTypeInterruptMask InterruptMaskM12 {
    Pcal9535aTypeInterruptMask get ();
    void set (Pcal9535aTypeInterruptMask value);
}
member InterruptMaskM12 : Pcal9535aTypeInterruptMask with get, set

Property Value

Type: Pcal9535aTypeInterruptMask
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptMaskM13 Property

IRD

Pcal9535aInterruptMaskM13 Property

Interrupt Mask: M1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptMask InterruptMaskM13 { get; set; }
Public Property InterruptMaskM13 As Pcal9535aTypeInterruptMask
    Get
    Set
public:
property Pcal9535aTypeInterruptMask InterruptMaskM13 {
    Pcal9535aTypeInterruptMask get ();
    void set (Pcal9535aTypeInterruptMask value);
}
member InterruptMaskM13 : Pcal9535aTypeInterruptMask with get, set

Property Value

Type: Pcal9535aTypeInterruptMask
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptMaskM14 Property

IRD

Pcal9535aInterruptMaskM14 Property

Interrupt Mask: M1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptMask InterruptMaskM14 { get; set; }
Public Property InterruptMaskM14 As Pcal9535aTypeInterruptMask
    Get
    Set
public:
property Pcal9535aTypeInterruptMask InterruptMaskM14 {
    Pcal9535aTypeInterruptMask get ();
    void set (Pcal9535aTypeInterruptMask value);
}
member InterruptMaskM14 : Pcal9535aTypeInterruptMask with get, set

Property Value

Type: Pcal9535aTypeInterruptMask
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptMaskM15 Property

IRD

Pcal9535aInterruptMaskM15 Property

Interrupt Mask: M1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptMask InterruptMaskM15 { get; set; }
Public Property InterruptMaskM15 As Pcal9535aTypeInterruptMask
    Get
    Set
public:
property Pcal9535aTypeInterruptMask InterruptMaskM15 {
    Pcal9535aTypeInterruptMask get ();
    void set (Pcal9535aTypeInterruptMask value);
}
member InterruptMaskM15 : Pcal9535aTypeInterruptMask with get, set

Property Value

Type: Pcal9535aTypeInterruptMask
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptMaskM16 Property

IRD

Pcal9535aInterruptMaskM16 Property

Interrupt Mask: M1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptMask InterruptMaskM16 { get; set; }
Public Property InterruptMaskM16 As Pcal9535aTypeInterruptMask
    Get
    Set
public:
property Pcal9535aTypeInterruptMask InterruptMaskM16 {
    Pcal9535aTypeInterruptMask get ();
    void set (Pcal9535aTypeInterruptMask value);
}
member InterruptMaskM16 : Pcal9535aTypeInterruptMask with get, set

Property Value

Type: Pcal9535aTypeInterruptMask
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptMaskM17 Property

IRD

Pcal9535aInterruptMaskM17 Property

Interrupt Mask: M1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptMask InterruptMaskM17 { get; set; }
Public Property InterruptMaskM17 As Pcal9535aTypeInterruptMask
    Get
    Set
public:
property Pcal9535aTypeInterruptMask InterruptMaskM17 {
    Pcal9535aTypeInterruptMask get ();
    void set (Pcal9535aTypeInterruptMask value);
}
member InterruptMaskM17 : Pcal9535aTypeInterruptMask with get, set

Property Value

Type: Pcal9535aTypeInterruptMask
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptStatusS00 Property

IRD

Pcal9535aInterruptStatusS00 Property

Interrupt Status: S0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptStatus InterruptStatusS00 { get; }
Public ReadOnly Property InterruptStatusS00 As Pcal9535aTypeInterruptStatus
    Get
public:
property Pcal9535aTypeInterruptStatus InterruptStatusS00 {
    Pcal9535aTypeInterruptStatus get ();
}
member InterruptStatusS00 : Pcal9535aTypeInterruptStatus with get

Property Value

Type: Pcal9535aTypeInterruptStatus
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptStatusS01 Property

IRD

Pcal9535aInterruptStatusS01 Property

Interrupt Status: S0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptStatus InterruptStatusS01 { get; }
Public ReadOnly Property InterruptStatusS01 As Pcal9535aTypeInterruptStatus
    Get
public:
property Pcal9535aTypeInterruptStatus InterruptStatusS01 {
    Pcal9535aTypeInterruptStatus get ();
}
member InterruptStatusS01 : Pcal9535aTypeInterruptStatus with get

Property Value

Type: Pcal9535aTypeInterruptStatus
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptStatusS02 Property

IRD

Pcal9535aInterruptStatusS02 Property

Interrupt Status: S0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptStatus InterruptStatusS02 { get; }
Public ReadOnly Property InterruptStatusS02 As Pcal9535aTypeInterruptStatus
    Get
public:
property Pcal9535aTypeInterruptStatus InterruptStatusS02 {
    Pcal9535aTypeInterruptStatus get ();
}
member InterruptStatusS02 : Pcal9535aTypeInterruptStatus with get

Property Value

Type: Pcal9535aTypeInterruptStatus
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptStatusS03 Property

IRD

Pcal9535aInterruptStatusS03 Property

Interrupt Status: S0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptStatus InterruptStatusS03 { get; }
Public ReadOnly Property InterruptStatusS03 As Pcal9535aTypeInterruptStatus
    Get
public:
property Pcal9535aTypeInterruptStatus InterruptStatusS03 {
    Pcal9535aTypeInterruptStatus get ();
}
member InterruptStatusS03 : Pcal9535aTypeInterruptStatus with get

Property Value

Type: Pcal9535aTypeInterruptStatus
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptStatusS04 Property

IRD

Pcal9535aInterruptStatusS04 Property

Interrupt Status: S0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptStatus InterruptStatusS04 { get; }
Public ReadOnly Property InterruptStatusS04 As Pcal9535aTypeInterruptStatus
    Get
public:
property Pcal9535aTypeInterruptStatus InterruptStatusS04 {
    Pcal9535aTypeInterruptStatus get ();
}
member InterruptStatusS04 : Pcal9535aTypeInterruptStatus with get

Property Value

Type: Pcal9535aTypeInterruptStatus
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptStatusS05 Property

IRD

Pcal9535aInterruptStatusS05 Property

Interrupt Status: S0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptStatus InterruptStatusS05 { get; }
Public ReadOnly Property InterruptStatusS05 As Pcal9535aTypeInterruptStatus
    Get
public:
property Pcal9535aTypeInterruptStatus InterruptStatusS05 {
    Pcal9535aTypeInterruptStatus get ();
}
member InterruptStatusS05 : Pcal9535aTypeInterruptStatus with get

Property Value

Type: Pcal9535aTypeInterruptStatus
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptStatusS06 Property

IRD

Pcal9535aInterruptStatusS06 Property

Interrupt Status: S0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptStatus InterruptStatusS06 { get; }
Public ReadOnly Property InterruptStatusS06 As Pcal9535aTypeInterruptStatus
    Get
public:
property Pcal9535aTypeInterruptStatus InterruptStatusS06 {
    Pcal9535aTypeInterruptStatus get ();
}
member InterruptStatusS06 : Pcal9535aTypeInterruptStatus with get

Property Value

Type: Pcal9535aTypeInterruptStatus
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptStatusS07 Property

IRD

Pcal9535aInterruptStatusS07 Property

Interrupt Status: S0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptStatus InterruptStatusS07 { get; }
Public ReadOnly Property InterruptStatusS07 As Pcal9535aTypeInterruptStatus
    Get
public:
property Pcal9535aTypeInterruptStatus InterruptStatusS07 {
    Pcal9535aTypeInterruptStatus get ();
}
member InterruptStatusS07 : Pcal9535aTypeInterruptStatus with get

Property Value

Type: Pcal9535aTypeInterruptStatus
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptStatusS10 Property

IRD

Pcal9535aInterruptStatusS10 Property

Interrupt Status: S1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptStatus InterruptStatusS10 { get; }
Public ReadOnly Property InterruptStatusS10 As Pcal9535aTypeInterruptStatus
    Get
public:
property Pcal9535aTypeInterruptStatus InterruptStatusS10 {
    Pcal9535aTypeInterruptStatus get ();
}
member InterruptStatusS10 : Pcal9535aTypeInterruptStatus with get

Property Value

Type: Pcal9535aTypeInterruptStatus
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptStatusS11 Property

IRD

Pcal9535aInterruptStatusS11 Property

Interrupt Status: S1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptStatus InterruptStatusS11 { get; }
Public ReadOnly Property InterruptStatusS11 As Pcal9535aTypeInterruptStatus
    Get
public:
property Pcal9535aTypeInterruptStatus InterruptStatusS11 {
    Pcal9535aTypeInterruptStatus get ();
}
member InterruptStatusS11 : Pcal9535aTypeInterruptStatus with get

Property Value

Type: Pcal9535aTypeInterruptStatus
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptStatusS12 Property

IRD

Pcal9535aInterruptStatusS12 Property

Interrupt Status: S1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptStatus InterruptStatusS12 { get; }
Public ReadOnly Property InterruptStatusS12 As Pcal9535aTypeInterruptStatus
    Get
public:
property Pcal9535aTypeInterruptStatus InterruptStatusS12 {
    Pcal9535aTypeInterruptStatus get ();
}
member InterruptStatusS12 : Pcal9535aTypeInterruptStatus with get

Property Value

Type: Pcal9535aTypeInterruptStatus
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptStatusS13 Property

IRD

Pcal9535aInterruptStatusS13 Property

Interrupt Status: S1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptStatus InterruptStatusS13 { get; }
Public ReadOnly Property InterruptStatusS13 As Pcal9535aTypeInterruptStatus
    Get
public:
property Pcal9535aTypeInterruptStatus InterruptStatusS13 {
    Pcal9535aTypeInterruptStatus get ();
}
member InterruptStatusS13 : Pcal9535aTypeInterruptStatus with get

Property Value

Type: Pcal9535aTypeInterruptStatus
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptStatusS14 Property

IRD

Pcal9535aInterruptStatusS14 Property

Interrupt Status: S1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptStatus InterruptStatusS14 { get; }
Public ReadOnly Property InterruptStatusS14 As Pcal9535aTypeInterruptStatus
    Get
public:
property Pcal9535aTypeInterruptStatus InterruptStatusS14 {
    Pcal9535aTypeInterruptStatus get ();
}
member InterruptStatusS14 : Pcal9535aTypeInterruptStatus with get

Property Value

Type: Pcal9535aTypeInterruptStatus
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptStatusS15 Property

IRD

Pcal9535aInterruptStatusS15 Property

Interrupt Status: S1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptStatus InterruptStatusS15 { get; }
Public ReadOnly Property InterruptStatusS15 As Pcal9535aTypeInterruptStatus
    Get
public:
property Pcal9535aTypeInterruptStatus InterruptStatusS15 {
    Pcal9535aTypeInterruptStatus get ();
}
member InterruptStatusS15 : Pcal9535aTypeInterruptStatus with get

Property Value

Type: Pcal9535aTypeInterruptStatus
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptStatusS16 Property

IRD

Pcal9535aInterruptStatusS16 Property

Interrupt Status: S1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptStatus InterruptStatusS16 { get; }
Public ReadOnly Property InterruptStatusS16 As Pcal9535aTypeInterruptStatus
    Get
public:
property Pcal9535aTypeInterruptStatus InterruptStatusS16 {
    Pcal9535aTypeInterruptStatus get ();
}
member InterruptStatusS16 : Pcal9535aTypeInterruptStatus with get

Property Value

Type: Pcal9535aTypeInterruptStatus
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.InterruptStatusS17 Property

IRD

Pcal9535aInterruptStatusS17 Property

Interrupt Status: S1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeInterruptStatus InterruptStatusS17 { get; }
Public ReadOnly Property InterruptStatusS17 As Pcal9535aTypeInterruptStatus
    Get
public:
property Pcal9535aTypeInterruptStatus InterruptStatusS17 {
    Pcal9535aTypeInterruptStatus get ();
}
member InterruptStatusS17 : Pcal9535aTypeInterruptStatus with get

Property Value

Type: Pcal9535aTypeInterruptStatus
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputDriveStrengthCC00 Property

IRD

Pcal9535aOutputDriveStrengthCC00 Property

Output Drive Strength: CC0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC00 { get; set; }
Public Property OutputDriveStrengthCC00 As Pcal9535aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC00 {
    Pcal9535aTypeOutputDriveStrength get ();
    void set (Pcal9535aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC00 : Pcal9535aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9535aTypeOutputDriveStrength
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputDriveStrengthCC01 Property

IRD

Pcal9535aOutputDriveStrengthCC01 Property

Output Drive Strength: CC0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC01 { get; set; }
Public Property OutputDriveStrengthCC01 As Pcal9535aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC01 {
    Pcal9535aTypeOutputDriveStrength get ();
    void set (Pcal9535aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC01 : Pcal9535aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9535aTypeOutputDriveStrength
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputDriveStrengthCC02 Property

IRD

Pcal9535aOutputDriveStrengthCC02 Property

Output Drive Strength: CC0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC02 { get; set; }
Public Property OutputDriveStrengthCC02 As Pcal9535aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC02 {
    Pcal9535aTypeOutputDriveStrength get ();
    void set (Pcal9535aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC02 : Pcal9535aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9535aTypeOutputDriveStrength
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputDriveStrengthCC03 Property

IRD

Pcal9535aOutputDriveStrengthCC03 Property

Output Drive Strength: CC0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC03 { get; set; }
Public Property OutputDriveStrengthCC03 As Pcal9535aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC03 {
    Pcal9535aTypeOutputDriveStrength get ();
    void set (Pcal9535aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC03 : Pcal9535aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9535aTypeOutputDriveStrength
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputDriveStrengthCC04 Property

IRD

Pcal9535aOutputDriveStrengthCC04 Property

Output Drive Strength: CC0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC04 { get; set; }
Public Property OutputDriveStrengthCC04 As Pcal9535aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC04 {
    Pcal9535aTypeOutputDriveStrength get ();
    void set (Pcal9535aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC04 : Pcal9535aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9535aTypeOutputDriveStrength
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputDriveStrengthCC05 Property

IRD

Pcal9535aOutputDriveStrengthCC05 Property

Output Drive Strength: CC0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC05 { get; set; }
Public Property OutputDriveStrengthCC05 As Pcal9535aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC05 {
    Pcal9535aTypeOutputDriveStrength get ();
    void set (Pcal9535aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC05 : Pcal9535aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9535aTypeOutputDriveStrength
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputDriveStrengthCC06 Property

IRD

Pcal9535aOutputDriveStrengthCC06 Property

Output Drive Strength: CC0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC06 { get; set; }
Public Property OutputDriveStrengthCC06 As Pcal9535aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC06 {
    Pcal9535aTypeOutputDriveStrength get ();
    void set (Pcal9535aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC06 : Pcal9535aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9535aTypeOutputDriveStrength
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputDriveStrengthCC07 Property

IRD

Pcal9535aOutputDriveStrengthCC07 Property

Output Drive Strength: CC0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC07 { get; set; }
Public Property OutputDriveStrengthCC07 As Pcal9535aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC07 {
    Pcal9535aTypeOutputDriveStrength get ();
    void set (Pcal9535aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC07 : Pcal9535aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9535aTypeOutputDriveStrength
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputDriveStrengthCC10 Property

IRD

Pcal9535aOutputDriveStrengthCC10 Property

Output Drive Strength: CC1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC10 { get; set; }
Public Property OutputDriveStrengthCC10 As Pcal9535aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC10 {
    Pcal9535aTypeOutputDriveStrength get ();
    void set (Pcal9535aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC10 : Pcal9535aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9535aTypeOutputDriveStrength
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputDriveStrengthCC11 Property

IRD

Pcal9535aOutputDriveStrengthCC11 Property

Output Drive Strength: CC1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC11 { get; set; }
Public Property OutputDriveStrengthCC11 As Pcal9535aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC11 {
    Pcal9535aTypeOutputDriveStrength get ();
    void set (Pcal9535aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC11 : Pcal9535aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9535aTypeOutputDriveStrength
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputDriveStrengthCC12 Property

IRD

Pcal9535aOutputDriveStrengthCC12 Property

Output Drive Strength: CC1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC12 { get; set; }
Public Property OutputDriveStrengthCC12 As Pcal9535aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC12 {
    Pcal9535aTypeOutputDriveStrength get ();
    void set (Pcal9535aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC12 : Pcal9535aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9535aTypeOutputDriveStrength
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputDriveStrengthCC13 Property

IRD

Pcal9535aOutputDriveStrengthCC13 Property

Output Drive Strength: CC1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC13 { get; set; }
Public Property OutputDriveStrengthCC13 As Pcal9535aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC13 {
    Pcal9535aTypeOutputDriveStrength get ();
    void set (Pcal9535aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC13 : Pcal9535aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9535aTypeOutputDriveStrength
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputDriveStrengthCC14 Property

IRD

Pcal9535aOutputDriveStrengthCC14 Property

Output Drive Strength: CC1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC14 { get; set; }
Public Property OutputDriveStrengthCC14 As Pcal9535aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC14 {
    Pcal9535aTypeOutputDriveStrength get ();
    void set (Pcal9535aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC14 : Pcal9535aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9535aTypeOutputDriveStrength
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputDriveStrengthCC15 Property

IRD

Pcal9535aOutputDriveStrengthCC15 Property

Output Drive Strength: CC1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC15 { get; set; }
Public Property OutputDriveStrengthCC15 As Pcal9535aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC15 {
    Pcal9535aTypeOutputDriveStrength get ();
    void set (Pcal9535aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC15 : Pcal9535aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9535aTypeOutputDriveStrength
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputDriveStrengthCC16 Property

IRD

Pcal9535aOutputDriveStrengthCC16 Property

Output Drive Strength: CC1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC16 { get; set; }
Public Property OutputDriveStrengthCC16 As Pcal9535aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC16 {
    Pcal9535aTypeOutputDriveStrength get ();
    void set (Pcal9535aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC16 : Pcal9535aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9535aTypeOutputDriveStrength
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputDriveStrengthCC17 Property

IRD

Pcal9535aOutputDriveStrengthCC17 Property

Output Drive Strength: CC1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC17 { get; set; }
Public Property OutputDriveStrengthCC17 As Pcal9535aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9535aTypeOutputDriveStrength OutputDriveStrengthCC17 {
    Pcal9535aTypeOutputDriveStrength get ();
    void set (Pcal9535aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC17 : Pcal9535aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9535aTypeOutputDriveStrength
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputPortConfigurationODEN0 Property

IRD

Pcal9535aOutputPortConfigurationODEN0 Property

Output Port Configuration: ODEN0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeOutputPortConfiguration OutputPortConfigurationODEN0 { get; set; }
Public Property OutputPortConfigurationODEN0 As Pcal9535aTypeOutputPortConfiguration
    Get
    Set
public:
property Pcal9535aTypeOutputPortConfiguration OutputPortConfigurationODEN0 {
    Pcal9535aTypeOutputPortConfiguration get ();
    void set (Pcal9535aTypeOutputPortConfiguration value);
}
member OutputPortConfigurationODEN0 : Pcal9535aTypeOutputPortConfiguration with get, set

Property Value

Type: Pcal9535aTypeOutputPortConfiguration
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputPortConfigurationODEN1 Property

IRD

Pcal9535aOutputPortConfigurationODEN1 Property

Output Port Configuration: ODEN1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypeOutputPortConfiguration OutputPortConfigurationODEN1 { get; set; }
Public Property OutputPortConfigurationODEN1 As Pcal9535aTypeOutputPortConfiguration
    Get
    Set
public:
property Pcal9535aTypeOutputPortConfiguration OutputPortConfigurationODEN1 {
    Pcal9535aTypeOutputPortConfiguration get ();
    void set (Pcal9535aTypeOutputPortConfiguration value);
}
member OutputPortConfigurationODEN1 : Pcal9535aTypeOutputPortConfiguration with get, set

Property Value

Type: Pcal9535aTypeOutputPortConfiguration
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputPortO00 Property

IRD

Pcal9535aOutputPortO00 Property

Output Port: O0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO00 { get; set; }
Public Property OutputPortO00 As Byte
    Get
    Set
public:
property unsigned char OutputPortO00 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO00 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputPortO01 Property

IRD

Pcal9535aOutputPortO01 Property

Output Port: O0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO01 { get; set; }
Public Property OutputPortO01 As Byte
    Get
    Set
public:
property unsigned char OutputPortO01 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO01 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputPortO02 Property

IRD

Pcal9535aOutputPortO02 Property

Output Port: O0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO02 { get; set; }
Public Property OutputPortO02 As Byte
    Get
    Set
public:
property unsigned char OutputPortO02 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO02 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputPortO03 Property

IRD

Pcal9535aOutputPortO03 Property

Output Port: O0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO03 { get; set; }
Public Property OutputPortO03 As Byte
    Get
    Set
public:
property unsigned char OutputPortO03 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO03 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputPortO04 Property

IRD

Pcal9535aOutputPortO04 Property

Output Port: O0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO04 { get; set; }
Public Property OutputPortO04 As Byte
    Get
    Set
public:
property unsigned char OutputPortO04 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO04 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputPortO05 Property

IRD

Pcal9535aOutputPortO05 Property

Output Port: O0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO05 { get; set; }
Public Property OutputPortO05 As Byte
    Get
    Set
public:
property unsigned char OutputPortO05 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO05 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputPortO06 Property

IRD

Pcal9535aOutputPortO06 Property

Output Port: O0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO06 { get; set; }
Public Property OutputPortO06 As Byte
    Get
    Set
public:
property unsigned char OutputPortO06 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO06 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputPortO07 Property

IRD

Pcal9535aOutputPortO07 Property

Output Port: O0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO07 { get; set; }
Public Property OutputPortO07 As Byte
    Get
    Set
public:
property unsigned char OutputPortO07 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO07 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputPortO10 Property

IRD

Pcal9535aOutputPortO10 Property

Output Port: O1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO10 { get; set; }
Public Property OutputPortO10 As Byte
    Get
    Set
public:
property unsigned char OutputPortO10 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO10 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputPortO11 Property

IRD

Pcal9535aOutputPortO11 Property

Output Port: O1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO11 { get; set; }
Public Property OutputPortO11 As Byte
    Get
    Set
public:
property unsigned char OutputPortO11 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO11 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputPortO12 Property

IRD

Pcal9535aOutputPortO12 Property

Output Port: O1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO12 { get; set; }
Public Property OutputPortO12 As Byte
    Get
    Set
public:
property unsigned char OutputPortO12 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO12 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputPortO13 Property

IRD

Pcal9535aOutputPortO13 Property

Output Port: O1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO13 { get; set; }
Public Property OutputPortO13 As Byte
    Get
    Set
public:
property unsigned char OutputPortO13 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO13 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputPortO14 Property

IRD

Pcal9535aOutputPortO14 Property

Output Port: O1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO14 { get; set; }
Public Property OutputPortO14 As Byte
    Get
    Set
public:
property unsigned char OutputPortO14 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO14 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputPortO15 Property

IRD

Pcal9535aOutputPortO15 Property

Output Port: O1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO15 { get; set; }
Public Property OutputPortO15 As Byte
    Get
    Set
public:
property unsigned char OutputPortO15 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO15 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputPortO16 Property

IRD

Pcal9535aOutputPortO16 Property

Output Port: O1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO16 { get; set; }
Public Property OutputPortO16 As Byte
    Get
    Set
public:
property unsigned char OutputPortO16 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO16 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.OutputPortO17 Property

IRD

Pcal9535aOutputPortO17 Property

Output Port: O1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO17 { get; set; }
Public Property OutputPortO17 As Byte
    Get
    Set
public:
property unsigned char OutputPortO17 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO17 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PolarityInversionN00 Property

IRD

Pcal9535aPolarityInversionN00 Property

Polarity Inversion: N0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePolarityInversion PolarityInversionN00 { get; set; }
Public Property PolarityInversionN00 As Pcal9535aTypePolarityInversion
    Get
    Set
public:
property Pcal9535aTypePolarityInversion PolarityInversionN00 {
    Pcal9535aTypePolarityInversion get ();
    void set (Pcal9535aTypePolarityInversion value);
}
member PolarityInversionN00 : Pcal9535aTypePolarityInversion with get, set

Property Value

Type: Pcal9535aTypePolarityInversion
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PolarityInversionN01 Property

IRD

Pcal9535aPolarityInversionN01 Property

Polarity Inversion: N0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePolarityInversion PolarityInversionN01 { get; set; }
Public Property PolarityInversionN01 As Pcal9535aTypePolarityInversion
    Get
    Set
public:
property Pcal9535aTypePolarityInversion PolarityInversionN01 {
    Pcal9535aTypePolarityInversion get ();
    void set (Pcal9535aTypePolarityInversion value);
}
member PolarityInversionN01 : Pcal9535aTypePolarityInversion with get, set

Property Value

Type: Pcal9535aTypePolarityInversion
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PolarityInversionN02 Property

IRD

Pcal9535aPolarityInversionN02 Property

Polarity Inversion: N0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePolarityInversion PolarityInversionN02 { get; set; }
Public Property PolarityInversionN02 As Pcal9535aTypePolarityInversion
    Get
    Set
public:
property Pcal9535aTypePolarityInversion PolarityInversionN02 {
    Pcal9535aTypePolarityInversion get ();
    void set (Pcal9535aTypePolarityInversion value);
}
member PolarityInversionN02 : Pcal9535aTypePolarityInversion with get, set

Property Value

Type: Pcal9535aTypePolarityInversion
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PolarityInversionN03 Property

IRD

Pcal9535aPolarityInversionN03 Property

Polarity Inversion: N0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePolarityInversion PolarityInversionN03 { get; set; }
Public Property PolarityInversionN03 As Pcal9535aTypePolarityInversion
    Get
    Set
public:
property Pcal9535aTypePolarityInversion PolarityInversionN03 {
    Pcal9535aTypePolarityInversion get ();
    void set (Pcal9535aTypePolarityInversion value);
}
member PolarityInversionN03 : Pcal9535aTypePolarityInversion with get, set

Property Value

Type: Pcal9535aTypePolarityInversion
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PolarityInversionN04 Property

IRD

Pcal9535aPolarityInversionN04 Property

Polarity Inversion: N0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePolarityInversion PolarityInversionN04 { get; set; }
Public Property PolarityInversionN04 As Pcal9535aTypePolarityInversion
    Get
    Set
public:
property Pcal9535aTypePolarityInversion PolarityInversionN04 {
    Pcal9535aTypePolarityInversion get ();
    void set (Pcal9535aTypePolarityInversion value);
}
member PolarityInversionN04 : Pcal9535aTypePolarityInversion with get, set

Property Value

Type: Pcal9535aTypePolarityInversion
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PolarityInversionN05 Property

IRD

Pcal9535aPolarityInversionN05 Property

Polarity Inversion: N0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePolarityInversion PolarityInversionN05 { get; set; }
Public Property PolarityInversionN05 As Pcal9535aTypePolarityInversion
    Get
    Set
public:
property Pcal9535aTypePolarityInversion PolarityInversionN05 {
    Pcal9535aTypePolarityInversion get ();
    void set (Pcal9535aTypePolarityInversion value);
}
member PolarityInversionN05 : Pcal9535aTypePolarityInversion with get, set

Property Value

Type: Pcal9535aTypePolarityInversion
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PolarityInversionN06 Property

IRD

Pcal9535aPolarityInversionN06 Property

Polarity Inversion: N0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePolarityInversion PolarityInversionN06 { get; set; }
Public Property PolarityInversionN06 As Pcal9535aTypePolarityInversion
    Get
    Set
public:
property Pcal9535aTypePolarityInversion PolarityInversionN06 {
    Pcal9535aTypePolarityInversion get ();
    void set (Pcal9535aTypePolarityInversion value);
}
member PolarityInversionN06 : Pcal9535aTypePolarityInversion with get, set

Property Value

Type: Pcal9535aTypePolarityInversion
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PolarityInversionN07 Property

IRD

Pcal9535aPolarityInversionN07 Property

Polarity Inversion: N0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePolarityInversion PolarityInversionN07 { get; set; }
Public Property PolarityInversionN07 As Pcal9535aTypePolarityInversion
    Get
    Set
public:
property Pcal9535aTypePolarityInversion PolarityInversionN07 {
    Pcal9535aTypePolarityInversion get ();
    void set (Pcal9535aTypePolarityInversion value);
}
member PolarityInversionN07 : Pcal9535aTypePolarityInversion with get, set

Property Value

Type: Pcal9535aTypePolarityInversion
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PolarityInversionN10 Property

IRD

Pcal9535aPolarityInversionN10 Property

Polarity Inversion: N1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePolarityInversion PolarityInversionN10 { get; set; }
Public Property PolarityInversionN10 As Pcal9535aTypePolarityInversion
    Get
    Set
public:
property Pcal9535aTypePolarityInversion PolarityInversionN10 {
    Pcal9535aTypePolarityInversion get ();
    void set (Pcal9535aTypePolarityInversion value);
}
member PolarityInversionN10 : Pcal9535aTypePolarityInversion with get, set

Property Value

Type: Pcal9535aTypePolarityInversion
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PolarityInversionN11 Property

IRD

Pcal9535aPolarityInversionN11 Property

Polarity Inversion: N1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePolarityInversion PolarityInversionN11 { get; set; }
Public Property PolarityInversionN11 As Pcal9535aTypePolarityInversion
    Get
    Set
public:
property Pcal9535aTypePolarityInversion PolarityInversionN11 {
    Pcal9535aTypePolarityInversion get ();
    void set (Pcal9535aTypePolarityInversion value);
}
member PolarityInversionN11 : Pcal9535aTypePolarityInversion with get, set

Property Value

Type: Pcal9535aTypePolarityInversion
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PolarityInversionN12 Property

IRD

Pcal9535aPolarityInversionN12 Property

Polarity Inversion: N1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePolarityInversion PolarityInversionN12 { get; set; }
Public Property PolarityInversionN12 As Pcal9535aTypePolarityInversion
    Get
    Set
public:
property Pcal9535aTypePolarityInversion PolarityInversionN12 {
    Pcal9535aTypePolarityInversion get ();
    void set (Pcal9535aTypePolarityInversion value);
}
member PolarityInversionN12 : Pcal9535aTypePolarityInversion with get, set

Property Value

Type: Pcal9535aTypePolarityInversion
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PolarityInversionN13 Property

IRD

Pcal9535aPolarityInversionN13 Property

Polarity Inversion: N1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePolarityInversion PolarityInversionN13 { get; set; }
Public Property PolarityInversionN13 As Pcal9535aTypePolarityInversion
    Get
    Set
public:
property Pcal9535aTypePolarityInversion PolarityInversionN13 {
    Pcal9535aTypePolarityInversion get ();
    void set (Pcal9535aTypePolarityInversion value);
}
member PolarityInversionN13 : Pcal9535aTypePolarityInversion with get, set

Property Value

Type: Pcal9535aTypePolarityInversion
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PolarityInversionN14 Property

IRD

Pcal9535aPolarityInversionN14 Property

Polarity Inversion: N1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePolarityInversion PolarityInversionN14 { get; set; }
Public Property PolarityInversionN14 As Pcal9535aTypePolarityInversion
    Get
    Set
public:
property Pcal9535aTypePolarityInversion PolarityInversionN14 {
    Pcal9535aTypePolarityInversion get ();
    void set (Pcal9535aTypePolarityInversion value);
}
member PolarityInversionN14 : Pcal9535aTypePolarityInversion with get, set

Property Value

Type: Pcal9535aTypePolarityInversion
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PolarityInversionN15 Property

IRD

Pcal9535aPolarityInversionN15 Property

Polarity Inversion: N1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePolarityInversion PolarityInversionN15 { get; set; }
Public Property PolarityInversionN15 As Pcal9535aTypePolarityInversion
    Get
    Set
public:
property Pcal9535aTypePolarityInversion PolarityInversionN15 {
    Pcal9535aTypePolarityInversion get ();
    void set (Pcal9535aTypePolarityInversion value);
}
member PolarityInversionN15 : Pcal9535aTypePolarityInversion with get, set

Property Value

Type: Pcal9535aTypePolarityInversion
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PolarityInversionN16 Property

IRD

Pcal9535aPolarityInversionN16 Property

Polarity Inversion: N1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePolarityInversion PolarityInversionN16 { get; set; }
Public Property PolarityInversionN16 As Pcal9535aTypePolarityInversion
    Get
    Set
public:
property Pcal9535aTypePolarityInversion PolarityInversionN16 {
    Pcal9535aTypePolarityInversion get ();
    void set (Pcal9535aTypePolarityInversion value);
}
member PolarityInversionN16 : Pcal9535aTypePolarityInversion with get, set

Property Value

Type: Pcal9535aTypePolarityInversion
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PolarityInversionN17 Property

IRD

Pcal9535aPolarityInversionN17 Property

Polarity Inversion: N1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePolarityInversion PolarityInversionN17 { get; set; }
Public Property PolarityInversionN17 As Pcal9535aTypePolarityInversion
    Get
    Set
public:
property Pcal9535aTypePolarityInversion PolarityInversionN17 {
    Pcal9535aTypePolarityInversion get ();
    void set (Pcal9535aTypePolarityInversion value);
}
member PolarityInversionN17 : Pcal9535aTypePolarityInversion with get, set

Property Value

Type: Pcal9535aTypePolarityInversion
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownEnablePE00 Property

IRD

Pcal9535aPullUpPullDownEnablePE00 Property

Pull-Up/Pull-Down Enable: PE0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE00 { get; set; }
Public Property PullUpPullDownEnablePE00 As Pcal9535aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE00 {
    Pcal9535aTypePullUpPullDownEnable get ();
    void set (Pcal9535aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE00 : Pcal9535aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownEnable
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownEnablePE01 Property

IRD

Pcal9535aPullUpPullDownEnablePE01 Property

Pull-Up/Pull-Down Enable: PE0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE01 { get; set; }
Public Property PullUpPullDownEnablePE01 As Pcal9535aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE01 {
    Pcal9535aTypePullUpPullDownEnable get ();
    void set (Pcal9535aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE01 : Pcal9535aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownEnable
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownEnablePE02 Property

IRD

Pcal9535aPullUpPullDownEnablePE02 Property

Pull-Up/Pull-Down Enable: PE0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE02 { get; set; }
Public Property PullUpPullDownEnablePE02 As Pcal9535aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE02 {
    Pcal9535aTypePullUpPullDownEnable get ();
    void set (Pcal9535aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE02 : Pcal9535aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownEnable
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownEnablePE03 Property

IRD

Pcal9535aPullUpPullDownEnablePE03 Property

Pull-Up/Pull-Down Enable: PE0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE03 { get; set; }
Public Property PullUpPullDownEnablePE03 As Pcal9535aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE03 {
    Pcal9535aTypePullUpPullDownEnable get ();
    void set (Pcal9535aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE03 : Pcal9535aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownEnable
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownEnablePE04 Property

IRD

Pcal9535aPullUpPullDownEnablePE04 Property

Pull-Up/Pull-Down Enable: PE0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE04 { get; set; }
Public Property PullUpPullDownEnablePE04 As Pcal9535aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE04 {
    Pcal9535aTypePullUpPullDownEnable get ();
    void set (Pcal9535aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE04 : Pcal9535aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownEnable
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownEnablePE05 Property

IRD

Pcal9535aPullUpPullDownEnablePE05 Property

Pull-Up/Pull-Down Enable: PE0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE05 { get; set; }
Public Property PullUpPullDownEnablePE05 As Pcal9535aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE05 {
    Pcal9535aTypePullUpPullDownEnable get ();
    void set (Pcal9535aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE05 : Pcal9535aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownEnable
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownEnablePE06 Property

IRD

Pcal9535aPullUpPullDownEnablePE06 Property

Pull-Up/Pull-Down Enable: PE0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE06 { get; set; }
Public Property PullUpPullDownEnablePE06 As Pcal9535aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE06 {
    Pcal9535aTypePullUpPullDownEnable get ();
    void set (Pcal9535aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE06 : Pcal9535aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownEnable
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownEnablePE07 Property

IRD

Pcal9535aPullUpPullDownEnablePE07 Property

Pull-Up/Pull-Down Enable: PE0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE07 { get; set; }
Public Property PullUpPullDownEnablePE07 As Pcal9535aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE07 {
    Pcal9535aTypePullUpPullDownEnable get ();
    void set (Pcal9535aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE07 : Pcal9535aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownEnable
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownEnablePE10 Property

IRD

Pcal9535aPullUpPullDownEnablePE10 Property

Pull-Up/Pull-Down Enable: PE1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE10 { get; set; }
Public Property PullUpPullDownEnablePE10 As Pcal9535aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE10 {
    Pcal9535aTypePullUpPullDownEnable get ();
    void set (Pcal9535aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE10 : Pcal9535aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownEnable
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownEnablePE11 Property

IRD

Pcal9535aPullUpPullDownEnablePE11 Property

Pull-Up/Pull-Down Enable: PE1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE11 { get; set; }
Public Property PullUpPullDownEnablePE11 As Pcal9535aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE11 {
    Pcal9535aTypePullUpPullDownEnable get ();
    void set (Pcal9535aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE11 : Pcal9535aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownEnable
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownEnablePE12 Property

IRD

Pcal9535aPullUpPullDownEnablePE12 Property

Pull-Up/Pull-Down Enable: PE1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE12 { get; set; }
Public Property PullUpPullDownEnablePE12 As Pcal9535aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE12 {
    Pcal9535aTypePullUpPullDownEnable get ();
    void set (Pcal9535aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE12 : Pcal9535aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownEnable
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownEnablePE13 Property

IRD

Pcal9535aPullUpPullDownEnablePE13 Property

Pull-Up/Pull-Down Enable: PE1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE13 { get; set; }
Public Property PullUpPullDownEnablePE13 As Pcal9535aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE13 {
    Pcal9535aTypePullUpPullDownEnable get ();
    void set (Pcal9535aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE13 : Pcal9535aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownEnable
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownEnablePE14 Property

IRD

Pcal9535aPullUpPullDownEnablePE14 Property

Pull-Up/Pull-Down Enable: PE1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE14 { get; set; }
Public Property PullUpPullDownEnablePE14 As Pcal9535aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE14 {
    Pcal9535aTypePullUpPullDownEnable get ();
    void set (Pcal9535aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE14 : Pcal9535aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownEnable
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownEnablePE15 Property

IRD

Pcal9535aPullUpPullDownEnablePE15 Property

Pull-Up/Pull-Down Enable: PE1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE15 { get; set; }
Public Property PullUpPullDownEnablePE15 As Pcal9535aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE15 {
    Pcal9535aTypePullUpPullDownEnable get ();
    void set (Pcal9535aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE15 : Pcal9535aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownEnable
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownEnablePE16 Property

IRD

Pcal9535aPullUpPullDownEnablePE16 Property

Pull-Up/Pull-Down Enable: PE1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE16 { get; set; }
Public Property PullUpPullDownEnablePE16 As Pcal9535aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE16 {
    Pcal9535aTypePullUpPullDownEnable get ();
    void set (Pcal9535aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE16 : Pcal9535aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownEnable
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownEnablePE17 Property

IRD

Pcal9535aPullUpPullDownEnablePE17 Property

Pull-Up/Pull-Down Enable: PE1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE17 { get; set; }
Public Property PullUpPullDownEnablePE17 As Pcal9535aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownEnable PullUpPullDownEnablePE17 {
    Pcal9535aTypePullUpPullDownEnable get ();
    void set (Pcal9535aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE17 : Pcal9535aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownEnable
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownSelectionPUD00 Property

IRD

Pcal9535aPullUpPullDownSelectionPUD00 Property

Pull-Up/Pull-Down Selection: PUD0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD00 { get; set; }
Public Property PullUpPullDownSelectionPUD00 As Pcal9535aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD00 {
    Pcal9535aTypePullUpPullDownSelection get ();
    void set (Pcal9535aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD00 : Pcal9535aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownSelection
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownSelectionPUD01 Property

IRD

Pcal9535aPullUpPullDownSelectionPUD01 Property

Pull-Up/Pull-Down Selection: PUD0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD01 { get; set; }
Public Property PullUpPullDownSelectionPUD01 As Pcal9535aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD01 {
    Pcal9535aTypePullUpPullDownSelection get ();
    void set (Pcal9535aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD01 : Pcal9535aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownSelection
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownSelectionPUD02 Property

IRD

Pcal9535aPullUpPullDownSelectionPUD02 Property

Pull-Up/Pull-Down Selection: PUD0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD02 { get; set; }
Public Property PullUpPullDownSelectionPUD02 As Pcal9535aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD02 {
    Pcal9535aTypePullUpPullDownSelection get ();
    void set (Pcal9535aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD02 : Pcal9535aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownSelection
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownSelectionPUD03 Property

IRD

Pcal9535aPullUpPullDownSelectionPUD03 Property

Pull-Up/Pull-Down Selection: PUD0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD03 { get; set; }
Public Property PullUpPullDownSelectionPUD03 As Pcal9535aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD03 {
    Pcal9535aTypePullUpPullDownSelection get ();
    void set (Pcal9535aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD03 : Pcal9535aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownSelection
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownSelectionPUD04 Property

IRD

Pcal9535aPullUpPullDownSelectionPUD04 Property

Pull-Up/Pull-Down Selection: PUD0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD04 { get; set; }
Public Property PullUpPullDownSelectionPUD04 As Pcal9535aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD04 {
    Pcal9535aTypePullUpPullDownSelection get ();
    void set (Pcal9535aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD04 : Pcal9535aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownSelection
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownSelectionPUD05 Property

IRD

Pcal9535aPullUpPullDownSelectionPUD05 Property

Pull-Up/Pull-Down Selection: PUD0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD05 { get; set; }
Public Property PullUpPullDownSelectionPUD05 As Pcal9535aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD05 {
    Pcal9535aTypePullUpPullDownSelection get ();
    void set (Pcal9535aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD05 : Pcal9535aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownSelection
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownSelectionPUD06 Property

IRD

Pcal9535aPullUpPullDownSelectionPUD06 Property

Pull-Up/Pull-Down Selection: PUD0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD06 { get; set; }
Public Property PullUpPullDownSelectionPUD06 As Pcal9535aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD06 {
    Pcal9535aTypePullUpPullDownSelection get ();
    void set (Pcal9535aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD06 : Pcal9535aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownSelection
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownSelectionPUD07 Property

IRD

Pcal9535aPullUpPullDownSelectionPUD07 Property

Pull-Up/Pull-Down Selection: PUD0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD07 { get; set; }
Public Property PullUpPullDownSelectionPUD07 As Pcal9535aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD07 {
    Pcal9535aTypePullUpPullDownSelection get ();
    void set (Pcal9535aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD07 : Pcal9535aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownSelection
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownSelectionPUD10 Property

IRD

Pcal9535aPullUpPullDownSelectionPUD10 Property

Pull-Up/Pull-Down Selection: PUD1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD10 { get; set; }
Public Property PullUpPullDownSelectionPUD10 As Pcal9535aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD10 {
    Pcal9535aTypePullUpPullDownSelection get ();
    void set (Pcal9535aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD10 : Pcal9535aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownSelection
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownSelectionPUD11 Property

IRD

Pcal9535aPullUpPullDownSelectionPUD11 Property

Pull-Up/Pull-Down Selection: PUD1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD11 { get; set; }
Public Property PullUpPullDownSelectionPUD11 As Pcal9535aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD11 {
    Pcal9535aTypePullUpPullDownSelection get ();
    void set (Pcal9535aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD11 : Pcal9535aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownSelection
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownSelectionPUD12 Property

IRD

Pcal9535aPullUpPullDownSelectionPUD12 Property

Pull-Up/Pull-Down Selection: PUD1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD12 { get; set; }
Public Property PullUpPullDownSelectionPUD12 As Pcal9535aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD12 {
    Pcal9535aTypePullUpPullDownSelection get ();
    void set (Pcal9535aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD12 : Pcal9535aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownSelection
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownSelectionPUD13 Property

IRD

Pcal9535aPullUpPullDownSelectionPUD13 Property

Pull-Up/Pull-Down Selection: PUD1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD13 { get; set; }
Public Property PullUpPullDownSelectionPUD13 As Pcal9535aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD13 {
    Pcal9535aTypePullUpPullDownSelection get ();
    void set (Pcal9535aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD13 : Pcal9535aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownSelection
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownSelectionPUD14 Property

IRD

Pcal9535aPullUpPullDownSelectionPUD14 Property

Pull-Up/Pull-Down Selection: PUD1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD14 { get; set; }
Public Property PullUpPullDownSelectionPUD14 As Pcal9535aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD14 {
    Pcal9535aTypePullUpPullDownSelection get ();
    void set (Pcal9535aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD14 : Pcal9535aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownSelection
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownSelectionPUD15 Property

IRD

Pcal9535aPullUpPullDownSelectionPUD15 Property

Pull-Up/Pull-Down Selection: PUD1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD15 { get; set; }
Public Property PullUpPullDownSelectionPUD15 As Pcal9535aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD15 {
    Pcal9535aTypePullUpPullDownSelection get ();
    void set (Pcal9535aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD15 : Pcal9535aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownSelection
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownSelectionPUD16 Property

IRD

Pcal9535aPullUpPullDownSelectionPUD16 Property

Pull-Up/Pull-Down Selection: PUD1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD16 { get; set; }
Public Property PullUpPullDownSelectionPUD16 As Pcal9535aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD16 {
    Pcal9535aTypePullUpPullDownSelection get ();
    void set (Pcal9535aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD16 : Pcal9535aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownSelection
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.PullUpPullDownSelectionPUD17 Property

IRD

Pcal9535aPullUpPullDownSelectionPUD17 Property

Pull-Up/Pull-Down Selection: PUD1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD17 { get; set; }
Public Property PullUpPullDownSelectionPUD17 As Pcal9535aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9535aTypePullUpPullDownSelection PullUpPullDownSelectionPUD17 {
    Pcal9535aTypePullUpPullDownSelection get ();
    void set (Pcal9535aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD17 : Pcal9535aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9535aTypePullUpPullDownSelection
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a Methods

The Pcal9535a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.Flush Method

IRD

Pcal9535aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcal9535a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9535a.TypeConfiguration Enumeration

IRD

Pcal9535aTypeConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Output | 0 | Output
Input | 1 | Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9535a.TypeInputLatch Enumeration

IRD

Pcal9535aTypeInputLatch Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInputLatch
Public Enumeration TypeInputLatch
public enum class TypeInputLatch
type TypeInputLatch
Members
Member name | Value | Description
NotLatched | 0 | Not Latched
Latched | 1 | Latched
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9535a.TypeInterruptMask Enumeration

IRD

Pcal9535aTypeInterruptMask Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptMask
Public Enumeration TypeInterruptMask
public enum class TypeInterruptMask
type TypeInterruptMask
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9535a.TypeInterruptStatus Enumeration

IRD

Pcal9535aTypeInterruptStatus Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatus
Public Enumeration TypeInterruptStatus
public enum class TypeInterruptStatus
type TypeInterruptStatus
Members
Member name | Value | Description
NotSource | 0 | Not Source
Source | 1 | Source
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9535a.TypeOutputDriveStrength Enumeration

IRD

Pcal9535aTypeOutputDriveStrength Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputDriveStrength
Public Enumeration TypeOutputDriveStrength
public enum class TypeOutputDriveStrength
type TypeOutputDriveStrength
Members
Member name | Value | Description
Value_025x | 0 | 0.25x
Value_05x | 1 | 0.5x
Value_075x | 2 | 0.75x
Value_10x | 3 | 1.0x
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9535a.TypeOutputPortConfiguration Enumeration

IRD

Pcal9535aTypeOutputPortConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputPortConfiguration
Public Enumeration TypeOutputPortConfiguration
public enum class TypeOutputPortConfiguration
type TypeOutputPortConfiguration
Members
Member name | Value | Description
PushPull | 0 | Push-Pull
OpenDrain | 1 | Open-Drain
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9535a.TypePolarityInversion Enumeration

IRD

Pcal9535aTypePolarityInversion Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarityInversion
Public Enumeration TypePolarityInversion
public enum class TypePolarityInversion
type TypePolarityInversion
Members
Member name | Value | Description
NotInverted | 0 | Not Inverted
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9535a.TypePullUpPullDownEnable Enumeration

IRD

Pcal9535aTypePullUpPullDownEnable Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePullUpPullDownEnable
Public Enumeration TypePullUpPullDownEnable
public enum class TypePullUpPullDownEnable
type TypePullUpPullDownEnable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9535a.TypePullUpPullDownSelection Enumeration

IRD

Pcal9535aTypePullUpPullDownSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePullUpPullDownSelection
Public Enumeration TypePullUpPullDownSelection
public enum class TypePullUpPullDownSelection
type TypePullUpPullDownSelection
Members
Member name | Value | Description
Value_100KΩPullDown | 0 | 100 kΩ Pull-Down
Value_100KΩPullUp | 1 | 100 kΩ Pull-Up
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9538a Class

NXP Semiconductors: PCAL 9538A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPcal9538a

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcal9538a
Public Class Pcal9538a
public ref class Pcal9538a
type Pcal9538a =  class end

The Pcal9538a type exposes the following members.

Constructors
 | Name | Description
Public method | Pcal9538a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC0 | Configuration: C0
Public property | ConfigurationC1 | Configuration: C1
Public property | ConfigurationC2 | Configuration: C2
Public property | ConfigurationC3 | Configuration: C3
Public property | ConfigurationC4 | Configuration: C4
Public property | ConfigurationC5 | Configuration: C5
Public property | ConfigurationC6 | Configuration: C6
Public property | ConfigurationC7 | Configuration: C7
Public property | InputLatchL0 | Input Latch: L0
Public property | InputLatchL1 | Input Latch: L1
Public property | InputLatchL2 | Input Latch: L2
Public property | InputLatchL3 | Input Latch: L3
Public property | InputLatchL4 | Input Latch: L4
Public property | InputLatchL5 | Input Latch: L5
Public property | InputLatchL6 | Input Latch: L6
Public property | InputLatchL7 | Input Latch: L7
Public property | InputPortI0 | Input Port: I0
Public property | InputPortI1 | Input Port: I1
Public property | InputPortI2 | Input Port: I2
Public property | InputPortI3 | Input Port: I3
Public property | InputPortI4 | Input Port: I4
Public property | InputPortI5 | Input Port: I5
Public property | InputPortI6 | Input Port: I6
Public property | InputPortI7 | Input Port: I7
Public property | InterruptMaskM0 | Interrupt Mask: M0
Public property | InterruptMaskM1 | Interrupt Mask: M1
Public property | InterruptMaskM2 | Interrupt Mask: M2
Public property | InterruptMaskM3 | Interrupt Mask: M3
Public property | InterruptMaskM4 | Interrupt Mask: M4
Public property | InterruptMaskM5 | Interrupt Mask: M5
Public property | InterruptMaskM6 | Interrupt Mask: M6
Public property | InterruptMaskM7 | Interrupt Mask: M7
Public property | InterruptStatusS0 | Interrupt Status: S0
Public property | InterruptStatusS1 | Interrupt Status: S1
Public property | InterruptStatusS2 | Interrupt Status: S2
Public property | InterruptStatusS3 | Interrupt Status: S3
Public property | InterruptStatusS4 | Interrupt Status: S4
Public property | InterruptStatusS5 | Interrupt Status: S5
Public property | InterruptStatusS6 | Interrupt Status: S6
Public property | InterruptStatusS7 | Interrupt Status: S7
Public property | OutputDriveStrengthCC0 | Output Drive Strength: CC0
Public property | OutputDriveStrengthCC1 | Output Drive Strength: CC1
Public property | OutputDriveStrengthCC2 | Output Drive Strength: CC2
Public property | OutputDriveStrengthCC3 | Output Drive Strength: CC3
Public property | OutputDriveStrengthCC4 | Output Drive Strength: CC4
Public property | OutputDriveStrengthCC5 | Output Drive Strength: CC5
Public property | OutputDriveStrengthCC6 | Output Drive Strength: CC6
Public property | OutputDriveStrengthCC7 | Output Drive Strength: CC7
Public property | OutputPortConfigurationODEN0 | Output Port Configuration: ODEN0
Public property | OutputPortO0 | Output Port: O0
Public property | OutputPortO1 | Output Port: O1
Public property | OutputPortO2 | Output Port: O2
Public property | OutputPortO3 | Output Port: O3
Public property | OutputPortO4 | Output Port: O4
Public property | OutputPortO5 | Output Port: O5
Public property | OutputPortO6 | Output Port: O6
Public property | OutputPortO7 | Output Port: O7
Public property | PolarityInversionN0 | Polarity Inversion: N0
Public property | PolarityInversionN1 | Polarity Inversion: N1
Public property | PolarityInversionN2 | Polarity Inversion: N2
Public property | PolarityInversionN3 | Polarity Inversion: N3
Public property | PolarityInversionN4 | Polarity Inversion: N4
Public property | PolarityInversionN5 | Polarity Inversion: N5
Public property | PolarityInversionN6 | Polarity Inversion: N6
Public property | PolarityInversionN7 | Polarity Inversion: N7
Public property | PullUpPullDownEnablePE0 | Pull-Up/Pull-Down Enable: PE0
Public property | PullUpPullDownEnablePE1 | Pull-Up/Pull-Down Enable: PE1
Public property | PullUpPullDownEnablePE2 | Pull-Up/Pull-Down Enable: PE2
Public property | PullUpPullDownEnablePE3 | Pull-Up/Pull-Down Enable: PE3
Public property | PullUpPullDownEnablePE4 | Pull-Up/Pull-Down Enable: PE4
Public property | PullUpPullDownEnablePE5 | Pull-Up/Pull-Down Enable: PE5
Public property | PullUpPullDownEnablePE6 | Pull-Up/Pull-Down Enable: PE6
Public property | PullUpPullDownEnablePE7 | Pull-Up/Pull-Down Enable: PE7
Public property | PullUpPullDownSelectionPUD0 | Pull-Up/Pull-Down Selection: PUD0
Public property | PullUpPullDownSelectionPUD1 | Pull-Up/Pull-Down Selection: PUD1
Public property | PullUpPullDownSelectionPUD2 | Pull-Up/Pull-Down Selection: PUD2
Public property | PullUpPullDownSelectionPUD3 | Pull-Up/Pull-Down Selection: PUD3
Public property | PullUpPullDownSelectionPUD4 | Pull-Up/Pull-Down Selection: PUD4
Public property | PullUpPullDownSelectionPUD5 | Pull-Up/Pull-Down Selection: PUD5
Public property | PullUpPullDownSelectionPUD6 | Pull-Up/Pull-Down Selection: PUD6
Public property | PullUpPullDownSelectionPUD7 | Pull-Up/Pull-Down Selection: PUD7
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Voltage 8-Bit I2C-Bus And SMBus Low Power I/O Port With Interrupt, Reset And Agile I/O
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9538a Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcal9538a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcal9538a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a Properties

The Pcal9538a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC0 | Configuration: C0
Public property | ConfigurationC1 | Configuration: C1
Public property | ConfigurationC2 | Configuration: C2
Public property | ConfigurationC3 | Configuration: C3
Public property | ConfigurationC4 | Configuration: C4
Public property | ConfigurationC5 | Configuration: C5
Public property | ConfigurationC6 | Configuration: C6
Public property | ConfigurationC7 | Configuration: C7
Public property | InputLatchL0 | Input Latch: L0
Public property | InputLatchL1 | Input Latch: L1
Public property | InputLatchL2 | Input Latch: L2
Public property | InputLatchL3 | Input Latch: L3
Public property | InputLatchL4 | Input Latch: L4
Public property | InputLatchL5 | Input Latch: L5
Public property | InputLatchL6 | Input Latch: L6
Public property | InputLatchL7 | Input Latch: L7
Public property | InputPortI0 | Input Port: I0
Public property | InputPortI1 | Input Port: I1
Public property | InputPortI2 | Input Port: I2
Public property | InputPortI3 | Input Port: I3
Public property | InputPortI4 | Input Port: I4
Public property | InputPortI5 | Input Port: I5
Public property | InputPortI6 | Input Port: I6
Public property | InputPortI7 | Input Port: I7
Public property | InterruptMaskM0 | Interrupt Mask: M0
Public property | InterruptMaskM1 | Interrupt Mask: M1
Public property | InterruptMaskM2 | Interrupt Mask: M2
Public property | InterruptMaskM3 | Interrupt Mask: M3
Public property | InterruptMaskM4 | Interrupt Mask: M4
Public property | InterruptMaskM5 | Interrupt Mask: M5
Public property | InterruptMaskM6 | Interrupt Mask: M6
Public property | InterruptMaskM7 | Interrupt Mask: M7
Public property | InterruptStatusS0 | Interrupt Status: S0
Public property | InterruptStatusS1 | Interrupt Status: S1
Public property | InterruptStatusS2 | Interrupt Status: S2
Public property | InterruptStatusS3 | Interrupt Status: S3
Public property | InterruptStatusS4 | Interrupt Status: S4
Public property | InterruptStatusS5 | Interrupt Status: S5
Public property | InterruptStatusS6 | Interrupt Status: S6
Public property | InterruptStatusS7 | Interrupt Status: S7
Public property | OutputDriveStrengthCC0 | Output Drive Strength: CC0
Public property | OutputDriveStrengthCC1 | Output Drive Strength: CC1
Public property | OutputDriveStrengthCC2 | Output Drive Strength: CC2
Public property | OutputDriveStrengthCC3 | Output Drive Strength: CC3
Public property | OutputDriveStrengthCC4 | Output Drive Strength: CC4
Public property | OutputDriveStrengthCC5 | Output Drive Strength: CC5
Public property | OutputDriveStrengthCC6 | Output Drive Strength: CC6
Public property | OutputDriveStrengthCC7 | Output Drive Strength: CC7
Public property | OutputPortConfigurationODEN0 | Output Port Configuration: ODEN0
Public property | OutputPortO0 | Output Port: O0
Public property | OutputPortO1 | Output Port: O1
Public property | OutputPortO2 | Output Port: O2
Public property | OutputPortO3 | Output Port: O3
Public property | OutputPortO4 | Output Port: O4
Public property | OutputPortO5 | Output Port: O5
Public property | OutputPortO6 | Output Port: O6
Public property | OutputPortO7 | Output Port: O7
Public property | PolarityInversionN0 | Polarity Inversion: N0
Public property | PolarityInversionN1 | Polarity Inversion: N1
Public property | PolarityInversionN2 | Polarity Inversion: N2
Public property | PolarityInversionN3 | Polarity Inversion: N3
Public property | PolarityInversionN4 | Polarity Inversion: N4
Public property | PolarityInversionN5 | Polarity Inversion: N5
Public property | PolarityInversionN6 | Polarity Inversion: N6
Public property | PolarityInversionN7 | Polarity Inversion: N7
Public property | PullUpPullDownEnablePE0 | Pull-Up/Pull-Down Enable: PE0
Public property | PullUpPullDownEnablePE1 | Pull-Up/Pull-Down Enable: PE1
Public property | PullUpPullDownEnablePE2 | Pull-Up/Pull-Down Enable: PE2
Public property | PullUpPullDownEnablePE3 | Pull-Up/Pull-Down Enable: PE3
Public property | PullUpPullDownEnablePE4 | Pull-Up/Pull-Down Enable: PE4
Public property | PullUpPullDownEnablePE5 | Pull-Up/Pull-Down Enable: PE5
Public property | PullUpPullDownEnablePE6 | Pull-Up/Pull-Down Enable: PE6
Public property | PullUpPullDownEnablePE7 | Pull-Up/Pull-Down Enable: PE7
Public property | PullUpPullDownSelectionPUD0 | Pull-Up/Pull-Down Selection: PUD0
Public property | PullUpPullDownSelectionPUD1 | Pull-Up/Pull-Down Selection: PUD1
Public property | PullUpPullDownSelectionPUD2 | Pull-Up/Pull-Down Selection: PUD2
Public property | PullUpPullDownSelectionPUD3 | Pull-Up/Pull-Down Selection: PUD3
Public property | PullUpPullDownSelectionPUD4 | Pull-Up/Pull-Down Selection: PUD4
Public property | PullUpPullDownSelectionPUD5 | Pull-Up/Pull-Down Selection: PUD5
Public property | PullUpPullDownSelectionPUD6 | Pull-Up/Pull-Down Selection: PUD6
Public property | PullUpPullDownSelectionPUD7 | Pull-Up/Pull-Down Selection: PUD7
Top
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.AutoFlush Property

IRD

Pcal9538aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.ConfigurationC0 Property

IRD

Pcal9538aConfigurationC0 Property

Configuration: C0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeConfiguration ConfigurationC0 { get; set; }
Public Property ConfigurationC0 As Pcal9538aTypeConfiguration
    Get
    Set
public:
property Pcal9538aTypeConfiguration ConfigurationC0 {
    Pcal9538aTypeConfiguration get ();
    void set (Pcal9538aTypeConfiguration value);
}
member ConfigurationC0 : Pcal9538aTypeConfiguration with get, set

Property Value

Type: Pcal9538aTypeConfiguration
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.ConfigurationC1 Property

IRD

Pcal9538aConfigurationC1 Property

Configuration: C1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeConfiguration ConfigurationC1 { get; set; }
Public Property ConfigurationC1 As Pcal9538aTypeConfiguration
    Get
    Set
public:
property Pcal9538aTypeConfiguration ConfigurationC1 {
    Pcal9538aTypeConfiguration get ();
    void set (Pcal9538aTypeConfiguration value);
}
member ConfigurationC1 : Pcal9538aTypeConfiguration with get, set

Property Value

Type: Pcal9538aTypeConfiguration
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.ConfigurationC2 Property

IRD

Pcal9538aConfigurationC2 Property

Configuration: C2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeConfiguration ConfigurationC2 { get; set; }
Public Property ConfigurationC2 As Pcal9538aTypeConfiguration
    Get
    Set
public:
property Pcal9538aTypeConfiguration ConfigurationC2 {
    Pcal9538aTypeConfiguration get ();
    void set (Pcal9538aTypeConfiguration value);
}
member ConfigurationC2 : Pcal9538aTypeConfiguration with get, set

Property Value

Type: Pcal9538aTypeConfiguration
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.ConfigurationC3 Property

IRD

Pcal9538aConfigurationC3 Property

Configuration: C3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeConfiguration ConfigurationC3 { get; set; }
Public Property ConfigurationC3 As Pcal9538aTypeConfiguration
    Get
    Set
public:
property Pcal9538aTypeConfiguration ConfigurationC3 {
    Pcal9538aTypeConfiguration get ();
    void set (Pcal9538aTypeConfiguration value);
}
member ConfigurationC3 : Pcal9538aTypeConfiguration with get, set

Property Value

Type: Pcal9538aTypeConfiguration
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.ConfigurationC4 Property

IRD

Pcal9538aConfigurationC4 Property

Configuration: C4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeConfiguration ConfigurationC4 { get; set; }
Public Property ConfigurationC4 As Pcal9538aTypeConfiguration
    Get
    Set
public:
property Pcal9538aTypeConfiguration ConfigurationC4 {
    Pcal9538aTypeConfiguration get ();
    void set (Pcal9538aTypeConfiguration value);
}
member ConfigurationC4 : Pcal9538aTypeConfiguration with get, set

Property Value

Type: Pcal9538aTypeConfiguration
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.ConfigurationC5 Property

IRD

Pcal9538aConfigurationC5 Property

Configuration: C5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeConfiguration ConfigurationC5 { get; set; }
Public Property ConfigurationC5 As Pcal9538aTypeConfiguration
    Get
    Set
public:
property Pcal9538aTypeConfiguration ConfigurationC5 {
    Pcal9538aTypeConfiguration get ();
    void set (Pcal9538aTypeConfiguration value);
}
member ConfigurationC5 : Pcal9538aTypeConfiguration with get, set

Property Value

Type: Pcal9538aTypeConfiguration
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.ConfigurationC6 Property

IRD

Pcal9538aConfigurationC6 Property

Configuration: C6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeConfiguration ConfigurationC6 { get; set; }
Public Property ConfigurationC6 As Pcal9538aTypeConfiguration
    Get
    Set
public:
property Pcal9538aTypeConfiguration ConfigurationC6 {
    Pcal9538aTypeConfiguration get ();
    void set (Pcal9538aTypeConfiguration value);
}
member ConfigurationC6 : Pcal9538aTypeConfiguration with get, set

Property Value

Type: Pcal9538aTypeConfiguration
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.ConfigurationC7 Property

IRD

Pcal9538aConfigurationC7 Property

Configuration: C7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeConfiguration ConfigurationC7 { get; set; }
Public Property ConfigurationC7 As Pcal9538aTypeConfiguration
    Get
    Set
public:
property Pcal9538aTypeConfiguration ConfigurationC7 {
    Pcal9538aTypeConfiguration get ();
    void set (Pcal9538aTypeConfiguration value);
}
member ConfigurationC7 : Pcal9538aTypeConfiguration with get, set

Property Value

Type: Pcal9538aTypeConfiguration
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InputLatchL0 Property

IRD

Pcal9538aInputLatchL0 Property

Input Latch: L0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInputLatch InputLatchL0 { get; set; }
Public Property InputLatchL0 As Pcal9538aTypeInputLatch
    Get
    Set
public:
property Pcal9538aTypeInputLatch InputLatchL0 {
    Pcal9538aTypeInputLatch get ();
    void set (Pcal9538aTypeInputLatch value);
}
member InputLatchL0 : Pcal9538aTypeInputLatch with get, set

Property Value

Type: Pcal9538aTypeInputLatch
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InputLatchL1 Property

IRD

Pcal9538aInputLatchL1 Property

Input Latch: L1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInputLatch InputLatchL1 { get; set; }
Public Property InputLatchL1 As Pcal9538aTypeInputLatch
    Get
    Set
public:
property Pcal9538aTypeInputLatch InputLatchL1 {
    Pcal9538aTypeInputLatch get ();
    void set (Pcal9538aTypeInputLatch value);
}
member InputLatchL1 : Pcal9538aTypeInputLatch with get, set

Property Value

Type: Pcal9538aTypeInputLatch
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InputLatchL2 Property

IRD

Pcal9538aInputLatchL2 Property

Input Latch: L2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInputLatch InputLatchL2 { get; set; }
Public Property InputLatchL2 As Pcal9538aTypeInputLatch
    Get
    Set
public:
property Pcal9538aTypeInputLatch InputLatchL2 {
    Pcal9538aTypeInputLatch get ();
    void set (Pcal9538aTypeInputLatch value);
}
member InputLatchL2 : Pcal9538aTypeInputLatch with get, set

Property Value

Type: Pcal9538aTypeInputLatch
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InputLatchL3 Property

IRD

Pcal9538aInputLatchL3 Property

Input Latch: L3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInputLatch InputLatchL3 { get; set; }
Public Property InputLatchL3 As Pcal9538aTypeInputLatch
    Get
    Set
public:
property Pcal9538aTypeInputLatch InputLatchL3 {
    Pcal9538aTypeInputLatch get ();
    void set (Pcal9538aTypeInputLatch value);
}
member InputLatchL3 : Pcal9538aTypeInputLatch with get, set

Property Value

Type: Pcal9538aTypeInputLatch
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InputLatchL4 Property

IRD

Pcal9538aInputLatchL4 Property

Input Latch: L4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInputLatch InputLatchL4 { get; set; }
Public Property InputLatchL4 As Pcal9538aTypeInputLatch
    Get
    Set
public:
property Pcal9538aTypeInputLatch InputLatchL4 {
    Pcal9538aTypeInputLatch get ();
    void set (Pcal9538aTypeInputLatch value);
}
member InputLatchL4 : Pcal9538aTypeInputLatch with get, set

Property Value

Type: Pcal9538aTypeInputLatch
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InputLatchL5 Property

IRD

Pcal9538aInputLatchL5 Property

Input Latch: L5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInputLatch InputLatchL5 { get; set; }
Public Property InputLatchL5 As Pcal9538aTypeInputLatch
    Get
    Set
public:
property Pcal9538aTypeInputLatch InputLatchL5 {
    Pcal9538aTypeInputLatch get ();
    void set (Pcal9538aTypeInputLatch value);
}
member InputLatchL5 : Pcal9538aTypeInputLatch with get, set

Property Value

Type: Pcal9538aTypeInputLatch
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InputLatchL6 Property

IRD

Pcal9538aInputLatchL6 Property

Input Latch: L6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInputLatch InputLatchL6 { get; set; }
Public Property InputLatchL6 As Pcal9538aTypeInputLatch
    Get
    Set
public:
property Pcal9538aTypeInputLatch InputLatchL6 {
    Pcal9538aTypeInputLatch get ();
    void set (Pcal9538aTypeInputLatch value);
}
member InputLatchL6 : Pcal9538aTypeInputLatch with get, set

Property Value

Type: Pcal9538aTypeInputLatch
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InputLatchL7 Property

IRD

Pcal9538aInputLatchL7 Property

Input Latch: L7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInputLatch InputLatchL7 { get; set; }
Public Property InputLatchL7 As Pcal9538aTypeInputLatch
    Get
    Set
public:
property Pcal9538aTypeInputLatch InputLatchL7 {
    Pcal9538aTypeInputLatch get ();
    void set (Pcal9538aTypeInputLatch value);
}
member InputLatchL7 : Pcal9538aTypeInputLatch with get, set

Property Value

Type: Pcal9538aTypeInputLatch
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InputPortI0 Property

IRD

Pcal9538aInputPortI0 Property

Input Port: I0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI0 { get; }
Public ReadOnly Property InputPortI0 As Byte
    Get
public:
property unsigned char InputPortI0 {
    unsigned char get ();
}
member InputPortI0 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InputPortI1 Property

IRD

Pcal9538aInputPortI1 Property

Input Port: I1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI1 { get; }
Public ReadOnly Property InputPortI1 As Byte
    Get
public:
property unsigned char InputPortI1 {
    unsigned char get ();
}
member InputPortI1 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InputPortI2 Property

IRD

Pcal9538aInputPortI2 Property

Input Port: I2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI2 { get; }
Public ReadOnly Property InputPortI2 As Byte
    Get
public:
property unsigned char InputPortI2 {
    unsigned char get ();
}
member InputPortI2 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InputPortI3 Property

IRD

Pcal9538aInputPortI3 Property

Input Port: I3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI3 { get; }
Public ReadOnly Property InputPortI3 As Byte
    Get
public:
property unsigned char InputPortI3 {
    unsigned char get ();
}
member InputPortI3 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InputPortI4 Property

IRD

Pcal9538aInputPortI4 Property

Input Port: I4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI4 { get; }
Public ReadOnly Property InputPortI4 As Byte
    Get
public:
property unsigned char InputPortI4 {
    unsigned char get ();
}
member InputPortI4 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InputPortI5 Property

IRD

Pcal9538aInputPortI5 Property

Input Port: I5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI5 { get; }
Public ReadOnly Property InputPortI5 As Byte
    Get
public:
property unsigned char InputPortI5 {
    unsigned char get ();
}
member InputPortI5 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InputPortI6 Property

IRD

Pcal9538aInputPortI6 Property

Input Port: I6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI6 { get; }
Public ReadOnly Property InputPortI6 As Byte
    Get
public:
property unsigned char InputPortI6 {
    unsigned char get ();
}
member InputPortI6 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InputPortI7 Property

IRD

Pcal9538aInputPortI7 Property

Input Port: I7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI7 { get; }
Public ReadOnly Property InputPortI7 As Byte
    Get
public:
property unsigned char InputPortI7 {
    unsigned char get ();
}
member InputPortI7 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InterruptMaskM0 Property

IRD

Pcal9538aInterruptMaskM0 Property

Interrupt Mask: M0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInterruptMask InterruptMaskM0 { get; set; }
Public Property InterruptMaskM0 As Pcal9538aTypeInterruptMask
    Get
    Set
public:
property Pcal9538aTypeInterruptMask InterruptMaskM0 {
    Pcal9538aTypeInterruptMask get ();
    void set (Pcal9538aTypeInterruptMask value);
}
member InterruptMaskM0 : Pcal9538aTypeInterruptMask with get, set

Property Value

Type: Pcal9538aTypeInterruptMask
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InterruptMaskM1 Property

IRD

Pcal9538aInterruptMaskM1 Property

Interrupt Mask: M1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInterruptMask InterruptMaskM1 { get; set; }
Public Property InterruptMaskM1 As Pcal9538aTypeInterruptMask
    Get
    Set
public:
property Pcal9538aTypeInterruptMask InterruptMaskM1 {
    Pcal9538aTypeInterruptMask get ();
    void set (Pcal9538aTypeInterruptMask value);
}
member InterruptMaskM1 : Pcal9538aTypeInterruptMask with get, set

Property Value

Type: Pcal9538aTypeInterruptMask
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InterruptMaskM2 Property

IRD

Pcal9538aInterruptMaskM2 Property

Interrupt Mask: M2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInterruptMask InterruptMaskM2 { get; set; }
Public Property InterruptMaskM2 As Pcal9538aTypeInterruptMask
    Get
    Set
public:
property Pcal9538aTypeInterruptMask InterruptMaskM2 {
    Pcal9538aTypeInterruptMask get ();
    void set (Pcal9538aTypeInterruptMask value);
}
member InterruptMaskM2 : Pcal9538aTypeInterruptMask with get, set

Property Value

Type: Pcal9538aTypeInterruptMask
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InterruptMaskM3 Property

IRD

Pcal9538aInterruptMaskM3 Property

Interrupt Mask: M3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInterruptMask InterruptMaskM3 { get; set; }
Public Property InterruptMaskM3 As Pcal9538aTypeInterruptMask
    Get
    Set
public:
property Pcal9538aTypeInterruptMask InterruptMaskM3 {
    Pcal9538aTypeInterruptMask get ();
    void set (Pcal9538aTypeInterruptMask value);
}
member InterruptMaskM3 : Pcal9538aTypeInterruptMask with get, set

Property Value

Type: Pcal9538aTypeInterruptMask
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InterruptMaskM4 Property

IRD

Pcal9538aInterruptMaskM4 Property

Interrupt Mask: M4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInterruptMask InterruptMaskM4 { get; set; }
Public Property InterruptMaskM4 As Pcal9538aTypeInterruptMask
    Get
    Set
public:
property Pcal9538aTypeInterruptMask InterruptMaskM4 {
    Pcal9538aTypeInterruptMask get ();
    void set (Pcal9538aTypeInterruptMask value);
}
member InterruptMaskM4 : Pcal9538aTypeInterruptMask with get, set

Property Value

Type: Pcal9538aTypeInterruptMask
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InterruptMaskM5 Property

IRD

Pcal9538aInterruptMaskM5 Property

Interrupt Mask: M5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInterruptMask InterruptMaskM5 { get; set; }
Public Property InterruptMaskM5 As Pcal9538aTypeInterruptMask
    Get
    Set
public:
property Pcal9538aTypeInterruptMask InterruptMaskM5 {
    Pcal9538aTypeInterruptMask get ();
    void set (Pcal9538aTypeInterruptMask value);
}
member InterruptMaskM5 : Pcal9538aTypeInterruptMask with get, set

Property Value

Type: Pcal9538aTypeInterruptMask
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InterruptMaskM6 Property

IRD

Pcal9538aInterruptMaskM6 Property

Interrupt Mask: M6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInterruptMask InterruptMaskM6 { get; set; }
Public Property InterruptMaskM6 As Pcal9538aTypeInterruptMask
    Get
    Set
public:
property Pcal9538aTypeInterruptMask InterruptMaskM6 {
    Pcal9538aTypeInterruptMask get ();
    void set (Pcal9538aTypeInterruptMask value);
}
member InterruptMaskM6 : Pcal9538aTypeInterruptMask with get, set

Property Value

Type: Pcal9538aTypeInterruptMask
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InterruptMaskM7 Property

IRD

Pcal9538aInterruptMaskM7 Property

Interrupt Mask: M7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInterruptMask InterruptMaskM7 { get; set; }
Public Property InterruptMaskM7 As Pcal9538aTypeInterruptMask
    Get
    Set
public:
property Pcal9538aTypeInterruptMask InterruptMaskM7 {
    Pcal9538aTypeInterruptMask get ();
    void set (Pcal9538aTypeInterruptMask value);
}
member InterruptMaskM7 : Pcal9538aTypeInterruptMask with get, set

Property Value

Type: Pcal9538aTypeInterruptMask
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InterruptStatusS0 Property

IRD

Pcal9538aInterruptStatusS0 Property

Interrupt Status: S0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInterruptStatus InterruptStatusS0 { get; }
Public ReadOnly Property InterruptStatusS0 As Pcal9538aTypeInterruptStatus
    Get
public:
property Pcal9538aTypeInterruptStatus InterruptStatusS0 {
    Pcal9538aTypeInterruptStatus get ();
}
member InterruptStatusS0 : Pcal9538aTypeInterruptStatus with get

Property Value

Type: Pcal9538aTypeInterruptStatus
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InterruptStatusS1 Property

IRD

Pcal9538aInterruptStatusS1 Property

Interrupt Status: S1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInterruptStatus InterruptStatusS1 { get; }
Public ReadOnly Property InterruptStatusS1 As Pcal9538aTypeInterruptStatus
    Get
public:
property Pcal9538aTypeInterruptStatus InterruptStatusS1 {
    Pcal9538aTypeInterruptStatus get ();
}
member InterruptStatusS1 : Pcal9538aTypeInterruptStatus with get

Property Value

Type: Pcal9538aTypeInterruptStatus
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InterruptStatusS2 Property

IRD

Pcal9538aInterruptStatusS2 Property

Interrupt Status: S2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInterruptStatus InterruptStatusS2 { get; }
Public ReadOnly Property InterruptStatusS2 As Pcal9538aTypeInterruptStatus
    Get
public:
property Pcal9538aTypeInterruptStatus InterruptStatusS2 {
    Pcal9538aTypeInterruptStatus get ();
}
member InterruptStatusS2 : Pcal9538aTypeInterruptStatus with get

Property Value

Type: Pcal9538aTypeInterruptStatus
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InterruptStatusS3 Property

IRD

Pcal9538aInterruptStatusS3 Property

Interrupt Status: S3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInterruptStatus InterruptStatusS3 { get; }
Public ReadOnly Property InterruptStatusS3 As Pcal9538aTypeInterruptStatus
    Get
public:
property Pcal9538aTypeInterruptStatus InterruptStatusS3 {
    Pcal9538aTypeInterruptStatus get ();
}
member InterruptStatusS3 : Pcal9538aTypeInterruptStatus with get

Property Value

Type: Pcal9538aTypeInterruptStatus
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InterruptStatusS4 Property

IRD

Pcal9538aInterruptStatusS4 Property

Interrupt Status: S4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInterruptStatus InterruptStatusS4 { get; }
Public ReadOnly Property InterruptStatusS4 As Pcal9538aTypeInterruptStatus
    Get
public:
property Pcal9538aTypeInterruptStatus InterruptStatusS4 {
    Pcal9538aTypeInterruptStatus get ();
}
member InterruptStatusS4 : Pcal9538aTypeInterruptStatus with get

Property Value

Type: Pcal9538aTypeInterruptStatus
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InterruptStatusS5 Property

IRD

Pcal9538aInterruptStatusS5 Property

Interrupt Status: S5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInterruptStatus InterruptStatusS5 { get; }
Public ReadOnly Property InterruptStatusS5 As Pcal9538aTypeInterruptStatus
    Get
public:
property Pcal9538aTypeInterruptStatus InterruptStatusS5 {
    Pcal9538aTypeInterruptStatus get ();
}
member InterruptStatusS5 : Pcal9538aTypeInterruptStatus with get

Property Value

Type: Pcal9538aTypeInterruptStatus
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InterruptStatusS6 Property

IRD

Pcal9538aInterruptStatusS6 Property

Interrupt Status: S6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInterruptStatus InterruptStatusS6 { get; }
Public ReadOnly Property InterruptStatusS6 As Pcal9538aTypeInterruptStatus
    Get
public:
property Pcal9538aTypeInterruptStatus InterruptStatusS6 {
    Pcal9538aTypeInterruptStatus get ();
}
member InterruptStatusS6 : Pcal9538aTypeInterruptStatus with get

Property Value

Type: Pcal9538aTypeInterruptStatus
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.InterruptStatusS7 Property

IRD

Pcal9538aInterruptStatusS7 Property

Interrupt Status: S7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeInterruptStatus InterruptStatusS7 { get; }
Public ReadOnly Property InterruptStatusS7 As Pcal9538aTypeInterruptStatus
    Get
public:
property Pcal9538aTypeInterruptStatus InterruptStatusS7 {
    Pcal9538aTypeInterruptStatus get ();
}
member InterruptStatusS7 : Pcal9538aTypeInterruptStatus with get

Property Value

Type: Pcal9538aTypeInterruptStatus
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.OutputDriveStrengthCC0 Property

IRD

Pcal9538aOutputDriveStrengthCC0 Property

Output Drive Strength: CC0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeOutputDriveStrength OutputDriveStrengthCC0 { get; set; }
Public Property OutputDriveStrengthCC0 As Pcal9538aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9538aTypeOutputDriveStrength OutputDriveStrengthCC0 {
    Pcal9538aTypeOutputDriveStrength get ();
    void set (Pcal9538aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC0 : Pcal9538aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9538aTypeOutputDriveStrength
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.OutputDriveStrengthCC1 Property

IRD

Pcal9538aOutputDriveStrengthCC1 Property

Output Drive Strength: CC1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeOutputDriveStrength OutputDriveStrengthCC1 { get; set; }
Public Property OutputDriveStrengthCC1 As Pcal9538aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9538aTypeOutputDriveStrength OutputDriveStrengthCC1 {
    Pcal9538aTypeOutputDriveStrength get ();
    void set (Pcal9538aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC1 : Pcal9538aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9538aTypeOutputDriveStrength
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.OutputDriveStrengthCC2 Property

IRD

Pcal9538aOutputDriveStrengthCC2 Property

Output Drive Strength: CC2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeOutputDriveStrength OutputDriveStrengthCC2 { get; set; }
Public Property OutputDriveStrengthCC2 As Pcal9538aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9538aTypeOutputDriveStrength OutputDriveStrengthCC2 {
    Pcal9538aTypeOutputDriveStrength get ();
    void set (Pcal9538aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC2 : Pcal9538aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9538aTypeOutputDriveStrength
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.OutputDriveStrengthCC3 Property

IRD

Pcal9538aOutputDriveStrengthCC3 Property

Output Drive Strength: CC3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeOutputDriveStrength OutputDriveStrengthCC3 { get; set; }
Public Property OutputDriveStrengthCC3 As Pcal9538aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9538aTypeOutputDriveStrength OutputDriveStrengthCC3 {
    Pcal9538aTypeOutputDriveStrength get ();
    void set (Pcal9538aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC3 : Pcal9538aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9538aTypeOutputDriveStrength
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.OutputDriveStrengthCC4 Property

IRD

Pcal9538aOutputDriveStrengthCC4 Property

Output Drive Strength: CC4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeOutputDriveStrength OutputDriveStrengthCC4 { get; set; }
Public Property OutputDriveStrengthCC4 As Pcal9538aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9538aTypeOutputDriveStrength OutputDriveStrengthCC4 {
    Pcal9538aTypeOutputDriveStrength get ();
    void set (Pcal9538aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC4 : Pcal9538aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9538aTypeOutputDriveStrength
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.OutputDriveStrengthCC5 Property

IRD

Pcal9538aOutputDriveStrengthCC5 Property

Output Drive Strength: CC5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeOutputDriveStrength OutputDriveStrengthCC5 { get; set; }
Public Property OutputDriveStrengthCC5 As Pcal9538aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9538aTypeOutputDriveStrength OutputDriveStrengthCC5 {
    Pcal9538aTypeOutputDriveStrength get ();
    void set (Pcal9538aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC5 : Pcal9538aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9538aTypeOutputDriveStrength
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.OutputDriveStrengthCC6 Property

IRD

Pcal9538aOutputDriveStrengthCC6 Property

Output Drive Strength: CC6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeOutputDriveStrength OutputDriveStrengthCC6 { get; set; }
Public Property OutputDriveStrengthCC6 As Pcal9538aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9538aTypeOutputDriveStrength OutputDriveStrengthCC6 {
    Pcal9538aTypeOutputDriveStrength get ();
    void set (Pcal9538aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC6 : Pcal9538aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9538aTypeOutputDriveStrength
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.OutputDriveStrengthCC7 Property

IRD

Pcal9538aOutputDriveStrengthCC7 Property

Output Drive Strength: CC7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeOutputDriveStrength OutputDriveStrengthCC7 { get; set; }
Public Property OutputDriveStrengthCC7 As Pcal9538aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9538aTypeOutputDriveStrength OutputDriveStrengthCC7 {
    Pcal9538aTypeOutputDriveStrength get ();
    void set (Pcal9538aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC7 : Pcal9538aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9538aTypeOutputDriveStrength
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.OutputPortConfigurationODEN0 Property

IRD

Pcal9538aOutputPortConfigurationODEN0 Property

Output Port Configuration: ODEN0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypeOutputPortConfiguration OutputPortConfigurationODEN0 { get; set; }
Public Property OutputPortConfigurationODEN0 As Pcal9538aTypeOutputPortConfiguration
    Get
    Set
public:
property Pcal9538aTypeOutputPortConfiguration OutputPortConfigurationODEN0 {
    Pcal9538aTypeOutputPortConfiguration get ();
    void set (Pcal9538aTypeOutputPortConfiguration value);
}
member OutputPortConfigurationODEN0 : Pcal9538aTypeOutputPortConfiguration with get, set

Property Value

Type: Pcal9538aTypeOutputPortConfiguration
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.OutputPortO0 Property

IRD

Pcal9538aOutputPortO0 Property

Output Port: O0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO0 { get; set; }
Public Property OutputPortO0 As Byte
    Get
    Set
public:
property unsigned char OutputPortO0 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.OutputPortO1 Property

IRD

Pcal9538aOutputPortO1 Property

Output Port: O1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO1 { get; set; }
Public Property OutputPortO1 As Byte
    Get
    Set
public:
property unsigned char OutputPortO1 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.OutputPortO2 Property

IRD

Pcal9538aOutputPortO2 Property

Output Port: O2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO2 { get; set; }
Public Property OutputPortO2 As Byte
    Get
    Set
public:
property unsigned char OutputPortO2 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.OutputPortO3 Property

IRD

Pcal9538aOutputPortO3 Property

Output Port: O3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO3 { get; set; }
Public Property OutputPortO3 As Byte
    Get
    Set
public:
property unsigned char OutputPortO3 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.OutputPortO4 Property

IRD

Pcal9538aOutputPortO4 Property

Output Port: O4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO4 { get; set; }
Public Property OutputPortO4 As Byte
    Get
    Set
public:
property unsigned char OutputPortO4 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.OutputPortO5 Property

IRD

Pcal9538aOutputPortO5 Property

Output Port: O5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO5 { get; set; }
Public Property OutputPortO5 As Byte
    Get
    Set
public:
property unsigned char OutputPortO5 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.OutputPortO6 Property

IRD

Pcal9538aOutputPortO6 Property

Output Port: O6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO6 { get; set; }
Public Property OutputPortO6 As Byte
    Get
    Set
public:
property unsigned char OutputPortO6 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.OutputPortO7 Property

IRD

Pcal9538aOutputPortO7 Property

Output Port: O7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO7 { get; set; }
Public Property OutputPortO7 As Byte
    Get
    Set
public:
property unsigned char OutputPortO7 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PolarityInversionN0 Property

IRD

Pcal9538aPolarityInversionN0 Property

Polarity Inversion: N0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePolarityInversion PolarityInversionN0 { get; set; }
Public Property PolarityInversionN0 As Pcal9538aTypePolarityInversion
    Get
    Set
public:
property Pcal9538aTypePolarityInversion PolarityInversionN0 {
    Pcal9538aTypePolarityInversion get ();
    void set (Pcal9538aTypePolarityInversion value);
}
member PolarityInversionN0 : Pcal9538aTypePolarityInversion with get, set

Property Value

Type: Pcal9538aTypePolarityInversion
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PolarityInversionN1 Property

IRD

Pcal9538aPolarityInversionN1 Property

Polarity Inversion: N1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePolarityInversion PolarityInversionN1 { get; set; }
Public Property PolarityInversionN1 As Pcal9538aTypePolarityInversion
    Get
    Set
public:
property Pcal9538aTypePolarityInversion PolarityInversionN1 {
    Pcal9538aTypePolarityInversion get ();
    void set (Pcal9538aTypePolarityInversion value);
}
member PolarityInversionN1 : Pcal9538aTypePolarityInversion with get, set

Property Value

Type: Pcal9538aTypePolarityInversion
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PolarityInversionN2 Property

IRD

Pcal9538aPolarityInversionN2 Property

Polarity Inversion: N2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePolarityInversion PolarityInversionN2 { get; set; }
Public Property PolarityInversionN2 As Pcal9538aTypePolarityInversion
    Get
    Set
public:
property Pcal9538aTypePolarityInversion PolarityInversionN2 {
    Pcal9538aTypePolarityInversion get ();
    void set (Pcal9538aTypePolarityInversion value);
}
member PolarityInversionN2 : Pcal9538aTypePolarityInversion with get, set

Property Value

Type: Pcal9538aTypePolarityInversion
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PolarityInversionN3 Property

IRD

Pcal9538aPolarityInversionN3 Property

Polarity Inversion: N3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePolarityInversion PolarityInversionN3 { get; set; }
Public Property PolarityInversionN3 As Pcal9538aTypePolarityInversion
    Get
    Set
public:
property Pcal9538aTypePolarityInversion PolarityInversionN3 {
    Pcal9538aTypePolarityInversion get ();
    void set (Pcal9538aTypePolarityInversion value);
}
member PolarityInversionN3 : Pcal9538aTypePolarityInversion with get, set

Property Value

Type: Pcal9538aTypePolarityInversion
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PolarityInversionN4 Property

IRD

Pcal9538aPolarityInversionN4 Property

Polarity Inversion: N4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePolarityInversion PolarityInversionN4 { get; set; }
Public Property PolarityInversionN4 As Pcal9538aTypePolarityInversion
    Get
    Set
public:
property Pcal9538aTypePolarityInversion PolarityInversionN4 {
    Pcal9538aTypePolarityInversion get ();
    void set (Pcal9538aTypePolarityInversion value);
}
member PolarityInversionN4 : Pcal9538aTypePolarityInversion with get, set

Property Value

Type: Pcal9538aTypePolarityInversion
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PolarityInversionN5 Property

IRD

Pcal9538aPolarityInversionN5 Property

Polarity Inversion: N5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePolarityInversion PolarityInversionN5 { get; set; }
Public Property PolarityInversionN5 As Pcal9538aTypePolarityInversion
    Get
    Set
public:
property Pcal9538aTypePolarityInversion PolarityInversionN5 {
    Pcal9538aTypePolarityInversion get ();
    void set (Pcal9538aTypePolarityInversion value);
}
member PolarityInversionN5 : Pcal9538aTypePolarityInversion with get, set

Property Value

Type: Pcal9538aTypePolarityInversion
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PolarityInversionN6 Property

IRD

Pcal9538aPolarityInversionN6 Property

Polarity Inversion: N6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePolarityInversion PolarityInversionN6 { get; set; }
Public Property PolarityInversionN6 As Pcal9538aTypePolarityInversion
    Get
    Set
public:
property Pcal9538aTypePolarityInversion PolarityInversionN6 {
    Pcal9538aTypePolarityInversion get ();
    void set (Pcal9538aTypePolarityInversion value);
}
member PolarityInversionN6 : Pcal9538aTypePolarityInversion with get, set

Property Value

Type: Pcal9538aTypePolarityInversion
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PolarityInversionN7 Property

IRD

Pcal9538aPolarityInversionN7 Property

Polarity Inversion: N7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePolarityInversion PolarityInversionN7 { get; set; }
Public Property PolarityInversionN7 As Pcal9538aTypePolarityInversion
    Get
    Set
public:
property Pcal9538aTypePolarityInversion PolarityInversionN7 {
    Pcal9538aTypePolarityInversion get ();
    void set (Pcal9538aTypePolarityInversion value);
}
member PolarityInversionN7 : Pcal9538aTypePolarityInversion with get, set

Property Value

Type: Pcal9538aTypePolarityInversion
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PullUpPullDownEnablePE0 Property

IRD

Pcal9538aPullUpPullDownEnablePE0 Property

Pull-Up/Pull-Down Enable: PE0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePullUpPullDownEnable PullUpPullDownEnablePE0 { get; set; }
Public Property PullUpPullDownEnablePE0 As Pcal9538aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9538aTypePullUpPullDownEnable PullUpPullDownEnablePE0 {
    Pcal9538aTypePullUpPullDownEnable get ();
    void set (Pcal9538aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE0 : Pcal9538aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9538aTypePullUpPullDownEnable
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PullUpPullDownEnablePE1 Property

IRD

Pcal9538aPullUpPullDownEnablePE1 Property

Pull-Up/Pull-Down Enable: PE1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePullUpPullDownEnable PullUpPullDownEnablePE1 { get; set; }
Public Property PullUpPullDownEnablePE1 As Pcal9538aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9538aTypePullUpPullDownEnable PullUpPullDownEnablePE1 {
    Pcal9538aTypePullUpPullDownEnable get ();
    void set (Pcal9538aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE1 : Pcal9538aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9538aTypePullUpPullDownEnable
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PullUpPullDownEnablePE2 Property

IRD

Pcal9538aPullUpPullDownEnablePE2 Property

Pull-Up/Pull-Down Enable: PE2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePullUpPullDownEnable PullUpPullDownEnablePE2 { get; set; }
Public Property PullUpPullDownEnablePE2 As Pcal9538aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9538aTypePullUpPullDownEnable PullUpPullDownEnablePE2 {
    Pcal9538aTypePullUpPullDownEnable get ();
    void set (Pcal9538aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE2 : Pcal9538aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9538aTypePullUpPullDownEnable
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PullUpPullDownEnablePE3 Property

IRD

Pcal9538aPullUpPullDownEnablePE3 Property

Pull-Up/Pull-Down Enable: PE3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePullUpPullDownEnable PullUpPullDownEnablePE3 { get; set; }
Public Property PullUpPullDownEnablePE3 As Pcal9538aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9538aTypePullUpPullDownEnable PullUpPullDownEnablePE3 {
    Pcal9538aTypePullUpPullDownEnable get ();
    void set (Pcal9538aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE3 : Pcal9538aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9538aTypePullUpPullDownEnable
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PullUpPullDownEnablePE4 Property

IRD

Pcal9538aPullUpPullDownEnablePE4 Property

Pull-Up/Pull-Down Enable: PE4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePullUpPullDownEnable PullUpPullDownEnablePE4 { get; set; }
Public Property PullUpPullDownEnablePE4 As Pcal9538aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9538aTypePullUpPullDownEnable PullUpPullDownEnablePE4 {
    Pcal9538aTypePullUpPullDownEnable get ();
    void set (Pcal9538aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE4 : Pcal9538aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9538aTypePullUpPullDownEnable
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PullUpPullDownEnablePE5 Property

IRD

Pcal9538aPullUpPullDownEnablePE5 Property

Pull-Up/Pull-Down Enable: PE5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePullUpPullDownEnable PullUpPullDownEnablePE5 { get; set; }
Public Property PullUpPullDownEnablePE5 As Pcal9538aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9538aTypePullUpPullDownEnable PullUpPullDownEnablePE5 {
    Pcal9538aTypePullUpPullDownEnable get ();
    void set (Pcal9538aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE5 : Pcal9538aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9538aTypePullUpPullDownEnable
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PullUpPullDownEnablePE6 Property

IRD

Pcal9538aPullUpPullDownEnablePE6 Property

Pull-Up/Pull-Down Enable: PE6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePullUpPullDownEnable PullUpPullDownEnablePE6 { get; set; }
Public Property PullUpPullDownEnablePE6 As Pcal9538aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9538aTypePullUpPullDownEnable PullUpPullDownEnablePE6 {
    Pcal9538aTypePullUpPullDownEnable get ();
    void set (Pcal9538aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE6 : Pcal9538aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9538aTypePullUpPullDownEnable
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PullUpPullDownEnablePE7 Property

IRD

Pcal9538aPullUpPullDownEnablePE7 Property

Pull-Up/Pull-Down Enable: PE7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePullUpPullDownEnable PullUpPullDownEnablePE7 { get; set; }
Public Property PullUpPullDownEnablePE7 As Pcal9538aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9538aTypePullUpPullDownEnable PullUpPullDownEnablePE7 {
    Pcal9538aTypePullUpPullDownEnable get ();
    void set (Pcal9538aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE7 : Pcal9538aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9538aTypePullUpPullDownEnable
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PullUpPullDownSelectionPUD0 Property

IRD

Pcal9538aPullUpPullDownSelectionPUD0 Property

Pull-Up/Pull-Down Selection: PUD0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePullUpPullDownSelection PullUpPullDownSelectionPUD0 { get; set; }
Public Property PullUpPullDownSelectionPUD0 As Pcal9538aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9538aTypePullUpPullDownSelection PullUpPullDownSelectionPUD0 {
    Pcal9538aTypePullUpPullDownSelection get ();
    void set (Pcal9538aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD0 : Pcal9538aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9538aTypePullUpPullDownSelection
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PullUpPullDownSelectionPUD1 Property

IRD

Pcal9538aPullUpPullDownSelectionPUD1 Property

Pull-Up/Pull-Down Selection: PUD1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePullUpPullDownSelection PullUpPullDownSelectionPUD1 { get; set; }
Public Property PullUpPullDownSelectionPUD1 As Pcal9538aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9538aTypePullUpPullDownSelection PullUpPullDownSelectionPUD1 {
    Pcal9538aTypePullUpPullDownSelection get ();
    void set (Pcal9538aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD1 : Pcal9538aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9538aTypePullUpPullDownSelection
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PullUpPullDownSelectionPUD2 Property

IRD

Pcal9538aPullUpPullDownSelectionPUD2 Property

Pull-Up/Pull-Down Selection: PUD2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePullUpPullDownSelection PullUpPullDownSelectionPUD2 { get; set; }
Public Property PullUpPullDownSelectionPUD2 As Pcal9538aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9538aTypePullUpPullDownSelection PullUpPullDownSelectionPUD2 {
    Pcal9538aTypePullUpPullDownSelection get ();
    void set (Pcal9538aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD2 : Pcal9538aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9538aTypePullUpPullDownSelection
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PullUpPullDownSelectionPUD3 Property

IRD

Pcal9538aPullUpPullDownSelectionPUD3 Property

Pull-Up/Pull-Down Selection: PUD3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePullUpPullDownSelection PullUpPullDownSelectionPUD3 { get; set; }
Public Property PullUpPullDownSelectionPUD3 As Pcal9538aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9538aTypePullUpPullDownSelection PullUpPullDownSelectionPUD3 {
    Pcal9538aTypePullUpPullDownSelection get ();
    void set (Pcal9538aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD3 : Pcal9538aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9538aTypePullUpPullDownSelection
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PullUpPullDownSelectionPUD4 Property

IRD

Pcal9538aPullUpPullDownSelectionPUD4 Property

Pull-Up/Pull-Down Selection: PUD4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePullUpPullDownSelection PullUpPullDownSelectionPUD4 { get; set; }
Public Property PullUpPullDownSelectionPUD4 As Pcal9538aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9538aTypePullUpPullDownSelection PullUpPullDownSelectionPUD4 {
    Pcal9538aTypePullUpPullDownSelection get ();
    void set (Pcal9538aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD4 : Pcal9538aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9538aTypePullUpPullDownSelection
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PullUpPullDownSelectionPUD5 Property

IRD

Pcal9538aPullUpPullDownSelectionPUD5 Property

Pull-Up/Pull-Down Selection: PUD5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePullUpPullDownSelection PullUpPullDownSelectionPUD5 { get; set; }
Public Property PullUpPullDownSelectionPUD5 As Pcal9538aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9538aTypePullUpPullDownSelection PullUpPullDownSelectionPUD5 {
    Pcal9538aTypePullUpPullDownSelection get ();
    void set (Pcal9538aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD5 : Pcal9538aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9538aTypePullUpPullDownSelection
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PullUpPullDownSelectionPUD6 Property

IRD

Pcal9538aPullUpPullDownSelectionPUD6 Property

Pull-Up/Pull-Down Selection: PUD6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePullUpPullDownSelection PullUpPullDownSelectionPUD6 { get; set; }
Public Property PullUpPullDownSelectionPUD6 As Pcal9538aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9538aTypePullUpPullDownSelection PullUpPullDownSelectionPUD6 {
    Pcal9538aTypePullUpPullDownSelection get ();
    void set (Pcal9538aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD6 : Pcal9538aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9538aTypePullUpPullDownSelection
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.PullUpPullDownSelectionPUD7 Property

IRD

Pcal9538aPullUpPullDownSelectionPUD7 Property

Pull-Up/Pull-Down Selection: PUD7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9538aTypePullUpPullDownSelection PullUpPullDownSelectionPUD7 { get; set; }
Public Property PullUpPullDownSelectionPUD7 As Pcal9538aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9538aTypePullUpPullDownSelection PullUpPullDownSelectionPUD7 {
    Pcal9538aTypePullUpPullDownSelection get ();
    void set (Pcal9538aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD7 : Pcal9538aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9538aTypePullUpPullDownSelection
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a Methods

The Pcal9538a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.Flush Method

IRD

Pcal9538aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcal9538a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9538a.TypeConfiguration Enumeration

IRD

Pcal9538aTypeConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Output | 0 | Output
Input | 1 | Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9538a.TypeInputLatch Enumeration

IRD

Pcal9538aTypeInputLatch Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInputLatch
Public Enumeration TypeInputLatch
public enum class TypeInputLatch
type TypeInputLatch
Members
Member name | Value | Description
NotLatched | 0 | Not Latched
Latched | 1 | Latched
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9538a.TypeInterruptMask Enumeration

IRD

Pcal9538aTypeInterruptMask Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptMask
Public Enumeration TypeInterruptMask
public enum class TypeInterruptMask
type TypeInterruptMask
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9538a.TypeInterruptStatus Enumeration

IRD

Pcal9538aTypeInterruptStatus Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatus
Public Enumeration TypeInterruptStatus
public enum class TypeInterruptStatus
type TypeInterruptStatus
Members
Member name | Value | Description
NotSource | 0 | Not Source
Source | 1 | Source
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9538a.TypeOutputDriveStrength Enumeration

IRD

Pcal9538aTypeOutputDriveStrength Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputDriveStrength
Public Enumeration TypeOutputDriveStrength
public enum class TypeOutputDriveStrength
type TypeOutputDriveStrength
Members
Member name | Value | Description
Value_025x | 0 | 0.25x
Value_05x | 1 | 0.5x
Value_075x | 2 | 0.75x
Value_10x | 3 | 1.0x
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9538a.TypeOutputPortConfiguration Enumeration

IRD

Pcal9538aTypeOutputPortConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputPortConfiguration
Public Enumeration TypeOutputPortConfiguration
public enum class TypeOutputPortConfiguration
type TypeOutputPortConfiguration
Members
Member name | Value | Description
PushPull | 0 | Push-Pull
OpenDrain | 1 | Open-Drain
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9538a.TypePolarityInversion Enumeration

IRD

Pcal9538aTypePolarityInversion Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarityInversion
Public Enumeration TypePolarityInversion
public enum class TypePolarityInversion
type TypePolarityInversion
Members
Member name | Value | Description
NotInverted | 0 | Not Inverted
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9538a.TypePullUpPullDownEnable Enumeration

IRD

Pcal9538aTypePullUpPullDownEnable Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePullUpPullDownEnable
Public Enumeration TypePullUpPullDownEnable
public enum class TypePullUpPullDownEnable
type TypePullUpPullDownEnable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9538a.TypePullUpPullDownSelection Enumeration

IRD

Pcal9538aTypePullUpPullDownSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePullUpPullDownSelection
Public Enumeration TypePullUpPullDownSelection
public enum class TypePullUpPullDownSelection
type TypePullUpPullDownSelection
Members
Member name | Value | Description
Value_100KΩPullDown | 0 | 100 kΩ Pull-Down
Value_100KΩPullUp | 1 | 100 kΩ Pull-Up
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9539a Class

NXP Semiconductors: PCAL 9539A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPcal9539a

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcal9539a
Public Class Pcal9539a
public ref class Pcal9539a
type Pcal9539a =  class end

The Pcal9539a type exposes the following members.

Constructors
 | Name | Description
Public method | Pcal9539a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration: C0.0
Public property | ConfigurationC01 | Configuration: C0.1
Public property | ConfigurationC02 | Configuration: C0.2
Public property | ConfigurationC03 | Configuration: C0.3
Public property | ConfigurationC04 | Configuration: C0.4
Public property | ConfigurationC05 | Configuration: C0.5
Public property | ConfigurationC06 | Configuration: C0.6
Public property | ConfigurationC07 | Configuration: C0.7
Public property | ConfigurationC10 | Configuration: C1.0
Public property | ConfigurationC11 | Configuration: C1.1
Public property | ConfigurationC12 | Configuration: C1.2
Public property | ConfigurationC13 | Configuration: C1.3
Public property | ConfigurationC14 | Configuration: C1.4
Public property | ConfigurationC15 | Configuration: C1.5
Public property | ConfigurationC16 | Configuration: C1.6
Public property | ConfigurationC17 | Configuration: C1.7
Public property | InputLatchL00 | Input Latch: L0.0
Public property | InputLatchL01 | Input Latch: L0.1
Public property | InputLatchL02 | Input Latch: L0.2
Public property | InputLatchL03 | Input Latch: L0.3
Public property | InputLatchL04 | Input Latch: L0.4
Public property | InputLatchL05 | Input Latch: L0.5
Public property | InputLatchL06 | Input Latch: L0.6
Public property | InputLatchL07 | Input Latch: L0.7
Public property | InputLatchL10 | Input Latch: L1.0
Public property | InputLatchL11 | Input Latch: L1.1
Public property | InputLatchL12 | Input Latch: L1.2
Public property | InputLatchL13 | Input Latch: L1.3
Public property | InputLatchL14 | Input Latch: L1.4
Public property | InputLatchL15 | Input Latch: L1.5
Public property | InputLatchL16 | Input Latch: L1.6
Public property | InputLatchL17 | Input Latch: L1.7
Public property | InputPortI00 | Input Port: I0.0
Public property | InputPortI01 | Input Port: I0.1
Public property | InputPortI02 | Input Port: I0.2
Public property | InputPortI03 | Input Port: I0.3
Public property | InputPortI04 | Input Port: I0.4
Public property | InputPortI05 | Input Port: I0.5
Public property | InputPortI06 | Input Port: I0.6
Public property | InputPortI07 | Input Port: I0.7
Public property | InputPortI10 | Input Port: I1.0
Public property | InputPortI11 | Input Port: I1.1
Public property | InputPortI12 | Input Port: I1.2
Public property | InputPortI13 | Input Port: I1.3
Public property | InputPortI14 | Input Port: I1.4
Public property | InputPortI15 | Input Port: I1.5
Public property | InputPortI16 | Input Port: I1.6
Public property | InputPortI17 | Input Port: I1.7
Public property | InterruptMaskM00 | Interrupt Mask: M0.0
Public property | InterruptMaskM01 | Interrupt Mask: M0.1
Public property | InterruptMaskM02 | Interrupt Mask: M0.2
Public property | InterruptMaskM03 | Interrupt Mask: M0.3
Public property | InterruptMaskM04 | Interrupt Mask: M0.4
Public property | InterruptMaskM05 | Interrupt Mask: M0.5
Public property | InterruptMaskM06 | Interrupt Mask: M0.6
Public property | InterruptMaskM07 | Interrupt Mask: M0.7
Public property | InterruptMaskM10 | Interrupt Mask: M1.0
Public property | InterruptMaskM11 | Interrupt Mask: M1.1
Public property | InterruptMaskM12 | Interrupt Mask: M1.2
Public property | InterruptMaskM13 | Interrupt Mask: M1.3
Public property | InterruptMaskM14 | Interrupt Mask: M1.4
Public property | InterruptMaskM15 | Interrupt Mask: M1.5
Public property | InterruptMaskM16 | Interrupt Mask: M1.6
Public property | InterruptMaskM17 | Interrupt Mask: M1.7
Public property | InterruptStatusS00 | Interrupt Status: S0.0
Public property | InterruptStatusS01 | Interrupt Status: S0.1
Public property | InterruptStatusS02 | Interrupt Status: S0.2
Public property | InterruptStatusS03 | Interrupt Status: S0.3
Public property | InterruptStatusS04 | Interrupt Status: S0.4
Public property | InterruptStatusS05 | Interrupt Status: S0.5
Public property | InterruptStatusS06 | Interrupt Status: S0.6
Public property | InterruptStatusS07 | Interrupt Status: S0.7
Public property | InterruptStatusS10 | Interrupt Status: S1.0
Public property | InterruptStatusS11 | Interrupt Status: S1.1
Public property | InterruptStatusS12 | Interrupt Status: S1.2
Public property | InterruptStatusS13 | Interrupt Status: S1.3
Public property | InterruptStatusS14 | Interrupt Status: S1.4
Public property | InterruptStatusS15 | Interrupt Status: S1.5
Public property | InterruptStatusS16 | Interrupt Status: S1.6
Public property | InterruptStatusS17 | Interrupt Status: S1.7
Public property | OutputDriveStrengthCC00 | Output Drive Strength: CC0.0
Public property | OutputDriveStrengthCC01 | Output Drive Strength: CC0.1
Public property | OutputDriveStrengthCC02 | Output Drive Strength: CC0.2
Public property | OutputDriveStrengthCC03 | Output Drive Strength: CC0.3
Public property | OutputDriveStrengthCC04 | Output Drive Strength: CC0.4
Public property | OutputDriveStrengthCC05 | Output Drive Strength: CC0.5
Public property | OutputDriveStrengthCC06 | Output Drive Strength: CC0.6
Public property | OutputDriveStrengthCC07 | Output Drive Strength: CC0.7
Public property | OutputDriveStrengthCC10 | Output Drive Strength: CC1.0
Public property | OutputDriveStrengthCC11 | Output Drive Strength: CC1.1
Public property | OutputDriveStrengthCC12 | Output Drive Strength: CC1.2
Public property | OutputDriveStrengthCC13 | Output Drive Strength: CC1.3
Public property | OutputDriveStrengthCC14 | Output Drive Strength: CC1.4
Public property | OutputDriveStrengthCC15 | Output Drive Strength: CC1.5
Public property | OutputDriveStrengthCC16 | Output Drive Strength: CC1.6
Public property | OutputDriveStrengthCC17 | Output Drive Strength: CC1.7
Public property | OutputPortConfigurationODEN0 | Output Port Configuration: ODEN0
Public property | OutputPortConfigurationODEN1 | Output Port Configuration: ODEN1
Public property | OutputPortO00 | Output Port: O0.0
Public property | OutputPortO01 | Output Port: O0.1
Public property | OutputPortO02 | Output Port: O0.2
Public property | OutputPortO03 | Output Port: O0.3
Public property | OutputPortO04 | Output Port: O0.4
Public property | OutputPortO05 | Output Port: O0.5
Public property | OutputPortO06 | Output Port: O0.6
Public property | OutputPortO07 | Output Port: O0.7
Public property | OutputPortO10 | Output Port: O1.0
Public property | OutputPortO11 | Output Port: O1.1
Public property | OutputPortO12 | Output Port: O1.2
Public property | OutputPortO13 | Output Port: O1.3
Public property | OutputPortO14 | Output Port: O1.4
Public property | OutputPortO15 | Output Port: O1.5
Public property | OutputPortO16 | Output Port: O1.6
Public property | OutputPortO17 | Output Port: O1.7
Public property | PolarityInversionN00 | Polarity Inversion: N0.0
Public property | PolarityInversionN01 | Polarity Inversion: N0.1
Public property | PolarityInversionN02 | Polarity Inversion: N0.2
Public property | PolarityInversionN03 | Polarity Inversion: N0.3
Public property | PolarityInversionN04 | Polarity Inversion: N0.4
Public property | PolarityInversionN05 | Polarity Inversion: N0.5
Public property | PolarityInversionN06 | Polarity Inversion: N0.6
Public property | PolarityInversionN07 | Polarity Inversion: N0.7
Public property | PolarityInversionN10 | Polarity Inversion: N1.0
Public property | PolarityInversionN11 | Polarity Inversion: N1.1
Public property | PolarityInversionN12 | Polarity Inversion: N1.2
Public property | PolarityInversionN13 | Polarity Inversion: N1.3
Public property | PolarityInversionN14 | Polarity Inversion: N1.4
Public property | PolarityInversionN15 | Polarity Inversion: N1.5
Public property | PolarityInversionN16 | Polarity Inversion: N1.6
Public property | PolarityInversionN17 | Polarity Inversion: N1.7
Public property | PullUpPullDownEnablePE00 | Pull-Up/Pull-Down Enable: PE0.0
Public property | PullUpPullDownEnablePE01 | Pull-Up/Pull-Down Enable: PE0.1
Public property | PullUpPullDownEnablePE02 | Pull-Up/Pull-Down Enable: PE0.2
Public property | PullUpPullDownEnablePE03 | Pull-Up/Pull-Down Enable: PE0.3
Public property | PullUpPullDownEnablePE04 | Pull-Up/Pull-Down Enable: PE0.4
Public property | PullUpPullDownEnablePE05 | Pull-Up/Pull-Down Enable: PE0.5
Public property | PullUpPullDownEnablePE06 | Pull-Up/Pull-Down Enable: PE0.6
Public property | PullUpPullDownEnablePE07 | Pull-Up/Pull-Down Enable: PE0.7
Public property | PullUpPullDownEnablePE10 | Pull-Up/Pull-Down Enable: PE1.0
Public property | PullUpPullDownEnablePE11 | Pull-Up/Pull-Down Enable: PE1.1
Public property | PullUpPullDownEnablePE12 | Pull-Up/Pull-Down Enable: PE1.2
Public property | PullUpPullDownEnablePE13 | Pull-Up/Pull-Down Enable: PE1.3
Public property | PullUpPullDownEnablePE14 | Pull-Up/Pull-Down Enable: PE1.4
Public property | PullUpPullDownEnablePE15 | Pull-Up/Pull-Down Enable: PE1.5
Public property | PullUpPullDownEnablePE16 | Pull-Up/Pull-Down Enable: PE1.6
Public property | PullUpPullDownEnablePE17 | Pull-Up/Pull-Down Enable: PE1.7
Public property | PullUpPullDownSelectionPUD00 | Pull-Up/Pull-Down Selection: PUD0.0
Public property | PullUpPullDownSelectionPUD01 | Pull-Up/Pull-Down Selection: PUD0.1
Public property | PullUpPullDownSelectionPUD02 | Pull-Up/Pull-Down Selection: PUD0.2
Public property | PullUpPullDownSelectionPUD03 | Pull-Up/Pull-Down Selection: PUD0.3
Public property | PullUpPullDownSelectionPUD04 | Pull-Up/Pull-Down Selection: PUD0.4
Public property | PullUpPullDownSelectionPUD05 | Pull-Up/Pull-Down Selection: PUD0.5
Public property | PullUpPullDownSelectionPUD06 | Pull-Up/Pull-Down Selection: PUD0.6
Public property | PullUpPullDownSelectionPUD07 | Pull-Up/Pull-Down Selection: PUD0.7
Public property | PullUpPullDownSelectionPUD10 | Pull-Up/Pull-Down Selection: PUD1.0
Public property | PullUpPullDownSelectionPUD11 | Pull-Up/Pull-Down Selection: PUD1.1
Public property | PullUpPullDownSelectionPUD12 | Pull-Up/Pull-Down Selection: PUD1.2
Public property | PullUpPullDownSelectionPUD13 | Pull-Up/Pull-Down Selection: PUD1.3
Public property | PullUpPullDownSelectionPUD14 | Pull-Up/Pull-Down Selection: PUD1.4
Public property | PullUpPullDownSelectionPUD15 | Pull-Up/Pull-Down Selection: PUD1.5
Public property | PullUpPullDownSelectionPUD16 | Pull-Up/Pull-Down Selection: PUD1.6
Public property | PullUpPullDownSelectionPUD17 | Pull-Up/Pull-Down Selection: PUD1.7
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Voltage 16-Bit I2C-Bus And SMBus Low Power I/O Port With Interrupt And Reset
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9539a Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcal9539a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcal9539a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a Properties

The Pcal9539a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration: C0.0
Public property | ConfigurationC01 | Configuration: C0.1
Public property | ConfigurationC02 | Configuration: C0.2
Public property | ConfigurationC03 | Configuration: C0.3
Public property | ConfigurationC04 | Configuration: C0.4
Public property | ConfigurationC05 | Configuration: C0.5
Public property | ConfigurationC06 | Configuration: C0.6
Public property | ConfigurationC07 | Configuration: C0.7
Public property | ConfigurationC10 | Configuration: C1.0
Public property | ConfigurationC11 | Configuration: C1.1
Public property | ConfigurationC12 | Configuration: C1.2
Public property | ConfigurationC13 | Configuration: C1.3
Public property | ConfigurationC14 | Configuration: C1.4
Public property | ConfigurationC15 | Configuration: C1.5
Public property | ConfigurationC16 | Configuration: C1.6
Public property | ConfigurationC17 | Configuration: C1.7
Public property | InputLatchL00 | Input Latch: L0.0
Public property | InputLatchL01 | Input Latch: L0.1
Public property | InputLatchL02 | Input Latch: L0.2
Public property | InputLatchL03 | Input Latch: L0.3
Public property | InputLatchL04 | Input Latch: L0.4
Public property | InputLatchL05 | Input Latch: L0.5
Public property | InputLatchL06 | Input Latch: L0.6
Public property | InputLatchL07 | Input Latch: L0.7
Public property | InputLatchL10 | Input Latch: L1.0
Public property | InputLatchL11 | Input Latch: L1.1
Public property | InputLatchL12 | Input Latch: L1.2
Public property | InputLatchL13 | Input Latch: L1.3
Public property | InputLatchL14 | Input Latch: L1.4
Public property | InputLatchL15 | Input Latch: L1.5
Public property | InputLatchL16 | Input Latch: L1.6
Public property | InputLatchL17 | Input Latch: L1.7
Public property | InputPortI00 | Input Port: I0.0
Public property | InputPortI01 | Input Port: I0.1
Public property | InputPortI02 | Input Port: I0.2
Public property | InputPortI03 | Input Port: I0.3
Public property | InputPortI04 | Input Port: I0.4
Public property | InputPortI05 | Input Port: I0.5
Public property | InputPortI06 | Input Port: I0.6
Public property | InputPortI07 | Input Port: I0.7
Public property | InputPortI10 | Input Port: I1.0
Public property | InputPortI11 | Input Port: I1.1
Public property | InputPortI12 | Input Port: I1.2
Public property | InputPortI13 | Input Port: I1.3
Public property | InputPortI14 | Input Port: I1.4
Public property | InputPortI15 | Input Port: I1.5
Public property | InputPortI16 | Input Port: I1.6
Public property | InputPortI17 | Input Port: I1.7
Public property | InterruptMaskM00 | Interrupt Mask: M0.0
Public property | InterruptMaskM01 | Interrupt Mask: M0.1
Public property | InterruptMaskM02 | Interrupt Mask: M0.2
Public property | InterruptMaskM03 | Interrupt Mask: M0.3
Public property | InterruptMaskM04 | Interrupt Mask: M0.4
Public property | InterruptMaskM05 | Interrupt Mask: M0.5
Public property | InterruptMaskM06 | Interrupt Mask: M0.6
Public property | InterruptMaskM07 | Interrupt Mask: M0.7
Public property | InterruptMaskM10 | Interrupt Mask: M1.0
Public property | InterruptMaskM11 | Interrupt Mask: M1.1
Public property | InterruptMaskM12 | Interrupt Mask: M1.2
Public property | InterruptMaskM13 | Interrupt Mask: M1.3
Public property | InterruptMaskM14 | Interrupt Mask: M1.4
Public property | InterruptMaskM15 | Interrupt Mask: M1.5
Public property | InterruptMaskM16 | Interrupt Mask: M1.6
Public property | InterruptMaskM17 | Interrupt Mask: M1.7
Public property | InterruptStatusS00 | Interrupt Status: S0.0
Public property | InterruptStatusS01 | Interrupt Status: S0.1
Public property | InterruptStatusS02 | Interrupt Status: S0.2
Public property | InterruptStatusS03 | Interrupt Status: S0.3
Public property | InterruptStatusS04 | Interrupt Status: S0.4
Public property | InterruptStatusS05 | Interrupt Status: S0.5
Public property | InterruptStatusS06 | Interrupt Status: S0.6
Public property | InterruptStatusS07 | Interrupt Status: S0.7
Public property | InterruptStatusS10 | Interrupt Status: S1.0
Public property | InterruptStatusS11 | Interrupt Status: S1.1
Public property | InterruptStatusS12 | Interrupt Status: S1.2
Public property | InterruptStatusS13 | Interrupt Status: S1.3
Public property | InterruptStatusS14 | Interrupt Status: S1.4
Public property | InterruptStatusS15 | Interrupt Status: S1.5
Public property | InterruptStatusS16 | Interrupt Status: S1.6
Public property | InterruptStatusS17 | Interrupt Status: S1.7
Public property | OutputDriveStrengthCC00 | Output Drive Strength: CC0.0
Public property | OutputDriveStrengthCC01 | Output Drive Strength: CC0.1
Public property | OutputDriveStrengthCC02 | Output Drive Strength: CC0.2
Public property | OutputDriveStrengthCC03 | Output Drive Strength: CC0.3
Public property | OutputDriveStrengthCC04 | Output Drive Strength: CC0.4
Public property | OutputDriveStrengthCC05 | Output Drive Strength: CC0.5
Public property | OutputDriveStrengthCC06 | Output Drive Strength: CC0.6
Public property | OutputDriveStrengthCC07 | Output Drive Strength: CC0.7
Public property | OutputDriveStrengthCC10 | Output Drive Strength: CC1.0
Public property | OutputDriveStrengthCC11 | Output Drive Strength: CC1.1
Public property | OutputDriveStrengthCC12 | Output Drive Strength: CC1.2
Public property | OutputDriveStrengthCC13 | Output Drive Strength: CC1.3
Public property | OutputDriveStrengthCC14 | Output Drive Strength: CC1.4
Public property | OutputDriveStrengthCC15 | Output Drive Strength: CC1.5
Public property | OutputDriveStrengthCC16 | Output Drive Strength: CC1.6
Public property | OutputDriveStrengthCC17 | Output Drive Strength: CC1.7
Public property | OutputPortConfigurationODEN0 | Output Port Configuration: ODEN0
Public property | OutputPortConfigurationODEN1 | Output Port Configuration: ODEN1
Public property | OutputPortO00 | Output Port: O0.0
Public property | OutputPortO01 | Output Port: O0.1
Public property | OutputPortO02 | Output Port: O0.2
Public property | OutputPortO03 | Output Port: O0.3
Public property | OutputPortO04 | Output Port: O0.4
Public property | OutputPortO05 | Output Port: O0.5
Public property | OutputPortO06 | Output Port: O0.6
Public property | OutputPortO07 | Output Port: O0.7
Public property | OutputPortO10 | Output Port: O1.0
Public property | OutputPortO11 | Output Port: O1.1
Public property | OutputPortO12 | Output Port: O1.2
Public property | OutputPortO13 | Output Port: O1.3
Public property | OutputPortO14 | Output Port: O1.4
Public property | OutputPortO15 | Output Port: O1.5
Public property | OutputPortO16 | Output Port: O1.6
Public property | OutputPortO17 | Output Port: O1.7
Public property | PolarityInversionN00 | Polarity Inversion: N0.0
Public property | PolarityInversionN01 | Polarity Inversion: N0.1
Public property | PolarityInversionN02 | Polarity Inversion: N0.2
Public property | PolarityInversionN03 | Polarity Inversion: N0.3
Public property | PolarityInversionN04 | Polarity Inversion: N0.4
Public property | PolarityInversionN05 | Polarity Inversion: N0.5
Public property | PolarityInversionN06 | Polarity Inversion: N0.6
Public property | PolarityInversionN07 | Polarity Inversion: N0.7
Public property | PolarityInversionN10 | Polarity Inversion: N1.0
Public property | PolarityInversionN11 | Polarity Inversion: N1.1
Public property | PolarityInversionN12 | Polarity Inversion: N1.2
Public property | PolarityInversionN13 | Polarity Inversion: N1.3
Public property | PolarityInversionN14 | Polarity Inversion: N1.4
Public property | PolarityInversionN15 | Polarity Inversion: N1.5
Public property | PolarityInversionN16 | Polarity Inversion: N1.6
Public property | PolarityInversionN17 | Polarity Inversion: N1.7
Public property | PullUpPullDownEnablePE00 | Pull-Up/Pull-Down Enable: PE0.0
Public property | PullUpPullDownEnablePE01 | Pull-Up/Pull-Down Enable: PE0.1
Public property | PullUpPullDownEnablePE02 | Pull-Up/Pull-Down Enable: PE0.2
Public property | PullUpPullDownEnablePE03 | Pull-Up/Pull-Down Enable: PE0.3
Public property | PullUpPullDownEnablePE04 | Pull-Up/Pull-Down Enable: PE0.4
Public property | PullUpPullDownEnablePE05 | Pull-Up/Pull-Down Enable: PE0.5
Public property | PullUpPullDownEnablePE06 | Pull-Up/Pull-Down Enable: PE0.6
Public property | PullUpPullDownEnablePE07 | Pull-Up/Pull-Down Enable: PE0.7
Public property | PullUpPullDownEnablePE10 | Pull-Up/Pull-Down Enable: PE1.0
Public property | PullUpPullDownEnablePE11 | Pull-Up/Pull-Down Enable: PE1.1
Public property | PullUpPullDownEnablePE12 | Pull-Up/Pull-Down Enable: PE1.2
Public property | PullUpPullDownEnablePE13 | Pull-Up/Pull-Down Enable: PE1.3
Public property | PullUpPullDownEnablePE14 | Pull-Up/Pull-Down Enable: PE1.4
Public property | PullUpPullDownEnablePE15 | Pull-Up/Pull-Down Enable: PE1.5
Public property | PullUpPullDownEnablePE16 | Pull-Up/Pull-Down Enable: PE1.6
Public property | PullUpPullDownEnablePE17 | Pull-Up/Pull-Down Enable: PE1.7
Public property | PullUpPullDownSelectionPUD00 | Pull-Up/Pull-Down Selection: PUD0.0
Public property | PullUpPullDownSelectionPUD01 | Pull-Up/Pull-Down Selection: PUD0.1
Public property | PullUpPullDownSelectionPUD02 | Pull-Up/Pull-Down Selection: PUD0.2
Public property | PullUpPullDownSelectionPUD03 | Pull-Up/Pull-Down Selection: PUD0.3
Public property | PullUpPullDownSelectionPUD04 | Pull-Up/Pull-Down Selection: PUD0.4
Public property | PullUpPullDownSelectionPUD05 | Pull-Up/Pull-Down Selection: PUD0.5
Public property | PullUpPullDownSelectionPUD06 | Pull-Up/Pull-Down Selection: PUD0.6
Public property | PullUpPullDownSelectionPUD07 | Pull-Up/Pull-Down Selection: PUD0.7
Public property | PullUpPullDownSelectionPUD10 | Pull-Up/Pull-Down Selection: PUD1.0
Public property | PullUpPullDownSelectionPUD11 | Pull-Up/Pull-Down Selection: PUD1.1
Public property | PullUpPullDownSelectionPUD12 | Pull-Up/Pull-Down Selection: PUD1.2
Public property | PullUpPullDownSelectionPUD13 | Pull-Up/Pull-Down Selection: PUD1.3
Public property | PullUpPullDownSelectionPUD14 | Pull-Up/Pull-Down Selection: PUD1.4
Public property | PullUpPullDownSelectionPUD15 | Pull-Up/Pull-Down Selection: PUD1.5
Public property | PullUpPullDownSelectionPUD16 | Pull-Up/Pull-Down Selection: PUD1.6
Public property | PullUpPullDownSelectionPUD17 | Pull-Up/Pull-Down Selection: PUD1.7
Top
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.AutoFlush Property

IRD

Pcal9539aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.ConfigurationC00 Property

IRD

Pcal9539aConfigurationC00 Property

Configuration: C0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeConfiguration ConfigurationC00 { get; set; }
Public Property ConfigurationC00 As Pcal9539aTypeConfiguration
    Get
    Set
public:
property Pcal9539aTypeConfiguration ConfigurationC00 {
    Pcal9539aTypeConfiguration get ();
    void set (Pcal9539aTypeConfiguration value);
}
member ConfigurationC00 : Pcal9539aTypeConfiguration with get, set

Property Value

Type: Pcal9539aTypeConfiguration
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.ConfigurationC01 Property

IRD

Pcal9539aConfigurationC01 Property

Configuration: C0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeConfiguration ConfigurationC01 { get; set; }
Public Property ConfigurationC01 As Pcal9539aTypeConfiguration
    Get
    Set
public:
property Pcal9539aTypeConfiguration ConfigurationC01 {
    Pcal9539aTypeConfiguration get ();
    void set (Pcal9539aTypeConfiguration value);
}
member ConfigurationC01 : Pcal9539aTypeConfiguration with get, set

Property Value

Type: Pcal9539aTypeConfiguration
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.ConfigurationC02 Property

IRD

Pcal9539aConfigurationC02 Property

Configuration: C0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeConfiguration ConfigurationC02 { get; set; }
Public Property ConfigurationC02 As Pcal9539aTypeConfiguration
    Get
    Set
public:
property Pcal9539aTypeConfiguration ConfigurationC02 {
    Pcal9539aTypeConfiguration get ();
    void set (Pcal9539aTypeConfiguration value);
}
member ConfigurationC02 : Pcal9539aTypeConfiguration with get, set

Property Value

Type: Pcal9539aTypeConfiguration
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.ConfigurationC03 Property

IRD

Pcal9539aConfigurationC03 Property

Configuration: C0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeConfiguration ConfigurationC03 { get; set; }
Public Property ConfigurationC03 As Pcal9539aTypeConfiguration
    Get
    Set
public:
property Pcal9539aTypeConfiguration ConfigurationC03 {
    Pcal9539aTypeConfiguration get ();
    void set (Pcal9539aTypeConfiguration value);
}
member ConfigurationC03 : Pcal9539aTypeConfiguration with get, set

Property Value

Type: Pcal9539aTypeConfiguration
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.ConfigurationC04 Property

IRD

Pcal9539aConfigurationC04 Property

Configuration: C0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeConfiguration ConfigurationC04 { get; set; }
Public Property ConfigurationC04 As Pcal9539aTypeConfiguration
    Get
    Set
public:
property Pcal9539aTypeConfiguration ConfigurationC04 {
    Pcal9539aTypeConfiguration get ();
    void set (Pcal9539aTypeConfiguration value);
}
member ConfigurationC04 : Pcal9539aTypeConfiguration with get, set

Property Value

Type: Pcal9539aTypeConfiguration
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.ConfigurationC05 Property

IRD

Pcal9539aConfigurationC05 Property

Configuration: C0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeConfiguration ConfigurationC05 { get; set; }
Public Property ConfigurationC05 As Pcal9539aTypeConfiguration
    Get
    Set
public:
property Pcal9539aTypeConfiguration ConfigurationC05 {
    Pcal9539aTypeConfiguration get ();
    void set (Pcal9539aTypeConfiguration value);
}
member ConfigurationC05 : Pcal9539aTypeConfiguration with get, set

Property Value

Type: Pcal9539aTypeConfiguration
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.ConfigurationC06 Property

IRD

Pcal9539aConfigurationC06 Property

Configuration: C0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeConfiguration ConfigurationC06 { get; set; }
Public Property ConfigurationC06 As Pcal9539aTypeConfiguration
    Get
    Set
public:
property Pcal9539aTypeConfiguration ConfigurationC06 {
    Pcal9539aTypeConfiguration get ();
    void set (Pcal9539aTypeConfiguration value);
}
member ConfigurationC06 : Pcal9539aTypeConfiguration with get, set

Property Value

Type: Pcal9539aTypeConfiguration
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.ConfigurationC07 Property

IRD

Pcal9539aConfigurationC07 Property

Configuration: C0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeConfiguration ConfigurationC07 { get; set; }
Public Property ConfigurationC07 As Pcal9539aTypeConfiguration
    Get
    Set
public:
property Pcal9539aTypeConfiguration ConfigurationC07 {
    Pcal9539aTypeConfiguration get ();
    void set (Pcal9539aTypeConfiguration value);
}
member ConfigurationC07 : Pcal9539aTypeConfiguration with get, set

Property Value

Type: Pcal9539aTypeConfiguration
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.ConfigurationC10 Property

IRD

Pcal9539aConfigurationC10 Property

Configuration: C1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeConfiguration ConfigurationC10 { get; set; }
Public Property ConfigurationC10 As Pcal9539aTypeConfiguration
    Get
    Set
public:
property Pcal9539aTypeConfiguration ConfigurationC10 {
    Pcal9539aTypeConfiguration get ();
    void set (Pcal9539aTypeConfiguration value);
}
member ConfigurationC10 : Pcal9539aTypeConfiguration with get, set

Property Value

Type: Pcal9539aTypeConfiguration
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.ConfigurationC11 Property

IRD

Pcal9539aConfigurationC11 Property

Configuration: C1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeConfiguration ConfigurationC11 { get; set; }
Public Property ConfigurationC11 As Pcal9539aTypeConfiguration
    Get
    Set
public:
property Pcal9539aTypeConfiguration ConfigurationC11 {
    Pcal9539aTypeConfiguration get ();
    void set (Pcal9539aTypeConfiguration value);
}
member ConfigurationC11 : Pcal9539aTypeConfiguration with get, set

Property Value

Type: Pcal9539aTypeConfiguration
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.ConfigurationC12 Property

IRD

Pcal9539aConfigurationC12 Property

Configuration: C1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeConfiguration ConfigurationC12 { get; set; }
Public Property ConfigurationC12 As Pcal9539aTypeConfiguration
    Get
    Set
public:
property Pcal9539aTypeConfiguration ConfigurationC12 {
    Pcal9539aTypeConfiguration get ();
    void set (Pcal9539aTypeConfiguration value);
}
member ConfigurationC12 : Pcal9539aTypeConfiguration with get, set

Property Value

Type: Pcal9539aTypeConfiguration
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.ConfigurationC13 Property

IRD

Pcal9539aConfigurationC13 Property

Configuration: C1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeConfiguration ConfigurationC13 { get; set; }
Public Property ConfigurationC13 As Pcal9539aTypeConfiguration
    Get
    Set
public:
property Pcal9539aTypeConfiguration ConfigurationC13 {
    Pcal9539aTypeConfiguration get ();
    void set (Pcal9539aTypeConfiguration value);
}
member ConfigurationC13 : Pcal9539aTypeConfiguration with get, set

Property Value

Type: Pcal9539aTypeConfiguration
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.ConfigurationC14 Property

IRD

Pcal9539aConfigurationC14 Property

Configuration: C1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeConfiguration ConfigurationC14 { get; set; }
Public Property ConfigurationC14 As Pcal9539aTypeConfiguration
    Get
    Set
public:
property Pcal9539aTypeConfiguration ConfigurationC14 {
    Pcal9539aTypeConfiguration get ();
    void set (Pcal9539aTypeConfiguration value);
}
member ConfigurationC14 : Pcal9539aTypeConfiguration with get, set

Property Value

Type: Pcal9539aTypeConfiguration
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.ConfigurationC15 Property

IRD

Pcal9539aConfigurationC15 Property

Configuration: C1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeConfiguration ConfigurationC15 { get; set; }
Public Property ConfigurationC15 As Pcal9539aTypeConfiguration
    Get
    Set
public:
property Pcal9539aTypeConfiguration ConfigurationC15 {
    Pcal9539aTypeConfiguration get ();
    void set (Pcal9539aTypeConfiguration value);
}
member ConfigurationC15 : Pcal9539aTypeConfiguration with get, set

Property Value

Type: Pcal9539aTypeConfiguration
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.ConfigurationC16 Property

IRD

Pcal9539aConfigurationC16 Property

Configuration: C1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeConfiguration ConfigurationC16 { get; set; }
Public Property ConfigurationC16 As Pcal9539aTypeConfiguration
    Get
    Set
public:
property Pcal9539aTypeConfiguration ConfigurationC16 {
    Pcal9539aTypeConfiguration get ();
    void set (Pcal9539aTypeConfiguration value);
}
member ConfigurationC16 : Pcal9539aTypeConfiguration with get, set

Property Value

Type: Pcal9539aTypeConfiguration
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.ConfigurationC17 Property

IRD

Pcal9539aConfigurationC17 Property

Configuration: C1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeConfiguration ConfigurationC17 { get; set; }
Public Property ConfigurationC17 As Pcal9539aTypeConfiguration
    Get
    Set
public:
property Pcal9539aTypeConfiguration ConfigurationC17 {
    Pcal9539aTypeConfiguration get ();
    void set (Pcal9539aTypeConfiguration value);
}
member ConfigurationC17 : Pcal9539aTypeConfiguration with get, set

Property Value

Type: Pcal9539aTypeConfiguration
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputLatchL00 Property

IRD

Pcal9539aInputLatchL00 Property

Input Latch: L0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInputLatch InputLatchL00 { get; set; }
Public Property InputLatchL00 As Pcal9539aTypeInputLatch
    Get
    Set
public:
property Pcal9539aTypeInputLatch InputLatchL00 {
    Pcal9539aTypeInputLatch get ();
    void set (Pcal9539aTypeInputLatch value);
}
member InputLatchL00 : Pcal9539aTypeInputLatch with get, set

Property Value

Type: Pcal9539aTypeInputLatch
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputLatchL01 Property

IRD

Pcal9539aInputLatchL01 Property

Input Latch: L0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInputLatch InputLatchL01 { get; set; }
Public Property InputLatchL01 As Pcal9539aTypeInputLatch
    Get
    Set
public:
property Pcal9539aTypeInputLatch InputLatchL01 {
    Pcal9539aTypeInputLatch get ();
    void set (Pcal9539aTypeInputLatch value);
}
member InputLatchL01 : Pcal9539aTypeInputLatch with get, set

Property Value

Type: Pcal9539aTypeInputLatch
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputLatchL02 Property

IRD

Pcal9539aInputLatchL02 Property

Input Latch: L0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInputLatch InputLatchL02 { get; set; }
Public Property InputLatchL02 As Pcal9539aTypeInputLatch
    Get
    Set
public:
property Pcal9539aTypeInputLatch InputLatchL02 {
    Pcal9539aTypeInputLatch get ();
    void set (Pcal9539aTypeInputLatch value);
}
member InputLatchL02 : Pcal9539aTypeInputLatch with get, set

Property Value

Type: Pcal9539aTypeInputLatch
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputLatchL03 Property

IRD

Pcal9539aInputLatchL03 Property

Input Latch: L0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInputLatch InputLatchL03 { get; set; }
Public Property InputLatchL03 As Pcal9539aTypeInputLatch
    Get
    Set
public:
property Pcal9539aTypeInputLatch InputLatchL03 {
    Pcal9539aTypeInputLatch get ();
    void set (Pcal9539aTypeInputLatch value);
}
member InputLatchL03 : Pcal9539aTypeInputLatch with get, set

Property Value

Type: Pcal9539aTypeInputLatch
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputLatchL04 Property

IRD

Pcal9539aInputLatchL04 Property

Input Latch: L0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInputLatch InputLatchL04 { get; set; }
Public Property InputLatchL04 As Pcal9539aTypeInputLatch
    Get
    Set
public:
property Pcal9539aTypeInputLatch InputLatchL04 {
    Pcal9539aTypeInputLatch get ();
    void set (Pcal9539aTypeInputLatch value);
}
member InputLatchL04 : Pcal9539aTypeInputLatch with get, set

Property Value

Type: Pcal9539aTypeInputLatch
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputLatchL05 Property

IRD

Pcal9539aInputLatchL05 Property

Input Latch: L0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInputLatch InputLatchL05 { get; set; }
Public Property InputLatchL05 As Pcal9539aTypeInputLatch
    Get
    Set
public:
property Pcal9539aTypeInputLatch InputLatchL05 {
    Pcal9539aTypeInputLatch get ();
    void set (Pcal9539aTypeInputLatch value);
}
member InputLatchL05 : Pcal9539aTypeInputLatch with get, set

Property Value

Type: Pcal9539aTypeInputLatch
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputLatchL06 Property

IRD

Pcal9539aInputLatchL06 Property

Input Latch: L0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInputLatch InputLatchL06 { get; set; }
Public Property InputLatchL06 As Pcal9539aTypeInputLatch
    Get
    Set
public:
property Pcal9539aTypeInputLatch InputLatchL06 {
    Pcal9539aTypeInputLatch get ();
    void set (Pcal9539aTypeInputLatch value);
}
member InputLatchL06 : Pcal9539aTypeInputLatch with get, set

Property Value

Type: Pcal9539aTypeInputLatch
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputLatchL07 Property

IRD

Pcal9539aInputLatchL07 Property

Input Latch: L0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInputLatch InputLatchL07 { get; set; }
Public Property InputLatchL07 As Pcal9539aTypeInputLatch
    Get
    Set
public:
property Pcal9539aTypeInputLatch InputLatchL07 {
    Pcal9539aTypeInputLatch get ();
    void set (Pcal9539aTypeInputLatch value);
}
member InputLatchL07 : Pcal9539aTypeInputLatch with get, set

Property Value

Type: Pcal9539aTypeInputLatch
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputLatchL10 Property

IRD

Pcal9539aInputLatchL10 Property

Input Latch: L1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInputLatch InputLatchL10 { get; set; }
Public Property InputLatchL10 As Pcal9539aTypeInputLatch
    Get
    Set
public:
property Pcal9539aTypeInputLatch InputLatchL10 {
    Pcal9539aTypeInputLatch get ();
    void set (Pcal9539aTypeInputLatch value);
}
member InputLatchL10 : Pcal9539aTypeInputLatch with get, set

Property Value

Type: Pcal9539aTypeInputLatch
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputLatchL11 Property

IRD

Pcal9539aInputLatchL11 Property

Input Latch: L1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInputLatch InputLatchL11 { get; set; }
Public Property InputLatchL11 As Pcal9539aTypeInputLatch
    Get
    Set
public:
property Pcal9539aTypeInputLatch InputLatchL11 {
    Pcal9539aTypeInputLatch get ();
    void set (Pcal9539aTypeInputLatch value);
}
member InputLatchL11 : Pcal9539aTypeInputLatch with get, set

Property Value

Type: Pcal9539aTypeInputLatch
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputLatchL12 Property

IRD

Pcal9539aInputLatchL12 Property

Input Latch: L1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInputLatch InputLatchL12 { get; set; }
Public Property InputLatchL12 As Pcal9539aTypeInputLatch
    Get
    Set
public:
property Pcal9539aTypeInputLatch InputLatchL12 {
    Pcal9539aTypeInputLatch get ();
    void set (Pcal9539aTypeInputLatch value);
}
member InputLatchL12 : Pcal9539aTypeInputLatch with get, set

Property Value

Type: Pcal9539aTypeInputLatch
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputLatchL13 Property

IRD

Pcal9539aInputLatchL13 Property

Input Latch: L1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInputLatch InputLatchL13 { get; set; }
Public Property InputLatchL13 As Pcal9539aTypeInputLatch
    Get
    Set
public:
property Pcal9539aTypeInputLatch InputLatchL13 {
    Pcal9539aTypeInputLatch get ();
    void set (Pcal9539aTypeInputLatch value);
}
member InputLatchL13 : Pcal9539aTypeInputLatch with get, set

Property Value

Type: Pcal9539aTypeInputLatch
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputLatchL14 Property

IRD

Pcal9539aInputLatchL14 Property

Input Latch: L1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInputLatch InputLatchL14 { get; set; }
Public Property InputLatchL14 As Pcal9539aTypeInputLatch
    Get
    Set
public:
property Pcal9539aTypeInputLatch InputLatchL14 {
    Pcal9539aTypeInputLatch get ();
    void set (Pcal9539aTypeInputLatch value);
}
member InputLatchL14 : Pcal9539aTypeInputLatch with get, set

Property Value

Type: Pcal9539aTypeInputLatch
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputLatchL15 Property

IRD

Pcal9539aInputLatchL15 Property

Input Latch: L1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInputLatch InputLatchL15 { get; set; }
Public Property InputLatchL15 As Pcal9539aTypeInputLatch
    Get
    Set
public:
property Pcal9539aTypeInputLatch InputLatchL15 {
    Pcal9539aTypeInputLatch get ();
    void set (Pcal9539aTypeInputLatch value);
}
member InputLatchL15 : Pcal9539aTypeInputLatch with get, set

Property Value

Type: Pcal9539aTypeInputLatch
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputLatchL16 Property

IRD

Pcal9539aInputLatchL16 Property

Input Latch: L1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInputLatch InputLatchL16 { get; set; }
Public Property InputLatchL16 As Pcal9539aTypeInputLatch
    Get
    Set
public:
property Pcal9539aTypeInputLatch InputLatchL16 {
    Pcal9539aTypeInputLatch get ();
    void set (Pcal9539aTypeInputLatch value);
}
member InputLatchL16 : Pcal9539aTypeInputLatch with get, set

Property Value

Type: Pcal9539aTypeInputLatch
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputLatchL17 Property

IRD

Pcal9539aInputLatchL17 Property

Input Latch: L1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInputLatch InputLatchL17 { get; set; }
Public Property InputLatchL17 As Pcal9539aTypeInputLatch
    Get
    Set
public:
property Pcal9539aTypeInputLatch InputLatchL17 {
    Pcal9539aTypeInputLatch get ();
    void set (Pcal9539aTypeInputLatch value);
}
member InputLatchL17 : Pcal9539aTypeInputLatch with get, set

Property Value

Type: Pcal9539aTypeInputLatch
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputPortI00 Property

IRD

Pcal9539aInputPortI00 Property

Input Port: I0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI00 { get; }
Public ReadOnly Property InputPortI00 As Byte
    Get
public:
property unsigned char InputPortI00 {
    unsigned char get ();
}
member InputPortI00 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputPortI01 Property

IRD

Pcal9539aInputPortI01 Property

Input Port: I0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI01 { get; }
Public ReadOnly Property InputPortI01 As Byte
    Get
public:
property unsigned char InputPortI01 {
    unsigned char get ();
}
member InputPortI01 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputPortI02 Property

IRD

Pcal9539aInputPortI02 Property

Input Port: I0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI02 { get; }
Public ReadOnly Property InputPortI02 As Byte
    Get
public:
property unsigned char InputPortI02 {
    unsigned char get ();
}
member InputPortI02 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputPortI03 Property

IRD

Pcal9539aInputPortI03 Property

Input Port: I0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI03 { get; }
Public ReadOnly Property InputPortI03 As Byte
    Get
public:
property unsigned char InputPortI03 {
    unsigned char get ();
}
member InputPortI03 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputPortI04 Property

IRD

Pcal9539aInputPortI04 Property

Input Port: I0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI04 { get; }
Public ReadOnly Property InputPortI04 As Byte
    Get
public:
property unsigned char InputPortI04 {
    unsigned char get ();
}
member InputPortI04 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputPortI05 Property

IRD

Pcal9539aInputPortI05 Property

Input Port: I0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI05 { get; }
Public ReadOnly Property InputPortI05 As Byte
    Get
public:
property unsigned char InputPortI05 {
    unsigned char get ();
}
member InputPortI05 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputPortI06 Property

IRD

Pcal9539aInputPortI06 Property

Input Port: I0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI06 { get; }
Public ReadOnly Property InputPortI06 As Byte
    Get
public:
property unsigned char InputPortI06 {
    unsigned char get ();
}
member InputPortI06 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputPortI07 Property

IRD

Pcal9539aInputPortI07 Property

Input Port: I0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI07 { get; }
Public ReadOnly Property InputPortI07 As Byte
    Get
public:
property unsigned char InputPortI07 {
    unsigned char get ();
}
member InputPortI07 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputPortI10 Property

IRD

Pcal9539aInputPortI10 Property

Input Port: I1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI10 { get; }
Public ReadOnly Property InputPortI10 As Byte
    Get
public:
property unsigned char InputPortI10 {
    unsigned char get ();
}
member InputPortI10 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputPortI11 Property

IRD

Pcal9539aInputPortI11 Property

Input Port: I1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI11 { get; }
Public ReadOnly Property InputPortI11 As Byte
    Get
public:
property unsigned char InputPortI11 {
    unsigned char get ();
}
member InputPortI11 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputPortI12 Property

IRD

Pcal9539aInputPortI12 Property

Input Port: I1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI12 { get; }
Public ReadOnly Property InputPortI12 As Byte
    Get
public:
property unsigned char InputPortI12 {
    unsigned char get ();
}
member InputPortI12 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputPortI13 Property

IRD

Pcal9539aInputPortI13 Property

Input Port: I1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI13 { get; }
Public ReadOnly Property InputPortI13 As Byte
    Get
public:
property unsigned char InputPortI13 {
    unsigned char get ();
}
member InputPortI13 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputPortI14 Property

IRD

Pcal9539aInputPortI14 Property

Input Port: I1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI14 { get; }
Public ReadOnly Property InputPortI14 As Byte
    Get
public:
property unsigned char InputPortI14 {
    unsigned char get ();
}
member InputPortI14 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputPortI15 Property

IRD

Pcal9539aInputPortI15 Property

Input Port: I1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI15 { get; }
Public ReadOnly Property InputPortI15 As Byte
    Get
public:
property unsigned char InputPortI15 {
    unsigned char get ();
}
member InputPortI15 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputPortI16 Property

IRD

Pcal9539aInputPortI16 Property

Input Port: I1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI16 { get; }
Public ReadOnly Property InputPortI16 As Byte
    Get
public:
property unsigned char InputPortI16 {
    unsigned char get ();
}
member InputPortI16 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InputPortI17 Property

IRD

Pcal9539aInputPortI17 Property

Input Port: I1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI17 { get; }
Public ReadOnly Property InputPortI17 As Byte
    Get
public:
property unsigned char InputPortI17 {
    unsigned char get ();
}
member InputPortI17 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptMaskM00 Property

IRD

Pcal9539aInterruptMaskM00 Property

Interrupt Mask: M0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptMask InterruptMaskM00 { get; set; }
Public Property InterruptMaskM00 As Pcal9539aTypeInterruptMask
    Get
    Set
public:
property Pcal9539aTypeInterruptMask InterruptMaskM00 {
    Pcal9539aTypeInterruptMask get ();
    void set (Pcal9539aTypeInterruptMask value);
}
member InterruptMaskM00 : Pcal9539aTypeInterruptMask with get, set

Property Value

Type: Pcal9539aTypeInterruptMask
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptMaskM01 Property

IRD

Pcal9539aInterruptMaskM01 Property

Interrupt Mask: M0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptMask InterruptMaskM01 { get; set; }
Public Property InterruptMaskM01 As Pcal9539aTypeInterruptMask
    Get
    Set
public:
property Pcal9539aTypeInterruptMask InterruptMaskM01 {
    Pcal9539aTypeInterruptMask get ();
    void set (Pcal9539aTypeInterruptMask value);
}
member InterruptMaskM01 : Pcal9539aTypeInterruptMask with get, set

Property Value

Type: Pcal9539aTypeInterruptMask
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptMaskM02 Property

IRD

Pcal9539aInterruptMaskM02 Property

Interrupt Mask: M0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptMask InterruptMaskM02 { get; set; }
Public Property InterruptMaskM02 As Pcal9539aTypeInterruptMask
    Get
    Set
public:
property Pcal9539aTypeInterruptMask InterruptMaskM02 {
    Pcal9539aTypeInterruptMask get ();
    void set (Pcal9539aTypeInterruptMask value);
}
member InterruptMaskM02 : Pcal9539aTypeInterruptMask with get, set

Property Value

Type: Pcal9539aTypeInterruptMask
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptMaskM03 Property

IRD

Pcal9539aInterruptMaskM03 Property

Interrupt Mask: M0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptMask InterruptMaskM03 { get; set; }
Public Property InterruptMaskM03 As Pcal9539aTypeInterruptMask
    Get
    Set
public:
property Pcal9539aTypeInterruptMask InterruptMaskM03 {
    Pcal9539aTypeInterruptMask get ();
    void set (Pcal9539aTypeInterruptMask value);
}
member InterruptMaskM03 : Pcal9539aTypeInterruptMask with get, set

Property Value

Type: Pcal9539aTypeInterruptMask
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptMaskM04 Property

IRD

Pcal9539aInterruptMaskM04 Property

Interrupt Mask: M0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptMask InterruptMaskM04 { get; set; }
Public Property InterruptMaskM04 As Pcal9539aTypeInterruptMask
    Get
    Set
public:
property Pcal9539aTypeInterruptMask InterruptMaskM04 {
    Pcal9539aTypeInterruptMask get ();
    void set (Pcal9539aTypeInterruptMask value);
}
member InterruptMaskM04 : Pcal9539aTypeInterruptMask with get, set

Property Value

Type: Pcal9539aTypeInterruptMask
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptMaskM05 Property

IRD

Pcal9539aInterruptMaskM05 Property

Interrupt Mask: M0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptMask InterruptMaskM05 { get; set; }
Public Property InterruptMaskM05 As Pcal9539aTypeInterruptMask
    Get
    Set
public:
property Pcal9539aTypeInterruptMask InterruptMaskM05 {
    Pcal9539aTypeInterruptMask get ();
    void set (Pcal9539aTypeInterruptMask value);
}
member InterruptMaskM05 : Pcal9539aTypeInterruptMask with get, set

Property Value

Type: Pcal9539aTypeInterruptMask
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptMaskM06 Property

IRD

Pcal9539aInterruptMaskM06 Property

Interrupt Mask: M0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptMask InterruptMaskM06 { get; set; }
Public Property InterruptMaskM06 As Pcal9539aTypeInterruptMask
    Get
    Set
public:
property Pcal9539aTypeInterruptMask InterruptMaskM06 {
    Pcal9539aTypeInterruptMask get ();
    void set (Pcal9539aTypeInterruptMask value);
}
member InterruptMaskM06 : Pcal9539aTypeInterruptMask with get, set

Property Value

Type: Pcal9539aTypeInterruptMask
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptMaskM07 Property

IRD

Pcal9539aInterruptMaskM07 Property

Interrupt Mask: M0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptMask InterruptMaskM07 { get; set; }
Public Property InterruptMaskM07 As Pcal9539aTypeInterruptMask
    Get
    Set
public:
property Pcal9539aTypeInterruptMask InterruptMaskM07 {
    Pcal9539aTypeInterruptMask get ();
    void set (Pcal9539aTypeInterruptMask value);
}
member InterruptMaskM07 : Pcal9539aTypeInterruptMask with get, set

Property Value

Type: Pcal9539aTypeInterruptMask
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptMaskM10 Property

IRD

Pcal9539aInterruptMaskM10 Property

Interrupt Mask: M1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptMask InterruptMaskM10 { get; set; }
Public Property InterruptMaskM10 As Pcal9539aTypeInterruptMask
    Get
    Set
public:
property Pcal9539aTypeInterruptMask InterruptMaskM10 {
    Pcal9539aTypeInterruptMask get ();
    void set (Pcal9539aTypeInterruptMask value);
}
member InterruptMaskM10 : Pcal9539aTypeInterruptMask with get, set

Property Value

Type: Pcal9539aTypeInterruptMask
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptMaskM11 Property

IRD

Pcal9539aInterruptMaskM11 Property

Interrupt Mask: M1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptMask InterruptMaskM11 { get; set; }
Public Property InterruptMaskM11 As Pcal9539aTypeInterruptMask
    Get
    Set
public:
property Pcal9539aTypeInterruptMask InterruptMaskM11 {
    Pcal9539aTypeInterruptMask get ();
    void set (Pcal9539aTypeInterruptMask value);
}
member InterruptMaskM11 : Pcal9539aTypeInterruptMask with get, set

Property Value

Type: Pcal9539aTypeInterruptMask
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptMaskM12 Property

IRD

Pcal9539aInterruptMaskM12 Property

Interrupt Mask: M1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptMask InterruptMaskM12 { get; set; }
Public Property InterruptMaskM12 As Pcal9539aTypeInterruptMask
    Get
    Set
public:
property Pcal9539aTypeInterruptMask InterruptMaskM12 {
    Pcal9539aTypeInterruptMask get ();
    void set (Pcal9539aTypeInterruptMask value);
}
member InterruptMaskM12 : Pcal9539aTypeInterruptMask with get, set

Property Value

Type: Pcal9539aTypeInterruptMask
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptMaskM13 Property

IRD

Pcal9539aInterruptMaskM13 Property

Interrupt Mask: M1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptMask InterruptMaskM13 { get; set; }
Public Property InterruptMaskM13 As Pcal9539aTypeInterruptMask
    Get
    Set
public:
property Pcal9539aTypeInterruptMask InterruptMaskM13 {
    Pcal9539aTypeInterruptMask get ();
    void set (Pcal9539aTypeInterruptMask value);
}
member InterruptMaskM13 : Pcal9539aTypeInterruptMask with get, set

Property Value

Type: Pcal9539aTypeInterruptMask
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptMaskM14 Property

IRD

Pcal9539aInterruptMaskM14 Property

Interrupt Mask: M1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptMask InterruptMaskM14 { get; set; }
Public Property InterruptMaskM14 As Pcal9539aTypeInterruptMask
    Get
    Set
public:
property Pcal9539aTypeInterruptMask InterruptMaskM14 {
    Pcal9539aTypeInterruptMask get ();
    void set (Pcal9539aTypeInterruptMask value);
}
member InterruptMaskM14 : Pcal9539aTypeInterruptMask with get, set

Property Value

Type: Pcal9539aTypeInterruptMask
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptMaskM15 Property

IRD

Pcal9539aInterruptMaskM15 Property

Interrupt Mask: M1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptMask InterruptMaskM15 { get; set; }
Public Property InterruptMaskM15 As Pcal9539aTypeInterruptMask
    Get
    Set
public:
property Pcal9539aTypeInterruptMask InterruptMaskM15 {
    Pcal9539aTypeInterruptMask get ();
    void set (Pcal9539aTypeInterruptMask value);
}
member InterruptMaskM15 : Pcal9539aTypeInterruptMask with get, set

Property Value

Type: Pcal9539aTypeInterruptMask
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptMaskM16 Property

IRD

Pcal9539aInterruptMaskM16 Property

Interrupt Mask: M1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptMask InterruptMaskM16 { get; set; }
Public Property InterruptMaskM16 As Pcal9539aTypeInterruptMask
    Get
    Set
public:
property Pcal9539aTypeInterruptMask InterruptMaskM16 {
    Pcal9539aTypeInterruptMask get ();
    void set (Pcal9539aTypeInterruptMask value);
}
member InterruptMaskM16 : Pcal9539aTypeInterruptMask with get, set

Property Value

Type: Pcal9539aTypeInterruptMask
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptMaskM17 Property

IRD

Pcal9539aInterruptMaskM17 Property

Interrupt Mask: M1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptMask InterruptMaskM17 { get; set; }
Public Property InterruptMaskM17 As Pcal9539aTypeInterruptMask
    Get
    Set
public:
property Pcal9539aTypeInterruptMask InterruptMaskM17 {
    Pcal9539aTypeInterruptMask get ();
    void set (Pcal9539aTypeInterruptMask value);
}
member InterruptMaskM17 : Pcal9539aTypeInterruptMask with get, set

Property Value

Type: Pcal9539aTypeInterruptMask
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptStatusS00 Property

IRD

Pcal9539aInterruptStatusS00 Property

Interrupt Status: S0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptStatus InterruptStatusS00 { get; }
Public ReadOnly Property InterruptStatusS00 As Pcal9539aTypeInterruptStatus
    Get
public:
property Pcal9539aTypeInterruptStatus InterruptStatusS00 {
    Pcal9539aTypeInterruptStatus get ();
}
member InterruptStatusS00 : Pcal9539aTypeInterruptStatus with get

Property Value

Type: Pcal9539aTypeInterruptStatus
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptStatusS01 Property

IRD

Pcal9539aInterruptStatusS01 Property

Interrupt Status: S0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptStatus InterruptStatusS01 { get; }
Public ReadOnly Property InterruptStatusS01 As Pcal9539aTypeInterruptStatus
    Get
public:
property Pcal9539aTypeInterruptStatus InterruptStatusS01 {
    Pcal9539aTypeInterruptStatus get ();
}
member InterruptStatusS01 : Pcal9539aTypeInterruptStatus with get

Property Value

Type: Pcal9539aTypeInterruptStatus
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptStatusS02 Property

IRD

Pcal9539aInterruptStatusS02 Property

Interrupt Status: S0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptStatus InterruptStatusS02 { get; }
Public ReadOnly Property InterruptStatusS02 As Pcal9539aTypeInterruptStatus
    Get
public:
property Pcal9539aTypeInterruptStatus InterruptStatusS02 {
    Pcal9539aTypeInterruptStatus get ();
}
member InterruptStatusS02 : Pcal9539aTypeInterruptStatus with get

Property Value

Type: Pcal9539aTypeInterruptStatus
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptStatusS03 Property

IRD

Pcal9539aInterruptStatusS03 Property

Interrupt Status: S0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptStatus InterruptStatusS03 { get; }
Public ReadOnly Property InterruptStatusS03 As Pcal9539aTypeInterruptStatus
    Get
public:
property Pcal9539aTypeInterruptStatus InterruptStatusS03 {
    Pcal9539aTypeInterruptStatus get ();
}
member InterruptStatusS03 : Pcal9539aTypeInterruptStatus with get

Property Value

Type: Pcal9539aTypeInterruptStatus
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptStatusS04 Property

IRD

Pcal9539aInterruptStatusS04 Property

Interrupt Status: S0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptStatus InterruptStatusS04 { get; }
Public ReadOnly Property InterruptStatusS04 As Pcal9539aTypeInterruptStatus
    Get
public:
property Pcal9539aTypeInterruptStatus InterruptStatusS04 {
    Pcal9539aTypeInterruptStatus get ();
}
member InterruptStatusS04 : Pcal9539aTypeInterruptStatus with get

Property Value

Type: Pcal9539aTypeInterruptStatus
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptStatusS05 Property

IRD

Pcal9539aInterruptStatusS05 Property

Interrupt Status: S0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptStatus InterruptStatusS05 { get; }
Public ReadOnly Property InterruptStatusS05 As Pcal9539aTypeInterruptStatus
    Get
public:
property Pcal9539aTypeInterruptStatus InterruptStatusS05 {
    Pcal9539aTypeInterruptStatus get ();
}
member InterruptStatusS05 : Pcal9539aTypeInterruptStatus with get

Property Value

Type: Pcal9539aTypeInterruptStatus
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptStatusS06 Property

IRD

Pcal9539aInterruptStatusS06 Property

Interrupt Status: S0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptStatus InterruptStatusS06 { get; }
Public ReadOnly Property InterruptStatusS06 As Pcal9539aTypeInterruptStatus
    Get
public:
property Pcal9539aTypeInterruptStatus InterruptStatusS06 {
    Pcal9539aTypeInterruptStatus get ();
}
member InterruptStatusS06 : Pcal9539aTypeInterruptStatus with get

Property Value

Type: Pcal9539aTypeInterruptStatus
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptStatusS07 Property

IRD

Pcal9539aInterruptStatusS07 Property

Interrupt Status: S0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptStatus InterruptStatusS07 { get; }
Public ReadOnly Property InterruptStatusS07 As Pcal9539aTypeInterruptStatus
    Get
public:
property Pcal9539aTypeInterruptStatus InterruptStatusS07 {
    Pcal9539aTypeInterruptStatus get ();
}
member InterruptStatusS07 : Pcal9539aTypeInterruptStatus with get

Property Value

Type: Pcal9539aTypeInterruptStatus
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptStatusS10 Property

IRD

Pcal9539aInterruptStatusS10 Property

Interrupt Status: S1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptStatus InterruptStatusS10 { get; }
Public ReadOnly Property InterruptStatusS10 As Pcal9539aTypeInterruptStatus
    Get
public:
property Pcal9539aTypeInterruptStatus InterruptStatusS10 {
    Pcal9539aTypeInterruptStatus get ();
}
member InterruptStatusS10 : Pcal9539aTypeInterruptStatus with get

Property Value

Type: Pcal9539aTypeInterruptStatus
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptStatusS11 Property

IRD

Pcal9539aInterruptStatusS11 Property

Interrupt Status: S1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptStatus InterruptStatusS11 { get; }
Public ReadOnly Property InterruptStatusS11 As Pcal9539aTypeInterruptStatus
    Get
public:
property Pcal9539aTypeInterruptStatus InterruptStatusS11 {
    Pcal9539aTypeInterruptStatus get ();
}
member InterruptStatusS11 : Pcal9539aTypeInterruptStatus with get

Property Value

Type: Pcal9539aTypeInterruptStatus
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptStatusS12 Property

IRD

Pcal9539aInterruptStatusS12 Property

Interrupt Status: S1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptStatus InterruptStatusS12 { get; }
Public ReadOnly Property InterruptStatusS12 As Pcal9539aTypeInterruptStatus
    Get
public:
property Pcal9539aTypeInterruptStatus InterruptStatusS12 {
    Pcal9539aTypeInterruptStatus get ();
}
member InterruptStatusS12 : Pcal9539aTypeInterruptStatus with get

Property Value

Type: Pcal9539aTypeInterruptStatus
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptStatusS13 Property

IRD

Pcal9539aInterruptStatusS13 Property

Interrupt Status: S1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptStatus InterruptStatusS13 { get; }
Public ReadOnly Property InterruptStatusS13 As Pcal9539aTypeInterruptStatus
    Get
public:
property Pcal9539aTypeInterruptStatus InterruptStatusS13 {
    Pcal9539aTypeInterruptStatus get ();
}
member InterruptStatusS13 : Pcal9539aTypeInterruptStatus with get

Property Value

Type: Pcal9539aTypeInterruptStatus
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptStatusS14 Property

IRD

Pcal9539aInterruptStatusS14 Property

Interrupt Status: S1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptStatus InterruptStatusS14 { get; }
Public ReadOnly Property InterruptStatusS14 As Pcal9539aTypeInterruptStatus
    Get
public:
property Pcal9539aTypeInterruptStatus InterruptStatusS14 {
    Pcal9539aTypeInterruptStatus get ();
}
member InterruptStatusS14 : Pcal9539aTypeInterruptStatus with get

Property Value

Type: Pcal9539aTypeInterruptStatus
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptStatusS15 Property

IRD

Pcal9539aInterruptStatusS15 Property

Interrupt Status: S1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptStatus InterruptStatusS15 { get; }
Public ReadOnly Property InterruptStatusS15 As Pcal9539aTypeInterruptStatus
    Get
public:
property Pcal9539aTypeInterruptStatus InterruptStatusS15 {
    Pcal9539aTypeInterruptStatus get ();
}
member InterruptStatusS15 : Pcal9539aTypeInterruptStatus with get

Property Value

Type: Pcal9539aTypeInterruptStatus
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptStatusS16 Property

IRD

Pcal9539aInterruptStatusS16 Property

Interrupt Status: S1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptStatus InterruptStatusS16 { get; }
Public ReadOnly Property InterruptStatusS16 As Pcal9539aTypeInterruptStatus
    Get
public:
property Pcal9539aTypeInterruptStatus InterruptStatusS16 {
    Pcal9539aTypeInterruptStatus get ();
}
member InterruptStatusS16 : Pcal9539aTypeInterruptStatus with get

Property Value

Type: Pcal9539aTypeInterruptStatus
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.InterruptStatusS17 Property

IRD

Pcal9539aInterruptStatusS17 Property

Interrupt Status: S1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeInterruptStatus InterruptStatusS17 { get; }
Public ReadOnly Property InterruptStatusS17 As Pcal9539aTypeInterruptStatus
    Get
public:
property Pcal9539aTypeInterruptStatus InterruptStatusS17 {
    Pcal9539aTypeInterruptStatus get ();
}
member InterruptStatusS17 : Pcal9539aTypeInterruptStatus with get

Property Value

Type: Pcal9539aTypeInterruptStatus
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputDriveStrengthCC00 Property

IRD

Pcal9539aOutputDriveStrengthCC00 Property

Output Drive Strength: CC0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC00 { get; set; }
Public Property OutputDriveStrengthCC00 As Pcal9539aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC00 {
    Pcal9539aTypeOutputDriveStrength get ();
    void set (Pcal9539aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC00 : Pcal9539aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9539aTypeOutputDriveStrength
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputDriveStrengthCC01 Property

IRD

Pcal9539aOutputDriveStrengthCC01 Property

Output Drive Strength: CC0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC01 { get; set; }
Public Property OutputDriveStrengthCC01 As Pcal9539aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC01 {
    Pcal9539aTypeOutputDriveStrength get ();
    void set (Pcal9539aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC01 : Pcal9539aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9539aTypeOutputDriveStrength
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputDriveStrengthCC02 Property

IRD

Pcal9539aOutputDriveStrengthCC02 Property

Output Drive Strength: CC0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC02 { get; set; }
Public Property OutputDriveStrengthCC02 As Pcal9539aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC02 {
    Pcal9539aTypeOutputDriveStrength get ();
    void set (Pcal9539aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC02 : Pcal9539aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9539aTypeOutputDriveStrength
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputDriveStrengthCC03 Property

IRD

Pcal9539aOutputDriveStrengthCC03 Property

Output Drive Strength: CC0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC03 { get; set; }
Public Property OutputDriveStrengthCC03 As Pcal9539aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC03 {
    Pcal9539aTypeOutputDriveStrength get ();
    void set (Pcal9539aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC03 : Pcal9539aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9539aTypeOutputDriveStrength
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputDriveStrengthCC04 Property

IRD

Pcal9539aOutputDriveStrengthCC04 Property

Output Drive Strength: CC0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC04 { get; set; }
Public Property OutputDriveStrengthCC04 As Pcal9539aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC04 {
    Pcal9539aTypeOutputDriveStrength get ();
    void set (Pcal9539aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC04 : Pcal9539aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9539aTypeOutputDriveStrength
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputDriveStrengthCC05 Property

IRD

Pcal9539aOutputDriveStrengthCC05 Property

Output Drive Strength: CC0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC05 { get; set; }
Public Property OutputDriveStrengthCC05 As Pcal9539aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC05 {
    Pcal9539aTypeOutputDriveStrength get ();
    void set (Pcal9539aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC05 : Pcal9539aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9539aTypeOutputDriveStrength
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputDriveStrengthCC06 Property

IRD

Pcal9539aOutputDriveStrengthCC06 Property

Output Drive Strength: CC0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC06 { get; set; }
Public Property OutputDriveStrengthCC06 As Pcal9539aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC06 {
    Pcal9539aTypeOutputDriveStrength get ();
    void set (Pcal9539aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC06 : Pcal9539aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9539aTypeOutputDriveStrength
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputDriveStrengthCC07 Property

IRD

Pcal9539aOutputDriveStrengthCC07 Property

Output Drive Strength: CC0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC07 { get; set; }
Public Property OutputDriveStrengthCC07 As Pcal9539aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC07 {
    Pcal9539aTypeOutputDriveStrength get ();
    void set (Pcal9539aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC07 : Pcal9539aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9539aTypeOutputDriveStrength
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputDriveStrengthCC10 Property

IRD

Pcal9539aOutputDriveStrengthCC10 Property

Output Drive Strength: CC1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC10 { get; set; }
Public Property OutputDriveStrengthCC10 As Pcal9539aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC10 {
    Pcal9539aTypeOutputDriveStrength get ();
    void set (Pcal9539aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC10 : Pcal9539aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9539aTypeOutputDriveStrength
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputDriveStrengthCC11 Property

IRD

Pcal9539aOutputDriveStrengthCC11 Property

Output Drive Strength: CC1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC11 { get; set; }
Public Property OutputDriveStrengthCC11 As Pcal9539aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC11 {
    Pcal9539aTypeOutputDriveStrength get ();
    void set (Pcal9539aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC11 : Pcal9539aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9539aTypeOutputDriveStrength
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputDriveStrengthCC12 Property

IRD

Pcal9539aOutputDriveStrengthCC12 Property

Output Drive Strength: CC1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC12 { get; set; }
Public Property OutputDriveStrengthCC12 As Pcal9539aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC12 {
    Pcal9539aTypeOutputDriveStrength get ();
    void set (Pcal9539aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC12 : Pcal9539aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9539aTypeOutputDriveStrength
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputDriveStrengthCC13 Property

IRD

Pcal9539aOutputDriveStrengthCC13 Property

Output Drive Strength: CC1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC13 { get; set; }
Public Property OutputDriveStrengthCC13 As Pcal9539aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC13 {
    Pcal9539aTypeOutputDriveStrength get ();
    void set (Pcal9539aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC13 : Pcal9539aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9539aTypeOutputDriveStrength
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputDriveStrengthCC14 Property

IRD

Pcal9539aOutputDriveStrengthCC14 Property

Output Drive Strength: CC1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC14 { get; set; }
Public Property OutputDriveStrengthCC14 As Pcal9539aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC14 {
    Pcal9539aTypeOutputDriveStrength get ();
    void set (Pcal9539aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC14 : Pcal9539aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9539aTypeOutputDriveStrength
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputDriveStrengthCC15 Property

IRD

Pcal9539aOutputDriveStrengthCC15 Property

Output Drive Strength: CC1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC15 { get; set; }
Public Property OutputDriveStrengthCC15 As Pcal9539aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC15 {
    Pcal9539aTypeOutputDriveStrength get ();
    void set (Pcal9539aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC15 : Pcal9539aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9539aTypeOutputDriveStrength
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputDriveStrengthCC16 Property

IRD

Pcal9539aOutputDriveStrengthCC16 Property

Output Drive Strength: CC1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC16 { get; set; }
Public Property OutputDriveStrengthCC16 As Pcal9539aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC16 {
    Pcal9539aTypeOutputDriveStrength get ();
    void set (Pcal9539aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC16 : Pcal9539aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9539aTypeOutputDriveStrength
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputDriveStrengthCC17 Property

IRD

Pcal9539aOutputDriveStrengthCC17 Property

Output Drive Strength: CC1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC17 { get; set; }
Public Property OutputDriveStrengthCC17 As Pcal9539aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9539aTypeOutputDriveStrength OutputDriveStrengthCC17 {
    Pcal9539aTypeOutputDriveStrength get ();
    void set (Pcal9539aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC17 : Pcal9539aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9539aTypeOutputDriveStrength
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputPortConfigurationODEN0 Property

IRD

Pcal9539aOutputPortConfigurationODEN0 Property

Output Port Configuration: ODEN0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeOutputPortConfiguration OutputPortConfigurationODEN0 { get; set; }
Public Property OutputPortConfigurationODEN0 As Pcal9539aTypeOutputPortConfiguration
    Get
    Set
public:
property Pcal9539aTypeOutputPortConfiguration OutputPortConfigurationODEN0 {
    Pcal9539aTypeOutputPortConfiguration get ();
    void set (Pcal9539aTypeOutputPortConfiguration value);
}
member OutputPortConfigurationODEN0 : Pcal9539aTypeOutputPortConfiguration with get, set

Property Value

Type: Pcal9539aTypeOutputPortConfiguration
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputPortConfigurationODEN1 Property

IRD

Pcal9539aOutputPortConfigurationODEN1 Property

Output Port Configuration: ODEN1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypeOutputPortConfiguration OutputPortConfigurationODEN1 { get; set; }
Public Property OutputPortConfigurationODEN1 As Pcal9539aTypeOutputPortConfiguration
    Get
    Set
public:
property Pcal9539aTypeOutputPortConfiguration OutputPortConfigurationODEN1 {
    Pcal9539aTypeOutputPortConfiguration get ();
    void set (Pcal9539aTypeOutputPortConfiguration value);
}
member OutputPortConfigurationODEN1 : Pcal9539aTypeOutputPortConfiguration with get, set

Property Value

Type: Pcal9539aTypeOutputPortConfiguration
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputPortO00 Property

IRD

Pcal9539aOutputPortO00 Property

Output Port: O0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO00 { get; set; }
Public Property OutputPortO00 As Byte
    Get
    Set
public:
property unsigned char OutputPortO00 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO00 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputPortO01 Property

IRD

Pcal9539aOutputPortO01 Property

Output Port: O0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO01 { get; set; }
Public Property OutputPortO01 As Byte
    Get
    Set
public:
property unsigned char OutputPortO01 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO01 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputPortO02 Property

IRD

Pcal9539aOutputPortO02 Property

Output Port: O0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO02 { get; set; }
Public Property OutputPortO02 As Byte
    Get
    Set
public:
property unsigned char OutputPortO02 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO02 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputPortO03 Property

IRD

Pcal9539aOutputPortO03 Property

Output Port: O0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO03 { get; set; }
Public Property OutputPortO03 As Byte
    Get
    Set
public:
property unsigned char OutputPortO03 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO03 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputPortO04 Property

IRD

Pcal9539aOutputPortO04 Property

Output Port: O0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO04 { get; set; }
Public Property OutputPortO04 As Byte
    Get
    Set
public:
property unsigned char OutputPortO04 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO04 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputPortO05 Property

IRD

Pcal9539aOutputPortO05 Property

Output Port: O0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO05 { get; set; }
Public Property OutputPortO05 As Byte
    Get
    Set
public:
property unsigned char OutputPortO05 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO05 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputPortO06 Property

IRD

Pcal9539aOutputPortO06 Property

Output Port: O0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO06 { get; set; }
Public Property OutputPortO06 As Byte
    Get
    Set
public:
property unsigned char OutputPortO06 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO06 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputPortO07 Property

IRD

Pcal9539aOutputPortO07 Property

Output Port: O0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO07 { get; set; }
Public Property OutputPortO07 As Byte
    Get
    Set
public:
property unsigned char OutputPortO07 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO07 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputPortO10 Property

IRD

Pcal9539aOutputPortO10 Property

Output Port: O1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO10 { get; set; }
Public Property OutputPortO10 As Byte
    Get
    Set
public:
property unsigned char OutputPortO10 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO10 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputPortO11 Property

IRD

Pcal9539aOutputPortO11 Property

Output Port: O1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO11 { get; set; }
Public Property OutputPortO11 As Byte
    Get
    Set
public:
property unsigned char OutputPortO11 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO11 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputPortO12 Property

IRD

Pcal9539aOutputPortO12 Property

Output Port: O1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO12 { get; set; }
Public Property OutputPortO12 As Byte
    Get
    Set
public:
property unsigned char OutputPortO12 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO12 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputPortO13 Property

IRD

Pcal9539aOutputPortO13 Property

Output Port: O1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO13 { get; set; }
Public Property OutputPortO13 As Byte
    Get
    Set
public:
property unsigned char OutputPortO13 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO13 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputPortO14 Property

IRD

Pcal9539aOutputPortO14 Property

Output Port: O1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO14 { get; set; }
Public Property OutputPortO14 As Byte
    Get
    Set
public:
property unsigned char OutputPortO14 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO14 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputPortO15 Property

IRD

Pcal9539aOutputPortO15 Property

Output Port: O1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO15 { get; set; }
Public Property OutputPortO15 As Byte
    Get
    Set
public:
property unsigned char OutputPortO15 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO15 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputPortO16 Property

IRD

Pcal9539aOutputPortO16 Property

Output Port: O1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO16 { get; set; }
Public Property OutputPortO16 As Byte
    Get
    Set
public:
property unsigned char OutputPortO16 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO16 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.OutputPortO17 Property

IRD

Pcal9539aOutputPortO17 Property

Output Port: O1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO17 { get; set; }
Public Property OutputPortO17 As Byte
    Get
    Set
public:
property unsigned char OutputPortO17 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO17 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PolarityInversionN00 Property

IRD

Pcal9539aPolarityInversionN00 Property

Polarity Inversion: N0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePolarityInversion PolarityInversionN00 { get; set; }
Public Property PolarityInversionN00 As Pcal9539aTypePolarityInversion
    Get
    Set
public:
property Pcal9539aTypePolarityInversion PolarityInversionN00 {
    Pcal9539aTypePolarityInversion get ();
    void set (Pcal9539aTypePolarityInversion value);
}
member PolarityInversionN00 : Pcal9539aTypePolarityInversion with get, set

Property Value

Type: Pcal9539aTypePolarityInversion
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PolarityInversionN01 Property

IRD

Pcal9539aPolarityInversionN01 Property

Polarity Inversion: N0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePolarityInversion PolarityInversionN01 { get; set; }
Public Property PolarityInversionN01 As Pcal9539aTypePolarityInversion
    Get
    Set
public:
property Pcal9539aTypePolarityInversion PolarityInversionN01 {
    Pcal9539aTypePolarityInversion get ();
    void set (Pcal9539aTypePolarityInversion value);
}
member PolarityInversionN01 : Pcal9539aTypePolarityInversion with get, set

Property Value

Type: Pcal9539aTypePolarityInversion
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PolarityInversionN02 Property

IRD

Pcal9539aPolarityInversionN02 Property

Polarity Inversion: N0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePolarityInversion PolarityInversionN02 { get; set; }
Public Property PolarityInversionN02 As Pcal9539aTypePolarityInversion
    Get
    Set
public:
property Pcal9539aTypePolarityInversion PolarityInversionN02 {
    Pcal9539aTypePolarityInversion get ();
    void set (Pcal9539aTypePolarityInversion value);
}
member PolarityInversionN02 : Pcal9539aTypePolarityInversion with get, set

Property Value

Type: Pcal9539aTypePolarityInversion
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PolarityInversionN03 Property

IRD

Pcal9539aPolarityInversionN03 Property

Polarity Inversion: N0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePolarityInversion PolarityInversionN03 { get; set; }
Public Property PolarityInversionN03 As Pcal9539aTypePolarityInversion
    Get
    Set
public:
property Pcal9539aTypePolarityInversion PolarityInversionN03 {
    Pcal9539aTypePolarityInversion get ();
    void set (Pcal9539aTypePolarityInversion value);
}
member PolarityInversionN03 : Pcal9539aTypePolarityInversion with get, set

Property Value

Type: Pcal9539aTypePolarityInversion
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PolarityInversionN04 Property

IRD

Pcal9539aPolarityInversionN04 Property

Polarity Inversion: N0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePolarityInversion PolarityInversionN04 { get; set; }
Public Property PolarityInversionN04 As Pcal9539aTypePolarityInversion
    Get
    Set
public:
property Pcal9539aTypePolarityInversion PolarityInversionN04 {
    Pcal9539aTypePolarityInversion get ();
    void set (Pcal9539aTypePolarityInversion value);
}
member PolarityInversionN04 : Pcal9539aTypePolarityInversion with get, set

Property Value

Type: Pcal9539aTypePolarityInversion
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PolarityInversionN05 Property

IRD

Pcal9539aPolarityInversionN05 Property

Polarity Inversion: N0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePolarityInversion PolarityInversionN05 { get; set; }
Public Property PolarityInversionN05 As Pcal9539aTypePolarityInversion
    Get
    Set
public:
property Pcal9539aTypePolarityInversion PolarityInversionN05 {
    Pcal9539aTypePolarityInversion get ();
    void set (Pcal9539aTypePolarityInversion value);
}
member PolarityInversionN05 : Pcal9539aTypePolarityInversion with get, set

Property Value

Type: Pcal9539aTypePolarityInversion
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PolarityInversionN06 Property

IRD

Pcal9539aPolarityInversionN06 Property

Polarity Inversion: N0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePolarityInversion PolarityInversionN06 { get; set; }
Public Property PolarityInversionN06 As Pcal9539aTypePolarityInversion
    Get
    Set
public:
property Pcal9539aTypePolarityInversion PolarityInversionN06 {
    Pcal9539aTypePolarityInversion get ();
    void set (Pcal9539aTypePolarityInversion value);
}
member PolarityInversionN06 : Pcal9539aTypePolarityInversion with get, set

Property Value

Type: Pcal9539aTypePolarityInversion
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PolarityInversionN07 Property

IRD

Pcal9539aPolarityInversionN07 Property

Polarity Inversion: N0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePolarityInversion PolarityInversionN07 { get; set; }
Public Property PolarityInversionN07 As Pcal9539aTypePolarityInversion
    Get
    Set
public:
property Pcal9539aTypePolarityInversion PolarityInversionN07 {
    Pcal9539aTypePolarityInversion get ();
    void set (Pcal9539aTypePolarityInversion value);
}
member PolarityInversionN07 : Pcal9539aTypePolarityInversion with get, set

Property Value

Type: Pcal9539aTypePolarityInversion
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PolarityInversionN10 Property

IRD

Pcal9539aPolarityInversionN10 Property

Polarity Inversion: N1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePolarityInversion PolarityInversionN10 { get; set; }
Public Property PolarityInversionN10 As Pcal9539aTypePolarityInversion
    Get
    Set
public:
property Pcal9539aTypePolarityInversion PolarityInversionN10 {
    Pcal9539aTypePolarityInversion get ();
    void set (Pcal9539aTypePolarityInversion value);
}
member PolarityInversionN10 : Pcal9539aTypePolarityInversion with get, set

Property Value

Type: Pcal9539aTypePolarityInversion
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PolarityInversionN11 Property

IRD

Pcal9539aPolarityInversionN11 Property

Polarity Inversion: N1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePolarityInversion PolarityInversionN11 { get; set; }
Public Property PolarityInversionN11 As Pcal9539aTypePolarityInversion
    Get
    Set
public:
property Pcal9539aTypePolarityInversion PolarityInversionN11 {
    Pcal9539aTypePolarityInversion get ();
    void set (Pcal9539aTypePolarityInversion value);
}
member PolarityInversionN11 : Pcal9539aTypePolarityInversion with get, set

Property Value

Type: Pcal9539aTypePolarityInversion
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PolarityInversionN12 Property

IRD

Pcal9539aPolarityInversionN12 Property

Polarity Inversion: N1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePolarityInversion PolarityInversionN12 { get; set; }
Public Property PolarityInversionN12 As Pcal9539aTypePolarityInversion
    Get
    Set
public:
property Pcal9539aTypePolarityInversion PolarityInversionN12 {
    Pcal9539aTypePolarityInversion get ();
    void set (Pcal9539aTypePolarityInversion value);
}
member PolarityInversionN12 : Pcal9539aTypePolarityInversion with get, set

Property Value

Type: Pcal9539aTypePolarityInversion
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PolarityInversionN13 Property

IRD

Pcal9539aPolarityInversionN13 Property

Polarity Inversion: N1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePolarityInversion PolarityInversionN13 { get; set; }
Public Property PolarityInversionN13 As Pcal9539aTypePolarityInversion
    Get
    Set
public:
property Pcal9539aTypePolarityInversion PolarityInversionN13 {
    Pcal9539aTypePolarityInversion get ();
    void set (Pcal9539aTypePolarityInversion value);
}
member PolarityInversionN13 : Pcal9539aTypePolarityInversion with get, set

Property Value

Type: Pcal9539aTypePolarityInversion
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PolarityInversionN14 Property

IRD

Pcal9539aPolarityInversionN14 Property

Polarity Inversion: N1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePolarityInversion PolarityInversionN14 { get; set; }
Public Property PolarityInversionN14 As Pcal9539aTypePolarityInversion
    Get
    Set
public:
property Pcal9539aTypePolarityInversion PolarityInversionN14 {
    Pcal9539aTypePolarityInversion get ();
    void set (Pcal9539aTypePolarityInversion value);
}
member PolarityInversionN14 : Pcal9539aTypePolarityInversion with get, set

Property Value

Type: Pcal9539aTypePolarityInversion
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PolarityInversionN15 Property

IRD

Pcal9539aPolarityInversionN15 Property

Polarity Inversion: N1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePolarityInversion PolarityInversionN15 { get; set; }
Public Property PolarityInversionN15 As Pcal9539aTypePolarityInversion
    Get
    Set
public:
property Pcal9539aTypePolarityInversion PolarityInversionN15 {
    Pcal9539aTypePolarityInversion get ();
    void set (Pcal9539aTypePolarityInversion value);
}
member PolarityInversionN15 : Pcal9539aTypePolarityInversion with get, set

Property Value

Type: Pcal9539aTypePolarityInversion
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PolarityInversionN16 Property

IRD

Pcal9539aPolarityInversionN16 Property

Polarity Inversion: N1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePolarityInversion PolarityInversionN16 { get; set; }
Public Property PolarityInversionN16 As Pcal9539aTypePolarityInversion
    Get
    Set
public:
property Pcal9539aTypePolarityInversion PolarityInversionN16 {
    Pcal9539aTypePolarityInversion get ();
    void set (Pcal9539aTypePolarityInversion value);
}
member PolarityInversionN16 : Pcal9539aTypePolarityInversion with get, set

Property Value

Type: Pcal9539aTypePolarityInversion
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PolarityInversionN17 Property

IRD

Pcal9539aPolarityInversionN17 Property

Polarity Inversion: N1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePolarityInversion PolarityInversionN17 { get; set; }
Public Property PolarityInversionN17 As Pcal9539aTypePolarityInversion
    Get
    Set
public:
property Pcal9539aTypePolarityInversion PolarityInversionN17 {
    Pcal9539aTypePolarityInversion get ();
    void set (Pcal9539aTypePolarityInversion value);
}
member PolarityInversionN17 : Pcal9539aTypePolarityInversion with get, set

Property Value

Type: Pcal9539aTypePolarityInversion
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownEnablePE00 Property

IRD

Pcal9539aPullUpPullDownEnablePE00 Property

Pull-Up/Pull-Down Enable: PE0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE00 { get; set; }
Public Property PullUpPullDownEnablePE00 As Pcal9539aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE00 {
    Pcal9539aTypePullUpPullDownEnable get ();
    void set (Pcal9539aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE00 : Pcal9539aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownEnable
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownEnablePE01 Property

IRD

Pcal9539aPullUpPullDownEnablePE01 Property

Pull-Up/Pull-Down Enable: PE0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE01 { get; set; }
Public Property PullUpPullDownEnablePE01 As Pcal9539aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE01 {
    Pcal9539aTypePullUpPullDownEnable get ();
    void set (Pcal9539aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE01 : Pcal9539aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownEnable
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownEnablePE02 Property

IRD

Pcal9539aPullUpPullDownEnablePE02 Property

Pull-Up/Pull-Down Enable: PE0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE02 { get; set; }
Public Property PullUpPullDownEnablePE02 As Pcal9539aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE02 {
    Pcal9539aTypePullUpPullDownEnable get ();
    void set (Pcal9539aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE02 : Pcal9539aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownEnable
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownEnablePE03 Property

IRD

Pcal9539aPullUpPullDownEnablePE03 Property

Pull-Up/Pull-Down Enable: PE0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE03 { get; set; }
Public Property PullUpPullDownEnablePE03 As Pcal9539aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE03 {
    Pcal9539aTypePullUpPullDownEnable get ();
    void set (Pcal9539aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE03 : Pcal9539aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownEnable
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownEnablePE04 Property

IRD

Pcal9539aPullUpPullDownEnablePE04 Property

Pull-Up/Pull-Down Enable: PE0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE04 { get; set; }
Public Property PullUpPullDownEnablePE04 As Pcal9539aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE04 {
    Pcal9539aTypePullUpPullDownEnable get ();
    void set (Pcal9539aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE04 : Pcal9539aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownEnable
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownEnablePE05 Property

IRD

Pcal9539aPullUpPullDownEnablePE05 Property

Pull-Up/Pull-Down Enable: PE0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE05 { get; set; }
Public Property PullUpPullDownEnablePE05 As Pcal9539aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE05 {
    Pcal9539aTypePullUpPullDownEnable get ();
    void set (Pcal9539aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE05 : Pcal9539aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownEnable
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownEnablePE06 Property

IRD

Pcal9539aPullUpPullDownEnablePE06 Property

Pull-Up/Pull-Down Enable: PE0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE06 { get; set; }
Public Property PullUpPullDownEnablePE06 As Pcal9539aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE06 {
    Pcal9539aTypePullUpPullDownEnable get ();
    void set (Pcal9539aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE06 : Pcal9539aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownEnable
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownEnablePE07 Property

IRD

Pcal9539aPullUpPullDownEnablePE07 Property

Pull-Up/Pull-Down Enable: PE0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE07 { get; set; }
Public Property PullUpPullDownEnablePE07 As Pcal9539aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE07 {
    Pcal9539aTypePullUpPullDownEnable get ();
    void set (Pcal9539aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE07 : Pcal9539aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownEnable
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownEnablePE10 Property

IRD

Pcal9539aPullUpPullDownEnablePE10 Property

Pull-Up/Pull-Down Enable: PE1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE10 { get; set; }
Public Property PullUpPullDownEnablePE10 As Pcal9539aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE10 {
    Pcal9539aTypePullUpPullDownEnable get ();
    void set (Pcal9539aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE10 : Pcal9539aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownEnable
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownEnablePE11 Property

IRD

Pcal9539aPullUpPullDownEnablePE11 Property

Pull-Up/Pull-Down Enable: PE1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE11 { get; set; }
Public Property PullUpPullDownEnablePE11 As Pcal9539aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE11 {
    Pcal9539aTypePullUpPullDownEnable get ();
    void set (Pcal9539aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE11 : Pcal9539aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownEnable
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownEnablePE12 Property

IRD

Pcal9539aPullUpPullDownEnablePE12 Property

Pull-Up/Pull-Down Enable: PE1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE12 { get; set; }
Public Property PullUpPullDownEnablePE12 As Pcal9539aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE12 {
    Pcal9539aTypePullUpPullDownEnable get ();
    void set (Pcal9539aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE12 : Pcal9539aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownEnable
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownEnablePE13 Property

IRD

Pcal9539aPullUpPullDownEnablePE13 Property

Pull-Up/Pull-Down Enable: PE1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE13 { get; set; }
Public Property PullUpPullDownEnablePE13 As Pcal9539aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE13 {
    Pcal9539aTypePullUpPullDownEnable get ();
    void set (Pcal9539aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE13 : Pcal9539aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownEnable
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownEnablePE14 Property

IRD

Pcal9539aPullUpPullDownEnablePE14 Property

Pull-Up/Pull-Down Enable: PE1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE14 { get; set; }
Public Property PullUpPullDownEnablePE14 As Pcal9539aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE14 {
    Pcal9539aTypePullUpPullDownEnable get ();
    void set (Pcal9539aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE14 : Pcal9539aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownEnable
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownEnablePE15 Property

IRD

Pcal9539aPullUpPullDownEnablePE15 Property

Pull-Up/Pull-Down Enable: PE1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE15 { get; set; }
Public Property PullUpPullDownEnablePE15 As Pcal9539aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE15 {
    Pcal9539aTypePullUpPullDownEnable get ();
    void set (Pcal9539aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE15 : Pcal9539aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownEnable
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownEnablePE16 Property

IRD

Pcal9539aPullUpPullDownEnablePE16 Property

Pull-Up/Pull-Down Enable: PE1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE16 { get; set; }
Public Property PullUpPullDownEnablePE16 As Pcal9539aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE16 {
    Pcal9539aTypePullUpPullDownEnable get ();
    void set (Pcal9539aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE16 : Pcal9539aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownEnable
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownEnablePE17 Property

IRD

Pcal9539aPullUpPullDownEnablePE17 Property

Pull-Up/Pull-Down Enable: PE1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE17 { get; set; }
Public Property PullUpPullDownEnablePE17 As Pcal9539aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownEnable PullUpPullDownEnablePE17 {
    Pcal9539aTypePullUpPullDownEnable get ();
    void set (Pcal9539aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE17 : Pcal9539aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownEnable
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownSelectionPUD00 Property

IRD

Pcal9539aPullUpPullDownSelectionPUD00 Property

Pull-Up/Pull-Down Selection: PUD0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD00 { get; set; }
Public Property PullUpPullDownSelectionPUD00 As Pcal9539aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD00 {
    Pcal9539aTypePullUpPullDownSelection get ();
    void set (Pcal9539aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD00 : Pcal9539aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownSelection
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownSelectionPUD01 Property

IRD

Pcal9539aPullUpPullDownSelectionPUD01 Property

Pull-Up/Pull-Down Selection: PUD0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD01 { get; set; }
Public Property PullUpPullDownSelectionPUD01 As Pcal9539aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD01 {
    Pcal9539aTypePullUpPullDownSelection get ();
    void set (Pcal9539aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD01 : Pcal9539aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownSelection
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownSelectionPUD02 Property

IRD

Pcal9539aPullUpPullDownSelectionPUD02 Property

Pull-Up/Pull-Down Selection: PUD0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD02 { get; set; }
Public Property PullUpPullDownSelectionPUD02 As Pcal9539aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD02 {
    Pcal9539aTypePullUpPullDownSelection get ();
    void set (Pcal9539aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD02 : Pcal9539aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownSelection
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownSelectionPUD03 Property

IRD

Pcal9539aPullUpPullDownSelectionPUD03 Property

Pull-Up/Pull-Down Selection: PUD0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD03 { get; set; }
Public Property PullUpPullDownSelectionPUD03 As Pcal9539aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD03 {
    Pcal9539aTypePullUpPullDownSelection get ();
    void set (Pcal9539aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD03 : Pcal9539aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownSelection
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownSelectionPUD04 Property

IRD

Pcal9539aPullUpPullDownSelectionPUD04 Property

Pull-Up/Pull-Down Selection: PUD0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD04 { get; set; }
Public Property PullUpPullDownSelectionPUD04 As Pcal9539aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD04 {
    Pcal9539aTypePullUpPullDownSelection get ();
    void set (Pcal9539aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD04 : Pcal9539aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownSelection
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownSelectionPUD05 Property

IRD

Pcal9539aPullUpPullDownSelectionPUD05 Property

Pull-Up/Pull-Down Selection: PUD0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD05 { get; set; }
Public Property PullUpPullDownSelectionPUD05 As Pcal9539aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD05 {
    Pcal9539aTypePullUpPullDownSelection get ();
    void set (Pcal9539aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD05 : Pcal9539aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownSelection
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownSelectionPUD06 Property

IRD

Pcal9539aPullUpPullDownSelectionPUD06 Property

Pull-Up/Pull-Down Selection: PUD0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD06 { get; set; }
Public Property PullUpPullDownSelectionPUD06 As Pcal9539aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD06 {
    Pcal9539aTypePullUpPullDownSelection get ();
    void set (Pcal9539aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD06 : Pcal9539aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownSelection
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownSelectionPUD07 Property

IRD

Pcal9539aPullUpPullDownSelectionPUD07 Property

Pull-Up/Pull-Down Selection: PUD0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD07 { get; set; }
Public Property PullUpPullDownSelectionPUD07 As Pcal9539aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD07 {
    Pcal9539aTypePullUpPullDownSelection get ();
    void set (Pcal9539aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD07 : Pcal9539aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownSelection
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownSelectionPUD10 Property

IRD

Pcal9539aPullUpPullDownSelectionPUD10 Property

Pull-Up/Pull-Down Selection: PUD1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD10 { get; set; }
Public Property PullUpPullDownSelectionPUD10 As Pcal9539aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD10 {
    Pcal9539aTypePullUpPullDownSelection get ();
    void set (Pcal9539aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD10 : Pcal9539aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownSelection
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownSelectionPUD11 Property

IRD

Pcal9539aPullUpPullDownSelectionPUD11 Property

Pull-Up/Pull-Down Selection: PUD1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD11 { get; set; }
Public Property PullUpPullDownSelectionPUD11 As Pcal9539aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD11 {
    Pcal9539aTypePullUpPullDownSelection get ();
    void set (Pcal9539aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD11 : Pcal9539aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownSelection
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownSelectionPUD12 Property

IRD

Pcal9539aPullUpPullDownSelectionPUD12 Property

Pull-Up/Pull-Down Selection: PUD1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD12 { get; set; }
Public Property PullUpPullDownSelectionPUD12 As Pcal9539aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD12 {
    Pcal9539aTypePullUpPullDownSelection get ();
    void set (Pcal9539aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD12 : Pcal9539aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownSelection
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownSelectionPUD13 Property

IRD

Pcal9539aPullUpPullDownSelectionPUD13 Property

Pull-Up/Pull-Down Selection: PUD1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD13 { get; set; }
Public Property PullUpPullDownSelectionPUD13 As Pcal9539aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD13 {
    Pcal9539aTypePullUpPullDownSelection get ();
    void set (Pcal9539aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD13 : Pcal9539aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownSelection
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownSelectionPUD14 Property

IRD

Pcal9539aPullUpPullDownSelectionPUD14 Property

Pull-Up/Pull-Down Selection: PUD1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD14 { get; set; }
Public Property PullUpPullDownSelectionPUD14 As Pcal9539aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD14 {
    Pcal9539aTypePullUpPullDownSelection get ();
    void set (Pcal9539aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD14 : Pcal9539aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownSelection
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownSelectionPUD15 Property

IRD

Pcal9539aPullUpPullDownSelectionPUD15 Property

Pull-Up/Pull-Down Selection: PUD1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD15 { get; set; }
Public Property PullUpPullDownSelectionPUD15 As Pcal9539aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD15 {
    Pcal9539aTypePullUpPullDownSelection get ();
    void set (Pcal9539aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD15 : Pcal9539aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownSelection
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownSelectionPUD16 Property

IRD

Pcal9539aPullUpPullDownSelectionPUD16 Property

Pull-Up/Pull-Down Selection: PUD1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD16 { get; set; }
Public Property PullUpPullDownSelectionPUD16 As Pcal9539aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD16 {
    Pcal9539aTypePullUpPullDownSelection get ();
    void set (Pcal9539aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD16 : Pcal9539aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownSelection
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.PullUpPullDownSelectionPUD17 Property

IRD

Pcal9539aPullUpPullDownSelectionPUD17 Property

Pull-Up/Pull-Down Selection: PUD1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD17 { get; set; }
Public Property PullUpPullDownSelectionPUD17 As Pcal9539aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9539aTypePullUpPullDownSelection PullUpPullDownSelectionPUD17 {
    Pcal9539aTypePullUpPullDownSelection get ();
    void set (Pcal9539aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD17 : Pcal9539aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9539aTypePullUpPullDownSelection
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a Methods

The Pcal9539a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.Flush Method

IRD

Pcal9539aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcal9539a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9539a.TypeConfiguration Enumeration

IRD

Pcal9539aTypeConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Output | 0 | Output
Input | 1 | Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9539a.TypeInputLatch Enumeration

IRD

Pcal9539aTypeInputLatch Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInputLatch
Public Enumeration TypeInputLatch
public enum class TypeInputLatch
type TypeInputLatch
Members
Member name | Value | Description
NotLatched | 0 | Not Latched
Latched | 1 | Latched
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9539a.TypeInterruptMask Enumeration

IRD

Pcal9539aTypeInterruptMask Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptMask
Public Enumeration TypeInterruptMask
public enum class TypeInterruptMask
type TypeInterruptMask
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9539a.TypeInterruptStatus Enumeration

IRD

Pcal9539aTypeInterruptStatus Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatus
Public Enumeration TypeInterruptStatus
public enum class TypeInterruptStatus
type TypeInterruptStatus
Members
Member name | Value | Description
NotSource | 0 | Not Source
Source | 1 | Source
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9539a.TypeOutputDriveStrength Enumeration

IRD

Pcal9539aTypeOutputDriveStrength Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputDriveStrength
Public Enumeration TypeOutputDriveStrength
public enum class TypeOutputDriveStrength
type TypeOutputDriveStrength
Members
Member name | Value | Description
Value_025x | 0 | 0.25x
Value_05x | 1 | 0.5x
Value_075x | 2 | 0.75x
Value_10x | 3 | 1.0x
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9539a.TypeOutputPortConfiguration Enumeration

IRD

Pcal9539aTypeOutputPortConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputPortConfiguration
Public Enumeration TypeOutputPortConfiguration
public enum class TypeOutputPortConfiguration
type TypeOutputPortConfiguration
Members
Member name | Value | Description
PushPull | 0 | Push-Pull
OpenDrain | 1 | Open-Drain
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9539a.TypePolarityInversion Enumeration

IRD

Pcal9539aTypePolarityInversion Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarityInversion
Public Enumeration TypePolarityInversion
public enum class TypePolarityInversion
type TypePolarityInversion
Members
Member name | Value | Description
NotInverted | 0 | Not Inverted
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9539a.TypePullUpPullDownEnable Enumeration

IRD

Pcal9539aTypePullUpPullDownEnable Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePullUpPullDownEnable
Public Enumeration TypePullUpPullDownEnable
public enum class TypePullUpPullDownEnable
type TypePullUpPullDownEnable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9539a.TypePullUpPullDownSelection Enumeration

IRD

Pcal9539aTypePullUpPullDownSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePullUpPullDownSelection
Public Enumeration TypePullUpPullDownSelection
public enum class TypePullUpPullDownSelection
type TypePullUpPullDownSelection
Members
Member name | Value | Description
Value_100KΩPullDown | 0 | 100 kΩ Pull-Down
Value_100KΩPullUp | 1 | 100 kΩ Pull-Up
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9555a Class

NXP Semiconductors: PCAL 9555A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPcal9555a

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcal9555a
Public Class Pcal9555a
public ref class Pcal9555a
type Pcal9555a =  class end

The Pcal9555a type exposes the following members.

Constructors
 | Name | Description
Public method | Pcal9555a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration: C0.0
Public property | ConfigurationC01 | Configuration: C0.1
Public property | ConfigurationC02 | Configuration: C0.2
Public property | ConfigurationC03 | Configuration: C0.3
Public property | ConfigurationC04 | Configuration: C0.4
Public property | ConfigurationC05 | Configuration: C0.5
Public property | ConfigurationC06 | Configuration: C0.6
Public property | ConfigurationC07 | Configuration: C0.7
Public property | ConfigurationC10 | Configuration: C1.0
Public property | ConfigurationC11 | Configuration: C1.1
Public property | ConfigurationC12 | Configuration: C1.2
Public property | ConfigurationC13 | Configuration: C1.3
Public property | ConfigurationC14 | Configuration: C1.4
Public property | ConfigurationC15 | Configuration: C1.5
Public property | ConfigurationC16 | Configuration: C1.6
Public property | ConfigurationC17 | Configuration: C1.7
Public property | InputLatchL00 | Input Latch: L0.0
Public property | InputLatchL01 | Input Latch: L0.1
Public property | InputLatchL02 | Input Latch: L0.2
Public property | InputLatchL03 | Input Latch: L0.3
Public property | InputLatchL04 | Input Latch: L0.4
Public property | InputLatchL05 | Input Latch: L0.5
Public property | InputLatchL06 | Input Latch: L0.6
Public property | InputLatchL07 | Input Latch: L0.7
Public property | InputLatchL10 | Input Latch: L1.0
Public property | InputLatchL11 | Input Latch: L1.1
Public property | InputLatchL12 | Input Latch: L1.2
Public property | InputLatchL13 | Input Latch: L1.3
Public property | InputLatchL14 | Input Latch: L1.4
Public property | InputLatchL15 | Input Latch: L1.5
Public property | InputLatchL16 | Input Latch: L1.6
Public property | InputLatchL17 | Input Latch: L1.7
Public property | InputPortI00 | Input Port: I0.0
Public property | InputPortI01 | Input Port: I0.1
Public property | InputPortI02 | Input Port: I0.2
Public property | InputPortI03 | Input Port: I0.3
Public property | InputPortI04 | Input Port: I0.4
Public property | InputPortI05 | Input Port: I0.5
Public property | InputPortI06 | Input Port: I0.6
Public property | InputPortI07 | Input Port: I0.7
Public property | InputPortI10 | Input Port: I1.0
Public property | InputPortI11 | Input Port: I1.1
Public property | InputPortI12 | Input Port: I1.2
Public property | InputPortI13 | Input Port: I1.3
Public property | InputPortI14 | Input Port: I1.4
Public property | InputPortI15 | Input Port: I1.5
Public property | InputPortI16 | Input Port: I1.6
Public property | InputPortI17 | Input Port: I1.7
Public property | InterruptMaskM00 | Interrupt Mask: M0.0
Public property | InterruptMaskM01 | Interrupt Mask: M0.1
Public property | InterruptMaskM02 | Interrupt Mask: M0.2
Public property | InterruptMaskM03 | Interrupt Mask: M0.3
Public property | InterruptMaskM04 | Interrupt Mask: M0.4
Public property | InterruptMaskM05 | Interrupt Mask: M0.5
Public property | InterruptMaskM06 | Interrupt Mask: M0.6
Public property | InterruptMaskM07 | Interrupt Mask: M0.7
Public property | InterruptMaskM10 | Interrupt Mask: M1.0
Public property | InterruptMaskM11 | Interrupt Mask: M1.1
Public property | InterruptMaskM12 | Interrupt Mask: M1.2
Public property | InterruptMaskM13 | Interrupt Mask: M1.3
Public property | InterruptMaskM14 | Interrupt Mask: M1.4
Public property | InterruptMaskM15 | Interrupt Mask: M1.5
Public property | InterruptMaskM16 | Interrupt Mask: M1.6
Public property | InterruptMaskM17 | Interrupt Mask: M1.7
Public property | InterruptStatusS00 | Interrupt Status: S0.0
Public property | InterruptStatusS01 | Interrupt Status: S0.1
Public property | InterruptStatusS02 | Interrupt Status: S0.2
Public property | InterruptStatusS03 | Interrupt Status: S0.3
Public property | InterruptStatusS04 | Interrupt Status: S0.4
Public property | InterruptStatusS05 | Interrupt Status: S0.5
Public property | InterruptStatusS06 | Interrupt Status: S0.6
Public property | InterruptStatusS07 | Interrupt Status: S0.7
Public property | InterruptStatusS10 | Interrupt Status: S1.0
Public property | InterruptStatusS11 | Interrupt Status: S1.1
Public property | InterruptStatusS12 | Interrupt Status: S1.2
Public property | InterruptStatusS13 | Interrupt Status: S1.3
Public property | InterruptStatusS14 | Interrupt Status: S1.4
Public property | InterruptStatusS15 | Interrupt Status: S1.5
Public property | InterruptStatusS16 | Interrupt Status: S1.6
Public property | InterruptStatusS17 | Interrupt Status: S1.7
Public property | OutputDriveStrengthCC00 | Output Drive Strength: CC0.0
Public property | OutputDriveStrengthCC01 | Output Drive Strength: CC0.1
Public property | OutputDriveStrengthCC02 | Output Drive Strength: CC0.2
Public property | OutputDriveStrengthCC03 | Output Drive Strength: CC0.3
Public property | OutputDriveStrengthCC04 | Output Drive Strength: CC0.4
Public property | OutputDriveStrengthCC05 | Output Drive Strength: CC0.5
Public property | OutputDriveStrengthCC06 | Output Drive Strength: CC0.6
Public property | OutputDriveStrengthCC07 | Output Drive Strength: CC0.7
Public property | OutputDriveStrengthCC10 | Output Drive Strength: CC1.0
Public property | OutputDriveStrengthCC11 | Output Drive Strength: CC1.1
Public property | OutputDriveStrengthCC12 | Output Drive Strength: CC1.2
Public property | OutputDriveStrengthCC13 | Output Drive Strength: CC1.3
Public property | OutputDriveStrengthCC14 | Output Drive Strength: CC1.4
Public property | OutputDriveStrengthCC15 | Output Drive Strength: CC1.5
Public property | OutputDriveStrengthCC16 | Output Drive Strength: CC1.6
Public property | OutputDriveStrengthCC17 | Output Drive Strength: CC1.7
Public property | OutputPortConfigurationODEN0 | Output Port Configuration: ODEN0
Public property | OutputPortConfigurationODEN1 | Output Port Configuration: ODEN1
Public property | OutputPortO00 | Output Port: O0.0
Public property | OutputPortO01 | Output Port: O0.1
Public property | OutputPortO02 | Output Port: O0.2
Public property | OutputPortO03 | Output Port: O0.3
Public property | OutputPortO04 | Output Port: O0.4
Public property | OutputPortO05 | Output Port: O0.5
Public property | OutputPortO06 | Output Port: O0.6
Public property | OutputPortO07 | Output Port: O0.7
Public property | OutputPortO10 | Output Port: O1.0
Public property | OutputPortO11 | Output Port: O1.1
Public property | OutputPortO12 | Output Port: O1.2
Public property | OutputPortO13 | Output Port: O1.3
Public property | OutputPortO14 | Output Port: O1.4
Public property | OutputPortO15 | Output Port: O1.5
Public property | OutputPortO16 | Output Port: O1.6
Public property | OutputPortO17 | Output Port: O1.7
Public property | PolarityInversionN00 | Polarity Inversion: N0.0
Public property | PolarityInversionN01 | Polarity Inversion: N0.1
Public property | PolarityInversionN02 | Polarity Inversion: N0.2
Public property | PolarityInversionN03 | Polarity Inversion: N0.3
Public property | PolarityInversionN04 | Polarity Inversion: N0.4
Public property | PolarityInversionN05 | Polarity Inversion: N0.5
Public property | PolarityInversionN06 | Polarity Inversion: N0.6
Public property | PolarityInversionN07 | Polarity Inversion: N0.7
Public property | PolarityInversionN10 | Polarity Inversion: N1.0
Public property | PolarityInversionN11 | Polarity Inversion: N1.1
Public property | PolarityInversionN12 | Polarity Inversion: N1.2
Public property | PolarityInversionN13 | Polarity Inversion: N1.3
Public property | PolarityInversionN14 | Polarity Inversion: N1.4
Public property | PolarityInversionN15 | Polarity Inversion: N1.5
Public property | PolarityInversionN16 | Polarity Inversion: N1.6
Public property | PolarityInversionN17 | Polarity Inversion: N1.7
Public property | PullUpPullDownEnablePE00 | Pull-Up/Pull-Down Enable: PE0.0
Public property | PullUpPullDownEnablePE01 | Pull-Up/Pull-Down Enable: PE0.1
Public property | PullUpPullDownEnablePE02 | Pull-Up/Pull-Down Enable: PE0.2
Public property | PullUpPullDownEnablePE03 | Pull-Up/Pull-Down Enable: PE0.3
Public property | PullUpPullDownEnablePE04 | Pull-Up/Pull-Down Enable: PE0.4
Public property | PullUpPullDownEnablePE05 | Pull-Up/Pull-Down Enable: PE0.5
Public property | PullUpPullDownEnablePE06 | Pull-Up/Pull-Down Enable: PE0.6
Public property | PullUpPullDownEnablePE07 | Pull-Up/Pull-Down Enable: PE0.7
Public property | PullUpPullDownEnablePE10 | Pull-Up/Pull-Down Enable: PE1.0
Public property | PullUpPullDownEnablePE11 | Pull-Up/Pull-Down Enable: PE1.1
Public property | PullUpPullDownEnablePE12 | Pull-Up/Pull-Down Enable: PE1.2
Public property | PullUpPullDownEnablePE13 | Pull-Up/Pull-Down Enable: PE1.3
Public property | PullUpPullDownEnablePE14 | Pull-Up/Pull-Down Enable: PE1.4
Public property | PullUpPullDownEnablePE15 | Pull-Up/Pull-Down Enable: PE1.5
Public property | PullUpPullDownEnablePE16 | Pull-Up/Pull-Down Enable: PE1.6
Public property | PullUpPullDownEnablePE17 | Pull-Up/Pull-Down Enable: PE1.7
Public property | PullUpPullDownSelectionPUD00 | Pull-Up/Pull-Down Selection: PUD0.0
Public property | PullUpPullDownSelectionPUD01 | Pull-Up/Pull-Down Selection: PUD0.1
Public property | PullUpPullDownSelectionPUD02 | Pull-Up/Pull-Down Selection: PUD0.2
Public property | PullUpPullDownSelectionPUD03 | Pull-Up/Pull-Down Selection: PUD0.3
Public property | PullUpPullDownSelectionPUD04 | Pull-Up/Pull-Down Selection: PUD0.4
Public property | PullUpPullDownSelectionPUD05 | Pull-Up/Pull-Down Selection: PUD0.5
Public property | PullUpPullDownSelectionPUD06 | Pull-Up/Pull-Down Selection: PUD0.6
Public property | PullUpPullDownSelectionPUD07 | Pull-Up/Pull-Down Selection: PUD0.7
Public property | PullUpPullDownSelectionPUD10 | Pull-Up/Pull-Down Selection: PUD1.0
Public property | PullUpPullDownSelectionPUD11 | Pull-Up/Pull-Down Selection: PUD1.1
Public property | PullUpPullDownSelectionPUD12 | Pull-Up/Pull-Down Selection: PUD1.2
Public property | PullUpPullDownSelectionPUD13 | Pull-Up/Pull-Down Selection: PUD1.3
Public property | PullUpPullDownSelectionPUD14 | Pull-Up/Pull-Down Selection: PUD1.4
Public property | PullUpPullDownSelectionPUD15 | Pull-Up/Pull-Down Selection: PUD1.5
Public property | PullUpPullDownSelectionPUD16 | Pull-Up/Pull-Down Selection: PUD1.6
Public property | PullUpPullDownSelectionPUD17 | Pull-Up/Pull-Down Selection: PUD1.7
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Voltage 16-Bit I2C-Bus GPIO With Agile I/O, Interrupt And Weak Pull-Up
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9555a Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcal9555a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcal9555a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a Properties

The Pcal9555a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration: C0.0
Public property | ConfigurationC01 | Configuration: C0.1
Public property | ConfigurationC02 | Configuration: C0.2
Public property | ConfigurationC03 | Configuration: C0.3
Public property | ConfigurationC04 | Configuration: C0.4
Public property | ConfigurationC05 | Configuration: C0.5
Public property | ConfigurationC06 | Configuration: C0.6
Public property | ConfigurationC07 | Configuration: C0.7
Public property | ConfigurationC10 | Configuration: C1.0
Public property | ConfigurationC11 | Configuration: C1.1
Public property | ConfigurationC12 | Configuration: C1.2
Public property | ConfigurationC13 | Configuration: C1.3
Public property | ConfigurationC14 | Configuration: C1.4
Public property | ConfigurationC15 | Configuration: C1.5
Public property | ConfigurationC16 | Configuration: C1.6
Public property | ConfigurationC17 | Configuration: C1.7
Public property | InputLatchL00 | Input Latch: L0.0
Public property | InputLatchL01 | Input Latch: L0.1
Public property | InputLatchL02 | Input Latch: L0.2
Public property | InputLatchL03 | Input Latch: L0.3
Public property | InputLatchL04 | Input Latch: L0.4
Public property | InputLatchL05 | Input Latch: L0.5
Public property | InputLatchL06 | Input Latch: L0.6
Public property | InputLatchL07 | Input Latch: L0.7
Public property | InputLatchL10 | Input Latch: L1.0
Public property | InputLatchL11 | Input Latch: L1.1
Public property | InputLatchL12 | Input Latch: L1.2
Public property | InputLatchL13 | Input Latch: L1.3
Public property | InputLatchL14 | Input Latch: L1.4
Public property | InputLatchL15 | Input Latch: L1.5
Public property | InputLatchL16 | Input Latch: L1.6
Public property | InputLatchL17 | Input Latch: L1.7
Public property | InputPortI00 | Input Port: I0.0
Public property | InputPortI01 | Input Port: I0.1
Public property | InputPortI02 | Input Port: I0.2
Public property | InputPortI03 | Input Port: I0.3
Public property | InputPortI04 | Input Port: I0.4
Public property | InputPortI05 | Input Port: I0.5
Public property | InputPortI06 | Input Port: I0.6
Public property | InputPortI07 | Input Port: I0.7
Public property | InputPortI10 | Input Port: I1.0
Public property | InputPortI11 | Input Port: I1.1
Public property | InputPortI12 | Input Port: I1.2
Public property | InputPortI13 | Input Port: I1.3
Public property | InputPortI14 | Input Port: I1.4
Public property | InputPortI15 | Input Port: I1.5
Public property | InputPortI16 | Input Port: I1.6
Public property | InputPortI17 | Input Port: I1.7
Public property | InterruptMaskM00 | Interrupt Mask: M0.0
Public property | InterruptMaskM01 | Interrupt Mask: M0.1
Public property | InterruptMaskM02 | Interrupt Mask: M0.2
Public property | InterruptMaskM03 | Interrupt Mask: M0.3
Public property | InterruptMaskM04 | Interrupt Mask: M0.4
Public property | InterruptMaskM05 | Interrupt Mask: M0.5
Public property | InterruptMaskM06 | Interrupt Mask: M0.6
Public property | InterruptMaskM07 | Interrupt Mask: M0.7
Public property | InterruptMaskM10 | Interrupt Mask: M1.0
Public property | InterruptMaskM11 | Interrupt Mask: M1.1
Public property | InterruptMaskM12 | Interrupt Mask: M1.2
Public property | InterruptMaskM13 | Interrupt Mask: M1.3
Public property | InterruptMaskM14 | Interrupt Mask: M1.4
Public property | InterruptMaskM15 | Interrupt Mask: M1.5
Public property | InterruptMaskM16 | Interrupt Mask: M1.6
Public property | InterruptMaskM17 | Interrupt Mask: M1.7
Public property | InterruptStatusS00 | Interrupt Status: S0.0
Public property | InterruptStatusS01 | Interrupt Status: S0.1
Public property | InterruptStatusS02 | Interrupt Status: S0.2
Public property | InterruptStatusS03 | Interrupt Status: S0.3
Public property | InterruptStatusS04 | Interrupt Status: S0.4
Public property | InterruptStatusS05 | Interrupt Status: S0.5
Public property | InterruptStatusS06 | Interrupt Status: S0.6
Public property | InterruptStatusS07 | Interrupt Status: S0.7
Public property | InterruptStatusS10 | Interrupt Status: S1.0
Public property | InterruptStatusS11 | Interrupt Status: S1.1
Public property | InterruptStatusS12 | Interrupt Status: S1.2
Public property | InterruptStatusS13 | Interrupt Status: S1.3
Public property | InterruptStatusS14 | Interrupt Status: S1.4
Public property | InterruptStatusS15 | Interrupt Status: S1.5
Public property | InterruptStatusS16 | Interrupt Status: S1.6
Public property | InterruptStatusS17 | Interrupt Status: S1.7
Public property | OutputDriveStrengthCC00 | Output Drive Strength: CC0.0
Public property | OutputDriveStrengthCC01 | Output Drive Strength: CC0.1
Public property | OutputDriveStrengthCC02 | Output Drive Strength: CC0.2
Public property | OutputDriveStrengthCC03 | Output Drive Strength: CC0.3
Public property | OutputDriveStrengthCC04 | Output Drive Strength: CC0.4
Public property | OutputDriveStrengthCC05 | Output Drive Strength: CC0.5
Public property | OutputDriveStrengthCC06 | Output Drive Strength: CC0.6
Public property | OutputDriveStrengthCC07 | Output Drive Strength: CC0.7
Public property | OutputDriveStrengthCC10 | Output Drive Strength: CC1.0
Public property | OutputDriveStrengthCC11 | Output Drive Strength: CC1.1
Public property | OutputDriveStrengthCC12 | Output Drive Strength: CC1.2
Public property | OutputDriveStrengthCC13 | Output Drive Strength: CC1.3
Public property | OutputDriveStrengthCC14 | Output Drive Strength: CC1.4
Public property | OutputDriveStrengthCC15 | Output Drive Strength: CC1.5
Public property | OutputDriveStrengthCC16 | Output Drive Strength: CC1.6
Public property | OutputDriveStrengthCC17 | Output Drive Strength: CC1.7
Public property | OutputPortConfigurationODEN0 | Output Port Configuration: ODEN0
Public property | OutputPortConfigurationODEN1 | Output Port Configuration: ODEN1
Public property | OutputPortO00 | Output Port: O0.0
Public property | OutputPortO01 | Output Port: O0.1
Public property | OutputPortO02 | Output Port: O0.2
Public property | OutputPortO03 | Output Port: O0.3
Public property | OutputPortO04 | Output Port: O0.4
Public property | OutputPortO05 | Output Port: O0.5
Public property | OutputPortO06 | Output Port: O0.6
Public property | OutputPortO07 | Output Port: O0.7
Public property | OutputPortO10 | Output Port: O1.0
Public property | OutputPortO11 | Output Port: O1.1
Public property | OutputPortO12 | Output Port: O1.2
Public property | OutputPortO13 | Output Port: O1.3
Public property | OutputPortO14 | Output Port: O1.4
Public property | OutputPortO15 | Output Port: O1.5
Public property | OutputPortO16 | Output Port: O1.6
Public property | OutputPortO17 | Output Port: O1.7
Public property | PolarityInversionN00 | Polarity Inversion: N0.0
Public property | PolarityInversionN01 | Polarity Inversion: N0.1
Public property | PolarityInversionN02 | Polarity Inversion: N0.2
Public property | PolarityInversionN03 | Polarity Inversion: N0.3
Public property | PolarityInversionN04 | Polarity Inversion: N0.4
Public property | PolarityInversionN05 | Polarity Inversion: N0.5
Public property | PolarityInversionN06 | Polarity Inversion: N0.6
Public property | PolarityInversionN07 | Polarity Inversion: N0.7
Public property | PolarityInversionN10 | Polarity Inversion: N1.0
Public property | PolarityInversionN11 | Polarity Inversion: N1.1
Public property | PolarityInversionN12 | Polarity Inversion: N1.2
Public property | PolarityInversionN13 | Polarity Inversion: N1.3
Public property | PolarityInversionN14 | Polarity Inversion: N1.4
Public property | PolarityInversionN15 | Polarity Inversion: N1.5
Public property | PolarityInversionN16 | Polarity Inversion: N1.6
Public property | PolarityInversionN17 | Polarity Inversion: N1.7
Public property | PullUpPullDownEnablePE00 | Pull-Up/Pull-Down Enable: PE0.0
Public property | PullUpPullDownEnablePE01 | Pull-Up/Pull-Down Enable: PE0.1
Public property | PullUpPullDownEnablePE02 | Pull-Up/Pull-Down Enable: PE0.2
Public property | PullUpPullDownEnablePE03 | Pull-Up/Pull-Down Enable: PE0.3
Public property | PullUpPullDownEnablePE04 | Pull-Up/Pull-Down Enable: PE0.4
Public property | PullUpPullDownEnablePE05 | Pull-Up/Pull-Down Enable: PE0.5
Public property | PullUpPullDownEnablePE06 | Pull-Up/Pull-Down Enable: PE0.6
Public property | PullUpPullDownEnablePE07 | Pull-Up/Pull-Down Enable: PE0.7
Public property | PullUpPullDownEnablePE10 | Pull-Up/Pull-Down Enable: PE1.0
Public property | PullUpPullDownEnablePE11 | Pull-Up/Pull-Down Enable: PE1.1
Public property | PullUpPullDownEnablePE12 | Pull-Up/Pull-Down Enable: PE1.2
Public property | PullUpPullDownEnablePE13 | Pull-Up/Pull-Down Enable: PE1.3
Public property | PullUpPullDownEnablePE14 | Pull-Up/Pull-Down Enable: PE1.4
Public property | PullUpPullDownEnablePE15 | Pull-Up/Pull-Down Enable: PE1.5
Public property | PullUpPullDownEnablePE16 | Pull-Up/Pull-Down Enable: PE1.6
Public property | PullUpPullDownEnablePE17 | Pull-Up/Pull-Down Enable: PE1.7
Public property | PullUpPullDownSelectionPUD00 | Pull-Up/Pull-Down Selection: PUD0.0
Public property | PullUpPullDownSelectionPUD01 | Pull-Up/Pull-Down Selection: PUD0.1
Public property | PullUpPullDownSelectionPUD02 | Pull-Up/Pull-Down Selection: PUD0.2
Public property | PullUpPullDownSelectionPUD03 | Pull-Up/Pull-Down Selection: PUD0.3
Public property | PullUpPullDownSelectionPUD04 | Pull-Up/Pull-Down Selection: PUD0.4
Public property | PullUpPullDownSelectionPUD05 | Pull-Up/Pull-Down Selection: PUD0.5
Public property | PullUpPullDownSelectionPUD06 | Pull-Up/Pull-Down Selection: PUD0.6
Public property | PullUpPullDownSelectionPUD07 | Pull-Up/Pull-Down Selection: PUD0.7
Public property | PullUpPullDownSelectionPUD10 | Pull-Up/Pull-Down Selection: PUD1.0
Public property | PullUpPullDownSelectionPUD11 | Pull-Up/Pull-Down Selection: PUD1.1
Public property | PullUpPullDownSelectionPUD12 | Pull-Up/Pull-Down Selection: PUD1.2
Public property | PullUpPullDownSelectionPUD13 | Pull-Up/Pull-Down Selection: PUD1.3
Public property | PullUpPullDownSelectionPUD14 | Pull-Up/Pull-Down Selection: PUD1.4
Public property | PullUpPullDownSelectionPUD15 | Pull-Up/Pull-Down Selection: PUD1.5
Public property | PullUpPullDownSelectionPUD16 | Pull-Up/Pull-Down Selection: PUD1.6
Public property | PullUpPullDownSelectionPUD17 | Pull-Up/Pull-Down Selection: PUD1.7
Top
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.AutoFlush Property

IRD

Pcal9555aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.ConfigurationC00 Property

IRD

Pcal9555aConfigurationC00 Property

Configuration: C0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeConfiguration ConfigurationC00 { get; set; }
Public Property ConfigurationC00 As Pcal9555aTypeConfiguration
    Get
    Set
public:
property Pcal9555aTypeConfiguration ConfigurationC00 {
    Pcal9555aTypeConfiguration get ();
    void set (Pcal9555aTypeConfiguration value);
}
member ConfigurationC00 : Pcal9555aTypeConfiguration with get, set

Property Value

Type: Pcal9555aTypeConfiguration
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.ConfigurationC01 Property

IRD

Pcal9555aConfigurationC01 Property

Configuration: C0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeConfiguration ConfigurationC01 { get; set; }
Public Property ConfigurationC01 As Pcal9555aTypeConfiguration
    Get
    Set
public:
property Pcal9555aTypeConfiguration ConfigurationC01 {
    Pcal9555aTypeConfiguration get ();
    void set (Pcal9555aTypeConfiguration value);
}
member ConfigurationC01 : Pcal9555aTypeConfiguration with get, set

Property Value

Type: Pcal9555aTypeConfiguration
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.ConfigurationC02 Property

IRD

Pcal9555aConfigurationC02 Property

Configuration: C0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeConfiguration ConfigurationC02 { get; set; }
Public Property ConfigurationC02 As Pcal9555aTypeConfiguration
    Get
    Set
public:
property Pcal9555aTypeConfiguration ConfigurationC02 {
    Pcal9555aTypeConfiguration get ();
    void set (Pcal9555aTypeConfiguration value);
}
member ConfigurationC02 : Pcal9555aTypeConfiguration with get, set

Property Value

Type: Pcal9555aTypeConfiguration
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.ConfigurationC03 Property

IRD

Pcal9555aConfigurationC03 Property

Configuration: C0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeConfiguration ConfigurationC03 { get; set; }
Public Property ConfigurationC03 As Pcal9555aTypeConfiguration
    Get
    Set
public:
property Pcal9555aTypeConfiguration ConfigurationC03 {
    Pcal9555aTypeConfiguration get ();
    void set (Pcal9555aTypeConfiguration value);
}
member ConfigurationC03 : Pcal9555aTypeConfiguration with get, set

Property Value

Type: Pcal9555aTypeConfiguration
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.ConfigurationC04 Property

IRD

Pcal9555aConfigurationC04 Property

Configuration: C0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeConfiguration ConfigurationC04 { get; set; }
Public Property ConfigurationC04 As Pcal9555aTypeConfiguration
    Get
    Set
public:
property Pcal9555aTypeConfiguration ConfigurationC04 {
    Pcal9555aTypeConfiguration get ();
    void set (Pcal9555aTypeConfiguration value);
}
member ConfigurationC04 : Pcal9555aTypeConfiguration with get, set

Property Value

Type: Pcal9555aTypeConfiguration
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.ConfigurationC05 Property

IRD

Pcal9555aConfigurationC05 Property

Configuration: C0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeConfiguration ConfigurationC05 { get; set; }
Public Property ConfigurationC05 As Pcal9555aTypeConfiguration
    Get
    Set
public:
property Pcal9555aTypeConfiguration ConfigurationC05 {
    Pcal9555aTypeConfiguration get ();
    void set (Pcal9555aTypeConfiguration value);
}
member ConfigurationC05 : Pcal9555aTypeConfiguration with get, set

Property Value

Type: Pcal9555aTypeConfiguration
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.ConfigurationC06 Property

IRD

Pcal9555aConfigurationC06 Property

Configuration: C0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeConfiguration ConfigurationC06 { get; set; }
Public Property ConfigurationC06 As Pcal9555aTypeConfiguration
    Get
    Set
public:
property Pcal9555aTypeConfiguration ConfigurationC06 {
    Pcal9555aTypeConfiguration get ();
    void set (Pcal9555aTypeConfiguration value);
}
member ConfigurationC06 : Pcal9555aTypeConfiguration with get, set

Property Value

Type: Pcal9555aTypeConfiguration
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.ConfigurationC07 Property

IRD

Pcal9555aConfigurationC07 Property

Configuration: C0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeConfiguration ConfigurationC07 { get; set; }
Public Property ConfigurationC07 As Pcal9555aTypeConfiguration
    Get
    Set
public:
property Pcal9555aTypeConfiguration ConfigurationC07 {
    Pcal9555aTypeConfiguration get ();
    void set (Pcal9555aTypeConfiguration value);
}
member ConfigurationC07 : Pcal9555aTypeConfiguration with get, set

Property Value

Type: Pcal9555aTypeConfiguration
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.ConfigurationC10 Property

IRD

Pcal9555aConfigurationC10 Property

Configuration: C1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeConfiguration ConfigurationC10 { get; set; }
Public Property ConfigurationC10 As Pcal9555aTypeConfiguration
    Get
    Set
public:
property Pcal9555aTypeConfiguration ConfigurationC10 {
    Pcal9555aTypeConfiguration get ();
    void set (Pcal9555aTypeConfiguration value);
}
member ConfigurationC10 : Pcal9555aTypeConfiguration with get, set

Property Value

Type: Pcal9555aTypeConfiguration
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.ConfigurationC11 Property

IRD

Pcal9555aConfigurationC11 Property

Configuration: C1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeConfiguration ConfigurationC11 { get; set; }
Public Property ConfigurationC11 As Pcal9555aTypeConfiguration
    Get
    Set
public:
property Pcal9555aTypeConfiguration ConfigurationC11 {
    Pcal9555aTypeConfiguration get ();
    void set (Pcal9555aTypeConfiguration value);
}
member ConfigurationC11 : Pcal9555aTypeConfiguration with get, set

Property Value

Type: Pcal9555aTypeConfiguration
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.ConfigurationC12 Property

IRD

Pcal9555aConfigurationC12 Property

Configuration: C1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeConfiguration ConfigurationC12 { get; set; }
Public Property ConfigurationC12 As Pcal9555aTypeConfiguration
    Get
    Set
public:
property Pcal9555aTypeConfiguration ConfigurationC12 {
    Pcal9555aTypeConfiguration get ();
    void set (Pcal9555aTypeConfiguration value);
}
member ConfigurationC12 : Pcal9555aTypeConfiguration with get, set

Property Value

Type: Pcal9555aTypeConfiguration
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.ConfigurationC13 Property

IRD

Pcal9555aConfigurationC13 Property

Configuration: C1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeConfiguration ConfigurationC13 { get; set; }
Public Property ConfigurationC13 As Pcal9555aTypeConfiguration
    Get
    Set
public:
property Pcal9555aTypeConfiguration ConfigurationC13 {
    Pcal9555aTypeConfiguration get ();
    void set (Pcal9555aTypeConfiguration value);
}
member ConfigurationC13 : Pcal9555aTypeConfiguration with get, set

Property Value

Type: Pcal9555aTypeConfiguration
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.ConfigurationC14 Property

IRD

Pcal9555aConfigurationC14 Property

Configuration: C1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeConfiguration ConfigurationC14 { get; set; }
Public Property ConfigurationC14 As Pcal9555aTypeConfiguration
    Get
    Set
public:
property Pcal9555aTypeConfiguration ConfigurationC14 {
    Pcal9555aTypeConfiguration get ();
    void set (Pcal9555aTypeConfiguration value);
}
member ConfigurationC14 : Pcal9555aTypeConfiguration with get, set

Property Value

Type: Pcal9555aTypeConfiguration
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.ConfigurationC15 Property

IRD

Pcal9555aConfigurationC15 Property

Configuration: C1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeConfiguration ConfigurationC15 { get; set; }
Public Property ConfigurationC15 As Pcal9555aTypeConfiguration
    Get
    Set
public:
property Pcal9555aTypeConfiguration ConfigurationC15 {
    Pcal9555aTypeConfiguration get ();
    void set (Pcal9555aTypeConfiguration value);
}
member ConfigurationC15 : Pcal9555aTypeConfiguration with get, set

Property Value

Type: Pcal9555aTypeConfiguration
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.ConfigurationC16 Property

IRD

Pcal9555aConfigurationC16 Property

Configuration: C1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeConfiguration ConfigurationC16 { get; set; }
Public Property ConfigurationC16 As Pcal9555aTypeConfiguration
    Get
    Set
public:
property Pcal9555aTypeConfiguration ConfigurationC16 {
    Pcal9555aTypeConfiguration get ();
    void set (Pcal9555aTypeConfiguration value);
}
member ConfigurationC16 : Pcal9555aTypeConfiguration with get, set

Property Value

Type: Pcal9555aTypeConfiguration
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.ConfigurationC17 Property

IRD

Pcal9555aConfigurationC17 Property

Configuration: C1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeConfiguration ConfigurationC17 { get; set; }
Public Property ConfigurationC17 As Pcal9555aTypeConfiguration
    Get
    Set
public:
property Pcal9555aTypeConfiguration ConfigurationC17 {
    Pcal9555aTypeConfiguration get ();
    void set (Pcal9555aTypeConfiguration value);
}
member ConfigurationC17 : Pcal9555aTypeConfiguration with get, set

Property Value

Type: Pcal9555aTypeConfiguration
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputLatchL00 Property

IRD

Pcal9555aInputLatchL00 Property

Input Latch: L0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInputLatch InputLatchL00 { get; set; }
Public Property InputLatchL00 As Pcal9555aTypeInputLatch
    Get
    Set
public:
property Pcal9555aTypeInputLatch InputLatchL00 {
    Pcal9555aTypeInputLatch get ();
    void set (Pcal9555aTypeInputLatch value);
}
member InputLatchL00 : Pcal9555aTypeInputLatch with get, set

Property Value

Type: Pcal9555aTypeInputLatch
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputLatchL01 Property

IRD

Pcal9555aInputLatchL01 Property

Input Latch: L0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInputLatch InputLatchL01 { get; set; }
Public Property InputLatchL01 As Pcal9555aTypeInputLatch
    Get
    Set
public:
property Pcal9555aTypeInputLatch InputLatchL01 {
    Pcal9555aTypeInputLatch get ();
    void set (Pcal9555aTypeInputLatch value);
}
member InputLatchL01 : Pcal9555aTypeInputLatch with get, set

Property Value

Type: Pcal9555aTypeInputLatch
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputLatchL02 Property

IRD

Pcal9555aInputLatchL02 Property

Input Latch: L0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInputLatch InputLatchL02 { get; set; }
Public Property InputLatchL02 As Pcal9555aTypeInputLatch
    Get
    Set
public:
property Pcal9555aTypeInputLatch InputLatchL02 {
    Pcal9555aTypeInputLatch get ();
    void set (Pcal9555aTypeInputLatch value);
}
member InputLatchL02 : Pcal9555aTypeInputLatch with get, set

Property Value

Type: Pcal9555aTypeInputLatch
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputLatchL03 Property

IRD

Pcal9555aInputLatchL03 Property

Input Latch: L0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInputLatch InputLatchL03 { get; set; }
Public Property InputLatchL03 As Pcal9555aTypeInputLatch
    Get
    Set
public:
property Pcal9555aTypeInputLatch InputLatchL03 {
    Pcal9555aTypeInputLatch get ();
    void set (Pcal9555aTypeInputLatch value);
}
member InputLatchL03 : Pcal9555aTypeInputLatch with get, set

Property Value

Type: Pcal9555aTypeInputLatch
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputLatchL04 Property

IRD

Pcal9555aInputLatchL04 Property

Input Latch: L0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInputLatch InputLatchL04 { get; set; }
Public Property InputLatchL04 As Pcal9555aTypeInputLatch
    Get
    Set
public:
property Pcal9555aTypeInputLatch InputLatchL04 {
    Pcal9555aTypeInputLatch get ();
    void set (Pcal9555aTypeInputLatch value);
}
member InputLatchL04 : Pcal9555aTypeInputLatch with get, set

Property Value

Type: Pcal9555aTypeInputLatch
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputLatchL05 Property

IRD

Pcal9555aInputLatchL05 Property

Input Latch: L0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInputLatch InputLatchL05 { get; set; }
Public Property InputLatchL05 As Pcal9555aTypeInputLatch
    Get
    Set
public:
property Pcal9555aTypeInputLatch InputLatchL05 {
    Pcal9555aTypeInputLatch get ();
    void set (Pcal9555aTypeInputLatch value);
}
member InputLatchL05 : Pcal9555aTypeInputLatch with get, set

Property Value

Type: Pcal9555aTypeInputLatch
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputLatchL06 Property

IRD

Pcal9555aInputLatchL06 Property

Input Latch: L0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInputLatch InputLatchL06 { get; set; }
Public Property InputLatchL06 As Pcal9555aTypeInputLatch
    Get
    Set
public:
property Pcal9555aTypeInputLatch InputLatchL06 {
    Pcal9555aTypeInputLatch get ();
    void set (Pcal9555aTypeInputLatch value);
}
member InputLatchL06 : Pcal9555aTypeInputLatch with get, set

Property Value

Type: Pcal9555aTypeInputLatch
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputLatchL07 Property

IRD

Pcal9555aInputLatchL07 Property

Input Latch: L0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInputLatch InputLatchL07 { get; set; }
Public Property InputLatchL07 As Pcal9555aTypeInputLatch
    Get
    Set
public:
property Pcal9555aTypeInputLatch InputLatchL07 {
    Pcal9555aTypeInputLatch get ();
    void set (Pcal9555aTypeInputLatch value);
}
member InputLatchL07 : Pcal9555aTypeInputLatch with get, set

Property Value

Type: Pcal9555aTypeInputLatch
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputLatchL10 Property

IRD

Pcal9555aInputLatchL10 Property

Input Latch: L1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInputLatch InputLatchL10 { get; set; }
Public Property InputLatchL10 As Pcal9555aTypeInputLatch
    Get
    Set
public:
property Pcal9555aTypeInputLatch InputLatchL10 {
    Pcal9555aTypeInputLatch get ();
    void set (Pcal9555aTypeInputLatch value);
}
member InputLatchL10 : Pcal9555aTypeInputLatch with get, set

Property Value

Type: Pcal9555aTypeInputLatch
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputLatchL11 Property

IRD

Pcal9555aInputLatchL11 Property

Input Latch: L1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInputLatch InputLatchL11 { get; set; }
Public Property InputLatchL11 As Pcal9555aTypeInputLatch
    Get
    Set
public:
property Pcal9555aTypeInputLatch InputLatchL11 {
    Pcal9555aTypeInputLatch get ();
    void set (Pcal9555aTypeInputLatch value);
}
member InputLatchL11 : Pcal9555aTypeInputLatch with get, set

Property Value

Type: Pcal9555aTypeInputLatch
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputLatchL12 Property

IRD

Pcal9555aInputLatchL12 Property

Input Latch: L1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInputLatch InputLatchL12 { get; set; }
Public Property InputLatchL12 As Pcal9555aTypeInputLatch
    Get
    Set
public:
property Pcal9555aTypeInputLatch InputLatchL12 {
    Pcal9555aTypeInputLatch get ();
    void set (Pcal9555aTypeInputLatch value);
}
member InputLatchL12 : Pcal9555aTypeInputLatch with get, set

Property Value

Type: Pcal9555aTypeInputLatch
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputLatchL13 Property

IRD

Pcal9555aInputLatchL13 Property

Input Latch: L1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInputLatch InputLatchL13 { get; set; }
Public Property InputLatchL13 As Pcal9555aTypeInputLatch
    Get
    Set
public:
property Pcal9555aTypeInputLatch InputLatchL13 {
    Pcal9555aTypeInputLatch get ();
    void set (Pcal9555aTypeInputLatch value);
}
member InputLatchL13 : Pcal9555aTypeInputLatch with get, set

Property Value

Type: Pcal9555aTypeInputLatch
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputLatchL14 Property

IRD

Pcal9555aInputLatchL14 Property

Input Latch: L1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInputLatch InputLatchL14 { get; set; }
Public Property InputLatchL14 As Pcal9555aTypeInputLatch
    Get
    Set
public:
property Pcal9555aTypeInputLatch InputLatchL14 {
    Pcal9555aTypeInputLatch get ();
    void set (Pcal9555aTypeInputLatch value);
}
member InputLatchL14 : Pcal9555aTypeInputLatch with get, set

Property Value

Type: Pcal9555aTypeInputLatch
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputLatchL15 Property

IRD

Pcal9555aInputLatchL15 Property

Input Latch: L1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInputLatch InputLatchL15 { get; set; }
Public Property InputLatchL15 As Pcal9555aTypeInputLatch
    Get
    Set
public:
property Pcal9555aTypeInputLatch InputLatchL15 {
    Pcal9555aTypeInputLatch get ();
    void set (Pcal9555aTypeInputLatch value);
}
member InputLatchL15 : Pcal9555aTypeInputLatch with get, set

Property Value

Type: Pcal9555aTypeInputLatch
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputLatchL16 Property

IRD

Pcal9555aInputLatchL16 Property

Input Latch: L1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInputLatch InputLatchL16 { get; set; }
Public Property InputLatchL16 As Pcal9555aTypeInputLatch
    Get
    Set
public:
property Pcal9555aTypeInputLatch InputLatchL16 {
    Pcal9555aTypeInputLatch get ();
    void set (Pcal9555aTypeInputLatch value);
}
member InputLatchL16 : Pcal9555aTypeInputLatch with get, set

Property Value

Type: Pcal9555aTypeInputLatch
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputLatchL17 Property

IRD

Pcal9555aInputLatchL17 Property

Input Latch: L1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInputLatch InputLatchL17 { get; set; }
Public Property InputLatchL17 As Pcal9555aTypeInputLatch
    Get
    Set
public:
property Pcal9555aTypeInputLatch InputLatchL17 {
    Pcal9555aTypeInputLatch get ();
    void set (Pcal9555aTypeInputLatch value);
}
member InputLatchL17 : Pcal9555aTypeInputLatch with get, set

Property Value

Type: Pcal9555aTypeInputLatch
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputPortI00 Property

IRD

Pcal9555aInputPortI00 Property

Input Port: I0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI00 { get; }
Public ReadOnly Property InputPortI00 As Byte
    Get
public:
property unsigned char InputPortI00 {
    unsigned char get ();
}
member InputPortI00 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputPortI01 Property

IRD

Pcal9555aInputPortI01 Property

Input Port: I0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI01 { get; }
Public ReadOnly Property InputPortI01 As Byte
    Get
public:
property unsigned char InputPortI01 {
    unsigned char get ();
}
member InputPortI01 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputPortI02 Property

IRD

Pcal9555aInputPortI02 Property

Input Port: I0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI02 { get; }
Public ReadOnly Property InputPortI02 As Byte
    Get
public:
property unsigned char InputPortI02 {
    unsigned char get ();
}
member InputPortI02 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputPortI03 Property

IRD

Pcal9555aInputPortI03 Property

Input Port: I0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI03 { get; }
Public ReadOnly Property InputPortI03 As Byte
    Get
public:
property unsigned char InputPortI03 {
    unsigned char get ();
}
member InputPortI03 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputPortI04 Property

IRD

Pcal9555aInputPortI04 Property

Input Port: I0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI04 { get; }
Public ReadOnly Property InputPortI04 As Byte
    Get
public:
property unsigned char InputPortI04 {
    unsigned char get ();
}
member InputPortI04 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputPortI05 Property

IRD

Pcal9555aInputPortI05 Property

Input Port: I0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI05 { get; }
Public ReadOnly Property InputPortI05 As Byte
    Get
public:
property unsigned char InputPortI05 {
    unsigned char get ();
}
member InputPortI05 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputPortI06 Property

IRD

Pcal9555aInputPortI06 Property

Input Port: I0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI06 { get; }
Public ReadOnly Property InputPortI06 As Byte
    Get
public:
property unsigned char InputPortI06 {
    unsigned char get ();
}
member InputPortI06 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputPortI07 Property

IRD

Pcal9555aInputPortI07 Property

Input Port: I0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI07 { get; }
Public ReadOnly Property InputPortI07 As Byte
    Get
public:
property unsigned char InputPortI07 {
    unsigned char get ();
}
member InputPortI07 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputPortI10 Property

IRD

Pcal9555aInputPortI10 Property

Input Port: I1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI10 { get; }
Public ReadOnly Property InputPortI10 As Byte
    Get
public:
property unsigned char InputPortI10 {
    unsigned char get ();
}
member InputPortI10 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputPortI11 Property

IRD

Pcal9555aInputPortI11 Property

Input Port: I1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI11 { get; }
Public ReadOnly Property InputPortI11 As Byte
    Get
public:
property unsigned char InputPortI11 {
    unsigned char get ();
}
member InputPortI11 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputPortI12 Property

IRD

Pcal9555aInputPortI12 Property

Input Port: I1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI12 { get; }
Public ReadOnly Property InputPortI12 As Byte
    Get
public:
property unsigned char InputPortI12 {
    unsigned char get ();
}
member InputPortI12 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputPortI13 Property

IRD

Pcal9555aInputPortI13 Property

Input Port: I1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI13 { get; }
Public ReadOnly Property InputPortI13 As Byte
    Get
public:
property unsigned char InputPortI13 {
    unsigned char get ();
}
member InputPortI13 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputPortI14 Property

IRD

Pcal9555aInputPortI14 Property

Input Port: I1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI14 { get; }
Public ReadOnly Property InputPortI14 As Byte
    Get
public:
property unsigned char InputPortI14 {
    unsigned char get ();
}
member InputPortI14 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputPortI15 Property

IRD

Pcal9555aInputPortI15 Property

Input Port: I1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI15 { get; }
Public ReadOnly Property InputPortI15 As Byte
    Get
public:
property unsigned char InputPortI15 {
    unsigned char get ();
}
member InputPortI15 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputPortI16 Property

IRD

Pcal9555aInputPortI16 Property

Input Port: I1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI16 { get; }
Public ReadOnly Property InputPortI16 As Byte
    Get
public:
property unsigned char InputPortI16 {
    unsigned char get ();
}
member InputPortI16 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InputPortI17 Property

IRD

Pcal9555aInputPortI17 Property

Input Port: I1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte InputPortI17 { get; }
Public ReadOnly Property InputPortI17 As Byte
    Get
public:
property unsigned char InputPortI17 {
    unsigned char get ();
}
member InputPortI17 : byte with get

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptMaskM00 Property

IRD

Pcal9555aInterruptMaskM00 Property

Interrupt Mask: M0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptMask InterruptMaskM00 { get; set; }
Public Property InterruptMaskM00 As Pcal9555aTypeInterruptMask
    Get
    Set
public:
property Pcal9555aTypeInterruptMask InterruptMaskM00 {
    Pcal9555aTypeInterruptMask get ();
    void set (Pcal9555aTypeInterruptMask value);
}
member InterruptMaskM00 : Pcal9555aTypeInterruptMask with get, set

Property Value

Type: Pcal9555aTypeInterruptMask
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptMaskM01 Property

IRD

Pcal9555aInterruptMaskM01 Property

Interrupt Mask: M0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptMask InterruptMaskM01 { get; set; }
Public Property InterruptMaskM01 As Pcal9555aTypeInterruptMask
    Get
    Set
public:
property Pcal9555aTypeInterruptMask InterruptMaskM01 {
    Pcal9555aTypeInterruptMask get ();
    void set (Pcal9555aTypeInterruptMask value);
}
member InterruptMaskM01 : Pcal9555aTypeInterruptMask with get, set

Property Value

Type: Pcal9555aTypeInterruptMask
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptMaskM02 Property

IRD

Pcal9555aInterruptMaskM02 Property

Interrupt Mask: M0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptMask InterruptMaskM02 { get; set; }
Public Property InterruptMaskM02 As Pcal9555aTypeInterruptMask
    Get
    Set
public:
property Pcal9555aTypeInterruptMask InterruptMaskM02 {
    Pcal9555aTypeInterruptMask get ();
    void set (Pcal9555aTypeInterruptMask value);
}
member InterruptMaskM02 : Pcal9555aTypeInterruptMask with get, set

Property Value

Type: Pcal9555aTypeInterruptMask
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptMaskM03 Property

IRD

Pcal9555aInterruptMaskM03 Property

Interrupt Mask: M0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptMask InterruptMaskM03 { get; set; }
Public Property InterruptMaskM03 As Pcal9555aTypeInterruptMask
    Get
    Set
public:
property Pcal9555aTypeInterruptMask InterruptMaskM03 {
    Pcal9555aTypeInterruptMask get ();
    void set (Pcal9555aTypeInterruptMask value);
}
member InterruptMaskM03 : Pcal9555aTypeInterruptMask with get, set

Property Value

Type: Pcal9555aTypeInterruptMask
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptMaskM04 Property

IRD

Pcal9555aInterruptMaskM04 Property

Interrupt Mask: M0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptMask InterruptMaskM04 { get; set; }
Public Property InterruptMaskM04 As Pcal9555aTypeInterruptMask
    Get
    Set
public:
property Pcal9555aTypeInterruptMask InterruptMaskM04 {
    Pcal9555aTypeInterruptMask get ();
    void set (Pcal9555aTypeInterruptMask value);
}
member InterruptMaskM04 : Pcal9555aTypeInterruptMask with get, set

Property Value

Type: Pcal9555aTypeInterruptMask
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptMaskM05 Property

IRD

Pcal9555aInterruptMaskM05 Property

Interrupt Mask: M0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptMask InterruptMaskM05 { get; set; }
Public Property InterruptMaskM05 As Pcal9555aTypeInterruptMask
    Get
    Set
public:
property Pcal9555aTypeInterruptMask InterruptMaskM05 {
    Pcal9555aTypeInterruptMask get ();
    void set (Pcal9555aTypeInterruptMask value);
}
member InterruptMaskM05 : Pcal9555aTypeInterruptMask with get, set

Property Value

Type: Pcal9555aTypeInterruptMask
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptMaskM06 Property

IRD

Pcal9555aInterruptMaskM06 Property

Interrupt Mask: M0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptMask InterruptMaskM06 { get; set; }
Public Property InterruptMaskM06 As Pcal9555aTypeInterruptMask
    Get
    Set
public:
property Pcal9555aTypeInterruptMask InterruptMaskM06 {
    Pcal9555aTypeInterruptMask get ();
    void set (Pcal9555aTypeInterruptMask value);
}
member InterruptMaskM06 : Pcal9555aTypeInterruptMask with get, set

Property Value

Type: Pcal9555aTypeInterruptMask
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptMaskM07 Property

IRD

Pcal9555aInterruptMaskM07 Property

Interrupt Mask: M0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptMask InterruptMaskM07 { get; set; }
Public Property InterruptMaskM07 As Pcal9555aTypeInterruptMask
    Get
    Set
public:
property Pcal9555aTypeInterruptMask InterruptMaskM07 {
    Pcal9555aTypeInterruptMask get ();
    void set (Pcal9555aTypeInterruptMask value);
}
member InterruptMaskM07 : Pcal9555aTypeInterruptMask with get, set

Property Value

Type: Pcal9555aTypeInterruptMask
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptMaskM10 Property

IRD

Pcal9555aInterruptMaskM10 Property

Interrupt Mask: M1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptMask InterruptMaskM10 { get; set; }
Public Property InterruptMaskM10 As Pcal9555aTypeInterruptMask
    Get
    Set
public:
property Pcal9555aTypeInterruptMask InterruptMaskM10 {
    Pcal9555aTypeInterruptMask get ();
    void set (Pcal9555aTypeInterruptMask value);
}
member InterruptMaskM10 : Pcal9555aTypeInterruptMask with get, set

Property Value

Type: Pcal9555aTypeInterruptMask
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptMaskM11 Property

IRD

Pcal9555aInterruptMaskM11 Property

Interrupt Mask: M1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptMask InterruptMaskM11 { get; set; }
Public Property InterruptMaskM11 As Pcal9555aTypeInterruptMask
    Get
    Set
public:
property Pcal9555aTypeInterruptMask InterruptMaskM11 {
    Pcal9555aTypeInterruptMask get ();
    void set (Pcal9555aTypeInterruptMask value);
}
member InterruptMaskM11 : Pcal9555aTypeInterruptMask with get, set

Property Value

Type: Pcal9555aTypeInterruptMask
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptMaskM12 Property

IRD

Pcal9555aInterruptMaskM12 Property

Interrupt Mask: M1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptMask InterruptMaskM12 { get; set; }
Public Property InterruptMaskM12 As Pcal9555aTypeInterruptMask
    Get
    Set
public:
property Pcal9555aTypeInterruptMask InterruptMaskM12 {
    Pcal9555aTypeInterruptMask get ();
    void set (Pcal9555aTypeInterruptMask value);
}
member InterruptMaskM12 : Pcal9555aTypeInterruptMask with get, set

Property Value

Type: Pcal9555aTypeInterruptMask
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptMaskM13 Property

IRD

Pcal9555aInterruptMaskM13 Property

Interrupt Mask: M1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptMask InterruptMaskM13 { get; set; }
Public Property InterruptMaskM13 As Pcal9555aTypeInterruptMask
    Get
    Set
public:
property Pcal9555aTypeInterruptMask InterruptMaskM13 {
    Pcal9555aTypeInterruptMask get ();
    void set (Pcal9555aTypeInterruptMask value);
}
member InterruptMaskM13 : Pcal9555aTypeInterruptMask with get, set

Property Value

Type: Pcal9555aTypeInterruptMask
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptMaskM14 Property

IRD

Pcal9555aInterruptMaskM14 Property

Interrupt Mask: M1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptMask InterruptMaskM14 { get; set; }
Public Property InterruptMaskM14 As Pcal9555aTypeInterruptMask
    Get
    Set
public:
property Pcal9555aTypeInterruptMask InterruptMaskM14 {
    Pcal9555aTypeInterruptMask get ();
    void set (Pcal9555aTypeInterruptMask value);
}
member InterruptMaskM14 : Pcal9555aTypeInterruptMask with get, set

Property Value

Type: Pcal9555aTypeInterruptMask
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptMaskM15 Property

IRD

Pcal9555aInterruptMaskM15 Property

Interrupt Mask: M1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptMask InterruptMaskM15 { get; set; }
Public Property InterruptMaskM15 As Pcal9555aTypeInterruptMask
    Get
    Set
public:
property Pcal9555aTypeInterruptMask InterruptMaskM15 {
    Pcal9555aTypeInterruptMask get ();
    void set (Pcal9555aTypeInterruptMask value);
}
member InterruptMaskM15 : Pcal9555aTypeInterruptMask with get, set

Property Value

Type: Pcal9555aTypeInterruptMask
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptMaskM16 Property

IRD

Pcal9555aInterruptMaskM16 Property

Interrupt Mask: M1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptMask InterruptMaskM16 { get; set; }
Public Property InterruptMaskM16 As Pcal9555aTypeInterruptMask
    Get
    Set
public:
property Pcal9555aTypeInterruptMask InterruptMaskM16 {
    Pcal9555aTypeInterruptMask get ();
    void set (Pcal9555aTypeInterruptMask value);
}
member InterruptMaskM16 : Pcal9555aTypeInterruptMask with get, set

Property Value

Type: Pcal9555aTypeInterruptMask
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptMaskM17 Property

IRD

Pcal9555aInterruptMaskM17 Property

Interrupt Mask: M1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptMask InterruptMaskM17 { get; set; }
Public Property InterruptMaskM17 As Pcal9555aTypeInterruptMask
    Get
    Set
public:
property Pcal9555aTypeInterruptMask InterruptMaskM17 {
    Pcal9555aTypeInterruptMask get ();
    void set (Pcal9555aTypeInterruptMask value);
}
member InterruptMaskM17 : Pcal9555aTypeInterruptMask with get, set

Property Value

Type: Pcal9555aTypeInterruptMask
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptStatusS00 Property

IRD

Pcal9555aInterruptStatusS00 Property

Interrupt Status: S0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptStatus InterruptStatusS00 { get; }
Public ReadOnly Property InterruptStatusS00 As Pcal9555aTypeInterruptStatus
    Get
public:
property Pcal9555aTypeInterruptStatus InterruptStatusS00 {
    Pcal9555aTypeInterruptStatus get ();
}
member InterruptStatusS00 : Pcal9555aTypeInterruptStatus with get

Property Value

Type: Pcal9555aTypeInterruptStatus
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptStatusS01 Property

IRD

Pcal9555aInterruptStatusS01 Property

Interrupt Status: S0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptStatus InterruptStatusS01 { get; }
Public ReadOnly Property InterruptStatusS01 As Pcal9555aTypeInterruptStatus
    Get
public:
property Pcal9555aTypeInterruptStatus InterruptStatusS01 {
    Pcal9555aTypeInterruptStatus get ();
}
member InterruptStatusS01 : Pcal9555aTypeInterruptStatus with get

Property Value

Type: Pcal9555aTypeInterruptStatus
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptStatusS02 Property

IRD

Pcal9555aInterruptStatusS02 Property

Interrupt Status: S0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptStatus InterruptStatusS02 { get; }
Public ReadOnly Property InterruptStatusS02 As Pcal9555aTypeInterruptStatus
    Get
public:
property Pcal9555aTypeInterruptStatus InterruptStatusS02 {
    Pcal9555aTypeInterruptStatus get ();
}
member InterruptStatusS02 : Pcal9555aTypeInterruptStatus with get

Property Value

Type: Pcal9555aTypeInterruptStatus
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptStatusS03 Property

IRD

Pcal9555aInterruptStatusS03 Property

Interrupt Status: S0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptStatus InterruptStatusS03 { get; }
Public ReadOnly Property InterruptStatusS03 As Pcal9555aTypeInterruptStatus
    Get
public:
property Pcal9555aTypeInterruptStatus InterruptStatusS03 {
    Pcal9555aTypeInterruptStatus get ();
}
member InterruptStatusS03 : Pcal9555aTypeInterruptStatus with get

Property Value

Type: Pcal9555aTypeInterruptStatus
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptStatusS04 Property

IRD

Pcal9555aInterruptStatusS04 Property

Interrupt Status: S0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptStatus InterruptStatusS04 { get; }
Public ReadOnly Property InterruptStatusS04 As Pcal9555aTypeInterruptStatus
    Get
public:
property Pcal9555aTypeInterruptStatus InterruptStatusS04 {
    Pcal9555aTypeInterruptStatus get ();
}
member InterruptStatusS04 : Pcal9555aTypeInterruptStatus with get

Property Value

Type: Pcal9555aTypeInterruptStatus
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptStatusS05 Property

IRD

Pcal9555aInterruptStatusS05 Property

Interrupt Status: S0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptStatus InterruptStatusS05 { get; }
Public ReadOnly Property InterruptStatusS05 As Pcal9555aTypeInterruptStatus
    Get
public:
property Pcal9555aTypeInterruptStatus InterruptStatusS05 {
    Pcal9555aTypeInterruptStatus get ();
}
member InterruptStatusS05 : Pcal9555aTypeInterruptStatus with get

Property Value

Type: Pcal9555aTypeInterruptStatus
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptStatusS06 Property

IRD

Pcal9555aInterruptStatusS06 Property

Interrupt Status: S0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptStatus InterruptStatusS06 { get; }
Public ReadOnly Property InterruptStatusS06 As Pcal9555aTypeInterruptStatus
    Get
public:
property Pcal9555aTypeInterruptStatus InterruptStatusS06 {
    Pcal9555aTypeInterruptStatus get ();
}
member InterruptStatusS06 : Pcal9555aTypeInterruptStatus with get

Property Value

Type: Pcal9555aTypeInterruptStatus
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptStatusS07 Property

IRD

Pcal9555aInterruptStatusS07 Property

Interrupt Status: S0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptStatus InterruptStatusS07 { get; }
Public ReadOnly Property InterruptStatusS07 As Pcal9555aTypeInterruptStatus
    Get
public:
property Pcal9555aTypeInterruptStatus InterruptStatusS07 {
    Pcal9555aTypeInterruptStatus get ();
}
member InterruptStatusS07 : Pcal9555aTypeInterruptStatus with get

Property Value

Type: Pcal9555aTypeInterruptStatus
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptStatusS10 Property

IRD

Pcal9555aInterruptStatusS10 Property

Interrupt Status: S1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptStatus InterruptStatusS10 { get; }
Public ReadOnly Property InterruptStatusS10 As Pcal9555aTypeInterruptStatus
    Get
public:
property Pcal9555aTypeInterruptStatus InterruptStatusS10 {
    Pcal9555aTypeInterruptStatus get ();
}
member InterruptStatusS10 : Pcal9555aTypeInterruptStatus with get

Property Value

Type: Pcal9555aTypeInterruptStatus
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptStatusS11 Property

IRD

Pcal9555aInterruptStatusS11 Property

Interrupt Status: S1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptStatus InterruptStatusS11 { get; }
Public ReadOnly Property InterruptStatusS11 As Pcal9555aTypeInterruptStatus
    Get
public:
property Pcal9555aTypeInterruptStatus InterruptStatusS11 {
    Pcal9555aTypeInterruptStatus get ();
}
member InterruptStatusS11 : Pcal9555aTypeInterruptStatus with get

Property Value

Type: Pcal9555aTypeInterruptStatus
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptStatusS12 Property

IRD

Pcal9555aInterruptStatusS12 Property

Interrupt Status: S1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptStatus InterruptStatusS12 { get; }
Public ReadOnly Property InterruptStatusS12 As Pcal9555aTypeInterruptStatus
    Get
public:
property Pcal9555aTypeInterruptStatus InterruptStatusS12 {
    Pcal9555aTypeInterruptStatus get ();
}
member InterruptStatusS12 : Pcal9555aTypeInterruptStatus with get

Property Value

Type: Pcal9555aTypeInterruptStatus
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptStatusS13 Property

IRD

Pcal9555aInterruptStatusS13 Property

Interrupt Status: S1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptStatus InterruptStatusS13 { get; }
Public ReadOnly Property InterruptStatusS13 As Pcal9555aTypeInterruptStatus
    Get
public:
property Pcal9555aTypeInterruptStatus InterruptStatusS13 {
    Pcal9555aTypeInterruptStatus get ();
}
member InterruptStatusS13 : Pcal9555aTypeInterruptStatus with get

Property Value

Type: Pcal9555aTypeInterruptStatus
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptStatusS14 Property

IRD

Pcal9555aInterruptStatusS14 Property

Interrupt Status: S1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptStatus InterruptStatusS14 { get; }
Public ReadOnly Property InterruptStatusS14 As Pcal9555aTypeInterruptStatus
    Get
public:
property Pcal9555aTypeInterruptStatus InterruptStatusS14 {
    Pcal9555aTypeInterruptStatus get ();
}
member InterruptStatusS14 : Pcal9555aTypeInterruptStatus with get

Property Value

Type: Pcal9555aTypeInterruptStatus
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptStatusS15 Property

IRD

Pcal9555aInterruptStatusS15 Property

Interrupt Status: S1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptStatus InterruptStatusS15 { get; }
Public ReadOnly Property InterruptStatusS15 As Pcal9555aTypeInterruptStatus
    Get
public:
property Pcal9555aTypeInterruptStatus InterruptStatusS15 {
    Pcal9555aTypeInterruptStatus get ();
}
member InterruptStatusS15 : Pcal9555aTypeInterruptStatus with get

Property Value

Type: Pcal9555aTypeInterruptStatus
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptStatusS16 Property

IRD

Pcal9555aInterruptStatusS16 Property

Interrupt Status: S1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptStatus InterruptStatusS16 { get; }
Public ReadOnly Property InterruptStatusS16 As Pcal9555aTypeInterruptStatus
    Get
public:
property Pcal9555aTypeInterruptStatus InterruptStatusS16 {
    Pcal9555aTypeInterruptStatus get ();
}
member InterruptStatusS16 : Pcal9555aTypeInterruptStatus with get

Property Value

Type: Pcal9555aTypeInterruptStatus
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.InterruptStatusS17 Property

IRD

Pcal9555aInterruptStatusS17 Property

Interrupt Status: S1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeInterruptStatus InterruptStatusS17 { get; }
Public ReadOnly Property InterruptStatusS17 As Pcal9555aTypeInterruptStatus
    Get
public:
property Pcal9555aTypeInterruptStatus InterruptStatusS17 {
    Pcal9555aTypeInterruptStatus get ();
}
member InterruptStatusS17 : Pcal9555aTypeInterruptStatus with get

Property Value

Type: Pcal9555aTypeInterruptStatus
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputDriveStrengthCC00 Property

IRD

Pcal9555aOutputDriveStrengthCC00 Property

Output Drive Strength: CC0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC00 { get; set; }
Public Property OutputDriveStrengthCC00 As Pcal9555aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC00 {
    Pcal9555aTypeOutputDriveStrength get ();
    void set (Pcal9555aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC00 : Pcal9555aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9555aTypeOutputDriveStrength
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputDriveStrengthCC01 Property

IRD

Pcal9555aOutputDriveStrengthCC01 Property

Output Drive Strength: CC0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC01 { get; set; }
Public Property OutputDriveStrengthCC01 As Pcal9555aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC01 {
    Pcal9555aTypeOutputDriveStrength get ();
    void set (Pcal9555aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC01 : Pcal9555aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9555aTypeOutputDriveStrength
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputDriveStrengthCC02 Property

IRD

Pcal9555aOutputDriveStrengthCC02 Property

Output Drive Strength: CC0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC02 { get; set; }
Public Property OutputDriveStrengthCC02 As Pcal9555aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC02 {
    Pcal9555aTypeOutputDriveStrength get ();
    void set (Pcal9555aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC02 : Pcal9555aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9555aTypeOutputDriveStrength
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputDriveStrengthCC03 Property

IRD

Pcal9555aOutputDriveStrengthCC03 Property

Output Drive Strength: CC0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC03 { get; set; }
Public Property OutputDriveStrengthCC03 As Pcal9555aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC03 {
    Pcal9555aTypeOutputDriveStrength get ();
    void set (Pcal9555aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC03 : Pcal9555aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9555aTypeOutputDriveStrength
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputDriveStrengthCC04 Property

IRD

Pcal9555aOutputDriveStrengthCC04 Property

Output Drive Strength: CC0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC04 { get; set; }
Public Property OutputDriveStrengthCC04 As Pcal9555aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC04 {
    Pcal9555aTypeOutputDriveStrength get ();
    void set (Pcal9555aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC04 : Pcal9555aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9555aTypeOutputDriveStrength
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputDriveStrengthCC05 Property

IRD

Pcal9555aOutputDriveStrengthCC05 Property

Output Drive Strength: CC0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC05 { get; set; }
Public Property OutputDriveStrengthCC05 As Pcal9555aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC05 {
    Pcal9555aTypeOutputDriveStrength get ();
    void set (Pcal9555aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC05 : Pcal9555aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9555aTypeOutputDriveStrength
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputDriveStrengthCC06 Property

IRD

Pcal9555aOutputDriveStrengthCC06 Property

Output Drive Strength: CC0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC06 { get; set; }
Public Property OutputDriveStrengthCC06 As Pcal9555aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC06 {
    Pcal9555aTypeOutputDriveStrength get ();
    void set (Pcal9555aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC06 : Pcal9555aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9555aTypeOutputDriveStrength
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputDriveStrengthCC07 Property

IRD

Pcal9555aOutputDriveStrengthCC07 Property

Output Drive Strength: CC0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC07 { get; set; }
Public Property OutputDriveStrengthCC07 As Pcal9555aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC07 {
    Pcal9555aTypeOutputDriveStrength get ();
    void set (Pcal9555aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC07 : Pcal9555aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9555aTypeOutputDriveStrength
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputDriveStrengthCC10 Property

IRD

Pcal9555aOutputDriveStrengthCC10 Property

Output Drive Strength: CC1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC10 { get; set; }
Public Property OutputDriveStrengthCC10 As Pcal9555aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC10 {
    Pcal9555aTypeOutputDriveStrength get ();
    void set (Pcal9555aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC10 : Pcal9555aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9555aTypeOutputDriveStrength
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputDriveStrengthCC11 Property

IRD

Pcal9555aOutputDriveStrengthCC11 Property

Output Drive Strength: CC1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC11 { get; set; }
Public Property OutputDriveStrengthCC11 As Pcal9555aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC11 {
    Pcal9555aTypeOutputDriveStrength get ();
    void set (Pcal9555aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC11 : Pcal9555aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9555aTypeOutputDriveStrength
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputDriveStrengthCC12 Property

IRD

Pcal9555aOutputDriveStrengthCC12 Property

Output Drive Strength: CC1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC12 { get; set; }
Public Property OutputDriveStrengthCC12 As Pcal9555aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC12 {
    Pcal9555aTypeOutputDriveStrength get ();
    void set (Pcal9555aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC12 : Pcal9555aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9555aTypeOutputDriveStrength
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputDriveStrengthCC13 Property

IRD

Pcal9555aOutputDriveStrengthCC13 Property

Output Drive Strength: CC1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC13 { get; set; }
Public Property OutputDriveStrengthCC13 As Pcal9555aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC13 {
    Pcal9555aTypeOutputDriveStrength get ();
    void set (Pcal9555aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC13 : Pcal9555aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9555aTypeOutputDriveStrength
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputDriveStrengthCC14 Property

IRD

Pcal9555aOutputDriveStrengthCC14 Property

Output Drive Strength: CC1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC14 { get; set; }
Public Property OutputDriveStrengthCC14 As Pcal9555aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC14 {
    Pcal9555aTypeOutputDriveStrength get ();
    void set (Pcal9555aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC14 : Pcal9555aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9555aTypeOutputDriveStrength
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputDriveStrengthCC15 Property

IRD

Pcal9555aOutputDriveStrengthCC15 Property

Output Drive Strength: CC1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC15 { get; set; }
Public Property OutputDriveStrengthCC15 As Pcal9555aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC15 {
    Pcal9555aTypeOutputDriveStrength get ();
    void set (Pcal9555aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC15 : Pcal9555aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9555aTypeOutputDriveStrength
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputDriveStrengthCC16 Property

IRD

Pcal9555aOutputDriveStrengthCC16 Property

Output Drive Strength: CC1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC16 { get; set; }
Public Property OutputDriveStrengthCC16 As Pcal9555aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC16 {
    Pcal9555aTypeOutputDriveStrength get ();
    void set (Pcal9555aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC16 : Pcal9555aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9555aTypeOutputDriveStrength
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputDriveStrengthCC17 Property

IRD

Pcal9555aOutputDriveStrengthCC17 Property

Output Drive Strength: CC1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC17 { get; set; }
Public Property OutputDriveStrengthCC17 As Pcal9555aTypeOutputDriveStrength
    Get
    Set
public:
property Pcal9555aTypeOutputDriveStrength OutputDriveStrengthCC17 {
    Pcal9555aTypeOutputDriveStrength get ();
    void set (Pcal9555aTypeOutputDriveStrength value);
}
member OutputDriveStrengthCC17 : Pcal9555aTypeOutputDriveStrength with get, set

Property Value

Type: Pcal9555aTypeOutputDriveStrength
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputPortConfigurationODEN0 Property

IRD

Pcal9555aOutputPortConfigurationODEN0 Property

Output Port Configuration: ODEN0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeOutputPortConfiguration OutputPortConfigurationODEN0 { get; set; }
Public Property OutputPortConfigurationODEN0 As Pcal9555aTypeOutputPortConfiguration
    Get
    Set
public:
property Pcal9555aTypeOutputPortConfiguration OutputPortConfigurationODEN0 {
    Pcal9555aTypeOutputPortConfiguration get ();
    void set (Pcal9555aTypeOutputPortConfiguration value);
}
member OutputPortConfigurationODEN0 : Pcal9555aTypeOutputPortConfiguration with get, set

Property Value

Type: Pcal9555aTypeOutputPortConfiguration
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputPortConfigurationODEN1 Property

IRD

Pcal9555aOutputPortConfigurationODEN1 Property

Output Port Configuration: ODEN1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypeOutputPortConfiguration OutputPortConfigurationODEN1 { get; set; }
Public Property OutputPortConfigurationODEN1 As Pcal9555aTypeOutputPortConfiguration
    Get
    Set
public:
property Pcal9555aTypeOutputPortConfiguration OutputPortConfigurationODEN1 {
    Pcal9555aTypeOutputPortConfiguration get ();
    void set (Pcal9555aTypeOutputPortConfiguration value);
}
member OutputPortConfigurationODEN1 : Pcal9555aTypeOutputPortConfiguration with get, set

Property Value

Type: Pcal9555aTypeOutputPortConfiguration
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputPortO00 Property

IRD

Pcal9555aOutputPortO00 Property

Output Port: O0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO00 { get; set; }
Public Property OutputPortO00 As Byte
    Get
    Set
public:
property unsigned char OutputPortO00 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO00 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputPortO01 Property

IRD

Pcal9555aOutputPortO01 Property

Output Port: O0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO01 { get; set; }
Public Property OutputPortO01 As Byte
    Get
    Set
public:
property unsigned char OutputPortO01 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO01 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputPortO02 Property

IRD

Pcal9555aOutputPortO02 Property

Output Port: O0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO02 { get; set; }
Public Property OutputPortO02 As Byte
    Get
    Set
public:
property unsigned char OutputPortO02 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO02 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputPortO03 Property

IRD

Pcal9555aOutputPortO03 Property

Output Port: O0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO03 { get; set; }
Public Property OutputPortO03 As Byte
    Get
    Set
public:
property unsigned char OutputPortO03 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO03 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputPortO04 Property

IRD

Pcal9555aOutputPortO04 Property

Output Port: O0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO04 { get; set; }
Public Property OutputPortO04 As Byte
    Get
    Set
public:
property unsigned char OutputPortO04 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO04 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputPortO05 Property

IRD

Pcal9555aOutputPortO05 Property

Output Port: O0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO05 { get; set; }
Public Property OutputPortO05 As Byte
    Get
    Set
public:
property unsigned char OutputPortO05 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO05 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputPortO06 Property

IRD

Pcal9555aOutputPortO06 Property

Output Port: O0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO06 { get; set; }
Public Property OutputPortO06 As Byte
    Get
    Set
public:
property unsigned char OutputPortO06 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO06 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputPortO07 Property

IRD

Pcal9555aOutputPortO07 Property

Output Port: O0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO07 { get; set; }
Public Property OutputPortO07 As Byte
    Get
    Set
public:
property unsigned char OutputPortO07 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO07 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputPortO10 Property

IRD

Pcal9555aOutputPortO10 Property

Output Port: O1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO10 { get; set; }
Public Property OutputPortO10 As Byte
    Get
    Set
public:
property unsigned char OutputPortO10 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO10 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputPortO11 Property

IRD

Pcal9555aOutputPortO11 Property

Output Port: O1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO11 { get; set; }
Public Property OutputPortO11 As Byte
    Get
    Set
public:
property unsigned char OutputPortO11 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO11 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputPortO12 Property

IRD

Pcal9555aOutputPortO12 Property

Output Port: O1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO12 { get; set; }
Public Property OutputPortO12 As Byte
    Get
    Set
public:
property unsigned char OutputPortO12 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO12 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputPortO13 Property

IRD

Pcal9555aOutputPortO13 Property

Output Port: O1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO13 { get; set; }
Public Property OutputPortO13 As Byte
    Get
    Set
public:
property unsigned char OutputPortO13 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO13 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputPortO14 Property

IRD

Pcal9555aOutputPortO14 Property

Output Port: O1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO14 { get; set; }
Public Property OutputPortO14 As Byte
    Get
    Set
public:
property unsigned char OutputPortO14 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO14 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputPortO15 Property

IRD

Pcal9555aOutputPortO15 Property

Output Port: O1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO15 { get; set; }
Public Property OutputPortO15 As Byte
    Get
    Set
public:
property unsigned char OutputPortO15 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO15 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputPortO16 Property

IRD

Pcal9555aOutputPortO16 Property

Output Port: O1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO16 { get; set; }
Public Property OutputPortO16 As Byte
    Get
    Set
public:
property unsigned char OutputPortO16 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO16 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.OutputPortO17 Property

IRD

Pcal9555aOutputPortO17 Property

Output Port: O1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputPortO17 { get; set; }
Public Property OutputPortO17 As Byte
    Get
    Set
public:
property unsigned char OutputPortO17 {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputPortO17 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PolarityInversionN00 Property

IRD

Pcal9555aPolarityInversionN00 Property

Polarity Inversion: N0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePolarityInversion PolarityInversionN00 { get; set; }
Public Property PolarityInversionN00 As Pcal9555aTypePolarityInversion
    Get
    Set
public:
property Pcal9555aTypePolarityInversion PolarityInversionN00 {
    Pcal9555aTypePolarityInversion get ();
    void set (Pcal9555aTypePolarityInversion value);
}
member PolarityInversionN00 : Pcal9555aTypePolarityInversion with get, set

Property Value

Type: Pcal9555aTypePolarityInversion
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PolarityInversionN01 Property

IRD

Pcal9555aPolarityInversionN01 Property

Polarity Inversion: N0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePolarityInversion PolarityInversionN01 { get; set; }
Public Property PolarityInversionN01 As Pcal9555aTypePolarityInversion
    Get
    Set
public:
property Pcal9555aTypePolarityInversion PolarityInversionN01 {
    Pcal9555aTypePolarityInversion get ();
    void set (Pcal9555aTypePolarityInversion value);
}
member PolarityInversionN01 : Pcal9555aTypePolarityInversion with get, set

Property Value

Type: Pcal9555aTypePolarityInversion
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PolarityInversionN02 Property

IRD

Pcal9555aPolarityInversionN02 Property

Polarity Inversion: N0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePolarityInversion PolarityInversionN02 { get; set; }
Public Property PolarityInversionN02 As Pcal9555aTypePolarityInversion
    Get
    Set
public:
property Pcal9555aTypePolarityInversion PolarityInversionN02 {
    Pcal9555aTypePolarityInversion get ();
    void set (Pcal9555aTypePolarityInversion value);
}
member PolarityInversionN02 : Pcal9555aTypePolarityInversion with get, set

Property Value

Type: Pcal9555aTypePolarityInversion
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PolarityInversionN03 Property

IRD

Pcal9555aPolarityInversionN03 Property

Polarity Inversion: N0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePolarityInversion PolarityInversionN03 { get; set; }
Public Property PolarityInversionN03 As Pcal9555aTypePolarityInversion
    Get
    Set
public:
property Pcal9555aTypePolarityInversion PolarityInversionN03 {
    Pcal9555aTypePolarityInversion get ();
    void set (Pcal9555aTypePolarityInversion value);
}
member PolarityInversionN03 : Pcal9555aTypePolarityInversion with get, set

Property Value

Type: Pcal9555aTypePolarityInversion
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PolarityInversionN04 Property

IRD

Pcal9555aPolarityInversionN04 Property

Polarity Inversion: N0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePolarityInversion PolarityInversionN04 { get; set; }
Public Property PolarityInversionN04 As Pcal9555aTypePolarityInversion
    Get
    Set
public:
property Pcal9555aTypePolarityInversion PolarityInversionN04 {
    Pcal9555aTypePolarityInversion get ();
    void set (Pcal9555aTypePolarityInversion value);
}
member PolarityInversionN04 : Pcal9555aTypePolarityInversion with get, set

Property Value

Type: Pcal9555aTypePolarityInversion
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PolarityInversionN05 Property

IRD

Pcal9555aPolarityInversionN05 Property

Polarity Inversion: N0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePolarityInversion PolarityInversionN05 { get; set; }
Public Property PolarityInversionN05 As Pcal9555aTypePolarityInversion
    Get
    Set
public:
property Pcal9555aTypePolarityInversion PolarityInversionN05 {
    Pcal9555aTypePolarityInversion get ();
    void set (Pcal9555aTypePolarityInversion value);
}
member PolarityInversionN05 : Pcal9555aTypePolarityInversion with get, set

Property Value

Type: Pcal9555aTypePolarityInversion
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PolarityInversionN06 Property

IRD

Pcal9555aPolarityInversionN06 Property

Polarity Inversion: N0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePolarityInversion PolarityInversionN06 { get; set; }
Public Property PolarityInversionN06 As Pcal9555aTypePolarityInversion
    Get
    Set
public:
property Pcal9555aTypePolarityInversion PolarityInversionN06 {
    Pcal9555aTypePolarityInversion get ();
    void set (Pcal9555aTypePolarityInversion value);
}
member PolarityInversionN06 : Pcal9555aTypePolarityInversion with get, set

Property Value

Type: Pcal9555aTypePolarityInversion
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PolarityInversionN07 Property

IRD

Pcal9555aPolarityInversionN07 Property

Polarity Inversion: N0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePolarityInversion PolarityInversionN07 { get; set; }
Public Property PolarityInversionN07 As Pcal9555aTypePolarityInversion
    Get
    Set
public:
property Pcal9555aTypePolarityInversion PolarityInversionN07 {
    Pcal9555aTypePolarityInversion get ();
    void set (Pcal9555aTypePolarityInversion value);
}
member PolarityInversionN07 : Pcal9555aTypePolarityInversion with get, set

Property Value

Type: Pcal9555aTypePolarityInversion
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PolarityInversionN10 Property

IRD

Pcal9555aPolarityInversionN10 Property

Polarity Inversion: N1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePolarityInversion PolarityInversionN10 { get; set; }
Public Property PolarityInversionN10 As Pcal9555aTypePolarityInversion
    Get
    Set
public:
property Pcal9555aTypePolarityInversion PolarityInversionN10 {
    Pcal9555aTypePolarityInversion get ();
    void set (Pcal9555aTypePolarityInversion value);
}
member PolarityInversionN10 : Pcal9555aTypePolarityInversion with get, set

Property Value

Type: Pcal9555aTypePolarityInversion
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PolarityInversionN11 Property

IRD

Pcal9555aPolarityInversionN11 Property

Polarity Inversion: N1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePolarityInversion PolarityInversionN11 { get; set; }
Public Property PolarityInversionN11 As Pcal9555aTypePolarityInversion
    Get
    Set
public:
property Pcal9555aTypePolarityInversion PolarityInversionN11 {
    Pcal9555aTypePolarityInversion get ();
    void set (Pcal9555aTypePolarityInversion value);
}
member PolarityInversionN11 : Pcal9555aTypePolarityInversion with get, set

Property Value

Type: Pcal9555aTypePolarityInversion
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PolarityInversionN12 Property

IRD

Pcal9555aPolarityInversionN12 Property

Polarity Inversion: N1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePolarityInversion PolarityInversionN12 { get; set; }
Public Property PolarityInversionN12 As Pcal9555aTypePolarityInversion
    Get
    Set
public:
property Pcal9555aTypePolarityInversion PolarityInversionN12 {
    Pcal9555aTypePolarityInversion get ();
    void set (Pcal9555aTypePolarityInversion value);
}
member PolarityInversionN12 : Pcal9555aTypePolarityInversion with get, set

Property Value

Type: Pcal9555aTypePolarityInversion
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PolarityInversionN13 Property

IRD

Pcal9555aPolarityInversionN13 Property

Polarity Inversion: N1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePolarityInversion PolarityInversionN13 { get; set; }
Public Property PolarityInversionN13 As Pcal9555aTypePolarityInversion
    Get
    Set
public:
property Pcal9555aTypePolarityInversion PolarityInversionN13 {
    Pcal9555aTypePolarityInversion get ();
    void set (Pcal9555aTypePolarityInversion value);
}
member PolarityInversionN13 : Pcal9555aTypePolarityInversion with get, set

Property Value

Type: Pcal9555aTypePolarityInversion
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PolarityInversionN14 Property

IRD

Pcal9555aPolarityInversionN14 Property

Polarity Inversion: N1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePolarityInversion PolarityInversionN14 { get; set; }
Public Property PolarityInversionN14 As Pcal9555aTypePolarityInversion
    Get
    Set
public:
property Pcal9555aTypePolarityInversion PolarityInversionN14 {
    Pcal9555aTypePolarityInversion get ();
    void set (Pcal9555aTypePolarityInversion value);
}
member PolarityInversionN14 : Pcal9555aTypePolarityInversion with get, set

Property Value

Type: Pcal9555aTypePolarityInversion
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PolarityInversionN15 Property

IRD

Pcal9555aPolarityInversionN15 Property

Polarity Inversion: N1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePolarityInversion PolarityInversionN15 { get; set; }
Public Property PolarityInversionN15 As Pcal9555aTypePolarityInversion
    Get
    Set
public:
property Pcal9555aTypePolarityInversion PolarityInversionN15 {
    Pcal9555aTypePolarityInversion get ();
    void set (Pcal9555aTypePolarityInversion value);
}
member PolarityInversionN15 : Pcal9555aTypePolarityInversion with get, set

Property Value

Type: Pcal9555aTypePolarityInversion
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PolarityInversionN16 Property

IRD

Pcal9555aPolarityInversionN16 Property

Polarity Inversion: N1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePolarityInversion PolarityInversionN16 { get; set; }
Public Property PolarityInversionN16 As Pcal9555aTypePolarityInversion
    Get
    Set
public:
property Pcal9555aTypePolarityInversion PolarityInversionN16 {
    Pcal9555aTypePolarityInversion get ();
    void set (Pcal9555aTypePolarityInversion value);
}
member PolarityInversionN16 : Pcal9555aTypePolarityInversion with get, set

Property Value

Type: Pcal9555aTypePolarityInversion
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PolarityInversionN17 Property

IRD

Pcal9555aPolarityInversionN17 Property

Polarity Inversion: N1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePolarityInversion PolarityInversionN17 { get; set; }
Public Property PolarityInversionN17 As Pcal9555aTypePolarityInversion
    Get
    Set
public:
property Pcal9555aTypePolarityInversion PolarityInversionN17 {
    Pcal9555aTypePolarityInversion get ();
    void set (Pcal9555aTypePolarityInversion value);
}
member PolarityInversionN17 : Pcal9555aTypePolarityInversion with get, set

Property Value

Type: Pcal9555aTypePolarityInversion
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownEnablePE00 Property

IRD

Pcal9555aPullUpPullDownEnablePE00 Property

Pull-Up/Pull-Down Enable: PE0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE00 { get; set; }
Public Property PullUpPullDownEnablePE00 As Pcal9555aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE00 {
    Pcal9555aTypePullUpPullDownEnable get ();
    void set (Pcal9555aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE00 : Pcal9555aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownEnable
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownEnablePE01 Property

IRD

Pcal9555aPullUpPullDownEnablePE01 Property

Pull-Up/Pull-Down Enable: PE0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE01 { get; set; }
Public Property PullUpPullDownEnablePE01 As Pcal9555aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE01 {
    Pcal9555aTypePullUpPullDownEnable get ();
    void set (Pcal9555aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE01 : Pcal9555aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownEnable
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownEnablePE02 Property

IRD

Pcal9555aPullUpPullDownEnablePE02 Property

Pull-Up/Pull-Down Enable: PE0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE02 { get; set; }
Public Property PullUpPullDownEnablePE02 As Pcal9555aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE02 {
    Pcal9555aTypePullUpPullDownEnable get ();
    void set (Pcal9555aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE02 : Pcal9555aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownEnable
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownEnablePE03 Property

IRD

Pcal9555aPullUpPullDownEnablePE03 Property

Pull-Up/Pull-Down Enable: PE0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE03 { get; set; }
Public Property PullUpPullDownEnablePE03 As Pcal9555aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE03 {
    Pcal9555aTypePullUpPullDownEnable get ();
    void set (Pcal9555aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE03 : Pcal9555aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownEnable
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownEnablePE04 Property

IRD

Pcal9555aPullUpPullDownEnablePE04 Property

Pull-Up/Pull-Down Enable: PE0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE04 { get; set; }
Public Property PullUpPullDownEnablePE04 As Pcal9555aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE04 {
    Pcal9555aTypePullUpPullDownEnable get ();
    void set (Pcal9555aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE04 : Pcal9555aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownEnable
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownEnablePE05 Property

IRD

Pcal9555aPullUpPullDownEnablePE05 Property

Pull-Up/Pull-Down Enable: PE0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE05 { get; set; }
Public Property PullUpPullDownEnablePE05 As Pcal9555aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE05 {
    Pcal9555aTypePullUpPullDownEnable get ();
    void set (Pcal9555aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE05 : Pcal9555aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownEnable
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownEnablePE06 Property

IRD

Pcal9555aPullUpPullDownEnablePE06 Property

Pull-Up/Pull-Down Enable: PE0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE06 { get; set; }
Public Property PullUpPullDownEnablePE06 As Pcal9555aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE06 {
    Pcal9555aTypePullUpPullDownEnable get ();
    void set (Pcal9555aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE06 : Pcal9555aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownEnable
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownEnablePE07 Property

IRD

Pcal9555aPullUpPullDownEnablePE07 Property

Pull-Up/Pull-Down Enable: PE0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE07 { get; set; }
Public Property PullUpPullDownEnablePE07 As Pcal9555aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE07 {
    Pcal9555aTypePullUpPullDownEnable get ();
    void set (Pcal9555aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE07 : Pcal9555aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownEnable
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownEnablePE10 Property

IRD

Pcal9555aPullUpPullDownEnablePE10 Property

Pull-Up/Pull-Down Enable: PE1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE10 { get; set; }
Public Property PullUpPullDownEnablePE10 As Pcal9555aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE10 {
    Pcal9555aTypePullUpPullDownEnable get ();
    void set (Pcal9555aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE10 : Pcal9555aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownEnable
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownEnablePE11 Property

IRD

Pcal9555aPullUpPullDownEnablePE11 Property

Pull-Up/Pull-Down Enable: PE1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE11 { get; set; }
Public Property PullUpPullDownEnablePE11 As Pcal9555aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE11 {
    Pcal9555aTypePullUpPullDownEnable get ();
    void set (Pcal9555aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE11 : Pcal9555aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownEnable
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownEnablePE12 Property

IRD

Pcal9555aPullUpPullDownEnablePE12 Property

Pull-Up/Pull-Down Enable: PE1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE12 { get; set; }
Public Property PullUpPullDownEnablePE12 As Pcal9555aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE12 {
    Pcal9555aTypePullUpPullDownEnable get ();
    void set (Pcal9555aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE12 : Pcal9555aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownEnable
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownEnablePE13 Property

IRD

Pcal9555aPullUpPullDownEnablePE13 Property

Pull-Up/Pull-Down Enable: PE1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE13 { get; set; }
Public Property PullUpPullDownEnablePE13 As Pcal9555aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE13 {
    Pcal9555aTypePullUpPullDownEnable get ();
    void set (Pcal9555aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE13 : Pcal9555aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownEnable
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownEnablePE14 Property

IRD

Pcal9555aPullUpPullDownEnablePE14 Property

Pull-Up/Pull-Down Enable: PE1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE14 { get; set; }
Public Property PullUpPullDownEnablePE14 As Pcal9555aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE14 {
    Pcal9555aTypePullUpPullDownEnable get ();
    void set (Pcal9555aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE14 : Pcal9555aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownEnable
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownEnablePE15 Property

IRD

Pcal9555aPullUpPullDownEnablePE15 Property

Pull-Up/Pull-Down Enable: PE1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE15 { get; set; }
Public Property PullUpPullDownEnablePE15 As Pcal9555aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE15 {
    Pcal9555aTypePullUpPullDownEnable get ();
    void set (Pcal9555aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE15 : Pcal9555aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownEnable
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownEnablePE16 Property

IRD

Pcal9555aPullUpPullDownEnablePE16 Property

Pull-Up/Pull-Down Enable: PE1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE16 { get; set; }
Public Property PullUpPullDownEnablePE16 As Pcal9555aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE16 {
    Pcal9555aTypePullUpPullDownEnable get ();
    void set (Pcal9555aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE16 : Pcal9555aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownEnable
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownEnablePE17 Property

IRD

Pcal9555aPullUpPullDownEnablePE17 Property

Pull-Up/Pull-Down Enable: PE1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE17 { get; set; }
Public Property PullUpPullDownEnablePE17 As Pcal9555aTypePullUpPullDownEnable
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownEnable PullUpPullDownEnablePE17 {
    Pcal9555aTypePullUpPullDownEnable get ();
    void set (Pcal9555aTypePullUpPullDownEnable value);
}
member PullUpPullDownEnablePE17 : Pcal9555aTypePullUpPullDownEnable with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownEnable
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownSelectionPUD00 Property

IRD

Pcal9555aPullUpPullDownSelectionPUD00 Property

Pull-Up/Pull-Down Selection: PUD0.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD00 { get; set; }
Public Property PullUpPullDownSelectionPUD00 As Pcal9555aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD00 {
    Pcal9555aTypePullUpPullDownSelection get ();
    void set (Pcal9555aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD00 : Pcal9555aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownSelection
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownSelectionPUD01 Property

IRD

Pcal9555aPullUpPullDownSelectionPUD01 Property

Pull-Up/Pull-Down Selection: PUD0.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD01 { get; set; }
Public Property PullUpPullDownSelectionPUD01 As Pcal9555aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD01 {
    Pcal9555aTypePullUpPullDownSelection get ();
    void set (Pcal9555aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD01 : Pcal9555aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownSelection
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownSelectionPUD02 Property

IRD

Pcal9555aPullUpPullDownSelectionPUD02 Property

Pull-Up/Pull-Down Selection: PUD0.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD02 { get; set; }
Public Property PullUpPullDownSelectionPUD02 As Pcal9555aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD02 {
    Pcal9555aTypePullUpPullDownSelection get ();
    void set (Pcal9555aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD02 : Pcal9555aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownSelection
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownSelectionPUD03 Property

IRD

Pcal9555aPullUpPullDownSelectionPUD03 Property

Pull-Up/Pull-Down Selection: PUD0.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD03 { get; set; }
Public Property PullUpPullDownSelectionPUD03 As Pcal9555aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD03 {
    Pcal9555aTypePullUpPullDownSelection get ();
    void set (Pcal9555aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD03 : Pcal9555aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownSelection
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownSelectionPUD04 Property

IRD

Pcal9555aPullUpPullDownSelectionPUD04 Property

Pull-Up/Pull-Down Selection: PUD0.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD04 { get; set; }
Public Property PullUpPullDownSelectionPUD04 As Pcal9555aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD04 {
    Pcal9555aTypePullUpPullDownSelection get ();
    void set (Pcal9555aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD04 : Pcal9555aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownSelection
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownSelectionPUD05 Property

IRD

Pcal9555aPullUpPullDownSelectionPUD05 Property

Pull-Up/Pull-Down Selection: PUD0.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD05 { get; set; }
Public Property PullUpPullDownSelectionPUD05 As Pcal9555aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD05 {
    Pcal9555aTypePullUpPullDownSelection get ();
    void set (Pcal9555aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD05 : Pcal9555aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownSelection
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownSelectionPUD06 Property

IRD

Pcal9555aPullUpPullDownSelectionPUD06 Property

Pull-Up/Pull-Down Selection: PUD0.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD06 { get; set; }
Public Property PullUpPullDownSelectionPUD06 As Pcal9555aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD06 {
    Pcal9555aTypePullUpPullDownSelection get ();
    void set (Pcal9555aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD06 : Pcal9555aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownSelection
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownSelectionPUD07 Property

IRD

Pcal9555aPullUpPullDownSelectionPUD07 Property

Pull-Up/Pull-Down Selection: PUD0.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD07 { get; set; }
Public Property PullUpPullDownSelectionPUD07 As Pcal9555aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD07 {
    Pcal9555aTypePullUpPullDownSelection get ();
    void set (Pcal9555aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD07 : Pcal9555aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownSelection
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownSelectionPUD10 Property

IRD

Pcal9555aPullUpPullDownSelectionPUD10 Property

Pull-Up/Pull-Down Selection: PUD1.0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD10 { get; set; }
Public Property PullUpPullDownSelectionPUD10 As Pcal9555aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD10 {
    Pcal9555aTypePullUpPullDownSelection get ();
    void set (Pcal9555aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD10 : Pcal9555aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownSelection
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownSelectionPUD11 Property

IRD

Pcal9555aPullUpPullDownSelectionPUD11 Property

Pull-Up/Pull-Down Selection: PUD1.1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD11 { get; set; }
Public Property PullUpPullDownSelectionPUD11 As Pcal9555aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD11 {
    Pcal9555aTypePullUpPullDownSelection get ();
    void set (Pcal9555aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD11 : Pcal9555aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownSelection
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownSelectionPUD12 Property

IRD

Pcal9555aPullUpPullDownSelectionPUD12 Property

Pull-Up/Pull-Down Selection: PUD1.2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD12 { get; set; }
Public Property PullUpPullDownSelectionPUD12 As Pcal9555aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD12 {
    Pcal9555aTypePullUpPullDownSelection get ();
    void set (Pcal9555aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD12 : Pcal9555aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownSelection
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownSelectionPUD13 Property

IRD

Pcal9555aPullUpPullDownSelectionPUD13 Property

Pull-Up/Pull-Down Selection: PUD1.3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD13 { get; set; }
Public Property PullUpPullDownSelectionPUD13 As Pcal9555aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD13 {
    Pcal9555aTypePullUpPullDownSelection get ();
    void set (Pcal9555aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD13 : Pcal9555aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownSelection
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownSelectionPUD14 Property

IRD

Pcal9555aPullUpPullDownSelectionPUD14 Property

Pull-Up/Pull-Down Selection: PUD1.4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD14 { get; set; }
Public Property PullUpPullDownSelectionPUD14 As Pcal9555aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD14 {
    Pcal9555aTypePullUpPullDownSelection get ();
    void set (Pcal9555aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD14 : Pcal9555aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownSelection
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownSelectionPUD15 Property

IRD

Pcal9555aPullUpPullDownSelectionPUD15 Property

Pull-Up/Pull-Down Selection: PUD1.5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD15 { get; set; }
Public Property PullUpPullDownSelectionPUD15 As Pcal9555aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD15 {
    Pcal9555aTypePullUpPullDownSelection get ();
    void set (Pcal9555aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD15 : Pcal9555aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownSelection
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownSelectionPUD16 Property

IRD

Pcal9555aPullUpPullDownSelectionPUD16 Property

Pull-Up/Pull-Down Selection: PUD1.6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD16 { get; set; }
Public Property PullUpPullDownSelectionPUD16 As Pcal9555aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD16 {
    Pcal9555aTypePullUpPullDownSelection get ();
    void set (Pcal9555aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD16 : Pcal9555aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownSelection
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.PullUpPullDownSelectionPUD17 Property

IRD

Pcal9555aPullUpPullDownSelectionPUD17 Property

Pull-Up/Pull-Down Selection: PUD1.7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD17 { get; set; }
Public Property PullUpPullDownSelectionPUD17 As Pcal9555aTypePullUpPullDownSelection
    Get
    Set
public:
property Pcal9555aTypePullUpPullDownSelection PullUpPullDownSelectionPUD17 {
    Pcal9555aTypePullUpPullDownSelection get ();
    void set (Pcal9555aTypePullUpPullDownSelection value);
}
member PullUpPullDownSelectionPUD17 : Pcal9555aTypePullUpPullDownSelection with get, set

Property Value

Type: Pcal9555aTypePullUpPullDownSelection
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a Methods

The Pcal9555a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.Flush Method

IRD

Pcal9555aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcal9555a Class
telos.Ird.NXPSemiconductors Namespace


Pcal9555a.TypeConfiguration Enumeration

IRD

Pcal9555aTypeConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Output | 0 | Output
Input | 1 | Input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9555a.TypeInputLatch Enumeration

IRD

Pcal9555aTypeInputLatch Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInputLatch
Public Enumeration TypeInputLatch
public enum class TypeInputLatch
type TypeInputLatch
Members
Member name | Value | Description
NotLatched | 0 | Not Latched
Latched | 1 | Latched
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9555a.TypeInterruptMask Enumeration

IRD

Pcal9555aTypeInterruptMask Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptMask
Public Enumeration TypeInterruptMask
public enum class TypeInterruptMask
type TypeInterruptMask
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9555a.TypeInterruptStatus Enumeration

IRD

Pcal9555aTypeInterruptStatus Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterruptStatus
Public Enumeration TypeInterruptStatus
public enum class TypeInterruptStatus
type TypeInterruptStatus
Members
Member name | Value | Description
NotSource | 0 | Not Source
Source | 1 | Source
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9555a.TypeOutputDriveStrength Enumeration

IRD

Pcal9555aTypeOutputDriveStrength Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputDriveStrength
Public Enumeration TypeOutputDriveStrength
public enum class TypeOutputDriveStrength
type TypeOutputDriveStrength
Members
Member name | Value | Description
Value_025x | 0 | 0.25x
Value_05x | 1 | 0.5x
Value_075x | 2 | 0.75x
Value_10x | 3 | 1.0x
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9555a.TypeOutputPortConfiguration Enumeration

IRD

Pcal9555aTypeOutputPortConfiguration Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputPortConfiguration
Public Enumeration TypeOutputPortConfiguration
public enum class TypeOutputPortConfiguration
type TypeOutputPortConfiguration
Members
Member name | Value | Description
PushPull | 0 | Push-Pull
OpenDrain | 1 | Open-Drain
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9555a.TypePolarityInversion Enumeration

IRD

Pcal9555aTypePolarityInversion Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarityInversion
Public Enumeration TypePolarityInversion
public enum class TypePolarityInversion
type TypePolarityInversion
Members
Member name | Value | Description
NotInverted | 0 | Not Inverted
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9555a.TypePullUpPullDownEnable Enumeration

IRD

Pcal9555aTypePullUpPullDownEnable Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePullUpPullDownEnable
Public Enumeration TypePullUpPullDownEnable
public enum class TypePullUpPullDownEnable
type TypePullUpPullDownEnable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcal9555a.TypePullUpPullDownSelection Enumeration

IRD

Pcal9555aTypePullUpPullDownSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePullUpPullDownSelection
Public Enumeration TypePullUpPullDownSelection
public enum class TypePullUpPullDownSelection
type TypePullUpPullDownSelection
Members
Member name | Value | Description
Value_100KΩPullDown | 0 | 100 kΩ Pull-Down
Value_100KΩPullUp | 1 | 100 kΩ Pull-Up
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a Class

NXP Semiconductors: PCF 85063A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPcf85063a

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcf85063a
Public Class Pcf85063a
public ref class Pcf85063a
type Pcf85063a =  class end

The Pcf85063a type exposes the following members.

Constructors
 | Name | Description
Public method | Pcf85063a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Control11224 | Control 1: 12_24
Public property | Control1CAPSEL | Control 1: CAP_SEL
Public property | Control1CIE | Control 1: CIE
Public property | Control1EXTTEST | Control 1: EXT_TEST
Public property | Control1SR | Control 1: SR
Public property | Control1STOP | Control 1: STOP
Public property | Control2AF | Control 2: AF
Public property | Control2AIE | Control 2: AIE
Public property | Control2COF | Control 2: COF (unit: Hz)
Public property | Control2HMI | Control 2: HMI
Public property | Control2MI | Control 2: MI
Public property | Control2TF | Control 2: TF
Public property | DayAlarmAEND | Day Alarm: AEN_D
Public property | DayAlarmDAYALARM | Day Alarm: DAY_ALARM
Public property | Days | Days
Public property | HourAlarmAENH | Hour Alarm: AEN_H
Public property | HourAlarmHOURALARM | Hour Alarm: HOUR_ALARM
Public property | Hours | Hours
Public property | MinuteAlarmAENM | Minute Alarm: AEN_M
Public property | MinuteAlarmMINUTEALARM | Minute Alarm: MINUTE_ALARM
Public property | Minutes | Minutes
Public property | Months | Months
Public property | OffsetMODE | Offset: MODE
Public property | OffsetOFFSET | Offset: OFFSET
Public property | RAM | RAM
Public property | SecondAlarmAENS | Second Alarm: AEN_S
Public property | SecondAlarmSECONDALARM | Second Alarm: SECOND_ALARM
Public property | SecondsOS | Seconds: OS
Public property | SecondsSECONDS | Seconds: SECONDS
Public property | TimerModeTCF | Timer Mode: TCF
Public property | TimerModeTE | Timer Mode: TE
Public property | TimerModeTIE | Timer Mode: TIE
Public property | TimerModeTITP | Timer Mode: TI_TP
Public property | TimerValue | Timer Value
Public property | WeekdayAlarmAENW | Weekday Alarm: AEN_W
Public property | WeekdayAlarmWEEKDAYALARM | Weekday Alarm: WEEKDAY_ALARM
Public property | Weekdays | Weekdays
Public property | Years | Years
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Tiny Real-Time Clock/Calendar With Alarm Function
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcf85063a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcf85063a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a Properties

The Pcf85063a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Control11224 | Control 1: 12_24
Public property | Control1CAPSEL | Control 1: CAP_SEL
Public property | Control1CIE | Control 1: CIE
Public property | Control1EXTTEST | Control 1: EXT_TEST
Public property | Control1SR | Control 1: SR
Public property | Control1STOP | Control 1: STOP
Public property | Control2AF | Control 2: AF
Public property | Control2AIE | Control 2: AIE
Public property | Control2COF | Control 2: COF (unit: Hz)
Public property | Control2HMI | Control 2: HMI
Public property | Control2MI | Control 2: MI
Public property | Control2TF | Control 2: TF
Public property | DayAlarmAEND | Day Alarm: AEN_D
Public property | DayAlarmDAYALARM | Day Alarm: DAY_ALARM
Public property | Days | Days
Public property | HourAlarmAENH | Hour Alarm: AEN_H
Public property | HourAlarmHOURALARM | Hour Alarm: HOUR_ALARM
Public property | Hours | Hours
Public property | MinuteAlarmAENM | Minute Alarm: AEN_M
Public property | MinuteAlarmMINUTEALARM | Minute Alarm: MINUTE_ALARM
Public property | Minutes | Minutes
Public property | Months | Months
Public property | OffsetMODE | Offset: MODE
Public property | OffsetOFFSET | Offset: OFFSET
Public property | RAM | RAM
Public property | SecondAlarmAENS | Second Alarm: AEN_S
Public property | SecondAlarmSECONDALARM | Second Alarm: SECOND_ALARM
Public property | SecondsOS | Seconds: OS
Public property | SecondsSECONDS | Seconds: SECONDS
Public property | TimerModeTCF | Timer Mode: TCF
Public property | TimerModeTE | Timer Mode: TE
Public property | TimerModeTIE | Timer Mode: TIE
Public property | TimerModeTITP | Timer Mode: TI_TP
Public property | TimerValue | Timer Value
Public property | WeekdayAlarmAENW | Weekday Alarm: AEN_W
Public property | WeekdayAlarmWEEKDAYALARM | Weekday Alarm: WEEKDAY_ALARM
Public property | Weekdays | Weekdays
Public property | Years | Years
Top
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.AutoFlush Property

IRD

Pcf85063aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Control11224 Property

IRD

Pcf85063aControl11224 Property

Control 1: 12_24

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeControl11224 Control11224 { get; set; }
Public Property Control11224 As Pcf85063aTypeControl11224
    Get
    Set
public:
property Pcf85063aTypeControl11224 Control11224 {
    Pcf85063aTypeControl11224 get ();
    void set (Pcf85063aTypeControl11224 value);
}
member Control11224 : Pcf85063aTypeControl11224 with get, set

Property Value

Type: Pcf85063aTypeControl11224
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Control1CAPSEL Property

IRD

Pcf85063aControl1CAPSEL Property

Control 1: CAP_SEL

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeControl1CapSel Control1CAPSEL { get; set; }
Public Property Control1CAPSEL As Pcf85063aTypeControl1CapSel
    Get
    Set
public:
property Pcf85063aTypeControl1CapSel Control1CAPSEL {
    Pcf85063aTypeControl1CapSel get ();
    void set (Pcf85063aTypeControl1CapSel value);
}
member Control1CAPSEL : Pcf85063aTypeControl1CapSel with get, set

Property Value

Type: Pcf85063aTypeControl1CapSel
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Control1CIE Property

IRD

Pcf85063aControl1CIE Property

Control 1: CIE

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeControl1Cie Control1CIE { get; set; }
Public Property Control1CIE As Pcf85063aTypeControl1Cie
    Get
    Set
public:
property Pcf85063aTypeControl1Cie Control1CIE {
    Pcf85063aTypeControl1Cie get ();
    void set (Pcf85063aTypeControl1Cie value);
}
member Control1CIE : Pcf85063aTypeControl1Cie with get, set

Property Value

Type: Pcf85063aTypeControl1Cie
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Control1EXTTEST Property

IRD

Pcf85063aControl1EXTTEST Property

Control 1: EXT_TEST

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeControl1ExtTest Control1EXTTEST { get; set; }
Public Property Control1EXTTEST As Pcf85063aTypeControl1ExtTest
    Get
    Set
public:
property Pcf85063aTypeControl1ExtTest Control1EXTTEST {
    Pcf85063aTypeControl1ExtTest get ();
    void set (Pcf85063aTypeControl1ExtTest value);
}
member Control1EXTTEST : Pcf85063aTypeControl1ExtTest with get, set

Property Value

Type: Pcf85063aTypeControl1ExtTest
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Control1SR Property

IRD

Pcf85063aControl1SR Property

Control 1: SR

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeControl1Sr Control1SR { get; set; }
Public Property Control1SR As Pcf85063aTypeControl1Sr
    Get
    Set
public:
property Pcf85063aTypeControl1Sr Control1SR {
    Pcf85063aTypeControl1Sr get ();
    void set (Pcf85063aTypeControl1Sr value);
}
member Control1SR : Pcf85063aTypeControl1Sr with get, set

Property Value

Type: Pcf85063aTypeControl1Sr
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Control1STOP Property

IRD

Pcf85063aControl1STOP Property

Control 1: STOP

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeControl1Stop Control1STOP { get; set; }
Public Property Control1STOP As Pcf85063aTypeControl1Stop
    Get
    Set
public:
property Pcf85063aTypeControl1Stop Control1STOP {
    Pcf85063aTypeControl1Stop get ();
    void set (Pcf85063aTypeControl1Stop value);
}
member Control1STOP : Pcf85063aTypeControl1Stop with get, set

Property Value

Type: Pcf85063aTypeControl1Stop
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Control2AF Property

IRD

Pcf85063aControl2AF Property

Control 2: AF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeControl2Af Control2AF { get; set; }
Public Property Control2AF As Pcf85063aTypeControl2Af
    Get
    Set
public:
property Pcf85063aTypeControl2Af Control2AF {
    Pcf85063aTypeControl2Af get ();
    void set (Pcf85063aTypeControl2Af value);
}
member Control2AF : Pcf85063aTypeControl2Af with get, set

Property Value

Type: Pcf85063aTypeControl2Af
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Control2AIE Property

IRD

Pcf85063aControl2AIE Property

Control 2: AIE

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeControl2Aie Control2AIE { get; set; }
Public Property Control2AIE As Pcf85063aTypeControl2Aie
    Get
    Set
public:
property Pcf85063aTypeControl2Aie Control2AIE {
    Pcf85063aTypeControl2Aie get ();
    void set (Pcf85063aTypeControl2Aie value);
}
member Control2AIE : Pcf85063aTypeControl2Aie with get, set

Property Value

Type: Pcf85063aTypeControl2Aie
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Control2COF Property

IRD

Pcf85063aControl2COF Property

Control 2: COF (unit: Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeControl2Cof Control2COF { get; set; }
Public Property Control2COF As Pcf85063aTypeControl2Cof
    Get
    Set
public:
property Pcf85063aTypeControl2Cof Control2COF {
    Pcf85063aTypeControl2Cof get ();
    void set (Pcf85063aTypeControl2Cof value);
}
member Control2COF : Pcf85063aTypeControl2Cof with get, set

Property Value

Type: Pcf85063aTypeControl2Cof
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Control2HMI Property

IRD

Pcf85063aControl2HMI Property

Control 2: HMI

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeControl2Hmi Control2HMI { get; set; }
Public Property Control2HMI As Pcf85063aTypeControl2Hmi
    Get
    Set
public:
property Pcf85063aTypeControl2Hmi Control2HMI {
    Pcf85063aTypeControl2Hmi get ();
    void set (Pcf85063aTypeControl2Hmi value);
}
member Control2HMI : Pcf85063aTypeControl2Hmi with get, set

Property Value

Type: Pcf85063aTypeControl2Hmi
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Control2MI Property

IRD

Pcf85063aControl2MI Property

Control 2: MI

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeControl2Mi Control2MI { get; set; }
Public Property Control2MI As Pcf85063aTypeControl2Mi
    Get
    Set
public:
property Pcf85063aTypeControl2Mi Control2MI {
    Pcf85063aTypeControl2Mi get ();
    void set (Pcf85063aTypeControl2Mi value);
}
member Control2MI : Pcf85063aTypeControl2Mi with get, set

Property Value

Type: Pcf85063aTypeControl2Mi
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Control2TF Property

IRD

Pcf85063aControl2TF Property

Control 2: TF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeControl2Tf Control2TF { get; set; }
Public Property Control2TF As Pcf85063aTypeControl2Tf
    Get
    Set
public:
property Pcf85063aTypeControl2Tf Control2TF {
    Pcf85063aTypeControl2Tf get ();
    void set (Pcf85063aTypeControl2Tf value);
}
member Control2TF : Pcf85063aTypeControl2Tf with get, set

Property Value

Type: Pcf85063aTypeControl2Tf
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.DayAlarmAEND Property

IRD

Pcf85063aDayAlarmAEND Property

Day Alarm: AEN_D

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeAlarmEnabledDisabled DayAlarmAEND { get; set; }
Public Property DayAlarmAEND As Pcf85063aTypeAlarmEnabledDisabled
    Get
    Set
public:
property Pcf85063aTypeAlarmEnabledDisabled DayAlarmAEND {
    Pcf85063aTypeAlarmEnabledDisabled get ();
    void set (Pcf85063aTypeAlarmEnabledDisabled value);
}
member DayAlarmAEND : Pcf85063aTypeAlarmEnabledDisabled with get, set

Property Value

Type: Pcf85063aTypeAlarmEnabledDisabled
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.DayAlarmDAYALARM Property

IRD

Pcf85063aDayAlarmDAYALARM Property

Day Alarm: DAY_ALARM

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DayAlarmDAYALARM { get; set; }
Public Property DayAlarmDAYALARM As Byte
    Get
    Set
public:
property unsigned char DayAlarmDAYALARM {
    unsigned char get ();
    void set (unsigned char value);
}
member DayAlarmDAYALARM : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Days Property

IRD

Pcf85063aDays Property

Days

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Days { get; set; }
Public Property Days As Byte
    Get
    Set
public:
property unsigned char Days {
    unsigned char get ();
    void set (unsigned char value);
}
member Days : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.HourAlarmAENH Property

IRD

Pcf85063aHourAlarmAENH Property

Hour Alarm: AEN_H

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeAlarmEnabledDisabled HourAlarmAENH { get; set; }
Public Property HourAlarmAENH As Pcf85063aTypeAlarmEnabledDisabled
    Get
    Set
public:
property Pcf85063aTypeAlarmEnabledDisabled HourAlarmAENH {
    Pcf85063aTypeAlarmEnabledDisabled get ();
    void set (Pcf85063aTypeAlarmEnabledDisabled value);
}
member HourAlarmAENH : Pcf85063aTypeAlarmEnabledDisabled with get, set

Property Value

Type: Pcf85063aTypeAlarmEnabledDisabled
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.HourAlarmHOURALARM Property

IRD

Pcf85063aHourAlarmHOURALARM Property

Hour Alarm: HOUR_ALARM

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte HourAlarmHOURALARM { get; set; }
Public Property HourAlarmHOURALARM As Byte
    Get
    Set
public:
property unsigned char HourAlarmHOURALARM {
    unsigned char get ();
    void set (unsigned char value);
}
member HourAlarmHOURALARM : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Hours Property

IRD

Pcf85063aHours Property

Hours

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Hours { get; set; }
Public Property Hours As Byte
    Get
    Set
public:
property unsigned char Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.MinuteAlarmAENM Property

IRD

Pcf85063aMinuteAlarmAENM Property

Minute Alarm: AEN_M

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeAlarmEnabledDisabled MinuteAlarmAENM { get; set; }
Public Property MinuteAlarmAENM As Pcf85063aTypeAlarmEnabledDisabled
    Get
    Set
public:
property Pcf85063aTypeAlarmEnabledDisabled MinuteAlarmAENM {
    Pcf85063aTypeAlarmEnabledDisabled get ();
    void set (Pcf85063aTypeAlarmEnabledDisabled value);
}
member MinuteAlarmAENM : Pcf85063aTypeAlarmEnabledDisabled with get, set

Property Value

Type: Pcf85063aTypeAlarmEnabledDisabled
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.MinuteAlarmMINUTEALARM Property

IRD

Pcf85063aMinuteAlarmMINUTEALARM Property

Minute Alarm: MINUTE_ALARM

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MinuteAlarmMINUTEALARM { get; set; }
Public Property MinuteAlarmMINUTEALARM As Byte
    Get
    Set
public:
property unsigned char MinuteAlarmMINUTEALARM {
    unsigned char get ();
    void set (unsigned char value);
}
member MinuteAlarmMINUTEALARM : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Minutes Property

IRD

Pcf85063aMinutes Property

Minutes

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Minutes { get; set; }
Public Property Minutes As Byte
    Get
    Set
public:
property unsigned char Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Months Property

IRD

Pcf85063aMonths Property

Months

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeMonths Months { get; set; }
Public Property Months As Pcf85063aTypeMonths
    Get
    Set
public:
property Pcf85063aTypeMonths Months {
    Pcf85063aTypeMonths get ();
    void set (Pcf85063aTypeMonths value);
}
member Months : Pcf85063aTypeMonths with get, set

Property Value

Type: Pcf85063aTypeMonths
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.OffsetMODE Property

IRD

Pcf85063aOffsetMODE Property

Offset: MODE

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeOffsetMode OffsetMODE { get; set; }
Public Property OffsetMODE As Pcf85063aTypeOffsetMode
    Get
    Set
public:
property Pcf85063aTypeOffsetMode OffsetMODE {
    Pcf85063aTypeOffsetMode get ();
    void set (Pcf85063aTypeOffsetMode value);
}
member OffsetMODE : Pcf85063aTypeOffsetMode with get, set

Property Value

Type: Pcf85063aTypeOffsetMode
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.OffsetOFFSET Property

IRD

Pcf85063aOffsetOFFSET Property

Offset: OFFSET

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte OffsetOFFSET { get; set; }
Public Property OffsetOFFSET As SByte
    Get
    Set
public:
property signed char OffsetOFFSET {
    signed char get ();
    void set (signed char value);
}
member OffsetOFFSET : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.RAM Property

IRD

Pcf85063aRAM Property

RAM

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RAM { get; set; }
Public Property RAM As Byte
    Get
    Set
public:
property unsigned char RAM {
    unsigned char get ();
    void set (unsigned char value);
}
member RAM : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.SecondAlarmAENS Property

IRD

Pcf85063aSecondAlarmAENS Property

Second Alarm: AEN_S

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeAlarmEnabledDisabled SecondAlarmAENS { get; set; }
Public Property SecondAlarmAENS As Pcf85063aTypeAlarmEnabledDisabled
    Get
    Set
public:
property Pcf85063aTypeAlarmEnabledDisabled SecondAlarmAENS {
    Pcf85063aTypeAlarmEnabledDisabled get ();
    void set (Pcf85063aTypeAlarmEnabledDisabled value);
}
member SecondAlarmAENS : Pcf85063aTypeAlarmEnabledDisabled with get, set

Property Value

Type: Pcf85063aTypeAlarmEnabledDisabled
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.SecondAlarmSECONDALARM Property

IRD

Pcf85063aSecondAlarmSECONDALARM Property

Second Alarm: SECOND_ALARM

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SecondAlarmSECONDALARM { get; set; }
Public Property SecondAlarmSECONDALARM As Byte
    Get
    Set
public:
property unsigned char SecondAlarmSECONDALARM {
    unsigned char get ();
    void set (unsigned char value);
}
member SecondAlarmSECONDALARM : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.SecondsOS Property

IRD

Pcf85063aSecondsOS Property

Seconds: OS

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeSecondsOs SecondsOS { get; set; }
Public Property SecondsOS As Pcf85063aTypeSecondsOs
    Get
    Set
public:
property Pcf85063aTypeSecondsOs SecondsOS {
    Pcf85063aTypeSecondsOs get ();
    void set (Pcf85063aTypeSecondsOs value);
}
member SecondsOS : Pcf85063aTypeSecondsOs with get, set

Property Value

Type: Pcf85063aTypeSecondsOs
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.SecondsSECONDS Property

IRD

Pcf85063aSecondsSECONDS Property

Seconds: SECONDS

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SecondsSECONDS { get; set; }
Public Property SecondsSECONDS As Byte
    Get
    Set
public:
property unsigned char SecondsSECONDS {
    unsigned char get ();
    void set (unsigned char value);
}
member SecondsSECONDS : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TimerModeTCF Property

IRD

Pcf85063aTimerModeTCF Property

Timer Mode: TCF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeTimerModeTcf TimerModeTCF { get; set; }
Public Property TimerModeTCF As Pcf85063aTypeTimerModeTcf
    Get
    Set
public:
property Pcf85063aTypeTimerModeTcf TimerModeTCF {
    Pcf85063aTypeTimerModeTcf get ();
    void set (Pcf85063aTypeTimerModeTcf value);
}
member TimerModeTCF : Pcf85063aTypeTimerModeTcf with get, set

Property Value

Type: Pcf85063aTypeTimerModeTcf
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TimerModeTE Property

IRD

Pcf85063aTimerModeTE Property

Timer Mode: TE

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeTimerModeTe TimerModeTE { get; set; }
Public Property TimerModeTE As Pcf85063aTypeTimerModeTe
    Get
    Set
public:
property Pcf85063aTypeTimerModeTe TimerModeTE {
    Pcf85063aTypeTimerModeTe get ();
    void set (Pcf85063aTypeTimerModeTe value);
}
member TimerModeTE : Pcf85063aTypeTimerModeTe with get, set

Property Value

Type: Pcf85063aTypeTimerModeTe
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TimerModeTIE Property

IRD

Pcf85063aTimerModeTIE Property

Timer Mode: TIE

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeTimerModeTie TimerModeTIE { get; set; }
Public Property TimerModeTIE As Pcf85063aTypeTimerModeTie
    Get
    Set
public:
property Pcf85063aTypeTimerModeTie TimerModeTIE {
    Pcf85063aTypeTimerModeTie get ();
    void set (Pcf85063aTypeTimerModeTie value);
}
member TimerModeTIE : Pcf85063aTypeTimerModeTie with get, set

Property Value

Type: Pcf85063aTypeTimerModeTie
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TimerModeTITP Property

IRD

Pcf85063aTimerModeTITP Property

Timer Mode: TI_TP

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeTimerModeTiTp TimerModeTITP { get; set; }
Public Property TimerModeTITP As Pcf85063aTypeTimerModeTiTp
    Get
    Set
public:
property Pcf85063aTypeTimerModeTiTp TimerModeTITP {
    Pcf85063aTypeTimerModeTiTp get ();
    void set (Pcf85063aTypeTimerModeTiTp value);
}
member TimerModeTITP : Pcf85063aTypeTimerModeTiTp with get, set

Property Value

Type: Pcf85063aTypeTimerModeTiTp
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TimerValue Property

IRD

Pcf85063aTimerValue Property

Timer Value

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TimerValue { get; set; }
Public Property TimerValue As Byte
    Get
    Set
public:
property unsigned char TimerValue {
    unsigned char get ();
    void set (unsigned char value);
}
member TimerValue : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.WeekdayAlarmAENW Property

IRD

Pcf85063aWeekdayAlarmAENW Property

Weekday Alarm: AEN_W

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeAlarmEnabledDisabled WeekdayAlarmAENW { get; set; }
Public Property WeekdayAlarmAENW As Pcf85063aTypeAlarmEnabledDisabled
    Get
    Set
public:
property Pcf85063aTypeAlarmEnabledDisabled WeekdayAlarmAENW {
    Pcf85063aTypeAlarmEnabledDisabled get ();
    void set (Pcf85063aTypeAlarmEnabledDisabled value);
}
member WeekdayAlarmAENW : Pcf85063aTypeAlarmEnabledDisabled with get, set

Property Value

Type: Pcf85063aTypeAlarmEnabledDisabled
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.WeekdayAlarmWEEKDAYALARM Property

IRD

Pcf85063aWeekdayAlarmWEEKDAYALARM Property

Weekday Alarm: WEEKDAY_ALARM

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeWeekdays WeekdayAlarmWEEKDAYALARM { get; set; }
Public Property WeekdayAlarmWEEKDAYALARM As Pcf85063aTypeWeekdays
    Get
    Set
public:
property Pcf85063aTypeWeekdays WeekdayAlarmWEEKDAYALARM {
    Pcf85063aTypeWeekdays get ();
    void set (Pcf85063aTypeWeekdays value);
}
member WeekdayAlarmWEEKDAYALARM : Pcf85063aTypeWeekdays with get, set

Property Value

Type: Pcf85063aTypeWeekdays
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Weekdays Property

IRD

Pcf85063aWeekdays Property

Weekdays

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063aTypeWeekdays Weekdays { get; set; }
Public Property Weekdays As Pcf85063aTypeWeekdays
    Get
    Set
public:
property Pcf85063aTypeWeekdays Weekdays {
    Pcf85063aTypeWeekdays get ();
    void set (Pcf85063aTypeWeekdays value);
}
member Weekdays : Pcf85063aTypeWeekdays with get, set

Property Value

Type: Pcf85063aTypeWeekdays
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Years Property

IRD

Pcf85063aYears Property

Years

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Years { get; set; }
Public Property Years As Byte
    Get
    Set
public:
property unsigned char Years {
    unsigned char get ();
    void set (unsigned char value);
}
member Years : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a Methods

The Pcf85063a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.Flush Method

IRD

Pcf85063aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcf85063a Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeAlarmEnabledDisabled Enumeration

IRD

Pcf85063aTypeAlarmEnabledDisabled Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlarmEnabledDisabled
Public Enumeration TypeAlarmEnabledDisabled
public enum class TypeAlarmEnabledDisabled
type TypeAlarmEnabledDisabled
Members
Member name | Value | Description
AlarmEnabled | 0 | Alarm: Enabled
AlarmDisabled | 1 | Alarm: Disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeControl11224 Enumeration

IRD

Pcf85063aTypeControl11224 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl11224
Public Enumeration TypeControl11224
public enum class TypeControl11224
type TypeControl11224
Members
Member name | Value | Description
Value_24HourMode | 0 | 24-Hour Mode
Value_12HourMode | 1 | 12-Hour Mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeControl1CapSel Enumeration

IRD

Pcf85063aTypeControl1CapSel Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1CapSel
Public Enumeration TypeControl1CapSel
public enum class TypeControl1CapSel
type TypeControl1CapSel
Members
Member name | Value | Description
Value_7PF | 0 | 7 pF
Value_125PF | 1 | 12.5 pF
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeControl1Cie Enumeration

IRD

Pcf85063aTypeControl1Cie Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Cie
Public Enumeration TypeControl1Cie
public enum class TypeControl1Cie
type TypeControl1Cie
Members
Member name | Value | Description
CorrectionInterruptNotGenerated | 0 | Correction Interrupt: Not Generated
CorrectionInterruptGenerated | 1 | Correction Interrupt: Generated
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeControl1ExtTest Enumeration

IRD

Pcf85063aTypeControl1ExtTest Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1ExtTest
Public Enumeration TypeControl1ExtTest
public enum class TypeControl1ExtTest
type TypeControl1ExtTest
Members
Member name | Value | Description
NormalMode | 0 | Normal Mode
ExternalClockTestMode | 1 | External Clock Test Mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeControl1Sr Enumeration

IRD

Pcf85063aTypeControl1Sr Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Sr
Public Enumeration TypeControl1Sr
public enum class TypeControl1Sr
type TypeControl1Sr
Members
Member name | Value | Description
SoftwareResetNone | 0 | Software Reset: None
SoftwareResetInitiate | 1 | Software Reset: Initiate
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeControl1Stop Enumeration

IRD

Pcf85063aTypeControl1Stop Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Stop
Public Enumeration TypeControl1Stop
public enum class TypeControl1Stop
type TypeControl1Stop
Members
Member name | Value | Description
RTCClockRuns | 0 | RTC Clock: Runs
RTCClockStopped | 1 | RTC Clock: Stopped
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeControl2Af Enumeration

IRD

Pcf85063aTypeControl2Af Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Af
Public Enumeration TypeControl2Af
public enum class TypeControl2Af
type TypeControl2Af
Members
Member name | Value | Description
AlarmFlagInactiveClear | 0 | Alarm Flag: Inactive/Clear
AlarmFlagActiveUnchanged | 1 | Alarm Flag: Active/Unchanged
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeControl2Aie Enumeration

IRD

Pcf85063aTypeControl2Aie Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Aie
Public Enumeration TypeControl2Aie
public enum class TypeControl2Aie
type TypeControl2Aie
Members
Member name | Value | Description
AlarmInterruptDisabled | 0 | Alarm Interrupt: Disabled
AlarmInterruptEnabled | 1 | Alarm Interrupt: Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeControl2Cof Enumeration

IRD

Pcf85063aTypeControl2Cof Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Cof
Public Enumeration TypeControl2Cof
public enum class TypeControl2Cof
type TypeControl2Cof
Members
Member name | Value | Description
Value_32768 | 0 | 32768
Value_16384 | 1 | 16384
Value_8192 | 2 | 8192
Value_4096 | 3 | 4096
Value_2048 | 4 | 2048
Value_1024 | 5 | 1024
Value_1 | 6 | 1
LOW | 7 | LOW
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeControl2Hmi Enumeration

IRD

Pcf85063aTypeControl2Hmi Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Hmi
Public Enumeration TypeControl2Hmi
public enum class TypeControl2Hmi
type TypeControl2Hmi
Members
Member name | Value | Description
HalfMinuteInterruptDisabled | 0 | Half Minute Interrupt: Disabled
HalfMinuteInterruptEnabled | 1 | Half Minute Interrupt: Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeControl2Mi Enumeration

IRD

Pcf85063aTypeControl2Mi Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Mi
Public Enumeration TypeControl2Mi
public enum class TypeControl2Mi
type TypeControl2Mi
Members
Member name | Value | Description
MinuteInterruptDisabled | 0 | Minute Interrupt: Disabled
MinuteInterruptEnabled | 1 | Minute Interrupt: Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeControl2Tf Enumeration

IRD

Pcf85063aTypeControl2Tf Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Tf
Public Enumeration TypeControl2Tf
public enum class TypeControl2Tf
type TypeControl2Tf
Members
Member name | Value | Description
TimerFlagNotSet | 0 | Timer Flag: Not Set
TimerFlagSet | 1 | Timer Flag: Set
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeMonths Enumeration

IRD

Pcf85063aTypeMonths Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMonths
Public Enumeration TypeMonths
public enum class TypeMonths
type TypeMonths
Members
Member name | Value | Description
January | 1 | January
February | 2 | February
March | 3 | March
April | 4 | April
May | 5 | May
June | 6 | June
July | 7 | July
August | 8 | August
September | 9 | September
October | 10 | October
November | 11 | November
December | 12 | December
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeOffsetMode Enumeration

IRD

Pcf85063aTypeOffsetMode Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOffsetMode
Public Enumeration TypeOffsetMode
public enum class TypeOffsetMode
type TypeOffsetMode
Members
Member name | Value | Description
NormalMode | 0 | Normal Mode
CourseMode | 1 | Course Mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeSecondsOs Enumeration

IRD

Pcf85063aTypeSecondsOs Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSecondsOs
Public Enumeration TypeSecondsOs
public enum class TypeSecondsOs
type TypeSecondsOs
Members
Member name | Value | Description
ClockIntegrityGuaranteed | 0 | Clock Integrity: Guaranteed
ClockIntegrityNotGuaranteed | 1 | Clock Integrity: Not Guaranteed
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeTimerModeTcf Enumeration

IRD

Pcf85063aTypeTimerModeTcf Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerModeTcf
Public Enumeration TypeTimerModeTcf
public enum class TypeTimerModeTcf
type TypeTimerModeTcf
Members
Member name | Value | Description
Value_4096KHz | 0 | 4.096 kHz
Value_64Hz | 1 | 64 Hz
Value_1Hz | 2 | 1 Hz
Value_160Hz | 3 | 1/60 Hz
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeTimerModeTe Enumeration

IRD

Pcf85063aTypeTimerModeTe Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerModeTe
Public Enumeration TypeTimerModeTe
public enum class TypeTimerModeTe
type TypeTimerModeTe
Members
Member name | Value | Description
TimerDisabled | 0 | Timer: Disabled
TimerEnabled | 1 | Timer: Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeTimerModeTie Enumeration

IRD

Pcf85063aTypeTimerModeTie Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerModeTie
Public Enumeration TypeTimerModeTie
public enum class TypeTimerModeTie
type TypeTimerModeTie
Members
Member name | Value | Description
TimerInterruptDisabled | 0 | Timer Interrupt: Disabled
TimerInterruptEnabled | 1 | Timer Interrupt: Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeTimerModeTiTp Enumeration

IRD

Pcf85063aTypeTimerModeTiTp Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimerModeTiTp
Public Enumeration TypeTimerModeTiTp
public enum class TypeTimerModeTiTp
type TypeTimerModeTiTp
Members
Member name | Value | Description
TimerInteruptModeFollowsTimerFlag | 0 | Timer Interupt Mode: Follows Timer Flag
TimerInteruptModeGeneratesPulse | 1 | Timer Interupt Mode: Generates Pulse
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063a.TypeWeekdays Enumeration

IRD

Pcf85063aTypeWeekdays Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeWeekdays
Public Enumeration TypeWeekdays
public enum class TypeWeekdays
type TypeWeekdays
Members
Member name | Value | Description
Sunday | 0 | Sunday
Monday | 1 | Monday
Tuesday | 2 | Tuesday
Wednesday | 3 | Wednesday
Thursday | 4 | Thursday
Friday | 5 | Friday
Saturday | 6 | Saturday
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063tp Class

NXP Semiconductors: PCF 85063TP
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPcf85063tp

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcf85063tp
Public Class Pcf85063tp
public ref class Pcf85063tp
type Pcf85063tp =  class end

The Pcf85063tp type exposes the following members.

Constructors
 | Name | Description
Public method | Pcf85063tp | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Control11224 | Control 1: 12_24
Public property | Control1CAPSEL | Control 1: CAP_SEL
Public property | Control1CIE | Control 1: CIE
Public property | Control1EXTTEST | Control 1: EXT_TEST
Public property | Control1SR | Control 1: SR
Public property | Control1STOP | Control 1: STOP
Public property | Control2COF | Control 2: COF (unit: Hz)
Public property | Control2HMI | Control 2: HMI
Public property | Control2MI | Control 2: MI
Public property | Control2TF | Control 2: TF
Public property | Days | Days
Public property | Hours | Hours
Public property | Minutes | Minutes
Public property | Months | Months
Public property | OffsetMODE | Offset: MODE
Public property | OffsetOFFSET | Offset: OFFSET
Public property | RAM | RAM
Public property | SecondsOS | Seconds: OS
Public property | SecondsSECONDS | Seconds: SECONDS
Public property | Weekdays | Weekdays
Public property | Years | Years
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Tiny Real-Time Clock/Calendar
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063tp Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063tp(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcf85063tp(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcf85063tp

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp Properties

The Pcf85063tp type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Control11224 | Control 1: 12_24
Public property | Control1CAPSEL | Control 1: CAP_SEL
Public property | Control1CIE | Control 1: CIE
Public property | Control1EXTTEST | Control 1: EXT_TEST
Public property | Control1SR | Control 1: SR
Public property | Control1STOP | Control 1: STOP
Public property | Control2COF | Control 2: COF (unit: Hz)
Public property | Control2HMI | Control 2: HMI
Public property | Control2MI | Control 2: MI
Public property | Control2TF | Control 2: TF
Public property | Days | Days
Public property | Hours | Hours
Public property | Minutes | Minutes
Public property | Months | Months
Public property | OffsetMODE | Offset: MODE
Public property | OffsetOFFSET | Offset: OFFSET
Public property | RAM | RAM
Public property | SecondsOS | Seconds: OS
Public property | SecondsSECONDS | Seconds: SECONDS
Public property | Weekdays | Weekdays
Public property | Years | Years
Top
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.AutoFlush Property

IRD

Pcf85063tpAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.Control11224 Property

IRD

Pcf85063tpControl11224 Property

Control 1: 12_24

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063tpTypeControl11224 Control11224 { get; set; }
Public Property Control11224 As Pcf85063tpTypeControl11224
    Get
    Set
public:
property Pcf85063tpTypeControl11224 Control11224 {
    Pcf85063tpTypeControl11224 get ();
    void set (Pcf85063tpTypeControl11224 value);
}
member Control11224 : Pcf85063tpTypeControl11224 with get, set

Property Value

Type: Pcf85063tpTypeControl11224
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.Control1CAPSEL Property

IRD

Pcf85063tpControl1CAPSEL Property

Control 1: CAP_SEL

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063tpTypeControl1CapSel Control1CAPSEL { get; set; }
Public Property Control1CAPSEL As Pcf85063tpTypeControl1CapSel
    Get
    Set
public:
property Pcf85063tpTypeControl1CapSel Control1CAPSEL {
    Pcf85063tpTypeControl1CapSel get ();
    void set (Pcf85063tpTypeControl1CapSel value);
}
member Control1CAPSEL : Pcf85063tpTypeControl1CapSel with get, set

Property Value

Type: Pcf85063tpTypeControl1CapSel
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.Control1CIE Property

IRD

Pcf85063tpControl1CIE Property

Control 1: CIE

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063tpTypeControl1Cie Control1CIE { get; set; }
Public Property Control1CIE As Pcf85063tpTypeControl1Cie
    Get
    Set
public:
property Pcf85063tpTypeControl1Cie Control1CIE {
    Pcf85063tpTypeControl1Cie get ();
    void set (Pcf85063tpTypeControl1Cie value);
}
member Control1CIE : Pcf85063tpTypeControl1Cie with get, set

Property Value

Type: Pcf85063tpTypeControl1Cie
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.Control1EXTTEST Property

IRD

Pcf85063tpControl1EXTTEST Property

Control 1: EXT_TEST

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063tpTypeControl1ExtTest Control1EXTTEST { get; set; }
Public Property Control1EXTTEST As Pcf85063tpTypeControl1ExtTest
    Get
    Set
public:
property Pcf85063tpTypeControl1ExtTest Control1EXTTEST {
    Pcf85063tpTypeControl1ExtTest get ();
    void set (Pcf85063tpTypeControl1ExtTest value);
}
member Control1EXTTEST : Pcf85063tpTypeControl1ExtTest with get, set

Property Value

Type: Pcf85063tpTypeControl1ExtTest
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.Control1SR Property

IRD

Pcf85063tpControl1SR Property

Control 1: SR

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063tpTypeControl1Sr Control1SR { get; set; }
Public Property Control1SR As Pcf85063tpTypeControl1Sr
    Get
    Set
public:
property Pcf85063tpTypeControl1Sr Control1SR {
    Pcf85063tpTypeControl1Sr get ();
    void set (Pcf85063tpTypeControl1Sr value);
}
member Control1SR : Pcf85063tpTypeControl1Sr with get, set

Property Value

Type: Pcf85063tpTypeControl1Sr
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.Control1STOP Property

IRD

Pcf85063tpControl1STOP Property

Control 1: STOP

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063tpTypeControl1Stop Control1STOP { get; set; }
Public Property Control1STOP As Pcf85063tpTypeControl1Stop
    Get
    Set
public:
property Pcf85063tpTypeControl1Stop Control1STOP {
    Pcf85063tpTypeControl1Stop get ();
    void set (Pcf85063tpTypeControl1Stop value);
}
member Control1STOP : Pcf85063tpTypeControl1Stop with get, set

Property Value

Type: Pcf85063tpTypeControl1Stop
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.Control2COF Property

IRD

Pcf85063tpControl2COF Property

Control 2: COF (unit: Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063tpTypeControl2Cof Control2COF { get; set; }
Public Property Control2COF As Pcf85063tpTypeControl2Cof
    Get
    Set
public:
property Pcf85063tpTypeControl2Cof Control2COF {
    Pcf85063tpTypeControl2Cof get ();
    void set (Pcf85063tpTypeControl2Cof value);
}
member Control2COF : Pcf85063tpTypeControl2Cof with get, set

Property Value

Type: Pcf85063tpTypeControl2Cof
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.Control2HMI Property

IRD

Pcf85063tpControl2HMI Property

Control 2: HMI

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063tpTypeControl2Hmi Control2HMI { get; set; }
Public Property Control2HMI As Pcf85063tpTypeControl2Hmi
    Get
    Set
public:
property Pcf85063tpTypeControl2Hmi Control2HMI {
    Pcf85063tpTypeControl2Hmi get ();
    void set (Pcf85063tpTypeControl2Hmi value);
}
member Control2HMI : Pcf85063tpTypeControl2Hmi with get, set

Property Value

Type: Pcf85063tpTypeControl2Hmi
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.Control2MI Property

IRD

Pcf85063tpControl2MI Property

Control 2: MI

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063tpTypeControl2Mi Control2MI { get; set; }
Public Property Control2MI As Pcf85063tpTypeControl2Mi
    Get
    Set
public:
property Pcf85063tpTypeControl2Mi Control2MI {
    Pcf85063tpTypeControl2Mi get ();
    void set (Pcf85063tpTypeControl2Mi value);
}
member Control2MI : Pcf85063tpTypeControl2Mi with get, set

Property Value

Type: Pcf85063tpTypeControl2Mi
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.Control2TF Property

IRD

Pcf85063tpControl2TF Property

Control 2: TF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063tpTypeControl2Tf Control2TF { get; set; }
Public Property Control2TF As Pcf85063tpTypeControl2Tf
    Get
    Set
public:
property Pcf85063tpTypeControl2Tf Control2TF {
    Pcf85063tpTypeControl2Tf get ();
    void set (Pcf85063tpTypeControl2Tf value);
}
member Control2TF : Pcf85063tpTypeControl2Tf with get, set

Property Value

Type: Pcf85063tpTypeControl2Tf
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.Days Property

IRD

Pcf85063tpDays Property

Days

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Days { get; set; }
Public Property Days As Byte
    Get
    Set
public:
property unsigned char Days {
    unsigned char get ();
    void set (unsigned char value);
}
member Days : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.Hours Property

IRD

Pcf85063tpHours Property

Hours

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Hours { get; set; }
Public Property Hours As Byte
    Get
    Set
public:
property unsigned char Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.Minutes Property

IRD

Pcf85063tpMinutes Property

Minutes

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Minutes { get; set; }
Public Property Minutes As Byte
    Get
    Set
public:
property unsigned char Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.Months Property

IRD

Pcf85063tpMonths Property

Months

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063tpTypeMonths Months { get; set; }
Public Property Months As Pcf85063tpTypeMonths
    Get
    Set
public:
property Pcf85063tpTypeMonths Months {
    Pcf85063tpTypeMonths get ();
    void set (Pcf85063tpTypeMonths value);
}
member Months : Pcf85063tpTypeMonths with get, set

Property Value

Type: Pcf85063tpTypeMonths
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.OffsetMODE Property

IRD

Pcf85063tpOffsetMODE Property

Offset: MODE

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063tpTypeOffsetMode OffsetMODE { get; set; }
Public Property OffsetMODE As Pcf85063tpTypeOffsetMode
    Get
    Set
public:
property Pcf85063tpTypeOffsetMode OffsetMODE {
    Pcf85063tpTypeOffsetMode get ();
    void set (Pcf85063tpTypeOffsetMode value);
}
member OffsetMODE : Pcf85063tpTypeOffsetMode with get, set

Property Value

Type: Pcf85063tpTypeOffsetMode
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.OffsetOFFSET Property

IRD

Pcf85063tpOffsetOFFSET Property

Offset: OFFSET

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte OffsetOFFSET { get; set; }
Public Property OffsetOFFSET As SByte
    Get
    Set
public:
property signed char OffsetOFFSET {
    signed char get ();
    void set (signed char value);
}
member OffsetOFFSET : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.RAM Property

IRD

Pcf85063tpRAM Property

RAM

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RAM { get; set; }
Public Property RAM As Byte
    Get
    Set
public:
property unsigned char RAM {
    unsigned char get ();
    void set (unsigned char value);
}
member RAM : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.SecondsOS Property

IRD

Pcf85063tpSecondsOS Property

Seconds: OS

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063tpTypeSecondsOs SecondsOS { get; set; }
Public Property SecondsOS As Pcf85063tpTypeSecondsOs
    Get
    Set
public:
property Pcf85063tpTypeSecondsOs SecondsOS {
    Pcf85063tpTypeSecondsOs get ();
    void set (Pcf85063tpTypeSecondsOs value);
}
member SecondsOS : Pcf85063tpTypeSecondsOs with get, set

Property Value

Type: Pcf85063tpTypeSecondsOs
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.SecondsSECONDS Property

IRD

Pcf85063tpSecondsSECONDS Property

Seconds: SECONDS

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SecondsSECONDS { get; set; }
Public Property SecondsSECONDS As Byte
    Get
    Set
public:
property unsigned char SecondsSECONDS {
    unsigned char get ();
    void set (unsigned char value);
}
member SecondsSECONDS : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.Weekdays Property

IRD

Pcf85063tpWeekdays Property

Weekdays

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcf85063tpTypeWeekdays Weekdays { get; set; }
Public Property Weekdays As Pcf85063tpTypeWeekdays
    Get
    Set
public:
property Pcf85063tpTypeWeekdays Weekdays {
    Pcf85063tpTypeWeekdays get ();
    void set (Pcf85063tpTypeWeekdays value);
}
member Weekdays : Pcf85063tpTypeWeekdays with get, set

Property Value

Type: Pcf85063tpTypeWeekdays
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.Years Property

IRD

Pcf85063tpYears Property

Years

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Years { get; set; }
Public Property Years As Byte
    Get
    Set
public:
property unsigned char Years {
    unsigned char get ();
    void set (unsigned char value);
}
member Years : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp Methods

The Pcf85063tp type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.Flush Method

IRD

Pcf85063tpFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcf85063tp Class
telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.TypeControl11224 Enumeration

IRD

Pcf85063tpTypeControl11224 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl11224
Public Enumeration TypeControl11224
public enum class TypeControl11224
type TypeControl11224
Members
Member name | Value | Description
Value_24HourMode | 0 | 24-Hour Mode
Value_12HourMode | 1 | 12-Hour Mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.TypeControl1CapSel Enumeration

IRD

Pcf85063tpTypeControl1CapSel Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1CapSel
Public Enumeration TypeControl1CapSel
public enum class TypeControl1CapSel
type TypeControl1CapSel
Members
Member name | Value | Description
Value_7PF | 0 | 7 pF
Value_125PF | 1 | 12.5 pF
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.TypeControl1Cie Enumeration

IRD

Pcf85063tpTypeControl1Cie Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Cie
Public Enumeration TypeControl1Cie
public enum class TypeControl1Cie
type TypeControl1Cie
Members
Member name | Value | Description
CorrectionInterruptNotGenerated | 0 | Correction Interrupt: Not Generated
CorrectionInterruptGenerated | 1 | Correction Interrupt: Generated
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.TypeControl1ExtTest Enumeration

IRD

Pcf85063tpTypeControl1ExtTest Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1ExtTest
Public Enumeration TypeControl1ExtTest
public enum class TypeControl1ExtTest
type TypeControl1ExtTest
Members
Member name | Value | Description
NormalMode | 0 | Normal Mode
ExternalClockTestMode | 1 | External Clock Test Mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.TypeControl1Sr Enumeration

IRD

Pcf85063tpTypeControl1Sr Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Sr
Public Enumeration TypeControl1Sr
public enum class TypeControl1Sr
type TypeControl1Sr
Members
Member name | Value | Description
SoftwareResetNone | 0 | Software Reset: None
SoftwareResetInitiate | 1 | Software Reset: Initiate
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.TypeControl1Stop Enumeration

IRD

Pcf85063tpTypeControl1Stop Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Stop
Public Enumeration TypeControl1Stop
public enum class TypeControl1Stop
type TypeControl1Stop
Members
Member name | Value | Description
RTCClockRuns | 0 | RTC Clock: Runs
RTCClockStopped | 1 | RTC Clock: Stopped
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.TypeControl2Cof Enumeration

IRD

Pcf85063tpTypeControl2Cof Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Cof
Public Enumeration TypeControl2Cof
public enum class TypeControl2Cof
type TypeControl2Cof
Members
Member name | Value | Description
Value_32768 | 0 | 32768
Value_16384 | 1 | 16384
Value_8192 | 2 | 8192
Value_4096 | 3 | 4096
Value_2048 | 4 | 2048
Value_1024 | 5 | 1024
Value_1 | 6 | 1
LOW | 7 | LOW
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.TypeControl2Hmi Enumeration

IRD

Pcf85063tpTypeControl2Hmi Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Hmi
Public Enumeration TypeControl2Hmi
public enum class TypeControl2Hmi
type TypeControl2Hmi
Members
Member name | Value | Description
HalfMinuteInterruptDisabled | 0 | Half Minute Interrupt: Disabled
HalfMinuteInterruptEnabled | 1 | Half Minute Interrupt: Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.TypeControl2Mi Enumeration

IRD

Pcf85063tpTypeControl2Mi Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Mi
Public Enumeration TypeControl2Mi
public enum class TypeControl2Mi
type TypeControl2Mi
Members
Member name | Value | Description
MinuteInterruptDisabled | 0 | Minute Interrupt: Disabled
MinuteInterruptEnabled | 1 | Minute Interrupt: Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.TypeControl2Tf Enumeration

IRD

Pcf85063tpTypeControl2Tf Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Tf
Public Enumeration TypeControl2Tf
public enum class TypeControl2Tf
type TypeControl2Tf
Members
Member name | Value | Description
TimerFlagNotSet | 0 | Timer Flag: Not Set
TimerFlagSet | 1 | Timer Flag: Set
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.TypeMonths Enumeration

IRD

Pcf85063tpTypeMonths Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMonths
Public Enumeration TypeMonths
public enum class TypeMonths
type TypeMonths
Members
Member name | Value | Description
January | 1 | January
February | 2 | February
March | 3 | March
April | 4 | April
May | 5 | May
June | 6 | June
July | 7 | July
August | 8 | August
September | 9 | September
October | 10 | October
November | 11 | November
December | 12 | December
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.TypeOffsetMode Enumeration

IRD

Pcf85063tpTypeOffsetMode Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOffsetMode
Public Enumeration TypeOffsetMode
public enum class TypeOffsetMode
type TypeOffsetMode
Members
Member name | Value | Description
NormalMode | 0 | Normal Mode
CourseMode | 1 | Course Mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.TypeSecondsOs Enumeration

IRD

Pcf85063tpTypeSecondsOs Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSecondsOs
Public Enumeration TypeSecondsOs
public enum class TypeSecondsOs
type TypeSecondsOs
Members
Member name | Value | Description
ClockIntegrityGuaranteed | 0 | Clock Integrity: Guaranteed
ClockIntegrityNotGuaranteed | 1 | Clock Integrity: Not Guaranteed
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pcf85063tp.TypeWeekdays Enumeration

IRD

Pcf85063tpTypeWeekdays Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeWeekdays
Public Enumeration TypeWeekdays
public enum class TypeWeekdays
type TypeWeekdays
Members
Member name | Value | Description
Sunday | 0 | Sunday
Monday | 1 | Monday
Tuesday | 2 | Tuesday
Wednesday | 3 | Wednesday
Thursday | 4 | Thursday
Friday | 5 | Friday
Saturday | 6 | Saturday
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pct2075 Class

NXP Semiconductors: PCT 2075
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsPct2075

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pct2075
Public Class Pct2075
public ref class Pct2075
type Pct2075 =  class end

The Pct2075 type exposes the following members.

Constructors
 | Name | Description
Public method | Pct2075 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DeviceOperationSHUTDOWN | Device Operation (SHUTDOWN)
Public property | FaultQueueOSFQUE | Fault Queue (OS_F_QUE)
Public property | HysteresisTHYST | Hysteresis (THYST) (unit: °C)
Public property | OSOperationOSCOMPINT | OS Operation (OS_COMP_INT)
Public property | OverTemperatureTOS | Over-Temperature (TOS) (unit: °C)
Public property | PolarityOSPOL | Polarity (OS_POL)
Public property | TemperatureIdleTIDLE | Temperature Idle (TIDLE) (unit: ms)
Public property | TemperatureTEMP | Temperature (TEMP) (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Digital Temperature Sensor And Thermal Watchdog
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pct2075 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pct2075(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pct2075(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pct2075

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pct2075 Class
telos.Ird.NXPSemiconductors Namespace


Pct2075 Properties

The Pct2075 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DeviceOperationSHUTDOWN | Device Operation (SHUTDOWN)
Public property | FaultQueueOSFQUE | Fault Queue (OS_F_QUE)
Public property | HysteresisTHYST | Hysteresis (THYST) (unit: °C)
Public property | OSOperationOSCOMPINT | OS Operation (OS_COMP_INT)
Public property | OverTemperatureTOS | Over-Temperature (TOS) (unit: °C)
Public property | PolarityOSPOL | Polarity (OS_POL)
Public property | TemperatureIdleTIDLE | Temperature Idle (TIDLE) (unit: ms)
Public property | TemperatureTEMP | Temperature (TEMP) (unit: °C)
Top
See Also

Reference

Pct2075 Class
telos.Ird.NXPSemiconductors Namespace


Pct2075.AutoFlush Property

IRD

Pct2075AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pct2075 Class
telos.Ird.NXPSemiconductors Namespace


Pct2075.DeviceOperationSHUTDOWN Property

IRD

Pct2075DeviceOperationSHUTDOWN Property

Device Operation (SHUTDOWN)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pct2075TypeOperationMode DeviceOperationSHUTDOWN { get; set; }
Public Property DeviceOperationSHUTDOWN As Pct2075TypeOperationMode
    Get
    Set
public:
property Pct2075TypeOperationMode DeviceOperationSHUTDOWN {
    Pct2075TypeOperationMode get ();
    void set (Pct2075TypeOperationMode value);
}
member DeviceOperationSHUTDOWN : Pct2075TypeOperationMode with get, set

Property Value

Type: Pct2075TypeOperationMode
See Also

Reference

Pct2075 Class
telos.Ird.NXPSemiconductors Namespace


Pct2075.FaultQueueOSFQUE Property

IRD

Pct2075FaultQueueOSFQUE Property

Fault Queue (OS_F_QUE)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pct2075TypeOsFaultQueue FaultQueueOSFQUE { get; set; }
Public Property FaultQueueOSFQUE As Pct2075TypeOsFaultQueue
    Get
    Set
public:
property Pct2075TypeOsFaultQueue FaultQueueOSFQUE {
    Pct2075TypeOsFaultQueue get ();
    void set (Pct2075TypeOsFaultQueue value);
}
member FaultQueueOSFQUE : Pct2075TypeOsFaultQueue with get, set

Property Value

Type: Pct2075TypeOsFaultQueue
See Also

Reference

Pct2075 Class
telos.Ird.NXPSemiconductors Namespace


Pct2075.HysteresisTHYST Property

IRD

Pct2075HysteresisTHYST Property

Hysteresis (THYST) (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double HysteresisTHYST { get; set; }
Public Property HysteresisTHYST As Double
    Get
    Set
public:
property double HysteresisTHYST {
    double get ();
    void set (double value);
}
member HysteresisTHYST : float with get, set

Property Value

Type: Double
See Also

Reference

Pct2075 Class
telos.Ird.NXPSemiconductors Namespace


Pct2075.OSOperationOSCOMPINT Property

IRD

Pct2075OSOperationOSCOMPINT Property

OS Operation (OS_COMP_INT)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pct2075TypeOsOperationModeSelection OSOperationOSCOMPINT { get; set; }
Public Property OSOperationOSCOMPINT As Pct2075TypeOsOperationModeSelection
    Get
    Set
public:
property Pct2075TypeOsOperationModeSelection OSOperationOSCOMPINT {
    Pct2075TypeOsOperationModeSelection get ();
    void set (Pct2075TypeOsOperationModeSelection value);
}
member OSOperationOSCOMPINT : Pct2075TypeOsOperationModeSelection with get, set

Property Value

Type: Pct2075TypeOsOperationModeSelection
See Also

Reference

Pct2075 Class
telos.Ird.NXPSemiconductors Namespace


Pct2075.OverTemperatureTOS Property

IRD

Pct2075OverTemperatureTOS Property

Over-Temperature (TOS) (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double OverTemperatureTOS { get; set; }
Public Property OverTemperatureTOS As Double
    Get
    Set
public:
property double OverTemperatureTOS {
    double get ();
    void set (double value);
}
member OverTemperatureTOS : float with get, set

Property Value

Type: Double
See Also

Reference

Pct2075 Class
telos.Ird.NXPSemiconductors Namespace


Pct2075.PolarityOSPOL Property

IRD

Pct2075PolarityOSPOL Property

Polarity (OS_POL)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pct2075TypeOsPolaritySelection PolarityOSPOL { get; set; }
Public Property PolarityOSPOL As Pct2075TypeOsPolaritySelection
    Get
    Set
public:
property Pct2075TypeOsPolaritySelection PolarityOSPOL {
    Pct2075TypeOsPolaritySelection get ();
    void set (Pct2075TypeOsPolaritySelection value);
}
member PolarityOSPOL : Pct2075TypeOsPolaritySelection with get, set

Property Value

Type: Pct2075TypeOsPolaritySelection
See Also

Reference

Pct2075 Class
telos.Ird.NXPSemiconductors Namespace


Pct2075.TemperatureIdleTIDLE Property

IRD

Pct2075TemperatureIdleTIDLE Property

Temperature Idle (TIDLE) (unit: ms)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TemperatureIdleTIDLE { get; set; }
Public Property TemperatureIdleTIDLE As Double
    Get
    Set
public:
property double TemperatureIdleTIDLE {
    double get ();
    void set (double value);
}
member TemperatureIdleTIDLE : float with get, set

Property Value

Type: Double
See Also

Reference

Pct2075 Class
telos.Ird.NXPSemiconductors Namespace


Pct2075.TemperatureTEMP Property

IRD

Pct2075TemperatureTEMP Property

Temperature (TEMP) (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TemperatureTEMP { get; }
Public ReadOnly Property TemperatureTEMP As Double
    Get
public:
property double TemperatureTEMP {
    double get ();
}
member TemperatureTEMP : float with get

Property Value

Type: Double
See Also

Reference

Pct2075 Class
telos.Ird.NXPSemiconductors Namespace


Pct2075 Methods

The Pct2075 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pct2075 Class
telos.Ird.NXPSemiconductors Namespace


Pct2075.Flush Method

IRD

Pct2075Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pct2075 Class
telos.Ird.NXPSemiconductors Namespace


Pct2075.TypeOperationMode Enumeration

IRD

Pct2075TypeOperationMode Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationMode
Public Enumeration TypeOperationMode
public enum class TypeOperationMode
type TypeOperationMode
Members
Member name | Value | Description
Normal | 0 | Normal
Shutdown | 1 | Shutdown
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pct2075.TypeOsFaultQueue Enumeration

IRD

Pct2075TypeOsFaultQueue Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOsFaultQueue
Public Enumeration TypeOsFaultQueue
public enum class TypeOsFaultQueue
type TypeOsFaultQueue
Members
Member name | Value | Description
QueueValue1 | 0 | Queue Value = 1
QueueValue2 | 1 | Queue Value = 2
QueueValue4 | 2 | Queue Value = 4
QueueValue6 | 3 | Queue Value = 6
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pct2075.TypeOsOperationModeSelection Enumeration

IRD

Pct2075TypeOsOperationModeSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOsOperationModeSelection
Public Enumeration TypeOsOperationModeSelection
public enum class TypeOsOperationModeSelection
type TypeOsOperationModeSelection
Members
Member name | Value | Description
OSComparator | 0 | OS Comparator
OSInterrupt | 1 | OS Interrupt
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Pct2075.TypeOsPolaritySelection Enumeration

IRD

Pct2075TypeOsPolaritySelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOsPolaritySelection
Public Enumeration TypeOsPolaritySelection
public enum class TypeOsPolaritySelection
type TypeOsPolaritySelection
Members
Member name | Value | Description
OSActiveLow | 0 | OS Active: Low
OSActiveHigh | 1 | OS Active: High
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Sa56004x Class

NXP Semiconductors: SA 56004X
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsSa56004x

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Sa56004x
Public Class Sa56004x
public ref class Sa56004x
type Sa56004x =  class end

The Sa56004x type exposes the following members.

Constructors
 | Name | Description
Public method | Sa56004x | Constructor
Top
Properties
 | Name | Description
Public property | ALERTMode | ALERT Mode
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationALERTMask | Configuration: ALERT Mask
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationLocalTCRITMask | Configuration: Local T_CRIT Mask
Public property | ConfigurationRemoteTCRITMask | Configuration: Remote T_CRIT Mask
Public property | ConfigurationRUNSTOP | Configuration: RUN/STOP
Public property | ConversionRate | Conversion Rate (unit: Hz)
Public property | LocalHighSetpoint | Local High Setpoint (unit: °C)
Public property | LocalLowSetpoint | Local Low Setpoint (unit: °C)
Public property | LocalTCRITSetpoint | Local T_CRIT Setpoint (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerSID | Manufacturer's ID
Public property | RemoteHighSetpoint | Remote High Setpoint (unit: °C)
Public property | RemoteLowSetpoint | Remote Low Setpoint (unit: °C)
Public property | RemoteTCRITSetpoint | Remote T_CRIT Setpoint (unit: °C)
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | RemoteTemperatureOffset | Remote Temperature Offset (unit: °C)
Public property | StatusBUSY | Status: BUSY
Public property | StatusLCRIT | Status: LCRIT
Public property | StatusLHIGH | Status: LHIGH
Public property | StatusLLOW | Status: LLOW
Public property | StatusOPEN | Status: OPEN
Public property | StatusRCRIT | Status: RCRIT
Public property | StatusRHIGH | Status: RHIGH
Public property | StatusRLOW | Status: RLOW
Public property | SteppingDieRevision | Stepping / Die Revision
Public property | TCRITHysteresis | T_CRIT Hysteresis (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShotConversion | One-Shot Conversion
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
SMBus-Compatible, 8-Pin, Remote/Local Digital Temperature Sensor With Overtemperature Alarms
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Sa56004x Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Sa56004x(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Sa56004x(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Sa56004x

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x Properties

The Sa56004x type exposes the following members.

Properties
 | Name | Description
Public property | ALERTMode | ALERT Mode
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationALERTMask | Configuration: ALERT Mask
Public property | ConfigurationFaultQueue | Configuration: Fault Queue
Public property | ConfigurationLocalTCRITMask | Configuration: Local T_CRIT Mask
Public property | ConfigurationRemoteTCRITMask | Configuration: Remote T_CRIT Mask
Public property | ConfigurationRUNSTOP | Configuration: RUN/STOP
Public property | ConversionRate | Conversion Rate (unit: Hz)
Public property | LocalHighSetpoint | Local High Setpoint (unit: °C)
Public property | LocalLowSetpoint | Local Low Setpoint (unit: °C)
Public property | LocalTCRITSetpoint | Local T_CRIT Setpoint (unit: °C)
Public property | LocalTemperature | Local Temperature (unit: °C)
Public property | ManufacturerSID | Manufacturer's ID
Public property | RemoteHighSetpoint | Remote High Setpoint (unit: °C)
Public property | RemoteLowSetpoint | Remote Low Setpoint (unit: °C)
Public property | RemoteTCRITSetpoint | Remote T_CRIT Setpoint (unit: °C)
Public property | RemoteTemperature | Remote Temperature (unit: °C)
Public property | RemoteTemperatureOffset | Remote Temperature Offset (unit: °C)
Public property | StatusBUSY | Status: BUSY
Public property | StatusLCRIT | Status: LCRIT
Public property | StatusLHIGH | Status: LHIGH
Public property | StatusLLOW | Status: LLOW
Public property | StatusOPEN | Status: OPEN
Public property | StatusRCRIT | Status: RCRIT
Public property | StatusRHIGH | Status: RHIGH
Public property | StatusRLOW | Status: RLOW
Public property | SteppingDieRevision | Stepping / Die Revision
Public property | TCRITHysteresis | T_CRIT Hysteresis (unit: °C)
Top
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.ALERTMode Property

IRD

Sa56004xALERTMode Property

ALERT Mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Sa56004xTypeAlertMode ALERTMode { get; set; }
Public Property ALERTMode As Sa56004xTypeAlertMode
    Get
    Set
public:
property Sa56004xTypeAlertMode ALERTMode {
    Sa56004xTypeAlertMode get ();
    void set (Sa56004xTypeAlertMode value);
}
member ALERTMode : Sa56004xTypeAlertMode with get, set

Property Value

Type: Sa56004xTypeAlertMode
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.AutoFlush Property

IRD

Sa56004xAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.ConfigurationALERTMask Property

IRD

Sa56004xConfigurationALERTMask Property

Configuration: ALERT Mask

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Sa56004xTypeConfigurationEnabledDisabled ConfigurationALERTMask { get; set; }
Public Property ConfigurationALERTMask As Sa56004xTypeConfigurationEnabledDisabled
    Get
    Set
public:
property Sa56004xTypeConfigurationEnabledDisabled ConfigurationALERTMask {
    Sa56004xTypeConfigurationEnabledDisabled get ();
    void set (Sa56004xTypeConfigurationEnabledDisabled value);
}
member ConfigurationALERTMask : Sa56004xTypeConfigurationEnabledDisabled with get, set

Property Value

Type: Sa56004xTypeConfigurationEnabledDisabled
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.ConfigurationFaultQueue Property

IRD

Sa56004xConfigurationFaultQueue Property

Configuration: Fault Queue

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Sa56004xTypeConfigurationEnabledDisabled ConfigurationFaultQueue { get; set; }
Public Property ConfigurationFaultQueue As Sa56004xTypeConfigurationEnabledDisabled
    Get
    Set
public:
property Sa56004xTypeConfigurationEnabledDisabled ConfigurationFaultQueue {
    Sa56004xTypeConfigurationEnabledDisabled get ();
    void set (Sa56004xTypeConfigurationEnabledDisabled value);
}
member ConfigurationFaultQueue : Sa56004xTypeConfigurationEnabledDisabled with get, set

Property Value

Type: Sa56004xTypeConfigurationEnabledDisabled
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.ConfigurationLocalTCRITMask Property

IRD

Sa56004xConfigurationLocalTCRITMask Property

Configuration: Local T_CRIT Mask

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Sa56004xTypeConfigurationEnabledDisabled ConfigurationLocalTCRITMask { get; set; }
Public Property ConfigurationLocalTCRITMask As Sa56004xTypeConfigurationEnabledDisabled
    Get
    Set
public:
property Sa56004xTypeConfigurationEnabledDisabled ConfigurationLocalTCRITMask {
    Sa56004xTypeConfigurationEnabledDisabled get ();
    void set (Sa56004xTypeConfigurationEnabledDisabled value);
}
member ConfigurationLocalTCRITMask : Sa56004xTypeConfigurationEnabledDisabled with get, set

Property Value

Type: Sa56004xTypeConfigurationEnabledDisabled
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.ConfigurationRemoteTCRITMask Property

IRD

Sa56004xConfigurationRemoteTCRITMask Property

Configuration: Remote T_CRIT Mask

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Sa56004xTypeConfigurationEnabledDisabled ConfigurationRemoteTCRITMask { get; set; }
Public Property ConfigurationRemoteTCRITMask As Sa56004xTypeConfigurationEnabledDisabled
    Get
    Set
public:
property Sa56004xTypeConfigurationEnabledDisabled ConfigurationRemoteTCRITMask {
    Sa56004xTypeConfigurationEnabledDisabled get ();
    void set (Sa56004xTypeConfigurationEnabledDisabled value);
}
member ConfigurationRemoteTCRITMask : Sa56004xTypeConfigurationEnabledDisabled with get, set

Property Value

Type: Sa56004xTypeConfigurationEnabledDisabled
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.ConfigurationRUNSTOP Property

IRD

Sa56004xConfigurationRUNSTOP Property

Configuration: RUN/STOP

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Sa56004xTypeConfigurationRunStop ConfigurationRUNSTOP { get; set; }
Public Property ConfigurationRUNSTOP As Sa56004xTypeConfigurationRunStop
    Get
    Set
public:
property Sa56004xTypeConfigurationRunStop ConfigurationRUNSTOP {
    Sa56004xTypeConfigurationRunStop get ();
    void set (Sa56004xTypeConfigurationRunStop value);
}
member ConfigurationRUNSTOP : Sa56004xTypeConfigurationRunStop with get, set

Property Value

Type: Sa56004xTypeConfigurationRunStop
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.ConversionRate Property

IRD

Sa56004xConversionRate Property

Conversion Rate (unit: Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Sa56004xTypeConversionRate ConversionRate { get; set; }
Public Property ConversionRate As Sa56004xTypeConversionRate
    Get
    Set
public:
property Sa56004xTypeConversionRate ConversionRate {
    Sa56004xTypeConversionRate get ();
    void set (Sa56004xTypeConversionRate value);
}
member ConversionRate : Sa56004xTypeConversionRate with get, set

Property Value

Type: Sa56004xTypeConversionRate
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.LocalHighSetpoint Property

IRD

Sa56004xLocalHighSetpoint Property

Local High Setpoint (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalHighSetpoint { get; set; }
Public Property LocalHighSetpoint As SByte
    Get
    Set
public:
property signed char LocalHighSetpoint {
    signed char get ();
    void set (signed char value);
}
member LocalHighSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.LocalLowSetpoint Property

IRD

Sa56004xLocalLowSetpoint Property

Local Low Setpoint (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalLowSetpoint { get; set; }
Public Property LocalLowSetpoint As SByte
    Get
    Set
public:
property signed char LocalLowSetpoint {
    signed char get ();
    void set (signed char value);
}
member LocalLowSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.LocalTCRITSetpoint Property

IRD

Sa56004xLocalTCRITSetpoint Property

Local T_CRIT Setpoint (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTCRITSetpoint { get; set; }
Public Property LocalTCRITSetpoint As SByte
    Get
    Set
public:
property signed char LocalTCRITSetpoint {
    signed char get ();
    void set (signed char value);
}
member LocalTCRITSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.LocalTemperature Property

IRD

Sa56004xLocalTemperature Property

Local Temperature (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LocalTemperature { get; }
Public ReadOnly Property LocalTemperature As Double
    Get
public:
property double LocalTemperature {
    double get ();
}
member LocalTemperature : float with get

Property Value

Type: Double
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.ManufacturerSID Property

IRD

Sa56004xManufacturerSID Property

Manufacturer's ID

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerSID { get; }
Public ReadOnly Property ManufacturerSID As Byte
    Get
public:
property unsigned char ManufacturerSID {
    unsigned char get ();
}
member ManufacturerSID : byte with get

Property Value

Type: Byte
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.RemoteHighSetpoint Property

IRD

Sa56004xRemoteHighSetpoint Property

Remote High Setpoint (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteHighSetpoint { get; set; }
Public Property RemoteHighSetpoint As Double
    Get
    Set
public:
property double RemoteHighSetpoint {
    double get ();
    void set (double value);
}
member RemoteHighSetpoint : float with get, set

Property Value

Type: Double
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.RemoteLowSetpoint Property

IRD

Sa56004xRemoteLowSetpoint Property

Remote Low Setpoint (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteLowSetpoint { get; set; }
Public Property RemoteLowSetpoint As Double
    Get
    Set
public:
property double RemoteLowSetpoint {
    double get ();
    void set (double value);
}
member RemoteLowSetpoint : float with get, set

Property Value

Type: Double
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.RemoteTCRITSetpoint Property

IRD

Sa56004xRemoteTCRITSetpoint Property

Remote T_CRIT Setpoint (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTCRITSetpoint { get; set; }
Public Property RemoteTCRITSetpoint As SByte
    Get
    Set
public:
property signed char RemoteTCRITSetpoint {
    signed char get ();
    void set (signed char value);
}
member RemoteTCRITSetpoint : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.RemoteTemperature Property

IRD

Sa56004xRemoteTemperature Property

Remote Temperature (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperature { get; }
Public ReadOnly Property RemoteTemperature As Double
    Get
public:
property double RemoteTemperature {
    double get ();
}
member RemoteTemperature : float with get

Property Value

Type: Double
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.RemoteTemperatureOffset Property

IRD

Sa56004xRemoteTemperatureOffset Property

Remote Temperature Offset (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperatureOffset { get; set; }
Public Property RemoteTemperatureOffset As Double
    Get
    Set
public:
property double RemoteTemperatureOffset {
    double get ();
    void set (double value);
}
member RemoteTemperatureOffset : float with get, set

Property Value

Type: Double
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.StatusBUSY Property

IRD

Sa56004xStatusBUSY Property

Status: BUSY

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Sa56004xTypeStatusBusy StatusBUSY { get; }
Public ReadOnly Property StatusBUSY As Sa56004xTypeStatusBusy
    Get
public:
property Sa56004xTypeStatusBusy StatusBUSY {
    Sa56004xTypeStatusBusy get ();
}
member StatusBUSY : Sa56004xTypeStatusBusy with get

Property Value

Type: Sa56004xTypeStatusBusy
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.StatusLCRIT Property

IRD

Sa56004xStatusLCRIT Property

Status: LCRIT

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Sa56004xTypeStatusAlarm StatusLCRIT { get; }
Public ReadOnly Property StatusLCRIT As Sa56004xTypeStatusAlarm
    Get
public:
property Sa56004xTypeStatusAlarm StatusLCRIT {
    Sa56004xTypeStatusAlarm get ();
}
member StatusLCRIT : Sa56004xTypeStatusAlarm with get

Property Value

Type: Sa56004xTypeStatusAlarm
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.StatusLHIGH Property

IRD

Sa56004xStatusLHIGH Property

Status: LHIGH

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Sa56004xTypeStatusAlarm StatusLHIGH { get; }
Public ReadOnly Property StatusLHIGH As Sa56004xTypeStatusAlarm
    Get
public:
property Sa56004xTypeStatusAlarm StatusLHIGH {
    Sa56004xTypeStatusAlarm get ();
}
member StatusLHIGH : Sa56004xTypeStatusAlarm with get

Property Value

Type: Sa56004xTypeStatusAlarm
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.StatusLLOW Property

IRD

Sa56004xStatusLLOW Property

Status: LLOW

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Sa56004xTypeStatusAlarm StatusLLOW { get; }
Public ReadOnly Property StatusLLOW As Sa56004xTypeStatusAlarm
    Get
public:
property Sa56004xTypeStatusAlarm StatusLLOW {
    Sa56004xTypeStatusAlarm get ();
}
member StatusLLOW : Sa56004xTypeStatusAlarm with get

Property Value

Type: Sa56004xTypeStatusAlarm
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.StatusOPEN Property

IRD

Sa56004xStatusOPEN Property

Status: OPEN

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Sa56004xTypeStatusOpen StatusOPEN { get; }
Public ReadOnly Property StatusOPEN As Sa56004xTypeStatusOpen
    Get
public:
property Sa56004xTypeStatusOpen StatusOPEN {
    Sa56004xTypeStatusOpen get ();
}
member StatusOPEN : Sa56004xTypeStatusOpen with get

Property Value

Type: Sa56004xTypeStatusOpen
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.StatusRCRIT Property

IRD

Sa56004xStatusRCRIT Property

Status: RCRIT

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Sa56004xTypeStatusAlarm StatusRCRIT { get; }
Public ReadOnly Property StatusRCRIT As Sa56004xTypeStatusAlarm
    Get
public:
property Sa56004xTypeStatusAlarm StatusRCRIT {
    Sa56004xTypeStatusAlarm get ();
}
member StatusRCRIT : Sa56004xTypeStatusAlarm with get

Property Value

Type: Sa56004xTypeStatusAlarm
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.StatusRHIGH Property

IRD

Sa56004xStatusRHIGH Property

Status: RHIGH

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Sa56004xTypeStatusAlarm StatusRHIGH { get; }
Public ReadOnly Property StatusRHIGH As Sa56004xTypeStatusAlarm
    Get
public:
property Sa56004xTypeStatusAlarm StatusRHIGH {
    Sa56004xTypeStatusAlarm get ();
}
member StatusRHIGH : Sa56004xTypeStatusAlarm with get

Property Value

Type: Sa56004xTypeStatusAlarm
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.StatusRLOW Property

IRD

Sa56004xStatusRLOW Property

Status: RLOW

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Sa56004xTypeStatusAlarm StatusRLOW { get; }
Public ReadOnly Property StatusRLOW As Sa56004xTypeStatusAlarm
    Get
public:
property Sa56004xTypeStatusAlarm StatusRLOW {
    Sa56004xTypeStatusAlarm get ();
}
member StatusRLOW : Sa56004xTypeStatusAlarm with get

Property Value

Type: Sa56004xTypeStatusAlarm
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.SteppingDieRevision Property

IRD

Sa56004xSteppingDieRevision Property

Stepping / Die Revision

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SteppingDieRevision { get; }
Public ReadOnly Property SteppingDieRevision As Byte
    Get
public:
property unsigned char SteppingDieRevision {
    unsigned char get ();
}
member SteppingDieRevision : byte with get

Property Value

Type: Byte
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.TCRITHysteresis Property

IRD

Sa56004xTCRITHysteresis Property

T_CRIT Hysteresis (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TCRITHysteresis { get; set; }
Public Property TCRITHysteresis As Byte
    Get
    Set
public:
property unsigned char TCRITHysteresis {
    unsigned char get ();
    void set (unsigned char value);
}
member TCRITHysteresis : byte with get, set

Property Value

Type: Byte
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x Methods

The Sa56004x type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OneShotConversion | One-Shot Conversion
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.Flush Method

IRD

Sa56004xFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.OneShotConversion Method

IRD

Sa56004xOneShotConversion Method

One-Shot Conversion

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void OneShotConversion()
Public Sub OneShotConversion
public:
void OneShotConversion()
member OneShotConversion : unit -> unit
See Also

Reference

Sa56004x Class
telos.Ird.NXPSemiconductors Namespace


Sa56004x.TypeAlertMode Enumeration

IRD

Sa56004xTypeAlertMode Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAlertMode
Public Enumeration TypeAlertMode
public enum class TypeAlertMode
type TypeAlertMode
Members
Member name | Value | Description
InterruptMode | 0 | Interrupt Mode
ComparatorMode | 1 | Comparator Mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Sa56004x.TypeConfigurationEnabledDisabled Enumeration

IRD

Sa56004xTypeConfigurationEnabledDisabled Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationEnabledDisabled
Public Enumeration TypeConfigurationEnabledDisabled
public enum class TypeConfigurationEnabledDisabled
type TypeConfigurationEnabledDisabled
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Sa56004x.TypeConfigurationRunStop Enumeration

IRD

Sa56004xTypeConfigurationRunStop Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationRunStop
Public Enumeration TypeConfigurationRunStop
public enum class TypeConfigurationRunStop
type TypeConfigurationRunStop
Members
Member name | Value | Description
Run | 0 | Run
Standby | 1 | Standby
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Sa56004x.TypeConversionRate Enumeration

IRD

Sa56004xTypeConversionRate Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConversionRate
Public Enumeration TypeConversionRate
public enum class TypeConversionRate
type TypeConversionRate
Members
Member name | Value | Description
Value_0_06 | 0 | 0.06
Value_0_12 | 1 | 0.12
Value_0_25 | 2 | 0.25
Value_0_50 | 3 | 0.50
Value_1 | 4 | 1
Value_2 | 5 | 2
Value_4 | 6 | 4
Value_8 | 7 | 8
Value_16 | 8 | 16
Value_32 | 9 | 32
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Sa56004x.TypeStatusAlarm Enumeration

IRD

Sa56004xTypeStatusAlarm Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusAlarm
Public Enumeration TypeStatusAlarm
public enum class TypeStatusAlarm
type TypeStatusAlarm
Members
Member name | Value | Description
NoAlarm | 0 | No Alarm
Alarm | 1 | Alarm
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Sa56004x.TypeStatusBusy Enumeration

IRD

Sa56004xTypeStatusBusy Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusBusy
Public Enumeration TypeStatusBusy
public enum class TypeStatusBusy
type TypeStatusBusy
Members
Member name | Value | Description
NotBusy | 0 | Not Busy
Busy | 1 | Busy
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Sa56004x.TypeStatusOpen Enumeration

IRD

Sa56004xTypeStatusOpen Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusOpen
Public Enumeration TypeStatusOpen
public enum class TypeStatusOpen
type TypeStatusOpen
Members
Member name | Value | Description
NotDisconnected | 0 | Not Disconnected
Disconnected | 1 | Disconnected
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118 Class

NXP Semiconductors: SAA 7118
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsSaa7118

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Saa7118
Public Class Saa7118
public ref class Saa7118
type Saa7118 =  class end

The Saa7118 type exposes the following members.

Constructors
 | Name | Description
Public method | Saa7118 | Constructor
Top
Properties
 | Name | Description
Public property | AdaptiveChrominanceCombFilter | Adaptive chrominance comb filter
Public property | AdaptiveLuminanceCombFilter | Adaptive luminance comb filter
Public property | ADCClockSelector | ADC clock selector
Public property | ADCSampleClockPhaseDelay | ADC sample clock phase delay
Public property | ADPortOutputEnable | AD port output enable
Public property | AGCHoldDuringVerticalBlankingPeriod | AGC hold during vertical blanking period
Public property | ALRCLKPhase | ALRCLK phase
Public property | AlternativeVGATEPosition | Alternative VGATE position
Public property | AmplitudeSearching | Amplitude searching
Public property | AnalogFunctionSelect | Analog function select
Public property | AnalogInputControl3 | Analog input control 3
Public property | AnalogInputControl4 | Analog input control 4
Public property | AnalogInputControl6 | Analog input control 6
Public property | AnalogInputControl7 | Analog input control 7
Public property | AnalogTestSelect | Analog test select
Public property | ASCLKPhase | ASCLK phase
Public property | AudioClockGeneration | Audio clock generation
Public property | AudioMasterClockCyclesPerField | Audio master clock cycles per field
Public property | AudioMasterClockNominalIncrement | Audio master clock nominal increment
Public property | AudioMasterClockVerticalReference | Audio master clock vertical reference
Public property | AudioPLLModes | Audio PLL modes
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AutomaticChrominanceGainControl | Automatic chrominance gain control
Public property | AutomaticChrominanceStandardDetectionControl | Automatic chrominance standard detection control
Public property | AutomaticFieldDetection | Automatic field detection
Public property | AutomaticGainControlIntegration | Automatic gain control integration
Public property | ChipVersion | Chip version
Public property | ChrominanceBandwidth | Chrominance bandwidth
Public property | ChrominanceGainValue | Chrominance gain value
Public property | ChrominanceHueControl | Chrominance hue control
Public property | ChrominanceSaturationControl | Chrominance saturation control
Public property | ChrominanceSaturationControlComponentPart | Chrominance saturation control component part
Public property | ChrominanceTrapCombFilterBypass | Chrominance trap/comb filter bypass
Public property | ClampingReferenceSelectionForAllADCs | Clamping/reference selection for all ADCs
Public property | ClearDTO | Clear DTO
Public property | ClockRatioAudioMasterClockToSerialBitClock | Clock ratio audio master clock to serial bit clock
Public property | ClockRatioSerialBitClockToChannelSelectClock | Clock ratio serial bit clock to channel select clock
Public property | ClosedCaptionValid | Closed caption valid
Public property | ColourOn | Colour on
Public property | ColourPeakOff | Colour peak off
Public property | ColourStandardSelectionInAUTOMode | Colour standard selection in AUTO mode
Public property | CombinedLuminanceChrominanceBandwidthAdjustment | Combined luminance/chrominance bandwidth adjustment
Public property | CompatibilityBitForSAA7199 | Compatibility bit for SAA7199
Public property | ComponentInputDelayAdjustmentRelativeToDecodedCVBSSignal | Component input delay adjustment relative to decoded CVBS signal (unit: pixel)
Public property | ComponentLuminancePeaking | Component luminance peaking
Public property | CopyProtectedSourceDetected | Copy protected source detected
Public property | DataType | Data type
Public property | DecoderAndVBISlicer | Decoder and VBI slicer
Public property | DetectedColourStandard | Detected colour standard
Public property | DisableChrominanceVerticalFilterAndPALPhaseErrorCorrection | Disable chrominance vertical filter and PAL phase error correction
Public property | DOSL | DOSL
Public property | DPROG | DPROG
Public property | DwordByteSwapInfluencesSerialOutputTiming | Dword byte swap, influences serial output timing
Public property | EnableExternalSourceSwitchIndicatorInputEXMCLR | Enable external source switch indicator Input EXMCLR
Public property | ERROFErrorFlagOfScalersOutputFormatterNormallySet | ERROF error flag of scalers output formatter, normally set
Public property | FAEFIFOFlagAlmostEmptyLevel | FAE FIFO flag almost empty level
Public property | FAEFIFOFlagAlmostFullLevel | FAE FIFO flag almost full level
Public property | FastColourTimeConstant | Fast colour time constant
Public property | FastSwitchEnable | Fast switch enable
Public property | FastSwitchInputDelayAdjustmentRelativeToComponentInputSignal | Fast switch input delay adjustment relative to component input signal (unit: pixel)
Public property | FastSwitchInputPolarityFSWE01 | Fast switch input polarity (FSWE=0/1)
Public property | FFILStatusOfTheInternalFIFOAlmostFilledFlag | FFIL status of the internal 'FIFO almost filled' flag
Public property | FFOVStatusOfTheInternalFIFOOverflowFlag | FFOV status of the internal 'FIFO overflow' flag
Public property | FIDSCIStatusOfTheFieldSequenceIDAtTheScalersInput | FIDSCI status of the field sequence ID at the scalers input
Public property | FIDSCOStatusOfTheFieldSequenceIDAtTheScalersOutput | FIDSCO status of the field sequence ID at the scalers output
Public property | FieldIDAndVBlankSelectionForTextOutput | Field ID and V-blank selection for text output
Public property | FieldIDAsSeenByTheVBISlicer | Field ID as seen by the VBI slicer
Public property | FieldOffset | Field offset
Public property | FieldSelection | Field selection
Public property | FineOffsetAdjustmentBYComponent | Fine offset adjustment B - Y component
Public property | FineOffsetAdjustmentRYComponent | Fine offset adjustment R - Y component
Public property | FinePositionOfHS | Fine position of HS
Public property | ForcedODDEVENToggle | Forced ODD/EVEN toggle
Public property | FramingCodeError | Framing code error
Public property | FramingCodeValid0Error | Framing code valid (0 error)
Public property | FramingCodeValid1Error | Framing code valid (1 error)
Public property | GainControlFix | Gain control fix
Public property | GainValueForActiveLuminanceChannelIsLimitedMaximumTop | Gain value for active luminance channel is limited; maximum (top)
Public property | GainValueForActiveLuminanceChannelIsLimitedMinimumBottom | Gain value for active luminance channel is limited; minimum (bottom)
Public property | GlobalControl1BackEndClock | Global control 1: back-end clock
Public property | GlobalControl1DefinitionOfTheFAndVTimingOfTheScalerOutput | Global control 1: Definition of the F and V timing of the scaler output
Public property | GlobalControl1IDQ | Global control 1: IDQ
Public property | GlobalControl1IDQPin | Global control 1: IDQ pin
Public property | GlobalControl1TaskOfRegisterSetA | Global control 1: Task of register set A
Public property | GlobalControl1TaskOfRegisterSetB | Global control 1: Task of register set B
Public property | HammingCheck | Hamming check
Public property | HLNotReferenceSelect | HL not reference select
Public property | HorizontalLockIndicatorSelection | Horizontal lock indicator selection
Public property | HorizontalOffset | Horizontal offset
Public property | HorizontalPLL | Horizontal PLL
Public property | HorizontalSyncStartDelayTimeStepSize8LLC | Horizontal sync start: Delay Time (Step size=8/LLC)
Public property | HorizontalSyncStopDelayTimeStepSize8LLC | Horizontal sync stop: Delay Time (Step size=8/LLC)
Public property | HorizontalTimeConstantSelection | Horizontal time constant selection
Public property | IdentificationBitForDetectedFieldFrequency | Identification bit for detected field frequency
Public property | IDG0 | IDG0
Public property | IDG1 | IDG1
Public property | IDH | IDH
Public property | IDV | IDV
Public property | ILLV | ILLV
Public property | IncrementDelay | Increment delay
Public property | InterruptEnableClosedCaptionDetectedLost | Interrupt enable 'closed caption detected/lost'
Public property | InterruptEnableColourStandardChanged0 | Interrupt enable 'colour standard changed 0'
Public property | InterruptEnableColourStandardChanged1 | Interrupt enable 'colour standard changed 1'
Public property | InterruptEnableColourStripeBurstAnyTypeDetectedLost | Interrupt enable 'colour stripe burst (any type) detected/lost'
Public property | InterruptEnableColourStripeType3BurstDetectedLost | Interrupt enable 'colour stripe type 3 burst detected/lost'
Public property | InterruptEnableCopyProtectedSignalFoundLost | Interrupt enable 'copy protected signal found/lost'
Public property | InterruptEnableErrorOutputFormatter | Interrupt enable 'error output formatter'
Public property | InterruptEnableFieldFrequencyHasChanged | Interrupt enable 'field frequency has changed'
Public property | InterruptEnableHorizontalAndVerticalLockReachedLost | Interrupt enable 'horizontal and vertical lock reached/lost'
Public property | InterruptEnableHorizontalPLLLockedUnlocked | Interrupt enable 'horizontal PLL locked/unlocked'
Public property | InterruptEnableInterlacedNonInterlacedSource | Interrupt enable 'interlaced/non-interlaced source'
Public property | InterruptEnablePALplusDetectedLost | Interrupt enable 'PALplus detected/lost'
Public property | InterruptEnableReadyForCaptureNotReady | Interrupt enable 'ready for capture/not ready'
Public property | InterruptEnableVPSSignalDetectedLost | Interrupt enable 'VPS signal detected/lost'
Public property | IPortIOEnableICLK | I port I/O enable: ICLK
Public property | IPortIOEnableIDQ | I port I/O enable: IDQ
Public property | IPortIOEnableIPortIOEnable | I port I/O enable: I port I/O enable
Public property | IPortSignalDefinitions | I port signal definitions
Public property | ITRIStatusOnInputPinITRIIfNotUsedFor3StateControl | ITRI status on input pin ITRI, if not used for 3-state control
Public property | LCR10Field1 | LCR10: Field 1
Public property | LCR10Field2 | LCR10: Field 2
Public property | LCR11Field1 | LCR11: Field 1
Public property | LCR11Field2 | LCR11: Field 2
Public property | LCR12Field1 | LCR12: Field 1
Public property | LCR12Field2 | LCR12: Field 2
Public property | LCR13Field1 | LCR13: Field 1
Public property | LCR13Field2 | LCR13: Field 2
Public property | LCR14Field1 | LCR14: Field 1
Public property | LCR14Field2 | LCR14: Field 2
Public property | LCR15Field1 | LCR15: Field 1
Public property | LCR15Field2 | LCR15: Field 2
Public property | LCR16Field1 | LCR16: Field 1
Public property | LCR16Field2 | LCR16: Field 2
Public property | LCR17Field1 | LCR17: Field 1
Public property | LCR17Field2 | LCR17: Field 2
Public property | LCR18Field1 | LCR18: Field 1
Public property | LCR18Field2 | LCR18: Field 2
Public property | LCR19Field1 | LCR19: Field 1
Public property | LCR19Field2 | LCR19: Field 2
Public property | LCR20Field1 | LCR20: Field 1
Public property | LCR20Field2 | LCR20: Field 2
Public property | LCR21Field1 | LCR21: Field 1
Public property | LCR21Field2 | LCR21: Field 2
Public property | LCR22Field1 | LCR22: Field 1
Public property | LCR22Field2 | LCR22: Field 2
Public property | LCR23Field1 | LCR23: Field 1
Public property | LCR23Field2 | LCR23: Field 2
Public property | LCR24Field1 | LCR24: Field 1
Public property | LCR24Field2 | LCR24: Field 2
Public property | LCR2Field1 | LCR2: Field 1
Public property | LCR2Field2 | LCR2: Field 2
Public property | LCR3Field1 | LCR3: Field 1
Public property | LCR3Field2 | LCR3: Field 2
Public property | LCR4Field1 | LCR4: Field 1
Public property | LCR4Field2 | LCR4: Field 2
Public property | LCR5Field1 | LCR5: Field 1
Public property | LCR5Field2 | LCR5: Field 2
Public property | LCR6Field1 | LCR6: Field 1
Public property | LCR6Field2 | LCR6: Field 2
Public property | LCR7Field1 | LCR7: Field 1
Public property | LCR7Field2 | LCR7: Field 2
Public property | LCR8Field1 | LCR8: Field 1
Public property | LCR8Field2 | LCR8: Field 2
Public property | LCR9Field1 | LCR9: Field 1
Public property | LCR9Field2 | LCR9: Field 2
Public property | LineNumber | Line Number
Public property | LLC2OutputEnable | LLC2 output enable
Public property | LLCOutputEnable | LLC output enable
Public property | LuminanceBrightnessControlComponentPart | Luminance brightness control component part
Public property | LuminanceBrightnessControlDecoderPart | Luminance brightness control: decoder part
Public property | LuminanceContrastControlComponentPart | Luminance contrast control component part
Public property | LuminanceContrastControlDecoderPartNegInverse | Luminance contrast control: Decoder part (neg=inverse)
Public property | LuminanceDelayCompensation | Luminance delay compensation
Public property | MacrovisionEncodedColourStripeBurstDetected | Macrovision encoded colour stripe burst detected
Public property | MacrovisionEncodedColourStripeBurstType34LineVersionDetected | Macrovision encoded colour stripe burst type 3 (4 line version) detected
Public property | ModeSelection | Mode selection
Public property | PALplusValid | PALplus valid
Public property | PolarityOfRTS0OutputSignal | Polarity of RTS0 output signal
Public property | PolarityOfRTS1OutputSignal | Polarity of RTS1 output signal
Public property | PRDONCopyOfBitDPROGCanBeUsedToDetectPowerUpAndStartUpFails | PRDON copy of bit DPROG, can be used to detect power-up and start-up fails
Public property | ProcessingDelayInNonCombFilterMode | Processing delay in non comb filter mode
Public property | ProgrammableFramingCode | Programmable framing code
Public property | RawDataGainControl | Raw data gain control
Public property | RawDataOffsetControl | Raw data offset control (unit: LSB)
Public property | ReadyForCapture | Ready for capture
Public property | Recode | Recode
Public property | RegSetAAccumulationLength | RegSet A: Accumulation length
Public property | RegSetAChromaIsProvided | RegSet A: Chroma is provided
Public property | RegSetAChrominanceFIRFilter | RegSet A: Chrominance FIR filter
Public property | RegSetADataQualified | RegSet A: Data qualified:
Public property | RegSetADwordsTransferred | RegSet A: Dwords transferred
Public property | RegSetAEdgeOfXRHInputIsHorizontalReference | RegSet A: Edge of XRH input is horizontal reference
Public property | RegSetAEdgeOfXRVInputAndDecoderV123IsVerticalReference | RegSet A: Edge of XRV input and decoder V123 is vertical reference:
Public property | RegSetAEventHandlerTriggers | RegSet A: Event handler triggers
Public property | RegSetAFormat | RegSet A: Format
Public property | RegSetAGain | RegSet A: Gain
Public property | RegSetAHorizontalChrominancePhaseOffset | RegSet A: Horizontal chrominance phase offset
Public property | RegSetAHorizontalChrominanceScalingIncrement | RegSet A: Horizontal chrominance scaling increment
Public property | RegSetAHorizontalInputWindowLength | RegSet A: Horizontal input window length
Public property | RegSetAHorizontalInputWindowStart | RegSet A: Horizontal input window start
Public property | RegSetAHorizontalLuminancePhaseOffset | RegSet A: Horizontal luminance phase offset (unit: Pixel)
Public property | RegSetAHorizontalLuminanceScalingIncrementScale1024Data | RegSet A: Horizontal luminance scaling increment Scale=1024/[Data]
Public property | RegSetAHorizontalOutputWindowLength | RegSet A:Horizontal output window length
Public property | RegSetAHorizontalPrescaling | RegSet A: Horizontal prescaling
Public property | RegSetAITU656 | RegSet A: ITU 656
Public property | RegSetALeadingLinesBefore1stYCBCRLineIsOutput | RegSet A: Leading lines before 1st Y + CB-CR line is output
Public property | RegSetALinesOutput | RegSet A: Lines output
Public property | RegSetALuminanceBrightnessControl | RegSet A: Luminance brightness control
Public property | RegSetALuminanceContrastControl | RegSet A: Luminance contrast control
Public property | RegSetALuminanceFIRFilter | RegSet A: Luminance FIR filter
Public property | RegSetANextTask | RegSet A: Next task
Public property | RegSetAOutputFieldID | RegSet A: Output field ID
Public property | RegSetAPrescalerOutputIsRenormalizedByGainFactor | RegSet A: Prescaler output is renormalized by gain factor
Public property | RegSetAReferenceEdgeForFieldDetection | RegSet A: Reference edge for field detection
Public property | RegSetAReferenceSignals | RegSet A: Reference signals:
Public property | RegSetASamplingScheme | RegSet A: Sampling scheme
Public property | RegSetASAVEAVCodeBitD5VGate | RegSet A: SAV/EAV code bit D5 (V) gate
Public property | RegSetASAVEAVCodeBitsD6AndD5FAndV | RegSet A: SAV/EAV code bits D6 and D5 (F and V)
Public property | RegSetAScalerInputSource | RegSet A: Scaler input source:
Public property | RegSetAScalerInputSource__1 | RegSet A: Scaler input source
Public property | RegSetAScalerSAVEAVByte | RegSet A: Scaler SAV/EAV byte
Public property | RegSetATaskHandlingControl | RegSet A: Task handling control
Public property | RegSetAVerticalChrominancePhaseOffsetData32 | RegSet A: Vertical chrominance phase offset=[Data]/32
Public property | RegSetAVerticalChrominanceScalingIncrement | RegSet A: Vertical chrominance scaling increment
Public property | RegSetAVerticalInputWindowLength | RegSet A: Vertical input window length
Public property | RegSetAVerticalInputWindowStart | RegSet A: Vertical input window start
Public property | RegSetAVerticalLuminancePhaseOffsetData32 | RegSet A: Vertical luminance phase offset=[Data]/32
Public property | RegSetAVerticalLuminanceScalingIncrementScale1024Data | RegSet A: Vertical luminance scaling increment Scale=1024/[Data]
Public property | RegSetAVerticalOutputWindowLength | RegSet A:Vertical output window length
Public property | RegSetAWeightingOfAllAccumulatedSamples | RegSet A: Weighting of all accumulated samples
Public property | RegSetAXCLK | RegSet A: XCLK
Public property | RegSetAXPortFieldID | RegSet A: X port field ID
Public property | RegSetAXRV | RegSet A: XRV
Public property | RegSetAYMIR | RegSet A: YMIR
Public property | RegSetAYMODE | RegSet A: YMODE
Public property | RegSetBAccumulationLength | RegSet B: Accumulation length
Public property | RegSetBChromaIsProvided | RegSet B: Chroma is provided
Public property | RegSetBChrominanceFIRFilter | RegSet B: Chrominance FIR filter
Public property | RegSetBDataQualified | RegSet B: Data qualified:
Public property | RegSetBDwordsTransferred | RegSet B: Dwords transferred
Public property | RegSetBEdgeOfXRHInputIsHorizontalReference | RegSet B: Edge of XRH input is horizontal reference
Public property | RegSetBEdgeOfXRVInputAndDecoderV123IsVerticalReference | RegSet B: Edge of XRV input and decoder V123 is vertical reference:
Public property | RegSetBEventHandlerTriggers | RegSet B: Event handler triggers
Public property | RegSetBFormat | RegSet B: Format
Public property | RegSetBGain | RegSet B: Gain
Public property | RegSetBHorizontalChrominancePhaseOffset | RegSet B: Horizontal chrominance phase offset
Public property | RegSetBHorizontalChrominanceScalingIncrement | RegSet B: Horizontal chrominance scaling increment
Public property | RegSetBHorizontalInputWindowLength | RegSet B: Horizontal input window length
Public property | RegSetBHorizontalInputWindowStart | RegSet B: Horizontal input window start
Public property | RegSetBHorizontalLuminancePhaseOffset | RegSet B: Horizontal luminance phase offset (unit: Pixel)
Public property | RegSetBHorizontalLuminanceScalingIncrementScale1024Data | RegSet B: Horizontal luminance scaling increment Scale=1024/[Data]
Public property | RegSetBHorizontalOutputWindowLength | RegSet B:Horizontal output window length
Public property | RegSetBHorizontalPrescaling | RegSet B: Horizontal prescaling
Public property | RegSetBITU656 | RegSet B: ITU 656
Public property | RegSetBLeadingLinesBefore1stYCBCRLineIsOutput | RegSet B: Leading lines before 1st Y + CB-CR line is output
Public property | RegSetBLinesOutput | RegSet B: Lines output
Public property | RegSetBLuminanceBrightnessControl | RegSet B: Luminance brightness control
Public property | RegSetBLuminanceContrastControl | RegSet B: Luminance contrast control
Public property | RegSetBLuminanceFIRFilter | RegSet B: Luminance FIR filter
Public property | RegSetBNextTask | RegSet B: Next task
Public property | RegSetBOutputFieldID | RegSet B: Output field ID
Public property | RegSetBPrescalerOutputIsRenormalizedByGainFactor | RegSet B: Prescaler output is renormalized by gain factor
Public property | RegSetBReferenceEdgeForFieldDetection | RegSet B: Reference edge for field detection
Public property | RegSetBReferenceSignals | RegSet B: Reference signals:
Public property | RegSetBSamplingScheme | RegSet B: Sampling scheme
Public property | RegSetBSAVEAVCodeBitD5VGate | RegSet B: SAV/EAV code bit D5 (V) gate
Public property | RegSetBSAVEAVCodeBitsD6AndD5FAndV | RegSet B: SAV/EAV code bits D6 and D5 (F and V)
Public property | RegSetBScalerInputSource | RegSet B: Scaler input source:
Public property | RegSetBScalerInputSource__1 | RegSet B: Scaler input source
Public property | RegSetBScalerSAVEAVByte | RegSet B: Scaler SAV/EAV byte
Public property | RegSetBTaskHandlingControl | RegSet B: Task handling control
Public property | RegSetBVerticalChrominancePhaseOffsetData32 | RegSet B: Vertical chrominance phase offset=[Data]/32
Public property | RegSetBVerticalChrominanceScalingIncrement | RegSet B: Vertical chrominance scaling increment
Public property | RegSetBVerticalInputWindowLength | RegSet B: Vertical input window length
Public property | RegSetBVerticalInputWindowStart | RegSet B: Vertical input window start
Public property | RegSetBVerticalLuminancePhaseOffsetData32 | RegSet B: Vertical luminance phase offset=[Data]/32
Public property | RegSetBVerticalLuminanceScalingIncrementScale1024Data | RegSet B: Vertical luminance scaling increment Scale=1024/[Data]
Public property | RegSetBVerticalOutputWindowLength | RegSet B:Vertical output window length
Public property | RegSetBWeightingOfAllAccumulatedSamples | RegSet B: Weighting of all accumulated samples
Public property | RegSetBXCLK | RegSet B: XCLK
Public property | RegSetBXPortFieldID | RegSet B: X port field ID
Public property | RegSetBXRV | RegSet B: XRV
Public property | RegSetBYMIR | RegSet B: YMIR
Public property | RegSetBYMODE | RegSet B: YMODE
Public property | RemodulationBandwidthForLuminance | Remodulation bandwidth for luminance
Public property | RTCOOutputEnable | RTCO output enable
Public property | RTSignalControlRTS0Output | RT signal control: RTS0 output
Public property | RTSignalControlRTS1Output | RT signal control: RTS1 output
Public property | Scaler | Scaler
Public property | SDIDCodes | SDID codes
Public property | SharpnessControl | Sharpness control
Public property | SlowTimeConstantActiveInWIPAMode | Slow time constant active in WIPA mode
Public property | SpecialCasesOfDIDProgramming | Special cases of DID programming
Public property | StandardDetectionSearchLoopLatency | Standard detection search loop latency
Public property | StatusBitForHorizontalAndVerticalLoop | Status bit for horizontal and vertical loop
Public property | StatusBitForInterlaceDetection | Status bit for interlace detection
Public property | StatusBitForLockedHorizontalFrequency | Status bit for locked horizontal frequency
Public property | SWRST | SWRST
Public property | UpdateHysteresisFor9BitGain | Update hysteresis for 9-bit gain
Public property | UpdateTimeIntervalForAGCValue | Update time interval for AGC value
Public property | VerticalNoiseReduction | Vertical noise reduction
Public property | VerticalOffset | Vertical offset
Public property | VGATEStart | VGATE start
Public property | VGATEStop | VGATE stop
Public property | VideoDataLimitedToRangeIDQ | Video data limited to range: IDQ
Public property | VideoDataLimitedToRangeIGP0 | Video data limited to range: IGP0
Public property | VideoDataLimitedToRangeIGP1 | Video data limited to range: IGP1
Public property | VideoDataLimitedToRangeIGPH | Video data limited to range: IGPH
Public property | VideoDataLimitedToRangeIGPV | Video data limited to range: IGPV
Public property | VPSValid | VPS valid
Public property | WhitePeakControlOff | White peak control off
Public property | WhitePeakLoopIsActivated | White peak loop is activated
Public property | XCLK | XCLK
Public property | XPD7ToXPD0 | XPD7 to XPD0
Public property | XPortOutput | X port output
Public property | XPortXRHOutputSelection | X port XRH output selection
Public property | XPortXRVOutputSelection | X port XRV output selection
Public property | XRDYOutputSignal | XRDY output signal
Public property | XTOUTOutputEnable | XTOUT output enable
Public property | XTRIStatusOnInputPinXTRIIfNotUsedFor3StateControl | XTRI status on input pin XTRI, if not used for 3-state control
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Multistandard video decoder with adaptive comb filter and component video input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Saa7118(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Saa7118

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118 Properties

The Saa7118 type exposes the following members.

Properties
 | Name | Description
Public property | AdaptiveChrominanceCombFilter | Adaptive chrominance comb filter
Public property | AdaptiveLuminanceCombFilter | Adaptive luminance comb filter
Public property | ADCClockSelector | ADC clock selector
Public property | ADCSampleClockPhaseDelay | ADC sample clock phase delay
Public property | ADPortOutputEnable | AD port output enable
Public property | AGCHoldDuringVerticalBlankingPeriod | AGC hold during vertical blanking period
Public property | ALRCLKPhase | ALRCLK phase
Public property | AlternativeVGATEPosition | Alternative VGATE position
Public property | AmplitudeSearching | Amplitude searching
Public property | AnalogFunctionSelect | Analog function select
Public property | AnalogInputControl3 | Analog input control 3
Public property | AnalogInputControl4 | Analog input control 4
Public property | AnalogInputControl6 | Analog input control 6
Public property | AnalogInputControl7 | Analog input control 7
Public property | AnalogTestSelect | Analog test select
Public property | ASCLKPhase | ASCLK phase
Public property | AudioClockGeneration | Audio clock generation
Public property | AudioMasterClockCyclesPerField | Audio master clock cycles per field
Public property | AudioMasterClockNominalIncrement | Audio master clock nominal increment
Public property | AudioMasterClockVerticalReference | Audio master clock vertical reference
Public property | AudioPLLModes | Audio PLL modes
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AutomaticChrominanceGainControl | Automatic chrominance gain control
Public property | AutomaticChrominanceStandardDetectionControl | Automatic chrominance standard detection control
Public property | AutomaticFieldDetection | Automatic field detection
Public property | AutomaticGainControlIntegration | Automatic gain control integration
Public property | ChipVersion | Chip version
Public property | ChrominanceBandwidth | Chrominance bandwidth
Public property | ChrominanceGainValue | Chrominance gain value
Public property | ChrominanceHueControl | Chrominance hue control
Public property | ChrominanceSaturationControl | Chrominance saturation control
Public property | ChrominanceSaturationControlComponentPart | Chrominance saturation control component part
Public property | ChrominanceTrapCombFilterBypass | Chrominance trap/comb filter bypass
Public property | ClampingReferenceSelectionForAllADCs | Clamping/reference selection for all ADCs
Public property | ClearDTO | Clear DTO
Public property | ClockRatioAudioMasterClockToSerialBitClock | Clock ratio audio master clock to serial bit clock
Public property | ClockRatioSerialBitClockToChannelSelectClock | Clock ratio serial bit clock to channel select clock
Public property | ClosedCaptionValid | Closed caption valid
Public property | ColourOn | Colour on
Public property | ColourPeakOff | Colour peak off
Public property | ColourStandardSelectionInAUTOMode | Colour standard selection in AUTO mode
Public property | CombinedLuminanceChrominanceBandwidthAdjustment | Combined luminance/chrominance bandwidth adjustment
Public property | CompatibilityBitForSAA7199 | Compatibility bit for SAA7199
Public property | ComponentInputDelayAdjustmentRelativeToDecodedCVBSSignal | Component input delay adjustment relative to decoded CVBS signal (unit: pixel)
Public property | ComponentLuminancePeaking | Component luminance peaking
Public property | CopyProtectedSourceDetected | Copy protected source detected
Public property | DataType | Data type
Public property | DecoderAndVBISlicer | Decoder and VBI slicer
Public property | DetectedColourStandard | Detected colour standard
Public property | DisableChrominanceVerticalFilterAndPALPhaseErrorCorrection | Disable chrominance vertical filter and PAL phase error correction
Public property | DOSL | DOSL
Public property | DPROG | DPROG
Public property | DwordByteSwapInfluencesSerialOutputTiming | Dword byte swap, influences serial output timing
Public property | EnableExternalSourceSwitchIndicatorInputEXMCLR | Enable external source switch indicator Input EXMCLR
Public property | ERROFErrorFlagOfScalersOutputFormatterNormallySet | ERROF error flag of scalers output formatter, normally set
Public property | FAEFIFOFlagAlmostEmptyLevel | FAE FIFO flag almost empty level
Public property | FAEFIFOFlagAlmostFullLevel | FAE FIFO flag almost full level
Public property | FastColourTimeConstant | Fast colour time constant
Public property | FastSwitchEnable | Fast switch enable
Public property | FastSwitchInputDelayAdjustmentRelativeToComponentInputSignal | Fast switch input delay adjustment relative to component input signal (unit: pixel)
Public property | FastSwitchInputPolarityFSWE01 | Fast switch input polarity (FSWE=0/1)
Public property | FFILStatusOfTheInternalFIFOAlmostFilledFlag | FFIL status of the internal 'FIFO almost filled' flag
Public property | FFOVStatusOfTheInternalFIFOOverflowFlag | FFOV status of the internal 'FIFO overflow' flag
Public property | FIDSCIStatusOfTheFieldSequenceIDAtTheScalersInput | FIDSCI status of the field sequence ID at the scalers input
Public property | FIDSCOStatusOfTheFieldSequenceIDAtTheScalersOutput | FIDSCO status of the field sequence ID at the scalers output
Public property | FieldIDAndVBlankSelectionForTextOutput | Field ID and V-blank selection for text output
Public property | FieldIDAsSeenByTheVBISlicer | Field ID as seen by the VBI slicer
Public property | FieldOffset | Field offset
Public property | FieldSelection | Field selection
Public property | FineOffsetAdjustmentBYComponent | Fine offset adjustment B - Y component
Public property | FineOffsetAdjustmentRYComponent | Fine offset adjustment R - Y component
Public property | FinePositionOfHS | Fine position of HS
Public property | ForcedODDEVENToggle | Forced ODD/EVEN toggle
Public property | FramingCodeError | Framing code error
Public property | FramingCodeValid0Error | Framing code valid (0 error)
Public property | FramingCodeValid1Error | Framing code valid (1 error)
Public property | GainControlFix | Gain control fix
Public property | GainValueForActiveLuminanceChannelIsLimitedMaximumTop | Gain value for active luminance channel is limited; maximum (top)
Public property | GainValueForActiveLuminanceChannelIsLimitedMinimumBottom | Gain value for active luminance channel is limited; minimum (bottom)
Public property | GlobalControl1BackEndClock | Global control 1: back-end clock
Public property | GlobalControl1DefinitionOfTheFAndVTimingOfTheScalerOutput | Global control 1: Definition of the F and V timing of the scaler output
Public property | GlobalControl1IDQ | Global control 1: IDQ
Public property | GlobalControl1IDQPin | Global control 1: IDQ pin
Public property | GlobalControl1TaskOfRegisterSetA | Global control 1: Task of register set A
Public property | GlobalControl1TaskOfRegisterSetB | Global control 1: Task of register set B
Public property | HammingCheck | Hamming check
Public property | HLNotReferenceSelect | HL not reference select
Public property | HorizontalLockIndicatorSelection | Horizontal lock indicator selection
Public property | HorizontalOffset | Horizontal offset
Public property | HorizontalPLL | Horizontal PLL
Public property | HorizontalSyncStartDelayTimeStepSize8LLC | Horizontal sync start: Delay Time (Step size=8/LLC)
Public property | HorizontalSyncStopDelayTimeStepSize8LLC | Horizontal sync stop: Delay Time (Step size=8/LLC)
Public property | HorizontalTimeConstantSelection | Horizontal time constant selection
Public property | IdentificationBitForDetectedFieldFrequency | Identification bit for detected field frequency
Public property | IDG0 | IDG0
Public property | IDG1 | IDG1
Public property | IDH | IDH
Public property | IDV | IDV
Public property | ILLV | ILLV
Public property | IncrementDelay | Increment delay
Public property | InterruptEnableClosedCaptionDetectedLost | Interrupt enable 'closed caption detected/lost'
Public property | InterruptEnableColourStandardChanged0 | Interrupt enable 'colour standard changed 0'
Public property | InterruptEnableColourStandardChanged1 | Interrupt enable 'colour standard changed 1'
Public property | InterruptEnableColourStripeBurstAnyTypeDetectedLost | Interrupt enable 'colour stripe burst (any type) detected/lost'
Public property | InterruptEnableColourStripeType3BurstDetectedLost | Interrupt enable 'colour stripe type 3 burst detected/lost'
Public property | InterruptEnableCopyProtectedSignalFoundLost | Interrupt enable 'copy protected signal found/lost'
Public property | InterruptEnableErrorOutputFormatter | Interrupt enable 'error output formatter'
Public property | InterruptEnableFieldFrequencyHasChanged | Interrupt enable 'field frequency has changed'
Public property | InterruptEnableHorizontalAndVerticalLockReachedLost | Interrupt enable 'horizontal and vertical lock reached/lost'
Public property | InterruptEnableHorizontalPLLLockedUnlocked | Interrupt enable 'horizontal PLL locked/unlocked'
Public property | InterruptEnableInterlacedNonInterlacedSource | Interrupt enable 'interlaced/non-interlaced source'
Public property | InterruptEnablePALplusDetectedLost | Interrupt enable 'PALplus detected/lost'
Public property | InterruptEnableReadyForCaptureNotReady | Interrupt enable 'ready for capture/not ready'
Public property | InterruptEnableVPSSignalDetectedLost | Interrupt enable 'VPS signal detected/lost'
Public property | IPortIOEnableICLK | I port I/O enable: ICLK
Public property | IPortIOEnableIDQ | I port I/O enable: IDQ
Public property | IPortIOEnableIPortIOEnable | I port I/O enable: I port I/O enable
Public property | IPortSignalDefinitions | I port signal definitions
Public property | ITRIStatusOnInputPinITRIIfNotUsedFor3StateControl | ITRI status on input pin ITRI, if not used for 3-state control
Public property | LCR10Field1 | LCR10: Field 1
Public property | LCR10Field2 | LCR10: Field 2
Public property | LCR11Field1 | LCR11: Field 1
Public property | LCR11Field2 | LCR11: Field 2
Public property | LCR12Field1 | LCR12: Field 1
Public property | LCR12Field2 | LCR12: Field 2
Public property | LCR13Field1 | LCR13: Field 1
Public property | LCR13Field2 | LCR13: Field 2
Public property | LCR14Field1 | LCR14: Field 1
Public property | LCR14Field2 | LCR14: Field 2
Public property | LCR15Field1 | LCR15: Field 1
Public property | LCR15Field2 | LCR15: Field 2
Public property | LCR16Field1 | LCR16: Field 1
Public property | LCR16Field2 | LCR16: Field 2
Public property | LCR17Field1 | LCR17: Field 1
Public property | LCR17Field2 | LCR17: Field 2
Public property | LCR18Field1 | LCR18: Field 1
Public property | LCR18Field2 | LCR18: Field 2
Public property | LCR19Field1 | LCR19: Field 1
Public property | LCR19Field2 | LCR19: Field 2
Public property | LCR20Field1 | LCR20: Field 1
Public property | LCR20Field2 | LCR20: Field 2
Public property | LCR21Field1 | LCR21: Field 1
Public property | LCR21Field2 | LCR21: Field 2
Public property | LCR22Field1 | LCR22: Field 1
Public property | LCR22Field2 | LCR22: Field 2
Public property | LCR23Field1 | LCR23: Field 1
Public property | LCR23Field2 | LCR23: Field 2
Public property | LCR24Field1 | LCR24: Field 1
Public property | LCR24Field2 | LCR24: Field 2
Public property | LCR2Field1 | LCR2: Field 1
Public property | LCR2Field2 | LCR2: Field 2
Public property | LCR3Field1 | LCR3: Field 1
Public property | LCR3Field2 | LCR3: Field 2
Public property | LCR4Field1 | LCR4: Field 1
Public property | LCR4Field2 | LCR4: Field 2
Public property | LCR5Field1 | LCR5: Field 1
Public property | LCR5Field2 | LCR5: Field 2
Public property | LCR6Field1 | LCR6: Field 1
Public property | LCR6Field2 | LCR6: Field 2
Public property | LCR7Field1 | LCR7: Field 1
Public property | LCR7Field2 | LCR7: Field 2
Public property | LCR8Field1 | LCR8: Field 1
Public property | LCR8Field2 | LCR8: Field 2
Public property | LCR9Field1 | LCR9: Field 1
Public property | LCR9Field2 | LCR9: Field 2
Public property | LineNumber | Line Number
Public property | LLC2OutputEnable | LLC2 output enable
Public property | LLCOutputEnable | LLC output enable
Public property | LuminanceBrightnessControlComponentPart | Luminance brightness control component part
Public property | LuminanceBrightnessControlDecoderPart | Luminance brightness control: decoder part
Public property | LuminanceContrastControlComponentPart | Luminance contrast control component part
Public property | LuminanceContrastControlDecoderPartNegInverse | Luminance contrast control: Decoder part (neg=inverse)
Public property | LuminanceDelayCompensation | Luminance delay compensation
Public property | MacrovisionEncodedColourStripeBurstDetected | Macrovision encoded colour stripe burst detected
Public property | MacrovisionEncodedColourStripeBurstType34LineVersionDetected | Macrovision encoded colour stripe burst type 3 (4 line version) detected
Public property | ModeSelection | Mode selection
Public property | PALplusValid | PALplus valid
Public property | PolarityOfRTS0OutputSignal | Polarity of RTS0 output signal
Public property | PolarityOfRTS1OutputSignal | Polarity of RTS1 output signal
Public property | PRDONCopyOfBitDPROGCanBeUsedToDetectPowerUpAndStartUpFails | PRDON copy of bit DPROG, can be used to detect power-up and start-up fails
Public property | ProcessingDelayInNonCombFilterMode | Processing delay in non comb filter mode
Public property | ProgrammableFramingCode | Programmable framing code
Public property | RawDataGainControl | Raw data gain control
Public property | RawDataOffsetControl | Raw data offset control (unit: LSB)
Public property | ReadyForCapture | Ready for capture
Public property | Recode | Recode
Public property | RegSetAAccumulationLength | RegSet A: Accumulation length
Public property | RegSetAChromaIsProvided | RegSet A: Chroma is provided
Public property | RegSetAChrominanceFIRFilter | RegSet A: Chrominance FIR filter
Public property | RegSetADataQualified | RegSet A: Data qualified:
Public property | RegSetADwordsTransferred | RegSet A: Dwords transferred
Public property | RegSetAEdgeOfXRHInputIsHorizontalReference | RegSet A: Edge of XRH input is horizontal reference
Public property | RegSetAEdgeOfXRVInputAndDecoderV123IsVerticalReference | RegSet A: Edge of XRV input and decoder V123 is vertical reference:
Public property | RegSetAEventHandlerTriggers | RegSet A: Event handler triggers
Public property | RegSetAFormat | RegSet A: Format
Public property | RegSetAGain | RegSet A: Gain
Public property | RegSetAHorizontalChrominancePhaseOffset | RegSet A: Horizontal chrominance phase offset
Public property | RegSetAHorizontalChrominanceScalingIncrement | RegSet A: Horizontal chrominance scaling increment
Public property | RegSetAHorizontalInputWindowLength | RegSet A: Horizontal input window length
Public property | RegSetAHorizontalInputWindowStart | RegSet A: Horizontal input window start
Public property | RegSetAHorizontalLuminancePhaseOffset | RegSet A: Horizontal luminance phase offset (unit: Pixel)
Public property | RegSetAHorizontalLuminanceScalingIncrementScale1024Data | RegSet A: Horizontal luminance scaling increment Scale=1024/[Data]
Public property | RegSetAHorizontalOutputWindowLength | RegSet A:Horizontal output window length
Public property | RegSetAHorizontalPrescaling | RegSet A: Horizontal prescaling
Public property | RegSetAITU656 | RegSet A: ITU 656
Public property | RegSetALeadingLinesBefore1stYCBCRLineIsOutput | RegSet A: Leading lines before 1st Y + CB-CR line is output
Public property | RegSetALinesOutput | RegSet A: Lines output
Public property | RegSetALuminanceBrightnessControl | RegSet A: Luminance brightness control
Public property | RegSetALuminanceContrastControl | RegSet A: Luminance contrast control
Public property | RegSetALuminanceFIRFilter | RegSet A: Luminance FIR filter
Public property | RegSetANextTask | RegSet A: Next task
Public property | RegSetAOutputFieldID | RegSet A: Output field ID
Public property | RegSetAPrescalerOutputIsRenormalizedByGainFactor | RegSet A: Prescaler output is renormalized by gain factor
Public property | RegSetAReferenceEdgeForFieldDetection | RegSet A: Reference edge for field detection
Public property | RegSetAReferenceSignals | RegSet A: Reference signals:
Public property | RegSetASamplingScheme | RegSet A: Sampling scheme
Public property | RegSetASAVEAVCodeBitD5VGate | RegSet A: SAV/EAV code bit D5 (V) gate
Public property | RegSetASAVEAVCodeBitsD6AndD5FAndV | RegSet A: SAV/EAV code bits D6 and D5 (F and V)
Public property | RegSetAScalerInputSource | RegSet A: Scaler input source:
Public property | RegSetAScalerInputSource__1 | RegSet A: Scaler input source
Public property | RegSetAScalerSAVEAVByte | RegSet A: Scaler SAV/EAV byte
Public property | RegSetATaskHandlingControl | RegSet A: Task handling control
Public property | RegSetAVerticalChrominancePhaseOffsetData32 | RegSet A: Vertical chrominance phase offset=[Data]/32
Public property | RegSetAVerticalChrominanceScalingIncrement | RegSet A: Vertical chrominance scaling increment
Public property | RegSetAVerticalInputWindowLength | RegSet A: Vertical input window length
Public property | RegSetAVerticalInputWindowStart | RegSet A: Vertical input window start
Public property | RegSetAVerticalLuminancePhaseOffsetData32 | RegSet A: Vertical luminance phase offset=[Data]/32
Public property | RegSetAVerticalLuminanceScalingIncrementScale1024Data | RegSet A: Vertical luminance scaling increment Scale=1024/[Data]
Public property | RegSetAVerticalOutputWindowLength | RegSet A:Vertical output window length
Public property | RegSetAWeightingOfAllAccumulatedSamples | RegSet A: Weighting of all accumulated samples
Public property | RegSetAXCLK | RegSet A: XCLK
Public property | RegSetAXPortFieldID | RegSet A: X port field ID
Public property | RegSetAXRV | RegSet A: XRV
Public property | RegSetAYMIR | RegSet A: YMIR
Public property | RegSetAYMODE | RegSet A: YMODE
Public property | RegSetBAccumulationLength | RegSet B: Accumulation length
Public property | RegSetBChromaIsProvided | RegSet B: Chroma is provided
Public property | RegSetBChrominanceFIRFilter | RegSet B: Chrominance FIR filter
Public property | RegSetBDataQualified | RegSet B: Data qualified:
Public property | RegSetBDwordsTransferred | RegSet B: Dwords transferred
Public property | RegSetBEdgeOfXRHInputIsHorizontalReference | RegSet B: Edge of XRH input is horizontal reference
Public property | RegSetBEdgeOfXRVInputAndDecoderV123IsVerticalReference | RegSet B: Edge of XRV input and decoder V123 is vertical reference:
Public property | RegSetBEventHandlerTriggers | RegSet B: Event handler triggers
Public property | RegSetBFormat | RegSet B: Format
Public property | RegSetBGain | RegSet B: Gain
Public property | RegSetBHorizontalChrominancePhaseOffset | RegSet B: Horizontal chrominance phase offset
Public property | RegSetBHorizontalChrominanceScalingIncrement | RegSet B: Horizontal chrominance scaling increment
Public property | RegSetBHorizontalInputWindowLength | RegSet B: Horizontal input window length
Public property | RegSetBHorizontalInputWindowStart | RegSet B: Horizontal input window start
Public property | RegSetBHorizontalLuminancePhaseOffset | RegSet B: Horizontal luminance phase offset (unit: Pixel)
Public property | RegSetBHorizontalLuminanceScalingIncrementScale1024Data | RegSet B: Horizontal luminance scaling increment Scale=1024/[Data]
Public property | RegSetBHorizontalOutputWindowLength | RegSet B:Horizontal output window length
Public property | RegSetBHorizontalPrescaling | RegSet B: Horizontal prescaling
Public property | RegSetBITU656 | RegSet B: ITU 656
Public property | RegSetBLeadingLinesBefore1stYCBCRLineIsOutput | RegSet B: Leading lines before 1st Y + CB-CR line is output
Public property | RegSetBLinesOutput | RegSet B: Lines output
Public property | RegSetBLuminanceBrightnessControl | RegSet B: Luminance brightness control
Public property | RegSetBLuminanceContrastControl | RegSet B: Luminance contrast control
Public property | RegSetBLuminanceFIRFilter | RegSet B: Luminance FIR filter
Public property | RegSetBNextTask | RegSet B: Next task
Public property | RegSetBOutputFieldID | RegSet B: Output field ID
Public property | RegSetBPrescalerOutputIsRenormalizedByGainFactor | RegSet B: Prescaler output is renormalized by gain factor
Public property | RegSetBReferenceEdgeForFieldDetection | RegSet B: Reference edge for field detection
Public property | RegSetBReferenceSignals | RegSet B: Reference signals:
Public property | RegSetBSamplingScheme | RegSet B: Sampling scheme
Public property | RegSetBSAVEAVCodeBitD5VGate | RegSet B: SAV/EAV code bit D5 (V) gate
Public property | RegSetBSAVEAVCodeBitsD6AndD5FAndV | RegSet B: SAV/EAV code bits D6 and D5 (F and V)
Public property | RegSetBScalerInputSource | RegSet B: Scaler input source:
Public property | RegSetBScalerInputSource__1 | RegSet B: Scaler input source
Public property | RegSetBScalerSAVEAVByte | RegSet B: Scaler SAV/EAV byte
Public property | RegSetBTaskHandlingControl | RegSet B: Task handling control
Public property | RegSetBVerticalChrominancePhaseOffsetData32 | RegSet B: Vertical chrominance phase offset=[Data]/32
Public property | RegSetBVerticalChrominanceScalingIncrement | RegSet B: Vertical chrominance scaling increment
Public property | RegSetBVerticalInputWindowLength | RegSet B: Vertical input window length
Public property | RegSetBVerticalInputWindowStart | RegSet B: Vertical input window start
Public property | RegSetBVerticalLuminancePhaseOffsetData32 | RegSet B: Vertical luminance phase offset=[Data]/32
Public property | RegSetBVerticalLuminanceScalingIncrementScale1024Data | RegSet B: Vertical luminance scaling increment Scale=1024/[Data]
Public property | RegSetBVerticalOutputWindowLength | RegSet B:Vertical output window length
Public property | RegSetBWeightingOfAllAccumulatedSamples | RegSet B: Weighting of all accumulated samples
Public property | RegSetBXCLK | RegSet B: XCLK
Public property | RegSetBXPortFieldID | RegSet B: X port field ID
Public property | RegSetBXRV | RegSet B: XRV
Public property | RegSetBYMIR | RegSet B: YMIR
Public property | RegSetBYMODE | RegSet B: YMODE
Public property | RemodulationBandwidthForLuminance | Remodulation bandwidth for luminance
Public property | RTCOOutputEnable | RTCO output enable
Public property | RTSignalControlRTS0Output | RT signal control: RTS0 output
Public property | RTSignalControlRTS1Output | RT signal control: RTS1 output
Public property | Scaler | Scaler
Public property | SDIDCodes | SDID codes
Public property | SharpnessControl | Sharpness control
Public property | SlowTimeConstantActiveInWIPAMode | Slow time constant active in WIPA mode
Public property | SpecialCasesOfDIDProgramming | Special cases of DID programming
Public property | StandardDetectionSearchLoopLatency | Standard detection search loop latency
Public property | StatusBitForHorizontalAndVerticalLoop | Status bit for horizontal and vertical loop
Public property | StatusBitForInterlaceDetection | Status bit for interlace detection
Public property | StatusBitForLockedHorizontalFrequency | Status bit for locked horizontal frequency
Public property | SWRST | SWRST
Public property | UpdateHysteresisFor9BitGain | Update hysteresis for 9-bit gain
Public property | UpdateTimeIntervalForAGCValue | Update time interval for AGC value
Public property | VerticalNoiseReduction | Vertical noise reduction
Public property | VerticalOffset | Vertical offset
Public property | VGATEStart | VGATE start
Public property | VGATEStop | VGATE stop
Public property | VideoDataLimitedToRangeIDQ | Video data limited to range: IDQ
Public property | VideoDataLimitedToRangeIGP0 | Video data limited to range: IGP0
Public property | VideoDataLimitedToRangeIGP1 | Video data limited to range: IGP1
Public property | VideoDataLimitedToRangeIGPH | Video data limited to range: IGPH
Public property | VideoDataLimitedToRangeIGPV | Video data limited to range: IGPV
Public property | VPSValid | VPS valid
Public property | WhitePeakControlOff | White peak control off
Public property | WhitePeakLoopIsActivated | White peak loop is activated
Public property | XCLK | XCLK
Public property | XPD7ToXPD0 | XPD7 to XPD0
Public property | XPortOutput | X port output
Public property | XPortXRHOutputSelection | X port XRH output selection
Public property | XPortXRVOutputSelection | X port XRV output selection
Public property | XRDYOutputSignal | XRDY output signal
Public property | XTOUTOutputEnable | XTOUT output enable
Public property | XTRIStatusOnInputPinXTRIIfNotUsedFor3StateControl | XTRI status on input pin XTRI, if not used for 3-state control
Top
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AdaptiveChrominanceCombFilter Property

IRD

Saa7118AdaptiveChrominanceCombFilter Property

Adaptive chrominance comb filter

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDCHROMINANCECONTROL10 AdaptiveChrominanceCombFilter { get; set; }
Public Property AdaptiveChrominanceCombFilter As Saa7118TYPIDCHROMINANCECONTROL10
    Get
    Set
public:
property Saa7118TYPIDCHROMINANCECONTROL10 AdaptiveChrominanceCombFilter {
    Saa7118TYPIDCHROMINANCECONTROL10 get ();
    void set (Saa7118TYPIDCHROMINANCECONTROL10 value);
}
member AdaptiveChrominanceCombFilter : Saa7118TYPIDCHROMINANCECONTROL10 with get, set

Property Value

Type: Saa7118TYPIDCHROMINANCECONTROL10
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AdaptiveLuminanceCombFilter Property

IRD

Saa7118AdaptiveLuminanceCombFilter Property

Adaptive luminance comb filter

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLUMINANCECONTROL3 AdaptiveLuminanceCombFilter { get; set; }
Public Property AdaptiveLuminanceCombFilter As Saa7118TYPIDLUMINANCECONTROL3
    Get
    Set
public:
property Saa7118TYPIDLUMINANCECONTROL3 AdaptiveLuminanceCombFilter {
    Saa7118TYPIDLUMINANCECONTROL3 get ();
    void set (Saa7118TYPIDLUMINANCECONTROL3 value);
}
member AdaptiveLuminanceCombFilter : Saa7118TYPIDLUMINANCECONTROL3 with get, set

Property Value

Type: Saa7118TYPIDLUMINANCECONTROL3
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ADCClockSelector Property

IRD

Saa7118ADCClockSelector Property

ADC clock selector

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDANALOGINPUTCONTROL52 ADCClockSelector { get; set; }
Public Property ADCClockSelector As Saa7118TYPIDANALOGINPUTCONTROL52
    Get
    Set
public:
property Saa7118TYPIDANALOGINPUTCONTROL52 ADCClockSelector {
    Saa7118TYPIDANALOGINPUTCONTROL52 get ();
    void set (Saa7118TYPIDANALOGINPUTCONTROL52 value);
}
member ADCClockSelector : Saa7118TYPIDANALOGINPUTCONTROL52 with get, set

Property Value

Type: Saa7118TYPIDANALOGINPUTCONTROL52
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ADCSampleClockPhaseDelay Property

IRD

Saa7118ADCSampleClockPhaseDelay Property

ADC sample clock phase delay

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCSampleClockPhaseDelay { get; set; }
Public Property ADCSampleClockPhaseDelay As Byte
    Get
    Set
public:
property unsigned char ADCSampleClockPhaseDelay {
    unsigned char get ();
    void set (unsigned char value);
}
member ADCSampleClockPhaseDelay : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ADPortOutputEnable Property

IRD

Saa7118ADPortOutputEnable Property

AD port output enable

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDANALOGINPUTCONTROL53 ADPortOutputEnable { get; set; }
Public Property ADPortOutputEnable As Saa7118TYPIDANALOGINPUTCONTROL53
    Get
    Set
public:
property Saa7118TYPIDANALOGINPUTCONTROL53 ADPortOutputEnable {
    Saa7118TYPIDANALOGINPUTCONTROL53 get ();
    void set (Saa7118TYPIDANALOGINPUTCONTROL53 value);
}
member ADPortOutputEnable : Saa7118TYPIDANALOGINPUTCONTROL53 with get, set

Property Value

Type: Saa7118TYPIDANALOGINPUTCONTROL53
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AGCHoldDuringVerticalBlankingPeriod Property

IRD

Saa7118AGCHoldDuringVerticalBlankingPeriod Property

AGC hold during vertical blanking period

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDANALOGINPUTCONTROL23 AGCHoldDuringVerticalBlankingPeriod { get; set; }
Public Property AGCHoldDuringVerticalBlankingPeriod As Saa7118TYPIDANALOGINPUTCONTROL23
    Get
    Set
public:
property Saa7118TYPIDANALOGINPUTCONTROL23 AGCHoldDuringVerticalBlankingPeriod {
    Saa7118TYPIDANALOGINPUTCONTROL23 get ();
    void set (Saa7118TYPIDANALOGINPUTCONTROL23 value);
}
member AGCHoldDuringVerticalBlankingPeriod : Saa7118TYPIDANALOGINPUTCONTROL23 with get, set

Property Value

Type: Saa7118TYPIDANALOGINPUTCONTROL23
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ALRCLKPhase Property

IRD

Saa7118ALRCLKPhase Property

ALRCLK phase

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDAUDIOCLOCKCONTROL1 ALRCLKPhase { get; set; }
Public Property ALRCLKPhase As Saa7118TYPIDAUDIOCLOCKCONTROL1
    Get
    Set
public:
property Saa7118TYPIDAUDIOCLOCKCONTROL1 ALRCLKPhase {
    Saa7118TYPIDAUDIOCLOCKCONTROL1 get ();
    void set (Saa7118TYPIDAUDIOCLOCKCONTROL1 value);
}
member ALRCLKPhase : Saa7118TYPIDAUDIOCLOCKCONTROL1 with get, set

Property Value

Type: Saa7118TYPIDAUDIOCLOCKCONTROL1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AlternativeVGATEPosition Property

IRD

Saa7118AlternativeVGATEPosition Property

Alternative VGATE position

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDMISCELLANEOUSVGATEMSBS0 AlternativeVGATEPosition { get; set; }
Public Property AlternativeVGATEPosition As Saa7118TYPIDMISCELLANEOUSVGATEMSBS0
    Get
    Set
public:
property Saa7118TYPIDMISCELLANEOUSVGATEMSBS0 AlternativeVGATEPosition {
    Saa7118TYPIDMISCELLANEOUSVGATEMSBS0 get ();
    void set (Saa7118TYPIDMISCELLANEOUSVGATEMSBS0 value);
}
member AlternativeVGATEPosition : Saa7118TYPIDMISCELLANEOUSVGATEMSBS0 with get, set

Property Value

Type: Saa7118TYPIDMISCELLANEOUSVGATEMSBS0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AmplitudeSearching Property

IRD

Saa7118AmplitudeSearching Property

Amplitude searching

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSLICERCONTROL10 AmplitudeSearching { get; set; }
Public Property AmplitudeSearching As Saa7118TYPIDSLICERCONTROL10
    Get
    Set
public:
property Saa7118TYPIDSLICERCONTROL10 AmplitudeSearching {
    Saa7118TYPIDSLICERCONTROL10 get ();
    void set (Saa7118TYPIDSLICERCONTROL10 value);
}
member AmplitudeSearching : Saa7118TYPIDSLICERCONTROL10 with get, set

Property Value

Type: Saa7118TYPIDSLICERCONTROL10
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AnalogFunctionSelect Property

IRD

Saa7118AnalogFunctionSelect Property

Analog function select

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDANALOGINPUTCONTROL11 AnalogFunctionSelect { get; set; }
Public Property AnalogFunctionSelect As Saa7118TYPIDANALOGINPUTCONTROL11
    Get
    Set
public:
property Saa7118TYPIDANALOGINPUTCONTROL11 AnalogFunctionSelect {
    Saa7118TYPIDANALOGINPUTCONTROL11 get ();
    void set (Saa7118TYPIDANALOGINPUTCONTROL11 value);
}
member AnalogFunctionSelect : Saa7118TYPIDANALOGINPUTCONTROL11 with get, set

Property Value

Type: Saa7118TYPIDANALOGINPUTCONTROL11
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AnalogInputControl3 Property

IRD

Saa7118AnalogInputControl3 Property

Analog input control 3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AnalogInputControl3 { get; set; }
Public Property AnalogInputControl3 As UShort
    Get
    Set
public:
property unsigned short AnalogInputControl3 {
    unsigned short get ();
    void set (unsigned short value);
}
member AnalogInputControl3 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AnalogInputControl4 Property

IRD

Saa7118AnalogInputControl4 Property

Analog input control 4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AnalogInputControl4 { get; set; }
Public Property AnalogInputControl4 As UShort
    Get
    Set
public:
property unsigned short AnalogInputControl4 {
    unsigned short get ();
    void set (unsigned short value);
}
member AnalogInputControl4 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AnalogInputControl6 Property

IRD

Saa7118AnalogInputControl6 Property

Analog input control 6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AnalogInputControl6 { get; set; }
Public Property AnalogInputControl6 As UShort
    Get
    Set
public:
property unsigned short AnalogInputControl6 {
    unsigned short get ();
    void set (unsigned short value);
}
member AnalogInputControl6 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AnalogInputControl7 Property

IRD

Saa7118AnalogInputControl7 Property

Analog input control 7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AnalogInputControl7 { get; set; }
Public Property AnalogInputControl7 As UShort
    Get
    Set
public:
property unsigned short AnalogInputControl7 {
    unsigned short get ();
    void set (unsigned short value);
}
member AnalogInputControl7 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AnalogTestSelect Property

IRD

Saa7118AnalogTestSelect Property

Analog test select

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL0 AnalogTestSelect { get; set; }
Public Property AnalogTestSelect As Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL0
    Get
    Set
public:
property Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL0 AnalogTestSelect {
    Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL0 get ();
    void set (Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL0 value);
}
member AnalogTestSelect : Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL0 with get, set

Property Value

Type: Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ASCLKPhase Property

IRD

Saa7118ASCLKPhase Property

ASCLK phase

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDAUDIOCLOCKCONTROL0 ASCLKPhase { get; set; }
Public Property ASCLKPhase As Saa7118TYPIDAUDIOCLOCKCONTROL0
    Get
    Set
public:
property Saa7118TYPIDAUDIOCLOCKCONTROL0 ASCLKPhase {
    Saa7118TYPIDAUDIOCLOCKCONTROL0 get ();
    void set (Saa7118TYPIDAUDIOCLOCKCONTROL0 value);
}
member ASCLKPhase : Saa7118TYPIDAUDIOCLOCKCONTROL0 with get, set

Property Value

Type: Saa7118TYPIDAUDIOCLOCKCONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AudioClockGeneration Property

IRD

Saa7118AudioClockGeneration Property

Audio clock generation

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL2 AudioClockGeneration { get; set; }
Public Property AudioClockGeneration As Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL2
    Get
    Set
public:
property Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL2 AudioClockGeneration {
    Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL2 get ();
    void set (Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL2 value);
}
member AudioClockGeneration : Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL2 with get, set

Property Value

Type: Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AudioMasterClockCyclesPerField Property

IRD

Saa7118AudioMasterClockCyclesPerField Property

Audio master clock cycles per field

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint AudioMasterClockCyclesPerField { get; set; }
Public Property AudioMasterClockCyclesPerField As UInteger
    Get
    Set
public:
property unsigned int AudioMasterClockCyclesPerField {
    unsigned int get ();
    void set (unsigned int value);
}
member AudioMasterClockCyclesPerField : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AudioMasterClockNominalIncrement Property

IRD

Saa7118AudioMasterClockNominalIncrement Property

Audio master clock nominal increment

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint AudioMasterClockNominalIncrement { get; set; }
Public Property AudioMasterClockNominalIncrement As UInteger
    Get
    Set
public:
property unsigned int AudioMasterClockNominalIncrement {
    unsigned int get ();
    void set (unsigned int value);
}
member AudioMasterClockNominalIncrement : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AudioMasterClockVerticalReference Property

IRD

Saa7118AudioMasterClockVerticalReference Property

Audio master clock vertical reference

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDAUDIOCLOCKCONTROL2 AudioMasterClockVerticalReference { get; set; }
Public Property AudioMasterClockVerticalReference As Saa7118TYPIDAUDIOCLOCKCONTROL2
    Get
    Set
public:
property Saa7118TYPIDAUDIOCLOCKCONTROL2 AudioMasterClockVerticalReference {
    Saa7118TYPIDAUDIOCLOCKCONTROL2 get ();
    void set (Saa7118TYPIDAUDIOCLOCKCONTROL2 value);
}
member AudioMasterClockVerticalReference : Saa7118TYPIDAUDIOCLOCKCONTROL2 with get, set

Property Value

Type: Saa7118TYPIDAUDIOCLOCKCONTROL2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AudioPLLModes Property

IRD

Saa7118AudioPLLModes Property

Audio PLL modes

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDAUDIOCLOCKCONTROL3 AudioPLLModes { get; set; }
Public Property AudioPLLModes As Saa7118TYPIDAUDIOCLOCKCONTROL3
    Get
    Set
public:
property Saa7118TYPIDAUDIOCLOCKCONTROL3 AudioPLLModes {
    Saa7118TYPIDAUDIOCLOCKCONTROL3 get ();
    void set (Saa7118TYPIDAUDIOCLOCKCONTROL3 value);
}
member AudioPLLModes : Saa7118TYPIDAUDIOCLOCKCONTROL3 with get, set

Property Value

Type: Saa7118TYPIDAUDIOCLOCKCONTROL3
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AutoFlush Property

IRD

Saa7118AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AutomaticChrominanceGainControl Property

IRD

Saa7118AutomaticChrominanceGainControl Property

Automatic chrominance gain control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDCHROMINANCEGAINCONTROL1 AutomaticChrominanceGainControl { get; set; }
Public Property AutomaticChrominanceGainControl As Saa7118TYPIDCHROMINANCEGAINCONTROL1
    Get
    Set
public:
property Saa7118TYPIDCHROMINANCEGAINCONTROL1 AutomaticChrominanceGainControl {
    Saa7118TYPIDCHROMINANCEGAINCONTROL1 get ();
    void set (Saa7118TYPIDCHROMINANCEGAINCONTROL1 value);
}
member AutomaticChrominanceGainControl : Saa7118TYPIDCHROMINANCEGAINCONTROL1 with get, set

Property Value

Type: Saa7118TYPIDCHROMINANCEGAINCONTROL1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AutomaticChrominanceStandardDetectionControl Property

IRD

Saa7118AutomaticChrominanceStandardDetectionControl Property

Automatic chrominance standard detection control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDCHROMINANCECONTROL101 AutomaticChrominanceStandardDetectionControl { get; set; }
Public Property AutomaticChrominanceStandardDetectionControl As Saa7118TYPIDCHROMINANCECONTROL101
    Get
    Set
public:
property Saa7118TYPIDCHROMINANCECONTROL101 AutomaticChrominanceStandardDetectionControl {
    Saa7118TYPIDCHROMINANCECONTROL101 get ();
    void set (Saa7118TYPIDCHROMINANCECONTROL101 value);
}
member AutomaticChrominanceStandardDetectionControl : Saa7118TYPIDCHROMINANCECONTROL101 with get, set

Property Value

Type: Saa7118TYPIDCHROMINANCECONTROL101
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AutomaticFieldDetection Property

IRD

Saa7118AutomaticFieldDetection Property

Automatic field detection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSYNCCONTROL5 AutomaticFieldDetection { get; set; }
Public Property AutomaticFieldDetection As Saa7118TYPIDSYNCCONTROL5
    Get
    Set
public:
property Saa7118TYPIDSYNCCONTROL5 AutomaticFieldDetection {
    Saa7118TYPIDSYNCCONTROL5 get ();
    void set (Saa7118TYPIDSYNCCONTROL5 value);
}
member AutomaticFieldDetection : Saa7118TYPIDSYNCCONTROL5 with get, set

Property Value

Type: Saa7118TYPIDSYNCCONTROL5
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.AutomaticGainControlIntegration Property

IRD

Saa7118AutomaticGainControlIntegration Property

Automatic gain control integration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDANALOGINPUTCONTROL21 AutomaticGainControlIntegration { get; set; }
Public Property AutomaticGainControlIntegration As Saa7118TYPIDANALOGINPUTCONTROL21
    Get
    Set
public:
property Saa7118TYPIDANALOGINPUTCONTROL21 AutomaticGainControlIntegration {
    Saa7118TYPIDANALOGINPUTCONTROL21 get ();
    void set (Saa7118TYPIDANALOGINPUTCONTROL21 value);
}
member AutomaticGainControlIntegration : Saa7118TYPIDANALOGINPUTCONTROL21 with get, set

Property Value

Type: Saa7118TYPIDANALOGINPUTCONTROL21
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ChipVersion Property

IRD

Saa7118ChipVersion Property

Chip version

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ChipVersion { get; }
Public ReadOnly Property ChipVersion As Byte
    Get
public:
property unsigned char ChipVersion {
    unsigned char get ();
}
member ChipVersion : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ChrominanceBandwidth Property

IRD

Saa7118ChrominanceBandwidth Property

Chrominance bandwidth

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDCHROMINANCECONTROL21 ChrominanceBandwidth { get; set; }
Public Property ChrominanceBandwidth As Saa7118TYPIDCHROMINANCECONTROL21
    Get
    Set
public:
property Saa7118TYPIDCHROMINANCECONTROL21 ChrominanceBandwidth {
    Saa7118TYPIDCHROMINANCECONTROL21 get ();
    void set (Saa7118TYPIDCHROMINANCECONTROL21 value);
}
member ChrominanceBandwidth : Saa7118TYPIDCHROMINANCECONTROL21 with get, set

Property Value

Type: Saa7118TYPIDCHROMINANCECONTROL21
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ChrominanceGainValue Property

IRD

Saa7118ChrominanceGainValue Property

Chrominance gain value

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDCHROMINANCEGAINCONTROL0 ChrominanceGainValue { get; set; }
Public Property ChrominanceGainValue As Saa7118TYPIDCHROMINANCEGAINCONTROL0
    Get
    Set
public:
property Saa7118TYPIDCHROMINANCEGAINCONTROL0 ChrominanceGainValue {
    Saa7118TYPIDCHROMINANCEGAINCONTROL0 get ();
    void set (Saa7118TYPIDCHROMINANCEGAINCONTROL0 value);
}
member ChrominanceGainValue : Saa7118TYPIDCHROMINANCEGAINCONTROL0 with get, set

Property Value

Type: Saa7118TYPIDCHROMINANCEGAINCONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ChrominanceHueControl Property

IRD

Saa7118ChrominanceHueControl Property

Chrominance hue control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ChrominanceHueControl { get; set; }
Public Property ChrominanceHueControl As Double
    Get
    Set
public:
property double ChrominanceHueControl {
    double get ();
    void set (double value);
}
member ChrominanceHueControl : float with get, set

Property Value

Type: Double
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ChrominanceSaturationControl Property

IRD

Saa7118ChrominanceSaturationControl Property

Chrominance saturation control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLUMINANCECONTRASLDECODERPART0 ChrominanceSaturationControl { get; set; }
Public Property ChrominanceSaturationControl As Saa7118TYPIDLUMINANCECONTRASLDECODERPART0
    Get
    Set
public:
property Saa7118TYPIDLUMINANCECONTRASLDECODERPART0 ChrominanceSaturationControl {
    Saa7118TYPIDLUMINANCECONTRASLDECODERPART0 get ();
    void set (Saa7118TYPIDLUMINANCECONTRASLDECODERPART0 value);
}
member ChrominanceSaturationControl : Saa7118TYPIDLUMINANCECONTRASLDECODERPART0 with get, set

Property Value

Type: Saa7118TYPIDLUMINANCECONTRASLDECODERPART0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ChrominanceSaturationControlComponentPart Property

IRD

Saa7118ChrominanceSaturationControlComponentPart Property

Chrominance saturation control component part

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLUMINANCECONTRASCOMPONENTPART0 ChrominanceSaturationControlComponentPart { get; set; }
Public Property ChrominanceSaturationControlComponentPart As Saa7118TYPIDLUMINANCECONTRASCOMPONENTPART0
    Get
    Set
public:
property Saa7118TYPIDLUMINANCECONTRASCOMPONENTPART0 ChrominanceSaturationControlComponentPart {
    Saa7118TYPIDLUMINANCECONTRASCOMPONENTPART0 get ();
    void set (Saa7118TYPIDLUMINANCECONTRASCOMPONENTPART0 value);
}
member ChrominanceSaturationControlComponentPart : Saa7118TYPIDLUMINANCECONTRASCOMPONENTPART0 with get, set

Property Value

Type: Saa7118TYPIDLUMINANCECONTRASCOMPONENTPART0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ChrominanceTrapCombFilterBypass Property

IRD

Saa7118ChrominanceTrapCombFilterBypass Property

Chrominance trap/comb filter bypass

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLUMINANCECONTROL4 ChrominanceTrapCombFilterBypass { get; set; }
Public Property ChrominanceTrapCombFilterBypass As Saa7118TYPIDLUMINANCECONTROL4
    Get
    Set
public:
property Saa7118TYPIDLUMINANCECONTROL4 ChrominanceTrapCombFilterBypass {
    Saa7118TYPIDLUMINANCECONTROL4 get ();
    void set (Saa7118TYPIDLUMINANCECONTROL4 value);
}
member ChrominanceTrapCombFilterBypass : Saa7118TYPIDLUMINANCECONTROL4 with get, set

Property Value

Type: Saa7118TYPIDLUMINANCECONTROL4
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ClampingReferenceSelectionForAllADCs Property

IRD

Saa7118ClampingReferenceSelectionForAllADCs Property

Clamping/reference selection for all ADCs

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDANALOGINPUTCONTROL51 ClampingReferenceSelectionForAllADCs { get; set; }
Public Property ClampingReferenceSelectionForAllADCs As Saa7118TYPIDANALOGINPUTCONTROL51
    Get
    Set
public:
property Saa7118TYPIDANALOGINPUTCONTROL51 ClampingReferenceSelectionForAllADCs {
    Saa7118TYPIDANALOGINPUTCONTROL51 get ();
    void set (Saa7118TYPIDANALOGINPUTCONTROL51 value);
}
member ClampingReferenceSelectionForAllADCs : Saa7118TYPIDANALOGINPUTCONTROL51 with get, set

Property Value

Type: Saa7118TYPIDANALOGINPUTCONTROL51
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ClearDTO Property

IRD

Saa7118ClearDTO Property

Clear DTO

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDCHROMINANCECONTROL14 ClearDTO { get; set; }
Public Property ClearDTO As Saa7118TYPIDCHROMINANCECONTROL14
    Get
    Set
public:
property Saa7118TYPIDCHROMINANCECONTROL14 ClearDTO {
    Saa7118TYPIDCHROMINANCECONTROL14 get ();
    void set (Saa7118TYPIDCHROMINANCECONTROL14 value);
}
member ClearDTO : Saa7118TYPIDCHROMINANCECONTROL14 with get, set

Property Value

Type: Saa7118TYPIDCHROMINANCECONTROL14
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ClockRatioAudioMasterClockToSerialBitClock Property

IRD

Saa7118ClockRatioAudioMasterClockToSerialBitClock Property

Clock ratio audio master clock to serial bit clock

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ClockRatioAudioMasterClockToSerialBitClock { get; set; }
Public Property ClockRatioAudioMasterClockToSerialBitClock As Byte
    Get
    Set
public:
property unsigned char ClockRatioAudioMasterClockToSerialBitClock {
    unsigned char get ();
    void set (unsigned char value);
}
member ClockRatioAudioMasterClockToSerialBitClock : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ClockRatioSerialBitClockToChannelSelectClock Property

IRD

Saa7118ClockRatioSerialBitClockToChannelSelectClock Property

Clock ratio serial bit clock to channel select clock

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ClockRatioSerialBitClockToChannelSelectClock { get; set; }
Public Property ClockRatioSerialBitClockToChannelSelectClock As Byte
    Get
    Set
public:
property unsigned char ClockRatioSerialBitClockToChannelSelectClock {
    unsigned char get ();
    void set (unsigned char value);
}
member ClockRatioSerialBitClockToChannelSelectClock : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ClosedCaptionValid Property

IRD

Saa7118ClosedCaptionValid Property

Closed caption valid

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSLICERSTATUSBYTE00 ClosedCaptionValid { get; }
Public ReadOnly Property ClosedCaptionValid As Saa7118TYPIDSLICERSTATUSBYTE00
    Get
public:
property Saa7118TYPIDSLICERSTATUSBYTE00 ClosedCaptionValid {
    Saa7118TYPIDSLICERSTATUSBYTE00 get ();
}
member ClosedCaptionValid : Saa7118TYPIDSLICERSTATUSBYTE00 with get

Property Value

Type: Saa7118TYPIDSLICERSTATUSBYTE00
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ColourOn Property

IRD

Saa7118ColourOn Property

Colour on

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDMODEDELAYCONTROL4 ColourOn { get; set; }
Public Property ColourOn As Saa7118TYPIDMODEDELAYCONTROL4
    Get
    Set
public:
property Saa7118TYPIDMODEDELAYCONTROL4 ColourOn {
    Saa7118TYPIDMODEDELAYCONTROL4 get ();
    void set (Saa7118TYPIDMODEDELAYCONTROL4 value);
}
member ColourOn : Saa7118TYPIDMODEDELAYCONTROL4 with get, set

Property Value

Type: Saa7118TYPIDMODEDELAYCONTROL4
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ColourPeakOff Property

IRD

Saa7118ColourPeakOff Property

Colour peak off

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDANALOGINPUTCONTROL22 ColourPeakOff { get; set; }
Public Property ColourPeakOff As Saa7118TYPIDANALOGINPUTCONTROL22
    Get
    Set
public:
property Saa7118TYPIDANALOGINPUTCONTROL22 ColourPeakOff {
    Saa7118TYPIDANALOGINPUTCONTROL22 get ();
    void set (Saa7118TYPIDANALOGINPUTCONTROL22 value);
}
member ColourPeakOff : Saa7118TYPIDANALOGINPUTCONTROL22 with get, set

Property Value

Type: Saa7118TYPIDANALOGINPUTCONTROL22
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ColourStandardSelectionInAUTOMode Property

IRD

Saa7118ColourStandardSelectionInAUTOMode Property

Colour standard selection in AUTO mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDCHROMINANCECONTROL13 ColourStandardSelectionInAUTOMode { get; set; }
Public Property ColourStandardSelectionInAUTOMode As Saa7118TYPIDCHROMINANCECONTROL13
    Get
    Set
public:
property Saa7118TYPIDCHROMINANCECONTROL13 ColourStandardSelectionInAUTOMode {
    Saa7118TYPIDCHROMINANCECONTROL13 get ();
    void set (Saa7118TYPIDCHROMINANCECONTROL13 value);
}
member ColourStandardSelectionInAUTOMode : Saa7118TYPIDCHROMINANCECONTROL13 with get, set

Property Value

Type: Saa7118TYPIDCHROMINANCECONTROL13
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.CombinedLuminanceChrominanceBandwidthAdjustment Property

IRD

Saa7118CombinedLuminanceChrominanceBandwidthAdjustment Property

Combined luminance/chrominance bandwidth adjustment

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDCHROMINANCECONTROL20 CombinedLuminanceChrominanceBandwidthAdjustment { get; set; }
Public Property CombinedLuminanceChrominanceBandwidthAdjustment As Saa7118TYPIDCHROMINANCECONTROL20
    Get
    Set
public:
property Saa7118TYPIDCHROMINANCECONTROL20 CombinedLuminanceChrominanceBandwidthAdjustment {
    Saa7118TYPIDCHROMINANCECONTROL20 get ();
    void set (Saa7118TYPIDCHROMINANCECONTROL20 value);
}
member CombinedLuminanceChrominanceBandwidthAdjustment : Saa7118TYPIDCHROMINANCECONTROL20 with get, set

Property Value

Type: Saa7118TYPIDCHROMINANCECONTROL20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.CompatibilityBitForSAA7199 Property

IRD

Saa7118CompatibilityBitForSAA7199 Property

Compatibility bit for SAA7199

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL3 CompatibilityBitForSAA7199 { get; set; }
Public Property CompatibilityBitForSAA7199 As Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL3
    Get
    Set
public:
property Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL3 CompatibilityBitForSAA7199 {
    Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL3 get ();
    void set (Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL3 value);
}
member CompatibilityBitForSAA7199 : Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL3 with get, set

Property Value

Type: Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL3
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ComponentInputDelayAdjustmentRelativeToDecodedCVBSSignal Property

IRD

Saa7118ComponentInputDelayAdjustmentRelativeToDecodedCVBSSignal Property

Component input delay adjustment relative to decoded CVBS signal (unit: pixel)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ComponentInputDelayAdjustmentRelativeToDecodedCVBSSignal { get; set; }
Public Property ComponentInputDelayAdjustmentRelativeToDecodedCVBSSignal As Double
    Get
    Set
public:
property double ComponentInputDelayAdjustmentRelativeToDecodedCVBSSignal {
    double get ();
    void set (double value);
}
member ComponentInputDelayAdjustmentRelativeToDecodedCVBSSignal : float with get, set

Property Value

Type: Double
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ComponentLuminancePeaking Property

IRD

Saa7118ComponentLuminancePeaking Property

Component luminance peaking

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDEnableDisable ComponentLuminancePeaking { get; set; }
Public Property ComponentLuminancePeaking As Saa7118IDEnableDisable
    Get
    Set
public:
property Saa7118IDEnableDisable ComponentLuminancePeaking {
    Saa7118IDEnableDisable get ();
    void set (Saa7118IDEnableDisable value);
}
member ComponentLuminancePeaking : Saa7118IDEnableDisable with get, set

Property Value

Type: Saa7118IDEnableDisable
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.CopyProtectedSourceDetected Property

IRD

Saa7118CopyProtectedSourceDetected Property

Copy protected source detected

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDNotActiveActive CopyProtectedSourceDetected { get; }
Public ReadOnly Property CopyProtectedSourceDetected As Saa7118IDNotActiveActive
    Get
public:
property Saa7118IDNotActiveActive CopyProtectedSourceDetected {
    Saa7118IDNotActiveActive get ();
}
member CopyProtectedSourceDetected : Saa7118IDNotActiveActive with get

Property Value

Type: Saa7118IDNotActiveActive
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.DataType Property

IRD

Saa7118DataType Property

Data type

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSLICERBYTE20 DataType { get; }
Public ReadOnly Property DataType As Saa7118TYPIDSLICERBYTE20
    Get
public:
property Saa7118TYPIDSLICERBYTE20 DataType {
    Saa7118TYPIDSLICERBYTE20 get ();
}
member DataType : Saa7118TYPIDSLICERBYTE20 with get

Property Value

Type: Saa7118TYPIDSLICERBYTE20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.DecoderAndVBISlicer Property

IRD

Saa7118DecoderAndVBISlicer Property

Decoder and VBI slicer

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL0 DecoderAndVBISlicer { get; set; }
Public Property DecoderAndVBISlicer As Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL0
    Get
    Set
public:
property Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL0 DecoderAndVBISlicer {
    Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL0 get ();
    void set (Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL0 value);
}
member DecoderAndVBISlicer : Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL0 with get, set

Property Value

Type: Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.DetectedColourStandard Property

IRD

Saa7118DetectedColourStandard Property

Detected colour standard

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSTATUSBYTE1VIDEODECODER0 DetectedColourStandard { get; }
Public ReadOnly Property DetectedColourStandard As Saa7118TYPIDSTATUSBYTE1VIDEODECODER0
    Get
public:
property Saa7118TYPIDSTATUSBYTE1VIDEODECODER0 DetectedColourStandard {
    Saa7118TYPIDSTATUSBYTE1VIDEODECODER0 get ();
}
member DetectedColourStandard : Saa7118TYPIDSTATUSBYTE1VIDEODECODER0 with get

Property Value

Type: Saa7118TYPIDSTATUSBYTE1VIDEODECODER0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.DisableChrominanceVerticalFilterAndPALPhaseErrorCorrection Property

IRD

Saa7118DisableChrominanceVerticalFilterAndPALPhaseErrorCorrection Property

Disable chrominance vertical filter and PAL phase error correction

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDCHROMINANCECONTROL12 DisableChrominanceVerticalFilterAndPALPhaseErrorCorrection { get; set; }
Public Property DisableChrominanceVerticalFilterAndPALPhaseErrorCorrection As Saa7118TYPIDCHROMINANCECONTROL12
    Get
    Set
public:
property Saa7118TYPIDCHROMINANCECONTROL12 DisableChrominanceVerticalFilterAndPALPhaseErrorCorrection {
    Saa7118TYPIDCHROMINANCECONTROL12 get ();
    void set (Saa7118TYPIDCHROMINANCECONTROL12 value);
}
member DisableChrominanceVerticalFilterAndPALPhaseErrorCorrection : Saa7118TYPIDCHROMINANCECONTROL12 with get, set

Property Value

Type: Saa7118TYPIDCHROMINANCECONTROL12
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.DOSL Property

IRD

Saa7118DOSL Property

DOSL

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL5 DOSL { get; set; }
Public Property DOSL As Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL5
    Get
    Set
public:
property Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL5 DOSL {
    Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL5 get ();
    void set (Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL5 value);
}
member DOSL : Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL5 with get, set

Property Value

Type: Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL5
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.DPROG Property

IRD

Saa7118DPROG Property

DPROG

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL3 DPROG { get; set; }
Public Property DPROG As Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL3
    Get
    Set
public:
property Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL3 DPROG {
    Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL3 get ();
    void set (Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL3 value);
}
member DPROG : Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL3 with get, set

Property Value

Type: Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL3
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.DwordByteSwapInfluencesSerialOutputTiming Property

IRD

Saa7118DwordByteSwapInfluencesSerialOutputTiming Property

Dword byte swap, influences serial output timing

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER6 DwordByteSwapInfluencesSerialOutputTiming { get; set; }
Public Property DwordByteSwapInfluencesSerialOutputTiming As Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER6
    Get
    Set
public:
property Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER6 DwordByteSwapInfluencesSerialOutputTiming {
    Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER6 get ();
    void set (Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER6 value);
}
member DwordByteSwapInfluencesSerialOutputTiming : Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER6 with get, set

Property Value

Type: Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER6
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.EnableExternalSourceSwitchIndicatorInputEXMCLR Property

IRD

Saa7118EnableExternalSourceSwitchIndicatorInputEXMCLR Property

Enable external source switch indicator Input EXMCLR

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDEnableDisable EnableExternalSourceSwitchIndicatorInputEXMCLR { get; set; }
Public Property EnableExternalSourceSwitchIndicatorInputEXMCLR As Saa7118IDEnableDisable
    Get
    Set
public:
property Saa7118IDEnableDisable EnableExternalSourceSwitchIndicatorInputEXMCLR {
    Saa7118IDEnableDisable get ();
    void set (Saa7118IDEnableDisable value);
}
member EnableExternalSourceSwitchIndicatorInputEXMCLR : Saa7118IDEnableDisable with get, set

Property Value

Type: Saa7118IDEnableDisable
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ERROFErrorFlagOfScalersOutputFormatterNormallySet Property

IRD

Saa7118ERROFErrorFlagOfScalersOutputFormatterNormallySet Property

ERROF error flag of scalers output formatter, normally set

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ERROFErrorFlagOfScalersOutputFormatterNormallySet { get; set; }
Public Property ERROFErrorFlagOfScalersOutputFormatterNormallySet As Byte
    Get
    Set
public:
property unsigned char ERROFErrorFlagOfScalersOutputFormatterNormallySet {
    unsigned char get ();
    void set (unsigned char value);
}
member ERROFErrorFlagOfScalersOutputFormatterNormallySet : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FAEFIFOFlagAlmostEmptyLevel Property

IRD

Saa7118FAEFIFOFlagAlmostEmptyLevel Property

FAE FIFO flag almost empty level

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION0 FAEFIFOFlagAlmostEmptyLevel { get; set; }
Public Property FAEFIFOFlagAlmostEmptyLevel As Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION0
    Get
    Set
public:
property Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION0 FAEFIFOFlagAlmostEmptyLevel {
    Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION0 get ();
    void set (Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION0 value);
}
member FAEFIFOFlagAlmostEmptyLevel : Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION0 with get, set

Property Value

Type: Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FAEFIFOFlagAlmostFullLevel Property

IRD

Saa7118FAEFIFOFlagAlmostFullLevel Property

FAE FIFO flag almost full level

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION1 FAEFIFOFlagAlmostFullLevel { get; set; }
Public Property FAEFIFOFlagAlmostFullLevel As Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION1
    Get
    Set
public:
property Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION1 FAEFIFOFlagAlmostFullLevel {
    Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION1 get ();
    void set (Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION1 value);
}
member FAEFIFOFlagAlmostFullLevel : Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION1 with get, set

Property Value

Type: Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FastColourTimeConstant Property

IRD

Saa7118FastColourTimeConstant Property

Fast colour time constant

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDCHROMINANCECONTROL11 FastColourTimeConstant { get; set; }
Public Property FastColourTimeConstant As Saa7118TYPIDCHROMINANCECONTROL11
    Get
    Set
public:
property Saa7118TYPIDCHROMINANCECONTROL11 FastColourTimeConstant {
    Saa7118TYPIDCHROMINANCECONTROL11 get ();
    void set (Saa7118TYPIDCHROMINANCECONTROL11 value);
}
member FastColourTimeConstant : Saa7118TYPIDCHROMINANCECONTROL11 with get, set

Property Value

Type: Saa7118TYPIDCHROMINANCECONTROL11
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FastSwitchEnable Property

IRD

Saa7118FastSwitchEnable Property

Fast switch enable

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDCOMPONENTDELAYFSWITCHCONTROL4 FastSwitchEnable { get; set; }
Public Property FastSwitchEnable As Saa7118TYPIDCOMPONENTDELAYFSWITCHCONTROL4
    Get
    Set
public:
property Saa7118TYPIDCOMPONENTDELAYFSWITCHCONTROL4 FastSwitchEnable {
    Saa7118TYPIDCOMPONENTDELAYFSWITCHCONTROL4 get ();
    void set (Saa7118TYPIDCOMPONENTDELAYFSWITCHCONTROL4 value);
}
member FastSwitchEnable : Saa7118TYPIDCOMPONENTDELAYFSWITCHCONTROL4 with get, set

Property Value

Type: Saa7118TYPIDCOMPONENTDELAYFSWITCHCONTROL4
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FastSwitchInputDelayAdjustmentRelativeToComponentInputSignal Property

IRD

Saa7118FastSwitchInputDelayAdjustmentRelativeToComponentInputSignal Property

Fast switch input delay adjustment relative to component input signal (unit: pixel)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte FastSwitchInputDelayAdjustmentRelativeToComponentInputSignal { get; set; }
Public Property FastSwitchInputDelayAdjustmentRelativeToComponentInputSignal As SByte
    Get
    Set
public:
property signed char FastSwitchInputDelayAdjustmentRelativeToComponentInputSignal {
    signed char get ();
    void set (signed char value);
}
member FastSwitchInputDelayAdjustmentRelativeToComponentInputSignal : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FastSwitchInputPolarityFSWE01 Property

IRD

Saa7118FastSwitchInputPolarityFSWE01 Property

Fast switch input polarity (FSWE=0/1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDCOMPONENTDELAYFSWITCHCONTROL3 FastSwitchInputPolarityFSWE01 { get; set; }
Public Property FastSwitchInputPolarityFSWE01 As Saa7118TYPIDCOMPONENTDELAYFSWITCHCONTROL3
    Get
    Set
public:
property Saa7118TYPIDCOMPONENTDELAYFSWITCHCONTROL3 FastSwitchInputPolarityFSWE01 {
    Saa7118TYPIDCOMPONENTDELAYFSWITCHCONTROL3 get ();
    void set (Saa7118TYPIDCOMPONENTDELAYFSWITCHCONTROL3 value);
}
member FastSwitchInputPolarityFSWE01 : Saa7118TYPIDCOMPONENTDELAYFSWITCHCONTROL3 with get, set

Property Value

Type: Saa7118TYPIDCOMPONENTDELAYFSWITCHCONTROL3
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FFILStatusOfTheInternalFIFOAlmostFilledFlag Property

IRD

Saa7118FFILStatusOfTheInternalFIFOAlmostFilledFlag Property

FFIL status of the internal 'FIFO almost filled' flag

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FFILStatusOfTheInternalFIFOAlmostFilledFlag { get; set; }
Public Property FFILStatusOfTheInternalFIFOAlmostFilledFlag As Byte
    Get
    Set
public:
property unsigned char FFILStatusOfTheInternalFIFOAlmostFilledFlag {
    unsigned char get ();
    void set (unsigned char value);
}
member FFILStatusOfTheInternalFIFOAlmostFilledFlag : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FFOVStatusOfTheInternalFIFOOverflowFlag Property

IRD

Saa7118FFOVStatusOfTheInternalFIFOOverflowFlag Property

FFOV status of the internal 'FIFO overflow' flag

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FFOVStatusOfTheInternalFIFOOverflowFlag { get; set; }
Public Property FFOVStatusOfTheInternalFIFOOverflowFlag As Byte
    Get
    Set
public:
property unsigned char FFOVStatusOfTheInternalFIFOOverflowFlag {
    unsigned char get ();
    void set (unsigned char value);
}
member FFOVStatusOfTheInternalFIFOOverflowFlag : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FIDSCIStatusOfTheFieldSequenceIDAtTheScalersInput Property

IRD

Saa7118FIDSCIStatusOfTheFieldSequenceIDAtTheScalersInput Property

FIDSCI status of the field sequence ID at the scalers input

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIDSCIStatusOfTheFieldSequenceIDAtTheScalersInput { get; set; }
Public Property FIDSCIStatusOfTheFieldSequenceIDAtTheScalersInput As Byte
    Get
    Set
public:
property unsigned char FIDSCIStatusOfTheFieldSequenceIDAtTheScalersInput {
    unsigned char get ();
    void set (unsigned char value);
}
member FIDSCIStatusOfTheFieldSequenceIDAtTheScalersInput : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FIDSCOStatusOfTheFieldSequenceIDAtTheScalersOutput Property

IRD

Saa7118FIDSCOStatusOfTheFieldSequenceIDAtTheScalersOutput Property

FIDSCO status of the field sequence ID at the scalers output

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIDSCOStatusOfTheFieldSequenceIDAtTheScalersOutput { get; set; }
Public Property FIDSCOStatusOfTheFieldSequenceIDAtTheScalersOutput As Byte
    Get
    Set
public:
property unsigned char FIDSCOStatusOfTheFieldSequenceIDAtTheScalersOutput {
    unsigned char get ();
    void set (unsigned char value);
}
member FIDSCOStatusOfTheFieldSequenceIDAtTheScalersOutput : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FieldIDAndVBlankSelectionForTextOutput Property

IRD

Saa7118FieldIDAndVBlankSelectionForTextOutput Property

Field ID and V-blank selection for text output

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDHEADERANDDATAIONCODECONTROL1 FieldIDAndVBlankSelectionForTextOutput { get; set; }
Public Property FieldIDAndVBlankSelectionForTextOutput As Saa7118TYPIDHEADERANDDATAIONCODECONTROL1
    Get
    Set
public:
property Saa7118TYPIDHEADERANDDATAIONCODECONTROL1 FieldIDAndVBlankSelectionForTextOutput {
    Saa7118TYPIDHEADERANDDATAIONCODECONTROL1 get ();
    void set (Saa7118TYPIDHEADERANDDATAIONCODECONTROL1 value);
}
member FieldIDAndVBlankSelectionForTextOutput : Saa7118TYPIDHEADERANDDATAIONCODECONTROL1 with get, set

Property Value

Type: Saa7118TYPIDHEADERANDDATAIONCODECONTROL1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FieldIDAsSeenByTheVBISlicer Property

IRD

Saa7118FieldIDAsSeenByTheVBISlicer Property

Field ID as seen by the VBI slicer

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FieldIDAsSeenByTheVBISlicer { get; }
Public ReadOnly Property FieldIDAsSeenByTheVBISlicer As Byte
    Get
public:
property unsigned char FieldIDAsSeenByTheVBISlicer {
    unsigned char get ();
}
member FieldIDAsSeenByTheVBISlicer : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FieldOffset Property

IRD

Saa7118FieldOffset Property

Field offset

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDFIELDOFFSETANDETSSLICERSET1 FieldOffset { get; set; }
Public Property FieldOffset As Saa7118TYPIDFIELDOFFSETANDETSSLICERSET1
    Get
    Set
public:
property Saa7118TYPIDFIELDOFFSETANDETSSLICERSET1 FieldOffset {
    Saa7118TYPIDFIELDOFFSETANDETSSLICERSET1 get ();
    void set (Saa7118TYPIDFIELDOFFSETANDETSSLICERSET1 value);
}
member FieldOffset : Saa7118TYPIDFIELDOFFSETANDETSSLICERSET1 with get, set

Property Value

Type: Saa7118TYPIDFIELDOFFSETANDETSSLICERSET1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FieldSelection Property

IRD

Saa7118FieldSelection Property

Field selection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSYNCCONTROL4 FieldSelection { get; set; }
Public Property FieldSelection As Saa7118TYPIDSYNCCONTROL4
    Get
    Set
public:
property Saa7118TYPIDSYNCCONTROL4 FieldSelection {
    Saa7118TYPIDSYNCCONTROL4 get ();
    void set (Saa7118TYPIDSYNCCONTROL4 value);
}
member FieldSelection : Saa7118TYPIDSYNCCONTROL4 with get, set

Property Value

Type: Saa7118TYPIDSYNCCONTROL4
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FineOffsetAdjustmentBYComponent Property

IRD

Saa7118FineOffsetAdjustmentBYComponent Property

Fine offset adjustment B - Y component

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDCHROMINANCECONTROL22 FineOffsetAdjustmentBYComponent { get; set; }
Public Property FineOffsetAdjustmentBYComponent As Saa7118TYPIDCHROMINANCECONTROL22
    Get
    Set
public:
property Saa7118TYPIDCHROMINANCECONTROL22 FineOffsetAdjustmentBYComponent {
    Saa7118TYPIDCHROMINANCECONTROL22 get ();
    void set (Saa7118TYPIDCHROMINANCECONTROL22 value);
}
member FineOffsetAdjustmentBYComponent : Saa7118TYPIDCHROMINANCECONTROL22 with get, set

Property Value

Type: Saa7118TYPIDCHROMINANCECONTROL22
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FineOffsetAdjustmentRYComponent Property

IRD

Saa7118FineOffsetAdjustmentRYComponent Property

Fine offset adjustment R - Y component

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDCHROMINANCECONTROL22 FineOffsetAdjustmentRYComponent { get; set; }
Public Property FineOffsetAdjustmentRYComponent As Saa7118TYPIDCHROMINANCECONTROL22
    Get
    Set
public:
property Saa7118TYPIDCHROMINANCECONTROL22 FineOffsetAdjustmentRYComponent {
    Saa7118TYPIDCHROMINANCECONTROL22 get ();
    void set (Saa7118TYPIDCHROMINANCECONTROL22 value);
}
member FineOffsetAdjustmentRYComponent : Saa7118TYPIDCHROMINANCECONTROL22 with get, set

Property Value

Type: Saa7118TYPIDCHROMINANCECONTROL22
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FinePositionOfHS Property

IRD

Saa7118FinePositionOfHS Property

Fine position of HS

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FinePositionOfHS { get; set; }
Public Property FinePositionOfHS As Byte
    Get
    Set
public:
property unsigned char FinePositionOfHS {
    unsigned char get ();
    void set (unsigned char value);
}
member FinePositionOfHS : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ForcedODDEVENToggle Property

IRD

Saa7118ForcedODDEVENToggle Property

Forced ODD/EVEN toggle

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSYNCCONTROL3 ForcedODDEVENToggle { get; set; }
Public Property ForcedODDEVENToggle As Saa7118TYPIDSYNCCONTROL3
    Get
    Set
public:
property Saa7118TYPIDSYNCCONTROL3 ForcedODDEVENToggle {
    Saa7118TYPIDSYNCCONTROL3 get ();
    void set (Saa7118TYPIDSYNCCONTROL3 value);
}
member ForcedODDEVENToggle : Saa7118TYPIDSYNCCONTROL3 with get, set

Property Value

Type: Saa7118TYPIDSYNCCONTROL3
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FramingCodeError Property

IRD

Saa7118FramingCodeError Property

Framing code error

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSLICERCONTROL11 FramingCodeError { get; set; }
Public Property FramingCodeError As Saa7118TYPIDSLICERCONTROL11
    Get
    Set
public:
property Saa7118TYPIDSLICERCONTROL11 FramingCodeError {
    Saa7118TYPIDSLICERCONTROL11 get ();
    void set (Saa7118TYPIDSLICERCONTROL11 value);
}
member FramingCodeError : Saa7118TYPIDSLICERCONTROL11 with get, set

Property Value

Type: Saa7118TYPIDSLICERCONTROL11
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FramingCodeValid0Error Property

IRD

Saa7118FramingCodeValid0Error Property

Framing code valid (0 error)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSLICERSTATUSBYTE04 FramingCodeValid0Error { get; }
Public ReadOnly Property FramingCodeValid0Error As Saa7118TYPIDSLICERSTATUSBYTE04
    Get
public:
property Saa7118TYPIDSLICERSTATUSBYTE04 FramingCodeValid0Error {
    Saa7118TYPIDSLICERSTATUSBYTE04 get ();
}
member FramingCodeValid0Error : Saa7118TYPIDSLICERSTATUSBYTE04 with get

Property Value

Type: Saa7118TYPIDSLICERSTATUSBYTE04
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.FramingCodeValid1Error Property

IRD

Saa7118FramingCodeValid1Error Property

Framing code valid (1 error)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSLICERSTATUSBYTE03 FramingCodeValid1Error { get; }
Public ReadOnly Property FramingCodeValid1Error As Saa7118TYPIDSLICERSTATUSBYTE03
    Get
public:
property Saa7118TYPIDSLICERSTATUSBYTE03 FramingCodeValid1Error {
    Saa7118TYPIDSLICERSTATUSBYTE03 get ();
}
member FramingCodeValid1Error : Saa7118TYPIDSLICERSTATUSBYTE03 with get

Property Value

Type: Saa7118TYPIDSLICERSTATUSBYTE03
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.GainControlFix Property

IRD

Saa7118GainControlFix Property

Gain control fix

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDANALOGINPUTCONTROL20 GainControlFix { get; set; }
Public Property GainControlFix As Saa7118TYPIDANALOGINPUTCONTROL20
    Get
    Set
public:
property Saa7118TYPIDANALOGINPUTCONTROL20 GainControlFix {
    Saa7118TYPIDANALOGINPUTCONTROL20 get ();
    void set (Saa7118TYPIDANALOGINPUTCONTROL20 value);
}
member GainControlFix : Saa7118TYPIDANALOGINPUTCONTROL20 with get, set

Property Value

Type: Saa7118TYPIDANALOGINPUTCONTROL20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.GainValueForActiveLuminanceChannelIsLimitedMaximumTop Property

IRD

Saa7118GainValueForActiveLuminanceChannelIsLimitedMaximumTop Property

Gain value for active luminance channel is limited; maximum (top)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDNotActiveActive GainValueForActiveLuminanceChannelIsLimitedMaximumTop { get; }
Public ReadOnly Property GainValueForActiveLuminanceChannelIsLimitedMaximumTop As Saa7118IDNotActiveActive
    Get
public:
property Saa7118IDNotActiveActive GainValueForActiveLuminanceChannelIsLimitedMaximumTop {
    Saa7118IDNotActiveActive get ();
}
member GainValueForActiveLuminanceChannelIsLimitedMaximumTop : Saa7118IDNotActiveActive with get

Property Value

Type: Saa7118IDNotActiveActive
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.GainValueForActiveLuminanceChannelIsLimitedMinimumBottom Property

IRD

Saa7118GainValueForActiveLuminanceChannelIsLimitedMinimumBottom Property

Gain value for active luminance channel is limited; minimum (bottom)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDNotActiveActive GainValueForActiveLuminanceChannelIsLimitedMinimumBottom { get; }
Public ReadOnly Property GainValueForActiveLuminanceChannelIsLimitedMinimumBottom As Saa7118IDNotActiveActive
    Get
public:
property Saa7118IDNotActiveActive GainValueForActiveLuminanceChannelIsLimitedMinimumBottom {
    Saa7118IDNotActiveActive get ();
}
member GainValueForActiveLuminanceChannelIsLimitedMinimumBottom : Saa7118IDNotActiveActive with get

Property Value

Type: Saa7118IDNotActiveActive
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.GlobalControl1BackEndClock Property

IRD

Saa7118GlobalControl1BackEndClock Property

Global control 1: back-end clock

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDGLOBALCONTROL10 GlobalControl1BackEndClock { get; set; }
Public Property GlobalControl1BackEndClock As Saa7118TYPIDGLOBALCONTROL10
    Get
    Set
public:
property Saa7118TYPIDGLOBALCONTROL10 GlobalControl1BackEndClock {
    Saa7118TYPIDGLOBALCONTROL10 get ();
    void set (Saa7118TYPIDGLOBALCONTROL10 value);
}
member GlobalControl1BackEndClock : Saa7118TYPIDGLOBALCONTROL10 with get, set

Property Value

Type: Saa7118TYPIDGLOBALCONTROL10
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.GlobalControl1DefinitionOfTheFAndVTimingOfTheScalerOutput Property

IRD

Saa7118GlobalControl1DefinitionOfTheFAndVTimingOfTheScalerOutput Property

Global control 1: Definition of the F and V timing of the scaler output

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDGLOBALCONTROL15 GlobalControl1DefinitionOfTheFAndVTimingOfTheScalerOutput { get; set; }
Public Property GlobalControl1DefinitionOfTheFAndVTimingOfTheScalerOutput As Saa7118TYPIDGLOBALCONTROL15
    Get
    Set
public:
property Saa7118TYPIDGLOBALCONTROL15 GlobalControl1DefinitionOfTheFAndVTimingOfTheScalerOutput {
    Saa7118TYPIDGLOBALCONTROL15 get ();
    void set (Saa7118TYPIDGLOBALCONTROL15 value);
}
member GlobalControl1DefinitionOfTheFAndVTimingOfTheScalerOutput : Saa7118TYPIDGLOBALCONTROL15 with get, set

Property Value

Type: Saa7118TYPIDGLOBALCONTROL15
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.GlobalControl1IDQ Property

IRD

Saa7118GlobalControl1IDQ Property

Global control 1: IDQ

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDGLOBALCONTROL12 GlobalControl1IDQ { get; set; }
Public Property GlobalControl1IDQ As Saa7118TYPIDGLOBALCONTROL12
    Get
    Set
public:
property Saa7118TYPIDGLOBALCONTROL12 GlobalControl1IDQ {
    Saa7118TYPIDGLOBALCONTROL12 get ();
    void set (Saa7118TYPIDGLOBALCONTROL12 value);
}
member GlobalControl1IDQ : Saa7118TYPIDGLOBALCONTROL12 with get, set

Property Value

Type: Saa7118TYPIDGLOBALCONTROL12
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.GlobalControl1IDQPin Property

IRD

Saa7118GlobalControl1IDQPin Property

Global control 1: IDQ pin

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDGLOBALCONTROL11 GlobalControl1IDQPin { get; set; }
Public Property GlobalControl1IDQPin As Saa7118TYPIDGLOBALCONTROL11
    Get
    Set
public:
property Saa7118TYPIDGLOBALCONTROL11 GlobalControl1IDQPin {
    Saa7118TYPIDGLOBALCONTROL11 get ();
    void set (Saa7118TYPIDGLOBALCONTROL11 value);
}
member GlobalControl1IDQPin : Saa7118TYPIDGLOBALCONTROL11 with get, set

Property Value

Type: Saa7118TYPIDGLOBALCONTROL11
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.GlobalControl1TaskOfRegisterSetA Property

IRD

Saa7118GlobalControl1TaskOfRegisterSetA Property

Global control 1: Task of register set A

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDEnableDisable GlobalControl1TaskOfRegisterSetA { get; set; }
Public Property GlobalControl1TaskOfRegisterSetA As Saa7118IDEnableDisable
    Get
    Set
public:
property Saa7118IDEnableDisable GlobalControl1TaskOfRegisterSetA {
    Saa7118IDEnableDisable get ();
    void set (Saa7118IDEnableDisable value);
}
member GlobalControl1TaskOfRegisterSetA : Saa7118IDEnableDisable with get, set

Property Value

Type: Saa7118IDEnableDisable
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.GlobalControl1TaskOfRegisterSetB Property

IRD

Saa7118GlobalControl1TaskOfRegisterSetB Property

Global control 1: Task of register set B

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDEnableDisable GlobalControl1TaskOfRegisterSetB { get; set; }
Public Property GlobalControl1TaskOfRegisterSetB As Saa7118IDEnableDisable
    Get
    Set
public:
property Saa7118IDEnableDisable GlobalControl1TaskOfRegisterSetB {
    Saa7118IDEnableDisable get ();
    void set (Saa7118IDEnableDisable value);
}
member GlobalControl1TaskOfRegisterSetB : Saa7118IDEnableDisable with get, set

Property Value

Type: Saa7118IDEnableDisable
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.HammingCheck Property

IRD

Saa7118HammingCheck Property

Hamming check

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSLICERCONTROL12 HammingCheck { get; set; }
Public Property HammingCheck As Saa7118TYPIDSLICERCONTROL12
    Get
    Set
public:
property Saa7118TYPIDSLICERCONTROL12 HammingCheck {
    Saa7118TYPIDSLICERCONTROL12 get ();
    void set (Saa7118TYPIDSLICERCONTROL12 value);
}
member HammingCheck : Saa7118TYPIDSLICERCONTROL12 with get, set

Property Value

Type: Saa7118TYPIDSLICERCONTROL12
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.HLNotReferenceSelect Property

IRD

Saa7118HLNotReferenceSelect Property

HL not reference select

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDANALOGINPUTCONTROL24 HLNotReferenceSelect { get; set; }
Public Property HLNotReferenceSelect As Saa7118TYPIDANALOGINPUTCONTROL24
    Get
    Set
public:
property Saa7118TYPIDANALOGINPUTCONTROL24 HLNotReferenceSelect {
    Saa7118TYPIDANALOGINPUTCONTROL24 get ();
    void set (Saa7118TYPIDANALOGINPUTCONTROL24 value);
}
member HLNotReferenceSelect : Saa7118TYPIDANALOGINPUTCONTROL24 with get, set

Property Value

Type: Saa7118TYPIDANALOGINPUTCONTROL24
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.HorizontalLockIndicatorSelection Property

IRD

Saa7118HorizontalLockIndicatorSelection Property

Horizontal lock indicator selection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDRTXPORTOUTPUTCONTROL1 HorizontalLockIndicatorSelection { get; set; }
Public Property HorizontalLockIndicatorSelection As Saa7118TYPIDRTXPORTOUTPUTCONTROL1
    Get
    Set
public:
property Saa7118TYPIDRTXPORTOUTPUTCONTROL1 HorizontalLockIndicatorSelection {
    Saa7118TYPIDRTXPORTOUTPUTCONTROL1 get ();
    void set (Saa7118TYPIDRTXPORTOUTPUTCONTROL1 value);
}
member HorizontalLockIndicatorSelection : Saa7118TYPIDRTXPORTOUTPUTCONTROL1 with get, set

Property Value

Type: Saa7118TYPIDRTXPORTOUTPUTCONTROL1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.HorizontalOffset Property

IRD

Saa7118HorizontalOffset Property

Horizontal offset

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort HorizontalOffset { get; set; }
Public Property HorizontalOffset As UShort
    Get
    Set
public:
property unsigned short HorizontalOffset {
    unsigned short get ();
    void set (unsigned short value);
}
member HorizontalOffset : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.HorizontalPLL Property

IRD

Saa7118HorizontalPLL Property

Horizontal PLL

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSYNCCONTROL1 HorizontalPLL { get; set; }
Public Property HorizontalPLL As Saa7118TYPIDSYNCCONTROL1
    Get
    Set
public:
property Saa7118TYPIDSYNCCONTROL1 HorizontalPLL {
    Saa7118TYPIDSYNCCONTROL1 get ();
    void set (Saa7118TYPIDSYNCCONTROL1 value);
}
member HorizontalPLL : Saa7118TYPIDSYNCCONTROL1 with get, set

Property Value

Type: Saa7118TYPIDSYNCCONTROL1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.HorizontalSyncStartDelayTimeStepSize8LLC Property

IRD

Saa7118HorizontalSyncStartDelayTimeStepSize8LLC Property

Horizontal sync start: Delay Time (Step size=8/LLC)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte HorizontalSyncStartDelayTimeStepSize8LLC { get; set; }
Public Property HorizontalSyncStartDelayTimeStepSize8LLC As SByte
    Get
    Set
public:
property signed char HorizontalSyncStartDelayTimeStepSize8LLC {
    signed char get ();
    void set (signed char value);
}
member HorizontalSyncStartDelayTimeStepSize8LLC : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.HorizontalSyncStopDelayTimeStepSize8LLC Property

IRD

Saa7118HorizontalSyncStopDelayTimeStepSize8LLC Property

Horizontal sync stop: Delay Time (Step size=8/LLC)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte HorizontalSyncStopDelayTimeStepSize8LLC { get; set; }
Public Property HorizontalSyncStopDelayTimeStepSize8LLC As SByte
    Get
    Set
public:
property signed char HorizontalSyncStopDelayTimeStepSize8LLC {
    signed char get ();
    void set (signed char value);
}
member HorizontalSyncStopDelayTimeStepSize8LLC : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.HorizontalTimeConstantSelection Property

IRD

Saa7118HorizontalTimeConstantSelection Property

Horizontal time constant selection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSYNCCONTROL2 HorizontalTimeConstantSelection { get; set; }
Public Property HorizontalTimeConstantSelection As Saa7118TYPIDSYNCCONTROL2
    Get
    Set
public:
property Saa7118TYPIDSYNCCONTROL2 HorizontalTimeConstantSelection {
    Saa7118TYPIDSYNCCONTROL2 get ();
    void set (Saa7118TYPIDSYNCCONTROL2 value);
}
member HorizontalTimeConstantSelection : Saa7118TYPIDSYNCCONTROL2 with get, set

Property Value

Type: Saa7118TYPIDSYNCCONTROL2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.IdentificationBitForDetectedFieldFrequency Property

IRD

Saa7118IdentificationBitForDetectedFieldFrequency Property

Identification bit for detected field frequency

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSTATUSBYTE2VIDEODECODER4 IdentificationBitForDetectedFieldFrequency { get; }
Public ReadOnly Property IdentificationBitForDetectedFieldFrequency As Saa7118TYPIDSTATUSBYTE2VIDEODECODER4
    Get
public:
property Saa7118TYPIDSTATUSBYTE2VIDEODECODER4 IdentificationBitForDetectedFieldFrequency {
    Saa7118TYPIDSTATUSBYTE2VIDEODECODER4 get ();
}
member IdentificationBitForDetectedFieldFrequency : Saa7118TYPIDSTATUSBYTE2VIDEODECODER4 with get

Property Value

Type: Saa7118TYPIDSTATUSBYTE2VIDEODECODER4
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.IDG0 Property

IRD

Saa7118IDG0 Property

IDG0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDIPORTSIGNALDEFINITIONS02 IDG0 { get; set; }
Public Property IDG0 As Saa7118TYPIDIPORTSIGNALDEFINITIONS02
    Get
    Set
public:
property Saa7118TYPIDIPORTSIGNALDEFINITIONS02 IDG0 {
    Saa7118TYPIDIPORTSIGNALDEFINITIONS02 get ();
    void set (Saa7118TYPIDIPORTSIGNALDEFINITIONS02 value);
}
member IDG0 : Saa7118TYPIDIPORTSIGNALDEFINITIONS02 with get, set

Property Value

Type: Saa7118TYPIDIPORTSIGNALDEFINITIONS02
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.IDG1 Property

IRD

Saa7118IDG1 Property

IDG1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDIPORTSIGNALDEFINITIONS01 IDG1 { get; set; }
Public Property IDG1 As Saa7118TYPIDIPORTSIGNALDEFINITIONS01
    Get
    Set
public:
property Saa7118TYPIDIPORTSIGNALDEFINITIONS01 IDG1 {
    Saa7118TYPIDIPORTSIGNALDEFINITIONS01 get ();
    void set (Saa7118TYPIDIPORTSIGNALDEFINITIONS01 value);
}
member IDG1 : Saa7118TYPIDIPORTSIGNALDEFINITIONS01 with get, set

Property Value

Type: Saa7118TYPIDIPORTSIGNALDEFINITIONS01
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.IDH Property

IRD

Saa7118IDH Property

IDH

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDIPORTSIGNALDEFINITIONS0 IDH { get; set; }
Public Property IDH As Saa7118TYPIDIPORTSIGNALDEFINITIONS0
    Get
    Set
public:
property Saa7118TYPIDIPORTSIGNALDEFINITIONS0 IDH {
    Saa7118TYPIDIPORTSIGNALDEFINITIONS0 get ();
    void set (Saa7118TYPIDIPORTSIGNALDEFINITIONS0 value);
}
member IDH : Saa7118TYPIDIPORTSIGNALDEFINITIONS0 with get, set

Property Value

Type: Saa7118TYPIDIPORTSIGNALDEFINITIONS0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.IDV Property

IRD

Saa7118IDV Property

IDV

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDIPORTSIGNALDEFINITIONS1 IDV { get; set; }
Public Property IDV As Saa7118TYPIDIPORTSIGNALDEFINITIONS1
    Get
    Set
public:
property Saa7118TYPIDIPORTSIGNALDEFINITIONS1 IDV {
    Saa7118TYPIDIPORTSIGNALDEFINITIONS1 get ();
    void set (Saa7118TYPIDIPORTSIGNALDEFINITIONS1 value);
}
member IDV : Saa7118TYPIDIPORTSIGNALDEFINITIONS1 with get, set

Property Value

Type: Saa7118TYPIDIPORTSIGNALDEFINITIONS1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ILLV Property

IRD

Saa7118ILLV Property

ILLV

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER5 ILLV { get; set; }
Public Property ILLV As Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER5
    Get
    Set
public:
property Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER5 ILLV {
    Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER5 get ();
    void set (Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER5 value);
}
member ILLV : Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER5 with get, set

Property Value

Type: Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER5
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.IncrementDelay Property

IRD

Saa7118IncrementDelay Property

Increment delay

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDHORIZONTALINCREMENTDELAY0 IncrementDelay { get; set; }
Public Property IncrementDelay As Saa7118TYPIDHORIZONTALINCREMENTDELAY0
    Get
    Set
public:
property Saa7118TYPIDHORIZONTALINCREMENTDELAY0 IncrementDelay {
    Saa7118TYPIDHORIZONTALINCREMENTDELAY0 get ();
    void set (Saa7118TYPIDHORIZONTALINCREMENTDELAY0 value);
}
member IncrementDelay : Saa7118TYPIDHORIZONTALINCREMENTDELAY0 with get, set

Property Value

Type: Saa7118TYPIDHORIZONTALINCREMENTDELAY0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.InterruptEnableClosedCaptionDetectedLost Property

IRD

Saa7118InterruptEnableClosedCaptionDetectedLost Property

Interrupt enable 'closed caption detected/lost'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDEnableDisable InterruptEnableClosedCaptionDetectedLost { get; set; }
Public Property InterruptEnableClosedCaptionDetectedLost As Saa7118IDEnableDisable
    Get
    Set
public:
property Saa7118IDEnableDisable InterruptEnableClosedCaptionDetectedLost {
    Saa7118IDEnableDisable get ();
    void set (Saa7118IDEnableDisable value);
}
member InterruptEnableClosedCaptionDetectedLost : Saa7118IDEnableDisable with get, set

Property Value

Type: Saa7118IDEnableDisable
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.InterruptEnableColourStandardChanged0 Property

IRD

Saa7118InterruptEnableColourStandardChanged0 Property

Interrupt enable 'colour standard changed 0'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDEnableDisable InterruptEnableColourStandardChanged0 { get; set; }
Public Property InterruptEnableColourStandardChanged0 As Saa7118IDEnableDisable
    Get
    Set
public:
property Saa7118IDEnableDisable InterruptEnableColourStandardChanged0 {
    Saa7118IDEnableDisable get ();
    void set (Saa7118IDEnableDisable value);
}
member InterruptEnableColourStandardChanged0 : Saa7118IDEnableDisable with get, set

Property Value

Type: Saa7118IDEnableDisable
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.InterruptEnableColourStandardChanged1 Property

IRD

Saa7118InterruptEnableColourStandardChanged1 Property

Interrupt enable 'colour standard changed 1'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDEnableDisable InterruptEnableColourStandardChanged1 { get; set; }
Public Property InterruptEnableColourStandardChanged1 As Saa7118IDEnableDisable
    Get
    Set
public:
property Saa7118IDEnableDisable InterruptEnableColourStandardChanged1 {
    Saa7118IDEnableDisable get ();
    void set (Saa7118IDEnableDisable value);
}
member InterruptEnableColourStandardChanged1 : Saa7118IDEnableDisable with get, set

Property Value

Type: Saa7118IDEnableDisable
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.InterruptEnableColourStripeBurstAnyTypeDetectedLost Property

IRD

Saa7118InterruptEnableColourStripeBurstAnyTypeDetectedLost Property

Interrupt enable 'colour stripe burst (any type) detected/lost'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDEnableDisable InterruptEnableColourStripeBurstAnyTypeDetectedLost { get; set; }
Public Property InterruptEnableColourStripeBurstAnyTypeDetectedLost As Saa7118IDEnableDisable
    Get
    Set
public:
property Saa7118IDEnableDisable InterruptEnableColourStripeBurstAnyTypeDetectedLost {
    Saa7118IDEnableDisable get ();
    void set (Saa7118IDEnableDisable value);
}
member InterruptEnableColourStripeBurstAnyTypeDetectedLost : Saa7118IDEnableDisable with get, set

Property Value

Type: Saa7118IDEnableDisable
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.InterruptEnableColourStripeType3BurstDetectedLost Property

IRD

Saa7118InterruptEnableColourStripeType3BurstDetectedLost Property

Interrupt enable 'colour stripe type 3 burst detected/lost'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDEnableDisable InterruptEnableColourStripeType3BurstDetectedLost { get; set; }
Public Property InterruptEnableColourStripeType3BurstDetectedLost As Saa7118IDEnableDisable
    Get
    Set
public:
property Saa7118IDEnableDisable InterruptEnableColourStripeType3BurstDetectedLost {
    Saa7118IDEnableDisable get ();
    void set (Saa7118IDEnableDisable value);
}
member InterruptEnableColourStripeType3BurstDetectedLost : Saa7118IDEnableDisable with get, set

Property Value

Type: Saa7118IDEnableDisable
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.InterruptEnableCopyProtectedSignalFoundLost Property

IRD

Saa7118InterruptEnableCopyProtectedSignalFoundLost Property

Interrupt enable 'copy protected signal found/lost'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDEnableDisable InterruptEnableCopyProtectedSignalFoundLost { get; set; }
Public Property InterruptEnableCopyProtectedSignalFoundLost As Saa7118IDEnableDisable
    Get
    Set
public:
property Saa7118IDEnableDisable InterruptEnableCopyProtectedSignalFoundLost {
    Saa7118IDEnableDisable get ();
    void set (Saa7118IDEnableDisable value);
}
member InterruptEnableCopyProtectedSignalFoundLost : Saa7118IDEnableDisable with get, set

Property Value

Type: Saa7118IDEnableDisable
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.InterruptEnableErrorOutputFormatter Property

IRD

Saa7118InterruptEnableErrorOutputFormatter Property

Interrupt enable 'error output formatter'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDEnableDisable InterruptEnableErrorOutputFormatter { get; set; }
Public Property InterruptEnableErrorOutputFormatter As Saa7118IDEnableDisable
    Get
    Set
public:
property Saa7118IDEnableDisable InterruptEnableErrorOutputFormatter {
    Saa7118IDEnableDisable get ();
    void set (Saa7118IDEnableDisable value);
}
member InterruptEnableErrorOutputFormatter : Saa7118IDEnableDisable with get, set

Property Value

Type: Saa7118IDEnableDisable
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.InterruptEnableFieldFrequencyHasChanged Property

IRD

Saa7118InterruptEnableFieldFrequencyHasChanged Property

Interrupt enable 'field frequency has changed'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDEnableDisable InterruptEnableFieldFrequencyHasChanged { get; set; }
Public Property InterruptEnableFieldFrequencyHasChanged As Saa7118IDEnableDisable
    Get
    Set
public:
property Saa7118IDEnableDisable InterruptEnableFieldFrequencyHasChanged {
    Saa7118IDEnableDisable get ();
    void set (Saa7118IDEnableDisable value);
}
member InterruptEnableFieldFrequencyHasChanged : Saa7118IDEnableDisable with get, set

Property Value

Type: Saa7118IDEnableDisable
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.InterruptEnableHorizontalAndVerticalLockReachedLost Property

IRD

Saa7118InterruptEnableHorizontalAndVerticalLockReachedLost Property

Interrupt enable 'horizontal and vertical lock reached/lost'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDEnableDisable InterruptEnableHorizontalAndVerticalLockReachedLost { get; set; }
Public Property InterruptEnableHorizontalAndVerticalLockReachedLost As Saa7118IDEnableDisable
    Get
    Set
public:
property Saa7118IDEnableDisable InterruptEnableHorizontalAndVerticalLockReachedLost {
    Saa7118IDEnableDisable get ();
    void set (Saa7118IDEnableDisable value);
}
member InterruptEnableHorizontalAndVerticalLockReachedLost : Saa7118IDEnableDisable with get, set

Property Value

Type: Saa7118IDEnableDisable
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.InterruptEnableHorizontalPLLLockedUnlocked Property

IRD

Saa7118InterruptEnableHorizontalPLLLockedUnlocked Property

Interrupt enable 'horizontal PLL locked/unlocked'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDEnableDisable InterruptEnableHorizontalPLLLockedUnlocked { get; set; }
Public Property InterruptEnableHorizontalPLLLockedUnlocked As Saa7118IDEnableDisable
    Get
    Set
public:
property Saa7118IDEnableDisable InterruptEnableHorizontalPLLLockedUnlocked {
    Saa7118IDEnableDisable get ();
    void set (Saa7118IDEnableDisable value);
}
member InterruptEnableHorizontalPLLLockedUnlocked : Saa7118IDEnableDisable with get, set

Property Value

Type: Saa7118IDEnableDisable
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.InterruptEnableInterlacedNonInterlacedSource Property

IRD

Saa7118InterruptEnableInterlacedNonInterlacedSource Property

Interrupt enable 'interlaced/non-interlaced source'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDEnableDisable InterruptEnableInterlacedNonInterlacedSource { get; set; }
Public Property InterruptEnableInterlacedNonInterlacedSource As Saa7118IDEnableDisable
    Get
    Set
public:
property Saa7118IDEnableDisable InterruptEnableInterlacedNonInterlacedSource {
    Saa7118IDEnableDisable get ();
    void set (Saa7118IDEnableDisable value);
}
member InterruptEnableInterlacedNonInterlacedSource : Saa7118IDEnableDisable with get, set

Property Value

Type: Saa7118IDEnableDisable
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.InterruptEnablePALplusDetectedLost Property

IRD

Saa7118InterruptEnablePALplusDetectedLost Property

Interrupt enable 'PALplus detected/lost'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDEnableDisable InterruptEnablePALplusDetectedLost { get; set; }
Public Property InterruptEnablePALplusDetectedLost As Saa7118IDEnableDisable
    Get
    Set
public:
property Saa7118IDEnableDisable InterruptEnablePALplusDetectedLost {
    Saa7118IDEnableDisable get ();
    void set (Saa7118IDEnableDisable value);
}
member InterruptEnablePALplusDetectedLost : Saa7118IDEnableDisable with get, set

Property Value

Type: Saa7118IDEnableDisable
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.InterruptEnableReadyForCaptureNotReady Property

IRD

Saa7118InterruptEnableReadyForCaptureNotReady Property

Interrupt enable 'ready for capture/not ready'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDEnableDisable InterruptEnableReadyForCaptureNotReady { get; set; }
Public Property InterruptEnableReadyForCaptureNotReady As Saa7118IDEnableDisable
    Get
    Set
public:
property Saa7118IDEnableDisable InterruptEnableReadyForCaptureNotReady {
    Saa7118IDEnableDisable get ();
    void set (Saa7118IDEnableDisable value);
}
member InterruptEnableReadyForCaptureNotReady : Saa7118IDEnableDisable with get, set

Property Value

Type: Saa7118IDEnableDisable
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.InterruptEnableVPSSignalDetectedLost Property

IRD

Saa7118InterruptEnableVPSSignalDetectedLost Property

Interrupt enable 'VPS signal detected/lost'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDEnableDisable InterruptEnableVPSSignalDetectedLost { get; set; }
Public Property InterruptEnableVPSSignalDetectedLost As Saa7118IDEnableDisable
    Get
    Set
public:
property Saa7118IDEnableDisable InterruptEnableVPSSignalDetectedLost {
    Saa7118IDEnableDisable get ();
    void set (Saa7118IDEnableDisable value);
}
member InterruptEnableVPSSignalDetectedLost : Saa7118IDEnableDisable with get, set

Property Value

Type: Saa7118IDEnableDisable
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.IPortIOEnableICLK Property

IRD

Saa7118IPortIOEnableICLK Property

I port I/O enable: ICLK

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDIPORTIOENABLEKPHASECONTROL1 IPortIOEnableICLK { get; set; }
Public Property IPortIOEnableICLK As Saa7118TYPIDIPORTIOENABLEKPHASECONTROL1
    Get
    Set
public:
property Saa7118TYPIDIPORTIOENABLEKPHASECONTROL1 IPortIOEnableICLK {
    Saa7118TYPIDIPORTIOENABLEKPHASECONTROL1 get ();
    void set (Saa7118TYPIDIPORTIOENABLEKPHASECONTROL1 value);
}
member IPortIOEnableICLK : Saa7118TYPIDIPORTIOENABLEKPHASECONTROL1 with get, set

Property Value

Type: Saa7118TYPIDIPORTIOENABLEKPHASECONTROL1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.IPortIOEnableIDQ Property

IRD

Saa7118IPortIOEnableIDQ Property

I port I/O enable: IDQ

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDIPORTIOENABLEKPHASECONTROL2 IPortIOEnableIDQ { get; set; }
Public Property IPortIOEnableIDQ As Saa7118TYPIDIPORTIOENABLEKPHASECONTROL2
    Get
    Set
public:
property Saa7118TYPIDIPORTIOENABLEKPHASECONTROL2 IPortIOEnableIDQ {
    Saa7118TYPIDIPORTIOENABLEKPHASECONTROL2 get ();
    void set (Saa7118TYPIDIPORTIOENABLEKPHASECONTROL2 value);
}
member IPortIOEnableIDQ : Saa7118TYPIDIPORTIOENABLEKPHASECONTROL2 with get, set

Property Value

Type: Saa7118TYPIDIPORTIOENABLEKPHASECONTROL2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.IPortIOEnableIPortIOEnable Property

IRD

Saa7118IPortIOEnableIPortIOEnable Property

I port I/O enable: I port I/O enable

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDIPORTIOENABLEKPHASECONTROL0 IPortIOEnableIPortIOEnable { get; set; }
Public Property IPortIOEnableIPortIOEnable As Saa7118TYPIDIPORTIOENABLEKPHASECONTROL0
    Get
    Set
public:
property Saa7118TYPIDIPORTIOENABLEKPHASECONTROL0 IPortIOEnableIPortIOEnable {
    Saa7118TYPIDIPORTIOENABLEKPHASECONTROL0 get ();
    void set (Saa7118TYPIDIPORTIOENABLEKPHASECONTROL0 value);
}
member IPortIOEnableIPortIOEnable : Saa7118TYPIDIPORTIOENABLEKPHASECONTROL0 with get, set

Property Value

Type: Saa7118TYPIDIPORTIOENABLEKPHASECONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.IPortSignalDefinitions Property

IRD

Saa7118IPortSignalDefinitions Property

I port signal definitions

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION2 IPortSignalDefinitions { get; set; }
Public Property IPortSignalDefinitions As Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION2
    Get
    Set
public:
property Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION2 IPortSignalDefinitions {
    Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION2 get ();
    void set (Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION2 value);
}
member IPortSignalDefinitions : Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION2 with get, set

Property Value

Type: Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ITRIStatusOnInputPinITRIIfNotUsedFor3StateControl Property

IRD

Saa7118ITRIStatusOnInputPinITRIIfNotUsedFor3StateControl Property

ITRI status on input pin ITRI, if not used for 3-state control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ITRIStatusOnInputPinITRIIfNotUsedFor3StateControl { get; set; }
Public Property ITRIStatusOnInputPinITRIIfNotUsedFor3StateControl As Byte
    Get
    Set
public:
property unsigned char ITRIStatusOnInputPinITRIIfNotUsedFor3StateControl {
    unsigned char get ();
    void set (unsigned char value);
}
member ITRIStatusOnInputPinITRIIfNotUsedFor3StateControl : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR10Field1 Property

IRD

Saa7118LCR10Field1 Property

LCR10: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR10Field1 { get; set; }
Public Property LCR10Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR10Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR10Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR10Field2 Property

IRD

Saa7118LCR10Field2 Property

LCR10: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR10Field2 { get; set; }
Public Property LCR10Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR10Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR10Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR11Field1 Property

IRD

Saa7118LCR11Field1 Property

LCR11: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR11Field1 { get; set; }
Public Property LCR11Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR11Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR11Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR11Field2 Property

IRD

Saa7118LCR11Field2 Property

LCR11: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR11Field2 { get; set; }
Public Property LCR11Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR11Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR11Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR12Field1 Property

IRD

Saa7118LCR12Field1 Property

LCR12: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR12Field1 { get; set; }
Public Property LCR12Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR12Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR12Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR12Field2 Property

IRD

Saa7118LCR12Field2 Property

LCR12: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR12Field2 { get; set; }
Public Property LCR12Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR12Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR12Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR13Field1 Property

IRD

Saa7118LCR13Field1 Property

LCR13: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR13Field1 { get; set; }
Public Property LCR13Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR13Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR13Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR13Field2 Property

IRD

Saa7118LCR13Field2 Property

LCR13: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR13Field2 { get; set; }
Public Property LCR13Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR13Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR13Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR14Field1 Property

IRD

Saa7118LCR14Field1 Property

LCR14: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR14Field1 { get; set; }
Public Property LCR14Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR14Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR14Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR14Field2 Property

IRD

Saa7118LCR14Field2 Property

LCR14: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR14Field2 { get; set; }
Public Property LCR14Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR14Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR14Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR15Field1 Property

IRD

Saa7118LCR15Field1 Property

LCR15: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR15Field1 { get; set; }
Public Property LCR15Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR15Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR15Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR15Field2 Property

IRD

Saa7118LCR15Field2 Property

LCR15: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR15Field2 { get; set; }
Public Property LCR15Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR15Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR15Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR16Field1 Property

IRD

Saa7118LCR16Field1 Property

LCR16: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR16Field1 { get; set; }
Public Property LCR16Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR16Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR16Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR16Field2 Property

IRD

Saa7118LCR16Field2 Property

LCR16: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR16Field2 { get; set; }
Public Property LCR16Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR16Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR16Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR17Field1 Property

IRD

Saa7118LCR17Field1 Property

LCR17: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR17Field1 { get; set; }
Public Property LCR17Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR17Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR17Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR17Field2 Property

IRD

Saa7118LCR17Field2 Property

LCR17: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR17Field2 { get; set; }
Public Property LCR17Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR17Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR17Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR18Field1 Property

IRD

Saa7118LCR18Field1 Property

LCR18: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR18Field1 { get; set; }
Public Property LCR18Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR18Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR18Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR18Field2 Property

IRD

Saa7118LCR18Field2 Property

LCR18: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR18Field2 { get; set; }
Public Property LCR18Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR18Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR18Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR19Field1 Property

IRD

Saa7118LCR19Field1 Property

LCR19: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR19Field1 { get; set; }
Public Property LCR19Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR19Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR19Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR19Field2 Property

IRD

Saa7118LCR19Field2 Property

LCR19: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR19Field2 { get; set; }
Public Property LCR19Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR19Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR19Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR20Field1 Property

IRD

Saa7118LCR20Field1 Property

LCR20: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR20Field1 { get; set; }
Public Property LCR20Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR20Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR20Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR20Field2 Property

IRD

Saa7118LCR20Field2 Property

LCR20: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR20Field2 { get; set; }
Public Property LCR20Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR20Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR20Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR21Field1 Property

IRD

Saa7118LCR21Field1 Property

LCR21: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR21Field1 { get; set; }
Public Property LCR21Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR21Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR21Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR21Field2 Property

IRD

Saa7118LCR21Field2 Property

LCR21: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR21Field2 { get; set; }
Public Property LCR21Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR21Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR21Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR22Field1 Property

IRD

Saa7118LCR22Field1 Property

LCR22: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR22Field1 { get; set; }
Public Property LCR22Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR22Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR22Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR22Field2 Property

IRD

Saa7118LCR22Field2 Property

LCR22: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR22Field2 { get; set; }
Public Property LCR22Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR22Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR22Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR23Field1 Property

IRD

Saa7118LCR23Field1 Property

LCR23: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR23Field1 { get; set; }
Public Property LCR23Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR23Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR23Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR23Field2 Property

IRD

Saa7118LCR23Field2 Property

LCR23: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR23Field2 { get; set; }
Public Property LCR23Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR23Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR23Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR24Field1 Property

IRD

Saa7118LCR24Field1 Property

LCR24: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR24Field1 { get; set; }
Public Property LCR24Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR24Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR24Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR24Field2 Property

IRD

Saa7118LCR24Field2 Property

LCR24: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR24Field2 { get; set; }
Public Property LCR24Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR24Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR24Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR2Field1 Property

IRD

Saa7118LCR2Field1 Property

LCR2: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR2Field1 { get; set; }
Public Property LCR2Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR2Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR2Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR2Field2 Property

IRD

Saa7118LCR2Field2 Property

LCR2: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR2Field2 { get; set; }
Public Property LCR2Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR2Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR2Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR3Field1 Property

IRD

Saa7118LCR3Field1 Property

LCR3: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR3Field1 { get; set; }
Public Property LCR3Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR3Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR3Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR3Field2 Property

IRD

Saa7118LCR3Field2 Property

LCR3: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR3Field2 { get; set; }
Public Property LCR3Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR3Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR3Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR4Field1 Property

IRD

Saa7118LCR4Field1 Property

LCR4: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR4Field1 { get; set; }
Public Property LCR4Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR4Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR4Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR4Field2 Property

IRD

Saa7118LCR4Field2 Property

LCR4: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR4Field2 { get; set; }
Public Property LCR4Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR4Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR4Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR5Field1 Property

IRD

Saa7118LCR5Field1 Property

LCR5: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR5Field1 { get; set; }
Public Property LCR5Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR5Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR5Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR5Field2 Property

IRD

Saa7118LCR5Field2 Property

LCR5: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR5Field2 { get; set; }
Public Property LCR5Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR5Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR5Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR6Field1 Property

IRD

Saa7118LCR6Field1 Property

LCR6: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR6Field1 { get; set; }
Public Property LCR6Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR6Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR6Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR6Field2 Property

IRD

Saa7118LCR6Field2 Property

LCR6: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR6Field2 { get; set; }
Public Property LCR6Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR6Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR6Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR7Field1 Property

IRD

Saa7118LCR7Field1 Property

LCR7: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR7Field1 { get; set; }
Public Property LCR7Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR7Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR7Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR7Field2 Property

IRD

Saa7118LCR7Field2 Property

LCR7: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR7Field2 { get; set; }
Public Property LCR7Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR7Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR7Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR8Field1 Property

IRD

Saa7118LCR8Field1 Property

LCR8: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR8Field1 { get; set; }
Public Property LCR8Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR8Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR8Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR8Field2 Property

IRD

Saa7118LCR8Field2 Property

LCR8: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR8Field2 { get; set; }
Public Property LCR8Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR8Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR8Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR9Field1 Property

IRD

Saa7118LCR9Field1 Property

LCR9: Field 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR9Field1 { get; set; }
Public Property LCR9Field1 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR9Field1 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR9Field1 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LCR9Field2 Property

IRD

Saa7118LCR9Field2 Property

LCR9: Field 2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR9Field2 { get; set; }
Public Property LCR9Field2 As Saa7118TYPIDLINECONTROLREGISTERLCR20
    Get
    Set
public:
property Saa7118TYPIDLINECONTROLREGISTERLCR20 LCR9Field2 {
    Saa7118TYPIDLINECONTROLREGISTERLCR20 get ();
    void set (Saa7118TYPIDLINECONTROLREGISTERLCR20 value);
}
member LCR9Field2 : Saa7118TYPIDLINECONTROLREGISTERLCR20 with get, set

Property Value

Type: Saa7118TYPIDLINECONTROLREGISTERLCR20
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LineNumber Property

IRD

Saa7118LineNumber Property

Line Number

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort LineNumber { get; }
Public ReadOnly Property LineNumber As UShort
    Get
public:
property unsigned short LineNumber {
    unsigned short get ();
}
member LineNumber : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LLC2OutputEnable Property

IRD

Saa7118LLC2OutputEnable Property

LLC2 output enable

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDMISCELLANEOUSVGATEMSBS2 LLC2OutputEnable { get; set; }
Public Property LLC2OutputEnable As Saa7118TYPIDMISCELLANEOUSVGATEMSBS2
    Get
    Set
public:
property Saa7118TYPIDMISCELLANEOUSVGATEMSBS2 LLC2OutputEnable {
    Saa7118TYPIDMISCELLANEOUSVGATEMSBS2 get ();
    void set (Saa7118TYPIDMISCELLANEOUSVGATEMSBS2 value);
}
member LLC2OutputEnable : Saa7118TYPIDMISCELLANEOUSVGATEMSBS2 with get, set

Property Value

Type: Saa7118TYPIDMISCELLANEOUSVGATEMSBS2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LLCOutputEnable Property

IRD

Saa7118LLCOutputEnable Property

LLC output enable

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDMISCELLANEOUSVGATEMSBS2 LLCOutputEnable { get; set; }
Public Property LLCOutputEnable As Saa7118TYPIDMISCELLANEOUSVGATEMSBS2
    Get
    Set
public:
property Saa7118TYPIDMISCELLANEOUSVGATEMSBS2 LLCOutputEnable {
    Saa7118TYPIDMISCELLANEOUSVGATEMSBS2 get ();
    void set (Saa7118TYPIDMISCELLANEOUSVGATEMSBS2 value);
}
member LLCOutputEnable : Saa7118TYPIDMISCELLANEOUSVGATEMSBS2 with get, set

Property Value

Type: Saa7118TYPIDMISCELLANEOUSVGATEMSBS2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LuminanceBrightnessControlComponentPart Property

IRD

Saa7118LuminanceBrightnessControlComponentPart Property

Luminance brightness control component part

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLUMINANCEBRIGHTNLDECODERPART0 LuminanceBrightnessControlComponentPart { get; set; }
Public Property LuminanceBrightnessControlComponentPart As Saa7118TYPIDLUMINANCEBRIGHTNLDECODERPART0
    Get
    Set
public:
property Saa7118TYPIDLUMINANCEBRIGHTNLDECODERPART0 LuminanceBrightnessControlComponentPart {
    Saa7118TYPIDLUMINANCEBRIGHTNLDECODERPART0 get ();
    void set (Saa7118TYPIDLUMINANCEBRIGHTNLDECODERPART0 value);
}
member LuminanceBrightnessControlComponentPart : Saa7118TYPIDLUMINANCEBRIGHTNLDECODERPART0 with get, set

Property Value

Type: Saa7118TYPIDLUMINANCEBRIGHTNLDECODERPART0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LuminanceBrightnessControlDecoderPart Property

IRD

Saa7118LuminanceBrightnessControlDecoderPart Property

Luminance brightness control: decoder part

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLUMINANCEBRIGHTNLDECODERPART0 LuminanceBrightnessControlDecoderPart { get; set; }
Public Property LuminanceBrightnessControlDecoderPart As Saa7118TYPIDLUMINANCEBRIGHTNLDECODERPART0
    Get
    Set
public:
property Saa7118TYPIDLUMINANCEBRIGHTNLDECODERPART0 LuminanceBrightnessControlDecoderPart {
    Saa7118TYPIDLUMINANCEBRIGHTNLDECODERPART0 get ();
    void set (Saa7118TYPIDLUMINANCEBRIGHTNLDECODERPART0 value);
}
member LuminanceBrightnessControlDecoderPart : Saa7118TYPIDLUMINANCEBRIGHTNLDECODERPART0 with get, set

Property Value

Type: Saa7118TYPIDLUMINANCEBRIGHTNLDECODERPART0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LuminanceContrastControlComponentPart Property

IRD

Saa7118LuminanceContrastControlComponentPart Property

Luminance contrast control component part

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLUMINANCECONTRASCOMPONENTPART0 LuminanceContrastControlComponentPart { get; set; }
Public Property LuminanceContrastControlComponentPart As Saa7118TYPIDLUMINANCECONTRASCOMPONENTPART0
    Get
    Set
public:
property Saa7118TYPIDLUMINANCECONTRASCOMPONENTPART0 LuminanceContrastControlComponentPart {
    Saa7118TYPIDLUMINANCECONTRASCOMPONENTPART0 get ();
    void set (Saa7118TYPIDLUMINANCECONTRASCOMPONENTPART0 value);
}
member LuminanceContrastControlComponentPart : Saa7118TYPIDLUMINANCECONTRASCOMPONENTPART0 with get, set

Property Value

Type: Saa7118TYPIDLUMINANCECONTRASCOMPONENTPART0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LuminanceContrastControlDecoderPartNegInverse Property

IRD

Saa7118LuminanceContrastControlDecoderPartNegInverse Property

Luminance contrast control: Decoder part (neg=inverse)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLUMINANCECONTRASLDECODERPART0 LuminanceContrastControlDecoderPartNegInverse { get; set; }
Public Property LuminanceContrastControlDecoderPartNegInverse As Saa7118TYPIDLUMINANCECONTRASLDECODERPART0
    Get
    Set
public:
property Saa7118TYPIDLUMINANCECONTRASLDECODERPART0 LuminanceContrastControlDecoderPartNegInverse {
    Saa7118TYPIDLUMINANCECONTRASLDECODERPART0 get ();
    void set (Saa7118TYPIDLUMINANCECONTRASLDECODERPART0 value);
}
member LuminanceContrastControlDecoderPartNegInverse : Saa7118TYPIDLUMINANCECONTRASLDECODERPART0 with get, set

Property Value

Type: Saa7118TYPIDLUMINANCECONTRASLDECODERPART0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.LuminanceDelayCompensation Property

IRD

Saa7118LuminanceDelayCompensation Property

Luminance delay compensation

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LuminanceDelayCompensation { get; set; }
Public Property LuminanceDelayCompensation As SByte
    Get
    Set
public:
property signed char LuminanceDelayCompensation {
    signed char get ();
    void set (signed char value);
}
member LuminanceDelayCompensation : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.MacrovisionEncodedColourStripeBurstDetected Property

IRD

Saa7118MacrovisionEncodedColourStripeBurstDetected Property

Macrovision encoded colour stripe burst detected

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDNotActiveActive MacrovisionEncodedColourStripeBurstDetected { get; }
Public ReadOnly Property MacrovisionEncodedColourStripeBurstDetected As Saa7118IDNotActiveActive
    Get
public:
property Saa7118IDNotActiveActive MacrovisionEncodedColourStripeBurstDetected {
    Saa7118IDNotActiveActive get ();
}
member MacrovisionEncodedColourStripeBurstDetected : Saa7118IDNotActiveActive with get

Property Value

Type: Saa7118IDNotActiveActive
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.MacrovisionEncodedColourStripeBurstType34LineVersionDetected Property

IRD

Saa7118MacrovisionEncodedColourStripeBurstType34LineVersionDetected Property

Macrovision encoded colour stripe burst type 3 (4 line version) detected

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDNotActiveActive MacrovisionEncodedColourStripeBurstType34LineVersionDetected { get; }
Public ReadOnly Property MacrovisionEncodedColourStripeBurstType34LineVersionDetected As Saa7118IDNotActiveActive
    Get
public:
property Saa7118IDNotActiveActive MacrovisionEncodedColourStripeBurstType34LineVersionDetected {
    Saa7118IDNotActiveActive get ();
}
member MacrovisionEncodedColourStripeBurstType34LineVersionDetected : Saa7118IDNotActiveActive with get

Property Value

Type: Saa7118IDNotActiveActive
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ModeSelection Property

IRD

Saa7118ModeSelection Property

Mode selection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDANALOGINPUTCONTROL10 ModeSelection { get; set; }
Public Property ModeSelection As Saa7118TYPIDANALOGINPUTCONTROL10
    Get
    Set
public:
property Saa7118TYPIDANALOGINPUTCONTROL10 ModeSelection {
    Saa7118TYPIDANALOGINPUTCONTROL10 get ();
    void set (Saa7118TYPIDANALOGINPUTCONTROL10 value);
}
member ModeSelection : Saa7118TYPIDANALOGINPUTCONTROL10 with get, set

Property Value

Type: Saa7118TYPIDANALOGINPUTCONTROL10
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.PALplusValid Property

IRD

Saa7118PALplusValid Property

PALplus valid

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSLICERSTATUSBYTE01 PALplusValid { get; }
Public ReadOnly Property PALplusValid As Saa7118TYPIDSLICERSTATUSBYTE01
    Get
public:
property Saa7118TYPIDSLICERSTATUSBYTE01 PALplusValid {
    Saa7118TYPIDSLICERSTATUSBYTE01 get ();
}
member PALplusValid : Saa7118TYPIDSLICERSTATUSBYTE01 with get

Property Value

Type: Saa7118TYPIDSLICERSTATUSBYTE01
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.PolarityOfRTS0OutputSignal Property

IRD

Saa7118PolarityOfRTS0OutputSignal Property

Polarity of RTS0 output signal

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDMODEDELAYCONTROL1 PolarityOfRTS0OutputSignal { get; set; }
Public Property PolarityOfRTS0OutputSignal As Saa7118TYPIDMODEDELAYCONTROL1
    Get
    Set
public:
property Saa7118TYPIDMODEDELAYCONTROL1 PolarityOfRTS0OutputSignal {
    Saa7118TYPIDMODEDELAYCONTROL1 get ();
    void set (Saa7118TYPIDMODEDELAYCONTROL1 value);
}
member PolarityOfRTS0OutputSignal : Saa7118TYPIDMODEDELAYCONTROL1 with get, set

Property Value

Type: Saa7118TYPIDMODEDELAYCONTROL1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.PolarityOfRTS1OutputSignal Property

IRD

Saa7118PolarityOfRTS1OutputSignal Property

Polarity of RTS1 output signal

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDMODEDELAYCONTROL1 PolarityOfRTS1OutputSignal { get; set; }
Public Property PolarityOfRTS1OutputSignal As Saa7118TYPIDMODEDELAYCONTROL1
    Get
    Set
public:
property Saa7118TYPIDMODEDELAYCONTROL1 PolarityOfRTS1OutputSignal {
    Saa7118TYPIDMODEDELAYCONTROL1 get ();
    void set (Saa7118TYPIDMODEDELAYCONTROL1 value);
}
member PolarityOfRTS1OutputSignal : Saa7118TYPIDMODEDELAYCONTROL1 with get, set

Property Value

Type: Saa7118TYPIDMODEDELAYCONTROL1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.PRDONCopyOfBitDPROGCanBeUsedToDetectPowerUpAndStartUpFails Property

IRD

Saa7118PRDONCopyOfBitDPROGCanBeUsedToDetectPowerUpAndStartUpFails Property

PRDON copy of bit DPROG, can be used to detect power-up and start-up fails

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PRDONCopyOfBitDPROGCanBeUsedToDetectPowerUpAndStartUpFails { get; set; }
Public Property PRDONCopyOfBitDPROGCanBeUsedToDetectPowerUpAndStartUpFails As Byte
    Get
    Set
public:
property unsigned char PRDONCopyOfBitDPROGCanBeUsedToDetectPowerUpAndStartUpFails {
    unsigned char get ();
    void set (unsigned char value);
}
member PRDONCopyOfBitDPROGCanBeUsedToDetectPowerUpAndStartUpFails : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ProcessingDelayInNonCombFilterMode Property

IRD

Saa7118ProcessingDelayInNonCombFilterMode Property

Processing delay in non comb filter mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLUMINANCECONTROL2 ProcessingDelayInNonCombFilterMode { get; set; }
Public Property ProcessingDelayInNonCombFilterMode As Saa7118TYPIDLUMINANCECONTROL2
    Get
    Set
public:
property Saa7118TYPIDLUMINANCECONTROL2 ProcessingDelayInNonCombFilterMode {
    Saa7118TYPIDLUMINANCECONTROL2 get ();
    void set (Saa7118TYPIDLUMINANCECONTROL2 value);
}
member ProcessingDelayInNonCombFilterMode : Saa7118TYPIDLUMINANCECONTROL2 with get, set

Property Value

Type: Saa7118TYPIDLUMINANCECONTROL2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ProgrammableFramingCode Property

IRD

Saa7118ProgrammableFramingCode Property

Programmable framing code

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ProgrammableFramingCode { get; set; }
Public Property ProgrammableFramingCode As Byte
    Get
    Set
public:
property unsigned char ProgrammableFramingCode {
    unsigned char get ();
    void set (unsigned char value);
}
member ProgrammableFramingCode : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RawDataGainControl Property

IRD

Saa7118RawDataGainControl Property

Raw data gain control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDRAWDATAGAINCONTROL0 RawDataGainControl { get; set; }
Public Property RawDataGainControl As Saa7118TYPIDRAWDATAGAINCONTROL0
    Get
    Set
public:
property Saa7118TYPIDRAWDATAGAINCONTROL0 RawDataGainControl {
    Saa7118TYPIDRAWDATAGAINCONTROL0 get ();
    void set (Saa7118TYPIDRAWDATAGAINCONTROL0 value);
}
member RawDataGainControl : Saa7118TYPIDRAWDATAGAINCONTROL0 with get, set

Property Value

Type: Saa7118TYPIDRAWDATAGAINCONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RawDataOffsetControl Property

IRD

Saa7118RawDataOffsetControl Property

Raw data offset control (unit: LSB)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RawDataOffsetControl { get; set; }
Public Property RawDataOffsetControl As SByte
    Get
    Set
public:
property signed char RawDataOffsetControl {
    signed char get ();
    void set (signed char value);
}
member RawDataOffsetControl : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.ReadyForCapture Property

IRD

Saa7118ReadyForCapture Property

Ready for capture

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDNotActiveActive ReadyForCapture { get; }
Public ReadOnly Property ReadyForCapture As Saa7118IDNotActiveActive
    Get
public:
property Saa7118IDNotActiveActive ReadyForCapture {
    Saa7118IDNotActiveActive get ();
}
member ReadyForCapture : Saa7118IDNotActiveActive with get

Property Value

Type: Saa7118IDNotActiveActive
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.Recode Property

IRD

Saa7118Recode Property

Recode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDFIELDOFFSETANDETSSLICERSET0 Recode { get; set; }
Public Property Recode As Saa7118TYPIDFIELDOFFSETANDETSSLICERSET0
    Get
    Set
public:
property Saa7118TYPIDFIELDOFFSETANDETSSLICERSET0 Recode {
    Saa7118TYPIDFIELDOFFSETANDETSSLICERSET0 get ();
    void set (Saa7118TYPIDFIELDOFFSETANDETSSLICERSET0 value);
}
member Recode : Saa7118TYPIDFIELDOFFSETANDETSSLICERSET0 with get, set

Property Value

Type: Saa7118TYPIDFIELDOFFSETANDETSSLICERSET0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAAccumulationLength Property

IRD

Saa7118RegSetAAccumulationLength Property

RegSet A: Accumulation length

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetAAccumulationLength { get; set; }
Public Property RegSetAAccumulationLength As Byte
    Get
    Set
public:
property unsigned char RegSetAAccumulationLength {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetAAccumulationLength : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAChromaIsProvided Property

IRD

Saa7118RegSetAChromaIsProvided Property

RegSet A: Chroma is provided

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION1 RegSetAChromaIsProvided { get; set; }
Public Property RegSetAChromaIsProvided As Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION1
    Get
    Set
public:
property Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION1 RegSetAChromaIsProvided {
    Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION1 get ();
    void set (Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION1 value);
}
member RegSetAChromaIsProvided : Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION1 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAChrominanceFIRFilter Property

IRD

Saa7118RegSetAChrominanceFIRFilter Property

RegSet A: Chrominance FIR filter

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL3 RegSetAChrominanceFIRFilter { get; set; }
Public Property RegSetAChrominanceFIRFilter As Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL3
    Get
    Set
public:
property Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL3 RegSetAChrominanceFIRFilter {
    Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL3 get ();
    void set (Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL3 value);
}
member RegSetAChrominanceFIRFilter : Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL3 with get, set

Property Value

Type: Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL3
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetADataQualified Property

IRD

Saa7118RegSetADataQualified Property

RegSet A: Data qualified:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS1 RegSetADataQualified { get; set; }
Public Property RegSetADataQualified As Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS1
    Get
    Set
public:
property Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS1 RegSetADataQualified {
    Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS1 get ();
    void set (Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS1 value);
}
member RegSetADataQualified : Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS1 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetADwordsTransferred Property

IRD

Saa7118RegSetADwordsTransferred Property

RegSet A: Dwords transferred

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION3 RegSetADwordsTransferred { get; set; }
Public Property RegSetADwordsTransferred As Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION3
    Get
    Set
public:
property Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION3 RegSetADwordsTransferred {
    Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION3 get ();
    void set (Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION3 value);
}
member RegSetADwordsTransferred : Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION3 with get, set

Property Value

Type: Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION3
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAEdgeOfXRHInputIsHorizontalReference Property

IRD

Saa7118RegSetAEdgeOfXRHInputIsHorizontalReference Property

RegSet A: Edge of XRH input is horizontal reference

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS2 RegSetAEdgeOfXRHInputIsHorizontalReference { get; set; }
Public Property RegSetAEdgeOfXRHInputIsHorizontalReference As Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS2
    Get
    Set
public:
property Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS2 RegSetAEdgeOfXRHInputIsHorizontalReference {
    Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS2 get ();
    void set (Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS2 value);
}
member RegSetAEdgeOfXRHInputIsHorizontalReference : Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS2 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAEdgeOfXRVInputAndDecoderV123IsVerticalReference Property

IRD

Saa7118RegSetAEdgeOfXRVInputAndDecoderV123IsVerticalReference Property

RegSet A: Edge of XRV input and decoder V123 is vertical reference:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS4 RegSetAEdgeOfXRVInputAndDecoderV123IsVerticalReference { get; set; }
Public Property RegSetAEdgeOfXRVInputAndDecoderV123IsVerticalReference As Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS4
    Get
    Set
public:
property Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS4 RegSetAEdgeOfXRVInputAndDecoderV123IsVerticalReference {
    Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS4 get ();
    void set (Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS4 value);
}
member RegSetAEdgeOfXRVInputAndDecoderV123IsVerticalReference : Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS4 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS4
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAEventHandlerTriggers Property

IRD

Saa7118RegSetAEventHandlerTriggers Property

RegSet A: Event handler triggers

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTATASKHANDLINGCONTROL0 RegSetAEventHandlerTriggers { get; set; }
Public Property RegSetAEventHandlerTriggers As Saa7118TYPIDTATASKHANDLINGCONTROL0
    Get
    Set
public:
property Saa7118TYPIDTATASKHANDLINGCONTROL0 RegSetAEventHandlerTriggers {
    Saa7118TYPIDTATASKHANDLINGCONTROL0 get ();
    void set (Saa7118TYPIDTATASKHANDLINGCONTROL0 value);
}
member RegSetAEventHandlerTriggers : Saa7118TYPIDTATASKHANDLINGCONTROL0 with get, set

Property Value

Type: Saa7118TYPIDTATASKHANDLINGCONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAFormat Property

IRD

Saa7118RegSetAFormat Property

RegSet A: Format

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION0 RegSetAFormat { get; set; }
Public Property RegSetAFormat As Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION0
    Get
    Set
public:
property Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION0 RegSetAFormat {
    Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION0 get ();
    void set (Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION0 value);
}
member RegSetAFormat : Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION0 with get, set

Property Value

Type: Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAGain Property

IRD

Saa7118RegSetAGain Property

RegSet A: Gain

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 RegSetAGain { get; set; }
Public Property RegSetAGain As Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0
    Get
    Set
public:
property Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 RegSetAGain {
    Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 get ();
    void set (Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 value);
}
member RegSetAGain : Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 with get, set

Property Value

Type: Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAHorizontalChrominancePhaseOffset Property

IRD

Saa7118RegSetAHorizontalChrominancePhaseOffset Property

RegSet A: Horizontal chrominance phase offset

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetAHorizontalChrominancePhaseOffset { get; set; }
Public Property RegSetAHorizontalChrominancePhaseOffset As Byte
    Get
    Set
public:
property unsigned char RegSetAHorizontalChrominancePhaseOffset {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetAHorizontalChrominancePhaseOffset : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAHorizontalChrominanceScalingIncrement Property

IRD

Saa7118RegSetAHorizontalChrominanceScalingIncrement Property

RegSet A: Horizontal chrominance scaling increment

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort RegSetAHorizontalChrominanceScalingIncrement { get; set; }
Public Property RegSetAHorizontalChrominanceScalingIncrement As UShort
    Get
    Set
public:
property unsigned short RegSetAHorizontalChrominanceScalingIncrement {
    unsigned short get ();
    void set (unsigned short value);
}
member RegSetAHorizontalChrominanceScalingIncrement : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAHorizontalInputWindowLength Property

IRD

Saa7118RegSetAHorizontalInputWindowLength Property

RegSet A: Horizontal input window length

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAHORIZONTALINPWINDOWLENGTHL0 RegSetAHorizontalInputWindowLength { get; set; }
Public Property RegSetAHorizontalInputWindowLength As Saa7118TYPIDTAHORIZONTALINPWINDOWLENGTHL0
    Get
    Set
public:
property Saa7118TYPIDTAHORIZONTALINPWINDOWLENGTHL0 RegSetAHorizontalInputWindowLength {
    Saa7118TYPIDTAHORIZONTALINPWINDOWLENGTHL0 get ();
    void set (Saa7118TYPIDTAHORIZONTALINPWINDOWLENGTHL0 value);
}
member RegSetAHorizontalInputWindowLength : Saa7118TYPIDTAHORIZONTALINPWINDOWLENGTHL0 with get, set

Property Value

Type: Saa7118TYPIDTAHORIZONTALINPWINDOWLENGTHL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAHorizontalInputWindowStart Property

IRD

Saa7118RegSetAHorizontalInputWindowStart Property

RegSet A: Horizontal input window start

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0 RegSetAHorizontalInputWindowStart { get; set; }
Public Property RegSetAHorizontalInputWindowStart As Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0
    Get
    Set
public:
property Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0 RegSetAHorizontalInputWindowStart {
    Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0 get ();
    void set (Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0 value);
}
member RegSetAHorizontalInputWindowStart : Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0 with get, set

Property Value

Type: Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAHorizontalLuminancePhaseOffset Property

IRD

Saa7118RegSetAHorizontalLuminancePhaseOffset Property

RegSet A: Horizontal luminance phase offset (unit: Pixel)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 RegSetAHorizontalLuminancePhaseOffset { get; set; }
Public Property RegSetAHorizontalLuminancePhaseOffset As Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
    Get
    Set
public:
property Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 RegSetAHorizontalLuminancePhaseOffset {
    Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 get ();
    void set (Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 value);
}
member RegSetAHorizontalLuminancePhaseOffset : Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 with get, set

Property Value

Type: Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAHorizontalLuminanceScalingIncrementScale1024Data Property

IRD

Saa7118RegSetAHorizontalLuminanceScalingIncrementScale1024Data Property

RegSet A: Horizontal luminance scaling increment Scale=1024/[Data]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAHORIZONTALLUMLINGINCREMENTL0 RegSetAHorizontalLuminanceScalingIncrementScale1024Data { get; set; }
Public Property RegSetAHorizontalLuminanceScalingIncrementScale1024Data As Saa7118TYPIDTAHORIZONTALLUMLINGINCREMENTL0
    Get
    Set
public:
property Saa7118TYPIDTAHORIZONTALLUMLINGINCREMENTL0 RegSetAHorizontalLuminanceScalingIncrementScale1024Data {
    Saa7118TYPIDTAHORIZONTALLUMLINGINCREMENTL0 get ();
    void set (Saa7118TYPIDTAHORIZONTALLUMLINGINCREMENTL0 value);
}
member RegSetAHorizontalLuminanceScalingIncrementScale1024Data : Saa7118TYPIDTAHORIZONTALLUMLINGINCREMENTL0 with get, set

Property Value

Type: Saa7118TYPIDTAHORIZONTALLUMLINGINCREMENTL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAHorizontalOutputWindowLength Property

IRD

Saa7118RegSetAHorizontalOutputWindowLength Property

RegSet A:Horizontal output window length

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 RegSetAHorizontalOutputWindowLength { get; set; }
Public Property RegSetAHorizontalOutputWindowLength As Saa7118TYPIDTAHORIZONTALOUTWINDOWLENGTHL0
    Get
    Set
public:
property Saa7118TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 RegSetAHorizontalOutputWindowLength {
    Saa7118TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 get ();
    void set (Saa7118TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 value);
}
member RegSetAHorizontalOutputWindowLength : Saa7118TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 with get, set

Property Value

Type: Saa7118TYPIDTAHORIZONTALOUTWINDOWLENGTHL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAHorizontalPrescaling Property

IRD

Saa7118RegSetAHorizontalPrescaling Property

RegSet A: Horizontal prescaling

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAHORIZONTALPRESCALING0 RegSetAHorizontalPrescaling { get; set; }
Public Property RegSetAHorizontalPrescaling As Saa7118TYPIDTAHORIZONTALPRESCALING0
    Get
    Set
public:
property Saa7118TYPIDTAHORIZONTALPRESCALING0 RegSetAHorizontalPrescaling {
    Saa7118TYPIDTAHORIZONTALPRESCALING0 get ();
    void set (Saa7118TYPIDTAHORIZONTALPRESCALING0 value);
}
member RegSetAHorizontalPrescaling : Saa7118TYPIDTAHORIZONTALPRESCALING0 with get, set

Property Value

Type: Saa7118TYPIDTAHORIZONTALPRESCALING0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAITU656 Property

IRD

Saa7118RegSetAITU656 Property

RegSet A: ITU 656

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION4 RegSetAITU656 { get; set; }
Public Property RegSetAITU656 As Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION4
    Get
    Set
public:
property Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION4 RegSetAITU656 {
    Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION4 get ();
    void set (Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION4 value);
}
member RegSetAITU656 : Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION4 with get, set

Property Value

Type: Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION4
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetALeadingLinesBefore1stYCBCRLineIsOutput Property

IRD

Saa7118RegSetALeadingLinesBefore1stYCBCRLineIsOutput Property

RegSet A: Leading lines before 1st Y + CB-CR line is output

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION1 RegSetALeadingLinesBefore1stYCBCRLineIsOutput { get; set; }
Public Property RegSetALeadingLinesBefore1stYCBCRLineIsOutput As Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION1
    Get
    Set
public:
property Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION1 RegSetALeadingLinesBefore1stYCBCRLineIsOutput {
    Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION1 get ();
    void set (Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION1 value);
}
member RegSetALeadingLinesBefore1stYCBCRLineIsOutput : Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION1 with get, set

Property Value

Type: Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetALinesOutput Property

IRD

Saa7118RegSetALinesOutput Property

RegSet A: Lines output

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION2 RegSetALinesOutput { get; set; }
Public Property RegSetALinesOutput As Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION2
    Get
    Set
public:
property Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION2 RegSetALinesOutput {
    Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION2 get ();
    void set (Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION2 value);
}
member RegSetALinesOutput : Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION2 with get, set

Property Value

Type: Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetALuminanceBrightnessControl Property

IRD

Saa7118RegSetALuminanceBrightnessControl Property

RegSet A: Luminance brightness control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTALUMINANCEBRIGGHTNESSCONTROL0 RegSetALuminanceBrightnessControl { get; set; }
Public Property RegSetALuminanceBrightnessControl As Saa7118TYPIDTALUMINANCEBRIGGHTNESSCONTROL0
    Get
    Set
public:
property Saa7118TYPIDTALUMINANCEBRIGGHTNESSCONTROL0 RegSetALuminanceBrightnessControl {
    Saa7118TYPIDTALUMINANCEBRIGGHTNESSCONTROL0 get ();
    void set (Saa7118TYPIDTALUMINANCEBRIGGHTNESSCONTROL0 value);
}
member RegSetALuminanceBrightnessControl : Saa7118TYPIDTALUMINANCEBRIGGHTNESSCONTROL0 with get, set

Property Value

Type: Saa7118TYPIDTALUMINANCEBRIGGHTNESSCONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetALuminanceContrastControl Property

IRD

Saa7118RegSetALuminanceContrastControl Property

RegSet A: Luminance contrast control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 RegSetALuminanceContrastControl { get; set; }
Public Property RegSetALuminanceContrastControl As Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0
    Get
    Set
public:
property Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 RegSetALuminanceContrastControl {
    Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 get ();
    void set (Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 value);
}
member RegSetALuminanceContrastControl : Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 with get, set

Property Value

Type: Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetALuminanceFIRFilter Property

IRD

Saa7118RegSetALuminanceFIRFilter Property

RegSet A: Luminance FIR filter

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL2 RegSetALuminanceFIRFilter { get; set; }
Public Property RegSetALuminanceFIRFilter As Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL2
    Get
    Set
public:
property Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL2 RegSetALuminanceFIRFilter {
    Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL2 get ();
    void set (Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL2 value);
}
member RegSetALuminanceFIRFilter : Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL2 with get, set

Property Value

Type: Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetANextTask Property

IRD

Saa7118RegSetANextTask Property

RegSet A: Next task

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTATASKHANDLINGCONTROL1 RegSetANextTask { get; set; }
Public Property RegSetANextTask As Saa7118TYPIDTATASKHANDLINGCONTROL1
    Get
    Set
public:
property Saa7118TYPIDTATASKHANDLINGCONTROL1 RegSetANextTask {
    Saa7118TYPIDTATASKHANDLINGCONTROL1 get ();
    void set (Saa7118TYPIDTATASKHANDLINGCONTROL1 value);
}
member RegSetANextTask : Saa7118TYPIDTATASKHANDLINGCONTROL1 with get, set

Property Value

Type: Saa7118TYPIDTATASKHANDLINGCONTROL1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAOutputFieldID Property

IRD

Saa7118RegSetAOutputFieldID Property

RegSet A: Output field ID

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTATASKHANDLINGCONTROL3 RegSetAOutputFieldID { get; set; }
Public Property RegSetAOutputFieldID As Saa7118TYPIDTATASKHANDLINGCONTROL3
    Get
    Set
public:
property Saa7118TYPIDTATASKHANDLINGCONTROL3 RegSetAOutputFieldID {
    Saa7118TYPIDTATASKHANDLINGCONTROL3 get ();
    void set (Saa7118TYPIDTATASKHANDLINGCONTROL3 value);
}
member RegSetAOutputFieldID : Saa7118TYPIDTATASKHANDLINGCONTROL3 with get, set

Property Value

Type: Saa7118TYPIDTATASKHANDLINGCONTROL3
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAPrescalerOutputIsRenormalizedByGainFactor Property

IRD

Saa7118RegSetAPrescalerOutputIsRenormalizedByGainFactor Property

RegSet A: Prescaler output is renormalized by gain factor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL0 RegSetAPrescalerOutputIsRenormalizedByGainFactor { get; set; }
Public Property RegSetAPrescalerOutputIsRenormalizedByGainFactor As Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL0
    Get
    Set
public:
property Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL0 RegSetAPrescalerOutputIsRenormalizedByGainFactor {
    Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL0 get ();
    void set (Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL0 value);
}
member RegSetAPrescalerOutputIsRenormalizedByGainFactor : Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL0 with get, set

Property Value

Type: Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAReferenceEdgeForFieldDetection Property

IRD

Saa7118RegSetAReferenceEdgeForFieldDetection Property

RegSet A: Reference edge for field detection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS7 RegSetAReferenceEdgeForFieldDetection { get; set; }
Public Property RegSetAReferenceEdgeForFieldDetection As Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS7
    Get
    Set
public:
property Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS7 RegSetAReferenceEdgeForFieldDetection {
    Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS7 get ();
    void set (Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS7 value);
}
member RegSetAReferenceEdgeForFieldDetection : Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS7 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS7
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAReferenceSignals Property

IRD

Saa7118RegSetAReferenceSignals Property

RegSet A: Reference signals:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS3 RegSetAReferenceSignals { get; set; }
Public Property RegSetAReferenceSignals As Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS3
    Get
    Set
public:
property Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS3 RegSetAReferenceSignals {
    Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS3 get ();
    void set (Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS3 value);
}
member RegSetAReferenceSignals : Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS3 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS3
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetASamplingScheme Property

IRD

Saa7118RegSetASamplingScheme Property

RegSet A: Sampling scheme

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION0 RegSetASamplingScheme { get; set; }
Public Property RegSetASamplingScheme As Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION0
    Get
    Set
public:
property Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION0 RegSetASamplingScheme {
    Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION0 get ();
    void set (Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION0 value);
}
member RegSetASamplingScheme : Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION0 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetASAVEAVCodeBitD5VGate Property

IRD

Saa7118RegSetASAVEAVCodeBitD5VGate Property

RegSet A: SAV/EAV code bit D5 (V) gate

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION5 RegSetASAVEAVCodeBitD5VGate { get; set; }
Public Property RegSetASAVEAVCodeBitD5VGate As Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION5
    Get
    Set
public:
property Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION5 RegSetASAVEAVCodeBitD5VGate {
    Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION5 get ();
    void set (Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION5 value);
}
member RegSetASAVEAVCodeBitD5VGate : Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION5 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION5
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetASAVEAVCodeBitsD6AndD5FAndV Property

IRD

Saa7118RegSetASAVEAVCodeBitsD6AndD5FAndV Property

RegSet A: SAV/EAV code bits D6 and D5 (F and V)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION4 RegSetASAVEAVCodeBitsD6AndD5FAndV { get; set; }
Public Property RegSetASAVEAVCodeBitsD6AndD5FAndV As Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION4
    Get
    Set
public:
property Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION4 RegSetASAVEAVCodeBitsD6AndD5FAndV {
    Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION4 get ();
    void set (Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION4 value);
}
member RegSetASAVEAVCodeBitsD6AndD5FAndV : Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION4 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION4
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAScalerInputSource Property

IRD

Saa7118RegSetAScalerInputSource Property

RegSet A: Scaler input source:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION2 RegSetAScalerInputSource { get; set; }
Public Property RegSetAScalerInputSource As Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION2
    Get
    Set
public:
property Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION2 RegSetAScalerInputSource {
    Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION2 get ();
    void set (Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION2 value);
}
member RegSetAScalerInputSource : Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION2 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAScalerInputSource__1 Property

IRD

Saa7118RegSetAScalerInputSource__1 Property

RegSet A: Scaler input source

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION3 RegSetAScalerInputSource__1 { get; set; }
Public Property RegSetAScalerInputSource__1 As Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION3
    Get
    Set
public:
property Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION3 RegSetAScalerInputSource__1 {
    Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION3 get ();
    void set (Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION3 value);
}
member RegSetAScalerInputSource__1 : Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION3 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION3
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAScalerSAVEAVByte Property

IRD

Saa7118RegSetAScalerSAVEAVByte Property

RegSet A: Scaler SAV/EAV byte

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTATASKHANDLINGCONTROL4 RegSetAScalerSAVEAVByte { get; set; }
Public Property RegSetAScalerSAVEAVByte As Saa7118TYPIDTATASKHANDLINGCONTROL4
    Get
    Set
public:
property Saa7118TYPIDTATASKHANDLINGCONTROL4 RegSetAScalerSAVEAVByte {
    Saa7118TYPIDTATASKHANDLINGCONTROL4 get ();
    void set (Saa7118TYPIDTATASKHANDLINGCONTROL4 value);
}
member RegSetAScalerSAVEAVByte : Saa7118TYPIDTATASKHANDLINGCONTROL4 with get, set

Property Value

Type: Saa7118TYPIDTATASKHANDLINGCONTROL4
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetATaskHandlingControl Property

IRD

Saa7118RegSetATaskHandlingControl Property

RegSet A: Task handling control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTATASKHANDLINGCONTROL2 RegSetATaskHandlingControl { get; set; }
Public Property RegSetATaskHandlingControl As Saa7118TYPIDTATASKHANDLINGCONTROL2
    Get
    Set
public:
property Saa7118TYPIDTATASKHANDLINGCONTROL2 RegSetATaskHandlingControl {
    Saa7118TYPIDTATASKHANDLINGCONTROL2 get ();
    void set (Saa7118TYPIDTATASKHANDLINGCONTROL2 value);
}
member RegSetATaskHandlingControl : Saa7118TYPIDTATASKHANDLINGCONTROL2 with get, set

Property Value

Type: Saa7118TYPIDTATASKHANDLINGCONTROL2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAVerticalChrominancePhaseOffsetData32 Property

IRD

Saa7118RegSetAVerticalChrominancePhaseOffsetData32 Property

RegSet A: Vertical chrominance phase offset=[Data]/32

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 RegSetAVerticalChrominancePhaseOffsetData32 { get; set; }
Public Property RegSetAVerticalChrominancePhaseOffsetData32 As Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
    Get
    Set
public:
property Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 RegSetAVerticalChrominancePhaseOffsetData32 {
    Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 get ();
    void set (Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 value);
}
member RegSetAVerticalChrominancePhaseOffsetData32 : Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 with get, set

Property Value

Type: Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAVerticalChrominanceScalingIncrement Property

IRD

Saa7118RegSetAVerticalChrominanceScalingIncrement Property

RegSet A: Vertical chrominance scaling increment

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort RegSetAVerticalChrominanceScalingIncrement { get; set; }
Public Property RegSetAVerticalChrominanceScalingIncrement As UShort
    Get
    Set
public:
property unsigned short RegSetAVerticalChrominanceScalingIncrement {
    unsigned short get ();
    void set (unsigned short value);
}
member RegSetAVerticalChrominanceScalingIncrement : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAVerticalInputWindowLength Property

IRD

Saa7118RegSetAVerticalInputWindowLength Property

RegSet A: Vertical input window length

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAVERTICALINPUTWINDOWLENGTHL0 RegSetAVerticalInputWindowLength { get; set; }
Public Property RegSetAVerticalInputWindowLength As Saa7118TYPIDTAVERTICALINPUTWINDOWLENGTHL0
    Get
    Set
public:
property Saa7118TYPIDTAVERTICALINPUTWINDOWLENGTHL0 RegSetAVerticalInputWindowLength {
    Saa7118TYPIDTAVERTICALINPUTWINDOWLENGTHL0 get ();
    void set (Saa7118TYPIDTAVERTICALINPUTWINDOWLENGTHL0 value);
}
member RegSetAVerticalInputWindowLength : Saa7118TYPIDTAVERTICALINPUTWINDOWLENGTHL0 with get, set

Property Value

Type: Saa7118TYPIDTAVERTICALINPUTWINDOWLENGTHL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAVerticalInputWindowStart Property

IRD

Saa7118RegSetAVerticalInputWindowStart Property

RegSet A: Vertical input window start

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAVERTICALINPUTTWINDOWSTARTL0 RegSetAVerticalInputWindowStart { get; set; }
Public Property RegSetAVerticalInputWindowStart As Saa7118TYPIDTAVERTICALINPUTTWINDOWSTARTL0
    Get
    Set
public:
property Saa7118TYPIDTAVERTICALINPUTTWINDOWSTARTL0 RegSetAVerticalInputWindowStart {
    Saa7118TYPIDTAVERTICALINPUTTWINDOWSTARTL0 get ();
    void set (Saa7118TYPIDTAVERTICALINPUTTWINDOWSTARTL0 value);
}
member RegSetAVerticalInputWindowStart : Saa7118TYPIDTAVERTICALINPUTTWINDOWSTARTL0 with get, set

Property Value

Type: Saa7118TYPIDTAVERTICALINPUTTWINDOWSTARTL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAVerticalLuminancePhaseOffsetData32 Property

IRD

Saa7118RegSetAVerticalLuminancePhaseOffsetData32 Property

RegSet A: Vertical luminance phase offset=[Data]/32

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 RegSetAVerticalLuminancePhaseOffsetData32 { get; set; }
Public Property RegSetAVerticalLuminancePhaseOffsetData32 As Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
    Get
    Set
public:
property Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 RegSetAVerticalLuminancePhaseOffsetData32 {
    Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 get ();
    void set (Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 value);
}
member RegSetAVerticalLuminancePhaseOffsetData32 : Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 with get, set

Property Value

Type: Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAVerticalLuminanceScalingIncrementScale1024Data Property

IRD

Saa7118RegSetAVerticalLuminanceScalingIncrementScale1024Data Property

RegSet A: Vertical luminance scaling increment Scale=1024/[Data]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAVERTICALLUMINLINGINCREMENTL0 RegSetAVerticalLuminanceScalingIncrementScale1024Data { get; set; }
Public Property RegSetAVerticalLuminanceScalingIncrementScale1024Data As Saa7118TYPIDTAVERTICALLUMINLINGINCREMENTL0
    Get
    Set
public:
property Saa7118TYPIDTAVERTICALLUMINLINGINCREMENTL0 RegSetAVerticalLuminanceScalingIncrementScale1024Data {
    Saa7118TYPIDTAVERTICALLUMINLINGINCREMENTL0 get ();
    void set (Saa7118TYPIDTAVERTICALLUMINLINGINCREMENTL0 value);
}
member RegSetAVerticalLuminanceScalingIncrementScale1024Data : Saa7118TYPIDTAVERTICALLUMINLINGINCREMENTL0 with get, set

Property Value

Type: Saa7118TYPIDTAVERTICALLUMINLINGINCREMENTL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAVerticalOutputWindowLength Property

IRD

Saa7118RegSetAVerticalOutputWindowLength Property

RegSet A:Vertical output window length

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 RegSetAVerticalOutputWindowLength { get; set; }
Public Property RegSetAVerticalOutputWindowLength As Saa7118TYPIDTAVERTICALOUTPUWINDOWLENGTHL0
    Get
    Set
public:
property Saa7118TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 RegSetAVerticalOutputWindowLength {
    Saa7118TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 get ();
    void set (Saa7118TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 value);
}
member RegSetAVerticalOutputWindowLength : Saa7118TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 with get, set

Property Value

Type: Saa7118TYPIDTAVERTICALOUTPUWINDOWLENGTHL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAWeightingOfAllAccumulatedSamples Property

IRD

Saa7118RegSetAWeightingOfAllAccumulatedSamples Property

RegSet A: Weighting of all accumulated samples

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL1 RegSetAWeightingOfAllAccumulatedSamples { get; set; }
Public Property RegSetAWeightingOfAllAccumulatedSamples As Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL1
    Get
    Set
public:
property Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL1 RegSetAWeightingOfAllAccumulatedSamples {
    Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL1 get ();
    void set (Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL1 value);
}
member RegSetAWeightingOfAllAccumulatedSamples : Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL1 with get, set

Property Value

Type: Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAXCLK Property

IRD

Saa7118RegSetAXCLK Property

RegSet A: XCLK

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS0 RegSetAXCLK { get; set; }
Public Property RegSetAXCLK As Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS0
    Get
    Set
public:
property Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS0 RegSetAXCLK {
    Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS0 get ();
    void set (Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS0 value);
}
member RegSetAXCLK : Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS0 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAXPortFieldID Property

IRD

Saa7118RegSetAXPortFieldID Property

RegSet A: X port field ID

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS6 RegSetAXPortFieldID { get; set; }
Public Property RegSetAXPortFieldID As Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS6
    Get
    Set
public:
property Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS6 RegSetAXPortFieldID {
    Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS6 get ();
    void set (Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS6 value);
}
member RegSetAXPortFieldID : Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS6 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS6
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAXRV Property

IRD

Saa7118RegSetAXRV Property

RegSet A: XRV

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS5 RegSetAXRV { get; set; }
Public Property RegSetAXRV As Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS5
    Get
    Set
public:
property Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS5 RegSetAXRV {
    Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS5 get ();
    void set (Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS5 value);
}
member RegSetAXRV : Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS5 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS5
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAYMIR Property

IRD

Saa7118RegSetAYMIR Property

RegSet A: YMIR

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAVERTICALSCALINGMODECONTROL1 RegSetAYMIR { get; set; }
Public Property RegSetAYMIR As Saa7118TYPIDTAVERTICALSCALINGMODECONTROL1
    Get
    Set
public:
property Saa7118TYPIDTAVERTICALSCALINGMODECONTROL1 RegSetAYMIR {
    Saa7118TYPIDTAVERTICALSCALINGMODECONTROL1 get ();
    void set (Saa7118TYPIDTAVERTICALSCALINGMODECONTROL1 value);
}
member RegSetAYMIR : Saa7118TYPIDTAVERTICALSCALINGMODECONTROL1 with get, set

Property Value

Type: Saa7118TYPIDTAVERTICALSCALINGMODECONTROL1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetAYMODE Property

IRD

Saa7118RegSetAYMODE Property

RegSet A: YMODE

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAVERTICALSCALINGMODECONTROL0 RegSetAYMODE { get; set; }
Public Property RegSetAYMODE As Saa7118TYPIDTAVERTICALSCALINGMODECONTROL0
    Get
    Set
public:
property Saa7118TYPIDTAVERTICALSCALINGMODECONTROL0 RegSetAYMODE {
    Saa7118TYPIDTAVERTICALSCALINGMODECONTROL0 get ();
    void set (Saa7118TYPIDTAVERTICALSCALINGMODECONTROL0 value);
}
member RegSetAYMODE : Saa7118TYPIDTAVERTICALSCALINGMODECONTROL0 with get, set

Property Value

Type: Saa7118TYPIDTAVERTICALSCALINGMODECONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBAccumulationLength Property

IRD

Saa7118RegSetBAccumulationLength Property

RegSet B: Accumulation length

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetBAccumulationLength { get; set; }
Public Property RegSetBAccumulationLength As Byte
    Get
    Set
public:
property unsigned char RegSetBAccumulationLength {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetBAccumulationLength : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBChromaIsProvided Property

IRD

Saa7118RegSetBChromaIsProvided Property

RegSet B: Chroma is provided

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION1 RegSetBChromaIsProvided { get; set; }
Public Property RegSetBChromaIsProvided As Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION1
    Get
    Set
public:
property Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION1 RegSetBChromaIsProvided {
    Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION1 get ();
    void set (Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION1 value);
}
member RegSetBChromaIsProvided : Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION1 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBChrominanceFIRFilter Property

IRD

Saa7118RegSetBChrominanceFIRFilter Property

RegSet B: Chrominance FIR filter

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL3 RegSetBChrominanceFIRFilter { get; set; }
Public Property RegSetBChrominanceFIRFilter As Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL3
    Get
    Set
public:
property Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL3 RegSetBChrominanceFIRFilter {
    Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL3 get ();
    void set (Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL3 value);
}
member RegSetBChrominanceFIRFilter : Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL3 with get, set

Property Value

Type: Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL3
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBDataQualified Property

IRD

Saa7118RegSetBDataQualified Property

RegSet B: Data qualified:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS1 RegSetBDataQualified { get; set; }
Public Property RegSetBDataQualified As Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS1
    Get
    Set
public:
property Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS1 RegSetBDataQualified {
    Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS1 get ();
    void set (Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS1 value);
}
member RegSetBDataQualified : Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS1 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBDwordsTransferred Property

IRD

Saa7118RegSetBDwordsTransferred Property

RegSet B: Dwords transferred

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION3 RegSetBDwordsTransferred { get; set; }
Public Property RegSetBDwordsTransferred As Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION3
    Get
    Set
public:
property Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION3 RegSetBDwordsTransferred {
    Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION3 get ();
    void set (Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION3 value);
}
member RegSetBDwordsTransferred : Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION3 with get, set

Property Value

Type: Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION3
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBEdgeOfXRHInputIsHorizontalReference Property

IRD

Saa7118RegSetBEdgeOfXRHInputIsHorizontalReference Property

RegSet B: Edge of XRH input is horizontal reference

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS2 RegSetBEdgeOfXRHInputIsHorizontalReference { get; set; }
Public Property RegSetBEdgeOfXRHInputIsHorizontalReference As Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS2
    Get
    Set
public:
property Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS2 RegSetBEdgeOfXRHInputIsHorizontalReference {
    Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS2 get ();
    void set (Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS2 value);
}
member RegSetBEdgeOfXRHInputIsHorizontalReference : Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS2 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBEdgeOfXRVInputAndDecoderV123IsVerticalReference Property

IRD

Saa7118RegSetBEdgeOfXRVInputAndDecoderV123IsVerticalReference Property

RegSet B: Edge of XRV input and decoder V123 is vertical reference:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS4 RegSetBEdgeOfXRVInputAndDecoderV123IsVerticalReference { get; set; }
Public Property RegSetBEdgeOfXRVInputAndDecoderV123IsVerticalReference As Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS4
    Get
    Set
public:
property Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS4 RegSetBEdgeOfXRVInputAndDecoderV123IsVerticalReference {
    Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS4 get ();
    void set (Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS4 value);
}
member RegSetBEdgeOfXRVInputAndDecoderV123IsVerticalReference : Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS4 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS4
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBEventHandlerTriggers Property

IRD

Saa7118RegSetBEventHandlerTriggers Property

RegSet B: Event handler triggers

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTATASKHANDLINGCONTROL0 RegSetBEventHandlerTriggers { get; set; }
Public Property RegSetBEventHandlerTriggers As Saa7118TYPIDTATASKHANDLINGCONTROL0
    Get
    Set
public:
property Saa7118TYPIDTATASKHANDLINGCONTROL0 RegSetBEventHandlerTriggers {
    Saa7118TYPIDTATASKHANDLINGCONTROL0 get ();
    void set (Saa7118TYPIDTATASKHANDLINGCONTROL0 value);
}
member RegSetBEventHandlerTriggers : Saa7118TYPIDTATASKHANDLINGCONTROL0 with get, set

Property Value

Type: Saa7118TYPIDTATASKHANDLINGCONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBFormat Property

IRD

Saa7118RegSetBFormat Property

RegSet B: Format

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION0 RegSetBFormat { get; set; }
Public Property RegSetBFormat As Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION0
    Get
    Set
public:
property Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION0 RegSetBFormat {
    Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION0 get ();
    void set (Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION0 value);
}
member RegSetBFormat : Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION0 with get, set

Property Value

Type: Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBGain Property

IRD

Saa7118RegSetBGain Property

RegSet B: Gain

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 RegSetBGain { get; set; }
Public Property RegSetBGain As Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0
    Get
    Set
public:
property Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 RegSetBGain {
    Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 get ();
    void set (Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 value);
}
member RegSetBGain : Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 with get, set

Property Value

Type: Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBHorizontalChrominancePhaseOffset Property

IRD

Saa7118RegSetBHorizontalChrominancePhaseOffset Property

RegSet B: Horizontal chrominance phase offset

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetBHorizontalChrominancePhaseOffset { get; set; }
Public Property RegSetBHorizontalChrominancePhaseOffset As Byte
    Get
    Set
public:
property unsigned char RegSetBHorizontalChrominancePhaseOffset {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetBHorizontalChrominancePhaseOffset : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBHorizontalChrominanceScalingIncrement Property

IRD

Saa7118RegSetBHorizontalChrominanceScalingIncrement Property

RegSet B: Horizontal chrominance scaling increment

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort RegSetBHorizontalChrominanceScalingIncrement { get; set; }
Public Property RegSetBHorizontalChrominanceScalingIncrement As UShort
    Get
    Set
public:
property unsigned short RegSetBHorizontalChrominanceScalingIncrement {
    unsigned short get ();
    void set (unsigned short value);
}
member RegSetBHorizontalChrominanceScalingIncrement : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBHorizontalInputWindowLength Property

IRD

Saa7118RegSetBHorizontalInputWindowLength Property

RegSet B: Horizontal input window length

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0 RegSetBHorizontalInputWindowLength { get; set; }
Public Property RegSetBHorizontalInputWindowLength As Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0
    Get
    Set
public:
property Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0 RegSetBHorizontalInputWindowLength {
    Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0 get ();
    void set (Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0 value);
}
member RegSetBHorizontalInputWindowLength : Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0 with get, set

Property Value

Type: Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBHorizontalInputWindowStart Property

IRD

Saa7118RegSetBHorizontalInputWindowStart Property

RegSet B: Horizontal input window start

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0 RegSetBHorizontalInputWindowStart { get; set; }
Public Property RegSetBHorizontalInputWindowStart As Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0
    Get
    Set
public:
property Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0 RegSetBHorizontalInputWindowStart {
    Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0 get ();
    void set (Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0 value);
}
member RegSetBHorizontalInputWindowStart : Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0 with get, set

Property Value

Type: Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBHorizontalLuminancePhaseOffset Property

IRD

Saa7118RegSetBHorizontalLuminancePhaseOffset Property

RegSet B: Horizontal luminance phase offset (unit: Pixel)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 RegSetBHorizontalLuminancePhaseOffset { get; set; }
Public Property RegSetBHorizontalLuminancePhaseOffset As Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
    Get
    Set
public:
property Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 RegSetBHorizontalLuminancePhaseOffset {
    Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 get ();
    void set (Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 value);
}
member RegSetBHorizontalLuminancePhaseOffset : Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 with get, set

Property Value

Type: Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBHorizontalLuminanceScalingIncrementScale1024Data Property

IRD

Saa7118RegSetBHorizontalLuminanceScalingIncrementScale1024Data Property

RegSet B: Horizontal luminance scaling increment Scale=1024/[Data]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTBHORIZONTALLUMLINGINCREMENTL0 RegSetBHorizontalLuminanceScalingIncrementScale1024Data { get; set; }
Public Property RegSetBHorizontalLuminanceScalingIncrementScale1024Data As Saa7118TYPIDTBHORIZONTALLUMLINGINCREMENTL0
    Get
    Set
public:
property Saa7118TYPIDTBHORIZONTALLUMLINGINCREMENTL0 RegSetBHorizontalLuminanceScalingIncrementScale1024Data {
    Saa7118TYPIDTBHORIZONTALLUMLINGINCREMENTL0 get ();
    void set (Saa7118TYPIDTBHORIZONTALLUMLINGINCREMENTL0 value);
}
member RegSetBHorizontalLuminanceScalingIncrementScale1024Data : Saa7118TYPIDTBHORIZONTALLUMLINGINCREMENTL0 with get, set

Property Value

Type: Saa7118TYPIDTBHORIZONTALLUMLINGINCREMENTL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBHorizontalOutputWindowLength Property

IRD

Saa7118RegSetBHorizontalOutputWindowLength Property

RegSet B:Horizontal output window length

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 RegSetBHorizontalOutputWindowLength { get; set; }
Public Property RegSetBHorizontalOutputWindowLength As Saa7118TYPIDTAHORIZONTALOUTWINDOWLENGTHL0
    Get
    Set
public:
property Saa7118TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 RegSetBHorizontalOutputWindowLength {
    Saa7118TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 get ();
    void set (Saa7118TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 value);
}
member RegSetBHorizontalOutputWindowLength : Saa7118TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 with get, set

Property Value

Type: Saa7118TYPIDTAHORIZONTALOUTWINDOWLENGTHL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBHorizontalPrescaling Property

IRD

Saa7118RegSetBHorizontalPrescaling Property

RegSet B: Horizontal prescaling

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAHORIZONTALPRESCALING0 RegSetBHorizontalPrescaling { get; set; }
Public Property RegSetBHorizontalPrescaling As Saa7118TYPIDTAHORIZONTALPRESCALING0
    Get
    Set
public:
property Saa7118TYPIDTAHORIZONTALPRESCALING0 RegSetBHorizontalPrescaling {
    Saa7118TYPIDTAHORIZONTALPRESCALING0 get ();
    void set (Saa7118TYPIDTAHORIZONTALPRESCALING0 value);
}
member RegSetBHorizontalPrescaling : Saa7118TYPIDTAHORIZONTALPRESCALING0 with get, set

Property Value

Type: Saa7118TYPIDTAHORIZONTALPRESCALING0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBITU656 Property

IRD

Saa7118RegSetBITU656 Property

RegSet B: ITU 656

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION4 RegSetBITU656 { get; set; }
Public Property RegSetBITU656 As Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION4
    Get
    Set
public:
property Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION4 RegSetBITU656 {
    Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION4 get ();
    void set (Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION4 value);
}
member RegSetBITU656 : Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION4 with get, set

Property Value

Type: Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION4
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBLeadingLinesBefore1stYCBCRLineIsOutput Property

IRD

Saa7118RegSetBLeadingLinesBefore1stYCBCRLineIsOutput Property

RegSet B: Leading lines before 1st Y + CB-CR line is output

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION1 RegSetBLeadingLinesBefore1stYCBCRLineIsOutput { get; set; }
Public Property RegSetBLeadingLinesBefore1stYCBCRLineIsOutput As Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION1
    Get
    Set
public:
property Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION1 RegSetBLeadingLinesBefore1stYCBCRLineIsOutput {
    Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION1 get ();
    void set (Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION1 value);
}
member RegSetBLeadingLinesBefore1stYCBCRLineIsOutput : Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION1 with get, set

Property Value

Type: Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBLinesOutput Property

IRD

Saa7118RegSetBLinesOutput Property

RegSet B: Lines output

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION2 RegSetBLinesOutput { get; set; }
Public Property RegSetBLinesOutput As Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION2
    Get
    Set
public:
property Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION2 RegSetBLinesOutput {
    Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION2 get ();
    void set (Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION2 value);
}
member RegSetBLinesOutput : Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION2 with get, set

Property Value

Type: Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBLuminanceBrightnessControl Property

IRD

Saa7118RegSetBLuminanceBrightnessControl Property

RegSet B: Luminance brightness control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTALUMINANCEBRIGGHTNESSCONTROL0 RegSetBLuminanceBrightnessControl { get; set; }
Public Property RegSetBLuminanceBrightnessControl As Saa7118TYPIDTALUMINANCEBRIGGHTNESSCONTROL0
    Get
    Set
public:
property Saa7118TYPIDTALUMINANCEBRIGGHTNESSCONTROL0 RegSetBLuminanceBrightnessControl {
    Saa7118TYPIDTALUMINANCEBRIGGHTNESSCONTROL0 get ();
    void set (Saa7118TYPIDTALUMINANCEBRIGGHTNESSCONTROL0 value);
}
member RegSetBLuminanceBrightnessControl : Saa7118TYPIDTALUMINANCEBRIGGHTNESSCONTROL0 with get, set

Property Value

Type: Saa7118TYPIDTALUMINANCEBRIGGHTNESSCONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBLuminanceContrastControl Property

IRD

Saa7118RegSetBLuminanceContrastControl Property

RegSet B: Luminance contrast control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 RegSetBLuminanceContrastControl { get; set; }
Public Property RegSetBLuminanceContrastControl As Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0
    Get
    Set
public:
property Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 RegSetBLuminanceContrastControl {
    Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 get ();
    void set (Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 value);
}
member RegSetBLuminanceContrastControl : Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 with get, set

Property Value

Type: Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBLuminanceFIRFilter Property

IRD

Saa7118RegSetBLuminanceFIRFilter Property

RegSet B: Luminance FIR filter

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL2 RegSetBLuminanceFIRFilter { get; set; }
Public Property RegSetBLuminanceFIRFilter As Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL2
    Get
    Set
public:
property Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL2 RegSetBLuminanceFIRFilter {
    Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL2 get ();
    void set (Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL2 value);
}
member RegSetBLuminanceFIRFilter : Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL2 with get, set

Property Value

Type: Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBNextTask Property

IRD

Saa7118RegSetBNextTask Property

RegSet B: Next task

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTATASKHANDLINGCONTROL1 RegSetBNextTask { get; set; }
Public Property RegSetBNextTask As Saa7118TYPIDTATASKHANDLINGCONTROL1
    Get
    Set
public:
property Saa7118TYPIDTATASKHANDLINGCONTROL1 RegSetBNextTask {
    Saa7118TYPIDTATASKHANDLINGCONTROL1 get ();
    void set (Saa7118TYPIDTATASKHANDLINGCONTROL1 value);
}
member RegSetBNextTask : Saa7118TYPIDTATASKHANDLINGCONTROL1 with get, set

Property Value

Type: Saa7118TYPIDTATASKHANDLINGCONTROL1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBOutputFieldID Property

IRD

Saa7118RegSetBOutputFieldID Property

RegSet B: Output field ID

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTATASKHANDLINGCONTROL3 RegSetBOutputFieldID { get; set; }
Public Property RegSetBOutputFieldID As Saa7118TYPIDTATASKHANDLINGCONTROL3
    Get
    Set
public:
property Saa7118TYPIDTATASKHANDLINGCONTROL3 RegSetBOutputFieldID {
    Saa7118TYPIDTATASKHANDLINGCONTROL3 get ();
    void set (Saa7118TYPIDTATASKHANDLINGCONTROL3 value);
}
member RegSetBOutputFieldID : Saa7118TYPIDTATASKHANDLINGCONTROL3 with get, set

Property Value

Type: Saa7118TYPIDTATASKHANDLINGCONTROL3
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBPrescalerOutputIsRenormalizedByGainFactor Property

IRD

Saa7118RegSetBPrescalerOutputIsRenormalizedByGainFactor Property

RegSet B: Prescaler output is renormalized by gain factor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL0 RegSetBPrescalerOutputIsRenormalizedByGainFactor { get; set; }
Public Property RegSetBPrescalerOutputIsRenormalizedByGainFactor As Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL0
    Get
    Set
public:
property Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL0 RegSetBPrescalerOutputIsRenormalizedByGainFactor {
    Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL0 get ();
    void set (Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL0 value);
}
member RegSetBPrescalerOutputIsRenormalizedByGainFactor : Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL0 with get, set

Property Value

Type: Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBReferenceEdgeForFieldDetection Property

IRD

Saa7118RegSetBReferenceEdgeForFieldDetection Property

RegSet B: Reference edge for field detection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS7 RegSetBReferenceEdgeForFieldDetection { get; set; }
Public Property RegSetBReferenceEdgeForFieldDetection As Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS7
    Get
    Set
public:
property Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS7 RegSetBReferenceEdgeForFieldDetection {
    Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS7 get ();
    void set (Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS7 value);
}
member RegSetBReferenceEdgeForFieldDetection : Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS7 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS7
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBReferenceSignals Property

IRD

Saa7118RegSetBReferenceSignals Property

RegSet B: Reference signals:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS3 RegSetBReferenceSignals { get; set; }
Public Property RegSetBReferenceSignals As Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS3
    Get
    Set
public:
property Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS3 RegSetBReferenceSignals {
    Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS3 get ();
    void set (Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS3 value);
}
member RegSetBReferenceSignals : Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS3 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS3
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBSamplingScheme Property

IRD

Saa7118RegSetBSamplingScheme Property

RegSet B: Sampling scheme

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION0 RegSetBSamplingScheme { get; set; }
Public Property RegSetBSamplingScheme As Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION0
    Get
    Set
public:
property Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION0 RegSetBSamplingScheme {
    Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION0 get ();
    void set (Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION0 value);
}
member RegSetBSamplingScheme : Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION0 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBSAVEAVCodeBitD5VGate Property

IRD

Saa7118RegSetBSAVEAVCodeBitD5VGate Property

RegSet B: SAV/EAV code bit D5 (V) gate

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION5 RegSetBSAVEAVCodeBitD5VGate { get; set; }
Public Property RegSetBSAVEAVCodeBitD5VGate As Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION5
    Get
    Set
public:
property Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION5 RegSetBSAVEAVCodeBitD5VGate {
    Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION5 get ();
    void set (Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION5 value);
}
member RegSetBSAVEAVCodeBitD5VGate : Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION5 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION5
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBSAVEAVCodeBitsD6AndD5FAndV Property

IRD

Saa7118RegSetBSAVEAVCodeBitsD6AndD5FAndV Property

RegSet B: SAV/EAV code bits D6 and D5 (F and V)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION4 RegSetBSAVEAVCodeBitsD6AndD5FAndV { get; set; }
Public Property RegSetBSAVEAVCodeBitsD6AndD5FAndV As Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION4
    Get
    Set
public:
property Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION4 RegSetBSAVEAVCodeBitsD6AndD5FAndV {
    Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION4 get ();
    void set (Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION4 value);
}
member RegSetBSAVEAVCodeBitsD6AndD5FAndV : Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION4 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION4
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBScalerInputSource Property

IRD

Saa7118RegSetBScalerInputSource Property

RegSet B: Scaler input source:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION2 RegSetBScalerInputSource { get; set; }
Public Property RegSetBScalerInputSource As Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION2
    Get
    Set
public:
property Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION2 RegSetBScalerInputSource {
    Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION2 get ();
    void set (Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION2 value);
}
member RegSetBScalerInputSource : Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION2 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBScalerInputSource__1 Property

IRD

Saa7118RegSetBScalerInputSource__1 Property

RegSet B: Scaler input source

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION3 RegSetBScalerInputSource__1 { get; set; }
Public Property RegSetBScalerInputSource__1 As Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION3
    Get
    Set
public:
property Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION3 RegSetBScalerInputSource__1 {
    Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION3 get ();
    void set (Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION3 value);
}
member RegSetBScalerInputSource__1 : Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION3 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION3
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBScalerSAVEAVByte Property

IRD

Saa7118RegSetBScalerSAVEAVByte Property

RegSet B: Scaler SAV/EAV byte

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTATASKHANDLINGCONTROL4 RegSetBScalerSAVEAVByte { get; set; }
Public Property RegSetBScalerSAVEAVByte As Saa7118TYPIDTATASKHANDLINGCONTROL4
    Get
    Set
public:
property Saa7118TYPIDTATASKHANDLINGCONTROL4 RegSetBScalerSAVEAVByte {
    Saa7118TYPIDTATASKHANDLINGCONTROL4 get ();
    void set (Saa7118TYPIDTATASKHANDLINGCONTROL4 value);
}
member RegSetBScalerSAVEAVByte : Saa7118TYPIDTATASKHANDLINGCONTROL4 with get, set

Property Value

Type: Saa7118TYPIDTATASKHANDLINGCONTROL4
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBTaskHandlingControl Property

IRD

Saa7118RegSetBTaskHandlingControl Property

RegSet B: Task handling control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTATASKHANDLINGCONTROL2 RegSetBTaskHandlingControl { get; set; }
Public Property RegSetBTaskHandlingControl As Saa7118TYPIDTATASKHANDLINGCONTROL2
    Get
    Set
public:
property Saa7118TYPIDTATASKHANDLINGCONTROL2 RegSetBTaskHandlingControl {
    Saa7118TYPIDTATASKHANDLINGCONTROL2 get ();
    void set (Saa7118TYPIDTATASKHANDLINGCONTROL2 value);
}
member RegSetBTaskHandlingControl : Saa7118TYPIDTATASKHANDLINGCONTROL2 with get, set

Property Value

Type: Saa7118TYPIDTATASKHANDLINGCONTROL2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBVerticalChrominancePhaseOffsetData32 Property

IRD

Saa7118RegSetBVerticalChrominancePhaseOffsetData32 Property

RegSet B: Vertical chrominance phase offset=[Data]/32

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 RegSetBVerticalChrominancePhaseOffsetData32 { get; set; }
Public Property RegSetBVerticalChrominancePhaseOffsetData32 As Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
    Get
    Set
public:
property Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 RegSetBVerticalChrominancePhaseOffsetData32 {
    Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 get ();
    void set (Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 value);
}
member RegSetBVerticalChrominancePhaseOffsetData32 : Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 with get, set

Property Value

Type: Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBVerticalChrominanceScalingIncrement Property

IRD

Saa7118RegSetBVerticalChrominanceScalingIncrement Property

RegSet B: Vertical chrominance scaling increment

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort RegSetBVerticalChrominanceScalingIncrement { get; set; }
Public Property RegSetBVerticalChrominanceScalingIncrement As UShort
    Get
    Set
public:
property unsigned short RegSetBVerticalChrominanceScalingIncrement {
    unsigned short get ();
    void set (unsigned short value);
}
member RegSetBVerticalChrominanceScalingIncrement : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBVerticalInputWindowLength Property

IRD

Saa7118RegSetBVerticalInputWindowLength Property

RegSet B: Vertical input window length

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAVERTICALINPUTWINDOWLENGTHL0 RegSetBVerticalInputWindowLength { get; set; }
Public Property RegSetBVerticalInputWindowLength As Saa7118TYPIDTAVERTICALINPUTWINDOWLENGTHL0
    Get
    Set
public:
property Saa7118TYPIDTAVERTICALINPUTWINDOWLENGTHL0 RegSetBVerticalInputWindowLength {
    Saa7118TYPIDTAVERTICALINPUTWINDOWLENGTHL0 get ();
    void set (Saa7118TYPIDTAVERTICALINPUTWINDOWLENGTHL0 value);
}
member RegSetBVerticalInputWindowLength : Saa7118TYPIDTAVERTICALINPUTWINDOWLENGTHL0 with get, set

Property Value

Type: Saa7118TYPIDTAVERTICALINPUTWINDOWLENGTHL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBVerticalInputWindowStart Property

IRD

Saa7118RegSetBVerticalInputWindowStart Property

RegSet B: Vertical input window start

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAVERTICALINPUTTWINDOWSTARTL0 RegSetBVerticalInputWindowStart { get; set; }
Public Property RegSetBVerticalInputWindowStart As Saa7118TYPIDTAVERTICALINPUTTWINDOWSTARTL0
    Get
    Set
public:
property Saa7118TYPIDTAVERTICALINPUTTWINDOWSTARTL0 RegSetBVerticalInputWindowStart {
    Saa7118TYPIDTAVERTICALINPUTTWINDOWSTARTL0 get ();
    void set (Saa7118TYPIDTAVERTICALINPUTTWINDOWSTARTL0 value);
}
member RegSetBVerticalInputWindowStart : Saa7118TYPIDTAVERTICALINPUTTWINDOWSTARTL0 with get, set

Property Value

Type: Saa7118TYPIDTAVERTICALINPUTTWINDOWSTARTL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBVerticalLuminancePhaseOffsetData32 Property

IRD

Saa7118RegSetBVerticalLuminancePhaseOffsetData32 Property

RegSet B: Vertical luminance phase offset=[Data]/32

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 RegSetBVerticalLuminancePhaseOffsetData32 { get; set; }
Public Property RegSetBVerticalLuminancePhaseOffsetData32 As Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
    Get
    Set
public:
property Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 RegSetBVerticalLuminancePhaseOffsetData32 {
    Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 get ();
    void set (Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 value);
}
member RegSetBVerticalLuminancePhaseOffsetData32 : Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 with get, set

Property Value

Type: Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBVerticalLuminanceScalingIncrementScale1024Data Property

IRD

Saa7118RegSetBVerticalLuminanceScalingIncrementScale1024Data Property

RegSet B: Vertical luminance scaling increment Scale=1024/[Data]

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTBVERTICALLUMINLINGINCREMENTL0 RegSetBVerticalLuminanceScalingIncrementScale1024Data { get; set; }
Public Property RegSetBVerticalLuminanceScalingIncrementScale1024Data As Saa7118TYPIDTBVERTICALLUMINLINGINCREMENTL0
    Get
    Set
public:
property Saa7118TYPIDTBVERTICALLUMINLINGINCREMENTL0 RegSetBVerticalLuminanceScalingIncrementScale1024Data {
    Saa7118TYPIDTBVERTICALLUMINLINGINCREMENTL0 get ();
    void set (Saa7118TYPIDTBVERTICALLUMINLINGINCREMENTL0 value);
}
member RegSetBVerticalLuminanceScalingIncrementScale1024Data : Saa7118TYPIDTBVERTICALLUMINLINGINCREMENTL0 with get, set

Property Value

Type: Saa7118TYPIDTBVERTICALLUMINLINGINCREMENTL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBVerticalOutputWindowLength Property

IRD

Saa7118RegSetBVerticalOutputWindowLength Property

RegSet B:Vertical output window length

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 RegSetBVerticalOutputWindowLength { get; set; }
Public Property RegSetBVerticalOutputWindowLength As Saa7118TYPIDTAVERTICALOUTPUWINDOWLENGTHL0
    Get
    Set
public:
property Saa7118TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 RegSetBVerticalOutputWindowLength {
    Saa7118TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 get ();
    void set (Saa7118TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 value);
}
member RegSetBVerticalOutputWindowLength : Saa7118TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 with get, set

Property Value

Type: Saa7118TYPIDTAVERTICALOUTPUWINDOWLENGTHL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBWeightingOfAllAccumulatedSamples Property

IRD

Saa7118RegSetBWeightingOfAllAccumulatedSamples Property

RegSet B: Weighting of all accumulated samples

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL1 RegSetBWeightingOfAllAccumulatedSamples { get; set; }
Public Property RegSetBWeightingOfAllAccumulatedSamples As Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL1
    Get
    Set
public:
property Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL1 RegSetBWeightingOfAllAccumulatedSamples {
    Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL1 get ();
    void set (Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL1 value);
}
member RegSetBWeightingOfAllAccumulatedSamples : Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL1 with get, set

Property Value

Type: Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBXCLK Property

IRD

Saa7118RegSetBXCLK Property

RegSet B: XCLK

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS0 RegSetBXCLK { get; set; }
Public Property RegSetBXCLK As Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS0
    Get
    Set
public:
property Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS0 RegSetBXCLK {
    Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS0 get ();
    void set (Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS0 value);
}
member RegSetBXCLK : Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS0 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBXPortFieldID Property

IRD

Saa7118RegSetBXPortFieldID Property

RegSet B: X port field ID

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS6 RegSetBXPortFieldID { get; set; }
Public Property RegSetBXPortFieldID As Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS6
    Get
    Set
public:
property Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS6 RegSetBXPortFieldID {
    Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS6 get ();
    void set (Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS6 value);
}
member RegSetBXPortFieldID : Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS6 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS6
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBXRV Property

IRD

Saa7118RegSetBXRV Property

RegSet B: XRV

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS5 RegSetBXRV { get; set; }
Public Property RegSetBXRV As Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS5
    Get
    Set
public:
property Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS5 RegSetBXRV {
    Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS5 get ();
    void set (Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS5 value);
}
member RegSetBXRV : Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS5 with get, set

Property Value

Type: Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS5
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBYMIR Property

IRD

Saa7118RegSetBYMIR Property

RegSet B: YMIR

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAVERTICALSCALINGMODECONTROL1 RegSetBYMIR { get; set; }
Public Property RegSetBYMIR As Saa7118TYPIDTAVERTICALSCALINGMODECONTROL1
    Get
    Set
public:
property Saa7118TYPIDTAVERTICALSCALINGMODECONTROL1 RegSetBYMIR {
    Saa7118TYPIDTAVERTICALSCALINGMODECONTROL1 get ();
    void set (Saa7118TYPIDTAVERTICALSCALINGMODECONTROL1 value);
}
member RegSetBYMIR : Saa7118TYPIDTAVERTICALSCALINGMODECONTROL1 with get, set

Property Value

Type: Saa7118TYPIDTAVERTICALSCALINGMODECONTROL1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RegSetBYMODE Property

IRD

Saa7118RegSetBYMODE Property

RegSet B: YMODE

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDTAVERTICALSCALINGMODECONTROL0 RegSetBYMODE { get; set; }
Public Property RegSetBYMODE As Saa7118TYPIDTAVERTICALSCALINGMODECONTROL0
    Get
    Set
public:
property Saa7118TYPIDTAVERTICALSCALINGMODECONTROL0 RegSetBYMODE {
    Saa7118TYPIDTAVERTICALSCALINGMODECONTROL0 get ();
    void set (Saa7118TYPIDTAVERTICALSCALINGMODECONTROL0 value);
}
member RegSetBYMODE : Saa7118TYPIDTAVERTICALSCALINGMODECONTROL0 with get, set

Property Value

Type: Saa7118TYPIDTAVERTICALSCALINGMODECONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RemodulationBandwidthForLuminance Property

IRD

Saa7118RemodulationBandwidthForLuminance Property

Remodulation bandwidth for luminance

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLUMINANCECONTROL1 RemodulationBandwidthForLuminance { get; set; }
Public Property RemodulationBandwidthForLuminance As Saa7118TYPIDLUMINANCECONTROL1
    Get
    Set
public:
property Saa7118TYPIDLUMINANCECONTROL1 RemodulationBandwidthForLuminance {
    Saa7118TYPIDLUMINANCECONTROL1 get ();
    void set (Saa7118TYPIDLUMINANCECONTROL1 value);
}
member RemodulationBandwidthForLuminance : Saa7118TYPIDLUMINANCECONTROL1 with get, set

Property Value

Type: Saa7118TYPIDLUMINANCECONTROL1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RTCOOutputEnable Property

IRD

Saa7118RTCOOutputEnable Property

RTCO output enable

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDRTXPORTOUTPUTCONTROL4 RTCOOutputEnable { get; set; }
Public Property RTCOOutputEnable As Saa7118TYPIDRTXPORTOUTPUTCONTROL4
    Get
    Set
public:
property Saa7118TYPIDRTXPORTOUTPUTCONTROL4 RTCOOutputEnable {
    Saa7118TYPIDRTXPORTOUTPUTCONTROL4 get ();
    void set (Saa7118TYPIDRTXPORTOUTPUTCONTROL4 value);
}
member RTCOOutputEnable : Saa7118TYPIDRTXPORTOUTPUTCONTROL4 with get, set

Property Value

Type: Saa7118TYPIDRTXPORTOUTPUTCONTROL4
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RTSignalControlRTS0Output Property

IRD

Saa7118RTSignalControlRTS0Output Property

RT signal control: RTS0 output

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 RTSignalControlRTS0Output { get; set; }
Public Property RTSignalControlRTS0Output As Saa7118TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0
    Get
    Set
public:
property Saa7118TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 RTSignalControlRTS0Output {
    Saa7118TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 get ();
    void set (Saa7118TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 value);
}
member RTSignalControlRTS0Output : Saa7118TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 with get, set

Property Value

Type: Saa7118TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.RTSignalControlRTS1Output Property

IRD

Saa7118RTSignalControlRTS1Output Property

RT signal control: RTS1 output

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 RTSignalControlRTS1Output { get; set; }
Public Property RTSignalControlRTS1Output As Saa7118TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0
    Get
    Set
public:
property Saa7118TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 RTSignalControlRTS1Output {
    Saa7118TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 get ();
    void set (Saa7118TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 value);
}
member RTSignalControlRTS1Output : Saa7118TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 with get, set

Property Value

Type: Saa7118TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.Scaler Property

IRD

Saa7118Scaler Property

Scaler

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL0 Scaler { get; set; }
Public Property Scaler As Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL0
    Get
    Set
public:
property Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL0 Scaler {
    Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL0 get ();
    void set (Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL0 value);
}
member Scaler : Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL0 with get, set

Property Value

Type: Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.SDIDCodes Property

IRD

Saa7118SDIDCodes Property

SDID codes

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SDIDCodes { get; set; }
Public Property SDIDCodes As Byte
    Get
    Set
public:
property unsigned char SDIDCodes {
    unsigned char get ();
    void set (unsigned char value);
}
member SDIDCodes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.SharpnessControl Property

IRD

Saa7118SharpnessControl Property

Sharpness control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDLUMINANCECONTROL0 SharpnessControl { get; set; }
Public Property SharpnessControl As Saa7118TYPIDLUMINANCECONTROL0
    Get
    Set
public:
property Saa7118TYPIDLUMINANCECONTROL0 SharpnessControl {
    Saa7118TYPIDLUMINANCECONTROL0 get ();
    void set (Saa7118TYPIDLUMINANCECONTROL0 value);
}
member SharpnessControl : Saa7118TYPIDLUMINANCECONTROL0 with get, set

Property Value

Type: Saa7118TYPIDLUMINANCECONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.SlowTimeConstantActiveInWIPAMode Property

IRD

Saa7118SlowTimeConstantActiveInWIPAMode Property

Slow time constant active in WIPA mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDNotActiveActive SlowTimeConstantActiveInWIPAMode { get; }
Public ReadOnly Property SlowTimeConstantActiveInWIPAMode As Saa7118IDNotActiveActive
    Get
public:
property Saa7118IDNotActiveActive SlowTimeConstantActiveInWIPAMode {
    Saa7118IDNotActiveActive get ();
}
member SlowTimeConstantActiveInWIPAMode : Saa7118IDNotActiveActive with get

Property Value

Type: Saa7118IDNotActiveActive
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.SpecialCasesOfDIDProgramming Property

IRD

Saa7118SpecialCasesOfDIDProgramming Property

Special cases of DID programming

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SpecialCasesOfDIDProgramming { get; set; }
Public Property SpecialCasesOfDIDProgramming As Byte
    Get
    Set
public:
property unsigned char SpecialCasesOfDIDProgramming {
    unsigned char get ();
    void set (unsigned char value);
}
member SpecialCasesOfDIDProgramming : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.StandardDetectionSearchLoopLatency Property

IRD

Saa7118StandardDetectionSearchLoopLatency Property

Standard detection search loop latency

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDMISCELLANEOUSVGATEMSBS1 StandardDetectionSearchLoopLatency { get; set; }
Public Property StandardDetectionSearchLoopLatency As Saa7118TYPIDMISCELLANEOUSVGATEMSBS1
    Get
    Set
public:
property Saa7118TYPIDMISCELLANEOUSVGATEMSBS1 StandardDetectionSearchLoopLatency {
    Saa7118TYPIDMISCELLANEOUSVGATEMSBS1 get ();
    void set (Saa7118TYPIDMISCELLANEOUSVGATEMSBS1 value);
}
member StandardDetectionSearchLoopLatency : Saa7118TYPIDMISCELLANEOUSVGATEMSBS1 with get, set

Property Value

Type: Saa7118TYPIDMISCELLANEOUSVGATEMSBS1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.StatusBitForHorizontalAndVerticalLoop Property

IRD

Saa7118StatusBitForHorizontalAndVerticalLoop Property

Status bit for horizontal and vertical loop

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSTATUSBYTE2VIDEODECODER5 StatusBitForHorizontalAndVerticalLoop { get; }
Public ReadOnly Property StatusBitForHorizontalAndVerticalLoop As Saa7118TYPIDSTATUSBYTE2VIDEODECODER5
    Get
public:
property Saa7118TYPIDSTATUSBYTE2VIDEODECODER5 StatusBitForHorizontalAndVerticalLoop {
    Saa7118TYPIDSTATUSBYTE2VIDEODECODER5 get ();
}
member StatusBitForHorizontalAndVerticalLoop : Saa7118TYPIDSTATUSBYTE2VIDEODECODER5 with get

Property Value

Type: Saa7118TYPIDSTATUSBYTE2VIDEODECODER5
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.StatusBitForInterlaceDetection Property

IRD

Saa7118StatusBitForInterlaceDetection Property

Status bit for interlace detection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSTATUSBYTE2VIDEODECODER6 StatusBitForInterlaceDetection { get; }
Public ReadOnly Property StatusBitForInterlaceDetection As Saa7118TYPIDSTATUSBYTE2VIDEODECODER6
    Get
public:
property Saa7118TYPIDSTATUSBYTE2VIDEODECODER6 StatusBitForInterlaceDetection {
    Saa7118TYPIDSTATUSBYTE2VIDEODECODER6 get ();
}
member StatusBitForInterlaceDetection : Saa7118TYPIDSTATUSBYTE2VIDEODECODER6 with get

Property Value

Type: Saa7118TYPIDSTATUSBYTE2VIDEODECODER6
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.StatusBitForLockedHorizontalFrequency Property

IRD

Saa7118StatusBitForLockedHorizontalFrequency Property

Status bit for locked horizontal frequency

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSTATUSBYTE1VIDEODECODER5 StatusBitForLockedHorizontalFrequency { get; }
Public ReadOnly Property StatusBitForLockedHorizontalFrequency As Saa7118TYPIDSTATUSBYTE1VIDEODECODER5
    Get
public:
property Saa7118TYPIDSTATUSBYTE1VIDEODECODER5 StatusBitForLockedHorizontalFrequency {
    Saa7118TYPIDSTATUSBYTE1VIDEODECODER5 get ();
}
member StatusBitForLockedHorizontalFrequency : Saa7118TYPIDSTATUSBYTE1VIDEODECODER5 with get

Property Value

Type: Saa7118TYPIDSTATUSBYTE1VIDEODECODER5
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.SWRST Property

IRD

Saa7118SWRST Property

SWRST

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL4 SWRST { get; set; }
Public Property SWRST As Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL4
    Get
    Set
public:
property Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL4 SWRST {
    Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL4 get ();
    void set (Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL4 value);
}
member SWRST : Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL4 with get, set

Property Value

Type: Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL4
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.UpdateHysteresisFor9BitGain Property

IRD

Saa7118UpdateHysteresisFor9BitGain Property

Update hysteresis for 9-bit gain

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDHORIZONTALINCREMENTDELAY1 UpdateHysteresisFor9BitGain { get; set; }
Public Property UpdateHysteresisFor9BitGain As Saa7118TYPIDHORIZONTALINCREMENTDELAY1
    Get
    Set
public:
property Saa7118TYPIDHORIZONTALINCREMENTDELAY1 UpdateHysteresisFor9BitGain {
    Saa7118TYPIDHORIZONTALINCREMENTDELAY1 get ();
    void set (Saa7118TYPIDHORIZONTALINCREMENTDELAY1 value);
}
member UpdateHysteresisFor9BitGain : Saa7118TYPIDHORIZONTALINCREMENTDELAY1 with get, set

Property Value

Type: Saa7118TYPIDHORIZONTALINCREMENTDELAY1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.UpdateTimeIntervalForAGCValue Property

IRD

Saa7118UpdateTimeIntervalForAGCValue Property

Update time interval for AGC value

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL2 UpdateTimeIntervalForAGCValue { get; set; }
Public Property UpdateTimeIntervalForAGCValue As Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL2
    Get
    Set
public:
property Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL2 UpdateTimeIntervalForAGCValue {
    Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL2 get ();
    void set (Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL2 value);
}
member UpdateTimeIntervalForAGCValue : Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL2 with get, set

Property Value

Type: Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.VerticalNoiseReduction Property

IRD

Saa7118VerticalNoiseReduction Property

Vertical noise reduction

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSYNCCONTROL0 VerticalNoiseReduction { get; set; }
Public Property VerticalNoiseReduction As Saa7118TYPIDSYNCCONTROL0
    Get
    Set
public:
property Saa7118TYPIDSYNCCONTROL0 VerticalNoiseReduction {
    Saa7118TYPIDSYNCCONTROL0 get ();
    void set (Saa7118TYPIDSYNCCONTROL0 value);
}
member VerticalNoiseReduction : Saa7118TYPIDSYNCCONTROL0 with get, set

Property Value

Type: Saa7118TYPIDSYNCCONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.VerticalOffset Property

IRD

Saa7118VerticalOffset Property

Vertical offset

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VerticalOffset { get; set; }
Public Property VerticalOffset As UShort
    Get
    Set
public:
property unsigned short VerticalOffset {
    unsigned short get ();
    void set (unsigned short value);
}
member VerticalOffset : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.VGATEStart Property

IRD

Saa7118VGATEStart Property

VGATE start

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDVGATESTART0 VGATEStart { get; set; }
Public Property VGATEStart As Saa7118TYPIDVGATESTART0
    Get
    Set
public:
property Saa7118TYPIDVGATESTART0 VGATEStart {
    Saa7118TYPIDVGATESTART0 get ();
    void set (Saa7118TYPIDVGATESTART0 value);
}
member VGATEStart : Saa7118TYPIDVGATESTART0 with get, set

Property Value

Type: Saa7118TYPIDVGATESTART0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.VGATEStop Property

IRD

Saa7118VGATEStop Property

VGATE stop

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDVGATESTART0 VGATEStop { get; set; }
Public Property VGATEStop As Saa7118TYPIDVGATESTART0
    Get
    Set
public:
property Saa7118TYPIDVGATESTART0 VGATEStop {
    Saa7118TYPIDVGATESTART0 get ();
    void set (Saa7118TYPIDVGATESTART0 value);
}
member VGATEStop : Saa7118TYPIDVGATESTART0 with get, set

Property Value

Type: Saa7118TYPIDVGATESTART0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.VideoDataLimitedToRangeIDQ Property

IRD

Saa7118VideoDataLimitedToRangeIDQ Property

Video data limited to range: IDQ

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 VideoDataLimitedToRangeIDQ { get; set; }
Public Property VideoDataLimitedToRangeIDQ As Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0
    Get
    Set
public:
property Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 VideoDataLimitedToRangeIDQ {
    Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 get ();
    void set (Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 value);
}
member VideoDataLimitedToRangeIDQ : Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 with get, set

Property Value

Type: Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.VideoDataLimitedToRangeIGP0 Property

IRD

Saa7118VideoDataLimitedToRangeIGP0 Property

Video data limited to range: IGP0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 VideoDataLimitedToRangeIGP0 { get; set; }
Public Property VideoDataLimitedToRangeIGP0 As Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0
    Get
    Set
public:
property Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 VideoDataLimitedToRangeIGP0 {
    Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 get ();
    void set (Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 value);
}
member VideoDataLimitedToRangeIGP0 : Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 with get, set

Property Value

Type: Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.VideoDataLimitedToRangeIGP1 Property

IRD

Saa7118VideoDataLimitedToRangeIGP1 Property

Video data limited to range: IGP1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 VideoDataLimitedToRangeIGP1 { get; set; }
Public Property VideoDataLimitedToRangeIGP1 As Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0
    Get
    Set
public:
property Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 VideoDataLimitedToRangeIGP1 {
    Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 get ();
    void set (Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 value);
}
member VideoDataLimitedToRangeIGP1 : Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 with get, set

Property Value

Type: Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.VideoDataLimitedToRangeIGPH Property

IRD

Saa7118VideoDataLimitedToRangeIGPH Property

Video data limited to range: IGPH

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 VideoDataLimitedToRangeIGPH { get; set; }
Public Property VideoDataLimitedToRangeIGPH As Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0
    Get
    Set
public:
property Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 VideoDataLimitedToRangeIGPH {
    Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 get ();
    void set (Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 value);
}
member VideoDataLimitedToRangeIGPH : Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 with get, set

Property Value

Type: Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.VideoDataLimitedToRangeIGPV Property

IRD

Saa7118VideoDataLimitedToRangeIGPV Property

Video data limited to range: IGPV

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 VideoDataLimitedToRangeIGPV { get; set; }
Public Property VideoDataLimitedToRangeIGPV As Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0
    Get
    Set
public:
property Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 VideoDataLimitedToRangeIGPV {
    Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 get ();
    void set (Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 value);
}
member VideoDataLimitedToRangeIGPV : Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 with get, set

Property Value

Type: Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.VPSValid Property

IRD

Saa7118VPSValid Property

VPS valid

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDSLICERSTATUSBYTE02 VPSValid { get; }
Public ReadOnly Property VPSValid As Saa7118TYPIDSLICERSTATUSBYTE02
    Get
public:
property Saa7118TYPIDSLICERSTATUSBYTE02 VPSValid {
    Saa7118TYPIDSLICERSTATUSBYTE02 get ();
}
member VPSValid : Saa7118TYPIDSLICERSTATUSBYTE02 with get

Property Value

Type: Saa7118TYPIDSLICERSTATUSBYTE02
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.WhitePeakControlOff Property

IRD

Saa7118WhitePeakControlOff Property

White peak control off

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDHORIZONTALINCREMENTDELAY2 WhitePeakControlOff { get; set; }
Public Property WhitePeakControlOff As Saa7118TYPIDHORIZONTALINCREMENTDELAY2
    Get
    Set
public:
property Saa7118TYPIDHORIZONTALINCREMENTDELAY2 WhitePeakControlOff {
    Saa7118TYPIDHORIZONTALINCREMENTDELAY2 get ();
    void set (Saa7118TYPIDHORIZONTALINCREMENTDELAY2 value);
}
member WhitePeakControlOff : Saa7118TYPIDHORIZONTALINCREMENTDELAY2 with get, set

Property Value

Type: Saa7118TYPIDHORIZONTALINCREMENTDELAY2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.WhitePeakLoopIsActivated Property

IRD

Saa7118WhitePeakLoopIsActivated Property

White peak loop is activated

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118IDNotActiveActive WhitePeakLoopIsActivated { get; }
Public ReadOnly Property WhitePeakLoopIsActivated As Saa7118IDNotActiveActive
    Get
public:
property Saa7118IDNotActiveActive WhitePeakLoopIsActivated {
    Saa7118IDNotActiveActive get ();
}
member WhitePeakLoopIsActivated : Saa7118IDNotActiveActive with get

Property Value

Type: Saa7118IDNotActiveActive
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.XCLK Property

IRD

Saa7118XCLK Property

XCLK

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDXPORTIOENABLEKPHASECONTROL2 XCLK { get; set; }
Public Property XCLK As Saa7118TYPIDXPORTIOENABLEKPHASECONTROL2
    Get
    Set
public:
property Saa7118TYPIDXPORTIOENABLEKPHASECONTROL2 XCLK {
    Saa7118TYPIDXPORTIOENABLEKPHASECONTROL2 get ();
    void set (Saa7118TYPIDXPORTIOENABLEKPHASECONTROL2 value);
}
member XCLK : Saa7118TYPIDXPORTIOENABLEKPHASECONTROL2 with get, set

Property Value

Type: Saa7118TYPIDXPORTIOENABLEKPHASECONTROL2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.XPD7ToXPD0 Property

IRD

Saa7118XPD7ToXPD0 Property

XPD7 to XPD0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDRTXPORTOUTPUTCONTROL0 XPD7ToXPD0 { get; set; }
Public Property XPD7ToXPD0 As Saa7118TYPIDRTXPORTOUTPUTCONTROL0
    Get
    Set
public:
property Saa7118TYPIDRTXPORTOUTPUTCONTROL0 XPD7ToXPD0 {
    Saa7118TYPIDRTXPORTOUTPUTCONTROL0 get ();
    void set (Saa7118TYPIDRTXPORTOUTPUTCONTROL0 value);
}
member XPD7ToXPD0 : Saa7118TYPIDRTXPORTOUTPUTCONTROL0 with get, set

Property Value

Type: Saa7118TYPIDRTXPORTOUTPUTCONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.XPortOutput Property

IRD

Saa7118XPortOutput Property

X port output

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDXPORTIOENABLEKPHASECONTROL0 XPortOutput { get; set; }
Public Property XPortOutput As Saa7118TYPIDXPORTIOENABLEKPHASECONTROL0
    Get
    Set
public:
property Saa7118TYPIDXPORTIOENABLEKPHASECONTROL0 XPortOutput {
    Saa7118TYPIDXPORTIOENABLEKPHASECONTROL0 get ();
    void set (Saa7118TYPIDXPORTIOENABLEKPHASECONTROL0 value);
}
member XPortOutput : Saa7118TYPIDXPORTIOENABLEKPHASECONTROL0 with get, set

Property Value

Type: Saa7118TYPIDXPORTIOENABLEKPHASECONTROL0
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.XPortXRHOutputSelection Property

IRD

Saa7118XPortXRHOutputSelection Property

X port XRH output selection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDRTXPORTOUTPUTCONTROL3 XPortXRHOutputSelection { get; set; }
Public Property XPortXRHOutputSelection As Saa7118TYPIDRTXPORTOUTPUTCONTROL3
    Get
    Set
public:
property Saa7118TYPIDRTXPORTOUTPUTCONTROL3 XPortXRHOutputSelection {
    Saa7118TYPIDRTXPORTOUTPUTCONTROL3 get ();
    void set (Saa7118TYPIDRTXPORTOUTPUTCONTROL3 value);
}
member XPortXRHOutputSelection : Saa7118TYPIDRTXPORTOUTPUTCONTROL3 with get, set

Property Value

Type: Saa7118TYPIDRTXPORTOUTPUTCONTROL3
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.XPortXRVOutputSelection Property

IRD

Saa7118XPortXRVOutputSelection Property

X port XRV output selection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDRTXPORTOUTPUTCONTROL2 XPortXRVOutputSelection { get; set; }
Public Property XPortXRVOutputSelection As Saa7118TYPIDRTXPORTOUTPUTCONTROL2
    Get
    Set
public:
property Saa7118TYPIDRTXPORTOUTPUTCONTROL2 XPortXRVOutputSelection {
    Saa7118TYPIDRTXPORTOUTPUTCONTROL2 get ();
    void set (Saa7118TYPIDRTXPORTOUTPUTCONTROL2 value);
}
member XPortXRVOutputSelection : Saa7118TYPIDRTXPORTOUTPUTCONTROL2 with get, set

Property Value

Type: Saa7118TYPIDRTXPORTOUTPUTCONTROL2
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.XRDYOutputSignal Property

IRD

Saa7118XRDYOutputSignal Property

XRDY output signal

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDXPORTIOENABLEKPHASECONTROL1 XRDYOutputSignal { get; set; }
Public Property XRDYOutputSignal As Saa7118TYPIDXPORTIOENABLEKPHASECONTROL1
    Get
    Set
public:
property Saa7118TYPIDXPORTIOENABLEKPHASECONTROL1 XRDYOutputSignal {
    Saa7118TYPIDXPORTIOENABLEKPHASECONTROL1 get ();
    void set (Saa7118TYPIDXPORTIOENABLEKPHASECONTROL1 value);
}
member XRDYOutputSignal : Saa7118TYPIDXPORTIOENABLEKPHASECONTROL1 with get, set

Property Value

Type: Saa7118TYPIDXPORTIOENABLEKPHASECONTROL1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.XTOUTOutputEnable Property

IRD

Saa7118XTOUTOutputEnable Property

XTOUT output enable

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL1 XTOUTOutputEnable { get; set; }
Public Property XTOUTOutputEnable As Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL1
    Get
    Set
public:
property Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL1 XTOUTOutputEnable {
    Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL1 get ();
    void set (Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL1 value);
}
member XTOUTOutputEnable : Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL1 with get, set

Property Value

Type: Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL1
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.XTRIStatusOnInputPinXTRIIfNotUsedFor3StateControl Property

IRD

Saa7118XTRIStatusOnInputPinXTRIIfNotUsedFor3StateControl Property

XTRI status on input pin XTRI, if not used for 3-state control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte XTRIStatusOnInputPinXTRIIfNotUsedFor3StateControl { get; set; }
Public Property XTRIStatusOnInputPinXTRIIfNotUsedFor3StateControl As Byte
    Get
    Set
public:
property unsigned char XTRIStatusOnInputPinXTRIIfNotUsedFor3StateControl {
    unsigned char get ();
    void set (unsigned char value);
}
member XTRIStatusOnInputPinXTRIIfNotUsedFor3StateControl : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118 Methods

The Saa7118 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.Flush Method

IRD

Saa7118Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Saa7118 Class
telos.Ird.NXPSemiconductors Namespace


Saa7118.IDEnableDisable Enumeration

IRD

Saa7118IDEnableDisable Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IDEnableDisable
Public Enumeration IDEnableDisable
public enum class IDEnableDisable
type IDEnableDisable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.IDNotActiveActive Enumeration

IRD

Saa7118IDNotActiveActive Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IDNotActiveActive
Public Enumeration IDNotActiveActive
public enum class IDNotActiveActive
type IDNotActiveActive
Members
Member name | Value | Description
NotActive | 0 | Not active
Active | 1 | Active
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDANALOGADCAUTOCIBILITYCONTROL0 Enumeration

IRD

Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGADCAUTOCIBILITYCONTROL0
Public Enumeration TYPIDANALOGADCAUTOCIBILITYCONTROL0
public enum class TYPIDANALOGADCAUTOCIBILITYCONTROL0
type TYPIDANALOGADCAUTOCIBILITYCONTROL0
Members
Member name | Value | Description
AOUTConnectedToGround | 0 | AOUT connected to ground
AOUTConnectedToInputAD1 | 1 | AOUT connected to input AD1
AOUTConnectedToInputAD2 | 2 | AOUT connected to input AD2
AOUTConnectedToInputAD3 | 3 | AOUT connected to input AD3
AOUTConnectedToInputAD4 | 4 | AOUT connected to input AD4
Reserved | 5 | Reserved
AOUTConnectedToInternalTestPointBPFOUT | 7 | AOUT connected to internal test point BPFOUT
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDANALOGADCAUTOCIBILITYCONTROL1 Enumeration

IRD

Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGADCAUTOCIBILITYCONTROL1
Public Enumeration TYPIDANALOGADCAUTOCIBILITYCONTROL1
public enum class TYPIDANALOGADCAUTOCIBILITYCONTROL1
type TYPIDANALOGADCAUTOCIBILITYCONTROL1
Members
Member name | Value | Description
XTOUT3Stated | 0 | XTOUT 3-stated
XTOUTenabled | 1 | XTOUTenabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDANALOGADCAUTOCIBILITYCONTROL2 Enumeration

IRD

Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGADCAUTOCIBILITYCONTROL2
Public Enumeration TYPIDANALOGADCAUTOCIBILITYCONTROL2
public enum class TYPIDANALOGADCAUTOCIBILITYCONTROL2
type TYPIDANALOGADCAUTOCIBILITYCONTROL2
Members
Member name | Value | Description
HorizontalUpdate | 0 | Horizontal update
VerticalUpdate | 1 | Vertical update
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDANALOGADCAUTOCIBILITYCONTROL3 Enumeration

IRD

Saa7118TYPIDANALOGADCAUTOCIBILITYCONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGADCAUTOCIBILITYCONTROL3
Public Enumeration TYPIDANALOGADCAUTOCIBILITYCONTROL3
public enum class TYPIDANALOGADCAUTOCIBILITYCONTROL3
type TYPIDANALOGADCAUTOCIBILITYCONTROL3
Members
Member name | Value | Description
Off | 0 | Off
On | 1 | On
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDANALOGINPUTCONTROL10 Enumeration

IRD

Saa7118TYPIDANALOGINPUTCONTROL10 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL10
Public Enumeration TYPIDANALOGINPUTCONTROL10
public enum class TYPIDANALOGINPUTCONTROL10
type TYPIDANALOGINPUTCONTROL10
Members
Member name | Value | Description
CVBSModes1Mode00CVBS | 0 | CVBS Modes 1: Mode 00: CVBS
CVBSModes1Mode01CVBS | 1 | CVBS Modes 1: Mode 01: CVBS
CVBSModes1Mode02CVBS | 2 | CVBS Modes 1: Mode 02: CVBS
CVBSModes1Mode03CVBS | 3 | CVBS Modes 1: Mode 03: CVBS
CVBSModes1Mode04CVBS | 4 | CVBS Modes 1: Mode 04: CVBS
CVBSModes1Mode05CVBS | 5 | CVBS Modes 1: Mode 05: CVBS
YCModes1Mode06Y | 6 | Y + C Modes 1: Mode 06: Y
YCModes1Mode07Y | 7 | Y + C Modes 1: Mode 07: Y
YCModes1Mode08Y | 8 | Y + C Modes 1: Mode 08: Y
YCModes1Mode09Y | 9 | Y + C Modes 1: Mode 09: Y
YCModes1Mode0AY | 10 | Y + C Modes 1: Mode 0A: Y
YCModes1Mode0BY | 11 | Y + C Modes 1: Mode 0B: Y
YCModes1Mode0CY | 12 | Y + C Modes 1: Mode 0C: Y
YCModes1Mode0DY | 13 | Y + C Modes 1: Mode 0D: Y
CVBSModes2ModeECVBS | 14 | CVBS Modes 2: Mode E: CVBS
CVBSModes2ModeFCVBS | 15 | CVBS Modes 2: Mode F: CVBS
CVBSModes2Mode10CVBS | 16 | CVBS Modes 2: Mode 10: CVBS
CVBSModes2Mode11CVBS | 17 | CVBS Modes 2: Mode 11: CVBS
CVBSModes2Mode12CVBS | 18 | CVBS Modes 2: Mode 12: CVBS
CVBSModes2Mode13CVBS | 19 | CVBS Modes 2: Mode 13: CVBS
CVBSModes2Mode14CVBS | 20 | CVBS Modes 2: Mode 14: CVBS
CVBSModes2Mode15CVBS | 21 | CVBS Modes 2: Mode 15: CVBS
YCModes2Mode16Y | 22 | Y + C Modes 2: Mode 16: Y
YCModes2Mode17Y | 23 | Y + C Modes 2: Mode 17: Y
YCModes2Mode18Y | 24 | Y + C Modes 2: Mode 18: Y
YCModes2Mode19Y | 25 | Y + C Modes 2: Mode 19: Y
YCModes2Mode1AY | 26 | Y + C Modes 2: Mode 1A: Y
YCModes2Mode1BY | 27 | Y + C Modes 2: Mode 1B: Y
YCModes2Mode1CY | 28 | Y + C Modes 2: Mode 1C: Y
YCModes2Mode1DY | 29 | Y + C Modes 2: Mode 1D: Y
CVBSModes3Mode1ECVBS | 30 | CVBS Modes 3: Mode 1E: CVBS
CVBSModes3Mode1FCVBS | 31 | CVBS Modes 3: Mode 1F: CVBS
YPBPRModesMode20SYPBPR | 32 | Y-PB-PR Modes: Mode 20: SY-PB-PR
YPBPRModesMode21SYPBPR | 33 | Y-PB-PR Modes: Mode 21: SY-PB-PR
YPBPRModesMode2ESYPBPR | 46 | Y-PB-PR Modes: Mode 2E: SY-PB-PR
YPBPRModesMode2FSYPBPR | 47 | Y-PB-PR Modes: Mode 2F: SY-PB-PR
RGBModesMode30SRGB | 48 | RGB Modes: Mode 30: SRGB
RGBModesMode31SRGB | 49 | RGB Modes: Mode 31: SRGB
RGBModesMode32SRGB | 50 | RGB Modes: Mode 32: SRGB
RGBModesMode33SRGB | 51 | RGB Modes: Mode 33: SRGB
RGBModesMode34SRGB | 52 | RGB Modes: Mode 34: SRGB
RGBModesMode35SRGB | 53 | RGB Modes: Mode 35: SRGB
RGBModesMode36SRGB | 54 | RGB Modes: Mode 36: SRGB
RGBModesMode37SRGB | 55 | RGB Modes: Mode 37: SRGB
RGBModesMode38SRGB | 56 | RGB Modes: Mode 38: SRGB
RGBModesMode39SRGB | 57 | RGB Modes: Mode 39: SRGB
RGBModesMode3ASRGB | 58 | RGB Modes: Mode 3A: SRGB
RGBModesMode3BSRGB | 59 | RGB Modes: Mode 3B: SRGB
RGBModesMode3CSRGB | 60 | RGB Modes: Mode 3C: SRGB
RGBModesMode3DSRGB | 61 | RGB Modes: Mode 3D: SRGB
RGBModesMode3ESRGB | 62 | RGB Modes: Mode 3E: SRGB
RGBModesMode3FSRGB | 63 | RGB Modes: Mode 3F: SRGB
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDANALOGINPUTCONTROL11 Enumeration

IRD

Saa7118TYPIDANALOGINPUTCONTROL11 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL11
Public Enumeration TYPIDANALOGINPUTCONTROL11
public enum class TYPIDANALOGINPUTCONTROL11
type TYPIDANALOGINPUTCONTROL11
Members
Member name | Value | Description
AmplifierPlusAntiAliasFilterBypassed | 0 | Amplifier plus anti-alias filter bypassed
AmplifierActive | 2 | Amplifier active
AmplifierPlusAntiAliasFilterActive | 3 | Amplifier plus anti-alias filter active
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDANALOGINPUTCONTROL20 Enumeration

IRD

Saa7118TYPIDANALOGINPUTCONTROL20 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL20
Public Enumeration TYPIDANALOGINPUTCONTROL20
public enum class TYPIDANALOGINPUTCONTROL20
type TYPIDANALOGINPUTCONTROL20
Members
Member name | Value | Description
AutomaticGainControlled | 0 | Automatic gain controlled
GainIsUserProgrammable | 1 | Gain is user programmable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDANALOGINPUTCONTROL21 Enumeration

IRD

Saa7118TYPIDANALOGINPUTCONTROL21 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL21
Public Enumeration TYPIDANALOGINPUTCONTROL21
public enum class TYPIDANALOGINPUTCONTROL21
type TYPIDANALOGINPUTCONTROL21
Members
Member name | Value | Description
AGCActive | 0 | AGC active
AGCIntegrationHoldFreeze | 1 | AGC integration hold (freeze)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDANALOGINPUTCONTROL22 Enumeration

IRD

Saa7118TYPIDANALOGINPUTCONTROL22 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL22
Public Enumeration TYPIDANALOGINPUTCONTROL22
public enum class TYPIDANALOGINPUTCONTROL22
type TYPIDANALOGINPUTCONTROL22
Members
Member name | Value | Description
ColourPeakControlActive | 0 | Colour peak control active
ColourPeakOff | 1 | Colour peak off
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDANALOGINPUTCONTROL23 Enumeration

IRD

Saa7118TYPIDANALOGINPUTCONTROL23 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL23
Public Enumeration TYPIDANALOGINPUTCONTROL23
public enum class TYPIDANALOGINPUTCONTROL23
type TYPIDANALOGINPUTCONTROL23
Members
Member name | Value | Description
ShortVerticalBlanking | 0 | Short vertical blanking
LongVerticalBlanking | 1 | Long vertical blanking
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDANALOGINPUTCONTROL24 Enumeration

IRD

Saa7118TYPIDANALOGINPUTCONTROL24 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL24
Public Enumeration TYPIDANALOGINPUTCONTROL24
public enum class TYPIDANALOGINPUTCONTROL24
type TYPIDANALOGINPUTCONTROL24
Members
Member name | Value | Description
NormalClamping | 0 | Normal clamping
ReferenceSelect | 1 | Reference select
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDANALOGINPUTCONTROL51 Enumeration

IRD

Saa7118TYPIDANALOGINPUTCONTROL51 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL51
Public Enumeration TYPIDANALOGINPUTCONTROL51
public enum class TYPIDANALOGINPUTCONTROL51
type TYPIDANALOGINPUTCONTROL51
Members
Member name | Value | Description
ClampingIsDependentOnHLNRS | 0 | Clamping is dependent on HLNRS
ReferenceSelection | 1 | Reference selection
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDANALOGINPUTCONTROL52 Enumeration

IRD

Saa7118TYPIDANALOGINPUTCONTROL52 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL52
Public Enumeration TYPIDANALOGINPUTCONTROL52
public enum class TYPIDANALOGINPUTCONTROL52
type TYPIDANALOGINPUTCONTROL52
Members
Member name | Value | Description
AllADCsAreClockedInternal | 0 | All ADCs are clocked internal
AllADCsAreClockedByTheExternal | 1 | All ADCs are clocked by the external
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDANALOGINPUTCONTROL53 Enumeration

IRD

Saa7118TYPIDANALOGINPUTCONTROL53 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL53
Public Enumeration TYPIDANALOGINPUTCONTROL53
public enum class TYPIDANALOGINPUTCONTROL53
type TYPIDANALOGINPUTCONTROL53
Members
Member name | Value | Description
ADPortIsSetTo3State | 0 | AD port is set to 3-state
ADPortIsEnabled | 1 | AD port is enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDAUDIOCLOCKCONTROL0 Enumeration

IRD

Saa7118TYPIDAUDIOCLOCKCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDAUDIOCLOCKCONTROL0
Public Enumeration TYPIDAUDIOCLOCKCONTROL0
public enum class TYPIDAUDIOCLOCKCONTROL0
type TYPIDAUDIOCLOCKCONTROL0
Members
Member name | Value | Description
ASCLKEdgesTriggeredByFallingEdgesOfAMCLK | 0 | ASCLK edges triggered by falling edges of AMCLK
ASCLKEdgesTriggeredByRisingEdgesOfAMCLK | 1 | ASCLK edges triggered by rising edges of AMCLK
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDAUDIOCLOCKCONTROL1 Enumeration

IRD

Saa7118TYPIDAUDIOCLOCKCONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDAUDIOCLOCKCONTROL1
Public Enumeration TYPIDAUDIOCLOCKCONTROL1
public enum class TYPIDAUDIOCLOCKCONTROL1
type TYPIDAUDIOCLOCKCONTROL1
Members
Member name | Value | Description
ALRCLKEdgesTriggeredByFallingEdgesOfASCLK | 0 | ALRCLK edges triggered by falling edges of ASCLK
ALRCLKEdgesTriggeredByRisingEdgesOfASCLK | 1 | ALRCLK edges triggered by rising edges of ASCLK
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDAUDIOCLOCKCONTROL2 Enumeration

IRD

Saa7118TYPIDAUDIOCLOCKCONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDAUDIOCLOCKCONTROL2
Public Enumeration TYPIDAUDIOCLOCKCONTROL2
public enum class TYPIDAUDIOCLOCKCONTROL2
type TYPIDAUDIOCLOCKCONTROL2
Members
Member name | Value | Description
VerticalReferencePulseIsTakenFromInternalDecoder | 0 | Vertical reference pulse is taken from internal decoder
VerticalReferenceIsTakenFromXRVInputExpansionPort | 1 | Vertical reference is taken from XRV input (expansion port)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDAUDIOCLOCKCONTROL3 Enumeration

IRD

Saa7118TYPIDAUDIOCLOCKCONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDAUDIOCLOCKCONTROL3
Public Enumeration TYPIDAUDIOCLOCKCONTROL3
public enum class TYPIDAUDIOCLOCKCONTROL3
type TYPIDAUDIOCLOCKCONTROL3
Members
Member name | Value | Description
PLLActiveAMCLKIsFieldLocked | 0 | PLL active, AMCLK is field-locked
PLLOpenAMCLKIsFreeRunning | 1 | PLL open, AMCLK is free-running
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDCHROMINANCECONTROL10 Enumeration

IRD

Saa7118TYPIDCHROMINANCECONTROL10 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCECONTROL10
Public Enumeration TYPIDCHROMINANCECONTROL10
public enum class TYPIDCHROMINANCECONTROL10
type TYPIDCHROMINANCECONTROL10
Members
Member name | Value | Description
Disabled | 0 | Disabled
Active | 1 | Active
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDCHROMINANCECONTROL101 Enumeration

IRD

Saa7118TYPIDCHROMINANCECONTROL101 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCECONTROL101
Public Enumeration TYPIDCHROMINANCECONTROL101
public enum class TYPIDCHROMINANCECONTROL101
type TYPIDCHROMINANCECONTROL101
Members
Member name | Value | Description
Disabled | 0 | Disabled
ActiveSharpnessControlPreset | 1 | Active/sharpness control preset
ActivePreset | 2 | Active preset
ActiveButNoFilterPresets | 3 | Active, but no filter presets
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDCHROMINANCECONTROL11 Enumeration

IRD

Saa7118TYPIDCHROMINANCECONTROL11 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCECONTROL11
Public Enumeration TYPIDCHROMINANCECONTROL11
public enum class TYPIDCHROMINANCECONTROL11
type TYPIDCHROMINANCECONTROL11
Members
Member name | Value | Description
NominalTimeConstant | 0 | Nominal time constant
FastTimeConstant | 1 | Fast time constant
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDCHROMINANCECONTROL12 Enumeration

IRD

Saa7118TYPIDCHROMINANCECONTROL12 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCECONTROL12
Public Enumeration TYPIDCHROMINANCECONTROL12
public enum class TYPIDCHROMINANCECONTROL12
type TYPIDCHROMINANCECONTROL12
Members
Member name | Value | Description
On | 0 | On
Off | 1 | Off
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDCHROMINANCECONTROL13 Enumeration

IRD

Saa7118TYPIDCHROMINANCECONTROL13 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCECONTROL13
Public Enumeration TYPIDCHROMINANCECONTROL13
public enum class TYPIDCHROMINANCECONTROL13
type TYPIDCHROMINANCECONTROL13
Members
Member name | Value | Description
PreferredStandardPALBGDHINTSCM443MHz358MHz | 0 | Preferred standard: PAL BGDHI/NTSC M (4.43 MHz/3.58 MHz)
ReservedDoNotUse | 1 | Reserved; do not use
PreferredStandardPALBGDHINTSCJapan443MHz358MHz | 4 | Preferred standard: PAL BGDHI/NTSC-Japan (4.43 MHz/3.58 MHz)
PreferredStandardSECAMNTSCM358MHz | 5 | Preferred standard: SECAM/NTSC-M (-/3.58 MHz)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDCHROMINANCECONTROL14 Enumeration

IRD

Saa7118TYPIDCHROMINANCECONTROL14 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCECONTROL14
Public Enumeration TYPIDCHROMINANCECONTROL14
public enum class TYPIDCHROMINANCECONTROL14
type TYPIDCHROMINANCECONTROL14
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enable | 1 | Enable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDCHROMINANCECONTROL20 Enumeration

IRD

Saa7118TYPIDCHROMINANCECONTROL20 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCECONTROL20
Public Enumeration TYPIDCHROMINANCECONTROL20
public enum class TYPIDCHROMINANCECONTROL20
type TYPIDCHROMINANCECONTROL20
Members
Member name | Value | Description
Value_0Smallest | 0 | 0 - Smallest
Value_7Largest | 7 | 7 - Largest
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDCHROMINANCECONTROL21 Enumeration

IRD

Saa7118TYPIDCHROMINANCECONTROL21 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCECONTROL21
Public Enumeration TYPIDCHROMINANCECONTROL21
public enum class TYPIDCHROMINANCECONTROL21
type TYPIDCHROMINANCECONTROL21
Members
Member name | Value | Description
Small | 0 | Small
Wide | 1 | Wide
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDCHROMINANCECONTROL22 Enumeration

IRD

Saa7118TYPIDCHROMINANCECONTROL22 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCECONTROL22
Public Enumeration TYPIDCHROMINANCECONTROL22
public enum class TYPIDCHROMINANCECONTROL22
type TYPIDCHROMINANCECONTROL22
Members
Member name | Value | Description
Value_0LSB | 0 | 0 LSB
Value_14LSB | 1 | 1/4 LSB
Value_12LSB | 2 | 1/2 LSB
Value_34LSB | 3 | 3/4 LSB
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDCHROMINANCEGAINCONTROL0 Enumeration

IRD

Saa7118TYPIDCHROMINANCEGAINCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCEGAINCONTROL0
Public Enumeration TYPIDCHROMINANCEGAINCONTROL0
public enum class TYPIDCHROMINANCEGAINCONTROL0
type TYPIDCHROMINANCEGAINCONTROL0
Members
Member name | Value | Description
Value_0MinimumGain05 | 0 | 0 - minimum gain (0.5)
Value_36NominalGain1125 | 36 | 36 - nominal gain (1.125)
Value_127MaximumGain75 | 127 | 127 - maximum gain (7.5)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDCHROMINANCEGAINCONTROL1 Enumeration

IRD

Saa7118TYPIDCHROMINANCEGAINCONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCEGAINCONTROL1
Public Enumeration TYPIDCHROMINANCEGAINCONTROL1
public enum class TYPIDCHROMINANCEGAINCONTROL1
type TYPIDCHROMINANCEGAINCONTROL1
Members
Member name | Value | Description
On | 0 | On
ProgrammableGain | 1 | Programmable gain
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDCOMPONENTDELAYFSWITCHCONTROL3 Enumeration

IRD

Saa7118TYPIDCOMPONENTDELAYFSWITCHCONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCOMPONENTDELAYFSWITCHCONTROL3
Public Enumeration TYPIDCOMPONENTDELAYFSWITCHCONTROL3
public enum class TYPIDCOMPONENTDELAYFSWITCHCONTROL3
type TYPIDCOMPONENTDELAYFSWITCHCONTROL3
Members
Member name | Value | Description
DecodedCVBSSignalCompenentSignal | 0 | Decoded CVBS signal/Compenent signal
CompenentSignalDecodedCVBSSignal | 1 | Compenent signal/Decoded CVBS signal
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDCOMPONENTDELAYFSWITCHCONTROL4 Enumeration

IRD

Saa7118TYPIDCOMPONENTDELAYFSWITCHCONTROL4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCOMPONENTDELAYFSWITCHCONTROL4
Public Enumeration TYPIDCOMPONENTDELAYFSWITCHCONTROL4
public enum class TYPIDCOMPONENTDELAYFSWITCHCONTROL4
type TYPIDCOMPONENTDELAYFSWITCHCONTROL4
Members
Member name | Value | Description
Disabled | 0 | Disabled
PixelwiseSwitchingBetweenDecodedCVBSSignalAndComponentInputSignalIsEnabled | 1 | Pixelwise switching between decoded CVBS signal and component input signal is enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDFIELDOFFSETANDETSSLICERSET0 Enumeration

IRD

Saa7118TYPIDFIELDOFFSETANDETSSLICERSET0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFIELDOFFSETANDETSSLICERSET0
Public Enumeration TYPIDFIELDOFFSETANDETSSLICERSET0
public enum class TYPIDFIELDOFFSETANDETSSLICERSET0
type TYPIDFIELDOFFSETANDETSSLICERSET0
Members
Member name | Value | Description
LeaveDataUnchanged | 0 | Leave data unchanged
Convert00HAndFFHDataBytesInto03HAndFCH | 1 | Convert 00H and FFH data bytes into 03H and FCH
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDFIELDOFFSETANDETSSLICERSET1 Enumeration

IRD

Saa7118TYPIDFIELDOFFSETANDETSSLICERSET1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFIELDOFFSETANDETSSLICERSET1
Public Enumeration TYPIDFIELDOFFSETANDETSSLICERSET1
public enum class TYPIDFIELDOFFSETANDETSSLICERSET1
type TYPIDFIELDOFFSETANDETSSLICERSET1
Members
Member name | Value | Description
NoModificationOfInternalFieldIndicatorDefaultFor50Hz625LinesInputSources | 0 | No modification of internal field indicator (default for 50 Hz 625 lines input sources)
InvertFieldIndicatorDefaultFor60Hz525LinesInputSources | 1 | Invert field indicator (default for 60 Hz 525 lines input sources)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDGLOBALCONTROL10 Enumeration

IRD

Saa7118TYPIDGLOBALCONTROL10 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDGLOBALCONTROL10
Public Enumeration TYPIDGLOBALCONTROL10
public enum class TYPIDGLOBALCONTROL10
type TYPIDGLOBALCONTROL10
Members
Member name | Value | Description
ICLKOutputAndBackEndClockIsLineLockedClockLLCFromDecoder | 0 | ICLK output and back-end clock is line-locked clock LLC from decoder
ICLKOutputAndBackEndClockIsXCLKFromXPort | 1 | ICLK output and back-end clock is XCLK from X port
ICLKOutputIsLLCAndBackEndClockIsLLC2Clock | 2 | ICLK output is LLC and back-end clock is LLC2 clock
BackEndClockIsTheICLKInput | 3 | Back-end clock is the ICLK input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDGLOBALCONTROL11 Enumeration

IRD

Saa7118TYPIDGLOBALCONTROL11 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDGLOBALCONTROL11
Public Enumeration TYPIDGLOBALCONTROL11
public enum class TYPIDGLOBALCONTROL11
type TYPIDGLOBALCONTROL11
Members
Member name | Value | Description
CarriesTheDataQualifier | 0 | Carries the data qualifier
CarriesAGatedBackEndClockDQANDCLK | 1 | Carries a gated back-end clock (DQ AND CLK)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDGLOBALCONTROL12 Enumeration

IRD

Saa7118TYPIDGLOBALCONTROL12 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDGLOBALCONTROL12
Public Enumeration TYPIDGLOBALCONTROL12
public enum class TYPIDGLOBALCONTROL12
type TYPIDGLOBALCONTROL12
Members
Member name | Value | Description
GenerationOnlyForValidData | 0 | Generation only for valid data
QualifiesValidDataInsideTheScalingRegionAndAllDataOutsideTheScalingRegion | 1 | Qualifies valid data inside the scaling region and all data outside the scaling region
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDGLOBALCONTROL15 Enumeration

IRD

Saa7118TYPIDGLOBALCONTROL15 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDGLOBALCONTROL15
Public Enumeration TYPIDGLOBALCONTROL15
public enum class TYPIDGLOBALCONTROL15
type TYPIDGLOBALCONTROL15
Members
Member name | Value | Description
ScalerWindow | 0 | Scaler window
VBIDataSlicer | 1 | VBI data slicer
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDHEADERANDDATAIONCODECONTROL1 Enumeration

IRD

Saa7118TYPIDHEADERANDDATAIONCODECONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDHEADERANDDATAIONCODECONTROL1
Public Enumeration TYPIDHEADERANDDATAIONCODECONTROL1
public enum class TYPIDHEADERANDDATAIONCODECONTROL1
type TYPIDHEADERANDDATAIONCODECONTROL1
Members
Member name | Value | Description
FAndVOutputOfSlicerIsLCRTableDependent | 0 | F and V output of slicer is LCR table dependent
FAndVOutputIsTakenFromDecoderRealTimeSignalsEVENITUAndVBLNKITU | 1 | F and V output is taken from decoder real-time signals EVEN_ITU and VBLNK_ITU
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDHORIZONTALINCREMENTDELAY0 Enumeration

IRD

Saa7118TYPIDHORIZONTALINCREMENTDELAY0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDHORIZONTALINCREMENTDELAY0
Public Enumeration TYPIDHORIZONTALINCREMENTDELAY0
public enum class TYPIDHORIZONTALINCREMENTDELAY0
type TYPIDHORIZONTALINCREMENTDELAY0
Members
Member name | Value | Description
Value_0MaximumDelay | 0 | 0 - Maximum delay
Value_1 | 1 | 1 -
Value_2 | 2 | 2 -
Value_3 | 3 | 3 -
Value_4 | 4 | 4 -
Value_5 | 5 | 5 -
Value_6 | 6 | 6 -
Value_7RecommendedPosition | 7 | 7 - Recommended position
Value_8 | 8 | 8 -
Value_9 | 9 | 9 -
Value_10 | 10 | 10 -
Value_11 | 11 | 11 -
Value_12 | 12 | 12 -
Value_13 | 13 | 13 -
Value_14MinimumDelay | 14 | 14 - Minimum delay
Value_15NoUpdate | 15 | 15 - No update
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDHORIZONTALINCREMENTDELAY1 Enumeration

IRD

Saa7118TYPIDHORIZONTALINCREMENTDELAY1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDHORIZONTALINCREMENTDELAY1
Public Enumeration TYPIDHORIZONTALINCREMENTDELAY1
public enum class TYPIDHORIZONTALINCREMENTDELAY1
type TYPIDHORIZONTALINCREMENTDELAY1
Members
Member name | Value | Description
Off | 0 | Off
Value_1LSB | 1 | +/- 1 LSB
Value_2LSB | 2 | +/- 2 LSB
Value_3LSB | 3 | +/- 3 LSB
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDHORIZONTALINCREMENTDELAY2 Enumeration

IRD

Saa7118TYPIDHORIZONTALINCREMENTDELAY2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDHORIZONTALINCREMENTDELAY2
Public Enumeration TYPIDHORIZONTALINCREMENTDELAY2
public enum class TYPIDHORIZONTALINCREMENTDELAY2
type TYPIDHORIZONTALINCREMENTDELAY2
Members
Member name | Value | Description
WhitePeakControlActive | 0 | White peak control active
WhitePeakControlDisabled | 1 | White peak control disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDIPORTFIFOFLAGANDARBITRATION0 Enumeration

IRD

Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTFIFOFLAGANDARBITRATION0
Public Enumeration TYPIDIPORTFIFOFLAGANDARBITRATION0
public enum class TYPIDIPORTFIFOFLAGANDARBITRATION0
type TYPIDIPORTFIFOFLAGANDARBITRATION0
Members
Member name | Value | Description
Smaller16Dwords | 0 | Smaller 16 Dwords
Smaller8Dwords | 1 | Smaller 8 Dwords
Smaller4Dwords | 2 | Smaller 4 Dwords
Value_0Dwords | 3 | 0 Dwords
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDIPORTFIFOFLAGANDARBITRATION1 Enumeration

IRD

Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTFIFOFLAGANDARBITRATION1
Public Enumeration TYPIDIPORTFIFOFLAGANDARBITRATION1
public enum class TYPIDIPORTFIFOFLAGANDARBITRATION1
type TYPIDIPORTFIFOFLAGANDARBITRATION1
Members
Member name | Value | Description
HigherOrSame16Dwords | 0 | Higher or same 16 Dwords
HigherOrSame24Dwords | 1 | Higher or same 24 Dwords
HigherOrSame28Dwords | 2 | Higher or same 28 Dwords
Value_32Dwords | 3 | 32 Dwords
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDIPORTFIFOFLAGANDARBITRATION2 Enumeration

IRD

Saa7118TYPIDIPORTFIFOFLAGANDARBITRATION2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTFIFOFLAGANDARBITRATION2
Public Enumeration TYPIDIPORTFIFOFLAGANDARBITRATION2
public enum class TYPIDIPORTFIFOFLAGANDARBITRATION2
type TYPIDIPORTFIFOFLAGANDARBITRATION2
Members
Member name | Value | Description
IPortDataOutputInhibited | 0 | I port data output inhibited
OnlyVideoDataIsTransferred | 1 | Only video data is transferred
OnlyTextDataIsTransferredNoEAVSAVWillOccur | 2 | Only text data is transferred (no EAV, SAV will occur)
TextAndVideoDataIsTransferredTextHasPriority | 3 | Text and video data is transferred, text has priority
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDIPORTIOENABLEKPHASECONTROL0 Enumeration

IRD

Saa7118TYPIDIPORTIOENABLEKPHASECONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTIOENABLEKPHASECONTROL0
Public Enumeration TYPIDIPORTIOENABLEKPHASECONTROL0
public enum class TYPIDIPORTIOENABLEKPHASECONTROL0
type TYPIDIPORTIOENABLEKPHASECONTROL0
Members
Member name | Value | Description
IPortOutputIsDisabledBySoftware | 0 | I port output is disabled by software
IPortOutputIsEnabledBySoftware | 1 | I port output is enabled by software
IPortOutputIsEnabledByPinITRIAtLogic0 | 2 | I port output is enabled by pin ITRI at logic 0
IPortOutputIsEnabledByPinITRIAtLogic1 | 3 | I port output is enabled by pin ITRI at logic 1
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDIPORTIOENABLEKPHASECONTROL1 Enumeration

IRD

Saa7118TYPIDIPORTIOENABLEKPHASECONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTIOENABLEKPHASECONTROL1
Public Enumeration TYPIDIPORTIOENABLEKPHASECONTROL1
public enum class TYPIDIPORTIOENABLEKPHASECONTROL1
type TYPIDIPORTIOENABLEKPHASECONTROL1
Members
Member name | Value | Description
DefaultOutputPhase | 0 | Default output phase
PhaseShiftedBy12ClockCycleRecommendedForICKS11AndICKS00 | 1 | Phase shifted by 1/2 clock cycle. recommended for ICKS1=1 and ICKS0=0
PhaseShiftedByApproximately3Ns | 2 | Phase shifted by approximately 3 ns
PhaseShiftedBy12ClockCycleApproximately3NsAlternativelyToSetting01 | 3 | Phase shifted by 1/2 clock cycle+approximately 3 ns. alternatively to setting '01'
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDIPORTIOENABLEKPHASECONTROL2 Enumeration

IRD

Saa7118TYPIDIPORTIOENABLEKPHASECONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTIOENABLEKPHASECONTROL2
Public Enumeration TYPIDIPORTIOENABLEKPHASECONTROL2
public enum class TYPIDIPORTIOENABLEKPHASECONTROL2
type TYPIDIPORTIOENABLEKPHASECONTROL2
Members
Member name | Value | Description
GatedClockDefaultOutputPhase | 0 | Gated clock default output phase
GatedClockPhaseShiftedBy12ClockCycleRecommendedForGatedClockOutput | 1 | Gated clock phase shifted by 1/2 clock cycle => recommended for gated clock output
GatedClockPhaseShiftedByApproximately3Ns | 2 | Gated clock phase shifted by approximately 3 ns
GatedClockPhaseShiftedBy12ClockCycleApproximately3NsAlternativelyToSetting01 | 3 | Gated clock phase shifted by 1/2 clock cycle + approximately 3 ns => alternatively to setting '01'
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDIPORTSIGNALDEFINITIONS0 Enumeration

IRD

Saa7118TYPIDIPORTSIGNALDEFINITIONS0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTSIGNALDEFINITIONS0
Public Enumeration TYPIDIPORTSIGNALDEFINITIONS0
public enum class TYPIDIPORTSIGNALDEFINITIONS0
type TYPIDIPORTSIGNALDEFINITIONS0
Members
Member name | Value | Description
HGateSignalFramingTheScalerOutput | 0 | H gate signal, framing the scaler output
ExtendedHGateFramingHGateDuringScalerOutputAndScalerInputHReferenceOutsideTheScalerWindow | 1 | Extended H gate (framing H gate during scaler output and scaler input H reference outside the scaler window)
HorizontalTriggerPulseOnActiveGoingEdgeOfHGate | 2 | Horizontal trigger pulse, on active going edge of H gate
HorizontalTriggerPulseOnActiveGoingEdgeOfExtendedHGate | 3 | Horizontal trigger pulse, on active going edge of extended H gate
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDIPORTSIGNALDEFINITIONS01 Enumeration

IRD

Saa7118TYPIDIPORTSIGNALDEFINITIONS01 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTSIGNALDEFINITIONS01
Public Enumeration TYPIDIPORTSIGNALDEFINITIONS01
public enum class TYPIDIPORTSIGNALDEFINITIONS01
type TYPIDIPORTSIGNALDEFINITIONS01
Members
Member name | Value | Description
OutputFieldIDAsDefinedByOFIDC | 0 | Output field ID, as defined by OFIDC
ABTaskFlagAsDefinedByCONLH | 1 | A/B task flag, as defined by CONLH
SlicedDataFlagFramingTheSlicedVBIDataAtTheIPort | 2 | Sliced data flag, framing the sliced VBI data at the I port
SetToLogic0 | 3 | Set to logic 0
OutputFIFOAlmostFilledFlag | 4 | Output FIFO almost filled flag
OutputFIFOOverflowFlag | 5 | Output FIFO overflow flag
OutputFIFOOverflowFullFlag | 6 | Output FIFO overflow full flag
OutputFIFOAlmostEmptyFlag | 7 | Output FIFO almost empty flag
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDIPORTSIGNALDEFINITIONS02 Enumeration

IRD

Saa7118TYPIDIPORTSIGNALDEFINITIONS02 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTSIGNALDEFINITIONS02
Public Enumeration TYPIDIPORTSIGNALDEFINITIONS02
public enum class TYPIDIPORTSIGNALDEFINITIONS02
type TYPIDIPORTSIGNALDEFINITIONS02
Members
Member name | Value | Description
OutputFieldIDAsDefinedByOFIDC | 0 | Output field ID, as defined by OFIDC
ABTaskFlagAsDefinedByCONLH | 1 | A/B task flag, as defined by CONLH
SlicedDataFlagFramingTheSlicedVBIDataAtTheIPort | 2 | Sliced data flag, framing the sliced VBI data at the I port
SetToLogic0 | 3 | Set to logic 0
OutputFIFOAlmostFilledFlag | 4 | Output FIFO almost filled flag
OutputFIFOOverflowFlag | 5 | Output FIFO overflow flag
OutputFIFOOverflowFullFlag | 6 | Output FIFO overflow full flag
OutputFIFOAlmostEmptyFlag | 7 | Output FIFO almost empty flag
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDIPORTSIGNALDEFINITIONS1 Enumeration

IRD

Saa7118TYPIDIPORTSIGNALDEFINITIONS1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTSIGNALDEFINITIONS1
Public Enumeration TYPIDIPORTSIGNALDEFINITIONS1
public enum class TYPIDIPORTSIGNALDEFINITIONS1
type TYPIDIPORTSIGNALDEFINITIONS1
Members
Member name | Value | Description
VGateSignalFramingScaledOutputLines | 0 | V gate signal, framing scaled output lines
VReferenceSignalFromScalerInput | 1 | V reference signal from scaler input
VerticalTriggerPulseDerivedFromVGate | 2 | Vertical trigger pulse, derived from V gate
VerticalTriggerPulseDerivedFromInputVReference | 3 | Vertical trigger pulse derived from input V reference
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDLINECONTROLREGISTERLCR20 Enumeration

IRD

Saa7118TYPIDLINECONTROLREGISTERLCR20 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDLINECONTROLREGISTERLCR20
Public Enumeration TYPIDLINECONTROLREGISTERLCR20
public enum class TYPIDLINECONTROLREGISTERLCR20
type TYPIDLINECONTROLREGISTERLCR20
Members
Member name | Value | Description
WST625 | 0 | WST625
CC625 | 1 | CC625
VPS | 2 | VPS
WSS | 3 | WSS
WST525 | 4 | WST525
CC525 | 5 | CC525
TestLine | 6 | Test line
Intercast | 7 | Intercast
GeneralText | 8 | General text
VITC625 | 9 | VITC625
VITC525 | 10 | VITC525
Reserved | 11 | Reserved
NABTS | 12 | NABTS
Japtext | 13 | Japtext
JFS | 14 | JFS
ActiveVideo | 15 | Active video
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDLUMINANCEBRIGHTNLDECODERPART0 Enumeration

IRD

Saa7118TYPIDLUMINANCEBRIGHTNLDECODERPART0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDLUMINANCEBRIGHTNLDECODERPART0
Public Enumeration TYPIDLUMINANCEBRIGHTNLDECODERPART0
public enum class TYPIDLUMINANCEBRIGHTNLDECODERPART0
type TYPIDLUMINANCEBRIGHTNLDECODERPART0
Members
Member name | Value | Description
Value_0Dark | 0 | 0 - Dark
Value_128ITULevel | 128 | 128 - ITU level
Value_255Bright | 255 | 255 - Bright
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDLUMINANCECONTRASCOMPONENTPART0 Enumeration

IRD

Saa7118TYPIDLUMINANCECONTRASCOMPONENTPART0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDLUMINANCECONTRASCOMPONENTPART0
Public Enumeration TYPIDLUMINANCECONTRASCOMPONENTPART0
public enum class TYPIDLUMINANCECONTRASCOMPONENTPART0
type TYPIDLUMINANCECONTRASCOMPONENTPART0
Members
Member name | Value | Description
Value_0Off | 0 | 0 (off)
Value_0_015625 | 1 | 0.015625
Value_0_03125 | 2 | 0.03125
Value_0_046875 | 3 | 0.046875
Value_0_0625 | 4 | 0.0625
Value_0_078125 | 5 | 0.078125
Value_0_09375 | 6 | 0.09375
Value_0_109375 | 7 | 0.109375
Value_0_125 | 8 | 0.125
Value_0_140625 | 9 | 0.140625
Value_0_15625 | 10 | 0.15625
Value_0_171875 | 11 | 0.171875
Value_0_1875 | 12 | 0.1875
Value_0_203125 | 13 | 0.203125
Value_0_21875 | 14 | 0.21875
Value_0_234375 | 15 | 0.234375
Value_0_25 | 16 | 0.25
Value_0_265625 | 17 | 0.265625
Value_0_28125 | 18 | 0.28125
Value_0_296875 | 19 | 0.296875
Value_0_3125 | 20 | 0.3125
Value_0_328125 | 21 | 0.328125
Value_0_34375 | 22 | 0.34375
Value_0_359375 | 23 | 0.359375
Value_0_375 | 24 | 0.375
Value_0_390625 | 25 | 0.390625
Value_0_40625 | 26 | 0.40625
Value_0_421875 | 27 | 0.421875
Value_0_4375 | 28 | 0.4375
Value_0_453125 | 29 | 0.453125
Value_0_46875 | 30 | 0.46875
Value_0_484375 | 31 | 0.484375
Value_0_5 | 32 | 0.5
Value_0_515625 | 33 | 0.515625
Value_0_53125 | 34 | 0.53125
Value_0_546875 | 35 | 0.546875
Value_0_5625 | 36 | 0.5625
Value_0_578125 | 37 | 0.578125
Value_0_59375 | 38 | 0.59375
Value_0_609375 | 39 | 0.609375
Value_0_625 | 40 | 0.625
Value_0_640625 | 41 | 0.640625
Value_0_65625 | 42 | 0.65625
Value_0_671875 | 43 | 0.671875
Value_0_6875 | 44 | 0.6875
Value_0_703125 | 45 | 0.703125
Value_0_71875 | 46 | 0.71875
Value_0_734375 | 47 | 0.734375
Value_0_75 | 48 | 0.75
Value_0_765625 | 49 | 0.765625
Value_0_78125 | 50 | 0.78125
Value_0_796875 | 51 | 0.796875
Value_0_8125 | 52 | 0.8125
Value_0_828125 | 53 | 0.828125
Value_0_84375 | 54 | 0.84375
Value_0_859375 | 55 | 0.859375
Value_0_875 | 56 | 0.875
Value_0_890625 | 57 | 0.890625
Value_0_90625 | 58 | 0.90625
Value_0_921875 | 59 | 0.921875
Value_0_9375 | 60 | 0.9375
Value_0_953125 | 61 | 0.953125
Value_0_96875 | 62 | 0.96875
Value_0_984375 | 63 | 0.984375
Value_10ITULevel | 64 | 1.0 (ITU level)
Value_1_015625 | 65 | 1.015625
Value_1_03125 | 66 | 1.03125
Value_1_046875 | 67 | 1.046875
Value_1_0625 | 68 | 1.0625
Value_1_078125 | 69 | 1.078125
Value_1_09375 | 70 | 1.09375
Value_1_109375 | 71 | 1.109375
Value_1_125 | 72 | 1.125
Value_1_140625 | 73 | 1.140625
Value_1_15625 | 74 | 1.15625
Value_1_171875 | 75 | 1.171875
Value_1_1875 | 76 | 1.1875
Value_1_203125 | 77 | 1.203125
Value_1_21875 | 78 | 1.21875
Value_1_234375 | 79 | 1.234375
Value_1_25 | 80 | 1.25
Value_1_265625 | 81 | 1.265625
Value_1_28125 | 82 | 1.28125
Value_1_296875 | 83 | 1.296875
Value_1_3125 | 84 | 1.3125
Value_1_328125 | 85 | 1.328125
Value_1_34375 | 86 | 1.34375
Value_1_359375 | 87 | 1.359375
Value_1_375 | 88 | 1.375
Value_1_390625 | 89 | 1.390625
Value_1_40625 | 90 | 1.40625
Value_1_421875 | 91 | 1.421875
Value_1_4375 | 92 | 1.4375
Value_1_453125 | 93 | 1.453125
Value_1_46875 | 94 | 1.46875
Value_1_484375 | 95 | 1.484375
Value_1_5 | 96 | 1.5
Value_1_515625 | 97 | 1.515625
Value_1_53125 | 98 | 1.53125
Value_1_546875 | 99 | 1.546875
Value_1_5625 | 100 | 1.5625
Value_1_578125 | 101 | 1.578125
Value_1_59375 | 102 | 1.59375
Value_1_609375 | 103 | 1.609375
Value_1_625 | 104 | 1.625
Value_1_640625 | 105 | 1.640625
Value_1_65625 | 106 | 1.65625
Value_1_671875 | 107 | 1.671875
Value_1_6875 | 108 | 1.6875
Value_1_703125 | 109 | 1.703125
Value_1_71875 | 110 | 1.71875
Value_1_734375 | 111 | 1.734375
Value_1_75 | 112 | 1.75
Value_1_765625 | 113 | 1.765625
Value_1_78125 | 114 | 1.78125
Value_1_796875 | 115 | 1.796875
Value_1_8125 | 116 | 1.8125
Value_1_828125 | 117 | 1.828125
Value_1_84375 | 118 | 1.84375
Value_1_859375 | 119 | 1.859375
Value_1_875 | 120 | 1.875
Value_1_890625 | 121 | 1.890625
Value_1_90625 | 122 | 1.90625
Value_1_921875 | 123 | 1.921875
Value_1_9375 | 124 | 1.9375
Value_1_953125 | 125 | 1.953125
Value_1_96875 | 126 | 1.96875
Value_1984Maximum | 127 | 1.984 (maximum)
Value_2Inverse | -128 | -2 (inverse)
Value_1984375Inverse | -127 | -1.984375 (inverse)
Value_196875Inverse | -126 | -1.96875 (inverse)
Value_1953125Inverse | -125 | -1.953125 (inverse)
Value_19375Inverse | -124 | -1.9375 (inverse)
Value_1921875Inverse | -123 | -1.921875 (inverse)
Value_190625Inverse | -122 | -1.90625 (inverse)
Value_1890625Inverse | -121 | -1.890625 (inverse)
Value_1875Inverse | -120 | -1.875 (inverse)
Value_1859375Inverse | -119 | -1.859375 (inverse)
Value_184375Inverse | -118 | -1.84375 (inverse)
Value_1828125Inverse | -117 | -1.828125 (inverse)
Value_18125Inverse | -116 | -1.8125 (inverse)
Value_1796875Inverse | -115 | -1.796875 (inverse)
Value_178125Inverse | -114 | -1.78125 (inverse)
Value_1765625Inverse | -113 | -1.765625 (inverse)
Value_175Inverse | -112 | -1.75 (inverse)
Value_1734375Inverse | -111 | -1.734375 (inverse)
Value_171875Inverse | -110 | -1.71875 (inverse)
Value_1703125Inverse | -109 | -1.703125 (inverse)
Value_16875Inverse | -108 | -1.6875 (inverse)
Value_1671875Inverse | -107 | -1.671875 (inverse)
Value_165625Inverse | -106 | -1.65625 (inverse)
Value_1640625Inverse | -105 | -1.640625 (inverse)
Value_1625Inverse | -104 | -1.625 (inverse)
Value_1609375Inverse | -103 | -1.609375 (inverse)
Value_159375Inverse | -102 | -1.59375 (inverse)
Value_1578125Inverse | -101 | -1.578125 (inverse)
Value_15625Inverse | -100 | -1.5625 (inverse)
Value_1546875Inverse | -99 | -1.546875 (inverse)
Value_153125Inverse | -98 | -1.53125 (inverse)
Value_1515625Inverse | -97 | -1.515625 (inverse)
Value_15Inverse | -96 | -1.5 (inverse)
Value_1484375Inverse | -95 | -1.484375 (inverse)
Value_146875Inverse | -94 | -1.46875 (inverse)
Value_1453125Inverse | -93 | -1.453125 (inverse)
Value_14375Inverse | -92 | -1.4375 (inverse)
Value_1421875Inverse | -91 | -1.421875 (inverse)
Value_140625Inverse | -90 | -1.40625 (inverse)
Value_1390625Inverse | -89 | -1.390625 (inverse)
Value_1375Inverse | -88 | -1.375 (inverse)
Value_1359375Inverse | -87 | -1.359375 (inverse)
Value_134375Inverse | -86 | -1.34375 (inverse)
Value_1328125Inverse | -85 | -1.328125 (inverse)
Value_13125Inverse | -84 | -1.3125 (inverse)
Value_1296875Inverse | -83 | -1.296875 (inverse)
Value_128125Inverse | -82 | -1.28125 (inverse)
Value_1265625Inverse | -81 | -1.265625 (inverse)
Value_125Inverse | -80 | -1.25 (inverse)
Value_1234375Inverse | -79 | -1.234375 (inverse)
Value_121875Inverse | -78 | -1.21875 (inverse)
Value_1203125Inverse | -77 | -1.203125 (inverse)
Value_11875Inverse | -76 | -1.1875 (inverse)
Value_1171875Inverse | -75 | -1.171875 (inverse)
Value_115625Inverse | -74 | -1.15625 (inverse)
Value_1140625Inverse | -73 | -1.140625 (inverse)
Value_1125Inverse | -72 | -1.125 (inverse)
Value_1109375Inverse | -71 | -1.109375 (inverse)
Value_109375Inverse | -70 | -1.09375 (inverse)
Value_1078125Inverse | -69 | -1.078125 (inverse)
Value_10625Inverse | -68 | -1.0625 (inverse)
Value_1046875Inverse | -67 | -1.046875 (inverse)
Value_103125Inverse | -66 | -1.03125 (inverse)
Value_1015625Inverse | -65 | -1.015625 (inverse)
Value_1Inverse | -64 | -1 (inverse)
Value_0984375Inverse | -63 | -0.984375 (inverse)
Value_096875Inverse | -62 | -0.96875 (inverse)
Value_0953125Inverse | -61 | -0.953125 (inverse)
Value_09375Inverse | -60 | -0.9375 (inverse)
Value_0921875Inverse | -59 | -0.921875 (inverse)
Value_090625Inverse | -58 | -0.90625 (inverse)
Value_0890625Inverse | -57 | -0.890625 (inverse)
Value_0875Inverse | -56 | -0.875 (inverse)
Value_0859375Inverse | -55 | -0.859375 (inverse)
Value_084375Inverse | -54 | -0.84375 (inverse)
Value_0828125Inverse | -53 | -0.828125 (inverse)
Value_08125Inverse | -52 | -0.8125 (inverse)
Value_0796875Inverse | -51 | -0.796875 (inverse)
Value_078125Inverse | -50 | -0.78125 (inverse)
Value_0765625Inverse | -49 | -0.765625 (inverse)
Value_075Inverse | -48 | -0.75 (inverse)
Value_0734375Inverse | -47 | -0.734375 (inverse)
Value_071875Inverse | -46 | -0.71875 (inverse)
Value_0703125Inverse | -45 | -0.703125 (inverse)
Value_06875Inverse | -44 | -0.6875 (inverse)
Value_0671875Inverse | -43 | -0.671875 (inverse)
Value_065625Inverse | -42 | -0.65625 (inverse)
Value_0640625Inverse | -41 | -0.640625 (inverse)
Value_0625Inverse | -40 | -0.625 (inverse)
Value_0609375Inverse | -39 | -0.609375 (inverse)
Value_059375Inverse | -38 | -0.59375 (inverse)
Value_0578125Inverse | -37 | -0.578125 (inverse)
Value_05625Inverse | -36 | -0.5625 (inverse)
Value_0546875Inverse | -35 | -0.546875 (inverse)
Value_053125Inverse | -34 | -0.53125 (inverse)
Value_0515625Inverse | -33 | -0.515625 (inverse)
Value_05Inverse | -32 | -0.5 (inverse)
Value_0484375Inverse | -31 | -0.484375 (inverse)
Value_046875Inverse | -30 | -0.46875 (inverse)
Value_0453125Inverse | -29 | -0.453125 (inverse)
Value_04375Inverse | -28 | -0.4375 (inverse)
Value_0421875Inverse | -27 | -0.421875 (inverse)
Value_040625Inverse | -26 | -0.40625 (inverse)
Value_0390625Inverse | -25 | -0.390625 (inverse)
Value_0375Inverse | -24 | -0.375 (inverse)
Value_0359375Inverse | -23 | -0.359375 (inverse)
Value_034375Inverse | -22 | -0.34375 (inverse)
Value_0328125Inverse | -21 | -0.328125 (inverse)
Value_03125Inverse | -20 | -0.3125 (inverse)
Value_0296875Inverse | -19 | -0.296875 (inverse)
Value_028125Inverse | -18 | -0.28125 (inverse)
Value_0265625Inverse | -17 | -0.265625 (inverse)
Value_025Inverse | -16 | -0.25 (inverse)
Value_0234375Inverse | -15 | -0.234375 (inverse)
Value_021875Inverse | -14 | -0.21875 (inverse)
Value_0203125Inverse | -13 | -0.203125 (inverse)
Value_01875Inverse | -12 | -0.1875 (inverse)
Value_0171875Inverse | -11 | -0.171875 (inverse)
Value_015625Inverse | -10 | -0.15625 (inverse)
Value_0140625Inverse | -9 | -0.140625 (inverse)
Value_0125Inverse | -8 | -0.125 (inverse)
Value_0109375Inverse | -7 | -0.109375 (inverse)
Value_009375Inverse | -6 | -0.09375 (inverse)
Value_0078125Inverse | -5 | -0.078125 (inverse)
Value_00625Inverse | -4 | -0.0625 (inverse)
Value_0046875Inverse | -3 | -0.046875 (inverse)
Value_003125Inverse | -2 | -0.03125 (inverse)
Value_0015625Inverse | -1 | -0.015625 (inverse)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDLUMINANCECONTRASLDECODERPART0 Enumeration

IRD

Saa7118TYPIDLUMINANCECONTRASLDECODERPART0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDLUMINANCECONTRASLDECODERPART0
Public Enumeration TYPIDLUMINANCECONTRASLDECODERPART0
public enum class TYPIDLUMINANCECONTRASLDECODERPART0
type TYPIDLUMINANCECONTRASLDECODERPART0
Members
Member name | Value | Description
Value_0Off | 0 | 0 (off)
Value_1063ITULevel | 64 | 1.063 (ITU level)
Value_1984Maximum | 127 | 1.984 (maximum)
Value_M_2 | -128 | -2
Value_M_1 | -64 | -1
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDLUMINANCECONTROL0 Enumeration

IRD

Saa7118TYPIDLUMINANCECONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDLUMINANCECONTROL0
Public Enumeration TYPIDLUMINANCECONTROL0
public enum class TYPIDLUMINANCECONTROL0
type TYPIDLUMINANCECONTROL0
Members
Member name | Value | Description
Plain | 0 | Plain
ResEnhFilter80DB41MHz | 1 | Res. enh. filter: 8.0 dB/4.1 MHz
ResEnhFilter68DB41MHz | 2 | Res. enh. filter: 6.8 dB/4.1 MHz
ResEnhFilter51DB41MHz | 3 | Res. enh. filter: 5.1 dB/4.1 MHz
ResEnhFilter41DB41MHz | 4 | Res. enh. filter: 4.1 dB/4.1 MHz
ResEnhFilter30DB41MHz | 5 | Res. enh. filter: 3.0 dB/4.1 MHz
ResEnhFilter23DB41MHz | 6 | Res. enh. filter: 2.3 dB/4.1 MHz
ResEnhFilter16DB41MHz | 7 | Res. enh. filter: 1.6 dB/4.1 MHz
LowPassFilter2Db41MHz | 8 | Low pass filter 2 db/4.1 MHz
LowPassFilter3Db41MHz | 9 | Low pass filter 3 db/4.1 MHz
LowPassFilter3Db33MHz4DB41MHz | 10 | Low pass filter 3 db/3.3 MHz / 4 dB/4.1 MHz
LowPassFilter3Db26MHz8DB41MHz | 11 | Low pass filter 3 db/2.6 MHz / 8 dB/4.1 MHz
LowPassFilter3Db24MHz14DB41MHz | 12 | Low pass filter 3 db/2.4 MHz / 14 dB/4.1 MHz
LowPassFilter3Db22MHzNotchAt34MHz | 13 | Low pass filter 3 db/2.2 MHz / notch at 3.4 MHz
LowPassFilter3Db19MHzNotchAt30MHz | 14 | Low pass filter 3 db/1.9 MHz / notch at 3.0 MHz
LowPassFilter3Db17MHzNotchAt25MHz | 15 | Low pass filter 3 db/1.7 MHz / notch at 2.5 MHz
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDLUMINANCECONTROL1 Enumeration

IRD

Saa7118TYPIDLUMINANCECONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDLUMINANCECONTROL1
Public Enumeration TYPIDLUMINANCECONTROL1
public enum class TYPIDLUMINANCECONTROL1
type TYPIDLUMINANCECONTROL1
Members
Member name | Value | Description
SmallBandwidth | 0 | Small bandwidth
LargeBandwidth | 1 | Large bandwidth
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDLUMINANCECONTROL2 Enumeration

IRD

Saa7118TYPIDLUMINANCECONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDLUMINANCECONTROL2
Public Enumeration TYPIDLUMINANCECONTROL2
public enum class TYPIDLUMINANCECONTROL2
type TYPIDLUMINANCECONTROL2
Members
Member name | Value | Description
EqualToInternalPipeliningDelay | 0 | Equal to internal pipelining delay
OneNTSCStandardsOrTwoPALStandardsVideoLinesAdditionalProcessingDelay | 1 | One (NTSC standards) or two (PAL standards) video lines additional processing delay
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDLUMINANCECONTROL3 Enumeration

IRD

Saa7118TYPIDLUMINANCECONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDLUMINANCECONTROL3
Public Enumeration TYPIDLUMINANCECONTROL3
public enum class TYPIDLUMINANCECONTROL3
type TYPIDLUMINANCECONTROL3
Members
Member name | Value | Description
Disabled | 0 | Disabled
Active | 1 | Active
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDLUMINANCECONTROL4 Enumeration

IRD

Saa7118TYPIDLUMINANCECONTROL4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDLUMINANCECONTROL4
Public Enumeration TYPIDLUMINANCECONTROL4
public enum class TYPIDLUMINANCECONTROL4
type TYPIDLUMINANCECONTROL4
Members
Member name | Value | Description
Active | 0 | Active
Bypassed | 1 | Bypassed
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDMISCELLANEOUSVGATEMSBS0 Enumeration

IRD

Saa7118TYPIDMISCELLANEOUSVGATEMSBS0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMISCELLANEOUSVGATEMSBS0
Public Enumeration TYPIDMISCELLANEOUSVGATEMSBS0
public enum class TYPIDMISCELLANEOUSVGATEMSBS0
type TYPIDMISCELLANEOUSVGATEMSBS0
Members
Member name | Value | Description
VGATEPositionAccordingVGATEStartStop | 0 | VGATE position according VGATE start/stop
VGATEOccursOneLineEarlier | 1 | VGATE occurs one line earlier
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDMISCELLANEOUSVGATEMSBS1 Enumeration

IRD

Saa7118TYPIDMISCELLANEOUSVGATEMSBS1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMISCELLANEOUSVGATEMSBS1
Public Enumeration TYPIDMISCELLANEOUSVGATEMSBS1
public enum class TYPIDMISCELLANEOUSVGATEMSBS1
type TYPIDMISCELLANEOUSVGATEMSBS1
Members
Member name | Value | Description
Reserved | 0 | Reserved
OneFields | 1 | One fields
TwoFields | 2 | Two fields
ThreeFields | 3 | Three fields
FourFields | 4 | Four fields
FiveFields | 5 | Five fields
SixFields | 6 | Six fields
SevenFields | 7 | Seven fields
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDMISCELLANEOUSVGATEMSBS2 Enumeration

IRD

Saa7118TYPIDMISCELLANEOUSVGATEMSBS2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMISCELLANEOUSVGATEMSBS2
Public Enumeration TYPIDMISCELLANEOUSVGATEMSBS2
public enum class TYPIDMISCELLANEOUSVGATEMSBS2
type TYPIDMISCELLANEOUSVGATEMSBS2
Members
Member name | Value | Description
Enable | 0 | Enable
Value_3State | 1 | 3-state
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDMODEDELAYCONTROL1 Enumeration

IRD

Saa7118TYPIDMODEDELAYCONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMODEDELAYCONTROL1
Public Enumeration TYPIDMODEDELAYCONTROL1
public enum class TYPIDMODEDELAYCONTROL1
type TYPIDMODEDELAYCONTROL1
Members
Member name | Value | Description
NonInverted | 0 | Non-inverted
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDMODEDELAYCONTROL4 Enumeration

IRD

Saa7118TYPIDMODEDELAYCONTROL4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMODEDELAYCONTROL4
Public Enumeration TYPIDMODEDELAYCONTROL4
public enum class TYPIDMODEDELAYCONTROL4
type TYPIDMODEDELAYCONTROL4
Members
Member name | Value | Description
AutomaticColourKillerEnabled | 0 | Automatic colour killer enabled
ColourForcedOn | 1 | Colour forced on
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDPOWERSAVECONTRODCPORTCONTROL0 Enumeration

IRD

Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDPOWERSAVECONTRODCPORTCONTROL0
Public Enumeration TYPIDPOWERSAVECONTRODCPORTCONTROL0
public enum class TYPIDPOWERSAVECONTRODCPORTCONTROL0
type TYPIDPOWERSAVECONTRODCPORTCONTROL0
Members
Member name | Value | Description
OperationalMode | 0 | Operational mode
PowerDownMode | 1 | Power-down mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDPOWERSAVECONTRODCPORTCONTROL2 Enumeration

IRD

Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDPOWERSAVECONTRODCPORTCONTROL2
Public Enumeration TYPIDPOWERSAVECONTRODCPORTCONTROL2
public enum class TYPIDPOWERSAVECONTRODCPORTCONTROL2
type TYPIDPOWERSAVECONTRODCPORTCONTROL2
Members
Member name | Value | Description
Active | 0 | Active
PowerDownAndOutputDisabled | 1 | Power-down and output disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDPOWERSAVECONTRODCPORTCONTROL3 Enumeration

IRD

Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDPOWERSAVECONTRODCPORTCONTROL3
Public Enumeration TYPIDPOWERSAVECONTRODCPORTCONTROL3
public enum class TYPIDPOWERSAVECONTRODCPORTCONTROL3
type TYPIDPOWERSAVECONTRODCPORTCONTROL3
Members
Member name | Value | Description
Value_0AfterReset | 0 | =0: After reset
Value_1CanBeUsedToAssignThatTheDeviceHasBeenProgrammed | 1 | =1 Can be used to assign that the device has been programmed
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDPOWERSAVECONTRODCPORTCONTROL4 Enumeration

IRD

Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDPOWERSAVECONTRODCPORTCONTROL4
Public Enumeration TYPIDPOWERSAVECONTRODCPORTCONTROL4
public enum class TYPIDPOWERSAVECONTRODCPORTCONTROL4
type TYPIDPOWERSAVECONTRODCPORTCONTROL4
Members
Member name | Value | Description
ScalerPathIsResetToItsIdleStateSoftwareReset | 0 | Scaler path is reset to its idle state, software reset
ScalerIsSwitchedBackToOperation | 1 | Scaler is switched back to operation
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDPOWERSAVECONTRODCPORTCONTROL5 Enumeration

IRD

Saa7118TYPIDPOWERSAVECONTRODCPORTCONTROL5 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDPOWERSAVECONTRODCPORTCONTROL5
Public Enumeration TYPIDPOWERSAVECONTRODCPORTCONTROL5
public enum class TYPIDPOWERSAVECONTRODCPORTCONTROL5
type TYPIDPOWERSAVECONTRODCPORTCONTROL5
Members
Member name | Value | Description
DigitizedADC1SignalIsFedToPortADP | 0 | Digitized ADC1 signal is fed to port ADP
DigitizedADC2SignalIsFedToPortADP | 1 | Digitized ADC2 signal is fed to port ADP
DigitizedADC3SignalIsFedToPortADP | 2 | Digitized ADC3 signal is fed to port ADP
DigitizedADC4SignalIsFedToPortADP | 3 | Digitized ADC4 signal is fed to port ADP
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDRAWDATAGAINCONTROL0 Enumeration

IRD

Saa7118TYPIDRAWDATAGAINCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDRAWDATAGAINCONTROL0
Public Enumeration TYPIDRAWDATAGAINCONTROL0
public enum class TYPIDRAWDATAGAINCONTROL0
type TYPIDRAWDATAGAINCONTROL0
Members
Member name | Value | Description
Value_0Off | 0 | 0 - off
Value_128NominalLevel | 128 | 128 - nominal level
Value_255DoubleAmplitude | 255 | 255 - double amplitude
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 Enumeration

IRD

Saa7118TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0
Public Enumeration TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0
public enum class TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0
type TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0
Members
Member name | Value | Description
Value_3State | 0 | 3-state
ConstantLOW | 1 | Constant LOW
CREF135MHzTogglingPulse | 2 | CREF (13.5 MHz toggling pulse)
CREF2675MHzTogglingPulse | 3 | CREF2 (6.75 MHz toggling pulse)
HorizontalLockIndicator | 4 | Horizontal lock indicator
VerticalHorizontalLock | 5 | Vertical/horizontal lock
VerticalHorizontalLockColourDetected | 6 | Vertical/horizontal lock/colour detected
Reserved | 7 | Reserved
HREFHorizontalReferenceSignal | 8 | HREF, horizontal reference signal
ProgrammableWidthInLLC8Steps | 9 | Programmable width in LLC8 steps
HREFGatedWithVGATE | 10 | HREF gated with VGATE
Reserved__1 | 11 | Reserved
V123VerticalSync | 12 | V123: vertical sync
VGATEProgrammable | 13 | VGATE: programmable
LSBsOfThe9BitADCS | 14 | LSBs of the 9-bit ADC's
FIDPositionProgrammable | 15 | FID position programmable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDRTXPORTOUTPUTCONTROL0 Enumeration

IRD

Saa7118TYPIDRTXPORTOUTPUTCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDRTXPORTOUTPUTCONTROL0
Public Enumeration TYPIDRTXPORTOUTPUTCONTROL0
public enum class TYPIDRTXPORTOUTPUTCONTROL0
type TYPIDRTXPORTOUTPUTCONTROL0
Members
Member name | Value | Description
ITU656 | 0 | ITU 656
ITU656LikeFormatWithModifiedFieldBlanking | 1 | ITU 656 like format with modified field blanking
YCBCR4228BitFormat | 2 | Y-CB-CR 4:2:2 8-bit format
Reserved | 3 | Reserved
MultiplexedAD2AD1OrAD4AD3BypassBitsD8ToD1 | 4 | Multiplexed AD2/AD1 or AD4/AD3 bypass (bits D8 to D1)
MultiplexedAD2AD1OrAD4AD3BypassBitsD7ToD0 | 5 | Multiplexed AD2/AD1 or AD4/AD3 bypass (bits D7 to D0)
Reserved__1 | 6 | Reserved
MultiplexedADCMSBLSBBypass | 7 | Multiplexed ADC MSB/LSB bypass
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDRTXPORTOUTPUTCONTROL1 Enumeration

IRD

Saa7118TYPIDRTXPORTOUTPUTCONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDRTXPORTOUTPUTCONTROL1
Public Enumeration TYPIDRTXPORTOUTPUTCONTROL1
public enum class TYPIDRTXPORTOUTPUTCONTROL1
type TYPIDRTXPORTOUTPUTCONTROL1
Members
Member name | Value | Description
CopyOfInvertedHLCKStatusBit | 0 | Copy of inverted HLCK status bit
FastHorizontalLockIndicator | 1 | Fast horizontal lock indicator
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDRTXPORTOUTPUTCONTROL2 Enumeration

IRD

Saa7118TYPIDRTXPORTOUTPUTCONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDRTXPORTOUTPUTCONTROL2
Public Enumeration TYPIDRTXPORTOUTPUTCONTROL2
public enum class TYPIDRTXPORTOUTPUTCONTROL2
type TYPIDRTXPORTOUTPUTCONTROL2
Members
Member name | Value | Description
V123 | 0 | V123
ITU656RelatedFieldID | 1 | ITU 656 related field ID
InvertedV123 | 2 | Inverted V123
InvertedITU656RelatedFieldID | 3 | Inverted ITU 656 related field ID
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDRTXPORTOUTPUTCONTROL3 Enumeration

IRD

Saa7118TYPIDRTXPORTOUTPUTCONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDRTXPORTOUTPUTCONTROL3
Public Enumeration TYPIDRTXPORTOUTPUTCONTROL3
public enum class TYPIDRTXPORTOUTPUTCONTROL3
type TYPIDRTXPORTOUTPUTCONTROL3
Members
Member name | Value | Description
HREF | 0 | HREF
ProgrammableWidthInLLC8Steps | 1 | Programmable width in LLC8 steps
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDRTXPORTOUTPUTCONTROL4 Enumeration

IRD

Saa7118TYPIDRTXPORTOUTPUTCONTROL4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDRTXPORTOUTPUTCONTROL4
Public Enumeration TYPIDRTXPORTOUTPUTCONTROL4
public enum class TYPIDRTXPORTOUTPUTCONTROL4
type TYPIDRTXPORTOUTPUTCONTROL4
Members
Member name | Value | Description
Value_3State | 0 | 3-state
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSLICERBYTE20 Enumeration

IRD

Saa7118TYPIDSLICERBYTE20 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSLICERBYTE20
Public Enumeration TYPIDSLICERBYTE20
public enum class TYPIDSLICERBYTE20
type TYPIDSLICERBYTE20
Members
Member name | Value | Description
TeletextEuroWSTCCST | 0 | Teletext EuroWST, CCST
EuropeanClosedCaption | 1 | European closed caption
VPS | 2 | VPS
WideScreenSignallingBits | 3 | Wide screen signalling bits
USTeletextWST | 4 | US teletext (WST)
USClosedCaptionLine21 | 5 | US closed caption (line 21)
VideoDataSelected | 6 | (video data selected)
RawDataSelected | 7 | (raw data selected)
Teletext | 8 | Teletext
VITCEBUTimeCodesEurope | 9 | VITC/EBU time codes (Europe)
VITCSMPTETimeCodesUSA | 10 | VITC/SMPTE time codes (USA)
Reserved | 11 | Reserved
USNABTS | 12 | US NABTS
MOJIJapanese | 13 | MOJI (Japanese)
JapaneseFormatSwitch | 14 | Japanese format switch
NoSlicedDataTransmitted | 15 | No sliced data transmitted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSLICERCONTROL10 Enumeration

IRD

Saa7118TYPIDSLICERCONTROL10 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSLICERCONTROL10
Public Enumeration TYPIDSLICERCONTROL10
public enum class TYPIDSLICERCONTROL10
type TYPIDSLICERCONTROL10
Members
Member name | Value | Description
AmplitudeSearchingActive | 0 | Amplitude searching active
AmplitudeSearchingStopped | 1 | Amplitude searching stopped
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSLICERCONTROL11 Enumeration

IRD

Saa7118TYPIDSLICERCONTROL11 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSLICERCONTROL11
Public Enumeration TYPIDSLICERCONTROL11
public enum class TYPIDSLICERCONTROL11
type TYPIDSLICERCONTROL11
Members
Member name | Value | Description
OneFramingCodeErrorAllowed | 0 | One framing code error allowed
NoFramingCodeErrorsAllowed | 1 | No framing code errors allowed
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSLICERCONTROL12 Enumeration

IRD

Saa7118TYPIDSLICERCONTROL12 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSLICERCONTROL12
Public Enumeration TYPIDSLICERCONTROL12
public enum class TYPIDSLICERCONTROL12
type TYPIDSLICERCONTROL12
Members
Member name | Value | Description
HammingCheckFor2BytesAfterFramingCodeDependentOnDataType | 0 | Hamming check for 2 bytes after framing code, dependent on data type
NoHammingCheck | 1 | No Hamming check
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSLICERSTATUSBYTE00 Enumeration

IRD

Saa7118TYPIDSLICERSTATUSBYTE00 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSLICERSTATUSBYTE00
Public Enumeration TYPIDSLICERSTATUSBYTE00
public enum class TYPIDSLICERSTATUSBYTE00
type TYPIDSLICERSTATUSBYTE00
Members
Member name | Value | Description
NoClosedCaptionInTheLastFrame | 0 | No closed caption in the last frame
ClosedCaptionDetected | 1 | Closed caption detected
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSLICERSTATUSBYTE01 Enumeration

IRD

Saa7118TYPIDSLICERSTATUSBYTE01 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSLICERSTATUSBYTE01
Public Enumeration TYPIDSLICERSTATUSBYTE01
public enum class TYPIDSLICERSTATUSBYTE01
type TYPIDSLICERSTATUSBYTE01
Members
Member name | Value | Description
NoPALplusInTheLastFrame | 0 | No PALplus in the last frame
PALplusDetected | 1 | PALplus detected
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSLICERSTATUSBYTE02 Enumeration

IRD

Saa7118TYPIDSLICERSTATUSBYTE02 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSLICERSTATUSBYTE02
Public Enumeration TYPIDSLICERSTATUSBYTE02
public enum class TYPIDSLICERSTATUSBYTE02
type TYPIDSLICERSTATUSBYTE02
Members
Member name | Value | Description
NoVPSInTheLastFrame | 0 | No VPS in the last frame
VPSDetected | 1 | VPS detected
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSLICERSTATUSBYTE03 Enumeration

IRD

Saa7118TYPIDSLICERSTATUSBYTE03 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSLICERSTATUSBYTE03
Public Enumeration TYPIDSLICERSTATUSBYTE03
public enum class TYPIDSLICERSTATUSBYTE03
type TYPIDSLICERSTATUSBYTE03
Members
Member name | Value | Description
NoFramingCode1ErrorInTheLastFrameDetected | 0 | No framing code (1 error) in the last frame detected
FramingCodeWith1ErrorDetected | 1 | Framing code with 1 error detected
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSLICERSTATUSBYTE04 Enumeration

IRD

Saa7118TYPIDSLICERSTATUSBYTE04 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSLICERSTATUSBYTE04
Public Enumeration TYPIDSLICERSTATUSBYTE04
public enum class TYPIDSLICERSTATUSBYTE04
type TYPIDSLICERSTATUSBYTE04
Members
Member name | Value | Description
NoFramingCode0ErrorInTheLastFrameDetected | 0 | No framing code (0 error) in the last frame detected
FramingCodeWith0ErrorDetected | 1 | Framing code with 0 error detected
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSTATUSBYTE1VIDEODECODER0 Enumeration

IRD

Saa7118TYPIDSTATUSBYTE1VIDEODECODER0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSTATUSBYTE1VIDEODECODER0
Public Enumeration TYPIDSTATUSBYTE1VIDEODECODER0
public enum class TYPIDSTATUSBYTE1VIDEODECODER0
type TYPIDSTATUSBYTE1VIDEODECODER0
Members
Member name | Value | Description
NoColour | 0 | No colour
NTSC | 1 | NTSC
PAL | 2 | PAL
SECAM | 3 | SECAM
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSTATUSBYTE1VIDEODECODER5 Enumeration

IRD

Saa7118TYPIDSTATUSBYTE1VIDEODECODER5 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSTATUSBYTE1VIDEODECODER5
Public Enumeration TYPIDSTATUSBYTE1VIDEODECODER5
public enum class TYPIDSTATUSBYTE1VIDEODECODER5
type TYPIDSTATUSBYTE1VIDEODECODER5
Members
Member name | Value | Description
Locked | 0 | Locked
Unlocked | 1 | Unlocked
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSTATUSBYTE2VIDEODECODER4 Enumeration

IRD

Saa7118TYPIDSTATUSBYTE2VIDEODECODER4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSTATUSBYTE2VIDEODECODER4
Public Enumeration TYPIDSTATUSBYTE2VIDEODECODER4
public enum class TYPIDSTATUSBYTE2VIDEODECODER4
type TYPIDSTATUSBYTE2VIDEODECODER4
Members
Member name | Value | Description
Value_50Hz | 0 | 50 Hz
Value_60Hz | 1 | 60 Hz
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSTATUSBYTE2VIDEODECODER5 Enumeration

IRD

Saa7118TYPIDSTATUSBYTE2VIDEODECODER5 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSTATUSBYTE2VIDEODECODER5
Public Enumeration TYPIDSTATUSBYTE2VIDEODECODER5
public enum class TYPIDSTATUSBYTE2VIDEODECODER5
type TYPIDSTATUSBYTE2VIDEODECODER5
Members
Member name | Value | Description
BothLoopsLocked | 0 | Both loops locked
Unlocked | 1 | Unlocked
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSTATUSBYTE2VIDEODECODER6 Enumeration

IRD

Saa7118TYPIDSTATUSBYTE2VIDEODECODER6 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSTATUSBYTE2VIDEODECODER6
Public Enumeration TYPIDSTATUSBYTE2VIDEODECODER6
public enum class TYPIDSTATUSBYTE2VIDEODECODER6
type TYPIDSTATUSBYTE2VIDEODECODER6
Members
Member name | Value | Description
NonInterlaced | 0 | Non-interlaced
Interlaced | 1 | Interlaced
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSYNCCONTROL0 Enumeration

IRD

Saa7118TYPIDSYNCCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSYNCCONTROL0
Public Enumeration TYPIDSYNCCONTROL0
public enum class TYPIDSYNCCONTROL0
type TYPIDSYNCCONTROL0
Members
Member name | Value | Description
NormalMode | 0 | Normal mode
FastMode | 1 | Fast mode
FreeRunningMode | 2 | Free running mode
VerticalNoiseReductionBypassed | 3 | Vertical noise reduction bypassed
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSYNCCONTROL1 Enumeration

IRD

Saa7118TYPIDSYNCCONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSYNCCONTROL1
Public Enumeration TYPIDSYNCCONTROL1
public enum class TYPIDSYNCCONTROL1
type TYPIDSYNCCONTROL1
Members
Member name | Value | Description
PLLClosed | 0 | PLL closed
PLLOpen | 1 | PLL open
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSYNCCONTROL2 Enumeration

IRD

Saa7118TYPIDSYNCCONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSYNCCONTROL2
Public Enumeration TYPIDSYNCCONTROL2
public enum class TYPIDSYNCCONTROL2
type TYPIDSYNCCONTROL2
Members
Member name | Value | Description
TVMode | 0 | TV mode
VTRMode | 1 | VTR mode
Reserved | 2 | Reserved
FastLockingMode | 3 | Fast locking mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSYNCCONTROL3 Enumeration

IRD

Saa7118TYPIDSYNCCONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSYNCCONTROL3
Public Enumeration TYPIDSYNCCONTROL3
public enum class TYPIDSYNCCONTROL3
type TYPIDSYNCCONTROL3
Members
Member name | Value | Description
WithInterlacedSource | 0 | With interlaced source
FieldwiseEvenIfSourceIsNonInterlaced | 1 | Fieldwise even if source is non-interlaced
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSYNCCONTROL4 Enumeration

IRD

Saa7118TYPIDSYNCCONTROL4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSYNCCONTROL4
Public Enumeration TYPIDSYNCCONTROL4
public enum class TYPIDSYNCCONTROL4
type TYPIDSYNCCONTROL4
Members
Member name | Value | Description
Value_50Hz625Lines | 0 | 50 Hz, 625 lines
Value_60Hz525Lines | 1 | 60 Hz, 525 lines
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDSYNCCONTROL5 Enumeration

IRD

Saa7118TYPIDSYNCCONTROL5 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSYNCCONTROL5
Public Enumeration TYPIDSYNCCONTROL5
public enum class TYPIDSYNCCONTROL5
type TYPIDSYNCCONTROL5
Members
Member name | Value | Description
FieldStateDirectlyControlled | 0 | Field state directly controlled
AutomaticFieldDetection | 1 | Automatic field detection
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAHORIZONTALINPTWINDOWSTARTL0 Enumeration

IRD

Saa7118TYPIDTAHORIZONTALINPTWINDOWSTARTL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAHORIZONTALINPTWINDOWSTARTL0
Public Enumeration TYPIDTAHORIZONTALINPTWINDOWSTARTL0
public enum class TYPIDTAHORIZONTALINPTWINDOWSTARTL0
type TYPIDTAHORIZONTALINPTWINDOWSTARTL0
Members
Member name | Value | Description
Value_2MinimumShouldBeKept | 2 | 2 - minimum (should be kept)
Value_3OddOffsetsCBCRCRCBSequence | 3 | 3 - Odd offsets: CB-CR -> CR-CB sequence
Value_4095MaximumPossiblePixelOffset | 4095 | 4095 - Maximum possible pixel offset
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAHORIZONTALINPWINDOWLENGTHL0 Enumeration

IRD

Saa7118TYPIDTAHORIZONTALINPWINDOWLENGTHL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAHORIZONTALINPWINDOWLENGTHL0
Public Enumeration TYPIDTAHORIZONTALINPWINDOWLENGTHL0
public enum class TYPIDTAHORIZONTALINPWINDOWLENGTHL0
type TYPIDTAHORIZONTALINPWINDOWLENGTHL0
Members
Member name | Value | Description
Value_0NoOutput | 0 | 0 - No output
Value_4095MaximumPossibleNumberOfInputPixels | 4095 | 4095 - Maximum possible number of input pixels
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 Enumeration

IRD

Saa7118TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
Public Enumeration TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
public enum class TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
type TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_132 | 1 | 1/32
Value_232 | 2 | 2/32
Value_332 | 3 | 3/32
Value_432 | 4 | 4/32
Value_532 | 5 | 5/32
Value_632 | 6 | 6/32
Value_732 | 7 | 7/32
Value_832 | 8 | 8/32
Value_932 | 9 | 9/32
Value_1032 | 10 | 10/32
Value_1132 | 11 | 11/32
Value_1232 | 12 | 12/32
Value_1332 | 13 | 13/32
Value_1432 | 14 | 14/32
Value_1532 | 15 | 15/32
Value_1632 | 16 | 16/32
Value_1732 | 17 | 17/32
Value_1832 | 18 | 18/32
Value_1932 | 19 | 19/32
Value_2032 | 20 | 20/32
Value_2132 | 21 | 21/32
Value_2232 | 22 | 22/32
Value_2332 | 23 | 23/32
Value_2432 | 24 | 24/32
Value_2532 | 25 | 25/32
Value_2632 | 26 | 26/32
Value_2732 | 27 | 27/32
Value_2832 | 28 | 28/32
Value_2932 | 29 | 29/32
Value_3032 | 30 | 30/32
Value_3132 | 31 | 31/32
Value_1 | 32 | 1
Value_3332 | 33 | 33/32
Value_3432 | 34 | 34/32
Value_3532 | 35 | 35/32
Value_3632 | 36 | 36/32
Value_3732 | 37 | 37/32
Value_3832 | 38 | 38/32
Value_3932 | 39 | 39/32
Value_4032 | 40 | 40/32
Value_4132 | 41 | 41/32
Value_4232 | 42 | 42/32
Value_4332 | 43 | 43/32
Value_4432 | 44 | 44/32
Value_4532 | 45 | 45/32
Value_4632 | 46 | 46/32
Value_4732 | 47 | 47/32
Value_4832 | 48 | 48/32
Value_4932 | 49 | 49/32
Value_5032 | 50 | 50/32
Value_5132 | 51 | 51/32
Value_5232 | 52 | 52/32
Value_5332 | 53 | 53/32
Value_5432 | 54 | 54/32
Value_5532 | 55 | 55/32
Value_5632 | 56 | 56/32
Value_5732 | 57 | 57/32
Value_5832 | 58 | 58/32
Value_5932 | 59 | 59/32
Value_6032 | 60 | 60/32
Value_6132 | 61 | 61/32
Value_6232 | 62 | 62/32
Value_6332 | 63 | 63/32
Value_2 | 64 | 2
Value_6532 | 65 | 65/32
Value_6632 | 66 | 66/32
Value_6732 | 67 | 67/32
Value_6832 | 68 | 68/32
Value_6932 | 69 | 69/32
Value_7032 | 70 | 70/32
Value_7132 | 71 | 71/32
Value_7232 | 72 | 72/32
Value_7332 | 73 | 73/32
Value_7432 | 74 | 74/32
Value_7532 | 75 | 75/32
Value_7632 | 76 | 76/32
Value_7732 | 77 | 77/32
Value_7832 | 78 | 78/32
Value_7932 | 79 | 79/32
Value_8032 | 80 | 80/32
Value_8132 | 81 | 81/32
Value_8232 | 82 | 82/32
Value_8332 | 83 | 83/32
Value_8432 | 84 | 84/32
Value_8532 | 85 | 85/32
Value_8632 | 86 | 86/32
Value_8732 | 87 | 87/32
Value_8832 | 88 | 88/32
Value_8932 | 89 | 89/32
Value_9032 | 90 | 90/32
Value_9132 | 91 | 91/32
Value_9232 | 92 | 92/32
Value_9332 | 93 | 93/32
Value_9432 | 94 | 94/32
Value_9532 | 95 | 95/32
Value_3 | 96 | 3
Value_9732 | 97 | 97/32
Value_9832 | 98 | 98/32
Value_9932 | 99 | 99/32
Value_10032 | 100 | 100/32
Value_10132 | 101 | 101/32
Value_10232 | 102 | 102/32
Value_10332 | 103 | 103/32
Value_10432 | 104 | 104/32
Value_10532 | 105 | 105/32
Value_10632 | 106 | 106/32
Value_10732 | 107 | 107/32
Value_10832 | 108 | 108/32
Value_10932 | 109 | 109/32
Value_11032 | 110 | 110/32
Value_11132 | 111 | 111/32
Value_11232 | 112 | 112/32
Value_11332 | 113 | 113/32
Value_11432 | 114 | 114/32
Value_11532 | 115 | 115/32
Value_11632 | 116 | 116/32
Value_11732 | 117 | 117/32
Value_11832 | 118 | 118/32
Value_11932 | 119 | 119/32
Value_12032 | 120 | 120/32
Value_12132 | 121 | 121/32
Value_12232 | 122 | 122/32
Value_12332 | 123 | 123/32
Value_12432 | 124 | 124/32
Value_12532 | 125 | 125/32
Value_12632 | 126 | 126/32
Value_12732 | 127 | 127/32
Value_4 | 128 | 4
Value_12932 | 129 | 129/32
Value_13032 | 130 | 130/32
Value_13132 | 131 | 131/32
Value_13232 | 132 | 132/32
Value_13332 | 133 | 133/32
Value_13432 | 134 | 134/32
Value_13532 | 135 | 135/32
Value_13632 | 136 | 136/32
Value_13732 | 137 | 137/32
Value_13832 | 138 | 138/32
Value_13932 | 139 | 139/32
Value_14032 | 140 | 140/32
Value_14132 | 141 | 141/32
Value_14232 | 142 | 142/32
Value_14332 | 143 | 143/32
Value_14432 | 144 | 144/32
Value_14532 | 145 | 145/32
Value_14632 | 146 | 146/32
Value_14732 | 147 | 147/32
Value_14832 | 148 | 148/32
Value_14932 | 149 | 149/32
Value_15032 | 150 | 150/32
Value_15132 | 151 | 151/32
Value_15232 | 152 | 152/32
Value_15332 | 153 | 153/32
Value_15432 | 154 | 154/32
Value_15532 | 155 | 155/32
Value_15632 | 156 | 156/32
Value_15732 | 157 | 157/32
Value_15832 | 158 | 158/32
Value_15932 | 159 | 159/32
Value_5 | 160 | 5
Value_16132 | 161 | 161/32
Value_16232 | 162 | 162/32
Value_16332 | 163 | 163/32
Value_16432 | 164 | 164/32
Value_16532 | 165 | 165/32
Value_16632 | 166 | 166/32
Value_16732 | 167 | 167/32
Value_16832 | 168 | 168/32
Value_16932 | 169 | 169/32
Value_17032 | 170 | 170/32
Value_17132 | 171 | 171/32
Value_17232 | 172 | 172/32
Value_17332 | 173 | 173/32
Value_17432 | 174 | 174/32
Value_17532 | 175 | 175/32
Value_17632 | 176 | 176/32
Value_17732 | 177 | 177/32
Value_17832 | 178 | 178/32
Value_17932 | 179 | 179/32
Value_18032 | 180 | 180/32
Value_18132 | 181 | 181/32
Value_18232 | 182 | 182/32
Value_18332 | 183 | 183/32
Value_18432 | 184 | 184/32
Value_18532 | 185 | 185/32
Value_18632 | 186 | 186/32
Value_18732 | 187 | 187/32
Value_18832 | 188 | 188/32
Value_18932 | 189 | 189/32
Value_19032 | 190 | 190/32
Value_19132 | 191 | 191/32
Value_6 | 192 | 6
Value_19332 | 193 | 193/32
Value_19432 | 194 | 194/32
Value_19532 | 195 | 195/32
Value_19632 | 196 | 196/32
Value_19732 | 197 | 197/32
Value_19832 | 198 | 198/32
Value_19932 | 199 | 199/32
Value_20032 | 200 | 200/32
Value_20132 | 201 | 201/32
Value_20232 | 202 | 202/32
Value_20332 | 203 | 203/32
Value_20432 | 204 | 204/32
Value_20532 | 205 | 205/32
Value_20632 | 206 | 206/32
Value_20732 | 207 | 207/32
Value_20832 | 208 | 208/32
Value_20932 | 209 | 209/32
Value_21032 | 210 | 210/32
Value_21132 | 211 | 211/32
Value_21232 | 212 | 212/32
Value_21332 | 213 | 213/32
Value_21432 | 214 | 214/32
Value_21532 | 215 | 215/32
Value_21632 | 216 | 216/32
Value_21732 | 217 | 217/32
Value_21832 | 218 | 218/32
Value_21932 | 219 | 219/32
Value_22032 | 220 | 220/32
Value_22132 | 221 | 221/32
Value_22232 | 222 | 222/32
Value_22332 | 223 | 223/32
Value_7 | 224 | 7
Value_22532 | 225 | 225/32
Value_22632 | 226 | 226/32
Value_22732 | 227 | 227/32
Value_22832 | 228 | 228/32
Value_22932 | 229 | 229/32
Value_23032 | 230 | 230/32
Value_23132 | 231 | 231/32
Value_23232 | 232 | 232/32
Value_23332 | 233 | 233/32
Value_23432 | 234 | 234/32
Value_23532 | 235 | 235/32
Value_23632 | 236 | 236/32
Value_23732 | 237 | 237/32
Value_23832 | 238 | 238/32
Value_23932 | 239 | 239/32
Value_24032 | 240 | 240/32
Value_24132 | 241 | 241/32
Value_24232 | 242 | 242/32
Value_24332 | 243 | 243/32
Value_24432 | 244 | 244/32
Value_24532 | 245 | 245/32
Value_24632 | 246 | 246/32
Value_24732 | 247 | 247/32
Value_24832 | 248 | 248/32
Value_24932 | 249 | 249/32
Value_25032 | 250 | 250/32
Value_25132 | 251 | 251/32
Value_25232 | 252 | 252/32
Value_25332 | 253 | 253/32
Value_25432 | 254 | 254/32
Value_25532 | 255 | 255/32
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAHORIZONTALLUMLINGINCREMENTL0 Enumeration

IRD

Saa7118TYPIDTAHORIZONTALLUMLINGINCREMENTL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAHORIZONTALLUMLINGINCREMENTL0
Public Enumeration TYPIDTAHORIZONTALLUMLINGINCREMENTL0
public enum class TYPIDTAHORIZONTALLUMLINGINCREMENTL0
type TYPIDTAHORIZONTALLUMLINGINCREMENTL0
Members
Member name | Value | Description
Value_10241 | 1024 | 1024 - =1
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 Enumeration

IRD

Saa7118TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAHORIZONTALOUTWINDOWLENGTHL0
Public Enumeration TYPIDTAHORIZONTALOUTWINDOWLENGTHL0
public enum class TYPIDTAHORIZONTALOUTWINDOWLENGTHL0
type TYPIDTAHORIZONTALOUTWINDOWLENGTHL0
Members
Member name | Value | Description
Value_0NoOutput | 0 | 0 - No output
Value_4095MaximumPossibleNumberOfInputPixels | 4095 | 4095 - Maximum possible number of input pixels
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAHORIZONTALPRESCALING0 Enumeration

IRD

Saa7118TYPIDTAHORIZONTALPRESCALING0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAHORIZONTALPRESCALING0
Public Enumeration TYPIDTAHORIZONTALPRESCALING0
public enum class TYPIDTAHORIZONTALPRESCALING0
type TYPIDTAHORIZONTALPRESCALING0
Members
Member name | Value | Description
Value_0NotAllowed | 0 | 0 - Not allowed
Downscale11 | 1 | Downscale=1/1
Downscale12 | 2 | Downscale=1/2
Downscale13 | 3 | Downscale=1/3
Downscale14 | 4 | Downscale=1/4
Downscale15 | 5 | Downscale=1/5
Downscale16 | 6 | Downscale=1/6
Downscale17 | 7 | Downscale=1/7
Downscale18 | 8 | Downscale=1/8
Downscale19 | 9 | Downscale=1/9
Downscale110 | 10 | Downscale=1/10
Downscale111 | 11 | Downscale=1/11
Downscale112 | 12 | Downscale=1/12
Downscale113 | 13 | Downscale=1/13
Downscale114 | 14 | Downscale=1/14
Downscale115 | 15 | Downscale=1/15
Downscale116 | 16 | Downscale=1/16
Downscale117 | 17 | Downscale=1/17
Downscale118 | 18 | Downscale=1/18
Downscale119 | 19 | Downscale=1/19
Downscale120 | 20 | Downscale=1/20
Downscale121 | 21 | Downscale=1/21
Downscale122 | 22 | Downscale=1/22
Downscale123 | 23 | Downscale=1/23
Downscale124 | 24 | Downscale=1/24
Downscale125 | 25 | Downscale=1/25
Downscale126 | 26 | Downscale=1/26
Downscale127 | 27 | Downscale=1/27
Downscale128 | 28 | Downscale=1/28
Downscale129 | 29 | Downscale=1/29
Downscale130 | 30 | Downscale=1/30
Downscale131 | 31 | Downscale=1/31
Downscale132 | 32 | Downscale=1/32
Downscale133 | 33 | Downscale=1/33
Downscale134 | 34 | Downscale=1/34
Downscale135 | 35 | Downscale=1/35
Downscale136 | 36 | Downscale=1/36
Downscale137 | 37 | Downscale=1/37
Downscale138 | 38 | Downscale=1/38
Downscale139 | 39 | Downscale=1/39
Downscale140 | 40 | Downscale=1/40
Downscale141 | 41 | Downscale=1/41
Downscale142 | 42 | Downscale=1/42
Downscale143 | 43 | Downscale=1/43
Downscale144 | 44 | Downscale=1/44
Downscale145 | 45 | Downscale=1/45
Downscale146 | 46 | Downscale=1/46
Downscale147 | 47 | Downscale=1/47
Downscale148 | 48 | Downscale=1/48
Downscale149 | 49 | Downscale=1/49
Downscale150 | 50 | Downscale=1/50
Downscale151 | 51 | Downscale=1/51
Downscale152 | 52 | Downscale=1/52
Downscale153 | 53 | Downscale=1/53
Downscale154 | 54 | Downscale=1/54
Downscale155 | 55 | Downscale=1/55
Downscale156 | 56 | Downscale=1/56
Downscale157 | 57 | Downscale=1/57
Downscale158 | 58 | Downscale=1/58
Downscale159 | 59 | Downscale=1/59
Downscale160 | 60 | Downscale=1/60
Downscale161 | 61 | Downscale=1/61
Downscale162 | 62 | Downscale=1/62
Downscale163 | 63 | Downscale=1/63
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAIPORTOUTPUTDCONFIGURATION0 Enumeration

IRD

Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAIPORTOUTPUTDCONFIGURATION0
Public Enumeration TYPIDTAIPORTOUTPUTDCONFIGURATION0
public enum class TYPIDTAIPORTOUTPUTDCONFIGURATION0
type TYPIDTAIPORTOUTPUTDCONFIGURATION0
Members
Member name | Value | Description
Value_422DwordFormatting | 0 | 4:2:2 Dword formatting
Value_411DwordFormatting | 1 | 4:1:1 Dword formatting
Value_420OnlyEvery2ndLineYCBCROutputInBetweenYonlyOutput | 2 | 4:2:0, only every 2nd line Y + CB-CR output, in between Yonly output
Value_410OnlyEvery4thLineYCBCROutputInBetweenYonlyOutput | 3 | 4:1:0, only every 4th line Y + CB-CR output, in between Yonly output
Yonly | 4 | Yonly
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAIPORTOUTPUTDCONFIGURATION1 Enumeration

IRD

Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAIPORTOUTPUTDCONFIGURATION1
Public Enumeration TYPIDTAIPORTOUTPUTDCONFIGURATION1
public enum class TYPIDTAIPORTOUTPUTDCONFIGURATION1
type TYPIDTAIPORTOUTPUTDCONFIGURATION1
Members
Member name | Value | Description
NoLine | 0 | No line
Value_1Line | 1 | 1 line
Value_2Lines | 2 | 2 lines
Value_3Lines | 3 | 3 lines
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAIPORTOUTPUTDCONFIGURATION2 Enumeration

IRD

Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAIPORTOUTPUTDCONFIGURATION2
Public Enumeration TYPIDTAIPORTOUTPUTDCONFIGURATION2
public enum class TYPIDTAIPORTOUTPUTDCONFIGURATION2
type TYPIDTAIPORTOUTPUTDCONFIGURATION2
Members
Member name | Value | Description
AllLinesWillBeOutput | 0 | All lines will be output
SkipTheNumberOfLeadingYOnlyLinesAsDefinedByFOI1AndFOI0 | 1 | Skip the number of leading Y only lines, as defined by FOI1 and FOI0
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAIPORTOUTPUTDCONFIGURATION3 Enumeration

IRD

Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAIPORTOUTPUTDCONFIGURATION3
Public Enumeration TYPIDTAIPORTOUTPUTDCONFIGURATION3
public enum class TYPIDTAIPORTOUTPUTDCONFIGURATION3
type TYPIDTAIPORTOUTPUTDCONFIGURATION3
Members
Member name | Value | Description
ByteWise | 0 | Byte wise
Value_16BitWordWiseViaIPDAndHPD | 1 | 16-bit word wise via IPD and HPD
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAIPORTOUTPUTDCONFIGURATION4 Enumeration

IRD

Saa7118TYPIDTAIPORTOUTPUTDCONFIGURATION4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAIPORTOUTPUTDCONFIGURATION4
Public Enumeration TYPIDTAIPORTOUTPUTDCONFIGURATION4
public enum class TYPIDTAIPORTOUTPUTDCONFIGURATION4
type TYPIDTAIPORTOUTPUTDCONFIGURATION4
Members
Member name | Value | Description
NoITU656LikeSAVEAVCodesAreAvailable | 0 | No ITU 656 like SAV/EAV codes are available
ITU656LikeSAVEAVCodesAreInsertedInTheOutputDataStreamFramedByAQualifier | 1 | ITU 656 like SAV/EAV codes are inserted in the output data stream, framed by a qualifier
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTALUMINANCEBRIGGHTNESSCONTROL0 Enumeration

IRD

Saa7118TYPIDTALUMINANCEBRIGGHTNESSCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTALUMINANCEBRIGGHTNESSCONTROL0
Public Enumeration TYPIDTALUMINANCEBRIGGHTNESSCONTROL0
public enum class TYPIDTALUMINANCEBRIGGHTNESSCONTROL0
type TYPIDTALUMINANCEBRIGGHTNESSCONTROL0
Members
Member name | Value | Description
NominalValue | 128 | Nominal value
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTALUMINANCECONTONTRASTCONTROL0 Enumeration

IRD

Saa7118TYPIDTALUMINANCECONTONTRASTCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTALUMINANCECONTONTRASTCONTROL0
Public Enumeration TYPIDTALUMINANCECONTONTRASTCONTROL0
public enum class TYPIDTALUMINANCECONTONTRASTCONTROL0
type TYPIDTALUMINANCECONTONTRASTCONTROL0
Members
Member name | Value | Description
Value_064 | 0 | 0/64
Value_164 | 1 | 1/64
Value_264 | 2 | 2/64
Value_364 | 3 | 3/64
Value_464 | 4 | 4/64
Value_564 | 5 | 5/64
Value_664 | 6 | 6/64
Value_764 | 7 | 7/64
Value_864 | 8 | 8/64
Value_964 | 9 | 9/64
Value_1064 | 10 | 10/64
Value_1164 | 11 | 11/64
Value_1264 | 12 | 12/64
Value_1364 | 13 | 13/64
Value_1464 | 14 | 14/64
Value_1564 | 15 | 15/64
Value_1664 | 16 | 16/64
Value_1764 | 17 | 17/64
Value_1864 | 18 | 18/64
Value_1964 | 19 | 19/64
Value_2064 | 20 | 20/64
Value_2164 | 21 | 21/64
Value_2264 | 22 | 22/64
Value_2364 | 23 | 23/64
Value_2464 | 24 | 24/64
Value_2564 | 25 | 25/64
Value_2664 | 26 | 26/64
Value_2764 | 27 | 27/64
Value_2864 | 28 | 28/64
Value_2964 | 29 | 29/64
Value_3064 | 30 | 30/64
Value_3164 | 31 | 31/64
Value_3264 | 32 | 32/64
Value_3364 | 33 | 33/64
Value_3464 | 34 | 34/64
Value_3564 | 35 | 35/64
Value_3664 | 36 | 36/64
Value_3764 | 37 | 37/64
Value_3864 | 38 | 38/64
Value_3964 | 39 | 39/64
Value_4064 | 40 | 40/64
Value_4164 | 41 | 41/64
Value_4264 | 42 | 42/64
Value_4364 | 43 | 43/64
Value_4464 | 44 | 44/64
Value_4564 | 45 | 45/64
Value_4664 | 46 | 46/64
Value_4764 | 47 | 47/64
Value_4864 | 48 | 48/64
Value_4964 | 49 | 49/64
Value_5064 | 50 | 50/64
Value_5164 | 51 | 51/64
Value_5264 | 52 | 52/64
Value_5364 | 53 | 53/64
Value_5464 | 54 | 54/64
Value_5564 | 55 | 55/64
Value_5664 | 56 | 56/64
Value_5764 | 57 | 57/64
Value_5864 | 58 | 58/64
Value_5964 | 59 | 59/64
Value_6064 | 60 | 60/64
Value_6164 | 61 | 61/64
Value_6264 | 62 | 62/64
Value_6364 | 63 | 63/64
NominalGain1 | 64 | Nominal Gain=1
Value_6564 | 65 | 65/64
Value_6664 | 66 | 66/64
Value_6764 | 67 | 67/64
Value_6864 | 68 | 68/64
Value_6964 | 69 | 69/64
Value_7064 | 70 | 70/64
Value_7164 | 71 | 71/64
Value_7264 | 72 | 72/64
Value_7364 | 73 | 73/64
Value_7464 | 74 | 74/64
Value_7564 | 75 | 75/64
Value_7664 | 76 | 76/64
Value_7764 | 77 | 77/64
Value_7864 | 78 | 78/64
Value_7964 | 79 | 79/64
Value_8064 | 80 | 80/64
Value_8164 | 81 | 81/64
Value_8264 | 82 | 82/64
Value_8364 | 83 | 83/64
Value_8464 | 84 | 84/64
Value_8564 | 85 | 85/64
Value_8664 | 86 | 86/64
Value_8764 | 87 | 87/64
Value_8864 | 88 | 88/64
Value_8964 | 89 | 89/64
Value_9064 | 90 | 90/64
Value_9164 | 91 | 91/64
Value_9264 | 92 | 92/64
Value_9364 | 93 | 93/64
Value_9464 | 94 | 94/64
Value_9564 | 95 | 95/64
Value_9664 | 96 | 96/64
Value_9764 | 97 | 97/64
Value_9864 | 98 | 98/64
Value_9964 | 99 | 99/64
Value_10064 | 100 | 100/64
Value_10164 | 101 | 101/64
Value_10264 | 102 | 102/64
Value_10364 | 103 | 103/64
Value_10464 | 104 | 104/64
Value_10564 | 105 | 105/64
Value_10664 | 106 | 106/64
Value_10764 | 107 | 107/64
Value_10864 | 108 | 108/64
Value_10964 | 109 | 109/64
Value_11064 | 110 | 110/64
Value_11164 | 111 | 111/64
Value_11264 | 112 | 112/64
Value_11364 | 113 | 113/64
Value_11464 | 114 | 114/64
Value_11564 | 115 | 115/64
Value_11664 | 116 | 116/64
Value_11764 | 117 | 117/64
Value_11864 | 118 | 118/64
Value_11964 | 119 | 119/64
Value_12064 | 120 | 120/64
Value_12164 | 121 | 121/64
Value_12264 | 122 | 122/64
Value_12364 | 123 | 123/64
Value_12464 | 124 | 124/64
Value_12564 | 125 | 125/64
Value_12664 | 126 | 126/64
Value_12764 | 127 | 127/64
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAPRESCALERDCGEFILTERCONTROL0 Enumeration

IRD

Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAPRESCALERDCGEFILTERCONTROL0
Public Enumeration TYPIDTAPRESCALERDCGEFILTERCONTROL0
public enum class TYPIDTAPRESCALERDCGEFILTERCONTROL0
type TYPIDTAPRESCALERDCGEFILTERCONTROL0
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_12 | 1 | 1/2
Value_14 | 2 | 1/4
Value_18 | 3 | 1/8
Value_116 | 4 | 1/16
Value_132 | 5 | 1/32
Value_164 | 6 | 1/64
Value_1128 | 7 | 1/128
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAPRESCALERDCGEFILTERCONTROL1 Enumeration

IRD

Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAPRESCALERDCGEFILTERCONTROL1
Public Enumeration TYPIDTAPRESCALERDCGEFILTERCONTROL1
public enum class TYPIDTAPRESCALERDCGEFILTERCONTROL1
type TYPIDTAPRESCALERDCGEFILTERCONTROL1
Members
Member name | Value | Description
Factor1 | 0 | Factor '1'
Factor2 | 1 | Factor '2'
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAPRESCALERDCGEFILTERCONTROL2 Enumeration

IRD

Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAPRESCALERDCGEFILTERCONTROL2
Public Enumeration TYPIDTAPRESCALERDCGEFILTERCONTROL2
public enum class TYPIDTAPRESCALERDCGEFILTERCONTROL2
type TYPIDTAPRESCALERDCGEFILTERCONTROL2
Members
Member name | Value | Description
Bypassed | 0 | Bypassed
HYZ14121 | 1 | H_y(z) = 1/4 (1 2 1)
HYZ18111754517511 | 2 | H_y(z) = 1/8 (-1 1 1.75 4.5 1.75 1 -1)
HYZ1812221 | 3 | H_y(z) = 1/8 (1 2 2 2 1)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAPRESCALERDCGEFILTERCONTROL3 Enumeration

IRD

Saa7118TYPIDTAPRESCALERDCGEFILTERCONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAPRESCALERDCGEFILTERCONTROL3
Public Enumeration TYPIDTAPRESCALERDCGEFILTERCONTROL3
public enum class TYPIDTAPRESCALERDCGEFILTERCONTROL3
type TYPIDTAPRESCALERDCGEFILTERCONTROL3
Members
Member name | Value | Description
Bypassed | 0 | Bypassed
HUvZ14121 | 1 | H_uv(z) = 1/4 (1 2 1)
HUvZ132381083 | 2 | H_uv(z) = 1/32 (3 8 10 8 3)
HUvZ1812221 | 3 | H_uv(z) = 1/8 (1 2 2 2 1)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTATASKHANDLINGCONTROL0 Enumeration

IRD

Saa7118TYPIDTATASKHANDLINGCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTATASKHANDLINGCONTROL0
Public Enumeration TYPIDTATASKHANDLINGCONTROL0
public enum class TYPIDTATASKHANDLINGCONTROL0
type TYPIDTATASKHANDLINGCONTROL0
Members
Member name | Value | Description
ImmediatelyAfterFinishingATask | 0 | Immediately after finishing a task
NextVSync | 1 | Next V-sync
WithFieldID0 | 2 | With field ID=0
WithFieldID1 | 3 | With field ID=1
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTATASKHANDLINGCONTROL1 Enumeration

IRD

Saa7118TYPIDTATASKHANDLINGCONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTATASKHANDLINGCONTROL1
Public Enumeration TYPIDTATASKHANDLINGCONTROL1
public enum class TYPIDTATASKHANDLINGCONTROL1
type TYPIDTATASKHANDLINGCONTROL1
Members
Member name | Value | Description
IfActiveTaskIsFinishedHandlingIsTakenOverByTheNextTask | 0 | If active task is finished, handling is taken over by the next task
ActiveTaskIsRepeatedOnceBeforeHandlingIsTakenOverByTheNextTask | 1 | Active task is repeated once, before handling is taken over by the next task
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTATASKHANDLINGCONTROL2 Enumeration

IRD

Saa7118TYPIDTATASKHANDLINGCONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTATASKHANDLINGCONTROL2
Public Enumeration TYPIDTATASKHANDLINGCONTROL2
public enum class TYPIDTATASKHANDLINGCONTROL2
type TYPIDTATASKHANDLINGCONTROL2
Members
Member name | Value | Description
ActiveTaskIsCarriedOutDirectly | 0 | Active task is carried out directly
Value_1FieldIsSkippedBeforeActiveTaskIsCarriedOut | 1 | 1 field is skipped before active task is carried out
Value_2FieldIsSkippedBeforeActiveTaskIsCarriedOut | 2 | 2 field is skipped before active task is carried out
Value_3FieldIsSkippedBeforeActiveTaskIsCarriedOut | 3 | 3 field is skipped before active task is carried out
Value_4FieldIsSkippedBeforeActiveTaskIsCarriedOut | 4 | 4 field is skipped before active task is carried out
Value_5FieldIsSkippedBeforeActiveTaskIsCarriedOut | 5 | 5 field is skipped before active task is carried out
Value_6FieldIsSkippedBeforeActiveTaskIsCarriedOut | 6 | 6 field is skipped before active task is carried out
Value_7FieldIsSkippedBeforeActiveTaskIsCarriedOut | 7 | 7 field is skipped before active task is carried out
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTATASKHANDLINGCONTROL3 Enumeration

IRD

Saa7118TYPIDTATASKHANDLINGCONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTATASKHANDLINGCONTROL3
Public Enumeration TYPIDTATASKHANDLINGCONTROL3
public enum class TYPIDTATASKHANDLINGCONTROL3
type TYPIDTATASKHANDLINGCONTROL3
Members
Member name | Value | Description
FieldIDFromScalerInput | 0 | Field ID from scaler input
TaskStatusFlag | 1 | Task status flag
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTATASKHANDLINGCONTROL4 Enumeration

IRD

Saa7118TYPIDTATASKHANDLINGCONTROL4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTATASKHANDLINGCONTROL4
Public Enumeration TYPIDTATASKHANDLINGCONTROL4
public enum class TYPIDTATASKHANDLINGCONTROL4
type TYPIDTATASKHANDLINGCONTROL4
Members
Member name | Value | Description
TaskFlag1 | 0 | Task flag=1
TaskFlag0 | 1 | Task flag=0
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAVERTICALINPUTTWINDOWSTARTL0 Enumeration

IRD

Saa7118TYPIDTAVERTICALINPUTTWINDOWSTARTL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAVERTICALINPUTTWINDOWSTARTL0
Public Enumeration TYPIDTAVERTICALINPUTTWINDOWSTARTL0
public enum class TYPIDTAVERTICALINPUTTWINDOWSTARTL0
type TYPIDTAVERTICALINPUTTWINDOWSTARTL0
Members
Member name | Value | Description
Value_4095MaximumLineOffset | 4095 | 4095 - Maximum line offset
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAVERTICALINPUTWINDOWLENGTHL0 Enumeration

IRD

Saa7118TYPIDTAVERTICALINPUTWINDOWLENGTHL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAVERTICALINPUTWINDOWLENGTHL0
Public Enumeration TYPIDTAVERTICALINPUTWINDOWLENGTHL0
public enum class TYPIDTAVERTICALINPUTWINDOWLENGTHL0
type TYPIDTAVERTICALINPUTWINDOWLENGTHL0
Members
Member name | Value | Description
Value_0NoInputLines | 0 | 0 - No input lines
Value_4095MaximumPossibleNumberOfInputLines | 4095 | 4095 - Maximum possible number of input lines
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAVERTICALLUMINLINGINCREMENTL0 Enumeration

IRD

Saa7118TYPIDTAVERTICALLUMINLINGINCREMENTL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAVERTICALLUMINLINGINCREMENTL0
Public Enumeration TYPIDTAVERTICALLUMINLINGINCREMENTL0
public enum class TYPIDTAVERTICALLUMINLINGINCREMENTL0
type TYPIDTAVERTICALLUMINLINGINCREMENTL0
Members
Member name | Value | Description
Value_10241 | 1024 | 1024 - =1
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 Enumeration

IRD

Saa7118TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAVERTICALOUTPUWINDOWLENGTHL0
Public Enumeration TYPIDTAVERTICALOUTPUWINDOWLENGTHL0
public enum class TYPIDTAVERTICALOUTPUWINDOWLENGTHL0
type TYPIDTAVERTICALOUTPUWINDOWLENGTHL0
Members
Member name | Value | Description
Value_0NoOutput | 0 | 0 - No output
Value_4095MaximumPossibleNumberOfOutputLines | 4095 | 4095 - Maximum possible number of output lines
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAVERTICALSCALINGMODECONTROL0 Enumeration

IRD

Saa7118TYPIDTAVERTICALSCALINGMODECONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAVERTICALSCALINGMODECONTROL0
Public Enumeration TYPIDTAVERTICALSCALINGMODECONTROL0
public enum class TYPIDTAVERTICALSCALINGMODECONTROL0
type TYPIDTAVERTICALSCALINGMODECONTROL0
Members
Member name | Value | Description
VerticalScalingPerformsLinearInterpolationBetweenLines | 0 | Vertical scaling performs linear interpolation between lines
VerticalScalingPerformsHigherOrderAccumulatingInterpolation | 1 | Vertical scaling performs higher order accumulating interpolation
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAVERTICALSCALINGMODECONTROL1 Enumeration

IRD

Saa7118TYPIDTAVERTICALSCALINGMODECONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAVERTICALSCALINGMODECONTROL1
Public Enumeration TYPIDTAVERTICALSCALINGMODECONTROL1
public enum class TYPIDTAVERTICALSCALINGMODECONTROL1
type TYPIDTAVERTICALSCALINGMODECONTROL1
Members
Member name | Value | Description
NoMirroring | 0 | No mirroring
LinesAreMirrored | 1 | Lines are mirrored
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAXPORTFORMATSDCONFIGURATION0 Enumeration

IRD

Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTFORMATSDCONFIGURATION0
Public Enumeration TYPIDTAXPORTFORMATSDCONFIGURATION0
public enum class TYPIDTAXPORTFORMATSDCONFIGURATION0
type TYPIDTAXPORTFORMATSDCONFIGURATION0
Members
Member name | Value | Description
InputIsYCBCR422 | 0 | Input is Y-CB-CR 4:2:2
InputIsYCBCR411 | 1 | Input is Y-CB-CR 4:1:1
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAXPORTFORMATSDCONFIGURATION1 Enumeration

IRD

Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTFORMATSDCONFIGURATION1
Public Enumeration TYPIDTAXPORTFORMATSDCONFIGURATION1
public enum class TYPIDTAXPORTFORMATSDCONFIGURATION1
type TYPIDTAXPORTFORMATSDCONFIGURATION1
Members
Member name | Value | Description
EveryLine | 0 | Every line
Every2ndLine | 1 | Every 2nd line
Every3rdLine | 2 | Every 3rd line
Every4thLine | 3 | Every 4th line
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAXPORTFORMATSDCONFIGURATION2 Enumeration

IRD

Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTFORMATSDCONFIGURATION2
Public Enumeration TYPIDTAXPORTFORMATSDCONFIGURATION2
public enum class TYPIDTAXPORTFORMATSDCONFIGURATION2
type TYPIDTAXPORTFORMATSDCONFIGURATION2
Members
Member name | Value | Description
ReactsOnSAA7118Request | 0 | Reacts on SAA7118 request
ContinuousDataStream | 1 | Continuous data stream
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAXPORTFORMATSDCONFIGURATION3 Enumeration

IRD

Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTFORMATSDCONFIGURATION3
Public Enumeration TYPIDTAXPORTFORMATSDCONFIGURATION3
public enum class TYPIDTAXPORTFORMATSDCONFIGURATION3
type TYPIDTAXPORTFORMATSDCONFIGURATION3
Members
Member name | Value | Description
DataFromDecoder | 0 | Data from decoder
YCBCRDataFromXPort | 1 | Y-CB-CR data from X port
RawDigitalCVBSFromSelectedAnalogChannel | 2 | Raw digital CVBS from selected analog channel
RawDigitalCVBS | 3 | Raw digital CVBS
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAXPORTFORMATSDCONFIGURATION4 Enumeration

IRD

Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTFORMATSDCONFIGURATION4
Public Enumeration TYPIDTAXPORTFORMATSDCONFIGURATION4
public enum class TYPIDTAXPORTFORMATSDCONFIGURATION4
type TYPIDTAXPORTFORMATSDCONFIGURATION4
Members
Member name | Value | Description
MayChangeBetweenSAVAndEAV | 0 | May change between SAV and EAV
AreSynchronizedToScalersOutputLineStart | 1 | Are synchronized to scalers output line start
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAXPORTFORMATSDCONFIGURATION5 Enumeration

IRD

Saa7118TYPIDTAXPORTFORMATSDCONFIGURATION5 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTFORMATSDCONFIGURATION5
Public Enumeration TYPIDTAXPORTFORMATSDCONFIGURATION5
public enum class TYPIDTAXPORTFORMATSDCONFIGURATION5
type TYPIDTAXPORTFORMATSDCONFIGURATION5
Members
Member name | Value | Description
OnPinIGPVAsGeneratedByTheInternalProcessing | 0 | On pin IGPV as generated by the internal processing
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAXPORTINPUTRNALDEFINITIONS0 Enumeration

IRD

Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTINPUTRNALDEFINITIONS0
Public Enumeration TYPIDTAXPORTINPUTRNALDEFINITIONS0
public enum class TYPIDTAXPORTINPUTRNALDEFINITIONS0
type TYPIDTAXPORTINPUTRNALDEFINITIONS0
Members
Member name | Value | Description
XCLKInputClockAndXDQInputQualifierAreNeeded | 0 | XCLK input clock and XDQ input qualifier are needed
DataRateIsDefinedByXCLKOnlyNoXDQSignalUsed | 1 | Data rate is defined by XCLK only, no XDQ signal used
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAXPORTINPUTRNALDEFINITIONS1 Enumeration

IRD

Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTINPUTRNALDEFINITIONS1
Public Enumeration TYPIDTAXPORTINPUTRNALDEFINITIONS1
public enum class TYPIDTAXPORTINPUTRNALDEFINITIONS1
type TYPIDTAXPORTINPUTRNALDEFINITIONS1
Members
Member name | Value | Description
XDQInputAtLogic1 | 0 | XDQ input at logic 1
XDQInputAtLogic0 | 1 | XDQ input at logic 0
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAXPORTINPUTRNALDEFINITIONS2 Enumeration

IRD

Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTINPUTRNALDEFINITIONS2
Public Enumeration TYPIDTAXPORTINPUTRNALDEFINITIONS2
public enum class TYPIDTAXPORTINPUTRNALDEFINITIONS2
type TYPIDTAXPORTINPUTRNALDEFINITIONS2
Members
Member name | Value | Description
Rising | 0 | Rising
Falling | 1 | Falling
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAXPORTINPUTRNALDEFINITIONS3 Enumeration

IRD

Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTINPUTRNALDEFINITIONS3
Public Enumeration TYPIDTAXPORTINPUTRNALDEFINITIONS3
public enum class TYPIDTAXPORTINPUTRNALDEFINITIONS3
type TYPIDTAXPORTINPUTRNALDEFINITIONS3
Members
Member name | Value | Description
TakenFromXRHAndXRV | 0 | Taken from XRH and XRV
DecodedFromEAVAndSAV | 1 | Decoded from EAV and SAV
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAXPORTINPUTRNALDEFINITIONS4 Enumeration

IRD

Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTINPUTRNALDEFINITIONS4
Public Enumeration TYPIDTAXPORTINPUTRNALDEFINITIONS4
public enum class TYPIDTAXPORTINPUTRNALDEFINITIONS4
type TYPIDTAXPORTINPUTRNALDEFINITIONS4
Members
Member name | Value | Description
Rising | 0 | Rising
Falling | 1 | Falling
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAXPORTINPUTRNALDEFINITIONS5 Enumeration

IRD

Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS5 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTINPUTRNALDEFINITIONS5
Public Enumeration TYPIDTAXPORTINPUTRNALDEFINITIONS5
public enum class TYPIDTAXPORTINPUTRNALDEFINITIONS5
type TYPIDTAXPORTINPUTRNALDEFINITIONS5
Members
Member name | Value | Description
VSyncOrVGateSignal | 0 | V-sync or V gate signal
FrameSyncVPulsesAreGeneratedInternallyOnBothEdgesOfFSInput | 1 | Frame sync, V pulses are generated internally on both edges of FS input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAXPORTINPUTRNALDEFINITIONS6 Enumeration

IRD

Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS6 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTINPUTRNALDEFINITIONS6
Public Enumeration TYPIDTAXPORTINPUTRNALDEFINITIONS6
public enum class TYPIDTAXPORTINPUTRNALDEFINITIONS6
type TYPIDTAXPORTINPUTRNALDEFINITIONS6
Members
Member name | Value | Description
StateOfXRHAtReferenceEdgeOnXRVDefinedByXFDV | 0 | State of XRH at reference edge on XRV (defined by XFDV)
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTAXPORTINPUTRNALDEFINITIONS7 Enumeration

IRD

Saa7118TYPIDTAXPORTINPUTRNALDEFINITIONS7 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTINPUTRNALDEFINITIONS7
Public Enumeration TYPIDTAXPORTINPUTRNALDEFINITIONS7
public enum class TYPIDTAXPORTINPUTRNALDEFINITIONS7
type TYPIDTAXPORTINPUTRNALDEFINITIONS7
Members
Member name | Value | Description
FallingEdgeOfXRV | 0 | Falling edge of XRV
RisingEdgeOfXRV | 1 | Rising edge of XRV
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTBHORIZONTALLUMLINGINCREMENTL0 Enumeration

IRD

Saa7118TYPIDTBHORIZONTALLUMLINGINCREMENTL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTBHORIZONTALLUMLINGINCREMENTL0
Public Enumeration TYPIDTBHORIZONTALLUMLINGINCREMENTL0
public enum class TYPIDTBHORIZONTALLUMLINGINCREMENTL0
type TYPIDTBHORIZONTALLUMLINGINCREMENTL0
Members
Member name | Value | Description
Value_10241 | 1024 | 1024 - =1
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDTBVERTICALLUMINLINGINCREMENTL0 Enumeration

IRD

Saa7118TYPIDTBVERTICALLUMINLINGINCREMENTL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTBVERTICALLUMINLINGINCREMENTL0
Public Enumeration TYPIDTBVERTICALLUMINLINGINCREMENTL0
public enum class TYPIDTBVERTICALLUMINLINGINCREMENTL0
type TYPIDTBVERTICALLUMINLINGINCREMENTL0
Members
Member name | Value | Description
Value_10241 | 1024 | 1024 - =1
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDVGATESTART0 Enumeration

IRD

Saa7118TYPIDVGATESTART0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDVGATESTART0
Public Enumeration TYPIDVGATESTART0
public enum class TYPIDVGATESTART0
type TYPIDVGATESTART0
Members
Member name | Value | Description
Value_50Hz231560Hz5268 | 0 | 50 Hz: 2/315 / 60 Hz: 5/268
Value_50Hz331660Hz6269 | 1 | 50 Hz: 3/316 / 60 Hz: 6/269
Value_50Hz431760Hz7270 | 2 | 50 Hz: 4/317 / 60 Hz: 7/270
Value_50Hz531860Hz8271 | 3 | 50 Hz: 5/318 / 60 Hz: 8/271
Value_50Hz631960Hz9272 | 4 | 50 Hz: 6/319 / 60 Hz: 9/272
Value_50Hz732060Hz10273 | 5 | 50 Hz: 7/320 / 60 Hz: 10/273
Value_50Hz832160Hz11274 | 6 | 50 Hz: 8/321 / 60 Hz: 11/274
Value_50Hz932260Hz12275 | 7 | 50 Hz: 9/322 / 60 Hz: 12/275
Value_50Hz1032360Hz13276 | 8 | 50 Hz: 10/323 / 60 Hz: 13/276
Value_50Hz1132460Hz14277 | 9 | 50 Hz: 11/324 / 60 Hz: 14/277
Value_50Hz1232560Hz15278 | 10 | 50 Hz: 12/325 / 60 Hz: 15/278
Value_50Hz1332660Hz16279 | 11 | 50 Hz: 13/326 / 60 Hz: 16/279
Value_50Hz1432760Hz17280 | 12 | 50 Hz: 14/327 / 60 Hz: 17/280
Value_50Hz1532860Hz18281 | 13 | 50 Hz: 15/328 / 60 Hz: 18/281
Value_50Hz1632960Hz19282 | 14 | 50 Hz: 16/329 / 60 Hz: 19/282
Value_50Hz1733060Hz20283 | 15 | 50 Hz: 17/330 / 60 Hz: 20/283
Value_50Hz1833160Hz21284 | 16 | 50 Hz: 18/331 / 60 Hz: 21/284
Value_50Hz1933260Hz22285 | 17 | 50 Hz: 19/332 / 60 Hz: 22/285
Value_50Hz2033360Hz23286 | 18 | 50 Hz: 20/333 / 60 Hz: 23/286
Value_50Hz2133460Hz24287 | 19 | 50 Hz: 21/334 / 60 Hz: 24/287
Value_50Hz2233560Hz25288 | 20 | 50 Hz: 22/335 / 60 Hz: 25/288
Value_50Hz2333660Hz26289 | 21 | 50 Hz: 23/336 / 60 Hz: 26/289
Value_50Hz2433760Hz27290 | 22 | 50 Hz: 24/337 / 60 Hz: 27/290
Value_50Hz2533860Hz28291 | 23 | 50 Hz: 25/338 / 60 Hz: 28/291
Value_50Hz2633960Hz29292 | 24 | 50 Hz: 26/339 / 60 Hz: 29/292
Value_50Hz2734060Hz30293 | 25 | 50 Hz: 27/340 / 60 Hz: 30/293
Value_50Hz2834160Hz31294 | 26 | 50 Hz: 28/341 / 60 Hz: 31/294
Value_50Hz2934260Hz32295 | 27 | 50 Hz: 29/342 / 60 Hz: 32/295
Value_50Hz3034360Hz33296 | 28 | 50 Hz: 30/343 / 60 Hz: 33/296
Value_50Hz3134460Hz34297 | 29 | 50 Hz: 31/344 / 60 Hz: 34/297
Value_50Hz3234560Hz35298 | 30 | 50 Hz: 32/345 / 60 Hz: 35/298
Value_50Hz3334660Hz36299 | 31 | 50 Hz: 33/346 / 60 Hz: 36/299
Value_50Hz3434760Hz37300 | 32 | 50 Hz: 34/347 / 60 Hz: 37/300
Value_50Hz3534860Hz38301 | 33 | 50 Hz: 35/348 / 60 Hz: 38/301
Value_50Hz3634960Hz39302 | 34 | 50 Hz: 36/349 / 60 Hz: 39/302
Value_50Hz3735060Hz40303 | 35 | 50 Hz: 37/350 / 60 Hz: 40/303
Value_50Hz3835160Hz41304 | 36 | 50 Hz: 38/351 / 60 Hz: 41/304
Value_50Hz3935260Hz42305 | 37 | 50 Hz: 39/352 / 60 Hz: 42/305
Value_50Hz4035360Hz43306 | 38 | 50 Hz: 40/353 / 60 Hz: 43/306
Value_50Hz4135460Hz44307 | 39 | 50 Hz: 41/354 / 60 Hz: 44/307
Value_50Hz4235560Hz45308 | 40 | 50 Hz: 42/355 / 60 Hz: 45/308
Value_50Hz4335660Hz46309 | 41 | 50 Hz: 43/356 / 60 Hz: 46/309
Value_50Hz4435760Hz47310 | 42 | 50 Hz: 44/357 / 60 Hz: 47/310
Value_50Hz4535860Hz48311 | 43 | 50 Hz: 45/358 / 60 Hz: 48/311
Value_50Hz4635960Hz49312 | 44 | 50 Hz: 46/359 / 60 Hz: 49/312
Value_50Hz4736060Hz50313 | 45 | 50 Hz: 47/360 / 60 Hz: 50/313
Value_50Hz4836160Hz51314 | 46 | 50 Hz: 48/361 / 60 Hz: 51/314
Value_50Hz4936260Hz52315 | 47 | 50 Hz: 49/362 / 60 Hz: 52/315
Value_50Hz5036360Hz53316 | 48 | 50 Hz: 50/363 / 60 Hz: 53/316
Value_50Hz5136460Hz54317 | 49 | 50 Hz: 51/364 / 60 Hz: 54/317
Value_50Hz5236560Hz55318 | 50 | 50 Hz: 52/365 / 60 Hz: 55/318
Value_50Hz5336660Hz56319 | 51 | 50 Hz: 53/366 / 60 Hz: 56/319
Value_50Hz5436760Hz57320 | 52 | 50 Hz: 54/367 / 60 Hz: 57/320
Value_50Hz5536860Hz58321 | 53 | 50 Hz: 55/368 / 60 Hz: 58/321
Value_50Hz5636960Hz59322 | 54 | 50 Hz: 56/369 / 60 Hz: 59/322
Value_50Hz5737060Hz60323 | 55 | 50 Hz: 57/370 / 60 Hz: 60/323
Value_50Hz5837160Hz61324 | 56 | 50 Hz: 58/371 / 60 Hz: 61/324
Value_50Hz5937260Hz62325 | 57 | 50 Hz: 59/372 / 60 Hz: 62/325
Value_50Hz6037360Hz63326 | 58 | 50 Hz: 60/373 / 60 Hz: 63/326
Value_50Hz6137460Hz64327 | 59 | 50 Hz: 61/374 / 60 Hz: 64/327
Value_50Hz6237560Hz65328 | 60 | 50 Hz: 62/375 / 60 Hz: 65/328
Value_50Hz6337660Hz66329 | 61 | 50 Hz: 63/376 / 60 Hz: 66/329
Value_50Hz6437760Hz67330 | 62 | 50 Hz: 64/377 / 60 Hz: 67/330
Value_50Hz6537860Hz68331 | 63 | 50 Hz: 65/378 / 60 Hz: 68/331
Value_50Hz6637960Hz69332 | 64 | 50 Hz: 66/379 / 60 Hz: 69/332
Value_50Hz6738060Hz70333 | 65 | 50 Hz: 67/380 / 60 Hz: 70/333
Value_50Hz6838160Hz71334 | 66 | 50 Hz: 68/381 / 60 Hz: 71/334
Value_50Hz6938260Hz72335 | 67 | 50 Hz: 69/382 / 60 Hz: 72/335
Value_50Hz7038360Hz73336 | 68 | 50 Hz: 70/383 / 60 Hz: 73/336
Value_50Hz7138460Hz74337 | 69 | 50 Hz: 71/384 / 60 Hz: 74/337
Value_50Hz7238560Hz75338 | 70 | 50 Hz: 72/385 / 60 Hz: 75/338
Value_50Hz7338660Hz76339 | 71 | 50 Hz: 73/386 / 60 Hz: 76/339
Value_50Hz7438760Hz77340 | 72 | 50 Hz: 74/387 / 60 Hz: 77/340
Value_50Hz7538860Hz78341 | 73 | 50 Hz: 75/388 / 60 Hz: 78/341
Value_50Hz7638960Hz79342 | 74 | 50 Hz: 76/389 / 60 Hz: 79/342
Value_50Hz7739060Hz80343 | 75 | 50 Hz: 77/390 / 60 Hz: 80/343
Value_50Hz7839160Hz81344 | 76 | 50 Hz: 78/391 / 60 Hz: 81/344
Value_50Hz7939260Hz82345 | 77 | 50 Hz: 79/392 / 60 Hz: 82/345
Value_50Hz8039360Hz83346 | 78 | 50 Hz: 80/393 / 60 Hz: 83/346
Value_50Hz8139460Hz84347 | 79 | 50 Hz: 81/394 / 60 Hz: 84/347
Value_50Hz8239560Hz85348 | 80 | 50 Hz: 82/395 / 60 Hz: 85/348
Value_50Hz8339660Hz86349 | 81 | 50 Hz: 83/396 / 60 Hz: 86/349
Value_50Hz8439760Hz87350 | 82 | 50 Hz: 84/397 / 60 Hz: 87/350
Value_50Hz8539860Hz88351 | 83 | 50 Hz: 85/398 / 60 Hz: 88/351
Value_50Hz8639960Hz89352 | 84 | 50 Hz: 86/399 / 60 Hz: 89/352
Value_50Hz8740060Hz90353 | 85 | 50 Hz: 87/400 / 60 Hz: 90/353
Value_50Hz8840160Hz91354 | 86 | 50 Hz: 88/401 / 60 Hz: 91/354
Value_50Hz8940260Hz92355 | 87 | 50 Hz: 89/402 / 60 Hz: 92/355
Value_50Hz9040360Hz93356 | 88 | 50 Hz: 90/403 / 60 Hz: 93/356
Value_50Hz9140460Hz94357 | 89 | 50 Hz: 91/404 / 60 Hz: 94/357
Value_50Hz9240560Hz95358 | 90 | 50 Hz: 92/405 / 60 Hz: 95/358
Value_50Hz9340660Hz96359 | 91 | 50 Hz: 93/406 / 60 Hz: 96/359
Value_50Hz9440760Hz97360 | 92 | 50 Hz: 94/407 / 60 Hz: 97/360
Value_50Hz9540860Hz98361 | 93 | 50 Hz: 95/408 / 60 Hz: 98/361
Value_50Hz9640960Hz99362 | 94 | 50 Hz: 96/409 / 60 Hz: 99/362
Value_50Hz9741060Hz100363 | 95 | 50 Hz: 97/410 / 60 Hz: 100/363
Value_50Hz9841160Hz101364 | 96 | 50 Hz: 98/411 / 60 Hz: 101/364
Value_50Hz9941260Hz102365 | 97 | 50 Hz: 99/412 / 60 Hz: 102/365
Value_50Hz10041360Hz103366 | 98 | 50 Hz: 100/413 / 60 Hz: 103/366
Value_50Hz10141460Hz104367 | 99 | 50 Hz: 101/414 / 60 Hz: 104/367
Value_50Hz10241560Hz105368 | 100 | 50 Hz: 102/415 / 60 Hz: 105/368
Value_50Hz10341660Hz106369 | 101 | 50 Hz: 103/416 / 60 Hz: 106/369
Value_50Hz10441760Hz107370 | 102 | 50 Hz: 104/417 / 60 Hz: 107/370
Value_50Hz10541860Hz108371 | 103 | 50 Hz: 105/418 / 60 Hz: 108/371
Value_50Hz10641960Hz109372 | 104 | 50 Hz: 106/419 / 60 Hz: 109/372
Value_50Hz10742060Hz110373 | 105 | 50 Hz: 107/420 / 60 Hz: 110/373
Value_50Hz10842160Hz111374 | 106 | 50 Hz: 108/421 / 60 Hz: 111/374
Value_50Hz10942260Hz112375 | 107 | 50 Hz: 109/422 / 60 Hz: 112/375
Value_50Hz11042360Hz113376 | 108 | 50 Hz: 110/423 / 60 Hz: 113/376
Value_50Hz11142460Hz114377 | 109 | 50 Hz: 111/424 / 60 Hz: 114/377
Value_50Hz11242560Hz115378 | 110 | 50 Hz: 112/425 / 60 Hz: 115/378
Value_50Hz11342660Hz116379 | 111 | 50 Hz: 113/426 / 60 Hz: 116/379
Value_50Hz11442760Hz117380 | 112 | 50 Hz: 114/427 / 60 Hz: 117/380
Value_50Hz11542860Hz118381 | 113 | 50 Hz: 115/428 / 60 Hz: 118/381
Value_50Hz11642960Hz119382 | 114 | 50 Hz: 116/429 / 60 Hz: 119/382
Value_50Hz11743060Hz120383 | 115 | 50 Hz: 117/430 / 60 Hz: 120/383
Value_50Hz11843160Hz121384 | 116 | 50 Hz: 118/431 / 60 Hz: 121/384
Value_50Hz11943260Hz122385 | 117 | 50 Hz: 119/432 / 60 Hz: 122/385
Value_50Hz12043360Hz123386 | 118 | 50 Hz: 120/433 / 60 Hz: 123/386
Value_50Hz12143460Hz124387 | 119 | 50 Hz: 121/434 / 60 Hz: 124/387
Value_50Hz12243560Hz125388 | 120 | 50 Hz: 122/435 / 60 Hz: 125/388
Value_50Hz12343660Hz126389 | 121 | 50 Hz: 123/436 / 60 Hz: 126/389
Value_50Hz12443760Hz127390 | 122 | 50 Hz: 124/437 / 60 Hz: 127/390
Value_50Hz12543860Hz128391 | 123 | 50 Hz: 125/438 / 60 Hz: 128/391
Value_50Hz12643960Hz129392 | 124 | 50 Hz: 126/439 / 60 Hz: 129/392
Value_50Hz12744060Hz130393 | 125 | 50 Hz: 127/440 / 60 Hz: 130/393
Value_50Hz12844160Hz131394 | 126 | 50 Hz: 128/441 / 60 Hz: 131/394
Value_50Hz12944260Hz132395 | 127 | 50 Hz: 129/442 / 60 Hz: 132/395
Value_50Hz13044360Hz133396 | 128 | 50 Hz: 130/443 / 60 Hz: 133/396
Value_50Hz13144460Hz134397 | 129 | 50 Hz: 131/444 / 60 Hz: 134/397
Value_50Hz13244560Hz135398 | 130 | 50 Hz: 132/445 / 60 Hz: 135/398
Value_50Hz13344660Hz136399 | 131 | 50 Hz: 133/446 / 60 Hz: 136/399
Value_50Hz13444760Hz137400 | 132 | 50 Hz: 134/447 / 60 Hz: 137/400
Value_50Hz13544860Hz138401 | 133 | 50 Hz: 135/448 / 60 Hz: 138/401
Value_50Hz13644960Hz139402 | 134 | 50 Hz: 136/449 / 60 Hz: 139/402
Value_50Hz13745060Hz140403 | 135 | 50 Hz: 137/450 / 60 Hz: 140/403
Value_50Hz13845160Hz141404 | 136 | 50 Hz: 138/451 / 60 Hz: 141/404
Value_50Hz13945260Hz142405 | 137 | 50 Hz: 139/452 / 60 Hz: 142/405
Value_50Hz14045360Hz143406 | 138 | 50 Hz: 140/453 / 60 Hz: 143/406
Value_50Hz14145460Hz144407 | 139 | 50 Hz: 141/454 / 60 Hz: 144/407
Value_50Hz14245560Hz145408 | 140 | 50 Hz: 142/455 / 60 Hz: 145/408
Value_50Hz14345660Hz146409 | 141 | 50 Hz: 143/456 / 60 Hz: 146/409
Value_50Hz14445760Hz147410 | 142 | 50 Hz: 144/457 / 60 Hz: 147/410
Value_50Hz14545860Hz148411 | 143 | 50 Hz: 145/458 / 60 Hz: 148/411
Value_50Hz14645960Hz149412 | 144 | 50 Hz: 146/459 / 60 Hz: 149/412
Value_50Hz14746060Hz150413 | 145 | 50 Hz: 147/460 / 60 Hz: 150/413
Value_50Hz14846160Hz151414 | 146 | 50 Hz: 148/461 / 60 Hz: 151/414
Value_50Hz14946260Hz152415 | 147 | 50 Hz: 149/462 / 60 Hz: 152/415
Value_50Hz15046360Hz153416 | 148 | 50 Hz: 150/463 / 60 Hz: 153/416
Value_50Hz15146460Hz154417 | 149 | 50 Hz: 151/464 / 60 Hz: 154/417
Value_50Hz15246560Hz155418 | 150 | 50 Hz: 152/465 / 60 Hz: 155/418
Value_50Hz15346660Hz156419 | 151 | 50 Hz: 153/466 / 60 Hz: 156/419
Value_50Hz15446760Hz157420 | 152 | 50 Hz: 154/467 / 60 Hz: 157/420
Value_50Hz15546860Hz158421 | 153 | 50 Hz: 155/468 / 60 Hz: 158/421
Value_50Hz15646960Hz159422 | 154 | 50 Hz: 156/469 / 60 Hz: 159/422
Value_50Hz15747060Hz160423 | 155 | 50 Hz: 157/470 / 60 Hz: 160/423
Value_50Hz15847160Hz161424 | 156 | 50 Hz: 158/471 / 60 Hz: 161/424
Value_50Hz15947260Hz162425 | 157 | 50 Hz: 159/472 / 60 Hz: 162/425
Value_50Hz16047360Hz163426 | 158 | 50 Hz: 160/473 / 60 Hz: 163/426
Value_50Hz16147460Hz164427 | 159 | 50 Hz: 161/474 / 60 Hz: 164/427
Value_50Hz16247560Hz165428 | 160 | 50 Hz: 162/475 / 60 Hz: 165/428
Value_50Hz16347660Hz166429 | 161 | 50 Hz: 163/476 / 60 Hz: 166/429
Value_50Hz16447760Hz167430 | 162 | 50 Hz: 164/477 / 60 Hz: 167/430
Value_50Hz16547860Hz168431 | 163 | 50 Hz: 165/478 / 60 Hz: 168/431
Value_50Hz16647960Hz169432 | 164 | 50 Hz: 166/479 / 60 Hz: 169/432
Value_50Hz16748060Hz170433 | 165 | 50 Hz: 167/480 / 60 Hz: 170/433
Value_50Hz16848160Hz171434 | 166 | 50 Hz: 168/481 / 60 Hz: 171/434
Value_50Hz16948260Hz172435 | 167 | 50 Hz: 169/482 / 60 Hz: 172/435
Value_50Hz17048360Hz173436 | 168 | 50 Hz: 170/483 / 60 Hz: 173/436
Value_50Hz17148460Hz174437 | 169 | 50 Hz: 171/484 / 60 Hz: 174/437
Value_50Hz17248560Hz175438 | 170 | 50 Hz: 172/485 / 60 Hz: 175/438
Value_50Hz17348660Hz176439 | 171 | 50 Hz: 173/486 / 60 Hz: 176/439
Value_50Hz17448760Hz177440 | 172 | 50 Hz: 174/487 / 60 Hz: 177/440
Value_50Hz17548860Hz178441 | 173 | 50 Hz: 175/488 / 60 Hz: 178/441
Value_50Hz17648960Hz179442 | 174 | 50 Hz: 176/489 / 60 Hz: 179/442
Value_50Hz17749060Hz180443 | 175 | 50 Hz: 177/490 / 60 Hz: 180/443
Value_50Hz17849160Hz181444 | 176 | 50 Hz: 178/491 / 60 Hz: 181/444
Value_50Hz17949260Hz182445 | 177 | 50 Hz: 179/492 / 60 Hz: 182/445
Value_50Hz18049360Hz183446 | 178 | 50 Hz: 180/493 / 60 Hz: 183/446
Value_50Hz18149460Hz184447 | 179 | 50 Hz: 181/494 / 60 Hz: 184/447
Value_50Hz18249560Hz185448 | 180 | 50 Hz: 182/495 / 60 Hz: 185/448
Value_50Hz18349660Hz186449 | 181 | 50 Hz: 183/496 / 60 Hz: 186/449
Value_50Hz18449760Hz187450 | 182 | 50 Hz: 184/497 / 60 Hz: 187/450
Value_50Hz18549860Hz188451 | 183 | 50 Hz: 185/498 / 60 Hz: 188/451
Value_50Hz18649960Hz189452 | 184 | 50 Hz: 186/499 / 60 Hz: 189/452
Value_50Hz18750060Hz190453 | 185 | 50 Hz: 187/500 / 60 Hz: 190/453
Value_50Hz18850160Hz191454 | 186 | 50 Hz: 188/501 / 60 Hz: 191/454
Value_50Hz18950260Hz192455 | 187 | 50 Hz: 189/502 / 60 Hz: 192/455
Value_50Hz19050360Hz193456 | 188 | 50 Hz: 190/503 / 60 Hz: 193/456
Value_50Hz19150460Hz194457 | 189 | 50 Hz: 191/504 / 60 Hz: 194/457
Value_50Hz19250560Hz195458 | 190 | 50 Hz: 192/505 / 60 Hz: 195/458
Value_50Hz19350660Hz196459 | 191 | 50 Hz: 193/506 / 60 Hz: 196/459
Value_50Hz19450760Hz197460 | 192 | 50 Hz: 194/507 / 60 Hz: 197/460
Value_50Hz19550860Hz198461 | 193 | 50 Hz: 195/508 / 60 Hz: 198/461
Value_50Hz19650960Hz199462 | 194 | 50 Hz: 196/509 / 60 Hz: 199/462
Value_50Hz19751060Hz200463 | 195 | 50 Hz: 197/510 / 60 Hz: 200/463
Value_50Hz19851160Hz201464 | 196 | 50 Hz: 198/511 / 60 Hz: 201/464
Value_50Hz19951260Hz202465 | 197 | 50 Hz: 199/512 / 60 Hz: 202/465
Value_50Hz20051360Hz203466 | 198 | 50 Hz: 200/513 / 60 Hz: 203/466
Value_50Hz20151460Hz204467 | 199 | 50 Hz: 201/514 / 60 Hz: 204/467
Value_50Hz20251560Hz205468 | 200 | 50 Hz: 202/515 / 60 Hz: 205/468
Value_50Hz20351660Hz206469 | 201 | 50 Hz: 203/516 / 60 Hz: 206/469
Value_50Hz20451760Hz207470 | 202 | 50 Hz: 204/517 / 60 Hz: 207/470
Value_50Hz20551860Hz208471 | 203 | 50 Hz: 205/518 / 60 Hz: 208/471
Value_50Hz20651960Hz209472 | 204 | 50 Hz: 206/519 / 60 Hz: 209/472
Value_50Hz20752060Hz210473 | 205 | 50 Hz: 207/520 / 60 Hz: 210/473
Value_50Hz20852160Hz211474 | 206 | 50 Hz: 208/521 / 60 Hz: 211/474
Value_50Hz20952260Hz212475 | 207 | 50 Hz: 209/522 / 60 Hz: 212/475
Value_50Hz21052360Hz213476 | 208 | 50 Hz: 210/523 / 60 Hz: 213/476
Value_50Hz21152460Hz214477 | 209 | 50 Hz: 211/524 / 60 Hz: 214/477
Value_50Hz21252560Hz215478 | 210 | 50 Hz: 212/525 / 60 Hz: 215/478
Value_50Hz21352660Hz216479 | 211 | 50 Hz: 213/526 / 60 Hz: 216/479
Value_50Hz21452760Hz217480 | 212 | 50 Hz: 214/527 / 60 Hz: 217/480
Value_50Hz21552860Hz218481 | 213 | 50 Hz: 215/528 / 60 Hz: 218/481
Value_50Hz21652960Hz219482 | 214 | 50 Hz: 216/529 / 60 Hz: 219/482
Value_50Hz21753060Hz220483 | 215 | 50 Hz: 217/530 / 60 Hz: 220/483
Value_50Hz21853160Hz221484 | 216 | 50 Hz: 218/531 / 60 Hz: 221/484
Value_50Hz21953260Hz222485 | 217 | 50 Hz: 219/532 / 60 Hz: 222/485
Value_50Hz22053360Hz223486 | 218 | 50 Hz: 220/533 / 60 Hz: 223/486
Value_50Hz22153460Hz224487 | 219 | 50 Hz: 221/534 / 60 Hz: 224/487
Value_50Hz22253560Hz225488 | 220 | 50 Hz: 222/535 / 60 Hz: 225/488
Value_50Hz22353660Hz226489 | 221 | 50 Hz: 223/536 / 60 Hz: 226/489
Value_50Hz22453760Hz227490 | 222 | 50 Hz: 224/537 / 60 Hz: 227/490
Value_50Hz22553860Hz228491 | 223 | 50 Hz: 225/538 / 60 Hz: 228/491
Value_50Hz22653960Hz229492 | 224 | 50 Hz: 226/539 / 60 Hz: 229/492
Value_50Hz22754060Hz230493 | 225 | 50 Hz: 227/540 / 60 Hz: 230/493
Value_50Hz22854160Hz231494 | 226 | 50 Hz: 228/541 / 60 Hz: 231/494
Value_50Hz22954260Hz232495 | 227 | 50 Hz: 229/542 / 60 Hz: 232/495
Value_50Hz23054360Hz233496 | 228 | 50 Hz: 230/543 / 60 Hz: 233/496
Value_50Hz23154460Hz234497 | 229 | 50 Hz: 231/544 / 60 Hz: 234/497
Value_50Hz23254560Hz235498 | 230 | 50 Hz: 232/545 / 60 Hz: 235/498
Value_50Hz23354660Hz236499 | 231 | 50 Hz: 233/546 / 60 Hz: 236/499
Value_50Hz23454760Hz237500 | 232 | 50 Hz: 234/547 / 60 Hz: 237/500
Value_50Hz23554860Hz238501 | 233 | 50 Hz: 235/548 / 60 Hz: 238/501
Value_50Hz23654960Hz239502 | 234 | 50 Hz: 236/549 / 60 Hz: 239/502
Value_50Hz23755060Hz240503 | 235 | 50 Hz: 237/550 / 60 Hz: 240/503
Value_50Hz23855160Hz241504 | 236 | 50 Hz: 238/551 / 60 Hz: 241/504
Value_50Hz23955260Hz242505 | 237 | 50 Hz: 239/552 / 60 Hz: 242/505
Value_50Hz24055360Hz243506 | 238 | 50 Hz: 240/553 / 60 Hz: 243/506
Value_50Hz24155460Hz244507 | 239 | 50 Hz: 241/554 / 60 Hz: 244/507
Value_50Hz24255560Hz245508 | 240 | 50 Hz: 242/555 / 60 Hz: 245/508
Value_50Hz24355660Hz246509 | 241 | 50 Hz: 243/556 / 60 Hz: 246/509
Value_50Hz24455760Hz247510 | 242 | 50 Hz: 244/557 / 60 Hz: 247/510
Value_50Hz24555860Hz248511 | 243 | 50 Hz: 245/558 / 60 Hz: 248/511
Value_50Hz24655960Hz249512 | 244 | 50 Hz: 246/559 / 60 Hz: 249/512
Value_50Hz24756060Hz250513 | 245 | 50 Hz: 247/560 / 60 Hz: 250/513
Value_50Hz24856160Hz251514 | 246 | 50 Hz: 248/561 / 60 Hz: 251/514
Value_50Hz24956260Hz252515 | 247 | 50 Hz: 249/562 / 60 Hz: 252/515
Value_50Hz25056360Hz253516 | 248 | 50 Hz: 250/563 / 60 Hz: 253/516
Value_50Hz25156460Hz254517 | 249 | 50 Hz: 251/564 / 60 Hz: 254/517
Value_50Hz25256560Hz255518 | 250 | 50 Hz: 252/565 / 60 Hz: 255/518
Value_50Hz25356660Hz256519 | 251 | 50 Hz: 253/566 / 60 Hz: 256/519
Value_50Hz25456760Hz257520 | 252 | 50 Hz: 254/567 / 60 Hz: 257/520
Value_50Hz25556860Hz258521 | 253 | 50 Hz: 255/568 / 60 Hz: 258/521
Value_50Hz25656960Hz259522 | 254 | 50 Hz: 256/569 / 60 Hz: 259/522
Value_50Hz25757060Hz260523 | 255 | 50 Hz: 257/570 / 60 Hz: 260/523
Value_50Hz25857160Hz261524 | 256 | 50 Hz: 258/571 / 60 Hz: 261/524
Value_50Hz25957260Hz262525 | 257 | 50 Hz: 259/572 / 60 Hz: 262/525
Value_50Hz26057360Hz2631 | 258 | 50 Hz: 260/573 / 60 Hz: 263/1
Value_50Hz26157460Hz2642 | 259 | 50 Hz: 261/574 / 60 Hz: 264/2
Value_50Hz26257560Hz2653 | 260 | 50 Hz: 262/575 / 60 Hz: 265/3
Value_50Hz263576 | 261 | 50 Hz: 263/576
Value_50Hz26457760Hz4267 | 262 | 50 Hz: 264/577 / 60 Hz: 4/267
Value_50Hz265578 | 263 | 50 Hz: 265/578
Value_50Hz266579 | 264 | 50 Hz: 266/579
Value_50Hz267580 | 265 | 50 Hz: 267/580
Value_50Hz268581 | 266 | 50 Hz: 268/581
Value_50Hz269582 | 267 | 50 Hz: 269/582
Value_50Hz270583 | 268 | 50 Hz: 270/583
Value_50Hz271584 | 269 | 50 Hz: 271/584
Value_50Hz272585 | 270 | 50 Hz: 272/585
Value_50Hz273586 | 271 | 50 Hz: 273/586
Value_50Hz274587 | 272 | 50 Hz: 274/587
Value_50Hz275588 | 273 | 50 Hz: 275/588
Value_50Hz276589 | 274 | 50 Hz: 276/589
Value_50Hz277590 | 275 | 50 Hz: 277/590
Value_50Hz278591 | 276 | 50 Hz: 278/591
Value_50Hz279592 | 277 | 50 Hz: 279/592
Value_50Hz280593 | 278 | 50 Hz: 280/593
Value_50Hz281594 | 279 | 50 Hz: 281/594
Value_50Hz282595 | 280 | 50 Hz: 282/595
Value_50Hz283596 | 281 | 50 Hz: 283/596
Value_50Hz284597 | 282 | 50 Hz: 284/597
Value_50Hz285598 | 283 | 50 Hz: 285/598
Value_50Hz286599 | 284 | 50 Hz: 286/599
Value_50Hz287600 | 285 | 50 Hz: 287/600
Value_50Hz288601 | 286 | 50 Hz: 288/601
Value_50Hz289602 | 287 | 50 Hz: 289/602
Value_50Hz290603 | 288 | 50 Hz: 290/603
Value_50Hz291604 | 289 | 50 Hz: 291/604
Value_50Hz292605 | 290 | 50 Hz: 292/605
Value_50Hz293606 | 291 | 50 Hz: 293/606
Value_50Hz294607 | 292 | 50 Hz: 294/607
Value_50Hz295608 | 293 | 50 Hz: 295/608
Value_50Hz296609 | 294 | 50 Hz: 296/609
Value_50Hz297610 | 295 | 50 Hz: 297/610
Value_50Hz298611 | 296 | 50 Hz: 298/611
Value_50Hz299612 | 297 | 50 Hz: 299/612
Value_50Hz300613 | 298 | 50 Hz: 300/613
Value_50Hz301614 | 299 | 50 Hz: 301/614
Value_50Hz302615 | 300 | 50 Hz: 302/615
Value_50Hz303616 | 301 | 50 Hz: 303/616
Value_50Hz304617 | 302 | 50 Hz: 304/617
Value_50Hz305618 | 303 | 50 Hz: 305/618
Value_50Hz306619 | 304 | 50 Hz: 306/619
Value_50Hz307620 | 305 | 50 Hz: 307/620
Value_50Hz308621 | 306 | 50 Hz: 308/621
Value_50Hz309622 | 307 | 50 Hz: 309/622
Value_50Hz310623 | 308 | 50 Hz: 310/623
Value_50Hz311624 | 309 | 50 Hz: 311/624
Value_50Hz312625 | 310 | 50 Hz: 312/625
Value_50Hz1314 | 312 | 50 Hz: 1/314
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDXPORTIOENABLEKPHASECONTROL0 Enumeration

IRD

Saa7118TYPIDXPORTIOENABLEKPHASECONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDXPORTIOENABLEKPHASECONTROL0
Public Enumeration TYPIDXPORTIOENABLEKPHASECONTROL0
public enum class TYPIDXPORTIOENABLEKPHASECONTROL0
type TYPIDXPORTIOENABLEKPHASECONTROL0
Members
Member name | Value | Description
DisabledBySoftware | 0 | Disabled by software
EnabledBySoftware | 1 | Enabled by software
EnabledByPinXTRIAtLogic0 | 2 | Enabled by pin XTRI at logic 0
EnabledByPinXTRIAtLogic1 | 3 | Enabled by pin XTRI at logic 1
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDXPORTIOENABLEKPHASECONTROL1 Enumeration

IRD

Saa7118TYPIDXPORTIOENABLEKPHASECONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDXPORTIOENABLEKPHASECONTROL1
Public Enumeration TYPIDXPORTIOENABLEKPHASECONTROL1
public enum class TYPIDXPORTIOENABLEKPHASECONTROL1
type TYPIDXPORTIOENABLEKPHASECONTROL1
Members
Member name | Value | Description
ABTaskFlagFromEventHandlerA1 | 0 | A/B task flag from event handler (A = 1)
ReadySignalFromScalerPathXRDY1MeansTheSAA7118IsReadyToReceiveData | 1 | Ready signal from scaler path (XRDY = 1 means the SAA7118 is ready to receive data)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDXPORTIOENABLEKPHASECONTROL2 Enumeration

IRD

Saa7118TYPIDXPORTIOENABLEKPHASECONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDXPORTIOENABLEKPHASECONTROL2
Public Enumeration TYPIDXPORTIOENABLEKPHASECONTROL2
public enum class TYPIDXPORTIOENABLEKPHASECONTROL2
type TYPIDXPORTIOENABLEKPHASECONTROL2
Members
Member name | Value | Description
DefaultOutputPhase | 0 | Default output phase
OutputInverted | 1 | Output inverted
PhaseShiftedByApproximately3Ns | 2 | Phase shifted by approximately 3 ns
OutputInvertedAndShiftedByApproximately3Ns | 3 | Output inverted and shifted by approximately 3 ns
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDXPORTSIGNALDEFONSTEXTSLICER0 Enumeration

IRD

Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDXPORTSIGNALDEFONSTEXTSLICER0
Public Enumeration TYPIDXPORTSIGNALDEFONSTEXTSLICER0
public enum class TYPIDXPORTSIGNALDEFONSTEXTSLICER0
type TYPIDXPORTSIGNALDEFONSTEXTSLICER0
Members
Member name | Value | Description
DefaultPolarity | 0 | Default polarity
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDXPORTSIGNALDEFONSTEXTSLICER5 Enumeration

IRD

Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER5 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDXPORTSIGNALDEFONSTEXTSLICER5
Public Enumeration TYPIDXPORTSIGNALDEFONSTEXTSLICER5
public enum class TYPIDXPORTSIGNALDEFONSTEXTSLICER5
type TYPIDXPORTSIGNALDEFONSTEXTSLICER5
Members
Member name | Value | Description
VideoDataLimitedToRange1To254 | 0 | Video data limited to range 1 to 254
VideoDataLimitedToRange8To247 | 1 | Video data limited to range 8 to 247
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7118.TYPIDXPORTSIGNALDEFONSTEXTSLICER6 Enumeration

IRD

Saa7118TYPIDXPORTSIGNALDEFONSTEXTSLICER6 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDXPORTSIGNALDEFONSTEXTSLICER6
Public Enumeration TYPIDXPORTSIGNALDEFONSTEXTSLICER6
public enum class TYPIDXPORTSIGNALDEFONSTEXTSLICER6
type TYPIDXPORTSIGNALDEFONSTEXTSLICER6
Members
Member name | Value | Description
D0D1D2D3FF0000SAVCB0Y0CR0Y1 | 0 | D0 D1 D2 D3 . FF 00 00 SAV CB0 Y0 CR0 Y1
D1D0D3D200FFSAV00Y0CB0Y1CR0 | 1 | D1 D0 D3 D2 . 00 FF SAV 00 Y0 CB0 Y1 CR0
D2D3D0D100SAVFF00CR0Y1CB0Y0 | 2 | D2 D3 D0 D1 . 00 SAV FF 00 CR0 Y1 CB0 Y0
D3D2D1D0SAV0000FFY1CR0Y0CB0 | 3 | D3 D2 D1 D0 . SAV 00 00 FF Y1 CR0 Y0 CB0
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119 Class

NXP Semiconductors: SAA 7119
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsSaa7119

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Saa7119
Public Class Saa7119
public ref class Saa7119
type Saa7119 =  class end

The Saa7119 type exposes the following members.

Constructors
 | Name | Description
Public method | Saa7119 | Constructor
Top
Properties
 | Name | Description
Public property | AdaptiveChrominanceCombFilter | Adaptive chrominance comb filter
Public property | AdaptiveLuminanceCombFilter | Adaptive luminance comb filter
Public property | AGA1 | AGA1
Public property | AGA2 | AGA2
Public property | ALRCLKPhase | ALRCLK phase
Public property | AlternativeVGATEPosition | Alternative VGATE position
Public property | AmplitudeSearching | Amplitude searching
Public property | AnalogTestSelect | Analog test select
Public property | AnalogueGainStageHasReachedItsLowerLimitOfOperationRange | Analogue gain stage has reached its lower limit of operation range
Public property | AnalogueGainStageHasReachedItsUpperLimitOfOperationRange | Analogue gain stage has reached its upper limit of operation range
Public property | ASCLKPhase | ASCLK phase
Public property | AudioClockCGCGenerationMode | Audio clock: CGC Generation mode
Public property | AudioClockGeneration | Audio clock generation
Public property | AudioMasterClockAMCLKNominalIncrement | Audio master clock (AMCLK) nominal increment
Public property | AudioMasterClockCyclesPerField | Audio master clock cycles per field
Public property | AudioMasterClockVerticalReference | Audio master clock vertical reference
Public property | AudioPLLModes | Audio PLL modes
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AutomaticaVCRTVDetectionThreshold | Automatica VCR/TV-detection threshold
Public property | AutomaticChrominanceStandardDetectionControl | Automatic chrominance standard detection control
Public property | AutomaticColorLimiter | Automatic color limiter
Public property | AutomaticFieldDetection | Automatic field detection
Public property | AutomaticGainControlIntegration | Automatic gain control integration
Public property | AutoStandardsSearchModeShort | Auto standards search mode short
Public property | BONDID | BONDID
Public property | CCHeaderEvenFieldsBeingUpdated | CC Header: Even fields: Being updated
Public property | CCHeaderEvenFieldsDataErroneous | CC Header: Even fields: Data erroneous
Public property | CCHeaderFreeRunningFieldCounter | CC Header: free running field counter
Public property | CCHeaderOddFieldsBeingUpdated | CC Header: Odd fields: Being updated
Public property | CCHeaderOddFieldsDataErroneous | CC Header: Odd fields: Data erroneous
Public property | CCPayloadDataByte1EvenFields | CC payload data byte 1 (even fields)
Public property | CCPayloadDataByte1OddFields | CC payload data byte 1 (odd fields)
Public property | CCPayloadDataByte2EvenFields | CC payload data byte 2 (even fields)
Public property | CCPayloadDataByte2OddFields | CC payload data byte 2 (odd fields)
Public property | CG1FeedbackDivider | CG1 Feedback Divider
Public property | ChangeOf12LineCharacteristicOfTheRetimedVAndFSignals | Change of 1/2 line characteristic of the retimed V and F signals
Public property | ChipID | Chip ID
Public property | ChrominanceBandwidth | Chrominance bandwidth
Public property | ChrominanceGainValue | Chrominance gain value
Public property | ChrominanceHueControl | Chrominance hue control
Public property | ChrominanceSaturationControlComponentPartNegInverse | Chrominance saturation control component part (neg=inverse)
Public property | ChrominanceSaturationControlDecoderPartNegInverse | Chrominance saturation control: Decoder part (neg=inverse)
Public property | ChrominanceTrapCombFilterBypass | Chrominance trap/comb filter bypass
Public property | ClockDelay | Clock Delay
Public property | ClockRatioAudioMasterClockAMXCLKToSerialBitClock | Clock ratio audio master clock (AMXCLK) to serial bit clock
Public property | ClockRatioSerialBitClockASCLKToChannelSelectClockALRCLK | Clock ratio serial bit clock (ASCLK) to channel select clock (ALRCLK)
Public property | ColourOn | Colour on
Public property | ColourStandardSelectionInAUTOMode | Colour standard selection in AUTO mode
Public property | CombinedLuminanceChrominanceBandwidthAdjustment | Combined luminance/chrominance bandwidth adjustment
Public property | CombThreshold | Comb threshold
Public property | ConstantHigh | Constant_high
Public property | ConstantLow | Constant_low
Public property | ContinuousFieldMode | Continuous field mode
Public property | CopyOfBitDPROGCanBeUsedToDetectPowerUpAndStartUpFails | Copy of bit DPROG, can be used to detect power-up and start-up fails
Public property | CopyProtectedSourceDetected | Copy protected source detected
Public property | CV0 | CV0
Public property | DecoderAndVBISlicer | Decoder and VBI slicer
Public property | DetectedColourStandard | Detected colour standard
Public property | DFQBP | DFQBP
Public property | DGA1 | DGA1 (unit: dB)
Public property | DGA2 | DGA2 (unit: dB)
Public property | DigitalGainStageHasReachedItsLowerLimitOfOperationRange | Digital gain stage has reached its lower limit of operation range
Public property | DigitalGainStageHasReachedItsUpperLimitOfOperationRange | Digital gain stage has reached its upper limit of operation range
Public property | DisableChrominanceVerticalFilterAndPALPhaseErrorCorrection | Disable chrominance vertical filter and PAL phase error correction
Public property | DitherModeAtDataPathOutput | Dither mode at data path output
Public property | DividerReset | Divider Reset
Public property | DPROG | DPROG
Public property | DwordByteSwapInfluencesSerialOutputTiming | Dword byte swap, influences serial output timing
Public property | EdgiEdgeBufferFull | Edgi Edge Buffer Full
Public property | EdgiFifoFull | Edgi Fifo Full
Public property | EnableClock1Generation | Enable Clock 1 Generation
Public property | EnableTheFIRFilterAsASecondOrderLowPass | Enable the FIR filter as a second-order low-pass
Public property | ErrorFlagOfScalersOutputFormatter | Error flag of scalers output formatter
Public property | EvenFieldsBeingUpdated | Even fields: Being updated
Public property | EvenFieldsDataErroneous | Even fields: Data erroneous
Public property | ExpertMode | Expert Mode
Public property | ExternalSourceSwitchIndicatorInputEXMCLR | External source switch indicator Input EXMCLR
Public property | FAEFIFOFlagAlmostEmptyLevel | FAE FIFO flag almost empty level
Public property | FAFFIFOFlagAlmostFullLevel | FAF FIFO flag almost full level
Public property | FastColourTimeConstant | Fast colour time constant
Public property | FASTCondition | FAST condition
Public property | FastPALSECAMSequenceCorrection | Fast PAL/SECAM sequence correction
Public property | FastSwitchInputSelect | Fast switch input select
Public property | FastSwitchPreviousFieldCriteria | Fast switch previous field criteria
Public property | FieldOffset | Field offset
Public property | FieldSelection | Field selection
Public property | Filter1Bypass | Filter 1 Bypass
Public property | Filter2Bypass | Filter 2 Bypass
Public property | FineOffsetAdjustmentBYComponent | Fine offset adjustment B - Y component
Public property | FineOffsetAdjustmentRYComponent | Fine offset adjustment R - Y component
Public property | FinePositionOfHS | Fine position of HS
Public property | FixColorPLL | Fix color PLL
Public property | ForceAnalogueGainForChannel1 | Force analogue gain for channel 1 (unit: dB)
Public property | ForceAnalogueGainForChannel1__1 | Force analogue gain for channel 1 (unit: dB)
Public property | ForceDigitalGainForChannel1 | Force digital gain for channel 1
Public property | ForceDigitalGainForChannel1CVBSY | Force digital gain for channel 1 (CVBS/Y)
Public property | ForcedODDEVENToggle | Forced ODD/EVEN toggle
Public property | FramingCodeError | Framing Code Error
Public property | FramingCodeForProgrammableDataTypes | Framing code for programmable data types
Public property | FreeRunningFieldCounter | Free running field counter
Public property | FSSHFT | FSSHFT
Public property | FSWAlphaValueOutputInverted | FSW alpha value output inverted
Public property | GainControlFix | Gain control fix
Public property | GainControlFixedAnalog | Gain control fixed analog
Public property | GS1HeaderEvenFieldsBeingUpdated | GS1 header: Even fields: Being updated
Public property | GS1HeaderEvenFieldsDataErroneous | GS1 header: Even fields: Data erroneous
Public property | GS1HeaderFreeRunningFieldCounter | GS1 header: free running field counter
Public property | GS1HeaderOddFieldsBeingUpdated | GS1 header: Odd fields: Being updated
Public property | GS1HeaderOddFieldsDataErroneous | GS1 header: Odd fields: Data erroneous
Public property | GS1PayloadDataByte1EvenFields | GS1 payload data byte 1 (even fields)
Public property | GS1PayloadDataByte1OddFields | GS1 payload data byte 1 (odd fields)
Public property | GS1PayloadDataByte2EvenFields | GS1 payload data byte 2 (even fields)
Public property | GS1PayloadDataByte2OddFields | GS1 payload data byte 2 (odd fields)
Public property | GS2PayloadDataByte1EvenFields | GS2 payload data byte 1 (even fields)
Public property | GS2PayloadDataByte1OddFields | GS2 payload data byte 1 (odd fields)
Public property | GS2PayloadDataByte2EvenFields | GS2 payload data byte 2 (even fields)
Public property | GS2PayloadDataByte2OddFields | GS2 payload data byte 2 (odd fields)
Public property | GS2PayloadDataByte3EvenFields | GS2 payload data byte 3 (even fields)
Public property | GS2PayloadDataByte3OddFields | GS2 payload data byte 3 (odd fields)
Public property | GS2PayloadDataByte4EvenFields | GS2 payload data byte 4 (even fields)
Public property | GS2PayloadDataByte4OddFields | GS2 payload data byte 4 (odd fields)
Public property | HammingCheck | Hamming Check
Public property | HorizontalDifferenceGain | Horizontal difference gain
Public property | HorizontalLockIndicatorSelection | Horizontal lock indicator selection
Public property | HorizontalOffsetForSlicer | Horizontal offset for slicer
Public property | HorizontalPLL | Horizontal PLL
Public property | HorizontalScalingModes | Horizontal Scaling Modes
Public property | HorizontalTimeConstantSelection | Horizontal time constant selection
Public property | HorSyncStartDelayTimeStepSize8LLC | Hor. sync start: Delay Time (Step size=8/LLC)
Public property | HorSyncStopDelayTimeStepSize8LLC | Hor. sync stop: Delay Time (Step size=8/LLC)
Public property | IDEL | IDEL
Public property | IdentificationBitForDetectedFieldFrequency | Identification bit for detected field frequency (unit: Hz)
Public property | IDQAsGatedClock | IDQ as gated clock
Public property | InterruptEnableColourStandardChanged0 | Interrupt enable 'colour standard changed 0'
Public property | InterruptEnableColourStandardChanged1 | Interrupt enable 'colour standard changed 1'
Public property | InterruptEnableColourStripeBurstAnyTypeDetectedLost | Interrupt enable 'colour stripe burst (any type) detected/lost'
Public property | InterruptEnableColourStripeType3BurstDetectedLost | Interrupt enable 'colour stripe type 3 burst detected/lost'
Public property | InterruptEnableCopyProtectedSignalFoundLost | Interrupt enable 'copy protected signal found/lost'
Public property | InterruptEnableCopyProtectedSignalFoundLostSecondI2CSlave | Interrupt enable 'copy protected signal found/lost' (second I2C slave)
Public property | InterruptEnableErrorOutputFormatter | Interrupt enable 'error output formatter'
Public property | InterruptEnableFieldFrequencyHasChanged | Interrupt enable 'field frequency has changed'
Public property | InterruptEnableHorizontalAndVerticalLockReachedLost | Interrupt enable 'horizontal and vertical lock reached/lost'
Public property | InterruptEnableHorizontalPLLLockedUnlocked | Interrupt enable 'horizontal PLL locked/unlocked'
Public property | InterruptEnableInterlacedNonInterlacedSource | Interrupt enable 'interlaced/non-interlaced source'
Public property | InterruptEnableNominalFieldLengthDetectedLost | Interrupt enable 'nominal field length detected/lost'
Public property | InterruptEnableNominalFieldLengthDetectedLostSecondI2CSlave | Interrupt enable 'nominal field length detected/lost' (second I2C slave)
Public property | InterruptEnableReadyForCaptureNotReady | Interrupt enable 'ready for capture/not ready'
Public property | InterruptEnableReadyForCaptureNotReadySecondI2CSlave | Interrupt enable 'ready for capture/not ready' (second I2C slave)
Public property | IPortDataClock | I-Port data clock
Public property | IPortGlobalVideoTransferControl | I - port global video transfer control
Public property | IPortOutput | I-port output
Public property | IPortPackingMode | I-Port Packing mode
Public property | IPortSignalDefinitionsIGP0 | I - port signal definitions IGP0
Public property | IPortSignalDefinitionsIGP1 | I - port signal definitions IGP1
Public property | IPortSignalDefinitionsIGPH | I-port signal definitions: IGPH
Public property | IPortSignalDefinitionsIGPV | I-port signal definitions: IGPV
Public property | LCRRegister10Field16050Hz | LCR Register 10: Field 1 (60/50 Hz)
Public property | LCRRegister10Field26050Hz | LCR Register 10: Field 2 (60/50 Hz)
Public property | LCRRegister11Field16050Hz | LCR Register 11: Field 1 (60/50 Hz)
Public property | LCRRegister11Field26050Hz | LCR Register 11: Field 2 (60/50 Hz)
Public property | LCRRegister12Field16050Hz | LCR Register 12: Field 1 (60/50 Hz)
Public property | LCRRegister12Field26050Hz | LCR Register 12: Field 2 (60/50 Hz)
Public property | LCRRegister13Field16050Hz | LCR Register 13: Field 1 (60/50 Hz)
Public property | LCRRegister13Field26050Hz | LCR Register 13: Field 2 (60/50 Hz)
Public property | LCRRegister14Field16050Hz | LCR Register 14: Field 1 (60/50 Hz)
Public property | LCRRegister14Field26050Hz | LCR Register 14: Field 2 (60/50 Hz)
Public property | LCRRegister15Field16050Hz | LCR Register 15: Field 1 (60/50 Hz)
Public property | LCRRegister15Field26050Hz | LCR Register 15: Field 2 (60/50 Hz)
Public property | LCRRegister16Field16050Hz | LCR Register 16: Field 1 (60/50 Hz)
Public property | LCRRegister16Field26050Hz | LCR Register 16: Field 2 (60/50 Hz)
Public property | LCRRegister17Field16050Hz | LCR Register 17: Field 1 (60/50 Hz)
Public property | LCRRegister17Field26050Hz | LCR Register 17: Field 2 (60/50 Hz)
Public property | LCRRegister18Field16050Hz | LCR Register 18: Field 1 (60/50 Hz)
Public property | LCRRegister18Field26050Hz | LCR Register 18: Field 2 (60/50 Hz)
Public property | LCRRegister19Field16050Hz | LCR Register 19: Field 1 (60/50 Hz)
Public property | LCRRegister19Field26050Hz | LCR Register 19: Field 2 (60/50 Hz)
Public property | LCRRegister20Field16050Hz | LCR Register 20: Field 1 (60/50 Hz)
Public property | LCRRegister20Field26050Hz | LCR Register 20: Field 2 (60/50 Hz)
Public property | LCRRegister21Field16050Hz | LCR Register 21: Field 1 (60/50 Hz)
Public property | LCRRegister21Field26050Hz | LCR Register 21: Field 2 (60/50 Hz)
Public property | LCRRegister22Field16050Hz | LCR Register 22: Field 1 (60/50 Hz)
Public property | LCRRegister22Field26050Hz | LCR Register 22: Field 2 (60/50 Hz)
Public property | LCRRegister23Field16050Hz | LCR Register 23: Field 1 (60/50 Hz)
Public property | LCRRegister23Field26050Hz | LCR Register 23: Field 2 (60/50 Hz)
Public property | LCRRegister24Field16050Hz | LCR Register 24: Field 1 (60/50 Hz)
Public property | LCRRegister24Field26050Hz | LCR Register 24: Field 2 (60/50 Hz)
Public property | LCRRegister2Field16050Hz | LCR Register 2: Field 1 (60/50 Hz)
Public property | LCRRegister2Field26050Hz | LCR Register 2: Field 2 (60/50 Hz)
Public property | LCRRegister3Field16050Hz | LCR Register 3: Field 1 (60/50 Hz)
Public property | LCRRegister3Field26050Hz | LCR Register 3: Field 2 (60/50 Hz)
Public property | LCRRegister4Field16050Hz | LCR Register 4: Field 1 (60/50 Hz)
Public property | LCRRegister4Field26050Hz | LCR Register 4: Field 2 (60/50 Hz)
Public property | LCRRegister5Field16050Hz | LCR Register 5: Field 1 (60/50 Hz)
Public property | LCRRegister5Field26050Hz | LCR Register 5: Field 2 (60/50 Hz)
Public property | LCRRegister6Field16050Hz | LCR Register 6: Field 1 (60/50 Hz)
Public property | LCRRegister6Field26050Hz | LCR Register 6: Field 2 (60/50 Hz)
Public property | LCRRegister7Field16050Hz | LCR Register 7: Field 1 (60/50 Hz)
Public property | LCRRegister7Field26050Hz | LCR Register 7: Field 2 (60/50 Hz)
Public property | LCRRegister8Field16050Hz | LCR Register 8: Field 1 (60/50 Hz)
Public property | LCRRegister8Field26050Hz | LCR Register 8: Field 2 (60/50 Hz)
Public property | LCRRegister9Field16050Hz | LCR Register 9: Field 1 (60/50 Hz)
Public property | LCRRegister9Field26050Hz | LCR Register 9: Field 2 (60/50 Hz)
Public property | LeftSlopeForKeystoneCompensation | Left Slope for keystone compensation
Public property | LengthAccumulationFilter | Length accumulation filter
Public property | LimitLevelImagePort | Limit Level Image Port
Public property | LLC2OutputEnable | LLC2 output enable
Public property | LLCOutputEnable | LLC output enable
Public property | LNFE10 | LNFE10
Public property | LNFE11 | LNFE11
Public property | LNFE12 | LNFE12
Public property | LNFE13 | LNFE13
Public property | LNFE14 | LNFE14
Public property | LNFE15 | LNFE15
Public property | LNFE16 | LNFE16
Public property | LNFE17 | LNFE17
Public property | LNFE18 | LNFE18
Public property | LNFE19 | LNFE19
Public property | LNFE2 | LNFE2
Public property | LNFE20 | LNFE20
Public property | LNFE21 | LNFE21
Public property | LNFE22 | LNFE22
Public property | LNFE23 | LNFE23
Public property | LNFE24 | LNFE24
Public property | LNFE3 | LNFE3
Public property | LNFE4 | LNFE4
Public property | LNFE5 | LNFE5
Public property | LNFE6 | LNFE6
Public property | LNFE7 | LNFE7
Public property | LNFE8 | LNFE8
Public property | LNFE9 | LNFE9
Public property | LNFO10 | LNFO10
Public property | LNFO11 | LNFO11
Public property | LNFO12 | LNFO12
Public property | LNFO13 | LNFO13
Public property | LNFO14 | LNFO14
Public property | LNFO15 | LNFO15
Public property | LNFO16 | LNFO16
Public property | LNFO17 | LNFO17
Public property | LNFO18 | LNFO18
Public property | LNFO19 | LNFO19
Public property | LNFO2 | LNFO2
Public property | LNFO20 | LNFO20
Public property | LNFO21 | LNFO21
Public property | LNFO22 | LNFO22
Public property | LNFO23 | LNFO23
Public property | LNFO24 | LNFO24
Public property | LNFO3 | LNFO3
Public property | LNFO4 | LNFO4
Public property | LNFO5 | LNFO5
Public property | LNFO6 | LNFO6
Public property | LNFO7 | LNFO7
Public property | LNFO8 | LNFO8
Public property | LNFO9 | LNFO9
Public property | LumaPeakingFilterEnable | Luma peaking filter enable
Public property | LuminanceBrightnessControlComponentPart | Luminance brightness control component part
Public property | LuminanceBrightnessControlDecoderPart | Luminance brightness control: decoder part
Public property | LuminanceContrastControlComponentPartNegInverse | Luminance contrast control component part (neg=inverse)
Public property | LuminanceContrastControlDecoderPartNegInverse | Luminance contrast control: Decoder part (neg=inverse)
Public property | LuminanceDelayCompensation | Luminance delay compensation
Public property | MacrovisionCopyProtectionEnable | Macrovision copy-protection enable
Public property | MacrovisionEncodedColourStripeBurstDetected | Macrovision encoded colour stripe burst detected
Public property | MacrovisionEncodedColourStripeBurstType34LineVersionDetected | Macrovision encoded colour stripe burst type 3 (4 line version) detected
Public property | MaximumVerticalNoiseReduction | Maximum vertical noise reduction
Public property | MedianFilterGain | Median filter gain
Public property | MixOfXPORTInputDataAndDecoderInputData | Mix of XPORT input data and decoder input data
Public property | ModeSelection | Mode selection
Public property | MSTTB | MSTTB
Public property | OddFieldsBeingUpdated | Odd fields: Being updated
Public property | OddFieldsDataErroneous | Odd fields: Data erroneous
Public property | OutputClockPhaseControl | Output clock phase control
Public property | OutputDivider | Output Divider
Public property | OverlayMode | Overlay mode
Public property | PALNTSCColorKillerLevelControl | PAL/NTSC Color Killer Level Control
Public property | PanelMode | Panel Mode
Public property | PanoramaMode | Panorama Mode
Public property | ParityBitGenerationHammingForITUCodeSequenceOnIPort | Parity Bit Generation (Hamming) for ITU code sequence on I-port
Public property | PFSL | PFSL
Public property | PLLActiveClock1MHz | PLL active (clock > 1MHz)
Public property | PLLLocked | PLL locked
Public property | PLLParameterI | PLL parameter I
Public property | PLLParameterP | PLL parameter P
Public property | PLLParameterR | PLL parameter R
Public property | PolarityOfRTS0OutputSignal | Polarity of RTS0 output signal
Public property | PolarityOfRTS1OutputSignal | Polarity of RTS1 output signal
Public property | PortAndScalerBackendClockSelection | Port and scaler backend clock selection
Public property | ProcessingDelayInNonCombFilterMode | Processing delay in non comb filter mode
Public property | ProgramableDelay | Programable delay
Public property | ProgramableDelay14Pixel | Programable delay (1/4 pixel)
Public property | ProgrammableComponentDelayAgainstCOMBDECProcessing | Programmable component delay against COMBDEC processing (unit: CLK1 delays)
Public property | RawDataGainControl | Raw data gain control
Public property | RawDataOffsetControl | Raw data offset control (unit: LSB)
Public property | ReadyForCapture | Ready for capture
Public property | RegSetA17SegmentCurvesForBCSInTheYUVOrColorManipulationsInTheRGBDomain | RegSet A: 17 segment curves for B,C,S in the YUV or color manipulations in the RGB domain
Public property | RegSetAAccumulationLength | RegSet A: Accumulation length
Public property | RegSetAChromaIsProvidedRegSetA | RegSet A: Chroma is provided(Reg. Set: A)
Public property | RegSetAChrominance | RegSet A: Chrominance
Public property | RegSetAChrominanceImprovementChangeOfCoringLevel | RegSet A: Chrominance Improvement: Change of coring level
Public property | RegSetAChrominanceImprovementSelectHighPassFilterForPeakComponent | RegSet A: Chrominance Improvement: Select High Pass Filter For Peak Component
Public property | RegSetAChrominanceImprovementSignalImprovementMode | RegSet A: Chrominance Improvement: Signal Improvement Mode
Public property | RegSetAChrominanceImprovementWeightingOfPeakComponent | RegSet A: Chrominance Improvement: Weighting of Peak Component
Public property | RegSetAChrominanceSaturationControl | RegSet A: Chrominance saturation control
Public property | RegSetADataQualified | RegSet A: Data qualified:
Public property | RegSetADitherNoiseShaper | RegSet A: Dither (Noise Shaper)
Public property | RegSetADownscale | RegSet A: Downscale
Public property | RegSetAEddiBypassEDBYP | RegSet A: Eddi_bypass (EDBYP)
Public property | RegSetAEddionEDON | RegSet A: Eddion (EDON)
Public property | RegSetAEdgeOfXRHInputIsHorizontalReference | RegSet A: Edge of XRH input is horizontal reference
Public property | RegSetAEdgeOfXRVInputAndDecoderV123IsVerticalReference | RegSet A: Edge of XRV input and decoder V123 is vertical reference:
Public property | RegSetAEdgiScalingIncrementValue1X | RegSet A: Edgi scaling increment: Value=1/x
Public property | RegSetAEdgiScalingPhase00 | RegSet A: Edgi Scaling phase: 00
Public property | RegSetAEdgiScalingPhase01 | RegSet A: Edgi Scaling phase: 01
Public property | RegSetAEdgiScalingPhase10 | RegSet A: Edgi Scaling phase: 10
Public property | RegSetAEdgiScalingPhase11 | RegSet A: Edgi Scaling phase: 11
Public property | RegSetAEventHandlerTriggers | RegSet A: Event handler triggers:
Public property | RegSetAFieldModeContinuousTaskMode | RegSet A: Field mode (continuous task mode)
Public property | RegSetAFormat | RegSet A: Format
Public property | RegSetAHorizontalChrominancePhaseOffset | RegSet A: Horizontal chrominance phase offset
Public property | RegSetAHorizontalChrominanceScalingIncrement | RegSet A: Horizontal chrominance scaling increment
Public property | RegSetAHorizontalInputAcquisitionWindowDefinitionInputWindowsLegth | RegSet A: Horizontal input acquisition window definition input windows legth
Public property | RegSetAHorizontalInputAcquisitionWindowDefinitionOffset | RegSet A: Horizontal input acquisition window definition offset
Public property | RegSetAHorizontalLuminancePhaseOffset | RegSet A: Horizontal luminance phase offset (unit: Pixel)
Public property | RegSetAHorizontalLuminanceScalingIncrement1024X | RegSet A: Horizontal luminance scaling increment 1024/x
Public property | RegSetAHorizontalOutputWindowLength | RegSet A: Horizontal output window length
Public property | RegSetAITU656 | RegSet A: ITU 656
Public property | RegSetALeadingLinesBefore1stYCBCRLineIsOutput | RegSet A: Leading lines before 1st Y + CB-CR line is output
Public property | RegSetALinesOutput | RegSet A: Lines output
Public property | RegSetALuminance | RegSet A: Luminance
Public property | RegSetALuminanceBrightnessControl | RegSet A: Luminance brightness control
Public property | RegSetALuminanceContrastControl | RegSet A: Luminance contrast control
Public property | RegSetALuminanceImprovementChangeOfCoringLevel | RegSet A: Luminance Improvement: Change of coring level
Public property | RegSetALuminanceImprovementSelectHighPassFilterForPeakComponent | RegSet A: Luminance Improvement: Select High Pass Filter For Peak Component
Public property | RegSetALuminanceImprovementSignalImprovementMode | RegSet A: Luminance Improvement: Signal Improvement Mode
Public property | RegSetALuminanceImprovementWeightingOfPeakComponent | RegSet A: Luminance Improvement: Weighting of Peak Component
Public property | RegSetAMirroring | RegSet A: Mirroring
Public property | RegSetANextTask | RegSet A: Next task:
Public property | RegSetAOutputFieldID | RegSet A: Output field ID
Public property | RegSetAPrescalerOutputIsRenormalizedByGainFactor | RegSet A: Prescaler output is renormalized by gain factor
Public property | RegSetAReferenceEdgeForFieldDetection | RegSet A: Reference edge for field detection
Public property | RegSetAReferenceSignals | RegSet A: Reference signals:
Public property | RegSetARemainingBlankingIntervals | RegSet A: Remaining blanking intervals
Public property | RegSetARGBYUVMatrixToReconvertRGBToYUVAfterManipulationsInTheRGBDomainFollowedByTheNoiseShaper | RegSet A: RGB -> YUV-Matrix, to reconvert RGB to YUV after manipulations in the RGB domain, followed by the Noise Shaper
Public property | RegSetASamplingScheme | RegSet A: Sampling scheme
Public property | RegSetASAVEAVCodeBitD5VGate | RegSet A: SAV/EAV code bit D5 (V) gate:
Public property | RegSetASAVEAVCodeBitsD6AndD5FAndV | RegSet A: SAV/EAV code bits D6 and D5 (F and V):
Public property | RegSetAScalerInputFormatConfigSource | RegSet A: Scaler input format/config source:
Public property | RegSetAScalerInputSource | RegSet A: Scaler input source:
Public property | RegSetAScalerSAVEAVByte | RegSet A: Scaler SAV/EAV byte
Public property | RegSetATaskHandlingControl | RegSet A: Task handling control
Public property | RegSetAVerticalInputAcquisitionWindowDefinition | RegSet A: Vertical input acquisition window definition
Public property | RegSetAVerticalInputAcquisitionWindowDefinitionOffset | RegSet A: Vertical input acquisition window definition offset
Public property | RegSetAVerticalOutputWindowLength | RegSet A: Vertical output window length
Public property | RegSetAVerticalScalingIncrementValue1X | RegSet A: Vertical scaling increment: Value=1/x
Public property | RegSetAVerticalScalingPerforms | RegSet A: Vertical scaling performs
Public property | RegSetAVerticalScalingPhaseOffset00 | RegSet A: Vertical Scaling phase offset 00
Public property | RegSetAVerticalScalingPhaseOffset01 | RegSet A: Vertical Scaling phase offset 01
Public property | RegSetAVerticalScalingPhaseOffset10 | RegSet A: Vertical Scaling phase offset 10
Public property | RegSetAVerticalScalingPhaseOffset11 | RegSet A: Vertical Scaling phase offset 11
Public property | RegSetAWeightingOfAllAccumulatedSamplesIsFactor | RegSet A: Weighting of all accumulated samples is factor =
Public property | RegSetAXCLK | RegSet A: XCLK
Public property | RegSetAXPortFieldID | RegSet A: X port field ID
Public property | RegSetAXRV | RegSet A: XRV
Public property | RegSetAYUVRGBMatrixFollowedBy17SegmentCurveGeneration | RegSet A: YUV -> RGB-Matrix, followed by 17 segment curve generation
Public property | RegSetB17SegmentCurvesForBCSInTheYUVOrColorManipulationsInTheRGBDomain | RegSet B: 17 segment curves for B,C,S in the YUV or color manipulations in the RGB domain
Public property | RegSetBAccumulationLength | RegSet B: Accumulation length
Public property | RegSetBChromaIsProvidedRegSetA | RegSet B: Chroma is provided(Reg. Set: A)
Public property | RegSetBChrominance | RegSet B: Chrominance
Public property | RegSetBChrominanceImprovementChangeOfCoringLevel | RegSet B: Chrominance Improvement: Change of coring level
Public property | RegSetBChrominanceImprovementSelectHighPassFilterForPeakComponent | RegSet B: Chrominance Improvement: Select High Pass Filter For Peak Component
Public property | RegSetBChrominanceImprovementSignalImprovementMode | RegSet B: Chrominance Improvement: Signal Improvement Mode
Public property | RegSetBChrominanceImprovementWeightingOfPeakComponent | RegSet B: Chrominance Improvement: Weighting of Peak Component
Public property | RegSetBChrominanceSaturationControl | RegSet B: Chrominance saturation control
Public property | RegSetBDataQualified | RegSet B: Data qualified:
Public property | RegSetBDitherNoiseShaper | RegSet B: Dither (Noise Shaper)
Public property | RegSetBDownscale | RegSet B: Downscale
Public property | RegSetBEddiBypassEDBYP | RegSet B: Eddi_bypass (EDBYP)
Public property | RegSetBEddionEDON | RegSet B: Eddion (EDON)
Public property | RegSetBEdgeOfXRHInputIsHorizontalReference | RegSet B: Edge of XRH input is horizontal reference
Public property | RegSetBEdgeOfXRVInputAndDecoderV123IsVerticalReference | RegSet B: Edge of XRV input and decoder V123 is vertical reference:
Public property | RegSetBEdgiScalingIncrementValue1X | RegSet B: Edgi scaling increment: Value=1/x
Public property | RegSetBEdgiScalingPhase00 | RegSet B: Edgi Scaling phase: 00
Public property | RegSetBEdgiScalingPhase01 | RegSet B: Edgi Scaling phase: 01
Public property | RegSetBEdgiScalingPhase10 | RegSet B: Edgi Scaling phase: 10
Public property | RegSetBEdgiScalingPhase11 | RegSet B: Edgi Scaling phase: 11
Public property | RegSetBEventHandlerTriggers | RegSet B: Event handler triggers:
Public property | RegSetBFieldModeContinuousTaskMode | RegSet B: Field mode (continuous task mode)
Public property | RegSetBFormat | RegSet B: Format
Public property | RegSetBHorizontalChrominancePhaseOffset | RegSet B: Horizontal chrominance phase offset
Public property | RegSetBHorizontalChrominanceScalingIncrement | RegSet B: Horizontal chrominance scaling increment
Public property | RegSetBHorizontalInputAcquisitionWindowDefinitionInputWindowsLegth | RegSet B: Horizontal input acquisition window definition input windows legth
Public property | RegSetBHorizontalInputAcquisitionWindowDefinitionOffset | RegSet B: Horizontal input acquisition window definition offset
Public property | RegSetBHorizontalLuminancePhaseOffset | RegSet B: Horizontal luminance phase offset (unit: Pixel)
Public property | RegSetBHorizontalLuminanceScalingIncrement1024X | RegSet B: Horizontal luminance scaling increment 1024/x
Public property | RegSetBHorizontalOutputWindowLength | RegSet B: Horizontal output window length
Public property | RegSetBITU656 | RegSet B: ITU 656
Public property | RegSetBLeadingLinesBefore1stYCBCRLineIsOutput | RegSet B: Leading lines before 1st Y + CB-CR line is output
Public property | RegSetBLinesOutput | RegSet B: Lines output
Public property | RegSetBLuminance | RegSet B: Luminance
Public property | RegSetBLuminanceBrightnessControl | RegSet B: Luminance brightness control
Public property | RegSetBLuminanceContrastControl | RegSet B: Luminance contrast control
Public property | RegSetBLuminanceImprovementChangeOfCoringLevel | RegSet B: Luminance Improvement: Change of coring level
Public property | RegSetBLuminanceImprovementSelectHighPassFilterForPeakComponent | RegSet B: Luminance Improvement: Select High Pass Filter For Peak Component
Public property | RegSetBLuminanceImprovementSignalImprovementMode | RegSet B: Luminance Improvement: Signal Improvement Mode
Public property | RegSetBLuminanceImprovementWeightingOfPeakComponent | RegSet B: Luminance Improvement: Weighting of Peak Component
Public property | RegSetBMirroring | RegSet B: Mirroring
Public property | RegSetBNextTask | RegSet B: Next task:
Public property | RegSetBOutputFieldID | RegSet B: Output field ID
Public property | RegSetBPrescalerOutputIsRenormalizedByGainFactor | RegSet B: Prescaler output is renormalized by gain factor
Public property | RegSetBReferenceEdgeForFieldDetection | RegSet B: Reference edge for field detection
Public property | RegSetBReferenceSignals | RegSet B: Reference signals:
Public property | RegSetBRemainingBlankingIntervals | RegSet B: Remaining blanking intervals
Public property | RegSetBRGBYUVMatrixToReconvertRGBToYUVAfterManipulationsInTheRGBDomainFollowedByTheNoiseShaper | RegSet B: RGB -> YUV-Matrix, to reconvert RGB to YUV after manipulations in the RGB domain, followed by the Noise Shaper
Public property | RegSetBSamplingScheme | RegSet B: Sampling scheme
Public property | RegSetBSAVEAVCodeBitD5VGate | RegSet B: SAV/EAV code bit D5 (V) gate:
Public property | RegSetBSAVEAVCodeBitsD6AndD5FAndV | RegSet B: SAV/EAV code bits D6 and D5 (F and V):
Public property | RegSetBScalerInputFormatConfigSource | RegSet B: Scaler input format/config source:
Public property | RegSetBScalerInputSource | RegSet B: Scaler input source:
Public property | RegSetBScalerSAVEAVByte | RegSet B: Scaler SAV/EAV byte
Public property | RegSetBTaskHandlingControl | RegSet B: Task handling control
Public property | RegSetBVerticalInputAcquisitionWindowDefinition | RegSet B: Vertical input acquisition window definition
Public property | RegSetBVerticalInputAcquisitionWindowDefinitionOffset | RegSet B: Vertical input acquisition window definition offset
Public property | RegSetBVerticalOutputWindowLength | RegSet B: Vertical output window length
Public property | RegSetBVerticalScalingIncrementValue1X | RegSet B: Vertical scaling increment: Value=1/x
Public property | RegSetBVerticalScalingPerforms | RegSet B: Vertical scaling performs
Public property | RegSetBVerticalScalingPhaseOffset00 | RegSet B: Vertical Scaling phase offset 00
Public property | RegSetBVerticalScalingPhaseOffset01 | RegSet B: Vertical Scaling phase offset 01
Public property | RegSetBVerticalScalingPhaseOffset10 | RegSet B: Vertical Scaling phase offset 10
Public property | RegSetBVerticalScalingPhaseOffset11 | RegSet B: Vertical Scaling phase offset 11
Public property | RegSetBWeightingOfAllAccumulatedSamplesIsFactor | RegSet B: Weighting of all accumulated samples is factor =
Public property | RegSetBXCLK | RegSet B: XCLK
Public property | RegSetBXPortFieldID | RegSet B: X port field ID
Public property | RegSetBXRV | RegSet B: XRV
Public property | RegSetBYUVRGBMatrixFollowedBy17SegmentCurveGeneration | RegSet B: YUV -> RGB-Matrix, followed by 17 segment curve generation
Public property | RemodulationBandwidthForLuminance | Remodulation bandwidth for luminance
Public property | ReportTheLinesWithinTwoFieldsContainAtLeastOneTransition | Report the lines within two fields (contain at least one transition)
Public property | RGB16565MappingToInternal16BitYUVOutputPath | RGB16 (565) mapping to internal 16 bit YUV output path
Public property | RightSlopeForKeystoneCompensation | Right Slope for keystone compensation
Public property | RTCOCompatiblityModeForSAA7199 | RTCO compatiblity mode for SAA7199
Public property | RTCOOutputEnable | RTCO output enable
Public property | RTS0OUTPUT | RTS0 OUTPUT
Public property | RTS1OUTPUT | RTS1 OUTPUT
Public property | RTXPortOutputControl | RT/X port output control
Public property | Scaler | Scaler
Public property | ScalerMode | Scaler Mode
Public property | SDIDCodes | SDID codes
Public property | SECAMColorKillerLevelControl | SECAM Color Killer Level Control
Public property | SelectLLC2 | Select LLC2
Public property | SharpnessControl | Sharpness control
Public property | SignalFedToPort | Signal fed to port
Public property | SlicedDataOutputModes | Sliced data output modes
Public property | SlicerStatusBit0 | Slicer Status Bit0
Public property | SlicerStatusBit1 | Slicer Status Bit1
Public property | StandardDetectionSearchLoopLatency | Standard detection search loop latency
Public property | StatusBitForFieldLength | Status bit for field length
Public property | StatusBitForHorizontalAndVerticalLoop | Status bit for horizontal and vertical loop
Public property | StatusBitForInterlaceDetection | Status bit for interlace detection
Public property | StatusBitForLockedHorizontalFrequency | Status bit for locked horizontal frequency
Public property | StatusBitForTimebaseOfInputSignal | Status bit for timebase of input signal
Public property | StatusOfTheFieldSequenceIDAtTheScalersInput | Status of the field sequence ID at the scalers input
Public property | StatusOfTheFieldSequenceIDAtTheScalersOutputScalerProcessingDependent | Status of the field sequence ID at the scalers output, scaler processing dependent
Public property | StatusOfTheInternalFIFOAlmostFilledFlag | Status of the internal 'FIFO almost filled' flag
Public property | StatusOfTheInternalFIFOOverflowFlag | Status of the internal 'FIFO overflow' flag
Public property | StatusOnInputPinITRIIfNotUsedFor3StateControlUsableAsHardwareFlagForSoftwareUse | Status on input pin ITRI, if not used for 3-state control, usable as hardware flag for software use
Public property | StatusOnInputPinXTRIIfNotUsedFor3StateControlUsableAsHardwareFlagForSoftwareUse | Status on input pin XTRI, if not used for 3-state control, usable as hardware flag for software use
Public property | SwapDataAssigmentsForPortsHPDAndIXDAllowsXPDAndHPDPortsToBeUsedAsYUVInputPath | Swap Data Assigments for Ports HPD and IXD (allows XPD and HPD ports to be used as YUV input path)
Public property | TaskOfRegisterSetA | Task of register set A
Public property | TaskOfRegisterSetB | Task of register set B
Public property | ThresholdForFASTConditionInPixelClocks | Threshold for FAST condition in pixel clocks
Public property | ThresholdForWIDTHConditionInPixelClocks | Threshold for WIDTH condition in pixel clocks
Public property | TimingGridForTheShiftOfTheOutputPositionLeftSlopeInKeystoneMode | Timing Grid for the shift of the output position (left slope) in keystone mode
Public property | UOffset14LSB | U offset (1/4 LSB)
Public property | ValueSubtractToCentre | Value subtract to centre
Public property | VerticalDifferenceGain | Vertical difference gain
Public property | VerticalDifferenceThreshold | Vertical difference threshold
Public property | VerticalNoiseReduction | Vertical noise reduction
Public property | VerticalNoiseReductionReset | Vertical noise reduction reset
Public property | VerticalOffsetForSlicer | Vertical offset for slicer
Public property | VerticalPLLDisable | Vertical PLL disable
Public property | VerticalSyncAndFieldIDSourceSelection | Vertical sync and Field ID source selection
Public property | VerticalTriggerEdge | Vertical trigger edge
Public property | VGATEStart | VGATE start
Public property | VGATEStop | VGATE stop
Public property | VOffset14LSB | V Offset (1/4 LSB)
Public property | WIDTHCondition | WIDTH condition
Public property | WPOFF | WPOFF
Public property | WSS525CRCCodeCheck | WSS525 CRC code check
Public property | WSSHeaderEvenFieldBeingUpdated | WSS-header: even field: being updated
Public property | WSSHeaderEvenFieldDataErroneous | WSS-header: even field: data erroneous
Public property | WSSHeaderFreeRunningFieldCounter | WSS-header: free running field counter
Public property | WSSHeaderOddFieldBeingUpdated | WSS-header: odd field: being updated
Public property | WSSHeaderOddFieldDataErroneous | WSS-header: odd field: data erroneous
Public property | WSSI2CReadback1EvenFields | WSS I2C readback 1 (even fields)
Public property | WSSI2CReadback1OddFields | WSS I2C readback 1 (odd fields)
Public property | WSSI2CReadback2EvenFields | WSS I2C readback 2 (even fields)
Public property | WSSI2CReadback2OddFields | WSS I2C readback 2 (odd fields)
Public property | WSSI2CReadback3EvenFields | WSS I2C readback 3 (even fields)
Public property | WSSI2CReadback3OddFields | WSS I2C readback 3 (odd fields)
Public property | XPortOutput | X-port output
Public property | XPortOutputIsEnabledByPinXTRIAt | X-port output is enabled by pin XTRI at:
Public property | XPortSignalDefinitionsIDQ | X-port signal definitions: IDQ
Public property | XPortSignalDefinitionsIGP0 | X-port signal definitions: IGP0
Public property | XPortSignalDefinitionsIGP1 | X-port signal definitions: IGP1
Public property | XPortSignalDefinitionsIGPH | X-port signal definitions: IGPH
Public property | XPortSignalDefinitionsIGPV | X-port signal definitions: IGPV
Public property | XPortXRHOutputSelection | X port XRH output selection
Public property | XPortXRVOutputSelection | X port XRV output selection
Public property | XRDYOutputSignalIs | XRDY output signal is
Public property | XTOUTOutputEnable | XTOUT output enable
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Multistandard video decoder with adaptive comb filter and component video input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Saa7119(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Saa7119

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119 Properties

The Saa7119 type exposes the following members.

Properties
 | Name | Description
Public property | AdaptiveChrominanceCombFilter | Adaptive chrominance comb filter
Public property | AdaptiveLuminanceCombFilter | Adaptive luminance comb filter
Public property | AGA1 | AGA1
Public property | AGA2 | AGA2
Public property | ALRCLKPhase | ALRCLK phase
Public property | AlternativeVGATEPosition | Alternative VGATE position
Public property | AmplitudeSearching | Amplitude searching
Public property | AnalogTestSelect | Analog test select
Public property | AnalogueGainStageHasReachedItsLowerLimitOfOperationRange | Analogue gain stage has reached its lower limit of operation range
Public property | AnalogueGainStageHasReachedItsUpperLimitOfOperationRange | Analogue gain stage has reached its upper limit of operation range
Public property | ASCLKPhase | ASCLK phase
Public property | AudioClockCGCGenerationMode | Audio clock: CGC Generation mode
Public property | AudioClockGeneration | Audio clock generation
Public property | AudioMasterClockAMCLKNominalIncrement | Audio master clock (AMCLK) nominal increment
Public property | AudioMasterClockCyclesPerField | Audio master clock cycles per field
Public property | AudioMasterClockVerticalReference | Audio master clock vertical reference
Public property | AudioPLLModes | Audio PLL modes
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AutomaticaVCRTVDetectionThreshold | Automatica VCR/TV-detection threshold
Public property | AutomaticChrominanceStandardDetectionControl | Automatic chrominance standard detection control
Public property | AutomaticColorLimiter | Automatic color limiter
Public property | AutomaticFieldDetection | Automatic field detection
Public property | AutomaticGainControlIntegration | Automatic gain control integration
Public property | AutoStandardsSearchModeShort | Auto standards search mode short
Public property | BONDID | BONDID
Public property | CCHeaderEvenFieldsBeingUpdated | CC Header: Even fields: Being updated
Public property | CCHeaderEvenFieldsDataErroneous | CC Header: Even fields: Data erroneous
Public property | CCHeaderFreeRunningFieldCounter | CC Header: free running field counter
Public property | CCHeaderOddFieldsBeingUpdated | CC Header: Odd fields: Being updated
Public property | CCHeaderOddFieldsDataErroneous | CC Header: Odd fields: Data erroneous
Public property | CCPayloadDataByte1EvenFields | CC payload data byte 1 (even fields)
Public property | CCPayloadDataByte1OddFields | CC payload data byte 1 (odd fields)
Public property | CCPayloadDataByte2EvenFields | CC payload data byte 2 (even fields)
Public property | CCPayloadDataByte2OddFields | CC payload data byte 2 (odd fields)
Public property | CG1FeedbackDivider | CG1 Feedback Divider
Public property | ChangeOf12LineCharacteristicOfTheRetimedVAndFSignals | Change of 1/2 line characteristic of the retimed V and F signals
Public property | ChipID | Chip ID
Public property | ChrominanceBandwidth | Chrominance bandwidth
Public property | ChrominanceGainValue | Chrominance gain value
Public property | ChrominanceHueControl | Chrominance hue control
Public property | ChrominanceSaturationControlComponentPartNegInverse | Chrominance saturation control component part (neg=inverse)
Public property | ChrominanceSaturationControlDecoderPartNegInverse | Chrominance saturation control: Decoder part (neg=inverse)
Public property | ChrominanceTrapCombFilterBypass | Chrominance trap/comb filter bypass
Public property | ClockDelay | Clock Delay
Public property | ClockRatioAudioMasterClockAMXCLKToSerialBitClock | Clock ratio audio master clock (AMXCLK) to serial bit clock
Public property | ClockRatioSerialBitClockASCLKToChannelSelectClockALRCLK | Clock ratio serial bit clock (ASCLK) to channel select clock (ALRCLK)
Public property | ColourOn | Colour on
Public property | ColourStandardSelectionInAUTOMode | Colour standard selection in AUTO mode
Public property | CombinedLuminanceChrominanceBandwidthAdjustment | Combined luminance/chrominance bandwidth adjustment
Public property | CombThreshold | Comb threshold
Public property | ConstantHigh | Constant_high
Public property | ConstantLow | Constant_low
Public property | ContinuousFieldMode | Continuous field mode
Public property | CopyOfBitDPROGCanBeUsedToDetectPowerUpAndStartUpFails | Copy of bit DPROG, can be used to detect power-up and start-up fails
Public property | CopyProtectedSourceDetected | Copy protected source detected
Public property | CV0 | CV0
Public property | DecoderAndVBISlicer | Decoder and VBI slicer
Public property | DetectedColourStandard | Detected colour standard
Public property | DFQBP | DFQBP
Public property | DGA1 | DGA1 (unit: dB)
Public property | DGA2 | DGA2 (unit: dB)
Public property | DigitalGainStageHasReachedItsLowerLimitOfOperationRange | Digital gain stage has reached its lower limit of operation range
Public property | DigitalGainStageHasReachedItsUpperLimitOfOperationRange | Digital gain stage has reached its upper limit of operation range
Public property | DisableChrominanceVerticalFilterAndPALPhaseErrorCorrection | Disable chrominance vertical filter and PAL phase error correction
Public property | DitherModeAtDataPathOutput | Dither mode at data path output
Public property | DividerReset | Divider Reset
Public property | DPROG | DPROG
Public property | DwordByteSwapInfluencesSerialOutputTiming | Dword byte swap, influences serial output timing
Public property | EdgiEdgeBufferFull | Edgi Edge Buffer Full
Public property | EdgiFifoFull | Edgi Fifo Full
Public property | EnableClock1Generation | Enable Clock 1 Generation
Public property | EnableTheFIRFilterAsASecondOrderLowPass | Enable the FIR filter as a second-order low-pass
Public property | ErrorFlagOfScalersOutputFormatter | Error flag of scalers output formatter
Public property | EvenFieldsBeingUpdated | Even fields: Being updated
Public property | EvenFieldsDataErroneous | Even fields: Data erroneous
Public property | ExpertMode | Expert Mode
Public property | ExternalSourceSwitchIndicatorInputEXMCLR | External source switch indicator Input EXMCLR
Public property | FAEFIFOFlagAlmostEmptyLevel | FAE FIFO flag almost empty level
Public property | FAFFIFOFlagAlmostFullLevel | FAF FIFO flag almost full level
Public property | FastColourTimeConstant | Fast colour time constant
Public property | FASTCondition | FAST condition
Public property | FastPALSECAMSequenceCorrection | Fast PAL/SECAM sequence correction
Public property | FastSwitchInputSelect | Fast switch input select
Public property | FastSwitchPreviousFieldCriteria | Fast switch previous field criteria
Public property | FieldOffset | Field offset
Public property | FieldSelection | Field selection
Public property | Filter1Bypass | Filter 1 Bypass
Public property | Filter2Bypass | Filter 2 Bypass
Public property | FineOffsetAdjustmentBYComponent | Fine offset adjustment B - Y component
Public property | FineOffsetAdjustmentRYComponent | Fine offset adjustment R - Y component
Public property | FinePositionOfHS | Fine position of HS
Public property | FixColorPLL | Fix color PLL
Public property | ForceAnalogueGainForChannel1 | Force analogue gain for channel 1 (unit: dB)
Public property | ForceAnalogueGainForChannel1__1 | Force analogue gain for channel 1 (unit: dB)
Public property | ForceDigitalGainForChannel1 | Force digital gain for channel 1
Public property | ForceDigitalGainForChannel1CVBSY | Force digital gain for channel 1 (CVBS/Y)
Public property | ForcedODDEVENToggle | Forced ODD/EVEN toggle
Public property | FramingCodeError | Framing Code Error
Public property | FramingCodeForProgrammableDataTypes | Framing code for programmable data types
Public property | FreeRunningFieldCounter | Free running field counter
Public property | FSSHFT | FSSHFT
Public property | FSWAlphaValueOutputInverted | FSW alpha value output inverted
Public property | GainControlFix | Gain control fix
Public property | GainControlFixedAnalog | Gain control fixed analog
Public property | GS1HeaderEvenFieldsBeingUpdated | GS1 header: Even fields: Being updated
Public property | GS1HeaderEvenFieldsDataErroneous | GS1 header: Even fields: Data erroneous
Public property | GS1HeaderFreeRunningFieldCounter | GS1 header: free running field counter
Public property | GS1HeaderOddFieldsBeingUpdated | GS1 header: Odd fields: Being updated
Public property | GS1HeaderOddFieldsDataErroneous | GS1 header: Odd fields: Data erroneous
Public property | GS1PayloadDataByte1EvenFields | GS1 payload data byte 1 (even fields)
Public property | GS1PayloadDataByte1OddFields | GS1 payload data byte 1 (odd fields)
Public property | GS1PayloadDataByte2EvenFields | GS1 payload data byte 2 (even fields)
Public property | GS1PayloadDataByte2OddFields | GS1 payload data byte 2 (odd fields)
Public property | GS2PayloadDataByte1EvenFields | GS2 payload data byte 1 (even fields)
Public property | GS2PayloadDataByte1OddFields | GS2 payload data byte 1 (odd fields)
Public property | GS2PayloadDataByte2EvenFields | GS2 payload data byte 2 (even fields)
Public property | GS2PayloadDataByte2OddFields | GS2 payload data byte 2 (odd fields)
Public property | GS2PayloadDataByte3EvenFields | GS2 payload data byte 3 (even fields)
Public property | GS2PayloadDataByte3OddFields | GS2 payload data byte 3 (odd fields)
Public property | GS2PayloadDataByte4EvenFields | GS2 payload data byte 4 (even fields)
Public property | GS2PayloadDataByte4OddFields | GS2 payload data byte 4 (odd fields)
Public property | HammingCheck | Hamming Check
Public property | HorizontalDifferenceGain | Horizontal difference gain
Public property | HorizontalLockIndicatorSelection | Horizontal lock indicator selection
Public property | HorizontalOffsetForSlicer | Horizontal offset for slicer
Public property | HorizontalPLL | Horizontal PLL
Public property | HorizontalScalingModes | Horizontal Scaling Modes
Public property | HorizontalTimeConstantSelection | Horizontal time constant selection
Public property | HorSyncStartDelayTimeStepSize8LLC | Hor. sync start: Delay Time (Step size=8/LLC)
Public property | HorSyncStopDelayTimeStepSize8LLC | Hor. sync stop: Delay Time (Step size=8/LLC)
Public property | IDEL | IDEL
Public property | IdentificationBitForDetectedFieldFrequency | Identification bit for detected field frequency (unit: Hz)
Public property | IDQAsGatedClock | IDQ as gated clock
Public property | InterruptEnableColourStandardChanged0 | Interrupt enable 'colour standard changed 0'
Public property | InterruptEnableColourStandardChanged1 | Interrupt enable 'colour standard changed 1'
Public property | InterruptEnableColourStripeBurstAnyTypeDetectedLost | Interrupt enable 'colour stripe burst (any type) detected/lost'
Public property | InterruptEnableColourStripeType3BurstDetectedLost | Interrupt enable 'colour stripe type 3 burst detected/lost'
Public property | InterruptEnableCopyProtectedSignalFoundLost | Interrupt enable 'copy protected signal found/lost'
Public property | InterruptEnableCopyProtectedSignalFoundLostSecondI2CSlave | Interrupt enable 'copy protected signal found/lost' (second I2C slave)
Public property | InterruptEnableErrorOutputFormatter | Interrupt enable 'error output formatter'
Public property | InterruptEnableFieldFrequencyHasChanged | Interrupt enable 'field frequency has changed'
Public property | InterruptEnableHorizontalAndVerticalLockReachedLost | Interrupt enable 'horizontal and vertical lock reached/lost'
Public property | InterruptEnableHorizontalPLLLockedUnlocked | Interrupt enable 'horizontal PLL locked/unlocked'
Public property | InterruptEnableInterlacedNonInterlacedSource | Interrupt enable 'interlaced/non-interlaced source'
Public property | InterruptEnableNominalFieldLengthDetectedLost | Interrupt enable 'nominal field length detected/lost'
Public property | InterruptEnableNominalFieldLengthDetectedLostSecondI2CSlave | Interrupt enable 'nominal field length detected/lost' (second I2C slave)
Public property | InterruptEnableReadyForCaptureNotReady | Interrupt enable 'ready for capture/not ready'
Public property | InterruptEnableReadyForCaptureNotReadySecondI2CSlave | Interrupt enable 'ready for capture/not ready' (second I2C slave)
Public property | IPortDataClock | I-Port data clock
Public property | IPortGlobalVideoTransferControl | I - port global video transfer control
Public property | IPortOutput | I-port output
Public property | IPortPackingMode | I-Port Packing mode
Public property | IPortSignalDefinitionsIGP0 | I - port signal definitions IGP0
Public property | IPortSignalDefinitionsIGP1 | I - port signal definitions IGP1
Public property | IPortSignalDefinitionsIGPH | I-port signal definitions: IGPH
Public property | IPortSignalDefinitionsIGPV | I-port signal definitions: IGPV
Public property | LCRRegister10Field16050Hz | LCR Register 10: Field 1 (60/50 Hz)
Public property | LCRRegister10Field26050Hz | LCR Register 10: Field 2 (60/50 Hz)
Public property | LCRRegister11Field16050Hz | LCR Register 11: Field 1 (60/50 Hz)
Public property | LCRRegister11Field26050Hz | LCR Register 11: Field 2 (60/50 Hz)
Public property | LCRRegister12Field16050Hz | LCR Register 12: Field 1 (60/50 Hz)
Public property | LCRRegister12Field26050Hz | LCR Register 12: Field 2 (60/50 Hz)
Public property | LCRRegister13Field16050Hz | LCR Register 13: Field 1 (60/50 Hz)
Public property | LCRRegister13Field26050Hz | LCR Register 13: Field 2 (60/50 Hz)
Public property | LCRRegister14Field16050Hz | LCR Register 14: Field 1 (60/50 Hz)
Public property | LCRRegister14Field26050Hz | LCR Register 14: Field 2 (60/50 Hz)
Public property | LCRRegister15Field16050Hz | LCR Register 15: Field 1 (60/50 Hz)
Public property | LCRRegister15Field26050Hz | LCR Register 15: Field 2 (60/50 Hz)
Public property | LCRRegister16Field16050Hz | LCR Register 16: Field 1 (60/50 Hz)
Public property | LCRRegister16Field26050Hz | LCR Register 16: Field 2 (60/50 Hz)
Public property | LCRRegister17Field16050Hz | LCR Register 17: Field 1 (60/50 Hz)
Public property | LCRRegister17Field26050Hz | LCR Register 17: Field 2 (60/50 Hz)
Public property | LCRRegister18Field16050Hz | LCR Register 18: Field 1 (60/50 Hz)
Public property | LCRRegister18Field26050Hz | LCR Register 18: Field 2 (60/50 Hz)
Public property | LCRRegister19Field16050Hz | LCR Register 19: Field 1 (60/50 Hz)
Public property | LCRRegister19Field26050Hz | LCR Register 19: Field 2 (60/50 Hz)
Public property | LCRRegister20Field16050Hz | LCR Register 20: Field 1 (60/50 Hz)
Public property | LCRRegister20Field26050Hz | LCR Register 20: Field 2 (60/50 Hz)
Public property | LCRRegister21Field16050Hz | LCR Register 21: Field 1 (60/50 Hz)
Public property | LCRRegister21Field26050Hz | LCR Register 21: Field 2 (60/50 Hz)
Public property | LCRRegister22Field16050Hz | LCR Register 22: Field 1 (60/50 Hz)
Public property | LCRRegister22Field26050Hz | LCR Register 22: Field 2 (60/50 Hz)
Public property | LCRRegister23Field16050Hz | LCR Register 23: Field 1 (60/50 Hz)
Public property | LCRRegister23Field26050Hz | LCR Register 23: Field 2 (60/50 Hz)
Public property | LCRRegister24Field16050Hz | LCR Register 24: Field 1 (60/50 Hz)
Public property | LCRRegister24Field26050Hz | LCR Register 24: Field 2 (60/50 Hz)
Public property | LCRRegister2Field16050Hz | LCR Register 2: Field 1 (60/50 Hz)
Public property | LCRRegister2Field26050Hz | LCR Register 2: Field 2 (60/50 Hz)
Public property | LCRRegister3Field16050Hz | LCR Register 3: Field 1 (60/50 Hz)
Public property | LCRRegister3Field26050Hz | LCR Register 3: Field 2 (60/50 Hz)
Public property | LCRRegister4Field16050Hz | LCR Register 4: Field 1 (60/50 Hz)
Public property | LCRRegister4Field26050Hz | LCR Register 4: Field 2 (60/50 Hz)
Public property | LCRRegister5Field16050Hz | LCR Register 5: Field 1 (60/50 Hz)
Public property | LCRRegister5Field26050Hz | LCR Register 5: Field 2 (60/50 Hz)
Public property | LCRRegister6Field16050Hz | LCR Register 6: Field 1 (60/50 Hz)
Public property | LCRRegister6Field26050Hz | LCR Register 6: Field 2 (60/50 Hz)
Public property | LCRRegister7Field16050Hz | LCR Register 7: Field 1 (60/50 Hz)
Public property | LCRRegister7Field26050Hz | LCR Register 7: Field 2 (60/50 Hz)
Public property | LCRRegister8Field16050Hz | LCR Register 8: Field 1 (60/50 Hz)
Public property | LCRRegister8Field26050Hz | LCR Register 8: Field 2 (60/50 Hz)
Public property | LCRRegister9Field16050Hz | LCR Register 9: Field 1 (60/50 Hz)
Public property | LCRRegister9Field26050Hz | LCR Register 9: Field 2 (60/50 Hz)
Public property | LeftSlopeForKeystoneCompensation | Left Slope for keystone compensation
Public property | LengthAccumulationFilter | Length accumulation filter
Public property | LimitLevelImagePort | Limit Level Image Port
Public property | LLC2OutputEnable | LLC2 output enable
Public property | LLCOutputEnable | LLC output enable
Public property | LNFE10 | LNFE10
Public property | LNFE11 | LNFE11
Public property | LNFE12 | LNFE12
Public property | LNFE13 | LNFE13
Public property | LNFE14 | LNFE14
Public property | LNFE15 | LNFE15
Public property | LNFE16 | LNFE16
Public property | LNFE17 | LNFE17
Public property | LNFE18 | LNFE18
Public property | LNFE19 | LNFE19
Public property | LNFE2 | LNFE2
Public property | LNFE20 | LNFE20
Public property | LNFE21 | LNFE21
Public property | LNFE22 | LNFE22
Public property | LNFE23 | LNFE23
Public property | LNFE24 | LNFE24
Public property | LNFE3 | LNFE3
Public property | LNFE4 | LNFE4
Public property | LNFE5 | LNFE5
Public property | LNFE6 | LNFE6
Public property | LNFE7 | LNFE7
Public property | LNFE8 | LNFE8
Public property | LNFE9 | LNFE9
Public property | LNFO10 | LNFO10
Public property | LNFO11 | LNFO11
Public property | LNFO12 | LNFO12
Public property | LNFO13 | LNFO13
Public property | LNFO14 | LNFO14
Public property | LNFO15 | LNFO15
Public property | LNFO16 | LNFO16
Public property | LNFO17 | LNFO17
Public property | LNFO18 | LNFO18
Public property | LNFO19 | LNFO19
Public property | LNFO2 | LNFO2
Public property | LNFO20 | LNFO20
Public property | LNFO21 | LNFO21
Public property | LNFO22 | LNFO22
Public property | LNFO23 | LNFO23
Public property | LNFO24 | LNFO24
Public property | LNFO3 | LNFO3
Public property | LNFO4 | LNFO4
Public property | LNFO5 | LNFO5
Public property | LNFO6 | LNFO6
Public property | LNFO7 | LNFO7
Public property | LNFO8 | LNFO8
Public property | LNFO9 | LNFO9
Public property | LumaPeakingFilterEnable | Luma peaking filter enable
Public property | LuminanceBrightnessControlComponentPart | Luminance brightness control component part
Public property | LuminanceBrightnessControlDecoderPart | Luminance brightness control: decoder part
Public property | LuminanceContrastControlComponentPartNegInverse | Luminance contrast control component part (neg=inverse)
Public property | LuminanceContrastControlDecoderPartNegInverse | Luminance contrast control: Decoder part (neg=inverse)
Public property | LuminanceDelayCompensation | Luminance delay compensation
Public property | MacrovisionCopyProtectionEnable | Macrovision copy-protection enable
Public property | MacrovisionEncodedColourStripeBurstDetected | Macrovision encoded colour stripe burst detected
Public property | MacrovisionEncodedColourStripeBurstType34LineVersionDetected | Macrovision encoded colour stripe burst type 3 (4 line version) detected
Public property | MaximumVerticalNoiseReduction | Maximum vertical noise reduction
Public property | MedianFilterGain | Median filter gain
Public property | MixOfXPORTInputDataAndDecoderInputData | Mix of XPORT input data and decoder input data
Public property | ModeSelection | Mode selection
Public property | MSTTB | MSTTB
Public property | OddFieldsBeingUpdated | Odd fields: Being updated
Public property | OddFieldsDataErroneous | Odd fields: Data erroneous
Public property | OutputClockPhaseControl | Output clock phase control
Public property | OutputDivider | Output Divider
Public property | OverlayMode | Overlay mode
Public property | PALNTSCColorKillerLevelControl | PAL/NTSC Color Killer Level Control
Public property | PanelMode | Panel Mode
Public property | PanoramaMode | Panorama Mode
Public property | ParityBitGenerationHammingForITUCodeSequenceOnIPort | Parity Bit Generation (Hamming) for ITU code sequence on I-port
Public property | PFSL | PFSL
Public property | PLLActiveClock1MHz | PLL active (clock > 1MHz)
Public property | PLLLocked | PLL locked
Public property | PLLParameterI | PLL parameter I
Public property | PLLParameterP | PLL parameter P
Public property | PLLParameterR | PLL parameter R
Public property | PolarityOfRTS0OutputSignal | Polarity of RTS0 output signal
Public property | PolarityOfRTS1OutputSignal | Polarity of RTS1 output signal
Public property | PortAndScalerBackendClockSelection | Port and scaler backend clock selection
Public property | ProcessingDelayInNonCombFilterMode | Processing delay in non comb filter mode
Public property | ProgramableDelay | Programable delay
Public property | ProgramableDelay14Pixel | Programable delay (1/4 pixel)
Public property | ProgrammableComponentDelayAgainstCOMBDECProcessing | Programmable component delay against COMBDEC processing (unit: CLK1 delays)
Public property | RawDataGainControl | Raw data gain control
Public property | RawDataOffsetControl | Raw data offset control (unit: LSB)
Public property | ReadyForCapture | Ready for capture
Public property | RegSetA17SegmentCurvesForBCSInTheYUVOrColorManipulationsInTheRGBDomain | RegSet A: 17 segment curves for B,C,S in the YUV or color manipulations in the RGB domain
Public property | RegSetAAccumulationLength | RegSet A: Accumulation length
Public property | RegSetAChromaIsProvidedRegSetA | RegSet A: Chroma is provided(Reg. Set: A)
Public property | RegSetAChrominance | RegSet A: Chrominance
Public property | RegSetAChrominanceImprovementChangeOfCoringLevel | RegSet A: Chrominance Improvement: Change of coring level
Public property | RegSetAChrominanceImprovementSelectHighPassFilterForPeakComponent | RegSet A: Chrominance Improvement: Select High Pass Filter For Peak Component
Public property | RegSetAChrominanceImprovementSignalImprovementMode | RegSet A: Chrominance Improvement: Signal Improvement Mode
Public property | RegSetAChrominanceImprovementWeightingOfPeakComponent | RegSet A: Chrominance Improvement: Weighting of Peak Component
Public property | RegSetAChrominanceSaturationControl | RegSet A: Chrominance saturation control
Public property | RegSetADataQualified | RegSet A: Data qualified:
Public property | RegSetADitherNoiseShaper | RegSet A: Dither (Noise Shaper)
Public property | RegSetADownscale | RegSet A: Downscale
Public property | RegSetAEddiBypassEDBYP | RegSet A: Eddi_bypass (EDBYP)
Public property | RegSetAEddionEDON | RegSet A: Eddion (EDON)
Public property | RegSetAEdgeOfXRHInputIsHorizontalReference | RegSet A: Edge of XRH input is horizontal reference
Public property | RegSetAEdgeOfXRVInputAndDecoderV123IsVerticalReference | RegSet A: Edge of XRV input and decoder V123 is vertical reference:
Public property | RegSetAEdgiScalingIncrementValue1X | RegSet A: Edgi scaling increment: Value=1/x
Public property | RegSetAEdgiScalingPhase00 | RegSet A: Edgi Scaling phase: 00
Public property | RegSetAEdgiScalingPhase01 | RegSet A: Edgi Scaling phase: 01
Public property | RegSetAEdgiScalingPhase10 | RegSet A: Edgi Scaling phase: 10
Public property | RegSetAEdgiScalingPhase11 | RegSet A: Edgi Scaling phase: 11
Public property | RegSetAEventHandlerTriggers | RegSet A: Event handler triggers:
Public property | RegSetAFieldModeContinuousTaskMode | RegSet A: Field mode (continuous task mode)
Public property | RegSetAFormat | RegSet A: Format
Public property | RegSetAHorizontalChrominancePhaseOffset | RegSet A: Horizontal chrominance phase offset
Public property | RegSetAHorizontalChrominanceScalingIncrement | RegSet A: Horizontal chrominance scaling increment
Public property | RegSetAHorizontalInputAcquisitionWindowDefinitionInputWindowsLegth | RegSet A: Horizontal input acquisition window definition input windows legth
Public property | RegSetAHorizontalInputAcquisitionWindowDefinitionOffset | RegSet A: Horizontal input acquisition window definition offset
Public property | RegSetAHorizontalLuminancePhaseOffset | RegSet A: Horizontal luminance phase offset (unit: Pixel)
Public property | RegSetAHorizontalLuminanceScalingIncrement1024X | RegSet A: Horizontal luminance scaling increment 1024/x
Public property | RegSetAHorizontalOutputWindowLength | RegSet A: Horizontal output window length
Public property | RegSetAITU656 | RegSet A: ITU 656
Public property | RegSetALeadingLinesBefore1stYCBCRLineIsOutput | RegSet A: Leading lines before 1st Y + CB-CR line is output
Public property | RegSetALinesOutput | RegSet A: Lines output
Public property | RegSetALuminance | RegSet A: Luminance
Public property | RegSetALuminanceBrightnessControl | RegSet A: Luminance brightness control
Public property | RegSetALuminanceContrastControl | RegSet A: Luminance contrast control
Public property | RegSetALuminanceImprovementChangeOfCoringLevel | RegSet A: Luminance Improvement: Change of coring level
Public property | RegSetALuminanceImprovementSelectHighPassFilterForPeakComponent | RegSet A: Luminance Improvement: Select High Pass Filter For Peak Component
Public property | RegSetALuminanceImprovementSignalImprovementMode | RegSet A: Luminance Improvement: Signal Improvement Mode
Public property | RegSetALuminanceImprovementWeightingOfPeakComponent | RegSet A: Luminance Improvement: Weighting of Peak Component
Public property | RegSetAMirroring | RegSet A: Mirroring
Public property | RegSetANextTask | RegSet A: Next task:
Public property | RegSetAOutputFieldID | RegSet A: Output field ID
Public property | RegSetAPrescalerOutputIsRenormalizedByGainFactor | RegSet A: Prescaler output is renormalized by gain factor
Public property | RegSetAReferenceEdgeForFieldDetection | RegSet A: Reference edge for field detection
Public property | RegSetAReferenceSignals | RegSet A: Reference signals:
Public property | RegSetARemainingBlankingIntervals | RegSet A: Remaining blanking intervals
Public property | RegSetARGBYUVMatrixToReconvertRGBToYUVAfterManipulationsInTheRGBDomainFollowedByTheNoiseShaper | RegSet A: RGB -> YUV-Matrix, to reconvert RGB to YUV after manipulations in the RGB domain, followed by the Noise Shaper
Public property | RegSetASamplingScheme | RegSet A: Sampling scheme
Public property | RegSetASAVEAVCodeBitD5VGate | RegSet A: SAV/EAV code bit D5 (V) gate:
Public property | RegSetASAVEAVCodeBitsD6AndD5FAndV | RegSet A: SAV/EAV code bits D6 and D5 (F and V):
Public property | RegSetAScalerInputFormatConfigSource | RegSet A: Scaler input format/config source:
Public property | RegSetAScalerInputSource | RegSet A: Scaler input source:
Public property | RegSetAScalerSAVEAVByte | RegSet A: Scaler SAV/EAV byte
Public property | RegSetATaskHandlingControl | RegSet A: Task handling control
Public property | RegSetAVerticalInputAcquisitionWindowDefinition | RegSet A: Vertical input acquisition window definition
Public property | RegSetAVerticalInputAcquisitionWindowDefinitionOffset | RegSet A: Vertical input acquisition window definition offset
Public property | RegSetAVerticalOutputWindowLength | RegSet A: Vertical output window length
Public property | RegSetAVerticalScalingIncrementValue1X | RegSet A: Vertical scaling increment: Value=1/x
Public property | RegSetAVerticalScalingPerforms | RegSet A: Vertical scaling performs
Public property | RegSetAVerticalScalingPhaseOffset00 | RegSet A: Vertical Scaling phase offset 00
Public property | RegSetAVerticalScalingPhaseOffset01 | RegSet A: Vertical Scaling phase offset 01
Public property | RegSetAVerticalScalingPhaseOffset10 | RegSet A: Vertical Scaling phase offset 10
Public property | RegSetAVerticalScalingPhaseOffset11 | RegSet A: Vertical Scaling phase offset 11
Public property | RegSetAWeightingOfAllAccumulatedSamplesIsFactor | RegSet A: Weighting of all accumulated samples is factor =
Public property | RegSetAXCLK | RegSet A: XCLK
Public property | RegSetAXPortFieldID | RegSet A: X port field ID
Public property | RegSetAXRV | RegSet A: XRV
Public property | RegSetAYUVRGBMatrixFollowedBy17SegmentCurveGeneration | RegSet A: YUV -> RGB-Matrix, followed by 17 segment curve generation
Public property | RegSetB17SegmentCurvesForBCSInTheYUVOrColorManipulationsInTheRGBDomain | RegSet B: 17 segment curves for B,C,S in the YUV or color manipulations in the RGB domain
Public property | RegSetBAccumulationLength | RegSet B: Accumulation length
Public property | RegSetBChromaIsProvidedRegSetA | RegSet B: Chroma is provided(Reg. Set: A)
Public property | RegSetBChrominance | RegSet B: Chrominance
Public property | RegSetBChrominanceImprovementChangeOfCoringLevel | RegSet B: Chrominance Improvement: Change of coring level
Public property | RegSetBChrominanceImprovementSelectHighPassFilterForPeakComponent | RegSet B: Chrominance Improvement: Select High Pass Filter For Peak Component
Public property | RegSetBChrominanceImprovementSignalImprovementMode | RegSet B: Chrominance Improvement: Signal Improvement Mode
Public property | RegSetBChrominanceImprovementWeightingOfPeakComponent | RegSet B: Chrominance Improvement: Weighting of Peak Component
Public property | RegSetBChrominanceSaturationControl | RegSet B: Chrominance saturation control
Public property | RegSetBDataQualified | RegSet B: Data qualified:
Public property | RegSetBDitherNoiseShaper | RegSet B: Dither (Noise Shaper)
Public property | RegSetBDownscale | RegSet B: Downscale
Public property | RegSetBEddiBypassEDBYP | RegSet B: Eddi_bypass (EDBYP)
Public property | RegSetBEddionEDON | RegSet B: Eddion (EDON)
Public property | RegSetBEdgeOfXRHInputIsHorizontalReference | RegSet B: Edge of XRH input is horizontal reference
Public property | RegSetBEdgeOfXRVInputAndDecoderV123IsVerticalReference | RegSet B: Edge of XRV input and decoder V123 is vertical reference:
Public property | RegSetBEdgiScalingIncrementValue1X | RegSet B: Edgi scaling increment: Value=1/x
Public property | RegSetBEdgiScalingPhase00 | RegSet B: Edgi Scaling phase: 00
Public property | RegSetBEdgiScalingPhase01 | RegSet B: Edgi Scaling phase: 01
Public property | RegSetBEdgiScalingPhase10 | RegSet B: Edgi Scaling phase: 10
Public property | RegSetBEdgiScalingPhase11 | RegSet B: Edgi Scaling phase: 11
Public property | RegSetBEventHandlerTriggers | RegSet B: Event handler triggers:
Public property | RegSetBFieldModeContinuousTaskMode | RegSet B: Field mode (continuous task mode)
Public property | RegSetBFormat | RegSet B: Format
Public property | RegSetBHorizontalChrominancePhaseOffset | RegSet B: Horizontal chrominance phase offset
Public property | RegSetBHorizontalChrominanceScalingIncrement | RegSet B: Horizontal chrominance scaling increment
Public property | RegSetBHorizontalInputAcquisitionWindowDefinitionInputWindowsLegth | RegSet B: Horizontal input acquisition window definition input windows legth
Public property | RegSetBHorizontalInputAcquisitionWindowDefinitionOffset | RegSet B: Horizontal input acquisition window definition offset
Public property | RegSetBHorizontalLuminancePhaseOffset | RegSet B: Horizontal luminance phase offset (unit: Pixel)
Public property | RegSetBHorizontalLuminanceScalingIncrement1024X | RegSet B: Horizontal luminance scaling increment 1024/x
Public property | RegSetBHorizontalOutputWindowLength | RegSet B: Horizontal output window length
Public property | RegSetBITU656 | RegSet B: ITU 656
Public property | RegSetBLeadingLinesBefore1stYCBCRLineIsOutput | RegSet B: Leading lines before 1st Y + CB-CR line is output
Public property | RegSetBLinesOutput | RegSet B: Lines output
Public property | RegSetBLuminance | RegSet B: Luminance
Public property | RegSetBLuminanceBrightnessControl | RegSet B: Luminance brightness control
Public property | RegSetBLuminanceContrastControl | RegSet B: Luminance contrast control
Public property | RegSetBLuminanceImprovementChangeOfCoringLevel | RegSet B: Luminance Improvement: Change of coring level
Public property | RegSetBLuminanceImprovementSelectHighPassFilterForPeakComponent | RegSet B: Luminance Improvement: Select High Pass Filter For Peak Component
Public property | RegSetBLuminanceImprovementSignalImprovementMode | RegSet B: Luminance Improvement: Signal Improvement Mode
Public property | RegSetBLuminanceImprovementWeightingOfPeakComponent | RegSet B: Luminance Improvement: Weighting of Peak Component
Public property | RegSetBMirroring | RegSet B: Mirroring
Public property | RegSetBNextTask | RegSet B: Next task:
Public property | RegSetBOutputFieldID | RegSet B: Output field ID
Public property | RegSetBPrescalerOutputIsRenormalizedByGainFactor | RegSet B: Prescaler output is renormalized by gain factor
Public property | RegSetBReferenceEdgeForFieldDetection | RegSet B: Reference edge for field detection
Public property | RegSetBReferenceSignals | RegSet B: Reference signals:
Public property | RegSetBRemainingBlankingIntervals | RegSet B: Remaining blanking intervals
Public property | RegSetBRGBYUVMatrixToReconvertRGBToYUVAfterManipulationsInTheRGBDomainFollowedByTheNoiseShaper | RegSet B: RGB -> YUV-Matrix, to reconvert RGB to YUV after manipulations in the RGB domain, followed by the Noise Shaper
Public property | RegSetBSamplingScheme | RegSet B: Sampling scheme
Public property | RegSetBSAVEAVCodeBitD5VGate | RegSet B: SAV/EAV code bit D5 (V) gate:
Public property | RegSetBSAVEAVCodeBitsD6AndD5FAndV | RegSet B: SAV/EAV code bits D6 and D5 (F and V):
Public property | RegSetBScalerInputFormatConfigSource | RegSet B: Scaler input format/config source:
Public property | RegSetBScalerInputSource | RegSet B: Scaler input source:
Public property | RegSetBScalerSAVEAVByte | RegSet B: Scaler SAV/EAV byte
Public property | RegSetBTaskHandlingControl | RegSet B: Task handling control
Public property | RegSetBVerticalInputAcquisitionWindowDefinition | RegSet B: Vertical input acquisition window definition
Public property | RegSetBVerticalInputAcquisitionWindowDefinitionOffset | RegSet B: Vertical input acquisition window definition offset
Public property | RegSetBVerticalOutputWindowLength | RegSet B: Vertical output window length
Public property | RegSetBVerticalScalingIncrementValue1X | RegSet B: Vertical scaling increment: Value=1/x
Public property | RegSetBVerticalScalingPerforms | RegSet B: Vertical scaling performs
Public property | RegSetBVerticalScalingPhaseOffset00 | RegSet B: Vertical Scaling phase offset 00
Public property | RegSetBVerticalScalingPhaseOffset01 | RegSet B: Vertical Scaling phase offset 01
Public property | RegSetBVerticalScalingPhaseOffset10 | RegSet B: Vertical Scaling phase offset 10
Public property | RegSetBVerticalScalingPhaseOffset11 | RegSet B: Vertical Scaling phase offset 11
Public property | RegSetBWeightingOfAllAccumulatedSamplesIsFactor | RegSet B: Weighting of all accumulated samples is factor =
Public property | RegSetBXCLK | RegSet B: XCLK
Public property | RegSetBXPortFieldID | RegSet B: X port field ID
Public property | RegSetBXRV | RegSet B: XRV
Public property | RegSetBYUVRGBMatrixFollowedBy17SegmentCurveGeneration | RegSet B: YUV -> RGB-Matrix, followed by 17 segment curve generation
Public property | RemodulationBandwidthForLuminance | Remodulation bandwidth for luminance
Public property | ReportTheLinesWithinTwoFieldsContainAtLeastOneTransition | Report the lines within two fields (contain at least one transition)
Public property | RGB16565MappingToInternal16BitYUVOutputPath | RGB16 (565) mapping to internal 16 bit YUV output path
Public property | RightSlopeForKeystoneCompensation | Right Slope for keystone compensation
Public property | RTCOCompatiblityModeForSAA7199 | RTCO compatiblity mode for SAA7199
Public property | RTCOOutputEnable | RTCO output enable
Public property | RTS0OUTPUT | RTS0 OUTPUT
Public property | RTS1OUTPUT | RTS1 OUTPUT
Public property | RTXPortOutputControl | RT/X port output control
Public property | Scaler | Scaler
Public property | ScalerMode | Scaler Mode
Public property | SDIDCodes | SDID codes
Public property | SECAMColorKillerLevelControl | SECAM Color Killer Level Control
Public property | SelectLLC2 | Select LLC2
Public property | SharpnessControl | Sharpness control
Public property | SignalFedToPort | Signal fed to port
Public property | SlicedDataOutputModes | Sliced data output modes
Public property | SlicerStatusBit0 | Slicer Status Bit0
Public property | SlicerStatusBit1 | Slicer Status Bit1
Public property | StandardDetectionSearchLoopLatency | Standard detection search loop latency
Public property | StatusBitForFieldLength | Status bit for field length
Public property | StatusBitForHorizontalAndVerticalLoop | Status bit for horizontal and vertical loop
Public property | StatusBitForInterlaceDetection | Status bit for interlace detection
Public property | StatusBitForLockedHorizontalFrequency | Status bit for locked horizontal frequency
Public property | StatusBitForTimebaseOfInputSignal | Status bit for timebase of input signal
Public property | StatusOfTheFieldSequenceIDAtTheScalersInput | Status of the field sequence ID at the scalers input
Public property | StatusOfTheFieldSequenceIDAtTheScalersOutputScalerProcessingDependent | Status of the field sequence ID at the scalers output, scaler processing dependent
Public property | StatusOfTheInternalFIFOAlmostFilledFlag | Status of the internal 'FIFO almost filled' flag
Public property | StatusOfTheInternalFIFOOverflowFlag | Status of the internal 'FIFO overflow' flag
Public property | StatusOnInputPinITRIIfNotUsedFor3StateControlUsableAsHardwareFlagForSoftwareUse | Status on input pin ITRI, if not used for 3-state control, usable as hardware flag for software use
Public property | StatusOnInputPinXTRIIfNotUsedFor3StateControlUsableAsHardwareFlagForSoftwareUse | Status on input pin XTRI, if not used for 3-state control, usable as hardware flag for software use
Public property | SwapDataAssigmentsForPortsHPDAndIXDAllowsXPDAndHPDPortsToBeUsedAsYUVInputPath | Swap Data Assigments for Ports HPD and IXD (allows XPD and HPD ports to be used as YUV input path)
Public property | TaskOfRegisterSetA | Task of register set A
Public property | TaskOfRegisterSetB | Task of register set B
Public property | ThresholdForFASTConditionInPixelClocks | Threshold for FAST condition in pixel clocks
Public property | ThresholdForWIDTHConditionInPixelClocks | Threshold for WIDTH condition in pixel clocks
Public property | TimingGridForTheShiftOfTheOutputPositionLeftSlopeInKeystoneMode | Timing Grid for the shift of the output position (left slope) in keystone mode
Public property | UOffset14LSB | U offset (1/4 LSB)
Public property | ValueSubtractToCentre | Value subtract to centre
Public property | VerticalDifferenceGain | Vertical difference gain
Public property | VerticalDifferenceThreshold | Vertical difference threshold
Public property | VerticalNoiseReduction | Vertical noise reduction
Public property | VerticalNoiseReductionReset | Vertical noise reduction reset
Public property | VerticalOffsetForSlicer | Vertical offset for slicer
Public property | VerticalPLLDisable | Vertical PLL disable
Public property | VerticalSyncAndFieldIDSourceSelection | Vertical sync and Field ID source selection
Public property | VerticalTriggerEdge | Vertical trigger edge
Public property | VGATEStart | VGATE start
Public property | VGATEStop | VGATE stop
Public property | VOffset14LSB | V Offset (1/4 LSB)
Public property | WIDTHCondition | WIDTH condition
Public property | WPOFF | WPOFF
Public property | WSS525CRCCodeCheck | WSS525 CRC code check
Public property | WSSHeaderEvenFieldBeingUpdated | WSS-header: even field: being updated
Public property | WSSHeaderEvenFieldDataErroneous | WSS-header: even field: data erroneous
Public property | WSSHeaderFreeRunningFieldCounter | WSS-header: free running field counter
Public property | WSSHeaderOddFieldBeingUpdated | WSS-header: odd field: being updated
Public property | WSSHeaderOddFieldDataErroneous | WSS-header: odd field: data erroneous
Public property | WSSI2CReadback1EvenFields | WSS I2C readback 1 (even fields)
Public property | WSSI2CReadback1OddFields | WSS I2C readback 1 (odd fields)
Public property | WSSI2CReadback2EvenFields | WSS I2C readback 2 (even fields)
Public property | WSSI2CReadback2OddFields | WSS I2C readback 2 (odd fields)
Public property | WSSI2CReadback3EvenFields | WSS I2C readback 3 (even fields)
Public property | WSSI2CReadback3OddFields | WSS I2C readback 3 (odd fields)
Public property | XPortOutput | X-port output
Public property | XPortOutputIsEnabledByPinXTRIAt | X-port output is enabled by pin XTRI at:
Public property | XPortSignalDefinitionsIDQ | X-port signal definitions: IDQ
Public property | XPortSignalDefinitionsIGP0 | X-port signal definitions: IGP0
Public property | XPortSignalDefinitionsIGP1 | X-port signal definitions: IGP1
Public property | XPortSignalDefinitionsIGPH | X-port signal definitions: IGPH
Public property | XPortSignalDefinitionsIGPV | X-port signal definitions: IGPV
Public property | XPortXRHOutputSelection | X port XRH output selection
Public property | XPortXRVOutputSelection | X port XRV output selection
Public property | XRDYOutputSignalIs | XRDY output signal is
Public property | XTOUTOutputEnable | XTOUT output enable
Top
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AdaptiveChrominanceCombFilter Property

IRD

Saa7119AdaptiveChrominanceCombFilter Property

Adaptive chrominance comb filter

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDCHROMINANCECONTROL10 AdaptiveChrominanceCombFilter { get; set; }
Public Property AdaptiveChrominanceCombFilter As Saa7119TYPIDCHROMINANCECONTROL10
    Get
    Set
public:
property Saa7119TYPIDCHROMINANCECONTROL10 AdaptiveChrominanceCombFilter {
    Saa7119TYPIDCHROMINANCECONTROL10 get ();
    void set (Saa7119TYPIDCHROMINANCECONTROL10 value);
}
member AdaptiveChrominanceCombFilter : Saa7119TYPIDCHROMINANCECONTROL10 with get, set

Property Value

Type: Saa7119TYPIDCHROMINANCECONTROL10
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AdaptiveLuminanceCombFilter Property

IRD

Saa7119AdaptiveLuminanceCombFilter Property

Adaptive luminance comb filter

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLUMINANCECONTROL3 AdaptiveLuminanceCombFilter { get; set; }
Public Property AdaptiveLuminanceCombFilter As Saa7119TYPIDLUMINANCECONTROL3
    Get
    Set
public:
property Saa7119TYPIDLUMINANCECONTROL3 AdaptiveLuminanceCombFilter {
    Saa7119TYPIDLUMINANCECONTROL3 get ();
    void set (Saa7119TYPIDLUMINANCECONTROL3 value);
}
member AdaptiveLuminanceCombFilter : Saa7119TYPIDLUMINANCECONTROL3 with get, set

Property Value

Type: Saa7119TYPIDLUMINANCECONTROL3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AGA1 Property

IRD

Saa7119AGA1 Property

AGA1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDANALOGINPUTCONTROL301 AGA1 { get; set; }
Public Property AGA1 As Saa7119TYPIDANALOGINPUTCONTROL301
    Get
    Set
public:
property Saa7119TYPIDANALOGINPUTCONTROL301 AGA1 {
    Saa7119TYPIDANALOGINPUTCONTROL301 get ();
    void set (Saa7119TYPIDANALOGINPUTCONTROL301 value);
}
member AGA1 : Saa7119TYPIDANALOGINPUTCONTROL301 with get, set

Property Value

Type: Saa7119TYPIDANALOGINPUTCONTROL301
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AGA2 Property

IRD

Saa7119AGA2 Property

AGA2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDANALOGINPUTCONTROL301 AGA2 { get; set; }
Public Property AGA2 As Saa7119TYPIDANALOGINPUTCONTROL301
    Get
    Set
public:
property Saa7119TYPIDANALOGINPUTCONTROL301 AGA2 {
    Saa7119TYPIDANALOGINPUTCONTROL301 get ();
    void set (Saa7119TYPIDANALOGINPUTCONTROL301 value);
}
member AGA2 : Saa7119TYPIDANALOGINPUTCONTROL301 with get, set

Property Value

Type: Saa7119TYPIDANALOGINPUTCONTROL301
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ALRCLKPhase Property

IRD

Saa7119ALRCLKPhase Property

ALRCLK phase

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDAUDIOCLOCKCONTROL1 ALRCLKPhase { get; set; }
Public Property ALRCLKPhase As Saa7119TYPIDAUDIOCLOCKCONTROL1
    Get
    Set
public:
property Saa7119TYPIDAUDIOCLOCKCONTROL1 ALRCLKPhase {
    Saa7119TYPIDAUDIOCLOCKCONTROL1 get ();
    void set (Saa7119TYPIDAUDIOCLOCKCONTROL1 value);
}
member ALRCLKPhase : Saa7119TYPIDAUDIOCLOCKCONTROL1 with get, set

Property Value

Type: Saa7119TYPIDAUDIOCLOCKCONTROL1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AlternativeVGATEPosition Property

IRD

Saa7119AlternativeVGATEPosition Property

Alternative VGATE position

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDMISCELLANEOUSVGATEMSBS0 AlternativeVGATEPosition { get; set; }
Public Property AlternativeVGATEPosition As Saa7119TYPIDMISCELLANEOUSVGATEMSBS0
    Get
    Set
public:
property Saa7119TYPIDMISCELLANEOUSVGATEMSBS0 AlternativeVGATEPosition {
    Saa7119TYPIDMISCELLANEOUSVGATEMSBS0 get ();
    void set (Saa7119TYPIDMISCELLANEOUSVGATEMSBS0 value);
}
member AlternativeVGATEPosition : Saa7119TYPIDMISCELLANEOUSVGATEMSBS0 with get, set

Property Value

Type: Saa7119TYPIDMISCELLANEOUSVGATEMSBS0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AmplitudeSearching Property

IRD

Saa7119AmplitudeSearching Property

Amplitude searching

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSET0 AmplitudeSearching { get; set; }
Public Property AmplitudeSearching As Saa7119TYPIDSLICERSET0
    Get
    Set
public:
property Saa7119TYPIDSLICERSET0 AmplitudeSearching {
    Saa7119TYPIDSLICERSET0 get ();
    void set (Saa7119TYPIDSLICERSET0 value);
}
member AmplitudeSearching : Saa7119TYPIDSLICERSET0 with get, set

Property Value

Type: Saa7119TYPIDSLICERSET0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AnalogTestSelect Property

IRD

Saa7119AnalogTestSelect Property

Analog test select

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDANALOGADCAUTOCIBILITYCONTROL1 AnalogTestSelect { get; set; }
Public Property AnalogTestSelect As Saa7119TYPIDANALOGADCAUTOCIBILITYCONTROL1
    Get
    Set
public:
property Saa7119TYPIDANALOGADCAUTOCIBILITYCONTROL1 AnalogTestSelect {
    Saa7119TYPIDANALOGADCAUTOCIBILITYCONTROL1 get ();
    void set (Saa7119TYPIDANALOGADCAUTOCIBILITYCONTROL1 value);
}
member AnalogTestSelect : Saa7119TYPIDANALOGADCAUTOCIBILITYCONTROL1 with get, set

Property Value

Type: Saa7119TYPIDANALOGADCAUTOCIBILITYCONTROL1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AnalogueGainStageHasReachedItsLowerLimitOfOperationRange Property

IRD

Saa7119AnalogueGainStageHasReachedItsLowerLimitOfOperationRange Property

Analogue gain stage has reached its lower limit of operation range

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSTATUSBYTE1VIDEODECODER3 AnalogueGainStageHasReachedItsLowerLimitOfOperationRange { get; }
Public ReadOnly Property AnalogueGainStageHasReachedItsLowerLimitOfOperationRange As Saa7119TYPIDSTATUSBYTE1VIDEODECODER3
    Get
public:
property Saa7119TYPIDSTATUSBYTE1VIDEODECODER3 AnalogueGainStageHasReachedItsLowerLimitOfOperationRange {
    Saa7119TYPIDSTATUSBYTE1VIDEODECODER3 get ();
}
member AnalogueGainStageHasReachedItsLowerLimitOfOperationRange : Saa7119TYPIDSTATUSBYTE1VIDEODECODER3 with get

Property Value

Type: Saa7119TYPIDSTATUSBYTE1VIDEODECODER3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AnalogueGainStageHasReachedItsUpperLimitOfOperationRange Property

IRD

Saa7119AnalogueGainStageHasReachedItsUpperLimitOfOperationRange Property

Analogue gain stage has reached its upper limit of operation range

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSTATUSBYTE1VIDEODECODER4 AnalogueGainStageHasReachedItsUpperLimitOfOperationRange { get; }
Public ReadOnly Property AnalogueGainStageHasReachedItsUpperLimitOfOperationRange As Saa7119TYPIDSTATUSBYTE1VIDEODECODER4
    Get
public:
property Saa7119TYPIDSTATUSBYTE1VIDEODECODER4 AnalogueGainStageHasReachedItsUpperLimitOfOperationRange {
    Saa7119TYPIDSTATUSBYTE1VIDEODECODER4 get ();
}
member AnalogueGainStageHasReachedItsUpperLimitOfOperationRange : Saa7119TYPIDSTATUSBYTE1VIDEODECODER4 with get

Property Value

Type: Saa7119TYPIDSTATUSBYTE1VIDEODECODER4
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ASCLKPhase Property

IRD

Saa7119ASCLKPhase Property

ASCLK phase

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDAUDIOCLOCKCONTROL0 ASCLKPhase { get; set; }
Public Property ASCLKPhase As Saa7119TYPIDAUDIOCLOCKCONTROL0
    Get
    Set
public:
property Saa7119TYPIDAUDIOCLOCKCONTROL0 ASCLKPhase {
    Saa7119TYPIDAUDIOCLOCKCONTROL0 get ();
    void set (Saa7119TYPIDAUDIOCLOCKCONTROL0 value);
}
member ASCLKPhase : Saa7119TYPIDAUDIOCLOCKCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDAUDIOCLOCKCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AudioClockCGCGenerationMode Property

IRD

Saa7119AudioClockCGCGenerationMode Property

Audio clock: CGC Generation mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDAUDIOCLOCKCONTROL4 AudioClockCGCGenerationMode { get; set; }
Public Property AudioClockCGCGenerationMode As Saa7119TYPIDAUDIOCLOCKCONTROL4
    Get
    Set
public:
property Saa7119TYPIDAUDIOCLOCKCONTROL4 AudioClockCGCGenerationMode {
    Saa7119TYPIDAUDIOCLOCKCONTROL4 get ();
    void set (Saa7119TYPIDAUDIOCLOCKCONTROL4 value);
}
member AudioClockCGCGenerationMode : Saa7119TYPIDAUDIOCLOCKCONTROL4 with get, set

Property Value

Type: Saa7119TYPIDAUDIOCLOCKCONTROL4
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AudioClockGeneration Property

IRD

Saa7119AudioClockGeneration Property

Audio clock generation

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDADCPORTCONTROLGLOBALSET2 AudioClockGeneration { get; set; }
Public Property AudioClockGeneration As Saa7119TYPIDADCPORTCONTROLGLOBALSET2
    Get
    Set
public:
property Saa7119TYPIDADCPORTCONTROLGLOBALSET2 AudioClockGeneration {
    Saa7119TYPIDADCPORTCONTROLGLOBALSET2 get ();
    void set (Saa7119TYPIDADCPORTCONTROLGLOBALSET2 value);
}
member AudioClockGeneration : Saa7119TYPIDADCPORTCONTROLGLOBALSET2 with get, set

Property Value

Type: Saa7119TYPIDADCPORTCONTROLGLOBALSET2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AudioMasterClockAMCLKNominalIncrement Property

IRD

Saa7119AudioMasterClockAMCLKNominalIncrement Property

Audio master clock (AMCLK) nominal increment

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint AudioMasterClockAMCLKNominalIncrement { get; set; }
Public Property AudioMasterClockAMCLKNominalIncrement As UInteger
    Get
    Set
public:
property unsigned int AudioMasterClockAMCLKNominalIncrement {
    unsigned int get ();
    void set (unsigned int value);
}
member AudioMasterClockAMCLKNominalIncrement : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AudioMasterClockCyclesPerField Property

IRD

Saa7119AudioMasterClockCyclesPerField Property

Audio master clock cycles per field

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint AudioMasterClockCyclesPerField { get; set; }
Public Property AudioMasterClockCyclesPerField As UInteger
    Get
    Set
public:
property unsigned int AudioMasterClockCyclesPerField {
    unsigned int get ();
    void set (unsigned int value);
}
member AudioMasterClockCyclesPerField : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AudioMasterClockVerticalReference Property

IRD

Saa7119AudioMasterClockVerticalReference Property

Audio master clock vertical reference

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDAUDIOCLOCKCONTROL2 AudioMasterClockVerticalReference { get; set; }
Public Property AudioMasterClockVerticalReference As Saa7119TYPIDAUDIOCLOCKCONTROL2
    Get
    Set
public:
property Saa7119TYPIDAUDIOCLOCKCONTROL2 AudioMasterClockVerticalReference {
    Saa7119TYPIDAUDIOCLOCKCONTROL2 get ();
    void set (Saa7119TYPIDAUDIOCLOCKCONTROL2 value);
}
member AudioMasterClockVerticalReference : Saa7119TYPIDAUDIOCLOCKCONTROL2 with get, set

Property Value

Type: Saa7119TYPIDAUDIOCLOCKCONTROL2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AudioPLLModes Property

IRD

Saa7119AudioPLLModes Property

Audio PLL modes

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDAUDIOCLOCKCONTROL3 AudioPLLModes { get; set; }
Public Property AudioPLLModes As Saa7119TYPIDAUDIOCLOCKCONTROL3
    Get
    Set
public:
property Saa7119TYPIDAUDIOCLOCKCONTROL3 AudioPLLModes {
    Saa7119TYPIDAUDIOCLOCKCONTROL3 get ();
    void set (Saa7119TYPIDAUDIOCLOCKCONTROL3 value);
}
member AudioPLLModes : Saa7119TYPIDAUDIOCLOCKCONTROL3 with get, set

Property Value

Type: Saa7119TYPIDAUDIOCLOCKCONTROL3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AutoFlush Property

IRD

Saa7119AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AutomaticaVCRTVDetectionThreshold Property

IRD

Saa7119AutomaticaVCRTVDetectionThreshold Property

Automatica VCR/TV-detection threshold

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION5 AutomaticaVCRTVDetectionThreshold { get; set; }
Public Property AutomaticaVCRTVDetectionThreshold As Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION5
    Get
    Set
public:
property Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION5 AutomaticaVCRTVDetectionThreshold {
    Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION5 get ();
    void set (Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION5 value);
}
member AutomaticaVCRTVDetectionThreshold : Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION5 with get, set

Property Value

Type: Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION5
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AutomaticChrominanceStandardDetectionControl Property

IRD

Saa7119AutomaticChrominanceStandardDetectionControl Property

Automatic chrominance standard detection control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDCHROMINANCECONTROL101 AutomaticChrominanceStandardDetectionControl { get; set; }
Public Property AutomaticChrominanceStandardDetectionControl As Saa7119TYPIDCHROMINANCECONTROL101
    Get
    Set
public:
property Saa7119TYPIDCHROMINANCECONTROL101 AutomaticChrominanceStandardDetectionControl {
    Saa7119TYPIDCHROMINANCECONTROL101 get ();
    void set (Saa7119TYPIDCHROMINANCECONTROL101 value);
}
member AutomaticChrominanceStandardDetectionControl : Saa7119TYPIDCHROMINANCECONTROL101 with get, set

Property Value

Type: Saa7119TYPIDCHROMINANCECONTROL101
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AutomaticColorLimiter Property

IRD

Saa7119AutomaticColorLimiter Property

Automatic color limiter

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION1 AutomaticColorLimiter { get; set; }
Public Property AutomaticColorLimiter As Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION1
    Get
    Set
public:
property Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION1 AutomaticColorLimiter {
    Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION1 get ();
    void set (Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION1 value);
}
member AutomaticColorLimiter : Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION1 with get, set

Property Value

Type: Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AutomaticFieldDetection Property

IRD

Saa7119AutomaticFieldDetection Property

Automatic field detection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSYNCCONTROL5 AutomaticFieldDetection { get; set; }
Public Property AutomaticFieldDetection As Saa7119TYPIDSYNCCONTROL5
    Get
    Set
public:
property Saa7119TYPIDSYNCCONTROL5 AutomaticFieldDetection {
    Saa7119TYPIDSYNCCONTROL5 get ();
    void set (Saa7119TYPIDSYNCCONTROL5 value);
}
member AutomaticFieldDetection : Saa7119TYPIDSYNCCONTROL5 with get, set

Property Value

Type: Saa7119TYPIDSYNCCONTROL5
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AutomaticGainControlIntegration Property

IRD

Saa7119AutomaticGainControlIntegration Property

Automatic gain control integration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDANALOGINPUTCONTROL21 AutomaticGainControlIntegration { get; set; }
Public Property AutomaticGainControlIntegration As Saa7119TYPIDANALOGINPUTCONTROL21
    Get
    Set
public:
property Saa7119TYPIDANALOGINPUTCONTROL21 AutomaticGainControlIntegration {
    Saa7119TYPIDANALOGINPUTCONTROL21 get ();
    void set (Saa7119TYPIDANALOGINPUTCONTROL21 value);
}
member AutomaticGainControlIntegration : Saa7119TYPIDANALOGINPUTCONTROL21 with get, set

Property Value

Type: Saa7119TYPIDANALOGINPUTCONTROL21
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.AutoStandardsSearchModeShort Property

IRD

Saa7119AutoStandardsSearchModeShort Property

Auto standards search mode short

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL22 AutoStandardsSearchModeShort { get; set; }
Public Property AutoStandardsSearchModeShort As Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL22
    Get
    Set
public:
property Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL22 AutoStandardsSearchModeShort {
    Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL22 get ();
    void set (Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL22 value);
}
member AutoStandardsSearchModeShort : Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL22 with get, set

Property Value

Type: Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL22
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.BONDID Property

IRD

Saa7119BONDID Property

BONDID

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte BONDID { get; }
Public ReadOnly Property BONDID As Byte
    Get
public:
property unsigned char BONDID {
    unsigned char get ();
}
member BONDID : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.CCHeaderEvenFieldsBeingUpdated Property

IRD

Saa7119CCHeaderEvenFieldsBeingUpdated Property

CC Header: Even fields: Being updated

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCHeaderEvenFieldsBeingUpdated { get; }
Public ReadOnly Property CCHeaderEvenFieldsBeingUpdated As Byte
    Get
public:
property unsigned char CCHeaderEvenFieldsBeingUpdated {
    unsigned char get ();
}
member CCHeaderEvenFieldsBeingUpdated : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.CCHeaderEvenFieldsDataErroneous Property

IRD

Saa7119CCHeaderEvenFieldsDataErroneous Property

CC Header: Even fields: Data erroneous

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCHeaderEvenFieldsDataErroneous { get; }
Public ReadOnly Property CCHeaderEvenFieldsDataErroneous As Byte
    Get
public:
property unsigned char CCHeaderEvenFieldsDataErroneous {
    unsigned char get ();
}
member CCHeaderEvenFieldsDataErroneous : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.CCHeaderFreeRunningFieldCounter Property

IRD

Saa7119CCHeaderFreeRunningFieldCounter Property

CC Header: free running field counter

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCHeaderFreeRunningFieldCounter { get; }
Public ReadOnly Property CCHeaderFreeRunningFieldCounter As Byte
    Get
public:
property unsigned char CCHeaderFreeRunningFieldCounter {
    unsigned char get ();
}
member CCHeaderFreeRunningFieldCounter : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.CCHeaderOddFieldsBeingUpdated Property

IRD

Saa7119CCHeaderOddFieldsBeingUpdated Property

CC Header: Odd fields: Being updated

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCHeaderOddFieldsBeingUpdated { get; }
Public ReadOnly Property CCHeaderOddFieldsBeingUpdated As Byte
    Get
public:
property unsigned char CCHeaderOddFieldsBeingUpdated {
    unsigned char get ();
}
member CCHeaderOddFieldsBeingUpdated : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.CCHeaderOddFieldsDataErroneous Property

IRD

Saa7119CCHeaderOddFieldsDataErroneous Property

CC Header: Odd fields: Data erroneous

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCHeaderOddFieldsDataErroneous { get; }
Public ReadOnly Property CCHeaderOddFieldsDataErroneous As Byte
    Get
public:
property unsigned char CCHeaderOddFieldsDataErroneous {
    unsigned char get ();
}
member CCHeaderOddFieldsDataErroneous : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.CCPayloadDataByte1EvenFields Property

IRD

Saa7119CCPayloadDataByte1EvenFields Property

CC payload data byte 1 (even fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCPayloadDataByte1EvenFields { get; }
Public ReadOnly Property CCPayloadDataByte1EvenFields As Byte
    Get
public:
property unsigned char CCPayloadDataByte1EvenFields {
    unsigned char get ();
}
member CCPayloadDataByte1EvenFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.CCPayloadDataByte1OddFields Property

IRD

Saa7119CCPayloadDataByte1OddFields Property

CC payload data byte 1 (odd fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCPayloadDataByte1OddFields { get; }
Public ReadOnly Property CCPayloadDataByte1OddFields As Byte
    Get
public:
property unsigned char CCPayloadDataByte1OddFields {
    unsigned char get ();
}
member CCPayloadDataByte1OddFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.CCPayloadDataByte2EvenFields Property

IRD

Saa7119CCPayloadDataByte2EvenFields Property

CC payload data byte 2 (even fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCPayloadDataByte2EvenFields { get; }
Public ReadOnly Property CCPayloadDataByte2EvenFields As Byte
    Get
public:
property unsigned char CCPayloadDataByte2EvenFields {
    unsigned char get ();
}
member CCPayloadDataByte2EvenFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.CCPayloadDataByte2OddFields Property

IRD

Saa7119CCPayloadDataByte2OddFields Property

CC payload data byte 2 (odd fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CCPayloadDataByte2OddFields { get; }
Public ReadOnly Property CCPayloadDataByte2OddFields As Byte
    Get
public:
property unsigned char CCPayloadDataByte2OddFields {
    unsigned char get ();
}
member CCPayloadDataByte2OddFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.CG1FeedbackDivider Property

IRD

Saa7119CG1FeedbackDivider Property

CG1 Feedback Divider

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CG1FeedbackDivider { get; set; }
Public Property CG1FeedbackDivider As Byte
    Get
    Set
public:
property unsigned char CG1FeedbackDivider {
    unsigned char get ();
    void set (unsigned char value);
}
member CG1FeedbackDivider : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ChangeOf12LineCharacteristicOfTheRetimedVAndFSignals Property

IRD

Saa7119ChangeOf12LineCharacteristicOfTheRetimedVAndFSignals Property

Change of 1/2 line characteristic of the retimed V and F signals

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS1 ChangeOf12LineCharacteristicOfTheRetimedVAndFSignals { get; set; }
Public Property ChangeOf12LineCharacteristicOfTheRetimedVAndFSignals As Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS1
    Get
    Set
public:
property Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS1 ChangeOf12LineCharacteristicOfTheRetimedVAndFSignals {
    Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS1 get ();
    void set (Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS1 value);
}
member ChangeOf12LineCharacteristicOfTheRetimedVAndFSignals : Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS1 with get, set

Property Value

Type: Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ChipID Property

IRD

Saa7119ChipID Property

Chip ID

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ChipID { get; }
Public ReadOnly Property ChipID As Byte
    Get
public:
property unsigned char ChipID {
    unsigned char get ();
}
member ChipID : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ChrominanceBandwidth Property

IRD

Saa7119ChrominanceBandwidth Property

Chrominance bandwidth

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDCHROMINANCECONTROL21 ChrominanceBandwidth { get; set; }
Public Property ChrominanceBandwidth As Saa7119TYPIDCHROMINANCECONTROL21
    Get
    Set
public:
property Saa7119TYPIDCHROMINANCECONTROL21 ChrominanceBandwidth {
    Saa7119TYPIDCHROMINANCECONTROL21 get ();
    void set (Saa7119TYPIDCHROMINANCECONTROL21 value);
}
member ChrominanceBandwidth : Saa7119TYPIDCHROMINANCECONTROL21 with get, set

Property Value

Type: Saa7119TYPIDCHROMINANCECONTROL21
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ChrominanceGainValue Property

IRD

Saa7119ChrominanceGainValue Property

Chrominance gain value

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDCHROMINANCEGAINCONTROL0 ChrominanceGainValue { get; set; }
Public Property ChrominanceGainValue As Saa7119TYPIDCHROMINANCEGAINCONTROL0
    Get
    Set
public:
property Saa7119TYPIDCHROMINANCEGAINCONTROL0 ChrominanceGainValue {
    Saa7119TYPIDCHROMINANCEGAINCONTROL0 get ();
    void set (Saa7119TYPIDCHROMINANCEGAINCONTROL0 value);
}
member ChrominanceGainValue : Saa7119TYPIDCHROMINANCEGAINCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDCHROMINANCEGAINCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ChrominanceHueControl Property

IRD

Saa7119ChrominanceHueControl Property

Chrominance hue control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ChrominanceHueControl { get; set; }
Public Property ChrominanceHueControl As Double
    Get
    Set
public:
property double ChrominanceHueControl {
    double get ();
    void set (double value);
}
member ChrominanceHueControl : float with get, set

Property Value

Type: Double
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ChrominanceSaturationControlComponentPartNegInverse Property

IRD

Saa7119ChrominanceSaturationControlComponentPartNegInverse Property

Chrominance saturation control component part (neg=inverse)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDCHROMINANCESATURCOMPONENTPART0 ChrominanceSaturationControlComponentPartNegInverse { get; set; }
Public Property ChrominanceSaturationControlComponentPartNegInverse As Saa7119TYPIDCHROMINANCESATURCOMPONENTPART0
    Get
    Set
public:
property Saa7119TYPIDCHROMINANCESATURCOMPONENTPART0 ChrominanceSaturationControlComponentPartNegInverse {
    Saa7119TYPIDCHROMINANCESATURCOMPONENTPART0 get ();
    void set (Saa7119TYPIDCHROMINANCESATURCOMPONENTPART0 value);
}
member ChrominanceSaturationControlComponentPartNegInverse : Saa7119TYPIDCHROMINANCESATURCOMPONENTPART0 with get, set

Property Value

Type: Saa7119TYPIDCHROMINANCESATURCOMPONENTPART0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ChrominanceSaturationControlDecoderPartNegInverse Property

IRD

Saa7119ChrominanceSaturationControlDecoderPartNegInverse Property

Chrominance saturation control: Decoder part (neg=inverse)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDCHROMINANCESATURURATIONCONTROL0 ChrominanceSaturationControlDecoderPartNegInverse { get; set; }
Public Property ChrominanceSaturationControlDecoderPartNegInverse As Saa7119TYPIDCHROMINANCESATURURATIONCONTROL0
    Get
    Set
public:
property Saa7119TYPIDCHROMINANCESATURURATIONCONTROL0 ChrominanceSaturationControlDecoderPartNegInverse {
    Saa7119TYPIDCHROMINANCESATURURATIONCONTROL0 get ();
    void set (Saa7119TYPIDCHROMINANCESATURURATIONCONTROL0 value);
}
member ChrominanceSaturationControlDecoderPartNegInverse : Saa7119TYPIDCHROMINANCESATURURATIONCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDCHROMINANCESATURURATIONCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ChrominanceTrapCombFilterBypass Property

IRD

Saa7119ChrominanceTrapCombFilterBypass Property

Chrominance trap/comb filter bypass

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLUMINANCECONTROL4 ChrominanceTrapCombFilterBypass { get; set; }
Public Property ChrominanceTrapCombFilterBypass As Saa7119TYPIDLUMINANCECONTROL4
    Get
    Set
public:
property Saa7119TYPIDLUMINANCECONTROL4 ChrominanceTrapCombFilterBypass {
    Saa7119TYPIDLUMINANCECONTROL4 get ();
    void set (Saa7119TYPIDLUMINANCECONTROL4 value);
}
member ChrominanceTrapCombFilterBypass : Saa7119TYPIDLUMINANCECONTROL4 with get, set

Property Value

Type: Saa7119TYPIDLUMINANCECONTROL4
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ClockDelay Property

IRD

Saa7119ClockDelay Property

Clock Delay

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ClockDelay { get; set; }
Public Property ClockDelay As Byte
    Get
    Set
public:
property unsigned char ClockDelay {
    unsigned char get ();
    void set (unsigned char value);
}
member ClockDelay : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ClockRatioAudioMasterClockAMXCLKToSerialBitClock Property

IRD

Saa7119ClockRatioAudioMasterClockAMXCLKToSerialBitClock Property

Clock ratio audio master clock (AMXCLK) to serial bit clock

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ClockRatioAudioMasterClockAMXCLKToSerialBitClock { get; set; }
Public Property ClockRatioAudioMasterClockAMXCLKToSerialBitClock As Byte
    Get
    Set
public:
property unsigned char ClockRatioAudioMasterClockAMXCLKToSerialBitClock {
    unsigned char get ();
    void set (unsigned char value);
}
member ClockRatioAudioMasterClockAMXCLKToSerialBitClock : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ClockRatioSerialBitClockASCLKToChannelSelectClockALRCLK Property

IRD

Saa7119ClockRatioSerialBitClockASCLKToChannelSelectClockALRCLK Property

Clock ratio serial bit clock (ASCLK) to channel select clock (ALRCLK)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ClockRatioSerialBitClockASCLKToChannelSelectClockALRCLK { get; set; }
Public Property ClockRatioSerialBitClockASCLKToChannelSelectClockALRCLK As Byte
    Get
    Set
public:
property unsigned char ClockRatioSerialBitClockASCLKToChannelSelectClockALRCLK {
    unsigned char get ();
    void set (unsigned char value);
}
member ClockRatioSerialBitClockASCLKToChannelSelectClockALRCLK : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ColourOn Property

IRD

Saa7119ColourOn Property

Colour on

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDMODEDELAYCONTROL4 ColourOn { get; set; }
Public Property ColourOn As Saa7119TYPIDMODEDELAYCONTROL4
    Get
    Set
public:
property Saa7119TYPIDMODEDELAYCONTROL4 ColourOn {
    Saa7119TYPIDMODEDELAYCONTROL4 get ();
    void set (Saa7119TYPIDMODEDELAYCONTROL4 value);
}
member ColourOn : Saa7119TYPIDMODEDELAYCONTROL4 with get, set

Property Value

Type: Saa7119TYPIDMODEDELAYCONTROL4
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ColourStandardSelectionInAUTOMode Property

IRD

Saa7119ColourStandardSelectionInAUTOMode Property

Colour standard selection in AUTO mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDCHROMINANCECONTROL13 ColourStandardSelectionInAUTOMode { get; set; }
Public Property ColourStandardSelectionInAUTOMode As Saa7119TYPIDCHROMINANCECONTROL13
    Get
    Set
public:
property Saa7119TYPIDCHROMINANCECONTROL13 ColourStandardSelectionInAUTOMode {
    Saa7119TYPIDCHROMINANCECONTROL13 get ();
    void set (Saa7119TYPIDCHROMINANCECONTROL13 value);
}
member ColourStandardSelectionInAUTOMode : Saa7119TYPIDCHROMINANCECONTROL13 with get, set

Property Value

Type: Saa7119TYPIDCHROMINANCECONTROL13
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.CombinedLuminanceChrominanceBandwidthAdjustment Property

IRD

Saa7119CombinedLuminanceChrominanceBandwidthAdjustment Property

Combined luminance/chrominance bandwidth adjustment

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDCHROMINANCECONTROL20 CombinedLuminanceChrominanceBandwidthAdjustment { get; set; }
Public Property CombinedLuminanceChrominanceBandwidthAdjustment As Saa7119TYPIDCHROMINANCECONTROL20
    Get
    Set
public:
property Saa7119TYPIDCHROMINANCECONTROL20 CombinedLuminanceChrominanceBandwidthAdjustment {
    Saa7119TYPIDCHROMINANCECONTROL20 get ();
    void set (Saa7119TYPIDCHROMINANCECONTROL20 value);
}
member CombinedLuminanceChrominanceBandwidthAdjustment : Saa7119TYPIDCHROMINANCECONTROL20 with get, set

Property Value

Type: Saa7119TYPIDCHROMINANCECONTROL20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.CombThreshold Property

IRD

Saa7119CombThreshold Property

Comb threshold

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL10 CombThreshold { get; set; }
Public Property CombThreshold As Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL10
    Get
    Set
public:
property Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL10 CombThreshold {
    Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL10 get ();
    void set (Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL10 value);
}
member CombThreshold : Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL10 with get, set

Property Value

Type: Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL10
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ConstantHigh Property

IRD

Saa7119ConstantHigh Property

Constant_high

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ConstantHigh { get; set; }
Public Property ConstantHigh As Byte
    Get
    Set
public:
property unsigned char ConstantHigh {
    unsigned char get ();
    void set (unsigned char value);
}
member ConstantHigh : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ConstantLow Property

IRD

Saa7119ConstantLow Property

Constant_low

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ConstantLow { get; set; }
Public Property ConstantLow As Byte
    Get
    Set
public:
property unsigned char ConstantLow {
    unsigned char get ();
    void set (unsigned char value);
}
member ConstantLow : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ContinuousFieldMode Property

IRD

Saa7119ContinuousFieldMode Property

Continuous field mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDGLOBALSETTINGS3 ContinuousFieldMode { get; set; }
Public Property ContinuousFieldMode As Saa7119TYPIDGLOBALSETTINGS3
    Get
    Set
public:
property Saa7119TYPIDGLOBALSETTINGS3 ContinuousFieldMode {
    Saa7119TYPIDGLOBALSETTINGS3 get ();
    void set (Saa7119TYPIDGLOBALSETTINGS3 value);
}
member ContinuousFieldMode : Saa7119TYPIDGLOBALSETTINGS3 with get, set

Property Value

Type: Saa7119TYPIDGLOBALSETTINGS3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.CopyOfBitDPROGCanBeUsedToDetectPowerUpAndStartUpFails Property

IRD

Saa7119CopyOfBitDPROGCanBeUsedToDetectPowerUpAndStartUpFails Property

Copy of bit DPROG, can be used to detect power-up and start-up fails

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CopyOfBitDPROGCanBeUsedToDetectPowerUpAndStartUpFails { get; }
Public ReadOnly Property CopyOfBitDPROGCanBeUsedToDetectPowerUpAndStartUpFails As Byte
    Get
public:
property unsigned char CopyOfBitDPROGCanBeUsedToDetectPowerUpAndStartUpFails {
    unsigned char get ();
}
member CopyOfBitDPROGCanBeUsedToDetectPowerUpAndStartUpFails : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.CopyProtectedSourceDetected Property

IRD

Saa7119CopyProtectedSourceDetected Property

Copy protected source detected

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDNotActiveActive CopyProtectedSourceDetected { get; }
Public ReadOnly Property CopyProtectedSourceDetected As Saa7119IDNotActiveActive
    Get
public:
property Saa7119IDNotActiveActive CopyProtectedSourceDetected {
    Saa7119IDNotActiveActive get ();
}
member CopyProtectedSourceDetected : Saa7119IDNotActiveActive with get

Property Value

Type: Saa7119IDNotActiveActive
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.CV0 Property

IRD

Saa7119CV0 Property

CV0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CV0 { get; }
Public ReadOnly Property CV0 As Byte
    Get
public:
property unsigned char CV0 {
    unsigned char get ();
}
member CV0 : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.DecoderAndVBISlicer Property

IRD

Saa7119DecoderAndVBISlicer Property

Decoder and VBI slicer

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDADCPORTCONTROLGLOBALSET0 DecoderAndVBISlicer { get; set; }
Public Property DecoderAndVBISlicer As Saa7119TYPIDADCPORTCONTROLGLOBALSET0
    Get
    Set
public:
property Saa7119TYPIDADCPORTCONTROLGLOBALSET0 DecoderAndVBISlicer {
    Saa7119TYPIDADCPORTCONTROLGLOBALSET0 get ();
    void set (Saa7119TYPIDADCPORTCONTROLGLOBALSET0 value);
}
member DecoderAndVBISlicer : Saa7119TYPIDADCPORTCONTROLGLOBALSET0 with get, set

Property Value

Type: Saa7119TYPIDADCPORTCONTROLGLOBALSET0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.DetectedColourStandard Property

IRD

Saa7119DetectedColourStandard Property

Detected colour standard

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSTATUSBYTE1VIDEODECODER0 DetectedColourStandard { get; }
Public ReadOnly Property DetectedColourStandard As Saa7119TYPIDSTATUSBYTE1VIDEODECODER0
    Get
public:
property Saa7119TYPIDSTATUSBYTE1VIDEODECODER0 DetectedColourStandard {
    Saa7119TYPIDSTATUSBYTE1VIDEODECODER0 get ();
}
member DetectedColourStandard : Saa7119TYPIDSTATUSBYTE1VIDEODECODER0 with get

Property Value

Type: Saa7119TYPIDSTATUSBYTE1VIDEODECODER0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.DFQBP Property

IRD

Saa7119DFQBP Property

DFQBP

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DFQBP { get; set; }
Public Property DFQBP As Byte
    Get
    Set
public:
property unsigned char DFQBP {
    unsigned char get ();
    void set (unsigned char value);
}
member DFQBP : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.DGA1 Property

IRD

Saa7119DGA1 Property

DGA1 (unit: dB)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDANALOGINPUTCONTROL30 DGA1 { get; set; }
Public Property DGA1 As Saa7119TYPIDANALOGINPUTCONTROL30
    Get
    Set
public:
property Saa7119TYPIDANALOGINPUTCONTROL30 DGA1 {
    Saa7119TYPIDANALOGINPUTCONTROL30 get ();
    void set (Saa7119TYPIDANALOGINPUTCONTROL30 value);
}
member DGA1 : Saa7119TYPIDANALOGINPUTCONTROL30 with get, set

Property Value

Type: Saa7119TYPIDANALOGINPUTCONTROL30
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.DGA2 Property

IRD

Saa7119DGA2 Property

DGA2 (unit: dB)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDANALOGINPUTCONTROL30 DGA2 { get; set; }
Public Property DGA2 As Saa7119TYPIDANALOGINPUTCONTROL30
    Get
    Set
public:
property Saa7119TYPIDANALOGINPUTCONTROL30 DGA2 {
    Saa7119TYPIDANALOGINPUTCONTROL30 get ();
    void set (Saa7119TYPIDANALOGINPUTCONTROL30 value);
}
member DGA2 : Saa7119TYPIDANALOGINPUTCONTROL30 with get, set

Property Value

Type: Saa7119TYPIDANALOGINPUTCONTROL30
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.DigitalGainStageHasReachedItsLowerLimitOfOperationRange Property

IRD

Saa7119DigitalGainStageHasReachedItsLowerLimitOfOperationRange Property

Digital gain stage has reached its lower limit of operation range

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSTATUSBYTE1VIDEODECODER1 DigitalGainStageHasReachedItsLowerLimitOfOperationRange { get; }
Public ReadOnly Property DigitalGainStageHasReachedItsLowerLimitOfOperationRange As Saa7119TYPIDSTATUSBYTE1VIDEODECODER1
    Get
public:
property Saa7119TYPIDSTATUSBYTE1VIDEODECODER1 DigitalGainStageHasReachedItsLowerLimitOfOperationRange {
    Saa7119TYPIDSTATUSBYTE1VIDEODECODER1 get ();
}
member DigitalGainStageHasReachedItsLowerLimitOfOperationRange : Saa7119TYPIDSTATUSBYTE1VIDEODECODER1 with get

Property Value

Type: Saa7119TYPIDSTATUSBYTE1VIDEODECODER1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.DigitalGainStageHasReachedItsUpperLimitOfOperationRange Property

IRD

Saa7119DigitalGainStageHasReachedItsUpperLimitOfOperationRange Property

Digital gain stage has reached its upper limit of operation range

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSTATUSBYTE1VIDEODECODER2 DigitalGainStageHasReachedItsUpperLimitOfOperationRange { get; }
Public ReadOnly Property DigitalGainStageHasReachedItsUpperLimitOfOperationRange As Saa7119TYPIDSTATUSBYTE1VIDEODECODER2
    Get
public:
property Saa7119TYPIDSTATUSBYTE1VIDEODECODER2 DigitalGainStageHasReachedItsUpperLimitOfOperationRange {
    Saa7119TYPIDSTATUSBYTE1VIDEODECODER2 get ();
}
member DigitalGainStageHasReachedItsUpperLimitOfOperationRange : Saa7119TYPIDSTATUSBYTE1VIDEODECODER2 with get

Property Value

Type: Saa7119TYPIDSTATUSBYTE1VIDEODECODER2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.DisableChrominanceVerticalFilterAndPALPhaseErrorCorrection Property

IRD

Saa7119DisableChrominanceVerticalFilterAndPALPhaseErrorCorrection Property

Disable chrominance vertical filter and PAL phase error correction

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDCHROMINANCECONTROL12 DisableChrominanceVerticalFilterAndPALPhaseErrorCorrection { get; set; }
Public Property DisableChrominanceVerticalFilterAndPALPhaseErrorCorrection As Saa7119TYPIDCHROMINANCECONTROL12
    Get
    Set
public:
property Saa7119TYPIDCHROMINANCECONTROL12 DisableChrominanceVerticalFilterAndPALPhaseErrorCorrection {
    Saa7119TYPIDCHROMINANCECONTROL12 get ();
    void set (Saa7119TYPIDCHROMINANCECONTROL12 value);
}
member DisableChrominanceVerticalFilterAndPALPhaseErrorCorrection : Saa7119TYPIDCHROMINANCECONTROL12 with get, set

Property Value

Type: Saa7119TYPIDCHROMINANCECONTROL12
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.DitherModeAtDataPathOutput Property

IRD

Saa7119DitherModeAtDataPathOutput Property

Dither mode at data path output

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDDITHERLUMA2 DitherModeAtDataPathOutput { get; set; }
Public Property DitherModeAtDataPathOutput As Saa7119TYPIDDITHERLUMA2
    Get
    Set
public:
property Saa7119TYPIDDITHERLUMA2 DitherModeAtDataPathOutput {
    Saa7119TYPIDDITHERLUMA2 get ();
    void set (Saa7119TYPIDDITHERLUMA2 value);
}
member DitherModeAtDataPathOutput : Saa7119TYPIDDITHERLUMA2 with get, set

Property Value

Type: Saa7119TYPIDDITHERLUMA2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.DividerReset Property

IRD

Saa7119DividerReset Property

Divider Reset

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DividerReset { get; set; }
Public Property DividerReset As Byte
    Get
    Set
public:
property unsigned char DividerReset {
    unsigned char get ();
    void set (unsigned char value);
}
member DividerReset : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.DPROG Property

IRD

Saa7119DPROG Property

DPROG

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDADCPORTCONTROLGLOBALSET3 DPROG { get; set; }
Public Property DPROG As Saa7119TYPIDADCPORTCONTROLGLOBALSET3
    Get
    Set
public:
property Saa7119TYPIDADCPORTCONTROLGLOBALSET3 DPROG {
    Saa7119TYPIDADCPORTCONTROLGLOBALSET3 get ();
    void set (Saa7119TYPIDADCPORTCONTROLGLOBALSET3 value);
}
member DPROG : Saa7119TYPIDADCPORTCONTROLGLOBALSET3 with get, set

Property Value

Type: Saa7119TYPIDADCPORTCONTROLGLOBALSET3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.DwordByteSwapInfluencesSerialOutputTiming Property

IRD

Saa7119DwordByteSwapInfluencesSerialOutputTiming Property

Dword byte swap, influences serial output timing

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES5 DwordByteSwapInfluencesSerialOutputTiming { get; set; }
Public Property DwordByteSwapInfluencesSerialOutputTiming As Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES5
    Get
    Set
public:
property Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES5 DwordByteSwapInfluencesSerialOutputTiming {
    Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES5 get ();
    void set (Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES5 value);
}
member DwordByteSwapInfluencesSerialOutputTiming : Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES5 with get, set

Property Value

Type: Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES5
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.EdgiEdgeBufferFull Property

IRD

Saa7119EdgiEdgeBufferFull Property

Edgi Edge Buffer Full

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSTATUSINFORMATIOATIONEDGIPART0 EdgiEdgeBufferFull { get; set; }
Public Property EdgiEdgeBufferFull As Saa7119TYPIDSTATUSINFORMATIOATIONEDGIPART0
    Get
    Set
public:
property Saa7119TYPIDSTATUSINFORMATIOATIONEDGIPART0 EdgiEdgeBufferFull {
    Saa7119TYPIDSTATUSINFORMATIOATIONEDGIPART0 get ();
    void set (Saa7119TYPIDSTATUSINFORMATIOATIONEDGIPART0 value);
}
member EdgiEdgeBufferFull : Saa7119TYPIDSTATUSINFORMATIOATIONEDGIPART0 with get, set

Property Value

Type: Saa7119TYPIDSTATUSINFORMATIOATIONEDGIPART0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.EdgiFifoFull Property

IRD

Saa7119EdgiFifoFull Property

Edgi Fifo Full

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSTATUSINFORMATIOATIONEDGIPART0 EdgiFifoFull { get; set; }
Public Property EdgiFifoFull As Saa7119TYPIDSTATUSINFORMATIOATIONEDGIPART0
    Get
    Set
public:
property Saa7119TYPIDSTATUSINFORMATIOATIONEDGIPART0 EdgiFifoFull {
    Saa7119TYPIDSTATUSINFORMATIOATIONEDGIPART0 get ();
    void set (Saa7119TYPIDSTATUSINFORMATIOATIONEDGIPART0 value);
}
member EdgiFifoFull : Saa7119TYPIDSTATUSINFORMATIOATIONEDGIPART0 with get, set

Property Value

Type: Saa7119TYPIDSTATUSINFORMATIOATIONEDGIPART0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.EnableClock1Generation Property

IRD

Saa7119EnableClock1Generation Property

Enable Clock 1 Generation

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable EnableClock1Generation { get; set; }
Public Property EnableClock1Generation As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable EnableClock1Generation {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member EnableClock1Generation : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.EnableTheFIRFilterAsASecondOrderLowPass Property

IRD

Saa7119EnableTheFIRFilterAsASecondOrderLowPass Property

Enable the FIR filter as a second-order low-pass

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EnableTheFIRFilterAsASecondOrderLowPass { get; set; }
Public Property EnableTheFIRFilterAsASecondOrderLowPass As Byte
    Get
    Set
public:
property unsigned char EnableTheFIRFilterAsASecondOrderLowPass {
    unsigned char get ();
    void set (unsigned char value);
}
member EnableTheFIRFilterAsASecondOrderLowPass : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ErrorFlagOfScalersOutputFormatter Property

IRD

Saa7119ErrorFlagOfScalersOutputFormatter Property

Error flag of scalers output formatter

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ErrorFlagOfScalersOutputFormatter { get; }
Public ReadOnly Property ErrorFlagOfScalersOutputFormatter As Byte
    Get
public:
property unsigned char ErrorFlagOfScalersOutputFormatter {
    unsigned char get ();
}
member ErrorFlagOfScalersOutputFormatter : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.EvenFieldsBeingUpdated Property

IRD

Saa7119EvenFieldsBeingUpdated Property

Even fields: Being updated

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EvenFieldsBeingUpdated { get; }
Public ReadOnly Property EvenFieldsBeingUpdated As Byte
    Get
public:
property unsigned char EvenFieldsBeingUpdated {
    unsigned char get ();
}
member EvenFieldsBeingUpdated : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.EvenFieldsDataErroneous Property

IRD

Saa7119EvenFieldsDataErroneous Property

Even fields: Data erroneous

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EvenFieldsDataErroneous { get; }
Public ReadOnly Property EvenFieldsDataErroneous As Byte
    Get
public:
property unsigned char EvenFieldsDataErroneous {
    unsigned char get ();
}
member EvenFieldsDataErroneous : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ExpertMode Property

IRD

Saa7119ExpertMode Property

Expert Mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDANALOGINPUTCONTROL24 ExpertMode { get; set; }
Public Property ExpertMode As Saa7119TYPIDANALOGINPUTCONTROL24
    Get
    Set
public:
property Saa7119TYPIDANALOGINPUTCONTROL24 ExpertMode {
    Saa7119TYPIDANALOGINPUTCONTROL24 get ();
    void set (Saa7119TYPIDANALOGINPUTCONTROL24 value);
}
member ExpertMode : Saa7119TYPIDANALOGINPUTCONTROL24 with get, set

Property Value

Type: Saa7119TYPIDANALOGINPUTCONTROL24
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ExternalSourceSwitchIndicatorInputEXMCLR Property

IRD

Saa7119ExternalSourceSwitchIndicatorInputEXMCLR Property

External source switch indicator Input EXMCLR

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable ExternalSourceSwitchIndicatorInputEXMCLR { get; set; }
Public Property ExternalSourceSwitchIndicatorInputEXMCLR As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable ExternalSourceSwitchIndicatorInputEXMCLR {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member ExternalSourceSwitchIndicatorInputEXMCLR : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.FAEFIFOFlagAlmostEmptyLevel Property

IRD

Saa7119FAEFIFOFlagAlmostEmptyLevel Property

FAE FIFO flag almost empty level

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION0 FAEFIFOFlagAlmostEmptyLevel { get; set; }
Public Property FAEFIFOFlagAlmostEmptyLevel As Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION0
    Get
    Set
public:
property Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION0 FAEFIFOFlagAlmostEmptyLevel {
    Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION0 get ();
    void set (Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION0 value);
}
member FAEFIFOFlagAlmostEmptyLevel : Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION0 with get, set

Property Value

Type: Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.FAFFIFOFlagAlmostFullLevel Property

IRD

Saa7119FAFFIFOFlagAlmostFullLevel Property

FAF FIFO flag almost full level

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION1 FAFFIFOFlagAlmostFullLevel { get; set; }
Public Property FAFFIFOFlagAlmostFullLevel As Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION1
    Get
    Set
public:
property Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION1 FAFFIFOFlagAlmostFullLevel {
    Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION1 get ();
    void set (Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION1 value);
}
member FAFFIFOFlagAlmostFullLevel : Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION1 with get, set

Property Value

Type: Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.FastColourTimeConstant Property

IRD

Saa7119FastColourTimeConstant Property

Fast colour time constant

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDCHROMINANCECONTROL11 FastColourTimeConstant { get; set; }
Public Property FastColourTimeConstant As Saa7119TYPIDCHROMINANCECONTROL11
    Get
    Set
public:
property Saa7119TYPIDCHROMINANCECONTROL11 FastColourTimeConstant {
    Saa7119TYPIDCHROMINANCECONTROL11 get ();
    void set (Saa7119TYPIDCHROMINANCECONTROL11 value);
}
member FastColourTimeConstant : Saa7119TYPIDCHROMINANCECONTROL11 with get, set

Property Value

Type: Saa7119TYPIDCHROMINANCECONTROL11
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.FASTCondition Property

IRD

Saa7119FASTCondition Property

FAST condition

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FASTCondition { get; set; }
Public Property FASTCondition As Byte
    Get
    Set
public:
property unsigned char FASTCondition {
    unsigned char get ();
    void set (unsigned char value);
}
member FASTCondition : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.FastPALSECAMSequenceCorrection Property

IRD

Saa7119FastPALSECAMSequenceCorrection Property

Fast PAL/SECAM sequence correction

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION0 FastPALSECAMSequenceCorrection { get; set; }
Public Property FastPALSECAMSequenceCorrection As Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION0
    Get
    Set
public:
property Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION0 FastPALSECAMSequenceCorrection {
    Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION0 get ();
    void set (Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION0 value);
}
member FastPALSECAMSequenceCorrection : Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION0 with get, set

Property Value

Type: Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.FastSwitchInputSelect Property

IRD

Saa7119FastSwitchInputSelect Property

Fast switch input select

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDFASTSWITCHCONTROL34 FastSwitchInputSelect { get; set; }
Public Property FastSwitchInputSelect As Saa7119TYPIDFASTSWITCHCONTROL34
    Get
    Set
public:
property Saa7119TYPIDFASTSWITCHCONTROL34 FastSwitchInputSelect {
    Saa7119TYPIDFASTSWITCHCONTROL34 get ();
    void set (Saa7119TYPIDFASTSWITCHCONTROL34 value);
}
member FastSwitchInputSelect : Saa7119TYPIDFASTSWITCHCONTROL34 with get, set

Property Value

Type: Saa7119TYPIDFASTSWITCHCONTROL34
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.FastSwitchPreviousFieldCriteria Property

IRD

Saa7119FastSwitchPreviousFieldCriteria Property

Fast switch previous field criteria

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDFASTSWITCHCONTROL32 FastSwitchPreviousFieldCriteria { get; set; }
Public Property FastSwitchPreviousFieldCriteria As Saa7119TYPIDFASTSWITCHCONTROL32
    Get
    Set
public:
property Saa7119TYPIDFASTSWITCHCONTROL32 FastSwitchPreviousFieldCriteria {
    Saa7119TYPIDFASTSWITCHCONTROL32 get ();
    void set (Saa7119TYPIDFASTSWITCHCONTROL32 value);
}
member FastSwitchPreviousFieldCriteria : Saa7119TYPIDFASTSWITCHCONTROL32 with get, set

Property Value

Type: Saa7119TYPIDFASTSWITCHCONTROL32
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.FieldOffset Property

IRD

Saa7119FieldOffset Property

Field offset

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDFIELDOFFSETANDERTICALOFFSETS1 FieldOffset { get; set; }
Public Property FieldOffset As Saa7119TYPIDFIELDOFFSETANDERTICALOFFSETS1
    Get
    Set
public:
property Saa7119TYPIDFIELDOFFSETANDERTICALOFFSETS1 FieldOffset {
    Saa7119TYPIDFIELDOFFSETANDERTICALOFFSETS1 get ();
    void set (Saa7119TYPIDFIELDOFFSETANDERTICALOFFSETS1 value);
}
member FieldOffset : Saa7119TYPIDFIELDOFFSETANDERTICALOFFSETS1 with get, set

Property Value

Type: Saa7119TYPIDFIELDOFFSETANDERTICALOFFSETS1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.FieldSelection Property

IRD

Saa7119FieldSelection Property

Field selection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSYNCCONTROL4 FieldSelection { get; set; }
Public Property FieldSelection As Saa7119TYPIDSYNCCONTROL4
    Get
    Set
public:
property Saa7119TYPIDSYNCCONTROL4 FieldSelection {
    Saa7119TYPIDSYNCCONTROL4 get ();
    void set (Saa7119TYPIDSYNCCONTROL4 value);
}
member FieldSelection : Saa7119TYPIDSYNCCONTROL4 with get, set

Property Value

Type: Saa7119TYPIDSYNCCONTROL4
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.Filter1Bypass Property

IRD

Saa7119Filter1Bypass Property

Filter 1 Bypass

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDANALOGINPUTCONTROL11 Filter1Bypass { get; set; }
Public Property Filter1Bypass As Saa7119TYPIDANALOGINPUTCONTROL11
    Get
    Set
public:
property Saa7119TYPIDANALOGINPUTCONTROL11 Filter1Bypass {
    Saa7119TYPIDANALOGINPUTCONTROL11 get ();
    void set (Saa7119TYPIDANALOGINPUTCONTROL11 value);
}
member Filter1Bypass : Saa7119TYPIDANALOGINPUTCONTROL11 with get, set

Property Value

Type: Saa7119TYPIDANALOGINPUTCONTROL11
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.Filter2Bypass Property

IRD

Saa7119Filter2Bypass Property

Filter 2 Bypass

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDANALOGINPUTCONTROL11 Filter2Bypass { get; set; }
Public Property Filter2Bypass As Saa7119TYPIDANALOGINPUTCONTROL11
    Get
    Set
public:
property Saa7119TYPIDANALOGINPUTCONTROL11 Filter2Bypass {
    Saa7119TYPIDANALOGINPUTCONTROL11 get ();
    void set (Saa7119TYPIDANALOGINPUTCONTROL11 value);
}
member Filter2Bypass : Saa7119TYPIDANALOGINPUTCONTROL11 with get, set

Property Value

Type: Saa7119TYPIDANALOGINPUTCONTROL11
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.FineOffsetAdjustmentBYComponent Property

IRD

Saa7119FineOffsetAdjustmentBYComponent Property

Fine offset adjustment B - Y component

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDCHROMINANCECONTROL22 FineOffsetAdjustmentBYComponent { get; set; }
Public Property FineOffsetAdjustmentBYComponent As Saa7119TYPIDCHROMINANCECONTROL22
    Get
    Set
public:
property Saa7119TYPIDCHROMINANCECONTROL22 FineOffsetAdjustmentBYComponent {
    Saa7119TYPIDCHROMINANCECONTROL22 get ();
    void set (Saa7119TYPIDCHROMINANCECONTROL22 value);
}
member FineOffsetAdjustmentBYComponent : Saa7119TYPIDCHROMINANCECONTROL22 with get, set

Property Value

Type: Saa7119TYPIDCHROMINANCECONTROL22
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.FineOffsetAdjustmentRYComponent Property

IRD

Saa7119FineOffsetAdjustmentRYComponent Property

Fine offset adjustment R - Y component

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDCHROMINANCECONTROL22 FineOffsetAdjustmentRYComponent { get; set; }
Public Property FineOffsetAdjustmentRYComponent As Saa7119TYPIDCHROMINANCECONTROL22
    Get
    Set
public:
property Saa7119TYPIDCHROMINANCECONTROL22 FineOffsetAdjustmentRYComponent {
    Saa7119TYPIDCHROMINANCECONTROL22 get ();
    void set (Saa7119TYPIDCHROMINANCECONTROL22 value);
}
member FineOffsetAdjustmentRYComponent : Saa7119TYPIDCHROMINANCECONTROL22 with get, set

Property Value

Type: Saa7119TYPIDCHROMINANCECONTROL22
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.FinePositionOfHS Property

IRD

Saa7119FinePositionOfHS Property

Fine position of HS

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FinePositionOfHS { get; set; }
Public Property FinePositionOfHS As Byte
    Get
    Set
public:
property unsigned char FinePositionOfHS {
    unsigned char get ();
    void set (unsigned char value);
}
member FinePositionOfHS : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.FixColorPLL Property

IRD

Saa7119FixColorPLL Property

Fix color PLL

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL21 FixColorPLL { get; set; }
Public Property FixColorPLL As Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL21
    Get
    Set
public:
property Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL21 FixColorPLL {
    Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL21 get ();
    void set (Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL21 value);
}
member FixColorPLL : Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL21 with get, set

Property Value

Type: Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL21
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ForceAnalogueGainForChannel1 Property

IRD

Saa7119ForceAnalogueGainForChannel1 Property

Force analogue gain for channel 1 (unit: dB)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ForceAnalogueGainForChannel1 { get; set; }
Public Property ForceAnalogueGainForChannel1 As Double
    Get
    Set
public:
property double ForceAnalogueGainForChannel1 {
    double get ();
    void set (double value);
}
member ForceAnalogueGainForChannel1 : float with get, set

Property Value

Type: Double
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ForceAnalogueGainForChannel1__1 Property

IRD

Saa7119ForceAnalogueGainForChannel1__1 Property

Force analogue gain for channel 1 (unit: dB)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ForceAnalogueGainForChannel1__1 { get; set; }
Public Property ForceAnalogueGainForChannel1__1 As Double
    Get
    Set
public:
property double ForceAnalogueGainForChannel1__1 {
    double get ();
    void set (double value);
}
member ForceAnalogueGainForChannel1__1 : float with get, set

Property Value

Type: Double
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ForceDigitalGainForChannel1 Property

IRD

Saa7119ForceDigitalGainForChannel1 Property

Force digital gain for channel 1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDANALOGINPUTCONTROL30 ForceDigitalGainForChannel1 { get; set; }
Public Property ForceDigitalGainForChannel1 As Saa7119TYPIDANALOGINPUTCONTROL30
    Get
    Set
public:
property Saa7119TYPIDANALOGINPUTCONTROL30 ForceDigitalGainForChannel1 {
    Saa7119TYPIDANALOGINPUTCONTROL30 get ();
    void set (Saa7119TYPIDANALOGINPUTCONTROL30 value);
}
member ForceDigitalGainForChannel1 : Saa7119TYPIDANALOGINPUTCONTROL30 with get, set

Property Value

Type: Saa7119TYPIDANALOGINPUTCONTROL30
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ForceDigitalGainForChannel1CVBSY Property

IRD

Saa7119ForceDigitalGainForChannel1CVBSY Property

Force digital gain for channel 1 (CVBS/Y)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDANALOGINPUTCONTROL30 ForceDigitalGainForChannel1CVBSY { get; set; }
Public Property ForceDigitalGainForChannel1CVBSY As Saa7119TYPIDANALOGINPUTCONTROL30
    Get
    Set
public:
property Saa7119TYPIDANALOGINPUTCONTROL30 ForceDigitalGainForChannel1CVBSY {
    Saa7119TYPIDANALOGINPUTCONTROL30 get ();
    void set (Saa7119TYPIDANALOGINPUTCONTROL30 value);
}
member ForceDigitalGainForChannel1CVBSY : Saa7119TYPIDANALOGINPUTCONTROL30 with get, set

Property Value

Type: Saa7119TYPIDANALOGINPUTCONTROL30
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ForcedODDEVENToggle Property

IRD

Saa7119ForcedODDEVENToggle Property

Forced ODD/EVEN toggle

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSYNCCONTROL3 ForcedODDEVENToggle { get; set; }
Public Property ForcedODDEVENToggle As Saa7119TYPIDSYNCCONTROL3
    Get
    Set
public:
property Saa7119TYPIDSYNCCONTROL3 ForcedODDEVENToggle {
    Saa7119TYPIDSYNCCONTROL3 get ();
    void set (Saa7119TYPIDSYNCCONTROL3 value);
}
member ForcedODDEVENToggle : Saa7119TYPIDSYNCCONTROL3 with get, set

Property Value

Type: Saa7119TYPIDSYNCCONTROL3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.FramingCodeError Property

IRD

Saa7119FramingCodeError Property

Framing Code Error

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSET1 FramingCodeError { get; set; }
Public Property FramingCodeError As Saa7119TYPIDSLICERSET1
    Get
    Set
public:
property Saa7119TYPIDSLICERSET1 FramingCodeError {
    Saa7119TYPIDSLICERSET1 get ();
    void set (Saa7119TYPIDSLICERSET1 value);
}
member FramingCodeError : Saa7119TYPIDSLICERSET1 with get, set

Property Value

Type: Saa7119TYPIDSLICERSET1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.FramingCodeForProgrammableDataTypes Property

IRD

Saa7119FramingCodeForProgrammableDataTypes Property

Framing code for programmable data types

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FramingCodeForProgrammableDataTypes { get; set; }
Public Property FramingCodeForProgrammableDataTypes As Byte
    Get
    Set
public:
property unsigned char FramingCodeForProgrammableDataTypes {
    unsigned char get ();
    void set (unsigned char value);
}
member FramingCodeForProgrammableDataTypes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.FreeRunningFieldCounter Property

IRD

Saa7119FreeRunningFieldCounter Property

Free running field counter

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FreeRunningFieldCounter { get; }
Public ReadOnly Property FreeRunningFieldCounter As Byte
    Get
public:
property unsigned char FreeRunningFieldCounter {
    unsigned char get ();
}
member FreeRunningFieldCounter : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.FSSHFT Property

IRD

Saa7119FSSHFT Property

FSSHFT

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDFASTSWITCHCONTROL10 FSSHFT { get; set; }
Public Property FSSHFT As Saa7119TYPIDFASTSWITCHCONTROL10
    Get
    Set
public:
property Saa7119TYPIDFASTSWITCHCONTROL10 FSSHFT {
    Saa7119TYPIDFASTSWITCHCONTROL10 get ();
    void set (Saa7119TYPIDFASTSWITCHCONTROL10 value);
}
member FSSHFT : Saa7119TYPIDFASTSWITCHCONTROL10 with get, set

Property Value

Type: Saa7119TYPIDFASTSWITCHCONTROL10
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.FSWAlphaValueOutputInverted Property

IRD

Saa7119FSWAlphaValueOutputInverted Property

FSW alpha value output inverted

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FSWAlphaValueOutputInverted { get; set; }
Public Property FSWAlphaValueOutputInverted As Byte
    Get
    Set
public:
property unsigned char FSWAlphaValueOutputInverted {
    unsigned char get ();
    void set (unsigned char value);
}
member FSWAlphaValueOutputInverted : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GainControlFix Property

IRD

Saa7119GainControlFix Property

Gain control fix

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDANALOGINPUTCONTROL20 GainControlFix { get; set; }
Public Property GainControlFix As Saa7119TYPIDANALOGINPUTCONTROL20
    Get
    Set
public:
property Saa7119TYPIDANALOGINPUTCONTROL20 GainControlFix {
    Saa7119TYPIDANALOGINPUTCONTROL20 get ();
    void set (Saa7119TYPIDANALOGINPUTCONTROL20 value);
}
member GainControlFix : Saa7119TYPIDANALOGINPUTCONTROL20 with get, set

Property Value

Type: Saa7119TYPIDANALOGINPUTCONTROL20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GainControlFixedAnalog Property

IRD

Saa7119GainControlFixedAnalog Property

Gain control fixed analog

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDANALOGINPUTCONTROL22 GainControlFixedAnalog { get; set; }
Public Property GainControlFixedAnalog As Saa7119TYPIDANALOGINPUTCONTROL22
    Get
    Set
public:
property Saa7119TYPIDANALOGINPUTCONTROL22 GainControlFixedAnalog {
    Saa7119TYPIDANALOGINPUTCONTROL22 get ();
    void set (Saa7119TYPIDANALOGINPUTCONTROL22 value);
}
member GainControlFixedAnalog : Saa7119TYPIDANALOGINPUTCONTROL22 with get, set

Property Value

Type: Saa7119TYPIDANALOGINPUTCONTROL22
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GS1HeaderEvenFieldsBeingUpdated Property

IRD

Saa7119GS1HeaderEvenFieldsBeingUpdated Property

GS1 header: Even fields: Being updated

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GS1HeaderEvenFieldsBeingUpdated { get; }
Public ReadOnly Property GS1HeaderEvenFieldsBeingUpdated As Byte
    Get
public:
property unsigned char GS1HeaderEvenFieldsBeingUpdated {
    unsigned char get ();
}
member GS1HeaderEvenFieldsBeingUpdated : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GS1HeaderEvenFieldsDataErroneous Property

IRD

Saa7119GS1HeaderEvenFieldsDataErroneous Property

GS1 header: Even fields: Data erroneous

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GS1HeaderEvenFieldsDataErroneous { get; }
Public ReadOnly Property GS1HeaderEvenFieldsDataErroneous As Byte
    Get
public:
property unsigned char GS1HeaderEvenFieldsDataErroneous {
    unsigned char get ();
}
member GS1HeaderEvenFieldsDataErroneous : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GS1HeaderFreeRunningFieldCounter Property

IRD

Saa7119GS1HeaderFreeRunningFieldCounter Property

GS1 header: free running field counter

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GS1HeaderFreeRunningFieldCounter { get; }
Public ReadOnly Property GS1HeaderFreeRunningFieldCounter As Byte
    Get
public:
property unsigned char GS1HeaderFreeRunningFieldCounter {
    unsigned char get ();
}
member GS1HeaderFreeRunningFieldCounter : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GS1HeaderOddFieldsBeingUpdated Property

IRD

Saa7119GS1HeaderOddFieldsBeingUpdated Property

GS1 header: Odd fields: Being updated

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GS1HeaderOddFieldsBeingUpdated { get; }
Public ReadOnly Property GS1HeaderOddFieldsBeingUpdated As Byte
    Get
public:
property unsigned char GS1HeaderOddFieldsBeingUpdated {
    unsigned char get ();
}
member GS1HeaderOddFieldsBeingUpdated : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GS1HeaderOddFieldsDataErroneous Property

IRD

Saa7119GS1HeaderOddFieldsDataErroneous Property

GS1 header: Odd fields: Data erroneous

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GS1HeaderOddFieldsDataErroneous { get; }
Public ReadOnly Property GS1HeaderOddFieldsDataErroneous As Byte
    Get
public:
property unsigned char GS1HeaderOddFieldsDataErroneous {
    unsigned char get ();
}
member GS1HeaderOddFieldsDataErroneous : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GS1PayloadDataByte1EvenFields Property

IRD

Saa7119GS1PayloadDataByte1EvenFields Property

GS1 payload data byte 1 (even fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GS1PayloadDataByte1EvenFields { get; }
Public ReadOnly Property GS1PayloadDataByte1EvenFields As Byte
    Get
public:
property unsigned char GS1PayloadDataByte1EvenFields {
    unsigned char get ();
}
member GS1PayloadDataByte1EvenFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GS1PayloadDataByte1OddFields Property

IRD

Saa7119GS1PayloadDataByte1OddFields Property

GS1 payload data byte 1 (odd fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GS1PayloadDataByte1OddFields { get; }
Public ReadOnly Property GS1PayloadDataByte1OddFields As Byte
    Get
public:
property unsigned char GS1PayloadDataByte1OddFields {
    unsigned char get ();
}
member GS1PayloadDataByte1OddFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GS1PayloadDataByte2EvenFields Property

IRD

Saa7119GS1PayloadDataByte2EvenFields Property

GS1 payload data byte 2 (even fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GS1PayloadDataByte2EvenFields { get; }
Public ReadOnly Property GS1PayloadDataByte2EvenFields As Byte
    Get
public:
property unsigned char GS1PayloadDataByte2EvenFields {
    unsigned char get ();
}
member GS1PayloadDataByte2EvenFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GS1PayloadDataByte2OddFields Property

IRD

Saa7119GS1PayloadDataByte2OddFields Property

GS1 payload data byte 2 (odd fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GS1PayloadDataByte2OddFields { get; }
Public ReadOnly Property GS1PayloadDataByte2OddFields As Byte
    Get
public:
property unsigned char GS1PayloadDataByte2OddFields {
    unsigned char get ();
}
member GS1PayloadDataByte2OddFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GS2PayloadDataByte1EvenFields Property

IRD

Saa7119GS2PayloadDataByte1EvenFields Property

GS2 payload data byte 1 (even fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GS2PayloadDataByte1EvenFields { get; }
Public ReadOnly Property GS2PayloadDataByte1EvenFields As Byte
    Get
public:
property unsigned char GS2PayloadDataByte1EvenFields {
    unsigned char get ();
}
member GS2PayloadDataByte1EvenFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GS2PayloadDataByte1OddFields Property

IRD

Saa7119GS2PayloadDataByte1OddFields Property

GS2 payload data byte 1 (odd fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GS2PayloadDataByte1OddFields { get; }
Public ReadOnly Property GS2PayloadDataByte1OddFields As Byte
    Get
public:
property unsigned char GS2PayloadDataByte1OddFields {
    unsigned char get ();
}
member GS2PayloadDataByte1OddFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GS2PayloadDataByte2EvenFields Property

IRD

Saa7119GS2PayloadDataByte2EvenFields Property

GS2 payload data byte 2 (even fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GS2PayloadDataByte2EvenFields { get; }
Public ReadOnly Property GS2PayloadDataByte2EvenFields As Byte
    Get
public:
property unsigned char GS2PayloadDataByte2EvenFields {
    unsigned char get ();
}
member GS2PayloadDataByte2EvenFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GS2PayloadDataByte2OddFields Property

IRD

Saa7119GS2PayloadDataByte2OddFields Property

GS2 payload data byte 2 (odd fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GS2PayloadDataByte2OddFields { get; }
Public ReadOnly Property GS2PayloadDataByte2OddFields As Byte
    Get
public:
property unsigned char GS2PayloadDataByte2OddFields {
    unsigned char get ();
}
member GS2PayloadDataByte2OddFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GS2PayloadDataByte3EvenFields Property

IRD

Saa7119GS2PayloadDataByte3EvenFields Property

GS2 payload data byte 3 (even fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GS2PayloadDataByte3EvenFields { get; }
Public ReadOnly Property GS2PayloadDataByte3EvenFields As Byte
    Get
public:
property unsigned char GS2PayloadDataByte3EvenFields {
    unsigned char get ();
}
member GS2PayloadDataByte3EvenFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GS2PayloadDataByte3OddFields Property

IRD

Saa7119GS2PayloadDataByte3OddFields Property

GS2 payload data byte 3 (odd fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GS2PayloadDataByte3OddFields { get; }
Public ReadOnly Property GS2PayloadDataByte3OddFields As Byte
    Get
public:
property unsigned char GS2PayloadDataByte3OddFields {
    unsigned char get ();
}
member GS2PayloadDataByte3OddFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GS2PayloadDataByte4EvenFields Property

IRD

Saa7119GS2PayloadDataByte4EvenFields Property

GS2 payload data byte 4 (even fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GS2PayloadDataByte4EvenFields { get; }
Public ReadOnly Property GS2PayloadDataByte4EvenFields As Byte
    Get
public:
property unsigned char GS2PayloadDataByte4EvenFields {
    unsigned char get ();
}
member GS2PayloadDataByte4EvenFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.GS2PayloadDataByte4OddFields Property

IRD

Saa7119GS2PayloadDataByte4OddFields Property

GS2 payload data byte 4 (odd fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GS2PayloadDataByte4OddFields { get; }
Public ReadOnly Property GS2PayloadDataByte4OddFields As Byte
    Get
public:
property unsigned char GS2PayloadDataByte4OddFields {
    unsigned char get ();
}
member GS2PayloadDataByte4OddFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.HammingCheck Property

IRD

Saa7119HammingCheck Property

Hamming Check

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSET2 HammingCheck { get; set; }
Public Property HammingCheck As Saa7119TYPIDSLICERSET2
    Get
    Set
public:
property Saa7119TYPIDSLICERSET2 HammingCheck {
    Saa7119TYPIDSLICERSET2 get ();
    void set (Saa7119TYPIDSLICERSET2 value);
}
member HammingCheck : Saa7119TYPIDSLICERSET2 with get, set

Property Value

Type: Saa7119TYPIDSLICERSET2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.HorizontalDifferenceGain Property

IRD

Saa7119HorizontalDifferenceGain Property

Horizontal difference gain

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL13 HorizontalDifferenceGain { get; set; }
Public Property HorizontalDifferenceGain As Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL13
    Get
    Set
public:
property Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL13 HorizontalDifferenceGain {
    Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL13 get ();
    void set (Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL13 value);
}
member HorizontalDifferenceGain : Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL13 with get, set

Property Value

Type: Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL13
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.HorizontalLockIndicatorSelection Property

IRD

Saa7119HorizontalLockIndicatorSelection Property

Horizontal lock indicator selection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDRTXPORTOUTPUTCONTROL0 HorizontalLockIndicatorSelection { get; set; }
Public Property HorizontalLockIndicatorSelection As Saa7119TYPIDRTXPORTOUTPUTCONTROL0
    Get
    Set
public:
property Saa7119TYPIDRTXPORTOUTPUTCONTROL0 HorizontalLockIndicatorSelection {
    Saa7119TYPIDRTXPORTOUTPUTCONTROL0 get ();
    void set (Saa7119TYPIDRTXPORTOUTPUTCONTROL0 value);
}
member HorizontalLockIndicatorSelection : Saa7119TYPIDRTXPORTOUTPUTCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDRTXPORTOUTPUTCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.HorizontalOffsetForSlicer Property

IRD

Saa7119HorizontalOffsetForSlicer Property

Horizontal offset for slicer

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort HorizontalOffsetForSlicer { get; set; }
Public Property HorizontalOffsetForSlicer As UShort
    Get
    Set
public:
property unsigned short HorizontalOffsetForSlicer {
    unsigned short get ();
    void set (unsigned short value);
}
member HorizontalOffsetForSlicer : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.HorizontalPLL Property

IRD

Saa7119HorizontalPLL Property

Horizontal PLL

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSYNCCONTROL1 HorizontalPLL { get; set; }
Public Property HorizontalPLL As Saa7119TYPIDSYNCCONTROL1
    Get
    Set
public:
property Saa7119TYPIDSYNCCONTROL1 HorizontalPLL {
    Saa7119TYPIDSYNCCONTROL1 get ();
    void set (Saa7119TYPIDSYNCCONTROL1 value);
}
member HorizontalPLL : Saa7119TYPIDSYNCCONTROL1 with get, set

Property Value

Type: Saa7119TYPIDSYNCCONTROL1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.HorizontalScalingModes Property

IRD

Saa7119HorizontalScalingModes Property

Horizontal Scaling Modes

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDPANORAMAANDKEYSTONING2 HorizontalScalingModes { get; set; }
Public Property HorizontalScalingModes As Saa7119TYPIDPANORAMAANDKEYSTONING2
    Get
    Set
public:
property Saa7119TYPIDPANORAMAANDKEYSTONING2 HorizontalScalingModes {
    Saa7119TYPIDPANORAMAANDKEYSTONING2 get ();
    void set (Saa7119TYPIDPANORAMAANDKEYSTONING2 value);
}
member HorizontalScalingModes : Saa7119TYPIDPANORAMAANDKEYSTONING2 with get, set

Property Value

Type: Saa7119TYPIDPANORAMAANDKEYSTONING2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.HorizontalTimeConstantSelection Property

IRD

Saa7119HorizontalTimeConstantSelection Property

Horizontal time constant selection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSYNCCONTROL2 HorizontalTimeConstantSelection { get; set; }
Public Property HorizontalTimeConstantSelection As Saa7119TYPIDSYNCCONTROL2
    Get
    Set
public:
property Saa7119TYPIDSYNCCONTROL2 HorizontalTimeConstantSelection {
    Saa7119TYPIDSYNCCONTROL2 get ();
    void set (Saa7119TYPIDSYNCCONTROL2 value);
}
member HorizontalTimeConstantSelection : Saa7119TYPIDSYNCCONTROL2 with get, set

Property Value

Type: Saa7119TYPIDSYNCCONTROL2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.HorSyncStartDelayTimeStepSize8LLC Property

IRD

Saa7119HorSyncStartDelayTimeStepSize8LLC Property

Hor. sync start: Delay Time (Step size=8/LLC)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte HorSyncStartDelayTimeStepSize8LLC { get; set; }
Public Property HorSyncStartDelayTimeStepSize8LLC As SByte
    Get
    Set
public:
property signed char HorSyncStartDelayTimeStepSize8LLC {
    signed char get ();
    void set (signed char value);
}
member HorSyncStartDelayTimeStepSize8LLC : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.HorSyncStopDelayTimeStepSize8LLC Property

IRD

Saa7119HorSyncStopDelayTimeStepSize8LLC Property

Hor. sync stop: Delay Time (Step size=8/LLC)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte HorSyncStopDelayTimeStepSize8LLC { get; set; }
Public Property HorSyncStopDelayTimeStepSize8LLC As SByte
    Get
    Set
public:
property signed char HorSyncStopDelayTimeStepSize8LLC {
    signed char get ();
    void set (signed char value);
}
member HorSyncStopDelayTimeStepSize8LLC : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.IDEL Property

IRD

Saa7119IDEL Property

IDEL

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDHORIZONTALINCREMENTDELAY0 IDEL { get; set; }
Public Property IDEL As Saa7119TYPIDHORIZONTALINCREMENTDELAY0
    Get
    Set
public:
property Saa7119TYPIDHORIZONTALINCREMENTDELAY0 IDEL {
    Saa7119TYPIDHORIZONTALINCREMENTDELAY0 get ();
    void set (Saa7119TYPIDHORIZONTALINCREMENTDELAY0 value);
}
member IDEL : Saa7119TYPIDHORIZONTALINCREMENTDELAY0 with get, set

Property Value

Type: Saa7119TYPIDHORIZONTALINCREMENTDELAY0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.IdentificationBitForDetectedFieldFrequency Property

IRD

Saa7119IdentificationBitForDetectedFieldFrequency Property

Identification bit for detected field frequency (unit: Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSTATUSBYTE2VIDEODECODER5 IdentificationBitForDetectedFieldFrequency { get; }
Public ReadOnly Property IdentificationBitForDetectedFieldFrequency As Saa7119TYPIDSTATUSBYTE2VIDEODECODER5
    Get
public:
property Saa7119TYPIDSTATUSBYTE2VIDEODECODER5 IdentificationBitForDetectedFieldFrequency {
    Saa7119TYPIDSTATUSBYTE2VIDEODECODER5 get ();
}
member IdentificationBitForDetectedFieldFrequency : Saa7119TYPIDSTATUSBYTE2VIDEODECODER5 with get

Property Value

Type: Saa7119TYPIDSTATUSBYTE2VIDEODECODER5
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.IDQAsGatedClock Property

IRD

Saa7119IDQAsGatedClock Property

IDQ as gated clock

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDIPORTIOENABLEKPHASECONTROL2 IDQAsGatedClock { get; set; }
Public Property IDQAsGatedClock As Saa7119TYPIDIPORTIOENABLEKPHASECONTROL2
    Get
    Set
public:
property Saa7119TYPIDIPORTIOENABLEKPHASECONTROL2 IDQAsGatedClock {
    Saa7119TYPIDIPORTIOENABLEKPHASECONTROL2 get ();
    void set (Saa7119TYPIDIPORTIOENABLEKPHASECONTROL2 value);
}
member IDQAsGatedClock : Saa7119TYPIDIPORTIOENABLEKPHASECONTROL2 with get, set

Property Value

Type: Saa7119TYPIDIPORTIOENABLEKPHASECONTROL2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.InterruptEnableColourStandardChanged0 Property

IRD

Saa7119InterruptEnableColourStandardChanged0 Property

Interrupt enable 'colour standard changed 0'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable InterruptEnableColourStandardChanged0 { get; set; }
Public Property InterruptEnableColourStandardChanged0 As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable InterruptEnableColourStandardChanged0 {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member InterruptEnableColourStandardChanged0 : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.InterruptEnableColourStandardChanged1 Property

IRD

Saa7119InterruptEnableColourStandardChanged1 Property

Interrupt enable 'colour standard changed 1'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable InterruptEnableColourStandardChanged1 { get; set; }
Public Property InterruptEnableColourStandardChanged1 As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable InterruptEnableColourStandardChanged1 {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member InterruptEnableColourStandardChanged1 : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.InterruptEnableColourStripeBurstAnyTypeDetectedLost Property

IRD

Saa7119InterruptEnableColourStripeBurstAnyTypeDetectedLost Property

Interrupt enable 'colour stripe burst (any type) detected/lost'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable InterruptEnableColourStripeBurstAnyTypeDetectedLost { get; set; }
Public Property InterruptEnableColourStripeBurstAnyTypeDetectedLost As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable InterruptEnableColourStripeBurstAnyTypeDetectedLost {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member InterruptEnableColourStripeBurstAnyTypeDetectedLost : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.InterruptEnableColourStripeType3BurstDetectedLost Property

IRD

Saa7119InterruptEnableColourStripeType3BurstDetectedLost Property

Interrupt enable 'colour stripe type 3 burst detected/lost'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable InterruptEnableColourStripeType3BurstDetectedLost { get; set; }
Public Property InterruptEnableColourStripeType3BurstDetectedLost As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable InterruptEnableColourStripeType3BurstDetectedLost {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member InterruptEnableColourStripeType3BurstDetectedLost : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.InterruptEnableCopyProtectedSignalFoundLost Property

IRD

Saa7119InterruptEnableCopyProtectedSignalFoundLost Property

Interrupt enable 'copy protected signal found/lost'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable InterruptEnableCopyProtectedSignalFoundLost { get; set; }
Public Property InterruptEnableCopyProtectedSignalFoundLost As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable InterruptEnableCopyProtectedSignalFoundLost {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member InterruptEnableCopyProtectedSignalFoundLost : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.InterruptEnableCopyProtectedSignalFoundLostSecondI2CSlave Property

IRD

Saa7119InterruptEnableCopyProtectedSignalFoundLostSecondI2CSlave Property

Interrupt enable 'copy protected signal found/lost' (second I2C slave)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable InterruptEnableCopyProtectedSignalFoundLostSecondI2CSlave { get; set; }
Public Property InterruptEnableCopyProtectedSignalFoundLostSecondI2CSlave As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable InterruptEnableCopyProtectedSignalFoundLostSecondI2CSlave {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member InterruptEnableCopyProtectedSignalFoundLostSecondI2CSlave : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.InterruptEnableErrorOutputFormatter Property

IRD

Saa7119InterruptEnableErrorOutputFormatter Property

Interrupt enable 'error output formatter'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable InterruptEnableErrorOutputFormatter { get; set; }
Public Property InterruptEnableErrorOutputFormatter As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable InterruptEnableErrorOutputFormatter {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member InterruptEnableErrorOutputFormatter : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.InterruptEnableFieldFrequencyHasChanged Property

IRD

Saa7119InterruptEnableFieldFrequencyHasChanged Property

Interrupt enable 'field frequency has changed'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable InterruptEnableFieldFrequencyHasChanged { get; set; }
Public Property InterruptEnableFieldFrequencyHasChanged As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable InterruptEnableFieldFrequencyHasChanged {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member InterruptEnableFieldFrequencyHasChanged : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.InterruptEnableHorizontalAndVerticalLockReachedLost Property

IRD

Saa7119InterruptEnableHorizontalAndVerticalLockReachedLost Property

Interrupt enable 'horizontal and vertical lock reached/lost'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable InterruptEnableHorizontalAndVerticalLockReachedLost { get; set; }
Public Property InterruptEnableHorizontalAndVerticalLockReachedLost As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable InterruptEnableHorizontalAndVerticalLockReachedLost {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member InterruptEnableHorizontalAndVerticalLockReachedLost : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.InterruptEnableHorizontalPLLLockedUnlocked Property

IRD

Saa7119InterruptEnableHorizontalPLLLockedUnlocked Property

Interrupt enable 'horizontal PLL locked/unlocked'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable InterruptEnableHorizontalPLLLockedUnlocked { get; set; }
Public Property InterruptEnableHorizontalPLLLockedUnlocked As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable InterruptEnableHorizontalPLLLockedUnlocked {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member InterruptEnableHorizontalPLLLockedUnlocked : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.InterruptEnableInterlacedNonInterlacedSource Property

IRD

Saa7119InterruptEnableInterlacedNonInterlacedSource Property

Interrupt enable 'interlaced/non-interlaced source'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable InterruptEnableInterlacedNonInterlacedSource { get; set; }
Public Property InterruptEnableInterlacedNonInterlacedSource As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable InterruptEnableInterlacedNonInterlacedSource {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member InterruptEnableInterlacedNonInterlacedSource : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.InterruptEnableNominalFieldLengthDetectedLost Property

IRD

Saa7119InterruptEnableNominalFieldLengthDetectedLost Property

Interrupt enable 'nominal field length detected/lost'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable InterruptEnableNominalFieldLengthDetectedLost { get; set; }
Public Property InterruptEnableNominalFieldLengthDetectedLost As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable InterruptEnableNominalFieldLengthDetectedLost {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member InterruptEnableNominalFieldLengthDetectedLost : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.InterruptEnableNominalFieldLengthDetectedLostSecondI2CSlave Property

IRD

Saa7119InterruptEnableNominalFieldLengthDetectedLostSecondI2CSlave Property

Interrupt enable 'nominal field length detected/lost' (second I2C slave)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable InterruptEnableNominalFieldLengthDetectedLostSecondI2CSlave { get; set; }
Public Property InterruptEnableNominalFieldLengthDetectedLostSecondI2CSlave As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable InterruptEnableNominalFieldLengthDetectedLostSecondI2CSlave {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member InterruptEnableNominalFieldLengthDetectedLostSecondI2CSlave : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.InterruptEnableReadyForCaptureNotReady Property

IRD

Saa7119InterruptEnableReadyForCaptureNotReady Property

Interrupt enable 'ready for capture/not ready'

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable InterruptEnableReadyForCaptureNotReady { get; set; }
Public Property InterruptEnableReadyForCaptureNotReady As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable InterruptEnableReadyForCaptureNotReady {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member InterruptEnableReadyForCaptureNotReady : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.InterruptEnableReadyForCaptureNotReadySecondI2CSlave Property

IRD

Saa7119InterruptEnableReadyForCaptureNotReadySecondI2CSlave Property

Interrupt enable 'ready for capture/not ready' (second I2C slave)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable InterruptEnableReadyForCaptureNotReadySecondI2CSlave { get; set; }
Public Property InterruptEnableReadyForCaptureNotReadySecondI2CSlave As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable InterruptEnableReadyForCaptureNotReadySecondI2CSlave {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member InterruptEnableReadyForCaptureNotReadySecondI2CSlave : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.IPortDataClock Property

IRD

Saa7119IPortDataClock Property

I-Port data clock

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDIPORTIOENABLEKPHASECONTROL1 IPortDataClock { get; set; }
Public Property IPortDataClock As Saa7119TYPIDIPORTIOENABLEKPHASECONTROL1
    Get
    Set
public:
property Saa7119TYPIDIPORTIOENABLEKPHASECONTROL1 IPortDataClock {
    Saa7119TYPIDIPORTIOENABLEKPHASECONTROL1 get ();
    void set (Saa7119TYPIDIPORTIOENABLEKPHASECONTROL1 value);
}
member IPortDataClock : Saa7119TYPIDIPORTIOENABLEKPHASECONTROL1 with get, set

Property Value

Type: Saa7119TYPIDIPORTIOENABLEKPHASECONTROL1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.IPortGlobalVideoTransferControl Property

IRD

Saa7119IPortGlobalVideoTransferControl Property

I - port global video transfer control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION2 IPortGlobalVideoTransferControl { get; set; }
Public Property IPortGlobalVideoTransferControl As Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION2
    Get
    Set
public:
property Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION2 IPortGlobalVideoTransferControl {
    Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION2 get ();
    void set (Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION2 value);
}
member IPortGlobalVideoTransferControl : Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION2 with get, set

Property Value

Type: Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.IPortOutput Property

IRD

Saa7119IPortOutput Property

I-port output

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDIPORTIOENABLEKPHASECONTROL0 IPortOutput { get; set; }
Public Property IPortOutput As Saa7119TYPIDIPORTIOENABLEKPHASECONTROL0
    Get
    Set
public:
property Saa7119TYPIDIPORTIOENABLEKPHASECONTROL0 IPortOutput {
    Saa7119TYPIDIPORTIOENABLEKPHASECONTROL0 get ();
    void set (Saa7119TYPIDIPORTIOENABLEKPHASECONTROL0 value);
}
member IPortOutput : Saa7119TYPIDIPORTIOENABLEKPHASECONTROL0 with get, set

Property Value

Type: Saa7119TYPIDIPORTIOENABLEKPHASECONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.IPortPackingMode Property

IRD

Saa7119IPortPackingMode Property

I-Port Packing mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION3 IPortPackingMode { get; set; }
Public Property IPortPackingMode As Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION3
    Get
    Set
public:
property Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION3 IPortPackingMode {
    Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION3 get ();
    void set (Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION3 value);
}
member IPortPackingMode : Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION3 with get, set

Property Value

Type: Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.IPortSignalDefinitionsIGP0 Property

IRD

Saa7119IPortSignalDefinitionsIGP0 Property

I - port signal definitions IGP0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDIPORTSIGNALDEFINITIONS01 IPortSignalDefinitionsIGP0 { get; set; }
Public Property IPortSignalDefinitionsIGP0 As Saa7119TYPIDIPORTSIGNALDEFINITIONS01
    Get
    Set
public:
property Saa7119TYPIDIPORTSIGNALDEFINITIONS01 IPortSignalDefinitionsIGP0 {
    Saa7119TYPIDIPORTSIGNALDEFINITIONS01 get ();
    void set (Saa7119TYPIDIPORTSIGNALDEFINITIONS01 value);
}
member IPortSignalDefinitionsIGP0 : Saa7119TYPIDIPORTSIGNALDEFINITIONS01 with get, set

Property Value

Type: Saa7119TYPIDIPORTSIGNALDEFINITIONS01
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.IPortSignalDefinitionsIGP1 Property

IRD

Saa7119IPortSignalDefinitionsIGP1 Property

I - port signal definitions IGP1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDIPORTSIGNALDEFINITIONS02 IPortSignalDefinitionsIGP1 { get; set; }
Public Property IPortSignalDefinitionsIGP1 As Saa7119TYPIDIPORTSIGNALDEFINITIONS02
    Get
    Set
public:
property Saa7119TYPIDIPORTSIGNALDEFINITIONS02 IPortSignalDefinitionsIGP1 {
    Saa7119TYPIDIPORTSIGNALDEFINITIONS02 get ();
    void set (Saa7119TYPIDIPORTSIGNALDEFINITIONS02 value);
}
member IPortSignalDefinitionsIGP1 : Saa7119TYPIDIPORTSIGNALDEFINITIONS02 with get, set

Property Value

Type: Saa7119TYPIDIPORTSIGNALDEFINITIONS02
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.IPortSignalDefinitionsIGPH Property

IRD

Saa7119IPortSignalDefinitionsIGPH Property

I-port signal definitions: IGPH

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDIPORTSIGNALDEFINITIONS0 IPortSignalDefinitionsIGPH { get; set; }
Public Property IPortSignalDefinitionsIGPH As Saa7119TYPIDIPORTSIGNALDEFINITIONS0
    Get
    Set
public:
property Saa7119TYPIDIPORTSIGNALDEFINITIONS0 IPortSignalDefinitionsIGPH {
    Saa7119TYPIDIPORTSIGNALDEFINITIONS0 get ();
    void set (Saa7119TYPIDIPORTSIGNALDEFINITIONS0 value);
}
member IPortSignalDefinitionsIGPH : Saa7119TYPIDIPORTSIGNALDEFINITIONS0 with get, set

Property Value

Type: Saa7119TYPIDIPORTSIGNALDEFINITIONS0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.IPortSignalDefinitionsIGPV Property

IRD

Saa7119IPortSignalDefinitionsIGPV Property

I-port signal definitions: IGPV

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDIPORTSIGNALDEFINITIONS1 IPortSignalDefinitionsIGPV { get; set; }
Public Property IPortSignalDefinitionsIGPV As Saa7119TYPIDIPORTSIGNALDEFINITIONS1
    Get
    Set
public:
property Saa7119TYPIDIPORTSIGNALDEFINITIONS1 IPortSignalDefinitionsIGPV {
    Saa7119TYPIDIPORTSIGNALDEFINITIONS1 get ();
    void set (Saa7119TYPIDIPORTSIGNALDEFINITIONS1 value);
}
member IPortSignalDefinitionsIGPV : Saa7119TYPIDIPORTSIGNALDEFINITIONS1 with get, set

Property Value

Type: Saa7119TYPIDIPORTSIGNALDEFINITIONS1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister10Field16050Hz Property

IRD

Saa7119LCRRegister10Field16050Hz Property

LCR Register 10: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister10Field16050Hz { get; set; }
Public Property LCRRegister10Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister10Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister10Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister10Field26050Hz Property

IRD

Saa7119LCRRegister10Field26050Hz Property

LCR Register 10: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister10Field26050Hz { get; set; }
Public Property LCRRegister10Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister10Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister10Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister11Field16050Hz Property

IRD

Saa7119LCRRegister11Field16050Hz Property

LCR Register 11: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister11Field16050Hz { get; set; }
Public Property LCRRegister11Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister11Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister11Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister11Field26050Hz Property

IRD

Saa7119LCRRegister11Field26050Hz Property

LCR Register 11: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister11Field26050Hz { get; set; }
Public Property LCRRegister11Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister11Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister11Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister12Field16050Hz Property

IRD

Saa7119LCRRegister12Field16050Hz Property

LCR Register 12: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister12Field16050Hz { get; set; }
Public Property LCRRegister12Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister12Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister12Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister12Field26050Hz Property

IRD

Saa7119LCRRegister12Field26050Hz Property

LCR Register 12: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister12Field26050Hz { get; set; }
Public Property LCRRegister12Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister12Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister12Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister13Field16050Hz Property

IRD

Saa7119LCRRegister13Field16050Hz Property

LCR Register 13: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister13Field16050Hz { get; set; }
Public Property LCRRegister13Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister13Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister13Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister13Field26050Hz Property

IRD

Saa7119LCRRegister13Field26050Hz Property

LCR Register 13: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister13Field26050Hz { get; set; }
Public Property LCRRegister13Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister13Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister13Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister14Field16050Hz Property

IRD

Saa7119LCRRegister14Field16050Hz Property

LCR Register 14: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister14Field16050Hz { get; set; }
Public Property LCRRegister14Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister14Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister14Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister14Field26050Hz Property

IRD

Saa7119LCRRegister14Field26050Hz Property

LCR Register 14: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister14Field26050Hz { get; set; }
Public Property LCRRegister14Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister14Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister14Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister15Field16050Hz Property

IRD

Saa7119LCRRegister15Field16050Hz Property

LCR Register 15: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister15Field16050Hz { get; set; }
Public Property LCRRegister15Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister15Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister15Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister15Field26050Hz Property

IRD

Saa7119LCRRegister15Field26050Hz Property

LCR Register 15: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister15Field26050Hz { get; set; }
Public Property LCRRegister15Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister15Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister15Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister16Field16050Hz Property

IRD

Saa7119LCRRegister16Field16050Hz Property

LCR Register 16: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister16Field16050Hz { get; set; }
Public Property LCRRegister16Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister16Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister16Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister16Field26050Hz Property

IRD

Saa7119LCRRegister16Field26050Hz Property

LCR Register 16: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister16Field26050Hz { get; set; }
Public Property LCRRegister16Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister16Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister16Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister17Field16050Hz Property

IRD

Saa7119LCRRegister17Field16050Hz Property

LCR Register 17: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister17Field16050Hz { get; set; }
Public Property LCRRegister17Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister17Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister17Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister17Field26050Hz Property

IRD

Saa7119LCRRegister17Field26050Hz Property

LCR Register 17: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister17Field26050Hz { get; set; }
Public Property LCRRegister17Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister17Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister17Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister18Field16050Hz Property

IRD

Saa7119LCRRegister18Field16050Hz Property

LCR Register 18: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister18Field16050Hz { get; set; }
Public Property LCRRegister18Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister18Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister18Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister18Field26050Hz Property

IRD

Saa7119LCRRegister18Field26050Hz Property

LCR Register 18: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister18Field26050Hz { get; set; }
Public Property LCRRegister18Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister18Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister18Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister19Field16050Hz Property

IRD

Saa7119LCRRegister19Field16050Hz Property

LCR Register 19: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister19Field16050Hz { get; set; }
Public Property LCRRegister19Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister19Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister19Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister19Field26050Hz Property

IRD

Saa7119LCRRegister19Field26050Hz Property

LCR Register 19: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister19Field26050Hz { get; set; }
Public Property LCRRegister19Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister19Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister19Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister20Field16050Hz Property

IRD

Saa7119LCRRegister20Field16050Hz Property

LCR Register 20: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister20Field16050Hz { get; set; }
Public Property LCRRegister20Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister20Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister20Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister20Field26050Hz Property

IRD

Saa7119LCRRegister20Field26050Hz Property

LCR Register 20: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister20Field26050Hz { get; set; }
Public Property LCRRegister20Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister20Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister20Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister21Field16050Hz Property

IRD

Saa7119LCRRegister21Field16050Hz Property

LCR Register 21: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister21Field16050Hz { get; set; }
Public Property LCRRegister21Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister21Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister21Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister21Field26050Hz Property

IRD

Saa7119LCRRegister21Field26050Hz Property

LCR Register 21: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister21Field26050Hz { get; set; }
Public Property LCRRegister21Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister21Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister21Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister22Field16050Hz Property

IRD

Saa7119LCRRegister22Field16050Hz Property

LCR Register 22: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister22Field16050Hz { get; set; }
Public Property LCRRegister22Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister22Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister22Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister22Field26050Hz Property

IRD

Saa7119LCRRegister22Field26050Hz Property

LCR Register 22: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister22Field26050Hz { get; set; }
Public Property LCRRegister22Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister22Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister22Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister23Field16050Hz Property

IRD

Saa7119LCRRegister23Field16050Hz Property

LCR Register 23: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister23Field16050Hz { get; set; }
Public Property LCRRegister23Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister23Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister23Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister23Field26050Hz Property

IRD

Saa7119LCRRegister23Field26050Hz Property

LCR Register 23: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister23Field26050Hz { get; set; }
Public Property LCRRegister23Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister23Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister23Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister24Field16050Hz Property

IRD

Saa7119LCRRegister24Field16050Hz Property

LCR Register 24: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister24Field16050Hz { get; set; }
Public Property LCRRegister24Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister24Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister24Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister24Field26050Hz Property

IRD

Saa7119LCRRegister24Field26050Hz Property

LCR Register 24: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister24Field26050Hz { get; set; }
Public Property LCRRegister24Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister24Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister24Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister2Field16050Hz Property

IRD

Saa7119LCRRegister2Field16050Hz Property

LCR Register 2: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister2Field16050Hz { get; set; }
Public Property LCRRegister2Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister2Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister2Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister2Field26050Hz Property

IRD

Saa7119LCRRegister2Field26050Hz Property

LCR Register 2: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister2Field26050Hz { get; set; }
Public Property LCRRegister2Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister2Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister2Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister3Field16050Hz Property

IRD

Saa7119LCRRegister3Field16050Hz Property

LCR Register 3: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister3Field16050Hz { get; set; }
Public Property LCRRegister3Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister3Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister3Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister3Field26050Hz Property

IRD

Saa7119LCRRegister3Field26050Hz Property

LCR Register 3: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister3Field26050Hz { get; set; }
Public Property LCRRegister3Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister3Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister3Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister4Field16050Hz Property

IRD

Saa7119LCRRegister4Field16050Hz Property

LCR Register 4: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister4Field16050Hz { get; set; }
Public Property LCRRegister4Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister4Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister4Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister4Field26050Hz Property

IRD

Saa7119LCRRegister4Field26050Hz Property

LCR Register 4: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister4Field26050Hz { get; set; }
Public Property LCRRegister4Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister4Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister4Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister5Field16050Hz Property

IRD

Saa7119LCRRegister5Field16050Hz Property

LCR Register 5: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister5Field16050Hz { get; set; }
Public Property LCRRegister5Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister5Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister5Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister5Field26050Hz Property

IRD

Saa7119LCRRegister5Field26050Hz Property

LCR Register 5: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister5Field26050Hz { get; set; }
Public Property LCRRegister5Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister5Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister5Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister6Field16050Hz Property

IRD

Saa7119LCRRegister6Field16050Hz Property

LCR Register 6: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister6Field16050Hz { get; set; }
Public Property LCRRegister6Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister6Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister6Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister6Field26050Hz Property

IRD

Saa7119LCRRegister6Field26050Hz Property

LCR Register 6: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister6Field26050Hz { get; set; }
Public Property LCRRegister6Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister6Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister6Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister7Field16050Hz Property

IRD

Saa7119LCRRegister7Field16050Hz Property

LCR Register 7: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister7Field16050Hz { get; set; }
Public Property LCRRegister7Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister7Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister7Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister7Field26050Hz Property

IRD

Saa7119LCRRegister7Field26050Hz Property

LCR Register 7: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister7Field26050Hz { get; set; }
Public Property LCRRegister7Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister7Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister7Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister8Field16050Hz Property

IRD

Saa7119LCRRegister8Field16050Hz Property

LCR Register 8: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister8Field16050Hz { get; set; }
Public Property LCRRegister8Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister8Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister8Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister8Field26050Hz Property

IRD

Saa7119LCRRegister8Field26050Hz Property

LCR Register 8: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister8Field26050Hz { get; set; }
Public Property LCRRegister8Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister8Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister8Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister9Field16050Hz Property

IRD

Saa7119LCRRegister9Field16050Hz Property

LCR Register 9: Field 1 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister9Field16050Hz { get; set; }
Public Property LCRRegister9Field16050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister9Field16050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister9Field16050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LCRRegister9Field26050Hz Property

IRD

Saa7119LCRRegister9Field26050Hz Property

LCR Register 9: Field 2 (60/50 Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLCRREGISTER20 LCRRegister9Field26050Hz { get; set; }
Public Property LCRRegister9Field26050Hz As Saa7119TYPIDLCRREGISTER20
    Get
    Set
public:
property Saa7119TYPIDLCRREGISTER20 LCRRegister9Field26050Hz {
    Saa7119TYPIDLCRREGISTER20 get ();
    void set (Saa7119TYPIDLCRREGISTER20 value);
}
member LCRRegister9Field26050Hz : Saa7119TYPIDLCRREGISTER20 with get, set

Property Value

Type: Saa7119TYPIDLCRREGISTER20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LeftSlopeForKeystoneCompensation Property

IRD

Saa7119LeftSlopeForKeystoneCompensation Property

Left Slope for keystone compensation

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LeftSlopeForKeystoneCompensation { get; set; }
Public Property LeftSlopeForKeystoneCompensation As Byte
    Get
    Set
public:
property unsigned char LeftSlopeForKeystoneCompensation {
    unsigned char get ();
    void set (unsigned char value);
}
member LeftSlopeForKeystoneCompensation : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LengthAccumulationFilter Property

IRD

Saa7119LengthAccumulationFilter Property

Length accumulation filter

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LengthAccumulationFilter { get; set; }
Public Property LengthAccumulationFilter As Double
    Get
    Set
public:
property double LengthAccumulationFilter {
    double get ();
    void set (double value);
}
member LengthAccumulationFilter : float with get, set

Property Value

Type: Double
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LimitLevelImagePort Property

IRD

Saa7119LimitLevelImagePort Property

Limit Level Image Port

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS5 LimitLevelImagePort { get; set; }
Public Property LimitLevelImagePort As Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS5
    Get
    Set
public:
property Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS5 LimitLevelImagePort {
    Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS5 get ();
    void set (Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS5 value);
}
member LimitLevelImagePort : Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS5 with get, set

Property Value

Type: Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS5
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LLC2OutputEnable Property

IRD

Saa7119LLC2OutputEnable Property

LLC2 output enable

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDMISCELLANEOUSVGATEMSBS2 LLC2OutputEnable { get; set; }
Public Property LLC2OutputEnable As Saa7119TYPIDMISCELLANEOUSVGATEMSBS2
    Get
    Set
public:
property Saa7119TYPIDMISCELLANEOUSVGATEMSBS2 LLC2OutputEnable {
    Saa7119TYPIDMISCELLANEOUSVGATEMSBS2 get ();
    void set (Saa7119TYPIDMISCELLANEOUSVGATEMSBS2 value);
}
member LLC2OutputEnable : Saa7119TYPIDMISCELLANEOUSVGATEMSBS2 with get, set

Property Value

Type: Saa7119TYPIDMISCELLANEOUSVGATEMSBS2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LLCOutputEnable Property

IRD

Saa7119LLCOutputEnable Property

LLC output enable

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDMISCELLANEOUSVGATEMSBS2 LLCOutputEnable { get; set; }
Public Property LLCOutputEnable As Saa7119TYPIDMISCELLANEOUSVGATEMSBS2
    Get
    Set
public:
property Saa7119TYPIDMISCELLANEOUSVGATEMSBS2 LLCOutputEnable {
    Saa7119TYPIDMISCELLANEOUSVGATEMSBS2 get ();
    void set (Saa7119TYPIDMISCELLANEOUSVGATEMSBS2 value);
}
member LLCOutputEnable : Saa7119TYPIDMISCELLANEOUSVGATEMSBS2 with get, set

Property Value

Type: Saa7119TYPIDMISCELLANEOUSVGATEMSBS2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE10 Property

IRD

Saa7119LNFE10 Property

LNFE10

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE10 { get; set; }
Public Property LNFE10 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE10 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE10 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE11 Property

IRD

Saa7119LNFE11 Property

LNFE11

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE11 { get; set; }
Public Property LNFE11 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE11 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE11 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE12 Property

IRD

Saa7119LNFE12 Property

LNFE12

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE12 { get; set; }
Public Property LNFE12 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE12 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE12 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE13 Property

IRD

Saa7119LNFE13 Property

LNFE13

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE13 { get; set; }
Public Property LNFE13 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE13 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE13 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE14 Property

IRD

Saa7119LNFE14 Property

LNFE14

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE14 { get; set; }
Public Property LNFE14 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE14 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE14 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE15 Property

IRD

Saa7119LNFE15 Property

LNFE15

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE15 { get; set; }
Public Property LNFE15 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE15 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE15 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE16 Property

IRD

Saa7119LNFE16 Property

LNFE16

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE16 { get; set; }
Public Property LNFE16 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE16 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE16 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE17 Property

IRD

Saa7119LNFE17 Property

LNFE17

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE17 { get; set; }
Public Property LNFE17 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE17 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE17 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE18 Property

IRD

Saa7119LNFE18 Property

LNFE18

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE18 { get; set; }
Public Property LNFE18 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE18 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE18 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE19 Property

IRD

Saa7119LNFE19 Property

LNFE19

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE19 { get; set; }
Public Property LNFE19 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE19 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE19 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE2 Property

IRD

Saa7119LNFE2 Property

LNFE2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE2 { get; set; }
Public Property LNFE2 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE2 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE2 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE20 Property

IRD

Saa7119LNFE20 Property

LNFE20

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE20 { get; set; }
Public Property LNFE20 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE20 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE20 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE21 Property

IRD

Saa7119LNFE21 Property

LNFE21

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE21 { get; set; }
Public Property LNFE21 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE21 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE21 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE22 Property

IRD

Saa7119LNFE22 Property

LNFE22

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE22 { get; set; }
Public Property LNFE22 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE22 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE22 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE23 Property

IRD

Saa7119LNFE23 Property

LNFE23

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE23 { get; set; }
Public Property LNFE23 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE23 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE23 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE24 Property

IRD

Saa7119LNFE24 Property

LNFE24

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE24 { get; set; }
Public Property LNFE24 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE24 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE24 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE3 Property

IRD

Saa7119LNFE3 Property

LNFE3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE3 { get; set; }
Public Property LNFE3 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE3 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE3 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE4 Property

IRD

Saa7119LNFE4 Property

LNFE4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE4 { get; set; }
Public Property LNFE4 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE4 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE4 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE5 Property

IRD

Saa7119LNFE5 Property

LNFE5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE5 { get; set; }
Public Property LNFE5 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE5 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE5 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE6 Property

IRD

Saa7119LNFE6 Property

LNFE6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE6 { get; set; }
Public Property LNFE6 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE6 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE6 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE7 Property

IRD

Saa7119LNFE7 Property

LNFE7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE7 { get; set; }
Public Property LNFE7 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE7 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE7 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE8 Property

IRD

Saa7119LNFE8 Property

LNFE8

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE8 { get; set; }
Public Property LNFE8 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE8 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE8 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFE9 Property

IRD

Saa7119LNFE9 Property

LNFE9

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE9 { get; set; }
Public Property LNFE9 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFE9 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFE9 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO10 Property

IRD

Saa7119LNFO10 Property

LNFO10

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO10 { get; set; }
Public Property LNFO10 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO10 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO10 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO11 Property

IRD

Saa7119LNFO11 Property

LNFO11

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO11 { get; set; }
Public Property LNFO11 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO11 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO11 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO12 Property

IRD

Saa7119LNFO12 Property

LNFO12

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO12 { get; set; }
Public Property LNFO12 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO12 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO12 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO13 Property

IRD

Saa7119LNFO13 Property

LNFO13

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO13 { get; set; }
Public Property LNFO13 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO13 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO13 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO14 Property

IRD

Saa7119LNFO14 Property

LNFO14

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO14 { get; set; }
Public Property LNFO14 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO14 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO14 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO15 Property

IRD

Saa7119LNFO15 Property

LNFO15

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO15 { get; set; }
Public Property LNFO15 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO15 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO15 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO16 Property

IRD

Saa7119LNFO16 Property

LNFO16

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO16 { get; set; }
Public Property LNFO16 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO16 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO16 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO17 Property

IRD

Saa7119LNFO17 Property

LNFO17

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO17 { get; set; }
Public Property LNFO17 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO17 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO17 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO18 Property

IRD

Saa7119LNFO18 Property

LNFO18

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO18 { get; set; }
Public Property LNFO18 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO18 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO18 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO19 Property

IRD

Saa7119LNFO19 Property

LNFO19

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO19 { get; set; }
Public Property LNFO19 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO19 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO19 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO2 Property

IRD

Saa7119LNFO2 Property

LNFO2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO2 { get; set; }
Public Property LNFO2 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO2 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO2 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO20 Property

IRD

Saa7119LNFO20 Property

LNFO20

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO20 { get; set; }
Public Property LNFO20 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO20 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO20 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO21 Property

IRD

Saa7119LNFO21 Property

LNFO21

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO21 { get; set; }
Public Property LNFO21 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO21 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO21 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO22 Property

IRD

Saa7119LNFO22 Property

LNFO22

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO22 { get; set; }
Public Property LNFO22 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO22 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO22 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO23 Property

IRD

Saa7119LNFO23 Property

LNFO23

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO23 { get; set; }
Public Property LNFO23 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO23 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO23 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO24 Property

IRD

Saa7119LNFO24 Property

LNFO24

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO24 { get; set; }
Public Property LNFO24 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO24 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO24 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO3 Property

IRD

Saa7119LNFO3 Property

LNFO3

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO3 { get; set; }
Public Property LNFO3 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO3 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO3 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO4 Property

IRD

Saa7119LNFO4 Property

LNFO4

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO4 { get; set; }
Public Property LNFO4 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO4 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO4 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO5 Property

IRD

Saa7119LNFO5 Property

LNFO5

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO5 { get; set; }
Public Property LNFO5 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO5 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO5 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO6 Property

IRD

Saa7119LNFO6 Property

LNFO6

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO6 { get; set; }
Public Property LNFO6 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO6 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO6 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO7 Property

IRD

Saa7119LNFO7 Property

LNFO7

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO7 { get; set; }
Public Property LNFO7 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO7 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO7 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO8 Property

IRD

Saa7119LNFO8 Property

LNFO8

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO8 { get; set; }
Public Property LNFO8 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO8 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO8 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LNFO9 Property

IRD

Saa7119LNFO9 Property

LNFO9

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO9 { get; set; }
Public Property LNFO9 As Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
    Get
    Set
public:
property Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 LNFO9 {
    Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 get ();
    void set (Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 value);
}
member LNFO9 : Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 with get, set

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LumaPeakingFilterEnable Property

IRD

Saa7119LumaPeakingFilterEnable Property

Luma peaking filter enable

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte LumaPeakingFilterEnable { get; set; }
Public Property LumaPeakingFilterEnable As Byte
    Get
    Set
public:
property unsigned char LumaPeakingFilterEnable {
    unsigned char get ();
    void set (unsigned char value);
}
member LumaPeakingFilterEnable : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LuminanceBrightnessControlComponentPart Property

IRD

Saa7119LuminanceBrightnessControlComponentPart Property

Luminance brightness control component part

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLUMINANCEBRIGHTNLDECODERPART0 LuminanceBrightnessControlComponentPart { get; set; }
Public Property LuminanceBrightnessControlComponentPart As Saa7119TYPIDLUMINANCEBRIGHTNLDECODERPART0
    Get
    Set
public:
property Saa7119TYPIDLUMINANCEBRIGHTNLDECODERPART0 LuminanceBrightnessControlComponentPart {
    Saa7119TYPIDLUMINANCEBRIGHTNLDECODERPART0 get ();
    void set (Saa7119TYPIDLUMINANCEBRIGHTNLDECODERPART0 value);
}
member LuminanceBrightnessControlComponentPart : Saa7119TYPIDLUMINANCEBRIGHTNLDECODERPART0 with get, set

Property Value

Type: Saa7119TYPIDLUMINANCEBRIGHTNLDECODERPART0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LuminanceBrightnessControlDecoderPart Property

IRD

Saa7119LuminanceBrightnessControlDecoderPart Property

Luminance brightness control: decoder part

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLUMINANCEBRIGHTNLDECODERPART0 LuminanceBrightnessControlDecoderPart { get; set; }
Public Property LuminanceBrightnessControlDecoderPart As Saa7119TYPIDLUMINANCEBRIGHTNLDECODERPART0
    Get
    Set
public:
property Saa7119TYPIDLUMINANCEBRIGHTNLDECODERPART0 LuminanceBrightnessControlDecoderPart {
    Saa7119TYPIDLUMINANCEBRIGHTNLDECODERPART0 get ();
    void set (Saa7119TYPIDLUMINANCEBRIGHTNLDECODERPART0 value);
}
member LuminanceBrightnessControlDecoderPart : Saa7119TYPIDLUMINANCEBRIGHTNLDECODERPART0 with get, set

Property Value

Type: Saa7119TYPIDLUMINANCEBRIGHTNLDECODERPART0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LuminanceContrastControlComponentPartNegInverse Property

IRD

Saa7119LuminanceContrastControlComponentPartNegInverse Property

Luminance contrast control component part (neg=inverse)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLUMINANCECONTRASCOMPONENTPART0 LuminanceContrastControlComponentPartNegInverse { get; set; }
Public Property LuminanceContrastControlComponentPartNegInverse As Saa7119TYPIDLUMINANCECONTRASCOMPONENTPART0
    Get
    Set
public:
property Saa7119TYPIDLUMINANCECONTRASCOMPONENTPART0 LuminanceContrastControlComponentPartNegInverse {
    Saa7119TYPIDLUMINANCECONTRASCOMPONENTPART0 get ();
    void set (Saa7119TYPIDLUMINANCECONTRASCOMPONENTPART0 value);
}
member LuminanceContrastControlComponentPartNegInverse : Saa7119TYPIDLUMINANCECONTRASCOMPONENTPART0 with get, set

Property Value

Type: Saa7119TYPIDLUMINANCECONTRASCOMPONENTPART0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LuminanceContrastControlDecoderPartNegInverse Property

IRD

Saa7119LuminanceContrastControlDecoderPartNegInverse Property

Luminance contrast control: Decoder part (neg=inverse)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLUMINANCECONTRASLDECODERPART0 LuminanceContrastControlDecoderPartNegInverse { get; set; }
Public Property LuminanceContrastControlDecoderPartNegInverse As Saa7119TYPIDLUMINANCECONTRASLDECODERPART0
    Get
    Set
public:
property Saa7119TYPIDLUMINANCECONTRASLDECODERPART0 LuminanceContrastControlDecoderPartNegInverse {
    Saa7119TYPIDLUMINANCECONTRASLDECODERPART0 get ();
    void set (Saa7119TYPIDLUMINANCECONTRASLDECODERPART0 value);
}
member LuminanceContrastControlDecoderPartNegInverse : Saa7119TYPIDLUMINANCECONTRASLDECODERPART0 with get, set

Property Value

Type: Saa7119TYPIDLUMINANCECONTRASLDECODERPART0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.LuminanceDelayCompensation Property

IRD

Saa7119LuminanceDelayCompensation Property

Luminance delay compensation

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LuminanceDelayCompensation { get; set; }
Public Property LuminanceDelayCompensation As SByte
    Get
    Set
public:
property signed char LuminanceDelayCompensation {
    signed char get ();
    void set (signed char value);
}
member LuminanceDelayCompensation : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.MacrovisionCopyProtectionEnable Property

IRD

Saa7119MacrovisionCopyProtectionEnable Property

Macrovision copy-protection enable

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDANALOGINPUTCONTROL23 MacrovisionCopyProtectionEnable { get; set; }
Public Property MacrovisionCopyProtectionEnable As Saa7119TYPIDANALOGINPUTCONTROL23
    Get
    Set
public:
property Saa7119TYPIDANALOGINPUTCONTROL23 MacrovisionCopyProtectionEnable {
    Saa7119TYPIDANALOGINPUTCONTROL23 get ();
    void set (Saa7119TYPIDANALOGINPUTCONTROL23 value);
}
member MacrovisionCopyProtectionEnable : Saa7119TYPIDANALOGINPUTCONTROL23 with get, set

Property Value

Type: Saa7119TYPIDANALOGINPUTCONTROL23
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.MacrovisionEncodedColourStripeBurstDetected Property

IRD

Saa7119MacrovisionEncodedColourStripeBurstDetected Property

Macrovision encoded colour stripe burst detected

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDNotActiveActive MacrovisionEncodedColourStripeBurstDetected { get; }
Public ReadOnly Property MacrovisionEncodedColourStripeBurstDetected As Saa7119IDNotActiveActive
    Get
public:
property Saa7119IDNotActiveActive MacrovisionEncodedColourStripeBurstDetected {
    Saa7119IDNotActiveActive get ();
}
member MacrovisionEncodedColourStripeBurstDetected : Saa7119IDNotActiveActive with get

Property Value

Type: Saa7119IDNotActiveActive
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.MacrovisionEncodedColourStripeBurstType34LineVersionDetected Property

IRD

Saa7119MacrovisionEncodedColourStripeBurstType34LineVersionDetected Property

Macrovision encoded colour stripe burst type 3 (4 line version) detected

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDNotActiveActive MacrovisionEncodedColourStripeBurstType34LineVersionDetected { get; }
Public ReadOnly Property MacrovisionEncodedColourStripeBurstType34LineVersionDetected As Saa7119IDNotActiveActive
    Get
public:
property Saa7119IDNotActiveActive MacrovisionEncodedColourStripeBurstType34LineVersionDetected {
    Saa7119IDNotActiveActive get ();
}
member MacrovisionEncodedColourStripeBurstType34LineVersionDetected : Saa7119IDNotActiveActive with get

Property Value

Type: Saa7119IDNotActiveActive
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.MaximumVerticalNoiseReduction Property

IRD

Saa7119MaximumVerticalNoiseReduction Property

Maximum vertical noise reduction

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION2 MaximumVerticalNoiseReduction { get; set; }
Public Property MaximumVerticalNoiseReduction As Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION2
    Get
    Set
public:
property Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION2 MaximumVerticalNoiseReduction {
    Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION2 get ();
    void set (Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION2 value);
}
member MaximumVerticalNoiseReduction : Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION2 with get, set

Property Value

Type: Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.MedianFilterGain Property

IRD

Saa7119MedianFilterGain Property

Median filter gain

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL11 MedianFilterGain { get; set; }
Public Property MedianFilterGain As Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL11
    Get
    Set
public:
property Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL11 MedianFilterGain {
    Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL11 get ();
    void set (Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL11 value);
}
member MedianFilterGain : Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL11 with get, set

Property Value

Type: Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL11
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.MixOfXPORTInputDataAndDecoderInputData Property

IRD

Saa7119MixOfXPORTInputDataAndDecoderInputData Property

Mix of XPORT input data and decoder input data

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDXPORTIOENABLEKPHASECONTROL3 MixOfXPORTInputDataAndDecoderInputData { get; set; }
Public Property MixOfXPORTInputDataAndDecoderInputData As Saa7119TYPIDXPORTIOENABLEKPHASECONTROL3
    Get
    Set
public:
property Saa7119TYPIDXPORTIOENABLEKPHASECONTROL3 MixOfXPORTInputDataAndDecoderInputData {
    Saa7119TYPIDXPORTIOENABLEKPHASECONTROL3 get ();
    void set (Saa7119TYPIDXPORTIOENABLEKPHASECONTROL3 value);
}
member MixOfXPORTInputDataAndDecoderInputData : Saa7119TYPIDXPORTIOENABLEKPHASECONTROL3 with get, set

Property Value

Type: Saa7119TYPIDXPORTIOENABLEKPHASECONTROL3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ModeSelection Property

IRD

Saa7119ModeSelection Property

Mode selection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDANALOGINPUTCONTROL10 ModeSelection { get; set; }
Public Property ModeSelection As Saa7119TYPIDANALOGINPUTCONTROL10
    Get
    Set
public:
property Saa7119TYPIDANALOGINPUTCONTROL10 ModeSelection {
    Saa7119TYPIDANALOGINPUTCONTROL10 get ();
    void set (Saa7119TYPIDANALOGINPUTCONTROL10 value);
}
member ModeSelection : Saa7119TYPIDANALOGINPUTCONTROL10 with get, set

Property Value

Type: Saa7119TYPIDANALOGINPUTCONTROL10
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.MSTTB Property

IRD

Saa7119MSTTB Property

MSTTB

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable MSTTB { get; set; }
Public Property MSTTB As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable MSTTB {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member MSTTB : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.OddFieldsBeingUpdated Property

IRD

Saa7119OddFieldsBeingUpdated Property

Odd fields: Being updated

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OddFieldsBeingUpdated { get; }
Public ReadOnly Property OddFieldsBeingUpdated As Byte
    Get
public:
property unsigned char OddFieldsBeingUpdated {
    unsigned char get ();
}
member OddFieldsBeingUpdated : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.OddFieldsDataErroneous Property

IRD

Saa7119OddFieldsDataErroneous Property

Odd fields: Data erroneous

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OddFieldsDataErroneous { get; }
Public ReadOnly Property OddFieldsDataErroneous As Byte
    Get
public:
property unsigned char OddFieldsDataErroneous {
    unsigned char get ();
}
member OddFieldsDataErroneous : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.OutputClockPhaseControl Property

IRD

Saa7119OutputClockPhaseControl Property

Output clock phase control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDXPORTIOENABLEKPHASECONTROL4 OutputClockPhaseControl { get; set; }
Public Property OutputClockPhaseControl As Saa7119TYPIDXPORTIOENABLEKPHASECONTROL4
    Get
    Set
public:
property Saa7119TYPIDXPORTIOENABLEKPHASECONTROL4 OutputClockPhaseControl {
    Saa7119TYPIDXPORTIOENABLEKPHASECONTROL4 get ();
    void set (Saa7119TYPIDXPORTIOENABLEKPHASECONTROL4 value);
}
member OutputClockPhaseControl : Saa7119TYPIDXPORTIOENABLEKPHASECONTROL4 with get, set

Property Value

Type: Saa7119TYPIDXPORTIOENABLEKPHASECONTROL4
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.OutputDivider Property

IRD

Saa7119OutputDivider Property

Output Divider

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputDivider { get; set; }
Public Property OutputDivider As Byte
    Get
    Set
public:
property unsigned char OutputDivider {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputDivider : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.OverlayMode Property

IRD

Saa7119OverlayMode Property

Overlay mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDOVERLAYCONTROL0 OverlayMode { get; set; }
Public Property OverlayMode As Saa7119TYPIDOVERLAYCONTROL0
    Get
    Set
public:
property Saa7119TYPIDOVERLAYCONTROL0 OverlayMode {
    Saa7119TYPIDOVERLAYCONTROL0 get ();
    void set (Saa7119TYPIDOVERLAYCONTROL0 value);
}
member OverlayMode : Saa7119TYPIDOVERLAYCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDOVERLAYCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.PALNTSCColorKillerLevelControl Property

IRD

Saa7119PALNTSCColorKillerLevelControl Property

PAL/NTSC Color Killer Level Control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDCOLORKILLERLEVELCONTROL0 PALNTSCColorKillerLevelControl { get; set; }
Public Property PALNTSCColorKillerLevelControl As Saa7119TYPIDCOLORKILLERLEVELCONTROL0
    Get
    Set
public:
property Saa7119TYPIDCOLORKILLERLEVELCONTROL0 PALNTSCColorKillerLevelControl {
    Saa7119TYPIDCOLORKILLERLEVELCONTROL0 get ();
    void set (Saa7119TYPIDCOLORKILLERLEVELCONTROL0 value);
}
member PALNTSCColorKillerLevelControl : Saa7119TYPIDCOLORKILLERLEVELCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDCOLORKILLERLEVELCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.PanelMode Property

IRD

Saa7119PanelMode Property

Panel Mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDPANORAMAANDKEYSTONING1 PanelMode { get; set; }
Public Property PanelMode As Saa7119TYPIDPANORAMAANDKEYSTONING1
    Get
    Set
public:
property Saa7119TYPIDPANORAMAANDKEYSTONING1 PanelMode {
    Saa7119TYPIDPANORAMAANDKEYSTONING1 get ();
    void set (Saa7119TYPIDPANORAMAANDKEYSTONING1 value);
}
member PanelMode : Saa7119TYPIDPANORAMAANDKEYSTONING1 with get, set

Property Value

Type: Saa7119TYPIDPANORAMAANDKEYSTONING1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.PanoramaMode Property

IRD

Saa7119PanoramaMode Property

Panorama Mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDPANORAMAANDKEYSTONING0 PanoramaMode { get; set; }
Public Property PanoramaMode As Saa7119TYPIDPANORAMAANDKEYSTONING0
    Get
    Set
public:
property Saa7119TYPIDPANORAMAANDKEYSTONING0 PanoramaMode {
    Saa7119TYPIDPANORAMAANDKEYSTONING0 get ();
    void set (Saa7119TYPIDPANORAMAANDKEYSTONING0 value);
}
member PanoramaMode : Saa7119TYPIDPANORAMAANDKEYSTONING0 with get, set

Property Value

Type: Saa7119TYPIDPANORAMAANDKEYSTONING0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ParityBitGenerationHammingForITUCodeSequenceOnIPort Property

IRD

Saa7119ParityBitGenerationHammingForITUCodeSequenceOnIPort Property

Parity Bit Generation (Hamming) for ITU code sequence on I-port

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS2 ParityBitGenerationHammingForITUCodeSequenceOnIPort { get; set; }
Public Property ParityBitGenerationHammingForITUCodeSequenceOnIPort As Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS2
    Get
    Set
public:
property Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS2 ParityBitGenerationHammingForITUCodeSequenceOnIPort {
    Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS2 get ();
    void set (Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS2 value);
}
member ParityBitGenerationHammingForITUCodeSequenceOnIPort : Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS2 with get, set

Property Value

Type: Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.PFSL Property

IRD

Saa7119PFSL Property

PFSL

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDHORIZONTALINCREMENTDELAY1 PFSL { get; set; }
Public Property PFSL As Saa7119TYPIDHORIZONTALINCREMENTDELAY1
    Get
    Set
public:
property Saa7119TYPIDHORIZONTALINCREMENTDELAY1 PFSL {
    Saa7119TYPIDHORIZONTALINCREMENTDELAY1 get ();
    void set (Saa7119TYPIDHORIZONTALINCREMENTDELAY1 value);
}
member PFSL : Saa7119TYPIDHORIZONTALINCREMENTDELAY1 with get, set

Property Value

Type: Saa7119TYPIDHORIZONTALINCREMENTDELAY1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.PLLActiveClock1MHz Property

IRD

Saa7119PLLActiveClock1MHz Property

PLL active (clock > 1MHz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDPLL1DIGANNASTATUS0 PLLActiveClock1MHz { get; set; }
Public Property PLLActiveClock1MHz As Saa7119TYPIDPLL1DIGANNASTATUS0
    Get
    Set
public:
property Saa7119TYPIDPLL1DIGANNASTATUS0 PLLActiveClock1MHz {
    Saa7119TYPIDPLL1DIGANNASTATUS0 get ();
    void set (Saa7119TYPIDPLL1DIGANNASTATUS0 value);
}
member PLLActiveClock1MHz : Saa7119TYPIDPLL1DIGANNASTATUS0 with get, set

Property Value

Type: Saa7119TYPIDPLL1DIGANNASTATUS0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.PLLLocked Property

IRD

Saa7119PLLLocked Property

PLL locked

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDPLL1DIGANNASTATUS1 PLLLocked { get; set; }
Public Property PLLLocked As Saa7119TYPIDPLL1DIGANNASTATUS1
    Get
    Set
public:
property Saa7119TYPIDPLL1DIGANNASTATUS1 PLLLocked {
    Saa7119TYPIDPLL1DIGANNASTATUS1 get ();
    void set (Saa7119TYPIDPLL1DIGANNASTATUS1 value);
}
member PLLLocked : Saa7119TYPIDPLL1DIGANNASTATUS1 with get, set

Property Value

Type: Saa7119TYPIDPLL1DIGANNASTATUS1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.PLLParameterI Property

IRD

Saa7119PLLParameterI Property

PLL parameter I

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PLLParameterI { get; set; }
Public Property PLLParameterI As Byte
    Get
    Set
public:
property unsigned char PLLParameterI {
    unsigned char get ();
    void set (unsigned char value);
}
member PLLParameterI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.PLLParameterP Property

IRD

Saa7119PLLParameterP Property

PLL parameter P

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PLLParameterP { get; set; }
Public Property PLLParameterP As Byte
    Get
    Set
public:
property unsigned char PLLParameterP {
    unsigned char get ();
    void set (unsigned char value);
}
member PLLParameterP : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.PLLParameterR Property

IRD

Saa7119PLLParameterR Property

PLL parameter R

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PLLParameterR { get; set; }
Public Property PLLParameterR As Byte
    Get
    Set
public:
property unsigned char PLLParameterR {
    unsigned char get ();
    void set (unsigned char value);
}
member PLLParameterR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.PolarityOfRTS0OutputSignal Property

IRD

Saa7119PolarityOfRTS0OutputSignal Property

Polarity of RTS0 output signal

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDMODEDELAYCONTROL1 PolarityOfRTS0OutputSignal { get; set; }
Public Property PolarityOfRTS0OutputSignal As Saa7119TYPIDMODEDELAYCONTROL1
    Get
    Set
public:
property Saa7119TYPIDMODEDELAYCONTROL1 PolarityOfRTS0OutputSignal {
    Saa7119TYPIDMODEDELAYCONTROL1 get ();
    void set (Saa7119TYPIDMODEDELAYCONTROL1 value);
}
member PolarityOfRTS0OutputSignal : Saa7119TYPIDMODEDELAYCONTROL1 with get, set

Property Value

Type: Saa7119TYPIDMODEDELAYCONTROL1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.PolarityOfRTS1OutputSignal Property

IRD

Saa7119PolarityOfRTS1OutputSignal Property

Polarity of RTS1 output signal

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDMODEDELAYCONTROL1 PolarityOfRTS1OutputSignal { get; set; }
Public Property PolarityOfRTS1OutputSignal As Saa7119TYPIDMODEDELAYCONTROL1
    Get
    Set
public:
property Saa7119TYPIDMODEDELAYCONTROL1 PolarityOfRTS1OutputSignal {
    Saa7119TYPIDMODEDELAYCONTROL1 get ();
    void set (Saa7119TYPIDMODEDELAYCONTROL1 value);
}
member PolarityOfRTS1OutputSignal : Saa7119TYPIDMODEDELAYCONTROL1 with get, set

Property Value

Type: Saa7119TYPIDMODEDELAYCONTROL1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.PortAndScalerBackendClockSelection Property

IRD

Saa7119PortAndScalerBackendClockSelection Property

Port and scaler backend clock selection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PortAndScalerBackendClockSelection { get; set; }
Public Property PortAndScalerBackendClockSelection As Byte
    Get
    Set
public:
property unsigned char PortAndScalerBackendClockSelection {
    unsigned char get ();
    void set (unsigned char value);
}
member PortAndScalerBackendClockSelection : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ProcessingDelayInNonCombFilterMode Property

IRD

Saa7119ProcessingDelayInNonCombFilterMode Property

Processing delay in non comb filter mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLUMINANCECONTROL2 ProcessingDelayInNonCombFilterMode { get; set; }
Public Property ProcessingDelayInNonCombFilterMode As Saa7119TYPIDLUMINANCECONTROL2
    Get
    Set
public:
property Saa7119TYPIDLUMINANCECONTROL2 ProcessingDelayInNonCombFilterMode {
    Saa7119TYPIDLUMINANCECONTROL2 get ();
    void set (Saa7119TYPIDLUMINANCECONTROL2 value);
}
member ProcessingDelayInNonCombFilterMode : Saa7119TYPIDLUMINANCECONTROL2 with get, set

Property Value

Type: Saa7119TYPIDLUMINANCECONTROL2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ProgramableDelay Property

IRD

Saa7119ProgramableDelay Property

Programable delay

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte ProgramableDelay { get; set; }
Public Property ProgramableDelay As SByte
    Get
    Set
public:
property signed char ProgramableDelay {
    signed char get ();
    void set (signed char value);
}
member ProgramableDelay : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ProgramableDelay14Pixel Property

IRD

Saa7119ProgramableDelay14Pixel Property

Programable delay (1/4 pixel)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ProgramableDelay14Pixel { get; set; }
Public Property ProgramableDelay14Pixel As Double
    Get
    Set
public:
property double ProgramableDelay14Pixel {
    double get ();
    void set (double value);
}
member ProgramableDelay14Pixel : float with get, set

Property Value

Type: Double
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ProgrammableComponentDelayAgainstCOMBDECProcessing Property

IRD

Saa7119ProgrammableComponentDelayAgainstCOMBDECProcessing Property

Programmable component delay against COMBDEC processing (unit: CLK1 delays)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ProgrammableComponentDelayAgainstCOMBDECProcessing { get; set; }
Public Property ProgrammableComponentDelayAgainstCOMBDECProcessing As Double
    Get
    Set
public:
property double ProgrammableComponentDelayAgainstCOMBDECProcessing {
    double get ();
    void set (double value);
}
member ProgrammableComponentDelayAgainstCOMBDECProcessing : float with get, set

Property Value

Type: Double
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RawDataGainControl Property

IRD

Saa7119RawDataGainControl Property

Raw data gain control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDRAWDATAGAINCONTROL0 RawDataGainControl { get; set; }
Public Property RawDataGainControl As Saa7119TYPIDRAWDATAGAINCONTROL0
    Get
    Set
public:
property Saa7119TYPIDRAWDATAGAINCONTROL0 RawDataGainControl {
    Saa7119TYPIDRAWDATAGAINCONTROL0 get ();
    void set (Saa7119TYPIDRAWDATAGAINCONTROL0 value);
}
member RawDataGainControl : Saa7119TYPIDRAWDATAGAINCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDRAWDATAGAINCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RawDataOffsetControl Property

IRD

Saa7119RawDataOffsetControl Property

Raw data offset control (unit: LSB)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RawDataOffsetControl { get; set; }
Public Property RawDataOffsetControl As SByte
    Get
    Set
public:
property signed char RawDataOffsetControl {
    signed char get ();
    void set (signed char value);
}
member RawDataOffsetControl : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ReadyForCapture Property

IRD

Saa7119ReadyForCapture Property

Ready for capture

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDNotActiveActive ReadyForCapture { get; }
Public ReadOnly Property ReadyForCapture As Saa7119IDNotActiveActive
    Get
public:
property Saa7119IDNotActiveActive ReadyForCapture {
    Saa7119IDNotActiveActive get ();
}
member ReadyForCapture : Saa7119IDNotActiveActive with get

Property Value

Type: Saa7119IDNotActiveActive
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetA17SegmentCurvesForBCSInTheYUVOrColorManipulationsInTheRGBDomain Property

IRD

Saa7119RegSetA17SegmentCurvesForBCSInTheYUVOrColorManipulationsInTheRGBDomain Property

RegSet A: 17 segment curves for B,C,S in the YUV or color manipulations in the RGB domain

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL1 RegSetA17SegmentCurvesForBCSInTheYUVOrColorManipulationsInTheRGBDomain { get; set; }
Public Property RegSetA17SegmentCurvesForBCSInTheYUVOrColorManipulationsInTheRGBDomain As Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL1
    Get
    Set
public:
property Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL1 RegSetA17SegmentCurvesForBCSInTheYUVOrColorManipulationsInTheRGBDomain {
    Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL1 get ();
    void set (Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL1 value);
}
member RegSetA17SegmentCurvesForBCSInTheYUVOrColorManipulationsInTheRGBDomain : Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL1 with get, set

Property Value

Type: Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAAccumulationLength Property

IRD

Saa7119RegSetAAccumulationLength Property

RegSet A: Accumulation length

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetAAccumulationLength { get; set; }
Public Property RegSetAAccumulationLength As Byte
    Get
    Set
public:
property unsigned char RegSetAAccumulationLength {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetAAccumulationLength : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAChromaIsProvidedRegSetA Property

IRD

Saa7119RegSetAChromaIsProvidedRegSetA Property

RegSet A: Chroma is provided(Reg. Set: A)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION1 RegSetAChromaIsProvidedRegSetA { get; set; }
Public Property RegSetAChromaIsProvidedRegSetA As Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION1
    Get
    Set
public:
property Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION1 RegSetAChromaIsProvidedRegSetA {
    Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION1 get ();
    void set (Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION1 value);
}
member RegSetAChromaIsProvidedRegSetA : Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION1 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAChrominance Property

IRD

Saa7119RegSetAChrominance Property

RegSet A: Chrominance

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL3 RegSetAChrominance { get; set; }
Public Property RegSetAChrominance As Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL3
    Get
    Set
public:
property Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL3 RegSetAChrominance {
    Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL3 get ();
    void set (Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL3 value);
}
member RegSetAChrominance : Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL3 with get, set

Property Value

Type: Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAChrominanceImprovementChangeOfCoringLevel Property

IRD

Saa7119RegSetAChrominanceImprovementChangeOfCoringLevel Property

RegSet A: Chrominance Improvement: Change of coring level

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetAChrominanceImprovementChangeOfCoringLevel { get; set; }
Public Property RegSetAChrominanceImprovementChangeOfCoringLevel As Byte
    Get
    Set
public:
property unsigned char RegSetAChrominanceImprovementChangeOfCoringLevel {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetAChrominanceImprovementChangeOfCoringLevel : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAChrominanceImprovementSelectHighPassFilterForPeakComponent Property

IRD

Saa7119RegSetAChrominanceImprovementSelectHighPassFilterForPeakComponent Property

RegSet A: Chrominance Improvement: Select High Pass Filter For Peak Component

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetAChrominanceImprovementSelectHighPassFilterForPeakComponent { get; set; }
Public Property RegSetAChrominanceImprovementSelectHighPassFilterForPeakComponent As Byte
    Get
    Set
public:
property unsigned char RegSetAChrominanceImprovementSelectHighPassFilterForPeakComponent {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetAChrominanceImprovementSelectHighPassFilterForPeakComponent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAChrominanceImprovementSignalImprovementMode Property

IRD

Saa7119RegSetAChrominanceImprovementSignalImprovementMode Property

RegSet A: Chrominance Improvement: Signal Improvement Mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL3 RegSetAChrominanceImprovementSignalImprovementMode { get; set; }
Public Property RegSetAChrominanceImprovementSignalImprovementMode As Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL3
    Get
    Set
public:
property Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL3 RegSetAChrominanceImprovementSignalImprovementMode {
    Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL3 get ();
    void set (Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL3 value);
}
member RegSetAChrominanceImprovementSignalImprovementMode : Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL3 with get, set

Property Value

Type: Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAChrominanceImprovementWeightingOfPeakComponent Property

IRD

Saa7119RegSetAChrominanceImprovementWeightingOfPeakComponent Property

RegSet A: Chrominance Improvement: Weighting of Peak Component

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL0 RegSetAChrominanceImprovementWeightingOfPeakComponent { get; set; }
Public Property RegSetAChrominanceImprovementWeightingOfPeakComponent As Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL0
    Get
    Set
public:
property Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL0 RegSetAChrominanceImprovementWeightingOfPeakComponent {
    Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL0 get ();
    void set (Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL0 value);
}
member RegSetAChrominanceImprovementWeightingOfPeakComponent : Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAChrominanceSaturationControl Property

IRD

Saa7119RegSetAChrominanceSaturationControl Property

RegSet A: Chrominance saturation control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 RegSetAChrominanceSaturationControl { get; set; }
Public Property RegSetAChrominanceSaturationControl As Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0
    Get
    Set
public:
property Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 RegSetAChrominanceSaturationControl {
    Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 get ();
    void set (Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 value);
}
member RegSetAChrominanceSaturationControl : Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetADataQualified Property

IRD

Saa7119RegSetADataQualified Property

RegSet A: Data qualified:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS1 RegSetADataQualified { get; set; }
Public Property RegSetADataQualified As Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS1
    Get
    Set
public:
property Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS1 RegSetADataQualified {
    Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS1 get ();
    void set (Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS1 value);
}
member RegSetADataQualified : Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS1 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetADitherNoiseShaper Property

IRD

Saa7119RegSetADitherNoiseShaper Property

RegSet A: Dither (Noise Shaper)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL3 RegSetADitherNoiseShaper { get; set; }
Public Property RegSetADitherNoiseShaper As Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL3
    Get
    Set
public:
property Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL3 RegSetADitherNoiseShaper {
    Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL3 get ();
    void set (Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL3 value);
}
member RegSetADitherNoiseShaper : Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL3 with get, set

Property Value

Type: Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetADownscale Property

IRD

Saa7119RegSetADownscale Property

RegSet A: Downscale

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAHORIZONTALPRESCALING0 RegSetADownscale { get; set; }
Public Property RegSetADownscale As Saa7119TYPIDTAHORIZONTALPRESCALING0
    Get
    Set
public:
property Saa7119TYPIDTAHORIZONTALPRESCALING0 RegSetADownscale {
    Saa7119TYPIDTAHORIZONTALPRESCALING0 get ();
    void set (Saa7119TYPIDTAHORIZONTALPRESCALING0 value);
}
member RegSetADownscale : Saa7119TYPIDTAHORIZONTALPRESCALING0 with get, set

Property Value

Type: Saa7119TYPIDTAHORIZONTALPRESCALING0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAEddiBypassEDBYP Property

IRD

Saa7119RegSetAEddiBypassEDBYP Property

RegSet A: Eddi_bypass (EDBYP)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable RegSetAEddiBypassEDBYP { get; set; }
Public Property RegSetAEddiBypassEDBYP As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable RegSetAEddiBypassEDBYP {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member RegSetAEddiBypassEDBYP : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAEddionEDON Property

IRD

Saa7119RegSetAEddionEDON Property

RegSet A: Eddion (EDON)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAEDGICONTROL3 RegSetAEddionEDON { get; set; }
Public Property RegSetAEddionEDON As Saa7119TYPIDTAEDGICONTROL3
    Get
    Set
public:
property Saa7119TYPIDTAEDGICONTROL3 RegSetAEddionEDON {
    Saa7119TYPIDTAEDGICONTROL3 get ();
    void set (Saa7119TYPIDTAEDGICONTROL3 value);
}
member RegSetAEddionEDON : Saa7119TYPIDTAEDGICONTROL3 with get, set

Property Value

Type: Saa7119TYPIDTAEDGICONTROL3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAEdgeOfXRHInputIsHorizontalReference Property

IRD

Saa7119RegSetAEdgeOfXRHInputIsHorizontalReference Property

RegSet A: Edge of XRH input is horizontal reference

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS2 RegSetAEdgeOfXRHInputIsHorizontalReference { get; set; }
Public Property RegSetAEdgeOfXRHInputIsHorizontalReference As Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS2
    Get
    Set
public:
property Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS2 RegSetAEdgeOfXRHInputIsHorizontalReference {
    Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS2 get ();
    void set (Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS2 value);
}
member RegSetAEdgeOfXRHInputIsHorizontalReference : Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS2 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAEdgeOfXRVInputAndDecoderV123IsVerticalReference Property

IRD

Saa7119RegSetAEdgeOfXRVInputAndDecoderV123IsVerticalReference Property

RegSet A: Edge of XRV input and decoder V123 is vertical reference:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS4 RegSetAEdgeOfXRVInputAndDecoderV123IsVerticalReference { get; set; }
Public Property RegSetAEdgeOfXRVInputAndDecoderV123IsVerticalReference As Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS4
    Get
    Set
public:
property Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS4 RegSetAEdgeOfXRVInputAndDecoderV123IsVerticalReference {
    Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS4 get ();
    void set (Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS4 value);
}
member RegSetAEdgeOfXRVInputAndDecoderV123IsVerticalReference : Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS4 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS4
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAEdgiScalingIncrementValue1X Property

IRD

Saa7119RegSetAEdgiScalingIncrementValue1X Property

RegSet A: Edgi scaling increment: Value=1/x

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort RegSetAEdgiScalingIncrementValue1X { get; set; }
Public Property RegSetAEdgiScalingIncrementValue1X As UShort
    Get
    Set
public:
property unsigned short RegSetAEdgiScalingIncrementValue1X {
    unsigned short get ();
    void set (unsigned short value);
}
member RegSetAEdgiScalingIncrementValue1X : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAEdgiScalingPhase00 Property

IRD

Saa7119RegSetAEdgiScalingPhase00 Property

RegSet A: Edgi Scaling phase: 00

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetAEdgiScalingPhase00 { get; set; }
Public Property RegSetAEdgiScalingPhase00 As Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetAEdgiScalingPhase00 {
    Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 get ();
    void set (Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 value);
}
member RegSetAEdgiScalingPhase00 : Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAEdgiScalingPhase01 Property

IRD

Saa7119RegSetAEdgiScalingPhase01 Property

RegSet A: Edgi Scaling phase: 01

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetAEdgiScalingPhase01 { get; set; }
Public Property RegSetAEdgiScalingPhase01 As Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetAEdgiScalingPhase01 {
    Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 get ();
    void set (Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 value);
}
member RegSetAEdgiScalingPhase01 : Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAEdgiScalingPhase10 Property

IRD

Saa7119RegSetAEdgiScalingPhase10 Property

RegSet A: Edgi Scaling phase: 10

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetAEdgiScalingPhase10 { get; set; }
Public Property RegSetAEdgiScalingPhase10 As Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetAEdgiScalingPhase10 {
    Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 get ();
    void set (Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 value);
}
member RegSetAEdgiScalingPhase10 : Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAEdgiScalingPhase11 Property

IRD

Saa7119RegSetAEdgiScalingPhase11 Property

RegSet A: Edgi Scaling phase: 11

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetAEdgiScalingPhase11 { get; set; }
Public Property RegSetAEdgiScalingPhase11 As Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetAEdgiScalingPhase11 {
    Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 get ();
    void set (Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 value);
}
member RegSetAEdgiScalingPhase11 : Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAEventHandlerTriggers Property

IRD

Saa7119RegSetAEventHandlerTriggers Property

RegSet A: Event handler triggers:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTATASKHANDLINGCONTROL0 RegSetAEventHandlerTriggers { get; set; }
Public Property RegSetAEventHandlerTriggers As Saa7119TYPIDTATASKHANDLINGCONTROL0
    Get
    Set
public:
property Saa7119TYPIDTATASKHANDLINGCONTROL0 RegSetAEventHandlerTriggers {
    Saa7119TYPIDTATASKHANDLINGCONTROL0 get ();
    void set (Saa7119TYPIDTATASKHANDLINGCONTROL0 value);
}
member RegSetAEventHandlerTriggers : Saa7119TYPIDTATASKHANDLINGCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDTATASKHANDLINGCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAFieldModeContinuousTaskMode Property

IRD

Saa7119RegSetAFieldModeContinuousTaskMode Property

RegSet A: Field mode (continuous task mode)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONH0 RegSetAFieldModeContinuousTaskMode { get; set; }
Public Property RegSetAFieldModeContinuousTaskMode As Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONH0
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONH0 RegSetAFieldModeContinuousTaskMode {
    Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONH0 get ();
    void set (Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONH0 value);
}
member RegSetAFieldModeContinuousTaskMode : Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONH0 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONH0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAFormat Property

IRD

Saa7119RegSetAFormat Property

RegSet A: Format

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION0 RegSetAFormat { get; set; }
Public Property RegSetAFormat As Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION0
    Get
    Set
public:
property Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION0 RegSetAFormat {
    Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION0 get ();
    void set (Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION0 value);
}
member RegSetAFormat : Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION0 with get, set

Property Value

Type: Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAHorizontalChrominancePhaseOffset Property

IRD

Saa7119RegSetAHorizontalChrominancePhaseOffset Property

RegSet A: Horizontal chrominance phase offset

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetAHorizontalChrominancePhaseOffset { get; set; }
Public Property RegSetAHorizontalChrominancePhaseOffset As Byte
    Get
    Set
public:
property unsigned char RegSetAHorizontalChrominancePhaseOffset {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetAHorizontalChrominancePhaseOffset : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAHorizontalChrominanceScalingIncrement Property

IRD

Saa7119RegSetAHorizontalChrominanceScalingIncrement Property

RegSet A: Horizontal chrominance scaling increment

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort RegSetAHorizontalChrominanceScalingIncrement { get; set; }
Public Property RegSetAHorizontalChrominanceScalingIncrement As UShort
    Get
    Set
public:
property unsigned short RegSetAHorizontalChrominanceScalingIncrement {
    unsigned short get ();
    void set (unsigned short value);
}
member RegSetAHorizontalChrominanceScalingIncrement : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAHorizontalInputAcquisitionWindowDefinitionInputWindowsLegth Property

IRD

Saa7119RegSetAHorizontalInputAcquisitionWindowDefinitionInputWindowsLegth Property

RegSet A: Horizontal input acquisition window definition input windows legth

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAHORIZONTALINPWINDOWLENGTHL0 RegSetAHorizontalInputAcquisitionWindowDefinitionInputWindowsLegth { get; set; }
Public Property RegSetAHorizontalInputAcquisitionWindowDefinitionInputWindowsLegth As Saa7119TYPIDTAHORIZONTALINPWINDOWLENGTHL0
    Get
    Set
public:
property Saa7119TYPIDTAHORIZONTALINPWINDOWLENGTHL0 RegSetAHorizontalInputAcquisitionWindowDefinitionInputWindowsLegth {
    Saa7119TYPIDTAHORIZONTALINPWINDOWLENGTHL0 get ();
    void set (Saa7119TYPIDTAHORIZONTALINPWINDOWLENGTHL0 value);
}
member RegSetAHorizontalInputAcquisitionWindowDefinitionInputWindowsLegth : Saa7119TYPIDTAHORIZONTALINPWINDOWLENGTHL0 with get, set

Property Value

Type: Saa7119TYPIDTAHORIZONTALINPWINDOWLENGTHL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAHorizontalInputAcquisitionWindowDefinitionOffset Property

IRD

Saa7119RegSetAHorizontalInputAcquisitionWindowDefinitionOffset Property

RegSet A: Horizontal input acquisition window definition offset

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAHORIZONTALINPINITIONOFFSETL0 RegSetAHorizontalInputAcquisitionWindowDefinitionOffset { get; set; }
Public Property RegSetAHorizontalInputAcquisitionWindowDefinitionOffset As Saa7119TYPIDTAHORIZONTALINPINITIONOFFSETL0
    Get
    Set
public:
property Saa7119TYPIDTAHORIZONTALINPINITIONOFFSETL0 RegSetAHorizontalInputAcquisitionWindowDefinitionOffset {
    Saa7119TYPIDTAHORIZONTALINPINITIONOFFSETL0 get ();
    void set (Saa7119TYPIDTAHORIZONTALINPINITIONOFFSETL0 value);
}
member RegSetAHorizontalInputAcquisitionWindowDefinitionOffset : Saa7119TYPIDTAHORIZONTALINPINITIONOFFSETL0 with get, set

Property Value

Type: Saa7119TYPIDTAHORIZONTALINPINITIONOFFSETL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAHorizontalLuminancePhaseOffset Property

IRD

Saa7119RegSetAHorizontalLuminancePhaseOffset Property

RegSet A: Horizontal luminance phase offset (unit: Pixel)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 RegSetAHorizontalLuminancePhaseOffset { get; set; }
Public Property RegSetAHorizontalLuminancePhaseOffset As Saa7119TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
    Get
    Set
public:
property Saa7119TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 RegSetAHorizontalLuminancePhaseOffset {
    Saa7119TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 get ();
    void set (Saa7119TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 value);
}
member RegSetAHorizontalLuminancePhaseOffset : Saa7119TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 with get, set

Property Value

Type: Saa7119TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAHorizontalLuminanceScalingIncrement1024X Property

IRD

Saa7119RegSetAHorizontalLuminanceScalingIncrement1024X Property

RegSet A: Horizontal luminance scaling increment 1024/x

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort RegSetAHorizontalLuminanceScalingIncrement1024X { get; set; }
Public Property RegSetAHorizontalLuminanceScalingIncrement1024X As UShort
    Get
    Set
public:
property unsigned short RegSetAHorizontalLuminanceScalingIncrement1024X {
    unsigned short get ();
    void set (unsigned short value);
}
member RegSetAHorizontalLuminanceScalingIncrement1024X : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAHorizontalOutputWindowLength Property

IRD

Saa7119RegSetAHorizontalOutputWindowLength Property

RegSet A: Horizontal output window length

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 RegSetAHorizontalOutputWindowLength { get; set; }
Public Property RegSetAHorizontalOutputWindowLength As Saa7119TYPIDTAHORIZONTALOUTWINDOWLENGTHL0
    Get
    Set
public:
property Saa7119TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 RegSetAHorizontalOutputWindowLength {
    Saa7119TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 get ();
    void set (Saa7119TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 value);
}
member RegSetAHorizontalOutputWindowLength : Saa7119TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 with get, set

Property Value

Type: Saa7119TYPIDTAHORIZONTALOUTWINDOWLENGTHL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAITU656 Property

IRD

Saa7119RegSetAITU656 Property

RegSet A: ITU 656

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION4 RegSetAITU656 { get; set; }
Public Property RegSetAITU656 As Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION4
    Get
    Set
public:
property Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION4 RegSetAITU656 {
    Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION4 get ();
    void set (Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION4 value);
}
member RegSetAITU656 : Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION4 with get, set

Property Value

Type: Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION4
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetALeadingLinesBefore1stYCBCRLineIsOutput Property

IRD

Saa7119RegSetALeadingLinesBefore1stYCBCRLineIsOutput Property

RegSet A: Leading lines before 1st Y + CB-CR line is output

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION1 RegSetALeadingLinesBefore1stYCBCRLineIsOutput { get; set; }
Public Property RegSetALeadingLinesBefore1stYCBCRLineIsOutput As Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION1
    Get
    Set
public:
property Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION1 RegSetALeadingLinesBefore1stYCBCRLineIsOutput {
    Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION1 get ();
    void set (Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION1 value);
}
member RegSetALeadingLinesBefore1stYCBCRLineIsOutput : Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION1 with get, set

Property Value

Type: Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetALinesOutput Property

IRD

Saa7119RegSetALinesOutput Property

RegSet A: Lines output

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION2 RegSetALinesOutput { get; set; }
Public Property RegSetALinesOutput As Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION2
    Get
    Set
public:
property Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION2 RegSetALinesOutput {
    Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION2 get ();
    void set (Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION2 value);
}
member RegSetALinesOutput : Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION2 with get, set

Property Value

Type: Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetALuminance Property

IRD

Saa7119RegSetALuminance Property

RegSet A: Luminance

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL2 RegSetALuminance { get; set; }
Public Property RegSetALuminance As Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL2
    Get
    Set
public:
property Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL2 RegSetALuminance {
    Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL2 get ();
    void set (Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL2 value);
}
member RegSetALuminance : Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL2 with get, set

Property Value

Type: Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetALuminanceBrightnessControl Property

IRD

Saa7119RegSetALuminanceBrightnessControl Property

RegSet A: Luminance brightness control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetALuminanceBrightnessControl { get; set; }
Public Property RegSetALuminanceBrightnessControl As Byte
    Get
    Set
public:
property unsigned char RegSetALuminanceBrightnessControl {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetALuminanceBrightnessControl : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetALuminanceContrastControl Property

IRD

Saa7119RegSetALuminanceContrastControl Property

RegSet A: Luminance contrast control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 RegSetALuminanceContrastControl { get; set; }
Public Property RegSetALuminanceContrastControl As Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0
    Get
    Set
public:
property Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 RegSetALuminanceContrastControl {
    Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 get ();
    void set (Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 value);
}
member RegSetALuminanceContrastControl : Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetALuminanceImprovementChangeOfCoringLevel Property

IRD

Saa7119RegSetALuminanceImprovementChangeOfCoringLevel Property

RegSet A: Luminance Improvement: Change of coring level

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetALuminanceImprovementChangeOfCoringLevel { get; set; }
Public Property RegSetALuminanceImprovementChangeOfCoringLevel As Byte
    Get
    Set
public:
property unsigned char RegSetALuminanceImprovementChangeOfCoringLevel {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetALuminanceImprovementChangeOfCoringLevel : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetALuminanceImprovementSelectHighPassFilterForPeakComponent Property

IRD

Saa7119RegSetALuminanceImprovementSelectHighPassFilterForPeakComponent Property

RegSet A: Luminance Improvement: Select High Pass Filter For Peak Component

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetALuminanceImprovementSelectHighPassFilterForPeakComponent { get; set; }
Public Property RegSetALuminanceImprovementSelectHighPassFilterForPeakComponent As Byte
    Get
    Set
public:
property unsigned char RegSetALuminanceImprovementSelectHighPassFilterForPeakComponent {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetALuminanceImprovementSelectHighPassFilterForPeakComponent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetALuminanceImprovementSignalImprovementMode Property

IRD

Saa7119RegSetALuminanceImprovementSignalImprovementMode Property

RegSet A: Luminance Improvement: Signal Improvement Mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL3 RegSetALuminanceImprovementSignalImprovementMode { get; set; }
Public Property RegSetALuminanceImprovementSignalImprovementMode As Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL3
    Get
    Set
public:
property Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL3 RegSetALuminanceImprovementSignalImprovementMode {
    Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL3 get ();
    void set (Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL3 value);
}
member RegSetALuminanceImprovementSignalImprovementMode : Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL3 with get, set

Property Value

Type: Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetALuminanceImprovementWeightingOfPeakComponent Property

IRD

Saa7119RegSetALuminanceImprovementWeightingOfPeakComponent Property

RegSet A: Luminance Improvement: Weighting of Peak Component

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL0 RegSetALuminanceImprovementWeightingOfPeakComponent { get; set; }
Public Property RegSetALuminanceImprovementWeightingOfPeakComponent As Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL0
    Get
    Set
public:
property Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL0 RegSetALuminanceImprovementWeightingOfPeakComponent {
    Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL0 get ();
    void set (Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL0 value);
}
member RegSetALuminanceImprovementWeightingOfPeakComponent : Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAMirroring Property

IRD

Saa7119RegSetAMirroring Property

RegSet A: Mirroring

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAEDGICONTROL1 RegSetAMirroring { get; set; }
Public Property RegSetAMirroring As Saa7119TYPIDTAEDGICONTROL1
    Get
    Set
public:
property Saa7119TYPIDTAEDGICONTROL1 RegSetAMirroring {
    Saa7119TYPIDTAEDGICONTROL1 get ();
    void set (Saa7119TYPIDTAEDGICONTROL1 value);
}
member RegSetAMirroring : Saa7119TYPIDTAEDGICONTROL1 with get, set

Property Value

Type: Saa7119TYPIDTAEDGICONTROL1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetANextTask Property

IRD

Saa7119RegSetANextTask Property

RegSet A: Next task:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTATASKHANDLINGCONTROL1 RegSetANextTask { get; set; }
Public Property RegSetANextTask As Saa7119TYPIDTATASKHANDLINGCONTROL1
    Get
    Set
public:
property Saa7119TYPIDTATASKHANDLINGCONTROL1 RegSetANextTask {
    Saa7119TYPIDTATASKHANDLINGCONTROL1 get ();
    void set (Saa7119TYPIDTATASKHANDLINGCONTROL1 value);
}
member RegSetANextTask : Saa7119TYPIDTATASKHANDLINGCONTROL1 with get, set

Property Value

Type: Saa7119TYPIDTATASKHANDLINGCONTROL1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAOutputFieldID Property

IRD

Saa7119RegSetAOutputFieldID Property

RegSet A: Output field ID

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTATASKHANDLINGCONTROL3 RegSetAOutputFieldID { get; set; }
Public Property RegSetAOutputFieldID As Saa7119TYPIDTATASKHANDLINGCONTROL3
    Get
    Set
public:
property Saa7119TYPIDTATASKHANDLINGCONTROL3 RegSetAOutputFieldID {
    Saa7119TYPIDTATASKHANDLINGCONTROL3 get ();
    void set (Saa7119TYPIDTATASKHANDLINGCONTROL3 value);
}
member RegSetAOutputFieldID : Saa7119TYPIDTATASKHANDLINGCONTROL3 with get, set

Property Value

Type: Saa7119TYPIDTATASKHANDLINGCONTROL3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAPrescalerOutputIsRenormalizedByGainFactor Property

IRD

Saa7119RegSetAPrescalerOutputIsRenormalizedByGainFactor Property

RegSet A: Prescaler output is renormalized by gain factor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL0 RegSetAPrescalerOutputIsRenormalizedByGainFactor { get; set; }
Public Property RegSetAPrescalerOutputIsRenormalizedByGainFactor As Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL0
    Get
    Set
public:
property Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL0 RegSetAPrescalerOutputIsRenormalizedByGainFactor {
    Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL0 get ();
    void set (Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL0 value);
}
member RegSetAPrescalerOutputIsRenormalizedByGainFactor : Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAReferenceEdgeForFieldDetection Property

IRD

Saa7119RegSetAReferenceEdgeForFieldDetection Property

RegSet A: Reference edge for field detection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS7 RegSetAReferenceEdgeForFieldDetection { get; set; }
Public Property RegSetAReferenceEdgeForFieldDetection As Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS7
    Get
    Set
public:
property Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS7 RegSetAReferenceEdgeForFieldDetection {
    Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS7 get ();
    void set (Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS7 value);
}
member RegSetAReferenceEdgeForFieldDetection : Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS7 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS7
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAReferenceSignals Property

IRD

Saa7119RegSetAReferenceSignals Property

RegSet A: Reference signals:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS3 RegSetAReferenceSignals { get; set; }
Public Property RegSetAReferenceSignals As Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS3
    Get
    Set
public:
property Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS3 RegSetAReferenceSignals {
    Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS3 get ();
    void set (Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS3 value);
}
member RegSetAReferenceSignals : Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS3 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetARemainingBlankingIntervals Property

IRD

Saa7119RegSetARemainingBlankingIntervals Property

RegSet A: Remaining blanking intervals

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION3 RegSetARemainingBlankingIntervals { get; set; }
Public Property RegSetARemainingBlankingIntervals As Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION3
    Get
    Set
public:
property Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION3 RegSetARemainingBlankingIntervals {
    Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION3 get ();
    void set (Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION3 value);
}
member RegSetARemainingBlankingIntervals : Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION3 with get, set

Property Value

Type: Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetARGBYUVMatrixToReconvertRGBToYUVAfterManipulationsInTheRGBDomainFollowedByTheNoiseShaper Property

IRD

Saa7119RegSetARGBYUVMatrixToReconvertRGBToYUVAfterManipulationsInTheRGBDomainFollowedByTheNoiseShaper Property

RegSet A: RGB -> YUV-Matrix, to reconvert RGB to YUV after manipulations in the RGB domain, followed by the Noise Shaper

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL2 RegSetARGBYUVMatrixToReconvertRGBToYUVAfterManipulationsInTheRGBDomainFollowedByTheNoiseShaper { get; set; }
Public Property RegSetARGBYUVMatrixToReconvertRGBToYUVAfterManipulationsInTheRGBDomainFollowedByTheNoiseShaper As Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL2
    Get
    Set
public:
property Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL2 RegSetARGBYUVMatrixToReconvertRGBToYUVAfterManipulationsInTheRGBDomainFollowedByTheNoiseShaper {
    Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL2 get ();
    void set (Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL2 value);
}
member RegSetARGBYUVMatrixToReconvertRGBToYUVAfterManipulationsInTheRGBDomainFollowedByTheNoiseShaper : Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL2 with get, set

Property Value

Type: Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetASamplingScheme Property

IRD

Saa7119RegSetASamplingScheme Property

RegSet A: Sampling scheme

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION0 RegSetASamplingScheme { get; set; }
Public Property RegSetASamplingScheme As Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION0
    Get
    Set
public:
property Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION0 RegSetASamplingScheme {
    Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION0 get ();
    void set (Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION0 value);
}
member RegSetASamplingScheme : Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION0 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetASAVEAVCodeBitD5VGate Property

IRD

Saa7119RegSetASAVEAVCodeBitD5VGate Property

RegSet A: SAV/EAV code bit D5 (V) gate:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION5 RegSetASAVEAVCodeBitD5VGate { get; set; }
Public Property RegSetASAVEAVCodeBitD5VGate As Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION5
    Get
    Set
public:
property Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION5 RegSetASAVEAVCodeBitD5VGate {
    Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION5 get ();
    void set (Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION5 value);
}
member RegSetASAVEAVCodeBitD5VGate : Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION5 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION5
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetASAVEAVCodeBitsD6AndD5FAndV Property

IRD

Saa7119RegSetASAVEAVCodeBitsD6AndD5FAndV Property

RegSet A: SAV/EAV code bits D6 and D5 (F and V):

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION4 RegSetASAVEAVCodeBitsD6AndD5FAndV { get; set; }
Public Property RegSetASAVEAVCodeBitsD6AndD5FAndV As Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION4
    Get
    Set
public:
property Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION4 RegSetASAVEAVCodeBitsD6AndD5FAndV {
    Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION4 get ();
    void set (Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION4 value);
}
member RegSetASAVEAVCodeBitsD6AndD5FAndV : Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION4 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION4
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAScalerInputFormatConfigSource Property

IRD

Saa7119RegSetAScalerInputFormatConfigSource Property

RegSet A: Scaler input format/config source:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION3 RegSetAScalerInputFormatConfigSource { get; set; }
Public Property RegSetAScalerInputFormatConfigSource As Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION3
    Get
    Set
public:
property Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION3 RegSetAScalerInputFormatConfigSource {
    Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION3 get ();
    void set (Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION3 value);
}
member RegSetAScalerInputFormatConfigSource : Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION3 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAScalerInputSource Property

IRD

Saa7119RegSetAScalerInputSource Property

RegSet A: Scaler input source:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION2 RegSetAScalerInputSource { get; set; }
Public Property RegSetAScalerInputSource As Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION2
    Get
    Set
public:
property Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION2 RegSetAScalerInputSource {
    Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION2 get ();
    void set (Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION2 value);
}
member RegSetAScalerInputSource : Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION2 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAScalerSAVEAVByte Property

IRD

Saa7119RegSetAScalerSAVEAVByte Property

RegSet A: Scaler SAV/EAV byte

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTATASKHANDLINGCONTROL4 RegSetAScalerSAVEAVByte { get; set; }
Public Property RegSetAScalerSAVEAVByte As Saa7119TYPIDTATASKHANDLINGCONTROL4
    Get
    Set
public:
property Saa7119TYPIDTATASKHANDLINGCONTROL4 RegSetAScalerSAVEAVByte {
    Saa7119TYPIDTATASKHANDLINGCONTROL4 get ();
    void set (Saa7119TYPIDTATASKHANDLINGCONTROL4 value);
}
member RegSetAScalerSAVEAVByte : Saa7119TYPIDTATASKHANDLINGCONTROL4 with get, set

Property Value

Type: Saa7119TYPIDTATASKHANDLINGCONTROL4
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetATaskHandlingControl Property

IRD

Saa7119RegSetATaskHandlingControl Property

RegSet A: Task handling control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTATASKHANDLINGCONTROL2 RegSetATaskHandlingControl { get; set; }
Public Property RegSetATaskHandlingControl As Saa7119TYPIDTATASKHANDLINGCONTROL2
    Get
    Set
public:
property Saa7119TYPIDTATASKHANDLINGCONTROL2 RegSetATaskHandlingControl {
    Saa7119TYPIDTATASKHANDLINGCONTROL2 get ();
    void set (Saa7119TYPIDTATASKHANDLINGCONTROL2 value);
}
member RegSetATaskHandlingControl : Saa7119TYPIDTATASKHANDLINGCONTROL2 with get, set

Property Value

Type: Saa7119TYPIDTATASKHANDLINGCONTROL2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAVerticalInputAcquisitionWindowDefinition Property

IRD

Saa7119RegSetAVerticalInputAcquisitionWindowDefinition Property

RegSet A: Vertical input acquisition window definition

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONL0 RegSetAVerticalInputAcquisitionWindowDefinition { get; set; }
Public Property RegSetAVerticalInputAcquisitionWindowDefinition As Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONL0
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONL0 RegSetAVerticalInputAcquisitionWindowDefinition {
    Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONL0 get ();
    void set (Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONL0 value);
}
member RegSetAVerticalInputAcquisitionWindowDefinition : Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONL0 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAVerticalInputAcquisitionWindowDefinitionOffset Property

IRD

Saa7119RegSetAVerticalInputAcquisitionWindowDefinitionOffset Property

RegSet A: Vertical input acquisition window definition offset

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALINPUTINITIONOFFSETL0 RegSetAVerticalInputAcquisitionWindowDefinitionOffset { get; set; }
Public Property RegSetAVerticalInputAcquisitionWindowDefinitionOffset As Saa7119TYPIDTAVERTICALINPUTINITIONOFFSETL0
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALINPUTINITIONOFFSETL0 RegSetAVerticalInputAcquisitionWindowDefinitionOffset {
    Saa7119TYPIDTAVERTICALINPUTINITIONOFFSETL0 get ();
    void set (Saa7119TYPIDTAVERTICALINPUTINITIONOFFSETL0 value);
}
member RegSetAVerticalInputAcquisitionWindowDefinitionOffset : Saa7119TYPIDTAVERTICALINPUTINITIONOFFSETL0 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALINPUTINITIONOFFSETL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAVerticalOutputWindowLength Property

IRD

Saa7119RegSetAVerticalOutputWindowLength Property

RegSet A: Vertical output window length

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 RegSetAVerticalOutputWindowLength { get; set; }
Public Property RegSetAVerticalOutputWindowLength As Saa7119TYPIDTAVERTICALOUTPUWINDOWLENGTHL0
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 RegSetAVerticalOutputWindowLength {
    Saa7119TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 get ();
    void set (Saa7119TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 value);
}
member RegSetAVerticalOutputWindowLength : Saa7119TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALOUTPUWINDOWLENGTHL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAVerticalScalingIncrementValue1X Property

IRD

Saa7119RegSetAVerticalScalingIncrementValue1X Property

RegSet A: Vertical scaling increment: Value=1/x

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort RegSetAVerticalScalingIncrementValue1X { get; set; }
Public Property RegSetAVerticalScalingIncrementValue1X As UShort
    Get
    Set
public:
property unsigned short RegSetAVerticalScalingIncrementValue1X {
    unsigned short get ();
    void set (unsigned short value);
}
member RegSetAVerticalScalingIncrementValue1X : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAVerticalScalingPerforms Property

IRD

Saa7119RegSetAVerticalScalingPerforms Property

RegSet A: Vertical scaling performs

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAEDGICONTROL0 RegSetAVerticalScalingPerforms { get; set; }
Public Property RegSetAVerticalScalingPerforms As Saa7119TYPIDTAEDGICONTROL0
    Get
    Set
public:
property Saa7119TYPIDTAEDGICONTROL0 RegSetAVerticalScalingPerforms {
    Saa7119TYPIDTAEDGICONTROL0 get ();
    void set (Saa7119TYPIDTAEDGICONTROL0 value);
}
member RegSetAVerticalScalingPerforms : Saa7119TYPIDTAEDGICONTROL0 with get, set

Property Value

Type: Saa7119TYPIDTAEDGICONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAVerticalScalingPhaseOffset00 Property

IRD

Saa7119RegSetAVerticalScalingPhaseOffset00 Property

RegSet A: Vertical Scaling phase offset 00

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetAVerticalScalingPhaseOffset00 { get; set; }
Public Property RegSetAVerticalScalingPhaseOffset00 As Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetAVerticalScalingPhaseOffset00 {
    Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 get ();
    void set (Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 value);
}
member RegSetAVerticalScalingPhaseOffset00 : Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAVerticalScalingPhaseOffset01 Property

IRD

Saa7119RegSetAVerticalScalingPhaseOffset01 Property

RegSet A: Vertical Scaling phase offset 01

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetAVerticalScalingPhaseOffset01 { get; set; }
Public Property RegSetAVerticalScalingPhaseOffset01 As Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetAVerticalScalingPhaseOffset01 {
    Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 get ();
    void set (Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 value);
}
member RegSetAVerticalScalingPhaseOffset01 : Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAVerticalScalingPhaseOffset10 Property

IRD

Saa7119RegSetAVerticalScalingPhaseOffset10 Property

RegSet A: Vertical Scaling phase offset 10

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetAVerticalScalingPhaseOffset10 { get; set; }
Public Property RegSetAVerticalScalingPhaseOffset10 As Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetAVerticalScalingPhaseOffset10 {
    Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 get ();
    void set (Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 value);
}
member RegSetAVerticalScalingPhaseOffset10 : Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAVerticalScalingPhaseOffset11 Property

IRD

Saa7119RegSetAVerticalScalingPhaseOffset11 Property

RegSet A: Vertical Scaling phase offset 11

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetAVerticalScalingPhaseOffset11 { get; set; }
Public Property RegSetAVerticalScalingPhaseOffset11 As Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetAVerticalScalingPhaseOffset11 {
    Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 get ();
    void set (Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 value);
}
member RegSetAVerticalScalingPhaseOffset11 : Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAWeightingOfAllAccumulatedSamplesIsFactor Property

IRD

Saa7119RegSetAWeightingOfAllAccumulatedSamplesIsFactor Property

RegSet A: Weighting of all accumulated samples is factor =

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetAWeightingOfAllAccumulatedSamplesIsFactor { get; set; }
Public Property RegSetAWeightingOfAllAccumulatedSamplesIsFactor As Byte
    Get
    Set
public:
property unsigned char RegSetAWeightingOfAllAccumulatedSamplesIsFactor {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetAWeightingOfAllAccumulatedSamplesIsFactor : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAXCLK Property

IRD

Saa7119RegSetAXCLK Property

RegSet A: XCLK

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS0 RegSetAXCLK { get; set; }
Public Property RegSetAXCLK As Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS0
    Get
    Set
public:
property Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS0 RegSetAXCLK {
    Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS0 get ();
    void set (Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS0 value);
}
member RegSetAXCLK : Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS0 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAXPortFieldID Property

IRD

Saa7119RegSetAXPortFieldID Property

RegSet A: X port field ID

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS6 RegSetAXPortFieldID { get; set; }
Public Property RegSetAXPortFieldID As Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS6
    Get
    Set
public:
property Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS6 RegSetAXPortFieldID {
    Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS6 get ();
    void set (Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS6 value);
}
member RegSetAXPortFieldID : Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS6 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS6
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAXRV Property

IRD

Saa7119RegSetAXRV Property

RegSet A: XRV

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS5 RegSetAXRV { get; set; }
Public Property RegSetAXRV As Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS5
    Get
    Set
public:
property Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS5 RegSetAXRV {
    Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS5 get ();
    void set (Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS5 value);
}
member RegSetAXRV : Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS5 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS5
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetAYUVRGBMatrixFollowedBy17SegmentCurveGeneration Property

IRD

Saa7119RegSetAYUVRGBMatrixFollowedBy17SegmentCurveGeneration Property

RegSet A: YUV -> RGB-Matrix, followed by 17 segment curve generation

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL0 RegSetAYUVRGBMatrixFollowedBy17SegmentCurveGeneration { get; set; }
Public Property RegSetAYUVRGBMatrixFollowedBy17SegmentCurveGeneration As Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL0
    Get
    Set
public:
property Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL0 RegSetAYUVRGBMatrixFollowedBy17SegmentCurveGeneration {
    Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL0 get ();
    void set (Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL0 value);
}
member RegSetAYUVRGBMatrixFollowedBy17SegmentCurveGeneration : Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetB17SegmentCurvesForBCSInTheYUVOrColorManipulationsInTheRGBDomain Property

IRD

Saa7119RegSetB17SegmentCurvesForBCSInTheYUVOrColorManipulationsInTheRGBDomain Property

RegSet B: 17 segment curves for B,C,S in the YUV or color manipulations in the RGB domain

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL1 RegSetB17SegmentCurvesForBCSInTheYUVOrColorManipulationsInTheRGBDomain { get; set; }
Public Property RegSetB17SegmentCurvesForBCSInTheYUVOrColorManipulationsInTheRGBDomain As Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL1
    Get
    Set
public:
property Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL1 RegSetB17SegmentCurvesForBCSInTheYUVOrColorManipulationsInTheRGBDomain {
    Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL1 get ();
    void set (Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL1 value);
}
member RegSetB17SegmentCurvesForBCSInTheYUVOrColorManipulationsInTheRGBDomain : Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL1 with get, set

Property Value

Type: Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBAccumulationLength Property

IRD

Saa7119RegSetBAccumulationLength Property

RegSet B: Accumulation length

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetBAccumulationLength { get; set; }
Public Property RegSetBAccumulationLength As Byte
    Get
    Set
public:
property unsigned char RegSetBAccumulationLength {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetBAccumulationLength : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBChromaIsProvidedRegSetA Property

IRD

Saa7119RegSetBChromaIsProvidedRegSetA Property

RegSet B: Chroma is provided(Reg. Set: A)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION1 RegSetBChromaIsProvidedRegSetA { get; set; }
Public Property RegSetBChromaIsProvidedRegSetA As Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION1
    Get
    Set
public:
property Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION1 RegSetBChromaIsProvidedRegSetA {
    Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION1 get ();
    void set (Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION1 value);
}
member RegSetBChromaIsProvidedRegSetA : Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION1 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBChrominance Property

IRD

Saa7119RegSetBChrominance Property

RegSet B: Chrominance

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL3 RegSetBChrominance { get; set; }
Public Property RegSetBChrominance As Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL3
    Get
    Set
public:
property Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL3 RegSetBChrominance {
    Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL3 get ();
    void set (Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL3 value);
}
member RegSetBChrominance : Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL3 with get, set

Property Value

Type: Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBChrominanceImprovementChangeOfCoringLevel Property

IRD

Saa7119RegSetBChrominanceImprovementChangeOfCoringLevel Property

RegSet B: Chrominance Improvement: Change of coring level

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetBChrominanceImprovementChangeOfCoringLevel { get; set; }
Public Property RegSetBChrominanceImprovementChangeOfCoringLevel As Byte
    Get
    Set
public:
property unsigned char RegSetBChrominanceImprovementChangeOfCoringLevel {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetBChrominanceImprovementChangeOfCoringLevel : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBChrominanceImprovementSelectHighPassFilterForPeakComponent Property

IRD

Saa7119RegSetBChrominanceImprovementSelectHighPassFilterForPeakComponent Property

RegSet B: Chrominance Improvement: Select High Pass Filter For Peak Component

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetBChrominanceImprovementSelectHighPassFilterForPeakComponent { get; set; }
Public Property RegSetBChrominanceImprovementSelectHighPassFilterForPeakComponent As Byte
    Get
    Set
public:
property unsigned char RegSetBChrominanceImprovementSelectHighPassFilterForPeakComponent {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetBChrominanceImprovementSelectHighPassFilterForPeakComponent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBChrominanceImprovementSignalImprovementMode Property

IRD

Saa7119RegSetBChrominanceImprovementSignalImprovementMode Property

RegSet B: Chrominance Improvement: Signal Improvement Mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL3 RegSetBChrominanceImprovementSignalImprovementMode { get; set; }
Public Property RegSetBChrominanceImprovementSignalImprovementMode As Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL3
    Get
    Set
public:
property Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL3 RegSetBChrominanceImprovementSignalImprovementMode {
    Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL3 get ();
    void set (Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL3 value);
}
member RegSetBChrominanceImprovementSignalImprovementMode : Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL3 with get, set

Property Value

Type: Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBChrominanceImprovementWeightingOfPeakComponent Property

IRD

Saa7119RegSetBChrominanceImprovementWeightingOfPeakComponent Property

RegSet B: Chrominance Improvement: Weighting of Peak Component

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL0 RegSetBChrominanceImprovementWeightingOfPeakComponent { get; set; }
Public Property RegSetBChrominanceImprovementWeightingOfPeakComponent As Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL0
    Get
    Set
public:
property Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL0 RegSetBChrominanceImprovementWeightingOfPeakComponent {
    Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL0 get ();
    void set (Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL0 value);
}
member RegSetBChrominanceImprovementWeightingOfPeakComponent : Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBChrominanceSaturationControl Property

IRD

Saa7119RegSetBChrominanceSaturationControl Property

RegSet B: Chrominance saturation control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 RegSetBChrominanceSaturationControl { get; set; }
Public Property RegSetBChrominanceSaturationControl As Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0
    Get
    Set
public:
property Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 RegSetBChrominanceSaturationControl {
    Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 get ();
    void set (Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 value);
}
member RegSetBChrominanceSaturationControl : Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBDataQualified Property

IRD

Saa7119RegSetBDataQualified Property

RegSet B: Data qualified:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS1 RegSetBDataQualified { get; set; }
Public Property RegSetBDataQualified As Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS1
    Get
    Set
public:
property Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS1 RegSetBDataQualified {
    Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS1 get ();
    void set (Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS1 value);
}
member RegSetBDataQualified : Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS1 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBDitherNoiseShaper Property

IRD

Saa7119RegSetBDitherNoiseShaper Property

RegSet B: Dither (Noise Shaper)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL3 RegSetBDitherNoiseShaper { get; set; }
Public Property RegSetBDitherNoiseShaper As Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL3
    Get
    Set
public:
property Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL3 RegSetBDitherNoiseShaper {
    Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL3 get ();
    void set (Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL3 value);
}
member RegSetBDitherNoiseShaper : Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL3 with get, set

Property Value

Type: Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBDownscale Property

IRD

Saa7119RegSetBDownscale Property

RegSet B: Downscale

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAHORIZONTALPRESCALING0 RegSetBDownscale { get; set; }
Public Property RegSetBDownscale As Saa7119TYPIDTAHORIZONTALPRESCALING0
    Get
    Set
public:
property Saa7119TYPIDTAHORIZONTALPRESCALING0 RegSetBDownscale {
    Saa7119TYPIDTAHORIZONTALPRESCALING0 get ();
    void set (Saa7119TYPIDTAHORIZONTALPRESCALING0 value);
}
member RegSetBDownscale : Saa7119TYPIDTAHORIZONTALPRESCALING0 with get, set

Property Value

Type: Saa7119TYPIDTAHORIZONTALPRESCALING0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBEddiBypassEDBYP Property

IRD

Saa7119RegSetBEddiBypassEDBYP Property

RegSet B: Eddi_bypass (EDBYP)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable RegSetBEddiBypassEDBYP { get; set; }
Public Property RegSetBEddiBypassEDBYP As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable RegSetBEddiBypassEDBYP {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member RegSetBEddiBypassEDBYP : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBEddionEDON Property

IRD

Saa7119RegSetBEddionEDON Property

RegSet B: Eddion (EDON)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAEDGICONTROL3 RegSetBEddionEDON { get; set; }
Public Property RegSetBEddionEDON As Saa7119TYPIDTAEDGICONTROL3
    Get
    Set
public:
property Saa7119TYPIDTAEDGICONTROL3 RegSetBEddionEDON {
    Saa7119TYPIDTAEDGICONTROL3 get ();
    void set (Saa7119TYPIDTAEDGICONTROL3 value);
}
member RegSetBEddionEDON : Saa7119TYPIDTAEDGICONTROL3 with get, set

Property Value

Type: Saa7119TYPIDTAEDGICONTROL3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBEdgeOfXRHInputIsHorizontalReference Property

IRD

Saa7119RegSetBEdgeOfXRHInputIsHorizontalReference Property

RegSet B: Edge of XRH input is horizontal reference

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS2 RegSetBEdgeOfXRHInputIsHorizontalReference { get; set; }
Public Property RegSetBEdgeOfXRHInputIsHorizontalReference As Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS2
    Get
    Set
public:
property Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS2 RegSetBEdgeOfXRHInputIsHorizontalReference {
    Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS2 get ();
    void set (Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS2 value);
}
member RegSetBEdgeOfXRHInputIsHorizontalReference : Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS2 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBEdgeOfXRVInputAndDecoderV123IsVerticalReference Property

IRD

Saa7119RegSetBEdgeOfXRVInputAndDecoderV123IsVerticalReference Property

RegSet B: Edge of XRV input and decoder V123 is vertical reference:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS4 RegSetBEdgeOfXRVInputAndDecoderV123IsVerticalReference { get; set; }
Public Property RegSetBEdgeOfXRVInputAndDecoderV123IsVerticalReference As Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS4
    Get
    Set
public:
property Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS4 RegSetBEdgeOfXRVInputAndDecoderV123IsVerticalReference {
    Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS4 get ();
    void set (Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS4 value);
}
member RegSetBEdgeOfXRVInputAndDecoderV123IsVerticalReference : Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS4 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS4
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBEdgiScalingIncrementValue1X Property

IRD

Saa7119RegSetBEdgiScalingIncrementValue1X Property

RegSet B: Edgi scaling increment: Value=1/x

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort RegSetBEdgiScalingIncrementValue1X { get; set; }
Public Property RegSetBEdgiScalingIncrementValue1X As UShort
    Get
    Set
public:
property unsigned short RegSetBEdgiScalingIncrementValue1X {
    unsigned short get ();
    void set (unsigned short value);
}
member RegSetBEdgiScalingIncrementValue1X : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBEdgiScalingPhase00 Property

IRD

Saa7119RegSetBEdgiScalingPhase00 Property

RegSet B: Edgi Scaling phase: 00

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetBEdgiScalingPhase00 { get; set; }
Public Property RegSetBEdgiScalingPhase00 As Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetBEdgiScalingPhase00 {
    Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 get ();
    void set (Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 value);
}
member RegSetBEdgiScalingPhase00 : Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBEdgiScalingPhase01 Property

IRD

Saa7119RegSetBEdgiScalingPhase01 Property

RegSet B: Edgi Scaling phase: 01

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetBEdgiScalingPhase01 { get; set; }
Public Property RegSetBEdgiScalingPhase01 As Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetBEdgiScalingPhase01 {
    Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 get ();
    void set (Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 value);
}
member RegSetBEdgiScalingPhase01 : Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBEdgiScalingPhase10 Property

IRD

Saa7119RegSetBEdgiScalingPhase10 Property

RegSet B: Edgi Scaling phase: 10

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetBEdgiScalingPhase10 { get; set; }
Public Property RegSetBEdgiScalingPhase10 As Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetBEdgiScalingPhase10 {
    Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 get ();
    void set (Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 value);
}
member RegSetBEdgiScalingPhase10 : Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBEdgiScalingPhase11 Property

IRD

Saa7119RegSetBEdgiScalingPhase11 Property

RegSet B: Edgi Scaling phase: 11

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetBEdgiScalingPhase11 { get; set; }
Public Property RegSetBEdgiScalingPhase11 As Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetBEdgiScalingPhase11 {
    Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 get ();
    void set (Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 value);
}
member RegSetBEdgiScalingPhase11 : Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBEventHandlerTriggers Property

IRD

Saa7119RegSetBEventHandlerTriggers Property

RegSet B: Event handler triggers:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTATASKHANDLINGCONTROL0 RegSetBEventHandlerTriggers { get; set; }
Public Property RegSetBEventHandlerTriggers As Saa7119TYPIDTATASKHANDLINGCONTROL0
    Get
    Set
public:
property Saa7119TYPIDTATASKHANDLINGCONTROL0 RegSetBEventHandlerTriggers {
    Saa7119TYPIDTATASKHANDLINGCONTROL0 get ();
    void set (Saa7119TYPIDTATASKHANDLINGCONTROL0 value);
}
member RegSetBEventHandlerTriggers : Saa7119TYPIDTATASKHANDLINGCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDTATASKHANDLINGCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBFieldModeContinuousTaskMode Property

IRD

Saa7119RegSetBFieldModeContinuousTaskMode Property

RegSet B: Field mode (continuous task mode)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONH0 RegSetBFieldModeContinuousTaskMode { get; set; }
Public Property RegSetBFieldModeContinuousTaskMode As Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONH0
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONH0 RegSetBFieldModeContinuousTaskMode {
    Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONH0 get ();
    void set (Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONH0 value);
}
member RegSetBFieldModeContinuousTaskMode : Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONH0 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONH0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBFormat Property

IRD

Saa7119RegSetBFormat Property

RegSet B: Format

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION0 RegSetBFormat { get; set; }
Public Property RegSetBFormat As Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION0
    Get
    Set
public:
property Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION0 RegSetBFormat {
    Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION0 get ();
    void set (Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION0 value);
}
member RegSetBFormat : Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION0 with get, set

Property Value

Type: Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBHorizontalChrominancePhaseOffset Property

IRD

Saa7119RegSetBHorizontalChrominancePhaseOffset Property

RegSet B: Horizontal chrominance phase offset

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetBHorizontalChrominancePhaseOffset { get; set; }
Public Property RegSetBHorizontalChrominancePhaseOffset As Byte
    Get
    Set
public:
property unsigned char RegSetBHorizontalChrominancePhaseOffset {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetBHorizontalChrominancePhaseOffset : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBHorizontalChrominanceScalingIncrement Property

IRD

Saa7119RegSetBHorizontalChrominanceScalingIncrement Property

RegSet B: Horizontal chrominance scaling increment

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort RegSetBHorizontalChrominanceScalingIncrement { get; set; }
Public Property RegSetBHorizontalChrominanceScalingIncrement As UShort
    Get
    Set
public:
property unsigned short RegSetBHorizontalChrominanceScalingIncrement {
    unsigned short get ();
    void set (unsigned short value);
}
member RegSetBHorizontalChrominanceScalingIncrement : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBHorizontalInputAcquisitionWindowDefinitionInputWindowsLegth Property

IRD

Saa7119RegSetBHorizontalInputAcquisitionWindowDefinitionInputWindowsLegth Property

RegSet B: Horizontal input acquisition window definition input windows legth

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAHORIZONTALINPWINDOWLENGTHL0 RegSetBHorizontalInputAcquisitionWindowDefinitionInputWindowsLegth { get; set; }
Public Property RegSetBHorizontalInputAcquisitionWindowDefinitionInputWindowsLegth As Saa7119TYPIDTAHORIZONTALINPWINDOWLENGTHL0
    Get
    Set
public:
property Saa7119TYPIDTAHORIZONTALINPWINDOWLENGTHL0 RegSetBHorizontalInputAcquisitionWindowDefinitionInputWindowsLegth {
    Saa7119TYPIDTAHORIZONTALINPWINDOWLENGTHL0 get ();
    void set (Saa7119TYPIDTAHORIZONTALINPWINDOWLENGTHL0 value);
}
member RegSetBHorizontalInputAcquisitionWindowDefinitionInputWindowsLegth : Saa7119TYPIDTAHORIZONTALINPWINDOWLENGTHL0 with get, set

Property Value

Type: Saa7119TYPIDTAHORIZONTALINPWINDOWLENGTHL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBHorizontalInputAcquisitionWindowDefinitionOffset Property

IRD

Saa7119RegSetBHorizontalInputAcquisitionWindowDefinitionOffset Property

RegSet B: Horizontal input acquisition window definition offset

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAHORIZONTALINPINITIONOFFSETL0 RegSetBHorizontalInputAcquisitionWindowDefinitionOffset { get; set; }
Public Property RegSetBHorizontalInputAcquisitionWindowDefinitionOffset As Saa7119TYPIDTAHORIZONTALINPINITIONOFFSETL0
    Get
    Set
public:
property Saa7119TYPIDTAHORIZONTALINPINITIONOFFSETL0 RegSetBHorizontalInputAcquisitionWindowDefinitionOffset {
    Saa7119TYPIDTAHORIZONTALINPINITIONOFFSETL0 get ();
    void set (Saa7119TYPIDTAHORIZONTALINPINITIONOFFSETL0 value);
}
member RegSetBHorizontalInputAcquisitionWindowDefinitionOffset : Saa7119TYPIDTAHORIZONTALINPINITIONOFFSETL0 with get, set

Property Value

Type: Saa7119TYPIDTAHORIZONTALINPINITIONOFFSETL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBHorizontalLuminancePhaseOffset Property

IRD

Saa7119RegSetBHorizontalLuminancePhaseOffset Property

RegSet B: Horizontal luminance phase offset (unit: Pixel)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 RegSetBHorizontalLuminancePhaseOffset { get; set; }
Public Property RegSetBHorizontalLuminancePhaseOffset As Saa7119TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
    Get
    Set
public:
property Saa7119TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 RegSetBHorizontalLuminancePhaseOffset {
    Saa7119TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 get ();
    void set (Saa7119TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 value);
}
member RegSetBHorizontalLuminancePhaseOffset : Saa7119TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 with get, set

Property Value

Type: Saa7119TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBHorizontalLuminanceScalingIncrement1024X Property

IRD

Saa7119RegSetBHorizontalLuminanceScalingIncrement1024X Property

RegSet B: Horizontal luminance scaling increment 1024/x

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort RegSetBHorizontalLuminanceScalingIncrement1024X { get; set; }
Public Property RegSetBHorizontalLuminanceScalingIncrement1024X As UShort
    Get
    Set
public:
property unsigned short RegSetBHorizontalLuminanceScalingIncrement1024X {
    unsigned short get ();
    void set (unsigned short value);
}
member RegSetBHorizontalLuminanceScalingIncrement1024X : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBHorizontalOutputWindowLength Property

IRD

Saa7119RegSetBHorizontalOutputWindowLength Property

RegSet B: Horizontal output window length

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 RegSetBHorizontalOutputWindowLength { get; set; }
Public Property RegSetBHorizontalOutputWindowLength As Saa7119TYPIDTAHORIZONTALOUTWINDOWLENGTHL0
    Get
    Set
public:
property Saa7119TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 RegSetBHorizontalOutputWindowLength {
    Saa7119TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 get ();
    void set (Saa7119TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 value);
}
member RegSetBHorizontalOutputWindowLength : Saa7119TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 with get, set

Property Value

Type: Saa7119TYPIDTAHORIZONTALOUTWINDOWLENGTHL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBITU656 Property

IRD

Saa7119RegSetBITU656 Property

RegSet B: ITU 656

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION4 RegSetBITU656 { get; set; }
Public Property RegSetBITU656 As Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION4
    Get
    Set
public:
property Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION4 RegSetBITU656 {
    Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION4 get ();
    void set (Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION4 value);
}
member RegSetBITU656 : Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION4 with get, set

Property Value

Type: Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION4
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBLeadingLinesBefore1stYCBCRLineIsOutput Property

IRD

Saa7119RegSetBLeadingLinesBefore1stYCBCRLineIsOutput Property

RegSet B: Leading lines before 1st Y + CB-CR line is output

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION1 RegSetBLeadingLinesBefore1stYCBCRLineIsOutput { get; set; }
Public Property RegSetBLeadingLinesBefore1stYCBCRLineIsOutput As Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION1
    Get
    Set
public:
property Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION1 RegSetBLeadingLinesBefore1stYCBCRLineIsOutput {
    Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION1 get ();
    void set (Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION1 value);
}
member RegSetBLeadingLinesBefore1stYCBCRLineIsOutput : Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION1 with get, set

Property Value

Type: Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBLinesOutput Property

IRD

Saa7119RegSetBLinesOutput Property

RegSet B: Lines output

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION2 RegSetBLinesOutput { get; set; }
Public Property RegSetBLinesOutput As Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION2
    Get
    Set
public:
property Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION2 RegSetBLinesOutput {
    Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION2 get ();
    void set (Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION2 value);
}
member RegSetBLinesOutput : Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION2 with get, set

Property Value

Type: Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBLuminance Property

IRD

Saa7119RegSetBLuminance Property

RegSet B: Luminance

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL2 RegSetBLuminance { get; set; }
Public Property RegSetBLuminance As Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL2
    Get
    Set
public:
property Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL2 RegSetBLuminance {
    Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL2 get ();
    void set (Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL2 value);
}
member RegSetBLuminance : Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL2 with get, set

Property Value

Type: Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBLuminanceBrightnessControl Property

IRD

Saa7119RegSetBLuminanceBrightnessControl Property

RegSet B: Luminance brightness control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetBLuminanceBrightnessControl { get; set; }
Public Property RegSetBLuminanceBrightnessControl As Byte
    Get
    Set
public:
property unsigned char RegSetBLuminanceBrightnessControl {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetBLuminanceBrightnessControl : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBLuminanceContrastControl Property

IRD

Saa7119RegSetBLuminanceContrastControl Property

RegSet B: Luminance contrast control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 RegSetBLuminanceContrastControl { get; set; }
Public Property RegSetBLuminanceContrastControl As Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0
    Get
    Set
public:
property Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 RegSetBLuminanceContrastControl {
    Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 get ();
    void set (Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 value);
}
member RegSetBLuminanceContrastControl : Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBLuminanceImprovementChangeOfCoringLevel Property

IRD

Saa7119RegSetBLuminanceImprovementChangeOfCoringLevel Property

RegSet B: Luminance Improvement: Change of coring level

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetBLuminanceImprovementChangeOfCoringLevel { get; set; }
Public Property RegSetBLuminanceImprovementChangeOfCoringLevel As Byte
    Get
    Set
public:
property unsigned char RegSetBLuminanceImprovementChangeOfCoringLevel {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetBLuminanceImprovementChangeOfCoringLevel : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBLuminanceImprovementSelectHighPassFilterForPeakComponent Property

IRD

Saa7119RegSetBLuminanceImprovementSelectHighPassFilterForPeakComponent Property

RegSet B: Luminance Improvement: Select High Pass Filter For Peak Component

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetBLuminanceImprovementSelectHighPassFilterForPeakComponent { get; set; }
Public Property RegSetBLuminanceImprovementSelectHighPassFilterForPeakComponent As Byte
    Get
    Set
public:
property unsigned char RegSetBLuminanceImprovementSelectHighPassFilterForPeakComponent {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetBLuminanceImprovementSelectHighPassFilterForPeakComponent : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBLuminanceImprovementSignalImprovementMode Property

IRD

Saa7119RegSetBLuminanceImprovementSignalImprovementMode Property

RegSet B: Luminance Improvement: Signal Improvement Mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL3 RegSetBLuminanceImprovementSignalImprovementMode { get; set; }
Public Property RegSetBLuminanceImprovementSignalImprovementMode As Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL3
    Get
    Set
public:
property Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL3 RegSetBLuminanceImprovementSignalImprovementMode {
    Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL3 get ();
    void set (Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL3 value);
}
member RegSetBLuminanceImprovementSignalImprovementMode : Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL3 with get, set

Property Value

Type: Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBLuminanceImprovementWeightingOfPeakComponent Property

IRD

Saa7119RegSetBLuminanceImprovementWeightingOfPeakComponent Property

RegSet B: Luminance Improvement: Weighting of Peak Component

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL0 RegSetBLuminanceImprovementWeightingOfPeakComponent { get; set; }
Public Property RegSetBLuminanceImprovementWeightingOfPeakComponent As Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL0
    Get
    Set
public:
property Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL0 RegSetBLuminanceImprovementWeightingOfPeakComponent {
    Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL0 get ();
    void set (Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL0 value);
}
member RegSetBLuminanceImprovementWeightingOfPeakComponent : Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBMirroring Property

IRD

Saa7119RegSetBMirroring Property

RegSet B: Mirroring

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAEDGICONTROL1 RegSetBMirroring { get; set; }
Public Property RegSetBMirroring As Saa7119TYPIDTAEDGICONTROL1
    Get
    Set
public:
property Saa7119TYPIDTAEDGICONTROL1 RegSetBMirroring {
    Saa7119TYPIDTAEDGICONTROL1 get ();
    void set (Saa7119TYPIDTAEDGICONTROL1 value);
}
member RegSetBMirroring : Saa7119TYPIDTAEDGICONTROL1 with get, set

Property Value

Type: Saa7119TYPIDTAEDGICONTROL1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBNextTask Property

IRD

Saa7119RegSetBNextTask Property

RegSet B: Next task:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTATASKHANDLINGCONTROL1 RegSetBNextTask { get; set; }
Public Property RegSetBNextTask As Saa7119TYPIDTATASKHANDLINGCONTROL1
    Get
    Set
public:
property Saa7119TYPIDTATASKHANDLINGCONTROL1 RegSetBNextTask {
    Saa7119TYPIDTATASKHANDLINGCONTROL1 get ();
    void set (Saa7119TYPIDTATASKHANDLINGCONTROL1 value);
}
member RegSetBNextTask : Saa7119TYPIDTATASKHANDLINGCONTROL1 with get, set

Property Value

Type: Saa7119TYPIDTATASKHANDLINGCONTROL1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBOutputFieldID Property

IRD

Saa7119RegSetBOutputFieldID Property

RegSet B: Output field ID

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTATASKHANDLINGCONTROL3 RegSetBOutputFieldID { get; set; }
Public Property RegSetBOutputFieldID As Saa7119TYPIDTATASKHANDLINGCONTROL3
    Get
    Set
public:
property Saa7119TYPIDTATASKHANDLINGCONTROL3 RegSetBOutputFieldID {
    Saa7119TYPIDTATASKHANDLINGCONTROL3 get ();
    void set (Saa7119TYPIDTATASKHANDLINGCONTROL3 value);
}
member RegSetBOutputFieldID : Saa7119TYPIDTATASKHANDLINGCONTROL3 with get, set

Property Value

Type: Saa7119TYPIDTATASKHANDLINGCONTROL3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBPrescalerOutputIsRenormalizedByGainFactor Property

IRD

Saa7119RegSetBPrescalerOutputIsRenormalizedByGainFactor Property

RegSet B: Prescaler output is renormalized by gain factor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL0 RegSetBPrescalerOutputIsRenormalizedByGainFactor { get; set; }
Public Property RegSetBPrescalerOutputIsRenormalizedByGainFactor As Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL0
    Get
    Set
public:
property Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL0 RegSetBPrescalerOutputIsRenormalizedByGainFactor {
    Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL0 get ();
    void set (Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL0 value);
}
member RegSetBPrescalerOutputIsRenormalizedByGainFactor : Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBReferenceEdgeForFieldDetection Property

IRD

Saa7119RegSetBReferenceEdgeForFieldDetection Property

RegSet B: Reference edge for field detection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS7 RegSetBReferenceEdgeForFieldDetection { get; set; }
Public Property RegSetBReferenceEdgeForFieldDetection As Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS7
    Get
    Set
public:
property Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS7 RegSetBReferenceEdgeForFieldDetection {
    Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS7 get ();
    void set (Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS7 value);
}
member RegSetBReferenceEdgeForFieldDetection : Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS7 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS7
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBReferenceSignals Property

IRD

Saa7119RegSetBReferenceSignals Property

RegSet B: Reference signals:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS3 RegSetBReferenceSignals { get; set; }
Public Property RegSetBReferenceSignals As Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS3
    Get
    Set
public:
property Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS3 RegSetBReferenceSignals {
    Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS3 get ();
    void set (Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS3 value);
}
member RegSetBReferenceSignals : Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS3 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBRemainingBlankingIntervals Property

IRD

Saa7119RegSetBRemainingBlankingIntervals Property

RegSet B: Remaining blanking intervals

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION3 RegSetBRemainingBlankingIntervals { get; set; }
Public Property RegSetBRemainingBlankingIntervals As Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION3
    Get
    Set
public:
property Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION3 RegSetBRemainingBlankingIntervals {
    Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION3 get ();
    void set (Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION3 value);
}
member RegSetBRemainingBlankingIntervals : Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION3 with get, set

Property Value

Type: Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBRGBYUVMatrixToReconvertRGBToYUVAfterManipulationsInTheRGBDomainFollowedByTheNoiseShaper Property

IRD

Saa7119RegSetBRGBYUVMatrixToReconvertRGBToYUVAfterManipulationsInTheRGBDomainFollowedByTheNoiseShaper Property

RegSet B: RGB -> YUV-Matrix, to reconvert RGB to YUV after manipulations in the RGB domain, followed by the Noise Shaper

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL2 RegSetBRGBYUVMatrixToReconvertRGBToYUVAfterManipulationsInTheRGBDomainFollowedByTheNoiseShaper { get; set; }
Public Property RegSetBRGBYUVMatrixToReconvertRGBToYUVAfterManipulationsInTheRGBDomainFollowedByTheNoiseShaper As Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL2
    Get
    Set
public:
property Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL2 RegSetBRGBYUVMatrixToReconvertRGBToYUVAfterManipulationsInTheRGBDomainFollowedByTheNoiseShaper {
    Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL2 get ();
    void set (Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL2 value);
}
member RegSetBRGBYUVMatrixToReconvertRGBToYUVAfterManipulationsInTheRGBDomainFollowedByTheNoiseShaper : Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL2 with get, set

Property Value

Type: Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBSamplingScheme Property

IRD

Saa7119RegSetBSamplingScheme Property

RegSet B: Sampling scheme

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION0 RegSetBSamplingScheme { get; set; }
Public Property RegSetBSamplingScheme As Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION0
    Get
    Set
public:
property Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION0 RegSetBSamplingScheme {
    Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION0 get ();
    void set (Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION0 value);
}
member RegSetBSamplingScheme : Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION0 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBSAVEAVCodeBitD5VGate Property

IRD

Saa7119RegSetBSAVEAVCodeBitD5VGate Property

RegSet B: SAV/EAV code bit D5 (V) gate:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION5 RegSetBSAVEAVCodeBitD5VGate { get; set; }
Public Property RegSetBSAVEAVCodeBitD5VGate As Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION5
    Get
    Set
public:
property Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION5 RegSetBSAVEAVCodeBitD5VGate {
    Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION5 get ();
    void set (Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION5 value);
}
member RegSetBSAVEAVCodeBitD5VGate : Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION5 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION5
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBSAVEAVCodeBitsD6AndD5FAndV Property

IRD

Saa7119RegSetBSAVEAVCodeBitsD6AndD5FAndV Property

RegSet B: SAV/EAV code bits D6 and D5 (F and V):

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION4 RegSetBSAVEAVCodeBitsD6AndD5FAndV { get; set; }
Public Property RegSetBSAVEAVCodeBitsD6AndD5FAndV As Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION4
    Get
    Set
public:
property Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION4 RegSetBSAVEAVCodeBitsD6AndD5FAndV {
    Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION4 get ();
    void set (Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION4 value);
}
member RegSetBSAVEAVCodeBitsD6AndD5FAndV : Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION4 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION4
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBScalerInputFormatConfigSource Property

IRD

Saa7119RegSetBScalerInputFormatConfigSource Property

RegSet B: Scaler input format/config source:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION3 RegSetBScalerInputFormatConfigSource { get; set; }
Public Property RegSetBScalerInputFormatConfigSource As Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION3
    Get
    Set
public:
property Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION3 RegSetBScalerInputFormatConfigSource {
    Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION3 get ();
    void set (Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION3 value);
}
member RegSetBScalerInputFormatConfigSource : Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION3 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBScalerInputSource Property

IRD

Saa7119RegSetBScalerInputSource Property

RegSet B: Scaler input source:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION2 RegSetBScalerInputSource { get; set; }
Public Property RegSetBScalerInputSource As Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION2
    Get
    Set
public:
property Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION2 RegSetBScalerInputSource {
    Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION2 get ();
    void set (Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION2 value);
}
member RegSetBScalerInputSource : Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION2 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBScalerSAVEAVByte Property

IRD

Saa7119RegSetBScalerSAVEAVByte Property

RegSet B: Scaler SAV/EAV byte

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTATASKHANDLINGCONTROL4 RegSetBScalerSAVEAVByte { get; set; }
Public Property RegSetBScalerSAVEAVByte As Saa7119TYPIDTATASKHANDLINGCONTROL4
    Get
    Set
public:
property Saa7119TYPIDTATASKHANDLINGCONTROL4 RegSetBScalerSAVEAVByte {
    Saa7119TYPIDTATASKHANDLINGCONTROL4 get ();
    void set (Saa7119TYPIDTATASKHANDLINGCONTROL4 value);
}
member RegSetBScalerSAVEAVByte : Saa7119TYPIDTATASKHANDLINGCONTROL4 with get, set

Property Value

Type: Saa7119TYPIDTATASKHANDLINGCONTROL4
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBTaskHandlingControl Property

IRD

Saa7119RegSetBTaskHandlingControl Property

RegSet B: Task handling control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTATASKHANDLINGCONTROL2 RegSetBTaskHandlingControl { get; set; }
Public Property RegSetBTaskHandlingControl As Saa7119TYPIDTATASKHANDLINGCONTROL2
    Get
    Set
public:
property Saa7119TYPIDTATASKHANDLINGCONTROL2 RegSetBTaskHandlingControl {
    Saa7119TYPIDTATASKHANDLINGCONTROL2 get ();
    void set (Saa7119TYPIDTATASKHANDLINGCONTROL2 value);
}
member RegSetBTaskHandlingControl : Saa7119TYPIDTATASKHANDLINGCONTROL2 with get, set

Property Value

Type: Saa7119TYPIDTATASKHANDLINGCONTROL2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBVerticalInputAcquisitionWindowDefinition Property

IRD

Saa7119RegSetBVerticalInputAcquisitionWindowDefinition Property

RegSet B: Vertical input acquisition window definition

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONL0 RegSetBVerticalInputAcquisitionWindowDefinition { get; set; }
Public Property RegSetBVerticalInputAcquisitionWindowDefinition As Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONL0
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONL0 RegSetBVerticalInputAcquisitionWindowDefinition {
    Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONL0 get ();
    void set (Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONL0 value);
}
member RegSetBVerticalInputAcquisitionWindowDefinition : Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONL0 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBVerticalInputAcquisitionWindowDefinitionOffset Property

IRD

Saa7119RegSetBVerticalInputAcquisitionWindowDefinitionOffset Property

RegSet B: Vertical input acquisition window definition offset

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALINPUTINITIONOFFSETL0 RegSetBVerticalInputAcquisitionWindowDefinitionOffset { get; set; }
Public Property RegSetBVerticalInputAcquisitionWindowDefinitionOffset As Saa7119TYPIDTAVERTICALINPUTINITIONOFFSETL0
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALINPUTINITIONOFFSETL0 RegSetBVerticalInputAcquisitionWindowDefinitionOffset {
    Saa7119TYPIDTAVERTICALINPUTINITIONOFFSETL0 get ();
    void set (Saa7119TYPIDTAVERTICALINPUTINITIONOFFSETL0 value);
}
member RegSetBVerticalInputAcquisitionWindowDefinitionOffset : Saa7119TYPIDTAVERTICALINPUTINITIONOFFSETL0 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALINPUTINITIONOFFSETL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBVerticalOutputWindowLength Property

IRD

Saa7119RegSetBVerticalOutputWindowLength Property

RegSet B: Vertical output window length

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 RegSetBVerticalOutputWindowLength { get; set; }
Public Property RegSetBVerticalOutputWindowLength As Saa7119TYPIDTAVERTICALOUTPUWINDOWLENGTHL0
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 RegSetBVerticalOutputWindowLength {
    Saa7119TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 get ();
    void set (Saa7119TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 value);
}
member RegSetBVerticalOutputWindowLength : Saa7119TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALOUTPUWINDOWLENGTHL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBVerticalScalingIncrementValue1X Property

IRD

Saa7119RegSetBVerticalScalingIncrementValue1X Property

RegSet B: Vertical scaling increment: Value=1/x

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort RegSetBVerticalScalingIncrementValue1X { get; set; }
Public Property RegSetBVerticalScalingIncrementValue1X As UShort
    Get
    Set
public:
property unsigned short RegSetBVerticalScalingIncrementValue1X {
    unsigned short get ();
    void set (unsigned short value);
}
member RegSetBVerticalScalingIncrementValue1X : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBVerticalScalingPerforms Property

IRD

Saa7119RegSetBVerticalScalingPerforms Property

RegSet B: Vertical scaling performs

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAEDGICONTROL0 RegSetBVerticalScalingPerforms { get; set; }
Public Property RegSetBVerticalScalingPerforms As Saa7119TYPIDTAEDGICONTROL0
    Get
    Set
public:
property Saa7119TYPIDTAEDGICONTROL0 RegSetBVerticalScalingPerforms {
    Saa7119TYPIDTAEDGICONTROL0 get ();
    void set (Saa7119TYPIDTAEDGICONTROL0 value);
}
member RegSetBVerticalScalingPerforms : Saa7119TYPIDTAEDGICONTROL0 with get, set

Property Value

Type: Saa7119TYPIDTAEDGICONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBVerticalScalingPhaseOffset00 Property

IRD

Saa7119RegSetBVerticalScalingPhaseOffset00 Property

RegSet B: Vertical Scaling phase offset 00

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetBVerticalScalingPhaseOffset00 { get; set; }
Public Property RegSetBVerticalScalingPhaseOffset00 As Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetBVerticalScalingPhaseOffset00 {
    Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 get ();
    void set (Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 value);
}
member RegSetBVerticalScalingPhaseOffset00 : Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBVerticalScalingPhaseOffset01 Property

IRD

Saa7119RegSetBVerticalScalingPhaseOffset01 Property

RegSet B: Vertical Scaling phase offset 01

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetBVerticalScalingPhaseOffset01 { get; set; }
Public Property RegSetBVerticalScalingPhaseOffset01 As Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetBVerticalScalingPhaseOffset01 {
    Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 get ();
    void set (Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 value);
}
member RegSetBVerticalScalingPhaseOffset01 : Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBVerticalScalingPhaseOffset10 Property

IRD

Saa7119RegSetBVerticalScalingPhaseOffset10 Property

RegSet B: Vertical Scaling phase offset 10

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetBVerticalScalingPhaseOffset10 { get; set; }
Public Property RegSetBVerticalScalingPhaseOffset10 As Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetBVerticalScalingPhaseOffset10 {
    Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 get ();
    void set (Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 value);
}
member RegSetBVerticalScalingPhaseOffset10 : Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBVerticalScalingPhaseOffset11 Property

IRD

Saa7119RegSetBVerticalScalingPhaseOffset11 Property

RegSet B: Vertical Scaling phase offset 11

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetBVerticalScalingPhaseOffset11 { get; set; }
Public Property RegSetBVerticalScalingPhaseOffset11 As Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
    Get
    Set
public:
property Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 RegSetBVerticalScalingPhaseOffset11 {
    Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 get ();
    void set (Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 value);
}
member RegSetBVerticalScalingPhaseOffset11 : Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 with get, set

Property Value

Type: Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBWeightingOfAllAccumulatedSamplesIsFactor Property

IRD

Saa7119RegSetBWeightingOfAllAccumulatedSamplesIsFactor Property

RegSet B: Weighting of all accumulated samples is factor =

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RegSetBWeightingOfAllAccumulatedSamplesIsFactor { get; set; }
Public Property RegSetBWeightingOfAllAccumulatedSamplesIsFactor As Byte
    Get
    Set
public:
property unsigned char RegSetBWeightingOfAllAccumulatedSamplesIsFactor {
    unsigned char get ();
    void set (unsigned char value);
}
member RegSetBWeightingOfAllAccumulatedSamplesIsFactor : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBXCLK Property

IRD

Saa7119RegSetBXCLK Property

RegSet B: XCLK

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS0 RegSetBXCLK { get; set; }
Public Property RegSetBXCLK As Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS0
    Get
    Set
public:
property Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS0 RegSetBXCLK {
    Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS0 get ();
    void set (Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS0 value);
}
member RegSetBXCLK : Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS0 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBXPortFieldID Property

IRD

Saa7119RegSetBXPortFieldID Property

RegSet B: X port field ID

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS6 RegSetBXPortFieldID { get; set; }
Public Property RegSetBXPortFieldID As Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS6
    Get
    Set
public:
property Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS6 RegSetBXPortFieldID {
    Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS6 get ();
    void set (Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS6 value);
}
member RegSetBXPortFieldID : Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS6 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS6
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBXRV Property

IRD

Saa7119RegSetBXRV Property

RegSet B: XRV

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS5 RegSetBXRV { get; set; }
Public Property RegSetBXRV As Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS5
    Get
    Set
public:
property Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS5 RegSetBXRV {
    Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS5 get ();
    void set (Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS5 value);
}
member RegSetBXRV : Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS5 with get, set

Property Value

Type: Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS5
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RegSetBYUVRGBMatrixFollowedBy17SegmentCurveGeneration Property

IRD

Saa7119RegSetBYUVRGBMatrixFollowedBy17SegmentCurveGeneration Property

RegSet B: YUV -> RGB-Matrix, followed by 17 segment curve generation

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL0 RegSetBYUVRGBMatrixFollowedBy17SegmentCurveGeneration { get; set; }
Public Property RegSetBYUVRGBMatrixFollowedBy17SegmentCurveGeneration As Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL0
    Get
    Set
public:
property Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL0 RegSetBYUVRGBMatrixFollowedBy17SegmentCurveGeneration {
    Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL0 get ();
    void set (Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL0 value);
}
member RegSetBYUVRGBMatrixFollowedBy17SegmentCurveGeneration : Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RemodulationBandwidthForLuminance Property

IRD

Saa7119RemodulationBandwidthForLuminance Property

Remodulation bandwidth for luminance

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLUMINANCECONTROL1 RemodulationBandwidthForLuminance { get; set; }
Public Property RemodulationBandwidthForLuminance As Saa7119TYPIDLUMINANCECONTROL1
    Get
    Set
public:
property Saa7119TYPIDLUMINANCECONTROL1 RemodulationBandwidthForLuminance {
    Saa7119TYPIDLUMINANCECONTROL1 get ();
    void set (Saa7119TYPIDLUMINANCECONTROL1 value);
}
member RemodulationBandwidthForLuminance : Saa7119TYPIDLUMINANCECONTROL1 with get, set

Property Value

Type: Saa7119TYPIDLUMINANCECONTROL1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ReportTheLinesWithinTwoFieldsContainAtLeastOneTransition Property

IRD

Saa7119ReportTheLinesWithinTwoFieldsContainAtLeastOneTransition Property

Report the lines within two fields (contain at least one transition)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDFASTSWITCHSTATUS0 ReportTheLinesWithinTwoFieldsContainAtLeastOneTransition { get; set; }
Public Property ReportTheLinesWithinTwoFieldsContainAtLeastOneTransition As Saa7119TYPIDFASTSWITCHSTATUS0
    Get
    Set
public:
property Saa7119TYPIDFASTSWITCHSTATUS0 ReportTheLinesWithinTwoFieldsContainAtLeastOneTransition {
    Saa7119TYPIDFASTSWITCHSTATUS0 get ();
    void set (Saa7119TYPIDFASTSWITCHSTATUS0 value);
}
member ReportTheLinesWithinTwoFieldsContainAtLeastOneTransition : Saa7119TYPIDFASTSWITCHSTATUS0 with get, set

Property Value

Type: Saa7119TYPIDFASTSWITCHSTATUS0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RGB16565MappingToInternal16BitYUVOutputPath Property

IRD

Saa7119RGB16565MappingToInternal16BitYUVOutputPath Property

RGB16 (565) mapping to internal 16 bit YUV output path

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS3 RGB16565MappingToInternal16BitYUVOutputPath { get; set; }
Public Property RGB16565MappingToInternal16BitYUVOutputPath As Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS3
    Get
    Set
public:
property Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS3 RGB16565MappingToInternal16BitYUVOutputPath {
    Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS3 get ();
    void set (Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS3 value);
}
member RGB16565MappingToInternal16BitYUVOutputPath : Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS3 with get, set

Property Value

Type: Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RightSlopeForKeystoneCompensation Property

IRD

Saa7119RightSlopeForKeystoneCompensation Property

Right Slope for keystone compensation

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RightSlopeForKeystoneCompensation { get; set; }
Public Property RightSlopeForKeystoneCompensation As Byte
    Get
    Set
public:
property unsigned char RightSlopeForKeystoneCompensation {
    unsigned char get ();
    void set (unsigned char value);
}
member RightSlopeForKeystoneCompensation : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RTCOCompatiblityModeForSAA7199 Property

IRD

Saa7119RTCOCompatiblityModeForSAA7199 Property

RTCO compatiblity mode for SAA7199

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION4 RTCOCompatiblityModeForSAA7199 { get; set; }
Public Property RTCOCompatiblityModeForSAA7199 As Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION4
    Get
    Set
public:
property Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION4 RTCOCompatiblityModeForSAA7199 {
    Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION4 get ();
    void set (Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION4 value);
}
member RTCOCompatiblityModeForSAA7199 : Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION4 with get, set

Property Value

Type: Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION4
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RTCOOutputEnable Property

IRD

Saa7119RTCOOutputEnable Property

RTCO output enable

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDRTXPORTOUTPUTCONTROL3 RTCOOutputEnable { get; set; }
Public Property RTCOOutputEnable As Saa7119TYPIDRTXPORTOUTPUTCONTROL3
    Get
    Set
public:
property Saa7119TYPIDRTXPORTOUTPUTCONTROL3 RTCOOutputEnable {
    Saa7119TYPIDRTXPORTOUTPUTCONTROL3 get ();
    void set (Saa7119TYPIDRTXPORTOUTPUTCONTROL3 value);
}
member RTCOOutputEnable : Saa7119TYPIDRTXPORTOUTPUTCONTROL3 with get, set

Property Value

Type: Saa7119TYPIDRTXPORTOUTPUTCONTROL3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RTS0OUTPUT Property

IRD

Saa7119RTS0OUTPUT Property

RTS0 OUTPUT

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 RTS0OUTPUT { get; set; }
Public Property RTS0OUTPUT As Saa7119TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0
    Get
    Set
public:
property Saa7119TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 RTS0OUTPUT {
    Saa7119TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 get ();
    void set (Saa7119TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 value);
}
member RTS0OUTPUT : Saa7119TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 with get, set

Property Value

Type: Saa7119TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RTS1OUTPUT Property

IRD

Saa7119RTS1OUTPUT Property

RTS1 OUTPUT

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 RTS1OUTPUT { get; set; }
Public Property RTS1OUTPUT As Saa7119TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0
    Get
    Set
public:
property Saa7119TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 RTS1OUTPUT {
    Saa7119TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 get ();
    void set (Saa7119TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 value);
}
member RTS1OUTPUT : Saa7119TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 with get, set

Property Value

Type: Saa7119TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.RTXPortOutputControl Property

IRD

Saa7119RTXPortOutputControl Property

RT/X port output control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDRTXPORTOUTPUTCONTROL01 RTXPortOutputControl { get; set; }
Public Property RTXPortOutputControl As Saa7119TYPIDRTXPORTOUTPUTCONTROL01
    Get
    Set
public:
property Saa7119TYPIDRTXPORTOUTPUTCONTROL01 RTXPortOutputControl {
    Saa7119TYPIDRTXPORTOUTPUTCONTROL01 get ();
    void set (Saa7119TYPIDRTXPORTOUTPUTCONTROL01 value);
}
member RTXPortOutputControl : Saa7119TYPIDRTXPORTOUTPUTCONTROL01 with get, set

Property Value

Type: Saa7119TYPIDRTXPORTOUTPUTCONTROL01
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.Scaler Property

IRD

Saa7119Scaler Property

Scaler

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDADCPORTCONTROLGLOBALSET4 Scaler { get; set; }
Public Property Scaler As Saa7119TYPIDADCPORTCONTROLGLOBALSET4
    Get
    Set
public:
property Saa7119TYPIDADCPORTCONTROLGLOBALSET4 Scaler {
    Saa7119TYPIDADCPORTCONTROLGLOBALSET4 get ();
    void set (Saa7119TYPIDADCPORTCONTROLGLOBALSET4 value);
}
member Scaler : Saa7119TYPIDADCPORTCONTROLGLOBALSET4 with get, set

Property Value

Type: Saa7119TYPIDADCPORTCONTROLGLOBALSET4
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ScalerMode Property

IRD

Saa7119ScalerMode Property

Scaler Mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDADCPORTCONTROLGLOBALSET1 ScalerMode { get; set; }
Public Property ScalerMode As Saa7119TYPIDADCPORTCONTROLGLOBALSET1
    Get
    Set
public:
property Saa7119TYPIDADCPORTCONTROLGLOBALSET1 ScalerMode {
    Saa7119TYPIDADCPORTCONTROLGLOBALSET1 get ();
    void set (Saa7119TYPIDADCPORTCONTROLGLOBALSET1 value);
}
member ScalerMode : Saa7119TYPIDADCPORTCONTROLGLOBALSET1 with get, set

Property Value

Type: Saa7119TYPIDADCPORTCONTROLGLOBALSET1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.SDIDCodes Property

IRD

Saa7119SDIDCodes Property

SDID codes

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SDIDCodes { get; set; }
Public Property SDIDCodes As Byte
    Get
    Set
public:
property unsigned char SDIDCodes {
    unsigned char get ();
    void set (unsigned char value);
}
member SDIDCodes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.SECAMColorKillerLevelControl Property

IRD

Saa7119SECAMColorKillerLevelControl Property

SECAM Color Killer Level Control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDCOLORKILLERLEVELCONTROL0 SECAMColorKillerLevelControl { get; set; }
Public Property SECAMColorKillerLevelControl As Saa7119TYPIDCOLORKILLERLEVELCONTROL0
    Get
    Set
public:
property Saa7119TYPIDCOLORKILLERLEVELCONTROL0 SECAMColorKillerLevelControl {
    Saa7119TYPIDCOLORKILLERLEVELCONTROL0 get ();
    void set (Saa7119TYPIDCOLORKILLERLEVELCONTROL0 value);
}
member SECAMColorKillerLevelControl : Saa7119TYPIDCOLORKILLERLEVELCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDCOLORKILLERLEVELCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.SelectLLC2 Property

IRD

Saa7119SelectLLC2 Property

Select LLC2

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL23 SelectLLC2 { get; set; }
Public Property SelectLLC2 As Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL23
    Get
    Set
public:
property Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL23 SelectLLC2 {
    Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL23 get ();
    void set (Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL23 value);
}
member SelectLLC2 : Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL23 with get, set

Property Value

Type: Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL23
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.SharpnessControl Property

IRD

Saa7119SharpnessControl Property

Sharpness control

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDLUMINANCECONTROL0 SharpnessControl { get; set; }
Public Property SharpnessControl As Saa7119TYPIDLUMINANCECONTROL0
    Get
    Set
public:
property Saa7119TYPIDLUMINANCECONTROL0 SharpnessControl {
    Saa7119TYPIDLUMINANCECONTROL0 get ();
    void set (Saa7119TYPIDLUMINANCECONTROL0 value);
}
member SharpnessControl : Saa7119TYPIDLUMINANCECONTROL0 with get, set

Property Value

Type: Saa7119TYPIDLUMINANCECONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.SignalFedToPort Property

IRD

Saa7119SignalFedToPort Property

Signal fed to port

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDADCPORTCONTROLGLOBALSET01 SignalFedToPort { get; set; }
Public Property SignalFedToPort As Saa7119TYPIDADCPORTCONTROLGLOBALSET01
    Get
    Set
public:
property Saa7119TYPIDADCPORTCONTROLGLOBALSET01 SignalFedToPort {
    Saa7119TYPIDADCPORTCONTROLGLOBALSET01 get ();
    void set (Saa7119TYPIDADCPORTCONTROLGLOBALSET01 value);
}
member SignalFedToPort : Saa7119TYPIDADCPORTCONTROLGLOBALSET01 with get, set

Property Value

Type: Saa7119TYPIDADCPORTCONTROLGLOBALSET01
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.SlicedDataOutputModes Property

IRD

Saa7119SlicedDataOutputModes Property

Sliced data output modes

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SlicedDataOutputModes { get; set; }
Public Property SlicedDataOutputModes As Byte
    Get
    Set
public:
property unsigned char SlicedDataOutputModes {
    unsigned char get ();
    void set (unsigned char value);
}
member SlicedDataOutputModes : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.SlicerStatusBit0 Property

IRD

Saa7119SlicerStatusBit0 Property

Slicer Status Bit0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITBITSDIDCODES1 SlicerStatusBit0 { get; }
Public ReadOnly Property SlicerStatusBit0 As Saa7119TYPIDSLICERSTATUSBITBITSDIDCODES1
    Get
public:
property Saa7119TYPIDSLICERSTATUSBITBITSDIDCODES1 SlicerStatusBit0 {
    Saa7119TYPIDSLICERSTATUSBITBITSDIDCODES1 get ();
}
member SlicerStatusBit0 : Saa7119TYPIDSLICERSTATUSBITBITSDIDCODES1 with get

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITBITSDIDCODES1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.SlicerStatusBit1 Property

IRD

Saa7119SlicerStatusBit1 Property

Slicer Status Bit1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSTATUSBITBITSDIDCODES2 SlicerStatusBit1 { get; }
Public ReadOnly Property SlicerStatusBit1 As Saa7119TYPIDSLICERSTATUSBITBITSDIDCODES2
    Get
public:
property Saa7119TYPIDSLICERSTATUSBITBITSDIDCODES2 SlicerStatusBit1 {
    Saa7119TYPIDSLICERSTATUSBITBITSDIDCODES2 get ();
}
member SlicerStatusBit1 : Saa7119TYPIDSLICERSTATUSBITBITSDIDCODES2 with get

Property Value

Type: Saa7119TYPIDSLICERSTATUSBITBITSDIDCODES2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.StandardDetectionSearchLoopLatency Property

IRD

Saa7119StandardDetectionSearchLoopLatency Property

Standard detection search loop latency

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDMISCELLANEOUSVGATEMSBS1 StandardDetectionSearchLoopLatency { get; set; }
Public Property StandardDetectionSearchLoopLatency As Saa7119TYPIDMISCELLANEOUSVGATEMSBS1
    Get
    Set
public:
property Saa7119TYPIDMISCELLANEOUSVGATEMSBS1 StandardDetectionSearchLoopLatency {
    Saa7119TYPIDMISCELLANEOUSVGATEMSBS1 get ();
    void set (Saa7119TYPIDMISCELLANEOUSVGATEMSBS1 value);
}
member StandardDetectionSearchLoopLatency : Saa7119TYPIDMISCELLANEOUSVGATEMSBS1 with get, set

Property Value

Type: Saa7119TYPIDMISCELLANEOUSVGATEMSBS1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.StatusBitForFieldLength Property

IRD

Saa7119StatusBitForFieldLength Property

Status bit for field length

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSTATUSBYTE1VIDEODECODER6 StatusBitForFieldLength { get; }
Public ReadOnly Property StatusBitForFieldLength As Saa7119TYPIDSTATUSBYTE1VIDEODECODER6
    Get
public:
property Saa7119TYPIDSTATUSBYTE1VIDEODECODER6 StatusBitForFieldLength {
    Saa7119TYPIDSTATUSBYTE1VIDEODECODER6 get ();
}
member StatusBitForFieldLength : Saa7119TYPIDSTATUSBYTE1VIDEODECODER6 with get

Property Value

Type: Saa7119TYPIDSTATUSBYTE1VIDEODECODER6
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.StatusBitForHorizontalAndVerticalLoop Property

IRD

Saa7119StatusBitForHorizontalAndVerticalLoop Property

Status bit for horizontal and vertical loop

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSTATUSBYTE2VIDEODECODER6 StatusBitForHorizontalAndVerticalLoop { get; }
Public ReadOnly Property StatusBitForHorizontalAndVerticalLoop As Saa7119TYPIDSTATUSBYTE2VIDEODECODER6
    Get
public:
property Saa7119TYPIDSTATUSBYTE2VIDEODECODER6 StatusBitForHorizontalAndVerticalLoop {
    Saa7119TYPIDSTATUSBYTE2VIDEODECODER6 get ();
}
member StatusBitForHorizontalAndVerticalLoop : Saa7119TYPIDSTATUSBYTE2VIDEODECODER6 with get

Property Value

Type: Saa7119TYPIDSTATUSBYTE2VIDEODECODER6
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.StatusBitForInterlaceDetection Property

IRD

Saa7119StatusBitForInterlaceDetection Property

Status bit for interlace detection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSTATUSBYTE2VIDEODECODER7 StatusBitForInterlaceDetection { get; }
Public ReadOnly Property StatusBitForInterlaceDetection As Saa7119TYPIDSTATUSBYTE2VIDEODECODER7
    Get
public:
property Saa7119TYPIDSTATUSBYTE2VIDEODECODER7 StatusBitForInterlaceDetection {
    Saa7119TYPIDSTATUSBYTE2VIDEODECODER7 get ();
}
member StatusBitForInterlaceDetection : Saa7119TYPIDSTATUSBYTE2VIDEODECODER7 with get

Property Value

Type: Saa7119TYPIDSTATUSBYTE2VIDEODECODER7
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.StatusBitForLockedHorizontalFrequency Property

IRD

Saa7119StatusBitForLockedHorizontalFrequency Property

Status bit for locked horizontal frequency

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSTATUSBYTE1VIDEODECODER5 StatusBitForLockedHorizontalFrequency { get; }
Public ReadOnly Property StatusBitForLockedHorizontalFrequency As Saa7119TYPIDSTATUSBYTE1VIDEODECODER5
    Get
public:
property Saa7119TYPIDSTATUSBYTE1VIDEODECODER5 StatusBitForLockedHorizontalFrequency {
    Saa7119TYPIDSTATUSBYTE1VIDEODECODER5 get ();
}
member StatusBitForLockedHorizontalFrequency : Saa7119TYPIDSTATUSBYTE1VIDEODECODER5 with get

Property Value

Type: Saa7119TYPIDSTATUSBYTE1VIDEODECODER5
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.StatusBitForTimebaseOfInputSignal Property

IRD

Saa7119StatusBitForTimebaseOfInputSignal Property

Status bit for timebase of input signal

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSTATUSBYTE2VIDEODECODER4 StatusBitForTimebaseOfInputSignal { get; }
Public ReadOnly Property StatusBitForTimebaseOfInputSignal As Saa7119TYPIDSTATUSBYTE2VIDEODECODER4
    Get
public:
property Saa7119TYPIDSTATUSBYTE2VIDEODECODER4 StatusBitForTimebaseOfInputSignal {
    Saa7119TYPIDSTATUSBYTE2VIDEODECODER4 get ();
}
member StatusBitForTimebaseOfInputSignal : Saa7119TYPIDSTATUSBYTE2VIDEODECODER4 with get

Property Value

Type: Saa7119TYPIDSTATUSBYTE2VIDEODECODER4
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.StatusOfTheFieldSequenceIDAtTheScalersInput Property

IRD

Saa7119StatusOfTheFieldSequenceIDAtTheScalersInput Property

Status of the field sequence ID at the scalers input

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte StatusOfTheFieldSequenceIDAtTheScalersInput { get; }
Public ReadOnly Property StatusOfTheFieldSequenceIDAtTheScalersInput As Byte
    Get
public:
property unsigned char StatusOfTheFieldSequenceIDAtTheScalersInput {
    unsigned char get ();
}
member StatusOfTheFieldSequenceIDAtTheScalersInput : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.StatusOfTheFieldSequenceIDAtTheScalersOutputScalerProcessingDependent Property

IRD

Saa7119StatusOfTheFieldSequenceIDAtTheScalersOutputScalerProcessingDependent Property

Status of the field sequence ID at the scalers output, scaler processing dependent

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte StatusOfTheFieldSequenceIDAtTheScalersOutputScalerProcessingDependent { get; }
Public ReadOnly Property StatusOfTheFieldSequenceIDAtTheScalersOutputScalerProcessingDependent As Byte
    Get
public:
property unsigned char StatusOfTheFieldSequenceIDAtTheScalersOutputScalerProcessingDependent {
    unsigned char get ();
}
member StatusOfTheFieldSequenceIDAtTheScalersOutputScalerProcessingDependent : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.StatusOfTheInternalFIFOAlmostFilledFlag Property

IRD

Saa7119StatusOfTheInternalFIFOAlmostFilledFlag Property

Status of the internal 'FIFO almost filled' flag

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte StatusOfTheInternalFIFOAlmostFilledFlag { get; }
Public ReadOnly Property StatusOfTheInternalFIFOAlmostFilledFlag As Byte
    Get
public:
property unsigned char StatusOfTheInternalFIFOAlmostFilledFlag {
    unsigned char get ();
}
member StatusOfTheInternalFIFOAlmostFilledFlag : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.StatusOfTheInternalFIFOOverflowFlag Property

IRD

Saa7119StatusOfTheInternalFIFOOverflowFlag Property

Status of the internal 'FIFO overflow' flag

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte StatusOfTheInternalFIFOOverflowFlag { get; }
Public ReadOnly Property StatusOfTheInternalFIFOOverflowFlag As Byte
    Get
public:
property unsigned char StatusOfTheInternalFIFOOverflowFlag {
    unsigned char get ();
}
member StatusOfTheInternalFIFOOverflowFlag : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.StatusOnInputPinITRIIfNotUsedFor3StateControlUsableAsHardwareFlagForSoftwareUse Property

IRD

Saa7119StatusOnInputPinITRIIfNotUsedFor3StateControlUsableAsHardwareFlagForSoftwareUse Property

Status on input pin ITRI, if not used for 3-state control, usable as hardware flag for software use

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte StatusOnInputPinITRIIfNotUsedFor3StateControlUsableAsHardwareFlagForSoftwareUse { get; }
Public ReadOnly Property StatusOnInputPinITRIIfNotUsedFor3StateControlUsableAsHardwareFlagForSoftwareUse As Byte
    Get
public:
property unsigned char StatusOnInputPinITRIIfNotUsedFor3StateControlUsableAsHardwareFlagForSoftwareUse {
    unsigned char get ();
}
member StatusOnInputPinITRIIfNotUsedFor3StateControlUsableAsHardwareFlagForSoftwareUse : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.StatusOnInputPinXTRIIfNotUsedFor3StateControlUsableAsHardwareFlagForSoftwareUse Property

IRD

Saa7119StatusOnInputPinXTRIIfNotUsedFor3StateControlUsableAsHardwareFlagForSoftwareUse Property

Status on input pin XTRI, if not used for 3-state control, usable as hardware flag for software use

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte StatusOnInputPinXTRIIfNotUsedFor3StateControlUsableAsHardwareFlagForSoftwareUse { get; }
Public ReadOnly Property StatusOnInputPinXTRIIfNotUsedFor3StateControlUsableAsHardwareFlagForSoftwareUse As Byte
    Get
public:
property unsigned char StatusOnInputPinXTRIIfNotUsedFor3StateControlUsableAsHardwareFlagForSoftwareUse {
    unsigned char get ();
}
member StatusOnInputPinXTRIIfNotUsedFor3StateControlUsableAsHardwareFlagForSoftwareUse : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.SwapDataAssigmentsForPortsHPDAndIXDAllowsXPDAndHPDPortsToBeUsedAsYUVInputPath Property

IRD

Saa7119SwapDataAssigmentsForPortsHPDAndIXDAllowsXPDAndHPDPortsToBeUsedAsYUVInputPath Property

Swap Data Assigments for Ports HPD and IXD (allows XPD and HPD ports to be used as YUV input path)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS4 SwapDataAssigmentsForPortsHPDAndIXDAllowsXPDAndHPDPortsToBeUsedAsYUVInputPath { get; set; }
Public Property SwapDataAssigmentsForPortsHPDAndIXDAllowsXPDAndHPDPortsToBeUsedAsYUVInputPath As Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS4
    Get
    Set
public:
property Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS4 SwapDataAssigmentsForPortsHPDAndIXDAllowsXPDAndHPDPortsToBeUsedAsYUVInputPath {
    Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS4 get ();
    void set (Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS4 value);
}
member SwapDataAssigmentsForPortsHPDAndIXDAllowsXPDAndHPDPortsToBeUsedAsYUVInputPath : Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS4 with get, set

Property Value

Type: Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS4
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.TaskOfRegisterSetA Property

IRD

Saa7119TaskOfRegisterSetA Property

Task of register set A

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable TaskOfRegisterSetA { get; set; }
Public Property TaskOfRegisterSetA As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable TaskOfRegisterSetA {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member TaskOfRegisterSetA : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.TaskOfRegisterSetB Property

IRD

Saa7119TaskOfRegisterSetB Property

Task of register set B

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119IDEnableDisable TaskOfRegisterSetB { get; set; }
Public Property TaskOfRegisterSetB As Saa7119IDEnableDisable
    Get
    Set
public:
property Saa7119IDEnableDisable TaskOfRegisterSetB {
    Saa7119IDEnableDisable get ();
    void set (Saa7119IDEnableDisable value);
}
member TaskOfRegisterSetB : Saa7119IDEnableDisable with get, set

Property Value

Type: Saa7119IDEnableDisable
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ThresholdForFASTConditionInPixelClocks Property

IRD

Saa7119ThresholdForFASTConditionInPixelClocks Property

Threshold for FAST condition in pixel clocks

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDFASTSWITCHCONTROL12 ThresholdForFASTConditionInPixelClocks { get; set; }
Public Property ThresholdForFASTConditionInPixelClocks As Saa7119TYPIDFASTSWITCHCONTROL12
    Get
    Set
public:
property Saa7119TYPIDFASTSWITCHCONTROL12 ThresholdForFASTConditionInPixelClocks {
    Saa7119TYPIDFASTSWITCHCONTROL12 get ();
    void set (Saa7119TYPIDFASTSWITCHCONTROL12 value);
}
member ThresholdForFASTConditionInPixelClocks : Saa7119TYPIDFASTSWITCHCONTROL12 with get, set

Property Value

Type: Saa7119TYPIDFASTSWITCHCONTROL12
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ThresholdForWIDTHConditionInPixelClocks Property

IRD

Saa7119ThresholdForWIDTHConditionInPixelClocks Property

Threshold for WIDTH condition in pixel clocks

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDFASTSWITCHCONTROL12 ThresholdForWIDTHConditionInPixelClocks { get; set; }
Public Property ThresholdForWIDTHConditionInPixelClocks As Saa7119TYPIDFASTSWITCHCONTROL12
    Get
    Set
public:
property Saa7119TYPIDFASTSWITCHCONTROL12 ThresholdForWIDTHConditionInPixelClocks {
    Saa7119TYPIDFASTSWITCHCONTROL12 get ();
    void set (Saa7119TYPIDFASTSWITCHCONTROL12 value);
}
member ThresholdForWIDTHConditionInPixelClocks : Saa7119TYPIDFASTSWITCHCONTROL12 with get, set

Property Value

Type: Saa7119TYPIDFASTSWITCHCONTROL12
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.TimingGridForTheShiftOfTheOutputPositionLeftSlopeInKeystoneMode Property

IRD

Saa7119TimingGridForTheShiftOfTheOutputPositionLeftSlopeInKeystoneMode Property

Timing Grid for the shift of the output position (left slope) in keystone mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDPANORAMAANDKEYSTONING3 TimingGridForTheShiftOfTheOutputPositionLeftSlopeInKeystoneMode { get; set; }
Public Property TimingGridForTheShiftOfTheOutputPositionLeftSlopeInKeystoneMode As Saa7119TYPIDPANORAMAANDKEYSTONING3
    Get
    Set
public:
property Saa7119TYPIDPANORAMAANDKEYSTONING3 TimingGridForTheShiftOfTheOutputPositionLeftSlopeInKeystoneMode {
    Saa7119TYPIDPANORAMAANDKEYSTONING3 get ();
    void set (Saa7119TYPIDPANORAMAANDKEYSTONING3 value);
}
member TimingGridForTheShiftOfTheOutputPositionLeftSlopeInKeystoneMode : Saa7119TYPIDPANORAMAANDKEYSTONING3 with get, set

Property Value

Type: Saa7119TYPIDPANORAMAANDKEYSTONING3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.UOffset14LSB Property

IRD

Saa7119UOffset14LSB Property

U offset (1/4 LSB)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte UOffset14LSB { get; set; }
Public Property UOffset14LSB As SByte
    Get
    Set
public:
property signed char UOffset14LSB {
    signed char get ();
    void set (signed char value);
}
member UOffset14LSB : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.ValueSubtractToCentre Property

IRD

Saa7119ValueSubtractToCentre Property

Value subtract to centre

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ValueSubtractToCentre { get; set; }
Public Property ValueSubtractToCentre As Byte
    Get
    Set
public:
property unsigned char ValueSubtractToCentre {
    unsigned char get ();
    void set (unsigned char value);
}
member ValueSubtractToCentre : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.VerticalDifferenceGain Property

IRD

Saa7119VerticalDifferenceGain Property

Vertical difference gain

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL11 VerticalDifferenceGain { get; set; }
Public Property VerticalDifferenceGain As Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL11
    Get
    Set
public:
property Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL11 VerticalDifferenceGain {
    Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL11 get ();
    void set (Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL11 value);
}
member VerticalDifferenceGain : Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL11 with get, set

Property Value

Type: Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL11
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.VerticalDifferenceThreshold Property

IRD

Saa7119VerticalDifferenceThreshold Property

Vertical difference threshold

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL20 VerticalDifferenceThreshold { get; set; }
Public Property VerticalDifferenceThreshold As Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL20
    Get
    Set
public:
property Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL20 VerticalDifferenceThreshold {
    Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL20 get ();
    void set (Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL20 value);
}
member VerticalDifferenceThreshold : Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL20 with get, set

Property Value

Type: Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL20
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.VerticalNoiseReduction Property

IRD

Saa7119VerticalNoiseReduction Property

Vertical noise reduction

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSYNCCONTROL0 VerticalNoiseReduction { get; set; }
Public Property VerticalNoiseReduction As Saa7119TYPIDSYNCCONTROL0
    Get
    Set
public:
property Saa7119TYPIDSYNCCONTROL0 VerticalNoiseReduction {
    Saa7119TYPIDSYNCCONTROL0 get ();
    void set (Saa7119TYPIDSYNCCONTROL0 value);
}
member VerticalNoiseReduction : Saa7119TYPIDSYNCCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDSYNCCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.VerticalNoiseReductionReset Property

IRD

Saa7119VerticalNoiseReductionReset Property

Vertical noise reduction reset

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION3 VerticalNoiseReductionReset { get; set; }
Public Property VerticalNoiseReductionReset As Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION3
    Get
    Set
public:
property Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION3 VerticalNoiseReductionReset {
    Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION3 get ();
    void set (Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION3 value);
}
member VerticalNoiseReductionReset : Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION3 with get, set

Property Value

Type: Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.VerticalOffsetForSlicer Property

IRD

Saa7119VerticalOffsetForSlicer Property

Vertical offset for slicer

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VerticalOffsetForSlicer { get; set; }
Public Property VerticalOffsetForSlicer As UShort
    Get
    Set
public:
property unsigned short VerticalOffsetForSlicer {
    unsigned short get ();
    void set (unsigned short value);
}
member VerticalOffsetForSlicer : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.VerticalPLLDisable Property

IRD

Saa7119VerticalPLLDisable Property

Vertical PLL disable

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL24 VerticalPLLDisable { get; set; }
Public Property VerticalPLLDisable As Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL24
    Get
    Set
public:
property Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL24 VerticalPLLDisable {
    Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL24 get ();
    void set (Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL24 value);
}
member VerticalPLLDisable : Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL24 with get, set

Property Value

Type: Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL24
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.VerticalSyncAndFieldIDSourceSelection Property

IRD

Saa7119VerticalSyncAndFieldIDSourceSelection Property

Vertical sync and Field ID source selection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS0 VerticalSyncAndFieldIDSourceSelection { get; set; }
Public Property VerticalSyncAndFieldIDSourceSelection As Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS0
    Get
    Set
public:
property Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS0 VerticalSyncAndFieldIDSourceSelection {
    Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS0 get ();
    void set (Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS0 value);
}
member VerticalSyncAndFieldIDSourceSelection : Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS0 with get, set

Property Value

Type: Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.VerticalTriggerEdge Property

IRD

Saa7119VerticalTriggerEdge Property

Vertical trigger edge

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDFIELDOFFSETANDERTICALOFFSETS0 VerticalTriggerEdge { get; set; }
Public Property VerticalTriggerEdge As Saa7119TYPIDFIELDOFFSETANDERTICALOFFSETS0
    Get
    Set
public:
property Saa7119TYPIDFIELDOFFSETANDERTICALOFFSETS0 VerticalTriggerEdge {
    Saa7119TYPIDFIELDOFFSETANDERTICALOFFSETS0 get ();
    void set (Saa7119TYPIDFIELDOFFSETANDERTICALOFFSETS0 value);
}
member VerticalTriggerEdge : Saa7119TYPIDFIELDOFFSETANDERTICALOFFSETS0 with get, set

Property Value

Type: Saa7119TYPIDFIELDOFFSETANDERTICALOFFSETS0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.VGATEStart Property

IRD

Saa7119VGATEStart Property

VGATE start

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDVGATESTART0 VGATEStart { get; set; }
Public Property VGATEStart As Saa7119TYPIDVGATESTART0
    Get
    Set
public:
property Saa7119TYPIDVGATESTART0 VGATEStart {
    Saa7119TYPIDVGATESTART0 get ();
    void set (Saa7119TYPIDVGATESTART0 value);
}
member VGATEStart : Saa7119TYPIDVGATESTART0 with get, set

Property Value

Type: Saa7119TYPIDVGATESTART0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.VGATEStop Property

IRD

Saa7119VGATEStop Property

VGATE stop

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDVGATESTART0 VGATEStop { get; set; }
Public Property VGATEStop As Saa7119TYPIDVGATESTART0
    Get
    Set
public:
property Saa7119TYPIDVGATESTART0 VGATEStop {
    Saa7119TYPIDVGATESTART0 get ();
    void set (Saa7119TYPIDVGATESTART0 value);
}
member VGATEStop : Saa7119TYPIDVGATESTART0 with get, set

Property Value

Type: Saa7119TYPIDVGATESTART0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.VOffset14LSB Property

IRD

Saa7119VOffset14LSB Property

V Offset (1/4 LSB)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte VOffset14LSB { get; set; }
Public Property VOffset14LSB As SByte
    Get
    Set
public:
property signed char VOffset14LSB {
    signed char get ();
    void set (signed char value);
}
member VOffset14LSB : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.WIDTHCondition Property

IRD

Saa7119WIDTHCondition Property

WIDTH condition

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WIDTHCondition { get; set; }
Public Property WIDTHCondition As Byte
    Get
    Set
public:
property unsigned char WIDTHCondition {
    unsigned char get ();
    void set (unsigned char value);
}
member WIDTHCondition : byte with get, set

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.WPOFF Property

IRD

Saa7119WPOFF Property

WPOFF

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDHORIZONTALINCREMENTDELAY2 WPOFF { get; set; }
Public Property WPOFF As Saa7119TYPIDHORIZONTALINCREMENTDELAY2
    Get
    Set
public:
property Saa7119TYPIDHORIZONTALINCREMENTDELAY2 WPOFF {
    Saa7119TYPIDHORIZONTALINCREMENTDELAY2 get ();
    void set (Saa7119TYPIDHORIZONTALINCREMENTDELAY2 value);
}
member WPOFF : Saa7119TYPIDHORIZONTALINCREMENTDELAY2 with get, set

Property Value

Type: Saa7119TYPIDHORIZONTALINCREMENTDELAY2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.WSS525CRCCodeCheck Property

IRD

Saa7119WSS525CRCCodeCheck Property

WSS525 CRC code check

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDSLICERSET3 WSS525CRCCodeCheck { get; set; }
Public Property WSS525CRCCodeCheck As Saa7119TYPIDSLICERSET3
    Get
    Set
public:
property Saa7119TYPIDSLICERSET3 WSS525CRCCodeCheck {
    Saa7119TYPIDSLICERSET3 get ();
    void set (Saa7119TYPIDSLICERSET3 value);
}
member WSS525CRCCodeCheck : Saa7119TYPIDSLICERSET3 with get, set

Property Value

Type: Saa7119TYPIDSLICERSET3
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.WSSHeaderEvenFieldBeingUpdated Property

IRD

Saa7119WSSHeaderEvenFieldBeingUpdated Property

WSS-header: even field: being updated

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WSSHeaderEvenFieldBeingUpdated { get; }
Public ReadOnly Property WSSHeaderEvenFieldBeingUpdated As Byte
    Get
public:
property unsigned char WSSHeaderEvenFieldBeingUpdated {
    unsigned char get ();
}
member WSSHeaderEvenFieldBeingUpdated : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.WSSHeaderEvenFieldDataErroneous Property

IRD

Saa7119WSSHeaderEvenFieldDataErroneous Property

WSS-header: even field: data erroneous

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WSSHeaderEvenFieldDataErroneous { get; }
Public ReadOnly Property WSSHeaderEvenFieldDataErroneous As Byte
    Get
public:
property unsigned char WSSHeaderEvenFieldDataErroneous {
    unsigned char get ();
}
member WSSHeaderEvenFieldDataErroneous : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.WSSHeaderFreeRunningFieldCounter Property

IRD

Saa7119WSSHeaderFreeRunningFieldCounter Property

WSS-header: free running field counter

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WSSHeaderFreeRunningFieldCounter { get; }
Public ReadOnly Property WSSHeaderFreeRunningFieldCounter As Byte
    Get
public:
property unsigned char WSSHeaderFreeRunningFieldCounter {
    unsigned char get ();
}
member WSSHeaderFreeRunningFieldCounter : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.WSSHeaderOddFieldBeingUpdated Property

IRD

Saa7119WSSHeaderOddFieldBeingUpdated Property

WSS-header: odd field: being updated

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WSSHeaderOddFieldBeingUpdated { get; }
Public ReadOnly Property WSSHeaderOddFieldBeingUpdated As Byte
    Get
public:
property unsigned char WSSHeaderOddFieldBeingUpdated {
    unsigned char get ();
}
member WSSHeaderOddFieldBeingUpdated : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.WSSHeaderOddFieldDataErroneous Property

IRD

Saa7119WSSHeaderOddFieldDataErroneous Property

WSS-header: odd field: data erroneous

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WSSHeaderOddFieldDataErroneous { get; }
Public ReadOnly Property WSSHeaderOddFieldDataErroneous As Byte
    Get
public:
property unsigned char WSSHeaderOddFieldDataErroneous {
    unsigned char get ();
}
member WSSHeaderOddFieldDataErroneous : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.WSSI2CReadback1EvenFields Property

IRD

Saa7119WSSI2CReadback1EvenFields Property

WSS I2C readback 1 (even fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WSSI2CReadback1EvenFields { get; }
Public ReadOnly Property WSSI2CReadback1EvenFields As Byte
    Get
public:
property unsigned char WSSI2CReadback1EvenFields {
    unsigned char get ();
}
member WSSI2CReadback1EvenFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.WSSI2CReadback1OddFields Property

IRD

Saa7119WSSI2CReadback1OddFields Property

WSS I2C readback 1 (odd fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WSSI2CReadback1OddFields { get; }
Public ReadOnly Property WSSI2CReadback1OddFields As Byte
    Get
public:
property unsigned char WSSI2CReadback1OddFields {
    unsigned char get ();
}
member WSSI2CReadback1OddFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.WSSI2CReadback2EvenFields Property

IRD

Saa7119WSSI2CReadback2EvenFields Property

WSS I2C readback 2 (even fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WSSI2CReadback2EvenFields { get; }
Public ReadOnly Property WSSI2CReadback2EvenFields As Byte
    Get
public:
property unsigned char WSSI2CReadback2EvenFields {
    unsigned char get ();
}
member WSSI2CReadback2EvenFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.WSSI2CReadback2OddFields Property

IRD

Saa7119WSSI2CReadback2OddFields Property

WSS I2C readback 2 (odd fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WSSI2CReadback2OddFields { get; }
Public ReadOnly Property WSSI2CReadback2OddFields As Byte
    Get
public:
property unsigned char WSSI2CReadback2OddFields {
    unsigned char get ();
}
member WSSI2CReadback2OddFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.WSSI2CReadback3EvenFields Property

IRD

Saa7119WSSI2CReadback3EvenFields Property

WSS I2C readback 3 (even fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WSSI2CReadback3EvenFields { get; }
Public ReadOnly Property WSSI2CReadback3EvenFields As Byte
    Get
public:
property unsigned char WSSI2CReadback3EvenFields {
    unsigned char get ();
}
member WSSI2CReadback3EvenFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.WSSI2CReadback3OddFields Property

IRD

Saa7119WSSI2CReadback3OddFields Property

WSS I2C readback 3 (odd fields)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WSSI2CReadback3OddFields { get; }
Public ReadOnly Property WSSI2CReadback3OddFields As Byte
    Get
public:
property unsigned char WSSI2CReadback3OddFields {
    unsigned char get ();
}
member WSSI2CReadback3OddFields : byte with get

Property Value

Type: Byte
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.XPortOutput Property

IRD

Saa7119XPortOutput Property

X-port output

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDXPORTIOENABLEKPHASECONTROL0 XPortOutput { get; set; }
Public Property XPortOutput As Saa7119TYPIDXPORTIOENABLEKPHASECONTROL0
    Get
    Set
public:
property Saa7119TYPIDXPORTIOENABLEKPHASECONTROL0 XPortOutput {
    Saa7119TYPIDXPORTIOENABLEKPHASECONTROL0 get ();
    void set (Saa7119TYPIDXPORTIOENABLEKPHASECONTROL0 value);
}
member XPortOutput : Saa7119TYPIDXPORTIOENABLEKPHASECONTROL0 with get, set

Property Value

Type: Saa7119TYPIDXPORTIOENABLEKPHASECONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.XPortOutputIsEnabledByPinXTRIAt Property

IRD

Saa7119XPortOutputIsEnabledByPinXTRIAt Property

X-port output is enabled by pin XTRI at:

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDXPORTIOENABLEKPHASECONTROL1 XPortOutputIsEnabledByPinXTRIAt { get; set; }
Public Property XPortOutputIsEnabledByPinXTRIAt As Saa7119TYPIDXPORTIOENABLEKPHASECONTROL1
    Get
    Set
public:
property Saa7119TYPIDXPORTIOENABLEKPHASECONTROL1 XPortOutputIsEnabledByPinXTRIAt {
    Saa7119TYPIDXPORTIOENABLEKPHASECONTROL1 get ();
    void set (Saa7119TYPIDXPORTIOENABLEKPHASECONTROL1 value);
}
member XPortOutputIsEnabledByPinXTRIAt : Saa7119TYPIDXPORTIOENABLEKPHASECONTROL1 with get, set

Property Value

Type: Saa7119TYPIDXPORTIOENABLEKPHASECONTROL1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.XPortSignalDefinitionsIDQ Property

IRD

Saa7119XPortSignalDefinitionsIDQ Property

X-port signal definitions: IDQ

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 XPortSignalDefinitionsIDQ { get; set; }
Public Property XPortSignalDefinitionsIDQ As Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0
    Get
    Set
public:
property Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 XPortSignalDefinitionsIDQ {
    Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 get ();
    void set (Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 value);
}
member XPortSignalDefinitionsIDQ : Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 with get, set

Property Value

Type: Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.XPortSignalDefinitionsIGP0 Property

IRD

Saa7119XPortSignalDefinitionsIGP0 Property

X-port signal definitions: IGP0

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 XPortSignalDefinitionsIGP0 { get; set; }
Public Property XPortSignalDefinitionsIGP0 As Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0
    Get
    Set
public:
property Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 XPortSignalDefinitionsIGP0 {
    Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 get ();
    void set (Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 value);
}
member XPortSignalDefinitionsIGP0 : Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 with get, set

Property Value

Type: Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.XPortSignalDefinitionsIGP1 Property

IRD

Saa7119XPortSignalDefinitionsIGP1 Property

X-port signal definitions: IGP1

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 XPortSignalDefinitionsIGP1 { get; set; }
Public Property XPortSignalDefinitionsIGP1 As Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0
    Get
    Set
public:
property Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 XPortSignalDefinitionsIGP1 {
    Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 get ();
    void set (Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 value);
}
member XPortSignalDefinitionsIGP1 : Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 with get, set

Property Value

Type: Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.XPortSignalDefinitionsIGPH Property

IRD

Saa7119XPortSignalDefinitionsIGPH Property

X-port signal definitions: IGPH

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 XPortSignalDefinitionsIGPH { get; set; }
Public Property XPortSignalDefinitionsIGPH As Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0
    Get
    Set
public:
property Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 XPortSignalDefinitionsIGPH {
    Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 get ();
    void set (Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 value);
}
member XPortSignalDefinitionsIGPH : Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 with get, set

Property Value

Type: Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.XPortSignalDefinitionsIGPV Property

IRD

Saa7119XPortSignalDefinitionsIGPV Property

X-port signal definitions: IGPV

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 XPortSignalDefinitionsIGPV { get; set; }
Public Property XPortSignalDefinitionsIGPV As Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0
    Get
    Set
public:
property Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 XPortSignalDefinitionsIGPV {
    Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 get ();
    void set (Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 value);
}
member XPortSignalDefinitionsIGPV : Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 with get, set

Property Value

Type: Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.XPortXRHOutputSelection Property

IRD

Saa7119XPortXRHOutputSelection Property

X port XRH output selection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDRTXPORTOUTPUTCONTROL2 XPortXRHOutputSelection { get; set; }
Public Property XPortXRHOutputSelection As Saa7119TYPIDRTXPORTOUTPUTCONTROL2
    Get
    Set
public:
property Saa7119TYPIDRTXPORTOUTPUTCONTROL2 XPortXRHOutputSelection {
    Saa7119TYPIDRTXPORTOUTPUTCONTROL2 get ();
    void set (Saa7119TYPIDRTXPORTOUTPUTCONTROL2 value);
}
member XPortXRHOutputSelection : Saa7119TYPIDRTXPORTOUTPUTCONTROL2 with get, set

Property Value

Type: Saa7119TYPIDRTXPORTOUTPUTCONTROL2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.XPortXRVOutputSelection Property

IRD

Saa7119XPortXRVOutputSelection Property

X port XRV output selection

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDRTXPORTOUTPUTCONTROL1 XPortXRVOutputSelection { get; set; }
Public Property XPortXRVOutputSelection As Saa7119TYPIDRTXPORTOUTPUTCONTROL1
    Get
    Set
public:
property Saa7119TYPIDRTXPORTOUTPUTCONTROL1 XPortXRVOutputSelection {
    Saa7119TYPIDRTXPORTOUTPUTCONTROL1 get ();
    void set (Saa7119TYPIDRTXPORTOUTPUTCONTROL1 value);
}
member XPortXRVOutputSelection : Saa7119TYPIDRTXPORTOUTPUTCONTROL1 with get, set

Property Value

Type: Saa7119TYPIDRTXPORTOUTPUTCONTROL1
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.XRDYOutputSignalIs Property

IRD

Saa7119XRDYOutputSignalIs Property

XRDY output signal is

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDXPORTIOENABLEKPHASECONTROL2 XRDYOutputSignalIs { get; set; }
Public Property XRDYOutputSignalIs As Saa7119TYPIDXPORTIOENABLEKPHASECONTROL2
    Get
    Set
public:
property Saa7119TYPIDXPORTIOENABLEKPHASECONTROL2 XRDYOutputSignalIs {
    Saa7119TYPIDXPORTIOENABLEKPHASECONTROL2 get ();
    void set (Saa7119TYPIDXPORTIOENABLEKPHASECONTROL2 value);
}
member XRDYOutputSignalIs : Saa7119TYPIDXPORTIOENABLEKPHASECONTROL2 with get, set

Property Value

Type: Saa7119TYPIDXPORTIOENABLEKPHASECONTROL2
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.XTOUTOutputEnable Property

IRD

Saa7119XTOUTOutputEnable Property

XTOUT output enable

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Saa7119TYPIDANALOGADCAUTOCIBILITYCONTROL0 XTOUTOutputEnable { get; set; }
Public Property XTOUTOutputEnable As Saa7119TYPIDANALOGADCAUTOCIBILITYCONTROL0
    Get
    Set
public:
property Saa7119TYPIDANALOGADCAUTOCIBILITYCONTROL0 XTOUTOutputEnable {
    Saa7119TYPIDANALOGADCAUTOCIBILITYCONTROL0 get ();
    void set (Saa7119TYPIDANALOGADCAUTOCIBILITYCONTROL0 value);
}
member XTOUTOutputEnable : Saa7119TYPIDANALOGADCAUTOCIBILITYCONTROL0 with get, set

Property Value

Type: Saa7119TYPIDANALOGADCAUTOCIBILITYCONTROL0
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119 Methods

The Saa7119 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.Flush Method

IRD

Saa7119Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Saa7119 Class
telos.Ird.NXPSemiconductors Namespace


Saa7119.IDEnableDisable Enumeration

IRD

Saa7119IDEnableDisable Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IDEnableDisable
Public Enumeration IDEnableDisable
public enum class IDEnableDisable
type IDEnableDisable
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.IDNotActiveActive Enumeration

IRD

Saa7119IDNotActiveActive Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IDNotActiveActive
Public Enumeration IDNotActiveActive
public enum class IDNotActiveActive
type IDNotActiveActive
Members
Member name | Value | Description
NotActive | 0 | Not active
Active | 1 | Active
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDADCPORTCONTROLGLOBALSET0 Enumeration

IRD

Saa7119TYPIDADCPORTCONTROLGLOBALSET0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDADCPORTCONTROLGLOBALSET0
Public Enumeration TYPIDADCPORTCONTROLGLOBALSET0
public enum class TYPIDADCPORTCONTROLGLOBALSET0
type TYPIDADCPORTCONTROLGLOBALSET0
Members
Member name | Value | Description
OperationalMode | 0 | Operational mode
PowerDownMode | 1 | Power-down mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDADCPORTCONTROLGLOBALSET01 Enumeration

IRD

Saa7119TYPIDADCPORTCONTROLGLOBALSET01 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDADCPORTCONTROLGLOBALSET01
Public Enumeration TYPIDADCPORTCONTROLGLOBALSET01
public enum class TYPIDADCPORTCONTROLGLOBALSET01
type TYPIDADCPORTCONTROLGLOBALSET01
Members
Member name | Value | Description
DigitizedADC1 | 0 | Digitized ADC1
DigitizedADC2 | 1 | Digitized ADC2
DigitizedADC3 | 2 | Digitized ADC3
DigitizedADC4 | 3 | Digitized ADC4
Signal0ADISD321 | 4 | Signal {0, ADISD3, 2, 1}
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDADCPORTCONTROLGLOBALSET1 Enumeration

IRD

Saa7119TYPIDADCPORTCONTROLGLOBALSET1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDADCPORTCONTROLGLOBALSET1
Public Enumeration TYPIDADCPORTCONTROLGLOBALSET1
public enum class TYPIDADCPORTCONTROLGLOBALSET1
type TYPIDADCPORTCONTROLGLOBALSET1
Members
Member name | Value | Description
OperationalMode | 0 | Operational mode
PowerDownMode | 1 | Power-down mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDADCPORTCONTROLGLOBALSET2 Enumeration

IRD

Saa7119TYPIDADCPORTCONTROLGLOBALSET2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDADCPORTCONTROLGLOBALSET2
Public Enumeration TYPIDADCPORTCONTROLGLOBALSET2
public enum class TYPIDADCPORTCONTROLGLOBALSET2
type TYPIDADCPORTCONTROLGLOBALSET2
Members
Member name | Value | Description
Active | 0 | Active
PowerDownAndOutputDisabled | 1 | Power-down and output disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDADCPORTCONTROLGLOBALSET3 Enumeration

IRD

Saa7119TYPIDADCPORTCONTROLGLOBALSET3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDADCPORTCONTROLGLOBALSET3
Public Enumeration TYPIDADCPORTCONTROLGLOBALSET3
public enum class TYPIDADCPORTCONTROLGLOBALSET3
type TYPIDADCPORTCONTROLGLOBALSET3
Members
Member name | Value | Description
Value_0AfterReset | 0 | =0 after reset
Value_1CanBeUsedToAssignThatTheDeviceHasBeenProgrammed | 1 | =1 can be used to assign that the device has been programmed
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDADCPORTCONTROLGLOBALSET4 Enumeration

IRD

Saa7119TYPIDADCPORTCONTROLGLOBALSET4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDADCPORTCONTROLGLOBALSET4
Public Enumeration TYPIDADCPORTCONTROLGLOBALSET4
public enum class TYPIDADCPORTCONTROLGLOBALSET4
type TYPIDADCPORTCONTROLGLOBALSET4
Members
Member name | Value | Description
PathIsResetToItsIdleStateSoftwareReset | 0 | Path is reset to its idle state/software reset
SwitchedBackToOperation | 1 | Switched back to operation
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDANALOGADCAUTOCIBILITYCONTROL0 Enumeration

IRD

Saa7119TYPIDANALOGADCAUTOCIBILITYCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGADCAUTOCIBILITYCONTROL0
Public Enumeration TYPIDANALOGADCAUTOCIBILITYCONTROL0
public enum class TYPIDANALOGADCAUTOCIBILITYCONTROL0
type TYPIDANALOGADCAUTOCIBILITYCONTROL0
Members
Member name | Value | Description
Value_3Stated | 0 | 3-stated
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDANALOGADCAUTOCIBILITYCONTROL1 Enumeration

IRD

Saa7119TYPIDANALOGADCAUTOCIBILITYCONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGADCAUTOCIBILITYCONTROL1
Public Enumeration TYPIDANALOGADCAUTOCIBILITYCONTROL1
public enum class TYPIDANALOGADCAUTOCIBILITYCONTROL1
type TYPIDANALOGADCAUTOCIBILITYCONTROL1
Members
Member name | Value | Description
AOUT1ConnectedToGround | 0 | AOUT1 connected to ground
AOUT1ConnectedToInputOfADC1 | 1 | AOUT1 connected to input of ADC1
AOUT1ConnectedToInputOfADC2 | 2 | AOUT1 connected to input of ADC2
AOUT1ConnectedToInputOfADC3 | 3 | AOUT1 connected to input of ADC3
AOUT1ConnectedToInputOfAD4 | 4 | AOUT1 connected to input of AD4
AOUT1ConnectedToInternalTestPointBpfoutCgc1 | 5 | AOUT1 connected to internal test point bpfout cgc 1
AOUT1ConnectedToInternalTestPointBpfoutCgc2 | 6 | AOUT1 connected to internal test point bpfout cgc 2
AOUT1ConnectedToInternalTestPointVref | 7 | AOUT1 connected to internal test point vref
AOUT1ConnectedToInputAI21 | 8 | AOUT1 connected to input AI21
AOUT1ConnectedToInputAI22 | 9 | AOUT1 connected to input AI22
AOUT1ConnectedToInputAI23 | 10 | AOUT1 connected to input AI23
AOUT1ConnectedToInputAI24 | 11 | AOUT1 connected to input AI24
AOUT1ConnectedToInputAI11 | 12 | AOUT1 connected to input AI11
AOUT1ConnectedToInputAI12 | 13 | AOUT1 connected to input AI12
AOUT1ConnectedToInputAI13 | 14 | AOUT1 connected to input AI13
AOUT1ConnectedToInputAI14 | 15 | AOUT1 connected to input AI14
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDANALOGINPUTCONTROL10 Enumeration

IRD

Saa7119TYPIDANALOGINPUTCONTROL10 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL10
Public Enumeration TYPIDANALOGINPUTCONTROL10
public enum class TYPIDANALOGINPUTCONTROL10
type TYPIDANALOGINPUTCONTROL10
Members
Member name | Value | Description
CVBSModes1Mode00CVBS | 0 | CVBS modes 1: Mode 00: CVBS
CVBSModes1Mode01CVBS | 1 | CVBS modes 1: Mode 01: CVBS
CVBSModes1Mode02CVBS | 2 | CVBS modes 1: Mode 02: CVBS
CVBSModes1Mode03CVBS | 3 | CVBS modes 1: Mode 03: CVBS
CVBSModes1Mode04CVBS | 4 | CVBS modes 1: Mode 04: CVBS
CVBSModes1Mode05CVBS | 5 | CVBS modes 1: Mode 05: CVBS
YCModes1Mode06Y | 6 | Y + C modes 1: Mode 06: Y
YCModes1Mode07Y | 7 | Y + C modes 1: Mode 07: Y
YCModes1Mode08Y | 8 | Y + C modes 1: Mode 08: Y
YCModes1Mode09Y | 9 | Y + C modes 1: Mode 09: Y
YCModes1Mode0AY | 10 | Y + C modes 1: Mode 0A: Y
YCModes1Mode0BY | 11 | Y + C modes 1: Mode 0B: Y
YCModes1Mode0CY | 12 | Y + C modes 1: Mode 0C: Y
YCModes1Mode0DY | 13 | Y + C modes 1: Mode 0D: Y
CVBSModes2ModeECVBS | 14 | CVBS modes 2: Mode E: CVBS
CVBSModes2ModeFCVBS | 15 | CVBS modes 2: Mode F: CVBS
CVBSModes2Mode10CVBS | 16 | CVBS modes 2: Mode 10: CVBS
CVBSModes2Mode11CVBS | 17 | CVBS modes 2: Mode 11: CVBS
CVBSModes2Mode12CVBS | 18 | CVBS modes 2: Mode 12: CVBS
CVBSModes2Mode13CVBS | 19 | CVBS modes 2: Mode 13: CVBS
CVBSModes2Mode14CVBS | 20 | CVBS modes 2: Mode 14: CVBS
CVBSModes2Mode15CVBS | 21 | CVBS modes 2: Mode 15: CVBS
YCModes2Mode16Y | 22 | Y + C modes 2: Mode 16: Y
YCModes2Mode17Y | 23 | Y + C modes 2: Mode 17: Y
YCModes2Mode18Y | 24 | Y + C modes 2: Mode 18: Y
YCModes2Mode19Y | 25 | Y + C modes 2: Mode 19: Y
YCModes2Mode1AY | 26 | Y + C modes 2: Mode 1A: Y
YCModes2Mode1BY | 27 | Y + C modes 2: Mode 1B: Y
YCModes2Mode1CY | 28 | Y + C modes 2: Mode 1C: Y
YCModes2Mode1DY | 29 | Y + C modes 2: Mode 1D: Y
CVBSModes3Mode1ECVBS | 30 | CVBS modes 3: Mode 1E: CVBS
CVBSModes3Mode1FCVBS | 31 | CVBS modes 3: Mode 1F: CVBS
YCBCRModesMode20SYCBCR | 32 | Y-CB-CR modes: Mode 20: SY-CB-CR
YCBCRModesMode21SYCBCR | 33 | Y-CB-CR modes: Mode 21: SY-CB-CR
YCBCRModesMode22SYCBCR | 34 | Y-CB-CR modes: Mode 22: SY-CB-CR
YCBCRModesMode23SYCBCR | 35 | Y-CB-CR modes: Mode 23: SY-CB-CR
Reserved | 36 | Reserved
YCBCRModesMode2ESYCBCR | 46 | Y-CB-CR modes: Mode 2E: SY-CB-CR
YCBCRModesMode2FSYCBCR | 47 | Y-CB-CR modes: Mode 2F: SY-CB-CR
RGBModesMode30SRGB | 48 | RGB modes: Mode 30: SRGB
RGBModesMode31SRGB | 49 | RGB modes: Mode 31: SRGB
RGBModesMode32SRGB | 50 | RGB modes: Mode 32: SRGB
RGBModesMode33SRGB | 51 | RGB modes: Mode 33: SRGB
Reserved__1 | 52 | Reserved
RGBModesMode3ESRGB | 62 | RGB modes: Mode 3E: SRGB
RGBModesMode3FSRGB | 63 | RGB modes: Mode 3F: SRGB
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDANALOGINPUTCONTROL11 Enumeration

IRD

Saa7119TYPIDANALOGINPUTCONTROL11 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL11
Public Enumeration TYPIDANALOGINPUTCONTROL11
public enum class TYPIDANALOGINPUTCONTROL11
type TYPIDANALOGINPUTCONTROL11
Members
Member name | Value | Description
NoBypass | 0 | No bypass
BypassOn | 1 | Bypass on
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDANALOGINPUTCONTROL20 Enumeration

IRD

Saa7119TYPIDANALOGINPUTCONTROL20 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL20
Public Enumeration TYPIDANALOGINPUTCONTROL20
public enum class TYPIDANALOGINPUTCONTROL20
type TYPIDANALOGINPUTCONTROL20
Members
Member name | Value | Description
AutomaticGainControlled | 0 | Automatic gain controlled
GainIsUserProgrammable | 1 | Gain is user programmable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDANALOGINPUTCONTROL21 Enumeration

IRD

Saa7119TYPIDANALOGINPUTCONTROL21 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL21
Public Enumeration TYPIDANALOGINPUTCONTROL21
public enum class TYPIDANALOGINPUTCONTROL21
type TYPIDANALOGINPUTCONTROL21
Members
Member name | Value | Description
AGCActive | 0 | AGC active
AGCIntegrationHoldFreeze | 1 | AGC integration hold (freeze)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDANALOGINPUTCONTROL22 Enumeration

IRD

Saa7119TYPIDANALOGINPUTCONTROL22 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL22
Public Enumeration TYPIDANALOGINPUTCONTROL22
public enum class TYPIDANALOGINPUTCONTROL22
type TYPIDANALOGINPUTCONTROL22
Members
Member name | Value | Description
AGCActive | 0 | AGC active
GainStaticControl | 1 | Gain static control
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDANALOGINPUTCONTROL23 Enumeration

IRD

Saa7119TYPIDANALOGINPUTCONTROL23 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL23
Public Enumeration TYPIDANALOGINPUTCONTROL23
public enum class TYPIDANALOGINPUTCONTROL23
type TYPIDANALOGINPUTCONTROL23
Members
Member name | Value | Description
Off | 0 | Off
On | 1 | On
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDANALOGINPUTCONTROL24 Enumeration

IRD

Saa7119TYPIDANALOGINPUTCONTROL24 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL24
Public Enumeration TYPIDANALOGINPUTCONTROL24
public enum class TYPIDANALOGINPUTCONTROL24
type TYPIDANALOGINPUTCONTROL24
Members
Member name | Value | Description
Off | 0 | Off
On | 1 | On
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDANALOGINPUTCONTROL30 Enumeration

IRD

Saa7119TYPIDANALOGINPUTCONTROL30 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL30
Public Enumeration TYPIDANALOGINPUTCONTROL30
public enum class TYPIDANALOGINPUTCONTROL30
type TYPIDANALOGINPUTCONTROL30
Members
Member name | Value | Description
Value_M_2_45 | 0 | -2.45
Value_M_2_36 | 1 | -2.36
Value_M_2_28 | 2 | -2.28
Value_M_2_19 | 3 | -2.19
Value_M_2_10 | 4 | -2.10
Value_M_2_01 | 5 | -2.01
Value_M_1_93 | 6 | -1.93
Value_M_1_85 | 7 | -1.85
Value_M_1_76 | 8 | -1.76
Value_M_1_68 | 9 | -1.68
Value_M_1_60 | 10 | -1.60
Value_M_1_52 | 11 | -1.52
Value_M_1_44 | 12 | -1.44
Value_M_1_36 | 13 | -1.36
Value_M_1_28 | 14 | -1.28
Value_M_1_20 | 15 | -1.20
Value_M_1_12 | 16 | -1.12
Value_M_1_04 | 17 | -1.04
Value_M_0_968 | 18 | -0.968
Value_M_0_893 | 19 | -0.893
Value_M_0_812 | 20 | -0.812
Value_M_0_743 | 21 | -0.743
Value_M_0_669 | 22 | -0.669
Value_M_0_597 | 23 | -0.597
Value_M_0_524 | 24 | -0.524
Value_M_0_453 | 25 | -0.453
Value_M_0_381 | 26 | -0.381
Value_M_0_311 | 27 | -0.311
Value_M_0_241 | 28 | -0.241
Value_M_0_171 | 29 | -0.171
Value_M_0_102 | 30 | -0.102
Value_M_0_034 | 31 | -0.034
Value_0_034 | 32 | 0.034
Value_0_101 | 33 | 0.101
Value_0_168 | 34 | 0.168
Value_0_234 | 35 | 0.234
Value_0_300 | 36 | 0.300
Value_0_365 | 37 | 0.365
Value_0_430 | 38 | 0.430
Value_0_495 | 39 | 0.495
Value_0_558 | 40 | 0.558
Value_0_622 | 41 | 0.622
Value_0_685 | 42 | 0.685
Value_0_747 | 43 | 0.747
Value_0_809 | 44 | 0.809
Value_0_871 | 45 | 0.871
Value_0_932 | 46 | 0.932
Value_0_993 | 47 | 0.993
Value_1_05 | 48 | 1.05
Value_1_11 | 49 | 1.11
Value_1_17 | 50 | 1.17
Value_1_23 | 51 | 1.23
Value_1_29 | 52 | 1.29
Value_1_34 | 53 | 1.34
Value_1_41 | 54 | 1.41
Value_1_46 | 55 | 1.46
Value_1_52 | 56 | 1.52
Value_1_58 | 57 | 1.58
Value_1_63 | 58 | 1.63
Value_1_69 | 59 | 1.69
Value_1_74 | 60 | 1.74
Value_1_80 | 61 | 1.80
Value_1_86 | 62 | 1.86
Value_1_91 | 63 | 1.91
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDANALOGINPUTCONTROL301 Enumeration

IRD

Saa7119TYPIDANALOGINPUTCONTROL301 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDANALOGINPUTCONTROL301
Public Enumeration TYPIDANALOGINPUTCONTROL301
public enum class TYPIDANALOGINPUTCONTROL301
type TYPIDANALOGINPUTCONTROL301
Members
Member name | Value | Description
Value_M_4_5 | 0 | -4.5
Value_M_3 | 1 | -3
Value_M_1_5 | 2 | -1.5
Value_0 | 3 | 0
Value_1_5 | 4 | 1.5
Value_3 | 5 | 3
Value_4_5 | 6 | 4.5
Value_6 | 7 | 6
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDAUDIOCLOCKCONTROL0 Enumeration

IRD

Saa7119TYPIDAUDIOCLOCKCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDAUDIOCLOCKCONTROL0
Public Enumeration TYPIDAUDIOCLOCKCONTROL0
public enum class TYPIDAUDIOCLOCKCONTROL0
type TYPIDAUDIOCLOCKCONTROL0
Members
Member name | Value | Description
ASCLKEdgesTriggeredByFallingEdgesOfAMCLK | 0 | ASCLK edges triggered by falling edges of AMCLK
ASCLKEdgesTriggeredByRisingEdgesOfAMCLK | 1 | ASCLK edges triggered by rising edges of AMCLK
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDAUDIOCLOCKCONTROL1 Enumeration

IRD

Saa7119TYPIDAUDIOCLOCKCONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDAUDIOCLOCKCONTROL1
Public Enumeration TYPIDAUDIOCLOCKCONTROL1
public enum class TYPIDAUDIOCLOCKCONTROL1
type TYPIDAUDIOCLOCKCONTROL1
Members
Member name | Value | Description
ALRCLKEdgesTriggeredByFallingEdgesOfASCLK | 0 | ALRCLK edges triggered by falling edges of ASCLK
ALRCLKEdgesTriggeredByRisingEdgesOfASCLK | 1 | ALRCLK edges triggered by rising edges of ASCLK
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDAUDIOCLOCKCONTROL2 Enumeration

IRD

Saa7119TYPIDAUDIOCLOCKCONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDAUDIOCLOCKCONTROL2
Public Enumeration TYPIDAUDIOCLOCKCONTROL2
public enum class TYPIDAUDIOCLOCKCONTROL2
type TYPIDAUDIOCLOCKCONTROL2
Members
Member name | Value | Description
VerticalReferencePulseIsTakenFromInternalDecoder | 0 | Vertical reference pulse is taken from internal decoder
VerticalReferenceIsTakenFromXRVInputExpansionPort | 1 | Vertical reference is taken from XRV input (expansion port)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDAUDIOCLOCKCONTROL3 Enumeration

IRD

Saa7119TYPIDAUDIOCLOCKCONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDAUDIOCLOCKCONTROL3
Public Enumeration TYPIDAUDIOCLOCKCONTROL3
public enum class TYPIDAUDIOCLOCKCONTROL3
type TYPIDAUDIOCLOCKCONTROL3
Members
Member name | Value | Description
PLLActiveAMCLKIsFieldLocked | 0 | PLL active; AMCLK is field-locked
PLLOpenAMCLKIsFreeRunning | 1 | PLL open; AMCLK is free-running
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDAUDIOCLOCKCONTROL4 Enumeration

IRD

Saa7119TYPIDAUDIOCLOCKCONTROL4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDAUDIOCLOCKCONTROL4
Public Enumeration TYPIDAUDIOCLOCKCONTROL4
public enum class TYPIDAUDIOCLOCKCONTROL4
type TYPIDAUDIOCLOCKCONTROL4
Members
Member name | Value | Description
SecondCGCCGC2Bypassed | 0 | Second CGC (CGC2) bypassed
SecondCGCCGC2InUseForAudioClockGeneration | 1 | Second CGC (CGC2) in use for Audio clock generation
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDCHROMINANCECONTROL10 Enumeration

IRD

Saa7119TYPIDCHROMINANCECONTROL10 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCECONTROL10
Public Enumeration TYPIDCHROMINANCECONTROL10
public enum class TYPIDCHROMINANCECONTROL10
type TYPIDCHROMINANCECONTROL10
Members
Member name | Value | Description
Disabled | 0 | Disabled
Active | 1 | Active
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDCHROMINANCECONTROL101 Enumeration

IRD

Saa7119TYPIDCHROMINANCECONTROL101 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCECONTROL101
Public Enumeration TYPIDCHROMINANCECONTROL101
public enum class TYPIDCHROMINANCECONTROL101
type TYPIDCHROMINANCECONTROL101
Members
Member name | Value | Description
Disabled | 0 | Disabled
AutoModeActiveHighest | 1 | Auto mode active (highest)
AutoModeActiveMedium | 2 | Auto mode active (medium)
AutoModeActiveLowest | 3 | Auto mode active (lowest)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDCHROMINANCECONTROL11 Enumeration

IRD

Saa7119TYPIDCHROMINANCECONTROL11 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCECONTROL11
Public Enumeration TYPIDCHROMINANCECONTROL11
public enum class TYPIDCHROMINANCECONTROL11
type TYPIDCHROMINANCECONTROL11
Members
Member name | Value | Description
NominalTimeConstant | 0 | Nominal time constant
FastTimeConstant | 1 | Fast time constant
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDCHROMINANCECONTROL12 Enumeration

IRD

Saa7119TYPIDCHROMINANCECONTROL12 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCECONTROL12
Public Enumeration TYPIDCHROMINANCECONTROL12
public enum class TYPIDCHROMINANCECONTROL12
type TYPIDCHROMINANCECONTROL12
Members
Member name | Value | Description
On | 0 | On
Off | 1 | Off
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDCHROMINANCECONTROL13 Enumeration

IRD

Saa7119TYPIDCHROMINANCECONTROL13 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCECONTROL13
Public Enumeration TYPIDCHROMINANCECONTROL13
public enum class TYPIDCHROMINANCECONTROL13
type TYPIDCHROMINANCECONTROL13
Members
Member name | Value | Description
PreferredStandardPALBGDHINTSCM443MHz358MHz | 0 | Preferred standard: PAL BGDHI/NTSC M (4.43 MHz/3.58 MHz)
ReservedDoNotUse | 1 | Reserved; do not use
PreferredStandardPALBGDHINTSCJapan443MHz358MHz | 4 | Preferred standard: PAL BGDHI/NTSC-Japan (4.43 MHz/3.58 MHz)
PreferredStandardSECAMNTSCM358MHz | 5 | Preferred standard: SECAM/NTSC-M (-/3.58 MHz)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDCHROMINANCECONTROL20 Enumeration

IRD

Saa7119TYPIDCHROMINANCECONTROL20 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCECONTROL20
Public Enumeration TYPIDCHROMINANCECONTROL20
public enum class TYPIDCHROMINANCECONTROL20
type TYPIDCHROMINANCECONTROL20
Members
Member name | Value | Description
Value_0Smallest | 0 | 0 - Smallest
Value_7Largest | 7 | 7 - Largest
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDCHROMINANCECONTROL21 Enumeration

IRD

Saa7119TYPIDCHROMINANCECONTROL21 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCECONTROL21
Public Enumeration TYPIDCHROMINANCECONTROL21
public enum class TYPIDCHROMINANCECONTROL21
type TYPIDCHROMINANCECONTROL21
Members
Member name | Value | Description
Small | 0 | Small
Wide | 1 | Wide
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDCHROMINANCECONTROL22 Enumeration

IRD

Saa7119TYPIDCHROMINANCECONTROL22 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCECONTROL22
Public Enumeration TYPIDCHROMINANCECONTROL22
public enum class TYPIDCHROMINANCECONTROL22
type TYPIDCHROMINANCECONTROL22
Members
Member name | Value | Description
Value_0LSB | 0 | 0 LSB
Value_14LSB | 1 | 1/4 LSB
Value_12LSB | 2 | 1/2 LSB
Value_34LSB | 3 | 3/4 LSB
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDCHROMINANCEGAINCONTROL0 Enumeration

IRD

Saa7119TYPIDCHROMINANCEGAINCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCEGAINCONTROL0
Public Enumeration TYPIDCHROMINANCEGAINCONTROL0
public enum class TYPIDCHROMINANCEGAINCONTROL0
type TYPIDCHROMINANCEGAINCONTROL0
Members
Member name | Value | Description
MinimumGain05 | 0 | Minimum gain (0.5)
NominalGain1125 | 36 | Nominal gain (1.125)
MaximumGain105 | 143 | Maximum gain (10.5)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDCHROMINANCESATURCOMPONENTPART0 Enumeration

IRD

Saa7119TYPIDCHROMINANCESATURCOMPONENTPART0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCESATURCOMPONENTPART0
Public Enumeration TYPIDCHROMINANCESATURCOMPONENTPART0
public enum class TYPIDCHROMINANCESATURCOMPONENTPART0
type TYPIDCHROMINANCESATURCOMPONENTPART0
Members
Member name | Value | Description
Value_0Off | 0 | 0 (off)
Value_10ITULevel | 64 | 1.0 (ITU level)
Value_1984Maximum | 127 | 1.984 (maximum)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDCHROMINANCESATURURATIONCONTROL0 Enumeration

IRD

Saa7119TYPIDCHROMINANCESATURURATIONCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHROMINANCESATURURATIONCONTROL0
Public Enumeration TYPIDCHROMINANCESATURURATIONCONTROL0
public enum class TYPIDCHROMINANCESATURURATIONCONTROL0
type TYPIDCHROMINANCESATURURATIONCONTROL0
Members
Member name | Value | Description
Value_0Off | 0 | 0 (off)
Value_1984Maximum | 127 | 1.984 (maximum)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDCOLORKILLERLEVELCONTROL0 Enumeration

IRD

Saa7119TYPIDCOLORKILLERLEVELCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCOLORKILLERLEVELCONTROL0
Public Enumeration TYPIDCOLORKILLERLEVELCONTROL0
public enum class TYPIDCOLORKILLERLEVELCONTROL0
type TYPIDCOLORKILLERLEVELCONTROL0
Members
Member name | Value | Description
MinimumLevel | 0 | Minimum level
RecommendedValue | 8 | Recommended value
Maximum | 15 | Maximum
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDDITHERLUMA2 Enumeration

IRD

Saa7119TYPIDDITHERLUMA2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDDITHERLUMA2
Public Enumeration TYPIDDITHERLUMA2
public enum class TYPIDDITHERLUMA2
type TYPIDDITHERLUMA2
Members
Member name | Value | Description
NoDither | 0 | No dither
Value_1LSBDither | 1 | 1 LSB dither
Value_2LSBDither | 2 | 2 LSB dither
Value_3LSBDither | 3 | 3 LSB dither
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDENHANCEDCOMBFILTILTERCONTROL10 Enumeration

IRD

Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL10 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDENHANCEDCOMBFILTILTERCONTROL10
Public Enumeration TYPIDENHANCEDCOMBFILTILTERCONTROL10
public enum class TYPIDENHANCEDCOMBFILTILTERCONTROL10
type TYPIDENHANCEDCOMBFILTILTERCONTROL10
Members
Member name | Value | Description
LowestCombStrength | 0 | Lowest comb strength
RecommendedValue | 1 | Recommended value
HigherCombStrength | 2 | Higher comb strength
HighestCombStrength | 3 | Highest comb strength
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDENHANCEDCOMBFILTILTERCONTROL11 Enumeration

IRD

Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL11 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDENHANCEDCOMBFILTILTERCONTROL11
Public Enumeration TYPIDENHANCEDCOMBFILTILTERCONTROL11
public enum class TYPIDENHANCEDCOMBFILTILTERCONTROL11
type TYPIDENHANCEDCOMBFILTILTERCONTROL11
Members
Member name | Value | Description
HighestLuminanceBandwidth | 0 | Highest luminance bandwidth
LowerLuminanceBandwidth | 1 | Lower luminance bandwidth
RecommendedValue | 2 | Recommended value
LowestLuminanceBandwidth | 3 | Lowest luminance bandwidth
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDENHANCEDCOMBFILTILTERCONTROL13 Enumeration

IRD

Saa7119TYPIDENHANCEDCOMBFILTILTERCONTROL13 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDENHANCEDCOMBFILTILTERCONTROL13
Public Enumeration TYPIDENHANCEDCOMBFILTILTERCONTROL13
public enum class TYPIDENHANCEDCOMBFILTILTERCONTROL13
type TYPIDENHANCEDCOMBFILTILTERCONTROL13
Members
Member name | Value | Description
LowestLuminanceBandwidth | 0 | Lowest luminance bandwidth
HigerLuminanceBandwidth | 1 | Higer luminance bandwidth
RecommendedValue | 2 | Recommended value
HighestLuminanceBandwidth | 3 | Highest luminance bandwidth
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDENHANCEDSYNCANDILTERCONTROL20 Enumeration

IRD

Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL20 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDENHANCEDSYNCANDILTERCONTROL20
Public Enumeration TYPIDENHANCEDSYNCANDILTERCONTROL20
public enum class TYPIDENHANCEDSYNCANDILTERCONTROL20
type TYPIDENHANCEDSYNCANDILTERCONTROL20
Members
Member name | Value | Description
HighestCombStrength | 0 | Highest comb strength
RecommendedValue | 1 | Recommended value
LowerCombStrength | 2 | Lower comb strength
LowestCombStrength | 3 | Lowest comb strength
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDENHANCEDSYNCANDILTERCONTROL21 Enumeration

IRD

Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL21 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDENHANCEDSYNCANDILTERCONTROL21
Public Enumeration TYPIDENHANCEDSYNCANDILTERCONTROL21
public enum class TYPIDENHANCEDSYNCANDILTERCONTROL21
type TYPIDENHANCEDSYNCANDILTERCONTROL21
Members
Member name | Value | Description
PLLRunning | 0 | PLL running
PLLFixed | 1 | PLL fixed
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDENHANCEDSYNCANDILTERCONTROL22 Enumeration

IRD

Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL22 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDENHANCEDSYNCANDILTERCONTROL22
Public Enumeration TYPIDENHANCEDSYNCANDILTERCONTROL22
public enum class TYPIDENHANCEDSYNCANDILTERCONTROL22
type TYPIDENHANCEDSYNCANDILTERCONTROL22
Members
Member name | Value | Description
FullSearch | 0 | Full search
OnlyASubsetOfStandardsCanBeDetected | 1 | Only a subset of standards can be detected
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDENHANCEDSYNCANDILTERCONTROL23 Enumeration

IRD

Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL23 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDENHANCEDSYNCANDILTERCONTROL23
Public Enumeration TYPIDENHANCEDSYNCANDILTERCONTROL23
public enum class TYPIDENHANCEDSYNCANDILTERCONTROL23
type TYPIDENHANCEDSYNCANDILTERCONTROL23
Members
Member name | Value | Description
HalfPixelFrequency135MHzNom | 0 | Half pixel frequency (13.5MHz nom.)
DoublePixelFrequency54MHzNom | 1 | Double pixel frequency (54MHz nom.)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDENHANCEDSYNCANDILTERCONTROL24 Enumeration

IRD

Saa7119TYPIDENHANCEDSYNCANDILTERCONTROL24 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDENHANCEDSYNCANDILTERCONTROL24
Public Enumeration TYPIDENHANCEDSYNCANDILTERCONTROL24
public enum class TYPIDENHANCEDSYNCANDILTERCONTROL24
type TYPIDENHANCEDSYNCANDILTERCONTROL24
Members
Member name | Value | Description
Enabled | 0 | Enabled
Disabled | 1 | Disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDFASTSWITCHCONTROL10 Enumeration

IRD

Saa7119TYPIDFASTSWITCHCONTROL10 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFASTSWITCHCONTROL10
Public Enumeration TYPIDFASTSWITCHCONTROL10
public enum class TYPIDFASTSWITCHCONTROL10
type TYPIDFASTSWITCHCONTROL10
Members
Member name | Value | Description
GainIs15 | 0 | Gain is 1.5
GainIs2 | 1 | Gain is 2
GainIs25 | 2 | Gain is 2.5
GainIs3 | 3 | Gain is 3
GainIs4 | 4 | Gain is 4
GainIs5 | 5 | Gain is 5
GainIs6 | 6 | Gain is 6
GainIs8 | 7 | Gain is 8
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDFASTSWITCHCONTROL12 Enumeration

IRD

Saa7119TYPIDFASTSWITCHCONTROL12 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFASTSWITCHCONTROL12
Public Enumeration TYPIDFASTSWITCHCONTROL12
public enum class TYPIDFASTSWITCHCONTROL12
type TYPIDFASTSWITCHCONTROL12
Members
Member name | Value | Description
Value_2 | 0 | 2
Value_4 | 1 | 4
Value_6 | 2 | 6
Value_8 | 3 | 8
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDFASTSWITCHCONTROL32 Enumeration

IRD

Saa7119TYPIDFASTSWITCHCONTROL32 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFASTSWITCHCONTROL32
Public Enumeration TYPIDFASTSWITCHCONTROL32
public enum class TYPIDFASTSWITCHCONTROL32
type TYPIDFASTSWITCHCONTROL32
Members
Member name | Value | Description
SetOnlyIfAllFastswitchEventsWithinTwoFieldsAreLegal | 0 | Set only if all fastswitch events within two fields are legal
SetEvenWithOccuranceOfIllegalFSWEvents | 1 | Set even with occurance of illegal FSW events
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDFASTSWITCHCONTROL34 Enumeration

IRD

Saa7119TYPIDFASTSWITCHCONTROL34 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFASTSWITCHCONTROL34
Public Enumeration TYPIDFASTSWITCHCONTROL34
public enum class TYPIDFASTSWITCHCONTROL34
type TYPIDFASTSWITCHCONTROL34
Members
Member name | Value | Description
ThreeBitADC | 0 | Three bit ADC
LegacyFSWPin | 1 | Legacy FSW pin
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDFASTSWITCHSTATUS0 Enumeration

IRD

Saa7119TYPIDFASTSWITCHSTATUS0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFASTSWITCHSTATUS0
Public Enumeration TYPIDFASTSWITCHSTATUS0
public enum class TYPIDFASTSWITCHSTATUS0
type TYPIDFASTSWITCHSTATUS0
Members
Member name | Value | Description
NoLineHasATransition | 0 | No line has a transition
Value_1LineHasATransition | 1 | 1 line has a transition
MoreThan2LinesHaveATransition | 2 | More than 2 lines have a transition
MoreThan4LinesHaveATransition | 3 | More than 4 lines have a transition
MoreThan8LinesHaveATransition | 4 | More than 8 lines have a transition
MoreThan16LinesHaveATransition | 5 | More than 16 lines have a transition
MoreThan32LinesHaveATransition | 6 | More than 32 lines have a transition
MoreThan63LinesHaveATransition | 7 | More than 63 lines have a transition
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDFIELDOFFSETANDERTICALOFFSETS0 Enumeration

IRD

Saa7119TYPIDFIELDOFFSETANDERTICALOFFSETS0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFIELDOFFSETANDERTICALOFFSETS0
Public Enumeration TYPIDFIELDOFFSETANDERTICALOFFSETS0
public enum class TYPIDFIELDOFFSETANDERTICALOFFSETS0
type TYPIDFIELDOFFSETANDERTICALOFFSETS0
Members
Member name | Value | Description
VBISlicerTriggersOnTheNegativeEdgeOfTheInternalV123VSync | 0 | VBI slicer triggers on the negative edge of the internal V123 V-sync
VBISlicerTriggersOnThePositiveEdgeOfTheInternalV123VSync | 1 | VBI slicer triggers on the positive edge of the internal V123 V-sync
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDFIELDOFFSETANDERTICALOFFSETS1 Enumeration

IRD

Saa7119TYPIDFIELDOFFSETANDERTICALOFFSETS1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDFIELDOFFSETANDERTICALOFFSETS1
Public Enumeration TYPIDFIELDOFFSETANDERTICALOFFSETS1
public enum class TYPIDFIELDOFFSETANDERTICALOFFSETS1
type TYPIDFIELDOFFSETANDERTICALOFFSETS1
Members
Member name | Value | Description
NoModificationOfInternalFieldIndicatorDefaultFor50Hz625LinesInputSources | 0 | No modification of internal field indicator (default for 50 Hz 625 lines input sources)
InvertFieldIndicatorDefaultFor60Hz525LinesInputSources | 1 | Invert field indicator (default for 60 Hz 525 lines input sources)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDGLOBALSETTINGS3 Enumeration

IRD

Saa7119TYPIDGLOBALSETTINGS3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDGLOBALSETTINGS3
Public Enumeration TYPIDGLOBALSETTINGS3
public enum class TYPIDGLOBALSETTINGS3
type TYPIDGLOBALSETTINGS3
Members
Member name | Value | Description
FieldProcessingIsDoneAccordingTheTriggerConditionsAndWindowDefinitionsOfAnEnabledProgrammingPage | 0 | Field processing is done according the trigger conditions and window definitions of an enabled programming page
PermanentProcessingOfTheEnabledTaskAccordingToTEB | 1 | Permanent processing of the enabled task according to TEB
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDHORIZONTALINCREMENTDELAY0 Enumeration

IRD

Saa7119TYPIDHORIZONTALINCREMENTDELAY0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDHORIZONTALINCREMENTDELAY0
Public Enumeration TYPIDHORIZONTALINCREMENTDELAY0
public enum class TYPIDHORIZONTALINCREMENTDELAY0
type TYPIDHORIZONTALINCREMENTDELAY0
Members
Member name | Value | Description
Value_0MaximumDelay | 0 | 0 - Maximum delay
Value_1 | 1 | 1 -
Value_2 | 2 | 2 -
Value_3 | 3 | 3 -
Value_4 | 4 | 4 -
Value_5 | 5 | 5 -
Value_6 | 6 | 6 -
Value_7RecommendedPosition | 7 | 7 - Recommended position
Value_8 | 8 | 8 -
Value_9 | 9 | 9 -
Value_10 | 10 | 10 -
Value_11 | 11 | 11 -
Value_12 | 12 | 12 -
Value_13 | 13 | 13 -
Value_14MinimumDelay | 14 | 14 - Minimum delay
Value_15NoUpdate | 15 | 15 - No update
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDHORIZONTALINCREMENTDELAY1 Enumeration

IRD

Saa7119TYPIDHORIZONTALINCREMENTDELAY1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDHORIZONTALINCREMENTDELAY1
Public Enumeration TYPIDHORIZONTALINCREMENTDELAY1
public enum class TYPIDHORIZONTALINCREMENTDELAY1
type TYPIDHORIZONTALINCREMENTDELAY1
Members
Member name | Value | Description
Value_0LowCurrentLowPerformanceSetting | 0 | 0 - Low-current/Low-performance setting
Value_3 | 1 | 3
Value_2Default | 2 | 2 - Default
Value_3HighCurrentMaxPerformanceSetting | 3 | 3 - High-current/Max-performance setting
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDHORIZONTALINCREMENTDELAY2 Enumeration

IRD

Saa7119TYPIDHORIZONTALINCREMENTDELAY2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDHORIZONTALINCREMENTDELAY2
Public Enumeration TYPIDHORIZONTALINCREMENTDELAY2
public enum class TYPIDHORIZONTALINCREMENTDELAY2
type TYPIDHORIZONTALINCREMENTDELAY2
Members
Member name | Value | Description
WhitePeakControlActive | 0 | White peak control active
WhitePeakControlDisabled | 1 | White peak control disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDIPORTCONTROLANANDDEFINITIONS0 Enumeration

IRD

Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTCONTROLANANDDEFINITIONS0
Public Enumeration TYPIDIPORTCONTROLANANDDEFINITIONS0
public enum class TYPIDIPORTCONTROLANANDDEFINITIONS0
type TYPIDIPORTCONTROLANANDDEFINITIONS0
Members
Member name | Value | Description
VBlankingSignalFromScalerInput | 0 | V-blanking signal from scaler input
ProgrammableVGateSignalVGATELFromDecoder | 1 | Programmable V-gate signal VGATE_L from decoder
LCRTableControlledVGateAndFieldIDFromTheTextDataPath | 2 | LCR table controlled V-gate and Field ID from the text data path
CONLVControlledRegionAndPageDependentVGateFromScalerDataPath | 3 | CONLV controlled region and page dependent V-gate from scaler data path
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDIPORTCONTROLANANDDEFINITIONS1 Enumeration

IRD

Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTCONTROLANANDDEFINITIONS1
Public Enumeration TYPIDIPORTCONTROLANANDDEFINITIONS1
public enum class TYPIDIPORTCONTROLANANDDEFINITIONS1
type TYPIDIPORTCONTROLANANDDEFINITIONS1
Members
Member name | Value | Description
FID0VEdgeAfterEndOfLineEOLFIDChange01AfterStartOfLineSOLFID1VEdgeAfterSOLFIDChange10AfterEOL | 0 | FID '0' -> V-edge after End Of Line (EOL), FID change 0->1 after Start Of Line (SOL) FID '1' -> V-edge after SOL, FID change 1->0 after EOL
UpperVAndFIDTimingCharacteristicsChangeFromEOLToSOLAndVv | 1 | Upper V and FID timing characteristics change from EOL to SOL and .vv
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDIPORTCONTROLANANDDEFINITIONS2 Enumeration

IRD

Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTCONTROLANANDDEFINITIONS2
Public Enumeration TYPIDIPORTCONTROLANANDDEFINITIONS2
public enum class TYPIDIPORTCONTROLANANDDEFINITIONS2
type TYPIDIPORTCONTROLANANDDEFINITIONS2
Members
Member name | Value | Description
Off | 0 | Off
On | 1 | On
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDIPORTCONTROLANANDDEFINITIONS3 Enumeration

IRD

Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTCONTROLANANDDEFINITIONS3
Public Enumeration TYPIDIPORTCONTROLANANDDEFINITIONS3
public enum class TYPIDIPORTCONTROLANANDDEFINITIONS3
type TYPIDIPORTCONTROLANANDDEFINITIONS3
Members
Member name | Value | Description
Off | 0 | Off
On | 1 | On
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDIPORTCONTROLANANDDEFINITIONS4 Enumeration

IRD

Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTCONTROLANANDDEFINITIONS4
Public Enumeration TYPIDIPORTCONTROLANANDDEFINITIONS4
public enum class TYPIDIPORTCONTROLANANDDEFINITIONS4
type TYPIDIPORTCONTROLANANDDEFINITIONS4
Members
Member name | Value | Description
Off | 0 | Off
On | 1 | On
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDIPORTCONTROLANANDDEFINITIONS5 Enumeration

IRD

Saa7119TYPIDIPORTCONTROLANANDDEFINITIONS5 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTCONTROLANANDDEFINITIONS5
Public Enumeration TYPIDIPORTCONTROLANANDDEFINITIONS5
public enum class TYPIDIPORTCONTROLANANDDEFINITIONS5
type TYPIDIPORTCONTROLANANDDEFINITIONS5
Members
Member name | Value | Description
OutputRange01FE | 0 | Output range: 01-FE
OutputRange08F7 | 1 | Output range: 08-F7
OutputRange10EF | 2 | Output range: 10-EF
Unlimited | 3 | Unlimited
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDIPORTFIFOFLAGANDARBITRATION0 Enumeration

IRD

Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTFIFOFLAGANDARBITRATION0
Public Enumeration TYPIDIPORTFIFOFLAGANDARBITRATION0
public enum class TYPIDIPORTFIFOFLAGANDARBITRATION0
type TYPIDIPORTFIFOFLAGANDARBITRATION0
Members
Member name | Value | Description
SmalerThan16Dwords | 0 | Smaler than 16 Dwords
SmalerThan8Dwords | 1 | Smaler than 8 Dwords
SmalerThan4Dwords | 2 | Smaler than 4 Dwords
Value_0Dwords | 3 | 0 Dwords
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDIPORTFIFOFLAGANDARBITRATION1 Enumeration

IRD

Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTFIFOFLAGANDARBITRATION1
Public Enumeration TYPIDIPORTFIFOFLAGANDARBITRATION1
public enum class TYPIDIPORTFIFOFLAGANDARBITRATION1
type TYPIDIPORTFIFOFLAGANDARBITRATION1
Members
Member name | Value | Description
SmalerOrSameThan16Dwords | 0 | Smaler or same than 16 Dwords
SmalerOrSameThan24Dwords | 1 | Smaler or same than 24 Dwords
SmalerOrSameThan28Dwords | 2 | Smaler or same than 28 Dwords
Value_32Dwords | 3 | 32 Dwords
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDIPORTFIFOFLAGANDARBITRATION2 Enumeration

IRD

Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTFIFOFLAGANDARBITRATION2
Public Enumeration TYPIDIPORTFIFOFLAGANDARBITRATION2
public enum class TYPIDIPORTFIFOFLAGANDARBITRATION2
type TYPIDIPORTFIFOFLAGANDARBITRATION2
Members
Member name | Value | Description
IPortVideoDataOutputIsInhibited | 0 | I-port video data output is inhibited
IPortVideoDataAreTransferred | 1 | I-port video data are transferred
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDIPORTFIFOFLAGANDARBITRATION3 Enumeration

IRD

Saa7119TYPIDIPORTFIFOFLAGANDARBITRATION3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTFIFOFLAGANDARBITRATION3
Public Enumeration TYPIDIPORTFIFOFLAGANDARBITRATION3
public enum class TYPIDIPORTFIFOFLAGANDARBITRATION3
type TYPIDIPORTFIFOFLAGANDARBITRATION3
Members
Member name | Value | Description
DataPackingControlledByITRDYPin | 0 | Data packing controlled by ITRDY pin
DataPackingIsDoneInternallyByHREFSynchronousDelayedTriggerPulses | 1 | Data packing is done internally, by HREF synchronous delayed trigger pulses
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDIPORTIOENABLEKPHASECONTROL0 Enumeration

IRD

Saa7119TYPIDIPORTIOENABLEKPHASECONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTIOENABLEKPHASECONTROL0
Public Enumeration TYPIDIPORTIOENABLEKPHASECONTROL0
public enum class TYPIDIPORTIOENABLEKPHASECONTROL0
type TYPIDIPORTIOENABLEKPHASECONTROL0
Members
Member name | Value | Description
DisabledBySoftware | 0 | Disabled by software
EnabledBySoftware | 1 | Enabled by software
EnabledByPinITRIAtLogic | 2 | Enabled by pin ITRI at logic
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDIPORTIOENABLEKPHASECONTROL1 Enumeration

IRD

Saa7119TYPIDIPORTIOENABLEKPHASECONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTIOENABLEKPHASECONTROL1
Public Enumeration TYPIDIPORTIOENABLEKPHASECONTROL1
public enum class TYPIDIPORTIOENABLEKPHASECONTROL1
type TYPIDIPORTIOENABLEKPHASECONTROL1
Members
Member name | Value | Description
InvertedInputOutputPhase | 0 | Inverted input/output phase
NonInvertedInputOutputPhaseRecommendedPositionAtICKS1011bExternalICLKOnly | 1 | Non inverted input/output phase recommended position at ICKS[1:0] = 11b (external ICLK only)
InvertedAndPhaseShiftedByAbout3Nsec | 2 | Inverted and phase shifted by about 3 nsec
NonInvertedAndPhaseShiftedByAbout3Nsec | 3 | Non inverted and phase shifted by about 3 nsec
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDIPORTIOENABLEKPHASECONTROL2 Enumeration

IRD

Saa7119TYPIDIPORTIOENABLEKPHASECONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTIOENABLEKPHASECONTROL2
Public Enumeration TYPIDIPORTIOENABLEKPHASECONTROL2
public enum class TYPIDIPORTIOENABLEKPHASECONTROL2
type TYPIDIPORTIOENABLEKPHASECONTROL2
Members
Member name | Value | Description
ShortDataHoldTimeAbout2NsecSignalRemainsAt1DuringCyclesWithoutValidData | 0 | Short data hold time (about 2 nsec, signal remains at '1' during cycles without valid data)
BalancedSetupAndHoldTimeSignalRemainsAt0DuringCyclesWithoutValidData | 1 | Balanced setup and hold time (signal remains at '0' during cycles without valid data)
IPCK32At00ButDelayedByAbout35NsecHoldTimeAbout15Nsec | 2 | IPCK[3:2] at '00', but delayed by about 3.5 nsec (hold time about -1.5 nsec)
IPCK32At01ButDelayedByAbout35Nsec | 3 | IPCK[3:2] at '01', but delayed by about 3.5 nsec
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDIPORTSIGNALDEFINITIONS0 Enumeration

IRD

Saa7119TYPIDIPORTSIGNALDEFINITIONS0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTSIGNALDEFINITIONS0
Public Enumeration TYPIDIPORTSIGNALDEFINITIONS0
public enum class TYPIDIPORTSIGNALDEFINITIONS0
type TYPIDIPORTSIGNALDEFINITIONS0
Members
Member name | Value | Description
HGateSignalFramingTheScalerOutputData | 0 | H-gate signal, framing the scaler output data
ExtendedHGate | 1 | Extended H-gate
HorizontalTriggerPulseOnActiveGoingEdgeOfHGate | 2 | Horizontal trigger pulse, on active going edge of H-gate
HorizontalTriggerPulseOnActiveGoingEdgeOfExtendedHGate | 3 | Horizontal trigger pulse, on active going edge of extended H-gate
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDIPORTSIGNALDEFINITIONS01 Enumeration

IRD

Saa7119TYPIDIPORTSIGNALDEFINITIONS01 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTSIGNALDEFINITIONS01
Public Enumeration TYPIDIPORTSIGNALDEFINITIONS01
public enum class TYPIDIPORTSIGNALDEFINITIONS01
type TYPIDIPORTSIGNALDEFINITIONS01
Members
Member name | Value | Description
OutputFieldIDAsDefinedByVEAV8110 | 0 | Output field ID, as defined by V_EAV[81[1:0]]
FieldIDAsDefinedByVEAVAndFTIME812 | 1 | Field ID, as defined by V_EAV and FTIME[81[2]]
SlicedDataFlagFramingTheSlicedVBIDataAtTheIPort | 2 | Sliced data flag, framing the sliced VBI data at the I-port
ABTaskFlagAsDefinedByCONLH907 | 3 | A/B task flag, as defined by CONLH [90[7]]
TheOutputFIFOAlmostFilledFlag | 4 | The output FIFO almost filled flag
TheOutputFIFOAlmostFullFlagLevelToBeProgrammedInIPortPackingMode | 5 | The output FIFO almost full flag, level to be programmed in I-port Packing mode
TheOutputFIFOAlmostEmptyFlagLevelToBeProgrammedInIPortPackingMode | 6 | The output FIFO almost empty flag, level to be programmed in I-port Packing mode
ProgrammableHSyncFromRasterGenerator | 7 | Programmable H-sync from raster generator
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDIPORTSIGNALDEFINITIONS02 Enumeration

IRD

Saa7119TYPIDIPORTSIGNALDEFINITIONS02 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTSIGNALDEFINITIONS02
Public Enumeration TYPIDIPORTSIGNALDEFINITIONS02
public enum class TYPIDIPORTSIGNALDEFINITIONS02
type TYPIDIPORTSIGNALDEFINITIONS02
Members
Member name | Value | Description
OutputFieldIDAsDefinedByVEAV8110 | 0 | Output field ID, as defined by V_EAV[81[1:0]]
FieldIDAsDefinedByVEAVAndFTIME812 | 1 | Field ID, as defined by V_EAV and FTIME[81[2]]
SlicedDataFlagFramingTheSlicedVBIDataAtTheIPort | 2 | Sliced data flag, framing the sliced VBI data at the I-port
ABTaskFlagAsDefinedByCONLH907 | 3 | A/B task flag, as defined by CONLH [90[7]]
TheOutputFIFOAlmostFilledFlag | 4 | The output FIFO almost filled flag
TheOutputFIFOAlmostFullFlagLevelToBeProgrammedInIPortPackingMode | 5 | The output FIFO almost full flag, level to be programmed in I-port Packing mode
TheOutputFIFOAlmostEmptyFlagLevelToBeProgrammedInIPortPackingMode | 6 | The output FIFO almost empty flag, level to be programmed in I-port Packing mode
ProgrammableHSyncFromRasterGenerator | 7 | Programmable H-sync from raster generator
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDIPORTSIGNALDEFINITIONS1 Enumeration

IRD

Saa7119TYPIDIPORTSIGNALDEFINITIONS1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDIPORTSIGNALDEFINITIONS1
Public Enumeration TYPIDIPORTSIGNALDEFINITIONS1
public enum class TYPIDIPORTSIGNALDEFINITIONS1
type TYPIDIPORTSIGNALDEFINITIONS1
Members
Member name | Value | Description
VGateSignalFramingScaledOutputLines | 0 | V-gate signal, framing scaled output lines
VReferenceSignalFromScalerInput | 1 | V-reference signal from scaler input
VerticalTriggerPulseDerivedFromVGate | 2 | Vertical trigger pulse, derived from V-gate
VerticalTriggerPulseDerivedFromInputVReference | 3 | Vertical trigger pulse derived from input V-reference
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDLCRREGISTER20 Enumeration

IRD

Saa7119TYPIDLCRREGISTER20 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDLCRREGISTER20
Public Enumeration TYPIDLCRREGISTER20
public enum class TYPIDLCRREGISTER20
type TYPIDLCRREGISTER20
Members
Member name | Value | Description
DoNotAcquire | 0 | Do not acquire
USTeletextEuroTeletext | 1 | US Teletext/Euro Teletext
NABTSEuroTeletextWithProgammableFramingCode | 2 | NABTS/Euro Teletext with progammable Framing Code
MojiReserved | 3 | Moji/Reserved
USClosedCaptionEuroClosedCaption | 4 | US Closed Caption/Euro Closed Caption
CGMSEuroWideScreenSignalling | 5 | CGMS/Euro Wide Screen Signalling
VITC525VITC625 | 6 | VITC525/VITC625
Gemstar2xVPS | 7 | Gemstar2x/VPS
Gemstar1xReserved | 8 | Gemstar1x/reserved
Reserved | 9 | Reserved
Open15MHz | 10 | Open1 (5 MHz)
Open257272MHz | 11 | Open2 (5,7272 MHz)
Reserved__1 | 12 | Reserved
DoNotAcquireRAW | 13 | Do not acquire (RAW)
DoNotAcquireTest | 14 | Do not acquire (Test)
DoNotAcquireActiveVideo | 15 | Do not acquire (active video)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDLUMINANCEBRIGHTNLDECODERPART0 Enumeration

IRD

Saa7119TYPIDLUMINANCEBRIGHTNLDECODERPART0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDLUMINANCEBRIGHTNLDECODERPART0
Public Enumeration TYPIDLUMINANCEBRIGHTNLDECODERPART0
public enum class TYPIDLUMINANCEBRIGHTNLDECODERPART0
type TYPIDLUMINANCEBRIGHTNLDECODERPART0
Members
Member name | Value | Description
Value_0Dark | 0 | 0 - Dark
Value_128ITULevel | 128 | 128 - ITU level
Value_255Bright | 255 | 255 - Bright
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDLUMINANCECONTRASCOMPONENTPART0 Enumeration

IRD

Saa7119TYPIDLUMINANCECONTRASCOMPONENTPART0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDLUMINANCECONTRASCOMPONENTPART0
Public Enumeration TYPIDLUMINANCECONTRASCOMPONENTPART0
public enum class TYPIDLUMINANCECONTRASCOMPONENTPART0
type TYPIDLUMINANCECONTRASCOMPONENTPART0
Members
Member name | Value | Description
Value_0Off | 0 | 0 (off)
Value_10ITULevel | 64 | 1.0 (ITU level)
Value_1984Maximum | 127 | 1.984 (maximum)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDLUMINANCECONTRASLDECODERPART0 Enumeration

IRD

Saa7119TYPIDLUMINANCECONTRASLDECODERPART0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDLUMINANCECONTRASLDECODERPART0
Public Enumeration TYPIDLUMINANCECONTRASLDECODERPART0
public enum class TYPIDLUMINANCECONTRASLDECODERPART0
type TYPIDLUMINANCECONTRASLDECODERPART0
Members
Member name | Value | Description
Value_0Off | 0 | 0 (off)
Value_1063ITULevel | 68 | 1.063 (ITU level)
Value_1984Maximum | 127 | 1.984 (maximum)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDLUMINANCECONTROL0 Enumeration

IRD

Saa7119TYPIDLUMINANCECONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDLUMINANCECONTROL0
Public Enumeration TYPIDLUMINANCECONTROL0
public enum class TYPIDLUMINANCECONTROL0
type TYPIDLUMINANCECONTROL0
Members
Member name | Value | Description
Plain | 0 | Plain
ResEnhFilter80DB41MHz | 1 | Res. enh. filter: 8.0 dB/4.1 MHz
ResEnhFilter68DB41MHz | 2 | Res. enh. filter: 6.8 dB/4.1 MHz
ResEnhFilter51DB41MHz | 3 | Res. enh. filter: 5.1 dB/4.1 MHz
ResEnhFilter41DB41MHz | 4 | Res. enh. filter: 4.1 dB/4.1 MHz
ResEnhFilter30DB41MHz | 5 | Res. enh. filter: 3.0 dB/4.1 MHz
ResEnhFilter23DB41MHz | 6 | Res. enh. filter: 2.3 dB/4.1 MHz
ResEnhFilter16DB41MHz | 7 | Res. enh. filter: 1.6 dB/4.1 MHz
LowPassFilter2Db41MHz | 8 | Low pass filter 2 db/4.1 MHz
LowPassFilter3Db41MHz | 9 | Low pass filter 3 db/4.1 MHz
LowPassFilter3Db33MHz4DB41MHz | 10 | Low pass filter 3 db/3.3 MHz / 4 dB/4.1 MHz
LowPassFilter3Db26MHz8DB41MHz | 11 | Low pass filter 3 db/2.6 MHz / 8 dB/4.1 MHz
LowPassFilter3Db24MHz14DB41MHz | 12 | Low pass filter 3 db/2.4 MHz / 14 dB/4.1 MHz
LowPassFilter3Db22MHzNotchAt34MHz | 13 | Low pass filter 3 db/2.2 MHz / notch at 3.4 MHz
LowPassFilter3Db19MHzNotchAt30MHz | 14 | Low pass filter 3 db/1.9 MHz / notch at 3.0 MHz
LowPassFilter3Db17MHzNotchAt25MHz | 15 | Low pass filter 3 db/1.7 MHz / notch at 2.5 MHz
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDLUMINANCECONTROL1 Enumeration

IRD

Saa7119TYPIDLUMINANCECONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDLUMINANCECONTROL1
Public Enumeration TYPIDLUMINANCECONTROL1
public enum class TYPIDLUMINANCECONTROL1
type TYPIDLUMINANCECONTROL1
Members
Member name | Value | Description
SmallRemodulationBandwidth | 0 | Small remodulation bandwidth
LargeRemodulationBandwidth | 1 | Large remodulation bandwidth
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDLUMINANCECONTROL2 Enumeration

IRD

Saa7119TYPIDLUMINANCECONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDLUMINANCECONTROL2
Public Enumeration TYPIDLUMINANCECONTROL2
public enum class TYPIDLUMINANCECONTROL2
type TYPIDLUMINANCECONTROL2
Members
Member name | Value | Description
ProcessingDelayIsEqualToInternalPipeliningDelay | 0 | Processing delay is equal to internal pipelining delay
OneNTSCStandardsOrTwoPALStandardsVideoLinesAdditionalProcessingDelay | 1 | One (NTSC standards) or two (PAL standards) video lines additional processing delay
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDLUMINANCECONTROL3 Enumeration

IRD

Saa7119TYPIDLUMINANCECONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDLUMINANCECONTROL3
Public Enumeration TYPIDLUMINANCECONTROL3
public enum class TYPIDLUMINANCECONTROL3
type TYPIDLUMINANCECONTROL3
Members
Member name | Value | Description
Disabled | 0 | Disabled
Active | 1 | Active
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDLUMINANCECONTROL4 Enumeration

IRD

Saa7119TYPIDLUMINANCECONTROL4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDLUMINANCECONTROL4
Public Enumeration TYPIDLUMINANCECONTROL4
public enum class TYPIDLUMINANCECONTROL4
type TYPIDLUMINANCECONTROL4
Members
Member name | Value | Description
ChrominanceTrapOrLuminanceCombFilterActive | 0 | Chrominance trap or luminance comb filter active
ChrominanceTrapOrLuminanceCombFilterBypassed | 1 | Chrominance trap or luminance comb filter bypassed
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDMISCCHROMACONTTVVCRDETECTION0 Enumeration

IRD

Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMISCCHROMACONTTVVCRDETECTION0
Public Enumeration TYPIDMISCCHROMACONTTVVCRDETECTION0
public enum class TYPIDMISCCHROMACONTTVVCRDETECTION0
type TYPIDMISCCHROMACONTTVVCRDETECTION0
Members
Member name | Value | Description
SequenceCorrectionEnabledOncePerField | 0 | Sequence correction enabled once per field
ToBeUsedIfImmediateSequenceCorrectionIsRequired | 1 | To be used, if immediate sequence correction is required
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDMISCCHROMACONTTVVCRDETECTION1 Enumeration

IRD

Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMISCCHROMACONTTVVCRDETECTION1
Public Enumeration TYPIDMISCCHROMACONTTVVCRDETECTION1
public enum class TYPIDMISCCHROMACONTTVVCRDETECTION1
type TYPIDMISCCHROMACONTTVVCRDETECTION1
Members
Member name | Value | Description
Disabled | 0 | Disabled
Active | 1 | Active
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDMISCCHROMACONTTVVCRDETECTION2 Enumeration

IRD

Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMISCCHROMACONTTVVCRDETECTION2
Public Enumeration TYPIDMISCCHROMACONTTVVCRDETECTION2
public enum class TYPIDMISCCHROMACONTTVVCRDETECTION2
type TYPIDMISCCHROMACONTTVVCRDETECTION2
Members
Member name | Value | Description
Normal | 0 | Normal
ExtremellyHighVerticalNoiseSuppression | 1 | Extremelly high vertical noise suppression
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDMISCCHROMACONTTVVCRDETECTION3 Enumeration

IRD

Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMISCCHROMACONTTVVCRDETECTION3
Public Enumeration TYPIDMISCCHROMACONTTVVCRDETECTION3
public enum class TYPIDMISCCHROMACONTTVVCRDETECTION3
type TYPIDMISCCHROMACONTTVVCRDETECTION3
Members
Member name | Value | Description
Disabled | 0 | Disabled
Active | 1 | Active
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDMISCCHROMACONTTVVCRDETECTION4 Enumeration

IRD

Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMISCCHROMACONTTVVCRDETECTION4
Public Enumeration TYPIDMISCCHROMACONTTVVCRDETECTION4
public enum class TYPIDMISCCHROMACONTTVVCRDETECTION4
type TYPIDMISCCHROMACONTTVVCRDETECTION4
Members
Member name | Value | Description
Off | 0 | Off
On | 1 | On
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDMISCCHROMACONTTVVCRDETECTION5 Enumeration

IRD

Saa7119TYPIDMISCCHROMACONTTVVCRDETECTION5 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMISCCHROMACONTTVVCRDETECTION5
Public Enumeration TYPIDMISCCHROMACONTTVVCRDETECTION5
public enum class TYPIDMISCCHROMACONTTVVCRDETECTION5
type TYPIDMISCCHROMACONTTVVCRDETECTION5
Members
Member name | Value | Description
VerySensitiveToPhaseErrors | 0 | Very sensitive to phase errors
RecommendedValue | 1 | Recommended value
LessSensitiveToPhaseErrors | 2 | Less sensitive to phase errors
InsensitiveToPhaseErrors | 3 | Insensitive to phase errors
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDMISCELLANEOUSVGATEMSBS0 Enumeration

IRD

Saa7119TYPIDMISCELLANEOUSVGATEMSBS0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMISCELLANEOUSVGATEMSBS0
Public Enumeration TYPIDMISCELLANEOUSVGATEMSBS0
public enum class TYPIDMISCELLANEOUSVGATEMSBS0
type TYPIDMISCELLANEOUSVGATEMSBS0
Members
Member name | Value | Description
VGATEPositionAccordingVGATEStartStop | 0 | VGATE position according VGATE start/stop
VGATEOccursOneLineEarlier | 1 | VGATE occurs one line earlier
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDMISCELLANEOUSVGATEMSBS1 Enumeration

IRD

Saa7119TYPIDMISCELLANEOUSVGATEMSBS1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMISCELLANEOUSVGATEMSBS1
Public Enumeration TYPIDMISCELLANEOUSVGATEMSBS1
public enum class TYPIDMISCELLANEOUSVGATEMSBS1
type TYPIDMISCELLANEOUSVGATEMSBS1
Members
Member name | Value | Description
Reserved | 0 | Reserved
OneFields | 1 | One fields
TwoFields | 2 | Two fields
ThreeFields | 3 | Three fields
FourFields | 4 | Four fields
FiveFields | 5 | Five fields
SixFields | 6 | Six fields
SevenFields | 7 | Seven fields
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDMISCELLANEOUSVGATEMSBS2 Enumeration

IRD

Saa7119TYPIDMISCELLANEOUSVGATEMSBS2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMISCELLANEOUSVGATEMSBS2
Public Enumeration TYPIDMISCELLANEOUSVGATEMSBS2
public enum class TYPIDMISCELLANEOUSVGATEMSBS2
type TYPIDMISCELLANEOUSVGATEMSBS2
Members
Member name | Value | Description
Enable | 0 | Enable
Value_3State | 1 | 3-state
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDMODEDELAYCONTROL1 Enumeration

IRD

Saa7119TYPIDMODEDELAYCONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMODEDELAYCONTROL1
Public Enumeration TYPIDMODEDELAYCONTROL1
public enum class TYPIDMODEDELAYCONTROL1
type TYPIDMODEDELAYCONTROL1
Members
Member name | Value | Description
NonInverted | 0 | Non-inverted
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDMODEDELAYCONTROL4 Enumeration

IRD

Saa7119TYPIDMODEDELAYCONTROL4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMODEDELAYCONTROL4
Public Enumeration TYPIDMODEDELAYCONTROL4
public enum class TYPIDMODEDELAYCONTROL4
type TYPIDMODEDELAYCONTROL4
Members
Member name | Value | Description
AutomaticColourKillerEnabled | 0 | Automatic colour killer enabled
ColourForcedOn | 1 | Colour forced on
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDOVERLAYCONTROL0 Enumeration

IRD

Saa7119TYPIDOVERLAYCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDOVERLAYCONTROL0
Public Enumeration TYPIDOVERLAYCONTROL0
public enum class TYPIDOVERLAYCONTROL0
type TYPIDOVERLAYCONTROL0
Members
Member name | Value | Description
ForceMAIN | 0 | Force MAIN
ForceOVERLAY | 1 | Force OVERLAY
DirectSoftMixing | 2 | Direct soft mixing
ForceBLUE | 3 | Force BLUE
FullMAINWithOverlay | 4 | Full MAIN with overlay
HalfMAINWithOverlay | 5 | Half MAIN with overlay
QuartMAINWithOverlay | 6 | Quart MAIN with overlay
FullMAINWithBlue | 7 | Full MAIN with blue
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDPANORAMAANDKEYSTONING0 Enumeration

IRD

Saa7119TYPIDPANORAMAANDKEYSTONING0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDPANORAMAANDKEYSTONING0
Public Enumeration TYPIDPANORAMAANDKEYSTONING0
public enum class TYPIDPANORAMAANDKEYSTONING0
type TYPIDPANORAMAANDKEYSTONING0
Members
Member name | Value | Description
NoPanoramaCurve | 0 | No panorama curve
MinimumScaleRatioOf1XS22220EG720InputPixelScaleRatioIsReducedBy123InTheMiddle | 1 | Minimum scale ratio of 1 - (XS/2)^2/(2^20),e.g. 720 input pixel : scale ratio is reduced by -12.3% in the middle
MinimumScaleRatioOf1XS22219EG720InputPixelScaleRatioIsReducedBy247InTheMiddle | 2 | Minimum scale ratio of 1 - (XS/2)^2 / (2^19), e.g. 720 input pixel : scale ratio is reduced by -24.7% in the middle
MinimumScaleRatioOf1125xXS22219EG720InputPixelScaleRatioIsReducedBy308InTheMiddle | 3 | Minimum scale ratio of 1 - [1.25x(XS/2)^2 / (2^19)], e.g. 720 input pixel : scale ratio is reduced by -30.8% in the middle
NoPanoramaCurve__1 | 4 | No panorama curve
AmaronapCurveInversCharacteristicTo001 | 5 | Amaronap curve - invers characteristic to '001'
AmaronapCurveInversCharacteristicTo010 | 6 | Amaronap curve - invers characteristic to '010'
AmaronapCurveInversCharacteristicTo011 | 7 | Amaronap curve - invers characteristic to '011'
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDPANORAMAANDKEYSTONING1 Enumeration

IRD

Saa7119TYPIDPANORAMAANDKEYSTONING1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDPANORAMAANDKEYSTONING1
Public Enumeration TYPIDPANORAMAANDKEYSTONING1
public enum class TYPIDPANORAMAANDKEYSTONING1
type TYPIDPANORAMAANDKEYSTONING1
Members
Member name | Value | Description
IPortSignalDefinitionsAndIPortBehaviourLikeForTheSAA7115 | 0 | I-port signal definitions and I-port behaviour like for the SAA7115
IPortSignalDefinitionsAndIPortBehaviourForPanelApplicationsTheRasterGeneratorAddrRange0x0xNeedToBeProgrammed | 1 | I-port signal definitions and I-port behaviour for panel applications the raster generator (addr. range 0x.. - 0x.. ) need to be programmed
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDPANORAMAANDKEYSTONING2 Enumeration

IRD

Saa7119TYPIDPANORAMAANDKEYSTONING2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDPANORAMAANDKEYSTONING2
Public Enumeration TYPIDPANORAMAANDKEYSTONING2
public enum class TYPIDPANORAMAANDKEYSTONING2
type TYPIDPANORAMAANDKEYSTONING2
Members
Member name | Value | Description
LikeSAA7115XSXDXSCYAndXSCCNeedToBeProgrammed | 0 | Like SAA7115, XS, XD, XSCY and XSCC need to be programmed
CalculationOfTheInternalHScaleIncrementByXSAndXDRatioXSXD | 1 | Calculation of the internal H-scale increment by XS and XD, ratio= XS/XD
CalculationOfTheInternalHScaleIncrementForKeystoneCompensationUpDownProjection | 2 | Calculation of the internal H-scale increment for keystone compensation (up-down projection)
CalculationOfTheInternalHScaleIncrementForKeystoneCompensationDownUpProjection | 3 | Calculation of the internal H-scale increment for keystone compensation (down-up projection)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDPANORAMAANDKEYSTONING3 Enumeration

IRD

Saa7119TYPIDPANORAMAANDKEYSTONING3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDPANORAMAANDKEYSTONING3
Public Enumeration TYPIDPANORAMAANDKEYSTONING3
public enum class TYPIDPANORAMAANDKEYSTONING3
type TYPIDPANORAMAANDKEYSTONING3
Members
Member name | Value | Description
ShiftOf1DisplayClockPerPixelFor24BitRGBModes | 0 | Shift of 1 display clock per pixel (for 24 bit RGB modes)
ShiftOf2DisplayClockPerPixelFor16BitYUVModes | 2 | Shift of 2 display clock per pixel (for 16 bit YUV modes)
ShiftOf4DisplayClockPerPixelFor8BitSerialYUVModes | 3 | Shift of 4 display clock per pixel (for 8 bit serial YUV modes)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDPLL1DIGANNASTATUS0 Enumeration

IRD

Saa7119TYPIDPLL1DIGANNASTATUS0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDPLL1DIGANNASTATUS0
Public Enumeration TYPIDPLL1DIGANNASTATUS0
public enum class TYPIDPLL1DIGANNASTATUS0
type TYPIDPLL1DIGANNASTATUS0
Members
Member name | Value | Description
PLLNotRunning | 0 | PLL not running
PLLRunning1MHz | 1 | PLL running (>1MHz)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDPLL1DIGANNASTATUS1 Enumeration

IRD

Saa7119TYPIDPLL1DIGANNASTATUS1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDPLL1DIGANNASTATUS1
Public Enumeration TYPIDPLL1DIGANNASTATUS1
public enum class TYPIDPLL1DIGANNASTATUS1
type TYPIDPLL1DIGANNASTATUS1
Members
Member name | Value | Description
PLLNotLocked | 0 | PLL not locked
PLLLocked | 1 | PLL locked
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDRAWDATAGAINCONTROL0 Enumeration

IRD

Saa7119TYPIDRAWDATAGAINCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDRAWDATAGAINCONTROL0
Public Enumeration TYPIDRAWDATAGAINCONTROL0
public enum class TYPIDRAWDATAGAINCONTROL0
type TYPIDRAWDATAGAINCONTROL0
Members
Member name | Value | Description
Value_0Off | 0 | 0 - Off
Value_128NominalLevel | 128 | 128 - Nominal level
Value_255DoubleAmplitude | 255 | 255 - Double Amplitude
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 Enumeration

IRD

Saa7119TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0
Public Enumeration TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0
public enum class TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0
type TYPIDRTSIGNALCONTROLOLRTS0OUTPUT0
Members
Member name | Value | Description
Value_3State | 0 | 3-state
ConstantLOW | 1 | Constant LOW
CREF135MHzTogglingPulse | 2 | CREF (13.5 MHz toggling pulse)
CREF2675MHzTogglingPulse | 3 | CREF2 (6.75 MHz toggling pulse)
HorizontalLockIndicator | 4 | Horizontal lock indicator
VerticalHorizontalLock | 5 | Vertical/horizontal lock
VerticalHorizontalLockColourDetected | 6 | Vertical/horizontal lock/colour detected
Reserved | 7 | Reserved
HREFHorizontalReferenceSignal | 8 | HREF, horizontal reference signal
ProgrammableWidthInLLC8Steps | 9 | Programmable width in LLC8 steps
HREFGatedWithVGATE | 10 | HREF gated with VGATE
Reserved__1 | 11 | Reserved
V123VerticalSync | 12 | V123: vertical sync
VGATEProgrammable | 13 | VGATE: programmable
LSBsOfThe9BitADCS | 14 | LSBs of the 9-bit ADC's
FIDPositionProgrammable | 15 | FID position programmable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDRTXPORTOUTPUTCONTROL0 Enumeration

IRD

Saa7119TYPIDRTXPORTOUTPUTCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDRTXPORTOUTPUTCONTROL0
Public Enumeration TYPIDRTXPORTOUTPUTCONTROL0
public enum class TYPIDRTXPORTOUTPUTCONTROL0
type TYPIDRTXPORTOUTPUTCONTROL0
Members
Member name | Value | Description
CopyOfInvertedHLCKStatusBit | 0 | Copy of inverted HLCK status bit
FastHorizontalLockIndicator | 1 | Fast horizontal lock indicator
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDRTXPORTOUTPUTCONTROL01 Enumeration

IRD

Saa7119TYPIDRTXPORTOUTPUTCONTROL01 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDRTXPORTOUTPUTCONTROL01
Public Enumeration TYPIDRTXPORTOUTPUTCONTROL01
public enum class TYPIDRTXPORTOUTPUTCONTROL01
type TYPIDRTXPORTOUTPUTCONTROL01
Members
Member name | Value | Description
ITU6568BitStandardModeXRHS | 0 | ITU656 - 8 Bit standard mode (XRHS)
ModifiedITU6568BitModeXRHS | 1 | Modified ITU656-8-bit mode (XRHS)
Value_8BitMultiplexedYCbCrModeXRHS | 2 | 8-bit multiplexed Y,Cb,Cr-mode (XRHS)
Reserved | 3 | Reserved
ITU65610BitStandardMode | 8 | ITU656-10-bit standard mode
ModifiedITU10BitMode | 9 | Modified ITU-10-bit mode
Value_10BitMultiplexedYCbCrMode | 10 | 10-bit multiplexed Y, Cb, Cr-mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDRTXPORTOUTPUTCONTROL1 Enumeration

IRD

Saa7119TYPIDRTXPORTOUTPUTCONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDRTXPORTOUTPUTCONTROL1
Public Enumeration TYPIDRTXPORTOUTPUTCONTROL1
public enum class TYPIDRTXPORTOUTPUTCONTROL1
type TYPIDRTXPORTOUTPUTCONTROL1
Members
Member name | Value | Description
V123 | 0 | V123
ITU656RelatedFieldID | 1 | ITU 656 related field ID
InvertedV123 | 2 | Inverted V123
InvertedITU656RelatedFieldID | 3 | Inverted ITU 656 related field ID
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDRTXPORTOUTPUTCONTROL2 Enumeration

IRD

Saa7119TYPIDRTXPORTOUTPUTCONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDRTXPORTOUTPUTCONTROL2
Public Enumeration TYPIDRTXPORTOUTPUTCONTROL2
public enum class TYPIDRTXPORTOUTPUTCONTROL2
type TYPIDRTXPORTOUTPUTCONTROL2
Members
Member name | Value | Description
HREF | 0 | HREF
ProgrammableWidthInLLC8Steps | 1 | Programmable width in LLC8 steps
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDRTXPORTOUTPUTCONTROL3 Enumeration

IRD

Saa7119TYPIDRTXPORTOUTPUTCONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDRTXPORTOUTPUTCONTROL3
Public Enumeration TYPIDRTXPORTOUTPUTCONTROL3
public enum class TYPIDRTXPORTOUTPUTCONTROL3
type TYPIDRTXPORTOUTPUTCONTROL3
Members
Member name | Value | Description
Value_3State | 0 | 3-state
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSLICERSET0 Enumeration

IRD

Saa7119TYPIDSLICERSET0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSLICERSET0
Public Enumeration TYPIDSLICERSET0
public enum class TYPIDSLICERSET0
type TYPIDSLICERSET0
Members
Member name | Value | Description
Active | 0 | Active
Stopped | 1 | Stopped
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSLICERSET1 Enumeration

IRD

Saa7119TYPIDSLICERSET1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSLICERSET1
Public Enumeration TYPIDSLICERSET1
public enum class TYPIDSLICERSET1
type TYPIDSLICERSET1
Members
Member name | Value | Description
OneFramingCodeErrorAllowed | 0 | One framing code error allowed
NoFramingCodeErrorsAllowed | 1 | No framing code errors allowed
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSLICERSET2 Enumeration

IRD

Saa7119TYPIDSLICERSET2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSLICERSET2
Public Enumeration TYPIDSLICERSET2
public enum class TYPIDSLICERSET2
type TYPIDSLICERSET2
Members
Member name | Value | Description
HammingCheckFor2BytesAfterFramingCode | 0 | Hamming check for 2 bytes after framing code
NoHammingCheck | 1 | No Hamming check
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSLICERSET3 Enumeration

IRD

Saa7119TYPIDSLICERSET3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSLICERSET3
Public Enumeration TYPIDSLICERSET3
public enum class TYPIDSLICERSET3
type TYPIDSLICERSET3
Members
Member name | Value | Description
AllWSS525PacketsAreConsideredValidRegardlessOfCRCERR | 0 | All WSS525 packets are considered valid, regardless of CRCERR
OnlyWSS525PacketsWithCRCERR0AreConsideredValid | 1 | Only WSS525 packets with CRCERR = 0 are considered valid
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSLICERSTATUSBITBITSDIDCODES1 Enumeration

IRD

Saa7119TYPIDSLICERSTATUSBITBITSDIDCODES1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSLICERSTATUSBITBITSDIDCODES1
Public Enumeration TYPIDSLICERSTATUSBITBITSDIDCODES1
public enum class TYPIDSLICERSTATUSBITBITSDIDCODES1
type TYPIDSLICERSTATUSBITBITSDIDCODES1
Members
Member name | Value | Description
NoFramingCode1ErrorInTheLastFrameDetected | 0 | No Framing code (1 error) in the last frame detected
FramingCodeWith1ErrorDetected | 1 | Framing code with 1 error detected
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSLICERSTATUSBITBITSDIDCODES2 Enumeration

IRD

Saa7119TYPIDSLICERSTATUSBITBITSDIDCODES2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSLICERSTATUSBITBITSDIDCODES2
Public Enumeration TYPIDSLICERSTATUSBITBITSDIDCODES2
public enum class TYPIDSLICERSTATUSBITBITSDIDCODES2
type TYPIDSLICERSTATUSBITBITSDIDCODES2
Members
Member name | Value | Description
NoFramingCode0ErrorInTheLastFrameDetected | 0 | No Framing code (0 error) in the last frame detected
FramingCodeWith0ErrorDetected | 1 | Framing code with 0 error detected
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSLICERSTATUSBITTHEODDFIELD00 Enumeration

IRD

Saa7119TYPIDSLICERSTATUSBITTHEODDFIELD00 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSLICERSTATUSBITTHEODDFIELD00
Public Enumeration TYPIDSLICERSTATUSBITTHEODDFIELD00
public enum class TYPIDSLICERSTATUSBITTHEODDFIELD00
type TYPIDSLICERSTATUSBITTHEODDFIELD00
Members
Member name | Value | Description
ProgrammedVbiDataTypeNotDetectedInCorrespondingLine | 0 | Programmed vbi data type not detected in corresponding line
VbiDataTypeDetectedInCorrespondingLine | 1 | Vbi data type detected in corresponding line
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSTATUSBYTE1VIDEODECODER0 Enumeration

IRD

Saa7119TYPIDSTATUSBYTE1VIDEODECODER0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSTATUSBYTE1VIDEODECODER0
Public Enumeration TYPIDSTATUSBYTE1VIDEODECODER0
public enum class TYPIDSTATUSBYTE1VIDEODECODER0
type TYPIDSTATUSBYTE1VIDEODECODER0
Members
Member name | Value | Description
NoColour | 0 | No colour
NTSC | 1 | NTSC
PAL | 2 | PAL
SECAM | 3 | SECAM
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSTATUSBYTE1VIDEODECODER1 Enumeration

IRD

Saa7119TYPIDSTATUSBYTE1VIDEODECODER1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSTATUSBYTE1VIDEODECODER1
Public Enumeration TYPIDSTATUSBYTE1VIDEODECODER1
public enum class TYPIDSTATUSBYTE1VIDEODECODER1
type TYPIDSTATUSBYTE1VIDEODECODER1
Members
Member name | Value | Description
NotYetReached | 0 | Not (yet) reached
LimitReached | 1 | Limit reached
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSTATUSBYTE1VIDEODECODER2 Enumeration

IRD

Saa7119TYPIDSTATUSBYTE1VIDEODECODER2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSTATUSBYTE1VIDEODECODER2
Public Enumeration TYPIDSTATUSBYTE1VIDEODECODER2
public enum class TYPIDSTATUSBYTE1VIDEODECODER2
type TYPIDSTATUSBYTE1VIDEODECODER2
Members
Member name | Value | Description
NotYetReached | 0 | Not (yet) reached
LimitReached | 1 | Limit reached
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSTATUSBYTE1VIDEODECODER3 Enumeration

IRD

Saa7119TYPIDSTATUSBYTE1VIDEODECODER3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSTATUSBYTE1VIDEODECODER3
Public Enumeration TYPIDSTATUSBYTE1VIDEODECODER3
public enum class TYPIDSTATUSBYTE1VIDEODECODER3
type TYPIDSTATUSBYTE1VIDEODECODER3
Members
Member name | Value | Description
NotYetReached | 0 | Not (yet) reached
LimitReached | 1 | Limit reached
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSTATUSBYTE1VIDEODECODER4 Enumeration

IRD

Saa7119TYPIDSTATUSBYTE1VIDEODECODER4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSTATUSBYTE1VIDEODECODER4
Public Enumeration TYPIDSTATUSBYTE1VIDEODECODER4
public enum class TYPIDSTATUSBYTE1VIDEODECODER4
type TYPIDSTATUSBYTE1VIDEODECODER4
Members
Member name | Value | Description
NotYetReached | 0 | Not (yet) reached
LimitReached | 1 | Limit reached
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSTATUSBYTE1VIDEODECODER5 Enumeration

IRD

Saa7119TYPIDSTATUSBYTE1VIDEODECODER5 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSTATUSBYTE1VIDEODECODER5
Public Enumeration TYPIDSTATUSBYTE1VIDEODECODER5
public enum class TYPIDSTATUSBYTE1VIDEODECODER5
type TYPIDSTATUSBYTE1VIDEODECODER5
Members
Member name | Value | Description
Locked | 0 | Locked
Unlocked | 1 | Unlocked
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSTATUSBYTE1VIDEODECODER6 Enumeration

IRD

Saa7119TYPIDSTATUSBYTE1VIDEODECODER6 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSTATUSBYTE1VIDEODECODER6
Public Enumeration TYPIDSTATUSBYTE1VIDEODECODER6
public enum class TYPIDSTATUSBYTE1VIDEODECODER6
type TYPIDSTATUSBYTE1VIDEODECODER6
Members
Member name | Value | Description
Nonstandard | 0 | Nonstandard
Standard | 1 | Standard
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSTATUSBYTE2VIDEODECODER4 Enumeration

IRD

Saa7119TYPIDSTATUSBYTE2VIDEODECODER4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSTATUSBYTE2VIDEODECODER4
Public Enumeration TYPIDSTATUSBYTE2VIDEODECODER4
public enum class TYPIDSTATUSBYTE2VIDEODECODER4
type TYPIDSTATUSBYTE2VIDEODECODER4
Members
Member name | Value | Description
NonstableTimebase | 0 | Nonstable timebase
StableTimebase | 1 | Stable timebase
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSTATUSBYTE2VIDEODECODER5 Enumeration

IRD

Saa7119TYPIDSTATUSBYTE2VIDEODECODER5 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSTATUSBYTE2VIDEODECODER5
Public Enumeration TYPIDSTATUSBYTE2VIDEODECODER5
public enum class TYPIDSTATUSBYTE2VIDEODECODER5
type TYPIDSTATUSBYTE2VIDEODECODER5
Members
Member name | Value | Description
Value_50 | 0 | 50
Value_60 | 1 | 60
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSTATUSBYTE2VIDEODECODER6 Enumeration

IRD

Saa7119TYPIDSTATUSBYTE2VIDEODECODER6 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSTATUSBYTE2VIDEODECODER6
Public Enumeration TYPIDSTATUSBYTE2VIDEODECODER6
public enum class TYPIDSTATUSBYTE2VIDEODECODER6
type TYPIDSTATUSBYTE2VIDEODECODER6
Members
Member name | Value | Description
BothLoopsLocked | 0 | Both loops locked
Unlocked | 1 | Unlocked
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSTATUSBYTE2VIDEODECODER7 Enumeration

IRD

Saa7119TYPIDSTATUSBYTE2VIDEODECODER7 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSTATUSBYTE2VIDEODECODER7
Public Enumeration TYPIDSTATUSBYTE2VIDEODECODER7
public enum class TYPIDSTATUSBYTE2VIDEODECODER7
type TYPIDSTATUSBYTE2VIDEODECODER7
Members
Member name | Value | Description
NonInterlaced | 0 | Non-interlaced
Interlaced | 1 | Interlaced
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSTATUSINFORMATIOATIONEDGIPART0 Enumeration

IRD

Saa7119TYPIDSTATUSINFORMATIOATIONEDGIPART0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSTATUSINFORMATIOATIONEDGIPART0
Public Enumeration TYPIDSTATUSINFORMATIOATIONEDGIPART0
public enum class TYPIDSTATUSINFORMATIOATIONEDGIPART0
type TYPIDSTATUSINFORMATIOATIONEDGIPART0
Members
Member name | Value | Description
BufferNotYetFull | 0 | Buffer not (yet) full
BufferFull | 1 | Buffer full
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSYNCCONTROL0 Enumeration

IRD

Saa7119TYPIDSYNCCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSYNCCONTROL0
Public Enumeration TYPIDSYNCCONTROL0
public enum class TYPIDSYNCCONTROL0
type TYPIDSYNCCONTROL0
Members
Member name | Value | Description
NormalMode | 0 | Normal mode
FastMode | 1 | Fast mode
FreeRunningMode | 2 | Free running mode
VerticalNoiseReductionBypassed | 3 | Vertical noise reduction bypassed
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSYNCCONTROL1 Enumeration

IRD

Saa7119TYPIDSYNCCONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSYNCCONTROL1
Public Enumeration TYPIDSYNCCONTROL1
public enum class TYPIDSYNCCONTROL1
type TYPIDSYNCCONTROL1
Members
Member name | Value | Description
PLLClosed | 0 | PLL closed
PLLOpen | 1 | PLL open
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSYNCCONTROL2 Enumeration

IRD

Saa7119TYPIDSYNCCONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSYNCCONTROL2
Public Enumeration TYPIDSYNCCONTROL2
public enum class TYPIDSYNCCONTROL2
type TYPIDSYNCCONTROL2
Members
Member name | Value | Description
TVMode | 0 | TV mode
VTRMode | 1 | VTR mode
AutomaticTVVCR | 2 | Automatic TV/VCR
FastLockingMode | 3 | Fast locking mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSYNCCONTROL3 Enumeration

IRD

Saa7119TYPIDSYNCCONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSYNCCONTROL3
Public Enumeration TYPIDSYNCCONTROL3
public enum class TYPIDSYNCCONTROL3
type TYPIDSYNCCONTROL3
Members
Member name | Value | Description
ODDEVENSignalTogglesOnlyWithInterlacedSource | 0 | ODD/EVEN signal toggles only with interlaced source
ODDEVENSignalTogglesFieldwiseEvenIfSourceIsNonInterlaced | 1 | ODD/EVEN signal toggles fieldwise even if source is non-interlaced
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSYNCCONTROL4 Enumeration

IRD

Saa7119TYPIDSYNCCONTROL4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSYNCCONTROL4
Public Enumeration TYPIDSYNCCONTROL4
public enum class TYPIDSYNCCONTROL4
type TYPIDSYNCCONTROL4
Members
Member name | Value | Description
Value_50Hz625Lines | 0 | 50 Hz, 625 lines
Value_60Hz525Lines | 1 | 60 Hz, 525 lines
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDSYNCCONTROL5 Enumeration

IRD

Saa7119TYPIDSYNCCONTROL5 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSYNCCONTROL5
Public Enumeration TYPIDSYNCCONTROL5
public enum class TYPIDSYNCCONTROL5
type TYPIDSYNCCONTROL5
Members
Member name | Value | Description
FieldStateDirectlyControlled | 0 | Field state directly controlled
AutomaticFieldDetection | 1 | Automatic field detection
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTACHROMINANCEIMOVEMENTCONTROL0 Enumeration

IRD

Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTACHROMINANCEIMOVEMENTCONTROL0
Public Enumeration TYPIDTACHROMINANCEIMOVEMENTCONTROL0
public enum class TYPIDTACHROMINANCEIMOVEMENTCONTROL0
type TYPIDTACHROMINANCEIMOVEMENTCONTROL0
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_14 | 1 | 1/4
Value_12 | 2 | 1/2
Value_1 | 3 | 1
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTACHROMINANCEIMOVEMENTCONTROL3 Enumeration

IRD

Saa7119TYPIDTACHROMINANCEIMOVEMENTCONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTACHROMINANCEIMOVEMENTCONTROL3
Public Enumeration TYPIDTACHROMINANCEIMOVEMENTCONTROL3
public enum class TYPIDTACHROMINANCEIMOVEMENTCONTROL3
type TYPIDTACHROMINANCEIMOVEMENTCONTROL3
Members
Member name | Value | Description
ChromaPeaking | 0 | Chroma peaking
OvershotReductionLevel1 | 2 | Overshot reduction level 1
OvershotReductionLevel2 | 3 | Overshot reduction level 2
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAEDGICONTROL0 Enumeration

IRD

Saa7119TYPIDTAEDGICONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAEDGICONTROL0
Public Enumeration TYPIDTAEDGICONTROL0
public enum class TYPIDTAEDGICONTROL0
type TYPIDTAEDGICONTROL0
Members
Member name | Value | Description
LinearInterpolationBetweenLines | 0 | Linear interpolation between lines
HigherOrderAccumulatingInterpolationBetterAliasSuppression | 1 | Higher order accumulating interpolation, better alias suppression
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAEDGICONTROL1 Enumeration

IRD

Saa7119TYPIDTAEDGICONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAEDGICONTROL1
Public Enumeration TYPIDTAEDGICONTROL1
public enum class TYPIDTAEDGICONTROL1
type TYPIDTAEDGICONTROL1
Members
Member name | Value | Description
No | 0 | No
LinesAreMirrored | 1 | Lines are mirrored
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAEDGICONTROL3 Enumeration

IRD

Saa7119TYPIDTAEDGICONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAEDGICONTROL3
Public Enumeration TYPIDTAEDGICONTROL3
public enum class TYPIDTAEDGICONTROL3
type TYPIDTAEDGICONTROL3
Members
Member name | Value | Description
VerticalInterpolation | 0 | Vertical interpolation
AngularInterpolation | 1 | Angular interpolation.
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAHORIZONTALINPINITIONOFFSETL0 Enumeration

IRD

Saa7119TYPIDTAHORIZONTALINPINITIONOFFSETL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAHORIZONTALINPINITIONOFFSETL0
Public Enumeration TYPIDTAHORIZONTALINPINITIONOFFSETL0
public enum class TYPIDTAHORIZONTALINPINITIONOFFSETL0
type TYPIDTAHORIZONTALINPINITIONOFFSETL0
Members
Member name | Value | Description
Value_0MinimumShouldBeKept | 2 | 0 - minimum (should be kept)
Value_3OddOffsetsCBCRCRCBSequence | 3 | 3 - Odd offsets: CB-CR -> CR-CB sequence
Value_4095MaximumPossiblePixelOffset | 4095 | 4095 - Maximum possible pixel offset
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAHORIZONTALINPWINDOWLENGTHL0 Enumeration

IRD

Saa7119TYPIDTAHORIZONTALINPWINDOWLENGTHL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAHORIZONTALINPWINDOWLENGTHL0
Public Enumeration TYPIDTAHORIZONTALINPWINDOWLENGTHL0
public enum class TYPIDTAHORIZONTALINPWINDOWLENGTHL0
type TYPIDTAHORIZONTALINPWINDOWLENGTHL0
Members
Member name | Value | Description
Value_0NoOutput | 0 | 0 - No output
Value_4095MaximumPossibleNumberOfInputPixels | 4095 | 4095 - Maximum possible number of input pixels
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 Enumeration

IRD

Saa7119TYPIDTAHORIZONTALLUMCEPHASEOFFSET0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
Public Enumeration TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
public enum class TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
type TYPIDTAHORIZONTALLUMCEPHASEOFFSET0
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_132 | 1 | 1/32
Value_232 | 2 | 2/32
Value_332 | 3 | 3/32
Value_432 | 4 | 4/32
Value_532 | 5 | 5/32
Value_632 | 6 | 6/32
Value_732 | 7 | 7/32
Value_832 | 8 | 8/32
Value_932 | 9 | 9/32
Value_1032 | 10 | 10/32
Value_1132 | 11 | 11/32
Value_1232 | 12 | 12/32
Value_1332 | 13 | 13/32
Value_1432 | 14 | 14/32
Value_1532 | 15 | 15/32
Value_1632 | 16 | 16/32
Value_1732 | 17 | 17/32
Value_1832 | 18 | 18/32
Value_1932 | 19 | 19/32
Value_2032 | 20 | 20/32
Value_2132 | 21 | 21/32
Value_2232 | 22 | 22/32
Value_2332 | 23 | 23/32
Value_2432 | 24 | 24/32
Value_2532 | 25 | 25/32
Value_2632 | 26 | 26/32
Value_2732 | 27 | 27/32
Value_2832 | 28 | 28/32
Value_2932 | 29 | 29/32
Value_3032 | 30 | 30/32
Value_3132 | 31 | 31/32
Value_1 | 32 | 1
Value_3332 | 33 | 33/32
Value_3432 | 34 | 34/32
Value_3532 | 35 | 35/32
Value_3632 | 36 | 36/32
Value_3732 | 37 | 37/32
Value_3832 | 38 | 38/32
Value_3932 | 39 | 39/32
Value_4032 | 40 | 40/32
Value_4132 | 41 | 41/32
Value_4232 | 42 | 42/32
Value_4332 | 43 | 43/32
Value_4432 | 44 | 44/32
Value_4532 | 45 | 45/32
Value_4632 | 46 | 46/32
Value_4732 | 47 | 47/32
Value_4832 | 48 | 48/32
Value_4932 | 49 | 49/32
Value_5032 | 50 | 50/32
Value_5132 | 51 | 51/32
Value_5232 | 52 | 52/32
Value_5332 | 53 | 53/32
Value_5432 | 54 | 54/32
Value_5532 | 55 | 55/32
Value_5632 | 56 | 56/32
Value_5732 | 57 | 57/32
Value_5832 | 58 | 58/32
Value_5932 | 59 | 59/32
Value_6032 | 60 | 60/32
Value_6132 | 61 | 61/32
Value_6232 | 62 | 62/32
Value_6332 | 63 | 63/32
Value_2 | 64 | 2
Value_6532 | 65 | 65/32
Value_6632 | 66 | 66/32
Value_6732 | 67 | 67/32
Value_6832 | 68 | 68/32
Value_6932 | 69 | 69/32
Value_7032 | 70 | 70/32
Value_7132 | 71 | 71/32
Value_7232 | 72 | 72/32
Value_7332 | 73 | 73/32
Value_7432 | 74 | 74/32
Value_7532 | 75 | 75/32
Value_7632 | 76 | 76/32
Value_7732 | 77 | 77/32
Value_7832 | 78 | 78/32
Value_7932 | 79 | 79/32
Value_8032 | 80 | 80/32
Value_8132 | 81 | 81/32
Value_8232 | 82 | 82/32
Value_8332 | 83 | 83/32
Value_8432 | 84 | 84/32
Value_8532 | 85 | 85/32
Value_8632 | 86 | 86/32
Value_8732 | 87 | 87/32
Value_8832 | 88 | 88/32
Value_8932 | 89 | 89/32
Value_9032 | 90 | 90/32
Value_9132 | 91 | 91/32
Value_9232 | 92 | 92/32
Value_9332 | 93 | 93/32
Value_9432 | 94 | 94/32
Value_9532 | 95 | 95/32
Value_3 | 96 | 3
Value_9732 | 97 | 97/32
Value_9832 | 98 | 98/32
Value_9932 | 99 | 99/32
Value_10032 | 100 | 100/32
Value_10132 | 101 | 101/32
Value_10232 | 102 | 102/32
Value_10332 | 103 | 103/32
Value_10432 | 104 | 104/32
Value_10532 | 105 | 105/32
Value_10632 | 106 | 106/32
Value_10732 | 107 | 107/32
Value_10832 | 108 | 108/32
Value_10932 | 109 | 109/32
Value_11032 | 110 | 110/32
Value_11132 | 111 | 111/32
Value_11232 | 112 | 112/32
Value_11332 | 113 | 113/32
Value_11432 | 114 | 114/32
Value_11532 | 115 | 115/32
Value_11632 | 116 | 116/32
Value_11732 | 117 | 117/32
Value_11832 | 118 | 118/32
Value_11932 | 119 | 119/32
Value_12032 | 120 | 120/32
Value_12132 | 121 | 121/32
Value_12232 | 122 | 122/32
Value_12332 | 123 | 123/32
Value_12432 | 124 | 124/32
Value_12532 | 125 | 125/32
Value_12632 | 126 | 126/32
Value_12732 | 127 | 127/32
Value_4 | 128 | 4
Value_12932 | 129 | 129/32
Value_13032 | 130 | 130/32
Value_13132 | 131 | 131/32
Value_13232 | 132 | 132/32
Value_13332 | 133 | 133/32
Value_13432 | 134 | 134/32
Value_13532 | 135 | 135/32
Value_13632 | 136 | 136/32
Value_13732 | 137 | 137/32
Value_13832 | 138 | 138/32
Value_13932 | 139 | 139/32
Value_14032 | 140 | 140/32
Value_14132 | 141 | 141/32
Value_14232 | 142 | 142/32
Value_14332 | 143 | 143/32
Value_14432 | 144 | 144/32
Value_14532 | 145 | 145/32
Value_14632 | 146 | 146/32
Value_14732 | 147 | 147/32
Value_14832 | 148 | 148/32
Value_14932 | 149 | 149/32
Value_15032 | 150 | 150/32
Value_15132 | 151 | 151/32
Value_15232 | 152 | 152/32
Value_15332 | 153 | 153/32
Value_15432 | 154 | 154/32
Value_15532 | 155 | 155/32
Value_15632 | 156 | 156/32
Value_15732 | 157 | 157/32
Value_15832 | 158 | 158/32
Value_15932 | 159 | 159/32
Value_5 | 160 | 5
Value_16132 | 161 | 161/32
Value_16232 | 162 | 162/32
Value_16332 | 163 | 163/32
Value_16432 | 164 | 164/32
Value_16532 | 165 | 165/32
Value_16632 | 166 | 166/32
Value_16732 | 167 | 167/32
Value_16832 | 168 | 168/32
Value_16932 | 169 | 169/32
Value_17032 | 170 | 170/32
Value_17132 | 171 | 171/32
Value_17232 | 172 | 172/32
Value_17332 | 173 | 173/32
Value_17432 | 174 | 174/32
Value_17532 | 175 | 175/32
Value_17632 | 176 | 176/32
Value_17732 | 177 | 177/32
Value_17832 | 178 | 178/32
Value_17932 | 179 | 179/32
Value_18032 | 180 | 180/32
Value_18132 | 181 | 181/32
Value_18232 | 182 | 182/32
Value_18332 | 183 | 183/32
Value_18432 | 184 | 184/32
Value_18532 | 185 | 185/32
Value_18632 | 186 | 186/32
Value_18732 | 187 | 187/32
Value_18832 | 188 | 188/32
Value_18932 | 189 | 189/32
Value_19032 | 190 | 190/32
Value_19132 | 191 | 191/32
Value_6 | 192 | 6
Value_19332 | 193 | 193/32
Value_19432 | 194 | 194/32
Value_19532 | 195 | 195/32
Value_19632 | 196 | 196/32
Value_19732 | 197 | 197/32
Value_19832 | 198 | 198/32
Value_19932 | 199 | 199/32
Value_20032 | 200 | 200/32
Value_20132 | 201 | 201/32
Value_20232 | 202 | 202/32
Value_20332 | 203 | 203/32
Value_20432 | 204 | 204/32
Value_20532 | 205 | 205/32
Value_20632 | 206 | 206/32
Value_20732 | 207 | 207/32
Value_20832 | 208 | 208/32
Value_20932 | 209 | 209/32
Value_21032 | 210 | 210/32
Value_21132 | 211 | 211/32
Value_21232 | 212 | 212/32
Value_21332 | 213 | 213/32
Value_21432 | 214 | 214/32
Value_21532 | 215 | 215/32
Value_21632 | 216 | 216/32
Value_21732 | 217 | 217/32
Value_21832 | 218 | 218/32
Value_21932 | 219 | 219/32
Value_22032 | 220 | 220/32
Value_22132 | 221 | 221/32
Value_22232 | 222 | 222/32
Value_22332 | 223 | 223/32
Value_7 | 224 | 7
Value_22532 | 225 | 225/32
Value_22632 | 226 | 226/32
Value_22732 | 227 | 227/32
Value_22832 | 228 | 228/32
Value_22932 | 229 | 229/32
Value_23032 | 230 | 230/32
Value_23132 | 231 | 231/32
Value_23232 | 232 | 232/32
Value_23332 | 233 | 233/32
Value_23432 | 234 | 234/32
Value_23532 | 235 | 235/32
Value_23632 | 236 | 236/32
Value_23732 | 237 | 237/32
Value_23832 | 238 | 238/32
Value_23932 | 239 | 239/32
Value_24032 | 240 | 240/32
Value_24132 | 241 | 241/32
Value_24232 | 242 | 242/32
Value_24332 | 243 | 243/32
Value_24432 | 244 | 244/32
Value_24532 | 245 | 245/32
Value_24632 | 246 | 246/32
Value_24732 | 247 | 247/32
Value_24832 | 248 | 248/32
Value_24932 | 249 | 249/32
Value_25032 | 250 | 250/32
Value_25132 | 251 | 251/32
Value_25232 | 252 | 252/32
Value_25332 | 253 | 253/32
Value_25432 | 254 | 254/32
Value_25532 | 255 | 255/32
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 Enumeration

IRD

Saa7119TYPIDTAHORIZONTALOUTWINDOWLENGTHL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAHORIZONTALOUTWINDOWLENGTHL0
Public Enumeration TYPIDTAHORIZONTALOUTWINDOWLENGTHL0
public enum class TYPIDTAHORIZONTALOUTWINDOWLENGTHL0
type TYPIDTAHORIZONTALOUTWINDOWLENGTHL0
Members
Member name | Value | Description
Value_0NoOutput | 0 | 0 - No output
Value_4095MaximumPossibleNumberOfInputPixels | 4095 | 4095 - Maximum possible number of input pixels
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAHORIZONTALPRESCALING0 Enumeration

IRD

Saa7119TYPIDTAHORIZONTALPRESCALING0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAHORIZONTALPRESCALING0
Public Enumeration TYPIDTAHORIZONTALPRESCALING0
public enum class TYPIDTAHORIZONTALPRESCALING0
type TYPIDTAHORIZONTALPRESCALING0
Members
Member name | Value | Description
Value_10 | 0 | 1/0
Value_11 | 1 | 1/1
Value_12 | 2 | 1/2
Value_13 | 3 | 1/3
Value_14 | 4 | 1/4
Value_15 | 5 | 1/5
Value_16 | 6 | 1/6
Value_17 | 7 | 1/7
Value_18 | 8 | 1/8
Value_19 | 9 | 1/9
Value_110 | 10 | 1/10
Value_111 | 11 | 1/11
Value_112 | 12 | 1/12
Value_113 | 13 | 1/13
Value_114 | 14 | 1/14
Value_115 | 15 | 1/15
Value_116 | 16 | 1/16
Value_117 | 17 | 1/17
Value_118 | 18 | 1/18
Value_119 | 19 | 1/19
Value_120 | 20 | 1/20
Value_121 | 21 | 1/21
Value_122 | 22 | 1/22
Value_123 | 23 | 1/23
Value_124 | 24 | 1/24
Value_125 | 25 | 1/25
Value_126 | 26 | 1/26
Value_127 | 27 | 1/27
Value_128 | 28 | 1/28
Value_129 | 29 | 1/29
Value_130 | 30 | 1/30
Value_131 | 31 | 1/31
Value_132 | 32 | 1/32
Value_133 | 33 | 1/33
Value_134 | 34 | 1/34
Value_135 | 35 | 1/35
Value_136 | 36 | 1/36
Value_137 | 37 | 1/37
Value_138 | 38 | 1/38
Value_139 | 39 | 1/39
Value_140 | 40 | 1/40
Value_141 | 41 | 1/41
Value_142 | 42 | 1/42
Value_143 | 43 | 1/43
Value_144 | 44 | 1/44
Value_145 | 45 | 1/45
Value_146 | 46 | 1/46
Value_147 | 47 | 1/47
Value_148 | 48 | 1/48
Value_149 | 49 | 1/49
Value_150 | 50 | 1/50
Value_151 | 51 | 1/51
Value_152 | 52 | 1/52
Value_153 | 53 | 1/53
Value_154 | 54 | 1/54
Value_155 | 55 | 1/55
Value_156 | 56 | 1/56
Value_157 | 57 | 1/57
Value_158 | 58 | 1/58
Value_159 | 59 | 1/59
Value_160 | 60 | 1/60
Value_161 | 61 | 1/61
Value_162 | 62 | 1/62
Value_163 | 63 | 1/63
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAIPORTOUTPUTDCONFIGURATION0 Enumeration

IRD

Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAIPORTOUTPUTDCONFIGURATION0
Public Enumeration TYPIDTAIPORTOUTPUTDCONFIGURATION0
public enum class TYPIDTAIPORTOUTPUTDCONFIGURATION0
type TYPIDTAIPORTOUTPUTDCONFIGURATION0
Members
Member name | Value | Description
Value_422DwordFormatting | 0 | 4:2:2 - Dword formatting
Value_411DwordFormatting | 1 | 4:1:1 - Dword formatting
Value_420OnlyEvery2ndLineYCBCROutputInBetweenYonlyOutput | 2 | 4:2:0 - Only every 2nd line Y + CB-CR output, in between Yonly output)
Value_410OnlyEvery4thLineYCBCROutputInBetweenYonlyOutput | 3 | 4:1:0 - Only every 4th line Y + CB-CR output, in between Yonly output)
Yonly | 4 | Yonly
NotDefined | 5 | Not defined
Value_24bitRGBMode888ViaHPDIXDIPDPort | 7 | 24bit RGB Mode 8-8-8 (via HPD, IXD, IPD port)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAIPORTOUTPUTDCONFIGURATION1 Enumeration

IRD

Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAIPORTOUTPUTDCONFIGURATION1
Public Enumeration TYPIDTAIPORTOUTPUTDCONFIGURATION1
public enum class TYPIDTAIPORTOUTPUTDCONFIGURATION1
type TYPIDTAIPORTOUTPUTDCONFIGURATION1
Members
Member name | Value | Description
NoLine | 0 | No line
Value_1Line | 1 | 1 line
Value_2Lines | 2 | 2 lines
Value_3Lines | 3 | 3 lines
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAIPORTOUTPUTDCONFIGURATION2 Enumeration

IRD

Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAIPORTOUTPUTDCONFIGURATION2
Public Enumeration TYPIDTAIPORTOUTPUTDCONFIGURATION2
public enum class TYPIDTAIPORTOUTPUTDCONFIGURATION2
type TYPIDTAIPORTOUTPUTDCONFIGURATION2
Members
Member name | Value | Description
AllLinesWillBeOutput | 0 | All lines will be output
SkipTheNumberOfLeadingYOnlyLinesAsDefinedByFOI1AndFOI0 | 1 | Skip the number of leading Y only lines, as defined by FOI1 and FOI0
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAIPORTOUTPUTDCONFIGURATION3 Enumeration

IRD

Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAIPORTOUTPUTDCONFIGURATION3
Public Enumeration TYPIDTAIPORTOUTPUTDCONFIGURATION3
public enum class TYPIDTAIPORTOUTPUTDCONFIGURATION3
type TYPIDTAIPORTOUTPUTDCONFIGURATION3
Members
Member name | Value | Description
FilledWith0x00 | 0 | Filled with 0x00
FilledWith0x80 | 1 | Filled with 0x80
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAIPORTOUTPUTDCONFIGURATION4 Enumeration

IRD

Saa7119TYPIDTAIPORTOUTPUTDCONFIGURATION4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAIPORTOUTPUTDCONFIGURATION4
Public Enumeration TYPIDTAIPORTOUTPUTDCONFIGURATION4
public enum class TYPIDTAIPORTOUTPUTDCONFIGURATION4
type TYPIDTAIPORTOUTPUTDCONFIGURATION4
Members
Member name | Value | Description
NoITU656LikeSAVEAVCodesAreAvailable | 0 | No ITU 656 like SAV/EAV codes are available
ITU656LikeSAVEAVCodesAreInsertedInTheOutputDataStreamFramedByAQualifier | 1 | ITU 656 like SAV/EAV codes are inserted in the output data stream, framed by a qualifier
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTALUMINANCECONTONTRASTCONTROL0 Enumeration

IRD

Saa7119TYPIDTALUMINANCECONTONTRASTCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTALUMINANCECONTONTRASTCONTROL0
Public Enumeration TYPIDTALUMINANCECONTONTRASTCONTROL0
public enum class TYPIDTALUMINANCECONTONTRASTCONTROL0
type TYPIDTALUMINANCECONTONTRASTCONTROL0
Members
Member name | Value | Description
Gain0 | 0 | Gain=0
Gain164 | 1 | Gain=1/64
Gain264 | 2 | Gain=2/64
Gain364 | 3 | Gain=3/64
Gain464 | 4 | Gain=4/64
Gain564 | 5 | Gain=5/64
Gain664 | 6 | Gain=6/64
Gain764 | 7 | Gain=7/64
Gain864 | 8 | Gain=8/64
Gain964 | 9 | Gain=9/64
Gain1064 | 10 | Gain=10/64
Gain1164 | 11 | Gain=11/64
Gain1264 | 12 | Gain=12/64
Gain1364 | 13 | Gain=13/64
Gain1464 | 14 | Gain=14/64
Gain1564 | 15 | Gain=15/64
Gain1664 | 16 | Gain=16/64
Gain1764 | 17 | Gain=17/64
Gain1864 | 18 | Gain=18/64
Gain1964 | 19 | Gain=19/64
Gain2064 | 20 | Gain=20/64
Gain2164 | 21 | Gain=21/64
Gain2264 | 22 | Gain=22/64
Gain2364 | 23 | Gain=23/64
Gain2464 | 24 | Gain=24/64
Gain2564 | 25 | Gain=25/64
Gain2664 | 26 | Gain=26/64
Gain2764 | 27 | Gain=27/64
Gain2864 | 28 | Gain=28/64
Gain2964 | 29 | Gain=29/64
Gain3064 | 30 | Gain=30/64
Gain3164 | 31 | Gain=31/64
Gain3264 | 32 | Gain=32/64
Gain3364 | 33 | Gain=33/64
Gain3464 | 34 | Gain=34/64
Gain3564 | 35 | Gain=35/64
Gain3664 | 36 | Gain=36/64
Gain3764 | 37 | Gain=37/64
Gain3864 | 38 | Gain=38/64
Gain3964 | 39 | Gain=39/64
Gain4064 | 40 | Gain=40/64
Gain4164 | 41 | Gain=41/64
Gain4264 | 42 | Gain=42/64
Gain4364 | 43 | Gain=43/64
Gain4464 | 44 | Gain=44/64
Gain4564 | 45 | Gain=45/64
Gain4664 | 46 | Gain=46/64
Gain4764 | 47 | Gain=47/64
Gain4864 | 48 | Gain=48/64
Gain4964 | 49 | Gain=49/64
Gain5064 | 50 | Gain=50/64
Gain5164 | 51 | Gain=51/64
Gain5264 | 52 | Gain=52/64
Gain5364 | 53 | Gain=53/64
Gain5464 | 54 | Gain=54/64
Gain5564 | 55 | Gain=55/64
Gain5664 | 56 | Gain=56/64
Gain5764 | 57 | Gain=57/64
Gain5864 | 58 | Gain=58/64
Gain5964 | 59 | Gain=59/64
Gain6064 | 60 | Gain=60/64
Gain6164 | 61 | Gain=61/64
Gain6264 | 62 | Gain=62/64
Gain6364 | 63 | Gain=63/64
Gain1 | 64 | Gain=1
Gain6564 | 65 | Gain=65/64
Gain6664 | 66 | Gain=66/64
Gain6764 | 67 | Gain=67/64
Gain6864 | 68 | Gain=68/64
Gain6964 | 69 | Gain=69/64
Gain7064 | 70 | Gain=70/64
Gain7164 | 71 | Gain=71/64
Gain7264 | 72 | Gain=72/64
Gain7364 | 73 | Gain=73/64
Gain7464 | 74 | Gain=74/64
Gain7564 | 75 | Gain=75/64
Gain7664 | 76 | Gain=76/64
Gain7764 | 77 | Gain=77/64
Gain7864 | 78 | Gain=78/64
Gain7964 | 79 | Gain=79/64
Gain8064 | 80 | Gain=80/64
Gain8164 | 81 | Gain=81/64
Gain8264 | 82 | Gain=82/64
Gain8364 | 83 | Gain=83/64
Gain8464 | 84 | Gain=84/64
Gain8564 | 85 | Gain=85/64
Gain8664 | 86 | Gain=86/64
Gain8764 | 87 | Gain=87/64
Gain8864 | 88 | Gain=88/64
Gain8964 | 89 | Gain=89/64
Gain9064 | 90 | Gain=90/64
Gain9164 | 91 | Gain=91/64
Gain9264 | 92 | Gain=92/64
Gain9364 | 93 | Gain=93/64
Gain9464 | 94 | Gain=94/64
Gain9564 | 95 | Gain=95/64
Gain9664 | 96 | Gain=96/64
Gain9764 | 97 | Gain=97/64
Gain9864 | 98 | Gain=98/64
Gain9964 | 99 | Gain=99/64
Gain10064 | 100 | Gain=100/64
Gain10164 | 101 | Gain=101/64
Gain10264 | 102 | Gain=102/64
Gain10364 | 103 | Gain=103/64
Gain10464 | 104 | Gain=104/64
Gain10564 | 105 | Gain=105/64
Gain10664 | 106 | Gain=106/64
Gain10764 | 107 | Gain=107/64
Gain10864 | 108 | Gain=108/64
Gain10964 | 109 | Gain=109/64
Gain11064 | 110 | Gain=110/64
Gain11164 | 111 | Gain=111/64
Gain11264 | 112 | Gain=112/64
Gain11364 | 113 | Gain=113/64
Gain11464 | 114 | Gain=114/64
Gain11564 | 115 | Gain=115/64
Gain11664 | 116 | Gain=116/64
Gain11764 | 117 | Gain=117/64
Gain11864 | 118 | Gain=118/64
Gain11964 | 119 | Gain=119/64
Gain12064 | 120 | Gain=120/64
Gain12164 | 121 | Gain=121/64
Gain12264 | 122 | Gain=122/64
Gain12364 | 123 | Gain=123/64
Gain12464 | 124 | Gain=124/64
Gain12564 | 125 | Gain=125/64
Gain12664 | 126 | Gain=126/64
Gain12764 | 127 | Gain=127/64
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTALUMINANCEIMPROVEMENTCONTROL0 Enumeration

IRD

Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTALUMINANCEIMPROVEMENTCONTROL0
Public Enumeration TYPIDTALUMINANCEIMPROVEMENTCONTROL0
public enum class TYPIDTALUMINANCEIMPROVEMENTCONTROL0
type TYPIDTALUMINANCEIMPROVEMENTCONTROL0
Members
Member name | Value | Description
PeakingOFF | 0 | Peaking OFF
Value_18 | 1 | 1/8
Value_316 | 2 | 3/16
Value_14 | 3 | 1/4
Value_38 | 4 | 3/8
Value_14__1 | 5 | 1/4
Value_34 | 6 | 3/4
Value_1 | 7 | 1
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTALUMINANCEIMPROVEMENTCONTROL3 Enumeration

IRD

Saa7119TYPIDTALUMINANCEIMPROVEMENTCONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTALUMINANCEIMPROVEMENTCONTROL3
Public Enumeration TYPIDTALUMINANCEIMPROVEMENTCONTROL3
public enum class TYPIDTALUMINANCEIMPROVEMENTCONTROL3
type TYPIDTALUMINANCEIMPROVEMENTCONTROL3
Members
Member name | Value | Description
LumaPeaking | 0 | Luma peaking
OvershotReductionLevel1 | 2 | Overshot reduction level 1
OvershotReductionLevel2 | 3 | Overshot reduction level 2
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAPRESCALERDCGEFILTERCONTROL0 Enumeration

IRD

Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAPRESCALERDCGEFILTERCONTROL0
Public Enumeration TYPIDTAPRESCALERDCGEFILTERCONTROL0
public enum class TYPIDTAPRESCALERDCGEFILTERCONTROL0
type TYPIDTAPRESCALERDCGEFILTERCONTROL0
Members
Member name | Value | Description
PrescalerOutputIsRenormalizedByGainFactor11 | 0 | Prescaler output is renormalized by gain factor=1/1
PrescalerOutputIsRenormalizedByGainFactor12 | 1 | Prescaler output is renormalized by gain factor=1/2
PrescalerOutputIsRenormalizedByGainFactor14 | 2 | Prescaler output is renormalized by gain factor=1/4
PrescalerOutputIsRenormalizedByGainFactor18 | 3 | Prescaler output is renormalized by gain factor=1/8
PrescalerOutputIsRenormalizedByGainFactor116 | 4 | Prescaler output is renormalized by gain factor=1/16
PrescalerOutputIsRenormalizedByGainFactor132 | 5 | Prescaler output is renormalized by gain factor=1/32
PrescalerOutputIsRenormalizedByGainFactor164 | 6 | Prescaler output is renormalized by gain factor=1/64
PrescalerOutputIsRenormalizedByGainFactor1128 | 7 | Prescaler output is renormalized by gain factor=1/128
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAPRESCALERDCGEFILTERCONTROL2 Enumeration

IRD

Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAPRESCALERDCGEFILTERCONTROL2
Public Enumeration TYPIDTAPRESCALERDCGEFILTERCONTROL2
public enum class TYPIDTAPRESCALERDCGEFILTERCONTROL2
type TYPIDTAPRESCALERDCGEFILTERCONTROL2
Members
Member name | Value | Description
LuminanceFIRFilterBypassed | 0 | Luminance FIR filter bypassed
HYZ14121 | 1 | H_y(z) = 1/4(1 2 1)
HYZ18111754517511 | 2 | H_y(z) = 1/8 (-1 1 1.75 4.5 1.75 1 -1)
HYZ1812221 | 3 | H_y(z) = 1/8 (1 2 2 2 1)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAPRESCALERDCGEFILTERCONTROL3 Enumeration

IRD

Saa7119TYPIDTAPRESCALERDCGEFILTERCONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAPRESCALERDCGEFILTERCONTROL3
Public Enumeration TYPIDTAPRESCALERDCGEFILTERCONTROL3
public enum class TYPIDTAPRESCALERDCGEFILTERCONTROL3
type TYPIDTAPRESCALERDCGEFILTERCONTROL3
Members
Member name | Value | Description
ChrominanceFIRFilterBypassed | 0 | Chrominance FIR filter bypassed
HUvZ14121 | 1 | H_uv(z) = 1/4 (1 2 1)
HUvZ132381083 | 2 | H_uv(z) = 1/32 (3 8 10 8 3)
HUvZ1812221 | 3 | H_uv(z) = 1/8 (1 2 2 2 1)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTASCALERPOSTPRCESSINGCONTROL0 Enumeration

IRD

Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTASCALERPOSTPRCESSINGCONTROL0
Public Enumeration TYPIDTASCALERPOSTPRCESSINGCONTROL0
public enum class TYPIDTASCALERPOSTPRCESSINGCONTROL0
type TYPIDTASCALERPOSTPRCESSINGCONTROL0
Members
Member name | Value | Description
On | 0 | On
Bypass | 1 | Bypass
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTASCALERPOSTPRCESSINGCONTROL1 Enumeration

IRD

Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTASCALERPOSTPRCESSINGCONTROL1
Public Enumeration TYPIDTASCALERPOSTPRCESSINGCONTROL1
public enum class TYPIDTASCALERPOSTPRCESSINGCONTROL1
type TYPIDTASCALERPOSTPRCESSINGCONTROL1
Members
Member name | Value | Description
Bypass | 0 | Bypass
On | 1 | On
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTASCALERPOSTPRCESSINGCONTROL2 Enumeration

IRD

Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTASCALERPOSTPRCESSINGCONTROL2
Public Enumeration TYPIDTASCALERPOSTPRCESSINGCONTROL2
public enum class TYPIDTASCALERPOSTPRCESSINGCONTROL2
type TYPIDTASCALERPOSTPRCESSINGCONTROL2
Members
Member name | Value | Description
On | 0 | On
Bypass | 1 | Bypass
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTASCALERPOSTPRCESSINGCONTROL3 Enumeration

IRD

Saa7119TYPIDTASCALERPOSTPRCESSINGCONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTASCALERPOSTPRCESSINGCONTROL3
Public Enumeration TYPIDTASCALERPOSTPRCESSINGCONTROL3
public enum class TYPIDTASCALERPOSTPRCESSINGCONTROL3
type TYPIDTASCALERPOSTPRCESSINGCONTROL3
Members
Member name | Value | Description
Off9BitTruncatedTo8Bit | 0 | Off, 9 bit truncated to 8 bit
Value_9Bit8Bit | 1 | 9 bit -> 8 bit
Value_9Bit6Bit | 2 | 9 bit -> 6 bit
Value_9Bit5Bit | 3 | 9 bit -> 5 bit
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTATASKHANDLINGCONTROL0 Enumeration

IRD

Saa7119TYPIDTATASKHANDLINGCONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTATASKHANDLINGCONTROL0
Public Enumeration TYPIDTATASKHANDLINGCONTROL0
public enum class TYPIDTATASKHANDLINGCONTROL0
type TYPIDTATASKHANDLINGCONTROL0
Members
Member name | Value | Description
ImmediatelyAfterFinishingATask | 0 | Immediately after finishing a task
NextVSync | 1 | Next V-sync
WithFieldID0 | 2 | With field ID=0
WithFieldID1 | 3 | With field ID=1
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTATASKHANDLINGCONTROL1 Enumeration

IRD

Saa7119TYPIDTATASKHANDLINGCONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTATASKHANDLINGCONTROL1
Public Enumeration TYPIDTATASKHANDLINGCONTROL1
public enum class TYPIDTATASKHANDLINGCONTROL1
type TYPIDTATASKHANDLINGCONTROL1
Members
Member name | Value | Description
IfActiveTaskIsFinishedHandlingIsTakenOverByTheNextTask | 0 | If active task is finished, handling is taken over by the next task
ActiveTaskIsRepeatedOnceBeforeHandlingIsTakenOverByTheNextTask | 1 | Active task is repeated once, before handling is taken over by the next task
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTATASKHANDLINGCONTROL2 Enumeration

IRD

Saa7119TYPIDTATASKHANDLINGCONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTATASKHANDLINGCONTROL2
Public Enumeration TYPIDTATASKHANDLINGCONTROL2
public enum class TYPIDTATASKHANDLINGCONTROL2
type TYPIDTATASKHANDLINGCONTROL2
Members
Member name | Value | Description
ActiveTaskIsCarriedOutDirectly | 0 | Active task is carried out directly
Value_1FieldIsSkippedBeforeActiveTaskIsCarriedOut | 1 | 1 field is skipped before active task is carried out
Value_2FieldIsSkippedBeforeActiveTaskIsCarriedOut | 2 | 2 field is skipped before active task is carried out
Value_3FieldIsSkippedBeforeActiveTaskIsCarriedOut | 3 | 3 field is skipped before active task is carried out
Value_4FieldIsSkippedBeforeActiveTaskIsCarriedOut | 4 | 4 field is skipped before active task is carried out
Value_5FieldIsSkippedBeforeActiveTaskIsCarriedOut | 5 | 5 field is skipped before active task is carried out
Value_6FieldIsSkippedBeforeActiveTaskIsCarriedOut | 6 | 6 field is skipped before active task is carried out
Value_7FieldIsSkippedBeforeActiveTaskIsCarriedOut | 7 | 7 field is skipped before active task is carried out
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTATASKHANDLINGCONTROL3 Enumeration

IRD

Saa7119TYPIDTATASKHANDLINGCONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTATASKHANDLINGCONTROL3
Public Enumeration TYPIDTATASKHANDLINGCONTROL3
public enum class TYPIDTATASKHANDLINGCONTROL3
type TYPIDTATASKHANDLINGCONTROL3
Members
Member name | Value | Description
FieldIDFromScalerInput | 0 | Field ID from scaler input
TaskStatusFlag | 1 | Task status flag
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTATASKHANDLINGCONTROL4 Enumeration

IRD

Saa7119TYPIDTATASKHANDLINGCONTROL4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTATASKHANDLINGCONTROL4
Public Enumeration TYPIDTATASKHANDLINGCONTROL4
public enum class TYPIDTATASKHANDLINGCONTROL4
type TYPIDTATASKHANDLINGCONTROL4
Members
Member name | Value | Description
TaskFlag1 | 0 | Task flag=1
TaskFlag0 | 1 | Task flag=0
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAVERTICALINPUTDOWDEFINITIONH0 Enumeration

IRD

Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONH0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAVERTICALINPUTDOWDEFINITIONH0
Public Enumeration TYPIDTAVERTICALINPUTDOWDEFINITIONH0
public enum class TYPIDTAVERTICALINPUTDOWDEFINITIONH0
type TYPIDTAVERTICALINPUTDOWDEFINITIONH0
Members
Member name | Value | Description
VerticalProcessingIsDefinedByOffsetAndLengthParameters | 0 | Vertical processing is defined by offset and length parameters
VerticalProcessingIsDefinedByStartAndEndLineParameters | 1 | Vertical processing is defined by start and end line parameters
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAVERTICALINPUTDOWDEFINITIONL0 Enumeration

IRD

Saa7119TYPIDTAVERTICALINPUTDOWDEFINITIONL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAVERTICALINPUTDOWDEFINITIONL0
Public Enumeration TYPIDTAVERTICALINPUTDOWDEFINITIONL0
public enum class TYPIDTAVERTICALINPUTDOWDEFINITIONL0
type TYPIDTAVERTICALINPUTDOWDEFINITIONL0
Members
Member name | Value | Description
Value_0NoInputLines | 0 | 0 - No input lines
Value_4095MaximumPossibleNumberOfInputLines | 4095 | 4095 - Maximum possible number of input lines
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAVERTICALINPUTINITIONOFFSETL0 Enumeration

IRD

Saa7119TYPIDTAVERTICALINPUTINITIONOFFSETL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAVERTICALINPUTINITIONOFFSETL0
Public Enumeration TYPIDTAVERTICALINPUTINITIONOFFSETL0
public enum class TYPIDTAVERTICALINPUTINITIONOFFSETL0
type TYPIDTAVERTICALINPUTINITIONOFFSETL0
Members
Member name | Value | Description
Value_4095MaximumLineOffset | 4095 | 4095 - Maximum line offset
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 Enumeration

IRD

Saa7119TYPIDTAVERTICALOUTPUWINDOWLENGTHL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAVERTICALOUTPUWINDOWLENGTHL0
Public Enumeration TYPIDTAVERTICALOUTPUWINDOWLENGTHL0
public enum class TYPIDTAVERTICALOUTPUWINDOWLENGTHL0
type TYPIDTAVERTICALOUTPUWINDOWLENGTHL0
Members
Member name | Value | Description
Value_0NoOutput | 0 | 0 - No output
Value_4095MaximumPossibleNumberOfInputPixels | 4095 | 4095 - Maximum possible number of input pixels
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAVERTICALSCALIPHASEOFFSET000 Enumeration

IRD

Saa7119TYPIDTAVERTICALSCALIPHASEOFFSET000 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAVERTICALSCALIPHASEOFFSET000
Public Enumeration TYPIDTAVERTICALSCALIPHASEOFFSET000
public enum class TYPIDTAVERTICALSCALIPHASEOFFSET000
type TYPIDTAVERTICALSCALIPHASEOFFSET000
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_132 | 1 | 1/32
Value_232 | 2 | 2/32
Value_332 | 3 | 3/32
Value_432 | 4 | 4/32
Value_532 | 5 | 5/32
Value_632 | 6 | 6/32
Value_732 | 7 | 7/32
Value_832 | 8 | 8/32
Value_932 | 9 | 9/32
Value_1032 | 10 | 10/32
Value_1132 | 11 | 11/32
Value_1232 | 12 | 12/32
Value_1332 | 13 | 13/32
Value_1432 | 14 | 14/32
Value_1532 | 15 | 15/32
Value_1632 | 16 | 16/32
Value_1732 | 17 | 17/32
Value_1832 | 18 | 18/32
Value_1932 | 19 | 19/32
Value_2032 | 20 | 20/32
Value_2132 | 21 | 21/32
Value_2232 | 22 | 22/32
Value_2332 | 23 | 23/32
Value_2432 | 24 | 24/32
Value_2532 | 25 | 25/32
Value_2632 | 26 | 26/32
Value_2732 | 27 | 27/32
Value_2832 | 28 | 28/32
Value_2932 | 29 | 29/32
Value_3032 | 30 | 30/32
Value_3132 | 31 | 31/32
Value_1 | 32 | 1
Value_3332 | 33 | 33/32
Value_3432 | 34 | 34/32
Value_3532 | 35 | 35/32
Value_3632 | 36 | 36/32
Value_3732 | 37 | 37/32
Value_3832 | 38 | 38/32
Value_3932 | 39 | 39/32
Value_4032 | 40 | 40/32
Value_4132 | 41 | 41/32
Value_4232 | 42 | 42/32
Value_4332 | 43 | 43/32
Value_4432 | 44 | 44/32
Value_4532 | 45 | 45/32
Value_4632 | 46 | 46/32
Value_4732 | 47 | 47/32
Value_4832 | 48 | 48/32
Value_4932 | 49 | 49/32
Value_5032 | 50 | 50/32
Value_5132 | 51 | 51/32
Value_5232 | 52 | 52/32
Value_5332 | 53 | 53/32
Value_5432 | 54 | 54/32
Value_5532 | 55 | 55/32
Value_5632 | 56 | 56/32
Value_5732 | 57 | 57/32
Value_5832 | 58 | 58/32
Value_5932 | 59 | 59/32
Value_6032 | 60 | 60/32
Value_6132 | 61 | 61/32
Value_6232 | 62 | 62/32
Value_6332 | 63 | 63/32
Value_2 | 64 | 2
Value_6532 | 65 | 65/32
Value_6632 | 66 | 66/32
Value_6732 | 67 | 67/32
Value_6832 | 68 | 68/32
Value_6932 | 69 | 69/32
Value_7032 | 70 | 70/32
Value_7132 | 71 | 71/32
Value_7232 | 72 | 72/32
Value_7332 | 73 | 73/32
Value_7432 | 74 | 74/32
Value_7532 | 75 | 75/32
Value_7632 | 76 | 76/32
Value_7732 | 77 | 77/32
Value_7832 | 78 | 78/32
Value_7932 | 79 | 79/32
Value_8032 | 80 | 80/32
Value_8132 | 81 | 81/32
Value_8232 | 82 | 82/32
Value_8332 | 83 | 83/32
Value_8432 | 84 | 84/32
Value_8532 | 85 | 85/32
Value_8632 | 86 | 86/32
Value_8732 | 87 | 87/32
Value_8832 | 88 | 88/32
Value_8932 | 89 | 89/32
Value_9032 | 90 | 90/32
Value_9132 | 91 | 91/32
Value_9232 | 92 | 92/32
Value_9332 | 93 | 93/32
Value_9432 | 94 | 94/32
Value_9532 | 95 | 95/32
Value_3 | 96 | 3
Value_9732 | 97 | 97/32
Value_9832 | 98 | 98/32
Value_9932 | 99 | 99/32
Value_10032 | 100 | 100/32
Value_10132 | 101 | 101/32
Value_10232 | 102 | 102/32
Value_10332 | 103 | 103/32
Value_10432 | 104 | 104/32
Value_10532 | 105 | 105/32
Value_10632 | 106 | 106/32
Value_10732 | 107 | 107/32
Value_10832 | 108 | 108/32
Value_10932 | 109 | 109/32
Value_11032 | 110 | 110/32
Value_11132 | 111 | 111/32
Value_11232 | 112 | 112/32
Value_11332 | 113 | 113/32
Value_11432 | 114 | 114/32
Value_11532 | 115 | 115/32
Value_11632 | 116 | 116/32
Value_11732 | 117 | 117/32
Value_11832 | 118 | 118/32
Value_11932 | 119 | 119/32
Value_12032 | 120 | 120/32
Value_12132 | 121 | 121/32
Value_12232 | 122 | 122/32
Value_12332 | 123 | 123/32
Value_12432 | 124 | 124/32
Value_12532 | 125 | 125/32
Value_12632 | 126 | 126/32
Value_12732 | 127 | 127/32
Value_4 | 128 | 4
Value_12932 | 129 | 129/32
Value_13032 | 130 | 130/32
Value_13132 | 131 | 131/32
Value_13232 | 132 | 132/32
Value_13332 | 133 | 133/32
Value_13432 | 134 | 134/32
Value_13532 | 135 | 135/32
Value_13632 | 136 | 136/32
Value_13732 | 137 | 137/32
Value_13832 | 138 | 138/32
Value_13932 | 139 | 139/32
Value_14032 | 140 | 140/32
Value_14132 | 141 | 141/32
Value_14232 | 142 | 142/32
Value_14332 | 143 | 143/32
Value_14432 | 144 | 144/32
Value_14532 | 145 | 145/32
Value_14632 | 146 | 146/32
Value_14732 | 147 | 147/32
Value_14832 | 148 | 148/32
Value_14932 | 149 | 149/32
Value_15032 | 150 | 150/32
Value_15132 | 151 | 151/32
Value_15232 | 152 | 152/32
Value_15332 | 153 | 153/32
Value_15432 | 154 | 154/32
Value_15532 | 155 | 155/32
Value_15632 | 156 | 156/32
Value_15732 | 157 | 157/32
Value_15832 | 158 | 158/32
Value_15932 | 159 | 159/32
Value_5 | 160 | 5
Value_16132 | 161 | 161/32
Value_16232 | 162 | 162/32
Value_16332 | 163 | 163/32
Value_16432 | 164 | 164/32
Value_16532 | 165 | 165/32
Value_16632 | 166 | 166/32
Value_16732 | 167 | 167/32
Value_16832 | 168 | 168/32
Value_16932 | 169 | 169/32
Value_17032 | 170 | 170/32
Value_17132 | 171 | 171/32
Value_17232 | 172 | 172/32
Value_17332 | 173 | 173/32
Value_17432 | 174 | 174/32
Value_17532 | 175 | 175/32
Value_17632 | 176 | 176/32
Value_17732 | 177 | 177/32
Value_17832 | 178 | 178/32
Value_17932 | 179 | 179/32
Value_18032 | 180 | 180/32
Value_18132 | 181 | 181/32
Value_18232 | 182 | 182/32
Value_18332 | 183 | 183/32
Value_18432 | 184 | 184/32
Value_18532 | 185 | 185/32
Value_18632 | 186 | 186/32
Value_18732 | 187 | 187/32
Value_18832 | 188 | 188/32
Value_18932 | 189 | 189/32
Value_19032 | 190 | 190/32
Value_19132 | 191 | 191/32
Value_6 | 192 | 6
Value_19332 | 193 | 193/32
Value_19432 | 194 | 194/32
Value_19532 | 195 | 195/32
Value_19632 | 196 | 196/32
Value_19732 | 197 | 197/32
Value_19832 | 198 | 198/32
Value_19932 | 199 | 199/32
Value_20032 | 200 | 200/32
Value_20132 | 201 | 201/32
Value_20232 | 202 | 202/32
Value_20332 | 203 | 203/32
Value_20432 | 204 | 204/32
Value_20532 | 205 | 205/32
Value_20632 | 206 | 206/32
Value_20732 | 207 | 207/32
Value_20832 | 208 | 208/32
Value_20932 | 209 | 209/32
Value_21032 | 210 | 210/32
Value_21132 | 211 | 211/32
Value_21232 | 212 | 212/32
Value_21332 | 213 | 213/32
Value_21432 | 214 | 214/32
Value_21532 | 215 | 215/32
Value_21632 | 216 | 216/32
Value_21732 | 217 | 217/32
Value_21832 | 218 | 218/32
Value_21932 | 219 | 219/32
Value_22032 | 220 | 220/32
Value_22132 | 221 | 221/32
Value_22232 | 222 | 222/32
Value_22332 | 223 | 223/32
Value_7 | 224 | 7
Value_22532 | 225 | 225/32
Value_22632 | 226 | 226/32
Value_22732 | 227 | 227/32
Value_22832 | 228 | 228/32
Value_22932 | 229 | 229/32
Value_23032 | 230 | 230/32
Value_23132 | 231 | 231/32
Value_23232 | 232 | 232/32
Value_23332 | 233 | 233/32
Value_23432 | 234 | 234/32
Value_23532 | 235 | 235/32
Value_23632 | 236 | 236/32
Value_23732 | 237 | 237/32
Value_23832 | 238 | 238/32
Value_23932 | 239 | 239/32
Value_24032 | 240 | 240/32
Value_24132 | 241 | 241/32
Value_24232 | 242 | 242/32
Value_24332 | 243 | 243/32
Value_24432 | 244 | 244/32
Value_24532 | 245 | 245/32
Value_24632 | 246 | 246/32
Value_24732 | 247 | 247/32
Value_24832 | 248 | 248/32
Value_24932 | 249 | 249/32
Value_25032 | 250 | 250/32
Value_25132 | 251 | 251/32
Value_25232 | 252 | 252/32
Value_25332 | 253 | 253/32
Value_25432 | 254 | 254/32
Value_25532 | 255 | 255/32
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAXPORTFORMATSDCONFIGURATION0 Enumeration

IRD

Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTFORMATSDCONFIGURATION0
Public Enumeration TYPIDTAXPORTFORMATSDCONFIGURATION0
public enum class TYPIDTAXPORTFORMATSDCONFIGURATION0
type TYPIDTAXPORTFORMATSDCONFIGURATION0
Members
Member name | Value | Description
InputIsYCBCR422Like | 0 | Input is Y-CB-CR 4:2:2 like
InputIsYCBCR411Like | 1 | Input is Y-CB-CR 4:1:1 like
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAXPORTFORMATSDCONFIGURATION1 Enumeration

IRD

Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTFORMATSDCONFIGURATION1
Public Enumeration TYPIDTAXPORTFORMATSDCONFIGURATION1
public enum class TYPIDTAXPORTFORMATSDCONFIGURATION1
type TYPIDTAXPORTFORMATSDCONFIGURATION1
Members
Member name | Value | Description
EveryLine | 0 | Every line
Every2ndLine | 1 | Every 2nd line
Every3rdLine | 2 | Every 3rd line
Every4thLine | 3 | Every 4th line
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAXPORTFORMATSDCONFIGURATION2 Enumeration

IRD

Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTFORMATSDCONFIGURATION2
Public Enumeration TYPIDTAXPORTFORMATSDCONFIGURATION2
public enum class TYPIDTAXPORTFORMATSDCONFIGURATION2
type TYPIDTAXPORTFORMATSDCONFIGURATION2
Members
Member name | Value | Description
ReactsOnSAA7119Request | 0 | Reacts on SAA7119 request
ContinuousDataStream | 1 | Continuous data stream
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAXPORTFORMATSDCONFIGURATION3 Enumeration

IRD

Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTFORMATSDCONFIGURATION3
Public Enumeration TYPIDTAXPORTFORMATSDCONFIGURATION3
public enum class TYPIDTAXPORTFORMATSDCONFIGURATION3
type TYPIDTAXPORTFORMATSDCONFIGURATION3
Members
Member name | Value | Description
DataFromDecoder | 0 | Data from decoder
YCBCRDataFromXPort | 1 | Y-CB-CR data from X port
RawDigitalCVBSFromSelectedAnalogChannel | 2 | Raw digital CVBS from selected analog channel
RawDigitalCVBS | 3 | Raw digital CVBS
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAXPORTFORMATSDCONFIGURATION4 Enumeration

IRD

Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTFORMATSDCONFIGURATION4
Public Enumeration TYPIDTAXPORTFORMATSDCONFIGURATION4
public enum class TYPIDTAXPORTFORMATSDCONFIGURATION4
type TYPIDTAXPORTFORMATSDCONFIGURATION4
Members
Member name | Value | Description
MayChangeBetweenSAVAndEAV | 0 | May change between SAV and EAV
AreSynchronizedToScalersOutputLineStart | 1 | Are synchronized to scalers output line start
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAXPORTFORMATSDCONFIGURATION5 Enumeration

IRD

Saa7119TYPIDTAXPORTFORMATSDCONFIGURATION5 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTFORMATSDCONFIGURATION5
Public Enumeration TYPIDTAXPORTFORMATSDCONFIGURATION5
public enum class TYPIDTAXPORTFORMATSDCONFIGURATION5
type TYPIDTAXPORTFORMATSDCONFIGURATION5
Members
Member name | Value | Description
OnPinIGPVAsGeneratedByTheInternalProcessing | 0 | On pin IGPV as generated by the internal processing
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAXPORTINPUTRNALDEFINITIONS0 Enumeration

IRD

Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTINPUTRNALDEFINITIONS0
Public Enumeration TYPIDTAXPORTINPUTRNALDEFINITIONS0
public enum class TYPIDTAXPORTINPUTRNALDEFINITIONS0
type TYPIDTAXPORTINPUTRNALDEFINITIONS0
Members
Member name | Value | Description
XCLKInputClockAndXDQInputQualifierAreNeeded | 0 | XCLK input clock and XDQ input qualifier are needed
DataRateIsDefinedByXCLKOnlyNoXDQSignalUsed | 1 | Data rate is defined by XCLK only, no XDQ signal used
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAXPORTINPUTRNALDEFINITIONS1 Enumeration

IRD

Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTINPUTRNALDEFINITIONS1
Public Enumeration TYPIDTAXPORTINPUTRNALDEFINITIONS1
public enum class TYPIDTAXPORTINPUTRNALDEFINITIONS1
type TYPIDTAXPORTINPUTRNALDEFINITIONS1
Members
Member name | Value | Description
XDQInputAtLogic1 | 0 | XDQ input at logic 1
XDQInputAtLogic0 | 1 | XDQ input at logic 0
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAXPORTINPUTRNALDEFINITIONS2 Enumeration

IRD

Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTINPUTRNALDEFINITIONS2
Public Enumeration TYPIDTAXPORTINPUTRNALDEFINITIONS2
public enum class TYPIDTAXPORTINPUTRNALDEFINITIONS2
type TYPIDTAXPORTINPUTRNALDEFINITIONS2
Members
Member name | Value | Description
Rising | 0 | Rising
Falling | 1 | Falling
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAXPORTINPUTRNALDEFINITIONS3 Enumeration

IRD

Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTINPUTRNALDEFINITIONS3
Public Enumeration TYPIDTAXPORTINPUTRNALDEFINITIONS3
public enum class TYPIDTAXPORTINPUTRNALDEFINITIONS3
type TYPIDTAXPORTINPUTRNALDEFINITIONS3
Members
Member name | Value | Description
TakenFromXRHAndXRV | 0 | Taken from XRH and XRV
DecodedFromEAVAndSAV | 1 | Decoded from EAV and SAV
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAXPORTINPUTRNALDEFINITIONS4 Enumeration

IRD

Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTINPUTRNALDEFINITIONS4
Public Enumeration TYPIDTAXPORTINPUTRNALDEFINITIONS4
public enum class TYPIDTAXPORTINPUTRNALDEFINITIONS4
type TYPIDTAXPORTINPUTRNALDEFINITIONS4
Members
Member name | Value | Description
Rising | 0 | Rising
Falling | 1 | Falling
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAXPORTINPUTRNALDEFINITIONS5 Enumeration

IRD

Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS5 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTINPUTRNALDEFINITIONS5
Public Enumeration TYPIDTAXPORTINPUTRNALDEFINITIONS5
public enum class TYPIDTAXPORTINPUTRNALDEFINITIONS5
type TYPIDTAXPORTINPUTRNALDEFINITIONS5
Members
Member name | Value | Description
VSyncOrVGateSignal | 0 | V-sync or V gate signal
FrameSyncVPulsesAreGeneratedInternallyOnBothEdgesOfFSInput | 1 | Frame sync, V pulses are generated internally on both edges of FS input
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAXPORTINPUTRNALDEFINITIONS6 Enumeration

IRD

Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS6 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTINPUTRNALDEFINITIONS6
Public Enumeration TYPIDTAXPORTINPUTRNALDEFINITIONS6
public enum class TYPIDTAXPORTINPUTRNALDEFINITIONS6
type TYPIDTAXPORTINPUTRNALDEFINITIONS6
Members
Member name | Value | Description
StateOfXRHAtReferenceEdgeOnXRVDefinedByXFDV | 0 | State of XRH at reference edge on XRV (defined by XFDV)
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDTAXPORTINPUTRNALDEFINITIONS7 Enumeration

IRD

Saa7119TYPIDTAXPORTINPUTRNALDEFINITIONS7 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTAXPORTINPUTRNALDEFINITIONS7
Public Enumeration TYPIDTAXPORTINPUTRNALDEFINITIONS7
public enum class TYPIDTAXPORTINPUTRNALDEFINITIONS7
type TYPIDTAXPORTINPUTRNALDEFINITIONS7
Members
Member name | Value | Description
FallingEdgeOfXRV | 0 | Falling edge of XRV
RisingEdgeOfXRV | 1 | Rising edge of XRV
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDVGATESTART0 Enumeration

IRD

Saa7119TYPIDVGATESTART0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDVGATESTART0
Public Enumeration TYPIDVGATESTART0
public enum class TYPIDVGATESTART0
type TYPIDVGATESTART0
Members
Member name | Value | Description
Value_50Hz231560Hz5268 | 0 | 50 Hz: 2/315 / 60 Hz: 5/268
Value_50Hz331660Hz6269 | 1 | 50 Hz: 3/316 / 60 Hz: 6/269
Value_50Hz431760Hz7270 | 2 | 50 Hz: 4/317 / 60 Hz: 7/270
Value_50Hz531860Hz8271 | 3 | 50 Hz: 5/318 / 60 Hz: 8/271
Value_50Hz631960Hz9272 | 4 | 50 Hz: 6/319 / 60 Hz: 9/272
Value_50Hz732060Hz10273 | 5 | 50 Hz: 7/320 / 60 Hz: 10/273
Value_50Hz832160Hz11274 | 6 | 50 Hz: 8/321 / 60 Hz: 11/274
Value_50Hz932260Hz12275 | 7 | 50 Hz: 9/322 / 60 Hz: 12/275
Value_50Hz1032360Hz13276 | 8 | 50 Hz: 10/323 / 60 Hz: 13/276
Value_50Hz1132460Hz14277 | 9 | 50 Hz: 11/324 / 60 Hz: 14/277
Value_50Hz1232560Hz15278 | 10 | 50 Hz: 12/325 / 60 Hz: 15/278
Value_50Hz1332660Hz16279 | 11 | 50 Hz: 13/326 / 60 Hz: 16/279
Value_50Hz1432760Hz17280 | 12 | 50 Hz: 14/327 / 60 Hz: 17/280
Value_50Hz1532860Hz18281 | 13 | 50 Hz: 15/328 / 60 Hz: 18/281
Value_50Hz1632960Hz19282 | 14 | 50 Hz: 16/329 / 60 Hz: 19/282
Value_50Hz1733060Hz20283 | 15 | 50 Hz: 17/330 / 60 Hz: 20/283
Value_50Hz1833160Hz21284 | 16 | 50 Hz: 18/331 / 60 Hz: 21/284
Value_50Hz1933260Hz22285 | 17 | 50 Hz: 19/332 / 60 Hz: 22/285
Value_50Hz2033360Hz23286 | 18 | 50 Hz: 20/333 / 60 Hz: 23/286
Value_50Hz2133460Hz24287 | 19 | 50 Hz: 21/334 / 60 Hz: 24/287
Value_50Hz2233560Hz25288 | 20 | 50 Hz: 22/335 / 60 Hz: 25/288
Value_50Hz2333660Hz26289 | 21 | 50 Hz: 23/336 / 60 Hz: 26/289
Value_50Hz2433760Hz27290 | 22 | 50 Hz: 24/337 / 60 Hz: 27/290
Value_50Hz2533860Hz28291 | 23 | 50 Hz: 25/338 / 60 Hz: 28/291
Value_50Hz2633960Hz29292 | 24 | 50 Hz: 26/339 / 60 Hz: 29/292
Value_50Hz2734060Hz30293 | 25 | 50 Hz: 27/340 / 60 Hz: 30/293
Value_50Hz2834160Hz31294 | 26 | 50 Hz: 28/341 / 60 Hz: 31/294
Value_50Hz2934260Hz32295 | 27 | 50 Hz: 29/342 / 60 Hz: 32/295
Value_50Hz3034360Hz33296 | 28 | 50 Hz: 30/343 / 60 Hz: 33/296
Value_50Hz3134460Hz34297 | 29 | 50 Hz: 31/344 / 60 Hz: 34/297
Value_50Hz3234560Hz35298 | 30 | 50 Hz: 32/345 / 60 Hz: 35/298
Value_50Hz3334660Hz36299 | 31 | 50 Hz: 33/346 / 60 Hz: 36/299
Value_50Hz3434760Hz37300 | 32 | 50 Hz: 34/347 / 60 Hz: 37/300
Value_50Hz3534860Hz38301 | 33 | 50 Hz: 35/348 / 60 Hz: 38/301
Value_50Hz3634960Hz39302 | 34 | 50 Hz: 36/349 / 60 Hz: 39/302
Value_50Hz3735060Hz40303 | 35 | 50 Hz: 37/350 / 60 Hz: 40/303
Value_50Hz3835160Hz41304 | 36 | 50 Hz: 38/351 / 60 Hz: 41/304
Value_50Hz3935260Hz42305 | 37 | 50 Hz: 39/352 / 60 Hz: 42/305
Value_50Hz4035360Hz43306 | 38 | 50 Hz: 40/353 / 60 Hz: 43/306
Value_50Hz4135460Hz44307 | 39 | 50 Hz: 41/354 / 60 Hz: 44/307
Value_50Hz4235560Hz45308 | 40 | 50 Hz: 42/355 / 60 Hz: 45/308
Value_50Hz4335660Hz46309 | 41 | 50 Hz: 43/356 / 60 Hz: 46/309
Value_50Hz4435760Hz47310 | 42 | 50 Hz: 44/357 / 60 Hz: 47/310
Value_50Hz4535860Hz48311 | 43 | 50 Hz: 45/358 / 60 Hz: 48/311
Value_50Hz4635960Hz49312 | 44 | 50 Hz: 46/359 / 60 Hz: 49/312
Value_50Hz4736060Hz50313 | 45 | 50 Hz: 47/360 / 60 Hz: 50/313
Value_50Hz4836160Hz51314 | 46 | 50 Hz: 48/361 / 60 Hz: 51/314
Value_50Hz4936260Hz52315 | 47 | 50 Hz: 49/362 / 60 Hz: 52/315
Value_50Hz5036360Hz53316 | 48 | 50 Hz: 50/363 / 60 Hz: 53/316
Value_50Hz5136460Hz54317 | 49 | 50 Hz: 51/364 / 60 Hz: 54/317
Value_50Hz5236560Hz55318 | 50 | 50 Hz: 52/365 / 60 Hz: 55/318
Value_50Hz5336660Hz56319 | 51 | 50 Hz: 53/366 / 60 Hz: 56/319
Value_50Hz5436760Hz57320 | 52 | 50 Hz: 54/367 / 60 Hz: 57/320
Value_50Hz5536860Hz58321 | 53 | 50 Hz: 55/368 / 60 Hz: 58/321
Value_50Hz5636960Hz59322 | 54 | 50 Hz: 56/369 / 60 Hz: 59/322
Value_50Hz5737060Hz60323 | 55 | 50 Hz: 57/370 / 60 Hz: 60/323
Value_50Hz5837160Hz61324 | 56 | 50 Hz: 58/371 / 60 Hz: 61/324
Value_50Hz5937260Hz62325 | 57 | 50 Hz: 59/372 / 60 Hz: 62/325
Value_50Hz6037360Hz63326 | 58 | 50 Hz: 60/373 / 60 Hz: 63/326
Value_50Hz6137460Hz64327 | 59 | 50 Hz: 61/374 / 60 Hz: 64/327
Value_50Hz6237560Hz65328 | 60 | 50 Hz: 62/375 / 60 Hz: 65/328
Value_50Hz6337660Hz66329 | 61 | 50 Hz: 63/376 / 60 Hz: 66/329
Value_50Hz6437760Hz67330 | 62 | 50 Hz: 64/377 / 60 Hz: 67/330
Value_50Hz6537860Hz68331 | 63 | 50 Hz: 65/378 / 60 Hz: 68/331
Value_50Hz6637960Hz69332 | 64 | 50 Hz: 66/379 / 60 Hz: 69/332
Value_50Hz6738060Hz70333 | 65 | 50 Hz: 67/380 / 60 Hz: 70/333
Value_50Hz6838160Hz71334 | 66 | 50 Hz: 68/381 / 60 Hz: 71/334
Value_50Hz6938260Hz72335 | 67 | 50 Hz: 69/382 / 60 Hz: 72/335
Value_50Hz7038360Hz73336 | 68 | 50 Hz: 70/383 / 60 Hz: 73/336
Value_50Hz7138460Hz74337 | 69 | 50 Hz: 71/384 / 60 Hz: 74/337
Value_50Hz7238560Hz75338 | 70 | 50 Hz: 72/385 / 60 Hz: 75/338
Value_50Hz7338660Hz76339 | 71 | 50 Hz: 73/386 / 60 Hz: 76/339
Value_50Hz7438760Hz77340 | 72 | 50 Hz: 74/387 / 60 Hz: 77/340
Value_50Hz7538860Hz78341 | 73 | 50 Hz: 75/388 / 60 Hz: 78/341
Value_50Hz7638960Hz79342 | 74 | 50 Hz: 76/389 / 60 Hz: 79/342
Value_50Hz7739060Hz80343 | 75 | 50 Hz: 77/390 / 60 Hz: 80/343
Value_50Hz7839160Hz81344 | 76 | 50 Hz: 78/391 / 60 Hz: 81/344
Value_50Hz7939260Hz82345 | 77 | 50 Hz: 79/392 / 60 Hz: 82/345
Value_50Hz8039360Hz83346 | 78 | 50 Hz: 80/393 / 60 Hz: 83/346
Value_50Hz8139460Hz84347 | 79 | 50 Hz: 81/394 / 60 Hz: 84/347
Value_50Hz8239560Hz85348 | 80 | 50 Hz: 82/395 / 60 Hz: 85/348
Value_50Hz8339660Hz86349 | 81 | 50 Hz: 83/396 / 60 Hz: 86/349
Value_50Hz8439760Hz87350 | 82 | 50 Hz: 84/397 / 60 Hz: 87/350
Value_50Hz8539860Hz88351 | 83 | 50 Hz: 85/398 / 60 Hz: 88/351
Value_50Hz8639960Hz89352 | 84 | 50 Hz: 86/399 / 60 Hz: 89/352
Value_50Hz8740060Hz90353 | 85 | 50 Hz: 87/400 / 60 Hz: 90/353
Value_50Hz8840160Hz91354 | 86 | 50 Hz: 88/401 / 60 Hz: 91/354
Value_50Hz8940260Hz92355 | 87 | 50 Hz: 89/402 / 60 Hz: 92/355
Value_50Hz9040360Hz93356 | 88 | 50 Hz: 90/403 / 60 Hz: 93/356
Value_50Hz9140460Hz94357 | 89 | 50 Hz: 91/404 / 60 Hz: 94/357
Value_50Hz9240560Hz95358 | 90 | 50 Hz: 92/405 / 60 Hz: 95/358
Value_50Hz9340660Hz96359 | 91 | 50 Hz: 93/406 / 60 Hz: 96/359
Value_50Hz9440760Hz97360 | 92 | 50 Hz: 94/407 / 60 Hz: 97/360
Value_50Hz9540860Hz98361 | 93 | 50 Hz: 95/408 / 60 Hz: 98/361
Value_50Hz9640960Hz99362 | 94 | 50 Hz: 96/409 / 60 Hz: 99/362
Value_50Hz9741060Hz100363 | 95 | 50 Hz: 97/410 / 60 Hz: 100/363
Value_50Hz9841160Hz101364 | 96 | 50 Hz: 98/411 / 60 Hz: 101/364
Value_50Hz9941260Hz102365 | 97 | 50 Hz: 99/412 / 60 Hz: 102/365
Value_50Hz10041360Hz103366 | 98 | 50 Hz: 100/413 / 60 Hz: 103/366
Value_50Hz10141460Hz104367 | 99 | 50 Hz: 101/414 / 60 Hz: 104/367
Value_50Hz10241560Hz105368 | 100 | 50 Hz: 102/415 / 60 Hz: 105/368
Value_50Hz10341660Hz106369 | 101 | 50 Hz: 103/416 / 60 Hz: 106/369
Value_50Hz10441760Hz107370 | 102 | 50 Hz: 104/417 / 60 Hz: 107/370
Value_50Hz10541860Hz108371 | 103 | 50 Hz: 105/418 / 60 Hz: 108/371
Value_50Hz10641960Hz109372 | 104 | 50 Hz: 106/419 / 60 Hz: 109/372
Value_50Hz10742060Hz110373 | 105 | 50 Hz: 107/420 / 60 Hz: 110/373
Value_50Hz10842160Hz111374 | 106 | 50 Hz: 108/421 / 60 Hz: 111/374
Value_50Hz10942260Hz112375 | 107 | 50 Hz: 109/422 / 60 Hz: 112/375
Value_50Hz11042360Hz113376 | 108 | 50 Hz: 110/423 / 60 Hz: 113/376
Value_50Hz11142460Hz114377 | 109 | 50 Hz: 111/424 / 60 Hz: 114/377
Value_50Hz11242560Hz115378 | 110 | 50 Hz: 112/425 / 60 Hz: 115/378
Value_50Hz11342660Hz116379 | 111 | 50 Hz: 113/426 / 60 Hz: 116/379
Value_50Hz11442760Hz117380 | 112 | 50 Hz: 114/427 / 60 Hz: 117/380
Value_50Hz11542860Hz118381 | 113 | 50 Hz: 115/428 / 60 Hz: 118/381
Value_50Hz11642960Hz119382 | 114 | 50 Hz: 116/429 / 60 Hz: 119/382
Value_50Hz11743060Hz120383 | 115 | 50 Hz: 117/430 / 60 Hz: 120/383
Value_50Hz11843160Hz121384 | 116 | 50 Hz: 118/431 / 60 Hz: 121/384
Value_50Hz11943260Hz122385 | 117 | 50 Hz: 119/432 / 60 Hz: 122/385
Value_50Hz12043360Hz123386 | 118 | 50 Hz: 120/433 / 60 Hz: 123/386
Value_50Hz12143460Hz124387 | 119 | 50 Hz: 121/434 / 60 Hz: 124/387
Value_50Hz12243560Hz125388 | 120 | 50 Hz: 122/435 / 60 Hz: 125/388
Value_50Hz12343660Hz126389 | 121 | 50 Hz: 123/436 / 60 Hz: 126/389
Value_50Hz12443760Hz127390 | 122 | 50 Hz: 124/437 / 60 Hz: 127/390
Value_50Hz12543860Hz128391 | 123 | 50 Hz: 125/438 / 60 Hz: 128/391
Value_50Hz12643960Hz129392 | 124 | 50 Hz: 126/439 / 60 Hz: 129/392
Value_50Hz12744060Hz130393 | 125 | 50 Hz: 127/440 / 60 Hz: 130/393
Value_50Hz12844160Hz131394 | 126 | 50 Hz: 128/441 / 60 Hz: 131/394
Value_50Hz12944260Hz132395 | 127 | 50 Hz: 129/442 / 60 Hz: 132/395
Value_50Hz13044360Hz133396 | 128 | 50 Hz: 130/443 / 60 Hz: 133/396
Value_50Hz13144460Hz134397 | 129 | 50 Hz: 131/444 / 60 Hz: 134/397
Value_50Hz13244560Hz135398 | 130 | 50 Hz: 132/445 / 60 Hz: 135/398
Value_50Hz13344660Hz136399 | 131 | 50 Hz: 133/446 / 60 Hz: 136/399
Value_50Hz13444760Hz137400 | 132 | 50 Hz: 134/447 / 60 Hz: 137/400
Value_50Hz13544860Hz138401 | 133 | 50 Hz: 135/448 / 60 Hz: 138/401
Value_50Hz13644960Hz139402 | 134 | 50 Hz: 136/449 / 60 Hz: 139/402
Value_50Hz13745060Hz140403 | 135 | 50 Hz: 137/450 / 60 Hz: 140/403
Value_50Hz13845160Hz141404 | 136 | 50 Hz: 138/451 / 60 Hz: 141/404
Value_50Hz13945260Hz142405 | 137 | 50 Hz: 139/452 / 60 Hz: 142/405
Value_50Hz14045360Hz143406 | 138 | 50 Hz: 140/453 / 60 Hz: 143/406
Value_50Hz14145460Hz144407 | 139 | 50 Hz: 141/454 / 60 Hz: 144/407
Value_50Hz14245560Hz145408 | 140 | 50 Hz: 142/455 / 60 Hz: 145/408
Value_50Hz14345660Hz146409 | 141 | 50 Hz: 143/456 / 60 Hz: 146/409
Value_50Hz14445760Hz147410 | 142 | 50 Hz: 144/457 / 60 Hz: 147/410
Value_50Hz14545860Hz148411 | 143 | 50 Hz: 145/458 / 60 Hz: 148/411
Value_50Hz14645960Hz149412 | 144 | 50 Hz: 146/459 / 60 Hz: 149/412
Value_50Hz14746060Hz150413 | 145 | 50 Hz: 147/460 / 60 Hz: 150/413
Value_50Hz14846160Hz151414 | 146 | 50 Hz: 148/461 / 60 Hz: 151/414
Value_50Hz14946260Hz152415 | 147 | 50 Hz: 149/462 / 60 Hz: 152/415
Value_50Hz15046360Hz153416 | 148 | 50 Hz: 150/463 / 60 Hz: 153/416
Value_50Hz15146460Hz154417 | 149 | 50 Hz: 151/464 / 60 Hz: 154/417
Value_50Hz15246560Hz155418 | 150 | 50 Hz: 152/465 / 60 Hz: 155/418
Value_50Hz15346660Hz156419 | 151 | 50 Hz: 153/466 / 60 Hz: 156/419
Value_50Hz15446760Hz157420 | 152 | 50 Hz: 154/467 / 60 Hz: 157/420
Value_50Hz15546860Hz158421 | 153 | 50 Hz: 155/468 / 60 Hz: 158/421
Value_50Hz15646960Hz159422 | 154 | 50 Hz: 156/469 / 60 Hz: 159/422
Value_50Hz15747060Hz160423 | 155 | 50 Hz: 157/470 / 60 Hz: 160/423
Value_50Hz15847160Hz161424 | 156 | 50 Hz: 158/471 / 60 Hz: 161/424
Value_50Hz15947260Hz162425 | 157 | 50 Hz: 159/472 / 60 Hz: 162/425
Value_50Hz16047360Hz163426 | 158 | 50 Hz: 160/473 / 60 Hz: 163/426
Value_50Hz16147460Hz164427 | 159 | 50 Hz: 161/474 / 60 Hz: 164/427
Value_50Hz16247560Hz165428 | 160 | 50 Hz: 162/475 / 60 Hz: 165/428
Value_50Hz16347660Hz166429 | 161 | 50 Hz: 163/476 / 60 Hz: 166/429
Value_50Hz16447760Hz167430 | 162 | 50 Hz: 164/477 / 60 Hz: 167/430
Value_50Hz16547860Hz168431 | 163 | 50 Hz: 165/478 / 60 Hz: 168/431
Value_50Hz16647960Hz169432 | 164 | 50 Hz: 166/479 / 60 Hz: 169/432
Value_50Hz16748060Hz170433 | 165 | 50 Hz: 167/480 / 60 Hz: 170/433
Value_50Hz16848160Hz171434 | 166 | 50 Hz: 168/481 / 60 Hz: 171/434
Value_50Hz16948260Hz172435 | 167 | 50 Hz: 169/482 / 60 Hz: 172/435
Value_50Hz17048360Hz173436 | 168 | 50 Hz: 170/483 / 60 Hz: 173/436
Value_50Hz17148460Hz174437 | 169 | 50 Hz: 171/484 / 60 Hz: 174/437
Value_50Hz17248560Hz175438 | 170 | 50 Hz: 172/485 / 60 Hz: 175/438
Value_50Hz17348660Hz176439 | 171 | 50 Hz: 173/486 / 60 Hz: 176/439
Value_50Hz17448760Hz177440 | 172 | 50 Hz: 174/487 / 60 Hz: 177/440
Value_50Hz17548860Hz178441 | 173 | 50 Hz: 175/488 / 60 Hz: 178/441
Value_50Hz17648960Hz179442 | 174 | 50 Hz: 176/489 / 60 Hz: 179/442
Value_50Hz17749060Hz180443 | 175 | 50 Hz: 177/490 / 60 Hz: 180/443
Value_50Hz17849160Hz181444 | 176 | 50 Hz: 178/491 / 60 Hz: 181/444
Value_50Hz17949260Hz182445 | 177 | 50 Hz: 179/492 / 60 Hz: 182/445
Value_50Hz18049360Hz183446 | 178 | 50 Hz: 180/493 / 60 Hz: 183/446
Value_50Hz18149460Hz184447 | 179 | 50 Hz: 181/494 / 60 Hz: 184/447
Value_50Hz18249560Hz185448 | 180 | 50 Hz: 182/495 / 60 Hz: 185/448
Value_50Hz18349660Hz186449 | 181 | 50 Hz: 183/496 / 60 Hz: 186/449
Value_50Hz18449760Hz187450 | 182 | 50 Hz: 184/497 / 60 Hz: 187/450
Value_50Hz18549860Hz188451 | 183 | 50 Hz: 185/498 / 60 Hz: 188/451
Value_50Hz18649960Hz189452 | 184 | 50 Hz: 186/499 / 60 Hz: 189/452
Value_50Hz18750060Hz190453 | 185 | 50 Hz: 187/500 / 60 Hz: 190/453
Value_50Hz18850160Hz191454 | 186 | 50 Hz: 188/501 / 60 Hz: 191/454
Value_50Hz18950260Hz192455 | 187 | 50 Hz: 189/502 / 60 Hz: 192/455
Value_50Hz19050360Hz193456 | 188 | 50 Hz: 190/503 / 60 Hz: 193/456
Value_50Hz19150460Hz194457 | 189 | 50 Hz: 191/504 / 60 Hz: 194/457
Value_50Hz19250560Hz195458 | 190 | 50 Hz: 192/505 / 60 Hz: 195/458
Value_50Hz19350660Hz196459 | 191 | 50 Hz: 193/506 / 60 Hz: 196/459
Value_50Hz19450760Hz197460 | 192 | 50 Hz: 194/507 / 60 Hz: 197/460
Value_50Hz19550860Hz198461 | 193 | 50 Hz: 195/508 / 60 Hz: 198/461
Value_50Hz19650960Hz199462 | 194 | 50 Hz: 196/509 / 60 Hz: 199/462
Value_50Hz19751060Hz200463 | 195 | 50 Hz: 197/510 / 60 Hz: 200/463
Value_50Hz19851160Hz201464 | 196 | 50 Hz: 198/511 / 60 Hz: 201/464
Value_50Hz19951260Hz202465 | 197 | 50 Hz: 199/512 / 60 Hz: 202/465
Value_50Hz20051360Hz203466 | 198 | 50 Hz: 200/513 / 60 Hz: 203/466
Value_50Hz20151460Hz204467 | 199 | 50 Hz: 201/514 / 60 Hz: 204/467
Value_50Hz20251560Hz205468 | 200 | 50 Hz: 202/515 / 60 Hz: 205/468
Value_50Hz20351660Hz206469 | 201 | 50 Hz: 203/516 / 60 Hz: 206/469
Value_50Hz20451760Hz207470 | 202 | 50 Hz: 204/517 / 60 Hz: 207/470
Value_50Hz20551860Hz208471 | 203 | 50 Hz: 205/518 / 60 Hz: 208/471
Value_50Hz20651960Hz209472 | 204 | 50 Hz: 206/519 / 60 Hz: 209/472
Value_50Hz20752060Hz210473 | 205 | 50 Hz: 207/520 / 60 Hz: 210/473
Value_50Hz20852160Hz211474 | 206 | 50 Hz: 208/521 / 60 Hz: 211/474
Value_50Hz20952260Hz212475 | 207 | 50 Hz: 209/522 / 60 Hz: 212/475
Value_50Hz21052360Hz213476 | 208 | 50 Hz: 210/523 / 60 Hz: 213/476
Value_50Hz21152460Hz214477 | 209 | 50 Hz: 211/524 / 60 Hz: 214/477
Value_50Hz21252560Hz215478 | 210 | 50 Hz: 212/525 / 60 Hz: 215/478
Value_50Hz21352660Hz216479 | 211 | 50 Hz: 213/526 / 60 Hz: 216/479
Value_50Hz21452760Hz217480 | 212 | 50 Hz: 214/527 / 60 Hz: 217/480
Value_50Hz21552860Hz218481 | 213 | 50 Hz: 215/528 / 60 Hz: 218/481
Value_50Hz21652960Hz219482 | 214 | 50 Hz: 216/529 / 60 Hz: 219/482
Value_50Hz21753060Hz220483 | 215 | 50 Hz: 217/530 / 60 Hz: 220/483
Value_50Hz21853160Hz221484 | 216 | 50 Hz: 218/531 / 60 Hz: 221/484
Value_50Hz21953260Hz222485 | 217 | 50 Hz: 219/532 / 60 Hz: 222/485
Value_50Hz22053360Hz223486 | 218 | 50 Hz: 220/533 / 60 Hz: 223/486
Value_50Hz22153460Hz224487 | 219 | 50 Hz: 221/534 / 60 Hz: 224/487
Value_50Hz22253560Hz225488 | 220 | 50 Hz: 222/535 / 60 Hz: 225/488
Value_50Hz22353660Hz226489 | 221 | 50 Hz: 223/536 / 60 Hz: 226/489
Value_50Hz22453760Hz227490 | 222 | 50 Hz: 224/537 / 60 Hz: 227/490
Value_50Hz22553860Hz228491 | 223 | 50 Hz: 225/538 / 60 Hz: 228/491
Value_50Hz22653960Hz229492 | 224 | 50 Hz: 226/539 / 60 Hz: 229/492
Value_50Hz22754060Hz230493 | 225 | 50 Hz: 227/540 / 60 Hz: 230/493
Value_50Hz22854160Hz231494 | 226 | 50 Hz: 228/541 / 60 Hz: 231/494
Value_50Hz22954260Hz232495 | 227 | 50 Hz: 229/542 / 60 Hz: 232/495
Value_50Hz23054360Hz233496 | 228 | 50 Hz: 230/543 / 60 Hz: 233/496
Value_50Hz23154460Hz234497 | 229 | 50 Hz: 231/544 / 60 Hz: 234/497
Value_50Hz23254560Hz235498 | 230 | 50 Hz: 232/545 / 60 Hz: 235/498
Value_50Hz23354660Hz236499 | 231 | 50 Hz: 233/546 / 60 Hz: 236/499
Value_50Hz23454760Hz237500 | 232 | 50 Hz: 234/547 / 60 Hz: 237/500
Value_50Hz23554860Hz238501 | 233 | 50 Hz: 235/548 / 60 Hz: 238/501
Value_50Hz23654960Hz239502 | 234 | 50 Hz: 236/549 / 60 Hz: 239/502
Value_50Hz23755060Hz240503 | 235 | 50 Hz: 237/550 / 60 Hz: 240/503
Value_50Hz23855160Hz241504 | 236 | 50 Hz: 238/551 / 60 Hz: 241/504
Value_50Hz23955260Hz242505 | 237 | 50 Hz: 239/552 / 60 Hz: 242/505
Value_50Hz24055360Hz243506 | 238 | 50 Hz: 240/553 / 60 Hz: 243/506
Value_50Hz24155460Hz244507 | 239 | 50 Hz: 241/554 / 60 Hz: 244/507
Value_50Hz24255560Hz245508 | 240 | 50 Hz: 242/555 / 60 Hz: 245/508
Value_50Hz24355660Hz246509 | 241 | 50 Hz: 243/556 / 60 Hz: 246/509
Value_50Hz24455760Hz247510 | 242 | 50 Hz: 244/557 / 60 Hz: 247/510
Value_50Hz24555860Hz248511 | 243 | 50 Hz: 245/558 / 60 Hz: 248/511
Value_50Hz24655960Hz249512 | 244 | 50 Hz: 246/559 / 60 Hz: 249/512
Value_50Hz24756060Hz250513 | 245 | 50 Hz: 247/560 / 60 Hz: 250/513
Value_50Hz24856160Hz251514 | 246 | 50 Hz: 248/561 / 60 Hz: 251/514
Value_50Hz24956260Hz252515 | 247 | 50 Hz: 249/562 / 60 Hz: 252/515
Value_50Hz25056360Hz253516 | 248 | 50 Hz: 250/563 / 60 Hz: 253/516
Value_50Hz25156460Hz254517 | 249 | 50 Hz: 251/564 / 60 Hz: 254/517
Value_50Hz25256560Hz255518 | 250 | 50 Hz: 252/565 / 60 Hz: 255/518
Value_50Hz25356660Hz256519 | 251 | 50 Hz: 253/566 / 60 Hz: 256/519
Value_50Hz25456760Hz257520 | 252 | 50 Hz: 254/567 / 60 Hz: 257/520
Value_50Hz25556860Hz258521 | 253 | 50 Hz: 255/568 / 60 Hz: 258/521
Value_50Hz25656960Hz259522 | 254 | 50 Hz: 256/569 / 60 Hz: 259/522
Value_50Hz25757060Hz260523 | 255 | 50 Hz: 257/570 / 60 Hz: 260/523
Value_50Hz25857160Hz261524 | 256 | 50 Hz: 258/571 / 60 Hz: 261/524
Value_50Hz25957260Hz262525 | 257 | 50 Hz: 259/572 / 60 Hz: 262/525
Value_50Hz26057360Hz2631 | 258 | 50 Hz: 260/573 / 60 Hz: 263/1
Value_50Hz26157460Hz2642 | 259 | 50 Hz: 261/574 / 60 Hz: 264/2
Value_50Hz26257560Hz2653 | 260 | 50 Hz: 262/575 / 60 Hz: 265/3
Value_50Hz263576 | 261 | 50 Hz: 263/576
Value_50Hz26457760Hz4267 | 262 | 50 Hz: 264/577 / 60 Hz: 4/267
Value_50Hz265578 | 263 | 50 Hz: 265/578
Value_50Hz266579 | 264 | 50 Hz: 266/579
Value_50Hz267580 | 265 | 50 Hz: 267/580
Value_50Hz268581 | 266 | 50 Hz: 268/581
Value_50Hz269582 | 267 | 50 Hz: 269/582
Value_50Hz270583 | 268 | 50 Hz: 270/583
Value_50Hz271584 | 269 | 50 Hz: 271/584
Value_50Hz272585 | 270 | 50 Hz: 272/585
Value_50Hz273586 | 271 | 50 Hz: 273/586
Value_50Hz274587 | 272 | 50 Hz: 274/587
Value_50Hz275588 | 273 | 50 Hz: 275/588
Value_50Hz276589 | 274 | 50 Hz: 276/589
Value_50Hz277590 | 275 | 50 Hz: 277/590
Value_50Hz278591 | 276 | 50 Hz: 278/591
Value_50Hz279592 | 277 | 50 Hz: 279/592
Value_50Hz280593 | 278 | 50 Hz: 280/593
Value_50Hz281594 | 279 | 50 Hz: 281/594
Value_50Hz282595 | 280 | 50 Hz: 282/595
Value_50Hz283596 | 281 | 50 Hz: 283/596
Value_50Hz284597 | 282 | 50 Hz: 284/597
Value_50Hz285598 | 283 | 50 Hz: 285/598
Value_50Hz286599 | 284 | 50 Hz: 286/599
Value_50Hz287600 | 285 | 50 Hz: 287/600
Value_50Hz288601 | 286 | 50 Hz: 288/601
Value_50Hz289602 | 287 | 50 Hz: 289/602
Value_50Hz290603 | 288 | 50 Hz: 290/603
Value_50Hz291604 | 289 | 50 Hz: 291/604
Value_50Hz292605 | 290 | 50 Hz: 292/605
Value_50Hz293606 | 291 | 50 Hz: 293/606
Value_50Hz294607 | 292 | 50 Hz: 294/607
Value_50Hz295608 | 293 | 50 Hz: 295/608
Value_50Hz296609 | 294 | 50 Hz: 296/609
Value_50Hz297610 | 295 | 50 Hz: 297/610
Value_50Hz298611 | 296 | 50 Hz: 298/611
Value_50Hz299612 | 297 | 50 Hz: 299/612
Value_50Hz300613 | 298 | 50 Hz: 300/613
Value_50Hz301614 | 299 | 50 Hz: 301/614
Value_50Hz302615 | 300 | 50 Hz: 302/615
Value_50Hz303616 | 301 | 50 Hz: 303/616
Value_50Hz304617 | 302 | 50 Hz: 304/617
Value_50Hz305618 | 303 | 50 Hz: 305/618
Value_50Hz306619 | 304 | 50 Hz: 306/619
Value_50Hz307620 | 305 | 50 Hz: 307/620
Value_50Hz308621 | 306 | 50 Hz: 308/621
Value_50Hz309622 | 307 | 50 Hz: 309/622
Value_50Hz310623 | 308 | 50 Hz: 310/623
Value_50Hz311624 | 309 | 50 Hz: 311/624
Value_50Hz312625 | 310 | 50 Hz: 312/625
Value_50Hz1314 | 312 | 50 Hz: 1/314
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDXPORTIOENABLEKPHASECONTROL0 Enumeration

IRD

Saa7119TYPIDXPORTIOENABLEKPHASECONTROL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDXPORTIOENABLEKPHASECONTROL0
Public Enumeration TYPIDXPORTIOENABLEKPHASECONTROL0
public enum class TYPIDXPORTIOENABLEKPHASECONTROL0
type TYPIDXPORTIOENABLEKPHASECONTROL0
Members
Member name | Value | Description
DisabledBySoftware | 0 | Disabled by software
EnabledBySoftware | 1 | Enabled by software
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDXPORTIOENABLEKPHASECONTROL1 Enumeration

IRD

Saa7119TYPIDXPORTIOENABLEKPHASECONTROL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDXPORTIOENABLEKPHASECONTROL1
Public Enumeration TYPIDXPORTIOENABLEKPHASECONTROL1
public enum class TYPIDXPORTIOENABLEKPHASECONTROL1
type TYPIDXPORTIOENABLEKPHASECONTROL1
Members
Member name | Value | Description
Logic0 | 0 | Logic 0
Logic1 | 1 | Logic 1
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDXPORTIOENABLEKPHASECONTROL2 Enumeration

IRD

Saa7119TYPIDXPORTIOENABLEKPHASECONTROL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDXPORTIOENABLEKPHASECONTROL2
Public Enumeration TYPIDXPORTIOENABLEKPHASECONTROL2
public enum class TYPIDXPORTIOENABLEKPHASECONTROL2
type TYPIDXPORTIOENABLEKPHASECONTROL2
Members
Member name | Value | Description
ABTaskFlagFromEventHandlerA1 | 0 | A/B task flag from event handler (A = 1)
ReadySignalFromScalerPathXRDY1MeansTheSAA7119IsReadyToReceiveData | 1 | Ready signal from scaler path (XRDY = 1 means the SAA7119 is ready to receive data)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDXPORTIOENABLEKPHASECONTROL3 Enumeration

IRD

Saa7119TYPIDXPORTIOENABLEKPHASECONTROL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDXPORTIOENABLEKPHASECONTROL3
Public Enumeration TYPIDXPORTIOENABLEKPHASECONTROL3
public enum class TYPIDXPORTIOENABLEKPHASECONTROL3
type TYPIDXPORTIOENABLEKPHASECONTROL3
Members
Member name | Value | Description
MixOff | 0 | Mix off
MixOn | 1 | Mix on
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDXPORTIOENABLEKPHASECONTROL4 Enumeration

IRD

Saa7119TYPIDXPORTIOENABLEKPHASECONTROL4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDXPORTIOENABLEKPHASECONTROL4
Public Enumeration TYPIDXPORTIOENABLEKPHASECONTROL4
public enum class TYPIDXPORTIOENABLEKPHASECONTROL4
type TYPIDXPORTIOENABLEKPHASECONTROL4
Members
Member name | Value | Description
XCLKInvertedInputOutputPhase | 0 | XCLK inverted input/output phase
XCLKNonInvertedInputOutputPhaseRecommendedValue | 1 | XCLK non inverted input/output phase, recommended value
XCLKInvertedAndPhaseShiftedByAbout3Nsec | 2 | XCLK inverted and phase shifted by about 3 nsec
XCLKNonInvertedAndPhaseShiftedByAbout3Nsec | 3 | XCLK non inverted and phase shifted by about 3 nsec
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDXPORTSIGNALDEFGNALPOLARITIES0 Enumeration

IRD

Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDXPORTSIGNALDEFGNALPOLARITIES0
Public Enumeration TYPIDXPORTSIGNALDEFGNALPOLARITIES0
public enum class TYPIDXPORTSIGNALDEFGNALPOLARITIES0
type TYPIDXPORTSIGNALDEFGNALPOLARITIES0
Members
Member name | Value | Description
DefaultPolarity | 0 | Default polarity
Inverted | 1 | Inverted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Saa7119.TYPIDXPORTSIGNALDEFGNALPOLARITIES5 Enumeration

IRD

Saa7119TYPIDXPORTSIGNALDEFGNALPOLARITIES5 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDXPORTSIGNALDEFGNALPOLARITIES5
Public Enumeration TYPIDXPORTSIGNALDEFGNALPOLARITIES5
public enum class TYPIDXPORTSIGNALDEFGNALPOLARITIES5
type TYPIDXPORTSIGNALDEFGNALPOLARITIES5
Members
Member name | Value | Description
D0D1D2D3FF0000SAVCB0Y0CR0Y1 | 0 | D0 D1 D2 D3 -> FF 00 00 SAV CB0 Y0 CR0 Y1
D1D0D3D200FFSAV00Y0CB0Y1CR0 | 1 | D1 D0 D3 D2 -> 00 FF SAV 00 Y0 CB0 Y1 CR0
D2D3D0D100SAVFF00CR0Y1CB0Y0 | 2 | D2 D3 D0 D1 -> 00 SAV FF 00 CR0 Y1 CB0 Y0
D3D2D1D0SAV0000FFY1CR0Y0CB0 | 3 | D3 D2 D1 D0 -> SAV 00 00 FF Y1 CR0 Y0 CB0
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se95 Class

NXP Semiconductors: SE 95
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsSe95

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Se95
Public Class Se95
public ref class Se95
type Se95 =  class end

The Se95 type exposes the following members.

Constructors
 | Name | Description
Public method | Se95 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConversionRateRATEVAL | Conversion Rate (RATEVAL)
Public property | DeviceOperationSHUTDOWN | Device Operation (SHUTDOWN)
Public property | FaultQueueOSFQUE | Fault Queue (OS_F_QUE)
Public property | HysteresisTHYST | Hysteresis (THYST) (unit: °C)
Public property | ManufacturerIDCodeID | Manufacturer ID Code (ID)
Public property | OSOperationOSCOMPINT | OS Operation (OS_COMP_INT)
Public property | OverTemperatureTOS | Over-Temperature (TOS) (unit: °C)
Public property | PolarityOSPOL | Polarity (OS_POL)
Public property | TemperatureTEMP | Temperature (TEMP) (unit: °C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Ultra High Accuracy Digital Temperature Sensor And Thermal Watchdog
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se95 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se95(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Se95(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Se95

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Se95 Class
telos.Ird.NXPSemiconductors Namespace


Se95 Properties

The Se95 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConversionRateRATEVAL | Conversion Rate (RATEVAL)
Public property | DeviceOperationSHUTDOWN | Device Operation (SHUTDOWN)
Public property | FaultQueueOSFQUE | Fault Queue (OS_F_QUE)
Public property | HysteresisTHYST | Hysteresis (THYST) (unit: °C)
Public property | ManufacturerIDCodeID | Manufacturer ID Code (ID)
Public property | OSOperationOSCOMPINT | OS Operation (OS_COMP_INT)
Public property | OverTemperatureTOS | Over-Temperature (TOS) (unit: °C)
Public property | PolarityOSPOL | Polarity (OS_POL)
Public property | TemperatureTEMP | Temperature (TEMP) (unit: °C)
Top
See Also

Reference

Se95 Class
telos.Ird.NXPSemiconductors Namespace


Se95.AutoFlush Property

IRD

Se95AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Se95 Class
telos.Ird.NXPSemiconductors Namespace


Se95.ConversionRateRATEVAL Property

IRD

Se95ConversionRateRATEVAL Property

Conversion Rate (RATEVAL)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se95TypeConversionRate ConversionRateRATEVAL { get; set; }
Public Property ConversionRateRATEVAL As Se95TypeConversionRate
    Get
    Set
public:
property Se95TypeConversionRate ConversionRateRATEVAL {
    Se95TypeConversionRate get ();
    void set (Se95TypeConversionRate value);
}
member ConversionRateRATEVAL : Se95TypeConversionRate with get, set

Property Value

Type: Se95TypeConversionRate
See Also

Reference

Se95 Class
telos.Ird.NXPSemiconductors Namespace


Se95.DeviceOperationSHUTDOWN Property

IRD

Se95DeviceOperationSHUTDOWN Property

Device Operation (SHUTDOWN)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se95TypeOperationMode DeviceOperationSHUTDOWN { get; set; }
Public Property DeviceOperationSHUTDOWN As Se95TypeOperationMode
    Get
    Set
public:
property Se95TypeOperationMode DeviceOperationSHUTDOWN {
    Se95TypeOperationMode get ();
    void set (Se95TypeOperationMode value);
}
member DeviceOperationSHUTDOWN : Se95TypeOperationMode with get, set

Property Value

Type: Se95TypeOperationMode
See Also

Reference

Se95 Class
telos.Ird.NXPSemiconductors Namespace


Se95.FaultQueueOSFQUE Property

IRD

Se95FaultQueueOSFQUE Property

Fault Queue (OS_F_QUE)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se95TypeOsFaultQueue FaultQueueOSFQUE { get; set; }
Public Property FaultQueueOSFQUE As Se95TypeOsFaultQueue
    Get
    Set
public:
property Se95TypeOsFaultQueue FaultQueueOSFQUE {
    Se95TypeOsFaultQueue get ();
    void set (Se95TypeOsFaultQueue value);
}
member FaultQueueOSFQUE : Se95TypeOsFaultQueue with get, set

Property Value

Type: Se95TypeOsFaultQueue
See Also

Reference

Se95 Class
telos.Ird.NXPSemiconductors Namespace


Se95.HysteresisTHYST Property

IRD

Se95HysteresisTHYST Property

Hysteresis (THYST) (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double HysteresisTHYST { get; set; }
Public Property HysteresisTHYST As Double
    Get
    Set
public:
property double HysteresisTHYST {
    double get ();
    void set (double value);
}
member HysteresisTHYST : float with get, set

Property Value

Type: Double
See Also

Reference

Se95 Class
telos.Ird.NXPSemiconductors Namespace


Se95.ManufacturerIDCodeID Property

IRD

Se95ManufacturerIDCodeID Property

Manufacturer ID Code (ID)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufacturerIDCodeID { get; }
Public ReadOnly Property ManufacturerIDCodeID As Byte
    Get
public:
property unsigned char ManufacturerIDCodeID {
    unsigned char get ();
}
member ManufacturerIDCodeID : byte with get

Property Value

Type: Byte
See Also

Reference

Se95 Class
telos.Ird.NXPSemiconductors Namespace


Se95.OSOperationOSCOMPINT Property

IRD

Se95OSOperationOSCOMPINT Property

OS Operation (OS_COMP_INT)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se95TypeOsOperationModeSelection OSOperationOSCOMPINT { get; set; }
Public Property OSOperationOSCOMPINT As Se95TypeOsOperationModeSelection
    Get
    Set
public:
property Se95TypeOsOperationModeSelection OSOperationOSCOMPINT {
    Se95TypeOsOperationModeSelection get ();
    void set (Se95TypeOsOperationModeSelection value);
}
member OSOperationOSCOMPINT : Se95TypeOsOperationModeSelection with get, set

Property Value

Type: Se95TypeOsOperationModeSelection
See Also

Reference

Se95 Class
telos.Ird.NXPSemiconductors Namespace


Se95.OverTemperatureTOS Property

IRD

Se95OverTemperatureTOS Property

Over-Temperature (TOS) (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double OverTemperatureTOS { get; set; }
Public Property OverTemperatureTOS As Double
    Get
    Set
public:
property double OverTemperatureTOS {
    double get ();
    void set (double value);
}
member OverTemperatureTOS : float with get, set

Property Value

Type: Double
See Also

Reference

Se95 Class
telos.Ird.NXPSemiconductors Namespace


Se95.PolarityOSPOL Property

IRD

Se95PolarityOSPOL Property

Polarity (OS_POL)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se95TypeOsPolaritySelection PolarityOSPOL { get; set; }
Public Property PolarityOSPOL As Se95TypeOsPolaritySelection
    Get
    Set
public:
property Se95TypeOsPolaritySelection PolarityOSPOL {
    Se95TypeOsPolaritySelection get ();
    void set (Se95TypeOsPolaritySelection value);
}
member PolarityOSPOL : Se95TypeOsPolaritySelection with get, set

Property Value

Type: Se95TypeOsPolaritySelection
See Also

Reference

Se95 Class
telos.Ird.NXPSemiconductors Namespace


Se95.TemperatureTEMP Property

IRD

Se95TemperatureTEMP Property

Temperature (TEMP) (unit: °C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TemperatureTEMP { get; }
Public ReadOnly Property TemperatureTEMP As Double
    Get
public:
property double TemperatureTEMP {
    double get ();
}
member TemperatureTEMP : float with get

Property Value

Type: Double
See Also

Reference

Se95 Class
telos.Ird.NXPSemiconductors Namespace


Se95 Methods

The Se95 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Se95 Class
telos.Ird.NXPSemiconductors Namespace


Se95.Flush Method

IRD

Se95Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Se95 Class
telos.Ird.NXPSemiconductors Namespace


Se95.TypeConversionRate Enumeration

IRD

Se95TypeConversionRate Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConversionRate
Public Enumeration TypeConversionRate
public enum class TypeConversionRate
type TypeConversionRate
Members
Member name | Value | Description
ConversionsPerSecond10 | 0 | Conversions Per Second: 10
ConversionsPerSecond0125 | 1 | Conversions Per Second: 0.125
ConversionsPerSecond1 | 2 | Conversions Per Second: 1
ConversionsPerSecond30 | 3 | Conversions Per Second: 30
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se95.TypeOperationMode Enumeration

IRD

Se95TypeOperationMode Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationMode
Public Enumeration TypeOperationMode
public enum class TypeOperationMode
type TypeOperationMode
Members
Member name | Value | Description
Normal | 0 | Normal
Shutdown | 1 | Shutdown
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se95.TypeOsFaultQueue Enumeration

IRD

Se95TypeOsFaultQueue Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOsFaultQueue
Public Enumeration TypeOsFaultQueue
public enum class TypeOsFaultQueue
type TypeOsFaultQueue
Members
Member name | Value | Description
QueueValue1 | 0 | Queue Value = 1
QueueValue2 | 1 | Queue Value = 2
QueueValue4 | 2 | Queue Value = 4
QueueValue6 | 3 | Queue Value = 6
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se95.TypeOsOperationModeSelection Enumeration

IRD

Se95TypeOsOperationModeSelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOsOperationModeSelection
Public Enumeration TypeOsOperationModeSelection
public enum class TypeOsOperationModeSelection
type TypeOsOperationModeSelection
Members
Member name | Value | Description
OSComparator | 0 | OS Comparator
OSInterrupt | 1 | OS Interrupt
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se95.TypeOsPolaritySelection Enumeration

IRD

Se95TypeOsPolaritySelection Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOsPolaritySelection
Public Enumeration TypeOsPolaritySelection
public enum class TypeOsPolaritySelection
type TypeOsPolaritySelection
Members
Member name | Value | Description
OSActiveLow | 0 | OS Active: Low
OSActiveHigh | 1 | OS Active: High
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b Class

NXP Semiconductors: SE 97B (Temperature)
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsSe97b

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Se97b
Public Class Se97b
public ref class Se97b
type Se97b =  class end

The Se97b type exposes the following members.

Constructors
 | Name | Description
Public method | Se97b | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CapabilityBCAP | Capability: BCAP
Public property | CapabilityEVSD | Capability: EVSD
Public property | CapabilityHACC | Capability: HACC
Public property | CapabilityTMOUT | Capability: TMOUT
Public property | CapabilityTRES | Capability: TRES
Public property | CapabilityVHV | Capability: VHV
Public property | CapabilityWRNG | Capability: WRNG
Public property | ConfigurationAWLB | Configuration: AWLB
Public property | ConfigurationCEVNT | Configuration: CEVNT
Public property | ConfigurationCTLB | Configuration: CTLB
Public property | ConfigurationCVO | Configuration: CVO
Public property | ConfigurationEMD | Configuration: EMD
Public property | ConfigurationEOCTL | Configuration: EOCTL
Public property | ConfigurationEP | Configuration: EP
Public property | ConfigurationESTAT | Configuration:: ESTAT
Public property | ConfigurationHEN | Configuration: HEN
Public property | ConfigurationSHMD | Configuration: SHMD
Public property | CriticalAlarmTripCT | Critical Alarm Trip: CT (unit: ° C)
Public property | DeviceID | Device ID
Public property | DeviceRevision | Device Revision
Public property | LowerBoundaryAlarmTripLBT | Lower Boundary Alarm Trip: LBT (unit: ° C)
Public property | ManufacturerID | Manufacturer ID
Public property | SMBusDisableARA | SM Bus: Disable ARA
Public property | SMBusDisableTimeout | SM Bus: Disable Timeout
Public property | SMBusEnableSDTO | SM Bus: Enable SDTO
Public property | SMBusEventSleepState | SM Bus: Event Sleep State
Public property | SMBusFlagUpdateMode | SM Bus: Flag Update Mode
Public property | SMBusIntrClearMode | SM Bus: Intr Clear Mode
Public property | TemperatureAAW | Temperature: AAW
Public property | TemperatureACT | Temperature: ACT
Public property | TemperatureBAW | Temperature: BAW
Public property | TemperatureTEMP | Temperature: TEMP (unit: ° C)
Public property | UpperBoundaryAlarmTripUBT | Upper Boundary Alarm Trip: UBT (unit: ° C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
DDR Memory Module Temperature Sensor With Integrated SPD
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97b(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Se97b(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Se97b

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b Properties

The Se97b type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CapabilityBCAP | Capability: BCAP
Public property | CapabilityEVSD | Capability: EVSD
Public property | CapabilityHACC | Capability: HACC
Public property | CapabilityTMOUT | Capability: TMOUT
Public property | CapabilityTRES | Capability: TRES
Public property | CapabilityVHV | Capability: VHV
Public property | CapabilityWRNG | Capability: WRNG
Public property | ConfigurationAWLB | Configuration: AWLB
Public property | ConfigurationCEVNT | Configuration: CEVNT
Public property | ConfigurationCTLB | Configuration: CTLB
Public property | ConfigurationCVO | Configuration: CVO
Public property | ConfigurationEMD | Configuration: EMD
Public property | ConfigurationEOCTL | Configuration: EOCTL
Public property | ConfigurationEP | Configuration: EP
Public property | ConfigurationESTAT | Configuration:: ESTAT
Public property | ConfigurationHEN | Configuration: HEN
Public property | ConfigurationSHMD | Configuration: SHMD
Public property | CriticalAlarmTripCT | Critical Alarm Trip: CT (unit: ° C)
Public property | DeviceID | Device ID
Public property | DeviceRevision | Device Revision
Public property | LowerBoundaryAlarmTripLBT | Lower Boundary Alarm Trip: LBT (unit: ° C)
Public property | ManufacturerID | Manufacturer ID
Public property | SMBusDisableARA | SM Bus: Disable ARA
Public property | SMBusDisableTimeout | SM Bus: Disable Timeout
Public property | SMBusEnableSDTO | SM Bus: Enable SDTO
Public property | SMBusEventSleepState | SM Bus: Event Sleep State
Public property | SMBusFlagUpdateMode | SM Bus: Flag Update Mode
Public property | SMBusIntrClearMode | SM Bus: Intr Clear Mode
Public property | TemperatureAAW | Temperature: AAW
Public property | TemperatureACT | Temperature: ACT
Public property | TemperatureBAW | Temperature: BAW
Public property | TemperatureTEMP | Temperature: TEMP (unit: ° C)
Public property | UpperBoundaryAlarmTripUBT | Upper Boundary Alarm Trip: UBT (unit: ° C)
Top
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.AutoFlush Property

IRD

Se97bAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.CapabilityBCAP Property

IRD

Se97bCapabilityBCAP Property

Capability: BCAP

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeCapabilityBasicCapability CapabilityBCAP { get; }
Public ReadOnly Property CapabilityBCAP As Se97bTypeCapabilityBasicCapability
    Get
public:
property Se97bTypeCapabilityBasicCapability CapabilityBCAP {
    Se97bTypeCapabilityBasicCapability get ();
}
member CapabilityBCAP : Se97bTypeCapabilityBasicCapability with get

Property Value

Type: Se97bTypeCapabilityBasicCapability
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.CapabilityEVSD Property

IRD

Se97bCapabilityEVSD Property

Capability: EVSD

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeCapabilityEventShutdownAction CapabilityEVSD { get; }
Public ReadOnly Property CapabilityEVSD As Se97bTypeCapabilityEventShutdownAction
    Get
public:
property Se97bTypeCapabilityEventShutdownAction CapabilityEVSD {
    Se97bTypeCapabilityEventShutdownAction get ();
}
member CapabilityEVSD : Se97bTypeCapabilityEventShutdownAction with get

Property Value

Type: Se97bTypeCapabilityEventShutdownAction
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.CapabilityHACC Property

IRD

Se97bCapabilityHACC Property

Capability: HACC

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeCapabilityHigherAccuracy CapabilityHACC { get; }
Public ReadOnly Property CapabilityHACC As Se97bTypeCapabilityHigherAccuracy
    Get
public:
property Se97bTypeCapabilityHigherAccuracy CapabilityHACC {
    Se97bTypeCapabilityHigherAccuracy get ();
}
member CapabilityHACC : Se97bTypeCapabilityHigherAccuracy with get

Property Value

Type: Se97bTypeCapabilityHigherAccuracy
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.CapabilityTMOUT Property

IRD

Se97bCapabilityTMOUT Property

Capability: TMOUT

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeCapabilityBusTimeoutPeriod CapabilityTMOUT { get; }
Public ReadOnly Property CapabilityTMOUT As Se97bTypeCapabilityBusTimeoutPeriod
    Get
public:
property Se97bTypeCapabilityBusTimeoutPeriod CapabilityTMOUT {
    Se97bTypeCapabilityBusTimeoutPeriod get ();
}
member CapabilityTMOUT : Se97bTypeCapabilityBusTimeoutPeriod with get

Property Value

Type: Se97bTypeCapabilityBusTimeoutPeriod
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.CapabilityTRES Property

IRD

Se97bCapabilityTRES Property

Capability: TRES

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeCapabilityTemperatureResolution CapabilityTRES { get; }
Public ReadOnly Property CapabilityTRES As Se97bTypeCapabilityTemperatureResolution
    Get
public:
property Se97bTypeCapabilityTemperatureResolution CapabilityTRES {
    Se97bTypeCapabilityTemperatureResolution get ();
}
member CapabilityTRES : Se97bTypeCapabilityTemperatureResolution with get

Property Value

Type: Se97bTypeCapabilityTemperatureResolution
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.CapabilityVHV Property

IRD

Se97bCapabilityVHV Property

Capability: VHV

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeCapabilityHighVoltageStandoff CapabilityVHV { get; }
Public ReadOnly Property CapabilityVHV As Se97bTypeCapabilityHighVoltageStandoff
    Get
public:
property Se97bTypeCapabilityHighVoltageStandoff CapabilityVHV {
    Se97bTypeCapabilityHighVoltageStandoff get ();
}
member CapabilityVHV : Se97bTypeCapabilityHighVoltageStandoff with get

Property Value

Type: Se97bTypeCapabilityHighVoltageStandoff
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.CapabilityWRNG Property

IRD

Se97bCapabilityWRNG Property

Capability: WRNG

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeCapabilityWideRange CapabilityWRNG { get; }
Public ReadOnly Property CapabilityWRNG As Se97bTypeCapabilityWideRange
    Get
public:
property Se97bTypeCapabilityWideRange CapabilityWRNG {
    Se97bTypeCapabilityWideRange get ();
}
member CapabilityWRNG : Se97bTypeCapabilityWideRange with get

Property Value

Type: Se97bTypeCapabilityWideRange
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.ConfigurationAWLB Property

IRD

Se97bConfigurationAWLB Property

Configuration: AWLB

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeConfigurationAlarmWindowLock ConfigurationAWLB { get; set; }
Public Property ConfigurationAWLB As Se97bTypeConfigurationAlarmWindowLock
    Get
    Set
public:
property Se97bTypeConfigurationAlarmWindowLock ConfigurationAWLB {
    Se97bTypeConfigurationAlarmWindowLock get ();
    void set (Se97bTypeConfigurationAlarmWindowLock value);
}
member ConfigurationAWLB : Se97bTypeConfigurationAlarmWindowLock with get, set

Property Value

Type: Se97bTypeConfigurationAlarmWindowLock
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.ConfigurationCEVNT Property

IRD

Se97bConfigurationCEVNT Property

Configuration: CEVNT

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeConfigurationClearEvent ConfigurationCEVNT { set; }
Public WriteOnly Property ConfigurationCEVNT As Se97bTypeConfigurationClearEvent
    Set
public:
property Se97bTypeConfigurationClearEvent ConfigurationCEVNT {
    void set (Se97bTypeConfigurationClearEvent value);
}
member ConfigurationCEVNT : Se97bTypeConfigurationClearEvent with set

Property Value

Type: Se97bTypeConfigurationClearEvent
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.ConfigurationCTLB Property

IRD

Se97bConfigurationCTLB Property

Configuration: CTLB

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeConfigurationCriticalTripLock ConfigurationCTLB { get; set; }
Public Property ConfigurationCTLB As Se97bTypeConfigurationCriticalTripLock
    Get
    Set
public:
property Se97bTypeConfigurationCriticalTripLock ConfigurationCTLB {
    Se97bTypeConfigurationCriticalTripLock get ();
    void set (Se97bTypeConfigurationCriticalTripLock value);
}
member ConfigurationCTLB : Se97bTypeConfigurationCriticalTripLock with get, set

Property Value

Type: Se97bTypeConfigurationCriticalTripLock
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.ConfigurationCVO Property

IRD

Se97bConfigurationCVO Property

Configuration: CVO

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeConfigurationCriticalEventOnly ConfigurationCVO { get; set; }
Public Property ConfigurationCVO As Se97bTypeConfigurationCriticalEventOnly
    Get
    Set
public:
property Se97bTypeConfigurationCriticalEventOnly ConfigurationCVO {
    Se97bTypeConfigurationCriticalEventOnly get ();
    void set (Se97bTypeConfigurationCriticalEventOnly value);
}
member ConfigurationCVO : Se97bTypeConfigurationCriticalEventOnly with get, set

Property Value

Type: Se97bTypeConfigurationCriticalEventOnly
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.ConfigurationEMD Property

IRD

Se97bConfigurationEMD Property

Configuration: EMD

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeConfigurationEventMode ConfigurationEMD { get; set; }
Public Property ConfigurationEMD As Se97bTypeConfigurationEventMode
    Get
    Set
public:
property Se97bTypeConfigurationEventMode ConfigurationEMD {
    Se97bTypeConfigurationEventMode get ();
    void set (Se97bTypeConfigurationEventMode value);
}
member ConfigurationEMD : Se97bTypeConfigurationEventMode with get, set

Property Value

Type: Se97bTypeConfigurationEventMode
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.ConfigurationEOCTL Property

IRD

Se97bConfigurationEOCTL Property

Configuration: EOCTL

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeConfigurationEventOutputControl ConfigurationEOCTL { get; set; }
Public Property ConfigurationEOCTL As Se97bTypeConfigurationEventOutputControl
    Get
    Set
public:
property Se97bTypeConfigurationEventOutputControl ConfigurationEOCTL {
    Se97bTypeConfigurationEventOutputControl get ();
    void set (Se97bTypeConfigurationEventOutputControl value);
}
member ConfigurationEOCTL : Se97bTypeConfigurationEventOutputControl with get, set

Property Value

Type: Se97bTypeConfigurationEventOutputControl
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.ConfigurationEP Property

IRD

Se97bConfigurationEP Property

Configuration: EP

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeConfigurationEventPolarity ConfigurationEP { get; set; }
Public Property ConfigurationEP As Se97bTypeConfigurationEventPolarity
    Get
    Set
public:
property Se97bTypeConfigurationEventPolarity ConfigurationEP {
    Se97bTypeConfigurationEventPolarity get ();
    void set (Se97bTypeConfigurationEventPolarity value);
}
member ConfigurationEP : Se97bTypeConfigurationEventPolarity with get, set

Property Value

Type: Se97bTypeConfigurationEventPolarity
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.ConfigurationESTAT Property

IRD

Se97bConfigurationESTAT Property

Configuration:: ESTAT

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeConfigurationEventStatus ConfigurationESTAT { get; }
Public ReadOnly Property ConfigurationESTAT As Se97bTypeConfigurationEventStatus
    Get
public:
property Se97bTypeConfigurationEventStatus ConfigurationESTAT {
    Se97bTypeConfigurationEventStatus get ();
}
member ConfigurationESTAT : Se97bTypeConfigurationEventStatus with get

Property Value

Type: Se97bTypeConfigurationEventStatus
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.ConfigurationHEN Property

IRD

Se97bConfigurationHEN Property

Configuration: HEN

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeConfigurationHysteresisEnable ConfigurationHEN { get; set; }
Public Property ConfigurationHEN As Se97bTypeConfigurationHysteresisEnable
    Get
    Set
public:
property Se97bTypeConfigurationHysteresisEnable ConfigurationHEN {
    Se97bTypeConfigurationHysteresisEnable get ();
    void set (Se97bTypeConfigurationHysteresisEnable value);
}
member ConfigurationHEN : Se97bTypeConfigurationHysteresisEnable with get, set

Property Value

Type: Se97bTypeConfigurationHysteresisEnable
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.ConfigurationSHMD Property

IRD

Se97bConfigurationSHMD Property

Configuration: SHMD

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeConfigurationShutdownMode ConfigurationSHMD { get; set; }
Public Property ConfigurationSHMD As Se97bTypeConfigurationShutdownMode
    Get
    Set
public:
property Se97bTypeConfigurationShutdownMode ConfigurationSHMD {
    Se97bTypeConfigurationShutdownMode get ();
    void set (Se97bTypeConfigurationShutdownMode value);
}
member ConfigurationSHMD : Se97bTypeConfigurationShutdownMode with get, set

Property Value

Type: Se97bTypeConfigurationShutdownMode
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.CriticalAlarmTripCT Property

IRD

Se97bCriticalAlarmTripCT Property

Critical Alarm Trip: CT (unit: ° C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CriticalAlarmTripCT { get; set; }
Public Property CriticalAlarmTripCT As Double
    Get
    Set
public:
property double CriticalAlarmTripCT {
    double get ();
    void set (double value);
}
member CriticalAlarmTripCT : float with get, set

Property Value

Type: Double
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.DeviceID Property

IRD

Se97bDeviceID Property

Device ID

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.DeviceRevision Property

IRD

Se97bDeviceRevision Property

Device Revision

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceRevision { get; }
Public ReadOnly Property DeviceRevision As Byte
    Get
public:
property unsigned char DeviceRevision {
    unsigned char get ();
}
member DeviceRevision : byte with get

Property Value

Type: Byte
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.LowerBoundaryAlarmTripLBT Property

IRD

Se97bLowerBoundaryAlarmTripLBT Property

Lower Boundary Alarm Trip: LBT (unit: ° C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LowerBoundaryAlarmTripLBT { get; set; }
Public Property LowerBoundaryAlarmTripLBT As Double
    Get
    Set
public:
property double LowerBoundaryAlarmTripLBT {
    double get ();
    void set (double value);
}
member LowerBoundaryAlarmTripLBT : float with get, set

Property Value

Type: Double
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.ManufacturerID Property

IRD

Se97bManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As UShort
    Get
public:
property unsigned short ManufacturerID {
    unsigned short get ();
}
member ManufacturerID : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.SMBusDisableARA Property

IRD

Se97bSMBusDisableARA Property

SM Bus: Disable ARA

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeSmbusAlertResponseAddress SMBusDisableARA { get; set; }
Public Property SMBusDisableARA As Se97bTypeSmbusAlertResponseAddress
    Get
    Set
public:
property Se97bTypeSmbusAlertResponseAddress SMBusDisableARA {
    Se97bTypeSmbusAlertResponseAddress get ();
    void set (Se97bTypeSmbusAlertResponseAddress value);
}
member SMBusDisableARA : Se97bTypeSmbusAlertResponseAddress with get, set

Property Value

Type: Se97bTypeSmbusAlertResponseAddress
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.SMBusDisableTimeout Property

IRD

Se97bSMBusDisableTimeout Property

SM Bus: Disable Timeout

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeSmbusTimeout SMBusDisableTimeout { get; set; }
Public Property SMBusDisableTimeout As Se97bTypeSmbusTimeout
    Get
    Set
public:
property Se97bTypeSmbusTimeout SMBusDisableTimeout {
    Se97bTypeSmbusTimeout get ();
    void set (Se97bTypeSmbusTimeout value);
}
member SMBusDisableTimeout : Se97bTypeSmbusTimeout with get, set

Property Value

Type: Se97bTypeSmbusTimeout
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.SMBusEnableSDTO Property

IRD

Se97bSMBusEnableSDTO Property

SM Bus: Enable SDTO

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeSmbusTimeoutDuringShutdown SMBusEnableSDTO { get; set; }
Public Property SMBusEnableSDTO As Se97bTypeSmbusTimeoutDuringShutdown
    Get
    Set
public:
property Se97bTypeSmbusTimeoutDuringShutdown SMBusEnableSDTO {
    Se97bTypeSmbusTimeoutDuringShutdown get ();
    void set (Se97bTypeSmbusTimeoutDuringShutdown value);
}
member SMBusEnableSDTO : Se97bTypeSmbusTimeoutDuringShutdown with get, set

Property Value

Type: Se97bTypeSmbusTimeoutDuringShutdown
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.SMBusEventSleepState Property

IRD

Se97bSMBusEventSleepState Property

SM Bus: Event Sleep State

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeSmbusEventSleepState SMBusEventSleepState { get; set; }
Public Property SMBusEventSleepState As Se97bTypeSmbusEventSleepState
    Get
    Set
public:
property Se97bTypeSmbusEventSleepState SMBusEventSleepState {
    Se97bTypeSmbusEventSleepState get ();
    void set (Se97bTypeSmbusEventSleepState value);
}
member SMBusEventSleepState : Se97bTypeSmbusEventSleepState with get, set

Property Value

Type: Se97bTypeSmbusEventSleepState
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.SMBusFlagUpdateMode Property

IRD

Se97bSMBusFlagUpdateMode Property

SM Bus: Flag Update Mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeSmbusFlagUpdateMode SMBusFlagUpdateMode { get; set; }
Public Property SMBusFlagUpdateMode As Se97bTypeSmbusFlagUpdateMode
    Get
    Set
public:
property Se97bTypeSmbusFlagUpdateMode SMBusFlagUpdateMode {
    Se97bTypeSmbusFlagUpdateMode get ();
    void set (Se97bTypeSmbusFlagUpdateMode value);
}
member SMBusFlagUpdateMode : Se97bTypeSmbusFlagUpdateMode with get, set

Property Value

Type: Se97bTypeSmbusFlagUpdateMode
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.SMBusIntrClearMode Property

IRD

Se97bSMBusIntrClearMode Property

SM Bus: Intr Clear Mode

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeSmbusInterruptFlopClearingMode SMBusIntrClearMode { get; set; }
Public Property SMBusIntrClearMode As Se97bTypeSmbusInterruptFlopClearingMode
    Get
    Set
public:
property Se97bTypeSmbusInterruptFlopClearingMode SMBusIntrClearMode {
    Se97bTypeSmbusInterruptFlopClearingMode get ();
    void set (Se97bTypeSmbusInterruptFlopClearingMode value);
}
member SMBusIntrClearMode : Se97bTypeSmbusInterruptFlopClearingMode with get, set

Property Value

Type: Se97bTypeSmbusInterruptFlopClearingMode
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.TemperatureAAW Property

IRD

Se97bTemperatureAAW Property

Temperature: AAW

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeTemperatureAboveAlarmWindow TemperatureAAW { get; }
Public ReadOnly Property TemperatureAAW As Se97bTypeTemperatureAboveAlarmWindow
    Get
public:
property Se97bTypeTemperatureAboveAlarmWindow TemperatureAAW {
    Se97bTypeTemperatureAboveAlarmWindow get ();
}
member TemperatureAAW : Se97bTypeTemperatureAboveAlarmWindow with get

Property Value

Type: Se97bTypeTemperatureAboveAlarmWindow
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.TemperatureACT Property

IRD

Se97bTemperatureACT Property

Temperature: ACT

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeTemperatureAboveCriticalTrip TemperatureACT { get; }
Public ReadOnly Property TemperatureACT As Se97bTypeTemperatureAboveCriticalTrip
    Get
public:
property Se97bTypeTemperatureAboveCriticalTrip TemperatureACT {
    Se97bTypeTemperatureAboveCriticalTrip get ();
}
member TemperatureACT : Se97bTypeTemperatureAboveCriticalTrip with get

Property Value

Type: Se97bTypeTemperatureAboveCriticalTrip
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.TemperatureBAW Property

IRD

Se97bTemperatureBAW Property

Temperature: BAW

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se97bTypeTemperatureBelowAlarmWindow TemperatureBAW { get; }
Public ReadOnly Property TemperatureBAW As Se97bTypeTemperatureBelowAlarmWindow
    Get
public:
property Se97bTypeTemperatureBelowAlarmWindow TemperatureBAW {
    Se97bTypeTemperatureBelowAlarmWindow get ();
}
member TemperatureBAW : Se97bTypeTemperatureBelowAlarmWindow with get

Property Value

Type: Se97bTypeTemperatureBelowAlarmWindow
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.TemperatureTEMP Property

IRD

Se97bTemperatureTEMP Property

Temperature: TEMP (unit: ° C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TemperatureTEMP { get; }
Public ReadOnly Property TemperatureTEMP As Double
    Get
public:
property double TemperatureTEMP {
    double get ();
}
member TemperatureTEMP : float with get

Property Value

Type: Double
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.UpperBoundaryAlarmTripUBT Property

IRD

Se97bUpperBoundaryAlarmTripUBT Property

Upper Boundary Alarm Trip: UBT (unit: ° C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double UpperBoundaryAlarmTripUBT { get; set; }
Public Property UpperBoundaryAlarmTripUBT As Double
    Get
    Set
public:
property double UpperBoundaryAlarmTripUBT {
    double get ();
    void set (double value);
}
member UpperBoundaryAlarmTripUBT : float with get, set

Property Value

Type: Double
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b Methods

The Se97b type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.Flush Method

IRD

Se97bFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Se97b Class
telos.Ird.NXPSemiconductors Namespace


Se97b.TypeCapabilityBasicCapability Enumeration

IRD

Se97bTypeCapabilityBasicCapability Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityBasicCapability
Public Enumeration TypeCapabilityBasicCapability
public enum class TypeCapabilityBasicCapability
type TypeCapabilityBasicCapability
Members
Member name | Value | Description
BasicCapabilityDisable | 0 | Basic Capability: Disable
AlarmAndCriticalTripsInterruptCapability | 1 | Alarm And Critical Trips Interrupt Capability
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeCapabilityBusTimeoutPeriod Enumeration

IRD

Se97bTypeCapabilityBusTimeoutPeriod Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityBusTimeoutPeriod
Public Enumeration TypeCapabilityBusTimeoutPeriod
public enum class TypeCapabilityBusTimeoutPeriod
type TypeCapabilityBusTimeoutPeriod
Members
Member name | Value | Description
BusTimeoutPeriodDisabled | 0 | Bus Timeout Period: Disabled
TToSMBusIsSupportedWithin25MsTo35Ms | 1 | t_to(SMBus) Is Supported Within 25 ms to 35 ms
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeCapabilityEventShutdownAction Enumeration

IRD

Se97bTypeCapabilityEventShutdownAction Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityEventShutdownAction
Public Enumeration TypeCapabilityEventShutdownAction
public enum class TypeCapabilityEventShutdownAction
type TypeCapabilityEventShutdownAction
Members
Member name | Value | Description
WhenEnteringShutdownEventOutputFreezesInCurrentState | 0 | When Entering Shutdown: Event Output Freezes In Current State
WhenEnteringShutdownEventOutputIsDeAsserted | 1 | When Entering Shutdown: Event Output Is De-Asserted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeCapabilityHigherAccuracy Enumeration

IRD

Se97bTypeCapabilityHigherAccuracy Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityHigherAccuracy
Public Enumeration TypeCapabilityHigherAccuracy
public enum class TypeCapabilityHigherAccuracy
type TypeCapabilityHigherAccuracy
Members
Member name | Value | Description
HigherAccuracyDisable | 0 | Higher Accuracy: Disable
BGradeAccuracy | 1 | B Grade Accuracy
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeCapabilityHighVoltageStandoff Enumeration

IRD

Se97bTypeCapabilityHighVoltageStandoff Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityHighVoltageStandoff
Public Enumeration TypeCapabilityHighVoltageStandoff
public enum class TypeCapabilityHighVoltageStandoff
type TypeCapabilityHighVoltageStandoff
Members
Member name | Value | Description
HighVoltageStandoffPinA0Disable | 0 | High Voltage Standoff Pin A0: Disable
HighVoltageStandoffPinA0EnableSupportsVoltageUpTo10V | 1 | High Voltage Standoff Pin A0: Enable (Supports Voltage Up To 10V)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeCapabilityTemperatureResolution Enumeration

IRD

Se97bTypeCapabilityTemperatureResolution Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityTemperatureResolution
Public Enumeration TypeCapabilityTemperatureResolution
public enum class TypeCapabilityTemperatureResolution
type TypeCapabilityTemperatureResolution
Members
Member name | Value | Description
Resolution0125C11Bit | 2 | Resolution 0.125 °C (11 Bit)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeCapabilityWideRange Enumeration

IRD

Se97bTypeCapabilityWideRange Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityWideRange
Public Enumeration TypeCapabilityWideRange
public enum class TypeCapabilityWideRange
type TypeCapabilityWideRange
Members
Member name | Value | Description
WideRangeDisable | 0 | Wide Range: Disable
ReadTemperatureBelow0CAndSetSignBit | 1 | Read Temperature Below 0 °C And Set Sign Bit
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeConfigurationAlarmWindowLock Enumeration

IRD

Se97bTypeConfigurationAlarmWindowLock Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationAlarmWindowLock
Public Enumeration TypeConfigurationAlarmWindowLock
public enum class TypeConfigurationAlarmWindowLock
type TypeConfigurationAlarmWindowLock
Members
Member name | Value | Description
UpperAndLowerAlarmTripRegisterNotLockedCanBeAltered | 0 | Upper And Lower Alarm Trip Register: Not Locked, Can Be Altered
UpperAndLowerAlarmTripRegisterCannotBeAltered | 1 | Upper And Lower Alarm Trip Register: Cannot Be Altered
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeConfigurationClearEvent Enumeration

IRD

Se97bTypeConfigurationClearEvent Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationClearEvent
Public Enumeration TypeConfigurationClearEvent
public enum class TypeConfigurationClearEvent
type TypeConfigurationClearEvent
Members
Member name | Value | Description
NoEffect | 0 | No Effect
ClearActiveEventInInterruptMode | 1 | Clear Active Event In Interrupt Mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeConfigurationCriticalEventOnly Enumeration

IRD

Se97bTypeConfigurationCriticalEventOnly Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationCriticalEventOnly
Public Enumeration TypeConfigurationCriticalEventOnly
public enum class TypeConfigurationCriticalEventOnly
type TypeConfigurationCriticalEventOnly
Members
Member name | Value | Description
EventOutputOnAlarmOrCriticalTemperature | 0 | Event Output On Alarm Or Critical Temperature
EventOnlyIfTemperatureIsAboveValueInCriticalTempRegister | 1 | Event Only If Temperature Is Above Value in Critical Temp Register
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeConfigurationCriticalTripLock Enumeration

IRD

Se97bTypeConfigurationCriticalTripLock Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationCriticalTripLock
Public Enumeration TypeConfigurationCriticalTripLock
public enum class TypeConfigurationCriticalTripLock
type TypeConfigurationCriticalTripLock
Members
Member name | Value | Description
CriticalAlarmTripRegisterNotLockedCanBeAltered | 0 | Critical Alarm Trip Register: Not Locked, Can Be Altered
CriticalAlarmTripRegisterCannotBeAltered | 1 | Critical Alarm Trip Register: Cannot Be Altered
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeConfigurationEventMode Enumeration

IRD

Se97bTypeConfigurationEventMode Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationEventMode
Public Enumeration TypeConfigurationEventMode
public enum class TypeConfigurationEventMode
type TypeConfigurationEventMode
Members
Member name | Value | Description
ComparatorOutputMode | 0 | Comparator Output Mode
InterruptMode | 1 | Interrupt Mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeConfigurationEventOutputControl Enumeration

IRD

Se97bTypeConfigurationEventOutputControl Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationEventOutputControl
Public Enumeration TypeConfigurationEventOutputControl
public enum class TypeConfigurationEventOutputControl
type TypeConfigurationEventOutputControl
Members
Member name | Value | Description
EventOutputDisable | 0 | Event Output: Disable
EventOutputEnable | 1 | Event Output: Enable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeConfigurationEventPolarity Enumeration

IRD

Se97bTypeConfigurationEventPolarity Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationEventPolarity
Public Enumeration TypeConfigurationEventPolarity
public enum class TypeConfigurationEventPolarity
type TypeConfigurationEventPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active: Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeConfigurationEventStatus Enumeration

IRD

Se97bTypeConfigurationEventStatus Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationEventStatus
Public Enumeration TypeConfigurationEventStatus
public enum class TypeConfigurationEventStatus
type TypeConfigurationEventStatus
Members
Member name | Value | Description
EventOutputConditionIsNotBeeingAsserted | 0 | Event Output Condition Is Not Beeing Asserted
EventOutputPinIsBeeingAsserted | 1 | Event Output Pin Is Beeing Asserted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeConfigurationHysteresisEnable Enumeration

IRD

Se97bTypeConfigurationHysteresisEnable Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationHysteresisEnable
Public Enumeration TypeConfigurationHysteresisEnable
public enum class TypeConfigurationHysteresisEnable
type TypeConfigurationHysteresisEnable
Members
Member name | Value | Description
HysteresisDisable | 0 | Hysteresis: Disable
HysteresisEnableAt15C | 1 | Hysteresis: Enable At 1.5 °C
HysteresisEnableAt3C | 2 | Hysteresis: Enable At 3 °C
HysteresisEnableAt6C | 3 | Hysteresis: Enable At 6 °C
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeConfigurationShutdownMode Enumeration

IRD

Se97bTypeConfigurationShutdownMode Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationShutdownMode
Public Enumeration TypeConfigurationShutdownMode
public enum class TypeConfigurationShutdownMode
type TypeConfigurationShutdownMode
Members
Member name | Value | Description
TemperatureSensorEnable | 0 | Temperature Sensor: Enable
TemperatureSensorDisable | 1 | Temperature Sensor: Disable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeSmbusAlertResponseAddress Enumeration

IRD

Se97bTypeSmbusAlertResponseAddress Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSmbusAlertResponseAddress
Public Enumeration TypeSmbusAlertResponseAddress
public enum class TypeSmbusAlertResponseAddress
type TypeSmbusAlertResponseAddress
Members
Member name | Value | Description
SMBusAlertResponseAddressEnable | 0 | SM-Bus Alert Response Address: Enable
SMBusAlertResponseAddressDisable | 1 | SM-Bus Alert Response Address: Disable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeSmbusEventSleepState Enumeration

IRD

Se97bTypeSmbusEventSleepState Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSmbusEventSleepState
Public Enumeration TypeSmbusEventSleepState
public enum class TypeSmbusEventSleepState
type TypeSmbusEventSleepState
Members
Member name | Value | Description
EventPinStateIsFrozen | 0 | Event Pin State Is Frozen
EventPinIsDeAssertedStateBasedOnPolarityBit | 1 | Event Pin Is De-Asserted, State Based On Polarity Bit
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeSmbusFlagUpdateMode Enumeration

IRD

Se97bTypeSmbusFlagUpdateMode Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSmbusFlagUpdateMode
Public Enumeration TypeSmbusFlagUpdateMode
public enum class TypeSmbusFlagUpdateMode
type TypeSmbusFlagUpdateMode
Members
Member name | Value | Description
UpdateAAWBAWACTFlagsContinuously | 0 | Update AAW,BAW, ACT Flags: Continuously
UpdateAAWBAWACTFlagsWithNewTemperatureConversion | 1 | Update AAW,BAW, ACT Flags: With New Temperature Conversion
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeSmbusInterruptFlopClearingMode Enumeration

IRD

Se97bTypeSmbusInterruptFlopClearingMode Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSmbusInterruptFlopClearingMode
Public Enumeration TypeSmbusInterruptFlopClearingMode
public enum class TypeSmbusInterruptFlopClearingMode
type TypeSmbusInterruptFlopClearingMode
Members
Member name | Value | Description
ClearingInterruptFlowWhileInComparatorModeAllowed | 0 | Clearing Interrupt Flow While In Comparator Mode: Allowed
ClearingInterruptFlowWhileInComparatorModeDisabled | 1 | Clearing Interrupt Flow While In Comparator Mode: Disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeSmbusTimeout Enumeration

IRD

Se97bTypeSmbusTimeout Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSmbusTimeout
Public Enumeration TypeSmbusTimeout
public enum class TypeSmbusTimeout
type TypeSmbusTimeout
Members
Member name | Value | Description
SMBusTimeoutEnabled | 0 | SM-Bus Timeout: Enabled
SMBusTimeoutDisabled | 1 | SM-Bus Timeout: Disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeSmbusTimeoutDuringShutdown Enumeration

IRD

Se97bTypeSmbusTimeoutDuringShutdown Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSmbusTimeoutDuringShutdown
Public Enumeration TypeSmbusTimeoutDuringShutdown
public enum class TypeSmbusTimeoutDuringShutdown
type TypeSmbusTimeoutDuringShutdown
Members
Member name | Value | Description
SMBusTimeoutDuringShutdownDisabled | 0 | SM-Bus Timeout During Shutdown: Disabled
SMBusTimeoutDuringShutdownEnabled | 1 | SM-Bus Timeout During Shutdown: Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeTemperatureAboveAlarmWindow Enumeration

IRD

Se97bTypeTemperatureAboveAlarmWindow Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTemperatureAboveAlarmWindow
Public Enumeration TypeTemperatureAboveAlarmWindow
public enum class TypeTemperatureAboveAlarmWindow
type TypeTemperatureAboveAlarmWindow
Members
Member name | Value | Description
IncreasingTambTtripUDecreasingTambTtripUThys | 0 | Increasing: Tamb < Ttrip(u) / Decreasing: Tamb < Ttrip(u) - Thys
IncreasingTambTtripUDecreasingTambTtripUThys__1 | 1 | Increasing: Tamb >= Ttrip(u) / Decreasing: Tamb >= Ttrip(u) - Thys
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeTemperatureAboveCriticalTrip Enumeration

IRD

Se97bTypeTemperatureAboveCriticalTrip Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTemperatureAboveCriticalTrip
Public Enumeration TypeTemperatureAboveCriticalTrip
public enum class TypeTemperatureAboveCriticalTrip
type TypeTemperatureAboveCriticalTrip
Members
Member name | Value | Description
IncreasingTambTthCritDecreasingTambTthCritThys | 0 | Increasing: Tamb < Tth(crit) / Decreasing: Tamb < Tth(crit) - Thys
IncreasingTambTthCritDecreasingTambTthCritThys__1 | 1 | Increasing:Tamb >= Tth(crit) / Decreasing: Tamb >= Tth(crit) - Thys
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se97b.TypeTemperatureBelowAlarmWindow Enumeration

IRD

Se97bTypeTemperatureBelowAlarmWindow Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTemperatureBelowAlarmWindow
Public Enumeration TypeTemperatureBelowAlarmWindow
public enum class TypeTemperatureBelowAlarmWindow
type TypeTemperatureBelowAlarmWindow
Members
Member name | Value | Description
IncreasingTambTtripIDecreasingTambTtripIThys | 0 | Increasing: Tamb < Ttrip(i) / Decreasing: Tamb < Ttrip(i) - Thys
IncreasingTambTtripIDecreasingTambTtripIThys__1 | 1 | Increasing: Tamb >= Ttrip(i) / Decreasing: Tamb >= Ttrip(i) - Thys
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a Class

NXP Semiconductors: SE 98A
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsSe98a

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Se98a
Public Class Se98a
public ref class Se98a
type Se98a =  class end

The Se98a type exposes the following members.

Constructors
 | Name | Description
Public method | Se98a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CapabilityBCAP | Capability: BCAP
Public property | CapabilityHACC | Capability: HACC
Public property | CapabilityTRES | Capability: TRES
Public property | CapabilityVHV | Capability: VHV
Public property | CapabilityWRNG | Capability: WRNG
Public property | ConfigurationAWLB | Configuration: AWLB
Public property | ConfigurationCEVNT | Configuration: CEVNT
Public property | ConfigurationCTLB | Configuration: CTLB
Public property | ConfigurationCVO | Configuration: CVO
Public property | ConfigurationEMD | Configuration: EMD
Public property | ConfigurationEOCTL | Configuration: EOCTL
Public property | ConfigurationEP | Configuration: EP
Public property | ConfigurationESTAT | Configuration:: ESTAT
Public property | ConfigurationHEN | Configuration: HEN
Public property | ConfigurationSHMD | Configuration: SHMD
Public property | CriticalAlarmTripCT | Critical Alarm Trip: CT (unit: ° C)
Public property | DeviceID | Device ID
Public property | LowerBoundaryAlarmTripLBT | Lower Boundary Alarm Trip: LBT (unit: ° C)
Public property | ManufacturerID | Manufacturer ID
Public property | SMBusSALRT | SM Bus: SALRT
Public property | SMBusSTMOUT | SM Bus: STMOUT
Public property | TemperatureAAW | Temperature: AAW
Public property | TemperatureACT | Temperature: ACT
Public property | TemperatureBAW | Temperature: BAW
Public property | TemperatureTEMP | Temperature: TEMP (unit: ° C)
Public property | UpperBoundaryAlarmTripUBT | Upper Boundary Alarm Trip: UBT (unit: ° C)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
DDR Memory Module Temperature Sensor
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Se98a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Se98a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a Properties

The Se98a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CapabilityBCAP | Capability: BCAP
Public property | CapabilityHACC | Capability: HACC
Public property | CapabilityTRES | Capability: TRES
Public property | CapabilityVHV | Capability: VHV
Public property | CapabilityWRNG | Capability: WRNG
Public property | ConfigurationAWLB | Configuration: AWLB
Public property | ConfigurationCEVNT | Configuration: CEVNT
Public property | ConfigurationCTLB | Configuration: CTLB
Public property | ConfigurationCVO | Configuration: CVO
Public property | ConfigurationEMD | Configuration: EMD
Public property | ConfigurationEOCTL | Configuration: EOCTL
Public property | ConfigurationEP | Configuration: EP
Public property | ConfigurationESTAT | Configuration:: ESTAT
Public property | ConfigurationHEN | Configuration: HEN
Public property | ConfigurationSHMD | Configuration: SHMD
Public property | CriticalAlarmTripCT | Critical Alarm Trip: CT (unit: ° C)
Public property | DeviceID | Device ID
Public property | LowerBoundaryAlarmTripLBT | Lower Boundary Alarm Trip: LBT (unit: ° C)
Public property | ManufacturerID | Manufacturer ID
Public property | SMBusSALRT | SM Bus: SALRT
Public property | SMBusSTMOUT | SM Bus: STMOUT
Public property | TemperatureAAW | Temperature: AAW
Public property | TemperatureACT | Temperature: ACT
Public property | TemperatureBAW | Temperature: BAW
Public property | TemperatureTEMP | Temperature: TEMP (unit: ° C)
Public property | UpperBoundaryAlarmTripUBT | Upper Boundary Alarm Trip: UBT (unit: ° C)
Top
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.AutoFlush Property

IRD

Se98aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.CapabilityBCAP Property

IRD

Se98aCapabilityBCAP Property

Capability: BCAP

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeCapabilityBasicCapability CapabilityBCAP { get; }
Public ReadOnly Property CapabilityBCAP As Se98aTypeCapabilityBasicCapability
    Get
public:
property Se98aTypeCapabilityBasicCapability CapabilityBCAP {
    Se98aTypeCapabilityBasicCapability get ();
}
member CapabilityBCAP : Se98aTypeCapabilityBasicCapability with get

Property Value

Type: Se98aTypeCapabilityBasicCapability
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.CapabilityHACC Property

IRD

Se98aCapabilityHACC Property

Capability: HACC

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeCapabilityHigherAccuracy CapabilityHACC { get; }
Public ReadOnly Property CapabilityHACC As Se98aTypeCapabilityHigherAccuracy
    Get
public:
property Se98aTypeCapabilityHigherAccuracy CapabilityHACC {
    Se98aTypeCapabilityHigherAccuracy get ();
}
member CapabilityHACC : Se98aTypeCapabilityHigherAccuracy with get

Property Value

Type: Se98aTypeCapabilityHigherAccuracy
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.CapabilityTRES Property

IRD

Se98aCapabilityTRES Property

Capability: TRES

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeCapabilityTemperatureResolution CapabilityTRES { get; }
Public ReadOnly Property CapabilityTRES As Se98aTypeCapabilityTemperatureResolution
    Get
public:
property Se98aTypeCapabilityTemperatureResolution CapabilityTRES {
    Se98aTypeCapabilityTemperatureResolution get ();
}
member CapabilityTRES : Se98aTypeCapabilityTemperatureResolution with get

Property Value

Type: Se98aTypeCapabilityTemperatureResolution
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.CapabilityVHV Property

IRD

Se98aCapabilityVHV Property

Capability: VHV

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeCapabilityHighVoltageStandoff CapabilityVHV { get; }
Public ReadOnly Property CapabilityVHV As Se98aTypeCapabilityHighVoltageStandoff
    Get
public:
property Se98aTypeCapabilityHighVoltageStandoff CapabilityVHV {
    Se98aTypeCapabilityHighVoltageStandoff get ();
}
member CapabilityVHV : Se98aTypeCapabilityHighVoltageStandoff with get

Property Value

Type: Se98aTypeCapabilityHighVoltageStandoff
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.CapabilityWRNG Property

IRD

Se98aCapabilityWRNG Property

Capability: WRNG

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeCapabilityWideRange CapabilityWRNG { get; }
Public ReadOnly Property CapabilityWRNG As Se98aTypeCapabilityWideRange
    Get
public:
property Se98aTypeCapabilityWideRange CapabilityWRNG {
    Se98aTypeCapabilityWideRange get ();
}
member CapabilityWRNG : Se98aTypeCapabilityWideRange with get

Property Value

Type: Se98aTypeCapabilityWideRange
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.ConfigurationAWLB Property

IRD

Se98aConfigurationAWLB Property

Configuration: AWLB

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeConfigurationAlarmWindowLock ConfigurationAWLB { get; set; }
Public Property ConfigurationAWLB As Se98aTypeConfigurationAlarmWindowLock
    Get
    Set
public:
property Se98aTypeConfigurationAlarmWindowLock ConfigurationAWLB {
    Se98aTypeConfigurationAlarmWindowLock get ();
    void set (Se98aTypeConfigurationAlarmWindowLock value);
}
member ConfigurationAWLB : Se98aTypeConfigurationAlarmWindowLock with get, set

Property Value

Type: Se98aTypeConfigurationAlarmWindowLock
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.ConfigurationCEVNT Property

IRD

Se98aConfigurationCEVNT Property

Configuration: CEVNT

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeConfigurationClearEvent ConfigurationCEVNT { set; }
Public WriteOnly Property ConfigurationCEVNT As Se98aTypeConfigurationClearEvent
    Set
public:
property Se98aTypeConfigurationClearEvent ConfigurationCEVNT {
    void set (Se98aTypeConfigurationClearEvent value);
}
member ConfigurationCEVNT : Se98aTypeConfigurationClearEvent with set

Property Value

Type: Se98aTypeConfigurationClearEvent
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.ConfigurationCTLB Property

IRD

Se98aConfigurationCTLB Property

Configuration: CTLB

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeConfigurationCriticalTripLock ConfigurationCTLB { get; set; }
Public Property ConfigurationCTLB As Se98aTypeConfigurationCriticalTripLock
    Get
    Set
public:
property Se98aTypeConfigurationCriticalTripLock ConfigurationCTLB {
    Se98aTypeConfigurationCriticalTripLock get ();
    void set (Se98aTypeConfigurationCriticalTripLock value);
}
member ConfigurationCTLB : Se98aTypeConfigurationCriticalTripLock with get, set

Property Value

Type: Se98aTypeConfigurationCriticalTripLock
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.ConfigurationCVO Property

IRD

Se98aConfigurationCVO Property

Configuration: CVO

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeConfigurationCriticalEventOnly ConfigurationCVO { get; set; }
Public Property ConfigurationCVO As Se98aTypeConfigurationCriticalEventOnly
    Get
    Set
public:
property Se98aTypeConfigurationCriticalEventOnly ConfigurationCVO {
    Se98aTypeConfigurationCriticalEventOnly get ();
    void set (Se98aTypeConfigurationCriticalEventOnly value);
}
member ConfigurationCVO : Se98aTypeConfigurationCriticalEventOnly with get, set

Property Value

Type: Se98aTypeConfigurationCriticalEventOnly
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.ConfigurationEMD Property

IRD

Se98aConfigurationEMD Property

Configuration: EMD

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeConfigurationEventMode ConfigurationEMD { get; set; }
Public Property ConfigurationEMD As Se98aTypeConfigurationEventMode
    Get
    Set
public:
property Se98aTypeConfigurationEventMode ConfigurationEMD {
    Se98aTypeConfigurationEventMode get ();
    void set (Se98aTypeConfigurationEventMode value);
}
member ConfigurationEMD : Se98aTypeConfigurationEventMode with get, set

Property Value

Type: Se98aTypeConfigurationEventMode
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.ConfigurationEOCTL Property

IRD

Se98aConfigurationEOCTL Property

Configuration: EOCTL

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeConfigurationEventOutputControl ConfigurationEOCTL { get; set; }
Public Property ConfigurationEOCTL As Se98aTypeConfigurationEventOutputControl
    Get
    Set
public:
property Se98aTypeConfigurationEventOutputControl ConfigurationEOCTL {
    Se98aTypeConfigurationEventOutputControl get ();
    void set (Se98aTypeConfigurationEventOutputControl value);
}
member ConfigurationEOCTL : Se98aTypeConfigurationEventOutputControl with get, set

Property Value

Type: Se98aTypeConfigurationEventOutputControl
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.ConfigurationEP Property

IRD

Se98aConfigurationEP Property

Configuration: EP

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeConfigurationEventPolarity ConfigurationEP { get; set; }
Public Property ConfigurationEP As Se98aTypeConfigurationEventPolarity
    Get
    Set
public:
property Se98aTypeConfigurationEventPolarity ConfigurationEP {
    Se98aTypeConfigurationEventPolarity get ();
    void set (Se98aTypeConfigurationEventPolarity value);
}
member ConfigurationEP : Se98aTypeConfigurationEventPolarity with get, set

Property Value

Type: Se98aTypeConfigurationEventPolarity
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.ConfigurationESTAT Property

IRD

Se98aConfigurationESTAT Property

Configuration:: ESTAT

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeConfigurationEventStatus ConfigurationESTAT { get; }
Public ReadOnly Property ConfigurationESTAT As Se98aTypeConfigurationEventStatus
    Get
public:
property Se98aTypeConfigurationEventStatus ConfigurationESTAT {
    Se98aTypeConfigurationEventStatus get ();
}
member ConfigurationESTAT : Se98aTypeConfigurationEventStatus with get

Property Value

Type: Se98aTypeConfigurationEventStatus
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.ConfigurationHEN Property

IRD

Se98aConfigurationHEN Property

Configuration: HEN

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeConfigurationHysteresisEnable ConfigurationHEN { get; set; }
Public Property ConfigurationHEN As Se98aTypeConfigurationHysteresisEnable
    Get
    Set
public:
property Se98aTypeConfigurationHysteresisEnable ConfigurationHEN {
    Se98aTypeConfigurationHysteresisEnable get ();
    void set (Se98aTypeConfigurationHysteresisEnable value);
}
member ConfigurationHEN : Se98aTypeConfigurationHysteresisEnable with get, set

Property Value

Type: Se98aTypeConfigurationHysteresisEnable
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.ConfigurationSHMD Property

IRD

Se98aConfigurationSHMD Property

Configuration: SHMD

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeConfigurationShutdownMode ConfigurationSHMD { get; set; }
Public Property ConfigurationSHMD As Se98aTypeConfigurationShutdownMode
    Get
    Set
public:
property Se98aTypeConfigurationShutdownMode ConfigurationSHMD {
    Se98aTypeConfigurationShutdownMode get ();
    void set (Se98aTypeConfigurationShutdownMode value);
}
member ConfigurationSHMD : Se98aTypeConfigurationShutdownMode with get, set

Property Value

Type: Se98aTypeConfigurationShutdownMode
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.CriticalAlarmTripCT Property

IRD

Se98aCriticalAlarmTripCT Property

Critical Alarm Trip: CT (unit: ° C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double CriticalAlarmTripCT { get; set; }
Public Property CriticalAlarmTripCT As Double
    Get
    Set
public:
property double CriticalAlarmTripCT {
    double get ();
    void set (double value);
}
member CriticalAlarmTripCT : float with get, set

Property Value

Type: Double
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.DeviceID Property

IRD

Se98aDeviceID Property

Device ID

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DeviceID { get; }
Public ReadOnly Property DeviceID As UShort
    Get
public:
property unsigned short DeviceID {
    unsigned short get ();
}
member DeviceID : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.LowerBoundaryAlarmTripLBT Property

IRD

Se98aLowerBoundaryAlarmTripLBT Property

Lower Boundary Alarm Trip: LBT (unit: ° C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LowerBoundaryAlarmTripLBT { get; set; }
Public Property LowerBoundaryAlarmTripLBT As Double
    Get
    Set
public:
property double LowerBoundaryAlarmTripLBT {
    double get ();
    void set (double value);
}
member LowerBoundaryAlarmTripLBT : float with get, set

Property Value

Type: Double
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.ManufacturerID Property

IRD

Se98aManufacturerID Property

Manufacturer ID

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ManufacturerID { get; }
Public ReadOnly Property ManufacturerID As UShort
    Get
public:
property unsigned short ManufacturerID {
    unsigned short get ();
}
member ManufacturerID : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.SMBusSALRT Property

IRD

Se98aSMBusSALRT Property

SM Bus: SALRT

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeSmbusAlert SMBusSALRT { get; set; }
Public Property SMBusSALRT As Se98aTypeSmbusAlert
    Get
    Set
public:
property Se98aTypeSmbusAlert SMBusSALRT {
    Se98aTypeSmbusAlert get ();
    void set (Se98aTypeSmbusAlert value);
}
member SMBusSALRT : Se98aTypeSmbusAlert with get, set

Property Value

Type: Se98aTypeSmbusAlert
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.SMBusSTMOUT Property

IRD

Se98aSMBusSTMOUT Property

SM Bus: STMOUT

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeSmbusTimeout SMBusSTMOUT { get; set; }
Public Property SMBusSTMOUT As Se98aTypeSmbusTimeout
    Get
    Set
public:
property Se98aTypeSmbusTimeout SMBusSTMOUT {
    Se98aTypeSmbusTimeout get ();
    void set (Se98aTypeSmbusTimeout value);
}
member SMBusSTMOUT : Se98aTypeSmbusTimeout with get, set

Property Value

Type: Se98aTypeSmbusTimeout
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.TemperatureAAW Property

IRD

Se98aTemperatureAAW Property

Temperature: AAW

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeTemperatureAboveAlarmWindow TemperatureAAW { get; }
Public ReadOnly Property TemperatureAAW As Se98aTypeTemperatureAboveAlarmWindow
    Get
public:
property Se98aTypeTemperatureAboveAlarmWindow TemperatureAAW {
    Se98aTypeTemperatureAboveAlarmWindow get ();
}
member TemperatureAAW : Se98aTypeTemperatureAboveAlarmWindow with get

Property Value

Type: Se98aTypeTemperatureAboveAlarmWindow
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.TemperatureACT Property

IRD

Se98aTemperatureACT Property

Temperature: ACT

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeTemperatureAboveCriticalTrip TemperatureACT { get; }
Public ReadOnly Property TemperatureACT As Se98aTypeTemperatureAboveCriticalTrip
    Get
public:
property Se98aTypeTemperatureAboveCriticalTrip TemperatureACT {
    Se98aTypeTemperatureAboveCriticalTrip get ();
}
member TemperatureACT : Se98aTypeTemperatureAboveCriticalTrip with get

Property Value

Type: Se98aTypeTemperatureAboveCriticalTrip
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.TemperatureBAW Property

IRD

Se98aTemperatureBAW Property

Temperature: BAW

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Se98aTypeTemperatureBelowAlarmWindow TemperatureBAW { get; }
Public ReadOnly Property TemperatureBAW As Se98aTypeTemperatureBelowAlarmWindow
    Get
public:
property Se98aTypeTemperatureBelowAlarmWindow TemperatureBAW {
    Se98aTypeTemperatureBelowAlarmWindow get ();
}
member TemperatureBAW : Se98aTypeTemperatureBelowAlarmWindow with get

Property Value

Type: Se98aTypeTemperatureBelowAlarmWindow
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.TemperatureTEMP Property

IRD

Se98aTemperatureTEMP Property

Temperature: TEMP (unit: ° C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double TemperatureTEMP { get; }
Public ReadOnly Property TemperatureTEMP As Double
    Get
public:
property double TemperatureTEMP {
    double get ();
}
member TemperatureTEMP : float with get

Property Value

Type: Double
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.UpperBoundaryAlarmTripUBT Property

IRD

Se98aUpperBoundaryAlarmTripUBT Property

Upper Boundary Alarm Trip: UBT (unit: ° C)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double UpperBoundaryAlarmTripUBT { get; set; }
Public Property UpperBoundaryAlarmTripUBT As Double
    Get
    Set
public:
property double UpperBoundaryAlarmTripUBT {
    double get ();
    void set (double value);
}
member UpperBoundaryAlarmTripUBT : float with get, set

Property Value

Type: Double
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a Methods

The Se98a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.Flush Method

IRD

Se98aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Se98a Class
telos.Ird.NXPSemiconductors Namespace


Se98a.TypeCapabilityBasicCapability Enumeration

IRD

Se98aTypeCapabilityBasicCapability Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityBasicCapability
Public Enumeration TypeCapabilityBasicCapability
public enum class TypeCapabilityBasicCapability
type TypeCapabilityBasicCapability
Members
Member name | Value | Description
BasicCapabilityDisable | 0 | Basic Capability: Disable
AlarmAndCriticalTripsInterruptCapability | 1 | Alarm And Critical Trips Interrupt Capability
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeCapabilityHigherAccuracy Enumeration

IRD

Se98aTypeCapabilityHigherAccuracy Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityHigherAccuracy
Public Enumeration TypeCapabilityHigherAccuracy
public enum class TypeCapabilityHigherAccuracy
type TypeCapabilityHigherAccuracy
Members
Member name | Value | Description
HigherAccuracyDisable | 0 | Higher Accuracy: Disable
BGradeAccuracy | 1 | B Grade Accuracy
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeCapabilityHighVoltageStandoff Enumeration

IRD

Se98aTypeCapabilityHighVoltageStandoff Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityHighVoltageStandoff
Public Enumeration TypeCapabilityHighVoltageStandoff
public enum class TypeCapabilityHighVoltageStandoff
type TypeCapabilityHighVoltageStandoff
Members
Member name | Value | Description
HighVoltageStandoffPinA0Disable | 0 | High Voltage Standoff Pin A0: Disable
HighVoltageStandoffPinA0Enable | 1 | High Voltage Standoff Pin A0: Enable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeCapabilityTemperatureResolution Enumeration

IRD

Se98aTypeCapabilityTemperatureResolution Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityTemperatureResolution
Public Enumeration TypeCapabilityTemperatureResolution
public enum class TypeCapabilityTemperatureResolution
type TypeCapabilityTemperatureResolution
Members
Member name | Value | Description
Resolution0125C11Bit | 2 | Resolution 0.125 °C (11 Bit)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeCapabilityWideRange Enumeration

IRD

Se98aTypeCapabilityWideRange Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityWideRange
Public Enumeration TypeCapabilityWideRange
public enum class TypeCapabilityWideRange
type TypeCapabilityWideRange
Members
Member name | Value | Description
WideRangeDisable | 0 | Wide Range: Disable
ReadTemperatureBelow0CAndSetSignBit | 1 | Read Temperature Below 0 °C And Set Sign Bit
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeConfigurationAlarmWindowLock Enumeration

IRD

Se98aTypeConfigurationAlarmWindowLock Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationAlarmWindowLock
Public Enumeration TypeConfigurationAlarmWindowLock
public enum class TypeConfigurationAlarmWindowLock
type TypeConfigurationAlarmWindowLock
Members
Member name | Value | Description
UpperAndLowerAlarmTripRegisterNotLockedCanBeAltered | 0 | Upper And Lower Alarm Trip Register: Not Locked, Can Be Altered
UpperAndLowerAlarmTripRegisterCannotBeAltered | 1 | Upper And Lower Alarm Trip Register: Cannot Be Altered
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeConfigurationClearEvent Enumeration

IRD

Se98aTypeConfigurationClearEvent Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationClearEvent
Public Enumeration TypeConfigurationClearEvent
public enum class TypeConfigurationClearEvent
type TypeConfigurationClearEvent
Members
Member name | Value | Description
NoEffect | 0 | No Effect
ClearActiveEventInInterruptMode | 1 | Clear Active Event In Interrupt Mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeConfigurationCriticalEventOnly Enumeration

IRD

Se98aTypeConfigurationCriticalEventOnly Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationCriticalEventOnly
Public Enumeration TypeConfigurationCriticalEventOnly
public enum class TypeConfigurationCriticalEventOnly
type TypeConfigurationCriticalEventOnly
Members
Member name | Value | Description
EventOutputOnAlarmOrCriticalTemperature | 0 | Event Output On Alarm Or Critical Temperature
EventOnlyIfTemperatureIsAboveValueInCriticalTempRegister | 1 | Event Only If Temperature Is Above Value in Critical Temp Register
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeConfigurationCriticalTripLock Enumeration

IRD

Se98aTypeConfigurationCriticalTripLock Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationCriticalTripLock
Public Enumeration TypeConfigurationCriticalTripLock
public enum class TypeConfigurationCriticalTripLock
type TypeConfigurationCriticalTripLock
Members
Member name | Value | Description
CriticalAlarmTripRegisterNotLockedCanBeAltered | 0 | Critical Alarm Trip Register: Not Locked, Can Be Altered
CriticalAlarmTripRegisterCannotBeAltered | 1 | Critical Alarm Trip Register: Cannot Be Altered
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeConfigurationEventMode Enumeration

IRD

Se98aTypeConfigurationEventMode Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationEventMode
Public Enumeration TypeConfigurationEventMode
public enum class TypeConfigurationEventMode
type TypeConfigurationEventMode
Members
Member name | Value | Description
ComparatorOutputMode | 0 | Comparator Output Mode
InterruptMode | 1 | Interrupt Mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeConfigurationEventOutputControl Enumeration

IRD

Se98aTypeConfigurationEventOutputControl Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationEventOutputControl
Public Enumeration TypeConfigurationEventOutputControl
public enum class TypeConfigurationEventOutputControl
type TypeConfigurationEventOutputControl
Members
Member name | Value | Description
EventOutputDisable | 0 | Event Output: Disable
EventOutputEnable | 1 | Event Output: Enable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeConfigurationEventPolarity Enumeration

IRD

Se98aTypeConfigurationEventPolarity Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationEventPolarity
Public Enumeration TypeConfigurationEventPolarity
public enum class TypeConfigurationEventPolarity
type TypeConfigurationEventPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active: Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeConfigurationEventStatus Enumeration

IRD

Se98aTypeConfigurationEventStatus Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationEventStatus
Public Enumeration TypeConfigurationEventStatus
public enum class TypeConfigurationEventStatus
type TypeConfigurationEventStatus
Members
Member name | Value | Description
EventOutputConditionIsNotBeeingAsserted | 0 | Event Output Condition Is Not Beeing Asserted
EventOutputPinIsBeeingAsserted | 1 | Event Output Pin Is Beeing Asserted
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeConfigurationHysteresisEnable Enumeration

IRD

Se98aTypeConfigurationHysteresisEnable Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationHysteresisEnable
Public Enumeration TypeConfigurationHysteresisEnable
public enum class TypeConfigurationHysteresisEnable
type TypeConfigurationHysteresisEnable
Members
Member name | Value | Description
HysteresisDisable | 0 | Hysteresis: Disable
HysteresisEnableAt15C | 1 | Hysteresis: Enable At 1.5 °C
HysteresisEnableAt3C | 2 | Hysteresis: Enable At 3 °C
HysteresisEnableAt6C | 3 | Hysteresis: Enable At 6 °C
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeConfigurationShutdownMode Enumeration

IRD

Se98aTypeConfigurationShutdownMode Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigurationShutdownMode
Public Enumeration TypeConfigurationShutdownMode
public enum class TypeConfigurationShutdownMode
type TypeConfigurationShutdownMode
Members
Member name | Value | Description
TemperatureSensorEnable | 0 | Temperature Sensor: Enable
TemperatureSensorDisable | 1 | Temperature Sensor: Disable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeSmbusAlert Enumeration

IRD

Se98aTypeSmbusAlert Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSmbusAlert
Public Enumeration TypeSmbusAlert
public enum class TypeSmbusAlert
type TypeSmbusAlert
Members
Member name | Value | Description
SMBusAlertEnable | 0 | SM-Bus Alert: Enable
SMBusAlertDisable | 1 | SM-Bus alert: Disable
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeSmbusTimeout Enumeration

IRD

Se98aTypeSmbusTimeout Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSmbusTimeout
Public Enumeration TypeSmbusTimeout
public enum class TypeSmbusTimeout
type TypeSmbusTimeout
Members
Member name | Value | Description
SMBusTimeoutEnabled | 0 | SM-Bus Timeout: Enabled
SMBusTimeoutDisabled | 1 | SM-Bus Timeout: Disabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeTemperatureAboveAlarmWindow Enumeration

IRD

Se98aTypeTemperatureAboveAlarmWindow Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTemperatureAboveAlarmWindow
Public Enumeration TypeTemperatureAboveAlarmWindow
public enum class TypeTemperatureAboveAlarmWindow
type TypeTemperatureAboveAlarmWindow
Members
Member name | Value | Description
IncreasingTambTtripUDecreasingTambTtripUThys | 0 | Increasing: Tamb < Ttrip(u) / Decreasing: Tamb < Ttrip(u) - Thys
IncreasingTambTtripUDecreasingTambTtripUThys__1 | 1 | Increasing: Tamb >= Ttrip(u) / Decreasing: Tamb >= Ttrip(u) - Thys
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeTemperatureAboveCriticalTrip Enumeration

IRD

Se98aTypeTemperatureAboveCriticalTrip Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTemperatureAboveCriticalTrip
Public Enumeration TypeTemperatureAboveCriticalTrip
public enum class TypeTemperatureAboveCriticalTrip
type TypeTemperatureAboveCriticalTrip
Members
Member name | Value | Description
IncreasingTambTthCritDecreasingTambTthCritThys | 0 | Increasing: Tamb < Tth(crit) / Decreasing: Tamb < Tth(crit) - Thys
IncreasingTambTthCritDecreasingTambTthCritThys__1 | 1 | Increasing:Tamb >= Tth(crit) / Decreasing: Tamb >= Tth(crit) - Thys
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Se98a.TypeTemperatureBelowAlarmWindow Enumeration

IRD

Se98aTypeTemperatureBelowAlarmWindow Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTemperatureBelowAlarmWindow
Public Enumeration TypeTemperatureBelowAlarmWindow
public enum class TypeTemperatureBelowAlarmWindow
type TypeTemperatureBelowAlarmWindow
Members
Member name | Value | Description
IncreasingTambTtripIDecreasingTambTtripIThys | 0 | Increasing: Tamb < Ttrip(i) / Decreasing: Tamb < Ttrip(i) - Thys
IncreasingTambTtripIDecreasingTambTtripIThys__1 | 1 | Increasing: Tamb >= Ttrip(i) / Decreasing: Tamb >= Ttrip(i) - Thys
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046 Class

NXP Semiconductors: TDA 10046 AHT
Inheritance Hierarchy
SystemObject
telos.Ird.NXPSemiconductorsTda10046

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Tda10046
Public Class Tda10046
public ref class Tda10046
type Tda10046 =  class end

The Tda10046 type exposes the following members.

Constructors
 | Name | Description
Public method | Tda10046 | Constructor
Top
Properties
 | Name | Description
Public property | AGCIFControlCommandAGCIFLEV70 | AGC IF control command (AGCIF_LEV[7:0])
Public property | AGCIFPinZAGCIF10 | AGC_IF pin (Z_AGC_IF[1:0])
Public property | AGCLoopUSEAGCTUN | AGC loop (USE_AGC_TUN)
Public property | AGCThresholdAGCReNormalizationAUTOAGC | AGC threshold/AGC re-normalization (AUTO_AGC)
Public property | AGCTUNERControlCommandAGCIFLEV70 | AGC TUNER control Command (AGCIF_LEV[7:0])
Public property | AGCTUNPinZAGCTUN10 | AGC_TUN pin (Z_AGC_TUN[1:0])
Public property | AllowsThePossibilityToInverseTheLevelOfGPIO0POLAGPIO0 | Allows the possibility to inverse the level of GPIO 0 (POLA_GPIO0)
Public property | AllowsThePossibilityToInverseTheLevelOfGPIO1POLAGPIO1 | Allows the possibility to inverse the level of GPIO 1 (POLA_GPIO1)
Public property | AllowsThePossibilityToInverseTheLevelOfGPIO2POLAGPIO2 | Allows the possibility to inverse the level of GPIO 2 (POLA_GPIO2)
Public property | AllowsThePossibilityToInverseTheLevelOfGPIO3POLAGPIO3 | Allows the possibility to inverse the level of GPIO 3 (POLA_GPIO3)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AutoOffsetAUTOOFFSET | Auto Offset (AUTOOFFSET)
Public property | AverageNoisePowerEstimationOfferingARangeNPOUT70 | Average noise power estimation offering a range (NP_OUT[7:0]) (unit: dB)
Public property | BitErrorRateAtTheViterbiDecoderOutputVBERLUT10 | Bit Error Rate at the Viterbi decoder output (VBER_LUT[1:0])
Public property | BootOfTheDSPBOOTEEP | Boot of the DSP (BOOT_EEP)
Public property | BootOfTheDSPBOOTHOST | Boot of the DSP (BOOT_HOST)
Public property | CBERRefreshedITCBER | CBER refreshed (ITCBER)
Public property | ChannelBitErrorRateCBERLUT40 | Channel Bit Error Rate (CBER_LUT[4:0])
Public property | ClockDividerRatioOfThePLLNI2C40 | Clock divider ratio of the PLL (N_I2C[4:0])
Public property | ClockDividerRatioOfThePLLPI2C0 | Clock divider ratio of the PLL (P_I2C[0])
Public property | ClockMultiplierRatioOfThePLLMI2C70 | Clock multiplier ratio of the PLL (M_I2C[7:0])
Public property | CodeWordCounterForTheDSPApplicationSoftwareBootDSPCPT70 | Code Word Counter for the DSP application software boot (DSPCPT[7:0])
Public property | CodeWordInputForTheDSPApplicationSoftwareBootDSPCODEIN70 | Code word input for the DSP application software boot (DSPCODEIN [7:0])
Public property | CommandSamplingErrorCorrectionAlgorithmWREF250 | Command sampling error correction algorithm (WREF[25:0])
Public property | CommandWordSamplingErrorCorrectionAlgorithmINVWREF110 | Command word sampling error correction algorithm (INV_WREF[11:0])
Public property | ConfigurationParametersDigitalLoopAGCCONF2 | Configuration (parameters digital loop) (AGC_CONF[2])
Public property | ConstellationValueFoundIfAUTOTPS1CONSF10 | Constellation value found (if AUTOTPS=1) (CONS_F[1:0])
Public property | ConsumptionOfTheADCADCCS10 | Consumption of the ADC (ADC_CS[1:0])
Public property | CounterIncrementedDuringTheLockProcessSCANCPT70 | Counter incremented during the lock process (SCAN_CPT[7:0])
Public property | CrystalOrClockPrecisionCRYST100PPM | Crystal or clock precision (CRYST100PPM)
Public property | DecodingOfTheTPSCRCStreamTPSLOCK | Decoding of the TPS CRC stream (TPS_LOCK)
Public property | DESCramblerInhibitionDESCI | DESCrambler inhibition (DESCI)
Public property | DigitalAGCLevelDIGAGC70 | Digital AGC level (DIG_AGC [7:0]) (unit: dB)
Public property | DigitalPLLAtMPEG2OutputInterfaceInhibitionPLLI | Digital PLL at MPEG2 output interface inhibition (PLLI)
Public property | DirectionOfTheMultiPurposeRegisterDSPINTRW | Direction of the Multi-purpose register (DSPINT_RW)
Public property | DivisionFactorOfTheSamplingClockVALDIV60 | Division factor of the sampling clock (VALDIV[6:0])
Public property | DSPReadyDSPREADY | DSP Ready (DSPREADY)
Public property | DVBTNetworksCorrectlySizedENOUTGI | DVB-T networks correctly sized (EN_OUT_GI)
Public property | EnableInterruptCBERRefreshedITSEL4 | Enable interrupt: CBER refreshed (ITSEL[4])
Public property | EnableInterruptDVBTSuperFrameSyncFlagITSEL2 | Enable interrupt: DVB-T super frame sync flag (ITSEL[2])
Public property | EnableInterruptFELGoesHighITSEL0 | Enable interrupt FEL goes high (ITSEL[0])
Public property | EnableInterruptFELGoesLowITSEL1 | Enable interrupt: FEL goes low (ITSEL[1])
Public property | EnableInterruptUncorrectablePacketITSEL5 | Enable interrupt: uncorrectable packet (ITSEL[5])
Public property | EnableInterruptVBERRefreshedITSEL3 | Enable interrupt: VBER refreshed (ITSEL[3])
Public property | EqualizationFilterCHINF8 | Equalization filter (CH_INF[8])
Public property | EqualizerAdaptationDISADAPTFILT | Equalizer adaptation (DIS_ADAPTFILT)
Public property | ErrorCounterUsedInTheViterbiDecoderOutputBitErrorRateMeasurementVBER190 | Error counter used in the Viterbi decoder output bit error rate measurement (VBER[19:0])
Public property | ErrorIndicatorBitInhibitionIEI | Error Indicator bit inhibition (IEI)
Public property | FFTSizeAUTO2K8K | FFT size (AUTO2K8K)
Public property | FFTSizeFoundIfAUTO2K8K1CNF2K8KF | FFT size found (if AUTO2K8K=1) (CNF2K8K_F)
Public property | FFTSizeIfAUTO2K8K0CNF2K8K | FFT size (if AUTO2K8K=0) (CNF2K8K)
Public property | FormatOfThe10BitADCOutputCodeADCMODE | Format of the 10-bit ADC output code (ADC_MODE)
Public property | FrequencyErrorDeltaFFREQERR150 | Frequency error deltaF (FREQERR[15:0]) (unit: Hz)
Public property | FrequencyOffsetOfTheRFSignalAUTOOFFSET0OFFSET20 | Frequency offset of the RF signal (AUTOOFFSET=0) (OFFSET[2:0])
Public property | FrequencyOffsetOfTheRFSignalAUTOOFFSET1OFFSETF20 | Frequency offset of the RF signal (AUTOOFFSET=1) (OFFSET_F[2:0])
Public property | FrequencyRecoveryAlgorithmFREQLOCK | Frequency recovery algorithm (FREQ_LOCK)
Public property | FrontEndLockFEL | Front End Lock (FEL)
Public property | GainOfTheDigitalAGCLoopForTheTunerPartAGCIFGAIN70 | Gain of the digital AGC loop for the tuner part (AGCIF_GAIN[7:0])
Public property | GainOfTheDigitalAGCLoopForTheTunerPartAGCTUNGAIN70 | Gain of the digital AGC loop for the tuner part (AGCTUN_GAIN[7:0])
Public property | GainOfTheInternalTrackHoldCircuitOfADCADCGAINSET | Gain of the internal track/hold circuit of ADC (ADC_GAINSET)
Public property | GPIO0PinDeltaSigmaInputWordSELDS0 | GPIO[0] pin deltaSigma input word (SEL_DS[0])
Public property | GPIO1PinDeltaSigmaInputWordSELDS1 | GPIO[1] pin deltaSigma input word (SEL_DS[1])
Public property | GPIOPin0ZGPIO010 | GPIO pin 0 (Z_GPIO0[1:0])
Public property | GPIOPin1ZGPIO110 | GPIO pin 1 (Z_GPIO1[1:0])
Public property | GPIOPin2ZGPIO210 | GPIO pin 2 (Z_GPIO2[1:0])
Public property | GPIOPin3ZGPIO310 | GPIO pin 3 (Z_GPIO3[1:0])
Public property | GuardIntervalSizeIfAUTOGI0DELTA10 | Guard Interval size (if AUTOGI=0) (DELTA[1:0])
Public property | GuardIntervalSizeValueFoundIfAUTOGI0DELTAF10 | Guard interval size value found (if AUTOGI=0) (DELTA_F[1:0])
Public property | GuardIntervalValueAUTOGI | Guard Interval value (AUTOGI)
Public property | HierarchicalLevelIfAutoTPS0ALPHA10 | Hierarchical level (if AutoTPS=0) (ALPHA[1:0])
Public property | HierarchicalLevelValueIfAutoTPS1ALPHAF10 | Hierarchical level value (if AutoTPS=1) (ALPHA_F[1:0])
Public property | I2CAnalogLevelOutputPinGPIO0Vmax5V33VI2CDS070 | I2C analog level (output pin GPIO[0]) (Vmax=5 V/3.3 V) (I2C_DS0[7:0]) (unit: V)
Public property | I2CDS1 | I2C_DS1 (unit: V)
Public property | I2CDS2 | I2C_DS2 (unit: V)
Public property | I2CDS3 | I2C_DS3 (unit: V)
Public property | I2CEEPBusSpeedEEPSPD10 | I2C EEP bus speed (EEPSPD[1:0]) (unit: kHz)
Public property | IdentifyTheCellFromWhichTheSignalComesFromCELLID150 | Identify the cell from which the signal comes from (CELL_ID[15:0])
Public property | Identity | Identity
Public property | InnerCodeRateOfTheHighPriorityStreamIfAUTOTPS0RH20 | Inner code rate of the high priority stream (if AUTOTPS=0) (RH[2:0])
Public property | InnerCodeRateOfTheHighPriorityStreamIfAutoTPS1RH20 | Inner code rate of the high priority stream (if AutoTPS=1) (RH[2:0])
Public property | InnerCodeRateOfTheLowPriorityStreamIfAUTOTPS0RL20 | Inner code rate of the low priority stream (if AUTOTPS=0) (RL[2:0])
Public property | InnerCodeRateOfTheLowPriorityStreamIfAutoTPS1RL20 | Inner code rate of the low priority stream (if AutoTPS=1) (RL[2:0])
Public property | InputClockOfThePLLFquartzFsampPLLBYP | Input clock of the PLL (Fquartz->Fsamp) (PLL_BYP)
Public property | InputSignalCouplingADCDCIN | Input signal coupling (ADC_DCIN)
Public property | InputSignalUSEADCINT | Input signal (USE_ADC_INT)
Public property | InterruptOccurredCBERRefreshedITSTAT4 | Interrupt occurred: CBER refreshed (ITSTAT[4])
Public property | InterruptOccurredDVBTSuperFrameSyncFlagITSTAT2 | Interrupt occurred: DVB-T super frame sync flag (ITSTAT[2])
Public property | InterruptOccurredFELHighITSTAT0 | Interrupt occurred: FEL high (ITSTAT[0])
Public property | InterruptOccurredFELLowITSTAT1 | Interrupt occurred: FEL low (ITSTAT[1])
Public property | InterruptOccurredUncorrectablePacketITSTAT5 | Interrupt occurred: uncorrectable packet (ITSTAT[5])
Public property | InterruptOccurredVBERRefreshedITSTAT3 | Interrupt occurred: VBER refreshed (ITSTAT[3])
Public property | InverseTheLevelOfTheOfThePinAGCIFPOLAAGCIF | Inverse the level of the of the pin AGC_IF (POLA_AGC_IF)
Public property | InverseTheLevelOfTheOfThePinAGCTUNPinPOLAAGCTUN | Inverse the level of the of the pin AGC_TUN pin (POLA_AGC_TUN)
Public property | InverseTheLevelOfTheSamplingClockPOLASACLK | Inverse the level of the sampling clock (POLA_SACLK)
Public property | ModeForBothParallelAndSerialMPEGTSInterfacesDEGIG | Mode for both parallel and serial MPEG-TS interfaces (DEGIG)
Public property | ModulationIfAutoTPS0CONS10 | Modulation (if AutoTPS=0) (CONS[1:0])
Public property | MPEGTSMPEGTSModesLSBMSBSLSB | MPEG-TS MPEG-TS modes LSB/MSB (S_LSB)
Public property | MPEGTSMPEGTSModesPSYNCActivePSYNCLENGTH | MPEG-TS MPEG-TS modes PSYNC active (PSYNC_LENGTH)
Public property | MPEGTSParallelPinsParallelMPEGTSSerialStreamSBUS | MPEG-TS parallel pins: parallel MPEG-TS/serial stream (S_BUS)
Public property | MPEGTSParallelSerialInterfacesTSONUncor | MPEG-TS parallel/serial interfaces (TS_ON_uncor)
Public property | MultiPurposeAccessRegisterAddressDSPAD150 | Multi-purpose access register address (DSPAD[15:0])
Public property | MultiPurposeDoubleBufferDataRegisterDSPREG150 | Multi-purpose double buffer Data Register (DSPREG[15:0])
Public property | MUXGPIOOutput0OUTSEL0 | MUX_GPIO output0 (OUT_SEL0)
Public property | MUXGPIOOutput1OUTSEL1 | MUX_GPIO output1 (OUT_SEL1)
Public property | MUXGPIOOutput2OUTSEL2 | MUX_GPIO output2 (OUT_SEL2)
Public property | MUXGPIOOutput3OUTSEL3 | MUX_GPIO output3 (OUT_SEL3)
Public property | MUXModeMUXCMD30 | MUX mode (MUX_CMD[3:0])
Public property | NumberOfBitsOfTheSequenceLengthFromWhichTheViterbiOutputBitErrorRateIsComputedPVBER10 | Number of bits of the sequence length from which the Viterbi output Bit Error Rate is computed (PVBER[1:0])
Public property | NumberOfSymbolsInInternalCBERMeasurementCPT150 | Number of symbols in internal CBER measurement (CPT[15:0]) (unit: ms)
Public property | NumberOfUncorrectablePacketsAfterMasterResetCPTU60 | Number of uncorrectable packets , after master reset (CPTU[6:0])
Public property | OCLKSOCLKClocksPresentDuringTheRedundancyBytesREDUNDCLK | OCLK/S_OCLK clocks present during the redundancy bytes (REDUND_CLK)
Public property | OffsetRelativelyToTheSamplingFrequencyFREQOFFSET | Offset relatively to the sampling frequency (FREQ_OFFSET) (unit: MHz)
Public property | OutputClockOfThePLLPLLCLKEN | Output clock of the PLL (PLL_CLK_EN)
Public property | OutputClocksOCLKSOCLKInvertedPOCLK | Output clocks (OCLK/S_OCLK) inverted (POCLK)
Public property | OutputSignalsDENSDENInvertedPDEN | Output signals DEN/S_DEN inverted (PDEN)
Public property | OutputSignalsPSYNCSPSYNCInvertedPPSYNC | Output signals PSYNC/S_PSYNC inverted (PPSYNC)
Public property | OutputSignalsUNCORSUNCORInvertedPUNCOR | Output signals UNCOR/S_UNCOR inverted (PUNCOR)
Public property | ParallelMPEG2TransportStreamSignalsZTSPAR | Parallel MPEG2 Transport Stream signals (Z_TS_PAR)
Public property | ParametersOfTheModulationAUTOTPS | Parameters of the modulation (AUTOTPS)
Public property | PLLIsLockedAfterBeingProgrammedPLLLock | PLL is locked after being programmed (PLL_lock)
Public property | PolarityOfTheMUXClockMUXPOLACLK | Polarity of the MUX clock (MUX_POLA_CLK)
Public property | PowerDownModeADCPWDN | Power Down Mode (ADC_PWDN)
Public property | PowerDownModePLLPWDWN | Power-Down mode (PLL_PWDWN)
Public property | PriorityOfTheDecodedStreamHPLP | Priority of the decoded stream (HP/LP)
Public property | PulseKillerAlgorithmUSEPK | Pulse Killer algorithm (USE_PK)
Public property | RecoveryAlgorithmTIMELOCK | Recovery algorithm (TIME_LOCK)
Public property | ReedSolomonInhibitionRSI | Reed Solomon inhibition (RSI)
Public property | ReNormalizationGainAGCRENORM70 | Re-normalization gain (AGC_RENORM[7:0]) (unit: V)
Public property | ResetDSPToStartItsApplicationSoftwareSTARTLOCK | Reset DSP to start its application software (START_LOCK)
Public property | ResetI2CCounterCLBUNC | Reset I2C counter (CLBUNC)
Public property | ResetOfCountersInternalCBERMeasurementCLBVBER | Reset of counters internal CBER measurement (CLBVBER)
Public property | ResetOfCountersOfInternalVBERMeasurementCLBVBER | Reset of counters of internal VBER measurement (CLBVBER)
Public property | SACLKPinZSACLK | SACLK pin (Z_SACLK)
Public property | SamplingErrorCorrectionAlgorithmTIMERR70 | Sampling error correction algorithm (TIMERR[7:0])
Public property | SCLTUNSDATUNI2CBusConnectionBPI2CTUNEEP | SCL_TUN/SDA_TUN I2C bus connection (BP_I2CTUNEEP)
Public property | SelectsBetweenScanZappingModeZAPSCAN | Selects between scan/zapping mode (ZAP/SCAN)
Public property | SequencingOfProgrammingMonitoringThePLLAUTOPLL | Sequencing of programming/monitoring the PLL (AUTOPLL)
Public property | SerialMPEG2TransportStreamSignalsZTSSER | Serial MPEG2 Transport Stream signals (Z_TS_SER)
Public property | SleepModeADCSLEEP | Sleep mode (ADC_SLEEP)
Public property | SoftResetExceptI2CRegisterCLRI2CN | Soft Reset (except I2C register) (CLR_I2C_N)
Public property | SpectralInversionOnTheInputSpectrumINVQ | Spectral inversion on the input spectrum (INV_Q)
Public property | StandByOrPowerDownModeICSTDBY | Stand-by (or power-down) mode (IC_STDBY)
Public property | StaticFrequencyCorrectionPHY2150 | Static frequency correction (PHY2[15:0])
Public property | StatusOf16BytesOfRedundancyOfTheMPEGTSPacketsDataONRed | Status of 16 bytes of redundancy of the MPEG-TS packets (Data_ON_red)
Public property | SwitchTheDigitalControlOfTheTunerAGCSWITCHTUNIF | Switch the digital control of the tuner AGC (SWITCH_TUN_IF)
Public property | ThresholdOfTheDigitalAGCAGCTHRES70 | Threshold of the digital AGC (AGC_THRES[7:0])
Public property | ThresholdOfTheIFLoopForMaximumAttenuationAtTheIFLevelAGCIFMAX70 | Threshold of the IF loop for maximum attenuation at the IF level (AGCIF_MAX[7:0])
Public property | ThresholdOfTheIFLoopForMaximumAttenuationAtTheTunerLevelAGCTUNMAX70 | Threshold of the 'IF' loop for maximum attenuation at the tuner level (AGCTUN_MAX[7:0])
Public property | ThresholdOfTheIFLoopForMinimumAttenuationAtTheIFLevelAGCIFMIN70 | Threshold of the IF loop for minimum attenuation at the IF level (AGCIF_MIN[7:0])
Public property | ThresholdOfTheIFLoopForMinimumAttenuationAtTheTunerLevelAGCTUNMIN70 | Threshold of the 'IF' loop for minimum attenuation at the tuner level (AGCTUN_MIN[7:0])
Public property | TPSInformationForTheEvenDVBTFramesEXTTPSEVEN50 | TPS information for the even DVB-T frames (EXTTPS_EVEN[5:0])
Public property | TPSInformationForTheOddDVBTFramesEXTTPSODD50 | TPS information for the odd DVB-T frames (EXTTPS_ODD[5:0])
Public property | TPSInformationUsedToProvideTheTPSLengthIndicatorTPSLENGTH50 | TPS information used to provide the TPS length indicator (TPS_LENGTH[5:0])
Public property | ValueGPIO0PinGPIOIN0 | Value GPIO[0] pin (GPIO_IN[0])
Public property | ValueGPIO1PinGPIOIN1 | Value GPIO[1] pin (GPIO_IN[1])
Public property | ValueGPIO2PinGPIOIN2 | Value GPIO[2] pin (GPIO_IN[2])
Public property | ValueGPIO3PinGPIOIN3 | Value GPIO[3] pin (GPIO_IN[3])
Public property | VBERRefreshedITVBER | VBER refreshed (ITVBER)
Public property | WatchdogTimerDSPWD | Watchdog Timer (DSP_WD)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Single chip channel receiver for 2K and 8K COFDM modulated signals
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046 Constructor

Constructor

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Tda10046(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Tda10046

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046 Properties

The Tda10046 type exposes the following members.

Properties
 | Name | Description
Public property | AGCIFControlCommandAGCIFLEV70 | AGC IF control command (AGCIF_LEV[7:0])
Public property | AGCIFPinZAGCIF10 | AGC_IF pin (Z_AGC_IF[1:0])
Public property | AGCLoopUSEAGCTUN | AGC loop (USE_AGC_TUN)
Public property | AGCThresholdAGCReNormalizationAUTOAGC | AGC threshold/AGC re-normalization (AUTO_AGC)
Public property | AGCTUNERControlCommandAGCIFLEV70 | AGC TUNER control Command (AGCIF_LEV[7:0])
Public property | AGCTUNPinZAGCTUN10 | AGC_TUN pin (Z_AGC_TUN[1:0])
Public property | AllowsThePossibilityToInverseTheLevelOfGPIO0POLAGPIO0 | Allows the possibility to inverse the level of GPIO 0 (POLA_GPIO0)
Public property | AllowsThePossibilityToInverseTheLevelOfGPIO1POLAGPIO1 | Allows the possibility to inverse the level of GPIO 1 (POLA_GPIO1)
Public property | AllowsThePossibilityToInverseTheLevelOfGPIO2POLAGPIO2 | Allows the possibility to inverse the level of GPIO 2 (POLA_GPIO2)
Public property | AllowsThePossibilityToInverseTheLevelOfGPIO3POLAGPIO3 | Allows the possibility to inverse the level of GPIO 3 (POLA_GPIO3)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AutoOffsetAUTOOFFSET | Auto Offset (AUTOOFFSET)
Public property | AverageNoisePowerEstimationOfferingARangeNPOUT70 | Average noise power estimation offering a range (NP_OUT[7:0]) (unit: dB)
Public property | BitErrorRateAtTheViterbiDecoderOutputVBERLUT10 | Bit Error Rate at the Viterbi decoder output (VBER_LUT[1:0])
Public property | BootOfTheDSPBOOTEEP | Boot of the DSP (BOOT_EEP)
Public property | BootOfTheDSPBOOTHOST | Boot of the DSP (BOOT_HOST)
Public property | CBERRefreshedITCBER | CBER refreshed (ITCBER)
Public property | ChannelBitErrorRateCBERLUT40 | Channel Bit Error Rate (CBER_LUT[4:0])
Public property | ClockDividerRatioOfThePLLNI2C40 | Clock divider ratio of the PLL (N_I2C[4:0])
Public property | ClockDividerRatioOfThePLLPI2C0 | Clock divider ratio of the PLL (P_I2C[0])
Public property | ClockMultiplierRatioOfThePLLMI2C70 | Clock multiplier ratio of the PLL (M_I2C[7:0])
Public property | CodeWordCounterForTheDSPApplicationSoftwareBootDSPCPT70 | Code Word Counter for the DSP application software boot (DSPCPT[7:0])
Public property | CodeWordInputForTheDSPApplicationSoftwareBootDSPCODEIN70 | Code word input for the DSP application software boot (DSPCODEIN [7:0])
Public property | CommandSamplingErrorCorrectionAlgorithmWREF250 | Command sampling error correction algorithm (WREF[25:0])
Public property | CommandWordSamplingErrorCorrectionAlgorithmINVWREF110 | Command word sampling error correction algorithm (INV_WREF[11:0])
Public property | ConfigurationParametersDigitalLoopAGCCONF2 | Configuration (parameters digital loop) (AGC_CONF[2])
Public property | ConstellationValueFoundIfAUTOTPS1CONSF10 | Constellation value found (if AUTOTPS=1) (CONS_F[1:0])
Public property | ConsumptionOfTheADCADCCS10 | Consumption of the ADC (ADC_CS[1:0])
Public property | CounterIncrementedDuringTheLockProcessSCANCPT70 | Counter incremented during the lock process (SCAN_CPT[7:0])
Public property | CrystalOrClockPrecisionCRYST100PPM | Crystal or clock precision (CRYST100PPM)
Public property | DecodingOfTheTPSCRCStreamTPSLOCK | Decoding of the TPS CRC stream (TPS_LOCK)
Public property | DESCramblerInhibitionDESCI | DESCrambler inhibition (DESCI)
Public property | DigitalAGCLevelDIGAGC70 | Digital AGC level (DIG_AGC [7:0]) (unit: dB)
Public property | DigitalPLLAtMPEG2OutputInterfaceInhibitionPLLI | Digital PLL at MPEG2 output interface inhibition (PLLI)
Public property | DirectionOfTheMultiPurposeRegisterDSPINTRW | Direction of the Multi-purpose register (DSPINT_RW)
Public property | DivisionFactorOfTheSamplingClockVALDIV60 | Division factor of the sampling clock (VALDIV[6:0])
Public property | DSPReadyDSPREADY | DSP Ready (DSPREADY)
Public property | DVBTNetworksCorrectlySizedENOUTGI | DVB-T networks correctly sized (EN_OUT_GI)
Public property | EnableInterruptCBERRefreshedITSEL4 | Enable interrupt: CBER refreshed (ITSEL[4])
Public property | EnableInterruptDVBTSuperFrameSyncFlagITSEL2 | Enable interrupt: DVB-T super frame sync flag (ITSEL[2])
Public property | EnableInterruptFELGoesHighITSEL0 | Enable interrupt FEL goes high (ITSEL[0])
Public property | EnableInterruptFELGoesLowITSEL1 | Enable interrupt: FEL goes low (ITSEL[1])
Public property | EnableInterruptUncorrectablePacketITSEL5 | Enable interrupt: uncorrectable packet (ITSEL[5])
Public property | EnableInterruptVBERRefreshedITSEL3 | Enable interrupt: VBER refreshed (ITSEL[3])
Public property | EqualizationFilterCHINF8 | Equalization filter (CH_INF[8])
Public property | EqualizerAdaptationDISADAPTFILT | Equalizer adaptation (DIS_ADAPTFILT)
Public property | ErrorCounterUsedInTheViterbiDecoderOutputBitErrorRateMeasurementVBER190 | Error counter used in the Viterbi decoder output bit error rate measurement (VBER[19:0])
Public property | ErrorIndicatorBitInhibitionIEI | Error Indicator bit inhibition (IEI)
Public property | FFTSizeAUTO2K8K | FFT size (AUTO2K8K)
Public property | FFTSizeFoundIfAUTO2K8K1CNF2K8KF | FFT size found (if AUTO2K8K=1) (CNF2K8K_F)
Public property | FFTSizeIfAUTO2K8K0CNF2K8K | FFT size (if AUTO2K8K=0) (CNF2K8K)
Public property | FormatOfThe10BitADCOutputCodeADCMODE | Format of the 10-bit ADC output code (ADC_MODE)
Public property | FrequencyErrorDeltaFFREQERR150 | Frequency error deltaF (FREQERR[15:0]) (unit: Hz)
Public property | FrequencyOffsetOfTheRFSignalAUTOOFFSET0OFFSET20 | Frequency offset of the RF signal (AUTOOFFSET=0) (OFFSET[2:0])
Public property | FrequencyOffsetOfTheRFSignalAUTOOFFSET1OFFSETF20 | Frequency offset of the RF signal (AUTOOFFSET=1) (OFFSET_F[2:0])
Public property | FrequencyRecoveryAlgorithmFREQLOCK | Frequency recovery algorithm (FREQ_LOCK)
Public property | FrontEndLockFEL | Front End Lock (FEL)
Public property | GainOfTheDigitalAGCLoopForTheTunerPartAGCIFGAIN70 | Gain of the digital AGC loop for the tuner part (AGCIF_GAIN[7:0])
Public property | GainOfTheDigitalAGCLoopForTheTunerPartAGCTUNGAIN70 | Gain of the digital AGC loop for the tuner part (AGCTUN_GAIN[7:0])
Public property | GainOfTheInternalTrackHoldCircuitOfADCADCGAINSET | Gain of the internal track/hold circuit of ADC (ADC_GAINSET)
Public property | GPIO0PinDeltaSigmaInputWordSELDS0 | GPIO[0] pin deltaSigma input word (SEL_DS[0])
Public property | GPIO1PinDeltaSigmaInputWordSELDS1 | GPIO[1] pin deltaSigma input word (SEL_DS[1])
Public property | GPIOPin0ZGPIO010 | GPIO pin 0 (Z_GPIO0[1:0])
Public property | GPIOPin1ZGPIO110 | GPIO pin 1 (Z_GPIO1[1:0])
Public property | GPIOPin2ZGPIO210 | GPIO pin 2 (Z_GPIO2[1:0])
Public property | GPIOPin3ZGPIO310 | GPIO pin 3 (Z_GPIO3[1:0])
Public property | GuardIntervalSizeIfAUTOGI0DELTA10 | Guard Interval size (if AUTOGI=0) (DELTA[1:0])
Public property | GuardIntervalSizeValueFoundIfAUTOGI0DELTAF10 | Guard interval size value found (if AUTOGI=0) (DELTA_F[1:0])
Public property | GuardIntervalValueAUTOGI | Guard Interval value (AUTOGI)
Public property | HierarchicalLevelIfAutoTPS0ALPHA10 | Hierarchical level (if AutoTPS=0) (ALPHA[1:0])
Public property | HierarchicalLevelValueIfAutoTPS1ALPHAF10 | Hierarchical level value (if AutoTPS=1) (ALPHA_F[1:0])
Public property | I2CAnalogLevelOutputPinGPIO0Vmax5V33VI2CDS070 | I2C analog level (output pin GPIO[0]) (Vmax=5 V/3.3 V) (I2C_DS0[7:0]) (unit: V)
Public property | I2CDS1 | I2C_DS1 (unit: V)
Public property | I2CDS2 | I2C_DS2 (unit: V)
Public property | I2CDS3 | I2C_DS3 (unit: V)
Public property | I2CEEPBusSpeedEEPSPD10 | I2C EEP bus speed (EEPSPD[1:0]) (unit: kHz)
Public property | IdentifyTheCellFromWhichTheSignalComesFromCELLID150 | Identify the cell from which the signal comes from (CELL_ID[15:0])
Public property | Identity | Identity
Public property | InnerCodeRateOfTheHighPriorityStreamIfAUTOTPS0RH20 | Inner code rate of the high priority stream (if AUTOTPS=0) (RH[2:0])
Public property | InnerCodeRateOfTheHighPriorityStreamIfAutoTPS1RH20 | Inner code rate of the high priority stream (if AutoTPS=1) (RH[2:0])
Public property | InnerCodeRateOfTheLowPriorityStreamIfAUTOTPS0RL20 | Inner code rate of the low priority stream (if AUTOTPS=0) (RL[2:0])
Public property | InnerCodeRateOfTheLowPriorityStreamIfAutoTPS1RL20 | Inner code rate of the low priority stream (if AutoTPS=1) (RL[2:0])
Public property | InputClockOfThePLLFquartzFsampPLLBYP | Input clock of the PLL (Fquartz->Fsamp) (PLL_BYP)
Public property | InputSignalCouplingADCDCIN | Input signal coupling (ADC_DCIN)
Public property | InputSignalUSEADCINT | Input signal (USE_ADC_INT)
Public property | InterruptOccurredCBERRefreshedITSTAT4 | Interrupt occurred: CBER refreshed (ITSTAT[4])
Public property | InterruptOccurredDVBTSuperFrameSyncFlagITSTAT2 | Interrupt occurred: DVB-T super frame sync flag (ITSTAT[2])
Public property | InterruptOccurredFELHighITSTAT0 | Interrupt occurred: FEL high (ITSTAT[0])
Public property | InterruptOccurredFELLowITSTAT1 | Interrupt occurred: FEL low (ITSTAT[1])
Public property | InterruptOccurredUncorrectablePacketITSTAT5 | Interrupt occurred: uncorrectable packet (ITSTAT[5])
Public property | InterruptOccurredVBERRefreshedITSTAT3 | Interrupt occurred: VBER refreshed (ITSTAT[3])
Public property | InverseTheLevelOfTheOfThePinAGCIFPOLAAGCIF | Inverse the level of the of the pin AGC_IF (POLA_AGC_IF)
Public property | InverseTheLevelOfTheOfThePinAGCTUNPinPOLAAGCTUN | Inverse the level of the of the pin AGC_TUN pin (POLA_AGC_TUN)
Public property | InverseTheLevelOfTheSamplingClockPOLASACLK | Inverse the level of the sampling clock (POLA_SACLK)
Public property | ModeForBothParallelAndSerialMPEGTSInterfacesDEGIG | Mode for both parallel and serial MPEG-TS interfaces (DEGIG)
Public property | ModulationIfAutoTPS0CONS10 | Modulation (if AutoTPS=0) (CONS[1:0])
Public property | MPEGTSMPEGTSModesLSBMSBSLSB | MPEG-TS MPEG-TS modes LSB/MSB (S_LSB)
Public property | MPEGTSMPEGTSModesPSYNCActivePSYNCLENGTH | MPEG-TS MPEG-TS modes PSYNC active (PSYNC_LENGTH)
Public property | MPEGTSParallelPinsParallelMPEGTSSerialStreamSBUS | MPEG-TS parallel pins: parallel MPEG-TS/serial stream (S_BUS)
Public property | MPEGTSParallelSerialInterfacesTSONUncor | MPEG-TS parallel/serial interfaces (TS_ON_uncor)
Public property | MultiPurposeAccessRegisterAddressDSPAD150 | Multi-purpose access register address (DSPAD[15:0])
Public property | MultiPurposeDoubleBufferDataRegisterDSPREG150 | Multi-purpose double buffer Data Register (DSPREG[15:0])
Public property | MUXGPIOOutput0OUTSEL0 | MUX_GPIO output0 (OUT_SEL0)
Public property | MUXGPIOOutput1OUTSEL1 | MUX_GPIO output1 (OUT_SEL1)
Public property | MUXGPIOOutput2OUTSEL2 | MUX_GPIO output2 (OUT_SEL2)
Public property | MUXGPIOOutput3OUTSEL3 | MUX_GPIO output3 (OUT_SEL3)
Public property | MUXModeMUXCMD30 | MUX mode (MUX_CMD[3:0])
Public property | NumberOfBitsOfTheSequenceLengthFromWhichTheViterbiOutputBitErrorRateIsComputedPVBER10 | Number of bits of the sequence length from which the Viterbi output Bit Error Rate is computed (PVBER[1:0])
Public property | NumberOfSymbolsInInternalCBERMeasurementCPT150 | Number of symbols in internal CBER measurement (CPT[15:0]) (unit: ms)
Public property | NumberOfUncorrectablePacketsAfterMasterResetCPTU60 | Number of uncorrectable packets , after master reset (CPTU[6:0])
Public property | OCLKSOCLKClocksPresentDuringTheRedundancyBytesREDUNDCLK | OCLK/S_OCLK clocks present during the redundancy bytes (REDUND_CLK)
Public property | OffsetRelativelyToTheSamplingFrequencyFREQOFFSET | Offset relatively to the sampling frequency (FREQ_OFFSET) (unit: MHz)
Public property | OutputClockOfThePLLPLLCLKEN | Output clock of the PLL (PLL_CLK_EN)
Public property | OutputClocksOCLKSOCLKInvertedPOCLK | Output clocks (OCLK/S_OCLK) inverted (POCLK)
Public property | OutputSignalsDENSDENInvertedPDEN | Output signals DEN/S_DEN inverted (PDEN)
Public property | OutputSignalsPSYNCSPSYNCInvertedPPSYNC | Output signals PSYNC/S_PSYNC inverted (PPSYNC)
Public property | OutputSignalsUNCORSUNCORInvertedPUNCOR | Output signals UNCOR/S_UNCOR inverted (PUNCOR)
Public property | ParallelMPEG2TransportStreamSignalsZTSPAR | Parallel MPEG2 Transport Stream signals (Z_TS_PAR)
Public property | ParametersOfTheModulationAUTOTPS | Parameters of the modulation (AUTOTPS)
Public property | PLLIsLockedAfterBeingProgrammedPLLLock | PLL is locked after being programmed (PLL_lock)
Public property | PolarityOfTheMUXClockMUXPOLACLK | Polarity of the MUX clock (MUX_POLA_CLK)
Public property | PowerDownModeADCPWDN | Power Down Mode (ADC_PWDN)
Public property | PowerDownModePLLPWDWN | Power-Down mode (PLL_PWDWN)
Public property | PriorityOfTheDecodedStreamHPLP | Priority of the decoded stream (HP/LP)
Public property | PulseKillerAlgorithmUSEPK | Pulse Killer algorithm (USE_PK)
Public property | RecoveryAlgorithmTIMELOCK | Recovery algorithm (TIME_LOCK)
Public property | ReedSolomonInhibitionRSI | Reed Solomon inhibition (RSI)
Public property | ReNormalizationGainAGCRENORM70 | Re-normalization gain (AGC_RENORM[7:0]) (unit: V)
Public property | ResetDSPToStartItsApplicationSoftwareSTARTLOCK | Reset DSP to start its application software (START_LOCK)
Public property | ResetI2CCounterCLBUNC | Reset I2C counter (CLBUNC)
Public property | ResetOfCountersInternalCBERMeasurementCLBVBER | Reset of counters internal CBER measurement (CLBVBER)
Public property | ResetOfCountersOfInternalVBERMeasurementCLBVBER | Reset of counters of internal VBER measurement (CLBVBER)
Public property | SACLKPinZSACLK | SACLK pin (Z_SACLK)
Public property | SamplingErrorCorrectionAlgorithmTIMERR70 | Sampling error correction algorithm (TIMERR[7:0])
Public property | SCLTUNSDATUNI2CBusConnectionBPI2CTUNEEP | SCL_TUN/SDA_TUN I2C bus connection (BP_I2CTUNEEP)
Public property | SelectsBetweenScanZappingModeZAPSCAN | Selects between scan/zapping mode (ZAP/SCAN)
Public property | SequencingOfProgrammingMonitoringThePLLAUTOPLL | Sequencing of programming/monitoring the PLL (AUTOPLL)
Public property | SerialMPEG2TransportStreamSignalsZTSSER | Serial MPEG2 Transport Stream signals (Z_TS_SER)
Public property | SleepModeADCSLEEP | Sleep mode (ADC_SLEEP)
Public property | SoftResetExceptI2CRegisterCLRI2CN | Soft Reset (except I2C register) (CLR_I2C_N)
Public property | SpectralInversionOnTheInputSpectrumINVQ | Spectral inversion on the input spectrum (INV_Q)
Public property | StandByOrPowerDownModeICSTDBY | Stand-by (or power-down) mode (IC_STDBY)
Public property | StaticFrequencyCorrectionPHY2150 | Static frequency correction (PHY2[15:0])
Public property | StatusOf16BytesOfRedundancyOfTheMPEGTSPacketsDataONRed | Status of 16 bytes of redundancy of the MPEG-TS packets (Data_ON_red)
Public property | SwitchTheDigitalControlOfTheTunerAGCSWITCHTUNIF | Switch the digital control of the tuner AGC (SWITCH_TUN_IF)
Public property | ThresholdOfTheDigitalAGCAGCTHRES70 | Threshold of the digital AGC (AGC_THRES[7:0])
Public property | ThresholdOfTheIFLoopForMaximumAttenuationAtTheIFLevelAGCIFMAX70 | Threshold of the IF loop for maximum attenuation at the IF level (AGCIF_MAX[7:0])
Public property | ThresholdOfTheIFLoopForMaximumAttenuationAtTheTunerLevelAGCTUNMAX70 | Threshold of the 'IF' loop for maximum attenuation at the tuner level (AGCTUN_MAX[7:0])
Public property | ThresholdOfTheIFLoopForMinimumAttenuationAtTheIFLevelAGCIFMIN70 | Threshold of the IF loop for minimum attenuation at the IF level (AGCIF_MIN[7:0])
Public property | ThresholdOfTheIFLoopForMinimumAttenuationAtTheTunerLevelAGCTUNMIN70 | Threshold of the 'IF' loop for minimum attenuation at the tuner level (AGCTUN_MIN[7:0])
Public property | TPSInformationForTheEvenDVBTFramesEXTTPSEVEN50 | TPS information for the even DVB-T frames (EXTTPS_EVEN[5:0])
Public property | TPSInformationForTheOddDVBTFramesEXTTPSODD50 | TPS information for the odd DVB-T frames (EXTTPS_ODD[5:0])
Public property | TPSInformationUsedToProvideTheTPSLengthIndicatorTPSLENGTH50 | TPS information used to provide the TPS length indicator (TPS_LENGTH[5:0])
Public property | ValueGPIO0PinGPIOIN0 | Value GPIO[0] pin (GPIO_IN[0])
Public property | ValueGPIO1PinGPIOIN1 | Value GPIO[1] pin (GPIO_IN[1])
Public property | ValueGPIO2PinGPIOIN2 | Value GPIO[2] pin (GPIO_IN[2])
Public property | ValueGPIO3PinGPIOIN3 | Value GPIO[3] pin (GPIO_IN[3])
Public property | VBERRefreshedITVBER | VBER refreshed (ITVBER)
Public property | WatchdogTimerDSPWD | Watchdog Timer (DSP_WD)
Top
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.AGCIFControlCommandAGCIFLEV70 Property

IRD

Tda10046AGCIFControlCommandAGCIFLEV70 Property

AGC IF control command (AGCIF_LEV[7:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDMINMAXSIGNALATTENUATION AGCIFControlCommandAGCIFLEV70 { get; }
Public ReadOnly Property AGCIFControlCommandAGCIFLEV70 As Tda10046TYPIDMINMAXSIGNALATTENUATION
    Get
public:
property Tda10046TYPIDMINMAXSIGNALATTENUATION AGCIFControlCommandAGCIFLEV70 {
    Tda10046TYPIDMINMAXSIGNALATTENUATION get ();
}
member AGCIFControlCommandAGCIFLEV70 : Tda10046TYPIDMINMAXSIGNALATTENUATION with get

Property Value

Type: Tda10046TYPIDMINMAXSIGNALATTENUATION
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.AGCIFPinZAGCIF10 Property

IRD

Tda10046AGCIFPinZAGCIF10 Property

AGC_IF pin (Z_AGC_IF[1:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE11 AGCIFPinZAGCIF10 { set; }
Public WriteOnly Property AGCIFPinZAGCIF10 As Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE11
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE11 AGCIFPinZAGCIF10 {
    void set (Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE11 value);
}
member AGCIFPinZAGCIF10 : Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE11 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE11
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.AGCLoopUSEAGCTUN Property

IRD

Tda10046AGCLoopUSEAGCTUN Property

AGC loop (USE_AGC_TUN)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF2 AGCLoopUSEAGCTUN { set; }
Public WriteOnly Property AGCLoopUSEAGCTUN As Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF2
    Set
public:
property Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF2 AGCLoopUSEAGCTUN {
    void set (Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF2 value);
}
member AGCLoopUSEAGCTUN : Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF2 with set

Property Value

Type: Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF2
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.AGCThresholdAGCReNormalizationAUTOAGC Property

IRD

Tda10046AGCThresholdAGCReNormalizationAUTOAGC Property

AGC threshold/AGC re-normalization (AUTO_AGC)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF1 AGCThresholdAGCReNormalizationAUTOAGC { set; }
Public WriteOnly Property AGCThresholdAGCReNormalizationAUTOAGC As Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF1
    Set
public:
property Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF1 AGCThresholdAGCReNormalizationAUTOAGC {
    void set (Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF1 value);
}
member AGCThresholdAGCReNormalizationAUTOAGC : Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF1 with set

Property Value

Type: Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF1
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.AGCTUNERControlCommandAGCIFLEV70 Property

IRD

Tda10046AGCTUNERControlCommandAGCIFLEV70 Property

AGC TUNER control Command (AGCIF_LEV[7:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDMINMAXSIGNALATTENUATION AGCTUNERControlCommandAGCIFLEV70 { get; }
Public ReadOnly Property AGCTUNERControlCommandAGCIFLEV70 As Tda10046TYPIDMINMAXSIGNALATTENUATION
    Get
public:
property Tda10046TYPIDMINMAXSIGNALATTENUATION AGCTUNERControlCommandAGCIFLEV70 {
    Tda10046TYPIDMINMAXSIGNALATTENUATION get ();
}
member AGCTUNERControlCommandAGCIFLEV70 : Tda10046TYPIDMINMAXSIGNALATTENUATION with get

Property Value

Type: Tda10046TYPIDMINMAXSIGNALATTENUATION
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.AGCTUNPinZAGCTUN10 Property

IRD

Tda10046AGCTUNPinZAGCTUN10 Property

AGC_TUN pin (Z_AGC_TUN[1:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE11 AGCTUNPinZAGCTUN10 { set; }
Public WriteOnly Property AGCTUNPinZAGCTUN10 As Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE11
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE11 AGCTUNPinZAGCTUN10 {
    void set (Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE11 value);
}
member AGCTUNPinZAGCTUN10 : Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE11 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE11
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.AllowsThePossibilityToInverseTheLevelOfGPIO0POLAGPIO0 Property

IRD

Tda10046AllowsThePossibilityToInverseTheLevelOfGPIO0POLAGPIO0 Property

Allows the possibility to inverse the level of GPIO 0 (POLA_GPIO0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 AllowsThePossibilityToInverseTheLevelOfGPIO0POLAGPIO0 { set; }
Public WriteOnly Property AllowsThePossibilityToInverseTheLevelOfGPIO0POLAGPIO0 As Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0
    Set
public:
property Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 AllowsThePossibilityToInverseTheLevelOfGPIO0POLAGPIO0 {
    void set (Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 value);
}
member AllowsThePossibilityToInverseTheLevelOfGPIO0POLAGPIO0 : Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.AllowsThePossibilityToInverseTheLevelOfGPIO1POLAGPIO1 Property

IRD

Tda10046AllowsThePossibilityToInverseTheLevelOfGPIO1POLAGPIO1 Property

Allows the possibility to inverse the level of GPIO 1 (POLA_GPIO1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 AllowsThePossibilityToInverseTheLevelOfGPIO1POLAGPIO1 { set; }
Public WriteOnly Property AllowsThePossibilityToInverseTheLevelOfGPIO1POLAGPIO1 As Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0
    Set
public:
property Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 AllowsThePossibilityToInverseTheLevelOfGPIO1POLAGPIO1 {
    void set (Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 value);
}
member AllowsThePossibilityToInverseTheLevelOfGPIO1POLAGPIO1 : Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.AllowsThePossibilityToInverseTheLevelOfGPIO2POLAGPIO2 Property

IRD

Tda10046AllowsThePossibilityToInverseTheLevelOfGPIO2POLAGPIO2 Property

Allows the possibility to inverse the level of GPIO 2 (POLA_GPIO2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 AllowsThePossibilityToInverseTheLevelOfGPIO2POLAGPIO2 { set; }
Public WriteOnly Property AllowsThePossibilityToInverseTheLevelOfGPIO2POLAGPIO2 As Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0
    Set
public:
property Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 AllowsThePossibilityToInverseTheLevelOfGPIO2POLAGPIO2 {
    void set (Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 value);
}
member AllowsThePossibilityToInverseTheLevelOfGPIO2POLAGPIO2 : Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.AllowsThePossibilityToInverseTheLevelOfGPIO3POLAGPIO3 Property

IRD

Tda10046AllowsThePossibilityToInverseTheLevelOfGPIO3POLAGPIO3 Property

Allows the possibility to inverse the level of GPIO 3 (POLA_GPIO3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 AllowsThePossibilityToInverseTheLevelOfGPIO3POLAGPIO3 { set; }
Public WriteOnly Property AllowsThePossibilityToInverseTheLevelOfGPIO3POLAGPIO3 As Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0
    Set
public:
property Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 AllowsThePossibilityToInverseTheLevelOfGPIO3POLAGPIO3 {
    void set (Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 value);
}
member AllowsThePossibilityToInverseTheLevelOfGPIO3POLAGPIO3 : Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.AutoFlush Property

IRD

Tda10046AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.AutoOffsetAUTOOFFSET Property

IRD

Tda10046AutoOffsetAUTOOFFSET Property

Auto Offset (AUTOOFFSET)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDAUTOMATICLOCKAUTO4 AutoOffsetAUTOOFFSET { set; }
Public WriteOnly Property AutoOffsetAUTOOFFSET As Tda10046TYPIDAUTOMATICLOCKAUTO4
    Set
public:
property Tda10046TYPIDAUTOMATICLOCKAUTO4 AutoOffsetAUTOOFFSET {
    void set (Tda10046TYPIDAUTOMATICLOCKAUTO4 value);
}
member AutoOffsetAUTOOFFSET : Tda10046TYPIDAUTOMATICLOCKAUTO4 with set

Property Value

Type: Tda10046TYPIDAUTOMATICLOCKAUTO4
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.AverageNoisePowerEstimationOfferingARangeNPOUT70 Property

IRD

Tda10046AverageNoisePowerEstimationOfferingARangeNPOUT70 Property

Average noise power estimation offering a range (NP_OUT[7:0]) (unit: dB)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDNOISEPOWERESTIMMATIONNPOUT0 AverageNoisePowerEstimationOfferingARangeNPOUT70 { get; }
Public ReadOnly Property AverageNoisePowerEstimationOfferingARangeNPOUT70 As Tda10046TYPIDNOISEPOWERESTIMMATIONNPOUT0
    Get
public:
property Tda10046TYPIDNOISEPOWERESTIMMATIONNPOUT0 AverageNoisePowerEstimationOfferingARangeNPOUT70 {
    Tda10046TYPIDNOISEPOWERESTIMMATIONNPOUT0 get ();
}
member AverageNoisePowerEstimationOfferingARangeNPOUT70 : Tda10046TYPIDNOISEPOWERESTIMMATIONNPOUT0 with get

Property Value

Type: Tda10046TYPIDNOISEPOWERESTIMMATIONNPOUT0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.BitErrorRateAtTheViterbiDecoderOutputVBERLUT10 Property

IRD

Tda10046BitErrorRateAtTheViterbiDecoderOutputVBERLUT10 Property

Bit Error Rate at the Viterbi decoder output (VBER_LUT[1:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCHANNELBITERRORPUTCVBERLUT1 BitErrorRateAtTheViterbiDecoderOutputVBERLUT10 { get; }
Public ReadOnly Property BitErrorRateAtTheViterbiDecoderOutputVBERLUT10 As Tda10046TYPIDCHANNELBITERRORPUTCVBERLUT1
    Get
public:
property Tda10046TYPIDCHANNELBITERRORPUTCVBERLUT1 BitErrorRateAtTheViterbiDecoderOutputVBERLUT10 {
    Tda10046TYPIDCHANNELBITERRORPUTCVBERLUT1 get ();
}
member BitErrorRateAtTheViterbiDecoderOutputVBERLUT10 : Tda10046TYPIDCHANNELBITERRORPUTCVBERLUT1 with get

Property Value

Type: Tda10046TYPIDCHANNELBITERRORPUTCVBERLUT1
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.BootOfTheDSPBOOTEEP Property

IRD

Tda10046BootOfTheDSPBOOTEEP Property

Boot of the DSP (BOOT_EEP)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDBYPASSIFINTERNAONS3CONFC42 BootOfTheDSPBOOTEEP { set; }
Public WriteOnly Property BootOfTheDSPBOOTEEP As Tda10046TYPIDBYPASSIFINTERNAONS3CONFC42
    Set
public:
property Tda10046TYPIDBYPASSIFINTERNAONS3CONFC42 BootOfTheDSPBOOTEEP {
    void set (Tda10046TYPIDBYPASSIFINTERNAONS3CONFC42 value);
}
member BootOfTheDSPBOOTEEP : Tda10046TYPIDBYPASSIFINTERNAONS3CONFC42 with set

Property Value

Type: Tda10046TYPIDBYPASSIFINTERNAONS3CONFC42
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.BootOfTheDSPBOOTHOST Property

IRD

Tda10046BootOfTheDSPBOOTHOST Property

Boot of the DSP (BOOT_HOST)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDBYPASSIFINTERNAONS3CONFC42 BootOfTheDSPBOOTHOST { set; }
Public WriteOnly Property BootOfTheDSPBOOTHOST As Tda10046TYPIDBYPASSIFINTERNAONS3CONFC42
    Set
public:
property Tda10046TYPIDBYPASSIFINTERNAONS3CONFC42 BootOfTheDSPBOOTHOST {
    void set (Tda10046TYPIDBYPASSIFINTERNAONS3CONFC42 value);
}
member BootOfTheDSPBOOTHOST : Tda10046TYPIDBYPASSIFINTERNAONS3CONFC42 with set

Property Value

Type: Tda10046TYPIDBYPASSIFINTERNAONS3CONFC42
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.CBERRefreshedITCBER Property

IRD

Tda10046CBERRefreshedITCBER Property

CBER refreshed (ITCBER)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCHANNELBITERROROLCVBERCTRL0 CBERRefreshedITCBER { get; set; }
Public Property CBERRefreshedITCBER As Tda10046TYPIDCHANNELBITERROROLCVBERCTRL0
    Get
    Set
public:
property Tda10046TYPIDCHANNELBITERROROLCVBERCTRL0 CBERRefreshedITCBER {
    Tda10046TYPIDCHANNELBITERROROLCVBERCTRL0 get ();
    void set (Tda10046TYPIDCHANNELBITERROROLCVBERCTRL0 value);
}
member CBERRefreshedITCBER : Tda10046TYPIDCHANNELBITERROROLCVBERCTRL0 with get, set

Property Value

Type: Tda10046TYPIDCHANNELBITERROROLCVBERCTRL0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ChannelBitErrorRateCBERLUT40 Property

IRD

Tda10046ChannelBitErrorRateCBERLUT40 Property

Channel Bit Error Rate (CBER_LUT[4:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCHANNELBITERRORPUTCVBERLUT0 ChannelBitErrorRateCBERLUT40 { get; }
Public ReadOnly Property ChannelBitErrorRateCBERLUT40 As Tda10046TYPIDCHANNELBITERRORPUTCVBERLUT0
    Get
public:
property Tda10046TYPIDCHANNELBITERRORPUTCVBERLUT0 ChannelBitErrorRateCBERLUT40 {
    Tda10046TYPIDCHANNELBITERRORPUTCVBERLUT0 get ();
}
member ChannelBitErrorRateCBERLUT40 : Tda10046TYPIDCHANNELBITERRORPUTCVBERLUT0 with get

Property Value

Type: Tda10046TYPIDCHANNELBITERRORPUTCVBERLUT0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ClockDividerRatioOfThePLLNI2C40 Property

IRD

Tda10046ClockDividerRatioOfThePLLNI2C40 Property

Clock divider ratio of the PLL (N_I2C[4:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ClockDividerRatioOfThePLLNI2C40 { set; }
Public WriteOnly Property ClockDividerRatioOfThePLLNI2C40 As Byte
    Set
public:
property unsigned char ClockDividerRatioOfThePLLNI2C40 {
    void set (unsigned char value);
}
member ClockDividerRatioOfThePLLNI2C40 : byte with set

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ClockDividerRatioOfThePLLPI2C0 Property

IRD

Tda10046ClockDividerRatioOfThePLLPI2C0 Property

Clock divider ratio of the PLL (P_I2C[0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ClockDividerRatioOfThePLLPI2C0 { set; }
Public WriteOnly Property ClockDividerRatioOfThePLLPI2C0 As Byte
    Set
public:
property unsigned char ClockDividerRatioOfThePLLPI2C0 {
    void set (unsigned char value);
}
member ClockDividerRatioOfThePLLPI2C0 : byte with set

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ClockMultiplierRatioOfThePLLMI2C70 Property

IRD

Tda10046ClockMultiplierRatioOfThePLLMI2C70 Property

Clock multiplier ratio of the PLL (M_I2C[7:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ClockMultiplierRatioOfThePLLMI2C70 { set; }
Public WriteOnly Property ClockMultiplierRatioOfThePLLMI2C70 As UShort
    Set
public:
property unsigned short ClockMultiplierRatioOfThePLLMI2C70 {
    void set (unsigned short value);
}
member ClockMultiplierRatioOfThePLLMI2C70 : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.CodeWordCounterForTheDSPApplicationSoftwareBootDSPCPT70 Property

IRD

Tda10046CodeWordCounterForTheDSPApplicationSoftwareBootDSPCPT70 Property

Code Word Counter for the DSP application software boot (DSPCPT[7:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CodeWordCounterForTheDSPApplicationSoftwareBootDSPCPT70 { set; }
Public WriteOnly Property CodeWordCounterForTheDSPApplicationSoftwareBootDSPCPT70 As Byte
    Set
public:
property unsigned char CodeWordCounterForTheDSPApplicationSoftwareBootDSPCPT70 {
    void set (unsigned char value);
}
member CodeWordCounterForTheDSPApplicationSoftwareBootDSPCPT70 : byte with set

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.CodeWordInputForTheDSPApplicationSoftwareBootDSPCODEIN70 Property

IRD

Tda10046CodeWordInputForTheDSPApplicationSoftwareBootDSPCODEIN70 Property

Code word input for the DSP application software boot (DSPCODEIN [7:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CodeWordInputForTheDSPApplicationSoftwareBootDSPCODEIN70 { set; }
Public WriteOnly Property CodeWordInputForTheDSPApplicationSoftwareBootDSPCODEIN70 As Byte
    Set
public:
property unsigned char CodeWordInputForTheDSPApplicationSoftwareBootDSPCODEIN70 {
    void set (unsigned char value);
}
member CodeWordInputForTheDSPApplicationSoftwareBootDSPCODEIN70 : byte with set

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.CommandSamplingErrorCorrectionAlgorithmWREF250 Property

IRD

Tda10046CommandSamplingErrorCorrectionAlgorithmWREF250 Property

Command sampling error correction algorithm (WREF[25:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint CommandSamplingErrorCorrectionAlgorithmWREF250 { set; }
Public WriteOnly Property CommandSamplingErrorCorrectionAlgorithmWREF250 As UInteger
    Set
public:
property unsigned int CommandSamplingErrorCorrectionAlgorithmWREF250 {
    void set (unsigned int value);
}
member CommandSamplingErrorCorrectionAlgorithmWREF250 : uint32 with set

Property Value

Type: UInt32
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.CommandWordSamplingErrorCorrectionAlgorithmINVWREF110 Property

IRD

Tda10046CommandWordSamplingErrorCorrectionAlgorithmINVWREF110 Property

Command word sampling error correction algorithm (INV_WREF[11:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort CommandWordSamplingErrorCorrectionAlgorithmINVWREF110 { set; }
Public WriteOnly Property CommandWordSamplingErrorCorrectionAlgorithmINVWREF110 As UShort
    Set
public:
property unsigned short CommandWordSamplingErrorCorrectionAlgorithmINVWREF110 {
    void set (unsigned short value);
}
member CommandWordSamplingErrorCorrectionAlgorithmINVWREF110 : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ConfigurationParametersDigitalLoopAGCCONF2 Property

IRD

Tda10046ConfigurationParametersDigitalLoopAGCCONF2 Property

Configuration (parameters digital loop) (AGC_CONF[2])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF0 ConfigurationParametersDigitalLoopAGCCONF2 { set; }
Public WriteOnly Property ConfigurationParametersDigitalLoopAGCCONF2 As Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF0
    Set
public:
property Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF0 ConfigurationParametersDigitalLoopAGCCONF2 {
    void set (Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF0 value);
}
member ConfigurationParametersDigitalLoopAGCCONF2 : Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF0 with set

Property Value

Type: Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ConstellationValueFoundIfAUTOTPS1CONSF10 Property

IRD

Tda10046ConstellationValueFoundIfAUTOTPS1CONSF10 Property

Constellation value found (if AUTOTPS=1) (CONS_F[1:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINPUTCONFIGURATION1INCONF10 ConstellationValueFoundIfAUTOTPS1CONSF10 { get; }
Public ReadOnly Property ConstellationValueFoundIfAUTOTPS1CONSF10 As Tda10046TYPIDINPUTCONFIGURATION1INCONF10
    Get
public:
property Tda10046TYPIDINPUTCONFIGURATION1INCONF10 ConstellationValueFoundIfAUTOTPS1CONSF10 {
    Tda10046TYPIDINPUTCONFIGURATION1INCONF10 get ();
}
member ConstellationValueFoundIfAUTOTPS1CONSF10 : Tda10046TYPIDINPUTCONFIGURATION1INCONF10 with get

Property Value

Type: Tda10046TYPIDINPUTCONFIGURATION1INCONF10
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ConsumptionOfTheADCADCCS10 Property

IRD

Tda10046ConsumptionOfTheADCADCCS10 Property

Consumption of the ADC (ADC_CS[1:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONADCADCCONFADC2 ConsumptionOfTheADCADCCS10 { set; }
Public WriteOnly Property ConsumptionOfTheADCADCCS10 As Tda10046TYPIDCONFIGURATIONADCADCCONFADC2
    Set
public:
property Tda10046TYPIDCONFIGURATIONADCADCCONFADC2 ConsumptionOfTheADCADCCS10 {
    void set (Tda10046TYPIDCONFIGURATIONADCADCCONFADC2 value);
}
member ConsumptionOfTheADCADCCS10 : Tda10046TYPIDCONFIGURATIONADCADCCONFADC2 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONADCADCCONFADC2
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.CounterIncrementedDuringTheLockProcessSCANCPT70 Property

IRD

Tda10046CounterIncrementedDuringTheLockProcessSCANCPT70 Property

Counter incremented during the lock process (SCAN_CPT[7:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CounterIncrementedDuringTheLockProcessSCANCPT70 { get; }
Public ReadOnly Property CounterIncrementedDuringTheLockProcessSCANCPT70 As Byte
    Get
public:
property unsigned char CounterIncrementedDuringTheLockProcessSCANCPT70 {
    unsigned char get ();
}
member CounterIncrementedDuringTheLockProcessSCANCPT70 : byte with get

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.CrystalOrClockPrecisionCRYST100PPM Property

IRD

Tda10046CrystalOrClockPrecisionCRYST100PPM Property

Crystal or clock precision (CRYST100PPM)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDAUTOMATICLOCKAUTO7 CrystalOrClockPrecisionCRYST100PPM { set; }
Public WriteOnly Property CrystalOrClockPrecisionCRYST100PPM As Tda10046TYPIDAUTOMATICLOCKAUTO7
    Set
public:
property Tda10046TYPIDAUTOMATICLOCKAUTO7 CrystalOrClockPrecisionCRYST100PPM {
    void set (Tda10046TYPIDAUTOMATICLOCKAUTO7 value);
}
member CrystalOrClockPrecisionCRYST100PPM : Tda10046TYPIDAUTOMATICLOCKAUTO7 with set

Property Value

Type: Tda10046TYPIDAUTOMATICLOCKAUTO7
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.DecodingOfTheTPSCRCStreamTPSLOCK Property

IRD

Tda10046DecodingOfTheTPSCRCStreamTPSLOCK Property

Decoding of the TPS CRC stream (TPS_LOCK)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS0 DecodingOfTheTPSCRCStreamTPSLOCK { get; }
Public ReadOnly Property DecodingOfTheTPSCRCStreamTPSLOCK As Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS0
    Get
public:
property Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS0 DecodingOfTheTPSCRCStreamTPSLOCK {
    Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS0 get ();
}
member DecodingOfTheTPSCRCStreamTPSLOCK : Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS0 with get

Property Value

Type: Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.DESCramblerInhibitionDESCI Property

IRD

Tda10046DESCramblerInhibitionDESCI Property

DESCrambler inhibition (DESCI)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C30 DESCramblerInhibitionDESCI { set; }
Public WriteOnly Property DESCramblerInhibitionDESCI As Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C30
    Set
public:
property Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C30 DESCramblerInhibitionDESCI {
    void set (Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C30 value);
}
member DESCramblerInhibitionDESCI : Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C30 with set

Property Value

Type: Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C30
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.DigitalAGCLevelDIGAGC70 Property

IRD

Tda10046DigitalAGCLevelDIGAGC70 Property

Digital AGC level (DIG_AGC [7:0]) (unit: dB)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDDIGITALAGCLEVELDIGAGCLEVEL0 DigitalAGCLevelDIGAGC70 { get; }
Public ReadOnly Property DigitalAGCLevelDIGAGC70 As Tda10046TYPIDDIGITALAGCLEVELDIGAGCLEVEL0
    Get
public:
property Tda10046TYPIDDIGITALAGCLEVELDIGAGCLEVEL0 DigitalAGCLevelDIGAGC70 {
    Tda10046TYPIDDIGITALAGCLEVELDIGAGCLEVEL0 get ();
}
member DigitalAGCLevelDIGAGC70 : Tda10046TYPIDDIGITALAGCLEVELDIGAGCLEVEL0 with get

Property Value

Type: Tda10046TYPIDDIGITALAGCLEVELDIGAGCLEVEL0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.DigitalPLLAtMPEG2OutputInterfaceInhibitionPLLI Property

IRD

Tda10046DigitalPLLAtMPEG2OutputInterfaceInhibitionPLLI Property

Digital PLL at MPEG2 output interface inhibition (PLLI)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10 DigitalPLLAtMPEG2OutputInterfaceInhibitionPLLI { set; }
Public WriteOnly Property DigitalPLLAtMPEG2OutputInterfaceInhibitionPLLI As Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10
    Set
public:
property Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10 DigitalPLLAtMPEG2OutputInterfaceInhibitionPLLI {
    void set (Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10 value);
}
member DigitalPLLAtMPEG2OutputInterfaceInhibitionPLLI : Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10 with set

Property Value

Type: Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.DirectionOfTheMultiPurposeRegisterDSPINTRW Property

IRD

Tda10046DirectionOfTheMultiPurposeRegisterDSPINTRW Property

Direction of the Multi-purpose register (DSPINT_RW)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDBYPASSIFINTERNAONS3CONFC44 DirectionOfTheMultiPurposeRegisterDSPINTRW { set; }
Public WriteOnly Property DirectionOfTheMultiPurposeRegisterDSPINTRW As Tda10046TYPIDBYPASSIFINTERNAONS3CONFC44
    Set
public:
property Tda10046TYPIDBYPASSIFINTERNAONS3CONFC44 DirectionOfTheMultiPurposeRegisterDSPINTRW {
    void set (Tda10046TYPIDBYPASSIFINTERNAONS3CONFC44 value);
}
member DirectionOfTheMultiPurposeRegisterDSPINTRW : Tda10046TYPIDBYPASSIFINTERNAONS3CONFC44 with set

Property Value

Type: Tda10046TYPIDBYPASSIFINTERNAONS3CONFC44
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.DivisionFactorOfTheSamplingClockVALDIV60 Property

IRD

Tda10046DivisionFactorOfTheSamplingClockVALDIV60 Property

Division factor of the sampling clock (VALDIV[6:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DivisionFactorOfTheSamplingClockVALDIV60 { set; }
Public WriteOnly Property DivisionFactorOfTheSamplingClockVALDIV60 As Byte
    Set
public:
property unsigned char DivisionFactorOfTheSamplingClockVALDIV60 {
    void set (unsigned char value);
}
member DivisionFactorOfTheSamplingClockVALDIV60 : byte with set

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.DSPReadyDSPREADY Property

IRD

Tda10046DSPReadyDSPREADY Property

DSP Ready (DSPREADY)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS4 DSPReadyDSPREADY { get; }
Public ReadOnly Property DSPReadyDSPREADY As Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS4
    Get
public:
property Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS4 DSPReadyDSPREADY {
    Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS4 get ();
}
member DSPReadyDSPREADY : Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS4 with get

Property Value

Type: Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS4
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.DVBTNetworksCorrectlySizedENOUTGI Property

IRD

Tda10046DVBTNetworksCorrectlySizedENOUTGI Property

DVB-T networks correctly sized (EN_OUT_GI)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCHANNELINFORMATICHANNELINFO11 DVBTNetworksCorrectlySizedENOUTGI { get; set; }
Public Property DVBTNetworksCorrectlySizedENOUTGI As Tda10046TYPIDCHANNELINFORMATICHANNELINFO11
    Get
    Set
public:
property Tda10046TYPIDCHANNELINFORMATICHANNELINFO11 DVBTNetworksCorrectlySizedENOUTGI {
    Tda10046TYPIDCHANNELINFORMATICHANNELINFO11 get ();
    void set (Tda10046TYPIDCHANNELINFORMATICHANNELINFO11 value);
}
member DVBTNetworksCorrectlySizedENOUTGI : Tda10046TYPIDCHANNELINFORMATICHANNELINFO11 with get, set

Property Value

Type: Tda10046TYPIDCHANNELINFORMATICHANNELINFO11
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.EnableInterruptCBERRefreshedITSEL4 Property

IRD

Tda10046EnableInterruptCBERRefreshedITSEL4 Property

Enable interrupt: CBER refreshed (ITSEL[4])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 EnableInterruptCBERRefreshedITSEL4 { set; }
Public WriteOnly Property EnableInterruptCBERRefreshedITSEL4 As Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0
    Set
public:
property Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 EnableInterruptCBERRefreshedITSEL4 {
    void set (Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 value);
}
member EnableInterruptCBERRefreshedITSEL4 : Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 with set

Property Value

Type: Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.EnableInterruptDVBTSuperFrameSyncFlagITSEL2 Property

IRD

Tda10046EnableInterruptDVBTSuperFrameSyncFlagITSEL2 Property

Enable interrupt: DVB-T super frame sync flag (ITSEL[2])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 EnableInterruptDVBTSuperFrameSyncFlagITSEL2 { set; }
Public WriteOnly Property EnableInterruptDVBTSuperFrameSyncFlagITSEL2 As Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0
    Set
public:
property Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 EnableInterruptDVBTSuperFrameSyncFlagITSEL2 {
    void set (Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 value);
}
member EnableInterruptDVBTSuperFrameSyncFlagITSEL2 : Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 with set

Property Value

Type: Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.EnableInterruptFELGoesHighITSEL0 Property

IRD

Tda10046EnableInterruptFELGoesHighITSEL0 Property

Enable interrupt FEL goes high (ITSEL[0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 EnableInterruptFELGoesHighITSEL0 { set; }
Public WriteOnly Property EnableInterruptFELGoesHighITSEL0 As Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0
    Set
public:
property Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 EnableInterruptFELGoesHighITSEL0 {
    void set (Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 value);
}
member EnableInterruptFELGoesHighITSEL0 : Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 with set

Property Value

Type: Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.EnableInterruptFELGoesLowITSEL1 Property

IRD

Tda10046EnableInterruptFELGoesLowITSEL1 Property

Enable interrupt: FEL goes low (ITSEL[1])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 EnableInterruptFELGoesLowITSEL1 { set; }
Public WriteOnly Property EnableInterruptFELGoesLowITSEL1 As Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0
    Set
public:
property Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 EnableInterruptFELGoesLowITSEL1 {
    void set (Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 value);
}
member EnableInterruptFELGoesLowITSEL1 : Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 with set

Property Value

Type: Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.EnableInterruptUncorrectablePacketITSEL5 Property

IRD

Tda10046EnableInterruptUncorrectablePacketITSEL5 Property

Enable interrupt: uncorrectable packet (ITSEL[5])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 EnableInterruptUncorrectablePacketITSEL5 { set; }
Public WriteOnly Property EnableInterruptUncorrectablePacketITSEL5 As Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0
    Set
public:
property Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 EnableInterruptUncorrectablePacketITSEL5 {
    void set (Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 value);
}
member EnableInterruptUncorrectablePacketITSEL5 : Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 with set

Property Value

Type: Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.EnableInterruptVBERRefreshedITSEL3 Property

IRD

Tda10046EnableInterruptVBERRefreshedITSEL3 Property

Enable interrupt: VBER refreshed (ITSEL[3])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 EnableInterruptVBERRefreshedITSEL3 { set; }
Public WriteOnly Property EnableInterruptVBERRefreshedITSEL3 As Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0
    Set
public:
property Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 EnableInterruptVBERRefreshedITSEL3 {
    void set (Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 value);
}
member EnableInterruptVBERRefreshedITSEL3 : Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 with set

Property Value

Type: Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.EqualizationFilterCHINF8 Property

IRD

Tda10046EqualizationFilterCHINF8 Property

Equalization filter (CH_INF[8])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCHANNELINFORMATICHANNELINFO10 EqualizationFilterCHINF8 { get; set; }
Public Property EqualizationFilterCHINF8 As Tda10046TYPIDCHANNELINFORMATICHANNELINFO10
    Get
    Set
public:
property Tda10046TYPIDCHANNELINFORMATICHANNELINFO10 EqualizationFilterCHINF8 {
    Tda10046TYPIDCHANNELINFORMATICHANNELINFO10 get ();
    void set (Tda10046TYPIDCHANNELINFORMATICHANNELINFO10 value);
}
member EqualizationFilterCHINF8 : Tda10046TYPIDCHANNELINFORMATICHANNELINFO10 with get, set

Property Value

Type: Tda10046TYPIDCHANNELINFORMATICHANNELINFO10
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.EqualizerAdaptationDISADAPTFILT Property

IRD

Tda10046EqualizerAdaptationDISADAPTFILT Property

Equalizer adaptation (DIS_ADAPTFILT)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C34 EqualizerAdaptationDISADAPTFILT { set; }
Public WriteOnly Property EqualizerAdaptationDISADAPTFILT As Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C34
    Set
public:
property Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C34 EqualizerAdaptationDISADAPTFILT {
    void set (Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C34 value);
}
member EqualizerAdaptationDISADAPTFILT : Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C34 with set

Property Value

Type: Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C34
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ErrorCounterUsedInTheViterbiDecoderOutputBitErrorRateMeasurementVBER190 Property

IRD

Tda10046ErrorCounterUsedInTheViterbiDecoderOutputBitErrorRateMeasurementVBER190 Property

Error counter used in the Viterbi decoder output bit error rate measurement (VBER[19:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint ErrorCounterUsedInTheViterbiDecoderOutputBitErrorRateMeasurementVBER190 { get; }
Public ReadOnly Property ErrorCounterUsedInTheViterbiDecoderOutputBitErrorRateMeasurementVBER190 As UInteger
    Get
public:
property unsigned int ErrorCounterUsedInTheViterbiDecoderOutputBitErrorRateMeasurementVBER190 {
    unsigned int get ();
}
member ErrorCounterUsedInTheViterbiDecoderOutputBitErrorRateMeasurementVBER190 : uint32 with get

Property Value

Type: UInt32
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ErrorIndicatorBitInhibitionIEI Property

IRD

Tda10046ErrorIndicatorBitInhibitionIEI Property

Error Indicator bit inhibition (IEI)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10 ErrorIndicatorBitInhibitionIEI { set; }
Public WriteOnly Property ErrorIndicatorBitInhibitionIEI As Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10
    Set
public:
property Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10 ErrorIndicatorBitInhibitionIEI {
    void set (Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10 value);
}
member ErrorIndicatorBitInhibitionIEI : Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10 with set

Property Value

Type: Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.FFTSizeAUTO2K8K Property

IRD

Tda10046FFTSizeAUTO2K8K Property

FFT size (AUTO2K8K)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDAUTOMATICLOCKAUTO2 FFTSizeAUTO2K8K { set; }
Public WriteOnly Property FFTSizeAUTO2K8K As Tda10046TYPIDAUTOMATICLOCKAUTO2
    Set
public:
property Tda10046TYPIDAUTOMATICLOCKAUTO2 FFTSizeAUTO2K8K {
    void set (Tda10046TYPIDAUTOMATICLOCKAUTO2 value);
}
member FFTSizeAUTO2K8K : Tda10046TYPIDAUTOMATICLOCKAUTO2 with set

Property Value

Type: Tda10046TYPIDAUTOMATICLOCKAUTO2
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.FFTSizeFoundIfAUTO2K8K1CNF2K8KF Property

IRD

Tda10046FFTSizeFoundIfAUTO2K8K1CNF2K8KF Property

FFT size found (if AUTO2K8K=1) (CNF2K8K_F)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINPUTCONFIGURATION1INCONF12 FFTSizeFoundIfAUTO2K8K1CNF2K8KF { get; }
Public ReadOnly Property FFTSizeFoundIfAUTO2K8K1CNF2K8KF As Tda10046TYPIDINPUTCONFIGURATION1INCONF12
    Get
public:
property Tda10046TYPIDINPUTCONFIGURATION1INCONF12 FFTSizeFoundIfAUTO2K8K1CNF2K8KF {
    Tda10046TYPIDINPUTCONFIGURATION1INCONF12 get ();
}
member FFTSizeFoundIfAUTO2K8K1CNF2K8KF : Tda10046TYPIDINPUTCONFIGURATION1INCONF12 with get

Property Value

Type: Tda10046TYPIDINPUTCONFIGURATION1INCONF12
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.FFTSizeIfAUTO2K8K0CNF2K8K Property

IRD

Tda10046FFTSizeIfAUTO2K8K0CNF2K8K Property

FFT size (if AUTO2K8K=0) (CNF2K8K)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINPUTCONFIGURATION1INCONF12 FFTSizeIfAUTO2K8K0CNF2K8K { set; }
Public WriteOnly Property FFTSizeIfAUTO2K8K0CNF2K8K As Tda10046TYPIDINPUTCONFIGURATION1INCONF12
    Set
public:
property Tda10046TYPIDINPUTCONFIGURATION1INCONF12 FFTSizeIfAUTO2K8K0CNF2K8K {
    void set (Tda10046TYPIDINPUTCONFIGURATION1INCONF12 value);
}
member FFTSizeIfAUTO2K8K0CNF2K8K : Tda10046TYPIDINPUTCONFIGURATION1INCONF12 with set

Property Value

Type: Tda10046TYPIDINPUTCONFIGURATION1INCONF12
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.FormatOfThe10BitADCOutputCodeADCMODE Property

IRD

Tda10046FormatOfThe10BitADCOutputCodeADCMODE Property

Format of the 10-bit ADC output code (ADC_MODE)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONADCADCCONFADC4 FormatOfThe10BitADCOutputCodeADCMODE { set; }
Public WriteOnly Property FormatOfThe10BitADCOutputCodeADCMODE As Tda10046TYPIDCONFIGURATIONADCADCCONFADC4
    Set
public:
property Tda10046TYPIDCONFIGURATIONADCADCCONFADC4 FormatOfThe10BitADCOutputCodeADCMODE {
    void set (Tda10046TYPIDCONFIGURATIONADCADCCONFADC4 value);
}
member FormatOfThe10BitADCOutputCodeADCMODE : Tda10046TYPIDCONFIGURATIONADCADCCONFADC4 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONADCADCCONFADC4
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.FrequencyErrorDeltaFFREQERR150 Property

IRD

Tda10046FrequencyErrorDeltaFFREQERR150 Property

Frequency error deltaF (FREQERR[15:0]) (unit: Hz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort FrequencyErrorDeltaFFREQERR150 { get; set; }
Public Property FrequencyErrorDeltaFFREQERR150 As UShort
    Get
    Set
public:
property unsigned short FrequencyErrorDeltaFFREQERR150 {
    unsigned short get ();
    void set (unsigned short value);
}
member FrequencyErrorDeltaFFREQERR150 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.FrequencyOffsetOfTheRFSignalAUTOOFFSET0OFFSET20 Property

IRD

Tda10046FrequencyOffsetOfTheRFSignalAUTOOFFSET0OFFSET20 Property

Frequency offset of the RF signal (AUTOOFFSET=0) (OFFSET[2:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINPUTCONFIGURATION2INCONF20 FrequencyOffsetOfTheRFSignalAUTOOFFSET0OFFSET20 { set; }
Public WriteOnly Property FrequencyOffsetOfTheRFSignalAUTOOFFSET0OFFSET20 As Tda10046TYPIDINPUTCONFIGURATION2INCONF20
    Set
public:
property Tda10046TYPIDINPUTCONFIGURATION2INCONF20 FrequencyOffsetOfTheRFSignalAUTOOFFSET0OFFSET20 {
    void set (Tda10046TYPIDINPUTCONFIGURATION2INCONF20 value);
}
member FrequencyOffsetOfTheRFSignalAUTOOFFSET0OFFSET20 : Tda10046TYPIDINPUTCONFIGURATION2INCONF20 with set

Property Value

Type: Tda10046TYPIDINPUTCONFIGURATION2INCONF20
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.FrequencyOffsetOfTheRFSignalAUTOOFFSET1OFFSETF20 Property

IRD

Tda10046FrequencyOffsetOfTheRFSignalAUTOOFFSET1OFFSETF20 Property

Frequency offset of the RF signal (AUTOOFFSET=1) (OFFSET_F[2:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINPUTCONFIGURATION2INCONF201 FrequencyOffsetOfTheRFSignalAUTOOFFSET1OFFSETF20 { get; }
Public ReadOnly Property FrequencyOffsetOfTheRFSignalAUTOOFFSET1OFFSETF20 As Tda10046TYPIDINPUTCONFIGURATION2INCONF201
    Get
public:
property Tda10046TYPIDINPUTCONFIGURATION2INCONF201 FrequencyOffsetOfTheRFSignalAUTOOFFSET1OFFSETF20 {
    Tda10046TYPIDINPUTCONFIGURATION2INCONF201 get ();
}
member FrequencyOffsetOfTheRFSignalAUTOOFFSET1OFFSETF20 : Tda10046TYPIDINPUTCONFIGURATION2INCONF201 with get

Property Value

Type: Tda10046TYPIDINPUTCONFIGURATION2INCONF201
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.FrequencyRecoveryAlgorithmFREQLOCK Property

IRD

Tda10046FrequencyRecoveryAlgorithmFREQLOCK Property

Frequency recovery algorithm (FREQ_LOCK)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS1 FrequencyRecoveryAlgorithmFREQLOCK { get; }
Public ReadOnly Property FrequencyRecoveryAlgorithmFREQLOCK As Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS1
    Get
public:
property Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS1 FrequencyRecoveryAlgorithmFREQLOCK {
    Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS1 get ();
}
member FrequencyRecoveryAlgorithmFREQLOCK : Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS1 with get

Property Value

Type: Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS1
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.FrontEndLockFEL Property

IRD

Tda10046FrontEndLockFEL Property

Front End Lock (FEL)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS3 FrontEndLockFEL { get; }
Public ReadOnly Property FrontEndLockFEL As Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS3
    Get
public:
property Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS3 FrontEndLockFEL {
    Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS3 get ();
}
member FrontEndLockFEL : Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS3 with get

Property Value

Type: Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS3
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.GainOfTheDigitalAGCLoopForTheTunerPartAGCIFGAIN70 Property

IRD

Tda10046GainOfTheDigitalAGCLoopForTheTunerPartAGCIFGAIN70 Property

Gain of the digital AGC loop for the tuner part (AGCIF_GAIN[7:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDAGCLOOPGAINAGCGAINS0 GainOfTheDigitalAGCLoopForTheTunerPartAGCIFGAIN70 { set; }
Public WriteOnly Property GainOfTheDigitalAGCLoopForTheTunerPartAGCIFGAIN70 As Tda10046TYPIDAGCLOOPGAINAGCGAINS0
    Set
public:
property Tda10046TYPIDAGCLOOPGAINAGCGAINS0 GainOfTheDigitalAGCLoopForTheTunerPartAGCIFGAIN70 {
    void set (Tda10046TYPIDAGCLOOPGAINAGCGAINS0 value);
}
member GainOfTheDigitalAGCLoopForTheTunerPartAGCIFGAIN70 : Tda10046TYPIDAGCLOOPGAINAGCGAINS0 with set

Property Value

Type: Tda10046TYPIDAGCLOOPGAINAGCGAINS0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.GainOfTheDigitalAGCLoopForTheTunerPartAGCTUNGAIN70 Property

IRD

Tda10046GainOfTheDigitalAGCLoopForTheTunerPartAGCTUNGAIN70 Property

Gain of the digital AGC loop for the tuner part (AGCTUN_GAIN[7:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDAGCLOOPGAINAGCGAINS0 GainOfTheDigitalAGCLoopForTheTunerPartAGCTUNGAIN70 { set; }
Public WriteOnly Property GainOfTheDigitalAGCLoopForTheTunerPartAGCTUNGAIN70 As Tda10046TYPIDAGCLOOPGAINAGCGAINS0
    Set
public:
property Tda10046TYPIDAGCLOOPGAINAGCGAINS0 GainOfTheDigitalAGCLoopForTheTunerPartAGCTUNGAIN70 {
    void set (Tda10046TYPIDAGCLOOPGAINAGCGAINS0 value);
}
member GainOfTheDigitalAGCLoopForTheTunerPartAGCTUNGAIN70 : Tda10046TYPIDAGCLOOPGAINAGCGAINS0 with set

Property Value

Type: Tda10046TYPIDAGCLOOPGAINAGCGAINS0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.GainOfTheInternalTrackHoldCircuitOfADCADCGAINSET Property

IRD

Tda10046GainOfTheInternalTrackHoldCircuitOfADCADCGAINSET Property

Gain of the internal track/hold circuit of ADC (ADC_GAINSET)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONADCADCCONFADC0 GainOfTheInternalTrackHoldCircuitOfADCADCGAINSET { set; }
Public WriteOnly Property GainOfTheInternalTrackHoldCircuitOfADCADCGAINSET As Tda10046TYPIDCONFIGURATIONADCADCCONFADC0
    Set
public:
property Tda10046TYPIDCONFIGURATIONADCADCCONFADC0 GainOfTheInternalTrackHoldCircuitOfADCADCGAINSET {
    void set (Tda10046TYPIDCONFIGURATIONADCADCCONFADC0 value);
}
member GainOfTheInternalTrackHoldCircuitOfADCADCGAINSET : Tda10046TYPIDCONFIGURATIONADCADCCONFADC0 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONADCADCCONFADC0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.GPIO0PinDeltaSigmaInputWordSELDS0 Property

IRD

Tda10046GPIO0PinDeltaSigmaInputWordSELDS0 Property

GPIO[0] pin deltaSigma input word (SEL_DS[0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDGPIOSELECTGPIOSELECT0 GPIO0PinDeltaSigmaInputWordSELDS0 { set; }
Public WriteOnly Property GPIO0PinDeltaSigmaInputWordSELDS0 As Tda10046TYPIDGPIOSELECTGPIOSELECT0
    Set
public:
property Tda10046TYPIDGPIOSELECTGPIOSELECT0 GPIO0PinDeltaSigmaInputWordSELDS0 {
    void set (Tda10046TYPIDGPIOSELECTGPIOSELECT0 value);
}
member GPIO0PinDeltaSigmaInputWordSELDS0 : Tda10046TYPIDGPIOSELECTGPIOSELECT0 with set

Property Value

Type: Tda10046TYPIDGPIOSELECTGPIOSELECT0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.GPIO1PinDeltaSigmaInputWordSELDS1 Property

IRD

Tda10046GPIO1PinDeltaSigmaInputWordSELDS1 Property

GPIO[1] pin deltaSigma input word (SEL_DS[1])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDGPIOSELECTGPIOSELECT0 GPIO1PinDeltaSigmaInputWordSELDS1 { set; }
Public WriteOnly Property GPIO1PinDeltaSigmaInputWordSELDS1 As Tda10046TYPIDGPIOSELECTGPIOSELECT0
    Set
public:
property Tda10046TYPIDGPIOSELECTGPIOSELECT0 GPIO1PinDeltaSigmaInputWordSELDS1 {
    void set (Tda10046TYPIDGPIOSELECTGPIOSELECT0 value);
}
member GPIO1PinDeltaSigmaInputWordSELDS1 : Tda10046TYPIDGPIOSELECTGPIOSELECT0 with set

Property Value

Type: Tda10046TYPIDGPIOSELECTGPIOSELECT0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.GPIOPin0ZGPIO010 Property

IRD

Tda10046GPIOPin0ZGPIO010 Property

GPIO pin 0 (Z_GPIO0[1:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20 GPIOPin0ZGPIO010 { set; }
Public WriteOnly Property GPIOPin0ZGPIO010 As Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20 GPIOPin0ZGPIO010 {
    void set (Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20 value);
}
member GPIOPin0ZGPIO010 : Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.GPIOPin1ZGPIO110 Property

IRD

Tda10046GPIOPin1ZGPIO110 Property

GPIO pin 1 (Z_GPIO1[1:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20 GPIOPin1ZGPIO110 { set; }
Public WriteOnly Property GPIOPin1ZGPIO110 As Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20 GPIOPin1ZGPIO110 {
    void set (Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20 value);
}
member GPIOPin1ZGPIO110 : Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.GPIOPin2ZGPIO210 Property

IRD

Tda10046GPIOPin2ZGPIO210 Property

GPIO pin 2 (Z_GPIO2[1:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20 GPIOPin2ZGPIO210 { set; }
Public WriteOnly Property GPIOPin2ZGPIO210 As Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20 GPIOPin2ZGPIO210 {
    void set (Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20 value);
}
member GPIOPin2ZGPIO210 : Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.GPIOPin3ZGPIO310 Property

IRD

Tda10046GPIOPin3ZGPIO310 Property

GPIO pin 3 (Z_GPIO3[1:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20 GPIOPin3ZGPIO310 { set; }
Public WriteOnly Property GPIOPin3ZGPIO310 As Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20 GPIOPin3ZGPIO310 {
    void set (Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20 value);
}
member GPIOPin3ZGPIO310 : Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.GuardIntervalSizeIfAUTOGI0DELTA10 Property

IRD

Tda10046GuardIntervalSizeIfAUTOGI0DELTA10 Property

Guard Interval size (if AUTOGI=0) (DELTA[1:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINPUTCONFIGURATION1INCONF11 GuardIntervalSizeIfAUTOGI0DELTA10 { set; }
Public WriteOnly Property GuardIntervalSizeIfAUTOGI0DELTA10 As Tda10046TYPIDINPUTCONFIGURATION1INCONF11
    Set
public:
property Tda10046TYPIDINPUTCONFIGURATION1INCONF11 GuardIntervalSizeIfAUTOGI0DELTA10 {
    void set (Tda10046TYPIDINPUTCONFIGURATION1INCONF11 value);
}
member GuardIntervalSizeIfAUTOGI0DELTA10 : Tda10046TYPIDINPUTCONFIGURATION1INCONF11 with set

Property Value

Type: Tda10046TYPIDINPUTCONFIGURATION1INCONF11
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.GuardIntervalSizeValueFoundIfAUTOGI0DELTAF10 Property

IRD

Tda10046GuardIntervalSizeValueFoundIfAUTOGI0DELTAF10 Property

Guard interval size value found (if AUTOGI=0) (DELTA_F[1:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINPUTCONFIGURATION1INCONF11 GuardIntervalSizeValueFoundIfAUTOGI0DELTAF10 { get; }
Public ReadOnly Property GuardIntervalSizeValueFoundIfAUTOGI0DELTAF10 As Tda10046TYPIDINPUTCONFIGURATION1INCONF11
    Get
public:
property Tda10046TYPIDINPUTCONFIGURATION1INCONF11 GuardIntervalSizeValueFoundIfAUTOGI0DELTAF10 {
    Tda10046TYPIDINPUTCONFIGURATION1INCONF11 get ();
}
member GuardIntervalSizeValueFoundIfAUTOGI0DELTAF10 : Tda10046TYPIDINPUTCONFIGURATION1INCONF11 with get

Property Value

Type: Tda10046TYPIDINPUTCONFIGURATION1INCONF11
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.GuardIntervalValueAUTOGI Property

IRD

Tda10046GuardIntervalValueAUTOGI Property

Guard Interval value (AUTOGI)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDAUTOMATICLOCKAUTO1 GuardIntervalValueAUTOGI { set; }
Public WriteOnly Property GuardIntervalValueAUTOGI As Tda10046TYPIDAUTOMATICLOCKAUTO1
    Set
public:
property Tda10046TYPIDAUTOMATICLOCKAUTO1 GuardIntervalValueAUTOGI {
    void set (Tda10046TYPIDAUTOMATICLOCKAUTO1 value);
}
member GuardIntervalValueAUTOGI : Tda10046TYPIDAUTOMATICLOCKAUTO1 with set

Property Value

Type: Tda10046TYPIDAUTOMATICLOCKAUTO1
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.HierarchicalLevelIfAutoTPS0ALPHA10 Property

IRD

Tda10046HierarchicalLevelIfAutoTPS0ALPHA10 Property

Hierarchical level (if AutoTPS=0) (ALPHA[1:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINPUTCONFIGURATION1INCONF13 HierarchicalLevelIfAutoTPS0ALPHA10 { set; }
Public WriteOnly Property HierarchicalLevelIfAutoTPS0ALPHA10 As Tda10046TYPIDINPUTCONFIGURATION1INCONF13
    Set
public:
property Tda10046TYPIDINPUTCONFIGURATION1INCONF13 HierarchicalLevelIfAutoTPS0ALPHA10 {
    void set (Tda10046TYPIDINPUTCONFIGURATION1INCONF13 value);
}
member HierarchicalLevelIfAutoTPS0ALPHA10 : Tda10046TYPIDINPUTCONFIGURATION1INCONF13 with set

Property Value

Type: Tda10046TYPIDINPUTCONFIGURATION1INCONF13
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.HierarchicalLevelValueIfAutoTPS1ALPHAF10 Property

IRD

Tda10046HierarchicalLevelValueIfAutoTPS1ALPHAF10 Property

Hierarchical level value (if AutoTPS=1) (ALPHA_F[1:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINPUTCONFIGURATION1INCONF13 HierarchicalLevelValueIfAutoTPS1ALPHAF10 { get; }
Public ReadOnly Property HierarchicalLevelValueIfAutoTPS1ALPHAF10 As Tda10046TYPIDINPUTCONFIGURATION1INCONF13
    Get
public:
property Tda10046TYPIDINPUTCONFIGURATION1INCONF13 HierarchicalLevelValueIfAutoTPS1ALPHAF10 {
    Tda10046TYPIDINPUTCONFIGURATION1INCONF13 get ();
}
member HierarchicalLevelValueIfAutoTPS1ALPHAF10 : Tda10046TYPIDINPUTCONFIGURATION1INCONF13 with get

Property Value

Type: Tda10046TYPIDINPUTCONFIGURATION1INCONF13
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.I2CAnalogLevelOutputPinGPIO0Vmax5V33VI2CDS070 Property

IRD

Tda10046I2CAnalogLevelOutputPinGPIO0Vmax5V33VI2CDS070 Property

I2C analog level (output pin GPIO[0]) (Vmax=5 V/3.3 V) (I2C_DS0[7:0]) (unit: V)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00 I2CAnalogLevelOutputPinGPIO0Vmax5V33VI2CDS070 { set; }
Public WriteOnly Property I2CAnalogLevelOutputPinGPIO0Vmax5V33VI2CDS070 As Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00
    Set
public:
property Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00 I2CAnalogLevelOutputPinGPIO0Vmax5V33VI2CDS070 {
    void set (Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00 value);
}
member I2CAnalogLevelOutputPinGPIO0Vmax5V33VI2CDS070 : Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00 with set

Property Value

Type: Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.I2CDS1 Property

IRD

Tda10046I2CDS1 Property

I2C_DS1 (unit: V)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00 I2CDS1 { set; }
Public WriteOnly Property I2CDS1 As Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00
    Set
public:
property Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00 I2CDS1 {
    void set (Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00 value);
}
member I2CDS1 : Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00 with set

Property Value

Type: Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.I2CDS2 Property

IRD

Tda10046I2CDS2 Property

I2C_DS2 (unit: V)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00 I2CDS2 { set; }
Public WriteOnly Property I2CDS2 As Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00
    Set
public:
property Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00 I2CDS2 {
    void set (Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00 value);
}
member I2CDS2 : Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00 with set

Property Value

Type: Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.I2CDS3 Property

IRD

Tda10046I2CDS3 Property

I2C_DS3 (unit: V)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00 I2CDS3 { set; }
Public WriteOnly Property I2CDS3 As Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00
    Set
public:
property Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00 I2CDS3 {
    void set (Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00 value);
}
member I2CDS3 : Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00 with set

Property Value

Type: Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.I2CEEPBusSpeedEEPSPD10 Property

IRD

Tda10046I2CEEPBusSpeedEEPSPD10 Property

I2C EEP bus speed (EEPSPD[1:0]) (unit: kHz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDBYPASSIFINTERNAONS3CONFC46 I2CEEPBusSpeedEEPSPD10 { set; }
Public WriteOnly Property I2CEEPBusSpeedEEPSPD10 As Tda10046TYPIDBYPASSIFINTERNAONS3CONFC46
    Set
public:
property Tda10046TYPIDBYPASSIFINTERNAONS3CONFC46 I2CEEPBusSpeedEEPSPD10 {
    void set (Tda10046TYPIDBYPASSIFINTERNAONS3CONFC46 value);
}
member I2CEEPBusSpeedEEPSPD10 : Tda10046TYPIDBYPASSIFINTERNAONS3CONFC46 with set

Property Value

Type: Tda10046TYPIDBYPASSIFINTERNAONS3CONFC46
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.IdentifyTheCellFromWhichTheSignalComesFromCELLID150 Property

IRD

Tda10046IdentifyTheCellFromWhichTheSignalComesFromCELLID150 Property

Identify the cell from which the signal comes from (CELL_ID[15:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort IdentifyTheCellFromWhichTheSignalComesFromCELLID150 { get; }
Public ReadOnly Property IdentifyTheCellFromWhichTheSignalComesFromCELLID150 As UShort
    Get
public:
property unsigned short IdentifyTheCellFromWhichTheSignalComesFromCELLID150 {
    unsigned short get ();
}
member IdentifyTheCellFromWhichTheSignalComesFromCELLID150 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.Identity Property

IRD

Tda10046Identity Property

Identity

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Identity { get; }
Public ReadOnly Property Identity As Byte
    Get
public:
property unsigned char Identity {
    unsigned char get ();
}
member Identity : byte with get

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.InnerCodeRateOfTheHighPriorityStreamIfAUTOTPS0RH20 Property

IRD

Tda10046InnerCodeRateOfTheHighPriorityStreamIfAUTOTPS0RH20 Property

Inner code rate of the high priority stream (if AUTOTPS=0) (RH[2:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINPUTCONFIGURATION2INCONF201 InnerCodeRateOfTheHighPriorityStreamIfAUTOTPS0RH20 { set; }
Public WriteOnly Property InnerCodeRateOfTheHighPriorityStreamIfAUTOTPS0RH20 As Tda10046TYPIDINPUTCONFIGURATION2INCONF201
    Set
public:
property Tda10046TYPIDINPUTCONFIGURATION2INCONF201 InnerCodeRateOfTheHighPriorityStreamIfAUTOTPS0RH20 {
    void set (Tda10046TYPIDINPUTCONFIGURATION2INCONF201 value);
}
member InnerCodeRateOfTheHighPriorityStreamIfAUTOTPS0RH20 : Tda10046TYPIDINPUTCONFIGURATION2INCONF201 with set

Property Value

Type: Tda10046TYPIDINPUTCONFIGURATION2INCONF201
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.InnerCodeRateOfTheHighPriorityStreamIfAutoTPS1RH20 Property

IRD

Tda10046InnerCodeRateOfTheHighPriorityStreamIfAutoTPS1RH20 Property

Inner code rate of the high priority stream (if AutoTPS=1) (RH[2:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINPUTCONFIGURATION2INCONF201 InnerCodeRateOfTheHighPriorityStreamIfAutoTPS1RH20 { get; }
Public ReadOnly Property InnerCodeRateOfTheHighPriorityStreamIfAutoTPS1RH20 As Tda10046TYPIDINPUTCONFIGURATION2INCONF201
    Get
public:
property Tda10046TYPIDINPUTCONFIGURATION2INCONF201 InnerCodeRateOfTheHighPriorityStreamIfAutoTPS1RH20 {
    Tda10046TYPIDINPUTCONFIGURATION2INCONF201 get ();
}
member InnerCodeRateOfTheHighPriorityStreamIfAutoTPS1RH20 : Tda10046TYPIDINPUTCONFIGURATION2INCONF201 with get

Property Value

Type: Tda10046TYPIDINPUTCONFIGURATION2INCONF201
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.InnerCodeRateOfTheLowPriorityStreamIfAUTOTPS0RL20 Property

IRD

Tda10046InnerCodeRateOfTheLowPriorityStreamIfAUTOTPS0RL20 Property

Inner code rate of the low priority stream (if AUTOTPS=0) (RL[2:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINPUTCONFIGURATION2INCONF201 InnerCodeRateOfTheLowPriorityStreamIfAUTOTPS0RL20 { set; }
Public WriteOnly Property InnerCodeRateOfTheLowPriorityStreamIfAUTOTPS0RL20 As Tda10046TYPIDINPUTCONFIGURATION2INCONF201
    Set
public:
property Tda10046TYPIDINPUTCONFIGURATION2INCONF201 InnerCodeRateOfTheLowPriorityStreamIfAUTOTPS0RL20 {
    void set (Tda10046TYPIDINPUTCONFIGURATION2INCONF201 value);
}
member InnerCodeRateOfTheLowPriorityStreamIfAUTOTPS0RL20 : Tda10046TYPIDINPUTCONFIGURATION2INCONF201 with set

Property Value

Type: Tda10046TYPIDINPUTCONFIGURATION2INCONF201
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.InnerCodeRateOfTheLowPriorityStreamIfAutoTPS1RL20 Property

IRD

Tda10046InnerCodeRateOfTheLowPriorityStreamIfAutoTPS1RL20 Property

Inner code rate of the low priority stream (if AutoTPS=1) (RL[2:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINPUTCONFIGURATION2INCONF201 InnerCodeRateOfTheLowPriorityStreamIfAutoTPS1RL20 { get; }
Public ReadOnly Property InnerCodeRateOfTheLowPriorityStreamIfAutoTPS1RL20 As Tda10046TYPIDINPUTCONFIGURATION2INCONF201
    Get
public:
property Tda10046TYPIDINPUTCONFIGURATION2INCONF201 InnerCodeRateOfTheLowPriorityStreamIfAutoTPS1RL20 {
    Tda10046TYPIDINPUTCONFIGURATION2INCONF201 get ();
}
member InnerCodeRateOfTheLowPriorityStreamIfAutoTPS1RL20 : Tda10046TYPIDINPUTCONFIGURATION2INCONF201 with get

Property Value

Type: Tda10046TYPIDINPUTCONFIGURATION2INCONF201
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.InputClockOfThePLLFquartzFsampPLLBYP Property

IRD

Tda10046InputClockOfThePLLFquartzFsampPLLBYP Property

Input clock of the PLL (Fquartz->Fsamp) (PLL_BYP)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL11 InputClockOfThePLLFquartzFsampPLLBYP { set; }
Public WriteOnly Property InputClockOfThePLLFquartzFsampPLLBYP As Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL11
    Set
public:
property Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL11 InputClockOfThePLLFquartzFsampPLLBYP {
    void set (Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL11 value);
}
member InputClockOfThePLLFquartzFsampPLLBYP : Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL11 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL11
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.InputSignalCouplingADCDCIN Property

IRD

Tda10046InputSignalCouplingADCDCIN Property

Input signal coupling (ADC_DCIN)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONADCADCCONFADC1 InputSignalCouplingADCDCIN { set; }
Public WriteOnly Property InputSignalCouplingADCDCIN As Tda10046TYPIDCONFIGURATIONADCADCCONFADC1
    Set
public:
property Tda10046TYPIDCONFIGURATIONADCADCCONFADC1 InputSignalCouplingADCDCIN {
    void set (Tda10046TYPIDCONFIGURATIONADCADCCONFADC1 value);
}
member InputSignalCouplingADCDCIN : Tda10046TYPIDCONFIGURATIONADCADCCONFADC1 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONADCADCCONFADC1
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.InputSignalUSEADCINT Property

IRD

Tda10046InputSignalUSEADCINT Property

Input signal (USE_ADC_INT)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONADCADCCONFADC3 InputSignalUSEADCINT { set; }
Public WriteOnly Property InputSignalUSEADCINT As Tda10046TYPIDCONFIGURATIONADCADCCONFADC3
    Set
public:
property Tda10046TYPIDCONFIGURATIONADCADCCONFADC3 InputSignalUSEADCINT {
    void set (Tda10046TYPIDCONFIGURATIONADCADCCONFADC3 value);
}
member InputSignalUSEADCINT : Tda10046TYPIDCONFIGURATIONADCADCCONFADC3 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONADCADCCONFADC3
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.InterruptOccurredCBERRefreshedITSTAT4 Property

IRD

Tda10046InterruptOccurredCBERRefreshedITSTAT4 Property

Interrupt occurred: CBER refreshed (ITSTAT[4])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 InterruptOccurredCBERRefreshedITSTAT4 { get; }
Public ReadOnly Property InterruptOccurredCBERRefreshedITSTAT4 As Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0
    Get
public:
property Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 InterruptOccurredCBERRefreshedITSTAT4 {
    Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 get ();
}
member InterruptOccurredCBERRefreshedITSTAT4 : Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 with get

Property Value

Type: Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.InterruptOccurredDVBTSuperFrameSyncFlagITSTAT2 Property

IRD

Tda10046InterruptOccurredDVBTSuperFrameSyncFlagITSTAT2 Property

Interrupt occurred: DVB-T super frame sync flag (ITSTAT[2])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 InterruptOccurredDVBTSuperFrameSyncFlagITSTAT2 { get; }
Public ReadOnly Property InterruptOccurredDVBTSuperFrameSyncFlagITSTAT2 As Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0
    Get
public:
property Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 InterruptOccurredDVBTSuperFrameSyncFlagITSTAT2 {
    Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 get ();
}
member InterruptOccurredDVBTSuperFrameSyncFlagITSTAT2 : Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 with get

Property Value

Type: Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.InterruptOccurredFELHighITSTAT0 Property

IRD

Tda10046InterruptOccurredFELHighITSTAT0 Property

Interrupt occurred: FEL high (ITSTAT[0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 InterruptOccurredFELHighITSTAT0 { get; }
Public ReadOnly Property InterruptOccurredFELHighITSTAT0 As Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0
    Get
public:
property Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 InterruptOccurredFELHighITSTAT0 {
    Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 get ();
}
member InterruptOccurredFELHighITSTAT0 : Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 with get

Property Value

Type: Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.InterruptOccurredFELLowITSTAT1 Property

IRD

Tda10046InterruptOccurredFELLowITSTAT1 Property

Interrupt occurred: FEL low (ITSTAT[1])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 InterruptOccurredFELLowITSTAT1 { get; }
Public ReadOnly Property InterruptOccurredFELLowITSTAT1 As Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0
    Get
public:
property Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 InterruptOccurredFELLowITSTAT1 {
    Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 get ();
}
member InterruptOccurredFELLowITSTAT1 : Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 with get

Property Value

Type: Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.InterruptOccurredUncorrectablePacketITSTAT5 Property

IRD

Tda10046InterruptOccurredUncorrectablePacketITSTAT5 Property

Interrupt occurred: uncorrectable packet (ITSTAT[5])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 InterruptOccurredUncorrectablePacketITSTAT5 { get; }
Public ReadOnly Property InterruptOccurredUncorrectablePacketITSTAT5 As Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0
    Get
public:
property Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 InterruptOccurredUncorrectablePacketITSTAT5 {
    Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 get ();
}
member InterruptOccurredUncorrectablePacketITSTAT5 : Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 with get

Property Value

Type: Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.InterruptOccurredVBERRefreshedITSTAT3 Property

IRD

Tda10046InterruptOccurredVBERRefreshedITSTAT3 Property

Interrupt occurred: VBER refreshed (ITSTAT[3])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 InterruptOccurredVBERRefreshedITSTAT3 { get; }
Public ReadOnly Property InterruptOccurredVBERRefreshedITSTAT3 As Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0
    Get
public:
property Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 InterruptOccurredVBERRefreshedITSTAT3 {
    Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 get ();
}
member InterruptOccurredVBERRefreshedITSTAT3 : Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 with get

Property Value

Type: Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.InverseTheLevelOfTheOfThePinAGCIFPOLAAGCIF Property

IRD

Tda10046InverseTheLevelOfTheOfThePinAGCIFPOLAAGCIF Property

Inverse the level of the of the pin AGC_IF (POLA_AGC_IF)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 InverseTheLevelOfTheOfThePinAGCIFPOLAAGCIF { set; }
Public WriteOnly Property InverseTheLevelOfTheOfThePinAGCIFPOLAAGCIF As Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0
    Set
public:
property Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 InverseTheLevelOfTheOfThePinAGCIFPOLAAGCIF {
    void set (Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 value);
}
member InverseTheLevelOfTheOfThePinAGCIFPOLAAGCIF : Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.InverseTheLevelOfTheOfThePinAGCTUNPinPOLAAGCTUN Property

IRD

Tda10046InverseTheLevelOfTheOfThePinAGCTUNPinPOLAAGCTUN Property

Inverse the level of the of the pin AGC_TUN pin (POLA_AGC_TUN)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 InverseTheLevelOfTheOfThePinAGCTUNPinPOLAAGCTUN { set; }
Public WriteOnly Property InverseTheLevelOfTheOfThePinAGCTUNPinPOLAAGCTUN As Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0
    Set
public:
property Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 InverseTheLevelOfTheOfThePinAGCTUNPinPOLAAGCTUN {
    void set (Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 value);
}
member InverseTheLevelOfTheOfThePinAGCTUNPinPOLAAGCTUN : Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.InverseTheLevelOfTheSamplingClockPOLASACLK Property

IRD

Tda10046InverseTheLevelOfTheSamplingClockPOLASACLK Property

Inverse the level of the sampling clock (POLA_SACLK)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 InverseTheLevelOfTheSamplingClockPOLASACLK { set; }
Public WriteOnly Property InverseTheLevelOfTheSamplingClockPOLASACLK As Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0
    Set
public:
property Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 InverseTheLevelOfTheSamplingClockPOLASACLK {
    void set (Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 value);
}
member InverseTheLevelOfTheSamplingClockPOLASACLK : Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ModeForBothParallelAndSerialMPEGTSInterfacesDEGIG Property

IRD

Tda10046ModeForBothParallelAndSerialMPEGTSInterfacesDEGIG Property

Mode for both parallel and serial MPEG-TS interfaces (DEGIG)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRAAM1CONFTS11 ModeForBothParallelAndSerialMPEGTSInterfacesDEGIG { set; }
Public WriteOnly Property ModeForBothParallelAndSerialMPEGTSInterfacesDEGIG As Tda10046TYPIDCONFIGURATIONTRAAM1CONFTS11
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRAAM1CONFTS11 ModeForBothParallelAndSerialMPEGTSInterfacesDEGIG {
    void set (Tda10046TYPIDCONFIGURATIONTRAAM1CONFTS11 value);
}
member ModeForBothParallelAndSerialMPEGTSInterfacesDEGIG : Tda10046TYPIDCONFIGURATIONTRAAM1CONFTS11 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRAAM1CONFTS11
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ModulationIfAutoTPS0CONS10 Property

IRD

Tda10046ModulationIfAutoTPS0CONS10 Property

Modulation (if AutoTPS=0) (CONS[1:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDINPUTCONFIGURATION1INCONF10 ModulationIfAutoTPS0CONS10 { set; }
Public WriteOnly Property ModulationIfAutoTPS0CONS10 As Tda10046TYPIDINPUTCONFIGURATION1INCONF10
    Set
public:
property Tda10046TYPIDINPUTCONFIGURATION1INCONF10 ModulationIfAutoTPS0CONS10 {
    void set (Tda10046TYPIDINPUTCONFIGURATION1INCONF10 value);
}
member ModulationIfAutoTPS0CONS10 : Tda10046TYPIDINPUTCONFIGURATION1INCONF10 with set

Property Value

Type: Tda10046TYPIDINPUTCONFIGURATION1INCONF10
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.MPEGTSMPEGTSModesLSBMSBSLSB Property

IRD

Tda10046MPEGTSMPEGTSModesLSBMSBSLSB Property

MPEG-TS MPEG-TS modes LSB/MSB (S_LSB)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS25 MPEGTSMPEGTSModesLSBMSBSLSB { set; }
Public WriteOnly Property MPEGTSMPEGTSModesLSBMSBSLSB As Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS25
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS25 MPEGTSMPEGTSModesLSBMSBSLSB {
    void set (Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS25 value);
}
member MPEGTSMPEGTSModesLSBMSBSLSB : Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS25 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS25
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.MPEGTSMPEGTSModesPSYNCActivePSYNCLENGTH Property

IRD

Tda10046MPEGTSMPEGTSModesPSYNCActivePSYNCLENGTH Property

MPEG-TS MPEG-TS modes PSYNC active (PSYNC_LENGTH)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS26 MPEGTSMPEGTSModesPSYNCActivePSYNCLENGTH { set; }
Public WriteOnly Property MPEGTSMPEGTSModesPSYNCActivePSYNCLENGTH As Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS26
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS26 MPEGTSMPEGTSModesPSYNCActivePSYNCLENGTH {
    void set (Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS26 value);
}
member MPEGTSMPEGTSModesPSYNCActivePSYNCLENGTH : Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS26 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS26
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.MPEGTSParallelPinsParallelMPEGTSSerialStreamSBUS Property

IRD

Tda10046MPEGTSParallelPinsParallelMPEGTSSerialStreamSBUS Property

MPEG-TS parallel pins: parallel MPEG-TS/serial stream (S_BUS)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS24 MPEGTSParallelPinsParallelMPEGTSSerialStreamSBUS { set; }
Public WriteOnly Property MPEGTSParallelPinsParallelMPEGTSSerialStreamSBUS As Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS24
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS24 MPEGTSParallelPinsParallelMPEGTSSerialStreamSBUS {
    void set (Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS24 value);
}
member MPEGTSParallelPinsParallelMPEGTSSerialStreamSBUS : Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS24 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS24
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.MPEGTSParallelSerialInterfacesTSONUncor Property

IRD

Tda10046MPEGTSParallelSerialInterfacesTSONUncor Property

MPEG-TS parallel/serial interfaces (TS_ON_uncor)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONMISISCCONFMISC1 MPEGTSParallelSerialInterfacesTSONUncor { set; }
Public WriteOnly Property MPEGTSParallelSerialInterfacesTSONUncor As Tda10046TYPIDCONFIGURATIONMISISCCONFMISC1
    Set
public:
property Tda10046TYPIDCONFIGURATIONMISISCCONFMISC1 MPEGTSParallelSerialInterfacesTSONUncor {
    void set (Tda10046TYPIDCONFIGURATIONMISISCCONFMISC1 value);
}
member MPEGTSParallelSerialInterfacesTSONUncor : Tda10046TYPIDCONFIGURATIONMISISCCONFMISC1 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONMISISCCONFMISC1
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.MultiPurposeAccessRegisterAddressDSPAD150 Property

IRD

Tda10046MultiPurposeAccessRegisterAddressDSPAD150 Property

Multi-purpose access register address (DSPAD[15:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDMULTIPURPOSEACCBDSPADLSB0 MultiPurposeAccessRegisterAddressDSPAD150 { set; }
Public WriteOnly Property MultiPurposeAccessRegisterAddressDSPAD150 As Tda10046TYPIDMULTIPURPOSEACCBDSPADLSB0
    Set
public:
property Tda10046TYPIDMULTIPURPOSEACCBDSPADLSB0 MultiPurposeAccessRegisterAddressDSPAD150 {
    void set (Tda10046TYPIDMULTIPURPOSEACCBDSPADLSB0 value);
}
member MultiPurposeAccessRegisterAddressDSPAD150 : Tda10046TYPIDMULTIPURPOSEACCBDSPADLSB0 with set

Property Value

Type: Tda10046TYPIDMULTIPURPOSEACCBDSPADLSB0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.MultiPurposeDoubleBufferDataRegisterDSPREG150 Property

IRD

Tda10046MultiPurposeDoubleBufferDataRegisterDSPREG150 Property

Multi-purpose double buffer Data Register (DSPREG[15:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MultiPurposeDoubleBufferDataRegisterDSPREG150 { get; set; }
Public Property MultiPurposeDoubleBufferDataRegisterDSPREG150 As UShort
    Get
    Set
public:
property unsigned short MultiPurposeDoubleBufferDataRegisterDSPREG150 {
    unsigned short get ();
    void set (unsigned short value);
}
member MultiPurposeDoubleBufferDataRegisterDSPREG150 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.MUXGPIOOutput0OUTSEL0 Property

IRD

Tda10046MUXGPIOOutput0OUTSEL0 Property

MUX_GPIO output0 (OUT_SEL0)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL0 MUXGPIOOutput0OUTSEL0 { set; }
Public WriteOnly Property MUXGPIOOutput0OUTSEL0 As Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL0
    Set
public:
property Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL0 MUXGPIOOutput0OUTSEL0 {
    void set (Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL0 value);
}
member MUXGPIOOutput0OUTSEL0 : Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL0 with set

Property Value

Type: Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.MUXGPIOOutput1OUTSEL1 Property

IRD

Tda10046MUXGPIOOutput1OUTSEL1 Property

MUX_GPIO output1 (OUT_SEL1)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL1 MUXGPIOOutput1OUTSEL1 { set; }
Public WriteOnly Property MUXGPIOOutput1OUTSEL1 As Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL1
    Set
public:
property Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL1 MUXGPIOOutput1OUTSEL1 {
    void set (Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL1 value);
}
member MUXGPIOOutput1OUTSEL1 : Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL1 with set

Property Value

Type: Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL1
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.MUXGPIOOutput2OUTSEL2 Property

IRD

Tda10046MUXGPIOOutput2OUTSEL2 Property

MUX_GPIO output2 (OUT_SEL2)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL2 MUXGPIOOutput2OUTSEL2 { set; }
Public WriteOnly Property MUXGPIOOutput2OUTSEL2 As Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL2
    Set
public:
property Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL2 MUXGPIOOutput2OUTSEL2 {
    void set (Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL2 value);
}
member MUXGPIOOutput2OUTSEL2 : Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL2 with set

Property Value

Type: Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL2
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.MUXGPIOOutput3OUTSEL3 Property

IRD

Tda10046MUXGPIOOutput3OUTSEL3 Property

MUX_GPIO output3 (OUT_SEL3)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL3 MUXGPIOOutput3OUTSEL3 { set; }
Public WriteOnly Property MUXGPIOOutput3OUTSEL3 As Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL3
    Set
public:
property Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL3 MUXGPIOOutput3OUTSEL3 {
    void set (Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL3 value);
}
member MUXGPIOOutput3OUTSEL3 : Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL3 with set

Property Value

Type: Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL3
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.MUXModeMUXCMD30 Property

IRD

Tda10046MUXModeMUXCMD30 Property

MUX mode (MUX_CMD[3:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDICFUNCTIONALITYICMODE0 MUXModeMUXCMD30 { set; }
Public WriteOnly Property MUXModeMUXCMD30 As Tda10046TYPIDICFUNCTIONALITYICMODE0
    Set
public:
property Tda10046TYPIDICFUNCTIONALITYICMODE0 MUXModeMUXCMD30 {
    void set (Tda10046TYPIDICFUNCTIONALITYICMODE0 value);
}
member MUXModeMUXCMD30 : Tda10046TYPIDICFUNCTIONALITYICMODE0 with set

Property Value

Type: Tda10046TYPIDICFUNCTIONALITYICMODE0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.NumberOfBitsOfTheSequenceLengthFromWhichTheViterbiOutputBitErrorRateIsComputedPVBER10 Property

IRD

Tda10046NumberOfBitsOfTheSequenceLengthFromWhichTheViterbiOutputBitErrorRateIsComputedPVBER10 Property

Number of bits of the sequence length from which the Viterbi output Bit Error Rate is computed (PVBER[1:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCHANNELBITERROROLCVBERCTRL4 NumberOfBitsOfTheSequenceLengthFromWhichTheViterbiOutputBitErrorRateIsComputedPVBER10 { set; }
Public WriteOnly Property NumberOfBitsOfTheSequenceLengthFromWhichTheViterbiOutputBitErrorRateIsComputedPVBER10 As Tda10046TYPIDCHANNELBITERROROLCVBERCTRL4
    Set
public:
property Tda10046TYPIDCHANNELBITERROROLCVBERCTRL4 NumberOfBitsOfTheSequenceLengthFromWhichTheViterbiOutputBitErrorRateIsComputedPVBER10 {
    void set (Tda10046TYPIDCHANNELBITERROROLCVBERCTRL4 value);
}
member NumberOfBitsOfTheSequenceLengthFromWhichTheViterbiOutputBitErrorRateIsComputedPVBER10 : Tda10046TYPIDCHANNELBITERROROLCVBERCTRL4 with set

Property Value

Type: Tda10046TYPIDCHANNELBITERROROLCVBERCTRL4
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.NumberOfSymbolsInInternalCBERMeasurementCPT150 Property

IRD

Tda10046NumberOfSymbolsInInternalCBERMeasurementCPT150 Property

Number of symbols in internal CBER measurement (CPT[15:0]) (unit: ms)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort NumberOfSymbolsInInternalCBERMeasurementCPT150 { get; set; }
Public Property NumberOfSymbolsInInternalCBERMeasurementCPT150 As UShort
    Get
    Set
public:
property unsigned short NumberOfSymbolsInInternalCBERMeasurementCPT150 {
    unsigned short get ();
    void set (unsigned short value);
}
member NumberOfSymbolsInInternalCBERMeasurementCPT150 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.NumberOfUncorrectablePacketsAfterMasterResetCPTU60 Property

IRD

Tda10046NumberOfUncorrectablePacketsAfterMasterResetCPTU60 Property

Number of uncorrectable packets , after master reset (CPTU[6:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte NumberOfUncorrectablePacketsAfterMasterResetCPTU60 { get; set; }
Public Property NumberOfUncorrectablePacketsAfterMasterResetCPTU60 As Byte
    Get
    Set
public:
property unsigned char NumberOfUncorrectablePacketsAfterMasterResetCPTU60 {
    unsigned char get ();
    void set (unsigned char value);
}
member NumberOfUncorrectablePacketsAfterMasterResetCPTU60 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.OCLKSOCLKClocksPresentDuringTheRedundancyBytesREDUNDCLK Property

IRD

Tda10046OCLKSOCLKClocksPresentDuringTheRedundancyBytesREDUNDCLK Property

OCLK/S_OCLK clocks present during the redundancy bytes (REDUND_CLK)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS27 OCLKSOCLKClocksPresentDuringTheRedundancyBytesREDUNDCLK { set; }
Public WriteOnly Property OCLKSOCLKClocksPresentDuringTheRedundancyBytesREDUNDCLK As Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS27
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS27 OCLKSOCLKClocksPresentDuringTheRedundancyBytesREDUNDCLK {
    void set (Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS27 value);
}
member OCLKSOCLKClocksPresentDuringTheRedundancyBytesREDUNDCLK : Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS27 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS27
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.OffsetRelativelyToTheSamplingFrequencyFREQOFFSET Property

IRD

Tda10046OffsetRelativelyToTheSamplingFrequencyFREQOFFSET Property

Offset relatively to the sampling frequency (FREQ_OFFSET) (unit: MHz)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDOFFSETRELATIVELYYFREQOFFSET0 OffsetRelativelyToTheSamplingFrequencyFREQOFFSET { set; }
Public WriteOnly Property OffsetRelativelyToTheSamplingFrequencyFREQOFFSET As Tda10046TYPIDOFFSETRELATIVELYYFREQOFFSET0
    Set
public:
property Tda10046TYPIDOFFSETRELATIVELYYFREQOFFSET0 OffsetRelativelyToTheSamplingFrequencyFREQOFFSET {
    void set (Tda10046TYPIDOFFSETRELATIVELYYFREQOFFSET0 value);
}
member OffsetRelativelyToTheSamplingFrequencyFREQOFFSET : Tda10046TYPIDOFFSETRELATIVELYYFREQOFFSET0 with set

Property Value

Type: Tda10046TYPIDOFFSETRELATIVELYYFREQOFFSET0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.OutputClockOfThePLLPLLCLKEN Property

IRD

Tda10046OutputClockOfThePLLPLLCLKEN Property

Output clock of the PLL (PLL_CLK_EN)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL12 OutputClockOfThePLLPLLCLKEN { set; }
Public WriteOnly Property OutputClockOfThePLLPLLCLKEN As Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL12
    Set
public:
property Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL12 OutputClockOfThePLLPLLCLKEN {
    void set (Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL12 value);
}
member OutputClockOfThePLLPLLCLKEN : Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL12 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL12
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.OutputClocksOCLKSOCLKInvertedPOCLK Property

IRD

Tda10046OutputClocksOCLKSOCLKInvertedPOCLK Property

Output clocks (OCLK/S_OCLK) inverted (POCLK)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS20 OutputClocksOCLKSOCLKInvertedPOCLK { set; }
Public WriteOnly Property OutputClocksOCLKSOCLKInvertedPOCLK As Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS20
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS20 OutputClocksOCLKSOCLKInvertedPOCLK {
    void set (Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS20 value);
}
member OutputClocksOCLKSOCLKInvertedPOCLK : Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS20 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS20
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.OutputSignalsDENSDENInvertedPDEN Property

IRD

Tda10046OutputSignalsDENSDENInvertedPDEN Property

Output signals DEN/S_DEN inverted (PDEN)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS21 OutputSignalsDENSDENInvertedPDEN { set; }
Public WriteOnly Property OutputSignalsDENSDENInvertedPDEN As Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS21
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS21 OutputSignalsDENSDENInvertedPDEN {
    void set (Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS21 value);
}
member OutputSignalsDENSDENInvertedPDEN : Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS21 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS21
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.OutputSignalsPSYNCSPSYNCInvertedPPSYNC Property

IRD

Tda10046OutputSignalsPSYNCSPSYNCInvertedPPSYNC Property

Output signals PSYNC/S_PSYNC inverted (PPSYNC)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS23 OutputSignalsPSYNCSPSYNCInvertedPPSYNC { set; }
Public WriteOnly Property OutputSignalsPSYNCSPSYNCInvertedPPSYNC As Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS23
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS23 OutputSignalsPSYNCSPSYNCInvertedPPSYNC {
    void set (Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS23 value);
}
member OutputSignalsPSYNCSPSYNCInvertedPPSYNC : Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS23 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS23
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.OutputSignalsUNCORSUNCORInvertedPUNCOR Property

IRD

Tda10046OutputSignalsUNCORSUNCORInvertedPUNCOR Property

Output signals UNCOR/S_UNCOR inverted (PUNCOR)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS21 OutputSignalsUNCORSUNCORInvertedPUNCOR { set; }
Public WriteOnly Property OutputSignalsUNCORSUNCORInvertedPUNCOR As Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS21
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS21 OutputSignalsUNCORSUNCORInvertedPUNCOR {
    void set (Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS21 value);
}
member OutputSignalsUNCORSUNCORInvertedPUNCOR : Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS21 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS21
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ParallelMPEG2TransportStreamSignalsZTSPAR Property

IRD

Tda10046ParallelMPEG2TransportStreamSignalsZTSPAR Property

Parallel MPEG2 Transport Stream signals (Z_TS_PAR)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13 ParallelMPEG2TransportStreamSignalsZTSPAR { set; }
Public WriteOnly Property ParallelMPEG2TransportStreamSignalsZTSPAR As Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13 ParallelMPEG2TransportStreamSignalsZTSPAR {
    void set (Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13 value);
}
member ParallelMPEG2TransportStreamSignalsZTSPAR : Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ParametersOfTheModulationAUTOTPS Property

IRD

Tda10046ParametersOfTheModulationAUTOTPS Property

Parameters of the modulation (AUTOTPS)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDAUTOMATICLOCKAUTO0 ParametersOfTheModulationAUTOTPS { set; }
Public WriteOnly Property ParametersOfTheModulationAUTOTPS As Tda10046TYPIDAUTOMATICLOCKAUTO0
    Set
public:
property Tda10046TYPIDAUTOMATICLOCKAUTO0 ParametersOfTheModulationAUTOTPS {
    void set (Tda10046TYPIDAUTOMATICLOCKAUTO0 value);
}
member ParametersOfTheModulationAUTOTPS : Tda10046TYPIDAUTOMATICLOCKAUTO0 with set

Property Value

Type: Tda10046TYPIDAUTOMATICLOCKAUTO0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.PLLIsLockedAfterBeingProgrammedPLLLock Property

IRD

Tda10046PLLIsLockedAfterBeingProgrammedPLLLock Property

PLL is locked after being programmed (PLL_lock)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS5 PLLIsLockedAfterBeingProgrammedPLLLock { get; }
Public ReadOnly Property PLLIsLockedAfterBeingProgrammedPLLLock As Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS5
    Get
public:
property Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS5 PLLIsLockedAfterBeingProgrammedPLLLock {
    Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS5 get ();
}
member PLLIsLockedAfterBeingProgrammedPLLLock : Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS5 with get

Property Value

Type: Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS5
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.PolarityOfTheMUXClockMUXPOLACLK Property

IRD

Tda10046PolarityOfTheMUXClockMUXPOLACLK Property

Polarity of the MUX clock (MUX_POLA_CLK)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDICFUNCTIONALITYICMODE1 PolarityOfTheMUXClockMUXPOLACLK { set; }
Public WriteOnly Property PolarityOfTheMUXClockMUXPOLACLK As Tda10046TYPIDICFUNCTIONALITYICMODE1
    Set
public:
property Tda10046TYPIDICFUNCTIONALITYICMODE1 PolarityOfTheMUXClockMUXPOLACLK {
    void set (Tda10046TYPIDICFUNCTIONALITYICMODE1 value);
}
member PolarityOfTheMUXClockMUXPOLACLK : Tda10046TYPIDICFUNCTIONALITYICMODE1 with set

Property Value

Type: Tda10046TYPIDICFUNCTIONALITYICMODE1
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.PowerDownModeADCPWDN Property

IRD

Tda10046PowerDownModeADCPWDN Property

Power Down Mode (ADC_PWDN)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONADCADCCONFADC5 PowerDownModeADCPWDN { set; }
Public WriteOnly Property PowerDownModeADCPWDN As Tda10046TYPIDCONFIGURATIONADCADCCONFADC5
    Set
public:
property Tda10046TYPIDCONFIGURATIONADCADCCONFADC5 PowerDownModeADCPWDN {
    void set (Tda10046TYPIDCONFIGURATIONADCADCCONFADC5 value);
}
member PowerDownModeADCPWDN : Tda10046TYPIDCONFIGURATIONADCADCCONFADC5 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONADCADCCONFADC5
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.PowerDownModePLLPWDWN Property

IRD

Tda10046PowerDownModePLLPWDWN Property

Power-Down mode (PLL_PWDWN)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL10 PowerDownModePLLPWDWN { set; }
Public WriteOnly Property PowerDownModePLLPWDWN As Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL10
    Set
public:
property Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL10 PowerDownModePLLPWDWN {
    void set (Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL10 value);
}
member PowerDownModePLLPWDWN : Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL10 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL10
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.PriorityOfTheDecodedStreamHPLP Property

IRD

Tda10046PriorityOfTheDecodedStreamHPLP Property

Priority of the decoded stream (HP/LP)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDAUTOMATICLOCKAUTO3 PriorityOfTheDecodedStreamHPLP { set; }
Public WriteOnly Property PriorityOfTheDecodedStreamHPLP As Tda10046TYPIDAUTOMATICLOCKAUTO3
    Set
public:
property Tda10046TYPIDAUTOMATICLOCKAUTO3 PriorityOfTheDecodedStreamHPLP {
    void set (Tda10046TYPIDAUTOMATICLOCKAUTO3 value);
}
member PriorityOfTheDecodedStreamHPLP : Tda10046TYPIDAUTOMATICLOCKAUTO3 with set

Property Value

Type: Tda10046TYPIDAUTOMATICLOCKAUTO3
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.PulseKillerAlgorithmUSEPK Property

IRD

Tda10046PulseKillerAlgorithmUSEPK Property

Pulse Killer algorithm (USE_PK)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10 PulseKillerAlgorithmUSEPK { set; }
Public WriteOnly Property PulseKillerAlgorithmUSEPK As Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10
    Set
public:
property Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10 PulseKillerAlgorithmUSEPK {
    void set (Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10 value);
}
member PulseKillerAlgorithmUSEPK : Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10 with set

Property Value

Type: Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.RecoveryAlgorithmTIMELOCK Property

IRD

Tda10046RecoveryAlgorithmTIMELOCK Property

Recovery algorithm (TIME_LOCK)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS1 RecoveryAlgorithmTIMELOCK { get; }
Public ReadOnly Property RecoveryAlgorithmTIMELOCK As Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS1
    Get
public:
property Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS1 RecoveryAlgorithmTIMELOCK {
    Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS1 get ();
}
member RecoveryAlgorithmTIMELOCK : Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS1 with get

Property Value

Type: Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS1
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ReedSolomonInhibitionRSI Property

IRD

Tda10046ReedSolomonInhibitionRSI Property

Reed Solomon inhibition (RSI)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C30 ReedSolomonInhibitionRSI { set; }
Public WriteOnly Property ReedSolomonInhibitionRSI As Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C30
    Set
public:
property Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C30 ReedSolomonInhibitionRSI {
    void set (Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C30 value);
}
member ReedSolomonInhibitionRSI : Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C30 with set

Property Value

Type: Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C30
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ReNormalizationGainAGCRENORM70 Property

IRD

Tda10046ReNormalizationGainAGCRENORM70 Property

Re-normalization gain (AGC_RENORM[7:0]) (unit: V)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ReNormalizationGainAGCRENORM70 { set; }
Public WriteOnly Property ReNormalizationGainAGCRENORM70 As Byte
    Set
public:
property unsigned char ReNormalizationGainAGCRENORM70 {
    void set (unsigned char value);
}
member ReNormalizationGainAGCRENORM70 : byte with set

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ResetDSPToStartItsApplicationSoftwareSTARTLOCK Property

IRD

Tda10046ResetDSPToStartItsApplicationSoftwareSTARTLOCK Property

Reset DSP to start its application software (START_LOCK)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDAUTOMATICLOCKAUTO6 ResetDSPToStartItsApplicationSoftwareSTARTLOCK { set; }
Public WriteOnly Property ResetDSPToStartItsApplicationSoftwareSTARTLOCK As Tda10046TYPIDAUTOMATICLOCKAUTO6
    Set
public:
property Tda10046TYPIDAUTOMATICLOCKAUTO6 ResetDSPToStartItsApplicationSoftwareSTARTLOCK {
    void set (Tda10046TYPIDAUTOMATICLOCKAUTO6 value);
}
member ResetDSPToStartItsApplicationSoftwareSTARTLOCK : Tda10046TYPIDAUTOMATICLOCKAUTO6 with set

Property Value

Type: Tda10046TYPIDAUTOMATICLOCKAUTO6
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ResetI2CCounterCLBUNC Property

IRD

Tda10046ResetI2CCounterCLBUNC Property

Reset I2C counter (CLBUNC)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDACTIVATEDNOTACTIVATED ResetI2CCounterCLBUNC { set; }
Public WriteOnly Property ResetI2CCounterCLBUNC As Tda10046TYPIDACTIVATEDNOTACTIVATED
    Set
public:
property Tda10046TYPIDACTIVATEDNOTACTIVATED ResetI2CCounterCLBUNC {
    void set (Tda10046TYPIDACTIVATEDNOTACTIVATED value);
}
member ResetI2CCounterCLBUNC : Tda10046TYPIDACTIVATEDNOTACTIVATED with set

Property Value

Type: Tda10046TYPIDACTIVATEDNOTACTIVATED
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ResetOfCountersInternalCBERMeasurementCLBVBER Property

IRD

Tda10046ResetOfCountersInternalCBERMeasurementCLBVBER Property

Reset of counters internal CBER measurement (CLBVBER)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDACTIVATEDNOTACTIVATED ResetOfCountersInternalCBERMeasurementCLBVBER { set; }
Public WriteOnly Property ResetOfCountersInternalCBERMeasurementCLBVBER As Tda10046TYPIDACTIVATEDNOTACTIVATED
    Set
public:
property Tda10046TYPIDACTIVATEDNOTACTIVATED ResetOfCountersInternalCBERMeasurementCLBVBER {
    void set (Tda10046TYPIDACTIVATEDNOTACTIVATED value);
}
member ResetOfCountersInternalCBERMeasurementCLBVBER : Tda10046TYPIDACTIVATEDNOTACTIVATED with set

Property Value

Type: Tda10046TYPIDACTIVATEDNOTACTIVATED
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ResetOfCountersOfInternalVBERMeasurementCLBVBER Property

IRD

Tda10046ResetOfCountersOfInternalVBERMeasurementCLBVBER Property

Reset of counters of internal VBER measurement (CLBVBER)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDACTIVATEDNOTACTIVATED ResetOfCountersOfInternalVBERMeasurementCLBVBER { set; }
Public WriteOnly Property ResetOfCountersOfInternalVBERMeasurementCLBVBER As Tda10046TYPIDACTIVATEDNOTACTIVATED
    Set
public:
property Tda10046TYPIDACTIVATEDNOTACTIVATED ResetOfCountersOfInternalVBERMeasurementCLBVBER {
    void set (Tda10046TYPIDACTIVATEDNOTACTIVATED value);
}
member ResetOfCountersOfInternalVBERMeasurementCLBVBER : Tda10046TYPIDACTIVATEDNOTACTIVATED with set

Property Value

Type: Tda10046TYPIDACTIVATEDNOTACTIVATED
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.SACLKPinZSACLK Property

IRD

Tda10046SACLKPinZSACLK Property

SACLK pin (Z_SACLK)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13 SACLKPinZSACLK { set; }
Public WriteOnly Property SACLKPinZSACLK As Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13 SACLKPinZSACLK {
    void set (Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13 value);
}
member SACLKPinZSACLK : Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.SamplingErrorCorrectionAlgorithmTIMERR70 Property

IRD

Tda10046SamplingErrorCorrectionAlgorithmTIMERR70 Property

Sampling error correction algorithm (TIMERR[7:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDTIMEERRORTIMEERROR0 SamplingErrorCorrectionAlgorithmTIMERR70 { get; set; }
Public Property SamplingErrorCorrectionAlgorithmTIMERR70 As Tda10046TYPIDTIMEERRORTIMEERROR0
    Get
    Set
public:
property Tda10046TYPIDTIMEERRORTIMEERROR0 SamplingErrorCorrectionAlgorithmTIMERR70 {
    Tda10046TYPIDTIMEERRORTIMEERROR0 get ();
    void set (Tda10046TYPIDTIMEERRORTIMEERROR0 value);
}
member SamplingErrorCorrectionAlgorithmTIMERR70 : Tda10046TYPIDTIMEERRORTIMEERROR0 with get, set

Property Value

Type: Tda10046TYPIDTIMEERRORTIMEERROR0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.SCLTUNSDATUNI2CBusConnectionBPI2CTUNEEP Property

IRD

Tda10046SCLTUNSDATUNI2CBusConnectionBPI2CTUNEEP Property

SCL_TUN/SDA_TUN I2C bus connection (BP_I2CTUNEEP)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDBYPASSIFINTERNAONS3CONFC41 SCLTUNSDATUNI2CBusConnectionBPI2CTUNEEP { set; }
Public WriteOnly Property SCLTUNSDATUNI2CBusConnectionBPI2CTUNEEP As Tda10046TYPIDBYPASSIFINTERNAONS3CONFC41
    Set
public:
property Tda10046TYPIDBYPASSIFINTERNAONS3CONFC41 SCLTUNSDATUNI2CBusConnectionBPI2CTUNEEP {
    void set (Tda10046TYPIDBYPASSIFINTERNAONS3CONFC41 value);
}
member SCLTUNSDATUNI2CBusConnectionBPI2CTUNEEP : Tda10046TYPIDBYPASSIFINTERNAONS3CONFC41 with set

Property Value

Type: Tda10046TYPIDBYPASSIFINTERNAONS3CONFC41
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.SelectsBetweenScanZappingModeZAPSCAN Property

IRD

Tda10046SelectsBetweenScanZappingModeZAPSCAN Property

Selects between scan/zapping mode (ZAP/SCAN)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDAUTOMATICLOCKAUTO5 SelectsBetweenScanZappingModeZAPSCAN { set; }
Public WriteOnly Property SelectsBetweenScanZappingModeZAPSCAN As Tda10046TYPIDAUTOMATICLOCKAUTO5
    Set
public:
property Tda10046TYPIDAUTOMATICLOCKAUTO5 SelectsBetweenScanZappingModeZAPSCAN {
    void set (Tda10046TYPIDAUTOMATICLOCKAUTO5 value);
}
member SelectsBetweenScanZappingModeZAPSCAN : Tda10046TYPIDAUTOMATICLOCKAUTO5 with set

Property Value

Type: Tda10046TYPIDAUTOMATICLOCKAUTO5
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.SequencingOfProgrammingMonitoringThePLLAUTOPLL Property

IRD

Tda10046SequencingOfProgrammingMonitoringThePLLAUTOPLL Property

Sequencing of programming/monitoring the PLL (AUTOPLL)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL13 SequencingOfProgrammingMonitoringThePLLAUTOPLL { set; }
Public WriteOnly Property SequencingOfProgrammingMonitoringThePLLAUTOPLL As Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL13
    Set
public:
property Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL13 SequencingOfProgrammingMonitoringThePLLAUTOPLL {
    void set (Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL13 value);
}
member SequencingOfProgrammingMonitoringThePLLAUTOPLL : Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL13 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL13
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.SerialMPEG2TransportStreamSignalsZTSSER Property

IRD

Tda10046SerialMPEG2TransportStreamSignalsZTSSER Property

Serial MPEG2 Transport Stream signals (Z_TS_SER)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13 SerialMPEG2TransportStreamSignalsZTSSER { set; }
Public WriteOnly Property SerialMPEG2TransportStreamSignalsZTSSER As Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13 SerialMPEG2TransportStreamSignalsZTSSER {
    void set (Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13 value);
}
member SerialMPEG2TransportStreamSignalsZTSSER : Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.SleepModeADCSLEEP Property

IRD

Tda10046SleepModeADCSLEEP Property

Sleep mode (ADC_SLEEP)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONADCADCCONFADC5 SleepModeADCSLEEP { set; }
Public WriteOnly Property SleepModeADCSLEEP As Tda10046TYPIDCONFIGURATIONADCADCCONFADC5
    Set
public:
property Tda10046TYPIDCONFIGURATIONADCADCCONFADC5 SleepModeADCSLEEP {
    void set (Tda10046TYPIDCONFIGURATIONADCADCCONFADC5 value);
}
member SleepModeADCSLEEP : Tda10046TYPIDCONFIGURATIONADCADCCONFADC5 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONADCADCCONFADC5
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.SoftResetExceptI2CRegisterCLRI2CN Property

IRD

Tda10046SoftResetExceptI2CRegisterCLRI2CN Property

Soft Reset (except I2C register) (CLR_I2C_N)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE10 SoftResetExceptI2CRegisterCLRI2CN { set; }
Public WriteOnly Property SoftResetExceptI2CRegisterCLRI2CN As Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE10
    Set
public:
property Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE10 SoftResetExceptI2CRegisterCLRI2CN {
    void set (Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE10 value);
}
member SoftResetExceptI2CRegisterCLRI2CN : Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE10 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE10
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.SpectralInversionOnTheInputSpectrumINVQ Property

IRD

Tda10046SpectralInversionOnTheInputSpectrumINVQ Property

Spectral inversion on the input spectrum (INV_Q)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10 SpectralInversionOnTheInputSpectrumINVQ { set; }
Public WriteOnly Property SpectralInversionOnTheInputSpectrumINVQ As Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10
    Set
public:
property Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10 SpectralInversionOnTheInputSpectrumINVQ {
    void set (Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10 value);
}
member SpectralInversionOnTheInputSpectrumINVQ : Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10 with set

Property Value

Type: Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.StandByOrPowerDownModeICSTDBY Property

IRD

Tda10046StandByOrPowerDownModeICSTDBY Property

Stand-by (or power-down) mode (IC_STDBY)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONADCADCCONFADC5 StandByOrPowerDownModeICSTDBY { set; }
Public WriteOnly Property StandByOrPowerDownModeICSTDBY As Tda10046TYPIDCONFIGURATIONADCADCCONFADC5
    Set
public:
property Tda10046TYPIDCONFIGURATIONADCADCCONFADC5 StandByOrPowerDownModeICSTDBY {
    void set (Tda10046TYPIDCONFIGURATIONADCADCCONFADC5 value);
}
member StandByOrPowerDownModeICSTDBY : Tda10046TYPIDCONFIGURATIONADCADCCONFADC5 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONADCADCCONFADC5
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.StaticFrequencyCorrectionPHY2150 Property

IRD

Tda10046StaticFrequencyCorrectionPHY2150 Property

Static frequency correction (PHY2[15:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort StaticFrequencyCorrectionPHY2150 { get; set; }
Public Property StaticFrequencyCorrectionPHY2150 As UShort
    Get
    Set
public:
property unsigned short StaticFrequencyCorrectionPHY2150 {
    unsigned short get ();
    void set (unsigned short value);
}
member StaticFrequencyCorrectionPHY2150 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.StatusOf16BytesOfRedundancyOfTheMPEGTSPacketsDataONRed Property

IRD

Tda10046StatusOf16BytesOfRedundancyOfTheMPEGTSPacketsDataONRed Property

Status of 16 bytes of redundancy of the MPEG-TS packets (Data_ON_red)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONMISISCCONFMISC0 StatusOf16BytesOfRedundancyOfTheMPEGTSPacketsDataONRed { set; }
Public WriteOnly Property StatusOf16BytesOfRedundancyOfTheMPEGTSPacketsDataONRed As Tda10046TYPIDCONFIGURATIONMISISCCONFMISC0
    Set
public:
property Tda10046TYPIDCONFIGURATIONMISISCCONFMISC0 StatusOf16BytesOfRedundancyOfTheMPEGTSPacketsDataONRed {
    void set (Tda10046TYPIDCONFIGURATIONMISISCCONFMISC0 value);
}
member StatusOf16BytesOfRedundancyOfTheMPEGTSPacketsDataONRed : Tda10046TYPIDCONFIGURATIONMISISCCONFMISC0 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONMISISCCONFMISC0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.SwitchTheDigitalControlOfTheTunerAGCSWITCHTUNIF Property

IRD

Tda10046SwitchTheDigitalControlOfTheTunerAGCSWITCHTUNIF Property

Switch the digital control of the tuner AGC (SWITCH_TUN_IF)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 SwitchTheDigitalControlOfTheTunerAGCSWITCHTUNIF { set; }
Public WriteOnly Property SwitchTheDigitalControlOfTheTunerAGCSWITCHTUNIF As Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0
    Set
public:
property Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 SwitchTheDigitalControlOfTheTunerAGCSWITCHTUNIF {
    void set (Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 value);
}
member SwitchTheDigitalControlOfTheTunerAGCSWITCHTUNIF : Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 with set

Property Value

Type: Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ThresholdOfTheDigitalAGCAGCTHRES70 Property

IRD

Tda10046ThresholdOfTheDigitalAGCAGCTHRES70 Property

Threshold of the digital AGC (AGC_THRES[7:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ThresholdOfTheDigitalAGCAGCTHRES70 { set; }
Public WriteOnly Property ThresholdOfTheDigitalAGCAGCTHRES70 As Byte
    Set
public:
property unsigned char ThresholdOfTheDigitalAGCAGCTHRES70 {
    void set (unsigned char value);
}
member ThresholdOfTheDigitalAGCAGCTHRES70 : byte with set

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ThresholdOfTheIFLoopForMaximumAttenuationAtTheIFLevelAGCIFMAX70 Property

IRD

Tda10046ThresholdOfTheIFLoopForMaximumAttenuationAtTheIFLevelAGCIFMAX70 Property

Threshold of the IF loop for maximum attenuation at the IF level (AGCIF_MAX[7:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ThresholdOfTheIFLoopForMaximumAttenuationAtTheIFLevelAGCIFMAX70 { set; }
Public WriteOnly Property ThresholdOfTheIFLoopForMaximumAttenuationAtTheIFLevelAGCIFMAX70 As Byte
    Set
public:
property unsigned char ThresholdOfTheIFLoopForMaximumAttenuationAtTheIFLevelAGCIFMAX70 {
    void set (unsigned char value);
}
member ThresholdOfTheIFLoopForMaximumAttenuationAtTheIFLevelAGCIFMAX70 : byte with set

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ThresholdOfTheIFLoopForMaximumAttenuationAtTheTunerLevelAGCTUNMAX70 Property

IRD

Tda10046ThresholdOfTheIFLoopForMaximumAttenuationAtTheTunerLevelAGCTUNMAX70 Property

Threshold of the 'IF' loop for maximum attenuation at the tuner level (AGCTUN_MAX[7:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ThresholdOfTheIFLoopForMaximumAttenuationAtTheTunerLevelAGCTUNMAX70 { set; }
Public WriteOnly Property ThresholdOfTheIFLoopForMaximumAttenuationAtTheTunerLevelAGCTUNMAX70 As Byte
    Set
public:
property unsigned char ThresholdOfTheIFLoopForMaximumAttenuationAtTheTunerLevelAGCTUNMAX70 {
    void set (unsigned char value);
}
member ThresholdOfTheIFLoopForMaximumAttenuationAtTheTunerLevelAGCTUNMAX70 : byte with set

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ThresholdOfTheIFLoopForMinimumAttenuationAtTheIFLevelAGCIFMIN70 Property

IRD

Tda10046ThresholdOfTheIFLoopForMinimumAttenuationAtTheIFLevelAGCIFMIN70 Property

Threshold of the IF loop for minimum attenuation at the IF level (AGCIF_MIN[7:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ThresholdOfTheIFLoopForMinimumAttenuationAtTheIFLevelAGCIFMIN70 { set; }
Public WriteOnly Property ThresholdOfTheIFLoopForMinimumAttenuationAtTheIFLevelAGCIFMIN70 As Byte
    Set
public:
property unsigned char ThresholdOfTheIFLoopForMinimumAttenuationAtTheIFLevelAGCIFMIN70 {
    void set (unsigned char value);
}
member ThresholdOfTheIFLoopForMinimumAttenuationAtTheIFLevelAGCIFMIN70 : byte with set

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ThresholdOfTheIFLoopForMinimumAttenuationAtTheTunerLevelAGCTUNMIN70 Property

IRD

Tda10046ThresholdOfTheIFLoopForMinimumAttenuationAtTheTunerLevelAGCTUNMIN70 Property

Threshold of the 'IF' loop for minimum attenuation at the tuner level (AGCTUN_MIN[7:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ThresholdOfTheIFLoopForMinimumAttenuationAtTheTunerLevelAGCTUNMIN70 { set; }
Public WriteOnly Property ThresholdOfTheIFLoopForMinimumAttenuationAtTheTunerLevelAGCTUNMIN70 As Byte
    Set
public:
property unsigned char ThresholdOfTheIFLoopForMinimumAttenuationAtTheTunerLevelAGCTUNMIN70 {
    void set (unsigned char value);
}
member ThresholdOfTheIFLoopForMinimumAttenuationAtTheTunerLevelAGCTUNMIN70 : byte with set

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.TPSInformationForTheEvenDVBTFramesEXTTPSEVEN50 Property

IRD

Tda10046TPSInformationForTheEvenDVBTFramesEXTTPSEVEN50 Property

TPS information for the even DVB-T frames (EXTTPS_EVEN[5:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TPSInformationForTheEvenDVBTFramesEXTTPSEVEN50 { get; }
Public ReadOnly Property TPSInformationForTheEvenDVBTFramesEXTTPSEVEN50 As Byte
    Get
public:
property unsigned char TPSInformationForTheEvenDVBTFramesEXTTPSEVEN50 {
    unsigned char get ();
}
member TPSInformationForTheEvenDVBTFramesEXTTPSEVEN50 : byte with get

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.TPSInformationForTheOddDVBTFramesEXTTPSODD50 Property

IRD

Tda10046TPSInformationForTheOddDVBTFramesEXTTPSODD50 Property

TPS information for the odd DVB-T frames (EXTTPS_ODD[5:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TPSInformationForTheOddDVBTFramesEXTTPSODD50 { get; }
Public ReadOnly Property TPSInformationForTheOddDVBTFramesEXTTPSODD50 As Byte
    Get
public:
property unsigned char TPSInformationForTheOddDVBTFramesEXTTPSODD50 {
    unsigned char get ();
}
member TPSInformationForTheOddDVBTFramesEXTTPSODD50 : byte with get

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.TPSInformationUsedToProvideTheTPSLengthIndicatorTPSLENGTH50 Property

IRD

Tda10046TPSInformationUsedToProvideTheTPSLengthIndicatorTPSLENGTH50 Property

TPS information used to provide the TPS length indicator (TPS_LENGTH[5:0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TPSInformationUsedToProvideTheTPSLengthIndicatorTPSLENGTH50 { get; }
Public ReadOnly Property TPSInformationUsedToProvideTheTPSLengthIndicatorTPSLENGTH50 As Byte
    Get
public:
property unsigned char TPSInformationUsedToProvideTheTPSLengthIndicatorTPSLENGTH50 {
    unsigned char get ();
}
member TPSInformationUsedToProvideTheTPSLengthIndicatorTPSLENGTH50 : byte with get

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ValueGPIO0PinGPIOIN0 Property

IRD

Tda10046ValueGPIO0PinGPIOIN0 Property

Value GPIO[0] pin (GPIO_IN[0])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ValueGPIO0PinGPIOIN0 { get; }
Public ReadOnly Property ValueGPIO0PinGPIOIN0 As Byte
    Get
public:
property unsigned char ValueGPIO0PinGPIOIN0 {
    unsigned char get ();
}
member ValueGPIO0PinGPIOIN0 : byte with get

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ValueGPIO1PinGPIOIN1 Property

IRD

Tda10046ValueGPIO1PinGPIOIN1 Property

Value GPIO[1] pin (GPIO_IN[1])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ValueGPIO1PinGPIOIN1 { get; }
Public ReadOnly Property ValueGPIO1PinGPIOIN1 As Byte
    Get
public:
property unsigned char ValueGPIO1PinGPIOIN1 {
    unsigned char get ();
}
member ValueGPIO1PinGPIOIN1 : byte with get

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ValueGPIO2PinGPIOIN2 Property

IRD

Tda10046ValueGPIO2PinGPIOIN2 Property

Value GPIO[2] pin (GPIO_IN[2])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ValueGPIO2PinGPIOIN2 { get; }
Public ReadOnly Property ValueGPIO2PinGPIOIN2 As Byte
    Get
public:
property unsigned char ValueGPIO2PinGPIOIN2 {
    unsigned char get ();
}
member ValueGPIO2PinGPIOIN2 : byte with get

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.ValueGPIO3PinGPIOIN3 Property

IRD

Tda10046ValueGPIO3PinGPIOIN3 Property

Value GPIO[3] pin (GPIO_IN[3])

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ValueGPIO3PinGPIOIN3 { get; }
Public ReadOnly Property ValueGPIO3PinGPIOIN3 As Byte
    Get
public:
property unsigned char ValueGPIO3PinGPIOIN3 {
    unsigned char get ();
}
member ValueGPIO3PinGPIOIN3 : byte with get

Property Value

Type: Byte
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.VBERRefreshedITVBER Property

IRD

Tda10046VBERRefreshedITVBER Property

VBER refreshed (ITVBER)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDCHANNELBITERROROLCVBERCTRL2 VBERRefreshedITVBER { get; set; }
Public Property VBERRefreshedITVBER As Tda10046TYPIDCHANNELBITERROROLCVBERCTRL2
    Get
    Set
public:
property Tda10046TYPIDCHANNELBITERROROLCVBERCTRL2 VBERRefreshedITVBER {
    Tda10046TYPIDCHANNELBITERROROLCVBERCTRL2 get ();
    void set (Tda10046TYPIDCHANNELBITERROROLCVBERCTRL2 value);
}
member VBERRefreshedITVBER : Tda10046TYPIDCHANNELBITERROROLCVBERCTRL2 with get, set

Property Value

Type: Tda10046TYPIDCHANNELBITERROROLCVBERCTRL2
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.WatchdogTimerDSPWD Property

IRD

Tda10046WatchdogTimerDSPWD Property

Watchdog Timer (DSP_WD)

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tda10046TYPIDBYPASSIFINTERNAONS3CONFC45 WatchdogTimerDSPWD { set; }
Public WriteOnly Property WatchdogTimerDSPWD As Tda10046TYPIDBYPASSIFINTERNAONS3CONFC45
    Set
public:
property Tda10046TYPIDBYPASSIFINTERNAONS3CONFC45 WatchdogTimerDSPWD {
    void set (Tda10046TYPIDBYPASSIFINTERNAONS3CONFC45 value);
}
member WatchdogTimerDSPWD : Tda10046TYPIDBYPASSIFINTERNAONS3CONFC45 with set

Property Value

Type: Tda10046TYPIDBYPASSIFINTERNAONS3CONFC45
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046 Methods

The Tda10046 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.Flush Method

IRD

Tda10046Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Tda10046 Class
telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDACTIVATEDNOTACTIVATED Enumeration

IRD

Tda10046TYPIDACTIVATEDNOTACTIVATED Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDACTIVATEDNOTACTIVATED
Public Enumeration TYPIDACTIVATEDNOTACTIVATED
public enum class TYPIDACTIVATEDNOTACTIVATED
type TYPIDACTIVATEDNOTACTIVATED
Members
Member name | Value | Description
Activated | 0 | Activated
NotActivated | 1 | Not activated
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDAGCLOOPGAINAGCGAINS0 Enumeration

IRD

Tda10046TYPIDAGCLOOPGAINAGCGAINS0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDAGCLOOPGAINAGCGAINS0
Public Enumeration TYPIDAGCLOOPGAINAGCGAINS0
public enum class TYPIDAGCLOOPGAINAGCGAINS0
type TYPIDAGCLOOPGAINAGCGAINS0
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_2 | 1 | 2
Value_4Default | 2 | 4 (default)
Value_8 | 3 | 8
Value_16 | 4 | 16
Value_32 | 5 | 32
Value_64 | 6 | 64
Value_128 | 7 | 128
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDAUTOMATICLOCKAUTO0 Enumeration

IRD

Tda10046TYPIDAUTOMATICLOCKAUTO0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDAUTOMATICLOCKAUTO0
Public Enumeration TYPIDAUTOMATICLOCKAUTO0
public enum class TYPIDAUTOMATICLOCKAUTO0
type TYPIDAUTOMATICLOCKAUTO0
Members
Member name | Value | Description
SetByConsAlphaRlRh | 0 | Set by 'Cons', 'alpha', 'rl', 'rh'
ExtractedFromTheTPSStreamDefault | 1 | Extracted from the TPS stream (default)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDAUTOMATICLOCKAUTO1 Enumeration

IRD

Tda10046TYPIDAUTOMATICLOCKAUTO1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDAUTOMATICLOCKAUTO1
Public Enumeration TYPIDAUTOMATICLOCKAUTO1
public enum class TYPIDAUTOMATICLOCKAUTO1
type TYPIDAUTOMATICLOCKAUTO1
Members
Member name | Value | Description
SetByDelta | 0 | Set by 'delta'
AutomaticallyFoundAndSetDefault | 1 | Automatically found and set (default)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDAUTOMATICLOCKAUTO2 Enumeration

IRD

Tda10046TYPIDAUTOMATICLOCKAUTO2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDAUTOMATICLOCKAUTO2
Public Enumeration TYPIDAUTOMATICLOCKAUTO2
public enum class TYPIDAUTOMATICLOCKAUTO2
type TYPIDAUTOMATICLOCKAUTO2
Members
Member name | Value | Description
SetByCnf2K8K | 0 | Set by 'cnf2K8K'
AutomaticallyFoundAndSet | 1 | Automatically found and set
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDAUTOMATICLOCKAUTO3 Enumeration

IRD

Tda10046TYPIDAUTOMATICLOCKAUTO3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDAUTOMATICLOCKAUTO3
Public Enumeration TYPIDAUTOMATICLOCKAUTO3
public enum class TYPIDAUTOMATICLOCKAUTO3
type TYPIDAUTOMATICLOCKAUTO3
Members
Member name | Value | Description
HighPriorityHPDefault | 0 | High priority, HP (default)
LowPriorityLP | 1 | Low priority, LP
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDAUTOMATICLOCKAUTO4 Enumeration

IRD

Tda10046TYPIDAUTOMATICLOCKAUTO4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDAUTOMATICLOCKAUTO4
Public Enumeration TYPIDAUTOMATICLOCKAUTO4
public enum class TYPIDAUTOMATICLOCKAUTO4
type TYPIDAUTOMATICLOCKAUTO4
Members
Member name | Value | Description
TakesIntoAccountTheOffsetValueWrittenInOffsetDefault | 0 | Takes into account the offset value written in 'offset' (default)
FindsFrequencyOffsetOfTheDVBTSignalAutomatically | 1 | Finds frequency offset of the DVB-T signal automatically
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDAUTOMATICLOCKAUTO5 Enumeration

IRD

Tda10046TYPIDAUTOMATICLOCKAUTO5 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDAUTOMATICLOCKAUTO5
Public Enumeration TYPIDAUTOMATICLOCKAUTO5
public enum class TYPIDAUTOMATICLOCKAUTO5
type TYPIDAUTOMATICLOCKAUTO5
Members
Member name | Value | Description
ScanModeDefault | 0 | Scan mode (default)
ZappingMode | 1 | Zapping mode
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDAUTOMATICLOCKAUTO6 Enumeration

IRD

Tda10046TYPIDAUTOMATICLOCKAUTO6 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDAUTOMATICLOCKAUTO6
Public Enumeration TYPIDAUTOMATICLOCKAUTO6
public enum class TYPIDAUTOMATICLOCKAUTO6
type TYPIDAUTOMATICLOCKAUTO6
Members
Member name | Value | Description
ResetsTheDSP | 0 | Resets the DSP
NoReset | 1 | No Reset
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDAUTOMATICLOCKAUTO7 Enumeration

IRD

Tda10046TYPIDAUTOMATICLOCKAUTO7 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDAUTOMATICLOCKAUTO7
Public Enumeration TYPIDAUTOMATICLOCKAUTO7
public enum class TYPIDAUTOMATICLOCKAUTO7
type TYPIDAUTOMATICLOCKAUTO7
Members
Member name | Value | Description
Value_50PpmDefault | 0 | +/- 50 ppm (default)
Value_100Ppm | 1 | +/- 100 ppm
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDBYPASSIFINTERNAONS1CONFC10 Enumeration

IRD

Tda10046TYPIDBYPASSIFINTERNAONS1CONFC10 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDBYPASSIFINTERNAONS1CONFC10
Public Enumeration TYPIDBYPASSIFINTERNAONS1CONFC10
public enum class TYPIDBYPASSIFINTERNAONS1CONFC10
type TYPIDBYPASSIFINTERNAONS1CONFC10
Members
Member name | Value | Description
NotActivatedDefaultValue | 0 | Not activated (default value)
Activated | 1 | Activated
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDBYPASSIFINTERNAONS3CONFC41 Enumeration

IRD

Tda10046TYPIDBYPASSIFINTERNAONS3CONFC41 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDBYPASSIFINTERNAONS3CONFC41
Public Enumeration TYPIDBYPASSIFINTERNAONS3CONFC41
public enum class TYPIDBYPASSIFINTERNAONS3CONFC41
type TYPIDBYPASSIFINTERNAONS3CONFC41
Members
Member name | Value | Description
TriStatedDefault | 0 | Tri-stated (default)
ConnectedToTheMaster | 1 | Connected to the master
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDBYPASSIFINTERNAONS3CONFC42 Enumeration

IRD

Tda10046TYPIDBYPASSIFINTERNAONS3CONFC42 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDBYPASSIFINTERNAONS3CONFC42
Public Enumeration TYPIDBYPASSIFINTERNAONS3CONFC42
public enum class TYPIDBYPASSIFINTERNAONS3CONFC42
type TYPIDBYPASSIFINTERNAONS3CONFC42
Members
Member name | Value | Description
NotInitiated | 0 | Not initiated
Initiated | 1 | Initiated
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDBYPASSIFINTERNAONS3CONFC44 Enumeration

IRD

Tda10046TYPIDBYPASSIFINTERNAONS3CONFC44 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDBYPASSIFINTERNAONS3CONFC44
Public Enumeration TYPIDBYPASSIFINTERNAONS3CONFC44
public enum class TYPIDBYPASSIFINTERNAONS3CONFC44
type TYPIDBYPASSIFINTERNAONS3CONFC44
Members
Member name | Value | Description
R | 0 | R
W | 1 | W
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDBYPASSIFINTERNAONS3CONFC45 Enumeration

IRD

Tda10046TYPIDBYPASSIFINTERNAONS3CONFC45 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDBYPASSIFINTERNAONS3CONFC45
Public Enumeration TYPIDBYPASSIFINTERNAONS3CONFC45
public enum class TYPIDBYPASSIFINTERNAONS3CONFC45
type TYPIDBYPASSIFINTERNAONS3CONFC45
Members
Member name | Value | Description
DisabledDefault | 0 | Disabled (default)
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDBYPASSIFINTERNAONS3CONFC46 Enumeration

IRD

Tda10046TYPIDBYPASSIFINTERNAONS3CONFC46 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDBYPASSIFINTERNAONS3CONFC46
Public Enumeration TYPIDBYPASSIFINTERNAONS3CONFC46
public enum class TYPIDBYPASSIFINTERNAONS3CONFC46
type TYPIDBYPASSIFINTERNAONS3CONFC46
Members
Member name | Value | Description
Value_400Default | 0 | ~400 (default)
Value_200 | 1 | ~200
Value_100 | 2 | ~100
Value_50 | 3 | ~50
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDBYPASSIFINTERNAS2CONFC2C30 Enumeration

IRD

Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C30 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDBYPASSIFINTERNAS2CONFC2C30
Public Enumeration TYPIDBYPASSIFINTERNAS2CONFC2C30
public enum class TYPIDBYPASSIFINTERNAS2CONFC2C30
type TYPIDBYPASSIFINTERNAS2CONFC2C30
Members
Member name | Value | Description
NotActivatedValidatedDefault | 0 | Not activated/validated (default)
Activated | 1 | Activated
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDBYPASSIFINTERNAS2CONFC2C34 Enumeration

IRD

Tda10046TYPIDBYPASSIFINTERNAS2CONFC2C34 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDBYPASSIFINTERNAS2CONFC2C34
Public Enumeration TYPIDBYPASSIFINTERNAS2CONFC2C34
public enum class TYPIDBYPASSIFINTERNAS2CONFC2C34
type TYPIDBYPASSIFINTERNAS2CONFC2C34
Members
Member name | Value | Description
MostCloselyToTheCurrentEchoProfileDefault | 0 | Most closely to the current echo profile (default)
SizedForeverToTheWorstCaseEchoProfileDuration | 1 | Sized 'forever' to the worst-case echo profile duration
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCHANNELBITERROROLCVBERCTRL0 Enumeration

IRD

Tda10046TYPIDCHANNELBITERROROLCVBERCTRL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHANNELBITERROROLCVBERCTRL0
Public Enumeration TYPIDCHANNELBITERROROLCVBERCTRL0
public enum class TYPIDCHANNELBITERROROLCVBERCTRL0
type TYPIDCHANNELBITERROROLCVBERCTRL0
Members
Member name | Value | Description
NotRefreshed | 0 | Not refreshed
Refreshed | 1 | Refreshed
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCHANNELBITERROROLCVBERCTRL2 Enumeration

IRD

Tda10046TYPIDCHANNELBITERROROLCVBERCTRL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHANNELBITERROROLCVBERCTRL2
Public Enumeration TYPIDCHANNELBITERROROLCVBERCTRL2
public enum class TYPIDCHANNELBITERROROLCVBERCTRL2
type TYPIDCHANNELBITERROROLCVBERCTRL2
Members
Member name | Value | Description
NotRefreshed | 0 | Not refreshed
Refreshed | 1 | Refreshed
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCHANNELBITERROROLCVBERCTRL4 Enumeration

IRD

Tda10046TYPIDCHANNELBITERROROLCVBERCTRL4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHANNELBITERROROLCVBERCTRL4
Public Enumeration TYPIDCHANNELBITERROROLCVBERCTRL4
public enum class TYPIDCHANNELBITERROROLCVBERCTRL4
type TYPIDCHANNELBITERROROLCVBERCTRL4
Members
Member name | Value | Description
Value_99552 | 0 | 99 552
Value_1000416 | 1 | 1 000 416
Value_9999264Default | 2 | 9 999 264 (default)
Value_100000800 | 3 | 100 000 800
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCHANNELBITERRORPUTCVBERLUT0 Enumeration

IRD

Tda10046TYPIDCHANNELBITERRORPUTCVBERLUT0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHANNELBITERRORPUTCVBERLUT0
Public Enumeration TYPIDCHANNELBITERRORPUTCVBERLUT0
public enum class TYPIDCHANNELBITERRORPUTCVBERLUT0
type TYPIDCHANNELBITERRORPUTCVBERLUT0
Members
Member name | Value | Description
Cber10E1 | 0 | Cber=10E-1..
Cber90E210E1 | 1 | Cber=9.0E-2..10E-1
Cber80E290E2 | 2 | Cber=8.0E-2..9.0E-2
Cber70E280E2 | 3 | Cber=7.0E-2..8.0E-2
Cber60E270E2 | 4 | Cber=6.0E-2..7.0E-2
Cber50E260E2 | 5 | Cber=5.0E-2..6.0E-2
Cber40E250E2 | 6 | Cber=4.0E-2..5.0E-2
Cber30E240E2 | 7 | Cber=3.0E-2..4.0E-2
Cber25E230E2 | 8 | Cber=2.5E-2..3.0E-2
Cber17E225E2 | 9 | Cber=1.7E-2..2.5E-2
Cber13E217E2 | 10 | Cber=1.3E-2..1.7E-2
Cber10E213E2 | 11 | Cber=1.0E-2..1.3E-2
Cber70E310E2 | 12 | Cber=7.0E-3..1.0E-2
Cber55E370E3 | 13 | Cber=5.5E-3..7.0E-3
Cber30E355E3 | 14 | Cber=3.0E-3..5.5E-3
Cber15E330E3 | 15 | Cber=1.5E-3..3.0E-3
Cber10E315E3 | 16 | Cber=1.0E-3..1.5E-3
Cber55E410E3 | 17 | Cber=5.5E-4..1.0E-3
Cber30E455E4 | 18 | Cber=3.0E-4..5.5E-4
Cber15E430E4 | 19 | Cber=1.5E-4..3.0E-4
Cber60E515E4 | 20 | Cber=6.0E-5..1.5E-4
Cber30E560E5 | 21 | Cber=3.0E-5..6.0E-5
Cber10E530E5 | 22 | Cber=1.0E-5..3.0E-5
Cber40E610E5 | 23 | Cber=4.0E-6..1.0E-5
Cber10E640E6 | 24 | Cber=1.0E-6..4.0E-6
Cber10E6 | 25 | Cber=..1.0E-6
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCHANNELBITERRORPUTCVBERLUT1 Enumeration

IRD

Tda10046TYPIDCHANNELBITERRORPUTCVBERLUT1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHANNELBITERRORPUTCVBERLUT1
Public Enumeration TYPIDCHANNELBITERRORPUTCVBERLUT1
public enum class TYPIDCHANNELBITERRORPUTCVBERLUT1
type TYPIDCHANNELBITERRORPUTCVBERLUT1
Members
Member name | Value | Description
Value_10E2 | 0 | 10E-2..
Value_10E210E3 | 1 | 10E-2..10E-3
Value_10E310E4 | 2 | 10E-3..10E-4
Value_10E4 | 3 | ..10E-4
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCHANNELINFORMATICHANNELINFO10 Enumeration

IRD

Tda10046TYPIDCHANNELINFORMATICHANNELINFO10 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHANNELINFORMATICHANNELINFO10
Public Enumeration TYPIDCHANNELINFORMATICHANNELINFO10
public enum class TYPIDCHANNELINFORMATICHANNELINFO10
type TYPIDCHANNELINFORMATICHANNELINFO10
Members
Member name | Value | Description
Narrower | 0 | Narrower
Wider | 1 | Wider
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCHANNELINFORMATICHANNELINFO11 Enumeration

IRD

Tda10046TYPIDCHANNELINFORMATICHANNELINFO11 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCHANNELINFORMATICHANNELINFO11
Public Enumeration TYPIDCHANNELINFORMATICHANNELINFO11
public enum class TYPIDCHANNELINFORMATICHANNELINFO11
type TYPIDCHANNELINFORMATICHANNELINFO11
Members
Member name | Value | Description
DemodulationPerformancesNotOptimized | 0 | Demodulation performances not optimized
DemodulationPerformancesOptimized | 1 | Demodulation performances optimized
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONADCADCCONFADC0 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONADCADCCONFADC0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONADCADCCONFADC0
Public Enumeration TYPIDCONFIGURATIONADCADCCONFADC0
public enum class TYPIDCONFIGURATIONADCADCCONFADC0
type TYPIDCONFIGURATIONADCADCCONFADC0
Members
Member name | Value | Description
VRangeGain20V0DBDefault | 0 | VRange/Gain: 2.0 V/0 dB (default)
VRangeGain10V6DB | 1 | VRange/Gain: 1.0 V/6 dB
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONADCADCCONFADC1 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONADCADCCONFADC1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONADCADCCONFADC1
Public Enumeration TYPIDCONFIGURATIONADCADCCONFADC1
public enum class TYPIDCONFIGURATIONADCADCCONFADC1
type TYPIDCONFIGURATIONADCADCCONFADC1
Members
Member name | Value | Description
ACCoupleDefault | 0 | AC-couple (default)
DCCouple | 1 | DC-couple
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONADCADCCONFADC2 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONADCADCCONFADC2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONADCADCCONFADC2
Public Enumeration TYPIDCONFIGURATIONADCADCCONFADC2
public enum class TYPIDCONFIGURATIONADCADCCONFADC2
type TYPIDCONFIGURATIONADCADCCONFADC2
Members
Member name | Value | Description
CurrentRatioRecommendedFsamp02530MHz | 0 | Current ratio/recommended Fsamp: 0.25/30 MHz
CurrentRatioRecommendedFsamp0550MHzDefault | 1 | Current ratio/recommended Fsamp: 0.5/50 MHz (default)
CurrentRatioRecommendedFsamp1075MHz | 2 | Current ratio/recommended Fsamp: 1.0/75 MHz
CurrentRatioRecommendedFsamp1590MHz | 3 | Current ratio/recommended Fsamp: 1.5/90 MHz
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONADCADCCONFADC3 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONADCADCCONFADC3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONADCADCCONFADC3
Public Enumeration TYPIDCONFIGURATIONADCADCCONFADC3
public enum class TYPIDCONFIGURATIONADCADCCONFADC3
type TYPIDCONFIGURATIONADCADCCONFADC3
Members
Member name | Value | Description
Digital10BitMaxIFFromAnExternalADCSampledBySACLK | 0 | Digital 10-bit (max) IF from an external ADC sampled by SACLK
AnalogIFSampledByThe10BitInternalADCDefault | 1 | Analog IF sampled by the 10-bit internal ADC (default)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONADCADCCONFADC4 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONADCADCCONFADC4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONADCADCCONFADC4
Public Enumeration TYPIDCONFIGURATIONADCADCCONFADC4
public enum class TYPIDCONFIGURATIONADCADCCONFADC4
type TYPIDCONFIGURATIONADCADCCONFADC4
Members
Member name | Value | Description
OffsetBinary | 0 | Offset binary
Value_2SComplementDefault | 1 | 2's complement (default)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONADCADCCONFADC5 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONADCADCCONFADC5 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONADCADCCONFADC5
Public Enumeration TYPIDCONFIGURATIONADCADCCONFADC5
public enum class TYPIDCONFIGURATIONADCADCCONFADC5
type TYPIDCONFIGURATIONADCADCCONFADC5
Members
Member name | Value | Description
NotSetDefault | 0 | Not set (default)
Set | 1 | Set
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONMISISCCONFMISC0 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONMISISCCONFMISC0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONMISISCCONFMISC0
Public Enumeration TYPIDCONFIGURATIONMISISCCONFMISC0
public enum class TYPIDCONFIGURATIONMISISCCONFMISC0
type TYPIDCONFIGURATIONMISISCCONFMISC0
Members
Member name | Value | Description
SetTo0 | 0 | Set to '0'
LetAsTheyAreDefault | 1 | Let as they are (default)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONMISISCCONFMISC1 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONMISISCCONFMISC1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONMISISCCONFMISC1
Public Enumeration TYPIDCONFIGURATIONMISISCCONFMISC1
public enum class TYPIDCONFIGURATIONMISISCCONFMISC1
type TYPIDCONFIGURATIONMISISCCONFMISC1
Members
Member name | Value | Description
DeclaredUncorrectable | 0 | Declared uncorrectable
RemainUnchangedDefault | 1 | Remain unchanged (default)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONPLLL1CONFPLL10 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL10 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONPLLL1CONFPLL10
Public Enumeration TYPIDCONFIGURATIONPLLL1CONFPLL10
public enum class TYPIDCONFIGURATIONPLLL1CONFPLL10
type TYPIDCONFIGURATIONPLLL1CONFPLL10
Members
Member name | Value | Description
PLLNoPowerDownMode | 0 | PLL: No Power-Down mode
AutoPLL0PLLPowerDownModeDefaultValue | 1 | Auto PLL=0: PLL: Power-Down mode (default value)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONPLLL1CONFPLL11 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL11 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONPLLL1CONFPLL11
Public Enumeration TYPIDCONFIGURATIONPLLL1CONFPLL11
public enum class TYPIDCONFIGURATIONPLLL1CONFPLL11
type TYPIDCONFIGURATIONPLLL1CONFPLL11
Members
Member name | Value | Description
NotProvided | 0 | Not provided
AutoPLL0ProvidedDefaultValue | 1 | AutoPLL=0: provided (default value)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONPLLL1CONFPLL12 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL12 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONPLLL1CONFPLL12
Public Enumeration TYPIDCONFIGURATIONPLLL1CONFPLL12
public enum class TYPIDCONFIGURATIONPLLL1CONFPLL12
type TYPIDCONFIGURATIONPLLL1CONFPLL12
Members
Member name | Value | Description
NotEnabled | 0 | Not enabled
AutoPLL0EnabledIfNotInPowerDownModeDefaultValue | 1 | AutoPLL=0: enabled (if not in Power-Down mode) (default value)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONPLLL1CONFPLL13 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONPLLL1CONFPLL13 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONPLLL1CONFPLL13
Public Enumeration TYPIDCONFIGURATIONPLLL1CONFPLL13
public enum class TYPIDCONFIGURATIONPLLL1CONFPLL13
type TYPIDCONFIGURATIONPLLL1CONFPLL13
Members
Member name | Value | Description
HandledManually | 0 | Handled manually
HandledAutomaticallyDefaultValue | 1 | Handled automatically (default value)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONPOLCONFPOLARITY0 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONPOLCONFPOLARITY0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONPOLCONFPOLARITY0
Public Enumeration TYPIDCONFIGURATIONPOLCONFPOLARITY0
public enum class TYPIDCONFIGURATIONPOLCONFPOLARITY0
type TYPIDCONFIGURATIONPOLCONFPOLARITY0
Members
Member name | Value | Description
NotAllowedDefault | 0 | Not allowed (default)
Allowed | 1 | Allowed
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONTRAAM1CONFTS11 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONTRAAM1CONFTS11 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONTRAAM1CONFTS11
Public Enumeration TYPIDCONFIGURATIONTRAAM1CONFTS11
public enum class TYPIDCONFIGURATIONTRAAM1CONFTS11
type TYPIDCONFIGURATIONTRAAM1CONFTS11
Members
Member name | Value | Description
ModeADefault | 0 | Mode A (default)
ModeB | 1 | Mode B
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONTRAAM2CONFTS20 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS20 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONTRAAM2CONFTS20
Public Enumeration TYPIDCONFIGURATIONTRAAM2CONFTS20
public enum class TYPIDCONFIGURATIONTRAAM2CONFTS20
type TYPIDCONFIGURATIONTRAAM2CONFTS20
Members
Member name | Value | Description
RisingFallingEdgeInOutputDataForModeABDefault | 0 | Rising/falling edge in output data for mode A/B (default)
RisingFallingEdgeInOutputDataForModeBA | 1 | Rising/falling edge in output data for mode B/A
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONTRAAM2CONFTS21 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS21 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONTRAAM2CONFTS21
Public Enumeration TYPIDCONFIGURATIONTRAAM2CONFTS21
public enum class TYPIDCONFIGURATIONTRAAM2CONFTS21
type TYPIDCONFIGURATIONTRAAM2CONFTS21
Members
Member name | Value | Description
NotInvertedHighLowFor18816BytesDefault | 0 | Not inverted: high/low for 188/16 bytes (default)
InvertedLowHighFor18816Bytes | 1 | Inverted: low/high for 188/16 bytes
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONTRAAM2CONFTS23 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS23 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONTRAAM2CONFTS23
Public Enumeration TYPIDCONFIGURATIONTRAAM2CONFTS23
public enum class TYPIDCONFIGURATIONTRAAM2CONFTS23
type TYPIDCONFIGURATIONTRAAM2CONFTS23
Members
Member name | Value | Description
NotInvertedHighLowForTheFirstByteOfPacket203RemainingBytesDefault | 0 | Not inverted: high/low for the first byte of packet/203 remaining bytes (default)
NotInvertedLowHighForTheFirstByteOfPacket203RemainingBytes | 1 | Not inverted: low/high for the first byte of packet/203 remaining bytes
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONTRAAM2CONFTS24 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS24 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONTRAAM2CONFTS24
Public Enumeration TYPIDCONFIGURATIONTRAAM2CONFTS24
public enum class TYPIDCONFIGURATIONTRAAM2CONFTS24
type TYPIDCONFIGURATIONTRAAM2CONFTS24
Members
Member name | Value | Description
ParallelStreamDefault | 0 | Parallel stream (default)
SerialStream | 1 | Serial stream
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONTRAAM2CONFTS25 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS25 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONTRAAM2CONFTS25
Public Enumeration TYPIDCONFIGURATIONTRAAM2CONFTS25
public enum class TYPIDCONFIGURATIONTRAAM2CONFTS25
type TYPIDCONFIGURATIONTRAAM2CONFTS25
Members
Member name | Value | Description
MSBFirstDefault | 0 | MSB first (default)
LSBFirst | 1 | LSB first
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONTRAAM2CONFTS26 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS26 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONTRAAM2CONFTS26
Public Enumeration TYPIDCONFIGURATIONTRAAM2CONFTS26
public enum class TYPIDCONFIGURATIONTRAAM2CONFTS26
type TYPIDCONFIGURATIONTRAAM2CONFTS26
Members
Member name | Value | Description
WholeBitsOfFirstByte | 0 | Whole bits of first byte
FirstBitOnlyOfFirstByteDefault | 1 | First bit only of first byte (default)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONTRAAM2CONFTS27 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONTRAAM2CONFTS27 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONTRAAM2CONFTS27
Public Enumeration TYPIDCONFIGURATIONTRAAM2CONFTS27
public enum class TYPIDCONFIGURATIONTRAAM2CONFTS27
type TYPIDCONFIGURATIONTRAAM2CONFTS27
Members
Member name | Value | Description
NotPresent | 0 | Not present
PresentDefault | 1 | Present (default)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONTRICONFTRISTATE10 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE10 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONTRICONFTRISTATE10
Public Enumeration TYPIDCONFIGURATIONTRICONFTRISTATE10
public enum class TYPIDCONFIGURATIONTRICONFTRISTATE10
type TYPIDCONFIGURATIONTRICONFTRISTATE10
Members
Member name | Value | Description
ResetBecomesActive | 0 | Reset becomes active
ResetNotActiveDefault | 1 | Reset not active (default)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONTRICONFTRISTATE11 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE11 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONTRICONFTRISTATE11
Public Enumeration TYPIDCONFIGURATIONTRICONFTRISTATE11
public enum class TYPIDCONFIGURATIONTRICONFTRISTATE11
type TYPIDCONFIGURATIONTRICONFTRISTATE11
Members
Member name | Value | Description
ItIsAPushPullDriveOutputFor33VOutputLevel | 0 | It is a push-pull drive output (for 3.3 V output level)
Reserved | 1 | Reserved
IsAnOpendrainLikeOutputFor5VOutputLevel | 2 | Is an opendrain like-output (for 5 V output level)
TheAGCIFPinIsForcedToTriStateModeDefaultValue | 3 | The AGC_IF pin is forced to tri-state mode (default value)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONTRICONFTRISTATE13 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE13 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONTRICONFTRISTATE13
Public Enumeration TYPIDCONFIGURATIONTRICONFTRISTATE13
public enum class TYPIDCONFIGURATIONTRICONFTRISTATE13
type TYPIDCONFIGURATIONTRICONFTRISTATE13
Members
Member name | Value | Description
PushPullDriveOutput | 0 | Push-pull drive output
PinIsForcedToTriStateModeDefaultValue | 1 | Pin is forced to tri-state mode (default value)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDCONFIGURATIONTRICONFTRISTATE20 Enumeration

IRD

Tda10046TYPIDCONFIGURATIONTRICONFTRISTATE20 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDCONFIGURATIONTRICONFTRISTATE20
Public Enumeration TYPIDCONFIGURATIONTRICONFTRISTATE20
public enum class TYPIDCONFIGURATIONTRICONFTRISTATE20
type TYPIDCONFIGURATIONTRICONFTRISTATE20
Members
Member name | Value | Description
PushPullDriveOutputFor33VOutputLevel | 0 | Push-pull drive output (for 3.3 V output level).
Input | 1 | Input
OpendrainLikeOutputFor5VOutputLevel | 2 | Opendrain like-output (for 5 V output level).
ForcedToTriStateModeDefaultValue | 3 | Forced to tri-state mode (default value)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDDIGITALAGCLEVELDIGAGCLEVEL0 Enumeration

IRD

Tda10046TYPIDDIGITALAGCLEVELDIGAGCLEVEL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDDIGITALAGCLEVELDIGAGCLEVEL0
Public Enumeration TYPIDDIGITALAGCLEVELDIGAGCLEVEL0
public enum class TYPIDDIGITALAGCLEVELDIGAGCLEVEL0
type TYPIDDIGITALAGCLEVELDIGAGCLEVEL0
Members
Member name | Value | Description
Invalid | 0 | Invalid
Value_M_12_04 | 5 | -12.04
Value_M_6_02 | 6 | -6.02
Value_M_2_50 | 7 | -2.50
Value_0_00 | 8 | 0.00
Value_1_94 | 9 | 1.94
Value_3_52 | 10 | 3.52
Value_4_86 | 11 | 4.86
Value_6_02 | 12 | 6.02
Value_7_04 | 13 | 7.04
Value_7_96 | 14 | 7.96
Value_8_79 | 15 | 8.79
Value_9_54 | 16 | 9.54
Value_10_24 | 17 | 10.24
Value_10_88 | 18 | 10.88
Value_11_48 | 19 | 11.48
Value_12_04 | 20 | 12.04
Value_12_57 | 21 | 12.57
Value_13_06 | 22 | 13.06
Value_13_53 | 23 | 13.53
Value_13_98 | 24 | 13.98
Value_14_40 | 25 | 14.40
Value_14_81 | 26 | 14.81
Value_15_19 | 27 | 15.19
Value_15_56 | 28 | 15.56
Value_15_92 | 29 | 15.92
Value_16_26 | 30 | 16.26
Value_16_59 | 31 | 16.59
Value_16_90 | 32 | 16.90
Value_17_21 | 33 | 17.21
Value_17_50 | 34 | 17.50
Value_17_79 | 35 | 17.79
Value_18_06 | 36 | 18.06
Value_18_33 | 37 | 18.33
Value_18_59 | 38 | 18.59
Value_18_84 | 39 | 18.84
Value_19_08 | 40 | 19.08
Value_19_32 | 41 | 19.32
Value_19_55 | 42 | 19.55
Value_19_78 | 43 | 19.78
Value_20_00 | 44 | 20.00
Value_20_21 | 45 | 20.21
Value_20_42 | 46 | 20.42
Value_20_63 | 47 | 20.63
Value_20_83 | 48 | 20.83
Value_21_02 | 49 | 21.02
Value_21_21 | 50 | 21.21
Value_21_40 | 51 | 21.40
Value_21_58 | 52 | 21.58
Value_21_76 | 53 | 21.76
Value_21_94 | 54 | 21.94
Value_22_11 | 55 | 22.11
Value_22_28 | 56 | 22.28
Value_22_44 | 57 | 22.44
Value_22_61 | 58 | 22.61
Value_22_77 | 59 | 22.77
Value_22_92 | 60 | 22.92
Value_23_08 | 61 | 23.08
Value_23_23 | 62 | 23.23
Value_23_38 | 63 | 23.38
Value_23_52 | 64 | 23.52
Value_23_67 | 65 | 23.67
Value_23_81 | 66 | 23.81
Value_23_95 | 67 | 23.95
Value_24_08 | 68 | 24.08
Value_24_22 | 69 | 24.22
Value_24_35 | 70 | 24.35
Value_24_48 | 71 | 24.48
Value_24_61 | 72 | 24.61
Value_24_74 | 73 | 24.74
Value_24_86 | 74 | 24.86
Value_24_98 | 75 | 24.98
Value_25_11 | 76 | 25.11
Value_25_23 | 77 | 25.23
Value_25_34 | 78 | 25.34
Value_25_46 | 79 | 25.46
Value_25_58 | 80 | 25.58
Value_25_69 | 81 | 25.69
Value_25_80 | 82 | 25.80
Value_25_91 | 83 | 25.91
Value_26_02 | 84 | 26.02
Value_26_13 | 85 | 26.13
Value_26_24 | 86 | 26.24
Value_26_34 | 87 | 26.34
Value_26_44 | 88 | 26.44
Value_26_55 | 89 | 26.55
Value_26_65 | 90 | 26.65
Value_26_75 | 91 | 26.75
Value_26_85 | 92 | 26.85
Value_26_95 | 93 | 26.95
Value_27_04 | 94 | 27.04
Value_27_14 | 95 | 27.14
Value_27_23 | 96 | 27.23
Value_27_33 | 97 | 27.33
Value_27_42 | 98 | 27.42
Value_27_51 | 99 | 27.51
Value_27_60 | 100 | 27.60
Value_27_69 | 101 | 27.69
Value_27_78 | 102 | 27.78
Value_27_87 | 103 | 27.87
Value_27_96 | 104 | 27.96
Value_28_05 | 105 | 28.05
Value_28_13 | 106 | 28.13
Value_28_22 | 107 | 28.22
Value_28_30 | 108 | 28.30
Value_28_38 | 109 | 28.38
Value_28_46 | 110 | 28.46
Value_28_55 | 111 | 28.55
Value_28_63 | 112 | 28.63
Value_28_71 | 113 | 28.71
Value_28_79 | 114 | 28.79
Value_28_87 | 115 | 28.87
Value_28_94 | 116 | 28.94
Value_29_02 | 117 | 29.02
Value_29_10 | 118 | 29.10
Value_29_17 | 119 | 29.17
Value_29_25 | 120 | 29.25
Value_29_32 | 121 | 29.32
Value_29_40 | 122 | 29.40
Value_29_47 | 123 | 29.47
Value_29_54 | 124 | 29.54
Value_29_61 | 125 | 29.61
Value_29_69 | 126 | 29.69
Value_29_76 | 127 | 29.76
Value_29_83 | 128 | 29.83
Value_29_90 | 129 | 29.90
Value_29_97 | 130 | 29.97
Value_30_03 | 131 | 30.03
Value_30_10 | 132 | 30.10
Value_30_17 | 133 | 30.17
Value_30_24 | 134 | 30.24
Value_30_30 | 135 | 30.30
Value_30_37 | 136 | 30.37
Value_30_44 | 137 | 30.44
Value_30_50 | 138 | 30.50
Value_30_57 | 139 | 30.57
Value_30_63 | 140 | 30.63
Value_30_69 | 141 | 30.69
Value_30_76 | 142 | 30.76
Value_30_82 | 143 | 30.82
Value_30_88 | 144 | 30.88
Value_30_94 | 145 | 30.94
Value_31_00 | 146 | 31.00
Value_31_07 | 147 | 31.07
Value_31_13 | 148 | 31.13
Value_31_19 | 149 | 31.19
Value_31_25 | 150 | 31.25
Value_31_31 | 151 | 31.31
Value_31_36 | 152 | 31.36
Value_31_42 | 153 | 31.42
Value_31_48 | 154 | 31.48
Value_31_54 | 155 | 31.54
Value_31_60 | 156 | 31.60
Value_31_65 | 157 | 31.65
Value_31_71 | 158 | 31.71
Value_31_77 | 159 | 31.77
Value_31_82 | 160 | 31.82
Value_31_88 | 161 | 31.88
Value_31_93 | 162 | 31.93
Value_31_99 | 163 | 31.99
Value_32_04 | 164 | 32.04
Value_32_10 | 165 | 32.10
Value_32_15 | 166 | 32.15
Value_32_20 | 167 | 32.20
Value_32_26 | 168 | 32.26
Value_32_31 | 169 | 32.31
Value_32_36 | 170 | 32.36
Value_32_41 | 171 | 32.41
Value_32_46 | 172 | 32.46
Value_32_52 | 173 | 32.52
Value_32_57 | 174 | 32.57
Value_32_62 | 175 | 32.62
Value_32_67 | 176 | 32.67
Value_32_72 | 177 | 32.72
Value_32_77 | 178 | 32.77
Value_32_82 | 179 | 32.82
Value_32_87 | 180 | 32.87
Value_32_92 | 181 | 32.92
Value_32_97 | 182 | 32.97
Value_33_02 | 183 | 33.02
Value_33_06 | 184 | 33.06
Value_33_11 | 185 | 33.11
Value_33_16 | 186 | 33.16
Value_33_21 | 187 | 33.21
Value_33_26 | 188 | 33.26
Value_33_30 | 189 | 33.30
Value_33_35 | 190 | 33.35
Value_33_40 | 191 | 33.40
Value_33_44 | 192 | 33.44
Value_33_49 | 193 | 33.49
Value_33_53 | 194 | 33.53
Value_33_58 | 195 | 33.58
Value_33_62 | 196 | 33.62
Value_33_67 | 197 | 33.67
Value_33_71 | 198 | 33.71
Value_33_76 | 199 | 33.76
Value_33_80 | 200 | 33.80
Value_33_85 | 201 | 33.85
Value_33_89 | 202 | 33.89
Value_33_94 | 203 | 33.94
Value_33_98 | 204 | 33.98
Value_34_02 | 205 | 34.02
Value_34_07 | 206 | 34.07
Value_34_11 | 207 | 34.11
Value_34_15 | 208 | 34.15
Value_34_19 | 209 | 34.19
Value_34_24 | 210 | 34.24
Value_34_28 | 211 | 34.28
Value_34_32 | 212 | 34.32
Value_34_36 | 213 | 34.36
Value_34_40 | 214 | 34.40
Value_34_44 | 215 | 34.44
Value_34_49 | 216 | 34.49
Value_34_53 | 217 | 34.53
Value_34_57 | 218 | 34.57
Value_34_61 | 219 | 34.61
Value_34_65 | 220 | 34.65
Value_34_69 | 221 | 34.69
Value_34_73 | 222 | 34.73
Value_34_77 | 223 | 34.77
Value_34_81 | 224 | 34.81
Value_34_85 | 225 | 34.85
Value_34_89 | 226 | 34.89
Value_34_92 | 227 | 34.92
Value_34_96 | 228 | 34.96
Value_35_00 | 229 | 35.00
Value_35_04 | 230 | 35.04
Value_35_08 | 231 | 35.08
Value_35_12 | 232 | 35.12
Value_35_16 | 233 | 35.16
Value_35_19 | 234 | 35.19
Value_35_23 | 235 | 35.23
Value_35_27 | 236 | 35.27
Value_35_31 | 237 | 35.31
Value_35_34 | 238 | 35.34
Value_35_38 | 239 | 35.38
Value_35_42 | 240 | 35.42
Value_35_45 | 241 | 35.45
Value_35_49 | 242 | 35.49
Value_35_53 | 243 | 35.53
Value_35_56 | 244 | 35.56
Value_35_60 | 245 | 35.60
Value_35_64 | 246 | 35.64
Value_35_67 | 247 | 35.67
Value_35_71 | 248 | 35.71
Value_35_74 | 249 | 35.74
Value_35_78 | 250 | 35.78
Value_35_81 | 251 | 35.81
Value_35_85 | 252 | 35.85
Value_35_88 | 253 | 35.88
Value_35_92 | 254 | 35.92
Value_35_95 | 255 | 35.95
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDDUALAGCLOOPCONTIONAGCCONF0 Enumeration

IRD

Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDDUALAGCLOOPCONTIONAGCCONF0
Public Enumeration TYPIDDUALAGCLOOPCONTIONAGCCONF0
public enum class TYPIDDUALAGCLOOPCONTIONAGCCONF0
type TYPIDDUALAGCLOOPCONTIONAGCCONF0
Members
Member name | Value | Description
UseTheErrorDefault | 0 | Use the error (default)
UseTheSignOfTheError | 1 | Use the sign of the error
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDDUALAGCLOOPCONTIONAGCCONF1 Enumeration

IRD

Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDDUALAGCLOOPCONTIONAGCCONF1
Public Enumeration TYPIDDUALAGCLOOPCONTIONAGCCONF1
public enum class TYPIDDUALAGCLOOPCONTIONAGCCONF1
type TYPIDDUALAGCLOOPCONTIONAGCCONF1
Members
Member name | Value | Description
ValuesOfAGCTHRESAGCRENORMRegistersAreUsed | 0 | Values of AGC_THRES/AGC_RENORM registers are used
AutomaticallyHandledDefault | 1 | Automatically handled (default)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDDUALAGCLOOPCONTIONAGCCONF2 Enumeration

IRD

Tda10046TYPIDDUALAGCLOOPCONTIONAGCCONF2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDDUALAGCLOOPCONTIONAGCCONF2
Public Enumeration TYPIDDUALAGCLOOPCONTIONAGCCONF2
public enum class TYPIDDUALAGCLOOPCONTIONAGCCONF2
type TYPIDDUALAGCLOOPCONTIONAGCCONF2
Members
Member name | Value | Description
SingleIFAGCLoopDefault | 0 | Single IF AGC loop (default)
DoubleAGCLoop | 1 | Double AGC loop
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDGENERALPURPOSEO0GPIOSPDS00 Enumeration

IRD

Tda10046TYPIDGENERALPURPOSEO0GPIOSPDS00 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDGENERALPURPOSEO0GPIOSPDS00
Public Enumeration TYPIDGENERALPURPOSEO0GPIOSPDS00
public enum class TYPIDGENERALPURPOSEO0GPIOSPDS00
type TYPIDGENERALPURPOSEO0GPIOSPDS00
Members
Member name | Value | Description
Value_00000000 | 0 | 0.000/0.000
Value_00130020 | 1 | 0.013/0.020
Value_00260039 | 2 | 0.026/0.039
Value_00390059 | 3 | 0.039/0.059
Value_00520078 | 4 | 0.052/0.078
Value_00650098 | 5 | 0.065/0.098
Value_00780118 | 6 | 0.078/0.118
Value_00910137 | 7 | 0.091/0.137
Value_01040157 | 8 | 0.104/0.157
Value_01160176 | 9 | 0.116/0.176
Value_01290196 | 10 | 0.129/0.196
Value_01420216 | 11 | 0.142/0.216
Value_01550235 | 12 | 0.155/0.235
Value_01680255 | 13 | 0.168/0.255
Value_01810275 | 14 | 0.181/0.275
Value_01940294 | 15 | 0.194/0.294
Value_02070314 | 16 | 0.207/0.314
Value_02200333 | 17 | 0.220/0.333
Value_02330353 | 18 | 0.233/0.353
Value_02460373 | 19 | 0.246/0.373
Value_02590392 | 20 | 0.259/0.392
Value_02720412 | 21 | 0.272/0.412
Value_02850431 | 22 | 0.285/0.431
Value_02980451 | 23 | 0.298/0.451
Value_03110471 | 24 | 0.311/0.471
Value_03240490 | 25 | 0.324/0.490
Value_03360510 | 26 | 0.336/0.510
Value_03490529 | 27 | 0.349/0.529
Value_03620549 | 28 | 0.362/0.549
Value_03750569 | 29 | 0.375/0.569
Value_03880588 | 30 | 0.388/0.588
Value_04010608 | 31 | 0.401/0.608
Value_04140627 | 32 | 0.414/0.627
Value_04270647 | 33 | 0.427/0.647
Value_04400667 | 34 | 0.440/0.667
Value_04530686 | 35 | 0.453/0.686
Value_04660706 | 36 | 0.466/0.706
Value_04790725 | 37 | 0.479/0.725
Value_04920745 | 38 | 0.492/0.745
Value_05050765 | 39 | 0.505/0.765
Value_05180784 | 40 | 0.518/0.784
Value_05310804 | 41 | 0.531/0.804
Value_05440824 | 42 | 0.544/0.824
Value_05560843 | 43 | 0.556/0.843
Value_05690863 | 44 | 0.569/0.863
Value_05820882 | 45 | 0.582/0.882
Value_05950902 | 46 | 0.595/0.902
Value_06080922 | 47 | 0.608/0.922
Value_06210941 | 48 | 0.621/0.941
Value_06340961 | 49 | 0.634/0.961
Value_06470980 | 50 | 0.647/0.980
Value_06601000 | 51 | 0.660/1.000
Value_06731020 | 52 | 0.673/1.020
Value_06861039 | 53 | 0.686/1.039
Value_06991059 | 54 | 0.699/1.059
Value_07121078 | 55 | 0.712/1.078
Value_07251098 | 56 | 0.725/1.098
Value_07381118 | 57 | 0.738/1.118
Value_07511137 | 58 | 0.751/1.137
Value_07641157 | 59 | 0.764/1.157
Value_07761176 | 60 | 0.776/1.176
Value_07891196 | 61 | 0.789/1.196
Value_08021216 | 62 | 0.802/1.216
Value_08151235 | 63 | 0.815/1.235
Value_08281255 | 64 | 0.828/1.255
Value_08411275 | 65 | 0.841/1.275
Value_08541294 | 66 | 0.854/1.294
Value_08671314 | 67 | 0.867/1.314
Value_08801333 | 68 | 0.880/1.333
Value_08931353 | 69 | 0.893/1.353
Value_09061373 | 70 | 0.906/1.373
Value_09191392 | 71 | 0.919/1.392
Value_09321412 | 72 | 0.932/1.412
Value_09451431 | 73 | 0.945/1.431
Value_09581451 | 74 | 0.958/1.451
Value_09711471 | 75 | 0.971/1.471
Value_09841490 | 76 | 0.984/1.490
Value_09961510 | 77 | 0.996/1.510
Value_10091529 | 78 | 1.009/1.529
Value_10221549 | 79 | 1.022/1.549
Value_10351569 | 80 | 1.035/1.569
Value_10481588 | 81 | 1.048/1.588
Value_10611608 | 82 | 1.061/1.608
Value_10741627 | 83 | 1.074/1.627
Value_10871647 | 84 | 1.087/1.647
Value_11001667 | 85 | 1.100/1.667
Value_11131686 | 86 | 1.113/1.686
Value_11261706 | 87 | 1.126/1.706
Value_11391725 | 88 | 1.139/1.725
Value_11521745 | 89 | 1.152/1.745
Value_11651765 | 90 | 1.165/1.765
Value_11781784 | 91 | 1.178/1.784
Value_11911804 | 92 | 1.191/1.804
Value_12041824 | 93 | 1.204/1.824
Value_12161843 | 94 | 1.216/1.843
Value_12291863 | 95 | 1.229/1.863
Value_12421882 | 96 | 1.242/1.882
Value_12551902 | 97 | 1.255/1.902
Value_12681922 | 98 | 1.268/1.922
Value_12811941 | 99 | 1.281/1.941
Value_12941961 | 100 | 1.294/1.961
Value_13071980 | 101 | 1.307/1.980
Value_13202000 | 102 | 1.320/2.000
Value_13332020 | 103 | 1.333/2.020
Value_13462039 | 104 | 1.346/2.039
Value_13592059 | 105 | 1.359/2.059
Value_13722078 | 106 | 1.372/2.078
Value_13852098 | 107 | 1.385/2.098
Value_13982118 | 108 | 1.398/2.118
Value_14112137 | 109 | 1.411/2.137
Value_14242157 | 110 | 1.424/2.157
Value_14362176 | 111 | 1.436/2.176
Value_14492196 | 112 | 1.449/2.196
Value_14622216 | 113 | 1.462/2.216
Value_14752235 | 114 | 1.475/2.235
Value_14882255 | 115 | 1.488/2.255
Value_15012275 | 116 | 1.501/2.275
Value_15142294 | 117 | 1.514/2.294
Value_15272314 | 118 | 1.527/2.314
Value_15402333 | 119 | 1.540/2.333
Value_15532353 | 120 | 1.553/2.353
Value_15662373 | 121 | 1.566/2.373
Value_15792392 | 122 | 1.579/2.392
Value_15922412 | 123 | 1.592/2.412
Value_16052431 | 124 | 1.605/2.431
Value_16182451 | 125 | 1.618/2.451
Value_16312471 | 126 | 1.631/2.471
Value_16442490 | 127 | 1.644/2.490
Value_16562510 | 128 | 1.656/2.510
Value_16692529 | 129 | 1.669/2.529
Value_16822549 | 130 | 1.682/2.549
Value_16952569 | 131 | 1.695/2.569
Value_17082588 | 132 | 1.708/2.588
Value_17212608 | 133 | 1.721/2.608
Value_17342627 | 134 | 1.734/2.627
Value_17472647 | 135 | 1.747/2.647
Value_17602667 | 136 | 1.760/2.667
Value_17732686 | 137 | 1.773/2.686
Value_17862706 | 138 | 1.786/2.706
Value_17992725 | 139 | 1.799/2.725
Value_18122745 | 140 | 1.812/2.745
Value_18252765 | 141 | 1.825/2.765
Value_18382784 | 142 | 1.838/2.784
Value_18512804 | 143 | 1.851/2.804
Value_18642824 | 144 | 1.864/2.824
Value_18762843 | 145 | 1.876/2.843
Value_18892863 | 146 | 1.889/2.863
Value_19022882 | 147 | 1.902/2.882
Value_19152902 | 148 | 1.915/2.902
Value_19282922 | 149 | 1.928/2.922
Value_19412941 | 150 | 1.941/2.941
Value_19542961 | 151 | 1.954/2.961
Value_19672980 | 152 | 1.967/2.980
Value_19803000 | 153 | 1.980/3.000
Value_19933020 | 154 | 1.993/3.020
Value_20063039 | 155 | 2.006/3.039
Value_20193059 | 156 | 2.019/3.059
Value_20323078 | 157 | 2.032/3.078
Value_20453098 | 158 | 2.045/3.098
Value_20583118 | 159 | 2.058/3.118
Value_20713137 | 160 | 2.071/3.137
Value_20843157 | 161 | 2.084/3.157
Value_20963176 | 162 | 2.096/3.176
Value_21093196 | 163 | 2.109/3.196
Value_21223216 | 164 | 2.122/3.216
Value_21353235 | 165 | 2.135/3.235
Value_21483255 | 166 | 2.148/3.255
Value_21613275 | 167 | 2.161/3.275
Value_21743294 | 168 | 2.174/3.294
Value_21873314 | 169 | 2.187/3.314
Value_22003333 | 170 | 2.200/3.333
Value_22133353 | 171 | 2.213/3.353
Value_22263373 | 172 | 2.226/3.373
Value_22393392 | 173 | 2.239/3.392
Value_22523412 | 174 | 2.252/3.412
Value_22653431 | 175 | 2.265/3.431
Value_22783451 | 176 | 2.278/3.451
Value_22913471 | 177 | 2.291/3.471
Value_23043490 | 178 | 2.304/3.490
Value_23163510 | 179 | 2.316/3.510
Value_23293529 | 180 | 2.329/3.529
Value_23423549 | 181 | 2.342/3.549
Value_23553569 | 182 | 2.355/3.569
Value_23683588 | 183 | 2.368/3.588
Value_23813608 | 184 | 2.381/3.608
Value_23943627 | 185 | 2.394/3.627
Value_24073647 | 186 | 2.407/3.647
Value_24203667 | 187 | 2.420/3.667
Value_24333686 | 188 | 2.433/3.686
Value_24463706 | 189 | 2.446/3.706
Value_24593725 | 190 | 2.459/3.725
Value_24723745 | 191 | 2.472/3.745
Value_24853765 | 192 | 2.485/3.765
Value_24983784 | 193 | 2.498/3.784
Value_25113804 | 194 | 2.511/3.804
Value_25243824 | 195 | 2.524/3.824
Value_25363843 | 196 | 2.536/3.843
Value_25493863 | 197 | 2.549/3.863
Value_25623882 | 198 | 2.562/3.882
Value_25753902 | 199 | 2.575/3.902
Value_25883922 | 200 | 2.588/3.922
Value_26013941 | 201 | 2.601/3.941
Value_26143961 | 202 | 2.614/3.961
Value_26273980 | 203 | 2.627/3.980
Value_26404000 | 204 | 2.640/4.000
Value_26534020 | 205 | 2.653/4.020
Value_26664039 | 206 | 2.666/4.039
Value_26794059 | 207 | 2.679/4.059
Value_26924078 | 208 | 2.692/4.078
Value_27054098 | 209 | 2.705/4.098
Value_27184118 | 210 | 2.718/4.118
Value_27314137 | 211 | 2.731/4.137
Value_27444157 | 212 | 2.744/4.157
Value_27564176 | 213 | 2.756/4.176
Value_27694196 | 214 | 2.769/4.196
Value_27824216 | 215 | 2.782/4.216
Value_27954235 | 216 | 2.795/4.235
Value_28084255 | 217 | 2.808/4.255
Value_28214275 | 218 | 2.821/4.275
Value_28344294 | 219 | 2.834/4.294
Value_28474314 | 220 | 2.847/4.314
Value_28604333 | 221 | 2.860/4.333
Value_28734353 | 222 | 2.873/4.353
Value_28864373 | 223 | 2.886/4.373
Value_28994392 | 224 | 2.899/4.392
Value_29124412 | 225 | 2.912/4.412
Value_29254431 | 226 | 2.925/4.431
Value_29384451 | 227 | 2.938/4.451
Value_29514471 | 228 | 2.951/4.471
Value_29644490 | 229 | 2.964/4.490
Value_29764510 | 230 | 2.976/4.510
Value_29894529 | 231 | 2.989/4.529
Value_30024549 | 232 | 3.002/4.549
Value_30154569 | 233 | 3.015/4.569
Value_30284588 | 234 | 3.028/4.588
Value_30414608 | 235 | 3.041/4.608
Value_30544627 | 236 | 3.054/4.627
Value_30674647 | 237 | 3.067/4.647
Value_30804667 | 238 | 3.080/4.667
Value_30934686 | 239 | 3.093/4.686
Value_31064706 | 240 | 3.106/4.706
Value_31194725 | 241 | 3.119/4.725
Value_31324745 | 242 | 3.132/4.745
Value_31454765 | 243 | 3.145/4.765
Value_31584784 | 244 | 3.158/4.784
Value_31714804 | 245 | 3.171/4.804
Value_31844824 | 246 | 3.184/4.824
Value_31964843 | 247 | 3.196/4.843
Value_32094863 | 248 | 3.209/4.863
Value_32224882 | 249 | 3.222/4.882
Value_32354902 | 250 | 3.235/4.902
Value_32484922 | 251 | 3.248/4.922
Value_32614941 | 252 | 3.261/4.941
Value_32744961 | 253 | 3.274/4.961
Value_32874980 | 254 | 3.287/4.980
Value_33005000 | 255 | 3.300/5.000
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDGPIOOUTPUTGPIOOUTSEL0 Enumeration

IRD

Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDGPIOOUTPUTGPIOOUTSEL0
Public Enumeration TYPIDGPIOOUTPUTGPIOOUTSEL0
public enum class TYPIDGPIOOUTPUTGPIOOUTSEL0
type TYPIDGPIOOUTPUTGPIOOUTSEL0
Members
Member name | Value | Description
FELDefault | 0 | FEL (default)
ITInterrupt | 1 | IT (interrupt)
DSPFlag0 | 2 | DSP_flag0
DeltaSigmaOut0 | 3 | DeltaSigma_out0
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDGPIOOUTPUTGPIOOUTSEL1 Enumeration

IRD

Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDGPIOOUTPUTGPIOOUTSEL1
Public Enumeration TYPIDGPIOOUTPUTGPIOOUTSEL1
public enum class TYPIDGPIOOUTPUTGPIOOUTSEL1
type TYPIDGPIOOUTPUTGPIOOUTSEL1
Members
Member name | Value | Description
FEL | 0 | FEL
FFTWindow | 1 | FFT_Window
DSPFlag1 | 2 | DSP_flag1
DeltaSigmaOut1Default | 3 | DeltaSigma_out1 (default)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDGPIOOUTPUTGPIOOUTSEL2 Enumeration

IRD

Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL2 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDGPIOOUTPUTGPIOOUTSEL2
Public Enumeration TYPIDGPIOOUTPUTGPIOOUTSEL2
public enum class TYPIDGPIOOUTPUTGPIOOUTSEL2
type TYPIDGPIOOUTPUTGPIOOUTSEL2
Members
Member name | Value | Description
FEL | 0 | FEL
ITInterruptDefault | 1 | IT (interrupt) (default)
DSPFlag2 | 2 | DSP_flag2
DeltaSigmaOut2 | 3 | DeltaSigma_out2
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDGPIOOUTPUTGPIOOUTSEL3 Enumeration

IRD

Tda10046TYPIDGPIOOUTPUTGPIOOUTSEL3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDGPIOOUTPUTGPIOOUTSEL3
Public Enumeration TYPIDGPIOOUTPUTGPIOOUTSEL3
public enum class TYPIDGPIOOUTPUTGPIOOUTSEL3
type TYPIDGPIOOUTPUTGPIOOUTSEL3
Members
Member name | Value | Description
FEL | 0 | FEL
FFTWindow | 1 | FFT_Window
DSPFlag3 | 2 | DSP_flag3
DeltaSigmaOut3Default | 3 | DeltaSigma_out3 (default)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDGPIOSELECTGPIOSELECT0 Enumeration

IRD

Tda10046TYPIDGPIOSELECTGPIOSELECT0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDGPIOSELECTGPIOSELECT0
Public Enumeration TYPIDGPIOSELECTGPIOSELECT0
public enum class TYPIDGPIOSELECTGPIOSELECT0
type TYPIDGPIOSELECTGPIOSELECT0
Members
Member name | Value | Description
ProvidedByTheHostDefault | 0 | Provided by the host (default)
ProvidedByDSP | 1 | Provided by DSP
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDICFUNCTIONALITYICMODE0 Enumeration

IRD

Tda10046TYPIDICFUNCTIONALITYICMODE0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDICFUNCTIONALITYICMODE0
Public Enumeration TYPIDICFUNCTIONALITYICMODE0
public enum class TYPIDICFUNCTIONALITYICMODE0
type TYPIDICFUNCTIONALITYICMODE0
Members
Member name | Value | Description
ProvidesNormalMPEGTSOutputTSOUT1DefaultMode | 0 | Provides Normal MPEG-TS output (TS_OUT1) (default mode)
ProvidesMPEGTSOutputWithFlagsSuperFrameTSAndByteCorSubstitutedToPsyncAndSUncorTSOUT2 | 1 | Provides MPEG-TS output with flags 'SuperFrame_TS' and 'Byte_cor' substituted to 'psync' and 's_uncor' (TS_OUT2)
ProvidesMPEGTSOutputWithDataBusInvertedToHelpForBoardDesignINVTSOUT | 2 | Provides MPEG-TS output with Data bus inverted to help for board design (INV_TS_OUT)
ProvidesTheConstellationOutputAfterEqualizationCONSTEL | 3 | Provides the constellation output after equalization (CONSTEL)
ProvidesTheFrequencyAndTheChannelStateInformationResponsesOfTheChannelAfterEqualizationFREQRESP | 4 | Provides the frequency and the channel state information responses of the channel after equalization (FREQ RESP)
ProvidesViterbiDecoderOutputDataClockVITERBIOUT | 5 | Provides Viterbi decoder output data/clock (VITERBI OUT)
ProvidesViterbiDecoderInputMetricsVITERBIIN | 6 | Provides Viterbi decoder input metrics (VITERBI IN)
ProvidesFewDspRegistersForDebugDSPOUT | 7 | Provides few dsp registers for debug (DSPOUT)
AllowsToEnterTheOutputOfAnExternalADCSampledByTheClockAvailableOnTheSACLKPinADCEXT | 8 | Allows to enter the output of an external ADC sampled by the clock available on the SACLK pin (ADC_EXT)
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDICFUNCTIONALITYICMODE1 Enumeration

IRD

Tda10046TYPIDICFUNCTIONALITYICMODE1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDICFUNCTIONALITYICMODE1
Public Enumeration TYPIDICFUNCTIONALITYICMODE1
public enum class TYPIDICFUNCTIONALITYICMODE1
type TYPIDICFUNCTIONALITYICMODE1
Members
Member name | Value | Description
NoReversingPolarityDefault | 0 | No reversing polarity (default)
ReversingPolarity | 1 | Reversing polarity
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDINPUTCONFIGURATION1INCONF10 Enumeration

IRD

Tda10046TYPIDINPUTCONFIGURATION1INCONF10 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINPUTCONFIGURATION1INCONF10
Public Enumeration TYPIDINPUTCONFIGURATION1INCONF10
public enum class TYPIDINPUTCONFIGURATION1INCONF10
type TYPIDINPUTCONFIGURATION1INCONF10
Members
Member name | Value | Description
QPSKDefault | 0 | QPSK(default)
Value_16QAM | 1 | 16-QAM
Value_64QAM | 2 | 64-QAM
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDINPUTCONFIGURATION1INCONF11 Enumeration

IRD

Tda10046TYPIDINPUTCONFIGURATION1INCONF11 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINPUTCONFIGURATION1INCONF11
Public Enumeration TYPIDINPUTCONFIGURATION1INCONF11
public enum class TYPIDINPUTCONFIGURATION1INCONF11
type TYPIDINPUTCONFIGURATION1INCONF11
Members
Member name | Value | Description
Value_132Default | 0 | 1/32(default)
Value_116 | 1 | 1/16
Value_18 | 2 | 1/8
Value_14 | 3 | 1/4
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDINPUTCONFIGURATION1INCONF12 Enumeration

IRD

Tda10046TYPIDINPUTCONFIGURATION1INCONF12 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINPUTCONFIGURATION1INCONF12
Public Enumeration TYPIDINPUTCONFIGURATION1INCONF12
public enum class TYPIDINPUTCONFIGURATION1INCONF12
type TYPIDINPUTCONFIGURATION1INCONF12
Members
Member name | Value | Description
Value_2KDefault | 0 | 2K (default)
Value_8K | 1 | 8K
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDINPUTCONFIGURATION1INCONF13 Enumeration

IRD

Tda10046TYPIDINPUTCONFIGURATION1INCONF13 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINPUTCONFIGURATION1INCONF13
Public Enumeration TYPIDINPUTCONFIGURATION1INCONF13
public enum class TYPIDINPUTCONFIGURATION1INCONF13
type TYPIDINPUTCONFIGURATION1INCONF13
Members
Member name | Value | Description
NonHierarchical | 0 | Non hierarchical
A1 | 1 | a=1
A2 | 2 | a=2
A4 | 3 | a=4
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDINPUTCONFIGURATION2INCONF20 Enumeration

IRD

Tda10046TYPIDINPUTCONFIGURATION2INCONF20 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINPUTCONFIGURATION2INCONF20
Public Enumeration TYPIDINPUTCONFIGURATION2INCONF20
public enum class TYPIDINPUTCONFIGURATION2INCONF20
type TYPIDINPUTCONFIGURATION2INCONF20
Members
Member name | Value | Description
NoOffsetDefault | 0 | No offset (default)
Value_16MHz | 1 | + 1/6 MHz
Value_16MHz__1 | 2 | - 1/6 MHz
Value_26MHz | 3 | + 2/6 MHz
Value_26MHz__1 | 4 | - 2/6 MHz
Value_36MHz | 5 | + 3/6 MHz
Value_36MHz__1 | 6 | - 3/6 MHz
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDINPUTCONFIGURATION2INCONF201 Enumeration

IRD

Tda10046TYPIDINPUTCONFIGURATION2INCONF201 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINPUTCONFIGURATION2INCONF201
Public Enumeration TYPIDINPUTCONFIGURATION2INCONF201
public enum class TYPIDINPUTCONFIGURATION2INCONF201
type TYPIDINPUTCONFIGURATION2INCONF201
Members
Member name | Value | Description
Value_12Default | 0 | 1/2 (default)
Value_23 | 1 | 2/3
Value_34 | 2 | 3/4
Value_56 | 3 | 5/6
Value_78 | 4 | 7/8
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDINTERRUPTIONENABABLINGITSEL0 Enumeration

IRD

Tda10046TYPIDINTERRUPTIONENABABLINGITSEL0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINTERRUPTIONENABABLINGITSEL0
Public Enumeration TYPIDINTERRUPTIONENABABLINGITSEL0
public enum class TYPIDINTERRUPTIONENABABLINGITSEL0
type TYPIDINTERRUPTIONENABABLINGITSEL0
Members
Member name | Value | Description
NotEnabled | 0 | Not enabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDINTERRUPTIONREADADINGITSTAT0 Enumeration

IRD

Tda10046TYPIDINTERRUPTIONREADADINGITSTAT0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDINTERRUPTIONREADADINGITSTAT0
Public Enumeration TYPIDINTERRUPTIONREADADINGITSTAT0
public enum class TYPIDINTERRUPTIONREADADINGITSTAT0
type TYPIDINTERRUPTIONREADADINGITSTAT0
Members
Member name | Value | Description
Occurred | 0 | Occurred
NotOccurred | 1 | Not occurred
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDMINMAXSIGNALATTENUATION Enumeration

IRD

Tda10046TYPIDMINMAXSIGNALATTENUATION Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMINMAXSIGNALATTENUATION
Public Enumeration TYPIDMINMAXSIGNALATTENUATION
public enum class TYPIDMINMAXSIGNALATTENUATION
type TYPIDMINMAXSIGNALATTENUATION
Members
Member name | Value | Description
MinimumSignalAttenuation | 0 | Minimum signal attenuation
MaximumSignalAttenuation | 255 | Maximum signal attenuation
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDMULTIPURPOSEACCBDSPADLSB0 Enumeration

IRD

Tda10046TYPIDMULTIPURPOSEACCBDSPADLSB0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDMULTIPURPOSEACCBDSPADLSB0
Public Enumeration TYPIDMULTIPURPOSEACCBDSPADLSB0
public enum class TYPIDMULTIPURPOSEACCBDSPADLSB0
type TYPIDMULTIPURPOSEACCBDSPADLSB0
Members
Member name | Value | Description
ResetOfDspreg | 24832 | Reset of dspreg
ReturnsTheEmbeddedSoftwareVersionNumber | 26368 | Returns the embedded software version number
ReturnsAnEstimationOfTheAnalogCCIPowerInsideTheDVBTSpectrum | 26624 | Returns an estimation of the analog CCI power inside the DVB-T spectrum
StopTheDSPToSimulateAStandstill | 27392 | Stop the DSP to simulate a standstill
ReturnsTheRatioInDBBetweenThePowerInsideTheGuardIntervalAndThePowerOutsideTheGuardInterval | 27648 | Returns the ratio (in dB) between the power inside the 'Guard Interval' and the power outside the 'Guard Interval'
ReturnsTheCRCOfTheFirmwareOfTheDSPCode | 27904 | Returns the CRC of the firmware of the DSP code
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDNOISEPOWERESTIMMATIONNPOUT0 Enumeration

IRD

Tda10046TYPIDNOISEPOWERESTIMMATIONNPOUT0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDNOISEPOWERESTIMMATIONNPOUT0
Public Enumeration TYPIDNOISEPOWERESTIMMATIONNPOUT0
public enum class TYPIDNOISEPOWERESTIMMATIONNPOUT0
type TYPIDNOISEPOWERESTIMMATIONNPOUT0
Members
Member name | Value | Description
Value_0_00 | 1 | 0.00
Value_M_3_01 | 2 | -3.01
Value_M_4_77 | 3 | -4.77
Value_M_6_02 | 4 | -6.02
Value_M_6_99 | 5 | -6.99
Value_M_7_78 | 6 | -7.78
Value_M_8_45 | 7 | -8.45
Value_M_9_03 | 8 | -9.03
Value_M_9_54 | 9 | -9.54
Value_M_10_00 | 10 | -10.00
Value_M_10_41 | 11 | -10.41
Value_M_10_79 | 12 | -10.79
Value_M_11_14 | 13 | -11.14
Value_M_11_46 | 14 | -11.46
Value_M_11_76 | 15 | -11.76
Value_M_12_04 | 16 | -12.04
Value_M_12_30 | 17 | -12.30
Value_M_12_55 | 18 | -12.55
Value_M_12_79 | 19 | -12.79
Value_M_13_01 | 20 | -13.01
Value_M_13_22 | 21 | -13.22
Value_M_13_42 | 22 | -13.42
Value_M_13_62 | 23 | -13.62
Value_M_13_80 | 24 | -13.80
Value_M_13_98 | 25 | -13.98
Value_M_14_15 | 26 | -14.15
Value_M_14_31 | 27 | -14.31
Value_M_14_47 | 28 | -14.47
Value_M_14_62 | 29 | -14.62
Value_M_14_77 | 30 | -14.77
Value_M_14_91 | 31 | -14.91
Value_M_15_05 | 32 | -15.05
Value_M_15_19 | 33 | -15.19
Value_M_15_31 | 34 | -15.31
Value_M_15_44 | 35 | -15.44
Value_M_15_56 | 36 | -15.56
Value_M_15_68 | 37 | -15.68
Value_M_15_80 | 38 | -15.80
Value_M_15_91 | 39 | -15.91
Value_M_16_02 | 40 | -16.02
Value_M_16_13 | 41 | -16.13
Value_M_16_23 | 42 | -16.23
Value_M_16_33 | 43 | -16.33
Value_M_16_43 | 44 | -16.43
Value_M_16_53 | 45 | -16.53
Value_M_16_63 | 46 | -16.63
Value_M_16_72 | 47 | -16.72
Value_M_16_81 | 48 | -16.81
Value_M_16_90 | 49 | -16.90
Value_M_16_99 | 50 | -16.99
Value_M_17_08 | 51 | -17.08
Value_M_17_16 | 52 | -17.16
Value_M_17_24 | 53 | -17.24
Value_M_17_32 | 54 | -17.32
Value_M_17_40 | 55 | -17.40
Value_M_17_48 | 56 | -17.48
Value_M_17_56 | 57 | -17.56
Value_M_17_63 | 58 | -17.63
Value_M_17_71 | 59 | -17.71
Value_M_17_78 | 60 | -17.78
Value_M_17_85 | 61 | -17.85
Value_M_17_92 | 62 | -17.92
Value_M_17_99 | 63 | -17.99
Value_M_18_06 | 64 | -18.06
Value_M_18_13 | 65 | -18.13
Value_M_18_20 | 66 | -18.20
Value_M_18_26 | 67 | -18.26
Value_M_18_33 | 68 | -18.33
Value_M_18_39 | 69 | -18.39
Value_M_18_45 | 70 | -18.45
Value_M_18_51 | 71 | -18.51
Value_M_18_57 | 72 | -18.57
Value_M_18_63 | 73 | -18.63
Value_M_18_69 | 74 | -18.69
Value_M_18_75 | 75 | -18.75
Value_M_18_81 | 76 | -18.81
Value_M_18_86 | 77 | -18.86
Value_M_18_92 | 78 | -18.92
Value_M_18_98 | 79 | -18.98
Value_M_19_03 | 80 | -19.03
Value_M_19_08 | 81 | -19.08
Value_M_19_14 | 82 | -19.14
Value_M_19_19 | 83 | -19.19
Value_M_19_24 | 84 | -19.24
Value_M_19_29 | 85 | -19.29
Value_M_19_34 | 86 | -19.34
Value_M_19_40 | 87 | -19.40
Value_M_19_44 | 88 | -19.44
Value_M_19_49 | 89 | -19.49
Value_M_19_54 | 90 | -19.54
Value_M_19_59 | 91 | -19.59
Value_M_19_64 | 92 | -19.64
Value_M_19_68 | 93 | -19.68
Value_M_19_73 | 94 | -19.73
Value_M_19_78 | 95 | -19.78
Value_M_19_82 | 96 | -19.82
Value_M_19_87 | 97 | -19.87
Value_M_19_91 | 98 | -19.91
Value_M_19_96 | 99 | -19.96
Value_M_20_00 | 100 | -20.00
Value_M_20_04 | 101 | -20.04
Value_M_20_09 | 102 | -20.09
Value_M_20_13 | 103 | -20.13
Value_M_20_17 | 104 | -20.17
Value_M_20_21 | 105 | -20.21
Value_M_20_25 | 106 | -20.25
Value_M_20_29 | 107 | -20.29
Value_M_20_33 | 108 | -20.33
Value_M_20_37 | 109 | -20.37
Value_M_20_41 | 110 | -20.41
Value_M_20_45 | 111 | -20.45
Value_M_20_49 | 112 | -20.49
Value_M_20_53 | 113 | -20.53
Value_M_20_57 | 114 | -20.57
Value_M_20_61 | 115 | -20.61
Value_M_20_64 | 116 | -20.64
Value_M_20_68 | 117 | -20.68
Value_M_20_72 | 118 | -20.72
Value_M_20_76 | 119 | -20.76
Value_M_20_79 | 120 | -20.79
Value_M_20_83 | 121 | -20.83
Value_M_20_86 | 122 | -20.86
Value_M_20_90 | 123 | -20.90
Value_M_20_93 | 124 | -20.93
Value_M_20_97 | 125 | -20.97
Value_M_21_00 | 126 | -21.00
Value_M_21_04 | 127 | -21.04
Value_M_21_07 | 128 | -21.07
Value_M_21_11 | 129 | -21.11
Value_M_21_14 | 130 | -21.14
Value_M_21_17 | 131 | -21.17
Value_M_21_21 | 132 | -21.21
Value_M_21_24 | 133 | -21.24
Value_M_21_27 | 134 | -21.27
Value_M_21_30 | 135 | -21.30
Value_M_21_34 | 136 | -21.34
Value_M_21_37 | 137 | -21.37
Value_M_21_40 | 138 | -21.40
Value_M_21_43 | 139 | -21.43
Value_M_21_46 | 140 | -21.46
Value_M_21_49 | 141 | -21.49
Value_M_21_52 | 142 | -21.52
Value_M_21_55 | 143 | -21.55
Value_M_21_58 | 144 | -21.58
Value_M_21_61 | 145 | -21.61
Value_M_21_64 | 146 | -21.64
Value_M_21_67 | 147 | -21.67
Value_M_21_70 | 148 | -21.70
Value_M_21_73 | 149 | -21.73
Value_M_21_76 | 150 | -21.76
Value_M_21_79 | 151 | -21.79
Value_M_21_82 | 152 | -21.82
Value_M_21_85 | 153 | -21.85
Value_M_21_88 | 154 | -21.88
Value_M_21_90 | 155 | -21.90
Value_M_21_93 | 156 | -21.93
Value_M_21_96 | 157 | -21.96
Value_M_21_99 | 158 | -21.99
Value_M_22_01 | 159 | -22.01
Value_M_22_04 | 160 | -22.04
Value_M_22_07 | 161 | -22.07
Value_M_22_10 | 162 | -22.10
Value_M_22_12 | 163 | -22.12
Value_M_22_15 | 164 | -22.15
Value_M_22_17 | 165 | -22.17
Value_M_22_20 | 166 | -22.20
Value_M_22_23 | 167 | -22.23
Value_M_22_25 | 168 | -22.25
Value_M_22_28 | 169 | -22.28
Value_M_22_30 | 170 | -22.30
Value_M_22_33 | 171 | -22.33
Value_M_22_36 | 172 | -22.36
Value_M_22_38 | 173 | -22.38
Value_M_22_41 | 174 | -22.41
Value_M_22_43 | 175 | -22.43
Value_M_22_46 | 176 | -22.46
Value_M_22_48 | 177 | -22.48
Value_M_22_50 | 178 | -22.50
Value_M_22_53 | 179 | -22.53
Value_M_22_55 | 180 | -22.55
Value_M_22_58 | 181 | -22.58
Value_M_22_60 | 182 | -22.60
Value_M_22_62 | 183 | -22.62
Value_M_22_65 | 184 | -22.65
Value_M_22_67 | 185 | -22.67
Value_M_22_70 | 186 | -22.70
Value_M_22_72 | 187 | -22.72
Value_M_22_74 | 188 | -22.74
Value_M_22_76 | 189 | -22.76
Value_M_22_79 | 190 | -22.79
Value_M_22_81 | 191 | -22.81
Value_M_22_83 | 192 | -22.83
Value_M_22_86 | 193 | -22.86
Value_M_22_88 | 194 | -22.88
Value_M_22_90 | 195 | -22.90
Value_M_22_92 | 196 | -22.92
Value_M_22_94 | 197 | -22.94
Value_M_22_97 | 198 | -22.97
Value_M_22_99 | 199 | -22.99
Value_M_23_01 | 200 | -23.01
Value_M_23_03 | 201 | -23.03
Value_M_23_05 | 202 | -23.05
Value_M_23_07 | 203 | -23.07
Value_M_23_10 | 204 | -23.10
Value_M_23_12 | 205 | -23.12
Value_M_23_14 | 206 | -23.14
Value_M_23_16 | 207 | -23.16
Value_M_23_18 | 208 | -23.18
Value_M_23_20 | 209 | -23.20
Value_M_23_22 | 210 | -23.22
Value_M_23_24 | 211 | -23.24
Value_M_23_26 | 212 | -23.26
Value_M_23_28 | 213 | -23.28
Value_M_23_30 | 214 | -23.30
Value_M_23_32 | 215 | -23.32
Value_M_23_34 | 216 | -23.34
Value_M_23_36 | 217 | -23.36
Value_M_23_38 | 218 | -23.38
Value_M_23_40 | 219 | -23.40
Value_M_23_42 | 220 | -23.42
Value_M_23_44 | 221 | -23.44
Value_M_23_46 | 222 | -23.46
Value_M_23_48 | 223 | -23.48
Value_M_23_50 | 224 | -23.50
Value_M_23_52 | 225 | -23.52
Value_M_23_54 | 226 | -23.54
Value_M_23_56 | 227 | -23.56
Value_M_23_58 | 228 | -23.58
Value_M_23_60 | 229 | -23.60
Value_M_23_62 | 230 | -23.62
Value_M_23_64 | 231 | -23.64
Value_M_23_65 | 232 | -23.65
Value_M_23_67 | 233 | -23.67
Value_M_23_69 | 234 | -23.69
Value_M_23_71 | 235 | -23.71
Value_M_23_73 | 236 | -23.73
Value_M_23_75 | 237 | -23.75
Value_M_23_77 | 238 | -23.77
Value_M_23_78 | 239 | -23.78
Value_M_23_80 | 240 | -23.80
Value_M_23_82 | 241 | -23.82
Value_M_23_84 | 242 | -23.84
Value_M_23_86 | 243 | -23.86
Value_M_23_87 | 244 | -23.87
Value_M_23_89 | 245 | -23.89
Value_M_23_91 | 246 | -23.91
Value_M_23_93 | 247 | -23.93
Value_M_23_94 | 248 | -23.94
Value_M_23_96 | 249 | -23.96
Value_M_23_98 | 250 | -23.98
Value_M_24_00 | 251 | -24.00
Value_M_24_01 | 252 | -24.01
Value_M_24_03 | 253 | -24.03
Value_M_24_05 | 254 | -24.05
Value_M_24_07 | 255 | -24.07
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDOFFSETRELATIVELYYFREQOFFSET0 Enumeration

IRD

Tda10046TYPIDOFFSETRELATIVELYYFREQOFFSET0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDOFFSETRELATIVELYYFREQOFFSET0
Public Enumeration TYPIDOFFSETRELATIVELYYFREQOFFSET0
public enum class TYPIDOFFSETRELATIVELYYFREQOFFSET0
type TYPIDOFFSETRELATIVELYYFREQOFFSET0
Members
Member name | Value | Description
Value_5461_33 | 1 | 5461.33
Value_2730_67 | 2 | 2730.67
Value_1820_44 | 3 | 1820.44
Value_1365_33 | 4 | 1365.33
Value_1092_27 | 5 | 1092.27
Value_910_22 | 6 | 910.22
Value_780_19 | 7 | 780.19
Value_682_67 | 8 | 682.67
Value_606_81 | 9 | 606.81
Value_546_13 | 10 | 546.13
Value_496_48 | 11 | 496.48
Value_455_11 | 12 | 455.11
Value_420_10 | 13 | 420.10
Value_390_10 | 14 | 390.10
Value_364_09 | 15 | 364.09
Value_341_33 | 16 | 341.33
Value_321_25 | 17 | 321.25
Value_303_41 | 18 | 303.41
Value_287_44 | 19 | 287.44
Value_273_07 | 20 | 273.07
Value_260_06 | 21 | 260.06
Value_248_24 | 22 | 248.24
Value_237_45 | 23 | 237.45
Value_227_56 | 24 | 227.56
Value_218_45 | 25 | 218.45
Value_210_05 | 26 | 210.05
Value_202_27 | 27 | 202.27
Value_195_05 | 28 | 195.05
Value_188_32 | 29 | 188.32
Value_182_04 | 30 | 182.04
Value_176_17 | 31 | 176.17
Value_170_67 | 32 | 170.67
Value_165_49 | 33 | 165.49
Value_160_63 | 34 | 160.63
Value_156_04 | 35 | 156.04
Value_151_70 | 36 | 151.70
Value_147_60 | 37 | 147.60
Value_143_72 | 38 | 143.72
Value_140_03 | 39 | 140.03
Value_136_53 | 40 | 136.53
Value_133_20 | 41 | 133.20
Value_130_03 | 42 | 130.03
Value_127_01 | 43 | 127.01
Value_124_12 | 44 | 124.12
Value_121_36 | 45 | 121.36
Value_118_72 | 46 | 118.72
Value_116_20 | 47 | 116.20
Value_113_78 | 48 | 113.78
Value_111_46 | 49 | 111.46
Value_109_23 | 50 | 109.23
Value_107_08 | 51 | 107.08
Value_105_03 | 52 | 105.03
Value_103_04 | 53 | 103.04
Value_101_14 | 54 | 101.14
Value_99_30 | 55 | 99.30
Value_97_52 | 56 | 97.52
Value_95_81 | 57 | 95.81
Value_94_16 | 58 | 94.16
Value_92_56 | 59 | 92.56
Value_91_02 | 60 | 91.02
Value_89_53 | 61 | 89.53
Value_88_09 | 62 | 88.09
Value_86_69 | 63 | 86.69
Value_85_33 | 64 | 85.33
Value_84_02 | 65 | 84.02
Value_82_75 | 66 | 82.75
Value_81_51 | 67 | 81.51
Value_80_31 | 68 | 80.31
Value_79_15 | 69 | 79.15
Value_78_02 | 70 | 78.02
Value_76_92 | 71 | 76.92
Value_75_85 | 72 | 75.85
Value_74_81 | 73 | 74.81
Value_73_80 | 74 | 73.80
Value_72_82 | 75 | 72.82
Value_71_86 | 76 | 71.86
Value_70_93 | 77 | 70.93
Value_70_02 | 78 | 70.02
Value_69_13 | 79 | 69.13
Value_68_27 | 80 | 68.27
Value_67_42 | 81 | 67.42
Value_66_60 | 82 | 66.60
Value_65_80 | 83 | 65.80
Value_65_02 | 84 | 65.02
Value_64_25 | 85 | 64.25
Value_63_50 | 86 | 63.50
Value_62_77 | 87 | 62.77
Value_62_06 | 88 | 62.06
Value_61_36 | 89 | 61.36
Value_60_68 | 90 | 60.68
Value_60_01 | 91 | 60.01
Value_59_36 | 92 | 59.36
Value_58_72 | 93 | 58.72
Value_58_10 | 94 | 58.10
Value_57_49 | 95 | 57.49
Value_56_89 | 96 | 56.89
Value_56_30 | 97 | 56.30
Value_55_73 | 98 | 55.73
Value_55_16 | 99 | 55.16
Value_54_61 | 100 | 54.61
Value_54_07 | 101 | 54.07
Value_53_54 | 102 | 53.54
Value_53_02 | 103 | 53.02
Value_52_51 | 104 | 52.51
Value_52_01 | 105 | 52.01
Value_51_52 | 106 | 51.52
Value_51_04 | 107 | 51.04
Value_50_57 | 108 | 50.57
Value_50_10 | 109 | 50.10
Value_49_65 | 110 | 49.65
Value_49_20 | 111 | 49.20
Value_48_76 | 112 | 48.76
Value_48_33 | 113 | 48.33
Value_47_91 | 114 | 47.91
Value_47_49 | 115 | 47.49
Value_47_08 | 116 | 47.08
Value_46_68 | 117 | 46.68
Value_46_28 | 118 | 46.28
Value_45_89 | 119 | 45.89
Value_45_51 | 120 | 45.51
Value_45_13 | 121 | 45.13
Value_44_77 | 122 | 44.77
Value_44_40 | 123 | 44.40
Value_44_04 | 124 | 44.04
Value_43_69 | 125 | 43.69
Value_43_34 | 126 | 43.34
Value_43_00 | 127 | 43.00
Value_42_67 | 128 | 42.67
Value_42_34 | 129 | 42.34
Value_42_01 | 130 | 42.01
Value_41_69 | 131 | 41.69
Value_41_37 | 132 | 41.37
Value_41_06 | 133 | 41.06
Value_40_76 | 134 | 40.76
Value_40_45 | 135 | 40.45
Value_40_16 | 136 | 40.16
Value_39_86 | 137 | 39.86
Value_39_57 | 138 | 39.57
Value_39_29 | 139 | 39.29
Value_39_01 | 140 | 39.01
Value_38_73 | 141 | 38.73
Value_38_46 | 142 | 38.46
Value_38_19 | 143 | 38.19
Value_37_93 | 144 | 37.93
Value_37_66 | 145 | 37.66
Value_37_41 | 146 | 37.41
Value_37_15 | 147 | 37.15
Value_36_90 | 148 | 36.90
Value_36_65 | 149 | 36.65
Value_36_41 | 150 | 36.41
Value_36_17 | 151 | 36.17
Value_35_93 | 152 | 35.93
Value_35_69 | 153 | 35.69
Value_35_46 | 154 | 35.46
Value_35_23 | 155 | 35.23
Value_35_01 | 156 | 35.01
Value_34_79 | 157 | 34.79
Value_34_57 | 158 | 34.57
Value_34_35 | 159 | 34.35
Value_34_13 | 160 | 34.13
Value_33_92 | 161 | 33.92
Value_33_71 | 162 | 33.71
Value_33_51 | 163 | 33.51
Value_33_30 | 164 | 33.30
Value_33_10 | 165 | 33.10
Value_32_90 | 166 | 32.90
Value_32_70 | 167 | 32.70
Value_32_51 | 168 | 32.51
Value_32_32 | 169 | 32.32
Value_32_13 | 170 | 32.13
Value_31_94 | 171 | 31.94
Value_31_75 | 172 | 31.75
Value_31_57 | 173 | 31.57
Value_31_39 | 174 | 31.39
Value_31_21 | 175 | 31.21
Value_31_03 | 176 | 31.03
Value_30_85 | 177 | 30.85
Value_30_68 | 178 | 30.68
Value_30_51 | 179 | 30.51
Value_30_34 | 180 | 30.34
Value_30_17 | 181 | 30.17
Value_30_01 | 182 | 30.01
Value_29_84 | 183 | 29.84
Value_29_68 | 184 | 29.68
Value_29_52 | 185 | 29.52
Value_29_36 | 186 | 29.36
Value_29_20 | 187 | 29.20
Value_29_05 | 188 | 29.05
Value_28_90 | 189 | 28.90
Value_28_74 | 190 | 28.74
Value_28_59 | 191 | 28.59
Value_28_44 | 192 | 28.44
Value_28_30 | 193 | 28.30
Value_28_15 | 194 | 28.15
Value_28_01 | 195 | 28.01
Value_27_86 | 196 | 27.86
Value_27_72 | 197 | 27.72
Value_27_58 | 198 | 27.58
Value_27_44 | 199 | 27.44
Value_27_31 | 200 | 27.31
Value_27_17 | 201 | 27.17
Value_27_04 | 202 | 27.04
Value_26_90 | 203 | 26.90
Value_26_77 | 204 | 26.77
Value_26_64 | 205 | 26.64
Value_26_51 | 206 | 26.51
Value_26_38 | 207 | 26.38
Value_26_26 | 208 | 26.26
Value_26_13 | 209 | 26.13
Value_26_01 | 210 | 26.01
Value_25_88 | 211 | 25.88
Value_25_76 | 212 | 25.76
Value_25_64 | 213 | 25.64
Value_25_52 | 214 | 25.52
Value_25_40 | 215 | 25.40
Value_25_28 | 216 | 25.28
Value_25_17 | 217 | 25.17
Value_25_05 | 218 | 25.05
Value_24_94 | 219 | 24.94
Value_24_82 | 220 | 24.82
Value_24_71 | 221 | 24.71
Value_24_60 | 222 | 24.60
Value_24_49 | 223 | 24.49
Value_24_38 | 224 | 24.38
Value_24_27 | 225 | 24.27
Value_24_17 | 226 | 24.17
Value_24_06 | 227 | 24.06
Value_23_95 | 228 | 23.95
Value_23_85 | 229 | 23.85
Value_23_74 | 230 | 23.74
Value_23_64 | 231 | 23.64
Value_23_54 | 232 | 23.54
Value_23_44 | 233 | 23.44
Value_23_34 | 234 | 23.34
Value_23_24 | 235 | 23.24
Value_23_14 | 236 | 23.14
Value_23_04 | 237 | 23.04
Value_22_95 | 238 | 22.95
Value_22_85 | 239 | 22.85
Value_22_76 | 240 | 22.76
Value_22_66 | 241 | 22.66
Value_22_57 | 242 | 22.57
Value_22_47 | 243 | 22.47
Value_22_38 | 244 | 22.38
Value_22_29 | 245 | 22.29
Value_22_20 | 246 | 22.20
Value_22_11 | 247 | 22.11
Value_22_02 | 248 | 22.02
Value_21_93 | 249 | 21.93
Value_21_85 | 250 | 21.85
Value_21_76 | 251 | 21.76
Value_21_67 | 252 | 21.67
Value_21_59 | 253 | 21.59
Value_21_50 | 254 | 21.50
Value_21_42 | 255 | 21.42
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDSYNCHRONISATIONSSSYNCSTATUS0 Enumeration

IRD

Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSYNCHRONISATIONSSSYNCSTATUS0
Public Enumeration TYPIDSYNCHRONISATIONSSSYNCSTATUS0
public enum class TYPIDSYNCHRONISATIONSSSYNCSTATUS0
type TYPIDSYNCHRONISATIONSSSYNCSTATUS0
Members
Member name | Value | Description
NotGood | 0 | Not good
Good | 1 | Good
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDSYNCHRONISATIONSSSYNCSTATUS1 Enumeration

IRD

Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS1 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSYNCHRONISATIONSSSYNCSTATUS1
Public Enumeration TYPIDSYNCHRONISATIONSSSYNCSTATUS1
public enum class TYPIDSYNCHRONISATIONSSSYNCSTATUS1
type TYPIDSYNCHRONISATIONSSSYNCSTATUS1
Members
Member name | Value | Description
NotSynchronized | 0 | Not synchronized
GetsSynchronized | 1 | Gets synchronized
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDSYNCHRONISATIONSSSYNCSTATUS3 Enumeration

IRD

Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS3 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSYNCHRONISATIONSSSYNCSTATUS3
Public Enumeration TYPIDSYNCHRONISATIONSSSYNCSTATUS3
public enum class TYPIDSYNCHRONISATIONSSSYNCSTATUS3
type TYPIDSYNCHRONISATIONSSSYNCSTATUS3
Members
Member name | Value | Description
TPSLOCKTIMELOCKOrFREQLOCKAreAtNotAHighLevel | 0 | TPS_LOCK, TIME_LOCK or FREQ_LOCK are at not a high level
TPSLOCKTIMELOCKAndFREQLOCKAreAtAHighLevel | 1 | TPS_LOCK, TIME_LOCK and FREQ_LOCK are at a high level
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDSYNCHRONISATIONSSSYNCSTATUS4 Enumeration

IRD

Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS4 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSYNCHRONISATIONSSSYNCSTATUS4
Public Enumeration TYPIDSYNCHRONISATIONSSSYNCSTATUS4
public enum class TYPIDSYNCHRONISATIONSSSYNCSTATUS4
type TYPIDSYNCHRONISATIONSSSYNCSTATUS4
Members
Member name | Value | Description
CodeHasNotBeenCorrectlyDownloaded | 0 | Code has not been correctly downloaded
CodeHasBeenCorrectlyDownloaded | 1 | Code has been correctly downloaded
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDSYNCHRONISATIONSSSYNCSTATUS5 Enumeration

IRD

Tda10046TYPIDSYNCHRONISATIONSSSYNCSTATUS5 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDSYNCHRONISATIONSSSYNCSTATUS5
Public Enumeration TYPIDSYNCHRONISATIONSSSYNCSTATUS5
public enum class TYPIDSYNCHRONISATIONSSSYNCSTATUS5
type TYPIDSYNCHRONISATIONSSSYNCSTATUS5
Members
Member name | Value | Description
PLLIsNotLockedAfterBeingProgrammed | 0 | PLL is not locked after being programmed
PLLIsLockedAfterBeingProgrammed | 1 | PLL is locked after being programmed
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


Tda10046.TYPIDTIMEERRORTIMEERROR0 Enumeration

IRD

Tda10046TYPIDTIMEERRORTIMEERROR0 Enumeration

Namespace: telos.Ird.NXPSemiconductors
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TYPIDTIMEERRORTIMEERROR0
Public Enumeration TYPIDTIMEERRORTIMEERROR0
public enum class TYPIDTIMEERRORTIMEERROR0
type TYPIDTIMEERRORTIMEERROR0
Members
Member name | Value | Description
Value_0000FsampleBandwidth | 0 | 0.000*Fsample/Bandwidth
Value_0021FsampleBandwidth | 1 | 0.021*Fsample/Bandwidth
Value_0042FsampleBandwidth | 2 | 0.042*Fsample/Bandwidth
Value_0063FsampleBandwidth | 3 | 0.063*Fsample/Bandwidth
Value_0083FsampleBandwidth | 4 | 0.083*Fsample/Bandwidth
Value_0104FsampleBandwidth | 5 | 0.104*Fsample/Bandwidth
Value_0125FsampleBandwidth | 6 | 0.125*Fsample/Bandwidth
Value_0146FsampleBandwidth | 7 | 0.146*Fsample/Bandwidth
Value_0167FsampleBandwidth | 8 | 0.167*Fsample/Bandwidth
Value_0188FsampleBandwidth | 9 | 0.188*Fsample/Bandwidth
Value_0209FsampleBandwidth | 10 | 0.209*Fsample/Bandwidth
Value_0229FsampleBandwidth | 11 | 0.229*Fsample/Bandwidth
Value_0250FsampleBandwidth | 12 | 0.250*Fsample/Bandwidth
Value_0271FsampleBandwidth | 13 | 0.271*Fsample/Bandwidth
Value_0292FsampleBandwidth | 14 | 0.292*Fsample/Bandwidth
Value_0313FsampleBandwidth | 15 | 0.313*Fsample/Bandwidth
Value_0334FsampleBandwidth | 16 | 0.334*Fsample/Bandwidth
Value_0355FsampleBandwidth | 17 | 0.355*Fsample/Bandwidth
Value_0376FsampleBandwidth | 18 | 0.376*Fsample/Bandwidth
Value_0396FsampleBandwidth | 19 | 0.396*Fsample/Bandwidth
Value_0417FsampleBandwidth | 20 | 0.417*Fsample/Bandwidth
Value_0438FsampleBandwidth | 21 | 0.438*Fsample/Bandwidth
Value_0459FsampleBandwidth | 22 | 0.459*Fsample/Bandwidth
Value_0480FsampleBandwidth | 23 | 0.480*Fsample/Bandwidth
Value_0501FsampleBandwidth | 24 | 0.501*Fsample/Bandwidth
Value_0522FsampleBandwidth | 25 | 0.522*Fsample/Bandwidth
Value_0542FsampleBandwidth | 26 | 0.542*Fsample/Bandwidth
Value_0563FsampleBandwidth | 27 | 0.563*Fsample/Bandwidth
Value_0584FsampleBandwidth | 28 | 0.584*Fsample/Bandwidth
Value_0605FsampleBandwidth | 29 | 0.605*Fsample/Bandwidth
Value_0626FsampleBandwidth | 30 | 0.626*Fsample/Bandwidth
Value_0647FsampleBandwidth | 31 | 0.647*Fsample/Bandwidth
Value_0668FsampleBandwidth | 32 | 0.668*Fsample/Bandwidth
Value_0688FsampleBandwidth | 33 | 0.688*Fsample/Bandwidth
Value_0709FsampleBandwidth | 34 | 0.709*Fsample/Bandwidth
Value_0730FsampleBandwidth | 35 | 0.730*Fsample/Bandwidth
Value_0751FsampleBandwidth | 36 | 0.751*Fsample/Bandwidth
Value_0772FsampleBandwidth | 37 | 0.772*Fsample/Bandwidth
Value_0793FsampleBandwidth | 38 | 0.793*Fsample/Bandwidth
Value_0814FsampleBandwidth | 39 | 0.814*Fsample/Bandwidth
Value_0834FsampleBandwidth | 40 | 0.834*Fsample/Bandwidth
Value_0855FsampleBandwidth | 41 | 0.855*Fsample/Bandwidth
Value_0876FsampleBandwidth | 42 | 0.876*Fsample/Bandwidth
Value_0897FsampleBandwidth | 43 | 0.897*Fsample/Bandwidth
Value_0918FsampleBandwidth | 44 | 0.918*Fsample/Bandwidth
Value_0939FsampleBandwidth | 45 | 0.939*Fsample/Bandwidth
Value_0960FsampleBandwidth | 46 | 0.960*Fsample/Bandwidth
Value_0980FsampleBandwidth | 47 | 0.980*Fsample/Bandwidth
Value_1001FsampleBandwidth | 48 | 1.001*Fsample/Bandwidth
Value_1022FsampleBandwidth | 49 | 1.022*Fsample/Bandwidth
Value_1043FsampleBandwidth | 50 | 1.043*Fsample/Bandwidth
Value_1064FsampleBandwidth | 51 | 1.064*Fsample/Bandwidth
Value_1085FsampleBandwidth | 52 | 1.085*Fsample/Bandwidth
Value_1106FsampleBandwidth | 53 | 1.106*Fsample/Bandwidth
Value_1127FsampleBandwidth | 54 | 1.127*Fsample/Bandwidth
Value_1147FsampleBandwidth | 55 | 1.147*Fsample/Bandwidth
Value_1168FsampleBandwidth | 56 | 1.168*Fsample/Bandwidth
Value_1189FsampleBandwidth | 57 | 1.189*Fsample/Bandwidth
Value_1210FsampleBandwidth | 58 | 1.210*Fsample/Bandwidth
Value_1231FsampleBandwidth | 59 | 1.231*Fsample/Bandwidth
Value_1252FsampleBandwidth | 60 | 1.252*Fsample/Bandwidth
Value_1273FsampleBandwidth | 61 | 1.273*Fsample/Bandwidth
Value_1293FsampleBandwidth | 62 | 1.293*Fsample/Bandwidth
Value_1314FsampleBandwidth | 63 | 1.314*Fsample/Bandwidth
Value_1335FsampleBandwidth | 64 | 1.335*Fsample/Bandwidth
Value_1356FsampleBandwidth | 65 | 1.356*Fsample/Bandwidth
Value_1377FsampleBandwidth | 66 | 1.377*Fsample/Bandwidth
Value_1398FsampleBandwidth | 67 | 1.398*Fsample/Bandwidth
Value_1419FsampleBandwidth | 68 | 1.419*Fsample/Bandwidth
Value_1439FsampleBandwidth | 69 | 1.439*Fsample/Bandwidth
Value_1460FsampleBandwidth | 70 | 1.460*Fsample/Bandwidth
Value_1481FsampleBandwidth | 71 | 1.481*Fsample/Bandwidth
Value_1502FsampleBandwidth | 72 | 1.502*Fsample/Bandwidth
Value_1523FsampleBandwidth | 73 | 1.523*Fsample/Bandwidth
Value_1544FsampleBandwidth | 74 | 1.544*Fsample/Bandwidth
Value_1565FsampleBandwidth | 75 | 1.565*Fsample/Bandwidth
Value_1585FsampleBandwidth | 76 | 1.585*Fsample/Bandwidth
Value_1606FsampleBandwidth | 77 | 1.606*Fsample/Bandwidth
Value_1627FsampleBandwidth | 78 | 1.627*Fsample/Bandwidth
Value_1648FsampleBandwidth | 79 | 1.648*Fsample/Bandwidth
Value_1669FsampleBandwidth | 80 | 1.669*Fsample/Bandwidth
Value_1690FsampleBandwidth | 81 | 1.690*Fsample/Bandwidth
Value_1711FsampleBandwidth | 82 | 1.711*Fsample/Bandwidth
Value_1732FsampleBandwidth | 83 | 1.732*Fsample/Bandwidth
Value_1752FsampleBandwidth | 84 | 1.752*Fsample/Bandwidth
Value_1773FsampleBandwidth | 85 | 1.773*Fsample/Bandwidth
Value_1794FsampleBandwidth | 86 | 1.794*Fsample/Bandwidth
Value_1815FsampleBandwidth | 87 | 1.815*Fsample/Bandwidth
Value_1836FsampleBandwidth | 88 | 1.836*Fsample/Bandwidth
Value_1857FsampleBandwidth | 89 | 1.857*Fsample/Bandwidth
Value_1878FsampleBandwidth | 90 | 1.878*Fsample/Bandwidth
Value_1898FsampleBandwidth | 91 | 1.898*Fsample/Bandwidth
Value_1919FsampleBandwidth | 92 | 1.919*Fsample/Bandwidth
Value_1940FsampleBandwidth | 93 | 1.940*Fsample/Bandwidth
Value_1961FsampleBandwidth | 94 | 1.961*Fsample/Bandwidth
Value_1982FsampleBandwidth | 95 | 1.982*Fsample/Bandwidth
Value_2003FsampleBandwidth | 96 | 2.003*Fsample/Bandwidth
Value_2024FsampleBandwidth | 97 | 2.024*Fsample/Bandwidth
Value_2044FsampleBandwidth | 98 | 2.044*Fsample/Bandwidth
Value_2065FsampleBandwidth | 99 | 2.065*Fsample/Bandwidth
Value_2086FsampleBandwidth | 100 | 2.086*Fsample/Bandwidth
Value_2107FsampleBandwidth | 101 | 2.107*Fsample/Bandwidth
Value_2128FsampleBandwidth | 102 | 2.128*Fsample/Bandwidth
Value_2149FsampleBandwidth | 103 | 2.149*Fsample/Bandwidth
Value_2170FsampleBandwidth | 104 | 2.170*Fsample/Bandwidth
Value_2190FsampleBandwidth | 105 | 2.190*Fsample/Bandwidth
Value_2211FsampleBandwidth | 106 | 2.211*Fsample/Bandwidth
Value_2232FsampleBandwidth | 107 | 2.232*Fsample/Bandwidth
Value_2253FsampleBandwidth | 108 | 2.253*Fsample/Bandwidth
Value_2274FsampleBandwidth | 109 | 2.274*Fsample/Bandwidth
Value_2295FsampleBandwidth | 110 | 2.295*Fsample/Bandwidth
Value_2316FsampleBandwidth | 111 | 2.316*Fsample/Bandwidth
Value_2337FsampleBandwidth | 112 | 2.337*Fsample/Bandwidth
Value_2357FsampleBandwidth | 113 | 2.357*Fsample/Bandwidth
Value_2378FsampleBandwidth | 114 | 2.378*Fsample/Bandwidth
Value_2399FsampleBandwidth | 115 | 2.399*Fsample/Bandwidth
Value_2420FsampleBandwidth | 116 | 2.420*Fsample/Bandwidth
Value_2441FsampleBandwidth | 117 | 2.441*Fsample/Bandwidth
Value_2462FsampleBandwidth | 118 | 2.462*Fsample/Bandwidth
Value_2483FsampleBandwidth | 119 | 2.483*Fsample/Bandwidth
Value_2503FsampleBandwidth | 120 | 2.503*Fsample/Bandwidth
Value_2524FsampleBandwidth | 121 | 2.524*Fsample/Bandwidth
Value_2545FsampleBandwidth | 122 | 2.545*Fsample/Bandwidth
Value_2566FsampleBandwidth | 123 | 2.566*Fsample/Bandwidth
Value_2587FsampleBandwidth | 124 | 2.587*Fsample/Bandwidth
Value_2608FsampleBandwidth | 125 | 2.608*Fsample/Bandwidth
Value_2629FsampleBandwidth | 126 | 2.629*Fsample/Bandwidth
Value_2649FsampleBandwidth | 127 | 2.649*Fsample/Bandwidth
Value_2670FsampleBandwidth | 128 | 2.670*Fsample/Bandwidth
Value_2691FsampleBandwidth | 129 | 2.691*Fsample/Bandwidth
Value_2712FsampleBandwidth | 130 | 2.712*Fsample/Bandwidth
Value_2733FsampleBandwidth | 131 | 2.733*Fsample/Bandwidth
Value_2754FsampleBandwidth | 132 | 2.754*Fsample/Bandwidth
Value_2775FsampleBandwidth | 133 | 2.775*Fsample/Bandwidth
Value_2795FsampleBandwidth | 134 | 2.795*Fsample/Bandwidth
Value_2816FsampleBandwidth | 135 | 2.816*Fsample/Bandwidth
Value_2837FsampleBandwidth | 136 | 2.837*Fsample/Bandwidth
Value_2858FsampleBandwidth | 137 | 2.858*Fsample/Bandwidth
Value_2879FsampleBandwidth | 138 | 2.879*Fsample/Bandwidth
Value_2900FsampleBandwidth | 139 | 2.900*Fsample/Bandwidth
Value_2921FsampleBandwidth | 140 | 2.921*Fsample/Bandwidth
Value_2941FsampleBandwidth | 141 | 2.941*Fsample/Bandwidth
Value_2962FsampleBandwidth | 142 | 2.962*Fsample/Bandwidth
Value_2983FsampleBandwidth | 143 | 2.983*Fsample/Bandwidth
Value_3004FsampleBandwidth | 144 | 3.004*Fsample/Bandwidth
Value_3025FsampleBandwidth | 145 | 3.025*Fsample/Bandwidth
Value_3046FsampleBandwidth | 146 | 3.046*Fsample/Bandwidth
Value_3067FsampleBandwidth | 147 | 3.067*Fsample/Bandwidth
Value_3088FsampleBandwidth | 148 | 3.088*Fsample/Bandwidth
Value_3108FsampleBandwidth | 149 | 3.108*Fsample/Bandwidth
Value_3129FsampleBandwidth | 150 | 3.129*Fsample/Bandwidth
Value_3150FsampleBandwidth | 151 | 3.150*Fsample/Bandwidth
Value_3171FsampleBandwidth | 152 | 3.171*Fsample/Bandwidth
Value_3192FsampleBandwidth | 153 | 3.192*Fsample/Bandwidth
Value_3213FsampleBandwidth | 154 | 3.213*Fsample/Bandwidth
Value_3234FsampleBandwidth | 155 | 3.234*Fsample/Bandwidth
Value_3254FsampleBandwidth | 156 | 3.254*Fsample/Bandwidth
Value_3275FsampleBandwidth | 157 | 3.275*Fsample/Bandwidth
Value_3296FsampleBandwidth | 158 | 3.296*Fsample/Bandwidth
Value_3317FsampleBandwidth | 159 | 3.317*Fsample/Bandwidth
Value_3338FsampleBandwidth | 160 | 3.338*Fsample/Bandwidth
Value_3359FsampleBandwidth | 161 | 3.359*Fsample/Bandwidth
Value_3380FsampleBandwidth | 162 | 3.380*Fsample/Bandwidth
Value_3400FsampleBandwidth | 163 | 3.400*Fsample/Bandwidth
Value_3421FsampleBandwidth | 164 | 3.421*Fsample/Bandwidth
Value_3442FsampleBandwidth | 165 | 3.442*Fsample/Bandwidth
Value_3463FsampleBandwidth | 166 | 3.463*Fsample/Bandwidth
Value_3484FsampleBandwidth | 167 | 3.484*Fsample/Bandwidth
Value_3505FsampleBandwidth | 168 | 3.505*Fsample/Bandwidth
Value_3526FsampleBandwidth | 169 | 3.526*Fsample/Bandwidth
Value_3546FsampleBandwidth | 170 | 3.546*Fsample/Bandwidth
Value_3567FsampleBandwidth | 171 | 3.567*Fsample/Bandwidth
Value_3588FsampleBandwidth | 172 | 3.588*Fsample/Bandwidth
Value_3609FsampleBandwidth | 173 | 3.609*Fsample/Bandwidth
Value_3630FsampleBandwidth | 174 | 3.630*Fsample/Bandwidth
Value_3651FsampleBandwidth | 175 | 3.651*Fsample/Bandwidth
Value_3672FsampleBandwidth | 176 | 3.672*Fsample/Bandwidth
Value_3693FsampleBandwidth | 177 | 3.693*Fsample/Bandwidth
Value_3713FsampleBandwidth | 178 | 3.713*Fsample/Bandwidth
Value_3734FsampleBandwidth | 179 | 3.734*Fsample/Bandwidth
Value_3755FsampleBandwidth | 180 | 3.755*Fsample/Bandwidth
Value_3776FsampleBandwidth | 181 | 3.776*Fsample/Bandwidth
Value_3797FsampleBandwidth | 182 | 3.797*Fsample/Bandwidth
Value_3818FsampleBandwidth | 183 | 3.818*Fsample/Bandwidth
Value_3839FsampleBandwidth | 184 | 3.839*Fsample/Bandwidth
Value_3859FsampleBandwidth | 185 | 3.859*Fsample/Bandwidth
Value_3880FsampleBandwidth | 186 | 3.880*Fsample/Bandwidth
Value_3901FsampleBandwidth | 187 | 3.901*Fsample/Bandwidth
Value_3922FsampleBandwidth | 188 | 3.922*Fsample/Bandwidth
Value_3943FsampleBandwidth | 189 | 3.943*Fsample/Bandwidth
Value_3964FsampleBandwidth | 190 | 3.964*Fsample/Bandwidth
Value_3985FsampleBandwidth | 191 | 3.985*Fsample/Bandwidth
Value_4005FsampleBandwidth | 192 | 4.005*Fsample/Bandwidth
Value_4026FsampleBandwidth | 193 | 4.026*Fsample/Bandwidth
Value_4047FsampleBandwidth | 194 | 4.047*Fsample/Bandwidth
Value_4068FsampleBandwidth | 195 | 4.068*Fsample/Bandwidth
Value_4089FsampleBandwidth | 196 | 4.089*Fsample/Bandwidth
Value_4110FsampleBandwidth | 197 | 4.110*Fsample/Bandwidth
Value_4131FsampleBandwidth | 198 | 4.131*Fsample/Bandwidth
Value_4151FsampleBandwidth | 199 | 4.151*Fsample/Bandwidth
Value_4172FsampleBandwidth | 200 | 4.172*Fsample/Bandwidth
Value_4193FsampleBandwidth | 201 | 4.193*Fsample/Bandwidth
Value_4214FsampleBandwidth | 202 | 4.214*Fsample/Bandwidth
Value_4235FsampleBandwidth | 203 | 4.235*Fsample/Bandwidth
Value_4256FsampleBandwidth | 204 | 4.256*Fsample/Bandwidth
Value_4277FsampleBandwidth | 205 | 4.277*Fsample/Bandwidth
Value_4297FsampleBandwidth | 206 | 4.297*Fsample/Bandwidth
Value_4318FsampleBandwidth | 207 | 4.318*Fsample/Bandwidth
Value_4339FsampleBandwidth | 208 | 4.339*Fsample/Bandwidth
Value_4360FsampleBandwidth | 209 | 4.360*Fsample/Bandwidth
Value_4381FsampleBandwidth | 210 | 4.381*Fsample/Bandwidth
Value_4402FsampleBandwidth | 211 | 4.402*Fsample/Bandwidth
Value_4423FsampleBandwidth | 212 | 4.423*Fsample/Bandwidth
Value_4444FsampleBandwidth | 213 | 4.444*Fsample/Bandwidth
Value_4464FsampleBandwidth | 214 | 4.464*Fsample/Bandwidth
Value_4485FsampleBandwidth | 215 | 4.485*Fsample/Bandwidth
Value_4506FsampleBandwidth | 216 | 4.506*Fsample/Bandwidth
Value_4527FsampleBandwidth | 217 | 4.527*Fsample/Bandwidth
Value_4548FsampleBandwidth | 218 | 4.548*Fsample/Bandwidth
Value_4569FsampleBandwidth | 219 | 4.569*Fsample/Bandwidth
Value_4590FsampleBandwidth | 220 | 4.590*Fsample/Bandwidth
Value_4610FsampleBandwidth | 221 | 4.610*Fsample/Bandwidth
Value_4631FsampleBandwidth | 222 | 4.631*Fsample/Bandwidth
Value_4652FsampleBandwidth | 223 | 4.652*Fsample/Bandwidth
Value_4673FsampleBandwidth | 224 | 4.673*Fsample/Bandwidth
Value_4694FsampleBandwidth | 225 | 4.694*Fsample/Bandwidth
Value_4715FsampleBandwidth | 226 | 4.715*Fsample/Bandwidth
Value_4736FsampleBandwidth | 227 | 4.736*Fsample/Bandwidth
Value_4756FsampleBandwidth | 228 | 4.756*Fsample/Bandwidth
Value_4777FsampleBandwidth | 229 | 4.777*Fsample/Bandwidth
Value_4798FsampleBandwidth | 230 | 4.798*Fsample/Bandwidth
Value_4819FsampleBandwidth | 231 | 4.819*Fsample/Bandwidth
Value_4840FsampleBandwidth | 232 | 4.840*Fsample/Bandwidth
Value_4861FsampleBandwidth | 233 | 4.861*Fsample/Bandwidth
Value_4882FsampleBandwidth | 234 | 4.882*Fsample/Bandwidth
Value_4902FsampleBandwidth | 235 | 4.902*Fsample/Bandwidth
Value_4923FsampleBandwidth | 236 | 4.923*Fsample/Bandwidth
Value_4944FsampleBandwidth | 237 | 4.944*Fsample/Bandwidth
Value_4965FsampleBandwidth | 238 | 4.965*Fsample/Bandwidth
Value_4986FsampleBandwidth | 239 | 4.986*Fsample/Bandwidth
Value_5007FsampleBandwidth | 240 | 5.007*Fsample/Bandwidth
Value_5028FsampleBandwidth | 241 | 5.028*Fsample/Bandwidth
Value_5049FsampleBandwidth | 242 | 5.049*Fsample/Bandwidth
Value_5069FsampleBandwidth | 243 | 5.069*Fsample/Bandwidth
Value_5090FsampleBandwidth | 244 | 5.090*Fsample/Bandwidth
Value_5111FsampleBandwidth | 245 | 5.111*Fsample/Bandwidth
Value_5132FsampleBandwidth | 246 | 5.132*Fsample/Bandwidth
Value_5153FsampleBandwidth | 247 | 5.153*Fsample/Bandwidth
Value_5174FsampleBandwidth | 248 | 5.174*Fsample/Bandwidth
Value_5195FsampleBandwidth | 249 | 5.195*Fsample/Bandwidth
Value_5215FsampleBandwidth | 250 | 5.215*Fsample/Bandwidth
Value_5236FsampleBandwidth | 251 | 5.236*Fsample/Bandwidth
Value_5257FsampleBandwidth | 252 | 5.257*Fsample/Bandwidth
Value_5278FsampleBandwidth | 253 | 5.278*Fsample/Bandwidth
Value_5299FsampleBandwidth | 254 | 5.299*Fsample/Bandwidth
Value_5320FsampleBandwidth | 255 | 5.320*Fsample/Bandwidth
See Also

Reference

telos.Ird.NXPSemiconductors Namespace


telos.Ird.SBSForum Namespace

Classes
 | Class | Description
Public class | Battery | SBS Forum: Smart Battery Data
Public class | BatteryFuelCell | SBS Forum: Smart Battery Data - Fuel Cell
Public class | Charger | SBS Forum: Smart Battery Charger
Public class | Manager | SBS Forum: Smart Battery Manager
Public class | Selector | SBS Forum: Smart Battery Selector
Public class | SmbusArp | SBS Forum: SMBus ARP
Enumerations
 | Enumeration | Description
Public enumeration | BatteryAtRateOkType |
Public enumeration | BatteryAtRateTimeToEmptyType |
Public enumeration | BatteryAtRateTimeToFullType |
Public enumeration | BatteryChargingCurrentType |
Public enumeration | BatteryChargingVoltageType |
Public enumeration | BatteryCycleCountType |
Public enumeration | BatteryModeAlarmModeType |
Public enumeration | BatteryModeCapacityModeType |
Public enumeration | BatteryModeChargeControllerEnabledType |
Public enumeration | BatteryModeChargerModeType |
Public enumeration | BatteryModeConditionFlagType |
Public enumeration | BatteryModePrimaryBatterySupportType |
Public enumeration | BatteryModePrimaryBatteryType |
Public enumeration | BatteryModeSupportedType |
Public enumeration | BatterySpecificationInfoRevisionType |
Public enumeration | BatterySpecificationInfoVersionType |
Public enumeration | BatteryStatusDischargingType |
Public enumeration | BatteryStatusErrorCodeType |
Public enumeration | BatteryStatusFullyChargedType |
Public enumeration | BatteryStatusFullyDischargedType |
Public enumeration | BatteryStatusInitializedType |
Public enumeration | BatteryStatusOverChargedType |
Public enumeration | BatteryStatusOverTempType |
Public enumeration | BatteryStatusRemainingCapacityType |
Public enumeration | BatteryStatusRemainingTimeType |
Public enumeration | BatteryStatusTerminateChargeType |
Public enumeration | BatteryStatusTerminateDischargeType |
Public enumeration | BatteryFuelCellAtRateOkType |
Public enumeration | BatteryFuelCellAtRateTimeToEmptyType |
Public enumeration | BatteryFuelCellAtRateTimeToFullType |
Public enumeration | BatteryFuelCellChargingCurrentType |
Public enumeration | BatteryFuelCellChargingVoltageType |
Public enumeration | BatteryFuelCellCycleCountType |
Public enumeration | BatteryFuelCellFcModeChangeStatusEnableType |
Public enumeration | BatteryFuelCellFcModeFcTempGranularityType |
Public enumeration | BatteryFuelCellFcModeFuelCellSelectorType |
Public enumeration | BatteryFuelCellFcStatusAlarmConditionsType |
Public enumeration | BatteryFuelCellFcStatusCartridgeStatusType |
Public enumeration | BatteryFuelCellFcStatusInternalBatteryType |
Public enumeration | BatteryFuelCellFcStatusStateType |
Public enumeration | BatteryFuelCellModeAlarmModeType |
Public enumeration | BatteryFuelCellModeCapacityModeType |
Public enumeration | BatteryFuelCellModeChargeControllerEnabledType |
Public enumeration | BatteryFuelCellModeChargerModeType |
Public enumeration | BatteryFuelCellModeConditionFlagType |
Public enumeration | BatteryFuelCellModeFuelCellType |
Public enumeration | BatteryFuelCellModePrimaryBatterySupportType |
Public enumeration | BatteryFuelCellModePrimaryBatteryType |
Public enumeration | BatteryFuelCellModeSupportedType |
Public enumeration | BatteryFuelCellRemainingCapacityAlarmType |
Public enumeration | BatteryFuelCellRemainingTimeAlarmType |
Public enumeration | BatteryFuelCellSpecificationInfoRevisionType |
Public enumeration | BatteryFuelCellSpecificationInfoVersionType |
Public enumeration | BatteryFuelCellStartTimeType |
Public enumeration | BatteryFuelCellStatusDischargingType |
Public enumeration | BatteryFuelCellStatusErrorCodeType |
Public enumeration | BatteryFuelCellStatusFullyChargedType |
Public enumeration | BatteryFuelCellStatusFullyDischargedType |
Public enumeration | BatteryFuelCellStatusInitializedType |
Public enumeration | BatteryFuelCellStatusOverChargedType |
Public enumeration | BatteryFuelCellStatusOverTempType |
Public enumeration | BatteryFuelCellStatusRemainingCapacityType |
Public enumeration | BatteryFuelCellStatusRemainingTimeType |
Public enumeration | BatteryFuelCellStatusTerminateChargeType |
Public enumeration | BatteryFuelCellStatusTerminateDischargeType |
Public enumeration | BatteryFuelCellTotalRuntimeType |
Public enumeration | ChargerAcPresentType |
Public enumeration | ChargerAlarmErrorType |
Public enumeration | ChargerAlarmInhibitedType |
Public enumeration | ChargerBatteryPresentType |
Public enumeration | ChargerChargeInhibitedType |
Public enumeration | ChargerChargingCurrentType |
Public enumeration | ChargerChargingVoltageType |
Public enumeration | ChargerCurrentNotregType |
Public enumeration | ChargerCurrentOrType |
Public enumeration | ChargerEnablePollingType |
Public enumeration | ChargerInhibitChargeType |
Public enumeration | ChargerLevelType |
Public enumeration | ChargerOverChargedAlarmType |
Public enumeration | ChargerOverTempAlarmType |
Public enumeration | ChargerPollingEnabledType |
Public enumeration | ChargerPorResetType |
Public enumeration | ChargerPowerFailType |
Public enumeration | ChargerResColdType |
Public enumeration | ChargerResetToZeroType |
Public enumeration | ChargerResHotType |
Public enumeration | ChargerResOrType |
Public enumeration | ChargerResUrType |
Public enumeration | ChargerSelectorSupportType |
Public enumeration | ChargerSpecVersionType |
Public enumeration | ChargerStatusDischargingType |
Public enumeration | ChargerStatusFullyChargedType |
Public enumeration | ChargerStatusFullyDischargedType |
Public enumeration | ChargerStatusInitializedType |
Public enumeration | ChargerTerminateChargeAlarmType |
Public enumeration | ChargerTerminateDischargeAlarmType |
Public enumeration | ChargerVoltageNotregType |
Public enumeration | ChargerVoltageOrType |
Public enumeration | ManagerBoolType |
Public enumeration | ManagerSupportedType |
Public enumeration | ManagerSystemInfoRevisionType |
Public enumeration | ManagerSystemStateChargeType |
Public enumeration | ManagerSystemStateContCalibrateXType |
Public enumeration | ManagerSystemStateContChargerPorType |
Public enumeration | ManagerSystemStateContChargingInhibitType |
Public enumeration | ManagerSystemStatePowerByType |
Public enumeration | ManagerSystemStatePresentType |
Public enumeration | ManagerSystemStateSmbType |
Public enumeration | SelectorOkToUseType |
Public enumeration | SelectorPresentType |
Public enumeration | SelectorSelectorRevisionType |
Public enumeration | SelectorSelectorStateChargeReadType |
Public enumeration | SelectorSelectorStateChargeWriteType |
Public enumeration | SelectorSelectorStatePowerByReadType |
Public enumeration | SelectorSelectorStatePowerByWriteType |
Public enumeration | SelectorSelectorStateSmbReadType |
Public enumeration | SelectorSelectorStateSmbWriteType |
Public enumeration | SelectorSupportedType |
Public enumeration | SelectorUseNextType |
Public enumeration | SmbusArpTypeAddress |
Public enumeration | SmbusArpTypeSmbusVersion |
Public enumeration | SmbusArpTypeSupported |
Public enumeration | SmbusArpTypeUdidVersion |


Battery Class

SBS Forum: Smart Battery Data
Inheritance Hierarchy
SystemObject
telos.Ird.SBSForumBattery

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Battery
Public Class Battery
public ref class Battery
type Battery =  class end

The Battery type exposes the following members.

Constructors
 | Name | Description
Public method | Battery | Constructor
Top
Properties
 | Name | Description
Public property | AbsoluteStateOfCharge | Absolute State Of Charge (unit: %)
Public property | AtRate | At Rate (unit: mA ; 10 mW)
Public property | AtRateOK | At Rate OK
Public property | AtRateTimeToEmpty | At Rate Time To Empty (unit: min)
Public property | AtRateTimeToFull | At Rate Time To Full (unit: min)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AverageCurrent | Average Current (unit: mA)
Public property | AverageTimeToEmpty | Average Time To Empty (unit: min)
Public property | AverageTimeToFull | Average Time To Full (unit: min)
Public property | ChargingCurrent | Charging Current (unit: mA)
Public property | ChargingVoltage | Charging Voltage (unit: mV)
Public property | Current | Current (unit: mA)
Public property | CycleCount | Cycle Count
Public property | DesignCapacity | Design Capacity (unit: mAh ; 10 mWh)
Public property | DesignVoltage | Design Voltage (unit: mV)
Public property | DeviceChemistry | Device Chemistry
Public property | DeviceName | Device Name
Public property | FullChargeCapacity | Full Charge Capacity (unit: mAh ; 10 mWh)
Public property | ManufactureDateDay | Manufacture Date: Day
Public property | ManufactureDateMonth | Manufacture Date: Month
Public property | ManufactureDateYear | Manufacture Date: Year
Public property | ManufacturerAccess | Manufacturer Access
Public property | ManufacturerData | Manufacturer Data
Public property | ManufacturerName | Manufacturer Name
Public property | MaxError | Max Error (unit: %)
Public property | ModeAlarmMode | Mode: Alarm Mode
Public property | ModeCapacityMode | Mode: Capacity Mode
Public property | ModeChargeControllerEnabled | Mode: Charge Controller Enabled
Public property | ModeChargerMode | Mode: Charger Mode
Public property | ModeConditionFlag | Mode: Condition Flag
Public property | ModeInternalChargeController | Mode: Internal Charge Controller
Public property | ModePrimaryBattery | Mode: Primary Battery
Public property | ModePrimaryBatterySupport | Mode: Primary Battery Support
Public property | RelativeStateOfCharge | Relative State Of Charge (unit: %)
Public property | RemainingCapacity | Remaining Capacity (unit: mAh ; 10 mWh)
Public property | RemainingCapacityAlarm | Remaining Capacity Alarm (unit: mAh @ C/5 ; 10 mWh @ P/5)
Public property | RemainingTimeAlarm | Remaining Time Alarm (unit: min)
Public property | RunTimeToEmpty | Run Time To Empty (unit: min)
Public property | SerialNumber | Serial Number
Public property | SpecificationInfoIPScale | Specification Info: IPScale
Public property | SpecificationInfoRevision | Specification Info: Revision
Public property | SpecificationInfoVersion | Specification Info: Version
Public property | SpecificationInfoVScale | Specification Info: VScale
Public property | StatusDischarging | Status: Discharging
Public property | StatusErrorCodes | Status: Error Codes
Public property | StatusFullyCharged | Status: Fully Charged
Public property | StatusFullyDischarged | Status: Fully Discharged
Public property | StatusInitialized | Status: Initialized
Public property | StatusOverChargedAlarm | Status: Over Charged Alarm
Public property | StatusOverTempAlarm | Status: Over Temp Alarm
Public property | StatusRemainingCapacityAlarm | Status: Remaining Capacity Alarm
Public property | StatusRemainingTimeAlarm | Status: Remaining Time Alarm
Public property | StatusTerminateChargeAlarm | Status: Terminate Charge Alarm
Public property | StatusTerminateDischargeAlarm | Status: Terminate Discharge Alarm
Public property | Temperature | Temperature (unit: °K)
Public property | Voltage | Voltage (unit: mV)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Smart Battery Data - Revision 1.1
See Also

Reference

telos.Ird.SBSForum Namespace


Battery Constructor

Constructor

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Battery(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Battery(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Battery

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery Properties

The Battery type exposes the following members.

Properties
 | Name | Description
Public property | AbsoluteStateOfCharge | Absolute State Of Charge (unit: %)
Public property | AtRate | At Rate (unit: mA ; 10 mW)
Public property | AtRateOK | At Rate OK
Public property | AtRateTimeToEmpty | At Rate Time To Empty (unit: min)
Public property | AtRateTimeToFull | At Rate Time To Full (unit: min)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AverageCurrent | Average Current (unit: mA)
Public property | AverageTimeToEmpty | Average Time To Empty (unit: min)
Public property | AverageTimeToFull | Average Time To Full (unit: min)
Public property | ChargingCurrent | Charging Current (unit: mA)
Public property | ChargingVoltage | Charging Voltage (unit: mV)
Public property | Current | Current (unit: mA)
Public property | CycleCount | Cycle Count
Public property | DesignCapacity | Design Capacity (unit: mAh ; 10 mWh)
Public property | DesignVoltage | Design Voltage (unit: mV)
Public property | DeviceChemistry | Device Chemistry
Public property | DeviceName | Device Name
Public property | FullChargeCapacity | Full Charge Capacity (unit: mAh ; 10 mWh)
Public property | ManufactureDateDay | Manufacture Date: Day
Public property | ManufactureDateMonth | Manufacture Date: Month
Public property | ManufactureDateYear | Manufacture Date: Year
Public property | ManufacturerAccess | Manufacturer Access
Public property | ManufacturerData | Manufacturer Data
Public property | ManufacturerName | Manufacturer Name
Public property | MaxError | Max Error (unit: %)
Public property | ModeAlarmMode | Mode: Alarm Mode
Public property | ModeCapacityMode | Mode: Capacity Mode
Public property | ModeChargeControllerEnabled | Mode: Charge Controller Enabled
Public property | ModeChargerMode | Mode: Charger Mode
Public property | ModeConditionFlag | Mode: Condition Flag
Public property | ModeInternalChargeController | Mode: Internal Charge Controller
Public property | ModePrimaryBattery | Mode: Primary Battery
Public property | ModePrimaryBatterySupport | Mode: Primary Battery Support
Public property | RelativeStateOfCharge | Relative State Of Charge (unit: %)
Public property | RemainingCapacity | Remaining Capacity (unit: mAh ; 10 mWh)
Public property | RemainingCapacityAlarm | Remaining Capacity Alarm (unit: mAh @ C/5 ; 10 mWh @ P/5)
Public property | RemainingTimeAlarm | Remaining Time Alarm (unit: min)
Public property | RunTimeToEmpty | Run Time To Empty (unit: min)
Public property | SerialNumber | Serial Number
Public property | SpecificationInfoIPScale | Specification Info: IPScale
Public property | SpecificationInfoRevision | Specification Info: Revision
Public property | SpecificationInfoVersion | Specification Info: Version
Public property | SpecificationInfoVScale | Specification Info: VScale
Public property | StatusDischarging | Status: Discharging
Public property | StatusErrorCodes | Status: Error Codes
Public property | StatusFullyCharged | Status: Fully Charged
Public property | StatusFullyDischarged | Status: Fully Discharged
Public property | StatusInitialized | Status: Initialized
Public property | StatusOverChargedAlarm | Status: Over Charged Alarm
Public property | StatusOverTempAlarm | Status: Over Temp Alarm
Public property | StatusRemainingCapacityAlarm | Status: Remaining Capacity Alarm
Public property | StatusRemainingTimeAlarm | Status: Remaining Time Alarm
Public property | StatusTerminateChargeAlarm | Status: Terminate Charge Alarm
Public property | StatusTerminateDischargeAlarm | Status: Terminate Discharge Alarm
Public property | Temperature | Temperature (unit: °K)
Public property | Voltage | Voltage (unit: mV)
Top
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.AbsoluteStateOfCharge Property

IRD

BatteryAbsoluteStateOfCharge Property

Absolute State Of Charge (unit: %)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AbsoluteStateOfCharge { get; }
Public ReadOnly Property AbsoluteStateOfCharge As Byte
    Get
public:
property unsigned char AbsoluteStateOfCharge {
    unsigned char get ();
}
member AbsoluteStateOfCharge : byte with get

Property Value

Type: Byte
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.AtRate Property

IRD

BatteryAtRate Property

At Rate (unit: mA ; 10 mW)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short AtRate { get; set; }
Public Property AtRate As Short
    Get
    Set
public:
property short AtRate {
    short get ();
    void set (short value);
}
member AtRate : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.AtRateOK Property

IRD

BatteryAtRateOK Property

At Rate OK

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryAtRateOkType AtRateOK { get; }
Public ReadOnly Property AtRateOK As BatteryAtRateOkType
    Get
public:
property BatteryAtRateOkType AtRateOK {
    BatteryAtRateOkType get ();
}
member AtRateOK : BatteryAtRateOkType with get

Property Value

Type: BatteryAtRateOkType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.AtRateTimeToEmpty Property

IRD

BatteryAtRateTimeToEmpty Property

At Rate Time To Empty (unit: min)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryAtRateTimeToEmptyType AtRateTimeToEmpty { get; }
Public ReadOnly Property AtRateTimeToEmpty As BatteryAtRateTimeToEmptyType
    Get
public:
property BatteryAtRateTimeToEmptyType AtRateTimeToEmpty {
    BatteryAtRateTimeToEmptyType get ();
}
member AtRateTimeToEmpty : BatteryAtRateTimeToEmptyType with get

Property Value

Type: BatteryAtRateTimeToEmptyType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.AtRateTimeToFull Property

IRD

BatteryAtRateTimeToFull Property

At Rate Time To Full (unit: min)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryAtRateTimeToFullType AtRateTimeToFull { get; }
Public ReadOnly Property AtRateTimeToFull As BatteryAtRateTimeToFullType
    Get
public:
property BatteryAtRateTimeToFullType AtRateTimeToFull {
    BatteryAtRateTimeToFullType get ();
}
member AtRateTimeToFull : BatteryAtRateTimeToFullType with get

Property Value

Type: BatteryAtRateTimeToFullType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.AutoFlush Property

IRD

BatteryAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.AverageCurrent Property

IRD

BatteryAverageCurrent Property

Average Current (unit: mA)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short AverageCurrent { get; }
Public ReadOnly Property AverageCurrent As Short
    Get
public:
property short AverageCurrent {
    short get ();
}
member AverageCurrent : int16 with get

Property Value

Type: Int16
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.AverageTimeToEmpty Property

IRD

BatteryAverageTimeToEmpty Property

Average Time To Empty (unit: min)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryAtRateTimeToEmptyType AverageTimeToEmpty { get; }
Public ReadOnly Property AverageTimeToEmpty As BatteryAtRateTimeToEmptyType
    Get
public:
property BatteryAtRateTimeToEmptyType AverageTimeToEmpty {
    BatteryAtRateTimeToEmptyType get ();
}
member AverageTimeToEmpty : BatteryAtRateTimeToEmptyType with get

Property Value

Type: BatteryAtRateTimeToEmptyType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.AverageTimeToFull Property

IRD

BatteryAverageTimeToFull Property

Average Time To Full (unit: min)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryAtRateTimeToFullType AverageTimeToFull { get; }
Public ReadOnly Property AverageTimeToFull As BatteryAtRateTimeToFullType
    Get
public:
property BatteryAtRateTimeToFullType AverageTimeToFull {
    BatteryAtRateTimeToFullType get ();
}
member AverageTimeToFull : BatteryAtRateTimeToFullType with get

Property Value

Type: BatteryAtRateTimeToFullType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.ChargingCurrent Property

IRD

BatteryChargingCurrent Property

Charging Current (unit: mA)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryChargingCurrentType ChargingCurrent { get; }
Public ReadOnly Property ChargingCurrent As BatteryChargingCurrentType
    Get
public:
property BatteryChargingCurrentType ChargingCurrent {
    BatteryChargingCurrentType get ();
}
member ChargingCurrent : BatteryChargingCurrentType with get

Property Value

Type: BatteryChargingCurrentType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.ChargingVoltage Property

IRD

BatteryChargingVoltage Property

Charging Voltage (unit: mV)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryChargingVoltageType ChargingVoltage { get; }
Public ReadOnly Property ChargingVoltage As BatteryChargingVoltageType
    Get
public:
property BatteryChargingVoltageType ChargingVoltage {
    BatteryChargingVoltageType get ();
}
member ChargingVoltage : BatteryChargingVoltageType with get

Property Value

Type: BatteryChargingVoltageType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.Current Property

IRD

BatteryCurrent Property

Current (unit: mA)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short Current { get; }
Public ReadOnly Property Current As Short
    Get
public:
property short Current {
    short get ();
}
member Current : int16 with get

Property Value

Type: Int16
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.CycleCount Property

IRD

BatteryCycleCount Property

Cycle Count

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryCycleCountType CycleCount { get; }
Public ReadOnly Property CycleCount As BatteryCycleCountType
    Get
public:
property BatteryCycleCountType CycleCount {
    BatteryCycleCountType get ();
}
member CycleCount : BatteryCycleCountType with get

Property Value

Type: BatteryCycleCountType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.DesignCapacity Property

IRD

BatteryDesignCapacity Property

Design Capacity (unit: mAh ; 10 mWh)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DesignCapacity { get; }
Public ReadOnly Property DesignCapacity As UShort
    Get
public:
property unsigned short DesignCapacity {
    unsigned short get ();
}
member DesignCapacity : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.DesignVoltage Property

IRD

BatteryDesignVoltage Property

Design Voltage (unit: mV)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DesignVoltage { get; }
Public ReadOnly Property DesignVoltage As UShort
    Get
public:
property unsigned short DesignVoltage {
    unsigned short get ();
}
member DesignVoltage : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.DeviceChemistry Property

IRD

BatteryDeviceChemistry Property

Device Chemistry

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public string DeviceChemistry { get; }
Public ReadOnly Property DeviceChemistry As String
    Get
public:
property String^ DeviceChemistry {
    String^ get ();
}
member DeviceChemistry : string with get

Property Value

Type: String
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.DeviceName Property

IRD

BatteryDeviceName Property

Device Name

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public string DeviceName { get; }
Public ReadOnly Property DeviceName As String
    Get
public:
property String^ DeviceName {
    String^ get ();
}
member DeviceName : string with get

Property Value

Type: String
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.FullChargeCapacity Property

IRD

BatteryFullChargeCapacity Property

Full Charge Capacity (unit: mAh ; 10 mWh)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort FullChargeCapacity { get; }
Public ReadOnly Property FullChargeCapacity As UShort
    Get
public:
property unsigned short FullChargeCapacity {
    unsigned short get ();
}
member FullChargeCapacity : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.ManufactureDateDay Property

IRD

BatteryManufactureDateDay Property

Manufacture Date: Day

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufactureDateDay { get; }
Public ReadOnly Property ManufactureDateDay As Byte
    Get
public:
property unsigned char ManufactureDateDay {
    unsigned char get ();
}
member ManufactureDateDay : byte with get

Property Value

Type: Byte
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.ManufactureDateMonth Property

IRD

BatteryManufactureDateMonth Property

Manufacture Date: Month

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufactureDateMonth { get; }
Public ReadOnly Property ManufactureDateMonth As Byte
    Get
public:
property unsigned char ManufactureDateMonth {
    unsigned char get ();
}
member ManufactureDateMonth : byte with get

Property Value

Type: Byte
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.ManufactureDateYear Property

IRD

BatteryManufactureDateYear Property

Manufacture Date: Year

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ManufactureDateYear { get; }
Public ReadOnly Property ManufactureDateYear As UShort
    Get
public:
property unsigned short ManufactureDateYear {
    unsigned short get ();
}
member ManufactureDateYear : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.ManufacturerAccess Property

IRD

BatteryManufacturerAccess Property

Manufacturer Access

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ManufacturerAccess { get; set; }
Public Property ManufacturerAccess As UShort
    Get
    Set
public:
property unsigned short ManufacturerAccess {
    unsigned short get ();
    void set (unsigned short value);
}
member ManufacturerAccess : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.ManufacturerData Property

IRD

BatteryManufacturerData Property

Manufacturer Data

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] ManufacturerData { get; }
Public ReadOnly Property ManufacturerData As Byte()
    Get
public:
property array<unsigned char>^ ManufacturerData {
    array<unsigned char>^ get ();
}
member ManufacturerData : byte[] with get

Property Value

Type: Byte
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.ManufacturerName Property

IRD

BatteryManufacturerName Property

Manufacturer Name

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public string ManufacturerName { get; }
Public ReadOnly Property ManufacturerName As String
    Get
public:
property String^ ManufacturerName {
    String^ get ();
}
member ManufacturerName : string with get

Property Value

Type: String
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.MaxError Property

IRD

BatteryMaxError Property

Max Error (unit: %)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MaxError { get; }
Public ReadOnly Property MaxError As Byte
    Get
public:
property unsigned char MaxError {
    unsigned char get ();
}
member MaxError : byte with get

Property Value

Type: Byte
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.ModeAlarmMode Property

IRD

BatteryModeAlarmMode Property

Mode: Alarm Mode

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryModeAlarmModeType ModeAlarmMode { get; set; }
Public Property ModeAlarmMode As BatteryModeAlarmModeType
    Get
    Set
public:
property BatteryModeAlarmModeType ModeAlarmMode {
    BatteryModeAlarmModeType get ();
    void set (BatteryModeAlarmModeType value);
}
member ModeAlarmMode : BatteryModeAlarmModeType with get, set

Property Value

Type: BatteryModeAlarmModeType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.ModeCapacityMode Property

IRD

BatteryModeCapacityMode Property

Mode: Capacity Mode

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryModeCapacityModeType ModeCapacityMode { get; set; }
Public Property ModeCapacityMode As BatteryModeCapacityModeType
    Get
    Set
public:
property BatteryModeCapacityModeType ModeCapacityMode {
    BatteryModeCapacityModeType get ();
    void set (BatteryModeCapacityModeType value);
}
member ModeCapacityMode : BatteryModeCapacityModeType with get, set

Property Value

Type: BatteryModeCapacityModeType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.ModeChargeControllerEnabled Property

IRD

BatteryModeChargeControllerEnabled Property

Mode: Charge Controller Enabled

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryModeChargeControllerEnabledType ModeChargeControllerEnabled { get; set; }
Public Property ModeChargeControllerEnabled As BatteryModeChargeControllerEnabledType
    Get
    Set
public:
property BatteryModeChargeControllerEnabledType ModeChargeControllerEnabled {
    BatteryModeChargeControllerEnabledType get ();
    void set (BatteryModeChargeControllerEnabledType value);
}
member ModeChargeControllerEnabled : BatteryModeChargeControllerEnabledType with get, set

Property Value

Type: BatteryModeChargeControllerEnabledType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.ModeChargerMode Property

IRD

BatteryModeChargerMode Property

Mode: Charger Mode

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryModeChargerModeType ModeChargerMode { get; set; }
Public Property ModeChargerMode As BatteryModeChargerModeType
    Get
    Set
public:
property BatteryModeChargerModeType ModeChargerMode {
    BatteryModeChargerModeType get ();
    void set (BatteryModeChargerModeType value);
}
member ModeChargerMode : BatteryModeChargerModeType with get, set

Property Value

Type: BatteryModeChargerModeType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.ModeConditionFlag Property

IRD

BatteryModeConditionFlag Property

Mode: Condition Flag

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryModeConditionFlagType ModeConditionFlag { get; }
Public ReadOnly Property ModeConditionFlag As BatteryModeConditionFlagType
    Get
public:
property BatteryModeConditionFlagType ModeConditionFlag {
    BatteryModeConditionFlagType get ();
}
member ModeConditionFlag : BatteryModeConditionFlagType with get

Property Value

Type: BatteryModeConditionFlagType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.ModeInternalChargeController Property

IRD

BatteryModeInternalChargeController Property

Mode: Internal Charge Controller

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryModeSupportedType ModeInternalChargeController { get; }
Public ReadOnly Property ModeInternalChargeController As BatteryModeSupportedType
    Get
public:
property BatteryModeSupportedType ModeInternalChargeController {
    BatteryModeSupportedType get ();
}
member ModeInternalChargeController : BatteryModeSupportedType with get

Property Value

Type: BatteryModeSupportedType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.ModePrimaryBattery Property

IRD

BatteryModePrimaryBattery Property

Mode: Primary Battery

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryModePrimaryBatteryType ModePrimaryBattery { get; set; }
Public Property ModePrimaryBattery As BatteryModePrimaryBatteryType
    Get
    Set
public:
property BatteryModePrimaryBatteryType ModePrimaryBattery {
    BatteryModePrimaryBatteryType get ();
    void set (BatteryModePrimaryBatteryType value);
}
member ModePrimaryBattery : BatteryModePrimaryBatteryType with get, set

Property Value

Type: BatteryModePrimaryBatteryType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.ModePrimaryBatterySupport Property

IRD

BatteryModePrimaryBatterySupport Property

Mode: Primary Battery Support

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryModePrimaryBatterySupportType ModePrimaryBatterySupport { get; }
Public ReadOnly Property ModePrimaryBatterySupport As BatteryModePrimaryBatterySupportType
    Get
public:
property BatteryModePrimaryBatterySupportType ModePrimaryBatterySupport {
    BatteryModePrimaryBatterySupportType get ();
}
member ModePrimaryBatterySupport : BatteryModePrimaryBatterySupportType with get

Property Value

Type: BatteryModePrimaryBatterySupportType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.RelativeStateOfCharge Property

IRD

BatteryRelativeStateOfCharge Property

Relative State Of Charge (unit: %)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RelativeStateOfCharge { get; }
Public ReadOnly Property RelativeStateOfCharge As Byte
    Get
public:
property unsigned char RelativeStateOfCharge {
    unsigned char get ();
}
member RelativeStateOfCharge : byte with get

Property Value

Type: Byte
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.RemainingCapacity Property

IRD

BatteryRemainingCapacity Property

Remaining Capacity (unit: mAh ; 10 mWh)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort RemainingCapacity { get; }
Public ReadOnly Property RemainingCapacity As UShort
    Get
public:
property unsigned short RemainingCapacity {
    unsigned short get ();
}
member RemainingCapacity : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.RemainingCapacityAlarm Property

IRD

BatteryRemainingCapacityAlarm Property

Remaining Capacity Alarm (unit: mAh @ C/5 ; 10 mWh @ P/5)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort RemainingCapacityAlarm { get; set; }
Public Property RemainingCapacityAlarm As UShort
    Get
    Set
public:
property unsigned short RemainingCapacityAlarm {
    unsigned short get ();
    void set (unsigned short value);
}
member RemainingCapacityAlarm : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.RemainingTimeAlarm Property

IRD

BatteryRemainingTimeAlarm Property

Remaining Time Alarm (unit: min)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort RemainingTimeAlarm { get; set; }
Public Property RemainingTimeAlarm As UShort
    Get
    Set
public:
property unsigned short RemainingTimeAlarm {
    unsigned short get ();
    void set (unsigned short value);
}
member RemainingTimeAlarm : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.RunTimeToEmpty Property

IRD

BatteryRunTimeToEmpty Property

Run Time To Empty (unit: min)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryAtRateTimeToEmptyType RunTimeToEmpty { get; }
Public ReadOnly Property RunTimeToEmpty As BatteryAtRateTimeToEmptyType
    Get
public:
property BatteryAtRateTimeToEmptyType RunTimeToEmpty {
    BatteryAtRateTimeToEmptyType get ();
}
member RunTimeToEmpty : BatteryAtRateTimeToEmptyType with get

Property Value

Type: BatteryAtRateTimeToEmptyType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.SerialNumber Property

IRD

BatterySerialNumber Property

Serial Number

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort SerialNumber { get; }
Public ReadOnly Property SerialNumber As UShort
    Get
public:
property unsigned short SerialNumber {
    unsigned short get ();
}
member SerialNumber : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.SpecificationInfoIPScale Property

IRD

BatterySpecificationInfoIPScale Property

Specification Info: IPScale

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SpecificationInfoIPScale { get; }
Public ReadOnly Property SpecificationInfoIPScale As Byte
    Get
public:
property unsigned char SpecificationInfoIPScale {
    unsigned char get ();
}
member SpecificationInfoIPScale : byte with get

Property Value

Type: Byte
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.SpecificationInfoRevision Property

IRD

BatterySpecificationInfoRevision Property

Specification Info: Revision

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatterySpecificationInfoRevisionType SpecificationInfoRevision { get; }
Public ReadOnly Property SpecificationInfoRevision As BatterySpecificationInfoRevisionType
    Get
public:
property BatterySpecificationInfoRevisionType SpecificationInfoRevision {
    BatterySpecificationInfoRevisionType get ();
}
member SpecificationInfoRevision : BatterySpecificationInfoRevisionType with get

Property Value

Type: BatterySpecificationInfoRevisionType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.SpecificationInfoVersion Property

IRD

BatterySpecificationInfoVersion Property

Specification Info: Version

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatterySpecificationInfoVersionType SpecificationInfoVersion { get; }
Public ReadOnly Property SpecificationInfoVersion As BatterySpecificationInfoVersionType
    Get
public:
property BatterySpecificationInfoVersionType SpecificationInfoVersion {
    BatterySpecificationInfoVersionType get ();
}
member SpecificationInfoVersion : BatterySpecificationInfoVersionType with get

Property Value

Type: BatterySpecificationInfoVersionType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.SpecificationInfoVScale Property

IRD

BatterySpecificationInfoVScale Property

Specification Info: VScale

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SpecificationInfoVScale { get; }
Public ReadOnly Property SpecificationInfoVScale As Byte
    Get
public:
property unsigned char SpecificationInfoVScale {
    unsigned char get ();
}
member SpecificationInfoVScale : byte with get

Property Value

Type: Byte
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.StatusDischarging Property

IRD

BatteryStatusDischarging Property

Status: Discharging

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryStatusDischargingType StatusDischarging { get; }
Public ReadOnly Property StatusDischarging As BatteryStatusDischargingType
    Get
public:
property BatteryStatusDischargingType StatusDischarging {
    BatteryStatusDischargingType get ();
}
member StatusDischarging : BatteryStatusDischargingType with get

Property Value

Type: BatteryStatusDischargingType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.StatusErrorCodes Property

IRD

BatteryStatusErrorCodes Property

Status: Error Codes

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryStatusErrorCodeType StatusErrorCodes { get; }
Public ReadOnly Property StatusErrorCodes As BatteryStatusErrorCodeType
    Get
public:
property BatteryStatusErrorCodeType StatusErrorCodes {
    BatteryStatusErrorCodeType get ();
}
member StatusErrorCodes : BatteryStatusErrorCodeType with get

Property Value

Type: BatteryStatusErrorCodeType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.StatusFullyCharged Property

IRD

BatteryStatusFullyCharged Property

Status: Fully Charged

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryStatusFullyChargedType StatusFullyCharged { get; }
Public ReadOnly Property StatusFullyCharged As BatteryStatusFullyChargedType
    Get
public:
property BatteryStatusFullyChargedType StatusFullyCharged {
    BatteryStatusFullyChargedType get ();
}
member StatusFullyCharged : BatteryStatusFullyChargedType with get

Property Value

Type: BatteryStatusFullyChargedType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.StatusFullyDischarged Property

IRD

BatteryStatusFullyDischarged Property

Status: Fully Discharged

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryStatusFullyDischargedType StatusFullyDischarged { get; }
Public ReadOnly Property StatusFullyDischarged As BatteryStatusFullyDischargedType
    Get
public:
property BatteryStatusFullyDischargedType StatusFullyDischarged {
    BatteryStatusFullyDischargedType get ();
}
member StatusFullyDischarged : BatteryStatusFullyDischargedType with get

Property Value

Type: BatteryStatusFullyDischargedType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.StatusInitialized Property

IRD

BatteryStatusInitialized Property

Status: Initialized

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryStatusInitializedType StatusInitialized { get; }
Public ReadOnly Property StatusInitialized As BatteryStatusInitializedType
    Get
public:
property BatteryStatusInitializedType StatusInitialized {
    BatteryStatusInitializedType get ();
}
member StatusInitialized : BatteryStatusInitializedType with get

Property Value

Type: BatteryStatusInitializedType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.StatusOverChargedAlarm Property

IRD

BatteryStatusOverChargedAlarm Property

Status: Over Charged Alarm

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryStatusOverChargedType StatusOverChargedAlarm { get; }
Public ReadOnly Property StatusOverChargedAlarm As BatteryStatusOverChargedType
    Get
public:
property BatteryStatusOverChargedType StatusOverChargedAlarm {
    BatteryStatusOverChargedType get ();
}
member StatusOverChargedAlarm : BatteryStatusOverChargedType with get

Property Value

Type: BatteryStatusOverChargedType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.StatusOverTempAlarm Property

IRD

BatteryStatusOverTempAlarm Property

Status: Over Temp Alarm

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryStatusOverTempType StatusOverTempAlarm { get; }
Public ReadOnly Property StatusOverTempAlarm As BatteryStatusOverTempType
    Get
public:
property BatteryStatusOverTempType StatusOverTempAlarm {
    BatteryStatusOverTempType get ();
}
member StatusOverTempAlarm : BatteryStatusOverTempType with get

Property Value

Type: BatteryStatusOverTempType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.StatusRemainingCapacityAlarm Property

IRD

BatteryStatusRemainingCapacityAlarm Property

Status: Remaining Capacity Alarm

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryStatusRemainingCapacityType StatusRemainingCapacityAlarm { get; }
Public ReadOnly Property StatusRemainingCapacityAlarm As BatteryStatusRemainingCapacityType
    Get
public:
property BatteryStatusRemainingCapacityType StatusRemainingCapacityAlarm {
    BatteryStatusRemainingCapacityType get ();
}
member StatusRemainingCapacityAlarm : BatteryStatusRemainingCapacityType with get

Property Value

Type: BatteryStatusRemainingCapacityType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.StatusRemainingTimeAlarm Property

IRD

BatteryStatusRemainingTimeAlarm Property

Status: Remaining Time Alarm

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryStatusRemainingTimeType StatusRemainingTimeAlarm { get; }
Public ReadOnly Property StatusRemainingTimeAlarm As BatteryStatusRemainingTimeType
    Get
public:
property BatteryStatusRemainingTimeType StatusRemainingTimeAlarm {
    BatteryStatusRemainingTimeType get ();
}
member StatusRemainingTimeAlarm : BatteryStatusRemainingTimeType with get

Property Value

Type: BatteryStatusRemainingTimeType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.StatusTerminateChargeAlarm Property

IRD

BatteryStatusTerminateChargeAlarm Property

Status: Terminate Charge Alarm

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryStatusTerminateChargeType StatusTerminateChargeAlarm { get; }
Public ReadOnly Property StatusTerminateChargeAlarm As BatteryStatusTerminateChargeType
    Get
public:
property BatteryStatusTerminateChargeType StatusTerminateChargeAlarm {
    BatteryStatusTerminateChargeType get ();
}
member StatusTerminateChargeAlarm : BatteryStatusTerminateChargeType with get

Property Value

Type: BatteryStatusTerminateChargeType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.StatusTerminateDischargeAlarm Property

IRD

BatteryStatusTerminateDischargeAlarm Property

Status: Terminate Discharge Alarm

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryStatusTerminateDischargeType StatusTerminateDischargeAlarm { get; }
Public ReadOnly Property StatusTerminateDischargeAlarm As BatteryStatusTerminateDischargeType
    Get
public:
property BatteryStatusTerminateDischargeType StatusTerminateDischargeAlarm {
    BatteryStatusTerminateDischargeType get ();
}
member StatusTerminateDischargeAlarm : BatteryStatusTerminateDischargeType with get

Property Value

Type: BatteryStatusTerminateDischargeType
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.Temperature Property

IRD

BatteryTemperature Property

Temperature (unit: °K)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.Voltage Property

IRD

BatteryVoltage Property

Voltage (unit: mV)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort Voltage { get; }
Public ReadOnly Property Voltage As UShort
    Get
public:
property unsigned short Voltage {
    unsigned short get ();
}
member Voltage : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery Methods

The Battery type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.Flush Method

IRD

BatteryFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Battery Class
telos.Ird.SBSForum Namespace


Battery.AtRateOkType Enumeration

IRD

BatteryAtRateOkType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AtRateOkType
Public Enumeration AtRateOkType
public enum class AtRateOkType
type AtRateOkType
Members
Member name | Value | Description
False | 0 | False
True | 1 | True
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.AtRateTimeToEmptyType Enumeration

IRD

BatteryAtRateTimeToEmptyType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AtRateTimeToEmptyType
Public Enumeration AtRateTimeToEmptyType
public enum class AtRateTimeToEmptyType
type AtRateTimeToEmptyType
Members
Member name | Value | Description
NotDischarged | 65535 | Not Discharged
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.AtRateTimeToFullType Enumeration

IRD

BatteryAtRateTimeToFullType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AtRateTimeToFullType
Public Enumeration AtRateTimeToFullType
public enum class AtRateTimeToFullType
type AtRateTimeToFullType
Members
Member name | Value | Description
NotCharged | 65535 | Not Charged
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.ChargingCurrentType Enumeration

IRD

BatteryChargingCurrentType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ChargingCurrentType
Public Enumeration ChargingCurrentType
public enum class ChargingCurrentType
type ChargingCurrentType
Members
Member name | Value | Description
ChargerShouldBeVoltageSource | 65535 | Charger Should Be Voltage Source
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.ChargingVoltageType Enumeration

IRD

BatteryChargingVoltageType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ChargingVoltageType
Public Enumeration ChargingVoltageType
public enum class ChargingVoltageType
type ChargingVoltageType
Members
Member name | Value | Description
ChargerShouldBeCurrentSource | 65535 | Charger Should Be Current Source
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.CycleCountType Enumeration

IRD

BatteryCycleCountType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CycleCountType
Public Enumeration CycleCountType
public enum class CycleCountType
type CycleCountType
Members
Member name | Value | Description
Value_65535 | 65535 | >= 65535
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.ModeAlarmModeType Enumeration

IRD

BatteryModeAlarmModeType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModeAlarmModeType
Public Enumeration ModeAlarmModeType
public enum class ModeAlarmModeType
type ModeAlarmModeType
Members
Member name | Value | Description
DisableAlarmWarningBroadcasts | 1 | Disable AlarmWarning Broadcasts
EnableAlarmWarningBroadcasts | 0 | Enable AlarmWarning Broadcasts
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.ModeCapacityModeType Enumeration

IRD

BatteryModeCapacityModeType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModeCapacityModeType
Public Enumeration ModeCapacityModeType
public enum class ModeCapacityModeType
type ModeCapacityModeType
Members
Member name | Value | Description
ReportIn10mWOr10mWh | 1 | Report In 10mW Or 10mWh
ReportInMAOrMAh | 0 | Report In mA Or mAh
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.ModeChargeControllerEnabledType Enumeration

IRD

BatteryModeChargeControllerEnabledType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModeChargeControllerEnabledType
Public Enumeration ModeChargeControllerEnabledType
public enum class ModeChargeControllerEnabledType
type ModeChargeControllerEnabledType
Members
Member name | Value | Description
InternalChargeControlEnabled | 1 | Internal Charge Control Enabled
InternalChargeControlDisabled | 0 | Internal Charge Control Disabled
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.ModeChargerModeType Enumeration

IRD

BatteryModeChargerModeType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModeChargerModeType
Public Enumeration ModeChargerModeType
public enum class ModeChargerModeType
type ModeChargerModeType
Members
Member name | Value | Description
DisableChargingVoltageAndChargingCurrentBroadcasts | 1 | Disable ChargingVoltage And ChargingCurrent Broadcasts
EnableChargingVoltageAndChargingCurrentBroadcasts | 0 | Enable ChargingVoltage And ChargingCurrent Broadcasts
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.ModeConditionFlagType Enumeration

IRD

BatteryModeConditionFlagType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModeConditionFlagType
Public Enumeration ModeConditionFlagType
public enum class ModeConditionFlagType
type ModeConditionFlagType
Members
Member name | Value | Description
ConditioningCycleRequested | 1 | Conditioning Cycle Requested
BatteryOK | 0 | Battery OK
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.ModePrimaryBatterySupportType Enumeration

IRD

BatteryModePrimaryBatterySupportType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModePrimaryBatterySupportType
Public Enumeration ModePrimaryBatterySupportType
public enum class ModePrimaryBatterySupportType
type ModePrimaryBatterySupportType
Members
Member name | Value | Description
PrimaryOrSecondaryBatterySupport | 1 | Primary Or Secondary Battery Support
NotSupported | 0 | Not Supported
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.ModePrimaryBatteryType Enumeration

IRD

BatteryModePrimaryBatteryType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModePrimaryBatteryType
Public Enumeration ModePrimaryBatteryType
public enum class ModePrimaryBatteryType
type ModePrimaryBatteryType
Members
Member name | Value | Description
BatteryOperatingInItSecondaryRole | 1 | Battery Operating In It Secondary Role
BatteryOperatingInItPrimaryRole | 0 | Battery Operating In It Primary Role
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.ModeSupportedType Enumeration

IRD

BatteryModeSupportedType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModeSupportedType
Public Enumeration ModeSupportedType
public enum class ModeSupportedType
type ModeSupportedType
Members
Member name | Value | Description
Supported | 1 | Supported
NotSupported | 0 | Not Supported
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.SpecificationInfoRevisionType Enumeration

IRD

BatterySpecificationInfoRevisionType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SpecificationInfoRevisionType
Public Enumeration SpecificationInfoRevisionType
public enum class SpecificationInfoRevisionType
type SpecificationInfoRevisionType
Members
Member name | Value | Description
Version1011 | 1 | Version 1.0 / 1.1
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.SpecificationInfoVersionType Enumeration

IRD

BatterySpecificationInfoVersionType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SpecificationInfoVersionType
Public Enumeration SpecificationInfoVersionType
public enum class SpecificationInfoVersionType
type SpecificationInfoVersionType
Members
Member name | Value | Description
Version10 | 1 | Version 1.0
Version11 | 2 | Version 1.1
Version11WithPEC | 3 | Version 1.1 With PEC
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.StatusDischargingType Enumeration

IRD

BatteryStatusDischargingType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusDischargingType
Public Enumeration StatusDischargingType
public enum class StatusDischargingType
type StatusDischargingType
Members
Member name | Value | Description
BatteryIsDischarging | 1 | Battery Is Discharging
BatteryIsAcceptingAChargeCurrent | 0 | Battery Is Accepting A Charge Current
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.StatusErrorCodeType Enumeration

IRD

BatteryStatusErrorCodeType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusErrorCodeType
Public Enumeration StatusErrorCodeType
public enum class StatusErrorCodeType
type StatusErrorCodeType
Members
Member name | Value | Description
OK | 0 | OK
Busy | 1 | Busy
ReservedCommand | 2 | Reserved Command
UnsupportedCommand | 3 | Unsupported Command
AccessDenied | 4 | Access Denied
OverflowUnderflow | 5 | Overflow/Underflow
BadSize | 6 | Bad Size
UnknownError | 7 | Unknown Error
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.StatusFullyChargedType Enumeration

IRD

BatteryStatusFullyChargedType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusFullyChargedType
Public Enumeration StatusFullyChargedType
public enum class StatusFullyChargedType
type StatusFullyChargedType
Members
Member name | Value | Description
BatteryIsFullAndFurtherChargeIsNotRequired | 1 | Battery Is Full And Further Charge Is Not Required
BatteryIsNoLongerConsideredInAFullState | 0 | Battery Is No Longer Considered In A Full State
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.StatusFullyDischargedType Enumeration

IRD

BatteryStatusFullyDischargedType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusFullyDischargedType
Public Enumeration StatusFullyDischargedType
public enum class StatusFullyDischargedType
type StatusFullyDischargedType
Members
Member name | Value | Description
BatteryCapacityIsDepleted | 1 | Battery Capacity Is Depleted
RelativeStateOfCharge20 | 0 | "Relative State Of Charge" > 20%
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.StatusInitializedType Enumeration

IRD

BatteryStatusInitializedType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusInitializedType
Public Enumeration StatusInitializedType
public enum class StatusInitializedType
type StatusInitializedType
Members
Member name | Value | Description
FirstCalibratedOrConfiguredAtTimeOfManufacture | 1 | First Calibrated Or Configured At Time Of Manufacture
CalibrationOrConfigurationInformationHasBeenLostAndAccurracyIsSignificantlyImpaired | 0 | Calibration Or Configuration Information Has Been Lost And Accurracy Is Significantly Impaired
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.StatusOverChargedType Enumeration

IRD

BatteryStatusOverChargedType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusOverChargedType
Public Enumeration StatusOverChargedType
public enum class StatusOverChargedType
type StatusOverChargedType
Members
Member name | Value | Description
BatteryIsFullyChargedAndChargingIsComplete | 1 | Battery Is Fully Charged And Charging Is Complete
ChargingIsNoLongerDetected | 0 | Charging Is No Longer Detected
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.StatusOverTempType Enumeration

IRD

BatteryStatusOverTempType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusOverTempType
Public Enumeration StatusOverTempType
public enum class StatusOverTempType
type StatusOverTempType
Members
Member name | Value | Description
TemperatureIsAbovePreSetLimit | 1 | Temperature Is Above Pre-Set Limit
TemperatureDropsIntoAcceptableRange | 0 | Temperature Drops Into Acceptable Range
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.StatusRemainingCapacityType Enumeration

IRD

BatteryStatusRemainingCapacityType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusRemainingCapacityType
Public Enumeration StatusRemainingCapacityType
public enum class StatusRemainingCapacityType
type StatusRemainingCapacityType
Members
Member name | Value | Description
RemainingCapacityRemainingCapacityAlarm | 1 | "Remaining Capacity" < "Remaining Capacity Alarm"
RemainingCapacityRemainingCapacityAlarmOrRemainingCapacityAlarm0 | 0 | "Remaining Capacity" > "Remaining Capacity Alarm" or "Remaining Capacity Alarm" == 0
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.StatusRemainingTimeType Enumeration

IRD

BatteryStatusRemainingTimeType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusRemainingTimeType
Public Enumeration StatusRemainingTimeType
public enum class StatusRemainingTimeType
type StatusRemainingTimeType
Members
Member name | Value | Description
AverageTimeToEmptyRemainingTimeAlarm | 1 | "Average Time To Empty" < "Remaining Time Alarm"
AverageTimeToEmptyRemainingTimeAlarmOrRemainingTimeAlarm0 | 0 | "Average Time To Empty" > "Remaining Time Alarm" Or "Remaining Time Alarm" == 0
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.StatusTerminateChargeType Enumeration

IRD

BatteryStatusTerminateChargeType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusTerminateChargeType
Public Enumeration StatusTerminateChargeType
public enum class StatusTerminateChargeType
type StatusTerminateChargeType
Members
Member name | Value | Description
ChargingShouldSuspendTemporarily | 1 | Charging Should Suspend Temporarily
ChargingIsNoLongerDetected | 0 | Charging Is No Longer Detected
See Also

Reference

telos.Ird.SBSForum Namespace


Battery.StatusTerminateDischargeType Enumeration

IRD

BatteryStatusTerminateDischargeType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusTerminateDischargeType
Public Enumeration StatusTerminateDischargeType
public enum class StatusTerminateDischargeType
type StatusTerminateDischargeType
Members
Member name | Value | Description
BatteryCapacityDepleted | 1 | Battery Capacity Depleted
DischargeIsNoLongerDetected | 0 | Discharge Is No Longer Detected
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell Class

SBS Forum: Smart Battery Data - Fuel Cell
Inheritance Hierarchy
SystemObject
telos.Ird.SBSForumBatteryFuelCell

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class BatteryFuelCell
Public Class BatteryFuelCell
public ref class BatteryFuelCell
type BatteryFuelCell =  class end

The BatteryFuelCell type exposes the following members.

Constructors
 | Name | Description
Public method | BatteryFuelCell | Constructor
Top
Properties
 | Name | Description
Public property | AbsoluteStateOfCharge | Absolute State Of Charge (unit: %)
Public property | AtRate | At Rate (unit: mA)
Public property | AtRateOK | At Rate OK
Public property | AtRateTimeToEmpty | At Rate Time To Empty (unit: min)
Public property | AtRateTimeToFull | At Rate Time To Full (unit: min)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AutoSoftOFF | Auto Soft-OFF (unit: s)
Public property | AverageCurrent | Average Current (unit: mA)
Public property | AverageTimeToEmpty | Average Time To Empty (unit: min)
Public property | AverageTimeToFull | Average Time To Full (unit: min)
Public property | ChargingCurrent | Charging Current (unit: mA)
Public property | ChargingVoltage | Charging Voltage (unit: mV)
Public property | Current | Current (unit: mA)
Public property | CycleCount | Cycle Count
Public property | DesignCapacity | Design Capacity (unit: mAh)
Public property | DesignMaxPower | Design Max Power (unit: 10 mW)
Public property | DesignVoltage | Design Voltage (unit: mV)
Public property | DeviceChemistry | Device Chemistry
Public property | DeviceName | Device Name
Public property | FCModeChangeStatusEnable | FC Mode: Change Status Enable
Public property | FCModeFCTempGranularity | FC Mode: FC Temp Granularity
Public property | FCModeFuelCellSelector | FC Mode: Fuel Cell Selector
Public property | FCModeSetMode | FC Mode: Set Mode
Public property | FCStatusAlarmConditions | FC Status: Alarm Conditions
Public property | FCStatusCartridgeStatus | FC Status: Cartridge Status
Public property | FCStatusInternalBattery | FC Status: Internal Battery
Public property | FCStatusState | FC Status: State
Public property | FCTempReformer | FC Temp: Reformer (unit: °C ; 2°C)
Public property | FCTempStack | FC Temp: Stack (unit: °C ; 2°C)
Public property | FullChargeCapacity | Full Charge Capacity (unit: mAh)
Public property | ManufactureDateDay | Manufacture Date: Day
Public property | ManufactureDateMonth | Manufacture Date: Month
Public property | ManufactureDateYear | Manufacture Date: Year
Public property | ManufacturerAccess | Manufacturer Access
Public property | ManufacturerData | Manufacturer Data
Public property | ManufacturerName | Manufacturer Name
Public property | MaxError | Max Error (unit: %)
Public property | ModeAlarmMode | Mode: Alarm Mode
Public property | ModeCapacityMode | Mode: Capacity Mode
Public property | ModeChargeControllerEnabled | Mode: Charge Controller Enabled
Public property | ModeChargerMode | Mode: Charger Mode
Public property | ModeConditionFlag | Mode: Condition Flag
Public property | ModeFuellCell | Mode: Fuell Cell
Public property | ModeInternalChargeController | Mode: Internal Charge Controller
Public property | ModePrimaryBattery | Mode: Primary Battery
Public property | ModePrimaryBatterySupport | Mode: Primary Battery Support
Public property | RelativeStateOfCharge | Relative State Of Charge (unit: %)
Public property | RemainingCapacity | Remaining Capacity (unit: mAh)
Public property | RemainingCapacityAlarm | Remaining Capacity Alarm (unit: mAh @ C/5 ; Design Max Current)
Public property | RemainingTimeAlarm | Remaining Time Alarm (unit: min)
Public property | RunTimeToEmpty | Run Time To Empty (unit: min)
Public property | SerialNumber | Serial Number
Public property | SpecificationInfoIPScale | Specification Info: IPScale
Public property | SpecificationInfoRevision | Specification Info: Revision
Public property | SpecificationInfoVersion | Specification Info: Version
Public property | SpecificationInfoVScale | Specification Info: VScale
Public property | StartTime | Start Time (unit: s)
Public property | StatusDischarging | Status: Discharging
Public property | StatusErrorCodes | Status: Error Codes
Public property | StatusFullyCharged | Status: Fully Charged
Public property | StatusFullyDischarged | Status: Fully Discharged
Public property | StatusInitialized | Status: Initialized
Public property | StatusOverChargedAlarm | Status: Over Charged Alarm
Public property | StatusOverTempAlarm | Status: Over Temp Alarm
Public property | StatusRemainingCapacityAlarm | Status: Remaining Capacity Alarm
Public property | StatusRemainingTimeAlarm | Status: Remaining Time Alarm
Public property | StatusTerminateChargeAlarm | Status: Terminate Charge Alarm
Public property | StatusTerminateDischargeAlarm | Status: Terminate Discharge Alarm
Public property | Temperature | Temperature (unit: °K)
Public property | TotalRuntime | Total Runtime (unit: hours)
Public property | Voltage | Voltage (unit: mV)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Smart Battery Data (Addendum For Fuel Cell Systems) - Revision 1.02
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell Constructor

Constructor

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCell(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
BatteryFuelCell(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> BatteryFuelCell

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell Properties

The BatteryFuelCell type exposes the following members.

Properties
 | Name | Description
Public property | AbsoluteStateOfCharge | Absolute State Of Charge (unit: %)
Public property | AtRate | At Rate (unit: mA)
Public property | AtRateOK | At Rate OK
Public property | AtRateTimeToEmpty | At Rate Time To Empty (unit: min)
Public property | AtRateTimeToFull | At Rate Time To Full (unit: min)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AutoSoftOFF | Auto Soft-OFF (unit: s)
Public property | AverageCurrent | Average Current (unit: mA)
Public property | AverageTimeToEmpty | Average Time To Empty (unit: min)
Public property | AverageTimeToFull | Average Time To Full (unit: min)
Public property | ChargingCurrent | Charging Current (unit: mA)
Public property | ChargingVoltage | Charging Voltage (unit: mV)
Public property | Current | Current (unit: mA)
Public property | CycleCount | Cycle Count
Public property | DesignCapacity | Design Capacity (unit: mAh)
Public property | DesignMaxPower | Design Max Power (unit: 10 mW)
Public property | DesignVoltage | Design Voltage (unit: mV)
Public property | DeviceChemistry | Device Chemistry
Public property | DeviceName | Device Name
Public property | FCModeChangeStatusEnable | FC Mode: Change Status Enable
Public property | FCModeFCTempGranularity | FC Mode: FC Temp Granularity
Public property | FCModeFuelCellSelector | FC Mode: Fuel Cell Selector
Public property | FCModeSetMode | FC Mode: Set Mode
Public property | FCStatusAlarmConditions | FC Status: Alarm Conditions
Public property | FCStatusCartridgeStatus | FC Status: Cartridge Status
Public property | FCStatusInternalBattery | FC Status: Internal Battery
Public property | FCStatusState | FC Status: State
Public property | FCTempReformer | FC Temp: Reformer (unit: °C ; 2°C)
Public property | FCTempStack | FC Temp: Stack (unit: °C ; 2°C)
Public property | FullChargeCapacity | Full Charge Capacity (unit: mAh)
Public property | ManufactureDateDay | Manufacture Date: Day
Public property | ManufactureDateMonth | Manufacture Date: Month
Public property | ManufactureDateYear | Manufacture Date: Year
Public property | ManufacturerAccess | Manufacturer Access
Public property | ManufacturerData | Manufacturer Data
Public property | ManufacturerName | Manufacturer Name
Public property | MaxError | Max Error (unit: %)
Public property | ModeAlarmMode | Mode: Alarm Mode
Public property | ModeCapacityMode | Mode: Capacity Mode
Public property | ModeChargeControllerEnabled | Mode: Charge Controller Enabled
Public property | ModeChargerMode | Mode: Charger Mode
Public property | ModeConditionFlag | Mode: Condition Flag
Public property | ModeFuellCell | Mode: Fuell Cell
Public property | ModeInternalChargeController | Mode: Internal Charge Controller
Public property | ModePrimaryBattery | Mode: Primary Battery
Public property | ModePrimaryBatterySupport | Mode: Primary Battery Support
Public property | RelativeStateOfCharge | Relative State Of Charge (unit: %)
Public property | RemainingCapacity | Remaining Capacity (unit: mAh)
Public property | RemainingCapacityAlarm | Remaining Capacity Alarm (unit: mAh @ C/5 ; Design Max Current)
Public property | RemainingTimeAlarm | Remaining Time Alarm (unit: min)
Public property | RunTimeToEmpty | Run Time To Empty (unit: min)
Public property | SerialNumber | Serial Number
Public property | SpecificationInfoIPScale | Specification Info: IPScale
Public property | SpecificationInfoRevision | Specification Info: Revision
Public property | SpecificationInfoVersion | Specification Info: Version
Public property | SpecificationInfoVScale | Specification Info: VScale
Public property | StartTime | Start Time (unit: s)
Public property | StatusDischarging | Status: Discharging
Public property | StatusErrorCodes | Status: Error Codes
Public property | StatusFullyCharged | Status: Fully Charged
Public property | StatusFullyDischarged | Status: Fully Discharged
Public property | StatusInitialized | Status: Initialized
Public property | StatusOverChargedAlarm | Status: Over Charged Alarm
Public property | StatusOverTempAlarm | Status: Over Temp Alarm
Public property | StatusRemainingCapacityAlarm | Status: Remaining Capacity Alarm
Public property | StatusRemainingTimeAlarm | Status: Remaining Time Alarm
Public property | StatusTerminateChargeAlarm | Status: Terminate Charge Alarm
Public property | StatusTerminateDischargeAlarm | Status: Terminate Discharge Alarm
Public property | Temperature | Temperature (unit: °K)
Public property | TotalRuntime | Total Runtime (unit: hours)
Public property | Voltage | Voltage (unit: mV)
Top
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.AbsoluteStateOfCharge Property

IRD

BatteryFuelCellAbsoluteStateOfCharge Property

Absolute State Of Charge (unit: %)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AbsoluteStateOfCharge { get; }
Public ReadOnly Property AbsoluteStateOfCharge As Byte
    Get
public:
property unsigned char AbsoluteStateOfCharge {
    unsigned char get ();
}
member AbsoluteStateOfCharge : byte with get

Property Value

Type: Byte
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.AtRate Property

IRD

BatteryFuelCellAtRate Property

At Rate (unit: mA)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short AtRate { get; set; }
Public Property AtRate As Short
    Get
    Set
public:
property short AtRate {
    short get ();
    void set (short value);
}
member AtRate : int16 with get, set

Property Value

Type: Int16
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.AtRateOK Property

IRD

BatteryFuelCellAtRateOK Property

At Rate OK

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellAtRateOkType AtRateOK { get; }
Public ReadOnly Property AtRateOK As BatteryFuelCellAtRateOkType
    Get
public:
property BatteryFuelCellAtRateOkType AtRateOK {
    BatteryFuelCellAtRateOkType get ();
}
member AtRateOK : BatteryFuelCellAtRateOkType with get

Property Value

Type: BatteryFuelCellAtRateOkType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.AtRateTimeToEmpty Property

IRD

BatteryFuelCellAtRateTimeToEmpty Property

At Rate Time To Empty (unit: min)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellAtRateTimeToEmptyType AtRateTimeToEmpty { get; }
Public ReadOnly Property AtRateTimeToEmpty As BatteryFuelCellAtRateTimeToEmptyType
    Get
public:
property BatteryFuelCellAtRateTimeToEmptyType AtRateTimeToEmpty {
    BatteryFuelCellAtRateTimeToEmptyType get ();
}
member AtRateTimeToEmpty : BatteryFuelCellAtRateTimeToEmptyType with get

Property Value

Type: BatteryFuelCellAtRateTimeToEmptyType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.AtRateTimeToFull Property

IRD

BatteryFuelCellAtRateTimeToFull Property

At Rate Time To Full (unit: min)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellAtRateTimeToFullType AtRateTimeToFull { get; }
Public ReadOnly Property AtRateTimeToFull As BatteryFuelCellAtRateTimeToFullType
    Get
public:
property BatteryFuelCellAtRateTimeToFullType AtRateTimeToFull {
    BatteryFuelCellAtRateTimeToFullType get ();
}
member AtRateTimeToFull : BatteryFuelCellAtRateTimeToFullType with get

Property Value

Type: BatteryFuelCellAtRateTimeToFullType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.AutoFlush Property

IRD

BatteryFuelCellAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.AutoSoftOFF Property

IRD

BatteryFuelCellAutoSoftOFF Property

Auto Soft-OFF (unit: s)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort AutoSoftOFF { get; }
Public ReadOnly Property AutoSoftOFF As UShort
    Get
public:
property unsigned short AutoSoftOFF {
    unsigned short get ();
}
member AutoSoftOFF : uint16 with get

Property Value

Type: UInt16
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.AverageCurrent Property

IRD

BatteryFuelCellAverageCurrent Property

Average Current (unit: mA)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short AverageCurrent { get; }
Public ReadOnly Property AverageCurrent As Short
    Get
public:
property short AverageCurrent {
    short get ();
}
member AverageCurrent : int16 with get

Property Value

Type: Int16
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.AverageTimeToEmpty Property

IRD

BatteryFuelCellAverageTimeToEmpty Property

Average Time To Empty (unit: min)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellAtRateTimeToEmptyType AverageTimeToEmpty { get; }
Public ReadOnly Property AverageTimeToEmpty As BatteryFuelCellAtRateTimeToEmptyType
    Get
public:
property BatteryFuelCellAtRateTimeToEmptyType AverageTimeToEmpty {
    BatteryFuelCellAtRateTimeToEmptyType get ();
}
member AverageTimeToEmpty : BatteryFuelCellAtRateTimeToEmptyType with get

Property Value

Type: BatteryFuelCellAtRateTimeToEmptyType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.AverageTimeToFull Property

IRD

BatteryFuelCellAverageTimeToFull Property

Average Time To Full (unit: min)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellAtRateTimeToFullType AverageTimeToFull { get; }
Public ReadOnly Property AverageTimeToFull As BatteryFuelCellAtRateTimeToFullType
    Get
public:
property BatteryFuelCellAtRateTimeToFullType AverageTimeToFull {
    BatteryFuelCellAtRateTimeToFullType get ();
}
member AverageTimeToFull : BatteryFuelCellAtRateTimeToFullType with get

Property Value

Type: BatteryFuelCellAtRateTimeToFullType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.ChargingCurrent Property

IRD

BatteryFuelCellChargingCurrent Property

Charging Current (unit: mA)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellChargingCurrentType ChargingCurrent { get; }
Public ReadOnly Property ChargingCurrent As BatteryFuelCellChargingCurrentType
    Get
public:
property BatteryFuelCellChargingCurrentType ChargingCurrent {
    BatteryFuelCellChargingCurrentType get ();
}
member ChargingCurrent : BatteryFuelCellChargingCurrentType with get

Property Value

Type: BatteryFuelCellChargingCurrentType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.ChargingVoltage Property

IRD

BatteryFuelCellChargingVoltage Property

Charging Voltage (unit: mV)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellChargingVoltageType ChargingVoltage { get; }
Public ReadOnly Property ChargingVoltage As BatteryFuelCellChargingVoltageType
    Get
public:
property BatteryFuelCellChargingVoltageType ChargingVoltage {
    BatteryFuelCellChargingVoltageType get ();
}
member ChargingVoltage : BatteryFuelCellChargingVoltageType with get

Property Value

Type: BatteryFuelCellChargingVoltageType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.Current Property

IRD

BatteryFuelCellCurrent Property

Current (unit: mA)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short Current { get; }
Public ReadOnly Property Current As Short
    Get
public:
property short Current {
    short get ();
}
member Current : int16 with get

Property Value

Type: Int16
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.CycleCount Property

IRD

BatteryFuelCellCycleCount Property

Cycle Count

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellCycleCountType CycleCount { get; }
Public ReadOnly Property CycleCount As BatteryFuelCellCycleCountType
    Get
public:
property BatteryFuelCellCycleCountType CycleCount {
    BatteryFuelCellCycleCountType get ();
}
member CycleCount : BatteryFuelCellCycleCountType with get

Property Value

Type: BatteryFuelCellCycleCountType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.DesignCapacity Property

IRD

BatteryFuelCellDesignCapacity Property

Design Capacity (unit: mAh)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DesignCapacity { get; }
Public ReadOnly Property DesignCapacity As UShort
    Get
public:
property unsigned short DesignCapacity {
    unsigned short get ();
}
member DesignCapacity : uint16 with get

Property Value

Type: UInt16
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.DesignMaxPower Property

IRD

BatteryFuelCellDesignMaxPower Property

Design Max Power (unit: 10 mW)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DesignMaxPower { get; }
Public ReadOnly Property DesignMaxPower As UShort
    Get
public:
property unsigned short DesignMaxPower {
    unsigned short get ();
}
member DesignMaxPower : uint16 with get

Property Value

Type: UInt16
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.DesignVoltage Property

IRD

BatteryFuelCellDesignVoltage Property

Design Voltage (unit: mV)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort DesignVoltage { get; }
Public ReadOnly Property DesignVoltage As UShort
    Get
public:
property unsigned short DesignVoltage {
    unsigned short get ();
}
member DesignVoltage : uint16 with get

Property Value

Type: UInt16
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.DeviceChemistry Property

IRD

BatteryFuelCellDeviceChemistry Property

Device Chemistry

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public string DeviceChemistry { get; }
Public ReadOnly Property DeviceChemistry As String
    Get
public:
property String^ DeviceChemistry {
    String^ get ();
}
member DeviceChemistry : string with get

Property Value

Type: String
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.DeviceName Property

IRD

BatteryFuelCellDeviceName Property

Device Name

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public string DeviceName { get; }
Public ReadOnly Property DeviceName As String
    Get
public:
property String^ DeviceName {
    String^ get ();
}
member DeviceName : string with get

Property Value

Type: String
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.FCModeChangeStatusEnable Property

IRD

BatteryFuelCellFCModeChangeStatusEnable Property

FC Mode: Change Status Enable

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellFcModeChangeStatusEnableType FCModeChangeStatusEnable { get; set; }
Public Property FCModeChangeStatusEnable As BatteryFuelCellFcModeChangeStatusEnableType
    Get
    Set
public:
property BatteryFuelCellFcModeChangeStatusEnableType FCModeChangeStatusEnable {
    BatteryFuelCellFcModeChangeStatusEnableType get ();
    void set (BatteryFuelCellFcModeChangeStatusEnableType value);
}
member FCModeChangeStatusEnable : BatteryFuelCellFcModeChangeStatusEnableType with get, set

Property Value

Type: BatteryFuelCellFcModeChangeStatusEnableType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.FCModeFCTempGranularity Property

IRD

BatteryFuelCellFCModeFCTempGranularity Property

FC Mode: FC Temp Granularity

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellFcModeFcTempGranularityType FCModeFCTempGranularity { get; set; }
Public Property FCModeFCTempGranularity As BatteryFuelCellFcModeFcTempGranularityType
    Get
    Set
public:
property BatteryFuelCellFcModeFcTempGranularityType FCModeFCTempGranularity {
    BatteryFuelCellFcModeFcTempGranularityType get ();
    void set (BatteryFuelCellFcModeFcTempGranularityType value);
}
member FCModeFCTempGranularity : BatteryFuelCellFcModeFcTempGranularityType with get, set

Property Value

Type: BatteryFuelCellFcModeFcTempGranularityType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.FCModeFuelCellSelector Property

IRD

BatteryFuelCellFCModeFuelCellSelector Property

FC Mode: Fuel Cell Selector

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellFcModeFuelCellSelectorType FCModeFuelCellSelector { get; set; }
Public Property FCModeFuelCellSelector As BatteryFuelCellFcModeFuelCellSelectorType
    Get
    Set
public:
property BatteryFuelCellFcModeFuelCellSelectorType FCModeFuelCellSelector {
    BatteryFuelCellFcModeFuelCellSelectorType get ();
    void set (BatteryFuelCellFcModeFuelCellSelectorType value);
}
member FCModeFuelCellSelector : BatteryFuelCellFcModeFuelCellSelectorType with get, set

Property Value

Type: BatteryFuelCellFcModeFuelCellSelectorType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.FCModeSetMode Property

IRD

BatteryFuelCellFCModeSetMode Property

FC Mode: Set Mode

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellFcStatusStateType FCModeSetMode { get; set; }
Public Property FCModeSetMode As BatteryFuelCellFcStatusStateType
    Get
    Set
public:
property BatteryFuelCellFcStatusStateType FCModeSetMode {
    BatteryFuelCellFcStatusStateType get ();
    void set (BatteryFuelCellFcStatusStateType value);
}
member FCModeSetMode : BatteryFuelCellFcStatusStateType with get, set

Property Value

Type: BatteryFuelCellFcStatusStateType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.FCStatusAlarmConditions Property

IRD

BatteryFuelCellFCStatusAlarmConditions Property

FC Status: Alarm Conditions

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellFcStatusAlarmConditionsType FCStatusAlarmConditions { get; }
Public ReadOnly Property FCStatusAlarmConditions As BatteryFuelCellFcStatusAlarmConditionsType
    Get
public:
property BatteryFuelCellFcStatusAlarmConditionsType FCStatusAlarmConditions {
    BatteryFuelCellFcStatusAlarmConditionsType get ();
}
member FCStatusAlarmConditions : BatteryFuelCellFcStatusAlarmConditionsType with get

Property Value

Type: BatteryFuelCellFcStatusAlarmConditionsType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.FCStatusCartridgeStatus Property

IRD

BatteryFuelCellFCStatusCartridgeStatus Property

FC Status: Cartridge Status

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellFcStatusCartridgeStatusType FCStatusCartridgeStatus { get; }
Public ReadOnly Property FCStatusCartridgeStatus As BatteryFuelCellFcStatusCartridgeStatusType
    Get
public:
property BatteryFuelCellFcStatusCartridgeStatusType FCStatusCartridgeStatus {
    BatteryFuelCellFcStatusCartridgeStatusType get ();
}
member FCStatusCartridgeStatus : BatteryFuelCellFcStatusCartridgeStatusType with get

Property Value

Type: BatteryFuelCellFcStatusCartridgeStatusType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.FCStatusInternalBattery Property

IRD

BatteryFuelCellFCStatusInternalBattery Property

FC Status: Internal Battery

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellFcStatusInternalBatteryType FCStatusInternalBattery { get; }
Public ReadOnly Property FCStatusInternalBattery As BatteryFuelCellFcStatusInternalBatteryType
    Get
public:
property BatteryFuelCellFcStatusInternalBatteryType FCStatusInternalBattery {
    BatteryFuelCellFcStatusInternalBatteryType get ();
}
member FCStatusInternalBattery : BatteryFuelCellFcStatusInternalBatteryType with get

Property Value

Type: BatteryFuelCellFcStatusInternalBatteryType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.FCStatusState Property

IRD

BatteryFuelCellFCStatusState Property

FC Status: State

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellFcStatusStateType FCStatusState { get; }
Public ReadOnly Property FCStatusState As BatteryFuelCellFcStatusStateType
    Get
public:
property BatteryFuelCellFcStatusStateType FCStatusState {
    BatteryFuelCellFcStatusStateType get ();
}
member FCStatusState : BatteryFuelCellFcStatusStateType with get

Property Value

Type: BatteryFuelCellFcStatusStateType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.FCTempReformer Property

IRD

BatteryFuelCellFCTempReformer Property

FC Temp: Reformer (unit: °C ; 2°C)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FCTempReformer { get; }
Public ReadOnly Property FCTempReformer As Byte
    Get
public:
property unsigned char FCTempReformer {
    unsigned char get ();
}
member FCTempReformer : byte with get

Property Value

Type: Byte
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.FCTempStack Property

IRD

BatteryFuelCellFCTempStack Property

FC Temp: Stack (unit: °C ; 2°C)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FCTempStack { get; }
Public ReadOnly Property FCTempStack As Byte
    Get
public:
property unsigned char FCTempStack {
    unsigned char get ();
}
member FCTempStack : byte with get

Property Value

Type: Byte
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.FullChargeCapacity Property

IRD

BatteryFuelCellFullChargeCapacity Property

Full Charge Capacity (unit: mAh)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort FullChargeCapacity { get; }
Public ReadOnly Property FullChargeCapacity As UShort
    Get
public:
property unsigned short FullChargeCapacity {
    unsigned short get ();
}
member FullChargeCapacity : uint16 with get

Property Value

Type: UInt16
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.ManufactureDateDay Property

IRD

BatteryFuelCellManufactureDateDay Property

Manufacture Date: Day

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufactureDateDay { get; }
Public ReadOnly Property ManufactureDateDay As Byte
    Get
public:
property unsigned char ManufactureDateDay {
    unsigned char get ();
}
member ManufactureDateDay : byte with get

Property Value

Type: Byte
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.ManufactureDateMonth Property

IRD

BatteryFuelCellManufactureDateMonth Property

Manufacture Date: Month

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ManufactureDateMonth { get; }
Public ReadOnly Property ManufactureDateMonth As Byte
    Get
public:
property unsigned char ManufactureDateMonth {
    unsigned char get ();
}
member ManufactureDateMonth : byte with get

Property Value

Type: Byte
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.ManufactureDateYear Property

IRD

BatteryFuelCellManufactureDateYear Property

Manufacture Date: Year

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ManufactureDateYear { get; }
Public ReadOnly Property ManufactureDateYear As UShort
    Get
public:
property unsigned short ManufactureDateYear {
    unsigned short get ();
}
member ManufactureDateYear : uint16 with get

Property Value

Type: UInt16
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.ManufacturerAccess Property

IRD

BatteryFuelCellManufacturerAccess Property

Manufacturer Access

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ManufacturerAccess { get; set; }
Public Property ManufacturerAccess As UShort
    Get
    Set
public:
property unsigned short ManufacturerAccess {
    unsigned short get ();
    void set (unsigned short value);
}
member ManufacturerAccess : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.ManufacturerData Property

IRD

BatteryFuelCellManufacturerData Property

Manufacturer Data

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] ManufacturerData { get; }
Public ReadOnly Property ManufacturerData As Byte()
    Get
public:
property array<unsigned char>^ ManufacturerData {
    array<unsigned char>^ get ();
}
member ManufacturerData : byte[] with get

Property Value

Type: Byte
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.ManufacturerName Property

IRD

BatteryFuelCellManufacturerName Property

Manufacturer Name

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public string ManufacturerName { get; }
Public ReadOnly Property ManufacturerName As String
    Get
public:
property String^ ManufacturerName {
    String^ get ();
}
member ManufacturerName : string with get

Property Value

Type: String
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.MaxError Property

IRD

BatteryFuelCellMaxError Property

Max Error (unit: %)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MaxError { get; }
Public ReadOnly Property MaxError As Byte
    Get
public:
property unsigned char MaxError {
    unsigned char get ();
}
member MaxError : byte with get

Property Value

Type: Byte
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.ModeAlarmMode Property

IRD

BatteryFuelCellModeAlarmMode Property

Mode: Alarm Mode

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellModeAlarmModeType ModeAlarmMode { get; set; }
Public Property ModeAlarmMode As BatteryFuelCellModeAlarmModeType
    Get
    Set
public:
property BatteryFuelCellModeAlarmModeType ModeAlarmMode {
    BatteryFuelCellModeAlarmModeType get ();
    void set (BatteryFuelCellModeAlarmModeType value);
}
member ModeAlarmMode : BatteryFuelCellModeAlarmModeType with get, set

Property Value

Type: BatteryFuelCellModeAlarmModeType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.ModeCapacityMode Property

IRD

BatteryFuelCellModeCapacityMode Property

Mode: Capacity Mode

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellModeCapacityModeType ModeCapacityMode { get; set; }
Public Property ModeCapacityMode As BatteryFuelCellModeCapacityModeType
    Get
    Set
public:
property BatteryFuelCellModeCapacityModeType ModeCapacityMode {
    BatteryFuelCellModeCapacityModeType get ();
    void set (BatteryFuelCellModeCapacityModeType value);
}
member ModeCapacityMode : BatteryFuelCellModeCapacityModeType with get, set

Property Value

Type: BatteryFuelCellModeCapacityModeType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.ModeChargeControllerEnabled Property

IRD

BatteryFuelCellModeChargeControllerEnabled Property

Mode: Charge Controller Enabled

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellModeChargeControllerEnabledType ModeChargeControllerEnabled { get; set; }
Public Property ModeChargeControllerEnabled As BatteryFuelCellModeChargeControllerEnabledType
    Get
    Set
public:
property BatteryFuelCellModeChargeControllerEnabledType ModeChargeControllerEnabled {
    BatteryFuelCellModeChargeControllerEnabledType get ();
    void set (BatteryFuelCellModeChargeControllerEnabledType value);
}
member ModeChargeControllerEnabled : BatteryFuelCellModeChargeControllerEnabledType with get, set

Property Value

Type: BatteryFuelCellModeChargeControllerEnabledType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.ModeChargerMode Property

IRD

BatteryFuelCellModeChargerMode Property

Mode: Charger Mode

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellModeChargerModeType ModeChargerMode { get; set; }
Public Property ModeChargerMode As BatteryFuelCellModeChargerModeType
    Get
    Set
public:
property BatteryFuelCellModeChargerModeType ModeChargerMode {
    BatteryFuelCellModeChargerModeType get ();
    void set (BatteryFuelCellModeChargerModeType value);
}
member ModeChargerMode : BatteryFuelCellModeChargerModeType with get, set

Property Value

Type: BatteryFuelCellModeChargerModeType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.ModeConditionFlag Property

IRD

BatteryFuelCellModeConditionFlag Property

Mode: Condition Flag

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellModeConditionFlagType ModeConditionFlag { get; }
Public ReadOnly Property ModeConditionFlag As BatteryFuelCellModeConditionFlagType
    Get
public:
property BatteryFuelCellModeConditionFlagType ModeConditionFlag {
    BatteryFuelCellModeConditionFlagType get ();
}
member ModeConditionFlag : BatteryFuelCellModeConditionFlagType with get

Property Value

Type: BatteryFuelCellModeConditionFlagType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.ModeFuellCell Property

IRD

BatteryFuelCellModeFuellCell Property

Mode: Fuell Cell

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellModeFuelCellType ModeFuellCell { get; }
Public ReadOnly Property ModeFuellCell As BatteryFuelCellModeFuelCellType
    Get
public:
property BatteryFuelCellModeFuelCellType ModeFuellCell {
    BatteryFuelCellModeFuelCellType get ();
}
member ModeFuellCell : BatteryFuelCellModeFuelCellType with get

Property Value

Type: BatteryFuelCellModeFuelCellType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.ModeInternalChargeController Property

IRD

BatteryFuelCellModeInternalChargeController Property

Mode: Internal Charge Controller

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellModeSupportedType ModeInternalChargeController { get; }
Public ReadOnly Property ModeInternalChargeController As BatteryFuelCellModeSupportedType
    Get
public:
property BatteryFuelCellModeSupportedType ModeInternalChargeController {
    BatteryFuelCellModeSupportedType get ();
}
member ModeInternalChargeController : BatteryFuelCellModeSupportedType with get

Property Value

Type: BatteryFuelCellModeSupportedType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.ModePrimaryBattery Property

IRD

BatteryFuelCellModePrimaryBattery Property

Mode: Primary Battery

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellModePrimaryBatteryType ModePrimaryBattery { get; set; }
Public Property ModePrimaryBattery As BatteryFuelCellModePrimaryBatteryType
    Get
    Set
public:
property BatteryFuelCellModePrimaryBatteryType ModePrimaryBattery {
    BatteryFuelCellModePrimaryBatteryType get ();
    void set (BatteryFuelCellModePrimaryBatteryType value);
}
member ModePrimaryBattery : BatteryFuelCellModePrimaryBatteryType with get, set

Property Value

Type: BatteryFuelCellModePrimaryBatteryType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.ModePrimaryBatterySupport Property

IRD

BatteryFuelCellModePrimaryBatterySupport Property

Mode: Primary Battery Support

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellModePrimaryBatterySupportType ModePrimaryBatterySupport { get; }
Public ReadOnly Property ModePrimaryBatterySupport As BatteryFuelCellModePrimaryBatterySupportType
    Get
public:
property BatteryFuelCellModePrimaryBatterySupportType ModePrimaryBatterySupport {
    BatteryFuelCellModePrimaryBatterySupportType get ();
}
member ModePrimaryBatterySupport : BatteryFuelCellModePrimaryBatterySupportType with get

Property Value

Type: BatteryFuelCellModePrimaryBatterySupportType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.RelativeStateOfCharge Property

IRD

BatteryFuelCellRelativeStateOfCharge Property

Relative State Of Charge (unit: %)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RelativeStateOfCharge { get; }
Public ReadOnly Property RelativeStateOfCharge As Byte
    Get
public:
property unsigned char RelativeStateOfCharge {
    unsigned char get ();
}
member RelativeStateOfCharge : byte with get

Property Value

Type: Byte
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.RemainingCapacity Property

IRD

BatteryFuelCellRemainingCapacity Property

Remaining Capacity (unit: mAh)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort RemainingCapacity { get; }
Public ReadOnly Property RemainingCapacity As UShort
    Get
public:
property unsigned short RemainingCapacity {
    unsigned short get ();
}
member RemainingCapacity : uint16 with get

Property Value

Type: UInt16
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.RemainingCapacityAlarm Property

IRD

BatteryFuelCellRemainingCapacityAlarm Property

Remaining Capacity Alarm (unit: mAh @ C/5 ; Design Max Current)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellRemainingCapacityAlarmType RemainingCapacityAlarm { get; set; }
Public Property RemainingCapacityAlarm As BatteryFuelCellRemainingCapacityAlarmType
    Get
    Set
public:
property BatteryFuelCellRemainingCapacityAlarmType RemainingCapacityAlarm {
    BatteryFuelCellRemainingCapacityAlarmType get ();
    void set (BatteryFuelCellRemainingCapacityAlarmType value);
}
member RemainingCapacityAlarm : BatteryFuelCellRemainingCapacityAlarmType with get, set

Property Value

Type: BatteryFuelCellRemainingCapacityAlarmType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.RemainingTimeAlarm Property

IRD

BatteryFuelCellRemainingTimeAlarm Property

Remaining Time Alarm (unit: min)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellRemainingTimeAlarmType RemainingTimeAlarm { get; set; }
Public Property RemainingTimeAlarm As BatteryFuelCellRemainingTimeAlarmType
    Get
    Set
public:
property BatteryFuelCellRemainingTimeAlarmType RemainingTimeAlarm {
    BatteryFuelCellRemainingTimeAlarmType get ();
    void set (BatteryFuelCellRemainingTimeAlarmType value);
}
member RemainingTimeAlarm : BatteryFuelCellRemainingTimeAlarmType with get, set

Property Value

Type: BatteryFuelCellRemainingTimeAlarmType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.RunTimeToEmpty Property

IRD

BatteryFuelCellRunTimeToEmpty Property

Run Time To Empty (unit: min)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellAtRateTimeToEmptyType RunTimeToEmpty { get; }
Public ReadOnly Property RunTimeToEmpty As BatteryFuelCellAtRateTimeToEmptyType
    Get
public:
property BatteryFuelCellAtRateTimeToEmptyType RunTimeToEmpty {
    BatteryFuelCellAtRateTimeToEmptyType get ();
}
member RunTimeToEmpty : BatteryFuelCellAtRateTimeToEmptyType with get

Property Value

Type: BatteryFuelCellAtRateTimeToEmptyType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.SerialNumber Property

IRD

BatteryFuelCellSerialNumber Property

Serial Number

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort SerialNumber { get; }
Public ReadOnly Property SerialNumber As UShort
    Get
public:
property unsigned short SerialNumber {
    unsigned short get ();
}
member SerialNumber : uint16 with get

Property Value

Type: UInt16
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.SpecificationInfoIPScale Property

IRD

BatteryFuelCellSpecificationInfoIPScale Property

Specification Info: IPScale

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SpecificationInfoIPScale { get; }
Public ReadOnly Property SpecificationInfoIPScale As Byte
    Get
public:
property unsigned char SpecificationInfoIPScale {
    unsigned char get ();
}
member SpecificationInfoIPScale : byte with get

Property Value

Type: Byte
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.SpecificationInfoRevision Property

IRD

BatteryFuelCellSpecificationInfoRevision Property

Specification Info: Revision

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellSpecificationInfoRevisionType SpecificationInfoRevision { get; }
Public ReadOnly Property SpecificationInfoRevision As BatteryFuelCellSpecificationInfoRevisionType
    Get
public:
property BatteryFuelCellSpecificationInfoRevisionType SpecificationInfoRevision {
    BatteryFuelCellSpecificationInfoRevisionType get ();
}
member SpecificationInfoRevision : BatteryFuelCellSpecificationInfoRevisionType with get

Property Value

Type: BatteryFuelCellSpecificationInfoRevisionType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.SpecificationInfoVersion Property

IRD

BatteryFuelCellSpecificationInfoVersion Property

Specification Info: Version

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellSpecificationInfoVersionType SpecificationInfoVersion { get; }
Public ReadOnly Property SpecificationInfoVersion As BatteryFuelCellSpecificationInfoVersionType
    Get
public:
property BatteryFuelCellSpecificationInfoVersionType SpecificationInfoVersion {
    BatteryFuelCellSpecificationInfoVersionType get ();
}
member SpecificationInfoVersion : BatteryFuelCellSpecificationInfoVersionType with get

Property Value

Type: BatteryFuelCellSpecificationInfoVersionType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.SpecificationInfoVScale Property

IRD

BatteryFuelCellSpecificationInfoVScale Property

Specification Info: VScale

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SpecificationInfoVScale { get; }
Public ReadOnly Property SpecificationInfoVScale As Byte
    Get
public:
property unsigned char SpecificationInfoVScale {
    unsigned char get ();
}
member SpecificationInfoVScale : byte with get

Property Value

Type: Byte
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.StartTime Property

IRD

BatteryFuelCellStartTime Property

Start Time (unit: s)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellStartTimeType StartTime { get; }
Public ReadOnly Property StartTime As BatteryFuelCellStartTimeType
    Get
public:
property BatteryFuelCellStartTimeType StartTime {
    BatteryFuelCellStartTimeType get ();
}
member StartTime : BatteryFuelCellStartTimeType with get

Property Value

Type: BatteryFuelCellStartTimeType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusDischarging Property

IRD

BatteryFuelCellStatusDischarging Property

Status: Discharging

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellStatusDischargingType StatusDischarging { get; }
Public ReadOnly Property StatusDischarging As BatteryFuelCellStatusDischargingType
    Get
public:
property BatteryFuelCellStatusDischargingType StatusDischarging {
    BatteryFuelCellStatusDischargingType get ();
}
member StatusDischarging : BatteryFuelCellStatusDischargingType with get

Property Value

Type: BatteryFuelCellStatusDischargingType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusErrorCodes Property

IRD

BatteryFuelCellStatusErrorCodes Property

Status: Error Codes

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellStatusErrorCodeType StatusErrorCodes { get; }
Public ReadOnly Property StatusErrorCodes As BatteryFuelCellStatusErrorCodeType
    Get
public:
property BatteryFuelCellStatusErrorCodeType StatusErrorCodes {
    BatteryFuelCellStatusErrorCodeType get ();
}
member StatusErrorCodes : BatteryFuelCellStatusErrorCodeType with get

Property Value

Type: BatteryFuelCellStatusErrorCodeType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusFullyCharged Property

IRD

BatteryFuelCellStatusFullyCharged Property

Status: Fully Charged

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellStatusFullyChargedType StatusFullyCharged { get; }
Public ReadOnly Property StatusFullyCharged As BatteryFuelCellStatusFullyChargedType
    Get
public:
property BatteryFuelCellStatusFullyChargedType StatusFullyCharged {
    BatteryFuelCellStatusFullyChargedType get ();
}
member StatusFullyCharged : BatteryFuelCellStatusFullyChargedType with get

Property Value

Type: BatteryFuelCellStatusFullyChargedType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusFullyDischarged Property

IRD

BatteryFuelCellStatusFullyDischarged Property

Status: Fully Discharged

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellStatusFullyDischargedType StatusFullyDischarged { get; }
Public ReadOnly Property StatusFullyDischarged As BatteryFuelCellStatusFullyDischargedType
    Get
public:
property BatteryFuelCellStatusFullyDischargedType StatusFullyDischarged {
    BatteryFuelCellStatusFullyDischargedType get ();
}
member StatusFullyDischarged : BatteryFuelCellStatusFullyDischargedType with get

Property Value

Type: BatteryFuelCellStatusFullyDischargedType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusInitialized Property

IRD

BatteryFuelCellStatusInitialized Property

Status: Initialized

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellStatusInitializedType StatusInitialized { get; }
Public ReadOnly Property StatusInitialized As BatteryFuelCellStatusInitializedType
    Get
public:
property BatteryFuelCellStatusInitializedType StatusInitialized {
    BatteryFuelCellStatusInitializedType get ();
}
member StatusInitialized : BatteryFuelCellStatusInitializedType with get

Property Value

Type: BatteryFuelCellStatusInitializedType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusOverChargedAlarm Property

IRD

BatteryFuelCellStatusOverChargedAlarm Property

Status: Over Charged Alarm

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellStatusOverChargedType StatusOverChargedAlarm { get; }
Public ReadOnly Property StatusOverChargedAlarm As BatteryFuelCellStatusOverChargedType
    Get
public:
property BatteryFuelCellStatusOverChargedType StatusOverChargedAlarm {
    BatteryFuelCellStatusOverChargedType get ();
}
member StatusOverChargedAlarm : BatteryFuelCellStatusOverChargedType with get

Property Value

Type: BatteryFuelCellStatusOverChargedType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusOverTempAlarm Property

IRD

BatteryFuelCellStatusOverTempAlarm Property

Status: Over Temp Alarm

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellStatusOverTempType StatusOverTempAlarm { get; }
Public ReadOnly Property StatusOverTempAlarm As BatteryFuelCellStatusOverTempType
    Get
public:
property BatteryFuelCellStatusOverTempType StatusOverTempAlarm {
    BatteryFuelCellStatusOverTempType get ();
}
member StatusOverTempAlarm : BatteryFuelCellStatusOverTempType with get

Property Value

Type: BatteryFuelCellStatusOverTempType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusRemainingCapacityAlarm Property

IRD

BatteryFuelCellStatusRemainingCapacityAlarm Property

Status: Remaining Capacity Alarm

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellStatusRemainingCapacityType StatusRemainingCapacityAlarm { get; }
Public ReadOnly Property StatusRemainingCapacityAlarm As BatteryFuelCellStatusRemainingCapacityType
    Get
public:
property BatteryFuelCellStatusRemainingCapacityType StatusRemainingCapacityAlarm {
    BatteryFuelCellStatusRemainingCapacityType get ();
}
member StatusRemainingCapacityAlarm : BatteryFuelCellStatusRemainingCapacityType with get

Property Value

Type: BatteryFuelCellStatusRemainingCapacityType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusRemainingTimeAlarm Property

IRD

BatteryFuelCellStatusRemainingTimeAlarm Property

Status: Remaining Time Alarm

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellStatusRemainingTimeType StatusRemainingTimeAlarm { get; }
Public ReadOnly Property StatusRemainingTimeAlarm As BatteryFuelCellStatusRemainingTimeType
    Get
public:
property BatteryFuelCellStatusRemainingTimeType StatusRemainingTimeAlarm {
    BatteryFuelCellStatusRemainingTimeType get ();
}
member StatusRemainingTimeAlarm : BatteryFuelCellStatusRemainingTimeType with get

Property Value

Type: BatteryFuelCellStatusRemainingTimeType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusTerminateChargeAlarm Property

IRD

BatteryFuelCellStatusTerminateChargeAlarm Property

Status: Terminate Charge Alarm

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellStatusTerminateChargeType StatusTerminateChargeAlarm { get; }
Public ReadOnly Property StatusTerminateChargeAlarm As BatteryFuelCellStatusTerminateChargeType
    Get
public:
property BatteryFuelCellStatusTerminateChargeType StatusTerminateChargeAlarm {
    BatteryFuelCellStatusTerminateChargeType get ();
}
member StatusTerminateChargeAlarm : BatteryFuelCellStatusTerminateChargeType with get

Property Value

Type: BatteryFuelCellStatusTerminateChargeType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusTerminateDischargeAlarm Property

IRD

BatteryFuelCellStatusTerminateDischargeAlarm Property

Status: Terminate Discharge Alarm

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellStatusTerminateDischargeType StatusTerminateDischargeAlarm { get; }
Public ReadOnly Property StatusTerminateDischargeAlarm As BatteryFuelCellStatusTerminateDischargeType
    Get
public:
property BatteryFuelCellStatusTerminateDischargeType StatusTerminateDischargeAlarm {
    BatteryFuelCellStatusTerminateDischargeType get ();
}
member StatusTerminateDischargeAlarm : BatteryFuelCellStatusTerminateDischargeType with get

Property Value

Type: BatteryFuelCellStatusTerminateDischargeType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.Temperature Property

IRD

BatteryFuelCellTemperature Property

Temperature (unit: °K)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Temperature { get; }
Public ReadOnly Property Temperature As Double
    Get
public:
property double Temperature {
    double get ();
}
member Temperature : float with get

Property Value

Type: Double
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.TotalRuntime Property

IRD

BatteryFuelCellTotalRuntime Property

Total Runtime (unit: hours)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public BatteryFuelCellTotalRuntimeType TotalRuntime { get; }
Public ReadOnly Property TotalRuntime As BatteryFuelCellTotalRuntimeType
    Get
public:
property BatteryFuelCellTotalRuntimeType TotalRuntime {
    BatteryFuelCellTotalRuntimeType get ();
}
member TotalRuntime : BatteryFuelCellTotalRuntimeType with get

Property Value

Type: BatteryFuelCellTotalRuntimeType
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.Voltage Property

IRD

BatteryFuelCellVoltage Property

Voltage (unit: mV)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort Voltage { get; }
Public ReadOnly Property Voltage As UShort
    Get
public:
property unsigned short Voltage {
    unsigned short get ();
}
member Voltage : uint16 with get

Property Value

Type: UInt16
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell Methods

The BatteryFuelCell type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.Flush Method

IRD

BatteryFuelCellFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

BatteryFuelCell Class
telos.Ird.SBSForum Namespace


BatteryFuelCell.AtRateOkType Enumeration

IRD

BatteryFuelCellAtRateOkType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AtRateOkType
Public Enumeration AtRateOkType
public enum class AtRateOkType
type AtRateOkType
Members
Member name | Value | Description
False | 0 | False
True | 1 | True
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.AtRateTimeToEmptyType Enumeration

IRD

BatteryFuelCellAtRateTimeToEmptyType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AtRateTimeToEmptyType
Public Enumeration AtRateTimeToEmptyType
public enum class AtRateTimeToEmptyType
type AtRateTimeToEmptyType
Members
Member name | Value | Description
NotDischarged | 65535 | Not Discharged
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.AtRateTimeToFullType Enumeration

IRD

BatteryFuelCellAtRateTimeToFullType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AtRateTimeToFullType
Public Enumeration AtRateTimeToFullType
public enum class AtRateTimeToFullType
type AtRateTimeToFullType
Members
Member name | Value | Description
NotCharged | 65535 | Not Charged
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.ChargingCurrentType Enumeration

IRD

BatteryFuelCellChargingCurrentType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ChargingCurrentType
Public Enumeration ChargingCurrentType
public enum class ChargingCurrentType
type ChargingCurrentType
Members
Member name | Value | Description
ChargerShouldBeVoltageSource | 65535 | Charger Should Be Voltage Source
NoInternalRechargeableBattery | 0 | No Internal Rechargeable Battery
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.ChargingVoltageType Enumeration

IRD

BatteryFuelCellChargingVoltageType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ChargingVoltageType
Public Enumeration ChargingVoltageType
public enum class ChargingVoltageType
type ChargingVoltageType
Members
Member name | Value | Description
ChargerShouldBeCurrentSource | 65535 | Charger Should Be Current Source
NoInternalRechargeableBattery | 0 | No Internal Rechargeable Battery
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.CycleCountType Enumeration

IRD

BatteryFuelCellCycleCountType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CycleCountType
Public Enumeration CycleCountType
public enum class CycleCountType
type CycleCountType
Members
Member name | Value | Description
Value_65535 | 65535 | >= 65535
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.FcModeChangeStatusEnableType Enumeration

IRD

BatteryFuelCellFcModeChangeStatusEnableType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FcModeChangeStatusEnableType
Public Enumeration FcModeChangeStatusEnableType
public enum class FcModeChangeStatusEnableType
type FcModeChangeStatusEnableType
Members
Member name | Value | Description
FCModeChangeDisabled | 0 | FC Mode Change: Disabled
FCModeChangeEnabled | 1 | FC Mode Change: Enabled
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.FcModeFcTempGranularityType Enumeration

IRD

BatteryFuelCellFcModeFcTempGranularityType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FcModeFcTempGranularityType
Public Enumeration FcModeFcTempGranularityType
public enum class FcModeFcTempGranularityType
type FcModeFcTempGranularityType
Members
Member name | Value | Description
Value_1C | 0 | 1 °C
Value_2C | 1 | 2 °C
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.FcModeFuelCellSelectorType Enumeration

IRD

BatteryFuelCellFcModeFuelCellSelectorType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FcModeFuelCellSelectorType
Public Enumeration FcModeFuelCellSelectorType
public enum class FcModeFuelCellSelectorType
type FcModeFuelCellSelectorType
Members
Member name | Value | Description
InternalBattery | 0 | Internal Battery
FuelCell | 1 | Fuel Cell
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.FcStatusAlarmConditionsType Enumeration

IRD

BatteryFuelCellFcStatusAlarmConditionsType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FcStatusAlarmConditionsType
Public Enumeration FcStatusAlarmConditionsType
public enum class FcStatusAlarmConditionsType
type FcStatusAlarmConditionsType
Members
Member name | Value | Description
Initialized | 15 | Initialized
Overload | 8 | Overload
CellDamageMEA | 7 | Cell Damage (MEA)
OverTempAlarm | 6 | Over Temp Alarm
RemainingFuelCapacityAlarm | 5 | Remaining Fuel Capacity Alarm
RemainingFuelTimeAlarm | 4 | Remaining Fuel Time Alarm
InsufficientAirFlow | 3 | Insufficient Air Flow
LiquidLeakage | 2 | Liquid Leakage
BOPDamage | 1 | BOP Damage
NoAlarms | 0 | No Alarms
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.FcStatusCartridgeStatusType Enumeration

IRD

BatteryFuelCellFcStatusCartridgeStatusType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FcStatusCartridgeStatusType
Public Enumeration FcStatusCartridgeStatusType
public enum class FcStatusCartridgeStatusType
type FcStatusCartridgeStatusType
Members
Member name | Value | Description
FuelCartridgeAbsence | 0 | Fuel Cartridge: Absence
FuelCartridgePresence | 1 | Fuel Cartridge: Presence
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.FcStatusInternalBatteryType Enumeration

IRD

BatteryFuelCellFcStatusInternalBatteryType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FcStatusInternalBatteryType
Public Enumeration FcStatusInternalBatteryType
public enum class FcStatusInternalBatteryType
type FcStatusInternalBatteryType
Members
Member name | Value | Description
OptionalInternalBatteryAbsence | 0 | Optional Internal Battery: Absence
OptionalInternalBatteryPresence | 1 | Optional Internal Battery: Presence
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.FcStatusStateType Enumeration

IRD

BatteryFuelCellFcStatusStateType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FcStatusStateType
Public Enumeration FcStatusStateType
public enum class FcStatusStateType
type FcStatusStateType
Members
Member name | Value | Description
OFFState | 0 | OFF State
SoftOFFState | 1 | Soft-OFF State
StartupMode | 2 | Startup Mode
IdleMode | 3 | Idle Mode
ONStateProducingPowerOrCharging | 4 | ON State: Producing Power Or Charging
ONStateProducingPowerInParallelWithBattery | 5 | ON State: Producing Power In Parallel With Battery
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.ModeAlarmModeType Enumeration

IRD

BatteryFuelCellModeAlarmModeType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModeAlarmModeType
Public Enumeration ModeAlarmModeType
public enum class ModeAlarmModeType
type ModeAlarmModeType
Members
Member name | Value | Description
DisableAlarmWarningBroadcasts | 1 | Disable AlarmWarning Broadcasts
EnableAlarmWarningBroadcasts | 0 | Enable AlarmWarning Broadcasts
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.ModeCapacityModeType Enumeration

IRD

BatteryFuelCellModeCapacityModeType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModeCapacityModeType
Public Enumeration ModeCapacityModeType
public enum class ModeCapacityModeType
type ModeCapacityModeType
Members
Member name | Value | Description
ReportIn10mWOr10mWh | 1 | Report In 10mW Or 10mWh
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.ModeChargeControllerEnabledType Enumeration

IRD

BatteryFuelCellModeChargeControllerEnabledType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModeChargeControllerEnabledType
Public Enumeration ModeChargeControllerEnabledType
public enum class ModeChargeControllerEnabledType
type ModeChargeControllerEnabledType
Members
Member name | Value | Description
InternalChargeControlEnabled | 1 | Internal Charge Control Enabled
InternalChargeControlDisabled | 0 | Internal Charge Control Disabled
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.ModeChargerModeType Enumeration

IRD

BatteryFuelCellModeChargerModeType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModeChargerModeType
Public Enumeration ModeChargerModeType
public enum class ModeChargerModeType
type ModeChargerModeType
Members
Member name | Value | Description
DisableChargingVoltageAndChargingCurrentBroadcasts | 1 | Disable ChargingVoltage And ChargingCurrent Broadcasts
EnableChargingVoltageAndChargingCurrentBroadcasts | 0 | Enable ChargingVoltage And ChargingCurrent Broadcasts
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.ModeConditionFlagType Enumeration

IRD

BatteryFuelCellModeConditionFlagType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModeConditionFlagType
Public Enumeration ModeConditionFlagType
public enum class ModeConditionFlagType
type ModeConditionFlagType
Members
Member name | Value | Description
ConditioningCycleRequested | 1 | Conditioning Cycle Requested
BatteryOK | 0 | Battery OK
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.ModeFuelCellType Enumeration

IRD

BatteryFuelCellModeFuelCellType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModeFuelCellType
Public Enumeration ModeFuelCellType
public enum class ModeFuelCellType
type ModeFuelCellType
Members
Member name | Value | Description
FuelCell | 1 | Fuel Cell
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.ModePrimaryBatterySupportType Enumeration

IRD

BatteryFuelCellModePrimaryBatterySupportType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModePrimaryBatterySupportType
Public Enumeration ModePrimaryBatterySupportType
public enum class ModePrimaryBatterySupportType
type ModePrimaryBatterySupportType
Members
Member name | Value | Description
PrimaryOrSecondaryBatterySupport | 1 | Primary Or Secondary Battery Support
NotSupported | 0 | Not Supported
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.ModePrimaryBatteryType Enumeration

IRD

BatteryFuelCellModePrimaryBatteryType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModePrimaryBatteryType
Public Enumeration ModePrimaryBatteryType
public enum class ModePrimaryBatteryType
type ModePrimaryBatteryType
Members
Member name | Value | Description
BatteryOperatingInItSecondaryRole | 1 | Battery Operating In It Secondary Role
BatteryOperatingInItPrimaryRole | 0 | Battery Operating In It Primary Role
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.ModeSupportedType Enumeration

IRD

BatteryFuelCellModeSupportedType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModeSupportedType
Public Enumeration ModeSupportedType
public enum class ModeSupportedType
type ModeSupportedType
Members
Member name | Value | Description
Supported | 1 | Supported
NotSupported | 0 | Not Supported
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.RemainingCapacityAlarmType Enumeration

IRD

BatteryFuelCellRemainingCapacityAlarmType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum RemainingCapacityAlarmType
Public Enumeration RemainingCapacityAlarmType
public enum class RemainingCapacityAlarmType
type RemainingCapacityAlarmType
Members
Member name | Value | Description
AlarmDisabled | 0 | Alarm Disabled
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.RemainingTimeAlarmType Enumeration

IRD

BatteryFuelCellRemainingTimeAlarmType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum RemainingTimeAlarmType
Public Enumeration RemainingTimeAlarmType
public enum class RemainingTimeAlarmType
type RemainingTimeAlarmType
Members
Member name | Value | Description
AlarmDisabled | 0 | Alarm Disabled
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.SpecificationInfoRevisionType Enumeration

IRD

BatteryFuelCellSpecificationInfoRevisionType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SpecificationInfoRevisionType
Public Enumeration SpecificationInfoRevisionType
public enum class SpecificationInfoRevisionType
type SpecificationInfoRevisionType
Members
Member name | Value | Description
Version1011 | 1 | Version 1.0 / 1.1
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.SpecificationInfoVersionType Enumeration

IRD

BatteryFuelCellSpecificationInfoVersionType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SpecificationInfoVersionType
Public Enumeration SpecificationInfoVersionType
public enum class SpecificationInfoVersionType
type SpecificationInfoVersionType
Members
Member name | Value | Description
Version10 | 1 | Version 1.0
Version11 | 2 | Version 1.1
Version11WithPEC | 3 | Version 1.1 With PEC
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.StartTimeType Enumeration

IRD

BatteryFuelCellStartTimeType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StartTimeType
Public Enumeration StartTimeType
public enum class StartTimeType
type StartTimeType
Members
Member name | Value | Description
CannotPredict | 65535 | Cannot Predict
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusDischargingType Enumeration

IRD

BatteryFuelCellStatusDischargingType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusDischargingType
Public Enumeration StatusDischargingType
public enum class StatusDischargingType
type StatusDischargingType
Members
Member name | Value | Description
BatteryIsDischarging | 1 | Battery Is Discharging
BatteryIsAcceptingAChargeCurrent | 0 | Battery Is Accepting A Charge Current
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusErrorCodeType Enumeration

IRD

BatteryFuelCellStatusErrorCodeType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusErrorCodeType
Public Enumeration StatusErrorCodeType
public enum class StatusErrorCodeType
type StatusErrorCodeType
Members
Member name | Value | Description
OK | 0 | OK
Busy | 1 | Busy
ReservedCommand | 2 | Reserved Command
UnsupportedCommand | 3 | Unsupported Command
AccessDenied | 4 | Access Denied
OverflowUnderflow | 5 | Overflow/Underflow
BadSize | 6 | Bad Size
UnknownError | 7 | Unknown Error
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusFullyChargedType Enumeration

IRD

BatteryFuelCellStatusFullyChargedType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusFullyChargedType
Public Enumeration StatusFullyChargedType
public enum class StatusFullyChargedType
type StatusFullyChargedType
Members
Member name | Value | Description
BatteryIsFullAndFurtherChargeIsNotRequired | 1 | Battery Is Full And Further Charge Is Not Required
BatteryIsNoLongerConsideredInAFullState | 0 | Battery Is No Longer Considered In A Full State
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusFullyDischargedType Enumeration

IRD

BatteryFuelCellStatusFullyDischargedType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusFullyDischargedType
Public Enumeration StatusFullyDischargedType
public enum class StatusFullyDischargedType
type StatusFullyDischargedType
Members
Member name | Value | Description
BatteryCapacityIsDepleted | 1 | Battery Capacity Is Depleted
RelativeStateOfCharge20 | 0 | "Relative State Of Charge" > 20%
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusInitializedType Enumeration

IRD

BatteryFuelCellStatusInitializedType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusInitializedType
Public Enumeration StatusInitializedType
public enum class StatusInitializedType
type StatusInitializedType
Members
Member name | Value | Description
FirstCalibratedOrConfiguredAtTimeOfManufacture | 1 | First Calibrated Or Configured At Time Of Manufacture
CalibrationOrConfigurationInformationHasBeenLostAndAccurracyIsSignificantlyImpaired | 0 | Calibration Or Configuration Information Has Been Lost And Accurracy Is Significantly Impaired
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusOverChargedType Enumeration

IRD

BatteryFuelCellStatusOverChargedType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusOverChargedType
Public Enumeration StatusOverChargedType
public enum class StatusOverChargedType
type StatusOverChargedType
Members
Member name | Value | Description
BatteryIsFullyChargedAndChargingIsComplete | 1 | Battery Is Fully Charged And Charging Is Complete
ChargingIsNoLongerDetected | 0 | Charging Is No Longer Detected
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusOverTempType Enumeration

IRD

BatteryFuelCellStatusOverTempType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusOverTempType
Public Enumeration StatusOverTempType
public enum class StatusOverTempType
type StatusOverTempType
Members
Member name | Value | Description
TemperatureIsAbovePreSetLimit | 1 | Temperature Is Above Pre-Set Limit
TemperatureDropsIntoAcceptableRange | 0 | Temperature Drops Into Acceptable Range
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusRemainingCapacityType Enumeration

IRD

BatteryFuelCellStatusRemainingCapacityType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusRemainingCapacityType
Public Enumeration StatusRemainingCapacityType
public enum class StatusRemainingCapacityType
type StatusRemainingCapacityType
Members
Member name | Value | Description
RemainingCapacityRemainingCapacityAlarm | 1 | "Remaining Capacity" < "Remaining Capacity Alarm"
RemainingCapacityRemainingCapacityAlarmOrRemainingCapacityAlarm0 | 0 | "Remaining Capacity" > "Remaining Capacity Alarm" or "Remaining Capacity Alarm" == 0
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusRemainingTimeType Enumeration

IRD

BatteryFuelCellStatusRemainingTimeType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusRemainingTimeType
Public Enumeration StatusRemainingTimeType
public enum class StatusRemainingTimeType
type StatusRemainingTimeType
Members
Member name | Value | Description
AverageTimeToEmptyRemainingTimeAlarm | 1 | "Average Time To Empty" < "Remaining Time Alarm"
AverageTimeToEmptyRemainingTimeAlarmOrRemainingTimeAlarm0 | 0 | "Average Time To Empty" > "Remaining Time Alarm" Or "Remaining Time Alarm" == 0
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusTerminateChargeType Enumeration

IRD

BatteryFuelCellStatusTerminateChargeType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusTerminateChargeType
Public Enumeration StatusTerminateChargeType
public enum class StatusTerminateChargeType
type StatusTerminateChargeType
Members
Member name | Value | Description
ChargingShouldSuspendTemporarily | 1 | Charging Should Suspend Temporarily
ChargingIsNoLongerDetected | 0 | Charging Is No Longer Detected
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.StatusTerminateDischargeType Enumeration

IRD

BatteryFuelCellStatusTerminateDischargeType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusTerminateDischargeType
Public Enumeration StatusTerminateDischargeType
public enum class StatusTerminateDischargeType
type StatusTerminateDischargeType
Members
Member name | Value | Description
BatteryCapacityDepleted | 1 | Battery Capacity Depleted
DischargeIsNoLongerDetected | 0 | Discharge Is No Longer Detected
See Also

Reference

telos.Ird.SBSForum Namespace


BatteryFuelCell.TotalRuntimeType Enumeration

IRD

BatteryFuelCellTotalRuntimeType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TotalRuntimeType
Public Enumeration TotalRuntimeType
public enum class TotalRuntimeType
type TotalRuntimeType
Members
Member name | Value | Description
Value_65535 | 65535 | >= 65535
See Also

Reference

telos.Ird.SBSForum Namespace


Charger Class

SBS Forum: Smart Battery Charger
Inheritance Hierarchy
SystemObject
telos.Ird.SBSForumCharger

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Charger
Public Class Charger
public ref class Charger
type Charger =  class end

The Charger type exposes the following members.

Constructors
 | Name | Description
Public method | Charger | Constructor
Top
Properties
 | Name | Description
Public property | ACPresent | AC Present
Public property | AlarmInhibited | Alarm Inhibited
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryPresent | Battery Present
Public property | ChargeInhibited | Charge Inhibited
Public property | ChargerSpec | Charger Spec
Public property | ChargingCurrent | Charging Current (unit: mA)
Public property | ChargingVoltage | Charging Voltage (unit: mV)
Public property | CurrentNotReg | Current Not Reg
Public property | CurrentOR | Current OR
Public property | Discharging | Discharging
Public property | EnablePolling | Enable Polling
Public property | ErrorCode | Error Code
Public property | FullyCharged | Fully Charged
Public property | FullyDischarged | Fully Discharged
Public property | InhibitCharge | Inhibit Charge
Public property | Initialized | Initialized
Public property | Level23 | Level 2/3
Public property | OverChargedAlarm | Over Charged Alarm
Public property | OverTempAlarm | Over Temp Alarm
Public property | PollingEnabled | Polling Enabled
Public property | PORReset | POR Reset
Public property | PowerFail | Power Fail
Public property | RESCold | RES Cold
Public property | ResetToZero | Reset To Zero
Public property | RESHot | RES Hot
Public property | RESOR | RES OR
Public property | RESUR | RES UR
Public property | SelectorSupport | Selector Support
Public property | TerminateChargeAlarm | Terminate Charge Alarm
Public property | TerminateDischargeAlarm | Terminate Discharge Alarm
Public property | VoltageNotReg | Voltage Not Reg
Public property | VoltageOR | Voltage OR
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Smart Battery Charger - Revision 1.1
See Also

Reference

telos.Ird.SBSForum Namespace


Charger Constructor

Constructor

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Charger(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Charger(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Charger

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger Properties

The Charger type exposes the following members.

Properties
 | Name | Description
Public property | ACPresent | AC Present
Public property | AlarmInhibited | Alarm Inhibited
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteryPresent | Battery Present
Public property | ChargeInhibited | Charge Inhibited
Public property | ChargerSpec | Charger Spec
Public property | ChargingCurrent | Charging Current (unit: mA)
Public property | ChargingVoltage | Charging Voltage (unit: mV)
Public property | CurrentNotReg | Current Not Reg
Public property | CurrentOR | Current OR
Public property | Discharging | Discharging
Public property | EnablePolling | Enable Polling
Public property | ErrorCode | Error Code
Public property | FullyCharged | Fully Charged
Public property | FullyDischarged | Fully Discharged
Public property | InhibitCharge | Inhibit Charge
Public property | Initialized | Initialized
Public property | Level23 | Level 2/3
Public property | OverChargedAlarm | Over Charged Alarm
Public property | OverTempAlarm | Over Temp Alarm
Public property | PollingEnabled | Polling Enabled
Public property | PORReset | POR Reset
Public property | PowerFail | Power Fail
Public property | RESCold | RES Cold
Public property | ResetToZero | Reset To Zero
Public property | RESHot | RES Hot
Public property | RESOR | RES OR
Public property | RESUR | RES UR
Public property | SelectorSupport | Selector Support
Public property | TerminateChargeAlarm | Terminate Charge Alarm
Public property | TerminateDischargeAlarm | Terminate Discharge Alarm
Public property | VoltageNotReg | Voltage Not Reg
Public property | VoltageOR | Voltage OR
Top
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.ACPresent Property

IRD

ChargerACPresent Property

AC Present

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerAcPresentType ACPresent { get; }
Public ReadOnly Property ACPresent As ChargerAcPresentType
    Get
public:
property ChargerAcPresentType ACPresent {
    ChargerAcPresentType get ();
}
member ACPresent : ChargerAcPresentType with get

Property Value

Type: ChargerAcPresentType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.AlarmInhibited Property

IRD

ChargerAlarmInhibited Property

Alarm Inhibited

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerAlarmInhibitedType AlarmInhibited { get; }
Public ReadOnly Property AlarmInhibited As ChargerAlarmInhibitedType
    Get
public:
property ChargerAlarmInhibitedType AlarmInhibited {
    ChargerAlarmInhibitedType get ();
}
member AlarmInhibited : ChargerAlarmInhibitedType with get

Property Value

Type: ChargerAlarmInhibitedType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.AutoFlush Property

IRD

ChargerAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.BatteryPresent Property

IRD

ChargerBatteryPresent Property

Battery Present

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerBatteryPresentType BatteryPresent { get; }
Public ReadOnly Property BatteryPresent As ChargerBatteryPresentType
    Get
public:
property ChargerBatteryPresentType BatteryPresent {
    ChargerBatteryPresentType get ();
}
member BatteryPresent : ChargerBatteryPresentType with get

Property Value

Type: ChargerBatteryPresentType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.ChargeInhibited Property

IRD

ChargerChargeInhibited Property

Charge Inhibited

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerChargeInhibitedType ChargeInhibited { get; }
Public ReadOnly Property ChargeInhibited As ChargerChargeInhibitedType
    Get
public:
property ChargerChargeInhibitedType ChargeInhibited {
    ChargerChargeInhibitedType get ();
}
member ChargeInhibited : ChargerChargeInhibitedType with get

Property Value

Type: ChargerChargeInhibitedType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.ChargerSpec Property

IRD

ChargerChargerSpec Property

Charger Spec

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerSpecVersionType ChargerSpec { get; }
Public ReadOnly Property ChargerSpec As ChargerSpecVersionType
    Get
public:
property ChargerSpecVersionType ChargerSpec {
    ChargerSpecVersionType get ();
}
member ChargerSpec : ChargerSpecVersionType with get

Property Value

Type: ChargerSpecVersionType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.ChargingCurrent Property

IRD

ChargerChargingCurrent Property

Charging Current (unit: mA)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerChargingCurrentType ChargingCurrent { set; }
Public WriteOnly Property ChargingCurrent As ChargerChargingCurrentType
    Set
public:
property ChargerChargingCurrentType ChargingCurrent {
    void set (ChargerChargingCurrentType value);
}
member ChargingCurrent : ChargerChargingCurrentType with set

Property Value

Type: ChargerChargingCurrentType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.ChargingVoltage Property

IRD

ChargerChargingVoltage Property

Charging Voltage (unit: mV)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerChargingVoltageType ChargingVoltage { set; }
Public WriteOnly Property ChargingVoltage As ChargerChargingVoltageType
    Set
public:
property ChargerChargingVoltageType ChargingVoltage {
    void set (ChargerChargingVoltageType value);
}
member ChargingVoltage : ChargerChargingVoltageType with set

Property Value

Type: ChargerChargingVoltageType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.CurrentNotReg Property

IRD

ChargerCurrentNotReg Property

Current Not Reg

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerCurrentNotregType CurrentNotReg { get; }
Public ReadOnly Property CurrentNotReg As ChargerCurrentNotregType
    Get
public:
property ChargerCurrentNotregType CurrentNotReg {
    ChargerCurrentNotregType get ();
}
member CurrentNotReg : ChargerCurrentNotregType with get

Property Value

Type: ChargerCurrentNotregType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.CurrentOR Property

IRD

ChargerCurrentOR Property

Current OR

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerCurrentOrType CurrentOR { get; }
Public ReadOnly Property CurrentOR As ChargerCurrentOrType
    Get
public:
property ChargerCurrentOrType CurrentOR {
    ChargerCurrentOrType get ();
}
member CurrentOR : ChargerCurrentOrType with get

Property Value

Type: ChargerCurrentOrType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.Discharging Property

IRD

ChargerDischarging Property

Discharging

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerStatusDischargingType Discharging { set; }
Public WriteOnly Property Discharging As ChargerStatusDischargingType
    Set
public:
property ChargerStatusDischargingType Discharging {
    void set (ChargerStatusDischargingType value);
}
member Discharging : ChargerStatusDischargingType with set

Property Value

Type: ChargerStatusDischargingType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.EnablePolling Property

IRD

ChargerEnablePolling Property

Enable Polling

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerEnablePollingType EnablePolling { set; }
Public WriteOnly Property EnablePolling As ChargerEnablePollingType
    Set
public:
property ChargerEnablePollingType EnablePolling {
    void set (ChargerEnablePollingType value);
}
member EnablePolling : ChargerEnablePollingType with set

Property Value

Type: ChargerEnablePollingType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.ErrorCode Property

IRD

ChargerErrorCode Property

Error Code

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerAlarmErrorType ErrorCode { set; }
Public WriteOnly Property ErrorCode As ChargerAlarmErrorType
    Set
public:
property ChargerAlarmErrorType ErrorCode {
    void set (ChargerAlarmErrorType value);
}
member ErrorCode : ChargerAlarmErrorType with set

Property Value

Type: ChargerAlarmErrorType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.FullyCharged Property

IRD

ChargerFullyCharged Property

Fully Charged

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerStatusFullyChargedType FullyCharged { set; }
Public WriteOnly Property FullyCharged As ChargerStatusFullyChargedType
    Set
public:
property ChargerStatusFullyChargedType FullyCharged {
    void set (ChargerStatusFullyChargedType value);
}
member FullyCharged : ChargerStatusFullyChargedType with set

Property Value

Type: ChargerStatusFullyChargedType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.FullyDischarged Property

IRD

ChargerFullyDischarged Property

Fully Discharged

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerStatusFullyDischargedType FullyDischarged { set; }
Public WriteOnly Property FullyDischarged As ChargerStatusFullyDischargedType
    Set
public:
property ChargerStatusFullyDischargedType FullyDischarged {
    void set (ChargerStatusFullyDischargedType value);
}
member FullyDischarged : ChargerStatusFullyDischargedType with set

Property Value

Type: ChargerStatusFullyDischargedType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.InhibitCharge Property

IRD

ChargerInhibitCharge Property

Inhibit Charge

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerInhibitChargeType InhibitCharge { set; }
Public WriteOnly Property InhibitCharge As ChargerInhibitChargeType
    Set
public:
property ChargerInhibitChargeType InhibitCharge {
    void set (ChargerInhibitChargeType value);
}
member InhibitCharge : ChargerInhibitChargeType with set

Property Value

Type: ChargerInhibitChargeType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.Initialized Property

IRD

ChargerInitialized Property

Initialized

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerStatusInitializedType Initialized { set; }
Public WriteOnly Property Initialized As ChargerStatusInitializedType
    Set
public:
property ChargerStatusInitializedType Initialized {
    void set (ChargerStatusInitializedType value);
}
member Initialized : ChargerStatusInitializedType with set

Property Value

Type: ChargerStatusInitializedType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.Level23 Property

IRD

ChargerLevel23 Property

Level 2/3

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerLevelType Level23 { get; }
Public ReadOnly Property Level23 As ChargerLevelType
    Get
public:
property ChargerLevelType Level23 {
    ChargerLevelType get ();
}
member Level23 : ChargerLevelType with get

Property Value

Type: ChargerLevelType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.OverChargedAlarm Property

IRD

ChargerOverChargedAlarm Property

Over Charged Alarm

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerOverChargedAlarmType OverChargedAlarm { set; }
Public WriteOnly Property OverChargedAlarm As ChargerOverChargedAlarmType
    Set
public:
property ChargerOverChargedAlarmType OverChargedAlarm {
    void set (ChargerOverChargedAlarmType value);
}
member OverChargedAlarm : ChargerOverChargedAlarmType with set

Property Value

Type: ChargerOverChargedAlarmType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.OverTempAlarm Property

IRD

ChargerOverTempAlarm Property

Over Temp Alarm

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerOverTempAlarmType OverTempAlarm { set; }
Public WriteOnly Property OverTempAlarm As ChargerOverTempAlarmType
    Set
public:
property ChargerOverTempAlarmType OverTempAlarm {
    void set (ChargerOverTempAlarmType value);
}
member OverTempAlarm : ChargerOverTempAlarmType with set

Property Value

Type: ChargerOverTempAlarmType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.PollingEnabled Property

IRD

ChargerPollingEnabled Property

Polling Enabled

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerPollingEnabledType PollingEnabled { get; }
Public ReadOnly Property PollingEnabled As ChargerPollingEnabledType
    Get
public:
property ChargerPollingEnabledType PollingEnabled {
    ChargerPollingEnabledType get ();
}
member PollingEnabled : ChargerPollingEnabledType with get

Property Value

Type: ChargerPollingEnabledType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.PORReset Property

IRD

ChargerPORReset Property

POR Reset

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerPorResetType PORReset { set; }
Public WriteOnly Property PORReset As ChargerPorResetType
    Set
public:
property ChargerPorResetType PORReset {
    void set (ChargerPorResetType value);
}
member PORReset : ChargerPorResetType with set

Property Value

Type: ChargerPorResetType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.PowerFail Property

IRD

ChargerPowerFail Property

Power Fail

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerPowerFailType PowerFail { get; }
Public ReadOnly Property PowerFail As ChargerPowerFailType
    Get
public:
property ChargerPowerFailType PowerFail {
    ChargerPowerFailType get ();
}
member PowerFail : ChargerPowerFailType with get

Property Value

Type: ChargerPowerFailType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.RESCold Property

IRD

ChargerRESCold Property

RES Cold

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerResColdType RESCold { get; }
Public ReadOnly Property RESCold As ChargerResColdType
    Get
public:
property ChargerResColdType RESCold {
    ChargerResColdType get ();
}
member RESCold : ChargerResColdType with get

Property Value

Type: ChargerResColdType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.ResetToZero Property

IRD

ChargerResetToZero Property

Reset To Zero

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerResetToZeroType ResetToZero { set; }
Public WriteOnly Property ResetToZero As ChargerResetToZeroType
    Set
public:
property ChargerResetToZeroType ResetToZero {
    void set (ChargerResetToZeroType value);
}
member ResetToZero : ChargerResetToZeroType with set

Property Value

Type: ChargerResetToZeroType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.RESHot Property

IRD

ChargerRESHot Property

RES Hot

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerResHotType RESHot { get; }
Public ReadOnly Property RESHot As ChargerResHotType
    Get
public:
property ChargerResHotType RESHot {
    ChargerResHotType get ();
}
member RESHot : ChargerResHotType with get

Property Value

Type: ChargerResHotType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.RESOR Property

IRD

ChargerRESOR Property

RES OR

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerResOrType RESOR { get; }
Public ReadOnly Property RESOR As ChargerResOrType
    Get
public:
property ChargerResOrType RESOR {
    ChargerResOrType get ();
}
member RESOR : ChargerResOrType with get

Property Value

Type: ChargerResOrType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.RESUR Property

IRD

ChargerRESUR Property

RES UR

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerResUrType RESUR { get; }
Public ReadOnly Property RESUR As ChargerResUrType
    Get
public:
property ChargerResUrType RESUR {
    ChargerResUrType get ();
}
member RESUR : ChargerResUrType with get

Property Value

Type: ChargerResUrType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.SelectorSupport Property

IRD

ChargerSelectorSupport Property

Selector Support

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerSelectorSupportType SelectorSupport { get; }
Public ReadOnly Property SelectorSupport As ChargerSelectorSupportType
    Get
public:
property ChargerSelectorSupportType SelectorSupport {
    ChargerSelectorSupportType get ();
}
member SelectorSupport : ChargerSelectorSupportType with get

Property Value

Type: ChargerSelectorSupportType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.TerminateChargeAlarm Property

IRD

ChargerTerminateChargeAlarm Property

Terminate Charge Alarm

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerTerminateChargeAlarmType TerminateChargeAlarm { set; }
Public WriteOnly Property TerminateChargeAlarm As ChargerTerminateChargeAlarmType
    Set
public:
property ChargerTerminateChargeAlarmType TerminateChargeAlarm {
    void set (ChargerTerminateChargeAlarmType value);
}
member TerminateChargeAlarm : ChargerTerminateChargeAlarmType with set

Property Value

Type: ChargerTerminateChargeAlarmType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.TerminateDischargeAlarm Property

IRD

ChargerTerminateDischargeAlarm Property

Terminate Discharge Alarm

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerTerminateDischargeAlarmType TerminateDischargeAlarm { set; }
Public WriteOnly Property TerminateDischargeAlarm As ChargerTerminateDischargeAlarmType
    Set
public:
property ChargerTerminateDischargeAlarmType TerminateDischargeAlarm {
    void set (ChargerTerminateDischargeAlarmType value);
}
member TerminateDischargeAlarm : ChargerTerminateDischargeAlarmType with set

Property Value

Type: ChargerTerminateDischargeAlarmType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.VoltageNotReg Property

IRD

ChargerVoltageNotReg Property

Voltage Not Reg

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerVoltageNotregType VoltageNotReg { get; }
Public ReadOnly Property VoltageNotReg As ChargerVoltageNotregType
    Get
public:
property ChargerVoltageNotregType VoltageNotReg {
    ChargerVoltageNotregType get ();
}
member VoltageNotReg : ChargerVoltageNotregType with get

Property Value

Type: ChargerVoltageNotregType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.VoltageOR Property

IRD

ChargerVoltageOR Property

Voltage OR

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ChargerVoltageOrType VoltageOR { get; }
Public ReadOnly Property VoltageOR As ChargerVoltageOrType
    Get
public:
property ChargerVoltageOrType VoltageOR {
    ChargerVoltageOrType get ();
}
member VoltageOR : ChargerVoltageOrType with get

Property Value

Type: ChargerVoltageOrType
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger Methods

The Charger type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.Flush Method

IRD

ChargerFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Charger Class
telos.Ird.SBSForum Namespace


Charger.AcPresentType Enumeration

IRD

ChargerAcPresentType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AcPresentType
Public Enumeration AcPresentType
public enum class AcPresentType
type AcPresentType
Members
Member name | Value | Description
ChargePowerIsNotAvailable | 0 | Charge Power: Is Not Available
ChargePowerIsAvailable | 1 | Charge Power: Is Available
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.AlarmErrorType Enumeration

IRD

ChargerAlarmErrorType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmErrorType
Public Enumeration AlarmErrorType
public enum class AlarmErrorType
type AlarmErrorType
Members
Member name | Value | Description
OK | 0 | OK
Busy | 1 | Busy
ReservedCommand | 2 | Reserved Command
UnsupportedCommand | 3 | Unsupported Command
AccessDenied | 4 | Access Denied
OverflowUnderflow | 5 | Overflow/Underflow
BadSize | 6 | Bad Size
UnknownError | 7 | Unknown Error
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.AlarmInhibitedType Enumeration

IRD

ChargerAlarmInhibitedType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlarmInhibitedType
Public Enumeration AlarmInhibitedType
public enum class AlarmInhibitedType
type AlarmInhibitedType
Members
Member name | Value | Description
ChargerNotAlarmInhibited | 0 | Charger: Not Alarm Inhibited
ChargerAlarmInhibited | 1 | Charger: Alarm Inhibited
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.BatteryPresentType Enumeration

IRD

ChargerBatteryPresentType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum BatteryPresentType
Public Enumeration BatteryPresentType
public enum class BatteryPresentType
type BatteryPresentType
Members
Member name | Value | Description
BatteryIsNotPresent | 0 | Battery: Is Not Present
BatteryIsPresent | 1 | Battery: Is Present
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.ChargeInhibitedType Enumeration

IRD

ChargerChargeInhibitedType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ChargeInhibitedType
Public Enumeration ChargeInhibitedType
public enum class ChargeInhibitedType
type ChargeInhibitedType
Members
Member name | Value | Description
ChargerEnabled | 0 | Charger: Enabled
ChargerInhibited | 1 | Charger: Inhibited
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.ChargingCurrentType Enumeration

IRD

ChargerChargingCurrentType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ChargingCurrentType
Public Enumeration ChargingCurrentType
public enum class ChargingCurrentType
type ChargingCurrentType
Members
Member name | Value | Description
ConstantVoltageAtChargingVoltageNeeded | 65535 | Constant Voltage At ChargingVoltage Needed
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.ChargingVoltageType Enumeration

IRD

ChargerChargingVoltageType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ChargingVoltageType
Public Enumeration ChargingVoltageType
public enum class ChargingVoltageType
type ChargingVoltageType
Members
Member name | Value | Description
ConstantCurrentAtChargingCurrentNeeded | 65535 | Constant Current At ChargingCurrent Needed
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.CurrentNotregType Enumeration

IRD

ChargerCurrentNotregType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CurrentNotregType
Public Enumeration CurrentNotregType
public enum class CurrentNotregType
type CurrentNotregType
Members
Member name | Value | Description
OutputCurrentInRegulation | 0 | Output Current In Regulation
ChargingCurrentNotBeingMet | 1 | ChargingCurrent Not Being Met
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.CurrentOrType Enumeration

IRD

ChargerCurrentOrType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CurrentOrType
Public Enumeration CurrentOrType
public enum class CurrentOrType
type CurrentOrType
Members
Member name | Value | Description
ChargingCurrentValueValid | 0 | ChargingCurrent Value: Valid
ChargingCurrentValueInvalid | 1 | ChargingCurrent Value: Invalid
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.EnablePollingType Enumeration

IRD

ChargerEnablePollingType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum EnablePollingType
Public Enumeration EnablePollingType
public enum class EnablePollingType
type EnablePollingType
Members
Member name | Value | Description
DisablePolling | 0 | Disable Polling
EnablePolling | 1 | Enable Polling
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.InhibitChargeType Enumeration

IRD

ChargerInhibitChargeType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum InhibitChargeType
Public Enumeration InhibitChargeType
public enum class InhibitChargeType
type InhibitChargeType
Members
Member name | Value | Description
EnableCharging | 0 | Enable Charging
InhibitCharging | 1 | Inhibit Charging
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.LevelType Enumeration

IRD

ChargerLevelType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum LevelType
Public Enumeration LevelType
public enum class LevelType
type LevelType
Members
Member name | Value | Description
Reserved | 0 | Reserved
ChargerIsLevel2 | 1 | Charger Is Level 2
Reserved__1 | 2 | Reserved
ChargerIsLevel3 | 3 | Charger Is Level 3
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.OverChargedAlarmType Enumeration

IRD

ChargerOverChargedAlarmType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum OverChargedAlarmType
Public Enumeration OverChargedAlarmType
public enum class OverChargedAlarmType
type OverChargedAlarmType
Members
Member name | Value | Description
ChargingIsNoLongerDetected | 0 | Charging Is No Longer Detected
BatteryIsFullyChargedAndChargingIsComplete | 1 | Battery Is Fully Charged And Charging Is Complete
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.OverTempAlarmType Enumeration

IRD

ChargerOverTempAlarmType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum OverTempAlarmType
Public Enumeration OverTempAlarmType
public enum class OverTempAlarmType
type OverTempAlarmType
Members
Member name | Value | Description
TemperatureDropsIntoAcceptableRange | 0 | Temperature Drops Into Acceptable Range
TemperatureIsAbovePreSetLimit | 1 | Temperature Is Above Pre-Set Limit
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.PollingEnabledType Enumeration

IRD

ChargerPollingEnabledType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum PollingEnabledType
Public Enumeration PollingEnabledType
public enum class PollingEnabledType
type PollingEnabledType
Members
Member name | Value | Description
ChargerInSlaveModePollingDisabled | 0 | Charger: In Slave-Mode (Polling Disabled)
ChargerInMasterModePollingEnabled | 1 | Charger: In Master Mode (Polling Enabled)
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.PorResetType Enumeration

IRD

ChargerPorResetType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum PorResetType
Public Enumeration PorResetType
public enum class PorResetType
type PorResetType
Members
Member name | Value | Description
ModeUnchanged | 0 | Mode Unchanged
SetChargerToPowerOnDefaults | 1 | Set Charger To Power-On Defaults
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.PowerFailType Enumeration

IRD

ChargerPowerFailType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum PowerFailType
Public Enumeration PowerFailType
public enum class PowerFailType
type PowerFailType
Members
Member name | Value | Description
InputVoltageNotLow | 0 | Input Voltage: Not Low
InputVoltageLow | 1 | Input Voltage: Low
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.ResColdType Enumeration

IRD

ChargerResColdType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ResColdType
Public Enumeration ResColdType
public enum class ResColdType
type ResColdType
Members
Member name | Value | Description
SafetySignalNotCold | 0 | Safety Signal: Not Cold
SafetySignalCold | 1 | Safety Signal: Cold
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.ResetToZeroType Enumeration

IRD

ChargerResetToZeroType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ResetToZeroType
Public Enumeration ResetToZeroType
public enum class ResetToZeroType
type ResetToZeroType
Members
Member name | Value | Description
ChargingValuesUnchanged | 0 | Charging Values: Unchanged
ChargingValuesSetToZero | 1 | Charging Values: Set To Zero
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.ResHotType Enumeration

IRD

ChargerResHotType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ResHotType
Public Enumeration ResHotType
public enum class ResHotType
type ResHotType
Members
Member name | Value | Description
SafetySignalNotHot | 0 | Safety Signal: Not Hot
SafetySignalHot | 1 | Safety Signal: Hot
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.ResOrType Enumeration

IRD

ChargerResOrType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ResOrType
Public Enumeration ResOrType
public enum class ResOrType
type ResOrType
Members
Member name | Value | Description
SafetySignalNotOverRange | 0 | Safety Signal: Not Over-Range
SafetySignalOverRange | 1 | Safety Signal: Over-Range
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.ResUrType Enumeration

IRD

ChargerResUrType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ResUrType
Public Enumeration ResUrType
public enum class ResUrType
type ResUrType
Members
Member name | Value | Description
SafetySignalNotUnderRange | 0 | Safety Signal: Not Under-Range
SafetySignalUnderRange | 1 | Safety Signal: Under-Range
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.SelectorSupportType Enumeration

IRD

ChargerSelectorSupportType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SelectorSupportType
Public Enumeration SelectorSupportType
public enum class SelectorSupportType
type SelectorSupportType
Members
Member name | Value | Description
SelectorCommandsNotSupported | 0 | Selector Commands: Not Supported
SelectorCommandsSupported | 1 | Selector Commands: Supported
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.SpecVersionType Enumeration

IRD

ChargerSpecVersionType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SpecVersionType
Public Enumeration SpecVersionType
public enum class SpecVersionType
type SpecVersionType
Members
Member name | Value | Description
Version10 | 1 | Version 1.0
Version11 | 2 | Version 1.1
Version11WithPEC | 3 | Version 1.1 With PEC
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.StatusDischargingType Enumeration

IRD

ChargerStatusDischargingType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusDischargingType
Public Enumeration StatusDischargingType
public enum class StatusDischargingType
type StatusDischargingType
Members
Member name | Value | Description
BatteryAcceptingChargeCurrent | 0 | Battery: Accepting Charge Current
BatteryDischarging | 1 | Battery: Discharging
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.StatusFullyChargedType Enumeration

IRD

ChargerStatusFullyChargedType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusFullyChargedType
Public Enumeration StatusFullyChargedType
public enum class StatusFullyChargedType
type StatusFullyChargedType
Members
Member name | Value | Description
BatteryNotFullyCharged | 0 | Battery: Not Fully Charged
BatteryFullyCharged | 1 | Battery: Fully Charged
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.StatusFullyDischargedType Enumeration

IRD

ChargerStatusFullyDischargedType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusFullyDischargedType
Public Enumeration StatusFullyDischargedType
public enum class StatusFullyDischargedType
type StatusFullyDischargedType
Members
Member name | Value | Description
RelativeStateOfCharge20 | 0 | RelativeStateOfCharge > 20%
BatteryCapacityDepleted | 1 | Battery Capacity Depleted
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.StatusInitializedType Enumeration

IRD

ChargerStatusInitializedType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusInitializedType
Public Enumeration StatusInitializedType
public enum class StatusInitializedType
type StatusInitializedType
Members
Member name | Value | Description
CalibrationConfigurationLost | 0 | Calibration/Configuration: Lost
CalibrationConfigurationOK | 1 | Calibration/Configuration: OK
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.TerminateChargeAlarmType Enumeration

IRD

ChargerTerminateChargeAlarmType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TerminateChargeAlarmType
Public Enumeration TerminateChargeAlarmType
public enum class TerminateChargeAlarmType
type TerminateChargeAlarmType
Members
Member name | Value | Description
ChargingIsNoLongerDetected | 0 | Charging Is No Longer Detected
ChargingShouldSuspendTemporarily | 1 | Charging Should Suspend Temporarily
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.TerminateDischargeAlarmType Enumeration

IRD

ChargerTerminateDischargeAlarmType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TerminateDischargeAlarmType
Public Enumeration TerminateDischargeAlarmType
public enum class TerminateDischargeAlarmType
type TerminateDischargeAlarmType
Members
Member name | Value | Description
DischargeIsNoLongerDetected | 0 | Discharge Is No Longer Detected
BatteryCapacityDepleted | 1 | Battery Capacity Depleted
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.VoltageNotregType Enumeration

IRD

ChargerVoltageNotregType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum VoltageNotregType
Public Enumeration VoltageNotregType
public enum class VoltageNotregType
type VoltageNotregType
Members
Member name | Value | Description
OutputVoltageInRegulation | 0 | Output Voltage In Regulation
ChargingVoltageNotBeingMet | 1 | ChargingVoltage Not Being Met
See Also

Reference

telos.Ird.SBSForum Namespace


Charger.VoltageOrType Enumeration

IRD

ChargerVoltageOrType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum VoltageOrType
Public Enumeration VoltageOrType
public enum class VoltageOrType
type VoltageOrType
Members
Member name | Value | Description
ChargingVoltageValueValid | 0 | ChargingVoltage Value: Valid
ChargingVoltageValueInvalid | 1 | ChargingVoltage Value: Invalid
See Also

Reference

telos.Ird.SBSForum Namespace


Manager Class

SBS Forum: Smart Battery Manager
Inheritance Hierarchy
SystemObject
telos.Ird.SBSForumManager

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Manager
Public Class Manager
public ref class Manager
type Manager =  class end

The Manager type exposes the following members.

Constructors
 | Name | Description
Public method | Manager | Constructor
Top
Properties
 | Name | Description
Public property | ACPresent | AC Present
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteriesSupportedBatteryA | Batteries Supported (Battery A)
Public property | BatteriesSupportedBatteryB | Batteries Supported (Battery B)
Public property | BatteriesSupportedBatteryC | Batteries Supported (Battery C)
Public property | BatteriesSupportedBatteryD | Batteries Supported (Battery D)
Public property | BatterySystemRevision | Battery System Revision
Public property | Calibrate | Calibrate
Public property | CalibrateRequest | Calibrate Request
Public property | CalibrateRequestSupport | Calibrate Request Support
Public property | CalibrateX | Calibrate X
Public property | Charge | Charge
Public property | ChargerPOR | Charger POR
Public property | ChargingInhibit | Charging Inhibit
Public property | IPScale | IPScale
Public property | PowerBy | Power By
Public property | PowerNotGood | Power Not Good
Public property | Present | Present
Public property | SMB | SMB
Public property | VScale | VScale
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Smart Battery Manager - Revision 1.0
See Also

Reference

telos.Ird.SBSForum Namespace


Manager Constructor

Constructor

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Manager(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Manager(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Manager

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager Properties

The Manager type exposes the following members.

Properties
 | Name | Description
Public property | ACPresent | AC Present
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteriesSupportedBatteryA | Batteries Supported (Battery A)
Public property | BatteriesSupportedBatteryB | Batteries Supported (Battery B)
Public property | BatteriesSupportedBatteryC | Batteries Supported (Battery C)
Public property | BatteriesSupportedBatteryD | Batteries Supported (Battery D)
Public property | BatterySystemRevision | Battery System Revision
Public property | Calibrate | Calibrate
Public property | CalibrateRequest | Calibrate Request
Public property | CalibrateRequestSupport | Calibrate Request Support
Public property | CalibrateX | Calibrate X
Public property | Charge | Charge
Public property | ChargerPOR | Charger POR
Public property | ChargingInhibit | Charging Inhibit
Public property | IPScale | IPScale
Public property | PowerBy | Power By
Public property | PowerNotGood | Power Not Good
Public property | Present | Present
Public property | SMB | SMB
Public property | VScale | VScale
Top
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.ACPresent Property

IRD

ManagerACPresent Property

AC Present

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ManagerBoolType ACPresent { get; }
Public ReadOnly Property ACPresent As ManagerBoolType
    Get
public:
property ManagerBoolType ACPresent {
    ManagerBoolType get ();
}
member ACPresent : ManagerBoolType with get

Property Value

Type: ManagerBoolType
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.AutoFlush Property

IRD

ManagerAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.BatteriesSupportedBatteryA Property

IRD

ManagerBatteriesSupportedBatteryA Property

Batteries Supported (Battery A)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ManagerSupportedType BatteriesSupportedBatteryA { get; }
Public ReadOnly Property BatteriesSupportedBatteryA As ManagerSupportedType
    Get
public:
property ManagerSupportedType BatteriesSupportedBatteryA {
    ManagerSupportedType get ();
}
member BatteriesSupportedBatteryA : ManagerSupportedType with get

Property Value

Type: ManagerSupportedType
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.BatteriesSupportedBatteryB Property

IRD

ManagerBatteriesSupportedBatteryB Property

Batteries Supported (Battery B)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ManagerSupportedType BatteriesSupportedBatteryB { get; }
Public ReadOnly Property BatteriesSupportedBatteryB As ManagerSupportedType
    Get
public:
property ManagerSupportedType BatteriesSupportedBatteryB {
    ManagerSupportedType get ();
}
member BatteriesSupportedBatteryB : ManagerSupportedType with get

Property Value

Type: ManagerSupportedType
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.BatteriesSupportedBatteryC Property

IRD

ManagerBatteriesSupportedBatteryC Property

Batteries Supported (Battery C)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ManagerSupportedType BatteriesSupportedBatteryC { get; }
Public ReadOnly Property BatteriesSupportedBatteryC As ManagerSupportedType
    Get
public:
property ManagerSupportedType BatteriesSupportedBatteryC {
    ManagerSupportedType get ();
}
member BatteriesSupportedBatteryC : ManagerSupportedType with get

Property Value

Type: ManagerSupportedType
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.BatteriesSupportedBatteryD Property

IRD

ManagerBatteriesSupportedBatteryD Property

Batteries Supported (Battery D)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ManagerSupportedType BatteriesSupportedBatteryD { get; }
Public ReadOnly Property BatteriesSupportedBatteryD As ManagerSupportedType
    Get
public:
property ManagerSupportedType BatteriesSupportedBatteryD {
    ManagerSupportedType get ();
}
member BatteriesSupportedBatteryD : ManagerSupportedType with get

Property Value

Type: ManagerSupportedType
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.BatterySystemRevision Property

IRD

ManagerBatterySystemRevision Property

Battery System Revision

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ManagerSystemInfoRevisionType BatterySystemRevision { get; }
Public ReadOnly Property BatterySystemRevision As ManagerSystemInfoRevisionType
    Get
public:
property ManagerSystemInfoRevisionType BatterySystemRevision {
    ManagerSystemInfoRevisionType get ();
}
member BatterySystemRevision : ManagerSystemInfoRevisionType with get

Property Value

Type: ManagerSystemInfoRevisionType
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.Calibrate Property

IRD

ManagerCalibrate Property

Calibrate

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ManagerBoolType Calibrate { get; set; }
Public Property Calibrate As ManagerBoolType
    Get
    Set
public:
property ManagerBoolType Calibrate {
    ManagerBoolType get ();
    void set (ManagerBoolType value);
}
member Calibrate : ManagerBoolType with get, set

Property Value

Type: ManagerBoolType
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.CalibrateRequest Property

IRD

ManagerCalibrateRequest Property

Calibrate Request

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ManagerBoolType CalibrateRequest { get; }
Public ReadOnly Property CalibrateRequest As ManagerBoolType
    Get
public:
property ManagerBoolType CalibrateRequest {
    ManagerBoolType get ();
}
member CalibrateRequest : ManagerBoolType with get

Property Value

Type: ManagerBoolType
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.CalibrateRequestSupport Property

IRD

ManagerCalibrateRequestSupport Property

Calibrate Request Support

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ManagerBoolType CalibrateRequestSupport { get; }
Public ReadOnly Property CalibrateRequestSupport As ManagerBoolType
    Get
public:
property ManagerBoolType CalibrateRequestSupport {
    ManagerBoolType get ();
}
member CalibrateRequestSupport : ManagerBoolType with get

Property Value

Type: ManagerBoolType
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.CalibrateX Property

IRD

ManagerCalibrateX Property

Calibrate X

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ManagerSystemStateContCalibrateXType CalibrateX { get; set; }
Public Property CalibrateX As ManagerSystemStateContCalibrateXType
    Get
    Set
public:
property ManagerSystemStateContCalibrateXType CalibrateX {
    ManagerSystemStateContCalibrateXType get ();
    void set (ManagerSystemStateContCalibrateXType value);
}
member CalibrateX : ManagerSystemStateContCalibrateXType with get, set

Property Value

Type: ManagerSystemStateContCalibrateXType
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.Charge Property

IRD

ManagerCharge Property

Charge

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ManagerSystemStateChargeType Charge { get; }
Public ReadOnly Property Charge As ManagerSystemStateChargeType
    Get
public:
property ManagerSystemStateChargeType Charge {
    ManagerSystemStateChargeType get ();
}
member Charge : ManagerSystemStateChargeType with get

Property Value

Type: ManagerSystemStateChargeType
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.ChargerPOR Property

IRD

ManagerChargerPOR Property

Charger POR

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ManagerSystemStateContChargerPorType ChargerPOR { set; }
Public WriteOnly Property ChargerPOR As ManagerSystemStateContChargerPorType
    Set
public:
property ManagerSystemStateContChargerPorType ChargerPOR {
    void set (ManagerSystemStateContChargerPorType value);
}
member ChargerPOR : ManagerSystemStateContChargerPorType with set

Property Value

Type: ManagerSystemStateContChargerPorType
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.ChargingInhibit Property

IRD

ManagerChargingInhibit Property

Charging Inhibit

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ManagerSystemStateContChargingInhibitType ChargingInhibit { get; set; }
Public Property ChargingInhibit As ManagerSystemStateContChargingInhibitType
    Get
    Set
public:
property ManagerSystemStateContChargingInhibitType ChargingInhibit {
    ManagerSystemStateContChargingInhibitType get ();
    void set (ManagerSystemStateContChargingInhibitType value);
}
member ChargingInhibit : ManagerSystemStateContChargingInhibitType with get, set

Property Value

Type: ManagerSystemStateContChargingInhibitType
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.IPScale Property

IRD

ManagerIPScale Property

IPScale

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IPScale { get; }
Public ReadOnly Property IPScale As Byte
    Get
public:
property unsigned char IPScale {
    unsigned char get ();
}
member IPScale : byte with get

Property Value

Type: Byte
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.PowerBy Property

IRD

ManagerPowerBy Property

Power By

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ManagerSystemStatePowerByType PowerBy { get; }
Public ReadOnly Property PowerBy As ManagerSystemStatePowerByType
    Get
public:
property ManagerSystemStatePowerByType PowerBy {
    ManagerSystemStatePowerByType get ();
}
member PowerBy : ManagerSystemStatePowerByType with get

Property Value

Type: ManagerSystemStatePowerByType
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.PowerNotGood Property

IRD

ManagerPowerNotGood Property

Power Not Good

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ManagerBoolType PowerNotGood { get; }
Public ReadOnly Property PowerNotGood As ManagerBoolType
    Get
public:
property ManagerBoolType PowerNotGood {
    ManagerBoolType get ();
}
member PowerNotGood : ManagerBoolType with get

Property Value

Type: ManagerBoolType
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.Present Property

IRD

ManagerPresent Property

Present

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ManagerSystemStatePresentType Present { get; }
Public ReadOnly Property Present As ManagerSystemStatePresentType
    Get
public:
property ManagerSystemStatePresentType Present {
    ManagerSystemStatePresentType get ();
}
member Present : ManagerSystemStatePresentType with get

Property Value

Type: ManagerSystemStatePresentType
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.SMB Property

IRD

ManagerSMB Property

SMB

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ManagerSystemStateSmbType SMB { get; set; }
Public Property SMB As ManagerSystemStateSmbType
    Get
    Set
public:
property ManagerSystemStateSmbType SMB {
    ManagerSystemStateSmbType get ();
    void set (ManagerSystemStateSmbType value);
}
member SMB : ManagerSystemStateSmbType with get, set

Property Value

Type: ManagerSystemStateSmbType
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.VScale Property

IRD

ManagerVScale Property

VScale

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VScale { get; }
Public ReadOnly Property VScale As Byte
    Get
public:
property unsigned char VScale {
    unsigned char get ();
}
member VScale : byte with get

Property Value

Type: Byte
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager Methods

The Manager type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.Flush Method

IRD

ManagerFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Manager Class
telos.Ird.SBSForum Namespace


Manager.BoolType Enumeration

IRD

ManagerBoolType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum BoolType
Public Enumeration BoolType
public enum class BoolType
type BoolType
Members
Member name | Value | Description
False | 0 | False
True | 1 | True
See Also

Reference

telos.Ird.SBSForum Namespace


Manager.SupportedType Enumeration

IRD

ManagerSupportedType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SupportedType
Public Enumeration SupportedType
public enum class SupportedType
type SupportedType
Members
Member name | Value | Description
NotSupported | 0 | Not Supported
Supported | 1 | Supported
See Also

Reference

telos.Ird.SBSForum Namespace


Manager.SystemInfoRevisionType Enumeration

IRD

ManagerSystemInfoRevisionType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SystemInfoRevisionType
Public Enumeration SystemInfoRevisionType
public enum class SystemInfoRevisionType
type SystemInfoRevisionType
Members
Member name | Value | Description
Version10 | 8 | Version 1.0
Version10WithPEC | 9 | Version 1.0 With PEC
See Also

Reference

telos.Ird.SBSForum Namespace


Manager.SystemStateChargeType Enumeration

IRD

ManagerSystemStateChargeType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SystemStateChargeType
Public Enumeration SystemStateChargeType
public enum class SystemStateChargeType
type SystemStateChargeType
Members
Member name | Value | Description
BatteriesChargedNone | 0 | Batteries Charged: None
BatteriesChargedA | 1 | Batteries Charged: A
BatteriesChargedB | 2 | Batteries Charged: B
BatteriesChargedAB | 3 | Batteries Charged: A, B
BatteriesChargedC | 4 | Batteries Charged: C
BatteriesChargedAC | 5 | Batteries Charged: A, C
BatteriesChargedBC | 6 | Batteries Charged: B, C
BatteriesChargedABC | 7 | Batteries Charged: A, B, C
BatteriesChargedD | 8 | Batteries Charged: D
BatteriesChargedAD | 9 | Batteries Charged: A, D
BatteriesChargedBD | 10 | Batteries Charged: B, D
BatteriesChargedABD | 11 | Batteries Charged: A, B, D
BatteriesChargedCD | 12 | Batteries Charged: C, D
BatteriesChargedACD | 13 | Batteries Charged: A, C, D
BatteriesChargedBCD | 14 | Batteries Charged: B, C, D
BatteriesChargedABCD | 15 | Batteries Charged: A, B, C, D
See Also

Reference

telos.Ird.SBSForum Namespace


Manager.SystemStateContCalibrateXType Enumeration

IRD

ManagerSystemStateContCalibrateXType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SystemStateContCalibrateXType
Public Enumeration SystemStateContCalibrateXType
public enum class SystemStateContCalibrateXType
type SystemStateContCalibrateXType
Members
Member name | Value | Description
BatteryCalibratedNone | 0 | Battery Calibrated: None
BatteriesCalibratedA | 1 | Batteries Calibrated: A
BatteriesCalibratedB | 2 | Batteries Calibrated: B
Reserved | 3 | Reserved
BatteriesCalibratedC | 4 | Batteries Calibrated: C
Reserved__1 | 5 | Reserved
BatteriesCalibratedD | 8 | Batteries Calibrated: D
Reserved__2 | 9 | Reserved
See Also

Reference

telos.Ird.SBSForum Namespace


Manager.SystemStateContChargerPorType Enumeration

IRD

ManagerSystemStateContChargerPorType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SystemStateContChargerPorType
Public Enumeration SystemStateContChargerPorType
public enum class SystemStateContChargerPorType
type SystemStateContChargerPorType
Members
Member name | Value | Description
ChargerDoNotForcePowerOnReset | 0 | Charger: Do Not Force Power On Reset
ChargerForcePowerOnReset | 1 | Charger: Force Power On Reset
See Also

Reference

telos.Ird.SBSForum Namespace


Manager.SystemStateContChargingInhibitType Enumeration

IRD

ManagerSystemStateContChargingInhibitType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SystemStateContChargingInhibitType
Public Enumeration SystemStateContChargingInhibitType
public enum class SystemStateContChargingInhibitType
type SystemStateContChargingInhibitType
Members
Member name | Value | Description
ChargingIsAllowed | 0 | Charging Is Allowed
ChargingIsInhibit | 1 | Charging Is Inhibit
See Also

Reference

telos.Ird.SBSForum Namespace


Manager.SystemStatePowerByType Enumeration

IRD

ManagerSystemStatePowerByType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SystemStatePowerByType
Public Enumeration SystemStatePowerByType
public enum class SystemStatePowerByType
type SystemStatePowerByType
Members
Member name | Value | Description
SystemPoweredByAC | 0 | System Powered By: AC
SystemPoweredByBatteryA | 1 | System Powered By Battery: A
SystemPoweredByBatteryB | 2 | System Powered By Battery: B
SystemPoweredByBatteryAB | 3 | System Powered By Battery: A, B
SystemPoweredByBatteryC | 4 | System Powered By Battery: C
SystemPoweredByBatteryAC | 5 | System Powered By Battery: A, C
SystemPoweredByBatteryBC | 6 | System Powered By Battery: B, C
SystemPoweredByBatteryABC | 7 | System Powered By Battery: A, B, C
SystemPoweredByBatteryD | 8 | System Powered By Battery: D
SystemPoweredByBatteryAD | 9 | System Powered By Battery: A, D
SystemPoweredByBatteryBD | 10 | System Powered By Battery: B, D
SystemPoweredByBatteryABD | 11 | System Powered By Battery: A, B, D
SystemPoweredByBatteryCD | 12 | System Powered By Battery: C, D
SystemPoweredByBatteryACD | 13 | System Powered By Battery: A, C, D
SystemPoweredByBatteryBCD | 14 | System Powered By Battery: B, C, D
SystemPoweredByBatteryABCD | 15 | System Powered By Battery: A, B, C, D
See Also

Reference

telos.Ird.SBSForum Namespace


Manager.SystemStatePresentType Enumeration

IRD

ManagerSystemStatePresentType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SystemStatePresentType
Public Enumeration SystemStatePresentType
public enum class SystemStatePresentType
type SystemStatePresentType
Members
Member name | Value | Description
BatteriesPresentNone | 0 | Batteries Present: None
BatteriesPresentA | 1 | Batteries Present: A
BatteriesPresentB | 2 | Batteries Present: B
BatteriesPresentAB | 3 | Batteries Present: A, B
BatteriesPresentC | 4 | Batteries Present: C
BatteriesPresentAC | 5 | Batteries Present: A, C
BatteriesPresentBC | 6 | Batteries Present: B, C
BatteriesPresentABC | 7 | Batteries Present: A, B, C
BatteriesPresentD | 8 | Batteries Present: D
BatteriesPresentAD | 9 | Batteries Present: A, D
BatteriesPresentBD | 10 | Batteries Present: B, D
BatteriesPresentABD | 11 | Batteries Present: A, B, D
BatteriesPresentCD | 12 | Batteries Present: C, D
BatteriesPresentACD | 13 | Batteries Present: A, C, D
BatteriesPresentBCD | 14 | Batteries Present: B, C, D
BatteriesPresentABCD | 15 | Batteries Present: A, B, C, D
See Also

Reference

telos.Ird.SBSForum Namespace


Manager.SystemStateSmbType Enumeration

IRD

ManagerSystemStateSmbType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SystemStateSmbType
Public Enumeration SystemStateSmbType
public enum class SystemStateSmbType
type SystemStateSmbType
Members
Member name | Value | Description
Reserved | 0 | Reserved
SMBusHostIsCommunicatingWithBatteryA | 1 | SMBus Host Is Communicating With: Battery A
SMBusHostIsCommunicatingWithBatteryB | 2 | SMBus Host Is Communicating With: Battery B
Reserved__1 | 3 | Reserved
SMBusHostIsCommunicatingWithBatteryC | 4 | SMBus Host Is Communicating With: Battery C
Reserved__2 | 5 | Reserved
SMBusHostIsCommunicatingWithBatteryD | 8 | SMBus Host Is Communicating With: Battery D
Reserved__3 | 9 | Reserved
SMBusHostIsCommunicatingWithCompositeOfTheBatterySPoweringTheSystem | 15 | SMBus Host Is Communicating With: Composite Of The Battery(s) Powering The System
See Also

Reference

telos.Ird.SBSForum Namespace


Selector Class

SBS Forum: Smart Battery Selector
Inheritance Hierarchy
SystemObject
telos.Ird.SBSForumSelector

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Selector
Public Class Selector
public ref class Selector
type Selector =  class end

The Selector type exposes the following members.

Constructors
 | Name | Description
Public method | Selector | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteriesSupportedBatteryA | Batteries Supported (Battery A)
Public property | BatteriesSupportedBatteryB | Batteries Supported (Battery B)
Public property | BatteriesSupportedBatteryC | Batteries Supported (Battery C)
Public property | BatteriesSupportedBatteryD | Batteries Supported (Battery D)
Public property | Charge | Charge
Public property | Charge__1 | Charge
Public property | ChargingIndicator | Charging Indicator
Public property | OKToUseBatteryA | OK To Use (Battery A)
Public property | OKToUseBatteryB | OK To Use (Battery B)
Public property | OKToUseBatteryC | OK To Use (Battery C)
Public property | OKToUseBatteryD | OK To Use (Battery D)
Public property | PowerBy | Power By
Public property | PowerBy__1 | Power By
Public property | PresentBatteryA | Present (Battery A)
Public property | PresentBatteryB | Present (Battery B)
Public property | PresentBatteryC | Present (Battery C)
Public property | PresentBatteryD | Present (Battery D)
Public property | SelectorRevision | Selector Revision
Public property | SMB | SMB
Public property | SMB__1 | SMB
Public property | UseNext | Use Next
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Smart Battery Selector - Revision 1.1
See Also

Reference

telos.Ird.SBSForum Namespace


Selector Constructor

Constructor

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Selector(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Selector(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Selector

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector Properties

The Selector type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BatteriesSupportedBatteryA | Batteries Supported (Battery A)
Public property | BatteriesSupportedBatteryB | Batteries Supported (Battery B)
Public property | BatteriesSupportedBatteryC | Batteries Supported (Battery C)
Public property | BatteriesSupportedBatteryD | Batteries Supported (Battery D)
Public property | Charge | Charge
Public property | Charge__1 | Charge
Public property | ChargingIndicator | Charging Indicator
Public property | OKToUseBatteryA | OK To Use (Battery A)
Public property | OKToUseBatteryB | OK To Use (Battery B)
Public property | OKToUseBatteryC | OK To Use (Battery C)
Public property | OKToUseBatteryD | OK To Use (Battery D)
Public property | PowerBy | Power By
Public property | PowerBy__1 | Power By
Public property | PresentBatteryA | Present (Battery A)
Public property | PresentBatteryB | Present (Battery B)
Public property | PresentBatteryC | Present (Battery C)
Public property | PresentBatteryD | Present (Battery D)
Public property | SelectorRevision | Selector Revision
Public property | SMB | SMB
Public property | SMB__1 | SMB
Public property | UseNext | Use Next
Top
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.AutoFlush Property

IRD

SelectorAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.BatteriesSupportedBatteryA Property

IRD

SelectorBatteriesSupportedBatteryA Property

Batteries Supported (Battery A)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorSupportedType BatteriesSupportedBatteryA { get; }
Public ReadOnly Property BatteriesSupportedBatteryA As SelectorSupportedType
    Get
public:
property SelectorSupportedType BatteriesSupportedBatteryA {
    SelectorSupportedType get ();
}
member BatteriesSupportedBatteryA : SelectorSupportedType with get

Property Value

Type: SelectorSupportedType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.BatteriesSupportedBatteryB Property

IRD

SelectorBatteriesSupportedBatteryB Property

Batteries Supported (Battery B)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorSupportedType BatteriesSupportedBatteryB { get; }
Public ReadOnly Property BatteriesSupportedBatteryB As SelectorSupportedType
    Get
public:
property SelectorSupportedType BatteriesSupportedBatteryB {
    SelectorSupportedType get ();
}
member BatteriesSupportedBatteryB : SelectorSupportedType with get

Property Value

Type: SelectorSupportedType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.BatteriesSupportedBatteryC Property

IRD

SelectorBatteriesSupportedBatteryC Property

Batteries Supported (Battery C)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorSupportedType BatteriesSupportedBatteryC { get; }
Public ReadOnly Property BatteriesSupportedBatteryC As SelectorSupportedType
    Get
public:
property SelectorSupportedType BatteriesSupportedBatteryC {
    SelectorSupportedType get ();
}
member BatteriesSupportedBatteryC : SelectorSupportedType with get

Property Value

Type: SelectorSupportedType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.BatteriesSupportedBatteryD Property

IRD

SelectorBatteriesSupportedBatteryD Property

Batteries Supported (Battery D)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorSupportedType BatteriesSupportedBatteryD { get; }
Public ReadOnly Property BatteriesSupportedBatteryD As SelectorSupportedType
    Get
public:
property SelectorSupportedType BatteriesSupportedBatteryD {
    SelectorSupportedType get ();
}
member BatteriesSupportedBatteryD : SelectorSupportedType with get

Property Value

Type: SelectorSupportedType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.Charge Property

IRD

SelectorCharge Property

Charge

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorSelectorStateChargeReadType Charge { get; }
Public ReadOnly Property Charge As SelectorSelectorStateChargeReadType
    Get
public:
property SelectorSelectorStateChargeReadType Charge {
    SelectorSelectorStateChargeReadType get ();
}
member Charge : SelectorSelectorStateChargeReadType with get

Property Value

Type: SelectorSelectorStateChargeReadType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.Charge__1 Property

IRD

SelectorCharge__1 Property

Charge

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorSelectorStateChargeWriteType Charge__1 { set; }
Public WriteOnly Property Charge__1 As SelectorSelectorStateChargeWriteType
    Set
public:
property SelectorSelectorStateChargeWriteType Charge__1 {
    void set (SelectorSelectorStateChargeWriteType value);
}
member Charge__1 : SelectorSelectorStateChargeWriteType with set

Property Value

Type: SelectorSelectorStateChargeWriteType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.ChargingIndicator Property

IRD

SelectorChargingIndicator Property

Charging Indicator

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorSupportedType ChargingIndicator { get; }
Public ReadOnly Property ChargingIndicator As SelectorSupportedType
    Get
public:
property SelectorSupportedType ChargingIndicator {
    SelectorSupportedType get ();
}
member ChargingIndicator : SelectorSupportedType with get

Property Value

Type: SelectorSupportedType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.OKToUseBatteryA Property

IRD

SelectorOKToUseBatteryA Property

OK To Use (Battery A)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorOkToUseType OKToUseBatteryA { get; set; }
Public Property OKToUseBatteryA As SelectorOkToUseType
    Get
    Set
public:
property SelectorOkToUseType OKToUseBatteryA {
    SelectorOkToUseType get ();
    void set (SelectorOkToUseType value);
}
member OKToUseBatteryA : SelectorOkToUseType with get, set

Property Value

Type: SelectorOkToUseType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.OKToUseBatteryB Property

IRD

SelectorOKToUseBatteryB Property

OK To Use (Battery B)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorOkToUseType OKToUseBatteryB { get; set; }
Public Property OKToUseBatteryB As SelectorOkToUseType
    Get
    Set
public:
property SelectorOkToUseType OKToUseBatteryB {
    SelectorOkToUseType get ();
    void set (SelectorOkToUseType value);
}
member OKToUseBatteryB : SelectorOkToUseType with get, set

Property Value

Type: SelectorOkToUseType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.OKToUseBatteryC Property

IRD

SelectorOKToUseBatteryC Property

OK To Use (Battery C)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorOkToUseType OKToUseBatteryC { get; set; }
Public Property OKToUseBatteryC As SelectorOkToUseType
    Get
    Set
public:
property SelectorOkToUseType OKToUseBatteryC {
    SelectorOkToUseType get ();
    void set (SelectorOkToUseType value);
}
member OKToUseBatteryC : SelectorOkToUseType with get, set

Property Value

Type: SelectorOkToUseType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.OKToUseBatteryD Property

IRD

SelectorOKToUseBatteryD Property

OK To Use (Battery D)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorOkToUseType OKToUseBatteryD { get; set; }
Public Property OKToUseBatteryD As SelectorOkToUseType
    Get
    Set
public:
property SelectorOkToUseType OKToUseBatteryD {
    SelectorOkToUseType get ();
    void set (SelectorOkToUseType value);
}
member OKToUseBatteryD : SelectorOkToUseType with get, set

Property Value

Type: SelectorOkToUseType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.PowerBy Property

IRD

SelectorPowerBy Property

Power By

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorSelectorStatePowerByReadType PowerBy { get; }
Public ReadOnly Property PowerBy As SelectorSelectorStatePowerByReadType
    Get
public:
property SelectorSelectorStatePowerByReadType PowerBy {
    SelectorSelectorStatePowerByReadType get ();
}
member PowerBy : SelectorSelectorStatePowerByReadType with get

Property Value

Type: SelectorSelectorStatePowerByReadType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.PowerBy__1 Property

IRD

SelectorPowerBy__1 Property

Power By

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorSelectorStatePowerByWriteType PowerBy__1 { set; }
Public WriteOnly Property PowerBy__1 As SelectorSelectorStatePowerByWriteType
    Set
public:
property SelectorSelectorStatePowerByWriteType PowerBy__1 {
    void set (SelectorSelectorStatePowerByWriteType value);
}
member PowerBy__1 : SelectorSelectorStatePowerByWriteType with set

Property Value

Type: SelectorSelectorStatePowerByWriteType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.PresentBatteryA Property

IRD

SelectorPresentBatteryA Property

Present (Battery A)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorPresentType PresentBatteryA { get; }
Public ReadOnly Property PresentBatteryA As SelectorPresentType
    Get
public:
property SelectorPresentType PresentBatteryA {
    SelectorPresentType get ();
}
member PresentBatteryA : SelectorPresentType with get

Property Value

Type: SelectorPresentType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.PresentBatteryB Property

IRD

SelectorPresentBatteryB Property

Present (Battery B)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorPresentType PresentBatteryB { get; }
Public ReadOnly Property PresentBatteryB As SelectorPresentType
    Get
public:
property SelectorPresentType PresentBatteryB {
    SelectorPresentType get ();
}
member PresentBatteryB : SelectorPresentType with get

Property Value

Type: SelectorPresentType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.PresentBatteryC Property

IRD

SelectorPresentBatteryC Property

Present (Battery C)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorPresentType PresentBatteryC { get; }
Public ReadOnly Property PresentBatteryC As SelectorPresentType
    Get
public:
property SelectorPresentType PresentBatteryC {
    SelectorPresentType get ();
}
member PresentBatteryC : SelectorPresentType with get

Property Value

Type: SelectorPresentType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.PresentBatteryD Property

IRD

SelectorPresentBatteryD Property

Present (Battery D)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorPresentType PresentBatteryD { get; }
Public ReadOnly Property PresentBatteryD As SelectorPresentType
    Get
public:
property SelectorPresentType PresentBatteryD {
    SelectorPresentType get ();
}
member PresentBatteryD : SelectorPresentType with get

Property Value

Type: SelectorPresentType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.SelectorRevision Property

IRD

SelectorSelectorRevision Property

Selector Revision

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorSelectorRevisionType SelectorRevision { get; }
Public ReadOnly Property SelectorRevision As SelectorSelectorRevisionType
    Get
public:
property SelectorSelectorRevisionType SelectorRevision {
    SelectorSelectorRevisionType get ();
}
member SelectorRevision : SelectorSelectorRevisionType with get

Property Value

Type: SelectorSelectorRevisionType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.SMB Property

IRD

SelectorSMB Property

SMB

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorSelectorStateSmbReadType SMB { get; }
Public ReadOnly Property SMB As SelectorSelectorStateSmbReadType
    Get
public:
property SelectorSelectorStateSmbReadType SMB {
    SelectorSelectorStateSmbReadType get ();
}
member SMB : SelectorSelectorStateSmbReadType with get

Property Value

Type: SelectorSelectorStateSmbReadType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.SMB__1 Property

IRD

SelectorSMB__1 Property

SMB

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorSelectorStateSmbWriteType SMB__1 { set; }
Public WriteOnly Property SMB__1 As SelectorSelectorStateSmbWriteType
    Set
public:
property SelectorSelectorStateSmbWriteType SMB__1 {
    void set (SelectorSelectorStateSmbWriteType value);
}
member SMB__1 : SelectorSelectorStateSmbWriteType with set

Property Value

Type: SelectorSelectorStateSmbWriteType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.UseNext Property

IRD

SelectorUseNext Property

Use Next

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SelectorUseNextType UseNext { get; set; }
Public Property UseNext As SelectorUseNextType
    Get
    Set
public:
property SelectorUseNextType UseNext {
    SelectorUseNextType get ();
    void set (SelectorUseNextType value);
}
member UseNext : SelectorUseNextType with get, set

Property Value

Type: SelectorUseNextType
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector Methods

The Selector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.Flush Method

IRD

SelectorFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Selector Class
telos.Ird.SBSForum Namespace


Selector.OkToUseType Enumeration

IRD

SelectorOkToUseType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum OkToUseType
Public Enumeration OkToUseType
public enum class OkToUseType
type OkToUseType
Members
Member name | Value | Description
DisallowTheUse | 0 | Disallow The Use
AllowTheUse | 1 | Allow The Use
See Also

Reference

telos.Ird.SBSForum Namespace


Selector.PresentType Enumeration

IRD

SelectorPresentType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum PresentType
Public Enumeration PresentType
public enum class PresentType
type PresentType
Members
Member name | Value | Description
NotPresent | 0 | Not Present
Present | 1 | Present
See Also

Reference

telos.Ird.SBSForum Namespace


Selector.SelectorRevisionType Enumeration

IRD

SelectorSelectorRevisionType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SelectorRevisionType
Public Enumeration SelectorRevisionType
public enum class SelectorRevisionType
type SelectorRevisionType
Members
Member name | Value | Description
Version10 | 1 | Version 1.0
Version11 | 2 | Version 1.1
Version11WithPEC | 3 | Version 1.1 With PEC
See Also

Reference

telos.Ird.SBSForum Namespace


Selector.SelectorStateChargeReadType Enumeration

IRD

SelectorSelectorStateChargeReadType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SelectorStateChargeReadType
Public Enumeration SelectorStateChargeReadType
public enum class SelectorStateChargeReadType
type SelectorStateChargeReadType
Members
Member name | Value | Description
BatteryConnectedToChargerUnknownNone | 0 | Battery Connected To Charger: Unknown/None
BatteryConnectedToChargerBatteryAACNotPresent | 1 | Battery Connected To Charger: Battery A ; AC: Not Present
BatteryConnectedToChargerBatteryBACNotPresent | 2 | Battery Connected To Charger: Battery B ; AC: Not Present
Reserved | 3 | Reserved
BatteryConnectedToChargerBatteryCACNotPresent | 4 | Battery Connected To Charger: Battery C ; AC: Not Present
Reserved__1 | 5 | Reserved
BatteryConnectedToChargerBatteryDACPresent | 7 | Battery Connected To Charger: Battery D ; AC: Present
BatteryConnectedToChargerBatteryDACNotPresent | 8 | Battery Connected To Charger: Battery D ; AC: Not Present
Reserved__2 | 9 | Reserved
BatteryConnectedToChargerBatteryCACPresent | 11 | Battery Connected To Charger: Battery C ; AC: Present
Reserved__3 | 12 | Reserved
BatteryConnectedToChargerBatteryBACPresent | 13 | Battery Connected To Charger: Battery B ; AC: Present
BatteryConnectedToChargerBatteryAACPresent | 14 | Battery Connected To Charger: Battery A ; AC: Present
BatteryConnectedToChargerUnknownNoneACPresent | 15 | Battery Connected To Charger: Unknown/None ; AC: Present
See Also

Reference

telos.Ird.SBSForum Namespace


Selector.SelectorStateChargeWriteType Enumeration

IRD

SelectorSelectorStateChargeWriteType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SelectorStateChargeWriteType
Public Enumeration SelectorStateChargeWriteType
public enum class SelectorStateChargeWriteType
type SelectorStateChargeWriteType
Members
Member name | Value | Description
BatteryConnectedToChargerUnknownNone | 0 | Battery Connected To Charger: Unknown/None
BatteryConnectedToChargerBatteryAACNotPresent | 1 | Battery Connected To Charger: Battery A ; AC: Not Present
BatteryConnectedToChargerBatteryBACNotPresent | 2 | Battery Connected To Charger: Battery B ; AC: Not Present
Reserved | 3 | Reserved
BatteryConnectedToChargerBatteryCACNotPresent | 4 | Battery Connected To Charger: Battery C ; AC: Not Present
Reserved__1 | 5 | Reserved
BatteryConnectedToChargerBatteryDACNotPresent | 8 | Battery Connected To Charger: Battery D ; AC: Not Present
Reserved__2 | 9 | Reserved
NotChanged | 15 | Not Changed
See Also

Reference

telos.Ird.SBSForum Namespace


Selector.SelectorStatePowerByReadType Enumeration

IRD

SelectorSelectorStatePowerByReadType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SelectorStatePowerByReadType
Public Enumeration SelectorStatePowerByReadType
public enum class SelectorStatePowerByReadType
type SelectorStatePowerByReadType
Members
Member name | Value | Description
SystemIsPoweredByACPower | 0 | System Is Powered By: AC Power
SystemCommunicatesWithAndIsPoweredByBatteryAChargerDisabledUnknown | 1 | System Communicates With And Is Powered By: Battery A ; Charger: Disabled/Unknown
SystemCommunicatesWithAndIsPoweredByBatteryBChargerDisabledUnknown | 2 | System Communicates With And Is Powered By: Battery B ; Charger: Disabled/Unknown
Reserved | 3 | Reserved
SystemCommunicatesWithAndIsPoweredByBatteryCChargerDisabledUnknown | 4 | System Communicates With And Is Powered By: Battery C ; Charger: Disabled/Unknown
Reserved__1 | 5 | Reserved
SystemCommunicatesWithAndIsPoweredByBatteryDChargerEnabled | 7 | System Communicates With And Is Powered By: Battery D ; Charger: Enabled
SystemCommunicatesWithAndIsPoweredByBatteryDChargerDisabledUnknown | 8 | System Communicates With And Is Powered By: Battery D ; Charger: Disabled/Unknown
Reserved__2 | 9 | Reserved
SystemCommunicatesWithAndIsPoweredByBatteryCChargerEnabled | 11 | System Communicates With And Is Powered By: Battery C ; Charger: Enabled
Reserved__3 | 12 | Reserved
SystemCommunicatesWithAndIsPoweredByBatteryBChargerEnabled | 13 | System Communicates With And Is Powered By: Battery B ; Charger: Enabled
SystemCommunicatesWithAndIsPoweredByBatteryAChargerEnabled | 14 | System Communicates With And Is Powered By: Battery A ; Charger: Enabled
SystemIsPoweredByACPowerChargerEnabled | 15 | System Is Powered By: AC Power ; Charger: Enabled
See Also

Reference

telos.Ird.SBSForum Namespace


Selector.SelectorStatePowerByWriteType Enumeration

IRD

SelectorSelectorStatePowerByWriteType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SelectorStatePowerByWriteType
Public Enumeration SelectorStatePowerByWriteType
public enum class SelectorStatePowerByWriteType
type SelectorStatePowerByWriteType
Members
Member name | Value | Description
SystemIsPoweredByACPower | 0 | System Is Powered By: AC Power
SystemCommunicatesWithAndIsPoweredByBatteryAChargerDisabledUnknown | 1 | System Communicates With And Is Powered By: Battery A ; Charger: Disabled/Unknown
SystemCommunicatesWithAndIsPoweredByBatteryBChargerDisabledUnknown | 2 | System Communicates With And Is Powered By: Battery B ; Charger: Disabled/Unknown
Reserved | 3 | Reserved
SystemCommunicatesWithAndIsPoweredByBatteryCChargerDisabledUnknown | 4 | System Communicates With And Is Powered By: Battery C ; Charger: Disabled/Unknown
Reserved__1 | 5 | Reserved
SystemCommunicatesWithAndIsPoweredByBatteryDChargerDisabledUnknown | 8 | System Communicates With And Is Powered By: Battery D ; Charger: Disabled/Unknown
Reserved__2 | 9 | Reserved
NotChanged | 15 | Not Changed
See Also

Reference

telos.Ird.SBSForum Namespace


Selector.SelectorStateSmbReadType Enumeration

IRD

SelectorSelectorStateSmbReadType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SelectorStateSmbReadType
Public Enumeration SelectorStateSmbReadType
public enum class SelectorStateSmbReadType
type SelectorStateSmbReadType
Members
Member name | Value | Description
SMBusHostIsConnectedToNoUnknownBattery | 0 | SMBus Host Is Connected To: No/Unknown Battery
SMBusHostIsConnectedToBatteryA | 1 | SMBus Host Is Connected To: Battery A
SMBusHostIsConnectedToBatteryB | 2 | SMBus Host Is Connected To: Battery B
Reserved | 3 | Reserved
SMBusHostIsConnectedToBatteryC | 4 | SMBus Host Is Connected To: Battery C
Reserved__1 | 5 | Reserved
SMBusHostIsConnectedToBatteryD | 8 | SMBus Host Is Connected To: Battery D
Reserved__2 | 9 | Reserved
See Also

Reference

telos.Ird.SBSForum Namespace


Selector.SelectorStateSmbWriteType Enumeration

IRD

SelectorSelectorStateSmbWriteType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SelectorStateSmbWriteType
Public Enumeration SelectorStateSmbWriteType
public enum class SelectorStateSmbWriteType
type SelectorStateSmbWriteType
Members
Member name | Value | Description
SMBusHostIsConnectedToNoUnknownBattery | 0 | SMBus Host Is Connected To: No/Unknown Battery
SMBusHostIsConnectedToBatteryA | 1 | SMBus Host Is Connected To: Battery A
SMBusHostIsConnectedToBatteryB | 2 | SMBus Host Is Connected To: Battery B
Reserved | 3 | Reserved
SMBusHostIsConnectedToBatteryC | 4 | SMBus Host Is Connected To: Battery C
Reserved__1 | 5 | Reserved
SMBusHostIsConnectedToBatteryD | 8 | SMBus Host Is Connected To: Battery D
Reserved__2 | 9 | Reserved
NotChanged | 15 | Not Changed
See Also

Reference

telos.Ird.SBSForum Namespace


Selector.SupportedType Enumeration

IRD

SelectorSupportedType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SupportedType
Public Enumeration SupportedType
public enum class SupportedType
type SupportedType
Members
Member name | Value | Description
NotSupported | 0 | Not Supported
Supported | 1 | Supported
See Also

Reference

telos.Ird.SBSForum Namespace


Selector.UseNextType Enumeration

IRD

SelectorUseNextType Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum UseNextType
Public Enumeration UseNextType
public enum class UseNextType
type UseNextType
Members
Member name | Value | Description
NextToBeDischargedChoosenBySelector | 0 | Next To Be Discharged: Choosen By Selector
NextToBeDischargedBatteryA | 1 | Next To Be Discharged: Battery A
NextToBeDischargedBatteryB | 2 | Next To Be Discharged: Battery B
Reserved | 3 | Reserved
NextToBeDischargedBatteryC | 4 | Next To Be Discharged: Battery C
Reserved__1 | 5 | Reserved
NextToBeDischargedBatteryD | 8 | Next To Be Discharged: Battery D
Reserved__2 | 9 | Reserved
See Also

Reference

telos.Ird.SBSForum Namespace


SmbusArp Class

SBS Forum: SMBus ARP
Inheritance Hierarchy
SystemObject
telos.Ird.SBSForumSmbusArp

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class SmbusArp
Public Class SmbusArp
public ref class SmbusArp
type SmbusArp =  class end

The SmbusArp type exposes the following members.

Constructors
 | Name | Description
Public method | SmbusArp | Constructor
Top
Properties
 | Name | Description
Public property | AssignAddressSlaveAddress | Assign Address: Slave Address
Public property | AssignAddressUDID | Assign Address: UDID
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | GetUDIDDirected0x03SlaveAddress | Get UDID (Directed: 0x03): Slave Address
Public property | GetUDIDDirected0x03UDID | Get UDID (Directed: 0x03): UDID
Public property | GetUDIDDirected0x04SlaveAddress | Get UDID (Directed: 0x04): Slave Address
Public property | GetUDIDDirected0x04UDID | Get UDID (Directed: 0x04): UDID
Public property | GetUDIDDirected0x05SlaveAddress | Get UDID (Directed: 0x05): Slave Address
Public property | GetUDIDDirected0x05UDID | Get UDID (Directed: 0x05): UDID
Public property | GetUDIDDirected0x06SlaveAddress | Get UDID (Directed: 0x06): Slave Address
Public property | GetUDIDDirected0x06UDID | Get UDID (Directed: 0x06): UDID
Public property | GetUDIDDirected0x07SlaveAddress | Get UDID (Directed: 0x07): Slave Address
Public property | GetUDIDDirected0x07UDID | Get UDID (Directed: 0x07): UDID
Public property | GetUDIDDirected0x08SlaveAddress | Get UDID (Directed: 0x08): Slave Address
Public property | GetUDIDDirected0x08UDID | Get UDID (Directed: 0x08): UDID
Public property | GetUDIDDirected0x09SlaveAddress | Get UDID (Directed: 0x09): Slave Address
Public property | GetUDIDDirected0x09UDID | Get UDID (Directed: 0x09): UDID
Public property | GetUDIDDirected0x0aSlaveAddress | Get UDID (Directed: 0x0a): Slave Address
Public property | GetUDIDDirected0x0aUDID | Get UDID (Directed: 0x0a): UDID
Public property | GetUDIDDirected0x0bSlaveAddress | Get UDID (Directed: 0x0b): Slave Address
Public property | GetUDIDDirected0x0bUDID | Get UDID (Directed: 0x0b): UDID
Public property | GetUDIDDirected0x0cSlaveAddress | Get UDID (Directed: 0x0c): Slave Address
Public property | GetUDIDDirected0x0cUDID | Get UDID (Directed: 0x0c): UDID
Public property | GetUDIDDirected0x0dSlaveAddress | Get UDID (Directed: 0x0d): Slave Address
Public property | GetUDIDDirected0x0dUDID | Get UDID (Directed: 0x0d): UDID
Public property | GetUDIDDirected0x0eSlaveAddress | Get UDID (Directed: 0x0e): Slave Address
Public property | GetUDIDDirected0x0eUDID | Get UDID (Directed: 0x0e): UDID
Public property | GetUDIDDirected0x0fSlaveAddress | Get UDID (Directed: 0x0f): Slave Address
Public property | GetUDIDDirected0x0fUDID | Get UDID (Directed: 0x0f): UDID
Public property | GetUDIDDirected0x10SlaveAddress | Get UDID (Directed: 0x10): Slave Address
Public property | GetUDIDDirected0x10UDID | Get UDID (Directed: 0x10): UDID
Public property | GetUDIDDirected0x11SlaveAddress | Get UDID (Directed: 0x11): Slave Address
Public property | GetUDIDDirected0x11UDID | Get UDID (Directed: 0x11): UDID
Public property | GetUDIDDirected0x12SlaveAddress | Get UDID (Directed: 0x12): Slave Address
Public property | GetUDIDDirected0x12UDID | Get UDID (Directed: 0x12): UDID
Public property | GetUDIDDirected0x13SlaveAddress | Get UDID (Directed: 0x13): Slave Address
Public property | GetUDIDDirected0x13UDID | Get UDID (Directed: 0x13): UDID
Public property | GetUDIDDirected0x14SlaveAddress | Get UDID (Directed: 0x14): Slave Address
Public property | GetUDIDDirected0x14UDID | Get UDID (Directed: 0x14): UDID
Public property | GetUDIDDirected0x15SlaveAddress | Get UDID (Directed: 0x15): Slave Address
Public property | GetUDIDDirected0x15UDID | Get UDID (Directed: 0x15): UDID
Public property | GetUDIDDirected0x16SlaveAddress | Get UDID (Directed: 0x16): Slave Address
Public property | GetUDIDDirected0x16UDID | Get UDID (Directed: 0x16): UDID
Public property | GetUDIDDirected0x17SlaveAddress | Get UDID (Directed: 0x17): Slave Address
Public property | GetUDIDDirected0x17UDID | Get UDID (Directed: 0x17): UDID
Public property | GetUDIDDirected0x18SlaveAddress | Get UDID (Directed: 0x18): Slave Address
Public property | GetUDIDDirected0x18UDID | Get UDID (Directed: 0x18): UDID
Public property | GetUDIDDirected0x19SlaveAddress | Get UDID (Directed: 0x19): Slave Address
Public property | GetUDIDDirected0x19UDID | Get UDID (Directed: 0x19): UDID
Public property | GetUDIDDirected0x1aSlaveAddress | Get UDID (Directed: 0x1a): Slave Address
Public property | GetUDIDDirected0x1aUDID | Get UDID (Directed: 0x1a): UDID
Public property | GetUDIDDirected0x1bSlaveAddress | Get UDID (Directed: 0x1b): Slave Address
Public property | GetUDIDDirected0x1bUDID | Get UDID (Directed: 0x1b): UDID
Public property | GetUDIDDirected0x1cSlaveAddress | Get UDID (Directed: 0x1c): Slave Address
Public property | GetUDIDDirected0x1cUDID | Get UDID (Directed: 0x1c): UDID
Public property | GetUDIDDirected0x1dSlaveAddress | Get UDID (Directed: 0x1d): Slave Address
Public property | GetUDIDDirected0x1dUDID | Get UDID (Directed: 0x1d): UDID
Public property | GetUDIDDirected0x1eSlaveAddress | Get UDID (Directed: 0x1e): Slave Address
Public property | GetUDIDDirected0x1eUDID | Get UDID (Directed: 0x1e): UDID
Public property | GetUDIDDirected0x1fSlaveAddress | Get UDID (Directed: 0x1f): Slave Address
Public property | GetUDIDDirected0x1fUDID | Get UDID (Directed: 0x1f): UDID
Public property | GetUDIDDirected0x20SlaveAddress | Get UDID (Directed: 0x20): Slave Address
Public property | GetUDIDDirected0x20UDID | Get UDID (Directed: 0x20): UDID
Public property | GetUDIDDirected0x21SlaveAddress | Get UDID (Directed: 0x21): Slave Address
Public property | GetUDIDDirected0x21UDID | Get UDID (Directed: 0x21): UDID
Public property | GetUDIDDirected0x22SlaveAddress | Get UDID (Directed: 0x22): Slave Address
Public property | GetUDIDDirected0x22UDID | Get UDID (Directed: 0x22): UDID
Public property | GetUDIDDirected0x23SlaveAddress | Get UDID (Directed: 0x23): Slave Address
Public property | GetUDIDDirected0x23UDID | Get UDID (Directed: 0x23): UDID
Public property | GetUDIDDirected0x24SlaveAddress | Get UDID (Directed: 0x24): Slave Address
Public property | GetUDIDDirected0x24UDID | Get UDID (Directed: 0x24): UDID
Public property | GetUDIDDirected0x25SlaveAddress | Get UDID (Directed: 0x25): Slave Address
Public property | GetUDIDDirected0x25UDID | Get UDID (Directed: 0x25): UDID
Public property | GetUDIDDirected0x26SlaveAddress | Get UDID (Directed: 0x26): Slave Address
Public property | GetUDIDDirected0x26UDID | Get UDID (Directed: 0x26): UDID
Public property | GetUDIDDirected0x27SlaveAddress | Get UDID (Directed: 0x27): Slave Address
Public property | GetUDIDDirected0x27UDID | Get UDID (Directed: 0x27): UDID
Public property | GetUDIDDirected0x28SlaveAddress | Get UDID (Directed: 0x28): Slave Address
Public property | GetUDIDDirected0x28UDID | Get UDID (Directed: 0x28): UDID
Public property | GetUDIDDirected0x29SlaveAddress | Get UDID (Directed: 0x29): Slave Address
Public property | GetUDIDDirected0x29UDID | Get UDID (Directed: 0x29): UDID
Public property | GetUDIDDirected0x2aSlaveAddress | Get UDID (Directed: 0x2a): Slave Address
Public property | GetUDIDDirected0x2aUDID | Get UDID (Directed: 0x2a): UDID
Public property | GetUDIDDirected0x2bSlaveAddress | Get UDID (Directed: 0x2b): Slave Address
Public property | GetUDIDDirected0x2bUDID | Get UDID (Directed: 0x2b): UDID
Public property | GetUDIDDirected0x2cSlaveAddress | Get UDID (Directed: 0x2c): Slave Address
Public property | GetUDIDDirected0x2cUDID | Get UDID (Directed: 0x2c): UDID
Public property | GetUDIDDirected0x2dSlaveAddress | Get UDID (Directed: 0x2d): Slave Address
Public property | GetUDIDDirected0x2dUDID | Get UDID (Directed: 0x2d): UDID
Public property | GetUDIDDirected0x2eSlaveAddress | Get UDID (Directed: 0x2e): Slave Address
Public property | GetUDIDDirected0x2eUDID | Get UDID (Directed: 0x2e): UDID
Public property | GetUDIDDirected0x2fSlaveAddress | Get UDID (Directed: 0x2f): Slave Address
Public property | GetUDIDDirected0x2fUDID | Get UDID (Directed: 0x2f): UDID
Public property | GetUDIDDirected0x30SlaveAddress | Get UDID (Directed: 0x30): Slave Address
Public property | GetUDIDDirected0x30UDID | Get UDID (Directed: 0x30): UDID
Public property | GetUDIDDirected0x31SlaveAddress | Get UDID (Directed: 0x31): Slave Address
Public property | GetUDIDDirected0x31UDID | Get UDID (Directed: 0x31): UDID
Public property | GetUDIDDirected0x32SlaveAddress | Get UDID (Directed: 0x32): Slave Address
Public property | GetUDIDDirected0x32UDID | Get UDID (Directed: 0x32): UDID
Public property | GetUDIDDirected0x33SlaveAddress | Get UDID (Directed: 0x33): Slave Address
Public property | GetUDIDDirected0x33UDID | Get UDID (Directed: 0x33): UDID
Public property | GetUDIDDirected0x34SlaveAddress | Get UDID (Directed: 0x34): Slave Address
Public property | GetUDIDDirected0x34UDID | Get UDID (Directed: 0x34): UDID
Public property | GetUDIDDirected0x35SlaveAddress | Get UDID (Directed: 0x35): Slave Address
Public property | GetUDIDDirected0x35UDID | Get UDID (Directed: 0x35): UDID
Public property | GetUDIDDirected0x36SlaveAddress | Get UDID (Directed: 0x36): Slave Address
Public property | GetUDIDDirected0x36UDID | Get UDID (Directed: 0x36): UDID
Public property | GetUDIDDirected0x37SlaveAddress | Get UDID (Directed: 0x37): Slave Address
Public property | GetUDIDDirected0x37UDID | Get UDID (Directed: 0x37): UDID
Public property | GetUDIDDirected0x38SlaveAddress | Get UDID (Directed: 0x38): Slave Address
Public property | GetUDIDDirected0x38UDID | Get UDID (Directed: 0x38): UDID
Public property | GetUDIDDirected0x39SlaveAddress | Get UDID (Directed: 0x39): Slave Address
Public property | GetUDIDDirected0x39UDID | Get UDID (Directed: 0x39): UDID
Public property | GetUDIDDirected0x3aSlaveAddress | Get UDID (Directed: 0x3a): Slave Address
Public property | GetUDIDDirected0x3aUDID | Get UDID (Directed: 0x3a): UDID
Public property | GetUDIDDirected0x3bSlaveAddress | Get UDID (Directed: 0x3b): Slave Address
Public property | GetUDIDDirected0x3bUDID | Get UDID (Directed: 0x3b): UDID
Public property | GetUDIDDirected0x3cSlaveAddress | Get UDID (Directed: 0x3c): Slave Address
Public property | GetUDIDDirected0x3cUDID | Get UDID (Directed: 0x3c): UDID
Public property | GetUDIDDirected0x3dSlaveAddress | Get UDID (Directed: 0x3d): Slave Address
Public property | GetUDIDDirected0x3dUDID | Get UDID (Directed: 0x3d): UDID
Public property | GetUDIDDirected0x3eSlaveAddress | Get UDID (Directed: 0x3e): Slave Address
Public property | GetUDIDDirected0x3eUDID | Get UDID (Directed: 0x3e): UDID
Public property | GetUDIDDirected0x3fSlaveAddress | Get UDID (Directed: 0x3f): Slave Address
Public property | GetUDIDDirected0x3fUDID | Get UDID (Directed: 0x3f): UDID
Public property | GetUDIDDirected0x40SlaveAddress | Get UDID (Directed: 0x40): Slave Address
Public property | GetUDIDDirected0x40UDID | Get UDID (Directed: 0x40): UDID
Public property | GetUDIDDirected0x41SlaveAddress | Get UDID (Directed: 0x41): Slave Address
Public property | GetUDIDDirected0x41UDID | Get UDID (Directed: 0x41): UDID
Public property | GetUDIDDirected0x42SlaveAddress | Get UDID (Directed: 0x42): Slave Address
Public property | GetUDIDDirected0x42UDID | Get UDID (Directed: 0x42): UDID
Public property | GetUDIDDirected0x43SlaveAddress | Get UDID (Directed: 0x43): Slave Address
Public property | GetUDIDDirected0x43UDID | Get UDID (Directed: 0x43): UDID
Public property | GetUDIDDirected0x44SlaveAddress | Get UDID (Directed: 0x44): Slave Address
Public property | GetUDIDDirected0x44UDID | Get UDID (Directed: 0x44): UDID
Public property | GetUDIDDirected0x45SlaveAddress | Get UDID (Directed: 0x45): Slave Address
Public property | GetUDIDDirected0x45UDID | Get UDID (Directed: 0x45): UDID
Public property | GetUDIDDirected0x46SlaveAddress | Get UDID (Directed: 0x46): Slave Address
Public property | GetUDIDDirected0x46UDID | Get UDID (Directed: 0x46): UDID
Public property | GetUDIDDirected0x47SlaveAddress | Get UDID (Directed: 0x47): Slave Address
Public property | GetUDIDDirected0x47UDID | Get UDID (Directed: 0x47): UDID
Public property | GetUDIDDirected0x48SlaveAddress | Get UDID (Directed: 0x48): Slave Address
Public property | GetUDIDDirected0x48UDID | Get UDID (Directed: 0x48): UDID
Public property | GetUDIDDirected0x49SlaveAddress | Get UDID (Directed: 0x49): Slave Address
Public property | GetUDIDDirected0x49UDID | Get UDID (Directed: 0x49): UDID
Public property | GetUDIDDirected0x4aSlaveAddress | Get UDID (Directed: 0x4a): Slave Address
Public property | GetUDIDDirected0x4aUDID | Get UDID (Directed: 0x4a): UDID
Public property | GetUDIDDirected0x4bSlaveAddress | Get UDID (Directed: 0x4b): Slave Address
Public property | GetUDIDDirected0x4bUDID | Get UDID (Directed: 0x4b): UDID
Public property | GetUDIDDirected0x4cSlaveAddress | Get UDID (Directed: 0x4c): Slave Address
Public property | GetUDIDDirected0x4cUDID | Get UDID (Directed: 0x4c): UDID
Public property | GetUDIDDirected0x4dSlaveAddress | Get UDID (Directed: 0x4d): Slave Address
Public property | GetUDIDDirected0x4dUDID | Get UDID (Directed: 0x4d): UDID
Public property | GetUDIDDirected0x4eSlaveAddress | Get UDID (Directed: 0x4e): Slave Address
Public property | GetUDIDDirected0x4eUDID | Get UDID (Directed: 0x4e): UDID
Public property | GetUDIDDirected0x4fSlaveAddress | Get UDID (Directed: 0x4f): Slave Address
Public property | GetUDIDDirected0x4fUDID | Get UDID (Directed: 0x4f): UDID
Public property | GetUDIDDirected0x50SlaveAddress | Get UDID (Directed: 0x50): Slave Address
Public property | GetUDIDDirected0x50UDID | Get UDID (Directed: 0x50): UDID
Public property | GetUDIDDirected0x51SlaveAddress | Get UDID (Directed: 0x51): Slave Address
Public property | GetUDIDDirected0x51UDID | Get UDID (Directed: 0x51): UDID
Public property | GetUDIDDirected0x52SlaveAddress | Get UDID (Directed: 0x52): Slave Address
Public property | GetUDIDDirected0x52UDID | Get UDID (Directed: 0x52): UDID
Public property | GetUDIDDirected0x53SlaveAddress | Get UDID (Directed: 0x53): Slave Address
Public property | GetUDIDDirected0x53UDID | Get UDID (Directed: 0x53): UDID
Public property | GetUDIDDirected0x54SlaveAddress | Get UDID (Directed: 0x54): Slave Address
Public property | GetUDIDDirected0x54UDID | Get UDID (Directed: 0x54): UDID
Public property | GetUDIDDirected0x55SlaveAddress | Get UDID (Directed: 0x55): Slave Address
Public property | GetUDIDDirected0x55UDID | Get UDID (Directed: 0x55): UDID
Public property | GetUDIDDirected0x56SlaveAddress | Get UDID (Directed: 0x56): Slave Address
Public property | GetUDIDDirected0x56UDID | Get UDID (Directed: 0x56): UDID
Public property | GetUDIDDirected0x57SlaveAddress | Get UDID (Directed: 0x57): Slave Address
Public property | GetUDIDDirected0x57UDID | Get UDID (Directed: 0x57): UDID
Public property | GetUDIDDirected0x58SlaveAddress | Get UDID (Directed: 0x58): Slave Address
Public property | GetUDIDDirected0x58UDID | Get UDID (Directed: 0x58): UDID
Public property | GetUDIDDirected0x59SlaveAddress | Get UDID (Directed: 0x59): Slave Address
Public property | GetUDIDDirected0x59UDID | Get UDID (Directed: 0x59): UDID
Public property | GetUDIDDirected0x5aSlaveAddress | Get UDID (Directed: 0x5a): Slave Address
Public property | GetUDIDDirected0x5aUDID | Get UDID (Directed: 0x5a): UDID
Public property | GetUDIDDirected0x5bSlaveAddress | Get UDID (Directed: 0x5b): Slave Address
Public property | GetUDIDDirected0x5bUDID | Get UDID (Directed: 0x5b): UDID
Public property | GetUDIDDirected0x5cSlaveAddress | Get UDID (Directed: 0x5c): Slave Address
Public property | GetUDIDDirected0x5cUDID | Get UDID (Directed: 0x5c): UDID
Public property | GetUDIDDirected0x5dSlaveAddress | Get UDID (Directed: 0x5d): Slave Address
Public property | GetUDIDDirected0x5dUDID | Get UDID (Directed: 0x5d): UDID
Public property | GetUDIDDirected0x5eSlaveAddress | Get UDID (Directed: 0x5e): Slave Address
Public property | GetUDIDDirected0x5eUDID | Get UDID (Directed: 0x5e): UDID
Public property | GetUDIDDirected0x5fSlaveAddress | Get UDID (Directed: 0x5f): Slave Address
Public property | GetUDIDDirected0x5fUDID | Get UDID (Directed: 0x5f): UDID
Public property | GetUDIDDirected0x60SlaveAddress | Get UDID (Directed: 0x60): Slave Address
Public property | GetUDIDDirected0x60UDID | Get UDID (Directed: 0x60): UDID
Public property | GetUDIDDirected0x61SlaveAddress | Get UDID (Directed: 0x61): Slave Address
Public property | GetUDIDDirected0x61UDID | Get UDID (Directed: 0x61): UDID
Public property | GetUDIDDirected0x62SlaveAddress | Get UDID (Directed: 0x62): Slave Address
Public property | GetUDIDDirected0x62UDID | Get UDID (Directed: 0x62): UDID
Public property | GetUDIDDirected0x63SlaveAddress | Get UDID (Directed: 0x63): Slave Address
Public property | GetUDIDDirected0x63UDID | Get UDID (Directed: 0x63): UDID
Public property | GetUDIDDirected0x64SlaveAddress | Get UDID (Directed: 0x64): Slave Address
Public property | GetUDIDDirected0x64UDID | Get UDID (Directed: 0x64): UDID
Public property | GetUDIDDirected0x65SlaveAddress | Get UDID (Directed: 0x65): Slave Address
Public property | GetUDIDDirected0x65UDID | Get UDID (Directed: 0x65): UDID
Public property | GetUDIDDirected0x66SlaveAddress | Get UDID (Directed: 0x66): Slave Address
Public property | GetUDIDDirected0x66UDID | Get UDID (Directed: 0x66): UDID
Public property | GetUDIDDirected0x67SlaveAddress | Get UDID (Directed: 0x67): Slave Address
Public property | GetUDIDDirected0x67UDID | Get UDID (Directed: 0x67): UDID
Public property | GetUDIDDirected0x68SlaveAddress | Get UDID (Directed: 0x68): Slave Address
Public property | GetUDIDDirected0x68UDID | Get UDID (Directed: 0x68): UDID
Public property | GetUDIDDirected0x69SlaveAddress | Get UDID (Directed: 0x69): Slave Address
Public property | GetUDIDDirected0x69UDID | Get UDID (Directed: 0x69): UDID
Public property | GetUDIDDirected0x6aSlaveAddress | Get UDID (Directed: 0x6a): Slave Address
Public property | GetUDIDDirected0x6aUDID | Get UDID (Directed: 0x6a): UDID
Public property | GetUDIDDirected0x6bSlaveAddress | Get UDID (Directed: 0x6b): Slave Address
Public property | GetUDIDDirected0x6bUDID | Get UDID (Directed: 0x6b): UDID
Public property | GetUDIDDirected0x6cSlaveAddress | Get UDID (Directed: 0x6c): Slave Address
Public property | GetUDIDDirected0x6cUDID | Get UDID (Directed: 0x6c): UDID
Public property | GetUDIDDirected0x6dSlaveAddress | Get UDID (Directed: 0x6d): Slave Address
Public property | GetUDIDDirected0x6dUDID | Get UDID (Directed: 0x6d): UDID
Public property | GetUDIDDirected0x6eSlaveAddress | Get UDID (Directed: 0x6e): Slave Address
Public property | GetUDIDDirected0x6eUDID | Get UDID (Directed: 0x6e): UDID
Public property | GetUDIDDirected0x6fSlaveAddress | Get UDID (Directed: 0x6f): Slave Address
Public property | GetUDIDDirected0x6fUDID | Get UDID (Directed: 0x6f): UDID
Public property | GetUDIDDirected0x70SlaveAddress | Get UDID (Directed: 0x70): Slave Address
Public property | GetUDIDDirected0x70UDID | Get UDID (Directed: 0x70): UDID
Public property | GetUDIDDirected0x71SlaveAddress | Get UDID (Directed: 0x71): Slave Address
Public property | GetUDIDDirected0x71UDID | Get UDID (Directed: 0x71): UDID
Public property | GetUDIDDirected0x72SlaveAddress | Get UDID (Directed: 0x72): Slave Address
Public property | GetUDIDDirected0x72UDID | Get UDID (Directed: 0x72): UDID
Public property | GetUDIDDirected0x73SlaveAddress | Get UDID (Directed: 0x73): Slave Address
Public property | GetUDIDDirected0x73UDID | Get UDID (Directed: 0x73): UDID
Public property | GetUDIDDirected0x74SlaveAddress | Get UDID (Directed: 0x74): Slave Address
Public property | GetUDIDDirected0x74UDID | Get UDID (Directed: 0x74): UDID
Public property | GetUDIDDirected0x75SlaveAddress | Get UDID (Directed: 0x75): Slave Address
Public property | GetUDIDDirected0x75UDID | Get UDID (Directed: 0x75): UDID
Public property | GetUDIDDirected0x76SlaveAddress | Get UDID (Directed: 0x76): Slave Address
Public property | GetUDIDDirected0x76UDID | Get UDID (Directed: 0x76): UDID
Public property | GetUDIDDirected0x77SlaveAddress | Get UDID (Directed: 0x77): Slave Address
Public property | GetUDIDDirected0x77UDID | Get UDID (Directed: 0x77): UDID
Public property | GetUDIDDirected0x78SlaveAddress | Get UDID (Directed: 0x78): Slave Address
Public property | GetUDIDDirected0x78UDID | Get UDID (Directed: 0x78): UDID
Public property | GetUDIDDirected0x79SlaveAddress | Get UDID (Directed: 0x79): Slave Address
Public property | GetUDIDDirected0x79UDID | Get UDID (Directed: 0x79): UDID
Public property | GetUDIDDirected0x7aSlaveAddress | Get UDID (Directed: 0x7a): Slave Address
Public property | GetUDIDDirected0x7aUDID | Get UDID (Directed: 0x7a): UDID
Public property | GetUDIDDirected0x7bSlaveAddress | Get UDID (Directed: 0x7b): Slave Address
Public property | GetUDIDDirected0x7bUDID | Get UDID (Directed: 0x7b): UDID
Public property | GetUDIDDirected0x7cSlaveAddress | Get UDID (Directed: 0x7c): Slave Address
Public property | GetUDIDDirected0x7cUDID | Get UDID (Directed: 0x7c): UDID
Public property | GetUDIDDirected0x7dSlaveAddress | Get UDID (Directed: 0x7d): Slave Address
Public property | GetUDIDDirected0x7dUDID | Get UDID (Directed: 0x7d): UDID
Public property | GetUDIDDirected0x7eSlaveAddress | Get UDID (Directed: 0x7e): Slave Address
Public property | GetUDIDDirected0x7eUDID | Get UDID (Directed: 0x7e): UDID
Public property | GetUDIDDirected0x7fSlaveAddress | Get UDID (Directed: 0x7f): Slave Address
Public property | GetUDIDDirected0x7fUDID | Get UDID (Directed: 0x7f): UDID
Public property | GetUDIDGeneralAddressType | Get UDID (General): Address Type
Public property | GetUDIDGeneralDeviceID | Get UDID (General): Device ID
Public property | GetUDIDGeneralPEC | Get UDID (General): PEC
Public property | GetUDIDGeneralSiliconRevisionID | Get UDID (General): Silicon Revision ID
Public property | GetUDIDGeneralSlaveAddress | Get UDID (General): Slave Address
Public property | GetUDIDGeneralSMBusVersion | Get UDID (General): SMBus Version
Public property | GetUDIDGeneralSubsystemDeviceID | Get UDID (General): Subsystem Device ID
Public property | GetUDIDGeneralSubsystemVendorID | Get UDID (General): Subsystem Vendor ID
Public property | GetUDIDGeneralSupportedProtocolsASF | Get UDID (General): Supported Protocols: ASF
Public property | GetUDIDGeneralSupportedProtocolsIPMI | Get UDID (General): Supported Protocols: IPMI
Public property | GetUDIDGeneralSupportedProtocolsOEM | Get UDID (General): Supported Protocols: OEM
Public property | GetUDIDGeneralSupportedProtocolsZONE | Get UDID (General): Supported Protocols: ZONE
Public property | GetUDIDGeneralUDIDVersion | Get UDID (General): UDID Version
Public property | GetUDIDGeneralVendorID | Get UDID (General): Vendor ID
Public property | GetUDIDGeneralVendorSpecificID | Get UDID (General): Vendor Specific ID
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareARP | Prepare ARP
Public method | ResetDeviceDirected0x03 | Reset Device (Directed: 0x03)
Public method | ResetDeviceDirected0x04 | Reset Device (Directed: 0x04)
Public method | ResetDeviceDirected0x05 | Reset Device (Directed: 0x05)
Public method | ResetDeviceDirected0x06 | Reset Device (Directed: 0x06)
Public method | ResetDeviceDirected0x07 | Reset Device (Directed: 0x07)
Public method | ResetDeviceDirected0x08 | Reset Device (Directed: 0x08)
Public method | ResetDeviceDirected0x09 | Reset Device (Directed: 0x09)
Public method | ResetDeviceDirected0x0a | Reset Device (Directed: 0x0a)
Public method | ResetDeviceDirected0x0b | Reset Device (Directed: 0x0b)
Public method | ResetDeviceDirected0x0c | Reset Device (Directed: 0x0c)
Public method | ResetDeviceDirected0x0d | Reset Device (Directed: 0x0d)
Public method | ResetDeviceDirected0x0e | Reset Device (Directed: 0x0e)
Public method | ResetDeviceDirected0x0f | Reset Device (Directed: 0x0f)
Public method | ResetDeviceDirected0x10 | Reset Device (Directed: 0x10)
Public method | ResetDeviceDirected0x11 | Reset Device (Directed: 0x11)
Public method | ResetDeviceDirected0x12 | Reset Device (Directed: 0x12)
Public method | ResetDeviceDirected0x13 | Reset Device (Directed: 0x13)
Public method | ResetDeviceDirected0x14 | Reset Device (Directed: 0x14)
Public method | ResetDeviceDirected0x15 | Reset Device (Directed: 0x15)
Public method | ResetDeviceDirected0x16 | Reset Device (Directed: 0x16)
Public method | ResetDeviceDirected0x17 | Reset Device (Directed: 0x17)
Public method | ResetDeviceDirected0x18 | Reset Device (Directed: 0x18)
Public method | ResetDeviceDirected0x19 | Reset Device (Directed: 0x19)
Public method | ResetDeviceDirected0x1a | Reset Device (Directed: 0x1a)
Public method | ResetDeviceDirected0x1b | Reset Device (Directed: 0x1b)
Public method | ResetDeviceDirected0x1c | Reset Device (Directed: 0x1c)
Public method | ResetDeviceDirected0x1d | Reset Device (Directed: 0x1d)
Public method | ResetDeviceDirected0x1e | Reset Device (Directed: 0x1e)
Public method | ResetDeviceDirected0x1f | Reset Device (Directed: 0x1f)
Public method | ResetDeviceDirected0x20 | Reset Device (Directed: 0x20)
Public method | ResetDeviceDirected0x21 | Reset Device (Directed: 0x21)
Public method | ResetDeviceDirected0x22 | Reset Device (Directed: 0x22)
Public method | ResetDeviceDirected0x23 | Reset Device (Directed: 0x23)
Public method | ResetDeviceDirected0x24 | Reset Device (Directed: 0x24)
Public method | ResetDeviceDirected0x25 | Reset Device (Directed: 0x25)
Public method | ResetDeviceDirected0x26 | Reset Device (Directed: 0x26)
Public method | ResetDeviceDirected0x27 | Reset Device (Directed: 0x27)
Public method | ResetDeviceDirected0x28 | Reset Device (Directed: 0x28)
Public method | ResetDeviceDirected0x29 | Reset Device (Directed: 0x29)
Public method | ResetDeviceDirected0x2a | Reset Device (Directed: 0x2a)
Public method | ResetDeviceDirected0x2b | Reset Device (Directed: 0x2b)
Public method | ResetDeviceDirected0x2c | Reset Device (Directed: 0x2c)
Public method | ResetDeviceDirected0x2d | Reset Device (Directed: 0x2d)
Public method | ResetDeviceDirected0x2e | Reset Device (Directed: 0x2e)
Public method | ResetDeviceDirected0x2f | Reset Device (Directed: 0x2f)
Public method | ResetDeviceDirected0x30 | Reset Device (Directed: 0x30)
Public method | ResetDeviceDirected0x31 | Reset Device (Directed: 0x31)
Public method | ResetDeviceDirected0x32 | Reset Device (Directed: 0x32)
Public method | ResetDeviceDirected0x33 | Reset Device (Directed: 0x33)
Public method | ResetDeviceDirected0x34 | Reset Device (Directed: 0x34)
Public method | ResetDeviceDirected0x35 | Reset Device (Directed: 0x35)
Public method | ResetDeviceDirected0x36 | Reset Device (Directed: 0x36)
Public method | ResetDeviceDirected0x37 | Reset Device (Directed: 0x37)
Public method | ResetDeviceDirected0x38 | Reset Device (Directed: 0x38)
Public method | ResetDeviceDirected0x39 | Reset Device (Directed: 0x39)
Public method | ResetDeviceDirected0x3a | Reset Device (Directed: 0x3a)
Public method | ResetDeviceDirected0x3b | Reset Device (Directed: 0x3b)
Public method | ResetDeviceDirected0x3c | Reset Device (Directed: 0x3c)
Public method | ResetDeviceDirected0x3d | Reset Device (Directed: 0x3d)
Public method | ResetDeviceDirected0x3e | Reset Device (Directed: 0x3e)
Public method | ResetDeviceDirected0x3f | Reset Device (Directed: 0x3f)
Public method | ResetDeviceDirected0x40 | Reset Device (Directed: 0x40)
Public method | ResetDeviceDirected0x41 | Reset Device (Directed: 0x41)
Public method | ResetDeviceDirected0x42 | Reset Device (Directed: 0x42)
Public method | ResetDeviceDirected0x43 | Reset Device (Directed: 0x43)
Public method | ResetDeviceDirected0x44 | Reset Device (Directed: 0x44)
Public method | ResetDeviceDirected0x45 | Reset Device (Directed: 0x45)
Public method | ResetDeviceDirected0x46 | Reset Device (Directed: 0x46)
Public method | ResetDeviceDirected0x47 | Reset Device (Directed: 0x47)
Public method | ResetDeviceDirected0x48 | Reset Device (Directed: 0x48)
Public method | ResetDeviceDirected0x49 | Reset Device (Directed: 0x49)
Public method | ResetDeviceDirected0x4a | Reset Device (Directed: 0x4a)
Public method | ResetDeviceDirected0x4b | Reset Device (Directed: 0x4b)
Public method | ResetDeviceDirected0x4c | Reset Device (Directed: 0x4c)
Public method | ResetDeviceDirected0x4d | Reset Device (Directed: 0x4d)
Public method | ResetDeviceDirected0x4e | Reset Device (Directed: 0x4e)
Public method | ResetDeviceDirected0x4f | Reset Device (Directed: 0x4f)
Public method | ResetDeviceDirected0x50 | Reset Device (Directed: 0x50)
Public method | ResetDeviceDirected0x51 | Reset Device (Directed: 0x51)
Public method | ResetDeviceDirected0x52 | Reset Device (Directed: 0x52)
Public method | ResetDeviceDirected0x53 | Reset Device (Directed: 0x53)
Public method | ResetDeviceDirected0x54 | Reset Device (Directed: 0x54)
Public method | ResetDeviceDirected0x55 | Reset Device (Directed: 0x55)
Public method | ResetDeviceDirected0x56 | Reset Device (Directed: 0x56)
Public method | ResetDeviceDirected0x57 | Reset Device (Directed: 0x57)
Public method | ResetDeviceDirected0x58 | Reset Device (Directed: 0x58)
Public method | ResetDeviceDirected0x59 | Reset Device (Directed: 0x59)
Public method | ResetDeviceDirected0x5a | Reset Device (Directed: 0x5a)
Public method | ResetDeviceDirected0x5b | Reset Device (Directed: 0x5b)
Public method | ResetDeviceDirected0x5c | Reset Device (Directed: 0x5c)
Public method | ResetDeviceDirected0x5d | Reset Device (Directed: 0x5d)
Public method | ResetDeviceDirected0x5e | Reset Device (Directed: 0x5e)
Public method | ResetDeviceDirected0x5f | Reset Device (Directed: 0x5f)
Public method | ResetDeviceDirected0x60 | Reset Device (Directed: 0x60)
Public method | ResetDeviceDirected0x61 | Reset Device (Directed: 0x61)
Public method | ResetDeviceDirected0x62 | Reset Device (Directed: 0x62)
Public method | ResetDeviceDirected0x63 | Reset Device (Directed: 0x63)
Public method | ResetDeviceDirected0x64 | Reset Device (Directed: 0x64)
Public method | ResetDeviceDirected0x65 | Reset Device (Directed: 0x65)
Public method | ResetDeviceDirected0x66 | Reset Device (Directed: 0x66)
Public method | ResetDeviceDirected0x67 | Reset Device (Directed: 0x67)
Public method | ResetDeviceDirected0x68 | Reset Device (Directed: 0x68)
Public method | ResetDeviceDirected0x69 | Reset Device (Directed: 0x69)
Public method | ResetDeviceDirected0x6a | Reset Device (Directed: 0x6a)
Public method | ResetDeviceDirected0x6b | Reset Device (Directed: 0x6b)
Public method | ResetDeviceDirected0x6c | Reset Device (Directed: 0x6c)
Public method | ResetDeviceDirected0x6d | Reset Device (Directed: 0x6d)
Public method | ResetDeviceDirected0x6e | Reset Device (Directed: 0x6e)
Public method | ResetDeviceDirected0x6f | Reset Device (Directed: 0x6f)
Public method | ResetDeviceDirected0x70 | Reset Device (Directed: 0x70)
Public method | ResetDeviceDirected0x71 | Reset Device (Directed: 0x71)
Public method | ResetDeviceDirected0x72 | Reset Device (Directed: 0x72)
Public method | ResetDeviceDirected0x73 | Reset Device (Directed: 0x73)
Public method | ResetDeviceDirected0x74 | Reset Device (Directed: 0x74)
Public method | ResetDeviceDirected0x75 | Reset Device (Directed: 0x75)
Public method | ResetDeviceDirected0x76 | Reset Device (Directed: 0x76)
Public method | ResetDeviceDirected0x77 | Reset Device (Directed: 0x77)
Public method | ResetDeviceDirected0x78 | Reset Device (Directed: 0x78)
Public method | ResetDeviceDirected0x79 | Reset Device (Directed: 0x79)
Public method | ResetDeviceDirected0x7a | Reset Device (Directed: 0x7a)
Public method | ResetDeviceDirected0x7b | Reset Device (Directed: 0x7b)
Public method | ResetDeviceDirected0x7c | Reset Device (Directed: 0x7c)
Public method | ResetDeviceDirected0x7d | Reset Device (Directed: 0x7d)
Public method | ResetDeviceDirected0x7e | Reset Device (Directed: 0x7e)
Public method | ResetDeviceDirected0x7f | Reset Device (Directed: 0x7f)
Public method | ResetDeviceGeneral | Reset Device (General)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
SMBus 3.0 - Address Resolution Protocol
See Also

Reference

telos.Ird.SBSForum Namespace


SmbusArp Constructor

Constructor

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SmbusArp(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
SmbusArp(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> SmbusArp

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp Properties

The SmbusArp type exposes the following members.

Properties
 | Name | Description
Public property | AssignAddressSlaveAddress | Assign Address: Slave Address
Public property | AssignAddressUDID | Assign Address: UDID
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | GetUDIDDirected0x03SlaveAddress | Get UDID (Directed: 0x03): Slave Address
Public property | GetUDIDDirected0x03UDID | Get UDID (Directed: 0x03): UDID
Public property | GetUDIDDirected0x04SlaveAddress | Get UDID (Directed: 0x04): Slave Address
Public property | GetUDIDDirected0x04UDID | Get UDID (Directed: 0x04): UDID
Public property | GetUDIDDirected0x05SlaveAddress | Get UDID (Directed: 0x05): Slave Address
Public property | GetUDIDDirected0x05UDID | Get UDID (Directed: 0x05): UDID
Public property | GetUDIDDirected0x06SlaveAddress | Get UDID (Directed: 0x06): Slave Address
Public property | GetUDIDDirected0x06UDID | Get UDID (Directed: 0x06): UDID
Public property | GetUDIDDirected0x07SlaveAddress | Get UDID (Directed: 0x07): Slave Address
Public property | GetUDIDDirected0x07UDID | Get UDID (Directed: 0x07): UDID
Public property | GetUDIDDirected0x08SlaveAddress | Get UDID (Directed: 0x08): Slave Address
Public property | GetUDIDDirected0x08UDID | Get UDID (Directed: 0x08): UDID
Public property | GetUDIDDirected0x09SlaveAddress | Get UDID (Directed: 0x09): Slave Address
Public property | GetUDIDDirected0x09UDID | Get UDID (Directed: 0x09): UDID
Public property | GetUDIDDirected0x0aSlaveAddress | Get UDID (Directed: 0x0a): Slave Address
Public property | GetUDIDDirected0x0aUDID | Get UDID (Directed: 0x0a): UDID
Public property | GetUDIDDirected0x0bSlaveAddress | Get UDID (Directed: 0x0b): Slave Address
Public property | GetUDIDDirected0x0bUDID | Get UDID (Directed: 0x0b): UDID
Public property | GetUDIDDirected0x0cSlaveAddress | Get UDID (Directed: 0x0c): Slave Address
Public property | GetUDIDDirected0x0cUDID | Get UDID (Directed: 0x0c): UDID
Public property | GetUDIDDirected0x0dSlaveAddress | Get UDID (Directed: 0x0d): Slave Address
Public property | GetUDIDDirected0x0dUDID | Get UDID (Directed: 0x0d): UDID
Public property | GetUDIDDirected0x0eSlaveAddress | Get UDID (Directed: 0x0e): Slave Address
Public property | GetUDIDDirected0x0eUDID | Get UDID (Directed: 0x0e): UDID
Public property | GetUDIDDirected0x0fSlaveAddress | Get UDID (Directed: 0x0f): Slave Address
Public property | GetUDIDDirected0x0fUDID | Get UDID (Directed: 0x0f): UDID
Public property | GetUDIDDirected0x10SlaveAddress | Get UDID (Directed: 0x10): Slave Address
Public property | GetUDIDDirected0x10UDID | Get UDID (Directed: 0x10): UDID
Public property | GetUDIDDirected0x11SlaveAddress | Get UDID (Directed: 0x11): Slave Address
Public property | GetUDIDDirected0x11UDID | Get UDID (Directed: 0x11): UDID
Public property | GetUDIDDirected0x12SlaveAddress | Get UDID (Directed: 0x12): Slave Address
Public property | GetUDIDDirected0x12UDID | Get UDID (Directed: 0x12): UDID
Public property | GetUDIDDirected0x13SlaveAddress | Get UDID (Directed: 0x13): Slave Address
Public property | GetUDIDDirected0x13UDID | Get UDID (Directed: 0x13): UDID
Public property | GetUDIDDirected0x14SlaveAddress | Get UDID (Directed: 0x14): Slave Address
Public property | GetUDIDDirected0x14UDID | Get UDID (Directed: 0x14): UDID
Public property | GetUDIDDirected0x15SlaveAddress | Get UDID (Directed: 0x15): Slave Address
Public property | GetUDIDDirected0x15UDID | Get UDID (Directed: 0x15): UDID
Public property | GetUDIDDirected0x16SlaveAddress | Get UDID (Directed: 0x16): Slave Address
Public property | GetUDIDDirected0x16UDID | Get UDID (Directed: 0x16): UDID
Public property | GetUDIDDirected0x17SlaveAddress | Get UDID (Directed: 0x17): Slave Address
Public property | GetUDIDDirected0x17UDID | Get UDID (Directed: 0x17): UDID
Public property | GetUDIDDirected0x18SlaveAddress | Get UDID (Directed: 0x18): Slave Address
Public property | GetUDIDDirected0x18UDID | Get UDID (Directed: 0x18): UDID
Public property | GetUDIDDirected0x19SlaveAddress | Get UDID (Directed: 0x19): Slave Address
Public property | GetUDIDDirected0x19UDID | Get UDID (Directed: 0x19): UDID
Public property | GetUDIDDirected0x1aSlaveAddress | Get UDID (Directed: 0x1a): Slave Address
Public property | GetUDIDDirected0x1aUDID | Get UDID (Directed: 0x1a): UDID
Public property | GetUDIDDirected0x1bSlaveAddress | Get UDID (Directed: 0x1b): Slave Address
Public property | GetUDIDDirected0x1bUDID | Get UDID (Directed: 0x1b): UDID
Public property | GetUDIDDirected0x1cSlaveAddress | Get UDID (Directed: 0x1c): Slave Address
Public property | GetUDIDDirected0x1cUDID | Get UDID (Directed: 0x1c): UDID
Public property | GetUDIDDirected0x1dSlaveAddress | Get UDID (Directed: 0x1d): Slave Address
Public property | GetUDIDDirected0x1dUDID | Get UDID (Directed: 0x1d): UDID
Public property | GetUDIDDirected0x1eSlaveAddress | Get UDID (Directed: 0x1e): Slave Address
Public property | GetUDIDDirected0x1eUDID | Get UDID (Directed: 0x1e): UDID
Public property | GetUDIDDirected0x1fSlaveAddress | Get UDID (Directed: 0x1f): Slave Address
Public property | GetUDIDDirected0x1fUDID | Get UDID (Directed: 0x1f): UDID
Public property | GetUDIDDirected0x20SlaveAddress | Get UDID (Directed: 0x20): Slave Address
Public property | GetUDIDDirected0x20UDID | Get UDID (Directed: 0x20): UDID
Public property | GetUDIDDirected0x21SlaveAddress | Get UDID (Directed: 0x21): Slave Address
Public property | GetUDIDDirected0x21UDID | Get UDID (Directed: 0x21): UDID
Public property | GetUDIDDirected0x22SlaveAddress | Get UDID (Directed: 0x22): Slave Address
Public property | GetUDIDDirected0x22UDID | Get UDID (Directed: 0x22): UDID
Public property | GetUDIDDirected0x23SlaveAddress | Get UDID (Directed: 0x23): Slave Address
Public property | GetUDIDDirected0x23UDID | Get UDID (Directed: 0x23): UDID
Public property | GetUDIDDirected0x24SlaveAddress | Get UDID (Directed: 0x24): Slave Address
Public property | GetUDIDDirected0x24UDID | Get UDID (Directed: 0x24): UDID
Public property | GetUDIDDirected0x25SlaveAddress | Get UDID (Directed: 0x25): Slave Address
Public property | GetUDIDDirected0x25UDID | Get UDID (Directed: 0x25): UDID
Public property | GetUDIDDirected0x26SlaveAddress | Get UDID (Directed: 0x26): Slave Address
Public property | GetUDIDDirected0x26UDID | Get UDID (Directed: 0x26): UDID
Public property | GetUDIDDirected0x27SlaveAddress | Get UDID (Directed: 0x27): Slave Address
Public property | GetUDIDDirected0x27UDID | Get UDID (Directed: 0x27): UDID
Public property | GetUDIDDirected0x28SlaveAddress | Get UDID (Directed: 0x28): Slave Address
Public property | GetUDIDDirected0x28UDID | Get UDID (Directed: 0x28): UDID
Public property | GetUDIDDirected0x29SlaveAddress | Get UDID (Directed: 0x29): Slave Address
Public property | GetUDIDDirected0x29UDID | Get UDID (Directed: 0x29): UDID
Public property | GetUDIDDirected0x2aSlaveAddress | Get UDID (Directed: 0x2a): Slave Address
Public property | GetUDIDDirected0x2aUDID | Get UDID (Directed: 0x2a): UDID
Public property | GetUDIDDirected0x2bSlaveAddress | Get UDID (Directed: 0x2b): Slave Address
Public property | GetUDIDDirected0x2bUDID | Get UDID (Directed: 0x2b): UDID
Public property | GetUDIDDirected0x2cSlaveAddress | Get UDID (Directed: 0x2c): Slave Address
Public property | GetUDIDDirected0x2cUDID | Get UDID (Directed: 0x2c): UDID
Public property | GetUDIDDirected0x2dSlaveAddress | Get UDID (Directed: 0x2d): Slave Address
Public property | GetUDIDDirected0x2dUDID | Get UDID (Directed: 0x2d): UDID
Public property | GetUDIDDirected0x2eSlaveAddress | Get UDID (Directed: 0x2e): Slave Address
Public property | GetUDIDDirected0x2eUDID | Get UDID (Directed: 0x2e): UDID
Public property | GetUDIDDirected0x2fSlaveAddress | Get UDID (Directed: 0x2f): Slave Address
Public property | GetUDIDDirected0x2fUDID | Get UDID (Directed: 0x2f): UDID
Public property | GetUDIDDirected0x30SlaveAddress | Get UDID (Directed: 0x30): Slave Address
Public property | GetUDIDDirected0x30UDID | Get UDID (Directed: 0x30): UDID
Public property | GetUDIDDirected0x31SlaveAddress | Get UDID (Directed: 0x31): Slave Address
Public property | GetUDIDDirected0x31UDID | Get UDID (Directed: 0x31): UDID
Public property | GetUDIDDirected0x32SlaveAddress | Get UDID (Directed: 0x32): Slave Address
Public property | GetUDIDDirected0x32UDID | Get UDID (Directed: 0x32): UDID
Public property | GetUDIDDirected0x33SlaveAddress | Get UDID (Directed: 0x33): Slave Address
Public property | GetUDIDDirected0x33UDID | Get UDID (Directed: 0x33): UDID
Public property | GetUDIDDirected0x34SlaveAddress | Get UDID (Directed: 0x34): Slave Address
Public property | GetUDIDDirected0x34UDID | Get UDID (Directed: 0x34): UDID
Public property | GetUDIDDirected0x35SlaveAddress | Get UDID (Directed: 0x35): Slave Address
Public property | GetUDIDDirected0x35UDID | Get UDID (Directed: 0x35): UDID
Public property | GetUDIDDirected0x36SlaveAddress | Get UDID (Directed: 0x36): Slave Address
Public property | GetUDIDDirected0x36UDID | Get UDID (Directed: 0x36): UDID
Public property | GetUDIDDirected0x37SlaveAddress | Get UDID (Directed: 0x37): Slave Address
Public property | GetUDIDDirected0x37UDID | Get UDID (Directed: 0x37): UDID
Public property | GetUDIDDirected0x38SlaveAddress | Get UDID (Directed: 0x38): Slave Address
Public property | GetUDIDDirected0x38UDID | Get UDID (Directed: 0x38): UDID
Public property | GetUDIDDirected0x39SlaveAddress | Get UDID (Directed: 0x39): Slave Address
Public property | GetUDIDDirected0x39UDID | Get UDID (Directed: 0x39): UDID
Public property | GetUDIDDirected0x3aSlaveAddress | Get UDID (Directed: 0x3a): Slave Address
Public property | GetUDIDDirected0x3aUDID | Get UDID (Directed: 0x3a): UDID
Public property | GetUDIDDirected0x3bSlaveAddress | Get UDID (Directed: 0x3b): Slave Address
Public property | GetUDIDDirected0x3bUDID | Get UDID (Directed: 0x3b): UDID
Public property | GetUDIDDirected0x3cSlaveAddress | Get UDID (Directed: 0x3c): Slave Address
Public property | GetUDIDDirected0x3cUDID | Get UDID (Directed: 0x3c): UDID
Public property | GetUDIDDirected0x3dSlaveAddress | Get UDID (Directed: 0x3d): Slave Address
Public property | GetUDIDDirected0x3dUDID | Get UDID (Directed: 0x3d): UDID
Public property | GetUDIDDirected0x3eSlaveAddress | Get UDID (Directed: 0x3e): Slave Address
Public property | GetUDIDDirected0x3eUDID | Get UDID (Directed: 0x3e): UDID
Public property | GetUDIDDirected0x3fSlaveAddress | Get UDID (Directed: 0x3f): Slave Address
Public property | GetUDIDDirected0x3fUDID | Get UDID (Directed: 0x3f): UDID
Public property | GetUDIDDirected0x40SlaveAddress | Get UDID (Directed: 0x40): Slave Address
Public property | GetUDIDDirected0x40UDID | Get UDID (Directed: 0x40): UDID
Public property | GetUDIDDirected0x41SlaveAddress | Get UDID (Directed: 0x41): Slave Address
Public property | GetUDIDDirected0x41UDID | Get UDID (Directed: 0x41): UDID
Public property | GetUDIDDirected0x42SlaveAddress | Get UDID (Directed: 0x42): Slave Address
Public property | GetUDIDDirected0x42UDID | Get UDID (Directed: 0x42): UDID
Public property | GetUDIDDirected0x43SlaveAddress | Get UDID (Directed: 0x43): Slave Address
Public property | GetUDIDDirected0x43UDID | Get UDID (Directed: 0x43): UDID
Public property | GetUDIDDirected0x44SlaveAddress | Get UDID (Directed: 0x44): Slave Address
Public property | GetUDIDDirected0x44UDID | Get UDID (Directed: 0x44): UDID
Public property | GetUDIDDirected0x45SlaveAddress | Get UDID (Directed: 0x45): Slave Address
Public property | GetUDIDDirected0x45UDID | Get UDID (Directed: 0x45): UDID
Public property | GetUDIDDirected0x46SlaveAddress | Get UDID (Directed: 0x46): Slave Address
Public property | GetUDIDDirected0x46UDID | Get UDID (Directed: 0x46): UDID
Public property | GetUDIDDirected0x47SlaveAddress | Get UDID (Directed: 0x47): Slave Address
Public property | GetUDIDDirected0x47UDID | Get UDID (Directed: 0x47): UDID
Public property | GetUDIDDirected0x48SlaveAddress | Get UDID (Directed: 0x48): Slave Address
Public property | GetUDIDDirected0x48UDID | Get UDID (Directed: 0x48): UDID
Public property | GetUDIDDirected0x49SlaveAddress | Get UDID (Directed: 0x49): Slave Address
Public property | GetUDIDDirected0x49UDID | Get UDID (Directed: 0x49): UDID
Public property | GetUDIDDirected0x4aSlaveAddress | Get UDID (Directed: 0x4a): Slave Address
Public property | GetUDIDDirected0x4aUDID | Get UDID (Directed: 0x4a): UDID
Public property | GetUDIDDirected0x4bSlaveAddress | Get UDID (Directed: 0x4b): Slave Address
Public property | GetUDIDDirected0x4bUDID | Get UDID (Directed: 0x4b): UDID
Public property | GetUDIDDirected0x4cSlaveAddress | Get UDID (Directed: 0x4c): Slave Address
Public property | GetUDIDDirected0x4cUDID | Get UDID (Directed: 0x4c): UDID
Public property | GetUDIDDirected0x4dSlaveAddress | Get UDID (Directed: 0x4d): Slave Address
Public property | GetUDIDDirected0x4dUDID | Get UDID (Directed: 0x4d): UDID
Public property | GetUDIDDirected0x4eSlaveAddress | Get UDID (Directed: 0x4e): Slave Address
Public property | GetUDIDDirected0x4eUDID | Get UDID (Directed: 0x4e): UDID
Public property | GetUDIDDirected0x4fSlaveAddress | Get UDID (Directed: 0x4f): Slave Address
Public property | GetUDIDDirected0x4fUDID | Get UDID (Directed: 0x4f): UDID
Public property | GetUDIDDirected0x50SlaveAddress | Get UDID (Directed: 0x50): Slave Address
Public property | GetUDIDDirected0x50UDID | Get UDID (Directed: 0x50): UDID
Public property | GetUDIDDirected0x51SlaveAddress | Get UDID (Directed: 0x51): Slave Address
Public property | GetUDIDDirected0x51UDID | Get UDID (Directed: 0x51): UDID
Public property | GetUDIDDirected0x52SlaveAddress | Get UDID (Directed: 0x52): Slave Address
Public property | GetUDIDDirected0x52UDID | Get UDID (Directed: 0x52): UDID
Public property | GetUDIDDirected0x53SlaveAddress | Get UDID (Directed: 0x53): Slave Address
Public property | GetUDIDDirected0x53UDID | Get UDID (Directed: 0x53): UDID
Public property | GetUDIDDirected0x54SlaveAddress | Get UDID (Directed: 0x54): Slave Address
Public property | GetUDIDDirected0x54UDID | Get UDID (Directed: 0x54): UDID
Public property | GetUDIDDirected0x55SlaveAddress | Get UDID (Directed: 0x55): Slave Address
Public property | GetUDIDDirected0x55UDID | Get UDID (Directed: 0x55): UDID
Public property | GetUDIDDirected0x56SlaveAddress | Get UDID (Directed: 0x56): Slave Address
Public property | GetUDIDDirected0x56UDID | Get UDID (Directed: 0x56): UDID
Public property | GetUDIDDirected0x57SlaveAddress | Get UDID (Directed: 0x57): Slave Address
Public property | GetUDIDDirected0x57UDID | Get UDID (Directed: 0x57): UDID
Public property | GetUDIDDirected0x58SlaveAddress | Get UDID (Directed: 0x58): Slave Address
Public property | GetUDIDDirected0x58UDID | Get UDID (Directed: 0x58): UDID
Public property | GetUDIDDirected0x59SlaveAddress | Get UDID (Directed: 0x59): Slave Address
Public property | GetUDIDDirected0x59UDID | Get UDID (Directed: 0x59): UDID
Public property | GetUDIDDirected0x5aSlaveAddress | Get UDID (Directed: 0x5a): Slave Address
Public property | GetUDIDDirected0x5aUDID | Get UDID (Directed: 0x5a): UDID
Public property | GetUDIDDirected0x5bSlaveAddress | Get UDID (Directed: 0x5b): Slave Address
Public property | GetUDIDDirected0x5bUDID | Get UDID (Directed: 0x5b): UDID
Public property | GetUDIDDirected0x5cSlaveAddress | Get UDID (Directed: 0x5c): Slave Address
Public property | GetUDIDDirected0x5cUDID | Get UDID (Directed: 0x5c): UDID
Public property | GetUDIDDirected0x5dSlaveAddress | Get UDID (Directed: 0x5d): Slave Address
Public property | GetUDIDDirected0x5dUDID | Get UDID (Directed: 0x5d): UDID
Public property | GetUDIDDirected0x5eSlaveAddress | Get UDID (Directed: 0x5e): Slave Address
Public property | GetUDIDDirected0x5eUDID | Get UDID (Directed: 0x5e): UDID
Public property | GetUDIDDirected0x5fSlaveAddress | Get UDID (Directed: 0x5f): Slave Address
Public property | GetUDIDDirected0x5fUDID | Get UDID (Directed: 0x5f): UDID
Public property | GetUDIDDirected0x60SlaveAddress | Get UDID (Directed: 0x60): Slave Address
Public property | GetUDIDDirected0x60UDID | Get UDID (Directed: 0x60): UDID
Public property | GetUDIDDirected0x61SlaveAddress | Get UDID (Directed: 0x61): Slave Address
Public property | GetUDIDDirected0x61UDID | Get UDID (Directed: 0x61): UDID
Public property | GetUDIDDirected0x62SlaveAddress | Get UDID (Directed: 0x62): Slave Address
Public property | GetUDIDDirected0x62UDID | Get UDID (Directed: 0x62): UDID
Public property | GetUDIDDirected0x63SlaveAddress | Get UDID (Directed: 0x63): Slave Address
Public property | GetUDIDDirected0x63UDID | Get UDID (Directed: 0x63): UDID
Public property | GetUDIDDirected0x64SlaveAddress | Get UDID (Directed: 0x64): Slave Address
Public property | GetUDIDDirected0x64UDID | Get UDID (Directed: 0x64): UDID
Public property | GetUDIDDirected0x65SlaveAddress | Get UDID (Directed: 0x65): Slave Address
Public property | GetUDIDDirected0x65UDID | Get UDID (Directed: 0x65): UDID
Public property | GetUDIDDirected0x66SlaveAddress | Get UDID (Directed: 0x66): Slave Address
Public property | GetUDIDDirected0x66UDID | Get UDID (Directed: 0x66): UDID
Public property | GetUDIDDirected0x67SlaveAddress | Get UDID (Directed: 0x67): Slave Address
Public property | GetUDIDDirected0x67UDID | Get UDID (Directed: 0x67): UDID
Public property | GetUDIDDirected0x68SlaveAddress | Get UDID (Directed: 0x68): Slave Address
Public property | GetUDIDDirected0x68UDID | Get UDID (Directed: 0x68): UDID
Public property | GetUDIDDirected0x69SlaveAddress | Get UDID (Directed: 0x69): Slave Address
Public property | GetUDIDDirected0x69UDID | Get UDID (Directed: 0x69): UDID
Public property | GetUDIDDirected0x6aSlaveAddress | Get UDID (Directed: 0x6a): Slave Address
Public property | GetUDIDDirected0x6aUDID | Get UDID (Directed: 0x6a): UDID
Public property | GetUDIDDirected0x6bSlaveAddress | Get UDID (Directed: 0x6b): Slave Address
Public property | GetUDIDDirected0x6bUDID | Get UDID (Directed: 0x6b): UDID
Public property | GetUDIDDirected0x6cSlaveAddress | Get UDID (Directed: 0x6c): Slave Address
Public property | GetUDIDDirected0x6cUDID | Get UDID (Directed: 0x6c): UDID
Public property | GetUDIDDirected0x6dSlaveAddress | Get UDID (Directed: 0x6d): Slave Address
Public property | GetUDIDDirected0x6dUDID | Get UDID (Directed: 0x6d): UDID
Public property | GetUDIDDirected0x6eSlaveAddress | Get UDID (Directed: 0x6e): Slave Address
Public property | GetUDIDDirected0x6eUDID | Get UDID (Directed: 0x6e): UDID
Public property | GetUDIDDirected0x6fSlaveAddress | Get UDID (Directed: 0x6f): Slave Address
Public property | GetUDIDDirected0x6fUDID | Get UDID (Directed: 0x6f): UDID
Public property | GetUDIDDirected0x70SlaveAddress | Get UDID (Directed: 0x70): Slave Address
Public property | GetUDIDDirected0x70UDID | Get UDID (Directed: 0x70): UDID
Public property | GetUDIDDirected0x71SlaveAddress | Get UDID (Directed: 0x71): Slave Address
Public property | GetUDIDDirected0x71UDID | Get UDID (Directed: 0x71): UDID
Public property | GetUDIDDirected0x72SlaveAddress | Get UDID (Directed: 0x72): Slave Address
Public property | GetUDIDDirected0x72UDID | Get UDID (Directed: 0x72): UDID
Public property | GetUDIDDirected0x73SlaveAddress | Get UDID (Directed: 0x73): Slave Address
Public property | GetUDIDDirected0x73UDID | Get UDID (Directed: 0x73): UDID
Public property | GetUDIDDirected0x74SlaveAddress | Get UDID (Directed: 0x74): Slave Address
Public property | GetUDIDDirected0x74UDID | Get UDID (Directed: 0x74): UDID
Public property | GetUDIDDirected0x75SlaveAddress | Get UDID (Directed: 0x75): Slave Address
Public property | GetUDIDDirected0x75UDID | Get UDID (Directed: 0x75): UDID
Public property | GetUDIDDirected0x76SlaveAddress | Get UDID (Directed: 0x76): Slave Address
Public property | GetUDIDDirected0x76UDID | Get UDID (Directed: 0x76): UDID
Public property | GetUDIDDirected0x77SlaveAddress | Get UDID (Directed: 0x77): Slave Address
Public property | GetUDIDDirected0x77UDID | Get UDID (Directed: 0x77): UDID
Public property | GetUDIDDirected0x78SlaveAddress | Get UDID (Directed: 0x78): Slave Address
Public property | GetUDIDDirected0x78UDID | Get UDID (Directed: 0x78): UDID
Public property | GetUDIDDirected0x79SlaveAddress | Get UDID (Directed: 0x79): Slave Address
Public property | GetUDIDDirected0x79UDID | Get UDID (Directed: 0x79): UDID
Public property | GetUDIDDirected0x7aSlaveAddress | Get UDID (Directed: 0x7a): Slave Address
Public property | GetUDIDDirected0x7aUDID | Get UDID (Directed: 0x7a): UDID
Public property | GetUDIDDirected0x7bSlaveAddress | Get UDID (Directed: 0x7b): Slave Address
Public property | GetUDIDDirected0x7bUDID | Get UDID (Directed: 0x7b): UDID
Public property | GetUDIDDirected0x7cSlaveAddress | Get UDID (Directed: 0x7c): Slave Address
Public property | GetUDIDDirected0x7cUDID | Get UDID (Directed: 0x7c): UDID
Public property | GetUDIDDirected0x7dSlaveAddress | Get UDID (Directed: 0x7d): Slave Address
Public property | GetUDIDDirected0x7dUDID | Get UDID (Directed: 0x7d): UDID
Public property | GetUDIDDirected0x7eSlaveAddress | Get UDID (Directed: 0x7e): Slave Address
Public property | GetUDIDDirected0x7eUDID | Get UDID (Directed: 0x7e): UDID
Public property | GetUDIDDirected0x7fSlaveAddress | Get UDID (Directed: 0x7f): Slave Address
Public property | GetUDIDDirected0x7fUDID | Get UDID (Directed: 0x7f): UDID
Public property | GetUDIDGeneralAddressType | Get UDID (General): Address Type
Public property | GetUDIDGeneralDeviceID | Get UDID (General): Device ID
Public property | GetUDIDGeneralPEC | Get UDID (General): PEC
Public property | GetUDIDGeneralSiliconRevisionID | Get UDID (General): Silicon Revision ID
Public property | GetUDIDGeneralSlaveAddress | Get UDID (General): Slave Address
Public property | GetUDIDGeneralSMBusVersion | Get UDID (General): SMBus Version
Public property | GetUDIDGeneralSubsystemDeviceID | Get UDID (General): Subsystem Device ID
Public property | GetUDIDGeneralSubsystemVendorID | Get UDID (General): Subsystem Vendor ID
Public property | GetUDIDGeneralSupportedProtocolsASF | Get UDID (General): Supported Protocols: ASF
Public property | GetUDIDGeneralSupportedProtocolsIPMI | Get UDID (General): Supported Protocols: IPMI
Public property | GetUDIDGeneralSupportedProtocolsOEM | Get UDID (General): Supported Protocols: OEM
Public property | GetUDIDGeneralSupportedProtocolsZONE | Get UDID (General): Supported Protocols: ZONE
Public property | GetUDIDGeneralUDIDVersion | Get UDID (General): UDID Version
Public property | GetUDIDGeneralVendorID | Get UDID (General): Vendor ID
Public property | GetUDIDGeneralVendorSpecificID | Get UDID (General): Vendor Specific ID
Top
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.AssignAddressSlaveAddress Property

IRD

SmbusArpAssignAddressSlaveAddress Property

Assign Address: Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AssignAddressSlaveAddress { set; }
Public WriteOnly Property AssignAddressSlaveAddress As Byte
    Set
public:
property unsigned char AssignAddressSlaveAddress {
    void set (unsigned char value);
}
member AssignAddressSlaveAddress : byte with set

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.AssignAddressUDID Property

IRD

SmbusArpAssignAddressUDID Property

Assign Address: UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] AssignAddressUDID { set; }
Public WriteOnly Property AssignAddressUDID As Byte()
    Set
public:
property array<unsigned char>^ AssignAddressUDID {
    void set (array<unsigned char>^ value);
}
member AssignAddressUDID : byte[] with set

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.AutoFlush Property

IRD

SmbusArpAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x03SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x03SlaveAddress Property

Get UDID (Directed: 0x03): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x03SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x03SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x03SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x03SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x03UDID Property

IRD

SmbusArpGetUDIDDirected0x03UDID Property

Get UDID (Directed: 0x03): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x03UDID { get; }
Public ReadOnly Property GetUDIDDirected0x03UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x03UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x03UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x04SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x04SlaveAddress Property

Get UDID (Directed: 0x04): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x04SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x04SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x04SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x04SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x04UDID Property

IRD

SmbusArpGetUDIDDirected0x04UDID Property

Get UDID (Directed: 0x04): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x04UDID { get; }
Public ReadOnly Property GetUDIDDirected0x04UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x04UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x04UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x05SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x05SlaveAddress Property

Get UDID (Directed: 0x05): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x05SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x05SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x05SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x05SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x05UDID Property

IRD

SmbusArpGetUDIDDirected0x05UDID Property

Get UDID (Directed: 0x05): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x05UDID { get; }
Public ReadOnly Property GetUDIDDirected0x05UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x05UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x05UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x06SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x06SlaveAddress Property

Get UDID (Directed: 0x06): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x06SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x06SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x06SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x06SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x06UDID Property

IRD

SmbusArpGetUDIDDirected0x06UDID Property

Get UDID (Directed: 0x06): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x06UDID { get; }
Public ReadOnly Property GetUDIDDirected0x06UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x06UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x06UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x07SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x07SlaveAddress Property

Get UDID (Directed: 0x07): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x07SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x07SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x07SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x07SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x07UDID Property

IRD

SmbusArpGetUDIDDirected0x07UDID Property

Get UDID (Directed: 0x07): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x07UDID { get; }
Public ReadOnly Property GetUDIDDirected0x07UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x07UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x07UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x08SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x08SlaveAddress Property

Get UDID (Directed: 0x08): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x08SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x08SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x08SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x08SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x08UDID Property

IRD

SmbusArpGetUDIDDirected0x08UDID Property

Get UDID (Directed: 0x08): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x08UDID { get; }
Public ReadOnly Property GetUDIDDirected0x08UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x08UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x08UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x09SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x09SlaveAddress Property

Get UDID (Directed: 0x09): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x09SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x09SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x09SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x09SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x09UDID Property

IRD

SmbusArpGetUDIDDirected0x09UDID Property

Get UDID (Directed: 0x09): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x09UDID { get; }
Public ReadOnly Property GetUDIDDirected0x09UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x09UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x09UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x0aSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x0aSlaveAddress Property

Get UDID (Directed: 0x0a): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x0aSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x0aSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x0aSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x0aSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x0aUDID Property

IRD

SmbusArpGetUDIDDirected0x0aUDID Property

Get UDID (Directed: 0x0a): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x0aUDID { get; }
Public ReadOnly Property GetUDIDDirected0x0aUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x0aUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x0aUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x0bSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x0bSlaveAddress Property

Get UDID (Directed: 0x0b): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x0bSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x0bSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x0bSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x0bSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x0bUDID Property

IRD

SmbusArpGetUDIDDirected0x0bUDID Property

Get UDID (Directed: 0x0b): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x0bUDID { get; }
Public ReadOnly Property GetUDIDDirected0x0bUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x0bUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x0bUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x0cSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x0cSlaveAddress Property

Get UDID (Directed: 0x0c): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x0cSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x0cSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x0cSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x0cSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x0cUDID Property

IRD

SmbusArpGetUDIDDirected0x0cUDID Property

Get UDID (Directed: 0x0c): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x0cUDID { get; }
Public ReadOnly Property GetUDIDDirected0x0cUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x0cUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x0cUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x0dSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x0dSlaveAddress Property

Get UDID (Directed: 0x0d): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x0dSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x0dSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x0dSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x0dSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x0dUDID Property

IRD

SmbusArpGetUDIDDirected0x0dUDID Property

Get UDID (Directed: 0x0d): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x0dUDID { get; }
Public ReadOnly Property GetUDIDDirected0x0dUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x0dUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x0dUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x0eSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x0eSlaveAddress Property

Get UDID (Directed: 0x0e): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x0eSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x0eSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x0eSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x0eSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x0eUDID Property

IRD

SmbusArpGetUDIDDirected0x0eUDID Property

Get UDID (Directed: 0x0e): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x0eUDID { get; }
Public ReadOnly Property GetUDIDDirected0x0eUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x0eUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x0eUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x0fSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x0fSlaveAddress Property

Get UDID (Directed: 0x0f): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x0fSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x0fSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x0fSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x0fSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x0fUDID Property

IRD

SmbusArpGetUDIDDirected0x0fUDID Property

Get UDID (Directed: 0x0f): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x0fUDID { get; }
Public ReadOnly Property GetUDIDDirected0x0fUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x0fUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x0fUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x10SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x10SlaveAddress Property

Get UDID (Directed: 0x10): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x10SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x10SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x10SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x10SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x10UDID Property

IRD

SmbusArpGetUDIDDirected0x10UDID Property

Get UDID (Directed: 0x10): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x10UDID { get; }
Public ReadOnly Property GetUDIDDirected0x10UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x10UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x10UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x11SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x11SlaveAddress Property

Get UDID (Directed: 0x11): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x11SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x11SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x11SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x11SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x11UDID Property

IRD

SmbusArpGetUDIDDirected0x11UDID Property

Get UDID (Directed: 0x11): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x11UDID { get; }
Public ReadOnly Property GetUDIDDirected0x11UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x11UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x11UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x12SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x12SlaveAddress Property

Get UDID (Directed: 0x12): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x12SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x12SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x12SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x12SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x12UDID Property

IRD

SmbusArpGetUDIDDirected0x12UDID Property

Get UDID (Directed: 0x12): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x12UDID { get; }
Public ReadOnly Property GetUDIDDirected0x12UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x12UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x12UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x13SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x13SlaveAddress Property

Get UDID (Directed: 0x13): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x13SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x13SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x13SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x13SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x13UDID Property

IRD

SmbusArpGetUDIDDirected0x13UDID Property

Get UDID (Directed: 0x13): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x13UDID { get; }
Public ReadOnly Property GetUDIDDirected0x13UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x13UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x13UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x14SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x14SlaveAddress Property

Get UDID (Directed: 0x14): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x14SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x14SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x14SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x14SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x14UDID Property

IRD

SmbusArpGetUDIDDirected0x14UDID Property

Get UDID (Directed: 0x14): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x14UDID { get; }
Public ReadOnly Property GetUDIDDirected0x14UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x14UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x14UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x15SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x15SlaveAddress Property

Get UDID (Directed: 0x15): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x15SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x15SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x15SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x15SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x15UDID Property

IRD

SmbusArpGetUDIDDirected0x15UDID Property

Get UDID (Directed: 0x15): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x15UDID { get; }
Public ReadOnly Property GetUDIDDirected0x15UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x15UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x15UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x16SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x16SlaveAddress Property

Get UDID (Directed: 0x16): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x16SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x16SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x16SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x16SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x16UDID Property

IRD

SmbusArpGetUDIDDirected0x16UDID Property

Get UDID (Directed: 0x16): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x16UDID { get; }
Public ReadOnly Property GetUDIDDirected0x16UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x16UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x16UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x17SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x17SlaveAddress Property

Get UDID (Directed: 0x17): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x17SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x17SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x17SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x17SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x17UDID Property

IRD

SmbusArpGetUDIDDirected0x17UDID Property

Get UDID (Directed: 0x17): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x17UDID { get; }
Public ReadOnly Property GetUDIDDirected0x17UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x17UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x17UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x18SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x18SlaveAddress Property

Get UDID (Directed: 0x18): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x18SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x18SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x18SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x18SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x18UDID Property

IRD

SmbusArpGetUDIDDirected0x18UDID Property

Get UDID (Directed: 0x18): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x18UDID { get; }
Public ReadOnly Property GetUDIDDirected0x18UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x18UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x18UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x19SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x19SlaveAddress Property

Get UDID (Directed: 0x19): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x19SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x19SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x19SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x19SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x19UDID Property

IRD

SmbusArpGetUDIDDirected0x19UDID Property

Get UDID (Directed: 0x19): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x19UDID { get; }
Public ReadOnly Property GetUDIDDirected0x19UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x19UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x19UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x1aSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x1aSlaveAddress Property

Get UDID (Directed: 0x1a): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x1aSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x1aSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x1aSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x1aSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x1aUDID Property

IRD

SmbusArpGetUDIDDirected0x1aUDID Property

Get UDID (Directed: 0x1a): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x1aUDID { get; }
Public ReadOnly Property GetUDIDDirected0x1aUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x1aUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x1aUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x1bSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x1bSlaveAddress Property

Get UDID (Directed: 0x1b): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x1bSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x1bSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x1bSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x1bSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x1bUDID Property

IRD

SmbusArpGetUDIDDirected0x1bUDID Property

Get UDID (Directed: 0x1b): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x1bUDID { get; }
Public ReadOnly Property GetUDIDDirected0x1bUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x1bUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x1bUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x1cSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x1cSlaveAddress Property

Get UDID (Directed: 0x1c): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x1cSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x1cSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x1cSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x1cSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x1cUDID Property

IRD

SmbusArpGetUDIDDirected0x1cUDID Property

Get UDID (Directed: 0x1c): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x1cUDID { get; }
Public ReadOnly Property GetUDIDDirected0x1cUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x1cUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x1cUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x1dSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x1dSlaveAddress Property

Get UDID (Directed: 0x1d): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x1dSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x1dSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x1dSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x1dSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x1dUDID Property

IRD

SmbusArpGetUDIDDirected0x1dUDID Property

Get UDID (Directed: 0x1d): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x1dUDID { get; }
Public ReadOnly Property GetUDIDDirected0x1dUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x1dUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x1dUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x1eSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x1eSlaveAddress Property

Get UDID (Directed: 0x1e): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x1eSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x1eSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x1eSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x1eSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x1eUDID Property

IRD

SmbusArpGetUDIDDirected0x1eUDID Property

Get UDID (Directed: 0x1e): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x1eUDID { get; }
Public ReadOnly Property GetUDIDDirected0x1eUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x1eUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x1eUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x1fSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x1fSlaveAddress Property

Get UDID (Directed: 0x1f): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x1fSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x1fSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x1fSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x1fSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x1fUDID Property

IRD

SmbusArpGetUDIDDirected0x1fUDID Property

Get UDID (Directed: 0x1f): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x1fUDID { get; }
Public ReadOnly Property GetUDIDDirected0x1fUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x1fUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x1fUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x20SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x20SlaveAddress Property

Get UDID (Directed: 0x20): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x20SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x20SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x20SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x20SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x20UDID Property

IRD

SmbusArpGetUDIDDirected0x20UDID Property

Get UDID (Directed: 0x20): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x20UDID { get; }
Public ReadOnly Property GetUDIDDirected0x20UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x20UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x20UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x21SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x21SlaveAddress Property

Get UDID (Directed: 0x21): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x21SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x21SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x21SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x21SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x21UDID Property

IRD

SmbusArpGetUDIDDirected0x21UDID Property

Get UDID (Directed: 0x21): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x21UDID { get; }
Public ReadOnly Property GetUDIDDirected0x21UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x21UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x21UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x22SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x22SlaveAddress Property

Get UDID (Directed: 0x22): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x22SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x22SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x22SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x22SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x22UDID Property

IRD

SmbusArpGetUDIDDirected0x22UDID Property

Get UDID (Directed: 0x22): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x22UDID { get; }
Public ReadOnly Property GetUDIDDirected0x22UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x22UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x22UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x23SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x23SlaveAddress Property

Get UDID (Directed: 0x23): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x23SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x23SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x23SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x23SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x23UDID Property

IRD

SmbusArpGetUDIDDirected0x23UDID Property

Get UDID (Directed: 0x23): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x23UDID { get; }
Public ReadOnly Property GetUDIDDirected0x23UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x23UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x23UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x24SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x24SlaveAddress Property

Get UDID (Directed: 0x24): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x24SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x24SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x24SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x24SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x24UDID Property

IRD

SmbusArpGetUDIDDirected0x24UDID Property

Get UDID (Directed: 0x24): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x24UDID { get; }
Public ReadOnly Property GetUDIDDirected0x24UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x24UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x24UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x25SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x25SlaveAddress Property

Get UDID (Directed: 0x25): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x25SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x25SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x25SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x25SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x25UDID Property

IRD

SmbusArpGetUDIDDirected0x25UDID Property

Get UDID (Directed: 0x25): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x25UDID { get; }
Public ReadOnly Property GetUDIDDirected0x25UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x25UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x25UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x26SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x26SlaveAddress Property

Get UDID (Directed: 0x26): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x26SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x26SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x26SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x26SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x26UDID Property

IRD

SmbusArpGetUDIDDirected0x26UDID Property

Get UDID (Directed: 0x26): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x26UDID { get; }
Public ReadOnly Property GetUDIDDirected0x26UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x26UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x26UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x27SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x27SlaveAddress Property

Get UDID (Directed: 0x27): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x27SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x27SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x27SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x27SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x27UDID Property

IRD

SmbusArpGetUDIDDirected0x27UDID Property

Get UDID (Directed: 0x27): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x27UDID { get; }
Public ReadOnly Property GetUDIDDirected0x27UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x27UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x27UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x28SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x28SlaveAddress Property

Get UDID (Directed: 0x28): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x28SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x28SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x28SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x28SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x28UDID Property

IRD

SmbusArpGetUDIDDirected0x28UDID Property

Get UDID (Directed: 0x28): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x28UDID { get; }
Public ReadOnly Property GetUDIDDirected0x28UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x28UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x28UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x29SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x29SlaveAddress Property

Get UDID (Directed: 0x29): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x29SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x29SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x29SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x29SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x29UDID Property

IRD

SmbusArpGetUDIDDirected0x29UDID Property

Get UDID (Directed: 0x29): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x29UDID { get; }
Public ReadOnly Property GetUDIDDirected0x29UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x29UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x29UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x2aSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x2aSlaveAddress Property

Get UDID (Directed: 0x2a): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x2aSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x2aSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x2aSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x2aSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x2aUDID Property

IRD

SmbusArpGetUDIDDirected0x2aUDID Property

Get UDID (Directed: 0x2a): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x2aUDID { get; }
Public ReadOnly Property GetUDIDDirected0x2aUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x2aUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x2aUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x2bSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x2bSlaveAddress Property

Get UDID (Directed: 0x2b): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x2bSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x2bSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x2bSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x2bSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x2bUDID Property

IRD

SmbusArpGetUDIDDirected0x2bUDID Property

Get UDID (Directed: 0x2b): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x2bUDID { get; }
Public ReadOnly Property GetUDIDDirected0x2bUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x2bUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x2bUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x2cSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x2cSlaveAddress Property

Get UDID (Directed: 0x2c): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x2cSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x2cSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x2cSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x2cSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x2cUDID Property

IRD

SmbusArpGetUDIDDirected0x2cUDID Property

Get UDID (Directed: 0x2c): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x2cUDID { get; }
Public ReadOnly Property GetUDIDDirected0x2cUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x2cUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x2cUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x2dSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x2dSlaveAddress Property

Get UDID (Directed: 0x2d): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x2dSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x2dSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x2dSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x2dSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x2dUDID Property

IRD

SmbusArpGetUDIDDirected0x2dUDID Property

Get UDID (Directed: 0x2d): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x2dUDID { get; }
Public ReadOnly Property GetUDIDDirected0x2dUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x2dUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x2dUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x2eSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x2eSlaveAddress Property

Get UDID (Directed: 0x2e): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x2eSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x2eSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x2eSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x2eSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x2eUDID Property

IRD

SmbusArpGetUDIDDirected0x2eUDID Property

Get UDID (Directed: 0x2e): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x2eUDID { get; }
Public ReadOnly Property GetUDIDDirected0x2eUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x2eUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x2eUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x2fSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x2fSlaveAddress Property

Get UDID (Directed: 0x2f): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x2fSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x2fSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x2fSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x2fSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x2fUDID Property

IRD

SmbusArpGetUDIDDirected0x2fUDID Property

Get UDID (Directed: 0x2f): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x2fUDID { get; }
Public ReadOnly Property GetUDIDDirected0x2fUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x2fUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x2fUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x30SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x30SlaveAddress Property

Get UDID (Directed: 0x30): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x30SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x30SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x30SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x30SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x30UDID Property

IRD

SmbusArpGetUDIDDirected0x30UDID Property

Get UDID (Directed: 0x30): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x30UDID { get; }
Public ReadOnly Property GetUDIDDirected0x30UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x30UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x30UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x31SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x31SlaveAddress Property

Get UDID (Directed: 0x31): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x31SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x31SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x31SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x31SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x31UDID Property

IRD

SmbusArpGetUDIDDirected0x31UDID Property

Get UDID (Directed: 0x31): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x31UDID { get; }
Public ReadOnly Property GetUDIDDirected0x31UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x31UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x31UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x32SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x32SlaveAddress Property

Get UDID (Directed: 0x32): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x32SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x32SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x32SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x32SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x32UDID Property

IRD

SmbusArpGetUDIDDirected0x32UDID Property

Get UDID (Directed: 0x32): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x32UDID { get; }
Public ReadOnly Property GetUDIDDirected0x32UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x32UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x32UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x33SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x33SlaveAddress Property

Get UDID (Directed: 0x33): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x33SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x33SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x33SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x33SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x33UDID Property

IRD

SmbusArpGetUDIDDirected0x33UDID Property

Get UDID (Directed: 0x33): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x33UDID { get; }
Public ReadOnly Property GetUDIDDirected0x33UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x33UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x33UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x34SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x34SlaveAddress Property

Get UDID (Directed: 0x34): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x34SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x34SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x34SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x34SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x34UDID Property

IRD

SmbusArpGetUDIDDirected0x34UDID Property

Get UDID (Directed: 0x34): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x34UDID { get; }
Public ReadOnly Property GetUDIDDirected0x34UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x34UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x34UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x35SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x35SlaveAddress Property

Get UDID (Directed: 0x35): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x35SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x35SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x35SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x35SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x35UDID Property

IRD

SmbusArpGetUDIDDirected0x35UDID Property

Get UDID (Directed: 0x35): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x35UDID { get; }
Public ReadOnly Property GetUDIDDirected0x35UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x35UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x35UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x36SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x36SlaveAddress Property

Get UDID (Directed: 0x36): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x36SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x36SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x36SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x36SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x36UDID Property

IRD

SmbusArpGetUDIDDirected0x36UDID Property

Get UDID (Directed: 0x36): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x36UDID { get; }
Public ReadOnly Property GetUDIDDirected0x36UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x36UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x36UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x37SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x37SlaveAddress Property

Get UDID (Directed: 0x37): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x37SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x37SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x37SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x37SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x37UDID Property

IRD

SmbusArpGetUDIDDirected0x37UDID Property

Get UDID (Directed: 0x37): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x37UDID { get; }
Public ReadOnly Property GetUDIDDirected0x37UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x37UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x37UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x38SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x38SlaveAddress Property

Get UDID (Directed: 0x38): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x38SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x38SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x38SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x38SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x38UDID Property

IRD

SmbusArpGetUDIDDirected0x38UDID Property

Get UDID (Directed: 0x38): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x38UDID { get; }
Public ReadOnly Property GetUDIDDirected0x38UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x38UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x38UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x39SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x39SlaveAddress Property

Get UDID (Directed: 0x39): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x39SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x39SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x39SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x39SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x39UDID Property

IRD

SmbusArpGetUDIDDirected0x39UDID Property

Get UDID (Directed: 0x39): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x39UDID { get; }
Public ReadOnly Property GetUDIDDirected0x39UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x39UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x39UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x3aSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x3aSlaveAddress Property

Get UDID (Directed: 0x3a): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x3aSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x3aSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x3aSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x3aSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x3aUDID Property

IRD

SmbusArpGetUDIDDirected0x3aUDID Property

Get UDID (Directed: 0x3a): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x3aUDID { get; }
Public ReadOnly Property GetUDIDDirected0x3aUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x3aUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x3aUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x3bSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x3bSlaveAddress Property

Get UDID (Directed: 0x3b): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x3bSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x3bSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x3bSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x3bSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x3bUDID Property

IRD

SmbusArpGetUDIDDirected0x3bUDID Property

Get UDID (Directed: 0x3b): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x3bUDID { get; }
Public ReadOnly Property GetUDIDDirected0x3bUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x3bUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x3bUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x3cSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x3cSlaveAddress Property

Get UDID (Directed: 0x3c): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x3cSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x3cSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x3cSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x3cSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x3cUDID Property

IRD

SmbusArpGetUDIDDirected0x3cUDID Property

Get UDID (Directed: 0x3c): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x3cUDID { get; }
Public ReadOnly Property GetUDIDDirected0x3cUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x3cUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x3cUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x3dSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x3dSlaveAddress Property

Get UDID (Directed: 0x3d): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x3dSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x3dSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x3dSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x3dSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x3dUDID Property

IRD

SmbusArpGetUDIDDirected0x3dUDID Property

Get UDID (Directed: 0x3d): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x3dUDID { get; }
Public ReadOnly Property GetUDIDDirected0x3dUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x3dUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x3dUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x3eSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x3eSlaveAddress Property

Get UDID (Directed: 0x3e): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x3eSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x3eSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x3eSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x3eSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x3eUDID Property

IRD

SmbusArpGetUDIDDirected0x3eUDID Property

Get UDID (Directed: 0x3e): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x3eUDID { get; }
Public ReadOnly Property GetUDIDDirected0x3eUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x3eUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x3eUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x3fSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x3fSlaveAddress Property

Get UDID (Directed: 0x3f): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x3fSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x3fSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x3fSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x3fSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x3fUDID Property

IRD

SmbusArpGetUDIDDirected0x3fUDID Property

Get UDID (Directed: 0x3f): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x3fUDID { get; }
Public ReadOnly Property GetUDIDDirected0x3fUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x3fUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x3fUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x40SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x40SlaveAddress Property

Get UDID (Directed: 0x40): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x40SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x40SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x40SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x40SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x40UDID Property

IRD

SmbusArpGetUDIDDirected0x40UDID Property

Get UDID (Directed: 0x40): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x40UDID { get; }
Public ReadOnly Property GetUDIDDirected0x40UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x40UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x40UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x41SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x41SlaveAddress Property

Get UDID (Directed: 0x41): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x41SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x41SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x41SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x41SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x41UDID Property

IRD

SmbusArpGetUDIDDirected0x41UDID Property

Get UDID (Directed: 0x41): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x41UDID { get; }
Public ReadOnly Property GetUDIDDirected0x41UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x41UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x41UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x42SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x42SlaveAddress Property

Get UDID (Directed: 0x42): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x42SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x42SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x42SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x42SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x42UDID Property

IRD

SmbusArpGetUDIDDirected0x42UDID Property

Get UDID (Directed: 0x42): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x42UDID { get; }
Public ReadOnly Property GetUDIDDirected0x42UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x42UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x42UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x43SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x43SlaveAddress Property

Get UDID (Directed: 0x43): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x43SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x43SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x43SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x43SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x43UDID Property

IRD

SmbusArpGetUDIDDirected0x43UDID Property

Get UDID (Directed: 0x43): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x43UDID { get; }
Public ReadOnly Property GetUDIDDirected0x43UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x43UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x43UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x44SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x44SlaveAddress Property

Get UDID (Directed: 0x44): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x44SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x44SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x44SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x44SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x44UDID Property

IRD

SmbusArpGetUDIDDirected0x44UDID Property

Get UDID (Directed: 0x44): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x44UDID { get; }
Public ReadOnly Property GetUDIDDirected0x44UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x44UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x44UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x45SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x45SlaveAddress Property

Get UDID (Directed: 0x45): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x45SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x45SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x45SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x45SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x45UDID Property

IRD

SmbusArpGetUDIDDirected0x45UDID Property

Get UDID (Directed: 0x45): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x45UDID { get; }
Public ReadOnly Property GetUDIDDirected0x45UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x45UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x45UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x46SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x46SlaveAddress Property

Get UDID (Directed: 0x46): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x46SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x46SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x46SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x46SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x46UDID Property

IRD

SmbusArpGetUDIDDirected0x46UDID Property

Get UDID (Directed: 0x46): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x46UDID { get; }
Public ReadOnly Property GetUDIDDirected0x46UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x46UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x46UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x47SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x47SlaveAddress Property

Get UDID (Directed: 0x47): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x47SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x47SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x47SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x47SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x47UDID Property

IRD

SmbusArpGetUDIDDirected0x47UDID Property

Get UDID (Directed: 0x47): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x47UDID { get; }
Public ReadOnly Property GetUDIDDirected0x47UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x47UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x47UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x48SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x48SlaveAddress Property

Get UDID (Directed: 0x48): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x48SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x48SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x48SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x48SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x48UDID Property

IRD

SmbusArpGetUDIDDirected0x48UDID Property

Get UDID (Directed: 0x48): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x48UDID { get; }
Public ReadOnly Property GetUDIDDirected0x48UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x48UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x48UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x49SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x49SlaveAddress Property

Get UDID (Directed: 0x49): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x49SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x49SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x49SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x49SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x49UDID Property

IRD

SmbusArpGetUDIDDirected0x49UDID Property

Get UDID (Directed: 0x49): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x49UDID { get; }
Public ReadOnly Property GetUDIDDirected0x49UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x49UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x49UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x4aSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x4aSlaveAddress Property

Get UDID (Directed: 0x4a): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x4aSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x4aSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x4aSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x4aSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x4aUDID Property

IRD

SmbusArpGetUDIDDirected0x4aUDID Property

Get UDID (Directed: 0x4a): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x4aUDID { get; }
Public ReadOnly Property GetUDIDDirected0x4aUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x4aUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x4aUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x4bSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x4bSlaveAddress Property

Get UDID (Directed: 0x4b): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x4bSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x4bSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x4bSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x4bSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x4bUDID Property

IRD

SmbusArpGetUDIDDirected0x4bUDID Property

Get UDID (Directed: 0x4b): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x4bUDID { get; }
Public ReadOnly Property GetUDIDDirected0x4bUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x4bUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x4bUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x4cSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x4cSlaveAddress Property

Get UDID (Directed: 0x4c): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x4cSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x4cSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x4cSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x4cSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x4cUDID Property

IRD

SmbusArpGetUDIDDirected0x4cUDID Property

Get UDID (Directed: 0x4c): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x4cUDID { get; }
Public ReadOnly Property GetUDIDDirected0x4cUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x4cUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x4cUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x4dSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x4dSlaveAddress Property

Get UDID (Directed: 0x4d): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x4dSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x4dSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x4dSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x4dSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x4dUDID Property

IRD

SmbusArpGetUDIDDirected0x4dUDID Property

Get UDID (Directed: 0x4d): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x4dUDID { get; }
Public ReadOnly Property GetUDIDDirected0x4dUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x4dUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x4dUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x4eSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x4eSlaveAddress Property

Get UDID (Directed: 0x4e): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x4eSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x4eSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x4eSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x4eSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x4eUDID Property

IRD

SmbusArpGetUDIDDirected0x4eUDID Property

Get UDID (Directed: 0x4e): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x4eUDID { get; }
Public ReadOnly Property GetUDIDDirected0x4eUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x4eUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x4eUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x4fSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x4fSlaveAddress Property

Get UDID (Directed: 0x4f): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x4fSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x4fSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x4fSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x4fSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x4fUDID Property

IRD

SmbusArpGetUDIDDirected0x4fUDID Property

Get UDID (Directed: 0x4f): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x4fUDID { get; }
Public ReadOnly Property GetUDIDDirected0x4fUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x4fUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x4fUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x50SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x50SlaveAddress Property

Get UDID (Directed: 0x50): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x50SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x50SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x50SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x50SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x50UDID Property

IRD

SmbusArpGetUDIDDirected0x50UDID Property

Get UDID (Directed: 0x50): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x50UDID { get; }
Public ReadOnly Property GetUDIDDirected0x50UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x50UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x50UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x51SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x51SlaveAddress Property

Get UDID (Directed: 0x51): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x51SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x51SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x51SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x51SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x51UDID Property

IRD

SmbusArpGetUDIDDirected0x51UDID Property

Get UDID (Directed: 0x51): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x51UDID { get; }
Public ReadOnly Property GetUDIDDirected0x51UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x51UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x51UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x52SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x52SlaveAddress Property

Get UDID (Directed: 0x52): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x52SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x52SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x52SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x52SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x52UDID Property

IRD

SmbusArpGetUDIDDirected0x52UDID Property

Get UDID (Directed: 0x52): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x52UDID { get; }
Public ReadOnly Property GetUDIDDirected0x52UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x52UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x52UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x53SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x53SlaveAddress Property

Get UDID (Directed: 0x53): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x53SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x53SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x53SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x53SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x53UDID Property

IRD

SmbusArpGetUDIDDirected0x53UDID Property

Get UDID (Directed: 0x53): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x53UDID { get; }
Public ReadOnly Property GetUDIDDirected0x53UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x53UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x53UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x54SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x54SlaveAddress Property

Get UDID (Directed: 0x54): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x54SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x54SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x54SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x54SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x54UDID Property

IRD

SmbusArpGetUDIDDirected0x54UDID Property

Get UDID (Directed: 0x54): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x54UDID { get; }
Public ReadOnly Property GetUDIDDirected0x54UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x54UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x54UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x55SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x55SlaveAddress Property

Get UDID (Directed: 0x55): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x55SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x55SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x55SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x55SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x55UDID Property

IRD

SmbusArpGetUDIDDirected0x55UDID Property

Get UDID (Directed: 0x55): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x55UDID { get; }
Public ReadOnly Property GetUDIDDirected0x55UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x55UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x55UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x56SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x56SlaveAddress Property

Get UDID (Directed: 0x56): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x56SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x56SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x56SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x56SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x56UDID Property

IRD

SmbusArpGetUDIDDirected0x56UDID Property

Get UDID (Directed: 0x56): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x56UDID { get; }
Public ReadOnly Property GetUDIDDirected0x56UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x56UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x56UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x57SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x57SlaveAddress Property

Get UDID (Directed: 0x57): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x57SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x57SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x57SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x57SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x57UDID Property

IRD

SmbusArpGetUDIDDirected0x57UDID Property

Get UDID (Directed: 0x57): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x57UDID { get; }
Public ReadOnly Property GetUDIDDirected0x57UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x57UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x57UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x58SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x58SlaveAddress Property

Get UDID (Directed: 0x58): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x58SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x58SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x58SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x58SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x58UDID Property

IRD

SmbusArpGetUDIDDirected0x58UDID Property

Get UDID (Directed: 0x58): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x58UDID { get; }
Public ReadOnly Property GetUDIDDirected0x58UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x58UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x58UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x59SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x59SlaveAddress Property

Get UDID (Directed: 0x59): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x59SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x59SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x59SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x59SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x59UDID Property

IRD

SmbusArpGetUDIDDirected0x59UDID Property

Get UDID (Directed: 0x59): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x59UDID { get; }
Public ReadOnly Property GetUDIDDirected0x59UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x59UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x59UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x5aSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x5aSlaveAddress Property

Get UDID (Directed: 0x5a): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x5aSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x5aSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x5aSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x5aSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x5aUDID Property

IRD

SmbusArpGetUDIDDirected0x5aUDID Property

Get UDID (Directed: 0x5a): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x5aUDID { get; }
Public ReadOnly Property GetUDIDDirected0x5aUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x5aUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x5aUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x5bSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x5bSlaveAddress Property

Get UDID (Directed: 0x5b): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x5bSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x5bSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x5bSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x5bSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x5bUDID Property

IRD

SmbusArpGetUDIDDirected0x5bUDID Property

Get UDID (Directed: 0x5b): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x5bUDID { get; }
Public ReadOnly Property GetUDIDDirected0x5bUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x5bUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x5bUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x5cSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x5cSlaveAddress Property

Get UDID (Directed: 0x5c): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x5cSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x5cSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x5cSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x5cSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x5cUDID Property

IRD

SmbusArpGetUDIDDirected0x5cUDID Property

Get UDID (Directed: 0x5c): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x5cUDID { get; }
Public ReadOnly Property GetUDIDDirected0x5cUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x5cUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x5cUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x5dSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x5dSlaveAddress Property

Get UDID (Directed: 0x5d): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x5dSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x5dSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x5dSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x5dSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x5dUDID Property

IRD

SmbusArpGetUDIDDirected0x5dUDID Property

Get UDID (Directed: 0x5d): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x5dUDID { get; }
Public ReadOnly Property GetUDIDDirected0x5dUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x5dUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x5dUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x5eSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x5eSlaveAddress Property

Get UDID (Directed: 0x5e): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x5eSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x5eSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x5eSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x5eSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x5eUDID Property

IRD

SmbusArpGetUDIDDirected0x5eUDID Property

Get UDID (Directed: 0x5e): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x5eUDID { get; }
Public ReadOnly Property GetUDIDDirected0x5eUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x5eUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x5eUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x5fSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x5fSlaveAddress Property

Get UDID (Directed: 0x5f): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x5fSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x5fSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x5fSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x5fSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x5fUDID Property

IRD

SmbusArpGetUDIDDirected0x5fUDID Property

Get UDID (Directed: 0x5f): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x5fUDID { get; }
Public ReadOnly Property GetUDIDDirected0x5fUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x5fUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x5fUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x60SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x60SlaveAddress Property

Get UDID (Directed: 0x60): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x60SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x60SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x60SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x60SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x60UDID Property

IRD

SmbusArpGetUDIDDirected0x60UDID Property

Get UDID (Directed: 0x60): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x60UDID { get; }
Public ReadOnly Property GetUDIDDirected0x60UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x60UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x60UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x61SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x61SlaveAddress Property

Get UDID (Directed: 0x61): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x61SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x61SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x61SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x61SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x61UDID Property

IRD

SmbusArpGetUDIDDirected0x61UDID Property

Get UDID (Directed: 0x61): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x61UDID { get; }
Public ReadOnly Property GetUDIDDirected0x61UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x61UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x61UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x62SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x62SlaveAddress Property

Get UDID (Directed: 0x62): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x62SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x62SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x62SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x62SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x62UDID Property

IRD

SmbusArpGetUDIDDirected0x62UDID Property

Get UDID (Directed: 0x62): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x62UDID { get; }
Public ReadOnly Property GetUDIDDirected0x62UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x62UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x62UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x63SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x63SlaveAddress Property

Get UDID (Directed: 0x63): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x63SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x63SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x63SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x63SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x63UDID Property

IRD

SmbusArpGetUDIDDirected0x63UDID Property

Get UDID (Directed: 0x63): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x63UDID { get; }
Public ReadOnly Property GetUDIDDirected0x63UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x63UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x63UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x64SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x64SlaveAddress Property

Get UDID (Directed: 0x64): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x64SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x64SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x64SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x64SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x64UDID Property

IRD

SmbusArpGetUDIDDirected0x64UDID Property

Get UDID (Directed: 0x64): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x64UDID { get; }
Public ReadOnly Property GetUDIDDirected0x64UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x64UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x64UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x65SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x65SlaveAddress Property

Get UDID (Directed: 0x65): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x65SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x65SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x65SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x65SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x65UDID Property

IRD

SmbusArpGetUDIDDirected0x65UDID Property

Get UDID (Directed: 0x65): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x65UDID { get; }
Public ReadOnly Property GetUDIDDirected0x65UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x65UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x65UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x66SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x66SlaveAddress Property

Get UDID (Directed: 0x66): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x66SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x66SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x66SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x66SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x66UDID Property

IRD

SmbusArpGetUDIDDirected0x66UDID Property

Get UDID (Directed: 0x66): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x66UDID { get; }
Public ReadOnly Property GetUDIDDirected0x66UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x66UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x66UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x67SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x67SlaveAddress Property

Get UDID (Directed: 0x67): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x67SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x67SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x67SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x67SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x67UDID Property

IRD

SmbusArpGetUDIDDirected0x67UDID Property

Get UDID (Directed: 0x67): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x67UDID { get; }
Public ReadOnly Property GetUDIDDirected0x67UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x67UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x67UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x68SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x68SlaveAddress Property

Get UDID (Directed: 0x68): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x68SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x68SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x68SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x68SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x68UDID Property

IRD

SmbusArpGetUDIDDirected0x68UDID Property

Get UDID (Directed: 0x68): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x68UDID { get; }
Public ReadOnly Property GetUDIDDirected0x68UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x68UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x68UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x69SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x69SlaveAddress Property

Get UDID (Directed: 0x69): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x69SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x69SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x69SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x69SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x69UDID Property

IRD

SmbusArpGetUDIDDirected0x69UDID Property

Get UDID (Directed: 0x69): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x69UDID { get; }
Public ReadOnly Property GetUDIDDirected0x69UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x69UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x69UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x6aSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x6aSlaveAddress Property

Get UDID (Directed: 0x6a): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x6aSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x6aSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x6aSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x6aSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x6aUDID Property

IRD

SmbusArpGetUDIDDirected0x6aUDID Property

Get UDID (Directed: 0x6a): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x6aUDID { get; }
Public ReadOnly Property GetUDIDDirected0x6aUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x6aUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x6aUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x6bSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x6bSlaveAddress Property

Get UDID (Directed: 0x6b): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x6bSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x6bSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x6bSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x6bSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x6bUDID Property

IRD

SmbusArpGetUDIDDirected0x6bUDID Property

Get UDID (Directed: 0x6b): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x6bUDID { get; }
Public ReadOnly Property GetUDIDDirected0x6bUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x6bUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x6bUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x6cSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x6cSlaveAddress Property

Get UDID (Directed: 0x6c): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x6cSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x6cSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x6cSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x6cSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x6cUDID Property

IRD

SmbusArpGetUDIDDirected0x6cUDID Property

Get UDID (Directed: 0x6c): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x6cUDID { get; }
Public ReadOnly Property GetUDIDDirected0x6cUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x6cUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x6cUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x6dSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x6dSlaveAddress Property

Get UDID (Directed: 0x6d): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x6dSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x6dSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x6dSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x6dSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x6dUDID Property

IRD

SmbusArpGetUDIDDirected0x6dUDID Property

Get UDID (Directed: 0x6d): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x6dUDID { get; }
Public ReadOnly Property GetUDIDDirected0x6dUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x6dUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x6dUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x6eSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x6eSlaveAddress Property

Get UDID (Directed: 0x6e): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x6eSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x6eSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x6eSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x6eSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x6eUDID Property

IRD

SmbusArpGetUDIDDirected0x6eUDID Property

Get UDID (Directed: 0x6e): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x6eUDID { get; }
Public ReadOnly Property GetUDIDDirected0x6eUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x6eUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x6eUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x6fSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x6fSlaveAddress Property

Get UDID (Directed: 0x6f): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x6fSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x6fSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x6fSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x6fSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x6fUDID Property

IRD

SmbusArpGetUDIDDirected0x6fUDID Property

Get UDID (Directed: 0x6f): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x6fUDID { get; }
Public ReadOnly Property GetUDIDDirected0x6fUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x6fUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x6fUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x70SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x70SlaveAddress Property

Get UDID (Directed: 0x70): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x70SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x70SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x70SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x70SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x70UDID Property

IRD

SmbusArpGetUDIDDirected0x70UDID Property

Get UDID (Directed: 0x70): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x70UDID { get; }
Public ReadOnly Property GetUDIDDirected0x70UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x70UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x70UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x71SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x71SlaveAddress Property

Get UDID (Directed: 0x71): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x71SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x71SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x71SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x71SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x71UDID Property

IRD

SmbusArpGetUDIDDirected0x71UDID Property

Get UDID (Directed: 0x71): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x71UDID { get; }
Public ReadOnly Property GetUDIDDirected0x71UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x71UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x71UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x72SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x72SlaveAddress Property

Get UDID (Directed: 0x72): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x72SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x72SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x72SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x72SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x72UDID Property

IRD

SmbusArpGetUDIDDirected0x72UDID Property

Get UDID (Directed: 0x72): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x72UDID { get; }
Public ReadOnly Property GetUDIDDirected0x72UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x72UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x72UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x73SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x73SlaveAddress Property

Get UDID (Directed: 0x73): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x73SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x73SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x73SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x73SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x73UDID Property

IRD

SmbusArpGetUDIDDirected0x73UDID Property

Get UDID (Directed: 0x73): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x73UDID { get; }
Public ReadOnly Property GetUDIDDirected0x73UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x73UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x73UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x74SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x74SlaveAddress Property

Get UDID (Directed: 0x74): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x74SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x74SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x74SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x74SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x74UDID Property

IRD

SmbusArpGetUDIDDirected0x74UDID Property

Get UDID (Directed: 0x74): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x74UDID { get; }
Public ReadOnly Property GetUDIDDirected0x74UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x74UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x74UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x75SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x75SlaveAddress Property

Get UDID (Directed: 0x75): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x75SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x75SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x75SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x75SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x75UDID Property

IRD

SmbusArpGetUDIDDirected0x75UDID Property

Get UDID (Directed: 0x75): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x75UDID { get; }
Public ReadOnly Property GetUDIDDirected0x75UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x75UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x75UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x76SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x76SlaveAddress Property

Get UDID (Directed: 0x76): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x76SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x76SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x76SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x76SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x76UDID Property

IRD

SmbusArpGetUDIDDirected0x76UDID Property

Get UDID (Directed: 0x76): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x76UDID { get; }
Public ReadOnly Property GetUDIDDirected0x76UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x76UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x76UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x77SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x77SlaveAddress Property

Get UDID (Directed: 0x77): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x77SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x77SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x77SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x77SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x77UDID Property

IRD

SmbusArpGetUDIDDirected0x77UDID Property

Get UDID (Directed: 0x77): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x77UDID { get; }
Public ReadOnly Property GetUDIDDirected0x77UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x77UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x77UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x78SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x78SlaveAddress Property

Get UDID (Directed: 0x78): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x78SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x78SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x78SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x78SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x78UDID Property

IRD

SmbusArpGetUDIDDirected0x78UDID Property

Get UDID (Directed: 0x78): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x78UDID { get; }
Public ReadOnly Property GetUDIDDirected0x78UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x78UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x78UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x79SlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x79SlaveAddress Property

Get UDID (Directed: 0x79): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x79SlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x79SlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x79SlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x79SlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x79UDID Property

IRD

SmbusArpGetUDIDDirected0x79UDID Property

Get UDID (Directed: 0x79): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x79UDID { get; }
Public ReadOnly Property GetUDIDDirected0x79UDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x79UDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x79UDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x7aSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x7aSlaveAddress Property

Get UDID (Directed: 0x7a): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x7aSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x7aSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x7aSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x7aSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x7aUDID Property

IRD

SmbusArpGetUDIDDirected0x7aUDID Property

Get UDID (Directed: 0x7a): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x7aUDID { get; }
Public ReadOnly Property GetUDIDDirected0x7aUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x7aUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x7aUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x7bSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x7bSlaveAddress Property

Get UDID (Directed: 0x7b): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x7bSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x7bSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x7bSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x7bSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x7bUDID Property

IRD

SmbusArpGetUDIDDirected0x7bUDID Property

Get UDID (Directed: 0x7b): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x7bUDID { get; }
Public ReadOnly Property GetUDIDDirected0x7bUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x7bUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x7bUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x7cSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x7cSlaveAddress Property

Get UDID (Directed: 0x7c): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x7cSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x7cSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x7cSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x7cSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x7cUDID Property

IRD

SmbusArpGetUDIDDirected0x7cUDID Property

Get UDID (Directed: 0x7c): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x7cUDID { get; }
Public ReadOnly Property GetUDIDDirected0x7cUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x7cUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x7cUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x7dSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x7dSlaveAddress Property

Get UDID (Directed: 0x7d): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x7dSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x7dSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x7dSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x7dSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x7dUDID Property

IRD

SmbusArpGetUDIDDirected0x7dUDID Property

Get UDID (Directed: 0x7d): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x7dUDID { get; }
Public ReadOnly Property GetUDIDDirected0x7dUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x7dUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x7dUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x7eSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x7eSlaveAddress Property

Get UDID (Directed: 0x7e): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x7eSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x7eSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x7eSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x7eSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x7eUDID Property

IRD

SmbusArpGetUDIDDirected0x7eUDID Property

Get UDID (Directed: 0x7e): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x7eUDID { get; }
Public ReadOnly Property GetUDIDDirected0x7eUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x7eUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x7eUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x7fSlaveAddress Property

IRD

SmbusArpGetUDIDDirected0x7fSlaveAddress Property

Get UDID (Directed: 0x7f): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDDirected0x7fSlaveAddress { get; }
Public ReadOnly Property GetUDIDDirected0x7fSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDDirected0x7fSlaveAddress {
    unsigned char get ();
}
member GetUDIDDirected0x7fSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDDirected0x7fUDID Property

IRD

SmbusArpGetUDIDDirected0x7fUDID Property

Get UDID (Directed: 0x7f): UDID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetUDIDDirected0x7fUDID { get; }
Public ReadOnly Property GetUDIDDirected0x7fUDID As Byte()
    Get
public:
property array<unsigned char>^ GetUDIDDirected0x7fUDID {
    array<unsigned char>^ get ();
}
member GetUDIDDirected0x7fUDID : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDGeneralAddressType Property

IRD

SmbusArpGetUDIDGeneralAddressType Property

Get UDID (General): Address Type

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SmbusArpTypeAddress GetUDIDGeneralAddressType { get; }
Public ReadOnly Property GetUDIDGeneralAddressType As SmbusArpTypeAddress
    Get
public:
property SmbusArpTypeAddress GetUDIDGeneralAddressType {
    SmbusArpTypeAddress get ();
}
member GetUDIDGeneralAddressType : SmbusArpTypeAddress with get

Property Value

Type: SmbusArpTypeAddress
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDGeneralDeviceID Property

IRD

SmbusArpGetUDIDGeneralDeviceID Property

Get UDID (General): Device ID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort GetUDIDGeneralDeviceID { get; }
Public ReadOnly Property GetUDIDGeneralDeviceID As UShort
    Get
public:
property unsigned short GetUDIDGeneralDeviceID {
    unsigned short get ();
}
member GetUDIDGeneralDeviceID : uint16 with get

Property Value

Type: UInt16
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDGeneralPEC Property

IRD

SmbusArpGetUDIDGeneralPEC Property

Get UDID (General): PEC

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SmbusArpTypeSupported GetUDIDGeneralPEC { get; }
Public ReadOnly Property GetUDIDGeneralPEC As SmbusArpTypeSupported
    Get
public:
property SmbusArpTypeSupported GetUDIDGeneralPEC {
    SmbusArpTypeSupported get ();
}
member GetUDIDGeneralPEC : SmbusArpTypeSupported with get

Property Value

Type: SmbusArpTypeSupported
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDGeneralSiliconRevisionID Property

IRD

SmbusArpGetUDIDGeneralSiliconRevisionID Property

Get UDID (General): Silicon Revision ID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDGeneralSiliconRevisionID { get; }
Public ReadOnly Property GetUDIDGeneralSiliconRevisionID As Byte
    Get
public:
property unsigned char GetUDIDGeneralSiliconRevisionID {
    unsigned char get ();
}
member GetUDIDGeneralSiliconRevisionID : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDGeneralSlaveAddress Property

IRD

SmbusArpGetUDIDGeneralSlaveAddress Property

Get UDID (General): Slave Address

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetUDIDGeneralSlaveAddress { get; }
Public ReadOnly Property GetUDIDGeneralSlaveAddress As Byte
    Get
public:
property unsigned char GetUDIDGeneralSlaveAddress {
    unsigned char get ();
}
member GetUDIDGeneralSlaveAddress : byte with get

Property Value

Type: Byte
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDGeneralSMBusVersion Property

IRD

SmbusArpGetUDIDGeneralSMBusVersion Property

Get UDID (General): SMBus Version

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SmbusArpTypeSmbusVersion GetUDIDGeneralSMBusVersion { get; }
Public ReadOnly Property GetUDIDGeneralSMBusVersion As SmbusArpTypeSmbusVersion
    Get
public:
property SmbusArpTypeSmbusVersion GetUDIDGeneralSMBusVersion {
    SmbusArpTypeSmbusVersion get ();
}
member GetUDIDGeneralSMBusVersion : SmbusArpTypeSmbusVersion with get

Property Value

Type: SmbusArpTypeSmbusVersion
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDGeneralSubsystemDeviceID Property

IRD

SmbusArpGetUDIDGeneralSubsystemDeviceID Property

Get UDID (General): Subsystem Device ID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort GetUDIDGeneralSubsystemDeviceID { get; }
Public ReadOnly Property GetUDIDGeneralSubsystemDeviceID As UShort
    Get
public:
property unsigned short GetUDIDGeneralSubsystemDeviceID {
    unsigned short get ();
}
member GetUDIDGeneralSubsystemDeviceID : uint16 with get

Property Value

Type: UInt16
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDGeneralSubsystemVendorID Property

IRD

SmbusArpGetUDIDGeneralSubsystemVendorID Property

Get UDID (General): Subsystem Vendor ID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort GetUDIDGeneralSubsystemVendorID { get; }
Public ReadOnly Property GetUDIDGeneralSubsystemVendorID As UShort
    Get
public:
property unsigned short GetUDIDGeneralSubsystemVendorID {
    unsigned short get ();
}
member GetUDIDGeneralSubsystemVendorID : uint16 with get

Property Value

Type: UInt16
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDGeneralSupportedProtocolsASF Property

IRD

SmbusArpGetUDIDGeneralSupportedProtocolsASF Property

Get UDID (General): Supported Protocols: ASF

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SmbusArpTypeSupported GetUDIDGeneralSupportedProtocolsASF { get; }
Public ReadOnly Property GetUDIDGeneralSupportedProtocolsASF As SmbusArpTypeSupported
    Get
public:
property SmbusArpTypeSupported GetUDIDGeneralSupportedProtocolsASF {
    SmbusArpTypeSupported get ();
}
member GetUDIDGeneralSupportedProtocolsASF : SmbusArpTypeSupported with get

Property Value

Type: SmbusArpTypeSupported
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDGeneralSupportedProtocolsIPMI Property

IRD

SmbusArpGetUDIDGeneralSupportedProtocolsIPMI Property

Get UDID (General): Supported Protocols: IPMI

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SmbusArpTypeSupported GetUDIDGeneralSupportedProtocolsIPMI { get; }
Public ReadOnly Property GetUDIDGeneralSupportedProtocolsIPMI As SmbusArpTypeSupported
    Get
public:
property SmbusArpTypeSupported GetUDIDGeneralSupportedProtocolsIPMI {
    SmbusArpTypeSupported get ();
}
member GetUDIDGeneralSupportedProtocolsIPMI : SmbusArpTypeSupported with get

Property Value

Type: SmbusArpTypeSupported
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDGeneralSupportedProtocolsOEM Property

IRD

SmbusArpGetUDIDGeneralSupportedProtocolsOEM Property

Get UDID (General): Supported Protocols: OEM

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SmbusArpTypeSupported GetUDIDGeneralSupportedProtocolsOEM { get; }
Public ReadOnly Property GetUDIDGeneralSupportedProtocolsOEM As SmbusArpTypeSupported
    Get
public:
property SmbusArpTypeSupported GetUDIDGeneralSupportedProtocolsOEM {
    SmbusArpTypeSupported get ();
}
member GetUDIDGeneralSupportedProtocolsOEM : SmbusArpTypeSupported with get

Property Value

Type: SmbusArpTypeSupported
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDGeneralSupportedProtocolsZONE Property

IRD

SmbusArpGetUDIDGeneralSupportedProtocolsZONE Property

Get UDID (General): Supported Protocols: ZONE

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SmbusArpTypeSupported GetUDIDGeneralSupportedProtocolsZONE { get; }
Public ReadOnly Property GetUDIDGeneralSupportedProtocolsZONE As SmbusArpTypeSupported
    Get
public:
property SmbusArpTypeSupported GetUDIDGeneralSupportedProtocolsZONE {
    SmbusArpTypeSupported get ();
}
member GetUDIDGeneralSupportedProtocolsZONE : SmbusArpTypeSupported with get

Property Value

Type: SmbusArpTypeSupported
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDGeneralUDIDVersion Property

IRD

SmbusArpGetUDIDGeneralUDIDVersion Property

Get UDID (General): UDID Version

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public SmbusArpTypeUdidVersion GetUDIDGeneralUDIDVersion { get; }
Public ReadOnly Property GetUDIDGeneralUDIDVersion As SmbusArpTypeUdidVersion
    Get
public:
property SmbusArpTypeUdidVersion GetUDIDGeneralUDIDVersion {
    SmbusArpTypeUdidVersion get ();
}
member GetUDIDGeneralUDIDVersion : SmbusArpTypeUdidVersion with get

Property Value

Type: SmbusArpTypeUdidVersion
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDGeneralVendorID Property

IRD

SmbusArpGetUDIDGeneralVendorID Property

Get UDID (General): Vendor ID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort GetUDIDGeneralVendorID { get; }
Public ReadOnly Property GetUDIDGeneralVendorID As UShort
    Get
public:
property unsigned short GetUDIDGeneralVendorID {
    unsigned short get ();
}
member GetUDIDGeneralVendorID : uint16 with get

Property Value

Type: UInt16
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.GetUDIDGeneralVendorSpecificID Property

IRD

SmbusArpGetUDIDGeneralVendorSpecificID Property

Get UDID (General): Vendor Specific ID

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint GetUDIDGeneralVendorSpecificID { get; }
Public ReadOnly Property GetUDIDGeneralVendorSpecificID As UInteger
    Get
public:
property unsigned int GetUDIDGeneralVendorSpecificID {
    unsigned int get ();
}
member GetUDIDGeneralVendorSpecificID : uint32 with get

Property Value

Type: UInt32
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp Methods

The SmbusArp type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareARP | Prepare ARP
Public method | ResetDeviceDirected0x03 | Reset Device (Directed: 0x03)
Public method | ResetDeviceDirected0x04 | Reset Device (Directed: 0x04)
Public method | ResetDeviceDirected0x05 | Reset Device (Directed: 0x05)
Public method | ResetDeviceDirected0x06 | Reset Device (Directed: 0x06)
Public method | ResetDeviceDirected0x07 | Reset Device (Directed: 0x07)
Public method | ResetDeviceDirected0x08 | Reset Device (Directed: 0x08)
Public method | ResetDeviceDirected0x09 | Reset Device (Directed: 0x09)
Public method | ResetDeviceDirected0x0a | Reset Device (Directed: 0x0a)
Public method | ResetDeviceDirected0x0b | Reset Device (Directed: 0x0b)
Public method | ResetDeviceDirected0x0c | Reset Device (Directed: 0x0c)
Public method | ResetDeviceDirected0x0d | Reset Device (Directed: 0x0d)
Public method | ResetDeviceDirected0x0e | Reset Device (Directed: 0x0e)
Public method | ResetDeviceDirected0x0f | Reset Device (Directed: 0x0f)
Public method | ResetDeviceDirected0x10 | Reset Device (Directed: 0x10)
Public method | ResetDeviceDirected0x11 | Reset Device (Directed: 0x11)
Public method | ResetDeviceDirected0x12 | Reset Device (Directed: 0x12)
Public method | ResetDeviceDirected0x13 | Reset Device (Directed: 0x13)
Public method | ResetDeviceDirected0x14 | Reset Device (Directed: 0x14)
Public method | ResetDeviceDirected0x15 | Reset Device (Directed: 0x15)
Public method | ResetDeviceDirected0x16 | Reset Device (Directed: 0x16)
Public method | ResetDeviceDirected0x17 | Reset Device (Directed: 0x17)
Public method | ResetDeviceDirected0x18 | Reset Device (Directed: 0x18)
Public method | ResetDeviceDirected0x19 | Reset Device (Directed: 0x19)
Public method | ResetDeviceDirected0x1a | Reset Device (Directed: 0x1a)
Public method | ResetDeviceDirected0x1b | Reset Device (Directed: 0x1b)
Public method | ResetDeviceDirected0x1c | Reset Device (Directed: 0x1c)
Public method | ResetDeviceDirected0x1d | Reset Device (Directed: 0x1d)
Public method | ResetDeviceDirected0x1e | Reset Device (Directed: 0x1e)
Public method | ResetDeviceDirected0x1f | Reset Device (Directed: 0x1f)
Public method | ResetDeviceDirected0x20 | Reset Device (Directed: 0x20)
Public method | ResetDeviceDirected0x21 | Reset Device (Directed: 0x21)
Public method | ResetDeviceDirected0x22 | Reset Device (Directed: 0x22)
Public method | ResetDeviceDirected0x23 | Reset Device (Directed: 0x23)
Public method | ResetDeviceDirected0x24 | Reset Device (Directed: 0x24)
Public method | ResetDeviceDirected0x25 | Reset Device (Directed: 0x25)
Public method | ResetDeviceDirected0x26 | Reset Device (Directed: 0x26)
Public method | ResetDeviceDirected0x27 | Reset Device (Directed: 0x27)
Public method | ResetDeviceDirected0x28 | Reset Device (Directed: 0x28)
Public method | ResetDeviceDirected0x29 | Reset Device (Directed: 0x29)
Public method | ResetDeviceDirected0x2a | Reset Device (Directed: 0x2a)
Public method | ResetDeviceDirected0x2b | Reset Device (Directed: 0x2b)
Public method | ResetDeviceDirected0x2c | Reset Device (Directed: 0x2c)
Public method | ResetDeviceDirected0x2d | Reset Device (Directed: 0x2d)
Public method | ResetDeviceDirected0x2e | Reset Device (Directed: 0x2e)
Public method | ResetDeviceDirected0x2f | Reset Device (Directed: 0x2f)
Public method | ResetDeviceDirected0x30 | Reset Device (Directed: 0x30)
Public method | ResetDeviceDirected0x31 | Reset Device (Directed: 0x31)
Public method | ResetDeviceDirected0x32 | Reset Device (Directed: 0x32)
Public method | ResetDeviceDirected0x33 | Reset Device (Directed: 0x33)
Public method | ResetDeviceDirected0x34 | Reset Device (Directed: 0x34)
Public method | ResetDeviceDirected0x35 | Reset Device (Directed: 0x35)
Public method | ResetDeviceDirected0x36 | Reset Device (Directed: 0x36)
Public method | ResetDeviceDirected0x37 | Reset Device (Directed: 0x37)
Public method | ResetDeviceDirected0x38 | Reset Device (Directed: 0x38)
Public method | ResetDeviceDirected0x39 | Reset Device (Directed: 0x39)
Public method | ResetDeviceDirected0x3a | Reset Device (Directed: 0x3a)
Public method | ResetDeviceDirected0x3b | Reset Device (Directed: 0x3b)
Public method | ResetDeviceDirected0x3c | Reset Device (Directed: 0x3c)
Public method | ResetDeviceDirected0x3d | Reset Device (Directed: 0x3d)
Public method | ResetDeviceDirected0x3e | Reset Device (Directed: 0x3e)
Public method | ResetDeviceDirected0x3f | Reset Device (Directed: 0x3f)
Public method | ResetDeviceDirected0x40 | Reset Device (Directed: 0x40)
Public method | ResetDeviceDirected0x41 | Reset Device (Directed: 0x41)
Public method | ResetDeviceDirected0x42 | Reset Device (Directed: 0x42)
Public method | ResetDeviceDirected0x43 | Reset Device (Directed: 0x43)
Public method | ResetDeviceDirected0x44 | Reset Device (Directed: 0x44)
Public method | ResetDeviceDirected0x45 | Reset Device (Directed: 0x45)
Public method | ResetDeviceDirected0x46 | Reset Device (Directed: 0x46)
Public method | ResetDeviceDirected0x47 | Reset Device (Directed: 0x47)
Public method | ResetDeviceDirected0x48 | Reset Device (Directed: 0x48)
Public method | ResetDeviceDirected0x49 | Reset Device (Directed: 0x49)
Public method | ResetDeviceDirected0x4a | Reset Device (Directed: 0x4a)
Public method | ResetDeviceDirected0x4b | Reset Device (Directed: 0x4b)
Public method | ResetDeviceDirected0x4c | Reset Device (Directed: 0x4c)
Public method | ResetDeviceDirected0x4d | Reset Device (Directed: 0x4d)
Public method | ResetDeviceDirected0x4e | Reset Device (Directed: 0x4e)
Public method | ResetDeviceDirected0x4f | Reset Device (Directed: 0x4f)
Public method | ResetDeviceDirected0x50 | Reset Device (Directed: 0x50)
Public method | ResetDeviceDirected0x51 | Reset Device (Directed: 0x51)
Public method | ResetDeviceDirected0x52 | Reset Device (Directed: 0x52)
Public method | ResetDeviceDirected0x53 | Reset Device (Directed: 0x53)
Public method | ResetDeviceDirected0x54 | Reset Device (Directed: 0x54)
Public method | ResetDeviceDirected0x55 | Reset Device (Directed: 0x55)
Public method | ResetDeviceDirected0x56 | Reset Device (Directed: 0x56)
Public method | ResetDeviceDirected0x57 | Reset Device (Directed: 0x57)
Public method | ResetDeviceDirected0x58 | Reset Device (Directed: 0x58)
Public method | ResetDeviceDirected0x59 | Reset Device (Directed: 0x59)
Public method | ResetDeviceDirected0x5a | Reset Device (Directed: 0x5a)
Public method | ResetDeviceDirected0x5b | Reset Device (Directed: 0x5b)
Public method | ResetDeviceDirected0x5c | Reset Device (Directed: 0x5c)
Public method | ResetDeviceDirected0x5d | Reset Device (Directed: 0x5d)
Public method | ResetDeviceDirected0x5e | Reset Device (Directed: 0x5e)
Public method | ResetDeviceDirected0x5f | Reset Device (Directed: 0x5f)
Public method | ResetDeviceDirected0x60 | Reset Device (Directed: 0x60)
Public method | ResetDeviceDirected0x61 | Reset Device (Directed: 0x61)
Public method | ResetDeviceDirected0x62 | Reset Device (Directed: 0x62)
Public method | ResetDeviceDirected0x63 | Reset Device (Directed: 0x63)
Public method | ResetDeviceDirected0x64 | Reset Device (Directed: 0x64)
Public method | ResetDeviceDirected0x65 | Reset Device (Directed: 0x65)
Public method | ResetDeviceDirected0x66 | Reset Device (Directed: 0x66)
Public method | ResetDeviceDirected0x67 | Reset Device (Directed: 0x67)
Public method | ResetDeviceDirected0x68 | Reset Device (Directed: 0x68)
Public method | ResetDeviceDirected0x69 | Reset Device (Directed: 0x69)
Public method | ResetDeviceDirected0x6a | Reset Device (Directed: 0x6a)
Public method | ResetDeviceDirected0x6b | Reset Device (Directed: 0x6b)
Public method | ResetDeviceDirected0x6c | Reset Device (Directed: 0x6c)
Public method | ResetDeviceDirected0x6d | Reset Device (Directed: 0x6d)
Public method | ResetDeviceDirected0x6e | Reset Device (Directed: 0x6e)
Public method | ResetDeviceDirected0x6f | Reset Device (Directed: 0x6f)
Public method | ResetDeviceDirected0x70 | Reset Device (Directed: 0x70)
Public method | ResetDeviceDirected0x71 | Reset Device (Directed: 0x71)
Public method | ResetDeviceDirected0x72 | Reset Device (Directed: 0x72)
Public method | ResetDeviceDirected0x73 | Reset Device (Directed: 0x73)
Public method | ResetDeviceDirected0x74 | Reset Device (Directed: 0x74)
Public method | ResetDeviceDirected0x75 | Reset Device (Directed: 0x75)
Public method | ResetDeviceDirected0x76 | Reset Device (Directed: 0x76)
Public method | ResetDeviceDirected0x77 | Reset Device (Directed: 0x77)
Public method | ResetDeviceDirected0x78 | Reset Device (Directed: 0x78)
Public method | ResetDeviceDirected0x79 | Reset Device (Directed: 0x79)
Public method | ResetDeviceDirected0x7a | Reset Device (Directed: 0x7a)
Public method | ResetDeviceDirected0x7b | Reset Device (Directed: 0x7b)
Public method | ResetDeviceDirected0x7c | Reset Device (Directed: 0x7c)
Public method | ResetDeviceDirected0x7d | Reset Device (Directed: 0x7d)
Public method | ResetDeviceDirected0x7e | Reset Device (Directed: 0x7e)
Public method | ResetDeviceDirected0x7f | Reset Device (Directed: 0x7f)
Public method | ResetDeviceGeneral | Reset Device (General)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.Flush Method

IRD

SmbusArpFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.PrepareARP Method

IRD

SmbusArpPrepareARP Method

Prepare ARP

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void PrepareARP()
Public Sub PrepareARP
public:
void PrepareARP()
member PrepareARP : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x03 Method

IRD

SmbusArpResetDeviceDirected0x03 Method

Reset Device (Directed: 0x03)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x03()
Public Sub ResetDeviceDirected0x03
public:
void ResetDeviceDirected0x03()
member ResetDeviceDirected0x03 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x04 Method

IRD

SmbusArpResetDeviceDirected0x04 Method

Reset Device (Directed: 0x04)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x04()
Public Sub ResetDeviceDirected0x04
public:
void ResetDeviceDirected0x04()
member ResetDeviceDirected0x04 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x05 Method

IRD

SmbusArpResetDeviceDirected0x05 Method

Reset Device (Directed: 0x05)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x05()
Public Sub ResetDeviceDirected0x05
public:
void ResetDeviceDirected0x05()
member ResetDeviceDirected0x05 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x06 Method

IRD

SmbusArpResetDeviceDirected0x06 Method

Reset Device (Directed: 0x06)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x06()
Public Sub ResetDeviceDirected0x06
public:
void ResetDeviceDirected0x06()
member ResetDeviceDirected0x06 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x07 Method

IRD

SmbusArpResetDeviceDirected0x07 Method

Reset Device (Directed: 0x07)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x07()
Public Sub ResetDeviceDirected0x07
public:
void ResetDeviceDirected0x07()
member ResetDeviceDirected0x07 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x08 Method

IRD

SmbusArpResetDeviceDirected0x08 Method

Reset Device (Directed: 0x08)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x08()
Public Sub ResetDeviceDirected0x08
public:
void ResetDeviceDirected0x08()
member ResetDeviceDirected0x08 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x09 Method

IRD

SmbusArpResetDeviceDirected0x09 Method

Reset Device (Directed: 0x09)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x09()
Public Sub ResetDeviceDirected0x09
public:
void ResetDeviceDirected0x09()
member ResetDeviceDirected0x09 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x0a Method

IRD

SmbusArpResetDeviceDirected0x0a Method

Reset Device (Directed: 0x0a)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x0a()
Public Sub ResetDeviceDirected0x0a
public:
void ResetDeviceDirected0x0a()
member ResetDeviceDirected0x0a : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x0b Method

IRD

SmbusArpResetDeviceDirected0x0b Method

Reset Device (Directed: 0x0b)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x0b()
Public Sub ResetDeviceDirected0x0b
public:
void ResetDeviceDirected0x0b()
member ResetDeviceDirected0x0b : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x0c Method

IRD

SmbusArpResetDeviceDirected0x0c Method

Reset Device (Directed: 0x0c)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x0c()
Public Sub ResetDeviceDirected0x0c
public:
void ResetDeviceDirected0x0c()
member ResetDeviceDirected0x0c : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x0d Method

IRD

SmbusArpResetDeviceDirected0x0d Method

Reset Device (Directed: 0x0d)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x0d()
Public Sub ResetDeviceDirected0x0d
public:
void ResetDeviceDirected0x0d()
member ResetDeviceDirected0x0d : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x0e Method

IRD

SmbusArpResetDeviceDirected0x0e Method

Reset Device (Directed: 0x0e)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x0e()
Public Sub ResetDeviceDirected0x0e
public:
void ResetDeviceDirected0x0e()
member ResetDeviceDirected0x0e : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x0f Method

IRD

SmbusArpResetDeviceDirected0x0f Method

Reset Device (Directed: 0x0f)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x0f()
Public Sub ResetDeviceDirected0x0f
public:
void ResetDeviceDirected0x0f()
member ResetDeviceDirected0x0f : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x10 Method

IRD

SmbusArpResetDeviceDirected0x10 Method

Reset Device (Directed: 0x10)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x10()
Public Sub ResetDeviceDirected0x10
public:
void ResetDeviceDirected0x10()
member ResetDeviceDirected0x10 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x11 Method

IRD

SmbusArpResetDeviceDirected0x11 Method

Reset Device (Directed: 0x11)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x11()
Public Sub ResetDeviceDirected0x11
public:
void ResetDeviceDirected0x11()
member ResetDeviceDirected0x11 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x12 Method

IRD

SmbusArpResetDeviceDirected0x12 Method

Reset Device (Directed: 0x12)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x12()
Public Sub ResetDeviceDirected0x12
public:
void ResetDeviceDirected0x12()
member ResetDeviceDirected0x12 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x13 Method

IRD

SmbusArpResetDeviceDirected0x13 Method

Reset Device (Directed: 0x13)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x13()
Public Sub ResetDeviceDirected0x13
public:
void ResetDeviceDirected0x13()
member ResetDeviceDirected0x13 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x14 Method

IRD

SmbusArpResetDeviceDirected0x14 Method

Reset Device (Directed: 0x14)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x14()
Public Sub ResetDeviceDirected0x14
public:
void ResetDeviceDirected0x14()
member ResetDeviceDirected0x14 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x15 Method

IRD

SmbusArpResetDeviceDirected0x15 Method

Reset Device (Directed: 0x15)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x15()
Public Sub ResetDeviceDirected0x15
public:
void ResetDeviceDirected0x15()
member ResetDeviceDirected0x15 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x16 Method

IRD

SmbusArpResetDeviceDirected0x16 Method

Reset Device (Directed: 0x16)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x16()
Public Sub ResetDeviceDirected0x16
public:
void ResetDeviceDirected0x16()
member ResetDeviceDirected0x16 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x17 Method

IRD

SmbusArpResetDeviceDirected0x17 Method

Reset Device (Directed: 0x17)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x17()
Public Sub ResetDeviceDirected0x17
public:
void ResetDeviceDirected0x17()
member ResetDeviceDirected0x17 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x18 Method

IRD

SmbusArpResetDeviceDirected0x18 Method

Reset Device (Directed: 0x18)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x18()
Public Sub ResetDeviceDirected0x18
public:
void ResetDeviceDirected0x18()
member ResetDeviceDirected0x18 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x19 Method

IRD

SmbusArpResetDeviceDirected0x19 Method

Reset Device (Directed: 0x19)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x19()
Public Sub ResetDeviceDirected0x19
public:
void ResetDeviceDirected0x19()
member ResetDeviceDirected0x19 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x1a Method

IRD

SmbusArpResetDeviceDirected0x1a Method

Reset Device (Directed: 0x1a)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x1a()
Public Sub ResetDeviceDirected0x1a
public:
void ResetDeviceDirected0x1a()
member ResetDeviceDirected0x1a : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x1b Method

IRD

SmbusArpResetDeviceDirected0x1b Method

Reset Device (Directed: 0x1b)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x1b()
Public Sub ResetDeviceDirected0x1b
public:
void ResetDeviceDirected0x1b()
member ResetDeviceDirected0x1b : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x1c Method

IRD

SmbusArpResetDeviceDirected0x1c Method

Reset Device (Directed: 0x1c)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x1c()
Public Sub ResetDeviceDirected0x1c
public:
void ResetDeviceDirected0x1c()
member ResetDeviceDirected0x1c : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x1d Method

IRD

SmbusArpResetDeviceDirected0x1d Method

Reset Device (Directed: 0x1d)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x1d()
Public Sub ResetDeviceDirected0x1d
public:
void ResetDeviceDirected0x1d()
member ResetDeviceDirected0x1d : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x1e Method

IRD

SmbusArpResetDeviceDirected0x1e Method

Reset Device (Directed: 0x1e)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x1e()
Public Sub ResetDeviceDirected0x1e
public:
void ResetDeviceDirected0x1e()
member ResetDeviceDirected0x1e : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x1f Method

IRD

SmbusArpResetDeviceDirected0x1f Method

Reset Device (Directed: 0x1f)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x1f()
Public Sub ResetDeviceDirected0x1f
public:
void ResetDeviceDirected0x1f()
member ResetDeviceDirected0x1f : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x20 Method

IRD

SmbusArpResetDeviceDirected0x20 Method

Reset Device (Directed: 0x20)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x20()
Public Sub ResetDeviceDirected0x20
public:
void ResetDeviceDirected0x20()
member ResetDeviceDirected0x20 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x21 Method

IRD

SmbusArpResetDeviceDirected0x21 Method

Reset Device (Directed: 0x21)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x21()
Public Sub ResetDeviceDirected0x21
public:
void ResetDeviceDirected0x21()
member ResetDeviceDirected0x21 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x22 Method

IRD

SmbusArpResetDeviceDirected0x22 Method

Reset Device (Directed: 0x22)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x22()
Public Sub ResetDeviceDirected0x22
public:
void ResetDeviceDirected0x22()
member ResetDeviceDirected0x22 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x23 Method

IRD

SmbusArpResetDeviceDirected0x23 Method

Reset Device (Directed: 0x23)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x23()
Public Sub ResetDeviceDirected0x23
public:
void ResetDeviceDirected0x23()
member ResetDeviceDirected0x23 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x24 Method

IRD

SmbusArpResetDeviceDirected0x24 Method

Reset Device (Directed: 0x24)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x24()
Public Sub ResetDeviceDirected0x24
public:
void ResetDeviceDirected0x24()
member ResetDeviceDirected0x24 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x25 Method

IRD

SmbusArpResetDeviceDirected0x25 Method

Reset Device (Directed: 0x25)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x25()
Public Sub ResetDeviceDirected0x25
public:
void ResetDeviceDirected0x25()
member ResetDeviceDirected0x25 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x26 Method

IRD

SmbusArpResetDeviceDirected0x26 Method

Reset Device (Directed: 0x26)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x26()
Public Sub ResetDeviceDirected0x26
public:
void ResetDeviceDirected0x26()
member ResetDeviceDirected0x26 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x27 Method

IRD

SmbusArpResetDeviceDirected0x27 Method

Reset Device (Directed: 0x27)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x27()
Public Sub ResetDeviceDirected0x27
public:
void ResetDeviceDirected0x27()
member ResetDeviceDirected0x27 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x28 Method

IRD

SmbusArpResetDeviceDirected0x28 Method

Reset Device (Directed: 0x28)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x28()
Public Sub ResetDeviceDirected0x28
public:
void ResetDeviceDirected0x28()
member ResetDeviceDirected0x28 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x29 Method

IRD

SmbusArpResetDeviceDirected0x29 Method

Reset Device (Directed: 0x29)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x29()
Public Sub ResetDeviceDirected0x29
public:
void ResetDeviceDirected0x29()
member ResetDeviceDirected0x29 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x2a Method

IRD

SmbusArpResetDeviceDirected0x2a Method

Reset Device (Directed: 0x2a)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x2a()
Public Sub ResetDeviceDirected0x2a
public:
void ResetDeviceDirected0x2a()
member ResetDeviceDirected0x2a : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x2b Method

IRD

SmbusArpResetDeviceDirected0x2b Method

Reset Device (Directed: 0x2b)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x2b()
Public Sub ResetDeviceDirected0x2b
public:
void ResetDeviceDirected0x2b()
member ResetDeviceDirected0x2b : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x2c Method

IRD

SmbusArpResetDeviceDirected0x2c Method

Reset Device (Directed: 0x2c)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x2c()
Public Sub ResetDeviceDirected0x2c
public:
void ResetDeviceDirected0x2c()
member ResetDeviceDirected0x2c : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x2d Method

IRD

SmbusArpResetDeviceDirected0x2d Method

Reset Device (Directed: 0x2d)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x2d()
Public Sub ResetDeviceDirected0x2d
public:
void ResetDeviceDirected0x2d()
member ResetDeviceDirected0x2d : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x2e Method

IRD

SmbusArpResetDeviceDirected0x2e Method

Reset Device (Directed: 0x2e)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x2e()
Public Sub ResetDeviceDirected0x2e
public:
void ResetDeviceDirected0x2e()
member ResetDeviceDirected0x2e : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x2f Method

IRD

SmbusArpResetDeviceDirected0x2f Method

Reset Device (Directed: 0x2f)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x2f()
Public Sub ResetDeviceDirected0x2f
public:
void ResetDeviceDirected0x2f()
member ResetDeviceDirected0x2f : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x30 Method

IRD

SmbusArpResetDeviceDirected0x30 Method

Reset Device (Directed: 0x30)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x30()
Public Sub ResetDeviceDirected0x30
public:
void ResetDeviceDirected0x30()
member ResetDeviceDirected0x30 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x31 Method

IRD

SmbusArpResetDeviceDirected0x31 Method

Reset Device (Directed: 0x31)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x31()
Public Sub ResetDeviceDirected0x31
public:
void ResetDeviceDirected0x31()
member ResetDeviceDirected0x31 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x32 Method

IRD

SmbusArpResetDeviceDirected0x32 Method

Reset Device (Directed: 0x32)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x32()
Public Sub ResetDeviceDirected0x32
public:
void ResetDeviceDirected0x32()
member ResetDeviceDirected0x32 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x33 Method

IRD

SmbusArpResetDeviceDirected0x33 Method

Reset Device (Directed: 0x33)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x33()
Public Sub ResetDeviceDirected0x33
public:
void ResetDeviceDirected0x33()
member ResetDeviceDirected0x33 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x34 Method

IRD

SmbusArpResetDeviceDirected0x34 Method

Reset Device (Directed: 0x34)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x34()
Public Sub ResetDeviceDirected0x34
public:
void ResetDeviceDirected0x34()
member ResetDeviceDirected0x34 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x35 Method

IRD

SmbusArpResetDeviceDirected0x35 Method

Reset Device (Directed: 0x35)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x35()
Public Sub ResetDeviceDirected0x35
public:
void ResetDeviceDirected0x35()
member ResetDeviceDirected0x35 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x36 Method

IRD

SmbusArpResetDeviceDirected0x36 Method

Reset Device (Directed: 0x36)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x36()
Public Sub ResetDeviceDirected0x36
public:
void ResetDeviceDirected0x36()
member ResetDeviceDirected0x36 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x37 Method

IRD

SmbusArpResetDeviceDirected0x37 Method

Reset Device (Directed: 0x37)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x37()
Public Sub ResetDeviceDirected0x37
public:
void ResetDeviceDirected0x37()
member ResetDeviceDirected0x37 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x38 Method

IRD

SmbusArpResetDeviceDirected0x38 Method

Reset Device (Directed: 0x38)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x38()
Public Sub ResetDeviceDirected0x38
public:
void ResetDeviceDirected0x38()
member ResetDeviceDirected0x38 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x39 Method

IRD

SmbusArpResetDeviceDirected0x39 Method

Reset Device (Directed: 0x39)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x39()
Public Sub ResetDeviceDirected0x39
public:
void ResetDeviceDirected0x39()
member ResetDeviceDirected0x39 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x3a Method

IRD

SmbusArpResetDeviceDirected0x3a Method

Reset Device (Directed: 0x3a)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x3a()
Public Sub ResetDeviceDirected0x3a
public:
void ResetDeviceDirected0x3a()
member ResetDeviceDirected0x3a : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x3b Method

IRD

SmbusArpResetDeviceDirected0x3b Method

Reset Device (Directed: 0x3b)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x3b()
Public Sub ResetDeviceDirected0x3b
public:
void ResetDeviceDirected0x3b()
member ResetDeviceDirected0x3b : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x3c Method

IRD

SmbusArpResetDeviceDirected0x3c Method

Reset Device (Directed: 0x3c)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x3c()
Public Sub ResetDeviceDirected0x3c
public:
void ResetDeviceDirected0x3c()
member ResetDeviceDirected0x3c : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x3d Method

IRD

SmbusArpResetDeviceDirected0x3d Method

Reset Device (Directed: 0x3d)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x3d()
Public Sub ResetDeviceDirected0x3d
public:
void ResetDeviceDirected0x3d()
member ResetDeviceDirected0x3d : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x3e Method

IRD

SmbusArpResetDeviceDirected0x3e Method

Reset Device (Directed: 0x3e)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x3e()
Public Sub ResetDeviceDirected0x3e
public:
void ResetDeviceDirected0x3e()
member ResetDeviceDirected0x3e : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x3f Method

IRD

SmbusArpResetDeviceDirected0x3f Method

Reset Device (Directed: 0x3f)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x3f()
Public Sub ResetDeviceDirected0x3f
public:
void ResetDeviceDirected0x3f()
member ResetDeviceDirected0x3f : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x40 Method

IRD

SmbusArpResetDeviceDirected0x40 Method

Reset Device (Directed: 0x40)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x40()
Public Sub ResetDeviceDirected0x40
public:
void ResetDeviceDirected0x40()
member ResetDeviceDirected0x40 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x41 Method

IRD

SmbusArpResetDeviceDirected0x41 Method

Reset Device (Directed: 0x41)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x41()
Public Sub ResetDeviceDirected0x41
public:
void ResetDeviceDirected0x41()
member ResetDeviceDirected0x41 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x42 Method

IRD

SmbusArpResetDeviceDirected0x42 Method

Reset Device (Directed: 0x42)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x42()
Public Sub ResetDeviceDirected0x42
public:
void ResetDeviceDirected0x42()
member ResetDeviceDirected0x42 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x43 Method

IRD

SmbusArpResetDeviceDirected0x43 Method

Reset Device (Directed: 0x43)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x43()
Public Sub ResetDeviceDirected0x43
public:
void ResetDeviceDirected0x43()
member ResetDeviceDirected0x43 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x44 Method

IRD

SmbusArpResetDeviceDirected0x44 Method

Reset Device (Directed: 0x44)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x44()
Public Sub ResetDeviceDirected0x44
public:
void ResetDeviceDirected0x44()
member ResetDeviceDirected0x44 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x45 Method

IRD

SmbusArpResetDeviceDirected0x45 Method

Reset Device (Directed: 0x45)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x45()
Public Sub ResetDeviceDirected0x45
public:
void ResetDeviceDirected0x45()
member ResetDeviceDirected0x45 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x46 Method

IRD

SmbusArpResetDeviceDirected0x46 Method

Reset Device (Directed: 0x46)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x46()
Public Sub ResetDeviceDirected0x46
public:
void ResetDeviceDirected0x46()
member ResetDeviceDirected0x46 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x47 Method

IRD

SmbusArpResetDeviceDirected0x47 Method

Reset Device (Directed: 0x47)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x47()
Public Sub ResetDeviceDirected0x47
public:
void ResetDeviceDirected0x47()
member ResetDeviceDirected0x47 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x48 Method

IRD

SmbusArpResetDeviceDirected0x48 Method

Reset Device (Directed: 0x48)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x48()
Public Sub ResetDeviceDirected0x48
public:
void ResetDeviceDirected0x48()
member ResetDeviceDirected0x48 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x49 Method

IRD

SmbusArpResetDeviceDirected0x49 Method

Reset Device (Directed: 0x49)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x49()
Public Sub ResetDeviceDirected0x49
public:
void ResetDeviceDirected0x49()
member ResetDeviceDirected0x49 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x4a Method

IRD

SmbusArpResetDeviceDirected0x4a Method

Reset Device (Directed: 0x4a)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x4a()
Public Sub ResetDeviceDirected0x4a
public:
void ResetDeviceDirected0x4a()
member ResetDeviceDirected0x4a : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x4b Method

IRD

SmbusArpResetDeviceDirected0x4b Method

Reset Device (Directed: 0x4b)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x4b()
Public Sub ResetDeviceDirected0x4b
public:
void ResetDeviceDirected0x4b()
member ResetDeviceDirected0x4b : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x4c Method

IRD

SmbusArpResetDeviceDirected0x4c Method

Reset Device (Directed: 0x4c)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x4c()
Public Sub ResetDeviceDirected0x4c
public:
void ResetDeviceDirected0x4c()
member ResetDeviceDirected0x4c : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x4d Method

IRD

SmbusArpResetDeviceDirected0x4d Method

Reset Device (Directed: 0x4d)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x4d()
Public Sub ResetDeviceDirected0x4d
public:
void ResetDeviceDirected0x4d()
member ResetDeviceDirected0x4d : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x4e Method

IRD

SmbusArpResetDeviceDirected0x4e Method

Reset Device (Directed: 0x4e)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x4e()
Public Sub ResetDeviceDirected0x4e
public:
void ResetDeviceDirected0x4e()
member ResetDeviceDirected0x4e : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x4f Method

IRD

SmbusArpResetDeviceDirected0x4f Method

Reset Device (Directed: 0x4f)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x4f()
Public Sub ResetDeviceDirected0x4f
public:
void ResetDeviceDirected0x4f()
member ResetDeviceDirected0x4f : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x50 Method

IRD

SmbusArpResetDeviceDirected0x50 Method

Reset Device (Directed: 0x50)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x50()
Public Sub ResetDeviceDirected0x50
public:
void ResetDeviceDirected0x50()
member ResetDeviceDirected0x50 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x51 Method

IRD

SmbusArpResetDeviceDirected0x51 Method

Reset Device (Directed: 0x51)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x51()
Public Sub ResetDeviceDirected0x51
public:
void ResetDeviceDirected0x51()
member ResetDeviceDirected0x51 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x52 Method

IRD

SmbusArpResetDeviceDirected0x52 Method

Reset Device (Directed: 0x52)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x52()
Public Sub ResetDeviceDirected0x52
public:
void ResetDeviceDirected0x52()
member ResetDeviceDirected0x52 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x53 Method

IRD

SmbusArpResetDeviceDirected0x53 Method

Reset Device (Directed: 0x53)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x53()
Public Sub ResetDeviceDirected0x53
public:
void ResetDeviceDirected0x53()
member ResetDeviceDirected0x53 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x54 Method

IRD

SmbusArpResetDeviceDirected0x54 Method

Reset Device (Directed: 0x54)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x54()
Public Sub ResetDeviceDirected0x54
public:
void ResetDeviceDirected0x54()
member ResetDeviceDirected0x54 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x55 Method

IRD

SmbusArpResetDeviceDirected0x55 Method

Reset Device (Directed: 0x55)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x55()
Public Sub ResetDeviceDirected0x55
public:
void ResetDeviceDirected0x55()
member ResetDeviceDirected0x55 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x56 Method

IRD

SmbusArpResetDeviceDirected0x56 Method

Reset Device (Directed: 0x56)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x56()
Public Sub ResetDeviceDirected0x56
public:
void ResetDeviceDirected0x56()
member ResetDeviceDirected0x56 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x57 Method

IRD

SmbusArpResetDeviceDirected0x57 Method

Reset Device (Directed: 0x57)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x57()
Public Sub ResetDeviceDirected0x57
public:
void ResetDeviceDirected0x57()
member ResetDeviceDirected0x57 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x58 Method

IRD

SmbusArpResetDeviceDirected0x58 Method

Reset Device (Directed: 0x58)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x58()
Public Sub ResetDeviceDirected0x58
public:
void ResetDeviceDirected0x58()
member ResetDeviceDirected0x58 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x59 Method

IRD

SmbusArpResetDeviceDirected0x59 Method

Reset Device (Directed: 0x59)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x59()
Public Sub ResetDeviceDirected0x59
public:
void ResetDeviceDirected0x59()
member ResetDeviceDirected0x59 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x5a Method

IRD

SmbusArpResetDeviceDirected0x5a Method

Reset Device (Directed: 0x5a)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x5a()
Public Sub ResetDeviceDirected0x5a
public:
void ResetDeviceDirected0x5a()
member ResetDeviceDirected0x5a : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x5b Method

IRD

SmbusArpResetDeviceDirected0x5b Method

Reset Device (Directed: 0x5b)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x5b()
Public Sub ResetDeviceDirected0x5b
public:
void ResetDeviceDirected0x5b()
member ResetDeviceDirected0x5b : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x5c Method

IRD

SmbusArpResetDeviceDirected0x5c Method

Reset Device (Directed: 0x5c)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x5c()
Public Sub ResetDeviceDirected0x5c
public:
void ResetDeviceDirected0x5c()
member ResetDeviceDirected0x5c : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x5d Method

IRD

SmbusArpResetDeviceDirected0x5d Method

Reset Device (Directed: 0x5d)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x5d()
Public Sub ResetDeviceDirected0x5d
public:
void ResetDeviceDirected0x5d()
member ResetDeviceDirected0x5d : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x5e Method

IRD

SmbusArpResetDeviceDirected0x5e Method

Reset Device (Directed: 0x5e)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x5e()
Public Sub ResetDeviceDirected0x5e
public:
void ResetDeviceDirected0x5e()
member ResetDeviceDirected0x5e : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x5f Method

IRD

SmbusArpResetDeviceDirected0x5f Method

Reset Device (Directed: 0x5f)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x5f()
Public Sub ResetDeviceDirected0x5f
public:
void ResetDeviceDirected0x5f()
member ResetDeviceDirected0x5f : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x60 Method

IRD

SmbusArpResetDeviceDirected0x60 Method

Reset Device (Directed: 0x60)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x60()
Public Sub ResetDeviceDirected0x60
public:
void ResetDeviceDirected0x60()
member ResetDeviceDirected0x60 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x61 Method

IRD

SmbusArpResetDeviceDirected0x61 Method

Reset Device (Directed: 0x61)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x61()
Public Sub ResetDeviceDirected0x61
public:
void ResetDeviceDirected0x61()
member ResetDeviceDirected0x61 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x62 Method

IRD

SmbusArpResetDeviceDirected0x62 Method

Reset Device (Directed: 0x62)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x62()
Public Sub ResetDeviceDirected0x62
public:
void ResetDeviceDirected0x62()
member ResetDeviceDirected0x62 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x63 Method

IRD

SmbusArpResetDeviceDirected0x63 Method

Reset Device (Directed: 0x63)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x63()
Public Sub ResetDeviceDirected0x63
public:
void ResetDeviceDirected0x63()
member ResetDeviceDirected0x63 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x64 Method

IRD

SmbusArpResetDeviceDirected0x64 Method

Reset Device (Directed: 0x64)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x64()
Public Sub ResetDeviceDirected0x64
public:
void ResetDeviceDirected0x64()
member ResetDeviceDirected0x64 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x65 Method

IRD

SmbusArpResetDeviceDirected0x65 Method

Reset Device (Directed: 0x65)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x65()
Public Sub ResetDeviceDirected0x65
public:
void ResetDeviceDirected0x65()
member ResetDeviceDirected0x65 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x66 Method

IRD

SmbusArpResetDeviceDirected0x66 Method

Reset Device (Directed: 0x66)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x66()
Public Sub ResetDeviceDirected0x66
public:
void ResetDeviceDirected0x66()
member ResetDeviceDirected0x66 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x67 Method

IRD

SmbusArpResetDeviceDirected0x67 Method

Reset Device (Directed: 0x67)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x67()
Public Sub ResetDeviceDirected0x67
public:
void ResetDeviceDirected0x67()
member ResetDeviceDirected0x67 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x68 Method

IRD

SmbusArpResetDeviceDirected0x68 Method

Reset Device (Directed: 0x68)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x68()
Public Sub ResetDeviceDirected0x68
public:
void ResetDeviceDirected0x68()
member ResetDeviceDirected0x68 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x69 Method

IRD

SmbusArpResetDeviceDirected0x69 Method

Reset Device (Directed: 0x69)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x69()
Public Sub ResetDeviceDirected0x69
public:
void ResetDeviceDirected0x69()
member ResetDeviceDirected0x69 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x6a Method

IRD

SmbusArpResetDeviceDirected0x6a Method

Reset Device (Directed: 0x6a)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x6a()
Public Sub ResetDeviceDirected0x6a
public:
void ResetDeviceDirected0x6a()
member ResetDeviceDirected0x6a : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x6b Method

IRD

SmbusArpResetDeviceDirected0x6b Method

Reset Device (Directed: 0x6b)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x6b()
Public Sub ResetDeviceDirected0x6b
public:
void ResetDeviceDirected0x6b()
member ResetDeviceDirected0x6b : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x6c Method

IRD

SmbusArpResetDeviceDirected0x6c Method

Reset Device (Directed: 0x6c)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x6c()
Public Sub ResetDeviceDirected0x6c
public:
void ResetDeviceDirected0x6c()
member ResetDeviceDirected0x6c : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x6d Method

IRD

SmbusArpResetDeviceDirected0x6d Method

Reset Device (Directed: 0x6d)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x6d()
Public Sub ResetDeviceDirected0x6d
public:
void ResetDeviceDirected0x6d()
member ResetDeviceDirected0x6d : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x6e Method

IRD

SmbusArpResetDeviceDirected0x6e Method

Reset Device (Directed: 0x6e)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x6e()
Public Sub ResetDeviceDirected0x6e
public:
void ResetDeviceDirected0x6e()
member ResetDeviceDirected0x6e : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x6f Method

IRD

SmbusArpResetDeviceDirected0x6f Method

Reset Device (Directed: 0x6f)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x6f()
Public Sub ResetDeviceDirected0x6f
public:
void ResetDeviceDirected0x6f()
member ResetDeviceDirected0x6f : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x70 Method

IRD

SmbusArpResetDeviceDirected0x70 Method

Reset Device (Directed: 0x70)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x70()
Public Sub ResetDeviceDirected0x70
public:
void ResetDeviceDirected0x70()
member ResetDeviceDirected0x70 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x71 Method

IRD

SmbusArpResetDeviceDirected0x71 Method

Reset Device (Directed: 0x71)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x71()
Public Sub ResetDeviceDirected0x71
public:
void ResetDeviceDirected0x71()
member ResetDeviceDirected0x71 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x72 Method

IRD

SmbusArpResetDeviceDirected0x72 Method

Reset Device (Directed: 0x72)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x72()
Public Sub ResetDeviceDirected0x72
public:
void ResetDeviceDirected0x72()
member ResetDeviceDirected0x72 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x73 Method

IRD

SmbusArpResetDeviceDirected0x73 Method

Reset Device (Directed: 0x73)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x73()
Public Sub ResetDeviceDirected0x73
public:
void ResetDeviceDirected0x73()
member ResetDeviceDirected0x73 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x74 Method

IRD

SmbusArpResetDeviceDirected0x74 Method

Reset Device (Directed: 0x74)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x74()
Public Sub ResetDeviceDirected0x74
public:
void ResetDeviceDirected0x74()
member ResetDeviceDirected0x74 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x75 Method

IRD

SmbusArpResetDeviceDirected0x75 Method

Reset Device (Directed: 0x75)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x75()
Public Sub ResetDeviceDirected0x75
public:
void ResetDeviceDirected0x75()
member ResetDeviceDirected0x75 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x76 Method

IRD

SmbusArpResetDeviceDirected0x76 Method

Reset Device (Directed: 0x76)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x76()
Public Sub ResetDeviceDirected0x76
public:
void ResetDeviceDirected0x76()
member ResetDeviceDirected0x76 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x77 Method

IRD

SmbusArpResetDeviceDirected0x77 Method

Reset Device (Directed: 0x77)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x77()
Public Sub ResetDeviceDirected0x77
public:
void ResetDeviceDirected0x77()
member ResetDeviceDirected0x77 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x78 Method

IRD

SmbusArpResetDeviceDirected0x78 Method

Reset Device (Directed: 0x78)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x78()
Public Sub ResetDeviceDirected0x78
public:
void ResetDeviceDirected0x78()
member ResetDeviceDirected0x78 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x79 Method

IRD

SmbusArpResetDeviceDirected0x79 Method

Reset Device (Directed: 0x79)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x79()
Public Sub ResetDeviceDirected0x79
public:
void ResetDeviceDirected0x79()
member ResetDeviceDirected0x79 : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x7a Method

IRD

SmbusArpResetDeviceDirected0x7a Method

Reset Device (Directed: 0x7a)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x7a()
Public Sub ResetDeviceDirected0x7a
public:
void ResetDeviceDirected0x7a()
member ResetDeviceDirected0x7a : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x7b Method

IRD

SmbusArpResetDeviceDirected0x7b Method

Reset Device (Directed: 0x7b)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x7b()
Public Sub ResetDeviceDirected0x7b
public:
void ResetDeviceDirected0x7b()
member ResetDeviceDirected0x7b : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x7c Method

IRD

SmbusArpResetDeviceDirected0x7c Method

Reset Device (Directed: 0x7c)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x7c()
Public Sub ResetDeviceDirected0x7c
public:
void ResetDeviceDirected0x7c()
member ResetDeviceDirected0x7c : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x7d Method

IRD

SmbusArpResetDeviceDirected0x7d Method

Reset Device (Directed: 0x7d)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x7d()
Public Sub ResetDeviceDirected0x7d
public:
void ResetDeviceDirected0x7d()
member ResetDeviceDirected0x7d : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x7e Method

IRD

SmbusArpResetDeviceDirected0x7e Method

Reset Device (Directed: 0x7e)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x7e()
Public Sub ResetDeviceDirected0x7e
public:
void ResetDeviceDirected0x7e()
member ResetDeviceDirected0x7e : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceDirected0x7f Method

IRD

SmbusArpResetDeviceDirected0x7f Method

Reset Device (Directed: 0x7f)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceDirected0x7f()
Public Sub ResetDeviceDirected0x7f
public:
void ResetDeviceDirected0x7f()
member ResetDeviceDirected0x7f : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.ResetDeviceGeneral Method

IRD

SmbusArpResetDeviceGeneral Method

Reset Device (General)

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDeviceGeneral()
Public Sub ResetDeviceGeneral
public:
void ResetDeviceGeneral()
member ResetDeviceGeneral : unit -> unit
See Also

Reference

SmbusArp Class
telos.Ird.SBSForum Namespace


SmbusArp.TypeAddress Enumeration

IRD

SmbusArpTypeAddress Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAddress
Public Enumeration TypeAddress
public enum class TypeAddress
type TypeAddress
Members
Member name | Value | Description
FixedAddress | 0 | Fixed Address
DynamicAndPersistentAddress | 1 | Dynamic And Persistent Address
DynamicAndVolatileAddress | 2 | Dynamic And Volatile Address
RandomNumber | 3 | Random Number
See Also

Reference

telos.Ird.SBSForum Namespace


SmbusArp.TypeSmbusVersion Enumeration

IRD

SmbusArpTypeSmbusVersion Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSmbusVersion
Public Enumeration TypeSmbusVersion
public enum class TypeSmbusVersion
type TypeSmbusVersion
Members
Member name | Value | Description
SMBus10 | 0 | SMBus 1.0
SMBus11 | 1 | SMBus 1.1
Reserved | 2 | Reserved
SMBus20 | 4 | SMBus 2.0
SMBus30 | 5 | SMBus 3.0
See Also

Reference

telos.Ird.SBSForum Namespace


SmbusArp.TypeSupported Enumeration

IRD

SmbusArpTypeSupported Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSupported
Public Enumeration TypeSupported
public enum class TypeSupported
type TypeSupported
Members
Member name | Value | Description
NotSupported | 0 | Not Supported
Supported | 1 | Supported
See Also

Reference

telos.Ird.SBSForum Namespace


SmbusArp.TypeUdidVersion Enumeration

IRD

SmbusArpTypeUdidVersion Enumeration

Namespace: telos.Ird.SBSForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeUdidVersion
Public Enumeration TypeUdidVersion
public enum class TypeUdidVersion
type TypeUdidVersion
Members
Member name | Value | Description
Version1 | 1 | Version 1
See Also

Reference

telos.Ird.SBSForum Namespace


telos.Ird.SMIForum Namespace

Classes
 | Class | Description
Public class | Pmbus | SMI Forum: PMBus 1.3
Enumerations
 | Enumeration | Description
Public enumeration | PmbusTypeAppProfileSupportProfile |
Public enumeration | PmbusTypeBool |
Public enumeration | PmbusTypeCapabilityAvsbus |
Public enumeration | PmbusTypeCapabilityMaxSpeed |
Public enumeration | PmbusTypeCapabilityNumericFormat |
Public enumeration | PmbusTypeCapabilityPec |
Public enumeration | PmbusTypeCapabilitySmbalert |
Public enumeration | PmbusTypeCoefficients |
Public enumeration | PmbusTypeFanConfigCommanded |
Public enumeration | PmbusTypeFanConfigInstalled |
Public enumeration | PmbusTypeOnOffConfig0 |
Public enumeration | PmbusTypeOnOffConfig1 |
Public enumeration | PmbusTypeOnOffConfig2 |
Public enumeration | PmbusTypeOnOffConfig3 |
Public enumeration | PmbusTypeOnOffConfig4 |
Public enumeration | PmbusTypeOperation |
Public enumeration | PmbusTypePage |
Public enumeration | PmbusTypePhase |
Public enumeration | PmbusTypePmbusRevision |
Public enumeration | PmbusTypePowerMode |
Public enumeration | PmbusTypeQueryFormat |
Public enumeration | PmbusTypeQuerySupported |
Public enumeration | PmbusTypeQuerySupportedRead |
Public enumeration | PmbusTypeQuerySupportedWrite |
Public enumeration | PmbusTypeReadKwhConfigFormat |
Public enumeration | PmbusTypeReadKwhConfigHasBeenResetted |
Public enumeration | PmbusTypeReadKwhConfigResetSupported |
Public enumeration | PmbusTypeReadKwhConfigRolledOver |
Public enumeration | PmbusTypeReadKwhConfigSupported |
Public enumeration | PmbusTypeReadKwhConfigUnit |
Public enumeration | PmbusTypeReadKwhConfigVolatile |
Public enumeration | PmbusTypeRespCurrentFaultsResponse |
Public enumeration | PmbusTypeRespCurrentFaultsRetry |
Public enumeration | PmbusTypeRespVoltageTempFaultsResponse |
Public enumeration | PmbusTypeRespVoltageTempFaultsRetry |
Public enumeration | PmbusTypeVoutModeMode |
Public enumeration | PmbusTypeWriteProtect |


Pmbus Class

SMI Forum: PMBus 1.3
Inheritance Hierarchy
SystemObject
telos.Ird.SMIForumPmbus

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pmbus
Public Class Pmbus
public ref class Pmbus
type Pmbus =  class end

The Pmbus type exposes the following members.

Constructors
 | Name | Description
Public method | Pmbus | Constructor
Top
Properties
 | Name | Description
Public property | APPPROFILESUPPORTApplication1MajorRevision | APP_PROFILE_SUPPORT: Application 1 Major Revision
Public property | APPPROFILESUPPORTApplication1MinorRevision | APP_PROFILE_SUPPORT: Application 1 Minor Revision
Public property | APPPROFILESUPPORTApplication1Profile | APP_PROFILE_SUPPORT: Application 1 Profile
Public property | APPPROFILESUPPORTApplication2MajorRevision | APP_PROFILE_SUPPORT: Application 2 Major Revision
Public property | APPPROFILESUPPORTApplication2MinorRevision | APP_PROFILE_SUPPORT: Application 2 Minor Revision
Public property | APPPROFILESUPPORTApplication2Profile | APP_PROFILE_SUPPORT: Application 2 Profile
Public property | APPPROFILESUPPORTApplication3MajorRevision | APP_PROFILE_SUPPORT: Application 3 Major Revision
Public property | APPPROFILESUPPORTApplication3MinorRevision | APP_PROFILE_SUPPORT: Application 3 Minor Revision
Public property | APPPROFILESUPPORTApplication3Profile | APP_PROFILE_SUPPORT: Application 3 Profile
Public property | APPPROFILESUPPORTApplication4MajorRevision | APP_PROFILE_SUPPORT: Application 4 Major Revision
Public property | APPPROFILESUPPORTApplication4MinorRevision | APP_PROFILE_SUPPORT: Application 4 Minor Revision
Public property | APPPROFILESUPPORTApplication4Profile | APP_PROFILE_SUPPORT: Application 4 Profile
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CAPABILITYAVSBusSupport | CAPABILITY: AVSBus Support
Public property | CAPABILITYMaximumBusSpeed | CAPABILITY: Maximum Bus Speed
Public property | CAPABILITYNumericFormat | CAPABILITY: Numeric Format
Public property | CAPABILITYPacketErrorChecking | CAPABILITY: Packet Error Checking
Public property | CAPABILITYSMBALERT | CAPABILITY: SMBALERT#
Public property | COEFFICIENTSB | COEFFICIENTS: b
Public property | COEFFICIENTSCommandCode | COEFFICIENTS: Command Code
Public property | COEFFICIENTSM | COEFFICIENTS: m
Public property | COEFFICIENTSR | COEFFICIENTS: R
Public property | COEFFICIENTSType | COEFFICIENTS: Type
Public property | FANCOMMAND1 | FAN_COMMAND_1
Public property | FANCOMMAND2 | FAN_COMMAND_2
Public property | FANCOMMAND3 | FAN_COMMAND_3
Public property | FANCOMMAND4 | FAN_COMMAND_4
Public property | FANCONFIG12Fan1CommandedBy | FAN_CONFIG_1_2: Fan 1 Commanded By
Public property | FANCONFIG12Fan1Installed | FAN_CONFIG_1_2: Fan 1 Installed
Public property | FANCONFIG12Fan1PulsesPerRevolution | FAN_CONFIG_1_2: Fan 1 Pulses Per Revolution
Public property | FANCONFIG12Fan2CommandedBy | FAN_CONFIG_1_2: Fan 2 Commanded By
Public property | FANCONFIG12Fan2Installed | FAN_CONFIG_1_2: Fan 2 Installed
Public property | FANCONFIG12Fan2PulsesPerRevolution | FAN_CONFIG_1_2: Fan 2 Pulses Per Revolution
Public property | FANCONFIG34Fan3CommandedBy | FAN_CONFIG_3_4: Fan 3 Commanded By
Public property | FANCONFIG34Fan3Installed | FAN_CONFIG_3_4: Fan 3 Installed
Public property | FANCONFIG34Fan3PulsesPerRevolution | FAN_CONFIG_3_4: Fan 3 Pulses Per Revolution
Public property | FANCONFIG34Fan4CommandedBy | FAN_CONFIG_3_4: Fan 4 Commanded By
Public property | FANCONFIG34Fan4Installed | FAN_CONFIG_3_4: Fan 4 Installed
Public property | FANCONFIG34Fan4PulsesPerRevolution | FAN_CONFIG_3_4: Fan 4 Pulses Per Revolution
Public property | FREQUENCYSWITCH | FREQUENCY_SWITCH
Public property | ICDEVICEID | IC_DEVICE_ID
Public property | ICDEVICEREV | IC_DEVICE_REV
Public property | IINOCFAULTLIMIT | IIN_OC_FAULT_LIMIT
Public property | IINOCFAULTRESPONSEDelayTime | IIN_OC_FAULT_RESPONSE: Delay Time
Public property | IINOCFAULTRESPONSEResponse | IIN_OC_FAULT_RESPONSE: Response
Public property | IINOCFAULTRESPONSERetrySetting | IIN_OC_FAULT_RESPONSE: Retry Setting
Public property | IINOCWARNLIMIT | IIN_OC_WARN_LIMIT
Public property | INTERLEAVEGroupIDNumber | INTERLEAVE: Group ID Number
Public property | INTERLEAVEInterleaveOrder | INTERLEAVE: Interleave Order
Public property | INTERLEAVENumberInGroup | INTERLEAVE: Number In Group
Public property | IOUTCALGAIN | IOUT_CAL_GAIN
Public property | IOUTCALOFFSET | IOUT_CAL_OFFSET
Public property | IOUTOCFAULTLIMIT | IOUT_OC_FAULT_LIMIT
Public property | IOUTOCFAULTRESPONSEDelayTime | IOUT_OC_FAULT_RESPONSE: Delay Time
Public property | IOUTOCFAULTRESPONSEResponse | IOUT_OC_FAULT_RESPONSE: Response
Public property | IOUTOCFAULTRESPONSERetrySetting | IOUT_OC_FAULT_RESPONSE: Retry Setting
Public property | IOUTOCLVFAULTLIMIT | IOUT_OC_LV_FAULT_LIMIT
Public property | IOUTOCLVFAULTRESPONSEDelayTime | IOUT_OC_LV_FAULT_RESPONSE: Delay Time
Public property | IOUTOCLVFAULTRESPONSEResponse | IOUT_OC_LV_FAULT_RESPONSE: Response
Public property | IOUTOCLVFAULTRESPONSERetrySetting | IOUT_OC_LV_FAULT_RESPONSE: Retry Setting
Public property | IOUTOCWARNLIMIT | IOUT_OC_WARN_LIMIT
Public property | IOUTUCFAULTLIMIT | IOUT_UC_FAULT_LIMIT
Public property | IOUTUCFAULTRESPONSEDelayTime | IOUT_UC_FAULT_RESPONSE: Delay Time
Public property | IOUTUCFAULTRESPONSEResponse | IOUT_UC_FAULT_RESPONSE: Response
Public property | IOUTUCFAULTRESPONSERetrySetting | IOUT_UC_FAULT_RESPONSE: Retry Setting
Public property | MAXDUTY | MAX_DUTY
Public property | MFRDATE | MFR_DATE
Public property | MFREFFICIENCYHLEfficiencyHighPower | MFR_EFFICIENCY_HL: Efficiency (High Power)
Public property | MFREFFICIENCYHLEfficiencyLowPower | MFR_EFFICIENCY_HL: Efficiency (Low Power)
Public property | MFREFFICIENCYHLEfficiencyMediumPower | MFR_EFFICIENCY_HL: Efficiency (Medium Power)
Public property | MFREFFICIENCYHLInputVoltageHighLine | MFR_EFFICIENCY_HL: Input Voltage (High Line)
Public property | MFREFFICIENCYHLPowerHighPower | MFR_EFFICIENCY_HL: Power (High Power)
Public property | MFREFFICIENCYHLPowerLowPower | MFR_EFFICIENCY_HL: Power (Low Power)
Public property | MFREFFICIENCYHLPowerMediumPower | MFR_EFFICIENCY_HL: Power (Medium Power)
Public property | MFREFFICIENCYLLEfficiencyHighPower | MFR_EFFICIENCY_LL: Efficiency (High Power)
Public property | MFREFFICIENCYLLEfficiencyLowPower | MFR_EFFICIENCY_LL: Efficiency (Low Power)
Public property | MFREFFICIENCYLLEfficiencyMediumPower | MFR_EFFICIENCY_LL: Efficiency (Medium Power)
Public property | MFREFFICIENCYLLInputVoltageLowLine | MFR_EFFICIENCY_LL: Input Voltage (Low Line)
Public property | MFREFFICIENCYLLPowerHighPower | MFR_EFFICIENCY_LL: Power (High Power)
Public property | MFREFFICIENCYLLPowerLowPower | MFR_EFFICIENCY_LL: Power (Low Power)
Public property | MFREFFICIENCYLLPowerMediumPower | MFR_EFFICIENCY_LL: Power (Medium Power)
Public property | MFRID | MFR_ID
Public property | MFRIINMAX | MFR_IIN_MAX
Public property | MFRIOUTMAX | MFR_IOUT_MAX
Public property | MFRLOCATION | MFR_LOCATION
Public property | MFRMODEL | MFR_MODEL
Public property | MFRPINACCURACY | MFR_PIN_ACCURACY (unit: %)
Public property | MFRPINMAX | MFR_PIN_MAX
Public property | MFRPOUTMAX | MFR_POUT_MAX
Public property | MFRREVISION | MFR_REVISION
Public property | MFRSERIAL | MFR_SERIAL
Public property | MFRTAMBIENTMAX | MFR_TAMBIENT_MAX
Public property | MFRTAMBIENTMIN | MFR_TAMBIENT_MIN
Public property | MFRVINMAX | MFR_VIN_MAX
Public property | MFRVINMIN | MFR_VIN_MIN
Public property | MFRVOUTMAX | MFR_VOUT_MAX
Public property | MFRVOUTMIN | MFR_VOUT_MIN
Public property | ONOFFCONFIGCONTROLPin | ON_OFF_CONFIG: CONTROL Pin
Public property | ONOFFCONFIGCONTROLPinAction | ON_OFF_CONFIG: CONTROL Pin Action
Public property | ONOFFCONFIGPolarityCONTROLPin | ON_OFF_CONFIG: Polarity CONTROL Pin
Public property | ONOFFCONFIGPowerUp | ON_OFF_CONFIG: Power Up
Public property | ONOFFCONFIGSerialBus | ON_OFF_CONFIG: Serial Bus
Public property | OPERATION | OPERATION
Public property | OTFAULTLIMIT | OT_FAULT_LIMIT
Public property | OTFAULTRESPONSEDelayTime | OT_FAULT_RESPONSE: Delay Time
Public property | OTFAULTRESPONSEResponse | OT_FAULT_RESPONSE: Response
Public property | OTFAULTRESPONSERetrySetting | OT_FAULT_RESPONSE: Retry Setting
Public property | OTWARNLIMIT | OT_WARN_LIMIT
Public property | PAGE | PAGE
Public property | PAGEPLUSREADCOMMANDCODE | PAGE_PLUS_READ: COMMAND CODE
Public property | PAGEPLUSREADDATA | PAGE_PLUS_READ: DATA
Public property | PAGEPLUSREADPAGENUMBER | PAGE_PLUS_READ: PAGE NUMBER
Public property | PAGEPLUSWRITECOMMANDCODE | PAGE_PLUS_WRITE: COMMAND CODE
Public property | PAGEPLUSWRITEDATA | PAGE_PLUS_WRITE: DATA
Public property | PAGEPLUSWRITEPAGENUMBER | PAGE_PLUS_WRITE: PAGE NUMBER
Public property | PHASE | PHASE
Public property | PINOPWARNLIMIT | PIN_OP_WARN_LIMIT
Public property | PMBUSREVISIONPartIIRevision | PMBUS_REVISION: Part II Revision
Public property | PMBUSREVISIONPartIRevision | PMBUS_REVISION: Part I Revision
Public property | POUTMAX | POUT_MAX
Public property | POUTOPFAULTLIMIT | POUT_OP_FAULT_LIMIT
Public property | POUTOPFAULTRESPONSEDelayTime | POUT_OP_FAULT_RESPONSE: Delay Time
Public property | POUTOPFAULTRESPONSEResponse | POUT_OP_FAULT_RESPONSE: Response
Public property | POUTOPFAULTRESPONSERetrySetting | POUT_OP_FAULT_RESPONSE: Retry Setting
Public property | POUTOPWARNLIMIT | POUT_OP_WARN_LIMIT
Public property | POWERGOODOFF | POWER_GOOD_OFF
Public property | POWERGOODON | POWER_GOOD_ON
Public property | POWERMODE | POWER_MODE
Public property | QUERYCommand | QUERY: Command
Public property | QUERYCommandCode | QUERY: Command Code
Public property | QUERYCommandRead | QUERY: Command Read
Public property | QUERYCommandWrite | QUERY: Command Write
Public property | QUERYFormat | QUERY: Format
Public property | READDUTYCYCLE | READ_DUTY_CYCLE
Public property | READEINENERGYCOUNT | READ_EIN: ENERGY_COUNT
Public property | READEINROLLOVERCOUNT | READ_EIN: ROLLOVER_COUNT
Public property | READEINSAMPLECOUNT | READ_EIN: SAMPLE_COUNT
Public property | READEOUTENERGYCOUNT | READ_EOUT: ENERGY_COUNT
Public property | READEOUTROLLOVERCOUNT | READ_EOUT: ROLLOVER_COUNT
Public property | READEOUTSAMPLECOUNT | READ_EOUT: SAMPLE_COUNT
Public property | READFANSPEED1 | READ_FAN_SPEED_1
Public property | READFANSPEED2 | READ_FAN_SPEED_2
Public property | READFANSPEED3 | READ_FAN_SPEED_3
Public property | READFANSPEED4 | READ_FAN_SPEED_4
Public property | READFREQUENCY | READ_FREQUENCY
Public property | READIIN | READ_IIN
Public property | READIOUT | READ_IOUT
Public property | READKWHCONFIGInputFormat | READ_KWH_CONFIG: Input Format
Public property | READKWHCONFIGInputHasBeenResetted | READ_KWH_CONFIG: Input Has Been Resetted
Public property | READKWHCONFIGInputResetSupported | READ_KWH_CONFIG: Input Reset Supported
Public property | READKWHCONFIGInputUnits | READ_KWH_CONFIG: Input Units
Public property | READKWHCONFIGInputValueRolledOver | READ_KWH_CONFIG: Input Value Rolled Over
Public property | READKWHCONFIGInputVolatile | READ_KWH_CONFIG: Input Volatile
Public property | READKWHCONFIGOutputFormat | READ_KWH_CONFIG: Output Format
Public property | READKWHCONFIGOutputHasBeenResetted | READ_KWH_CONFIG: Output Has Been Resetted
Public property | READKWHCONFIGOutputResetSupported | READ_KWH_CONFIG: Output Reset Supported
Public property | READKWHCONFIGOutputUnits | READ_KWH_CONFIG: Output Units
Public property | READKWHCONFIGOutputValueRolledOver | READ_KWH_CONFIG: Output Value Rolled Over
Public property | READKWHCONFIGOutputVolatile | READ_KWH_CONFIG: Output Volatile
Public property | READKWHCONFIGREADKWHINSupported | READ_KWH_CONFIG: READ_KWH_IN Supported
Public property | READKWHCONFIGREADKWHOUTSupported | READ_KWH_CONFIG: READ_KWH_OUT Supported
Public property | READKWHIN | READ_KWH_IN
Public property | READKWHOUT | READ_KWH_OUT
Public property | READPIN | READ_PIN
Public property | READPOUT | READ_POUT
Public property | READTEMPERATURE1 | READ_TEMPERATURE_1
Public property | READTEMPERATURE2 | READ_TEMPERATURE_2
Public property | READTEMPERATURE3 | READ_TEMPERATURE_3
Public property | READVCAP | READ_VCAP
Public property | READVIN | READ_VIN
Public property | READVOUT | READ_VOUT
Public property | RESTOREDEFAULTCODE | RESTORE_DEFAULT_CODE
Public property | RESTOREUSERCODE | RESTORE_USER_CODE
Public property | SMBALERTMASKMask | SMBALERT_MASK: Mask
Public property | SMBALERTMASKStatusCommandCode | SMBALERT_MASK: Status Command Code
Public property | STATUSBYTEBUSY | STATUS_BYTE: BUSY
Public property | STATUSBYTECML | STATUS_BYTE: CML
Public property | STATUSBYTEIOUTOCFAULT | STATUS_BYTE: IOUT_OC_FAULT
Public property | STATUSBYTENONEOFTHEABOVE | STATUS_BYTE: NONE OF THE ABOVE
Public property | STATUSBYTEOFF | STATUS_BYTE: OFF
Public property | STATUSBYTETEMPERATURE | STATUS_BYTE: TEMPERATURE
Public property | STATUSBYTEVINUVFAULT | STATUS_BYTE: VIN_UV_FAULT
Public property | STATUSBYTEVOUTOVFAULT | STATUS_BYTE: VOUT_OV_FAULT
Public property | STATUSCMLInvalidOrUnsupportedCommandReceived | STATUS_CML: Invalid Or Unsupported Command Received
Public property | STATUSCMLInvalidOrUnsupportedDataReceived | STATUS_CML: Invalid Or Unsupported Data Received
Public property | STATUSCMLMemoryFaultDetected | STATUS_CML: Memory Fault Detected
Public property | STATUSCMLOtherCommunicationFault | STATUS_CML: Other Communication Fault
Public property | STATUSCMLOtherMemoryOrLogicFault | STATUS_CML: Other Memory Or Logic Fault
Public property | STATUSCMLPacketErrorCheckFailed | STATUS_CML: Packet Error Check Failed
Public property | STATUSCMLProcessorFaultDetected | STATUS_CML: Processor Fault Detected
Public property | STATUSFANS12AirflowFault | STATUS_FANS_1_2: Airflow Fault
Public property | STATUSFANS12AirflowWarning | STATUS_FANS_1_2: Airflow Warning
Public property | STATUSFANS12Fan1Fault | STATUS_FANS_1_2: Fan 1 Fault
Public property | STATUSFANS12Fan1SpeedOverridden | STATUS_FANS_1_2: Fan 1 Speed Overridden
Public property | STATUSFANS12Fan1Warning | STATUS_FANS_1_2: Fan 1 Warning
Public property | STATUSFANS12Fan2Fault | STATUS_FANS_1_2: Fan 2 Fault
Public property | STATUSFANS12Fan2SpeedOverridden | STATUS_FANS_1_2: Fan 2 Speed Overridden
Public property | STATUSFANS12Fan2Warning | STATUS_FANS_1_2: Fan 2 Warning
Public property | STATUSFANS34Fan3Fault | STATUS_FANS_3_4: Fan 3 Fault
Public property | STATUSFANS34Fan3SpeedOverridden | STATUS_FANS_3_4: Fan 3 Speed Overridden
Public property | STATUSFANS34Fan3Warning | STATUS_FANS_3_4: Fan 3 Warning
Public property | STATUSFANS34Fan4Fault | STATUS_FANS_3_4: Fan 4 Fault
Public property | STATUSFANS34Fan4SpeedOverridden | STATUS_FANS_3_4: Fan 4 Speed Overridden
Public property | STATUSFANS34Fan4Warning | STATUS_FANS_3_4: Fan 4 Warning
Public property | STATUSINPUTIINOCFAULT | STATUS_INPUT: IIN_OC_FAULT
Public property | STATUSINPUTIINOCWARNING | STATUS_INPUT: IIN_OC_WARNING
Public property | STATUSINPUTPINOPWARNING | STATUS_INPUT: PIN_OP_WARNING
Public property | STATUSINPUTUnitOffForInsufficientInputVoltage | STATUS_INPUT: Unit Off For Insufficient Input Voltage
Public property | STATUSINPUTVINOVFAULT | STATUS_INPUT: VIN_OV_FAULT
Public property | STATUSINPUTVINOVWARNING | STATUS_INPUT: VIN_OV_WARNING
Public property | STATUSINPUTVINUVFAULT | STATUS_INPUT: VIN_UV_FAULT
Public property | STATUSINPUTVINUVWARNING | STATUS_INPUT: VIN_UV_WARNING
Public property | STATUSIOUTCurrentShareFault | STATUS_IOUT: Current Share Fault
Public property | STATUSIOUTInPowerLimitingMode | STATUS_IOUT: In Power Limiting Mode
Public property | STATUSIOUTIOUTOCFAULT | STATUS_IOUT: IOUT_OC_FAULT
Public property | STATUSIOUTIOUTOCLVFAULT | STATUS_IOUT: IOUT_OC_LV_FAULT
Public property | STATUSIOUTIOUTOCWARNING | STATUS_IOUT: IOUT_OC_WARNING
Public property | STATUSIOUTIOUTUCFAULT | STATUS_IOUT: IOUT_UC_FAULT
Public property | STATUSIOUTPOUTOPFAULT | STATUS_IOUT: POUT_OP_FAULT
Public property | STATUSIOUTPOUTOPWARNING | STATUS_IOUT: POUT_OP_WARNING
Public property | STATUSMFRSPECIFIC | STATUS_MFR_SPECIFIC
Public property | STATUSOTHERFirstToAssertSMBALERT | STATUS_OTHER: First To Assert SMBALERT#
Public property | STATUSOTHERInputAFuseOrCircuitBreakerFault | STATUS_OTHER: Input A Fuse Or Circuit Breaker Fault
Public property | STATUSOTHERInputAORIngDeviceFault | STATUS_OTHER: Input A OR-ing Device Fault
Public property | STATUSOTHERInputBFuseOrCircuitBreakerFault | STATUS_OTHER: Input B Fuse Or Circuit Breaker Fault
Public property | STATUSOTHERInputBORIngDeviceFault | STATUS_OTHER: Input B OR-ing Device Fault
Public property | STATUSOTHEROutputORIngDeviceFault | STATUS_OTHER: Output OR-ing Device Fault
Public property | STATUSTEMPERATUREOTFAULT | STATUS_TEMPERATURE: OT_FAULT
Public property | STATUSTEMPERATUREOTWARNING | STATUS_TEMPERATURE: OT_WARNING
Public property | STATUSTEMPERATUREUTFAULT | STATUS_TEMPERATURE: UT_FAULT
Public property | STATUSTEMPERATUREUTWARNING | STATUS_TEMPERATURE: UT_WARNING
Public property | STATUSVOUTTOFFMAXWARNING | STATUS_VOUT: TOFF_MAX_WARNING
Public property | STATUSVOUTTONMAXFAULT | STATUS_VOUT: TON_MAX_FAULT
Public property | STATUSVOUTVOUTMAX | STATUS_VOUT: VOUT_MAX
Public property | STATUSVOUTVOUTOVFAULT | STATUS_VOUT: VOUT_OV_FAULT
Public property | STATUSVOUTVOUTOVWARNING | STATUS_VOUT: VOUT_OV_WARNING
Public property | STATUSVOUTVOUTTrackingError | STATUS_VOUT: VOUT Tracking Error
Public property | STATUSVOUTVOUTUVFAULT | STATUS_VOUT: VOUT_UV_FAULT
Public property | STATUSVOUTVOUTUVWARNING | STATUS_VOUT: VOUT_UV_WARNING
Public property | STATUSWORDBUSY | STATUS_WORD: BUSY
Public property | STATUSWORDCML | STATUS_WORD: CML
Public property | STATUSWORDFANS | STATUS_WORD: FANS
Public property | STATUSWORDINPUT | STATUS_WORD: INPUT
Public property | STATUSWORDIOUTOCFAULT | STATUS_WORD: IOUT_OC_FAULT
Public property | STATUSWORDIOUTPOUT | STATUS_WORD: IOUT/POUT
Public property | STATUSWORDMFRSPECIFIC | STATUS_WORD: MFR_SPECIFIC
Public property | STATUSWORDNONEOFTHEABOVE | STATUS_WORD: NONE OF THE ABOVE
Public property | STATUSWORDOFF | STATUS_WORD: OFF
Public property | STATUSWORDOTHER | STATUS_WORD: OTHER
Public property | STATUSWORDPOWERGOOD | STATUS_WORD: POWER_GOOD#
Public property | STATUSWORDTEMPERATURE | STATUS_WORD: TEMPERATURE
Public property | STATUSWORDUNKNOWN | STATUS_WORD: UNKNOWN
Public property | STATUSWORDVINUVFAULT | STATUS_WORD: VIN_UV_FAULT
Public property | STATUSWORDVOUT | STATUS_WORD: VOUT
Public property | STATUSWORDVOUTOVFAULT | STATUS_WORD: VOUT_OV_FAULT
Public property | STOREDEFAULTCODE | STORE_DEFAULT_CODE
Public property | STOREUSERCODE | STORE_USER_CODE
Public property | TOFFDELAY | TOFF_DELAY
Public property | TOFFFALL | TOFF_FALL
Public property | TOFFMAXWARNLIMIT | TOFF_MAX_WARN_LIMIT
Public property | TONDELAY | TON_DELAY
Public property | TONMAXFAULTLIMIT | TON_MAX_FAULT_LIMIT
Public property | TONMAXFAULTRESPONSEDelayTime | TON_MAX_FAULT_RESPONSE: Delay Time
Public property | TONMAXFAULTRESPONSEResponse | TON_MAX_FAULT_RESPONSE: Response
Public property | TONMAXFAULTRESPONSERetrySetting | TON_MAX_FAULT_RESPONSE: Retry Setting
Public property | TONRISE | TON_RISE
Public property | USERDATA00 | USER_DATA_00
Public property | USERDATA01 | USER_DATA_01
Public property | USERDATA02 | USER_DATA_02
Public property | USERDATA03 | USER_DATA_03
Public property | USERDATA04 | USER_DATA_04
Public property | USERDATA05 | USER_DATA_05
Public property | USERDATA06 | USER_DATA_06
Public property | USERDATA07 | USER_DATA_07
Public property | USERDATA08 | USER_DATA_08
Public property | USERDATA09 | USER_DATA_09
Public property | USERDATA10 | USER_DATA_10
Public property | USERDATA11 | USER_DATA_11
Public property | USERDATA12 | USER_DATA_12
Public property | USERDATA13 | USER_DATA_13
Public property | USERDATA14 | USER_DATA_14
Public property | USERDATA15 | USER_DATA_15
Public property | UTFAULTLIMIT | UT_FAULT_LIMIT
Public property | UTFAULTRESPONSEDelayTime | UT_FAULT_RESPONSE: Delay Time
Public property | UTFAULTRESPONSEResponse | UT_FAULT_RESPONSE: Response
Public property | UTFAULTRESPONSERetrySetting | UT_FAULT_RESPONSE: Retry Setting
Public property | UTWARNLIMIT | UT_WARN_LIMIT
Public property | VINOFF | VIN_OFF
Public property | VINON | VIN_ON
Public property | VINOVFAULTLIMIT | VIN_OV_FAULT_LIMIT
Public property | VINOVFAULTRESPONSEDelayTime | VIN_OV_FAULT_RESPONSE: Delay Time
Public property | VINOVFAULTRESPONSEResponse | VIN_OV_FAULT_RESPONSE: Response
Public property | VINOVFAULTRESPONSERetrySetting | VIN_OV_FAULT_RESPONSE: Retry Setting
Public property | VINOVWARNLIMIT | VIN_OV_WARN_LIMIT
Public property | VINUVFAULTLIMIT | VIN_UV_FAULT_LIMIT
Public property | VINUVFAULTRESPONSEDelayTime | VIN_UV_FAULT_RESPONSE: Delay Time
Public property | VINUVFAULTRESPONSEResponse | VIN_UV_FAULT_RESPONSE: Response
Public property | VINUVFAULTRESPONSERetrySetting | VIN_UV_FAULT_RESPONSE: Retry Setting
Public property | VINUVWARNLIMIT | VIN_UV_WARN_LIMIT
Public property | VOUTCALOFFSET | VOUT_CAL_OFFSET
Public property | VOUTCOMMAND | VOUT_COMMAND
Public property | VOUTDROOP | VOUT_DROOP
Public property | VOUTMARGINHIGH | VOUT_MARGIN_HIGH
Public property | VOUTMARGINLOW | VOUT_MARGIN_LOW
Public property | VOUTMAX | VOUT_MAX
Public property | VOUTMIN | VOUT_MIN
Public property | VOUTMODEMode | VOUT_MODE: Mode
Public property | VOUTMODEParameter | VOUT_MODE: Parameter
Public property | VOUTOVFAULTLIMIT | VOUT_OV_FAULT_LIMIT
Public property | VOUTOVFAULTRESPONSEDelayTime | VOUT_OV_FAULT_RESPONSE: Delay Time
Public property | VOUTOVFAULTRESPONSEResponse | VOUT_OV_FAULT_RESPONSE: Response
Public property | VOUTOVFAULTRESPONSERetrySetting | VOUT_OV_FAULT_RESPONSE: Retry Setting
Public property | VOUTOVWARNLIMIT | VOUT_OV_WARN_LIMIT
Public property | VOUTSCALELOOP | VOUT_SCALE_LOOP
Public property | VOUTSCALEMONITOR | VOUT_SCALE_MONITOR
Public property | VOUTTRANSITIONRATE | VOUT_TRANSITION_RATE
Public property | VOUTTRIM | VOUT_TRIM
Public property | VOUTUVFAULTLIMIT | VOUT_UV_FAULT_LIMIT
Public property | VOUTUVFAULTRESPONSEDelayTime | VOUT_UV_FAULT_RESPONSE: Delay Time
Public property | VOUTUVFAULTRESPONSEResponse | VOUT_UV_FAULT_RESPONSE: Response
Public property | VOUTUVFAULTRESPONSERetrySetting | VOUT_UV_FAULT_RESPONSE: Retry Setting
Public property | VOUTUVWARNLIMIT | VOUT_UV_WARN_LIMIT
Public property | WRITEPROTECT | WRITE_PROTECT
Public property | ZONEACTIVEACTIVEREADZONE | ZONE_ACTIVE: ACTIVE READ ZONE
Public property | ZONEACTIVEACTIVEWRITEZONE | ZONE_ACTIVE: ACTIVE WRITE ZONE
Public property | ZONECONFIGASSIGNEDREADZONE | ZONE_CONFIG: ASSIGNED READ ZONE
Public property | ZONECONFIGASSIGNEDWRITEZONE | ZONE_CONFIG: ASSIGNED WRITE ZONE
Public property | ZONECONFIGPAGENUMBER | ZONE_CONFIG: PAGE NUMBER
Top
Methods
 | Name | Description
Public method | CLEARFAULTS | CLEAR_FAULTS
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RESTOREDEFAULTALL | RESTORE_DEFAULT_ALL
Public method | RESTOREUSERALL | RESTORE_USER_ALL
Public method | STOREDEFAULTALL | STORE_DEFAULT_ALL
Public method | STOREUSERALL | STORE_USER_ALL
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
PMBus 1.3 - Power System Management Protocol
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus Constructor

Constructor

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pmbus(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pmbus(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pmbus

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus Properties

The Pmbus type exposes the following members.

Properties
 | Name | Description
Public property | APPPROFILESUPPORTApplication1MajorRevision | APP_PROFILE_SUPPORT: Application 1 Major Revision
Public property | APPPROFILESUPPORTApplication1MinorRevision | APP_PROFILE_SUPPORT: Application 1 Minor Revision
Public property | APPPROFILESUPPORTApplication1Profile | APP_PROFILE_SUPPORT: Application 1 Profile
Public property | APPPROFILESUPPORTApplication2MajorRevision | APP_PROFILE_SUPPORT: Application 2 Major Revision
Public property | APPPROFILESUPPORTApplication2MinorRevision | APP_PROFILE_SUPPORT: Application 2 Minor Revision
Public property | APPPROFILESUPPORTApplication2Profile | APP_PROFILE_SUPPORT: Application 2 Profile
Public property | APPPROFILESUPPORTApplication3MajorRevision | APP_PROFILE_SUPPORT: Application 3 Major Revision
Public property | APPPROFILESUPPORTApplication3MinorRevision | APP_PROFILE_SUPPORT: Application 3 Minor Revision
Public property | APPPROFILESUPPORTApplication3Profile | APP_PROFILE_SUPPORT: Application 3 Profile
Public property | APPPROFILESUPPORTApplication4MajorRevision | APP_PROFILE_SUPPORT: Application 4 Major Revision
Public property | APPPROFILESUPPORTApplication4MinorRevision | APP_PROFILE_SUPPORT: Application 4 Minor Revision
Public property | APPPROFILESUPPORTApplication4Profile | APP_PROFILE_SUPPORT: Application 4 Profile
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CAPABILITYAVSBusSupport | CAPABILITY: AVSBus Support
Public property | CAPABILITYMaximumBusSpeed | CAPABILITY: Maximum Bus Speed
Public property | CAPABILITYNumericFormat | CAPABILITY: Numeric Format
Public property | CAPABILITYPacketErrorChecking | CAPABILITY: Packet Error Checking
Public property | CAPABILITYSMBALERT | CAPABILITY: SMBALERT#
Public property | COEFFICIENTSB | COEFFICIENTS: b
Public property | COEFFICIENTSCommandCode | COEFFICIENTS: Command Code
Public property | COEFFICIENTSM | COEFFICIENTS: m
Public property | COEFFICIENTSR | COEFFICIENTS: R
Public property | COEFFICIENTSType | COEFFICIENTS: Type
Public property | FANCOMMAND1 | FAN_COMMAND_1
Public property | FANCOMMAND2 | FAN_COMMAND_2
Public property | FANCOMMAND3 | FAN_COMMAND_3
Public property | FANCOMMAND4 | FAN_COMMAND_4
Public property | FANCONFIG12Fan1CommandedBy | FAN_CONFIG_1_2: Fan 1 Commanded By
Public property | FANCONFIG12Fan1Installed | FAN_CONFIG_1_2: Fan 1 Installed
Public property | FANCONFIG12Fan1PulsesPerRevolution | FAN_CONFIG_1_2: Fan 1 Pulses Per Revolution
Public property | FANCONFIG12Fan2CommandedBy | FAN_CONFIG_1_2: Fan 2 Commanded By
Public property | FANCONFIG12Fan2Installed | FAN_CONFIG_1_2: Fan 2 Installed
Public property | FANCONFIG12Fan2PulsesPerRevolution | FAN_CONFIG_1_2: Fan 2 Pulses Per Revolution
Public property | FANCONFIG34Fan3CommandedBy | FAN_CONFIG_3_4: Fan 3 Commanded By
Public property | FANCONFIG34Fan3Installed | FAN_CONFIG_3_4: Fan 3 Installed
Public property | FANCONFIG34Fan3PulsesPerRevolution | FAN_CONFIG_3_4: Fan 3 Pulses Per Revolution
Public property | FANCONFIG34Fan4CommandedBy | FAN_CONFIG_3_4: Fan 4 Commanded By
Public property | FANCONFIG34Fan4Installed | FAN_CONFIG_3_4: Fan 4 Installed
Public property | FANCONFIG34Fan4PulsesPerRevolution | FAN_CONFIG_3_4: Fan 4 Pulses Per Revolution
Public property | FREQUENCYSWITCH | FREQUENCY_SWITCH
Public property | ICDEVICEID | IC_DEVICE_ID
Public property | ICDEVICEREV | IC_DEVICE_REV
Public property | IINOCFAULTLIMIT | IIN_OC_FAULT_LIMIT
Public property | IINOCFAULTRESPONSEDelayTime | IIN_OC_FAULT_RESPONSE: Delay Time
Public property | IINOCFAULTRESPONSEResponse | IIN_OC_FAULT_RESPONSE: Response
Public property | IINOCFAULTRESPONSERetrySetting | IIN_OC_FAULT_RESPONSE: Retry Setting
Public property | IINOCWARNLIMIT | IIN_OC_WARN_LIMIT
Public property | INTERLEAVEGroupIDNumber | INTERLEAVE: Group ID Number
Public property | INTERLEAVEInterleaveOrder | INTERLEAVE: Interleave Order
Public property | INTERLEAVENumberInGroup | INTERLEAVE: Number In Group
Public property | IOUTCALGAIN | IOUT_CAL_GAIN
Public property | IOUTCALOFFSET | IOUT_CAL_OFFSET
Public property | IOUTOCFAULTLIMIT | IOUT_OC_FAULT_LIMIT
Public property | IOUTOCFAULTRESPONSEDelayTime | IOUT_OC_FAULT_RESPONSE: Delay Time
Public property | IOUTOCFAULTRESPONSEResponse | IOUT_OC_FAULT_RESPONSE: Response
Public property | IOUTOCFAULTRESPONSERetrySetting | IOUT_OC_FAULT_RESPONSE: Retry Setting
Public property | IOUTOCLVFAULTLIMIT | IOUT_OC_LV_FAULT_LIMIT
Public property | IOUTOCLVFAULTRESPONSEDelayTime | IOUT_OC_LV_FAULT_RESPONSE: Delay Time
Public property | IOUTOCLVFAULTRESPONSEResponse | IOUT_OC_LV_FAULT_RESPONSE: Response
Public property | IOUTOCLVFAULTRESPONSERetrySetting | IOUT_OC_LV_FAULT_RESPONSE: Retry Setting
Public property | IOUTOCWARNLIMIT | IOUT_OC_WARN_LIMIT
Public property | IOUTUCFAULTLIMIT | IOUT_UC_FAULT_LIMIT
Public property | IOUTUCFAULTRESPONSEDelayTime | IOUT_UC_FAULT_RESPONSE: Delay Time
Public property | IOUTUCFAULTRESPONSEResponse | IOUT_UC_FAULT_RESPONSE: Response
Public property | IOUTUCFAULTRESPONSERetrySetting | IOUT_UC_FAULT_RESPONSE: Retry Setting
Public property | MAXDUTY | MAX_DUTY
Public property | MFRDATE | MFR_DATE
Public property | MFREFFICIENCYHLEfficiencyHighPower | MFR_EFFICIENCY_HL: Efficiency (High Power)
Public property | MFREFFICIENCYHLEfficiencyLowPower | MFR_EFFICIENCY_HL: Efficiency (Low Power)
Public property | MFREFFICIENCYHLEfficiencyMediumPower | MFR_EFFICIENCY_HL: Efficiency (Medium Power)
Public property | MFREFFICIENCYHLInputVoltageHighLine | MFR_EFFICIENCY_HL: Input Voltage (High Line)
Public property | MFREFFICIENCYHLPowerHighPower | MFR_EFFICIENCY_HL: Power (High Power)
Public property | MFREFFICIENCYHLPowerLowPower | MFR_EFFICIENCY_HL: Power (Low Power)
Public property | MFREFFICIENCYHLPowerMediumPower | MFR_EFFICIENCY_HL: Power (Medium Power)
Public property | MFREFFICIENCYLLEfficiencyHighPower | MFR_EFFICIENCY_LL: Efficiency (High Power)
Public property | MFREFFICIENCYLLEfficiencyLowPower | MFR_EFFICIENCY_LL: Efficiency (Low Power)
Public property | MFREFFICIENCYLLEfficiencyMediumPower | MFR_EFFICIENCY_LL: Efficiency (Medium Power)
Public property | MFREFFICIENCYLLInputVoltageLowLine | MFR_EFFICIENCY_LL: Input Voltage (Low Line)
Public property | MFREFFICIENCYLLPowerHighPower | MFR_EFFICIENCY_LL: Power (High Power)
Public property | MFREFFICIENCYLLPowerLowPower | MFR_EFFICIENCY_LL: Power (Low Power)
Public property | MFREFFICIENCYLLPowerMediumPower | MFR_EFFICIENCY_LL: Power (Medium Power)
Public property | MFRID | MFR_ID
Public property | MFRIINMAX | MFR_IIN_MAX
Public property | MFRIOUTMAX | MFR_IOUT_MAX
Public property | MFRLOCATION | MFR_LOCATION
Public property | MFRMODEL | MFR_MODEL
Public property | MFRPINACCURACY | MFR_PIN_ACCURACY (unit: %)
Public property | MFRPINMAX | MFR_PIN_MAX
Public property | MFRPOUTMAX | MFR_POUT_MAX
Public property | MFRREVISION | MFR_REVISION
Public property | MFRSERIAL | MFR_SERIAL
Public property | MFRTAMBIENTMAX | MFR_TAMBIENT_MAX
Public property | MFRTAMBIENTMIN | MFR_TAMBIENT_MIN
Public property | MFRVINMAX | MFR_VIN_MAX
Public property | MFRVINMIN | MFR_VIN_MIN
Public property | MFRVOUTMAX | MFR_VOUT_MAX
Public property | MFRVOUTMIN | MFR_VOUT_MIN
Public property | ONOFFCONFIGCONTROLPin | ON_OFF_CONFIG: CONTROL Pin
Public property | ONOFFCONFIGCONTROLPinAction | ON_OFF_CONFIG: CONTROL Pin Action
Public property | ONOFFCONFIGPolarityCONTROLPin | ON_OFF_CONFIG: Polarity CONTROL Pin
Public property | ONOFFCONFIGPowerUp | ON_OFF_CONFIG: Power Up
Public property | ONOFFCONFIGSerialBus | ON_OFF_CONFIG: Serial Bus
Public property | OPERATION | OPERATION
Public property | OTFAULTLIMIT | OT_FAULT_LIMIT
Public property | OTFAULTRESPONSEDelayTime | OT_FAULT_RESPONSE: Delay Time
Public property | OTFAULTRESPONSEResponse | OT_FAULT_RESPONSE: Response
Public property | OTFAULTRESPONSERetrySetting | OT_FAULT_RESPONSE: Retry Setting
Public property | OTWARNLIMIT | OT_WARN_LIMIT
Public property | PAGE | PAGE
Public property | PAGEPLUSREADCOMMANDCODE | PAGE_PLUS_READ: COMMAND CODE
Public property | PAGEPLUSREADDATA | PAGE_PLUS_READ: DATA
Public property | PAGEPLUSREADPAGENUMBER | PAGE_PLUS_READ: PAGE NUMBER
Public property | PAGEPLUSWRITECOMMANDCODE | PAGE_PLUS_WRITE: COMMAND CODE
Public property | PAGEPLUSWRITEDATA | PAGE_PLUS_WRITE: DATA
Public property | PAGEPLUSWRITEPAGENUMBER | PAGE_PLUS_WRITE: PAGE NUMBER
Public property | PHASE | PHASE
Public property | PINOPWARNLIMIT | PIN_OP_WARN_LIMIT
Public property | PMBUSREVISIONPartIIRevision | PMBUS_REVISION: Part II Revision
Public property | PMBUSREVISIONPartIRevision | PMBUS_REVISION: Part I Revision
Public property | POUTMAX | POUT_MAX
Public property | POUTOPFAULTLIMIT | POUT_OP_FAULT_LIMIT
Public property | POUTOPFAULTRESPONSEDelayTime | POUT_OP_FAULT_RESPONSE: Delay Time
Public property | POUTOPFAULTRESPONSEResponse | POUT_OP_FAULT_RESPONSE: Response
Public property | POUTOPFAULTRESPONSERetrySetting | POUT_OP_FAULT_RESPONSE: Retry Setting
Public property | POUTOPWARNLIMIT | POUT_OP_WARN_LIMIT
Public property | POWERGOODOFF | POWER_GOOD_OFF
Public property | POWERGOODON | POWER_GOOD_ON
Public property | POWERMODE | POWER_MODE
Public property | QUERYCommand | QUERY: Command
Public property | QUERYCommandCode | QUERY: Command Code
Public property | QUERYCommandRead | QUERY: Command Read
Public property | QUERYCommandWrite | QUERY: Command Write
Public property | QUERYFormat | QUERY: Format
Public property | READDUTYCYCLE | READ_DUTY_CYCLE
Public property | READEINENERGYCOUNT | READ_EIN: ENERGY_COUNT
Public property | READEINROLLOVERCOUNT | READ_EIN: ROLLOVER_COUNT
Public property | READEINSAMPLECOUNT | READ_EIN: SAMPLE_COUNT
Public property | READEOUTENERGYCOUNT | READ_EOUT: ENERGY_COUNT
Public property | READEOUTROLLOVERCOUNT | READ_EOUT: ROLLOVER_COUNT
Public property | READEOUTSAMPLECOUNT | READ_EOUT: SAMPLE_COUNT
Public property | READFANSPEED1 | READ_FAN_SPEED_1
Public property | READFANSPEED2 | READ_FAN_SPEED_2
Public property | READFANSPEED3 | READ_FAN_SPEED_3
Public property | READFANSPEED4 | READ_FAN_SPEED_4
Public property | READFREQUENCY | READ_FREQUENCY
Public property | READIIN | READ_IIN
Public property | READIOUT | READ_IOUT
Public property | READKWHCONFIGInputFormat | READ_KWH_CONFIG: Input Format
Public property | READKWHCONFIGInputHasBeenResetted | READ_KWH_CONFIG: Input Has Been Resetted
Public property | READKWHCONFIGInputResetSupported | READ_KWH_CONFIG: Input Reset Supported
Public property | READKWHCONFIGInputUnits | READ_KWH_CONFIG: Input Units
Public property | READKWHCONFIGInputValueRolledOver | READ_KWH_CONFIG: Input Value Rolled Over
Public property | READKWHCONFIGInputVolatile | READ_KWH_CONFIG: Input Volatile
Public property | READKWHCONFIGOutputFormat | READ_KWH_CONFIG: Output Format
Public property | READKWHCONFIGOutputHasBeenResetted | READ_KWH_CONFIG: Output Has Been Resetted
Public property | READKWHCONFIGOutputResetSupported | READ_KWH_CONFIG: Output Reset Supported
Public property | READKWHCONFIGOutputUnits | READ_KWH_CONFIG: Output Units
Public property | READKWHCONFIGOutputValueRolledOver | READ_KWH_CONFIG: Output Value Rolled Over
Public property | READKWHCONFIGOutputVolatile | READ_KWH_CONFIG: Output Volatile
Public property | READKWHCONFIGREADKWHINSupported | READ_KWH_CONFIG: READ_KWH_IN Supported
Public property | READKWHCONFIGREADKWHOUTSupported | READ_KWH_CONFIG: READ_KWH_OUT Supported
Public property | READKWHIN | READ_KWH_IN
Public property | READKWHOUT | READ_KWH_OUT
Public property | READPIN | READ_PIN
Public property | READPOUT | READ_POUT
Public property | READTEMPERATURE1 | READ_TEMPERATURE_1
Public property | READTEMPERATURE2 | READ_TEMPERATURE_2
Public property | READTEMPERATURE3 | READ_TEMPERATURE_3
Public property | READVCAP | READ_VCAP
Public property | READVIN | READ_VIN
Public property | READVOUT | READ_VOUT
Public property | RESTOREDEFAULTCODE | RESTORE_DEFAULT_CODE
Public property | RESTOREUSERCODE | RESTORE_USER_CODE
Public property | SMBALERTMASKMask | SMBALERT_MASK: Mask
Public property | SMBALERTMASKStatusCommandCode | SMBALERT_MASK: Status Command Code
Public property | STATUSBYTEBUSY | STATUS_BYTE: BUSY
Public property | STATUSBYTECML | STATUS_BYTE: CML
Public property | STATUSBYTEIOUTOCFAULT | STATUS_BYTE: IOUT_OC_FAULT
Public property | STATUSBYTENONEOFTHEABOVE | STATUS_BYTE: NONE OF THE ABOVE
Public property | STATUSBYTEOFF | STATUS_BYTE: OFF
Public property | STATUSBYTETEMPERATURE | STATUS_BYTE: TEMPERATURE
Public property | STATUSBYTEVINUVFAULT | STATUS_BYTE: VIN_UV_FAULT
Public property | STATUSBYTEVOUTOVFAULT | STATUS_BYTE: VOUT_OV_FAULT
Public property | STATUSCMLInvalidOrUnsupportedCommandReceived | STATUS_CML: Invalid Or Unsupported Command Received
Public property | STATUSCMLInvalidOrUnsupportedDataReceived | STATUS_CML: Invalid Or Unsupported Data Received
Public property | STATUSCMLMemoryFaultDetected | STATUS_CML: Memory Fault Detected
Public property | STATUSCMLOtherCommunicationFault | STATUS_CML: Other Communication Fault
Public property | STATUSCMLOtherMemoryOrLogicFault | STATUS_CML: Other Memory Or Logic Fault
Public property | STATUSCMLPacketErrorCheckFailed | STATUS_CML: Packet Error Check Failed
Public property | STATUSCMLProcessorFaultDetected | STATUS_CML: Processor Fault Detected
Public property | STATUSFANS12AirflowFault | STATUS_FANS_1_2: Airflow Fault
Public property | STATUSFANS12AirflowWarning | STATUS_FANS_1_2: Airflow Warning
Public property | STATUSFANS12Fan1Fault | STATUS_FANS_1_2: Fan 1 Fault
Public property | STATUSFANS12Fan1SpeedOverridden | STATUS_FANS_1_2: Fan 1 Speed Overridden
Public property | STATUSFANS12Fan1Warning | STATUS_FANS_1_2: Fan 1 Warning
Public property | STATUSFANS12Fan2Fault | STATUS_FANS_1_2: Fan 2 Fault
Public property | STATUSFANS12Fan2SpeedOverridden | STATUS_FANS_1_2: Fan 2 Speed Overridden
Public property | STATUSFANS12Fan2Warning | STATUS_FANS_1_2: Fan 2 Warning
Public property | STATUSFANS34Fan3Fault | STATUS_FANS_3_4: Fan 3 Fault
Public property | STATUSFANS34Fan3SpeedOverridden | STATUS_FANS_3_4: Fan 3 Speed Overridden
Public property | STATUSFANS34Fan3Warning | STATUS_FANS_3_4: Fan 3 Warning
Public property | STATUSFANS34Fan4Fault | STATUS_FANS_3_4: Fan 4 Fault
Public property | STATUSFANS34Fan4SpeedOverridden | STATUS_FANS_3_4: Fan 4 Speed Overridden
Public property | STATUSFANS34Fan4Warning | STATUS_FANS_3_4: Fan 4 Warning
Public property | STATUSINPUTIINOCFAULT | STATUS_INPUT: IIN_OC_FAULT
Public property | STATUSINPUTIINOCWARNING | STATUS_INPUT: IIN_OC_WARNING
Public property | STATUSINPUTPINOPWARNING | STATUS_INPUT: PIN_OP_WARNING
Public property | STATUSINPUTUnitOffForInsufficientInputVoltage | STATUS_INPUT: Unit Off For Insufficient Input Voltage
Public property | STATUSINPUTVINOVFAULT | STATUS_INPUT: VIN_OV_FAULT
Public property | STATUSINPUTVINOVWARNING | STATUS_INPUT: VIN_OV_WARNING
Public property | STATUSINPUTVINUVFAULT | STATUS_INPUT: VIN_UV_FAULT
Public property | STATUSINPUTVINUVWARNING | STATUS_INPUT: VIN_UV_WARNING
Public property | STATUSIOUTCurrentShareFault | STATUS_IOUT: Current Share Fault
Public property | STATUSIOUTInPowerLimitingMode | STATUS_IOUT: In Power Limiting Mode
Public property | STATUSIOUTIOUTOCFAULT | STATUS_IOUT: IOUT_OC_FAULT
Public property | STATUSIOUTIOUTOCLVFAULT | STATUS_IOUT: IOUT_OC_LV_FAULT
Public property | STATUSIOUTIOUTOCWARNING | STATUS_IOUT: IOUT_OC_WARNING
Public property | STATUSIOUTIOUTUCFAULT | STATUS_IOUT: IOUT_UC_FAULT
Public property | STATUSIOUTPOUTOPFAULT | STATUS_IOUT: POUT_OP_FAULT
Public property | STATUSIOUTPOUTOPWARNING | STATUS_IOUT: POUT_OP_WARNING
Public property | STATUSMFRSPECIFIC | STATUS_MFR_SPECIFIC
Public property | STATUSOTHERFirstToAssertSMBALERT | STATUS_OTHER: First To Assert SMBALERT#
Public property | STATUSOTHERInputAFuseOrCircuitBreakerFault | STATUS_OTHER: Input A Fuse Or Circuit Breaker Fault
Public property | STATUSOTHERInputAORIngDeviceFault | STATUS_OTHER: Input A OR-ing Device Fault
Public property | STATUSOTHERInputBFuseOrCircuitBreakerFault | STATUS_OTHER: Input B Fuse Or Circuit Breaker Fault
Public property | STATUSOTHERInputBORIngDeviceFault | STATUS_OTHER: Input B OR-ing Device Fault
Public property | STATUSOTHEROutputORIngDeviceFault | STATUS_OTHER: Output OR-ing Device Fault
Public property | STATUSTEMPERATUREOTFAULT | STATUS_TEMPERATURE: OT_FAULT
Public property | STATUSTEMPERATUREOTWARNING | STATUS_TEMPERATURE: OT_WARNING
Public property | STATUSTEMPERATUREUTFAULT | STATUS_TEMPERATURE: UT_FAULT
Public property | STATUSTEMPERATUREUTWARNING | STATUS_TEMPERATURE: UT_WARNING
Public property | STATUSVOUTTOFFMAXWARNING | STATUS_VOUT: TOFF_MAX_WARNING
Public property | STATUSVOUTTONMAXFAULT | STATUS_VOUT: TON_MAX_FAULT
Public property | STATUSVOUTVOUTMAX | STATUS_VOUT: VOUT_MAX
Public property | STATUSVOUTVOUTOVFAULT | STATUS_VOUT: VOUT_OV_FAULT
Public property | STATUSVOUTVOUTOVWARNING | STATUS_VOUT: VOUT_OV_WARNING
Public property | STATUSVOUTVOUTTrackingError | STATUS_VOUT: VOUT Tracking Error
Public property | STATUSVOUTVOUTUVFAULT | STATUS_VOUT: VOUT_UV_FAULT
Public property | STATUSVOUTVOUTUVWARNING | STATUS_VOUT: VOUT_UV_WARNING
Public property | STATUSWORDBUSY | STATUS_WORD: BUSY
Public property | STATUSWORDCML | STATUS_WORD: CML
Public property | STATUSWORDFANS | STATUS_WORD: FANS
Public property | STATUSWORDINPUT | STATUS_WORD: INPUT
Public property | STATUSWORDIOUTOCFAULT | STATUS_WORD: IOUT_OC_FAULT
Public property | STATUSWORDIOUTPOUT | STATUS_WORD: IOUT/POUT
Public property | STATUSWORDMFRSPECIFIC | STATUS_WORD: MFR_SPECIFIC
Public property | STATUSWORDNONEOFTHEABOVE | STATUS_WORD: NONE OF THE ABOVE
Public property | STATUSWORDOFF | STATUS_WORD: OFF
Public property | STATUSWORDOTHER | STATUS_WORD: OTHER
Public property | STATUSWORDPOWERGOOD | STATUS_WORD: POWER_GOOD#
Public property | STATUSWORDTEMPERATURE | STATUS_WORD: TEMPERATURE
Public property | STATUSWORDUNKNOWN | STATUS_WORD: UNKNOWN
Public property | STATUSWORDVINUVFAULT | STATUS_WORD: VIN_UV_FAULT
Public property | STATUSWORDVOUT | STATUS_WORD: VOUT
Public property | STATUSWORDVOUTOVFAULT | STATUS_WORD: VOUT_OV_FAULT
Public property | STOREDEFAULTCODE | STORE_DEFAULT_CODE
Public property | STOREUSERCODE | STORE_USER_CODE
Public property | TOFFDELAY | TOFF_DELAY
Public property | TOFFFALL | TOFF_FALL
Public property | TOFFMAXWARNLIMIT | TOFF_MAX_WARN_LIMIT
Public property | TONDELAY | TON_DELAY
Public property | TONMAXFAULTLIMIT | TON_MAX_FAULT_LIMIT
Public property | TONMAXFAULTRESPONSEDelayTime | TON_MAX_FAULT_RESPONSE: Delay Time
Public property | TONMAXFAULTRESPONSEResponse | TON_MAX_FAULT_RESPONSE: Response
Public property | TONMAXFAULTRESPONSERetrySetting | TON_MAX_FAULT_RESPONSE: Retry Setting
Public property | TONRISE | TON_RISE
Public property | USERDATA00 | USER_DATA_00
Public property | USERDATA01 | USER_DATA_01
Public property | USERDATA02 | USER_DATA_02
Public property | USERDATA03 | USER_DATA_03
Public property | USERDATA04 | USER_DATA_04
Public property | USERDATA05 | USER_DATA_05
Public property | USERDATA06 | USER_DATA_06
Public property | USERDATA07 | USER_DATA_07
Public property | USERDATA08 | USER_DATA_08
Public property | USERDATA09 | USER_DATA_09
Public property | USERDATA10 | USER_DATA_10
Public property | USERDATA11 | USER_DATA_11
Public property | USERDATA12 | USER_DATA_12
Public property | USERDATA13 | USER_DATA_13
Public property | USERDATA14 | USER_DATA_14
Public property | USERDATA15 | USER_DATA_15
Public property | UTFAULTLIMIT | UT_FAULT_LIMIT
Public property | UTFAULTRESPONSEDelayTime | UT_FAULT_RESPONSE: Delay Time
Public property | UTFAULTRESPONSEResponse | UT_FAULT_RESPONSE: Response
Public property | UTFAULTRESPONSERetrySetting | UT_FAULT_RESPONSE: Retry Setting
Public property | UTWARNLIMIT | UT_WARN_LIMIT
Public property | VINOFF | VIN_OFF
Public property | VINON | VIN_ON
Public property | VINOVFAULTLIMIT | VIN_OV_FAULT_LIMIT
Public property | VINOVFAULTRESPONSEDelayTime | VIN_OV_FAULT_RESPONSE: Delay Time
Public property | VINOVFAULTRESPONSEResponse | VIN_OV_FAULT_RESPONSE: Response
Public property | VINOVFAULTRESPONSERetrySetting | VIN_OV_FAULT_RESPONSE: Retry Setting
Public property | VINOVWARNLIMIT | VIN_OV_WARN_LIMIT
Public property | VINUVFAULTLIMIT | VIN_UV_FAULT_LIMIT
Public property | VINUVFAULTRESPONSEDelayTime | VIN_UV_FAULT_RESPONSE: Delay Time
Public property | VINUVFAULTRESPONSEResponse | VIN_UV_FAULT_RESPONSE: Response
Public property | VINUVFAULTRESPONSERetrySetting | VIN_UV_FAULT_RESPONSE: Retry Setting
Public property | VINUVWARNLIMIT | VIN_UV_WARN_LIMIT
Public property | VOUTCALOFFSET | VOUT_CAL_OFFSET
Public property | VOUTCOMMAND | VOUT_COMMAND
Public property | VOUTDROOP | VOUT_DROOP
Public property | VOUTMARGINHIGH | VOUT_MARGIN_HIGH
Public property | VOUTMARGINLOW | VOUT_MARGIN_LOW
Public property | VOUTMAX | VOUT_MAX
Public property | VOUTMIN | VOUT_MIN
Public property | VOUTMODEMode | VOUT_MODE: Mode
Public property | VOUTMODEParameter | VOUT_MODE: Parameter
Public property | VOUTOVFAULTLIMIT | VOUT_OV_FAULT_LIMIT
Public property | VOUTOVFAULTRESPONSEDelayTime | VOUT_OV_FAULT_RESPONSE: Delay Time
Public property | VOUTOVFAULTRESPONSEResponse | VOUT_OV_FAULT_RESPONSE: Response
Public property | VOUTOVFAULTRESPONSERetrySetting | VOUT_OV_FAULT_RESPONSE: Retry Setting
Public property | VOUTOVWARNLIMIT | VOUT_OV_WARN_LIMIT
Public property | VOUTSCALELOOP | VOUT_SCALE_LOOP
Public property | VOUTSCALEMONITOR | VOUT_SCALE_MONITOR
Public property | VOUTTRANSITIONRATE | VOUT_TRANSITION_RATE
Public property | VOUTTRIM | VOUT_TRIM
Public property | VOUTUVFAULTLIMIT | VOUT_UV_FAULT_LIMIT
Public property | VOUTUVFAULTRESPONSEDelayTime | VOUT_UV_FAULT_RESPONSE: Delay Time
Public property | VOUTUVFAULTRESPONSEResponse | VOUT_UV_FAULT_RESPONSE: Response
Public property | VOUTUVFAULTRESPONSERetrySetting | VOUT_UV_FAULT_RESPONSE: Retry Setting
Public property | VOUTUVWARNLIMIT | VOUT_UV_WARN_LIMIT
Public property | WRITEPROTECT | WRITE_PROTECT
Public property | ZONEACTIVEACTIVEREADZONE | ZONE_ACTIVE: ACTIVE READ ZONE
Public property | ZONEACTIVEACTIVEWRITEZONE | ZONE_ACTIVE: ACTIVE WRITE ZONE
Public property | ZONECONFIGASSIGNEDREADZONE | ZONE_CONFIG: ASSIGNED READ ZONE
Public property | ZONECONFIGASSIGNEDWRITEZONE | ZONE_CONFIG: ASSIGNED WRITE ZONE
Public property | ZONECONFIGPAGENUMBER | ZONE_CONFIG: PAGE NUMBER
Top
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.APPPROFILESUPPORTApplication1MajorRevision Property

IRD

PmbusAPPPROFILESUPPORTApplication1MajorRevision Property

APP_PROFILE_SUPPORT: Application 1 Major Revision

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte APPPROFILESUPPORTApplication1MajorRevision { get; }
Public ReadOnly Property APPPROFILESUPPORTApplication1MajorRevision As Byte
    Get
public:
property unsigned char APPPROFILESUPPORTApplication1MajorRevision {
    unsigned char get ();
}
member APPPROFILESUPPORTApplication1MajorRevision : byte with get

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.APPPROFILESUPPORTApplication1MinorRevision Property

IRD

PmbusAPPPROFILESUPPORTApplication1MinorRevision Property

APP_PROFILE_SUPPORT: Application 1 Minor Revision

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte APPPROFILESUPPORTApplication1MinorRevision { get; }
Public ReadOnly Property APPPROFILESUPPORTApplication1MinorRevision As Byte
    Get
public:
property unsigned char APPPROFILESUPPORTApplication1MinorRevision {
    unsigned char get ();
}
member APPPROFILESUPPORTApplication1MinorRevision : byte with get

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.APPPROFILESUPPORTApplication1Profile Property

IRD

PmbusAPPPROFILESUPPORTApplication1Profile Property

APP_PROFILE_SUPPORT: Application 1 Profile

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeAppProfileSupportProfile APPPROFILESUPPORTApplication1Profile { get; }
Public ReadOnly Property APPPROFILESUPPORTApplication1Profile As PmbusTypeAppProfileSupportProfile
    Get
public:
property PmbusTypeAppProfileSupportProfile APPPROFILESUPPORTApplication1Profile {
    PmbusTypeAppProfileSupportProfile get ();
}
member APPPROFILESUPPORTApplication1Profile : PmbusTypeAppProfileSupportProfile with get

Property Value

Type: PmbusTypeAppProfileSupportProfile
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.APPPROFILESUPPORTApplication2MajorRevision Property

IRD

PmbusAPPPROFILESUPPORTApplication2MajorRevision Property

APP_PROFILE_SUPPORT: Application 2 Major Revision

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte APPPROFILESUPPORTApplication2MajorRevision { get; }
Public ReadOnly Property APPPROFILESUPPORTApplication2MajorRevision As Byte
    Get
public:
property unsigned char APPPROFILESUPPORTApplication2MajorRevision {
    unsigned char get ();
}
member APPPROFILESUPPORTApplication2MajorRevision : byte with get

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.APPPROFILESUPPORTApplication2MinorRevision Property

IRD

PmbusAPPPROFILESUPPORTApplication2MinorRevision Property

APP_PROFILE_SUPPORT: Application 2 Minor Revision

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte APPPROFILESUPPORTApplication2MinorRevision { get; }
Public ReadOnly Property APPPROFILESUPPORTApplication2MinorRevision As Byte
    Get
public:
property unsigned char APPPROFILESUPPORTApplication2MinorRevision {
    unsigned char get ();
}
member APPPROFILESUPPORTApplication2MinorRevision : byte with get

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.APPPROFILESUPPORTApplication2Profile Property

IRD

PmbusAPPPROFILESUPPORTApplication2Profile Property

APP_PROFILE_SUPPORT: Application 2 Profile

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeAppProfileSupportProfile APPPROFILESUPPORTApplication2Profile { get; }
Public ReadOnly Property APPPROFILESUPPORTApplication2Profile As PmbusTypeAppProfileSupportProfile
    Get
public:
property PmbusTypeAppProfileSupportProfile APPPROFILESUPPORTApplication2Profile {
    PmbusTypeAppProfileSupportProfile get ();
}
member APPPROFILESUPPORTApplication2Profile : PmbusTypeAppProfileSupportProfile with get

Property Value

Type: PmbusTypeAppProfileSupportProfile
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.APPPROFILESUPPORTApplication3MajorRevision Property

IRD

PmbusAPPPROFILESUPPORTApplication3MajorRevision Property

APP_PROFILE_SUPPORT: Application 3 Major Revision

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte APPPROFILESUPPORTApplication3MajorRevision { get; }
Public ReadOnly Property APPPROFILESUPPORTApplication3MajorRevision As Byte
    Get
public:
property unsigned char APPPROFILESUPPORTApplication3MajorRevision {
    unsigned char get ();
}
member APPPROFILESUPPORTApplication3MajorRevision : byte with get

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.APPPROFILESUPPORTApplication3MinorRevision Property

IRD

PmbusAPPPROFILESUPPORTApplication3MinorRevision Property

APP_PROFILE_SUPPORT: Application 3 Minor Revision

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte APPPROFILESUPPORTApplication3MinorRevision { get; }
Public ReadOnly Property APPPROFILESUPPORTApplication3MinorRevision As Byte
    Get
public:
property unsigned char APPPROFILESUPPORTApplication3MinorRevision {
    unsigned char get ();
}
member APPPROFILESUPPORTApplication3MinorRevision : byte with get

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.APPPROFILESUPPORTApplication3Profile Property

IRD

PmbusAPPPROFILESUPPORTApplication3Profile Property

APP_PROFILE_SUPPORT: Application 3 Profile

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeAppProfileSupportProfile APPPROFILESUPPORTApplication3Profile { get; }
Public ReadOnly Property APPPROFILESUPPORTApplication3Profile As PmbusTypeAppProfileSupportProfile
    Get
public:
property PmbusTypeAppProfileSupportProfile APPPROFILESUPPORTApplication3Profile {
    PmbusTypeAppProfileSupportProfile get ();
}
member APPPROFILESUPPORTApplication3Profile : PmbusTypeAppProfileSupportProfile with get

Property Value

Type: PmbusTypeAppProfileSupportProfile
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.APPPROFILESUPPORTApplication4MajorRevision Property

IRD

PmbusAPPPROFILESUPPORTApplication4MajorRevision Property

APP_PROFILE_SUPPORT: Application 4 Major Revision

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte APPPROFILESUPPORTApplication4MajorRevision { get; }
Public ReadOnly Property APPPROFILESUPPORTApplication4MajorRevision As Byte
    Get
public:
property unsigned char APPPROFILESUPPORTApplication4MajorRevision {
    unsigned char get ();
}
member APPPROFILESUPPORTApplication4MajorRevision : byte with get

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.APPPROFILESUPPORTApplication4MinorRevision Property

IRD

PmbusAPPPROFILESUPPORTApplication4MinorRevision Property

APP_PROFILE_SUPPORT: Application 4 Minor Revision

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte APPPROFILESUPPORTApplication4MinorRevision { get; }
Public ReadOnly Property APPPROFILESUPPORTApplication4MinorRevision As Byte
    Get
public:
property unsigned char APPPROFILESUPPORTApplication4MinorRevision {
    unsigned char get ();
}
member APPPROFILESUPPORTApplication4MinorRevision : byte with get

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.APPPROFILESUPPORTApplication4Profile Property

IRD

PmbusAPPPROFILESUPPORTApplication4Profile Property

APP_PROFILE_SUPPORT: Application 4 Profile

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeAppProfileSupportProfile APPPROFILESUPPORTApplication4Profile { get; }
Public ReadOnly Property APPPROFILESUPPORTApplication4Profile As PmbusTypeAppProfileSupportProfile
    Get
public:
property PmbusTypeAppProfileSupportProfile APPPROFILESUPPORTApplication4Profile {
    PmbusTypeAppProfileSupportProfile get ();
}
member APPPROFILESUPPORTApplication4Profile : PmbusTypeAppProfileSupportProfile with get

Property Value

Type: PmbusTypeAppProfileSupportProfile
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.AutoFlush Property

IRD

PmbusAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.CAPABILITYAVSBusSupport Property

IRD

PmbusCAPABILITYAVSBusSupport Property

CAPABILITY: AVSBus Support

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeCapabilityAvsbus CAPABILITYAVSBusSupport { get; }
Public ReadOnly Property CAPABILITYAVSBusSupport As PmbusTypeCapabilityAvsbus
    Get
public:
property PmbusTypeCapabilityAvsbus CAPABILITYAVSBusSupport {
    PmbusTypeCapabilityAvsbus get ();
}
member CAPABILITYAVSBusSupport : PmbusTypeCapabilityAvsbus with get

Property Value

Type: PmbusTypeCapabilityAvsbus
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.CAPABILITYMaximumBusSpeed Property

IRD

PmbusCAPABILITYMaximumBusSpeed Property

CAPABILITY: Maximum Bus Speed

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeCapabilityMaxSpeed CAPABILITYMaximumBusSpeed { get; }
Public ReadOnly Property CAPABILITYMaximumBusSpeed As PmbusTypeCapabilityMaxSpeed
    Get
public:
property PmbusTypeCapabilityMaxSpeed CAPABILITYMaximumBusSpeed {
    PmbusTypeCapabilityMaxSpeed get ();
}
member CAPABILITYMaximumBusSpeed : PmbusTypeCapabilityMaxSpeed with get

Property Value

Type: PmbusTypeCapabilityMaxSpeed
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.CAPABILITYNumericFormat Property

IRD

PmbusCAPABILITYNumericFormat Property

CAPABILITY: Numeric Format

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeCapabilityNumericFormat CAPABILITYNumericFormat { get; }
Public ReadOnly Property CAPABILITYNumericFormat As PmbusTypeCapabilityNumericFormat
    Get
public:
property PmbusTypeCapabilityNumericFormat CAPABILITYNumericFormat {
    PmbusTypeCapabilityNumericFormat get ();
}
member CAPABILITYNumericFormat : PmbusTypeCapabilityNumericFormat with get

Property Value

Type: PmbusTypeCapabilityNumericFormat
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.CAPABILITYPacketErrorChecking Property

IRD

PmbusCAPABILITYPacketErrorChecking Property

CAPABILITY: Packet Error Checking

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeCapabilityPec CAPABILITYPacketErrorChecking { get; }
Public ReadOnly Property CAPABILITYPacketErrorChecking As PmbusTypeCapabilityPec
    Get
public:
property PmbusTypeCapabilityPec CAPABILITYPacketErrorChecking {
    PmbusTypeCapabilityPec get ();
}
member CAPABILITYPacketErrorChecking : PmbusTypeCapabilityPec with get

Property Value

Type: PmbusTypeCapabilityPec
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.CAPABILITYSMBALERT Property

IRD

PmbusCAPABILITYSMBALERT Property

CAPABILITY: SMBALERT#

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeCapabilitySmbalert CAPABILITYSMBALERT { get; }
Public ReadOnly Property CAPABILITYSMBALERT As PmbusTypeCapabilitySmbalert
    Get
public:
property PmbusTypeCapabilitySmbalert CAPABILITYSMBALERT {
    PmbusTypeCapabilitySmbalert get ();
}
member CAPABILITYSMBALERT : PmbusTypeCapabilitySmbalert with get

Property Value

Type: PmbusTypeCapabilitySmbalert
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.COEFFICIENTSB Property

IRD

PmbusCOEFFICIENTSB Property

COEFFICIENTS: b

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short COEFFICIENTSB { get; }
Public ReadOnly Property COEFFICIENTSB As Short
    Get
public:
property short COEFFICIENTSB {
    short get ();
}
member COEFFICIENTSB : int16 with get

Property Value

Type: Int16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.COEFFICIENTSCommandCode Property

IRD

PmbusCOEFFICIENTSCommandCode Property

COEFFICIENTS: Command Code

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte COEFFICIENTSCommandCode { set; }
Public WriteOnly Property COEFFICIENTSCommandCode As Byte
    Set
public:
property unsigned char COEFFICIENTSCommandCode {
    void set (unsigned char value);
}
member COEFFICIENTSCommandCode : byte with set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.COEFFICIENTSM Property

IRD

PmbusCOEFFICIENTSM Property

COEFFICIENTS: m

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short COEFFICIENTSM { get; }
Public ReadOnly Property COEFFICIENTSM As Short
    Get
public:
property short COEFFICIENTSM {
    short get ();
}
member COEFFICIENTSM : int16 with get

Property Value

Type: Int16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.COEFFICIENTSR Property

IRD

PmbusCOEFFICIENTSR Property

COEFFICIENTS: R

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte COEFFICIENTSR { get; }
Public ReadOnly Property COEFFICIENTSR As SByte
    Get
public:
property signed char COEFFICIENTSR {
    signed char get ();
}
member COEFFICIENTSR : sbyte with get

Property Value

Type: SByte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.COEFFICIENTSType Property

IRD

PmbusCOEFFICIENTSType Property

COEFFICIENTS: Type

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeCoefficients COEFFICIENTSType { set; }
Public WriteOnly Property COEFFICIENTSType As PmbusTypeCoefficients
    Set
public:
property PmbusTypeCoefficients COEFFICIENTSType {
    void set (PmbusTypeCoefficients value);
}
member COEFFICIENTSType : PmbusTypeCoefficients with set

Property Value

Type: PmbusTypeCoefficients
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.FANCOMMAND1 Property

IRD

PmbusFANCOMMAND1 Property

FAN_COMMAND_1

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort FANCOMMAND1 { get; set; }
Public Property FANCOMMAND1 As UShort
    Get
    Set
public:
property unsigned short FANCOMMAND1 {
    unsigned short get ();
    void set (unsigned short value);
}
member FANCOMMAND1 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.FANCOMMAND2 Property

IRD

PmbusFANCOMMAND2 Property

FAN_COMMAND_2

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort FANCOMMAND2 { get; set; }
Public Property FANCOMMAND2 As UShort
    Get
    Set
public:
property unsigned short FANCOMMAND2 {
    unsigned short get ();
    void set (unsigned short value);
}
member FANCOMMAND2 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.FANCOMMAND3 Property

IRD

PmbusFANCOMMAND3 Property

FAN_COMMAND_3

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort FANCOMMAND3 { get; set; }
Public Property FANCOMMAND3 As UShort
    Get
    Set
public:
property unsigned short FANCOMMAND3 {
    unsigned short get ();
    void set (unsigned short value);
}
member FANCOMMAND3 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.FANCOMMAND4 Property

IRD

PmbusFANCOMMAND4 Property

FAN_COMMAND_4

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort FANCOMMAND4 { get; set; }
Public Property FANCOMMAND4 As UShort
    Get
    Set
public:
property unsigned short FANCOMMAND4 {
    unsigned short get ();
    void set (unsigned short value);
}
member FANCOMMAND4 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.FANCONFIG12Fan1CommandedBy Property

IRD

PmbusFANCONFIG12Fan1CommandedBy Property

FAN_CONFIG_1_2: Fan 1 Commanded By

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeFanConfigCommanded FANCONFIG12Fan1CommandedBy { get; set; }
Public Property FANCONFIG12Fan1CommandedBy As PmbusTypeFanConfigCommanded
    Get
    Set
public:
property PmbusTypeFanConfigCommanded FANCONFIG12Fan1CommandedBy {
    PmbusTypeFanConfigCommanded get ();
    void set (PmbusTypeFanConfigCommanded value);
}
member FANCONFIG12Fan1CommandedBy : PmbusTypeFanConfigCommanded with get, set

Property Value

Type: PmbusTypeFanConfigCommanded
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.FANCONFIG12Fan1Installed Property

IRD

PmbusFANCONFIG12Fan1Installed Property

FAN_CONFIG_1_2: Fan 1 Installed

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeFanConfigInstalled FANCONFIG12Fan1Installed { get; set; }
Public Property FANCONFIG12Fan1Installed As PmbusTypeFanConfigInstalled
    Get
    Set
public:
property PmbusTypeFanConfigInstalled FANCONFIG12Fan1Installed {
    PmbusTypeFanConfigInstalled get ();
    void set (PmbusTypeFanConfigInstalled value);
}
member FANCONFIG12Fan1Installed : PmbusTypeFanConfigInstalled with get, set

Property Value

Type: PmbusTypeFanConfigInstalled
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.FANCONFIG12Fan1PulsesPerRevolution Property

IRD

PmbusFANCONFIG12Fan1PulsesPerRevolution Property

FAN_CONFIG_1_2: Fan 1 Pulses Per Revolution

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FANCONFIG12Fan1PulsesPerRevolution { get; set; }
Public Property FANCONFIG12Fan1PulsesPerRevolution As Byte
    Get
    Set
public:
property unsigned char FANCONFIG12Fan1PulsesPerRevolution {
    unsigned char get ();
    void set (unsigned char value);
}
member FANCONFIG12Fan1PulsesPerRevolution : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.FANCONFIG12Fan2CommandedBy Property

IRD

PmbusFANCONFIG12Fan2CommandedBy Property

FAN_CONFIG_1_2: Fan 2 Commanded By

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeFanConfigCommanded FANCONFIG12Fan2CommandedBy { get; set; }
Public Property FANCONFIG12Fan2CommandedBy As PmbusTypeFanConfigCommanded
    Get
    Set
public:
property PmbusTypeFanConfigCommanded FANCONFIG12Fan2CommandedBy {
    PmbusTypeFanConfigCommanded get ();
    void set (PmbusTypeFanConfigCommanded value);
}
member FANCONFIG12Fan2CommandedBy : PmbusTypeFanConfigCommanded with get, set

Property Value

Type: PmbusTypeFanConfigCommanded
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.FANCONFIG12Fan2Installed Property

IRD

PmbusFANCONFIG12Fan2Installed Property

FAN_CONFIG_1_2: Fan 2 Installed

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeFanConfigInstalled FANCONFIG12Fan2Installed { get; set; }
Public Property FANCONFIG12Fan2Installed As PmbusTypeFanConfigInstalled
    Get
    Set
public:
property PmbusTypeFanConfigInstalled FANCONFIG12Fan2Installed {
    PmbusTypeFanConfigInstalled get ();
    void set (PmbusTypeFanConfigInstalled value);
}
member FANCONFIG12Fan2Installed : PmbusTypeFanConfigInstalled with get, set

Property Value

Type: PmbusTypeFanConfigInstalled
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.FANCONFIG12Fan2PulsesPerRevolution Property

IRD

PmbusFANCONFIG12Fan2PulsesPerRevolution Property

FAN_CONFIG_1_2: Fan 2 Pulses Per Revolution

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FANCONFIG12Fan2PulsesPerRevolution { get; set; }
Public Property FANCONFIG12Fan2PulsesPerRevolution As Byte
    Get
    Set
public:
property unsigned char FANCONFIG12Fan2PulsesPerRevolution {
    unsigned char get ();
    void set (unsigned char value);
}
member FANCONFIG12Fan2PulsesPerRevolution : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.FANCONFIG34Fan3CommandedBy Property

IRD

PmbusFANCONFIG34Fan3CommandedBy Property

FAN_CONFIG_3_4: Fan 3 Commanded By

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeFanConfigCommanded FANCONFIG34Fan3CommandedBy { get; set; }
Public Property FANCONFIG34Fan3CommandedBy As PmbusTypeFanConfigCommanded
    Get
    Set
public:
property PmbusTypeFanConfigCommanded FANCONFIG34Fan3CommandedBy {
    PmbusTypeFanConfigCommanded get ();
    void set (PmbusTypeFanConfigCommanded value);
}
member FANCONFIG34Fan3CommandedBy : PmbusTypeFanConfigCommanded with get, set

Property Value

Type: PmbusTypeFanConfigCommanded
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.FANCONFIG34Fan3Installed Property

IRD

PmbusFANCONFIG34Fan3Installed Property

FAN_CONFIG_3_4: Fan 3 Installed

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeFanConfigInstalled FANCONFIG34Fan3Installed { get; set; }
Public Property FANCONFIG34Fan3Installed As PmbusTypeFanConfigInstalled
    Get
    Set
public:
property PmbusTypeFanConfigInstalled FANCONFIG34Fan3Installed {
    PmbusTypeFanConfigInstalled get ();
    void set (PmbusTypeFanConfigInstalled value);
}
member FANCONFIG34Fan3Installed : PmbusTypeFanConfigInstalled with get, set

Property Value

Type: PmbusTypeFanConfigInstalled
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.FANCONFIG34Fan3PulsesPerRevolution Property

IRD

PmbusFANCONFIG34Fan3PulsesPerRevolution Property

FAN_CONFIG_3_4: Fan 3 Pulses Per Revolution

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FANCONFIG34Fan3PulsesPerRevolution { get; set; }
Public Property FANCONFIG34Fan3PulsesPerRevolution As Byte
    Get
    Set
public:
property unsigned char FANCONFIG34Fan3PulsesPerRevolution {
    unsigned char get ();
    void set (unsigned char value);
}
member FANCONFIG34Fan3PulsesPerRevolution : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.FANCONFIG34Fan4CommandedBy Property

IRD

PmbusFANCONFIG34Fan4CommandedBy Property

FAN_CONFIG_3_4: Fan 4 Commanded By

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeFanConfigCommanded FANCONFIG34Fan4CommandedBy { get; set; }
Public Property FANCONFIG34Fan4CommandedBy As PmbusTypeFanConfigCommanded
    Get
    Set
public:
property PmbusTypeFanConfigCommanded FANCONFIG34Fan4CommandedBy {
    PmbusTypeFanConfigCommanded get ();
    void set (PmbusTypeFanConfigCommanded value);
}
member FANCONFIG34Fan4CommandedBy : PmbusTypeFanConfigCommanded with get, set

Property Value

Type: PmbusTypeFanConfigCommanded
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.FANCONFIG34Fan4Installed Property

IRD

PmbusFANCONFIG34Fan4Installed Property

FAN_CONFIG_3_4: Fan 4 Installed

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeFanConfigInstalled FANCONFIG34Fan4Installed { get; set; }
Public Property FANCONFIG34Fan4Installed As PmbusTypeFanConfigInstalled
    Get
    Set
public:
property PmbusTypeFanConfigInstalled FANCONFIG34Fan4Installed {
    PmbusTypeFanConfigInstalled get ();
    void set (PmbusTypeFanConfigInstalled value);
}
member FANCONFIG34Fan4Installed : PmbusTypeFanConfigInstalled with get, set

Property Value

Type: PmbusTypeFanConfigInstalled
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.FANCONFIG34Fan4PulsesPerRevolution Property

IRD

PmbusFANCONFIG34Fan4PulsesPerRevolution Property

FAN_CONFIG_3_4: Fan 4 Pulses Per Revolution

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FANCONFIG34Fan4PulsesPerRevolution { get; set; }
Public Property FANCONFIG34Fan4PulsesPerRevolution As Byte
    Get
    Set
public:
property unsigned char FANCONFIG34Fan4PulsesPerRevolution {
    unsigned char get ();
    void set (unsigned char value);
}
member FANCONFIG34Fan4PulsesPerRevolution : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.FREQUENCYSWITCH Property

IRD

PmbusFREQUENCYSWITCH Property

FREQUENCY_SWITCH

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort FREQUENCYSWITCH { get; set; }
Public Property FREQUENCYSWITCH As UShort
    Get
    Set
public:
property unsigned short FREQUENCYSWITCH {
    unsigned short get ();
    void set (unsigned short value);
}
member FREQUENCYSWITCH : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.ICDEVICEID Property

IRD

PmbusICDEVICEID Property

IC_DEVICE_ID

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public string ICDEVICEID { get; }
Public ReadOnly Property ICDEVICEID As String
    Get
public:
property String^ ICDEVICEID {
    String^ get ();
}
member ICDEVICEID : string with get

Property Value

Type: String
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.ICDEVICEREV Property

IRD

PmbusICDEVICEREV Property

IC_DEVICE_REV

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public string ICDEVICEREV { get; }
Public ReadOnly Property ICDEVICEREV As String
    Get
public:
property String^ ICDEVICEREV {
    String^ get ();
}
member ICDEVICEREV : string with get

Property Value

Type: String
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IINOCFAULTLIMIT Property

IRD

PmbusIINOCFAULTLIMIT Property

IIN_OC_FAULT_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort IINOCFAULTLIMIT { get; set; }
Public Property IINOCFAULTLIMIT As UShort
    Get
    Set
public:
property unsigned short IINOCFAULTLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member IINOCFAULTLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IINOCFAULTRESPONSEDelayTime Property

IRD

PmbusIINOCFAULTRESPONSEDelayTime Property

IIN_OC_FAULT_RESPONSE: Delay Time

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IINOCFAULTRESPONSEDelayTime { get; set; }
Public Property IINOCFAULTRESPONSEDelayTime As Byte
    Get
    Set
public:
property unsigned char IINOCFAULTRESPONSEDelayTime {
    unsigned char get ();
    void set (unsigned char value);
}
member IINOCFAULTRESPONSEDelayTime : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IINOCFAULTRESPONSEResponse Property

IRD

PmbusIINOCFAULTRESPONSEResponse Property

IIN_OC_FAULT_RESPONSE: Response

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespCurrentFaultsResponse IINOCFAULTRESPONSEResponse { get; set; }
Public Property IINOCFAULTRESPONSEResponse As PmbusTypeRespCurrentFaultsResponse
    Get
    Set
public:
property PmbusTypeRespCurrentFaultsResponse IINOCFAULTRESPONSEResponse {
    PmbusTypeRespCurrentFaultsResponse get ();
    void set (PmbusTypeRespCurrentFaultsResponse value);
}
member IINOCFAULTRESPONSEResponse : PmbusTypeRespCurrentFaultsResponse with get, set

Property Value

Type: PmbusTypeRespCurrentFaultsResponse
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IINOCFAULTRESPONSERetrySetting Property

IRD

PmbusIINOCFAULTRESPONSERetrySetting Property

IIN_OC_FAULT_RESPONSE: Retry Setting

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespCurrentFaultsRetry IINOCFAULTRESPONSERetrySetting { get; set; }
Public Property IINOCFAULTRESPONSERetrySetting As PmbusTypeRespCurrentFaultsRetry
    Get
    Set
public:
property PmbusTypeRespCurrentFaultsRetry IINOCFAULTRESPONSERetrySetting {
    PmbusTypeRespCurrentFaultsRetry get ();
    void set (PmbusTypeRespCurrentFaultsRetry value);
}
member IINOCFAULTRESPONSERetrySetting : PmbusTypeRespCurrentFaultsRetry with get, set

Property Value

Type: PmbusTypeRespCurrentFaultsRetry
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IINOCWARNLIMIT Property

IRD

PmbusIINOCWARNLIMIT Property

IIN_OC_WARN_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort IINOCWARNLIMIT { get; set; }
Public Property IINOCWARNLIMIT As UShort
    Get
    Set
public:
property unsigned short IINOCWARNLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member IINOCWARNLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.INTERLEAVEGroupIDNumber Property

IRD

PmbusINTERLEAVEGroupIDNumber Property

INTERLEAVE: Group ID Number

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTERLEAVEGroupIDNumber { get; set; }
Public Property INTERLEAVEGroupIDNumber As Byte
    Get
    Set
public:
property unsigned char INTERLEAVEGroupIDNumber {
    unsigned char get ();
    void set (unsigned char value);
}
member INTERLEAVEGroupIDNumber : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.INTERLEAVEInterleaveOrder Property

IRD

PmbusINTERLEAVEInterleaveOrder Property

INTERLEAVE: Interleave Order

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTERLEAVEInterleaveOrder { get; set; }
Public Property INTERLEAVEInterleaveOrder As Byte
    Get
    Set
public:
property unsigned char INTERLEAVEInterleaveOrder {
    unsigned char get ();
    void set (unsigned char value);
}
member INTERLEAVEInterleaveOrder : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.INTERLEAVENumberInGroup Property

IRD

PmbusINTERLEAVENumberInGroup Property

INTERLEAVE: Number In Group

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTERLEAVENumberInGroup { get; set; }
Public Property INTERLEAVENumberInGroup As Byte
    Get
    Set
public:
property unsigned char INTERLEAVENumberInGroup {
    unsigned char get ();
    void set (unsigned char value);
}
member INTERLEAVENumberInGroup : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IOUTCALGAIN Property

IRD

PmbusIOUTCALGAIN Property

IOUT_CAL_GAIN

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort IOUTCALGAIN { get; set; }
Public Property IOUTCALGAIN As UShort
    Get
    Set
public:
property unsigned short IOUTCALGAIN {
    unsigned short get ();
    void set (unsigned short value);
}
member IOUTCALGAIN : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IOUTCALOFFSET Property

IRD

PmbusIOUTCALOFFSET Property

IOUT_CAL_OFFSET

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort IOUTCALOFFSET { get; set; }
Public Property IOUTCALOFFSET As UShort
    Get
    Set
public:
property unsigned short IOUTCALOFFSET {
    unsigned short get ();
    void set (unsigned short value);
}
member IOUTCALOFFSET : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IOUTOCFAULTLIMIT Property

IRD

PmbusIOUTOCFAULTLIMIT Property

IOUT_OC_FAULT_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort IOUTOCFAULTLIMIT { get; set; }
Public Property IOUTOCFAULTLIMIT As UShort
    Get
    Set
public:
property unsigned short IOUTOCFAULTLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member IOUTOCFAULTLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IOUTOCFAULTRESPONSEDelayTime Property

IRD

PmbusIOUTOCFAULTRESPONSEDelayTime Property

IOUT_OC_FAULT_RESPONSE: Delay Time

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IOUTOCFAULTRESPONSEDelayTime { get; set; }
Public Property IOUTOCFAULTRESPONSEDelayTime As Byte
    Get
    Set
public:
property unsigned char IOUTOCFAULTRESPONSEDelayTime {
    unsigned char get ();
    void set (unsigned char value);
}
member IOUTOCFAULTRESPONSEDelayTime : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IOUTOCFAULTRESPONSEResponse Property

IRD

PmbusIOUTOCFAULTRESPONSEResponse Property

IOUT_OC_FAULT_RESPONSE: Response

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespCurrentFaultsResponse IOUTOCFAULTRESPONSEResponse { get; set; }
Public Property IOUTOCFAULTRESPONSEResponse As PmbusTypeRespCurrentFaultsResponse
    Get
    Set
public:
property PmbusTypeRespCurrentFaultsResponse IOUTOCFAULTRESPONSEResponse {
    PmbusTypeRespCurrentFaultsResponse get ();
    void set (PmbusTypeRespCurrentFaultsResponse value);
}
member IOUTOCFAULTRESPONSEResponse : PmbusTypeRespCurrentFaultsResponse with get, set

Property Value

Type: PmbusTypeRespCurrentFaultsResponse
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IOUTOCFAULTRESPONSERetrySetting Property

IRD

PmbusIOUTOCFAULTRESPONSERetrySetting Property

IOUT_OC_FAULT_RESPONSE: Retry Setting

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespCurrentFaultsRetry IOUTOCFAULTRESPONSERetrySetting { get; set; }
Public Property IOUTOCFAULTRESPONSERetrySetting As PmbusTypeRespCurrentFaultsRetry
    Get
    Set
public:
property PmbusTypeRespCurrentFaultsRetry IOUTOCFAULTRESPONSERetrySetting {
    PmbusTypeRespCurrentFaultsRetry get ();
    void set (PmbusTypeRespCurrentFaultsRetry value);
}
member IOUTOCFAULTRESPONSERetrySetting : PmbusTypeRespCurrentFaultsRetry with get, set

Property Value

Type: PmbusTypeRespCurrentFaultsRetry
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IOUTOCLVFAULTLIMIT Property

IRD

PmbusIOUTOCLVFAULTLIMIT Property

IOUT_OC_LV_FAULT_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort IOUTOCLVFAULTLIMIT { get; set; }
Public Property IOUTOCLVFAULTLIMIT As UShort
    Get
    Set
public:
property unsigned short IOUTOCLVFAULTLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member IOUTOCLVFAULTLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IOUTOCLVFAULTRESPONSEDelayTime Property

IRD

PmbusIOUTOCLVFAULTRESPONSEDelayTime Property

IOUT_OC_LV_FAULT_RESPONSE: Delay Time

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IOUTOCLVFAULTRESPONSEDelayTime { get; set; }
Public Property IOUTOCLVFAULTRESPONSEDelayTime As Byte
    Get
    Set
public:
property unsigned char IOUTOCLVFAULTRESPONSEDelayTime {
    unsigned char get ();
    void set (unsigned char value);
}
member IOUTOCLVFAULTRESPONSEDelayTime : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IOUTOCLVFAULTRESPONSEResponse Property

IRD

PmbusIOUTOCLVFAULTRESPONSEResponse Property

IOUT_OC_LV_FAULT_RESPONSE: Response

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespCurrentFaultsResponse IOUTOCLVFAULTRESPONSEResponse { get; set; }
Public Property IOUTOCLVFAULTRESPONSEResponse As PmbusTypeRespCurrentFaultsResponse
    Get
    Set
public:
property PmbusTypeRespCurrentFaultsResponse IOUTOCLVFAULTRESPONSEResponse {
    PmbusTypeRespCurrentFaultsResponse get ();
    void set (PmbusTypeRespCurrentFaultsResponse value);
}
member IOUTOCLVFAULTRESPONSEResponse : PmbusTypeRespCurrentFaultsResponse with get, set

Property Value

Type: PmbusTypeRespCurrentFaultsResponse
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IOUTOCLVFAULTRESPONSERetrySetting Property

IRD

PmbusIOUTOCLVFAULTRESPONSERetrySetting Property

IOUT_OC_LV_FAULT_RESPONSE: Retry Setting

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespCurrentFaultsRetry IOUTOCLVFAULTRESPONSERetrySetting { get; set; }
Public Property IOUTOCLVFAULTRESPONSERetrySetting As PmbusTypeRespCurrentFaultsRetry
    Get
    Set
public:
property PmbusTypeRespCurrentFaultsRetry IOUTOCLVFAULTRESPONSERetrySetting {
    PmbusTypeRespCurrentFaultsRetry get ();
    void set (PmbusTypeRespCurrentFaultsRetry value);
}
member IOUTOCLVFAULTRESPONSERetrySetting : PmbusTypeRespCurrentFaultsRetry with get, set

Property Value

Type: PmbusTypeRespCurrentFaultsRetry
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IOUTOCWARNLIMIT Property

IRD

PmbusIOUTOCWARNLIMIT Property

IOUT_OC_WARN_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort IOUTOCWARNLIMIT { get; set; }
Public Property IOUTOCWARNLIMIT As UShort
    Get
    Set
public:
property unsigned short IOUTOCWARNLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member IOUTOCWARNLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IOUTUCFAULTLIMIT Property

IRD

PmbusIOUTUCFAULTLIMIT Property

IOUT_UC_FAULT_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort IOUTUCFAULTLIMIT { get; set; }
Public Property IOUTUCFAULTLIMIT As UShort
    Get
    Set
public:
property unsigned short IOUTUCFAULTLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member IOUTUCFAULTLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IOUTUCFAULTRESPONSEDelayTime Property

IRD

PmbusIOUTUCFAULTRESPONSEDelayTime Property

IOUT_UC_FAULT_RESPONSE: Delay Time

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IOUTUCFAULTRESPONSEDelayTime { get; set; }
Public Property IOUTUCFAULTRESPONSEDelayTime As Byte
    Get
    Set
public:
property unsigned char IOUTUCFAULTRESPONSEDelayTime {
    unsigned char get ();
    void set (unsigned char value);
}
member IOUTUCFAULTRESPONSEDelayTime : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IOUTUCFAULTRESPONSEResponse Property

IRD

PmbusIOUTUCFAULTRESPONSEResponse Property

IOUT_UC_FAULT_RESPONSE: Response

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespCurrentFaultsResponse IOUTUCFAULTRESPONSEResponse { get; set; }
Public Property IOUTUCFAULTRESPONSEResponse As PmbusTypeRespCurrentFaultsResponse
    Get
    Set
public:
property PmbusTypeRespCurrentFaultsResponse IOUTUCFAULTRESPONSEResponse {
    PmbusTypeRespCurrentFaultsResponse get ();
    void set (PmbusTypeRespCurrentFaultsResponse value);
}
member IOUTUCFAULTRESPONSEResponse : PmbusTypeRespCurrentFaultsResponse with get, set

Property Value

Type: PmbusTypeRespCurrentFaultsResponse
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.IOUTUCFAULTRESPONSERetrySetting Property

IRD

PmbusIOUTUCFAULTRESPONSERetrySetting Property

IOUT_UC_FAULT_RESPONSE: Retry Setting

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespCurrentFaultsRetry IOUTUCFAULTRESPONSERetrySetting { get; set; }
Public Property IOUTUCFAULTRESPONSERetrySetting As PmbusTypeRespCurrentFaultsRetry
    Get
    Set
public:
property PmbusTypeRespCurrentFaultsRetry IOUTUCFAULTRESPONSERetrySetting {
    PmbusTypeRespCurrentFaultsRetry get ();
    void set (PmbusTypeRespCurrentFaultsRetry value);
}
member IOUTUCFAULTRESPONSERetrySetting : PmbusTypeRespCurrentFaultsRetry with get, set

Property Value

Type: PmbusTypeRespCurrentFaultsRetry
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MAXDUTY Property

IRD

PmbusMAXDUTY Property

MAX_DUTY

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MAXDUTY { get; set; }
Public Property MAXDUTY As UShort
    Get
    Set
public:
property unsigned short MAXDUTY {
    unsigned short get ();
    void set (unsigned short value);
}
member MAXDUTY : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFRDATE Property

IRD

PmbusMFRDATE Property

MFR_DATE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public string MFRDATE { get; set; }
Public Property MFRDATE As String
    Get
    Set
public:
property String^ MFRDATE {
    String^ get ();
    void set (String^ value);
}
member MFRDATE : string with get, set

Property Value

Type: String
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFREFFICIENCYHLEfficiencyHighPower Property

IRD

PmbusMFREFFICIENCYHLEfficiencyHighPower Property

MFR_EFFICIENCY_HL: Efficiency (High Power)

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFREFFICIENCYHLEfficiencyHighPower { get; }
Public ReadOnly Property MFREFFICIENCYHLEfficiencyHighPower As UShort
    Get
public:
property unsigned short MFREFFICIENCYHLEfficiencyHighPower {
    unsigned short get ();
}
member MFREFFICIENCYHLEfficiencyHighPower : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFREFFICIENCYHLEfficiencyLowPower Property

IRD

PmbusMFREFFICIENCYHLEfficiencyLowPower Property

MFR_EFFICIENCY_HL: Efficiency (Low Power)

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFREFFICIENCYHLEfficiencyLowPower { get; }
Public ReadOnly Property MFREFFICIENCYHLEfficiencyLowPower As UShort
    Get
public:
property unsigned short MFREFFICIENCYHLEfficiencyLowPower {
    unsigned short get ();
}
member MFREFFICIENCYHLEfficiencyLowPower : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFREFFICIENCYHLEfficiencyMediumPower Property

IRD

PmbusMFREFFICIENCYHLEfficiencyMediumPower Property

MFR_EFFICIENCY_HL: Efficiency (Medium Power)

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFREFFICIENCYHLEfficiencyMediumPower { get; }
Public ReadOnly Property MFREFFICIENCYHLEfficiencyMediumPower As UShort
    Get
public:
property unsigned short MFREFFICIENCYHLEfficiencyMediumPower {
    unsigned short get ();
}
member MFREFFICIENCYHLEfficiencyMediumPower : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFREFFICIENCYHLInputVoltageHighLine Property

IRD

PmbusMFREFFICIENCYHLInputVoltageHighLine Property

MFR_EFFICIENCY_HL: Input Voltage (High Line)

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFREFFICIENCYHLInputVoltageHighLine { get; }
Public ReadOnly Property MFREFFICIENCYHLInputVoltageHighLine As UShort
    Get
public:
property unsigned short MFREFFICIENCYHLInputVoltageHighLine {
    unsigned short get ();
}
member MFREFFICIENCYHLInputVoltageHighLine : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFREFFICIENCYHLPowerHighPower Property

IRD

PmbusMFREFFICIENCYHLPowerHighPower Property

MFR_EFFICIENCY_HL: Power (High Power)

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFREFFICIENCYHLPowerHighPower { get; }
Public ReadOnly Property MFREFFICIENCYHLPowerHighPower As UShort
    Get
public:
property unsigned short MFREFFICIENCYHLPowerHighPower {
    unsigned short get ();
}
member MFREFFICIENCYHLPowerHighPower : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFREFFICIENCYHLPowerLowPower Property

IRD

PmbusMFREFFICIENCYHLPowerLowPower Property

MFR_EFFICIENCY_HL: Power (Low Power)

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFREFFICIENCYHLPowerLowPower { get; }
Public ReadOnly Property MFREFFICIENCYHLPowerLowPower As UShort
    Get
public:
property unsigned short MFREFFICIENCYHLPowerLowPower {
    unsigned short get ();
}
member MFREFFICIENCYHLPowerLowPower : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFREFFICIENCYHLPowerMediumPower Property

IRD

PmbusMFREFFICIENCYHLPowerMediumPower Property

MFR_EFFICIENCY_HL: Power (Medium Power)

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFREFFICIENCYHLPowerMediumPower { get; }
Public ReadOnly Property MFREFFICIENCYHLPowerMediumPower As UShort
    Get
public:
property unsigned short MFREFFICIENCYHLPowerMediumPower {
    unsigned short get ();
}
member MFREFFICIENCYHLPowerMediumPower : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFREFFICIENCYLLEfficiencyHighPower Property

IRD

PmbusMFREFFICIENCYLLEfficiencyHighPower Property

MFR_EFFICIENCY_LL: Efficiency (High Power)

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFREFFICIENCYLLEfficiencyHighPower { get; }
Public ReadOnly Property MFREFFICIENCYLLEfficiencyHighPower As UShort
    Get
public:
property unsigned short MFREFFICIENCYLLEfficiencyHighPower {
    unsigned short get ();
}
member MFREFFICIENCYLLEfficiencyHighPower : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFREFFICIENCYLLEfficiencyLowPower Property

IRD

PmbusMFREFFICIENCYLLEfficiencyLowPower Property

MFR_EFFICIENCY_LL: Efficiency (Low Power)

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFREFFICIENCYLLEfficiencyLowPower { get; }
Public ReadOnly Property MFREFFICIENCYLLEfficiencyLowPower As UShort
    Get
public:
property unsigned short MFREFFICIENCYLLEfficiencyLowPower {
    unsigned short get ();
}
member MFREFFICIENCYLLEfficiencyLowPower : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFREFFICIENCYLLEfficiencyMediumPower Property

IRD

PmbusMFREFFICIENCYLLEfficiencyMediumPower Property

MFR_EFFICIENCY_LL: Efficiency (Medium Power)

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFREFFICIENCYLLEfficiencyMediumPower { get; }
Public ReadOnly Property MFREFFICIENCYLLEfficiencyMediumPower As UShort
    Get
public:
property unsigned short MFREFFICIENCYLLEfficiencyMediumPower {
    unsigned short get ();
}
member MFREFFICIENCYLLEfficiencyMediumPower : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFREFFICIENCYLLInputVoltageLowLine Property

IRD

PmbusMFREFFICIENCYLLInputVoltageLowLine Property

MFR_EFFICIENCY_LL: Input Voltage (Low Line)

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFREFFICIENCYLLInputVoltageLowLine { get; }
Public ReadOnly Property MFREFFICIENCYLLInputVoltageLowLine As UShort
    Get
public:
property unsigned short MFREFFICIENCYLLInputVoltageLowLine {
    unsigned short get ();
}
member MFREFFICIENCYLLInputVoltageLowLine : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFREFFICIENCYLLPowerHighPower Property

IRD

PmbusMFREFFICIENCYLLPowerHighPower Property

MFR_EFFICIENCY_LL: Power (High Power)

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFREFFICIENCYLLPowerHighPower { get; }
Public ReadOnly Property MFREFFICIENCYLLPowerHighPower As UShort
    Get
public:
property unsigned short MFREFFICIENCYLLPowerHighPower {
    unsigned short get ();
}
member MFREFFICIENCYLLPowerHighPower : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFREFFICIENCYLLPowerLowPower Property

IRD

PmbusMFREFFICIENCYLLPowerLowPower Property

MFR_EFFICIENCY_LL: Power (Low Power)

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFREFFICIENCYLLPowerLowPower { get; }
Public ReadOnly Property MFREFFICIENCYLLPowerLowPower As UShort
    Get
public:
property unsigned short MFREFFICIENCYLLPowerLowPower {
    unsigned short get ();
}
member MFREFFICIENCYLLPowerLowPower : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFREFFICIENCYLLPowerMediumPower Property

IRD

PmbusMFREFFICIENCYLLPowerMediumPower Property

MFR_EFFICIENCY_LL: Power (Medium Power)

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFREFFICIENCYLLPowerMediumPower { get; }
Public ReadOnly Property MFREFFICIENCYLLPowerMediumPower As UShort
    Get
public:
property unsigned short MFREFFICIENCYLLPowerMediumPower {
    unsigned short get ();
}
member MFREFFICIENCYLLPowerMediumPower : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFRID Property

IRD

PmbusMFRID Property

MFR_ID

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public string MFRID { get; set; }
Public Property MFRID As String
    Get
    Set
public:
property String^ MFRID {
    String^ get ();
    void set (String^ value);
}
member MFRID : string with get, set

Property Value

Type: String
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFRIINMAX Property

IRD

PmbusMFRIINMAX Property

MFR_IIN_MAX

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFRIINMAX { get; }
Public ReadOnly Property MFRIINMAX As UShort
    Get
public:
property unsigned short MFRIINMAX {
    unsigned short get ();
}
member MFRIINMAX : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFRIOUTMAX Property

IRD

PmbusMFRIOUTMAX Property

MFR_IOUT_MAX

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFRIOUTMAX { get; }
Public ReadOnly Property MFRIOUTMAX As UShort
    Get
public:
property unsigned short MFRIOUTMAX {
    unsigned short get ();
}
member MFRIOUTMAX : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFRLOCATION Property

IRD

PmbusMFRLOCATION Property

MFR_LOCATION

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public string MFRLOCATION { get; set; }
Public Property MFRLOCATION As String
    Get
    Set
public:
property String^ MFRLOCATION {
    String^ get ();
    void set (String^ value);
}
member MFRLOCATION : string with get, set

Property Value

Type: String
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFRMODEL Property

IRD

PmbusMFRMODEL Property

MFR_MODEL

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public string MFRMODEL { get; set; }
Public Property MFRMODEL As String
    Get
    Set
public:
property String^ MFRMODEL {
    String^ get ();
    void set (String^ value);
}
member MFRMODEL : string with get, set

Property Value

Type: String
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFRPINACCURACY Property

IRD

PmbusMFRPINACCURACY Property

MFR_PIN_ACCURACY (unit: %)

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MFRPINACCURACY { get; }
Public ReadOnly Property MFRPINACCURACY As Double
    Get
public:
property double MFRPINACCURACY {
    double get ();
}
member MFRPINACCURACY : float with get

Property Value

Type: Double
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFRPINMAX Property

IRD

PmbusMFRPINMAX Property

MFR_PIN_MAX

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFRPINMAX { get; }
Public ReadOnly Property MFRPINMAX As UShort
    Get
public:
property unsigned short MFRPINMAX {
    unsigned short get ();
}
member MFRPINMAX : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFRPOUTMAX Property

IRD

PmbusMFRPOUTMAX Property

MFR_POUT_MAX

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFRPOUTMAX { get; }
Public ReadOnly Property MFRPOUTMAX As UShort
    Get
public:
property unsigned short MFRPOUTMAX {
    unsigned short get ();
}
member MFRPOUTMAX : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFRREVISION Property

IRD

PmbusMFRREVISION Property

MFR_REVISION

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public string MFRREVISION { get; set; }
Public Property MFRREVISION As String
    Get
    Set
public:
property String^ MFRREVISION {
    String^ get ();
    void set (String^ value);
}
member MFRREVISION : string with get, set

Property Value

Type: String
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFRSERIAL Property

IRD

PmbusMFRSERIAL Property

MFR_SERIAL

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public string MFRSERIAL { get; set; }
Public Property MFRSERIAL As String
    Get
    Set
public:
property String^ MFRSERIAL {
    String^ get ();
    void set (String^ value);
}
member MFRSERIAL : string with get, set

Property Value

Type: String
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFRTAMBIENTMAX Property

IRD

PmbusMFRTAMBIENTMAX Property

MFR_TAMBIENT_MAX

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFRTAMBIENTMAX { get; }
Public ReadOnly Property MFRTAMBIENTMAX As UShort
    Get
public:
property unsigned short MFRTAMBIENTMAX {
    unsigned short get ();
}
member MFRTAMBIENTMAX : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFRTAMBIENTMIN Property

IRD

PmbusMFRTAMBIENTMIN Property

MFR_TAMBIENT_MIN

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFRTAMBIENTMIN { get; }
Public ReadOnly Property MFRTAMBIENTMIN As UShort
    Get
public:
property unsigned short MFRTAMBIENTMIN {
    unsigned short get ();
}
member MFRTAMBIENTMIN : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFRVINMAX Property

IRD

PmbusMFRVINMAX Property

MFR_VIN_MAX

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFRVINMAX { get; }
Public ReadOnly Property MFRVINMAX As UShort
    Get
public:
property unsigned short MFRVINMAX {
    unsigned short get ();
}
member MFRVINMAX : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFRVINMIN Property

IRD

PmbusMFRVINMIN Property

MFR_VIN_MIN

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFRVINMIN { get; }
Public ReadOnly Property MFRVINMIN As UShort
    Get
public:
property unsigned short MFRVINMIN {
    unsigned short get ();
}
member MFRVINMIN : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFRVOUTMAX Property

IRD

PmbusMFRVOUTMAX Property

MFR_VOUT_MAX

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFRVOUTMAX { get; }
Public ReadOnly Property MFRVOUTMAX As UShort
    Get
public:
property unsigned short MFRVOUTMAX {
    unsigned short get ();
}
member MFRVOUTMAX : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.MFRVOUTMIN Property

IRD

PmbusMFRVOUTMIN Property

MFR_VOUT_MIN

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort MFRVOUTMIN { get; }
Public ReadOnly Property MFRVOUTMIN As UShort
    Get
public:
property unsigned short MFRVOUTMIN {
    unsigned short get ();
}
member MFRVOUTMIN : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.ONOFFCONFIGCONTROLPin Property

IRD

PmbusONOFFCONFIGCONTROLPin Property

ON_OFF_CONFIG: CONTROL Pin

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeOnOffConfig2 ONOFFCONFIGCONTROLPin { get; set; }
Public Property ONOFFCONFIGCONTROLPin As PmbusTypeOnOffConfig2
    Get
    Set
public:
property PmbusTypeOnOffConfig2 ONOFFCONFIGCONTROLPin {
    PmbusTypeOnOffConfig2 get ();
    void set (PmbusTypeOnOffConfig2 value);
}
member ONOFFCONFIGCONTROLPin : PmbusTypeOnOffConfig2 with get, set

Property Value

Type: PmbusTypeOnOffConfig2
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.ONOFFCONFIGCONTROLPinAction Property

IRD

PmbusONOFFCONFIGCONTROLPinAction Property

ON_OFF_CONFIG: CONTROL Pin Action

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeOnOffConfig0 ONOFFCONFIGCONTROLPinAction { get; set; }
Public Property ONOFFCONFIGCONTROLPinAction As PmbusTypeOnOffConfig0
    Get
    Set
public:
property PmbusTypeOnOffConfig0 ONOFFCONFIGCONTROLPinAction {
    PmbusTypeOnOffConfig0 get ();
    void set (PmbusTypeOnOffConfig0 value);
}
member ONOFFCONFIGCONTROLPinAction : PmbusTypeOnOffConfig0 with get, set

Property Value

Type: PmbusTypeOnOffConfig0
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.ONOFFCONFIGPolarityCONTROLPin Property

IRD

PmbusONOFFCONFIGPolarityCONTROLPin Property

ON_OFF_CONFIG: Polarity CONTROL Pin

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeOnOffConfig1 ONOFFCONFIGPolarityCONTROLPin { get; set; }
Public Property ONOFFCONFIGPolarityCONTROLPin As PmbusTypeOnOffConfig1
    Get
    Set
public:
property PmbusTypeOnOffConfig1 ONOFFCONFIGPolarityCONTROLPin {
    PmbusTypeOnOffConfig1 get ();
    void set (PmbusTypeOnOffConfig1 value);
}
member ONOFFCONFIGPolarityCONTROLPin : PmbusTypeOnOffConfig1 with get, set

Property Value

Type: PmbusTypeOnOffConfig1
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.ONOFFCONFIGPowerUp Property

IRD

PmbusONOFFCONFIGPowerUp Property

ON_OFF_CONFIG: Power Up

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeOnOffConfig4 ONOFFCONFIGPowerUp { get; set; }
Public Property ONOFFCONFIGPowerUp As PmbusTypeOnOffConfig4
    Get
    Set
public:
property PmbusTypeOnOffConfig4 ONOFFCONFIGPowerUp {
    PmbusTypeOnOffConfig4 get ();
    void set (PmbusTypeOnOffConfig4 value);
}
member ONOFFCONFIGPowerUp : PmbusTypeOnOffConfig4 with get, set

Property Value

Type: PmbusTypeOnOffConfig4
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.ONOFFCONFIGSerialBus Property

IRD

PmbusONOFFCONFIGSerialBus Property

ON_OFF_CONFIG: Serial Bus

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeOnOffConfig3 ONOFFCONFIGSerialBus { get; set; }
Public Property ONOFFCONFIGSerialBus As PmbusTypeOnOffConfig3
    Get
    Set
public:
property PmbusTypeOnOffConfig3 ONOFFCONFIGSerialBus {
    PmbusTypeOnOffConfig3 get ();
    void set (PmbusTypeOnOffConfig3 value);
}
member ONOFFCONFIGSerialBus : PmbusTypeOnOffConfig3 with get, set

Property Value

Type: PmbusTypeOnOffConfig3
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.OPERATION Property

IRD

PmbusOPERATION Property

OPERATION

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeOperation OPERATION { get; set; }
Public Property OPERATION As PmbusTypeOperation
    Get
    Set
public:
property PmbusTypeOperation OPERATION {
    PmbusTypeOperation get ();
    void set (PmbusTypeOperation value);
}
member OPERATION : PmbusTypeOperation with get, set

Property Value

Type: PmbusTypeOperation
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.OTFAULTLIMIT Property

IRD

PmbusOTFAULTLIMIT Property

OT_FAULT_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort OTFAULTLIMIT { get; set; }
Public Property OTFAULTLIMIT As UShort
    Get
    Set
public:
property unsigned short OTFAULTLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member OTFAULTLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.OTFAULTRESPONSEDelayTime Property

IRD

PmbusOTFAULTRESPONSEDelayTime Property

OT_FAULT_RESPONSE: Delay Time

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OTFAULTRESPONSEDelayTime { get; set; }
Public Property OTFAULTRESPONSEDelayTime As Byte
    Get
    Set
public:
property unsigned char OTFAULTRESPONSEDelayTime {
    unsigned char get ();
    void set (unsigned char value);
}
member OTFAULTRESPONSEDelayTime : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.OTFAULTRESPONSEResponse Property

IRD

PmbusOTFAULTRESPONSEResponse Property

OT_FAULT_RESPONSE: Response

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespVoltageTempFaultsResponse OTFAULTRESPONSEResponse { get; set; }
Public Property OTFAULTRESPONSEResponse As PmbusTypeRespVoltageTempFaultsResponse
    Get
    Set
public:
property PmbusTypeRespVoltageTempFaultsResponse OTFAULTRESPONSEResponse {
    PmbusTypeRespVoltageTempFaultsResponse get ();
    void set (PmbusTypeRespVoltageTempFaultsResponse value);
}
member OTFAULTRESPONSEResponse : PmbusTypeRespVoltageTempFaultsResponse with get, set

Property Value

Type: PmbusTypeRespVoltageTempFaultsResponse
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.OTFAULTRESPONSERetrySetting Property

IRD

PmbusOTFAULTRESPONSERetrySetting Property

OT_FAULT_RESPONSE: Retry Setting

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespVoltageTempFaultsRetry OTFAULTRESPONSERetrySetting { get; set; }
Public Property OTFAULTRESPONSERetrySetting As PmbusTypeRespVoltageTempFaultsRetry
    Get
    Set
public:
property PmbusTypeRespVoltageTempFaultsRetry OTFAULTRESPONSERetrySetting {
    PmbusTypeRespVoltageTempFaultsRetry get ();
    void set (PmbusTypeRespVoltageTempFaultsRetry value);
}
member OTFAULTRESPONSERetrySetting : PmbusTypeRespVoltageTempFaultsRetry with get, set

Property Value

Type: PmbusTypeRespVoltageTempFaultsRetry
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.OTWARNLIMIT Property

IRD

PmbusOTWARNLIMIT Property

OT_WARN_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort OTWARNLIMIT { get; set; }
Public Property OTWARNLIMIT As UShort
    Get
    Set
public:
property unsigned short OTWARNLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member OTWARNLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.PAGE Property

IRD

PmbusPAGE Property

PAGE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypePage PAGE { get; set; }
Public Property PAGE As PmbusTypePage
    Get
    Set
public:
property PmbusTypePage PAGE {
    PmbusTypePage get ();
    void set (PmbusTypePage value);
}
member PAGE : PmbusTypePage with get, set

Property Value

Type: PmbusTypePage
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.PAGEPLUSREADCOMMANDCODE Property

IRD

PmbusPAGEPLUSREADCOMMANDCODE Property

PAGE_PLUS_READ: COMMAND CODE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PAGEPLUSREADCOMMANDCODE { set; }
Public WriteOnly Property PAGEPLUSREADCOMMANDCODE As Byte
    Set
public:
property unsigned char PAGEPLUSREADCOMMANDCODE {
    void set (unsigned char value);
}
member PAGEPLUSREADCOMMANDCODE : byte with set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.PAGEPLUSREADDATA Property

IRD

PmbusPAGEPLUSREADDATA Property

PAGE_PLUS_READ: DATA

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort PAGEPLUSREADDATA { get; }
Public ReadOnly Property PAGEPLUSREADDATA As UShort
    Get
public:
property unsigned short PAGEPLUSREADDATA {
    unsigned short get ();
}
member PAGEPLUSREADDATA : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.PAGEPLUSREADPAGENUMBER Property

IRD

PmbusPAGEPLUSREADPAGENUMBER Property

PAGE_PLUS_READ: PAGE NUMBER

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypePage PAGEPLUSREADPAGENUMBER { set; }
Public WriteOnly Property PAGEPLUSREADPAGENUMBER As PmbusTypePage
    Set
public:
property PmbusTypePage PAGEPLUSREADPAGENUMBER {
    void set (PmbusTypePage value);
}
member PAGEPLUSREADPAGENUMBER : PmbusTypePage with set

Property Value

Type: PmbusTypePage
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.PAGEPLUSWRITECOMMANDCODE Property

IRD

PmbusPAGEPLUSWRITECOMMANDCODE Property

PAGE_PLUS_WRITE: COMMAND CODE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PAGEPLUSWRITECOMMANDCODE { set; }
Public WriteOnly Property PAGEPLUSWRITECOMMANDCODE As Byte
    Set
public:
property unsigned char PAGEPLUSWRITECOMMANDCODE {
    void set (unsigned char value);
}
member PAGEPLUSWRITECOMMANDCODE : byte with set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.PAGEPLUSWRITEDATA Property

IRD

PmbusPAGEPLUSWRITEDATA Property

PAGE_PLUS_WRITE: DATA

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort PAGEPLUSWRITEDATA { set; }
Public WriteOnly Property PAGEPLUSWRITEDATA As UShort
    Set
public:
property unsigned short PAGEPLUSWRITEDATA {
    void set (unsigned short value);
}
member PAGEPLUSWRITEDATA : uint16 with set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.PAGEPLUSWRITEPAGENUMBER Property

IRD

PmbusPAGEPLUSWRITEPAGENUMBER Property

PAGE_PLUS_WRITE: PAGE NUMBER

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypePage PAGEPLUSWRITEPAGENUMBER { set; }
Public WriteOnly Property PAGEPLUSWRITEPAGENUMBER As PmbusTypePage
    Set
public:
property PmbusTypePage PAGEPLUSWRITEPAGENUMBER {
    void set (PmbusTypePage value);
}
member PAGEPLUSWRITEPAGENUMBER : PmbusTypePage with set

Property Value

Type: PmbusTypePage
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.PHASE Property

IRD

PmbusPHASE Property

PHASE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypePhase PHASE { get; set; }
Public Property PHASE As PmbusTypePhase
    Get
    Set
public:
property PmbusTypePhase PHASE {
    PmbusTypePhase get ();
    void set (PmbusTypePhase value);
}
member PHASE : PmbusTypePhase with get, set

Property Value

Type: PmbusTypePhase
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.PINOPWARNLIMIT Property

IRD

PmbusPINOPWARNLIMIT Property

PIN_OP_WARN_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort PINOPWARNLIMIT { get; set; }
Public Property PINOPWARNLIMIT As UShort
    Get
    Set
public:
property unsigned short PINOPWARNLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member PINOPWARNLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.PMBUSREVISIONPartIIRevision Property

IRD

PmbusPMBUSREVISIONPartIIRevision Property

PMBUS_REVISION: Part II Revision

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypePmbusRevision PMBUSREVISIONPartIIRevision { get; }
Public ReadOnly Property PMBUSREVISIONPartIIRevision As PmbusTypePmbusRevision
    Get
public:
property PmbusTypePmbusRevision PMBUSREVISIONPartIIRevision {
    PmbusTypePmbusRevision get ();
}
member PMBUSREVISIONPartIIRevision : PmbusTypePmbusRevision with get

Property Value

Type: PmbusTypePmbusRevision
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.PMBUSREVISIONPartIRevision Property

IRD

PmbusPMBUSREVISIONPartIRevision Property

PMBUS_REVISION: Part I Revision

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypePmbusRevision PMBUSREVISIONPartIRevision { get; }
Public ReadOnly Property PMBUSREVISIONPartIRevision As PmbusTypePmbusRevision
    Get
public:
property PmbusTypePmbusRevision PMBUSREVISIONPartIRevision {
    PmbusTypePmbusRevision get ();
}
member PMBUSREVISIONPartIRevision : PmbusTypePmbusRevision with get

Property Value

Type: PmbusTypePmbusRevision
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.POUTMAX Property

IRD

PmbusPOUTMAX Property

POUT_MAX

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort POUTMAX { get; set; }
Public Property POUTMAX As UShort
    Get
    Set
public:
property unsigned short POUTMAX {
    unsigned short get ();
    void set (unsigned short value);
}
member POUTMAX : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.POUTOPFAULTLIMIT Property

IRD

PmbusPOUTOPFAULTLIMIT Property

POUT_OP_FAULT_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort POUTOPFAULTLIMIT { get; set; }
Public Property POUTOPFAULTLIMIT As UShort
    Get
    Set
public:
property unsigned short POUTOPFAULTLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member POUTOPFAULTLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.POUTOPFAULTRESPONSEDelayTime Property

IRD

PmbusPOUTOPFAULTRESPONSEDelayTime Property

POUT_OP_FAULT_RESPONSE: Delay Time

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte POUTOPFAULTRESPONSEDelayTime { get; set; }
Public Property POUTOPFAULTRESPONSEDelayTime As Byte
    Get
    Set
public:
property unsigned char POUTOPFAULTRESPONSEDelayTime {
    unsigned char get ();
    void set (unsigned char value);
}
member POUTOPFAULTRESPONSEDelayTime : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.POUTOPFAULTRESPONSEResponse Property

IRD

PmbusPOUTOPFAULTRESPONSEResponse Property

POUT_OP_FAULT_RESPONSE: Response

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespVoltageTempFaultsResponse POUTOPFAULTRESPONSEResponse { get; set; }
Public Property POUTOPFAULTRESPONSEResponse As PmbusTypeRespVoltageTempFaultsResponse
    Get
    Set
public:
property PmbusTypeRespVoltageTempFaultsResponse POUTOPFAULTRESPONSEResponse {
    PmbusTypeRespVoltageTempFaultsResponse get ();
    void set (PmbusTypeRespVoltageTempFaultsResponse value);
}
member POUTOPFAULTRESPONSEResponse : PmbusTypeRespVoltageTempFaultsResponse with get, set

Property Value

Type: PmbusTypeRespVoltageTempFaultsResponse
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.POUTOPFAULTRESPONSERetrySetting Property

IRD

PmbusPOUTOPFAULTRESPONSERetrySetting Property

POUT_OP_FAULT_RESPONSE: Retry Setting

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespVoltageTempFaultsRetry POUTOPFAULTRESPONSERetrySetting { get; set; }
Public Property POUTOPFAULTRESPONSERetrySetting As PmbusTypeRespVoltageTempFaultsRetry
    Get
    Set
public:
property PmbusTypeRespVoltageTempFaultsRetry POUTOPFAULTRESPONSERetrySetting {
    PmbusTypeRespVoltageTempFaultsRetry get ();
    void set (PmbusTypeRespVoltageTempFaultsRetry value);
}
member POUTOPFAULTRESPONSERetrySetting : PmbusTypeRespVoltageTempFaultsRetry with get, set

Property Value

Type: PmbusTypeRespVoltageTempFaultsRetry
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.POUTOPWARNLIMIT Property

IRD

PmbusPOUTOPWARNLIMIT Property

POUT_OP_WARN_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort POUTOPWARNLIMIT { get; set; }
Public Property POUTOPWARNLIMIT As UShort
    Get
    Set
public:
property unsigned short POUTOPWARNLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member POUTOPWARNLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.POWERGOODOFF Property

IRD

PmbusPOWERGOODOFF Property

POWER_GOOD_OFF

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort POWERGOODOFF { get; set; }
Public Property POWERGOODOFF As UShort
    Get
    Set
public:
property unsigned short POWERGOODOFF {
    unsigned short get ();
    void set (unsigned short value);
}
member POWERGOODOFF : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.POWERGOODON Property

IRD

PmbusPOWERGOODON Property

POWER_GOOD_ON

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort POWERGOODON { get; set; }
Public Property POWERGOODON As UShort
    Get
    Set
public:
property unsigned short POWERGOODON {
    unsigned short get ();
    void set (unsigned short value);
}
member POWERGOODON : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.POWERMODE Property

IRD

PmbusPOWERMODE Property

POWER_MODE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypePowerMode POWERMODE { get; set; }
Public Property POWERMODE As PmbusTypePowerMode
    Get
    Set
public:
property PmbusTypePowerMode POWERMODE {
    PmbusTypePowerMode get ();
    void set (PmbusTypePowerMode value);
}
member POWERMODE : PmbusTypePowerMode with get, set

Property Value

Type: PmbusTypePowerMode
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.QUERYCommand Property

IRD

PmbusQUERYCommand Property

QUERY: Command

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeQuerySupported QUERYCommand { get; }
Public ReadOnly Property QUERYCommand As PmbusTypeQuerySupported
    Get
public:
property PmbusTypeQuerySupported QUERYCommand {
    PmbusTypeQuerySupported get ();
}
member QUERYCommand : PmbusTypeQuerySupported with get

Property Value

Type: PmbusTypeQuerySupported
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.QUERYCommandCode Property

IRD

PmbusQUERYCommandCode Property

QUERY: Command Code

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte QUERYCommandCode { set; }
Public WriteOnly Property QUERYCommandCode As Byte
    Set
public:
property unsigned char QUERYCommandCode {
    void set (unsigned char value);
}
member QUERYCommandCode : byte with set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.QUERYCommandRead Property

IRD

PmbusQUERYCommandRead Property

QUERY: Command Read

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeQuerySupportedRead QUERYCommandRead { get; }
Public ReadOnly Property QUERYCommandRead As PmbusTypeQuerySupportedRead
    Get
public:
property PmbusTypeQuerySupportedRead QUERYCommandRead {
    PmbusTypeQuerySupportedRead get ();
}
member QUERYCommandRead : PmbusTypeQuerySupportedRead with get

Property Value

Type: PmbusTypeQuerySupportedRead
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.QUERYCommandWrite Property

IRD

PmbusQUERYCommandWrite Property

QUERY: Command Write

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeQuerySupportedWrite QUERYCommandWrite { get; }
Public ReadOnly Property QUERYCommandWrite As PmbusTypeQuerySupportedWrite
    Get
public:
property PmbusTypeQuerySupportedWrite QUERYCommandWrite {
    PmbusTypeQuerySupportedWrite get ();
}
member QUERYCommandWrite : PmbusTypeQuerySupportedWrite with get

Property Value

Type: PmbusTypeQuerySupportedWrite
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.QUERYFormat Property

IRD

PmbusQUERYFormat Property

QUERY: Format

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeQueryFormat QUERYFormat { get; }
Public ReadOnly Property QUERYFormat As PmbusTypeQueryFormat
    Get
public:
property PmbusTypeQueryFormat QUERYFormat {
    PmbusTypeQueryFormat get ();
}
member QUERYFormat : PmbusTypeQueryFormat with get

Property Value

Type: PmbusTypeQueryFormat
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READDUTYCYCLE Property

IRD

PmbusREADDUTYCYCLE Property

READ_DUTY_CYCLE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort READDUTYCYCLE { get; }
Public ReadOnly Property READDUTYCYCLE As UShort
    Get
public:
property unsigned short READDUTYCYCLE {
    unsigned short get ();
}
member READDUTYCYCLE : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READEINENERGYCOUNT Property

IRD

PmbusREADEINENERGYCOUNT Property

READ_EIN: ENERGY_COUNT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort READEINENERGYCOUNT { get; }
Public ReadOnly Property READEINENERGYCOUNT As UShort
    Get
public:
property unsigned short READEINENERGYCOUNT {
    unsigned short get ();
}
member READEINENERGYCOUNT : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READEINROLLOVERCOUNT Property

IRD

PmbusREADEINROLLOVERCOUNT Property

READ_EIN: ROLLOVER_COUNT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte READEINROLLOVERCOUNT { get; }
Public ReadOnly Property READEINROLLOVERCOUNT As Byte
    Get
public:
property unsigned char READEINROLLOVERCOUNT {
    unsigned char get ();
}
member READEINROLLOVERCOUNT : byte with get

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READEINSAMPLECOUNT Property

IRD

PmbusREADEINSAMPLECOUNT Property

READ_EIN: SAMPLE_COUNT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint READEINSAMPLECOUNT { get; }
Public ReadOnly Property READEINSAMPLECOUNT As UInteger
    Get
public:
property unsigned int READEINSAMPLECOUNT {
    unsigned int get ();
}
member READEINSAMPLECOUNT : uint32 with get

Property Value

Type: UInt32
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READEOUTENERGYCOUNT Property

IRD

PmbusREADEOUTENERGYCOUNT Property

READ_EOUT: ENERGY_COUNT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort READEOUTENERGYCOUNT { get; }
Public ReadOnly Property READEOUTENERGYCOUNT As UShort
    Get
public:
property unsigned short READEOUTENERGYCOUNT {
    unsigned short get ();
}
member READEOUTENERGYCOUNT : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READEOUTROLLOVERCOUNT Property

IRD

PmbusREADEOUTROLLOVERCOUNT Property

READ_EOUT: ROLLOVER_COUNT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte READEOUTROLLOVERCOUNT { get; }
Public ReadOnly Property READEOUTROLLOVERCOUNT As Byte
    Get
public:
property unsigned char READEOUTROLLOVERCOUNT {
    unsigned char get ();
}
member READEOUTROLLOVERCOUNT : byte with get

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READEOUTSAMPLECOUNT Property

IRD

PmbusREADEOUTSAMPLECOUNT Property

READ_EOUT: SAMPLE_COUNT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint READEOUTSAMPLECOUNT { get; }
Public ReadOnly Property READEOUTSAMPLECOUNT As UInteger
    Get
public:
property unsigned int READEOUTSAMPLECOUNT {
    unsigned int get ();
}
member READEOUTSAMPLECOUNT : uint32 with get

Property Value

Type: UInt32
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READFANSPEED1 Property

IRD

PmbusREADFANSPEED1 Property

READ_FAN_SPEED_1

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort READFANSPEED1 { get; }
Public ReadOnly Property READFANSPEED1 As UShort
    Get
public:
property unsigned short READFANSPEED1 {
    unsigned short get ();
}
member READFANSPEED1 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READFANSPEED2 Property

IRD

PmbusREADFANSPEED2 Property

READ_FAN_SPEED_2

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort READFANSPEED2 { get; }
Public ReadOnly Property READFANSPEED2 As UShort
    Get
public:
property unsigned short READFANSPEED2 {
    unsigned short get ();
}
member READFANSPEED2 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READFANSPEED3 Property

IRD

PmbusREADFANSPEED3 Property

READ_FAN_SPEED_3

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort READFANSPEED3 { get; }
Public ReadOnly Property READFANSPEED3 As UShort
    Get
public:
property unsigned short READFANSPEED3 {
    unsigned short get ();
}
member READFANSPEED3 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READFANSPEED4 Property

IRD

PmbusREADFANSPEED4 Property

READ_FAN_SPEED_4

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort READFANSPEED4 { get; }
Public ReadOnly Property READFANSPEED4 As UShort
    Get
public:
property unsigned short READFANSPEED4 {
    unsigned short get ();
}
member READFANSPEED4 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READFREQUENCY Property

IRD

PmbusREADFREQUENCY Property

READ_FREQUENCY

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort READFREQUENCY { get; }
Public ReadOnly Property READFREQUENCY As UShort
    Get
public:
property unsigned short READFREQUENCY {
    unsigned short get ();
}
member READFREQUENCY : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READIIN Property

IRD

PmbusREADIIN Property

READ_IIN

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort READIIN { get; }
Public ReadOnly Property READIIN As UShort
    Get
public:
property unsigned short READIIN {
    unsigned short get ();
}
member READIIN : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READIOUT Property

IRD

PmbusREADIOUT Property

READ_IOUT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort READIOUT { get; }
Public ReadOnly Property READIOUT As UShort
    Get
public:
property unsigned short READIOUT {
    unsigned short get ();
}
member READIOUT : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READKWHCONFIGInputFormat Property

IRD

PmbusREADKWHCONFIGInputFormat Property

READ_KWH_CONFIG: Input Format

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeReadKwhConfigFormat READKWHCONFIGInputFormat { get; }
Public ReadOnly Property READKWHCONFIGInputFormat As PmbusTypeReadKwhConfigFormat
    Get
public:
property PmbusTypeReadKwhConfigFormat READKWHCONFIGInputFormat {
    PmbusTypeReadKwhConfigFormat get ();
}
member READKWHCONFIGInputFormat : PmbusTypeReadKwhConfigFormat with get

Property Value

Type: PmbusTypeReadKwhConfigFormat
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READKWHCONFIGInputHasBeenResetted Property

IRD

PmbusREADKWHCONFIGInputHasBeenResetted Property

READ_KWH_CONFIG: Input Has Been Resetted

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeReadKwhConfigHasBeenResetted READKWHCONFIGInputHasBeenResetted { get; set; }
Public Property READKWHCONFIGInputHasBeenResetted As PmbusTypeReadKwhConfigHasBeenResetted
    Get
    Set
public:
property PmbusTypeReadKwhConfigHasBeenResetted READKWHCONFIGInputHasBeenResetted {
    PmbusTypeReadKwhConfigHasBeenResetted get ();
    void set (PmbusTypeReadKwhConfigHasBeenResetted value);
}
member READKWHCONFIGInputHasBeenResetted : PmbusTypeReadKwhConfigHasBeenResetted with get, set

Property Value

Type: PmbusTypeReadKwhConfigHasBeenResetted
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READKWHCONFIGInputResetSupported Property

IRD

PmbusREADKWHCONFIGInputResetSupported Property

READ_KWH_CONFIG: Input Reset Supported

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeReadKwhConfigResetSupported READKWHCONFIGInputResetSupported { get; }
Public ReadOnly Property READKWHCONFIGInputResetSupported As PmbusTypeReadKwhConfigResetSupported
    Get
public:
property PmbusTypeReadKwhConfigResetSupported READKWHCONFIGInputResetSupported {
    PmbusTypeReadKwhConfigResetSupported get ();
}
member READKWHCONFIGInputResetSupported : PmbusTypeReadKwhConfigResetSupported with get

Property Value

Type: PmbusTypeReadKwhConfigResetSupported
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READKWHCONFIGInputUnits Property

IRD

PmbusREADKWHCONFIGInputUnits Property

READ_KWH_CONFIG: Input Units

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeReadKwhConfigUnit READKWHCONFIGInputUnits { get; }
Public ReadOnly Property READKWHCONFIGInputUnits As PmbusTypeReadKwhConfigUnit
    Get
public:
property PmbusTypeReadKwhConfigUnit READKWHCONFIGInputUnits {
    PmbusTypeReadKwhConfigUnit get ();
}
member READKWHCONFIGInputUnits : PmbusTypeReadKwhConfigUnit with get

Property Value

Type: PmbusTypeReadKwhConfigUnit
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READKWHCONFIGInputValueRolledOver Property

IRD

PmbusREADKWHCONFIGInputValueRolledOver Property

READ_KWH_CONFIG: Input Value Rolled Over

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeReadKwhConfigRolledOver READKWHCONFIGInputValueRolledOver { get; }
Public ReadOnly Property READKWHCONFIGInputValueRolledOver As PmbusTypeReadKwhConfigRolledOver
    Get
public:
property PmbusTypeReadKwhConfigRolledOver READKWHCONFIGInputValueRolledOver {
    PmbusTypeReadKwhConfigRolledOver get ();
}
member READKWHCONFIGInputValueRolledOver : PmbusTypeReadKwhConfigRolledOver with get

Property Value

Type: PmbusTypeReadKwhConfigRolledOver
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READKWHCONFIGInputVolatile Property

IRD

PmbusREADKWHCONFIGInputVolatile Property

READ_KWH_CONFIG: Input Volatile

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeReadKwhConfigVolatile READKWHCONFIGInputVolatile { get; }
Public ReadOnly Property READKWHCONFIGInputVolatile As PmbusTypeReadKwhConfigVolatile
    Get
public:
property PmbusTypeReadKwhConfigVolatile READKWHCONFIGInputVolatile {
    PmbusTypeReadKwhConfigVolatile get ();
}
member READKWHCONFIGInputVolatile : PmbusTypeReadKwhConfigVolatile with get

Property Value

Type: PmbusTypeReadKwhConfigVolatile
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READKWHCONFIGOutputFormat Property

IRD

PmbusREADKWHCONFIGOutputFormat Property

READ_KWH_CONFIG: Output Format

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeReadKwhConfigFormat READKWHCONFIGOutputFormat { get; }
Public ReadOnly Property READKWHCONFIGOutputFormat As PmbusTypeReadKwhConfigFormat
    Get
public:
property PmbusTypeReadKwhConfigFormat READKWHCONFIGOutputFormat {
    PmbusTypeReadKwhConfigFormat get ();
}
member READKWHCONFIGOutputFormat : PmbusTypeReadKwhConfigFormat with get

Property Value

Type: PmbusTypeReadKwhConfigFormat
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READKWHCONFIGOutputHasBeenResetted Property

IRD

PmbusREADKWHCONFIGOutputHasBeenResetted Property

READ_KWH_CONFIG: Output Has Been Resetted

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeReadKwhConfigHasBeenResetted READKWHCONFIGOutputHasBeenResetted { get; set; }
Public Property READKWHCONFIGOutputHasBeenResetted As PmbusTypeReadKwhConfigHasBeenResetted
    Get
    Set
public:
property PmbusTypeReadKwhConfigHasBeenResetted READKWHCONFIGOutputHasBeenResetted {
    PmbusTypeReadKwhConfigHasBeenResetted get ();
    void set (PmbusTypeReadKwhConfigHasBeenResetted value);
}
member READKWHCONFIGOutputHasBeenResetted : PmbusTypeReadKwhConfigHasBeenResetted with get, set

Property Value

Type: PmbusTypeReadKwhConfigHasBeenResetted
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READKWHCONFIGOutputResetSupported Property

IRD

PmbusREADKWHCONFIGOutputResetSupported Property

READ_KWH_CONFIG: Output Reset Supported

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeReadKwhConfigResetSupported READKWHCONFIGOutputResetSupported { get; }
Public ReadOnly Property READKWHCONFIGOutputResetSupported As PmbusTypeReadKwhConfigResetSupported
    Get
public:
property PmbusTypeReadKwhConfigResetSupported READKWHCONFIGOutputResetSupported {
    PmbusTypeReadKwhConfigResetSupported get ();
}
member READKWHCONFIGOutputResetSupported : PmbusTypeReadKwhConfigResetSupported with get

Property Value

Type: PmbusTypeReadKwhConfigResetSupported
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READKWHCONFIGOutputUnits Property

IRD

PmbusREADKWHCONFIGOutputUnits Property

READ_KWH_CONFIG: Output Units

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeReadKwhConfigUnit READKWHCONFIGOutputUnits { get; }
Public ReadOnly Property READKWHCONFIGOutputUnits As PmbusTypeReadKwhConfigUnit
    Get
public:
property PmbusTypeReadKwhConfigUnit READKWHCONFIGOutputUnits {
    PmbusTypeReadKwhConfigUnit get ();
}
member READKWHCONFIGOutputUnits : PmbusTypeReadKwhConfigUnit with get

Property Value

Type: PmbusTypeReadKwhConfigUnit
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READKWHCONFIGOutputValueRolledOver Property

IRD

PmbusREADKWHCONFIGOutputValueRolledOver Property

READ_KWH_CONFIG: Output Value Rolled Over

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeReadKwhConfigRolledOver READKWHCONFIGOutputValueRolledOver { get; }
Public ReadOnly Property READKWHCONFIGOutputValueRolledOver As PmbusTypeReadKwhConfigRolledOver
    Get
public:
property PmbusTypeReadKwhConfigRolledOver READKWHCONFIGOutputValueRolledOver {
    PmbusTypeReadKwhConfigRolledOver get ();
}
member READKWHCONFIGOutputValueRolledOver : PmbusTypeReadKwhConfigRolledOver with get

Property Value

Type: PmbusTypeReadKwhConfigRolledOver
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READKWHCONFIGOutputVolatile Property

IRD

PmbusREADKWHCONFIGOutputVolatile Property

READ_KWH_CONFIG: Output Volatile

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeReadKwhConfigVolatile READKWHCONFIGOutputVolatile { get; }
Public ReadOnly Property READKWHCONFIGOutputVolatile As PmbusTypeReadKwhConfigVolatile
    Get
public:
property PmbusTypeReadKwhConfigVolatile READKWHCONFIGOutputVolatile {
    PmbusTypeReadKwhConfigVolatile get ();
}
member READKWHCONFIGOutputVolatile : PmbusTypeReadKwhConfigVolatile with get

Property Value

Type: PmbusTypeReadKwhConfigVolatile
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READKWHCONFIGREADKWHINSupported Property

IRD

PmbusREADKWHCONFIGREADKWHINSupported Property

READ_KWH_CONFIG: READ_KWH_IN Supported

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeReadKwhConfigSupported READKWHCONFIGREADKWHINSupported { get; }
Public ReadOnly Property READKWHCONFIGREADKWHINSupported As PmbusTypeReadKwhConfigSupported
    Get
public:
property PmbusTypeReadKwhConfigSupported READKWHCONFIGREADKWHINSupported {
    PmbusTypeReadKwhConfigSupported get ();
}
member READKWHCONFIGREADKWHINSupported : PmbusTypeReadKwhConfigSupported with get

Property Value

Type: PmbusTypeReadKwhConfigSupported
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READKWHCONFIGREADKWHOUTSupported Property

IRD

PmbusREADKWHCONFIGREADKWHOUTSupported Property

READ_KWH_CONFIG: READ_KWH_OUT Supported

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeReadKwhConfigSupported READKWHCONFIGREADKWHOUTSupported { get; }
Public ReadOnly Property READKWHCONFIGREADKWHOUTSupported As PmbusTypeReadKwhConfigSupported
    Get
public:
property PmbusTypeReadKwhConfigSupported READKWHCONFIGREADKWHOUTSupported {
    PmbusTypeReadKwhConfigSupported get ();
}
member READKWHCONFIGREADKWHOUTSupported : PmbusTypeReadKwhConfigSupported with get

Property Value

Type: PmbusTypeReadKwhConfigSupported
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READKWHIN Property

IRD

PmbusREADKWHIN Property

READ_KWH_IN

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint READKWHIN { get; }
Public ReadOnly Property READKWHIN As UInteger
    Get
public:
property unsigned int READKWHIN {
    unsigned int get ();
}
member READKWHIN : uint32 with get

Property Value

Type: UInt32
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READKWHOUT Property

IRD

PmbusREADKWHOUT Property

READ_KWH_OUT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint READKWHOUT { get; }
Public ReadOnly Property READKWHOUT As UInteger
    Get
public:
property unsigned int READKWHOUT {
    unsigned int get ();
}
member READKWHOUT : uint32 with get

Property Value

Type: UInt32
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READPIN Property

IRD

PmbusREADPIN Property

READ_PIN

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort READPIN { get; }
Public ReadOnly Property READPIN As UShort
    Get
public:
property unsigned short READPIN {
    unsigned short get ();
}
member READPIN : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READPOUT Property

IRD

PmbusREADPOUT Property

READ_POUT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort READPOUT { get; }
Public ReadOnly Property READPOUT As UShort
    Get
public:
property unsigned short READPOUT {
    unsigned short get ();
}
member READPOUT : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READTEMPERATURE1 Property

IRD

PmbusREADTEMPERATURE1 Property

READ_TEMPERATURE_1

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort READTEMPERATURE1 { get; }
Public ReadOnly Property READTEMPERATURE1 As UShort
    Get
public:
property unsigned short READTEMPERATURE1 {
    unsigned short get ();
}
member READTEMPERATURE1 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READTEMPERATURE2 Property

IRD

PmbusREADTEMPERATURE2 Property

READ_TEMPERATURE_2

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort READTEMPERATURE2 { get; }
Public ReadOnly Property READTEMPERATURE2 As UShort
    Get
public:
property unsigned short READTEMPERATURE2 {
    unsigned short get ();
}
member READTEMPERATURE2 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READTEMPERATURE3 Property

IRD

PmbusREADTEMPERATURE3 Property

READ_TEMPERATURE_3

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort READTEMPERATURE3 { get; }
Public ReadOnly Property READTEMPERATURE3 As UShort
    Get
public:
property unsigned short READTEMPERATURE3 {
    unsigned short get ();
}
member READTEMPERATURE3 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READVCAP Property

IRD

PmbusREADVCAP Property

READ_VCAP

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort READVCAP { get; }
Public ReadOnly Property READVCAP As UShort
    Get
public:
property unsigned short READVCAP {
    unsigned short get ();
}
member READVCAP : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READVIN Property

IRD

PmbusREADVIN Property

READ_VIN

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort READVIN { get; }
Public ReadOnly Property READVIN As UShort
    Get
public:
property unsigned short READVIN {
    unsigned short get ();
}
member READVIN : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.READVOUT Property

IRD

PmbusREADVOUT Property

READ_VOUT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort READVOUT { get; }
Public ReadOnly Property READVOUT As UShort
    Get
public:
property unsigned short READVOUT {
    unsigned short get ();
}
member READVOUT : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.RESTOREDEFAULTCODE Property

IRD

PmbusRESTOREDEFAULTCODE Property

RESTORE_DEFAULT_CODE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESTOREDEFAULTCODE { set; }
Public WriteOnly Property RESTOREDEFAULTCODE As Byte
    Set
public:
property unsigned char RESTOREDEFAULTCODE {
    void set (unsigned char value);
}
member RESTOREDEFAULTCODE : byte with set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.RESTOREUSERCODE Property

IRD

PmbusRESTOREUSERCODE Property

RESTORE_USER_CODE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte RESTOREUSERCODE { set; }
Public WriteOnly Property RESTOREUSERCODE As Byte
    Set
public:
property unsigned char RESTOREUSERCODE {
    void set (unsigned char value);
}
member RESTOREUSERCODE : byte with set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.SMBALERTMASKMask Property

IRD

PmbusSMBALERTMASKMask Property

SMBALERT_MASK: Mask

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SMBALERTMASKMask { set; }
Public WriteOnly Property SMBALERTMASKMask As Byte
    Set
public:
property unsigned char SMBALERTMASKMask {
    void set (unsigned char value);
}
member SMBALERTMASKMask : byte with set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.SMBALERTMASKStatusCommandCode Property

IRD

PmbusSMBALERTMASKStatusCommandCode Property

SMBALERT_MASK: Status Command Code

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SMBALERTMASKStatusCommandCode { set; }
Public WriteOnly Property SMBALERTMASKStatusCommandCode As Byte
    Set
public:
property unsigned char SMBALERTMASKStatusCommandCode {
    void set (unsigned char value);
}
member SMBALERTMASKStatusCommandCode : byte with set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSBYTEBUSY Property

IRD

PmbusSTATUSBYTEBUSY Property

STATUS_BYTE: BUSY

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSBYTEBUSY { get; set; }
Public Property STATUSBYTEBUSY As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSBYTEBUSY {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSBYTEBUSY : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSBYTECML Property

IRD

PmbusSTATUSBYTECML Property

STATUS_BYTE: CML

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSBYTECML { get; set; }
Public Property STATUSBYTECML As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSBYTECML {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSBYTECML : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSBYTEIOUTOCFAULT Property

IRD

PmbusSTATUSBYTEIOUTOCFAULT Property

STATUS_BYTE: IOUT_OC_FAULT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSBYTEIOUTOCFAULT { get; set; }
Public Property STATUSBYTEIOUTOCFAULT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSBYTEIOUTOCFAULT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSBYTEIOUTOCFAULT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSBYTENONEOFTHEABOVE Property

IRD

PmbusSTATUSBYTENONEOFTHEABOVE Property

STATUS_BYTE: NONE OF THE ABOVE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSBYTENONEOFTHEABOVE { get; set; }
Public Property STATUSBYTENONEOFTHEABOVE As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSBYTENONEOFTHEABOVE {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSBYTENONEOFTHEABOVE : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSBYTEOFF Property

IRD

PmbusSTATUSBYTEOFF Property

STATUS_BYTE: OFF

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSBYTEOFF { get; set; }
Public Property STATUSBYTEOFF As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSBYTEOFF {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSBYTEOFF : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSBYTETEMPERATURE Property

IRD

PmbusSTATUSBYTETEMPERATURE Property

STATUS_BYTE: TEMPERATURE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSBYTETEMPERATURE { get; set; }
Public Property STATUSBYTETEMPERATURE As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSBYTETEMPERATURE {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSBYTETEMPERATURE : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSBYTEVINUVFAULT Property

IRD

PmbusSTATUSBYTEVINUVFAULT Property

STATUS_BYTE: VIN_UV_FAULT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSBYTEVINUVFAULT { get; set; }
Public Property STATUSBYTEVINUVFAULT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSBYTEVINUVFAULT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSBYTEVINUVFAULT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSBYTEVOUTOVFAULT Property

IRD

PmbusSTATUSBYTEVOUTOVFAULT Property

STATUS_BYTE: VOUT_OV_FAULT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSBYTEVOUTOVFAULT { get; set; }
Public Property STATUSBYTEVOUTOVFAULT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSBYTEVOUTOVFAULT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSBYTEVOUTOVFAULT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSCMLInvalidOrUnsupportedCommandReceived Property

IRD

PmbusSTATUSCMLInvalidOrUnsupportedCommandReceived Property

STATUS_CML: Invalid Or Unsupported Command Received

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSCMLInvalidOrUnsupportedCommandReceived { get; set; }
Public Property STATUSCMLInvalidOrUnsupportedCommandReceived As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSCMLInvalidOrUnsupportedCommandReceived {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSCMLInvalidOrUnsupportedCommandReceived : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSCMLInvalidOrUnsupportedDataReceived Property

IRD

PmbusSTATUSCMLInvalidOrUnsupportedDataReceived Property

STATUS_CML: Invalid Or Unsupported Data Received

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSCMLInvalidOrUnsupportedDataReceived { get; set; }
Public Property STATUSCMLInvalidOrUnsupportedDataReceived As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSCMLInvalidOrUnsupportedDataReceived {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSCMLInvalidOrUnsupportedDataReceived : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSCMLMemoryFaultDetected Property

IRD

PmbusSTATUSCMLMemoryFaultDetected Property

STATUS_CML: Memory Fault Detected

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSCMLMemoryFaultDetected { get; set; }
Public Property STATUSCMLMemoryFaultDetected As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSCMLMemoryFaultDetected {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSCMLMemoryFaultDetected : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSCMLOtherCommunicationFault Property

IRD

PmbusSTATUSCMLOtherCommunicationFault Property

STATUS_CML: Other Communication Fault

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSCMLOtherCommunicationFault { get; set; }
Public Property STATUSCMLOtherCommunicationFault As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSCMLOtherCommunicationFault {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSCMLOtherCommunicationFault : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSCMLOtherMemoryOrLogicFault Property

IRD

PmbusSTATUSCMLOtherMemoryOrLogicFault Property

STATUS_CML: Other Memory Or Logic Fault

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSCMLOtherMemoryOrLogicFault { get; set; }
Public Property STATUSCMLOtherMemoryOrLogicFault As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSCMLOtherMemoryOrLogicFault {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSCMLOtherMemoryOrLogicFault : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSCMLPacketErrorCheckFailed Property

IRD

PmbusSTATUSCMLPacketErrorCheckFailed Property

STATUS_CML: Packet Error Check Failed

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSCMLPacketErrorCheckFailed { get; set; }
Public Property STATUSCMLPacketErrorCheckFailed As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSCMLPacketErrorCheckFailed {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSCMLPacketErrorCheckFailed : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSCMLProcessorFaultDetected Property

IRD

PmbusSTATUSCMLProcessorFaultDetected Property

STATUS_CML: Processor Fault Detected

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSCMLProcessorFaultDetected { get; set; }
Public Property STATUSCMLProcessorFaultDetected As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSCMLProcessorFaultDetected {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSCMLProcessorFaultDetected : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSFANS12AirflowFault Property

IRD

PmbusSTATUSFANS12AirflowFault Property

STATUS_FANS_1_2: Airflow Fault

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSFANS12AirflowFault { get; set; }
Public Property STATUSFANS12AirflowFault As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSFANS12AirflowFault {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSFANS12AirflowFault : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSFANS12AirflowWarning Property

IRD

PmbusSTATUSFANS12AirflowWarning Property

STATUS_FANS_1_2: Airflow Warning

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSFANS12AirflowWarning { get; set; }
Public Property STATUSFANS12AirflowWarning As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSFANS12AirflowWarning {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSFANS12AirflowWarning : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSFANS12Fan1Fault Property

IRD

PmbusSTATUSFANS12Fan1Fault Property

STATUS_FANS_1_2: Fan 1 Fault

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSFANS12Fan1Fault { get; set; }
Public Property STATUSFANS12Fan1Fault As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSFANS12Fan1Fault {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSFANS12Fan1Fault : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSFANS12Fan1SpeedOverridden Property

IRD

PmbusSTATUSFANS12Fan1SpeedOverridden Property

STATUS_FANS_1_2: Fan 1 Speed Overridden

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSFANS12Fan1SpeedOverridden { get; set; }
Public Property STATUSFANS12Fan1SpeedOverridden As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSFANS12Fan1SpeedOverridden {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSFANS12Fan1SpeedOverridden : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSFANS12Fan1Warning Property

IRD

PmbusSTATUSFANS12Fan1Warning Property

STATUS_FANS_1_2: Fan 1 Warning

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSFANS12Fan1Warning { get; set; }
Public Property STATUSFANS12Fan1Warning As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSFANS12Fan1Warning {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSFANS12Fan1Warning : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSFANS12Fan2Fault Property

IRD

PmbusSTATUSFANS12Fan2Fault Property

STATUS_FANS_1_2: Fan 2 Fault

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSFANS12Fan2Fault { get; set; }
Public Property STATUSFANS12Fan2Fault As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSFANS12Fan2Fault {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSFANS12Fan2Fault : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSFANS12Fan2SpeedOverridden Property

IRD

PmbusSTATUSFANS12Fan2SpeedOverridden Property

STATUS_FANS_1_2: Fan 2 Speed Overridden

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSFANS12Fan2SpeedOverridden { get; set; }
Public Property STATUSFANS12Fan2SpeedOverridden As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSFANS12Fan2SpeedOverridden {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSFANS12Fan2SpeedOverridden : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSFANS12Fan2Warning Property

IRD

PmbusSTATUSFANS12Fan2Warning Property

STATUS_FANS_1_2: Fan 2 Warning

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSFANS12Fan2Warning { get; set; }
Public Property STATUSFANS12Fan2Warning As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSFANS12Fan2Warning {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSFANS12Fan2Warning : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSFANS34Fan3Fault Property

IRD

PmbusSTATUSFANS34Fan3Fault Property

STATUS_FANS_3_4: Fan 3 Fault

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSFANS34Fan3Fault { get; set; }
Public Property STATUSFANS34Fan3Fault As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSFANS34Fan3Fault {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSFANS34Fan3Fault : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSFANS34Fan3SpeedOverridden Property

IRD

PmbusSTATUSFANS34Fan3SpeedOverridden Property

STATUS_FANS_3_4: Fan 3 Speed Overridden

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSFANS34Fan3SpeedOverridden { get; set; }
Public Property STATUSFANS34Fan3SpeedOverridden As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSFANS34Fan3SpeedOverridden {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSFANS34Fan3SpeedOverridden : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSFANS34Fan3Warning Property

IRD

PmbusSTATUSFANS34Fan3Warning Property

STATUS_FANS_3_4: Fan 3 Warning

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSFANS34Fan3Warning { get; set; }
Public Property STATUSFANS34Fan3Warning As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSFANS34Fan3Warning {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSFANS34Fan3Warning : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSFANS34Fan4Fault Property

IRD

PmbusSTATUSFANS34Fan4Fault Property

STATUS_FANS_3_4: Fan 4 Fault

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSFANS34Fan4Fault { get; set; }
Public Property STATUSFANS34Fan4Fault As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSFANS34Fan4Fault {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSFANS34Fan4Fault : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSFANS34Fan4SpeedOverridden Property

IRD

PmbusSTATUSFANS34Fan4SpeedOverridden Property

STATUS_FANS_3_4: Fan 4 Speed Overridden

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSFANS34Fan4SpeedOverridden { get; set; }
Public Property STATUSFANS34Fan4SpeedOverridden As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSFANS34Fan4SpeedOverridden {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSFANS34Fan4SpeedOverridden : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSFANS34Fan4Warning Property

IRD

PmbusSTATUSFANS34Fan4Warning Property

STATUS_FANS_3_4: Fan 4 Warning

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSFANS34Fan4Warning { get; set; }
Public Property STATUSFANS34Fan4Warning As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSFANS34Fan4Warning {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSFANS34Fan4Warning : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSINPUTIINOCFAULT Property

IRD

PmbusSTATUSINPUTIINOCFAULT Property

STATUS_INPUT: IIN_OC_FAULT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSINPUTIINOCFAULT { get; set; }
Public Property STATUSINPUTIINOCFAULT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSINPUTIINOCFAULT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSINPUTIINOCFAULT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSINPUTIINOCWARNING Property

IRD

PmbusSTATUSINPUTIINOCWARNING Property

STATUS_INPUT: IIN_OC_WARNING

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSINPUTIINOCWARNING { get; set; }
Public Property STATUSINPUTIINOCWARNING As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSINPUTIINOCWARNING {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSINPUTIINOCWARNING : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSINPUTPINOPWARNING Property

IRD

PmbusSTATUSINPUTPINOPWARNING Property

STATUS_INPUT: PIN_OP_WARNING

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSINPUTPINOPWARNING { get; set; }
Public Property STATUSINPUTPINOPWARNING As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSINPUTPINOPWARNING {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSINPUTPINOPWARNING : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSINPUTUnitOffForInsufficientInputVoltage Property

IRD

PmbusSTATUSINPUTUnitOffForInsufficientInputVoltage Property

STATUS_INPUT: Unit Off For Insufficient Input Voltage

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSINPUTUnitOffForInsufficientInputVoltage { get; set; }
Public Property STATUSINPUTUnitOffForInsufficientInputVoltage As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSINPUTUnitOffForInsufficientInputVoltage {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSINPUTUnitOffForInsufficientInputVoltage : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSINPUTVINOVFAULT Property

IRD

PmbusSTATUSINPUTVINOVFAULT Property

STATUS_INPUT: VIN_OV_FAULT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSINPUTVINOVFAULT { get; set; }
Public Property STATUSINPUTVINOVFAULT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSINPUTVINOVFAULT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSINPUTVINOVFAULT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSINPUTVINOVWARNING Property

IRD

PmbusSTATUSINPUTVINOVWARNING Property

STATUS_INPUT: VIN_OV_WARNING

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSINPUTVINOVWARNING { get; set; }
Public Property STATUSINPUTVINOVWARNING As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSINPUTVINOVWARNING {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSINPUTVINOVWARNING : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSINPUTVINUVFAULT Property

IRD

PmbusSTATUSINPUTVINUVFAULT Property

STATUS_INPUT: VIN_UV_FAULT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSINPUTVINUVFAULT { get; set; }
Public Property STATUSINPUTVINUVFAULT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSINPUTVINUVFAULT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSINPUTVINUVFAULT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSINPUTVINUVWARNING Property

IRD

PmbusSTATUSINPUTVINUVWARNING Property

STATUS_INPUT: VIN_UV_WARNING

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSINPUTVINUVWARNING { get; set; }
Public Property STATUSINPUTVINUVWARNING As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSINPUTVINUVWARNING {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSINPUTVINUVWARNING : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSIOUTCurrentShareFault Property

IRD

PmbusSTATUSIOUTCurrentShareFault Property

STATUS_IOUT: Current Share Fault

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSIOUTCurrentShareFault { get; set; }
Public Property STATUSIOUTCurrentShareFault As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSIOUTCurrentShareFault {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSIOUTCurrentShareFault : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSIOUTInPowerLimitingMode Property

IRD

PmbusSTATUSIOUTInPowerLimitingMode Property

STATUS_IOUT: In Power Limiting Mode

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSIOUTInPowerLimitingMode { get; set; }
Public Property STATUSIOUTInPowerLimitingMode As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSIOUTInPowerLimitingMode {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSIOUTInPowerLimitingMode : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSIOUTIOUTOCFAULT Property

IRD

PmbusSTATUSIOUTIOUTOCFAULT Property

STATUS_IOUT: IOUT_OC_FAULT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSIOUTIOUTOCFAULT { get; set; }
Public Property STATUSIOUTIOUTOCFAULT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSIOUTIOUTOCFAULT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSIOUTIOUTOCFAULT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSIOUTIOUTOCLVFAULT Property

IRD

PmbusSTATUSIOUTIOUTOCLVFAULT Property

STATUS_IOUT: IOUT_OC_LV_FAULT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSIOUTIOUTOCLVFAULT { get; set; }
Public Property STATUSIOUTIOUTOCLVFAULT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSIOUTIOUTOCLVFAULT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSIOUTIOUTOCLVFAULT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSIOUTIOUTOCWARNING Property

IRD

PmbusSTATUSIOUTIOUTOCWARNING Property

STATUS_IOUT: IOUT_OC_WARNING

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSIOUTIOUTOCWARNING { get; set; }
Public Property STATUSIOUTIOUTOCWARNING As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSIOUTIOUTOCWARNING {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSIOUTIOUTOCWARNING : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSIOUTIOUTUCFAULT Property

IRD

PmbusSTATUSIOUTIOUTUCFAULT Property

STATUS_IOUT: IOUT_UC_FAULT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSIOUTIOUTUCFAULT { get; set; }
Public Property STATUSIOUTIOUTUCFAULT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSIOUTIOUTUCFAULT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSIOUTIOUTUCFAULT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSIOUTPOUTOPFAULT Property

IRD

PmbusSTATUSIOUTPOUTOPFAULT Property

STATUS_IOUT: POUT_OP_FAULT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSIOUTPOUTOPFAULT { get; set; }
Public Property STATUSIOUTPOUTOPFAULT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSIOUTPOUTOPFAULT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSIOUTPOUTOPFAULT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSIOUTPOUTOPWARNING Property

IRD

PmbusSTATUSIOUTPOUTOPWARNING Property

STATUS_IOUT: POUT_OP_WARNING

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSIOUTPOUTOPWARNING { get; set; }
Public Property STATUSIOUTPOUTOPWARNING As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSIOUTPOUTOPWARNING {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSIOUTPOUTOPWARNING : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSMFRSPECIFIC Property

IRD

PmbusSTATUSMFRSPECIFIC Property

STATUS_MFR_SPECIFIC

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STATUSMFRSPECIFIC { get; set; }
Public Property STATUSMFRSPECIFIC As Byte
    Get
    Set
public:
property unsigned char STATUSMFRSPECIFIC {
    unsigned char get ();
    void set (unsigned char value);
}
member STATUSMFRSPECIFIC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSOTHERFirstToAssertSMBALERT Property

IRD

PmbusSTATUSOTHERFirstToAssertSMBALERT Property

STATUS_OTHER: First To Assert SMBALERT#

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSOTHERFirstToAssertSMBALERT { get; set; }
Public Property STATUSOTHERFirstToAssertSMBALERT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSOTHERFirstToAssertSMBALERT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSOTHERFirstToAssertSMBALERT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSOTHERInputAFuseOrCircuitBreakerFault Property

IRD

PmbusSTATUSOTHERInputAFuseOrCircuitBreakerFault Property

STATUS_OTHER: Input A Fuse Or Circuit Breaker Fault

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSOTHERInputAFuseOrCircuitBreakerFault { get; set; }
Public Property STATUSOTHERInputAFuseOrCircuitBreakerFault As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSOTHERInputAFuseOrCircuitBreakerFault {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSOTHERInputAFuseOrCircuitBreakerFault : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSOTHERInputAORIngDeviceFault Property

IRD

PmbusSTATUSOTHERInputAORIngDeviceFault Property

STATUS_OTHER: Input A OR-ing Device Fault

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSOTHERInputAORIngDeviceFault { get; set; }
Public Property STATUSOTHERInputAORIngDeviceFault As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSOTHERInputAORIngDeviceFault {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSOTHERInputAORIngDeviceFault : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSOTHERInputBFuseOrCircuitBreakerFault Property

IRD

PmbusSTATUSOTHERInputBFuseOrCircuitBreakerFault Property

STATUS_OTHER: Input B Fuse Or Circuit Breaker Fault

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSOTHERInputBFuseOrCircuitBreakerFault { get; set; }
Public Property STATUSOTHERInputBFuseOrCircuitBreakerFault As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSOTHERInputBFuseOrCircuitBreakerFault {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSOTHERInputBFuseOrCircuitBreakerFault : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSOTHERInputBORIngDeviceFault Property

IRD

PmbusSTATUSOTHERInputBORIngDeviceFault Property

STATUS_OTHER: Input B OR-ing Device Fault

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSOTHERInputBORIngDeviceFault { get; set; }
Public Property STATUSOTHERInputBORIngDeviceFault As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSOTHERInputBORIngDeviceFault {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSOTHERInputBORIngDeviceFault : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSOTHEROutputORIngDeviceFault Property

IRD

PmbusSTATUSOTHEROutputORIngDeviceFault Property

STATUS_OTHER: Output OR-ing Device Fault

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSOTHEROutputORIngDeviceFault { get; set; }
Public Property STATUSOTHEROutputORIngDeviceFault As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSOTHEROutputORIngDeviceFault {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSOTHEROutputORIngDeviceFault : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSTEMPERATUREOTFAULT Property

IRD

PmbusSTATUSTEMPERATUREOTFAULT Property

STATUS_TEMPERATURE: OT_FAULT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSTEMPERATUREOTFAULT { get; set; }
Public Property STATUSTEMPERATUREOTFAULT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSTEMPERATUREOTFAULT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSTEMPERATUREOTFAULT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSTEMPERATUREOTWARNING Property

IRD

PmbusSTATUSTEMPERATUREOTWARNING Property

STATUS_TEMPERATURE: OT_WARNING

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSTEMPERATUREOTWARNING { get; set; }
Public Property STATUSTEMPERATUREOTWARNING As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSTEMPERATUREOTWARNING {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSTEMPERATUREOTWARNING : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSTEMPERATUREUTFAULT Property

IRD

PmbusSTATUSTEMPERATUREUTFAULT Property

STATUS_TEMPERATURE: UT_FAULT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSTEMPERATUREUTFAULT { get; set; }
Public Property STATUSTEMPERATUREUTFAULT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSTEMPERATUREUTFAULT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSTEMPERATUREUTFAULT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSTEMPERATUREUTWARNING Property

IRD

PmbusSTATUSTEMPERATUREUTWARNING Property

STATUS_TEMPERATURE: UT_WARNING

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSTEMPERATUREUTWARNING { get; set; }
Public Property STATUSTEMPERATUREUTWARNING As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSTEMPERATUREUTWARNING {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSTEMPERATUREUTWARNING : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSVOUTTOFFMAXWARNING Property

IRD

PmbusSTATUSVOUTTOFFMAXWARNING Property

STATUS_VOUT: TOFF_MAX_WARNING

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSVOUTTOFFMAXWARNING { get; set; }
Public Property STATUSVOUTTOFFMAXWARNING As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSVOUTTOFFMAXWARNING {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSVOUTTOFFMAXWARNING : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSVOUTTONMAXFAULT Property

IRD

PmbusSTATUSVOUTTONMAXFAULT Property

STATUS_VOUT: TON_MAX_FAULT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSVOUTTONMAXFAULT { get; set; }
Public Property STATUSVOUTTONMAXFAULT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSVOUTTONMAXFAULT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSVOUTTONMAXFAULT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSVOUTVOUTMAX Property

IRD

PmbusSTATUSVOUTVOUTMAX Property

STATUS_VOUT: VOUT_MAX

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSVOUTVOUTMAX { get; set; }
Public Property STATUSVOUTVOUTMAX As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSVOUTVOUTMAX {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSVOUTVOUTMAX : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSVOUTVOUTOVFAULT Property

IRD

PmbusSTATUSVOUTVOUTOVFAULT Property

STATUS_VOUT: VOUT_OV_FAULT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSVOUTVOUTOVFAULT { get; set; }
Public Property STATUSVOUTVOUTOVFAULT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSVOUTVOUTOVFAULT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSVOUTVOUTOVFAULT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSVOUTVOUTOVWARNING Property

IRD

PmbusSTATUSVOUTVOUTOVWARNING Property

STATUS_VOUT: VOUT_OV_WARNING

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSVOUTVOUTOVWARNING { get; set; }
Public Property STATUSVOUTVOUTOVWARNING As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSVOUTVOUTOVWARNING {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSVOUTVOUTOVWARNING : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSVOUTVOUTTrackingError Property

IRD

PmbusSTATUSVOUTVOUTTrackingError Property

STATUS_VOUT: VOUT Tracking Error

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSVOUTVOUTTrackingError { get; set; }
Public Property STATUSVOUTVOUTTrackingError As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSVOUTVOUTTrackingError {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSVOUTVOUTTrackingError : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSVOUTVOUTUVFAULT Property

IRD

PmbusSTATUSVOUTVOUTUVFAULT Property

STATUS_VOUT: VOUT_UV_FAULT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSVOUTVOUTUVFAULT { get; set; }
Public Property STATUSVOUTVOUTUVFAULT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSVOUTVOUTUVFAULT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSVOUTVOUTUVFAULT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSVOUTVOUTUVWARNING Property

IRD

PmbusSTATUSVOUTVOUTUVWARNING Property

STATUS_VOUT: VOUT_UV_WARNING

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSVOUTVOUTUVWARNING { get; set; }
Public Property STATUSVOUTVOUTUVWARNING As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSVOUTVOUTUVWARNING {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSVOUTVOUTUVWARNING : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSWORDBUSY Property

IRD

PmbusSTATUSWORDBUSY Property

STATUS_WORD: BUSY

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSWORDBUSY { get; set; }
Public Property STATUSWORDBUSY As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSWORDBUSY {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSWORDBUSY : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSWORDCML Property

IRD

PmbusSTATUSWORDCML Property

STATUS_WORD: CML

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSWORDCML { get; set; }
Public Property STATUSWORDCML As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSWORDCML {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSWORDCML : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSWORDFANS Property

IRD

PmbusSTATUSWORDFANS Property

STATUS_WORD: FANS

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSWORDFANS { get; set; }
Public Property STATUSWORDFANS As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSWORDFANS {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSWORDFANS : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSWORDINPUT Property

IRD

PmbusSTATUSWORDINPUT Property

STATUS_WORD: INPUT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSWORDINPUT { get; set; }
Public Property STATUSWORDINPUT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSWORDINPUT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSWORDINPUT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSWORDIOUTOCFAULT Property

IRD

PmbusSTATUSWORDIOUTOCFAULT Property

STATUS_WORD: IOUT_OC_FAULT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSWORDIOUTOCFAULT { get; set; }
Public Property STATUSWORDIOUTOCFAULT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSWORDIOUTOCFAULT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSWORDIOUTOCFAULT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSWORDIOUTPOUT Property

IRD

PmbusSTATUSWORDIOUTPOUT Property

STATUS_WORD: IOUT/POUT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSWORDIOUTPOUT { get; set; }
Public Property STATUSWORDIOUTPOUT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSWORDIOUTPOUT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSWORDIOUTPOUT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSWORDMFRSPECIFIC Property

IRD

PmbusSTATUSWORDMFRSPECIFIC Property

STATUS_WORD: MFR_SPECIFIC

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSWORDMFRSPECIFIC { get; set; }
Public Property STATUSWORDMFRSPECIFIC As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSWORDMFRSPECIFIC {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSWORDMFRSPECIFIC : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSWORDNONEOFTHEABOVE Property

IRD

PmbusSTATUSWORDNONEOFTHEABOVE Property

STATUS_WORD: NONE OF THE ABOVE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSWORDNONEOFTHEABOVE { get; set; }
Public Property STATUSWORDNONEOFTHEABOVE As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSWORDNONEOFTHEABOVE {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSWORDNONEOFTHEABOVE : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSWORDOFF Property

IRD

PmbusSTATUSWORDOFF Property

STATUS_WORD: OFF

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSWORDOFF { get; set; }
Public Property STATUSWORDOFF As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSWORDOFF {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSWORDOFF : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSWORDOTHER Property

IRD

PmbusSTATUSWORDOTHER Property

STATUS_WORD: OTHER

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSWORDOTHER { get; set; }
Public Property STATUSWORDOTHER As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSWORDOTHER {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSWORDOTHER : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSWORDPOWERGOOD Property

IRD

PmbusSTATUSWORDPOWERGOOD Property

STATUS_WORD: POWER_GOOD#

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSWORDPOWERGOOD { get; set; }
Public Property STATUSWORDPOWERGOOD As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSWORDPOWERGOOD {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSWORDPOWERGOOD : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSWORDTEMPERATURE Property

IRD

PmbusSTATUSWORDTEMPERATURE Property

STATUS_WORD: TEMPERATURE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSWORDTEMPERATURE { get; set; }
Public Property STATUSWORDTEMPERATURE As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSWORDTEMPERATURE {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSWORDTEMPERATURE : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSWORDUNKNOWN Property

IRD

PmbusSTATUSWORDUNKNOWN Property

STATUS_WORD: UNKNOWN

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSWORDUNKNOWN { get; set; }
Public Property STATUSWORDUNKNOWN As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSWORDUNKNOWN {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSWORDUNKNOWN : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSWORDVINUVFAULT Property

IRD

PmbusSTATUSWORDVINUVFAULT Property

STATUS_WORD: VIN_UV_FAULT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSWORDVINUVFAULT { get; set; }
Public Property STATUSWORDVINUVFAULT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSWORDVINUVFAULT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSWORDVINUVFAULT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSWORDVOUT Property

IRD

PmbusSTATUSWORDVOUT Property

STATUS_WORD: VOUT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSWORDVOUT { get; set; }
Public Property STATUSWORDVOUT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSWORDVOUT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSWORDVOUT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STATUSWORDVOUTOVFAULT Property

IRD

PmbusSTATUSWORDVOUTOVFAULT Property

STATUS_WORD: VOUT_OV_FAULT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeBool STATUSWORDVOUTOVFAULT { get; set; }
Public Property STATUSWORDVOUTOVFAULT As PmbusTypeBool
    Get
    Set
public:
property PmbusTypeBool STATUSWORDVOUTOVFAULT {
    PmbusTypeBool get ();
    void set (PmbusTypeBool value);
}
member STATUSWORDVOUTOVFAULT : PmbusTypeBool with get, set

Property Value

Type: PmbusTypeBool
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STOREDEFAULTCODE Property

IRD

PmbusSTOREDEFAULTCODE Property

STORE_DEFAULT_CODE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STOREDEFAULTCODE { set; }
Public WriteOnly Property STOREDEFAULTCODE As Byte
    Set
public:
property unsigned char STOREDEFAULTCODE {
    void set (unsigned char value);
}
member STOREDEFAULTCODE : byte with set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STOREUSERCODE Property

IRD

PmbusSTOREUSERCODE Property

STORE_USER_CODE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STOREUSERCODE { set; }
Public WriteOnly Property STOREUSERCODE As Byte
    Set
public:
property unsigned char STOREUSERCODE {
    void set (unsigned char value);
}
member STOREUSERCODE : byte with set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.TOFFDELAY Property

IRD

PmbusTOFFDELAY Property

TOFF_DELAY

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TOFFDELAY { get; set; }
Public Property TOFFDELAY As UShort
    Get
    Set
public:
property unsigned short TOFFDELAY {
    unsigned short get ();
    void set (unsigned short value);
}
member TOFFDELAY : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.TOFFFALL Property

IRD

PmbusTOFFFALL Property

TOFF_FALL

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TOFFFALL { get; set; }
Public Property TOFFFALL As UShort
    Get
    Set
public:
property unsigned short TOFFFALL {
    unsigned short get ();
    void set (unsigned short value);
}
member TOFFFALL : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.TOFFMAXWARNLIMIT Property

IRD

PmbusTOFFMAXWARNLIMIT Property

TOFF_MAX_WARN_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TOFFMAXWARNLIMIT { get; set; }
Public Property TOFFMAXWARNLIMIT As UShort
    Get
    Set
public:
property unsigned short TOFFMAXWARNLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member TOFFMAXWARNLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.TONDELAY Property

IRD

PmbusTONDELAY Property

TON_DELAY

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TONDELAY { get; set; }
Public Property TONDELAY As UShort
    Get
    Set
public:
property unsigned short TONDELAY {
    unsigned short get ();
    void set (unsigned short value);
}
member TONDELAY : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.TONMAXFAULTLIMIT Property

IRD

PmbusTONMAXFAULTLIMIT Property

TON_MAX_FAULT_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TONMAXFAULTLIMIT { get; set; }
Public Property TONMAXFAULTLIMIT As UShort
    Get
    Set
public:
property unsigned short TONMAXFAULTLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member TONMAXFAULTLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.TONMAXFAULTRESPONSEDelayTime Property

IRD

PmbusTONMAXFAULTRESPONSEDelayTime Property

TON_MAX_FAULT_RESPONSE: Delay Time

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TONMAXFAULTRESPONSEDelayTime { get; set; }
Public Property TONMAXFAULTRESPONSEDelayTime As Byte
    Get
    Set
public:
property unsigned char TONMAXFAULTRESPONSEDelayTime {
    unsigned char get ();
    void set (unsigned char value);
}
member TONMAXFAULTRESPONSEDelayTime : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.TONMAXFAULTRESPONSEResponse Property

IRD

PmbusTONMAXFAULTRESPONSEResponse Property

TON_MAX_FAULT_RESPONSE: Response

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespVoltageTempFaultsResponse TONMAXFAULTRESPONSEResponse { get; set; }
Public Property TONMAXFAULTRESPONSEResponse As PmbusTypeRespVoltageTempFaultsResponse
    Get
    Set
public:
property PmbusTypeRespVoltageTempFaultsResponse TONMAXFAULTRESPONSEResponse {
    PmbusTypeRespVoltageTempFaultsResponse get ();
    void set (PmbusTypeRespVoltageTempFaultsResponse value);
}
member TONMAXFAULTRESPONSEResponse : PmbusTypeRespVoltageTempFaultsResponse with get, set

Property Value

Type: PmbusTypeRespVoltageTempFaultsResponse
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.TONMAXFAULTRESPONSERetrySetting Property

IRD

PmbusTONMAXFAULTRESPONSERetrySetting Property

TON_MAX_FAULT_RESPONSE: Retry Setting

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespVoltageTempFaultsRetry TONMAXFAULTRESPONSERetrySetting { get; set; }
Public Property TONMAXFAULTRESPONSERetrySetting As PmbusTypeRespVoltageTempFaultsRetry
    Get
    Set
public:
property PmbusTypeRespVoltageTempFaultsRetry TONMAXFAULTRESPONSERetrySetting {
    PmbusTypeRespVoltageTempFaultsRetry get ();
    void set (PmbusTypeRespVoltageTempFaultsRetry value);
}
member TONMAXFAULTRESPONSERetrySetting : PmbusTypeRespVoltageTempFaultsRetry with get, set

Property Value

Type: PmbusTypeRespVoltageTempFaultsRetry
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.TONRISE Property

IRD

PmbusTONRISE Property

TON_RISE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TONRISE { get; set; }
Public Property TONRISE As UShort
    Get
    Set
public:
property unsigned short TONRISE {
    unsigned short get ();
    void set (unsigned short value);
}
member TONRISE : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.USERDATA00 Property

IRD

PmbusUSERDATA00 Property

USER_DATA_00

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] USERDATA00 { get; set; }
Public Property USERDATA00 As Byte()
    Get
    Set
public:
property array<unsigned char>^ USERDATA00 {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member USERDATA00 : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.USERDATA01 Property

IRD

PmbusUSERDATA01 Property

USER_DATA_01

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] USERDATA01 { get; set; }
Public Property USERDATA01 As Byte()
    Get
    Set
public:
property array<unsigned char>^ USERDATA01 {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member USERDATA01 : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.USERDATA02 Property

IRD

PmbusUSERDATA02 Property

USER_DATA_02

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] USERDATA02 { get; set; }
Public Property USERDATA02 As Byte()
    Get
    Set
public:
property array<unsigned char>^ USERDATA02 {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member USERDATA02 : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.USERDATA03 Property

IRD

PmbusUSERDATA03 Property

USER_DATA_03

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] USERDATA03 { get; set; }
Public Property USERDATA03 As Byte()
    Get
    Set
public:
property array<unsigned char>^ USERDATA03 {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member USERDATA03 : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.USERDATA04 Property

IRD

PmbusUSERDATA04 Property

USER_DATA_04

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] USERDATA04 { get; set; }
Public Property USERDATA04 As Byte()
    Get
    Set
public:
property array<unsigned char>^ USERDATA04 {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member USERDATA04 : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.USERDATA05 Property

IRD

PmbusUSERDATA05 Property

USER_DATA_05

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] USERDATA05 { get; set; }
Public Property USERDATA05 As Byte()
    Get
    Set
public:
property array<unsigned char>^ USERDATA05 {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member USERDATA05 : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.USERDATA06 Property

IRD

PmbusUSERDATA06 Property

USER_DATA_06

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] USERDATA06 { get; set; }
Public Property USERDATA06 As Byte()
    Get
    Set
public:
property array<unsigned char>^ USERDATA06 {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member USERDATA06 : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.USERDATA07 Property

IRD

PmbusUSERDATA07 Property

USER_DATA_07

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] USERDATA07 { get; set; }
Public Property USERDATA07 As Byte()
    Get
    Set
public:
property array<unsigned char>^ USERDATA07 {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member USERDATA07 : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.USERDATA08 Property

IRD

PmbusUSERDATA08 Property

USER_DATA_08

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] USERDATA08 { get; set; }
Public Property USERDATA08 As Byte()
    Get
    Set
public:
property array<unsigned char>^ USERDATA08 {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member USERDATA08 : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.USERDATA09 Property

IRD

PmbusUSERDATA09 Property

USER_DATA_09

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] USERDATA09 { get; set; }
Public Property USERDATA09 As Byte()
    Get
    Set
public:
property array<unsigned char>^ USERDATA09 {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member USERDATA09 : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.USERDATA10 Property

IRD

PmbusUSERDATA10 Property

USER_DATA_10

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] USERDATA10 { get; set; }
Public Property USERDATA10 As Byte()
    Get
    Set
public:
property array<unsigned char>^ USERDATA10 {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member USERDATA10 : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.USERDATA11 Property

IRD

PmbusUSERDATA11 Property

USER_DATA_11

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] USERDATA11 { get; set; }
Public Property USERDATA11 As Byte()
    Get
    Set
public:
property array<unsigned char>^ USERDATA11 {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member USERDATA11 : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.USERDATA12 Property

IRD

PmbusUSERDATA12 Property

USER_DATA_12

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] USERDATA12 { get; set; }
Public Property USERDATA12 As Byte()
    Get
    Set
public:
property array<unsigned char>^ USERDATA12 {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member USERDATA12 : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.USERDATA13 Property

IRD

PmbusUSERDATA13 Property

USER_DATA_13

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] USERDATA13 { get; set; }
Public Property USERDATA13 As Byte()
    Get
    Set
public:
property array<unsigned char>^ USERDATA13 {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member USERDATA13 : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.USERDATA14 Property

IRD

PmbusUSERDATA14 Property

USER_DATA_14

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] USERDATA14 { get; set; }
Public Property USERDATA14 As Byte()
    Get
    Set
public:
property array<unsigned char>^ USERDATA14 {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member USERDATA14 : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.USERDATA15 Property

IRD

PmbusUSERDATA15 Property

USER_DATA_15

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] USERDATA15 { get; set; }
Public Property USERDATA15 As Byte()
    Get
    Set
public:
property array<unsigned char>^ USERDATA15 {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member USERDATA15 : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.UTFAULTLIMIT Property

IRD

PmbusUTFAULTLIMIT Property

UT_FAULT_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UTFAULTLIMIT { get; set; }
Public Property UTFAULTLIMIT As UShort
    Get
    Set
public:
property unsigned short UTFAULTLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member UTFAULTLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.UTFAULTRESPONSEDelayTime Property

IRD

PmbusUTFAULTRESPONSEDelayTime Property

UT_FAULT_RESPONSE: Delay Time

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte UTFAULTRESPONSEDelayTime { get; set; }
Public Property UTFAULTRESPONSEDelayTime As Byte
    Get
    Set
public:
property unsigned char UTFAULTRESPONSEDelayTime {
    unsigned char get ();
    void set (unsigned char value);
}
member UTFAULTRESPONSEDelayTime : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.UTFAULTRESPONSEResponse Property

IRD

PmbusUTFAULTRESPONSEResponse Property

UT_FAULT_RESPONSE: Response

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespVoltageTempFaultsResponse UTFAULTRESPONSEResponse { get; set; }
Public Property UTFAULTRESPONSEResponse As PmbusTypeRespVoltageTempFaultsResponse
    Get
    Set
public:
property PmbusTypeRespVoltageTempFaultsResponse UTFAULTRESPONSEResponse {
    PmbusTypeRespVoltageTempFaultsResponse get ();
    void set (PmbusTypeRespVoltageTempFaultsResponse value);
}
member UTFAULTRESPONSEResponse : PmbusTypeRespVoltageTempFaultsResponse with get, set

Property Value

Type: PmbusTypeRespVoltageTempFaultsResponse
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.UTFAULTRESPONSERetrySetting Property

IRD

PmbusUTFAULTRESPONSERetrySetting Property

UT_FAULT_RESPONSE: Retry Setting

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespVoltageTempFaultsRetry UTFAULTRESPONSERetrySetting { get; set; }
Public Property UTFAULTRESPONSERetrySetting As PmbusTypeRespVoltageTempFaultsRetry
    Get
    Set
public:
property PmbusTypeRespVoltageTempFaultsRetry UTFAULTRESPONSERetrySetting {
    PmbusTypeRespVoltageTempFaultsRetry get ();
    void set (PmbusTypeRespVoltageTempFaultsRetry value);
}
member UTFAULTRESPONSERetrySetting : PmbusTypeRespVoltageTempFaultsRetry with get, set

Property Value

Type: PmbusTypeRespVoltageTempFaultsRetry
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.UTWARNLIMIT Property

IRD

PmbusUTWARNLIMIT Property

UT_WARN_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UTWARNLIMIT { get; set; }
Public Property UTWARNLIMIT As UShort
    Get
    Set
public:
property unsigned short UTWARNLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member UTWARNLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VINOFF Property

IRD

PmbusVINOFF Property

VIN_OFF

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VINOFF { get; set; }
Public Property VINOFF As UShort
    Get
    Set
public:
property unsigned short VINOFF {
    unsigned short get ();
    void set (unsigned short value);
}
member VINOFF : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VINON Property

IRD

PmbusVINON Property

VIN_ON

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VINON { get; set; }
Public Property VINON As UShort
    Get
    Set
public:
property unsigned short VINON {
    unsigned short get ();
    void set (unsigned short value);
}
member VINON : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VINOVFAULTLIMIT Property

IRD

PmbusVINOVFAULTLIMIT Property

VIN_OV_FAULT_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VINOVFAULTLIMIT { get; set; }
Public Property VINOVFAULTLIMIT As UShort
    Get
    Set
public:
property unsigned short VINOVFAULTLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member VINOVFAULTLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VINOVFAULTRESPONSEDelayTime Property

IRD

PmbusVINOVFAULTRESPONSEDelayTime Property

VIN_OV_FAULT_RESPONSE: Delay Time

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VINOVFAULTRESPONSEDelayTime { get; set; }
Public Property VINOVFAULTRESPONSEDelayTime As Byte
    Get
    Set
public:
property unsigned char VINOVFAULTRESPONSEDelayTime {
    unsigned char get ();
    void set (unsigned char value);
}
member VINOVFAULTRESPONSEDelayTime : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VINOVFAULTRESPONSEResponse Property

IRD

PmbusVINOVFAULTRESPONSEResponse Property

VIN_OV_FAULT_RESPONSE: Response

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespVoltageTempFaultsResponse VINOVFAULTRESPONSEResponse { get; set; }
Public Property VINOVFAULTRESPONSEResponse As PmbusTypeRespVoltageTempFaultsResponse
    Get
    Set
public:
property PmbusTypeRespVoltageTempFaultsResponse VINOVFAULTRESPONSEResponse {
    PmbusTypeRespVoltageTempFaultsResponse get ();
    void set (PmbusTypeRespVoltageTempFaultsResponse value);
}
member VINOVFAULTRESPONSEResponse : PmbusTypeRespVoltageTempFaultsResponse with get, set

Property Value

Type: PmbusTypeRespVoltageTempFaultsResponse
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VINOVFAULTRESPONSERetrySetting Property

IRD

PmbusVINOVFAULTRESPONSERetrySetting Property

VIN_OV_FAULT_RESPONSE: Retry Setting

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespVoltageTempFaultsRetry VINOVFAULTRESPONSERetrySetting { get; set; }
Public Property VINOVFAULTRESPONSERetrySetting As PmbusTypeRespVoltageTempFaultsRetry
    Get
    Set
public:
property PmbusTypeRespVoltageTempFaultsRetry VINOVFAULTRESPONSERetrySetting {
    PmbusTypeRespVoltageTempFaultsRetry get ();
    void set (PmbusTypeRespVoltageTempFaultsRetry value);
}
member VINOVFAULTRESPONSERetrySetting : PmbusTypeRespVoltageTempFaultsRetry with get, set

Property Value

Type: PmbusTypeRespVoltageTempFaultsRetry
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VINOVWARNLIMIT Property

IRD

PmbusVINOVWARNLIMIT Property

VIN_OV_WARN_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VINOVWARNLIMIT { get; set; }
Public Property VINOVWARNLIMIT As UShort
    Get
    Set
public:
property unsigned short VINOVWARNLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member VINOVWARNLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VINUVFAULTLIMIT Property

IRD

PmbusVINUVFAULTLIMIT Property

VIN_UV_FAULT_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VINUVFAULTLIMIT { get; set; }
Public Property VINUVFAULTLIMIT As UShort
    Get
    Set
public:
property unsigned short VINUVFAULTLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member VINUVFAULTLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VINUVFAULTRESPONSEDelayTime Property

IRD

PmbusVINUVFAULTRESPONSEDelayTime Property

VIN_UV_FAULT_RESPONSE: Delay Time

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VINUVFAULTRESPONSEDelayTime { get; set; }
Public Property VINUVFAULTRESPONSEDelayTime As Byte
    Get
    Set
public:
property unsigned char VINUVFAULTRESPONSEDelayTime {
    unsigned char get ();
    void set (unsigned char value);
}
member VINUVFAULTRESPONSEDelayTime : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VINUVFAULTRESPONSEResponse Property

IRD

PmbusVINUVFAULTRESPONSEResponse Property

VIN_UV_FAULT_RESPONSE: Response

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespVoltageTempFaultsResponse VINUVFAULTRESPONSEResponse { get; set; }
Public Property VINUVFAULTRESPONSEResponse As PmbusTypeRespVoltageTempFaultsResponse
    Get
    Set
public:
property PmbusTypeRespVoltageTempFaultsResponse VINUVFAULTRESPONSEResponse {
    PmbusTypeRespVoltageTempFaultsResponse get ();
    void set (PmbusTypeRespVoltageTempFaultsResponse value);
}
member VINUVFAULTRESPONSEResponse : PmbusTypeRespVoltageTempFaultsResponse with get, set

Property Value

Type: PmbusTypeRespVoltageTempFaultsResponse
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VINUVFAULTRESPONSERetrySetting Property

IRD

PmbusVINUVFAULTRESPONSERetrySetting Property

VIN_UV_FAULT_RESPONSE: Retry Setting

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespVoltageTempFaultsRetry VINUVFAULTRESPONSERetrySetting { get; set; }
Public Property VINUVFAULTRESPONSERetrySetting As PmbusTypeRespVoltageTempFaultsRetry
    Get
    Set
public:
property PmbusTypeRespVoltageTempFaultsRetry VINUVFAULTRESPONSERetrySetting {
    PmbusTypeRespVoltageTempFaultsRetry get ();
    void set (PmbusTypeRespVoltageTempFaultsRetry value);
}
member VINUVFAULTRESPONSERetrySetting : PmbusTypeRespVoltageTempFaultsRetry with get, set

Property Value

Type: PmbusTypeRespVoltageTempFaultsRetry
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VINUVWARNLIMIT Property

IRD

PmbusVINUVWARNLIMIT Property

VIN_UV_WARN_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VINUVWARNLIMIT { get; set; }
Public Property VINUVWARNLIMIT As UShort
    Get
    Set
public:
property unsigned short VINUVWARNLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member VINUVWARNLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTCALOFFSET Property

IRD

PmbusVOUTCALOFFSET Property

VOUT_CAL_OFFSET

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short VOUTCALOFFSET { get; set; }
Public Property VOUTCALOFFSET As Short
    Get
    Set
public:
property short VOUTCALOFFSET {
    short get ();
    void set (short value);
}
member VOUTCALOFFSET : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTCOMMAND Property

IRD

PmbusVOUTCOMMAND Property

VOUT_COMMAND

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VOUTCOMMAND { get; set; }
Public Property VOUTCOMMAND As UShort
    Get
    Set
public:
property unsigned short VOUTCOMMAND {
    unsigned short get ();
    void set (unsigned short value);
}
member VOUTCOMMAND : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTDROOP Property

IRD

PmbusVOUTDROOP Property

VOUT_DROOP

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VOUTDROOP { get; set; }
Public Property VOUTDROOP As UShort
    Get
    Set
public:
property unsigned short VOUTDROOP {
    unsigned short get ();
    void set (unsigned short value);
}
member VOUTDROOP : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTMARGINHIGH Property

IRD

PmbusVOUTMARGINHIGH Property

VOUT_MARGIN_HIGH

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VOUTMARGINHIGH { get; set; }
Public Property VOUTMARGINHIGH As UShort
    Get
    Set
public:
property unsigned short VOUTMARGINHIGH {
    unsigned short get ();
    void set (unsigned short value);
}
member VOUTMARGINHIGH : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTMARGINLOW Property

IRD

PmbusVOUTMARGINLOW Property

VOUT_MARGIN_LOW

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VOUTMARGINLOW { get; set; }
Public Property VOUTMARGINLOW As UShort
    Get
    Set
public:
property unsigned short VOUTMARGINLOW {
    unsigned short get ();
    void set (unsigned short value);
}
member VOUTMARGINLOW : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTMAX Property

IRD

PmbusVOUTMAX Property

VOUT_MAX

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VOUTMAX { get; set; }
Public Property VOUTMAX As UShort
    Get
    Set
public:
property unsigned short VOUTMAX {
    unsigned short get ();
    void set (unsigned short value);
}
member VOUTMAX : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTMIN Property

IRD

PmbusVOUTMIN Property

VOUT_MIN

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VOUTMIN { get; set; }
Public Property VOUTMIN As UShort
    Get
    Set
public:
property unsigned short VOUTMIN {
    unsigned short get ();
    void set (unsigned short value);
}
member VOUTMIN : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTMODEMode Property

IRD

PmbusVOUTMODEMode Property

VOUT_MODE: Mode

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeVoutModeMode VOUTMODEMode { get; set; }
Public Property VOUTMODEMode As PmbusTypeVoutModeMode
    Get
    Set
public:
property PmbusTypeVoutModeMode VOUTMODEMode {
    PmbusTypeVoutModeMode get ();
    void set (PmbusTypeVoutModeMode value);
}
member VOUTMODEMode : PmbusTypeVoutModeMode with get, set

Property Value

Type: PmbusTypeVoutModeMode
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTMODEParameter Property

IRD

PmbusVOUTMODEParameter Property

VOUT_MODE: Parameter

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VOUTMODEParameter { get; set; }
Public Property VOUTMODEParameter As Byte
    Get
    Set
public:
property unsigned char VOUTMODEParameter {
    unsigned char get ();
    void set (unsigned char value);
}
member VOUTMODEParameter : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTOVFAULTLIMIT Property

IRD

PmbusVOUTOVFAULTLIMIT Property

VOUT_OV_FAULT_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VOUTOVFAULTLIMIT { get; set; }
Public Property VOUTOVFAULTLIMIT As UShort
    Get
    Set
public:
property unsigned short VOUTOVFAULTLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member VOUTOVFAULTLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTOVFAULTRESPONSEDelayTime Property

IRD

PmbusVOUTOVFAULTRESPONSEDelayTime Property

VOUT_OV_FAULT_RESPONSE: Delay Time

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VOUTOVFAULTRESPONSEDelayTime { get; set; }
Public Property VOUTOVFAULTRESPONSEDelayTime As Byte
    Get
    Set
public:
property unsigned char VOUTOVFAULTRESPONSEDelayTime {
    unsigned char get ();
    void set (unsigned char value);
}
member VOUTOVFAULTRESPONSEDelayTime : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTOVFAULTRESPONSEResponse Property

IRD

PmbusVOUTOVFAULTRESPONSEResponse Property

VOUT_OV_FAULT_RESPONSE: Response

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespVoltageTempFaultsResponse VOUTOVFAULTRESPONSEResponse { get; set; }
Public Property VOUTOVFAULTRESPONSEResponse As PmbusTypeRespVoltageTempFaultsResponse
    Get
    Set
public:
property PmbusTypeRespVoltageTempFaultsResponse VOUTOVFAULTRESPONSEResponse {
    PmbusTypeRespVoltageTempFaultsResponse get ();
    void set (PmbusTypeRespVoltageTempFaultsResponse value);
}
member VOUTOVFAULTRESPONSEResponse : PmbusTypeRespVoltageTempFaultsResponse with get, set

Property Value

Type: PmbusTypeRespVoltageTempFaultsResponse
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTOVFAULTRESPONSERetrySetting Property

IRD

PmbusVOUTOVFAULTRESPONSERetrySetting Property

VOUT_OV_FAULT_RESPONSE: Retry Setting

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespVoltageTempFaultsRetry VOUTOVFAULTRESPONSERetrySetting { get; set; }
Public Property VOUTOVFAULTRESPONSERetrySetting As PmbusTypeRespVoltageTempFaultsRetry
    Get
    Set
public:
property PmbusTypeRespVoltageTempFaultsRetry VOUTOVFAULTRESPONSERetrySetting {
    PmbusTypeRespVoltageTempFaultsRetry get ();
    void set (PmbusTypeRespVoltageTempFaultsRetry value);
}
member VOUTOVFAULTRESPONSERetrySetting : PmbusTypeRespVoltageTempFaultsRetry with get, set

Property Value

Type: PmbusTypeRespVoltageTempFaultsRetry
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTOVWARNLIMIT Property

IRD

PmbusVOUTOVWARNLIMIT Property

VOUT_OV_WARN_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VOUTOVWARNLIMIT { get; set; }
Public Property VOUTOVWARNLIMIT As UShort
    Get
    Set
public:
property unsigned short VOUTOVWARNLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member VOUTOVWARNLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTSCALELOOP Property

IRD

PmbusVOUTSCALELOOP Property

VOUT_SCALE_LOOP

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VOUTSCALELOOP { get; set; }
Public Property VOUTSCALELOOP As UShort
    Get
    Set
public:
property unsigned short VOUTSCALELOOP {
    unsigned short get ();
    void set (unsigned short value);
}
member VOUTSCALELOOP : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTSCALEMONITOR Property

IRD

PmbusVOUTSCALEMONITOR Property

VOUT_SCALE_MONITOR

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VOUTSCALEMONITOR { get; set; }
Public Property VOUTSCALEMONITOR As UShort
    Get
    Set
public:
property unsigned short VOUTSCALEMONITOR {
    unsigned short get ();
    void set (unsigned short value);
}
member VOUTSCALEMONITOR : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTTRANSITIONRATE Property

IRD

PmbusVOUTTRANSITIONRATE Property

VOUT_TRANSITION_RATE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VOUTTRANSITIONRATE { get; set; }
Public Property VOUTTRANSITIONRATE As UShort
    Get
    Set
public:
property unsigned short VOUTTRANSITIONRATE {
    unsigned short get ();
    void set (unsigned short value);
}
member VOUTTRANSITIONRATE : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTTRIM Property

IRD

PmbusVOUTTRIM Property

VOUT_TRIM

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public short VOUTTRIM { get; set; }
Public Property VOUTTRIM As Short
    Get
    Set
public:
property short VOUTTRIM {
    short get ();
    void set (short value);
}
member VOUTTRIM : int16 with get, set

Property Value

Type: Int16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTUVFAULTLIMIT Property

IRD

PmbusVOUTUVFAULTLIMIT Property

VOUT_UV_FAULT_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VOUTUVFAULTLIMIT { get; set; }
Public Property VOUTUVFAULTLIMIT As UShort
    Get
    Set
public:
property unsigned short VOUTUVFAULTLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member VOUTUVFAULTLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTUVFAULTRESPONSEDelayTime Property

IRD

PmbusVOUTUVFAULTRESPONSEDelayTime Property

VOUT_UV_FAULT_RESPONSE: Delay Time

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte VOUTUVFAULTRESPONSEDelayTime { get; set; }
Public Property VOUTUVFAULTRESPONSEDelayTime As Byte
    Get
    Set
public:
property unsigned char VOUTUVFAULTRESPONSEDelayTime {
    unsigned char get ();
    void set (unsigned char value);
}
member VOUTUVFAULTRESPONSEDelayTime : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTUVFAULTRESPONSEResponse Property

IRD

PmbusVOUTUVFAULTRESPONSEResponse Property

VOUT_UV_FAULT_RESPONSE: Response

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespVoltageTempFaultsResponse VOUTUVFAULTRESPONSEResponse { get; set; }
Public Property VOUTUVFAULTRESPONSEResponse As PmbusTypeRespVoltageTempFaultsResponse
    Get
    Set
public:
property PmbusTypeRespVoltageTempFaultsResponse VOUTUVFAULTRESPONSEResponse {
    PmbusTypeRespVoltageTempFaultsResponse get ();
    void set (PmbusTypeRespVoltageTempFaultsResponse value);
}
member VOUTUVFAULTRESPONSEResponse : PmbusTypeRespVoltageTempFaultsResponse with get, set

Property Value

Type: PmbusTypeRespVoltageTempFaultsResponse
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTUVFAULTRESPONSERetrySetting Property

IRD

PmbusVOUTUVFAULTRESPONSERetrySetting Property

VOUT_UV_FAULT_RESPONSE: Retry Setting

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeRespVoltageTempFaultsRetry VOUTUVFAULTRESPONSERetrySetting { get; set; }
Public Property VOUTUVFAULTRESPONSERetrySetting As PmbusTypeRespVoltageTempFaultsRetry
    Get
    Set
public:
property PmbusTypeRespVoltageTempFaultsRetry VOUTUVFAULTRESPONSERetrySetting {
    PmbusTypeRespVoltageTempFaultsRetry get ();
    void set (PmbusTypeRespVoltageTempFaultsRetry value);
}
member VOUTUVFAULTRESPONSERetrySetting : PmbusTypeRespVoltageTempFaultsRetry with get, set

Property Value

Type: PmbusTypeRespVoltageTempFaultsRetry
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.VOUTUVWARNLIMIT Property

IRD

PmbusVOUTUVWARNLIMIT Property

VOUT_UV_WARN_LIMIT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort VOUTUVWARNLIMIT { get; set; }
Public Property VOUTUVWARNLIMIT As UShort
    Get
    Set
public:
property unsigned short VOUTUVWARNLIMIT {
    unsigned short get ();
    void set (unsigned short value);
}
member VOUTUVWARNLIMIT : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.WRITEPROTECT Property

IRD

PmbusWRITEPROTECT Property

WRITE_PROTECT

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public PmbusTypeWriteProtect WRITEPROTECT { get; set; }
Public Property WRITEPROTECT As PmbusTypeWriteProtect
    Get
    Set
public:
property PmbusTypeWriteProtect WRITEPROTECT {
    PmbusTypeWriteProtect get ();
    void set (PmbusTypeWriteProtect value);
}
member WRITEPROTECT : PmbusTypeWriteProtect with get, set

Property Value

Type: PmbusTypeWriteProtect
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.ZONEACTIVEACTIVEREADZONE Property

IRD

PmbusZONEACTIVEACTIVEREADZONE Property

ZONE_ACTIVE: ACTIVE READ ZONE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ZONEACTIVEACTIVEREADZONE { get; set; }
Public Property ZONEACTIVEACTIVEREADZONE As Byte
    Get
    Set
public:
property unsigned char ZONEACTIVEACTIVEREADZONE {
    unsigned char get ();
    void set (unsigned char value);
}
member ZONEACTIVEACTIVEREADZONE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.ZONEACTIVEACTIVEWRITEZONE Property

IRD

PmbusZONEACTIVEACTIVEWRITEZONE Property

ZONE_ACTIVE: ACTIVE WRITE ZONE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ZONEACTIVEACTIVEWRITEZONE { get; set; }
Public Property ZONEACTIVEACTIVEWRITEZONE As Byte
    Get
    Set
public:
property unsigned char ZONEACTIVEACTIVEWRITEZONE {
    unsigned char get ();
    void set (unsigned char value);
}
member ZONEACTIVEACTIVEWRITEZONE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.ZONECONFIGASSIGNEDREADZONE Property

IRD

PmbusZONECONFIGASSIGNEDREADZONE Property

ZONE_CONFIG: ASSIGNED READ ZONE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ZONECONFIGASSIGNEDREADZONE { get; set; }
Public Property ZONECONFIGASSIGNEDREADZONE As Byte
    Get
    Set
public:
property unsigned char ZONECONFIGASSIGNEDREADZONE {
    unsigned char get ();
    void set (unsigned char value);
}
member ZONECONFIGASSIGNEDREADZONE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.ZONECONFIGASSIGNEDWRITEZONE Property

IRD

PmbusZONECONFIGASSIGNEDWRITEZONE Property

ZONE_CONFIG: ASSIGNED WRITE ZONE

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ZONECONFIGASSIGNEDWRITEZONE { get; set; }
Public Property ZONECONFIGASSIGNEDWRITEZONE As Byte
    Get
    Set
public:
property unsigned char ZONECONFIGASSIGNEDWRITEZONE {
    unsigned char get ();
    void set (unsigned char value);
}
member ZONECONFIGASSIGNEDWRITEZONE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.ZONECONFIGPAGENUMBER Property

IRD

PmbusZONECONFIGPAGENUMBER Property

ZONE_CONFIG: PAGE NUMBER

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ZONECONFIGPAGENUMBER { get; set; }
Public Property ZONECONFIGPAGENUMBER As Byte
    Get
    Set
public:
property unsigned char ZONECONFIGPAGENUMBER {
    unsigned char get ();
    void set (unsigned char value);
}
member ZONECONFIGPAGENUMBER : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus Methods

The Pmbus type exposes the following members.

Methods
 | Name | Description
Public method | CLEARFAULTS | CLEAR_FAULTS
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RESTOREDEFAULTALL | RESTORE_DEFAULT_ALL
Public method | RESTOREUSERALL | RESTORE_USER_ALL
Public method | STOREDEFAULTALL | STORE_DEFAULT_ALL
Public method | STOREUSERALL | STORE_USER_ALL
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.CLEARFAULTS Method

IRD

PmbusCLEARFAULTS Method

CLEAR_FAULTS

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void CLEARFAULTS()
Public Sub CLEARFAULTS
public:
void CLEARFAULTS()
member CLEARFAULTS : unit -> unit
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.Flush Method

IRD

PmbusFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.RESTOREDEFAULTALL Method

IRD

PmbusRESTOREDEFAULTALL Method

RESTORE_DEFAULT_ALL

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void RESTOREDEFAULTALL()
Public Sub RESTOREDEFAULTALL
public:
void RESTOREDEFAULTALL()
member RESTOREDEFAULTALL : unit -> unit
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.RESTOREUSERALL Method

IRD

PmbusRESTOREUSERALL Method

RESTORE_USER_ALL

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void RESTOREUSERALL()
Public Sub RESTOREUSERALL
public:
void RESTOREUSERALL()
member RESTOREUSERALL : unit -> unit
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STOREDEFAULTALL Method

IRD

PmbusSTOREDEFAULTALL Method

STORE_DEFAULT_ALL

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void STOREDEFAULTALL()
Public Sub STOREDEFAULTALL
public:
void STOREDEFAULTALL()
member STOREDEFAULTALL : unit -> unit
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.STOREUSERALL Method

IRD

PmbusSTOREUSERALL Method

STORE_USER_ALL

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void STOREUSERALL()
Public Sub STOREUSERALL
public:
void STOREUSERALL()
member STOREUSERALL : unit -> unit
See Also

Reference

Pmbus Class
telos.Ird.SMIForum Namespace


Pmbus.TypeAppProfileSupportProfile Enumeration

IRD

PmbusTypeAppProfileSupportProfile Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAppProfileSupportProfile
Public Enumeration TypeAppProfileSupportProfile
public enum class TypeAppProfileSupportProfile
type TypeAppProfileSupportProfile
Members
Member name | Value | Description
NoApplicationProfilesSupported | 0 | No Application Profiles Supported
ServerACDCPowerSupply | 1 | Server AC-DC Power Supply
DCDCConvertersForMicroprocessorPower | 2 | DC-DC Converters For Microprocessor Power
DCDCConvertersForGeneralPurposeUse | 3 | DC-DC Converters For General Purpose Use
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeBool Enumeration

IRD

PmbusTypeBool Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBool
Public Enumeration TypeBool
public enum class TypeBool
type TypeBool
Members
Member name | Value | Description
True | 1 | True
False | 0 | False
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeCapabilityAvsbus Enumeration

IRD

PmbusTypeCapabilityAvsbus Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityAvsbus
Public Enumeration TypeCapabilityAvsbus
public enum class TypeCapabilityAvsbus
type TypeCapabilityAvsbus
Members
Member name | Value | Description
AVSBusNotSupported | 0 | AVSBus: Not Supported
AVSBusSupported | 1 | AVSBus: Supported
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeCapabilityMaxSpeed Enumeration

IRD

PmbusTypeCapabilityMaxSpeed Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityMaxSpeed
Public Enumeration TypeCapabilityMaxSpeed
public enum class TypeCapabilityMaxSpeed
type TypeCapabilityMaxSpeed
Members
Member name | Value | Description
Value_100KHz | 0 | 100 kHz
Value_400KHz | 1 | 400 kHz
Value_1MHz | 2 | 1 MHz
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeCapabilityNumericFormat Enumeration

IRD

PmbusTypeCapabilityNumericFormat Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityNumericFormat
Public Enumeration TypeCapabilityNumericFormat
public enum class TypeCapabilityNumericFormat
type TypeCapabilityNumericFormat
Members
Member name | Value | Description
LINEAROrDIRECT | 0 | LINEAR Or DIRECT
IEEEHalfPrecisionFloatingPoint | 1 | IEEE Half Precision Floating Point
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeCapabilityPec Enumeration

IRD

PmbusTypeCapabilityPec Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilityPec
Public Enumeration TypeCapabilityPec
public enum class TypeCapabilityPec
type TypeCapabilityPec
Members
Member name | Value | Description
NotSupported | 0 | Not Supported
Supported | 1 | Supported
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeCapabilitySmbalert Enumeration

IRD

PmbusTypeCapabilitySmbalert Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCapabilitySmbalert
Public Enumeration TypeCapabilitySmbalert
public enum class TypeCapabilitySmbalert
type TypeCapabilitySmbalert
Members
Member name | Value | Description
Supported | 0 | Supported
NotSupported | 1 | Not Supported
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeCoefficients Enumeration

IRD

PmbusTypeCoefficients Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCoefficients
Public Enumeration TypeCoefficients
public enum class TypeCoefficients
type TypeCoefficients
Members
Member name | Value | Description
Read | 0 | Read
Write | 1 | Write
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeFanConfigCommanded Enumeration

IRD

PmbusTypeFanConfigCommanded Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFanConfigCommanded
Public Enumeration TypeFanConfigCommanded
public enum class TypeFanConfigCommanded
type TypeFanConfigCommanded
Members
Member name | Value | Description
RPM | 1 | RPM
DutyCycle | 0 | Duty Cycle
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeFanConfigInstalled Enumeration

IRD

PmbusTypeFanConfigInstalled Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFanConfigInstalled
Public Enumeration TypeFanConfigInstalled
public enum class TypeFanConfigInstalled
type TypeFanConfigInstalled
Members
Member name | Value | Description
IsInstalled | 1 | Is Installed
IsNotInstalled | 0 | Is Not Installed
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeOnOffConfig0 Enumeration

IRD

PmbusTypeOnOffConfig0 Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOffConfig0
Public Enumeration TypeOnOffConfig0
public enum class TypeOnOffConfig0
type TypeOnOffConfig0
Members
Member name | Value | Description
UseTurnOffDelay | 0 | Use Turn Off Delay
TurnOffAsFastAsPossible | 1 | Turn Off As Fast As Possible
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeOnOffConfig1 Enumeration

IRD

PmbusTypeOnOffConfig1 Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOffConfig1
Public Enumeration TypeOnOffConfig1
public enum class TypeOnOffConfig1
type TypeOnOffConfig1
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeOnOffConfig2 Enumeration

IRD

PmbusTypeOnOffConfig2 Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOffConfig2
Public Enumeration TypeOnOffConfig2
public enum class TypeOnOffConfig2
type TypeOnOffConfig2
Members
Member name | Value | Description
NotUsed | 0 | Not Used
Used | 1 | Used
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeOnOffConfig3 Enumeration

IRD

PmbusTypeOnOffConfig3 Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOffConfig3
Public Enumeration TypeOnOffConfig3
public enum class TypeOnOffConfig3
type TypeOnOffConfig3
Members
Member name | Value | Description
NotUsed | 0 | Not Used
Used | 1 | Used
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeOnOffConfig4 Enumeration

IRD

PmbusTypeOnOffConfig4 Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOnOffConfig4
Public Enumeration TypeOnOffConfig4
public enum class TypeOnOffConfig4
type TypeOnOffConfig4
Members
Member name | Value | Description
Immediately | 0 | Immediately
WaitForCONTROLPinAndOPERATIONCommand | 1 | Wait For CONTROL Pin And OPERATION Command
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeOperation Enumeration

IRD

PmbusTypeOperation Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperation
Public Enumeration TypeOperation
public enum class TypeOperation
type TypeOperation
Members
Member name | Value | Description
ImmediateOff | 0 | Immediate Off
PowerDownSequencing | 32 | Power Down Sequencing
VOUTCOMMANDAVSBusTargetRailVoltageIsUpdatedUponTransfer | 64 | VOUT_COMMAND / AVSBus Target Rail Voltage is Updated Upon Transfer
VOUTMARGINLOWIgnoreFaultsWhenMargined | 74 | VOUT_MARGIN_LOW / Ignore Faults When Margined
VOUTMARGINLOWActOnFaultsWhenMargined | 76 | VOUT_MARGIN_LOW / Act On Faults When Margined
VOUTMARGINHIGHIgnoreFaultsWhenMargined | 82 | VOUT_MARGIN_HIGH / Ignore Faults When Margined
VOUTMARGINHIGHActOnFaultsWhenMargined | 84 | VOUT_MARGIN_HIGH / Act On Faults When Margined
AVSBusVOUTCOMMANDValueIsNotUpdatedUponTransfer | 88 | AVSBus / VOUT_COMMAND Value Is Not Updated Upon Transfer
AVSBusVOUTCOMMANDValueIsUpdatedUponTransfer | 89 | AVSBus / VOUT_COMMAND Value Is Updated Upon Transfer
AVSBusVOUTCOMMANDValueIsNotUpdatedUponTransfer__1 | 90 | AVSBus / VOUT_COMMAND Value Is Not Updated Upon Transfer
AVSBusVOUTCOMMANDValueIsUpdatedUponTransfer__1 | 91 | AVSBus / VOUT_COMMAND Value Is Updated Upon Transfer
AVSBusVOUTCOMMANDValueIsNotUpdatedUponTransfer__2 | 92 | AVSBus / VOUT_COMMAND Value Is Not Updated Upon Transfer
AVSBusVOUTCOMMANDValueIsUpdatedUponTransfer__2 | 93 | AVSBus / VOUT_COMMAND Value Is Updated Upon Transfer
AVSBusVOUTCOMMANDValueIsNotUpdatedUponTransfer__3 | 94 | AVSBus / VOUT_COMMAND Value Is Not Updated Upon Transfer
AVSBusVOUTCOMMANDValueIsUpdatedUponTransfer__3 | 95 | AVSBus / VOUT_COMMAND Value Is Updated Upon Transfer
VOUTCOMMANDAVSBusTargetRailVoltageIsUpdatedUponTransfer__1 | 96 | VOUT_COMMAND / AVSBus Target Rail Voltage is Updated Upon Transfer
VOUTMARGINLOWIgnoreFaultsWhenMargined__1 | 106 | VOUT_MARGIN_LOW / Ignore Faults When Margined
VOUTMARGINLOWActOnFaultsWhenMargined__1 | 108 | VOUT_MARGIN_LOW / Act On Faults When Margined
VOUTMARGINHIGHIgnoreFaultsWhenMargined__1 | 114 | VOUT_MARGIN_HIGH / Ignore Faults When Margined
VOUTMARGINHIGHActOnFaultsWhenMargined__1 | 116 | VOUT_MARGIN_HIGH / Act On Faults When Margined
AVSBusVOUTCOMMANDValueIsNotUpdatedUponTransfer__4 | 120 | AVSBus / VOUT_COMMAND Value Is Not Updated Upon Transfer
AVSBusVOUTCOMMANDValueIsNotUpdatedUponTransfer__5 | 122 | AVSBus / VOUT_COMMAND Value Is Not Updated Upon Transfer
AVSBusVOUTCOMMANDValueIsNotUpdatedUponTransfer__6 | 124 | AVSBus / VOUT_COMMAND Value Is Not Updated Upon Transfer
AVSBusVOUTCOMMANDValueIsNotUpdatedUponTransfer__7 | 126 | AVSBus / VOUT_COMMAND Value Is Not Updated Upon Transfer
AVSBusVOUTCOMMANDValueIsUpdatedUponTransfer__4 | 121 | AVSBus / VOUT_COMMAND Value Is Updated Upon Transfer
AVSBusVOUTCOMMANDValueIsUpdatedUponTransfer__5 | 123 | AVSBus / VOUT_COMMAND Value Is Updated Upon Transfer
AVSBusVOUTCOMMANDValueIsUpdatedUponTransfer__6 | 125 | AVSBus / VOUT_COMMAND Value Is Updated Upon Transfer
AVSBusVOUTCOMMANDValueIsUpdatedUponTransfer__7 | 127 | AVSBus / VOUT_COMMAND Value Is Updated Upon Transfer
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypePage Enumeration

IRD

PmbusTypePage Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePage
Public Enumeration TypePage
public enum class TypePage
type TypePage
Members
Member name | Value | Description
AllOutputs | 255 | All Outputs
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypePhase Enumeration

IRD

PmbusTypePhase Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePhase
Public Enumeration TypePhase
public enum class TypePhase
type TypePhase
Members
Member name | Value | Description
AllOutputs | 255 | All Outputs
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypePmbusRevision Enumeration

IRD

PmbusTypePmbusRevision Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePmbusRevision
Public Enumeration TypePmbusRevision
public enum class TypePmbusRevision
type TypePmbusRevision
Members
Member name | Value | Description
Value_1_0 | 0 | 1.0
Value_1_1 | 1 | 1.1
Value_1_2 | 2 | 1.2
Value_1_3 | 3 | 1.3
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypePowerMode Enumeration

IRD

PmbusTypePowerMode Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerMode
Public Enumeration TypePowerMode
public enum class TypePowerMode
type TypePowerMode
Members
Member name | Value | Description
MaximumEfficiency | 0 | Maximum Efficiency
Reserved | 1 | Reserved
MaximumPower | 3 | Maximum Power
ManufacturerDefined | 4 | Manufacturer Defined
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeQueryFormat Enumeration

IRD

PmbusTypeQueryFormat Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeQueryFormat
Public Enumeration TypeQueryFormat
public enum class TypeQueryFormat
type TypeQueryFormat
Members
Member name | Value | Description
LinearDataFormat | 0 | Linear Data Format
Value_16BitSignedNumber | 1 | 16 Bit Signed Number
IEEEHalfPrecisionFloatingPointNumber | 2 | IEEE Half Precision Floating Point Number
DirectModeFormat | 3 | Direct Mode Format
Value_8BitUnsignedNumber | 4 | 8 Bit Unsigned Number
VIDModeFormat | 5 | VID Mode Format
ManufacturerSpecificFormat | 6 | Manufacturer Specific Format
NotNumeric | 7 | Not Numeric
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeQuerySupported Enumeration

IRD

PmbusTypeQuerySupported Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeQuerySupported
Public Enumeration TypeQuerySupported
public enum class TypeQuerySupported
type TypeQuerySupported
Members
Member name | Value | Description
Supported | 1 | Supported
NotSupported | 0 | Not Supported
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeQuerySupportedRead Enumeration

IRD

PmbusTypeQuerySupportedRead Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeQuerySupportedRead
Public Enumeration TypeQuerySupportedRead
public enum class TypeQuerySupportedRead
type TypeQuerySupportedRead
Members
Member name | Value | Description
SupportedForRead | 1 | Supported For Read
NotSupportedForRead | 0 | Not Supported For Read
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeQuerySupportedWrite Enumeration

IRD

PmbusTypeQuerySupportedWrite Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeQuerySupportedWrite
Public Enumeration TypeQuerySupportedWrite
public enum class TypeQuerySupportedWrite
type TypeQuerySupportedWrite
Members
Member name | Value | Description
SupportedForWrite | 1 | Supported For Write
NotSupportedForWrite | 0 | Not Supported For Write
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeReadKwhConfigFormat Enumeration

IRD

PmbusTypeReadKwhConfigFormat Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeReadKwhConfigFormat
Public Enumeration TypeReadKwhConfigFormat
public enum class TypeReadKwhConfigFormat
type TypeReadKwhConfigFormat
Members
Member name | Value | Description
Unsigned32BitInteger | 0 | Unsigned 32 Bit Integer
IEEESinglePrecision | 1 | IEEE Single Precision
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeReadKwhConfigHasBeenResetted Enumeration

IRD

PmbusTypeReadKwhConfigHasBeenResetted Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeReadKwhConfigHasBeenResetted
Public Enumeration TypeReadKwhConfigHasBeenResetted
public enum class TypeReadKwhConfigHasBeenResetted
type TypeReadKwhConfigHasBeenResetted
Members
Member name | Value | Description
ValueHasNotBeenReset | 0 | Value Has Not Been Reset
ValueHasBeenReset | 1 | Value Has Been Reset
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeReadKwhConfigResetSupported Enumeration

IRD

PmbusTypeReadKwhConfigResetSupported Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeReadKwhConfigResetSupported
Public Enumeration TypeReadKwhConfigResetSupported
public enum class TypeReadKwhConfigResetSupported
type TypeReadKwhConfigResetSupported
Members
Member name | Value | Description
NotSupported | 0 | Not Supported
Supported | 1 | Supported
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeReadKwhConfigRolledOver Enumeration

IRD

PmbusTypeReadKwhConfigRolledOver Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeReadKwhConfigRolledOver
Public Enumeration TypeReadKwhConfigRolledOver
public enum class TypeReadKwhConfigRolledOver
type TypeReadKwhConfigRolledOver
Members
Member name | Value | Description
NotRolledOver | 0 | Not Rolled Over
RolledOver | 1 | Rolled Over
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeReadKwhConfigSupported Enumeration

IRD

PmbusTypeReadKwhConfigSupported Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeReadKwhConfigSupported
Public Enumeration TypeReadKwhConfigSupported
public enum class TypeReadKwhConfigSupported
type TypeReadKwhConfigSupported
Members
Member name | Value | Description
NotSupported | 0 | Not Supported
Supported | 1 | Supported
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeReadKwhConfigUnit Enumeration

IRD

PmbusTypeReadKwhConfigUnit Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeReadKwhConfigUnit
Public Enumeration TypeReadKwhConfigUnit
public enum class TypeReadKwhConfigUnit
type TypeReadKwhConfigUnit
Members
Member name | Value | Description
MWHours | 0 | mW-Hours
WHours | 1 | W-Hours
KWHours | 2 | kW-Hours
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeReadKwhConfigVolatile Enumeration

IRD

PmbusTypeReadKwhConfigVolatile Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeReadKwhConfigVolatile
Public Enumeration TypeReadKwhConfigVolatile
public enum class TypeReadKwhConfigVolatile
type TypeReadKwhConfigVolatile
Members
Member name | Value | Description
NonVolatile | 0 | Non-Volatile
Volatile | 1 | Volatile
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeRespCurrentFaultsResponse Enumeration

IRD

PmbusTypeRespCurrentFaultsResponse Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRespCurrentFaultsResponse
Public Enumeration TypeRespCurrentFaultsResponse
public enum class TypeRespCurrentFaultsResponse
type TypeRespCurrentFaultsResponse
Members
Member name | Value | Description
OutputCurrentIOUTOCFAULTLIMITMaintained | 0 | Output Current IOUT_OC_FAULT_LIMIT Maintained
OutputCurrentIOUTOCFAULTLIMITMaintainedIfOutputVoltageAboveIOUTOCUVFAULTLIMIT | 1 | Output Current IOUT_OC_FAULT_LIMIT Maintained, If Output Voltage Above IOUT_OC_UV_FAULT_LIMIT
OutputCurrentIOUTOCFAULTLIMITMaintainedForTheDelayTime | 2 | Output Current IOUT_OC_FAULT_LIMIT Maintained For The Delay Time
ShutDown | 3 | Shut Down
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeRespCurrentFaultsRetry Enumeration

IRD

PmbusTypeRespCurrentFaultsRetry Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRespCurrentFaultsRetry
Public Enumeration TypeRespCurrentFaultsRetry
public enum class TypeRespCurrentFaultsRetry
type TypeRespCurrentFaultsRetry
Members
Member name | Value | Description
NotRestarted | 0 | Not Restarted
Restarted1Retry | 1 | Restarted (1 Retry)
Restarted2Retries | 2 | Restarted (2 Retries)
Restarted3Retries | 3 | Restarted (3 Retries)
Restarted4Retries | 4 | Restarted (4 Retries)
Restarted5Retries | 5 | Restarted (5 Retries)
Restarted6Retries | 6 | Restarted (6 Retries)
RestartedContinuously | 7 | Restarted Continuously
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeRespVoltageTempFaultsResponse Enumeration

IRD

PmbusTypeRespVoltageTempFaultsResponse Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRespVoltageTempFaultsResponse
Public Enumeration TypeRespVoltageTempFaultsResponse
public enum class TypeRespVoltageTempFaultsResponse
type TypeRespVoltageTempFaultsResponse
Members
Member name | Value | Description
OperationContinuedWithoutInterruption | 0 | Operation Continued Without Interruption
OperationContinuedForTheSpecifiedDelayTime | 1 | Operation Continued For The Specified Delay Time
ShutDown | 2 | Shut Down
OutputIsDisabledDuringFaultAfterwardsOperationContinues | 3 | Output Is Disabled During Fault, Afterwards Operation Continues
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeRespVoltageTempFaultsRetry Enumeration

IRD

PmbusTypeRespVoltageTempFaultsRetry Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRespVoltageTempFaultsRetry
Public Enumeration TypeRespVoltageTempFaultsRetry
public enum class TypeRespVoltageTempFaultsRetry
type TypeRespVoltageTempFaultsRetry
Members
Member name | Value | Description
NotRestarted | 0 | Not Restarted
Restarted1Retry | 1 | Restarted (1 Retry)
Restarted2Retries | 2 | Restarted (2 Retries)
Restarted3Retries | 3 | Restarted (3 Retries)
Restarted4Retries | 4 | Restarted (4 Retries)
Restarted5Retries | 5 | Restarted (5 Retries)
Restarted6Retries | 6 | Restarted (6 Retries)
RestartedContinuously | 7 | Restarted Continuously
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeVoutModeMode Enumeration

IRD

PmbusTypeVoutModeMode Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVoutModeMode
Public Enumeration TypeVoutModeMode
public enum class TypeVoutModeMode
type TypeVoutModeMode
Members
Member name | Value | Description
Linear | 0 | Linear
VID | 1 | VID
Direct | 2 | Direct
See Also

Reference

telos.Ird.SMIForum Namespace


Pmbus.TypeWriteProtect Enumeration

IRD

PmbusTypeWriteProtect Enumeration

Namespace: telos.Ird.SMIForum
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeWriteProtect
Public Enumeration TypeWriteProtect
public enum class TypeWriteProtect
type TypeWriteProtect
Members
Member name | Value | Description
OnlyWRITEPROTECTCommand | 128 | Only WRITE_PROTECT Command
OnlyWRITEPROTECTOPERATIONAndPAGECommands | 64 | Only WRITE_PROTECT, OPERATION and PAGE Commands
OnlyWRITEPROTECTOPERATIONPAGEONOFFCONFIGAndVOUTCOMMANDCommands | 32 | Only WRITE_PROTECT, OPERATION, PAGE, ON_OFF_CONFIG and VOUT_COMMAND Commands
AllCommands | 0 | All Commands
See Also

Reference

telos.Ird.SMIForum Namespace


telos.Ird.ST Namespace

Classes
 | Class | Description
Public class | Lis331hh | ST: LIS 331 HH
Public class | M41t62 | ST: M41T62
Public class | M41t63 | ST: M41T63
Public class | M41t64 | ST: M41T64
Public class | M41t65 | ST: M41T65
Public class | Stmpe1208s | ST: STMPE 1208S
Public class | Stmpe321 | ST: STMPE 321
Public class | Stmpe610 | ST: STMPE 610
Public class | Stmpe811 | ST: STMPE 811
Public class | Stmpe821 | ST: STMPE 821
Enumerations
 | Enumeration | Description
Public enumeration | Lis331hhCtrlReg1Dr |
Public enumeration | Lis331hhCtrlReg1Pm |
Public enumeration | Lis331hhCtrlReg2Boot |
Public enumeration | Lis331hhCtrlReg2Fds |
Public enumeration | Lis331hhCtrlReg2Hpcf |
Public enumeration | Lis331hhCtrlReg2Hpen |
Public enumeration | Lis331hhCtrlReg2Hpm |
Public enumeration | Lis331hhCtrlReg3I1Cfg |
Public enumeration | Lis331hhCtrlReg3I2Cfg |
Public enumeration | Lis331hhCtrlReg3Ihl |
Public enumeration | Lis331hhCtrlReg3Lir |
Public enumeration | Lis331hhCtrlReg3PpOd |
Public enumeration | Lis331hhCtrlReg4Bdu |
Public enumeration | Lis331hhCtrlReg4Ble |
Public enumeration | Lis331hhCtrlReg4Fs |
Public enumeration | Lis331hhCtrlReg4Sim |
Public enumeration | Lis331hhCtrlReg4Stsign |
Public enumeration | Lis331hhCtrlReg5TurnOn |
Public enumeration | Lis331hhDisabled0Enabled1 |
Public enumeration | Lis331hhIntCfgAoi6d |
Public enumeration | Lis331hhIntSrc |
Public enumeration | Lis331hhStatusRegDa |
Public enumeration | Lis331hhStatusRegOr |
Public enumeration | M41t62TypeCb |
Public enumeration | M41t62TypeRb |
Public enumeration | M41t62TypeRpt |
Public enumeration | M41t62TypeRs |
Public enumeration | M41t62TypeS |
Public enumeration | M41t63TypeCb |
Public enumeration | M41t63TypeRb |
Public enumeration | M41t63TypeRpt |
Public enumeration | M41t63TypeRs |
Public enumeration | M41t63TypeS |
Public enumeration | M41t64TypeCb |
Public enumeration | M41t64TypeRb |
Public enumeration | M41t64TypeRpt |
Public enumeration | M41t64TypeRs |
Public enumeration | M41t64TypeS |
Public enumeration | M41t65TypeCb |
Public enumeration | M41t65TypeRb |
Public enumeration | M41t65TypeRpt |
Public enumeration | M41t65TypeS |
Public enumeration | Stmpe1208sCtrl1HoldC |
Public enumeration | Stmpe1208sCtrl1Ndiv |
Public enumeration | Stmpe1208sCtrl1Pdiv |
Public enumeration | Stmpe1208sCtrl2BeepEn |
Public enumeration | Stmpe1208sCtrl2IntPol |
Public enumeration | Stmpe1208sCtrl2Regd |
Public enumeration | Stmpe1208sCtrl2Scd |
Public enumeration | Stmpe1208sEnableDisable |
Public enumeration | Stmpe1208sExtIntPol |
Public enumeration | Stmpe1208sGpioDir |
Public enumeration | Stmpe1208sStatus |
Public enumeration | Stmpe1208sTouch |
Public enumeration | Stmpe1208sUint8 |
Public enumeration | Stmpe321Enable1Disable0 |
Public enumeration | Stmpe321FeatureSelAfs |
Public enumeration | Stmpe321GpioDir |
Public enumeration | Stmpe321GpioFunct |
Public enumeration | Stmpe321IntCtrlIntEn |
Public enumeration | Stmpe321IntCtrlPolarity |
Public enumeration | Stmpe321IntCtrlType |
Public enumeration | Stmpe321SysCfg2SensorClock |
Public enumeration | Stmpe610AdcCtrl1Mod12b |
Public enumeration | Stmpe610AdcCtrl1RefSel |
Public enumeration | Stmpe610AdcCtrl1SampleTime |
Public enumeration | Stmpe610AdcCtrl2AdcFreq |
Public enumeration | Stmpe610IntCtrlGlobalInt |
Public enumeration | Stmpe610IntCtrlPolarity |
Public enumeration | Stmpe610IntCtrlType |
Public enumeration | Stmpe610TscCfgAveCtrl |
Public enumeration | Stmpe610TscCfgSettling |
Public enumeration | Stmpe610TscCfgTouchDetDelay |
Public enumeration | Stmpe610TscCtrlOpMod |
Public enumeration | Stmpe610TscCtrlSta |
Public enumeration | Stmpe610TscCtrlTrack |
Public enumeration | Stmpe610TscIDrive |
Public enumeration | Stmpe811AdcCtrl1Mod12b |
Public enumeration | Stmpe811AdcCtrl1RefSel |
Public enumeration | Stmpe811AdcCtrl1SampleTime |
Public enumeration | Stmpe811AdcCtrl2AdcFreq |
Public enumeration | Stmpe811IntCtrlGlobalInt |
Public enumeration | Stmpe811IntCtrlPolarity |
Public enumeration | Stmpe811IntCtrlType |
Public enumeration | Stmpe811TscCfgAveCtrl |
Public enumeration | Stmpe811TscCfgSettling |
Public enumeration | Stmpe811TscCfgTouchDetDelay |
Public enumeration | Stmpe811TscCtrlOpMod |
Public enumeration | Stmpe811TscCtrlSta |
Public enumeration | Stmpe811TscCtrlTrack |
Public enumeration | Stmpe811TscIDrive |
Public enumeration | Stmpe821Enable1Disable0 |
Public enumeration | Stmpe821FeatureSelAfs |
Public enumeration | Stmpe821GpioDir |
Public enumeration | Stmpe821GpioFunct |
Public enumeration | Stmpe821IntCtrlIntEn |
Public enumeration | Stmpe821IntCtrlPolarity |
Public enumeration | Stmpe821IntCtrlType |
Public enumeration | Stmpe821PwmCtrlFrameOrder |
Public enumeration | Stmpe821PwmCtrlPeriod0 |
Public enumeration | Stmpe821PwmCtrlPeriod1 |
Public enumeration | Stmpe821PwmCtrlRepetition |
Public enumeration | Stmpe821PwmOffOutput |
Public enumeration | Stmpe821PwmRampRate |
Public enumeration | Stmpe821PwmSetupBrightness |
Public enumeration | Stmpe821PwmSetupTiming |
Public enumeration | Stmpe821SysCfg2SensorClock |


Lis331hh Class

ST: LIS 331 HH
Inheritance Hierarchy
SystemObject
telos.Ird.STLis331hh

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lis331hh
Public Class Lis331hh
public ref class Lis331hh
type Lis331hh =  class end

The Lis331hh type exposes the following members.

Constructors
 | Name | Description
Public method | Lis331hh | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CTRLREG1DR | CTRL_REG1: DR
Public property | CTRLREG1PM | CTRL_REG1: PM
Public property | CTRLREG1Xen | CTRL_REG1: Xen
Public property | CTRLREG1Yen | CTRL_REG1: Yen
Public property | CTRLREG1Zen | CTRL_REG1: Zen
Public property | CTRLREG2BOOT | CTRL_REG2: BOOT
Public property | CTRLREG2FDS | CTRL_REG2: FDS
Public property | CTRLREG2HPCF | CTRL_REG2: HPCF
Public property | CTRLREG2HPen1 | CTRL_REG2: HPen1
Public property | CTRLREG2HPen2 | CTRL_REG2: HPen2
Public property | CTRLREG2HPM | CTRL_REG2: HPM
Public property | CTRLREG3I1CFG | CTRL_REG3: I1_CFG
Public property | CTRLREG3I2CFG | CTRL_REG3: I2_CFG
Public property | CTRLREG3IHL | CTRL_REG3: IHL
Public property | CTRLREG3LIR1 | CTRL_REG3: LIR1
Public property | CTRLREG3LIR2 | CTRL_REG3: LIR2
Public property | CTRLREG3PPOD | CTRL_REG3: PP_OD
Public property | CTRLREG4BDU | CTRL_REG4: BDU
Public property | CTRLREG4BLE | CTRL_REG4: BLE
Public property | CTRLREG4FS | CTRL_REG4: FS
Public property | CTRLREG4SIM | CTRL_REG4: SIM
Public property | CTRLREG4ST | CTRL_REG4: ST
Public property | CTRLREG4STsign | CTRL_REG4: STsign
Public property | CTRLREG5TurnOn | CTRL_REG5: TurnOn
Public property | INT1CFGAOI6D | INT1_CFG: AOI/6D
Public property | INT1CFGXHIE | INT1_CFG: XHIE
Public property | INT1CFGXLIE | INT1_CFG: XLIE
Public property | INT1CFGYHIE | INT1_CFG: YHIE
Public property | INT1CFGYLIE | INT1_CFG: YLIE
Public property | INT1CFGZHIE | INT1_CFG: ZHIE
Public property | INT1CFGZLIE | INT1_CFG: ZLIE
Public property | INT1DURATION | INT1_DURATION
Public property | INT1SRCIA | INT1_SRC: IA
Public property | INT1SRCXH | INT1_SRC: XH
Public property | INT1SRCXL | INT1_SRC: XL
Public property | INT1SRCYH | INT1_SRC: YH
Public property | INT1SRCYL | INT1_SRC: YL
Public property | INT1SRCZH | INT1_SRC: ZH
Public property | INT1SRCZL | INT1_SRC: ZL
Public property | INT1THS | INT1_THS
Public property | INT2CFGAOI6D | INT2_CFG: AOI/6D
Public property | INT2CFGXHIE | INT2_CFG: XHIE
Public property | INT2CFGXLIE | INT2_CFG: XLIE
Public property | INT2CFGYHIE | INT2_CFG: YHIE
Public property | INT2CFGYLIE | INT2_CFG: YLIE
Public property | INT2CFGZHIE | INT2_CFG: ZHIE
Public property | INT2CFGZLIE | INT2_CFG: ZLIE
Public property | INT2DURATION | INT2_DURATION
Public property | INT2SRCIA | INT2_SRC: IA
Public property | INT2SRCXH | INT2_SRC: XH
Public property | INT2SRCXL | INT2_SRC: XL
Public property | INT2SRCYH | INT2_SRC: YH
Public property | INT2SRCYL | INT2_SRC: YL
Public property | INT2SRCZH | INT2_SRC: ZH
Public property | INT2SRCZL | INT2_SRC: ZL
Public property | INT2THS | INT2_THS
Public property | OUTXH | OUT_X_H
Public property | OUTXL | OUT_X_L
Public property | OUTYH | OUT_Y_H
Public property | OUTYL | OUT_Y_L
Public property | OUTZH | OUT_Z_H
Public property | OUTZL | OUT_Z_L
Public property | REFERENCE | REFERENCE
Public property | STATUSREGXDA | STATUS_REG: XDA
Public property | STATUSREGXOR | STATUS_REG: XOR
Public property | STATUSREGYDA | STATUS_REG: YDA
Public property | STATUSREGYOR | STATUS_REG: YOR
Public property | STATUSREGZDA | STATUS_REG: ZDA
Public property | STATUSREGZOR | STATUS_REG: ZOR
Public property | STATUSREGZYXDA | STATUS_REG: ZYXDA
Public property | STATUSREGZYXOR | STATUS_REG: ZYXOR
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HPFILTERRESET | HP_FILTER_RESET
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
MEMS Digital Output Motion Sensor Ultra Low-Power High Full-Scale 3-Axes "Nano" Accelerometer
See Also

Reference

telos.Ird.ST Namespace


Lis331hh Constructor

Constructor

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hh(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lis331hh(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lis331hh

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh Properties

The Lis331hh type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CTRLREG1DR | CTRL_REG1: DR
Public property | CTRLREG1PM | CTRL_REG1: PM
Public property | CTRLREG1Xen | CTRL_REG1: Xen
Public property | CTRLREG1Yen | CTRL_REG1: Yen
Public property | CTRLREG1Zen | CTRL_REG1: Zen
Public property | CTRLREG2BOOT | CTRL_REG2: BOOT
Public property | CTRLREG2FDS | CTRL_REG2: FDS
Public property | CTRLREG2HPCF | CTRL_REG2: HPCF
Public property | CTRLREG2HPen1 | CTRL_REG2: HPen1
Public property | CTRLREG2HPen2 | CTRL_REG2: HPen2
Public property | CTRLREG2HPM | CTRL_REG2: HPM
Public property | CTRLREG3I1CFG | CTRL_REG3: I1_CFG
Public property | CTRLREG3I2CFG | CTRL_REG3: I2_CFG
Public property | CTRLREG3IHL | CTRL_REG3: IHL
Public property | CTRLREG3LIR1 | CTRL_REG3: LIR1
Public property | CTRLREG3LIR2 | CTRL_REG3: LIR2
Public property | CTRLREG3PPOD | CTRL_REG3: PP_OD
Public property | CTRLREG4BDU | CTRL_REG4: BDU
Public property | CTRLREG4BLE | CTRL_REG4: BLE
Public property | CTRLREG4FS | CTRL_REG4: FS
Public property | CTRLREG4SIM | CTRL_REG4: SIM
Public property | CTRLREG4ST | CTRL_REG4: ST
Public property | CTRLREG4STsign | CTRL_REG4: STsign
Public property | CTRLREG5TurnOn | CTRL_REG5: TurnOn
Public property | INT1CFGAOI6D | INT1_CFG: AOI/6D
Public property | INT1CFGXHIE | INT1_CFG: XHIE
Public property | INT1CFGXLIE | INT1_CFG: XLIE
Public property | INT1CFGYHIE | INT1_CFG: YHIE
Public property | INT1CFGYLIE | INT1_CFG: YLIE
Public property | INT1CFGZHIE | INT1_CFG: ZHIE
Public property | INT1CFGZLIE | INT1_CFG: ZLIE
Public property | INT1DURATION | INT1_DURATION
Public property | INT1SRCIA | INT1_SRC: IA
Public property | INT1SRCXH | INT1_SRC: XH
Public property | INT1SRCXL | INT1_SRC: XL
Public property | INT1SRCYH | INT1_SRC: YH
Public property | INT1SRCYL | INT1_SRC: YL
Public property | INT1SRCZH | INT1_SRC: ZH
Public property | INT1SRCZL | INT1_SRC: ZL
Public property | INT1THS | INT1_THS
Public property | INT2CFGAOI6D | INT2_CFG: AOI/6D
Public property | INT2CFGXHIE | INT2_CFG: XHIE
Public property | INT2CFGXLIE | INT2_CFG: XLIE
Public property | INT2CFGYHIE | INT2_CFG: YHIE
Public property | INT2CFGYLIE | INT2_CFG: YLIE
Public property | INT2CFGZHIE | INT2_CFG: ZHIE
Public property | INT2CFGZLIE | INT2_CFG: ZLIE
Public property | INT2DURATION | INT2_DURATION
Public property | INT2SRCIA | INT2_SRC: IA
Public property | INT2SRCXH | INT2_SRC: XH
Public property | INT2SRCXL | INT2_SRC: XL
Public property | INT2SRCYH | INT2_SRC: YH
Public property | INT2SRCYL | INT2_SRC: YL
Public property | INT2SRCZH | INT2_SRC: ZH
Public property | INT2SRCZL | INT2_SRC: ZL
Public property | INT2THS | INT2_THS
Public property | OUTXH | OUT_X_H
Public property | OUTXL | OUT_X_L
Public property | OUTYH | OUT_Y_H
Public property | OUTYL | OUT_Y_L
Public property | OUTZH | OUT_Z_H
Public property | OUTZL | OUT_Z_L
Public property | REFERENCE | REFERENCE
Public property | STATUSREGXDA | STATUS_REG: XDA
Public property | STATUSREGXOR | STATUS_REG: XOR
Public property | STATUSREGYDA | STATUS_REG: YDA
Public property | STATUSREGYOR | STATUS_REG: YOR
Public property | STATUSREGZDA | STATUS_REG: ZDA
Public property | STATUSREGZOR | STATUS_REG: ZOR
Public property | STATUSREGZYXDA | STATUS_REG: ZYXDA
Public property | STATUSREGZYXOR | STATUS_REG: ZYXOR
Top
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.AutoFlush Property

IRD

Lis331hhAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG1DR Property

IRD

Lis331hhCTRLREG1DR Property

CTRL_REG1: DR

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg1Dr CTRLREG1DR { get; set; }
Public Property CTRLREG1DR As Lis331hhCtrlReg1Dr
    Get
    Set
public:
property Lis331hhCtrlReg1Dr CTRLREG1DR {
    Lis331hhCtrlReg1Dr get ();
    void set (Lis331hhCtrlReg1Dr value);
}
member CTRLREG1DR : Lis331hhCtrlReg1Dr with get, set

Property Value

Type: Lis331hhCtrlReg1Dr
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG1PM Property

IRD

Lis331hhCTRLREG1PM Property

CTRL_REG1: PM

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg1Pm CTRLREG1PM { get; set; }
Public Property CTRLREG1PM As Lis331hhCtrlReg1Pm
    Get
    Set
public:
property Lis331hhCtrlReg1Pm CTRLREG1PM {
    Lis331hhCtrlReg1Pm get ();
    void set (Lis331hhCtrlReg1Pm value);
}
member CTRLREG1PM : Lis331hhCtrlReg1Pm with get, set

Property Value

Type: Lis331hhCtrlReg1Pm
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG1Xen Property

IRD

Lis331hhCTRLREG1Xen Property

CTRL_REG1: Xen

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhDisabled0Enabled1 CTRLREG1Xen { get; set; }
Public Property CTRLREG1Xen As Lis331hhDisabled0Enabled1
    Get
    Set
public:
property Lis331hhDisabled0Enabled1 CTRLREG1Xen {
    Lis331hhDisabled0Enabled1 get ();
    void set (Lis331hhDisabled0Enabled1 value);
}
member CTRLREG1Xen : Lis331hhDisabled0Enabled1 with get, set

Property Value

Type: Lis331hhDisabled0Enabled1
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG1Yen Property

IRD

Lis331hhCTRLREG1Yen Property

CTRL_REG1: Yen

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhDisabled0Enabled1 CTRLREG1Yen { get; set; }
Public Property CTRLREG1Yen As Lis331hhDisabled0Enabled1
    Get
    Set
public:
property Lis331hhDisabled0Enabled1 CTRLREG1Yen {
    Lis331hhDisabled0Enabled1 get ();
    void set (Lis331hhDisabled0Enabled1 value);
}
member CTRLREG1Yen : Lis331hhDisabled0Enabled1 with get, set

Property Value

Type: Lis331hhDisabled0Enabled1
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG1Zen Property

IRD

Lis331hhCTRLREG1Zen Property

CTRL_REG1: Zen

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhDisabled0Enabled1 CTRLREG1Zen { get; set; }
Public Property CTRLREG1Zen As Lis331hhDisabled0Enabled1
    Get
    Set
public:
property Lis331hhDisabled0Enabled1 CTRLREG1Zen {
    Lis331hhDisabled0Enabled1 get ();
    void set (Lis331hhDisabled0Enabled1 value);
}
member CTRLREG1Zen : Lis331hhDisabled0Enabled1 with get, set

Property Value

Type: Lis331hhDisabled0Enabled1
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG2BOOT Property

IRD

Lis331hhCTRLREG2BOOT Property

CTRL_REG2: BOOT

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg2Boot CTRLREG2BOOT { get; set; }
Public Property CTRLREG2BOOT As Lis331hhCtrlReg2Boot
    Get
    Set
public:
property Lis331hhCtrlReg2Boot CTRLREG2BOOT {
    Lis331hhCtrlReg2Boot get ();
    void set (Lis331hhCtrlReg2Boot value);
}
member CTRLREG2BOOT : Lis331hhCtrlReg2Boot with get, set

Property Value

Type: Lis331hhCtrlReg2Boot
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG2FDS Property

IRD

Lis331hhCTRLREG2FDS Property

CTRL_REG2: FDS

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg2Fds CTRLREG2FDS { get; set; }
Public Property CTRLREG2FDS As Lis331hhCtrlReg2Fds
    Get
    Set
public:
property Lis331hhCtrlReg2Fds CTRLREG2FDS {
    Lis331hhCtrlReg2Fds get ();
    void set (Lis331hhCtrlReg2Fds value);
}
member CTRLREG2FDS : Lis331hhCtrlReg2Fds with get, set

Property Value

Type: Lis331hhCtrlReg2Fds
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG2HPCF Property

IRD

Lis331hhCTRLREG2HPCF Property

CTRL_REG2: HPCF

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg2Hpcf CTRLREG2HPCF { get; set; }
Public Property CTRLREG2HPCF As Lis331hhCtrlReg2Hpcf
    Get
    Set
public:
property Lis331hhCtrlReg2Hpcf CTRLREG2HPCF {
    Lis331hhCtrlReg2Hpcf get ();
    void set (Lis331hhCtrlReg2Hpcf value);
}
member CTRLREG2HPCF : Lis331hhCtrlReg2Hpcf with get, set

Property Value

Type: Lis331hhCtrlReg2Hpcf
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG2HPen1 Property

IRD

Lis331hhCTRLREG2HPen1 Property

CTRL_REG2: HPen1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg2Hpen CTRLREG2HPen1 { get; set; }
Public Property CTRLREG2HPen1 As Lis331hhCtrlReg2Hpen
    Get
    Set
public:
property Lis331hhCtrlReg2Hpen CTRLREG2HPen1 {
    Lis331hhCtrlReg2Hpen get ();
    void set (Lis331hhCtrlReg2Hpen value);
}
member CTRLREG2HPen1 : Lis331hhCtrlReg2Hpen with get, set

Property Value

Type: Lis331hhCtrlReg2Hpen
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG2HPen2 Property

IRD

Lis331hhCTRLREG2HPen2 Property

CTRL_REG2: HPen2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg2Hpen CTRLREG2HPen2 { get; set; }
Public Property CTRLREG2HPen2 As Lis331hhCtrlReg2Hpen
    Get
    Set
public:
property Lis331hhCtrlReg2Hpen CTRLREG2HPen2 {
    Lis331hhCtrlReg2Hpen get ();
    void set (Lis331hhCtrlReg2Hpen value);
}
member CTRLREG2HPen2 : Lis331hhCtrlReg2Hpen with get, set

Property Value

Type: Lis331hhCtrlReg2Hpen
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG2HPM Property

IRD

Lis331hhCTRLREG2HPM Property

CTRL_REG2: HPM

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg2Hpm CTRLREG2HPM { get; set; }
Public Property CTRLREG2HPM As Lis331hhCtrlReg2Hpm
    Get
    Set
public:
property Lis331hhCtrlReg2Hpm CTRLREG2HPM {
    Lis331hhCtrlReg2Hpm get ();
    void set (Lis331hhCtrlReg2Hpm value);
}
member CTRLREG2HPM : Lis331hhCtrlReg2Hpm with get, set

Property Value

Type: Lis331hhCtrlReg2Hpm
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG3I1CFG Property

IRD

Lis331hhCTRLREG3I1CFG Property

CTRL_REG3: I1_CFG

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg3I1Cfg CTRLREG3I1CFG { get; set; }
Public Property CTRLREG3I1CFG As Lis331hhCtrlReg3I1Cfg
    Get
    Set
public:
property Lis331hhCtrlReg3I1Cfg CTRLREG3I1CFG {
    Lis331hhCtrlReg3I1Cfg get ();
    void set (Lis331hhCtrlReg3I1Cfg value);
}
member CTRLREG3I1CFG : Lis331hhCtrlReg3I1Cfg with get, set

Property Value

Type: Lis331hhCtrlReg3I1Cfg
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG3I2CFG Property

IRD

Lis331hhCTRLREG3I2CFG Property

CTRL_REG3: I2_CFG

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg3I2Cfg CTRLREG3I2CFG { get; set; }
Public Property CTRLREG3I2CFG As Lis331hhCtrlReg3I2Cfg
    Get
    Set
public:
property Lis331hhCtrlReg3I2Cfg CTRLREG3I2CFG {
    Lis331hhCtrlReg3I2Cfg get ();
    void set (Lis331hhCtrlReg3I2Cfg value);
}
member CTRLREG3I2CFG : Lis331hhCtrlReg3I2Cfg with get, set

Property Value

Type: Lis331hhCtrlReg3I2Cfg
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG3IHL Property

IRD

Lis331hhCTRLREG3IHL Property

CTRL_REG3: IHL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg3Ihl CTRLREG3IHL { get; set; }
Public Property CTRLREG3IHL As Lis331hhCtrlReg3Ihl
    Get
    Set
public:
property Lis331hhCtrlReg3Ihl CTRLREG3IHL {
    Lis331hhCtrlReg3Ihl get ();
    void set (Lis331hhCtrlReg3Ihl value);
}
member CTRLREG3IHL : Lis331hhCtrlReg3Ihl with get, set

Property Value

Type: Lis331hhCtrlReg3Ihl
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG3LIR1 Property

IRD

Lis331hhCTRLREG3LIR1 Property

CTRL_REG3: LIR1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg3Lir CTRLREG3LIR1 { get; set; }
Public Property CTRLREG3LIR1 As Lis331hhCtrlReg3Lir
    Get
    Set
public:
property Lis331hhCtrlReg3Lir CTRLREG3LIR1 {
    Lis331hhCtrlReg3Lir get ();
    void set (Lis331hhCtrlReg3Lir value);
}
member CTRLREG3LIR1 : Lis331hhCtrlReg3Lir with get, set

Property Value

Type: Lis331hhCtrlReg3Lir
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG3LIR2 Property

IRD

Lis331hhCTRLREG3LIR2 Property

CTRL_REG3: LIR2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg3Lir CTRLREG3LIR2 { get; set; }
Public Property CTRLREG3LIR2 As Lis331hhCtrlReg3Lir
    Get
    Set
public:
property Lis331hhCtrlReg3Lir CTRLREG3LIR2 {
    Lis331hhCtrlReg3Lir get ();
    void set (Lis331hhCtrlReg3Lir value);
}
member CTRLREG3LIR2 : Lis331hhCtrlReg3Lir with get, set

Property Value

Type: Lis331hhCtrlReg3Lir
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG3PPOD Property

IRD

Lis331hhCTRLREG3PPOD Property

CTRL_REG3: PP_OD

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg3PpOd CTRLREG3PPOD { get; set; }
Public Property CTRLREG3PPOD As Lis331hhCtrlReg3PpOd
    Get
    Set
public:
property Lis331hhCtrlReg3PpOd CTRLREG3PPOD {
    Lis331hhCtrlReg3PpOd get ();
    void set (Lis331hhCtrlReg3PpOd value);
}
member CTRLREG3PPOD : Lis331hhCtrlReg3PpOd with get, set

Property Value

Type: Lis331hhCtrlReg3PpOd
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG4BDU Property

IRD

Lis331hhCTRLREG4BDU Property

CTRL_REG4: BDU

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg4Bdu CTRLREG4BDU { get; set; }
Public Property CTRLREG4BDU As Lis331hhCtrlReg4Bdu
    Get
    Set
public:
property Lis331hhCtrlReg4Bdu CTRLREG4BDU {
    Lis331hhCtrlReg4Bdu get ();
    void set (Lis331hhCtrlReg4Bdu value);
}
member CTRLREG4BDU : Lis331hhCtrlReg4Bdu with get, set

Property Value

Type: Lis331hhCtrlReg4Bdu
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG4BLE Property

IRD

Lis331hhCTRLREG4BLE Property

CTRL_REG4: BLE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg4Ble CTRLREG4BLE { get; set; }
Public Property CTRLREG4BLE As Lis331hhCtrlReg4Ble
    Get
    Set
public:
property Lis331hhCtrlReg4Ble CTRLREG4BLE {
    Lis331hhCtrlReg4Ble get ();
    void set (Lis331hhCtrlReg4Ble value);
}
member CTRLREG4BLE : Lis331hhCtrlReg4Ble with get, set

Property Value

Type: Lis331hhCtrlReg4Ble
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG4FS Property

IRD

Lis331hhCTRLREG4FS Property

CTRL_REG4: FS

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg4Fs CTRLREG4FS { get; set; }
Public Property CTRLREG4FS As Lis331hhCtrlReg4Fs
    Get
    Set
public:
property Lis331hhCtrlReg4Fs CTRLREG4FS {
    Lis331hhCtrlReg4Fs get ();
    void set (Lis331hhCtrlReg4Fs value);
}
member CTRLREG4FS : Lis331hhCtrlReg4Fs with get, set

Property Value

Type: Lis331hhCtrlReg4Fs
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG4SIM Property

IRD

Lis331hhCTRLREG4SIM Property

CTRL_REG4: SIM

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg4Sim CTRLREG4SIM { get; set; }
Public Property CTRLREG4SIM As Lis331hhCtrlReg4Sim
    Get
    Set
public:
property Lis331hhCtrlReg4Sim CTRLREG4SIM {
    Lis331hhCtrlReg4Sim get ();
    void set (Lis331hhCtrlReg4Sim value);
}
member CTRLREG4SIM : Lis331hhCtrlReg4Sim with get, set

Property Value

Type: Lis331hhCtrlReg4Sim
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG4ST Property

IRD

Lis331hhCTRLREG4ST Property

CTRL_REG4: ST

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhDisabled0Enabled1 CTRLREG4ST { get; set; }
Public Property CTRLREG4ST As Lis331hhDisabled0Enabled1
    Get
    Set
public:
property Lis331hhDisabled0Enabled1 CTRLREG4ST {
    Lis331hhDisabled0Enabled1 get ();
    void set (Lis331hhDisabled0Enabled1 value);
}
member CTRLREG4ST : Lis331hhDisabled0Enabled1 with get, set

Property Value

Type: Lis331hhDisabled0Enabled1
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG4STsign Property

IRD

Lis331hhCTRLREG4STsign Property

CTRL_REG4: STsign

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg4Stsign CTRLREG4STsign { get; set; }
Public Property CTRLREG4STsign As Lis331hhCtrlReg4Stsign
    Get
    Set
public:
property Lis331hhCtrlReg4Stsign CTRLREG4STsign {
    Lis331hhCtrlReg4Stsign get ();
    void set (Lis331hhCtrlReg4Stsign value);
}
member CTRLREG4STsign : Lis331hhCtrlReg4Stsign with get, set

Property Value

Type: Lis331hhCtrlReg4Stsign
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CTRLREG5TurnOn Property

IRD

Lis331hhCTRLREG5TurnOn Property

CTRL_REG5: TurnOn

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhCtrlReg5TurnOn CTRLREG5TurnOn { get; set; }
Public Property CTRLREG5TurnOn As Lis331hhCtrlReg5TurnOn
    Get
    Set
public:
property Lis331hhCtrlReg5TurnOn CTRLREG5TurnOn {
    Lis331hhCtrlReg5TurnOn get ();
    void set (Lis331hhCtrlReg5TurnOn value);
}
member CTRLREG5TurnOn : Lis331hhCtrlReg5TurnOn with get, set

Property Value

Type: Lis331hhCtrlReg5TurnOn
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT1CFGAOI6D Property

IRD

Lis331hhINT1CFGAOI6D Property

INT1_CFG: AOI/6D

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhIntCfgAoi6d INT1CFGAOI6D { get; set; }
Public Property INT1CFGAOI6D As Lis331hhIntCfgAoi6d
    Get
    Set
public:
property Lis331hhIntCfgAoi6d INT1CFGAOI6D {
    Lis331hhIntCfgAoi6d get ();
    void set (Lis331hhIntCfgAoi6d value);
}
member INT1CFGAOI6D : Lis331hhIntCfgAoi6d with get, set

Property Value

Type: Lis331hhIntCfgAoi6d
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT1CFGXHIE Property

IRD

Lis331hhINT1CFGXHIE Property

INT1_CFG: XHIE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhDisabled0Enabled1 INT1CFGXHIE { get; set; }
Public Property INT1CFGXHIE As Lis331hhDisabled0Enabled1
    Get
    Set
public:
property Lis331hhDisabled0Enabled1 INT1CFGXHIE {
    Lis331hhDisabled0Enabled1 get ();
    void set (Lis331hhDisabled0Enabled1 value);
}
member INT1CFGXHIE : Lis331hhDisabled0Enabled1 with get, set

Property Value

Type: Lis331hhDisabled0Enabled1
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT1CFGXLIE Property

IRD

Lis331hhINT1CFGXLIE Property

INT1_CFG: XLIE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhDisabled0Enabled1 INT1CFGXLIE { get; set; }
Public Property INT1CFGXLIE As Lis331hhDisabled0Enabled1
    Get
    Set
public:
property Lis331hhDisabled0Enabled1 INT1CFGXLIE {
    Lis331hhDisabled0Enabled1 get ();
    void set (Lis331hhDisabled0Enabled1 value);
}
member INT1CFGXLIE : Lis331hhDisabled0Enabled1 with get, set

Property Value

Type: Lis331hhDisabled0Enabled1
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT1CFGYHIE Property

IRD

Lis331hhINT1CFGYHIE Property

INT1_CFG: YHIE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhDisabled0Enabled1 INT1CFGYHIE { get; set; }
Public Property INT1CFGYHIE As Lis331hhDisabled0Enabled1
    Get
    Set
public:
property Lis331hhDisabled0Enabled1 INT1CFGYHIE {
    Lis331hhDisabled0Enabled1 get ();
    void set (Lis331hhDisabled0Enabled1 value);
}
member INT1CFGYHIE : Lis331hhDisabled0Enabled1 with get, set

Property Value

Type: Lis331hhDisabled0Enabled1
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT1CFGYLIE Property

IRD

Lis331hhINT1CFGYLIE Property

INT1_CFG: YLIE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhDisabled0Enabled1 INT1CFGYLIE { get; set; }
Public Property INT1CFGYLIE As Lis331hhDisabled0Enabled1
    Get
    Set
public:
property Lis331hhDisabled0Enabled1 INT1CFGYLIE {
    Lis331hhDisabled0Enabled1 get ();
    void set (Lis331hhDisabled0Enabled1 value);
}
member INT1CFGYLIE : Lis331hhDisabled0Enabled1 with get, set

Property Value

Type: Lis331hhDisabled0Enabled1
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT1CFGZHIE Property

IRD

Lis331hhINT1CFGZHIE Property

INT1_CFG: ZHIE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhDisabled0Enabled1 INT1CFGZHIE { get; set; }
Public Property INT1CFGZHIE As Lis331hhDisabled0Enabled1
    Get
    Set
public:
property Lis331hhDisabled0Enabled1 INT1CFGZHIE {
    Lis331hhDisabled0Enabled1 get ();
    void set (Lis331hhDisabled0Enabled1 value);
}
member INT1CFGZHIE : Lis331hhDisabled0Enabled1 with get, set

Property Value

Type: Lis331hhDisabled0Enabled1
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT1CFGZLIE Property

IRD

Lis331hhINT1CFGZLIE Property

INT1_CFG: ZLIE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhDisabled0Enabled1 INT1CFGZLIE { get; set; }
Public Property INT1CFGZLIE As Lis331hhDisabled0Enabled1
    Get
    Set
public:
property Lis331hhDisabled0Enabled1 INT1CFGZLIE {
    Lis331hhDisabled0Enabled1 get ();
    void set (Lis331hhDisabled0Enabled1 value);
}
member INT1CFGZLIE : Lis331hhDisabled0Enabled1 with get, set

Property Value

Type: Lis331hhDisabled0Enabled1
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT1DURATION Property

IRD

Lis331hhINT1DURATION Property

INT1_DURATION

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INT1DURATION { get; set; }
Public Property INT1DURATION As Byte
    Get
    Set
public:
property unsigned char INT1DURATION {
    unsigned char get ();
    void set (unsigned char value);
}
member INT1DURATION : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT1SRCIA Property

IRD

Lis331hhINT1SRCIA Property

INT1_SRC: IA

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhIntSrc INT1SRCIA { get; }
Public ReadOnly Property INT1SRCIA As Lis331hhIntSrc
    Get
public:
property Lis331hhIntSrc INT1SRCIA {
    Lis331hhIntSrc get ();
}
member INT1SRCIA : Lis331hhIntSrc with get

Property Value

Type: Lis331hhIntSrc
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT1SRCXH Property

IRD

Lis331hhINT1SRCXH Property

INT1_SRC: XH

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhIntSrc INT1SRCXH { get; }
Public ReadOnly Property INT1SRCXH As Lis331hhIntSrc
    Get
public:
property Lis331hhIntSrc INT1SRCXH {
    Lis331hhIntSrc get ();
}
member INT1SRCXH : Lis331hhIntSrc with get

Property Value

Type: Lis331hhIntSrc
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT1SRCXL Property

IRD

Lis331hhINT1SRCXL Property

INT1_SRC: XL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhIntSrc INT1SRCXL { get; }
Public ReadOnly Property INT1SRCXL As Lis331hhIntSrc
    Get
public:
property Lis331hhIntSrc INT1SRCXL {
    Lis331hhIntSrc get ();
}
member INT1SRCXL : Lis331hhIntSrc with get

Property Value

Type: Lis331hhIntSrc
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT1SRCYH Property

IRD

Lis331hhINT1SRCYH Property

INT1_SRC: YH

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhIntSrc INT1SRCYH { get; }
Public ReadOnly Property INT1SRCYH As Lis331hhIntSrc
    Get
public:
property Lis331hhIntSrc INT1SRCYH {
    Lis331hhIntSrc get ();
}
member INT1SRCYH : Lis331hhIntSrc with get

Property Value

Type: Lis331hhIntSrc
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT1SRCYL Property

IRD

Lis331hhINT1SRCYL Property

INT1_SRC: YL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhIntSrc INT1SRCYL { get; }
Public ReadOnly Property INT1SRCYL As Lis331hhIntSrc
    Get
public:
property Lis331hhIntSrc INT1SRCYL {
    Lis331hhIntSrc get ();
}
member INT1SRCYL : Lis331hhIntSrc with get

Property Value

Type: Lis331hhIntSrc
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT1SRCZH Property

IRD

Lis331hhINT1SRCZH Property

INT1_SRC: ZH

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhIntSrc INT1SRCZH { get; }
Public ReadOnly Property INT1SRCZH As Lis331hhIntSrc
    Get
public:
property Lis331hhIntSrc INT1SRCZH {
    Lis331hhIntSrc get ();
}
member INT1SRCZH : Lis331hhIntSrc with get

Property Value

Type: Lis331hhIntSrc
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT1SRCZL Property

IRD

Lis331hhINT1SRCZL Property

INT1_SRC: ZL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhIntSrc INT1SRCZL { get; }
Public ReadOnly Property INT1SRCZL As Lis331hhIntSrc
    Get
public:
property Lis331hhIntSrc INT1SRCZL {
    Lis331hhIntSrc get ();
}
member INT1SRCZL : Lis331hhIntSrc with get

Property Value

Type: Lis331hhIntSrc
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT1THS Property

IRD

Lis331hhINT1THS Property

INT1_THS

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INT1THS { get; set; }
Public Property INT1THS As Byte
    Get
    Set
public:
property unsigned char INT1THS {
    unsigned char get ();
    void set (unsigned char value);
}
member INT1THS : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT2CFGAOI6D Property

IRD

Lis331hhINT2CFGAOI6D Property

INT2_CFG: AOI/6D

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhIntCfgAoi6d INT2CFGAOI6D { get; set; }
Public Property INT2CFGAOI6D As Lis331hhIntCfgAoi6d
    Get
    Set
public:
property Lis331hhIntCfgAoi6d INT2CFGAOI6D {
    Lis331hhIntCfgAoi6d get ();
    void set (Lis331hhIntCfgAoi6d value);
}
member INT2CFGAOI6D : Lis331hhIntCfgAoi6d with get, set

Property Value

Type: Lis331hhIntCfgAoi6d
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT2CFGXHIE Property

IRD

Lis331hhINT2CFGXHIE Property

INT2_CFG: XHIE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhDisabled0Enabled1 INT2CFGXHIE { get; set; }
Public Property INT2CFGXHIE As Lis331hhDisabled0Enabled1
    Get
    Set
public:
property Lis331hhDisabled0Enabled1 INT2CFGXHIE {
    Lis331hhDisabled0Enabled1 get ();
    void set (Lis331hhDisabled0Enabled1 value);
}
member INT2CFGXHIE : Lis331hhDisabled0Enabled1 with get, set

Property Value

Type: Lis331hhDisabled0Enabled1
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT2CFGXLIE Property

IRD

Lis331hhINT2CFGXLIE Property

INT2_CFG: XLIE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhDisabled0Enabled1 INT2CFGXLIE { get; set; }
Public Property INT2CFGXLIE As Lis331hhDisabled0Enabled1
    Get
    Set
public:
property Lis331hhDisabled0Enabled1 INT2CFGXLIE {
    Lis331hhDisabled0Enabled1 get ();
    void set (Lis331hhDisabled0Enabled1 value);
}
member INT2CFGXLIE : Lis331hhDisabled0Enabled1 with get, set

Property Value

Type: Lis331hhDisabled0Enabled1
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT2CFGYHIE Property

IRD

Lis331hhINT2CFGYHIE Property

INT2_CFG: YHIE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhDisabled0Enabled1 INT2CFGYHIE { get; set; }
Public Property INT2CFGYHIE As Lis331hhDisabled0Enabled1
    Get
    Set
public:
property Lis331hhDisabled0Enabled1 INT2CFGYHIE {
    Lis331hhDisabled0Enabled1 get ();
    void set (Lis331hhDisabled0Enabled1 value);
}
member INT2CFGYHIE : Lis331hhDisabled0Enabled1 with get, set

Property Value

Type: Lis331hhDisabled0Enabled1
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT2CFGYLIE Property

IRD

Lis331hhINT2CFGYLIE Property

INT2_CFG: YLIE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhDisabled0Enabled1 INT2CFGYLIE { get; set; }
Public Property INT2CFGYLIE As Lis331hhDisabled0Enabled1
    Get
    Set
public:
property Lis331hhDisabled0Enabled1 INT2CFGYLIE {
    Lis331hhDisabled0Enabled1 get ();
    void set (Lis331hhDisabled0Enabled1 value);
}
member INT2CFGYLIE : Lis331hhDisabled0Enabled1 with get, set

Property Value

Type: Lis331hhDisabled0Enabled1
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT2CFGZHIE Property

IRD

Lis331hhINT2CFGZHIE Property

INT2_CFG: ZHIE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhDisabled0Enabled1 INT2CFGZHIE { get; set; }
Public Property INT2CFGZHIE As Lis331hhDisabled0Enabled1
    Get
    Set
public:
property Lis331hhDisabled0Enabled1 INT2CFGZHIE {
    Lis331hhDisabled0Enabled1 get ();
    void set (Lis331hhDisabled0Enabled1 value);
}
member INT2CFGZHIE : Lis331hhDisabled0Enabled1 with get, set

Property Value

Type: Lis331hhDisabled0Enabled1
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT2CFGZLIE Property

IRD

Lis331hhINT2CFGZLIE Property

INT2_CFG: ZLIE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhDisabled0Enabled1 INT2CFGZLIE { get; set; }
Public Property INT2CFGZLIE As Lis331hhDisabled0Enabled1
    Get
    Set
public:
property Lis331hhDisabled0Enabled1 INT2CFGZLIE {
    Lis331hhDisabled0Enabled1 get ();
    void set (Lis331hhDisabled0Enabled1 value);
}
member INT2CFGZLIE : Lis331hhDisabled0Enabled1 with get, set

Property Value

Type: Lis331hhDisabled0Enabled1
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT2DURATION Property

IRD

Lis331hhINT2DURATION Property

INT2_DURATION

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INT2DURATION { get; set; }
Public Property INT2DURATION As Byte
    Get
    Set
public:
property unsigned char INT2DURATION {
    unsigned char get ();
    void set (unsigned char value);
}
member INT2DURATION : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT2SRCIA Property

IRD

Lis331hhINT2SRCIA Property

INT2_SRC: IA

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhIntSrc INT2SRCIA { get; }
Public ReadOnly Property INT2SRCIA As Lis331hhIntSrc
    Get
public:
property Lis331hhIntSrc INT2SRCIA {
    Lis331hhIntSrc get ();
}
member INT2SRCIA : Lis331hhIntSrc with get

Property Value

Type: Lis331hhIntSrc
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT2SRCXH Property

IRD

Lis331hhINT2SRCXH Property

INT2_SRC: XH

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhIntSrc INT2SRCXH { get; }
Public ReadOnly Property INT2SRCXH As Lis331hhIntSrc
    Get
public:
property Lis331hhIntSrc INT2SRCXH {
    Lis331hhIntSrc get ();
}
member INT2SRCXH : Lis331hhIntSrc with get

Property Value

Type: Lis331hhIntSrc
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT2SRCXL Property

IRD

Lis331hhINT2SRCXL Property

INT2_SRC: XL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhIntSrc INT2SRCXL { get; }
Public ReadOnly Property INT2SRCXL As Lis331hhIntSrc
    Get
public:
property Lis331hhIntSrc INT2SRCXL {
    Lis331hhIntSrc get ();
}
member INT2SRCXL : Lis331hhIntSrc with get

Property Value

Type: Lis331hhIntSrc
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT2SRCYH Property

IRD

Lis331hhINT2SRCYH Property

INT2_SRC: YH

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhIntSrc INT2SRCYH { get; }
Public ReadOnly Property INT2SRCYH As Lis331hhIntSrc
    Get
public:
property Lis331hhIntSrc INT2SRCYH {
    Lis331hhIntSrc get ();
}
member INT2SRCYH : Lis331hhIntSrc with get

Property Value

Type: Lis331hhIntSrc
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT2SRCYL Property

IRD

Lis331hhINT2SRCYL Property

INT2_SRC: YL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhIntSrc INT2SRCYL { get; }
Public ReadOnly Property INT2SRCYL As Lis331hhIntSrc
    Get
public:
property Lis331hhIntSrc INT2SRCYL {
    Lis331hhIntSrc get ();
}
member INT2SRCYL : Lis331hhIntSrc with get

Property Value

Type: Lis331hhIntSrc
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT2SRCZH Property

IRD

Lis331hhINT2SRCZH Property

INT2_SRC: ZH

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhIntSrc INT2SRCZH { get; }
Public ReadOnly Property INT2SRCZH As Lis331hhIntSrc
    Get
public:
property Lis331hhIntSrc INT2SRCZH {
    Lis331hhIntSrc get ();
}
member INT2SRCZH : Lis331hhIntSrc with get

Property Value

Type: Lis331hhIntSrc
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT2SRCZL Property

IRD

Lis331hhINT2SRCZL Property

INT2_SRC: ZL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhIntSrc INT2SRCZL { get; }
Public ReadOnly Property INT2SRCZL As Lis331hhIntSrc
    Get
public:
property Lis331hhIntSrc INT2SRCZL {
    Lis331hhIntSrc get ();
}
member INT2SRCZL : Lis331hhIntSrc with get

Property Value

Type: Lis331hhIntSrc
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.INT2THS Property

IRD

Lis331hhINT2THS Property

INT2_THS

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INT2THS { get; set; }
Public Property INT2THS As Byte
    Get
    Set
public:
property unsigned char INT2THS {
    unsigned char get ();
    void set (unsigned char value);
}
member INT2THS : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.OUTXH Property

IRD

Lis331hhOUTXH Property

OUT_X_H

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OUTXH { get; }
Public ReadOnly Property OUTXH As Byte
    Get
public:
property unsigned char OUTXH {
    unsigned char get ();
}
member OUTXH : byte with get

Property Value

Type: Byte
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.OUTXL Property

IRD

Lis331hhOUTXL Property

OUT_X_L

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OUTXL { get; }
Public ReadOnly Property OUTXL As Byte
    Get
public:
property unsigned char OUTXL {
    unsigned char get ();
}
member OUTXL : byte with get

Property Value

Type: Byte
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.OUTYH Property

IRD

Lis331hhOUTYH Property

OUT_Y_H

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OUTYH { get; }
Public ReadOnly Property OUTYH As Byte
    Get
public:
property unsigned char OUTYH {
    unsigned char get ();
}
member OUTYH : byte with get

Property Value

Type: Byte
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.OUTYL Property

IRD

Lis331hhOUTYL Property

OUT_Y_L

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OUTYL { get; }
Public ReadOnly Property OUTYL As Byte
    Get
public:
property unsigned char OUTYL {
    unsigned char get ();
}
member OUTYL : byte with get

Property Value

Type: Byte
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.OUTZH Property

IRD

Lis331hhOUTZH Property

OUT_Z_H

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OUTZH { get; }
Public ReadOnly Property OUTZH As Byte
    Get
public:
property unsigned char OUTZH {
    unsigned char get ();
}
member OUTZH : byte with get

Property Value

Type: Byte
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.OUTZL Property

IRD

Lis331hhOUTZL Property

OUT_Z_L

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OUTZL { get; }
Public ReadOnly Property OUTZL As Byte
    Get
public:
property unsigned char OUTZL {
    unsigned char get ();
}
member OUTZL : byte with get

Property Value

Type: Byte
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.REFERENCE Property

IRD

Lis331hhREFERENCE Property

REFERENCE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte REFERENCE { get; set; }
Public Property REFERENCE As Byte
    Get
    Set
public:
property unsigned char REFERENCE {
    unsigned char get ();
    void set (unsigned char value);
}
member REFERENCE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.STATUSREGXDA Property

IRD

Lis331hhSTATUSREGXDA Property

STATUS_REG: XDA

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhStatusRegDa STATUSREGXDA { get; }
Public ReadOnly Property STATUSREGXDA As Lis331hhStatusRegDa
    Get
public:
property Lis331hhStatusRegDa STATUSREGXDA {
    Lis331hhStatusRegDa get ();
}
member STATUSREGXDA : Lis331hhStatusRegDa with get

Property Value

Type: Lis331hhStatusRegDa
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.STATUSREGXOR Property

IRD

Lis331hhSTATUSREGXOR Property

STATUS_REG: XOR

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhStatusRegOr STATUSREGXOR { get; }
Public ReadOnly Property STATUSREGXOR As Lis331hhStatusRegOr
    Get
public:
property Lis331hhStatusRegOr STATUSREGXOR {
    Lis331hhStatusRegOr get ();
}
member STATUSREGXOR : Lis331hhStatusRegOr with get

Property Value

Type: Lis331hhStatusRegOr
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.STATUSREGYDA Property

IRD

Lis331hhSTATUSREGYDA Property

STATUS_REG: YDA

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhStatusRegDa STATUSREGYDA { get; }
Public ReadOnly Property STATUSREGYDA As Lis331hhStatusRegDa
    Get
public:
property Lis331hhStatusRegDa STATUSREGYDA {
    Lis331hhStatusRegDa get ();
}
member STATUSREGYDA : Lis331hhStatusRegDa with get

Property Value

Type: Lis331hhStatusRegDa
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.STATUSREGYOR Property

IRD

Lis331hhSTATUSREGYOR Property

STATUS_REG: YOR

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhStatusRegOr STATUSREGYOR { get; }
Public ReadOnly Property STATUSREGYOR As Lis331hhStatusRegOr
    Get
public:
property Lis331hhStatusRegOr STATUSREGYOR {
    Lis331hhStatusRegOr get ();
}
member STATUSREGYOR : Lis331hhStatusRegOr with get

Property Value

Type: Lis331hhStatusRegOr
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.STATUSREGZDA Property

IRD

Lis331hhSTATUSREGZDA Property

STATUS_REG: ZDA

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhStatusRegDa STATUSREGZDA { get; }
Public ReadOnly Property STATUSREGZDA As Lis331hhStatusRegDa
    Get
public:
property Lis331hhStatusRegDa STATUSREGZDA {
    Lis331hhStatusRegDa get ();
}
member STATUSREGZDA : Lis331hhStatusRegDa with get

Property Value

Type: Lis331hhStatusRegDa
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.STATUSREGZOR Property

IRD

Lis331hhSTATUSREGZOR Property

STATUS_REG: ZOR

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhStatusRegOr STATUSREGZOR { get; }
Public ReadOnly Property STATUSREGZOR As Lis331hhStatusRegOr
    Get
public:
property Lis331hhStatusRegOr STATUSREGZOR {
    Lis331hhStatusRegOr get ();
}
member STATUSREGZOR : Lis331hhStatusRegOr with get

Property Value

Type: Lis331hhStatusRegOr
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.STATUSREGZYXDA Property

IRD

Lis331hhSTATUSREGZYXDA Property

STATUS_REG: ZYXDA

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhStatusRegDa STATUSREGZYXDA { get; }
Public ReadOnly Property STATUSREGZYXDA As Lis331hhStatusRegDa
    Get
public:
property Lis331hhStatusRegDa STATUSREGZYXDA {
    Lis331hhStatusRegDa get ();
}
member STATUSREGZYXDA : Lis331hhStatusRegDa with get

Property Value

Type: Lis331hhStatusRegDa
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.STATUSREGZYXOR Property

IRD

Lis331hhSTATUSREGZYXOR Property

STATUS_REG: ZYXOR

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lis331hhStatusRegOr STATUSREGZYXOR { get; }
Public ReadOnly Property STATUSREGZYXOR As Lis331hhStatusRegOr
    Get
public:
property Lis331hhStatusRegOr STATUSREGZYXOR {
    Lis331hhStatusRegOr get ();
}
member STATUSREGZYXOR : Lis331hhStatusRegOr with get

Property Value

Type: Lis331hhStatusRegOr
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh Methods

The Lis331hh type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HPFILTERRESET | HP_FILTER_RESET
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.Flush Method

IRD

Lis331hhFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.HPFILTERRESET Method

IRD

Lis331hhHPFILTERRESET Method

HP_FILTER_RESET

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void HPFILTERRESET()
Public Sub HPFILTERRESET
public:
void HPFILTERRESET()
member HPFILTERRESET : unit -> unit
See Also

Reference

Lis331hh Class
telos.Ird.ST Namespace


Lis331hh.CtrlReg1Dr Enumeration

IRD

Lis331hhCtrlReg1Dr Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReg1Dr
Public Enumeration CtrlReg1Dr
public enum class CtrlReg1Dr
type CtrlReg1Dr
Members
Member name | Value | Description
ODR50 | 0 | ODR=50
ODR100 | 1 | ODR=100
ODR400 | 2 | ODR=400
ODR1000 | 3 | ODR=1000
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.CtrlReg1Pm Enumeration

IRD

Lis331hhCtrlReg1Pm Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReg1Pm
Public Enumeration CtrlReg1Pm
public enum class CtrlReg1Pm
type CtrlReg1Pm
Members
Member name | Value | Description
PowerDown | 0 | Power-Down
NormalModeODR | 1 | Normal Mode (ODR)
LowPower05 | 2 | Low-Power (0.5)
LowPower1 | 3 | Low-Power (1)
LowPower2 | 4 | Low-Power (2)
LowPower5 | 5 | Low-Power (5)
LowPower10 | 6 | Low-Power (10)
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.CtrlReg2Boot Enumeration

IRD

Lis331hhCtrlReg2Boot Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReg2Boot
Public Enumeration CtrlReg2Boot
public enum class CtrlReg2Boot
type CtrlReg2Boot
Members
Member name | Value | Description
NormalMode | 0 | Normal Mode
RebootMemoryContent | 1 | Reboot Memory Content
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.CtrlReg2Fds Enumeration

IRD

Lis331hhCtrlReg2Fds Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReg2Fds
Public Enumeration CtrlReg2Fds
public enum class CtrlReg2Fds
type CtrlReg2Fds
Members
Member name | Value | Description
InternalFilterBypassed | 0 | Internal Filter Bypassed
DataFromInternalFilterSentToOutputRegister | 1 | Data From Internal Filter Sent To Output Register
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.CtrlReg2Hpcf Enumeration

IRD

Lis331hhCtrlReg2Hpcf Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReg2Hpcf
Public Enumeration CtrlReg2Hpcf
public enum class CtrlReg2Hpcf
type CtrlReg2Hpcf
Members
Member name | Value | Description
Value_8 | 0 | 8
Value_16 | 1 | 16
Value_32 | 2 | 32
Value_64 | 3 | 64
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.CtrlReg2Hpen Enumeration

IRD

Lis331hhCtrlReg2Hpen Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReg2Hpen
Public Enumeration CtrlReg2Hpen
public enum class CtrlReg2Hpen
type CtrlReg2Hpen
Members
Member name | Value | Description
FilterBypassed | 0 | Filter Bypassed
FilterEnabled | 1 | Filter Enabled
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.CtrlReg2Hpm Enumeration

IRD

Lis331hhCtrlReg2Hpm Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReg2Hpm
Public Enumeration CtrlReg2Hpm
public enum class CtrlReg2Hpm
type CtrlReg2Hpm
Members
Member name | Value | Description
NormalMode | 0 | Normal Mode
ReferenceSignalForFiltering | 1 | Reference Signal For Filtering
NormalMode__1 | 2 | Normal Mode
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.CtrlReg3I1Cfg Enumeration

IRD

Lis331hhCtrlReg3I1Cfg Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReg3I1Cfg
Public Enumeration CtrlReg3I1Cfg
public enum class CtrlReg3I1Cfg
type CtrlReg3I1Cfg
Members
Member name | Value | Description
Interrupt1Source | 0 | Interrupt 1 Source
Interrupt1SourceORInterrupt2Source | 1 | Interrupt 1 Source OR Interrupt 2 Source
DataReady | 2 | Data Ready
BootRunning | 3 | Boot Running
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.CtrlReg3I2Cfg Enumeration

IRD

Lis331hhCtrlReg3I2Cfg Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReg3I2Cfg
Public Enumeration CtrlReg3I2Cfg
public enum class CtrlReg3I2Cfg
type CtrlReg3I2Cfg
Members
Member name | Value | Description
Interrupt2Source | 0 | Interrupt 2 Source
Interrupt1SourceORInterrupt2Source | 1 | Interrupt 1 Source OR Interrupt 2 Source
DataReady | 2 | Data Ready
BootRunning | 3 | Boot Running
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.CtrlReg3Ihl Enumeration

IRD

Lis331hhCtrlReg3Ihl Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReg3Ihl
Public Enumeration CtrlReg3Ihl
public enum class CtrlReg3Ihl
type CtrlReg3Ihl
Members
Member name | Value | Description
ActiveHigh | 0 | Active High
ActiveLow | 1 | Active Low
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.CtrlReg3Lir Enumeration

IRD

Lis331hhCtrlReg3Lir Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReg3Lir
Public Enumeration CtrlReg3Lir
public enum class CtrlReg3Lir
type CtrlReg3Lir
Members
Member name | Value | Description
NotLatched | 0 | Not Latched
Latched | 1 | Latched
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.CtrlReg3PpOd Enumeration

IRD

Lis331hhCtrlReg3PpOd Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReg3PpOd
Public Enumeration CtrlReg3PpOd
public enum class CtrlReg3PpOd
type CtrlReg3PpOd
Members
Member name | Value | Description
PushPull | 0 | Push-Pull
OpenDrain | 1 | Open Drain
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.CtrlReg4Bdu Enumeration

IRD

Lis331hhCtrlReg4Bdu Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReg4Bdu
Public Enumeration CtrlReg4Bdu
public enum class CtrlReg4Bdu
type CtrlReg4Bdu
Members
Member name | Value | Description
ContinuosUpdate | 0 | Continuos Update
NotUpdated | 1 | Not Updated
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.CtrlReg4Ble Enumeration

IRD

Lis331hhCtrlReg4Ble Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReg4Ble
Public Enumeration CtrlReg4Ble
public enum class CtrlReg4Ble
type CtrlReg4Ble
Members
Member name | Value | Description
LSBLowerAddress | 0 | LSB @ Lower Address
MSBLowerAddress | 1 | MSB @ Lower Address
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.CtrlReg4Fs Enumeration

IRD

Lis331hhCtrlReg4Fs Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReg4Fs
Public Enumeration CtrlReg4Fs
public enum class CtrlReg4Fs
type CtrlReg4Fs
Members
Member name | Value | Description
Value_6G | 0 | ±6 g
Value_12G | 1 | ±12 g
Reserved | 2 | Reserved
Value_24G | 3 | ±24 g
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.CtrlReg4Sim Enumeration

IRD

Lis331hhCtrlReg4Sim Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReg4Sim
Public Enumeration CtrlReg4Sim
public enum class CtrlReg4Sim
type CtrlReg4Sim
Members
Member name | Value | Description
Value_4WireInterface | 0 | 4-Wire Interface
Value_3WireInterface | 1 | 3-Wire Interface
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.CtrlReg4Stsign Enumeration

IRD

Lis331hhCtrlReg4Stsign Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReg4Stsign
Public Enumeration CtrlReg4Stsign
public enum class CtrlReg4Stsign
type CtrlReg4Stsign
Members
Member name | Value | Description
SelfTestPlus | 0 | Self-Test Plus
SelfTestMinus | 1 | Self-Test Minus
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.CtrlReg5TurnOn Enumeration

IRD

Lis331hhCtrlReg5TurnOn Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReg5TurnOn
Public Enumeration CtrlReg5TurnOn
public enum class CtrlReg5TurnOn
type CtrlReg5TurnOn
Members
Member name | Value | Description
Disabled | 0 | Disabled
Reserved | 1 | Reserved
Enabled | 3 | Enabled
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.Disabled0Enabled1 Enumeration

IRD

Lis331hhDisabled0Enabled1 Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Disabled0Enabled1
Public Enumeration Disabled0Enabled1
public enum class Disabled0Enabled1
type Disabled0Enabled1
Members
Member name | Value | Description
Disabled | 0 | Disabled
Enabled | 1 | Enabled
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.IntCfgAoi6d Enumeration

IRD

Lis331hhIntCfgAoi6d Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IntCfgAoi6d
Public Enumeration IntCfgAoi6d
public enum class IntCfgAoi6d
type IntCfgAoi6d
Members
Member name | Value | Description
ORCombinationOfInterruptEvents | 0 | OR Combination Of Interrupt Events
Value_6DirectionMovementRecognition | 1 | 6 Direction Movement Recognition
ANDCombinationOfInterruptEvents | 2 | AND Combination Of Interrupt Events
Value_6DirectionPositionRecognition | 3 | 6 Direction Position Recognition
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.IntSrc Enumeration

IRD

Lis331hhIntSrc Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IntSrc
Public Enumeration IntSrc
public enum class IntSrc
type IntSrc
Members
Member name | Value | Description
NoInterrupt | 0 | No Interrupt
Interrupt | 1 | Interrupt
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.StatusRegDa Enumeration

IRD

Lis331hhStatusRegDa Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusRegDa
Public Enumeration StatusRegDa
public enum class StatusRegDa
type StatusRegDa
Members
Member name | Value | Description
NewDataNotAvailable | 0 | New Data: Not Available
NewDataAvailable | 1 | New Data: Available
See Also

Reference

telos.Ird.ST Namespace


Lis331hh.StatusRegOr Enumeration

IRD

Lis331hhStatusRegOr Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum StatusRegOr
Public Enumeration StatusRegOr
public enum class StatusRegOr
type StatusRegOr
Members
Member name | Value | Description
NoOverrun | 0 | No Overrun
Overrun | 1 | Overrun
See Also

Reference

telos.Ird.ST Namespace


M41t62 Class

ST: M41T62
Inheritance Hierarchy
SystemObject
telos.Ird.STM41t62

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class M41t62
Public Class M41t62
public ref class M41t62
type M41t62 =  class end

The M41t62 type exposes the following members.

Constructors
 | Name | Description
Public method | M41t62 | Constructor
Top
Properties
 | Name | Description
Public property | AlarmDate | Alarm Date
Public property | AlarmFlagAF | Alarm Flag (AF)
Public property | AlarmFlagEnableAFE | Alarm Flag Enable (AFE)
Public property | AlarmHour | Alarm Hour
Public property | AlarmMinutes | Alarm Minutes
Public property | AlarmMonth | Alarm Month
Public property | AlarmRepeatMode | Alarm Repeat Mode
Public property | AlarmSeconds | Alarm Seconds
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Calibration | Calibration
Public property | CenturyCB | Century (CB)
Public property | Date | Date
Public property | DayOfWeek | Day Of Week
Public property | Hours | Hours
Public property | Minutes | Minutes
Public property | Month | Month
Public property | OscillatorFailInterruptEnableOFIE | Oscillator Fail Interrupt Enable (OFIE)
Public property | OscillatorFailOF | Oscillator Fail (OF)
Public property | OutputLevelOUT | Output Level (OUT)
Public property | Property_10ths100thsOfSeconds | 10ths/100ths Of Seconds
Public property | Seconds | Seconds
Public property | SignS | Sign (S)
Public property | SquareWaveEnableSQWE | Square Wave Enable (SQWE)
Public property | SQWFrequencyRS | SQW Frequency (RS) (unit: Hz)
Public property | StopST | Stop (ST)
Public property | WatchdogFlagWDF | Watchdog Flag (WDF)
Public property | WatchdogMultiplierBMB | Watchdog Multiplier (BMB)
Public property | WatchdogResolutionRB | Watchdog Resolution (RB) (unit: Hz)
Public property | Year | Year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Power Serial Real-Time Clock (RTC) With Alarm
See Also

Reference

telos.Ird.ST Namespace


M41t62 Constructor

Constructor

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t62(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
M41t62(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> M41t62

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62 Properties

The M41t62 type exposes the following members.

Properties
 | Name | Description
Public property | AlarmDate | Alarm Date
Public property | AlarmFlagAF | Alarm Flag (AF)
Public property | AlarmFlagEnableAFE | Alarm Flag Enable (AFE)
Public property | AlarmHour | Alarm Hour
Public property | AlarmMinutes | Alarm Minutes
Public property | AlarmMonth | Alarm Month
Public property | AlarmRepeatMode | Alarm Repeat Mode
Public property | AlarmSeconds | Alarm Seconds
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Calibration | Calibration
Public property | CenturyCB | Century (CB)
Public property | Date | Date
Public property | DayOfWeek | Day Of Week
Public property | Hours | Hours
Public property | Minutes | Minutes
Public property | Month | Month
Public property | OscillatorFailInterruptEnableOFIE | Oscillator Fail Interrupt Enable (OFIE)
Public property | OscillatorFailOF | Oscillator Fail (OF)
Public property | OutputLevelOUT | Output Level (OUT)
Public property | Property_10ths100thsOfSeconds | 10ths/100ths Of Seconds
Public property | Seconds | Seconds
Public property | SignS | Sign (S)
Public property | SquareWaveEnableSQWE | Square Wave Enable (SQWE)
Public property | SQWFrequencyRS | SQW Frequency (RS) (unit: Hz)
Public property | StopST | Stop (ST)
Public property | WatchdogFlagWDF | Watchdog Flag (WDF)
Public property | WatchdogMultiplierBMB | Watchdog Multiplier (BMB)
Public property | WatchdogResolutionRB | Watchdog Resolution (RB) (unit: Hz)
Public property | Year | Year
Top
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.AlarmDate Property

IRD

M41t62AlarmDate Property

Alarm Date

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmDate { get; set; }
Public Property AlarmDate As Byte
    Get
    Set
public:
property unsigned char AlarmDate {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmDate : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.AlarmFlagAF Property

IRD

M41t62AlarmFlagAF Property

Alarm Flag (AF)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmFlagAF { get; }
Public ReadOnly Property AlarmFlagAF As Byte
    Get
public:
property unsigned char AlarmFlagAF {
    unsigned char get ();
}
member AlarmFlagAF : byte with get

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.AlarmFlagEnableAFE Property

IRD

M41t62AlarmFlagEnableAFE Property

Alarm Flag Enable (AFE)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmFlagEnableAFE { get; set; }
Public Property AlarmFlagEnableAFE As Byte
    Get
    Set
public:
property unsigned char AlarmFlagEnableAFE {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmFlagEnableAFE : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.AlarmHour Property

IRD

M41t62AlarmHour Property

Alarm Hour

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmHour { get; set; }
Public Property AlarmHour As Byte
    Get
    Set
public:
property unsigned char AlarmHour {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmHour : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.AlarmMinutes Property

IRD

M41t62AlarmMinutes Property

Alarm Minutes

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmMinutes { get; set; }
Public Property AlarmMinutes As Byte
    Get
    Set
public:
property unsigned char AlarmMinutes {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmMinutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.AlarmMonth Property

IRD

M41t62AlarmMonth Property

Alarm Month

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmMonth { get; set; }
Public Property AlarmMonth As Byte
    Get
    Set
public:
property unsigned char AlarmMonth {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmMonth : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.AlarmRepeatMode Property

IRD

M41t62AlarmRepeatMode Property

Alarm Repeat Mode

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t62TypeRpt AlarmRepeatMode { get; set; }
Public Property AlarmRepeatMode As M41t62TypeRpt
    Get
    Set
public:
property M41t62TypeRpt AlarmRepeatMode {
    M41t62TypeRpt get ();
    void set (M41t62TypeRpt value);
}
member AlarmRepeatMode : M41t62TypeRpt with get, set

Property Value

Type: M41t62TypeRpt
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.AlarmSeconds Property

IRD

M41t62AlarmSeconds Property

Alarm Seconds

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmSeconds { get; set; }
Public Property AlarmSeconds As Byte
    Get
    Set
public:
property unsigned char AlarmSeconds {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmSeconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.AutoFlush Property

IRD

M41t62AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.Calibration Property

IRD

M41t62Calibration Property

Calibration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Calibration { get; set; }
Public Property Calibration As Byte
    Get
    Set
public:
property unsigned char Calibration {
    unsigned char get ();
    void set (unsigned char value);
}
member Calibration : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.CenturyCB Property

IRD

M41t62CenturyCB Property

Century (CB)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t62TypeCb CenturyCB { get; set; }
Public Property CenturyCB As M41t62TypeCb
    Get
    Set
public:
property M41t62TypeCb CenturyCB {
    M41t62TypeCb get ();
    void set (M41t62TypeCb value);
}
member CenturyCB : M41t62TypeCb with get, set

Property Value

Type: M41t62TypeCb
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.Date Property

IRD

M41t62Date Property

Date

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Date { get; set; }
Public Property Date As Byte
    Get
    Set
public:
property unsigned char Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.DayOfWeek Property

IRD

M41t62DayOfWeek Property

Day Of Week

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DayOfWeek { get; set; }
Public Property DayOfWeek As Byte
    Get
    Set
public:
property unsigned char DayOfWeek {
    unsigned char get ();
    void set (unsigned char value);
}
member DayOfWeek : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.Hours Property

IRD

M41t62Hours Property

Hours

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Hours { get; set; }
Public Property Hours As Byte
    Get
    Set
public:
property unsigned char Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.Minutes Property

IRD

M41t62Minutes Property

Minutes

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Minutes { get; set; }
Public Property Minutes As Byte
    Get
    Set
public:
property unsigned char Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.Month Property

IRD

M41t62Month Property

Month

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Month { get; set; }
Public Property Month As Byte
    Get
    Set
public:
property unsigned char Month {
    unsigned char get ();
    void set (unsigned char value);
}
member Month : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.OscillatorFailInterruptEnableOFIE Property

IRD

M41t62OscillatorFailInterruptEnableOFIE Property

Oscillator Fail Interrupt Enable (OFIE)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OscillatorFailInterruptEnableOFIE { get; set; }
Public Property OscillatorFailInterruptEnableOFIE As Byte
    Get
    Set
public:
property unsigned char OscillatorFailInterruptEnableOFIE {
    unsigned char get ();
    void set (unsigned char value);
}
member OscillatorFailInterruptEnableOFIE : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.OscillatorFailOF Property

IRD

M41t62OscillatorFailOF Property

Oscillator Fail (OF)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OscillatorFailOF { get; set; }
Public Property OscillatorFailOF As Byte
    Get
    Set
public:
property unsigned char OscillatorFailOF {
    unsigned char get ();
    void set (unsigned char value);
}
member OscillatorFailOF : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.OutputLevelOUT Property

IRD

M41t62OutputLevelOUT Property

Output Level (OUT)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputLevelOUT { get; set; }
Public Property OutputLevelOUT As Byte
    Get
    Set
public:
property unsigned char OutputLevelOUT {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputLevelOUT : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.Property_10ths100thsOfSeconds Property

IRD

M41t62Property_10ths100thsOfSeconds Property

10ths/100ths Of Seconds

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Property_10ths100thsOfSeconds { get; set; }
Public Property Property_10ths100thsOfSeconds As Byte
    Get
    Set
public:
property unsigned char Property_10ths100thsOfSeconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Property_10ths100thsOfSeconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.Seconds Property

IRD

M41t62Seconds Property

Seconds

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Seconds { get; set; }
Public Property Seconds As Byte
    Get
    Set
public:
property unsigned char Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.SignS Property

IRD

M41t62SignS Property

Sign (S)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t62TypeS SignS { get; set; }
Public Property SignS As M41t62TypeS
    Get
    Set
public:
property M41t62TypeS SignS {
    M41t62TypeS get ();
    void set (M41t62TypeS value);
}
member SignS : M41t62TypeS with get, set

Property Value

Type: M41t62TypeS
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.SquareWaveEnableSQWE Property

IRD

M41t62SquareWaveEnableSQWE Property

Square Wave Enable (SQWE)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SquareWaveEnableSQWE { get; set; }
Public Property SquareWaveEnableSQWE As Byte
    Get
    Set
public:
property unsigned char SquareWaveEnableSQWE {
    unsigned char get ();
    void set (unsigned char value);
}
member SquareWaveEnableSQWE : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.SQWFrequencyRS Property

IRD

M41t62SQWFrequencyRS Property

SQW Frequency (RS) (unit: Hz)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t62TypeRs SQWFrequencyRS { get; set; }
Public Property SQWFrequencyRS As M41t62TypeRs
    Get
    Set
public:
property M41t62TypeRs SQWFrequencyRS {
    M41t62TypeRs get ();
    void set (M41t62TypeRs value);
}
member SQWFrequencyRS : M41t62TypeRs with get, set

Property Value

Type: M41t62TypeRs
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.StopST Property

IRD

M41t62StopST Property

Stop (ST)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte StopST { get; set; }
Public Property StopST As Byte
    Get
    Set
public:
property unsigned char StopST {
    unsigned char get ();
    void set (unsigned char value);
}
member StopST : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.WatchdogFlagWDF Property

IRD

M41t62WatchdogFlagWDF Property

Watchdog Flag (WDF)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WatchdogFlagWDF { get; }
Public ReadOnly Property WatchdogFlagWDF As Byte
    Get
public:
property unsigned char WatchdogFlagWDF {
    unsigned char get ();
}
member WatchdogFlagWDF : byte with get

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.WatchdogMultiplierBMB Property

IRD

M41t62WatchdogMultiplierBMB Property

Watchdog Multiplier (BMB)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WatchdogMultiplierBMB { get; set; }
Public Property WatchdogMultiplierBMB As Byte
    Get
    Set
public:
property unsigned char WatchdogMultiplierBMB {
    unsigned char get ();
    void set (unsigned char value);
}
member WatchdogMultiplierBMB : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.WatchdogResolutionRB Property

IRD

M41t62WatchdogResolutionRB Property

Watchdog Resolution (RB) (unit: Hz)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t62TypeRb WatchdogResolutionRB { get; set; }
Public Property WatchdogResolutionRB As M41t62TypeRb
    Get
    Set
public:
property M41t62TypeRb WatchdogResolutionRB {
    M41t62TypeRb get ();
    void set (M41t62TypeRb value);
}
member WatchdogResolutionRB : M41t62TypeRb with get, set

Property Value

Type: M41t62TypeRb
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.Year Property

IRD

M41t62Year Property

Year

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Year { get; set; }
Public Property Year As Byte
    Get
    Set
public:
property unsigned char Year {
    unsigned char get ();
    void set (unsigned char value);
}
member Year : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62 Methods

The M41t62 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.Flush Method

IRD

M41t62Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

M41t62 Class
telos.Ird.ST Namespace


M41t62.TypeCb Enumeration

IRD

M41t62TypeCb Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCb
Public Enumeration TypeCb
public enum class TypeCb
type TypeCb
Members
Member name | Value | Description
Value_2000 | 0 | 2000
Value_2100 | 1 | 2100
Value_2200 | 2 | 2200
Value_2300 | 3 | 2300
See Also

Reference

telos.Ird.ST Namespace


M41t62.TypeRb Enumeration

IRD

M41t62TypeRb Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRb
Public Enumeration TypeRb
public enum class TypeRb
type TypeRb
Members
Member name | Value | Description
Value_16 | 0 | 16
Value_4 | 1 | 4
Value_1 | 2 | 1
Value_14 | 3 | 1/4
Value_160 | 4 | 1/60
Invalid | 5 | Invalid
See Also

Reference

telos.Ird.ST Namespace


M41t62.TypeRpt Enumeration

IRD

M41t62TypeRpt Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRpt
Public Enumeration TypeRpt
public enum class TypeRpt
type TypeRpt
Members
Member name | Value | Description
OncePerYear | 0 | Once Per Year
OncePerMonth | 22 | Once Per Month
OncePerDay | 24 | Once Per Day
OncePerHour | 28 | Once Per Hour
OncePerMinute | 30 | Once Per Minute
OncePerSecond | 31 | Once Per Second
See Also

Reference

telos.Ird.ST Namespace


M41t62.TypeRs Enumeration

IRD

M41t62TypeRs Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRs
Public Enumeration TypeRs
public enum class TypeRs
type TypeRs
Members
Member name | Value | Description
None | 0 | None
Value_32768 | 1 | 32768
Value_8192 | 2 | 8192
Value_4096 | 3 | 4096
Value_2048 | 4 | 2048
Value_1024 | 5 | 1024
Value_512 | 6 | 512
Value_256 | 7 | 256
Value_128 | 8 | 128
Value_64 | 9 | 64
Value_32 | 10 | 32
Value_16 | 11 | 16
Value_8 | 12 | 8
Value_4 | 13 | 4
Value_2 | 14 | 2
Value_1 | 15 | 1
See Also

Reference

telos.Ird.ST Namespace


M41t62.TypeS Enumeration

IRD

M41t62TypeS Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeS
Public Enumeration TypeS
public enum class TypeS
type TypeS
Members
Member name | Value | Description
NegativeCalibration | 0 | Negative Calibration
PositiveCalibration | 1 | Positive Calibration
See Also

Reference

telos.Ird.ST Namespace


M41t63 Class

ST: M41T63
Inheritance Hierarchy
SystemObject
telos.Ird.STM41t63

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class M41t63
Public Class M41t63
public ref class M41t63
type M41t63 =  class end

The M41t63 type exposes the following members.

Constructors
 | Name | Description
Public method | M41t63 | Constructor
Top
Properties
 | Name | Description
Public property | AlarmDate | Alarm Date
Public property | AlarmFlagAF | Alarm Flag (AF)
Public property | AlarmHour | Alarm Hour
Public property | AlarmMinutes | Alarm Minutes
Public property | AlarmMonth | Alarm Month
Public property | AlarmRepeatMode | Alarm Repeat Mode
Public property | AlarmSeconds | Alarm Seconds
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Calibration | Calibration
Public property | CenturyCB | Century (CB)
Public property | Date | Date
Public property | DayOfWeek | Day Of Week
Public property | Hours | Hours
Public property | Minutes | Minutes
Public property | Month | Month
Public property | OscillatorFailOF | Oscillator Fail (OF)
Public property | Property_10ths100thsOfSeconds | 10ths/100ths Of Seconds
Public property | Seconds | Seconds
Public property | SignS | Sign (S)
Public property | SquareWaveEnableSQWE | Square Wave Enable (SQWE)
Public property | SQWFrequencyRS | SQW Frequency (RS) (unit: Hz)
Public property | StopST | Stop (ST)
Public property | WatchdogFlagWDF | Watchdog Flag (WDF)
Public property | WatchdogMultiplierBMB | Watchdog Multiplier (BMB)
Public property | WatchdogResolutionRB | Watchdog Resolution (RB) (unit: Hz)
Public property | Year | Year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Power Serial Real-Time Clock (RTC) With Alarm
See Also

Reference

telos.Ird.ST Namespace


M41t63 Constructor

Constructor

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t63(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
M41t63(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> M41t63

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63 Properties

The M41t63 type exposes the following members.

Properties
 | Name | Description
Public property | AlarmDate | Alarm Date
Public property | AlarmFlagAF | Alarm Flag (AF)
Public property | AlarmHour | Alarm Hour
Public property | AlarmMinutes | Alarm Minutes
Public property | AlarmMonth | Alarm Month
Public property | AlarmRepeatMode | Alarm Repeat Mode
Public property | AlarmSeconds | Alarm Seconds
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Calibration | Calibration
Public property | CenturyCB | Century (CB)
Public property | Date | Date
Public property | DayOfWeek | Day Of Week
Public property | Hours | Hours
Public property | Minutes | Minutes
Public property | Month | Month
Public property | OscillatorFailOF | Oscillator Fail (OF)
Public property | Property_10ths100thsOfSeconds | 10ths/100ths Of Seconds
Public property | Seconds | Seconds
Public property | SignS | Sign (S)
Public property | SquareWaveEnableSQWE | Square Wave Enable (SQWE)
Public property | SQWFrequencyRS | SQW Frequency (RS) (unit: Hz)
Public property | StopST | Stop (ST)
Public property | WatchdogFlagWDF | Watchdog Flag (WDF)
Public property | WatchdogMultiplierBMB | Watchdog Multiplier (BMB)
Public property | WatchdogResolutionRB | Watchdog Resolution (RB) (unit: Hz)
Public property | Year | Year
Top
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.AlarmDate Property

IRD

M41t63AlarmDate Property

Alarm Date

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmDate { get; set; }
Public Property AlarmDate As Byte
    Get
    Set
public:
property unsigned char AlarmDate {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmDate : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.AlarmFlagAF Property

IRD

M41t63AlarmFlagAF Property

Alarm Flag (AF)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmFlagAF { get; }
Public ReadOnly Property AlarmFlagAF As Byte
    Get
public:
property unsigned char AlarmFlagAF {
    unsigned char get ();
}
member AlarmFlagAF : byte with get

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.AlarmHour Property

IRD

M41t63AlarmHour Property

Alarm Hour

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmHour { get; set; }
Public Property AlarmHour As Byte
    Get
    Set
public:
property unsigned char AlarmHour {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmHour : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.AlarmMinutes Property

IRD

M41t63AlarmMinutes Property

Alarm Minutes

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmMinutes { get; set; }
Public Property AlarmMinutes As Byte
    Get
    Set
public:
property unsigned char AlarmMinutes {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmMinutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.AlarmMonth Property

IRD

M41t63AlarmMonth Property

Alarm Month

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmMonth { get; set; }
Public Property AlarmMonth As Byte
    Get
    Set
public:
property unsigned char AlarmMonth {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmMonth : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.AlarmRepeatMode Property

IRD

M41t63AlarmRepeatMode Property

Alarm Repeat Mode

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t63TypeRpt AlarmRepeatMode { get; set; }
Public Property AlarmRepeatMode As M41t63TypeRpt
    Get
    Set
public:
property M41t63TypeRpt AlarmRepeatMode {
    M41t63TypeRpt get ();
    void set (M41t63TypeRpt value);
}
member AlarmRepeatMode : M41t63TypeRpt with get, set

Property Value

Type: M41t63TypeRpt
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.AlarmSeconds Property

IRD

M41t63AlarmSeconds Property

Alarm Seconds

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmSeconds { get; set; }
Public Property AlarmSeconds As Byte
    Get
    Set
public:
property unsigned char AlarmSeconds {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmSeconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.AutoFlush Property

IRD

M41t63AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.Calibration Property

IRD

M41t63Calibration Property

Calibration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Calibration { get; set; }
Public Property Calibration As Byte
    Get
    Set
public:
property unsigned char Calibration {
    unsigned char get ();
    void set (unsigned char value);
}
member Calibration : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.CenturyCB Property

IRD

M41t63CenturyCB Property

Century (CB)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t63TypeCb CenturyCB { get; set; }
Public Property CenturyCB As M41t63TypeCb
    Get
    Set
public:
property M41t63TypeCb CenturyCB {
    M41t63TypeCb get ();
    void set (M41t63TypeCb value);
}
member CenturyCB : M41t63TypeCb with get, set

Property Value

Type: M41t63TypeCb
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.Date Property

IRD

M41t63Date Property

Date

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Date { get; set; }
Public Property Date As Byte
    Get
    Set
public:
property unsigned char Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.DayOfWeek Property

IRD

M41t63DayOfWeek Property

Day Of Week

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DayOfWeek { get; set; }
Public Property DayOfWeek As Byte
    Get
    Set
public:
property unsigned char DayOfWeek {
    unsigned char get ();
    void set (unsigned char value);
}
member DayOfWeek : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.Hours Property

IRD

M41t63Hours Property

Hours

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Hours { get; set; }
Public Property Hours As Byte
    Get
    Set
public:
property unsigned char Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.Minutes Property

IRD

M41t63Minutes Property

Minutes

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Minutes { get; set; }
Public Property Minutes As Byte
    Get
    Set
public:
property unsigned char Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.Month Property

IRD

M41t63Month Property

Month

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Month { get; set; }
Public Property Month As Byte
    Get
    Set
public:
property unsigned char Month {
    unsigned char get ();
    void set (unsigned char value);
}
member Month : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.OscillatorFailOF Property

IRD

M41t63OscillatorFailOF Property

Oscillator Fail (OF)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OscillatorFailOF { get; set; }
Public Property OscillatorFailOF As Byte
    Get
    Set
public:
property unsigned char OscillatorFailOF {
    unsigned char get ();
    void set (unsigned char value);
}
member OscillatorFailOF : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.Property_10ths100thsOfSeconds Property

IRD

M41t63Property_10ths100thsOfSeconds Property

10ths/100ths Of Seconds

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Property_10ths100thsOfSeconds { get; set; }
Public Property Property_10ths100thsOfSeconds As Byte
    Get
    Set
public:
property unsigned char Property_10ths100thsOfSeconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Property_10ths100thsOfSeconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.Seconds Property

IRD

M41t63Seconds Property

Seconds

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Seconds { get; set; }
Public Property Seconds As Byte
    Get
    Set
public:
property unsigned char Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.SignS Property

IRD

M41t63SignS Property

Sign (S)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t63TypeS SignS { get; set; }
Public Property SignS As M41t63TypeS
    Get
    Set
public:
property M41t63TypeS SignS {
    M41t63TypeS get ();
    void set (M41t63TypeS value);
}
member SignS : M41t63TypeS with get, set

Property Value

Type: M41t63TypeS
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.SquareWaveEnableSQWE Property

IRD

M41t63SquareWaveEnableSQWE Property

Square Wave Enable (SQWE)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SquareWaveEnableSQWE { get; set; }
Public Property SquareWaveEnableSQWE As Byte
    Get
    Set
public:
property unsigned char SquareWaveEnableSQWE {
    unsigned char get ();
    void set (unsigned char value);
}
member SquareWaveEnableSQWE : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.SQWFrequencyRS Property

IRD

M41t63SQWFrequencyRS Property

SQW Frequency (RS) (unit: Hz)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t63TypeRs SQWFrequencyRS { get; set; }
Public Property SQWFrequencyRS As M41t63TypeRs
    Get
    Set
public:
property M41t63TypeRs SQWFrequencyRS {
    M41t63TypeRs get ();
    void set (M41t63TypeRs value);
}
member SQWFrequencyRS : M41t63TypeRs with get, set

Property Value

Type: M41t63TypeRs
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.StopST Property

IRD

M41t63StopST Property

Stop (ST)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte StopST { get; set; }
Public Property StopST As Byte
    Get
    Set
public:
property unsigned char StopST {
    unsigned char get ();
    void set (unsigned char value);
}
member StopST : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.WatchdogFlagWDF Property

IRD

M41t63WatchdogFlagWDF Property

Watchdog Flag (WDF)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WatchdogFlagWDF { get; }
Public ReadOnly Property WatchdogFlagWDF As Byte
    Get
public:
property unsigned char WatchdogFlagWDF {
    unsigned char get ();
}
member WatchdogFlagWDF : byte with get

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.WatchdogMultiplierBMB Property

IRD

M41t63WatchdogMultiplierBMB Property

Watchdog Multiplier (BMB)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WatchdogMultiplierBMB { get; set; }
Public Property WatchdogMultiplierBMB As Byte
    Get
    Set
public:
property unsigned char WatchdogMultiplierBMB {
    unsigned char get ();
    void set (unsigned char value);
}
member WatchdogMultiplierBMB : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.WatchdogResolutionRB Property

IRD

M41t63WatchdogResolutionRB Property

Watchdog Resolution (RB) (unit: Hz)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t63TypeRb WatchdogResolutionRB { get; set; }
Public Property WatchdogResolutionRB As M41t63TypeRb
    Get
    Set
public:
property M41t63TypeRb WatchdogResolutionRB {
    M41t63TypeRb get ();
    void set (M41t63TypeRb value);
}
member WatchdogResolutionRB : M41t63TypeRb with get, set

Property Value

Type: M41t63TypeRb
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.Year Property

IRD

M41t63Year Property

Year

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Year { get; set; }
Public Property Year As Byte
    Get
    Set
public:
property unsigned char Year {
    unsigned char get ();
    void set (unsigned char value);
}
member Year : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63 Methods

The M41t63 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.Flush Method

IRD

M41t63Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

M41t63 Class
telos.Ird.ST Namespace


M41t63.TypeCb Enumeration

IRD

M41t63TypeCb Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCb
Public Enumeration TypeCb
public enum class TypeCb
type TypeCb
Members
Member name | Value | Description
Value_2000 | 0 | 2000
Value_2100 | 1 | 2100
Value_2200 | 2 | 2200
Value_2300 | 3 | 2300
See Also

Reference

telos.Ird.ST Namespace


M41t63.TypeRb Enumeration

IRD

M41t63TypeRb Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRb
Public Enumeration TypeRb
public enum class TypeRb
type TypeRb
Members
Member name | Value | Description
Value_16 | 0 | 16
Value_4 | 1 | 4
Value_1 | 2 | 1
Value_14 | 3 | 1/4
Value_160 | 4 | 1/60
Invalid | 5 | Invalid
See Also

Reference

telos.Ird.ST Namespace


M41t63.TypeRpt Enumeration

IRD

M41t63TypeRpt Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRpt
Public Enumeration TypeRpt
public enum class TypeRpt
type TypeRpt
Members
Member name | Value | Description
OncePerYear | 0 | Once Per Year
OncePerMonth | 22 | Once Per Month
OncePerDay | 24 | Once Per Day
OncePerHour | 28 | Once Per Hour
OncePerMinute | 30 | Once Per Minute
OncePerSecond | 31 | Once Per Second
See Also

Reference

telos.Ird.ST Namespace


M41t63.TypeRs Enumeration

IRD

M41t63TypeRs Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRs
Public Enumeration TypeRs
public enum class TypeRs
type TypeRs
Members
Member name | Value | Description
None | 0 | None
Value_32768 | 1 | 32768
Value_8192 | 2 | 8192
Value_4096 | 3 | 4096
Value_2048 | 4 | 2048
Value_1024 | 5 | 1024
Value_512 | 6 | 512
Value_256 | 7 | 256
Value_128 | 8 | 128
Value_64 | 9 | 64
Value_32 | 10 | 32
Value_16 | 11 | 16
Value_8 | 12 | 8
Value_4 | 13 | 4
Value_2 | 14 | 2
Value_1 | 15 | 1
See Also

Reference

telos.Ird.ST Namespace


M41t63.TypeS Enumeration

IRD

M41t63TypeS Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeS
Public Enumeration TypeS
public enum class TypeS
type TypeS
Members
Member name | Value | Description
NegativeCalibration | 0 | Negative Calibration
PositiveCalibration | 1 | Positive Calibration
See Also

Reference

telos.Ird.ST Namespace


M41t64 Class

ST: M41T64
Inheritance Hierarchy
SystemObject
telos.Ird.STM41t64

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class M41t64
Public Class M41t64
public ref class M41t64
type M41t64 =  class end

The M41t64 type exposes the following members.

Constructors
 | Name | Description
Public method | M41t64 | Constructor
Top
Properties
 | Name | Description
Public property | AlarmDate | Alarm Date
Public property | AlarmFlagAF | Alarm Flag (AF)
Public property | AlarmHour | Alarm Hour
Public property | AlarmMinutes | Alarm Minutes
Public property | AlarmMonth | Alarm Month
Public property | AlarmRepeatMode | Alarm Repeat Mode
Public property | AlarmSeconds | Alarm Seconds
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Calibration | Calibration
Public property | CenturyCB | Century (CB)
Public property | Date | Date
Public property | DayOfWeek | Day Of Week
Public property | Hours | Hours
Public property | Minutes | Minutes
Public property | Month | Month
Public property | OscillatorFailOF | Oscillator Fail (OF)
Public property | Property_10ths100thsOfSeconds | 10ths/100ths Of Seconds
Public property | Property_32KHzEnable32KE | 32 kHz Enable (32KE)
Public property | Seconds | Seconds
Public property | SignS | Sign (S)
Public property | SquareWaveEnableSQWE | Square Wave Enable (SQWE)
Public property | SQWFrequencyRS | SQW Frequency (RS) (unit: Hz)
Public property | StopST | Stop (ST)
Public property | WatchdogFlagWDF | Watchdog Flag (WDF)
Public property | WatchdogMultiplierBMB | Watchdog Multiplier (BMB)
Public property | WatchdogResolutionRB | Watchdog Resolution (RB) (unit: Hz)
Public property | Year | Year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Power Serial Real-Time Clock (RTC) With Alarm
See Also

Reference

telos.Ird.ST Namespace


M41t64 Constructor

Constructor

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t64(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
M41t64(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> M41t64

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64 Properties

The M41t64 type exposes the following members.

Properties
 | Name | Description
Public property | AlarmDate | Alarm Date
Public property | AlarmFlagAF | Alarm Flag (AF)
Public property | AlarmHour | Alarm Hour
Public property | AlarmMinutes | Alarm Minutes
Public property | AlarmMonth | Alarm Month
Public property | AlarmRepeatMode | Alarm Repeat Mode
Public property | AlarmSeconds | Alarm Seconds
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Calibration | Calibration
Public property | CenturyCB | Century (CB)
Public property | Date | Date
Public property | DayOfWeek | Day Of Week
Public property | Hours | Hours
Public property | Minutes | Minutes
Public property | Month | Month
Public property | OscillatorFailOF | Oscillator Fail (OF)
Public property | Property_10ths100thsOfSeconds | 10ths/100ths Of Seconds
Public property | Property_32KHzEnable32KE | 32 kHz Enable (32KE)
Public property | Seconds | Seconds
Public property | SignS | Sign (S)
Public property | SquareWaveEnableSQWE | Square Wave Enable (SQWE)
Public property | SQWFrequencyRS | SQW Frequency (RS) (unit: Hz)
Public property | StopST | Stop (ST)
Public property | WatchdogFlagWDF | Watchdog Flag (WDF)
Public property | WatchdogMultiplierBMB | Watchdog Multiplier (BMB)
Public property | WatchdogResolutionRB | Watchdog Resolution (RB) (unit: Hz)
Public property | Year | Year
Top
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.AlarmDate Property

IRD

M41t64AlarmDate Property

Alarm Date

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmDate { get; set; }
Public Property AlarmDate As Byte
    Get
    Set
public:
property unsigned char AlarmDate {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmDate : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.AlarmFlagAF Property

IRD

M41t64AlarmFlagAF Property

Alarm Flag (AF)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmFlagAF { get; }
Public ReadOnly Property AlarmFlagAF As Byte
    Get
public:
property unsigned char AlarmFlagAF {
    unsigned char get ();
}
member AlarmFlagAF : byte with get

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.AlarmHour Property

IRD

M41t64AlarmHour Property

Alarm Hour

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmHour { get; set; }
Public Property AlarmHour As Byte
    Get
    Set
public:
property unsigned char AlarmHour {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmHour : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.AlarmMinutes Property

IRD

M41t64AlarmMinutes Property

Alarm Minutes

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmMinutes { get; set; }
Public Property AlarmMinutes As Byte
    Get
    Set
public:
property unsigned char AlarmMinutes {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmMinutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.AlarmMonth Property

IRD

M41t64AlarmMonth Property

Alarm Month

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmMonth { get; set; }
Public Property AlarmMonth As Byte
    Get
    Set
public:
property unsigned char AlarmMonth {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmMonth : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.AlarmRepeatMode Property

IRD

M41t64AlarmRepeatMode Property

Alarm Repeat Mode

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t64TypeRpt AlarmRepeatMode { get; set; }
Public Property AlarmRepeatMode As M41t64TypeRpt
    Get
    Set
public:
property M41t64TypeRpt AlarmRepeatMode {
    M41t64TypeRpt get ();
    void set (M41t64TypeRpt value);
}
member AlarmRepeatMode : M41t64TypeRpt with get, set

Property Value

Type: M41t64TypeRpt
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.AlarmSeconds Property

IRD

M41t64AlarmSeconds Property

Alarm Seconds

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmSeconds { get; set; }
Public Property AlarmSeconds As Byte
    Get
    Set
public:
property unsigned char AlarmSeconds {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmSeconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.AutoFlush Property

IRD

M41t64AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.Calibration Property

IRD

M41t64Calibration Property

Calibration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Calibration { get; set; }
Public Property Calibration As Byte
    Get
    Set
public:
property unsigned char Calibration {
    unsigned char get ();
    void set (unsigned char value);
}
member Calibration : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.CenturyCB Property

IRD

M41t64CenturyCB Property

Century (CB)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t64TypeCb CenturyCB { get; set; }
Public Property CenturyCB As M41t64TypeCb
    Get
    Set
public:
property M41t64TypeCb CenturyCB {
    M41t64TypeCb get ();
    void set (M41t64TypeCb value);
}
member CenturyCB : M41t64TypeCb with get, set

Property Value

Type: M41t64TypeCb
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.Date Property

IRD

M41t64Date Property

Date

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Date { get; set; }
Public Property Date As Byte
    Get
    Set
public:
property unsigned char Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.DayOfWeek Property

IRD

M41t64DayOfWeek Property

Day Of Week

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DayOfWeek { get; set; }
Public Property DayOfWeek As Byte
    Get
    Set
public:
property unsigned char DayOfWeek {
    unsigned char get ();
    void set (unsigned char value);
}
member DayOfWeek : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.Hours Property

IRD

M41t64Hours Property

Hours

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Hours { get; set; }
Public Property Hours As Byte
    Get
    Set
public:
property unsigned char Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.Minutes Property

IRD

M41t64Minutes Property

Minutes

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Minutes { get; set; }
Public Property Minutes As Byte
    Get
    Set
public:
property unsigned char Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.Month Property

IRD

M41t64Month Property

Month

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Month { get; set; }
Public Property Month As Byte
    Get
    Set
public:
property unsigned char Month {
    unsigned char get ();
    void set (unsigned char value);
}
member Month : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.OscillatorFailOF Property

IRD

M41t64OscillatorFailOF Property

Oscillator Fail (OF)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OscillatorFailOF { get; set; }
Public Property OscillatorFailOF As Byte
    Get
    Set
public:
property unsigned char OscillatorFailOF {
    unsigned char get ();
    void set (unsigned char value);
}
member OscillatorFailOF : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.Property_10ths100thsOfSeconds Property

IRD

M41t64Property_10ths100thsOfSeconds Property

10ths/100ths Of Seconds

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Property_10ths100thsOfSeconds { get; set; }
Public Property Property_10ths100thsOfSeconds As Byte
    Get
    Set
public:
property unsigned char Property_10ths100thsOfSeconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Property_10ths100thsOfSeconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.Property_32KHzEnable32KE Property

IRD

M41t64Property_32KHzEnable32KE Property

32 kHz Enable (32KE)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Property_32KHzEnable32KE { get; set; }
Public Property Property_32KHzEnable32KE As Byte
    Get
    Set
public:
property unsigned char Property_32KHzEnable32KE {
    unsigned char get ();
    void set (unsigned char value);
}
member Property_32KHzEnable32KE : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.Seconds Property

IRD

M41t64Seconds Property

Seconds

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Seconds { get; set; }
Public Property Seconds As Byte
    Get
    Set
public:
property unsigned char Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.SignS Property

IRD

M41t64SignS Property

Sign (S)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t64TypeS SignS { get; set; }
Public Property SignS As M41t64TypeS
    Get
    Set
public:
property M41t64TypeS SignS {
    M41t64TypeS get ();
    void set (M41t64TypeS value);
}
member SignS : M41t64TypeS with get, set

Property Value

Type: M41t64TypeS
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.SquareWaveEnableSQWE Property

IRD

M41t64SquareWaveEnableSQWE Property

Square Wave Enable (SQWE)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SquareWaveEnableSQWE { get; set; }
Public Property SquareWaveEnableSQWE As Byte
    Get
    Set
public:
property unsigned char SquareWaveEnableSQWE {
    unsigned char get ();
    void set (unsigned char value);
}
member SquareWaveEnableSQWE : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.SQWFrequencyRS Property

IRD

M41t64SQWFrequencyRS Property

SQW Frequency (RS) (unit: Hz)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t64TypeRs SQWFrequencyRS { get; set; }
Public Property SQWFrequencyRS As M41t64TypeRs
    Get
    Set
public:
property M41t64TypeRs SQWFrequencyRS {
    M41t64TypeRs get ();
    void set (M41t64TypeRs value);
}
member SQWFrequencyRS : M41t64TypeRs with get, set

Property Value

Type: M41t64TypeRs
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.StopST Property

IRD

M41t64StopST Property

Stop (ST)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte StopST { get; set; }
Public Property StopST As Byte
    Get
    Set
public:
property unsigned char StopST {
    unsigned char get ();
    void set (unsigned char value);
}
member StopST : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.WatchdogFlagWDF Property

IRD

M41t64WatchdogFlagWDF Property

Watchdog Flag (WDF)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WatchdogFlagWDF { get; }
Public ReadOnly Property WatchdogFlagWDF As Byte
    Get
public:
property unsigned char WatchdogFlagWDF {
    unsigned char get ();
}
member WatchdogFlagWDF : byte with get

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.WatchdogMultiplierBMB Property

IRD

M41t64WatchdogMultiplierBMB Property

Watchdog Multiplier (BMB)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WatchdogMultiplierBMB { get; set; }
Public Property WatchdogMultiplierBMB As Byte
    Get
    Set
public:
property unsigned char WatchdogMultiplierBMB {
    unsigned char get ();
    void set (unsigned char value);
}
member WatchdogMultiplierBMB : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.WatchdogResolutionRB Property

IRD

M41t64WatchdogResolutionRB Property

Watchdog Resolution (RB) (unit: Hz)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t64TypeRb WatchdogResolutionRB { get; set; }
Public Property WatchdogResolutionRB As M41t64TypeRb
    Get
    Set
public:
property M41t64TypeRb WatchdogResolutionRB {
    M41t64TypeRb get ();
    void set (M41t64TypeRb value);
}
member WatchdogResolutionRB : M41t64TypeRb with get, set

Property Value

Type: M41t64TypeRb
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.Year Property

IRD

M41t64Year Property

Year

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Year { get; set; }
Public Property Year As Byte
    Get
    Set
public:
property unsigned char Year {
    unsigned char get ();
    void set (unsigned char value);
}
member Year : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64 Methods

The M41t64 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.Flush Method

IRD

M41t64Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

M41t64 Class
telos.Ird.ST Namespace


M41t64.TypeCb Enumeration

IRD

M41t64TypeCb Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCb
Public Enumeration TypeCb
public enum class TypeCb
type TypeCb
Members
Member name | Value | Description
Value_2000 | 0 | 2000
Value_2100 | 1 | 2100
Value_2200 | 2 | 2200
Value_2300 | 3 | 2300
See Also

Reference

telos.Ird.ST Namespace


M41t64.TypeRb Enumeration

IRD

M41t64TypeRb Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRb
Public Enumeration TypeRb
public enum class TypeRb
type TypeRb
Members
Member name | Value | Description
Value_16 | 0 | 16
Value_4 | 1 | 4
Value_1 | 2 | 1
Value_14 | 3 | 1/4
Value_160 | 4 | 1/60
Invalid | 5 | Invalid
See Also

Reference

telos.Ird.ST Namespace


M41t64.TypeRpt Enumeration

IRD

M41t64TypeRpt Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRpt
Public Enumeration TypeRpt
public enum class TypeRpt
type TypeRpt
Members
Member name | Value | Description
OncePerYear | 0 | Once Per Year
OncePerMonth | 22 | Once Per Month
OncePerDay | 24 | Once Per Day
OncePerHour | 28 | Once Per Hour
OncePerMinute | 30 | Once Per Minute
OncePerSecond | 31 | Once Per Second
See Also

Reference

telos.Ird.ST Namespace


M41t64.TypeRs Enumeration

IRD

M41t64TypeRs Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRs
Public Enumeration TypeRs
public enum class TypeRs
type TypeRs
Members
Member name | Value | Description
None | 0 | None
Value_32768 | 1 | 32768
Value_8192 | 2 | 8192
Value_4096 | 3 | 4096
Value_2048 | 4 | 2048
Value_1024 | 5 | 1024
Value_512 | 6 | 512
Value_256 | 7 | 256
Value_128 | 8 | 128
Value_64 | 9 | 64
Value_32 | 10 | 32
Value_16 | 11 | 16
Value_8 | 12 | 8
Value_4 | 13 | 4
Value_2 | 14 | 2
Value_1 | 15 | 1
See Also

Reference

telos.Ird.ST Namespace


M41t64.TypeS Enumeration

IRD

M41t64TypeS Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeS
Public Enumeration TypeS
public enum class TypeS
type TypeS
Members
Member name | Value | Description
NegativeCalibration | 0 | Negative Calibration
PositiveCalibration | 1 | Positive Calibration
See Also

Reference

telos.Ird.ST Namespace


M41t65 Class

ST: M41T65
Inheritance Hierarchy
SystemObject
telos.Ird.STM41t65

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class M41t65
Public Class M41t65
public ref class M41t65
type M41t65 =  class end

The M41t65 type exposes the following members.

Constructors
 | Name | Description
Public method | M41t65 | Constructor
Top
Properties
 | Name | Description
Public property | AlarmDate | Alarm Date
Public property | AlarmFlagAF | Alarm Flag (AF)
Public property | AlarmFlagEnableAFE | Alarm Flag Enable (AFE)
Public property | AlarmHour | Alarm Hour
Public property | AlarmMinutes | Alarm Minutes
Public property | AlarmMonth | Alarm Month
Public property | AlarmRepeatMode | Alarm Repeat Mode
Public property | AlarmSeconds | Alarm Seconds
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Calibration | Calibration
Public property | CenturyCB | Century (CB)
Public property | Date | Date
Public property | DayOfWeek | Day Of Week
Public property | FrequencyTestFT | Frequency Test (FT)
Public property | Hours | Hours
Public property | Minutes | Minutes
Public property | Month | Month
Public property | OscillatorFailInterruptEnableOFIE | Oscillator Fail Interrupt Enable (OFIE)
Public property | OscillatorFailOF | Oscillator Fail (OF)
Public property | OutputLevelOUT | Output Level (OUT)
Public property | Property_10ths100thsOfSeconds | 10ths/100ths Of Seconds
Public property | Seconds | Seconds
Public property | SignS | Sign (S)
Public property | StopST | Stop (ST)
Public property | WatchdogFlagWDF | Watchdog Flag (WDF)
Public property | WatchdogMultiplierBMB | Watchdog Multiplier (BMB)
Public property | WatchdogResolutionRB | Watchdog Resolution (RB) (unit: Hz)
Public property | Year | Year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Power Serial Real-Time Clock (RTC) With Alarm
See Also

Reference

telos.Ird.ST Namespace


M41t65 Constructor

Constructor

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t65(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
M41t65(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> M41t65

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65 Properties

The M41t65 type exposes the following members.

Properties
 | Name | Description
Public property | AlarmDate | Alarm Date
Public property | AlarmFlagAF | Alarm Flag (AF)
Public property | AlarmFlagEnableAFE | Alarm Flag Enable (AFE)
Public property | AlarmHour | Alarm Hour
Public property | AlarmMinutes | Alarm Minutes
Public property | AlarmMonth | Alarm Month
Public property | AlarmRepeatMode | Alarm Repeat Mode
Public property | AlarmSeconds | Alarm Seconds
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Calibration | Calibration
Public property | CenturyCB | Century (CB)
Public property | Date | Date
Public property | DayOfWeek | Day Of Week
Public property | FrequencyTestFT | Frequency Test (FT)
Public property | Hours | Hours
Public property | Minutes | Minutes
Public property | Month | Month
Public property | OscillatorFailInterruptEnableOFIE | Oscillator Fail Interrupt Enable (OFIE)
Public property | OscillatorFailOF | Oscillator Fail (OF)
Public property | OutputLevelOUT | Output Level (OUT)
Public property | Property_10ths100thsOfSeconds | 10ths/100ths Of Seconds
Public property | Seconds | Seconds
Public property | SignS | Sign (S)
Public property | StopST | Stop (ST)
Public property | WatchdogFlagWDF | Watchdog Flag (WDF)
Public property | WatchdogMultiplierBMB | Watchdog Multiplier (BMB)
Public property | WatchdogResolutionRB | Watchdog Resolution (RB) (unit: Hz)
Public property | Year | Year
Top
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.AlarmDate Property

IRD

M41t65AlarmDate Property

Alarm Date

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmDate { get; set; }
Public Property AlarmDate As Byte
    Get
    Set
public:
property unsigned char AlarmDate {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmDate : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.AlarmFlagAF Property

IRD

M41t65AlarmFlagAF Property

Alarm Flag (AF)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmFlagAF { get; }
Public ReadOnly Property AlarmFlagAF As Byte
    Get
public:
property unsigned char AlarmFlagAF {
    unsigned char get ();
}
member AlarmFlagAF : byte with get

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.AlarmFlagEnableAFE Property

IRD

M41t65AlarmFlagEnableAFE Property

Alarm Flag Enable (AFE)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmFlagEnableAFE { get; set; }
Public Property AlarmFlagEnableAFE As Byte
    Get
    Set
public:
property unsigned char AlarmFlagEnableAFE {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmFlagEnableAFE : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.AlarmHour Property

IRD

M41t65AlarmHour Property

Alarm Hour

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmHour { get; set; }
Public Property AlarmHour As Byte
    Get
    Set
public:
property unsigned char AlarmHour {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmHour : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.AlarmMinutes Property

IRD

M41t65AlarmMinutes Property

Alarm Minutes

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmMinutes { get; set; }
Public Property AlarmMinutes As Byte
    Get
    Set
public:
property unsigned char AlarmMinutes {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmMinutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.AlarmMonth Property

IRD

M41t65AlarmMonth Property

Alarm Month

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmMonth { get; set; }
Public Property AlarmMonth As Byte
    Get
    Set
public:
property unsigned char AlarmMonth {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmMonth : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.AlarmRepeatMode Property

IRD

M41t65AlarmRepeatMode Property

Alarm Repeat Mode

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t65TypeRpt AlarmRepeatMode { get; set; }
Public Property AlarmRepeatMode As M41t65TypeRpt
    Get
    Set
public:
property M41t65TypeRpt AlarmRepeatMode {
    M41t65TypeRpt get ();
    void set (M41t65TypeRpt value);
}
member AlarmRepeatMode : M41t65TypeRpt with get, set

Property Value

Type: M41t65TypeRpt
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.AlarmSeconds Property

IRD

M41t65AlarmSeconds Property

Alarm Seconds

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AlarmSeconds { get; set; }
Public Property AlarmSeconds As Byte
    Get
    Set
public:
property unsigned char AlarmSeconds {
    unsigned char get ();
    void set (unsigned char value);
}
member AlarmSeconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.AutoFlush Property

IRD

M41t65AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.Calibration Property

IRD

M41t65Calibration Property

Calibration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Calibration { get; set; }
Public Property Calibration As Byte
    Get
    Set
public:
property unsigned char Calibration {
    unsigned char get ();
    void set (unsigned char value);
}
member Calibration : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.CenturyCB Property

IRD

M41t65CenturyCB Property

Century (CB)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t65TypeCb CenturyCB { get; set; }
Public Property CenturyCB As M41t65TypeCb
    Get
    Set
public:
property M41t65TypeCb CenturyCB {
    M41t65TypeCb get ();
    void set (M41t65TypeCb value);
}
member CenturyCB : M41t65TypeCb with get, set

Property Value

Type: M41t65TypeCb
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.Date Property

IRD

M41t65Date Property

Date

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Date { get; set; }
Public Property Date As Byte
    Get
    Set
public:
property unsigned char Date {
    unsigned char get ();
    void set (unsigned char value);
}
member Date : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.DayOfWeek Property

IRD

M41t65DayOfWeek Property

Day Of Week

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DayOfWeek { get; set; }
Public Property DayOfWeek As Byte
    Get
    Set
public:
property unsigned char DayOfWeek {
    unsigned char get ();
    void set (unsigned char value);
}
member DayOfWeek : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.FrequencyTestFT Property

IRD

M41t65FrequencyTestFT Property

Frequency Test (FT)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FrequencyTestFT { get; set; }
Public Property FrequencyTestFT As Byte
    Get
    Set
public:
property unsigned char FrequencyTestFT {
    unsigned char get ();
    void set (unsigned char value);
}
member FrequencyTestFT : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.Hours Property

IRD

M41t65Hours Property

Hours

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Hours { get; set; }
Public Property Hours As Byte
    Get
    Set
public:
property unsigned char Hours {
    unsigned char get ();
    void set (unsigned char value);
}
member Hours : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.Minutes Property

IRD

M41t65Minutes Property

Minutes

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Minutes { get; set; }
Public Property Minutes As Byte
    Get
    Set
public:
property unsigned char Minutes {
    unsigned char get ();
    void set (unsigned char value);
}
member Minutes : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.Month Property

IRD

M41t65Month Property

Month

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Month { get; set; }
Public Property Month As Byte
    Get
    Set
public:
property unsigned char Month {
    unsigned char get ();
    void set (unsigned char value);
}
member Month : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.OscillatorFailInterruptEnableOFIE Property

IRD

M41t65OscillatorFailInterruptEnableOFIE Property

Oscillator Fail Interrupt Enable (OFIE)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OscillatorFailInterruptEnableOFIE { get; set; }
Public Property OscillatorFailInterruptEnableOFIE As Byte
    Get
    Set
public:
property unsigned char OscillatorFailInterruptEnableOFIE {
    unsigned char get ();
    void set (unsigned char value);
}
member OscillatorFailInterruptEnableOFIE : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.OscillatorFailOF Property

IRD

M41t65OscillatorFailOF Property

Oscillator Fail (OF)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OscillatorFailOF { get; set; }
Public Property OscillatorFailOF As Byte
    Get
    Set
public:
property unsigned char OscillatorFailOF {
    unsigned char get ();
    void set (unsigned char value);
}
member OscillatorFailOF : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.OutputLevelOUT Property

IRD

M41t65OutputLevelOUT Property

Output Level (OUT)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte OutputLevelOUT { get; set; }
Public Property OutputLevelOUT As Byte
    Get
    Set
public:
property unsigned char OutputLevelOUT {
    unsigned char get ();
    void set (unsigned char value);
}
member OutputLevelOUT : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.Property_10ths100thsOfSeconds Property

IRD

M41t65Property_10ths100thsOfSeconds Property

10ths/100ths Of Seconds

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Property_10ths100thsOfSeconds { get; set; }
Public Property Property_10ths100thsOfSeconds As Byte
    Get
    Set
public:
property unsigned char Property_10ths100thsOfSeconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Property_10ths100thsOfSeconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.Seconds Property

IRD

M41t65Seconds Property

Seconds

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Seconds { get; set; }
Public Property Seconds As Byte
    Get
    Set
public:
property unsigned char Seconds {
    unsigned char get ();
    void set (unsigned char value);
}
member Seconds : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.SignS Property

IRD

M41t65SignS Property

Sign (S)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t65TypeS SignS { get; set; }
Public Property SignS As M41t65TypeS
    Get
    Set
public:
property M41t65TypeS SignS {
    M41t65TypeS get ();
    void set (M41t65TypeS value);
}
member SignS : M41t65TypeS with get, set

Property Value

Type: M41t65TypeS
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.StopST Property

IRD

M41t65StopST Property

Stop (ST)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte StopST { get; set; }
Public Property StopST As Byte
    Get
    Set
public:
property unsigned char StopST {
    unsigned char get ();
    void set (unsigned char value);
}
member StopST : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.WatchdogFlagWDF Property

IRD

M41t65WatchdogFlagWDF Property

Watchdog Flag (WDF)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WatchdogFlagWDF { get; }
Public ReadOnly Property WatchdogFlagWDF As Byte
    Get
public:
property unsigned char WatchdogFlagWDF {
    unsigned char get ();
}
member WatchdogFlagWDF : byte with get

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.WatchdogMultiplierBMB Property

IRD

M41t65WatchdogMultiplierBMB Property

Watchdog Multiplier (BMB)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte WatchdogMultiplierBMB { get; set; }
Public Property WatchdogMultiplierBMB As Byte
    Get
    Set
public:
property unsigned char WatchdogMultiplierBMB {
    unsigned char get ();
    void set (unsigned char value);
}
member WatchdogMultiplierBMB : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.WatchdogResolutionRB Property

IRD

M41t65WatchdogResolutionRB Property

Watchdog Resolution (RB) (unit: Hz)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public M41t65TypeRb WatchdogResolutionRB { get; set; }
Public Property WatchdogResolutionRB As M41t65TypeRb
    Get
    Set
public:
property M41t65TypeRb WatchdogResolutionRB {
    M41t65TypeRb get ();
    void set (M41t65TypeRb value);
}
member WatchdogResolutionRB : M41t65TypeRb with get, set

Property Value

Type: M41t65TypeRb
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.Year Property

IRD

M41t65Year Property

Year

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Year { get; set; }
Public Property Year As Byte
    Get
    Set
public:
property unsigned char Year {
    unsigned char get ();
    void set (unsigned char value);
}
member Year : byte with get, set

Property Value

Type: Byte
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65 Methods

The M41t65 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.Flush Method

IRD

M41t65Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

M41t65 Class
telos.Ird.ST Namespace


M41t65.TypeCb Enumeration

IRD

M41t65TypeCb Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeCb
Public Enumeration TypeCb
public enum class TypeCb
type TypeCb
Members
Member name | Value | Description
Value_2000 | 0 | 2000
Value_2100 | 1 | 2100
Value_2200 | 2 | 2200
Value_2300 | 3 | 2300
See Also

Reference

telos.Ird.ST Namespace


M41t65.TypeRb Enumeration

IRD

M41t65TypeRb Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRb
Public Enumeration TypeRb
public enum class TypeRb
type TypeRb
Members
Member name | Value | Description
Value_16 | 0 | 16
Value_4 | 1 | 4
Value_1 | 2 | 1
Value_14 | 3 | 1/4
Value_160 | 4 | 1/60
Invalid | 5 | Invalid
See Also

Reference

telos.Ird.ST Namespace


M41t65.TypeRpt Enumeration

IRD

M41t65TypeRpt Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRpt
Public Enumeration TypeRpt
public enum class TypeRpt
type TypeRpt
Members
Member name | Value | Description
OncePerYear | 0 | Once Per Year
OncePerMonth | 22 | Once Per Month
OncePerDay | 24 | Once Per Day
OncePerHour | 28 | Once Per Hour
OncePerMinute | 30 | Once Per Minute
OncePerSecond | 31 | Once Per Second
See Also

Reference

telos.Ird.ST Namespace


M41t65.TypeS Enumeration

IRD

M41t65TypeS Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeS
Public Enumeration TypeS
public enum class TypeS
type TypeS
Members
Member name | Value | Description
NegativeCalibration | 0 | Negative Calibration
PositiveCalibration | 1 | Positive Calibration
See Also

Reference

telos.Ird.ST Namespace


Stmpe1208s Class

ST: STMPE 1208S
Inheritance Hierarchy
SystemObject
telos.Ird.STStmpe1208s

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Stmpe1208s
Public Class Stmpe1208s
public ref class Stmpe1208s
type Stmpe1208s =  class end

The Stmpe1208s type exposes the following members.

Constructors
 | Name | Description
Public method | Stmpe1208s | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BEEPFREQUENCY | BEEP_FREQUENCY
Public property | BEEPPERIOD | BEEP_PERIOD
Public property | CALIBRATEDIMPEDANCE0 | CALIBRATED_IMPEDANCE 0
Public property | CALIBRATEDIMPEDANCE1 | CALIBRATED_IMPEDANCE 1
Public property | CALIBRATEDIMPEDANCE10 | CALIBRATED_IMPEDANCE 10
Public property | CALIBRATEDIMPEDANCE11 | CALIBRATED_IMPEDANCE 11
Public property | CALIBRATEDIMPEDANCE2 | CALIBRATED_IMPEDANCE 2
Public property | CALIBRATEDIMPEDANCE3 | CALIBRATED_IMPEDANCE 3
Public property | CALIBRATEDIMPEDANCE4 | CALIBRATED_IMPEDANCE 4
Public property | CALIBRATEDIMPEDANCE5 | CALIBRATED_IMPEDANCE 5
Public property | CALIBRATEDIMPEDANCE6 | CALIBRATED_IMPEDANCE 6
Public property | CALIBRATEDIMPEDANCE7 | CALIBRATED_IMPEDANCE 7
Public property | CALIBRATEDIMPEDANCE8 | CALIBRATED_IMPEDANCE 8
Public property | CALIBRATEDIMPEDANCE9 | CALIBRATED_IMPEDANCE 9
Public property | CALINTERVAL | CAL_INTERVAL
Public property | CTRL1F2A | CTRL_1: F2A
Public property | CTRL1HDCC | CTRL_1: HDC_C
Public property | CTRL1HDCU | CTRL_1: HDC_U
Public property | CTRL1HOLDC | CTRL_1: HOLD_C
Public property | CTRL1NDIV | CTRL_1: NDIV
Public property | CTRL1PDIV | CTRL_1: PDIV (unit: kHz)
Public property | CTRL2BEEPEN | CTRL_2: BEEP_EN
Public property | CTRL2INTPOL | CTRL_2: INT_POL
Public property | CTRL2REGD | CTRL_2: REGD
Public property | CTRL2SCD | CTRL_2: SCD
Public property | ETCWAIT | ETC_WAIT
Public property | EVR | EVR
Public property | EXTINTENIO0 | EXT_INT_EN: IO-0
Public property | EXTINTENIO1 | EXT_INT_EN: IO-1
Public property | EXTINTENIO2 | EXT_INT_EN: IO-2
Public property | EXTINTENIO3 | EXT_INT_EN: IO-3
Public property | EXTINTENIO4 | EXT_INT_EN: IO-4
Public property | EXTINTENIO5 | EXT_INT_EN: IO-5
Public property | EXTINTENIO6 | EXT_INT_EN: IO-6
Public property | EXTINTENIO7 | EXT_INT_EN: IO-7
Public property | EXTINTPOLIO0 | EXT_INT_POL: IO-0
Public property | EXTINTPOLIO1 | EXT_INT_POL: IO-1
Public property | EXTINTPOLIO2 | EXT_INT_POL: IO-2
Public property | EXTINTPOLIO3 | EXT_INT_POL: IO-3
Public property | EXTINTPOLIO4 | EXT_INT_POL: IO-4
Public property | EXTINTPOLIO5 | EXT_INT_POL: IO-5
Public property | EXTINTPOLIO6 | EXT_INT_POL: IO-6
Public property | EXTINTPOLIO7 | EXT_INT_POL: IO-7
Public property | FEATURESELAFS1 | FEATURE_SEL: AFS1
Public property | FEATURESELAFS2 | FEATURE_SEL: AFS2
Public property | FEATURESELAFS3 | FEATURE_SEL: AFS3
Public property | FEATURESELFILTEREN | FEATURE_SEL: FILTER_EN
Public property | FILTERPERIOD | FILTER_PERIOD
Public property | FILTERTHRESHOLD | FILTER_THRESHOLD
Public property | GPIOCFGHIO10 | GPIO_CFG_H: IO-10
Public property | GPIOCFGHIO11 | GPIO_CFG_H: IO-11
Public property | GPIOCFGHIO8 | GPIO_CFG_H: IO-8
Public property | GPIOCFGHIO9 | GPIO_CFG_H: IO-9
Public property | GPIOCFGLIO0 | GPIO_CFG_L: IO-0
Public property | GPIOCFGLIO1 | GPIO_CFG_L: IO-1
Public property | GPIOCFGLIO2 | GPIO_CFG_L: IO-2
Public property | GPIOCFGLIO3 | GPIO_CFG_L: IO-3
Public property | GPIOCFGLIO4 | GPIO_CFG_L: IO-4
Public property | GPIOCFGLIO5 | GPIO_CFG_L: IO-5
Public property | GPIOCFGLIO6 | GPIO_CFG_L: IO-6
Public property | GPIOCFGLIO7 | GPIO_CFG_L: IO-7
Public property | GPIODIRHIO10 | GPIO_DIR_H: IO-10
Public property | GPIODIRHIO11 | GPIO_DIR_H: IO-11
Public property | GPIODIRHIO8 | GPIO_DIR_H: IO-8
Public property | GPIODIRHIO9 | GPIO_DIR_H: IO-9
Public property | GPIODIRLIO0 | GPIO_DIR_L: IO-0
Public property | GPIODIRLIO1 | GPIO_DIR_L: IO-1
Public property | GPIODIRLIO2 | GPIO_DIR_L: IO-2
Public property | GPIODIRLIO3 | GPIO_DIR_L: IO-3
Public property | GPIODIRLIO4 | GPIO_DIR_L: IO-4
Public property | GPIODIRLIO5 | GPIO_DIR_L: IO-5
Public property | GPIODIRLIO6 | GPIO_DIR_L: IO-6
Public property | GPIODIRLIO7 | GPIO_DIR_L: IO-7
Public property | GPIOINHIO10 | GPIO_IN_H: IO-10
Public property | GPIOINHIO11 | GPIO_IN_H: IO-11
Public property | GPIOINHIO8 | GPIO_IN_H: IO-8
Public property | GPIOINHIO9 | GPIO_IN_H: IO-9
Public property | GPIOINLIO0 | GPIO_IN_L: IO-0
Public property | GPIOINLIO1 | GPIO_IN_L: IO-1
Public property | GPIOINLIO2 | GPIO_IN_L: IO-2
Public property | GPIOINLIO3 | GPIO_IN_L: IO-3
Public property | GPIOINLIO4 | GPIO_IN_L: IO-4
Public property | GPIOINLIO5 | GPIO_IN_L: IO-5
Public property | GPIOINLIO6 | GPIO_IN_L: IO-6
Public property | GPIOINLIO7 | GPIO_IN_L: IO-7
Public property | GPIOSTAHIO10 | GPIO_STA_H: IO-10
Public property | GPIOSTAHIO11 | GPIO_STA_H: IO-11
Public property | GPIOSTAHIO8 | GPIO_STA_H: IO-8
Public property | GPIOSTAHIO9 | GPIO_STA_H: IO-9
Public property | GPIOSTALIO0 | GPIO_STA_L: IO-0
Public property | GPIOSTALIO1 | GPIO_STA_L: IO-1
Public property | GPIOSTALIO2 | GPIO_STA_L: IO-2
Public property | GPIOSTALIO3 | GPIO_STA_L: IO-3
Public property | GPIOSTALIO4 | GPIO_STA_L: IO-4
Public property | GPIOSTALIO5 | GPIO_STA_L: IO-5
Public property | GPIOSTALIO6 | GPIO_STA_L: IO-6
Public property | GPIOSTALIO7 | GPIO_STA_L: IO-7
Public property | IDLETIME | IDLE_TIME
Public property | IMPEDANCE0 | IMPEDANCE 0
Public property | IMPEDANCE1 | IMPEDANCE 1
Public property | IMPEDANCE10 | IMPEDANCE 10
Public property | IMPEDANCE11 | IMPEDANCE 11
Public property | IMPEDANCE2 | IMPEDANCE 2
Public property | IMPEDANCE3 | IMPEDANCE 3
Public property | IMPEDANCE4 | IMPEDANCE 4
Public property | IMPEDANCE5 | IMPEDANCE 5
Public property | IMPEDANCE6 | IMPEDANCE 6
Public property | IMPEDANCE7 | IMPEDANCE 7
Public property | IMPEDANCE8 | IMPEDANCE 8
Public property | IMPEDANCE9 | IMPEDANCE 9
Public property | INTCLRA2I | INT_CLR: A2I
Public property | INTCLREINT | INT_CLR: EINT
Public property | INTCLREOC | INT_CLR: EOC
Public property | INTCLRI2A | INT_CLR: I2A
Public property | INTCLRTouch | INT_CLR: Touch
Public property | INTEGRATIONTIME | INTEGRATION_TIME
Public property | INTMASKA2I | INT_MASK: A2I
Public property | INTMASKEINT | INT_MASK: EINT
Public property | INTMASKEOC | INT_MASK: EOC
Public property | INTMASKI2A | INT_MASK: I2A
Public property | INTMASKTouch | INT_MASK: Touch
Public property | INTPENDINGA21 | INT_PENDING: A21
Public property | INTPENDINGEOC | INT_PENDING: EOC
Public property | INTPENDINGI2A | INT_PENDING: I2A
Public property | INTPENDINGTouch | INT_PENDING: Touch
Public property | REFERENCEDELAY | REFERENCE_DELAY
Public property | STATUSIDLE | STATUS: IDLE
Public property | STRENGTH0 | STRENGTH 0
Public property | STRENGTH1 | STRENGTH 1
Public property | STRENGTH10 | STRENGTH 10
Public property | STRENGTH11 | STRENGTH 11
Public property | STRENGTH2 | STRENGTH 2
Public property | STRENGTH3 | STRENGTH 3
Public property | STRENGTH4 | STRENGTH 4
Public property | STRENGTH5 | STRENGTH 5
Public property | STRENGTH6 | STRENGTH 6
Public property | STRENGTH7 | STRENGTH 7
Public property | STRENGTH8 | STRENGTH 8
Public property | STRENGTH9 | STRENGTH 9
Public property | STRENGTHTHRES0 | STRENGTH_THRES 0
Public property | STRENGTHTHRES1 | STRENGTH_THRES 1
Public property | STRENGTHTHRES10 | STRENGTH_THRES 10
Public property | STRENGTHTHRES11 | STRENGTH_THRES 11
Public property | STRENGTHTHRES2 | STRENGTH_THRES 2
Public property | STRENGTHTHRES3 | STRENGTH_THRES 3
Public property | STRENGTHTHRES4 | STRENGTH_THRES 4
Public property | STRENGTHTHRES5 | STRENGTH_THRES 5
Public property | STRENGTHTHRES6 | STRENGTH_THRES 6
Public property | STRENGTHTHRES7 | STRENGTH_THRES 7
Public property | STRENGTHTHRES8 | STRENGTH_THRES 8
Public property | STRENGTHTHRES9 | STRENGTH_THRES 9
Public property | TOUCHBYTEHCH10 | TOUCH_BYTE_H: CH10
Public property | TOUCHBYTEHCH11 | TOUCH_BYTE_H: CH11
Public property | TOUCHBYTEHCH8 | TOUCH_BYTE_H: CH8
Public property | TOUCHBYTEHCH9 | TOUCH_BYTE_H: CH9
Public property | TOUCHBYTELCH0 | TOUCH_BYTE_L: CH0
Public property | TOUCHBYTELCH1 | TOUCH_BYTE_L: CH1
Public property | TOUCHBYTELCH2 | TOUCH_BYTE_L: CH2
Public property | TOUCHBYTELCH3 | TOUCH_BYTE_L: CH3
Public property | TOUCHBYTELCH4 | TOUCH_BYTE_L: CH4
Public property | TOUCHBYTELCH5 | TOUCH_BYTE_L: CH5
Public property | TOUCHBYTELCH6 | TOUCH_BYTE_L: CH6
Public property | TOUCHBYTELCH7 | TOUCH_BYTE_L: CH7
Public property | TVR0 | TVR 0
Public property | TVR1 | TVR 1
Public property | TVR10 | TVR 10
Public property | TVR11 | TVR 11
Public property | TVR2 | TVR 2
Public property | TVR3 | TVR 3
Public property | TVR4 | TVR 4
Public property | TVR5 | TVR 5
Public property | TVR6 | TVR 6
Public property | TVR7 | TVR 7
Public property | TVR8 | TVR 8
Public property | TVR9 | TVR 9
Top
Methods
 | Name | Description
Public method | BIASOFF | BIAS_OFF
Public method | BIASON | BIAS_ON
Public method | CLKSRCEXTERNAL | CLK_SRC_EXTERNAL
Public method | CLKSRCINTERNAL | CLK_SRC_INTERNAL
Public method | ColdReset | Cold Reset
Public method | EnterSleep | Enter Sleep
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WakeUp | Wake Up
Public method | WarmReset | Warm Reset
Top
Remarks
S-Touch 12-Channel CapacitiveTouchkey Controller
See Also

Reference

telos.Ird.ST Namespace


Stmpe1208s Constructor

Constructor

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208s(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Stmpe1208s(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Stmpe1208s

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s Properties

The Stmpe1208s type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BEEPFREQUENCY | BEEP_FREQUENCY
Public property | BEEPPERIOD | BEEP_PERIOD
Public property | CALIBRATEDIMPEDANCE0 | CALIBRATED_IMPEDANCE 0
Public property | CALIBRATEDIMPEDANCE1 | CALIBRATED_IMPEDANCE 1
Public property | CALIBRATEDIMPEDANCE10 | CALIBRATED_IMPEDANCE 10
Public property | CALIBRATEDIMPEDANCE11 | CALIBRATED_IMPEDANCE 11
Public property | CALIBRATEDIMPEDANCE2 | CALIBRATED_IMPEDANCE 2
Public property | CALIBRATEDIMPEDANCE3 | CALIBRATED_IMPEDANCE 3
Public property | CALIBRATEDIMPEDANCE4 | CALIBRATED_IMPEDANCE 4
Public property | CALIBRATEDIMPEDANCE5 | CALIBRATED_IMPEDANCE 5
Public property | CALIBRATEDIMPEDANCE6 | CALIBRATED_IMPEDANCE 6
Public property | CALIBRATEDIMPEDANCE7 | CALIBRATED_IMPEDANCE 7
Public property | CALIBRATEDIMPEDANCE8 | CALIBRATED_IMPEDANCE 8
Public property | CALIBRATEDIMPEDANCE9 | CALIBRATED_IMPEDANCE 9
Public property | CALINTERVAL | CAL_INTERVAL
Public property | CTRL1F2A | CTRL_1: F2A
Public property | CTRL1HDCC | CTRL_1: HDC_C
Public property | CTRL1HDCU | CTRL_1: HDC_U
Public property | CTRL1HOLDC | CTRL_1: HOLD_C
Public property | CTRL1NDIV | CTRL_1: NDIV
Public property | CTRL1PDIV | CTRL_1: PDIV (unit: kHz)
Public property | CTRL2BEEPEN | CTRL_2: BEEP_EN
Public property | CTRL2INTPOL | CTRL_2: INT_POL
Public property | CTRL2REGD | CTRL_2: REGD
Public property | CTRL2SCD | CTRL_2: SCD
Public property | ETCWAIT | ETC_WAIT
Public property | EVR | EVR
Public property | EXTINTENIO0 | EXT_INT_EN: IO-0
Public property | EXTINTENIO1 | EXT_INT_EN: IO-1
Public property | EXTINTENIO2 | EXT_INT_EN: IO-2
Public property | EXTINTENIO3 | EXT_INT_EN: IO-3
Public property | EXTINTENIO4 | EXT_INT_EN: IO-4
Public property | EXTINTENIO5 | EXT_INT_EN: IO-5
Public property | EXTINTENIO6 | EXT_INT_EN: IO-6
Public property | EXTINTENIO7 | EXT_INT_EN: IO-7
Public property | EXTINTPOLIO0 | EXT_INT_POL: IO-0
Public property | EXTINTPOLIO1 | EXT_INT_POL: IO-1
Public property | EXTINTPOLIO2 | EXT_INT_POL: IO-2
Public property | EXTINTPOLIO3 | EXT_INT_POL: IO-3
Public property | EXTINTPOLIO4 | EXT_INT_POL: IO-4
Public property | EXTINTPOLIO5 | EXT_INT_POL: IO-5
Public property | EXTINTPOLIO6 | EXT_INT_POL: IO-6
Public property | EXTINTPOLIO7 | EXT_INT_POL: IO-7
Public property | FEATURESELAFS1 | FEATURE_SEL: AFS1
Public property | FEATURESELAFS2 | FEATURE_SEL: AFS2
Public property | FEATURESELAFS3 | FEATURE_SEL: AFS3
Public property | FEATURESELFILTEREN | FEATURE_SEL: FILTER_EN
Public property | FILTERPERIOD | FILTER_PERIOD
Public property | FILTERTHRESHOLD | FILTER_THRESHOLD
Public property | GPIOCFGHIO10 | GPIO_CFG_H: IO-10
Public property | GPIOCFGHIO11 | GPIO_CFG_H: IO-11
Public property | GPIOCFGHIO8 | GPIO_CFG_H: IO-8
Public property | GPIOCFGHIO9 | GPIO_CFG_H: IO-9
Public property | GPIOCFGLIO0 | GPIO_CFG_L: IO-0
Public property | GPIOCFGLIO1 | GPIO_CFG_L: IO-1
Public property | GPIOCFGLIO2 | GPIO_CFG_L: IO-2
Public property | GPIOCFGLIO3 | GPIO_CFG_L: IO-3
Public property | GPIOCFGLIO4 | GPIO_CFG_L: IO-4
Public property | GPIOCFGLIO5 | GPIO_CFG_L: IO-5
Public property | GPIOCFGLIO6 | GPIO_CFG_L: IO-6
Public property | GPIOCFGLIO7 | GPIO_CFG_L: IO-7
Public property | GPIODIRHIO10 | GPIO_DIR_H: IO-10
Public property | GPIODIRHIO11 | GPIO_DIR_H: IO-11
Public property | GPIODIRHIO8 | GPIO_DIR_H: IO-8
Public property | GPIODIRHIO9 | GPIO_DIR_H: IO-9
Public property | GPIODIRLIO0 | GPIO_DIR_L: IO-0
Public property | GPIODIRLIO1 | GPIO_DIR_L: IO-1
Public property | GPIODIRLIO2 | GPIO_DIR_L: IO-2
Public property | GPIODIRLIO3 | GPIO_DIR_L: IO-3
Public property | GPIODIRLIO4 | GPIO_DIR_L: IO-4
Public property | GPIODIRLIO5 | GPIO_DIR_L: IO-5
Public property | GPIODIRLIO6 | GPIO_DIR_L: IO-6
Public property | GPIODIRLIO7 | GPIO_DIR_L: IO-7
Public property | GPIOINHIO10 | GPIO_IN_H: IO-10
Public property | GPIOINHIO11 | GPIO_IN_H: IO-11
Public property | GPIOINHIO8 | GPIO_IN_H: IO-8
Public property | GPIOINHIO9 | GPIO_IN_H: IO-9
Public property | GPIOINLIO0 | GPIO_IN_L: IO-0
Public property | GPIOINLIO1 | GPIO_IN_L: IO-1
Public property | GPIOINLIO2 | GPIO_IN_L: IO-2
Public property | GPIOINLIO3 | GPIO_IN_L: IO-3
Public property | GPIOINLIO4 | GPIO_IN_L: IO-4
Public property | GPIOINLIO5 | GPIO_IN_L: IO-5
Public property | GPIOINLIO6 | GPIO_IN_L: IO-6
Public property | GPIOINLIO7 | GPIO_IN_L: IO-7
Public property | GPIOSTAHIO10 | GPIO_STA_H: IO-10
Public property | GPIOSTAHIO11 | GPIO_STA_H: IO-11
Public property | GPIOSTAHIO8 | GPIO_STA_H: IO-8
Public property | GPIOSTAHIO9 | GPIO_STA_H: IO-9
Public property | GPIOSTALIO0 | GPIO_STA_L: IO-0
Public property | GPIOSTALIO1 | GPIO_STA_L: IO-1
Public property | GPIOSTALIO2 | GPIO_STA_L: IO-2
Public property | GPIOSTALIO3 | GPIO_STA_L: IO-3
Public property | GPIOSTALIO4 | GPIO_STA_L: IO-4
Public property | GPIOSTALIO5 | GPIO_STA_L: IO-5
Public property | GPIOSTALIO6 | GPIO_STA_L: IO-6
Public property | GPIOSTALIO7 | GPIO_STA_L: IO-7
Public property | IDLETIME | IDLE_TIME
Public property | IMPEDANCE0 | IMPEDANCE 0
Public property | IMPEDANCE1 | IMPEDANCE 1
Public property | IMPEDANCE10 | IMPEDANCE 10
Public property | IMPEDANCE11 | IMPEDANCE 11
Public property | IMPEDANCE2 | IMPEDANCE 2
Public property | IMPEDANCE3 | IMPEDANCE 3
Public property | IMPEDANCE4 | IMPEDANCE 4
Public property | IMPEDANCE5 | IMPEDANCE 5
Public property | IMPEDANCE6 | IMPEDANCE 6
Public property | IMPEDANCE7 | IMPEDANCE 7
Public property | IMPEDANCE8 | IMPEDANCE 8
Public property | IMPEDANCE9 | IMPEDANCE 9
Public property | INTCLRA2I | INT_CLR: A2I
Public property | INTCLREINT | INT_CLR: EINT
Public property | INTCLREOC | INT_CLR: EOC
Public property | INTCLRI2A | INT_CLR: I2A
Public property | INTCLRTouch | INT_CLR: Touch
Public property | INTEGRATIONTIME | INTEGRATION_TIME
Public property | INTMASKA2I | INT_MASK: A2I
Public property | INTMASKEINT | INT_MASK: EINT
Public property | INTMASKEOC | INT_MASK: EOC
Public property | INTMASKI2A | INT_MASK: I2A
Public property | INTMASKTouch | INT_MASK: Touch
Public property | INTPENDINGA21 | INT_PENDING: A21
Public property | INTPENDINGEOC | INT_PENDING: EOC
Public property | INTPENDINGI2A | INT_PENDING: I2A
Public property | INTPENDINGTouch | INT_PENDING: Touch
Public property | REFERENCEDELAY | REFERENCE_DELAY
Public property | STATUSIDLE | STATUS: IDLE
Public property | STRENGTH0 | STRENGTH 0
Public property | STRENGTH1 | STRENGTH 1
Public property | STRENGTH10 | STRENGTH 10
Public property | STRENGTH11 | STRENGTH 11
Public property | STRENGTH2 | STRENGTH 2
Public property | STRENGTH3 | STRENGTH 3
Public property | STRENGTH4 | STRENGTH 4
Public property | STRENGTH5 | STRENGTH 5
Public property | STRENGTH6 | STRENGTH 6
Public property | STRENGTH7 | STRENGTH 7
Public property | STRENGTH8 | STRENGTH 8
Public property | STRENGTH9 | STRENGTH 9
Public property | STRENGTHTHRES0 | STRENGTH_THRES 0
Public property | STRENGTHTHRES1 | STRENGTH_THRES 1
Public property | STRENGTHTHRES10 | STRENGTH_THRES 10
Public property | STRENGTHTHRES11 | STRENGTH_THRES 11
Public property | STRENGTHTHRES2 | STRENGTH_THRES 2
Public property | STRENGTHTHRES3 | STRENGTH_THRES 3
Public property | STRENGTHTHRES4 | STRENGTH_THRES 4
Public property | STRENGTHTHRES5 | STRENGTH_THRES 5
Public property | STRENGTHTHRES6 | STRENGTH_THRES 6
Public property | STRENGTHTHRES7 | STRENGTH_THRES 7
Public property | STRENGTHTHRES8 | STRENGTH_THRES 8
Public property | STRENGTHTHRES9 | STRENGTH_THRES 9
Public property | TOUCHBYTEHCH10 | TOUCH_BYTE_H: CH10
Public property | TOUCHBYTEHCH11 | TOUCH_BYTE_H: CH11
Public property | TOUCHBYTEHCH8 | TOUCH_BYTE_H: CH8
Public property | TOUCHBYTEHCH9 | TOUCH_BYTE_H: CH9
Public property | TOUCHBYTELCH0 | TOUCH_BYTE_L: CH0
Public property | TOUCHBYTELCH1 | TOUCH_BYTE_L: CH1
Public property | TOUCHBYTELCH2 | TOUCH_BYTE_L: CH2
Public property | TOUCHBYTELCH3 | TOUCH_BYTE_L: CH3
Public property | TOUCHBYTELCH4 | TOUCH_BYTE_L: CH4
Public property | TOUCHBYTELCH5 | TOUCH_BYTE_L: CH5
Public property | TOUCHBYTELCH6 | TOUCH_BYTE_L: CH6
Public property | TOUCHBYTELCH7 | TOUCH_BYTE_L: CH7
Public property | TVR0 | TVR 0
Public property | TVR1 | TVR 1
Public property | TVR10 | TVR 10
Public property | TVR11 | TVR 11
Public property | TVR2 | TVR 2
Public property | TVR3 | TVR 3
Public property | TVR4 | TVR 4
Public property | TVR5 | TVR 5
Public property | TVR6 | TVR 6
Public property | TVR7 | TVR 7
Public property | TVR8 | TVR 8
Public property | TVR9 | TVR 9
Top
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.AutoFlush Property

IRD

Stmpe1208sAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.BEEPFREQUENCY Property

IRD

Stmpe1208sBEEPFREQUENCY Property

BEEP_FREQUENCY

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 BEEPFREQUENCY { get; set; }
Public Property BEEPFREQUENCY As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 BEEPFREQUENCY {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member BEEPFREQUENCY : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.BEEPPERIOD Property

IRD

Stmpe1208sBEEPPERIOD Property

BEEP_PERIOD

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 BEEPPERIOD { get; set; }
Public Property BEEPPERIOD As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 BEEPPERIOD {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member BEEPPERIOD : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CALIBRATEDIMPEDANCE0 Property

IRD

Stmpe1208sCALIBRATEDIMPEDANCE0 Property

CALIBRATED_IMPEDANCE 0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 CALIBRATEDIMPEDANCE0 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE0 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 CALIBRATEDIMPEDANCE0 {
    Stmpe1208sUint8 get ();
}
member CALIBRATEDIMPEDANCE0 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CALIBRATEDIMPEDANCE1 Property

IRD

Stmpe1208sCALIBRATEDIMPEDANCE1 Property

CALIBRATED_IMPEDANCE 1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 CALIBRATEDIMPEDANCE1 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE1 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 CALIBRATEDIMPEDANCE1 {
    Stmpe1208sUint8 get ();
}
member CALIBRATEDIMPEDANCE1 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CALIBRATEDIMPEDANCE10 Property

IRD

Stmpe1208sCALIBRATEDIMPEDANCE10 Property

CALIBRATED_IMPEDANCE 10

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 CALIBRATEDIMPEDANCE10 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE10 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 CALIBRATEDIMPEDANCE10 {
    Stmpe1208sUint8 get ();
}
member CALIBRATEDIMPEDANCE10 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CALIBRATEDIMPEDANCE11 Property

IRD

Stmpe1208sCALIBRATEDIMPEDANCE11 Property

CALIBRATED_IMPEDANCE 11

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 CALIBRATEDIMPEDANCE11 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE11 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 CALIBRATEDIMPEDANCE11 {
    Stmpe1208sUint8 get ();
}
member CALIBRATEDIMPEDANCE11 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CALIBRATEDIMPEDANCE2 Property

IRD

Stmpe1208sCALIBRATEDIMPEDANCE2 Property

CALIBRATED_IMPEDANCE 2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 CALIBRATEDIMPEDANCE2 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE2 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 CALIBRATEDIMPEDANCE2 {
    Stmpe1208sUint8 get ();
}
member CALIBRATEDIMPEDANCE2 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CALIBRATEDIMPEDANCE3 Property

IRD

Stmpe1208sCALIBRATEDIMPEDANCE3 Property

CALIBRATED_IMPEDANCE 3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 CALIBRATEDIMPEDANCE3 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE3 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 CALIBRATEDIMPEDANCE3 {
    Stmpe1208sUint8 get ();
}
member CALIBRATEDIMPEDANCE3 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CALIBRATEDIMPEDANCE4 Property

IRD

Stmpe1208sCALIBRATEDIMPEDANCE4 Property

CALIBRATED_IMPEDANCE 4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 CALIBRATEDIMPEDANCE4 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE4 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 CALIBRATEDIMPEDANCE4 {
    Stmpe1208sUint8 get ();
}
member CALIBRATEDIMPEDANCE4 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CALIBRATEDIMPEDANCE5 Property

IRD

Stmpe1208sCALIBRATEDIMPEDANCE5 Property

CALIBRATED_IMPEDANCE 5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 CALIBRATEDIMPEDANCE5 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE5 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 CALIBRATEDIMPEDANCE5 {
    Stmpe1208sUint8 get ();
}
member CALIBRATEDIMPEDANCE5 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CALIBRATEDIMPEDANCE6 Property

IRD

Stmpe1208sCALIBRATEDIMPEDANCE6 Property

CALIBRATED_IMPEDANCE 6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 CALIBRATEDIMPEDANCE6 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE6 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 CALIBRATEDIMPEDANCE6 {
    Stmpe1208sUint8 get ();
}
member CALIBRATEDIMPEDANCE6 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CALIBRATEDIMPEDANCE7 Property

IRD

Stmpe1208sCALIBRATEDIMPEDANCE7 Property

CALIBRATED_IMPEDANCE 7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 CALIBRATEDIMPEDANCE7 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE7 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 CALIBRATEDIMPEDANCE7 {
    Stmpe1208sUint8 get ();
}
member CALIBRATEDIMPEDANCE7 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CALIBRATEDIMPEDANCE8 Property

IRD

Stmpe1208sCALIBRATEDIMPEDANCE8 Property

CALIBRATED_IMPEDANCE 8

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 CALIBRATEDIMPEDANCE8 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE8 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 CALIBRATEDIMPEDANCE8 {
    Stmpe1208sUint8 get ();
}
member CALIBRATEDIMPEDANCE8 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CALIBRATEDIMPEDANCE9 Property

IRD

Stmpe1208sCALIBRATEDIMPEDANCE9 Property

CALIBRATED_IMPEDANCE 9

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 CALIBRATEDIMPEDANCE9 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE9 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 CALIBRATEDIMPEDANCE9 {
    Stmpe1208sUint8 get ();
}
member CALIBRATEDIMPEDANCE9 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CALINTERVAL Property

IRD

Stmpe1208sCALINTERVAL Property

CAL_INTERVAL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 CALINTERVAL { get; set; }
Public Property CALINTERVAL As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 CALINTERVAL {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member CALINTERVAL : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CTRL1F2A Property

IRD

Stmpe1208sCTRL1F2A Property

CTRL_1: F2A

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CTRL1F2A { get; set; }
Public Property CTRL1F2A As Byte
    Get
    Set
public:
property unsigned char CTRL1F2A {
    unsigned char get ();
    void set (unsigned char value);
}
member CTRL1F2A : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CTRL1HDCC Property

IRD

Stmpe1208sCTRL1HDCC Property

CTRL_1: HDC_C

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CTRL1HDCC { get; set; }
Public Property CTRL1HDCC As Byte
    Get
    Set
public:
property unsigned char CTRL1HDCC {
    unsigned char get ();
    void set (unsigned char value);
}
member CTRL1HDCC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CTRL1HDCU Property

IRD

Stmpe1208sCTRL1HDCU Property

CTRL_1: HDC_U

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CTRL1HDCU { get; set; }
Public Property CTRL1HDCU As Byte
    Get
    Set
public:
property unsigned char CTRL1HDCU {
    unsigned char get ();
    void set (unsigned char value);
}
member CTRL1HDCU : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CTRL1HOLDC Property

IRD

Stmpe1208sCTRL1HOLDC Property

CTRL_1: HOLD_C

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sCtrl1HoldC CTRL1HOLDC { get; set; }
Public Property CTRL1HOLDC As Stmpe1208sCtrl1HoldC
    Get
    Set
public:
property Stmpe1208sCtrl1HoldC CTRL1HOLDC {
    Stmpe1208sCtrl1HoldC get ();
    void set (Stmpe1208sCtrl1HoldC value);
}
member CTRL1HOLDC : Stmpe1208sCtrl1HoldC with get, set

Property Value

Type: Stmpe1208sCtrl1HoldC
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CTRL1NDIV Property

IRD

Stmpe1208sCTRL1NDIV Property

CTRL_1: NDIV

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sCtrl1Ndiv CTRL1NDIV { get; set; }
Public Property CTRL1NDIV As Stmpe1208sCtrl1Ndiv
    Get
    Set
public:
property Stmpe1208sCtrl1Ndiv CTRL1NDIV {
    Stmpe1208sCtrl1Ndiv get ();
    void set (Stmpe1208sCtrl1Ndiv value);
}
member CTRL1NDIV : Stmpe1208sCtrl1Ndiv with get, set

Property Value

Type: Stmpe1208sCtrl1Ndiv
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CTRL1PDIV Property

IRD

Stmpe1208sCTRL1PDIV Property

CTRL_1: PDIV (unit: kHz)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sCtrl1Pdiv CTRL1PDIV { get; set; }
Public Property CTRL1PDIV As Stmpe1208sCtrl1Pdiv
    Get
    Set
public:
property Stmpe1208sCtrl1Pdiv CTRL1PDIV {
    Stmpe1208sCtrl1Pdiv get ();
    void set (Stmpe1208sCtrl1Pdiv value);
}
member CTRL1PDIV : Stmpe1208sCtrl1Pdiv with get, set

Property Value

Type: Stmpe1208sCtrl1Pdiv
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CTRL2BEEPEN Property

IRD

Stmpe1208sCTRL2BEEPEN Property

CTRL_2: BEEP_EN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sCtrl2BeepEn CTRL2BEEPEN { get; set; }
Public Property CTRL2BEEPEN As Stmpe1208sCtrl2BeepEn
    Get
    Set
public:
property Stmpe1208sCtrl2BeepEn CTRL2BEEPEN {
    Stmpe1208sCtrl2BeepEn get ();
    void set (Stmpe1208sCtrl2BeepEn value);
}
member CTRL2BEEPEN : Stmpe1208sCtrl2BeepEn with get, set

Property Value

Type: Stmpe1208sCtrl2BeepEn
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CTRL2INTPOL Property

IRD

Stmpe1208sCTRL2INTPOL Property

CTRL_2: INT_POL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sCtrl2IntPol CTRL2INTPOL { get; set; }
Public Property CTRL2INTPOL As Stmpe1208sCtrl2IntPol
    Get
    Set
public:
property Stmpe1208sCtrl2IntPol CTRL2INTPOL {
    Stmpe1208sCtrl2IntPol get ();
    void set (Stmpe1208sCtrl2IntPol value);
}
member CTRL2INTPOL : Stmpe1208sCtrl2IntPol with get, set

Property Value

Type: Stmpe1208sCtrl2IntPol
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CTRL2REGD Property

IRD

Stmpe1208sCTRL2REGD Property

CTRL_2: REGD

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sCtrl2Regd CTRL2REGD { get; set; }
Public Property CTRL2REGD As Stmpe1208sCtrl2Regd
    Get
    Set
public:
property Stmpe1208sCtrl2Regd CTRL2REGD {
    Stmpe1208sCtrl2Regd get ();
    void set (Stmpe1208sCtrl2Regd value);
}
member CTRL2REGD : Stmpe1208sCtrl2Regd with get, set

Property Value

Type: Stmpe1208sCtrl2Regd
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CTRL2SCD Property

IRD

Stmpe1208sCTRL2SCD Property

CTRL_2: SCD

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sCtrl2Scd CTRL2SCD { get; set; }
Public Property CTRL2SCD As Stmpe1208sCtrl2Scd
    Get
    Set
public:
property Stmpe1208sCtrl2Scd CTRL2SCD {
    Stmpe1208sCtrl2Scd get ();
    void set (Stmpe1208sCtrl2Scd value);
}
member CTRL2SCD : Stmpe1208sCtrl2Scd with get, set

Property Value

Type: Stmpe1208sCtrl2Scd
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.ETCWAIT Property

IRD

Stmpe1208sETCWAIT Property

ETC_WAIT

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 ETCWAIT { get; set; }
Public Property ETCWAIT As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 ETCWAIT {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member ETCWAIT : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.EVR Property

IRD

Stmpe1208sEVR Property

EVR

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EVR { get; set; }
Public Property EVR As Byte
    Get
    Set
public:
property unsigned char EVR {
    unsigned char get ();
    void set (unsigned char value);
}
member EVR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.EXTINTENIO0 Property

IRD

Stmpe1208sEXTINTENIO0 Property

EXT_INT_EN: IO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sEnableDisable EXTINTENIO0 { get; set; }
Public Property EXTINTENIO0 As Stmpe1208sEnableDisable
    Get
    Set
public:
property Stmpe1208sEnableDisable EXTINTENIO0 {
    Stmpe1208sEnableDisable get ();
    void set (Stmpe1208sEnableDisable value);
}
member EXTINTENIO0 : Stmpe1208sEnableDisable with get, set

Property Value

Type: Stmpe1208sEnableDisable
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.EXTINTENIO1 Property

IRD

Stmpe1208sEXTINTENIO1 Property

EXT_INT_EN: IO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sEnableDisable EXTINTENIO1 { get; set; }
Public Property EXTINTENIO1 As Stmpe1208sEnableDisable
    Get
    Set
public:
property Stmpe1208sEnableDisable EXTINTENIO1 {
    Stmpe1208sEnableDisable get ();
    void set (Stmpe1208sEnableDisable value);
}
member EXTINTENIO1 : Stmpe1208sEnableDisable with get, set

Property Value

Type: Stmpe1208sEnableDisable
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.EXTINTENIO2 Property

IRD

Stmpe1208sEXTINTENIO2 Property

EXT_INT_EN: IO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sEnableDisable EXTINTENIO2 { get; set; }
Public Property EXTINTENIO2 As Stmpe1208sEnableDisable
    Get
    Set
public:
property Stmpe1208sEnableDisable EXTINTENIO2 {
    Stmpe1208sEnableDisable get ();
    void set (Stmpe1208sEnableDisable value);
}
member EXTINTENIO2 : Stmpe1208sEnableDisable with get, set

Property Value

Type: Stmpe1208sEnableDisable
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.EXTINTENIO3 Property

IRD

Stmpe1208sEXTINTENIO3 Property

EXT_INT_EN: IO-3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sEnableDisable EXTINTENIO3 { get; set; }
Public Property EXTINTENIO3 As Stmpe1208sEnableDisable
    Get
    Set
public:
property Stmpe1208sEnableDisable EXTINTENIO3 {
    Stmpe1208sEnableDisable get ();
    void set (Stmpe1208sEnableDisable value);
}
member EXTINTENIO3 : Stmpe1208sEnableDisable with get, set

Property Value

Type: Stmpe1208sEnableDisable
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.EXTINTENIO4 Property

IRD

Stmpe1208sEXTINTENIO4 Property

EXT_INT_EN: IO-4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sEnableDisable EXTINTENIO4 { get; set; }
Public Property EXTINTENIO4 As Stmpe1208sEnableDisable
    Get
    Set
public:
property Stmpe1208sEnableDisable EXTINTENIO4 {
    Stmpe1208sEnableDisable get ();
    void set (Stmpe1208sEnableDisable value);
}
member EXTINTENIO4 : Stmpe1208sEnableDisable with get, set

Property Value

Type: Stmpe1208sEnableDisable
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.EXTINTENIO5 Property

IRD

Stmpe1208sEXTINTENIO5 Property

EXT_INT_EN: IO-5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sEnableDisable EXTINTENIO5 { get; set; }
Public Property EXTINTENIO5 As Stmpe1208sEnableDisable
    Get
    Set
public:
property Stmpe1208sEnableDisable EXTINTENIO5 {
    Stmpe1208sEnableDisable get ();
    void set (Stmpe1208sEnableDisable value);
}
member EXTINTENIO5 : Stmpe1208sEnableDisable with get, set

Property Value

Type: Stmpe1208sEnableDisable
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.EXTINTENIO6 Property

IRD

Stmpe1208sEXTINTENIO6 Property

EXT_INT_EN: IO-6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sEnableDisable EXTINTENIO6 { get; set; }
Public Property EXTINTENIO6 As Stmpe1208sEnableDisable
    Get
    Set
public:
property Stmpe1208sEnableDisable EXTINTENIO6 {
    Stmpe1208sEnableDisable get ();
    void set (Stmpe1208sEnableDisable value);
}
member EXTINTENIO6 : Stmpe1208sEnableDisable with get, set

Property Value

Type: Stmpe1208sEnableDisable
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.EXTINTENIO7 Property

IRD

Stmpe1208sEXTINTENIO7 Property

EXT_INT_EN: IO-7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sEnableDisable EXTINTENIO7 { get; set; }
Public Property EXTINTENIO7 As Stmpe1208sEnableDisable
    Get
    Set
public:
property Stmpe1208sEnableDisable EXTINTENIO7 {
    Stmpe1208sEnableDisable get ();
    void set (Stmpe1208sEnableDisable value);
}
member EXTINTENIO7 : Stmpe1208sEnableDisable with get, set

Property Value

Type: Stmpe1208sEnableDisable
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.EXTINTPOLIO0 Property

IRD

Stmpe1208sEXTINTPOLIO0 Property

EXT_INT_POL: IO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sExtIntPol EXTINTPOLIO0 { get; set; }
Public Property EXTINTPOLIO0 As Stmpe1208sExtIntPol
    Get
    Set
public:
property Stmpe1208sExtIntPol EXTINTPOLIO0 {
    Stmpe1208sExtIntPol get ();
    void set (Stmpe1208sExtIntPol value);
}
member EXTINTPOLIO0 : Stmpe1208sExtIntPol with get, set

Property Value

Type: Stmpe1208sExtIntPol
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.EXTINTPOLIO1 Property

IRD

Stmpe1208sEXTINTPOLIO1 Property

EXT_INT_POL: IO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sExtIntPol EXTINTPOLIO1 { get; set; }
Public Property EXTINTPOLIO1 As Stmpe1208sExtIntPol
    Get
    Set
public:
property Stmpe1208sExtIntPol EXTINTPOLIO1 {
    Stmpe1208sExtIntPol get ();
    void set (Stmpe1208sExtIntPol value);
}
member EXTINTPOLIO1 : Stmpe1208sExtIntPol with get, set

Property Value

Type: Stmpe1208sExtIntPol
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.EXTINTPOLIO2 Property

IRD

Stmpe1208sEXTINTPOLIO2 Property

EXT_INT_POL: IO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sExtIntPol EXTINTPOLIO2 { get; set; }
Public Property EXTINTPOLIO2 As Stmpe1208sExtIntPol
    Get
    Set
public:
property Stmpe1208sExtIntPol EXTINTPOLIO2 {
    Stmpe1208sExtIntPol get ();
    void set (Stmpe1208sExtIntPol value);
}
member EXTINTPOLIO2 : Stmpe1208sExtIntPol with get, set

Property Value

Type: Stmpe1208sExtIntPol
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.EXTINTPOLIO3 Property

IRD

Stmpe1208sEXTINTPOLIO3 Property

EXT_INT_POL: IO-3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sExtIntPol EXTINTPOLIO3 { get; set; }
Public Property EXTINTPOLIO3 As Stmpe1208sExtIntPol
    Get
    Set
public:
property Stmpe1208sExtIntPol EXTINTPOLIO3 {
    Stmpe1208sExtIntPol get ();
    void set (Stmpe1208sExtIntPol value);
}
member EXTINTPOLIO3 : Stmpe1208sExtIntPol with get, set

Property Value

Type: Stmpe1208sExtIntPol
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.EXTINTPOLIO4 Property

IRD

Stmpe1208sEXTINTPOLIO4 Property

EXT_INT_POL: IO-4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sExtIntPol EXTINTPOLIO4 { get; set; }
Public Property EXTINTPOLIO4 As Stmpe1208sExtIntPol
    Get
    Set
public:
property Stmpe1208sExtIntPol EXTINTPOLIO4 {
    Stmpe1208sExtIntPol get ();
    void set (Stmpe1208sExtIntPol value);
}
member EXTINTPOLIO4 : Stmpe1208sExtIntPol with get, set

Property Value

Type: Stmpe1208sExtIntPol
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.EXTINTPOLIO5 Property

IRD

Stmpe1208sEXTINTPOLIO5 Property

EXT_INT_POL: IO-5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sExtIntPol EXTINTPOLIO5 { get; set; }
Public Property EXTINTPOLIO5 As Stmpe1208sExtIntPol
    Get
    Set
public:
property Stmpe1208sExtIntPol EXTINTPOLIO5 {
    Stmpe1208sExtIntPol get ();
    void set (Stmpe1208sExtIntPol value);
}
member EXTINTPOLIO5 : Stmpe1208sExtIntPol with get, set

Property Value

Type: Stmpe1208sExtIntPol
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.EXTINTPOLIO6 Property

IRD

Stmpe1208sEXTINTPOLIO6 Property

EXT_INT_POL: IO-6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sExtIntPol EXTINTPOLIO6 { get; set; }
Public Property EXTINTPOLIO6 As Stmpe1208sExtIntPol
    Get
    Set
public:
property Stmpe1208sExtIntPol EXTINTPOLIO6 {
    Stmpe1208sExtIntPol get ();
    void set (Stmpe1208sExtIntPol value);
}
member EXTINTPOLIO6 : Stmpe1208sExtIntPol with get, set

Property Value

Type: Stmpe1208sExtIntPol
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.EXTINTPOLIO7 Property

IRD

Stmpe1208sEXTINTPOLIO7 Property

EXT_INT_POL: IO-7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sExtIntPol EXTINTPOLIO7 { get; set; }
Public Property EXTINTPOLIO7 As Stmpe1208sExtIntPol
    Get
    Set
public:
property Stmpe1208sExtIntPol EXTINTPOLIO7 {
    Stmpe1208sExtIntPol get ();
    void set (Stmpe1208sExtIntPol value);
}
member EXTINTPOLIO7 : Stmpe1208sExtIntPol with get, set

Property Value

Type: Stmpe1208sExtIntPol
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.FEATURESELAFS1 Property

IRD

Stmpe1208sFEATURESELAFS1 Property

FEATURE_SEL: AFS1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sEnableDisable FEATURESELAFS1 { get; set; }
Public Property FEATURESELAFS1 As Stmpe1208sEnableDisable
    Get
    Set
public:
property Stmpe1208sEnableDisable FEATURESELAFS1 {
    Stmpe1208sEnableDisable get ();
    void set (Stmpe1208sEnableDisable value);
}
member FEATURESELAFS1 : Stmpe1208sEnableDisable with get, set

Property Value

Type: Stmpe1208sEnableDisable
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.FEATURESELAFS2 Property

IRD

Stmpe1208sFEATURESELAFS2 Property

FEATURE_SEL: AFS2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sEnableDisable FEATURESELAFS2 { get; set; }
Public Property FEATURESELAFS2 As Stmpe1208sEnableDisable
    Get
    Set
public:
property Stmpe1208sEnableDisable FEATURESELAFS2 {
    Stmpe1208sEnableDisable get ();
    void set (Stmpe1208sEnableDisable value);
}
member FEATURESELAFS2 : Stmpe1208sEnableDisable with get, set

Property Value

Type: Stmpe1208sEnableDisable
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.FEATURESELAFS3 Property

IRD

Stmpe1208sFEATURESELAFS3 Property

FEATURE_SEL: AFS3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sEnableDisable FEATURESELAFS3 { get; set; }
Public Property FEATURESELAFS3 As Stmpe1208sEnableDisable
    Get
    Set
public:
property Stmpe1208sEnableDisable FEATURESELAFS3 {
    Stmpe1208sEnableDisable get ();
    void set (Stmpe1208sEnableDisable value);
}
member FEATURESELAFS3 : Stmpe1208sEnableDisable with get, set

Property Value

Type: Stmpe1208sEnableDisable
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.FEATURESELFILTEREN Property

IRD

Stmpe1208sFEATURESELFILTEREN Property

FEATURE_SEL: FILTER_EN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sEnableDisable FEATURESELFILTEREN { get; set; }
Public Property FEATURESELFILTEREN As Stmpe1208sEnableDisable
    Get
    Set
public:
property Stmpe1208sEnableDisable FEATURESELFILTEREN {
    Stmpe1208sEnableDisable get ();
    void set (Stmpe1208sEnableDisable value);
}
member FEATURESELFILTEREN : Stmpe1208sEnableDisable with get, set

Property Value

Type: Stmpe1208sEnableDisable
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.FILTERPERIOD Property

IRD

Stmpe1208sFILTERPERIOD Property

FILTER_PERIOD

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 FILTERPERIOD { get; set; }
Public Property FILTERPERIOD As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 FILTERPERIOD {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member FILTERPERIOD : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.FILTERTHRESHOLD Property

IRD

Stmpe1208sFILTERTHRESHOLD Property

FILTER_THRESHOLD

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 FILTERTHRESHOLD { get; set; }
Public Property FILTERTHRESHOLD As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 FILTERTHRESHOLD {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member FILTERTHRESHOLD : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOCFGHIO10 Property

IRD

Stmpe1208sGPIOCFGHIO10 Property

GPIO_CFG_H: IO-10

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOCFGHIO10 { get; set; }
Public Property GPIOCFGHIO10 As Byte
    Get
    Set
public:
property unsigned char GPIOCFGHIO10 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOCFGHIO10 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOCFGHIO11 Property

IRD

Stmpe1208sGPIOCFGHIO11 Property

GPIO_CFG_H: IO-11

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOCFGHIO11 { get; set; }
Public Property GPIOCFGHIO11 As Byte
    Get
    Set
public:
property unsigned char GPIOCFGHIO11 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOCFGHIO11 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOCFGHIO8 Property

IRD

Stmpe1208sGPIOCFGHIO8 Property

GPIO_CFG_H: IO-8

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOCFGHIO8 { get; set; }
Public Property GPIOCFGHIO8 As Byte
    Get
    Set
public:
property unsigned char GPIOCFGHIO8 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOCFGHIO8 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOCFGHIO9 Property

IRD

Stmpe1208sGPIOCFGHIO9 Property

GPIO_CFG_H: IO-9

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOCFGHIO9 { get; set; }
Public Property GPIOCFGHIO9 As Byte
    Get
    Set
public:
property unsigned char GPIOCFGHIO9 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOCFGHIO9 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOCFGLIO0 Property

IRD

Stmpe1208sGPIOCFGLIO0 Property

GPIO_CFG_L: IO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOCFGLIO0 { get; set; }
Public Property GPIOCFGLIO0 As Byte
    Get
    Set
public:
property unsigned char GPIOCFGLIO0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOCFGLIO0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOCFGLIO1 Property

IRD

Stmpe1208sGPIOCFGLIO1 Property

GPIO_CFG_L: IO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOCFGLIO1 { get; set; }
Public Property GPIOCFGLIO1 As Byte
    Get
    Set
public:
property unsigned char GPIOCFGLIO1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOCFGLIO1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOCFGLIO2 Property

IRD

Stmpe1208sGPIOCFGLIO2 Property

GPIO_CFG_L: IO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOCFGLIO2 { get; set; }
Public Property GPIOCFGLIO2 As Byte
    Get
    Set
public:
property unsigned char GPIOCFGLIO2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOCFGLIO2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOCFGLIO3 Property

IRD

Stmpe1208sGPIOCFGLIO3 Property

GPIO_CFG_L: IO-3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOCFGLIO3 { get; set; }
Public Property GPIOCFGLIO3 As Byte
    Get
    Set
public:
property unsigned char GPIOCFGLIO3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOCFGLIO3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOCFGLIO4 Property

IRD

Stmpe1208sGPIOCFGLIO4 Property

GPIO_CFG_L: IO-4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOCFGLIO4 { get; set; }
Public Property GPIOCFGLIO4 As Byte
    Get
    Set
public:
property unsigned char GPIOCFGLIO4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOCFGLIO4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOCFGLIO5 Property

IRD

Stmpe1208sGPIOCFGLIO5 Property

GPIO_CFG_L: IO-5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOCFGLIO5 { get; set; }
Public Property GPIOCFGLIO5 As Byte
    Get
    Set
public:
property unsigned char GPIOCFGLIO5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOCFGLIO5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOCFGLIO6 Property

IRD

Stmpe1208sGPIOCFGLIO6 Property

GPIO_CFG_L: IO-6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOCFGLIO6 { get; set; }
Public Property GPIOCFGLIO6 As Byte
    Get
    Set
public:
property unsigned char GPIOCFGLIO6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOCFGLIO6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOCFGLIO7 Property

IRD

Stmpe1208sGPIOCFGLIO7 Property

GPIO_CFG_L: IO-7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOCFGLIO7 { get; set; }
Public Property GPIOCFGLIO7 As Byte
    Get
    Set
public:
property unsigned char GPIOCFGLIO7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOCFGLIO7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIODIRHIO10 Property

IRD

Stmpe1208sGPIODIRHIO10 Property

GPIO_DIR_H: IO-10

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sGpioDir GPIODIRHIO10 { get; set; }
Public Property GPIODIRHIO10 As Stmpe1208sGpioDir
    Get
    Set
public:
property Stmpe1208sGpioDir GPIODIRHIO10 {
    Stmpe1208sGpioDir get ();
    void set (Stmpe1208sGpioDir value);
}
member GPIODIRHIO10 : Stmpe1208sGpioDir with get, set

Property Value

Type: Stmpe1208sGpioDir
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIODIRHIO11 Property

IRD

Stmpe1208sGPIODIRHIO11 Property

GPIO_DIR_H: IO-11

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sGpioDir GPIODIRHIO11 { get; set; }
Public Property GPIODIRHIO11 As Stmpe1208sGpioDir
    Get
    Set
public:
property Stmpe1208sGpioDir GPIODIRHIO11 {
    Stmpe1208sGpioDir get ();
    void set (Stmpe1208sGpioDir value);
}
member GPIODIRHIO11 : Stmpe1208sGpioDir with get, set

Property Value

Type: Stmpe1208sGpioDir
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIODIRHIO8 Property

IRD

Stmpe1208sGPIODIRHIO8 Property

GPIO_DIR_H: IO-8

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sEnableDisable GPIODIRHIO8 { get; set; }
Public Property GPIODIRHIO8 As Stmpe1208sEnableDisable
    Get
    Set
public:
property Stmpe1208sEnableDisable GPIODIRHIO8 {
    Stmpe1208sEnableDisable get ();
    void set (Stmpe1208sEnableDisable value);
}
member GPIODIRHIO8 : Stmpe1208sEnableDisable with get, set

Property Value

Type: Stmpe1208sEnableDisable
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIODIRHIO9 Property

IRD

Stmpe1208sGPIODIRHIO9 Property

GPIO_DIR_H: IO-9

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sGpioDir GPIODIRHIO9 { get; set; }
Public Property GPIODIRHIO9 As Stmpe1208sGpioDir
    Get
    Set
public:
property Stmpe1208sGpioDir GPIODIRHIO9 {
    Stmpe1208sGpioDir get ();
    void set (Stmpe1208sGpioDir value);
}
member GPIODIRHIO9 : Stmpe1208sGpioDir with get, set

Property Value

Type: Stmpe1208sGpioDir
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIODIRLIO0 Property

IRD

Stmpe1208sGPIODIRLIO0 Property

GPIO_DIR_L: IO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sGpioDir GPIODIRLIO0 { get; set; }
Public Property GPIODIRLIO0 As Stmpe1208sGpioDir
    Get
    Set
public:
property Stmpe1208sGpioDir GPIODIRLIO0 {
    Stmpe1208sGpioDir get ();
    void set (Stmpe1208sGpioDir value);
}
member GPIODIRLIO0 : Stmpe1208sGpioDir with get, set

Property Value

Type: Stmpe1208sGpioDir
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIODIRLIO1 Property

IRD

Stmpe1208sGPIODIRLIO1 Property

GPIO_DIR_L: IO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sGpioDir GPIODIRLIO1 { get; set; }
Public Property GPIODIRLIO1 As Stmpe1208sGpioDir
    Get
    Set
public:
property Stmpe1208sGpioDir GPIODIRLIO1 {
    Stmpe1208sGpioDir get ();
    void set (Stmpe1208sGpioDir value);
}
member GPIODIRLIO1 : Stmpe1208sGpioDir with get, set

Property Value

Type: Stmpe1208sGpioDir
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIODIRLIO2 Property

IRD

Stmpe1208sGPIODIRLIO2 Property

GPIO_DIR_L: IO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sGpioDir GPIODIRLIO2 { get; set; }
Public Property GPIODIRLIO2 As Stmpe1208sGpioDir
    Get
    Set
public:
property Stmpe1208sGpioDir GPIODIRLIO2 {
    Stmpe1208sGpioDir get ();
    void set (Stmpe1208sGpioDir value);
}
member GPIODIRLIO2 : Stmpe1208sGpioDir with get, set

Property Value

Type: Stmpe1208sGpioDir
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIODIRLIO3 Property

IRD

Stmpe1208sGPIODIRLIO3 Property

GPIO_DIR_L: IO-3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sGpioDir GPIODIRLIO3 { get; set; }
Public Property GPIODIRLIO3 As Stmpe1208sGpioDir
    Get
    Set
public:
property Stmpe1208sGpioDir GPIODIRLIO3 {
    Stmpe1208sGpioDir get ();
    void set (Stmpe1208sGpioDir value);
}
member GPIODIRLIO3 : Stmpe1208sGpioDir with get, set

Property Value

Type: Stmpe1208sGpioDir
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIODIRLIO4 Property

IRD

Stmpe1208sGPIODIRLIO4 Property

GPIO_DIR_L: IO-4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sGpioDir GPIODIRLIO4 { get; set; }
Public Property GPIODIRLIO4 As Stmpe1208sGpioDir
    Get
    Set
public:
property Stmpe1208sGpioDir GPIODIRLIO4 {
    Stmpe1208sGpioDir get ();
    void set (Stmpe1208sGpioDir value);
}
member GPIODIRLIO4 : Stmpe1208sGpioDir with get, set

Property Value

Type: Stmpe1208sGpioDir
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIODIRLIO5 Property

IRD

Stmpe1208sGPIODIRLIO5 Property

GPIO_DIR_L: IO-5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sGpioDir GPIODIRLIO5 { get; set; }
Public Property GPIODIRLIO5 As Stmpe1208sGpioDir
    Get
    Set
public:
property Stmpe1208sGpioDir GPIODIRLIO5 {
    Stmpe1208sGpioDir get ();
    void set (Stmpe1208sGpioDir value);
}
member GPIODIRLIO5 : Stmpe1208sGpioDir with get, set

Property Value

Type: Stmpe1208sGpioDir
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIODIRLIO6 Property

IRD

Stmpe1208sGPIODIRLIO6 Property

GPIO_DIR_L: IO-6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sGpioDir GPIODIRLIO6 { get; set; }
Public Property GPIODIRLIO6 As Stmpe1208sGpioDir
    Get
    Set
public:
property Stmpe1208sGpioDir GPIODIRLIO6 {
    Stmpe1208sGpioDir get ();
    void set (Stmpe1208sGpioDir value);
}
member GPIODIRLIO6 : Stmpe1208sGpioDir with get, set

Property Value

Type: Stmpe1208sGpioDir
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIODIRLIO7 Property

IRD

Stmpe1208sGPIODIRLIO7 Property

GPIO_DIR_L: IO-7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sGpioDir GPIODIRLIO7 { get; set; }
Public Property GPIODIRLIO7 As Stmpe1208sGpioDir
    Get
    Set
public:
property Stmpe1208sGpioDir GPIODIRLIO7 {
    Stmpe1208sGpioDir get ();
    void set (Stmpe1208sGpioDir value);
}
member GPIODIRLIO7 : Stmpe1208sGpioDir with get, set

Property Value

Type: Stmpe1208sGpioDir
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOINHIO10 Property

IRD

Stmpe1208sGPIOINHIO10 Property

GPIO_IN_H: IO-10

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINHIO10 { get; }
Public ReadOnly Property GPIOINHIO10 As Byte
    Get
public:
property unsigned char GPIOINHIO10 {
    unsigned char get ();
}
member GPIOINHIO10 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOINHIO11 Property

IRD

Stmpe1208sGPIOINHIO11 Property

GPIO_IN_H: IO-11

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINHIO11 { get; }
Public ReadOnly Property GPIOINHIO11 As Byte
    Get
public:
property unsigned char GPIOINHIO11 {
    unsigned char get ();
}
member GPIOINHIO11 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOINHIO8 Property

IRD

Stmpe1208sGPIOINHIO8 Property

GPIO_IN_H: IO-8

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINHIO8 { get; }
Public ReadOnly Property GPIOINHIO8 As Byte
    Get
public:
property unsigned char GPIOINHIO8 {
    unsigned char get ();
}
member GPIOINHIO8 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOINHIO9 Property

IRD

Stmpe1208sGPIOINHIO9 Property

GPIO_IN_H: IO-9

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINHIO9 { get; }
Public ReadOnly Property GPIOINHIO9 As Byte
    Get
public:
property unsigned char GPIOINHIO9 {
    unsigned char get ();
}
member GPIOINHIO9 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOINLIO0 Property

IRD

Stmpe1208sGPIOINLIO0 Property

GPIO_IN_L: IO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINLIO0 { get; }
Public ReadOnly Property GPIOINLIO0 As Byte
    Get
public:
property unsigned char GPIOINLIO0 {
    unsigned char get ();
}
member GPIOINLIO0 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOINLIO1 Property

IRD

Stmpe1208sGPIOINLIO1 Property

GPIO_IN_L: IO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINLIO1 { get; }
Public ReadOnly Property GPIOINLIO1 As Byte
    Get
public:
property unsigned char GPIOINLIO1 {
    unsigned char get ();
}
member GPIOINLIO1 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOINLIO2 Property

IRD

Stmpe1208sGPIOINLIO2 Property

GPIO_IN_L: IO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINLIO2 { get; }
Public ReadOnly Property GPIOINLIO2 As Byte
    Get
public:
property unsigned char GPIOINLIO2 {
    unsigned char get ();
}
member GPIOINLIO2 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOINLIO3 Property

IRD

Stmpe1208sGPIOINLIO3 Property

GPIO_IN_L: IO-3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINLIO3 { get; }
Public ReadOnly Property GPIOINLIO3 As Byte
    Get
public:
property unsigned char GPIOINLIO3 {
    unsigned char get ();
}
member GPIOINLIO3 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOINLIO4 Property

IRD

Stmpe1208sGPIOINLIO4 Property

GPIO_IN_L: IO-4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINLIO4 { get; }
Public ReadOnly Property GPIOINLIO4 As Byte
    Get
public:
property unsigned char GPIOINLIO4 {
    unsigned char get ();
}
member GPIOINLIO4 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOINLIO5 Property

IRD

Stmpe1208sGPIOINLIO5 Property

GPIO_IN_L: IO-5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINLIO5 { get; }
Public ReadOnly Property GPIOINLIO5 As Byte
    Get
public:
property unsigned char GPIOINLIO5 {
    unsigned char get ();
}
member GPIOINLIO5 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOINLIO6 Property

IRD

Stmpe1208sGPIOINLIO6 Property

GPIO_IN_L: IO-6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINLIO6 { get; }
Public ReadOnly Property GPIOINLIO6 As Byte
    Get
public:
property unsigned char GPIOINLIO6 {
    unsigned char get ();
}
member GPIOINLIO6 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOINLIO7 Property

IRD

Stmpe1208sGPIOINLIO7 Property

GPIO_IN_L: IO-7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINLIO7 { get; }
Public ReadOnly Property GPIOINLIO7 As Byte
    Get
public:
property unsigned char GPIOINLIO7 {
    unsigned char get ();
}
member GPIOINLIO7 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOSTAHIO10 Property

IRD

Stmpe1208sGPIOSTAHIO10 Property

GPIO_STA_H: IO-10

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSTAHIO10 { get; set; }
Public Property GPIOSTAHIO10 As Byte
    Get
    Set
public:
property unsigned char GPIOSTAHIO10 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSTAHIO10 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOSTAHIO11 Property

IRD

Stmpe1208sGPIOSTAHIO11 Property

GPIO_STA_H: IO-11

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSTAHIO11 { get; set; }
Public Property GPIOSTAHIO11 As Byte
    Get
    Set
public:
property unsigned char GPIOSTAHIO11 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSTAHIO11 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOSTAHIO8 Property

IRD

Stmpe1208sGPIOSTAHIO8 Property

GPIO_STA_H: IO-8

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSTAHIO8 { get; set; }
Public Property GPIOSTAHIO8 As Byte
    Get
    Set
public:
property unsigned char GPIOSTAHIO8 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSTAHIO8 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOSTAHIO9 Property

IRD

Stmpe1208sGPIOSTAHIO9 Property

GPIO_STA_H: IO-9

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSTAHIO9 { get; set; }
Public Property GPIOSTAHIO9 As Byte
    Get
    Set
public:
property unsigned char GPIOSTAHIO9 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSTAHIO9 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOSTALIO0 Property

IRD

Stmpe1208sGPIOSTALIO0 Property

GPIO_STA_L: IO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSTALIO0 { get; set; }
Public Property GPIOSTALIO0 As Byte
    Get
    Set
public:
property unsigned char GPIOSTALIO0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSTALIO0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOSTALIO1 Property

IRD

Stmpe1208sGPIOSTALIO1 Property

GPIO_STA_L: IO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSTALIO1 { get; set; }
Public Property GPIOSTALIO1 As Byte
    Get
    Set
public:
property unsigned char GPIOSTALIO1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSTALIO1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOSTALIO2 Property

IRD

Stmpe1208sGPIOSTALIO2 Property

GPIO_STA_L: IO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSTALIO2 { get; set; }
Public Property GPIOSTALIO2 As Byte
    Get
    Set
public:
property unsigned char GPIOSTALIO2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSTALIO2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOSTALIO3 Property

IRD

Stmpe1208sGPIOSTALIO3 Property

GPIO_STA_L: IO-3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSTALIO3 { get; set; }
Public Property GPIOSTALIO3 As Byte
    Get
    Set
public:
property unsigned char GPIOSTALIO3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSTALIO3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOSTALIO4 Property

IRD

Stmpe1208sGPIOSTALIO4 Property

GPIO_STA_L: IO-4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSTALIO4 { get; set; }
Public Property GPIOSTALIO4 As Byte
    Get
    Set
public:
property unsigned char GPIOSTALIO4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSTALIO4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOSTALIO5 Property

IRD

Stmpe1208sGPIOSTALIO5 Property

GPIO_STA_L: IO-5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSTALIO5 { get; set; }
Public Property GPIOSTALIO5 As Byte
    Get
    Set
public:
property unsigned char GPIOSTALIO5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSTALIO5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOSTALIO6 Property

IRD

Stmpe1208sGPIOSTALIO6 Property

GPIO_STA_L: IO-6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSTALIO6 { get; set; }
Public Property GPIOSTALIO6 As Byte
    Get
    Set
public:
property unsigned char GPIOSTALIO6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSTALIO6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.GPIOSTALIO7 Property

IRD

Stmpe1208sGPIOSTALIO7 Property

GPIO_STA_L: IO-7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSTALIO7 { get; set; }
Public Property GPIOSTALIO7 As Byte
    Get
    Set
public:
property unsigned char GPIOSTALIO7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSTALIO7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.IDLETIME Property

IRD

Stmpe1208sIDLETIME Property

IDLE_TIME

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 IDLETIME { get; set; }
Public Property IDLETIME As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 IDLETIME {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member IDLETIME : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.IMPEDANCE0 Property

IRD

Stmpe1208sIMPEDANCE0 Property

IMPEDANCE 0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 IMPEDANCE0 { get; }
Public ReadOnly Property IMPEDANCE0 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 IMPEDANCE0 {
    Stmpe1208sUint8 get ();
}
member IMPEDANCE0 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.IMPEDANCE1 Property

IRD

Stmpe1208sIMPEDANCE1 Property

IMPEDANCE 1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 IMPEDANCE1 { get; }
Public ReadOnly Property IMPEDANCE1 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 IMPEDANCE1 {
    Stmpe1208sUint8 get ();
}
member IMPEDANCE1 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.IMPEDANCE10 Property

IRD

Stmpe1208sIMPEDANCE10 Property

IMPEDANCE 10

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 IMPEDANCE10 { get; }
Public ReadOnly Property IMPEDANCE10 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 IMPEDANCE10 {
    Stmpe1208sUint8 get ();
}
member IMPEDANCE10 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.IMPEDANCE11 Property

IRD

Stmpe1208sIMPEDANCE11 Property

IMPEDANCE 11

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 IMPEDANCE11 { get; }
Public ReadOnly Property IMPEDANCE11 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 IMPEDANCE11 {
    Stmpe1208sUint8 get ();
}
member IMPEDANCE11 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.IMPEDANCE2 Property

IRD

Stmpe1208sIMPEDANCE2 Property

IMPEDANCE 2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 IMPEDANCE2 { get; }
Public ReadOnly Property IMPEDANCE2 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 IMPEDANCE2 {
    Stmpe1208sUint8 get ();
}
member IMPEDANCE2 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.IMPEDANCE3 Property

IRD

Stmpe1208sIMPEDANCE3 Property

IMPEDANCE 3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 IMPEDANCE3 { get; }
Public ReadOnly Property IMPEDANCE3 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 IMPEDANCE3 {
    Stmpe1208sUint8 get ();
}
member IMPEDANCE3 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.IMPEDANCE4 Property

IRD

Stmpe1208sIMPEDANCE4 Property

IMPEDANCE 4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 IMPEDANCE4 { get; }
Public ReadOnly Property IMPEDANCE4 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 IMPEDANCE4 {
    Stmpe1208sUint8 get ();
}
member IMPEDANCE4 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.IMPEDANCE5 Property

IRD

Stmpe1208sIMPEDANCE5 Property

IMPEDANCE 5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 IMPEDANCE5 { get; }
Public ReadOnly Property IMPEDANCE5 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 IMPEDANCE5 {
    Stmpe1208sUint8 get ();
}
member IMPEDANCE5 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.IMPEDANCE6 Property

IRD

Stmpe1208sIMPEDANCE6 Property

IMPEDANCE 6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 IMPEDANCE6 { get; }
Public ReadOnly Property IMPEDANCE6 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 IMPEDANCE6 {
    Stmpe1208sUint8 get ();
}
member IMPEDANCE6 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.IMPEDANCE7 Property

IRD

Stmpe1208sIMPEDANCE7 Property

IMPEDANCE 7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 IMPEDANCE7 { get; }
Public ReadOnly Property IMPEDANCE7 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 IMPEDANCE7 {
    Stmpe1208sUint8 get ();
}
member IMPEDANCE7 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.IMPEDANCE8 Property

IRD

Stmpe1208sIMPEDANCE8 Property

IMPEDANCE 8

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 IMPEDANCE8 { get; }
Public ReadOnly Property IMPEDANCE8 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 IMPEDANCE8 {
    Stmpe1208sUint8 get ();
}
member IMPEDANCE8 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.IMPEDANCE9 Property

IRD

Stmpe1208sIMPEDANCE9 Property

IMPEDANCE 9

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 IMPEDANCE9 { get; }
Public ReadOnly Property IMPEDANCE9 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 IMPEDANCE9 {
    Stmpe1208sUint8 get ();
}
member IMPEDANCE9 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.INTCLRA2I Property

IRD

Stmpe1208sINTCLRA2I Property

INT_CLR: A2I

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTCLRA2I { get; set; }
Public Property INTCLRA2I As Byte
    Get
    Set
public:
property unsigned char INTCLRA2I {
    unsigned char get ();
    void set (unsigned char value);
}
member INTCLRA2I : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.INTCLREINT Property

IRD

Stmpe1208sINTCLREINT Property

INT_CLR: EINT

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTCLREINT { get; set; }
Public Property INTCLREINT As Byte
    Get
    Set
public:
property unsigned char INTCLREINT {
    unsigned char get ();
    void set (unsigned char value);
}
member INTCLREINT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.INTCLREOC Property

IRD

Stmpe1208sINTCLREOC Property

INT_CLR: EOC

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTCLREOC { get; set; }
Public Property INTCLREOC As Byte
    Get
    Set
public:
property unsigned char INTCLREOC {
    unsigned char get ();
    void set (unsigned char value);
}
member INTCLREOC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.INTCLRI2A Property

IRD

Stmpe1208sINTCLRI2A Property

INT_CLR: I2A

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTCLRI2A { get; set; }
Public Property INTCLRI2A As Byte
    Get
    Set
public:
property unsigned char INTCLRI2A {
    unsigned char get ();
    void set (unsigned char value);
}
member INTCLRI2A : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.INTCLRTouch Property

IRD

Stmpe1208sINTCLRTouch Property

INT_CLR: Touch

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTCLRTouch { get; set; }
Public Property INTCLRTouch As Byte
    Get
    Set
public:
property unsigned char INTCLRTouch {
    unsigned char get ();
    void set (unsigned char value);
}
member INTCLRTouch : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.INTEGRATIONTIME Property

IRD

Stmpe1208sINTEGRATIONTIME Property

INTEGRATION_TIME

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 INTEGRATIONTIME { get; set; }
Public Property INTEGRATIONTIME As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 INTEGRATIONTIME {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member INTEGRATIONTIME : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.INTMASKA2I Property

IRD

Stmpe1208sINTMASKA2I Property

INT_MASK: A2I

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTMASKA2I { get; set; }
Public Property INTMASKA2I As Byte
    Get
    Set
public:
property unsigned char INTMASKA2I {
    unsigned char get ();
    void set (unsigned char value);
}
member INTMASKA2I : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.INTMASKEINT Property

IRD

Stmpe1208sINTMASKEINT Property

INT_MASK: EINT

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTMASKEINT { get; set; }
Public Property INTMASKEINT As Byte
    Get
    Set
public:
property unsigned char INTMASKEINT {
    unsigned char get ();
    void set (unsigned char value);
}
member INTMASKEINT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.INTMASKEOC Property

IRD

Stmpe1208sINTMASKEOC Property

INT_MASK: EOC

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTMASKEOC { get; set; }
Public Property INTMASKEOC As Byte
    Get
    Set
public:
property unsigned char INTMASKEOC {
    unsigned char get ();
    void set (unsigned char value);
}
member INTMASKEOC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.INTMASKI2A Property

IRD

Stmpe1208sINTMASKI2A Property

INT_MASK: I2A

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTMASKI2A { get; set; }
Public Property INTMASKI2A As Byte
    Get
    Set
public:
property unsigned char INTMASKI2A {
    unsigned char get ();
    void set (unsigned char value);
}
member INTMASKI2A : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.INTMASKTouch Property

IRD

Stmpe1208sINTMASKTouch Property

INT_MASK: Touch

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTMASKTouch { get; set; }
Public Property INTMASKTouch As Byte
    Get
    Set
public:
property unsigned char INTMASKTouch {
    unsigned char get ();
    void set (unsigned char value);
}
member INTMASKTouch : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.INTPENDINGA21 Property

IRD

Stmpe1208sINTPENDINGA21 Property

INT_PENDING: A21

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTPENDINGA21 { get; }
Public ReadOnly Property INTPENDINGA21 As Byte
    Get
public:
property unsigned char INTPENDINGA21 {
    unsigned char get ();
}
member INTPENDINGA21 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.INTPENDINGEOC Property

IRD

Stmpe1208sINTPENDINGEOC Property

INT_PENDING: EOC

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTPENDINGEOC { get; }
Public ReadOnly Property INTPENDINGEOC As Byte
    Get
public:
property unsigned char INTPENDINGEOC {
    unsigned char get ();
}
member INTPENDINGEOC : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.INTPENDINGI2A Property

IRD

Stmpe1208sINTPENDINGI2A Property

INT_PENDING: I2A

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTPENDINGI2A { get; }
Public ReadOnly Property INTPENDINGI2A As Byte
    Get
public:
property unsigned char INTPENDINGI2A {
    unsigned char get ();
}
member INTPENDINGI2A : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.INTPENDINGTouch Property

IRD

Stmpe1208sINTPENDINGTouch Property

INT_PENDING: Touch

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTPENDINGTouch { get; }
Public ReadOnly Property INTPENDINGTouch As Byte
    Get
public:
property unsigned char INTPENDINGTouch {
    unsigned char get ();
}
member INTPENDINGTouch : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.REFERENCEDELAY Property

IRD

Stmpe1208sREFERENCEDELAY Property

REFERENCE_DELAY

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte REFERENCEDELAY { get; set; }
Public Property REFERENCEDELAY As Byte
    Get
    Set
public:
property unsigned char REFERENCEDELAY {
    unsigned char get ();
    void set (unsigned char value);
}
member REFERENCEDELAY : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STATUSIDLE Property

IRD

Stmpe1208sSTATUSIDLE Property

STATUS: IDLE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sStatus STATUSIDLE { get; }
Public ReadOnly Property STATUSIDLE As Stmpe1208sStatus
    Get
public:
property Stmpe1208sStatus STATUSIDLE {
    Stmpe1208sStatus get ();
}
member STATUSIDLE : Stmpe1208sStatus with get

Property Value

Type: Stmpe1208sStatus
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTH0 Property

IRD

Stmpe1208sSTRENGTH0 Property

STRENGTH 0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTH0 { get; }
Public ReadOnly Property STRENGTH0 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 STRENGTH0 {
    Stmpe1208sUint8 get ();
}
member STRENGTH0 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTH1 Property

IRD

Stmpe1208sSTRENGTH1 Property

STRENGTH 1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTH1 { get; }
Public ReadOnly Property STRENGTH1 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 STRENGTH1 {
    Stmpe1208sUint8 get ();
}
member STRENGTH1 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTH10 Property

IRD

Stmpe1208sSTRENGTH10 Property

STRENGTH 10

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTH10 { get; }
Public ReadOnly Property STRENGTH10 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 STRENGTH10 {
    Stmpe1208sUint8 get ();
}
member STRENGTH10 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTH11 Property

IRD

Stmpe1208sSTRENGTH11 Property

STRENGTH 11

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTH11 { get; }
Public ReadOnly Property STRENGTH11 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 STRENGTH11 {
    Stmpe1208sUint8 get ();
}
member STRENGTH11 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTH2 Property

IRD

Stmpe1208sSTRENGTH2 Property

STRENGTH 2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTH2 { get; }
Public ReadOnly Property STRENGTH2 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 STRENGTH2 {
    Stmpe1208sUint8 get ();
}
member STRENGTH2 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTH3 Property

IRD

Stmpe1208sSTRENGTH3 Property

STRENGTH 3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTH3 { get; }
Public ReadOnly Property STRENGTH3 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 STRENGTH3 {
    Stmpe1208sUint8 get ();
}
member STRENGTH3 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTH4 Property

IRD

Stmpe1208sSTRENGTH4 Property

STRENGTH 4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTH4 { get; }
Public ReadOnly Property STRENGTH4 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 STRENGTH4 {
    Stmpe1208sUint8 get ();
}
member STRENGTH4 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTH5 Property

IRD

Stmpe1208sSTRENGTH5 Property

STRENGTH 5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTH5 { get; }
Public ReadOnly Property STRENGTH5 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 STRENGTH5 {
    Stmpe1208sUint8 get ();
}
member STRENGTH5 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTH6 Property

IRD

Stmpe1208sSTRENGTH6 Property

STRENGTH 6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTH6 { get; }
Public ReadOnly Property STRENGTH6 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 STRENGTH6 {
    Stmpe1208sUint8 get ();
}
member STRENGTH6 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTH7 Property

IRD

Stmpe1208sSTRENGTH7 Property

STRENGTH 7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTH7 { get; }
Public ReadOnly Property STRENGTH7 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 STRENGTH7 {
    Stmpe1208sUint8 get ();
}
member STRENGTH7 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTH8 Property

IRD

Stmpe1208sSTRENGTH8 Property

STRENGTH 8

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTH8 { get; }
Public ReadOnly Property STRENGTH8 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 STRENGTH8 {
    Stmpe1208sUint8 get ();
}
member STRENGTH8 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTH9 Property

IRD

Stmpe1208sSTRENGTH9 Property

STRENGTH 9

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTH9 { get; }
Public ReadOnly Property STRENGTH9 As Stmpe1208sUint8
    Get
public:
property Stmpe1208sUint8 STRENGTH9 {
    Stmpe1208sUint8 get ();
}
member STRENGTH9 : Stmpe1208sUint8 with get

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTHTHRES0 Property

IRD

Stmpe1208sSTRENGTHTHRES0 Property

STRENGTH_THRES 0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTHTHRES0 { get; set; }
Public Property STRENGTHTHRES0 As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 STRENGTHTHRES0 {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member STRENGTHTHRES0 : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTHTHRES1 Property

IRD

Stmpe1208sSTRENGTHTHRES1 Property

STRENGTH_THRES 1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTHTHRES1 { get; set; }
Public Property STRENGTHTHRES1 As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 STRENGTHTHRES1 {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member STRENGTHTHRES1 : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTHTHRES10 Property

IRD

Stmpe1208sSTRENGTHTHRES10 Property

STRENGTH_THRES 10

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTHTHRES10 { get; set; }
Public Property STRENGTHTHRES10 As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 STRENGTHTHRES10 {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member STRENGTHTHRES10 : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTHTHRES11 Property

IRD

Stmpe1208sSTRENGTHTHRES11 Property

STRENGTH_THRES 11

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTHTHRES11 { get; set; }
Public Property STRENGTHTHRES11 As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 STRENGTHTHRES11 {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member STRENGTHTHRES11 : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTHTHRES2 Property

IRD

Stmpe1208sSTRENGTHTHRES2 Property

STRENGTH_THRES 2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTHTHRES2 { get; set; }
Public Property STRENGTHTHRES2 As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 STRENGTHTHRES2 {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member STRENGTHTHRES2 : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTHTHRES3 Property

IRD

Stmpe1208sSTRENGTHTHRES3 Property

STRENGTH_THRES 3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTHTHRES3 { get; set; }
Public Property STRENGTHTHRES3 As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 STRENGTHTHRES3 {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member STRENGTHTHRES3 : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTHTHRES4 Property

IRD

Stmpe1208sSTRENGTHTHRES4 Property

STRENGTH_THRES 4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTHTHRES4 { get; set; }
Public Property STRENGTHTHRES4 As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 STRENGTHTHRES4 {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member STRENGTHTHRES4 : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTHTHRES5 Property

IRD

Stmpe1208sSTRENGTHTHRES5 Property

STRENGTH_THRES 5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTHTHRES5 { get; set; }
Public Property STRENGTHTHRES5 As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 STRENGTHTHRES5 {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member STRENGTHTHRES5 : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTHTHRES6 Property

IRD

Stmpe1208sSTRENGTHTHRES6 Property

STRENGTH_THRES 6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTHTHRES6 { get; set; }
Public Property STRENGTHTHRES6 As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 STRENGTHTHRES6 {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member STRENGTHTHRES6 : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTHTHRES7 Property

IRD

Stmpe1208sSTRENGTHTHRES7 Property

STRENGTH_THRES 7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTHTHRES7 { get; set; }
Public Property STRENGTHTHRES7 As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 STRENGTHTHRES7 {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member STRENGTHTHRES7 : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTHTHRES8 Property

IRD

Stmpe1208sSTRENGTHTHRES8 Property

STRENGTH_THRES 8

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTHTHRES8 { get; set; }
Public Property STRENGTHTHRES8 As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 STRENGTHTHRES8 {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member STRENGTHTHRES8 : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.STRENGTHTHRES9 Property

IRD

Stmpe1208sSTRENGTHTHRES9 Property

STRENGTH_THRES 9

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sUint8 STRENGTHTHRES9 { get; set; }
Public Property STRENGTHTHRES9 As Stmpe1208sUint8
    Get
    Set
public:
property Stmpe1208sUint8 STRENGTHTHRES9 {
    Stmpe1208sUint8 get ();
    void set (Stmpe1208sUint8 value);
}
member STRENGTHTHRES9 : Stmpe1208sUint8 with get, set

Property Value

Type: Stmpe1208sUint8
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TOUCHBYTEHCH10 Property

IRD

Stmpe1208sTOUCHBYTEHCH10 Property

TOUCH_BYTE_H: CH10

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sTouch TOUCHBYTEHCH10 { get; }
Public ReadOnly Property TOUCHBYTEHCH10 As Stmpe1208sTouch
    Get
public:
property Stmpe1208sTouch TOUCHBYTEHCH10 {
    Stmpe1208sTouch get ();
}
member TOUCHBYTEHCH10 : Stmpe1208sTouch with get

Property Value

Type: Stmpe1208sTouch
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TOUCHBYTEHCH11 Property

IRD

Stmpe1208sTOUCHBYTEHCH11 Property

TOUCH_BYTE_H: CH11

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sTouch TOUCHBYTEHCH11 { get; }
Public ReadOnly Property TOUCHBYTEHCH11 As Stmpe1208sTouch
    Get
public:
property Stmpe1208sTouch TOUCHBYTEHCH11 {
    Stmpe1208sTouch get ();
}
member TOUCHBYTEHCH11 : Stmpe1208sTouch with get

Property Value

Type: Stmpe1208sTouch
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TOUCHBYTEHCH8 Property

IRD

Stmpe1208sTOUCHBYTEHCH8 Property

TOUCH_BYTE_H: CH8

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sTouch TOUCHBYTEHCH8 { get; }
Public ReadOnly Property TOUCHBYTEHCH8 As Stmpe1208sTouch
    Get
public:
property Stmpe1208sTouch TOUCHBYTEHCH8 {
    Stmpe1208sTouch get ();
}
member TOUCHBYTEHCH8 : Stmpe1208sTouch with get

Property Value

Type: Stmpe1208sTouch
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TOUCHBYTEHCH9 Property

IRD

Stmpe1208sTOUCHBYTEHCH9 Property

TOUCH_BYTE_H: CH9

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sTouch TOUCHBYTEHCH9 { get; }
Public ReadOnly Property TOUCHBYTEHCH9 As Stmpe1208sTouch
    Get
public:
property Stmpe1208sTouch TOUCHBYTEHCH9 {
    Stmpe1208sTouch get ();
}
member TOUCHBYTEHCH9 : Stmpe1208sTouch with get

Property Value

Type: Stmpe1208sTouch
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TOUCHBYTELCH0 Property

IRD

Stmpe1208sTOUCHBYTELCH0 Property

TOUCH_BYTE_L: CH0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sTouch TOUCHBYTELCH0 { get; }
Public ReadOnly Property TOUCHBYTELCH0 As Stmpe1208sTouch
    Get
public:
property Stmpe1208sTouch TOUCHBYTELCH0 {
    Stmpe1208sTouch get ();
}
member TOUCHBYTELCH0 : Stmpe1208sTouch with get

Property Value

Type: Stmpe1208sTouch
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TOUCHBYTELCH1 Property

IRD

Stmpe1208sTOUCHBYTELCH1 Property

TOUCH_BYTE_L: CH1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sTouch TOUCHBYTELCH1 { get; }
Public ReadOnly Property TOUCHBYTELCH1 As Stmpe1208sTouch
    Get
public:
property Stmpe1208sTouch TOUCHBYTELCH1 {
    Stmpe1208sTouch get ();
}
member TOUCHBYTELCH1 : Stmpe1208sTouch with get

Property Value

Type: Stmpe1208sTouch
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TOUCHBYTELCH2 Property

IRD

Stmpe1208sTOUCHBYTELCH2 Property

TOUCH_BYTE_L: CH2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sTouch TOUCHBYTELCH2 { get; }
Public ReadOnly Property TOUCHBYTELCH2 As Stmpe1208sTouch
    Get
public:
property Stmpe1208sTouch TOUCHBYTELCH2 {
    Stmpe1208sTouch get ();
}
member TOUCHBYTELCH2 : Stmpe1208sTouch with get

Property Value

Type: Stmpe1208sTouch
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TOUCHBYTELCH3 Property

IRD

Stmpe1208sTOUCHBYTELCH3 Property

TOUCH_BYTE_L: CH3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sTouch TOUCHBYTELCH3 { get; }
Public ReadOnly Property TOUCHBYTELCH3 As Stmpe1208sTouch
    Get
public:
property Stmpe1208sTouch TOUCHBYTELCH3 {
    Stmpe1208sTouch get ();
}
member TOUCHBYTELCH3 : Stmpe1208sTouch with get

Property Value

Type: Stmpe1208sTouch
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TOUCHBYTELCH4 Property

IRD

Stmpe1208sTOUCHBYTELCH4 Property

TOUCH_BYTE_L: CH4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sTouch TOUCHBYTELCH4 { get; }
Public ReadOnly Property TOUCHBYTELCH4 As Stmpe1208sTouch
    Get
public:
property Stmpe1208sTouch TOUCHBYTELCH4 {
    Stmpe1208sTouch get ();
}
member TOUCHBYTELCH4 : Stmpe1208sTouch with get

Property Value

Type: Stmpe1208sTouch
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TOUCHBYTELCH5 Property

IRD

Stmpe1208sTOUCHBYTELCH5 Property

TOUCH_BYTE_L: CH5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sTouch TOUCHBYTELCH5 { get; }
Public ReadOnly Property TOUCHBYTELCH5 As Stmpe1208sTouch
    Get
public:
property Stmpe1208sTouch TOUCHBYTELCH5 {
    Stmpe1208sTouch get ();
}
member TOUCHBYTELCH5 : Stmpe1208sTouch with get

Property Value

Type: Stmpe1208sTouch
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TOUCHBYTELCH6 Property

IRD

Stmpe1208sTOUCHBYTELCH6 Property

TOUCH_BYTE_L: CH6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sTouch TOUCHBYTELCH6 { get; }
Public ReadOnly Property TOUCHBYTELCH6 As Stmpe1208sTouch
    Get
public:
property Stmpe1208sTouch TOUCHBYTELCH6 {
    Stmpe1208sTouch get ();
}
member TOUCHBYTELCH6 : Stmpe1208sTouch with get

Property Value

Type: Stmpe1208sTouch
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TOUCHBYTELCH7 Property

IRD

Stmpe1208sTOUCHBYTELCH7 Property

TOUCH_BYTE_L: CH7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe1208sTouch TOUCHBYTELCH7 { get; }
Public ReadOnly Property TOUCHBYTELCH7 As Stmpe1208sTouch
    Get
public:
property Stmpe1208sTouch TOUCHBYTELCH7 {
    Stmpe1208sTouch get ();
}
member TOUCHBYTELCH7 : Stmpe1208sTouch with get

Property Value

Type: Stmpe1208sTouch
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TVR0 Property

IRD

Stmpe1208sTVR0 Property

TVR 0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR0 { get; set; }
Public Property TVR0 As Byte
    Get
    Set
public:
property unsigned char TVR0 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TVR1 Property

IRD

Stmpe1208sTVR1 Property

TVR 1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR1 { get; set; }
Public Property TVR1 As Byte
    Get
    Set
public:
property unsigned char TVR1 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TVR10 Property

IRD

Stmpe1208sTVR10 Property

TVR 10

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR10 { get; set; }
Public Property TVR10 As Byte
    Get
    Set
public:
property unsigned char TVR10 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR10 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TVR11 Property

IRD

Stmpe1208sTVR11 Property

TVR 11

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR11 { get; set; }
Public Property TVR11 As Byte
    Get
    Set
public:
property unsigned char TVR11 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR11 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TVR2 Property

IRD

Stmpe1208sTVR2 Property

TVR 2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR2 { get; set; }
Public Property TVR2 As Byte
    Get
    Set
public:
property unsigned char TVR2 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TVR3 Property

IRD

Stmpe1208sTVR3 Property

TVR 3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR3 { get; set; }
Public Property TVR3 As Byte
    Get
    Set
public:
property unsigned char TVR3 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TVR4 Property

IRD

Stmpe1208sTVR4 Property

TVR 4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR4 { get; set; }
Public Property TVR4 As Byte
    Get
    Set
public:
property unsigned char TVR4 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TVR5 Property

IRD

Stmpe1208sTVR5 Property

TVR 5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR5 { get; set; }
Public Property TVR5 As Byte
    Get
    Set
public:
property unsigned char TVR5 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TVR6 Property

IRD

Stmpe1208sTVR6 Property

TVR 6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR6 { get; set; }
Public Property TVR6 As Byte
    Get
    Set
public:
property unsigned char TVR6 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TVR7 Property

IRD

Stmpe1208sTVR7 Property

TVR 7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR7 { get; set; }
Public Property TVR7 As Byte
    Get
    Set
public:
property unsigned char TVR7 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TVR8 Property

IRD

Stmpe1208sTVR8 Property

TVR 8

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR8 { get; set; }
Public Property TVR8 As Byte
    Get
    Set
public:
property unsigned char TVR8 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR8 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.TVR9 Property

IRD

Stmpe1208sTVR9 Property

TVR 9

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR9 { get; set; }
Public Property TVR9 As Byte
    Get
    Set
public:
property unsigned char TVR9 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR9 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s Methods

The Stmpe1208s type exposes the following members.

Methods
 | Name | Description
Public method | BIASOFF | BIAS_OFF
Public method | BIASON | BIAS_ON
Public method | CLKSRCEXTERNAL | CLK_SRC_EXTERNAL
Public method | CLKSRCINTERNAL | CLK_SRC_INTERNAL
Public method | ColdReset | Cold Reset
Public method | EnterSleep | Enter Sleep
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WakeUp | Wake Up
Public method | WarmReset | Warm Reset
Top
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.BIASOFF Method

IRD

Stmpe1208sBIASOFF Method

BIAS_OFF

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void BIASOFF()
Public Sub BIASOFF
public:
void BIASOFF()
member BIASOFF : unit -> unit
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.BIASON Method

IRD

Stmpe1208sBIASON Method

BIAS_ON

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void BIASON()
Public Sub BIASON
public:
void BIASON()
member BIASON : unit -> unit
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CLKSRCEXTERNAL Method

IRD

Stmpe1208sCLKSRCEXTERNAL Method

CLK_SRC_EXTERNAL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void CLKSRCEXTERNAL()
Public Sub CLKSRCEXTERNAL
public:
void CLKSRCEXTERNAL()
member CLKSRCEXTERNAL : unit -> unit
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.CLKSRCINTERNAL Method

IRD

Stmpe1208sCLKSRCINTERNAL Method

CLK_SRC_INTERNAL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void CLKSRCINTERNAL()
Public Sub CLKSRCINTERNAL
public:
void CLKSRCINTERNAL()
member CLKSRCINTERNAL : unit -> unit
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.ColdReset Method

IRD

Stmpe1208sColdReset Method

Cold Reset

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void ColdReset()
Public Sub ColdReset
public:
void ColdReset()
member ColdReset : unit -> unit
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.EnterSleep Method

IRD

Stmpe1208sEnterSleep Method

Enter Sleep

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void EnterSleep()
Public Sub EnterSleep
public:
void EnterSleep()
member EnterSleep : unit -> unit
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.Flush Method

IRD

Stmpe1208sFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.WakeUp Method

IRD

Stmpe1208sWakeUp Method

Wake Up

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void WakeUp()
Public Sub WakeUp
public:
void WakeUp()
member WakeUp : unit -> unit
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.WarmReset Method

IRD

Stmpe1208sWarmReset Method

Warm Reset

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void WarmReset()
Public Sub WarmReset
public:
void WarmReset()
member WarmReset : unit -> unit
See Also

Reference

Stmpe1208s Class
telos.Ird.ST Namespace


Stmpe1208s.Ctrl1HoldC Enumeration

IRD

Stmpe1208sCtrl1HoldC Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Ctrl1HoldC
Public Enumeration Ctrl1HoldC
public enum class Ctrl1HoldC
type Ctrl1HoldC
Members
Member name | Value | Description
AutoCalibrationEnabled | 0 | Auto-Calibration: Enabled
AutoCalibrationDisabled | 1 | Auto-Calibration: Disabled
See Also

Reference

telos.Ird.ST Namespace


Stmpe1208s.Ctrl1Ndiv Enumeration

IRD

Stmpe1208sCtrl1Ndiv Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Ctrl1Ndiv
Public Enumeration Ctrl1Ndiv
public enum class Ctrl1Ndiv
type Ctrl1Ndiv
Members
Member name | Value | Description
SystemClock80 | 0 | System Clock / 80
SystemClock160 | 1 | System Clock / 160
See Also

Reference

telos.Ird.ST Namespace


Stmpe1208s.Ctrl1Pdiv Enumeration

IRD

Stmpe1208sCtrl1Pdiv Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Ctrl1Pdiv
Public Enumeration Ctrl1Pdiv
public enum class Ctrl1Pdiv
type Ctrl1Pdiv
Members
Member name | Value | Description
Value_1600 | 0 | 1600
Value_800 | 1 | 800
Value_400 | 2 | 400
Value_200 | 3 | 200
See Also

Reference

telos.Ird.ST Namespace


Stmpe1208s.Ctrl2BeepEn Enumeration

IRD

Stmpe1208sCtrl2BeepEn Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Ctrl2BeepEn
Public Enumeration Ctrl2BeepEn
public enum class Ctrl2BeepEn
type Ctrl2BeepEn
Members
Member name | Value | Description
BeepOutputDisabled | 0 | Beep Output: Disabled
BeepOutputEnabled | 1 | Beep Output: Enabled
See Also

Reference

telos.Ird.ST Namespace


Stmpe1208s.Ctrl2IntPol Enumeration

IRD

Stmpe1208sCtrl2IntPol Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Ctrl2IntPol
Public Enumeration Ctrl2IntPol
public enum class Ctrl2IntPol
type Ctrl2IntPol
Members
Member name | Value | Description
RisingEdge | 0 | Rising Edge
FallingEdge | 1 | Falling Edge
See Also

Reference

telos.Ird.ST Namespace


Stmpe1208s.Ctrl2Regd Enumeration

IRD

Stmpe1208sCtrl2Regd Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Ctrl2Regd
Public Enumeration Ctrl2Regd
public enum class Ctrl2Regd
type Ctrl2Regd
Members
Member name | Value | Description
InternalRegulatorEnabled | 0 | Internal Regulator: Enabled
InternalRegulatorDisabled | 1 | Internal Regulator: Disabled
See Also

Reference

telos.Ird.ST Namespace


Stmpe1208s.Ctrl2Scd Enumeration

IRD

Stmpe1208sCtrl2Scd Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Ctrl2Scd
Public Enumeration Ctrl2Scd
public enum class Ctrl2Scd
type Ctrl2Scd
Members
Member name | Value | Description
SensorClockEnabled | 0 | Sensor Clock: Enabled
SensorClockDisabled | 1 | Sensor Clock: Disabled
See Also

Reference

telos.Ird.ST Namespace


Stmpe1208s.EnableDisable Enumeration

IRD

Stmpe1208sEnableDisable Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum EnableDisable
Public Enumeration EnableDisable
public enum class EnableDisable
type EnableDisable
Members
Member name | Value | Description
Enabled | 1 | Enabled
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.ST Namespace


Stmpe1208s.ExtIntPol Enumeration

IRD

Stmpe1208sExtIntPol Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExtIntPol
Public Enumeration ExtIntPol
public enum class ExtIntPol
type ExtIntPol
Members
Member name | Value | Description
PositiveEdge | 0 | Positive Edge
NegativeEdge | 1 | Negative Edge
See Also

Reference

telos.Ird.ST Namespace


Stmpe1208s.GpioDir Enumeration

IRD

Stmpe1208sGpioDir Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum GpioDir
Public Enumeration GpioDir
public enum class GpioDir
type GpioDir
Members
Member name | Value | Description
Input | 1 | Input
Output | 0 | Output
See Also

Reference

telos.Ird.ST Namespace


Stmpe1208s.Status Enumeration

IRD

Stmpe1208sStatus Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Status
Public Enumeration Status
public enum class Status
type Status
Members
Member name | Value | Description
Idle | 1 | Idle
NotIdle | 0 | Not Idle
See Also

Reference

telos.Ird.ST Namespace


Stmpe1208s.Touch Enumeration

IRD

Stmpe1208sTouch Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Touch
Public Enumeration Touch
public enum class Touch
type Touch
Members
Member name | Value | Description
Touched | 1 | Touched
NotTouched | 0 | Not Touched
See Also

Reference

telos.Ird.ST Namespace


Stmpe1208s.Uint8 Enumeration

IRD

Stmpe1208sUint8 Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Uint8
Public Enumeration Uint8
public enum class Uint8
type Uint8
Members
Member name | Value | Description
Clear | 1 | Clear
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.ST Namespace


Stmpe321 Class

ST: STMPE 321
Inheritance Hierarchy
SystemObject
telos.Ird.STStmpe321

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Stmpe321
Public Class Stmpe321
public ref class Stmpe321
type Stmpe321 =  class end

The Stmpe321 type exposes the following members.

Constructors
 | Name | Description
Public method | Stmpe321 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CALIBRATEDIMPEDANCE0 | CALIBRATED_IMPEDANCE 0
Public property | CALIBRATEDIMPEDANCE1 | CALIBRATED_IMPEDANCE 1
Public property | CALIBRATEDIMPEDANCE2 | CALIBRATED_IMPEDANCE 2
Public property | CALINTERVAL | CAL_INTERVAL
Public property | CHIPID0 | CHIP_ID_0
Public property | CHIPID1 | CHIP_ID_1
Public property | CTRLF2A | CTRL: F2A
Public property | CTRLHDCC | CTRL: HDC_C
Public property | CTRLHDCU | CTRL: HDC_U
Public property | CTRLHOLD | CTRL: HOLD
Public property | ETCWAIT | ETC_WAIT
Public property | EVR | EVR
Public property | FEATURESELECTAFS | FEATURE_SELECT: AFS
Public property | FEATURESELECTFilterEN | FEATURE_SELECT: Filter EN
Public property | FIFO0 | FIFO-0
Public property | FIFO1 | FIFO-1
Public property | FIFO2 | FIFO-2
Public property | FIFO3 | FIFO-3
Public property | FILTERPERIOD | FILTER_PERIOD
Public property | FILTERTHRESHOLD | FILTER_THRESHOLD
Public property | GPIODIRIO0 | GPIO_DIR: IO-0
Public property | GPIODIRIO1 | GPIO_DIR: IO-1
Public property | GPIODIRIO2 | GPIO_DIR: IO-2
Public property | GPIOFUNCTIO0 | GPIO_FUNCT: IO-0
Public property | GPIOFUNCTIO1 | GPIO_FUNCT: IO-1
Public property | GPIOFUNCTIO2 | GPIO_FUNCT: IO-2
Public property | GPIOINTENIO0 | GPIO_INT_EN: IO-0
Public property | GPIOINTENIO1 | GPIO_INT_EN: IO-1
Public property | GPIOINTENIO2 | GPIO_INT_EN: IO-2
Public property | GPIOINTSTAIO0 | GPIO_INT_STA: IO-0
Public property | GPIOINTSTAIO1 | GPIO_INT_STA: IO-1
Public property | GPIOINTSTAIO2 | GPIO_INT_STA: IO-2
Public property | GPIOMRIO0 | GPIO_MR: IO-0
Public property | GPIOMRIO1 | GPIO_MR: IO-1
Public property | GPIOMRIO2 | GPIO_MR: IO-2
Public property | GPIOSETIO0 | GPIO_SET: IO-0
Public property | GPIOSETIO1 | GPIO_SET: IO-1
Public property | GPIOSETIO2 | GPIO_SET: IO-2
Public property | IDVER | ID_VER
Public property | IMPEDANCE0 | IMPEDANCE 0
Public property | IMPEDANCE1 | IMPEDANCE 1
Public property | IMPEDANCE2 | IMPEDANCE 2
Public property | INTCLREOC | INT_CLR: EOC
Public property | INTCTRLINTEN | INT_CTRL: INT_EN
Public property | INTCTRLPOLARITY | INT_CTRL: POLARITY
Public property | INTCTRLTYPE | INT_CTRL: TYPE
Public property | INTEGRATIONTIME | INTEGRATION_TIME
Public property | INTENFIFO | INT_EN: FIFO
Public property | INTENGEN | INT_EN: GEN
Public property | INTENGPIO | INT_EN: GPIO
Public property | INTENPOR | INT_EN: POR
Public property | INTMASKEOC | INT_MASK: EOC
Public property | INTSTAFIFO | INT_STA: FIFO
Public property | INTSTAGEN | INT_STA: GEN
Public property | INTSTAGPIO | INT_STA: GPIO
Public property | INTSTAPOR | INT_STA: POR
Public property | REFERENCEDELAY | REFERENCE_DELAY
Public property | STRENGTH0 | STRENGTH 0
Public property | STRENGTH1 | STRENGTH 1
Public property | STRENGTH2 | STRENGTH 2
Public property | STRENGTHTHRESHOLD0 | STRENGTH_THRESHOLD 0
Public property | STRENGTHTHRESHOLD1 | STRENGTH_THRESHOLD 1
Public property | STRENGTHTHRESHOLD2 | STRENGTH_THRESHOLD 2
Public property | SYSCFG1HIBERNATE | SYS_CFG_1: HIBERNATE
Public property | SYSCFG1SLEEP | SYS_CFG_1: SLEEP
Public property | SYSCFG1SOFTRESET | SYS_CFG_1: SOFT_RESET
Public property | SYSCFG1WARMRESET | SYS_CFG_1: WARM_RESET
Public property | SYSCFG2FIFOCLOCKDISABLE | SYS_CFG_2: FIFO_CLOCK_DISABLE
Public property | SYSCFG2GPIOCLOCKDISABLE | SYS_CFG_2: GPIO CLOCK DISABLE
Public property | SYSCFG2SENSORCLOCK | SYS_CFG_2: SENSOR_CLOCK
Public property | SYSCFG2TOUCHCLOCKDISABLE | SYS_CFG_2: TOUCH CLOCK DISABLE
Public property | TINTPENDINGEOC | TINT_PENDING: EOC
Public property | TVR0 | TVR 0
Public property | TVR1 | TVR 1
Public property | TVR2 | TVR 2
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
3-Channel Capacitive Touchkey Controller
See Also

Reference

telos.Ird.ST Namespace


Stmpe321 Constructor

Constructor

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe321(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Stmpe321(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Stmpe321

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321 Properties

The Stmpe321 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CALIBRATEDIMPEDANCE0 | CALIBRATED_IMPEDANCE 0
Public property | CALIBRATEDIMPEDANCE1 | CALIBRATED_IMPEDANCE 1
Public property | CALIBRATEDIMPEDANCE2 | CALIBRATED_IMPEDANCE 2
Public property | CALINTERVAL | CAL_INTERVAL
Public property | CHIPID0 | CHIP_ID_0
Public property | CHIPID1 | CHIP_ID_1
Public property | CTRLF2A | CTRL: F2A
Public property | CTRLHDCC | CTRL: HDC_C
Public property | CTRLHDCU | CTRL: HDC_U
Public property | CTRLHOLD | CTRL: HOLD
Public property | ETCWAIT | ETC_WAIT
Public property | EVR | EVR
Public property | FEATURESELECTAFS | FEATURE_SELECT: AFS
Public property | FEATURESELECTFilterEN | FEATURE_SELECT: Filter EN
Public property | FIFO0 | FIFO-0
Public property | FIFO1 | FIFO-1
Public property | FIFO2 | FIFO-2
Public property | FIFO3 | FIFO-3
Public property | FILTERPERIOD | FILTER_PERIOD
Public property | FILTERTHRESHOLD | FILTER_THRESHOLD
Public property | GPIODIRIO0 | GPIO_DIR: IO-0
Public property | GPIODIRIO1 | GPIO_DIR: IO-1
Public property | GPIODIRIO2 | GPIO_DIR: IO-2
Public property | GPIOFUNCTIO0 | GPIO_FUNCT: IO-0
Public property | GPIOFUNCTIO1 | GPIO_FUNCT: IO-1
Public property | GPIOFUNCTIO2 | GPIO_FUNCT: IO-2
Public property | GPIOINTENIO0 | GPIO_INT_EN: IO-0
Public property | GPIOINTENIO1 | GPIO_INT_EN: IO-1
Public property | GPIOINTENIO2 | GPIO_INT_EN: IO-2
Public property | GPIOINTSTAIO0 | GPIO_INT_STA: IO-0
Public property | GPIOINTSTAIO1 | GPIO_INT_STA: IO-1
Public property | GPIOINTSTAIO2 | GPIO_INT_STA: IO-2
Public property | GPIOMRIO0 | GPIO_MR: IO-0
Public property | GPIOMRIO1 | GPIO_MR: IO-1
Public property | GPIOMRIO2 | GPIO_MR: IO-2
Public property | GPIOSETIO0 | GPIO_SET: IO-0
Public property | GPIOSETIO1 | GPIO_SET: IO-1
Public property | GPIOSETIO2 | GPIO_SET: IO-2
Public property | IDVER | ID_VER
Public property | IMPEDANCE0 | IMPEDANCE 0
Public property | IMPEDANCE1 | IMPEDANCE 1
Public property | IMPEDANCE2 | IMPEDANCE 2
Public property | INTCLREOC | INT_CLR: EOC
Public property | INTCTRLINTEN | INT_CTRL: INT_EN
Public property | INTCTRLPOLARITY | INT_CTRL: POLARITY
Public property | INTCTRLTYPE | INT_CTRL: TYPE
Public property | INTEGRATIONTIME | INTEGRATION_TIME
Public property | INTENFIFO | INT_EN: FIFO
Public property | INTENGEN | INT_EN: GEN
Public property | INTENGPIO | INT_EN: GPIO
Public property | INTENPOR | INT_EN: POR
Public property | INTMASKEOC | INT_MASK: EOC
Public property | INTSTAFIFO | INT_STA: FIFO
Public property | INTSTAGEN | INT_STA: GEN
Public property | INTSTAGPIO | INT_STA: GPIO
Public property | INTSTAPOR | INT_STA: POR
Public property | REFERENCEDELAY | REFERENCE_DELAY
Public property | STRENGTH0 | STRENGTH 0
Public property | STRENGTH1 | STRENGTH 1
Public property | STRENGTH2 | STRENGTH 2
Public property | STRENGTHTHRESHOLD0 | STRENGTH_THRESHOLD 0
Public property | STRENGTHTHRESHOLD1 | STRENGTH_THRESHOLD 1
Public property | STRENGTHTHRESHOLD2 | STRENGTH_THRESHOLD 2
Public property | SYSCFG1HIBERNATE | SYS_CFG_1: HIBERNATE
Public property | SYSCFG1SLEEP | SYS_CFG_1: SLEEP
Public property | SYSCFG1SOFTRESET | SYS_CFG_1: SOFT_RESET
Public property | SYSCFG1WARMRESET | SYS_CFG_1: WARM_RESET
Public property | SYSCFG2FIFOCLOCKDISABLE | SYS_CFG_2: FIFO_CLOCK_DISABLE
Public property | SYSCFG2GPIOCLOCKDISABLE | SYS_CFG_2: GPIO CLOCK DISABLE
Public property | SYSCFG2SENSORCLOCK | SYS_CFG_2: SENSOR_CLOCK
Public property | SYSCFG2TOUCHCLOCKDISABLE | SYS_CFG_2: TOUCH CLOCK DISABLE
Public property | TINTPENDINGEOC | TINT_PENDING: EOC
Public property | TVR0 | TVR 0
Public property | TVR1 | TVR 1
Public property | TVR2 | TVR 2
Top
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.AutoFlush Property

IRD

Stmpe321AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.CALIBRATEDIMPEDANCE0 Property

IRD

Stmpe321CALIBRATEDIMPEDANCE0 Property

CALIBRATED_IMPEDANCE 0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CALIBRATEDIMPEDANCE0 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE0 As Byte
    Get
public:
property unsigned char CALIBRATEDIMPEDANCE0 {
    unsigned char get ();
}
member CALIBRATEDIMPEDANCE0 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.CALIBRATEDIMPEDANCE1 Property

IRD

Stmpe321CALIBRATEDIMPEDANCE1 Property

CALIBRATED_IMPEDANCE 1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CALIBRATEDIMPEDANCE1 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE1 As Byte
    Get
public:
property unsigned char CALIBRATEDIMPEDANCE1 {
    unsigned char get ();
}
member CALIBRATEDIMPEDANCE1 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.CALIBRATEDIMPEDANCE2 Property

IRD

Stmpe321CALIBRATEDIMPEDANCE2 Property

CALIBRATED_IMPEDANCE 2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CALIBRATEDIMPEDANCE2 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE2 As Byte
    Get
public:
property unsigned char CALIBRATEDIMPEDANCE2 {
    unsigned char get ();
}
member CALIBRATEDIMPEDANCE2 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.CALINTERVAL Property

IRD

Stmpe321CALINTERVAL Property

CAL_INTERVAL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CALINTERVAL { get; set; }
Public Property CALINTERVAL As Byte
    Get
    Set
public:
property unsigned char CALINTERVAL {
    unsigned char get ();
    void set (unsigned char value);
}
member CALINTERVAL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.CHIPID0 Property

IRD

Stmpe321CHIPID0 Property

CHIP_ID_0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CHIPID0 { get; }
Public ReadOnly Property CHIPID0 As Byte
    Get
public:
property unsigned char CHIPID0 {
    unsigned char get ();
}
member CHIPID0 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.CHIPID1 Property

IRD

Stmpe321CHIPID1 Property

CHIP_ID_1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CHIPID1 { get; }
Public ReadOnly Property CHIPID1 As Byte
    Get
public:
property unsigned char CHIPID1 {
    unsigned char get ();
}
member CHIPID1 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.CTRLF2A Property

IRD

Stmpe321CTRLF2A Property

CTRL: F2A

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CTRLF2A { get; set; }
Public Property CTRLF2A As Byte
    Get
    Set
public:
property unsigned char CTRLF2A {
    unsigned char get ();
    void set (unsigned char value);
}
member CTRLF2A : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.CTRLHDCC Property

IRD

Stmpe321CTRLHDCC Property

CTRL: HDC_C

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CTRLHDCC { get; set; }
Public Property CTRLHDCC As Byte
    Get
    Set
public:
property unsigned char CTRLHDCC {
    unsigned char get ();
    void set (unsigned char value);
}
member CTRLHDCC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.CTRLHDCU Property

IRD

Stmpe321CTRLHDCU Property

CTRL: HDC_U

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CTRLHDCU { get; set; }
Public Property CTRLHDCU As Byte
    Get
    Set
public:
property unsigned char CTRLHDCU {
    unsigned char get ();
    void set (unsigned char value);
}
member CTRLHDCU : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.CTRLHOLD Property

IRD

Stmpe321CTRLHOLD Property

CTRL: HOLD

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CTRLHOLD { get; set; }
Public Property CTRLHOLD As Byte
    Get
    Set
public:
property unsigned char CTRLHOLD {
    unsigned char get ();
    void set (unsigned char value);
}
member CTRLHOLD : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.ETCWAIT Property

IRD

Stmpe321ETCWAIT Property

ETC_WAIT

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ETCWAIT { get; set; }
Public Property ETCWAIT As Byte
    Get
    Set
public:
property unsigned char ETCWAIT {
    unsigned char get ();
    void set (unsigned char value);
}
member ETCWAIT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.EVR Property

IRD

Stmpe321EVR Property

EVR

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EVR { get; set; }
Public Property EVR As Byte
    Get
    Set
public:
property unsigned char EVR {
    unsigned char get ();
    void set (unsigned char value);
}
member EVR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.FEATURESELECTAFS Property

IRD

Stmpe321FEATURESELECTAFS Property

FEATURE_SELECT: AFS

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe321FeatureSelAfs FEATURESELECTAFS { get; set; }
Public Property FEATURESELECTAFS As Stmpe321FeatureSelAfs
    Get
    Set
public:
property Stmpe321FeatureSelAfs FEATURESELECTAFS {
    Stmpe321FeatureSelAfs get ();
    void set (Stmpe321FeatureSelAfs value);
}
member FEATURESELECTAFS : Stmpe321FeatureSelAfs with get, set

Property Value

Type: Stmpe321FeatureSelAfs
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.FEATURESELECTFilterEN Property

IRD

Stmpe321FEATURESELECTFilterEN Property

FEATURE_SELECT: Filter EN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FEATURESELECTFilterEN { get; set; }
Public Property FEATURESELECTFilterEN As Byte
    Get
    Set
public:
property unsigned char FEATURESELECTFilterEN {
    unsigned char get ();
    void set (unsigned char value);
}
member FEATURESELECTFilterEN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.FIFO0 Property

IRD

Stmpe321FIFO0 Property

FIFO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort FIFO0 { get; }
Public ReadOnly Property FIFO0 As UShort
    Get
public:
property unsigned short FIFO0 {
    unsigned short get ();
}
member FIFO0 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.FIFO1 Property

IRD

Stmpe321FIFO1 Property

FIFO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort FIFO1 { get; }
Public ReadOnly Property FIFO1 As UShort
    Get
public:
property unsigned short FIFO1 {
    unsigned short get ();
}
member FIFO1 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.FIFO2 Property

IRD

Stmpe321FIFO2 Property

FIFO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort FIFO2 { get; }
Public ReadOnly Property FIFO2 As UShort
    Get
public:
property unsigned short FIFO2 {
    unsigned short get ();
}
member FIFO2 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.FIFO3 Property

IRD

Stmpe321FIFO3 Property

FIFO-3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort FIFO3 { get; }
Public ReadOnly Property FIFO3 As UShort
    Get
public:
property unsigned short FIFO3 {
    unsigned short get ();
}
member FIFO3 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.FILTERPERIOD Property

IRD

Stmpe321FILTERPERIOD Property

FILTER_PERIOD

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FILTERPERIOD { get; set; }
Public Property FILTERPERIOD As Byte
    Get
    Set
public:
property unsigned char FILTERPERIOD {
    unsigned char get ();
    void set (unsigned char value);
}
member FILTERPERIOD : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.FILTERTHRESHOLD Property

IRD

Stmpe321FILTERTHRESHOLD Property

FILTER_THRESHOLD

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FILTERTHRESHOLD { get; set; }
Public Property FILTERTHRESHOLD As Byte
    Get
    Set
public:
property unsigned char FILTERTHRESHOLD {
    unsigned char get ();
    void set (unsigned char value);
}
member FILTERTHRESHOLD : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.GPIODIRIO0 Property

IRD

Stmpe321GPIODIRIO0 Property

GPIO_DIR: IO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe321GpioDir GPIODIRIO0 { get; set; }
Public Property GPIODIRIO0 As Stmpe321GpioDir
    Get
    Set
public:
property Stmpe321GpioDir GPIODIRIO0 {
    Stmpe321GpioDir get ();
    void set (Stmpe321GpioDir value);
}
member GPIODIRIO0 : Stmpe321GpioDir with get, set

Property Value

Type: Stmpe321GpioDir
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.GPIODIRIO1 Property

IRD

Stmpe321GPIODIRIO1 Property

GPIO_DIR: IO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe321GpioDir GPIODIRIO1 { get; set; }
Public Property GPIODIRIO1 As Stmpe321GpioDir
    Get
    Set
public:
property Stmpe321GpioDir GPIODIRIO1 {
    Stmpe321GpioDir get ();
    void set (Stmpe321GpioDir value);
}
member GPIODIRIO1 : Stmpe321GpioDir with get, set

Property Value

Type: Stmpe321GpioDir
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.GPIODIRIO2 Property

IRD

Stmpe321GPIODIRIO2 Property

GPIO_DIR: IO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe321GpioDir GPIODIRIO2 { get; set; }
Public Property GPIODIRIO2 As Stmpe321GpioDir
    Get
    Set
public:
property Stmpe321GpioDir GPIODIRIO2 {
    Stmpe321GpioDir get ();
    void set (Stmpe321GpioDir value);
}
member GPIODIRIO2 : Stmpe321GpioDir with get, set

Property Value

Type: Stmpe321GpioDir
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.GPIOFUNCTIO0 Property

IRD

Stmpe321GPIOFUNCTIO0 Property

GPIO_FUNCT: IO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe321GpioFunct GPIOFUNCTIO0 { get; set; }
Public Property GPIOFUNCTIO0 As Stmpe321GpioFunct
    Get
    Set
public:
property Stmpe321GpioFunct GPIOFUNCTIO0 {
    Stmpe321GpioFunct get ();
    void set (Stmpe321GpioFunct value);
}
member GPIOFUNCTIO0 : Stmpe321GpioFunct with get, set

Property Value

Type: Stmpe321GpioFunct
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.GPIOFUNCTIO1 Property

IRD

Stmpe321GPIOFUNCTIO1 Property

GPIO_FUNCT: IO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe321GpioFunct GPIOFUNCTIO1 { get; set; }
Public Property GPIOFUNCTIO1 As Stmpe321GpioFunct
    Get
    Set
public:
property Stmpe321GpioFunct GPIOFUNCTIO1 {
    Stmpe321GpioFunct get ();
    void set (Stmpe321GpioFunct value);
}
member GPIOFUNCTIO1 : Stmpe321GpioFunct with get, set

Property Value

Type: Stmpe321GpioFunct
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.GPIOFUNCTIO2 Property

IRD

Stmpe321GPIOFUNCTIO2 Property

GPIO_FUNCT: IO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe321GpioFunct GPIOFUNCTIO2 { get; set; }
Public Property GPIOFUNCTIO2 As Stmpe321GpioFunct
    Get
    Set
public:
property Stmpe321GpioFunct GPIOFUNCTIO2 {
    Stmpe321GpioFunct get ();
    void set (Stmpe321GpioFunct value);
}
member GPIOFUNCTIO2 : Stmpe321GpioFunct with get, set

Property Value

Type: Stmpe321GpioFunct
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.GPIOINTENIO0 Property

IRD

Stmpe321GPIOINTENIO0 Property

GPIO_INT_EN: IO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe321Enable1Disable0 GPIOINTENIO0 { get; set; }
Public Property GPIOINTENIO0 As Stmpe321Enable1Disable0
    Get
    Set
public:
property Stmpe321Enable1Disable0 GPIOINTENIO0 {
    Stmpe321Enable1Disable0 get ();
    void set (Stmpe321Enable1Disable0 value);
}
member GPIOINTENIO0 : Stmpe321Enable1Disable0 with get, set

Property Value

Type: Stmpe321Enable1Disable0
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.GPIOINTENIO1 Property

IRD

Stmpe321GPIOINTENIO1 Property

GPIO_INT_EN: IO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe321Enable1Disable0 GPIOINTENIO1 { get; set; }
Public Property GPIOINTENIO1 As Stmpe321Enable1Disable0
    Get
    Set
public:
property Stmpe321Enable1Disable0 GPIOINTENIO1 {
    Stmpe321Enable1Disable0 get ();
    void set (Stmpe321Enable1Disable0 value);
}
member GPIOINTENIO1 : Stmpe321Enable1Disable0 with get, set

Property Value

Type: Stmpe321Enable1Disable0
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.GPIOINTENIO2 Property

IRD

Stmpe321GPIOINTENIO2 Property

GPIO_INT_EN: IO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe321Enable1Disable0 GPIOINTENIO2 { get; set; }
Public Property GPIOINTENIO2 As Stmpe321Enable1Disable0
    Get
    Set
public:
property Stmpe321Enable1Disable0 GPIOINTENIO2 {
    Stmpe321Enable1Disable0 get ();
    void set (Stmpe321Enable1Disable0 value);
}
member GPIOINTENIO2 : Stmpe321Enable1Disable0 with get, set

Property Value

Type: Stmpe321Enable1Disable0
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.GPIOINTSTAIO0 Property

IRD

Stmpe321GPIOINTSTAIO0 Property

GPIO_INT_STA: IO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINTSTAIO0 { get; set; }
Public Property GPIOINTSTAIO0 As Byte
    Get
    Set
public:
property unsigned char GPIOINTSTAIO0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOINTSTAIO0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.GPIOINTSTAIO1 Property

IRD

Stmpe321GPIOINTSTAIO1 Property

GPIO_INT_STA: IO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINTSTAIO1 { get; set; }
Public Property GPIOINTSTAIO1 As Byte
    Get
    Set
public:
property unsigned char GPIOINTSTAIO1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOINTSTAIO1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.GPIOINTSTAIO2 Property

IRD

Stmpe321GPIOINTSTAIO2 Property

GPIO_INT_STA: IO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINTSTAIO2 { get; set; }
Public Property GPIOINTSTAIO2 As Byte
    Get
    Set
public:
property unsigned char GPIOINTSTAIO2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOINTSTAIO2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.GPIOMRIO0 Property

IRD

Stmpe321GPIOMRIO0 Property

GPIO_MR: IO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOMRIO0 { get; set; }
Public Property GPIOMRIO0 As Byte
    Get
    Set
public:
property unsigned char GPIOMRIO0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOMRIO0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.GPIOMRIO1 Property

IRD

Stmpe321GPIOMRIO1 Property

GPIO_MR: IO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOMRIO1 { get; set; }
Public Property GPIOMRIO1 As Byte
    Get
    Set
public:
property unsigned char GPIOMRIO1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOMRIO1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.GPIOMRIO2 Property

IRD

Stmpe321GPIOMRIO2 Property

GPIO_MR: IO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOMRIO2 { get; set; }
Public Property GPIOMRIO2 As Byte
    Get
    Set
public:
property unsigned char GPIOMRIO2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOMRIO2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.GPIOSETIO0 Property

IRD

Stmpe321GPIOSETIO0 Property

GPIO_SET: IO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSETIO0 { get; set; }
Public Property GPIOSETIO0 As Byte
    Get
    Set
public:
property unsigned char GPIOSETIO0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSETIO0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.GPIOSETIO1 Property

IRD

Stmpe321GPIOSETIO1 Property

GPIO_SET: IO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSETIO1 { get; set; }
Public Property GPIOSETIO1 As Byte
    Get
    Set
public:
property unsigned char GPIOSETIO1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSETIO1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.GPIOSETIO2 Property

IRD

Stmpe321GPIOSETIO2 Property

GPIO_SET: IO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSETIO2 { get; set; }
Public Property GPIOSETIO2 As Byte
    Get
    Set
public:
property unsigned char GPIOSETIO2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSETIO2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.IDVER Property

IRD

Stmpe321IDVER Property

ID_VER

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IDVER { get; }
Public ReadOnly Property IDVER As Byte
    Get
public:
property unsigned char IDVER {
    unsigned char get ();
}
member IDVER : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.IMPEDANCE0 Property

IRD

Stmpe321IMPEDANCE0 Property

IMPEDANCE 0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IMPEDANCE0 { get; }
Public ReadOnly Property IMPEDANCE0 As Byte
    Get
public:
property unsigned char IMPEDANCE0 {
    unsigned char get ();
}
member IMPEDANCE0 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.IMPEDANCE1 Property

IRD

Stmpe321IMPEDANCE1 Property

IMPEDANCE 1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IMPEDANCE1 { get; }
Public ReadOnly Property IMPEDANCE1 As Byte
    Get
public:
property unsigned char IMPEDANCE1 {
    unsigned char get ();
}
member IMPEDANCE1 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.IMPEDANCE2 Property

IRD

Stmpe321IMPEDANCE2 Property

IMPEDANCE 2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IMPEDANCE2 { get; }
Public ReadOnly Property IMPEDANCE2 As Byte
    Get
public:
property unsigned char IMPEDANCE2 {
    unsigned char get ();
}
member IMPEDANCE2 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.INTCLREOC Property

IRD

Stmpe321INTCLREOC Property

INT_CLR: EOC

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTCLREOC { get; set; }
Public Property INTCLREOC As Byte
    Get
    Set
public:
property unsigned char INTCLREOC {
    unsigned char get ();
    void set (unsigned char value);
}
member INTCLREOC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.INTCTRLINTEN Property

IRD

Stmpe321INTCTRLINTEN Property

INT_CTRL: INT_EN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe321IntCtrlIntEn INTCTRLINTEN { get; set; }
Public Property INTCTRLINTEN As Stmpe321IntCtrlIntEn
    Get
    Set
public:
property Stmpe321IntCtrlIntEn INTCTRLINTEN {
    Stmpe321IntCtrlIntEn get ();
    void set (Stmpe321IntCtrlIntEn value);
}
member INTCTRLINTEN : Stmpe321IntCtrlIntEn with get, set

Property Value

Type: Stmpe321IntCtrlIntEn
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.INTCTRLPOLARITY Property

IRD

Stmpe321INTCTRLPOLARITY Property

INT_CTRL: POLARITY

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe321IntCtrlPolarity INTCTRLPOLARITY { get; set; }
Public Property INTCTRLPOLARITY As Stmpe321IntCtrlPolarity
    Get
    Set
public:
property Stmpe321IntCtrlPolarity INTCTRLPOLARITY {
    Stmpe321IntCtrlPolarity get ();
    void set (Stmpe321IntCtrlPolarity value);
}
member INTCTRLPOLARITY : Stmpe321IntCtrlPolarity with get, set

Property Value

Type: Stmpe321IntCtrlPolarity
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.INTCTRLTYPE Property

IRD

Stmpe321INTCTRLTYPE Property

INT_CTRL: TYPE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe321IntCtrlType INTCTRLTYPE { get; set; }
Public Property INTCTRLTYPE As Stmpe321IntCtrlType
    Get
    Set
public:
property Stmpe321IntCtrlType INTCTRLTYPE {
    Stmpe321IntCtrlType get ();
    void set (Stmpe321IntCtrlType value);
}
member INTCTRLTYPE : Stmpe321IntCtrlType with get, set

Property Value

Type: Stmpe321IntCtrlType
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.INTEGRATIONTIME Property

IRD

Stmpe321INTEGRATIONTIME Property

INTEGRATION_TIME

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTEGRATIONTIME { get; set; }
Public Property INTEGRATIONTIME As Byte
    Get
    Set
public:
property unsigned char INTEGRATIONTIME {
    unsigned char get ();
    void set (unsigned char value);
}
member INTEGRATIONTIME : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.INTENFIFO Property

IRD

Stmpe321INTENFIFO Property

INT_EN: FIFO

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENFIFO { get; set; }
Public Property INTENFIFO As Byte
    Get
    Set
public:
property unsigned char INTENFIFO {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENFIFO : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.INTENGEN Property

IRD

Stmpe321INTENGEN Property

INT_EN: GEN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENGEN { get; set; }
Public Property INTENGEN As Byte
    Get
    Set
public:
property unsigned char INTENGEN {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENGEN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.INTENGPIO Property

IRD

Stmpe321INTENGPIO Property

INT_EN: GPIO

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENGPIO { get; set; }
Public Property INTENGPIO As Byte
    Get
    Set
public:
property unsigned char INTENGPIO {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENGPIO : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.INTENPOR Property

IRD

Stmpe321INTENPOR Property

INT_EN: POR

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENPOR { get; set; }
Public Property INTENPOR As Byte
    Get
    Set
public:
property unsigned char INTENPOR {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENPOR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.INTMASKEOC Property

IRD

Stmpe321INTMASKEOC Property

INT_MASK: EOC

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTMASKEOC { get; set; }
Public Property INTMASKEOC As Byte
    Get
    Set
public:
property unsigned char INTMASKEOC {
    unsigned char get ();
    void set (unsigned char value);
}
member INTMASKEOC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.INTSTAFIFO Property

IRD

Stmpe321INTSTAFIFO Property

INT_STA: FIFO

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAFIFO { get; }
Public ReadOnly Property INTSTAFIFO As Byte
    Get
public:
property unsigned char INTSTAFIFO {
    unsigned char get ();
}
member INTSTAFIFO : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.INTSTAGEN Property

IRD

Stmpe321INTSTAGEN Property

INT_STA: GEN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAGEN { get; }
Public ReadOnly Property INTSTAGEN As Byte
    Get
public:
property unsigned char INTSTAGEN {
    unsigned char get ();
}
member INTSTAGEN : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.INTSTAGPIO Property

IRD

Stmpe321INTSTAGPIO Property

INT_STA: GPIO

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAGPIO { get; }
Public ReadOnly Property INTSTAGPIO As Byte
    Get
public:
property unsigned char INTSTAGPIO {
    unsigned char get ();
}
member INTSTAGPIO : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.INTSTAPOR Property

IRD

Stmpe321INTSTAPOR Property

INT_STA: POR

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAPOR { get; }
Public ReadOnly Property INTSTAPOR As Byte
    Get
public:
property unsigned char INTSTAPOR {
    unsigned char get ();
}
member INTSTAPOR : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.REFERENCEDELAY Property

IRD

Stmpe321REFERENCEDELAY Property

REFERENCE_DELAY

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte REFERENCEDELAY { get; set; }
Public Property REFERENCEDELAY As Byte
    Get
    Set
public:
property unsigned char REFERENCEDELAY {
    unsigned char get ();
    void set (unsigned char value);
}
member REFERENCEDELAY : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.STRENGTH0 Property

IRD

Stmpe321STRENGTH0 Property

STRENGTH 0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTH0 { get; }
Public ReadOnly Property STRENGTH0 As Byte
    Get
public:
property unsigned char STRENGTH0 {
    unsigned char get ();
}
member STRENGTH0 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.STRENGTH1 Property

IRD

Stmpe321STRENGTH1 Property

STRENGTH 1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTH1 { get; }
Public ReadOnly Property STRENGTH1 As Byte
    Get
public:
property unsigned char STRENGTH1 {
    unsigned char get ();
}
member STRENGTH1 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.STRENGTH2 Property

IRD

Stmpe321STRENGTH2 Property

STRENGTH 2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTH2 { get; }
Public ReadOnly Property STRENGTH2 As Byte
    Get
public:
property unsigned char STRENGTH2 {
    unsigned char get ();
}
member STRENGTH2 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.STRENGTHTHRESHOLD0 Property

IRD

Stmpe321STRENGTHTHRESHOLD0 Property

STRENGTH_THRESHOLD 0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTHTHRESHOLD0 { get; set; }
Public Property STRENGTHTHRESHOLD0 As Byte
    Get
    Set
public:
property unsigned char STRENGTHTHRESHOLD0 {
    unsigned char get ();
    void set (unsigned char value);
}
member STRENGTHTHRESHOLD0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.STRENGTHTHRESHOLD1 Property

IRD

Stmpe321STRENGTHTHRESHOLD1 Property

STRENGTH_THRESHOLD 1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTHTHRESHOLD1 { get; set; }
Public Property STRENGTHTHRESHOLD1 As Byte
    Get
    Set
public:
property unsigned char STRENGTHTHRESHOLD1 {
    unsigned char get ();
    void set (unsigned char value);
}
member STRENGTHTHRESHOLD1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.STRENGTHTHRESHOLD2 Property

IRD

Stmpe321STRENGTHTHRESHOLD2 Property

STRENGTH_THRESHOLD 2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTHTHRESHOLD2 { get; set; }
Public Property STRENGTHTHRESHOLD2 As Byte
    Get
    Set
public:
property unsigned char STRENGTHTHRESHOLD2 {
    unsigned char get ();
    void set (unsigned char value);
}
member STRENGTHTHRESHOLD2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.SYSCFG1HIBERNATE Property

IRD

Stmpe321SYSCFG1HIBERNATE Property

SYS_CFG_1: HIBERNATE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCFG1HIBERNATE { get; set; }
Public Property SYSCFG1HIBERNATE As Byte
    Get
    Set
public:
property unsigned char SYSCFG1HIBERNATE {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCFG1HIBERNATE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.SYSCFG1SLEEP Property

IRD

Stmpe321SYSCFG1SLEEP Property

SYS_CFG_1: SLEEP

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCFG1SLEEP { get; set; }
Public Property SYSCFG1SLEEP As Byte
    Get
    Set
public:
property unsigned char SYSCFG1SLEEP {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCFG1SLEEP : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.SYSCFG1SOFTRESET Property

IRD

Stmpe321SYSCFG1SOFTRESET Property

SYS_CFG_1: SOFT_RESET

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCFG1SOFTRESET { get; set; }
Public Property SYSCFG1SOFTRESET As Byte
    Get
    Set
public:
property unsigned char SYSCFG1SOFTRESET {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCFG1SOFTRESET : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.SYSCFG1WARMRESET Property

IRD

Stmpe321SYSCFG1WARMRESET Property

SYS_CFG_1: WARM_RESET

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCFG1WARMRESET { get; set; }
Public Property SYSCFG1WARMRESET As Byte
    Get
    Set
public:
property unsigned char SYSCFG1WARMRESET {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCFG1WARMRESET : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.SYSCFG2FIFOCLOCKDISABLE Property

IRD

Stmpe321SYSCFG2FIFOCLOCKDISABLE Property

SYS_CFG_2: FIFO_CLOCK_DISABLE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCFG2FIFOCLOCKDISABLE { get; set; }
Public Property SYSCFG2FIFOCLOCKDISABLE As Byte
    Get
    Set
public:
property unsigned char SYSCFG2FIFOCLOCKDISABLE {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCFG2FIFOCLOCKDISABLE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.SYSCFG2GPIOCLOCKDISABLE Property

IRD

Stmpe321SYSCFG2GPIOCLOCKDISABLE Property

SYS_CFG_2: GPIO CLOCK DISABLE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCFG2GPIOCLOCKDISABLE { get; set; }
Public Property SYSCFG2GPIOCLOCKDISABLE As Byte
    Get
    Set
public:
property unsigned char SYSCFG2GPIOCLOCKDISABLE {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCFG2GPIOCLOCKDISABLE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.SYSCFG2SENSORCLOCK Property

IRD

Stmpe321SYSCFG2SENSORCLOCK Property

SYS_CFG_2: SENSOR_CLOCK

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe321SysCfg2SensorClock SYSCFG2SENSORCLOCK { get; set; }
Public Property SYSCFG2SENSORCLOCK As Stmpe321SysCfg2SensorClock
    Get
    Set
public:
property Stmpe321SysCfg2SensorClock SYSCFG2SENSORCLOCK {
    Stmpe321SysCfg2SensorClock get ();
    void set (Stmpe321SysCfg2SensorClock value);
}
member SYSCFG2SENSORCLOCK : Stmpe321SysCfg2SensorClock with get, set

Property Value

Type: Stmpe321SysCfg2SensorClock
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.SYSCFG2TOUCHCLOCKDISABLE Property

IRD

Stmpe321SYSCFG2TOUCHCLOCKDISABLE Property

SYS_CFG_2: TOUCH CLOCK DISABLE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCFG2TOUCHCLOCKDISABLE { get; set; }
Public Property SYSCFG2TOUCHCLOCKDISABLE As Byte
    Get
    Set
public:
property unsigned char SYSCFG2TOUCHCLOCKDISABLE {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCFG2TOUCHCLOCKDISABLE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.TINTPENDINGEOC Property

IRD

Stmpe321TINTPENDINGEOC Property

TINT_PENDING: EOC

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TINTPENDINGEOC { get; }
Public ReadOnly Property TINTPENDINGEOC As Byte
    Get
public:
property unsigned char TINTPENDINGEOC {
    unsigned char get ();
}
member TINTPENDINGEOC : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.TVR0 Property

IRD

Stmpe321TVR0 Property

TVR 0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR0 { get; set; }
Public Property TVR0 As Byte
    Get
    Set
public:
property unsigned char TVR0 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.TVR1 Property

IRD

Stmpe321TVR1 Property

TVR 1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR1 { get; set; }
Public Property TVR1 As Byte
    Get
    Set
public:
property unsigned char TVR1 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.TVR2 Property

IRD

Stmpe321TVR2 Property

TVR 2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR2 { get; set; }
Public Property TVR2 As Byte
    Get
    Set
public:
property unsigned char TVR2 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321 Methods

The Stmpe321 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.Flush Method

IRD

Stmpe321Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Stmpe321 Class
telos.Ird.ST Namespace


Stmpe321.Enable1Disable0 Enumeration

IRD

Stmpe321Enable1Disable0 Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Enable1Disable0
Public Enumeration Enable1Disable0
public enum class Enable1Disable0
type Enable1Disable0
Members
Member name | Value | Description
Enabled | 1 | Enabled
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.ST Namespace


Stmpe321.FeatureSelAfs Enumeration

IRD

Stmpe321FeatureSelAfs Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FeatureSelAfs
Public Enumeration FeatureSelAfs
public enum class FeatureSelAfs
type FeatureSelAfs
Members
Member name | Value | Description
AFSMode1 | 1 | AFS Mode 1
AFSMode2 | 2 | AFS Mode 2
AFSMode3 | 3 | AFS Mode 3
See Also

Reference

telos.Ird.ST Namespace


Stmpe321.GpioDir Enumeration

IRD

Stmpe321GpioDir Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum GpioDir
Public Enumeration GpioDir
public enum class GpioDir
type GpioDir
Members
Member name | Value | Description
Input | 0 | Input
Output | 1 | Output
See Also

Reference

telos.Ird.ST Namespace


Stmpe321.GpioFunct Enumeration

IRD

Stmpe321GpioFunct Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum GpioFunct
Public Enumeration GpioFunct
public enum class GpioFunct
type GpioFunct
Members
Member name | Value | Description
GPIO | 1 | GPIO
Touchkey | 0 | Touchkey
See Also

Reference

telos.Ird.ST Namespace


Stmpe321.IntCtrlIntEn Enumeration

IRD

Stmpe321IntCtrlIntEn Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IntCtrlIntEn
Public Enumeration IntCtrlIntEn
public enum class IntCtrlIntEn
type IntCtrlIntEn
Members
Member name | Value | Description
AllInterruptsDisabled | 0 | All Interrupts: Disabled
AllInterruptsEnabled | 1 | All Interrupts: Enabled
See Also

Reference

telos.Ird.ST Namespace


Stmpe321.IntCtrlPolarity Enumeration

IRD

Stmpe321IntCtrlPolarity Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IntCtrlPolarity
Public Enumeration IntCtrlPolarity
public enum class IntCtrlPolarity
type IntCtrlPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.ST Namespace


Stmpe321.IntCtrlType Enumeration

IRD

Stmpe321IntCtrlType Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IntCtrlType
Public Enumeration IntCtrlType
public enum class IntCtrlType
type IntCtrlType
Members
Member name | Value | Description
LevelTrigger | 0 | Level Trigger
EdgeTrigger | 1 | Edge Trigger
See Also

Reference

telos.Ird.ST Namespace


Stmpe321.SysCfg2SensorClock Enumeration

IRD

Stmpe321SysCfg2SensorClock Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SysCfg2SensorClock
Public Enumeration SysCfg2SensorClock
public enum class SysCfg2SensorClock
type SysCfg2SensorClock
Members
Member name | Value | Description
Divider1 | 0 | Divider = 1
Divider2 | 1 | Divider = 2
Divider4 | 2 | Divider = 4
Divider8 | 3 | Divider = 8
Divider16 | 4 | Divider = 16
See Also

Reference

telos.Ird.ST Namespace


Stmpe610 Class

ST: STMPE 610
Inheritance Hierarchy
SystemObject
telos.Ird.STStmpe610

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Stmpe610
Public Class Stmpe610
public ref class Stmpe610
type Stmpe610 =  class end

The Stmpe610 type exposes the following members.

Constructors
 | Name | Description
Public method | Stmpe610 | Constructor
Top
Properties
 | Name | Description
Public property | ADCCAPT | ADC_CAPT
Public property | ADCCTRL1MOD12B | ADC_CTRL1: MOD_12B (unit: bit)
Public property | ADCCTRL1REFSEL | ADC_CTRL1: REF_SEL
Public property | ADCCTRL1SAMPLETIME | ADC_CTRL1: SAMPLE_TIME
Public property | ADCCTRL2ADCFREQ | ADC_CTRL2: ADC_FREQ (unit: MHz)
Public property | ADCDATACH0 | ADC_DATA_CH0
Public property | ADCDATACH1 | ADC_DATA_CH1
Public property | ADCDATACH2 | ADC_DATA_CH2
Public property | ADCDATACH3 | ADC_DATA_CH3
Public property | ADCDATACH4 | ADC_DATA_CH4
Public property | ADCDATACH5 | ADC_DATA_CH5
Public property | ADCDATACH6 | ADC_DATA_CH6
Public property | ADCDATACH7 | ADC_DATA_CH7
Public property | ADCINTEN | ADC_INT_EN
Public property | ADCINTSTA | ADC_INT_STA
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CHIPID | CHIP_ID
Public property | FIFOCTRLSTAFIFOEMPTY | FIFO_CTRL_STA: FIFO_EMPTY
Public property | FIFOCTRLSTAFIFOFULL | FIFO_CTRL_STA: FIFO_FULL
Public property | FIFOCTRLSTAFIFOOFLOW | FIFO_CTRL_STA: FIFO_OFLOW
Public property | FIFOCTRLSTAFIFORESET | FIFO_CTRL_STA: FIFO_RESET
Public property | FIFOCTRLSTAFIFOTHTRIG | FIFO_CTRL_STA: FIFO_TH_TRIG
Public property | FIFOSIZE | FIFO_SIZE
Public property | FIFOTH | FIFO_TH
Public property | GPIOALTFUNCT | GPIO_ALT_FUNCT
Public property | GPIOCLRPIN | GPIO_CLR_PIN
Public property | GPIODIR | GPIO_DIR
Public property | GPIOEDSTA | GPIO_ED_STA
Public property | GPIOFE | GPIO_FE
Public property | GPIOINTEN | GPIO_INT_EN
Public property | GPIOINTSTA | GPIO_INT_STA
Public property | GPIOMPSTA | GPIO_MP_STA
Public property | GPIORE | GPIO_RE
Public property | GPIOSETPIN | GPIO_SET_PIN
Public property | IDVER | ID_VER
Public property | INTCTRLGLOBALINT | INT_CTRL: GLOBAL_INT
Public property | INTCTRLINTPOLARITY | INT_CTRL: INT_POLARITY
Public property | INTCTRLINTTYPE | INT_CTRL: INT_TYPE
Public property | INTENADC | INT_EN: ADC
Public property | INTENFIFOEMPTY | INT_EN: FIFO_EMPTY
Public property | INTENFIFOFULL | INT_EN: FIFO_FULL
Public property | INTENFIFOOFLOW | INT_EN: FIFO_OFLOW
Public property | INTENFIFOTH | INT_EN: FIFO_TH
Public property | INTENGPIO | INT_EN: GPIO
Public property | INTENTOUCHDET | INT_EN: TOUCH_DET
Public property | INTSTAADC | INT_STA: ADC
Public property | INTSTAFIFOEMPTY | INT_STA: FIFO_EMPTY
Public property | INTSTAFIFOFULL | INT_STA: FIFO_FULL
Public property | INTSTAFIFOOFLOW | INT_STA: FIFO_OFLOW
Public property | INTSTAFIFOTH | INT_STA: FIFO_TH
Public property | INTSTAGPIO | INT_STA: GPIO
Public property | INTSTATOUCHDET | INT_STA: TOUCH_DET
Public property | SPICFGAUTOINCR | SPI_CFG: AUTO_INCR
Public property | SPICFGSPICLKMOD0 | SPI_CFG: SPI_CLK_MOD0
Public property | SPICFGSPICLKMOD1 | SPI_CFG: SPI_CLK_MOD1
Public property | SYSCTRL1HIBERNATE | SYS_CTRL1: HIBERNATE
Public property | SYSCTRL1SOFTRESET | SYS_CTRL1: SOFT_RESET
Public property | SYSCTRL2ADCOFF | SYS_CTRL2: ADC_OFF
Public property | SYSCTRL2GPIOOFF | SYS_CTRL2: GPIO_OFF
Public property | SYSCTRL2TSCOFF | SYS_CTRL2: TSC_OFF
Public property | TSCCFGAVECTRL | TSC_CFG: AVE_CTRL
Public property | TSCCFGSETTLING | TSC_CFG: SETTLING
Public property | TSCCFGTOUCHDETDELAY | TSC_CFG: TOUCH_DET_DELAY
Public property | TSCCTRLEN | TSC_CTRL: EN
Public property | TSCCTRLOPMOD | TSC_CTRL: OP_MOD
Public property | TSCCTRLTRACK | TSC_CTRL: TRACK
Public property | TSCCTRLTSCSTA | TSC_CTRL: TSC_STA
Public property | TSCDATA | TSC_DATA
Public property | TSCDATAX | TSC_DATA_X
Public property | TSCDATAY | TSC_DATA_Y
Public property | TSCDATAZ | TSC_DATA_Z
Public property | TSCFRACTIONZ | TSC_FRACTION_Z
Public property | TSCIDRIVE | TSC_I_DRIVE
Public property | TSCSHIELDX | TSC_SHIELD: X+
Public property | TSCSHIELDX__1 | TSC_SHIELD: X-
Public property | TSCSHIELDY | TSC_SHIELD: Y+
Public property | TSCSHIELDY__1 | TSC_SHIELD: Y-
Public property | WDWBLX | WDW_BL_X
Public property | WDWBLY | WDW_BL_Y
Public property | WDWTRX | WDW_TR_X
Public property | WDWTRY | WDW_TR_Y
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
S-Touch: Advanced Touchscreen Controller With 6-Bit Port Expander
See Also

Reference

telos.Ird.ST Namespace


Stmpe610 Constructor

Constructor

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe610(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Stmpe610(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Stmpe610

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610 Properties

The Stmpe610 type exposes the following members.

Properties
 | Name | Description
Public property | ADCCAPT | ADC_CAPT
Public property | ADCCTRL1MOD12B | ADC_CTRL1: MOD_12B (unit: bit)
Public property | ADCCTRL1REFSEL | ADC_CTRL1: REF_SEL
Public property | ADCCTRL1SAMPLETIME | ADC_CTRL1: SAMPLE_TIME
Public property | ADCCTRL2ADCFREQ | ADC_CTRL2: ADC_FREQ (unit: MHz)
Public property | ADCDATACH0 | ADC_DATA_CH0
Public property | ADCDATACH1 | ADC_DATA_CH1
Public property | ADCDATACH2 | ADC_DATA_CH2
Public property | ADCDATACH3 | ADC_DATA_CH3
Public property | ADCDATACH4 | ADC_DATA_CH4
Public property | ADCDATACH5 | ADC_DATA_CH5
Public property | ADCDATACH6 | ADC_DATA_CH6
Public property | ADCDATACH7 | ADC_DATA_CH7
Public property | ADCINTEN | ADC_INT_EN
Public property | ADCINTSTA | ADC_INT_STA
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CHIPID | CHIP_ID
Public property | FIFOCTRLSTAFIFOEMPTY | FIFO_CTRL_STA: FIFO_EMPTY
Public property | FIFOCTRLSTAFIFOFULL | FIFO_CTRL_STA: FIFO_FULL
Public property | FIFOCTRLSTAFIFOOFLOW | FIFO_CTRL_STA: FIFO_OFLOW
Public property | FIFOCTRLSTAFIFORESET | FIFO_CTRL_STA: FIFO_RESET
Public property | FIFOCTRLSTAFIFOTHTRIG | FIFO_CTRL_STA: FIFO_TH_TRIG
Public property | FIFOSIZE | FIFO_SIZE
Public property | FIFOTH | FIFO_TH
Public property | GPIOALTFUNCT | GPIO_ALT_FUNCT
Public property | GPIOCLRPIN | GPIO_CLR_PIN
Public property | GPIODIR | GPIO_DIR
Public property | GPIOEDSTA | GPIO_ED_STA
Public property | GPIOFE | GPIO_FE
Public property | GPIOINTEN | GPIO_INT_EN
Public property | GPIOINTSTA | GPIO_INT_STA
Public property | GPIOMPSTA | GPIO_MP_STA
Public property | GPIORE | GPIO_RE
Public property | GPIOSETPIN | GPIO_SET_PIN
Public property | IDVER | ID_VER
Public property | INTCTRLGLOBALINT | INT_CTRL: GLOBAL_INT
Public property | INTCTRLINTPOLARITY | INT_CTRL: INT_POLARITY
Public property | INTCTRLINTTYPE | INT_CTRL: INT_TYPE
Public property | INTENADC | INT_EN: ADC
Public property | INTENFIFOEMPTY | INT_EN: FIFO_EMPTY
Public property | INTENFIFOFULL | INT_EN: FIFO_FULL
Public property | INTENFIFOOFLOW | INT_EN: FIFO_OFLOW
Public property | INTENFIFOTH | INT_EN: FIFO_TH
Public property | INTENGPIO | INT_EN: GPIO
Public property | INTENTOUCHDET | INT_EN: TOUCH_DET
Public property | INTSTAADC | INT_STA: ADC
Public property | INTSTAFIFOEMPTY | INT_STA: FIFO_EMPTY
Public property | INTSTAFIFOFULL | INT_STA: FIFO_FULL
Public property | INTSTAFIFOOFLOW | INT_STA: FIFO_OFLOW
Public property | INTSTAFIFOTH | INT_STA: FIFO_TH
Public property | INTSTAGPIO | INT_STA: GPIO
Public property | INTSTATOUCHDET | INT_STA: TOUCH_DET
Public property | SPICFGAUTOINCR | SPI_CFG: AUTO_INCR
Public property | SPICFGSPICLKMOD0 | SPI_CFG: SPI_CLK_MOD0
Public property | SPICFGSPICLKMOD1 | SPI_CFG: SPI_CLK_MOD1
Public property | SYSCTRL1HIBERNATE | SYS_CTRL1: HIBERNATE
Public property | SYSCTRL1SOFTRESET | SYS_CTRL1: SOFT_RESET
Public property | SYSCTRL2ADCOFF | SYS_CTRL2: ADC_OFF
Public property | SYSCTRL2GPIOOFF | SYS_CTRL2: GPIO_OFF
Public property | SYSCTRL2TSCOFF | SYS_CTRL2: TSC_OFF
Public property | TSCCFGAVECTRL | TSC_CFG: AVE_CTRL
Public property | TSCCFGSETTLING | TSC_CFG: SETTLING
Public property | TSCCFGTOUCHDETDELAY | TSC_CFG: TOUCH_DET_DELAY
Public property | TSCCTRLEN | TSC_CTRL: EN
Public property | TSCCTRLOPMOD | TSC_CTRL: OP_MOD
Public property | TSCCTRLTRACK | TSC_CTRL: TRACK
Public property | TSCCTRLTSCSTA | TSC_CTRL: TSC_STA
Public property | TSCDATA | TSC_DATA
Public property | TSCDATAX | TSC_DATA_X
Public property | TSCDATAY | TSC_DATA_Y
Public property | TSCDATAZ | TSC_DATA_Z
Public property | TSCFRACTIONZ | TSC_FRACTION_Z
Public property | TSCIDRIVE | TSC_I_DRIVE
Public property | TSCSHIELDX | TSC_SHIELD: X+
Public property | TSCSHIELDX__1 | TSC_SHIELD: X-
Public property | TSCSHIELDY | TSC_SHIELD: Y+
Public property | TSCSHIELDY__1 | TSC_SHIELD: Y-
Public property | WDWBLX | WDW_BL_X
Public property | WDWBLY | WDW_BL_Y
Public property | WDWTRX | WDW_TR_X
Public property | WDWTRY | WDW_TR_Y
Top
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.ADCCAPT Property

IRD

Stmpe610ADCCAPT Property

ADC_CAPT

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCCAPT { get; set; }
Public Property ADCCAPT As Byte
    Get
    Set
public:
property unsigned char ADCCAPT {
    unsigned char get ();
    void set (unsigned char value);
}
member ADCCAPT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.ADCCTRL1MOD12B Property

IRD

Stmpe610ADCCTRL1MOD12B Property

ADC_CTRL1: MOD_12B (unit: bit)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe610AdcCtrl1Mod12b ADCCTRL1MOD12B { get; set; }
Public Property ADCCTRL1MOD12B As Stmpe610AdcCtrl1Mod12b
    Get
    Set
public:
property Stmpe610AdcCtrl1Mod12b ADCCTRL1MOD12B {
    Stmpe610AdcCtrl1Mod12b get ();
    void set (Stmpe610AdcCtrl1Mod12b value);
}
member ADCCTRL1MOD12B : Stmpe610AdcCtrl1Mod12b with get, set

Property Value

Type: Stmpe610AdcCtrl1Mod12b
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.ADCCTRL1REFSEL Property

IRD

Stmpe610ADCCTRL1REFSEL Property

ADC_CTRL1: REF_SEL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe610AdcCtrl1RefSel ADCCTRL1REFSEL { get; set; }
Public Property ADCCTRL1REFSEL As Stmpe610AdcCtrl1RefSel
    Get
    Set
public:
property Stmpe610AdcCtrl1RefSel ADCCTRL1REFSEL {
    Stmpe610AdcCtrl1RefSel get ();
    void set (Stmpe610AdcCtrl1RefSel value);
}
member ADCCTRL1REFSEL : Stmpe610AdcCtrl1RefSel with get, set

Property Value

Type: Stmpe610AdcCtrl1RefSel
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.ADCCTRL1SAMPLETIME Property

IRD

Stmpe610ADCCTRL1SAMPLETIME Property

ADC_CTRL1: SAMPLE_TIME

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe610AdcCtrl1SampleTime ADCCTRL1SAMPLETIME { get; set; }
Public Property ADCCTRL1SAMPLETIME As Stmpe610AdcCtrl1SampleTime
    Get
    Set
public:
property Stmpe610AdcCtrl1SampleTime ADCCTRL1SAMPLETIME {
    Stmpe610AdcCtrl1SampleTime get ();
    void set (Stmpe610AdcCtrl1SampleTime value);
}
member ADCCTRL1SAMPLETIME : Stmpe610AdcCtrl1SampleTime with get, set

Property Value

Type: Stmpe610AdcCtrl1SampleTime
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.ADCCTRL2ADCFREQ Property

IRD

Stmpe610ADCCTRL2ADCFREQ Property

ADC_CTRL2: ADC_FREQ (unit: MHz)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe610AdcCtrl2AdcFreq ADCCTRL2ADCFREQ { get; set; }
Public Property ADCCTRL2ADCFREQ As Stmpe610AdcCtrl2AdcFreq
    Get
    Set
public:
property Stmpe610AdcCtrl2AdcFreq ADCCTRL2ADCFREQ {
    Stmpe610AdcCtrl2AdcFreq get ();
    void set (Stmpe610AdcCtrl2AdcFreq value);
}
member ADCCTRL2ADCFREQ : Stmpe610AdcCtrl2AdcFreq with get, set

Property Value

Type: Stmpe610AdcCtrl2AdcFreq
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.ADCDATACH0 Property

IRD

Stmpe610ADCDATACH0 Property

ADC_DATA_CH0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCDATACH0 { get; }
Public ReadOnly Property ADCDATACH0 As UShort
    Get
public:
property unsigned short ADCDATACH0 {
    unsigned short get ();
}
member ADCDATACH0 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.ADCDATACH1 Property

IRD

Stmpe610ADCDATACH1 Property

ADC_DATA_CH1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCDATACH1 { get; }
Public ReadOnly Property ADCDATACH1 As UShort
    Get
public:
property unsigned short ADCDATACH1 {
    unsigned short get ();
}
member ADCDATACH1 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.ADCDATACH2 Property

IRD

Stmpe610ADCDATACH2 Property

ADC_DATA_CH2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCDATACH2 { get; }
Public ReadOnly Property ADCDATACH2 As UShort
    Get
public:
property unsigned short ADCDATACH2 {
    unsigned short get ();
}
member ADCDATACH2 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.ADCDATACH3 Property

IRD

Stmpe610ADCDATACH3 Property

ADC_DATA_CH3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCDATACH3 { get; }
Public ReadOnly Property ADCDATACH3 As UShort
    Get
public:
property unsigned short ADCDATACH3 {
    unsigned short get ();
}
member ADCDATACH3 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.ADCDATACH4 Property

IRD

Stmpe610ADCDATACH4 Property

ADC_DATA_CH4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCDATACH4 { get; }
Public ReadOnly Property ADCDATACH4 As UShort
    Get
public:
property unsigned short ADCDATACH4 {
    unsigned short get ();
}
member ADCDATACH4 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.ADCDATACH5 Property

IRD

Stmpe610ADCDATACH5 Property

ADC_DATA_CH5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCDATACH5 { get; }
Public ReadOnly Property ADCDATACH5 As UShort
    Get
public:
property unsigned short ADCDATACH5 {
    unsigned short get ();
}
member ADCDATACH5 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.ADCDATACH6 Property

IRD

Stmpe610ADCDATACH6 Property

ADC_DATA_CH6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCDATACH6 { get; }
Public ReadOnly Property ADCDATACH6 As UShort
    Get
public:
property unsigned short ADCDATACH6 {
    unsigned short get ();
}
member ADCDATACH6 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.ADCDATACH7 Property

IRD

Stmpe610ADCDATACH7 Property

ADC_DATA_CH7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCDATACH7 { get; }
Public ReadOnly Property ADCDATACH7 As UShort
    Get
public:
property unsigned short ADCDATACH7 {
    unsigned short get ();
}
member ADCDATACH7 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.ADCINTEN Property

IRD

Stmpe610ADCINTEN Property

ADC_INT_EN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCINTEN { get; set; }
Public Property ADCINTEN As Byte
    Get
    Set
public:
property unsigned char ADCINTEN {
    unsigned char get ();
    void set (unsigned char value);
}
member ADCINTEN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.ADCINTSTA Property

IRD

Stmpe610ADCINTSTA Property

ADC_INT_STA

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCINTSTA { get; }
Public ReadOnly Property ADCINTSTA As Byte
    Get
public:
property unsigned char ADCINTSTA {
    unsigned char get ();
}
member ADCINTSTA : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.AutoFlush Property

IRD

Stmpe610AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.CHIPID Property

IRD

Stmpe610CHIPID Property

CHIP_ID

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort CHIPID { get; }
Public ReadOnly Property CHIPID As UShort
    Get
public:
property unsigned short CHIPID {
    unsigned short get ();
}
member CHIPID : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.FIFOCTRLSTAFIFOEMPTY Property

IRD

Stmpe610FIFOCTRLSTAFIFOEMPTY Property

FIFO_CTRL_STA: FIFO_EMPTY

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOCTRLSTAFIFOEMPTY { get; set; }
Public Property FIFOCTRLSTAFIFOEMPTY As Byte
    Get
    Set
public:
property unsigned char FIFOCTRLSTAFIFOEMPTY {
    unsigned char get ();
    void set (unsigned char value);
}
member FIFOCTRLSTAFIFOEMPTY : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.FIFOCTRLSTAFIFOFULL Property

IRD

Stmpe610FIFOCTRLSTAFIFOFULL Property

FIFO_CTRL_STA: FIFO_FULL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOCTRLSTAFIFOFULL { get; set; }
Public Property FIFOCTRLSTAFIFOFULL As Byte
    Get
    Set
public:
property unsigned char FIFOCTRLSTAFIFOFULL {
    unsigned char get ();
    void set (unsigned char value);
}
member FIFOCTRLSTAFIFOFULL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.FIFOCTRLSTAFIFOOFLOW Property

IRD

Stmpe610FIFOCTRLSTAFIFOOFLOW Property

FIFO_CTRL_STA: FIFO_OFLOW

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOCTRLSTAFIFOOFLOW { get; set; }
Public Property FIFOCTRLSTAFIFOOFLOW As Byte
    Get
    Set
public:
property unsigned char FIFOCTRLSTAFIFOOFLOW {
    unsigned char get ();
    void set (unsigned char value);
}
member FIFOCTRLSTAFIFOOFLOW : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.FIFOCTRLSTAFIFORESET Property

IRD

Stmpe610FIFOCTRLSTAFIFORESET Property

FIFO_CTRL_STA: FIFO_RESET

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOCTRLSTAFIFORESET { get; set; }
Public Property FIFOCTRLSTAFIFORESET As Byte
    Get
    Set
public:
property unsigned char FIFOCTRLSTAFIFORESET {
    unsigned char get ();
    void set (unsigned char value);
}
member FIFOCTRLSTAFIFORESET : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.FIFOCTRLSTAFIFOTHTRIG Property

IRD

Stmpe610FIFOCTRLSTAFIFOTHTRIG Property

FIFO_CTRL_STA: FIFO_TH_TRIG

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOCTRLSTAFIFOTHTRIG { get; set; }
Public Property FIFOCTRLSTAFIFOTHTRIG As Byte
    Get
    Set
public:
property unsigned char FIFOCTRLSTAFIFOTHTRIG {
    unsigned char get ();
    void set (unsigned char value);
}
member FIFOCTRLSTAFIFOTHTRIG : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.FIFOSIZE Property

IRD

Stmpe610FIFOSIZE Property

FIFO_SIZE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOSIZE { get; }
Public ReadOnly Property FIFOSIZE As Byte
    Get
public:
property unsigned char FIFOSIZE {
    unsigned char get ();
}
member FIFOSIZE : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.FIFOTH Property

IRD

Stmpe610FIFOTH Property

FIFO_TH

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOTH { get; set; }
Public Property FIFOTH As Byte
    Get
    Set
public:
property unsigned char FIFOTH {
    unsigned char get ();
    void set (unsigned char value);
}
member FIFOTH : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.GPIOALTFUNCT Property

IRD

Stmpe610GPIOALTFUNCT Property

GPIO_ALT_FUNCT

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOALTFUNCT { get; set; }
Public Property GPIOALTFUNCT As Byte
    Get
    Set
public:
property unsigned char GPIOALTFUNCT {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOALTFUNCT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.GPIOCLRPIN Property

IRD

Stmpe610GPIOCLRPIN Property

GPIO_CLR_PIN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOCLRPIN { get; set; }
Public Property GPIOCLRPIN As Byte
    Get
    Set
public:
property unsigned char GPIOCLRPIN {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOCLRPIN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.GPIODIR Property

IRD

Stmpe610GPIODIR Property

GPIO_DIR

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODIR { get; set; }
Public Property GPIODIR As Byte
    Get
    Set
public:
property unsigned char GPIODIR {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODIR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.GPIOEDSTA Property

IRD

Stmpe610GPIOEDSTA Property

GPIO_ED_STA

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOEDSTA { get; set; }
Public Property GPIOEDSTA As Byte
    Get
    Set
public:
property unsigned char GPIOEDSTA {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOEDSTA : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.GPIOFE Property

IRD

Stmpe610GPIOFE Property

GPIO_FE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOFE { get; set; }
Public Property GPIOFE As Byte
    Get
    Set
public:
property unsigned char GPIOFE {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOFE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.GPIOINTEN Property

IRD

Stmpe610GPIOINTEN Property

GPIO_INT_EN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINTEN { get; set; }
Public Property GPIOINTEN As Byte
    Get
    Set
public:
property unsigned char GPIOINTEN {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOINTEN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.GPIOINTSTA Property

IRD

Stmpe610GPIOINTSTA Property

GPIO_INT_STA

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINTSTA { get; }
Public ReadOnly Property GPIOINTSTA As Byte
    Get
public:
property unsigned char GPIOINTSTA {
    unsigned char get ();
}
member GPIOINTSTA : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.GPIOMPSTA Property

IRD

Stmpe610GPIOMPSTA Property

GPIO_MP_STA

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOMPSTA { get; set; }
Public Property GPIOMPSTA As Byte
    Get
    Set
public:
property unsigned char GPIOMPSTA {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOMPSTA : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.GPIORE Property

IRD

Stmpe610GPIORE Property

GPIO_RE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIORE { get; set; }
Public Property GPIORE As Byte
    Get
    Set
public:
property unsigned char GPIORE {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIORE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.GPIOSETPIN Property

IRD

Stmpe610GPIOSETPIN Property

GPIO_SET_PIN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSETPIN { get; set; }
Public Property GPIOSETPIN As Byte
    Get
    Set
public:
property unsigned char GPIOSETPIN {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSETPIN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.IDVER Property

IRD

Stmpe610IDVER Property

ID_VER

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IDVER { get; }
Public ReadOnly Property IDVER As Byte
    Get
public:
property unsigned char IDVER {
    unsigned char get ();
}
member IDVER : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.INTCTRLGLOBALINT Property

IRD

Stmpe610INTCTRLGLOBALINT Property

INT_CTRL: GLOBAL_INT

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe610IntCtrlGlobalInt INTCTRLGLOBALINT { get; set; }
Public Property INTCTRLGLOBALINT As Stmpe610IntCtrlGlobalInt
    Get
    Set
public:
property Stmpe610IntCtrlGlobalInt INTCTRLGLOBALINT {
    Stmpe610IntCtrlGlobalInt get ();
    void set (Stmpe610IntCtrlGlobalInt value);
}
member INTCTRLGLOBALINT : Stmpe610IntCtrlGlobalInt with get, set

Property Value

Type: Stmpe610IntCtrlGlobalInt
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.INTCTRLINTPOLARITY Property

IRD

Stmpe610INTCTRLINTPOLARITY Property

INT_CTRL: INT_POLARITY

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe610IntCtrlPolarity INTCTRLINTPOLARITY { get; set; }
Public Property INTCTRLINTPOLARITY As Stmpe610IntCtrlPolarity
    Get
    Set
public:
property Stmpe610IntCtrlPolarity INTCTRLINTPOLARITY {
    Stmpe610IntCtrlPolarity get ();
    void set (Stmpe610IntCtrlPolarity value);
}
member INTCTRLINTPOLARITY : Stmpe610IntCtrlPolarity with get, set

Property Value

Type: Stmpe610IntCtrlPolarity
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.INTCTRLINTTYPE Property

IRD

Stmpe610INTCTRLINTTYPE Property

INT_CTRL: INT_TYPE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe610IntCtrlType INTCTRLINTTYPE { get; set; }
Public Property INTCTRLINTTYPE As Stmpe610IntCtrlType
    Get
    Set
public:
property Stmpe610IntCtrlType INTCTRLINTTYPE {
    Stmpe610IntCtrlType get ();
    void set (Stmpe610IntCtrlType value);
}
member INTCTRLINTTYPE : Stmpe610IntCtrlType with get, set

Property Value

Type: Stmpe610IntCtrlType
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.INTENADC Property

IRD

Stmpe610INTENADC Property

INT_EN: ADC

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENADC { get; set; }
Public Property INTENADC As Byte
    Get
    Set
public:
property unsigned char INTENADC {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENADC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.INTENFIFOEMPTY Property

IRD

Stmpe610INTENFIFOEMPTY Property

INT_EN: FIFO_EMPTY

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENFIFOEMPTY { get; set; }
Public Property INTENFIFOEMPTY As Byte
    Get
    Set
public:
property unsigned char INTENFIFOEMPTY {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENFIFOEMPTY : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.INTENFIFOFULL Property

IRD

Stmpe610INTENFIFOFULL Property

INT_EN: FIFO_FULL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENFIFOFULL { get; set; }
Public Property INTENFIFOFULL As Byte
    Get
    Set
public:
property unsigned char INTENFIFOFULL {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENFIFOFULL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.INTENFIFOOFLOW Property

IRD

Stmpe610INTENFIFOOFLOW Property

INT_EN: FIFO_OFLOW

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENFIFOOFLOW { get; set; }
Public Property INTENFIFOOFLOW As Byte
    Get
    Set
public:
property unsigned char INTENFIFOOFLOW {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENFIFOOFLOW : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.INTENFIFOTH Property

IRD

Stmpe610INTENFIFOTH Property

INT_EN: FIFO_TH

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENFIFOTH { get; set; }
Public Property INTENFIFOTH As Byte
    Get
    Set
public:
property unsigned char INTENFIFOTH {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENFIFOTH : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.INTENGPIO Property

IRD

Stmpe610INTENGPIO Property

INT_EN: GPIO

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENGPIO { get; set; }
Public Property INTENGPIO As Byte
    Get
    Set
public:
property unsigned char INTENGPIO {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENGPIO : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.INTENTOUCHDET Property

IRD

Stmpe610INTENTOUCHDET Property

INT_EN: TOUCH_DET

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENTOUCHDET { get; set; }
Public Property INTENTOUCHDET As Byte
    Get
    Set
public:
property unsigned char INTENTOUCHDET {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENTOUCHDET : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.INTSTAADC Property

IRD

Stmpe610INTSTAADC Property

INT_STA: ADC

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAADC { get; }
Public ReadOnly Property INTSTAADC As Byte
    Get
public:
property unsigned char INTSTAADC {
    unsigned char get ();
}
member INTSTAADC : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.INTSTAFIFOEMPTY Property

IRD

Stmpe610INTSTAFIFOEMPTY Property

INT_STA: FIFO_EMPTY

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAFIFOEMPTY { get; }
Public ReadOnly Property INTSTAFIFOEMPTY As Byte
    Get
public:
property unsigned char INTSTAFIFOEMPTY {
    unsigned char get ();
}
member INTSTAFIFOEMPTY : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.INTSTAFIFOFULL Property

IRD

Stmpe610INTSTAFIFOFULL Property

INT_STA: FIFO_FULL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAFIFOFULL { get; }
Public ReadOnly Property INTSTAFIFOFULL As Byte
    Get
public:
property unsigned char INTSTAFIFOFULL {
    unsigned char get ();
}
member INTSTAFIFOFULL : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.INTSTAFIFOOFLOW Property

IRD

Stmpe610INTSTAFIFOOFLOW Property

INT_STA: FIFO_OFLOW

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAFIFOOFLOW { get; }
Public ReadOnly Property INTSTAFIFOOFLOW As Byte
    Get
public:
property unsigned char INTSTAFIFOOFLOW {
    unsigned char get ();
}
member INTSTAFIFOOFLOW : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.INTSTAFIFOTH Property

IRD

Stmpe610INTSTAFIFOTH Property

INT_STA: FIFO_TH

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAFIFOTH { get; }
Public ReadOnly Property INTSTAFIFOTH As Byte
    Get
public:
property unsigned char INTSTAFIFOTH {
    unsigned char get ();
}
member INTSTAFIFOTH : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.INTSTAGPIO Property

IRD

Stmpe610INTSTAGPIO Property

INT_STA: GPIO

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAGPIO { get; }
Public ReadOnly Property INTSTAGPIO As Byte
    Get
public:
property unsigned char INTSTAGPIO {
    unsigned char get ();
}
member INTSTAGPIO : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.INTSTATOUCHDET Property

IRD

Stmpe610INTSTATOUCHDET Property

INT_STA: TOUCH_DET

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTATOUCHDET { get; }
Public ReadOnly Property INTSTATOUCHDET As Byte
    Get
public:
property unsigned char INTSTATOUCHDET {
    unsigned char get ();
}
member INTSTATOUCHDET : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.SPICFGAUTOINCR Property

IRD

Stmpe610SPICFGAUTOINCR Property

SPI_CFG: AUTO_INCR

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SPICFGAUTOINCR { get; set; }
Public Property SPICFGAUTOINCR As Byte
    Get
    Set
public:
property unsigned char SPICFGAUTOINCR {
    unsigned char get ();
    void set (unsigned char value);
}
member SPICFGAUTOINCR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.SPICFGSPICLKMOD0 Property

IRD

Stmpe610SPICFGSPICLKMOD0 Property

SPI_CFG: SPI_CLK_MOD0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SPICFGSPICLKMOD0 { get; set; }
Public Property SPICFGSPICLKMOD0 As Byte
    Get
    Set
public:
property unsigned char SPICFGSPICLKMOD0 {
    unsigned char get ();
    void set (unsigned char value);
}
member SPICFGSPICLKMOD0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.SPICFGSPICLKMOD1 Property

IRD

Stmpe610SPICFGSPICLKMOD1 Property

SPI_CFG: SPI_CLK_MOD1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SPICFGSPICLKMOD1 { get; set; }
Public Property SPICFGSPICLKMOD1 As Byte
    Get
    Set
public:
property unsigned char SPICFGSPICLKMOD1 {
    unsigned char get ();
    void set (unsigned char value);
}
member SPICFGSPICLKMOD1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.SYSCTRL1HIBERNATE Property

IRD

Stmpe610SYSCTRL1HIBERNATE Property

SYS_CTRL1: HIBERNATE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCTRL1HIBERNATE { get; set; }
Public Property SYSCTRL1HIBERNATE As Byte
    Get
    Set
public:
property unsigned char SYSCTRL1HIBERNATE {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCTRL1HIBERNATE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.SYSCTRL1SOFTRESET Property

IRD

Stmpe610SYSCTRL1SOFTRESET Property

SYS_CTRL1: SOFT_RESET

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCTRL1SOFTRESET { get; set; }
Public Property SYSCTRL1SOFTRESET As Byte
    Get
    Set
public:
property unsigned char SYSCTRL1SOFTRESET {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCTRL1SOFTRESET : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.SYSCTRL2ADCOFF Property

IRD

Stmpe610SYSCTRL2ADCOFF Property

SYS_CTRL2: ADC_OFF

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCTRL2ADCOFF { get; set; }
Public Property SYSCTRL2ADCOFF As Byte
    Get
    Set
public:
property unsigned char SYSCTRL2ADCOFF {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCTRL2ADCOFF : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.SYSCTRL2GPIOOFF Property

IRD

Stmpe610SYSCTRL2GPIOOFF Property

SYS_CTRL2: GPIO_OFF

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCTRL2GPIOOFF { get; set; }
Public Property SYSCTRL2GPIOOFF As Byte
    Get
    Set
public:
property unsigned char SYSCTRL2GPIOOFF {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCTRL2GPIOOFF : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.SYSCTRL2TSCOFF Property

IRD

Stmpe610SYSCTRL2TSCOFF Property

SYS_CTRL2: TSC_OFF

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCTRL2TSCOFF { get; set; }
Public Property SYSCTRL2TSCOFF As Byte
    Get
    Set
public:
property unsigned char SYSCTRL2TSCOFF {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCTRL2TSCOFF : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.TSCCFGAVECTRL Property

IRD

Stmpe610TSCCFGAVECTRL Property

TSC_CFG: AVE_CTRL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe610TscCfgAveCtrl TSCCFGAVECTRL { get; set; }
Public Property TSCCFGAVECTRL As Stmpe610TscCfgAveCtrl
    Get
    Set
public:
property Stmpe610TscCfgAveCtrl TSCCFGAVECTRL {
    Stmpe610TscCfgAveCtrl get ();
    void set (Stmpe610TscCfgAveCtrl value);
}
member TSCCFGAVECTRL : Stmpe610TscCfgAveCtrl with get, set

Property Value

Type: Stmpe610TscCfgAveCtrl
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.TSCCFGSETTLING Property

IRD

Stmpe610TSCCFGSETTLING Property

TSC_CFG: SETTLING

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe610TscCfgSettling TSCCFGSETTLING { get; set; }
Public Property TSCCFGSETTLING As Stmpe610TscCfgSettling
    Get
    Set
public:
property Stmpe610TscCfgSettling TSCCFGSETTLING {
    Stmpe610TscCfgSettling get ();
    void set (Stmpe610TscCfgSettling value);
}
member TSCCFGSETTLING : Stmpe610TscCfgSettling with get, set

Property Value

Type: Stmpe610TscCfgSettling
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.TSCCFGTOUCHDETDELAY Property

IRD

Stmpe610TSCCFGTOUCHDETDELAY Property

TSC_CFG: TOUCH_DET_DELAY

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe610TscCfgTouchDetDelay TSCCFGTOUCHDETDELAY { get; set; }
Public Property TSCCFGTOUCHDETDELAY As Stmpe610TscCfgTouchDetDelay
    Get
    Set
public:
property Stmpe610TscCfgTouchDetDelay TSCCFGTOUCHDETDELAY {
    Stmpe610TscCfgTouchDetDelay get ();
    void set (Stmpe610TscCfgTouchDetDelay value);
}
member TSCCFGTOUCHDETDELAY : Stmpe610TscCfgTouchDetDelay with get, set

Property Value

Type: Stmpe610TscCfgTouchDetDelay
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.TSCCTRLEN Property

IRD

Stmpe610TSCCTRLEN Property

TSC_CTRL: EN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TSCCTRLEN { get; set; }
Public Property TSCCTRLEN As Byte
    Get
    Set
public:
property unsigned char TSCCTRLEN {
    unsigned char get ();
    void set (unsigned char value);
}
member TSCCTRLEN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.TSCCTRLOPMOD Property

IRD

Stmpe610TSCCTRLOPMOD Property

TSC_CTRL: OP_MOD

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe610TscCtrlOpMod TSCCTRLOPMOD { get; set; }
Public Property TSCCTRLOPMOD As Stmpe610TscCtrlOpMod
    Get
    Set
public:
property Stmpe610TscCtrlOpMod TSCCTRLOPMOD {
    Stmpe610TscCtrlOpMod get ();
    void set (Stmpe610TscCtrlOpMod value);
}
member TSCCTRLOPMOD : Stmpe610TscCtrlOpMod with get, set

Property Value

Type: Stmpe610TscCtrlOpMod
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.TSCCTRLTRACK Property

IRD

Stmpe610TSCCTRLTRACK Property

TSC_CTRL: TRACK

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe610TscCtrlTrack TSCCTRLTRACK { get; set; }
Public Property TSCCTRLTRACK As Stmpe610TscCtrlTrack
    Get
    Set
public:
property Stmpe610TscCtrlTrack TSCCTRLTRACK {
    Stmpe610TscCtrlTrack get ();
    void set (Stmpe610TscCtrlTrack value);
}
member TSCCTRLTRACK : Stmpe610TscCtrlTrack with get, set

Property Value

Type: Stmpe610TscCtrlTrack
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.TSCCTRLTSCSTA Property

IRD

Stmpe610TSCCTRLTSCSTA Property

TSC_CTRL: TSC_STA

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe610TscCtrlSta TSCCTRLTSCSTA { get; set; }
Public Property TSCCTRLTSCSTA As Stmpe610TscCtrlSta
    Get
    Set
public:
property Stmpe610TscCtrlSta TSCCTRLTSCSTA {
    Stmpe610TscCtrlSta get ();
    void set (Stmpe610TscCtrlSta value);
}
member TSCCTRLTSCSTA : Stmpe610TscCtrlSta with get, set

Property Value

Type: Stmpe610TscCtrlSta
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.TSCDATA Property

IRD

Stmpe610TSCDATA Property

TSC_DATA

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint TSCDATA { get; }
Public ReadOnly Property TSCDATA As UInteger
    Get
public:
property unsigned int TSCDATA {
    unsigned int get ();
}
member TSCDATA : uint32 with get

Property Value

Type: UInt32
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.TSCDATAX Property

IRD

Stmpe610TSCDATAX Property

TSC_DATA_X

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TSCDATAX { get; }
Public ReadOnly Property TSCDATAX As UShort
    Get
public:
property unsigned short TSCDATAX {
    unsigned short get ();
}
member TSCDATAX : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.TSCDATAY Property

IRD

Stmpe610TSCDATAY Property

TSC_DATA_Y

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TSCDATAY { get; }
Public ReadOnly Property TSCDATAY As UShort
    Get
public:
property unsigned short TSCDATAY {
    unsigned short get ();
}
member TSCDATAY : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.TSCDATAZ Property

IRD

Stmpe610TSCDATAZ Property

TSC_DATA_Z

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TSCDATAZ { get; }
Public ReadOnly Property TSCDATAZ As Byte
    Get
public:
property unsigned char TSCDATAZ {
    unsigned char get ();
}
member TSCDATAZ : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.TSCFRACTIONZ Property

IRD

Stmpe610TSCFRACTIONZ Property

TSC_FRACTION_Z

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TSCFRACTIONZ { get; }
Public ReadOnly Property TSCFRACTIONZ As Byte
    Get
public:
property unsigned char TSCFRACTIONZ {
    unsigned char get ();
}
member TSCFRACTIONZ : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.TSCIDRIVE Property

IRD

Stmpe610TSCIDRIVE Property

TSC_I_DRIVE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe610TscIDrive TSCIDRIVE { get; set; }
Public Property TSCIDRIVE As Stmpe610TscIDrive
    Get
    Set
public:
property Stmpe610TscIDrive TSCIDRIVE {
    Stmpe610TscIDrive get ();
    void set (Stmpe610TscIDrive value);
}
member TSCIDRIVE : Stmpe610TscIDrive with get, set

Property Value

Type: Stmpe610TscIDrive
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.TSCSHIELDX Property

IRD

Stmpe610TSCSHIELDX Property

TSC_SHIELD: X+

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TSCSHIELDX { get; set; }
Public Property TSCSHIELDX As Byte
    Get
    Set
public:
property unsigned char TSCSHIELDX {
    unsigned char get ();
    void set (unsigned char value);
}
member TSCSHIELDX : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.TSCSHIELDX__1 Property

IRD

Stmpe610TSCSHIELDX__1 Property

TSC_SHIELD: X-

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TSCSHIELDX__1 { get; set; }
Public Property TSCSHIELDX__1 As Byte
    Get
    Set
public:
property unsigned char TSCSHIELDX__1 {
    unsigned char get ();
    void set (unsigned char value);
}
member TSCSHIELDX__1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.TSCSHIELDY Property

IRD

Stmpe610TSCSHIELDY Property

TSC_SHIELD: Y+

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TSCSHIELDY { get; set; }
Public Property TSCSHIELDY As Byte
    Get
    Set
public:
property unsigned char TSCSHIELDY {
    unsigned char get ();
    void set (unsigned char value);
}
member TSCSHIELDY : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.TSCSHIELDY__1 Property

IRD

Stmpe610TSCSHIELDY__1 Property

TSC_SHIELD: Y-

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TSCSHIELDY__1 { get; set; }
Public Property TSCSHIELDY__1 As Byte
    Get
    Set
public:
property unsigned char TSCSHIELDY__1 {
    unsigned char get ();
    void set (unsigned char value);
}
member TSCSHIELDY__1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.WDWBLX Property

IRD

Stmpe610WDWBLX Property

WDW_BL_X

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WDWBLX { get; set; }
Public Property WDWBLX As UShort
    Get
    Set
public:
property unsigned short WDWBLX {
    unsigned short get ();
    void set (unsigned short value);
}
member WDWBLX : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.WDWBLY Property

IRD

Stmpe610WDWBLY Property

WDW_BL_Y

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WDWBLY { get; set; }
Public Property WDWBLY As UShort
    Get
    Set
public:
property unsigned short WDWBLY {
    unsigned short get ();
    void set (unsigned short value);
}
member WDWBLY : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.WDWTRX Property

IRD

Stmpe610WDWTRX Property

WDW_TR_X

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WDWTRX { get; set; }
Public Property WDWTRX As UShort
    Get
    Set
public:
property unsigned short WDWTRX {
    unsigned short get ();
    void set (unsigned short value);
}
member WDWTRX : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.WDWTRY Property

IRD

Stmpe610WDWTRY Property

WDW_TR_Y

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WDWTRY { get; set; }
Public Property WDWTRY As UShort
    Get
    Set
public:
property unsigned short WDWTRY {
    unsigned short get ();
    void set (unsigned short value);
}
member WDWTRY : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610 Methods

The Stmpe610 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.Flush Method

IRD

Stmpe610Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Stmpe610 Class
telos.Ird.ST Namespace


Stmpe610.AdcCtrl1Mod12b Enumeration

IRD

Stmpe610AdcCtrl1Mod12b Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AdcCtrl1Mod12b
Public Enumeration AdcCtrl1Mod12b
public enum class AdcCtrl1Mod12b
type AdcCtrl1Mod12b
Members
Member name | Value | Description
Value_12 | 1 | 12
Value_10 | 0 | 10
See Also

Reference

telos.Ird.ST Namespace


Stmpe610.AdcCtrl1RefSel Enumeration

IRD

Stmpe610AdcCtrl1RefSel Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AdcCtrl1RefSel
Public Enumeration AdcCtrl1RefSel
public enum class AdcCtrl1RefSel
type AdcCtrl1RefSel
Members
Member name | Value | Description
ExternalReference | 1 | External Reference
InternalReference | 0 | Internal Reference
See Also

Reference

telos.Ird.ST Namespace


Stmpe610.AdcCtrl1SampleTime Enumeration

IRD

Stmpe610AdcCtrl1SampleTime Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AdcCtrl1SampleTime
Public Enumeration AdcCtrl1SampleTime
public enum class AdcCtrl1SampleTime
type AdcCtrl1SampleTime
Members
Member name | Value | Description
Value_36 | 0 | 36
Value_44 | 1 | 44
Value_56 | 2 | 56
Value_64 | 3 | 64
Value_80 | 4 | 80
Value_96 | 5 | 96
Value_124 | 6 | 124
Reserved | 7 | Reserved
See Also

Reference

telos.Ird.ST Namespace


Stmpe610.AdcCtrl2AdcFreq Enumeration

IRD

Stmpe610AdcCtrl2AdcFreq Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AdcCtrl2AdcFreq
Public Enumeration AdcCtrl2AdcFreq
public enum class AdcCtrl2AdcFreq
type AdcCtrl2AdcFreq
Members
Member name | Value | Description
Value_1_625 | 0 | 1.625
Value_3_25 | 1 | 3.25
Value_6_5 | 2 | 6.5
See Also

Reference

telos.Ird.ST Namespace


Stmpe610.IntCtrlGlobalInt Enumeration

IRD

Stmpe610IntCtrlGlobalInt Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IntCtrlGlobalInt
Public Enumeration IntCtrlGlobalInt
public enum class IntCtrlGlobalInt
type IntCtrlGlobalInt
Members
Member name | Value | Description
GlobalInterrupt | 1 | Global Interrupt
StopsAllInterrupts | 0 | Stops All Interrupts
See Also

Reference

telos.Ird.ST Namespace


Stmpe610.IntCtrlPolarity Enumeration

IRD

Stmpe610IntCtrlPolarity Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IntCtrlPolarity
Public Enumeration IntCtrlPolarity
public enum class IntCtrlPolarity
type IntCtrlPolarity
Members
Member name | Value | Description
ActiveHighRisingEdge | 1 | Active High/Rising Edge
ActiveLowFallingEdge | 0 | Active Low/Falling Edge
See Also

Reference

telos.Ird.ST Namespace


Stmpe610.IntCtrlType Enumeration

IRD

Stmpe610IntCtrlType Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IntCtrlType
Public Enumeration IntCtrlType
public enum class IntCtrlType
type IntCtrlType
Members
Member name | Value | Description
EdgeInterrupt | 1 | Edge Interrupt
LevelInterrupt | 0 | Level Interrupt
See Also

Reference

telos.Ird.ST Namespace


Stmpe610.TscCfgAveCtrl Enumeration

IRD

Stmpe610TscCfgAveCtrl Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TscCfgAveCtrl
Public Enumeration TscCfgAveCtrl
public enum class TscCfgAveCtrl
type TscCfgAveCtrl
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_2 | 1 | 2
Value_4 | 2 | 4
Value_8 | 3 | 8
See Also

Reference

telos.Ird.ST Namespace


Stmpe610.TscCfgSettling Enumeration

IRD

Stmpe610TscCfgSettling Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TscCfgSettling
Public Enumeration TscCfgSettling
public enum class TscCfgSettling
type TscCfgSettling
Members
Member name | Value | Description
Value_10Us | 0 | 10 µs
Value_100Us | 1 | 100 µs
Value_500Us | 2 | 500 µs
Value_1Ms | 3 | 1 ms
Value_5Ms | 4 | 5 ms
Value_10Ms | 5 | 10 ms
Value_50Ms | 6 | 50 ms
Value_100Ms | 7 | 100 ms
See Also

Reference

telos.Ird.ST Namespace


Stmpe610.TscCfgTouchDetDelay Enumeration

IRD

Stmpe610TscCfgTouchDetDelay Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TscCfgTouchDetDelay
Public Enumeration TscCfgTouchDetDelay
public enum class TscCfgTouchDetDelay
type TscCfgTouchDetDelay
Members
Member name | Value | Description
Value_10Us | 0 | 10 µs
Value_50Us | 1 | 50 µs
Value_100Us | 2 | 100 µs
Value_500Us | 3 | 500 µs
Value_1Ms | 4 | 1 ms
Value_5Ms | 5 | 5 ms
Value_10Ms | 6 | 10 ms
Value_50Ms | 7 | 50 ms
See Also

Reference

telos.Ird.ST Namespace


Stmpe610.TscCtrlOpMod Enumeration

IRD

Stmpe610TscCtrlOpMod Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TscCtrlOpMod
Public Enumeration TscCtrlOpMod
public enum class TscCtrlOpMod
type TscCtrlOpMod
Members
Member name | Value | Description
XYZ | 0 | X, Y, Z
XY | 1 | X, Y
X | 2 | X
Y | 3 | Y
Z | 4 | Z
Reserved | 5 | Reserved
See Also

Reference

telos.Ird.ST Namespace


Stmpe610.TscCtrlSta Enumeration

IRD

Stmpe610TscCtrlSta Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TscCtrlSta
Public Enumeration TscCtrlSta
public enum class TscCtrlSta
type TscCtrlSta
Members
Member name | Value | Description
Detected | 1 | Detected
NotDetected | 0 | Not Detected
See Also

Reference

telos.Ird.ST Namespace


Stmpe610.TscCtrlTrack Enumeration

IRD

Stmpe610TscCtrlTrack Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TscCtrlTrack
Public Enumeration TscCtrlTrack
public enum class TscCtrlTrack
type TscCtrlTrack
Members
Member name | Value | Description
NoWindowTracking | 0 | No Window Tracking
Value_4 | 1 | 4
Value_8 | 2 | 8
Value_16 | 3 | 16
Value_32 | 4 | 32
Value_64 | 5 | 64
Value_92 | 6 | 92
Value_127 | 7 | 127
See Also

Reference

telos.Ird.ST Namespace


Stmpe610.TscIDrive Enumeration

IRD

Stmpe610TscIDrive Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TscIDrive
Public Enumeration TscIDrive
public enum class TscIDrive
type TscIDrive
Members
Member name | Value | Description
Value_20MATypical35MAMax | 0 | 20 mA Typical, 35 mA Max
Value_50MATypical80MAMax | 1 | 50 mA Typical, 80 mA Max
See Also

Reference

telos.Ird.ST Namespace


Stmpe811 Class

ST: STMPE 811
Inheritance Hierarchy
SystemObject
telos.Ird.STStmpe811

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Stmpe811
Public Class Stmpe811
public ref class Stmpe811
type Stmpe811 =  class end

The Stmpe811 type exposes the following members.

Constructors
 | Name | Description
Public method | Stmpe811 | Constructor
Top
Properties
 | Name | Description
Public property | ADCCAPT | ADC_CAPT
Public property | ADCCTRL1MOD12B | ADC_CTRL1: MOD_12B (unit: bit)
Public property | ADCCTRL1REFSEL | ADC_CTRL1: REF_SEL
Public property | ADCCTRL1SAMPLETIME | ADC_CTRL1: SAMPLE_TIME
Public property | ADCCTRL2ADCFREQ | ADC_CTRL2: ADC_FREQ (unit: MHz)
Public property | ADCDATACH0 | ADC_DATA_CH0
Public property | ADCDATACH1 | ADC_DATA_CH1
Public property | ADCDATACH2 | ADC_DATA_CH2
Public property | ADCDATACH3 | ADC_DATA_CH3
Public property | ADCDATACH4 | ADC_DATA_CH4
Public property | ADCDATACH5 | ADC_DATA_CH5
Public property | ADCDATACH6 | ADC_DATA_CH6
Public property | ADCDATACH7 | ADC_DATA_CH7
Public property | ADCINTEN | ADC_INT_EN
Public property | ADCINTSTA | ADC_INT_STA
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CHIPID | CHIP_ID
Public property | FIFOSIZE | FIFO_SIZE
Public property | FIFOSTAFIFOEMPTY | FIFO_STA: FIFO_EMPTY
Public property | FIFOSTAFIFOFULL | FIFO_STA: FIFO_FULL
Public property | FIFOSTAFIFOOFLOW | FIFO_STA: FIFO_OFLOW
Public property | FIFOSTAFIFORESET | FIFO_STA: FIFO_RESET
Public property | FIFOSTAFIFOTHTRIG | FIFO_STA: FIFO_TH_TRIG
Public property | FIFOTH | FIFO_TH
Public property | GPIOALTFUNCT | GPIO_ALT_FUNCT
Public property | GPIOCLRPIN | GPIO_CLR_PIN
Public property | GPIODIR | GPIO_DIR
Public property | GPIOEDSTA | GPIO_ED_STA
Public property | GPIOFE | GPIO_FE
Public property | GPIOINTEN | GPIO_INT_EN
Public property | GPIOINTSTA | GPIO_INT_STA
Public property | GPIOMPSTA | GPIO_MP_STA
Public property | GPIORE | GPIO_RE
Public property | GPIOSETPIN | GPIO_SET_PIN
Public property | IDVER | ID_VER
Public property | INTCTRLGLOBALINT | INT_CTRL: GLOBAL_INT
Public property | INTCTRLINTPOLARITY | INT_CTRL: INT_POLARITY
Public property | INTCTRLINTTYPE | INT_CTRL: INT_TYPE
Public property | INTENADC | INT_EN: ADC
Public property | INTENFIFOEMPTY | INT_EN: FIFO_EMPTY
Public property | INTENFIFOFULL | INT_EN: FIFO_FULL
Public property | INTENFIFOOFLOW | INT_EN: FIFO_OFLOW
Public property | INTENFIFOTH | INT_EN: FIFO_TH
Public property | INTENGPIO | INT_EN: GPIO
Public property | INTENTEMPSENS | INT_EN: TEMP_SENS
Public property | INTENTOUCHDET | INT_EN: TOUCH_DET
Public property | INTSTAADC | INT_STA: ADC
Public property | INTSTAFIFOEMPTY | INT_STA: FIFO_EMPTY
Public property | INTSTAFIFOFULL | INT_STA: FIFO_FULL
Public property | INTSTAFIFOOFLOW | INT_STA: FIFO_OFLOW
Public property | INTSTAFIFOTH | INT_STA: FIFO_TH
Public property | INTSTAGPIO | INT_STA: GPIO
Public property | INTSTATEMPSENS | INT_STA: TEMP_SENS
Public property | INTSTATOUCHDET | INT_STA: TOUCH_DET
Public property | SPICFGAUTOINCR | SPI_CFG: AUTO_INCR
Public property | SPICFGSPICLKMOD0 | SPI_CFG: SPI_CLK_MOD0
Public property | SPICFGSPICLKMOD1 | SPI_CFG: SPI_CLK_MOD1
Public property | SYSCTRL1HIBERNATE | SYS_CTRL1: HIBERNATE
Public property | SYSCTRL1SOFTRESET | SYS_CTRL1: SOFT_RESET
Public property | SYSCTRL2ADCOFF | SYS_CTRL2: ADC_OFF
Public property | SYSCTRL2GPIOOFF | SYS_CTRL2: GPIO_OFF
Public property | SYSCTRL2TSCOFF | SYS_CTRL2: TSC_OFF
Public property | SYSCTRL2TSOFF | SYS_CTRL2: TS_OFF
Public property | TEMPCTRLACQ | TEMP_CTRL: ACQ
Public property | TEMPCTRLACQMOD | TEMP_CTRL: ACQ_MOD
Public property | TEMPCTRLENABLE | TEMP_CTRL: ENABLE
Public property | TEMPCTRLTHRESEN | TEMP_CTRL: THRES_EN
Public property | TEMPCTRLTHRESRANGE | TEMP_CTRL: THRES_RANGE
Public property | TEMPDATA | TEMP_DATA
Public property | TEMPTH | TEMP_TH
Public property | TSCCFGAVECTRL | TSC_CFG: AVE_CTRL
Public property | TSCCFGSETTLING | TSC_CFG: SETTLING
Public property | TSCCFGTOUCHDETDELAY | TSC_CFG: TOUCH_DET_DELAY
Public property | TSCCTRLEN | TSC_CTRL: EN
Public property | TSCCTRLOPMOD | TSC_CTRL: OP_MOD
Public property | TSCCTRLTRACK | TSC_CTRL: TRACK
Public property | TSCCTRLTSCSTA | TSC_CTRL: TSC_STA
Public property | TSCDATAX | TSC_DATA_X
Public property | TSCDATAXYZ | TSC_DATA_XYZ
Public property | TSCDATAY | TSC_DATA_Y
Public property | TSCDATAZ | TSC_DATA_Z
Public property | TSCFRACTIONZ | TSC_FRACTION_Z
Public property | TSCIDRIVE | TSC_I_DRIVE
Public property | TSCSHIELDX | TSC_SHIELD: X+
Public property | TSCSHIELDX__1 | TSC_SHIELD: X-
Public property | TSCSHIELDY | TSC_SHIELD: Y+
Public property | TSCSHIELDY__1 | TSC_SHIELD: Y-
Public property | WDWBLX | WDW_BL_X
Public property | WDWBLY | WDW_BL_Y
Public property | WDWTRX | WDW_TR_X
Public property | WDWTRY | WDW_TR_Y
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Advanced Resistive Touch Screen Controller With 8-bit GPIO Expander
See Also

Reference

telos.Ird.ST Namespace


Stmpe811 Constructor

Constructor

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe811(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Stmpe811(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Stmpe811

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811 Properties

The Stmpe811 type exposes the following members.

Properties
 | Name | Description
Public property | ADCCAPT | ADC_CAPT
Public property | ADCCTRL1MOD12B | ADC_CTRL1: MOD_12B (unit: bit)
Public property | ADCCTRL1REFSEL | ADC_CTRL1: REF_SEL
Public property | ADCCTRL1SAMPLETIME | ADC_CTRL1: SAMPLE_TIME
Public property | ADCCTRL2ADCFREQ | ADC_CTRL2: ADC_FREQ (unit: MHz)
Public property | ADCDATACH0 | ADC_DATA_CH0
Public property | ADCDATACH1 | ADC_DATA_CH1
Public property | ADCDATACH2 | ADC_DATA_CH2
Public property | ADCDATACH3 | ADC_DATA_CH3
Public property | ADCDATACH4 | ADC_DATA_CH4
Public property | ADCDATACH5 | ADC_DATA_CH5
Public property | ADCDATACH6 | ADC_DATA_CH6
Public property | ADCDATACH7 | ADC_DATA_CH7
Public property | ADCINTEN | ADC_INT_EN
Public property | ADCINTSTA | ADC_INT_STA
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CHIPID | CHIP_ID
Public property | FIFOSIZE | FIFO_SIZE
Public property | FIFOSTAFIFOEMPTY | FIFO_STA: FIFO_EMPTY
Public property | FIFOSTAFIFOFULL | FIFO_STA: FIFO_FULL
Public property | FIFOSTAFIFOOFLOW | FIFO_STA: FIFO_OFLOW
Public property | FIFOSTAFIFORESET | FIFO_STA: FIFO_RESET
Public property | FIFOSTAFIFOTHTRIG | FIFO_STA: FIFO_TH_TRIG
Public property | FIFOTH | FIFO_TH
Public property | GPIOALTFUNCT | GPIO_ALT_FUNCT
Public property | GPIOCLRPIN | GPIO_CLR_PIN
Public property | GPIODIR | GPIO_DIR
Public property | GPIOEDSTA | GPIO_ED_STA
Public property | GPIOFE | GPIO_FE
Public property | GPIOINTEN | GPIO_INT_EN
Public property | GPIOINTSTA | GPIO_INT_STA
Public property | GPIOMPSTA | GPIO_MP_STA
Public property | GPIORE | GPIO_RE
Public property | GPIOSETPIN | GPIO_SET_PIN
Public property | IDVER | ID_VER
Public property | INTCTRLGLOBALINT | INT_CTRL: GLOBAL_INT
Public property | INTCTRLINTPOLARITY | INT_CTRL: INT_POLARITY
Public property | INTCTRLINTTYPE | INT_CTRL: INT_TYPE
Public property | INTENADC | INT_EN: ADC
Public property | INTENFIFOEMPTY | INT_EN: FIFO_EMPTY
Public property | INTENFIFOFULL | INT_EN: FIFO_FULL
Public property | INTENFIFOOFLOW | INT_EN: FIFO_OFLOW
Public property | INTENFIFOTH | INT_EN: FIFO_TH
Public property | INTENGPIO | INT_EN: GPIO
Public property | INTENTEMPSENS | INT_EN: TEMP_SENS
Public property | INTENTOUCHDET | INT_EN: TOUCH_DET
Public property | INTSTAADC | INT_STA: ADC
Public property | INTSTAFIFOEMPTY | INT_STA: FIFO_EMPTY
Public property | INTSTAFIFOFULL | INT_STA: FIFO_FULL
Public property | INTSTAFIFOOFLOW | INT_STA: FIFO_OFLOW
Public property | INTSTAFIFOTH | INT_STA: FIFO_TH
Public property | INTSTAGPIO | INT_STA: GPIO
Public property | INTSTATEMPSENS | INT_STA: TEMP_SENS
Public property | INTSTATOUCHDET | INT_STA: TOUCH_DET
Public property | SPICFGAUTOINCR | SPI_CFG: AUTO_INCR
Public property | SPICFGSPICLKMOD0 | SPI_CFG: SPI_CLK_MOD0
Public property | SPICFGSPICLKMOD1 | SPI_CFG: SPI_CLK_MOD1
Public property | SYSCTRL1HIBERNATE | SYS_CTRL1: HIBERNATE
Public property | SYSCTRL1SOFTRESET | SYS_CTRL1: SOFT_RESET
Public property | SYSCTRL2ADCOFF | SYS_CTRL2: ADC_OFF
Public property | SYSCTRL2GPIOOFF | SYS_CTRL2: GPIO_OFF
Public property | SYSCTRL2TSCOFF | SYS_CTRL2: TSC_OFF
Public property | SYSCTRL2TSOFF | SYS_CTRL2: TS_OFF
Public property | TEMPCTRLACQ | TEMP_CTRL: ACQ
Public property | TEMPCTRLACQMOD | TEMP_CTRL: ACQ_MOD
Public property | TEMPCTRLENABLE | TEMP_CTRL: ENABLE
Public property | TEMPCTRLTHRESEN | TEMP_CTRL: THRES_EN
Public property | TEMPCTRLTHRESRANGE | TEMP_CTRL: THRES_RANGE
Public property | TEMPDATA | TEMP_DATA
Public property | TEMPTH | TEMP_TH
Public property | TSCCFGAVECTRL | TSC_CFG: AVE_CTRL
Public property | TSCCFGSETTLING | TSC_CFG: SETTLING
Public property | TSCCFGTOUCHDETDELAY | TSC_CFG: TOUCH_DET_DELAY
Public property | TSCCTRLEN | TSC_CTRL: EN
Public property | TSCCTRLOPMOD | TSC_CTRL: OP_MOD
Public property | TSCCTRLTRACK | TSC_CTRL: TRACK
Public property | TSCCTRLTSCSTA | TSC_CTRL: TSC_STA
Public property | TSCDATAX | TSC_DATA_X
Public property | TSCDATAXYZ | TSC_DATA_XYZ
Public property | TSCDATAY | TSC_DATA_Y
Public property | TSCDATAZ | TSC_DATA_Z
Public property | TSCFRACTIONZ | TSC_FRACTION_Z
Public property | TSCIDRIVE | TSC_I_DRIVE
Public property | TSCSHIELDX | TSC_SHIELD: X+
Public property | TSCSHIELDX__1 | TSC_SHIELD: X-
Public property | TSCSHIELDY | TSC_SHIELD: Y+
Public property | TSCSHIELDY__1 | TSC_SHIELD: Y-
Public property | WDWBLX | WDW_BL_X
Public property | WDWBLY | WDW_BL_Y
Public property | WDWTRX | WDW_TR_X
Public property | WDWTRY | WDW_TR_Y
Top
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.ADCCAPT Property

IRD

Stmpe811ADCCAPT Property

ADC_CAPT

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCCAPT { get; set; }
Public Property ADCCAPT As Byte
    Get
    Set
public:
property unsigned char ADCCAPT {
    unsigned char get ();
    void set (unsigned char value);
}
member ADCCAPT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.ADCCTRL1MOD12B Property

IRD

Stmpe811ADCCTRL1MOD12B Property

ADC_CTRL1: MOD_12B (unit: bit)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe811AdcCtrl1Mod12b ADCCTRL1MOD12B { get; set; }
Public Property ADCCTRL1MOD12B As Stmpe811AdcCtrl1Mod12b
    Get
    Set
public:
property Stmpe811AdcCtrl1Mod12b ADCCTRL1MOD12B {
    Stmpe811AdcCtrl1Mod12b get ();
    void set (Stmpe811AdcCtrl1Mod12b value);
}
member ADCCTRL1MOD12B : Stmpe811AdcCtrl1Mod12b with get, set

Property Value

Type: Stmpe811AdcCtrl1Mod12b
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.ADCCTRL1REFSEL Property

IRD

Stmpe811ADCCTRL1REFSEL Property

ADC_CTRL1: REF_SEL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe811AdcCtrl1RefSel ADCCTRL1REFSEL { get; set; }
Public Property ADCCTRL1REFSEL As Stmpe811AdcCtrl1RefSel
    Get
    Set
public:
property Stmpe811AdcCtrl1RefSel ADCCTRL1REFSEL {
    Stmpe811AdcCtrl1RefSel get ();
    void set (Stmpe811AdcCtrl1RefSel value);
}
member ADCCTRL1REFSEL : Stmpe811AdcCtrl1RefSel with get, set

Property Value

Type: Stmpe811AdcCtrl1RefSel
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.ADCCTRL1SAMPLETIME Property

IRD

Stmpe811ADCCTRL1SAMPLETIME Property

ADC_CTRL1: SAMPLE_TIME

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe811AdcCtrl1SampleTime ADCCTRL1SAMPLETIME { get; set; }
Public Property ADCCTRL1SAMPLETIME As Stmpe811AdcCtrl1SampleTime
    Get
    Set
public:
property Stmpe811AdcCtrl1SampleTime ADCCTRL1SAMPLETIME {
    Stmpe811AdcCtrl1SampleTime get ();
    void set (Stmpe811AdcCtrl1SampleTime value);
}
member ADCCTRL1SAMPLETIME : Stmpe811AdcCtrl1SampleTime with get, set

Property Value

Type: Stmpe811AdcCtrl1SampleTime
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.ADCCTRL2ADCFREQ Property

IRD

Stmpe811ADCCTRL2ADCFREQ Property

ADC_CTRL2: ADC_FREQ (unit: MHz)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe811AdcCtrl2AdcFreq ADCCTRL2ADCFREQ { get; set; }
Public Property ADCCTRL2ADCFREQ As Stmpe811AdcCtrl2AdcFreq
    Get
    Set
public:
property Stmpe811AdcCtrl2AdcFreq ADCCTRL2ADCFREQ {
    Stmpe811AdcCtrl2AdcFreq get ();
    void set (Stmpe811AdcCtrl2AdcFreq value);
}
member ADCCTRL2ADCFREQ : Stmpe811AdcCtrl2AdcFreq with get, set

Property Value

Type: Stmpe811AdcCtrl2AdcFreq
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.ADCDATACH0 Property

IRD

Stmpe811ADCDATACH0 Property

ADC_DATA_CH0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCDATACH0 { get; }
Public ReadOnly Property ADCDATACH0 As UShort
    Get
public:
property unsigned short ADCDATACH0 {
    unsigned short get ();
}
member ADCDATACH0 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.ADCDATACH1 Property

IRD

Stmpe811ADCDATACH1 Property

ADC_DATA_CH1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCDATACH1 { get; }
Public ReadOnly Property ADCDATACH1 As UShort
    Get
public:
property unsigned short ADCDATACH1 {
    unsigned short get ();
}
member ADCDATACH1 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.ADCDATACH2 Property

IRD

Stmpe811ADCDATACH2 Property

ADC_DATA_CH2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCDATACH2 { get; }
Public ReadOnly Property ADCDATACH2 As UShort
    Get
public:
property unsigned short ADCDATACH2 {
    unsigned short get ();
}
member ADCDATACH2 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.ADCDATACH3 Property

IRD

Stmpe811ADCDATACH3 Property

ADC_DATA_CH3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCDATACH3 { get; }
Public ReadOnly Property ADCDATACH3 As UShort
    Get
public:
property unsigned short ADCDATACH3 {
    unsigned short get ();
}
member ADCDATACH3 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.ADCDATACH4 Property

IRD

Stmpe811ADCDATACH4 Property

ADC_DATA_CH4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCDATACH4 { get; }
Public ReadOnly Property ADCDATACH4 As UShort
    Get
public:
property unsigned short ADCDATACH4 {
    unsigned short get ();
}
member ADCDATACH4 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.ADCDATACH5 Property

IRD

Stmpe811ADCDATACH5 Property

ADC_DATA_CH5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCDATACH5 { get; }
Public ReadOnly Property ADCDATACH5 As UShort
    Get
public:
property unsigned short ADCDATACH5 {
    unsigned short get ();
}
member ADCDATACH5 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.ADCDATACH6 Property

IRD

Stmpe811ADCDATACH6 Property

ADC_DATA_CH6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCDATACH6 { get; }
Public ReadOnly Property ADCDATACH6 As UShort
    Get
public:
property unsigned short ADCDATACH6 {
    unsigned short get ();
}
member ADCDATACH6 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.ADCDATACH7 Property

IRD

Stmpe811ADCDATACH7 Property

ADC_DATA_CH7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ADCDATACH7 { get; }
Public ReadOnly Property ADCDATACH7 As UShort
    Get
public:
property unsigned short ADCDATACH7 {
    unsigned short get ();
}
member ADCDATACH7 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.ADCINTEN Property

IRD

Stmpe811ADCINTEN Property

ADC_INT_EN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCINTEN { get; set; }
Public Property ADCINTEN As Byte
    Get
    Set
public:
property unsigned char ADCINTEN {
    unsigned char get ();
    void set (unsigned char value);
}
member ADCINTEN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.ADCINTSTA Property

IRD

Stmpe811ADCINTSTA Property

ADC_INT_STA

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCINTSTA { get; }
Public ReadOnly Property ADCINTSTA As Byte
    Get
public:
property unsigned char ADCINTSTA {
    unsigned char get ();
}
member ADCINTSTA : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.AutoFlush Property

IRD

Stmpe811AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.CHIPID Property

IRD

Stmpe811CHIPID Property

CHIP_ID

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort CHIPID { get; }
Public ReadOnly Property CHIPID As UShort
    Get
public:
property unsigned short CHIPID {
    unsigned short get ();
}
member CHIPID : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.FIFOSIZE Property

IRD

Stmpe811FIFOSIZE Property

FIFO_SIZE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOSIZE { get; }
Public ReadOnly Property FIFOSIZE As Byte
    Get
public:
property unsigned char FIFOSIZE {
    unsigned char get ();
}
member FIFOSIZE : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.FIFOSTAFIFOEMPTY Property

IRD

Stmpe811FIFOSTAFIFOEMPTY Property

FIFO_STA: FIFO_EMPTY

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOSTAFIFOEMPTY { get; set; }
Public Property FIFOSTAFIFOEMPTY As Byte
    Get
    Set
public:
property unsigned char FIFOSTAFIFOEMPTY {
    unsigned char get ();
    void set (unsigned char value);
}
member FIFOSTAFIFOEMPTY : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.FIFOSTAFIFOFULL Property

IRD

Stmpe811FIFOSTAFIFOFULL Property

FIFO_STA: FIFO_FULL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOSTAFIFOFULL { get; set; }
Public Property FIFOSTAFIFOFULL As Byte
    Get
    Set
public:
property unsigned char FIFOSTAFIFOFULL {
    unsigned char get ();
    void set (unsigned char value);
}
member FIFOSTAFIFOFULL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.FIFOSTAFIFOOFLOW Property

IRD

Stmpe811FIFOSTAFIFOOFLOW Property

FIFO_STA: FIFO_OFLOW

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOSTAFIFOOFLOW { get; set; }
Public Property FIFOSTAFIFOOFLOW As Byte
    Get
    Set
public:
property unsigned char FIFOSTAFIFOOFLOW {
    unsigned char get ();
    void set (unsigned char value);
}
member FIFOSTAFIFOOFLOW : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.FIFOSTAFIFORESET Property

IRD

Stmpe811FIFOSTAFIFORESET Property

FIFO_STA: FIFO_RESET

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOSTAFIFORESET { get; set; }
Public Property FIFOSTAFIFORESET As Byte
    Get
    Set
public:
property unsigned char FIFOSTAFIFORESET {
    unsigned char get ();
    void set (unsigned char value);
}
member FIFOSTAFIFORESET : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.FIFOSTAFIFOTHTRIG Property

IRD

Stmpe811FIFOSTAFIFOTHTRIG Property

FIFO_STA: FIFO_TH_TRIG

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOSTAFIFOTHTRIG { get; set; }
Public Property FIFOSTAFIFOTHTRIG As Byte
    Get
    Set
public:
property unsigned char FIFOSTAFIFOTHTRIG {
    unsigned char get ();
    void set (unsigned char value);
}
member FIFOSTAFIFOTHTRIG : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.FIFOTH Property

IRD

Stmpe811FIFOTH Property

FIFO_TH

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FIFOTH { get; set; }
Public Property FIFOTH As Byte
    Get
    Set
public:
property unsigned char FIFOTH {
    unsigned char get ();
    void set (unsigned char value);
}
member FIFOTH : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.GPIOALTFUNCT Property

IRD

Stmpe811GPIOALTFUNCT Property

GPIO_ALT_FUNCT

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOALTFUNCT { get; set; }
Public Property GPIOALTFUNCT As Byte
    Get
    Set
public:
property unsigned char GPIOALTFUNCT {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOALTFUNCT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.GPIOCLRPIN Property

IRD

Stmpe811GPIOCLRPIN Property

GPIO_CLR_PIN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOCLRPIN { get; set; }
Public Property GPIOCLRPIN As Byte
    Get
    Set
public:
property unsigned char GPIOCLRPIN {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOCLRPIN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.GPIODIR Property

IRD

Stmpe811GPIODIR Property

GPIO_DIR

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIODIR { get; set; }
Public Property GPIODIR As Byte
    Get
    Set
public:
property unsigned char GPIODIR {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIODIR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.GPIOEDSTA Property

IRD

Stmpe811GPIOEDSTA Property

GPIO_ED_STA

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOEDSTA { get; set; }
Public Property GPIOEDSTA As Byte
    Get
    Set
public:
property unsigned char GPIOEDSTA {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOEDSTA : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.GPIOFE Property

IRD

Stmpe811GPIOFE Property

GPIO_FE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOFE { get; set; }
Public Property GPIOFE As Byte
    Get
    Set
public:
property unsigned char GPIOFE {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOFE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.GPIOINTEN Property

IRD

Stmpe811GPIOINTEN Property

GPIO_INT_EN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINTEN { get; set; }
Public Property GPIOINTEN As Byte
    Get
    Set
public:
property unsigned char GPIOINTEN {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOINTEN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.GPIOINTSTA Property

IRD

Stmpe811GPIOINTSTA Property

GPIO_INT_STA

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINTSTA { get; }
Public ReadOnly Property GPIOINTSTA As Byte
    Get
public:
property unsigned char GPIOINTSTA {
    unsigned char get ();
}
member GPIOINTSTA : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.GPIOMPSTA Property

IRD

Stmpe811GPIOMPSTA Property

GPIO_MP_STA

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOMPSTA { get; set; }
Public Property GPIOMPSTA As Byte
    Get
    Set
public:
property unsigned char GPIOMPSTA {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOMPSTA : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.GPIORE Property

IRD

Stmpe811GPIORE Property

GPIO_RE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIORE { get; set; }
Public Property GPIORE As Byte
    Get
    Set
public:
property unsigned char GPIORE {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIORE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.GPIOSETPIN Property

IRD

Stmpe811GPIOSETPIN Property

GPIO_SET_PIN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSETPIN { get; set; }
Public Property GPIOSETPIN As Byte
    Get
    Set
public:
property unsigned char GPIOSETPIN {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSETPIN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.IDVER Property

IRD

Stmpe811IDVER Property

ID_VER

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IDVER { get; }
Public ReadOnly Property IDVER As Byte
    Get
public:
property unsigned char IDVER {
    unsigned char get ();
}
member IDVER : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTCTRLGLOBALINT Property

IRD

Stmpe811INTCTRLGLOBALINT Property

INT_CTRL: GLOBAL_INT

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe811IntCtrlGlobalInt INTCTRLGLOBALINT { get; set; }
Public Property INTCTRLGLOBALINT As Stmpe811IntCtrlGlobalInt
    Get
    Set
public:
property Stmpe811IntCtrlGlobalInt INTCTRLGLOBALINT {
    Stmpe811IntCtrlGlobalInt get ();
    void set (Stmpe811IntCtrlGlobalInt value);
}
member INTCTRLGLOBALINT : Stmpe811IntCtrlGlobalInt with get, set

Property Value

Type: Stmpe811IntCtrlGlobalInt
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTCTRLINTPOLARITY Property

IRD

Stmpe811INTCTRLINTPOLARITY Property

INT_CTRL: INT_POLARITY

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe811IntCtrlPolarity INTCTRLINTPOLARITY { get; set; }
Public Property INTCTRLINTPOLARITY As Stmpe811IntCtrlPolarity
    Get
    Set
public:
property Stmpe811IntCtrlPolarity INTCTRLINTPOLARITY {
    Stmpe811IntCtrlPolarity get ();
    void set (Stmpe811IntCtrlPolarity value);
}
member INTCTRLINTPOLARITY : Stmpe811IntCtrlPolarity with get, set

Property Value

Type: Stmpe811IntCtrlPolarity
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTCTRLINTTYPE Property

IRD

Stmpe811INTCTRLINTTYPE Property

INT_CTRL: INT_TYPE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe811IntCtrlType INTCTRLINTTYPE { get; set; }
Public Property INTCTRLINTTYPE As Stmpe811IntCtrlType
    Get
    Set
public:
property Stmpe811IntCtrlType INTCTRLINTTYPE {
    Stmpe811IntCtrlType get ();
    void set (Stmpe811IntCtrlType value);
}
member INTCTRLINTTYPE : Stmpe811IntCtrlType with get, set

Property Value

Type: Stmpe811IntCtrlType
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTENADC Property

IRD

Stmpe811INTENADC Property

INT_EN: ADC

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENADC { get; set; }
Public Property INTENADC As Byte
    Get
    Set
public:
property unsigned char INTENADC {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENADC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTENFIFOEMPTY Property

IRD

Stmpe811INTENFIFOEMPTY Property

INT_EN: FIFO_EMPTY

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENFIFOEMPTY { get; set; }
Public Property INTENFIFOEMPTY As Byte
    Get
    Set
public:
property unsigned char INTENFIFOEMPTY {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENFIFOEMPTY : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTENFIFOFULL Property

IRD

Stmpe811INTENFIFOFULL Property

INT_EN: FIFO_FULL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENFIFOFULL { get; set; }
Public Property INTENFIFOFULL As Byte
    Get
    Set
public:
property unsigned char INTENFIFOFULL {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENFIFOFULL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTENFIFOOFLOW Property

IRD

Stmpe811INTENFIFOOFLOW Property

INT_EN: FIFO_OFLOW

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENFIFOOFLOW { get; set; }
Public Property INTENFIFOOFLOW As Byte
    Get
    Set
public:
property unsigned char INTENFIFOOFLOW {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENFIFOOFLOW : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTENFIFOTH Property

IRD

Stmpe811INTENFIFOTH Property

INT_EN: FIFO_TH

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENFIFOTH { get; set; }
Public Property INTENFIFOTH As Byte
    Get
    Set
public:
property unsigned char INTENFIFOTH {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENFIFOTH : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTENGPIO Property

IRD

Stmpe811INTENGPIO Property

INT_EN: GPIO

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENGPIO { get; set; }
Public Property INTENGPIO As Byte
    Get
    Set
public:
property unsigned char INTENGPIO {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENGPIO : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTENTEMPSENS Property

IRD

Stmpe811INTENTEMPSENS Property

INT_EN: TEMP_SENS

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENTEMPSENS { get; set; }
Public Property INTENTEMPSENS As Byte
    Get
    Set
public:
property unsigned char INTENTEMPSENS {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENTEMPSENS : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTENTOUCHDET Property

IRD

Stmpe811INTENTOUCHDET Property

INT_EN: TOUCH_DET

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENTOUCHDET { get; set; }
Public Property INTENTOUCHDET As Byte
    Get
    Set
public:
property unsigned char INTENTOUCHDET {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENTOUCHDET : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTSTAADC Property

IRD

Stmpe811INTSTAADC Property

INT_STA: ADC

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAADC { get; }
Public ReadOnly Property INTSTAADC As Byte
    Get
public:
property unsigned char INTSTAADC {
    unsigned char get ();
}
member INTSTAADC : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTSTAFIFOEMPTY Property

IRD

Stmpe811INTSTAFIFOEMPTY Property

INT_STA: FIFO_EMPTY

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAFIFOEMPTY { get; }
Public ReadOnly Property INTSTAFIFOEMPTY As Byte
    Get
public:
property unsigned char INTSTAFIFOEMPTY {
    unsigned char get ();
}
member INTSTAFIFOEMPTY : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTSTAFIFOFULL Property

IRD

Stmpe811INTSTAFIFOFULL Property

INT_STA: FIFO_FULL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAFIFOFULL { get; }
Public ReadOnly Property INTSTAFIFOFULL As Byte
    Get
public:
property unsigned char INTSTAFIFOFULL {
    unsigned char get ();
}
member INTSTAFIFOFULL : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTSTAFIFOOFLOW Property

IRD

Stmpe811INTSTAFIFOOFLOW Property

INT_STA: FIFO_OFLOW

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAFIFOOFLOW { get; }
Public ReadOnly Property INTSTAFIFOOFLOW As Byte
    Get
public:
property unsigned char INTSTAFIFOOFLOW {
    unsigned char get ();
}
member INTSTAFIFOOFLOW : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTSTAFIFOTH Property

IRD

Stmpe811INTSTAFIFOTH Property

INT_STA: FIFO_TH

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAFIFOTH { get; }
Public ReadOnly Property INTSTAFIFOTH As Byte
    Get
public:
property unsigned char INTSTAFIFOTH {
    unsigned char get ();
}
member INTSTAFIFOTH : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTSTAGPIO Property

IRD

Stmpe811INTSTAGPIO Property

INT_STA: GPIO

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAGPIO { get; }
Public ReadOnly Property INTSTAGPIO As Byte
    Get
public:
property unsigned char INTSTAGPIO {
    unsigned char get ();
}
member INTSTAGPIO : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTSTATEMPSENS Property

IRD

Stmpe811INTSTATEMPSENS Property

INT_STA: TEMP_SENS

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTATEMPSENS { get; }
Public ReadOnly Property INTSTATEMPSENS As Byte
    Get
public:
property unsigned char INTSTATEMPSENS {
    unsigned char get ();
}
member INTSTATEMPSENS : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.INTSTATOUCHDET Property

IRD

Stmpe811INTSTATOUCHDET Property

INT_STA: TOUCH_DET

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTATOUCHDET { get; }
Public ReadOnly Property INTSTATOUCHDET As Byte
    Get
public:
property unsigned char INTSTATOUCHDET {
    unsigned char get ();
}
member INTSTATOUCHDET : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.SPICFGAUTOINCR Property

IRD

Stmpe811SPICFGAUTOINCR Property

SPI_CFG: AUTO_INCR

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SPICFGAUTOINCR { get; set; }
Public Property SPICFGAUTOINCR As Byte
    Get
    Set
public:
property unsigned char SPICFGAUTOINCR {
    unsigned char get ();
    void set (unsigned char value);
}
member SPICFGAUTOINCR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.SPICFGSPICLKMOD0 Property

IRD

Stmpe811SPICFGSPICLKMOD0 Property

SPI_CFG: SPI_CLK_MOD0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SPICFGSPICLKMOD0 { get; set; }
Public Property SPICFGSPICLKMOD0 As Byte
    Get
    Set
public:
property unsigned char SPICFGSPICLKMOD0 {
    unsigned char get ();
    void set (unsigned char value);
}
member SPICFGSPICLKMOD0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.SPICFGSPICLKMOD1 Property

IRD

Stmpe811SPICFGSPICLKMOD1 Property

SPI_CFG: SPI_CLK_MOD1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SPICFGSPICLKMOD1 { get; set; }
Public Property SPICFGSPICLKMOD1 As Byte
    Get
    Set
public:
property unsigned char SPICFGSPICLKMOD1 {
    unsigned char get ();
    void set (unsigned char value);
}
member SPICFGSPICLKMOD1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.SYSCTRL1HIBERNATE Property

IRD

Stmpe811SYSCTRL1HIBERNATE Property

SYS_CTRL1: HIBERNATE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCTRL1HIBERNATE { get; set; }
Public Property SYSCTRL1HIBERNATE As Byte
    Get
    Set
public:
property unsigned char SYSCTRL1HIBERNATE {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCTRL1HIBERNATE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.SYSCTRL1SOFTRESET Property

IRD

Stmpe811SYSCTRL1SOFTRESET Property

SYS_CTRL1: SOFT_RESET

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCTRL1SOFTRESET { get; set; }
Public Property SYSCTRL1SOFTRESET As Byte
    Get
    Set
public:
property unsigned char SYSCTRL1SOFTRESET {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCTRL1SOFTRESET : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.SYSCTRL2ADCOFF Property

IRD

Stmpe811SYSCTRL2ADCOFF Property

SYS_CTRL2: ADC_OFF

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCTRL2ADCOFF { get; set; }
Public Property SYSCTRL2ADCOFF As Byte
    Get
    Set
public:
property unsigned char SYSCTRL2ADCOFF {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCTRL2ADCOFF : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.SYSCTRL2GPIOOFF Property

IRD

Stmpe811SYSCTRL2GPIOOFF Property

SYS_CTRL2: GPIO_OFF

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCTRL2GPIOOFF { get; set; }
Public Property SYSCTRL2GPIOOFF As Byte
    Get
    Set
public:
property unsigned char SYSCTRL2GPIOOFF {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCTRL2GPIOOFF : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.SYSCTRL2TSCOFF Property

IRD

Stmpe811SYSCTRL2TSCOFF Property

SYS_CTRL2: TSC_OFF

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCTRL2TSCOFF { get; set; }
Public Property SYSCTRL2TSCOFF As Byte
    Get
    Set
public:
property unsigned char SYSCTRL2TSCOFF {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCTRL2TSCOFF : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.SYSCTRL2TSOFF Property

IRD

Stmpe811SYSCTRL2TSOFF Property

SYS_CTRL2: TS_OFF

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCTRL2TSOFF { get; set; }
Public Property SYSCTRL2TSOFF As Byte
    Get
    Set
public:
property unsigned char SYSCTRL2TSOFF {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCTRL2TSOFF : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TEMPCTRLACQ Property

IRD

Stmpe811TEMPCTRLACQ Property

TEMP_CTRL: ACQ

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TEMPCTRLACQ { get; set; }
Public Property TEMPCTRLACQ As Byte
    Get
    Set
public:
property unsigned char TEMPCTRLACQ {
    unsigned char get ();
    void set (unsigned char value);
}
member TEMPCTRLACQ : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TEMPCTRLACQMOD Property

IRD

Stmpe811TEMPCTRLACQMOD Property

TEMP_CTRL: ACQ_MOD

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TEMPCTRLACQMOD { get; set; }
Public Property TEMPCTRLACQMOD As Byte
    Get
    Set
public:
property unsigned char TEMPCTRLACQMOD {
    unsigned char get ();
    void set (unsigned char value);
}
member TEMPCTRLACQMOD : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TEMPCTRLENABLE Property

IRD

Stmpe811TEMPCTRLENABLE Property

TEMP_CTRL: ENABLE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TEMPCTRLENABLE { get; set; }
Public Property TEMPCTRLENABLE As Byte
    Get
    Set
public:
property unsigned char TEMPCTRLENABLE {
    unsigned char get ();
    void set (unsigned char value);
}
member TEMPCTRLENABLE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TEMPCTRLTHRESEN Property

IRD

Stmpe811TEMPCTRLTHRESEN Property

TEMP_CTRL: THRES_EN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TEMPCTRLTHRESEN { get; set; }
Public Property TEMPCTRLTHRESEN As Byte
    Get
    Set
public:
property unsigned char TEMPCTRLTHRESEN {
    unsigned char get ();
    void set (unsigned char value);
}
member TEMPCTRLTHRESEN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TEMPCTRLTHRESRANGE Property

IRD

Stmpe811TEMPCTRLTHRESRANGE Property

TEMP_CTRL: THRES_RANGE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TEMPCTRLTHRESRANGE { get; set; }
Public Property TEMPCTRLTHRESRANGE As Byte
    Get
    Set
public:
property unsigned char TEMPCTRLTHRESRANGE {
    unsigned char get ();
    void set (unsigned char value);
}
member TEMPCTRLTHRESRANGE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TEMPDATA Property

IRD

Stmpe811TEMPDATA Property

TEMP_DATA

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TEMPDATA { get; }
Public ReadOnly Property TEMPDATA As UShort
    Get
public:
property unsigned short TEMPDATA {
    unsigned short get ();
}
member TEMPDATA : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TEMPTH Property

IRD

Stmpe811TEMPTH Property

TEMP_TH

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TEMPTH { get; set; }
Public Property TEMPTH As UShort
    Get
    Set
public:
property unsigned short TEMPTH {
    unsigned short get ();
    void set (unsigned short value);
}
member TEMPTH : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TSCCFGAVECTRL Property

IRD

Stmpe811TSCCFGAVECTRL Property

TSC_CFG: AVE_CTRL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe811TscCfgAveCtrl TSCCFGAVECTRL { get; set; }
Public Property TSCCFGAVECTRL As Stmpe811TscCfgAveCtrl
    Get
    Set
public:
property Stmpe811TscCfgAveCtrl TSCCFGAVECTRL {
    Stmpe811TscCfgAveCtrl get ();
    void set (Stmpe811TscCfgAveCtrl value);
}
member TSCCFGAVECTRL : Stmpe811TscCfgAveCtrl with get, set

Property Value

Type: Stmpe811TscCfgAveCtrl
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TSCCFGSETTLING Property

IRD

Stmpe811TSCCFGSETTLING Property

TSC_CFG: SETTLING

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe811TscCfgSettling TSCCFGSETTLING { get; set; }
Public Property TSCCFGSETTLING As Stmpe811TscCfgSettling
    Get
    Set
public:
property Stmpe811TscCfgSettling TSCCFGSETTLING {
    Stmpe811TscCfgSettling get ();
    void set (Stmpe811TscCfgSettling value);
}
member TSCCFGSETTLING : Stmpe811TscCfgSettling with get, set

Property Value

Type: Stmpe811TscCfgSettling
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TSCCFGTOUCHDETDELAY Property

IRD

Stmpe811TSCCFGTOUCHDETDELAY Property

TSC_CFG: TOUCH_DET_DELAY

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe811TscCfgTouchDetDelay TSCCFGTOUCHDETDELAY { get; set; }
Public Property TSCCFGTOUCHDETDELAY As Stmpe811TscCfgTouchDetDelay
    Get
    Set
public:
property Stmpe811TscCfgTouchDetDelay TSCCFGTOUCHDETDELAY {
    Stmpe811TscCfgTouchDetDelay get ();
    void set (Stmpe811TscCfgTouchDetDelay value);
}
member TSCCFGTOUCHDETDELAY : Stmpe811TscCfgTouchDetDelay with get, set

Property Value

Type: Stmpe811TscCfgTouchDetDelay
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TSCCTRLEN Property

IRD

Stmpe811TSCCTRLEN Property

TSC_CTRL: EN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TSCCTRLEN { get; set; }
Public Property TSCCTRLEN As Byte
    Get
    Set
public:
property unsigned char TSCCTRLEN {
    unsigned char get ();
    void set (unsigned char value);
}
member TSCCTRLEN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TSCCTRLOPMOD Property

IRD

Stmpe811TSCCTRLOPMOD Property

TSC_CTRL: OP_MOD

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe811TscCtrlOpMod TSCCTRLOPMOD { get; set; }
Public Property TSCCTRLOPMOD As Stmpe811TscCtrlOpMod
    Get
    Set
public:
property Stmpe811TscCtrlOpMod TSCCTRLOPMOD {
    Stmpe811TscCtrlOpMod get ();
    void set (Stmpe811TscCtrlOpMod value);
}
member TSCCTRLOPMOD : Stmpe811TscCtrlOpMod with get, set

Property Value

Type: Stmpe811TscCtrlOpMod
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TSCCTRLTRACK Property

IRD

Stmpe811TSCCTRLTRACK Property

TSC_CTRL: TRACK

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe811TscCtrlTrack TSCCTRLTRACK { get; set; }
Public Property TSCCTRLTRACK As Stmpe811TscCtrlTrack
    Get
    Set
public:
property Stmpe811TscCtrlTrack TSCCTRLTRACK {
    Stmpe811TscCtrlTrack get ();
    void set (Stmpe811TscCtrlTrack value);
}
member TSCCTRLTRACK : Stmpe811TscCtrlTrack with get, set

Property Value

Type: Stmpe811TscCtrlTrack
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TSCCTRLTSCSTA Property

IRD

Stmpe811TSCCTRLTSCSTA Property

TSC_CTRL: TSC_STA

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe811TscCtrlSta TSCCTRLTSCSTA { get; set; }
Public Property TSCCTRLTSCSTA As Stmpe811TscCtrlSta
    Get
    Set
public:
property Stmpe811TscCtrlSta TSCCTRLTSCSTA {
    Stmpe811TscCtrlSta get ();
    void set (Stmpe811TscCtrlSta value);
}
member TSCCTRLTSCSTA : Stmpe811TscCtrlSta with get, set

Property Value

Type: Stmpe811TscCtrlSta
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TSCDATAX Property

IRD

Stmpe811TSCDATAX Property

TSC_DATA_X

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TSCDATAX { get; }
Public ReadOnly Property TSCDATAX As UShort
    Get
public:
property unsigned short TSCDATAX {
    unsigned short get ();
}
member TSCDATAX : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TSCDATAXYZ Property

IRD

Stmpe811TSCDATAXYZ Property

TSC_DATA_XYZ

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public uint TSCDATAXYZ { get; }
Public ReadOnly Property TSCDATAXYZ As UInteger
    Get
public:
property unsigned int TSCDATAXYZ {
    unsigned int get ();
}
member TSCDATAXYZ : uint32 with get

Property Value

Type: UInt32
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TSCDATAY Property

IRD

Stmpe811TSCDATAY Property

TSC_DATA_Y

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TSCDATAY { get; }
Public ReadOnly Property TSCDATAY As UShort
    Get
public:
property unsigned short TSCDATAY {
    unsigned short get ();
}
member TSCDATAY : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TSCDATAZ Property

IRD

Stmpe811TSCDATAZ Property

TSC_DATA_Z

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TSCDATAZ { get; }
Public ReadOnly Property TSCDATAZ As Byte
    Get
public:
property unsigned char TSCDATAZ {
    unsigned char get ();
}
member TSCDATAZ : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TSCFRACTIONZ Property

IRD

Stmpe811TSCFRACTIONZ Property

TSC_FRACTION_Z

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TSCFRACTIONZ { get; }
Public ReadOnly Property TSCFRACTIONZ As Byte
    Get
public:
property unsigned char TSCFRACTIONZ {
    unsigned char get ();
}
member TSCFRACTIONZ : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TSCIDRIVE Property

IRD

Stmpe811TSCIDRIVE Property

TSC_I_DRIVE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe811TscIDrive TSCIDRIVE { get; set; }
Public Property TSCIDRIVE As Stmpe811TscIDrive
    Get
    Set
public:
property Stmpe811TscIDrive TSCIDRIVE {
    Stmpe811TscIDrive get ();
    void set (Stmpe811TscIDrive value);
}
member TSCIDRIVE : Stmpe811TscIDrive with get, set

Property Value

Type: Stmpe811TscIDrive
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TSCSHIELDX Property

IRD

Stmpe811TSCSHIELDX Property

TSC_SHIELD: X+

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TSCSHIELDX { get; set; }
Public Property TSCSHIELDX As Byte
    Get
    Set
public:
property unsigned char TSCSHIELDX {
    unsigned char get ();
    void set (unsigned char value);
}
member TSCSHIELDX : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TSCSHIELDX__1 Property

IRD

Stmpe811TSCSHIELDX__1 Property

TSC_SHIELD: X-

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TSCSHIELDX__1 { get; set; }
Public Property TSCSHIELDX__1 As Byte
    Get
    Set
public:
property unsigned char TSCSHIELDX__1 {
    unsigned char get ();
    void set (unsigned char value);
}
member TSCSHIELDX__1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TSCSHIELDY Property

IRD

Stmpe811TSCSHIELDY Property

TSC_SHIELD: Y+

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TSCSHIELDY { get; set; }
Public Property TSCSHIELDY As Byte
    Get
    Set
public:
property unsigned char TSCSHIELDY {
    unsigned char get ();
    void set (unsigned char value);
}
member TSCSHIELDY : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.TSCSHIELDY__1 Property

IRD

Stmpe811TSCSHIELDY__1 Property

TSC_SHIELD: Y-

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TSCSHIELDY__1 { get; set; }
Public Property TSCSHIELDY__1 As Byte
    Get
    Set
public:
property unsigned char TSCSHIELDY__1 {
    unsigned char get ();
    void set (unsigned char value);
}
member TSCSHIELDY__1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.WDWBLX Property

IRD

Stmpe811WDWBLX Property

WDW_BL_X

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WDWBLX { get; set; }
Public Property WDWBLX As UShort
    Get
    Set
public:
property unsigned short WDWBLX {
    unsigned short get ();
    void set (unsigned short value);
}
member WDWBLX : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.WDWBLY Property

IRD

Stmpe811WDWBLY Property

WDW_BL_Y

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WDWBLY { get; set; }
Public Property WDWBLY As UShort
    Get
    Set
public:
property unsigned short WDWBLY {
    unsigned short get ();
    void set (unsigned short value);
}
member WDWBLY : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.WDWTRX Property

IRD

Stmpe811WDWTRX Property

WDW_TR_X

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WDWTRX { get; set; }
Public Property WDWTRX As UShort
    Get
    Set
public:
property unsigned short WDWTRX {
    unsigned short get ();
    void set (unsigned short value);
}
member WDWTRX : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.WDWTRY Property

IRD

Stmpe811WDWTRY Property

WDW_TR_Y

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort WDWTRY { get; set; }
Public Property WDWTRY As UShort
    Get
    Set
public:
property unsigned short WDWTRY {
    unsigned short get ();
    void set (unsigned short value);
}
member WDWTRY : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811 Methods

The Stmpe811 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.Flush Method

IRD

Stmpe811Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Stmpe811 Class
telos.Ird.ST Namespace


Stmpe811.AdcCtrl1Mod12b Enumeration

IRD

Stmpe811AdcCtrl1Mod12b Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AdcCtrl1Mod12b
Public Enumeration AdcCtrl1Mod12b
public enum class AdcCtrl1Mod12b
type AdcCtrl1Mod12b
Members
Member name | Value | Description
Value_12 | 1 | 12
Value_10 | 0 | 10
See Also

Reference

telos.Ird.ST Namespace


Stmpe811.AdcCtrl1RefSel Enumeration

IRD

Stmpe811AdcCtrl1RefSel Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AdcCtrl1RefSel
Public Enumeration AdcCtrl1RefSel
public enum class AdcCtrl1RefSel
type AdcCtrl1RefSel
Members
Member name | Value | Description
ExternalReference | 1 | External Reference
InternalReference | 0 | Internal Reference
See Also

Reference

telos.Ird.ST Namespace


Stmpe811.AdcCtrl1SampleTime Enumeration

IRD

Stmpe811AdcCtrl1SampleTime Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AdcCtrl1SampleTime
Public Enumeration AdcCtrl1SampleTime
public enum class AdcCtrl1SampleTime
type AdcCtrl1SampleTime
Members
Member name | Value | Description
Value_36 | 0 | 36
Value_44 | 1 | 44
Value_56 | 2 | 56
Value_64 | 3 | 64
Value_80 | 4 | 80
Value_96 | 5 | 96
Value_124 | 6 | 124
Reserved | 7 | Reserved
See Also

Reference

telos.Ird.ST Namespace


Stmpe811.AdcCtrl2AdcFreq Enumeration

IRD

Stmpe811AdcCtrl2AdcFreq Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum AdcCtrl2AdcFreq
Public Enumeration AdcCtrl2AdcFreq
public enum class AdcCtrl2AdcFreq
type AdcCtrl2AdcFreq
Members
Member name | Value | Description
Value_1_625 | 0 | 1.625
Value_3_25 | 1 | 3.25
Value_6_5 | 2 | 6.5
See Also

Reference

telos.Ird.ST Namespace


Stmpe811.IntCtrlGlobalInt Enumeration

IRD

Stmpe811IntCtrlGlobalInt Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IntCtrlGlobalInt
Public Enumeration IntCtrlGlobalInt
public enum class IntCtrlGlobalInt
type IntCtrlGlobalInt
Members
Member name | Value | Description
GlobalInterrupt | 1 | Global Interrupt
StopsAllInterrupts | 0 | Stops All Interrupts
See Also

Reference

telos.Ird.ST Namespace


Stmpe811.IntCtrlPolarity Enumeration

IRD

Stmpe811IntCtrlPolarity Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IntCtrlPolarity
Public Enumeration IntCtrlPolarity
public enum class IntCtrlPolarity
type IntCtrlPolarity
Members
Member name | Value | Description
ActiveHighRisingEdge | 1 | Active High/Rising Edge
ActiveLowFallingEdge | 0 | Active Low/Falling Edge
See Also

Reference

telos.Ird.ST Namespace


Stmpe811.IntCtrlType Enumeration

IRD

Stmpe811IntCtrlType Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IntCtrlType
Public Enumeration IntCtrlType
public enum class IntCtrlType
type IntCtrlType
Members
Member name | Value | Description
EdgeInterrupt | 1 | Edge Interrupt
LevelInterrupt | 0 | Level Interrupt
See Also

Reference

telos.Ird.ST Namespace


Stmpe811.TscCfgAveCtrl Enumeration

IRD

Stmpe811TscCfgAveCtrl Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TscCfgAveCtrl
Public Enumeration TscCfgAveCtrl
public enum class TscCfgAveCtrl
type TscCfgAveCtrl
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_2 | 1 | 2
Value_4 | 2 | 4
Value_8 | 3 | 8
See Also

Reference

telos.Ird.ST Namespace


Stmpe811.TscCfgSettling Enumeration

IRD

Stmpe811TscCfgSettling Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TscCfgSettling
Public Enumeration TscCfgSettling
public enum class TscCfgSettling
type TscCfgSettling
Members
Member name | Value | Description
Value_10Us | 0 | 10 µs
Value_100Us | 1 | 100 µs
Value_500Us | 2 | 500 µs
Value_1Ms | 3 | 1 ms
Value_5Ms | 4 | 5 ms
Value_10Ms | 5 | 10 ms
Value_50Ms | 6 | 50 ms
Value_100Ms | 7 | 100 ms
See Also

Reference

telos.Ird.ST Namespace


Stmpe811.TscCfgTouchDetDelay Enumeration

IRD

Stmpe811TscCfgTouchDetDelay Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TscCfgTouchDetDelay
Public Enumeration TscCfgTouchDetDelay
public enum class TscCfgTouchDetDelay
type TscCfgTouchDetDelay
Members
Member name | Value | Description
Value_10Us | 0 | 10 µs
Value_50Us | 1 | 50 µs
Value_100Us | 2 | 100 µs
Value_500Us | 3 | 500 µs
Value_1Ms | 4 | 1 ms
Value_5Ms | 5 | 5 ms
Value_10Ms | 6 | 10 ms
Value_50Ms | 7 | 50 ms
See Also

Reference

telos.Ird.ST Namespace


Stmpe811.TscCtrlOpMod Enumeration

IRD

Stmpe811TscCtrlOpMod Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TscCtrlOpMod
Public Enumeration TscCtrlOpMod
public enum class TscCtrlOpMod
type TscCtrlOpMod
Members
Member name | Value | Description
XYZ | 0 | X, Y, Z
XY | 1 | X, Y
X | 2 | X
Y | 3 | Y
Z | 4 | Z
Reserved | 5 | Reserved
See Also

Reference

telos.Ird.ST Namespace


Stmpe811.TscCtrlSta Enumeration

IRD

Stmpe811TscCtrlSta Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TscCtrlSta
Public Enumeration TscCtrlSta
public enum class TscCtrlSta
type TscCtrlSta
Members
Member name | Value | Description
Detected | 1 | Detected
NotDetected | 0 | Not Detected
See Also

Reference

telos.Ird.ST Namespace


Stmpe811.TscCtrlTrack Enumeration

IRD

Stmpe811TscCtrlTrack Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TscCtrlTrack
Public Enumeration TscCtrlTrack
public enum class TscCtrlTrack
type TscCtrlTrack
Members
Member name | Value | Description
NoWindowTracking | 0 | No Window Tracking
Value_4 | 1 | 4
Value_8 | 2 | 8
Value_16 | 3 | 16
Value_32 | 4 | 32
Value_64 | 5 | 64
Value_92 | 6 | 92
Value_127 | 7 | 127
See Also

Reference

telos.Ird.ST Namespace


Stmpe811.TscIDrive Enumeration

IRD

Stmpe811TscIDrive Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TscIDrive
Public Enumeration TscIDrive
public enum class TscIDrive
type TscIDrive
Members
Member name | Value | Description
Value_20MATypical35MAMax | 0 | 20 mA Typical, 35 mA Max
Value_50MATypical80MAMax | 1 | 50 mA Typical, 80 mA Max
See Also

Reference

telos.Ird.ST Namespace


Stmpe821 Class

ST: STMPE 821
Inheritance Hierarchy
SystemObject
telos.Ird.STStmpe821

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Stmpe821
Public Class Stmpe821
public ref class Stmpe821
type Stmpe821 =  class end

The Stmpe821 type exposes the following members.

Constructors
 | Name | Description
Public method | Stmpe821 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CALIBRATEDIMPEDANCE0 | CALIBRATED_IMPEDANCE 0
Public property | CALIBRATEDIMPEDANCE1 | CALIBRATED_IMPEDANCE 1
Public property | CALIBRATEDIMPEDANCE2 | CALIBRATED_IMPEDANCE 2
Public property | CALIBRATEDIMPEDANCE3 | CALIBRATED_IMPEDANCE 3
Public property | CALIBRATEDIMPEDANCE4 | CALIBRATED_IMPEDANCE 4
Public property | CALIBRATEDIMPEDANCE5 | CALIBRATED_IMPEDANCE 5
Public property | CALIBRATEDIMPEDANCE6 | CALIBRATED_IMPEDANCE 6
Public property | CALIBRATEDIMPEDANCE7 | CALIBRATED_IMPEDANCE 7
Public property | CALINTERVAL | CAL_INTERVAL
Public property | CHIPID0 | CHIP_ID_0
Public property | CHIPID1 | CHIP_ID_1
Public property | CTRLF2A | CTRL: F2A
Public property | CTRLHDCC | CTRL: HDC_C
Public property | CTRLHDCU | CTRL: HDC_U
Public property | CTRLHOLD | CTRL: HOLD
Public property | ETCWAIT | ETC_WAIT
Public property | EVR | EVR
Public property | FEATURESELECTAFS | FEATURE_SELECT: AFS
Public property | FEATURESELECTFilterEN | FEATURE_SELECT: Filter EN
Public property | FIFO0 | FIFO-0
Public property | FIFO1 | FIFO-1
Public property | FIFO2 | FIFO-2
Public property | FIFO3 | FIFO-3
Public property | FILTERPERIOD | FILTER_PERIOD
Public property | FILTERTHRESHOLD | FILTER_THRESHOLD
Public property | GPIODIRIO0 | GPIO_DIR: IO-0
Public property | GPIODIRIO1 | GPIO_DIR: IO-1
Public property | GPIODIRIO2 | GPIO_DIR: IO-2
Public property | GPIODIRIO3 | GPIO_DIR: IO-3
Public property | GPIODIRIO4 | GPIO_DIR: IO-4
Public property | GPIODIRIO5 | GPIO_DIR: IO-5
Public property | GPIODIRIO6 | GPIO_DIR: IO-6
Public property | GPIODIRIO7 | GPIO_DIR: IO-7
Public property | GPIOFUNCTIO0 | GPIO_FUNCT: IO-0
Public property | GPIOFUNCTIO1 | GPIO_FUNCT: IO-1
Public property | GPIOFUNCTIO2 | GPIO_FUNCT: IO-2
Public property | GPIOFUNCTIO3 | GPIO_FUNCT: IO-3
Public property | GPIOFUNCTIO4 | GPIO_FUNCT: IO-4
Public property | GPIOFUNCTIO5 | GPIO_FUNCT: IO-5
Public property | GPIOFUNCTIO6 | GPIO_FUNCT: IO-6
Public property | GPIOFUNCTIO7 | GPIO_FUNCT: IO-7
Public property | GPIOINTENIO0 | GPIO_INT_EN: IO-0
Public property | GPIOINTENIO1 | GPIO_INT_EN: IO-1
Public property | GPIOINTENIO2 | GPIO_INT_EN: IO-2
Public property | GPIOINTENIO3 | GPIO_INT_EN: IO-3
Public property | GPIOINTENIO4 | GPIO_INT_EN: IO-4
Public property | GPIOINTENIO5 | GPIO_INT_EN: IO-5
Public property | GPIOINTENIO6 | GPIO_INT_EN: IO-6
Public property | GPIOINTENIO7 | GPIO_INT_EN: IO-7
Public property | GPIOINTSTAIO0 | GPIO_INT_STA: IO-0
Public property | GPIOINTSTAIO1 | GPIO_INT_STA: IO-1
Public property | GPIOINTSTAIO2 | GPIO_INT_STA: IO-2
Public property | GPIOINTSTAIO3 | GPIO_INT_STA: IO-3
Public property | GPIOINTSTAIO4 | GPIO_INT_STA: IO-4
Public property | GPIOINTSTAIO5 | GPIO_INT_STA: IO-5
Public property | GPIOINTSTAIO6 | GPIO_INT_STA: IO-6
Public property | GPIOINTSTAIO7 | GPIO_INT_STA: IO-7
Public property | GPIOMRIO0 | GPIO_MR: IO-0
Public property | GPIOMRIO1 | GPIO_MR: IO-1
Public property | GPIOMRIO2 | GPIO_MR: IO-2
Public property | GPIOMRIO3 | GPIO_MR: IO-3
Public property | GPIOMRIO4 | GPIO_MR: IO-4
Public property | GPIOMRIO5 | GPIO_MR: IO-5
Public property | GPIOMRIO6 | GPIO_MR: IO-6
Public property | GPIOMRIO7 | GPIO_MR: IO-7
Public property | GPIOSETIO0 | GPIO_SET: IO-0
Public property | GPIOSETIO1 | GPIO_SET: IO-1
Public property | GPIOSETIO2 | GPIO_SET: IO-2
Public property | GPIOSETIO3 | GPIO_SET: IO-3
Public property | GPIOSETIO4 | GPIO_SET: IO-4
Public property | GPIOSETIO5 | GPIO_SET: IO-5
Public property | GPIOSETIO6 | GPIO_SET: IO-6
Public property | GPIOSETIO7 | GPIO_SET: IO-7
Public property | IDVER | ID_VER
Public property | IMPEDANCE0 | IMPEDANCE 0
Public property | IMPEDANCE1 | IMPEDANCE 1
Public property | IMPEDANCE2 | IMPEDANCE 2
Public property | IMPEDANCE3 | IMPEDANCE 3
Public property | IMPEDANCE4 | IMPEDANCE 4
Public property | IMPEDANCE5 | IMPEDANCE 5
Public property | IMPEDANCE6 | IMPEDANCE 6
Public property | IMPEDANCE7 | IMPEDANCE 7
Public property | INTCLREOC | INT_CLR: EOC
Public property | INTCTRLINTEN | INT_CTRL: INT_EN
Public property | INTCTRLPOLARITY | INT_CTRL: POLARITY
Public property | INTCTRLTYPE | INT_CTRL: TYPE
Public property | INTEGRATIONTIME | INTEGRATION_TIME
Public property | INTENFIFO | INT_EN: FIFO
Public property | INTENGEN | INT_EN: GEN
Public property | INTENGPIO | INT_EN: GPIO
Public property | INTENPOR | INT_EN: POR
Public property | INTENPWM0 | INT_EN: PWM0
Public property | INTENPWM1 | INT_EN: PWM1
Public property | INTENPWM2 | INT_EN: PWM2
Public property | INTENPWM3 | INT_EN: PWM3
Public property | INTMASKEOC | INT_MASK: EOC
Public property | INTSTAFIFO | INT_STA: FIFO
Public property | INTSTAGEN | INT_STA: GEN
Public property | INTSTAGPIO | INT_STA: GPIO
Public property | INTSTAPOR | INT_STA: POR
Public property | INTSTAPWM0 | INT_STA: PWM0
Public property | INTSTAPWM1 | INT_STA: PWM1
Public property | INTSTAPWM2 | INT_STA: PWM2
Public property | INTSTAPWM3 | INT_STA: PWM3
Public property | MASTERENEN0 | MASTER_EN: EN0
Public property | MASTERENEN1 | MASTER_EN: EN1
Public property | MASTERENEN2 | MASTER_EN: EN2
Public property | MASTERENEN3 | MASTER_EN: EN3
Public property | PWM0RAMPRATERAMPDOWN | PWM_0_RAMP_RATE: RAMP_DOWN
Public property | PWM0RAMPRATERAMPUP | PWM_0_RAMP_RATE: RAMP_UP
Public property | PWM0SETUPBRIGHTNESS | PWM_0_SETUP: BRIGHTNESS
Public property | PWM0SETUPRAMPMODE | PWM_0_SETUP: RAMP_MODE
Public property | PWM0SETUPTIMING | PWM_0_SETUP: TIMING (unit: mS)
Public property | PWM1RAMPRATERAMPDOWN | PWM_1_RAMP_RATE: RAMP_DOWN
Public property | PWM1RAMPRATERAMPUP | PWM_1_RAMP_RATE: RAMP_UP
Public property | PWM1SETUPBRIGHTNESS | PWM_1_SETUP: BRIGHTNESS
Public property | PWM1SETUPRAMPMODE | PWM_1_SETUP: RAMP_MODE
Public property | PWM1SETUPTIMING | PWM_1_SETUP: TIMING (unit: mS)
Public property | PWM2RAMPRATERAMPDOWN | PWM_2_RAMP_RATE: RAMP_DOWN
Public property | PWM2RAMPRATERAMPUP | PWM_2_RAMP_RATE: RAMP_UP
Public property | PWM2SETUPBRIGHTNESS | PWM_2_SETUP: BRIGHTNESS
Public property | PWM2SETUPRAMPMODE | PWM_2_SETUP: RAMP_MODE
Public property | PWM2SETUPTIMING | PWM_2_SETUP: TIMING (unit: mS)
Public property | PWM3RAMPRATERAMPDOWN | PWM_3_RAMP_RATE: RAMP_DOWN
Public property | PWM3RAMPRATERAMPUP | PWM_3_RAMP_RATE: RAMP_UP
Public property | PWM3SETUPBRIGHTNESS | PWM_3_SETUP: BRIGHTNESS
Public property | PWM3SETUPRAMPMODE | PWM_3_SETUP: RAMP_MODE
Public property | PWM3SETUPTIMING | PWM_3_SETUP: TIMING (unit: mS)
Public property | PWMCTRL0FRAMEORDER | PWM_CTRL_0: FRAME_ORDER
Public property | PWMCTRL0PERIOD0 | PWM_CTRL_0: PERIOD_0
Public property | PWMCTRL0PERIOD1 | PWM_CTRL_0: PERIOD_1
Public property | PWMCTRL0REPETITION | PWM_CTRL_0: REPETITION
Public property | PWMCTRL1FRAMEORDER | PWM_CTRL_1: FRAME_ORDER
Public property | PWMCTRL1PERIOD0 | PWM_CTRL_1: PERIOD_0
Public property | PWMCTRL1PERIOD1 | PWM_CTRL_1: PERIOD_1
Public property | PWMCTRL1REPETITION | PWM_CTRL_1: REPETITION
Public property | PWMCTRL2FRAMEORDER | PWM_CTRL_2: FRAME_ORDER
Public property | PWMCTRL2PERIOD0 | PWM_CTRL_2: PERIOD_0
Public property | PWMCTRL2PERIOD1 | PWM_CTRL_2: PERIOD_1
Public property | PWMCTRL2REPETITION | PWM_CTRL_2: REPETITION
Public property | PWMCTRL3FRAMEORDER | PWM_CTRL_3: FRAME_ORDER
Public property | PWMCTRL3PERIOD0 | PWM_CTRL_3: PERIOD_0
Public property | PWMCTRL3PERIOD1 | PWM_CTRL_3: PERIOD_1
Public property | PWMCTRL3REPETITION | PWM_CTRL_3: REPETITION
Public property | PWMOFFOUTPUTOUT0 | PWM_OFF_OUTPUT: OUT0
Public property | PWMOFFOUTPUTOUT1 | PWM_OFF_OUTPUT: OUT1
Public property | PWMOFFOUTPUTOUT2 | PWM_OFF_OUTPUT: OUT2
Public property | PWMOFFOUTPUTOUT3 | PWM_OFF_OUTPUT: OUT3
Public property | REFERENCEDELAY | REFERENCE_DELAY
Public property | STRENGTH0 | STRENGTH 0
Public property | STRENGTH1 | STRENGTH 1
Public property | STRENGTH2 | STRENGTH 2
Public property | STRENGTH3 | STRENGTH 3
Public property | STRENGTH4 | STRENGTH 4
Public property | STRENGTH5 | STRENGTH 5
Public property | STRENGTH6 | STRENGTH 6
Public property | STRENGTH7 | STRENGTH 7
Public property | STRENGTHTHRESHOLD0 | STRENGTH_THRESHOLD 0
Public property | STRENGTHTHRESHOLD1 | STRENGTH_THRESHOLD 1
Public property | STRENGTHTHRESHOLD2 | STRENGTH_THRESHOLD 2
Public property | STRENGTHTHRESHOLD3 | STRENGTH_THRESHOLD 3
Public property | STRENGTHTHRESHOLD4 | STRENGTH_THRESHOLD 4
Public property | STRENGTHTHRESHOLD5 | STRENGTH_THRESHOLD 5
Public property | STRENGTHTHRESHOLD6 | STRENGTH_THRESHOLD 6
Public property | STRENGTHTHRESHOLD7 | STRENGTH_THRESHOLD 7
Public property | SYSCFG1HIBERNATE | SYS_CFG_1: HIBERNATE
Public property | SYSCFG1SLEEP | SYS_CFG_1: SLEEP
Public property | SYSCFG1SOFTRESET | SYS_CFG_1: SOFT_RESET
Public property | SYSCFG1WARMRESET | SYS_CFG_1: WARM_RESET
Public property | SYSCFG2FIFOCLOCKDISABLE | SYS_CFG_2: FIFO_CLOCK_DISABLE
Public property | SYSCFG2GPIOCLOCKDISABLE | SYS_CFG_2: GPIO CLOCK DISABLE
Public property | SYSCFG2PWMCLOCKDISABLE | SYS_CFG_2: PWM CLOCK DISABLE
Public property | SYSCFG2SENSORCLOCK | SYS_CFG_2: SENSOR_CLOCK
Public property | SYSCFG2TOUCHCLOCKDISABLE | SYS_CFG_2: TOUCH CLOCK DISABLE
Public property | TINTPENDINGEOC | TINT_PENDING: EOC
Public property | TVR0 | TVR 0
Public property | TVR1 | TVR 1
Public property | TVR2 | TVR 2
Public property | TVR3 | TVR 3
Public property | TVR4 | TVR 4
Public property | TVR5 | TVR 5
Public property | TVR6 | TVR 6
Public property | TVR7 | TVR 7
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
8-Channel Capacitive Touch Key Controller
See Also

Reference

telos.Ird.ST Namespace


Stmpe821 Constructor

Constructor

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Stmpe821(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Stmpe821

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821 Properties

The Stmpe821 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CALIBRATEDIMPEDANCE0 | CALIBRATED_IMPEDANCE 0
Public property | CALIBRATEDIMPEDANCE1 | CALIBRATED_IMPEDANCE 1
Public property | CALIBRATEDIMPEDANCE2 | CALIBRATED_IMPEDANCE 2
Public property | CALIBRATEDIMPEDANCE3 | CALIBRATED_IMPEDANCE 3
Public property | CALIBRATEDIMPEDANCE4 | CALIBRATED_IMPEDANCE 4
Public property | CALIBRATEDIMPEDANCE5 | CALIBRATED_IMPEDANCE 5
Public property | CALIBRATEDIMPEDANCE6 | CALIBRATED_IMPEDANCE 6
Public property | CALIBRATEDIMPEDANCE7 | CALIBRATED_IMPEDANCE 7
Public property | CALINTERVAL | CAL_INTERVAL
Public property | CHIPID0 | CHIP_ID_0
Public property | CHIPID1 | CHIP_ID_1
Public property | CTRLF2A | CTRL: F2A
Public property | CTRLHDCC | CTRL: HDC_C
Public property | CTRLHDCU | CTRL: HDC_U
Public property | CTRLHOLD | CTRL: HOLD
Public property | ETCWAIT | ETC_WAIT
Public property | EVR | EVR
Public property | FEATURESELECTAFS | FEATURE_SELECT: AFS
Public property | FEATURESELECTFilterEN | FEATURE_SELECT: Filter EN
Public property | FIFO0 | FIFO-0
Public property | FIFO1 | FIFO-1
Public property | FIFO2 | FIFO-2
Public property | FIFO3 | FIFO-3
Public property | FILTERPERIOD | FILTER_PERIOD
Public property | FILTERTHRESHOLD | FILTER_THRESHOLD
Public property | GPIODIRIO0 | GPIO_DIR: IO-0
Public property | GPIODIRIO1 | GPIO_DIR: IO-1
Public property | GPIODIRIO2 | GPIO_DIR: IO-2
Public property | GPIODIRIO3 | GPIO_DIR: IO-3
Public property | GPIODIRIO4 | GPIO_DIR: IO-4
Public property | GPIODIRIO5 | GPIO_DIR: IO-5
Public property | GPIODIRIO6 | GPIO_DIR: IO-6
Public property | GPIODIRIO7 | GPIO_DIR: IO-7
Public property | GPIOFUNCTIO0 | GPIO_FUNCT: IO-0
Public property | GPIOFUNCTIO1 | GPIO_FUNCT: IO-1
Public property | GPIOFUNCTIO2 | GPIO_FUNCT: IO-2
Public property | GPIOFUNCTIO3 | GPIO_FUNCT: IO-3
Public property | GPIOFUNCTIO4 | GPIO_FUNCT: IO-4
Public property | GPIOFUNCTIO5 | GPIO_FUNCT: IO-5
Public property | GPIOFUNCTIO6 | GPIO_FUNCT: IO-6
Public property | GPIOFUNCTIO7 | GPIO_FUNCT: IO-7
Public property | GPIOINTENIO0 | GPIO_INT_EN: IO-0
Public property | GPIOINTENIO1 | GPIO_INT_EN: IO-1
Public property | GPIOINTENIO2 | GPIO_INT_EN: IO-2
Public property | GPIOINTENIO3 | GPIO_INT_EN: IO-3
Public property | GPIOINTENIO4 | GPIO_INT_EN: IO-4
Public property | GPIOINTENIO5 | GPIO_INT_EN: IO-5
Public property | GPIOINTENIO6 | GPIO_INT_EN: IO-6
Public property | GPIOINTENIO7 | GPIO_INT_EN: IO-7
Public property | GPIOINTSTAIO0 | GPIO_INT_STA: IO-0
Public property | GPIOINTSTAIO1 | GPIO_INT_STA: IO-1
Public property | GPIOINTSTAIO2 | GPIO_INT_STA: IO-2
Public property | GPIOINTSTAIO3 | GPIO_INT_STA: IO-3
Public property | GPIOINTSTAIO4 | GPIO_INT_STA: IO-4
Public property | GPIOINTSTAIO5 | GPIO_INT_STA: IO-5
Public property | GPIOINTSTAIO6 | GPIO_INT_STA: IO-6
Public property | GPIOINTSTAIO7 | GPIO_INT_STA: IO-7
Public property | GPIOMRIO0 | GPIO_MR: IO-0
Public property | GPIOMRIO1 | GPIO_MR: IO-1
Public property | GPIOMRIO2 | GPIO_MR: IO-2
Public property | GPIOMRIO3 | GPIO_MR: IO-3
Public property | GPIOMRIO4 | GPIO_MR: IO-4
Public property | GPIOMRIO5 | GPIO_MR: IO-5
Public property | GPIOMRIO6 | GPIO_MR: IO-6
Public property | GPIOMRIO7 | GPIO_MR: IO-7
Public property | GPIOSETIO0 | GPIO_SET: IO-0
Public property | GPIOSETIO1 | GPIO_SET: IO-1
Public property | GPIOSETIO2 | GPIO_SET: IO-2
Public property | GPIOSETIO3 | GPIO_SET: IO-3
Public property | GPIOSETIO4 | GPIO_SET: IO-4
Public property | GPIOSETIO5 | GPIO_SET: IO-5
Public property | GPIOSETIO6 | GPIO_SET: IO-6
Public property | GPIOSETIO7 | GPIO_SET: IO-7
Public property | IDVER | ID_VER
Public property | IMPEDANCE0 | IMPEDANCE 0
Public property | IMPEDANCE1 | IMPEDANCE 1
Public property | IMPEDANCE2 | IMPEDANCE 2
Public property | IMPEDANCE3 | IMPEDANCE 3
Public property | IMPEDANCE4 | IMPEDANCE 4
Public property | IMPEDANCE5 | IMPEDANCE 5
Public property | IMPEDANCE6 | IMPEDANCE 6
Public property | IMPEDANCE7 | IMPEDANCE 7
Public property | INTCLREOC | INT_CLR: EOC
Public property | INTCTRLINTEN | INT_CTRL: INT_EN
Public property | INTCTRLPOLARITY | INT_CTRL: POLARITY
Public property | INTCTRLTYPE | INT_CTRL: TYPE
Public property | INTEGRATIONTIME | INTEGRATION_TIME
Public property | INTENFIFO | INT_EN: FIFO
Public property | INTENGEN | INT_EN: GEN
Public property | INTENGPIO | INT_EN: GPIO
Public property | INTENPOR | INT_EN: POR
Public property | INTENPWM0 | INT_EN: PWM0
Public property | INTENPWM1 | INT_EN: PWM1
Public property | INTENPWM2 | INT_EN: PWM2
Public property | INTENPWM3 | INT_EN: PWM3
Public property | INTMASKEOC | INT_MASK: EOC
Public property | INTSTAFIFO | INT_STA: FIFO
Public property | INTSTAGEN | INT_STA: GEN
Public property | INTSTAGPIO | INT_STA: GPIO
Public property | INTSTAPOR | INT_STA: POR
Public property | INTSTAPWM0 | INT_STA: PWM0
Public property | INTSTAPWM1 | INT_STA: PWM1
Public property | INTSTAPWM2 | INT_STA: PWM2
Public property | INTSTAPWM3 | INT_STA: PWM3
Public property | MASTERENEN0 | MASTER_EN: EN0
Public property | MASTERENEN1 | MASTER_EN: EN1
Public property | MASTERENEN2 | MASTER_EN: EN2
Public property | MASTERENEN3 | MASTER_EN: EN3
Public property | PWM0RAMPRATERAMPDOWN | PWM_0_RAMP_RATE: RAMP_DOWN
Public property | PWM0RAMPRATERAMPUP | PWM_0_RAMP_RATE: RAMP_UP
Public property | PWM0SETUPBRIGHTNESS | PWM_0_SETUP: BRIGHTNESS
Public property | PWM0SETUPRAMPMODE | PWM_0_SETUP: RAMP_MODE
Public property | PWM0SETUPTIMING | PWM_0_SETUP: TIMING (unit: mS)
Public property | PWM1RAMPRATERAMPDOWN | PWM_1_RAMP_RATE: RAMP_DOWN
Public property | PWM1RAMPRATERAMPUP | PWM_1_RAMP_RATE: RAMP_UP
Public property | PWM1SETUPBRIGHTNESS | PWM_1_SETUP: BRIGHTNESS
Public property | PWM1SETUPRAMPMODE | PWM_1_SETUP: RAMP_MODE
Public property | PWM1SETUPTIMING | PWM_1_SETUP: TIMING (unit: mS)
Public property | PWM2RAMPRATERAMPDOWN | PWM_2_RAMP_RATE: RAMP_DOWN
Public property | PWM2RAMPRATERAMPUP | PWM_2_RAMP_RATE: RAMP_UP
Public property | PWM2SETUPBRIGHTNESS | PWM_2_SETUP: BRIGHTNESS
Public property | PWM2SETUPRAMPMODE | PWM_2_SETUP: RAMP_MODE
Public property | PWM2SETUPTIMING | PWM_2_SETUP: TIMING (unit: mS)
Public property | PWM3RAMPRATERAMPDOWN | PWM_3_RAMP_RATE: RAMP_DOWN
Public property | PWM3RAMPRATERAMPUP | PWM_3_RAMP_RATE: RAMP_UP
Public property | PWM3SETUPBRIGHTNESS | PWM_3_SETUP: BRIGHTNESS
Public property | PWM3SETUPRAMPMODE | PWM_3_SETUP: RAMP_MODE
Public property | PWM3SETUPTIMING | PWM_3_SETUP: TIMING (unit: mS)
Public property | PWMCTRL0FRAMEORDER | PWM_CTRL_0: FRAME_ORDER
Public property | PWMCTRL0PERIOD0 | PWM_CTRL_0: PERIOD_0
Public property | PWMCTRL0PERIOD1 | PWM_CTRL_0: PERIOD_1
Public property | PWMCTRL0REPETITION | PWM_CTRL_0: REPETITION
Public property | PWMCTRL1FRAMEORDER | PWM_CTRL_1: FRAME_ORDER
Public property | PWMCTRL1PERIOD0 | PWM_CTRL_1: PERIOD_0
Public property | PWMCTRL1PERIOD1 | PWM_CTRL_1: PERIOD_1
Public property | PWMCTRL1REPETITION | PWM_CTRL_1: REPETITION
Public property | PWMCTRL2FRAMEORDER | PWM_CTRL_2: FRAME_ORDER
Public property | PWMCTRL2PERIOD0 | PWM_CTRL_2: PERIOD_0
Public property | PWMCTRL2PERIOD1 | PWM_CTRL_2: PERIOD_1
Public property | PWMCTRL2REPETITION | PWM_CTRL_2: REPETITION
Public property | PWMCTRL3FRAMEORDER | PWM_CTRL_3: FRAME_ORDER
Public property | PWMCTRL3PERIOD0 | PWM_CTRL_3: PERIOD_0
Public property | PWMCTRL3PERIOD1 | PWM_CTRL_3: PERIOD_1
Public property | PWMCTRL3REPETITION | PWM_CTRL_3: REPETITION
Public property | PWMOFFOUTPUTOUT0 | PWM_OFF_OUTPUT: OUT0
Public property | PWMOFFOUTPUTOUT1 | PWM_OFF_OUTPUT: OUT1
Public property | PWMOFFOUTPUTOUT2 | PWM_OFF_OUTPUT: OUT2
Public property | PWMOFFOUTPUTOUT3 | PWM_OFF_OUTPUT: OUT3
Public property | REFERENCEDELAY | REFERENCE_DELAY
Public property | STRENGTH0 | STRENGTH 0
Public property | STRENGTH1 | STRENGTH 1
Public property | STRENGTH2 | STRENGTH 2
Public property | STRENGTH3 | STRENGTH 3
Public property | STRENGTH4 | STRENGTH 4
Public property | STRENGTH5 | STRENGTH 5
Public property | STRENGTH6 | STRENGTH 6
Public property | STRENGTH7 | STRENGTH 7
Public property | STRENGTHTHRESHOLD0 | STRENGTH_THRESHOLD 0
Public property | STRENGTHTHRESHOLD1 | STRENGTH_THRESHOLD 1
Public property | STRENGTHTHRESHOLD2 | STRENGTH_THRESHOLD 2
Public property | STRENGTHTHRESHOLD3 | STRENGTH_THRESHOLD 3
Public property | STRENGTHTHRESHOLD4 | STRENGTH_THRESHOLD 4
Public property | STRENGTHTHRESHOLD5 | STRENGTH_THRESHOLD 5
Public property | STRENGTHTHRESHOLD6 | STRENGTH_THRESHOLD 6
Public property | STRENGTHTHRESHOLD7 | STRENGTH_THRESHOLD 7
Public property | SYSCFG1HIBERNATE | SYS_CFG_1: HIBERNATE
Public property | SYSCFG1SLEEP | SYS_CFG_1: SLEEP
Public property | SYSCFG1SOFTRESET | SYS_CFG_1: SOFT_RESET
Public property | SYSCFG1WARMRESET | SYS_CFG_1: WARM_RESET
Public property | SYSCFG2FIFOCLOCKDISABLE | SYS_CFG_2: FIFO_CLOCK_DISABLE
Public property | SYSCFG2GPIOCLOCKDISABLE | SYS_CFG_2: GPIO CLOCK DISABLE
Public property | SYSCFG2PWMCLOCKDISABLE | SYS_CFG_2: PWM CLOCK DISABLE
Public property | SYSCFG2SENSORCLOCK | SYS_CFG_2: SENSOR_CLOCK
Public property | SYSCFG2TOUCHCLOCKDISABLE | SYS_CFG_2: TOUCH CLOCK DISABLE
Public property | TINTPENDINGEOC | TINT_PENDING: EOC
Public property | TVR0 | TVR 0
Public property | TVR1 | TVR 1
Public property | TVR2 | TVR 2
Public property | TVR3 | TVR 3
Public property | TVR4 | TVR 4
Public property | TVR5 | TVR 5
Public property | TVR6 | TVR 6
Public property | TVR7 | TVR 7
Top
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.AutoFlush Property

IRD

Stmpe821AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.CALIBRATEDIMPEDANCE0 Property

IRD

Stmpe821CALIBRATEDIMPEDANCE0 Property

CALIBRATED_IMPEDANCE 0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CALIBRATEDIMPEDANCE0 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE0 As Byte
    Get
public:
property unsigned char CALIBRATEDIMPEDANCE0 {
    unsigned char get ();
}
member CALIBRATEDIMPEDANCE0 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.CALIBRATEDIMPEDANCE1 Property

IRD

Stmpe821CALIBRATEDIMPEDANCE1 Property

CALIBRATED_IMPEDANCE 1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CALIBRATEDIMPEDANCE1 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE1 As Byte
    Get
public:
property unsigned char CALIBRATEDIMPEDANCE1 {
    unsigned char get ();
}
member CALIBRATEDIMPEDANCE1 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.CALIBRATEDIMPEDANCE2 Property

IRD

Stmpe821CALIBRATEDIMPEDANCE2 Property

CALIBRATED_IMPEDANCE 2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CALIBRATEDIMPEDANCE2 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE2 As Byte
    Get
public:
property unsigned char CALIBRATEDIMPEDANCE2 {
    unsigned char get ();
}
member CALIBRATEDIMPEDANCE2 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.CALIBRATEDIMPEDANCE3 Property

IRD

Stmpe821CALIBRATEDIMPEDANCE3 Property

CALIBRATED_IMPEDANCE 3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CALIBRATEDIMPEDANCE3 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE3 As Byte
    Get
public:
property unsigned char CALIBRATEDIMPEDANCE3 {
    unsigned char get ();
}
member CALIBRATEDIMPEDANCE3 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.CALIBRATEDIMPEDANCE4 Property

IRD

Stmpe821CALIBRATEDIMPEDANCE4 Property

CALIBRATED_IMPEDANCE 4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CALIBRATEDIMPEDANCE4 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE4 As Byte
    Get
public:
property unsigned char CALIBRATEDIMPEDANCE4 {
    unsigned char get ();
}
member CALIBRATEDIMPEDANCE4 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.CALIBRATEDIMPEDANCE5 Property

IRD

Stmpe821CALIBRATEDIMPEDANCE5 Property

CALIBRATED_IMPEDANCE 5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CALIBRATEDIMPEDANCE5 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE5 As Byte
    Get
public:
property unsigned char CALIBRATEDIMPEDANCE5 {
    unsigned char get ();
}
member CALIBRATEDIMPEDANCE5 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.CALIBRATEDIMPEDANCE6 Property

IRD

Stmpe821CALIBRATEDIMPEDANCE6 Property

CALIBRATED_IMPEDANCE 6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CALIBRATEDIMPEDANCE6 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE6 As Byte
    Get
public:
property unsigned char CALIBRATEDIMPEDANCE6 {
    unsigned char get ();
}
member CALIBRATEDIMPEDANCE6 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.CALIBRATEDIMPEDANCE7 Property

IRD

Stmpe821CALIBRATEDIMPEDANCE7 Property

CALIBRATED_IMPEDANCE 7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CALIBRATEDIMPEDANCE7 { get; }
Public ReadOnly Property CALIBRATEDIMPEDANCE7 As Byte
    Get
public:
property unsigned char CALIBRATEDIMPEDANCE7 {
    unsigned char get ();
}
member CALIBRATEDIMPEDANCE7 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.CALINTERVAL Property

IRD

Stmpe821CALINTERVAL Property

CAL_INTERVAL

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CALINTERVAL { get; set; }
Public Property CALINTERVAL As Byte
    Get
    Set
public:
property unsigned char CALINTERVAL {
    unsigned char get ();
    void set (unsigned char value);
}
member CALINTERVAL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.CHIPID0 Property

IRD

Stmpe821CHIPID0 Property

CHIP_ID_0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CHIPID0 { get; }
Public ReadOnly Property CHIPID0 As Byte
    Get
public:
property unsigned char CHIPID0 {
    unsigned char get ();
}
member CHIPID0 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.CHIPID1 Property

IRD

Stmpe821CHIPID1 Property

CHIP_ID_1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CHIPID1 { get; }
Public ReadOnly Property CHIPID1 As Byte
    Get
public:
property unsigned char CHIPID1 {
    unsigned char get ();
}
member CHIPID1 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.CTRLF2A Property

IRD

Stmpe821CTRLF2A Property

CTRL: F2A

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CTRLF2A { get; set; }
Public Property CTRLF2A As Byte
    Get
    Set
public:
property unsigned char CTRLF2A {
    unsigned char get ();
    void set (unsigned char value);
}
member CTRLF2A : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.CTRLHDCC Property

IRD

Stmpe821CTRLHDCC Property

CTRL: HDC_C

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CTRLHDCC { get; set; }
Public Property CTRLHDCC As Byte
    Get
    Set
public:
property unsigned char CTRLHDCC {
    unsigned char get ();
    void set (unsigned char value);
}
member CTRLHDCC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.CTRLHDCU Property

IRD

Stmpe821CTRLHDCU Property

CTRL: HDC_U

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CTRLHDCU { get; set; }
Public Property CTRLHDCU As Byte
    Get
    Set
public:
property unsigned char CTRLHDCU {
    unsigned char get ();
    void set (unsigned char value);
}
member CTRLHDCU : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.CTRLHOLD Property

IRD

Stmpe821CTRLHOLD Property

CTRL: HOLD

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CTRLHOLD { get; set; }
Public Property CTRLHOLD As Byte
    Get
    Set
public:
property unsigned char CTRLHOLD {
    unsigned char get ();
    void set (unsigned char value);
}
member CTRLHOLD : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.ETCWAIT Property

IRD

Stmpe821ETCWAIT Property

ETC_WAIT

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ETCWAIT { get; set; }
Public Property ETCWAIT As Byte
    Get
    Set
public:
property unsigned char ETCWAIT {
    unsigned char get ();
    void set (unsigned char value);
}
member ETCWAIT : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.EVR Property

IRD

Stmpe821EVR Property

EVR

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte EVR { get; set; }
Public Property EVR As Byte
    Get
    Set
public:
property unsigned char EVR {
    unsigned char get ();
    void set (unsigned char value);
}
member EVR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.FEATURESELECTAFS Property

IRD

Stmpe821FEATURESELECTAFS Property

FEATURE_SELECT: AFS

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821FeatureSelAfs FEATURESELECTAFS { get; set; }
Public Property FEATURESELECTAFS As Stmpe821FeatureSelAfs
    Get
    Set
public:
property Stmpe821FeatureSelAfs FEATURESELECTAFS {
    Stmpe821FeatureSelAfs get ();
    void set (Stmpe821FeatureSelAfs value);
}
member FEATURESELECTAFS : Stmpe821FeatureSelAfs with get, set

Property Value

Type: Stmpe821FeatureSelAfs
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.FEATURESELECTFilterEN Property

IRD

Stmpe821FEATURESELECTFilterEN Property

FEATURE_SELECT: Filter EN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FEATURESELECTFilterEN { get; set; }
Public Property FEATURESELECTFilterEN As Byte
    Get
    Set
public:
property unsigned char FEATURESELECTFilterEN {
    unsigned char get ();
    void set (unsigned char value);
}
member FEATURESELECTFilterEN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.FIFO0 Property

IRD

Stmpe821FIFO0 Property

FIFO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort FIFO0 { get; }
Public ReadOnly Property FIFO0 As UShort
    Get
public:
property unsigned short FIFO0 {
    unsigned short get ();
}
member FIFO0 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.FIFO1 Property

IRD

Stmpe821FIFO1 Property

FIFO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort FIFO1 { get; }
Public ReadOnly Property FIFO1 As UShort
    Get
public:
property unsigned short FIFO1 {
    unsigned short get ();
}
member FIFO1 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.FIFO2 Property

IRD

Stmpe821FIFO2 Property

FIFO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort FIFO2 { get; }
Public ReadOnly Property FIFO2 As UShort
    Get
public:
property unsigned short FIFO2 {
    unsigned short get ();
}
member FIFO2 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.FIFO3 Property

IRD

Stmpe821FIFO3 Property

FIFO-3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort FIFO3 { get; }
Public ReadOnly Property FIFO3 As UShort
    Get
public:
property unsigned short FIFO3 {
    unsigned short get ();
}
member FIFO3 : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.FILTERPERIOD Property

IRD

Stmpe821FILTERPERIOD Property

FILTER_PERIOD

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FILTERPERIOD { get; set; }
Public Property FILTERPERIOD As Byte
    Get
    Set
public:
property unsigned char FILTERPERIOD {
    unsigned char get ();
    void set (unsigned char value);
}
member FILTERPERIOD : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.FILTERTHRESHOLD Property

IRD

Stmpe821FILTERTHRESHOLD Property

FILTER_THRESHOLD

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte FILTERTHRESHOLD { get; set; }
Public Property FILTERTHRESHOLD As Byte
    Get
    Set
public:
property unsigned char FILTERTHRESHOLD {
    unsigned char get ();
    void set (unsigned char value);
}
member FILTERTHRESHOLD : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIODIRIO0 Property

IRD

Stmpe821GPIODIRIO0 Property

GPIO_DIR: IO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821GpioDir GPIODIRIO0 { get; set; }
Public Property GPIODIRIO0 As Stmpe821GpioDir
    Get
    Set
public:
property Stmpe821GpioDir GPIODIRIO0 {
    Stmpe821GpioDir get ();
    void set (Stmpe821GpioDir value);
}
member GPIODIRIO0 : Stmpe821GpioDir with get, set

Property Value

Type: Stmpe821GpioDir
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIODIRIO1 Property

IRD

Stmpe821GPIODIRIO1 Property

GPIO_DIR: IO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821GpioDir GPIODIRIO1 { get; set; }
Public Property GPIODIRIO1 As Stmpe821GpioDir
    Get
    Set
public:
property Stmpe821GpioDir GPIODIRIO1 {
    Stmpe821GpioDir get ();
    void set (Stmpe821GpioDir value);
}
member GPIODIRIO1 : Stmpe821GpioDir with get, set

Property Value

Type: Stmpe821GpioDir
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIODIRIO2 Property

IRD

Stmpe821GPIODIRIO2 Property

GPIO_DIR: IO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821GpioDir GPIODIRIO2 { get; set; }
Public Property GPIODIRIO2 As Stmpe821GpioDir
    Get
    Set
public:
property Stmpe821GpioDir GPIODIRIO2 {
    Stmpe821GpioDir get ();
    void set (Stmpe821GpioDir value);
}
member GPIODIRIO2 : Stmpe821GpioDir with get, set

Property Value

Type: Stmpe821GpioDir
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIODIRIO3 Property

IRD

Stmpe821GPIODIRIO3 Property

GPIO_DIR: IO-3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821GpioDir GPIODIRIO3 { get; set; }
Public Property GPIODIRIO3 As Stmpe821GpioDir
    Get
    Set
public:
property Stmpe821GpioDir GPIODIRIO3 {
    Stmpe821GpioDir get ();
    void set (Stmpe821GpioDir value);
}
member GPIODIRIO3 : Stmpe821GpioDir with get, set

Property Value

Type: Stmpe821GpioDir
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIODIRIO4 Property

IRD

Stmpe821GPIODIRIO4 Property

GPIO_DIR: IO-4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821GpioDir GPIODIRIO4 { get; set; }
Public Property GPIODIRIO4 As Stmpe821GpioDir
    Get
    Set
public:
property Stmpe821GpioDir GPIODIRIO4 {
    Stmpe821GpioDir get ();
    void set (Stmpe821GpioDir value);
}
member GPIODIRIO4 : Stmpe821GpioDir with get, set

Property Value

Type: Stmpe821GpioDir
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIODIRIO5 Property

IRD

Stmpe821GPIODIRIO5 Property

GPIO_DIR: IO-5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821GpioDir GPIODIRIO5 { get; set; }
Public Property GPIODIRIO5 As Stmpe821GpioDir
    Get
    Set
public:
property Stmpe821GpioDir GPIODIRIO5 {
    Stmpe821GpioDir get ();
    void set (Stmpe821GpioDir value);
}
member GPIODIRIO5 : Stmpe821GpioDir with get, set

Property Value

Type: Stmpe821GpioDir
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIODIRIO6 Property

IRD

Stmpe821GPIODIRIO6 Property

GPIO_DIR: IO-6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821GpioDir GPIODIRIO6 { get; set; }
Public Property GPIODIRIO6 As Stmpe821GpioDir
    Get
    Set
public:
property Stmpe821GpioDir GPIODIRIO6 {
    Stmpe821GpioDir get ();
    void set (Stmpe821GpioDir value);
}
member GPIODIRIO6 : Stmpe821GpioDir with get, set

Property Value

Type: Stmpe821GpioDir
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIODIRIO7 Property

IRD

Stmpe821GPIODIRIO7 Property

GPIO_DIR: IO-7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821GpioDir GPIODIRIO7 { get; set; }
Public Property GPIODIRIO7 As Stmpe821GpioDir
    Get
    Set
public:
property Stmpe821GpioDir GPIODIRIO7 {
    Stmpe821GpioDir get ();
    void set (Stmpe821GpioDir value);
}
member GPIODIRIO7 : Stmpe821GpioDir with get, set

Property Value

Type: Stmpe821GpioDir
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOFUNCTIO0 Property

IRD

Stmpe821GPIOFUNCTIO0 Property

GPIO_FUNCT: IO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821GpioFunct GPIOFUNCTIO0 { get; set; }
Public Property GPIOFUNCTIO0 As Stmpe821GpioFunct
    Get
    Set
public:
property Stmpe821GpioFunct GPIOFUNCTIO0 {
    Stmpe821GpioFunct get ();
    void set (Stmpe821GpioFunct value);
}
member GPIOFUNCTIO0 : Stmpe821GpioFunct with get, set

Property Value

Type: Stmpe821GpioFunct
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOFUNCTIO1 Property

IRD

Stmpe821GPIOFUNCTIO1 Property

GPIO_FUNCT: IO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821GpioFunct GPIOFUNCTIO1 { get; set; }
Public Property GPIOFUNCTIO1 As Stmpe821GpioFunct
    Get
    Set
public:
property Stmpe821GpioFunct GPIOFUNCTIO1 {
    Stmpe821GpioFunct get ();
    void set (Stmpe821GpioFunct value);
}
member GPIOFUNCTIO1 : Stmpe821GpioFunct with get, set

Property Value

Type: Stmpe821GpioFunct
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOFUNCTIO2 Property

IRD

Stmpe821GPIOFUNCTIO2 Property

GPIO_FUNCT: IO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821GpioFunct GPIOFUNCTIO2 { get; set; }
Public Property GPIOFUNCTIO2 As Stmpe821GpioFunct
    Get
    Set
public:
property Stmpe821GpioFunct GPIOFUNCTIO2 {
    Stmpe821GpioFunct get ();
    void set (Stmpe821GpioFunct value);
}
member GPIOFUNCTIO2 : Stmpe821GpioFunct with get, set

Property Value

Type: Stmpe821GpioFunct
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOFUNCTIO3 Property

IRD

Stmpe821GPIOFUNCTIO3 Property

GPIO_FUNCT: IO-3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821GpioFunct GPIOFUNCTIO3 { get; set; }
Public Property GPIOFUNCTIO3 As Stmpe821GpioFunct
    Get
    Set
public:
property Stmpe821GpioFunct GPIOFUNCTIO3 {
    Stmpe821GpioFunct get ();
    void set (Stmpe821GpioFunct value);
}
member GPIOFUNCTIO3 : Stmpe821GpioFunct with get, set

Property Value

Type: Stmpe821GpioFunct
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOFUNCTIO4 Property

IRD

Stmpe821GPIOFUNCTIO4 Property

GPIO_FUNCT: IO-4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821GpioFunct GPIOFUNCTIO4 { get; set; }
Public Property GPIOFUNCTIO4 As Stmpe821GpioFunct
    Get
    Set
public:
property Stmpe821GpioFunct GPIOFUNCTIO4 {
    Stmpe821GpioFunct get ();
    void set (Stmpe821GpioFunct value);
}
member GPIOFUNCTIO4 : Stmpe821GpioFunct with get, set

Property Value

Type: Stmpe821GpioFunct
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOFUNCTIO5 Property

IRD

Stmpe821GPIOFUNCTIO5 Property

GPIO_FUNCT: IO-5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821GpioFunct GPIOFUNCTIO5 { get; set; }
Public Property GPIOFUNCTIO5 As Stmpe821GpioFunct
    Get
    Set
public:
property Stmpe821GpioFunct GPIOFUNCTIO5 {
    Stmpe821GpioFunct get ();
    void set (Stmpe821GpioFunct value);
}
member GPIOFUNCTIO5 : Stmpe821GpioFunct with get, set

Property Value

Type: Stmpe821GpioFunct
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOFUNCTIO6 Property

IRD

Stmpe821GPIOFUNCTIO6 Property

GPIO_FUNCT: IO-6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821GpioFunct GPIOFUNCTIO6 { get; set; }
Public Property GPIOFUNCTIO6 As Stmpe821GpioFunct
    Get
    Set
public:
property Stmpe821GpioFunct GPIOFUNCTIO6 {
    Stmpe821GpioFunct get ();
    void set (Stmpe821GpioFunct value);
}
member GPIOFUNCTIO6 : Stmpe821GpioFunct with get, set

Property Value

Type: Stmpe821GpioFunct
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOFUNCTIO7 Property

IRD

Stmpe821GPIOFUNCTIO7 Property

GPIO_FUNCT: IO-7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821GpioFunct GPIOFUNCTIO7 { get; set; }
Public Property GPIOFUNCTIO7 As Stmpe821GpioFunct
    Get
    Set
public:
property Stmpe821GpioFunct GPIOFUNCTIO7 {
    Stmpe821GpioFunct get ();
    void set (Stmpe821GpioFunct value);
}
member GPIOFUNCTIO7 : Stmpe821GpioFunct with get, set

Property Value

Type: Stmpe821GpioFunct
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOINTENIO0 Property

IRD

Stmpe821GPIOINTENIO0 Property

GPIO_INT_EN: IO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821Enable1Disable0 GPIOINTENIO0 { get; set; }
Public Property GPIOINTENIO0 As Stmpe821Enable1Disable0
    Get
    Set
public:
property Stmpe821Enable1Disable0 GPIOINTENIO0 {
    Stmpe821Enable1Disable0 get ();
    void set (Stmpe821Enable1Disable0 value);
}
member GPIOINTENIO0 : Stmpe821Enable1Disable0 with get, set

Property Value

Type: Stmpe821Enable1Disable0
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOINTENIO1 Property

IRD

Stmpe821GPIOINTENIO1 Property

GPIO_INT_EN: IO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821Enable1Disable0 GPIOINTENIO1 { get; set; }
Public Property GPIOINTENIO1 As Stmpe821Enable1Disable0
    Get
    Set
public:
property Stmpe821Enable1Disable0 GPIOINTENIO1 {
    Stmpe821Enable1Disable0 get ();
    void set (Stmpe821Enable1Disable0 value);
}
member GPIOINTENIO1 : Stmpe821Enable1Disable0 with get, set

Property Value

Type: Stmpe821Enable1Disable0
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOINTENIO2 Property

IRD

Stmpe821GPIOINTENIO2 Property

GPIO_INT_EN: IO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821Enable1Disable0 GPIOINTENIO2 { get; set; }
Public Property GPIOINTENIO2 As Stmpe821Enable1Disable0
    Get
    Set
public:
property Stmpe821Enable1Disable0 GPIOINTENIO2 {
    Stmpe821Enable1Disable0 get ();
    void set (Stmpe821Enable1Disable0 value);
}
member GPIOINTENIO2 : Stmpe821Enable1Disable0 with get, set

Property Value

Type: Stmpe821Enable1Disable0
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOINTENIO3 Property

IRD

Stmpe821GPIOINTENIO3 Property

GPIO_INT_EN: IO-3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821Enable1Disable0 GPIOINTENIO3 { get; set; }
Public Property GPIOINTENIO3 As Stmpe821Enable1Disable0
    Get
    Set
public:
property Stmpe821Enable1Disable0 GPIOINTENIO3 {
    Stmpe821Enable1Disable0 get ();
    void set (Stmpe821Enable1Disable0 value);
}
member GPIOINTENIO3 : Stmpe821Enable1Disable0 with get, set

Property Value

Type: Stmpe821Enable1Disable0
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOINTENIO4 Property

IRD

Stmpe821GPIOINTENIO4 Property

GPIO_INT_EN: IO-4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821Enable1Disable0 GPIOINTENIO4 { get; set; }
Public Property GPIOINTENIO4 As Stmpe821Enable1Disable0
    Get
    Set
public:
property Stmpe821Enable1Disable0 GPIOINTENIO4 {
    Stmpe821Enable1Disable0 get ();
    void set (Stmpe821Enable1Disable0 value);
}
member GPIOINTENIO4 : Stmpe821Enable1Disable0 with get, set

Property Value

Type: Stmpe821Enable1Disable0
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOINTENIO5 Property

IRD

Stmpe821GPIOINTENIO5 Property

GPIO_INT_EN: IO-5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821Enable1Disable0 GPIOINTENIO5 { get; set; }
Public Property GPIOINTENIO5 As Stmpe821Enable1Disable0
    Get
    Set
public:
property Stmpe821Enable1Disable0 GPIOINTENIO5 {
    Stmpe821Enable1Disable0 get ();
    void set (Stmpe821Enable1Disable0 value);
}
member GPIOINTENIO5 : Stmpe821Enable1Disable0 with get, set

Property Value

Type: Stmpe821Enable1Disable0
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOINTENIO6 Property

IRD

Stmpe821GPIOINTENIO6 Property

GPIO_INT_EN: IO-6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821Enable1Disable0 GPIOINTENIO6 { get; set; }
Public Property GPIOINTENIO6 As Stmpe821Enable1Disable0
    Get
    Set
public:
property Stmpe821Enable1Disable0 GPIOINTENIO6 {
    Stmpe821Enable1Disable0 get ();
    void set (Stmpe821Enable1Disable0 value);
}
member GPIOINTENIO6 : Stmpe821Enable1Disable0 with get, set

Property Value

Type: Stmpe821Enable1Disable0
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOINTENIO7 Property

IRD

Stmpe821GPIOINTENIO7 Property

GPIO_INT_EN: IO-7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821Enable1Disable0 GPIOINTENIO7 { get; set; }
Public Property GPIOINTENIO7 As Stmpe821Enable1Disable0
    Get
    Set
public:
property Stmpe821Enable1Disable0 GPIOINTENIO7 {
    Stmpe821Enable1Disable0 get ();
    void set (Stmpe821Enable1Disable0 value);
}
member GPIOINTENIO7 : Stmpe821Enable1Disable0 with get, set

Property Value

Type: Stmpe821Enable1Disable0
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOINTSTAIO0 Property

IRD

Stmpe821GPIOINTSTAIO0 Property

GPIO_INT_STA: IO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINTSTAIO0 { get; set; }
Public Property GPIOINTSTAIO0 As Byte
    Get
    Set
public:
property unsigned char GPIOINTSTAIO0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOINTSTAIO0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOINTSTAIO1 Property

IRD

Stmpe821GPIOINTSTAIO1 Property

GPIO_INT_STA: IO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINTSTAIO1 { get; set; }
Public Property GPIOINTSTAIO1 As Byte
    Get
    Set
public:
property unsigned char GPIOINTSTAIO1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOINTSTAIO1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOINTSTAIO2 Property

IRD

Stmpe821GPIOINTSTAIO2 Property

GPIO_INT_STA: IO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINTSTAIO2 { get; set; }
Public Property GPIOINTSTAIO2 As Byte
    Get
    Set
public:
property unsigned char GPIOINTSTAIO2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOINTSTAIO2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOINTSTAIO3 Property

IRD

Stmpe821GPIOINTSTAIO3 Property

GPIO_INT_STA: IO-3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINTSTAIO3 { get; set; }
Public Property GPIOINTSTAIO3 As Byte
    Get
    Set
public:
property unsigned char GPIOINTSTAIO3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOINTSTAIO3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOINTSTAIO4 Property

IRD

Stmpe821GPIOINTSTAIO4 Property

GPIO_INT_STA: IO-4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINTSTAIO4 { get; set; }
Public Property GPIOINTSTAIO4 As Byte
    Get
    Set
public:
property unsigned char GPIOINTSTAIO4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOINTSTAIO4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOINTSTAIO5 Property

IRD

Stmpe821GPIOINTSTAIO5 Property

GPIO_INT_STA: IO-5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINTSTAIO5 { get; set; }
Public Property GPIOINTSTAIO5 As Byte
    Get
    Set
public:
property unsigned char GPIOINTSTAIO5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOINTSTAIO5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOINTSTAIO6 Property

IRD

Stmpe821GPIOINTSTAIO6 Property

GPIO_INT_STA: IO-6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINTSTAIO6 { get; set; }
Public Property GPIOINTSTAIO6 As Byte
    Get
    Set
public:
property unsigned char GPIOINTSTAIO6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOINTSTAIO6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOINTSTAIO7 Property

IRD

Stmpe821GPIOINTSTAIO7 Property

GPIO_INT_STA: IO-7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOINTSTAIO7 { get; set; }
Public Property GPIOINTSTAIO7 As Byte
    Get
    Set
public:
property unsigned char GPIOINTSTAIO7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOINTSTAIO7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOMRIO0 Property

IRD

Stmpe821GPIOMRIO0 Property

GPIO_MR: IO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOMRIO0 { get; set; }
Public Property GPIOMRIO0 As Byte
    Get
    Set
public:
property unsigned char GPIOMRIO0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOMRIO0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOMRIO1 Property

IRD

Stmpe821GPIOMRIO1 Property

GPIO_MR: IO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOMRIO1 { get; set; }
Public Property GPIOMRIO1 As Byte
    Get
    Set
public:
property unsigned char GPIOMRIO1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOMRIO1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOMRIO2 Property

IRD

Stmpe821GPIOMRIO2 Property

GPIO_MR: IO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOMRIO2 { get; set; }
Public Property GPIOMRIO2 As Byte
    Get
    Set
public:
property unsigned char GPIOMRIO2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOMRIO2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOMRIO3 Property

IRD

Stmpe821GPIOMRIO3 Property

GPIO_MR: IO-3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOMRIO3 { get; set; }
Public Property GPIOMRIO3 As Byte
    Get
    Set
public:
property unsigned char GPIOMRIO3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOMRIO3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOMRIO4 Property

IRD

Stmpe821GPIOMRIO4 Property

GPIO_MR: IO-4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOMRIO4 { get; set; }
Public Property GPIOMRIO4 As Byte
    Get
    Set
public:
property unsigned char GPIOMRIO4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOMRIO4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOMRIO5 Property

IRD

Stmpe821GPIOMRIO5 Property

GPIO_MR: IO-5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOMRIO5 { get; set; }
Public Property GPIOMRIO5 As Byte
    Get
    Set
public:
property unsigned char GPIOMRIO5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOMRIO5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOMRIO6 Property

IRD

Stmpe821GPIOMRIO6 Property

GPIO_MR: IO-6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOMRIO6 { get; set; }
Public Property GPIOMRIO6 As Byte
    Get
    Set
public:
property unsigned char GPIOMRIO6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOMRIO6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOMRIO7 Property

IRD

Stmpe821GPIOMRIO7 Property

GPIO_MR: IO-7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOMRIO7 { get; set; }
Public Property GPIOMRIO7 As Byte
    Get
    Set
public:
property unsigned char GPIOMRIO7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOMRIO7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOSETIO0 Property

IRD

Stmpe821GPIOSETIO0 Property

GPIO_SET: IO-0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSETIO0 { get; set; }
Public Property GPIOSETIO0 As Byte
    Get
    Set
public:
property unsigned char GPIOSETIO0 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSETIO0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOSETIO1 Property

IRD

Stmpe821GPIOSETIO1 Property

GPIO_SET: IO-1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSETIO1 { get; set; }
Public Property GPIOSETIO1 As Byte
    Get
    Set
public:
property unsigned char GPIOSETIO1 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSETIO1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOSETIO2 Property

IRD

Stmpe821GPIOSETIO2 Property

GPIO_SET: IO-2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSETIO2 { get; set; }
Public Property GPIOSETIO2 As Byte
    Get
    Set
public:
property unsigned char GPIOSETIO2 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSETIO2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOSETIO3 Property

IRD

Stmpe821GPIOSETIO3 Property

GPIO_SET: IO-3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSETIO3 { get; set; }
Public Property GPIOSETIO3 As Byte
    Get
    Set
public:
property unsigned char GPIOSETIO3 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSETIO3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOSETIO4 Property

IRD

Stmpe821GPIOSETIO4 Property

GPIO_SET: IO-4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSETIO4 { get; set; }
Public Property GPIOSETIO4 As Byte
    Get
    Set
public:
property unsigned char GPIOSETIO4 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSETIO4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOSETIO5 Property

IRD

Stmpe821GPIOSETIO5 Property

GPIO_SET: IO-5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSETIO5 { get; set; }
Public Property GPIOSETIO5 As Byte
    Get
    Set
public:
property unsigned char GPIOSETIO5 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSETIO5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOSETIO6 Property

IRD

Stmpe821GPIOSETIO6 Property

GPIO_SET: IO-6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSETIO6 { get; set; }
Public Property GPIOSETIO6 As Byte
    Get
    Set
public:
property unsigned char GPIOSETIO6 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSETIO6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.GPIOSETIO7 Property

IRD

Stmpe821GPIOSETIO7 Property

GPIO_SET: IO-7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte GPIOSETIO7 { get; set; }
Public Property GPIOSETIO7 As Byte
    Get
    Set
public:
property unsigned char GPIOSETIO7 {
    unsigned char get ();
    void set (unsigned char value);
}
member GPIOSETIO7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.IDVER Property

IRD

Stmpe821IDVER Property

ID_VER

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IDVER { get; }
Public ReadOnly Property IDVER As Byte
    Get
public:
property unsigned char IDVER {
    unsigned char get ();
}
member IDVER : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.IMPEDANCE0 Property

IRD

Stmpe821IMPEDANCE0 Property

IMPEDANCE 0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IMPEDANCE0 { get; }
Public ReadOnly Property IMPEDANCE0 As Byte
    Get
public:
property unsigned char IMPEDANCE0 {
    unsigned char get ();
}
member IMPEDANCE0 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.IMPEDANCE1 Property

IRD

Stmpe821IMPEDANCE1 Property

IMPEDANCE 1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IMPEDANCE1 { get; }
Public ReadOnly Property IMPEDANCE1 As Byte
    Get
public:
property unsigned char IMPEDANCE1 {
    unsigned char get ();
}
member IMPEDANCE1 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.IMPEDANCE2 Property

IRD

Stmpe821IMPEDANCE2 Property

IMPEDANCE 2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IMPEDANCE2 { get; }
Public ReadOnly Property IMPEDANCE2 As Byte
    Get
public:
property unsigned char IMPEDANCE2 {
    unsigned char get ();
}
member IMPEDANCE2 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.IMPEDANCE3 Property

IRD

Stmpe821IMPEDANCE3 Property

IMPEDANCE 3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IMPEDANCE3 { get; }
Public ReadOnly Property IMPEDANCE3 As Byte
    Get
public:
property unsigned char IMPEDANCE3 {
    unsigned char get ();
}
member IMPEDANCE3 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.IMPEDANCE4 Property

IRD

Stmpe821IMPEDANCE4 Property

IMPEDANCE 4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IMPEDANCE4 { get; }
Public ReadOnly Property IMPEDANCE4 As Byte
    Get
public:
property unsigned char IMPEDANCE4 {
    unsigned char get ();
}
member IMPEDANCE4 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.IMPEDANCE5 Property

IRD

Stmpe821IMPEDANCE5 Property

IMPEDANCE 5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IMPEDANCE5 { get; }
Public ReadOnly Property IMPEDANCE5 As Byte
    Get
public:
property unsigned char IMPEDANCE5 {
    unsigned char get ();
}
member IMPEDANCE5 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.IMPEDANCE6 Property

IRD

Stmpe821IMPEDANCE6 Property

IMPEDANCE 6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IMPEDANCE6 { get; }
Public ReadOnly Property IMPEDANCE6 As Byte
    Get
public:
property unsigned char IMPEDANCE6 {
    unsigned char get ();
}
member IMPEDANCE6 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.IMPEDANCE7 Property

IRD

Stmpe821IMPEDANCE7 Property

IMPEDANCE 7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte IMPEDANCE7 { get; }
Public ReadOnly Property IMPEDANCE7 As Byte
    Get
public:
property unsigned char IMPEDANCE7 {
    unsigned char get ();
}
member IMPEDANCE7 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTCLREOC Property

IRD

Stmpe821INTCLREOC Property

INT_CLR: EOC

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTCLREOC { get; set; }
Public Property INTCLREOC As Byte
    Get
    Set
public:
property unsigned char INTCLREOC {
    unsigned char get ();
    void set (unsigned char value);
}
member INTCLREOC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTCTRLINTEN Property

IRD

Stmpe821INTCTRLINTEN Property

INT_CTRL: INT_EN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821IntCtrlIntEn INTCTRLINTEN { get; set; }
Public Property INTCTRLINTEN As Stmpe821IntCtrlIntEn
    Get
    Set
public:
property Stmpe821IntCtrlIntEn INTCTRLINTEN {
    Stmpe821IntCtrlIntEn get ();
    void set (Stmpe821IntCtrlIntEn value);
}
member INTCTRLINTEN : Stmpe821IntCtrlIntEn with get, set

Property Value

Type: Stmpe821IntCtrlIntEn
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTCTRLPOLARITY Property

IRD

Stmpe821INTCTRLPOLARITY Property

INT_CTRL: POLARITY

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821IntCtrlPolarity INTCTRLPOLARITY { get; set; }
Public Property INTCTRLPOLARITY As Stmpe821IntCtrlPolarity
    Get
    Set
public:
property Stmpe821IntCtrlPolarity INTCTRLPOLARITY {
    Stmpe821IntCtrlPolarity get ();
    void set (Stmpe821IntCtrlPolarity value);
}
member INTCTRLPOLARITY : Stmpe821IntCtrlPolarity with get, set

Property Value

Type: Stmpe821IntCtrlPolarity
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTCTRLTYPE Property

IRD

Stmpe821INTCTRLTYPE Property

INT_CTRL: TYPE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821IntCtrlType INTCTRLTYPE { get; set; }
Public Property INTCTRLTYPE As Stmpe821IntCtrlType
    Get
    Set
public:
property Stmpe821IntCtrlType INTCTRLTYPE {
    Stmpe821IntCtrlType get ();
    void set (Stmpe821IntCtrlType value);
}
member INTCTRLTYPE : Stmpe821IntCtrlType with get, set

Property Value

Type: Stmpe821IntCtrlType
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTEGRATIONTIME Property

IRD

Stmpe821INTEGRATIONTIME Property

INTEGRATION_TIME

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTEGRATIONTIME { get; set; }
Public Property INTEGRATIONTIME As Byte
    Get
    Set
public:
property unsigned char INTEGRATIONTIME {
    unsigned char get ();
    void set (unsigned char value);
}
member INTEGRATIONTIME : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTENFIFO Property

IRD

Stmpe821INTENFIFO Property

INT_EN: FIFO

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENFIFO { get; set; }
Public Property INTENFIFO As Byte
    Get
    Set
public:
property unsigned char INTENFIFO {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENFIFO : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTENGEN Property

IRD

Stmpe821INTENGEN Property

INT_EN: GEN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENGEN { get; set; }
Public Property INTENGEN As Byte
    Get
    Set
public:
property unsigned char INTENGEN {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENGEN : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTENGPIO Property

IRD

Stmpe821INTENGPIO Property

INT_EN: GPIO

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENGPIO { get; set; }
Public Property INTENGPIO As Byte
    Get
    Set
public:
property unsigned char INTENGPIO {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENGPIO : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTENPOR Property

IRD

Stmpe821INTENPOR Property

INT_EN: POR

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENPOR { get; set; }
Public Property INTENPOR As Byte
    Get
    Set
public:
property unsigned char INTENPOR {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENPOR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTENPWM0 Property

IRD

Stmpe821INTENPWM0 Property

INT_EN: PWM0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENPWM0 { get; set; }
Public Property INTENPWM0 As Byte
    Get
    Set
public:
property unsigned char INTENPWM0 {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENPWM0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTENPWM1 Property

IRD

Stmpe821INTENPWM1 Property

INT_EN: PWM1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENPWM1 { get; set; }
Public Property INTENPWM1 As Byte
    Get
    Set
public:
property unsigned char INTENPWM1 {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENPWM1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTENPWM2 Property

IRD

Stmpe821INTENPWM2 Property

INT_EN: PWM2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENPWM2 { get; set; }
Public Property INTENPWM2 As Byte
    Get
    Set
public:
property unsigned char INTENPWM2 {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENPWM2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTENPWM3 Property

IRD

Stmpe821INTENPWM3 Property

INT_EN: PWM3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTENPWM3 { get; set; }
Public Property INTENPWM3 As Byte
    Get
    Set
public:
property unsigned char INTENPWM3 {
    unsigned char get ();
    void set (unsigned char value);
}
member INTENPWM3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTMASKEOC Property

IRD

Stmpe821INTMASKEOC Property

INT_MASK: EOC

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTMASKEOC { get; set; }
Public Property INTMASKEOC As Byte
    Get
    Set
public:
property unsigned char INTMASKEOC {
    unsigned char get ();
    void set (unsigned char value);
}
member INTMASKEOC : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTSTAFIFO Property

IRD

Stmpe821INTSTAFIFO Property

INT_STA: FIFO

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAFIFO { get; }
Public ReadOnly Property INTSTAFIFO As Byte
    Get
public:
property unsigned char INTSTAFIFO {
    unsigned char get ();
}
member INTSTAFIFO : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTSTAGEN Property

IRD

Stmpe821INTSTAGEN Property

INT_STA: GEN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAGEN { get; }
Public ReadOnly Property INTSTAGEN As Byte
    Get
public:
property unsigned char INTSTAGEN {
    unsigned char get ();
}
member INTSTAGEN : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTSTAGPIO Property

IRD

Stmpe821INTSTAGPIO Property

INT_STA: GPIO

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAGPIO { get; }
Public ReadOnly Property INTSTAGPIO As Byte
    Get
public:
property unsigned char INTSTAGPIO {
    unsigned char get ();
}
member INTSTAGPIO : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTSTAPOR Property

IRD

Stmpe821INTSTAPOR Property

INT_STA: POR

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAPOR { get; }
Public ReadOnly Property INTSTAPOR As Byte
    Get
public:
property unsigned char INTSTAPOR {
    unsigned char get ();
}
member INTSTAPOR : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTSTAPWM0 Property

IRD

Stmpe821INTSTAPWM0 Property

INT_STA: PWM0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAPWM0 { get; }
Public ReadOnly Property INTSTAPWM0 As Byte
    Get
public:
property unsigned char INTSTAPWM0 {
    unsigned char get ();
}
member INTSTAPWM0 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTSTAPWM1 Property

IRD

Stmpe821INTSTAPWM1 Property

INT_STA: PWM1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAPWM1 { get; }
Public ReadOnly Property INTSTAPWM1 As Byte
    Get
public:
property unsigned char INTSTAPWM1 {
    unsigned char get ();
}
member INTSTAPWM1 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTSTAPWM2 Property

IRD

Stmpe821INTSTAPWM2 Property

INT_STA: PWM2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAPWM2 { get; }
Public ReadOnly Property INTSTAPWM2 As Byte
    Get
public:
property unsigned char INTSTAPWM2 {
    unsigned char get ();
}
member INTSTAPWM2 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.INTSTAPWM3 Property

IRD

Stmpe821INTSTAPWM3 Property

INT_STA: PWM3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte INTSTAPWM3 { get; }
Public ReadOnly Property INTSTAPWM3 As Byte
    Get
public:
property unsigned char INTSTAPWM3 {
    unsigned char get ();
}
member INTSTAPWM3 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.MASTERENEN0 Property

IRD

Stmpe821MASTERENEN0 Property

MASTER_EN: EN0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MASTERENEN0 { get; set; }
Public Property MASTERENEN0 As Byte
    Get
    Set
public:
property unsigned char MASTERENEN0 {
    unsigned char get ();
    void set (unsigned char value);
}
member MASTERENEN0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.MASTERENEN1 Property

IRD

Stmpe821MASTERENEN1 Property

MASTER_EN: EN1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MASTERENEN1 { get; set; }
Public Property MASTERENEN1 As Byte
    Get
    Set
public:
property unsigned char MASTERENEN1 {
    unsigned char get ();
    void set (unsigned char value);
}
member MASTERENEN1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.MASTERENEN2 Property

IRD

Stmpe821MASTERENEN2 Property

MASTER_EN: EN2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MASTERENEN2 { get; set; }
Public Property MASTERENEN2 As Byte
    Get
    Set
public:
property unsigned char MASTERENEN2 {
    unsigned char get ();
    void set (unsigned char value);
}
member MASTERENEN2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.MASTERENEN3 Property

IRD

Stmpe821MASTERENEN3 Property

MASTER_EN: EN3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MASTERENEN3 { get; set; }
Public Property MASTERENEN3 As Byte
    Get
    Set
public:
property unsigned char MASTERENEN3 {
    unsigned char get ();
    void set (unsigned char value);
}
member MASTERENEN3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM0RAMPRATERAMPDOWN Property

IRD

Stmpe821PWM0RAMPRATERAMPDOWN Property

PWM_0_RAMP_RATE: RAMP_DOWN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmRampRate PWM0RAMPRATERAMPDOWN { get; set; }
Public Property PWM0RAMPRATERAMPDOWN As Stmpe821PwmRampRate
    Get
    Set
public:
property Stmpe821PwmRampRate PWM0RAMPRATERAMPDOWN {
    Stmpe821PwmRampRate get ();
    void set (Stmpe821PwmRampRate value);
}
member PWM0RAMPRATERAMPDOWN : Stmpe821PwmRampRate with get, set

Property Value

Type: Stmpe821PwmRampRate
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM0RAMPRATERAMPUP Property

IRD

Stmpe821PWM0RAMPRATERAMPUP Property

PWM_0_RAMP_RATE: RAMP_UP

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmRampRate PWM0RAMPRATERAMPUP { get; set; }
Public Property PWM0RAMPRATERAMPUP As Stmpe821PwmRampRate
    Get
    Set
public:
property Stmpe821PwmRampRate PWM0RAMPRATERAMPUP {
    Stmpe821PwmRampRate get ();
    void set (Stmpe821PwmRampRate value);
}
member PWM0RAMPRATERAMPUP : Stmpe821PwmRampRate with get, set

Property Value

Type: Stmpe821PwmRampRate
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM0SETUPBRIGHTNESS Property

IRD

Stmpe821PWM0SETUPBRIGHTNESS Property

PWM_0_SETUP: BRIGHTNESS

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmSetupBrightness PWM0SETUPBRIGHTNESS { get; set; }
Public Property PWM0SETUPBRIGHTNESS As Stmpe821PwmSetupBrightness
    Get
    Set
public:
property Stmpe821PwmSetupBrightness PWM0SETUPBRIGHTNESS {
    Stmpe821PwmSetupBrightness get ();
    void set (Stmpe821PwmSetupBrightness value);
}
member PWM0SETUPBRIGHTNESS : Stmpe821PwmSetupBrightness with get, set

Property Value

Type: Stmpe821PwmSetupBrightness
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM0SETUPRAMPMODE Property

IRD

Stmpe821PWM0SETUPRAMPMODE Property

PWM_0_SETUP: RAMP_MODE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM0SETUPRAMPMODE { get; set; }
Public Property PWM0SETUPRAMPMODE As Byte
    Get
    Set
public:
property unsigned char PWM0SETUPRAMPMODE {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM0SETUPRAMPMODE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM0SETUPTIMING Property

IRD

Stmpe821PWM0SETUPTIMING Property

PWM_0_SETUP: TIMING (unit: mS)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmSetupTiming PWM0SETUPTIMING { get; set; }
Public Property PWM0SETUPTIMING As Stmpe821PwmSetupTiming
    Get
    Set
public:
property Stmpe821PwmSetupTiming PWM0SETUPTIMING {
    Stmpe821PwmSetupTiming get ();
    void set (Stmpe821PwmSetupTiming value);
}
member PWM0SETUPTIMING : Stmpe821PwmSetupTiming with get, set

Property Value

Type: Stmpe821PwmSetupTiming
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM1RAMPRATERAMPDOWN Property

IRD

Stmpe821PWM1RAMPRATERAMPDOWN Property

PWM_1_RAMP_RATE: RAMP_DOWN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmRampRate PWM1RAMPRATERAMPDOWN { get; set; }
Public Property PWM1RAMPRATERAMPDOWN As Stmpe821PwmRampRate
    Get
    Set
public:
property Stmpe821PwmRampRate PWM1RAMPRATERAMPDOWN {
    Stmpe821PwmRampRate get ();
    void set (Stmpe821PwmRampRate value);
}
member PWM1RAMPRATERAMPDOWN : Stmpe821PwmRampRate with get, set

Property Value

Type: Stmpe821PwmRampRate
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM1RAMPRATERAMPUP Property

IRD

Stmpe821PWM1RAMPRATERAMPUP Property

PWM_1_RAMP_RATE: RAMP_UP

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmRampRate PWM1RAMPRATERAMPUP { get; set; }
Public Property PWM1RAMPRATERAMPUP As Stmpe821PwmRampRate
    Get
    Set
public:
property Stmpe821PwmRampRate PWM1RAMPRATERAMPUP {
    Stmpe821PwmRampRate get ();
    void set (Stmpe821PwmRampRate value);
}
member PWM1RAMPRATERAMPUP : Stmpe821PwmRampRate with get, set

Property Value

Type: Stmpe821PwmRampRate
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM1SETUPBRIGHTNESS Property

IRD

Stmpe821PWM1SETUPBRIGHTNESS Property

PWM_1_SETUP: BRIGHTNESS

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmSetupBrightness PWM1SETUPBRIGHTNESS { get; set; }
Public Property PWM1SETUPBRIGHTNESS As Stmpe821PwmSetupBrightness
    Get
    Set
public:
property Stmpe821PwmSetupBrightness PWM1SETUPBRIGHTNESS {
    Stmpe821PwmSetupBrightness get ();
    void set (Stmpe821PwmSetupBrightness value);
}
member PWM1SETUPBRIGHTNESS : Stmpe821PwmSetupBrightness with get, set

Property Value

Type: Stmpe821PwmSetupBrightness
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM1SETUPRAMPMODE Property

IRD

Stmpe821PWM1SETUPRAMPMODE Property

PWM_1_SETUP: RAMP_MODE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM1SETUPRAMPMODE { get; set; }
Public Property PWM1SETUPRAMPMODE As Byte
    Get
    Set
public:
property unsigned char PWM1SETUPRAMPMODE {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM1SETUPRAMPMODE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM1SETUPTIMING Property

IRD

Stmpe821PWM1SETUPTIMING Property

PWM_1_SETUP: TIMING (unit: mS)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmSetupTiming PWM1SETUPTIMING { get; set; }
Public Property PWM1SETUPTIMING As Stmpe821PwmSetupTiming
    Get
    Set
public:
property Stmpe821PwmSetupTiming PWM1SETUPTIMING {
    Stmpe821PwmSetupTiming get ();
    void set (Stmpe821PwmSetupTiming value);
}
member PWM1SETUPTIMING : Stmpe821PwmSetupTiming with get, set

Property Value

Type: Stmpe821PwmSetupTiming
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM2RAMPRATERAMPDOWN Property

IRD

Stmpe821PWM2RAMPRATERAMPDOWN Property

PWM_2_RAMP_RATE: RAMP_DOWN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmRampRate PWM2RAMPRATERAMPDOWN { get; set; }
Public Property PWM2RAMPRATERAMPDOWN As Stmpe821PwmRampRate
    Get
    Set
public:
property Stmpe821PwmRampRate PWM2RAMPRATERAMPDOWN {
    Stmpe821PwmRampRate get ();
    void set (Stmpe821PwmRampRate value);
}
member PWM2RAMPRATERAMPDOWN : Stmpe821PwmRampRate with get, set

Property Value

Type: Stmpe821PwmRampRate
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM2RAMPRATERAMPUP Property

IRD

Stmpe821PWM2RAMPRATERAMPUP Property

PWM_2_RAMP_RATE: RAMP_UP

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmRampRate PWM2RAMPRATERAMPUP { get; set; }
Public Property PWM2RAMPRATERAMPUP As Stmpe821PwmRampRate
    Get
    Set
public:
property Stmpe821PwmRampRate PWM2RAMPRATERAMPUP {
    Stmpe821PwmRampRate get ();
    void set (Stmpe821PwmRampRate value);
}
member PWM2RAMPRATERAMPUP : Stmpe821PwmRampRate with get, set

Property Value

Type: Stmpe821PwmRampRate
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM2SETUPBRIGHTNESS Property

IRD

Stmpe821PWM2SETUPBRIGHTNESS Property

PWM_2_SETUP: BRIGHTNESS

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmSetupBrightness PWM2SETUPBRIGHTNESS { get; set; }
Public Property PWM2SETUPBRIGHTNESS As Stmpe821PwmSetupBrightness
    Get
    Set
public:
property Stmpe821PwmSetupBrightness PWM2SETUPBRIGHTNESS {
    Stmpe821PwmSetupBrightness get ();
    void set (Stmpe821PwmSetupBrightness value);
}
member PWM2SETUPBRIGHTNESS : Stmpe821PwmSetupBrightness with get, set

Property Value

Type: Stmpe821PwmSetupBrightness
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM2SETUPRAMPMODE Property

IRD

Stmpe821PWM2SETUPRAMPMODE Property

PWM_2_SETUP: RAMP_MODE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM2SETUPRAMPMODE { get; set; }
Public Property PWM2SETUPRAMPMODE As Byte
    Get
    Set
public:
property unsigned char PWM2SETUPRAMPMODE {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM2SETUPRAMPMODE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM2SETUPTIMING Property

IRD

Stmpe821PWM2SETUPTIMING Property

PWM_2_SETUP: TIMING (unit: mS)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmSetupTiming PWM2SETUPTIMING { get; set; }
Public Property PWM2SETUPTIMING As Stmpe821PwmSetupTiming
    Get
    Set
public:
property Stmpe821PwmSetupTiming PWM2SETUPTIMING {
    Stmpe821PwmSetupTiming get ();
    void set (Stmpe821PwmSetupTiming value);
}
member PWM2SETUPTIMING : Stmpe821PwmSetupTiming with get, set

Property Value

Type: Stmpe821PwmSetupTiming
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM3RAMPRATERAMPDOWN Property

IRD

Stmpe821PWM3RAMPRATERAMPDOWN Property

PWM_3_RAMP_RATE: RAMP_DOWN

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmRampRate PWM3RAMPRATERAMPDOWN { get; set; }
Public Property PWM3RAMPRATERAMPDOWN As Stmpe821PwmRampRate
    Get
    Set
public:
property Stmpe821PwmRampRate PWM3RAMPRATERAMPDOWN {
    Stmpe821PwmRampRate get ();
    void set (Stmpe821PwmRampRate value);
}
member PWM3RAMPRATERAMPDOWN : Stmpe821PwmRampRate with get, set

Property Value

Type: Stmpe821PwmRampRate
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM3RAMPRATERAMPUP Property

IRD

Stmpe821PWM3RAMPRATERAMPUP Property

PWM_3_RAMP_RATE: RAMP_UP

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmRampRate PWM3RAMPRATERAMPUP { get; set; }
Public Property PWM3RAMPRATERAMPUP As Stmpe821PwmRampRate
    Get
    Set
public:
property Stmpe821PwmRampRate PWM3RAMPRATERAMPUP {
    Stmpe821PwmRampRate get ();
    void set (Stmpe821PwmRampRate value);
}
member PWM3RAMPRATERAMPUP : Stmpe821PwmRampRate with get, set

Property Value

Type: Stmpe821PwmRampRate
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM3SETUPBRIGHTNESS Property

IRD

Stmpe821PWM3SETUPBRIGHTNESS Property

PWM_3_SETUP: BRIGHTNESS

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmSetupBrightness PWM3SETUPBRIGHTNESS { get; set; }
Public Property PWM3SETUPBRIGHTNESS As Stmpe821PwmSetupBrightness
    Get
    Set
public:
property Stmpe821PwmSetupBrightness PWM3SETUPBRIGHTNESS {
    Stmpe821PwmSetupBrightness get ();
    void set (Stmpe821PwmSetupBrightness value);
}
member PWM3SETUPBRIGHTNESS : Stmpe821PwmSetupBrightness with get, set

Property Value

Type: Stmpe821PwmSetupBrightness
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM3SETUPRAMPMODE Property

IRD

Stmpe821PWM3SETUPRAMPMODE Property

PWM_3_SETUP: RAMP_MODE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PWM3SETUPRAMPMODE { get; set; }
Public Property PWM3SETUPRAMPMODE As Byte
    Get
    Set
public:
property unsigned char PWM3SETUPRAMPMODE {
    unsigned char get ();
    void set (unsigned char value);
}
member PWM3SETUPRAMPMODE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWM3SETUPTIMING Property

IRD

Stmpe821PWM3SETUPTIMING Property

PWM_3_SETUP: TIMING (unit: mS)

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmSetupTiming PWM3SETUPTIMING { get; set; }
Public Property PWM3SETUPTIMING As Stmpe821PwmSetupTiming
    Get
    Set
public:
property Stmpe821PwmSetupTiming PWM3SETUPTIMING {
    Stmpe821PwmSetupTiming get ();
    void set (Stmpe821PwmSetupTiming value);
}
member PWM3SETUPTIMING : Stmpe821PwmSetupTiming with get, set

Property Value

Type: Stmpe821PwmSetupTiming
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMCTRL0FRAMEORDER Property

IRD

Stmpe821PWMCTRL0FRAMEORDER Property

PWM_CTRL_0: FRAME_ORDER

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmCtrlFrameOrder PWMCTRL0FRAMEORDER { get; set; }
Public Property PWMCTRL0FRAMEORDER As Stmpe821PwmCtrlFrameOrder
    Get
    Set
public:
property Stmpe821PwmCtrlFrameOrder PWMCTRL0FRAMEORDER {
    Stmpe821PwmCtrlFrameOrder get ();
    void set (Stmpe821PwmCtrlFrameOrder value);
}
member PWMCTRL0FRAMEORDER : Stmpe821PwmCtrlFrameOrder with get, set

Property Value

Type: Stmpe821PwmCtrlFrameOrder
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMCTRL0PERIOD0 Property

IRD

Stmpe821PWMCTRL0PERIOD0 Property

PWM_CTRL_0: PERIOD_0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmCtrlPeriod0 PWMCTRL0PERIOD0 { get; set; }
Public Property PWMCTRL0PERIOD0 As Stmpe821PwmCtrlPeriod0
    Get
    Set
public:
property Stmpe821PwmCtrlPeriod0 PWMCTRL0PERIOD0 {
    Stmpe821PwmCtrlPeriod0 get ();
    void set (Stmpe821PwmCtrlPeriod0 value);
}
member PWMCTRL0PERIOD0 : Stmpe821PwmCtrlPeriod0 with get, set

Property Value

Type: Stmpe821PwmCtrlPeriod0
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMCTRL0PERIOD1 Property

IRD

Stmpe821PWMCTRL0PERIOD1 Property

PWM_CTRL_0: PERIOD_1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmCtrlPeriod1 PWMCTRL0PERIOD1 { get; set; }
Public Property PWMCTRL0PERIOD1 As Stmpe821PwmCtrlPeriod1
    Get
    Set
public:
property Stmpe821PwmCtrlPeriod1 PWMCTRL0PERIOD1 {
    Stmpe821PwmCtrlPeriod1 get ();
    void set (Stmpe821PwmCtrlPeriod1 value);
}
member PWMCTRL0PERIOD1 : Stmpe821PwmCtrlPeriod1 with get, set

Property Value

Type: Stmpe821PwmCtrlPeriod1
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMCTRL0REPETITION Property

IRD

Stmpe821PWMCTRL0REPETITION Property

PWM_CTRL_0: REPETITION

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmCtrlRepetition PWMCTRL0REPETITION { get; set; }
Public Property PWMCTRL0REPETITION As Stmpe821PwmCtrlRepetition
    Get
    Set
public:
property Stmpe821PwmCtrlRepetition PWMCTRL0REPETITION {
    Stmpe821PwmCtrlRepetition get ();
    void set (Stmpe821PwmCtrlRepetition value);
}
member PWMCTRL0REPETITION : Stmpe821PwmCtrlRepetition with get, set

Property Value

Type: Stmpe821PwmCtrlRepetition
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMCTRL1FRAMEORDER Property

IRD

Stmpe821PWMCTRL1FRAMEORDER Property

PWM_CTRL_1: FRAME_ORDER

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmCtrlFrameOrder PWMCTRL1FRAMEORDER { get; set; }
Public Property PWMCTRL1FRAMEORDER As Stmpe821PwmCtrlFrameOrder
    Get
    Set
public:
property Stmpe821PwmCtrlFrameOrder PWMCTRL1FRAMEORDER {
    Stmpe821PwmCtrlFrameOrder get ();
    void set (Stmpe821PwmCtrlFrameOrder value);
}
member PWMCTRL1FRAMEORDER : Stmpe821PwmCtrlFrameOrder with get, set

Property Value

Type: Stmpe821PwmCtrlFrameOrder
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMCTRL1PERIOD0 Property

IRD

Stmpe821PWMCTRL1PERIOD0 Property

PWM_CTRL_1: PERIOD_0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmCtrlPeriod0 PWMCTRL1PERIOD0 { get; set; }
Public Property PWMCTRL1PERIOD0 As Stmpe821PwmCtrlPeriod0
    Get
    Set
public:
property Stmpe821PwmCtrlPeriod0 PWMCTRL1PERIOD0 {
    Stmpe821PwmCtrlPeriod0 get ();
    void set (Stmpe821PwmCtrlPeriod0 value);
}
member PWMCTRL1PERIOD0 : Stmpe821PwmCtrlPeriod0 with get, set

Property Value

Type: Stmpe821PwmCtrlPeriod0
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMCTRL1PERIOD1 Property

IRD

Stmpe821PWMCTRL1PERIOD1 Property

PWM_CTRL_1: PERIOD_1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmCtrlPeriod1 PWMCTRL1PERIOD1 { get; set; }
Public Property PWMCTRL1PERIOD1 As Stmpe821PwmCtrlPeriod1
    Get
    Set
public:
property Stmpe821PwmCtrlPeriod1 PWMCTRL1PERIOD1 {
    Stmpe821PwmCtrlPeriod1 get ();
    void set (Stmpe821PwmCtrlPeriod1 value);
}
member PWMCTRL1PERIOD1 : Stmpe821PwmCtrlPeriod1 with get, set

Property Value

Type: Stmpe821PwmCtrlPeriod1
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMCTRL1REPETITION Property

IRD

Stmpe821PWMCTRL1REPETITION Property

PWM_CTRL_1: REPETITION

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmCtrlRepetition PWMCTRL1REPETITION { get; set; }
Public Property PWMCTRL1REPETITION As Stmpe821PwmCtrlRepetition
    Get
    Set
public:
property Stmpe821PwmCtrlRepetition PWMCTRL1REPETITION {
    Stmpe821PwmCtrlRepetition get ();
    void set (Stmpe821PwmCtrlRepetition value);
}
member PWMCTRL1REPETITION : Stmpe821PwmCtrlRepetition with get, set

Property Value

Type: Stmpe821PwmCtrlRepetition
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMCTRL2FRAMEORDER Property

IRD

Stmpe821PWMCTRL2FRAMEORDER Property

PWM_CTRL_2: FRAME_ORDER

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmCtrlFrameOrder PWMCTRL2FRAMEORDER { get; set; }
Public Property PWMCTRL2FRAMEORDER As Stmpe821PwmCtrlFrameOrder
    Get
    Set
public:
property Stmpe821PwmCtrlFrameOrder PWMCTRL2FRAMEORDER {
    Stmpe821PwmCtrlFrameOrder get ();
    void set (Stmpe821PwmCtrlFrameOrder value);
}
member PWMCTRL2FRAMEORDER : Stmpe821PwmCtrlFrameOrder with get, set

Property Value

Type: Stmpe821PwmCtrlFrameOrder
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMCTRL2PERIOD0 Property

IRD

Stmpe821PWMCTRL2PERIOD0 Property

PWM_CTRL_2: PERIOD_0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmCtrlPeriod0 PWMCTRL2PERIOD0 { get; set; }
Public Property PWMCTRL2PERIOD0 As Stmpe821PwmCtrlPeriod0
    Get
    Set
public:
property Stmpe821PwmCtrlPeriod0 PWMCTRL2PERIOD0 {
    Stmpe821PwmCtrlPeriod0 get ();
    void set (Stmpe821PwmCtrlPeriod0 value);
}
member PWMCTRL2PERIOD0 : Stmpe821PwmCtrlPeriod0 with get, set

Property Value

Type: Stmpe821PwmCtrlPeriod0
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMCTRL2PERIOD1 Property

IRD

Stmpe821PWMCTRL2PERIOD1 Property

PWM_CTRL_2: PERIOD_1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmCtrlPeriod1 PWMCTRL2PERIOD1 { get; set; }
Public Property PWMCTRL2PERIOD1 As Stmpe821PwmCtrlPeriod1
    Get
    Set
public:
property Stmpe821PwmCtrlPeriod1 PWMCTRL2PERIOD1 {
    Stmpe821PwmCtrlPeriod1 get ();
    void set (Stmpe821PwmCtrlPeriod1 value);
}
member PWMCTRL2PERIOD1 : Stmpe821PwmCtrlPeriod1 with get, set

Property Value

Type: Stmpe821PwmCtrlPeriod1
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMCTRL2REPETITION Property

IRD

Stmpe821PWMCTRL2REPETITION Property

PWM_CTRL_2: REPETITION

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmCtrlRepetition PWMCTRL2REPETITION { get; set; }
Public Property PWMCTRL2REPETITION As Stmpe821PwmCtrlRepetition
    Get
    Set
public:
property Stmpe821PwmCtrlRepetition PWMCTRL2REPETITION {
    Stmpe821PwmCtrlRepetition get ();
    void set (Stmpe821PwmCtrlRepetition value);
}
member PWMCTRL2REPETITION : Stmpe821PwmCtrlRepetition with get, set

Property Value

Type: Stmpe821PwmCtrlRepetition
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMCTRL3FRAMEORDER Property

IRD

Stmpe821PWMCTRL3FRAMEORDER Property

PWM_CTRL_3: FRAME_ORDER

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmCtrlFrameOrder PWMCTRL3FRAMEORDER { get; set; }
Public Property PWMCTRL3FRAMEORDER As Stmpe821PwmCtrlFrameOrder
    Get
    Set
public:
property Stmpe821PwmCtrlFrameOrder PWMCTRL3FRAMEORDER {
    Stmpe821PwmCtrlFrameOrder get ();
    void set (Stmpe821PwmCtrlFrameOrder value);
}
member PWMCTRL3FRAMEORDER : Stmpe821PwmCtrlFrameOrder with get, set

Property Value

Type: Stmpe821PwmCtrlFrameOrder
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMCTRL3PERIOD0 Property

IRD

Stmpe821PWMCTRL3PERIOD0 Property

PWM_CTRL_3: PERIOD_0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmCtrlPeriod0 PWMCTRL3PERIOD0 { get; set; }
Public Property PWMCTRL3PERIOD0 As Stmpe821PwmCtrlPeriod0
    Get
    Set
public:
property Stmpe821PwmCtrlPeriod0 PWMCTRL3PERIOD0 {
    Stmpe821PwmCtrlPeriod0 get ();
    void set (Stmpe821PwmCtrlPeriod0 value);
}
member PWMCTRL3PERIOD0 : Stmpe821PwmCtrlPeriod0 with get, set

Property Value

Type: Stmpe821PwmCtrlPeriod0
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMCTRL3PERIOD1 Property

IRD

Stmpe821PWMCTRL3PERIOD1 Property

PWM_CTRL_3: PERIOD_1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmCtrlPeriod1 PWMCTRL3PERIOD1 { get; set; }
Public Property PWMCTRL3PERIOD1 As Stmpe821PwmCtrlPeriod1
    Get
    Set
public:
property Stmpe821PwmCtrlPeriod1 PWMCTRL3PERIOD1 {
    Stmpe821PwmCtrlPeriod1 get ();
    void set (Stmpe821PwmCtrlPeriod1 value);
}
member PWMCTRL3PERIOD1 : Stmpe821PwmCtrlPeriod1 with get, set

Property Value

Type: Stmpe821PwmCtrlPeriod1
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMCTRL3REPETITION Property

IRD

Stmpe821PWMCTRL3REPETITION Property

PWM_CTRL_3: REPETITION

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmCtrlRepetition PWMCTRL3REPETITION { get; set; }
Public Property PWMCTRL3REPETITION As Stmpe821PwmCtrlRepetition
    Get
    Set
public:
property Stmpe821PwmCtrlRepetition PWMCTRL3REPETITION {
    Stmpe821PwmCtrlRepetition get ();
    void set (Stmpe821PwmCtrlRepetition value);
}
member PWMCTRL3REPETITION : Stmpe821PwmCtrlRepetition with get, set

Property Value

Type: Stmpe821PwmCtrlRepetition
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMOFFOUTPUTOUT0 Property

IRD

Stmpe821PWMOFFOUTPUTOUT0 Property

PWM_OFF_OUTPUT: OUT0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmOffOutput PWMOFFOUTPUTOUT0 { get; set; }
Public Property PWMOFFOUTPUTOUT0 As Stmpe821PwmOffOutput
    Get
    Set
public:
property Stmpe821PwmOffOutput PWMOFFOUTPUTOUT0 {
    Stmpe821PwmOffOutput get ();
    void set (Stmpe821PwmOffOutput value);
}
member PWMOFFOUTPUTOUT0 : Stmpe821PwmOffOutput with get, set

Property Value

Type: Stmpe821PwmOffOutput
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMOFFOUTPUTOUT1 Property

IRD

Stmpe821PWMOFFOUTPUTOUT1 Property

PWM_OFF_OUTPUT: OUT1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmOffOutput PWMOFFOUTPUTOUT1 { get; set; }
Public Property PWMOFFOUTPUTOUT1 As Stmpe821PwmOffOutput
    Get
    Set
public:
property Stmpe821PwmOffOutput PWMOFFOUTPUTOUT1 {
    Stmpe821PwmOffOutput get ();
    void set (Stmpe821PwmOffOutput value);
}
member PWMOFFOUTPUTOUT1 : Stmpe821PwmOffOutput with get, set

Property Value

Type: Stmpe821PwmOffOutput
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMOFFOUTPUTOUT2 Property

IRD

Stmpe821PWMOFFOUTPUTOUT2 Property

PWM_OFF_OUTPUT: OUT2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmOffOutput PWMOFFOUTPUTOUT2 { get; set; }
Public Property PWMOFFOUTPUTOUT2 As Stmpe821PwmOffOutput
    Get
    Set
public:
property Stmpe821PwmOffOutput PWMOFFOUTPUTOUT2 {
    Stmpe821PwmOffOutput get ();
    void set (Stmpe821PwmOffOutput value);
}
member PWMOFFOUTPUTOUT2 : Stmpe821PwmOffOutput with get, set

Property Value

Type: Stmpe821PwmOffOutput
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.PWMOFFOUTPUTOUT3 Property

IRD

Stmpe821PWMOFFOUTPUTOUT3 Property

PWM_OFF_OUTPUT: OUT3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821PwmOffOutput PWMOFFOUTPUTOUT3 { get; set; }
Public Property PWMOFFOUTPUTOUT3 As Stmpe821PwmOffOutput
    Get
    Set
public:
property Stmpe821PwmOffOutput PWMOFFOUTPUTOUT3 {
    Stmpe821PwmOffOutput get ();
    void set (Stmpe821PwmOffOutput value);
}
member PWMOFFOUTPUTOUT3 : Stmpe821PwmOffOutput with get, set

Property Value

Type: Stmpe821PwmOffOutput
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.REFERENCEDELAY Property

IRD

Stmpe821REFERENCEDELAY Property

REFERENCE_DELAY

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte REFERENCEDELAY { get; set; }
Public Property REFERENCEDELAY As Byte
    Get
    Set
public:
property unsigned char REFERENCEDELAY {
    unsigned char get ();
    void set (unsigned char value);
}
member REFERENCEDELAY : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.STRENGTH0 Property

IRD

Stmpe821STRENGTH0 Property

STRENGTH 0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTH0 { get; }
Public ReadOnly Property STRENGTH0 As Byte
    Get
public:
property unsigned char STRENGTH0 {
    unsigned char get ();
}
member STRENGTH0 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.STRENGTH1 Property

IRD

Stmpe821STRENGTH1 Property

STRENGTH 1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTH1 { get; }
Public ReadOnly Property STRENGTH1 As Byte
    Get
public:
property unsigned char STRENGTH1 {
    unsigned char get ();
}
member STRENGTH1 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.STRENGTH2 Property

IRD

Stmpe821STRENGTH2 Property

STRENGTH 2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTH2 { get; }
Public ReadOnly Property STRENGTH2 As Byte
    Get
public:
property unsigned char STRENGTH2 {
    unsigned char get ();
}
member STRENGTH2 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.STRENGTH3 Property

IRD

Stmpe821STRENGTH3 Property

STRENGTH 3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTH3 { get; }
Public ReadOnly Property STRENGTH3 As Byte
    Get
public:
property unsigned char STRENGTH3 {
    unsigned char get ();
}
member STRENGTH3 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.STRENGTH4 Property

IRD

Stmpe821STRENGTH4 Property

STRENGTH 4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTH4 { get; }
Public ReadOnly Property STRENGTH4 As Byte
    Get
public:
property unsigned char STRENGTH4 {
    unsigned char get ();
}
member STRENGTH4 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.STRENGTH5 Property

IRD

Stmpe821STRENGTH5 Property

STRENGTH 5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTH5 { get; }
Public ReadOnly Property STRENGTH5 As Byte
    Get
public:
property unsigned char STRENGTH5 {
    unsigned char get ();
}
member STRENGTH5 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.STRENGTH6 Property

IRD

Stmpe821STRENGTH6 Property

STRENGTH 6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTH6 { get; }
Public ReadOnly Property STRENGTH6 As Byte
    Get
public:
property unsigned char STRENGTH6 {
    unsigned char get ();
}
member STRENGTH6 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.STRENGTH7 Property

IRD

Stmpe821STRENGTH7 Property

STRENGTH 7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTH7 { get; }
Public ReadOnly Property STRENGTH7 As Byte
    Get
public:
property unsigned char STRENGTH7 {
    unsigned char get ();
}
member STRENGTH7 : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.STRENGTHTHRESHOLD0 Property

IRD

Stmpe821STRENGTHTHRESHOLD0 Property

STRENGTH_THRESHOLD 0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTHTHRESHOLD0 { get; set; }
Public Property STRENGTHTHRESHOLD0 As Byte
    Get
    Set
public:
property unsigned char STRENGTHTHRESHOLD0 {
    unsigned char get ();
    void set (unsigned char value);
}
member STRENGTHTHRESHOLD0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.STRENGTHTHRESHOLD1 Property

IRD

Stmpe821STRENGTHTHRESHOLD1 Property

STRENGTH_THRESHOLD 1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTHTHRESHOLD1 { get; set; }
Public Property STRENGTHTHRESHOLD1 As Byte
    Get
    Set
public:
property unsigned char STRENGTHTHRESHOLD1 {
    unsigned char get ();
    void set (unsigned char value);
}
member STRENGTHTHRESHOLD1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.STRENGTHTHRESHOLD2 Property

IRD

Stmpe821STRENGTHTHRESHOLD2 Property

STRENGTH_THRESHOLD 2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTHTHRESHOLD2 { get; set; }
Public Property STRENGTHTHRESHOLD2 As Byte
    Get
    Set
public:
property unsigned char STRENGTHTHRESHOLD2 {
    unsigned char get ();
    void set (unsigned char value);
}
member STRENGTHTHRESHOLD2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.STRENGTHTHRESHOLD3 Property

IRD

Stmpe821STRENGTHTHRESHOLD3 Property

STRENGTH_THRESHOLD 3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTHTHRESHOLD3 { get; set; }
Public Property STRENGTHTHRESHOLD3 As Byte
    Get
    Set
public:
property unsigned char STRENGTHTHRESHOLD3 {
    unsigned char get ();
    void set (unsigned char value);
}
member STRENGTHTHRESHOLD3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.STRENGTHTHRESHOLD4 Property

IRD

Stmpe821STRENGTHTHRESHOLD4 Property

STRENGTH_THRESHOLD 4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTHTHRESHOLD4 { get; set; }
Public Property STRENGTHTHRESHOLD4 As Byte
    Get
    Set
public:
property unsigned char STRENGTHTHRESHOLD4 {
    unsigned char get ();
    void set (unsigned char value);
}
member STRENGTHTHRESHOLD4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.STRENGTHTHRESHOLD5 Property

IRD

Stmpe821STRENGTHTHRESHOLD5 Property

STRENGTH_THRESHOLD 5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTHTHRESHOLD5 { get; set; }
Public Property STRENGTHTHRESHOLD5 As Byte
    Get
    Set
public:
property unsigned char STRENGTHTHRESHOLD5 {
    unsigned char get ();
    void set (unsigned char value);
}
member STRENGTHTHRESHOLD5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.STRENGTHTHRESHOLD6 Property

IRD

Stmpe821STRENGTHTHRESHOLD6 Property

STRENGTH_THRESHOLD 6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTHTHRESHOLD6 { get; set; }
Public Property STRENGTHTHRESHOLD6 As Byte
    Get
    Set
public:
property unsigned char STRENGTHTHRESHOLD6 {
    unsigned char get ();
    void set (unsigned char value);
}
member STRENGTHTHRESHOLD6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.STRENGTHTHRESHOLD7 Property

IRD

Stmpe821STRENGTHTHRESHOLD7 Property

STRENGTH_THRESHOLD 7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte STRENGTHTHRESHOLD7 { get; set; }
Public Property STRENGTHTHRESHOLD7 As Byte
    Get
    Set
public:
property unsigned char STRENGTHTHRESHOLD7 {
    unsigned char get ();
    void set (unsigned char value);
}
member STRENGTHTHRESHOLD7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.SYSCFG1HIBERNATE Property

IRD

Stmpe821SYSCFG1HIBERNATE Property

SYS_CFG_1: HIBERNATE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCFG1HIBERNATE { get; set; }
Public Property SYSCFG1HIBERNATE As Byte
    Get
    Set
public:
property unsigned char SYSCFG1HIBERNATE {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCFG1HIBERNATE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.SYSCFG1SLEEP Property

IRD

Stmpe821SYSCFG1SLEEP Property

SYS_CFG_1: SLEEP

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCFG1SLEEP { get; set; }
Public Property SYSCFG1SLEEP As Byte
    Get
    Set
public:
property unsigned char SYSCFG1SLEEP {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCFG1SLEEP : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.SYSCFG1SOFTRESET Property

IRD

Stmpe821SYSCFG1SOFTRESET Property

SYS_CFG_1: SOFT_RESET

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCFG1SOFTRESET { get; set; }
Public Property SYSCFG1SOFTRESET As Byte
    Get
    Set
public:
property unsigned char SYSCFG1SOFTRESET {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCFG1SOFTRESET : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.SYSCFG1WARMRESET Property

IRD

Stmpe821SYSCFG1WARMRESET Property

SYS_CFG_1: WARM_RESET

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCFG1WARMRESET { get; set; }
Public Property SYSCFG1WARMRESET As Byte
    Get
    Set
public:
property unsigned char SYSCFG1WARMRESET {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCFG1WARMRESET : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.SYSCFG2FIFOCLOCKDISABLE Property

IRD

Stmpe821SYSCFG2FIFOCLOCKDISABLE Property

SYS_CFG_2: FIFO_CLOCK_DISABLE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCFG2FIFOCLOCKDISABLE { get; set; }
Public Property SYSCFG2FIFOCLOCKDISABLE As Byte
    Get
    Set
public:
property unsigned char SYSCFG2FIFOCLOCKDISABLE {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCFG2FIFOCLOCKDISABLE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.SYSCFG2GPIOCLOCKDISABLE Property

IRD

Stmpe821SYSCFG2GPIOCLOCKDISABLE Property

SYS_CFG_2: GPIO CLOCK DISABLE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCFG2GPIOCLOCKDISABLE { get; set; }
Public Property SYSCFG2GPIOCLOCKDISABLE As Byte
    Get
    Set
public:
property unsigned char SYSCFG2GPIOCLOCKDISABLE {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCFG2GPIOCLOCKDISABLE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.SYSCFG2PWMCLOCKDISABLE Property

IRD

Stmpe821SYSCFG2PWMCLOCKDISABLE Property

SYS_CFG_2: PWM CLOCK DISABLE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCFG2PWMCLOCKDISABLE { get; set; }
Public Property SYSCFG2PWMCLOCKDISABLE As Byte
    Get
    Set
public:
property unsigned char SYSCFG2PWMCLOCKDISABLE {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCFG2PWMCLOCKDISABLE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.SYSCFG2SENSORCLOCK Property

IRD

Stmpe821SYSCFG2SENSORCLOCK Property

SYS_CFG_2: SENSOR_CLOCK

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Stmpe821SysCfg2SensorClock SYSCFG2SENSORCLOCK { get; set; }
Public Property SYSCFG2SENSORCLOCK As Stmpe821SysCfg2SensorClock
    Get
    Set
public:
property Stmpe821SysCfg2SensorClock SYSCFG2SENSORCLOCK {
    Stmpe821SysCfg2SensorClock get ();
    void set (Stmpe821SysCfg2SensorClock value);
}
member SYSCFG2SENSORCLOCK : Stmpe821SysCfg2SensorClock with get, set

Property Value

Type: Stmpe821SysCfg2SensorClock
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.SYSCFG2TOUCHCLOCKDISABLE Property

IRD

Stmpe821SYSCFG2TOUCHCLOCKDISABLE Property

SYS_CFG_2: TOUCH CLOCK DISABLE

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SYSCFG2TOUCHCLOCKDISABLE { get; set; }
Public Property SYSCFG2TOUCHCLOCKDISABLE As Byte
    Get
    Set
public:
property unsigned char SYSCFG2TOUCHCLOCKDISABLE {
    unsigned char get ();
    void set (unsigned char value);
}
member SYSCFG2TOUCHCLOCKDISABLE : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.TINTPENDINGEOC Property

IRD

Stmpe821TINTPENDINGEOC Property

TINT_PENDING: EOC

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TINTPENDINGEOC { get; }
Public ReadOnly Property TINTPENDINGEOC As Byte
    Get
public:
property unsigned char TINTPENDINGEOC {
    unsigned char get ();
}
member TINTPENDINGEOC : byte with get

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.TVR0 Property

IRD

Stmpe821TVR0 Property

TVR 0

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR0 { get; set; }
Public Property TVR0 As Byte
    Get
    Set
public:
property unsigned char TVR0 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.TVR1 Property

IRD

Stmpe821TVR1 Property

TVR 1

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR1 { get; set; }
Public Property TVR1 As Byte
    Get
    Set
public:
property unsigned char TVR1 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.TVR2 Property

IRD

Stmpe821TVR2 Property

TVR 2

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR2 { get; set; }
Public Property TVR2 As Byte
    Get
    Set
public:
property unsigned char TVR2 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.TVR3 Property

IRD

Stmpe821TVR3 Property

TVR 3

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR3 { get; set; }
Public Property TVR3 As Byte
    Get
    Set
public:
property unsigned char TVR3 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.TVR4 Property

IRD

Stmpe821TVR4 Property

TVR 4

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR4 { get; set; }
Public Property TVR4 As Byte
    Get
    Set
public:
property unsigned char TVR4 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.TVR5 Property

IRD

Stmpe821TVR5 Property

TVR 5

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR5 { get; set; }
Public Property TVR5 As Byte
    Get
    Set
public:
property unsigned char TVR5 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.TVR6 Property

IRD

Stmpe821TVR6 Property

TVR 6

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR6 { get; set; }
Public Property TVR6 As Byte
    Get
    Set
public:
property unsigned char TVR6 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.TVR7 Property

IRD

Stmpe821TVR7 Property

TVR 7

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte TVR7 { get; set; }
Public Property TVR7 As Byte
    Get
    Set
public:
property unsigned char TVR7 {
    unsigned char get ();
    void set (unsigned char value);
}
member TVR7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821 Methods

The Stmpe821 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.Flush Method

IRD

Stmpe821Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Stmpe821 Class
telos.Ird.ST Namespace


Stmpe821.Enable1Disable0 Enumeration

IRD

Stmpe821Enable1Disable0 Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum Enable1Disable0
Public Enumeration Enable1Disable0
public enum class Enable1Disable0
type Enable1Disable0
Members
Member name | Value | Description
Enabled | 1 | Enabled
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.ST Namespace


Stmpe821.FeatureSelAfs Enumeration

IRD

Stmpe821FeatureSelAfs Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum FeatureSelAfs
Public Enumeration FeatureSelAfs
public enum class FeatureSelAfs
type FeatureSelAfs
Members
Member name | Value | Description
AFSMode1 | 1 | AFS Mode 1
AFSMode2 | 2 | AFS Mode 2
AFSMode3 | 3 | AFS Mode 3
See Also

Reference

telos.Ird.ST Namespace


Stmpe821.GpioDir Enumeration

IRD

Stmpe821GpioDir Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum GpioDir
Public Enumeration GpioDir
public enum class GpioDir
type GpioDir
Members
Member name | Value | Description
Input | 0 | Input
Output | 1 | Output
See Also

Reference

telos.Ird.ST Namespace


Stmpe821.GpioFunct Enumeration

IRD

Stmpe821GpioFunct Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum GpioFunct
Public Enumeration GpioFunct
public enum class GpioFunct
type GpioFunct
Members
Member name | Value | Description
GPIO | 1 | GPIO
Touchkey | 0 | Touchkey
See Also

Reference

telos.Ird.ST Namespace


Stmpe821.IntCtrlIntEn Enumeration

IRD

Stmpe821IntCtrlIntEn Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IntCtrlIntEn
Public Enumeration IntCtrlIntEn
public enum class IntCtrlIntEn
type IntCtrlIntEn
Members
Member name | Value | Description
AllInterruptsDisabled | 0 | All Interrupts: Disabled
AllInterruptsEnabled | 1 | All Interrupts: Enabled
See Also

Reference

telos.Ird.ST Namespace


Stmpe821.IntCtrlPolarity Enumeration

IRD

Stmpe821IntCtrlPolarity Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IntCtrlPolarity
Public Enumeration IntCtrlPolarity
public enum class IntCtrlPolarity
type IntCtrlPolarity
Members
Member name | Value | Description
ActiveLow | 0 | Active Low
ActiveHigh | 1 | Active High
See Also

Reference

telos.Ird.ST Namespace


Stmpe821.IntCtrlType Enumeration

IRD

Stmpe821IntCtrlType Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum IntCtrlType
Public Enumeration IntCtrlType
public enum class IntCtrlType
type IntCtrlType
Members
Member name | Value | Description
LevelTrigger | 0 | Level Trigger
EdgeTrigger | 1 | Edge Trigger
See Also

Reference

telos.Ird.ST Namespace


Stmpe821.PwmCtrlFrameOrder Enumeration

IRD

Stmpe821PwmCtrlFrameOrder Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum PwmCtrlFrameOrder
Public Enumeration PwmCtrlFrameOrder
public enum class PwmCtrlFrameOrder
type PwmCtrlFrameOrder
Members
Member name | Value | Description
PERIOD0First | 0 | PERIOD_0 First
PERIOD1First | 1 | PERIOD_1 First
See Also

Reference

telos.Ird.ST Namespace


Stmpe821.PwmCtrlPeriod0 Enumeration

IRD

Stmpe821PwmCtrlPeriod0 Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum PwmCtrlPeriod0
Public Enumeration PwmCtrlPeriod0
public enum class PwmCtrlPeriod0
type PwmCtrlPeriod0
Members
Member name | Value | Description
Value_1TimeUnit | 0 | 1 Time Unit
Value_2TimeUnit | 1 | 2 Time Unit
Value_3TimeUnit | 2 | 3 Time Unit
Value_4TimeUnit | 3 | 4 Time Unit
See Also

Reference

telos.Ird.ST Namespace


Stmpe821.PwmCtrlPeriod1 Enumeration

IRD

Stmpe821PwmCtrlPeriod1 Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum PwmCtrlPeriod1
Public Enumeration PwmCtrlPeriod1
public enum class PwmCtrlPeriod1
type PwmCtrlPeriod1
Members
Member name | Value | Description
Value_0TimeUnitNoOFFPeriod | 0 | 0 Time Unit (No OFF Period)
Value_1TimeUnit | 1 | 1 Time Unit
Value_2TimeUnit | 2 | 2 Time Unit
Value_3TimeUnit | 3 | 3 Time Unit
See Also

Reference

telos.Ird.ST Namespace


Stmpe821.PwmCtrlRepetition Enumeration

IRD

Stmpe821PwmCtrlRepetition Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum PwmCtrlRepetition
Public Enumeration PwmCtrlRepetition
public enum class PwmCtrlRepetition
type PwmCtrlRepetition
Members
Member name | Value | Description
Infinite | 0 | Infinite
Value_1Pair | 1 | 1 Pair
Value_2Pairs | 2 | 2 Pairs
Value_3Pairs | 3 | 3 Pairs
Value_4Pairs | 4 | 4 Pairs
Value_5Pairs | 5 | 5 Pairs
Value_6Pairs | 6 | 6 Pairs
Value_7Pairs | 7 | 7 Pairs
See Also

Reference

telos.Ird.ST Namespace


Stmpe821.PwmOffOutput Enumeration

IRD

Stmpe821PwmOffOutput Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum PwmOffOutput
Public Enumeration PwmOffOutput
public enum class PwmOffOutput
type PwmOffOutput
Members
Member name | Value | Description
Output1 | 1 | Output "1"
Output0 | 0 | Output "0"
See Also

Reference

telos.Ird.ST Namespace


Stmpe821.PwmRampRate Enumeration

IRD

Stmpe821PwmRampRate Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum PwmRampRate
Public Enumeration PwmRampRate
public enum class PwmRampRate
type PwmRampRate
Members
Member name | Value | Description
Value_14 | 0 | 1/4
Value_18 | 1 | 1/8
Value_116 | 2 | 1/16
Value_132 | 3 | 1/32
Value_164 | 4 | 1/64
Value_1128 | 5 | 1/128
See Also

Reference

telos.Ird.ST Namespace


Stmpe821.PwmSetupBrightness Enumeration

IRD

Stmpe821PwmSetupBrightness Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum PwmSetupBrightness
Public Enumeration PwmSetupBrightness
public enum class PwmSetupBrightness
type PwmSetupBrightness
Members
Member name | Value | Description
Value_115 | 0 | 1:15
Value_214 | 1 | 2:14
Value_313 | 2 | 3:13
Value_412 | 3 | 4:12
Value_511 | 4 | 5:11
Value_610 | 5 | 6:10
Value_79 | 6 | 7:9
Value_88 | 7 | 8:8
Value_97 | 8 | 9:7
Value_106 | 9 | 10:6
Value_115__1 | 10 | 11:5
Value_124 | 11 | 12:4
Value_133 | 12 | 13:3
Value_142 | 13 | 14:2
Value_151 | 14 | 15:1
Value_160 | 15 | 16:0
See Also

Reference

telos.Ird.ST Namespace


Stmpe821.PwmSetupTiming Enumeration

IRD

Stmpe821PwmSetupTiming Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum PwmSetupTiming
Public Enumeration PwmSetupTiming
public enum class PwmSetupTiming
type PwmSetupTiming
Members
Member name | Value | Description
Value_20 | 0 | 20
Value_40 | 1 | 40
Value_80 | 2 | 80
Value_160 | 3 | 160
Value_320 | 4 | 320
Value_640 | 5 | 640
Value_1280 | 6 | 1280
Value_2560 | 7 | 2560
See Also

Reference

telos.Ird.ST Namespace


Stmpe821.SysCfg2SensorClock Enumeration

IRD

Stmpe821SysCfg2SensorClock Enumeration

Namespace: telos.Ird.ST
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum SysCfg2SensorClock
Public Enumeration SysCfg2SensorClock
public enum class SysCfg2SensorClock
type SysCfg2SensorClock
Members
Member name | Value | Description
Divider1 | 0 | Divider = 1
Divider2 | 1 | Divider = 2
Divider4 | 2 | Divider = 4
Divider8 | 3 | Divider = 8
Divider16 | 4 | Divider = 16
See Also

Reference

telos.Ird.ST Namespace


telos.Ird.TexasInstruments Namespace

Classes
 | Class | Description
Public class | Amc6821 | Texas Instruments: AMC 6821
Public class | Dsd1793 | Texas Instruments: DSD 1793
Public class | Dsd1794a | Texas Instruments: DSD 1794A
Public class | Lm49321 | Texas Instruments: LM 49321
Public class | Lm49352 | Texas Instruments: LM 49352
Public class | Lm4937 | Texas Instruments: LM 4937
Public class | Pca9534 | Texas Instruments: PCA 9534
Public class | Pca9535 | Texas Instruments: PCA 9535
Public class | Pca9536 | Texas Instruments: PCA 9536
Public class | Pca9539 | Texas Instruments: PCA 9539
Public class | Pca9543a | Texas Instruments: PCA 9543 A
Public class | Pca9545a | Texas Instruments: PCA 9545 A
Public class | Pca9546a | Texas Instruments: PCA 9546 A
Public class | Pca9554a | Texas Instruments: PCA 9554 A
Public class | Pca9555 | Texas Instruments: PCA 9555
Public class | Pca9557 | Texas Instruments: PCA 9557
Public class | Pcm1680 | Texas Instruments: PCM 1680
Public class | Pcm1681Q1 | Texas Instruments: PCM 1681-Q1
Public class | Pcm1690Q1 | Texas Instruments: PCM 1690-Q1
Public class | Pcm1774 | Texas Instruments: PCM 1774
Public class | Pcm1789Q1 | Texas Instruments: PCM 1789-Q1
Public class | Pcm1791a | Texas Instruments: PCM 1791A
Public class | Pcm1792a | Texas Instruments: PCM 1792A
Public class | Pcm1795 | Texas Instruments: PCM 1795
Public class | Pcm1796 | Texas Instruments: PCM 1796
Public class | Pcm1851a | Texas Instruments: PCM 1850A / 1851A
Public class | Pcm3060 | Texas Instruments: PCM 3060
Public class | Pcm3168a | Texas Instruments: PCM 3168A
Public class | Tca6408 | Texas Instruments: TCA 6408
Public class | Tca6416 | Texas Instruments: TCA 6416
Public class | Tca6424 | Texas Instruments: TCA 6424
Public class | Tca6507 | Texas Instruments: TCA 6507
Public class | Tlv320aic12k | Texas Instruments: TLV 320AIC12
Public class | Tlv320aic22c | Texas Instruments: TLV 320AIC22C
Public class | Tlv320dac23 | Texas Instruments: TLV 320DAC23
Public class | Tmp100 | Texas Instruments: TMP 100
Public class | Tmp101 | Texas Instruments: TMP 101
Public class | Tmp105 | Texas Instruments: TMP 105
Public class | Tmp106 | Texas Instruments: TMP 106
Public class | Tmp112 | Texas Instruments: TMP 112
Public class | Tmp175 | Texas Instruments: TMP 175
Public class | Tmp275 | Texas Instruments: TMP 275
Public class | Tmp400 | Texas Instruments: TMP 400
Public class | Tmp401 | Texas Instruments: TMP 401
Public class | Tmp421 | Texas Instruments: TMP 421
Public class | Tmp422 | Texas Instruments: TMP 422
Public class | Tmp423 | Texas Instruments: TMP 423
Public class | Tmp431 | Texas Instruments: TMP 431
Public class | Tmp432 | Texas Instruments: TMP 432
Public class | Tmp75 | Texas Instruments: TMP 75
Enumerations
 | Enumeration | Description
Public enumeration | Amc6821TypeConfigMode |
Public enumeration | Amc6821TypeConfigPspr |
Public enumeration | Amc6821TypeConfigTachFast |
Public enumeration | Amc6821TypeDcyRampBits |
Public enumeration | Amc6821TypeDcyRampRampe |
Public enumeration | Amc6821TypeDcyRampRate |
Public enumeration | Amc6821TypeEnabledDisabled |
Public enumeration | Amc6821TypeFanCharacteristicsFspd |
Public enumeration | Amc6821TypeFanCharacteristicsPwm |
Public enumeration | Amc6821TypeFanCharacteristicsStime |
Public enumeration | Amc6821TypeFdrc |
Public enumeration | Amc6821TypeReset |
Public enumeration | Amc6821TypeSlopeBits |
Public enumeration | Amc6821TypeStatusFans |
Public enumeration | Amc6821TypeStatusLpsv |
Public enumeration | Amc6821TypeStatusLtc |
Public enumeration | Amc6821TypeStatusLth |
Public enumeration | Amc6821TypeStatusLTherm |
Public enumeration | Amc6821TypeStatusLtl |
Public enumeration | Amc6821TypeStatusRpmAlarm |
Public enumeration | Amc6821TypeStatusRtc |
Public enumeration | Amc6821TypeStatusRtf |
Public enumeration | Amc6821TypeStatusRth |
Public enumeration | Amc6821TypeStatusRTherm |
Public enumeration | Amc6821TypeStatusRtl |
Public enumeration | Amc6821TypeStatusThermIn |
Public enumeration | Dsd1793TypeAttenuationLevel |
Public enumeration | Dsd1793TypeAudioControlAttenuationLoad |
Public enumeration | Dsd1793TypeAudioControlDataFormat |
Public enumeration | Dsd1793TypeAudioControlDeEmphasis |
Public enumeration | Dsd1793TypeAudioControlMute |
Public enumeration | Dsd1793TypeAudioControlSampling |
Public enumeration | Dsd1793TypeOperationControlBypass |
Public enumeration | Dsd1793TypeOperationControlDac |
Public enumeration | Dsd1793TypeOperationControlFilter |
Public enumeration | Dsd1793TypeOperationControlRate |
Public enumeration | Dsd1793TypeOperationControlReversal |
Public enumeration | Dsd1793TypeOperationControlZeroDetect |
Public enumeration | Dsd1793TypeSignalControlChannel |
Public enumeration | Dsd1793TypeSignalControlFilter |
Public enumeration | Dsd1793TypeSignalControlMode |
Public enumeration | Dsd1793TypeSignalControlMono |
Public enumeration | Dsd1793TypeSignalControlReset |
Public enumeration | Dsd1793TypeSignalControlSpeed |
Public enumeration | Dsd1793TypeZeroDetectionFlagLeft |
Public enumeration | Dsd1793TypeZeroDetectionFlagRight |
Public enumeration | Dsd1793TypeZeroOutputDsd |
Public enumeration | Dsd1793TypeZeroOutputPcm |
Public enumeration | Dsd1794aTypeAttenuationLevel |
Public enumeration | Dsd1794aTypeAudioControlAttenuationLoad |
Public enumeration | Dsd1794aTypeAudioControlDataFormat |
Public enumeration | Dsd1794aTypeAudioControlDeEmphasis |
Public enumeration | Dsd1794aTypeAudioControlMute |
Public enumeration | Dsd1794aTypeAudioControlSampling |
Public enumeration | Dsd1794aTypeOperationControlBypass |
Public enumeration | Dsd1794aTypeOperationControlDac |
Public enumeration | Dsd1794aTypeOperationControlFilter |
Public enumeration | Dsd1794aTypeOperationControlRate |
Public enumeration | Dsd1794aTypeOperationControlReversal |
Public enumeration | Dsd1794aTypeOperationControlZeroDetect |
Public enumeration | Dsd1794aTypeOperationControlZeroFlag |
Public enumeration | Dsd1794aTypeSignalControlChannel |
Public enumeration | Dsd1794aTypeSignalControlFilter |
Public enumeration | Dsd1794aTypeSignalControlMode |
Public enumeration | Dsd1794aTypeSignalControlMono |
Public enumeration | Dsd1794aTypeSignalControlReset |
Public enumeration | Dsd1794aTypeSignalControlSpeed |
Public enumeration | Dsd1794aTypeZeroDetectionFlagLeft |
Public enumeration | Dsd1794aTypeZeroDetectionFlagRight |
Public enumeration | Dsd1794aTypeZeroOutputDsd |
Public enumeration | Dsd1794aTypeZeroOutputPcm |
Public enumeration | Lm49321TypeClocksFast |
Public enumeration | Lm49321TypeClocksPllEn |
Public enumeration | Lm49321TypeClocksPllIn |
Public enumeration | Lm49321TypeClocksRDivider |
Public enumeration | Lm49321TypeClocksSelect |
Public enumeration | Lm49321TypeDacGainDigital |
Public enumeration | Lm49321TypeDacSetupCust |
Public enumeration | Lm49321TypeDacSetupDitherAl |
Public enumeration | Lm49321TypeDacSetupDitherOff |
Public enumeration | Lm49321TypeDacSetupMode |
Public enumeration | Lm49321TypeDacSetupMuteL |
Public enumeration | Lm49321TypeDacSetupMuteR |
Public enumeration | Lm49321TypeInterfaceFast |
Public enumeration | Lm49321TypeInterfaceMode |
Public enumeration | Lm49321TypeInterfaceRes |
Public enumeration | Lm49321TypeInterfaceSelect |
Public enumeration | Lm49321TypeModeControlMixer |
Public enumeration | Lm49321TypeModeControlOcl |
Public enumeration | Lm49321TypeOutputControlDac |
Public enumeration | Lm49321TypeOutputControlEarpiece |
Public enumeration | Lm49321TypeOutputControlHpl |
Public enumeration | Lm49321TypeOutputControlHpr |
Public enumeration | Lm49321TypeOutputControlMono |
Public enumeration | Lm49321TypeOutputControlSpeaker |
Public enumeration | Lm49321TypeOutputControlStereoIn |
Public enumeration | Lm49321TypeOutputControlStereoOut |
Public enumeration | Lm49321TypePllMDivider |
Public enumeration | Lm49321TypePllNDivider |
Public enumeration | Lm49321TypePllNModDither |
Public enumeration | Lm49321TypePllNModVco |
Public enumeration | Lm49321TypePllPDivider |
Public enumeration | Lm49321TypeVolume |
Public enumeration | Lm49352TypeAdcAlc1Limiter |
Public enumeration | Lm49352TypeAdcAlc1Lsel |
Public enumeration | Lm49352TypeAdcAlc1Ovr |
Public enumeration | Lm49352TypeAdcAlc1Rsel |
Public enumeration | Lm49352TypeAdcAlc1SampleRate |
Public enumeration | Lm49352TypeAdcAlc1Stereo |
Public enumeration | Lm49352TypeAdcAlc2NoiseGate |
Public enumeration | Lm49352TypeAdcAlc4AttackRate |
Public enumeration | Lm49352TypeAdcAlc5DecayRate |
Public enumeration | Lm49352TypeAdcAlc5PkDecayRate |
Public enumeration | Lm49352TypeAdcAlc6HoldTime |
Public enumeration | Lm49352TypeAdcBasicClock |
Public enumeration | Lm49352TypeAdcBasicDspOnly |
Public enumeration | Lm49352TypeAdcBasicMono |
Public enumeration | Lm49352TypeAdcBasicMuteL |
Public enumeration | Lm49352TypeAdcBasicMuteR |
Public enumeration | Lm49352TypeAdcBasicOsr |
Public enumeration | Lm49352TypeAdcEqBand1EqLevel |
Public enumeration | Lm49352TypeAdcEqBand1Freq |
Public enumeration | Lm49352TypeAdcEqBand2Freq |
Public enumeration | Lm49352TypeAdcEqBand2Q |
Public enumeration | Lm49352TypeAdcEqBand3Freq |
Public enumeration | Lm49352TypeAdcEqBand4Freq |
Public enumeration | Lm49352TypeAdcEqBand5Freq |
Public enumeration | Lm49352TypeAdcFxAlc |
Public enumeration | Lm49352TypeAdcFxEq |
Public enumeration | Lm49352TypeAdcFxHpf |
Public enumeration | Lm49352TypeAdcFxPk |
Public enumeration | Lm49352TypeAdcFxSclp |
Public enumeration | Lm49352TypeAdcInputAux |
Public enumeration | Lm49352TypeAdcInputDacl |
Public enumeration | Lm49352TypeAdcInputDacr |
Public enumeration | Lm49352TypeAdcInputMicl |
Public enumeration | Lm49352TypeAdcInputMicr |
Public enumeration | Lm49352TypeAdcInputMono |
Public enumeration | Lm49352TypeAdcLLevelStereo |
Public enumeration | Lm49352TypeAdcMixerLevel |
Public enumeration | Lm49352TypeAdcMixerStereo |
Public enumeration | Lm49352TypeAdcSoftclip1Knee |
Public enumeration | Lm49352TypeAdcSoftclip1Threshold |
Public enumeration | Lm49352TypeAdcSoftclip2ClipRatio |
Public enumeration | Lm49352TypeAudioPort1BasicClock |
Public enumeration | Lm49352TypeAudioPort1BasicClockPhase |
Public enumeration | Lm49352TypeAudioPort1BasicInvert |
Public enumeration | Lm49352TypeAudioPort1BasicRx |
Public enumeration | Lm49352TypeAudioPort1BasicStereo |
Public enumeration | Lm49352TypeAudioPort1BasicSync |
Public enumeration | Lm49352TypeAudioPort1BasicSyncPhase |
Public enumeration | Lm49352TypeAudioPort1BasicTx |
Public enumeration | Lm49352TypeAudioPort1ClkGen1Divider |
Public enumeration | Lm49352TypeAudioPort1ClkGen1Sel |
Public enumeration | Lm49352TypeAudioPort1ClkGen2SynthDenom |
Public enumeration | Lm49352TypeAudioPort1ClkGen2SynthNum |
Public enumeration | Lm49352TypeAudioPort1LSel |
Public enumeration | Lm49352TypeAudioPort1Mono |
Public enumeration | Lm49352TypeAudioPort1RSel |
Public enumeration | Lm49352TypeAudioPort1RxCompand |
Public enumeration | Lm49352TypeAudioPort1RxLaw |
Public enumeration | Lm49352TypeAudioPort1RxMode |
Public enumeration | Lm49352TypeAudioPort1Swap |
Public enumeration | Lm49352TypeAudioPort1SyncRate |
Public enumeration | Lm49352TypeAudioPort1SyncWidth |
Public enumeration | Lm49352TypeAudioPort1WidthExtra |
Public enumeration | Lm49352TypeAudioPort1WidthRxTx |
Public enumeration | Lm49352TypeAudioPort2LSel |
Public enumeration | Lm49352TypeAudioPort2RSel |
Public enumeration | Lm49352TypeAudioPort2Swap |
Public enumeration | Lm49352TypeAudioPortBasicClockPhase |
Public enumeration | Lm49352TypeAuxLevelSediff |
Public enumeration | Lm49352TypeAuxOutAux |
Public enumeration | Lm49352TypeAuxOutDacl |
Public enumeration | Lm49352TypeAuxOutDacr |
Public enumeration | Lm49352TypeAuxOutMic |
Public enumeration | Lm49352TypeAuxOutMono |
Public enumeration | Lm49352TypeClassDAux |
Public enumeration | Lm49352TypeClassDDacl |
Public enumeration | Lm49352TypeClassDDacr |
Public enumeration | Lm49352TypeClassDMono |
Public enumeration | Lm49352TypeDacBasicClock |
Public enumeration | Lm49352TypeDacBasicDspOnly |
Public enumeration | Lm49352TypeDacBasicMode |
Public enumeration | Lm49352TypeDacBasicMuteL |
Public enumeration | Lm49352TypeDacBasicMuteR |
Public enumeration | Lm49352TypeDacFxAlc |
Public enumeration | Lm49352TypeDacFxEq |
Public enumeration | Lm49352TypeDacFxPk |
Public enumeration | Lm49352TypeDacFxSclp |
Public enumeration | Lm49352TypeDacInputAdcL |
Public enumeration | Lm49352TypeDacInputAdcR |
Public enumeration | Lm49352TypeDacInputPort1L |
Public enumeration | Lm49352TypeDacInputPort1R |
Public enumeration | Lm49352TypeDacInputPort2L |
Public enumeration | Lm49352TypeDacInputPort2R |
Public enumeration | Lm49352TypeDacInputSwap |
Public enumeration | Lm49352TypeDecimatorInputLSel |
Public enumeration | Lm49352TypeDecimatorInputMxrClk |
Public enumeration | Lm49352TypeDecimatorInputRSel |
Public enumeration | Lm49352TypeForceCp |
Public enumeration | Lm49352TypeForceDac |
Public enumeration | Lm49352TypeGpio1Mode |
Public enumeration | Lm49352TypeGpio1Rx |
Public enumeration | Lm49352TypeGpio1Tx |
Public enumeration | Lm49352TypeGpio2Short |
Public enumeration | Lm49352TypeGpio2Temp |
Public enumeration | Lm49352TypeHeadphonesLAux |
Public enumeration | Lm49352TypeHeadphonesLDacl |
Public enumeration | Lm49352TypeHeadphonesLDacr |
Public enumeration | Lm49352TypeHeadphonesLMono |
Public enumeration | Lm49352TypeHeadphonesRAux |
Public enumeration | Lm49352TypeHeadphonesRDacl |
Public enumeration | Lm49352TypeHeadphonesRDacr |
Public enumeration | Lm49352TypeHeadphonesRMono |
Public enumeration | Lm49352TypeHpfMode |
Public enumeration | Lm49352TypeHpSenseAux |
Public enumeration | Lm49352TypeHpSenseAuxD |
Public enumeration | Lm49352TypeHpSenseClassD |
Public enumeration | Lm49352TypeHpSenseGeneral |
Public enumeration | Lm49352TypeMicInputMute |
Public enumeration | Lm49352TypeMicInputSediff |
Public enumeration | Lm49352TypeMonoLevelMono |
Public enumeration | Lm49352TypeMonoLevelSediff |
Public enumeration | Lm49352TypeOutputOptionsAuxLine |
Public enumeration | Lm49352TypeOutputOptionsAuxNeg |
Public enumeration | Lm49352TypeOutputOptionsHpLevel |
Public enumeration | Lm49352TypeOutputOptionsLsLevel |
Public enumeration | Lm49352TypePllClkSel |
Public enumeration | Lm49352TypePllM |
Public enumeration | Lm49352TypePllN |
Public enumeration | Lm49352TypePllNMod |
Public enumeration | Lm49352TypePllP |
Public enumeration | Lm49352TypePmcClkDiv |
Public enumeration | Lm49352TypePmcClocks |
Public enumeration | Lm49352TypePmcSetupChipActive |
Public enumeration | Lm49352TypePmcSetupChipEnable |
Public enumeration | Lm49352TypePmcSetupMclkOvr |
Public enumeration | Lm49352TypePmcSetupOscEnb |
Public enumeration | Lm49352TypePmcSetupPll |
Public enumeration | Lm49352TypePmcSetupPllP2enb |
Public enumeration | Lm49352TypePmcSetupPortClkOvr |
Public enumeration | Lm49352TypeReset |
Public enumeration | Lm49352TypeSetNotSet |
Public enumeration | Lm49352TypeSpreadSpectrum |
Public enumeration | Lm4937TypeClockConfigFast |
Public enumeration | Lm4937TypeClockConfigPllEn |
Public enumeration | Lm4937TypeClockConfigPllIn |
Public enumeration | Lm4937TypeClockConfigRDivider |
Public enumeration | Lm4937TypeClockConfigSelect |
Public enumeration | Lm4937TypeDacInputDigital |
Public enumeration | Lm4937TypeDacSetupCust |
Public enumeration | Lm4937TypeDacSetupDitherAl |
Public enumeration | Lm4937TypeDacSetupDitherOff |
Public enumeration | Lm4937TypeDacSetupMode |
Public enumeration | Lm4937TypeDacSetupMuteL |
Public enumeration | Lm4937TypeDacSetupMuteR |
Public enumeration | Lm4937TypeInterfaceFast |
Public enumeration | Lm4937TypeInterfaceMode |
Public enumeration | Lm4937TypeInterfaceRes |
Public enumeration | Lm4937TypeInterfaceSelect |
Public enumeration | Lm4937TypeModeControlCd |
Public enumeration | Lm4937TypeModeControlMixer |
Public enumeration | Lm4937TypeModeControlOutput |
Public enumeration | Lm4937TypeOutputControlEarpiece |
Public enumeration | Lm4937TypeOutputControlHpl |
Public enumeration | Lm4937TypeOutputControlHpr |
Public enumeration | Lm4937TypeOutputControlSpeaker |
Public enumeration | Lm4937TypePllmDivider |
Public enumeration | Lm4937TypePllnDivider |
Public enumeration | Lm4937TypePllnModDividerDither |
Public enumeration | Lm4937TypePllnModDividerVco |
Public enumeration | Lm4937TypePllpDivider |
Public enumeration | Lm4937TypeVolume |
Public enumeration | Pca9534TypeConfiguration |
Public enumeration | Pca9534TypeLevel |
Public enumeration | Pca9534TypePolarity |
Public enumeration | Pca9535TypeConfiguration |
Public enumeration | Pca9535TypeLevel |
Public enumeration | Pca9535TypePolarity |
Public enumeration | Pca9536TypeConfiguration |
Public enumeration | Pca9536TypeLevel |
Public enumeration | Pca9536TypePolarity |
Public enumeration | Pca9539TypeConfiguration |
Public enumeration | Pca9539TypeLevel |
Public enumeration | Pca9539TypePolarity |
Public enumeration | Pca9543aTypeEnabledDisabled |
Public enumeration | Pca9543aTypeInterrupt |
Public enumeration | Pca9545aTypeEnabledDisabled |
Public enumeration | Pca9545aTypeInterrupt |
Public enumeration | Pca9546aTypeEnabledDisabled |
Public enumeration | Pca9554aTypeConfiguration |
Public enumeration | Pca9554aTypeLevel |
Public enumeration | Pca9554aTypePolarity |
Public enumeration | Pca9555TypeConfiguration |
Public enumeration | Pca9555TypeLevel |
Public enumeration | Pca9555TypePolarity |
Public enumeration | Pca9557TypeConfiguration |
Public enumeration | Pca9557TypeLevel |
Public enumeration | Pca9557TypePolarity |
Public enumeration | Pcm1680TypeAttenuation |
Public enumeration | Pcm1680TypeDacControl1Dac1 |
Public enumeration | Pcm1680TypeDacControl1Dac2 |
Public enumeration | Pcm1680TypeDacControl1Dac3 |
Public enumeration | Pcm1680TypeDacControl1Dac4 |
Public enumeration | Pcm1680TypeDacControl1Dac5 |
Public enumeration | Pcm1680TypeDacControl1Dac6 |
Public enumeration | Pcm1680TypeDacControl2Dac7 |
Public enumeration | Pcm1680TypeDacControl2Dac8 |
Public enumeration | Pcm1680TypeDeEmphasisChannel |
Public enumeration | Pcm1680TypeDeEmphasisOutput |
Public enumeration | Pcm1680TypeDeEmphasisReset |
Public enumeration | Pcm1680TypeDeEmphasisSampling |
Public enumeration | Pcm1680TypeDeEmphasisZeroFlag |
Public enumeration | Pcm1680TypeDetectStatusZero1 |
Public enumeration | Pcm1680TypeDetectStatusZero2 |
Public enumeration | Pcm1680TypeDetectStatusZero3 |
Public enumeration | Pcm1680TypeDetectStatusZero4 |
Public enumeration | Pcm1680TypeDetectStatusZero5 |
Public enumeration | Pcm1680TypeDetectStatusZero6 |
Public enumeration | Pcm1680TypeDetectStatusZero7 |
Public enumeration | Pcm1680TypeDetectStatusZero8 |
Public enumeration | Pcm1680TypeFilterInterfaceFormat |
Public enumeration | Pcm1680TypeFilterRollOff |
Public enumeration | Pcm1680TypeModeSelectDams |
Public enumeration | Pcm1680TypeModeSelectZeroFlag |
Public enumeration | Pcm1680TypeMute1Vout1 |
Public enumeration | Pcm1680TypeMute1Vout2 |
Public enumeration | Pcm1680TypeMute1Vout3 |
Public enumeration | Pcm1680TypeMute1Vout4 |
Public enumeration | Pcm1680TypeMute1Vout5 |
Public enumeration | Pcm1680TypeMute1Vout6 |
Public enumeration | Pcm1680TypeMute2Vout7 |
Public enumeration | Pcm1680TypeMute2Vout8 |
Public enumeration | Pcm1680TypeRateControlOver |
Public enumeration | Pcm1681Q1TypeAttenuation |
Public enumeration | Pcm1681Q1TypeDacControl1Dac1 |
Public enumeration | Pcm1681Q1TypeDacControl1Dac2 |
Public enumeration | Pcm1681Q1TypeDacControl1Dac3 |
Public enumeration | Pcm1681Q1TypeDacControl1Dac4 |
Public enumeration | Pcm1681Q1TypeDacControl1Dac5 |
Public enumeration | Pcm1681Q1TypeDacControl1Dac6 |
Public enumeration | Pcm1681Q1TypeDacControl1Dac7 |
Public enumeration | Pcm1681Q1TypeDacControl1Dac8 |
Public enumeration | Pcm1681Q1TypeDacControl2Dac7 |
Public enumeration | Pcm1681Q1TypeDacControl2Dac8 |
Public enumeration | Pcm1681Q1TypeDeEmphasisChannel |
Public enumeration | Pcm1681Q1TypeDeEmphasisOutput |
Public enumeration | Pcm1681Q1TypeDeEmphasisReset |
Public enumeration | Pcm1681Q1TypeDeEmphasisSampling |
Public enumeration | Pcm1681Q1TypeDeEmphasisZeroFlag |
Public enumeration | Pcm1681Q1TypeDetectStatusZero1 |
Public enumeration | Pcm1681Q1TypeDetectStatusZero2 |
Public enumeration | Pcm1681Q1TypeDetectStatusZero3 |
Public enumeration | Pcm1681Q1TypeDetectStatusZero4 |
Public enumeration | Pcm1681Q1TypeDetectStatusZero5 |
Public enumeration | Pcm1681Q1TypeDetectStatusZero6 |
Public enumeration | Pcm1681Q1TypeDetectStatusZero7 |
Public enumeration | Pcm1681Q1TypeDetectStatusZero8 |
Public enumeration | Pcm1681Q1TypeFilterInterfaceFormat |
Public enumeration | Pcm1681Q1TypeFilterRollOff |
Public enumeration | Pcm1681Q1TypeModeSelectDams |
Public enumeration | Pcm1681Q1TypeModeSelectZeroFlag |
Public enumeration | Pcm1681Q1TypeMute1Vout1 |
Public enumeration | Pcm1681Q1TypeMute1Vout2 |
Public enumeration | Pcm1681Q1TypeMute1Vout3 |
Public enumeration | Pcm1681Q1TypeMute1Vout4 |
Public enumeration | Pcm1681Q1TypeMute1Vout5 |
Public enumeration | Pcm1681Q1TypeMute1Vout6 |
Public enumeration | Pcm1681Q1TypeMute1Vout7 |
Public enumeration | Pcm1681Q1TypeMute1Vout8 |
Public enumeration | Pcm1681Q1TypeMute2Vout7 |
Public enumeration | Pcm1681Q1TypeMute2Vout8 |
Public enumeration | Pcm1681Q1TypeOutputPhaseRev1 |
Public enumeration | Pcm1681Q1TypeOutputPhaseRev2 |
Public enumeration | Pcm1681Q1TypeOutputPhaseRev3 |
Public enumeration | Pcm1681Q1TypeOutputPhaseRev4 |
Public enumeration | Pcm1681Q1TypeOutputPhaseRev5 |
Public enumeration | Pcm1681Q1TypeOutputPhaseRev6 |
Public enumeration | Pcm1681Q1TypeOutputPhaseRev7 |
Public enumeration | Pcm1681Q1TypeOutputPhaseRev8 |
Public enumeration | Pcm1681Q1TypeRateControlOver |
Public enumeration | Pcm1681Q1TypeRateControlRollOffData1 |
Public enumeration | Pcm1681Q1TypeRateControlRollOffData2 |
Public enumeration | Pcm1681Q1TypeRateControlRollOffData3 |
Public enumeration | Pcm1681Q1TypeRateControlRollOffData4 |
Public enumeration | Pcm1690Q1TypeAttenuationModeDams |
Public enumeration | Pcm1690Q1TypeAttenuationModeDemp |
Public enumeration | Pcm1690Q1TypeAttenuationModeFlagPol |
Public enumeration | Pcm1690Q1TypeAttenuationModeFlagSel |
Public enumeration | Pcm1690Q1TypeModeControlAmute0 |
Public enumeration | Pcm1690Q1TypeModeControlAmute1 |
Public enumeration | Pcm1690Q1TypeModeControlAmute2 |
Public enumeration | Pcm1690Q1TypeModeControlAmute3 |
Public enumeration | Pcm1690Q1TypeModeControlRegisterReset |
Public enumeration | Pcm1690Q1TypeModeControlSamplingMode |
Public enumeration | Pcm1690Q1TypeModeControlSystemReset |
Public enumeration | Pcm1690Q1TypeModeSelectionAudioFormat |
Public enumeration | Pcm1690Q1TypeModeSelectionPowerSave |
Public enumeration | Pcm1690Q1TypeMuteControlMutda1 |
Public enumeration | Pcm1690Q1TypeMuteControlMutda2 |
Public enumeration | Pcm1690Q1TypeMuteControlMutda3 |
Public enumeration | Pcm1690Q1TypeMuteControlMutda4 |
Public enumeration | Pcm1690Q1TypeMuteControlMutda5 |
Public enumeration | Pcm1690Q1TypeMuteControlMutda6 |
Public enumeration | Pcm1690Q1TypeMuteControlMutda7 |
Public enumeration | Pcm1690Q1TypeMuteControlMutda8 |
Public enumeration | Pcm1690Q1TypeOperationControlFlt0 |
Public enumeration | Pcm1690Q1TypeOperationControlFlt1 |
Public enumeration | Pcm1690Q1TypeOperationControlFlt2 |
Public enumeration | Pcm1690Q1TypeOperationControlFlt3 |
Public enumeration | Pcm1690Q1TypeOperationControlOpeda0 |
Public enumeration | Pcm1690Q1TypeOperationControlOpeda1 |
Public enumeration | Pcm1690Q1TypeOperationControlOpeda2 |
Public enumeration | Pcm1690Q1TypeOperationControlOpeda3 |
Public enumeration | Pcm1690Q1TypePhaseSelectionRevda1 |
Public enumeration | Pcm1690Q1TypePhaseSelectionRevda2 |
Public enumeration | Pcm1690Q1TypePhaseSelectionRevda3 |
Public enumeration | Pcm1690Q1TypePhaseSelectionRevda4 |
Public enumeration | Pcm1690Q1TypePhaseSelectionRevda5 |
Public enumeration | Pcm1690Q1TypePhaseSelectionRevda6 |
Public enumeration | Pcm1690Q1TypePhaseSelectionRevda7 |
Public enumeration | Pcm1690Q1TypePhaseSelectionRevda8 |
Public enumeration | Pcm1690Q1TypeZeroFlagZero1 |
Public enumeration | Pcm1690Q1TypeZeroFlagZero2 |
Public enumeration | Pcm1690Q1TypeZeroFlagZero3 |
Public enumeration | Pcm1690Q1TypeZeroFlagZero4 |
Public enumeration | Pcm1690Q1TypeZeroFlagZero5 |
Public enumeration | Pcm1690Q1TypeZeroFlagZero6 |
Public enumeration | Pcm1690Q1TypeZeroFlagZero7 |
Public enumeration | Pcm1690Q1TypeZeroFlagZero8 |
Public enumeration | Pcm1774TypeAnalogInputLeft |
Public enumeration | Pcm1774TypeAnalogInputRight |
Public enumeration | Pcm1774TypeAnalogOutputHeadphone |
Public enumeration | Pcm1774TypeAnalogOutputVcom |
Public enumeration | Pcm1774TypeAnalogSelectLeft |
Public enumeration | Pcm1774TypeAnalogSelectRight |
Public enumeration | Pcm1774TypeAnalogSwitchMix0Left |
Public enumeration | Pcm1774TypeAnalogSwitchMix0Right |
Public enumeration | Pcm1774TypeAnalogSwitchMix1Left |
Public enumeration | Pcm1774TypeAnalogSwitchMix1Right |
Public enumeration | Pcm1774TypeAnalogSwitchMix2Left |
Public enumeration | Pcm1774TypeAnalogSwitchMix2Right |
Public enumeration | Pcm1774TypeAttenuation |
Public enumeration | Pcm1774TypeAttenuationLchMuteLeft |
Public enumeration | Pcm1774TypeAttenuationRchMuteRight |
Public enumeration | Pcm1774TypeBassBoostAdjust |
Public enumeration | Pcm1774TypeBckConfigurationBck |
Public enumeration | Pcm1774TypeBckConfigurationZero |
Public enumeration | Pcm1774TypeBoostGain |
Public enumeration | Pcm1774TypeDigitalMixingSelect |
Public enumeration | Pcm1774TypeHpaInsertionLeft |
Public enumeration | Pcm1774TypeHpaInsertionRight |
Public enumeration | Pcm1774TypeMasterModeBit |
Public enumeration | Pcm1774TypeMasterModeSelect |
Public enumeration | Pcm1774TypeOverSamplingAudioSelect |
Public enumeration | Pcm1774TypeOverSamplingControl |
Public enumeration | Pcm1774TypeOverSamplingDigitalGain |
Public enumeration | Pcm1774TypeOverSamplingFilterSelect |
Public enumeration | Pcm1774TypePowerControlBias |
Public enumeration | Pcm1774TypePowerControlFilterLeft |
Public enumeration | Pcm1774TypePowerControlFilterRight |
Public enumeration | Pcm1774TypePowerControlHeadLeft |
Public enumeration | Pcm1774TypePowerControlHeadRight |
Public enumeration | Pcm1774TypePowerMixerLeft |
Public enumeration | Pcm1774TypePowerMixerRight |
Public enumeration | Pcm1774TypeShutDownLeft |
Public enumeration | Pcm1774TypeShutDownRight |
Public enumeration | Pcm1774TypeSoundEffectFilter |
Public enumeration | Pcm1774TypeSoundEffectSelect |
Public enumeration | Pcm1774TypeSystemResetPolarity |
Public enumeration | Pcm1774TypeSystemResetSrst |
Public enumeration | Pcm1774TypeTimeControlPower |
Public enumeration | Pcm1774TypeTimeControlResistor |
Public enumeration | Pcm1774TypeVolume |
Public enumeration | Pcm1774TypeVolumeLchMuteLeft |
Public enumeration | Pcm1774TypeVolumeRchMuteRight |
Public enumeration | Pcm1774TypeXxBoostPg1 |
Public enumeration | Pcm1774TypeXxBoostPg2 |
Public enumeration | Pcm1789Q1TypeAttenuationModeAmute |
Public enumeration | Pcm1789Q1TypeAttenuationModeDams |
Public enumeration | Pcm1789Q1TypeAttenuationModeDemp |
Public enumeration | Pcm1789Q1TypeAttenuationModeFlagPol |
Public enumeration | Pcm1789Q1TypeAttenuationModeFlagSel |
Public enumeration | Pcm1789Q1TypeModeControlAmute0 |
Public enumeration | Pcm1789Q1TypeModeControlAmute1 |
Public enumeration | Pcm1789Q1TypeModeControlAmute2 |
Public enumeration | Pcm1789Q1TypeModeControlAmute3 |
Public enumeration | Pcm1789Q1TypeModeControlRegisterReset |
Public enumeration | Pcm1789Q1TypeModeControlSamplingMode |
Public enumeration | Pcm1789Q1TypeModeControlSystemReset |
Public enumeration | Pcm1789Q1TypeModeSelectionAudioFormat |
Public enumeration | Pcm1789Q1TypeModeSelectionPowerSave |
Public enumeration | Pcm1789Q1TypeMuteControlMutda1 |
Public enumeration | Pcm1789Q1TypeMuteControlMutda2 |
Public enumeration | Pcm1789Q1TypeOperationControlFlt |
Public enumeration | Pcm1789Q1TypeOperationControlOpeda |
Public enumeration | Pcm1789Q1TypePhaseSelectionRevda1 |
Public enumeration | Pcm1789Q1TypePhaseSelectionRevda2 |
Public enumeration | Pcm1789Q1TypeZeroFlagZero1 |
Public enumeration | Pcm1789Q1TypeZeroFlagZero2 |
Public enumeration | Pcm1791aTypeAttenuationLevel |
Public enumeration | Pcm1791aTypeAudioControlAttenuationLoad |
Public enumeration | Pcm1791aTypeAudioControlDataFormat |
Public enumeration | Pcm1791aTypeAudioControlDeEmphasis |
Public enumeration | Pcm1791aTypeAudioControlMute |
Public enumeration | Pcm1791aTypeAudioControlSampling |
Public enumeration | Pcm1791aTypeOperationControlDac |
Public enumeration | Pcm1791aTypeOperationControlFilter |
Public enumeration | Pcm1791aTypeOperationControlRate |
Public enumeration | Pcm1791aTypeOperationControlReversal |
Public enumeration | Pcm1791aTypeOperationControlZeroDetect |
Public enumeration | Pcm1791aTypeSignalControlChannel |
Public enumeration | Pcm1791aTypeSignalControlFilter |
Public enumeration | Pcm1791aTypeSignalControlMode |
Public enumeration | Pcm1791aTypeSignalControlMono |
Public enumeration | Pcm1791aTypeSignalControlReset |
Public enumeration | Pcm1791aTypeSignalControlSpeed |
Public enumeration | Pcm1791aTypeZeroDetectionFlagLeft |
Public enumeration | Pcm1791aTypeZeroDetectionFlagRight |
Public enumeration | Pcm1791aTypeZeroOutputDsd |
Public enumeration | Pcm1791aTypeZeroOutputPcm |
Public enumeration | Pcm1792aTypeAttenuationLevel |
Public enumeration | Pcm1792aTypeAudioControlAttenuationLoad |
Public enumeration | Pcm1792aTypeAudioControlDataFormat |
Public enumeration | Pcm1792aTypeAudioControlDeEmphasis |
Public enumeration | Pcm1792aTypeAudioControlMute |
Public enumeration | Pcm1792aTypeAudioControlSampling |
Public enumeration | Pcm1792aTypeOperationControlBypass |
Public enumeration | Pcm1792aTypeOperationControlDac |
Public enumeration | Pcm1792aTypeOperationControlFilter |
Public enumeration | Pcm1792aTypeOperationControlRate |
Public enumeration | Pcm1792aTypeOperationControlReversal |
Public enumeration | Pcm1792aTypeOperationControlZeroDetect |
Public enumeration | Pcm1792aTypeSignalControlChannel |
Public enumeration | Pcm1792aTypeSignalControlFilter |
Public enumeration | Pcm1792aTypeSignalControlMode |
Public enumeration | Pcm1792aTypeSignalControlMono |
Public enumeration | Pcm1792aTypeSignalControlReset |
Public enumeration | Pcm1792aTypeSignalControlSpeed |
Public enumeration | Pcm1792aTypeZeroDetectionFlagLeft |
Public enumeration | Pcm1792aTypeZeroDetectionFlagRight |
Public enumeration | Pcm1792aTypeZeroOutputDsd |
Public enumeration | Pcm1792aTypeZeroOutputPcm |
Public enumeration | Pcm1795TypeAttenuationLevel |
Public enumeration | Pcm1795TypeAudioControlAttenuationLoad |
Public enumeration | Pcm1795TypeAudioControlDataFormat |
Public enumeration | Pcm1795TypeAudioControlDeEmphasis |
Public enumeration | Pcm1795TypeAudioControlMute |
Public enumeration | Pcm1795TypeAudioControlSampling |
Public enumeration | Pcm1795TypeOperationControlBypass |
Public enumeration | Pcm1795TypeOperationControlDac |
Public enumeration | Pcm1795TypeOperationControlFilter |
Public enumeration | Pcm1795TypeOperationControlRate |
Public enumeration | Pcm1795TypeOperationControlReversal |
Public enumeration | Pcm1795TypeOperationControlZeroDetect |
Public enumeration | Pcm1795TypeSignalControlChannel |
Public enumeration | Pcm1795TypeSignalControlFilter |
Public enumeration | Pcm1795TypeSignalControlMode |
Public enumeration | Pcm1795TypeSignalControlMono |
Public enumeration | Pcm1795TypeSignalControlReset |
Public enumeration | Pcm1795TypeSignalControlSpeed |
Public enumeration | Pcm1795TypeZeroDetectionFlagLeft |
Public enumeration | Pcm1795TypeZeroDetectionFlagRight |
Public enumeration | Pcm1795TypeZeroOutputDsd |
Public enumeration | Pcm1795TypeZeroOutputPcm |
Public enumeration | Pcm1796TypeAttenuationLevel |
Public enumeration | Pcm1796TypeAudioControlAttenuationLoad |
Public enumeration | Pcm1796TypeAudioControlDataFormat |
Public enumeration | Pcm1796TypeAudioControlDeEmphasis |
Public enumeration | Pcm1796TypeAudioControlMute |
Public enumeration | Pcm1796TypeAudioControlSampling |
Public enumeration | Pcm1796TypeOperationControlBypass |
Public enumeration | Pcm1796TypeOperationControlDac |
Public enumeration | Pcm1796TypeOperationControlFilter |
Public enumeration | Pcm1796TypeOperationControlRate |
Public enumeration | Pcm1796TypeOperationControlReversal |
Public enumeration | Pcm1796TypeOperationControlZeroDetect |
Public enumeration | Pcm1796TypeSignalControlChannel |
Public enumeration | Pcm1796TypeSignalControlFilter |
Public enumeration | Pcm1796TypeSignalControlMode |
Public enumeration | Pcm1796TypeSignalControlMono |
Public enumeration | Pcm1796TypeSignalControlReset |
Public enumeration | Pcm1796TypeSignalControlSpeed |
Public enumeration | Pcm1796TypeZeroDetectionFlagLeft |
Public enumeration | Pcm1796TypeZeroDetectionFlagRight |
Public enumeration | Pcm1796TypeZeroOutputDsd |
Public enumeration | Pcm1796TypeZeroOutputPcm |
Public enumeration | Pcm1851aTypeChannelControl |
Public enumeration | Pcm1851aTypeGainControlReset |
Public enumeration | Pcm1851aTypeInterfaceControlBypass |
Public enumeration | Pcm1851aTypeInterfaceControlFormat |
Public enumeration | Pcm1851aTypeInterfaceControlMd |
Public enumeration | Pcm1851aTypeInterfaceControlPower |
Public enumeration | Pcm3060TypeAdcAttenuation |
Public enumeration | Pcm3060TypeAdcFilterBypass |
Public enumeration | Pcm3060TypeAdcFilterMute11 |
Public enumeration | Pcm3060TypeAdcFilterMute12 |
Public enumeration | Pcm3060TypeAdcFilterPhase |
Public enumeration | Pcm3060TypeAdcFilterZeroCross |
Public enumeration | Pcm3060TypeAdcInterfaceClock |
Public enumeration | Pcm3060TypeAdcInterfaceFormat |
Public enumeration | Pcm3060TypeAdcInterfaceMode |
Public enumeration | Pcm3060TypeDacAttenuation |
Public enumeration | Pcm3060TypeDacControlMut21 |
Public enumeration | Pcm3060TypeDacControlMut22 |
Public enumeration | Pcm3060TypeDacControlOver |
Public enumeration | Pcm3060TypeDacControlPhase |
Public enumeration | Pcm3060TypeDacFilterDeEmphasis |
Public enumeration | Pcm3060TypeDacFilterRolloff |
Public enumeration | Pcm3060TypeDacFilterSampling |
Public enumeration | Pcm3060TypeDacFilterZeroFunc |
Public enumeration | Pcm3060TypeDacFilterZeroPol |
Public enumeration | Pcm3060TypeDacInterfaceClock |
Public enumeration | Pcm3060TypeDacInterfaceFormat |
Public enumeration | Pcm3060TypeDacInterfaceMode |
Public enumeration | Pcm3060TypeModeControlAdc |
Public enumeration | Pcm3060TypeModeControlDac |
Public enumeration | Pcm3060TypeModeControlModeReset |
Public enumeration | Pcm3060TypeModeControlSingle |
Public enumeration | Pcm3060TypeModeControlSystemReset |
Public enumeration | Pcm3168aTypeAdcAttenuation |
Public enumeration | Pcm3168aTypeAdcAttenuationControlMode |
Public enumeration | Pcm3168aTypeAdcAttenuationControlOver |
Public enumeration | Pcm3168aTypeAdcAttenuationControlSpeed |
Public enumeration | Pcm3168aTypeAdcConfigControlInp1 |
Public enumeration | Pcm3168aTypeAdcConfigControlInp2 |
Public enumeration | Pcm3168aTypeAdcConfigControlInp3 |
Public enumeration | Pcm3168aTypeAdcConfigControlInp4 |
Public enumeration | Pcm3168aTypeAdcConfigControlInp5 |
Public enumeration | Pcm3168aTypeAdcConfigControlInp6 |
Public enumeration | Pcm3168aTypeAdcModeControlSampling |
Public enumeration | Pcm3168aTypeAdcModeSelectFormat |
Public enumeration | Pcm3168aTypeAdcModeSelectMs |
Public enumeration | Pcm3168aTypeAdcMuteAdc1 |
Public enumeration | Pcm3168aTypeAdcMuteAdc2 |
Public enumeration | Pcm3168aTypeAdcMuteAdc3 |
Public enumeration | Pcm3168aTypeAdcMuteAdc4 |
Public enumeration | Pcm3168aTypeAdcMuteAdc5 |
Public enumeration | Pcm3168aTypeAdcMuteAdc6 |
Public enumeration | Pcm3168aTypeAdcOverflowAdc1 |
Public enumeration | Pcm3168aTypeAdcOverflowAdc2 |
Public enumeration | Pcm3168aTypeAdcOverflowAdc3 |
Public enumeration | Pcm3168aTypeAdcOverflowAdc4 |
Public enumeration | Pcm3168aTypeAdcOverflowAdc5 |
Public enumeration | Pcm3168aTypeAdcOverflowAdc6 |
Public enumeration | Pcm3168aTypeAdcPhaseAdc1 |
Public enumeration | Pcm3168aTypeAdcPhaseAdc2 |
Public enumeration | Pcm3168aTypeAdcPhaseAdc3 |
Public enumeration | Pcm3168aTypeAdcPhaseAdc4 |
Public enumeration | Pcm3168aTypeAdcPhaseAdc5 |
Public enumeration | Pcm3168aTypeAdcPhaseAdc6 |
Public enumeration | Pcm3168aTypeAdcPowerControlByp12 |
Public enumeration | Pcm3168aTypeAdcPowerControlByp34 |
Public enumeration | Pcm3168aTypeAdcPowerControlByp56 |
Public enumeration | Pcm3168aTypeAdcPowerControlPow12 |
Public enumeration | Pcm3168aTypeAdcPowerControlPow34 |
Public enumeration | Pcm3168aTypeAdcPowerControlPow56 |
Public enumeration | Pcm3168aTypeDacAttenuation |
Public enumeration | Pcm3168aTypeDacAttenuationControlDeemp |
Public enumeration | Pcm3168aTypeDacAttenuationControlMode |
Public enumeration | Pcm3168aTypeDacAttenuationControlSpeed |
Public enumeration | Pcm3168aTypeDacAttenuationControlZfunc |
Public enumeration | Pcm3168aTypeDacAttenuationControlZpol |
Public enumeration | Pcm3168aTypeDacModeControlRegReset |
Public enumeration | Pcm3168aTypeDacModeControlSampling |
Public enumeration | Pcm3168aTypeDacModeControlSysReset |
Public enumeration | Pcm3168aTypeDacModeSelectFormat |
Public enumeration | Pcm3168aTypeDacModeSelectMs |
Public enumeration | Pcm3168aTypeDacModeSelectPower |
Public enumeration | Pcm3168aTypeDacMuteDac1 |
Public enumeration | Pcm3168aTypeDacMuteDac2 |
Public enumeration | Pcm3168aTypeDacMuteDac3 |
Public enumeration | Pcm3168aTypeDacMuteDac4 |
Public enumeration | Pcm3168aTypeDacMuteDac5 |
Public enumeration | Pcm3168aTypeDacMuteDac6 |
Public enumeration | Pcm3168aTypeDacMuteDac7 |
Public enumeration | Pcm3168aTypeDacMuteDac8 |
Public enumeration | Pcm3168aTypeDacOperationFilt12 |
Public enumeration | Pcm3168aTypeDacOperationFilt34 |
Public enumeration | Pcm3168aTypeDacOperationFilt56 |
Public enumeration | Pcm3168aTypeDacOperationFilt78 |
Public enumeration | Pcm3168aTypeDacOperationOp12 |
Public enumeration | Pcm3168aTypeDacOperationOp34 |
Public enumeration | Pcm3168aTypeDacOperationOp56 |
Public enumeration | Pcm3168aTypeDacOperationOp78 |
Public enumeration | Pcm3168aTypeDacPhaseDac1 |
Public enumeration | Pcm3168aTypeDacPhaseDac2 |
Public enumeration | Pcm3168aTypeDacPhaseDac3 |
Public enumeration | Pcm3168aTypeDacPhaseDac4 |
Public enumeration | Pcm3168aTypeDacPhaseDac5 |
Public enumeration | Pcm3168aTypeDacPhaseDac6 |
Public enumeration | Pcm3168aTypeDacPhaseDac7 |
Public enumeration | Pcm3168aTypeDacPhaseDac8 |
Public enumeration | Pcm3168aTypeDacZeroFlagDac1 |
Public enumeration | Pcm3168aTypeDacZeroFlagDac2 |
Public enumeration | Pcm3168aTypeDacZeroFlagDac3 |
Public enumeration | Pcm3168aTypeDacZeroFlagDac4 |
Public enumeration | Pcm3168aTypeDacZeroFlagDac5 |
Public enumeration | Pcm3168aTypeDacZeroFlagDac6 |
Public enumeration | Pcm3168aTypeDacZeroFlagDac7 |
Public enumeration | Pcm3168aTypeDacZeroFlagDac8 |
Public enumeration | Tca6408TypeConfiguration |
Public enumeration | Tca6408TypeLevel |
Public enumeration | Tca6408TypePolarity |
Public enumeration | Tca6416TypeConfiguration |
Public enumeration | Tca6416TypeLevel |
Public enumeration | Tca6416TypePolarity |
Public enumeration | Tca6424TypeConfiguration |
Public enumeration | Tca6424TypeLevel |
Public enumeration | Tca6424TypePolarity |
Public enumeration | Tca6507TypeInitialization |
Public enumeration | Tca6507TypeInitializationPwm |
Public enumeration | Tca6507TypeMaximumIntensityPwm |
Public enumeration | Tca6507TypeOneShot |
Public enumeration | Tca6507TypeSelect |
Public enumeration | Tca6507TypeTiming |
Public enumeration | Tlv320aic12kTypeControl1Adc |
Public enumeration | Tlv320aic12kTypeControl1Analog |
Public enumeration | Tlv320aic12kTypeControl1Bias |
Public enumeration | Tlv320aic12kTypeControl1Continue |
Public enumeration | Tlv320aic12kTypeControl1Dac |
Public enumeration | Tlv320aic12kTypeControl1Dac16 |
Public enumeration | Tlv320aic12kTypeControl1Digital |
Public enumeration | Tlv320aic12kTypeControl1Filter |
Public enumeration | Tlv320aic12kTypeControl2Decimate |
Public enumeration | Tlv320aic12kTypeControl2General |
Public enumeration | Tlv320aic12kTypeControl2Host |
Public enumeration | Tlv320aic12kTypeControl2Turbo |
Public enumeration | Tlv320aic12kTypeControl3Async |
Public enumeration | Tlv320aic12kTypeControl3Osr |
Public enumeration | Tlv320aic12kTypeControl3Power |
Public enumeration | Tlv320aic12kTypeControl3Reset |
Public enumeration | Tlv320aic12kTypeControl4Sync |
Public enumeration | Tlv320aic12kTypeControl5Gain |
Public enumeration | Tlv320aic12kTypeControl6Driver |
Public enumeration | Tlv320aic12kTypeControl6Input |
Public enumeration | Tlv320aic12kTypeControl6Mute2 |
Public enumeration | Tlv320aic12kTypeControl6Mute3 |
Public enumeration | Tlv320aic12kTypeControl6Prog |
Public enumeration | Tlv320aic22cTypeControl10Caller |
Public enumeration | Tlv320aic22cTypeControl10Hdin |
Public enumeration | Tlv320aic22cTypeControl10Hdout |
Public enumeration | Tlv320aic22cTypeControl10Hsin |
Public enumeration | Tlv320aic22cTypeControl10Hsout |
Public enumeration | Tlv320aic22cTypeControl10Line |
Public enumeration | Tlv320aic22cTypeControl10Mic |
Public enumeration | Tlv320aic22cTypeControl10Speaker |
Public enumeration | Tlv320aic22cTypeControl11Hand |
Public enumeration | Tlv320aic22cTypeControl11Head |
Public enumeration | Tlv320aic22cTypeControl11Mic |
Public enumeration | Tlv320aic22cTypeControl11Speaker |
Public enumeration | Tlv320aic22cTypeControl12Fsync |
Public enumeration | Tlv320aic22cTypeControl13Handecho |
Public enumeration | Tlv320aic22cTypeControl13Handout |
Public enumeration | Tlv320aic22cTypeControl13Valid |
Public enumeration | Tlv320aic22cTypeControl13Version |
Public enumeration | Tlv320aic22cTypeControl14Headecho |
Public enumeration | Tlv320aic22cTypeControl14Headout |
Public enumeration | Tlv320aic22cTypeControl14Line |
Public enumeration | Tlv320aic22cTypeControl14Master |
Public enumeration | Tlv320aic22cTypeControl14Pole |
Public enumeration | Tlv320aic22cTypeControl15Hpf |
Public enumeration | Tlv320aic22cTypeControl15Law |
Public enumeration | Tlv320aic22cTypeControl15Threshold |
Public enumeration | Tlv320aic22cTypeControl15ZeroAdc |
Public enumeration | Tlv320aic22cTypeControl15ZeroCross |
Public enumeration | Tlv320aic22cTypeControl15ZeroDac |
Public enumeration | Tlv320aic22cTypeControl16Hpf |
Public enumeration | Tlv320aic22cTypeControl16Law |
Public enumeration | Tlv320aic22cTypeControl16Threshold |
Public enumeration | Tlv320aic22cTypeControl16ZeroAdc |
Public enumeration | Tlv320aic22cTypeControl16ZeroCross |
Public enumeration | Tlv320aic22cTypeControl16ZeroDac |
Public enumeration | Tlv320aic22cTypeControl21Preamp |
Public enumeration | Tlv320aic22cTypeControl2Analog |
Public enumeration | Tlv320aic22cTypeControl2Digital |
Public enumeration | Tlv320aic22cTypeControl2Power |
Public enumeration | Tlv320aic22cTypeControl2Reset |
Public enumeration | Tlv320aic22cTypeControl3AdcGain |
Public enumeration | Tlv320aic22cTypeControl3Line |
Public enumeration | Tlv320aic22cTypeControl4DacGain |
Public enumeration | Tlv320aic22cTypeControl5Caller |
Public enumeration | Tlv320aic22cTypeControl5Hdin |
Public enumeration | Tlv320aic22cTypeControl5Hdout |
Public enumeration | Tlv320aic22cTypeControl5Hsin |
Public enumeration | Tlv320aic22cTypeControl5Hsout |
Public enumeration | Tlv320aic22cTypeControl5Line |
Public enumeration | Tlv320aic22cTypeControl5Mic |
Public enumeration | Tlv320aic22cTypeControl5Speaker |
Public enumeration | Tlv320aic22cTypeControl7Analog |
Public enumeration | Tlv320aic22cTypeControl7Digital |
Public enumeration | Tlv320aic22cTypeControl7Power |
Public enumeration | Tlv320aic22cTypeControl7Reset |
Public enumeration | Tlv320aic22cTypeControl8AdcGain |
Public enumeration | Tlv320aic22cTypeControl8Line |
Public enumeration | Tlv320aic22cTypeControl9DacGain |
Public enumeration | Tlv320dac23TypeAnalogAudioBypass |
Public enumeration | Tlv320dac23TypeAnalogAudioDac |
Public enumeration | Tlv320dac23TypeDigitalAudioDeEmphasis |
Public enumeration | Tlv320dac23TypeDigitalAudioMute |
Public enumeration | Tlv320dac23TypeDigitalInterfaceBit |
Public enumeration | Tlv320dac23TypeDigitalInterfaceFormat |
Public enumeration | Tlv320dac23TypeDigitalInterfaceMode |
Public enumeration | Tlv320dac23TypeDigitalInterfacePhase |
Public enumeration | Tlv320dac23TypeDigitalInterfaceSwap |
Public enumeration | Tlv320dac23TypeInterfaceActivation |
Public enumeration | Tlv320dac23TypeLineInputLeftMute |
Public enumeration | Tlv320dac23TypeLineInputRightMute |
Public enumeration | Tlv320dac23TypePowerDownClock |
Public enumeration | Tlv320dac23TypePowerDownDac |
Public enumeration | Tlv320dac23TypePowerDownLine |
Public enumeration | Tlv320dac23TypePowerDownOsc |
Public enumeration | Tlv320dac23TypePowerDownOut |
Public enumeration | Tlv320dac23TypePowerDownPower |
Public enumeration | Tlv320dac23TypeSampleRateBase |
Public enumeration | Tlv320dac23TypeSampleRateClock |
Public enumeration | Tlv320dac23TypeSampleRateInput |
Public enumeration | Tlv320dac23TypeSampleRateOutput |
Public enumeration | Tlv320dac23TypeVolumeControl |
Public enumeration | Tlv320dac23TypeVolumeLeftUpdate |
Public enumeration | Tlv320dac23TypeVolumeLeftZeroCross |
Public enumeration | Tlv320dac23TypeVolumeRightZeroCross |
Public enumeration | Tmp100ConfigAlertType |
Public enumeration | Tmp100ConfigFaultType |
Public enumeration | Tmp100ConfigOneShotType |
Public enumeration | Tmp100ConfigPolType |
Public enumeration | Tmp100ConfigResolutionType |
Public enumeration | Tmp100ConfigSdType |
Public enumeration | Tmp100ConfigTmType |
Public enumeration | Tmp101ConfigAlertType |
Public enumeration | Tmp101ConfigFaultType |
Public enumeration | Tmp101ConfigOneShotType |
Public enumeration | Tmp101ConfigPolType |
Public enumeration | Tmp101ConfigResolutionType |
Public enumeration | Tmp101ConfigSdType |
Public enumeration | Tmp101ConfigTmType |
Public enumeration | Tmp105ConfigFaultType |
Public enumeration | Tmp105ConfigOneShotType |
Public enumeration | Tmp105ConfigPolType |
Public enumeration | Tmp105ConfigResolutionType |
Public enumeration | Tmp105ConfigSdType |
Public enumeration | Tmp105ConfigTmType |
Public enumeration | Tmp106ConfigFaultType |
Public enumeration | Tmp106ConfigOneShotType |
Public enumeration | Tmp106ConfigPolType |
Public enumeration | Tmp106ConfigResolutionType |
Public enumeration | Tmp106ConfigSdType |
Public enumeration | Tmp106ConfigTmType |
Public enumeration | Tmp112ConfigConversionRateType |
Public enumeration | Tmp112ConfigConversionReadyType |
Public enumeration | Tmp112ConfigEmType |
Public enumeration | Tmp112ConfigFaultType |
Public enumeration | Tmp112ConfigOneShotType |
Public enumeration | Tmp112ConfigPolType |
Public enumeration | Tmp112ConfigResolutionType |
Public enumeration | Tmp112ConfigSdType |
Public enumeration | Tmp112ConfigTmType |
Public enumeration | Tmp175ConfigFaultType |
Public enumeration | Tmp175ConfigOneShotType |
Public enumeration | Tmp175ConfigPolType |
Public enumeration | Tmp175ConfigResolutionType |
Public enumeration | Tmp175ConfigSdType |
Public enumeration | Tmp175ConfigTmType |
Public enumeration | Tmp275ConfigFaultType |
Public enumeration | Tmp275ConfigOneShotType |
Public enumeration | Tmp275ConfigPolType |
Public enumeration | Tmp275ConfigResolutionType |
Public enumeration | Tmp275ConfigSdType |
Public enumeration | Tmp275ConfigTmType |
Public enumeration | Tmp400TypeConfigurationMask |
Public enumeration | Tmp400TypeConfigurationSd |
Public enumeration | Tmp400TypeConsecutiveAlert |
Public enumeration | Tmp400TypeConversionRate |
Public enumeration | Tmp400TypeEnabledDisabled |
Public enumeration | Tmp400TypeNCorrect |
Public enumeration | Tmp400TypeResolution |
Public enumeration | Tmp400TypeStatusBusy |
Public enumeration | Tmp400TypeStatusExceeded |
Public enumeration | Tmp400TypeStatusOpen |
Public enumeration | Tmp401TypeConfigurationAlTh |
Public enumeration | Tmp401TypeConfigurationMask |
Public enumeration | Tmp401TypeConfigurationSd |
Public enumeration | Tmp401TypeConfigurationTempRange |
Public enumeration | Tmp401TypeConsecutiveAlert |
Public enumeration | Tmp401TypeConversionRate |
Public enumeration | Tmp401TypeEnabledDisabled |
Public enumeration | Tmp401TypeResolution |
Public enumeration | Tmp401TypeStatusBusy |
Public enumeration | Tmp401TypeStatusExceeded |
Public enumeration | Tmp401TypeStatusOpen |
Public enumeration | Tmp421TypeBool |
Public enumeration | Tmp421TypeConversationRate |
Public enumeration | Tmp421TypeLen |
Public enumeration | Tmp421TypeNCorrect |
Public enumeration | Tmp421TypeRc |
Public enumeration | Tmp421TypeRen |
Public enumeration | Tmp421TypeSd |
Public enumeration | Tmp421TypeTempRange |
Public enumeration | Tmp421TypeTrigger |
Public enumeration | Tmp422TypeBool |
Public enumeration | Tmp422TypeConversationRate |
Public enumeration | Tmp422TypeLen |
Public enumeration | Tmp422TypeNCorrect |
Public enumeration | Tmp422TypeRc |
Public enumeration | Tmp422TypeRen |
Public enumeration | Tmp422TypeRen2 |
Public enumeration | Tmp422TypeSd |
Public enumeration | Tmp422TypeTempRange |
Public enumeration | Tmp422TypeTrigger |
Public enumeration | Tmp423TypeBool |
Public enumeration | Tmp423TypeConversationRate |
Public enumeration | Tmp423TypeLen |
Public enumeration | Tmp423TypeNCorrect |
Public enumeration | Tmp423TypeRc |
Public enumeration | Tmp423TypeRen |
Public enumeration | Tmp423TypeRen2 |
Public enumeration | Tmp423TypeRen3 |
Public enumeration | Tmp423TypeSd |
Public enumeration | Tmp423TypeTempRange |
Public enumeration | Tmp423TypeTrigger |
Public enumeration | Tmp431TypeBetaRange |
Public enumeration | Tmp431TypeConfigurationAlTh |
Public enumeration | Tmp431TypeConfigurationMask |
Public enumeration | Tmp431TypeConfigurationSd |
Public enumeration | Tmp431TypeConfigurationTempRange |
Public enumeration | Tmp431TypeConsecutiveAlert |
Public enumeration | Tmp431TypeConversionRate |
Public enumeration | Tmp431TypeEnabledDisabled |
Public enumeration | Tmp431TypeNCorrect |
Public enumeration | Tmp431TypeStatusBusy |
Public enumeration | Tmp431TypeStatusExceeded |
Public enumeration | Tmp431TypeStatusOpen |
Public enumeration | Tmp432TypeBetaRange |
Public enumeration | Tmp432TypeConfigurationAlTh |
Public enumeration | Tmp432TypeConfigurationMask |
Public enumeration | Tmp432TypeConfigurationSd |
Public enumeration | Tmp432TypeConfigurationTempRange |
Public enumeration | Tmp432TypeConsecutiveAlert |
Public enumeration | Tmp432TypeConversionRate |
Public enumeration | Tmp432TypeEnabledDisabled |
Public enumeration | Tmp432TypeNCorrect |
Public enumeration | Tmp432TypeStatusBusy |
Public enumeration | Tmp432TypeStatusExceeded |
Public enumeration | Tmp432TypeStatusOpen |
Public enumeration | Tmp75ConfigFaultType |
Public enumeration | Tmp75ConfigOneShotType |
Public enumeration | Tmp75ConfigPolType |
Public enumeration | Tmp75ConfigResolutionType |
Public enumeration | Tmp75ConfigSdType |
Public enumeration | Tmp75ConfigTmType |


Amc6821 Class

Texas Instruments: AMC 6821
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsAmc6821

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Amc6821
Public Class Amc6821
public ref class Amc6821
type Amc6821 =  class end

The Amc6821 type exposes the following members.

Constructors
 | Name | Description
Public method | Amc6821 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CompanyID | Company ID
Public property | ConfigurationFANFaultEN | Configuration (FAN-Fault-EN)
Public property | ConfigurationFANIE | Configuration (FANIE)
Public property | ConfigurationFDRC | Configuration (FDRC)
Public property | ConfigurationINTEN | Configuration (INT-EN)
Public property | ConfigurationLTOIE | Configuration (LTOIE)
Public property | ConfigurationMODE | Configuration (MODE)
Public property | ConfigurationOVREN | Configuration (OVREN)
Public property | ConfigurationPartRevisionNumber | Configuration (Part Revision Number)
Public property | ConfigurationPSPR | Configuration (PSPR)
Public property | ConfigurationPSVIE | Configuration (PSVIE)
Public property | ConfigurationPWMEN | Configuration (PWM-EN)
Public property | ConfigurationPWMINV | Configuration (PWMINV)
Public property | ConfigurationRST | Configuration (RST)
Public property | ConfigurationRTFIE | Configuration (RTFIE)
Public property | ConfigurationRTOIE | Configuration (RTOIE)
Public property | ConfigurationSTART | Configuration (START)
Public property | ConfigurationTACHEN | Configuration (TACH-EN)
Public property | ConfigurationTACHFAST | Configuration (TACH-FAST)
Public property | ConfigurationTACHMODE | Configuration (TACH-MODE)
Public property | ConfigurationTHERMFANES | Configuration (THERM-FAN-ES)
Public property | ConfigurationTHERMOVIE | Configuration (THERMOVIE)
Public property | DCYDutyCycle | DCY (Duty Cycle) (unit: %)
Public property | DCYLowTemp | DCY-Low-Temp (unit: %)
Public property | DCYRampRAMPE | DCY-Ramp (RAMPE)
Public property | DCYRampRATE | DCY-Ramp (RATE) (unit: DCY updates/s)
Public property | DCYRampSTEP | DCY-Ramp (STEP)
Public property | DCYRampTHRE | DCY-Ramp (THRE)
Public property | DeviceID | Device ID
Public property | FANCharacteristicsFSPD | FAN-Characteristics (FSPD)
Public property | FANCharacteristicsPWM | FAN-Characteristics (PWM) (unit: Hz)
Public property | FANCharacteristicsSTIME | FAN-Characteristics (STIME) (unit: s)
Public property | LocalCriticalTemp | Local-Critical-Temp (unit: °C)
Public property | LocalHighTempLimit | Local-High-Temp-Limit (unit: °C)
Public property | LocalLowTempLimit | Local-Low-Temp-Limit (unit: °C)
Public property | LocalTemperatureDecimalPlaces | Local-Temperature (Decimal Places) (unit: °C)
Public property | LocalTemperatureIntegerPlaces | Local-Temperature (Integer Places) (unit: °C)
Public property | LocalTempFanControlLowTemperature | Local Temp-Fan Control (Low Temperature) (unit: °C)
Public property | LocalTempFanControlSlope | Local Temp-Fan Control (Slope)
Public property | LocalTHERMLimit | Local-THERM-Limit (unit: °C)
Public property | PSVTemp | PSV-Temp (unit: °C)
Public property | RemoteCriticalTemp | Remote-Critical-Temp (unit: °C)
Public property | RemoteHighTempLimit | Remote-High-Temp-Limit (unit: °C)
Public property | RemoteLowTempLimit | Remote-Low-Temp-Limit (unit: °C)
Public property | RemoteTemperatureDecimalPlaces | Remote-Temperature (Decimal Places) (unit: °C)
Public property | RemoteTemperatureIntegerPlaces | Remote-Temperature (Integer Places) (unit: °C)
Public property | RemoteTempFanControlLowTemperature | Remote Temp-Fan Control (Low Temperature) (unit: °C)
Public property | RemoteTempFanControlSlope | Remote Temp-Fan Control (Slope)
Public property | RemoteTHERMLimit | Remote-THERM-Limit (unit: °C)
Public property | StatusFANS | Status (FANS)
Public property | StatusLPSV | Status (LPSV)
Public property | StatusLTC | Status (LTC)
Public property | StatusLTH | Status (LTH)
Public property | StatusLTHERM | Status (L-THERM)
Public property | StatusLTL | Status (LTL)
Public property | StatusRPMALARM | Status (RPM-ALARM)
Public property | StatusRTC | Status (RTC)
Public property | StatusRTF | Status (RTF)
Public property | StatusRTH | Status (RTH)
Public property | StatusRTHERM | Status (R-THERM)
Public property | StatusRTL | Status (RTL)
Public property | StatusTHERMIN | Status (THERM-IN)
Public property | TACHDATA | TACH-DATA
Public property | TACHHighLimit | TACH-High-Limit
Public property | TACHLowLimit | TACH-Low-Limit
Public property | TACHSETTING | TACH-SETTING
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Intelligent Temperature Monitor And PWM Fan Controller
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Amc6821(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Amc6821

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821 Properties

The Amc6821 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | CompanyID | Company ID
Public property | ConfigurationFANFaultEN | Configuration (FAN-Fault-EN)
Public property | ConfigurationFANIE | Configuration (FANIE)
Public property | ConfigurationFDRC | Configuration (FDRC)
Public property | ConfigurationINTEN | Configuration (INT-EN)
Public property | ConfigurationLTOIE | Configuration (LTOIE)
Public property | ConfigurationMODE | Configuration (MODE)
Public property | ConfigurationOVREN | Configuration (OVREN)
Public property | ConfigurationPartRevisionNumber | Configuration (Part Revision Number)
Public property | ConfigurationPSPR | Configuration (PSPR)
Public property | ConfigurationPSVIE | Configuration (PSVIE)
Public property | ConfigurationPWMEN | Configuration (PWM-EN)
Public property | ConfigurationPWMINV | Configuration (PWMINV)
Public property | ConfigurationRST | Configuration (RST)
Public property | ConfigurationRTFIE | Configuration (RTFIE)
Public property | ConfigurationRTOIE | Configuration (RTOIE)
Public property | ConfigurationSTART | Configuration (START)
Public property | ConfigurationTACHEN | Configuration (TACH-EN)
Public property | ConfigurationTACHFAST | Configuration (TACH-FAST)
Public property | ConfigurationTACHMODE | Configuration (TACH-MODE)
Public property | ConfigurationTHERMFANES | Configuration (THERM-FAN-ES)
Public property | ConfigurationTHERMOVIE | Configuration (THERMOVIE)
Public property | DCYDutyCycle | DCY (Duty Cycle) (unit: %)
Public property | DCYLowTemp | DCY-Low-Temp (unit: %)
Public property | DCYRampRAMPE | DCY-Ramp (RAMPE)
Public property | DCYRampRATE | DCY-Ramp (RATE) (unit: DCY updates/s)
Public property | DCYRampSTEP | DCY-Ramp (STEP)
Public property | DCYRampTHRE | DCY-Ramp (THRE)
Public property | DeviceID | Device ID
Public property | FANCharacteristicsFSPD | FAN-Characteristics (FSPD)
Public property | FANCharacteristicsPWM | FAN-Characteristics (PWM) (unit: Hz)
Public property | FANCharacteristicsSTIME | FAN-Characteristics (STIME) (unit: s)
Public property | LocalCriticalTemp | Local-Critical-Temp (unit: °C)
Public property | LocalHighTempLimit | Local-High-Temp-Limit (unit: °C)
Public property | LocalLowTempLimit | Local-Low-Temp-Limit (unit: °C)
Public property | LocalTemperatureDecimalPlaces | Local-Temperature (Decimal Places) (unit: °C)
Public property | LocalTemperatureIntegerPlaces | Local-Temperature (Integer Places) (unit: °C)
Public property | LocalTempFanControlLowTemperature | Local Temp-Fan Control (Low Temperature) (unit: °C)
Public property | LocalTempFanControlSlope | Local Temp-Fan Control (Slope)
Public property | LocalTHERMLimit | Local-THERM-Limit (unit: °C)
Public property | PSVTemp | PSV-Temp (unit: °C)
Public property | RemoteCriticalTemp | Remote-Critical-Temp (unit: °C)
Public property | RemoteHighTempLimit | Remote-High-Temp-Limit (unit: °C)
Public property | RemoteLowTempLimit | Remote-Low-Temp-Limit (unit: °C)
Public property | RemoteTemperatureDecimalPlaces | Remote-Temperature (Decimal Places) (unit: °C)
Public property | RemoteTemperatureIntegerPlaces | Remote-Temperature (Integer Places) (unit: °C)
Public property | RemoteTempFanControlLowTemperature | Remote Temp-Fan Control (Low Temperature) (unit: °C)
Public property | RemoteTempFanControlSlope | Remote Temp-Fan Control (Slope)
Public property | RemoteTHERMLimit | Remote-THERM-Limit (unit: °C)
Public property | StatusFANS | Status (FANS)
Public property | StatusLPSV | Status (LPSV)
Public property | StatusLTC | Status (LTC)
Public property | StatusLTH | Status (LTH)
Public property | StatusLTHERM | Status (L-THERM)
Public property | StatusLTL | Status (LTL)
Public property | StatusRPMALARM | Status (RPM-ALARM)
Public property | StatusRTC | Status (RTC)
Public property | StatusRTF | Status (RTF)
Public property | StatusRTH | Status (RTH)
Public property | StatusRTHERM | Status (R-THERM)
Public property | StatusRTL | Status (RTL)
Public property | StatusTHERMIN | Status (THERM-IN)
Public property | TACHDATA | TACH-DATA
Public property | TACHHighLimit | TACH-High-Limit
Public property | TACHLowLimit | TACH-Low-Limit
Public property | TACHSETTING | TACH-SETTING
Top
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.AutoFlush Property

IRD

Amc6821AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.CompanyID Property

IRD

Amc6821CompanyID Property

Company ID

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte CompanyID { get; }
Public ReadOnly Property CompanyID As Byte
    Get
public:
property unsigned char CompanyID {
    unsigned char get ();
}
member CompanyID : byte with get

Property Value

Type: Byte
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationFANFaultEN Property

IRD

Amc6821ConfigurationFANFaultEN Property

Configuration (FAN-Fault-EN)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeEnabledDisabled ConfigurationFANFaultEN { get; set; }
Public Property ConfigurationFANFaultEN As Amc6821TypeEnabledDisabled
    Get
    Set
public:
property Amc6821TypeEnabledDisabled ConfigurationFANFaultEN {
    Amc6821TypeEnabledDisabled get ();
    void set (Amc6821TypeEnabledDisabled value);
}
member ConfigurationFANFaultEN : Amc6821TypeEnabledDisabled with get, set

Property Value

Type: Amc6821TypeEnabledDisabled
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationFANIE Property

IRD

Amc6821ConfigurationFANIE Property

Configuration (FANIE)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeEnabledDisabled ConfigurationFANIE { get; set; }
Public Property ConfigurationFANIE As Amc6821TypeEnabledDisabled
    Get
    Set
public:
property Amc6821TypeEnabledDisabled ConfigurationFANIE {
    Amc6821TypeEnabledDisabled get ();
    void set (Amc6821TypeEnabledDisabled value);
}
member ConfigurationFANIE : Amc6821TypeEnabledDisabled with get, set

Property Value

Type: Amc6821TypeEnabledDisabled
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationFDRC Property

IRD

Amc6821ConfigurationFDRC Property

Configuration (FDRC)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeFdrc ConfigurationFDRC { get; set; }
Public Property ConfigurationFDRC As Amc6821TypeFdrc
    Get
    Set
public:
property Amc6821TypeFdrc ConfigurationFDRC {
    Amc6821TypeFdrc get ();
    void set (Amc6821TypeFdrc value);
}
member ConfigurationFDRC : Amc6821TypeFdrc with get, set

Property Value

Type: Amc6821TypeFdrc
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationINTEN Property

IRD

Amc6821ConfigurationINTEN Property

Configuration (INT-EN)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeEnabledDisabled ConfigurationINTEN { get; set; }
Public Property ConfigurationINTEN As Amc6821TypeEnabledDisabled
    Get
    Set
public:
property Amc6821TypeEnabledDisabled ConfigurationINTEN {
    Amc6821TypeEnabledDisabled get ();
    void set (Amc6821TypeEnabledDisabled value);
}
member ConfigurationINTEN : Amc6821TypeEnabledDisabled with get, set

Property Value

Type: Amc6821TypeEnabledDisabled
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationLTOIE Property

IRD

Amc6821ConfigurationLTOIE Property

Configuration (LTOIE)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeEnabledDisabled ConfigurationLTOIE { get; set; }
Public Property ConfigurationLTOIE As Amc6821TypeEnabledDisabled
    Get
    Set
public:
property Amc6821TypeEnabledDisabled ConfigurationLTOIE {
    Amc6821TypeEnabledDisabled get ();
    void set (Amc6821TypeEnabledDisabled value);
}
member ConfigurationLTOIE : Amc6821TypeEnabledDisabled with get, set

Property Value

Type: Amc6821TypeEnabledDisabled
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationMODE Property

IRD

Amc6821ConfigurationMODE Property

Configuration (MODE)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeConfigMode ConfigurationMODE { get; set; }
Public Property ConfigurationMODE As Amc6821TypeConfigMode
    Get
    Set
public:
property Amc6821TypeConfigMode ConfigurationMODE {
    Amc6821TypeConfigMode get ();
    void set (Amc6821TypeConfigMode value);
}
member ConfigurationMODE : Amc6821TypeConfigMode with get, set

Property Value

Type: Amc6821TypeConfigMode
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationOVREN Property

IRD

Amc6821ConfigurationOVREN Property

Configuration (OVREN)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeEnabledDisabled ConfigurationOVREN { get; set; }
Public Property ConfigurationOVREN As Amc6821TypeEnabledDisabled
    Get
    Set
public:
property Amc6821TypeEnabledDisabled ConfigurationOVREN {
    Amc6821TypeEnabledDisabled get ();
    void set (Amc6821TypeEnabledDisabled value);
}
member ConfigurationOVREN : Amc6821TypeEnabledDisabled with get, set

Property Value

Type: Amc6821TypeEnabledDisabled
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationPartRevisionNumber Property

IRD

Amc6821ConfigurationPartRevisionNumber Property

Configuration (Part Revision Number)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ConfigurationPartRevisionNumber { get; }
Public ReadOnly Property ConfigurationPartRevisionNumber As Byte
    Get
public:
property unsigned char ConfigurationPartRevisionNumber {
    unsigned char get ();
}
member ConfigurationPartRevisionNumber : byte with get

Property Value

Type: Byte
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationPSPR Property

IRD

Amc6821ConfigurationPSPR Property

Configuration (PSPR)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeConfigPspr ConfigurationPSPR { get; set; }
Public Property ConfigurationPSPR As Amc6821TypeConfigPspr
    Get
    Set
public:
property Amc6821TypeConfigPspr ConfigurationPSPR {
    Amc6821TypeConfigPspr get ();
    void set (Amc6821TypeConfigPspr value);
}
member ConfigurationPSPR : Amc6821TypeConfigPspr with get, set

Property Value

Type: Amc6821TypeConfigPspr
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationPSVIE Property

IRD

Amc6821ConfigurationPSVIE Property

Configuration (PSVIE)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeEnabledDisabled ConfigurationPSVIE { get; set; }
Public Property ConfigurationPSVIE As Amc6821TypeEnabledDisabled
    Get
    Set
public:
property Amc6821TypeEnabledDisabled ConfigurationPSVIE {
    Amc6821TypeEnabledDisabled get ();
    void set (Amc6821TypeEnabledDisabled value);
}
member ConfigurationPSVIE : Amc6821TypeEnabledDisabled with get, set

Property Value

Type: Amc6821TypeEnabledDisabled
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationPWMEN Property

IRD

Amc6821ConfigurationPWMEN Property

Configuration (PWM-EN)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeEnabledDisabled ConfigurationPWMEN { get; set; }
Public Property ConfigurationPWMEN As Amc6821TypeEnabledDisabled
    Get
    Set
public:
property Amc6821TypeEnabledDisabled ConfigurationPWMEN {
    Amc6821TypeEnabledDisabled get ();
    void set (Amc6821TypeEnabledDisabled value);
}
member ConfigurationPWMEN : Amc6821TypeEnabledDisabled with get, set

Property Value

Type: Amc6821TypeEnabledDisabled
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationPWMINV Property

IRD

Amc6821ConfigurationPWMINV Property

Configuration (PWMINV)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeEnabledDisabled ConfigurationPWMINV { get; set; }
Public Property ConfigurationPWMINV As Amc6821TypeEnabledDisabled
    Get
    Set
public:
property Amc6821TypeEnabledDisabled ConfigurationPWMINV {
    Amc6821TypeEnabledDisabled get ();
    void set (Amc6821TypeEnabledDisabled value);
}
member ConfigurationPWMINV : Amc6821TypeEnabledDisabled with get, set

Property Value

Type: Amc6821TypeEnabledDisabled
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationRST Property

IRD

Amc6821ConfigurationRST Property

Configuration (RST)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeReset ConfigurationRST { get; set; }
Public Property ConfigurationRST As Amc6821TypeReset
    Get
    Set
public:
property Amc6821TypeReset ConfigurationRST {
    Amc6821TypeReset get ();
    void set (Amc6821TypeReset value);
}
member ConfigurationRST : Amc6821TypeReset with get, set

Property Value

Type: Amc6821TypeReset
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationRTFIE Property

IRD

Amc6821ConfigurationRTFIE Property

Configuration (RTFIE)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeEnabledDisabled ConfigurationRTFIE { get; set; }
Public Property ConfigurationRTFIE As Amc6821TypeEnabledDisabled
    Get
    Set
public:
property Amc6821TypeEnabledDisabled ConfigurationRTFIE {
    Amc6821TypeEnabledDisabled get ();
    void set (Amc6821TypeEnabledDisabled value);
}
member ConfigurationRTFIE : Amc6821TypeEnabledDisabled with get, set

Property Value

Type: Amc6821TypeEnabledDisabled
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationRTOIE Property

IRD

Amc6821ConfigurationRTOIE Property

Configuration (RTOIE)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeEnabledDisabled ConfigurationRTOIE { get; set; }
Public Property ConfigurationRTOIE As Amc6821TypeEnabledDisabled
    Get
    Set
public:
property Amc6821TypeEnabledDisabled ConfigurationRTOIE {
    Amc6821TypeEnabledDisabled get ();
    void set (Amc6821TypeEnabledDisabled value);
}
member ConfigurationRTOIE : Amc6821TypeEnabledDisabled with get, set

Property Value

Type: Amc6821TypeEnabledDisabled
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationSTART Property

IRD

Amc6821ConfigurationSTART Property

Configuration (START)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeEnabledDisabled ConfigurationSTART { get; set; }
Public Property ConfigurationSTART As Amc6821TypeEnabledDisabled
    Get
    Set
public:
property Amc6821TypeEnabledDisabled ConfigurationSTART {
    Amc6821TypeEnabledDisabled get ();
    void set (Amc6821TypeEnabledDisabled value);
}
member ConfigurationSTART : Amc6821TypeEnabledDisabled with get, set

Property Value

Type: Amc6821TypeEnabledDisabled
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationTACHEN Property

IRD

Amc6821ConfigurationTACHEN Property

Configuration (TACH-EN)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeEnabledDisabled ConfigurationTACHEN { get; set; }
Public Property ConfigurationTACHEN As Amc6821TypeEnabledDisabled
    Get
    Set
public:
property Amc6821TypeEnabledDisabled ConfigurationTACHEN {
    Amc6821TypeEnabledDisabled get ();
    void set (Amc6821TypeEnabledDisabled value);
}
member ConfigurationTACHEN : Amc6821TypeEnabledDisabled with get, set

Property Value

Type: Amc6821TypeEnabledDisabled
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationTACHFAST Property

IRD

Amc6821ConfigurationTACHFAST Property

Configuration (TACH-FAST)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeConfigTachFast ConfigurationTACHFAST { get; set; }
Public Property ConfigurationTACHFAST As Amc6821TypeConfigTachFast
    Get
    Set
public:
property Amc6821TypeConfigTachFast ConfigurationTACHFAST {
    Amc6821TypeConfigTachFast get ();
    void set (Amc6821TypeConfigTachFast value);
}
member ConfigurationTACHFAST : Amc6821TypeConfigTachFast with get, set

Property Value

Type: Amc6821TypeConfigTachFast
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationTACHMODE Property

IRD

Amc6821ConfigurationTACHMODE Property

Configuration (TACH-MODE)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeEnabledDisabled ConfigurationTACHMODE { get; set; }
Public Property ConfigurationTACHMODE As Amc6821TypeEnabledDisabled
    Get
    Set
public:
property Amc6821TypeEnabledDisabled ConfigurationTACHMODE {
    Amc6821TypeEnabledDisabled get ();
    void set (Amc6821TypeEnabledDisabled value);
}
member ConfigurationTACHMODE : Amc6821TypeEnabledDisabled with get, set

Property Value

Type: Amc6821TypeEnabledDisabled
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationTHERMFANES Property

IRD

Amc6821ConfigurationTHERMFANES Property

Configuration (THERM-FAN-ES)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeEnabledDisabled ConfigurationTHERMFANES { get; set; }
Public Property ConfigurationTHERMFANES As Amc6821TypeEnabledDisabled
    Get
    Set
public:
property Amc6821TypeEnabledDisabled ConfigurationTHERMFANES {
    Amc6821TypeEnabledDisabled get ();
    void set (Amc6821TypeEnabledDisabled value);
}
member ConfigurationTHERMFANES : Amc6821TypeEnabledDisabled with get, set

Property Value

Type: Amc6821TypeEnabledDisabled
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.ConfigurationTHERMOVIE Property

IRD

Amc6821ConfigurationTHERMOVIE Property

Configuration (THERMOVIE)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeEnabledDisabled ConfigurationTHERMOVIE { get; set; }
Public Property ConfigurationTHERMOVIE As Amc6821TypeEnabledDisabled
    Get
    Set
public:
property Amc6821TypeEnabledDisabled ConfigurationTHERMOVIE {
    Amc6821TypeEnabledDisabled get ();
    void set (Amc6821TypeEnabledDisabled value);
}
member ConfigurationTHERMOVIE : Amc6821TypeEnabledDisabled with get, set

Property Value

Type: Amc6821TypeEnabledDisabled
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.DCYDutyCycle Property

IRD

Amc6821DCYDutyCycle Property

DCY (Duty Cycle) (unit: %)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DCYDutyCycle { get; set; }
Public Property DCYDutyCycle As Double
    Get
    Set
public:
property double DCYDutyCycle {
    double get ();
    void set (double value);
}
member DCYDutyCycle : float with get, set

Property Value

Type: Double
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.DCYLowTemp Property

IRD

Amc6821DCYLowTemp Property

DCY-Low-Temp (unit: %)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DCYLowTemp { get; set; }
Public Property DCYLowTemp As Double
    Get
    Set
public:
property double DCYLowTemp {
    double get ();
    void set (double value);
}
member DCYLowTemp : float with get, set

Property Value

Type: Double
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.DCYRampRAMPE Property

IRD

Amc6821DCYRampRAMPE Property

DCY-Ramp (RAMPE)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeDcyRampRampe DCYRampRAMPE { get; set; }
Public Property DCYRampRAMPE As Amc6821TypeDcyRampRampe
    Get
    Set
public:
property Amc6821TypeDcyRampRampe DCYRampRAMPE {
    Amc6821TypeDcyRampRampe get ();
    void set (Amc6821TypeDcyRampRampe value);
}
member DCYRampRAMPE : Amc6821TypeDcyRampRampe with get, set

Property Value

Type: Amc6821TypeDcyRampRampe
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.DCYRampRATE Property

IRD

Amc6821DCYRampRATE Property

DCY-Ramp (RATE) (unit: DCY updates/s)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeDcyRampRate DCYRampRATE { get; set; }
Public Property DCYRampRATE As Amc6821TypeDcyRampRate
    Get
    Set
public:
property Amc6821TypeDcyRampRate DCYRampRATE {
    Amc6821TypeDcyRampRate get ();
    void set (Amc6821TypeDcyRampRate value);
}
member DCYRampRATE : Amc6821TypeDcyRampRate with get, set

Property Value

Type: Amc6821TypeDcyRampRate
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.DCYRampSTEP Property

IRD

Amc6821DCYRampSTEP Property

DCY-Ramp (STEP)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeDcyRampBits DCYRampSTEP { get; set; }
Public Property DCYRampSTEP As Amc6821TypeDcyRampBits
    Get
    Set
public:
property Amc6821TypeDcyRampBits DCYRampSTEP {
    Amc6821TypeDcyRampBits get ();
    void set (Amc6821TypeDcyRampBits value);
}
member DCYRampSTEP : Amc6821TypeDcyRampBits with get, set

Property Value

Type: Amc6821TypeDcyRampBits
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.DCYRampTHRE Property

IRD

Amc6821DCYRampTHRE Property

DCY-Ramp (THRE)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeDcyRampBits DCYRampTHRE { get; set; }
Public Property DCYRampTHRE As Amc6821TypeDcyRampBits
    Get
    Set
public:
property Amc6821TypeDcyRampBits DCYRampTHRE {
    Amc6821TypeDcyRampBits get ();
    void set (Amc6821TypeDcyRampBits value);
}
member DCYRampTHRE : Amc6821TypeDcyRampBits with get, set

Property Value

Type: Amc6821TypeDcyRampBits
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.DeviceID Property

IRD

Amc6821DeviceID Property

Device ID

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceID { get; }
Public ReadOnly Property DeviceID As Byte
    Get
public:
property unsigned char DeviceID {
    unsigned char get ();
}
member DeviceID : byte with get

Property Value

Type: Byte
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.FANCharacteristicsFSPD Property

IRD

Amc6821FANCharacteristicsFSPD Property

FAN-Characteristics (FSPD)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeFanCharacteristicsFspd FANCharacteristicsFSPD { get; set; }
Public Property FANCharacteristicsFSPD As Amc6821TypeFanCharacteristicsFspd
    Get
    Set
public:
property Amc6821TypeFanCharacteristicsFspd FANCharacteristicsFSPD {
    Amc6821TypeFanCharacteristicsFspd get ();
    void set (Amc6821TypeFanCharacteristicsFspd value);
}
member FANCharacteristicsFSPD : Amc6821TypeFanCharacteristicsFspd with get, set

Property Value

Type: Amc6821TypeFanCharacteristicsFspd
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.FANCharacteristicsPWM Property

IRD

Amc6821FANCharacteristicsPWM Property

FAN-Characteristics (PWM) (unit: Hz)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeFanCharacteristicsPwm FANCharacteristicsPWM { get; set; }
Public Property FANCharacteristicsPWM As Amc6821TypeFanCharacteristicsPwm
    Get
    Set
public:
property Amc6821TypeFanCharacteristicsPwm FANCharacteristicsPWM {
    Amc6821TypeFanCharacteristicsPwm get ();
    void set (Amc6821TypeFanCharacteristicsPwm value);
}
member FANCharacteristicsPWM : Amc6821TypeFanCharacteristicsPwm with get, set

Property Value

Type: Amc6821TypeFanCharacteristicsPwm
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.FANCharacteristicsSTIME Property

IRD

Amc6821FANCharacteristicsSTIME Property

FAN-Characteristics (STIME) (unit: s)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeFanCharacteristicsStime FANCharacteristicsSTIME { get; set; }
Public Property FANCharacteristicsSTIME As Amc6821TypeFanCharacteristicsStime
    Get
    Set
public:
property Amc6821TypeFanCharacteristicsStime FANCharacteristicsSTIME {
    Amc6821TypeFanCharacteristicsStime get ();
    void set (Amc6821TypeFanCharacteristicsStime value);
}
member FANCharacteristicsSTIME : Amc6821TypeFanCharacteristicsStime with get, set

Property Value

Type: Amc6821TypeFanCharacteristicsStime
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.LocalCriticalTemp Property

IRD

Amc6821LocalCriticalTemp Property

Local-Critical-Temp (unit: °C)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalCriticalTemp { get; set; }
Public Property LocalCriticalTemp As SByte
    Get
    Set
public:
property signed char LocalCriticalTemp {
    signed char get ();
    void set (signed char value);
}
member LocalCriticalTemp : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.LocalHighTempLimit Property

IRD

Amc6821LocalHighTempLimit Property

Local-High-Temp-Limit (unit: °C)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalHighTempLimit { get; set; }
Public Property LocalHighTempLimit As SByte
    Get
    Set
public:
property signed char LocalHighTempLimit {
    signed char get ();
    void set (signed char value);
}
member LocalHighTempLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.LocalLowTempLimit Property

IRD

Amc6821LocalLowTempLimit Property

Local-Low-Temp-Limit (unit: °C)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalLowTempLimit { get; set; }
Public Property LocalLowTempLimit As SByte
    Get
    Set
public:
property signed char LocalLowTempLimit {
    signed char get ();
    void set (signed char value);
}
member LocalLowTempLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.LocalTemperatureDecimalPlaces Property

IRD

Amc6821LocalTemperatureDecimalPlaces Property

Local-Temperature (Decimal Places) (unit: °C)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LocalTemperatureDecimalPlaces { get; }
Public ReadOnly Property LocalTemperatureDecimalPlaces As Double
    Get
public:
property double LocalTemperatureDecimalPlaces {
    double get ();
}
member LocalTemperatureDecimalPlaces : float with get

Property Value

Type: Double
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.LocalTemperatureIntegerPlaces Property

IRD

Amc6821LocalTemperatureIntegerPlaces Property

Local-Temperature (Integer Places) (unit: °C)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTemperatureIntegerPlaces { get; }
Public ReadOnly Property LocalTemperatureIntegerPlaces As SByte
    Get
public:
property signed char LocalTemperatureIntegerPlaces {
    signed char get ();
}
member LocalTemperatureIntegerPlaces : sbyte with get

Property Value

Type: SByte
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.LocalTempFanControlLowTemperature Property

IRD

Amc6821LocalTempFanControlLowTemperature Property

Local Temp-Fan Control (Low Temperature) (unit: °C)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double LocalTempFanControlLowTemperature { get; set; }
Public Property LocalTempFanControlLowTemperature As Double
    Get
    Set
public:
property double LocalTempFanControlLowTemperature {
    double get ();
    void set (double value);
}
member LocalTempFanControlLowTemperature : float with get, set

Property Value

Type: Double
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.LocalTempFanControlSlope Property

IRD

Amc6821LocalTempFanControlSlope Property

Local Temp-Fan Control (Slope)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeSlopeBits LocalTempFanControlSlope { get; set; }
Public Property LocalTempFanControlSlope As Amc6821TypeSlopeBits
    Get
    Set
public:
property Amc6821TypeSlopeBits LocalTempFanControlSlope {
    Amc6821TypeSlopeBits get ();
    void set (Amc6821TypeSlopeBits value);
}
member LocalTempFanControlSlope : Amc6821TypeSlopeBits with get, set

Property Value

Type: Amc6821TypeSlopeBits
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.LocalTHERMLimit Property

IRD

Amc6821LocalTHERMLimit Property

Local-THERM-Limit (unit: °C)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte LocalTHERMLimit { get; set; }
Public Property LocalTHERMLimit As SByte
    Get
    Set
public:
property signed char LocalTHERMLimit {
    signed char get ();
    void set (signed char value);
}
member LocalTHERMLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.PSVTemp Property

IRD

Amc6821PSVTemp Property

PSV-Temp (unit: °C)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte PSVTemp { get; set; }
Public Property PSVTemp As Byte
    Get
    Set
public:
property unsigned char PSVTemp {
    unsigned char get ();
    void set (unsigned char value);
}
member PSVTemp : byte with get, set

Property Value

Type: Byte
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.RemoteCriticalTemp Property

IRD

Amc6821RemoteCriticalTemp Property

Remote-Critical-Temp (unit: °C)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteCriticalTemp { get; set; }
Public Property RemoteCriticalTemp As SByte
    Get
    Set
public:
property signed char RemoteCriticalTemp {
    signed char get ();
    void set (signed char value);
}
member RemoteCriticalTemp : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.RemoteHighTempLimit Property

IRD

Amc6821RemoteHighTempLimit Property

Remote-High-Temp-Limit (unit: °C)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteHighTempLimit { get; set; }
Public Property RemoteHighTempLimit As SByte
    Get
    Set
public:
property signed char RemoteHighTempLimit {
    signed char get ();
    void set (signed char value);
}
member RemoteHighTempLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.RemoteLowTempLimit Property

IRD

Amc6821RemoteLowTempLimit Property

Remote-Low-Temp-Limit (unit: °C)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteLowTempLimit { get; set; }
Public Property RemoteLowTempLimit As SByte
    Get
    Set
public:
property signed char RemoteLowTempLimit {
    signed char get ();
    void set (signed char value);
}
member RemoteLowTempLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.RemoteTemperatureDecimalPlaces Property

IRD

Amc6821RemoteTemperatureDecimalPlaces Property

Remote-Temperature (Decimal Places) (unit: °C)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTemperatureDecimalPlaces { get; }
Public ReadOnly Property RemoteTemperatureDecimalPlaces As Double
    Get
public:
property double RemoteTemperatureDecimalPlaces {
    double get ();
}
member RemoteTemperatureDecimalPlaces : float with get

Property Value

Type: Double
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.RemoteTemperatureIntegerPlaces Property

IRD

Amc6821RemoteTemperatureIntegerPlaces Property

Remote-Temperature (Integer Places) (unit: °C)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTemperatureIntegerPlaces { get; }
Public ReadOnly Property RemoteTemperatureIntegerPlaces As SByte
    Get
public:
property signed char RemoteTemperatureIntegerPlaces {
    signed char get ();
}
member RemoteTemperatureIntegerPlaces : sbyte with get

Property Value

Type: SByte
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.RemoteTempFanControlLowTemperature Property

IRD

Amc6821RemoteTempFanControlLowTemperature Property

Remote Temp-Fan Control (Low Temperature) (unit: °C)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RemoteTempFanControlLowTemperature { get; set; }
Public Property RemoteTempFanControlLowTemperature As Double
    Get
    Set
public:
property double RemoteTempFanControlLowTemperature {
    double get ();
    void set (double value);
}
member RemoteTempFanControlLowTemperature : float with get, set

Property Value

Type: Double
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.RemoteTempFanControlSlope Property

IRD

Amc6821RemoteTempFanControlSlope Property

Remote Temp-Fan Control (Slope)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeSlopeBits RemoteTempFanControlSlope { get; set; }
Public Property RemoteTempFanControlSlope As Amc6821TypeSlopeBits
    Get
    Set
public:
property Amc6821TypeSlopeBits RemoteTempFanControlSlope {
    Amc6821TypeSlopeBits get ();
    void set (Amc6821TypeSlopeBits value);
}
member RemoteTempFanControlSlope : Amc6821TypeSlopeBits with get, set

Property Value

Type: Amc6821TypeSlopeBits
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.RemoteTHERMLimit Property

IRD

Amc6821RemoteTHERMLimit Property

Remote-THERM-Limit (unit: °C)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public sbyte RemoteTHERMLimit { get; set; }
Public Property RemoteTHERMLimit As SByte
    Get
    Set
public:
property signed char RemoteTHERMLimit {
    signed char get ();
    void set (signed char value);
}
member RemoteTHERMLimit : sbyte with get, set

Property Value

Type: SByte
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.StatusFANS Property

IRD

Amc6821StatusFANS Property

Status (FANS)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeStatusFans StatusFANS { get; }
Public ReadOnly Property StatusFANS As Amc6821TypeStatusFans
    Get
public:
property Amc6821TypeStatusFans StatusFANS {
    Amc6821TypeStatusFans get ();
}
member StatusFANS : Amc6821TypeStatusFans with get

Property Value

Type: Amc6821TypeStatusFans
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.StatusLPSV Property

IRD

Amc6821StatusLPSV Property

Status (LPSV)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeStatusLpsv StatusLPSV { get; }
Public ReadOnly Property StatusLPSV As Amc6821TypeStatusLpsv
    Get
public:
property Amc6821TypeStatusLpsv StatusLPSV {
    Amc6821TypeStatusLpsv get ();
}
member StatusLPSV : Amc6821TypeStatusLpsv with get

Property Value

Type: Amc6821TypeStatusLpsv
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.StatusLTC Property

IRD

Amc6821StatusLTC Property

Status (LTC)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeStatusLtc StatusLTC { get; }
Public ReadOnly Property StatusLTC As Amc6821TypeStatusLtc
    Get
public:
property Amc6821TypeStatusLtc StatusLTC {
    Amc6821TypeStatusLtc get ();
}
member StatusLTC : Amc6821TypeStatusLtc with get

Property Value

Type: Amc6821TypeStatusLtc
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.StatusLTH Property

IRD

Amc6821StatusLTH Property

Status (LTH)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeStatusLth StatusLTH { get; }
Public ReadOnly Property StatusLTH As Amc6821TypeStatusLth
    Get
public:
property Amc6821TypeStatusLth StatusLTH {
    Amc6821TypeStatusLth get ();
}
member StatusLTH : Amc6821TypeStatusLth with get

Property Value

Type: Amc6821TypeStatusLth
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.StatusLTHERM Property

IRD

Amc6821StatusLTHERM Property

Status (L-THERM)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeStatusLTherm StatusLTHERM { get; }
Public ReadOnly Property StatusLTHERM As Amc6821TypeStatusLTherm
    Get
public:
property Amc6821TypeStatusLTherm StatusLTHERM {
    Amc6821TypeStatusLTherm get ();
}
member StatusLTHERM : Amc6821TypeStatusLTherm with get

Property Value

Type: Amc6821TypeStatusLTherm
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.StatusLTL Property

IRD

Amc6821StatusLTL Property

Status (LTL)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeStatusLtl StatusLTL { get; }
Public ReadOnly Property StatusLTL As Amc6821TypeStatusLtl
    Get
public:
property Amc6821TypeStatusLtl StatusLTL {
    Amc6821TypeStatusLtl get ();
}
member StatusLTL : Amc6821TypeStatusLtl with get

Property Value

Type: Amc6821TypeStatusLtl
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.StatusRPMALARM Property

IRD

Amc6821StatusRPMALARM Property

Status (RPM-ALARM)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeStatusRpmAlarm StatusRPMALARM { get; }
Public ReadOnly Property StatusRPMALARM As Amc6821TypeStatusRpmAlarm
    Get
public:
property Amc6821TypeStatusRpmAlarm StatusRPMALARM {
    Amc6821TypeStatusRpmAlarm get ();
}
member StatusRPMALARM : Amc6821TypeStatusRpmAlarm with get

Property Value

Type: Amc6821TypeStatusRpmAlarm
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.StatusRTC Property

IRD

Amc6821StatusRTC Property

Status (RTC)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeStatusRtc StatusRTC { get; }
Public ReadOnly Property StatusRTC As Amc6821TypeStatusRtc
    Get
public:
property Amc6821TypeStatusRtc StatusRTC {
    Amc6821TypeStatusRtc get ();
}
member StatusRTC : Amc6821TypeStatusRtc with get

Property Value

Type: Amc6821TypeStatusRtc
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.StatusRTF Property

IRD

Amc6821StatusRTF Property

Status (RTF)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeStatusRtf StatusRTF { get; }
Public ReadOnly Property StatusRTF As Amc6821TypeStatusRtf
    Get
public:
property Amc6821TypeStatusRtf StatusRTF {
    Amc6821TypeStatusRtf get ();
}
member StatusRTF : Amc6821TypeStatusRtf with get

Property Value

Type: Amc6821TypeStatusRtf
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.StatusRTH Property

IRD

Amc6821StatusRTH Property

Status (RTH)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeStatusRth StatusRTH { get; }
Public ReadOnly Property StatusRTH As Amc6821TypeStatusRth
    Get
public:
property Amc6821TypeStatusRth StatusRTH {
    Amc6821TypeStatusRth get ();
}
member StatusRTH : Amc6821TypeStatusRth with get

Property Value

Type: Amc6821TypeStatusRth
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.StatusRTHERM Property

IRD

Amc6821StatusRTHERM Property

Status (R-THERM)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeStatusRTherm StatusRTHERM { get; }
Public ReadOnly Property StatusRTHERM As Amc6821TypeStatusRTherm
    Get
public:
property Amc6821TypeStatusRTherm StatusRTHERM {
    Amc6821TypeStatusRTherm get ();
}
member StatusRTHERM : Amc6821TypeStatusRTherm with get

Property Value

Type: Amc6821TypeStatusRTherm
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.StatusRTL Property

IRD

Amc6821StatusRTL Property

Status (RTL)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeStatusRtl StatusRTL { get; }
Public ReadOnly Property StatusRTL As Amc6821TypeStatusRtl
    Get
public:
property Amc6821TypeStatusRtl StatusRTL {
    Amc6821TypeStatusRtl get ();
}
member StatusRTL : Amc6821TypeStatusRtl with get

Property Value

Type: Amc6821TypeStatusRtl
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.StatusTHERMIN Property

IRD

Amc6821StatusTHERMIN Property

Status (THERM-IN)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Amc6821TypeStatusThermIn StatusTHERMIN { get; }
Public ReadOnly Property StatusTHERMIN As Amc6821TypeStatusThermIn
    Get
public:
property Amc6821TypeStatusThermIn StatusTHERMIN {
    Amc6821TypeStatusThermIn get ();
}
member StatusTHERMIN : Amc6821TypeStatusThermIn with get

Property Value

Type: Amc6821TypeStatusThermIn
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.TACHDATA Property

IRD

Amc6821TACHDATA Property

TACH-DATA

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TACHDATA { get; }
Public ReadOnly Property TACHDATA As UShort
    Get
public:
property unsigned short TACHDATA {
    unsigned short get ();
}
member TACHDATA : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.TACHHighLimit Property

IRD

Amc6821TACHHighLimit Property

TACH-High-Limit

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TACHHighLimit { get; set; }
Public Property TACHHighLimit As UShort
    Get
    Set
public:
property unsigned short TACHHighLimit {
    unsigned short get ();
    void set (unsigned short value);
}
member TACHHighLimit : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.TACHLowLimit Property

IRD

Amc6821TACHLowLimit Property

TACH-Low-Limit

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TACHLowLimit { get; set; }
Public Property TACHLowLimit As UShort
    Get
    Set
public:
property unsigned short TACHLowLimit {
    unsigned short get ();
    void set (unsigned short value);
}
member TACHLowLimit : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.TACHSETTING Property

IRD

Amc6821TACHSETTING Property

TACH-SETTING

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort TACHSETTING { get; set; }
Public Property TACHSETTING As UShort
    Get
    Set
public:
property unsigned short TACHSETTING {
    unsigned short get ();
    void set (unsigned short value);
}
member TACHSETTING : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821 Methods

The Amc6821 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.Flush Method

IRD

Amc6821Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Amc6821 Class
telos.Ird.TexasInstruments Namespace


Amc6821.TypeConfigMode Enumeration

IRD

Amc6821TypeConfigMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigMode
Public Enumeration TypeConfigMode
public enum class TypeConfigMode
type TypeConfigMode
Members
Member name | Value | Description
Configure | 1 | Configure
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeConfigPspr Enumeration

IRD

Amc6821TypeConfigPspr Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigPspr
Public Enumeration TypeConfigPspr
public enum class TypeConfigPspr
type TypeConfigPspr
Members
Member name | Value | Description
FourPulsesRevolution | 1 | Four pulses/revolution
TwoPulsesRevolution | 0 | Two pulses/revolution
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeConfigTachFast Enumeration

IRD

Amc6821TypeConfigTachFast Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfigTachFast
Public Enumeration TypeConfigTachFast
public enum class TypeConfigTachFast
type TypeConfigTachFast
Members
Member name | Value | Description
TACHDataIsUpdatedEvery250Ms | 1 | TACH data is updated every 250 ms
TACHDataIsUpdatedEvery1S | 0 | TACH data is updated every 1 s
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeDcyRampBits Enumeration

IRD

Amc6821TypeDcyRampBits Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDcyRampBits
Public Enumeration TypeDcyRampBits
public enum class TypeDcyRampBits
type TypeDcyRampBits
Members
Member name | Value | Description
Value_1256 | 0 | 1/256
Value_2256 | 1 | 2/256
Value_4256 | 2 | 4/256
Value_8256 | 3 | 8/256
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeDcyRampRampe Enumeration

IRD

Amc6821TypeDcyRampRampe Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDcyRampRampe
Public Enumeration TypeDcyRampRampe
public enum class TypeDcyRampRampe
type TypeDcyRampRampe
Members
Member name | Value | Description
RampEnabled | 1 | Ramp: enabled
RampDisabled | 0 | Ramp: disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeDcyRampRate Enumeration

IRD

Amc6821TypeDcyRampRate Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDcyRampRate
Public Enumeration TypeDcyRampRate
public enum class TypeDcyRampRate
type TypeDcyRampRate
Members
Member name | Value | Description
Value_0_0625 | 0 | 0.0625
Value_0_125 | 1 | 0.125
Value_0_25 | 2 | 0.25
Value_0_5 | 3 | 0.5
Value_1 | 4 | 1
Value_2 | 5 | 2
Value_4 | 6 | 4
Value_8 | 7 | 8
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeEnabledDisabled Enumeration

IRD

Amc6821TypeEnabledDisabled Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeEnabledDisabled
Public Enumeration TypeEnabledDisabled
public enum class TypeEnabledDisabled
type TypeEnabledDisabled
Members
Member name | Value | Description
Enabled | 1 | Enabled
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeFanCharacteristicsFspd Enumeration

IRD

Amc6821TypeFanCharacteristicsFspd Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFanCharacteristicsFspd
Public Enumeration TypeFanCharacteristicsFspd
public enum class TypeFanCharacteristicsFspd
type TypeFanCharacteristicsFspd
Members
Member name | Value | Description
FanSpinUpDisabled | 1 | Fan spin-up: disabled
FanSpinUpEnabled | 0 | Fan spin-up: enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeFanCharacteristicsPwm Enumeration

IRD

Amc6821TypeFanCharacteristicsPwm Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFanCharacteristicsPwm
Public Enumeration TypeFanCharacteristicsPwm
public enum class TypeFanCharacteristicsPwm
type TypeFanCharacteristicsPwm
Members
Member name | Value | Description
Value_10PWMMODEFloating1000PWMMODEGND | 0 | 10 (PWM-MODE: floating) / 1000 (PWM-MODE: GND)
Value_15PWMMODEFloating10000PWMMODEGND | 1 | 15 (PWM-MODE: floating) / 10000 (PWM-MODE: GND)
Value_23PWMMODEFloating20000PWMMODEGND | 2 | 23 (PWM-MODE: floating) / 20000 (PWM-MODE: GND)
Value_30PWMMODEFloating25000PWMMODEGND | 3 | 30 (PWM-MODE: floating) / 25000 (PWM-MODE: GND)
Value_38PWMMODEFloating30000PWMMODEGND | 4 | 38 (PWM-MODE: floating) / 30000 (PWM-MODE: GND)
Value_47PWMMODEFloating40000PWMMODEGND | 5 | 47 (PWM-MODE: floating) / 40000 (PWM-MODE: GND)
Value_62PWMMODEFloating40000PWMMODEGND | 6 | 62 (PWM-MODE: floating) / 40000 (PWM-MODE: GND)
Value_94PWMMODEFloating40000PWMMODEGND | 7 | 94 (PWM-MODE: floating) / 40000 (PWM-MODE: GND)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeFanCharacteristicsStime Enumeration

IRD

Amc6821TypeFanCharacteristicsStime Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFanCharacteristicsStime
Public Enumeration TypeFanCharacteristicsStime
public enum class TypeFanCharacteristicsStime
type TypeFanCharacteristicsStime
Members
Member name | Value | Description
Value_0_2 | 0 | 0.2
Value_0_4 | 1 | 0.4
Value_0_6 | 2 | 0.6
Value_0_8 | 3 | 0.8
Value_1 | 4 | 1
Value_2 | 5 | 2
Value_4 | 6 | 4
Value_8 | 7 | 8
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeFdrc Enumeration

IRD

Amc6821TypeFdrc Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFdrc
Public Enumeration TypeFdrc
public enum class TypeFdrc
type TypeFdrc
Members
Member name | Value | Description
MaximumSpeedCalculatedControl | 3 | Maximum speed calculated control
AutoRemoteTemperatureFanControl | 2 | Auto remote-temperature-fan control
SoftwareDCYControl | 0 | Software DCY control
SoftwareRPMControl | 1 | Software RPM control
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeReset Enumeration

IRD

Amc6821TypeReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeReset
Public Enumeration TypeReset
public enum class TypeReset
type TypeReset
Members
Member name | Value | Description
Reset | 1 | Reset
Unmodified | 0 | Unmodified
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeSlopeBits Enumeration

IRD

Amc6821TypeSlopeBits Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSlopeBits
Public Enumeration TypeSlopeBits
public enum class TypeSlopeBits
type TypeSlopeBits
Members
Member name | Value | Description
Value_32LSBC1255C | 0 | 32 LSB/°C | 12.55 %/°C
Value_16LSBC627C | 1 | 16 LSB/°C | 6.27 %/°C
Value_8LSBC314C | 2 | 8 LSB/°C | 3.14 %/°C
Value_4LSBC157C | 3 | 4 LSB/°C | 1.57 %/°C
Value_2LSBC078C | 4 | 2 LSB/°C | 0.78 %/°C
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeStatusFans Enumeration

IRD

Amc6821TypeStatusFans Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusFans
Public Enumeration TypeStatusFans
public enum class TypeStatusFans
type TypeStatusFans
Members
Member name | Value | Description
TACHDATATACHLowLimit | 1 | TACH-DATA >= TACH-Low-Limit
TACHDATATACHLowLimit__1 | 0 | TACH-DATA < TACH-Low-Limit
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeStatusLpsv Enumeration

IRD

Amc6821TypeStatusLpsv Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusLpsv
Public Enumeration TypeStatusLpsv
public enum class TypeStatusLpsv
type TypeStatusLpsv
Members
Member name | Value | Description
ActiveControlTemperaturePSVTemp | 1 | Active control temperature <= PSV-Temp
ActiveControlTemperaturePSVTemp__1 | 0 | Active control temperature > PSV-Temp
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeStatusLtc Enumeration

IRD

Amc6821TypeStatusLtc Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusLtc
Public Enumeration TypeStatusLtc
public enum class TypeStatusLtc
type TypeStatusLtc
Members
Member name | Value | Description
LocalTemperatureLocalCriticalTemp | 1 | Local-Temperature >= Local-Critical-Temp
LocalTemperatureLocalCriticalTemp__1 | 0 | Local-Temperature < Local-Critical-Temp
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeStatusLth Enumeration

IRD

Amc6821TypeStatusLth Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusLth
Public Enumeration TypeStatusLth
public enum class TypeStatusLth
type TypeStatusLth
Members
Member name | Value | Description
LocalTemperatureLocalHighTempLimit | 1 | Local-Temperature >= Local-High-Temp-Limit
LocalTemperatureLocalHighTempLimit__1 | 0 | Local-Temperature < Local-High-Temp-Limit
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeStatusLTherm Enumeration

IRD

Amc6821TypeStatusLTherm Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusLTherm
Public Enumeration TypeStatusLTherm
public enum class TypeStatusLTherm
type TypeStatusLTherm
Members
Member name | Value | Description
LocalTemperatureLocalTHERMLimit | 1 | Local-Temperature > Local-THERM-Limit
LocalTemperatureLocalTHERMLimit__1 | 0 | Local-Temperature <= Local-THERM-Limit
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeStatusLtl Enumeration

IRD

Amc6821TypeStatusLtl Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusLtl
Public Enumeration TypeStatusLtl
public enum class TypeStatusLtl
type TypeStatusLtl
Members
Member name | Value | Description
LocalTemperatureLocalLowTempLimit | 1 | Local-Temperature <= Local-Low-Temp-Limit
LocalTemperatureLocalLowTempLimit__1 | 0 | Local-Temperature > Local-Low-Temp-Limit
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeStatusRpmAlarm Enumeration

IRD

Amc6821TypeStatusRpmAlarm Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusRpmAlarm
Public Enumeration TypeStatusRpmAlarm
public enum class TypeStatusRpmAlarm
type TypeStatusRpmAlarm
Members
Member name | Value | Description
TACHDATATACHHighLimit | 1 | TACH-DATA <= TACH-High-Limit
TACHDATATACHHighLimit__1 | 0 | TACH-DATA > TACH-High-Limit
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeStatusRtc Enumeration

IRD

Amc6821TypeStatusRtc Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusRtc
Public Enumeration TypeStatusRtc
public enum class TypeStatusRtc
type TypeStatusRtc
Members
Member name | Value | Description
RemoteTemperatureRemoteCriticalTemp | 1 | Remote-Temperature >= Remote-Critical-Temp
RemoteTemperatureRemoteCriticalTemp__1 | 0 | Remote-Temperature < Remote-Critical-Temp
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeStatusRtf Enumeration

IRD

Amc6821TypeStatusRtf Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusRtf
Public Enumeration TypeStatusRtf
public enum class TypeStatusRtf
type TypeStatusRtf
Members
Member name | Value | Description
RemoteSensorFailureInterrupt | 1 | Remote sensor-failure interrupt
RemoteSensorNormalCondition | 0 | Remote sensor normal condition
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeStatusRth Enumeration

IRD

Amc6821TypeStatusRth Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusRth
Public Enumeration TypeStatusRth
public enum class TypeStatusRth
type TypeStatusRth
Members
Member name | Value | Description
RemoteTemperatureRemoteHighTempLimit | 1 | Remote-Temperature >= Remote-High-Temp-Limit
RemoteTemperatureRemoteHighTempLimit__1 | 0 | Remote-Temperature > Remote-High-Temp-Limit
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeStatusRTherm Enumeration

IRD

Amc6821TypeStatusRTherm Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusRTherm
Public Enumeration TypeStatusRTherm
public enum class TypeStatusRTherm
type TypeStatusRTherm
Members
Member name | Value | Description
RemoteTemperatureRemoteTHERMLimit | 1 | Remote-Temperature > Remote-THERM-Limit
RemoteTemperatureRemoteTHERMLimit__1 | 0 | Remote-Temperature <= Remote-THERM-Limit
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeStatusRtl Enumeration

IRD

Amc6821TypeStatusRtl Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusRtl
Public Enumeration TypeStatusRtl
public enum class TypeStatusRtl
type TypeStatusRtl
Members
Member name | Value | Description
RemoteTemperatureRemoteLowTempLimit | 1 | Remote-Temperature <= Remote-Low-Temp-Limit
RemoteTemperatureRemoteLowTempLimit__1 | 0 | Remote-Temperature > Remote-Low-Temp-Limit
See Also

Reference

telos.Ird.TexasInstruments Namespace


Amc6821.TypeStatusThermIn Enumeration

IRD

Amc6821TypeStatusThermIn Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeStatusThermIn
Public Enumeration TypeStatusThermIn
public enum class TypeStatusThermIn
type TypeStatusThermIn
Members
Member name | Value | Description
THERMIsLow | 1 | THERM is low
THERMIsHigh | 0 | THERM is high
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793 Class

Texas Instruments: DSD 1793
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsDsd1793

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Dsd1793
Public Class Dsd1793
public ref class Dsd1793
type Dsd1793 =  class end

The Dsd1793 type exposes the following members.

Constructors
 | Name | Description
Public method | Dsd1793 | Constructor
Top
Properties
 | Name | Description
Public property | AttenuationLeftATL | Attenuation Left: ATL
Public property | AttenuationRightATR | Attenuation Right: ATR
Public property | AudioControlATLD | Audio Control: ATLD
Public property | AudioControlDME | Audio Control: DME
Public property | AudioControlDMF | Audio Control: DMF
Public property | AudioControlFMT | Audio Control: FMT
Public property | AudioControlMUTE | Audio Control: MUTE
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | OperationControlATS | Operation Control: ATS
Public property | OperationControlDFMS | Operation Control: DFMS
Public property | OperationControlFLT | Operation Control: FLT
Public property | OperationControlINZD | Operation Control: INZD
Public property | OperationControlOPE | Operation Control: OPE
Public property | OperationControlREV | Operation Control: REV
Public property | SignalControlCHSL | Signal Control: CHSL
Public property | SignalControlDFTH | Signal Control: DFTH
Public property | SignalControlDSD | Signal Control: DSD
Public property | SignalControlMONO | Signal Control: MONO
Public property | SignalControlOS | Signal Control: OS
Public property | SignalControlSRST | Signal Control: SRST
Public property | ZeroDetectionZFGL | Zero Detection: ZFGL
Public property | ZeroDetectionZFGR | Zero Detection: ZFGR
Public property | ZeroOutputDZ | Zero Output: DZ
Public property | ZeroOutputPCMZ | Zero Output: PCMZ
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Audio Stereo Digital-To-Analog Converter
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Dsd1793(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Dsd1793

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793 Properties

The Dsd1793 type exposes the following members.

Properties
 | Name | Description
Public property | AttenuationLeftATL | Attenuation Left: ATL
Public property | AttenuationRightATR | Attenuation Right: ATR
Public property | AudioControlATLD | Audio Control: ATLD
Public property | AudioControlDME | Audio Control: DME
Public property | AudioControlDMF | Audio Control: DMF
Public property | AudioControlFMT | Audio Control: FMT
Public property | AudioControlMUTE | Audio Control: MUTE
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | OperationControlATS | Operation Control: ATS
Public property | OperationControlDFMS | Operation Control: DFMS
Public property | OperationControlFLT | Operation Control: FLT
Public property | OperationControlINZD | Operation Control: INZD
Public property | OperationControlOPE | Operation Control: OPE
Public property | OperationControlREV | Operation Control: REV
Public property | SignalControlCHSL | Signal Control: CHSL
Public property | SignalControlDFTH | Signal Control: DFTH
Public property | SignalControlDSD | Signal Control: DSD
Public property | SignalControlMONO | Signal Control: MONO
Public property | SignalControlOS | Signal Control: OS
Public property | SignalControlSRST | Signal Control: SRST
Public property | ZeroDetectionZFGL | Zero Detection: ZFGL
Public property | ZeroDetectionZFGR | Zero Detection: ZFGR
Public property | ZeroOutputDZ | Zero Output: DZ
Public property | ZeroOutputPCMZ | Zero Output: PCMZ
Top
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.AttenuationLeftATL Property

IRD

Dsd1793AttenuationLeftATL Property

Attenuation Left: ATL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeAttenuationLevel AttenuationLeftATL { get; set; }
Public Property AttenuationLeftATL As Dsd1793TypeAttenuationLevel
    Get
    Set
public:
property Dsd1793TypeAttenuationLevel AttenuationLeftATL {
    Dsd1793TypeAttenuationLevel get ();
    void set (Dsd1793TypeAttenuationLevel value);
}
member AttenuationLeftATL : Dsd1793TypeAttenuationLevel with get, set

Property Value

Type: Dsd1793TypeAttenuationLevel
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.AttenuationRightATR Property

IRD

Dsd1793AttenuationRightATR Property

Attenuation Right: ATR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeAttenuationLevel AttenuationRightATR { get; set; }
Public Property AttenuationRightATR As Dsd1793TypeAttenuationLevel
    Get
    Set
public:
property Dsd1793TypeAttenuationLevel AttenuationRightATR {
    Dsd1793TypeAttenuationLevel get ();
    void set (Dsd1793TypeAttenuationLevel value);
}
member AttenuationRightATR : Dsd1793TypeAttenuationLevel with get, set

Property Value

Type: Dsd1793TypeAttenuationLevel
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.AudioControlATLD Property

IRD

Dsd1793AudioControlATLD Property

Audio Control: ATLD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeAudioControlAttenuationLoad AudioControlATLD { get; set; }
Public Property AudioControlATLD As Dsd1793TypeAudioControlAttenuationLoad
    Get
    Set
public:
property Dsd1793TypeAudioControlAttenuationLoad AudioControlATLD {
    Dsd1793TypeAudioControlAttenuationLoad get ();
    void set (Dsd1793TypeAudioControlAttenuationLoad value);
}
member AudioControlATLD : Dsd1793TypeAudioControlAttenuationLoad with get, set

Property Value

Type: Dsd1793TypeAudioControlAttenuationLoad
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.AudioControlDME Property

IRD

Dsd1793AudioControlDME Property

Audio Control: DME

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeAudioControlDeEmphasis AudioControlDME { get; set; }
Public Property AudioControlDME As Dsd1793TypeAudioControlDeEmphasis
    Get
    Set
public:
property Dsd1793TypeAudioControlDeEmphasis AudioControlDME {
    Dsd1793TypeAudioControlDeEmphasis get ();
    void set (Dsd1793TypeAudioControlDeEmphasis value);
}
member AudioControlDME : Dsd1793TypeAudioControlDeEmphasis with get, set

Property Value

Type: Dsd1793TypeAudioControlDeEmphasis
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.AudioControlDMF Property

IRD

Dsd1793AudioControlDMF Property

Audio Control: DMF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeAudioControlSampling AudioControlDMF { get; set; }
Public Property AudioControlDMF As Dsd1793TypeAudioControlSampling
    Get
    Set
public:
property Dsd1793TypeAudioControlSampling AudioControlDMF {
    Dsd1793TypeAudioControlSampling get ();
    void set (Dsd1793TypeAudioControlSampling value);
}
member AudioControlDMF : Dsd1793TypeAudioControlSampling with get, set

Property Value

Type: Dsd1793TypeAudioControlSampling
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.AudioControlFMT Property

IRD

Dsd1793AudioControlFMT Property

Audio Control: FMT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeAudioControlDataFormat AudioControlFMT { get; set; }
Public Property AudioControlFMT As Dsd1793TypeAudioControlDataFormat
    Get
    Set
public:
property Dsd1793TypeAudioControlDataFormat AudioControlFMT {
    Dsd1793TypeAudioControlDataFormat get ();
    void set (Dsd1793TypeAudioControlDataFormat value);
}
member AudioControlFMT : Dsd1793TypeAudioControlDataFormat with get, set

Property Value

Type: Dsd1793TypeAudioControlDataFormat
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.AudioControlMUTE Property

IRD

Dsd1793AudioControlMUTE Property

Audio Control: MUTE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeAudioControlMute AudioControlMUTE { get; set; }
Public Property AudioControlMUTE As Dsd1793TypeAudioControlMute
    Get
    Set
public:
property Dsd1793TypeAudioControlMute AudioControlMUTE {
    Dsd1793TypeAudioControlMute get ();
    void set (Dsd1793TypeAudioControlMute value);
}
member AudioControlMUTE : Dsd1793TypeAudioControlMute with get, set

Property Value

Type: Dsd1793TypeAudioControlMute
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.AutoFlush Property

IRD

Dsd1793AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.OperationControlATS Property

IRD

Dsd1793OperationControlATS Property

Operation Control: ATS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeOperationControlRate OperationControlATS { get; set; }
Public Property OperationControlATS As Dsd1793TypeOperationControlRate
    Get
    Set
public:
property Dsd1793TypeOperationControlRate OperationControlATS {
    Dsd1793TypeOperationControlRate get ();
    void set (Dsd1793TypeOperationControlRate value);
}
member OperationControlATS : Dsd1793TypeOperationControlRate with get, set

Property Value

Type: Dsd1793TypeOperationControlRate
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.OperationControlDFMS Property

IRD

Dsd1793OperationControlDFMS Property

Operation Control: DFMS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeOperationControlBypass OperationControlDFMS { get; set; }
Public Property OperationControlDFMS As Dsd1793TypeOperationControlBypass
    Get
    Set
public:
property Dsd1793TypeOperationControlBypass OperationControlDFMS {
    Dsd1793TypeOperationControlBypass get ();
    void set (Dsd1793TypeOperationControlBypass value);
}
member OperationControlDFMS : Dsd1793TypeOperationControlBypass with get, set

Property Value

Type: Dsd1793TypeOperationControlBypass
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.OperationControlFLT Property

IRD

Dsd1793OperationControlFLT Property

Operation Control: FLT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeOperationControlFilter OperationControlFLT { get; set; }
Public Property OperationControlFLT As Dsd1793TypeOperationControlFilter
    Get
    Set
public:
property Dsd1793TypeOperationControlFilter OperationControlFLT {
    Dsd1793TypeOperationControlFilter get ();
    void set (Dsd1793TypeOperationControlFilter value);
}
member OperationControlFLT : Dsd1793TypeOperationControlFilter with get, set

Property Value

Type: Dsd1793TypeOperationControlFilter
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.OperationControlINZD Property

IRD

Dsd1793OperationControlINZD Property

Operation Control: INZD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeOperationControlZeroDetect OperationControlINZD { get; set; }
Public Property OperationControlINZD As Dsd1793TypeOperationControlZeroDetect
    Get
    Set
public:
property Dsd1793TypeOperationControlZeroDetect OperationControlINZD {
    Dsd1793TypeOperationControlZeroDetect get ();
    void set (Dsd1793TypeOperationControlZeroDetect value);
}
member OperationControlINZD : Dsd1793TypeOperationControlZeroDetect with get, set

Property Value

Type: Dsd1793TypeOperationControlZeroDetect
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.OperationControlOPE Property

IRD

Dsd1793OperationControlOPE Property

Operation Control: OPE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeOperationControlDac OperationControlOPE { get; set; }
Public Property OperationControlOPE As Dsd1793TypeOperationControlDac
    Get
    Set
public:
property Dsd1793TypeOperationControlDac OperationControlOPE {
    Dsd1793TypeOperationControlDac get ();
    void set (Dsd1793TypeOperationControlDac value);
}
member OperationControlOPE : Dsd1793TypeOperationControlDac with get, set

Property Value

Type: Dsd1793TypeOperationControlDac
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.OperationControlREV Property

IRD

Dsd1793OperationControlREV Property

Operation Control: REV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeOperationControlReversal OperationControlREV { get; set; }
Public Property OperationControlREV As Dsd1793TypeOperationControlReversal
    Get
    Set
public:
property Dsd1793TypeOperationControlReversal OperationControlREV {
    Dsd1793TypeOperationControlReversal get ();
    void set (Dsd1793TypeOperationControlReversal value);
}
member OperationControlREV : Dsd1793TypeOperationControlReversal with get, set

Property Value

Type: Dsd1793TypeOperationControlReversal
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.SignalControlCHSL Property

IRD

Dsd1793SignalControlCHSL Property

Signal Control: CHSL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeSignalControlChannel SignalControlCHSL { get; set; }
Public Property SignalControlCHSL As Dsd1793TypeSignalControlChannel
    Get
    Set
public:
property Dsd1793TypeSignalControlChannel SignalControlCHSL {
    Dsd1793TypeSignalControlChannel get ();
    void set (Dsd1793TypeSignalControlChannel value);
}
member SignalControlCHSL : Dsd1793TypeSignalControlChannel with get, set

Property Value

Type: Dsd1793TypeSignalControlChannel
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.SignalControlDFTH Property

IRD

Dsd1793SignalControlDFTH Property

Signal Control: DFTH

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeSignalControlFilter SignalControlDFTH { get; set; }
Public Property SignalControlDFTH As Dsd1793TypeSignalControlFilter
    Get
    Set
public:
property Dsd1793TypeSignalControlFilter SignalControlDFTH {
    Dsd1793TypeSignalControlFilter get ();
    void set (Dsd1793TypeSignalControlFilter value);
}
member SignalControlDFTH : Dsd1793TypeSignalControlFilter with get, set

Property Value

Type: Dsd1793TypeSignalControlFilter
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.SignalControlDSD Property

IRD

Dsd1793SignalControlDSD Property

Signal Control: DSD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeSignalControlMode SignalControlDSD { get; set; }
Public Property SignalControlDSD As Dsd1793TypeSignalControlMode
    Get
    Set
public:
property Dsd1793TypeSignalControlMode SignalControlDSD {
    Dsd1793TypeSignalControlMode get ();
    void set (Dsd1793TypeSignalControlMode value);
}
member SignalControlDSD : Dsd1793TypeSignalControlMode with get, set

Property Value

Type: Dsd1793TypeSignalControlMode
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.SignalControlMONO Property

IRD

Dsd1793SignalControlMONO Property

Signal Control: MONO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeSignalControlMono SignalControlMONO { get; set; }
Public Property SignalControlMONO As Dsd1793TypeSignalControlMono
    Get
    Set
public:
property Dsd1793TypeSignalControlMono SignalControlMONO {
    Dsd1793TypeSignalControlMono get ();
    void set (Dsd1793TypeSignalControlMono value);
}
member SignalControlMONO : Dsd1793TypeSignalControlMono with get, set

Property Value

Type: Dsd1793TypeSignalControlMono
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.SignalControlOS Property

IRD

Dsd1793SignalControlOS Property

Signal Control: OS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeSignalControlSpeed SignalControlOS { get; set; }
Public Property SignalControlOS As Dsd1793TypeSignalControlSpeed
    Get
    Set
public:
property Dsd1793TypeSignalControlSpeed SignalControlOS {
    Dsd1793TypeSignalControlSpeed get ();
    void set (Dsd1793TypeSignalControlSpeed value);
}
member SignalControlOS : Dsd1793TypeSignalControlSpeed with get, set

Property Value

Type: Dsd1793TypeSignalControlSpeed
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.SignalControlSRST Property

IRD

Dsd1793SignalControlSRST Property

Signal Control: SRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeSignalControlReset SignalControlSRST { get; set; }
Public Property SignalControlSRST As Dsd1793TypeSignalControlReset
    Get
    Set
public:
property Dsd1793TypeSignalControlReset SignalControlSRST {
    Dsd1793TypeSignalControlReset get ();
    void set (Dsd1793TypeSignalControlReset value);
}
member SignalControlSRST : Dsd1793TypeSignalControlReset with get, set

Property Value

Type: Dsd1793TypeSignalControlReset
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.ZeroDetectionZFGL Property

IRD

Dsd1793ZeroDetectionZFGL Property

Zero Detection: ZFGL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeZeroDetectionFlagLeft ZeroDetectionZFGL { get; }
Public ReadOnly Property ZeroDetectionZFGL As Dsd1793TypeZeroDetectionFlagLeft
    Get
public:
property Dsd1793TypeZeroDetectionFlagLeft ZeroDetectionZFGL {
    Dsd1793TypeZeroDetectionFlagLeft get ();
}
member ZeroDetectionZFGL : Dsd1793TypeZeroDetectionFlagLeft with get

Property Value

Type: Dsd1793TypeZeroDetectionFlagLeft
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.ZeroDetectionZFGR Property

IRD

Dsd1793ZeroDetectionZFGR Property

Zero Detection: ZFGR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeZeroDetectionFlagRight ZeroDetectionZFGR { get; }
Public ReadOnly Property ZeroDetectionZFGR As Dsd1793TypeZeroDetectionFlagRight
    Get
public:
property Dsd1793TypeZeroDetectionFlagRight ZeroDetectionZFGR {
    Dsd1793TypeZeroDetectionFlagRight get ();
}
member ZeroDetectionZFGR : Dsd1793TypeZeroDetectionFlagRight with get

Property Value

Type: Dsd1793TypeZeroDetectionFlagRight
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.ZeroOutputDZ Property

IRD

Dsd1793ZeroOutputDZ Property

Zero Output: DZ

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeZeroOutputDsd ZeroOutputDZ { get; set; }
Public Property ZeroOutputDZ As Dsd1793TypeZeroOutputDsd
    Get
    Set
public:
property Dsd1793TypeZeroOutputDsd ZeroOutputDZ {
    Dsd1793TypeZeroOutputDsd get ();
    void set (Dsd1793TypeZeroOutputDsd value);
}
member ZeroOutputDZ : Dsd1793TypeZeroOutputDsd with get, set

Property Value

Type: Dsd1793TypeZeroOutputDsd
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.ZeroOutputPCMZ Property

IRD

Dsd1793ZeroOutputPCMZ Property

Zero Output: PCMZ

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1793TypeZeroOutputPcm ZeroOutputPCMZ { get; set; }
Public Property ZeroOutputPCMZ As Dsd1793TypeZeroOutputPcm
    Get
    Set
public:
property Dsd1793TypeZeroOutputPcm ZeroOutputPCMZ {
    Dsd1793TypeZeroOutputPcm get ();
    void set (Dsd1793TypeZeroOutputPcm value);
}
member ZeroOutputPCMZ : Dsd1793TypeZeroOutputPcm with get, set

Property Value

Type: Dsd1793TypeZeroOutputPcm
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793 Methods

The Dsd1793 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.Flush Method

IRD

Dsd1793Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Dsd1793 Class
telos.Ird.TexasInstruments Namespace


Dsd1793.TypeAttenuationLevel Enumeration

IRD

Dsd1793TypeAttenuationLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuationLevel
Public Enumeration TypeAttenuationLevel
public enum class TypeAttenuationLevel
type TypeAttenuationLevel
Members
Member name | Value | Description
Mute | 0 | Mute
Value_1200DB | 15 | -120.0 dB
Value_1195DB | 16 | -119.5 dB
Value_1190DB | 17 | -119.0 dB
Value_1185DB | 18 | -118.5 dB
Value_1180DB | 19 | -118.0 dB
Value_1175DB | 20 | -117.5 dB
Value_1170DB | 21 | -117.0 dB
Value_1165DB | 22 | -116.5 dB
Value_1160DB | 23 | -116.0 dB
Value_1155DB | 24 | -115.5 dB
Value_1150DB | 25 | -115.0 dB
Value_1145DB | 26 | -114.5 dB
Value_1140DB | 27 | -114.0 dB
Value_1135DB | 28 | -113.5 dB
Value_1130DB | 29 | -113.0 dB
Value_1125DB | 30 | -112.5 dB
Value_1120DB | 31 | -112.0 dB
Value_1115DB | 32 | -111.5 dB
Value_1110DB | 33 | -111.0 dB
Value_1105DB | 34 | -110.5 dB
Value_1100DB | 35 | -110.0 dB
Value_1095DB | 36 | -109.5 dB
Value_1090DB | 37 | -109.0 dB
Value_1085DB | 38 | -108.5 dB
Value_1080DB | 39 | -108.0 dB
Value_1075DB | 40 | -107.5 dB
Value_1070DB | 41 | -107.0 dB
Value_1065DB | 42 | -106.5 dB
Value_1060DB | 43 | -106.0 dB
Value_1055DB | 44 | -105.5 dB
Value_1050DB | 45 | -105.0 dB
Value_1045DB | 46 | -104.5 dB
Value_1040DB | 47 | -104.0 dB
Value_1035DB | 48 | -103.5 dB
Value_1030DB | 49 | -103.0 dB
Value_1025DB | 50 | -102.5 dB
Value_1020DB | 51 | -102.0 dB
Value_1015DB | 52 | -101.5 dB
Value_1010DB | 53 | -101.0 dB
Value_1005DB | 54 | -100.5 dB
Value_1000DB | 55 | -100.0 dB
Value_995DB | 56 | -99.5 dB
Value_990DB | 57 | -99.0 dB
Value_985DB | 58 | -98.5 dB
Value_980DB | 59 | -98.0 dB
Value_975DB | 60 | -97.5 dB
Value_970DB | 61 | -97.0 dB
Value_965DB | 62 | -96.5 dB
Value_960DB | 63 | -96.0 dB
Value_955DB | 64 | -95.5 dB
Value_950DB | 65 | -95.0 dB
Value_945DB | 66 | -94.5 dB
Value_940DB | 67 | -94.0 dB
Value_935DB | 68 | -93.5 dB
Value_930DB | 69 | -93.0 dB
Value_925DB | 70 | -92.5 dB
Value_920DB | 71 | -92.0 dB
Value_915DB | 72 | -91.5 dB
Value_910DB | 73 | -91.0 dB
Value_905DB | 74 | -90.5 dB
Value_900DB | 75 | -90.0 dB
Value_895DB | 76 | -89.5 dB
Value_890DB | 77 | -89.0 dB
Value_885DB | 78 | -88.5 dB
Value_880DB | 79 | -88.0 dB
Value_875DB | 80 | -87.5 dB
Value_870DB | 81 | -87.0 dB
Value_865DB | 82 | -86.5 dB
Value_860DB | 83 | -86.0 dB
Value_855DB | 84 | -85.5 dB
Value_850DB | 85 | -85.0 dB
Value_845DB | 86 | -84.5 dB
Value_840DB | 87 | -84.0 dB
Value_835DB | 88 | -83.5 dB
Value_830DB | 89 | -83.0 dB
Value_825DB | 90 | -82.5 dB
Value_820DB | 91 | -82.0 dB
Value_815DB | 92 | -81.5 dB
Value_810DB | 93 | -81.0 dB
Value_805DB | 94 | -80.5 dB
Value_800DB | 95 | -80.0 dB
Value_795DB | 96 | -79.5 dB
Value_790DB | 97 | -79.0 dB
Value_785DB | 98 | -78.5 dB
Value_780DB | 99 | -78.0 dB
Value_775DB | 100 | -77.5 dB
Value_770DB | 101 | -77.0 dB
Value_765DB | 102 | -76.5 dB
Value_760DB | 103 | -76.0 dB
Value_755DB | 104 | -75.5 dB
Value_750DB | 105 | -75.0 dB
Value_745DB | 106 | -74.5 dB
Value_740DB | 107 | -74.0 dB
Value_735DB | 108 | -73.5 dB
Value_730DB | 109 | -73.0 dB
Value_725DB | 110 | -72.5 dB
Value_720DB | 111 | -72.0 dB
Value_715DB | 112 | -71.5 dB
Value_710DB | 113 | -71.0 dB
Value_705DB | 114 | -70.5 dB
Value_700DB | 115 | -70.0 dB
Value_695DB | 116 | -69.5 dB
Value_690DB | 117 | -69.0 dB
Value_685DB | 118 | -68.5 dB
Value_680DB | 119 | -68.0 dB
Value_675DB | 120 | -67.5 dB
Value_670DB | 121 | -67.0 dB
Value_665DB | 122 | -66.5 dB
Value_660DB | 123 | -66.0 dB
Value_655DB | 124 | -65.5 dB
Value_650DB | 125 | -65.0 dB
Value_645DB | 126 | -64.5 dB
Value_640DB | 127 | -64.0 dB
Value_635DB | 128 | -63.5 dB
Value_630DB | 129 | -63.0 dB
Value_625DB | 130 | -62.5 dB
Value_620DB | 131 | -62.0 dB
Value_615DB | 132 | -61.5 dB
Value_610DB | 133 | -61.0 dB
Value_605DB | 134 | -60.5 dB
Value_600DB | 135 | -60.0 dB
Value_595DB | 136 | -59.5 dB
Value_590DB | 137 | -59.0 dB
Value_585DB | 138 | -58.5 dB
Value_580DB | 139 | -58.0 dB
Value_575DB | 140 | -57.5 dB
Value_570DB | 141 | -57.0 dB
Value_565DB | 142 | -56.5 dB
Value_560DB | 143 | -56.0 dB
Value_555DB | 144 | -55.5 dB
Value_550DB | 145 | -55.0 dB
Value_545DB | 146 | -54.5 dB
Value_540DB | 147 | -54.0 dB
Value_535DB | 148 | -53.5 dB
Value_530DB | 149 | -53.0 dB
Value_525DB | 150 | -52.5 dB
Value_520DB | 151 | -52.0 dB
Value_515DB | 152 | -51.5 dB
Value_510DB | 153 | -51.0 dB
Value_505DB | 154 | -50.5 dB
Value_500DB | 155 | -50.0 dB
Value_495DB | 156 | -49.5 dB
Value_490DB | 157 | -49.0 dB
Value_485DB | 158 | -48.5 dB
Value_480DB | 159 | -48.0 dB
Value_475DB | 160 | -47.5 dB
Value_470DB | 161 | -47.0 dB
Value_465DB | 162 | -46.5 dB
Value_460DB | 163 | -46.0 dB
Value_455DB | 164 | -45.5 dB
Value_450DB | 165 | -45.0 dB
Value_445DB | 166 | -44.5 dB
Value_440DB | 167 | -44.0 dB
Value_435DB | 168 | -43.5 dB
Value_430DB | 169 | -43.0 dB
Value_425DB | 170 | -42.5 dB
Value_420DB | 171 | -42.0 dB
Value_415DB | 172 | -41.5 dB
Value_410DB | 173 | -41.0 dB
Value_405DB | 174 | -40.5 dB
Value_400DB | 175 | -40.0 dB
Value_395DB | 176 | -39.5 dB
Value_390DB | 177 | -39.0 dB
Value_385DB | 178 | -38.5 dB
Value_380DB | 179 | -38.0 dB
Value_375DB | 180 | -37.5 dB
Value_370DB | 181 | -37.0 dB
Value_365DB | 182 | -36.5 dB
Value_360DB | 183 | -36.0 dB
Value_355DB | 184 | -35.5 dB
Value_350DB | 185 | -35.0 dB
Value_345DB | 186 | -34.5 dB
Value_340DB | 187 | -34.0 dB
Value_335DB | 188 | -33.5 dB
Value_330DB | 189 | -33.0 dB
Value_325DB | 190 | -32.5 dB
Value_320DB | 191 | -32.0 dB
Value_315DB | 192 | -31.5 dB
Value_310DB | 193 | -31.0 dB
Value_305DB | 194 | -30.5 dB
Value_300DB | 195 | -30.0 dB
Value_295DB | 196 | -29.5 dB
Value_290DB | 197 | -29.0 dB
Value_285DB | 198 | -28.5 dB
Value_280DB | 199 | -28.0 dB
Value_275DB | 200 | -27.5 dB
Value_270DB | 201 | -27.0 dB
Value_265DB | 202 | -26.5 dB
Value_260DB | 203 | -26.0 dB
Value_255DB | 204 | -25.5 dB
Value_250DB | 205 | -25.0 dB
Value_245DB | 206 | -24.5 dB
Value_240DB | 207 | -24.0 dB
Value_235DB | 208 | -23.5 dB
Value_230DB | 209 | -23.0 dB
Value_225DB | 210 | -22.5 dB
Value_220DB | 211 | -22.0 dB
Value_215DB | 212 | -21.5 dB
Value_210DB | 213 | -21.0 dB
Value_205DB | 214 | -20.5 dB
Value_200DB | 215 | -20.0 dB
Value_195DB | 216 | -19.5 dB
Value_190DB | 217 | -19.0 dB
Value_185DB | 218 | -18.5 dB
Value_180DB | 219 | -18.0 dB
Value_175DB | 220 | -17.5 dB
Value_170DB | 221 | -17.0 dB
Value_165DB | 222 | -16.5 dB
Value_160DB | 223 | -16.0 dB
Value_155DB | 224 | -15.5 dB
Value_150DB | 225 | -15.0 dB
Value_145DB | 226 | -14.5 dB
Value_140DB | 227 | -14.0 dB
Value_135DB | 228 | -13.5 dB
Value_130DB | 229 | -13.0 dB
Value_125DB | 230 | -12.5 dB
Value_120DB | 231 | -12.0 dB
Value_115DB | 232 | -11.5 dB
Value_110DB | 233 | -11.0 dB
Value_105DB | 234 | -10.5 dB
Value_100DB | 235 | -10.0 dB
Value_95DB | 236 | -9.5 dB
Value_90DB | 237 | -9.0 dB
Value_85DB | 238 | -8.5 dB
Value_80DB | 239 | -8.0 dB
Value_75DB | 240 | -7.5 dB
Value_70DB | 241 | -7.0 dB
Value_65DB | 242 | -6.5 dB
Value_60DB | 243 | -6.0 dB
Value_55DB | 244 | -5.5 dB
Value_50DB | 245 | -5.0 dB
Value_45DB | 246 | -4.5 dB
Value_40DB | 247 | -4.0 dB
Value_35DB | 248 | -3.5 dB
Value_30DB | 249 | -3.0 dB
Value_25DB | 250 | -2.5 dB
Value_20DB | 251 | -2.0 dB
Value_15DB | 252 | -1.5 dB
Value_10DB | 253 | -1.0 dB
Value_05DB | 254 | -0.5 dB
Value_0DB | 255 | 0 dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeAudioControlAttenuationLoad Enumeration

IRD

Dsd1793TypeAudioControlAttenuationLoad Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlAttenuationLoad
Public Enumeration TypeAudioControlAttenuationLoad
public enum class TypeAudioControlAttenuationLoad
type TypeAudioControlAttenuationLoad
Members
Member name | Value | Description
AttenuationControlDisabled | 0 | Attenuation Control: Disabled
AttenuationControlEnabled | 1 | Attenuation Control: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeAudioControlDataFormat Enumeration

IRD

Dsd1793TypeAudioControlDataFormat Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlDataFormat
Public Enumeration TypeAudioControlDataFormat
public enum class TypeAudioControlDataFormat
type TypeAudioControlDataFormat
Members
Member name | Value | Description
Value_16BitRightJustifiedStandardFormat | 0 | 16 Bit Right-Justified Standard Format
Value_20BitRightJustifiedStandardFormat | 1 | 20 Bit Right-Justified Standard Format
Value_24BitRightJustifiedStandardFormat | 2 | 24 Bit Right-Justified Standard Format
Value_24BitLeftJustifiedMSBFirstFormat | 3 | 24 Bit Left-Justified MSB-First Format
Value_16BitI2SFormat | 4 | 16 Bit I2S Format
Value_24BitI2SFormat | 5 | 24 Bit I2S Format
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeAudioControlDeEmphasis Enumeration

IRD

Dsd1793TypeAudioControlDeEmphasis Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlDeEmphasis
Public Enumeration TypeAudioControlDeEmphasis
public enum class TypeAudioControlDeEmphasis
type TypeAudioControlDeEmphasis
Members
Member name | Value | Description
DeEmphasisDisabled | 0 | De-Emphasis: Disabled
DeEmphasisEnabled | 1 | De-Emphasis: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeAudioControlMute Enumeration

IRD

Dsd1793TypeAudioControlMute Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlMute
Public Enumeration TypeAudioControlMute
public enum class TypeAudioControlMute
type TypeAudioControlMute
Members
Member name | Value | Description
MuteDisabled | 0 | Mute: Disabled
MuteEnabled | 1 | Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeAudioControlSampling Enumeration

IRD

Dsd1793TypeAudioControlSampling Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlSampling
Public Enumeration TypeAudioControlSampling
public enum class TypeAudioControlSampling
type TypeAudioControlSampling
Members
Member name | Value | Description
SamplingFequencyDisabled | 0 | Sampling Fequency: Disabled
SamplingFequency48KHz | 1 | Sampling Fequency: 48 kHz
SamplingFequency441KHz | 2 | Sampling Fequency: 44.1 kHz
SamplingFequency32KHz | 3 | Sampling Fequency: 32 kHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeOperationControlBypass Enumeration

IRD

Dsd1793TypeOperationControlBypass Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlBypass
Public Enumeration TypeOperationControlBypass
public enum class TypeOperationControlBypass
type TypeOperationControlBypass
Members
Member name | Value | Description
Monaural | 0 | Monaural
StereoInput | 1 | Stereo Input
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeOperationControlDac Enumeration

IRD

Dsd1793TypeOperationControlDac Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlDac
Public Enumeration TypeOperationControlDac
public enum class TypeOperationControlDac
type TypeOperationControlDac
Members
Member name | Value | Description
DACOperationEnabled | 0 | DAC Operation: Enabled
DACOperationDisabled | 1 | DAC Operation: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeOperationControlFilter Enumeration

IRD

Dsd1793TypeOperationControlFilter Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlFilter
Public Enumeration TypeOperationControlFilter
public enum class TypeOperationControlFilter
type TypeOperationControlFilter
Members
Member name | Value | Description
DigitalFilterSharpRollOff | 0 | Digital Filter: Sharp Roll-Off
DigitalFilterSlowRollOff | 1 | Digital Filter: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeOperationControlRate Enumeration

IRD

Dsd1793TypeOperationControlRate Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlRate
Public Enumeration TypeOperationControlRate
public enum class TypeOperationControlRate
type TypeOperationControlRate
Members
Member name | Value | Description
AttenuationRateLRCK1 | 0 | Attenuation Rate: LRCK / 1
AttenuationRateLRCK2 | 1 | Attenuation Rate: LRCK / 2
AttenuationRateLRCK4 | 2 | Attenuation Rate: LRCK / 4
AttenuationRateLRCK8 | 3 | Attenuation Rate: LRCK / 8
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeOperationControlReversal Enumeration

IRD

Dsd1793TypeOperationControlReversal Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlReversal
Public Enumeration TypeOperationControlReversal
public enum class TypeOperationControlReversal
type TypeOperationControlReversal
Members
Member name | Value | Description
OutputPhaseNormal | 0 | Output Phase: Normal
OutputPhaseInverted | 1 | Output Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeOperationControlZeroDetect Enumeration

IRD

Dsd1793TypeOperationControlZeroDetect Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlZeroDetect
Public Enumeration TypeOperationControlZeroDetect
public enum class TypeOperationControlZeroDetect
type TypeOperationControlZeroDetect
Members
Member name | Value | Description
InfiniteZeroDetectMuteDisabled | 0 | Infinite Zero Detect Mute: Disabled
InfiniteZeroDetectMuteEnabled | 1 | Infinite Zero Detect Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeSignalControlChannel Enumeration

IRD

Dsd1793TypeSignalControlChannel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlChannel
Public Enumeration TypeSignalControlChannel
public enum class TypeSignalControlChannel
type TypeSignalControlChannel
Members
Member name | Value | Description
LChannelSelected | 0 | L-Channel Selected
RChannelSelected | 1 | R-Channel Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeSignalControlFilter Enumeration

IRD

Dsd1793TypeSignalControlFilter Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlFilter
Public Enumeration TypeSignalControlFilter
public enum class TypeSignalControlFilter
type TypeSignalControlFilter
Members
Member name | Value | Description
DigitalFilterEnabled | 0 | Digital Filter: Enabled
DigitalFilterBypassedForExternalFilter | 1 | Digital Filter: Bypassed For External Filter
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeSignalControlMode Enumeration

IRD

Dsd1793TypeSignalControlMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlMode
Public Enumeration TypeSignalControlMode
public enum class TypeSignalControlMode
type TypeSignalControlMode
Members
Member name | Value | Description
DSDInterfaceModeDisabled | 0 | DSD Interface Mode: Disabled
DSDInterfaceModeEnabled | 1 | DSD Interface Mode: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeSignalControlMono Enumeration

IRD

Dsd1793TypeSignalControlMono Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlMono
Public Enumeration TypeSignalControlMono
public enum class TypeSignalControlMono
type TypeSignalControlMono
Members
Member name | Value | Description
StereoMode | 0 | Stereo Mode
MonauralMode | 1 | Monaural Mode
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeSignalControlReset Enumeration

IRD

Dsd1793TypeSignalControlReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlReset
Public Enumeration TypeSignalControlReset
public enum class TypeSignalControlReset
type TypeSignalControlReset
Members
Member name | Value | Description
SystemResetNormalOperation | 0 | System Reset: Normal Operation
SystemResetOperationOneResetPulse | 1 | System Reset Operation (One Reset Pulse)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeSignalControlSpeed Enumeration

IRD

Dsd1793TypeSignalControlSpeed Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlSpeed
Public Enumeration TypeSignalControlSpeed
public enum class TypeSignalControlSpeed
type TypeSignalControlSpeed
Members
Member name | Value | Description
OperationSpeed64XFs | 0 | Operation Speed: 64 x Fs
OperationSpeed32XFs | 1 | Operation Speed: 32 x Fs
OperationSpeed128XFs | 2 | Operation Speed: 128 x Fs
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeZeroDetectionFlagLeft Enumeration

IRD

Dsd1793TypeZeroDetectionFlagLeft Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroDetectionFlagLeft
Public Enumeration TypeZeroDetectionFlagLeft
public enum class TypeZeroDetectionFlagLeft
type TypeZeroDetectionFlagLeft
Members
Member name | Value | Description
LChannelZeroNotDetected | 0 | L-Channel: Zero Not Detected
LChannelZeroDetected | 1 | L-Channel: Zero Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeZeroDetectionFlagRight Enumeration

IRD

Dsd1793TypeZeroDetectionFlagRight Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroDetectionFlagRight
Public Enumeration TypeZeroDetectionFlagRight
public enum class TypeZeroDetectionFlagRight
type TypeZeroDetectionFlagRight
Members
Member name | Value | Description
RChannelZeroNotDetected | 0 | R-Channel: Zero Not Detected
RChannelZeroDetected | 1 | R-Channel: Zero Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeZeroOutputDsd Enumeration

IRD

Dsd1793TypeZeroOutputDsd Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroOutputDsd
Public Enumeration TypeZeroOutputDsd
public enum class TypeZeroOutputDsd
type TypeZeroOutputDsd
Members
Member name | Value | Description
ZeroOutputDisabled | 0 | Zero Output: Disabled
ZeroOutputEvenPatternDetect | 1 | Zero Output: Even Pattern Detect
ZeroOutput96HPatternDetect | 2 | Zero Output: 96H Pattern Detect
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1793.TypeZeroOutputPcm Enumeration

IRD

Dsd1793TypeZeroOutputPcm Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroOutputPcm
Public Enumeration TypeZeroOutputPcm
public enum class TypeZeroOutputPcm
type TypeZeroOutputPcm
Members
Member name | Value | Description
PCMZeroOutputDisabled | 0 | PCM Zero Output: Disabled
PCMZeroOutputEnabled | 1 | PCM Zero Output: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a Class

Texas Instruments: DSD 1794A
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsDsd1794a

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Dsd1794a
Public Class Dsd1794a
public ref class Dsd1794a
type Dsd1794a =  class end

The Dsd1794a type exposes the following members.

Constructors
 | Name | Description
Public method | Dsd1794a | Constructor
Top
Properties
 | Name | Description
Public property | AttenuationLeftATL | Attenuation Left: ATL
Public property | AttenuationRightATR | Attenuation Right: ATR
Public property | AudioControlATLD | Audio Control: ATLD
Public property | AudioControlDME | Audio Control: DME
Public property | AudioControlDMF | Audio Control: DMF
Public property | AudioControlFMT | Audio Control: FMT
Public property | AudioControlMUTE | Audio Control: MUTE
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | OperationControlATS | Operation Control: ATS
Public property | OperationControlDFMS | Operation Control: DFMS
Public property | OperationControlFLT | Operation Control: FLT
Public property | OperationControlINZD | Operation Control: INZD
Public property | OperationControlOPE | Operation Control: OPE
Public property | OperationControlREV | Operation Control: REV
Public property | OperationControlZOE | Operation Control: ZOE
Public property | SignalControlCHSL | Signal Control: CHSL
Public property | SignalControlDFTH | Signal Control: DFTH
Public property | SignalControlDSD | Signal Control: DSD
Public property | SignalControlMONO | Signal Control: MONO
Public property | SignalControlOS | Signal Control: OS
Public property | SignalControlSRST | Signal Control: SRST
Public property | ZeroDetectionZFGL | Zero Detection: ZFGL
Public property | ZeroDetectionZFGR | Zero Detection: ZFGR
Public property | ZeroOutputDZ | Zero Output: DZ
Public property | ZeroOutputPCMZ | Zero Output: PCMZ
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Audio Stereo Digital-To-Analog Converter
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Dsd1794a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Dsd1794a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a Properties

The Dsd1794a type exposes the following members.

Properties
 | Name | Description
Public property | AttenuationLeftATL | Attenuation Left: ATL
Public property | AttenuationRightATR | Attenuation Right: ATR
Public property | AudioControlATLD | Audio Control: ATLD
Public property | AudioControlDME | Audio Control: DME
Public property | AudioControlDMF | Audio Control: DMF
Public property | AudioControlFMT | Audio Control: FMT
Public property | AudioControlMUTE | Audio Control: MUTE
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | OperationControlATS | Operation Control: ATS
Public property | OperationControlDFMS | Operation Control: DFMS
Public property | OperationControlFLT | Operation Control: FLT
Public property | OperationControlINZD | Operation Control: INZD
Public property | OperationControlOPE | Operation Control: OPE
Public property | OperationControlREV | Operation Control: REV
Public property | OperationControlZOE | Operation Control: ZOE
Public property | SignalControlCHSL | Signal Control: CHSL
Public property | SignalControlDFTH | Signal Control: DFTH
Public property | SignalControlDSD | Signal Control: DSD
Public property | SignalControlMONO | Signal Control: MONO
Public property | SignalControlOS | Signal Control: OS
Public property | SignalControlSRST | Signal Control: SRST
Public property | ZeroDetectionZFGL | Zero Detection: ZFGL
Public property | ZeroDetectionZFGR | Zero Detection: ZFGR
Public property | ZeroOutputDZ | Zero Output: DZ
Public property | ZeroOutputPCMZ | Zero Output: PCMZ
Top
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.AttenuationLeftATL Property

IRD

Dsd1794aAttenuationLeftATL Property

Attenuation Left: ATL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeAttenuationLevel AttenuationLeftATL { get; set; }
Public Property AttenuationLeftATL As Dsd1794aTypeAttenuationLevel
    Get
    Set
public:
property Dsd1794aTypeAttenuationLevel AttenuationLeftATL {
    Dsd1794aTypeAttenuationLevel get ();
    void set (Dsd1794aTypeAttenuationLevel value);
}
member AttenuationLeftATL : Dsd1794aTypeAttenuationLevel with get, set

Property Value

Type: Dsd1794aTypeAttenuationLevel
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.AttenuationRightATR Property

IRD

Dsd1794aAttenuationRightATR Property

Attenuation Right: ATR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeAttenuationLevel AttenuationRightATR { get; set; }
Public Property AttenuationRightATR As Dsd1794aTypeAttenuationLevel
    Get
    Set
public:
property Dsd1794aTypeAttenuationLevel AttenuationRightATR {
    Dsd1794aTypeAttenuationLevel get ();
    void set (Dsd1794aTypeAttenuationLevel value);
}
member AttenuationRightATR : Dsd1794aTypeAttenuationLevel with get, set

Property Value

Type: Dsd1794aTypeAttenuationLevel
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.AudioControlATLD Property

IRD

Dsd1794aAudioControlATLD Property

Audio Control: ATLD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeAudioControlAttenuationLoad AudioControlATLD { get; set; }
Public Property AudioControlATLD As Dsd1794aTypeAudioControlAttenuationLoad
    Get
    Set
public:
property Dsd1794aTypeAudioControlAttenuationLoad AudioControlATLD {
    Dsd1794aTypeAudioControlAttenuationLoad get ();
    void set (Dsd1794aTypeAudioControlAttenuationLoad value);
}
member AudioControlATLD : Dsd1794aTypeAudioControlAttenuationLoad with get, set

Property Value

Type: Dsd1794aTypeAudioControlAttenuationLoad
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.AudioControlDME Property

IRD

Dsd1794aAudioControlDME Property

Audio Control: DME

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeAudioControlDeEmphasis AudioControlDME { get; set; }
Public Property AudioControlDME As Dsd1794aTypeAudioControlDeEmphasis
    Get
    Set
public:
property Dsd1794aTypeAudioControlDeEmphasis AudioControlDME {
    Dsd1794aTypeAudioControlDeEmphasis get ();
    void set (Dsd1794aTypeAudioControlDeEmphasis value);
}
member AudioControlDME : Dsd1794aTypeAudioControlDeEmphasis with get, set

Property Value

Type: Dsd1794aTypeAudioControlDeEmphasis
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.AudioControlDMF Property

IRD

Dsd1794aAudioControlDMF Property

Audio Control: DMF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeAudioControlSampling AudioControlDMF { get; set; }
Public Property AudioControlDMF As Dsd1794aTypeAudioControlSampling
    Get
    Set
public:
property Dsd1794aTypeAudioControlSampling AudioControlDMF {
    Dsd1794aTypeAudioControlSampling get ();
    void set (Dsd1794aTypeAudioControlSampling value);
}
member AudioControlDMF : Dsd1794aTypeAudioControlSampling with get, set

Property Value

Type: Dsd1794aTypeAudioControlSampling
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.AudioControlFMT Property

IRD

Dsd1794aAudioControlFMT Property

Audio Control: FMT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeAudioControlDataFormat AudioControlFMT { get; set; }
Public Property AudioControlFMT As Dsd1794aTypeAudioControlDataFormat
    Get
    Set
public:
property Dsd1794aTypeAudioControlDataFormat AudioControlFMT {
    Dsd1794aTypeAudioControlDataFormat get ();
    void set (Dsd1794aTypeAudioControlDataFormat value);
}
member AudioControlFMT : Dsd1794aTypeAudioControlDataFormat with get, set

Property Value

Type: Dsd1794aTypeAudioControlDataFormat
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.AudioControlMUTE Property

IRD

Dsd1794aAudioControlMUTE Property

Audio Control: MUTE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeAudioControlMute AudioControlMUTE { get; set; }
Public Property AudioControlMUTE As Dsd1794aTypeAudioControlMute
    Get
    Set
public:
property Dsd1794aTypeAudioControlMute AudioControlMUTE {
    Dsd1794aTypeAudioControlMute get ();
    void set (Dsd1794aTypeAudioControlMute value);
}
member AudioControlMUTE : Dsd1794aTypeAudioControlMute with get, set

Property Value

Type: Dsd1794aTypeAudioControlMute
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.AutoFlush Property

IRD

Dsd1794aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.OperationControlATS Property

IRD

Dsd1794aOperationControlATS Property

Operation Control: ATS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeOperationControlRate OperationControlATS { get; set; }
Public Property OperationControlATS As Dsd1794aTypeOperationControlRate
    Get
    Set
public:
property Dsd1794aTypeOperationControlRate OperationControlATS {
    Dsd1794aTypeOperationControlRate get ();
    void set (Dsd1794aTypeOperationControlRate value);
}
member OperationControlATS : Dsd1794aTypeOperationControlRate with get, set

Property Value

Type: Dsd1794aTypeOperationControlRate
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.OperationControlDFMS Property

IRD

Dsd1794aOperationControlDFMS Property

Operation Control: DFMS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeOperationControlBypass OperationControlDFMS { get; set; }
Public Property OperationControlDFMS As Dsd1794aTypeOperationControlBypass
    Get
    Set
public:
property Dsd1794aTypeOperationControlBypass OperationControlDFMS {
    Dsd1794aTypeOperationControlBypass get ();
    void set (Dsd1794aTypeOperationControlBypass value);
}
member OperationControlDFMS : Dsd1794aTypeOperationControlBypass with get, set

Property Value

Type: Dsd1794aTypeOperationControlBypass
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.OperationControlFLT Property

IRD

Dsd1794aOperationControlFLT Property

Operation Control: FLT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeOperationControlFilter OperationControlFLT { get; set; }
Public Property OperationControlFLT As Dsd1794aTypeOperationControlFilter
    Get
    Set
public:
property Dsd1794aTypeOperationControlFilter OperationControlFLT {
    Dsd1794aTypeOperationControlFilter get ();
    void set (Dsd1794aTypeOperationControlFilter value);
}
member OperationControlFLT : Dsd1794aTypeOperationControlFilter with get, set

Property Value

Type: Dsd1794aTypeOperationControlFilter
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.OperationControlINZD Property

IRD

Dsd1794aOperationControlINZD Property

Operation Control: INZD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeOperationControlZeroDetect OperationControlINZD { get; set; }
Public Property OperationControlINZD As Dsd1794aTypeOperationControlZeroDetect
    Get
    Set
public:
property Dsd1794aTypeOperationControlZeroDetect OperationControlINZD {
    Dsd1794aTypeOperationControlZeroDetect get ();
    void set (Dsd1794aTypeOperationControlZeroDetect value);
}
member OperationControlINZD : Dsd1794aTypeOperationControlZeroDetect with get, set

Property Value

Type: Dsd1794aTypeOperationControlZeroDetect
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.OperationControlOPE Property

IRD

Dsd1794aOperationControlOPE Property

Operation Control: OPE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeOperationControlDac OperationControlOPE { get; set; }
Public Property OperationControlOPE As Dsd1794aTypeOperationControlDac
    Get
    Set
public:
property Dsd1794aTypeOperationControlDac OperationControlOPE {
    Dsd1794aTypeOperationControlDac get ();
    void set (Dsd1794aTypeOperationControlDac value);
}
member OperationControlOPE : Dsd1794aTypeOperationControlDac with get, set

Property Value

Type: Dsd1794aTypeOperationControlDac
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.OperationControlREV Property

IRD

Dsd1794aOperationControlREV Property

Operation Control: REV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeOperationControlReversal OperationControlREV { get; set; }
Public Property OperationControlREV As Dsd1794aTypeOperationControlReversal
    Get
    Set
public:
property Dsd1794aTypeOperationControlReversal OperationControlREV {
    Dsd1794aTypeOperationControlReversal get ();
    void set (Dsd1794aTypeOperationControlReversal value);
}
member OperationControlREV : Dsd1794aTypeOperationControlReversal with get, set

Property Value

Type: Dsd1794aTypeOperationControlReversal
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.OperationControlZOE Property

IRD

Dsd1794aOperationControlZOE Property

Operation Control: ZOE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeOperationControlZeroFlag OperationControlZOE { get; set; }
Public Property OperationControlZOE As Dsd1794aTypeOperationControlZeroFlag
    Get
    Set
public:
property Dsd1794aTypeOperationControlZeroFlag OperationControlZOE {
    Dsd1794aTypeOperationControlZeroFlag get ();
    void set (Dsd1794aTypeOperationControlZeroFlag value);
}
member OperationControlZOE : Dsd1794aTypeOperationControlZeroFlag with get, set

Property Value

Type: Dsd1794aTypeOperationControlZeroFlag
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.SignalControlCHSL Property

IRD

Dsd1794aSignalControlCHSL Property

Signal Control: CHSL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeSignalControlChannel SignalControlCHSL { get; set; }
Public Property SignalControlCHSL As Dsd1794aTypeSignalControlChannel
    Get
    Set
public:
property Dsd1794aTypeSignalControlChannel SignalControlCHSL {
    Dsd1794aTypeSignalControlChannel get ();
    void set (Dsd1794aTypeSignalControlChannel value);
}
member SignalControlCHSL : Dsd1794aTypeSignalControlChannel with get, set

Property Value

Type: Dsd1794aTypeSignalControlChannel
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.SignalControlDFTH Property

IRD

Dsd1794aSignalControlDFTH Property

Signal Control: DFTH

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeSignalControlFilter SignalControlDFTH { get; set; }
Public Property SignalControlDFTH As Dsd1794aTypeSignalControlFilter
    Get
    Set
public:
property Dsd1794aTypeSignalControlFilter SignalControlDFTH {
    Dsd1794aTypeSignalControlFilter get ();
    void set (Dsd1794aTypeSignalControlFilter value);
}
member SignalControlDFTH : Dsd1794aTypeSignalControlFilter with get, set

Property Value

Type: Dsd1794aTypeSignalControlFilter
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.SignalControlDSD Property

IRD

Dsd1794aSignalControlDSD Property

Signal Control: DSD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeSignalControlMode SignalControlDSD { get; set; }
Public Property SignalControlDSD As Dsd1794aTypeSignalControlMode
    Get
    Set
public:
property Dsd1794aTypeSignalControlMode SignalControlDSD {
    Dsd1794aTypeSignalControlMode get ();
    void set (Dsd1794aTypeSignalControlMode value);
}
member SignalControlDSD : Dsd1794aTypeSignalControlMode with get, set

Property Value

Type: Dsd1794aTypeSignalControlMode
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.SignalControlMONO Property

IRD

Dsd1794aSignalControlMONO Property

Signal Control: MONO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeSignalControlMono SignalControlMONO { get; set; }
Public Property SignalControlMONO As Dsd1794aTypeSignalControlMono
    Get
    Set
public:
property Dsd1794aTypeSignalControlMono SignalControlMONO {
    Dsd1794aTypeSignalControlMono get ();
    void set (Dsd1794aTypeSignalControlMono value);
}
member SignalControlMONO : Dsd1794aTypeSignalControlMono with get, set

Property Value

Type: Dsd1794aTypeSignalControlMono
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.SignalControlOS Property

IRD

Dsd1794aSignalControlOS Property

Signal Control: OS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeSignalControlSpeed SignalControlOS { get; set; }
Public Property SignalControlOS As Dsd1794aTypeSignalControlSpeed
    Get
    Set
public:
property Dsd1794aTypeSignalControlSpeed SignalControlOS {
    Dsd1794aTypeSignalControlSpeed get ();
    void set (Dsd1794aTypeSignalControlSpeed value);
}
member SignalControlOS : Dsd1794aTypeSignalControlSpeed with get, set

Property Value

Type: Dsd1794aTypeSignalControlSpeed
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.SignalControlSRST Property

IRD

Dsd1794aSignalControlSRST Property

Signal Control: SRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeSignalControlReset SignalControlSRST { get; set; }
Public Property SignalControlSRST As Dsd1794aTypeSignalControlReset
    Get
    Set
public:
property Dsd1794aTypeSignalControlReset SignalControlSRST {
    Dsd1794aTypeSignalControlReset get ();
    void set (Dsd1794aTypeSignalControlReset value);
}
member SignalControlSRST : Dsd1794aTypeSignalControlReset with get, set

Property Value

Type: Dsd1794aTypeSignalControlReset
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.ZeroDetectionZFGL Property

IRD

Dsd1794aZeroDetectionZFGL Property

Zero Detection: ZFGL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeZeroDetectionFlagLeft ZeroDetectionZFGL { get; }
Public ReadOnly Property ZeroDetectionZFGL As Dsd1794aTypeZeroDetectionFlagLeft
    Get
public:
property Dsd1794aTypeZeroDetectionFlagLeft ZeroDetectionZFGL {
    Dsd1794aTypeZeroDetectionFlagLeft get ();
}
member ZeroDetectionZFGL : Dsd1794aTypeZeroDetectionFlagLeft with get

Property Value

Type: Dsd1794aTypeZeroDetectionFlagLeft
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.ZeroDetectionZFGR Property

IRD

Dsd1794aZeroDetectionZFGR Property

Zero Detection: ZFGR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeZeroDetectionFlagRight ZeroDetectionZFGR { get; }
Public ReadOnly Property ZeroDetectionZFGR As Dsd1794aTypeZeroDetectionFlagRight
    Get
public:
property Dsd1794aTypeZeroDetectionFlagRight ZeroDetectionZFGR {
    Dsd1794aTypeZeroDetectionFlagRight get ();
}
member ZeroDetectionZFGR : Dsd1794aTypeZeroDetectionFlagRight with get

Property Value

Type: Dsd1794aTypeZeroDetectionFlagRight
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.ZeroOutputDZ Property

IRD

Dsd1794aZeroOutputDZ Property

Zero Output: DZ

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeZeroOutputDsd ZeroOutputDZ { get; set; }
Public Property ZeroOutputDZ As Dsd1794aTypeZeroOutputDsd
    Get
    Set
public:
property Dsd1794aTypeZeroOutputDsd ZeroOutputDZ {
    Dsd1794aTypeZeroOutputDsd get ();
    void set (Dsd1794aTypeZeroOutputDsd value);
}
member ZeroOutputDZ : Dsd1794aTypeZeroOutputDsd with get, set

Property Value

Type: Dsd1794aTypeZeroOutputDsd
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.ZeroOutputPCMZ Property

IRD

Dsd1794aZeroOutputPCMZ Property

Zero Output: PCMZ

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Dsd1794aTypeZeroOutputPcm ZeroOutputPCMZ { get; set; }
Public Property ZeroOutputPCMZ As Dsd1794aTypeZeroOutputPcm
    Get
    Set
public:
property Dsd1794aTypeZeroOutputPcm ZeroOutputPCMZ {
    Dsd1794aTypeZeroOutputPcm get ();
    void set (Dsd1794aTypeZeroOutputPcm value);
}
member ZeroOutputPCMZ : Dsd1794aTypeZeroOutputPcm with get, set

Property Value

Type: Dsd1794aTypeZeroOutputPcm
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a Methods

The Dsd1794a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.Flush Method

IRD

Dsd1794aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Dsd1794a Class
telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeAttenuationLevel Enumeration

IRD

Dsd1794aTypeAttenuationLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuationLevel
Public Enumeration TypeAttenuationLevel
public enum class TypeAttenuationLevel
type TypeAttenuationLevel
Members
Member name | Value | Description
Mute | 0 | Mute
Value_1200DB | 15 | -120.0 dB
Value_1195DB | 16 | -119.5 dB
Value_1190DB | 17 | -119.0 dB
Value_1185DB | 18 | -118.5 dB
Value_1180DB | 19 | -118.0 dB
Value_1175DB | 20 | -117.5 dB
Value_1170DB | 21 | -117.0 dB
Value_1165DB | 22 | -116.5 dB
Value_1160DB | 23 | -116.0 dB
Value_1155DB | 24 | -115.5 dB
Value_1150DB | 25 | -115.0 dB
Value_1145DB | 26 | -114.5 dB
Value_1140DB | 27 | -114.0 dB
Value_1135DB | 28 | -113.5 dB
Value_1130DB | 29 | -113.0 dB
Value_1125DB | 30 | -112.5 dB
Value_1120DB | 31 | -112.0 dB
Value_1115DB | 32 | -111.5 dB
Value_1110DB | 33 | -111.0 dB
Value_1105DB | 34 | -110.5 dB
Value_1100DB | 35 | -110.0 dB
Value_1095DB | 36 | -109.5 dB
Value_1090DB | 37 | -109.0 dB
Value_1085DB | 38 | -108.5 dB
Value_1080DB | 39 | -108.0 dB
Value_1075DB | 40 | -107.5 dB
Value_1070DB | 41 | -107.0 dB
Value_1065DB | 42 | -106.5 dB
Value_1060DB | 43 | -106.0 dB
Value_1055DB | 44 | -105.5 dB
Value_1050DB | 45 | -105.0 dB
Value_1045DB | 46 | -104.5 dB
Value_1040DB | 47 | -104.0 dB
Value_1035DB | 48 | -103.5 dB
Value_1030DB | 49 | -103.0 dB
Value_1025DB | 50 | -102.5 dB
Value_1020DB | 51 | -102.0 dB
Value_1015DB | 52 | -101.5 dB
Value_1010DB | 53 | -101.0 dB
Value_1005DB | 54 | -100.5 dB
Value_1000DB | 55 | -100.0 dB
Value_995DB | 56 | -99.5 dB
Value_990DB | 57 | -99.0 dB
Value_985DB | 58 | -98.5 dB
Value_980DB | 59 | -98.0 dB
Value_975DB | 60 | -97.5 dB
Value_970DB | 61 | -97.0 dB
Value_965DB | 62 | -96.5 dB
Value_960DB | 63 | -96.0 dB
Value_955DB | 64 | -95.5 dB
Value_950DB | 65 | -95.0 dB
Value_945DB | 66 | -94.5 dB
Value_940DB | 67 | -94.0 dB
Value_935DB | 68 | -93.5 dB
Value_930DB | 69 | -93.0 dB
Value_925DB | 70 | -92.5 dB
Value_920DB | 71 | -92.0 dB
Value_915DB | 72 | -91.5 dB
Value_910DB | 73 | -91.0 dB
Value_905DB | 74 | -90.5 dB
Value_900DB | 75 | -90.0 dB
Value_895DB | 76 | -89.5 dB
Value_890DB | 77 | -89.0 dB
Value_885DB | 78 | -88.5 dB
Value_880DB | 79 | -88.0 dB
Value_875DB | 80 | -87.5 dB
Value_870DB | 81 | -87.0 dB
Value_865DB | 82 | -86.5 dB
Value_860DB | 83 | -86.0 dB
Value_855DB | 84 | -85.5 dB
Value_850DB | 85 | -85.0 dB
Value_845DB | 86 | -84.5 dB
Value_840DB | 87 | -84.0 dB
Value_835DB | 88 | -83.5 dB
Value_830DB | 89 | -83.0 dB
Value_825DB | 90 | -82.5 dB
Value_820DB | 91 | -82.0 dB
Value_815DB | 92 | -81.5 dB
Value_810DB | 93 | -81.0 dB
Value_805DB | 94 | -80.5 dB
Value_800DB | 95 | -80.0 dB
Value_795DB | 96 | -79.5 dB
Value_790DB | 97 | -79.0 dB
Value_785DB | 98 | -78.5 dB
Value_780DB | 99 | -78.0 dB
Value_775DB | 100 | -77.5 dB
Value_770DB | 101 | -77.0 dB
Value_765DB | 102 | -76.5 dB
Value_760DB | 103 | -76.0 dB
Value_755DB | 104 | -75.5 dB
Value_750DB | 105 | -75.0 dB
Value_745DB | 106 | -74.5 dB
Value_740DB | 107 | -74.0 dB
Value_735DB | 108 | -73.5 dB
Value_730DB | 109 | -73.0 dB
Value_725DB | 110 | -72.5 dB
Value_720DB | 111 | -72.0 dB
Value_715DB | 112 | -71.5 dB
Value_710DB | 113 | -71.0 dB
Value_705DB | 114 | -70.5 dB
Value_700DB | 115 | -70.0 dB
Value_695DB | 116 | -69.5 dB
Value_690DB | 117 | -69.0 dB
Value_685DB | 118 | -68.5 dB
Value_680DB | 119 | -68.0 dB
Value_675DB | 120 | -67.5 dB
Value_670DB | 121 | -67.0 dB
Value_665DB | 122 | -66.5 dB
Value_660DB | 123 | -66.0 dB
Value_655DB | 124 | -65.5 dB
Value_650DB | 125 | -65.0 dB
Value_645DB | 126 | -64.5 dB
Value_640DB | 127 | -64.0 dB
Value_635DB | 128 | -63.5 dB
Value_630DB | 129 | -63.0 dB
Value_625DB | 130 | -62.5 dB
Value_620DB | 131 | -62.0 dB
Value_615DB | 132 | -61.5 dB
Value_610DB | 133 | -61.0 dB
Value_605DB | 134 | -60.5 dB
Value_600DB | 135 | -60.0 dB
Value_595DB | 136 | -59.5 dB
Value_590DB | 137 | -59.0 dB
Value_585DB | 138 | -58.5 dB
Value_580DB | 139 | -58.0 dB
Value_575DB | 140 | -57.5 dB
Value_570DB | 141 | -57.0 dB
Value_565DB | 142 | -56.5 dB
Value_560DB | 143 | -56.0 dB
Value_555DB | 144 | -55.5 dB
Value_550DB | 145 | -55.0 dB
Value_545DB | 146 | -54.5 dB
Value_540DB | 147 | -54.0 dB
Value_535DB | 148 | -53.5 dB
Value_530DB | 149 | -53.0 dB
Value_525DB | 150 | -52.5 dB
Value_520DB | 151 | -52.0 dB
Value_515DB | 152 | -51.5 dB
Value_510DB | 153 | -51.0 dB
Value_505DB | 154 | -50.5 dB
Value_500DB | 155 | -50.0 dB
Value_495DB | 156 | -49.5 dB
Value_490DB | 157 | -49.0 dB
Value_485DB | 158 | -48.5 dB
Value_480DB | 159 | -48.0 dB
Value_475DB | 160 | -47.5 dB
Value_470DB | 161 | -47.0 dB
Value_465DB | 162 | -46.5 dB
Value_460DB | 163 | -46.0 dB
Value_455DB | 164 | -45.5 dB
Value_450DB | 165 | -45.0 dB
Value_445DB | 166 | -44.5 dB
Value_440DB | 167 | -44.0 dB
Value_435DB | 168 | -43.5 dB
Value_430DB | 169 | -43.0 dB
Value_425DB | 170 | -42.5 dB
Value_420DB | 171 | -42.0 dB
Value_415DB | 172 | -41.5 dB
Value_410DB | 173 | -41.0 dB
Value_405DB | 174 | -40.5 dB
Value_400DB | 175 | -40.0 dB
Value_395DB | 176 | -39.5 dB
Value_390DB | 177 | -39.0 dB
Value_385DB | 178 | -38.5 dB
Value_380DB | 179 | -38.0 dB
Value_375DB | 180 | -37.5 dB
Value_370DB | 181 | -37.0 dB
Value_365DB | 182 | -36.5 dB
Value_360DB | 183 | -36.0 dB
Value_355DB | 184 | -35.5 dB
Value_350DB | 185 | -35.0 dB
Value_345DB | 186 | -34.5 dB
Value_340DB | 187 | -34.0 dB
Value_335DB | 188 | -33.5 dB
Value_330DB | 189 | -33.0 dB
Value_325DB | 190 | -32.5 dB
Value_320DB | 191 | -32.0 dB
Value_315DB | 192 | -31.5 dB
Value_310DB | 193 | -31.0 dB
Value_305DB | 194 | -30.5 dB
Value_300DB | 195 | -30.0 dB
Value_295DB | 196 | -29.5 dB
Value_290DB | 197 | -29.0 dB
Value_285DB | 198 | -28.5 dB
Value_280DB | 199 | -28.0 dB
Value_275DB | 200 | -27.5 dB
Value_270DB | 201 | -27.0 dB
Value_265DB | 202 | -26.5 dB
Value_260DB | 203 | -26.0 dB
Value_255DB | 204 | -25.5 dB
Value_250DB | 205 | -25.0 dB
Value_245DB | 206 | -24.5 dB
Value_240DB | 207 | -24.0 dB
Value_235DB | 208 | -23.5 dB
Value_230DB | 209 | -23.0 dB
Value_225DB | 210 | -22.5 dB
Value_220DB | 211 | -22.0 dB
Value_215DB | 212 | -21.5 dB
Value_210DB | 213 | -21.0 dB
Value_205DB | 214 | -20.5 dB
Value_200DB | 215 | -20.0 dB
Value_195DB | 216 | -19.5 dB
Value_190DB | 217 | -19.0 dB
Value_185DB | 218 | -18.5 dB
Value_180DB | 219 | -18.0 dB
Value_175DB | 220 | -17.5 dB
Value_170DB | 221 | -17.0 dB
Value_165DB | 222 | -16.5 dB
Value_160DB | 223 | -16.0 dB
Value_155DB | 224 | -15.5 dB
Value_150DB | 225 | -15.0 dB
Value_145DB | 226 | -14.5 dB
Value_140DB | 227 | -14.0 dB
Value_135DB | 228 | -13.5 dB
Value_130DB | 229 | -13.0 dB
Value_125DB | 230 | -12.5 dB
Value_120DB | 231 | -12.0 dB
Value_115DB | 232 | -11.5 dB
Value_110DB | 233 | -11.0 dB
Value_105DB | 234 | -10.5 dB
Value_100DB | 235 | -10.0 dB
Value_95DB | 236 | -9.5 dB
Value_90DB | 237 | -9.0 dB
Value_85DB | 238 | -8.5 dB
Value_80DB | 239 | -8.0 dB
Value_75DB | 240 | -7.5 dB
Value_70DB | 241 | -7.0 dB
Value_65DB | 242 | -6.5 dB
Value_60DB | 243 | -6.0 dB
Value_55DB | 244 | -5.5 dB
Value_50DB | 245 | -5.0 dB
Value_45DB | 246 | -4.5 dB
Value_40DB | 247 | -4.0 dB
Value_35DB | 248 | -3.5 dB
Value_30DB | 249 | -3.0 dB
Value_25DB | 250 | -2.5 dB
Value_20DB | 251 | -2.0 dB
Value_15DB | 252 | -1.5 dB
Value_10DB | 253 | -1.0 dB
Value_05DB | 254 | -0.5 dB
Value_0DB | 255 | 0 dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeAudioControlAttenuationLoad Enumeration

IRD

Dsd1794aTypeAudioControlAttenuationLoad Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlAttenuationLoad
Public Enumeration TypeAudioControlAttenuationLoad
public enum class TypeAudioControlAttenuationLoad
type TypeAudioControlAttenuationLoad
Members
Member name | Value | Description
AttenuationControlDisabled | 0 | Attenuation Control: Disabled
AttenuationControlEnabled | 1 | Attenuation Control: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeAudioControlDataFormat Enumeration

IRD

Dsd1794aTypeAudioControlDataFormat Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlDataFormat
Public Enumeration TypeAudioControlDataFormat
public enum class TypeAudioControlDataFormat
type TypeAudioControlDataFormat
Members
Member name | Value | Description
Value_16BitRightJustifiedStandardFormat | 0 | 16 Bit Right-Justified Standard Format
Value_20BitRightJustifiedStandardFormat | 1 | 20 Bit Right-Justified Standard Format
Value_24BitRightJustifiedStandardFormat | 2 | 24 Bit Right-Justified Standard Format
Value_24BitLeftJustifiedMSBFirstFormat | 3 | 24 Bit Left-Justified MSB-First Format
Value_16BitI2SFormat | 4 | 16 Bit I2S Format
Value_24BitI2SFormat | 5 | 24 Bit I2S Format
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeAudioControlDeEmphasis Enumeration

IRD

Dsd1794aTypeAudioControlDeEmphasis Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlDeEmphasis
Public Enumeration TypeAudioControlDeEmphasis
public enum class TypeAudioControlDeEmphasis
type TypeAudioControlDeEmphasis
Members
Member name | Value | Description
DeEmphasisDisabled | 0 | De-Emphasis: Disabled
DeEmphasisEnabled | 1 | De-Emphasis: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeAudioControlMute Enumeration

IRD

Dsd1794aTypeAudioControlMute Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlMute
Public Enumeration TypeAudioControlMute
public enum class TypeAudioControlMute
type TypeAudioControlMute
Members
Member name | Value | Description
MuteDisabled | 0 | Mute: Disabled
MuteEnabled | 1 | Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeAudioControlSampling Enumeration

IRD

Dsd1794aTypeAudioControlSampling Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlSampling
Public Enumeration TypeAudioControlSampling
public enum class TypeAudioControlSampling
type TypeAudioControlSampling
Members
Member name | Value | Description
SamplingFequencyDisabled | 0 | Sampling Fequency: Disabled
SamplingFequency48KHz | 1 | Sampling Fequency: 48 kHz
SamplingFequency441KHz | 2 | Sampling Fequency: 44.1 kHz
SamplingFequency32KHz | 3 | Sampling Fequency: 32 kHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeOperationControlBypass Enumeration

IRD

Dsd1794aTypeOperationControlBypass Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlBypass
Public Enumeration TypeOperationControlBypass
public enum class TypeOperationControlBypass
type TypeOperationControlBypass
Members
Member name | Value | Description
Monaural | 0 | Monaural
StereoInput | 1 | Stereo Input
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeOperationControlDac Enumeration

IRD

Dsd1794aTypeOperationControlDac Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlDac
Public Enumeration TypeOperationControlDac
public enum class TypeOperationControlDac
type TypeOperationControlDac
Members
Member name | Value | Description
DACOperationEnabled | 0 | DAC Operation: Enabled
DACOperationDisabled | 1 | DAC Operation: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeOperationControlFilter Enumeration

IRD

Dsd1794aTypeOperationControlFilter Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlFilter
Public Enumeration TypeOperationControlFilter
public enum class TypeOperationControlFilter
type TypeOperationControlFilter
Members
Member name | Value | Description
DigitalFilterSharpRollOff | 0 | Digital Filter: Sharp Roll-Off
DigitalFilterSlowRollOff | 1 | Digital Filter: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeOperationControlRate Enumeration

IRD

Dsd1794aTypeOperationControlRate Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlRate
Public Enumeration TypeOperationControlRate
public enum class TypeOperationControlRate
type TypeOperationControlRate
Members
Member name | Value | Description
AttenuationRateLRCK1 | 0 | Attenuation Rate: LRCK / 1
AttenuationRateLRCK2 | 1 | Attenuation Rate: LRCK / 2
AttenuationRateLRCK4 | 2 | Attenuation Rate: LRCK / 4
AttenuationRateLRCK8 | 3 | Attenuation Rate: LRCK / 8
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeOperationControlReversal Enumeration

IRD

Dsd1794aTypeOperationControlReversal Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlReversal
Public Enumeration TypeOperationControlReversal
public enum class TypeOperationControlReversal
type TypeOperationControlReversal
Members
Member name | Value | Description
OutputPhaseNormal | 0 | Output Phase: Normal
OutputPhaseInverted | 1 | Output Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeOperationControlZeroDetect Enumeration

IRD

Dsd1794aTypeOperationControlZeroDetect Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlZeroDetect
Public Enumeration TypeOperationControlZeroDetect
public enum class TypeOperationControlZeroDetect
type TypeOperationControlZeroDetect
Members
Member name | Value | Description
InfiniteZeroDetectMuteDisabled | 0 | Infinite Zero Detect Mute: Disabled
InfiniteZeroDetectMuteEnabled | 1 | Infinite Zero Detect Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeOperationControlZeroFlag Enumeration

IRD

Dsd1794aTypeOperationControlZeroFlag Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlZeroFlag
Public Enumeration TypeOperationControlZeroFlag
public enum class TypeOperationControlZeroFlag
type TypeOperationControlZeroFlag
Members
Member name | Value | Description
DSDDataInput | 0 | DSD Data Input
ZeroFlagOutput | 1 | Zero Flag Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeSignalControlChannel Enumeration

IRD

Dsd1794aTypeSignalControlChannel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlChannel
Public Enumeration TypeSignalControlChannel
public enum class TypeSignalControlChannel
type TypeSignalControlChannel
Members
Member name | Value | Description
LChannelSelected | 0 | L-Channel Selected
RChannelSelected | 1 | R-Channel Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeSignalControlFilter Enumeration

IRD

Dsd1794aTypeSignalControlFilter Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlFilter
Public Enumeration TypeSignalControlFilter
public enum class TypeSignalControlFilter
type TypeSignalControlFilter
Members
Member name | Value | Description
DigitalFilterEnabled | 0 | Digital Filter: Enabled
DigitalFilterBypassedForExternalFilter | 1 | Digital Filter: Bypassed For External Filter
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeSignalControlMode Enumeration

IRD

Dsd1794aTypeSignalControlMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlMode
Public Enumeration TypeSignalControlMode
public enum class TypeSignalControlMode
type TypeSignalControlMode
Members
Member name | Value | Description
DSDInterfaceModeDisabled | 0 | DSD Interface Mode: Disabled
DSDInterfaceModeEnabled | 1 | DSD Interface Mode: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeSignalControlMono Enumeration

IRD

Dsd1794aTypeSignalControlMono Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlMono
Public Enumeration TypeSignalControlMono
public enum class TypeSignalControlMono
type TypeSignalControlMono
Members
Member name | Value | Description
StereoMode | 0 | Stereo Mode
MonauralMode | 1 | Monaural Mode
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeSignalControlReset Enumeration

IRD

Dsd1794aTypeSignalControlReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlReset
Public Enumeration TypeSignalControlReset
public enum class TypeSignalControlReset
type TypeSignalControlReset
Members
Member name | Value | Description
SystemResetNormalOperation | 0 | System Reset: Normal Operation
SystemResetOperationOneResetPulse | 1 | System Reset Operation (One Reset Pulse)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeSignalControlSpeed Enumeration

IRD

Dsd1794aTypeSignalControlSpeed Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlSpeed
Public Enumeration TypeSignalControlSpeed
public enum class TypeSignalControlSpeed
type TypeSignalControlSpeed
Members
Member name | Value | Description
OperationSpeed64XFs | 0 | Operation Speed: 64 x Fs
OperationSpeed32XFs | 1 | Operation Speed: 32 x Fs
OperationSpeed128XFs | 2 | Operation Speed: 128 x Fs
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeZeroDetectionFlagLeft Enumeration

IRD

Dsd1794aTypeZeroDetectionFlagLeft Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroDetectionFlagLeft
Public Enumeration TypeZeroDetectionFlagLeft
public enum class TypeZeroDetectionFlagLeft
type TypeZeroDetectionFlagLeft
Members
Member name | Value | Description
LChannelZeroNotDetected | 0 | L-Channel: Zero Not Detected
LChannelZeroDetected | 1 | L-Channel: Zero Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeZeroDetectionFlagRight Enumeration

IRD

Dsd1794aTypeZeroDetectionFlagRight Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroDetectionFlagRight
Public Enumeration TypeZeroDetectionFlagRight
public enum class TypeZeroDetectionFlagRight
type TypeZeroDetectionFlagRight
Members
Member name | Value | Description
RChannelZeroNotDetected | 0 | R-Channel: Zero Not Detected
RChannelZeroDetected | 1 | R-Channel: Zero Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeZeroOutputDsd Enumeration

IRD

Dsd1794aTypeZeroOutputDsd Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroOutputDsd
Public Enumeration TypeZeroOutputDsd
public enum class TypeZeroOutputDsd
type TypeZeroOutputDsd
Members
Member name | Value | Description
ZeroOutputDisabled | 0 | Zero Output: Disabled
ZeroOutputEvenPatternDetect | 1 | Zero Output: Even Pattern Detect
ZeroOutput96HPatternDetect | 2 | Zero Output: 96H Pattern Detect
See Also

Reference

telos.Ird.TexasInstruments Namespace


Dsd1794a.TypeZeroOutputPcm Enumeration

IRD

Dsd1794aTypeZeroOutputPcm Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroOutputPcm
Public Enumeration TypeZeroOutputPcm
public enum class TypeZeroOutputPcm
type TypeZeroOutputPcm
Members
Member name | Value | Description
PCMZeroOutputDisabled | 0 | PCM Zero Output: Disabled
PCMZeroOutputEnabled | 1 | PCM Zero Output: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321 Class

Texas Instruments: LM 49321
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsLm49321

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm49321
Public Class Lm49321
public ref class Lm49321
type Lm49321 =  class end

The Lm49321 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm49321 | Constructor
Top
Properties
 | Name | Description
Public property | AnalogGainANALGAIN | Analog Gain: ANA_L_GAIN (unit: dB)
Public property | AnalogGainANARGAIN | Analog Gain: ANA_R_GAIN (unit: dB)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ClocksAUDIOCLKSEL | Clocks: AUDIO_CLK_SEL
Public property | ClocksFASTCLOCK | Clocks: FAST_CLOCK
Public property | ClocksPLLENABLE | Clocks: PLL_ENABLE
Public property | ClocksPLLINPUT | Clocks: PLL_INPUT
Public property | ClocksRDIV | Clocks: R_DIV
Public property | CompCoeff0COMPCOEFF0 | Comp Coeff0: COMP_COEFF0
Public property | CompCoeff1COMPCOEFF1 | Comp Coeff1: COMP_COEFF1
Public property | CompCoeff2COMPCOEFF2 | Comp Coeff2: COMP_COEFF2
Public property | DACGainDIGLGAIN | DAC Gain: DIG_L_GAIN (unit: dB)
Public property | DACGainDIGRGAIN | DAC Gain: DIG_R_GAIN (unit: dB)
Public property | DACGainMONOINGAIN | DAC Gain: MONO_IN_GAIN (unit: dB)
Public property | DACSetupCUSTCOMP | DAC Setup: CUST_COMP
Public property | DACSetupDACMODE | DAC Setup: DAC_MODE
Public property | DACSetupDITHERALWAYSON | DAC Setup: DITHER_ALWAYS_ON
Public property | DACSetupDITHEROFF | DAC Setup: DITHER_OFF
Public property | DACSetupMUTEL | DAC Setup: MUTE_L
Public property | DACSetupMUTER | DAC Setup: MUTE_R
Public property | EPVolEPVOL | EP Vol: EP_VOL
Public property | HPLVolHPLVOL | HP L Vol: HP_L_VOL
Public property | HPRVolHPRVOL | HP R Vol: HP_R_VOL
Public property | InterfaceI2CFAST | Interface: I2C_FAST
Public property | InterfaceI2SMASTERSLAVE | Interface: I2S_MASTER_SLAVE
Public property | InterfaceI2SMODE | Interface: I2S_MODE
Public property | InterfaceI2SRESOLOLUTION | Interface: I2S_RESOLOLUTION
Public property | LSVolLSVOL | LS Vol: LS_VOL
Public property | ModeControlMODECONTROL | Mode Control: MODE_CONTROL
Public property | ModeControlOCL | Mode Control: OCL
Public property | OutputControlDACINPUTONLY | Output Control: DAC_INPUT_ONLY
Public property | OutputControlEPOUTPUT | Output Control: EP_OUTPUT
Public property | OutputControlHPLOUTPUT | Output Control: HP_L_OUTPUT
Public property | OutputControlHPROUTPUT | Output Control: HP_R_OUTPUT
Public property | OutputControlLSOUTPUT | Output Control: LS_OUTPUT
Public property | OutputControlMONOONLY | Output Control: MONO_ONLY
Public property | OutputControlSTEREOINPUTONLY | Output Control: STEREO_INPUT_ONLY
Public property | OutputControlSTEREOOUTPUTONLY | Output Control: STEREO_OUTPUT_ONLY
Public property | PLLMPLLM | PLL M: PLL_M
Public property | PLLNMODDITHERLEVEL | PLL N MOD: DITHER_LEVEL
Public property | PLLNMODPLLNMOD | PLL N MOD: PLL_N_MOD
Public property | PLLNMODVCOFAST | PLL N MOD: VCO_FAST
Public property | PLLNPLLN | PLL N: PLL_N
Public property | PLLPPLLP | PLL P: PLL_P
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Audio Sub-System With Stereo DAC
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm49321(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm49321

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321 Properties

The Lm49321 type exposes the following members.

Properties
 | Name | Description
Public property | AnalogGainANALGAIN | Analog Gain: ANA_L_GAIN (unit: dB)
Public property | AnalogGainANARGAIN | Analog Gain: ANA_R_GAIN (unit: dB)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ClocksAUDIOCLKSEL | Clocks: AUDIO_CLK_SEL
Public property | ClocksFASTCLOCK | Clocks: FAST_CLOCK
Public property | ClocksPLLENABLE | Clocks: PLL_ENABLE
Public property | ClocksPLLINPUT | Clocks: PLL_INPUT
Public property | ClocksRDIV | Clocks: R_DIV
Public property | CompCoeff0COMPCOEFF0 | Comp Coeff0: COMP_COEFF0
Public property | CompCoeff1COMPCOEFF1 | Comp Coeff1: COMP_COEFF1
Public property | CompCoeff2COMPCOEFF2 | Comp Coeff2: COMP_COEFF2
Public property | DACGainDIGLGAIN | DAC Gain: DIG_L_GAIN (unit: dB)
Public property | DACGainDIGRGAIN | DAC Gain: DIG_R_GAIN (unit: dB)
Public property | DACGainMONOINGAIN | DAC Gain: MONO_IN_GAIN (unit: dB)
Public property | DACSetupCUSTCOMP | DAC Setup: CUST_COMP
Public property | DACSetupDACMODE | DAC Setup: DAC_MODE
Public property | DACSetupDITHERALWAYSON | DAC Setup: DITHER_ALWAYS_ON
Public property | DACSetupDITHEROFF | DAC Setup: DITHER_OFF
Public property | DACSetupMUTEL | DAC Setup: MUTE_L
Public property | DACSetupMUTER | DAC Setup: MUTE_R
Public property | EPVolEPVOL | EP Vol: EP_VOL
Public property | HPLVolHPLVOL | HP L Vol: HP_L_VOL
Public property | HPRVolHPRVOL | HP R Vol: HP_R_VOL
Public property | InterfaceI2CFAST | Interface: I2C_FAST
Public property | InterfaceI2SMASTERSLAVE | Interface: I2S_MASTER_SLAVE
Public property | InterfaceI2SMODE | Interface: I2S_MODE
Public property | InterfaceI2SRESOLOLUTION | Interface: I2S_RESOLOLUTION
Public property | LSVolLSVOL | LS Vol: LS_VOL
Public property | ModeControlMODECONTROL | Mode Control: MODE_CONTROL
Public property | ModeControlOCL | Mode Control: OCL
Public property | OutputControlDACINPUTONLY | Output Control: DAC_INPUT_ONLY
Public property | OutputControlEPOUTPUT | Output Control: EP_OUTPUT
Public property | OutputControlHPLOUTPUT | Output Control: HP_L_OUTPUT
Public property | OutputControlHPROUTPUT | Output Control: HP_R_OUTPUT
Public property | OutputControlLSOUTPUT | Output Control: LS_OUTPUT
Public property | OutputControlMONOONLY | Output Control: MONO_ONLY
Public property | OutputControlSTEREOINPUTONLY | Output Control: STEREO_INPUT_ONLY
Public property | OutputControlSTEREOOUTPUTONLY | Output Control: STEREO_OUTPUT_ONLY
Public property | PLLMPLLM | PLL M: PLL_M
Public property | PLLNMODDITHERLEVEL | PLL N MOD: DITHER_LEVEL
Public property | PLLNMODPLLNMOD | PLL N MOD: PLL_N_MOD
Public property | PLLNMODVCOFAST | PLL N MOD: VCO_FAST
Public property | PLLNPLLN | PLL N: PLL_N
Public property | PLLPPLLP | PLL P: PLL_P
Top
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.AnalogGainANALGAIN Property

IRD

Lm49321AnalogGainANALGAIN Property

Analog Gain: ANA_L_GAIN (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AnalogGainANALGAIN { get; set; }
Public Property AnalogGainANALGAIN As Double
    Get
    Set
public:
property double AnalogGainANALGAIN {
    double get ();
    void set (double value);
}
member AnalogGainANALGAIN : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.AnalogGainANARGAIN Property

IRD

Lm49321AnalogGainANARGAIN Property

Analog Gain: ANA_R_GAIN (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AnalogGainANARGAIN { get; set; }
Public Property AnalogGainANARGAIN As Double
    Get
    Set
public:
property double AnalogGainANARGAIN {
    double get ();
    void set (double value);
}
member AnalogGainANARGAIN : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.AutoFlush Property

IRD

Lm49321AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.ClocksAUDIOCLKSEL Property

IRD

Lm49321ClocksAUDIOCLKSEL Property

Clocks: AUDIO_CLK_SEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeClocksSelect ClocksAUDIOCLKSEL { get; set; }
Public Property ClocksAUDIOCLKSEL As Lm49321TypeClocksSelect
    Get
    Set
public:
property Lm49321TypeClocksSelect ClocksAUDIOCLKSEL {
    Lm49321TypeClocksSelect get ();
    void set (Lm49321TypeClocksSelect value);
}
member ClocksAUDIOCLKSEL : Lm49321TypeClocksSelect with get, set

Property Value

Type: Lm49321TypeClocksSelect
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.ClocksFASTCLOCK Property

IRD

Lm49321ClocksFASTCLOCK Property

Clocks: FAST_CLOCK

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeClocksFast ClocksFASTCLOCK { get; set; }
Public Property ClocksFASTCLOCK As Lm49321TypeClocksFast
    Get
    Set
public:
property Lm49321TypeClocksFast ClocksFASTCLOCK {
    Lm49321TypeClocksFast get ();
    void set (Lm49321TypeClocksFast value);
}
member ClocksFASTCLOCK : Lm49321TypeClocksFast with get, set

Property Value

Type: Lm49321TypeClocksFast
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.ClocksPLLENABLE Property

IRD

Lm49321ClocksPLLENABLE Property

Clocks: PLL_ENABLE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeClocksPllEn ClocksPLLENABLE { get; set; }
Public Property ClocksPLLENABLE As Lm49321TypeClocksPllEn
    Get
    Set
public:
property Lm49321TypeClocksPllEn ClocksPLLENABLE {
    Lm49321TypeClocksPllEn get ();
    void set (Lm49321TypeClocksPllEn value);
}
member ClocksPLLENABLE : Lm49321TypeClocksPllEn with get, set

Property Value

Type: Lm49321TypeClocksPllEn
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.ClocksPLLINPUT Property

IRD

Lm49321ClocksPLLINPUT Property

Clocks: PLL_INPUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeClocksPllIn ClocksPLLINPUT { get; set; }
Public Property ClocksPLLINPUT As Lm49321TypeClocksPllIn
    Get
    Set
public:
property Lm49321TypeClocksPllIn ClocksPLLINPUT {
    Lm49321TypeClocksPllIn get ();
    void set (Lm49321TypeClocksPllIn value);
}
member ClocksPLLINPUT : Lm49321TypeClocksPllIn with get, set

Property Value

Type: Lm49321TypeClocksPllIn
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.ClocksRDIV Property

IRD

Lm49321ClocksRDIV Property

Clocks: R_DIV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeClocksRDivider ClocksRDIV { get; set; }
Public Property ClocksRDIV As Lm49321TypeClocksRDivider
    Get
    Set
public:
property Lm49321TypeClocksRDivider ClocksRDIV {
    Lm49321TypeClocksRDivider get ();
    void set (Lm49321TypeClocksRDivider value);
}
member ClocksRDIV : Lm49321TypeClocksRDivider with get, set

Property Value

Type: Lm49321TypeClocksRDivider
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.CompCoeff0COMPCOEFF0 Property

IRD

Lm49321CompCoeff0COMPCOEFF0 Property

Comp Coeff0: COMP_COEFF0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort CompCoeff0COMPCOEFF0 { get; set; }
Public Property CompCoeff0COMPCOEFF0 As UShort
    Get
    Set
public:
property unsigned short CompCoeff0COMPCOEFF0 {
    unsigned short get ();
    void set (unsigned short value);
}
member CompCoeff0COMPCOEFF0 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.CompCoeff1COMPCOEFF1 Property

IRD

Lm49321CompCoeff1COMPCOEFF1 Property

Comp Coeff1: COMP_COEFF1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort CompCoeff1COMPCOEFF1 { get; set; }
Public Property CompCoeff1COMPCOEFF1 As UShort
    Get
    Set
public:
property unsigned short CompCoeff1COMPCOEFF1 {
    unsigned short get ();
    void set (unsigned short value);
}
member CompCoeff1COMPCOEFF1 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.CompCoeff2COMPCOEFF2 Property

IRD

Lm49321CompCoeff2COMPCOEFF2 Property

Comp Coeff2: COMP_COEFF2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort CompCoeff2COMPCOEFF2 { get; set; }
Public Property CompCoeff2COMPCOEFF2 As UShort
    Get
    Set
public:
property unsigned short CompCoeff2COMPCOEFF2 {
    unsigned short get ();
    void set (unsigned short value);
}
member CompCoeff2COMPCOEFF2 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.DACGainDIGLGAIN Property

IRD

Lm49321DACGainDIGLGAIN Property

DAC Gain: DIG_L_GAIN (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeDacGainDigital DACGainDIGLGAIN { get; set; }
Public Property DACGainDIGLGAIN As Lm49321TypeDacGainDigital
    Get
    Set
public:
property Lm49321TypeDacGainDigital DACGainDIGLGAIN {
    Lm49321TypeDacGainDigital get ();
    void set (Lm49321TypeDacGainDigital value);
}
member DACGainDIGLGAIN : Lm49321TypeDacGainDigital with get, set

Property Value

Type: Lm49321TypeDacGainDigital
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.DACGainDIGRGAIN Property

IRD

Lm49321DACGainDIGRGAIN Property

DAC Gain: DIG_R_GAIN (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeDacGainDigital DACGainDIGRGAIN { get; set; }
Public Property DACGainDIGRGAIN As Lm49321TypeDacGainDigital
    Get
    Set
public:
property Lm49321TypeDacGainDigital DACGainDIGRGAIN {
    Lm49321TypeDacGainDigital get ();
    void set (Lm49321TypeDacGainDigital value);
}
member DACGainDIGRGAIN : Lm49321TypeDacGainDigital with get, set

Property Value

Type: Lm49321TypeDacGainDigital
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.DACGainMONOINGAIN Property

IRD

Lm49321DACGainMONOINGAIN Property

DAC Gain: MONO_IN_GAIN (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DACGainMONOINGAIN { get; set; }
Public Property DACGainMONOINGAIN As Double
    Get
    Set
public:
property double DACGainMONOINGAIN {
    double get ();
    void set (double value);
}
member DACGainMONOINGAIN : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.DACSetupCUSTCOMP Property

IRD

Lm49321DACSetupCUSTCOMP Property

DAC Setup: CUST_COMP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeDacSetupCust DACSetupCUSTCOMP { get; set; }
Public Property DACSetupCUSTCOMP As Lm49321TypeDacSetupCust
    Get
    Set
public:
property Lm49321TypeDacSetupCust DACSetupCUSTCOMP {
    Lm49321TypeDacSetupCust get ();
    void set (Lm49321TypeDacSetupCust value);
}
member DACSetupCUSTCOMP : Lm49321TypeDacSetupCust with get, set

Property Value

Type: Lm49321TypeDacSetupCust
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.DACSetupDACMODE Property

IRD

Lm49321DACSetupDACMODE Property

DAC Setup: DAC_MODE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeDacSetupMode DACSetupDACMODE { get; set; }
Public Property DACSetupDACMODE As Lm49321TypeDacSetupMode
    Get
    Set
public:
property Lm49321TypeDacSetupMode DACSetupDACMODE {
    Lm49321TypeDacSetupMode get ();
    void set (Lm49321TypeDacSetupMode value);
}
member DACSetupDACMODE : Lm49321TypeDacSetupMode with get, set

Property Value

Type: Lm49321TypeDacSetupMode
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.DACSetupDITHERALWAYSON Property

IRD

Lm49321DACSetupDITHERALWAYSON Property

DAC Setup: DITHER_ALWAYS_ON

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeDacSetupDitherAl DACSetupDITHERALWAYSON { get; set; }
Public Property DACSetupDITHERALWAYSON As Lm49321TypeDacSetupDitherAl
    Get
    Set
public:
property Lm49321TypeDacSetupDitherAl DACSetupDITHERALWAYSON {
    Lm49321TypeDacSetupDitherAl get ();
    void set (Lm49321TypeDacSetupDitherAl value);
}
member DACSetupDITHERALWAYSON : Lm49321TypeDacSetupDitherAl with get, set

Property Value

Type: Lm49321TypeDacSetupDitherAl
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.DACSetupDITHEROFF Property

IRD

Lm49321DACSetupDITHEROFF Property

DAC Setup: DITHER_OFF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeDacSetupDitherOff DACSetupDITHEROFF { get; set; }
Public Property DACSetupDITHEROFF As Lm49321TypeDacSetupDitherOff
    Get
    Set
public:
property Lm49321TypeDacSetupDitherOff DACSetupDITHEROFF {
    Lm49321TypeDacSetupDitherOff get ();
    void set (Lm49321TypeDacSetupDitherOff value);
}
member DACSetupDITHEROFF : Lm49321TypeDacSetupDitherOff with get, set

Property Value

Type: Lm49321TypeDacSetupDitherOff
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.DACSetupMUTEL Property

IRD

Lm49321DACSetupMUTEL Property

DAC Setup: MUTE_L

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeDacSetupMuteL DACSetupMUTEL { get; set; }
Public Property DACSetupMUTEL As Lm49321TypeDacSetupMuteL
    Get
    Set
public:
property Lm49321TypeDacSetupMuteL DACSetupMUTEL {
    Lm49321TypeDacSetupMuteL get ();
    void set (Lm49321TypeDacSetupMuteL value);
}
member DACSetupMUTEL : Lm49321TypeDacSetupMuteL with get, set

Property Value

Type: Lm49321TypeDacSetupMuteL
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.DACSetupMUTER Property

IRD

Lm49321DACSetupMUTER Property

DAC Setup: MUTE_R

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeDacSetupMuteR DACSetupMUTER { get; set; }
Public Property DACSetupMUTER As Lm49321TypeDacSetupMuteR
    Get
    Set
public:
property Lm49321TypeDacSetupMuteR DACSetupMUTER {
    Lm49321TypeDacSetupMuteR get ();
    void set (Lm49321TypeDacSetupMuteR value);
}
member DACSetupMUTER : Lm49321TypeDacSetupMuteR with get, set

Property Value

Type: Lm49321TypeDacSetupMuteR
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.EPVolEPVOL Property

IRD

Lm49321EPVolEPVOL Property

EP Vol: EP_VOL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeVolume EPVolEPVOL { get; set; }
Public Property EPVolEPVOL As Lm49321TypeVolume
    Get
    Set
public:
property Lm49321TypeVolume EPVolEPVOL {
    Lm49321TypeVolume get ();
    void set (Lm49321TypeVolume value);
}
member EPVolEPVOL : Lm49321TypeVolume with get, set

Property Value

Type: Lm49321TypeVolume
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.HPLVolHPLVOL Property

IRD

Lm49321HPLVolHPLVOL Property

HP L Vol: HP_L_VOL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeVolume HPLVolHPLVOL { get; set; }
Public Property HPLVolHPLVOL As Lm49321TypeVolume
    Get
    Set
public:
property Lm49321TypeVolume HPLVolHPLVOL {
    Lm49321TypeVolume get ();
    void set (Lm49321TypeVolume value);
}
member HPLVolHPLVOL : Lm49321TypeVolume with get, set

Property Value

Type: Lm49321TypeVolume
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.HPRVolHPRVOL Property

IRD

Lm49321HPRVolHPRVOL Property

HP R Vol: HP_R_VOL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeVolume HPRVolHPRVOL { get; set; }
Public Property HPRVolHPRVOL As Lm49321TypeVolume
    Get
    Set
public:
property Lm49321TypeVolume HPRVolHPRVOL {
    Lm49321TypeVolume get ();
    void set (Lm49321TypeVolume value);
}
member HPRVolHPRVOL : Lm49321TypeVolume with get, set

Property Value

Type: Lm49321TypeVolume
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.InterfaceI2CFAST Property

IRD

Lm49321InterfaceI2CFAST Property

Interface: I2C_FAST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeInterfaceFast InterfaceI2CFAST { get; set; }
Public Property InterfaceI2CFAST As Lm49321TypeInterfaceFast
    Get
    Set
public:
property Lm49321TypeInterfaceFast InterfaceI2CFAST {
    Lm49321TypeInterfaceFast get ();
    void set (Lm49321TypeInterfaceFast value);
}
member InterfaceI2CFAST : Lm49321TypeInterfaceFast with get, set

Property Value

Type: Lm49321TypeInterfaceFast
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.InterfaceI2SMASTERSLAVE Property

IRD

Lm49321InterfaceI2SMASTERSLAVE Property

Interface: I2S_MASTER_SLAVE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeInterfaceSelect InterfaceI2SMASTERSLAVE { get; set; }
Public Property InterfaceI2SMASTERSLAVE As Lm49321TypeInterfaceSelect
    Get
    Set
public:
property Lm49321TypeInterfaceSelect InterfaceI2SMASTERSLAVE {
    Lm49321TypeInterfaceSelect get ();
    void set (Lm49321TypeInterfaceSelect value);
}
member InterfaceI2SMASTERSLAVE : Lm49321TypeInterfaceSelect with get, set

Property Value

Type: Lm49321TypeInterfaceSelect
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.InterfaceI2SMODE Property

IRD

Lm49321InterfaceI2SMODE Property

Interface: I2S_MODE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeInterfaceMode InterfaceI2SMODE { get; set; }
Public Property InterfaceI2SMODE As Lm49321TypeInterfaceMode
    Get
    Set
public:
property Lm49321TypeInterfaceMode InterfaceI2SMODE {
    Lm49321TypeInterfaceMode get ();
    void set (Lm49321TypeInterfaceMode value);
}
member InterfaceI2SMODE : Lm49321TypeInterfaceMode with get, set

Property Value

Type: Lm49321TypeInterfaceMode
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.InterfaceI2SRESOLOLUTION Property

IRD

Lm49321InterfaceI2SRESOLOLUTION Property

Interface: I2S_RESOLOLUTION

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeInterfaceRes InterfaceI2SRESOLOLUTION { get; set; }
Public Property InterfaceI2SRESOLOLUTION As Lm49321TypeInterfaceRes
    Get
    Set
public:
property Lm49321TypeInterfaceRes InterfaceI2SRESOLOLUTION {
    Lm49321TypeInterfaceRes get ();
    void set (Lm49321TypeInterfaceRes value);
}
member InterfaceI2SRESOLOLUTION : Lm49321TypeInterfaceRes with get, set

Property Value

Type: Lm49321TypeInterfaceRes
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.LSVolLSVOL Property

IRD

Lm49321LSVolLSVOL Property

LS Vol: LS_VOL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeVolume LSVolLSVOL { get; set; }
Public Property LSVolLSVOL As Lm49321TypeVolume
    Get
    Set
public:
property Lm49321TypeVolume LSVolLSVOL {
    Lm49321TypeVolume get ();
    void set (Lm49321TypeVolume value);
}
member LSVolLSVOL : Lm49321TypeVolume with get, set

Property Value

Type: Lm49321TypeVolume
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.ModeControlMODECONTROL Property

IRD

Lm49321ModeControlMODECONTROL Property

Mode Control: MODE_CONTROL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeModeControlMixer ModeControlMODECONTROL { get; set; }
Public Property ModeControlMODECONTROL As Lm49321TypeModeControlMixer
    Get
    Set
public:
property Lm49321TypeModeControlMixer ModeControlMODECONTROL {
    Lm49321TypeModeControlMixer get ();
    void set (Lm49321TypeModeControlMixer value);
}
member ModeControlMODECONTROL : Lm49321TypeModeControlMixer with get, set

Property Value

Type: Lm49321TypeModeControlMixer
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.ModeControlOCL Property

IRD

Lm49321ModeControlOCL Property

Mode Control: OCL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeModeControlOcl ModeControlOCL { get; set; }
Public Property ModeControlOCL As Lm49321TypeModeControlOcl
    Get
    Set
public:
property Lm49321TypeModeControlOcl ModeControlOCL {
    Lm49321TypeModeControlOcl get ();
    void set (Lm49321TypeModeControlOcl value);
}
member ModeControlOCL : Lm49321TypeModeControlOcl with get, set

Property Value

Type: Lm49321TypeModeControlOcl
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.OutputControlDACINPUTONLY Property

IRD

Lm49321OutputControlDACINPUTONLY Property

Output Control: DAC_INPUT_ONLY

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeOutputControlDac OutputControlDACINPUTONLY { get; set; }
Public Property OutputControlDACINPUTONLY As Lm49321TypeOutputControlDac
    Get
    Set
public:
property Lm49321TypeOutputControlDac OutputControlDACINPUTONLY {
    Lm49321TypeOutputControlDac get ();
    void set (Lm49321TypeOutputControlDac value);
}
member OutputControlDACINPUTONLY : Lm49321TypeOutputControlDac with get, set

Property Value

Type: Lm49321TypeOutputControlDac
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.OutputControlEPOUTPUT Property

IRD

Lm49321OutputControlEPOUTPUT Property

Output Control: EP_OUTPUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeOutputControlEarpiece OutputControlEPOUTPUT { get; set; }
Public Property OutputControlEPOUTPUT As Lm49321TypeOutputControlEarpiece
    Get
    Set
public:
property Lm49321TypeOutputControlEarpiece OutputControlEPOUTPUT {
    Lm49321TypeOutputControlEarpiece get ();
    void set (Lm49321TypeOutputControlEarpiece value);
}
member OutputControlEPOUTPUT : Lm49321TypeOutputControlEarpiece with get, set

Property Value

Type: Lm49321TypeOutputControlEarpiece
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.OutputControlHPLOUTPUT Property

IRD

Lm49321OutputControlHPLOUTPUT Property

Output Control: HP_L_OUTPUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeOutputControlHpl OutputControlHPLOUTPUT { get; set; }
Public Property OutputControlHPLOUTPUT As Lm49321TypeOutputControlHpl
    Get
    Set
public:
property Lm49321TypeOutputControlHpl OutputControlHPLOUTPUT {
    Lm49321TypeOutputControlHpl get ();
    void set (Lm49321TypeOutputControlHpl value);
}
member OutputControlHPLOUTPUT : Lm49321TypeOutputControlHpl with get, set

Property Value

Type: Lm49321TypeOutputControlHpl
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.OutputControlHPROUTPUT Property

IRD

Lm49321OutputControlHPROUTPUT Property

Output Control: HP_R_OUTPUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeOutputControlHpr OutputControlHPROUTPUT { get; set; }
Public Property OutputControlHPROUTPUT As Lm49321TypeOutputControlHpr
    Get
    Set
public:
property Lm49321TypeOutputControlHpr OutputControlHPROUTPUT {
    Lm49321TypeOutputControlHpr get ();
    void set (Lm49321TypeOutputControlHpr value);
}
member OutputControlHPROUTPUT : Lm49321TypeOutputControlHpr with get, set

Property Value

Type: Lm49321TypeOutputControlHpr
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.OutputControlLSOUTPUT Property

IRD

Lm49321OutputControlLSOUTPUT Property

Output Control: LS_OUTPUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeOutputControlSpeaker OutputControlLSOUTPUT { get; set; }
Public Property OutputControlLSOUTPUT As Lm49321TypeOutputControlSpeaker
    Get
    Set
public:
property Lm49321TypeOutputControlSpeaker OutputControlLSOUTPUT {
    Lm49321TypeOutputControlSpeaker get ();
    void set (Lm49321TypeOutputControlSpeaker value);
}
member OutputControlLSOUTPUT : Lm49321TypeOutputControlSpeaker with get, set

Property Value

Type: Lm49321TypeOutputControlSpeaker
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.OutputControlMONOONLY Property

IRD

Lm49321OutputControlMONOONLY Property

Output Control: MONO_ONLY

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeOutputControlMono OutputControlMONOONLY { get; set; }
Public Property OutputControlMONOONLY As Lm49321TypeOutputControlMono
    Get
    Set
public:
property Lm49321TypeOutputControlMono OutputControlMONOONLY {
    Lm49321TypeOutputControlMono get ();
    void set (Lm49321TypeOutputControlMono value);
}
member OutputControlMONOONLY : Lm49321TypeOutputControlMono with get, set

Property Value

Type: Lm49321TypeOutputControlMono
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.OutputControlSTEREOINPUTONLY Property

IRD

Lm49321OutputControlSTEREOINPUTONLY Property

Output Control: STEREO_INPUT_ONLY

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeOutputControlStereoIn OutputControlSTEREOINPUTONLY { get; set; }
Public Property OutputControlSTEREOINPUTONLY As Lm49321TypeOutputControlStereoIn
    Get
    Set
public:
property Lm49321TypeOutputControlStereoIn OutputControlSTEREOINPUTONLY {
    Lm49321TypeOutputControlStereoIn get ();
    void set (Lm49321TypeOutputControlStereoIn value);
}
member OutputControlSTEREOINPUTONLY : Lm49321TypeOutputControlStereoIn with get, set

Property Value

Type: Lm49321TypeOutputControlStereoIn
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.OutputControlSTEREOOUTPUTONLY Property

IRD

Lm49321OutputControlSTEREOOUTPUTONLY Property

Output Control: STEREO_OUTPUT_ONLY

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypeOutputControlStereoOut OutputControlSTEREOOUTPUTONLY { get; set; }
Public Property OutputControlSTEREOOUTPUTONLY As Lm49321TypeOutputControlStereoOut
    Get
    Set
public:
property Lm49321TypeOutputControlStereoOut OutputControlSTEREOOUTPUTONLY {
    Lm49321TypeOutputControlStereoOut get ();
    void set (Lm49321TypeOutputControlStereoOut value);
}
member OutputControlSTEREOOUTPUTONLY : Lm49321TypeOutputControlStereoOut with get, set

Property Value

Type: Lm49321TypeOutputControlStereoOut
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.PLLMPLLM Property

IRD

Lm49321PLLMPLLM Property

PLL M: PLL_M

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypePllMDivider PLLMPLLM { get; set; }
Public Property PLLMPLLM As Lm49321TypePllMDivider
    Get
    Set
public:
property Lm49321TypePllMDivider PLLMPLLM {
    Lm49321TypePllMDivider get ();
    void set (Lm49321TypePllMDivider value);
}
member PLLMPLLM : Lm49321TypePllMDivider with get, set

Property Value

Type: Lm49321TypePllMDivider
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.PLLNMODDITHERLEVEL Property

IRD

Lm49321PLLNMODDITHERLEVEL Property

PLL N MOD: DITHER_LEVEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypePllNModDither PLLNMODDITHERLEVEL { get; set; }
Public Property PLLNMODDITHERLEVEL As Lm49321TypePllNModDither
    Get
    Set
public:
property Lm49321TypePllNModDither PLLNMODDITHERLEVEL {
    Lm49321TypePllNModDither get ();
    void set (Lm49321TypePllNModDither value);
}
member PLLNMODDITHERLEVEL : Lm49321TypePllNModDither with get, set

Property Value

Type: Lm49321TypePllNModDither
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.PLLNMODPLLNMOD Property

IRD

Lm49321PLLNMODPLLNMOD Property

PLL N MOD: PLL_N_MOD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double PLLNMODPLLNMOD { get; set; }
Public Property PLLNMODPLLNMOD As Double
    Get
    Set
public:
property double PLLNMODPLLNMOD {
    double get ();
    void set (double value);
}
member PLLNMODPLLNMOD : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.PLLNMODVCOFAST Property

IRD

Lm49321PLLNMODVCOFAST Property

PLL N MOD: VCO_FAST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypePllNModVco PLLNMODVCOFAST { get; set; }
Public Property PLLNMODVCOFAST As Lm49321TypePllNModVco
    Get
    Set
public:
property Lm49321TypePllNModVco PLLNMODVCOFAST {
    Lm49321TypePllNModVco get ();
    void set (Lm49321TypePllNModVco value);
}
member PLLNMODVCOFAST : Lm49321TypePllNModVco with get, set

Property Value

Type: Lm49321TypePllNModVco
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.PLLNPLLN Property

IRD

Lm49321PLLNPLLN Property

PLL N: PLL_N

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypePllNDivider PLLNPLLN { get; set; }
Public Property PLLNPLLN As Lm49321TypePllNDivider
    Get
    Set
public:
property Lm49321TypePllNDivider PLLNPLLN {
    Lm49321TypePllNDivider get ();
    void set (Lm49321TypePllNDivider value);
}
member PLLNPLLN : Lm49321TypePllNDivider with get, set

Property Value

Type: Lm49321TypePllNDivider
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.PLLPPLLP Property

IRD

Lm49321PLLPPLLP Property

PLL P: PLL_P

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49321TypePllPDivider PLLPPLLP { get; set; }
Public Property PLLPPLLP As Lm49321TypePllPDivider
    Get
    Set
public:
property Lm49321TypePllPDivider PLLPPLLP {
    Lm49321TypePllPDivider get ();
    void set (Lm49321TypePllPDivider value);
}
member PLLPPLLP : Lm49321TypePllPDivider with get, set

Property Value

Type: Lm49321TypePllPDivider
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321 Methods

The Lm49321 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.Flush Method

IRD

Lm49321Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm49321 Class
telos.Ird.TexasInstruments Namespace


Lm49321.TypeClocksFast Enumeration

IRD

Lm49321TypeClocksFast Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClocksFast
Public Enumeration TypeClocksFast
public enum class TypeClocksFast
type TypeClocksFast
Members
Member name | Value | Description
MCLKFrequencyNormal | 0 | MCLK Frequency: Normal
MCLKFrequencyDividedBy2 | 1 | MCLK Frequency: Divided By 2
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeClocksPllEn Enumeration

IRD

Lm49321TypeClocksPllEn Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClocksPllEn
Public Enumeration TypeClocksPllEn
public enum class TypeClocksPllEn
type TypeClocksPllEn
Members
Member name | Value | Description
PLLDisable | 0 | PLL Disable
PLLEnable | 1 | PLL Enable
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeClocksPllIn Enumeration

IRD

Lm49321TypeClocksPllIn Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClocksPllIn
Public Enumeration TypeClocksPllIn
public enum class TypeClocksPllIn
type TypeClocksPllIn
Members
Member name | Value | Description
PLLInputSourceMCLK | 0 | PLL Input Source: MCLK
PLLInputSourceI2SInputClock | 1 | PLL Input Source: I2S Input Clock
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeClocksRDivider Enumeration

IRD

Lm49321TypeClocksRDivider Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClocksRDivider
Public Enumeration TypeClocksRDivider
public enum class TypeClocksRDivider
type TypeClocksRDivider
Members
Member name | Value | Description
DividerValue1 | 0 | Divider Value: 1
DividerValue1__1 | 1 | Divider Value: 1
DividerValue15 | 2 | Divider Value: 1.5
DividerValue2 | 3 | Divider Value: 2
DividerValue25 | 4 | Divider Value: 2.5
DividerValue3 | 5 | Divider Value: 3
DividerValue35 | 6 | Divider Value: 3.5
DividerValue4 | 7 | Divider Value: 4
DividerValue45 | 8 | Divider Value: 4.5
DividerValue5 | 9 | Divider Value: 5
DividerValue55 | 10 | Divider Value: 5.5
DividerValue6 | 11 | Divider Value: 6
DividerValue65 | 12 | Divider Value: 6.5
DividerValue7 | 13 | Divider Value: 7
DividerValue75 | 14 | Divider Value: 7.5
DividerValue8 | 15 | Divider Value: 8
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeClocksSelect Enumeration

IRD

Lm49321TypeClocksSelect Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClocksSelect
Public Enumeration TypeClocksSelect
public enum class TypeClocksSelect
type TypeClocksSelect
Members
Member name | Value | Description
DACSubSystemSourcePLLInput | 0 | DAC Sub-System Source: PLL Input
DACSubSystemSourcePLLOutput | 1 | DAC Sub-System Source: PLL Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeDacGainDigital Enumeration

IRD

Lm49321TypeDacGainDigital Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacGainDigital
Public Enumeration TypeDacGainDigital
public enum class TypeDacGainDigital
type TypeDacGainDigital
Members
Member name | Value | Description
Value_M_3 | 0 | -3
Value_0 | 1 | 0
Value_3 | 2 | 3
Value_6 | 3 | 6
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeDacSetupCust Enumeration

IRD

Lm49321TypeDacSetupCust Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSetupCust
Public Enumeration TypeDacSetupCust
public enum class TypeDacSetupCust
type TypeDacSetupCust
Members
Member name | Value | Description
ManualFrequencyProgrammingDisabled | 0 | Manual Frequency Programming: Disabled
ManualFrequencyProgrammingEnabled | 1 | Manual Frequency Programming: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeDacSetupDitherAl Enumeration

IRD

Lm49321TypeDacSetupDitherAl Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSetupDitherAl
Public Enumeration TypeDacSetupDitherAl
public enum class TypeDacSetupDitherAl
type TypeDacSetupDitherAl
Members
Member name | Value | Description
DitherInDACPartlyOn | 0 | Dither In DAC: Partly On
DitherInDACAlwaysOn | 1 | Dither In DAC: Always On
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeDacSetupDitherOff Enumeration

IRD

Lm49321TypeDacSetupDitherOff Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSetupDitherOff
Public Enumeration TypeDacSetupDitherOff
public enum class TypeDacSetupDitherOff
type TypeDacSetupDitherOff
Members
Member name | Value | Description
DitherInDACEnabled | 0 | Dither In DAC: Enabled
DitherInDACDisabled | 1 | Dither In DAC: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeDacSetupMode Enumeration

IRD

Lm49321TypeDacSetupMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSetupMode
Public Enumeration TypeDacSetupMode
public enum class TypeDacSetupMode
type TypeDacSetupMode
Members
Member name | Value | Description
Oversampling125TypicalFs48KHzClockRequired12MHz | 0 | Oversampling: 125 / Typical Fs: 48 kHz / Clock Required: 12 MHz
Oversampling128TypicalFs441KHz48KHzClockRequired112869MHz12288MHz | 1 | Oversampling: 128 / Typical Fs: 44.1 kHz, 48 kHz / Clock Required: 11.2869 MHz, 12.288 MHz
Oversampling64TypicalFs96KHzClockRequired12288MHz | 2 | Oversampling: 64 / Typical Fs: 96 kHz / Clock Required: 12.288 MHz
Oversampling32TypicalFs192KHzClockRequired24576MHz | 3 | Oversampling: 32 / Typical Fs: 192 kHz / Clock Required: 24.576 MHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeDacSetupMuteL Enumeration

IRD

Lm49321TypeDacSetupMuteL Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSetupMuteL
Public Enumeration TypeDacSetupMuteL
public enum class TypeDacSetupMuteL
type TypeDacSetupMuteL
Members
Member name | Value | Description
LeftDACChannelNotMuted | 0 | Left DAC Channel: Not Muted
LeftDACChannelMutedOnNextZeroCrossing | 1 | Left DAC Channel: Muted (On Next Zero Crossing)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeDacSetupMuteR Enumeration

IRD

Lm49321TypeDacSetupMuteR Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSetupMuteR
Public Enumeration TypeDacSetupMuteR
public enum class TypeDacSetupMuteR
type TypeDacSetupMuteR
Members
Member name | Value | Description
RightDACChannelNotMuted | 0 | Right DAC Channel: Not Muted
RightDACChannelMutedOnNextZeroCrossing | 1 | Right DAC Channel: Muted (On Next Zero Crossing)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeInterfaceFast Enumeration

IRD

Lm49321TypeInterfaceFast Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterfaceFast
Public Enumeration TypeInterfaceFast
public enum class TypeInterfaceFast
type TypeInterfaceFast
Members
Member name | Value | Description
I2CSpeedUseDefaultUpTo400KHz | 0 | I2C Speed: Use Default Up To 400 kHz
I2CSpeedUseFastModeUpTo34MHz | 1 | I2C Speed: Use Fast Mode Up To 3.4 MHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeInterfaceMode Enumeration

IRD

Lm49321TypeInterfaceMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterfaceMode
Public Enumeration TypeInterfaceMode
public enum class TypeInterfaceMode
type TypeInterfaceMode
Members
Member name | Value | Description
I2SModeTimingNormal | 0 | I2S Mode Timing: Normal
I2SModeTimingLeftJustified | 1 | I2S Mode Timing: Left-Justified
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeInterfaceRes Enumeration

IRD

Lm49321TypeInterfaceRes Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterfaceRes
Public Enumeration TypeInterfaceRes
public enum class TypeInterfaceRes
type TypeInterfaceRes
Members
Member name | Value | Description
I2SResolution16Bit | 0 | I2S Resolution: 16 Bit
I2SResolution32Bit | 1 | I2S Resolution: 32 Bit
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeInterfaceSelect Enumeration

IRD

Lm49321TypeInterfaceSelect Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterfaceSelect
Public Enumeration TypeInterfaceSelect
public enum class TypeInterfaceSelect
type TypeInterfaceSelect
Members
Member name | Value | Description
SlaveModeClockAndWordSelectConfiguredAsInput | 0 | Slave Mode (Clock And Word Select Configured As Input)
MasterModeClockAndWordSelectConfiguredAsOutput | 1 | Master Mode (Clock And Word Select Configured As Output)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeModeControlMixer Enumeration

IRD

Lm49321TypeModeControlMixer Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlMixer
Public Enumeration TypeModeControlMixer
public enum class TypeModeControlMixer
type TypeModeControlMixer
Members
Member name | Value | Description
MonoEarpieceSDLoudspeakerSDHeadphoneLSDHeadphoneRSD | 0 | Mono Earpiece=SD / Loudspeaker=SD / Headphone L=SD / Headphone R=SD
MonoEarpieceMLoudspeakerMHeadphoneLMHeadphoneRM | 9 | Mono Earpiece=M / Loudspeaker=M / Headphone L=M / Headphone R=M
MonoEarpieceALARLoudspeakerALARHeadphoneLALHeadphoneRAR | 10 | Mono Earpiece=AL+AR / Loudspeaker=AL+AR / Headphone L=AL / Headphone R=AR
MonoEarpieceMALARLoudspeakerMALARHeadphoneLMALHeadphoneRMAR | 11 | Mono Earpiece=M+AL+AR / Loudspeaker=M+AL+AR / Headphone L=M+AL / Headphone R=M+AR
MonoEarpieceDLDRLoudspeakerDLDRHeadphoneLDLHeadphoneRDR | 12 | Mono Earpiece=DL+DR / Loudspeaker=DL+DR / Headphone L=DL / Headphone R=DR
MonoEarpieceDLDRALARLoudspeakerDLDRALARHeadphoneLDLALHeadphoneRDRAR | 13 | Mono Earpiece=DL+DR+AL+AR / Loudspeaker=DL+DR+AL+AR / Headphone L=DL+AL / Headphone R=DR+AR
MonoEarpieceMDLDRALARLoudspeakerMDLDRALARHeadphoneLMDLALHeadphoneRMDRAR | 14 | Mono Earpiece=M+DL+DR+AL+AR / Loudspeaker=M+DL+DR+AL+AR / Headphone L=M+DL+AL / Headphone R=M+DR+AR
MonoEarpieceMDLDRLoudspeakerMDLDRHeadphoneLMDLHeadphoneRMDR | 15 | Mono Earpiece=M+DL+DR / Loudspeaker=M+DL+DR / Headphone L=M+DL / Headphone R=M+DR
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeModeControlOcl Enumeration

IRD

Lm49321TypeModeControlOcl Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlOcl
Public Enumeration TypeModeControlOcl
public enum class TypeModeControlOcl
type TypeModeControlOcl
Members
Member name | Value | Description
HeadphoneOutputCapCoupled | 0 | Headphone Output: Cap-Coupled
HeadphoneOutputCapacitorlessOCL | 1 | Headphone Output: Capacitorless (OCL)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeOutputControlDac Enumeration

IRD

Lm49321TypeOutputControlDac Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputControlDac
Public Enumeration TypeOutputControlDac
public enum class TypeOutputControlDac
type TypeOutputControlDac
Members
Member name | Value | Description
DigitalInputsNormalOperation | 0 | Digital Inputs: Normal Operation
DigitalInputsDACLeftAndDACRightOnlyDisableAllOtherInputs | 1 | Digital Inputs: DAC Left And DAC Right Only (Disable All Other Inputs)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeOutputControlEarpiece Enumeration

IRD

Lm49321TypeOutputControlEarpiece Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputControlEarpiece
Public Enumeration TypeOutputControlEarpiece
public enum class TypeOutputControlEarpiece
type TypeOutputControlEarpiece
Members
Member name | Value | Description
MonoEarpieceOutputOff | 0 | Mono Earpiece: Output Off
MonoEarpieceOutputOn | 1 | Mono Earpiece: Output On
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeOutputControlHpl Enumeration

IRD

Lm49321TypeOutputControlHpl Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputControlHpl
Public Enumeration TypeOutputControlHpl
public enum class TypeOutputControlHpl
type TypeOutputControlHpl
Members
Member name | Value | Description
HeadphoneLeftChannelOutputOffOCL0OrMuteOCL1 | 0 | Headphone Left Channel: Output Off (OCL=0) Or Mute (OCL=1)
HeadphoneLeftChannelOutputOn | 1 | Headphone Left Channel: Output On
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeOutputControlHpr Enumeration

IRD

Lm49321TypeOutputControlHpr Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputControlHpr
Public Enumeration TypeOutputControlHpr
public enum class TypeOutputControlHpr
type TypeOutputControlHpr
Members
Member name | Value | Description
HeadphoneRightChannelOutputOffOCL0OrMuteOCL1 | 0 | Headphone Right Channel: Output Off (OCL=0) Or Mute (OCL=1)
HeadphoneRightChannelOutputOn | 1 | Headphone Right Channel: Output On
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeOutputControlMono Enumeration

IRD

Lm49321TypeOutputControlMono Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputControlMono
Public Enumeration TypeOutputControlMono
public enum class TypeOutputControlMono
type TypeOutputControlMono
Members
Member name | Value | Description
EarpieceAndLoudspeakerOutputNormalOperation | 0 | Earpiece And Loudspeaker Output: Normal Operation
EarpieceAndLoudspeakerOutputMUXEnabledDisableHeadphoneMUX | 1 | Earpiece And Loudspeaker Output: MUX Enabled (Disable Headphone MUX)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeOutputControlSpeaker Enumeration

IRD

Lm49321TypeOutputControlSpeaker Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputControlSpeaker
Public Enumeration TypeOutputControlSpeaker
public enum class TypeOutputControlSpeaker
type TypeOutputControlSpeaker
Members
Member name | Value | Description
LoudspeakerOutputOff | 0 | Loudspeaker: Output Off
LoudspeakerOutputOn | 1 | Loudspeaker: Output On
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeOutputControlStereoIn Enumeration

IRD

Lm49321TypeOutputControlStereoIn Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputControlStereoIn
Public Enumeration TypeOutputControlStereoIn
public enum class TypeOutputControlStereoIn
type TypeOutputControlStereoIn
Members
Member name | Value | Description
AnalogInputsNormalOperation | 0 | Analog Inputs: Normal Operation
AnalogInputsAnalogLeftAndRightOnlyDisableAllOtherInputs | 1 | Analog Inputs: Analog Left and Right Only (Disable All Other Inputs)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeOutputControlStereoOut Enumeration

IRD

Lm49321TypeOutputControlStereoOut Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputControlStereoOut
Public Enumeration TypeOutputControlStereoOut
public enum class TypeOutputControlStereoOut
type TypeOutputControlStereoOut
Members
Member name | Value | Description
HeadphoneOutputNormalOperation | 0 | Headphone Output: Normal Operation
HeadphoneOutputMUXEnabledDisableAllOtherOutputMUXS | 1 | Headphone Output: MUX Enabled (Disable All Other Output MUX's)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypePllMDivider Enumeration

IRD

Lm49321TypePllMDivider Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllMDivider
Public Enumeration TypePllMDivider
public enum class TypePllMDivider
type TypePllMDivider
Members
Member name | Value | Description
DividerOff | 0 | Divider Off
Value_1_0 | 1 | 1.0
Value_1_5 | 2 | 1.5
Value_2_0 | 3 | 2.0
Value_2_5 | 4 | 2.5
Value_3_0 | 5 | 3.0
Value_3_5 | 6 | 3.5
Value_4_0 | 7 | 4.0
Value_4_5 | 8 | 4.5
Value_5_0 | 9 | 5.0
Value_5_5 | 10 | 5.5
Value_6_0 | 11 | 6.0
Value_6_5 | 12 | 6.5
Value_7_0 | 13 | 7.0
Value_7_5 | 14 | 7.5
Value_8_0 | 15 | 8.0
Value_8_5 | 16 | 8.5
Value_9_0 | 17 | 9.0
Value_9_5 | 18 | 9.5
Value_10_0 | 19 | 10.0
Value_10_5 | 20 | 10.5
Value_11_0 | 21 | 11.0
Value_11_5 | 22 | 11.5
Value_12_0 | 23 | 12.0
Value_12_5 | 24 | 12.5
Value_13_0 | 25 | 13.0
Value_13_5 | 26 | 13.5
Value_14_0 | 27 | 14.0
Value_14_5 | 28 | 14.5
Value_15_0 | 29 | 15.0
Value_15_5 | 30 | 15.5
Value_16_0 | 31 | 16.0
Value_16_5 | 32 | 16.5
Value_17_0 | 33 | 17.0
Value_17_5 | 34 | 17.5
Value_18_0 | 35 | 18.0
Value_18_5 | 36 | 18.5
Value_19_0 | 37 | 19.0
Value_19_5 | 38 | 19.5
Value_20_0 | 39 | 20.0
Value_20_5 | 40 | 20.5
Value_21_0 | 41 | 21.0
Value_21_5 | 42 | 21.5
Value_22_0 | 43 | 22.0
Value_22_5 | 44 | 22.5
Value_23_0 | 45 | 23.0
Value_23_5 | 46 | 23.5
Value_24_0 | 47 | 24.0
Value_24_5 | 48 | 24.5
Value_25_0 | 49 | 25.0
Value_25_5 | 50 | 25.5
Value_26_0 | 51 | 26.0
Value_26_5 | 52 | 26.5
Value_27_0 | 53 | 27.0
Value_27_5 | 54 | 27.5
Value_28_0 | 55 | 28.0
Value_28_5 | 56 | 28.5
Value_29_0 | 57 | 29.0
Value_29_5 | 58 | 29.5
Value_30_0 | 59 | 30.0
Value_30_5 | 60 | 30.5
Value_31_0 | 61 | 31.0
Value_31_5 | 62 | 31.5
Value_32_0 | 63 | 32.0
Value_32_5 | 64 | 32.5
Value_33_0 | 65 | 33.0
Value_33_5 | 66 | 33.5
Value_34_0 | 67 | 34.0
Value_34_5 | 68 | 34.5
Value_35_0 | 69 | 35.0
Value_35_5 | 70 | 35.5
Value_36_0 | 71 | 36.0
Value_36_5 | 72 | 36.5
Value_37_0 | 73 | 37.0
Value_37_5 | 74 | 37.5
Value_38_0 | 75 | 38.0
Value_38_5 | 76 | 38.5
Value_39_0 | 77 | 39.0
Value_39_5 | 78 | 39.5
Value_40_0 | 79 | 40.0
Value_40_5 | 80 | 40.5
Value_41_0 | 81 | 41.0
Value_41_5 | 82 | 41.5
Value_42_0 | 83 | 42.0
Value_42_5 | 84 | 42.5
Value_43_0 | 85 | 43.0
Value_43_5 | 86 | 43.5
Value_44_0 | 87 | 44.0
Value_44_5 | 88 | 44.5
Value_45_0 | 89 | 45.0
Value_45_5 | 90 | 45.5
Value_46_0 | 91 | 46.0
Value_46_5 | 92 | 46.5
Value_47_0 | 93 | 47.0
Value_47_5 | 94 | 47.5
Value_48_0 | 95 | 48.0
Value_48_5 | 96 | 48.5
Value_49_0 | 97 | 49.0
Value_49_5 | 98 | 49.5
Value_50_0 | 99 | 50.0
Value_50_5 | 100 | 50.5
Value_51_0 | 101 | 51.0
Value_51_5 | 102 | 51.5
Value_52_0 | 103 | 52.0
Value_52_5 | 104 | 52.5
Value_53_0 | 105 | 53.0
Value_53_5 | 106 | 53.5
Value_54_0 | 107 | 54.0
Value_54_5 | 108 | 54.5
Value_55_0 | 109 | 55.0
Value_55_5 | 110 | 55.5
Value_56_0 | 111 | 56.0
Value_56_5 | 112 | 56.5
Value_57_0 | 113 | 57.0
Value_57_5 | 114 | 57.5
Value_58_0 | 115 | 58.0
Value_58_5 | 116 | 58.5
Value_59_0 | 117 | 59.0
Value_59_5 | 118 | 59.5
Value_60_0 | 119 | 60.0
Value_60_5 | 120 | 60.5
Value_61_0 | 121 | 61.0
Value_61_5 | 122 | 61.5
Value_62_0 | 123 | 62.0
Value_62_5 | 124 | 62.5
Value_63_0 | 125 | 63.0
Value_63_5 | 126 | 63.5
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypePllNDivider Enumeration

IRD

Lm49321TypePllNDivider Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllNDivider
Public Enumeration TypePllNDivider
public enum class TypePllNDivider
type TypePllNDivider
Members
Member name | Value | Description
DividerOff | 0 | Divider Off
Value_10 | 1 | 10
Value_11 | 11 | 11
Value_12 | 12 | 12
Value_13 | 13 | 13
Value_14 | 14 | 14
Value_15 | 15 | 15
Value_16 | 16 | 16
Value_17 | 17 | 17
Value_18 | 18 | 18
Value_19 | 19 | 19
Value_20 | 20 | 20
Value_21 | 21 | 21
Value_22 | 22 | 22
Value_23 | 23 | 23
Value_24 | 24 | 24
Value_25 | 25 | 25
Value_26 | 26 | 26
Value_27 | 27 | 27
Value_28 | 28 | 28
Value_29 | 29 | 29
Value_30 | 30 | 30
Value_31 | 31 | 31
Value_32 | 32 | 32
Value_33 | 33 | 33
Value_34 | 34 | 34
Value_35 | 35 | 35
Value_36 | 36 | 36
Value_37 | 37 | 37
Value_38 | 38 | 38
Value_39 | 39 | 39
Value_40 | 40 | 40
Value_41 | 41 | 41
Value_42 | 42 | 42
Value_43 | 43 | 43
Value_44 | 44 | 44
Value_45 | 45 | 45
Value_46 | 46 | 46
Value_47 | 47 | 47
Value_48 | 48 | 48
Value_49 | 49 | 49
Value_50 | 50 | 50
Value_51 | 51 | 51
Value_52 | 52 | 52
Value_53 | 53 | 53
Value_54 | 54 | 54
Value_55 | 55 | 55
Value_56 | 56 | 56
Value_57 | 57 | 57
Value_58 | 58 | 58
Value_59 | 59 | 59
Value_60 | 60 | 60
Value_61 | 61 | 61
Value_62 | 62 | 62
Value_63 | 63 | 63
Value_64 | 64 | 64
Value_65 | 65 | 65
Value_66 | 66 | 66
Value_67 | 67 | 67
Value_68 | 68 | 68
Value_69 | 69 | 69
Value_70 | 70 | 70
Value_71 | 71 | 71
Value_72 | 72 | 72
Value_73 | 73 | 73
Value_74 | 74 | 74
Value_75 | 75 | 75
Value_76 | 76 | 76
Value_77 | 77 | 77
Value_78 | 78 | 78
Value_79 | 79 | 79
Value_80 | 80 | 80
Value_81 | 81 | 81
Value_82 | 82 | 82
Value_83 | 83 | 83
Value_84 | 84 | 84
Value_85 | 85 | 85
Value_86 | 86 | 86
Value_87 | 87 | 87
Value_88 | 88 | 88
Value_89 | 89 | 89
Value_90 | 90 | 90
Value_91 | 91 | 91
Value_92 | 92 | 92
Value_93 | 93 | 93
Value_94 | 94 | 94
Value_95 | 95 | 95
Value_96 | 96 | 96
Value_97 | 97 | 97
Value_98 | 98 | 98
Value_99 | 99 | 99
Value_100 | 100 | 100
Value_101 | 101 | 101
Value_102 | 102 | 102
Value_103 | 103 | 103
Value_104 | 104 | 104
Value_105 | 105 | 105
Value_106 | 106 | 106
Value_107 | 107 | 107
Value_108 | 108 | 108
Value_109 | 109 | 109
Value_110 | 110 | 110
Value_111 | 111 | 111
Value_112 | 112 | 112
Value_113 | 113 | 113
Value_114 | 114 | 114
Value_115 | 115 | 115
Value_116 | 116 | 116
Value_117 | 117 | 117
Value_118 | 118 | 118
Value_119 | 119 | 119
Value_120 | 120 | 120
Value_121 | 121 | 121
Value_122 | 122 | 122
Value_123 | 123 | 123
Value_124 | 124 | 124
Value_125 | 125 | 125
Value_126 | 126 | 126
Value_127 | 127 | 127
Value_128 | 128 | 128
Value_129 | 129 | 129
Value_130 | 130 | 130
Value_131 | 131 | 131
Value_132 | 132 | 132
Value_133 | 133 | 133
Value_134 | 134 | 134
Value_135 | 135 | 135
Value_136 | 136 | 136
Value_137 | 137 | 137
Value_138 | 138 | 138
Value_139 | 139 | 139
Value_140 | 140 | 140
Value_141 | 141 | 141
Value_142 | 142 | 142
Value_143 | 143 | 143
Value_144 | 144 | 144
Value_145 | 145 | 145
Value_146 | 146 | 146
Value_147 | 147 | 147
Value_148 | 148 | 148
Value_149 | 149 | 149
Value_150 | 150 | 150
Value_151 | 151 | 151
Value_152 | 152 | 152
Value_153 | 153 | 153
Value_154 | 154 | 154
Value_155 | 155 | 155
Value_156 | 156 | 156
Value_157 | 157 | 157
Value_158 | 158 | 158
Value_159 | 159 | 159
Value_160 | 160 | 160
Value_161 | 161 | 161
Value_162 | 162 | 162
Value_163 | 163 | 163
Value_164 | 164 | 164
Value_165 | 165 | 165
Value_166 | 166 | 166
Value_167 | 167 | 167
Value_168 | 168 | 168
Value_169 | 169 | 169
Value_170 | 170 | 170
Value_171 | 171 | 171
Value_172 | 172 | 172
Value_173 | 173 | 173
Value_174 | 174 | 174
Value_175 | 175 | 175
Value_176 | 176 | 176
Value_177 | 177 | 177
Value_178 | 178 | 178
Value_179 | 179 | 179
Value_180 | 180 | 180
Value_181 | 181 | 181
Value_182 | 182 | 182
Value_183 | 183 | 183
Value_184 | 184 | 184
Value_185 | 185 | 185
Value_186 | 186 | 186
Value_187 | 187 | 187
Value_188 | 188 | 188
Value_189 | 189 | 189
Value_190 | 190 | 190
Value_191 | 191 | 191
Value_192 | 192 | 192
Value_193 | 193 | 193
Value_194 | 194 | 194
Value_195 | 195 | 195
Value_196 | 196 | 196
Value_197 | 197 | 197
Value_198 | 198 | 198
Value_199 | 199 | 199
Value_200 | 200 | 200
Value_201 | 201 | 201
Value_202 | 202 | 202
Value_203 | 203 | 203
Value_204 | 204 | 204
Value_205 | 205 | 205
Value_206 | 206 | 206
Value_207 | 207 | 207
Value_208 | 208 | 208
Value_209 | 209 | 209
Value_210 | 210 | 210
Value_211 | 211 | 211
Value_212 | 212 | 212
Value_213 | 213 | 213
Value_214 | 214 | 214
Value_215 | 215 | 215
Value_216 | 216 | 216
Value_217 | 217 | 217
Value_218 | 218 | 218
Value_219 | 219 | 219
Value_220 | 220 | 220
Value_221 | 221 | 221
Value_222 | 222 | 222
Value_223 | 223 | 223
Value_224 | 224 | 224
Value_225 | 225 | 225
Value_226 | 226 | 226
Value_227 | 227 | 227
Value_228 | 228 | 228
Value_229 | 229 | 229
Value_230 | 230 | 230
Value_231 | 231 | 231
Value_232 | 232 | 232
Value_233 | 233 | 233
Value_234 | 234 | 234
Value_235 | 235 | 235
Value_236 | 236 | 236
Value_237 | 237 | 237
Value_238 | 238 | 238
Value_239 | 239 | 239
Value_240 | 240 | 240
Value_241 | 241 | 241
Value_242 | 242 | 242
Value_243 | 243 | 243
Value_244 | 244 | 244
Value_245 | 245 | 245
Value_246 | 246 | 246
Value_247 | 247 | 247
Value_248 | 248 | 248
Value_249 | 249 | 249
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypePllNModDither Enumeration

IRD

Lm49321TypePllNModDither Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllNModDither
Public Enumeration TypePllNModDither
public enum class TypePllNModDither
type TypePllNModDither
Members
Member name | Value | Description
NModulatorDitherMedium32 | 0 | N Modulator Dither: Medium (32)
NModulatorDitherSmall16 | 1 | N Modulator Dither: Small (16)
NModulatorDitherLarge48 | 2 | N Modulator Dither: Large (48)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypePllNModVco Enumeration

IRD

Lm49321TypePllNModVco Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllNModVco
Public Enumeration TypePllNModVco
public enum class TypePllNModVco
type TypePllNModVco
Members
Member name | Value | Description
VCOSetTo4055MHz | 0 | VCO Set To 40 - 55 MHz
VCOSetToMaximumFrequency | 1 | VCO Set To Maximum Frequency
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypePllPDivider Enumeration

IRD

Lm49321TypePllPDivider Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllPDivider
Public Enumeration TypePllPDivider
public enum class TypePllPDivider
type TypePllPDivider
Members
Member name | Value | Description
DividerOff | 0 | Divider Off
DividerValue1 | 1 | Divider Value: 1
DividerValue15 | 2 | Divider Value: 1.5
DividerValue2 | 3 | Divider Value: 2
DividerValue25 | 4 | Divider Value: 2.5
DividerValue3 | 5 | Divider Value: 3
DividerValue35 | 6 | Divider Value: 3.5
DividerValue4 | 7 | Divider Value: 4
DividerValue45 | 8 | Divider Value: 4.5
DividerValue5 | 9 | Divider Value: 5
DividerValue55 | 10 | Divider Value: 5.5
DividerValue6 | 11 | Divider Value: 6
DividerValue65 | 12 | Divider Value: 6.5
DividerValue7 | 13 | Divider Value: 7
DividerValue75 | 14 | Divider Value: 7.5
DividerValue8 | 15 | Divider Value: 8
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49321.TypeVolume Enumeration

IRD

Lm49321TypeVolume Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVolume
Public Enumeration TypeVolume
public enum class TypeVolume
type TypeVolume
Members
Member name | Value | Description
Mute | 0 | Mute
Value_56DB | 1 | -56 dB
Value_52DB | 2 | -52 dB
Value_48DB | 3 | -48 dB
Value_45DB | 4 | -45 dB
Value_42DB | 5 | -42 dB
Value_39DB | 6 | -39 dB
Value_36DB | 7 | -36 dB
Value_33DB | 8 | -33 dB
Value_30DB | 9 | -30 dB
Value_28DB | 10 | -28 dB
Value_26DB | 11 | -26 dB
Value_24DB | 12 | -24 dB
Value_22DB | 13 | -22 dB
Value_20DB | 14 | -20 dB
Value_18DB | 15 | -18 dB
Value_16DB | 16 | -16 dB
Value_14DB | 17 | -14 dB
Value_12DB | 18 | -12 dB
Value_10DB | 19 | -10 dB
Value_8DB | 20 | -8 dB
Value_6DB | 21 | -6 dB
Value_4DB | 22 | -4 dB
Value_3DB | 23 | -3 dB
Value_2DB | 24 | -2 dB
Value_1DB | 25 | -1 dB
Value_0DB | 26 | 0 dB
Value_1DB__1 | 27 | 1 dB
Value_2DB__1 | 28 | 2 dB
Value_3DB__1 | 29 | 3 dB
Value_4DB__1 | 30 | 4 dB
Value_5DB | 31 | 5 dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352 Class

Texas Instruments: LM 49352
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsLm49352

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm49352
Public Class Lm49352
public ref class Lm49352
type Lm49352 =  class end

The Lm49352 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm49352 | Constructor
Top
Properties
 | Name | Description
Public property | ADCALC1LIMITER | ADC ALC1: LIMITER
Public property | ADCALC1SAMPLERATE | ADC ALC1: SAMPLE_RATE (unit: kHz)
Public property | ADCALC1SOURCELSEL | ADC ALC1: SOURCE_LSEL
Public property | ADCALC1SOURCEOVR | ADC ALC1: SOURCE_OVR
Public property | ADCALC1SOURCERSEL | ADC ALC1: SOURCE_RSEL
Public property | ADCALC1STEREOLINK | ADC ALC1: STEREO_LINK
Public property | ADCALC2NGENB | ADC ALC2: NG_ENB
Public property | ADCALC2NOISEFLOOR | ADC ALC2: NOISE_FLOOR (unit: dB)
Public property | ADCALC3TARGETLEVEL | ADC ALC3: TARGET_LEVEL (unit: dB)
Public property | ADCALC4ATTACKRATE | ADC ALC4: ATTACK_RATE (unit: μs)
Public property | ADCALC5DECAYRATE | ADC ALC5: DECAY_RATE (unit: μs)
Public property | ADCALC5PKDECAYRATE | ADC ALC5: PK_DECAY_RATE (unit: ms)
Public property | ADCALC6HOLDTIME | ADC ALC6: HOLD_TIME (unit: ms)
Public property | ADCALC7MAXLEVEL | ADC ALC7: MAX_LEVEL
Public property | ADCALC8MINLEVEL | ADC ALC8: MIN_LEVEL
Public property | ADCALCMonLALCMONL | ADC ALC Mon L: ALCMONL
Public property | ADCALCMonLSCLPLDISTORT | ADC ALC Mon L: SCLP_L_DISTORT
Public property | ADCALCMonLSCLPRDISTORT | ADC ALC Mon L: SCLP_R_DISTORT
Public property | ADCALCMonRALCMONR | ADC ALC Mon R: ALCMONR
Public property | ADCALCMonRSCLPLDISTORT | ADC ALC Mon R: SCLP_L_DISTORT
Public property | ADCALCMonRSCLPRDISTORT | ADC ALC Mon R: SCLP_R_DISTORT
Public property | ADCBasicADCCLKSEL | ADC Basic: ADC_CLK_SEL
Public property | ADCBasicADCDSPONLY | ADC Basic: ADC_DSP_ONLY
Public property | ADCBasicMONO | ADC Basic: MONO
Public property | ADCBasicMUTEL | ADC Basic: MUTE_L
Public property | ADCBasicMUTER | ADC Basic: MUTE_R
Public property | ADCBasicOSR | ADC Basic: OSR
Public property | ADCClockADCCLKDIV | ADC Clock: ADC_CLK_DIV
Public property | ADCEQBand1FREQ | ADC EQ Band1: FREQ (unit: Hz)
Public property | ADCEQBand1LEVEL | ADC EQ Band1: LEVEL (unit: dB)
Public property | ADCEQBand2FREQ | ADC EQ_Band2: FREQ (unit: Hz)
Public property | ADCEQBand2LEVEL | ADC EQ Band2: LEVEL (unit: dB)
Public property | ADCEQBand2Q | ADC EQ Band2: Q (unit: Octave)
Public property | ADCEQBand3FREQ | ADC EQ Band3: FREQ (unit: Hz)
Public property | ADCEQBand3LEVEL | ADC EQ Band3: LEVEL (unit: dB)
Public property | ADCEQBand3Q | ADC EQ Band3: Q (unit: Octave)
Public property | ADCEQBand4FREQ | ADC EQ Band4: FREQ (unit: kHz)
Public property | ADCEQBand4LEVEL | ADC EQ Band4: LEVEL (unit: dB)
Public property | ADCEQBand4Q | ADC EQ Band4: Q (unit: Octave)
Public property | ADCEQBand5FREQ | ADC EQ Band5: FREQ (unit: kHz)
Public property | ADCEQBand5LEVEL | ADC EQ Band5: LEVEL (unit: dB)
Public property | ADCFXADCALCENB | ADC FX: ADC_ALC_ENB
Public property | ADCFXADCEQENB | ADC FX: ADC_EQ_ENB
Public property | ADCFXADCHPFENB | ADC FX: ADC_HPF_ENB
Public property | ADCFXADCPKENB | ADC FX: ADC_PK_ENB
Public property | ADCFXADCSCLPENB | ADC FX: ADC_SCLP_ENB
Public property | ADCFXClipADCLCLIP | ADC FX Clip: ADC_L_CLIP
Public property | ADCFXClipADCRCLIP | ADC FX Clip: ADC_R_CLIP
Public property | ADCFXClipEQLCLIP | ADC FX Clip: EQ_L_CLIP
Public property | ADCFXClipEQRCLIP | ADC FX Clip: EQ_R_CLIP
Public property | ADCFXClipGAINLCLIP | ADC FX Clip: GAIN_L_CLIP
Public property | ADCFXClipGAINRCLIP | ADC FX Clip: GAIN_R_CLIP
Public property | ADCFXClipSCLPLCLIP | ADC FX Clip: SCLP_L_CLIP
Public property | ADCFXClipSCLPRCLIP | ADC FX Clip: SCLP_R_CLIP
Public property | ADCInputAUXADCR | ADC Input: AUX_ADCR
Public property | ADCInputDACLADCL | ADC Input: DACL_ADCL
Public property | ADCInputDACRADCR | ADC Input: DACR_ADCR
Public property | ADCInputMICADCL | ADC Input: MIC_ADCL
Public property | ADCInputMICADCR | ADC Input: MIC_ADCR
Public property | ADCInputMONOADCL | ADC Input: MONO_ADCL
Public property | ADCLLevelADCLLEVEL | ADC L Level: ADC_L_LEVEL (unit: dB)
Public property | ADCLLevelSTEREOLINK | ADC L Level: STEREO_LINK
Public property | ADCLVLMonLLVLMONL | ADC LVL Mon L: LVLMONL
Public property | ADCLVLMonRLVLMONR | ADC LVL Mon R: LVLMONR
Public property | ADCMixerADCMIXLEVELL | ADC Mixer: ADC_MIX_LEVEL_L (unit: dB)
Public property | ADCMixerADCMIXLEVELR | ADC Mixer: ADC_MIX_LEVEL_R (unit: dB)
Public property | ADCMixerSTEREOLINK | ADC Mixer: STEREO_LINK
Public property | ADCRLevelADCRLEVEL | ADC R Level: ADC_R_LEVEL (unit: dB)
Public property | ADCSoftclip1SOFTKNEE | ADC Softclip1: SOFT_KNEE
Public property | ADCSoftclip1THRESHOLD | ADC Softclip1: THRESHOLD (unit: dB)
Public property | ADCSoftclip2RATIO | ADC Softclip2: RATIO
Public property | ADCSoftclip3LEVEL | ADC Softclip3: LEVEL (unit: dB)
Public property | AudioPort1BasicCLOCKPHASE | Audio Port1 Basic: CLOCK_PHASE
Public property | AudioPort1BasicRXENABLE | Audio Port1 Basic: RX_ENABLE
Public property | AudioPort1BasicSTEREO | Audio Port1 Basic: STEREO
Public property | AudioPort1BasicSTEREOSYNCPHASE | Audio Port1 Basic: STEREO_SYNC_PHASE
Public property | AudioPort1BasicSYNCINVERT | Audio Port1 Basic: SYNC_INVERT
Public property | AudioPort1BasicSYNCMS | Audio Port1 Basic: SYNC_MS
Public property | AudioPort1BasicTXENABLE | Audio Port1 Basic: TX_ENABLE
Public property | AudioPort1BasisCLKMS | Audio Port1 Basis: CLK_MS
Public property | AudioPort1CLKGen1CLOCKSEL | Audio Port1 CLK Gen1: CLOCK_SEL
Public property | AudioPort1CLKGen1HALFCYCLECLKDIV | Audio Port1 CLK Gen1: HALF_CYCLE_CLK_DIV
Public property | AudioPort1CLKGen2SYNTHDENOM | Audio Port1 CLK Gen2: SYNTH_DENOM
Public property | AudioPort1CLKGen2SYNTHNUM | Audio Port1 CLK Gen2: SYNTH_NUM
Public property | AudioPort1LSEL | Audio Port1: L_SEL
Public property | AudioPort1MONO | Audio Port1: MONO
Public property | AudioPort1RSEL | Audio Port1: R_SEL
Public property | AudioPort1RXCOMPAND | Audio Port1 RX: COMPAND
Public property | AudioPort1RXMSBPOSITION | Audio Port1 RX: MSB_POSITION
Public property | AudioPort1RXRXMODE | Audio Port1 RX: RX_MODE
Public property | AudioPort1RXΜLawALaw | Audio Port1 RX: μLaw/A-Law
Public property | AudioPort1SWAP | Audio Port1: SWAP
Public property | AudioPort1SyncSYNCRATE | Audio Port1 Sync: SYNC_RATE
Public property | AudioPort1SyncSYNCWIDTH | Audio Port1 Sync: SYNC_WIDTH (unit: bits)
Public property | AudioPort1TXCOMPAND | Audio Port1 TX: COMPAND
Public property | AudioPort1TXMSBPOSITION | Audio Port1 TX: MSB_POSITION
Public property | AudioPort1TXTXMODE | Audio Port1 TX: TX_MODE
Public property | AudioPort1TXΜLawALaw | Audio Port1 TX: μLaw/A-Law
Public property | AudioPort1WidthRXWIDTH | Audio Port1 Width: RX_WIDTH (unit: bits)
Public property | AudioPort1WidthTXEXTRABITS | Audio Port1 Width: TX_EXTRA_BITS
Public property | AudioPort1WidthTXWIDTH | Audio Port1 Width: TX_WIDTH (unit: bits)
Public property | AudioPort2BasicCLOCKMS | Audio Port2 Basic: CLOCK_MS
Public property | AudioPort2BasicCLOCKPHASE | Audio Port2 Basic: CLOCK_PHASE
Public property | AudioPort2BasicRXENABLE | Audio Port2 Basic: RX_ENABLE
Public property | AudioPort2BasicSTEREO | Audio Port2 Basic: STEREO
Public property | AudioPort2BasicSTEREOSYNCPHASE | Audio Port2 Basic: STEREO_SYNC_PHASE
Public property | AudioPort2BasicSYNCINVERT | Audio Port2 Basic: SYNC_INVERT
Public property | AudioPort2BasicSYNCMS | Audio Port2 Basic: SYNC_MS
Public property | AudioPort2BasicTXENABLE | Audio Port2 Basic: TX_ENABLE
Public property | AudioPort2CLKGen1CLOCKSEL | Audio Port2 CLK Gen1: CLOCK_SEL
Public property | AudioPort2CLKGen1HALFCYCLECLKDIV | Audio Port2 CLK Gen1: HALF_CYCLE_CLK_DIV
Public property | AudioPort2CLKGen2SYNTHDENOM | Audio Port2 CLK Gen2: SYNTH_DENOM
Public property | AudioPort2CLKGen2SYNTHNUM | Audio Port2 CLK Gen2: SYNTH_NUM
Public property | AudioPort2LSEL | Audio Port2: L_SEL
Public property | AudioPort2MONO | Audio Port2: MONO
Public property | AudioPort2RSEL | Audio Port2: R_SEL
Public property | AudioPort2RXCOMPAND | Audio Port2 RX: COMPAND
Public property | AudioPort2RXMSBPOSITION | Audio Port2 RX: MSB_POSITION
Public property | AudioPort2RXRXMODE | Audio Port2 RX: RX_MODE
Public property | AudioPort2RXΜLawALaw | Audio Port2 RX: μLaw/A-Law
Public property | AudioPort2SWAP | Audio Port2: SWAP
Public property | AudioPort2SyncGenSYNCRATE | Audio Port2 Sync Gen: SYNC_RATE
Public property | AudioPort2SyncGenSYNCWIDTH | Audio Port2 Sync Gen: SYNC_WIDTH (unit: bits)
Public property | AudioPort2TXCOMPAND | Audio Port2 TX: COMPAND
Public property | AudioPort2TXMSBPOSITION | Audio Port2 TX: MSB_POSITION
Public property | AudioPort2TXTXMODE | Audio Port2 TX: TX_MODE
Public property | AudioPort2TXΜLawALaw | Audio Port2 TX: μLaw/A-Law
Public property | AudioPort2WidthRXWIDTH | Audio Port2 Width: RX_WIDTH (unit: bits)
Public property | AudioPort2WidthTXEXTRABITS | Audio Port2 Width: TX_EXTRA_BITS
Public property | AudioPort2WidthTXWIDTH | Audio Port2 Width: TX_WIDTH (unit: bits)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AUXLevelAUXLEVEL | AUX Level: AUX_LEVEL (unit: dB)
Public property | AUXLevelSEDIFF | AUX Level: SE/DIFF
Public property | AUXOutAUXAUX | AUX Out: AUX_AUX
Public property | AUXOutDACLAUX | AUX Out: DACL_AUX
Public property | AUXOutDACRAUX | AUX Out: DACR_AUX
Public property | AUXOutMICAUX | AUX Out: MIC_ AUX
Public property | AUXOutMONOAUX | AUX Out: MONO_AUX
Public property | ClassDAUXLS | Class D: AUX_LS
Public property | ClassDDACLLS | Class D: DACL_LS
Public property | ClassDDACRLS | Class D: DACR_LS
Public property | ClassDMONOLS | Class D: MONO_LS
Public property | DACALC1DACSAMPLE | DAC ALC1: DAC_SAMPLE (unit: kHz)
Public property | DACALC1LIMITER | DAC ALC1: LIMITER
Public property | DACALC1STEREOLINK | DAC ALC1: STEREO_LINK
Public property | DACALC2NGENB | DAC ALC2: NG_ENB
Public property | DACALC2NOISEFLOOR | DAC ALC2: NOISE_FLOOR (unit: dB)
Public property | DACALC3TARGETLEVEL | DAC ALC3: TARGET_LEVEL (unit: dB)
Public property | DACALC4ATTACKRATE | DAC ALC4: ATTACK_RATE (unit: μs)
Public property | DACALC5DECAYRATE | DAC ALC5: DECAY_RATE (unit: μs)
Public property | DACALC5PKDECAYRATE | DAC ALC5: PK_DECAY_RATE (unit: ms)
Public property | DACALC6HOLDTIME | DAC ALC6: HOLD_TIME (unit: ms)
Public property | DACALC7MAXLEVEL | DAC ALC7: MAX_LEVEL
Public property | DACALC8MINLEVEL | DAC ALC8: MIN_LEVEL
Public property | DACALCMonLALCMONL | DAC ALC Mon L: ALCMONL
Public property | DACALCMonLSCLPLDISTORT | DAC ALC Mon L: SCLP_L_DISTORT
Public property | DACALCMonLSCLPRDISTORT | DAC ALC Mon L: SCLP_R_DISTORT
Public property | DACALCMonRALCMONR | DAC ALC Mon R: ALCMONR
Public property | DACALCMonRSCLPLDISTORT | DAC ALC Mon R: SCLP_L_DISTORT
Public property | DACALCMonRSCLPRDISTORT | DAC ALC Mon R: SCLP_R_DISTORT
Public property | DACBasicDACCLKSEL | DAC Basic: DAC_CLK_SEL
Public property | DACBasicDSPONLY | DAC Basic: DSP_ONLY
Public property | DACBasicMODE | DAC Basic: MODE
Public property | DACBasicMUTEL | DAC Basic: MUTE_L
Public property | DACBasicMUTER | DAC Basic: MUTE_R
Public property | DACClockDACCLKDIV | DAC Clock: DAC_CLK_DIV
Public property | DACEQBand1FREQ | DAC EQ Band1: FREQ (unit: Hz)
Public property | DACEQBand1LEVEL | DAC EQ Band1: LEVEL (unit: dB)
Public property | DACEQBand2FREQ | DAC EQ Band2: FREQ (unit: Hz)
Public property | DACEQBand2LEVEL | DAC EQ Band2: LEVEL (unit: dB)
Public property | DACEQBand2Q | DAC EQ Band2: Q (unit: Octave)
Public property | DACEQBand3FREQ | DAC EQ Band3: FREQ (unit: Hz)
Public property | DACEQBand3LEVEL | DAC EQ Band3: LEVEL (unit: dB)
Public property | DACEQBand3Q | DAC EQ Band3: Q (unit: Octave)
Public property | DACEQBand4FREQ | DAC EQ Band4: FREQ (unit: kHz)
Public property | DACEQBand4LEVEL | DAC EQ Band4: LEVEL (unit: dB)
Public property | DACEQBand4Q | DAC EQ Band4: Q (unit: Octave)
Public property | DACEQBand5FREQ | DAC EQ Band5: FREQ (unit: kHz)
Public property | DACEQBand5LEVEL | DAC EQ Band5: LEVEL (unit: dB)
Public property | DACFXClip3DLCLIP | DAC FX Clip: 3D_L_CLIP
Public property | DACFXClip3DRCLIP | DAC FX Clip: 3D_R_CLIP
Public property | DACFXClipEQLCLIP | DAC FX Clip: EQ_L_CLIP
Public property | DACFXClipEQRCLIP | DAC FX Clip: EQ_R_CLIP
Public property | DACFXClipGAINLCLIP | DAC FX Clip: GAIN_L_CLIP
Public property | DACFXClipGAINRCLIP | DAC FX Clip: GAIN_R_CLIP
Public property | DACFXClipSCLPLCLIP | DAC FX Clip: SCLP_L_CLIP
Public property | DACFXClipSCLPRCLIP | DAC FX Clip: SCLP_R_CLIP
Public property | DACFXDACALCENB | DAC FX: DAC_ALC_ENB
Public property | DACFXDACEQENB | DAC FX: DAC_EQ_ENB
Public property | DACFXDACPKENB | DAC FX: DAC_PK_ENB
Public property | DACFXDACSCLPENB | DAC FX: DAC_SCLP_ENB
Public property | DACInputADCL | DAC Input: ADC_L
Public property | DACInputADCR | DAC Input: ADC_R
Public property | DACInputPORT1L | DAC Input: PORT1_L
Public property | DACInputPORT1R | DAC Input: PORT1_R
Public property | DACInputPORT2L | DAC Input: PORT2_L
Public property | DACInputPORT2R | DAC Input: PORT2_R
Public property | DACInputSWAP | DAC Input: SWAP
Public property | DACLLevelDACLLEVEL | DAC L Level: DAC_L_LEVEL (unit: dB)
Public property | DACLVLMonLLVLMONL | DAC LVL Mon L: LVLMONL
Public property | DACLVLMonRLVLMONR | DAC LVL Mon R: LVLMONR
Public property | DACRLevelDACRLEVEL | DAC R Level: DAC_R_LEVEL (unit: dB)
Public property | DACSoftclip1SOFTKNEE | DAC Softclip1: SOFT_KNEE
Public property | DACSoftclip1THRESHOLD | DAC Softclip1: THRESHOLD (unit: dB)
Public property | DACSoftclip2RATIO | DAC Softclip2: RATIO
Public property | DACSoftclip3LEVEL | DAC Softclip3: LEVEL (unit: dB)
Public property | DecimatorInputLSEL | Decimator Input: L_SEL
Public property | DecimatorInputMXRCLKSEL | Decimator Input: MXR_CLK_SEL
Public property | DecimatorInputRSEL | Decimator Input: R_SEL
Public property | ForceCPFORCE | Force: CP_FORCE
Public property | ForceDACREF | Force: DACREF
Public property | GPIO1GPIOMODE | GPIO1: GPIO_MODE
Public property | GPIO1GPIORX | GPIO1: GPIO_RX
Public property | GPIO1GPIOTX | GPIO1: GPIO_TX
Public property | GPIO2SHORT | GPIO2: SHORT
Public property | GPIO2TEMP | GPIO2: TEMP
Public property | HeadphonesLAUXHPL | Headphones L: AUX_HPL
Public property | HeadphonesLDACLHPL | Headphones L: DACL_HPL
Public property | HeadphonesLDACRHPL | Headphones L: DACR_HPL
Public property | HeadphonesLMONOHPL | Headphones L: MONO_HPL
Public property | HeadphonesRAUXHPR | Headphones R: AUX_HPR
Public property | HeadphonesRDACLHPR | Headphones R: DACL_HPR
Public property | HeadphonesRDACRHPR | Headphones R: DACR_HPR
Public property | HeadphonesRMONOHPR | Headphones R: MONO_HPR
Public property | HPFModeHPFMODE | HPF Mode: HPF_MODE
Public property | HPSenseHPSENSE | HP Sense: HP SENSE
Public property | HPSenseHPSENSEAUX | HP Sense: HPSENSE_AUX
Public property | HPSenseHPSENSEAUXD | HP Sense: HPSENSE_AUX_D
Public property | HPSenseHPSENSED | HP Sense: HPSENSE_D
Public property | InputLevel1PORT1RXLLVL | Input Level1: PORT1_RX_L_LVL (unit: dB)
Public property | InputLevel1PORT1RXRLVL | Input Level1: PORT1_RX_R_LVL (unit: dB)
Public property | InputLevel1PORT2RXLLVL | Input Level1: PORT2_RX_L_LVL (unit: dB)
Public property | InputLevel1PORT2RXRLVL | Input Level1: PORT2_RX_R_LVL (unit: dB)
Public property | InputLevel2ADCLLVL | Input Level2: ADC_L_LVL (unit: dB)
Public property | InputLevel2ADCRLVL | Input Level2: ADC_R_LVL (unit: dB)
Public property | InputLevel2INTERPLLVL | Input Level2: INTERP_L_LVL (unit: dB)
Public property | InputLevel2INTERPRLVL | Input Level2: INTERP_R_LVL (unit: dB)
Public property | MICInputMICLEVEL | MIC Input: MIC_LEVEL (unit: dB)
Public property | MICInputMUTE | MIC Input: MUTE
Public property | MICInputSEDIFF | MIC Input: SE_DIFF
Public property | MonoLevelAUXLMONO | Mono Level: AUXL_MONO
Public property | MonoLevelMONOLEVEL | Mono Level: MONO_LEVEL (unit: dB)
Public property | MonoLevelSEDIFF | Mono Level: SE/DIFF
Public property | OutputOptionsAUXLINEOUT | Output Options: AUX_LINE_OUT
Public property | OutputOptionsAUXNEG6dB | Output Options: AUX_NEG_6dB (unit: dB)
Public property | OutputOptionsLRHPLEVEL | Output Options: LR_HP_LEVEL (unit: dB)
Public property | OutputOptionsLSLEVEL | Output Options: LS_LEVEL (unit: dB)
Public property | PLLCLKSelPLLCLKSEL | PLL CLK Sel: PLL_CLK_SEL
Public property | PLLMPLLM | PLL M: PLL_M
Public property | PLLNModPLLNMOD | PLL N Mod: PLL_N_MOD
Public property | PLLNPLLN | PLL N: PLL_N
Public property | PLLP2PLLP2 | PLL P2: PLL_P2
Public property | PLLPPLLP1 | PLL P: PLL_P1
Public property | PMCCLKDivPMCCLKDIV | PMC CLK Div: PMC_CLK_DIV
Public property | PMCClocksPMCCLKSEL | PMC Clocks: PMC_CLK_SEL
Public property | PMCSetupCHIPACTIVE | PMC Setup: CHIP_ACTIVE
Public property | PMCSetupCHIPENABLE | PMC Setup: CHIP_ENABLE
Public property | PMCSetupMCLKOVR | PMC Setup: MCLK_OVR
Public property | PMCSetupOSCENB | PMC Setup: OSC_ENB
Public property | PMCSetupPLLENB | PMC Setup: PLL_ENB
Public property | PMCSetupPLLP2ENB | PMC Setup: PLL_P2ENB
Public property | PMCSetupPORT1CLKOVR | PMC Setup: PORT1_CLK_OVR
Public property | PMCSetupPORT2CLKOVR | PMC Setup: PORT2_CLK_OVR
Public property | ResetSOFTRESET | Reset: SOFT_RESET
Public property | SpreadSpectrumSSDISABLE | Spread Spectrum: SS_DISABLE
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Mono Class D Audio Codec Subsystem With Ground Referenced Headphone Amplifiers
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm49352(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm49352

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352 Properties

The Lm49352 type exposes the following members.

Properties
 | Name | Description
Public property | ADCALC1LIMITER | ADC ALC1: LIMITER
Public property | ADCALC1SAMPLERATE | ADC ALC1: SAMPLE_RATE (unit: kHz)
Public property | ADCALC1SOURCELSEL | ADC ALC1: SOURCE_LSEL
Public property | ADCALC1SOURCEOVR | ADC ALC1: SOURCE_OVR
Public property | ADCALC1SOURCERSEL | ADC ALC1: SOURCE_RSEL
Public property | ADCALC1STEREOLINK | ADC ALC1: STEREO_LINK
Public property | ADCALC2NGENB | ADC ALC2: NG_ENB
Public property | ADCALC2NOISEFLOOR | ADC ALC2: NOISE_FLOOR (unit: dB)
Public property | ADCALC3TARGETLEVEL | ADC ALC3: TARGET_LEVEL (unit: dB)
Public property | ADCALC4ATTACKRATE | ADC ALC4: ATTACK_RATE (unit: μs)
Public property | ADCALC5DECAYRATE | ADC ALC5: DECAY_RATE (unit: μs)
Public property | ADCALC5PKDECAYRATE | ADC ALC5: PK_DECAY_RATE (unit: ms)
Public property | ADCALC6HOLDTIME | ADC ALC6: HOLD_TIME (unit: ms)
Public property | ADCALC7MAXLEVEL | ADC ALC7: MAX_LEVEL
Public property | ADCALC8MINLEVEL | ADC ALC8: MIN_LEVEL
Public property | ADCALCMonLALCMONL | ADC ALC Mon L: ALCMONL
Public property | ADCALCMonLSCLPLDISTORT | ADC ALC Mon L: SCLP_L_DISTORT
Public property | ADCALCMonLSCLPRDISTORT | ADC ALC Mon L: SCLP_R_DISTORT
Public property | ADCALCMonRALCMONR | ADC ALC Mon R: ALCMONR
Public property | ADCALCMonRSCLPLDISTORT | ADC ALC Mon R: SCLP_L_DISTORT
Public property | ADCALCMonRSCLPRDISTORT | ADC ALC Mon R: SCLP_R_DISTORT
Public property | ADCBasicADCCLKSEL | ADC Basic: ADC_CLK_SEL
Public property | ADCBasicADCDSPONLY | ADC Basic: ADC_DSP_ONLY
Public property | ADCBasicMONO | ADC Basic: MONO
Public property | ADCBasicMUTEL | ADC Basic: MUTE_L
Public property | ADCBasicMUTER | ADC Basic: MUTE_R
Public property | ADCBasicOSR | ADC Basic: OSR
Public property | ADCClockADCCLKDIV | ADC Clock: ADC_CLK_DIV
Public property | ADCEQBand1FREQ | ADC EQ Band1: FREQ (unit: Hz)
Public property | ADCEQBand1LEVEL | ADC EQ Band1: LEVEL (unit: dB)
Public property | ADCEQBand2FREQ | ADC EQ_Band2: FREQ (unit: Hz)
Public property | ADCEQBand2LEVEL | ADC EQ Band2: LEVEL (unit: dB)
Public property | ADCEQBand2Q | ADC EQ Band2: Q (unit: Octave)
Public property | ADCEQBand3FREQ | ADC EQ Band3: FREQ (unit: Hz)
Public property | ADCEQBand3LEVEL | ADC EQ Band3: LEVEL (unit: dB)
Public property | ADCEQBand3Q | ADC EQ Band3: Q (unit: Octave)
Public property | ADCEQBand4FREQ | ADC EQ Band4: FREQ (unit: kHz)
Public property | ADCEQBand4LEVEL | ADC EQ Band4: LEVEL (unit: dB)
Public property | ADCEQBand4Q | ADC EQ Band4: Q (unit: Octave)
Public property | ADCEQBand5FREQ | ADC EQ Band5: FREQ (unit: kHz)
Public property | ADCEQBand5LEVEL | ADC EQ Band5: LEVEL (unit: dB)
Public property | ADCFXADCALCENB | ADC FX: ADC_ALC_ENB
Public property | ADCFXADCEQENB | ADC FX: ADC_EQ_ENB
Public property | ADCFXADCHPFENB | ADC FX: ADC_HPF_ENB
Public property | ADCFXADCPKENB | ADC FX: ADC_PK_ENB
Public property | ADCFXADCSCLPENB | ADC FX: ADC_SCLP_ENB
Public property | ADCFXClipADCLCLIP | ADC FX Clip: ADC_L_CLIP
Public property | ADCFXClipADCRCLIP | ADC FX Clip: ADC_R_CLIP
Public property | ADCFXClipEQLCLIP | ADC FX Clip: EQ_L_CLIP
Public property | ADCFXClipEQRCLIP | ADC FX Clip: EQ_R_CLIP
Public property | ADCFXClipGAINLCLIP | ADC FX Clip: GAIN_L_CLIP
Public property | ADCFXClipGAINRCLIP | ADC FX Clip: GAIN_R_CLIP
Public property | ADCFXClipSCLPLCLIP | ADC FX Clip: SCLP_L_CLIP
Public property | ADCFXClipSCLPRCLIP | ADC FX Clip: SCLP_R_CLIP
Public property | ADCInputAUXADCR | ADC Input: AUX_ADCR
Public property | ADCInputDACLADCL | ADC Input: DACL_ADCL
Public property | ADCInputDACRADCR | ADC Input: DACR_ADCR
Public property | ADCInputMICADCL | ADC Input: MIC_ADCL
Public property | ADCInputMICADCR | ADC Input: MIC_ADCR
Public property | ADCInputMONOADCL | ADC Input: MONO_ADCL
Public property | ADCLLevelADCLLEVEL | ADC L Level: ADC_L_LEVEL (unit: dB)
Public property | ADCLLevelSTEREOLINK | ADC L Level: STEREO_LINK
Public property | ADCLVLMonLLVLMONL | ADC LVL Mon L: LVLMONL
Public property | ADCLVLMonRLVLMONR | ADC LVL Mon R: LVLMONR
Public property | ADCMixerADCMIXLEVELL | ADC Mixer: ADC_MIX_LEVEL_L (unit: dB)
Public property | ADCMixerADCMIXLEVELR | ADC Mixer: ADC_MIX_LEVEL_R (unit: dB)
Public property | ADCMixerSTEREOLINK | ADC Mixer: STEREO_LINK
Public property | ADCRLevelADCRLEVEL | ADC R Level: ADC_R_LEVEL (unit: dB)
Public property | ADCSoftclip1SOFTKNEE | ADC Softclip1: SOFT_KNEE
Public property | ADCSoftclip1THRESHOLD | ADC Softclip1: THRESHOLD (unit: dB)
Public property | ADCSoftclip2RATIO | ADC Softclip2: RATIO
Public property | ADCSoftclip3LEVEL | ADC Softclip3: LEVEL (unit: dB)
Public property | AudioPort1BasicCLOCKPHASE | Audio Port1 Basic: CLOCK_PHASE
Public property | AudioPort1BasicRXENABLE | Audio Port1 Basic: RX_ENABLE
Public property | AudioPort1BasicSTEREO | Audio Port1 Basic: STEREO
Public property | AudioPort1BasicSTEREOSYNCPHASE | Audio Port1 Basic: STEREO_SYNC_PHASE
Public property | AudioPort1BasicSYNCINVERT | Audio Port1 Basic: SYNC_INVERT
Public property | AudioPort1BasicSYNCMS | Audio Port1 Basic: SYNC_MS
Public property | AudioPort1BasicTXENABLE | Audio Port1 Basic: TX_ENABLE
Public property | AudioPort1BasisCLKMS | Audio Port1 Basis: CLK_MS
Public property | AudioPort1CLKGen1CLOCKSEL | Audio Port1 CLK Gen1: CLOCK_SEL
Public property | AudioPort1CLKGen1HALFCYCLECLKDIV | Audio Port1 CLK Gen1: HALF_CYCLE_CLK_DIV
Public property | AudioPort1CLKGen2SYNTHDENOM | Audio Port1 CLK Gen2: SYNTH_DENOM
Public property | AudioPort1CLKGen2SYNTHNUM | Audio Port1 CLK Gen2: SYNTH_NUM
Public property | AudioPort1LSEL | Audio Port1: L_SEL
Public property | AudioPort1MONO | Audio Port1: MONO
Public property | AudioPort1RSEL | Audio Port1: R_SEL
Public property | AudioPort1RXCOMPAND | Audio Port1 RX: COMPAND
Public property | AudioPort1RXMSBPOSITION | Audio Port1 RX: MSB_POSITION
Public property | AudioPort1RXRXMODE | Audio Port1 RX: RX_MODE
Public property | AudioPort1RXΜLawALaw | Audio Port1 RX: μLaw/A-Law
Public property | AudioPort1SWAP | Audio Port1: SWAP
Public property | AudioPort1SyncSYNCRATE | Audio Port1 Sync: SYNC_RATE
Public property | AudioPort1SyncSYNCWIDTH | Audio Port1 Sync: SYNC_WIDTH (unit: bits)
Public property | AudioPort1TXCOMPAND | Audio Port1 TX: COMPAND
Public property | AudioPort1TXMSBPOSITION | Audio Port1 TX: MSB_POSITION
Public property | AudioPort1TXTXMODE | Audio Port1 TX: TX_MODE
Public property | AudioPort1TXΜLawALaw | Audio Port1 TX: μLaw/A-Law
Public property | AudioPort1WidthRXWIDTH | Audio Port1 Width: RX_WIDTH (unit: bits)
Public property | AudioPort1WidthTXEXTRABITS | Audio Port1 Width: TX_EXTRA_BITS
Public property | AudioPort1WidthTXWIDTH | Audio Port1 Width: TX_WIDTH (unit: bits)
Public property | AudioPort2BasicCLOCKMS | Audio Port2 Basic: CLOCK_MS
Public property | AudioPort2BasicCLOCKPHASE | Audio Port2 Basic: CLOCK_PHASE
Public property | AudioPort2BasicRXENABLE | Audio Port2 Basic: RX_ENABLE
Public property | AudioPort2BasicSTEREO | Audio Port2 Basic: STEREO
Public property | AudioPort2BasicSTEREOSYNCPHASE | Audio Port2 Basic: STEREO_SYNC_PHASE
Public property | AudioPort2BasicSYNCINVERT | Audio Port2 Basic: SYNC_INVERT
Public property | AudioPort2BasicSYNCMS | Audio Port2 Basic: SYNC_MS
Public property | AudioPort2BasicTXENABLE | Audio Port2 Basic: TX_ENABLE
Public property | AudioPort2CLKGen1CLOCKSEL | Audio Port2 CLK Gen1: CLOCK_SEL
Public property | AudioPort2CLKGen1HALFCYCLECLKDIV | Audio Port2 CLK Gen1: HALF_CYCLE_CLK_DIV
Public property | AudioPort2CLKGen2SYNTHDENOM | Audio Port2 CLK Gen2: SYNTH_DENOM
Public property | AudioPort2CLKGen2SYNTHNUM | Audio Port2 CLK Gen2: SYNTH_NUM
Public property | AudioPort2LSEL | Audio Port2: L_SEL
Public property | AudioPort2MONO | Audio Port2: MONO
Public property | AudioPort2RSEL | Audio Port2: R_SEL
Public property | AudioPort2RXCOMPAND | Audio Port2 RX: COMPAND
Public property | AudioPort2RXMSBPOSITION | Audio Port2 RX: MSB_POSITION
Public property | AudioPort2RXRXMODE | Audio Port2 RX: RX_MODE
Public property | AudioPort2RXΜLawALaw | Audio Port2 RX: μLaw/A-Law
Public property | AudioPort2SWAP | Audio Port2: SWAP
Public property | AudioPort2SyncGenSYNCRATE | Audio Port2 Sync Gen: SYNC_RATE
Public property | AudioPort2SyncGenSYNCWIDTH | Audio Port2 Sync Gen: SYNC_WIDTH (unit: bits)
Public property | AudioPort2TXCOMPAND | Audio Port2 TX: COMPAND
Public property | AudioPort2TXMSBPOSITION | Audio Port2 TX: MSB_POSITION
Public property | AudioPort2TXTXMODE | Audio Port2 TX: TX_MODE
Public property | AudioPort2TXΜLawALaw | Audio Port2 TX: μLaw/A-Law
Public property | AudioPort2WidthRXWIDTH | Audio Port2 Width: RX_WIDTH (unit: bits)
Public property | AudioPort2WidthTXEXTRABITS | Audio Port2 Width: TX_EXTRA_BITS
Public property | AudioPort2WidthTXWIDTH | Audio Port2 Width: TX_WIDTH (unit: bits)
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | AUXLevelAUXLEVEL | AUX Level: AUX_LEVEL (unit: dB)
Public property | AUXLevelSEDIFF | AUX Level: SE/DIFF
Public property | AUXOutAUXAUX | AUX Out: AUX_AUX
Public property | AUXOutDACLAUX | AUX Out: DACL_AUX
Public property | AUXOutDACRAUX | AUX Out: DACR_AUX
Public property | AUXOutMICAUX | AUX Out: MIC_ AUX
Public property | AUXOutMONOAUX | AUX Out: MONO_AUX
Public property | ClassDAUXLS | Class D: AUX_LS
Public property | ClassDDACLLS | Class D: DACL_LS
Public property | ClassDDACRLS | Class D: DACR_LS
Public property | ClassDMONOLS | Class D: MONO_LS
Public property | DACALC1DACSAMPLE | DAC ALC1: DAC_SAMPLE (unit: kHz)
Public property | DACALC1LIMITER | DAC ALC1: LIMITER
Public property | DACALC1STEREOLINK | DAC ALC1: STEREO_LINK
Public property | DACALC2NGENB | DAC ALC2: NG_ENB
Public property | DACALC2NOISEFLOOR | DAC ALC2: NOISE_FLOOR (unit: dB)
Public property | DACALC3TARGETLEVEL | DAC ALC3: TARGET_LEVEL (unit: dB)
Public property | DACALC4ATTACKRATE | DAC ALC4: ATTACK_RATE (unit: μs)
Public property | DACALC5DECAYRATE | DAC ALC5: DECAY_RATE (unit: μs)
Public property | DACALC5PKDECAYRATE | DAC ALC5: PK_DECAY_RATE (unit: ms)
Public property | DACALC6HOLDTIME | DAC ALC6: HOLD_TIME (unit: ms)
Public property | DACALC7MAXLEVEL | DAC ALC7: MAX_LEVEL
Public property | DACALC8MINLEVEL | DAC ALC8: MIN_LEVEL
Public property | DACALCMonLALCMONL | DAC ALC Mon L: ALCMONL
Public property | DACALCMonLSCLPLDISTORT | DAC ALC Mon L: SCLP_L_DISTORT
Public property | DACALCMonLSCLPRDISTORT | DAC ALC Mon L: SCLP_R_DISTORT
Public property | DACALCMonRALCMONR | DAC ALC Mon R: ALCMONR
Public property | DACALCMonRSCLPLDISTORT | DAC ALC Mon R: SCLP_L_DISTORT
Public property | DACALCMonRSCLPRDISTORT | DAC ALC Mon R: SCLP_R_DISTORT
Public property | DACBasicDACCLKSEL | DAC Basic: DAC_CLK_SEL
Public property | DACBasicDSPONLY | DAC Basic: DSP_ONLY
Public property | DACBasicMODE | DAC Basic: MODE
Public property | DACBasicMUTEL | DAC Basic: MUTE_L
Public property | DACBasicMUTER | DAC Basic: MUTE_R
Public property | DACClockDACCLKDIV | DAC Clock: DAC_CLK_DIV
Public property | DACEQBand1FREQ | DAC EQ Band1: FREQ (unit: Hz)
Public property | DACEQBand1LEVEL | DAC EQ Band1: LEVEL (unit: dB)
Public property | DACEQBand2FREQ | DAC EQ Band2: FREQ (unit: Hz)
Public property | DACEQBand2LEVEL | DAC EQ Band2: LEVEL (unit: dB)
Public property | DACEQBand2Q | DAC EQ Band2: Q (unit: Octave)
Public property | DACEQBand3FREQ | DAC EQ Band3: FREQ (unit: Hz)
Public property | DACEQBand3LEVEL | DAC EQ Band3: LEVEL (unit: dB)
Public property | DACEQBand3Q | DAC EQ Band3: Q (unit: Octave)
Public property | DACEQBand4FREQ | DAC EQ Band4: FREQ (unit: kHz)
Public property | DACEQBand4LEVEL | DAC EQ Band4: LEVEL (unit: dB)
Public property | DACEQBand4Q | DAC EQ Band4: Q (unit: Octave)
Public property | DACEQBand5FREQ | DAC EQ Band5: FREQ (unit: kHz)
Public property | DACEQBand5LEVEL | DAC EQ Band5: LEVEL (unit: dB)
Public property | DACFXClip3DLCLIP | DAC FX Clip: 3D_L_CLIP
Public property | DACFXClip3DRCLIP | DAC FX Clip: 3D_R_CLIP
Public property | DACFXClipEQLCLIP | DAC FX Clip: EQ_L_CLIP
Public property | DACFXClipEQRCLIP | DAC FX Clip: EQ_R_CLIP
Public property | DACFXClipGAINLCLIP | DAC FX Clip: GAIN_L_CLIP
Public property | DACFXClipGAINRCLIP | DAC FX Clip: GAIN_R_CLIP
Public property | DACFXClipSCLPLCLIP | DAC FX Clip: SCLP_L_CLIP
Public property | DACFXClipSCLPRCLIP | DAC FX Clip: SCLP_R_CLIP
Public property | DACFXDACALCENB | DAC FX: DAC_ALC_ENB
Public property | DACFXDACEQENB | DAC FX: DAC_EQ_ENB
Public property | DACFXDACPKENB | DAC FX: DAC_PK_ENB
Public property | DACFXDACSCLPENB | DAC FX: DAC_SCLP_ENB
Public property | DACInputADCL | DAC Input: ADC_L
Public property | DACInputADCR | DAC Input: ADC_R
Public property | DACInputPORT1L | DAC Input: PORT1_L
Public property | DACInputPORT1R | DAC Input: PORT1_R
Public property | DACInputPORT2L | DAC Input: PORT2_L
Public property | DACInputPORT2R | DAC Input: PORT2_R
Public property | DACInputSWAP | DAC Input: SWAP
Public property | DACLLevelDACLLEVEL | DAC L Level: DAC_L_LEVEL (unit: dB)
Public property | DACLVLMonLLVLMONL | DAC LVL Mon L: LVLMONL
Public property | DACLVLMonRLVLMONR | DAC LVL Mon R: LVLMONR
Public property | DACRLevelDACRLEVEL | DAC R Level: DAC_R_LEVEL (unit: dB)
Public property | DACSoftclip1SOFTKNEE | DAC Softclip1: SOFT_KNEE
Public property | DACSoftclip1THRESHOLD | DAC Softclip1: THRESHOLD (unit: dB)
Public property | DACSoftclip2RATIO | DAC Softclip2: RATIO
Public property | DACSoftclip3LEVEL | DAC Softclip3: LEVEL (unit: dB)
Public property | DecimatorInputLSEL | Decimator Input: L_SEL
Public property | DecimatorInputMXRCLKSEL | Decimator Input: MXR_CLK_SEL
Public property | DecimatorInputRSEL | Decimator Input: R_SEL
Public property | ForceCPFORCE | Force: CP_FORCE
Public property | ForceDACREF | Force: DACREF
Public property | GPIO1GPIOMODE | GPIO1: GPIO_MODE
Public property | GPIO1GPIORX | GPIO1: GPIO_RX
Public property | GPIO1GPIOTX | GPIO1: GPIO_TX
Public property | GPIO2SHORT | GPIO2: SHORT
Public property | GPIO2TEMP | GPIO2: TEMP
Public property | HeadphonesLAUXHPL | Headphones L: AUX_HPL
Public property | HeadphonesLDACLHPL | Headphones L: DACL_HPL
Public property | HeadphonesLDACRHPL | Headphones L: DACR_HPL
Public property | HeadphonesLMONOHPL | Headphones L: MONO_HPL
Public property | HeadphonesRAUXHPR | Headphones R: AUX_HPR
Public property | HeadphonesRDACLHPR | Headphones R: DACL_HPR
Public property | HeadphonesRDACRHPR | Headphones R: DACR_HPR
Public property | HeadphonesRMONOHPR | Headphones R: MONO_HPR
Public property | HPFModeHPFMODE | HPF Mode: HPF_MODE
Public property | HPSenseHPSENSE | HP Sense: HP SENSE
Public property | HPSenseHPSENSEAUX | HP Sense: HPSENSE_AUX
Public property | HPSenseHPSENSEAUXD | HP Sense: HPSENSE_AUX_D
Public property | HPSenseHPSENSED | HP Sense: HPSENSE_D
Public property | InputLevel1PORT1RXLLVL | Input Level1: PORT1_RX_L_LVL (unit: dB)
Public property | InputLevel1PORT1RXRLVL | Input Level1: PORT1_RX_R_LVL (unit: dB)
Public property | InputLevel1PORT2RXLLVL | Input Level1: PORT2_RX_L_LVL (unit: dB)
Public property | InputLevel1PORT2RXRLVL | Input Level1: PORT2_RX_R_LVL (unit: dB)
Public property | InputLevel2ADCLLVL | Input Level2: ADC_L_LVL (unit: dB)
Public property | InputLevel2ADCRLVL | Input Level2: ADC_R_LVL (unit: dB)
Public property | InputLevel2INTERPLLVL | Input Level2: INTERP_L_LVL (unit: dB)
Public property | InputLevel2INTERPRLVL | Input Level2: INTERP_R_LVL (unit: dB)
Public property | MICInputMICLEVEL | MIC Input: MIC_LEVEL (unit: dB)
Public property | MICInputMUTE | MIC Input: MUTE
Public property | MICInputSEDIFF | MIC Input: SE_DIFF
Public property | MonoLevelAUXLMONO | Mono Level: AUXL_MONO
Public property | MonoLevelMONOLEVEL | Mono Level: MONO_LEVEL (unit: dB)
Public property | MonoLevelSEDIFF | Mono Level: SE/DIFF
Public property | OutputOptionsAUXLINEOUT | Output Options: AUX_LINE_OUT
Public property | OutputOptionsAUXNEG6dB | Output Options: AUX_NEG_6dB (unit: dB)
Public property | OutputOptionsLRHPLEVEL | Output Options: LR_HP_LEVEL (unit: dB)
Public property | OutputOptionsLSLEVEL | Output Options: LS_LEVEL (unit: dB)
Public property | PLLCLKSelPLLCLKSEL | PLL CLK Sel: PLL_CLK_SEL
Public property | PLLMPLLM | PLL M: PLL_M
Public property | PLLNModPLLNMOD | PLL N Mod: PLL_N_MOD
Public property | PLLNPLLN | PLL N: PLL_N
Public property | PLLP2PLLP2 | PLL P2: PLL_P2
Public property | PLLPPLLP1 | PLL P: PLL_P1
Public property | PMCCLKDivPMCCLKDIV | PMC CLK Div: PMC_CLK_DIV
Public property | PMCClocksPMCCLKSEL | PMC Clocks: PMC_CLK_SEL
Public property | PMCSetupCHIPACTIVE | PMC Setup: CHIP_ACTIVE
Public property | PMCSetupCHIPENABLE | PMC Setup: CHIP_ENABLE
Public property | PMCSetupMCLKOVR | PMC Setup: MCLK_OVR
Public property | PMCSetupOSCENB | PMC Setup: OSC_ENB
Public property | PMCSetupPLLENB | PMC Setup: PLL_ENB
Public property | PMCSetupPLLP2ENB | PMC Setup: PLL_P2ENB
Public property | PMCSetupPORT1CLKOVR | PMC Setup: PORT1_CLK_OVR
Public property | PMCSetupPORT2CLKOVR | PMC Setup: PORT2_CLK_OVR
Public property | ResetSOFTRESET | Reset: SOFT_RESET
Public property | SpreadSpectrumSSDISABLE | Spread Spectrum: SS_DISABLE
Top
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALC1LIMITER Property

IRD

Lm49352ADCALC1LIMITER Property

ADC ALC1: LIMITER

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc1Limiter ADCALC1LIMITER { get; set; }
Public Property ADCALC1LIMITER As Lm49352TypeAdcAlc1Limiter
    Get
    Set
public:
property Lm49352TypeAdcAlc1Limiter ADCALC1LIMITER {
    Lm49352TypeAdcAlc1Limiter get ();
    void set (Lm49352TypeAdcAlc1Limiter value);
}
member ADCALC1LIMITER : Lm49352TypeAdcAlc1Limiter with get, set

Property Value

Type: Lm49352TypeAdcAlc1Limiter
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALC1SAMPLERATE Property

IRD

Lm49352ADCALC1SAMPLERATE Property

ADC ALC1: SAMPLE_RATE (unit: kHz)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc1SampleRate ADCALC1SAMPLERATE { get; set; }
Public Property ADCALC1SAMPLERATE As Lm49352TypeAdcAlc1SampleRate
    Get
    Set
public:
property Lm49352TypeAdcAlc1SampleRate ADCALC1SAMPLERATE {
    Lm49352TypeAdcAlc1SampleRate get ();
    void set (Lm49352TypeAdcAlc1SampleRate value);
}
member ADCALC1SAMPLERATE : Lm49352TypeAdcAlc1SampleRate with get, set

Property Value

Type: Lm49352TypeAdcAlc1SampleRate
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALC1SOURCELSEL Property

IRD

Lm49352ADCALC1SOURCELSEL Property

ADC ALC1: SOURCE_LSEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc1Lsel ADCALC1SOURCELSEL { get; set; }
Public Property ADCALC1SOURCELSEL As Lm49352TypeAdcAlc1Lsel
    Get
    Set
public:
property Lm49352TypeAdcAlc1Lsel ADCALC1SOURCELSEL {
    Lm49352TypeAdcAlc1Lsel get ();
    void set (Lm49352TypeAdcAlc1Lsel value);
}
member ADCALC1SOURCELSEL : Lm49352TypeAdcAlc1Lsel with get, set

Property Value

Type: Lm49352TypeAdcAlc1Lsel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALC1SOURCEOVR Property

IRD

Lm49352ADCALC1SOURCEOVR Property

ADC ALC1: SOURCE_OVR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc1Ovr ADCALC1SOURCEOVR { get; set; }
Public Property ADCALC1SOURCEOVR As Lm49352TypeAdcAlc1Ovr
    Get
    Set
public:
property Lm49352TypeAdcAlc1Ovr ADCALC1SOURCEOVR {
    Lm49352TypeAdcAlc1Ovr get ();
    void set (Lm49352TypeAdcAlc1Ovr value);
}
member ADCALC1SOURCEOVR : Lm49352TypeAdcAlc1Ovr with get, set

Property Value

Type: Lm49352TypeAdcAlc1Ovr
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALC1SOURCERSEL Property

IRD

Lm49352ADCALC1SOURCERSEL Property

ADC ALC1: SOURCE_RSEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc1Rsel ADCALC1SOURCERSEL { get; set; }
Public Property ADCALC1SOURCERSEL As Lm49352TypeAdcAlc1Rsel
    Get
    Set
public:
property Lm49352TypeAdcAlc1Rsel ADCALC1SOURCERSEL {
    Lm49352TypeAdcAlc1Rsel get ();
    void set (Lm49352TypeAdcAlc1Rsel value);
}
member ADCALC1SOURCERSEL : Lm49352TypeAdcAlc1Rsel with get, set

Property Value

Type: Lm49352TypeAdcAlc1Rsel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALC1STEREOLINK Property

IRD

Lm49352ADCALC1STEREOLINK Property

ADC ALC1: STEREO_LINK

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc1Stereo ADCALC1STEREOLINK { get; set; }
Public Property ADCALC1STEREOLINK As Lm49352TypeAdcAlc1Stereo
    Get
    Set
public:
property Lm49352TypeAdcAlc1Stereo ADCALC1STEREOLINK {
    Lm49352TypeAdcAlc1Stereo get ();
    void set (Lm49352TypeAdcAlc1Stereo value);
}
member ADCALC1STEREOLINK : Lm49352TypeAdcAlc1Stereo with get, set

Property Value

Type: Lm49352TypeAdcAlc1Stereo
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALC2NGENB Property

IRD

Lm49352ADCALC2NGENB Property

ADC ALC2: NG_ENB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc2NoiseGate ADCALC2NGENB { get; set; }
Public Property ADCALC2NGENB As Lm49352TypeAdcAlc2NoiseGate
    Get
    Set
public:
property Lm49352TypeAdcAlc2NoiseGate ADCALC2NGENB {
    Lm49352TypeAdcAlc2NoiseGate get ();
    void set (Lm49352TypeAdcAlc2NoiseGate value);
}
member ADCALC2NGENB : Lm49352TypeAdcAlc2NoiseGate with get, set

Property Value

Type: Lm49352TypeAdcAlc2NoiseGate
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALC2NOISEFLOOR Property

IRD

Lm49352ADCALC2NOISEFLOOR Property

ADC ALC2: NOISE_FLOOR (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ADCALC2NOISEFLOOR { get; set; }
Public Property ADCALC2NOISEFLOOR As Double
    Get
    Set
public:
property double ADCALC2NOISEFLOOR {
    double get ();
    void set (double value);
}
member ADCALC2NOISEFLOOR : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALC3TARGETLEVEL Property

IRD

Lm49352ADCALC3TARGETLEVEL Property

ADC ALC3: TARGET_LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ADCALC3TARGETLEVEL { get; set; }
Public Property ADCALC3TARGETLEVEL As Double
    Get
    Set
public:
property double ADCALC3TARGETLEVEL {
    double get ();
    void set (double value);
}
member ADCALC3TARGETLEVEL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALC4ATTACKRATE Property

IRD

Lm49352ADCALC4ATTACKRATE Property

ADC ALC4: ATTACK_RATE (unit: μs)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc4AttackRate ADCALC4ATTACKRATE { get; set; }
Public Property ADCALC4ATTACKRATE As Lm49352TypeAdcAlc4AttackRate
    Get
    Set
public:
property Lm49352TypeAdcAlc4AttackRate ADCALC4ATTACKRATE {
    Lm49352TypeAdcAlc4AttackRate get ();
    void set (Lm49352TypeAdcAlc4AttackRate value);
}
member ADCALC4ATTACKRATE : Lm49352TypeAdcAlc4AttackRate with get, set

Property Value

Type: Lm49352TypeAdcAlc4AttackRate
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALC5DECAYRATE Property

IRD

Lm49352ADCALC5DECAYRATE Property

ADC ALC5: DECAY_RATE (unit: μs)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc5DecayRate ADCALC5DECAYRATE { get; set; }
Public Property ADCALC5DECAYRATE As Lm49352TypeAdcAlc5DecayRate
    Get
    Set
public:
property Lm49352TypeAdcAlc5DecayRate ADCALC5DECAYRATE {
    Lm49352TypeAdcAlc5DecayRate get ();
    void set (Lm49352TypeAdcAlc5DecayRate value);
}
member ADCALC5DECAYRATE : Lm49352TypeAdcAlc5DecayRate with get, set

Property Value

Type: Lm49352TypeAdcAlc5DecayRate
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALC5PKDECAYRATE Property

IRD

Lm49352ADCALC5PKDECAYRATE Property

ADC ALC5: PK_DECAY_RATE (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc5PkDecayRate ADCALC5PKDECAYRATE { get; set; }
Public Property ADCALC5PKDECAYRATE As Lm49352TypeAdcAlc5PkDecayRate
    Get
    Set
public:
property Lm49352TypeAdcAlc5PkDecayRate ADCALC5PKDECAYRATE {
    Lm49352TypeAdcAlc5PkDecayRate get ();
    void set (Lm49352TypeAdcAlc5PkDecayRate value);
}
member ADCALC5PKDECAYRATE : Lm49352TypeAdcAlc5PkDecayRate with get, set

Property Value

Type: Lm49352TypeAdcAlc5PkDecayRate
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALC6HOLDTIME Property

IRD

Lm49352ADCALC6HOLDTIME Property

ADC ALC6: HOLD_TIME (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc6HoldTime ADCALC6HOLDTIME { get; set; }
Public Property ADCALC6HOLDTIME As Lm49352TypeAdcAlc6HoldTime
    Get
    Set
public:
property Lm49352TypeAdcAlc6HoldTime ADCALC6HOLDTIME {
    Lm49352TypeAdcAlc6HoldTime get ();
    void set (Lm49352TypeAdcAlc6HoldTime value);
}
member ADCALC6HOLDTIME : Lm49352TypeAdcAlc6HoldTime with get, set

Property Value

Type: Lm49352TypeAdcAlc6HoldTime
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALC7MAXLEVEL Property

IRD

Lm49352ADCALC7MAXLEVEL Property

ADC ALC7: MAX_LEVEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCALC7MAXLEVEL { get; set; }
Public Property ADCALC7MAXLEVEL As Byte
    Get
    Set
public:
property unsigned char ADCALC7MAXLEVEL {
    unsigned char get ();
    void set (unsigned char value);
}
member ADCALC7MAXLEVEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALC8MINLEVEL Property

IRD

Lm49352ADCALC8MINLEVEL Property

ADC ALC8: MIN_LEVEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCALC8MINLEVEL { get; set; }
Public Property ADCALC8MINLEVEL As Byte
    Get
    Set
public:
property unsigned char ADCALC8MINLEVEL {
    unsigned char get ();
    void set (unsigned char value);
}
member ADCALC8MINLEVEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALCMonLALCMONL Property

IRD

Lm49352ADCALCMonLALCMONL Property

ADC ALC Mon L: ALCMONL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCALCMonLALCMONL { get; set; }
Public Property ADCALCMonLALCMONL As Byte
    Get
    Set
public:
property unsigned char ADCALCMonLALCMONL {
    unsigned char get ();
    void set (unsigned char value);
}
member ADCALCMonLALCMONL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALCMonLSCLPLDISTORT Property

IRD

Lm49352ADCALCMonLSCLPLDISTORT Property

ADC ALC Mon L: SCLP_L_DISTORT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet ADCALCMonLSCLPLDISTORT { get; set; }
Public Property ADCALCMonLSCLPLDISTORT As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet ADCALCMonLSCLPLDISTORT {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member ADCALCMonLSCLPLDISTORT : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALCMonLSCLPRDISTORT Property

IRD

Lm49352ADCALCMonLSCLPRDISTORT Property

ADC ALC Mon L: SCLP_R_DISTORT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet ADCALCMonLSCLPRDISTORT { get; set; }
Public Property ADCALCMonLSCLPRDISTORT As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet ADCALCMonLSCLPRDISTORT {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member ADCALCMonLSCLPRDISTORT : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALCMonRALCMONR Property

IRD

Lm49352ADCALCMonRALCMONR Property

ADC ALC Mon R: ALCMONR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCALCMonRALCMONR { get; set; }
Public Property ADCALCMonRALCMONR As Byte
    Get
    Set
public:
property unsigned char ADCALCMonRALCMONR {
    unsigned char get ();
    void set (unsigned char value);
}
member ADCALCMonRALCMONR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALCMonRSCLPLDISTORT Property

IRD

Lm49352ADCALCMonRSCLPLDISTORT Property

ADC ALC Mon R: SCLP_L_DISTORT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet ADCALCMonRSCLPLDISTORT { get; set; }
Public Property ADCALCMonRSCLPLDISTORT As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet ADCALCMonRSCLPLDISTORT {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member ADCALCMonRSCLPLDISTORT : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCALCMonRSCLPRDISTORT Property

IRD

Lm49352ADCALCMonRSCLPRDISTORT Property

ADC ALC Mon R: SCLP_R_DISTORT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet ADCALCMonRSCLPRDISTORT { get; set; }
Public Property ADCALCMonRSCLPRDISTORT As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet ADCALCMonRSCLPRDISTORT {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member ADCALCMonRSCLPRDISTORT : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCBasicADCCLKSEL Property

IRD

Lm49352ADCBasicADCCLKSEL Property

ADC Basic: ADC_CLK_SEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcBasicClock ADCBasicADCCLKSEL { get; set; }
Public Property ADCBasicADCCLKSEL As Lm49352TypeAdcBasicClock
    Get
    Set
public:
property Lm49352TypeAdcBasicClock ADCBasicADCCLKSEL {
    Lm49352TypeAdcBasicClock get ();
    void set (Lm49352TypeAdcBasicClock value);
}
member ADCBasicADCCLKSEL : Lm49352TypeAdcBasicClock with get, set

Property Value

Type: Lm49352TypeAdcBasicClock
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCBasicADCDSPONLY Property

IRD

Lm49352ADCBasicADCDSPONLY Property

ADC Basic: ADC_DSP_ONLY

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcBasicDspOnly ADCBasicADCDSPONLY { get; set; }
Public Property ADCBasicADCDSPONLY As Lm49352TypeAdcBasicDspOnly
    Get
    Set
public:
property Lm49352TypeAdcBasicDspOnly ADCBasicADCDSPONLY {
    Lm49352TypeAdcBasicDspOnly get ();
    void set (Lm49352TypeAdcBasicDspOnly value);
}
member ADCBasicADCDSPONLY : Lm49352TypeAdcBasicDspOnly with get, set

Property Value

Type: Lm49352TypeAdcBasicDspOnly
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCBasicMONO Property

IRD

Lm49352ADCBasicMONO Property

ADC Basic: MONO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcBasicMono ADCBasicMONO { get; set; }
Public Property ADCBasicMONO As Lm49352TypeAdcBasicMono
    Get
    Set
public:
property Lm49352TypeAdcBasicMono ADCBasicMONO {
    Lm49352TypeAdcBasicMono get ();
    void set (Lm49352TypeAdcBasicMono value);
}
member ADCBasicMONO : Lm49352TypeAdcBasicMono with get, set

Property Value

Type: Lm49352TypeAdcBasicMono
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCBasicMUTEL Property

IRD

Lm49352ADCBasicMUTEL Property

ADC Basic: MUTE_L

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcBasicMuteL ADCBasicMUTEL { get; set; }
Public Property ADCBasicMUTEL As Lm49352TypeAdcBasicMuteL
    Get
    Set
public:
property Lm49352TypeAdcBasicMuteL ADCBasicMUTEL {
    Lm49352TypeAdcBasicMuteL get ();
    void set (Lm49352TypeAdcBasicMuteL value);
}
member ADCBasicMUTEL : Lm49352TypeAdcBasicMuteL with get, set

Property Value

Type: Lm49352TypeAdcBasicMuteL
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCBasicMUTER Property

IRD

Lm49352ADCBasicMUTER Property

ADC Basic: MUTE_R

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet ADCBasicMUTER { get; set; }
Public Property ADCBasicMUTER As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet ADCBasicMUTER {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member ADCBasicMUTER : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCBasicOSR Property

IRD

Lm49352ADCBasicOSR Property

ADC Basic: OSR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcBasicOsr ADCBasicOSR { get; set; }
Public Property ADCBasicOSR As Lm49352TypeAdcBasicOsr
    Get
    Set
public:
property Lm49352TypeAdcBasicOsr ADCBasicOSR {
    Lm49352TypeAdcBasicOsr get ();
    void set (Lm49352TypeAdcBasicOsr value);
}
member ADCBasicOSR : Lm49352TypeAdcBasicOsr with get, set

Property Value

Type: Lm49352TypeAdcBasicOsr
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCClockADCCLKDIV Property

IRD

Lm49352ADCClockADCCLKDIV Property

ADC Clock: ADC_CLK_DIV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypePmcClkDiv ADCClockADCCLKDIV { get; set; }
Public Property ADCClockADCCLKDIV As Lm49352TypePmcClkDiv
    Get
    Set
public:
property Lm49352TypePmcClkDiv ADCClockADCCLKDIV {
    Lm49352TypePmcClkDiv get ();
    void set (Lm49352TypePmcClkDiv value);
}
member ADCClockADCCLKDIV : Lm49352TypePmcClkDiv with get, set

Property Value

Type: Lm49352TypePmcClkDiv
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCEQBand1FREQ Property

IRD

Lm49352ADCEQBand1FREQ Property

ADC EQ Band1: FREQ (unit: Hz)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand1Freq ADCEQBand1FREQ { get; set; }
Public Property ADCEQBand1FREQ As Lm49352TypeAdcEqBand1Freq
    Get
    Set
public:
property Lm49352TypeAdcEqBand1Freq ADCEQBand1FREQ {
    Lm49352TypeAdcEqBand1Freq get ();
    void set (Lm49352TypeAdcEqBand1Freq value);
}
member ADCEQBand1FREQ : Lm49352TypeAdcEqBand1Freq with get, set

Property Value

Type: Lm49352TypeAdcEqBand1Freq
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCEQBand1LEVEL Property

IRD

Lm49352ADCEQBand1LEVEL Property

ADC EQ Band1: LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand1EqLevel ADCEQBand1LEVEL { get; set; }
Public Property ADCEQBand1LEVEL As Lm49352TypeAdcEqBand1EqLevel
    Get
    Set
public:
property Lm49352TypeAdcEqBand1EqLevel ADCEQBand1LEVEL {
    Lm49352TypeAdcEqBand1EqLevel get ();
    void set (Lm49352TypeAdcEqBand1EqLevel value);
}
member ADCEQBand1LEVEL : Lm49352TypeAdcEqBand1EqLevel with get, set

Property Value

Type: Lm49352TypeAdcEqBand1EqLevel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCEQBand2FREQ Property

IRD

Lm49352ADCEQBand2FREQ Property

ADC EQ_Band2: FREQ (unit: Hz)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand2Freq ADCEQBand2FREQ { get; set; }
Public Property ADCEQBand2FREQ As Lm49352TypeAdcEqBand2Freq
    Get
    Set
public:
property Lm49352TypeAdcEqBand2Freq ADCEQBand2FREQ {
    Lm49352TypeAdcEqBand2Freq get ();
    void set (Lm49352TypeAdcEqBand2Freq value);
}
member ADCEQBand2FREQ : Lm49352TypeAdcEqBand2Freq with get, set

Property Value

Type: Lm49352TypeAdcEqBand2Freq
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCEQBand2LEVEL Property

IRD

Lm49352ADCEQBand2LEVEL Property

ADC EQ Band2: LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand1EqLevel ADCEQBand2LEVEL { get; set; }
Public Property ADCEQBand2LEVEL As Lm49352TypeAdcEqBand1EqLevel
    Get
    Set
public:
property Lm49352TypeAdcEqBand1EqLevel ADCEQBand2LEVEL {
    Lm49352TypeAdcEqBand1EqLevel get ();
    void set (Lm49352TypeAdcEqBand1EqLevel value);
}
member ADCEQBand2LEVEL : Lm49352TypeAdcEqBand1EqLevel with get, set

Property Value

Type: Lm49352TypeAdcEqBand1EqLevel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCEQBand2Q Property

IRD

Lm49352ADCEQBand2Q Property

ADC EQ Band2: Q (unit: Octave)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand2Q ADCEQBand2Q { get; set; }
Public Property ADCEQBand2Q As Lm49352TypeAdcEqBand2Q
    Get
    Set
public:
property Lm49352TypeAdcEqBand2Q ADCEQBand2Q {
    Lm49352TypeAdcEqBand2Q get ();
    void set (Lm49352TypeAdcEqBand2Q value);
}
member ADCEQBand2Q : Lm49352TypeAdcEqBand2Q with get, set

Property Value

Type: Lm49352TypeAdcEqBand2Q
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCEQBand3FREQ Property

IRD

Lm49352ADCEQBand3FREQ Property

ADC EQ Band3: FREQ (unit: Hz)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand3Freq ADCEQBand3FREQ { get; set; }
Public Property ADCEQBand3FREQ As Lm49352TypeAdcEqBand3Freq
    Get
    Set
public:
property Lm49352TypeAdcEqBand3Freq ADCEQBand3FREQ {
    Lm49352TypeAdcEqBand3Freq get ();
    void set (Lm49352TypeAdcEqBand3Freq value);
}
member ADCEQBand3FREQ : Lm49352TypeAdcEqBand3Freq with get, set

Property Value

Type: Lm49352TypeAdcEqBand3Freq
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCEQBand3LEVEL Property

IRD

Lm49352ADCEQBand3LEVEL Property

ADC EQ Band3: LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand1EqLevel ADCEQBand3LEVEL { get; set; }
Public Property ADCEQBand3LEVEL As Lm49352TypeAdcEqBand1EqLevel
    Get
    Set
public:
property Lm49352TypeAdcEqBand1EqLevel ADCEQBand3LEVEL {
    Lm49352TypeAdcEqBand1EqLevel get ();
    void set (Lm49352TypeAdcEqBand1EqLevel value);
}
member ADCEQBand3LEVEL : Lm49352TypeAdcEqBand1EqLevel with get, set

Property Value

Type: Lm49352TypeAdcEqBand1EqLevel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCEQBand3Q Property

IRD

Lm49352ADCEQBand3Q Property

ADC EQ Band3: Q (unit: Octave)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand2Q ADCEQBand3Q { get; set; }
Public Property ADCEQBand3Q As Lm49352TypeAdcEqBand2Q
    Get
    Set
public:
property Lm49352TypeAdcEqBand2Q ADCEQBand3Q {
    Lm49352TypeAdcEqBand2Q get ();
    void set (Lm49352TypeAdcEqBand2Q value);
}
member ADCEQBand3Q : Lm49352TypeAdcEqBand2Q with get, set

Property Value

Type: Lm49352TypeAdcEqBand2Q
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCEQBand4FREQ Property

IRD

Lm49352ADCEQBand4FREQ Property

ADC EQ Band4: FREQ (unit: kHz)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand4Freq ADCEQBand4FREQ { get; set; }
Public Property ADCEQBand4FREQ As Lm49352TypeAdcEqBand4Freq
    Get
    Set
public:
property Lm49352TypeAdcEqBand4Freq ADCEQBand4FREQ {
    Lm49352TypeAdcEqBand4Freq get ();
    void set (Lm49352TypeAdcEqBand4Freq value);
}
member ADCEQBand4FREQ : Lm49352TypeAdcEqBand4Freq with get, set

Property Value

Type: Lm49352TypeAdcEqBand4Freq
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCEQBand4LEVEL Property

IRD

Lm49352ADCEQBand4LEVEL Property

ADC EQ Band4: LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand1EqLevel ADCEQBand4LEVEL { get; set; }
Public Property ADCEQBand4LEVEL As Lm49352TypeAdcEqBand1EqLevel
    Get
    Set
public:
property Lm49352TypeAdcEqBand1EqLevel ADCEQBand4LEVEL {
    Lm49352TypeAdcEqBand1EqLevel get ();
    void set (Lm49352TypeAdcEqBand1EqLevel value);
}
member ADCEQBand4LEVEL : Lm49352TypeAdcEqBand1EqLevel with get, set

Property Value

Type: Lm49352TypeAdcEqBand1EqLevel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCEQBand4Q Property

IRD

Lm49352ADCEQBand4Q Property

ADC EQ Band4: Q (unit: Octave)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand2Q ADCEQBand4Q { get; set; }
Public Property ADCEQBand4Q As Lm49352TypeAdcEqBand2Q
    Get
    Set
public:
property Lm49352TypeAdcEqBand2Q ADCEQBand4Q {
    Lm49352TypeAdcEqBand2Q get ();
    void set (Lm49352TypeAdcEqBand2Q value);
}
member ADCEQBand4Q : Lm49352TypeAdcEqBand2Q with get, set

Property Value

Type: Lm49352TypeAdcEqBand2Q
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCEQBand5FREQ Property

IRD

Lm49352ADCEQBand5FREQ Property

ADC EQ Band5: FREQ (unit: kHz)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand5Freq ADCEQBand5FREQ { get; set; }
Public Property ADCEQBand5FREQ As Lm49352TypeAdcEqBand5Freq
    Get
    Set
public:
property Lm49352TypeAdcEqBand5Freq ADCEQBand5FREQ {
    Lm49352TypeAdcEqBand5Freq get ();
    void set (Lm49352TypeAdcEqBand5Freq value);
}
member ADCEQBand5FREQ : Lm49352TypeAdcEqBand5Freq with get, set

Property Value

Type: Lm49352TypeAdcEqBand5Freq
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCEQBand5LEVEL Property

IRD

Lm49352ADCEQBand5LEVEL Property

ADC EQ Band5: LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand1EqLevel ADCEQBand5LEVEL { get; set; }
Public Property ADCEQBand5LEVEL As Lm49352TypeAdcEqBand1EqLevel
    Get
    Set
public:
property Lm49352TypeAdcEqBand1EqLevel ADCEQBand5LEVEL {
    Lm49352TypeAdcEqBand1EqLevel get ();
    void set (Lm49352TypeAdcEqBand1EqLevel value);
}
member ADCEQBand5LEVEL : Lm49352TypeAdcEqBand1EqLevel with get, set

Property Value

Type: Lm49352TypeAdcEqBand1EqLevel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCFXADCALCENB Property

IRD

Lm49352ADCFXADCALCENB Property

ADC FX: ADC_ALC_ENB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcFxAlc ADCFXADCALCENB { get; set; }
Public Property ADCFXADCALCENB As Lm49352TypeAdcFxAlc
    Get
    Set
public:
property Lm49352TypeAdcFxAlc ADCFXADCALCENB {
    Lm49352TypeAdcFxAlc get ();
    void set (Lm49352TypeAdcFxAlc value);
}
member ADCFXADCALCENB : Lm49352TypeAdcFxAlc with get, set

Property Value

Type: Lm49352TypeAdcFxAlc
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCFXADCEQENB Property

IRD

Lm49352ADCFXADCEQENB Property

ADC FX: ADC_EQ_ENB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcFxEq ADCFXADCEQENB { get; set; }
Public Property ADCFXADCEQENB As Lm49352TypeAdcFxEq
    Get
    Set
public:
property Lm49352TypeAdcFxEq ADCFXADCEQENB {
    Lm49352TypeAdcFxEq get ();
    void set (Lm49352TypeAdcFxEq value);
}
member ADCFXADCEQENB : Lm49352TypeAdcFxEq with get, set

Property Value

Type: Lm49352TypeAdcFxEq
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCFXADCHPFENB Property

IRD

Lm49352ADCFXADCHPFENB Property

ADC FX: ADC_HPF_ENB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcFxHpf ADCFXADCHPFENB { get; set; }
Public Property ADCFXADCHPFENB As Lm49352TypeAdcFxHpf
    Get
    Set
public:
property Lm49352TypeAdcFxHpf ADCFXADCHPFENB {
    Lm49352TypeAdcFxHpf get ();
    void set (Lm49352TypeAdcFxHpf value);
}
member ADCFXADCHPFENB : Lm49352TypeAdcFxHpf with get, set

Property Value

Type: Lm49352TypeAdcFxHpf
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCFXADCPKENB Property

IRD

Lm49352ADCFXADCPKENB Property

ADC FX: ADC_PK_ENB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcFxPk ADCFXADCPKENB { get; set; }
Public Property ADCFXADCPKENB As Lm49352TypeAdcFxPk
    Get
    Set
public:
property Lm49352TypeAdcFxPk ADCFXADCPKENB {
    Lm49352TypeAdcFxPk get ();
    void set (Lm49352TypeAdcFxPk value);
}
member ADCFXADCPKENB : Lm49352TypeAdcFxPk with get, set

Property Value

Type: Lm49352TypeAdcFxPk
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCFXADCSCLPENB Property

IRD

Lm49352ADCFXADCSCLPENB Property

ADC FX: ADC_SCLP_ENB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcFxSclp ADCFXADCSCLPENB { get; set; }
Public Property ADCFXADCSCLPENB As Lm49352TypeAdcFxSclp
    Get
    Set
public:
property Lm49352TypeAdcFxSclp ADCFXADCSCLPENB {
    Lm49352TypeAdcFxSclp get ();
    void set (Lm49352TypeAdcFxSclp value);
}
member ADCFXADCSCLPENB : Lm49352TypeAdcFxSclp with get, set

Property Value

Type: Lm49352TypeAdcFxSclp
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCFXClipADCLCLIP Property

IRD

Lm49352ADCFXClipADCLCLIP Property

ADC FX Clip: ADC_L_CLIP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet ADCFXClipADCLCLIP { get; set; }
Public Property ADCFXClipADCLCLIP As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet ADCFXClipADCLCLIP {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member ADCFXClipADCLCLIP : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCFXClipADCRCLIP Property

IRD

Lm49352ADCFXClipADCRCLIP Property

ADC FX Clip: ADC_R_CLIP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet ADCFXClipADCRCLIP { get; set; }
Public Property ADCFXClipADCRCLIP As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet ADCFXClipADCRCLIP {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member ADCFXClipADCRCLIP : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCFXClipEQLCLIP Property

IRD

Lm49352ADCFXClipEQLCLIP Property

ADC FX Clip: EQ_L_CLIP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet ADCFXClipEQLCLIP { get; set; }
Public Property ADCFXClipEQLCLIP As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet ADCFXClipEQLCLIP {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member ADCFXClipEQLCLIP : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCFXClipEQRCLIP Property

IRD

Lm49352ADCFXClipEQRCLIP Property

ADC FX Clip: EQ_R_CLIP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet ADCFXClipEQRCLIP { get; set; }
Public Property ADCFXClipEQRCLIP As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet ADCFXClipEQRCLIP {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member ADCFXClipEQRCLIP : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCFXClipGAINLCLIP Property

IRD

Lm49352ADCFXClipGAINLCLIP Property

ADC FX Clip: GAIN_L_CLIP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet ADCFXClipGAINLCLIP { get; set; }
Public Property ADCFXClipGAINLCLIP As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet ADCFXClipGAINLCLIP {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member ADCFXClipGAINLCLIP : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCFXClipGAINRCLIP Property

IRD

Lm49352ADCFXClipGAINRCLIP Property

ADC FX Clip: GAIN_R_CLIP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet ADCFXClipGAINRCLIP { get; set; }
Public Property ADCFXClipGAINRCLIP As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet ADCFXClipGAINRCLIP {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member ADCFXClipGAINRCLIP : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCFXClipSCLPLCLIP Property

IRD

Lm49352ADCFXClipSCLPLCLIP Property

ADC FX Clip: SCLP_L_CLIP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet ADCFXClipSCLPLCLIP { get; set; }
Public Property ADCFXClipSCLPLCLIP As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet ADCFXClipSCLPLCLIP {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member ADCFXClipSCLPLCLIP : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCFXClipSCLPRCLIP Property

IRD

Lm49352ADCFXClipSCLPRCLIP Property

ADC FX Clip: SCLP_R_CLIP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet ADCFXClipSCLPRCLIP { get; set; }
Public Property ADCFXClipSCLPRCLIP As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet ADCFXClipSCLPRCLIP {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member ADCFXClipSCLPRCLIP : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCInputAUXADCR Property

IRD

Lm49352ADCInputAUXADCR Property

ADC Input: AUX_ADCR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcInputAux ADCInputAUXADCR { get; set; }
Public Property ADCInputAUXADCR As Lm49352TypeAdcInputAux
    Get
    Set
public:
property Lm49352TypeAdcInputAux ADCInputAUXADCR {
    Lm49352TypeAdcInputAux get ();
    void set (Lm49352TypeAdcInputAux value);
}
member ADCInputAUXADCR : Lm49352TypeAdcInputAux with get, set

Property Value

Type: Lm49352TypeAdcInputAux
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCInputDACLADCL Property

IRD

Lm49352ADCInputDACLADCL Property

ADC Input: DACL_ADCL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcInputDacl ADCInputDACLADCL { get; set; }
Public Property ADCInputDACLADCL As Lm49352TypeAdcInputDacl
    Get
    Set
public:
property Lm49352TypeAdcInputDacl ADCInputDACLADCL {
    Lm49352TypeAdcInputDacl get ();
    void set (Lm49352TypeAdcInputDacl value);
}
member ADCInputDACLADCL : Lm49352TypeAdcInputDacl with get, set

Property Value

Type: Lm49352TypeAdcInputDacl
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCInputDACRADCR Property

IRD

Lm49352ADCInputDACRADCR Property

ADC Input: DACR_ADCR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcInputDacr ADCInputDACRADCR { get; set; }
Public Property ADCInputDACRADCR As Lm49352TypeAdcInputDacr
    Get
    Set
public:
property Lm49352TypeAdcInputDacr ADCInputDACRADCR {
    Lm49352TypeAdcInputDacr get ();
    void set (Lm49352TypeAdcInputDacr value);
}
member ADCInputDACRADCR : Lm49352TypeAdcInputDacr with get, set

Property Value

Type: Lm49352TypeAdcInputDacr
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCInputMICADCL Property

IRD

Lm49352ADCInputMICADCL Property

ADC Input: MIC_ADCL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcInputMicl ADCInputMICADCL { get; set; }
Public Property ADCInputMICADCL As Lm49352TypeAdcInputMicl
    Get
    Set
public:
property Lm49352TypeAdcInputMicl ADCInputMICADCL {
    Lm49352TypeAdcInputMicl get ();
    void set (Lm49352TypeAdcInputMicl value);
}
member ADCInputMICADCL : Lm49352TypeAdcInputMicl with get, set

Property Value

Type: Lm49352TypeAdcInputMicl
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCInputMICADCR Property

IRD

Lm49352ADCInputMICADCR Property

ADC Input: MIC_ADCR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcInputMicr ADCInputMICADCR { get; set; }
Public Property ADCInputMICADCR As Lm49352TypeAdcInputMicr
    Get
    Set
public:
property Lm49352TypeAdcInputMicr ADCInputMICADCR {
    Lm49352TypeAdcInputMicr get ();
    void set (Lm49352TypeAdcInputMicr value);
}
member ADCInputMICADCR : Lm49352TypeAdcInputMicr with get, set

Property Value

Type: Lm49352TypeAdcInputMicr
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCInputMONOADCL Property

IRD

Lm49352ADCInputMONOADCL Property

ADC Input: MONO_ADCL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcInputMono ADCInputMONOADCL { get; set; }
Public Property ADCInputMONOADCL As Lm49352TypeAdcInputMono
    Get
    Set
public:
property Lm49352TypeAdcInputMono ADCInputMONOADCL {
    Lm49352TypeAdcInputMono get ();
    void set (Lm49352TypeAdcInputMono value);
}
member ADCInputMONOADCL : Lm49352TypeAdcInputMono with get, set

Property Value

Type: Lm49352TypeAdcInputMono
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCLLevelADCLLEVEL Property

IRD

Lm49352ADCLLevelADCLLEVEL Property

ADC L Level: ADC_L_LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ADCLLevelADCLLEVEL { get; set; }
Public Property ADCLLevelADCLLEVEL As Double
    Get
    Set
public:
property double ADCLLevelADCLLEVEL {
    double get ();
    void set (double value);
}
member ADCLLevelADCLLEVEL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCLLevelSTEREOLINK Property

IRD

Lm49352ADCLLevelSTEREOLINK Property

ADC L Level: STEREO_LINK

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcLLevelStereo ADCLLevelSTEREOLINK { get; set; }
Public Property ADCLLevelSTEREOLINK As Lm49352TypeAdcLLevelStereo
    Get
    Set
public:
property Lm49352TypeAdcLLevelStereo ADCLLevelSTEREOLINK {
    Lm49352TypeAdcLLevelStereo get ();
    void set (Lm49352TypeAdcLLevelStereo value);
}
member ADCLLevelSTEREOLINK : Lm49352TypeAdcLLevelStereo with get, set

Property Value

Type: Lm49352TypeAdcLLevelStereo
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCLVLMonLLVLMONL Property

IRD

Lm49352ADCLVLMonLLVLMONL Property

ADC LVL Mon L: LVLMONL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCLVLMonLLVLMONL { get; set; }
Public Property ADCLVLMonLLVLMONL As Byte
    Get
    Set
public:
property unsigned char ADCLVLMonLLVLMONL {
    unsigned char get ();
    void set (unsigned char value);
}
member ADCLVLMonLLVLMONL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCLVLMonRLVLMONR Property

IRD

Lm49352ADCLVLMonRLVLMONR Property

ADC LVL Mon R: LVLMONR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte ADCLVLMonRLVLMONR { get; set; }
Public Property ADCLVLMonRLVLMONR As Byte
    Get
    Set
public:
property unsigned char ADCLVLMonRLVLMONR {
    unsigned char get ();
    void set (unsigned char value);
}
member ADCLVLMonRLVLMONR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCMixerADCMIXLEVELL Property

IRD

Lm49352ADCMixerADCMIXLEVELL Property

ADC Mixer: ADC_MIX_LEVEL_L (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcMixerLevel ADCMixerADCMIXLEVELL { get; set; }
Public Property ADCMixerADCMIXLEVELL As Lm49352TypeAdcMixerLevel
    Get
    Set
public:
property Lm49352TypeAdcMixerLevel ADCMixerADCMIXLEVELL {
    Lm49352TypeAdcMixerLevel get ();
    void set (Lm49352TypeAdcMixerLevel value);
}
member ADCMixerADCMIXLEVELL : Lm49352TypeAdcMixerLevel with get, set

Property Value

Type: Lm49352TypeAdcMixerLevel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCMixerADCMIXLEVELR Property

IRD

Lm49352ADCMixerADCMIXLEVELR Property

ADC Mixer: ADC_MIX_LEVEL_R (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcMixerLevel ADCMixerADCMIXLEVELR { get; set; }
Public Property ADCMixerADCMIXLEVELR As Lm49352TypeAdcMixerLevel
    Get
    Set
public:
property Lm49352TypeAdcMixerLevel ADCMixerADCMIXLEVELR {
    Lm49352TypeAdcMixerLevel get ();
    void set (Lm49352TypeAdcMixerLevel value);
}
member ADCMixerADCMIXLEVELR : Lm49352TypeAdcMixerLevel with get, set

Property Value

Type: Lm49352TypeAdcMixerLevel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCMixerSTEREOLINK Property

IRD

Lm49352ADCMixerSTEREOLINK Property

ADC Mixer: STEREO_LINK

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcMixerStereo ADCMixerSTEREOLINK { get; set; }
Public Property ADCMixerSTEREOLINK As Lm49352TypeAdcMixerStereo
    Get
    Set
public:
property Lm49352TypeAdcMixerStereo ADCMixerSTEREOLINK {
    Lm49352TypeAdcMixerStereo get ();
    void set (Lm49352TypeAdcMixerStereo value);
}
member ADCMixerSTEREOLINK : Lm49352TypeAdcMixerStereo with get, set

Property Value

Type: Lm49352TypeAdcMixerStereo
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCRLevelADCRLEVEL Property

IRD

Lm49352ADCRLevelADCRLEVEL Property

ADC R Level: ADC_R_LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ADCRLevelADCRLEVEL { get; set; }
Public Property ADCRLevelADCRLEVEL As Double
    Get
    Set
public:
property double ADCRLevelADCRLEVEL {
    double get ();
    void set (double value);
}
member ADCRLevelADCRLEVEL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCSoftclip1SOFTKNEE Property

IRD

Lm49352ADCSoftclip1SOFTKNEE Property

ADC Softclip1: SOFT_KNEE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcSoftclip1Knee ADCSoftclip1SOFTKNEE { get; set; }
Public Property ADCSoftclip1SOFTKNEE As Lm49352TypeAdcSoftclip1Knee
    Get
    Set
public:
property Lm49352TypeAdcSoftclip1Knee ADCSoftclip1SOFTKNEE {
    Lm49352TypeAdcSoftclip1Knee get ();
    void set (Lm49352TypeAdcSoftclip1Knee value);
}
member ADCSoftclip1SOFTKNEE : Lm49352TypeAdcSoftclip1Knee with get, set

Property Value

Type: Lm49352TypeAdcSoftclip1Knee
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCSoftclip1THRESHOLD Property

IRD

Lm49352ADCSoftclip1THRESHOLD Property

ADC Softclip1: THRESHOLD (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcSoftclip1Threshold ADCSoftclip1THRESHOLD { get; set; }
Public Property ADCSoftclip1THRESHOLD As Lm49352TypeAdcSoftclip1Threshold
    Get
    Set
public:
property Lm49352TypeAdcSoftclip1Threshold ADCSoftclip1THRESHOLD {
    Lm49352TypeAdcSoftclip1Threshold get ();
    void set (Lm49352TypeAdcSoftclip1Threshold value);
}
member ADCSoftclip1THRESHOLD : Lm49352TypeAdcSoftclip1Threshold with get, set

Property Value

Type: Lm49352TypeAdcSoftclip1Threshold
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCSoftclip2RATIO Property

IRD

Lm49352ADCSoftclip2RATIO Property

ADC Softclip2: RATIO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcSoftclip2ClipRatio ADCSoftclip2RATIO { get; set; }
Public Property ADCSoftclip2RATIO As Lm49352TypeAdcSoftclip2ClipRatio
    Get
    Set
public:
property Lm49352TypeAdcSoftclip2ClipRatio ADCSoftclip2RATIO {
    Lm49352TypeAdcSoftclip2ClipRatio get ();
    void set (Lm49352TypeAdcSoftclip2ClipRatio value);
}
member ADCSoftclip2RATIO : Lm49352TypeAdcSoftclip2ClipRatio with get, set

Property Value

Type: Lm49352TypeAdcSoftclip2ClipRatio
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ADCSoftclip3LEVEL Property

IRD

Lm49352ADCSoftclip3LEVEL Property

ADC Softclip3: LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double ADCSoftclip3LEVEL { get; set; }
Public Property ADCSoftclip3LEVEL As Double
    Get
    Set
public:
property double ADCSoftclip3LEVEL {
    double get ();
    void set (double value);
}
member ADCSoftclip3LEVEL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1BasicCLOCKPHASE Property

IRD

Lm49352AudioPort1BasicCLOCKPHASE Property

Audio Port1 Basic: CLOCK_PHASE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1BasicClockPhase AudioPort1BasicCLOCKPHASE { get; set; }
Public Property AudioPort1BasicCLOCKPHASE As Lm49352TypeAudioPort1BasicClockPhase
    Get
    Set
public:
property Lm49352TypeAudioPort1BasicClockPhase AudioPort1BasicCLOCKPHASE {
    Lm49352TypeAudioPort1BasicClockPhase get ();
    void set (Lm49352TypeAudioPort1BasicClockPhase value);
}
member AudioPort1BasicCLOCKPHASE : Lm49352TypeAudioPort1BasicClockPhase with get, set

Property Value

Type: Lm49352TypeAudioPort1BasicClockPhase
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1BasicRXENABLE Property

IRD

Lm49352AudioPort1BasicRXENABLE Property

Audio Port1 Basic: RX_ENABLE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1BasicRx AudioPort1BasicRXENABLE { get; set; }
Public Property AudioPort1BasicRXENABLE As Lm49352TypeAudioPort1BasicRx
    Get
    Set
public:
property Lm49352TypeAudioPort1BasicRx AudioPort1BasicRXENABLE {
    Lm49352TypeAudioPort1BasicRx get ();
    void set (Lm49352TypeAudioPort1BasicRx value);
}
member AudioPort1BasicRXENABLE : Lm49352TypeAudioPort1BasicRx with get, set

Property Value

Type: Lm49352TypeAudioPort1BasicRx
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1BasicSTEREO Property

IRD

Lm49352AudioPort1BasicSTEREO Property

Audio Port1 Basic: STEREO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1BasicStereo AudioPort1BasicSTEREO { get; set; }
Public Property AudioPort1BasicSTEREO As Lm49352TypeAudioPort1BasicStereo
    Get
    Set
public:
property Lm49352TypeAudioPort1BasicStereo AudioPort1BasicSTEREO {
    Lm49352TypeAudioPort1BasicStereo get ();
    void set (Lm49352TypeAudioPort1BasicStereo value);
}
member AudioPort1BasicSTEREO : Lm49352TypeAudioPort1BasicStereo with get, set

Property Value

Type: Lm49352TypeAudioPort1BasicStereo
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1BasicSTEREOSYNCPHASE Property

IRD

Lm49352AudioPort1BasicSTEREOSYNCPHASE Property

Audio Port1 Basic: STEREO_SYNC_PHASE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1BasicSyncPhase AudioPort1BasicSTEREOSYNCPHASE { get; set; }
Public Property AudioPort1BasicSTEREOSYNCPHASE As Lm49352TypeAudioPort1BasicSyncPhase
    Get
    Set
public:
property Lm49352TypeAudioPort1BasicSyncPhase AudioPort1BasicSTEREOSYNCPHASE {
    Lm49352TypeAudioPort1BasicSyncPhase get ();
    void set (Lm49352TypeAudioPort1BasicSyncPhase value);
}
member AudioPort1BasicSTEREOSYNCPHASE : Lm49352TypeAudioPort1BasicSyncPhase with get, set

Property Value

Type: Lm49352TypeAudioPort1BasicSyncPhase
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1BasicSYNCINVERT Property

IRD

Lm49352AudioPort1BasicSYNCINVERT Property

Audio Port1 Basic: SYNC_INVERT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1BasicInvert AudioPort1BasicSYNCINVERT { get; set; }
Public Property AudioPort1BasicSYNCINVERT As Lm49352TypeAudioPort1BasicInvert
    Get
    Set
public:
property Lm49352TypeAudioPort1BasicInvert AudioPort1BasicSYNCINVERT {
    Lm49352TypeAudioPort1BasicInvert get ();
    void set (Lm49352TypeAudioPort1BasicInvert value);
}
member AudioPort1BasicSYNCINVERT : Lm49352TypeAudioPort1BasicInvert with get, set

Property Value

Type: Lm49352TypeAudioPort1BasicInvert
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1BasicSYNCMS Property

IRD

Lm49352AudioPort1BasicSYNCMS Property

Audio Port1 Basic: SYNC_MS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1BasicSync AudioPort1BasicSYNCMS { get; set; }
Public Property AudioPort1BasicSYNCMS As Lm49352TypeAudioPort1BasicSync
    Get
    Set
public:
property Lm49352TypeAudioPort1BasicSync AudioPort1BasicSYNCMS {
    Lm49352TypeAudioPort1BasicSync get ();
    void set (Lm49352TypeAudioPort1BasicSync value);
}
member AudioPort1BasicSYNCMS : Lm49352TypeAudioPort1BasicSync with get, set

Property Value

Type: Lm49352TypeAudioPort1BasicSync
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1BasicTXENABLE Property

IRD

Lm49352AudioPort1BasicTXENABLE Property

Audio Port1 Basic: TX_ENABLE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1BasicTx AudioPort1BasicTXENABLE { get; set; }
Public Property AudioPort1BasicTXENABLE As Lm49352TypeAudioPort1BasicTx
    Get
    Set
public:
property Lm49352TypeAudioPort1BasicTx AudioPort1BasicTXENABLE {
    Lm49352TypeAudioPort1BasicTx get ();
    void set (Lm49352TypeAudioPort1BasicTx value);
}
member AudioPort1BasicTXENABLE : Lm49352TypeAudioPort1BasicTx with get, set

Property Value

Type: Lm49352TypeAudioPort1BasicTx
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1BasisCLKMS Property

IRD

Lm49352AudioPort1BasisCLKMS Property

Audio Port1 Basis: CLK_MS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1BasicClock AudioPort1BasisCLKMS { get; set; }
Public Property AudioPort1BasisCLKMS As Lm49352TypeAudioPort1BasicClock
    Get
    Set
public:
property Lm49352TypeAudioPort1BasicClock AudioPort1BasisCLKMS {
    Lm49352TypeAudioPort1BasicClock get ();
    void set (Lm49352TypeAudioPort1BasicClock value);
}
member AudioPort1BasisCLKMS : Lm49352TypeAudioPort1BasicClock with get, set

Property Value

Type: Lm49352TypeAudioPort1BasicClock
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1CLKGen1CLOCKSEL Property

IRD

Lm49352AudioPort1CLKGen1CLOCKSEL Property

Audio Port1 CLK Gen1: CLOCK_SEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1ClkGen1Sel AudioPort1CLKGen1CLOCKSEL { get; set; }
Public Property AudioPort1CLKGen1CLOCKSEL As Lm49352TypeAudioPort1ClkGen1Sel
    Get
    Set
public:
property Lm49352TypeAudioPort1ClkGen1Sel AudioPort1CLKGen1CLOCKSEL {
    Lm49352TypeAudioPort1ClkGen1Sel get ();
    void set (Lm49352TypeAudioPort1ClkGen1Sel value);
}
member AudioPort1CLKGen1CLOCKSEL : Lm49352TypeAudioPort1ClkGen1Sel with get, set

Property Value

Type: Lm49352TypeAudioPort1ClkGen1Sel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1CLKGen1HALFCYCLECLKDIV Property

IRD

Lm49352AudioPort1CLKGen1HALFCYCLECLKDIV Property

Audio Port1 CLK Gen1: HALF_CYCLE_CLK_DIV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1ClkGen1Divider AudioPort1CLKGen1HALFCYCLECLKDIV { get; set; }
Public Property AudioPort1CLKGen1HALFCYCLECLKDIV As Lm49352TypeAudioPort1ClkGen1Divider
    Get
    Set
public:
property Lm49352TypeAudioPort1ClkGen1Divider AudioPort1CLKGen1HALFCYCLECLKDIV {
    Lm49352TypeAudioPort1ClkGen1Divider get ();
    void set (Lm49352TypeAudioPort1ClkGen1Divider value);
}
member AudioPort1CLKGen1HALFCYCLECLKDIV : Lm49352TypeAudioPort1ClkGen1Divider with get, set

Property Value

Type: Lm49352TypeAudioPort1ClkGen1Divider
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1CLKGen2SYNTHDENOM Property

IRD

Lm49352AudioPort1CLKGen2SYNTHDENOM Property

Audio Port1 CLK Gen2: SYNTH_DENOM

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1ClkGen2SynthDenom AudioPort1CLKGen2SYNTHDENOM { get; set; }
Public Property AudioPort1CLKGen2SYNTHDENOM As Lm49352TypeAudioPort1ClkGen2SynthDenom
    Get
    Set
public:
property Lm49352TypeAudioPort1ClkGen2SynthDenom AudioPort1CLKGen2SYNTHDENOM {
    Lm49352TypeAudioPort1ClkGen2SynthDenom get ();
    void set (Lm49352TypeAudioPort1ClkGen2SynthDenom value);
}
member AudioPort1CLKGen2SYNTHDENOM : Lm49352TypeAudioPort1ClkGen2SynthDenom with get, set

Property Value

Type: Lm49352TypeAudioPort1ClkGen2SynthDenom
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1CLKGen2SYNTHNUM Property

IRD

Lm49352AudioPort1CLKGen2SYNTHNUM Property

Audio Port1 CLK Gen2: SYNTH_NUM

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1ClkGen2SynthNum AudioPort1CLKGen2SYNTHNUM { get; set; }
Public Property AudioPort1CLKGen2SYNTHNUM As Lm49352TypeAudioPort1ClkGen2SynthNum
    Get
    Set
public:
property Lm49352TypeAudioPort1ClkGen2SynthNum AudioPort1CLKGen2SYNTHNUM {
    Lm49352TypeAudioPort1ClkGen2SynthNum get ();
    void set (Lm49352TypeAudioPort1ClkGen2SynthNum value);
}
member AudioPort1CLKGen2SYNTHNUM : Lm49352TypeAudioPort1ClkGen2SynthNum with get, set

Property Value

Type: Lm49352TypeAudioPort1ClkGen2SynthNum
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1LSEL Property

IRD

Lm49352AudioPort1LSEL Property

Audio Port1: L_SEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1LSel AudioPort1LSEL { get; set; }
Public Property AudioPort1LSEL As Lm49352TypeAudioPort1LSel
    Get
    Set
public:
property Lm49352TypeAudioPort1LSel AudioPort1LSEL {
    Lm49352TypeAudioPort1LSel get ();
    void set (Lm49352TypeAudioPort1LSel value);
}
member AudioPort1LSEL : Lm49352TypeAudioPort1LSel with get, set

Property Value

Type: Lm49352TypeAudioPort1LSel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1MONO Property

IRD

Lm49352AudioPort1MONO Property

Audio Port1: MONO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1Mono AudioPort1MONO { get; set; }
Public Property AudioPort1MONO As Lm49352TypeAudioPort1Mono
    Get
    Set
public:
property Lm49352TypeAudioPort1Mono AudioPort1MONO {
    Lm49352TypeAudioPort1Mono get ();
    void set (Lm49352TypeAudioPort1Mono value);
}
member AudioPort1MONO : Lm49352TypeAudioPort1Mono with get, set

Property Value

Type: Lm49352TypeAudioPort1Mono
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1RSEL Property

IRD

Lm49352AudioPort1RSEL Property

Audio Port1: R_SEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1RSel AudioPort1RSEL { get; set; }
Public Property AudioPort1RSEL As Lm49352TypeAudioPort1RSel
    Get
    Set
public:
property Lm49352TypeAudioPort1RSel AudioPort1RSEL {
    Lm49352TypeAudioPort1RSel get ();
    void set (Lm49352TypeAudioPort1RSel value);
}
member AudioPort1RSEL : Lm49352TypeAudioPort1RSel with get, set

Property Value

Type: Lm49352TypeAudioPort1RSel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1RXCOMPAND Property

IRD

Lm49352AudioPort1RXCOMPAND Property

Audio Port1 RX: COMPAND

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1RxCompand AudioPort1RXCOMPAND { get; set; }
Public Property AudioPort1RXCOMPAND As Lm49352TypeAudioPort1RxCompand
    Get
    Set
public:
property Lm49352TypeAudioPort1RxCompand AudioPort1RXCOMPAND {
    Lm49352TypeAudioPort1RxCompand get ();
    void set (Lm49352TypeAudioPort1RxCompand value);
}
member AudioPort1RXCOMPAND : Lm49352TypeAudioPort1RxCompand with get, set

Property Value

Type: Lm49352TypeAudioPort1RxCompand
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1RXMSBPOSITION Property

IRD

Lm49352AudioPort1RXMSBPOSITION Property

Audio Port1 RX: MSB_POSITION

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AudioPort1RXMSBPOSITION { get; set; }
Public Property AudioPort1RXMSBPOSITION As Byte
    Get
    Set
public:
property unsigned char AudioPort1RXMSBPOSITION {
    unsigned char get ();
    void set (unsigned char value);
}
member AudioPort1RXMSBPOSITION : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1RXRXMODE Property

IRD

Lm49352AudioPort1RXRXMODE Property

Audio Port1 RX: RX_MODE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1RxMode AudioPort1RXRXMODE { get; set; }
Public Property AudioPort1RXRXMODE As Lm49352TypeAudioPort1RxMode
    Get
    Set
public:
property Lm49352TypeAudioPort1RxMode AudioPort1RXRXMODE {
    Lm49352TypeAudioPort1RxMode get ();
    void set (Lm49352TypeAudioPort1RxMode value);
}
member AudioPort1RXRXMODE : Lm49352TypeAudioPort1RxMode with get, set

Property Value

Type: Lm49352TypeAudioPort1RxMode
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1RXΜLawALaw Property

IRD

Lm49352AudioPort1RXΜLawALaw Property

Audio Port1 RX: μLaw/A-Law

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1RxLaw AudioPort1RXΜLawALaw { get; set; }
Public Property AudioPort1RXΜLawALaw As Lm49352TypeAudioPort1RxLaw
    Get
    Set
public:
property Lm49352TypeAudioPort1RxLaw AudioPort1RXΜLawALaw {
    Lm49352TypeAudioPort1RxLaw get ();
    void set (Lm49352TypeAudioPort1RxLaw value);
}
member AudioPort1RXΜLawALaw : Lm49352TypeAudioPort1RxLaw with get, set

Property Value

Type: Lm49352TypeAudioPort1RxLaw
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1SWAP Property

IRD

Lm49352AudioPort1SWAP Property

Audio Port1: SWAP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1Swap AudioPort1SWAP { get; set; }
Public Property AudioPort1SWAP As Lm49352TypeAudioPort1Swap
    Get
    Set
public:
property Lm49352TypeAudioPort1Swap AudioPort1SWAP {
    Lm49352TypeAudioPort1Swap get ();
    void set (Lm49352TypeAudioPort1Swap value);
}
member AudioPort1SWAP : Lm49352TypeAudioPort1Swap with get, set

Property Value

Type: Lm49352TypeAudioPort1Swap
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1SyncSYNCRATE Property

IRD

Lm49352AudioPort1SyncSYNCRATE Property

Audio Port1 Sync: SYNC_RATE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1SyncRate AudioPort1SyncSYNCRATE { get; set; }
Public Property AudioPort1SyncSYNCRATE As Lm49352TypeAudioPort1SyncRate
    Get
    Set
public:
property Lm49352TypeAudioPort1SyncRate AudioPort1SyncSYNCRATE {
    Lm49352TypeAudioPort1SyncRate get ();
    void set (Lm49352TypeAudioPort1SyncRate value);
}
member AudioPort1SyncSYNCRATE : Lm49352TypeAudioPort1SyncRate with get, set

Property Value

Type: Lm49352TypeAudioPort1SyncRate
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1SyncSYNCWIDTH Property

IRD

Lm49352AudioPort1SyncSYNCWIDTH Property

Audio Port1 Sync: SYNC_WIDTH (unit: bits)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1SyncWidth AudioPort1SyncSYNCWIDTH { get; set; }
Public Property AudioPort1SyncSYNCWIDTH As Lm49352TypeAudioPort1SyncWidth
    Get
    Set
public:
property Lm49352TypeAudioPort1SyncWidth AudioPort1SyncSYNCWIDTH {
    Lm49352TypeAudioPort1SyncWidth get ();
    void set (Lm49352TypeAudioPort1SyncWidth value);
}
member AudioPort1SyncSYNCWIDTH : Lm49352TypeAudioPort1SyncWidth with get, set

Property Value

Type: Lm49352TypeAudioPort1SyncWidth
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1TXCOMPAND Property

IRD

Lm49352AudioPort1TXCOMPAND Property

Audio Port1 TX: COMPAND

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1RxCompand AudioPort1TXCOMPAND { get; set; }
Public Property AudioPort1TXCOMPAND As Lm49352TypeAudioPort1RxCompand
    Get
    Set
public:
property Lm49352TypeAudioPort1RxCompand AudioPort1TXCOMPAND {
    Lm49352TypeAudioPort1RxCompand get ();
    void set (Lm49352TypeAudioPort1RxCompand value);
}
member AudioPort1TXCOMPAND : Lm49352TypeAudioPort1RxCompand with get, set

Property Value

Type: Lm49352TypeAudioPort1RxCompand
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1TXMSBPOSITION Property

IRD

Lm49352AudioPort1TXMSBPOSITION Property

Audio Port1 TX: MSB_POSITION

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AudioPort1TXMSBPOSITION { get; set; }
Public Property AudioPort1TXMSBPOSITION As Byte
    Get
    Set
public:
property unsigned char AudioPort1TXMSBPOSITION {
    unsigned char get ();
    void set (unsigned char value);
}
member AudioPort1TXMSBPOSITION : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1TXTXMODE Property

IRD

Lm49352AudioPort1TXTXMODE Property

Audio Port1 TX: TX_MODE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1RxMode AudioPort1TXTXMODE { get; set; }
Public Property AudioPort1TXTXMODE As Lm49352TypeAudioPort1RxMode
    Get
    Set
public:
property Lm49352TypeAudioPort1RxMode AudioPort1TXTXMODE {
    Lm49352TypeAudioPort1RxMode get ();
    void set (Lm49352TypeAudioPort1RxMode value);
}
member AudioPort1TXTXMODE : Lm49352TypeAudioPort1RxMode with get, set

Property Value

Type: Lm49352TypeAudioPort1RxMode
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1TXΜLawALaw Property

IRD

Lm49352AudioPort1TXΜLawALaw Property

Audio Port1 TX: μLaw/A-Law

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1RxLaw AudioPort1TXΜLawALaw { get; set; }
Public Property AudioPort1TXΜLawALaw As Lm49352TypeAudioPort1RxLaw
    Get
    Set
public:
property Lm49352TypeAudioPort1RxLaw AudioPort1TXΜLawALaw {
    Lm49352TypeAudioPort1RxLaw get ();
    void set (Lm49352TypeAudioPort1RxLaw value);
}
member AudioPort1TXΜLawALaw : Lm49352TypeAudioPort1RxLaw with get, set

Property Value

Type: Lm49352TypeAudioPort1RxLaw
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1WidthRXWIDTH Property

IRD

Lm49352AudioPort1WidthRXWIDTH Property

Audio Port1 Width: RX_WIDTH (unit: bits)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1WidthRxTx AudioPort1WidthRXWIDTH { get; set; }
Public Property AudioPort1WidthRXWIDTH As Lm49352TypeAudioPort1WidthRxTx
    Get
    Set
public:
property Lm49352TypeAudioPort1WidthRxTx AudioPort1WidthRXWIDTH {
    Lm49352TypeAudioPort1WidthRxTx get ();
    void set (Lm49352TypeAudioPort1WidthRxTx value);
}
member AudioPort1WidthRXWIDTH : Lm49352TypeAudioPort1WidthRxTx with get, set

Property Value

Type: Lm49352TypeAudioPort1WidthRxTx
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1WidthTXEXTRABITS Property

IRD

Lm49352AudioPort1WidthTXEXTRABITS Property

Audio Port1 Width: TX_EXTRA_BITS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1WidthExtra AudioPort1WidthTXEXTRABITS { get; set; }
Public Property AudioPort1WidthTXEXTRABITS As Lm49352TypeAudioPort1WidthExtra
    Get
    Set
public:
property Lm49352TypeAudioPort1WidthExtra AudioPort1WidthTXEXTRABITS {
    Lm49352TypeAudioPort1WidthExtra get ();
    void set (Lm49352TypeAudioPort1WidthExtra value);
}
member AudioPort1WidthTXEXTRABITS : Lm49352TypeAudioPort1WidthExtra with get, set

Property Value

Type: Lm49352TypeAudioPort1WidthExtra
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort1WidthTXWIDTH Property

IRD

Lm49352AudioPort1WidthTXWIDTH Property

Audio Port1 Width: TX_WIDTH (unit: bits)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1WidthRxTx AudioPort1WidthTXWIDTH { get; set; }
Public Property AudioPort1WidthTXWIDTH As Lm49352TypeAudioPort1WidthRxTx
    Get
    Set
public:
property Lm49352TypeAudioPort1WidthRxTx AudioPort1WidthTXWIDTH {
    Lm49352TypeAudioPort1WidthRxTx get ();
    void set (Lm49352TypeAudioPort1WidthRxTx value);
}
member AudioPort1WidthTXWIDTH : Lm49352TypeAudioPort1WidthRxTx with get, set

Property Value

Type: Lm49352TypeAudioPort1WidthRxTx
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2BasicCLOCKMS Property

IRD

Lm49352AudioPort2BasicCLOCKMS Property

Audio Port2 Basic: CLOCK_MS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1BasicClock AudioPort2BasicCLOCKMS { get; set; }
Public Property AudioPort2BasicCLOCKMS As Lm49352TypeAudioPort1BasicClock
    Get
    Set
public:
property Lm49352TypeAudioPort1BasicClock AudioPort2BasicCLOCKMS {
    Lm49352TypeAudioPort1BasicClock get ();
    void set (Lm49352TypeAudioPort1BasicClock value);
}
member AudioPort2BasicCLOCKMS : Lm49352TypeAudioPort1BasicClock with get, set

Property Value

Type: Lm49352TypeAudioPort1BasicClock
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2BasicCLOCKPHASE Property

IRD

Lm49352AudioPort2BasicCLOCKPHASE Property

Audio Port2 Basic: CLOCK_PHASE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1BasicClockPhase AudioPort2BasicCLOCKPHASE { get; set; }
Public Property AudioPort2BasicCLOCKPHASE As Lm49352TypeAudioPort1BasicClockPhase
    Get
    Set
public:
property Lm49352TypeAudioPort1BasicClockPhase AudioPort2BasicCLOCKPHASE {
    Lm49352TypeAudioPort1BasicClockPhase get ();
    void set (Lm49352TypeAudioPort1BasicClockPhase value);
}
member AudioPort2BasicCLOCKPHASE : Lm49352TypeAudioPort1BasicClockPhase with get, set

Property Value

Type: Lm49352TypeAudioPort1BasicClockPhase
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2BasicRXENABLE Property

IRD

Lm49352AudioPort2BasicRXENABLE Property

Audio Port2 Basic: RX_ENABLE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1BasicRx AudioPort2BasicRXENABLE { get; set; }
Public Property AudioPort2BasicRXENABLE As Lm49352TypeAudioPort1BasicRx
    Get
    Set
public:
property Lm49352TypeAudioPort1BasicRx AudioPort2BasicRXENABLE {
    Lm49352TypeAudioPort1BasicRx get ();
    void set (Lm49352TypeAudioPort1BasicRx value);
}
member AudioPort2BasicRXENABLE : Lm49352TypeAudioPort1BasicRx with get, set

Property Value

Type: Lm49352TypeAudioPort1BasicRx
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2BasicSTEREO Property

IRD

Lm49352AudioPort2BasicSTEREO Property

Audio Port2 Basic: STEREO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1BasicStereo AudioPort2BasicSTEREO { get; set; }
Public Property AudioPort2BasicSTEREO As Lm49352TypeAudioPort1BasicStereo
    Get
    Set
public:
property Lm49352TypeAudioPort1BasicStereo AudioPort2BasicSTEREO {
    Lm49352TypeAudioPort1BasicStereo get ();
    void set (Lm49352TypeAudioPort1BasicStereo value);
}
member AudioPort2BasicSTEREO : Lm49352TypeAudioPort1BasicStereo with get, set

Property Value

Type: Lm49352TypeAudioPort1BasicStereo
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2BasicSTEREOSYNCPHASE Property

IRD

Lm49352AudioPort2BasicSTEREOSYNCPHASE Property

Audio Port2 Basic: STEREO_SYNC_PHASE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1BasicSyncPhase AudioPort2BasicSTEREOSYNCPHASE { get; set; }
Public Property AudioPort2BasicSTEREOSYNCPHASE As Lm49352TypeAudioPort1BasicSyncPhase
    Get
    Set
public:
property Lm49352TypeAudioPort1BasicSyncPhase AudioPort2BasicSTEREOSYNCPHASE {
    Lm49352TypeAudioPort1BasicSyncPhase get ();
    void set (Lm49352TypeAudioPort1BasicSyncPhase value);
}
member AudioPort2BasicSTEREOSYNCPHASE : Lm49352TypeAudioPort1BasicSyncPhase with get, set

Property Value

Type: Lm49352TypeAudioPort1BasicSyncPhase
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2BasicSYNCINVERT Property

IRD

Lm49352AudioPort2BasicSYNCINVERT Property

Audio Port2 Basic: SYNC_INVERT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1BasicInvert AudioPort2BasicSYNCINVERT { get; set; }
Public Property AudioPort2BasicSYNCINVERT As Lm49352TypeAudioPort1BasicInvert
    Get
    Set
public:
property Lm49352TypeAudioPort1BasicInvert AudioPort2BasicSYNCINVERT {
    Lm49352TypeAudioPort1BasicInvert get ();
    void set (Lm49352TypeAudioPort1BasicInvert value);
}
member AudioPort2BasicSYNCINVERT : Lm49352TypeAudioPort1BasicInvert with get, set

Property Value

Type: Lm49352TypeAudioPort1BasicInvert
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2BasicSYNCMS Property

IRD

Lm49352AudioPort2BasicSYNCMS Property

Audio Port2 Basic: SYNC_MS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1BasicSync AudioPort2BasicSYNCMS { get; set; }
Public Property AudioPort2BasicSYNCMS As Lm49352TypeAudioPort1BasicSync
    Get
    Set
public:
property Lm49352TypeAudioPort1BasicSync AudioPort2BasicSYNCMS {
    Lm49352TypeAudioPort1BasicSync get ();
    void set (Lm49352TypeAudioPort1BasicSync value);
}
member AudioPort2BasicSYNCMS : Lm49352TypeAudioPort1BasicSync with get, set

Property Value

Type: Lm49352TypeAudioPort1BasicSync
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2BasicTXENABLE Property

IRD

Lm49352AudioPort2BasicTXENABLE Property

Audio Port2 Basic: TX_ENABLE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1BasicTx AudioPort2BasicTXENABLE { get; set; }
Public Property AudioPort2BasicTXENABLE As Lm49352TypeAudioPort1BasicTx
    Get
    Set
public:
property Lm49352TypeAudioPort1BasicTx AudioPort2BasicTXENABLE {
    Lm49352TypeAudioPort1BasicTx get ();
    void set (Lm49352TypeAudioPort1BasicTx value);
}
member AudioPort2BasicTXENABLE : Lm49352TypeAudioPort1BasicTx with get, set

Property Value

Type: Lm49352TypeAudioPort1BasicTx
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2CLKGen1CLOCKSEL Property

IRD

Lm49352AudioPort2CLKGen1CLOCKSEL Property

Audio Port2 CLK Gen1: CLOCK_SEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1ClkGen1Sel AudioPort2CLKGen1CLOCKSEL { get; set; }
Public Property AudioPort2CLKGen1CLOCKSEL As Lm49352TypeAudioPort1ClkGen1Sel
    Get
    Set
public:
property Lm49352TypeAudioPort1ClkGen1Sel AudioPort2CLKGen1CLOCKSEL {
    Lm49352TypeAudioPort1ClkGen1Sel get ();
    void set (Lm49352TypeAudioPort1ClkGen1Sel value);
}
member AudioPort2CLKGen1CLOCKSEL : Lm49352TypeAudioPort1ClkGen1Sel with get, set

Property Value

Type: Lm49352TypeAudioPort1ClkGen1Sel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2CLKGen1HALFCYCLECLKDIV Property

IRD

Lm49352AudioPort2CLKGen1HALFCYCLECLKDIV Property

Audio Port2 CLK Gen1: HALF_CYCLE_CLK_DIV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1ClkGen1Divider AudioPort2CLKGen1HALFCYCLECLKDIV { get; set; }
Public Property AudioPort2CLKGen1HALFCYCLECLKDIV As Lm49352TypeAudioPort1ClkGen1Divider
    Get
    Set
public:
property Lm49352TypeAudioPort1ClkGen1Divider AudioPort2CLKGen1HALFCYCLECLKDIV {
    Lm49352TypeAudioPort1ClkGen1Divider get ();
    void set (Lm49352TypeAudioPort1ClkGen1Divider value);
}
member AudioPort2CLKGen1HALFCYCLECLKDIV : Lm49352TypeAudioPort1ClkGen1Divider with get, set

Property Value

Type: Lm49352TypeAudioPort1ClkGen1Divider
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2CLKGen2SYNTHDENOM Property

IRD

Lm49352AudioPort2CLKGen2SYNTHDENOM Property

Audio Port2 CLK Gen2: SYNTH_DENOM

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1ClkGen2SynthDenom AudioPort2CLKGen2SYNTHDENOM { get; set; }
Public Property AudioPort2CLKGen2SYNTHDENOM As Lm49352TypeAudioPort1ClkGen2SynthDenom
    Get
    Set
public:
property Lm49352TypeAudioPort1ClkGen2SynthDenom AudioPort2CLKGen2SYNTHDENOM {
    Lm49352TypeAudioPort1ClkGen2SynthDenom get ();
    void set (Lm49352TypeAudioPort1ClkGen2SynthDenom value);
}
member AudioPort2CLKGen2SYNTHDENOM : Lm49352TypeAudioPort1ClkGen2SynthDenom with get, set

Property Value

Type: Lm49352TypeAudioPort1ClkGen2SynthDenom
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2CLKGen2SYNTHNUM Property

IRD

Lm49352AudioPort2CLKGen2SYNTHNUM Property

Audio Port2 CLK Gen2: SYNTH_NUM

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1ClkGen2SynthNum AudioPort2CLKGen2SYNTHNUM { get; set; }
Public Property AudioPort2CLKGen2SYNTHNUM As Lm49352TypeAudioPort1ClkGen2SynthNum
    Get
    Set
public:
property Lm49352TypeAudioPort1ClkGen2SynthNum AudioPort2CLKGen2SYNTHNUM {
    Lm49352TypeAudioPort1ClkGen2SynthNum get ();
    void set (Lm49352TypeAudioPort1ClkGen2SynthNum value);
}
member AudioPort2CLKGen2SYNTHNUM : Lm49352TypeAudioPort1ClkGen2SynthNum with get, set

Property Value

Type: Lm49352TypeAudioPort1ClkGen2SynthNum
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2LSEL Property

IRD

Lm49352AudioPort2LSEL Property

Audio Port2: L_SEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort2LSel AudioPort2LSEL { get; set; }
Public Property AudioPort2LSEL As Lm49352TypeAudioPort2LSel
    Get
    Set
public:
property Lm49352TypeAudioPort2LSel AudioPort2LSEL {
    Lm49352TypeAudioPort2LSel get ();
    void set (Lm49352TypeAudioPort2LSel value);
}
member AudioPort2LSEL : Lm49352TypeAudioPort2LSel with get, set

Property Value

Type: Lm49352TypeAudioPort2LSel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2MONO Property

IRD

Lm49352AudioPort2MONO Property

Audio Port2: MONO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1Mono AudioPort2MONO { get; set; }
Public Property AudioPort2MONO As Lm49352TypeAudioPort1Mono
    Get
    Set
public:
property Lm49352TypeAudioPort1Mono AudioPort2MONO {
    Lm49352TypeAudioPort1Mono get ();
    void set (Lm49352TypeAudioPort1Mono value);
}
member AudioPort2MONO : Lm49352TypeAudioPort1Mono with get, set

Property Value

Type: Lm49352TypeAudioPort1Mono
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2RSEL Property

IRD

Lm49352AudioPort2RSEL Property

Audio Port2: R_SEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort2RSel AudioPort2RSEL { get; set; }
Public Property AudioPort2RSEL As Lm49352TypeAudioPort2RSel
    Get
    Set
public:
property Lm49352TypeAudioPort2RSel AudioPort2RSEL {
    Lm49352TypeAudioPort2RSel get ();
    void set (Lm49352TypeAudioPort2RSel value);
}
member AudioPort2RSEL : Lm49352TypeAudioPort2RSel with get, set

Property Value

Type: Lm49352TypeAudioPort2RSel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2RXCOMPAND Property

IRD

Lm49352AudioPort2RXCOMPAND Property

Audio Port2 RX: COMPAND

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1RxCompand AudioPort2RXCOMPAND { get; set; }
Public Property AudioPort2RXCOMPAND As Lm49352TypeAudioPort1RxCompand
    Get
    Set
public:
property Lm49352TypeAudioPort1RxCompand AudioPort2RXCOMPAND {
    Lm49352TypeAudioPort1RxCompand get ();
    void set (Lm49352TypeAudioPort1RxCompand value);
}
member AudioPort2RXCOMPAND : Lm49352TypeAudioPort1RxCompand with get, set

Property Value

Type: Lm49352TypeAudioPort1RxCompand
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2RXMSBPOSITION Property

IRD

Lm49352AudioPort2RXMSBPOSITION Property

Audio Port2 RX: MSB_POSITION

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AudioPort2RXMSBPOSITION { get; set; }
Public Property AudioPort2RXMSBPOSITION As Byte
    Get
    Set
public:
property unsigned char AudioPort2RXMSBPOSITION {
    unsigned char get ();
    void set (unsigned char value);
}
member AudioPort2RXMSBPOSITION : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2RXRXMODE Property

IRD

Lm49352AudioPort2RXRXMODE Property

Audio Port2 RX: RX_MODE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1RxMode AudioPort2RXRXMODE { get; set; }
Public Property AudioPort2RXRXMODE As Lm49352TypeAudioPort1RxMode
    Get
    Set
public:
property Lm49352TypeAudioPort1RxMode AudioPort2RXRXMODE {
    Lm49352TypeAudioPort1RxMode get ();
    void set (Lm49352TypeAudioPort1RxMode value);
}
member AudioPort2RXRXMODE : Lm49352TypeAudioPort1RxMode with get, set

Property Value

Type: Lm49352TypeAudioPort1RxMode
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2RXΜLawALaw Property

IRD

Lm49352AudioPort2RXΜLawALaw Property

Audio Port2 RX: μLaw/A-Law

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1RxLaw AudioPort2RXΜLawALaw { get; set; }
Public Property AudioPort2RXΜLawALaw As Lm49352TypeAudioPort1RxLaw
    Get
    Set
public:
property Lm49352TypeAudioPort1RxLaw AudioPort2RXΜLawALaw {
    Lm49352TypeAudioPort1RxLaw get ();
    void set (Lm49352TypeAudioPort1RxLaw value);
}
member AudioPort2RXΜLawALaw : Lm49352TypeAudioPort1RxLaw with get, set

Property Value

Type: Lm49352TypeAudioPort1RxLaw
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2SWAP Property

IRD

Lm49352AudioPort2SWAP Property

Audio Port2: SWAP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort2Swap AudioPort2SWAP { get; set; }
Public Property AudioPort2SWAP As Lm49352TypeAudioPort2Swap
    Get
    Set
public:
property Lm49352TypeAudioPort2Swap AudioPort2SWAP {
    Lm49352TypeAudioPort2Swap get ();
    void set (Lm49352TypeAudioPort2Swap value);
}
member AudioPort2SWAP : Lm49352TypeAudioPort2Swap with get, set

Property Value

Type: Lm49352TypeAudioPort2Swap
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2SyncGenSYNCRATE Property

IRD

Lm49352AudioPort2SyncGenSYNCRATE Property

Audio Port2 Sync Gen: SYNC_RATE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1SyncRate AudioPort2SyncGenSYNCRATE { get; set; }
Public Property AudioPort2SyncGenSYNCRATE As Lm49352TypeAudioPort1SyncRate
    Get
    Set
public:
property Lm49352TypeAudioPort1SyncRate AudioPort2SyncGenSYNCRATE {
    Lm49352TypeAudioPort1SyncRate get ();
    void set (Lm49352TypeAudioPort1SyncRate value);
}
member AudioPort2SyncGenSYNCRATE : Lm49352TypeAudioPort1SyncRate with get, set

Property Value

Type: Lm49352TypeAudioPort1SyncRate
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2SyncGenSYNCWIDTH Property

IRD

Lm49352AudioPort2SyncGenSYNCWIDTH Property

Audio Port2 Sync Gen: SYNC_WIDTH (unit: bits)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1SyncWidth AudioPort2SyncGenSYNCWIDTH { get; set; }
Public Property AudioPort2SyncGenSYNCWIDTH As Lm49352TypeAudioPort1SyncWidth
    Get
    Set
public:
property Lm49352TypeAudioPort1SyncWidth AudioPort2SyncGenSYNCWIDTH {
    Lm49352TypeAudioPort1SyncWidth get ();
    void set (Lm49352TypeAudioPort1SyncWidth value);
}
member AudioPort2SyncGenSYNCWIDTH : Lm49352TypeAudioPort1SyncWidth with get, set

Property Value

Type: Lm49352TypeAudioPort1SyncWidth
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2TXCOMPAND Property

IRD

Lm49352AudioPort2TXCOMPAND Property

Audio Port2 TX: COMPAND

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1RxCompand AudioPort2TXCOMPAND { get; set; }
Public Property AudioPort2TXCOMPAND As Lm49352TypeAudioPort1RxCompand
    Get
    Set
public:
property Lm49352TypeAudioPort1RxCompand AudioPort2TXCOMPAND {
    Lm49352TypeAudioPort1RxCompand get ();
    void set (Lm49352TypeAudioPort1RxCompand value);
}
member AudioPort2TXCOMPAND : Lm49352TypeAudioPort1RxCompand with get, set

Property Value

Type: Lm49352TypeAudioPort1RxCompand
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2TXMSBPOSITION Property

IRD

Lm49352AudioPort2TXMSBPOSITION Property

Audio Port2 TX: MSB_POSITION

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte AudioPort2TXMSBPOSITION { get; set; }
Public Property AudioPort2TXMSBPOSITION As Byte
    Get
    Set
public:
property unsigned char AudioPort2TXMSBPOSITION {
    unsigned char get ();
    void set (unsigned char value);
}
member AudioPort2TXMSBPOSITION : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2TXTXMODE Property

IRD

Lm49352AudioPort2TXTXMODE Property

Audio Port2 TX: TX_MODE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1RxMode AudioPort2TXTXMODE { get; set; }
Public Property AudioPort2TXTXMODE As Lm49352TypeAudioPort1RxMode
    Get
    Set
public:
property Lm49352TypeAudioPort1RxMode AudioPort2TXTXMODE {
    Lm49352TypeAudioPort1RxMode get ();
    void set (Lm49352TypeAudioPort1RxMode value);
}
member AudioPort2TXTXMODE : Lm49352TypeAudioPort1RxMode with get, set

Property Value

Type: Lm49352TypeAudioPort1RxMode
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2TXΜLawALaw Property

IRD

Lm49352AudioPort2TXΜLawALaw Property

Audio Port2 TX: μLaw/A-Law

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1RxLaw AudioPort2TXΜLawALaw { get; set; }
Public Property AudioPort2TXΜLawALaw As Lm49352TypeAudioPort1RxLaw
    Get
    Set
public:
property Lm49352TypeAudioPort1RxLaw AudioPort2TXΜLawALaw {
    Lm49352TypeAudioPort1RxLaw get ();
    void set (Lm49352TypeAudioPort1RxLaw value);
}
member AudioPort2TXΜLawALaw : Lm49352TypeAudioPort1RxLaw with get, set

Property Value

Type: Lm49352TypeAudioPort1RxLaw
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2WidthRXWIDTH Property

IRD

Lm49352AudioPort2WidthRXWIDTH Property

Audio Port2 Width: RX_WIDTH (unit: bits)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1WidthRxTx AudioPort2WidthRXWIDTH { get; set; }
Public Property AudioPort2WidthRXWIDTH As Lm49352TypeAudioPort1WidthRxTx
    Get
    Set
public:
property Lm49352TypeAudioPort1WidthRxTx AudioPort2WidthRXWIDTH {
    Lm49352TypeAudioPort1WidthRxTx get ();
    void set (Lm49352TypeAudioPort1WidthRxTx value);
}
member AudioPort2WidthRXWIDTH : Lm49352TypeAudioPort1WidthRxTx with get, set

Property Value

Type: Lm49352TypeAudioPort1WidthRxTx
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2WidthTXEXTRABITS Property

IRD

Lm49352AudioPort2WidthTXEXTRABITS Property

Audio Port2 Width: TX_EXTRA_BITS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1WidthExtra AudioPort2WidthTXEXTRABITS { get; set; }
Public Property AudioPort2WidthTXEXTRABITS As Lm49352TypeAudioPort1WidthExtra
    Get
    Set
public:
property Lm49352TypeAudioPort1WidthExtra AudioPort2WidthTXEXTRABITS {
    Lm49352TypeAudioPort1WidthExtra get ();
    void set (Lm49352TypeAudioPort1WidthExtra value);
}
member AudioPort2WidthTXEXTRABITS : Lm49352TypeAudioPort1WidthExtra with get, set

Property Value

Type: Lm49352TypeAudioPort1WidthExtra
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AudioPort2WidthTXWIDTH Property

IRD

Lm49352AudioPort2WidthTXWIDTH Property

Audio Port2 Width: TX_WIDTH (unit: bits)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAudioPort1WidthRxTx AudioPort2WidthTXWIDTH { get; set; }
Public Property AudioPort2WidthTXWIDTH As Lm49352TypeAudioPort1WidthRxTx
    Get
    Set
public:
property Lm49352TypeAudioPort1WidthRxTx AudioPort2WidthTXWIDTH {
    Lm49352TypeAudioPort1WidthRxTx get ();
    void set (Lm49352TypeAudioPort1WidthRxTx value);
}
member AudioPort2WidthTXWIDTH : Lm49352TypeAudioPort1WidthRxTx with get, set

Property Value

Type: Lm49352TypeAudioPort1WidthRxTx
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AutoFlush Property

IRD

Lm49352AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AUXLevelAUXLEVEL Property

IRD

Lm49352AUXLevelAUXLEVEL Property

AUX Level: AUX_LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AUXLevelAUXLEVEL { get; set; }
Public Property AUXLevelAUXLEVEL As Double
    Get
    Set
public:
property double AUXLevelAUXLEVEL {
    double get ();
    void set (double value);
}
member AUXLevelAUXLEVEL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AUXLevelSEDIFF Property

IRD

Lm49352AUXLevelSEDIFF Property

AUX Level: SE/DIFF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAuxLevelSediff AUXLevelSEDIFF { get; set; }
Public Property AUXLevelSEDIFF As Lm49352TypeAuxLevelSediff
    Get
    Set
public:
property Lm49352TypeAuxLevelSediff AUXLevelSEDIFF {
    Lm49352TypeAuxLevelSediff get ();
    void set (Lm49352TypeAuxLevelSediff value);
}
member AUXLevelSEDIFF : Lm49352TypeAuxLevelSediff with get, set

Property Value

Type: Lm49352TypeAuxLevelSediff
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AUXOutAUXAUX Property

IRD

Lm49352AUXOutAUXAUX Property

AUX Out: AUX_AUX

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAuxOutAux AUXOutAUXAUX { get; set; }
Public Property AUXOutAUXAUX As Lm49352TypeAuxOutAux
    Get
    Set
public:
property Lm49352TypeAuxOutAux AUXOutAUXAUX {
    Lm49352TypeAuxOutAux get ();
    void set (Lm49352TypeAuxOutAux value);
}
member AUXOutAUXAUX : Lm49352TypeAuxOutAux with get, set

Property Value

Type: Lm49352TypeAuxOutAux
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AUXOutDACLAUX Property

IRD

Lm49352AUXOutDACLAUX Property

AUX Out: DACL_AUX

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAuxOutDacl AUXOutDACLAUX { get; set; }
Public Property AUXOutDACLAUX As Lm49352TypeAuxOutDacl
    Get
    Set
public:
property Lm49352TypeAuxOutDacl AUXOutDACLAUX {
    Lm49352TypeAuxOutDacl get ();
    void set (Lm49352TypeAuxOutDacl value);
}
member AUXOutDACLAUX : Lm49352TypeAuxOutDacl with get, set

Property Value

Type: Lm49352TypeAuxOutDacl
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AUXOutDACRAUX Property

IRD

Lm49352AUXOutDACRAUX Property

AUX Out: DACR_AUX

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAuxOutDacr AUXOutDACRAUX { get; set; }
Public Property AUXOutDACRAUX As Lm49352TypeAuxOutDacr
    Get
    Set
public:
property Lm49352TypeAuxOutDacr AUXOutDACRAUX {
    Lm49352TypeAuxOutDacr get ();
    void set (Lm49352TypeAuxOutDacr value);
}
member AUXOutDACRAUX : Lm49352TypeAuxOutDacr with get, set

Property Value

Type: Lm49352TypeAuxOutDacr
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AUXOutMICAUX Property

IRD

Lm49352AUXOutMICAUX Property

AUX Out: MIC_ AUX

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAuxOutMic AUXOutMICAUX { get; set; }
Public Property AUXOutMICAUX As Lm49352TypeAuxOutMic
    Get
    Set
public:
property Lm49352TypeAuxOutMic AUXOutMICAUX {
    Lm49352TypeAuxOutMic get ();
    void set (Lm49352TypeAuxOutMic value);
}
member AUXOutMICAUX : Lm49352TypeAuxOutMic with get, set

Property Value

Type: Lm49352TypeAuxOutMic
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.AUXOutMONOAUX Property

IRD

Lm49352AUXOutMONOAUX Property

AUX Out: MONO_AUX

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAuxOutMono AUXOutMONOAUX { get; set; }
Public Property AUXOutMONOAUX As Lm49352TypeAuxOutMono
    Get
    Set
public:
property Lm49352TypeAuxOutMono AUXOutMONOAUX {
    Lm49352TypeAuxOutMono get ();
    void set (Lm49352TypeAuxOutMono value);
}
member AUXOutMONOAUX : Lm49352TypeAuxOutMono with get, set

Property Value

Type: Lm49352TypeAuxOutMono
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ClassDAUXLS Property

IRD

Lm49352ClassDAUXLS Property

Class D: AUX_LS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeClassDAux ClassDAUXLS { get; set; }
Public Property ClassDAUXLS As Lm49352TypeClassDAux
    Get
    Set
public:
property Lm49352TypeClassDAux ClassDAUXLS {
    Lm49352TypeClassDAux get ();
    void set (Lm49352TypeClassDAux value);
}
member ClassDAUXLS : Lm49352TypeClassDAux with get, set

Property Value

Type: Lm49352TypeClassDAux
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ClassDDACLLS Property

IRD

Lm49352ClassDDACLLS Property

Class D: DACL_LS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeClassDDacl ClassDDACLLS { get; set; }
Public Property ClassDDACLLS As Lm49352TypeClassDDacl
    Get
    Set
public:
property Lm49352TypeClassDDacl ClassDDACLLS {
    Lm49352TypeClassDDacl get ();
    void set (Lm49352TypeClassDDacl value);
}
member ClassDDACLLS : Lm49352TypeClassDDacl with get, set

Property Value

Type: Lm49352TypeClassDDacl
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ClassDDACRLS Property

IRD

Lm49352ClassDDACRLS Property

Class D: DACR_LS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeClassDDacr ClassDDACRLS { get; set; }
Public Property ClassDDACRLS As Lm49352TypeClassDDacr
    Get
    Set
public:
property Lm49352TypeClassDDacr ClassDDACRLS {
    Lm49352TypeClassDDacr get ();
    void set (Lm49352TypeClassDDacr value);
}
member ClassDDACRLS : Lm49352TypeClassDDacr with get, set

Property Value

Type: Lm49352TypeClassDDacr
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ClassDMONOLS Property

IRD

Lm49352ClassDMONOLS Property

Class D: MONO_LS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeClassDMono ClassDMONOLS { get; set; }
Public Property ClassDMONOLS As Lm49352TypeClassDMono
    Get
    Set
public:
property Lm49352TypeClassDMono ClassDMONOLS {
    Lm49352TypeClassDMono get ();
    void set (Lm49352TypeClassDMono value);
}
member ClassDMONOLS : Lm49352TypeClassDMono with get, set

Property Value

Type: Lm49352TypeClassDMono
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACALC1DACSAMPLE Property

IRD

Lm49352DACALC1DACSAMPLE Property

DAC ALC1: DAC_SAMPLE (unit: kHz)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc1SampleRate DACALC1DACSAMPLE { get; set; }
Public Property DACALC1DACSAMPLE As Lm49352TypeAdcAlc1SampleRate
    Get
    Set
public:
property Lm49352TypeAdcAlc1SampleRate DACALC1DACSAMPLE {
    Lm49352TypeAdcAlc1SampleRate get ();
    void set (Lm49352TypeAdcAlc1SampleRate value);
}
member DACALC1DACSAMPLE : Lm49352TypeAdcAlc1SampleRate with get, set

Property Value

Type: Lm49352TypeAdcAlc1SampleRate
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACALC1LIMITER Property

IRD

Lm49352DACALC1LIMITER Property

DAC ALC1: LIMITER

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc1Limiter DACALC1LIMITER { get; set; }
Public Property DACALC1LIMITER As Lm49352TypeAdcAlc1Limiter
    Get
    Set
public:
property Lm49352TypeAdcAlc1Limiter DACALC1LIMITER {
    Lm49352TypeAdcAlc1Limiter get ();
    void set (Lm49352TypeAdcAlc1Limiter value);
}
member DACALC1LIMITER : Lm49352TypeAdcAlc1Limiter with get, set

Property Value

Type: Lm49352TypeAdcAlc1Limiter
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACALC1STEREOLINK Property

IRD

Lm49352DACALC1STEREOLINK Property

DAC ALC1: STEREO_LINK

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc1Stereo DACALC1STEREOLINK { get; set; }
Public Property DACALC1STEREOLINK As Lm49352TypeAdcAlc1Stereo
    Get
    Set
public:
property Lm49352TypeAdcAlc1Stereo DACALC1STEREOLINK {
    Lm49352TypeAdcAlc1Stereo get ();
    void set (Lm49352TypeAdcAlc1Stereo value);
}
member DACALC1STEREOLINK : Lm49352TypeAdcAlc1Stereo with get, set

Property Value

Type: Lm49352TypeAdcAlc1Stereo
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACALC2NGENB Property

IRD

Lm49352DACALC2NGENB Property

DAC ALC2: NG_ENB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc2NoiseGate DACALC2NGENB { get; set; }
Public Property DACALC2NGENB As Lm49352TypeAdcAlc2NoiseGate
    Get
    Set
public:
property Lm49352TypeAdcAlc2NoiseGate DACALC2NGENB {
    Lm49352TypeAdcAlc2NoiseGate get ();
    void set (Lm49352TypeAdcAlc2NoiseGate value);
}
member DACALC2NGENB : Lm49352TypeAdcAlc2NoiseGate with get, set

Property Value

Type: Lm49352TypeAdcAlc2NoiseGate
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACALC2NOISEFLOOR Property

IRD

Lm49352DACALC2NOISEFLOOR Property

DAC ALC2: NOISE_FLOOR (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DACALC2NOISEFLOOR { get; set; }
Public Property DACALC2NOISEFLOOR As Double
    Get
    Set
public:
property double DACALC2NOISEFLOOR {
    double get ();
    void set (double value);
}
member DACALC2NOISEFLOOR : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACALC3TARGETLEVEL Property

IRD

Lm49352DACALC3TARGETLEVEL Property

DAC ALC3: TARGET_LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DACALC3TARGETLEVEL { get; set; }
Public Property DACALC3TARGETLEVEL As Double
    Get
    Set
public:
property double DACALC3TARGETLEVEL {
    double get ();
    void set (double value);
}
member DACALC3TARGETLEVEL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACALC4ATTACKRATE Property

IRD

Lm49352DACALC4ATTACKRATE Property

DAC ALC4: ATTACK_RATE (unit: μs)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc4AttackRate DACALC4ATTACKRATE { get; set; }
Public Property DACALC4ATTACKRATE As Lm49352TypeAdcAlc4AttackRate
    Get
    Set
public:
property Lm49352TypeAdcAlc4AttackRate DACALC4ATTACKRATE {
    Lm49352TypeAdcAlc4AttackRate get ();
    void set (Lm49352TypeAdcAlc4AttackRate value);
}
member DACALC4ATTACKRATE : Lm49352TypeAdcAlc4AttackRate with get, set

Property Value

Type: Lm49352TypeAdcAlc4AttackRate
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACALC5DECAYRATE Property

IRD

Lm49352DACALC5DECAYRATE Property

DAC ALC5: DECAY_RATE (unit: μs)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc5DecayRate DACALC5DECAYRATE { get; set; }
Public Property DACALC5DECAYRATE As Lm49352TypeAdcAlc5DecayRate
    Get
    Set
public:
property Lm49352TypeAdcAlc5DecayRate DACALC5DECAYRATE {
    Lm49352TypeAdcAlc5DecayRate get ();
    void set (Lm49352TypeAdcAlc5DecayRate value);
}
member DACALC5DECAYRATE : Lm49352TypeAdcAlc5DecayRate with get, set

Property Value

Type: Lm49352TypeAdcAlc5DecayRate
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACALC5PKDECAYRATE Property

IRD

Lm49352DACALC5PKDECAYRATE Property

DAC ALC5: PK_DECAY_RATE (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc5PkDecayRate DACALC5PKDECAYRATE { get; set; }
Public Property DACALC5PKDECAYRATE As Lm49352TypeAdcAlc5PkDecayRate
    Get
    Set
public:
property Lm49352TypeAdcAlc5PkDecayRate DACALC5PKDECAYRATE {
    Lm49352TypeAdcAlc5PkDecayRate get ();
    void set (Lm49352TypeAdcAlc5PkDecayRate value);
}
member DACALC5PKDECAYRATE : Lm49352TypeAdcAlc5PkDecayRate with get, set

Property Value

Type: Lm49352TypeAdcAlc5PkDecayRate
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACALC6HOLDTIME Property

IRD

Lm49352DACALC6HOLDTIME Property

DAC ALC6: HOLD_TIME (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcAlc6HoldTime DACALC6HOLDTIME { get; set; }
Public Property DACALC6HOLDTIME As Lm49352TypeAdcAlc6HoldTime
    Get
    Set
public:
property Lm49352TypeAdcAlc6HoldTime DACALC6HOLDTIME {
    Lm49352TypeAdcAlc6HoldTime get ();
    void set (Lm49352TypeAdcAlc6HoldTime value);
}
member DACALC6HOLDTIME : Lm49352TypeAdcAlc6HoldTime with get, set

Property Value

Type: Lm49352TypeAdcAlc6HoldTime
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACALC7MAXLEVEL Property

IRD

Lm49352DACALC7MAXLEVEL Property

DAC ALC7: MAX_LEVEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACALC7MAXLEVEL { get; set; }
Public Property DACALC7MAXLEVEL As Byte
    Get
    Set
public:
property unsigned char DACALC7MAXLEVEL {
    unsigned char get ();
    void set (unsigned char value);
}
member DACALC7MAXLEVEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACALC8MINLEVEL Property

IRD

Lm49352DACALC8MINLEVEL Property

DAC ALC8: MIN_LEVEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACALC8MINLEVEL { get; set; }
Public Property DACALC8MINLEVEL As Byte
    Get
    Set
public:
property unsigned char DACALC8MINLEVEL {
    unsigned char get ();
    void set (unsigned char value);
}
member DACALC8MINLEVEL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACALCMonLALCMONL Property

IRD

Lm49352DACALCMonLALCMONL Property

DAC ALC Mon L: ALCMONL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACALCMonLALCMONL { get; set; }
Public Property DACALCMonLALCMONL As Byte
    Get
    Set
public:
property unsigned char DACALCMonLALCMONL {
    unsigned char get ();
    void set (unsigned char value);
}
member DACALCMonLALCMONL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACALCMonLSCLPLDISTORT Property

IRD

Lm49352DACALCMonLSCLPLDISTORT Property

DAC ALC Mon L: SCLP_L_DISTORT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet DACALCMonLSCLPLDISTORT { get; set; }
Public Property DACALCMonLSCLPLDISTORT As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet DACALCMonLSCLPLDISTORT {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member DACALCMonLSCLPLDISTORT : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACALCMonLSCLPRDISTORT Property

IRD

Lm49352DACALCMonLSCLPRDISTORT Property

DAC ALC Mon L: SCLP_R_DISTORT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet DACALCMonLSCLPRDISTORT { get; set; }
Public Property DACALCMonLSCLPRDISTORT As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet DACALCMonLSCLPRDISTORT {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member DACALCMonLSCLPRDISTORT : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACALCMonRALCMONR Property

IRD

Lm49352DACALCMonRALCMONR Property

DAC ALC Mon R: ALCMONR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACALCMonRALCMONR { get; set; }
Public Property DACALCMonRALCMONR As Byte
    Get
    Set
public:
property unsigned char DACALCMonRALCMONR {
    unsigned char get ();
    void set (unsigned char value);
}
member DACALCMonRALCMONR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACALCMonRSCLPLDISTORT Property

IRD

Lm49352DACALCMonRSCLPLDISTORT Property

DAC ALC Mon R: SCLP_L_DISTORT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet DACALCMonRSCLPLDISTORT { get; set; }
Public Property DACALCMonRSCLPLDISTORT As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet DACALCMonRSCLPLDISTORT {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member DACALCMonRSCLPLDISTORT : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACALCMonRSCLPRDISTORT Property

IRD

Lm49352DACALCMonRSCLPRDISTORT Property

DAC ALC Mon R: SCLP_R_DISTORT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet DACALCMonRSCLPRDISTORT { get; set; }
Public Property DACALCMonRSCLPRDISTORT As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet DACALCMonRSCLPRDISTORT {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member DACALCMonRSCLPRDISTORT : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACBasicDACCLKSEL Property

IRD

Lm49352DACBasicDACCLKSEL Property

DAC Basic: DAC_CLK_SEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeDacBasicClock DACBasicDACCLKSEL { get; set; }
Public Property DACBasicDACCLKSEL As Lm49352TypeDacBasicClock
    Get
    Set
public:
property Lm49352TypeDacBasicClock DACBasicDACCLKSEL {
    Lm49352TypeDacBasicClock get ();
    void set (Lm49352TypeDacBasicClock value);
}
member DACBasicDACCLKSEL : Lm49352TypeDacBasicClock with get, set

Property Value

Type: Lm49352TypeDacBasicClock
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACBasicDSPONLY Property

IRD

Lm49352DACBasicDSPONLY Property

DAC Basic: DSP_ONLY

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeDacBasicDspOnly DACBasicDSPONLY { get; set; }
Public Property DACBasicDSPONLY As Lm49352TypeDacBasicDspOnly
    Get
    Set
public:
property Lm49352TypeDacBasicDspOnly DACBasicDSPONLY {
    Lm49352TypeDacBasicDspOnly get ();
    void set (Lm49352TypeDacBasicDspOnly value);
}
member DACBasicDSPONLY : Lm49352TypeDacBasicDspOnly with get, set

Property Value

Type: Lm49352TypeDacBasicDspOnly
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACBasicMODE Property

IRD

Lm49352DACBasicMODE Property

DAC Basic: MODE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeDacBasicMode DACBasicMODE { get; set; }
Public Property DACBasicMODE As Lm49352TypeDacBasicMode
    Get
    Set
public:
property Lm49352TypeDacBasicMode DACBasicMODE {
    Lm49352TypeDacBasicMode get ();
    void set (Lm49352TypeDacBasicMode value);
}
member DACBasicMODE : Lm49352TypeDacBasicMode with get, set

Property Value

Type: Lm49352TypeDacBasicMode
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACBasicMUTEL Property

IRD

Lm49352DACBasicMUTEL Property

DAC Basic: MUTE_L

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeDacBasicMuteL DACBasicMUTEL { get; set; }
Public Property DACBasicMUTEL As Lm49352TypeDacBasicMuteL
    Get
    Set
public:
property Lm49352TypeDacBasicMuteL DACBasicMUTEL {
    Lm49352TypeDacBasicMuteL get ();
    void set (Lm49352TypeDacBasicMuteL value);
}
member DACBasicMUTEL : Lm49352TypeDacBasicMuteL with get, set

Property Value

Type: Lm49352TypeDacBasicMuteL
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACBasicMUTER Property

IRD

Lm49352DACBasicMUTER Property

DAC Basic: MUTE_R

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeDacBasicMuteR DACBasicMUTER { get; set; }
Public Property DACBasicMUTER As Lm49352TypeDacBasicMuteR
    Get
    Set
public:
property Lm49352TypeDacBasicMuteR DACBasicMUTER {
    Lm49352TypeDacBasicMuteR get ();
    void set (Lm49352TypeDacBasicMuteR value);
}
member DACBasicMUTER : Lm49352TypeDacBasicMuteR with get, set

Property Value

Type: Lm49352TypeDacBasicMuteR
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACClockDACCLKDIV Property

IRD

Lm49352DACClockDACCLKDIV Property

DAC Clock: DAC_CLK_DIV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypePmcClkDiv DACClockDACCLKDIV { get; set; }
Public Property DACClockDACCLKDIV As Lm49352TypePmcClkDiv
    Get
    Set
public:
property Lm49352TypePmcClkDiv DACClockDACCLKDIV {
    Lm49352TypePmcClkDiv get ();
    void set (Lm49352TypePmcClkDiv value);
}
member DACClockDACCLKDIV : Lm49352TypePmcClkDiv with get, set

Property Value

Type: Lm49352TypePmcClkDiv
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACEQBand1FREQ Property

IRD

Lm49352DACEQBand1FREQ Property

DAC EQ Band1: FREQ (unit: Hz)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand1Freq DACEQBand1FREQ { get; set; }
Public Property DACEQBand1FREQ As Lm49352TypeAdcEqBand1Freq
    Get
    Set
public:
property Lm49352TypeAdcEqBand1Freq DACEQBand1FREQ {
    Lm49352TypeAdcEqBand1Freq get ();
    void set (Lm49352TypeAdcEqBand1Freq value);
}
member DACEQBand1FREQ : Lm49352TypeAdcEqBand1Freq with get, set

Property Value

Type: Lm49352TypeAdcEqBand1Freq
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACEQBand1LEVEL Property

IRD

Lm49352DACEQBand1LEVEL Property

DAC EQ Band1: LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand1EqLevel DACEQBand1LEVEL { get; set; }
Public Property DACEQBand1LEVEL As Lm49352TypeAdcEqBand1EqLevel
    Get
    Set
public:
property Lm49352TypeAdcEqBand1EqLevel DACEQBand1LEVEL {
    Lm49352TypeAdcEqBand1EqLevel get ();
    void set (Lm49352TypeAdcEqBand1EqLevel value);
}
member DACEQBand1LEVEL : Lm49352TypeAdcEqBand1EqLevel with get, set

Property Value

Type: Lm49352TypeAdcEqBand1EqLevel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACEQBand2FREQ Property

IRD

Lm49352DACEQBand2FREQ Property

DAC EQ Band2: FREQ (unit: Hz)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand2Freq DACEQBand2FREQ { get; set; }
Public Property DACEQBand2FREQ As Lm49352TypeAdcEqBand2Freq
    Get
    Set
public:
property Lm49352TypeAdcEqBand2Freq DACEQBand2FREQ {
    Lm49352TypeAdcEqBand2Freq get ();
    void set (Lm49352TypeAdcEqBand2Freq value);
}
member DACEQBand2FREQ : Lm49352TypeAdcEqBand2Freq with get, set

Property Value

Type: Lm49352TypeAdcEqBand2Freq
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACEQBand2LEVEL Property

IRD

Lm49352DACEQBand2LEVEL Property

DAC EQ Band2: LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand1EqLevel DACEQBand2LEVEL { get; set; }
Public Property DACEQBand2LEVEL As Lm49352TypeAdcEqBand1EqLevel
    Get
    Set
public:
property Lm49352TypeAdcEqBand1EqLevel DACEQBand2LEVEL {
    Lm49352TypeAdcEqBand1EqLevel get ();
    void set (Lm49352TypeAdcEqBand1EqLevel value);
}
member DACEQBand2LEVEL : Lm49352TypeAdcEqBand1EqLevel with get, set

Property Value

Type: Lm49352TypeAdcEqBand1EqLevel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACEQBand2Q Property

IRD

Lm49352DACEQBand2Q Property

DAC EQ Band2: Q (unit: Octave)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand2Q DACEQBand2Q { get; set; }
Public Property DACEQBand2Q As Lm49352TypeAdcEqBand2Q
    Get
    Set
public:
property Lm49352TypeAdcEqBand2Q DACEQBand2Q {
    Lm49352TypeAdcEqBand2Q get ();
    void set (Lm49352TypeAdcEqBand2Q value);
}
member DACEQBand2Q : Lm49352TypeAdcEqBand2Q with get, set

Property Value

Type: Lm49352TypeAdcEqBand2Q
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACEQBand3FREQ Property

IRD

Lm49352DACEQBand3FREQ Property

DAC EQ Band3: FREQ (unit: Hz)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand3Freq DACEQBand3FREQ { get; set; }
Public Property DACEQBand3FREQ As Lm49352TypeAdcEqBand3Freq
    Get
    Set
public:
property Lm49352TypeAdcEqBand3Freq DACEQBand3FREQ {
    Lm49352TypeAdcEqBand3Freq get ();
    void set (Lm49352TypeAdcEqBand3Freq value);
}
member DACEQBand3FREQ : Lm49352TypeAdcEqBand3Freq with get, set

Property Value

Type: Lm49352TypeAdcEqBand3Freq
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACEQBand3LEVEL Property

IRD

Lm49352DACEQBand3LEVEL Property

DAC EQ Band3: LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand1EqLevel DACEQBand3LEVEL { get; set; }
Public Property DACEQBand3LEVEL As Lm49352TypeAdcEqBand1EqLevel
    Get
    Set
public:
property Lm49352TypeAdcEqBand1EqLevel DACEQBand3LEVEL {
    Lm49352TypeAdcEqBand1EqLevel get ();
    void set (Lm49352TypeAdcEqBand1EqLevel value);
}
member DACEQBand3LEVEL : Lm49352TypeAdcEqBand1EqLevel with get, set

Property Value

Type: Lm49352TypeAdcEqBand1EqLevel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACEQBand3Q Property

IRD

Lm49352DACEQBand3Q Property

DAC EQ Band3: Q (unit: Octave)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand2Q DACEQBand3Q { get; set; }
Public Property DACEQBand3Q As Lm49352TypeAdcEqBand2Q
    Get
    Set
public:
property Lm49352TypeAdcEqBand2Q DACEQBand3Q {
    Lm49352TypeAdcEqBand2Q get ();
    void set (Lm49352TypeAdcEqBand2Q value);
}
member DACEQBand3Q : Lm49352TypeAdcEqBand2Q with get, set

Property Value

Type: Lm49352TypeAdcEqBand2Q
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACEQBand4FREQ Property

IRD

Lm49352DACEQBand4FREQ Property

DAC EQ Band4: FREQ (unit: kHz)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand4Freq DACEQBand4FREQ { get; set; }
Public Property DACEQBand4FREQ As Lm49352TypeAdcEqBand4Freq
    Get
    Set
public:
property Lm49352TypeAdcEqBand4Freq DACEQBand4FREQ {
    Lm49352TypeAdcEqBand4Freq get ();
    void set (Lm49352TypeAdcEqBand4Freq value);
}
member DACEQBand4FREQ : Lm49352TypeAdcEqBand4Freq with get, set

Property Value

Type: Lm49352TypeAdcEqBand4Freq
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACEQBand4LEVEL Property

IRD

Lm49352DACEQBand4LEVEL Property

DAC EQ Band4: LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand1EqLevel DACEQBand4LEVEL { get; set; }
Public Property DACEQBand4LEVEL As Lm49352TypeAdcEqBand1EqLevel
    Get
    Set
public:
property Lm49352TypeAdcEqBand1EqLevel DACEQBand4LEVEL {
    Lm49352TypeAdcEqBand1EqLevel get ();
    void set (Lm49352TypeAdcEqBand1EqLevel value);
}
member DACEQBand4LEVEL : Lm49352TypeAdcEqBand1EqLevel with get, set

Property Value

Type: Lm49352TypeAdcEqBand1EqLevel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACEQBand4Q Property

IRD

Lm49352DACEQBand4Q Property

DAC EQ Band4: Q (unit: Octave)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand2Q DACEQBand4Q { get; set; }
Public Property DACEQBand4Q As Lm49352TypeAdcEqBand2Q
    Get
    Set
public:
property Lm49352TypeAdcEqBand2Q DACEQBand4Q {
    Lm49352TypeAdcEqBand2Q get ();
    void set (Lm49352TypeAdcEqBand2Q value);
}
member DACEQBand4Q : Lm49352TypeAdcEqBand2Q with get, set

Property Value

Type: Lm49352TypeAdcEqBand2Q
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACEQBand5FREQ Property

IRD

Lm49352DACEQBand5FREQ Property

DAC EQ Band5: FREQ (unit: kHz)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand5Freq DACEQBand5FREQ { get; set; }
Public Property DACEQBand5FREQ As Lm49352TypeAdcEqBand5Freq
    Get
    Set
public:
property Lm49352TypeAdcEqBand5Freq DACEQBand5FREQ {
    Lm49352TypeAdcEqBand5Freq get ();
    void set (Lm49352TypeAdcEqBand5Freq value);
}
member DACEQBand5FREQ : Lm49352TypeAdcEqBand5Freq with get, set

Property Value

Type: Lm49352TypeAdcEqBand5Freq
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACEQBand5LEVEL Property

IRD

Lm49352DACEQBand5LEVEL Property

DAC EQ Band5: LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcEqBand1EqLevel DACEQBand5LEVEL { get; set; }
Public Property DACEQBand5LEVEL As Lm49352TypeAdcEqBand1EqLevel
    Get
    Set
public:
property Lm49352TypeAdcEqBand1EqLevel DACEQBand5LEVEL {
    Lm49352TypeAdcEqBand1EqLevel get ();
    void set (Lm49352TypeAdcEqBand1EqLevel value);
}
member DACEQBand5LEVEL : Lm49352TypeAdcEqBand1EqLevel with get, set

Property Value

Type: Lm49352TypeAdcEqBand1EqLevel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACFXClip3DLCLIP Property

IRD

Lm49352DACFXClip3DLCLIP Property

DAC FX Clip: 3D_L_CLIP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet DACFXClip3DLCLIP { get; set; }
Public Property DACFXClip3DLCLIP As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet DACFXClip3DLCLIP {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member DACFXClip3DLCLIP : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACFXClip3DRCLIP Property

IRD

Lm49352DACFXClip3DRCLIP Property

DAC FX Clip: 3D_R_CLIP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet DACFXClip3DRCLIP { get; set; }
Public Property DACFXClip3DRCLIP As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet DACFXClip3DRCLIP {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member DACFXClip3DRCLIP : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACFXClipEQLCLIP Property

IRD

Lm49352DACFXClipEQLCLIP Property

DAC FX Clip: EQ_L_CLIP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet DACFXClipEQLCLIP { get; set; }
Public Property DACFXClipEQLCLIP As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet DACFXClipEQLCLIP {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member DACFXClipEQLCLIP : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACFXClipEQRCLIP Property

IRD

Lm49352DACFXClipEQRCLIP Property

DAC FX Clip: EQ_R_CLIP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet DACFXClipEQRCLIP { get; set; }
Public Property DACFXClipEQRCLIP As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet DACFXClipEQRCLIP {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member DACFXClipEQRCLIP : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACFXClipGAINLCLIP Property

IRD

Lm49352DACFXClipGAINLCLIP Property

DAC FX Clip: GAIN_L_CLIP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet DACFXClipGAINLCLIP { get; set; }
Public Property DACFXClipGAINLCLIP As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet DACFXClipGAINLCLIP {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member DACFXClipGAINLCLIP : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACFXClipGAINRCLIP Property

IRD

Lm49352DACFXClipGAINRCLIP Property

DAC FX Clip: GAIN_R_CLIP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet DACFXClipGAINRCLIP { get; set; }
Public Property DACFXClipGAINRCLIP As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet DACFXClipGAINRCLIP {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member DACFXClipGAINRCLIP : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACFXClipSCLPLCLIP Property

IRD

Lm49352DACFXClipSCLPLCLIP Property

DAC FX Clip: SCLP_L_CLIP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet DACFXClipSCLPLCLIP { get; set; }
Public Property DACFXClipSCLPLCLIP As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet DACFXClipSCLPLCLIP {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member DACFXClipSCLPLCLIP : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACFXClipSCLPRCLIP Property

IRD

Lm49352DACFXClipSCLPRCLIP Property

DAC FX Clip: SCLP_R_CLIP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSetNotSet DACFXClipSCLPRCLIP { get; set; }
Public Property DACFXClipSCLPRCLIP As Lm49352TypeSetNotSet
    Get
    Set
public:
property Lm49352TypeSetNotSet DACFXClipSCLPRCLIP {
    Lm49352TypeSetNotSet get ();
    void set (Lm49352TypeSetNotSet value);
}
member DACFXClipSCLPRCLIP : Lm49352TypeSetNotSet with get, set

Property Value

Type: Lm49352TypeSetNotSet
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACFXDACALCENB Property

IRD

Lm49352DACFXDACALCENB Property

DAC FX: DAC_ALC_ENB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeDacFxAlc DACFXDACALCENB { get; set; }
Public Property DACFXDACALCENB As Lm49352TypeDacFxAlc
    Get
    Set
public:
property Lm49352TypeDacFxAlc DACFXDACALCENB {
    Lm49352TypeDacFxAlc get ();
    void set (Lm49352TypeDacFxAlc value);
}
member DACFXDACALCENB : Lm49352TypeDacFxAlc with get, set

Property Value

Type: Lm49352TypeDacFxAlc
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACFXDACEQENB Property

IRD

Lm49352DACFXDACEQENB Property

DAC FX: DAC_EQ_ENB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeDacFxEq DACFXDACEQENB { get; set; }
Public Property DACFXDACEQENB As Lm49352TypeDacFxEq
    Get
    Set
public:
property Lm49352TypeDacFxEq DACFXDACEQENB {
    Lm49352TypeDacFxEq get ();
    void set (Lm49352TypeDacFxEq value);
}
member DACFXDACEQENB : Lm49352TypeDacFxEq with get, set

Property Value

Type: Lm49352TypeDacFxEq
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACFXDACPKENB Property

IRD

Lm49352DACFXDACPKENB Property

DAC FX: DAC_PK_ENB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcFxPk DACFXDACPKENB { get; set; }
Public Property DACFXDACPKENB As Lm49352TypeAdcFxPk
    Get
    Set
public:
property Lm49352TypeAdcFxPk DACFXDACPKENB {
    Lm49352TypeAdcFxPk get ();
    void set (Lm49352TypeAdcFxPk value);
}
member DACFXDACPKENB : Lm49352TypeAdcFxPk with get, set

Property Value

Type: Lm49352TypeAdcFxPk
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACFXDACSCLPENB Property

IRD

Lm49352DACFXDACSCLPENB Property

DAC FX: DAC_SCLP_ENB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeDacFxSclp DACFXDACSCLPENB { get; set; }
Public Property DACFXDACSCLPENB As Lm49352TypeDacFxSclp
    Get
    Set
public:
property Lm49352TypeDacFxSclp DACFXDACSCLPENB {
    Lm49352TypeDacFxSclp get ();
    void set (Lm49352TypeDacFxSclp value);
}
member DACFXDACSCLPENB : Lm49352TypeDacFxSclp with get, set

Property Value

Type: Lm49352TypeDacFxSclp
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACInputADCL Property

IRD

Lm49352DACInputADCL Property

DAC Input: ADC_L

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeDacInputAdcL DACInputADCL { get; set; }
Public Property DACInputADCL As Lm49352TypeDacInputAdcL
    Get
    Set
public:
property Lm49352TypeDacInputAdcL DACInputADCL {
    Lm49352TypeDacInputAdcL get ();
    void set (Lm49352TypeDacInputAdcL value);
}
member DACInputADCL : Lm49352TypeDacInputAdcL with get, set

Property Value

Type: Lm49352TypeDacInputAdcL
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACInputADCR Property

IRD

Lm49352DACInputADCR Property

DAC Input: ADC_R

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeDacInputAdcR DACInputADCR { get; set; }
Public Property DACInputADCR As Lm49352TypeDacInputAdcR
    Get
    Set
public:
property Lm49352TypeDacInputAdcR DACInputADCR {
    Lm49352TypeDacInputAdcR get ();
    void set (Lm49352TypeDacInputAdcR value);
}
member DACInputADCR : Lm49352TypeDacInputAdcR with get, set

Property Value

Type: Lm49352TypeDacInputAdcR
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACInputPORT1L Property

IRD

Lm49352DACInputPORT1L Property

DAC Input: PORT1_L

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeDacInputPort1L DACInputPORT1L { get; set; }
Public Property DACInputPORT1L As Lm49352TypeDacInputPort1L
    Get
    Set
public:
property Lm49352TypeDacInputPort1L DACInputPORT1L {
    Lm49352TypeDacInputPort1L get ();
    void set (Lm49352TypeDacInputPort1L value);
}
member DACInputPORT1L : Lm49352TypeDacInputPort1L with get, set

Property Value

Type: Lm49352TypeDacInputPort1L
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACInputPORT1R Property

IRD

Lm49352DACInputPORT1R Property

DAC Input: PORT1_R

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeDacInputPort1R DACInputPORT1R { get; set; }
Public Property DACInputPORT1R As Lm49352TypeDacInputPort1R
    Get
    Set
public:
property Lm49352TypeDacInputPort1R DACInputPORT1R {
    Lm49352TypeDacInputPort1R get ();
    void set (Lm49352TypeDacInputPort1R value);
}
member DACInputPORT1R : Lm49352TypeDacInputPort1R with get, set

Property Value

Type: Lm49352TypeDacInputPort1R
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACInputPORT2L Property

IRD

Lm49352DACInputPORT2L Property

DAC Input: PORT2_L

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeDacInputPort2L DACInputPORT2L { get; set; }
Public Property DACInputPORT2L As Lm49352TypeDacInputPort2L
    Get
    Set
public:
property Lm49352TypeDacInputPort2L DACInputPORT2L {
    Lm49352TypeDacInputPort2L get ();
    void set (Lm49352TypeDacInputPort2L value);
}
member DACInputPORT2L : Lm49352TypeDacInputPort2L with get, set

Property Value

Type: Lm49352TypeDacInputPort2L
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACInputPORT2R Property

IRD

Lm49352DACInputPORT2R Property

DAC Input: PORT2_R

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeDacInputPort2R DACInputPORT2R { get; set; }
Public Property DACInputPORT2R As Lm49352TypeDacInputPort2R
    Get
    Set
public:
property Lm49352TypeDacInputPort2R DACInputPORT2R {
    Lm49352TypeDacInputPort2R get ();
    void set (Lm49352TypeDacInputPort2R value);
}
member DACInputPORT2R : Lm49352TypeDacInputPort2R with get, set

Property Value

Type: Lm49352TypeDacInputPort2R
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACInputSWAP Property

IRD

Lm49352DACInputSWAP Property

DAC Input: SWAP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeDacInputSwap DACInputSWAP { get; set; }
Public Property DACInputSWAP As Lm49352TypeDacInputSwap
    Get
    Set
public:
property Lm49352TypeDacInputSwap DACInputSWAP {
    Lm49352TypeDacInputSwap get ();
    void set (Lm49352TypeDacInputSwap value);
}
member DACInputSWAP : Lm49352TypeDacInputSwap with get, set

Property Value

Type: Lm49352TypeDacInputSwap
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACLLevelDACLLEVEL Property

IRD

Lm49352DACLLevelDACLLEVEL Property

DAC L Level: DAC_L_LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DACLLevelDACLLEVEL { get; set; }
Public Property DACLLevelDACLLEVEL As Double
    Get
    Set
public:
property double DACLLevelDACLLEVEL {
    double get ();
    void set (double value);
}
member DACLLevelDACLLEVEL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACLVLMonLLVLMONL Property

IRD

Lm49352DACLVLMonLLVLMONL Property

DAC LVL Mon L: LVLMONL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACLVLMonLLVLMONL { get; set; }
Public Property DACLVLMonLLVLMONL As Byte
    Get
    Set
public:
property unsigned char DACLVLMonLLVLMONL {
    unsigned char get ();
    void set (unsigned char value);
}
member DACLVLMonLLVLMONL : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACLVLMonRLVLMONR Property

IRD

Lm49352DACLVLMonRLVLMONR Property

DAC LVL Mon R: LVLMONR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DACLVLMonRLVLMONR { get; set; }
Public Property DACLVLMonRLVLMONR As Byte
    Get
    Set
public:
property unsigned char DACLVLMonRLVLMONR {
    unsigned char get ();
    void set (unsigned char value);
}
member DACLVLMonRLVLMONR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACRLevelDACRLEVEL Property

IRD

Lm49352DACRLevelDACRLEVEL Property

DAC R Level: DAC_R_LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DACRLevelDACRLEVEL { get; set; }
Public Property DACRLevelDACRLEVEL As Double
    Get
    Set
public:
property double DACRLevelDACRLEVEL {
    double get ();
    void set (double value);
}
member DACRLevelDACRLEVEL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACSoftclip1SOFTKNEE Property

IRD

Lm49352DACSoftclip1SOFTKNEE Property

DAC Softclip1: SOFT_KNEE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcSoftclip1Knee DACSoftclip1SOFTKNEE { get; set; }
Public Property DACSoftclip1SOFTKNEE As Lm49352TypeAdcSoftclip1Knee
    Get
    Set
public:
property Lm49352TypeAdcSoftclip1Knee DACSoftclip1SOFTKNEE {
    Lm49352TypeAdcSoftclip1Knee get ();
    void set (Lm49352TypeAdcSoftclip1Knee value);
}
member DACSoftclip1SOFTKNEE : Lm49352TypeAdcSoftclip1Knee with get, set

Property Value

Type: Lm49352TypeAdcSoftclip1Knee
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACSoftclip1THRESHOLD Property

IRD

Lm49352DACSoftclip1THRESHOLD Property

DAC Softclip1: THRESHOLD (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcSoftclip1Threshold DACSoftclip1THRESHOLD { get; set; }
Public Property DACSoftclip1THRESHOLD As Lm49352TypeAdcSoftclip1Threshold
    Get
    Set
public:
property Lm49352TypeAdcSoftclip1Threshold DACSoftclip1THRESHOLD {
    Lm49352TypeAdcSoftclip1Threshold get ();
    void set (Lm49352TypeAdcSoftclip1Threshold value);
}
member DACSoftclip1THRESHOLD : Lm49352TypeAdcSoftclip1Threshold with get, set

Property Value

Type: Lm49352TypeAdcSoftclip1Threshold
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACSoftclip2RATIO Property

IRD

Lm49352DACSoftclip2RATIO Property

DAC Softclip2: RATIO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeAdcSoftclip2ClipRatio DACSoftclip2RATIO { get; set; }
Public Property DACSoftclip2RATIO As Lm49352TypeAdcSoftclip2ClipRatio
    Get
    Set
public:
property Lm49352TypeAdcSoftclip2ClipRatio DACSoftclip2RATIO {
    Lm49352TypeAdcSoftclip2ClipRatio get ();
    void set (Lm49352TypeAdcSoftclip2ClipRatio value);
}
member DACSoftclip2RATIO : Lm49352TypeAdcSoftclip2ClipRatio with get, set

Property Value

Type: Lm49352TypeAdcSoftclip2ClipRatio
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DACSoftclip3LEVEL Property

IRD

Lm49352DACSoftclip3LEVEL Property

DAC Softclip3: LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DACSoftclip3LEVEL { get; set; }
Public Property DACSoftclip3LEVEL As Double
    Get
    Set
public:
property double DACSoftclip3LEVEL {
    double get ();
    void set (double value);
}
member DACSoftclip3LEVEL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DecimatorInputLSEL Property

IRD

Lm49352DecimatorInputLSEL Property

Decimator Input: L_SEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeDecimatorInputLSel DecimatorInputLSEL { get; set; }
Public Property DecimatorInputLSEL As Lm49352TypeDecimatorInputLSel
    Get
    Set
public:
property Lm49352TypeDecimatorInputLSel DecimatorInputLSEL {
    Lm49352TypeDecimatorInputLSel get ();
    void set (Lm49352TypeDecimatorInputLSel value);
}
member DecimatorInputLSEL : Lm49352TypeDecimatorInputLSel with get, set

Property Value

Type: Lm49352TypeDecimatorInputLSel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DecimatorInputMXRCLKSEL Property

IRD

Lm49352DecimatorInputMXRCLKSEL Property

Decimator Input: MXR_CLK_SEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeDecimatorInputMxrClk DecimatorInputMXRCLKSEL { get; set; }
Public Property DecimatorInputMXRCLKSEL As Lm49352TypeDecimatorInputMxrClk
    Get
    Set
public:
property Lm49352TypeDecimatorInputMxrClk DecimatorInputMXRCLKSEL {
    Lm49352TypeDecimatorInputMxrClk get ();
    void set (Lm49352TypeDecimatorInputMxrClk value);
}
member DecimatorInputMXRCLKSEL : Lm49352TypeDecimatorInputMxrClk with get, set

Property Value

Type: Lm49352TypeDecimatorInputMxrClk
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.DecimatorInputRSEL Property

IRD

Lm49352DecimatorInputRSEL Property

Decimator Input: R_SEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeDecimatorInputRSel DecimatorInputRSEL { get; set; }
Public Property DecimatorInputRSEL As Lm49352TypeDecimatorInputRSel
    Get
    Set
public:
property Lm49352TypeDecimatorInputRSel DecimatorInputRSEL {
    Lm49352TypeDecimatorInputRSel get ();
    void set (Lm49352TypeDecimatorInputRSel value);
}
member DecimatorInputRSEL : Lm49352TypeDecimatorInputRSel with get, set

Property Value

Type: Lm49352TypeDecimatorInputRSel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ForceCPFORCE Property

IRD

Lm49352ForceCPFORCE Property

Force: CP_FORCE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeForceCp ForceCPFORCE { get; set; }
Public Property ForceCPFORCE As Lm49352TypeForceCp
    Get
    Set
public:
property Lm49352TypeForceCp ForceCPFORCE {
    Lm49352TypeForceCp get ();
    void set (Lm49352TypeForceCp value);
}
member ForceCPFORCE : Lm49352TypeForceCp with get, set

Property Value

Type: Lm49352TypeForceCp
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ForceDACREF Property

IRD

Lm49352ForceDACREF Property

Force: DACREF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeForceDac ForceDACREF { get; set; }
Public Property ForceDACREF As Lm49352TypeForceDac
    Get
    Set
public:
property Lm49352TypeForceDac ForceDACREF {
    Lm49352TypeForceDac get ();
    void set (Lm49352TypeForceDac value);
}
member ForceDACREF : Lm49352TypeForceDac with get, set

Property Value

Type: Lm49352TypeForceDac
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.GPIO1GPIOMODE Property

IRD

Lm49352GPIO1GPIOMODE Property

GPIO1: GPIO_MODE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeGpio1Mode GPIO1GPIOMODE { get; set; }
Public Property GPIO1GPIOMODE As Lm49352TypeGpio1Mode
    Get
    Set
public:
property Lm49352TypeGpio1Mode GPIO1GPIOMODE {
    Lm49352TypeGpio1Mode get ();
    void set (Lm49352TypeGpio1Mode value);
}
member GPIO1GPIOMODE : Lm49352TypeGpio1Mode with get, set

Property Value

Type: Lm49352TypeGpio1Mode
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.GPIO1GPIORX Property

IRD

Lm49352GPIO1GPIORX Property

GPIO1: GPIO_RX

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeGpio1Rx GPIO1GPIORX { get; set; }
Public Property GPIO1GPIORX As Lm49352TypeGpio1Rx
    Get
    Set
public:
property Lm49352TypeGpio1Rx GPIO1GPIORX {
    Lm49352TypeGpio1Rx get ();
    void set (Lm49352TypeGpio1Rx value);
}
member GPIO1GPIORX : Lm49352TypeGpio1Rx with get, set

Property Value

Type: Lm49352TypeGpio1Rx
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.GPIO1GPIOTX Property

IRD

Lm49352GPIO1GPIOTX Property

GPIO1: GPIO_TX

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeGpio1Tx GPIO1GPIOTX { get; set; }
Public Property GPIO1GPIOTX As Lm49352TypeGpio1Tx
    Get
    Set
public:
property Lm49352TypeGpio1Tx GPIO1GPIOTX {
    Lm49352TypeGpio1Tx get ();
    void set (Lm49352TypeGpio1Tx value);
}
member GPIO1GPIOTX : Lm49352TypeGpio1Tx with get, set

Property Value

Type: Lm49352TypeGpio1Tx
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.GPIO2SHORT Property

IRD

Lm49352GPIO2SHORT Property

GPIO2: SHORT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeGpio2Short GPIO2SHORT { get; set; }
Public Property GPIO2SHORT As Lm49352TypeGpio2Short
    Get
    Set
public:
property Lm49352TypeGpio2Short GPIO2SHORT {
    Lm49352TypeGpio2Short get ();
    void set (Lm49352TypeGpio2Short value);
}
member GPIO2SHORT : Lm49352TypeGpio2Short with get, set

Property Value

Type: Lm49352TypeGpio2Short
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.GPIO2TEMP Property

IRD

Lm49352GPIO2TEMP Property

GPIO2: TEMP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeGpio2Temp GPIO2TEMP { get; set; }
Public Property GPIO2TEMP As Lm49352TypeGpio2Temp
    Get
    Set
public:
property Lm49352TypeGpio2Temp GPIO2TEMP {
    Lm49352TypeGpio2Temp get ();
    void set (Lm49352TypeGpio2Temp value);
}
member GPIO2TEMP : Lm49352TypeGpio2Temp with get, set

Property Value

Type: Lm49352TypeGpio2Temp
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.HeadphonesLAUXHPL Property

IRD

Lm49352HeadphonesLAUXHPL Property

Headphones L: AUX_HPL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeHeadphonesLAux HeadphonesLAUXHPL { get; set; }
Public Property HeadphonesLAUXHPL As Lm49352TypeHeadphonesLAux
    Get
    Set
public:
property Lm49352TypeHeadphonesLAux HeadphonesLAUXHPL {
    Lm49352TypeHeadphonesLAux get ();
    void set (Lm49352TypeHeadphonesLAux value);
}
member HeadphonesLAUXHPL : Lm49352TypeHeadphonesLAux with get, set

Property Value

Type: Lm49352TypeHeadphonesLAux
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.HeadphonesLDACLHPL Property

IRD

Lm49352HeadphonesLDACLHPL Property

Headphones L: DACL_HPL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeHeadphonesLDacl HeadphonesLDACLHPL { get; set; }
Public Property HeadphonesLDACLHPL As Lm49352TypeHeadphonesLDacl
    Get
    Set
public:
property Lm49352TypeHeadphonesLDacl HeadphonesLDACLHPL {
    Lm49352TypeHeadphonesLDacl get ();
    void set (Lm49352TypeHeadphonesLDacl value);
}
member HeadphonesLDACLHPL : Lm49352TypeHeadphonesLDacl with get, set

Property Value

Type: Lm49352TypeHeadphonesLDacl
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.HeadphonesLDACRHPL Property

IRD

Lm49352HeadphonesLDACRHPL Property

Headphones L: DACR_HPL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeHeadphonesLDacr HeadphonesLDACRHPL { get; set; }
Public Property HeadphonesLDACRHPL As Lm49352TypeHeadphonesLDacr
    Get
    Set
public:
property Lm49352TypeHeadphonesLDacr HeadphonesLDACRHPL {
    Lm49352TypeHeadphonesLDacr get ();
    void set (Lm49352TypeHeadphonesLDacr value);
}
member HeadphonesLDACRHPL : Lm49352TypeHeadphonesLDacr with get, set

Property Value

Type: Lm49352TypeHeadphonesLDacr
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.HeadphonesLMONOHPL Property

IRD

Lm49352HeadphonesLMONOHPL Property

Headphones L: MONO_HPL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeHeadphonesLMono HeadphonesLMONOHPL { get; set; }
Public Property HeadphonesLMONOHPL As Lm49352TypeHeadphonesLMono
    Get
    Set
public:
property Lm49352TypeHeadphonesLMono HeadphonesLMONOHPL {
    Lm49352TypeHeadphonesLMono get ();
    void set (Lm49352TypeHeadphonesLMono value);
}
member HeadphonesLMONOHPL : Lm49352TypeHeadphonesLMono with get, set

Property Value

Type: Lm49352TypeHeadphonesLMono
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.HeadphonesRAUXHPR Property

IRD

Lm49352HeadphonesRAUXHPR Property

Headphones R: AUX_HPR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeHeadphonesRAux HeadphonesRAUXHPR { get; set; }
Public Property HeadphonesRAUXHPR As Lm49352TypeHeadphonesRAux
    Get
    Set
public:
property Lm49352TypeHeadphonesRAux HeadphonesRAUXHPR {
    Lm49352TypeHeadphonesRAux get ();
    void set (Lm49352TypeHeadphonesRAux value);
}
member HeadphonesRAUXHPR : Lm49352TypeHeadphonesRAux with get, set

Property Value

Type: Lm49352TypeHeadphonesRAux
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.HeadphonesRDACLHPR Property

IRD

Lm49352HeadphonesRDACLHPR Property

Headphones R: DACL_HPR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeHeadphonesRDacl HeadphonesRDACLHPR { get; set; }
Public Property HeadphonesRDACLHPR As Lm49352TypeHeadphonesRDacl
    Get
    Set
public:
property Lm49352TypeHeadphonesRDacl HeadphonesRDACLHPR {
    Lm49352TypeHeadphonesRDacl get ();
    void set (Lm49352TypeHeadphonesRDacl value);
}
member HeadphonesRDACLHPR : Lm49352TypeHeadphonesRDacl with get, set

Property Value

Type: Lm49352TypeHeadphonesRDacl
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.HeadphonesRDACRHPR Property

IRD

Lm49352HeadphonesRDACRHPR Property

Headphones R: DACR_HPR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeHeadphonesRDacr HeadphonesRDACRHPR { get; set; }
Public Property HeadphonesRDACRHPR As Lm49352TypeHeadphonesRDacr
    Get
    Set
public:
property Lm49352TypeHeadphonesRDacr HeadphonesRDACRHPR {
    Lm49352TypeHeadphonesRDacr get ();
    void set (Lm49352TypeHeadphonesRDacr value);
}
member HeadphonesRDACRHPR : Lm49352TypeHeadphonesRDacr with get, set

Property Value

Type: Lm49352TypeHeadphonesRDacr
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.HeadphonesRMONOHPR Property

IRD

Lm49352HeadphonesRMONOHPR Property

Headphones R: MONO_HPR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeHeadphonesRMono HeadphonesRMONOHPR { get; set; }
Public Property HeadphonesRMONOHPR As Lm49352TypeHeadphonesRMono
    Get
    Set
public:
property Lm49352TypeHeadphonesRMono HeadphonesRMONOHPR {
    Lm49352TypeHeadphonesRMono get ();
    void set (Lm49352TypeHeadphonesRMono value);
}
member HeadphonesRMONOHPR : Lm49352TypeHeadphonesRMono with get, set

Property Value

Type: Lm49352TypeHeadphonesRMono
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.HPFModeHPFMODE Property

IRD

Lm49352HPFModeHPFMODE Property

HPF Mode: HPF_MODE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeHpfMode HPFModeHPFMODE { get; set; }
Public Property HPFModeHPFMODE As Lm49352TypeHpfMode
    Get
    Set
public:
property Lm49352TypeHpfMode HPFModeHPFMODE {
    Lm49352TypeHpfMode get ();
    void set (Lm49352TypeHpfMode value);
}
member HPFModeHPFMODE : Lm49352TypeHpfMode with get, set

Property Value

Type: Lm49352TypeHpfMode
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.HPSenseHPSENSE Property

IRD

Lm49352HPSenseHPSENSE Property

HP Sense: HP SENSE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeHpSenseGeneral HPSenseHPSENSE { get; set; }
Public Property HPSenseHPSENSE As Lm49352TypeHpSenseGeneral
    Get
    Set
public:
property Lm49352TypeHpSenseGeneral HPSenseHPSENSE {
    Lm49352TypeHpSenseGeneral get ();
    void set (Lm49352TypeHpSenseGeneral value);
}
member HPSenseHPSENSE : Lm49352TypeHpSenseGeneral with get, set

Property Value

Type: Lm49352TypeHpSenseGeneral
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.HPSenseHPSENSEAUX Property

IRD

Lm49352HPSenseHPSENSEAUX Property

HP Sense: HPSENSE_AUX

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeHpSenseAux HPSenseHPSENSEAUX { get; set; }
Public Property HPSenseHPSENSEAUX As Lm49352TypeHpSenseAux
    Get
    Set
public:
property Lm49352TypeHpSenseAux HPSenseHPSENSEAUX {
    Lm49352TypeHpSenseAux get ();
    void set (Lm49352TypeHpSenseAux value);
}
member HPSenseHPSENSEAUX : Lm49352TypeHpSenseAux with get, set

Property Value

Type: Lm49352TypeHpSenseAux
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.HPSenseHPSENSEAUXD Property

IRD

Lm49352HPSenseHPSENSEAUXD Property

HP Sense: HPSENSE_AUX_D

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeHpSenseAuxD HPSenseHPSENSEAUXD { get; set; }
Public Property HPSenseHPSENSEAUXD As Lm49352TypeHpSenseAuxD
    Get
    Set
public:
property Lm49352TypeHpSenseAuxD HPSenseHPSENSEAUXD {
    Lm49352TypeHpSenseAuxD get ();
    void set (Lm49352TypeHpSenseAuxD value);
}
member HPSenseHPSENSEAUXD : Lm49352TypeHpSenseAuxD with get, set

Property Value

Type: Lm49352TypeHpSenseAuxD
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.HPSenseHPSENSED Property

IRD

Lm49352HPSenseHPSENSED Property

HP Sense: HPSENSE_D

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeHpSenseClassD HPSenseHPSENSED { get; set; }
Public Property HPSenseHPSENSED As Lm49352TypeHpSenseClassD
    Get
    Set
public:
property Lm49352TypeHpSenseClassD HPSenseHPSENSED {
    Lm49352TypeHpSenseClassD get ();
    void set (Lm49352TypeHpSenseClassD value);
}
member HPSenseHPSENSED : Lm49352TypeHpSenseClassD with get, set

Property Value

Type: Lm49352TypeHpSenseClassD
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.InputLevel1PORT1RXLLVL Property

IRD

Lm49352InputLevel1PORT1RXLLVL Property

Input Level1: PORT1_RX_L_LVL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double InputLevel1PORT1RXLLVL { get; set; }
Public Property InputLevel1PORT1RXLLVL As Double
    Get
    Set
public:
property double InputLevel1PORT1RXLLVL {
    double get ();
    void set (double value);
}
member InputLevel1PORT1RXLLVL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.InputLevel1PORT1RXRLVL Property

IRD

Lm49352InputLevel1PORT1RXRLVL Property

Input Level1: PORT1_RX_R_LVL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double InputLevel1PORT1RXRLVL { get; set; }
Public Property InputLevel1PORT1RXRLVL As Double
    Get
    Set
public:
property double InputLevel1PORT1RXRLVL {
    double get ();
    void set (double value);
}
member InputLevel1PORT1RXRLVL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.InputLevel1PORT2RXLLVL Property

IRD

Lm49352InputLevel1PORT2RXLLVL Property

Input Level1: PORT2_RX_L_LVL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double InputLevel1PORT2RXLLVL { get; set; }
Public Property InputLevel1PORT2RXLLVL As Double
    Get
    Set
public:
property double InputLevel1PORT2RXLLVL {
    double get ();
    void set (double value);
}
member InputLevel1PORT2RXLLVL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.InputLevel1PORT2RXRLVL Property

IRD

Lm49352InputLevel1PORT2RXRLVL Property

Input Level1: PORT2_RX_R_LVL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double InputLevel1PORT2RXRLVL { get; set; }
Public Property InputLevel1PORT2RXRLVL As Double
    Get
    Set
public:
property double InputLevel1PORT2RXRLVL {
    double get ();
    void set (double value);
}
member InputLevel1PORT2RXRLVL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.InputLevel2ADCLLVL Property

IRD

Lm49352InputLevel2ADCLLVL Property

Input Level2: ADC_L_LVL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double InputLevel2ADCLLVL { get; set; }
Public Property InputLevel2ADCLLVL As Double
    Get
    Set
public:
property double InputLevel2ADCLLVL {
    double get ();
    void set (double value);
}
member InputLevel2ADCLLVL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.InputLevel2ADCRLVL Property

IRD

Lm49352InputLevel2ADCRLVL Property

Input Level2: ADC_R_LVL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double InputLevel2ADCRLVL { get; set; }
Public Property InputLevel2ADCRLVL As Double
    Get
    Set
public:
property double InputLevel2ADCRLVL {
    double get ();
    void set (double value);
}
member InputLevel2ADCRLVL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.InputLevel2INTERPLLVL Property

IRD

Lm49352InputLevel2INTERPLLVL Property

Input Level2: INTERP_L_LVL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double InputLevel2INTERPLLVL { get; set; }
Public Property InputLevel2INTERPLLVL As Double
    Get
    Set
public:
property double InputLevel2INTERPLLVL {
    double get ();
    void set (double value);
}
member InputLevel2INTERPLLVL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.InputLevel2INTERPRLVL Property

IRD

Lm49352InputLevel2INTERPRLVL Property

Input Level2: INTERP_R_LVL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double InputLevel2INTERPRLVL { get; set; }
Public Property InputLevel2INTERPRLVL As Double
    Get
    Set
public:
property double InputLevel2INTERPRLVL {
    double get ();
    void set (double value);
}
member InputLevel2INTERPRLVL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.MICInputMICLEVEL Property

IRD

Lm49352MICInputMICLEVEL Property

MIC Input: MIC_LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MICInputMICLEVEL { get; set; }
Public Property MICInputMICLEVEL As Double
    Get
    Set
public:
property double MICInputMICLEVEL {
    double get ();
    void set (double value);
}
member MICInputMICLEVEL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.MICInputMUTE Property

IRD

Lm49352MICInputMUTE Property

MIC Input: MUTE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeMicInputMute MICInputMUTE { get; set; }
Public Property MICInputMUTE As Lm49352TypeMicInputMute
    Get
    Set
public:
property Lm49352TypeMicInputMute MICInputMUTE {
    Lm49352TypeMicInputMute get ();
    void set (Lm49352TypeMicInputMute value);
}
member MICInputMUTE : Lm49352TypeMicInputMute with get, set

Property Value

Type: Lm49352TypeMicInputMute
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.MICInputSEDIFF Property

IRD

Lm49352MICInputSEDIFF Property

MIC Input: SE_DIFF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeMicInputSediff MICInputSEDIFF { get; set; }
Public Property MICInputSEDIFF As Lm49352TypeMicInputSediff
    Get
    Set
public:
property Lm49352TypeMicInputSediff MICInputSEDIFF {
    Lm49352TypeMicInputSediff get ();
    void set (Lm49352TypeMicInputSediff value);
}
member MICInputSEDIFF : Lm49352TypeMicInputSediff with get, set

Property Value

Type: Lm49352TypeMicInputSediff
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.MonoLevelAUXLMONO Property

IRD

Lm49352MonoLevelAUXLMONO Property

Mono Level: AUXL_MONO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeMonoLevelMono MonoLevelAUXLMONO { get; set; }
Public Property MonoLevelAUXLMONO As Lm49352TypeMonoLevelMono
    Get
    Set
public:
property Lm49352TypeMonoLevelMono MonoLevelAUXLMONO {
    Lm49352TypeMonoLevelMono get ();
    void set (Lm49352TypeMonoLevelMono value);
}
member MonoLevelAUXLMONO : Lm49352TypeMonoLevelMono with get, set

Property Value

Type: Lm49352TypeMonoLevelMono
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.MonoLevelMONOLEVEL Property

IRD

Lm49352MonoLevelMONOLEVEL Property

Mono Level: MONO_LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double MonoLevelMONOLEVEL { get; set; }
Public Property MonoLevelMONOLEVEL As Double
    Get
    Set
public:
property double MonoLevelMONOLEVEL {
    double get ();
    void set (double value);
}
member MonoLevelMONOLEVEL : float with get, set

Property Value

Type: Double
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.MonoLevelSEDIFF Property

IRD

Lm49352MonoLevelSEDIFF Property

Mono Level: SE/DIFF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeMonoLevelSediff MonoLevelSEDIFF { get; set; }
Public Property MonoLevelSEDIFF As Lm49352TypeMonoLevelSediff
    Get
    Set
public:
property Lm49352TypeMonoLevelSediff MonoLevelSEDIFF {
    Lm49352TypeMonoLevelSediff get ();
    void set (Lm49352TypeMonoLevelSediff value);
}
member MonoLevelSEDIFF : Lm49352TypeMonoLevelSediff with get, set

Property Value

Type: Lm49352TypeMonoLevelSediff
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.OutputOptionsAUXLINEOUT Property

IRD

Lm49352OutputOptionsAUXLINEOUT Property

Output Options: AUX_LINE_OUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeOutputOptionsAuxLine OutputOptionsAUXLINEOUT { get; set; }
Public Property OutputOptionsAUXLINEOUT As Lm49352TypeOutputOptionsAuxLine
    Get
    Set
public:
property Lm49352TypeOutputOptionsAuxLine OutputOptionsAUXLINEOUT {
    Lm49352TypeOutputOptionsAuxLine get ();
    void set (Lm49352TypeOutputOptionsAuxLine value);
}
member OutputOptionsAUXLINEOUT : Lm49352TypeOutputOptionsAuxLine with get, set

Property Value

Type: Lm49352TypeOutputOptionsAuxLine
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.OutputOptionsAUXNEG6dB Property

IRD

Lm49352OutputOptionsAUXNEG6dB Property

Output Options: AUX_NEG_6dB (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeOutputOptionsAuxNeg OutputOptionsAUXNEG6dB { get; set; }
Public Property OutputOptionsAUXNEG6dB As Lm49352TypeOutputOptionsAuxNeg
    Get
    Set
public:
property Lm49352TypeOutputOptionsAuxNeg OutputOptionsAUXNEG6dB {
    Lm49352TypeOutputOptionsAuxNeg get ();
    void set (Lm49352TypeOutputOptionsAuxNeg value);
}
member OutputOptionsAUXNEG6dB : Lm49352TypeOutputOptionsAuxNeg with get, set

Property Value

Type: Lm49352TypeOutputOptionsAuxNeg
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.OutputOptionsLRHPLEVEL Property

IRD

Lm49352OutputOptionsLRHPLEVEL Property

Output Options: LR_HP_LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeOutputOptionsHpLevel OutputOptionsLRHPLEVEL { get; set; }
Public Property OutputOptionsLRHPLEVEL As Lm49352TypeOutputOptionsHpLevel
    Get
    Set
public:
property Lm49352TypeOutputOptionsHpLevel OutputOptionsLRHPLEVEL {
    Lm49352TypeOutputOptionsHpLevel get ();
    void set (Lm49352TypeOutputOptionsHpLevel value);
}
member OutputOptionsLRHPLEVEL : Lm49352TypeOutputOptionsHpLevel with get, set

Property Value

Type: Lm49352TypeOutputOptionsHpLevel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.OutputOptionsLSLEVEL Property

IRD

Lm49352OutputOptionsLSLEVEL Property

Output Options: LS_LEVEL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeOutputOptionsLsLevel OutputOptionsLSLEVEL { get; set; }
Public Property OutputOptionsLSLEVEL As Lm49352TypeOutputOptionsLsLevel
    Get
    Set
public:
property Lm49352TypeOutputOptionsLsLevel OutputOptionsLSLEVEL {
    Lm49352TypeOutputOptionsLsLevel get ();
    void set (Lm49352TypeOutputOptionsLsLevel value);
}
member OutputOptionsLSLEVEL : Lm49352TypeOutputOptionsLsLevel with get, set

Property Value

Type: Lm49352TypeOutputOptionsLsLevel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.PLLCLKSelPLLCLKSEL Property

IRD

Lm49352PLLCLKSelPLLCLKSEL Property

PLL CLK Sel: PLL_CLK_SEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypePllClkSel PLLCLKSelPLLCLKSEL { get; set; }
Public Property PLLCLKSelPLLCLKSEL As Lm49352TypePllClkSel
    Get
    Set
public:
property Lm49352TypePllClkSel PLLCLKSelPLLCLKSEL {
    Lm49352TypePllClkSel get ();
    void set (Lm49352TypePllClkSel value);
}
member PLLCLKSelPLLCLKSEL : Lm49352TypePllClkSel with get, set

Property Value

Type: Lm49352TypePllClkSel
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.PLLMPLLM Property

IRD

Lm49352PLLMPLLM Property

PLL M: PLL_M

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypePllM PLLMPLLM { get; set; }
Public Property PLLMPLLM As Lm49352TypePllM
    Get
    Set
public:
property Lm49352TypePllM PLLMPLLM {
    Lm49352TypePllM get ();
    void set (Lm49352TypePllM value);
}
member PLLMPLLM : Lm49352TypePllM with get, set

Property Value

Type: Lm49352TypePllM
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.PLLNModPLLNMOD Property

IRD

Lm49352PLLNModPLLNMOD Property

PLL N Mod: PLL_N_MOD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypePllNMod PLLNModPLLNMOD { get; set; }
Public Property PLLNModPLLNMOD As Lm49352TypePllNMod
    Get
    Set
public:
property Lm49352TypePllNMod PLLNModPLLNMOD {
    Lm49352TypePllNMod get ();
    void set (Lm49352TypePllNMod value);
}
member PLLNModPLLNMOD : Lm49352TypePllNMod with get, set

Property Value

Type: Lm49352TypePllNMod
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.PLLNPLLN Property

IRD

Lm49352PLLNPLLN Property

PLL N: PLL_N

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypePllN PLLNPLLN { get; set; }
Public Property PLLNPLLN As Lm49352TypePllN
    Get
    Set
public:
property Lm49352TypePllN PLLNPLLN {
    Lm49352TypePllN get ();
    void set (Lm49352TypePllN value);
}
member PLLNPLLN : Lm49352TypePllN with get, set

Property Value

Type: Lm49352TypePllN
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.PLLP2PLLP2 Property

IRD

Lm49352PLLP2PLLP2 Property

PLL P2: PLL_P2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypePllP PLLP2PLLP2 { get; set; }
Public Property PLLP2PLLP2 As Lm49352TypePllP
    Get
    Set
public:
property Lm49352TypePllP PLLP2PLLP2 {
    Lm49352TypePllP get ();
    void set (Lm49352TypePllP value);
}
member PLLP2PLLP2 : Lm49352TypePllP with get, set

Property Value

Type: Lm49352TypePllP
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.PLLPPLLP1 Property

IRD

Lm49352PLLPPLLP1 Property

PLL P: PLL_P1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypePllP PLLPPLLP1 { get; set; }
Public Property PLLPPLLP1 As Lm49352TypePllP
    Get
    Set
public:
property Lm49352TypePllP PLLPPLLP1 {
    Lm49352TypePllP get ();
    void set (Lm49352TypePllP value);
}
member PLLPPLLP1 : Lm49352TypePllP with get, set

Property Value

Type: Lm49352TypePllP
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.PMCCLKDivPMCCLKDIV Property

IRD

Lm49352PMCCLKDivPMCCLKDIV Property

PMC CLK Div: PMC_CLK_DIV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypePmcClkDiv PMCCLKDivPMCCLKDIV { get; set; }
Public Property PMCCLKDivPMCCLKDIV As Lm49352TypePmcClkDiv
    Get
    Set
public:
property Lm49352TypePmcClkDiv PMCCLKDivPMCCLKDIV {
    Lm49352TypePmcClkDiv get ();
    void set (Lm49352TypePmcClkDiv value);
}
member PMCCLKDivPMCCLKDIV : Lm49352TypePmcClkDiv with get, set

Property Value

Type: Lm49352TypePmcClkDiv
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.PMCClocksPMCCLKSEL Property

IRD

Lm49352PMCClocksPMCCLKSEL Property

PMC Clocks: PMC_CLK_SEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypePmcClocks PMCClocksPMCCLKSEL { get; set; }
Public Property PMCClocksPMCCLKSEL As Lm49352TypePmcClocks
    Get
    Set
public:
property Lm49352TypePmcClocks PMCClocksPMCCLKSEL {
    Lm49352TypePmcClocks get ();
    void set (Lm49352TypePmcClocks value);
}
member PMCClocksPMCCLKSEL : Lm49352TypePmcClocks with get, set

Property Value

Type: Lm49352TypePmcClocks
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.PMCSetupCHIPACTIVE Property

IRD

Lm49352PMCSetupCHIPACTIVE Property

PMC Setup: CHIP_ACTIVE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypePmcSetupChipActive PMCSetupCHIPACTIVE { get; }
Public ReadOnly Property PMCSetupCHIPACTIVE As Lm49352TypePmcSetupChipActive
    Get
public:
property Lm49352TypePmcSetupChipActive PMCSetupCHIPACTIVE {
    Lm49352TypePmcSetupChipActive get ();
}
member PMCSetupCHIPACTIVE : Lm49352TypePmcSetupChipActive with get

Property Value

Type: Lm49352TypePmcSetupChipActive
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.PMCSetupCHIPENABLE Property

IRD

Lm49352PMCSetupCHIPENABLE Property

PMC Setup: CHIP_ENABLE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypePmcSetupChipEnable PMCSetupCHIPENABLE { get; set; }
Public Property PMCSetupCHIPENABLE As Lm49352TypePmcSetupChipEnable
    Get
    Set
public:
property Lm49352TypePmcSetupChipEnable PMCSetupCHIPENABLE {
    Lm49352TypePmcSetupChipEnable get ();
    void set (Lm49352TypePmcSetupChipEnable value);
}
member PMCSetupCHIPENABLE : Lm49352TypePmcSetupChipEnable with get, set

Property Value

Type: Lm49352TypePmcSetupChipEnable
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.PMCSetupMCLKOVR Property

IRD

Lm49352PMCSetupMCLKOVR Property

PMC Setup: MCLK_OVR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypePmcSetupMclkOvr PMCSetupMCLKOVR { get; set; }
Public Property PMCSetupMCLKOVR As Lm49352TypePmcSetupMclkOvr
    Get
    Set
public:
property Lm49352TypePmcSetupMclkOvr PMCSetupMCLKOVR {
    Lm49352TypePmcSetupMclkOvr get ();
    void set (Lm49352TypePmcSetupMclkOvr value);
}
member PMCSetupMCLKOVR : Lm49352TypePmcSetupMclkOvr with get, set

Property Value

Type: Lm49352TypePmcSetupMclkOvr
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.PMCSetupOSCENB Property

IRD

Lm49352PMCSetupOSCENB Property

PMC Setup: OSC_ENB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypePmcSetupOscEnb PMCSetupOSCENB { get; set; }
Public Property PMCSetupOSCENB As Lm49352TypePmcSetupOscEnb
    Get
    Set
public:
property Lm49352TypePmcSetupOscEnb PMCSetupOSCENB {
    Lm49352TypePmcSetupOscEnb get ();
    void set (Lm49352TypePmcSetupOscEnb value);
}
member PMCSetupOSCENB : Lm49352TypePmcSetupOscEnb with get, set

Property Value

Type: Lm49352TypePmcSetupOscEnb
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.PMCSetupPLLENB Property

IRD

Lm49352PMCSetupPLLENB Property

PMC Setup: PLL_ENB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypePmcSetupPll PMCSetupPLLENB { get; set; }
Public Property PMCSetupPLLENB As Lm49352TypePmcSetupPll
    Get
    Set
public:
property Lm49352TypePmcSetupPll PMCSetupPLLENB {
    Lm49352TypePmcSetupPll get ();
    void set (Lm49352TypePmcSetupPll value);
}
member PMCSetupPLLENB : Lm49352TypePmcSetupPll with get, set

Property Value

Type: Lm49352TypePmcSetupPll
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.PMCSetupPLLP2ENB Property

IRD

Lm49352PMCSetupPLLP2ENB Property

PMC Setup: PLL_P2ENB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypePmcSetupPllP2enb PMCSetupPLLP2ENB { get; set; }
Public Property PMCSetupPLLP2ENB As Lm49352TypePmcSetupPllP2enb
    Get
    Set
public:
property Lm49352TypePmcSetupPllP2enb PMCSetupPLLP2ENB {
    Lm49352TypePmcSetupPllP2enb get ();
    void set (Lm49352TypePmcSetupPllP2enb value);
}
member PMCSetupPLLP2ENB : Lm49352TypePmcSetupPllP2enb with get, set

Property Value

Type: Lm49352TypePmcSetupPllP2enb
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.PMCSetupPORT1CLKOVR Property

IRD

Lm49352PMCSetupPORT1CLKOVR Property

PMC Setup: PORT1_CLK_OVR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypePmcSetupPortClkOvr PMCSetupPORT1CLKOVR { get; set; }
Public Property PMCSetupPORT1CLKOVR As Lm49352TypePmcSetupPortClkOvr
    Get
    Set
public:
property Lm49352TypePmcSetupPortClkOvr PMCSetupPORT1CLKOVR {
    Lm49352TypePmcSetupPortClkOvr get ();
    void set (Lm49352TypePmcSetupPortClkOvr value);
}
member PMCSetupPORT1CLKOVR : Lm49352TypePmcSetupPortClkOvr with get, set

Property Value

Type: Lm49352TypePmcSetupPortClkOvr
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.PMCSetupPORT2CLKOVR Property

IRD

Lm49352PMCSetupPORT2CLKOVR Property

PMC Setup: PORT2_CLK_OVR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypePmcSetupPortClkOvr PMCSetupPORT2CLKOVR { get; set; }
Public Property PMCSetupPORT2CLKOVR As Lm49352TypePmcSetupPortClkOvr
    Get
    Set
public:
property Lm49352TypePmcSetupPortClkOvr PMCSetupPORT2CLKOVR {
    Lm49352TypePmcSetupPortClkOvr get ();
    void set (Lm49352TypePmcSetupPortClkOvr value);
}
member PMCSetupPORT2CLKOVR : Lm49352TypePmcSetupPortClkOvr with get, set

Property Value

Type: Lm49352TypePmcSetupPortClkOvr
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.ResetSOFTRESET Property

IRD

Lm49352ResetSOFTRESET Property

Reset: SOFT_RESET

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeReset ResetSOFTRESET { get; set; }
Public Property ResetSOFTRESET As Lm49352TypeReset
    Get
    Set
public:
property Lm49352TypeReset ResetSOFTRESET {
    Lm49352TypeReset get ();
    void set (Lm49352TypeReset value);
}
member ResetSOFTRESET : Lm49352TypeReset with get, set

Property Value

Type: Lm49352TypeReset
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.SpreadSpectrumSSDISABLE Property

IRD

Lm49352SpreadSpectrumSSDISABLE Property

Spread Spectrum: SS_DISABLE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm49352TypeSpreadSpectrum SpreadSpectrumSSDISABLE { get; set; }
Public Property SpreadSpectrumSSDISABLE As Lm49352TypeSpreadSpectrum
    Get
    Set
public:
property Lm49352TypeSpreadSpectrum SpreadSpectrumSSDISABLE {
    Lm49352TypeSpreadSpectrum get ();
    void set (Lm49352TypeSpreadSpectrum value);
}
member SpreadSpectrumSSDISABLE : Lm49352TypeSpreadSpectrum with get, set

Property Value

Type: Lm49352TypeSpreadSpectrum
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352 Methods

The Lm49352 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.Flush Method

IRD

Lm49352Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm49352 Class
telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcAlc1Limiter Enumeration

IRD

Lm49352TypeAdcAlc1Limiter Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcAlc1Limiter
Public Enumeration TypeAdcAlc1Limiter
public enum class TypeAdcAlc1Limiter
type TypeAdcAlc1Limiter
Members
Member name | Value | Description
SignalAttenuationDisabled | 0 | Signal Attenuation: Disabled
SignalAttenuationEnabled | 1 | Signal Attenuation: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcAlc1Lsel Enumeration

IRD

Lm49352TypeAdcAlc1Lsel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcAlc1Lsel
Public Enumeration TypeAdcAlc1Lsel
public enum class TypeAdcAlc1Lsel
type TypeAdcAlc1Lsel
Members
Member name | Value | Description
LeftADCALCChannelNotActive | 0 | Left ADC ALC Channel: Not Active
LeftADCALCChannelActive | 1 | Left ADC ALC Channel: Active
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcAlc1Ovr Enumeration

IRD

Lm49352TypeAdcAlc1Ovr Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcAlc1Ovr
Public Enumeration TypeAdcAlc1Ovr
public enum class TypeAdcAlc1Ovr
type TypeAdcAlc1Ovr
Members
Member name | Value | Description
ADCALCDerterminedBySeleectedDACInput | 0 | ADC ALC Dertermined By Seleected DAC Input
ADCALCDerterminedBySOURCERSELAndSOURCELSEL | 1 | ADC ALC Dertermined By SOURCE_RSEL And SOURCE_LSEL
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcAlc1Rsel Enumeration

IRD

Lm49352TypeAdcAlc1Rsel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcAlc1Rsel
Public Enumeration TypeAdcAlc1Rsel
public enum class TypeAdcAlc1Rsel
type TypeAdcAlc1Rsel
Members
Member name | Value | Description
RightADCALCChannelNotActive | 0 | Right ADC ALC Channel: Not Active
RightADCALCChannelActive | 1 | Right ADC ALC Channel: Active
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcAlc1SampleRate Enumeration

IRD

Lm49352TypeAdcAlc1SampleRate Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcAlc1SampleRate
Public Enumeration TypeAdcAlc1SampleRate
public enum class TypeAdcAlc1SampleRate
type TypeAdcAlc1SampleRate
Members
Member name | Value | Description
Value_8 | 0 | 8
Value_12 | 1 | 12
Value_16 | 2 | 16
Value_24 | 3 | 24
Value_32 | 4 | 32
Value_48 | 5 | 48
Value_96 | 6 | 96
Value_192 | 7 | 192
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcAlc1Stereo Enumeration

IRD

Lm49352TypeAdcAlc1Stereo Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcAlc1Stereo
Public Enumeration TypeAdcAlc1Stereo
public enum class TypeAdcAlc1Stereo
type TypeAdcAlc1Stereo
Members
Member name | Value | Description
BothChannelsOperatesAsDualMono | 0 | Both Channels Operates As Dual Mono
ALCCircuitUsesStereoInputToControlStereoOutputGain | 1 | ALC Circuit Uses Stereo Input To Control Stereo Output Gain
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcAlc2NoiseGate Enumeration

IRD

Lm49352TypeAdcAlc2NoiseGate Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcAlc2NoiseGate
Public Enumeration TypeAdcAlc2NoiseGate
public enum class TypeAdcAlc2NoiseGate
type TypeAdcAlc2NoiseGate
Members
Member name | Value | Description
NoiseGateDisabled | 0 | Noise Gate: Disabled
NoiseGateEnabled | 1 | Noise Gate: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcAlc4AttackRate Enumeration

IRD

Lm49352TypeAdcAlc4AttackRate Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcAlc4AttackRate
Public Enumeration TypeAdcAlc4AttackRate
public enum class TypeAdcAlc4AttackRate
type TypeAdcAlc4AttackRate
Members
Member name | Value | Description
Value_21 | 0 | 21
Value_42 | 1 | 42
Value_83 | 2 | 83
Value_167 | 3 | 167
Value_250 | 4 | 250
Value_333 | 5 | 333
Value_417 | 6 | 417
Value_542 | 7 | 542
Value_729 | 8 | 729
Value_958 | 9 | 958
Value_1250 | 10 | 1250
Value_1604 | 11 | 1604
Value_1896 | 12 | 1896
Value_2208 | 13 | 2208
Value_2792 | 14 | 2792
Value_3708 | 15 | 3708
Value_4792 | 16 | 4792
Value_5688 | 17 | 5688
Value_6563 | 18 | 6563
Value_8396 | 19 | 8396
Value_11000 | 20 | 11000
Value_14167 | 21 | 14167
Value_17083 | 22 | 17083
Value_20000 | 23 | 20000
Value_25000 | 24 | 25000
Value_32000 | 25 | 32000
Value_45000 | 26 | 45000
Value_60000 | 27 | 60000
Value_75000 | 28 | 75000
Value_87500 | 29 | 87500
Value_100000 | 30 | 100000
Value_114583 | 31 | 114583
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcAlc5DecayRate Enumeration

IRD

Lm49352TypeAdcAlc5DecayRate Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcAlc5DecayRate
Public Enumeration TypeAdcAlc5DecayRate
public enum class TypeAdcAlc5DecayRate
type TypeAdcAlc5DecayRate
Members
Member name | Value | Description
Value_104 | 0 | 104
Value_125 | 1 | 125
Value_167 | 2 | 167
Value_250 | 3 | 250
Value_292 | 4 | 292
Value_396 | 5 | 396
Value_500 | 6 | 500
Value_708 | 7 | 708
Value_896 | 8 | 896
Value_1250 | 9 | 1250
Value_1396 | 10 | 1396
Value_2000 | 11 | 2000
Value_2708 | 12 | 2708
Value_3500 | 13 | 3500
Value_4750 | 14 | 4750
Value_6250 | 15 | 6250
Value_8000 | 16 | 8000
Value_11000 | 17 | 11000
Value_14000 | 18 | 14000
Value_18500 | 19 | 18500
Value_25000 | 20 | 25000
Value_32000 | 21 | 32000
Value_42000 | 22 | 42000
Value_55000 | 23 | 55000
Value_72500 | 24 | 72500
Value_100000 | 25 | 100000
Value_125000 | 26 | 125000
Value_160000 | 27 | 160000
Value_225000 | 28 | 225000
Value_300000 | 29 | 300000
Value_375000 | 30 | 375000
Value_500000 | 31 | 500000
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcAlc5PkDecayRate Enumeration

IRD

Lm49352TypeAdcAlc5PkDecayRate Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcAlc5PkDecayRate
Public Enumeration TypeAdcAlc5PkDecayRate
public enum class TypeAdcAlc5PkDecayRate
type TypeAdcAlc5PkDecayRate
Members
Member name | Value | Description
Value_1_3 | 0 | 1.3
Value_2_6 | 1 | 2.6
Value_5_3 | 2 | 5.3
Value_10_6 | 3 | 10.6
Value_21_3 | 4 | 21.3
Value_42_6 | 5 | 42.6
Value_85_5 | 6 | 85.5
Value_2730_0 | 7 | 2730.0
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcAlc6HoldTime Enumeration

IRD

Lm49352TypeAdcAlc6HoldTime Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcAlc6HoldTime
Public Enumeration TypeAdcAlc6HoldTime
public enum class TypeAdcAlc6HoldTime
type TypeAdcAlc6HoldTime
Members
Member name | Value | Description
Value_1_00 | 0 | 1.00
Value_1_25 | 1 | 1.25
Value_1_60 | 2 | 1.60
Value_2_00 | 3 | 2.00
Value_2_50 | 4 | 2.50
Value_3_20 | 5 | 3.20
Value_4_00 | 6 | 4.00
Value_5_00 | 7 | 5.00
Value_6_25 | 8 | 6.25
Value_8_00 | 9 | 8.00
Value_10_00 | 10 | 10.00
Value_12_50 | 11 | 12.50
Value_16_00 | 12 | 16.00
Value_20_00 | 13 | 20.00
Value_25_00 | 14 | 25.00
Value_32_00 | 15 | 32.00
Value_40_00 | 16 | 40.00
Value_50_00 | 17 | 50.00
Value_64_00 | 18 | 64.00
Value_80_00 | 19 | 80.00
Value_100_00 | 20 | 100.00
Value_125_00 | 21 | 125.00
Value_160_00 | 22 | 160.00
Value_200_00 | 23 | 200.00
Value_250_00 | 24 | 250.00
Value_320_00 | 25 | 320.00
Value_400_00 | 26 | 400.00
Value_500_00 | 27 | 500.00
Value_640_00 | 28 | 640.00
Value_800_00 | 29 | 800.00
Value_1000_00 | 30 | 1000.00
Value_1250_00 | 31 | 1250.00
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcBasicClock Enumeration

IRD

Lm49352TypeAdcBasicClock Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcBasicClock
Public Enumeration TypeAdcBasicClock
public enum class TypeAdcBasicClock
type TypeAdcBasicClock
Members
Member name | Value | Description
ADCClockDomainMCLK | 0 | ADC Clock Domain: MCLK
ADCClockDomainPORT1RXCLK | 1 | ADC Clock Domain: PORT1_RX_CLK
ADCClockDomainPORT2RXCLK | 2 | ADC Clock Domain: PORT2_RX_CLK
ADCClockDomainPLL1OUTPUT2 | 3 | ADC Clock Domain: PLL1_OUTPUT2
ADCClockDomainPLL2OUTPUT | 4 | ADC Clock Domain: PLL2_OUTPUT
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcBasicDspOnly Enumeration

IRD

Lm49352TypeAdcBasicDspOnly Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcBasicDspOnly
Public Enumeration TypeAdcBasicDspOnly
public enum class TypeAdcBasicDspOnly
type TypeAdcBasicDspOnly
Members
Member name | Value | Description
ADCAnalogCircuitNotDisabled | 0 | ADC Analog Circuit: Not Disabled
ADCAnalogCircuitDisabled | 1 | ADC Analog Circuit: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcBasicMono Enumeration

IRD

Lm49352TypeAdcBasicMono Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcBasicMono
Public Enumeration TypeAdcBasicMono
public enum class TypeAdcBasicMono
type TypeAdcBasicMono
Members
Member name | Value | Description
ADCOperationStereoAudio | 0 | ADC Operation: Stereo Audio
ADCOperationMonoVoiceLeftADCChannelActive | 1 | ADC Operation: Mono Voice (Left ADC Channel Active)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcBasicMuteL Enumeration

IRD

Lm49352TypeAdcBasicMuteL Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcBasicMuteL
Public Enumeration TypeAdcBasicMuteL
public enum class TypeAdcBasicMuteL
type TypeAdcBasicMuteL
Members
Member name | Value | Description
LeftADCOutputNotMuted | 0 | Left ADC Output: Not Muted
LeftADCOutputMuted | 1 | Left ADC Output: Muted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcBasicMuteR Enumeration

IRD

Lm49352TypeAdcBasicMuteR Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcBasicMuteR
Public Enumeration TypeAdcBasicMuteR
public enum class TypeAdcBasicMuteR
type TypeAdcBasicMuteR
Members
Member name | Value | Description
RightADCOutputNotMuted | 0 | Right ADC Output: Not Muted
RightADCOutputMuted | 1 | Right ADC Output: Muted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcBasicOsr Enumeration

IRD

Lm49352TypeAdcBasicOsr Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcBasicOsr
Public Enumeration TypeAdcBasicOsr
public enum class TypeAdcBasicOsr
type TypeAdcBasicOsr
Members
Member name | Value | Description
ADCOversamplingRatioStereoAudio128MonoVoice125 | 0 | ADC Oversampling Ratio: Stereo Audio = 128 / Mono Voice = 125
ADCOversamplingRatioStereoAudio128MonoVoice128 | 1 | ADC Oversampling Ratio: Stereo Audio = 128 / Mono Voice = 128
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcEqBand1EqLevel Enumeration

IRD

Lm49352TypeAdcEqBand1EqLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEqBand1EqLevel
Public Enumeration TypeAdcEqBand1EqLevel
public enum class TypeAdcEqBand1EqLevel
type TypeAdcEqBand1EqLevel
Members
Member name | Value | Description
Off | 0 | Off
Value_M_15 | 1 | -15
Value_M_14 | 2 | -14
Value_M_13 | 3 | -13
Value_M_12 | 4 | -12
Value_M_11 | 5 | -11
Value_M_10 | 6 | -10
Value_M_9 | 7 | -9
Value_M_8 | 8 | -8
Value_M_7 | 9 | -7
Value_M_6 | 10 | -6
Value_M_5 | 11 | -5
Value_M_4 | 12 | -4
Value_M_3 | 13 | -3
Value_M_2 | 14 | -2
Value_M_1 | 15 | -1
Value_0 | 16 | 0
Value_1 | 17 | 1
Value_2 | 18 | 2
Value_3 | 19 | 3
Value_4 | 20 | 4
Value_5 | 21 | 5
Value_6 | 22 | 6
Value_7 | 23 | 7
Value_8 | 24 | 8
Value_9 | 25 | 9
Value_10 | 26 | 10
Value_11 | 27 | 11
Value_12 | 28 | 12
Value_13 | 29 | 13
Value_14 | 30 | 14
Value_15 | 31 | 15
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcEqBand1Freq Enumeration

IRD

Lm49352TypeAdcEqBand1Freq Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEqBand1Freq
Public Enumeration TypeAdcEqBand1Freq
public enum class TypeAdcEqBand1Freq
type TypeAdcEqBand1Freq
Members
Member name | Value | Description
Value_60 | 0 | 60
Value_80 | 1 | 80
Value_100 | 2 | 100
Value_120 | 3 | 120
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcEqBand2Freq Enumeration

IRD

Lm49352TypeAdcEqBand2Freq Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEqBand2Freq
Public Enumeration TypeAdcEqBand2Freq
public enum class TypeAdcEqBand2Freq
type TypeAdcEqBand2Freq
Members
Member name | Value | Description
Value_150 | 0 | 150
Value_200 | 1 | 200
Value_250 | 2 | 250
Value_300 | 3 | 300
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcEqBand2Q Enumeration

IRD

Lm49352TypeAdcEqBand2Q Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEqBand2Q
Public Enumeration TypeAdcEqBand2Q
public enum class TypeAdcEqBand2Q
type TypeAdcEqBand2Q
Members
Member name | Value | Description
Value_23 | 0 | 2/3
Value_43 | 1 | 4/3
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcEqBand3Freq Enumeration

IRD

Lm49352TypeAdcEqBand3Freq Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEqBand3Freq
Public Enumeration TypeAdcEqBand3Freq
public enum class TypeAdcEqBand3Freq
type TypeAdcEqBand3Freq
Members
Member name | Value | Description
Value_600 | 0 | 600
Value_800 | 1 | 800
Value_1000 | 2 | 1000
Value_1200 | 3 | 1200
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcEqBand4Freq Enumeration

IRD

Lm49352TypeAdcEqBand4Freq Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEqBand4Freq
Public Enumeration TypeAdcEqBand4Freq
public enum class TypeAdcEqBand4Freq
type TypeAdcEqBand4Freq
Members
Member name | Value | Description
Value_2_0 | 0 | 2.0
Value_2_7 | 1 | 2.7
Value_3_4 | 2 | 3.4
Value_4_1 | 3 | 4.1
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcEqBand5Freq Enumeration

IRD

Lm49352TypeAdcEqBand5Freq Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcEqBand5Freq
Public Enumeration TypeAdcEqBand5Freq
public enum class TypeAdcEqBand5Freq
type TypeAdcEqBand5Freq
Members
Member name | Value | Description
Value_7 | 0 | 7
Value_9 | 1 | 9
Value_11 | 2 | 11
Value_13 | 3 | 13
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcFxAlc Enumeration

IRD

Lm49352TypeAdcFxAlc Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcFxAlc
Public Enumeration TypeAdcFxAlc
public enum class TypeAdcFxAlc
type TypeAdcFxAlc
Members
Member name | Value | Description
ADCAutomaticLevelControlDisabled | 0 | ADC Automatic Level Control: Disabled
ADCAutomaticLevelControlEnabled | 1 | ADC Automatic Level Control: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcFxEq Enumeration

IRD

Lm49352TypeAdcFxEq Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcFxEq
Public Enumeration TypeAdcFxEq
public enum class TypeAdcFxEq
type TypeAdcFxEq
Members
Member name | Value | Description
ADC5BandParametricEQDisabled | 0 | ADC 5-Band Parametric EQ: Disabled
ADC5BandParametricEQEnabled | 1 | ADC 5-Band Parametric EQ: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcFxHpf Enumeration

IRD

Lm49352TypeAdcFxHpf Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcFxHpf
Public Enumeration TypeAdcFxHpf
public enum class TypeAdcFxHpf
type TypeAdcFxHpf
Members
Member name | Value | Description
ADCHighPassFilterDisabled | 0 | ADC High Pass Filter: Disabled
ADCHighPassFilterEnabled | 1 | ADC High Pass Filter: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcFxPk Enumeration

IRD

Lm49352TypeAdcFxPk Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcFxPk
Public Enumeration TypeAdcFxPk
public enum class TypeAdcFxPk
type TypeAdcFxPk
Members
Member name | Value | Description
ADCPeakDetectorDisabled | 0 | ADC Peak Detector: Disabled
ADCPeakDetectorEnabled | 1 | ADC Peak Detector: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcFxSclp Enumeration

IRD

Lm49352TypeAdcFxSclp Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcFxSclp
Public Enumeration TypeAdcFxSclp
public enum class TypeAdcFxSclp
type TypeAdcFxSclp
Members
Member name | Value | Description
ADCSoftClipFeatureDisabled | 0 | ADC Soft Clip Feature: Disabled
ADCSoftClipFeatureEnabled | 1 | ADC Soft Clip Feature: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcInputAux Enumeration

IRD

Lm49352TypeAdcInputAux Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcInputAux
Public Enumeration TypeAdcInputAux
public enum class TypeAdcInputAux
type TypeAdcInputAux
Members
Member name | Value | Description
AUXInputNotAddedToADCRightInput | 0 | AUX Input Not Added To ADC Right Input
AUXInputAddedToADCRightInput | 1 | AUX Input Added To ADC Right Input
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcInputDacl Enumeration

IRD

Lm49352TypeAdcInputDacl Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcInputDacl
Public Enumeration TypeAdcInputDacl
public enum class TypeAdcInputDacl
type TypeAdcInputDacl
Members
Member name | Value | Description
LeftDACOutputNotAddedToLeftADCInput | 0 | Left DAC Output Not Added To Left ADC Input
LeftDACOutputAddedToLeftADCInput | 1 | Left DAC Output Added To Left ADC Input
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcInputDacr Enumeration

IRD

Lm49352TypeAdcInputDacr Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcInputDacr
Public Enumeration TypeAdcInputDacr
public enum class TypeAdcInputDacr
type TypeAdcInputDacr
Members
Member name | Value | Description
RightDACOutputNotAddedToADCRightInput | 0 | Right DAC Output Not Added To ADC Right Input
RightDACOutputAddedToADCRightInput | 1 | Right DAC Output Added To ADC Right Input
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcInputMicl Enumeration

IRD

Lm49352TypeAdcInputMicl Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcInputMicl
Public Enumeration TypeAdcInputMicl
public enum class TypeAdcInputMicl
type TypeAdcInputMicl
Members
Member name | Value | Description
MICInputNotAddedToADCLeftInput | 0 | MIC Input Not Added To ADC Left Input
MICInputAddedToADCLeftInput | 1 | MIC Input Added To ADC Left Input
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcInputMicr Enumeration

IRD

Lm49352TypeAdcInputMicr Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcInputMicr
Public Enumeration TypeAdcInputMicr
public enum class TypeAdcInputMicr
type TypeAdcInputMicr
Members
Member name | Value | Description
MICInputNotAddedToADCRightInput | 0 | MIC Input Not Added To ADC Right Input
MICInputAddedToADCRightInput | 1 | MIC Input Added To ADC Right Input
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcInputMono Enumeration

IRD

Lm49352TypeAdcInputMono Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcInputMono
Public Enumeration TypeAdcInputMono
public enum class TypeAdcInputMono
type TypeAdcInputMono
Members
Member name | Value | Description
MonoInputNotAddedToADCLeftInput | 0 | Mono Input Not Added To ADC Left Input
MonoInputAddedToADCLeftInput | 1 | Mono Input Added To ADC Left Input
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcLLevelStereo Enumeration

IRD

Lm49352TypeAdcLLevelStereo Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcLLevelStereo
Public Enumeration TypeAdcLLevelStereo
public enum class TypeAdcLLevelStereo
type TypeAdcLLevelStereo
Members
Member name | Value | Description
ADCRLEVELNotLinkedWithADCLLEVEL | 0 | ADC_R_LEVEL Not Linked With ADC_L_LEVEL
ADCRLEVELLinkedWithADCLLEVEL | 1 | ADC_R_LEVEL Linked With ADC_L_LEVEL
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcMixerLevel Enumeration

IRD

Lm49352TypeAdcMixerLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcMixerLevel
Public Enumeration TypeAdcMixerLevel
public enum class TypeAdcMixerLevel
type TypeAdcMixerLevel
Members
Member name | Value | Description
Value_0_00 | 0 | 0.00
Value_1_35 | 1 | 1.35
Value_3_50 | 2 | 3.50
Value_6_00 | 3 | 6.00
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcMixerStereo Enumeration

IRD

Lm49352TypeAdcMixerStereo Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcMixerStereo
Public Enumeration TypeAdcMixerStereo
public enum class TypeAdcMixerStereo
type TypeAdcMixerStereo
Members
Member name | Value | Description
StereoLinkStatusOff | 0 | Stereo Link Status: Off
StereoLinkStatusOn | 1 | Stereo Link Status: On
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcSoftclip1Knee Enumeration

IRD

Lm49352TypeAdcSoftclip1Knee Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcSoftclip1Knee
Public Enumeration TypeAdcSoftclip1Knee
public enum class TypeAdcSoftclip1Knee
type TypeAdcSoftclip1Knee
Members
Member name | Value | Description
AudioCompressorDoesNotApplyHigherCompression | 0 | Audio Compressor Does Not Apply Higher Compression
AudioCompressorApplysHigherCompression | 1 | Audio Compressor Applys Higher Compression
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcSoftclip1Threshold Enumeration

IRD

Lm49352TypeAdcSoftclip1Threshold Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcSoftclip1Threshold
Public Enumeration TypeAdcSoftclip1Threshold
public enum class TypeAdcSoftclip1Threshold
type TypeAdcSoftclip1Threshold
Members
Member name | Value | Description
Value_M_36 | 0 | -36
Value_M_30 | 1 | -30
Value_M_24 | 2 | -24
Value_M_20 | 3 | -20
Value_M_18 | 4 | -18
Value_M_17 | 5 | -17
Value_M_16 | 6 | -16
Value_M_15 | 7 | -15
Value_M_14 | 8 | -14
Value_M_12 | 9 | -12
Value_M_10 | 10 | -10
Value_M_8 | 11 | -8
Value_M_6 | 12 | -6
Value_M_4 | 13 | -4
Value_M_2_5 | 14 | -2.5
Value_M_1 | 15 | -1
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAdcSoftclip2ClipRatio Enumeration

IRD

Lm49352TypeAdcSoftclip2ClipRatio Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcSoftclip2ClipRatio
Public Enumeration TypeAdcSoftclip2ClipRatio
public enum class TypeAdcSoftclip2ClipRatio
type TypeAdcSoftclip2ClipRatio
Members
Member name | Value | Description
Value_11 | 0 | 1:1
Value_112 | 1 | 1:1.2
Value_114 | 2 | 1:1.4
Value_117 | 3 | 1:1.7
Value_120 | 4 | 1:2.0
Value_124 | 5 | 1:2.4
Value_128 | 6 | 1:2.8
Value_134 | 7 | 1:3.4
Value_140 | 8 | 1:4.0
Value_147 | 9 | 1:4.7
Value_157 | 10 | 1:5.7
Value_167 | 11 | 1:6.7
Value_180 | 12 | 1:8.0
Value_195 | 13 | 1:9.5
Value_1113 | 14 | 1:11.3
Value_1135 | 15 | 1:13.5
Value_1160 | 16 | 1:16.0
Value_1190 | 17 | 1:19.0
Value_1228 | 18 | 1:22.8
Value_1270 | 19 | 1:27.0
Value_1320 | 20 | 1:32.0
Value_1379 | 21 | 1:37.9
Value_1455 | 22 | 1:45.5
Value_1539 | 23 | 1:53.9
Value_1640 | 24 | 1:64.0
Value_1750 | 25 | 1:75.0
Value_1910 | 26 | 1:91.0
Value_1108 | 27 | 1:108
Value_1128 | 28 | 1:128
Value_1152 | 29 | 1:152
Value_1182 | 30 | 1:182
Value_1215 | 31 | 1:215
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1BasicClock Enumeration

IRD

Lm49352TypeAudioPort1BasicClock Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1BasicClock
Public Enumeration TypeAudioPort1BasicClock
public enum class TypeAudioPort1BasicClock
type TypeAudioPort1BasicClock
Members
Member name | Value | Description
NoClockTransmissionViaAudioPort | 0 | No Clock Transmission Via Audio Port
ClockTransmissionViaAudioPortRxOrTxMustBeEnabled | 1 | Clock Transmission Via Audio Port (Rx Or Tx Must Be Enabled)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1BasicClockPhase Enumeration

IRD

Lm49352TypeAudioPort1BasicClockPhase Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1BasicClockPhase
Public Enumeration TypeAudioPort1BasicClockPhase
public enum class TypeAudioPort1BasicClockPhase
type TypeAudioPort1BasicClockPhase
Members
Member name | Value | Description
AudioDataModeI2STxOnFallingRxOnRisingEdge | 0 | Audio Data Mode: I2S (Tx On Falling, Rx On Rising Edge)
AudioDataModePCMTxOnRisingRxOnFallingEdge | 1 | Audio Data Mode: PCM (Tx On Rising, Rx On Falling Edge)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1BasicInvert Enumeration

IRD

Lm49352TypeAudioPort1BasicInvert Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1BasicInvert
Public Enumeration TypeAudioPort1BasicInvert
public enum class TypeAudioPort1BasicInvert
type TypeAudioPort1BasicInvert
Members
Member name | Value | Description
SYNCLowLeftSYNCHighRight | 0 | SYNC Low = Left / SYNC High = Right
SYNCLowRightSYNCHighLeft | 1 | SYNC Low = Right / SYNC High = Left
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1BasicRx Enumeration

IRD

Lm49352TypeAudioPort1BasicRx Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1BasicRx
Public Enumeration TypeAudioPort1BasicRx
public enum class TypeAudioPort1BasicRx
type TypeAudioPort1BasicRx
Members
Member name | Value | Description
InputDisabled | 0 | Input: Disabled
InputEnabled | 1 | Input: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1BasicStereo Enumeration

IRD

Lm49352TypeAudioPort1BasicStereo Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1BasicStereo
Public Enumeration TypeAudioPort1BasicStereo
public enum class TypeAudioPort1BasicStereo
type TypeAudioPort1BasicStereo
Members
Member name | Value | Description
AudioPortReceiveAndTransmitNoStereoData | 0 | Audio Port Receive And Transmit: No Stereo Data
AudioPortReceiveAndTransmitStereoData | 1 | Audio Port Receive And Transmit: Stereo Data
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1BasicSync Enumeration

IRD

Lm49352TypeAudioPort1BasicSync Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1BasicSync
Public Enumeration TypeAudioPort1BasicSync
public enum class TypeAudioPort1BasicSync
type TypeAudioPort1BasicSync
Members
Member name | Value | Description
NoSyncTransmissionViaAudioPort | 0 | No Sync Transmission Via Audio Port
SyncTransmissionViaAudioPortRxOrTxMusBeEnabled | 1 | Sync Transmission Via Audio Port (Rx Or Tx Mus Be Enabled)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1BasicSyncPhase Enumeration

IRD

Lm49352TypeAudioPort1BasicSyncPhase Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1BasicSyncPhase
Public Enumeration TypeAudioPort1BasicSyncPhase
public enum class TypeAudioPort1BasicSyncPhase
type TypeAudioPort1BasicSyncPhase
Members
Member name | Value | Description
ChannelDataToOutputLeftLeftRightRight | 0 | Channel Data To Output: Left => Left / Right => Right
ChannelDataToOutputRightLeftLeftRight | 1 | Channel Data To Output: Right => Left / Left => Right
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1BasicTx Enumeration

IRD

Lm49352TypeAudioPort1BasicTx Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1BasicTx
Public Enumeration TypeAudioPort1BasicTx
public enum class TypeAudioPort1BasicTx
type TypeAudioPort1BasicTx
Members
Member name | Value | Description
OutputDisabled | 0 | Output: Disabled
OutputEnabled | 1 | Output: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1ClkGen1Divider Enumeration

IRD

Lm49352TypeAudioPort1ClkGen1Divider Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1ClkGen1Divider
Public Enumeration TypeAudioPort1ClkGen1Divider
public enum class TypeAudioPort1ClkGen1Divider
type TypeAudioPort1ClkGen1Divider
Members
Member name | Value | Description
Bypass | 0 | Bypass
Value_1_0 | 1 | 1.0
Value_1_5 | 2 | 1.5
Value_2_0 | 3 | 2.0
Value_2_5 | 4 | 2.5
Value_3_0 | 5 | 3.0
Value_3_5 | 6 | 3.5
Value_4_0 | 7 | 4.0
Value_4_5 | 8 | 4.5
Value_5_0 | 9 | 5.0
Value_5_5 | 10 | 5.5
Value_6_0 | 11 | 6.0
Value_6_5 | 12 | 6.5
Value_7_0 | 13 | 7.0
Value_7_5 | 14 | 7.5
Value_8_0 | 15 | 8.0
Value_8_5 | 16 | 8.5
Value_9_0 | 17 | 9.0
Value_9_5 | 18 | 9.5
Value_10_0 | 19 | 10.0
Value_10_5 | 20 | 10.5
Value_11_0 | 21 | 11.0
Value_11_5 | 22 | 11.5
Value_12_0 | 23 | 12.0
Value_12_5 | 24 | 12.5
Value_13_0 | 25 | 13.0
Value_13_5 | 26 | 13.5
Value_14_0 | 27 | 14.0
Value_14_5 | 28 | 14.5
Value_15_0 | 29 | 15.0
Value_15_5 | 30 | 15.5
Value_16_0 | 31 | 16.0
Value_16_5 | 32 | 16.5
Value_17_0 | 33 | 17.0
Value_17_5 | 34 | 17.5
Value_18_0 | 35 | 18.0
Value_18_5 | 36 | 18.5
Value_19_0 | 37 | 19.0
Value_19_5 | 38 | 19.5
Value_20_0 | 39 | 20.0
Value_20_5 | 40 | 20.5
Value_21_0 | 41 | 21.0
Value_21_5 | 42 | 21.5
Value_22_0 | 43 | 22.0
Value_22_5 | 44 | 22.5
Value_23_0 | 45 | 23.0
Value_23_5 | 46 | 23.5
Value_24_0 | 47 | 24.0
Value_24_5 | 48 | 24.5
Value_25_0 | 49 | 25.0
Value_25_5 | 50 | 25.5
Value_26_0 | 51 | 26.0
Value_26_5 | 52 | 26.5
Value_27_0 | 53 | 27.0
Value_27_5 | 54 | 27.5
Value_28_0 | 55 | 28.0
Value_28_5 | 56 | 28.5
Value_29_0 | 57 | 29.0
Value_29_5 | 58 | 29.5
Value_30_0 | 59 | 30.0
Value_30_5 | 60 | 30.5
Value_31_0 | 61 | 31.0
Value_31_5 | 62 | 31.5
Value_32_0 | 63 | 32.0
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1ClkGen1Sel Enumeration

IRD

Lm49352TypeAudioPort1ClkGen1Sel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1ClkGen1Sel
Public Enumeration TypeAudioPort1ClkGen1Sel
public enum class TypeAudioPort1ClkGen1Sel
type TypeAudioPort1ClkGen1Sel
Members
Member name | Value | Description
DACSOURCECLK | 0 | DAC_SOURCE_CLK
ADCSOURCECLK | 1 | ADC_SOURCE_CLK
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1ClkGen2SynthDenom Enumeration

IRD

Lm49352TypeAudioPort1ClkGen2SynthDenom Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1ClkGen2SynthDenom
Public Enumeration TypeAudioPort1ClkGen2SynthDenom
public enum class TypeAudioPort1ClkGen2SynthDenom
type TypeAudioPort1ClkGen2SynthDenom
Members
Member name | Value | Description
Value_128 | 0 | 128
Value_125 | 1 | 125
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1ClkGen2SynthNum Enumeration

IRD

Lm49352TypeAudioPort1ClkGen2SynthNum Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1ClkGen2SynthNum
Public Enumeration TypeAudioPort1ClkGen2SynthNum
public enum class TypeAudioPort1ClkGen2SynthNum
type TypeAudioPort1ClkGen2SynthNum
Members
Member name | Value | Description
SYNTHDENOM | 0 | SYNTH_DENOM
Value_100SYNTHDENOM | 1 | 100/SYNTH_DENOM
Value_96SYNTHDENOM | 2 | 96/SYNTH_DENOM
Value_80SYNTHDENOM | 3 | 80/SYNTH_DENOM
Value_72SYNTHDENOM | 4 | 72/SYNTH_DENOM
Value_64SYNTHDENOM | 5 | 64/SYNTH_DENOM
Value_48SYNTHDENOM | 6 | 48/SYNTH_DENOM
Value_0SYNTHDENOM | 7 | 0/SYNTH_DENOM
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1LSel Enumeration

IRD

Lm49352TypeAudioPort1LSel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1LSel
Public Enumeration TypeAudioPort1LSel
public enum class TypeAudioPort1LSel
type TypeAudioPort1LSel
Members
Member name | Value | Description
LeftTXChannelInputNone | 0 | Left TX Channel Input: None
LeftTXChannelInputADCL | 1 | Left TX Channel Input: ADC_L
LeftTXChannelInputPORT2RXL | 2 | Left TX Channel Input: PORT2_RX_L
LeftTXChannelInputDACINTERPL | 3 | Left TX Channel Input: DAC_INTERP_L
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1Mono Enumeration

IRD

Lm49352TypeAudioPort1Mono Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1Mono
Public Enumeration TypeAudioPort1Mono
public enum class TypeAudioPort1Mono
type TypeAudioPort1Mono
Members
Member name | Value | Description
MonoNotSet | 0 | Mono: Not Set
MonoSetRightChannelIgnoredLeftChannelLR2 | 1 | Mono: Set => Right Channel Ignored, Left Channel = (L+R)/2
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1RSel Enumeration

IRD

Lm49352TypeAudioPort1RSel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1RSel
Public Enumeration TypeAudioPort1RSel
public enum class TypeAudioPort1RSel
type TypeAudioPort1RSel
Members
Member name | Value | Description
RightTXChannelInputNone | 0 | Right TX Channel Input: None
RightTXChannelInputADCR | 1 | Right TX Channel Input: ADC_R
RightTXChannelInputPORT2RXR | 2 | Right TX Channel Input: PORT2_RX_R
RightTXChannelInputDACINTERPR | 3 | Right TX Channel Input: DAC_INTERP_R
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1RxCompand Enumeration

IRD

Lm49352TypeAudioPort1RxCompand Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1RxCompand
Public Enumeration TypeAudioPort1RxCompand
public enum class TypeAudioPort1RxCompand
type TypeAudioPort1RxCompand
Members
Member name | Value | Description
AudioDataWillNotBeCompanded | 0 | Audio Data Will Not Be Companded
AudioDataWillBeCompanded | 1 | Audio Data Will Be Companded
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1RxLaw Enumeration

IRD

Lm49352TypeAudioPort1RxLaw Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1RxLaw
Public Enumeration TypeAudioPort1RxLaw
public enum class TypeAudioPort1RxLaw
type TypeAudioPort1RxLaw
Members
Member name | Value | Description
ΜLaw | 0 | μLaw
ALaw | 1 | A-Law
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1RxMode Enumeration

IRD

Lm49352TypeAudioPort1RxMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1RxMode
Public Enumeration TypeAudioPort1RxMode
public enum class TypeAudioPort1RxMode
type TypeAudioPort1RxMode
Members
Member name | Value | Description
MSBJustified | 0 | MSB Justified
LSBJustified | 1 | LSB Justified
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1Swap Enumeration

IRD

Lm49352TypeAudioPort1Swap Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1Swap
Public Enumeration TypeAudioPort1Swap
public enum class TypeAudioPort1Swap
type TypeAudioPort1Swap
Members
Member name | Value | Description
LeftAndRightOutputNotSwappedToAudioPort1 | 0 | Left And Right Output Not Swapped To Audio Port 1
LeftAndRightOutputSwappedToAudioPort1 | 1 | Left And Right Output Swapped To Audio Port 1
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1SyncRate Enumeration

IRD

Lm49352TypeAudioPort1SyncRate Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1SyncRate
Public Enumeration TypeAudioPort1SyncRate
public enum class TypeAudioPort1SyncRate
type TypeAudioPort1SyncRate
Members
Member name | Value | Description
Value_8Mono16Stereo | 0 | 8 (Mono), 16 (Stereo)
Value_12Mono24Stereo | 1 | 12 (Mono), 24 (Stereo)
Value_16Mono32Stereo | 2 | 16 (Mono), 32 (Stereo)
Value_18Mono36Stereo | 3 | 18 (Mono), 36 (Stereo)
Value_20Mono40Stereo | 4 | 20 (Mono), 40 (Stereo)
Value_24Mono48Stereo | 5 | 24 (Mono), 48 (Stereo)
Value_25Mono50Stereo | 6 | 25 (Mono), 50 (Stereo)
Value_32Mono64Stereo | 7 | 32 (Mono), 64 (Stereo)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1SyncWidth Enumeration

IRD

Lm49352TypeAudioPort1SyncWidth Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1SyncWidth
Public Enumeration TypeAudioPort1SyncWidth
public enum class TypeAudioPort1SyncWidth
type TypeAudioPort1SyncWidth
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_2 | 1 | 2
Value_4 | 2 | 4
Value_7 | 3 | 7
Value_8 | 4 | 8
Value_11 | 5 | 11
Value_15 | 6 | 15
Value_16 | 7 | 16
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1WidthExtra Enumeration

IRD

Lm49352TypeAudioPort1WidthExtra Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1WidthExtra
Public Enumeration TypeAudioPort1WidthExtra
public enum class TypeAudioPort1WidthExtra
type TypeAudioPort1WidthExtra
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_1 | 1 | 1
HighZ | 2 | High-Z
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort1WidthRxTx Enumeration

IRD

Lm49352TypeAudioPort1WidthRxTx Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort1WidthRxTx
Public Enumeration TypeAudioPort1WidthRxTx
public enum class TypeAudioPort1WidthRxTx
type TypeAudioPort1WidthRxTx
Members
Member name | Value | Description
Value_24 | 0 | 24
Value_20 | 1 | 20
Value_18 | 2 | 18
Value_16 | 3 | 16
Value_14 | 4 | 14
Value_13 | 5 | 13
Value_12 | 6 | 12
Value_8 | 7 | 8
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort2LSel Enumeration

IRD

Lm49352TypeAudioPort2LSel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort2LSel
Public Enumeration TypeAudioPort2LSel
public enum class TypeAudioPort2LSel
type TypeAudioPort2LSel
Members
Member name | Value | Description
None | 0 | None
ADCL | 1 | ADC_L
PORT1RXL | 2 | PORT1_RX_L
DACINTERPL | 3 | DAC_INTERP_L
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort2RSel Enumeration

IRD

Lm49352TypeAudioPort2RSel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort2RSel
Public Enumeration TypeAudioPort2RSel
public enum class TypeAudioPort2RSel
type TypeAudioPort2RSel
Members
Member name | Value | Description
None | 0 | None
ADCR | 1 | ADC_R
PORT1RXR | 2 | PORT1_RX_R
DACINTERPR | 3 | DAC_INTERP_R
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPort2Swap Enumeration

IRD

Lm49352TypeAudioPort2Swap Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPort2Swap
Public Enumeration TypeAudioPort2Swap
public enum class TypeAudioPort2Swap
type TypeAudioPort2Swap
Members
Member name | Value | Description
LeftAndRightOutputNotSwappedToAudioPort2 | 0 | Left And Right Output Not Swapped To Audio Port 2
LeftAndRightOutputSwappedToAudioPort2 | 1 | Left And Right Output Swapped To Audio Port 2
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAudioPortBasicClockPhase Enumeration

IRD

Lm49352TypeAudioPortBasicClockPhase Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioPortBasicClockPhase
Public Enumeration TypeAudioPortBasicClockPhase
public enum class TypeAudioPortBasicClockPhase
type TypeAudioPortBasicClockPhase
Members
Member name | Value | Description
I2S | 0 | I2S
PCM | 1 | PCM
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAuxLevelSediff Enumeration

IRD

Lm49352TypeAuxLevelSediff Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAuxLevelSediff
Public Enumeration TypeAuxLevelSediff
public enum class TypeAuxLevelSediff
type TypeAuxLevelSediff
Members
Member name | Value | Description
AUXLInputNotIgnored | 0 | AUXL Input: Not Ignored
AUXLInputIgnored | 1 | AUXL Input: Ignored
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAuxOutAux Enumeration

IRD

Lm49352TypeAuxOutAux Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAuxOutAux
Public Enumeration TypeAuxOutAux
public enum class TypeAuxOutAux
type TypeAuxOutAux
Members
Member name | Value | Description
AUXInputNotAddedToRightAUXOutput | 0 | AUX Input Not Added To Right AUX Output
AUXInputAddedToRightAUXOutput | 1 | AUX Input Added To Right AUX Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAuxOutDacl Enumeration

IRD

Lm49352TypeAuxOutDacl Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAuxOutDacl
Public Enumeration TypeAuxOutDacl
public enum class TypeAuxOutDacl
type TypeAuxOutDacl
Members
Member name | Value | Description
LeftDACOutputNotAddedToRightAUXOutput | 0 | Left DAC Output Not Added To Right AUX Output
LeftDACOutputAddedToRightAUXOutput | 1 | Left DAC Output Added To Right AUX Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAuxOutDacr Enumeration

IRD

Lm49352TypeAuxOutDacr Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAuxOutDacr
Public Enumeration TypeAuxOutDacr
public enum class TypeAuxOutDacr
type TypeAuxOutDacr
Members
Member name | Value | Description
RightDACOutputNotAddedToRightAUXOutput | 0 | Right DAC Output Not Added To Right AUX Output
RightDACOutputAddedToRightAUXOutput | 1 | Right DAC Output Added To Right AUX Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAuxOutMic Enumeration

IRD

Lm49352TypeAuxOutMic Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAuxOutMic
Public Enumeration TypeAuxOutMic
public enum class TypeAuxOutMic
type TypeAuxOutMic
Members
Member name | Value | Description
MICInputNotAddedToRightAUXOutput | 0 | MIC Input Not Added To Right AUX Output
MICInputAddedToRightAUXOutput | 1 | MIC Input Added To Right AUX Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeAuxOutMono Enumeration

IRD

Lm49352TypeAuxOutMono Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAuxOutMono
Public Enumeration TypeAuxOutMono
public enum class TypeAuxOutMono
type TypeAuxOutMono
Members
Member name | Value | Description
MonoInputNotAddedToRightAUXOutput | 0 | Mono Input Not Added To Right AUX Output
MonoInputAddedToRightAUXOutput | 1 | Mono Input Added To Right AUX Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeClassDAux Enumeration

IRD

Lm49352TypeClassDAux Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClassDAux
Public Enumeration TypeClassDAux
public enum class TypeClassDAux
type TypeClassDAux
Members
Member name | Value | Description
AUXInputNotAddedToLoudspeakerOutput | 0 | AUX Input Not Added To Loudspeaker Output
AUXInputAddedToLoudspeakerOutput | 1 | AUX Input Added To Loudspeaker Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeClassDDacl Enumeration

IRD

Lm49352TypeClassDDacl Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClassDDacl
Public Enumeration TypeClassDDacl
public enum class TypeClassDDacl
type TypeClassDDacl
Members
Member name | Value | Description
LeftDACNotAddedToLoudspeakerOutput | 0 | Left DAC Not Added To Loudspeaker Output
LeftDACAddedToLoudspeakerOutput | 1 | Left DAC Added To Loudspeaker Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeClassDDacr Enumeration

IRD

Lm49352TypeClassDDacr Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClassDDacr
Public Enumeration TypeClassDDacr
public enum class TypeClassDDacr
type TypeClassDDacr
Members
Member name | Value | Description
RightDACNotAddedToLoudspeakerOutput | 0 | Right DAC Not Added To Loudspeaker Output
RightDACAddedToLoudspeakerOutput | 1 | Right DAC Added To Loudspeaker Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeClassDMono Enumeration

IRD

Lm49352TypeClassDMono Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClassDMono
Public Enumeration TypeClassDMono
public enum class TypeClassDMono
type TypeClassDMono
Members
Member name | Value | Description
MonoInputNotAddedToLoudspeakerOutput | 0 | Mono Input Not Added To Loudspeaker Output
MonoInputAddedToLoudspeakerOutput | 1 | Mono Input Added To Loudspeaker Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDacBasicClock Enumeration

IRD

Lm49352TypeDacBasicClock Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacBasicClock
Public Enumeration TypeDacBasicClock
public enum class TypeDacBasicClock
type TypeDacBasicClock
Members
Member name | Value | Description
DACClockDomainMCLK | 0 | DAC Clock Domain: MCLK
DACClockDomainPORT1RXCLK | 1 | DAC Clock Domain: PORT1_RX_CLK
DACClockDomainPORT2RXCLK | 2 | DAC Clock Domain: PORT2_RX_CLK
DACClockDomainPLLOUTPUT1 | 3 | DAC Clock Domain: PLL_OUTPUT1
DACClockDomainPLLOUTPUT2 | 4 | DAC Clock Domain: PLL_OUTPUT2
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDacBasicDspOnly Enumeration

IRD

Lm49352TypeDacBasicDspOnly Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacBasicDspOnly
Public Enumeration TypeDacBasicDspOnly
public enum class TypeDacBasicDspOnly
type TypeDacBasicDspOnly
Members
Member name | Value | Description
DACAnalogCircuitNotDisabled | 0 | DAC Analog Circuit: Not Disabled
DACAnalogCircuitDisabled | 1 | DAC Analog Circuit: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDacBasicMode Enumeration

IRD

Lm49352TypeDacBasicMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacBasicMode
Public Enumeration TypeDacBasicMode
public enum class TypeDacBasicMode
type TypeDacBasicMode
Members
Member name | Value | Description
Value_125 | 0 | 125
Value_128 | 1 | 128
Value_64 | 2 | 64
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDacBasicMuteL Enumeration

IRD

Lm49352TypeDacBasicMuteL Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacBasicMuteL
Public Enumeration TypeDacBasicMuteL
public enum class TypeDacBasicMuteL
type TypeDacBasicMuteL
Members
Member name | Value | Description
LeftDACOutputNotMuted | 0 | Left DAC Output: Not Muted
LeftDACOutputMuted | 1 | Left DAC Output: Muted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDacBasicMuteR Enumeration

IRD

Lm49352TypeDacBasicMuteR Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacBasicMuteR
Public Enumeration TypeDacBasicMuteR
public enum class TypeDacBasicMuteR
type TypeDacBasicMuteR
Members
Member name | Value | Description
RightDACOutputNotMuted | 0 | Right DAC Output: Not Muted
RightDACOutputMuted | 1 | Right DAC Output: Muted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDacFxAlc Enumeration

IRD

Lm49352TypeDacFxAlc Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacFxAlc
Public Enumeration TypeDacFxAlc
public enum class TypeDacFxAlc
type TypeDacFxAlc
Members
Member name | Value | Description
DACAutomaticLevelControlDisabled | 0 | DAC Automatic Level Control: Disabled
DACAutomaticLevelControlEnabled | 1 | DAC Automatic Level Control: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDacFxEq Enumeration

IRD

Lm49352TypeDacFxEq Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacFxEq
Public Enumeration TypeDacFxEq
public enum class TypeDacFxEq
type TypeDacFxEq
Members
Member name | Value | Description
DAC5BandParametricEQDisabled | 0 | DAC 5-Band Parametric EQ: Disabled
DAC5BandParametricEQEnabled | 1 | DAC 5-Band Parametric EQ: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDacFxPk Enumeration

IRD

Lm49352TypeDacFxPk Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacFxPk
Public Enumeration TypeDacFxPk
public enum class TypeDacFxPk
type TypeDacFxPk
Members
Member name | Value | Description
DACPeakDetectorDisabled | 0 | DAC Peak Detector: Disabled
DACPeakDetectorEnabled | 1 | DAC Peak Detector: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDacFxSclp Enumeration

IRD

Lm49352TypeDacFxSclp Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacFxSclp
Public Enumeration TypeDacFxSclp
public enum class TypeDacFxSclp
type TypeDacFxSclp
Members
Member name | Value | Description
DACSoftClipFeatureDisabled | 0 | DAC Soft Clip Feature: Disabled
DACSoftClipFeatureEnabled | 1 | DAC Soft Clip Feature: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDacInputAdcL Enumeration

IRD

Lm49352TypeDacInputAdcL Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacInputAdcL
Public Enumeration TypeDacInputAdcL
public enum class TypeDacInputAdcL
type TypeDacInputAdcL
Members
Member name | Value | Description
ADCLeftOutputNotAddedToDACLeftInput | 0 | ADC Left Output Not Added To DAC Left Input
ADCLeftOutputAddedToDACLeftInput | 1 | ADC Left Output Added To DAC Left Input
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDacInputAdcR Enumeration

IRD

Lm49352TypeDacInputAdcR Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacInputAdcR
Public Enumeration TypeDacInputAdcR
public enum class TypeDacInputAdcR
type TypeDacInputAdcR
Members
Member name | Value | Description
ADCRightOutputNotAddedToDACRightInput | 0 | ADC Right Output Not Added To DAC Right Input
ADCRightOutputAddedToDACRightInput | 1 | ADC Right Output Added To DAC Right Input
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDacInputPort1L Enumeration

IRD

Lm49352TypeDacInputPort1L Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacInputPort1L
Public Enumeration TypeDacInputPort1L
public enum class TypeDacInputPort1L
type TypeDacInputPort1L
Members
Member name | Value | Description
AudioPort1LeftRXChannelNotAddedToDACLeftInput | 0 | Audio Port1 Left RX Channel Not Added To DAC Left Input
AudioPort1LeftRXChannelAddedToDACLeftInput | 1 | Audio Port1 Left RX Channel Added To DAC Left Input
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDacInputPort1R Enumeration

IRD

Lm49352TypeDacInputPort1R Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacInputPort1R
Public Enumeration TypeDacInputPort1R
public enum class TypeDacInputPort1R
type TypeDacInputPort1R
Members
Member name | Value | Description
AudioPort1RightRXChannelNotAddedToDACRightInput | 0 | Audio Port1 Right RX Channel Not Added To DAC Right Input
AudioPort1RightRXChannelAddedToDACRightInput | 1 | Audio Port1 Right RX Channel Added To DAC Right Input
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDacInputPort2L Enumeration

IRD

Lm49352TypeDacInputPort2L Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacInputPort2L
Public Enumeration TypeDacInputPort2L
public enum class TypeDacInputPort2L
type TypeDacInputPort2L
Members
Member name | Value | Description
AudioPort2LeftRXChannelNotAddedToDACLeftInput | 0 | Audio Port2 Left RX Channel Not Added To DAC Left Input
AudioPort2LeftRXChannelAddedToDACLeftInput | 1 | Audio Port2 Left RX Channel Added To DAC Left Input
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDacInputPort2R Enumeration

IRD

Lm49352TypeDacInputPort2R Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacInputPort2R
Public Enumeration TypeDacInputPort2R
public enum class TypeDacInputPort2R
type TypeDacInputPort2R
Members
Member name | Value | Description
AudioPort2RightRXChannelNotAddedToDACRightInput | 0 | Audio Port2 Right RX Channel Not Added To DAC Right Input
AudioPort2RightRXChannelAddedToDACRightInput | 1 | Audio Port2 Right RX Channel Added To DAC Right Input
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDacInputSwap Enumeration

IRD

Lm49352TypeDacInputSwap Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacInputSwap
Public Enumeration TypeDacInputSwap
public enum class TypeDacInputSwap
type TypeDacInputSwap
Members
Member name | Value | Description
LeftAndRightInputNotSwappedToDAC | 0 | Left And Right Input Not Swapped To DAC
LeftAndRightInputSwappedToDAC | 1 | Left And Right Input Swapped To DAC
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDecimatorInputLSel Enumeration

IRD

Lm49352TypeDecimatorInputLSel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDecimatorInputLSel
Public Enumeration TypeDecimatorInputLSel
public enum class TypeDecimatorInputLSel
type TypeDecimatorInputLSel
Members
Member name | Value | Description
LeftADCDecimatorInputNone | 0 | Left ADC Decimator Input: None
LeftADCDecimatorInputPORT1RXL | 1 | Left ADC Decimator Input: PORT1_RX_L
LeftADCDecimatorInputPORT2RXL | 2 | Left ADC Decimator Input: PORT2_RX_L
LeftADCDecimatorInputDACINTERPL | 3 | Left ADC Decimator Input: DAC_INTERP_L
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDecimatorInputMxrClk Enumeration

IRD

Lm49352TypeDecimatorInputMxrClk Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDecimatorInputMxrClk
Public Enumeration TypeDecimatorInputMxrClk
public enum class TypeDecimatorInputMxrClk
type TypeDecimatorInputMxrClk
Members
Member name | Value | Description
DigitalMixerClockSourceAuto | 0 | Digital Mixer Clock Source: Auto
DigitalMixerClockSourceMCLK | 1 | Digital Mixer Clock Source: MCLK
DigitalMixerClockSourceDAC | 2 | Digital Mixer Clock Source: DAC
DigitalMixerClockSourceADC | 3 | Digital Mixer Clock Source: ADC
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeDecimatorInputRSel Enumeration

IRD

Lm49352TypeDecimatorInputRSel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDecimatorInputRSel
Public Enumeration TypeDecimatorInputRSel
public enum class TypeDecimatorInputRSel
type TypeDecimatorInputRSel
Members
Member name | Value | Description
RightADCDecimatorInputNone | 0 | Right ADC Decimator Input: None
RightADCDecimatorInputPORT1RXR | 1 | Right ADC Decimator Input: PORT1_RX_R
RightADCDecimatorInputPORT2RXR | 2 | Right ADC Decimator Input: PORT2_RX_R
RightADCDecimatorInputDACINTERPR | 3 | Right ADC Decimator Input: DAC_INTERP_R
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeForceCp Enumeration

IRD

Lm49352TypeForceCp Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeForceCp
Public Enumeration TypeForceCp
public enum class TypeForceCp
type TypeForceCp
Members
Member name | Value | Description
HPVSSLSVDDRailNotGenerated | 0 | HP_VSS: LS_VDD Rail Not Generated
HPVSSLSVDDRailGenerated | 1 | HP_VSS: LS_VDD Rail Generated
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeForceDac Enumeration

IRD

Lm49352TypeForceDac Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeForceDac
Public Enumeration TypeForceDac
public enum class TypeForceDac
type TypeForceDac
Members
Member name | Value | Description
DACREFUsesInternalBandgapReference | 0 | DACREF Uses Internal Bandgap Reference
DACREFIsDrivenByExternalVoltageReference | 1 | DACREF Is Driven By External Voltage Reference
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeGpio1Mode Enumeration

IRD

Lm49352TypeGpio1Mode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpio1Mode
Public Enumeration TypeGpio1Mode
public enum class TypeGpio1Mode
type TypeGpio1Mode
Members
Member name | Value | Description
GPIOModeDisabled | 0 | GPIO Mode Disabled
GPIORXIn | 1 | GPIO_RX (in)
CHIPENABLEIn | 2 | CHIP_ENABLE (in)
CHIPENABLEIn__1 | 3 | ^CHIP_ENABLE (in)
ADCMUTEIn | 4 | ADC_MUTE (in)
ADCMUTEIn__1 | 5 | ^ADC_MUTE (in)
HPSENSEIn | 6 | HP_SENSE (in)
HPSENSEIn__1 | 7 | ^HP_SENSE (in)
SPAREIn | 8 | SPARE (in)
SPAREIn__1 | 9 | ^SPARE (in)
GPIOTXOut | 10 | GPIO_TX (out)
CHIPACTIVEOut | 11 | CHIP_ACTIVE (out)
CHIPACTIVEOut__1 | 12 | ^CHIP_ACTIVE (out)
HPENABLEOut | 13 | HP_ENABLE (out)
HPENABLEOut__1 | 14 | ^HP_ENABLE (out)
LSENABLEOut | 15 | LS_ENABLE (out)
LSENABLEOut__1 | 16 | ^LS_ENABLE (out)
EPENABLEOut | 17 | EP_ENABLE (out)
EPENABLEOut__1 | 18 | ^EP_ENABLE (out)
ADCCLIPPEDOut | 19 | ADC_CLIPPED (out)
ADCCLIPPEDOut__1 | 20 | ^ADC_CLIPPED (out)
DACCLIPPEDOut | 21 | DAC_CLIPPED (out)
DACCLIPPEDOut__1 | 22 | ^DAC_CLIPPED (out)
SOMETHINGCLIPPEDOut | 23 | SOMETHING_CLIPPED (out)
SOMETHINGCLIPPEDOut__1 | 24 | ^SOMETHING_CLIPPED (out)
ADCNGACTIVEOut | 25 | ADC_NG_ACTIVE (out)
ADCNGACTIVEOut__1 | 26 | ^ADC_NG_ACTIVE (out)
DACNGACTIVEOut | 27 | DAC_NG_ACTIVE (out)
DACNGACTIVEOut__1 | 28 | ^DAC_NG_ACTIVE (out)
THERMALOut | 29 | THERMAL (out)
THERMALOut__1 | 30 | ^THERMAL (out)
LSSHORTCCTOut | 31 | LS_SHORT_CCT (out)
LSSHORTCCTOut__1 | 32 | ^LS_SHORT_CCT (out)
ANALOGERROROut | 33 | ANALOG_ERROR (out)
ANALOGERROROut__1 | 34 | ^ANALOG_ERROR (out)
ERROROut | 35 | ERROR (out)
ERROROut__1 | 36 | ^ERROR (out)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeGpio1Rx Enumeration

IRD

Lm49352TypeGpio1Rx Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpio1Rx
Public Enumeration TypeGpio1Rx
public enum class TypeGpio1Rx
type TypeGpio1Rx
Members
Member name | Value | Description
GPIOInputLogicalLow | 0 | GPIO Input: Logical Low
GPIOInputLogicalHigh | 1 | GPIO Input: Logical High
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeGpio1Tx Enumeration

IRD

Lm49352TypeGpio1Tx Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpio1Tx
Public Enumeration TypeGpio1Tx
public enum class TypeGpio1Tx
type TypeGpio1Tx
Members
Member name | Value | Description
GPIOOutputResultLogicalLow | 0 | GPIO Output Result: Logical Low
GPIOOutputResultLogicalHigh | 1 | GPIO Output Result: Logical High
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeGpio2Short Enumeration

IRD

Lm49352TypeGpio2Short Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpio2Short
Public Enumeration TypeGpio2Short
public enum class TypeGpio2Short
type TypeGpio2Short
Members
Member name | Value | Description
ShortCirciutEventOnClassDLoudspeakerNotOccurred | 0 | Short Circiut Event On Class D Loudspeaker: Not Occurred
ShortCirciutEventOnClassDLoudspeakerOccurred | 1 | Short Circiut Event On Class D Loudspeaker: Occurred
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeGpio2Temp Enumeration

IRD

Lm49352TypeGpio2Temp Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGpio2Temp
Public Enumeration TypeGpio2Temp
public enum class TypeGpio2Temp
type TypeGpio2Temp
Members
Member name | Value | Description
CriticalDeviceTemperatureNotReached | 0 | Critical Device Temperature: Not Reached
CriticalDeviceTemperatureReached | 1 | Critical Device Temperature: Reached
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeHeadphonesLAux Enumeration

IRD

Lm49352TypeHeadphonesLAux Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphonesLAux
Public Enumeration TypeHeadphonesLAux
public enum class TypeHeadphonesLAux
type TypeHeadphonesLAux
Members
Member name | Value | Description
AUXInputNotAddedToLeftHeadphoneOutput | 0 | AUX Input Not Added To Left Headphone Output
AUXInputAddedToLeftHeadphoneOutput | 1 | AUX Input Added To Left Headphone Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeHeadphonesLDacl Enumeration

IRD

Lm49352TypeHeadphonesLDacl Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphonesLDacl
Public Enumeration TypeHeadphonesLDacl
public enum class TypeHeadphonesLDacl
type TypeHeadphonesLDacl
Members
Member name | Value | Description
LeftDACOutputNotAddedToLeftHeadphoneOutput | 0 | Left DAC Output Not Added To Left Headphone Output
LeftDACOutputAddedToLeftHeadphoneOutput | 1 | Left DAC Output Added To Left Headphone Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeHeadphonesLDacr Enumeration

IRD

Lm49352TypeHeadphonesLDacr Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphonesLDacr
Public Enumeration TypeHeadphonesLDacr
public enum class TypeHeadphonesLDacr
type TypeHeadphonesLDacr
Members
Member name | Value | Description
RightDACOutputNotAddedToLeftHeadphoneOutput | 0 | Right DAC Output Not Added To Left Headphone Output
RightDACOutputAddedToLeftHeadphoneOutput | 1 | Right DAC Output Added To Left Headphone Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeHeadphonesLMono Enumeration

IRD

Lm49352TypeHeadphonesLMono Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphonesLMono
Public Enumeration TypeHeadphonesLMono
public enum class TypeHeadphonesLMono
type TypeHeadphonesLMono
Members
Member name | Value | Description
MonoInputNotAddedToLeftHeadphoneOutput | 0 | Mono Input Not Added To Left Headphone Output
MonoInputAddedToLeftHeadphoneOutput | 1 | Mono Input Added To Left Headphone Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeHeadphonesRAux Enumeration

IRD

Lm49352TypeHeadphonesRAux Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphonesRAux
Public Enumeration TypeHeadphonesRAux
public enum class TypeHeadphonesRAux
type TypeHeadphonesRAux
Members
Member name | Value | Description
AUXInputNotAddedToRightHeadphoneOutput | 0 | AUX Input Not Added To Right Headphone Output
AUXInputAddedToRightHeadphoneOutput | 1 | AUX Input Added To Right Headphone Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeHeadphonesRDacl Enumeration

IRD

Lm49352TypeHeadphonesRDacl Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphonesRDacl
Public Enumeration TypeHeadphonesRDacl
public enum class TypeHeadphonesRDacl
type TypeHeadphonesRDacl
Members
Member name | Value | Description
LeftDACOutputNotAddedToRightHeadphoneOutput | 0 | Left DAC Output Not Added To Right Headphone Output
LeftDACOutputAddedToRightHeadphoneOutput | 1 | Left DAC Output Added To Right Headphone Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeHeadphonesRDacr Enumeration

IRD

Lm49352TypeHeadphonesRDacr Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphonesRDacr
Public Enumeration TypeHeadphonesRDacr
public enum class TypeHeadphonesRDacr
type TypeHeadphonesRDacr
Members
Member name | Value | Description
RightDACOutputNotAddedToRightHeadphoneOutput | 0 | Right DAC Output Not Added To Right Headphone Output
RightDACOutputAddedToRightHeadphoneOutput | 1 | Right DAC Output Added To Right Headphone Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeHeadphonesRMono Enumeration

IRD

Lm49352TypeHeadphonesRMono Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHeadphonesRMono
Public Enumeration TypeHeadphonesRMono
public enum class TypeHeadphonesRMono
type TypeHeadphonesRMono
Members
Member name | Value | Description
MonoInputNotAddedToRightHeadphoneOutput | 0 | Mono Input Not Added To Right Headphone Output
MonoInputAddedToRightHeadphoneOutput | 1 | Mono Input Added To Right Headphone Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeHpfMode Enumeration

IRD

Lm49352TypeHpfMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHpfMode
Public Enumeration TypeHpfMode
public enum class TypeHpfMode
type TypeHpfMode
Members
Member name | Value | Description
Value_8KHzVoice | 0 | 8 kHz Voice
Value_12KHzVoice | 1 | 12 kHz Voice
Value_16KHzVoice | 2 | 16 kHz Voice
Value_24KHzVoice | 3 | 24 kHz Voice
Value_32KHzVoice | 4 | 32 kHz Voice
Value_32KHzAudio | 5 | 32 kHz Audio
Value_48KHzAudio | 6 | 48 kHz Audio
Value_96KHzAudio | 7 | 96 kHz Audio
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeHpSenseAux Enumeration

IRD

Lm49352TypeHpSenseAux Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHpSenseAux
Public Enumeration TypeHpSenseAux
public enum class TypeHpSenseAux
type TypeHpSenseAux
Members
Member name | Value | Description
HeadphoneSenseCircuitDisabled | 0 | Headphone Sense Circuit: Disabled
HeadphoneSenseCircuitEnabledInsertionAUXAmpOffRemovalAUXAmpOn | 1 | Headphone Sense Circuit: Enabled (Insertion: AUX Amp Off / Removal: AUX Amp On)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeHpSenseAuxD Enumeration

IRD

Lm49352TypeHpSenseAuxD Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHpSenseAuxD
Public Enumeration TypeHpSenseAuxD
public enum class TypeHpSenseAuxD
type TypeHpSenseAuxD
Members
Member name | Value | Description
HeadphoneSenseCircuitDisabled | 0 | Headphone Sense Circuit: Disabled
HeadphoneSenseCircuitEnabledInsertionHPAUXAmpOffRemovalHPAUXAmpOn | 1 | Headphone Sense Circuit: Enabled (Insertion: HP+AUX Amp Off / Removal: HP+AUX Amp On)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeHpSenseClassD Enumeration

IRD

Lm49352TypeHpSenseClassD Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHpSenseClassD
Public Enumeration TypeHpSenseClassD
public enum class TypeHpSenseClassD
type TypeHpSenseClassD
Members
Member name | Value | Description
HeadphoneSenseCircuitDisabled | 0 | Headphone Sense Circuit: Disabled
HeadphoneSenseCircuitEnabledInsertionSpeakerAmpOffRemovalSpeakerAmpOn | 1 | Headphone Sense Circuit: Enabled (Insertion: Speaker Amp Off / Removal: Speaker Amp On)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeHpSenseGeneral Enumeration

IRD

Lm49352TypeHpSenseGeneral Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHpSenseGeneral
Public Enumeration TypeHpSenseGeneral
public enum class TypeHpSenseGeneral
type TypeHpSenseGeneral
Members
Member name | Value | Description
HeadphoneSenseCircuitDisabled | 0 | Headphone Sense Circuit: Disabled
HeadphoneSenseCircuitEnabledInsertionHPAmpOnRemovalHPAmpOff | 1 | Headphone Sense Circuit: Enabled (Insertion: HP Amp On / Removal: HP Amp Off)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeMicInputMute Enumeration

IRD

Lm49352TypeMicInputMute Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMicInputMute
Public Enumeration TypeMicInputMute
public enum class TypeMicInputMute
type TypeMicInputMute
Members
Member name | Value | Description
MicrophonePreAmpNotMuted | 0 | Microphone Pre-Amp: Not Muted
MicrophonePreAmpMuted | 1 | Microphone Pre-Amp: Muted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeMicInputSediff Enumeration

IRD

Lm49352TypeMicInputSediff Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMicInputSediff
Public Enumeration TypeMicInputSediff
public enum class TypeMicInputSediff
type TypeMicInputSediff
Members
Member name | Value | Description
MICNegativInputNotIgnored | 0 | MIC Negativ Input: Not Ignored
MICNegativInputIgnored | 1 | MIC Negativ Input: Ignored
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeMonoLevelMono Enumeration

IRD

Lm49352TypeMonoLevelMono Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMonoLevelMono
Public Enumeration TypeMonoLevelMono
public enum class TypeMonoLevelMono
type TypeMonoLevelMono
Members
Member name | Value | Description
AUXLIsNotRoutedToMonoInputAmplifier | 0 | AUXL Is Not Routed To Mono Input Amplifier
AUXLIsRoutedToMonoInputAmplifier | 1 | AUXL Is Routed To Mono Input Amplifier
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeMonoLevelSediff Enumeration

IRD

Lm49352TypeMonoLevelSediff Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMonoLevelSediff
Public Enumeration TypeMonoLevelSediff
public enum class TypeMonoLevelSediff
type TypeMonoLevelSediff
Members
Member name | Value | Description
MonoInputNotIgnored | 0 | Mono Input: Not Ignored
MonoInputIgnored | 1 | Mono Input: Ignored
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeOutputOptionsAuxLine Enumeration

IRD

Lm49352TypeOutputOptionsAuxLine Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputOptionsAuxLine
Public Enumeration TypeOutputOptionsAuxLine
public enum class TypeOutputOptionsAuxLine
type TypeOutputOptionsAuxLine
Members
Member name | Value | Description
EarpieceAmplifier | 0 | Earpiece Amplifier
AUXLINEOUT | 1 | AUX_LINE_OUT
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeOutputOptionsAuxNeg Enumeration

IRD

Lm49352TypeOutputOptionsAuxNeg Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputOptionsAuxNeg
Public Enumeration TypeOutputOptionsAuxNeg
public enum class TypeOutputOptionsAuxNeg
type TypeOutputOptionsAuxNeg
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_M_6 | 1 | -6
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeOutputOptionsHpLevel Enumeration

IRD

Lm49352TypeOutputOptionsHpLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputOptionsHpLevel
Public Enumeration TypeOutputOptionsHpLevel
public enum class TypeOutputOptionsHpLevel
type TypeOutputOptionsHpLevel
Members
Member name | Value | Description
Value_0_0 | 0 | 0.0
Value_M_1_5 | 1 | -1.5
Value_M_3_0 | 2 | -3.0
Value_M_6_0 | 3 | -6.0
Value_M_9_0 | 4 | -9.0
Value_M_12_0 | 5 | -12.0
Value_M_15_0 | 6 | -15.0
Value_M_18_0 | 7 | -18.0
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeOutputOptionsLsLevel Enumeration

IRD

Lm49352TypeOutputOptionsLsLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputOptionsLsLevel
Public Enumeration TypeOutputOptionsLsLevel
public enum class TypeOutputOptionsLsLevel
type TypeOutputOptionsLsLevel
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_4 | 1 | 4
Value_8 | 2 | 8
Value_12 | 3 | 12
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypePllClkSel Enumeration

IRD

Lm49352TypePllClkSel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllClkSel
Public Enumeration TypePllClkSel
public enum class TypePllClkSel
type TypePllClkSel
Members
Member name | Value | Description
MCLK | 0 | MCLK
PORT1CLK | 1 | PORT1_CLK
PORT2CLK | 2 | PORT2_CLK
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypePllM Enumeration

IRD

Lm49352TypePllM Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllM
Public Enumeration TypePllM
public enum class TypePllM
type TypePllM
Members
Member name | Value | Description
Value_1 | 0 | 1
Value_1_5 | 2 | 1.5
Value_2_0 | 3 | 2.0
Value_2_5 | 4 | 2.5
Value_3_0 | 5 | 3.0
Value_3_5 | 6 | 3.5
Value_4_0 | 7 | 4.0
Value_4_5 | 8 | 4.5
Value_5_0 | 9 | 5.0
Value_5_5 | 10 | 5.5
Value_6_0 | 11 | 6.0
Value_6_5 | 12 | 6.5
Value_7_0 | 13 | 7.0
Value_7_5 | 14 | 7.5
Value_8_0 | 15 | 8.0
Value_8_5 | 16 | 8.5
Value_9_0 | 17 | 9.0
Value_9_5 | 18 | 9.5
Value_10_0 | 19 | 10.0
Value_10_5 | 20 | 10.5
Value_11_0 | 21 | 11.0
Value_11_5 | 22 | 11.5
Value_12_0 | 23 | 12.0
Value_12_5 | 24 | 12.5
Value_13_0 | 25 | 13.0
Value_13_5 | 26 | 13.5
Value_14_0 | 27 | 14.0
Value_14_5 | 28 | 14.5
Value_15_0 | 29 | 15.0
Value_15_5 | 30 | 15.5
Value_16_0 | 31 | 16.0
Value_16_5 | 32 | 16.5
Value_17_0 | 33 | 17.0
Value_17_5 | 34 | 17.5
Value_18_0 | 35 | 18.0
Value_18_5 | 36 | 18.5
Value_19_0 | 37 | 19.0
Value_19_5 | 38 | 19.5
Value_20_0 | 39 | 20.0
Value_20_5 | 40 | 20.5
Value_21_0 | 41 | 21.0
Value_21_5 | 42 | 21.5
Value_22_0 | 43 | 22.0
Value_22_5 | 44 | 22.5
Value_23_0 | 45 | 23.0
Value_23_5 | 46 | 23.5
Value_24_0 | 47 | 24.0
Value_24_5 | 48 | 24.5
Value_25_0 | 49 | 25.0
Value_25_5 | 50 | 25.5
Value_26_0 | 51 | 26.0
Value_26_5 | 52 | 26.5
Value_27_0 | 53 | 27.0
Value_27_5 | 54 | 27.5
Value_28_0 | 55 | 28.0
Value_28_5 | 56 | 28.5
Value_29_0 | 57 | 29.0
Value_29_5 | 58 | 29.5
Value_30_0 | 59 | 30.0
Value_30_5 | 60 | 30.5
Value_31_0 | 61 | 31.0
Value_31_5 | 62 | 31.5
Value_32_0 | 63 | 32.0
Value_32_5 | 64 | 32.5
Value_33_0 | 65 | 33.0
Value_33_5 | 66 | 33.5
Value_34_0 | 67 | 34.0
Value_34_5 | 68 | 34.5
Value_35_0 | 69 | 35.0
Value_35_5 | 70 | 35.5
Value_36_0 | 71 | 36.0
Value_36_5 | 72 | 36.5
Value_37_0 | 73 | 37.0
Value_37_5 | 74 | 37.5
Value_38_0 | 75 | 38.0
Value_38_5 | 76 | 38.5
Value_39_0 | 77 | 39.0
Value_39_5 | 78 | 39.5
Value_40_0 | 79 | 40.0
Value_40_5 | 80 | 40.5
Value_41_0 | 81 | 41.0
Value_41_5 | 82 | 41.5
Value_42_0 | 83 | 42.0
Value_42_5 | 84 | 42.5
Value_43_0 | 85 | 43.0
Value_43_5 | 86 | 43.5
Value_44_0 | 87 | 44.0
Value_44_5 | 88 | 44.5
Value_45_0 | 89 | 45.0
Value_45_5 | 90 | 45.5
Value_46_0 | 91 | 46.0
Value_46_5 | 92 | 46.5
Value_47_0 | 93 | 47.0
Value_47_5 | 94 | 47.5
Value_48_0 | 95 | 48.0
Value_48_5 | 96 | 48.5
Value_49_0 | 97 | 49.0
Value_49_5 | 98 | 49.5
Value_50_0 | 99 | 50.0
Value_50_5 | 100 | 50.5
Value_51_0 | 101 | 51.0
Value_51_5 | 102 | 51.5
Value_52_0 | 103 | 52.0
Value_52_5 | 104 | 52.5
Value_53_0 | 105 | 53.0
Value_53_5 | 106 | 53.5
Value_54_0 | 107 | 54.0
Value_54_5 | 108 | 54.5
Value_55_0 | 109 | 55.0
Value_55_5 | 110 | 55.5
Value_56_0 | 111 | 56.0
Value_56_5 | 112 | 56.5
Value_57_0 | 113 | 57.0
Value_57_5 | 114 | 57.5
Value_58_0 | 115 | 58.0
Value_58_5 | 116 | 58.5
Value_59_0 | 117 | 59.0
Value_59_5 | 118 | 59.5
Value_60_0 | 119 | 60.0
Value_60_5 | 120 | 60.5
Value_61_0 | 121 | 61.0
Value_61_5 | 122 | 61.5
Value_62_0 | 123 | 62.0
Value_62_5 | 124 | 62.5
Value_63_0 | 125 | 63.0
Value_63_5 | 126 | 63.5
Value_64_0 | 127 | 64.0
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypePllN Enumeration

IRD

Lm49352TypePllN Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllN
Public Enumeration TypePllN
public enum class TypePllN
type TypePllN
Members
Member name | Value | Description
Value_10 | 0 | 10
Value_11 | 11 | 11
Value_12 | 12 | 12
Value_13 | 13 | 13
Value_14 | 14 | 14
Value_15 | 15 | 15
Value_16 | 16 | 16
Value_17 | 17 | 17
Value_18 | 18 | 18
Value_19 | 19 | 19
Value_20 | 20 | 20
Value_21 | 21 | 21
Value_22 | 22 | 22
Value_23 | 23 | 23
Value_24 | 24 | 24
Value_25 | 25 | 25
Value_26 | 26 | 26
Value_27 | 27 | 27
Value_28 | 28 | 28
Value_29 | 29 | 29
Value_30 | 30 | 30
Value_31 | 31 | 31
Value_32 | 32 | 32
Value_33 | 33 | 33
Value_34 | 34 | 34
Value_35 | 35 | 35
Value_36 | 36 | 36
Value_37 | 37 | 37
Value_38 | 38 | 38
Value_39 | 39 | 39
Value_40 | 40 | 40
Value_41 | 41 | 41
Value_42 | 42 | 42
Value_43 | 43 | 43
Value_44 | 44 | 44
Value_45 | 45 | 45
Value_46 | 46 | 46
Value_47 | 47 | 47
Value_48 | 48 | 48
Value_49 | 49 | 49
Value_50 | 50 | 50
Value_51 | 51 | 51
Value_52 | 52 | 52
Value_53 | 53 | 53
Value_54 | 54 | 54
Value_55 | 55 | 55
Value_56 | 56 | 56
Value_57 | 57 | 57
Value_58 | 58 | 58
Value_59 | 59 | 59
Value_60 | 60 | 60
Value_61 | 61 | 61
Value_62 | 62 | 62
Value_63 | 63 | 63
Value_64 | 64 | 64
Value_65 | 65 | 65
Value_66 | 66 | 66
Value_67 | 67 | 67
Value_68 | 68 | 68
Value_69 | 69 | 69
Value_70 | 70 | 70
Value_71 | 71 | 71
Value_72 | 72 | 72
Value_73 | 73 | 73
Value_74 | 74 | 74
Value_75 | 75 | 75
Value_76 | 76 | 76
Value_77 | 77 | 77
Value_78 | 78 | 78
Value_79 | 79 | 79
Value_80 | 80 | 80
Value_81 | 81 | 81
Value_82 | 82 | 82
Value_83 | 83 | 83
Value_84 | 84 | 84
Value_85 | 85 | 85
Value_86 | 86 | 86
Value_87 | 87 | 87
Value_88 | 88 | 88
Value_89 | 89 | 89
Value_90 | 90 | 90
Value_91 | 91 | 91
Value_92 | 92 | 92
Value_93 | 93 | 93
Value_94 | 94 | 94
Value_95 | 95 | 95
Value_96 | 96 | 96
Value_97 | 97 | 97
Value_98 | 98 | 98
Value_99 | 99 | 99
Value_100 | 100 | 100
Value_101 | 101 | 101
Value_102 | 102 | 102
Value_103 | 103 | 103
Value_104 | 104 | 104
Value_105 | 105 | 105
Value_106 | 106 | 106
Value_107 | 107 | 107
Value_108 | 108 | 108
Value_109 | 109 | 109
Value_110 | 110 | 110
Value_111 | 111 | 111
Value_112 | 112 | 112
Value_113 | 113 | 113
Value_114 | 114 | 114
Value_115 | 115 | 115
Value_116 | 116 | 116
Value_117 | 117 | 117
Value_118 | 118 | 118
Value_119 | 119 | 119
Value_120 | 120 | 120
Value_121 | 121 | 121
Value_122 | 122 | 122
Value_123 | 123 | 123
Value_124 | 124 | 124
Value_125 | 125 | 125
Value_126 | 126 | 126
Value_127 | 127 | 127
Value_128 | 128 | 128
Value_129 | 129 | 129
Value_130 | 130 | 130
Value_131 | 131 | 131
Value_132 | 132 | 132
Value_133 | 133 | 133
Value_134 | 134 | 134
Value_135 | 135 | 135
Value_136 | 136 | 136
Value_137 | 137 | 137
Value_138 | 138 | 138
Value_139 | 139 | 139
Value_140 | 140 | 140
Value_141 | 141 | 141
Value_142 | 142 | 142
Value_143 | 143 | 143
Value_144 | 144 | 144
Value_145 | 145 | 145
Value_146 | 146 | 146
Value_147 | 147 | 147
Value_148 | 148 | 148
Value_149 | 149 | 149
Value_150 | 150 | 150
Value_151 | 151 | 151
Value_152 | 152 | 152
Value_153 | 153 | 153
Value_154 | 154 | 154
Value_155 | 155 | 155
Value_156 | 156 | 156
Value_157 | 157 | 157
Value_158 | 158 | 158
Value_159 | 159 | 159
Value_160 | 160 | 160
Value_161 | 161 | 161
Value_162 | 162 | 162
Value_163 | 163 | 163
Value_164 | 164 | 164
Value_165 | 165 | 165
Value_166 | 166 | 166
Value_167 | 167 | 167
Value_168 | 168 | 168
Value_169 | 169 | 169
Value_170 | 170 | 170
Value_171 | 171 | 171
Value_172 | 172 | 172
Value_173 | 173 | 173
Value_174 | 174 | 174
Value_175 | 175 | 175
Value_176 | 176 | 176
Value_177 | 177 | 177
Value_178 | 178 | 178
Value_179 | 179 | 179
Value_180 | 180 | 180
Value_181 | 181 | 181
Value_182 | 182 | 182
Value_183 | 183 | 183
Value_184 | 184 | 184
Value_185 | 185 | 185
Value_186 | 186 | 186
Value_187 | 187 | 187
Value_188 | 188 | 188
Value_189 | 189 | 189
Value_190 | 190 | 190
Value_191 | 191 | 191
Value_192 | 192 | 192
Value_193 | 193 | 193
Value_194 | 194 | 194
Value_195 | 195 | 195
Value_196 | 196 | 196
Value_197 | 197 | 197
Value_198 | 198 | 198
Value_199 | 199 | 199
Value_200 | 200 | 200
Value_201 | 201 | 201
Value_202 | 202 | 202
Value_203 | 203 | 203
Value_204 | 204 | 204
Value_205 | 205 | 205
Value_206 | 206 | 206
Value_207 | 207 | 207
Value_208 | 208 | 208
Value_209 | 209 | 209
Value_210 | 210 | 210
Value_211 | 211 | 211
Value_212 | 212 | 212
Value_213 | 213 | 213
Value_214 | 214 | 214
Value_215 | 215 | 215
Value_216 | 216 | 216
Value_217 | 217 | 217
Value_218 | 218 | 218
Value_219 | 219 | 219
Value_220 | 220 | 220
Value_221 | 221 | 221
Value_222 | 222 | 222
Value_223 | 223 | 223
Value_224 | 224 | 224
Value_225 | 225 | 225
Value_226 | 226 | 226
Value_227 | 227 | 227
Value_228 | 228 | 228
Value_229 | 229 | 229
Value_230 | 230 | 230
Value_231 | 231 | 231
Value_232 | 232 | 232
Value_233 | 233 | 233
Value_234 | 234 | 234
Value_235 | 235 | 235
Value_236 | 236 | 236
Value_237 | 237 | 237
Value_238 | 238 | 238
Value_239 | 239 | 239
Value_240 | 240 | 240
Value_241 | 241 | 241
Value_242 | 242 | 242
Value_243 | 243 | 243
Value_244 | 244 | 244
Value_245 | 245 | 245
Value_246 | 246 | 246
Value_247 | 247 | 247
Value_248 | 248 | 248
Value_249 | 249 | 249
Value_250 | 250 | 250
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypePllNMod Enumeration

IRD

Lm49352TypePllNMod Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllNMod
Public Enumeration TypePllNMod
public enum class TypePllNMod
type TypePllNMod
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_132 | 1 | 1/32
Value_232 | 2 | 2/32
Value_332 | 3 | 3/32
Value_432 | 4 | 4/32
Value_532 | 5 | 5/32
Value_632 | 6 | 6/32
Value_732 | 7 | 7/32
Value_832 | 8 | 8/32
Value_932 | 9 | 9/32
Value_1032 | 10 | 10/32
Value_1132 | 11 | 11/32
Value_1232 | 12 | 12/32
Value_1332 | 13 | 13/32
Value_1432 | 14 | 14/32
Value_1532 | 15 | 15/32
Value_1632 | 16 | 16/32
Value_1732 | 17 | 17/32
Value_1832 | 18 | 18/32
Value_1932 | 19 | 19/32
Value_2032 | 20 | 20/32
Value_2132 | 21 | 21/32
Value_2232 | 22 | 22/32
Value_2332 | 23 | 23/32
Value_2432 | 24 | 24/32
Value_2532 | 25 | 25/32
Value_2632 | 26 | 26/32
Value_2732 | 27 | 27/32
Value_2832 | 28 | 28/32
Value_2932 | 29 | 29/32
Value_3032 | 30 | 30/32
Value_3132 | 31 | 31/32
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypePllP Enumeration

IRD

Lm49352TypePllP Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllP
Public Enumeration TypePllP
public enum class TypePllP
type TypePllP
Members
Member name | Value | Description
Value_1_0 | 0 | 1.0
Value_1_5 | 2 | 1.5
Value_2_0 | 3 | 2.0
Value_2_5 | 4 | 2.5
Value_3_0 | 5 | 3.0
Value_3_5 | 6 | 3.5
Value_4_0 | 7 | 4.0
Value_4_5 | 8 | 4.5
Value_5_0 | 9 | 5.0
Value_5_5 | 10 | 5.5
Value_6_0 | 11 | 6.0
Value_6_5 | 12 | 6.5
Value_7_0 | 13 | 7.0
Value_7_5 | 14 | 7.5
Value_8_0 | 15 | 8.0
Value_8_5 | 16 | 8.5
Value_9_0 | 17 | 9.0
Value_9_5 | 18 | 9.5
Value_10_0 | 19 | 10.0
Value_10_5 | 20 | 10.5
Value_11_0 | 21 | 11.0
Value_11_5 | 22 | 11.5
Value_12_0 | 23 | 12.0
Value_12_5 | 24 | 12.5
Value_13_0 | 25 | 13.0
Value_13_5 | 26 | 13.5
Value_14_0 | 27 | 14.0
Value_14_5 | 28 | 14.5
Value_15_0 | 29 | 15.0
Value_15_5 | 30 | 15.5
Value_16_0 | 31 | 16.0
Value_16_5 | 32 | 16.5
Value_17_0 | 33 | 17.0
Value_17_5 | 34 | 17.5
Value_18_0 | 35 | 18.0
Value_18_5 | 36 | 18.5
Value_19_0 | 37 | 19.0
Value_19_5 | 38 | 19.5
Value_20_0 | 39 | 20.0
Value_20_5 | 40 | 20.5
Value_21_0 | 41 | 21.0
Value_21_5 | 42 | 21.5
Value_22_0 | 43 | 22.0
Value_22_5 | 44 | 22.5
Value_23_0 | 45 | 23.0
Value_23_5 | 46 | 23.5
Value_24_0 | 47 | 24.0
Value_24_5 | 48 | 24.5
Value_25_0 | 49 | 25.0
Value_25_5 | 50 | 25.5
Value_26_0 | 51 | 26.0
Value_26_5 | 52 | 26.5
Value_27_0 | 53 | 27.0
Value_27_5 | 54 | 27.5
Value_28_0 | 55 | 28.0
Value_28_5 | 56 | 28.5
Value_29_0 | 57 | 29.0
Value_29_5 | 58 | 29.5
Value_30_0 | 59 | 30.0
Value_30_5 | 60 | 30.5
Value_31_0 | 61 | 31.0
Value_31_5 | 62 | 31.5
Value_32_0 | 63 | 32.0
Value_32_5 | 64 | 32.5
Value_33_0 | 65 | 33.0
Value_33_5 | 66 | 33.5
Value_34_0 | 67 | 34.0
Value_34_5 | 68 | 34.5
Value_35_0 | 69 | 35.0
Value_35_5 | 70 | 35.5
Value_36_0 | 71 | 36.0
Value_36_5 | 72 | 36.5
Value_37_0 | 73 | 37.0
Value_37_5 | 74 | 37.5
Value_38_0 | 75 | 38.0
Value_38_5 | 76 | 38.5
Value_39_0 | 77 | 39.0
Value_39_5 | 78 | 39.5
Value_40_0 | 79 | 40.0
Value_40_5 | 80 | 40.5
Value_41_0 | 81 | 41.0
Value_41_5 | 82 | 41.5
Value_42_0 | 83 | 42.0
Value_42_5 | 84 | 42.5
Value_43_0 | 85 | 43.0
Value_43_5 | 86 | 43.5
Value_44_0 | 87 | 44.0
Value_44_5 | 88 | 44.5
Value_45_0 | 89 | 45.0
Value_45_5 | 90 | 45.5
Value_46_0 | 91 | 46.0
Value_46_5 | 92 | 46.5
Value_47_0 | 93 | 47.0
Value_47_5 | 94 | 47.5
Value_48_0 | 95 | 48.0
Value_48_5 | 96 | 48.5
Value_49_0 | 97 | 49.0
Value_49_5 | 98 | 49.5
Value_50_0 | 99 | 50.0
Value_50_5 | 100 | 50.5
Value_51_0 | 101 | 51.0
Value_51_5 | 102 | 51.5
Value_52_0 | 103 | 52.0
Value_52_5 | 104 | 52.5
Value_53_0 | 105 | 53.0
Value_53_5 | 106 | 53.5
Value_54_0 | 107 | 54.0
Value_54_5 | 108 | 54.5
Value_55_0 | 109 | 55.0
Value_55_5 | 110 | 55.5
Value_56_0 | 111 | 56.0
Value_56_5 | 112 | 56.5
Value_57_0 | 113 | 57.0
Value_57_5 | 114 | 57.5
Value_58_0 | 115 | 58.0
Value_58_5 | 116 | 58.5
Value_59_0 | 117 | 59.0
Value_59_5 | 118 | 59.5
Value_60_0 | 119 | 60.0
Value_60_5 | 120 | 60.5
Value_61_0 | 121 | 61.0
Value_61_5 | 122 | 61.5
Value_62_0 | 123 | 62.0
Value_62_5 | 124 | 62.5
Value_63_0 | 125 | 63.0
Value_63_5 | 126 | 63.5
Value_64_0 | 127 | 64.0
Value_64_5 | 128 | 64.5
Value_65_0 | 129 | 65.0
Value_65_5 | 130 | 65.5
Value_66_0 | 131 | 66.0
Value_66_5 | 132 | 66.5
Value_67_0 | 133 | 67.0
Value_67_5 | 134 | 67.5
Value_68_0 | 135 | 68.0
Value_68_5 | 136 | 68.5
Value_69_0 | 137 | 69.0
Value_69_5 | 138 | 69.5
Value_70_0 | 139 | 70.0
Value_70_5 | 140 | 70.5
Value_71_0 | 141 | 71.0
Value_71_5 | 142 | 71.5
Value_72_0 | 143 | 72.0
Value_72_5 | 144 | 72.5
Value_73_0 | 145 | 73.0
Value_73_5 | 146 | 73.5
Value_74_0 | 147 | 74.0
Value_74_5 | 148 | 74.5
Value_75_0 | 149 | 75.0
Value_75_5 | 150 | 75.5
Value_76_0 | 151 | 76.0
Value_76_5 | 152 | 76.5
Value_77_0 | 153 | 77.0
Value_77_5 | 154 | 77.5
Value_78_0 | 155 | 78.0
Value_78_5 | 156 | 78.5
Value_79_0 | 157 | 79.0
Value_79_5 | 158 | 79.5
Value_80_0 | 159 | 80.0
Value_80_5 | 160 | 80.5
Value_81_0 | 161 | 81.0
Value_81_5 | 162 | 81.5
Value_82_0 | 163 | 82.0
Value_82_5 | 164 | 82.5
Value_83_0 | 165 | 83.0
Value_83_5 | 166 | 83.5
Value_84_0 | 167 | 84.0
Value_84_5 | 168 | 84.5
Value_85_0 | 169 | 85.0
Value_85_5 | 170 | 85.5
Value_86_0 | 171 | 86.0
Value_86_5 | 172 | 86.5
Value_87_0 | 173 | 87.0
Value_87_5 | 174 | 87.5
Value_88_0 | 175 | 88.0
Value_88_5 | 176 | 88.5
Value_89_0 | 177 | 89.0
Value_89_5 | 178 | 89.5
Value_90_0 | 179 | 90.0
Value_90_5 | 180 | 90.5
Value_91_0 | 181 | 91.0
Value_91_5 | 182 | 91.5
Value_92_0 | 183 | 92.0
Value_92_5 | 184 | 92.5
Value_93_0 | 185 | 93.0
Value_93_5 | 186 | 93.5
Value_94_0 | 187 | 94.0
Value_94_5 | 188 | 94.5
Value_95_0 | 189 | 95.0
Value_95_5 | 190 | 95.5
Value_96_0 | 191 | 96.0
Value_96_5 | 192 | 96.5
Value_97_0 | 193 | 97.0
Value_97_5 | 194 | 97.5
Value_98_0 | 195 | 98.0
Value_98_5 | 196 | 98.5
Value_99_0 | 197 | 99.0
Value_99_5 | 198 | 99.5
Value_100_0 | 199 | 100.0
Value_100_5 | 200 | 100.5
Value_101_0 | 201 | 101.0
Value_101_5 | 202 | 101.5
Value_102_0 | 203 | 102.0
Value_102_5 | 204 | 102.5
Value_103_0 | 205 | 103.0
Value_103_5 | 206 | 103.5
Value_104_0 | 207 | 104.0
Value_104_5 | 208 | 104.5
Value_105_0 | 209 | 105.0
Value_105_5 | 210 | 105.5
Value_106_0 | 211 | 106.0
Value_106_5 | 212 | 106.5
Value_107_0 | 213 | 107.0
Value_107_5 | 214 | 107.5
Value_108_0 | 215 | 108.0
Value_108_5 | 216 | 108.5
Value_109_0 | 217 | 109.0
Value_109_5 | 218 | 109.5
Value_110_0 | 219 | 110.0
Value_110_5 | 220 | 110.5
Value_111_0 | 221 | 111.0
Value_111_5 | 222 | 111.5
Value_112_0 | 223 | 112.0
Value_112_5 | 224 | 112.5
Value_113_0 | 225 | 113.0
Value_113_5 | 226 | 113.5
Value_114_0 | 227 | 114.0
Value_114_5 | 228 | 114.5
Value_115_0 | 229 | 115.0
Value_115_5 | 230 | 115.5
Value_116_0 | 231 | 116.0
Value_116_5 | 232 | 116.5
Value_117_0 | 233 | 117.0
Value_117_5 | 234 | 117.5
Value_118_0 | 235 | 118.0
Value_118_5 | 236 | 118.5
Value_119_0 | 237 | 119.0
Value_119_5 | 238 | 119.5
Value_120_0 | 239 | 120.0
Value_120_5 | 240 | 120.5
Value_121_0 | 241 | 121.0
Value_121_5 | 242 | 121.5
Value_122_0 | 243 | 122.0
Value_122_5 | 244 | 122.5
Value_123_0 | 245 | 123.0
Value_123_5 | 246 | 123.5
Value_124_0 | 247 | 124.0
Value_124_5 | 248 | 124.5
Value_125_0 | 249 | 125.0
Value_125_5 | 250 | 125.5
Value_126_0 | 251 | 126.0
Value_126_5 | 252 | 126.5
Value_127_0 | 253 | 127.0
Value_127_5 | 254 | 127.5
Value_128_0 | 255 | 128.0
Value_128_5 | 256 | 128.5
Value_129_0 | 257 | 129.0
Value_129_5 | 258 | 129.5
Value_130_0 | 259 | 130.0
Value_130_5 | 260 | 130.5
Value_131_0 | 261 | 131.0
Value_131_5 | 262 | 131.5
Value_132_0 | 263 | 132.0
Value_132_5 | 264 | 132.5
Value_133_0 | 265 | 133.0
Value_133_5 | 266 | 133.5
Value_134_0 | 267 | 134.0
Value_134_5 | 268 | 134.5
Value_135_0 | 269 | 135.0
Value_135_5 | 270 | 135.5
Value_136_0 | 271 | 136.0
Value_136_5 | 272 | 136.5
Value_137_0 | 273 | 137.0
Value_137_5 | 274 | 137.5
Value_138_0 | 275 | 138.0
Value_138_5 | 276 | 138.5
Value_139_0 | 277 | 139.0
Value_139_5 | 278 | 139.5
Value_140_0 | 279 | 140.0
Value_140_5 | 280 | 140.5
Value_141_0 | 281 | 141.0
Value_141_5 | 282 | 141.5
Value_142_0 | 283 | 142.0
Value_142_5 | 284 | 142.5
Value_143_0 | 285 | 143.0
Value_143_5 | 286 | 143.5
Value_144_0 | 287 | 144.0
Value_144_5 | 288 | 144.5
Value_145_0 | 289 | 145.0
Value_145_5 | 290 | 145.5
Value_146_0 | 291 | 146.0
Value_146_5 | 292 | 146.5
Value_147_0 | 293 | 147.0
Value_147_5 | 294 | 147.5
Value_148_0 | 295 | 148.0
Value_148_5 | 296 | 148.5
Value_149_0 | 297 | 149.0
Value_149_5 | 298 | 149.5
Value_150_0 | 299 | 150.0
Value_150_5 | 300 | 150.5
Value_151_0 | 301 | 151.0
Value_151_5 | 302 | 151.5
Value_152_0 | 303 | 152.0
Value_152_5 | 304 | 152.5
Value_153_0 | 305 | 153.0
Value_153_5 | 306 | 153.5
Value_154_0 | 307 | 154.0
Value_154_5 | 308 | 154.5
Value_155_0 | 309 | 155.0
Value_155_5 | 310 | 155.5
Value_156_0 | 311 | 156.0
Value_156_5 | 312 | 156.5
Value_157_0 | 313 | 157.0
Value_157_5 | 314 | 157.5
Value_158_0 | 315 | 158.0
Value_158_5 | 316 | 158.5
Value_159_0 | 317 | 159.0
Value_159_5 | 318 | 159.5
Value_160_0 | 319 | 160.0
Value_160_5 | 320 | 160.5
Value_161_0 | 321 | 161.0
Value_161_5 | 322 | 161.5
Value_162_0 | 323 | 162.0
Value_162_5 | 324 | 162.5
Value_163_0 | 325 | 163.0
Value_163_5 | 326 | 163.5
Value_164_0 | 327 | 164.0
Value_164_5 | 328 | 164.5
Value_165_0 | 329 | 165.0
Value_165_5 | 330 | 165.5
Value_166_0 | 331 | 166.0
Value_166_5 | 332 | 166.5
Value_167_0 | 333 | 167.0
Value_167_5 | 334 | 167.5
Value_168_0 | 335 | 168.0
Value_168_5 | 336 | 168.5
Value_169_0 | 337 | 169.0
Value_169_5 | 338 | 169.5
Value_170_0 | 339 | 170.0
Value_170_5 | 340 | 170.5
Value_171_0 | 341 | 171.0
Value_171_5 | 342 | 171.5
Value_172_0 | 343 | 172.0
Value_172_5 | 344 | 172.5
Value_173_0 | 345 | 173.0
Value_173_5 | 346 | 173.5
Value_174_0 | 347 | 174.0
Value_174_5 | 348 | 174.5
Value_175_0 | 349 | 175.0
Value_175_5 | 350 | 175.5
Value_176_0 | 351 | 176.0
Value_176_5 | 352 | 176.5
Value_177_0 | 353 | 177.0
Value_177_5 | 354 | 177.5
Value_178_0 | 355 | 178.0
Value_178_5 | 356 | 178.5
Value_179_0 | 357 | 179.0
Value_179_5 | 358 | 179.5
Value_180_0 | 359 | 180.0
Value_180_5 | 360 | 180.5
Value_181_0 | 361 | 181.0
Value_181_5 | 362 | 181.5
Value_182_0 | 363 | 182.0
Value_182_5 | 364 | 182.5
Value_183_0 | 365 | 183.0
Value_183_5 | 366 | 183.5
Value_184_0 | 367 | 184.0
Value_184_5 | 368 | 184.5
Value_185_0 | 369 | 185.0
Value_185_5 | 370 | 185.5
Value_186_0 | 371 | 186.0
Value_186_5 | 372 | 186.5
Value_187_0 | 373 | 187.0
Value_187_5 | 374 | 187.5
Value_188_0 | 375 | 188.0
Value_188_5 | 376 | 188.5
Value_189_0 | 377 | 189.0
Value_189_5 | 378 | 189.5
Value_190_0 | 379 | 190.0
Value_190_5 | 380 | 190.5
Value_191_0 | 381 | 191.0
Value_191_5 | 382 | 191.5
Value_192_0 | 383 | 192.0
Value_192_5 | 384 | 192.5
Value_193_0 | 385 | 193.0
Value_193_5 | 386 | 193.5
Value_194_0 | 387 | 194.0
Value_194_5 | 388 | 194.5
Value_195_0 | 389 | 195.0
Value_195_5 | 390 | 195.5
Value_196_0 | 391 | 196.0
Value_196_5 | 392 | 196.5
Value_197_0 | 393 | 197.0
Value_197_5 | 394 | 197.5
Value_198_0 | 395 | 198.0
Value_198_5 | 396 | 198.5
Value_199_0 | 397 | 199.0
Value_199_5 | 398 | 199.5
Value_200_0 | 399 | 200.0
Value_200_5 | 400 | 200.5
Value_201_0 | 401 | 201.0
Value_201_5 | 402 | 201.5
Value_202_0 | 403 | 202.0
Value_202_5 | 404 | 202.5
Value_203_0 | 405 | 203.0
Value_203_5 | 406 | 203.5
Value_204_0 | 407 | 204.0
Value_204_5 | 408 | 204.5
Value_205_0 | 409 | 205.0
Value_205_5 | 410 | 205.5
Value_206_0 | 411 | 206.0
Value_206_5 | 412 | 206.5
Value_207_0 | 413 | 207.0
Value_207_5 | 414 | 207.5
Value_208_0 | 415 | 208.0
Value_208_5 | 416 | 208.5
Value_209_0 | 417 | 209.0
Value_209_5 | 418 | 209.5
Value_210_0 | 419 | 210.0
Value_210_5 | 420 | 210.5
Value_211_0 | 421 | 211.0
Value_211_5 | 422 | 211.5
Value_212_0 | 423 | 212.0
Value_212_5 | 424 | 212.5
Value_213_0 | 425 | 213.0
Value_213_5 | 426 | 213.5
Value_214_0 | 427 | 214.0
Value_214_5 | 428 | 214.5
Value_215_0 | 429 | 215.0
Value_215_5 | 430 | 215.5
Value_216_0 | 431 | 216.0
Value_216_5 | 432 | 216.5
Value_217_0 | 433 | 217.0
Value_217_5 | 434 | 217.5
Value_218_0 | 435 | 218.0
Value_218_5 | 436 | 218.5
Value_219_0 | 437 | 219.0
Value_219_5 | 438 | 219.5
Value_220_0 | 439 | 220.0
Value_220_5 | 440 | 220.5
Value_221_0 | 441 | 221.0
Value_221_5 | 442 | 221.5
Value_222_0 | 443 | 222.0
Value_222_5 | 444 | 222.5
Value_223_0 | 445 | 223.0
Value_223_5 | 446 | 223.5
Value_224_0 | 447 | 224.0
Value_224_5 | 448 | 224.5
Value_225_0 | 449 | 225.0
Value_225_5 | 450 | 225.5
Value_226_0 | 451 | 226.0
Value_226_5 | 452 | 226.5
Value_227_0 | 453 | 227.0
Value_227_5 | 454 | 227.5
Value_228_0 | 455 | 228.0
Value_228_5 | 456 | 228.5
Value_229_0 | 457 | 229.0
Value_229_5 | 458 | 229.5
Value_230_0 | 459 | 230.0
Value_230_5 | 460 | 230.5
Value_231_0 | 461 | 231.0
Value_231_5 | 462 | 231.5
Value_232_0 | 463 | 232.0
Value_232_5 | 464 | 232.5
Value_233_0 | 465 | 233.0
Value_233_5 | 466 | 233.5
Value_234_0 | 467 | 234.0
Value_234_5 | 468 | 234.5
Value_235_0 | 469 | 235.0
Value_235_5 | 470 | 235.5
Value_236_0 | 471 | 236.0
Value_236_5 | 472 | 236.5
Value_237_0 | 473 | 237.0
Value_237_5 | 474 | 237.5
Value_238_0 | 475 | 238.0
Value_238_5 | 476 | 238.5
Value_239_0 | 477 | 239.0
Value_239_5 | 478 | 239.5
Value_240_0 | 479 | 240.0
Value_240_5 | 480 | 240.5
Value_241_0 | 481 | 241.0
Value_241_5 | 482 | 241.5
Value_242_0 | 483 | 242.0
Value_242_5 | 484 | 242.5
Value_243_0 | 485 | 243.0
Value_243_5 | 486 | 243.5
Value_244_0 | 487 | 244.0
Value_244_5 | 488 | 244.5
Value_245_0 | 489 | 245.0
Value_245_5 | 490 | 245.5
Value_246_0 | 491 | 246.0
Value_246_5 | 492 | 246.5
Value_247_0 | 493 | 247.0
Value_247_5 | 494 | 247.5
Value_248_0 | 495 | 248.0
Value_248_5 | 496 | 248.5
Value_249_0 | 497 | 249.0
Value_249_5 | 498 | 249.5
Value_250_0 | 499 | 250.0
Value_250_5 | 500 | 250.5
Value_251_0 | 501 | 251.0
Value_251_5 | 502 | 251.5
Value_252_0 | 503 | 252.0
Value_252_5 | 504 | 252.5
Value_253_0 | 505 | 253.0
Value_253_5 | 506 | 253.5
Value_254_0 | 507 | 254.0
Value_254_5 | 508 | 254.5
Value_255_0 | 509 | 255.0
Value_255_5 | 510 | 255.5
Value_256_0 | 511 | 256.0
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypePmcClkDiv Enumeration

IRD

Lm49352TypePmcClkDiv Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePmcClkDiv
Public Enumeration TypePmcClkDiv
public enum class TypePmcClkDiv
type TypePmcClkDiv
Members
Member name | Value | Description
Value_1_0 | 0 | 1.0
Value_1_5 | 2 | 1.5
Value_2_0 | 3 | 2.0
Value_2_5 | 4 | 2.5
Value_3_0 | 5 | 3.0
Value_3_5 | 6 | 3.5
Value_4_0 | 7 | 4.0
Value_4_5 | 8 | 4.5
Value_5_0 | 9 | 5.0
Value_5_5 | 10 | 5.5
Value_6_0 | 11 | 6.0
Value_6_5 | 12 | 6.5
Value_7_0 | 13 | 7.0
Value_7_5 | 14 | 7.5
Value_8_0 | 15 | 8.0
Value_8_5 | 16 | 8.5
Value_9_0 | 17 | 9.0
Value_9_5 | 18 | 9.5
Value_10_0 | 19 | 10.0
Value_10_5 | 20 | 10.5
Value_11_0 | 21 | 11.0
Value_11_5 | 22 | 11.5
Value_12_0 | 23 | 12.0
Value_12_5 | 24 | 12.5
Value_13_0 | 25 | 13.0
Value_13_5 | 26 | 13.5
Value_14_0 | 27 | 14.0
Value_14_5 | 28 | 14.5
Value_15_0 | 29 | 15.0
Value_15_5 | 30 | 15.5
Value_16_0 | 31 | 16.0
Value_16_5 | 32 | 16.5
Value_17_0 | 33 | 17.0
Value_17_5 | 34 | 17.5
Value_18_0 | 35 | 18.0
Value_18_5 | 36 | 18.5
Value_19_0 | 37 | 19.0
Value_19_5 | 38 | 19.5
Value_20_0 | 39 | 20.0
Value_20_5 | 40 | 20.5
Value_21_0 | 41 | 21.0
Value_21_5 | 42 | 21.5
Value_22_0 | 43 | 22.0
Value_22_5 | 44 | 22.5
Value_23_0 | 45 | 23.0
Value_23_5 | 46 | 23.5
Value_24_0 | 47 | 24.0
Value_24_5 | 48 | 24.5
Value_25_0 | 49 | 25.0
Value_25_5 | 50 | 25.5
Value_26_0 | 51 | 26.0
Value_26_5 | 52 | 26.5
Value_27_0 | 53 | 27.0
Value_27_5 | 54 | 27.5
Value_28_0 | 55 | 28.0
Value_28_5 | 56 | 28.5
Value_29_0 | 57 | 29.0
Value_29_5 | 58 | 29.5
Value_30_0 | 59 | 30.0
Value_30_5 | 60 | 30.5
Value_31_0 | 61 | 31.0
Value_31_5 | 62 | 31.5
Value_32_0 | 63 | 32.0
Value_32_5 | 64 | 32.5
Value_33_0 | 65 | 33.0
Value_33_5 | 66 | 33.5
Value_34_0 | 67 | 34.0
Value_34_5 | 68 | 34.5
Value_35_0 | 69 | 35.0
Value_35_5 | 70 | 35.5
Value_36_0 | 71 | 36.0
Value_36_5 | 72 | 36.5
Value_37_0 | 73 | 37.0
Value_37_5 | 74 | 37.5
Value_38_0 | 75 | 38.0
Value_38_5 | 76 | 38.5
Value_39_0 | 77 | 39.0
Value_39_5 | 78 | 39.5
Value_40_0 | 79 | 40.0
Value_40_5 | 80 | 40.5
Value_41_0 | 81 | 41.0
Value_41_5 | 82 | 41.5
Value_42_0 | 83 | 42.0
Value_42_5 | 84 | 42.5
Value_43_0 | 85 | 43.0
Value_43_5 | 86 | 43.5
Value_44_0 | 87 | 44.0
Value_44_5 | 88 | 44.5
Value_45_0 | 89 | 45.0
Value_45_5 | 90 | 45.5
Value_46_0 | 91 | 46.0
Value_46_5 | 92 | 46.5
Value_47_0 | 93 | 47.0
Value_47_5 | 94 | 47.5
Value_48_0 | 95 | 48.0
Value_48_5 | 96 | 48.5
Value_49_0 | 97 | 49.0
Value_49_5 | 98 | 49.5
Value_50_0 | 99 | 50.0
Value_50_5 | 100 | 50.5
Value_51_0 | 101 | 51.0
Value_51_5 | 102 | 51.5
Value_52_0 | 103 | 52.0
Value_52_5 | 104 | 52.5
Value_53_0 | 105 | 53.0
Value_53_5 | 106 | 53.5
Value_54_0 | 107 | 54.0
Value_54_5 | 108 | 54.5
Value_55_0 | 109 | 55.0
Value_55_5 | 110 | 55.5
Value_56_0 | 111 | 56.0
Value_56_5 | 112 | 56.5
Value_57_0 | 113 | 57.0
Value_57_5 | 114 | 57.5
Value_58_0 | 115 | 58.0
Value_58_5 | 116 | 58.5
Value_59_0 | 117 | 59.0
Value_59_5 | 118 | 59.5
Value_60_0 | 119 | 60.0
Value_60_5 | 120 | 60.5
Value_61_0 | 121 | 61.0
Value_61_5 | 122 | 61.5
Value_62_0 | 123 | 62.0
Value_62_5 | 124 | 62.5
Value_63_0 | 125 | 63.0
Value_63_5 | 126 | 63.5
Value_64_0 | 127 | 64.0
Value_64_5 | 128 | 64.5
Value_65_0 | 129 | 65.0
Value_65_5 | 130 | 65.5
Value_66_0 | 131 | 66.0
Value_66_5 | 132 | 66.5
Value_67_0 | 133 | 67.0
Value_67_5 | 134 | 67.5
Value_68_0 | 135 | 68.0
Value_68_5 | 136 | 68.5
Value_69_0 | 137 | 69.0
Value_69_5 | 138 | 69.5
Value_70_0 | 139 | 70.0
Value_70_5 | 140 | 70.5
Value_71_0 | 141 | 71.0
Value_71_5 | 142 | 71.5
Value_72_0 | 143 | 72.0
Value_72_5 | 144 | 72.5
Value_73_0 | 145 | 73.0
Value_73_5 | 146 | 73.5
Value_74_0 | 147 | 74.0
Value_74_5 | 148 | 74.5
Value_75_0 | 149 | 75.0
Value_75_5 | 150 | 75.5
Value_76_0 | 151 | 76.0
Value_76_5 | 152 | 76.5
Value_77_0 | 153 | 77.0
Value_77_5 | 154 | 77.5
Value_78_0 | 155 | 78.0
Value_78_5 | 156 | 78.5
Value_79_0 | 157 | 79.0
Value_79_5 | 158 | 79.5
Value_80_0 | 159 | 80.0
Value_80_5 | 160 | 80.5
Value_81_0 | 161 | 81.0
Value_81_5 | 162 | 81.5
Value_82_0 | 163 | 82.0
Value_82_5 | 164 | 82.5
Value_83_0 | 165 | 83.0
Value_83_5 | 166 | 83.5
Value_84_0 | 167 | 84.0
Value_84_5 | 168 | 84.5
Value_85_0 | 169 | 85.0
Value_85_5 | 170 | 85.5
Value_86_0 | 171 | 86.0
Value_86_5 | 172 | 86.5
Value_87_0 | 173 | 87.0
Value_87_5 | 174 | 87.5
Value_88_0 | 175 | 88.0
Value_88_5 | 176 | 88.5
Value_89_0 | 177 | 89.0
Value_89_5 | 178 | 89.5
Value_90_0 | 179 | 90.0
Value_90_5 | 180 | 90.5
Value_91_0 | 181 | 91.0
Value_91_5 | 182 | 91.5
Value_92_0 | 183 | 92.0
Value_92_5 | 184 | 92.5
Value_93_0 | 185 | 93.0
Value_93_5 | 186 | 93.5
Value_94_0 | 187 | 94.0
Value_94_5 | 188 | 94.5
Value_95_0 | 189 | 95.0
Value_95_5 | 190 | 95.5
Value_96_0 | 191 | 96.0
Value_96_5 | 192 | 96.5
Value_97_0 | 193 | 97.0
Value_97_5 | 194 | 97.5
Value_98_0 | 195 | 98.0
Value_98_5 | 196 | 98.5
Value_99_0 | 197 | 99.0
Value_99_5 | 198 | 99.5
Value_100_0 | 199 | 100.0
Value_100_5 | 200 | 100.5
Value_101_0 | 201 | 101.0
Value_101_5 | 202 | 101.5
Value_102_0 | 203 | 102.0
Value_102_5 | 204 | 102.5
Value_103_0 | 205 | 103.0
Value_103_5 | 206 | 103.5
Value_104_0 | 207 | 104.0
Value_104_5 | 208 | 104.5
Value_105_0 | 209 | 105.0
Value_105_5 | 210 | 105.5
Value_106_0 | 211 | 106.0
Value_106_5 | 212 | 106.5
Value_107_0 | 213 | 107.0
Value_107_5 | 214 | 107.5
Value_108_0 | 215 | 108.0
Value_108_5 | 216 | 108.5
Value_109_0 | 217 | 109.0
Value_109_5 | 218 | 109.5
Value_110_0 | 219 | 110.0
Value_110_5 | 220 | 110.5
Value_111_0 | 221 | 111.0
Value_111_5 | 222 | 111.5
Value_112_0 | 223 | 112.0
Value_112_5 | 224 | 112.5
Value_113_0 | 225 | 113.0
Value_113_5 | 226 | 113.5
Value_114_0 | 227 | 114.0
Value_114_5 | 228 | 114.5
Value_115_0 | 229 | 115.0
Value_115_5 | 230 | 115.5
Value_116_0 | 231 | 116.0
Value_116_5 | 232 | 116.5
Value_117_0 | 233 | 117.0
Value_117_5 | 234 | 117.5
Value_118_0 | 235 | 118.0
Value_118_5 | 236 | 118.5
Value_119_0 | 237 | 119.0
Value_119_5 | 238 | 119.5
Value_120_0 | 239 | 120.0
Value_120_5 | 240 | 120.5
Value_121_0 | 241 | 121.0
Value_121_5 | 242 | 121.5
Value_122_0 | 243 | 122.0
Value_122_5 | 244 | 122.5
Value_123_0 | 245 | 123.0
Value_123_5 | 246 | 123.5
Value_124_0 | 247 | 124.0
Value_124_5 | 248 | 124.5
Value_125_0 | 249 | 125.0
Value_125_5 | 250 | 125.5
Value_126_0 | 251 | 126.0
Value_126_5 | 252 | 126.5
Value_127_0 | 253 | 127.0
Value_127_5 | 254 | 127.5
Value_128_0 | 255 | 128.0
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypePmcClocks Enumeration

IRD

Lm49352TypePmcClocks Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePmcClocks
Public Enumeration TypePmcClocks
public enum class TypePmcClocks
type TypePmcClocks
Members
Member name | Value | Description
MCLK | 0 | MCLK
Internal300KHzOscillator | 1 | Internal 300 kHz Oscillator
DACSOURCECLOCK | 2 | DAC SOURCE CLOCK
ADCSOURCECLOCK | 3 | ADC SOURCE CLOCK
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypePmcSetupChipActive Enumeration

IRD

Lm49352TypePmcSetupChipActive Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePmcSetupChipActive
Public Enumeration TypePmcSetupChipActive
public enum class TypePmcSetupChipActive
type TypePmcSetupChipActive
Members
Member name | Value | Description
ChipStatusDisabled | 0 | Chip Status: Disabled
ChipStatusEnabled | 1 | Chip Status: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypePmcSetupChipEnable Enumeration

IRD

Lm49352TypePmcSetupChipEnable Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePmcSetupChipEnable
Public Enumeration TypePmcSetupChipEnable
public enum class TypePmcSetupChipEnable
type TypePmcSetupChipEnable
Members
Member name | Value | Description
ChipTurnOff | 0 | Chip: Turn Off
ChipTurnOn | 1 | Chip: Turn On
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypePmcSetupMclkOvr Enumeration

IRD

Lm49352TypePmcSetupMclkOvr Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePmcSetupMclkOvr
Public Enumeration TypePmcSetupMclkOvr
public enum class TypePmcSetupMclkOvr
type TypePmcSetupMclkOvr
Members
Member name | Value | Description
IOControlAutomatic | 0 | I/O Control Automatic
MCLKInputForcedOn | 1 | MCLK Input Forced On
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypePmcSetupOscEnb Enumeration

IRD

Lm49352TypePmcSetupOscEnb Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePmcSetupOscEnb
Public Enumeration TypePmcSetupOscEnb
public enum class TypePmcSetupOscEnb
type TypePmcSetupOscEnb
Members
Member name | Value | Description
OscillatorOff | 0 | Oscillator: Off
OscillatorOn | 1 | Oscillator: On
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypePmcSetupPll Enumeration

IRD

Lm49352TypePmcSetupPll Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePmcSetupPll
Public Enumeration TypePmcSetupPll
public enum class TypePmcSetupPll
type TypePmcSetupPll
Members
Member name | Value | Description
PLLOff | 0 | PLL: Off
PLLOn | 1 | PLL: On
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypePmcSetupPllP2enb Enumeration

IRD

Lm49352TypePmcSetupPllP2enb Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePmcSetupPllP2enb
Public Enumeration TypePmcSetupPllP2enb
public enum class TypePmcSetupPllP2enb
type TypePmcSetupPllP2enb
Members
Member name | Value | Description
PLLP2Off | 0 | PLL P2: Off
PLLP2On | 1 | PLL P2: On
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypePmcSetupPortClkOvr Enumeration

IRD

Lm49352TypePmcSetupPortClkOvr Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePmcSetupPortClkOvr
Public Enumeration TypePmcSetupPortClkOvr
public enum class TypePmcSetupPortClkOvr
type TypePmcSetupPortClkOvr
Members
Member name | Value | Description
IOControlAutomatic | 0 | I/O Control Automatic
PORTCLKInputForcedOn | 1 | PORT_CLK Input Forced On
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeReset Enumeration

IRD

Lm49352TypeReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeReset
Public Enumeration TypeReset
public enum class TypeReset
type TypeReset
Members
Member name | Value | Description
DigitalCoreResetNotSet | 0 | Digital Core Reset: Not Set
DigitalCoreResetSet | 1 | Digital Core Reset: Set
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeSetNotSet Enumeration

IRD

Lm49352TypeSetNotSet Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSetNotSet
Public Enumeration TypeSetNotSet
public enum class TypeSetNotSet
type TypeSetNotSet
Members
Member name | Value | Description
NotSet | 0 | Not Set
Set | 1 | Set
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm49352.TypeSpreadSpectrum Enumeration

IRD

Lm49352TypeSpreadSpectrum Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSpreadSpectrum
Public Enumeration TypeSpreadSpectrum
public enum class TypeSpreadSpectrum
type TypeSpreadSpectrum
Members
Member name | Value | Description
SpreadSpectrumModeEnabled | 0 | Spread Spectrum Mode: Enabled
SpreadSpectrumModeDisabled | 1 | Spread Spectrum Mode: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937 Class

Texas Instruments: LM 4937
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsLm4937

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Lm4937
Public Class Lm4937
public ref class Lm4937
type Lm4937 =  class end

The Lm4937 type exposes the following members.

Constructors
 | Name | Description
Public method | Lm4937 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ClockConfigAUDIOCLKSEL | Clock Config: AUDIO_CLK_SEL
Public property | ClockConfigFASTCLOCK | Clock Config: FAST_CLOCK
Public property | ClockConfigPLLENABLE | Clock Config: PLL_ENABLE
Public property | ClockConfigPLLINPUT | Clock Config: PLL_INPUT
Public property | ClockConfigRDIV | Clock Config: R_DIV
Public property | Compensation0COMP0 | Compensation0: COMP0
Public property | Compensation1COMP1 | Compensation1: COMP1
Public property | Compensation2COMP2 | Compensation2: COMP2
Public property | DACInputDIGLGAIN | DAC Input: DIG_L_GAIN (unit: dB)
Public property | DACInputDIGRGAIN | DAC Input: DIG_R_GAIN (unit: dB)
Public property | DACInputMONOINGAIN | DAC Input: MONO_IN_GAIN (unit: dB)
Public property | DACSetupCUSTCOMP | DAC Setup: CUST_COMP
Public property | DACSetupDACMODE | DAC Setup: DAC_MODE
Public property | DACSetupDITHERALWAYSON | DAC Setup: DITHER_ALWAYS_ON
Public property | DACSetupDITHEROFF | DAC Setup: DITHER_OFF
Public property | DACSetupMUTEL | DAC Setup: MUTE_L
Public property | DACSetupMUTER | DAC Setup: MUTE_R
Public property | HeadphoneLeftHPLVOL | Headphone Left: HP_L_VOL
Public property | HeadphoneRightHPRVOL | Headphone Right: HP_R_VOL
Public property | InterfaceI2CFAST | Interface: I2C_FAST
Public property | InterfaceI2SMODE | Interface: I2S_MODE
Public property | InterfaceI2SMS | Interface: I2S_M/S
Public property | InterfaceI2SRESOL | Interface: I2S_RESOL
Public property | ModeControlCD | Mode Control: CD
Public property | ModeControlCD6 | Mode Control: CD_6
Public property | ModeControlOCL | Mode Control: OCL
Public property | MonoControlEPVOL | Mono Control: EP_VOL
Public property | OutputControlHPLOUTPUT | Output Control: HP_L_OUTPUT
Public property | OutputControlHPROUTPUT | Output Control: HP_R_OUTPUT
Public property | OutputControlLSOUTPUT | Output Control: LS_OUTPUT
Public property | OutputControlMONOOUTPUT | Output Control: MONO_OUTPUT
Public property | PLLMDividerPLLM | PLLM Divider: PLL_M
Public property | PLLNDividerPLLN | PLLN Divider: PLL_N
Public property | PLLNMODDividerPLLDITHLEV | PLLN MOD Divider: PLL_DITH_LEV
Public property | PLLNMODDividerPLLNMOD | PLLN MOD Divider: PLL_N_MOD
Public property | PLLNMODDividerVCOFAST | PLLN MOD Divider: VCO_FAST
Public property | PLLPDividerPLLP | PLLP Divider: PLL_P
Public property | RLInputANALGAIN | RL Input: ANA_L_GAIN (unit: dB)
Public property | RLInputANARGAIN | RL Input: ANA_R_GAIN (unit: dB)
Public property | SpealerControlLSVOL | Spealer Control: LS_VOL
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Audio Sub-System With OCL Stereo Headphone Output And RF Suppression
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Lm4937(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Lm4937

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937 Properties

The Lm4937 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ClockConfigAUDIOCLKSEL | Clock Config: AUDIO_CLK_SEL
Public property | ClockConfigFASTCLOCK | Clock Config: FAST_CLOCK
Public property | ClockConfigPLLENABLE | Clock Config: PLL_ENABLE
Public property | ClockConfigPLLINPUT | Clock Config: PLL_INPUT
Public property | ClockConfigRDIV | Clock Config: R_DIV
Public property | Compensation0COMP0 | Compensation0: COMP0
Public property | Compensation1COMP1 | Compensation1: COMP1
Public property | Compensation2COMP2 | Compensation2: COMP2
Public property | DACInputDIGLGAIN | DAC Input: DIG_L_GAIN (unit: dB)
Public property | DACInputDIGRGAIN | DAC Input: DIG_R_GAIN (unit: dB)
Public property | DACInputMONOINGAIN | DAC Input: MONO_IN_GAIN (unit: dB)
Public property | DACSetupCUSTCOMP | DAC Setup: CUST_COMP
Public property | DACSetupDACMODE | DAC Setup: DAC_MODE
Public property | DACSetupDITHERALWAYSON | DAC Setup: DITHER_ALWAYS_ON
Public property | DACSetupDITHEROFF | DAC Setup: DITHER_OFF
Public property | DACSetupMUTEL | DAC Setup: MUTE_L
Public property | DACSetupMUTER | DAC Setup: MUTE_R
Public property | HeadphoneLeftHPLVOL | Headphone Left: HP_L_VOL
Public property | HeadphoneRightHPRVOL | Headphone Right: HP_R_VOL
Public property | InterfaceI2CFAST | Interface: I2C_FAST
Public property | InterfaceI2SMODE | Interface: I2S_MODE
Public property | InterfaceI2SMS | Interface: I2S_M/S
Public property | InterfaceI2SRESOL | Interface: I2S_RESOL
Public property | ModeControlCD | Mode Control: CD
Public property | ModeControlCD6 | Mode Control: CD_6
Public property | ModeControlOCL | Mode Control: OCL
Public property | MonoControlEPVOL | Mono Control: EP_VOL
Public property | OutputControlHPLOUTPUT | Output Control: HP_L_OUTPUT
Public property | OutputControlHPROUTPUT | Output Control: HP_R_OUTPUT
Public property | OutputControlLSOUTPUT | Output Control: LS_OUTPUT
Public property | OutputControlMONOOUTPUT | Output Control: MONO_OUTPUT
Public property | PLLMDividerPLLM | PLLM Divider: PLL_M
Public property | PLLNDividerPLLN | PLLN Divider: PLL_N
Public property | PLLNMODDividerPLLDITHLEV | PLLN MOD Divider: PLL_DITH_LEV
Public property | PLLNMODDividerPLLNMOD | PLLN MOD Divider: PLL_N_MOD
Public property | PLLNMODDividerVCOFAST | PLLN MOD Divider: VCO_FAST
Public property | PLLPDividerPLLP | PLLP Divider: PLL_P
Public property | RLInputANALGAIN | RL Input: ANA_L_GAIN (unit: dB)
Public property | RLInputANARGAIN | RL Input: ANA_R_GAIN (unit: dB)
Public property | SpealerControlLSVOL | Spealer Control: LS_VOL
Top
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.AutoFlush Property

IRD

Lm4937AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.ClockConfigAUDIOCLKSEL Property

IRD

Lm4937ClockConfigAUDIOCLKSEL Property

Clock Config: AUDIO_CLK_SEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeClockConfigSelect ClockConfigAUDIOCLKSEL { get; set; }
Public Property ClockConfigAUDIOCLKSEL As Lm4937TypeClockConfigSelect
    Get
    Set
public:
property Lm4937TypeClockConfigSelect ClockConfigAUDIOCLKSEL {
    Lm4937TypeClockConfigSelect get ();
    void set (Lm4937TypeClockConfigSelect value);
}
member ClockConfigAUDIOCLKSEL : Lm4937TypeClockConfigSelect with get, set

Property Value

Type: Lm4937TypeClockConfigSelect
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.ClockConfigFASTCLOCK Property

IRD

Lm4937ClockConfigFASTCLOCK Property

Clock Config: FAST_CLOCK

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeClockConfigFast ClockConfigFASTCLOCK { get; set; }
Public Property ClockConfigFASTCLOCK As Lm4937TypeClockConfigFast
    Get
    Set
public:
property Lm4937TypeClockConfigFast ClockConfigFASTCLOCK {
    Lm4937TypeClockConfigFast get ();
    void set (Lm4937TypeClockConfigFast value);
}
member ClockConfigFASTCLOCK : Lm4937TypeClockConfigFast with get, set

Property Value

Type: Lm4937TypeClockConfigFast
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.ClockConfigPLLENABLE Property

IRD

Lm4937ClockConfigPLLENABLE Property

Clock Config: PLL_ENABLE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeClockConfigPllEn ClockConfigPLLENABLE { get; set; }
Public Property ClockConfigPLLENABLE As Lm4937TypeClockConfigPllEn
    Get
    Set
public:
property Lm4937TypeClockConfigPllEn ClockConfigPLLENABLE {
    Lm4937TypeClockConfigPllEn get ();
    void set (Lm4937TypeClockConfigPllEn value);
}
member ClockConfigPLLENABLE : Lm4937TypeClockConfigPllEn with get, set

Property Value

Type: Lm4937TypeClockConfigPllEn
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.ClockConfigPLLINPUT Property

IRD

Lm4937ClockConfigPLLINPUT Property

Clock Config: PLL_INPUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeClockConfigPllIn ClockConfigPLLINPUT { get; set; }
Public Property ClockConfigPLLINPUT As Lm4937TypeClockConfigPllIn
    Get
    Set
public:
property Lm4937TypeClockConfigPllIn ClockConfigPLLINPUT {
    Lm4937TypeClockConfigPllIn get ();
    void set (Lm4937TypeClockConfigPllIn value);
}
member ClockConfigPLLINPUT : Lm4937TypeClockConfigPllIn with get, set

Property Value

Type: Lm4937TypeClockConfigPllIn
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.ClockConfigRDIV Property

IRD

Lm4937ClockConfigRDIV Property

Clock Config: R_DIV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeClockConfigRDivider ClockConfigRDIV { get; set; }
Public Property ClockConfigRDIV As Lm4937TypeClockConfigRDivider
    Get
    Set
public:
property Lm4937TypeClockConfigRDivider ClockConfigRDIV {
    Lm4937TypeClockConfigRDivider get ();
    void set (Lm4937TypeClockConfigRDivider value);
}
member ClockConfigRDIV : Lm4937TypeClockConfigRDivider with get, set

Property Value

Type: Lm4937TypeClockConfigRDivider
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.Compensation0COMP0 Property

IRD

Lm4937Compensation0COMP0 Property

Compensation0: COMP0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort Compensation0COMP0 { get; set; }
Public Property Compensation0COMP0 As UShort
    Get
    Set
public:
property unsigned short Compensation0COMP0 {
    unsigned short get ();
    void set (unsigned short value);
}
member Compensation0COMP0 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.Compensation1COMP1 Property

IRD

Lm4937Compensation1COMP1 Property

Compensation1: COMP1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort Compensation1COMP1 { get; set; }
Public Property Compensation1COMP1 As UShort
    Get
    Set
public:
property unsigned short Compensation1COMP1 {
    unsigned short get ();
    void set (unsigned short value);
}
member Compensation1COMP1 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.Compensation2COMP2 Property

IRD

Lm4937Compensation2COMP2 Property

Compensation2: COMP2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public ushort Compensation2COMP2 { get; set; }
Public Property Compensation2COMP2 As UShort
    Get
    Set
public:
property unsigned short Compensation2COMP2 {
    unsigned short get ();
    void set (unsigned short value);
}
member Compensation2COMP2 : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.DACInputDIGLGAIN Property

IRD

Lm4937DACInputDIGLGAIN Property

DAC Input: DIG_L_GAIN (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeDacInputDigital DACInputDIGLGAIN { get; set; }
Public Property DACInputDIGLGAIN As Lm4937TypeDacInputDigital
    Get
    Set
public:
property Lm4937TypeDacInputDigital DACInputDIGLGAIN {
    Lm4937TypeDacInputDigital get ();
    void set (Lm4937TypeDacInputDigital value);
}
member DACInputDIGLGAIN : Lm4937TypeDacInputDigital with get, set

Property Value

Type: Lm4937TypeDacInputDigital
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.DACInputDIGRGAIN Property

IRD

Lm4937DACInputDIGRGAIN Property

DAC Input: DIG_R_GAIN (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeDacInputDigital DACInputDIGRGAIN { get; set; }
Public Property DACInputDIGRGAIN As Lm4937TypeDacInputDigital
    Get
    Set
public:
property Lm4937TypeDacInputDigital DACInputDIGRGAIN {
    Lm4937TypeDacInputDigital get ();
    void set (Lm4937TypeDacInputDigital value);
}
member DACInputDIGRGAIN : Lm4937TypeDacInputDigital with get, set

Property Value

Type: Lm4937TypeDacInputDigital
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.DACInputMONOINGAIN Property

IRD

Lm4937DACInputMONOINGAIN Property

DAC Input: MONO_IN_GAIN (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double DACInputMONOINGAIN { get; set; }
Public Property DACInputMONOINGAIN As Double
    Get
    Set
public:
property double DACInputMONOINGAIN {
    double get ();
    void set (double value);
}
member DACInputMONOINGAIN : float with get, set

Property Value

Type: Double
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.DACSetupCUSTCOMP Property

IRD

Lm4937DACSetupCUSTCOMP Property

DAC Setup: CUST_COMP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeDacSetupCust DACSetupCUSTCOMP { get; set; }
Public Property DACSetupCUSTCOMP As Lm4937TypeDacSetupCust
    Get
    Set
public:
property Lm4937TypeDacSetupCust DACSetupCUSTCOMP {
    Lm4937TypeDacSetupCust get ();
    void set (Lm4937TypeDacSetupCust value);
}
member DACSetupCUSTCOMP : Lm4937TypeDacSetupCust with get, set

Property Value

Type: Lm4937TypeDacSetupCust
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.DACSetupDACMODE Property

IRD

Lm4937DACSetupDACMODE Property

DAC Setup: DAC_MODE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeDacSetupMode DACSetupDACMODE { get; set; }
Public Property DACSetupDACMODE As Lm4937TypeDacSetupMode
    Get
    Set
public:
property Lm4937TypeDacSetupMode DACSetupDACMODE {
    Lm4937TypeDacSetupMode get ();
    void set (Lm4937TypeDacSetupMode value);
}
member DACSetupDACMODE : Lm4937TypeDacSetupMode with get, set

Property Value

Type: Lm4937TypeDacSetupMode
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.DACSetupDITHERALWAYSON Property

IRD

Lm4937DACSetupDITHERALWAYSON Property

DAC Setup: DITHER_ALWAYS_ON

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeDacSetupDitherAl DACSetupDITHERALWAYSON { get; set; }
Public Property DACSetupDITHERALWAYSON As Lm4937TypeDacSetupDitherAl
    Get
    Set
public:
property Lm4937TypeDacSetupDitherAl DACSetupDITHERALWAYSON {
    Lm4937TypeDacSetupDitherAl get ();
    void set (Lm4937TypeDacSetupDitherAl value);
}
member DACSetupDITHERALWAYSON : Lm4937TypeDacSetupDitherAl with get, set

Property Value

Type: Lm4937TypeDacSetupDitherAl
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.DACSetupDITHEROFF Property

IRD

Lm4937DACSetupDITHEROFF Property

DAC Setup: DITHER_OFF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeDacSetupDitherOff DACSetupDITHEROFF { get; set; }
Public Property DACSetupDITHEROFF As Lm4937TypeDacSetupDitherOff
    Get
    Set
public:
property Lm4937TypeDacSetupDitherOff DACSetupDITHEROFF {
    Lm4937TypeDacSetupDitherOff get ();
    void set (Lm4937TypeDacSetupDitherOff value);
}
member DACSetupDITHEROFF : Lm4937TypeDacSetupDitherOff with get, set

Property Value

Type: Lm4937TypeDacSetupDitherOff
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.DACSetupMUTEL Property

IRD

Lm4937DACSetupMUTEL Property

DAC Setup: MUTE_L

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeDacSetupMuteL DACSetupMUTEL { get; set; }
Public Property DACSetupMUTEL As Lm4937TypeDacSetupMuteL
    Get
    Set
public:
property Lm4937TypeDacSetupMuteL DACSetupMUTEL {
    Lm4937TypeDacSetupMuteL get ();
    void set (Lm4937TypeDacSetupMuteL value);
}
member DACSetupMUTEL : Lm4937TypeDacSetupMuteL with get, set

Property Value

Type: Lm4937TypeDacSetupMuteL
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.DACSetupMUTER Property

IRD

Lm4937DACSetupMUTER Property

DAC Setup: MUTE_R

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeDacSetupMuteR DACSetupMUTER { get; set; }
Public Property DACSetupMUTER As Lm4937TypeDacSetupMuteR
    Get
    Set
public:
property Lm4937TypeDacSetupMuteR DACSetupMUTER {
    Lm4937TypeDacSetupMuteR get ();
    void set (Lm4937TypeDacSetupMuteR value);
}
member DACSetupMUTER : Lm4937TypeDacSetupMuteR with get, set

Property Value

Type: Lm4937TypeDacSetupMuteR
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.HeadphoneLeftHPLVOL Property

IRD

Lm4937HeadphoneLeftHPLVOL Property

Headphone Left: HP_L_VOL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeVolume HeadphoneLeftHPLVOL { get; set; }
Public Property HeadphoneLeftHPLVOL As Lm4937TypeVolume
    Get
    Set
public:
property Lm4937TypeVolume HeadphoneLeftHPLVOL {
    Lm4937TypeVolume get ();
    void set (Lm4937TypeVolume value);
}
member HeadphoneLeftHPLVOL : Lm4937TypeVolume with get, set

Property Value

Type: Lm4937TypeVolume
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.HeadphoneRightHPRVOL Property

IRD

Lm4937HeadphoneRightHPRVOL Property

Headphone Right: HP_R_VOL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeVolume HeadphoneRightHPRVOL { get; set; }
Public Property HeadphoneRightHPRVOL As Lm4937TypeVolume
    Get
    Set
public:
property Lm4937TypeVolume HeadphoneRightHPRVOL {
    Lm4937TypeVolume get ();
    void set (Lm4937TypeVolume value);
}
member HeadphoneRightHPRVOL : Lm4937TypeVolume with get, set

Property Value

Type: Lm4937TypeVolume
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.InterfaceI2CFAST Property

IRD

Lm4937InterfaceI2CFAST Property

Interface: I2C_FAST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeInterfaceFast InterfaceI2CFAST { get; set; }
Public Property InterfaceI2CFAST As Lm4937TypeInterfaceFast
    Get
    Set
public:
property Lm4937TypeInterfaceFast InterfaceI2CFAST {
    Lm4937TypeInterfaceFast get ();
    void set (Lm4937TypeInterfaceFast value);
}
member InterfaceI2CFAST : Lm4937TypeInterfaceFast with get, set

Property Value

Type: Lm4937TypeInterfaceFast
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.InterfaceI2SMODE Property

IRD

Lm4937InterfaceI2SMODE Property

Interface: I2S_MODE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeInterfaceMode InterfaceI2SMODE { get; set; }
Public Property InterfaceI2SMODE As Lm4937TypeInterfaceMode
    Get
    Set
public:
property Lm4937TypeInterfaceMode InterfaceI2SMODE {
    Lm4937TypeInterfaceMode get ();
    void set (Lm4937TypeInterfaceMode value);
}
member InterfaceI2SMODE : Lm4937TypeInterfaceMode with get, set

Property Value

Type: Lm4937TypeInterfaceMode
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.InterfaceI2SMS Property

IRD

Lm4937InterfaceI2SMS Property

Interface: I2S_M/S

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeInterfaceSelect InterfaceI2SMS { get; set; }
Public Property InterfaceI2SMS As Lm4937TypeInterfaceSelect
    Get
    Set
public:
property Lm4937TypeInterfaceSelect InterfaceI2SMS {
    Lm4937TypeInterfaceSelect get ();
    void set (Lm4937TypeInterfaceSelect value);
}
member InterfaceI2SMS : Lm4937TypeInterfaceSelect with get, set

Property Value

Type: Lm4937TypeInterfaceSelect
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.InterfaceI2SRESOL Property

IRD

Lm4937InterfaceI2SRESOL Property

Interface: I2S_RESOL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeInterfaceRes InterfaceI2SRESOL { get; set; }
Public Property InterfaceI2SRESOL As Lm4937TypeInterfaceRes
    Get
    Set
public:
property Lm4937TypeInterfaceRes InterfaceI2SRESOL {
    Lm4937TypeInterfaceRes get ();
    void set (Lm4937TypeInterfaceRes value);
}
member InterfaceI2SRESOL : Lm4937TypeInterfaceRes with get, set

Property Value

Type: Lm4937TypeInterfaceRes
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.ModeControlCD Property

IRD

Lm4937ModeControlCD Property

Mode Control: CD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeModeControlMixer ModeControlCD { get; set; }
Public Property ModeControlCD As Lm4937TypeModeControlMixer
    Get
    Set
public:
property Lm4937TypeModeControlMixer ModeControlCD {
    Lm4937TypeModeControlMixer get ();
    void set (Lm4937TypeModeControlMixer value);
}
member ModeControlCD : Lm4937TypeModeControlMixer with get, set

Property Value

Type: Lm4937TypeModeControlMixer
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.ModeControlCD6 Property

IRD

Lm4937ModeControlCD6 Property

Mode Control: CD_6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeModeControlCd ModeControlCD6 { get; set; }
Public Property ModeControlCD6 As Lm4937TypeModeControlCd
    Get
    Set
public:
property Lm4937TypeModeControlCd ModeControlCD6 {
    Lm4937TypeModeControlCd get ();
    void set (Lm4937TypeModeControlCd value);
}
member ModeControlCD6 : Lm4937TypeModeControlCd with get, set

Property Value

Type: Lm4937TypeModeControlCd
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.ModeControlOCL Property

IRD

Lm4937ModeControlOCL Property

Mode Control: OCL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeModeControlOutput ModeControlOCL { get; set; }
Public Property ModeControlOCL As Lm4937TypeModeControlOutput
    Get
    Set
public:
property Lm4937TypeModeControlOutput ModeControlOCL {
    Lm4937TypeModeControlOutput get ();
    void set (Lm4937TypeModeControlOutput value);
}
member ModeControlOCL : Lm4937TypeModeControlOutput with get, set

Property Value

Type: Lm4937TypeModeControlOutput
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.MonoControlEPVOL Property

IRD

Lm4937MonoControlEPVOL Property

Mono Control: EP_VOL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeVolume MonoControlEPVOL { get; set; }
Public Property MonoControlEPVOL As Lm4937TypeVolume
    Get
    Set
public:
property Lm4937TypeVolume MonoControlEPVOL {
    Lm4937TypeVolume get ();
    void set (Lm4937TypeVolume value);
}
member MonoControlEPVOL : Lm4937TypeVolume with get, set

Property Value

Type: Lm4937TypeVolume
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.OutputControlHPLOUTPUT Property

IRD

Lm4937OutputControlHPLOUTPUT Property

Output Control: HP_L_OUTPUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeOutputControlHpl OutputControlHPLOUTPUT { get; set; }
Public Property OutputControlHPLOUTPUT As Lm4937TypeOutputControlHpl
    Get
    Set
public:
property Lm4937TypeOutputControlHpl OutputControlHPLOUTPUT {
    Lm4937TypeOutputControlHpl get ();
    void set (Lm4937TypeOutputControlHpl value);
}
member OutputControlHPLOUTPUT : Lm4937TypeOutputControlHpl with get, set

Property Value

Type: Lm4937TypeOutputControlHpl
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.OutputControlHPROUTPUT Property

IRD

Lm4937OutputControlHPROUTPUT Property

Output Control: HP_R_OUTPUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeOutputControlHpr OutputControlHPROUTPUT { get; set; }
Public Property OutputControlHPROUTPUT As Lm4937TypeOutputControlHpr
    Get
    Set
public:
property Lm4937TypeOutputControlHpr OutputControlHPROUTPUT {
    Lm4937TypeOutputControlHpr get ();
    void set (Lm4937TypeOutputControlHpr value);
}
member OutputControlHPROUTPUT : Lm4937TypeOutputControlHpr with get, set

Property Value

Type: Lm4937TypeOutputControlHpr
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.OutputControlLSOUTPUT Property

IRD

Lm4937OutputControlLSOUTPUT Property

Output Control: LS_OUTPUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeOutputControlSpeaker OutputControlLSOUTPUT { get; set; }
Public Property OutputControlLSOUTPUT As Lm4937TypeOutputControlSpeaker
    Get
    Set
public:
property Lm4937TypeOutputControlSpeaker OutputControlLSOUTPUT {
    Lm4937TypeOutputControlSpeaker get ();
    void set (Lm4937TypeOutputControlSpeaker value);
}
member OutputControlLSOUTPUT : Lm4937TypeOutputControlSpeaker with get, set

Property Value

Type: Lm4937TypeOutputControlSpeaker
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.OutputControlMONOOUTPUT Property

IRD

Lm4937OutputControlMONOOUTPUT Property

Output Control: MONO_OUTPUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeOutputControlEarpiece OutputControlMONOOUTPUT { get; set; }
Public Property OutputControlMONOOUTPUT As Lm4937TypeOutputControlEarpiece
    Get
    Set
public:
property Lm4937TypeOutputControlEarpiece OutputControlMONOOUTPUT {
    Lm4937TypeOutputControlEarpiece get ();
    void set (Lm4937TypeOutputControlEarpiece value);
}
member OutputControlMONOOUTPUT : Lm4937TypeOutputControlEarpiece with get, set

Property Value

Type: Lm4937TypeOutputControlEarpiece
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.PLLMDividerPLLM Property

IRD

Lm4937PLLMDividerPLLM Property

PLLM Divider: PLL_M

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypePllmDivider PLLMDividerPLLM { get; set; }
Public Property PLLMDividerPLLM As Lm4937TypePllmDivider
    Get
    Set
public:
property Lm4937TypePllmDivider PLLMDividerPLLM {
    Lm4937TypePllmDivider get ();
    void set (Lm4937TypePllmDivider value);
}
member PLLMDividerPLLM : Lm4937TypePllmDivider with get, set

Property Value

Type: Lm4937TypePllmDivider
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.PLLNDividerPLLN Property

IRD

Lm4937PLLNDividerPLLN Property

PLLN Divider: PLL_N

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypePllnDivider PLLNDividerPLLN { get; set; }
Public Property PLLNDividerPLLN As Lm4937TypePllnDivider
    Get
    Set
public:
property Lm4937TypePllnDivider PLLNDividerPLLN {
    Lm4937TypePllnDivider get ();
    void set (Lm4937TypePllnDivider value);
}
member PLLNDividerPLLN : Lm4937TypePllnDivider with get, set

Property Value

Type: Lm4937TypePllnDivider
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.PLLNMODDividerPLLDITHLEV Property

IRD

Lm4937PLLNMODDividerPLLDITHLEV Property

PLLN MOD Divider: PLL_DITH_LEV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypePllnModDividerDither PLLNMODDividerPLLDITHLEV { get; set; }
Public Property PLLNMODDividerPLLDITHLEV As Lm4937TypePllnModDividerDither
    Get
    Set
public:
property Lm4937TypePllnModDividerDither PLLNMODDividerPLLDITHLEV {
    Lm4937TypePllnModDividerDither get ();
    void set (Lm4937TypePllnModDividerDither value);
}
member PLLNMODDividerPLLDITHLEV : Lm4937TypePllnModDividerDither with get, set

Property Value

Type: Lm4937TypePllnModDividerDither
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.PLLNMODDividerPLLNMOD Property

IRD

Lm4937PLLNMODDividerPLLNMOD Property

PLLN MOD Divider: PLL_N_MOD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double PLLNMODDividerPLLNMOD { get; set; }
Public Property PLLNMODDividerPLLNMOD As Double
    Get
    Set
public:
property double PLLNMODDividerPLLNMOD {
    double get ();
    void set (double value);
}
member PLLNMODDividerPLLNMOD : float with get, set

Property Value

Type: Double
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.PLLNMODDividerVCOFAST Property

IRD

Lm4937PLLNMODDividerVCOFAST Property

PLLN MOD Divider: VCO_FAST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypePllnModDividerVco PLLNMODDividerVCOFAST { get; set; }
Public Property PLLNMODDividerVCOFAST As Lm4937TypePllnModDividerVco
    Get
    Set
public:
property Lm4937TypePllnModDividerVco PLLNMODDividerVCOFAST {
    Lm4937TypePllnModDividerVco get ();
    void set (Lm4937TypePllnModDividerVco value);
}
member PLLNMODDividerVCOFAST : Lm4937TypePllnModDividerVco with get, set

Property Value

Type: Lm4937TypePllnModDividerVco
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.PLLPDividerPLLP Property

IRD

Lm4937PLLPDividerPLLP Property

PLLP Divider: PLL_P

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypePllpDivider PLLPDividerPLLP { get; set; }
Public Property PLLPDividerPLLP As Lm4937TypePllpDivider
    Get
    Set
public:
property Lm4937TypePllpDivider PLLPDividerPLLP {
    Lm4937TypePllpDivider get ();
    void set (Lm4937TypePllpDivider value);
}
member PLLPDividerPLLP : Lm4937TypePllpDivider with get, set

Property Value

Type: Lm4937TypePllpDivider
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.RLInputANALGAIN Property

IRD

Lm4937RLInputANALGAIN Property

RL Input: ANA_L_GAIN (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RLInputANALGAIN { get; set; }
Public Property RLInputANALGAIN As Double
    Get
    Set
public:
property double RLInputANALGAIN {
    double get ();
    void set (double value);
}
member RLInputANALGAIN : float with get, set

Property Value

Type: Double
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.RLInputANARGAIN Property

IRD

Lm4937RLInputANARGAIN Property

RL Input: ANA_R_GAIN (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double RLInputANARGAIN { get; set; }
Public Property RLInputANARGAIN As Double
    Get
    Set
public:
property double RLInputANARGAIN {
    double get ();
    void set (double value);
}
member RLInputANARGAIN : float with get, set

Property Value

Type: Double
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.SpealerControlLSVOL Property

IRD

Lm4937SpealerControlLSVOL Property

Spealer Control: LS_VOL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Lm4937TypeVolume SpealerControlLSVOL { get; set; }
Public Property SpealerControlLSVOL As Lm4937TypeVolume
    Get
    Set
public:
property Lm4937TypeVolume SpealerControlLSVOL {
    Lm4937TypeVolume get ();
    void set (Lm4937TypeVolume value);
}
member SpealerControlLSVOL : Lm4937TypeVolume with get, set

Property Value

Type: Lm4937TypeVolume
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937 Methods

The Lm4937 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.Flush Method

IRD

Lm4937Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Lm4937 Class
telos.Ird.TexasInstruments Namespace


Lm4937.TypeClockConfigFast Enumeration

IRD

Lm4937TypeClockConfigFast Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockConfigFast
Public Enumeration TypeClockConfigFast
public enum class TypeClockConfigFast
type TypeClockConfigFast
Members
Member name | Value | Description
MCLKFrequencyNormal | 0 | MCLK Frequency: Normal
MCLKFrequencyDividedBy2 | 1 | MCLK Frequency: Divided By 2
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeClockConfigPllEn Enumeration

IRD

Lm4937TypeClockConfigPllEn Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockConfigPllEn
Public Enumeration TypeClockConfigPllEn
public enum class TypeClockConfigPllEn
type TypeClockConfigPllEn
Members
Member name | Value | Description
PLLDisable | 0 | PLL Disable
PLLEnable | 1 | PLL Enable
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeClockConfigPllIn Enumeration

IRD

Lm4937TypeClockConfigPllIn Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockConfigPllIn
Public Enumeration TypeClockConfigPllIn
public enum class TypeClockConfigPllIn
type TypeClockConfigPllIn
Members
Member name | Value | Description
PLLInputSourceMCLK | 0 | PLL Input Source: MCLK
PLLInputSourceI2SInputClock | 1 | PLL Input Source: I2S Input Clock
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeClockConfigRDivider Enumeration

IRD

Lm4937TypeClockConfigRDivider Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockConfigRDivider
Public Enumeration TypeClockConfigRDivider
public enum class TypeClockConfigRDivider
type TypeClockConfigRDivider
Members
Member name | Value | Description
DividerValue1 | 0 | Divider Value: 1
DividerValue1__1 | 1 | Divider Value: 1
DividerValue15 | 2 | Divider Value: 1.5
DividerValue2 | 3 | Divider Value: 2
DividerValue25 | 4 | Divider Value: 2.5
DividerValue3 | 5 | Divider Value: 3
DividerValue35 | 6 | Divider Value: 3.5
DividerValue4 | 7 | Divider Value: 4
DividerValue45 | 8 | Divider Value: 4.5
DividerValue5 | 9 | Divider Value: 5
DividerValue55 | 10 | Divider Value: 5.5
DividerValue6 | 11 | Divider Value: 6
DividerValue65 | 12 | Divider Value: 6.5
DividerValue7 | 13 | Divider Value: 7
DividerValue75 | 14 | Divider Value: 7.5
DividerValue8 | 15 | Divider Value: 8
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeClockConfigSelect Enumeration

IRD

Lm4937TypeClockConfigSelect Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeClockConfigSelect
Public Enumeration TypeClockConfigSelect
public enum class TypeClockConfigSelect
type TypeClockConfigSelect
Members
Member name | Value | Description
DACSubSystemSourcePLLInput | 0 | DAC Sub-System Source: PLL Input
DACSubSystemSourcePLLOutput | 1 | DAC Sub-System Source: PLL Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeDacInputDigital Enumeration

IRD

Lm4937TypeDacInputDigital Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacInputDigital
Public Enumeration TypeDacInputDigital
public enum class TypeDacInputDigital
type TypeDacInputDigital
Members
Member name | Value | Description
Value_M_3 | 0 | -3
Value_0 | 1 | 0
Value_3 | 2 | 3
Value_6 | 3 | 6
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeDacSetupCust Enumeration

IRD

Lm4937TypeDacSetupCust Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSetupCust
Public Enumeration TypeDacSetupCust
public enum class TypeDacSetupCust
type TypeDacSetupCust
Members
Member name | Value | Description
ManualFrequencyProgrammingDisabled | 0 | Manual Frequency Programming: Disabled
ManualFrequencyProgrammingEnabled | 1 | Manual Frequency Programming: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeDacSetupDitherAl Enumeration

IRD

Lm4937TypeDacSetupDitherAl Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSetupDitherAl
Public Enumeration TypeDacSetupDitherAl
public enum class TypeDacSetupDitherAl
type TypeDacSetupDitherAl
Members
Member name | Value | Description
DitherInDACPartlyOn | 0 | Dither In DAC: Partly On
DitherInDACAlwaysOn | 1 | Dither In DAC: Always On
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeDacSetupDitherOff Enumeration

IRD

Lm4937TypeDacSetupDitherOff Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSetupDitherOff
Public Enumeration TypeDacSetupDitherOff
public enum class TypeDacSetupDitherOff
type TypeDacSetupDitherOff
Members
Member name | Value | Description
DitherInDACEnabled | 0 | Dither In DAC: Enabled
DitherInDACDisabled | 1 | Dither In DAC: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeDacSetupMode Enumeration

IRD

Lm4937TypeDacSetupMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSetupMode
Public Enumeration TypeDacSetupMode
public enum class TypeDacSetupMode
type TypeDacSetupMode
Members
Member name | Value | Description
Oversampling125TypicalFs48KHzClockRequired12MHz | 0 | Oversampling: 125 / Typical Fs: 48 kHz / Clock Required: 12 MHz
Oversampling128TypicalFs441KHz48KHzClockRequired112869MHz12288MHz | 1 | Oversampling: 128 / Typical Fs: 44.1 kHz, 48 kHz / Clock Required: 11.2869 MHz, 12.288 MHz
Oversampling64TypicalFs96KHzClockRequired12288MHz | 2 | Oversampling: 64 / Typical Fs: 96 kHz / Clock Required: 12.288 MHz
Oversampling32TypicalFs192KHzClockRequired24576MHz | 3 | Oversampling: 32 / Typical Fs: 192 kHz / Clock Required: 24.576 MHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeDacSetupMuteL Enumeration

IRD

Lm4937TypeDacSetupMuteL Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSetupMuteL
Public Enumeration TypeDacSetupMuteL
public enum class TypeDacSetupMuteL
type TypeDacSetupMuteL
Members
Member name | Value | Description
LeftDACChannelNotMuted | 0 | Left DAC Channel: Not Muted
LeftDACChannelMutedOnNextZeroCrossing | 1 | Left DAC Channel: Muted (On Next Zero Crossing)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeDacSetupMuteR Enumeration

IRD

Lm4937TypeDacSetupMuteR Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacSetupMuteR
Public Enumeration TypeDacSetupMuteR
public enum class TypeDacSetupMuteR
type TypeDacSetupMuteR
Members
Member name | Value | Description
RightDACChannelNotMuted | 0 | Right DAC Channel: Not Muted
RightDACChannelMutedOnNextZeroCrossing | 1 | Right DAC Channel: Muted (On Next Zero Crossing)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeInterfaceFast Enumeration

IRD

Lm4937TypeInterfaceFast Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterfaceFast
Public Enumeration TypeInterfaceFast
public enum class TypeInterfaceFast
type TypeInterfaceFast
Members
Member name | Value | Description
I2CSpeedUseDefaultUpTo400KHz | 0 | I2C Speed: Use Default Up To 400 kHz
I2CSpeedUseFastModeUpTo34MHz | 1 | I2C Speed: Use Fast Mode Up To 3.4 MHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeInterfaceMode Enumeration

IRD

Lm4937TypeInterfaceMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterfaceMode
Public Enumeration TypeInterfaceMode
public enum class TypeInterfaceMode
type TypeInterfaceMode
Members
Member name | Value | Description
I2SModeTimingNormal | 0 | I2S Mode Timing: Normal
I2SModeTimingLeftJustified | 1 | I2S Mode Timing: Left-Justified
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeInterfaceRes Enumeration

IRD

Lm4937TypeInterfaceRes Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterfaceRes
Public Enumeration TypeInterfaceRes
public enum class TypeInterfaceRes
type TypeInterfaceRes
Members
Member name | Value | Description
I2SResolution16Bit | 0 | I2S Resolution: 16 Bit
I2SResolution32Bit | 1 | I2S Resolution: 32 Bit
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeInterfaceSelect Enumeration

IRD

Lm4937TypeInterfaceSelect Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterfaceSelect
Public Enumeration TypeInterfaceSelect
public enum class TypeInterfaceSelect
type TypeInterfaceSelect
Members
Member name | Value | Description
SlaveModeClockAndWordSelectConfiguredAsInput | 0 | Slave Mode (Clock And Word Select Configured As Input)
MasterModeClockAndWordSelectConfiguredAsOutput | 1 | Master Mode (Clock And Word Select Configured As Output)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeModeControlCd Enumeration

IRD

Lm4937TypeModeControlCd Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlCd
Public Enumeration TypeModeControlCd
public enum class TypeModeControlCd
type TypeModeControlCd
Members
Member name | Value | Description
HeadphoneOutputCapCoupled | 0 | Headphone Output: Cap-Coupled
HeadphoneOutputCapacitorlessOCL | 1 | Headphone Output: Capacitorless (OCL)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeModeControlMixer Enumeration

IRD

Lm4937TypeModeControlMixer Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlMixer
Public Enumeration TypeModeControlMixer
public enum class TypeModeControlMixer
type TypeModeControlMixer
Members
Member name | Value | Description
MonoEarpieceSDLoudspeakerSDHeadphoneLSDHeadphoneRSD | 0 | Mono Earpiece=SD / Loudspeaker=SD / Headphone L=SD / Headphone R=SD
MonoEarpieceMLoudspeakerMHeadphoneLMHeadphoneRM | 9 | Mono Earpiece=M / Loudspeaker=M / Headphone L=M / Headphone R=M
MonoEarpieceALARLoudspeakerALARHeadphoneLALHeadphoneRAR | 10 | Mono Earpiece=AL+AR / Loudspeaker=AL+AR / Headphone L=AL / Headphone R=AR
MonoEarpieceMALARLoudspeakerMALARHeadphoneLMALHeadphoneRMAR | 11 | Mono Earpiece=M+AL+AR / Loudspeaker=M+AL+AR / Headphone L=M+AL / Headphone R=M+AR
MonoEarpieceDLDRLoudspeakerDLDRHeadphoneLDLHeadphoneRDR | 12 | Mono Earpiece=DL+DR / Loudspeaker=DL+DR / Headphone L=DL / Headphone R=DR
MonoEarpieceDLDRALARLoudspeakerDLDRALARHeadphoneLDLALHeadphoneRDRAR | 13 | Mono Earpiece=DL+DR+AL+AR / Loudspeaker=DL+DR+AL+AR / Headphone L=DL+AL / Headphone R=DR+AR
MonoEarpieceMDLDRALARLoudspeakerMDLDRALARHeadphoneLMDLALHeadphoneRMDRAR | 14 | Mono Earpiece=M+DL+DR+AL+AR / Loudspeaker=M+DL+DR+AL+AR / Headphone L=M+DL+AL / Headphone R=M+DR+AR
MonoEarpieceMDLDRLoudspeakerMDLDRHeadphoneLMDLHeadphoneRMDR | 15 | Mono Earpiece=M+DL+DR / Loudspeaker=M+DL+DR / Headphone L=M+DL / Headphone R=M+DR
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeModeControlOutput Enumeration

IRD

Lm4937TypeModeControlOutput Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlOutput
Public Enumeration TypeModeControlOutput
public enum class TypeModeControlOutput
type TypeModeControlOutput
Members
Member name | Value | Description
OutputCapacitorlessOff | 0 | Output Capacitorless: Off
OutputCapacitorlessOn | 1 | Output Capacitorless: On
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeOutputControlEarpiece Enumeration

IRD

Lm4937TypeOutputControlEarpiece Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputControlEarpiece
Public Enumeration TypeOutputControlEarpiece
public enum class TypeOutputControlEarpiece
type TypeOutputControlEarpiece
Members
Member name | Value | Description
MonoEarpieceOutputOff | 0 | Mono Earpiece: Output Off
MonoEarpieceOutputOn | 1 | Mono Earpiece: Output On
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeOutputControlHpl Enumeration

IRD

Lm4937TypeOutputControlHpl Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputControlHpl
Public Enumeration TypeOutputControlHpl
public enum class TypeOutputControlHpl
type TypeOutputControlHpl
Members
Member name | Value | Description
HeadphoneLeftChannelOutputOffOCL0OrMuteOCL1 | 0 | Headphone Left Channel: Output Off (OCL=0) Or Mute (OCL=1)
HeadphoneLeftChannelOutputOn | 1 | Headphone Left Channel: Output On
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeOutputControlHpr Enumeration

IRD

Lm4937TypeOutputControlHpr Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputControlHpr
Public Enumeration TypeOutputControlHpr
public enum class TypeOutputControlHpr
type TypeOutputControlHpr
Members
Member name | Value | Description
HeadphoneRightChannelOutputOffOCL0OrMuteOCL1 | 0 | Headphone Right Channel: Output Off (OCL=0) Or Mute (OCL=1)
HeadphoneRightChannelOutputOn | 1 | Headphone Right Channel: Output On
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeOutputControlSpeaker Enumeration

IRD

Lm4937TypeOutputControlSpeaker Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputControlSpeaker
Public Enumeration TypeOutputControlSpeaker
public enum class TypeOutputControlSpeaker
type TypeOutputControlSpeaker
Members
Member name | Value | Description
LoudspeakerOutputOff | 0 | Loudspeaker: Output Off
LoudspeakerOutputOn | 1 | Loudspeaker: Output On
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypePllmDivider Enumeration

IRD

Lm4937TypePllmDivider Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllmDivider
Public Enumeration TypePllmDivider
public enum class TypePllmDivider
type TypePllmDivider
Members
Member name | Value | Description
DividerOff | 0 | Divider Off
Value_1_0 | 1 | 1.0
Value_1_5 | 2 | 1.5
Value_2_0 | 3 | 2.0
Value_2_5 | 4 | 2.5
Value_3_0 | 5 | 3.0
Value_3_5 | 6 | 3.5
Value_4_0 | 7 | 4.0
Value_4_5 | 8 | 4.5
Value_5_0 | 9 | 5.0
Value_5_5 | 10 | 5.5
Value_6_0 | 11 | 6.0
Value_6_5 | 12 | 6.5
Value_7_0 | 13 | 7.0
Value_7_5 | 14 | 7.5
Value_8_0 | 15 | 8.0
Value_8_5 | 16 | 8.5
Value_9_0 | 17 | 9.0
Value_9_5 | 18 | 9.5
Value_10_0 | 19 | 10.0
Value_10_5 | 20 | 10.5
Value_11_0 | 21 | 11.0
Value_11_5 | 22 | 11.5
Value_12_0 | 23 | 12.0
Value_12_5 | 24 | 12.5
Value_13_0 | 25 | 13.0
Value_13_5 | 26 | 13.5
Value_14_0 | 27 | 14.0
Value_14_5 | 28 | 14.5
Value_15_0 | 29 | 15.0
Value_15_5 | 30 | 15.5
Value_16_0 | 31 | 16.0
Value_16_5 | 32 | 16.5
Value_17_0 | 33 | 17.0
Value_17_5 | 34 | 17.5
Value_18_0 | 35 | 18.0
Value_18_5 | 36 | 18.5
Value_19_0 | 37 | 19.0
Value_19_5 | 38 | 19.5
Value_20_0 | 39 | 20.0
Value_20_5 | 40 | 20.5
Value_21_0 | 41 | 21.0
Value_21_5 | 42 | 21.5
Value_22_0 | 43 | 22.0
Value_22_5 | 44 | 22.5
Value_23_0 | 45 | 23.0
Value_23_5 | 46 | 23.5
Value_24_0 | 47 | 24.0
Value_24_5 | 48 | 24.5
Value_25_0 | 49 | 25.0
Value_25_5 | 50 | 25.5
Value_26_0 | 51 | 26.0
Value_26_5 | 52 | 26.5
Value_27_0 | 53 | 27.0
Value_27_5 | 54 | 27.5
Value_28_0 | 55 | 28.0
Value_28_5 | 56 | 28.5
Value_29_0 | 57 | 29.0
Value_29_5 | 58 | 29.5
Value_30_0 | 59 | 30.0
Value_30_5 | 60 | 30.5
Value_31_0 | 61 | 31.0
Value_31_5 | 62 | 31.5
Value_32_0 | 63 | 32.0
Value_32_5 | 64 | 32.5
Value_33_0 | 65 | 33.0
Value_33_5 | 66 | 33.5
Value_34_0 | 67 | 34.0
Value_34_5 | 68 | 34.5
Value_35_0 | 69 | 35.0
Value_35_5 | 70 | 35.5
Value_36_0 | 71 | 36.0
Value_36_5 | 72 | 36.5
Value_37_0 | 73 | 37.0
Value_37_5 | 74 | 37.5
Value_38_0 | 75 | 38.0
Value_38_5 | 76 | 38.5
Value_39_0 | 77 | 39.0
Value_39_5 | 78 | 39.5
Value_40_0 | 79 | 40.0
Value_40_5 | 80 | 40.5
Value_41_0 | 81 | 41.0
Value_41_5 | 82 | 41.5
Value_42_0 | 83 | 42.0
Value_42_5 | 84 | 42.5
Value_43_0 | 85 | 43.0
Value_43_5 | 86 | 43.5
Value_44_0 | 87 | 44.0
Value_44_5 | 88 | 44.5
Value_45_0 | 89 | 45.0
Value_45_5 | 90 | 45.5
Value_46_0 | 91 | 46.0
Value_46_5 | 92 | 46.5
Value_47_0 | 93 | 47.0
Value_47_5 | 94 | 47.5
Value_48_0 | 95 | 48.0
Value_48_5 | 96 | 48.5
Value_49_0 | 97 | 49.0
Value_49_5 | 98 | 49.5
Value_50_0 | 99 | 50.0
Value_50_5 | 100 | 50.5
Value_51_0 | 101 | 51.0
Value_51_5 | 102 | 51.5
Value_52_0 | 103 | 52.0
Value_52_5 | 104 | 52.5
Value_53_0 | 105 | 53.0
Value_53_5 | 106 | 53.5
Value_54_0 | 107 | 54.0
Value_54_5 | 108 | 54.5
Value_55_0 | 109 | 55.0
Value_55_5 | 110 | 55.5
Value_56_0 | 111 | 56.0
Value_56_5 | 112 | 56.5
Value_57_0 | 113 | 57.0
Value_57_5 | 114 | 57.5
Value_58_0 | 115 | 58.0
Value_58_5 | 116 | 58.5
Value_59_0 | 117 | 59.0
Value_59_5 | 118 | 59.5
Value_60_0 | 119 | 60.0
Value_60_5 | 120 | 60.5
Value_61_0 | 121 | 61.0
Value_61_5 | 122 | 61.5
Value_62_0 | 123 | 62.0
Value_62_5 | 124 | 62.5
Value_63_0 | 125 | 63.0
Value_63_5 | 126 | 63.5
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypePllnDivider Enumeration

IRD

Lm4937TypePllnDivider Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllnDivider
Public Enumeration TypePllnDivider
public enum class TypePllnDivider
type TypePllnDivider
Members
Member name | Value | Description
DividerOff | 0 | Divider Off
Value_10 | 1 | 10
Value_11 | 11 | 11
Value_12 | 12 | 12
Value_13 | 13 | 13
Value_14 | 14 | 14
Value_15 | 15 | 15
Value_16 | 16 | 16
Value_17 | 17 | 17
Value_18 | 18 | 18
Value_19 | 19 | 19
Value_20 | 20 | 20
Value_21 | 21 | 21
Value_22 | 22 | 22
Value_23 | 23 | 23
Value_24 | 24 | 24
Value_25 | 25 | 25
Value_26 | 26 | 26
Value_27 | 27 | 27
Value_28 | 28 | 28
Value_29 | 29 | 29
Value_30 | 30 | 30
Value_31 | 31 | 31
Value_32 | 32 | 32
Value_33 | 33 | 33
Value_34 | 34 | 34
Value_35 | 35 | 35
Value_36 | 36 | 36
Value_37 | 37 | 37
Value_38 | 38 | 38
Value_39 | 39 | 39
Value_40 | 40 | 40
Value_41 | 41 | 41
Value_42 | 42 | 42
Value_43 | 43 | 43
Value_44 | 44 | 44
Value_45 | 45 | 45
Value_46 | 46 | 46
Value_47 | 47 | 47
Value_48 | 48 | 48
Value_49 | 49 | 49
Value_50 | 50 | 50
Value_51 | 51 | 51
Value_52 | 52 | 52
Value_53 | 53 | 53
Value_54 | 54 | 54
Value_55 | 55 | 55
Value_56 | 56 | 56
Value_57 | 57 | 57
Value_58 | 58 | 58
Value_59 | 59 | 59
Value_60 | 60 | 60
Value_61 | 61 | 61
Value_62 | 62 | 62
Value_63 | 63 | 63
Value_64 | 64 | 64
Value_65 | 65 | 65
Value_66 | 66 | 66
Value_67 | 67 | 67
Value_68 | 68 | 68
Value_69 | 69 | 69
Value_70 | 70 | 70
Value_71 | 71 | 71
Value_72 | 72 | 72
Value_73 | 73 | 73
Value_74 | 74 | 74
Value_75 | 75 | 75
Value_76 | 76 | 76
Value_77 | 77 | 77
Value_78 | 78 | 78
Value_79 | 79 | 79
Value_80 | 80 | 80
Value_81 | 81 | 81
Value_82 | 82 | 82
Value_83 | 83 | 83
Value_84 | 84 | 84
Value_85 | 85 | 85
Value_86 | 86 | 86
Value_87 | 87 | 87
Value_88 | 88 | 88
Value_89 | 89 | 89
Value_90 | 90 | 90
Value_91 | 91 | 91
Value_92 | 92 | 92
Value_93 | 93 | 93
Value_94 | 94 | 94
Value_95 | 95 | 95
Value_96 | 96 | 96
Value_97 | 97 | 97
Value_98 | 98 | 98
Value_99 | 99 | 99
Value_100 | 100 | 100
Value_101 | 101 | 101
Value_102 | 102 | 102
Value_103 | 103 | 103
Value_104 | 104 | 104
Value_105 | 105 | 105
Value_106 | 106 | 106
Value_107 | 107 | 107
Value_108 | 108 | 108
Value_109 | 109 | 109
Value_110 | 110 | 110
Value_111 | 111 | 111
Value_112 | 112 | 112
Value_113 | 113 | 113
Value_114 | 114 | 114
Value_115 | 115 | 115
Value_116 | 116 | 116
Value_117 | 117 | 117
Value_118 | 118 | 118
Value_119 | 119 | 119
Value_120 | 120 | 120
Value_121 | 121 | 121
Value_122 | 122 | 122
Value_123 | 123 | 123
Value_124 | 124 | 124
Value_125 | 125 | 125
Value_126 | 126 | 126
Value_127 | 127 | 127
Value_128 | 128 | 128
Value_129 | 129 | 129
Value_130 | 130 | 130
Value_131 | 131 | 131
Value_132 | 132 | 132
Value_133 | 133 | 133
Value_134 | 134 | 134
Value_135 | 135 | 135
Value_136 | 136 | 136
Value_137 | 137 | 137
Value_138 | 138 | 138
Value_139 | 139 | 139
Value_140 | 140 | 140
Value_141 | 141 | 141
Value_142 | 142 | 142
Value_143 | 143 | 143
Value_144 | 144 | 144
Value_145 | 145 | 145
Value_146 | 146 | 146
Value_147 | 147 | 147
Value_148 | 148 | 148
Value_149 | 149 | 149
Value_150 | 150 | 150
Value_151 | 151 | 151
Value_152 | 152 | 152
Value_153 | 153 | 153
Value_154 | 154 | 154
Value_155 | 155 | 155
Value_156 | 156 | 156
Value_157 | 157 | 157
Value_158 | 158 | 158
Value_159 | 159 | 159
Value_160 | 160 | 160
Value_161 | 161 | 161
Value_162 | 162 | 162
Value_163 | 163 | 163
Value_164 | 164 | 164
Value_165 | 165 | 165
Value_166 | 166 | 166
Value_167 | 167 | 167
Value_168 | 168 | 168
Value_169 | 169 | 169
Value_170 | 170 | 170
Value_171 | 171 | 171
Value_172 | 172 | 172
Value_173 | 173 | 173
Value_174 | 174 | 174
Value_175 | 175 | 175
Value_176 | 176 | 176
Value_177 | 177 | 177
Value_178 | 178 | 178
Value_179 | 179 | 179
Value_180 | 180 | 180
Value_181 | 181 | 181
Value_182 | 182 | 182
Value_183 | 183 | 183
Value_184 | 184 | 184
Value_185 | 185 | 185
Value_186 | 186 | 186
Value_187 | 187 | 187
Value_188 | 188 | 188
Value_189 | 189 | 189
Value_190 | 190 | 190
Value_191 | 191 | 191
Value_192 | 192 | 192
Value_193 | 193 | 193
Value_194 | 194 | 194
Value_195 | 195 | 195
Value_196 | 196 | 196
Value_197 | 197 | 197
Value_198 | 198 | 198
Value_199 | 199 | 199
Value_200 | 200 | 200
Value_201 | 201 | 201
Value_202 | 202 | 202
Value_203 | 203 | 203
Value_204 | 204 | 204
Value_205 | 205 | 205
Value_206 | 206 | 206
Value_207 | 207 | 207
Value_208 | 208 | 208
Value_209 | 209 | 209
Value_210 | 210 | 210
Value_211 | 211 | 211
Value_212 | 212 | 212
Value_213 | 213 | 213
Value_214 | 214 | 214
Value_215 | 215 | 215
Value_216 | 216 | 216
Value_217 | 217 | 217
Value_218 | 218 | 218
Value_219 | 219 | 219
Value_220 | 220 | 220
Value_221 | 221 | 221
Value_222 | 222 | 222
Value_223 | 223 | 223
Value_224 | 224 | 224
Value_225 | 225 | 225
Value_226 | 226 | 226
Value_227 | 227 | 227
Value_228 | 228 | 228
Value_229 | 229 | 229
Value_230 | 230 | 230
Value_231 | 231 | 231
Value_232 | 232 | 232
Value_233 | 233 | 233
Value_234 | 234 | 234
Value_235 | 235 | 235
Value_236 | 236 | 236
Value_237 | 237 | 237
Value_238 | 238 | 238
Value_239 | 239 | 239
Value_240 | 240 | 240
Value_241 | 241 | 241
Value_242 | 242 | 242
Value_243 | 243 | 243
Value_244 | 244 | 244
Value_245 | 245 | 245
Value_246 | 246 | 246
Value_247 | 247 | 247
Value_248 | 248 | 248
Value_249 | 249 | 249
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypePllnModDividerDither Enumeration

IRD

Lm4937TypePllnModDividerDither Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllnModDividerDither
Public Enumeration TypePllnModDividerDither
public enum class TypePllnModDividerDither
type TypePllnModDividerDither
Members
Member name | Value | Description
NModulatorDitherMedium32 | 0 | N Modulator Dither: Medium (32)
NModulatorDitherSmall16 | 1 | N Modulator Dither: Small (16)
NModulatorDitherLarge48 | 2 | N Modulator Dither: Large (48)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypePllnModDividerVco Enumeration

IRD

Lm4937TypePllnModDividerVco Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllnModDividerVco
Public Enumeration TypePllnModDividerVco
public enum class TypePllnModDividerVco
type TypePllnModDividerVco
Members
Member name | Value | Description
VCOSetTo4055MHz | 0 | VCO Set To 40 - 55 MHz
VCOSetToMaximumFrequency | 1 | VCO Set To Maximum Frequency
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypePllpDivider Enumeration

IRD

Lm4937TypePllpDivider Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePllpDivider
Public Enumeration TypePllpDivider
public enum class TypePllpDivider
type TypePllpDivider
Members
Member name | Value | Description
DividerOff | 0 | Divider Off
DividerValue1 | 1 | Divider Value: 1
DividerValue15 | 2 | Divider Value: 1.5
DividerValue2 | 3 | Divider Value: 2
DividerValue25 | 4 | Divider Value: 2.5
DividerValue3 | 5 | Divider Value: 3
DividerValue35 | 6 | Divider Value: 3.5
DividerValue4 | 7 | Divider Value: 4
DividerValue45 | 8 | Divider Value: 4.5
DividerValue5 | 9 | Divider Value: 5
DividerValue55 | 10 | Divider Value: 5.5
DividerValue6 | 11 | Divider Value: 6
DividerValue65 | 12 | Divider Value: 6.5
DividerValue7 | 13 | Divider Value: 7
DividerValue75 | 14 | Divider Value: 7.5
DividerValue8 | 15 | Divider Value: 8
See Also

Reference

telos.Ird.TexasInstruments Namespace


Lm4937.TypeVolume Enumeration

IRD

Lm4937TypeVolume Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVolume
Public Enumeration TypeVolume
public enum class TypeVolume
type TypeVolume
Members
Member name | Value | Description
Value_90DBMute | 0 | -90 dB (Mute)
Value_56DB | 1 | -56 dB
Value_52DB | 2 | -52 dB
Value_48DB | 3 | -48 dB
Value_45DB | 4 | -45 dB
Value_42DB | 5 | -42 dB
Value_39DB | 6 | -39 dB
Value_36DB | 7 | -36 dB
Value_33DB | 8 | -33 dB
Value_30DB | 9 | -30 dB
Value_28DB | 10 | -28 dB
Value_26DB | 11 | -26 dB
Value_24DB | 12 | -24 dB
Value_22DB | 13 | -22 dB
Value_20DB | 14 | -20 dB
Value_18DB | 15 | -18 dB
Value_16DB | 16 | -16 dB
Value_14DB | 17 | -14 dB
Value_12DB | 18 | -12 dB
Value_10DB | 19 | -10 dB
Value_8DB | 20 | -8 dB
Value_6DB | 21 | -6 dB
Value_4DB | 22 | -4 dB
Value_3DB | 23 | -3 dB
Value_2DB | 24 | -2 dB
Value_1DB | 25 | -1 dB
Value_0DB | 26 | 0 dB
Value_1DB__1 | 27 | 1 dB
Value_2DB__1 | 28 | 2 dB
Value_3DB__1 | 29 | 3 dB
Value_4DB__1 | 30 | 4 dB
Value_5DB | 31 | 5 dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9534 Class

Texas Instruments: PCA 9534
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPca9534

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9534
Public Class Pca9534
public ref class Pca9534
type Pca9534 =  class end

The Pca9534 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9534 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC03 | Configuration (C-03)
Public property | ConfigurationC04 | Configuration (C-04)
Public property | ConfigurationC05 | Configuration (C-05)
Public property | ConfigurationC06 | Configuration (C-06)
Public property | ConfigurationC07 | Configuration (C-07)
Public property | InputI00 | Input (I-00)
Public property | InputI01 | Input (I-01)
Public property | InputI02 | Input (I-02)
Public property | InputI03 | Input (I-03)
Public property | InputI04 | Input (I-04)
Public property | InputI05 | Input (I-05)
Public property | InputI06 | Input (I-06)
Public property | InputI07 | Input (I-07)
Public property | OutputO00 | Output (O-00)
Public property | OutputO01 | Output (O-01)
Public property | OutputO02 | Output (O-02)
Public property | OutputO03 | Output (O-03)
Public property | OutputO04 | Output (O-04)
Public property | OutputO05 | Output (O-05)
Public property | OutputO06 | Output (O-06)
Public property | OutputO07 | Output (O-07)
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Public property | PolarityInversionP04 | Polarity Inversion (P-04)
Public property | PolarityInversionP05 | Polarity Inversion (P-05)
Public property | PolarityInversionP06 | Polarity Inversion (P-06)
Public property | PolarityInversionP07 | Polarity Inversion (P-07)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Remote 8-Bit I2C And SMBus Low-Power I/O Expander With Interrupt Output And Configuration Registers
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9534 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9534(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9534

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534 Properties

The Pca9534 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC03 | Configuration (C-03)
Public property | ConfigurationC04 | Configuration (C-04)
Public property | ConfigurationC05 | Configuration (C-05)
Public property | ConfigurationC06 | Configuration (C-06)
Public property | ConfigurationC07 | Configuration (C-07)
Public property | InputI00 | Input (I-00)
Public property | InputI01 | Input (I-01)
Public property | InputI02 | Input (I-02)
Public property | InputI03 | Input (I-03)
Public property | InputI04 | Input (I-04)
Public property | InputI05 | Input (I-05)
Public property | InputI06 | Input (I-06)
Public property | InputI07 | Input (I-07)
Public property | OutputO00 | Output (O-00)
Public property | OutputO01 | Output (O-01)
Public property | OutputO02 | Output (O-02)
Public property | OutputO03 | Output (O-03)
Public property | OutputO04 | Output (O-04)
Public property | OutputO05 | Output (O-05)
Public property | OutputO06 | Output (O-06)
Public property | OutputO07 | Output (O-07)
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Public property | PolarityInversionP04 | Polarity Inversion (P-04)
Public property | PolarityInversionP05 | Polarity Inversion (P-05)
Public property | PolarityInversionP06 | Polarity Inversion (P-06)
Public property | PolarityInversionP07 | Polarity Inversion (P-07)
Top
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.AutoFlush Property

IRD

Pca9534AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.ConfigurationC00 Property

IRD

Pca9534ConfigurationC00 Property

Configuration (C-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeConfiguration ConfigurationC00 { get; set; }
Public Property ConfigurationC00 As Pca9534TypeConfiguration
    Get
    Set
public:
property Pca9534TypeConfiguration ConfigurationC00 {
    Pca9534TypeConfiguration get ();
    void set (Pca9534TypeConfiguration value);
}
member ConfigurationC00 : Pca9534TypeConfiguration with get, set

Property Value

Type: Pca9534TypeConfiguration
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.ConfigurationC01 Property

IRD

Pca9534ConfigurationC01 Property

Configuration (C-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeConfiguration ConfigurationC01 { get; set; }
Public Property ConfigurationC01 As Pca9534TypeConfiguration
    Get
    Set
public:
property Pca9534TypeConfiguration ConfigurationC01 {
    Pca9534TypeConfiguration get ();
    void set (Pca9534TypeConfiguration value);
}
member ConfigurationC01 : Pca9534TypeConfiguration with get, set

Property Value

Type: Pca9534TypeConfiguration
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.ConfigurationC02 Property

IRD

Pca9534ConfigurationC02 Property

Configuration (C-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeConfiguration ConfigurationC02 { get; set; }
Public Property ConfigurationC02 As Pca9534TypeConfiguration
    Get
    Set
public:
property Pca9534TypeConfiguration ConfigurationC02 {
    Pca9534TypeConfiguration get ();
    void set (Pca9534TypeConfiguration value);
}
member ConfigurationC02 : Pca9534TypeConfiguration with get, set

Property Value

Type: Pca9534TypeConfiguration
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.ConfigurationC03 Property

IRD

Pca9534ConfigurationC03 Property

Configuration (C-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeConfiguration ConfigurationC03 { get; set; }
Public Property ConfigurationC03 As Pca9534TypeConfiguration
    Get
    Set
public:
property Pca9534TypeConfiguration ConfigurationC03 {
    Pca9534TypeConfiguration get ();
    void set (Pca9534TypeConfiguration value);
}
member ConfigurationC03 : Pca9534TypeConfiguration with get, set

Property Value

Type: Pca9534TypeConfiguration
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.ConfigurationC04 Property

IRD

Pca9534ConfigurationC04 Property

Configuration (C-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeConfiguration ConfigurationC04 { get; set; }
Public Property ConfigurationC04 As Pca9534TypeConfiguration
    Get
    Set
public:
property Pca9534TypeConfiguration ConfigurationC04 {
    Pca9534TypeConfiguration get ();
    void set (Pca9534TypeConfiguration value);
}
member ConfigurationC04 : Pca9534TypeConfiguration with get, set

Property Value

Type: Pca9534TypeConfiguration
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.ConfigurationC05 Property

IRD

Pca9534ConfigurationC05 Property

Configuration (C-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeConfiguration ConfigurationC05 { get; set; }
Public Property ConfigurationC05 As Pca9534TypeConfiguration
    Get
    Set
public:
property Pca9534TypeConfiguration ConfigurationC05 {
    Pca9534TypeConfiguration get ();
    void set (Pca9534TypeConfiguration value);
}
member ConfigurationC05 : Pca9534TypeConfiguration with get, set

Property Value

Type: Pca9534TypeConfiguration
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.ConfigurationC06 Property

IRD

Pca9534ConfigurationC06 Property

Configuration (C-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeConfiguration ConfigurationC06 { get; set; }
Public Property ConfigurationC06 As Pca9534TypeConfiguration
    Get
    Set
public:
property Pca9534TypeConfiguration ConfigurationC06 {
    Pca9534TypeConfiguration get ();
    void set (Pca9534TypeConfiguration value);
}
member ConfigurationC06 : Pca9534TypeConfiguration with get, set

Property Value

Type: Pca9534TypeConfiguration
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.ConfigurationC07 Property

IRD

Pca9534ConfigurationC07 Property

Configuration (C-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeConfiguration ConfigurationC07 { get; set; }
Public Property ConfigurationC07 As Pca9534TypeConfiguration
    Get
    Set
public:
property Pca9534TypeConfiguration ConfigurationC07 {
    Pca9534TypeConfiguration get ();
    void set (Pca9534TypeConfiguration value);
}
member ConfigurationC07 : Pca9534TypeConfiguration with get, set

Property Value

Type: Pca9534TypeConfiguration
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.InputI00 Property

IRD

Pca9534InputI00 Property

Input (I-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeLevel InputI00 { get; }
Public ReadOnly Property InputI00 As Pca9534TypeLevel
    Get
public:
property Pca9534TypeLevel InputI00 {
    Pca9534TypeLevel get ();
}
member InputI00 : Pca9534TypeLevel with get

Property Value

Type: Pca9534TypeLevel
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.InputI01 Property

IRD

Pca9534InputI01 Property

Input (I-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeLevel InputI01 { get; }
Public ReadOnly Property InputI01 As Pca9534TypeLevel
    Get
public:
property Pca9534TypeLevel InputI01 {
    Pca9534TypeLevel get ();
}
member InputI01 : Pca9534TypeLevel with get

Property Value

Type: Pca9534TypeLevel
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.InputI02 Property

IRD

Pca9534InputI02 Property

Input (I-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeLevel InputI02 { get; }
Public ReadOnly Property InputI02 As Pca9534TypeLevel
    Get
public:
property Pca9534TypeLevel InputI02 {
    Pca9534TypeLevel get ();
}
member InputI02 : Pca9534TypeLevel with get

Property Value

Type: Pca9534TypeLevel
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.InputI03 Property

IRD

Pca9534InputI03 Property

Input (I-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeLevel InputI03 { get; }
Public ReadOnly Property InputI03 As Pca9534TypeLevel
    Get
public:
property Pca9534TypeLevel InputI03 {
    Pca9534TypeLevel get ();
}
member InputI03 : Pca9534TypeLevel with get

Property Value

Type: Pca9534TypeLevel
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.InputI04 Property

IRD

Pca9534InputI04 Property

Input (I-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeLevel InputI04 { get; }
Public ReadOnly Property InputI04 As Pca9534TypeLevel
    Get
public:
property Pca9534TypeLevel InputI04 {
    Pca9534TypeLevel get ();
}
member InputI04 : Pca9534TypeLevel with get

Property Value

Type: Pca9534TypeLevel
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.InputI05 Property

IRD

Pca9534InputI05 Property

Input (I-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeLevel InputI05 { get; }
Public ReadOnly Property InputI05 As Pca9534TypeLevel
    Get
public:
property Pca9534TypeLevel InputI05 {
    Pca9534TypeLevel get ();
}
member InputI05 : Pca9534TypeLevel with get

Property Value

Type: Pca9534TypeLevel
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.InputI06 Property

IRD

Pca9534InputI06 Property

Input (I-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeLevel InputI06 { get; }
Public ReadOnly Property InputI06 As Pca9534TypeLevel
    Get
public:
property Pca9534TypeLevel InputI06 {
    Pca9534TypeLevel get ();
}
member InputI06 : Pca9534TypeLevel with get

Property Value

Type: Pca9534TypeLevel
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.InputI07 Property

IRD

Pca9534InputI07 Property

Input (I-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeLevel InputI07 { get; }
Public ReadOnly Property InputI07 As Pca9534TypeLevel
    Get
public:
property Pca9534TypeLevel InputI07 {
    Pca9534TypeLevel get ();
}
member InputI07 : Pca9534TypeLevel with get

Property Value

Type: Pca9534TypeLevel
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.OutputO00 Property

IRD

Pca9534OutputO00 Property

Output (O-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeLevel OutputO00 { get; set; }
Public Property OutputO00 As Pca9534TypeLevel
    Get
    Set
public:
property Pca9534TypeLevel OutputO00 {
    Pca9534TypeLevel get ();
    void set (Pca9534TypeLevel value);
}
member OutputO00 : Pca9534TypeLevel with get, set

Property Value

Type: Pca9534TypeLevel
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.OutputO01 Property

IRD

Pca9534OutputO01 Property

Output (O-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeLevel OutputO01 { get; set; }
Public Property OutputO01 As Pca9534TypeLevel
    Get
    Set
public:
property Pca9534TypeLevel OutputO01 {
    Pca9534TypeLevel get ();
    void set (Pca9534TypeLevel value);
}
member OutputO01 : Pca9534TypeLevel with get, set

Property Value

Type: Pca9534TypeLevel
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.OutputO02 Property

IRD

Pca9534OutputO02 Property

Output (O-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeLevel OutputO02 { get; set; }
Public Property OutputO02 As Pca9534TypeLevel
    Get
    Set
public:
property Pca9534TypeLevel OutputO02 {
    Pca9534TypeLevel get ();
    void set (Pca9534TypeLevel value);
}
member OutputO02 : Pca9534TypeLevel with get, set

Property Value

Type: Pca9534TypeLevel
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.OutputO03 Property

IRD

Pca9534OutputO03 Property

Output (O-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeLevel OutputO03 { get; set; }
Public Property OutputO03 As Pca9534TypeLevel
    Get
    Set
public:
property Pca9534TypeLevel OutputO03 {
    Pca9534TypeLevel get ();
    void set (Pca9534TypeLevel value);
}
member OutputO03 : Pca9534TypeLevel with get, set

Property Value

Type: Pca9534TypeLevel
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.OutputO04 Property

IRD

Pca9534OutputO04 Property

Output (O-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeLevel OutputO04 { get; set; }
Public Property OutputO04 As Pca9534TypeLevel
    Get
    Set
public:
property Pca9534TypeLevel OutputO04 {
    Pca9534TypeLevel get ();
    void set (Pca9534TypeLevel value);
}
member OutputO04 : Pca9534TypeLevel with get, set

Property Value

Type: Pca9534TypeLevel
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.OutputO05 Property

IRD

Pca9534OutputO05 Property

Output (O-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeLevel OutputO05 { get; set; }
Public Property OutputO05 As Pca9534TypeLevel
    Get
    Set
public:
property Pca9534TypeLevel OutputO05 {
    Pca9534TypeLevel get ();
    void set (Pca9534TypeLevel value);
}
member OutputO05 : Pca9534TypeLevel with get, set

Property Value

Type: Pca9534TypeLevel
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.OutputO06 Property

IRD

Pca9534OutputO06 Property

Output (O-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeLevel OutputO06 { get; set; }
Public Property OutputO06 As Pca9534TypeLevel
    Get
    Set
public:
property Pca9534TypeLevel OutputO06 {
    Pca9534TypeLevel get ();
    void set (Pca9534TypeLevel value);
}
member OutputO06 : Pca9534TypeLevel with get, set

Property Value

Type: Pca9534TypeLevel
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.OutputO07 Property

IRD

Pca9534OutputO07 Property

Output (O-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypeLevel OutputO07 { get; set; }
Public Property OutputO07 As Pca9534TypeLevel
    Get
    Set
public:
property Pca9534TypeLevel OutputO07 {
    Pca9534TypeLevel get ();
    void set (Pca9534TypeLevel value);
}
member OutputO07 : Pca9534TypeLevel with get, set

Property Value

Type: Pca9534TypeLevel
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.PolarityInversionP00 Property

IRD

Pca9534PolarityInversionP00 Property

Polarity Inversion (P-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypePolarity PolarityInversionP00 { get; set; }
Public Property PolarityInversionP00 As Pca9534TypePolarity
    Get
    Set
public:
property Pca9534TypePolarity PolarityInversionP00 {
    Pca9534TypePolarity get ();
    void set (Pca9534TypePolarity value);
}
member PolarityInversionP00 : Pca9534TypePolarity with get, set

Property Value

Type: Pca9534TypePolarity
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.PolarityInversionP01 Property

IRD

Pca9534PolarityInversionP01 Property

Polarity Inversion (P-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypePolarity PolarityInversionP01 { get; set; }
Public Property PolarityInversionP01 As Pca9534TypePolarity
    Get
    Set
public:
property Pca9534TypePolarity PolarityInversionP01 {
    Pca9534TypePolarity get ();
    void set (Pca9534TypePolarity value);
}
member PolarityInversionP01 : Pca9534TypePolarity with get, set

Property Value

Type: Pca9534TypePolarity
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.PolarityInversionP02 Property

IRD

Pca9534PolarityInversionP02 Property

Polarity Inversion (P-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypePolarity PolarityInversionP02 { get; set; }
Public Property PolarityInversionP02 As Pca9534TypePolarity
    Get
    Set
public:
property Pca9534TypePolarity PolarityInversionP02 {
    Pca9534TypePolarity get ();
    void set (Pca9534TypePolarity value);
}
member PolarityInversionP02 : Pca9534TypePolarity with get, set

Property Value

Type: Pca9534TypePolarity
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.PolarityInversionP03 Property

IRD

Pca9534PolarityInversionP03 Property

Polarity Inversion (P-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypePolarity PolarityInversionP03 { get; set; }
Public Property PolarityInversionP03 As Pca9534TypePolarity
    Get
    Set
public:
property Pca9534TypePolarity PolarityInversionP03 {
    Pca9534TypePolarity get ();
    void set (Pca9534TypePolarity value);
}
member PolarityInversionP03 : Pca9534TypePolarity with get, set

Property Value

Type: Pca9534TypePolarity
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.PolarityInversionP04 Property

IRD

Pca9534PolarityInversionP04 Property

Polarity Inversion (P-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypePolarity PolarityInversionP04 { get; set; }
Public Property PolarityInversionP04 As Pca9534TypePolarity
    Get
    Set
public:
property Pca9534TypePolarity PolarityInversionP04 {
    Pca9534TypePolarity get ();
    void set (Pca9534TypePolarity value);
}
member PolarityInversionP04 : Pca9534TypePolarity with get, set

Property Value

Type: Pca9534TypePolarity
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.PolarityInversionP05 Property

IRD

Pca9534PolarityInversionP05 Property

Polarity Inversion (P-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypePolarity PolarityInversionP05 { get; set; }
Public Property PolarityInversionP05 As Pca9534TypePolarity
    Get
    Set
public:
property Pca9534TypePolarity PolarityInversionP05 {
    Pca9534TypePolarity get ();
    void set (Pca9534TypePolarity value);
}
member PolarityInversionP05 : Pca9534TypePolarity with get, set

Property Value

Type: Pca9534TypePolarity
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.PolarityInversionP06 Property

IRD

Pca9534PolarityInversionP06 Property

Polarity Inversion (P-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypePolarity PolarityInversionP06 { get; set; }
Public Property PolarityInversionP06 As Pca9534TypePolarity
    Get
    Set
public:
property Pca9534TypePolarity PolarityInversionP06 {
    Pca9534TypePolarity get ();
    void set (Pca9534TypePolarity value);
}
member PolarityInversionP06 : Pca9534TypePolarity with get, set

Property Value

Type: Pca9534TypePolarity
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.PolarityInversionP07 Property

IRD

Pca9534PolarityInversionP07 Property

Polarity Inversion (P-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9534TypePolarity PolarityInversionP07 { get; set; }
Public Property PolarityInversionP07 As Pca9534TypePolarity
    Get
    Set
public:
property Pca9534TypePolarity PolarityInversionP07 {
    Pca9534TypePolarity get ();
    void set (Pca9534TypePolarity value);
}
member PolarityInversionP07 : Pca9534TypePolarity with get, set

Property Value

Type: Pca9534TypePolarity
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534 Methods

The Pca9534 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.Flush Method

IRD

Pca9534Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9534 Class
telos.Ird.TexasInstruments Namespace


Pca9534.TypeConfiguration Enumeration

IRD

Pca9534TypeConfiguration Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Input | 1 | Input
Output | 0 | Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9534.TypeLevel Enumeration

IRD

Pca9534TypeLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLevel
Public Enumeration TypeLevel
public enum class TypeLevel
type TypeLevel
Members
Member name | Value | Description
High | 1 | High
Low | 0 | Low
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9534.TypePolarity Enumeration

IRD

Pca9534TypePolarity Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarity
Public Enumeration TypePolarity
public enum class TypePolarity
type TypePolarity
Members
Member name | Value | Description
Inverted | 1 | Inverted
Normal | 0 | Normal
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9535 Class

Texas Instruments: PCA 9535
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPca9535

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9535
Public Class Pca9535
public ref class Pca9535
type Pca9535 =  class end

The Pca9535 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9535 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC03 | Configuration (C-03)
Public property | ConfigurationC04 | Configuration (C-04)
Public property | ConfigurationC05 | Configuration (C-05)
Public property | ConfigurationC06 | Configuration (C-06)
Public property | ConfigurationC07 | Configuration (C-07)
Public property | ConfigurationC10 | Configuration (C-10)
Public property | ConfigurationC11 | Configuration (C-11)
Public property | ConfigurationC12 | Configuration (C-12)
Public property | ConfigurationC13 | Configuration (C-13)
Public property | ConfigurationC14 | Configuration (C-14)
Public property | ConfigurationC15 | Configuration (C-15)
Public property | ConfigurationC16 | Configuration (C-16)
Public property | ConfigurationC17 | Configuration (C-17)
Public property | InputI00 | Input (I-00)
Public property | InputI01 | Input (I-01)
Public property | InputI02 | Input (I-02)
Public property | InputI03 | Input (I-03)
Public property | InputI04 | Input (I-04)
Public property | InputI05 | Input (I-05)
Public property | InputI06 | Input (I-06)
Public property | InputI07 | Input (I-07)
Public property | InputI10 | Input (I-10)
Public property | InputI11 | Input (I-11)
Public property | InputI12 | Input (I-12)
Public property | InputI13 | Input (I-13)
Public property | InputI14 | Input (I-14)
Public property | InputI15 | Input (I-15)
Public property | InputI16 | Input (I-16)
Public property | InputI17 | Input (I-17)
Public property | OutputO00 | Output (O-00)
Public property | OutputO01 | Output (O-01)
Public property | OutputO02 | Output (O-02)
Public property | OutputO03 | Output (O-03)
Public property | OutputO04 | Output (O-04)
Public property | OutputO05 | Output (O-05)
Public property | OutputO06 | Output (O-06)
Public property | OutputO07 | Output (O-07)
Public property | OutputO10 | Output (O-10)
Public property | OutputO11 | Output (O-11)
Public property | OutputO12 | Output (O-12)
Public property | OutputO13 | Output (O-13)
Public property | OutputO14 | Output (O-14)
Public property | OutputO15 | Output (O-15)
Public property | OutputO16 | Output (O-16)
Public property | OutputO17 | Output (O-17)
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Public property | PolarityInversionP04 | Polarity Inversion (P-04)
Public property | PolarityInversionP05 | Polarity Inversion (P-05)
Public property | PolarityInversionP06 | Polarity Inversion (P-06)
Public property | PolarityInversionP07 | Polarity Inversion (P-07)
Public property | PolarityInversionP10 | Polarity Inversion (P-10)
Public property | PolarityInversionP11 | Polarity Inversion (P-11)
Public property | PolarityInversionP12 | Polarity Inversion (P-12)
Public property | PolarityInversionP13 | Polarity Inversion (P-13)
Public property | PolarityInversionP14 | Polarity Inversion (P-14)
Public property | PolarityInversionP15 | Polarity Inversion (P-15)
Public property | PolarityInversionP16 | Polarity Inversion (P-16)
Public property | PolarityInversionP17 | Polarity Inversion (P-17)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Remote 16-Bit I2C And SMBus, Low-Power I/O Expander With Interrupt Output And Configuration Registers
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9535 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9535(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9535

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535 Properties

The Pca9535 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC03 | Configuration (C-03)
Public property | ConfigurationC04 | Configuration (C-04)
Public property | ConfigurationC05 | Configuration (C-05)
Public property | ConfigurationC06 | Configuration (C-06)
Public property | ConfigurationC07 | Configuration (C-07)
Public property | ConfigurationC10 | Configuration (C-10)
Public property | ConfigurationC11 | Configuration (C-11)
Public property | ConfigurationC12 | Configuration (C-12)
Public property | ConfigurationC13 | Configuration (C-13)
Public property | ConfigurationC14 | Configuration (C-14)
Public property | ConfigurationC15 | Configuration (C-15)
Public property | ConfigurationC16 | Configuration (C-16)
Public property | ConfigurationC17 | Configuration (C-17)
Public property | InputI00 | Input (I-00)
Public property | InputI01 | Input (I-01)
Public property | InputI02 | Input (I-02)
Public property | InputI03 | Input (I-03)
Public property | InputI04 | Input (I-04)
Public property | InputI05 | Input (I-05)
Public property | InputI06 | Input (I-06)
Public property | InputI07 | Input (I-07)
Public property | InputI10 | Input (I-10)
Public property | InputI11 | Input (I-11)
Public property | InputI12 | Input (I-12)
Public property | InputI13 | Input (I-13)
Public property | InputI14 | Input (I-14)
Public property | InputI15 | Input (I-15)
Public property | InputI16 | Input (I-16)
Public property | InputI17 | Input (I-17)
Public property | OutputO00 | Output (O-00)
Public property | OutputO01 | Output (O-01)
Public property | OutputO02 | Output (O-02)
Public property | OutputO03 | Output (O-03)
Public property | OutputO04 | Output (O-04)
Public property | OutputO05 | Output (O-05)
Public property | OutputO06 | Output (O-06)
Public property | OutputO07 | Output (O-07)
Public property | OutputO10 | Output (O-10)
Public property | OutputO11 | Output (O-11)
Public property | OutputO12 | Output (O-12)
Public property | OutputO13 | Output (O-13)
Public property | OutputO14 | Output (O-14)
Public property | OutputO15 | Output (O-15)
Public property | OutputO16 | Output (O-16)
Public property | OutputO17 | Output (O-17)
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Public property | PolarityInversionP04 | Polarity Inversion (P-04)
Public property | PolarityInversionP05 | Polarity Inversion (P-05)
Public property | PolarityInversionP06 | Polarity Inversion (P-06)
Public property | PolarityInversionP07 | Polarity Inversion (P-07)
Public property | PolarityInversionP10 | Polarity Inversion (P-10)
Public property | PolarityInversionP11 | Polarity Inversion (P-11)
Public property | PolarityInversionP12 | Polarity Inversion (P-12)
Public property | PolarityInversionP13 | Polarity Inversion (P-13)
Public property | PolarityInversionP14 | Polarity Inversion (P-14)
Public property | PolarityInversionP15 | Polarity Inversion (P-15)
Public property | PolarityInversionP16 | Polarity Inversion (P-16)
Public property | PolarityInversionP17 | Polarity Inversion (P-17)
Top
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.AutoFlush Property

IRD

Pca9535AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.ConfigurationC00 Property

IRD

Pca9535ConfigurationC00 Property

Configuration (C-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationC00 { get; set; }
Public Property ConfigurationC00 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationC00 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationC00 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.ConfigurationC01 Property

IRD

Pca9535ConfigurationC01 Property

Configuration (C-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationC01 { get; set; }
Public Property ConfigurationC01 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationC01 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationC01 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.ConfigurationC02 Property

IRD

Pca9535ConfigurationC02 Property

Configuration (C-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationC02 { get; set; }
Public Property ConfigurationC02 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationC02 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationC02 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.ConfigurationC03 Property

IRD

Pca9535ConfigurationC03 Property

Configuration (C-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationC03 { get; set; }
Public Property ConfigurationC03 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationC03 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationC03 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.ConfigurationC04 Property

IRD

Pca9535ConfigurationC04 Property

Configuration (C-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationC04 { get; set; }
Public Property ConfigurationC04 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationC04 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationC04 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.ConfigurationC05 Property

IRD

Pca9535ConfigurationC05 Property

Configuration (C-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationC05 { get; set; }
Public Property ConfigurationC05 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationC05 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationC05 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.ConfigurationC06 Property

IRD

Pca9535ConfigurationC06 Property

Configuration (C-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationC06 { get; set; }
Public Property ConfigurationC06 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationC06 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationC06 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.ConfigurationC07 Property

IRD

Pca9535ConfigurationC07 Property

Configuration (C-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationC07 { get; set; }
Public Property ConfigurationC07 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationC07 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationC07 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.ConfigurationC10 Property

IRD

Pca9535ConfigurationC10 Property

Configuration (C-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationC10 { get; set; }
Public Property ConfigurationC10 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationC10 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationC10 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.ConfigurationC11 Property

IRD

Pca9535ConfigurationC11 Property

Configuration (C-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationC11 { get; set; }
Public Property ConfigurationC11 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationC11 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationC11 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.ConfigurationC12 Property

IRD

Pca9535ConfigurationC12 Property

Configuration (C-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationC12 { get; set; }
Public Property ConfigurationC12 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationC12 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationC12 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.ConfigurationC13 Property

IRD

Pca9535ConfigurationC13 Property

Configuration (C-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationC13 { get; set; }
Public Property ConfigurationC13 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationC13 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationC13 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.ConfigurationC14 Property

IRD

Pca9535ConfigurationC14 Property

Configuration (C-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationC14 { get; set; }
Public Property ConfigurationC14 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationC14 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationC14 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.ConfigurationC15 Property

IRD

Pca9535ConfigurationC15 Property

Configuration (C-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationC15 { get; set; }
Public Property ConfigurationC15 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationC15 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationC15 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.ConfigurationC16 Property

IRD

Pca9535ConfigurationC16 Property

Configuration (C-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationC16 { get; set; }
Public Property ConfigurationC16 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationC16 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationC16 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.ConfigurationC17 Property

IRD

Pca9535ConfigurationC17 Property

Configuration (C-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeConfiguration ConfigurationC17 { get; set; }
Public Property ConfigurationC17 As Pca9535TypeConfiguration
    Get
    Set
public:
property Pca9535TypeConfiguration ConfigurationC17 {
    Pca9535TypeConfiguration get ();
    void set (Pca9535TypeConfiguration value);
}
member ConfigurationC17 : Pca9535TypeConfiguration with get, set

Property Value

Type: Pca9535TypeConfiguration
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.InputI00 Property

IRD

Pca9535InputI00 Property

Input (I-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel InputI00 { get; }
Public ReadOnly Property InputI00 As Pca9535TypeLevel
    Get
public:
property Pca9535TypeLevel InputI00 {
    Pca9535TypeLevel get ();
}
member InputI00 : Pca9535TypeLevel with get

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.InputI01 Property

IRD

Pca9535InputI01 Property

Input (I-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel InputI01 { get; }
Public ReadOnly Property InputI01 As Pca9535TypeLevel
    Get
public:
property Pca9535TypeLevel InputI01 {
    Pca9535TypeLevel get ();
}
member InputI01 : Pca9535TypeLevel with get

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.InputI02 Property

IRD

Pca9535InputI02 Property

Input (I-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel InputI02 { get; }
Public ReadOnly Property InputI02 As Pca9535TypeLevel
    Get
public:
property Pca9535TypeLevel InputI02 {
    Pca9535TypeLevel get ();
}
member InputI02 : Pca9535TypeLevel with get

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.InputI03 Property

IRD

Pca9535InputI03 Property

Input (I-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel InputI03 { get; }
Public ReadOnly Property InputI03 As Pca9535TypeLevel
    Get
public:
property Pca9535TypeLevel InputI03 {
    Pca9535TypeLevel get ();
}
member InputI03 : Pca9535TypeLevel with get

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.InputI04 Property

IRD

Pca9535InputI04 Property

Input (I-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel InputI04 { get; }
Public ReadOnly Property InputI04 As Pca9535TypeLevel
    Get
public:
property Pca9535TypeLevel InputI04 {
    Pca9535TypeLevel get ();
}
member InputI04 : Pca9535TypeLevel with get

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.InputI05 Property

IRD

Pca9535InputI05 Property

Input (I-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel InputI05 { get; }
Public ReadOnly Property InputI05 As Pca9535TypeLevel
    Get
public:
property Pca9535TypeLevel InputI05 {
    Pca9535TypeLevel get ();
}
member InputI05 : Pca9535TypeLevel with get

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.InputI06 Property

IRD

Pca9535InputI06 Property

Input (I-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel InputI06 { get; }
Public ReadOnly Property InputI06 As Pca9535TypeLevel
    Get
public:
property Pca9535TypeLevel InputI06 {
    Pca9535TypeLevel get ();
}
member InputI06 : Pca9535TypeLevel with get

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.InputI07 Property

IRD

Pca9535InputI07 Property

Input (I-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel InputI07 { get; }
Public ReadOnly Property InputI07 As Pca9535TypeLevel
    Get
public:
property Pca9535TypeLevel InputI07 {
    Pca9535TypeLevel get ();
}
member InputI07 : Pca9535TypeLevel with get

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.InputI10 Property

IRD

Pca9535InputI10 Property

Input (I-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel InputI10 { get; }
Public ReadOnly Property InputI10 As Pca9535TypeLevel
    Get
public:
property Pca9535TypeLevel InputI10 {
    Pca9535TypeLevel get ();
}
member InputI10 : Pca9535TypeLevel with get

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.InputI11 Property

IRD

Pca9535InputI11 Property

Input (I-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel InputI11 { get; }
Public ReadOnly Property InputI11 As Pca9535TypeLevel
    Get
public:
property Pca9535TypeLevel InputI11 {
    Pca9535TypeLevel get ();
}
member InputI11 : Pca9535TypeLevel with get

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.InputI12 Property

IRD

Pca9535InputI12 Property

Input (I-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel InputI12 { get; }
Public ReadOnly Property InputI12 As Pca9535TypeLevel
    Get
public:
property Pca9535TypeLevel InputI12 {
    Pca9535TypeLevel get ();
}
member InputI12 : Pca9535TypeLevel with get

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.InputI13 Property

IRD

Pca9535InputI13 Property

Input (I-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel InputI13 { get; }
Public ReadOnly Property InputI13 As Pca9535TypeLevel
    Get
public:
property Pca9535TypeLevel InputI13 {
    Pca9535TypeLevel get ();
}
member InputI13 : Pca9535TypeLevel with get

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.InputI14 Property

IRD

Pca9535InputI14 Property

Input (I-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel InputI14 { get; }
Public ReadOnly Property InputI14 As Pca9535TypeLevel
    Get
public:
property Pca9535TypeLevel InputI14 {
    Pca9535TypeLevel get ();
}
member InputI14 : Pca9535TypeLevel with get

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.InputI15 Property

IRD

Pca9535InputI15 Property

Input (I-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel InputI15 { get; }
Public ReadOnly Property InputI15 As Pca9535TypeLevel
    Get
public:
property Pca9535TypeLevel InputI15 {
    Pca9535TypeLevel get ();
}
member InputI15 : Pca9535TypeLevel with get

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.InputI16 Property

IRD

Pca9535InputI16 Property

Input (I-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel InputI16 { get; }
Public ReadOnly Property InputI16 As Pca9535TypeLevel
    Get
public:
property Pca9535TypeLevel InputI16 {
    Pca9535TypeLevel get ();
}
member InputI16 : Pca9535TypeLevel with get

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.InputI17 Property

IRD

Pca9535InputI17 Property

Input (I-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel InputI17 { get; }
Public ReadOnly Property InputI17 As Pca9535TypeLevel
    Get
public:
property Pca9535TypeLevel InputI17 {
    Pca9535TypeLevel get ();
}
member InputI17 : Pca9535TypeLevel with get

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.OutputO00 Property

IRD

Pca9535OutputO00 Property

Output (O-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel OutputO00 { get; set; }
Public Property OutputO00 As Pca9535TypeLevel
    Get
    Set
public:
property Pca9535TypeLevel OutputO00 {
    Pca9535TypeLevel get ();
    void set (Pca9535TypeLevel value);
}
member OutputO00 : Pca9535TypeLevel with get, set

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.OutputO01 Property

IRD

Pca9535OutputO01 Property

Output (O-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel OutputO01 { get; set; }
Public Property OutputO01 As Pca9535TypeLevel
    Get
    Set
public:
property Pca9535TypeLevel OutputO01 {
    Pca9535TypeLevel get ();
    void set (Pca9535TypeLevel value);
}
member OutputO01 : Pca9535TypeLevel with get, set

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.OutputO02 Property

IRD

Pca9535OutputO02 Property

Output (O-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel OutputO02 { get; set; }
Public Property OutputO02 As Pca9535TypeLevel
    Get
    Set
public:
property Pca9535TypeLevel OutputO02 {
    Pca9535TypeLevel get ();
    void set (Pca9535TypeLevel value);
}
member OutputO02 : Pca9535TypeLevel with get, set

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.OutputO03 Property

IRD

Pca9535OutputO03 Property

Output (O-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel OutputO03 { get; set; }
Public Property OutputO03 As Pca9535TypeLevel
    Get
    Set
public:
property Pca9535TypeLevel OutputO03 {
    Pca9535TypeLevel get ();
    void set (Pca9535TypeLevel value);
}
member OutputO03 : Pca9535TypeLevel with get, set

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.OutputO04 Property

IRD

Pca9535OutputO04 Property

Output (O-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel OutputO04 { get; set; }
Public Property OutputO04 As Pca9535TypeLevel
    Get
    Set
public:
property Pca9535TypeLevel OutputO04 {
    Pca9535TypeLevel get ();
    void set (Pca9535TypeLevel value);
}
member OutputO04 : Pca9535TypeLevel with get, set

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.OutputO05 Property

IRD

Pca9535OutputO05 Property

Output (O-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel OutputO05 { get; set; }
Public Property OutputO05 As Pca9535TypeLevel
    Get
    Set
public:
property Pca9535TypeLevel OutputO05 {
    Pca9535TypeLevel get ();
    void set (Pca9535TypeLevel value);
}
member OutputO05 : Pca9535TypeLevel with get, set

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.OutputO06 Property

IRD

Pca9535OutputO06 Property

Output (O-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel OutputO06 { get; set; }
Public Property OutputO06 As Pca9535TypeLevel
    Get
    Set
public:
property Pca9535TypeLevel OutputO06 {
    Pca9535TypeLevel get ();
    void set (Pca9535TypeLevel value);
}
member OutputO06 : Pca9535TypeLevel with get, set

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.OutputO07 Property

IRD

Pca9535OutputO07 Property

Output (O-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel OutputO07 { get; set; }
Public Property OutputO07 As Pca9535TypeLevel
    Get
    Set
public:
property Pca9535TypeLevel OutputO07 {
    Pca9535TypeLevel get ();
    void set (Pca9535TypeLevel value);
}
member OutputO07 : Pca9535TypeLevel with get, set

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.OutputO10 Property

IRD

Pca9535OutputO10 Property

Output (O-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel OutputO10 { get; set; }
Public Property OutputO10 As Pca9535TypeLevel
    Get
    Set
public:
property Pca9535TypeLevel OutputO10 {
    Pca9535TypeLevel get ();
    void set (Pca9535TypeLevel value);
}
member OutputO10 : Pca9535TypeLevel with get, set

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.OutputO11 Property

IRD

Pca9535OutputO11 Property

Output (O-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel OutputO11 { get; set; }
Public Property OutputO11 As Pca9535TypeLevel
    Get
    Set
public:
property Pca9535TypeLevel OutputO11 {
    Pca9535TypeLevel get ();
    void set (Pca9535TypeLevel value);
}
member OutputO11 : Pca9535TypeLevel with get, set

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.OutputO12 Property

IRD

Pca9535OutputO12 Property

Output (O-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel OutputO12 { get; set; }
Public Property OutputO12 As Pca9535TypeLevel
    Get
    Set
public:
property Pca9535TypeLevel OutputO12 {
    Pca9535TypeLevel get ();
    void set (Pca9535TypeLevel value);
}
member OutputO12 : Pca9535TypeLevel with get, set

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.OutputO13 Property

IRD

Pca9535OutputO13 Property

Output (O-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel OutputO13 { get; set; }
Public Property OutputO13 As Pca9535TypeLevel
    Get
    Set
public:
property Pca9535TypeLevel OutputO13 {
    Pca9535TypeLevel get ();
    void set (Pca9535TypeLevel value);
}
member OutputO13 : Pca9535TypeLevel with get, set

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.OutputO14 Property

IRD

Pca9535OutputO14 Property

Output (O-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel OutputO14 { get; set; }
Public Property OutputO14 As Pca9535TypeLevel
    Get
    Set
public:
property Pca9535TypeLevel OutputO14 {
    Pca9535TypeLevel get ();
    void set (Pca9535TypeLevel value);
}
member OutputO14 : Pca9535TypeLevel with get, set

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.OutputO15 Property

IRD

Pca9535OutputO15 Property

Output (O-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel OutputO15 { get; set; }
Public Property OutputO15 As Pca9535TypeLevel
    Get
    Set
public:
property Pca9535TypeLevel OutputO15 {
    Pca9535TypeLevel get ();
    void set (Pca9535TypeLevel value);
}
member OutputO15 : Pca9535TypeLevel with get, set

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.OutputO16 Property

IRD

Pca9535OutputO16 Property

Output (O-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel OutputO16 { get; set; }
Public Property OutputO16 As Pca9535TypeLevel
    Get
    Set
public:
property Pca9535TypeLevel OutputO16 {
    Pca9535TypeLevel get ();
    void set (Pca9535TypeLevel value);
}
member OutputO16 : Pca9535TypeLevel with get, set

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.OutputO17 Property

IRD

Pca9535OutputO17 Property

Output (O-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypeLevel OutputO17 { get; set; }
Public Property OutputO17 As Pca9535TypeLevel
    Get
    Set
public:
property Pca9535TypeLevel OutputO17 {
    Pca9535TypeLevel get ();
    void set (Pca9535TypeLevel value);
}
member OutputO17 : Pca9535TypeLevel with get, set

Property Value

Type: Pca9535TypeLevel
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.PolarityInversionP00 Property

IRD

Pca9535PolarityInversionP00 Property

Polarity Inversion (P-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarity PolarityInversionP00 { get; set; }
Public Property PolarityInversionP00 As Pca9535TypePolarity
    Get
    Set
public:
property Pca9535TypePolarity PolarityInversionP00 {
    Pca9535TypePolarity get ();
    void set (Pca9535TypePolarity value);
}
member PolarityInversionP00 : Pca9535TypePolarity with get, set

Property Value

Type: Pca9535TypePolarity
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.PolarityInversionP01 Property

IRD

Pca9535PolarityInversionP01 Property

Polarity Inversion (P-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarity PolarityInversionP01 { get; set; }
Public Property PolarityInversionP01 As Pca9535TypePolarity
    Get
    Set
public:
property Pca9535TypePolarity PolarityInversionP01 {
    Pca9535TypePolarity get ();
    void set (Pca9535TypePolarity value);
}
member PolarityInversionP01 : Pca9535TypePolarity with get, set

Property Value

Type: Pca9535TypePolarity
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.PolarityInversionP02 Property

IRD

Pca9535PolarityInversionP02 Property

Polarity Inversion (P-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarity PolarityInversionP02 { get; set; }
Public Property PolarityInversionP02 As Pca9535TypePolarity
    Get
    Set
public:
property Pca9535TypePolarity PolarityInversionP02 {
    Pca9535TypePolarity get ();
    void set (Pca9535TypePolarity value);
}
member PolarityInversionP02 : Pca9535TypePolarity with get, set

Property Value

Type: Pca9535TypePolarity
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.PolarityInversionP03 Property

IRD

Pca9535PolarityInversionP03 Property

Polarity Inversion (P-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarity PolarityInversionP03 { get; set; }
Public Property PolarityInversionP03 As Pca9535TypePolarity
    Get
    Set
public:
property Pca9535TypePolarity PolarityInversionP03 {
    Pca9535TypePolarity get ();
    void set (Pca9535TypePolarity value);
}
member PolarityInversionP03 : Pca9535TypePolarity with get, set

Property Value

Type: Pca9535TypePolarity
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.PolarityInversionP04 Property

IRD

Pca9535PolarityInversionP04 Property

Polarity Inversion (P-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarity PolarityInversionP04 { get; set; }
Public Property PolarityInversionP04 As Pca9535TypePolarity
    Get
    Set
public:
property Pca9535TypePolarity PolarityInversionP04 {
    Pca9535TypePolarity get ();
    void set (Pca9535TypePolarity value);
}
member PolarityInversionP04 : Pca9535TypePolarity with get, set

Property Value

Type: Pca9535TypePolarity
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.PolarityInversionP05 Property

IRD

Pca9535PolarityInversionP05 Property

Polarity Inversion (P-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarity PolarityInversionP05 { get; set; }
Public Property PolarityInversionP05 As Pca9535TypePolarity
    Get
    Set
public:
property Pca9535TypePolarity PolarityInversionP05 {
    Pca9535TypePolarity get ();
    void set (Pca9535TypePolarity value);
}
member PolarityInversionP05 : Pca9535TypePolarity with get, set

Property Value

Type: Pca9535TypePolarity
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.PolarityInversionP06 Property

IRD

Pca9535PolarityInversionP06 Property

Polarity Inversion (P-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarity PolarityInversionP06 { get; set; }
Public Property PolarityInversionP06 As Pca9535TypePolarity
    Get
    Set
public:
property Pca9535TypePolarity PolarityInversionP06 {
    Pca9535TypePolarity get ();
    void set (Pca9535TypePolarity value);
}
member PolarityInversionP06 : Pca9535TypePolarity with get, set

Property Value

Type: Pca9535TypePolarity
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.PolarityInversionP07 Property

IRD

Pca9535PolarityInversionP07 Property

Polarity Inversion (P-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarity PolarityInversionP07 { get; set; }
Public Property PolarityInversionP07 As Pca9535TypePolarity
    Get
    Set
public:
property Pca9535TypePolarity PolarityInversionP07 {
    Pca9535TypePolarity get ();
    void set (Pca9535TypePolarity value);
}
member PolarityInversionP07 : Pca9535TypePolarity with get, set

Property Value

Type: Pca9535TypePolarity
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.PolarityInversionP10 Property

IRD

Pca9535PolarityInversionP10 Property

Polarity Inversion (P-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarity PolarityInversionP10 { get; set; }
Public Property PolarityInversionP10 As Pca9535TypePolarity
    Get
    Set
public:
property Pca9535TypePolarity PolarityInversionP10 {
    Pca9535TypePolarity get ();
    void set (Pca9535TypePolarity value);
}
member PolarityInversionP10 : Pca9535TypePolarity with get, set

Property Value

Type: Pca9535TypePolarity
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.PolarityInversionP11 Property

IRD

Pca9535PolarityInversionP11 Property

Polarity Inversion (P-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarity PolarityInversionP11 { get; set; }
Public Property PolarityInversionP11 As Pca9535TypePolarity
    Get
    Set
public:
property Pca9535TypePolarity PolarityInversionP11 {
    Pca9535TypePolarity get ();
    void set (Pca9535TypePolarity value);
}
member PolarityInversionP11 : Pca9535TypePolarity with get, set

Property Value

Type: Pca9535TypePolarity
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.PolarityInversionP12 Property

IRD

Pca9535PolarityInversionP12 Property

Polarity Inversion (P-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarity PolarityInversionP12 { get; set; }
Public Property PolarityInversionP12 As Pca9535TypePolarity
    Get
    Set
public:
property Pca9535TypePolarity PolarityInversionP12 {
    Pca9535TypePolarity get ();
    void set (Pca9535TypePolarity value);
}
member PolarityInversionP12 : Pca9535TypePolarity with get, set

Property Value

Type: Pca9535TypePolarity
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.PolarityInversionP13 Property

IRD

Pca9535PolarityInversionP13 Property

Polarity Inversion (P-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarity PolarityInversionP13 { get; set; }
Public Property PolarityInversionP13 As Pca9535TypePolarity
    Get
    Set
public:
property Pca9535TypePolarity PolarityInversionP13 {
    Pca9535TypePolarity get ();
    void set (Pca9535TypePolarity value);
}
member PolarityInversionP13 : Pca9535TypePolarity with get, set

Property Value

Type: Pca9535TypePolarity
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.PolarityInversionP14 Property

IRD

Pca9535PolarityInversionP14 Property

Polarity Inversion (P-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarity PolarityInversionP14 { get; set; }
Public Property PolarityInversionP14 As Pca9535TypePolarity
    Get
    Set
public:
property Pca9535TypePolarity PolarityInversionP14 {
    Pca9535TypePolarity get ();
    void set (Pca9535TypePolarity value);
}
member PolarityInversionP14 : Pca9535TypePolarity with get, set

Property Value

Type: Pca9535TypePolarity
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.PolarityInversionP15 Property

IRD

Pca9535PolarityInversionP15 Property

Polarity Inversion (P-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarity PolarityInversionP15 { get; set; }
Public Property PolarityInversionP15 As Pca9535TypePolarity
    Get
    Set
public:
property Pca9535TypePolarity PolarityInversionP15 {
    Pca9535TypePolarity get ();
    void set (Pca9535TypePolarity value);
}
member PolarityInversionP15 : Pca9535TypePolarity with get, set

Property Value

Type: Pca9535TypePolarity
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.PolarityInversionP16 Property

IRD

Pca9535PolarityInversionP16 Property

Polarity Inversion (P-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarity PolarityInversionP16 { get; set; }
Public Property PolarityInversionP16 As Pca9535TypePolarity
    Get
    Set
public:
property Pca9535TypePolarity PolarityInversionP16 {
    Pca9535TypePolarity get ();
    void set (Pca9535TypePolarity value);
}
member PolarityInversionP16 : Pca9535TypePolarity with get, set

Property Value

Type: Pca9535TypePolarity
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.PolarityInversionP17 Property

IRD

Pca9535PolarityInversionP17 Property

Polarity Inversion (P-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9535TypePolarity PolarityInversionP17 { get; set; }
Public Property PolarityInversionP17 As Pca9535TypePolarity
    Get
    Set
public:
property Pca9535TypePolarity PolarityInversionP17 {
    Pca9535TypePolarity get ();
    void set (Pca9535TypePolarity value);
}
member PolarityInversionP17 : Pca9535TypePolarity with get, set

Property Value

Type: Pca9535TypePolarity
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535 Methods

The Pca9535 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.Flush Method

IRD

Pca9535Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9535 Class
telos.Ird.TexasInstruments Namespace


Pca9535.TypeConfiguration Enumeration

IRD

Pca9535TypeConfiguration Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Input | 1 | Input
Output | 0 | Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9535.TypeLevel Enumeration

IRD

Pca9535TypeLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLevel
Public Enumeration TypeLevel
public enum class TypeLevel
type TypeLevel
Members
Member name | Value | Description
High | 1 | High
Low | 0 | Low
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9535.TypePolarity Enumeration

IRD

Pca9535TypePolarity Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarity
Public Enumeration TypePolarity
public enum class TypePolarity
type TypePolarity
Members
Member name | Value | Description
Inverted | 1 | Inverted
Normal | 0 | Normal
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9536 Class

Texas Instruments: PCA 9536
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPca9536

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9536
Public Class Pca9536
public ref class Pca9536
type Pca9536 =  class end

The Pca9536 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9536 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC03 | Configuration (C-03)
Public property | InputI00 | Input (I-00)
Public property | InputI01 | Input (I-01)
Public property | InputI02 | Input (I-02)
Public property | InputI03 | Input (I-03)
Public property | OutputO00 | Output (O-00)
Public property | OutputO01 | Output (O-01)
Public property | OutputO02 | Output (O-02)
Public property | OutputO03 | Output (O-03)
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Remote 4-Bit I2C And SMBus I/O Expander With Configuration Registers
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9536 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9536(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9536

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536 Properties

The Pca9536 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC03 | Configuration (C-03)
Public property | InputI00 | Input (I-00)
Public property | InputI01 | Input (I-01)
Public property | InputI02 | Input (I-02)
Public property | InputI03 | Input (I-03)
Public property | OutputO00 | Output (O-00)
Public property | OutputO01 | Output (O-01)
Public property | OutputO02 | Output (O-02)
Public property | OutputO03 | Output (O-03)
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Top
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.AutoFlush Property

IRD

Pca9536AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.ConfigurationC00 Property

IRD

Pca9536ConfigurationC00 Property

Configuration (C-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypeConfiguration ConfigurationC00 { get; set; }
Public Property ConfigurationC00 As Pca9536TypeConfiguration
    Get
    Set
public:
property Pca9536TypeConfiguration ConfigurationC00 {
    Pca9536TypeConfiguration get ();
    void set (Pca9536TypeConfiguration value);
}
member ConfigurationC00 : Pca9536TypeConfiguration with get, set

Property Value

Type: Pca9536TypeConfiguration
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.ConfigurationC01 Property

IRD

Pca9536ConfigurationC01 Property

Configuration (C-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypeConfiguration ConfigurationC01 { get; set; }
Public Property ConfigurationC01 As Pca9536TypeConfiguration
    Get
    Set
public:
property Pca9536TypeConfiguration ConfigurationC01 {
    Pca9536TypeConfiguration get ();
    void set (Pca9536TypeConfiguration value);
}
member ConfigurationC01 : Pca9536TypeConfiguration with get, set

Property Value

Type: Pca9536TypeConfiguration
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.ConfigurationC02 Property

IRD

Pca9536ConfigurationC02 Property

Configuration (C-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypeConfiguration ConfigurationC02 { get; set; }
Public Property ConfigurationC02 As Pca9536TypeConfiguration
    Get
    Set
public:
property Pca9536TypeConfiguration ConfigurationC02 {
    Pca9536TypeConfiguration get ();
    void set (Pca9536TypeConfiguration value);
}
member ConfigurationC02 : Pca9536TypeConfiguration with get, set

Property Value

Type: Pca9536TypeConfiguration
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.ConfigurationC03 Property

IRD

Pca9536ConfigurationC03 Property

Configuration (C-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypeConfiguration ConfigurationC03 { get; set; }
Public Property ConfigurationC03 As Pca9536TypeConfiguration
    Get
    Set
public:
property Pca9536TypeConfiguration ConfigurationC03 {
    Pca9536TypeConfiguration get ();
    void set (Pca9536TypeConfiguration value);
}
member ConfigurationC03 : Pca9536TypeConfiguration with get, set

Property Value

Type: Pca9536TypeConfiguration
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.InputI00 Property

IRD

Pca9536InputI00 Property

Input (I-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypeLevel InputI00 { get; }
Public ReadOnly Property InputI00 As Pca9536TypeLevel
    Get
public:
property Pca9536TypeLevel InputI00 {
    Pca9536TypeLevel get ();
}
member InputI00 : Pca9536TypeLevel with get

Property Value

Type: Pca9536TypeLevel
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.InputI01 Property

IRD

Pca9536InputI01 Property

Input (I-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypeLevel InputI01 { get; }
Public ReadOnly Property InputI01 As Pca9536TypeLevel
    Get
public:
property Pca9536TypeLevel InputI01 {
    Pca9536TypeLevel get ();
}
member InputI01 : Pca9536TypeLevel with get

Property Value

Type: Pca9536TypeLevel
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.InputI02 Property

IRD

Pca9536InputI02 Property

Input (I-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypeLevel InputI02 { get; }
Public ReadOnly Property InputI02 As Pca9536TypeLevel
    Get
public:
property Pca9536TypeLevel InputI02 {
    Pca9536TypeLevel get ();
}
member InputI02 : Pca9536TypeLevel with get

Property Value

Type: Pca9536TypeLevel
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.InputI03 Property

IRD

Pca9536InputI03 Property

Input (I-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypeLevel InputI03 { get; }
Public ReadOnly Property InputI03 As Pca9536TypeLevel
    Get
public:
property Pca9536TypeLevel InputI03 {
    Pca9536TypeLevel get ();
}
member InputI03 : Pca9536TypeLevel with get

Property Value

Type: Pca9536TypeLevel
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.OutputO00 Property

IRD

Pca9536OutputO00 Property

Output (O-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypeLevel OutputO00 { get; set; }
Public Property OutputO00 As Pca9536TypeLevel
    Get
    Set
public:
property Pca9536TypeLevel OutputO00 {
    Pca9536TypeLevel get ();
    void set (Pca9536TypeLevel value);
}
member OutputO00 : Pca9536TypeLevel with get, set

Property Value

Type: Pca9536TypeLevel
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.OutputO01 Property

IRD

Pca9536OutputO01 Property

Output (O-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypeLevel OutputO01 { get; set; }
Public Property OutputO01 As Pca9536TypeLevel
    Get
    Set
public:
property Pca9536TypeLevel OutputO01 {
    Pca9536TypeLevel get ();
    void set (Pca9536TypeLevel value);
}
member OutputO01 : Pca9536TypeLevel with get, set

Property Value

Type: Pca9536TypeLevel
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.OutputO02 Property

IRD

Pca9536OutputO02 Property

Output (O-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypeLevel OutputO02 { get; set; }
Public Property OutputO02 As Pca9536TypeLevel
    Get
    Set
public:
property Pca9536TypeLevel OutputO02 {
    Pca9536TypeLevel get ();
    void set (Pca9536TypeLevel value);
}
member OutputO02 : Pca9536TypeLevel with get, set

Property Value

Type: Pca9536TypeLevel
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.OutputO03 Property

IRD

Pca9536OutputO03 Property

Output (O-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypeLevel OutputO03 { get; set; }
Public Property OutputO03 As Pca9536TypeLevel
    Get
    Set
public:
property Pca9536TypeLevel OutputO03 {
    Pca9536TypeLevel get ();
    void set (Pca9536TypeLevel value);
}
member OutputO03 : Pca9536TypeLevel with get, set

Property Value

Type: Pca9536TypeLevel
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.PolarityInversionP00 Property

IRD

Pca9536PolarityInversionP00 Property

Polarity Inversion (P-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypePolarity PolarityInversionP00 { get; set; }
Public Property PolarityInversionP00 As Pca9536TypePolarity
    Get
    Set
public:
property Pca9536TypePolarity PolarityInversionP00 {
    Pca9536TypePolarity get ();
    void set (Pca9536TypePolarity value);
}
member PolarityInversionP00 : Pca9536TypePolarity with get, set

Property Value

Type: Pca9536TypePolarity
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.PolarityInversionP01 Property

IRD

Pca9536PolarityInversionP01 Property

Polarity Inversion (P-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypePolarity PolarityInversionP01 { get; set; }
Public Property PolarityInversionP01 As Pca9536TypePolarity
    Get
    Set
public:
property Pca9536TypePolarity PolarityInversionP01 {
    Pca9536TypePolarity get ();
    void set (Pca9536TypePolarity value);
}
member PolarityInversionP01 : Pca9536TypePolarity with get, set

Property Value

Type: Pca9536TypePolarity
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.PolarityInversionP02 Property

IRD

Pca9536PolarityInversionP02 Property

Polarity Inversion (P-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypePolarity PolarityInversionP02 { get; set; }
Public Property PolarityInversionP02 As Pca9536TypePolarity
    Get
    Set
public:
property Pca9536TypePolarity PolarityInversionP02 {
    Pca9536TypePolarity get ();
    void set (Pca9536TypePolarity value);
}
member PolarityInversionP02 : Pca9536TypePolarity with get, set

Property Value

Type: Pca9536TypePolarity
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.PolarityInversionP03 Property

IRD

Pca9536PolarityInversionP03 Property

Polarity Inversion (P-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9536TypePolarity PolarityInversionP03 { get; set; }
Public Property PolarityInversionP03 As Pca9536TypePolarity
    Get
    Set
public:
property Pca9536TypePolarity PolarityInversionP03 {
    Pca9536TypePolarity get ();
    void set (Pca9536TypePolarity value);
}
member PolarityInversionP03 : Pca9536TypePolarity with get, set

Property Value

Type: Pca9536TypePolarity
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536 Methods

The Pca9536 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.Flush Method

IRD

Pca9536Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9536 Class
telos.Ird.TexasInstruments Namespace


Pca9536.TypeConfiguration Enumeration

IRD

Pca9536TypeConfiguration Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Input | 1 | Input
Output | 0 | Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9536.TypeLevel Enumeration

IRD

Pca9536TypeLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLevel
Public Enumeration TypeLevel
public enum class TypeLevel
type TypeLevel
Members
Member name | Value | Description
High | 1 | High
Low | 0 | Low
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9536.TypePolarity Enumeration

IRD

Pca9536TypePolarity Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarity
Public Enumeration TypePolarity
public enum class TypePolarity
type TypePolarity
Members
Member name | Value | Description
Inverted | 1 | Inverted
Normal | 0 | Normal
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9539 Class

Texas Instruments: PCA 9539
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPca9539

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9539
Public Class Pca9539
public ref class Pca9539
type Pca9539 =  class end

The Pca9539 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9539 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC03 | Configuration (C-03)
Public property | ConfigurationC04 | Configuration (C-04)
Public property | ConfigurationC05 | Configuration (C-05)
Public property | ConfigurationC06 | Configuration (C-06)
Public property | ConfigurationC07 | Configuration (C-07)
Public property | ConfigurationC10 | Configuration (C-10)
Public property | ConfigurationC11 | Configuration (C-11)
Public property | ConfigurationC12 | Configuration (C-12)
Public property | ConfigurationC13 | Configuration (C-13)
Public property | ConfigurationC14 | Configuration (C-14)
Public property | ConfigurationC15 | Configuration (C-15)
Public property | ConfigurationC16 | Configuration (C-16)
Public property | ConfigurationC17 | Configuration (C-17)
Public property | InputI00 | Input (I-00)
Public property | InputI01 | Input (I-01)
Public property | InputI02 | Input (I-02)
Public property | InputI03 | Input (I-03)
Public property | InputI04 | Input (I-04)
Public property | InputI05 | Input (I-05)
Public property | InputI06 | Input (I-06)
Public property | InputI07 | Input (I-07)
Public property | InputI10 | Input (I-10)
Public property | InputI11 | Input (I-11)
Public property | InputI12 | Input (I-12)
Public property | InputI13 | Input (I-13)
Public property | InputI14 | Input (I-14)
Public property | InputI15 | Input (I-15)
Public property | InputI16 | Input (I-16)
Public property | InputI17 | Input (I-17)
Public property | OutputO00 | Output (O-00)
Public property | OutputO01 | Output (O-01)
Public property | OutputO02 | Output (O-02)
Public property | OutputO03 | Output (O-03)
Public property | OutputO04 | Output (O-04)
Public property | OutputO05 | Output (O-05)
Public property | OutputO06 | Output (O-06)
Public property | OutputO07 | Output (O-07)
Public property | OutputO10 | Output (O-10)
Public property | OutputO11 | Output (O-11)
Public property | OutputO12 | Output (O-12)
Public property | OutputO13 | Output (O-13)
Public property | OutputO14 | Output (O-14)
Public property | OutputO15 | Output (O-15)
Public property | OutputO16 | Output (O-16)
Public property | OutputO17 | Output (O-17)
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Public property | PolarityInversionP04 | Polarity Inversion (P-04)
Public property | PolarityInversionP05 | Polarity Inversion (P-05)
Public property | PolarityInversionP06 | Polarity Inversion (P-06)
Public property | PolarityInversionP07 | Polarity Inversion (P-07)
Public property | PolarityInversionP10 | Polarity Inversion (P-10)
Public property | PolarityInversionP11 | Polarity Inversion (P-11)
Public property | PolarityInversionP12 | Polarity Inversion (P-12)
Public property | PolarityInversionP13 | Polarity Inversion (P-13)
Public property | PolarityInversionP14 | Polarity Inversion (P-14)
Public property | PolarityInversionP15 | Polarity Inversion (P-15)
Public property | PolarityInversionP16 | Polarity Inversion (P-16)
Public property | PolarityInversionP17 | Polarity Inversion (P-17)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Remote 16-Bit I2C And SMBus Low-Power I/O Expander With Interrupt Output, Reset And Configuration Registers
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9539 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9539(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9539

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539 Properties

The Pca9539 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC03 | Configuration (C-03)
Public property | ConfigurationC04 | Configuration (C-04)
Public property | ConfigurationC05 | Configuration (C-05)
Public property | ConfigurationC06 | Configuration (C-06)
Public property | ConfigurationC07 | Configuration (C-07)
Public property | ConfigurationC10 | Configuration (C-10)
Public property | ConfigurationC11 | Configuration (C-11)
Public property | ConfigurationC12 | Configuration (C-12)
Public property | ConfigurationC13 | Configuration (C-13)
Public property | ConfigurationC14 | Configuration (C-14)
Public property | ConfigurationC15 | Configuration (C-15)
Public property | ConfigurationC16 | Configuration (C-16)
Public property | ConfigurationC17 | Configuration (C-17)
Public property | InputI00 | Input (I-00)
Public property | InputI01 | Input (I-01)
Public property | InputI02 | Input (I-02)
Public property | InputI03 | Input (I-03)
Public property | InputI04 | Input (I-04)
Public property | InputI05 | Input (I-05)
Public property | InputI06 | Input (I-06)
Public property | InputI07 | Input (I-07)
Public property | InputI10 | Input (I-10)
Public property | InputI11 | Input (I-11)
Public property | InputI12 | Input (I-12)
Public property | InputI13 | Input (I-13)
Public property | InputI14 | Input (I-14)
Public property | InputI15 | Input (I-15)
Public property | InputI16 | Input (I-16)
Public property | InputI17 | Input (I-17)
Public property | OutputO00 | Output (O-00)
Public property | OutputO01 | Output (O-01)
Public property | OutputO02 | Output (O-02)
Public property | OutputO03 | Output (O-03)
Public property | OutputO04 | Output (O-04)
Public property | OutputO05 | Output (O-05)
Public property | OutputO06 | Output (O-06)
Public property | OutputO07 | Output (O-07)
Public property | OutputO10 | Output (O-10)
Public property | OutputO11 | Output (O-11)
Public property | OutputO12 | Output (O-12)
Public property | OutputO13 | Output (O-13)
Public property | OutputO14 | Output (O-14)
Public property | OutputO15 | Output (O-15)
Public property | OutputO16 | Output (O-16)
Public property | OutputO17 | Output (O-17)
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Public property | PolarityInversionP04 | Polarity Inversion (P-04)
Public property | PolarityInversionP05 | Polarity Inversion (P-05)
Public property | PolarityInversionP06 | Polarity Inversion (P-06)
Public property | PolarityInversionP07 | Polarity Inversion (P-07)
Public property | PolarityInversionP10 | Polarity Inversion (P-10)
Public property | PolarityInversionP11 | Polarity Inversion (P-11)
Public property | PolarityInversionP12 | Polarity Inversion (P-12)
Public property | PolarityInversionP13 | Polarity Inversion (P-13)
Public property | PolarityInversionP14 | Polarity Inversion (P-14)
Public property | PolarityInversionP15 | Polarity Inversion (P-15)
Public property | PolarityInversionP16 | Polarity Inversion (P-16)
Public property | PolarityInversionP17 | Polarity Inversion (P-17)
Top
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.AutoFlush Property

IRD

Pca9539AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.ConfigurationC00 Property

IRD

Pca9539ConfigurationC00 Property

Configuration (C-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationC00 { get; set; }
Public Property ConfigurationC00 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationC00 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationC00 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.ConfigurationC01 Property

IRD

Pca9539ConfigurationC01 Property

Configuration (C-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationC01 { get; set; }
Public Property ConfigurationC01 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationC01 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationC01 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.ConfigurationC02 Property

IRD

Pca9539ConfigurationC02 Property

Configuration (C-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationC02 { get; set; }
Public Property ConfigurationC02 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationC02 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationC02 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.ConfigurationC03 Property

IRD

Pca9539ConfigurationC03 Property

Configuration (C-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationC03 { get; set; }
Public Property ConfigurationC03 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationC03 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationC03 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.ConfigurationC04 Property

IRD

Pca9539ConfigurationC04 Property

Configuration (C-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationC04 { get; set; }
Public Property ConfigurationC04 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationC04 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationC04 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.ConfigurationC05 Property

IRD

Pca9539ConfigurationC05 Property

Configuration (C-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationC05 { get; set; }
Public Property ConfigurationC05 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationC05 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationC05 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.ConfigurationC06 Property

IRD

Pca9539ConfigurationC06 Property

Configuration (C-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationC06 { get; set; }
Public Property ConfigurationC06 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationC06 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationC06 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.ConfigurationC07 Property

IRD

Pca9539ConfigurationC07 Property

Configuration (C-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationC07 { get; set; }
Public Property ConfigurationC07 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationC07 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationC07 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.ConfigurationC10 Property

IRD

Pca9539ConfigurationC10 Property

Configuration (C-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationC10 { get; set; }
Public Property ConfigurationC10 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationC10 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationC10 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.ConfigurationC11 Property

IRD

Pca9539ConfigurationC11 Property

Configuration (C-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationC11 { get; set; }
Public Property ConfigurationC11 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationC11 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationC11 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.ConfigurationC12 Property

IRD

Pca9539ConfigurationC12 Property

Configuration (C-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationC12 { get; set; }
Public Property ConfigurationC12 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationC12 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationC12 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.ConfigurationC13 Property

IRD

Pca9539ConfigurationC13 Property

Configuration (C-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationC13 { get; set; }
Public Property ConfigurationC13 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationC13 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationC13 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.ConfigurationC14 Property

IRD

Pca9539ConfigurationC14 Property

Configuration (C-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationC14 { get; set; }
Public Property ConfigurationC14 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationC14 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationC14 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.ConfigurationC15 Property

IRD

Pca9539ConfigurationC15 Property

Configuration (C-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationC15 { get; set; }
Public Property ConfigurationC15 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationC15 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationC15 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.ConfigurationC16 Property

IRD

Pca9539ConfigurationC16 Property

Configuration (C-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationC16 { get; set; }
Public Property ConfigurationC16 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationC16 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationC16 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.ConfigurationC17 Property

IRD

Pca9539ConfigurationC17 Property

Configuration (C-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeConfiguration ConfigurationC17 { get; set; }
Public Property ConfigurationC17 As Pca9539TypeConfiguration
    Get
    Set
public:
property Pca9539TypeConfiguration ConfigurationC17 {
    Pca9539TypeConfiguration get ();
    void set (Pca9539TypeConfiguration value);
}
member ConfigurationC17 : Pca9539TypeConfiguration with get, set

Property Value

Type: Pca9539TypeConfiguration
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.InputI00 Property

IRD

Pca9539InputI00 Property

Input (I-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel InputI00 { get; }
Public ReadOnly Property InputI00 As Pca9539TypeLevel
    Get
public:
property Pca9539TypeLevel InputI00 {
    Pca9539TypeLevel get ();
}
member InputI00 : Pca9539TypeLevel with get

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.InputI01 Property

IRD

Pca9539InputI01 Property

Input (I-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel InputI01 { get; }
Public ReadOnly Property InputI01 As Pca9539TypeLevel
    Get
public:
property Pca9539TypeLevel InputI01 {
    Pca9539TypeLevel get ();
}
member InputI01 : Pca9539TypeLevel with get

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.InputI02 Property

IRD

Pca9539InputI02 Property

Input (I-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel InputI02 { get; }
Public ReadOnly Property InputI02 As Pca9539TypeLevel
    Get
public:
property Pca9539TypeLevel InputI02 {
    Pca9539TypeLevel get ();
}
member InputI02 : Pca9539TypeLevel with get

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.InputI03 Property

IRD

Pca9539InputI03 Property

Input (I-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel InputI03 { get; }
Public ReadOnly Property InputI03 As Pca9539TypeLevel
    Get
public:
property Pca9539TypeLevel InputI03 {
    Pca9539TypeLevel get ();
}
member InputI03 : Pca9539TypeLevel with get

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.InputI04 Property

IRD

Pca9539InputI04 Property

Input (I-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel InputI04 { get; }
Public ReadOnly Property InputI04 As Pca9539TypeLevel
    Get
public:
property Pca9539TypeLevel InputI04 {
    Pca9539TypeLevel get ();
}
member InputI04 : Pca9539TypeLevel with get

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.InputI05 Property

IRD

Pca9539InputI05 Property

Input (I-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel InputI05 { get; }
Public ReadOnly Property InputI05 As Pca9539TypeLevel
    Get
public:
property Pca9539TypeLevel InputI05 {
    Pca9539TypeLevel get ();
}
member InputI05 : Pca9539TypeLevel with get

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.InputI06 Property

IRD

Pca9539InputI06 Property

Input (I-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel InputI06 { get; }
Public ReadOnly Property InputI06 As Pca9539TypeLevel
    Get
public:
property Pca9539TypeLevel InputI06 {
    Pca9539TypeLevel get ();
}
member InputI06 : Pca9539TypeLevel with get

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.InputI07 Property

IRD

Pca9539InputI07 Property

Input (I-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel InputI07 { get; }
Public ReadOnly Property InputI07 As Pca9539TypeLevel
    Get
public:
property Pca9539TypeLevel InputI07 {
    Pca9539TypeLevel get ();
}
member InputI07 : Pca9539TypeLevel with get

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.InputI10 Property

IRD

Pca9539InputI10 Property

Input (I-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel InputI10 { get; }
Public ReadOnly Property InputI10 As Pca9539TypeLevel
    Get
public:
property Pca9539TypeLevel InputI10 {
    Pca9539TypeLevel get ();
}
member InputI10 : Pca9539TypeLevel with get

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.InputI11 Property

IRD

Pca9539InputI11 Property

Input (I-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel InputI11 { get; }
Public ReadOnly Property InputI11 As Pca9539TypeLevel
    Get
public:
property Pca9539TypeLevel InputI11 {
    Pca9539TypeLevel get ();
}
member InputI11 : Pca9539TypeLevel with get

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.InputI12 Property

IRD

Pca9539InputI12 Property

Input (I-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel InputI12 { get; }
Public ReadOnly Property InputI12 As Pca9539TypeLevel
    Get
public:
property Pca9539TypeLevel InputI12 {
    Pca9539TypeLevel get ();
}
member InputI12 : Pca9539TypeLevel with get

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.InputI13 Property

IRD

Pca9539InputI13 Property

Input (I-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel InputI13 { get; }
Public ReadOnly Property InputI13 As Pca9539TypeLevel
    Get
public:
property Pca9539TypeLevel InputI13 {
    Pca9539TypeLevel get ();
}
member InputI13 : Pca9539TypeLevel with get

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.InputI14 Property

IRD

Pca9539InputI14 Property

Input (I-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel InputI14 { get; }
Public ReadOnly Property InputI14 As Pca9539TypeLevel
    Get
public:
property Pca9539TypeLevel InputI14 {
    Pca9539TypeLevel get ();
}
member InputI14 : Pca9539TypeLevel with get

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.InputI15 Property

IRD

Pca9539InputI15 Property

Input (I-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel InputI15 { get; }
Public ReadOnly Property InputI15 As Pca9539TypeLevel
    Get
public:
property Pca9539TypeLevel InputI15 {
    Pca9539TypeLevel get ();
}
member InputI15 : Pca9539TypeLevel with get

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.InputI16 Property

IRD

Pca9539InputI16 Property

Input (I-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel InputI16 { get; }
Public ReadOnly Property InputI16 As Pca9539TypeLevel
    Get
public:
property Pca9539TypeLevel InputI16 {
    Pca9539TypeLevel get ();
}
member InputI16 : Pca9539TypeLevel with get

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.InputI17 Property

IRD

Pca9539InputI17 Property

Input (I-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel InputI17 { get; }
Public ReadOnly Property InputI17 As Pca9539TypeLevel
    Get
public:
property Pca9539TypeLevel InputI17 {
    Pca9539TypeLevel get ();
}
member InputI17 : Pca9539TypeLevel with get

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.OutputO00 Property

IRD

Pca9539OutputO00 Property

Output (O-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel OutputO00 { get; set; }
Public Property OutputO00 As Pca9539TypeLevel
    Get
    Set
public:
property Pca9539TypeLevel OutputO00 {
    Pca9539TypeLevel get ();
    void set (Pca9539TypeLevel value);
}
member OutputO00 : Pca9539TypeLevel with get, set

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.OutputO01 Property

IRD

Pca9539OutputO01 Property

Output (O-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel OutputO01 { get; set; }
Public Property OutputO01 As Pca9539TypeLevel
    Get
    Set
public:
property Pca9539TypeLevel OutputO01 {
    Pca9539TypeLevel get ();
    void set (Pca9539TypeLevel value);
}
member OutputO01 : Pca9539TypeLevel with get, set

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.OutputO02 Property

IRD

Pca9539OutputO02 Property

Output (O-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel OutputO02 { get; set; }
Public Property OutputO02 As Pca9539TypeLevel
    Get
    Set
public:
property Pca9539TypeLevel OutputO02 {
    Pca9539TypeLevel get ();
    void set (Pca9539TypeLevel value);
}
member OutputO02 : Pca9539TypeLevel with get, set

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.OutputO03 Property

IRD

Pca9539OutputO03 Property

Output (O-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel OutputO03 { get; set; }
Public Property OutputO03 As Pca9539TypeLevel
    Get
    Set
public:
property Pca9539TypeLevel OutputO03 {
    Pca9539TypeLevel get ();
    void set (Pca9539TypeLevel value);
}
member OutputO03 : Pca9539TypeLevel with get, set

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.OutputO04 Property

IRD

Pca9539OutputO04 Property

Output (O-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel OutputO04 { get; set; }
Public Property OutputO04 As Pca9539TypeLevel
    Get
    Set
public:
property Pca9539TypeLevel OutputO04 {
    Pca9539TypeLevel get ();
    void set (Pca9539TypeLevel value);
}
member OutputO04 : Pca9539TypeLevel with get, set

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.OutputO05 Property

IRD

Pca9539OutputO05 Property

Output (O-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel OutputO05 { get; set; }
Public Property OutputO05 As Pca9539TypeLevel
    Get
    Set
public:
property Pca9539TypeLevel OutputO05 {
    Pca9539TypeLevel get ();
    void set (Pca9539TypeLevel value);
}
member OutputO05 : Pca9539TypeLevel with get, set

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.OutputO06 Property

IRD

Pca9539OutputO06 Property

Output (O-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel OutputO06 { get; set; }
Public Property OutputO06 As Pca9539TypeLevel
    Get
    Set
public:
property Pca9539TypeLevel OutputO06 {
    Pca9539TypeLevel get ();
    void set (Pca9539TypeLevel value);
}
member OutputO06 : Pca9539TypeLevel with get, set

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.OutputO07 Property

IRD

Pca9539OutputO07 Property

Output (O-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel OutputO07 { get; set; }
Public Property OutputO07 As Pca9539TypeLevel
    Get
    Set
public:
property Pca9539TypeLevel OutputO07 {
    Pca9539TypeLevel get ();
    void set (Pca9539TypeLevel value);
}
member OutputO07 : Pca9539TypeLevel with get, set

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.OutputO10 Property

IRD

Pca9539OutputO10 Property

Output (O-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel OutputO10 { get; set; }
Public Property OutputO10 As Pca9539TypeLevel
    Get
    Set
public:
property Pca9539TypeLevel OutputO10 {
    Pca9539TypeLevel get ();
    void set (Pca9539TypeLevel value);
}
member OutputO10 : Pca9539TypeLevel with get, set

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.OutputO11 Property

IRD

Pca9539OutputO11 Property

Output (O-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel OutputO11 { get; set; }
Public Property OutputO11 As Pca9539TypeLevel
    Get
    Set
public:
property Pca9539TypeLevel OutputO11 {
    Pca9539TypeLevel get ();
    void set (Pca9539TypeLevel value);
}
member OutputO11 : Pca9539TypeLevel with get, set

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.OutputO12 Property

IRD

Pca9539OutputO12 Property

Output (O-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel OutputO12 { get; set; }
Public Property OutputO12 As Pca9539TypeLevel
    Get
    Set
public:
property Pca9539TypeLevel OutputO12 {
    Pca9539TypeLevel get ();
    void set (Pca9539TypeLevel value);
}
member OutputO12 : Pca9539TypeLevel with get, set

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.OutputO13 Property

IRD

Pca9539OutputO13 Property

Output (O-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel OutputO13 { get; set; }
Public Property OutputO13 As Pca9539TypeLevel
    Get
    Set
public:
property Pca9539TypeLevel OutputO13 {
    Pca9539TypeLevel get ();
    void set (Pca9539TypeLevel value);
}
member OutputO13 : Pca9539TypeLevel with get, set

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.OutputO14 Property

IRD

Pca9539OutputO14 Property

Output (O-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel OutputO14 { get; set; }
Public Property OutputO14 As Pca9539TypeLevel
    Get
    Set
public:
property Pca9539TypeLevel OutputO14 {
    Pca9539TypeLevel get ();
    void set (Pca9539TypeLevel value);
}
member OutputO14 : Pca9539TypeLevel with get, set

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.OutputO15 Property

IRD

Pca9539OutputO15 Property

Output (O-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel OutputO15 { get; set; }
Public Property OutputO15 As Pca9539TypeLevel
    Get
    Set
public:
property Pca9539TypeLevel OutputO15 {
    Pca9539TypeLevel get ();
    void set (Pca9539TypeLevel value);
}
member OutputO15 : Pca9539TypeLevel with get, set

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.OutputO16 Property

IRD

Pca9539OutputO16 Property

Output (O-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel OutputO16 { get; set; }
Public Property OutputO16 As Pca9539TypeLevel
    Get
    Set
public:
property Pca9539TypeLevel OutputO16 {
    Pca9539TypeLevel get ();
    void set (Pca9539TypeLevel value);
}
member OutputO16 : Pca9539TypeLevel with get, set

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.OutputO17 Property

IRD

Pca9539OutputO17 Property

Output (O-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypeLevel OutputO17 { get; set; }
Public Property OutputO17 As Pca9539TypeLevel
    Get
    Set
public:
property Pca9539TypeLevel OutputO17 {
    Pca9539TypeLevel get ();
    void set (Pca9539TypeLevel value);
}
member OutputO17 : Pca9539TypeLevel with get, set

Property Value

Type: Pca9539TypeLevel
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.PolarityInversionP00 Property

IRD

Pca9539PolarityInversionP00 Property

Polarity Inversion (P-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarity PolarityInversionP00 { get; set; }
Public Property PolarityInversionP00 As Pca9539TypePolarity
    Get
    Set
public:
property Pca9539TypePolarity PolarityInversionP00 {
    Pca9539TypePolarity get ();
    void set (Pca9539TypePolarity value);
}
member PolarityInversionP00 : Pca9539TypePolarity with get, set

Property Value

Type: Pca9539TypePolarity
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.PolarityInversionP01 Property

IRD

Pca9539PolarityInversionP01 Property

Polarity Inversion (P-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarity PolarityInversionP01 { get; set; }
Public Property PolarityInversionP01 As Pca9539TypePolarity
    Get
    Set
public:
property Pca9539TypePolarity PolarityInversionP01 {
    Pca9539TypePolarity get ();
    void set (Pca9539TypePolarity value);
}
member PolarityInversionP01 : Pca9539TypePolarity with get, set

Property Value

Type: Pca9539TypePolarity
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.PolarityInversionP02 Property

IRD

Pca9539PolarityInversionP02 Property

Polarity Inversion (P-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarity PolarityInversionP02 { get; set; }
Public Property PolarityInversionP02 As Pca9539TypePolarity
    Get
    Set
public:
property Pca9539TypePolarity PolarityInversionP02 {
    Pca9539TypePolarity get ();
    void set (Pca9539TypePolarity value);
}
member PolarityInversionP02 : Pca9539TypePolarity with get, set

Property Value

Type: Pca9539TypePolarity
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.PolarityInversionP03 Property

IRD

Pca9539PolarityInversionP03 Property

Polarity Inversion (P-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarity PolarityInversionP03 { get; set; }
Public Property PolarityInversionP03 As Pca9539TypePolarity
    Get
    Set
public:
property Pca9539TypePolarity PolarityInversionP03 {
    Pca9539TypePolarity get ();
    void set (Pca9539TypePolarity value);
}
member PolarityInversionP03 : Pca9539TypePolarity with get, set

Property Value

Type: Pca9539TypePolarity
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.PolarityInversionP04 Property

IRD

Pca9539PolarityInversionP04 Property

Polarity Inversion (P-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarity PolarityInversionP04 { get; set; }
Public Property PolarityInversionP04 As Pca9539TypePolarity
    Get
    Set
public:
property Pca9539TypePolarity PolarityInversionP04 {
    Pca9539TypePolarity get ();
    void set (Pca9539TypePolarity value);
}
member PolarityInversionP04 : Pca9539TypePolarity with get, set

Property Value

Type: Pca9539TypePolarity
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.PolarityInversionP05 Property

IRD

Pca9539PolarityInversionP05 Property

Polarity Inversion (P-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarity PolarityInversionP05 { get; set; }
Public Property PolarityInversionP05 As Pca9539TypePolarity
    Get
    Set
public:
property Pca9539TypePolarity PolarityInversionP05 {
    Pca9539TypePolarity get ();
    void set (Pca9539TypePolarity value);
}
member PolarityInversionP05 : Pca9539TypePolarity with get, set

Property Value

Type: Pca9539TypePolarity
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.PolarityInversionP06 Property

IRD

Pca9539PolarityInversionP06 Property

Polarity Inversion (P-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarity PolarityInversionP06 { get; set; }
Public Property PolarityInversionP06 As Pca9539TypePolarity
    Get
    Set
public:
property Pca9539TypePolarity PolarityInversionP06 {
    Pca9539TypePolarity get ();
    void set (Pca9539TypePolarity value);
}
member PolarityInversionP06 : Pca9539TypePolarity with get, set

Property Value

Type: Pca9539TypePolarity
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.PolarityInversionP07 Property

IRD

Pca9539PolarityInversionP07 Property

Polarity Inversion (P-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarity PolarityInversionP07 { get; set; }
Public Property PolarityInversionP07 As Pca9539TypePolarity
    Get
    Set
public:
property Pca9539TypePolarity PolarityInversionP07 {
    Pca9539TypePolarity get ();
    void set (Pca9539TypePolarity value);
}
member PolarityInversionP07 : Pca9539TypePolarity with get, set

Property Value

Type: Pca9539TypePolarity
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.PolarityInversionP10 Property

IRD

Pca9539PolarityInversionP10 Property

Polarity Inversion (P-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarity PolarityInversionP10 { get; set; }
Public Property PolarityInversionP10 As Pca9539TypePolarity
    Get
    Set
public:
property Pca9539TypePolarity PolarityInversionP10 {
    Pca9539TypePolarity get ();
    void set (Pca9539TypePolarity value);
}
member PolarityInversionP10 : Pca9539TypePolarity with get, set

Property Value

Type: Pca9539TypePolarity
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.PolarityInversionP11 Property

IRD

Pca9539PolarityInversionP11 Property

Polarity Inversion (P-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarity PolarityInversionP11 { get; set; }
Public Property PolarityInversionP11 As Pca9539TypePolarity
    Get
    Set
public:
property Pca9539TypePolarity PolarityInversionP11 {
    Pca9539TypePolarity get ();
    void set (Pca9539TypePolarity value);
}
member PolarityInversionP11 : Pca9539TypePolarity with get, set

Property Value

Type: Pca9539TypePolarity
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.PolarityInversionP12 Property

IRD

Pca9539PolarityInversionP12 Property

Polarity Inversion (P-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarity PolarityInversionP12 { get; set; }
Public Property PolarityInversionP12 As Pca9539TypePolarity
    Get
    Set
public:
property Pca9539TypePolarity PolarityInversionP12 {
    Pca9539TypePolarity get ();
    void set (Pca9539TypePolarity value);
}
member PolarityInversionP12 : Pca9539TypePolarity with get, set

Property Value

Type: Pca9539TypePolarity
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.PolarityInversionP13 Property

IRD

Pca9539PolarityInversionP13 Property

Polarity Inversion (P-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarity PolarityInversionP13 { get; set; }
Public Property PolarityInversionP13 As Pca9539TypePolarity
    Get
    Set
public:
property Pca9539TypePolarity PolarityInversionP13 {
    Pca9539TypePolarity get ();
    void set (Pca9539TypePolarity value);
}
member PolarityInversionP13 : Pca9539TypePolarity with get, set

Property Value

Type: Pca9539TypePolarity
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.PolarityInversionP14 Property

IRD

Pca9539PolarityInversionP14 Property

Polarity Inversion (P-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarity PolarityInversionP14 { get; set; }
Public Property PolarityInversionP14 As Pca9539TypePolarity
    Get
    Set
public:
property Pca9539TypePolarity PolarityInversionP14 {
    Pca9539TypePolarity get ();
    void set (Pca9539TypePolarity value);
}
member PolarityInversionP14 : Pca9539TypePolarity with get, set

Property Value

Type: Pca9539TypePolarity
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.PolarityInversionP15 Property

IRD

Pca9539PolarityInversionP15 Property

Polarity Inversion (P-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarity PolarityInversionP15 { get; set; }
Public Property PolarityInversionP15 As Pca9539TypePolarity
    Get
    Set
public:
property Pca9539TypePolarity PolarityInversionP15 {
    Pca9539TypePolarity get ();
    void set (Pca9539TypePolarity value);
}
member PolarityInversionP15 : Pca9539TypePolarity with get, set

Property Value

Type: Pca9539TypePolarity
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.PolarityInversionP16 Property

IRD

Pca9539PolarityInversionP16 Property

Polarity Inversion (P-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarity PolarityInversionP16 { get; set; }
Public Property PolarityInversionP16 As Pca9539TypePolarity
    Get
    Set
public:
property Pca9539TypePolarity PolarityInversionP16 {
    Pca9539TypePolarity get ();
    void set (Pca9539TypePolarity value);
}
member PolarityInversionP16 : Pca9539TypePolarity with get, set

Property Value

Type: Pca9539TypePolarity
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.PolarityInversionP17 Property

IRD

Pca9539PolarityInversionP17 Property

Polarity Inversion (P-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9539TypePolarity PolarityInversionP17 { get; set; }
Public Property PolarityInversionP17 As Pca9539TypePolarity
    Get
    Set
public:
property Pca9539TypePolarity PolarityInversionP17 {
    Pca9539TypePolarity get ();
    void set (Pca9539TypePolarity value);
}
member PolarityInversionP17 : Pca9539TypePolarity with get, set

Property Value

Type: Pca9539TypePolarity
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539 Methods

The Pca9539 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.Flush Method

IRD

Pca9539Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9539 Class
telos.Ird.TexasInstruments Namespace


Pca9539.TypeConfiguration Enumeration

IRD

Pca9539TypeConfiguration Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Input | 1 | Input
Output | 0 | Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9539.TypeLevel Enumeration

IRD

Pca9539TypeLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLevel
Public Enumeration TypeLevel
public enum class TypeLevel
type TypeLevel
Members
Member name | Value | Description
High | 1 | High
Low | 0 | Low
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9539.TypePolarity Enumeration

IRD

Pca9539TypePolarity Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarity
Public Enumeration TypePolarity
public enum class TypePolarity
type TypePolarity
Members
Member name | Value | Description
Inverted | 1 | Inverted
Normal | 0 | Normal
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9543a Class

Texas Instruments: PCA 9543 A
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPca9543a

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9543a
Public Class Pca9543a
public ref class Pca9543a
type Pca9543a =  class end

The Pca9543a type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9543a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | InterruptChannel0 | Interrupt Channel 0
Public property | InterruptChannel1 | Interrupt Channel 1
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Two-Channel I2C-SMBus Switch With Interrupt Logic and Reset
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9543a Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9543a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9543a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9543a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9543a Class
telos.Ird.TexasInstruments Namespace


Pca9543a Properties

The Pca9543a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | InterruptChannel0 | Interrupt Channel 0
Public property | InterruptChannel1 | Interrupt Channel 1
Top
See Also

Reference

Pca9543a Class
telos.Ird.TexasInstruments Namespace


Pca9543a.AutoFlush Property

IRD

Pca9543aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9543a Class
telos.Ird.TexasInstruments Namespace


Pca9543a.Channel0 Property

IRD

Pca9543aChannel0 Property

Channel 0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9543aTypeEnabledDisabled Channel0 { get; set; }
Public Property Channel0 As Pca9543aTypeEnabledDisabled
    Get
    Set
public:
property Pca9543aTypeEnabledDisabled Channel0 {
    Pca9543aTypeEnabledDisabled get ();
    void set (Pca9543aTypeEnabledDisabled value);
}
member Channel0 : Pca9543aTypeEnabledDisabled with get, set

Property Value

Type: Pca9543aTypeEnabledDisabled
See Also

Reference

Pca9543a Class
telos.Ird.TexasInstruments Namespace


Pca9543a.Channel1 Property

IRD

Pca9543aChannel1 Property

Channel 1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9543aTypeEnabledDisabled Channel1 { get; set; }
Public Property Channel1 As Pca9543aTypeEnabledDisabled
    Get
    Set
public:
property Pca9543aTypeEnabledDisabled Channel1 {
    Pca9543aTypeEnabledDisabled get ();
    void set (Pca9543aTypeEnabledDisabled value);
}
member Channel1 : Pca9543aTypeEnabledDisabled with get, set

Property Value

Type: Pca9543aTypeEnabledDisabled
See Also

Reference

Pca9543a Class
telos.Ird.TexasInstruments Namespace


Pca9543a.InterruptChannel0 Property

IRD

Pca9543aInterruptChannel0 Property

Interrupt Channel 0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9543aTypeInterrupt InterruptChannel0 { get; }
Public ReadOnly Property InterruptChannel0 As Pca9543aTypeInterrupt
    Get
public:
property Pca9543aTypeInterrupt InterruptChannel0 {
    Pca9543aTypeInterrupt get ();
}
member InterruptChannel0 : Pca9543aTypeInterrupt with get

Property Value

Type: Pca9543aTypeInterrupt
See Also

Reference

Pca9543a Class
telos.Ird.TexasInstruments Namespace


Pca9543a.InterruptChannel1 Property

IRD

Pca9543aInterruptChannel1 Property

Interrupt Channel 1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9543aTypeInterrupt InterruptChannel1 { get; }
Public ReadOnly Property InterruptChannel1 As Pca9543aTypeInterrupt
    Get
public:
property Pca9543aTypeInterrupt InterruptChannel1 {
    Pca9543aTypeInterrupt get ();
}
member InterruptChannel1 : Pca9543aTypeInterrupt with get

Property Value

Type: Pca9543aTypeInterrupt
See Also

Reference

Pca9543a Class
telos.Ird.TexasInstruments Namespace


Pca9543a Methods

The Pca9543a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9543a Class
telos.Ird.TexasInstruments Namespace


Pca9543a.Flush Method

IRD

Pca9543aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9543a Class
telos.Ird.TexasInstruments Namespace


Pca9543a.TypeEnabledDisabled Enumeration

IRD

Pca9543aTypeEnabledDisabled Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeEnabledDisabled
Public Enumeration TypeEnabledDisabled
public enum class TypeEnabledDisabled
type TypeEnabledDisabled
Members
Member name | Value | Description
Enabled | 1 | Enabled
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9543a.TypeInterrupt Enumeration

IRD

Pca9543aTypeInterrupt Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterrupt
Public Enumeration TypeInterrupt
public enum class TypeInterrupt
type TypeInterrupt
Members
Member name | Value | Description
Interrupt | 1 | Interrupt
NoInterrupt | 0 | No Interrupt
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9545a Class

Texas Instruments: PCA 9545 A
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPca9545a

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9545a
Public Class Pca9545a
public ref class Pca9545a
type Pca9545a =  class end

The Pca9545a type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9545a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | Channel2 | Channel 2
Public property | Channel3 | Channel 3
Public property | InterruptChannel0 | Interrupt Channel 0
Public property | InterruptChannel1 | Interrupt Channel 1
Public property | InterruptChannel2 | Interrupt Channel 2
Public property | InterruptChannel3 | Interrupt Channel 3
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
4-Channel I2C And SMBus Switch With Interrupt Logic And Reset Functions
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9545a Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9545a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9545a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9545a Class
telos.Ird.TexasInstruments Namespace


Pca9545a Properties

The Pca9545a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | Channel2 | Channel 2
Public property | Channel3 | Channel 3
Public property | InterruptChannel0 | Interrupt Channel 0
Public property | InterruptChannel1 | Interrupt Channel 1
Public property | InterruptChannel2 | Interrupt Channel 2
Public property | InterruptChannel3 | Interrupt Channel 3
Top
See Also

Reference

Pca9545a Class
telos.Ird.TexasInstruments Namespace


Pca9545a.AutoFlush Property

IRD

Pca9545aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9545a Class
telos.Ird.TexasInstruments Namespace


Pca9545a.Channel0 Property

IRD

Pca9545aChannel0 Property

Channel 0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545aTypeEnabledDisabled Channel0 { get; set; }
Public Property Channel0 As Pca9545aTypeEnabledDisabled
    Get
    Set
public:
property Pca9545aTypeEnabledDisabled Channel0 {
    Pca9545aTypeEnabledDisabled get ();
    void set (Pca9545aTypeEnabledDisabled value);
}
member Channel0 : Pca9545aTypeEnabledDisabled with get, set

Property Value

Type: Pca9545aTypeEnabledDisabled
See Also

Reference

Pca9545a Class
telos.Ird.TexasInstruments Namespace


Pca9545a.Channel1 Property

IRD

Pca9545aChannel1 Property

Channel 1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545aTypeEnabledDisabled Channel1 { get; set; }
Public Property Channel1 As Pca9545aTypeEnabledDisabled
    Get
    Set
public:
property Pca9545aTypeEnabledDisabled Channel1 {
    Pca9545aTypeEnabledDisabled get ();
    void set (Pca9545aTypeEnabledDisabled value);
}
member Channel1 : Pca9545aTypeEnabledDisabled with get, set

Property Value

Type: Pca9545aTypeEnabledDisabled
See Also

Reference

Pca9545a Class
telos.Ird.TexasInstruments Namespace


Pca9545a.Channel2 Property

IRD

Pca9545aChannel2 Property

Channel 2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545aTypeEnabledDisabled Channel2 { get; set; }
Public Property Channel2 As Pca9545aTypeEnabledDisabled
    Get
    Set
public:
property Pca9545aTypeEnabledDisabled Channel2 {
    Pca9545aTypeEnabledDisabled get ();
    void set (Pca9545aTypeEnabledDisabled value);
}
member Channel2 : Pca9545aTypeEnabledDisabled with get, set

Property Value

Type: Pca9545aTypeEnabledDisabled
See Also

Reference

Pca9545a Class
telos.Ird.TexasInstruments Namespace


Pca9545a.Channel3 Property

IRD

Pca9545aChannel3 Property

Channel 3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545aTypeEnabledDisabled Channel3 { get; set; }
Public Property Channel3 As Pca9545aTypeEnabledDisabled
    Get
    Set
public:
property Pca9545aTypeEnabledDisabled Channel3 {
    Pca9545aTypeEnabledDisabled get ();
    void set (Pca9545aTypeEnabledDisabled value);
}
member Channel3 : Pca9545aTypeEnabledDisabled with get, set

Property Value

Type: Pca9545aTypeEnabledDisabled
See Also

Reference

Pca9545a Class
telos.Ird.TexasInstruments Namespace


Pca9545a.InterruptChannel0 Property

IRD

Pca9545aInterruptChannel0 Property

Interrupt Channel 0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545aTypeInterrupt InterruptChannel0 { get; }
Public ReadOnly Property InterruptChannel0 As Pca9545aTypeInterrupt
    Get
public:
property Pca9545aTypeInterrupt InterruptChannel0 {
    Pca9545aTypeInterrupt get ();
}
member InterruptChannel0 : Pca9545aTypeInterrupt with get

Property Value

Type: Pca9545aTypeInterrupt
See Also

Reference

Pca9545a Class
telos.Ird.TexasInstruments Namespace


Pca9545a.InterruptChannel1 Property

IRD

Pca9545aInterruptChannel1 Property

Interrupt Channel 1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545aTypeInterrupt InterruptChannel1 { get; }
Public ReadOnly Property InterruptChannel1 As Pca9545aTypeInterrupt
    Get
public:
property Pca9545aTypeInterrupt InterruptChannel1 {
    Pca9545aTypeInterrupt get ();
}
member InterruptChannel1 : Pca9545aTypeInterrupt with get

Property Value

Type: Pca9545aTypeInterrupt
See Also

Reference

Pca9545a Class
telos.Ird.TexasInstruments Namespace


Pca9545a.InterruptChannel2 Property

IRD

Pca9545aInterruptChannel2 Property

Interrupt Channel 2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545aTypeInterrupt InterruptChannel2 { get; }
Public ReadOnly Property InterruptChannel2 As Pca9545aTypeInterrupt
    Get
public:
property Pca9545aTypeInterrupt InterruptChannel2 {
    Pca9545aTypeInterrupt get ();
}
member InterruptChannel2 : Pca9545aTypeInterrupt with get

Property Value

Type: Pca9545aTypeInterrupt
See Also

Reference

Pca9545a Class
telos.Ird.TexasInstruments Namespace


Pca9545a.InterruptChannel3 Property

IRD

Pca9545aInterruptChannel3 Property

Interrupt Channel 3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9545aTypeInterrupt InterruptChannel3 { get; }
Public ReadOnly Property InterruptChannel3 As Pca9545aTypeInterrupt
    Get
public:
property Pca9545aTypeInterrupt InterruptChannel3 {
    Pca9545aTypeInterrupt get ();
}
member InterruptChannel3 : Pca9545aTypeInterrupt with get

Property Value

Type: Pca9545aTypeInterrupt
See Also

Reference

Pca9545a Class
telos.Ird.TexasInstruments Namespace


Pca9545a Methods

The Pca9545a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9545a Class
telos.Ird.TexasInstruments Namespace


Pca9545a.Flush Method

IRD

Pca9545aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9545a Class
telos.Ird.TexasInstruments Namespace


Pca9545a.TypeEnabledDisabled Enumeration

IRD

Pca9545aTypeEnabledDisabled Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeEnabledDisabled
Public Enumeration TypeEnabledDisabled
public enum class TypeEnabledDisabled
type TypeEnabledDisabled
Members
Member name | Value | Description
Enabled | 1 | Enabled
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9545a.TypeInterrupt Enumeration

IRD

Pca9545aTypeInterrupt Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterrupt
Public Enumeration TypeInterrupt
public enum class TypeInterrupt
type TypeInterrupt
Members
Member name | Value | Description
Interrupt | 1 | Interrupt
NoInterrupt | 0 | No Interrupt
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9546a Class

Texas Instruments: PCA 9546 A
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPca9546a

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9546a
Public Class Pca9546a
public ref class Pca9546a
type Pca9546a =  class end

The Pca9546a type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9546a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | Channel2 | Channel 2
Public property | Channel3 | Channel 3
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
4-Channel I2C And SMBus Switch With Reset Function
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9546a Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9546a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9546a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9546a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9546a Class
telos.Ird.TexasInstruments Namespace


Pca9546a Properties

The Pca9546a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Channel0 | Channel 0
Public property | Channel1 | Channel 1
Public property | Channel2 | Channel 2
Public property | Channel3 | Channel 3
Top
See Also

Reference

Pca9546a Class
telos.Ird.TexasInstruments Namespace


Pca9546a.AutoFlush Property

IRD

Pca9546aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9546a Class
telos.Ird.TexasInstruments Namespace


Pca9546a.Channel0 Property

IRD

Pca9546aChannel0 Property

Channel 0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9546aTypeEnabledDisabled Channel0 { get; set; }
Public Property Channel0 As Pca9546aTypeEnabledDisabled
    Get
    Set
public:
property Pca9546aTypeEnabledDisabled Channel0 {
    Pca9546aTypeEnabledDisabled get ();
    void set (Pca9546aTypeEnabledDisabled value);
}
member Channel0 : Pca9546aTypeEnabledDisabled with get, set

Property Value

Type: Pca9546aTypeEnabledDisabled
See Also

Reference

Pca9546a Class
telos.Ird.TexasInstruments Namespace


Pca9546a.Channel1 Property

IRD

Pca9546aChannel1 Property

Channel 1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9546aTypeEnabledDisabled Channel1 { get; set; }
Public Property Channel1 As Pca9546aTypeEnabledDisabled
    Get
    Set
public:
property Pca9546aTypeEnabledDisabled Channel1 {
    Pca9546aTypeEnabledDisabled get ();
    void set (Pca9546aTypeEnabledDisabled value);
}
member Channel1 : Pca9546aTypeEnabledDisabled with get, set

Property Value

Type: Pca9546aTypeEnabledDisabled
See Also

Reference

Pca9546a Class
telos.Ird.TexasInstruments Namespace


Pca9546a.Channel2 Property

IRD

Pca9546aChannel2 Property

Channel 2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9546aTypeEnabledDisabled Channel2 { get; set; }
Public Property Channel2 As Pca9546aTypeEnabledDisabled
    Get
    Set
public:
property Pca9546aTypeEnabledDisabled Channel2 {
    Pca9546aTypeEnabledDisabled get ();
    void set (Pca9546aTypeEnabledDisabled value);
}
member Channel2 : Pca9546aTypeEnabledDisabled with get, set

Property Value

Type: Pca9546aTypeEnabledDisabled
See Also

Reference

Pca9546a Class
telos.Ird.TexasInstruments Namespace


Pca9546a.Channel3 Property

IRD

Pca9546aChannel3 Property

Channel 3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9546aTypeEnabledDisabled Channel3 { get; set; }
Public Property Channel3 As Pca9546aTypeEnabledDisabled
    Get
    Set
public:
property Pca9546aTypeEnabledDisabled Channel3 {
    Pca9546aTypeEnabledDisabled get ();
    void set (Pca9546aTypeEnabledDisabled value);
}
member Channel3 : Pca9546aTypeEnabledDisabled with get, set

Property Value

Type: Pca9546aTypeEnabledDisabled
See Also

Reference

Pca9546a Class
telos.Ird.TexasInstruments Namespace


Pca9546a Methods

The Pca9546a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9546a Class
telos.Ird.TexasInstruments Namespace


Pca9546a.Flush Method

IRD

Pca9546aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9546a Class
telos.Ird.TexasInstruments Namespace


Pca9546a.TypeEnabledDisabled Enumeration

IRD

Pca9546aTypeEnabledDisabled Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeEnabledDisabled
Public Enumeration TypeEnabledDisabled
public enum class TypeEnabledDisabled
type TypeEnabledDisabled
Members
Member name | Value | Description
Enabled | 1 | Enabled
Disabled | 0 | Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9554a Class

Texas Instruments: PCA 9554 A
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPca9554a

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9554a
Public Class Pca9554a
public ref class Pca9554a
type Pca9554a =  class end

The Pca9554a type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9554a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC03 | Configuration (C-03)
Public property | ConfigurationC04 | Configuration (C-04)
Public property | ConfigurationC05 | Configuration (C-05)
Public property | ConfigurationC06 | Configuration (C-06)
Public property | ConfigurationC07 | Configuration (C-07)
Public property | InputI00 | Input (I-00)
Public property | InputI01 | Input (I-01)
Public property | InputI02 | Input (I-02)
Public property | InputI03 | Input (I-03)
Public property | InputI04 | Input (I-04)
Public property | InputI05 | Input (I-05)
Public property | InputI06 | Input (I-06)
Public property | InputI07 | Input (I-07)
Public property | OutputO00 | Output (O-00)
Public property | OutputO01 | Output (O-01)
Public property | OutputO02 | Output (O-02)
Public property | OutputO03 | Output (O-03)
Public property | OutputO04 | Output (O-04)
Public property | OutputO05 | Output (O-05)
Public property | OutputO06 | Output (O-06)
Public property | OutputO07 | Output (O-07)
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Public property | PolarityInversionP04 | Polarity Inversion (P-04)
Public property | PolarityInversionP05 | Polarity Inversion (P-05)
Public property | PolarityInversionP06 | Polarity Inversion (P-06)
Public property | PolarityInversionP07 | Polarity Inversion (P-07)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Remote 8-Bit I2C And SMBus I/O Expander With Interrupt Output And Configuration Registers
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9554a Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9554a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9554a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a Properties

The Pca9554a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC03 | Configuration (C-03)
Public property | ConfigurationC04 | Configuration (C-04)
Public property | ConfigurationC05 | Configuration (C-05)
Public property | ConfigurationC06 | Configuration (C-06)
Public property | ConfigurationC07 | Configuration (C-07)
Public property | InputI00 | Input (I-00)
Public property | InputI01 | Input (I-01)
Public property | InputI02 | Input (I-02)
Public property | InputI03 | Input (I-03)
Public property | InputI04 | Input (I-04)
Public property | InputI05 | Input (I-05)
Public property | InputI06 | Input (I-06)
Public property | InputI07 | Input (I-07)
Public property | OutputO00 | Output (O-00)
Public property | OutputO01 | Output (O-01)
Public property | OutputO02 | Output (O-02)
Public property | OutputO03 | Output (O-03)
Public property | OutputO04 | Output (O-04)
Public property | OutputO05 | Output (O-05)
Public property | OutputO06 | Output (O-06)
Public property | OutputO07 | Output (O-07)
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Public property | PolarityInversionP04 | Polarity Inversion (P-04)
Public property | PolarityInversionP05 | Polarity Inversion (P-05)
Public property | PolarityInversionP06 | Polarity Inversion (P-06)
Public property | PolarityInversionP07 | Polarity Inversion (P-07)
Top
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.AutoFlush Property

IRD

Pca9554aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.ConfigurationC00 Property

IRD

Pca9554aConfigurationC00 Property

Configuration (C-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeConfiguration ConfigurationC00 { get; set; }
Public Property ConfigurationC00 As Pca9554aTypeConfiguration
    Get
    Set
public:
property Pca9554aTypeConfiguration ConfigurationC00 {
    Pca9554aTypeConfiguration get ();
    void set (Pca9554aTypeConfiguration value);
}
member ConfigurationC00 : Pca9554aTypeConfiguration with get, set

Property Value

Type: Pca9554aTypeConfiguration
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.ConfigurationC01 Property

IRD

Pca9554aConfigurationC01 Property

Configuration (C-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeConfiguration ConfigurationC01 { get; set; }
Public Property ConfigurationC01 As Pca9554aTypeConfiguration
    Get
    Set
public:
property Pca9554aTypeConfiguration ConfigurationC01 {
    Pca9554aTypeConfiguration get ();
    void set (Pca9554aTypeConfiguration value);
}
member ConfigurationC01 : Pca9554aTypeConfiguration with get, set

Property Value

Type: Pca9554aTypeConfiguration
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.ConfigurationC02 Property

IRD

Pca9554aConfigurationC02 Property

Configuration (C-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeConfiguration ConfigurationC02 { get; set; }
Public Property ConfigurationC02 As Pca9554aTypeConfiguration
    Get
    Set
public:
property Pca9554aTypeConfiguration ConfigurationC02 {
    Pca9554aTypeConfiguration get ();
    void set (Pca9554aTypeConfiguration value);
}
member ConfigurationC02 : Pca9554aTypeConfiguration with get, set

Property Value

Type: Pca9554aTypeConfiguration
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.ConfigurationC03 Property

IRD

Pca9554aConfigurationC03 Property

Configuration (C-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeConfiguration ConfigurationC03 { get; set; }
Public Property ConfigurationC03 As Pca9554aTypeConfiguration
    Get
    Set
public:
property Pca9554aTypeConfiguration ConfigurationC03 {
    Pca9554aTypeConfiguration get ();
    void set (Pca9554aTypeConfiguration value);
}
member ConfigurationC03 : Pca9554aTypeConfiguration with get, set

Property Value

Type: Pca9554aTypeConfiguration
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.ConfigurationC04 Property

IRD

Pca9554aConfigurationC04 Property

Configuration (C-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeConfiguration ConfigurationC04 { get; set; }
Public Property ConfigurationC04 As Pca9554aTypeConfiguration
    Get
    Set
public:
property Pca9554aTypeConfiguration ConfigurationC04 {
    Pca9554aTypeConfiguration get ();
    void set (Pca9554aTypeConfiguration value);
}
member ConfigurationC04 : Pca9554aTypeConfiguration with get, set

Property Value

Type: Pca9554aTypeConfiguration
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.ConfigurationC05 Property

IRD

Pca9554aConfigurationC05 Property

Configuration (C-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeConfiguration ConfigurationC05 { get; set; }
Public Property ConfigurationC05 As Pca9554aTypeConfiguration
    Get
    Set
public:
property Pca9554aTypeConfiguration ConfigurationC05 {
    Pca9554aTypeConfiguration get ();
    void set (Pca9554aTypeConfiguration value);
}
member ConfigurationC05 : Pca9554aTypeConfiguration with get, set

Property Value

Type: Pca9554aTypeConfiguration
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.ConfigurationC06 Property

IRD

Pca9554aConfigurationC06 Property

Configuration (C-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeConfiguration ConfigurationC06 { get; set; }
Public Property ConfigurationC06 As Pca9554aTypeConfiguration
    Get
    Set
public:
property Pca9554aTypeConfiguration ConfigurationC06 {
    Pca9554aTypeConfiguration get ();
    void set (Pca9554aTypeConfiguration value);
}
member ConfigurationC06 : Pca9554aTypeConfiguration with get, set

Property Value

Type: Pca9554aTypeConfiguration
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.ConfigurationC07 Property

IRD

Pca9554aConfigurationC07 Property

Configuration (C-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeConfiguration ConfigurationC07 { get; set; }
Public Property ConfigurationC07 As Pca9554aTypeConfiguration
    Get
    Set
public:
property Pca9554aTypeConfiguration ConfigurationC07 {
    Pca9554aTypeConfiguration get ();
    void set (Pca9554aTypeConfiguration value);
}
member ConfigurationC07 : Pca9554aTypeConfiguration with get, set

Property Value

Type: Pca9554aTypeConfiguration
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.InputI00 Property

IRD

Pca9554aInputI00 Property

Input (I-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeLevel InputI00 { get; }
Public ReadOnly Property InputI00 As Pca9554aTypeLevel
    Get
public:
property Pca9554aTypeLevel InputI00 {
    Pca9554aTypeLevel get ();
}
member InputI00 : Pca9554aTypeLevel with get

Property Value

Type: Pca9554aTypeLevel
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.InputI01 Property

IRD

Pca9554aInputI01 Property

Input (I-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeLevel InputI01 { get; }
Public ReadOnly Property InputI01 As Pca9554aTypeLevel
    Get
public:
property Pca9554aTypeLevel InputI01 {
    Pca9554aTypeLevel get ();
}
member InputI01 : Pca9554aTypeLevel with get

Property Value

Type: Pca9554aTypeLevel
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.InputI02 Property

IRD

Pca9554aInputI02 Property

Input (I-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeLevel InputI02 { get; }
Public ReadOnly Property InputI02 As Pca9554aTypeLevel
    Get
public:
property Pca9554aTypeLevel InputI02 {
    Pca9554aTypeLevel get ();
}
member InputI02 : Pca9554aTypeLevel with get

Property Value

Type: Pca9554aTypeLevel
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.InputI03 Property

IRD

Pca9554aInputI03 Property

Input (I-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeLevel InputI03 { get; }
Public ReadOnly Property InputI03 As Pca9554aTypeLevel
    Get
public:
property Pca9554aTypeLevel InputI03 {
    Pca9554aTypeLevel get ();
}
member InputI03 : Pca9554aTypeLevel with get

Property Value

Type: Pca9554aTypeLevel
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.InputI04 Property

IRD

Pca9554aInputI04 Property

Input (I-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeLevel InputI04 { get; }
Public ReadOnly Property InputI04 As Pca9554aTypeLevel
    Get
public:
property Pca9554aTypeLevel InputI04 {
    Pca9554aTypeLevel get ();
}
member InputI04 : Pca9554aTypeLevel with get

Property Value

Type: Pca9554aTypeLevel
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.InputI05 Property

IRD

Pca9554aInputI05 Property

Input (I-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeLevel InputI05 { get; }
Public ReadOnly Property InputI05 As Pca9554aTypeLevel
    Get
public:
property Pca9554aTypeLevel InputI05 {
    Pca9554aTypeLevel get ();
}
member InputI05 : Pca9554aTypeLevel with get

Property Value

Type: Pca9554aTypeLevel
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.InputI06 Property

IRD

Pca9554aInputI06 Property

Input (I-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeLevel InputI06 { get; }
Public ReadOnly Property InputI06 As Pca9554aTypeLevel
    Get
public:
property Pca9554aTypeLevel InputI06 {
    Pca9554aTypeLevel get ();
}
member InputI06 : Pca9554aTypeLevel with get

Property Value

Type: Pca9554aTypeLevel
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.InputI07 Property

IRD

Pca9554aInputI07 Property

Input (I-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeLevel InputI07 { get; }
Public ReadOnly Property InputI07 As Pca9554aTypeLevel
    Get
public:
property Pca9554aTypeLevel InputI07 {
    Pca9554aTypeLevel get ();
}
member InputI07 : Pca9554aTypeLevel with get

Property Value

Type: Pca9554aTypeLevel
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.OutputO00 Property

IRD

Pca9554aOutputO00 Property

Output (O-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeLevel OutputO00 { get; set; }
Public Property OutputO00 As Pca9554aTypeLevel
    Get
    Set
public:
property Pca9554aTypeLevel OutputO00 {
    Pca9554aTypeLevel get ();
    void set (Pca9554aTypeLevel value);
}
member OutputO00 : Pca9554aTypeLevel with get, set

Property Value

Type: Pca9554aTypeLevel
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.OutputO01 Property

IRD

Pca9554aOutputO01 Property

Output (O-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeLevel OutputO01 { get; set; }
Public Property OutputO01 As Pca9554aTypeLevel
    Get
    Set
public:
property Pca9554aTypeLevel OutputO01 {
    Pca9554aTypeLevel get ();
    void set (Pca9554aTypeLevel value);
}
member OutputO01 : Pca9554aTypeLevel with get, set

Property Value

Type: Pca9554aTypeLevel
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.OutputO02 Property

IRD

Pca9554aOutputO02 Property

Output (O-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeLevel OutputO02 { get; set; }
Public Property OutputO02 As Pca9554aTypeLevel
    Get
    Set
public:
property Pca9554aTypeLevel OutputO02 {
    Pca9554aTypeLevel get ();
    void set (Pca9554aTypeLevel value);
}
member OutputO02 : Pca9554aTypeLevel with get, set

Property Value

Type: Pca9554aTypeLevel
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.OutputO03 Property

IRD

Pca9554aOutputO03 Property

Output (O-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeLevel OutputO03 { get; set; }
Public Property OutputO03 As Pca9554aTypeLevel
    Get
    Set
public:
property Pca9554aTypeLevel OutputO03 {
    Pca9554aTypeLevel get ();
    void set (Pca9554aTypeLevel value);
}
member OutputO03 : Pca9554aTypeLevel with get, set

Property Value

Type: Pca9554aTypeLevel
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.OutputO04 Property

IRD

Pca9554aOutputO04 Property

Output (O-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeLevel OutputO04 { get; set; }
Public Property OutputO04 As Pca9554aTypeLevel
    Get
    Set
public:
property Pca9554aTypeLevel OutputO04 {
    Pca9554aTypeLevel get ();
    void set (Pca9554aTypeLevel value);
}
member OutputO04 : Pca9554aTypeLevel with get, set

Property Value

Type: Pca9554aTypeLevel
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.OutputO05 Property

IRD

Pca9554aOutputO05 Property

Output (O-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeLevel OutputO05 { get; set; }
Public Property OutputO05 As Pca9554aTypeLevel
    Get
    Set
public:
property Pca9554aTypeLevel OutputO05 {
    Pca9554aTypeLevel get ();
    void set (Pca9554aTypeLevel value);
}
member OutputO05 : Pca9554aTypeLevel with get, set

Property Value

Type: Pca9554aTypeLevel
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.OutputO06 Property

IRD

Pca9554aOutputO06 Property

Output (O-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeLevel OutputO06 { get; set; }
Public Property OutputO06 As Pca9554aTypeLevel
    Get
    Set
public:
property Pca9554aTypeLevel OutputO06 {
    Pca9554aTypeLevel get ();
    void set (Pca9554aTypeLevel value);
}
member OutputO06 : Pca9554aTypeLevel with get, set

Property Value

Type: Pca9554aTypeLevel
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.OutputO07 Property

IRD

Pca9554aOutputO07 Property

Output (O-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypeLevel OutputO07 { get; set; }
Public Property OutputO07 As Pca9554aTypeLevel
    Get
    Set
public:
property Pca9554aTypeLevel OutputO07 {
    Pca9554aTypeLevel get ();
    void set (Pca9554aTypeLevel value);
}
member OutputO07 : Pca9554aTypeLevel with get, set

Property Value

Type: Pca9554aTypeLevel
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.PolarityInversionP00 Property

IRD

Pca9554aPolarityInversionP00 Property

Polarity Inversion (P-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypePolarity PolarityInversionP00 { get; set; }
Public Property PolarityInversionP00 As Pca9554aTypePolarity
    Get
    Set
public:
property Pca9554aTypePolarity PolarityInversionP00 {
    Pca9554aTypePolarity get ();
    void set (Pca9554aTypePolarity value);
}
member PolarityInversionP00 : Pca9554aTypePolarity with get, set

Property Value

Type: Pca9554aTypePolarity
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.PolarityInversionP01 Property

IRD

Pca9554aPolarityInversionP01 Property

Polarity Inversion (P-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypePolarity PolarityInversionP01 { get; set; }
Public Property PolarityInversionP01 As Pca9554aTypePolarity
    Get
    Set
public:
property Pca9554aTypePolarity PolarityInversionP01 {
    Pca9554aTypePolarity get ();
    void set (Pca9554aTypePolarity value);
}
member PolarityInversionP01 : Pca9554aTypePolarity with get, set

Property Value

Type: Pca9554aTypePolarity
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.PolarityInversionP02 Property

IRD

Pca9554aPolarityInversionP02 Property

Polarity Inversion (P-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypePolarity PolarityInversionP02 { get; set; }
Public Property PolarityInversionP02 As Pca9554aTypePolarity
    Get
    Set
public:
property Pca9554aTypePolarity PolarityInversionP02 {
    Pca9554aTypePolarity get ();
    void set (Pca9554aTypePolarity value);
}
member PolarityInversionP02 : Pca9554aTypePolarity with get, set

Property Value

Type: Pca9554aTypePolarity
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.PolarityInversionP03 Property

IRD

Pca9554aPolarityInversionP03 Property

Polarity Inversion (P-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypePolarity PolarityInversionP03 { get; set; }
Public Property PolarityInversionP03 As Pca9554aTypePolarity
    Get
    Set
public:
property Pca9554aTypePolarity PolarityInversionP03 {
    Pca9554aTypePolarity get ();
    void set (Pca9554aTypePolarity value);
}
member PolarityInversionP03 : Pca9554aTypePolarity with get, set

Property Value

Type: Pca9554aTypePolarity
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.PolarityInversionP04 Property

IRD

Pca9554aPolarityInversionP04 Property

Polarity Inversion (P-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypePolarity PolarityInversionP04 { get; set; }
Public Property PolarityInversionP04 As Pca9554aTypePolarity
    Get
    Set
public:
property Pca9554aTypePolarity PolarityInversionP04 {
    Pca9554aTypePolarity get ();
    void set (Pca9554aTypePolarity value);
}
member PolarityInversionP04 : Pca9554aTypePolarity with get, set

Property Value

Type: Pca9554aTypePolarity
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.PolarityInversionP05 Property

IRD

Pca9554aPolarityInversionP05 Property

Polarity Inversion (P-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypePolarity PolarityInversionP05 { get; set; }
Public Property PolarityInversionP05 As Pca9554aTypePolarity
    Get
    Set
public:
property Pca9554aTypePolarity PolarityInversionP05 {
    Pca9554aTypePolarity get ();
    void set (Pca9554aTypePolarity value);
}
member PolarityInversionP05 : Pca9554aTypePolarity with get, set

Property Value

Type: Pca9554aTypePolarity
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.PolarityInversionP06 Property

IRD

Pca9554aPolarityInversionP06 Property

Polarity Inversion (P-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypePolarity PolarityInversionP06 { get; set; }
Public Property PolarityInversionP06 As Pca9554aTypePolarity
    Get
    Set
public:
property Pca9554aTypePolarity PolarityInversionP06 {
    Pca9554aTypePolarity get ();
    void set (Pca9554aTypePolarity value);
}
member PolarityInversionP06 : Pca9554aTypePolarity with get, set

Property Value

Type: Pca9554aTypePolarity
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.PolarityInversionP07 Property

IRD

Pca9554aPolarityInversionP07 Property

Polarity Inversion (P-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9554aTypePolarity PolarityInversionP07 { get; set; }
Public Property PolarityInversionP07 As Pca9554aTypePolarity
    Get
    Set
public:
property Pca9554aTypePolarity PolarityInversionP07 {
    Pca9554aTypePolarity get ();
    void set (Pca9554aTypePolarity value);
}
member PolarityInversionP07 : Pca9554aTypePolarity with get, set

Property Value

Type: Pca9554aTypePolarity
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a Methods

The Pca9554a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.Flush Method

IRD

Pca9554aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9554a Class
telos.Ird.TexasInstruments Namespace


Pca9554a.TypeConfiguration Enumeration

IRD

Pca9554aTypeConfiguration Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Input | 1 | Input
Output | 0 | Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9554a.TypeLevel Enumeration

IRD

Pca9554aTypeLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLevel
Public Enumeration TypeLevel
public enum class TypeLevel
type TypeLevel
Members
Member name | Value | Description
High | 1 | High
Low | 0 | Low
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9554a.TypePolarity Enumeration

IRD

Pca9554aTypePolarity Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarity
Public Enumeration TypePolarity
public enum class TypePolarity
type TypePolarity
Members
Member name | Value | Description
Inverted | 1 | Inverted
Normal | 0 | Normal
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9555 Class

Texas Instruments: PCA 9555
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPca9555

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9555
Public Class Pca9555
public ref class Pca9555
type Pca9555 =  class end

The Pca9555 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9555 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC03 | Configuration (C-03)
Public property | ConfigurationC04 | Configuration (C-04)
Public property | ConfigurationC05 | Configuration (C-05)
Public property | ConfigurationC06 | Configuration (C-06)
Public property | ConfigurationC07 | Configuration (C-07)
Public property | ConfigurationC10 | Configuration (C-10)
Public property | ConfigurationC11 | Configuration (C-11)
Public property | ConfigurationC12 | Configuration (C-12)
Public property | ConfigurationC13 | Configuration (C-13)
Public property | ConfigurationC14 | Configuration (C-14)
Public property | ConfigurationC15 | Configuration (C-15)
Public property | ConfigurationC16 | Configuration (C-16)
Public property | ConfigurationC17 | Configuration (C-17)
Public property | InputI00 | Input (I-00)
Public property | InputI01 | Input (I-01)
Public property | InputI02 | Input (I-02)
Public property | InputI03 | Input (I-03)
Public property | InputI04 | Input (I-04)
Public property | InputI05 | Input (I-05)
Public property | InputI06 | Input (I-06)
Public property | InputI07 | Input (I-07)
Public property | InputI10 | Input (I-10)
Public property | InputI11 | Input (I-11)
Public property | InputI12 | Input (I-12)
Public property | InputI13 | Input (I-13)
Public property | InputI14 | Input (I-14)
Public property | InputI15 | Input (I-15)
Public property | InputI16 | Input (I-16)
Public property | InputI17 | Input (I-17)
Public property | OutputO00 | Output (O-00)
Public property | OutputO01 | Output (O-01)
Public property | OutputO02 | Output (O-02)
Public property | OutputO03 | Output (O-03)
Public property | OutputO04 | Output (O-04)
Public property | OutputO05 | Output (O-05)
Public property | OutputO06 | Output (O-06)
Public property | OutputO07 | Output (O-07)
Public property | OutputO10 | Output (O-10)
Public property | OutputO11 | Output (O-11)
Public property | OutputO12 | Output (O-12)
Public property | OutputO13 | Output (O-13)
Public property | OutputO14 | Output (O-14)
Public property | OutputO15 | Output (O-15)
Public property | OutputO16 | Output (O-16)
Public property | OutputO17 | Output (O-17)
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Public property | PolarityInversionP04 | Polarity Inversion (P-04)
Public property | PolarityInversionP05 | Polarity Inversion (P-05)
Public property | PolarityInversionP06 | Polarity Inversion (P-06)
Public property | PolarityInversionP07 | Polarity Inversion (P-07)
Public property | PolarityInversionP10 | Polarity Inversion (P-10)
Public property | PolarityInversionP11 | Polarity Inversion (P-11)
Public property | PolarityInversionP12 | Polarity Inversion (P-12)
Public property | PolarityInversionP13 | Polarity Inversion (P-13)
Public property | PolarityInversionP14 | Polarity Inversion (P-14)
Public property | PolarityInversionP15 | Polarity Inversion (P-15)
Public property | PolarityInversionP16 | Polarity Inversion (P-16)
Public property | PolarityInversionP17 | Polarity Inversion (P-17)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Remote 16-Bit I2C And SMBus I/O Expander With Interrupt Output And Configuration Registers
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9555 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9555(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9555

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555 Properties

The Pca9555 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC03 | Configuration (C-03)
Public property | ConfigurationC04 | Configuration (C-04)
Public property | ConfigurationC05 | Configuration (C-05)
Public property | ConfigurationC06 | Configuration (C-06)
Public property | ConfigurationC07 | Configuration (C-07)
Public property | ConfigurationC10 | Configuration (C-10)
Public property | ConfigurationC11 | Configuration (C-11)
Public property | ConfigurationC12 | Configuration (C-12)
Public property | ConfigurationC13 | Configuration (C-13)
Public property | ConfigurationC14 | Configuration (C-14)
Public property | ConfigurationC15 | Configuration (C-15)
Public property | ConfigurationC16 | Configuration (C-16)
Public property | ConfigurationC17 | Configuration (C-17)
Public property | InputI00 | Input (I-00)
Public property | InputI01 | Input (I-01)
Public property | InputI02 | Input (I-02)
Public property | InputI03 | Input (I-03)
Public property | InputI04 | Input (I-04)
Public property | InputI05 | Input (I-05)
Public property | InputI06 | Input (I-06)
Public property | InputI07 | Input (I-07)
Public property | InputI10 | Input (I-10)
Public property | InputI11 | Input (I-11)
Public property | InputI12 | Input (I-12)
Public property | InputI13 | Input (I-13)
Public property | InputI14 | Input (I-14)
Public property | InputI15 | Input (I-15)
Public property | InputI16 | Input (I-16)
Public property | InputI17 | Input (I-17)
Public property | OutputO00 | Output (O-00)
Public property | OutputO01 | Output (O-01)
Public property | OutputO02 | Output (O-02)
Public property | OutputO03 | Output (O-03)
Public property | OutputO04 | Output (O-04)
Public property | OutputO05 | Output (O-05)
Public property | OutputO06 | Output (O-06)
Public property | OutputO07 | Output (O-07)
Public property | OutputO10 | Output (O-10)
Public property | OutputO11 | Output (O-11)
Public property | OutputO12 | Output (O-12)
Public property | OutputO13 | Output (O-13)
Public property | OutputO14 | Output (O-14)
Public property | OutputO15 | Output (O-15)
Public property | OutputO16 | Output (O-16)
Public property | OutputO17 | Output (O-17)
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Public property | PolarityInversionP04 | Polarity Inversion (P-04)
Public property | PolarityInversionP05 | Polarity Inversion (P-05)
Public property | PolarityInversionP06 | Polarity Inversion (P-06)
Public property | PolarityInversionP07 | Polarity Inversion (P-07)
Public property | PolarityInversionP10 | Polarity Inversion (P-10)
Public property | PolarityInversionP11 | Polarity Inversion (P-11)
Public property | PolarityInversionP12 | Polarity Inversion (P-12)
Public property | PolarityInversionP13 | Polarity Inversion (P-13)
Public property | PolarityInversionP14 | Polarity Inversion (P-14)
Public property | PolarityInversionP15 | Polarity Inversion (P-15)
Public property | PolarityInversionP16 | Polarity Inversion (P-16)
Public property | PolarityInversionP17 | Polarity Inversion (P-17)
Top
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.AutoFlush Property

IRD

Pca9555AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.ConfigurationC00 Property

IRD

Pca9555ConfigurationC00 Property

Configuration (C-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeConfiguration ConfigurationC00 { get; set; }
Public Property ConfigurationC00 As Pca9555TypeConfiguration
    Get
    Set
public:
property Pca9555TypeConfiguration ConfigurationC00 {
    Pca9555TypeConfiguration get ();
    void set (Pca9555TypeConfiguration value);
}
member ConfigurationC00 : Pca9555TypeConfiguration with get, set

Property Value

Type: Pca9555TypeConfiguration
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.ConfigurationC01 Property

IRD

Pca9555ConfigurationC01 Property

Configuration (C-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeConfiguration ConfigurationC01 { get; set; }
Public Property ConfigurationC01 As Pca9555TypeConfiguration
    Get
    Set
public:
property Pca9555TypeConfiguration ConfigurationC01 {
    Pca9555TypeConfiguration get ();
    void set (Pca9555TypeConfiguration value);
}
member ConfigurationC01 : Pca9555TypeConfiguration with get, set

Property Value

Type: Pca9555TypeConfiguration
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.ConfigurationC02 Property

IRD

Pca9555ConfigurationC02 Property

Configuration (C-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeConfiguration ConfigurationC02 { get; set; }
Public Property ConfigurationC02 As Pca9555TypeConfiguration
    Get
    Set
public:
property Pca9555TypeConfiguration ConfigurationC02 {
    Pca9555TypeConfiguration get ();
    void set (Pca9555TypeConfiguration value);
}
member ConfigurationC02 : Pca9555TypeConfiguration with get, set

Property Value

Type: Pca9555TypeConfiguration
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.ConfigurationC03 Property

IRD

Pca9555ConfigurationC03 Property

Configuration (C-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeConfiguration ConfigurationC03 { get; set; }
Public Property ConfigurationC03 As Pca9555TypeConfiguration
    Get
    Set
public:
property Pca9555TypeConfiguration ConfigurationC03 {
    Pca9555TypeConfiguration get ();
    void set (Pca9555TypeConfiguration value);
}
member ConfigurationC03 : Pca9555TypeConfiguration with get, set

Property Value

Type: Pca9555TypeConfiguration
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.ConfigurationC04 Property

IRD

Pca9555ConfigurationC04 Property

Configuration (C-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeConfiguration ConfigurationC04 { get; set; }
Public Property ConfigurationC04 As Pca9555TypeConfiguration
    Get
    Set
public:
property Pca9555TypeConfiguration ConfigurationC04 {
    Pca9555TypeConfiguration get ();
    void set (Pca9555TypeConfiguration value);
}
member ConfigurationC04 : Pca9555TypeConfiguration with get, set

Property Value

Type: Pca9555TypeConfiguration
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.ConfigurationC05 Property

IRD

Pca9555ConfigurationC05 Property

Configuration (C-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeConfiguration ConfigurationC05 { get; set; }
Public Property ConfigurationC05 As Pca9555TypeConfiguration
    Get
    Set
public:
property Pca9555TypeConfiguration ConfigurationC05 {
    Pca9555TypeConfiguration get ();
    void set (Pca9555TypeConfiguration value);
}
member ConfigurationC05 : Pca9555TypeConfiguration with get, set

Property Value

Type: Pca9555TypeConfiguration
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.ConfigurationC06 Property

IRD

Pca9555ConfigurationC06 Property

Configuration (C-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeConfiguration ConfigurationC06 { get; set; }
Public Property ConfigurationC06 As Pca9555TypeConfiguration
    Get
    Set
public:
property Pca9555TypeConfiguration ConfigurationC06 {
    Pca9555TypeConfiguration get ();
    void set (Pca9555TypeConfiguration value);
}
member ConfigurationC06 : Pca9555TypeConfiguration with get, set

Property Value

Type: Pca9555TypeConfiguration
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.ConfigurationC07 Property

IRD

Pca9555ConfigurationC07 Property

Configuration (C-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeConfiguration ConfigurationC07 { get; set; }
Public Property ConfigurationC07 As Pca9555TypeConfiguration
    Get
    Set
public:
property Pca9555TypeConfiguration ConfigurationC07 {
    Pca9555TypeConfiguration get ();
    void set (Pca9555TypeConfiguration value);
}
member ConfigurationC07 : Pca9555TypeConfiguration with get, set

Property Value

Type: Pca9555TypeConfiguration
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.ConfigurationC10 Property

IRD

Pca9555ConfigurationC10 Property

Configuration (C-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeConfiguration ConfigurationC10 { get; set; }
Public Property ConfigurationC10 As Pca9555TypeConfiguration
    Get
    Set
public:
property Pca9555TypeConfiguration ConfigurationC10 {
    Pca9555TypeConfiguration get ();
    void set (Pca9555TypeConfiguration value);
}
member ConfigurationC10 : Pca9555TypeConfiguration with get, set

Property Value

Type: Pca9555TypeConfiguration
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.ConfigurationC11 Property

IRD

Pca9555ConfigurationC11 Property

Configuration (C-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeConfiguration ConfigurationC11 { get; set; }
Public Property ConfigurationC11 As Pca9555TypeConfiguration
    Get
    Set
public:
property Pca9555TypeConfiguration ConfigurationC11 {
    Pca9555TypeConfiguration get ();
    void set (Pca9555TypeConfiguration value);
}
member ConfigurationC11 : Pca9555TypeConfiguration with get, set

Property Value

Type: Pca9555TypeConfiguration
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.ConfigurationC12 Property

IRD

Pca9555ConfigurationC12 Property

Configuration (C-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeConfiguration ConfigurationC12 { get; set; }
Public Property ConfigurationC12 As Pca9555TypeConfiguration
    Get
    Set
public:
property Pca9555TypeConfiguration ConfigurationC12 {
    Pca9555TypeConfiguration get ();
    void set (Pca9555TypeConfiguration value);
}
member ConfigurationC12 : Pca9555TypeConfiguration with get, set

Property Value

Type: Pca9555TypeConfiguration
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.ConfigurationC13 Property

IRD

Pca9555ConfigurationC13 Property

Configuration (C-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeConfiguration ConfigurationC13 { get; set; }
Public Property ConfigurationC13 As Pca9555TypeConfiguration
    Get
    Set
public:
property Pca9555TypeConfiguration ConfigurationC13 {
    Pca9555TypeConfiguration get ();
    void set (Pca9555TypeConfiguration value);
}
member ConfigurationC13 : Pca9555TypeConfiguration with get, set

Property Value

Type: Pca9555TypeConfiguration
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.ConfigurationC14 Property

IRD

Pca9555ConfigurationC14 Property

Configuration (C-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeConfiguration ConfigurationC14 { get; set; }
Public Property ConfigurationC14 As Pca9555TypeConfiguration
    Get
    Set
public:
property Pca9555TypeConfiguration ConfigurationC14 {
    Pca9555TypeConfiguration get ();
    void set (Pca9555TypeConfiguration value);
}
member ConfigurationC14 : Pca9555TypeConfiguration with get, set

Property Value

Type: Pca9555TypeConfiguration
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.ConfigurationC15 Property

IRD

Pca9555ConfigurationC15 Property

Configuration (C-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeConfiguration ConfigurationC15 { get; set; }
Public Property ConfigurationC15 As Pca9555TypeConfiguration
    Get
    Set
public:
property Pca9555TypeConfiguration ConfigurationC15 {
    Pca9555TypeConfiguration get ();
    void set (Pca9555TypeConfiguration value);
}
member ConfigurationC15 : Pca9555TypeConfiguration with get, set

Property Value

Type: Pca9555TypeConfiguration
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.ConfigurationC16 Property

IRD

Pca9555ConfigurationC16 Property

Configuration (C-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeConfiguration ConfigurationC16 { get; set; }
Public Property ConfigurationC16 As Pca9555TypeConfiguration
    Get
    Set
public:
property Pca9555TypeConfiguration ConfigurationC16 {
    Pca9555TypeConfiguration get ();
    void set (Pca9555TypeConfiguration value);
}
member ConfigurationC16 : Pca9555TypeConfiguration with get, set

Property Value

Type: Pca9555TypeConfiguration
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.ConfigurationC17 Property

IRD

Pca9555ConfigurationC17 Property

Configuration (C-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeConfiguration ConfigurationC17 { get; set; }
Public Property ConfigurationC17 As Pca9555TypeConfiguration
    Get
    Set
public:
property Pca9555TypeConfiguration ConfigurationC17 {
    Pca9555TypeConfiguration get ();
    void set (Pca9555TypeConfiguration value);
}
member ConfigurationC17 : Pca9555TypeConfiguration with get, set

Property Value

Type: Pca9555TypeConfiguration
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.InputI00 Property

IRD

Pca9555InputI00 Property

Input (I-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel InputI00 { get; }
Public ReadOnly Property InputI00 As Pca9555TypeLevel
    Get
public:
property Pca9555TypeLevel InputI00 {
    Pca9555TypeLevel get ();
}
member InputI00 : Pca9555TypeLevel with get

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.InputI01 Property

IRD

Pca9555InputI01 Property

Input (I-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel InputI01 { get; }
Public ReadOnly Property InputI01 As Pca9555TypeLevel
    Get
public:
property Pca9555TypeLevel InputI01 {
    Pca9555TypeLevel get ();
}
member InputI01 : Pca9555TypeLevel with get

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.InputI02 Property

IRD

Pca9555InputI02 Property

Input (I-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel InputI02 { get; }
Public ReadOnly Property InputI02 As Pca9555TypeLevel
    Get
public:
property Pca9555TypeLevel InputI02 {
    Pca9555TypeLevel get ();
}
member InputI02 : Pca9555TypeLevel with get

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.InputI03 Property

IRD

Pca9555InputI03 Property

Input (I-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel InputI03 { get; }
Public ReadOnly Property InputI03 As Pca9555TypeLevel
    Get
public:
property Pca9555TypeLevel InputI03 {
    Pca9555TypeLevel get ();
}
member InputI03 : Pca9555TypeLevel with get

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.InputI04 Property

IRD

Pca9555InputI04 Property

Input (I-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel InputI04 { get; }
Public ReadOnly Property InputI04 As Pca9555TypeLevel
    Get
public:
property Pca9555TypeLevel InputI04 {
    Pca9555TypeLevel get ();
}
member InputI04 : Pca9555TypeLevel with get

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.InputI05 Property

IRD

Pca9555InputI05 Property

Input (I-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel InputI05 { get; }
Public ReadOnly Property InputI05 As Pca9555TypeLevel
    Get
public:
property Pca9555TypeLevel InputI05 {
    Pca9555TypeLevel get ();
}
member InputI05 : Pca9555TypeLevel with get

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.InputI06 Property

IRD

Pca9555InputI06 Property

Input (I-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel InputI06 { get; }
Public ReadOnly Property InputI06 As Pca9555TypeLevel
    Get
public:
property Pca9555TypeLevel InputI06 {
    Pca9555TypeLevel get ();
}
member InputI06 : Pca9555TypeLevel with get

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.InputI07 Property

IRD

Pca9555InputI07 Property

Input (I-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel InputI07 { get; }
Public ReadOnly Property InputI07 As Pca9555TypeLevel
    Get
public:
property Pca9555TypeLevel InputI07 {
    Pca9555TypeLevel get ();
}
member InputI07 : Pca9555TypeLevel with get

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.InputI10 Property

IRD

Pca9555InputI10 Property

Input (I-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel InputI10 { get; }
Public ReadOnly Property InputI10 As Pca9555TypeLevel
    Get
public:
property Pca9555TypeLevel InputI10 {
    Pca9555TypeLevel get ();
}
member InputI10 : Pca9555TypeLevel with get

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.InputI11 Property

IRD

Pca9555InputI11 Property

Input (I-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel InputI11 { get; }
Public ReadOnly Property InputI11 As Pca9555TypeLevel
    Get
public:
property Pca9555TypeLevel InputI11 {
    Pca9555TypeLevel get ();
}
member InputI11 : Pca9555TypeLevel with get

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.InputI12 Property

IRD

Pca9555InputI12 Property

Input (I-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel InputI12 { get; }
Public ReadOnly Property InputI12 As Pca9555TypeLevel
    Get
public:
property Pca9555TypeLevel InputI12 {
    Pca9555TypeLevel get ();
}
member InputI12 : Pca9555TypeLevel with get

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.InputI13 Property

IRD

Pca9555InputI13 Property

Input (I-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel InputI13 { get; }
Public ReadOnly Property InputI13 As Pca9555TypeLevel
    Get
public:
property Pca9555TypeLevel InputI13 {
    Pca9555TypeLevel get ();
}
member InputI13 : Pca9555TypeLevel with get

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.InputI14 Property

IRD

Pca9555InputI14 Property

Input (I-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel InputI14 { get; }
Public ReadOnly Property InputI14 As Pca9555TypeLevel
    Get
public:
property Pca9555TypeLevel InputI14 {
    Pca9555TypeLevel get ();
}
member InputI14 : Pca9555TypeLevel with get

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.InputI15 Property

IRD

Pca9555InputI15 Property

Input (I-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel InputI15 { get; }
Public ReadOnly Property InputI15 As Pca9555TypeLevel
    Get
public:
property Pca9555TypeLevel InputI15 {
    Pca9555TypeLevel get ();
}
member InputI15 : Pca9555TypeLevel with get

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.InputI16 Property

IRD

Pca9555InputI16 Property

Input (I-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel InputI16 { get; }
Public ReadOnly Property InputI16 As Pca9555TypeLevel
    Get
public:
property Pca9555TypeLevel InputI16 {
    Pca9555TypeLevel get ();
}
member InputI16 : Pca9555TypeLevel with get

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.InputI17 Property

IRD

Pca9555InputI17 Property

Input (I-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel InputI17 { get; }
Public ReadOnly Property InputI17 As Pca9555TypeLevel
    Get
public:
property Pca9555TypeLevel InputI17 {
    Pca9555TypeLevel get ();
}
member InputI17 : Pca9555TypeLevel with get

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.OutputO00 Property

IRD

Pca9555OutputO00 Property

Output (O-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel OutputO00 { get; set; }
Public Property OutputO00 As Pca9555TypeLevel
    Get
    Set
public:
property Pca9555TypeLevel OutputO00 {
    Pca9555TypeLevel get ();
    void set (Pca9555TypeLevel value);
}
member OutputO00 : Pca9555TypeLevel with get, set

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.OutputO01 Property

IRD

Pca9555OutputO01 Property

Output (O-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel OutputO01 { get; set; }
Public Property OutputO01 As Pca9555TypeLevel
    Get
    Set
public:
property Pca9555TypeLevel OutputO01 {
    Pca9555TypeLevel get ();
    void set (Pca9555TypeLevel value);
}
member OutputO01 : Pca9555TypeLevel with get, set

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.OutputO02 Property

IRD

Pca9555OutputO02 Property

Output (O-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel OutputO02 { get; set; }
Public Property OutputO02 As Pca9555TypeLevel
    Get
    Set
public:
property Pca9555TypeLevel OutputO02 {
    Pca9555TypeLevel get ();
    void set (Pca9555TypeLevel value);
}
member OutputO02 : Pca9555TypeLevel with get, set

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.OutputO03 Property

IRD

Pca9555OutputO03 Property

Output (O-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel OutputO03 { get; set; }
Public Property OutputO03 As Pca9555TypeLevel
    Get
    Set
public:
property Pca9555TypeLevel OutputO03 {
    Pca9555TypeLevel get ();
    void set (Pca9555TypeLevel value);
}
member OutputO03 : Pca9555TypeLevel with get, set

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.OutputO04 Property

IRD

Pca9555OutputO04 Property

Output (O-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel OutputO04 { get; set; }
Public Property OutputO04 As Pca9555TypeLevel
    Get
    Set
public:
property Pca9555TypeLevel OutputO04 {
    Pca9555TypeLevel get ();
    void set (Pca9555TypeLevel value);
}
member OutputO04 : Pca9555TypeLevel with get, set

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.OutputO05 Property

IRD

Pca9555OutputO05 Property

Output (O-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel OutputO05 { get; set; }
Public Property OutputO05 As Pca9555TypeLevel
    Get
    Set
public:
property Pca9555TypeLevel OutputO05 {
    Pca9555TypeLevel get ();
    void set (Pca9555TypeLevel value);
}
member OutputO05 : Pca9555TypeLevel with get, set

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.OutputO06 Property

IRD

Pca9555OutputO06 Property

Output (O-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel OutputO06 { get; set; }
Public Property OutputO06 As Pca9555TypeLevel
    Get
    Set
public:
property Pca9555TypeLevel OutputO06 {
    Pca9555TypeLevel get ();
    void set (Pca9555TypeLevel value);
}
member OutputO06 : Pca9555TypeLevel with get, set

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.OutputO07 Property

IRD

Pca9555OutputO07 Property

Output (O-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel OutputO07 { get; set; }
Public Property OutputO07 As Pca9555TypeLevel
    Get
    Set
public:
property Pca9555TypeLevel OutputO07 {
    Pca9555TypeLevel get ();
    void set (Pca9555TypeLevel value);
}
member OutputO07 : Pca9555TypeLevel with get, set

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.OutputO10 Property

IRD

Pca9555OutputO10 Property

Output (O-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel OutputO10 { get; set; }
Public Property OutputO10 As Pca9555TypeLevel
    Get
    Set
public:
property Pca9555TypeLevel OutputO10 {
    Pca9555TypeLevel get ();
    void set (Pca9555TypeLevel value);
}
member OutputO10 : Pca9555TypeLevel with get, set

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.OutputO11 Property

IRD

Pca9555OutputO11 Property

Output (O-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel OutputO11 { get; set; }
Public Property OutputO11 As Pca9555TypeLevel
    Get
    Set
public:
property Pca9555TypeLevel OutputO11 {
    Pca9555TypeLevel get ();
    void set (Pca9555TypeLevel value);
}
member OutputO11 : Pca9555TypeLevel with get, set

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.OutputO12 Property

IRD

Pca9555OutputO12 Property

Output (O-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel OutputO12 { get; set; }
Public Property OutputO12 As Pca9555TypeLevel
    Get
    Set
public:
property Pca9555TypeLevel OutputO12 {
    Pca9555TypeLevel get ();
    void set (Pca9555TypeLevel value);
}
member OutputO12 : Pca9555TypeLevel with get, set

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.OutputO13 Property

IRD

Pca9555OutputO13 Property

Output (O-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel OutputO13 { get; set; }
Public Property OutputO13 As Pca9555TypeLevel
    Get
    Set
public:
property Pca9555TypeLevel OutputO13 {
    Pca9555TypeLevel get ();
    void set (Pca9555TypeLevel value);
}
member OutputO13 : Pca9555TypeLevel with get, set

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.OutputO14 Property

IRD

Pca9555OutputO14 Property

Output (O-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel OutputO14 { get; set; }
Public Property OutputO14 As Pca9555TypeLevel
    Get
    Set
public:
property Pca9555TypeLevel OutputO14 {
    Pca9555TypeLevel get ();
    void set (Pca9555TypeLevel value);
}
member OutputO14 : Pca9555TypeLevel with get, set

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.OutputO15 Property

IRD

Pca9555OutputO15 Property

Output (O-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel OutputO15 { get; set; }
Public Property OutputO15 As Pca9555TypeLevel
    Get
    Set
public:
property Pca9555TypeLevel OutputO15 {
    Pca9555TypeLevel get ();
    void set (Pca9555TypeLevel value);
}
member OutputO15 : Pca9555TypeLevel with get, set

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.OutputO16 Property

IRD

Pca9555OutputO16 Property

Output (O-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel OutputO16 { get; set; }
Public Property OutputO16 As Pca9555TypeLevel
    Get
    Set
public:
property Pca9555TypeLevel OutputO16 {
    Pca9555TypeLevel get ();
    void set (Pca9555TypeLevel value);
}
member OutputO16 : Pca9555TypeLevel with get, set

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.OutputO17 Property

IRD

Pca9555OutputO17 Property

Output (O-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypeLevel OutputO17 { get; set; }
Public Property OutputO17 As Pca9555TypeLevel
    Get
    Set
public:
property Pca9555TypeLevel OutputO17 {
    Pca9555TypeLevel get ();
    void set (Pca9555TypeLevel value);
}
member OutputO17 : Pca9555TypeLevel with get, set

Property Value

Type: Pca9555TypeLevel
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.PolarityInversionP00 Property

IRD

Pca9555PolarityInversionP00 Property

Polarity Inversion (P-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypePolarity PolarityInversionP00 { get; set; }
Public Property PolarityInversionP00 As Pca9555TypePolarity
    Get
    Set
public:
property Pca9555TypePolarity PolarityInversionP00 {
    Pca9555TypePolarity get ();
    void set (Pca9555TypePolarity value);
}
member PolarityInversionP00 : Pca9555TypePolarity with get, set

Property Value

Type: Pca9555TypePolarity
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.PolarityInversionP01 Property

IRD

Pca9555PolarityInversionP01 Property

Polarity Inversion (P-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypePolarity PolarityInversionP01 { get; set; }
Public Property PolarityInversionP01 As Pca9555TypePolarity
    Get
    Set
public:
property Pca9555TypePolarity PolarityInversionP01 {
    Pca9555TypePolarity get ();
    void set (Pca9555TypePolarity value);
}
member PolarityInversionP01 : Pca9555TypePolarity with get, set

Property Value

Type: Pca9555TypePolarity
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.PolarityInversionP02 Property

IRD

Pca9555PolarityInversionP02 Property

Polarity Inversion (P-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypePolarity PolarityInversionP02 { get; set; }
Public Property PolarityInversionP02 As Pca9555TypePolarity
    Get
    Set
public:
property Pca9555TypePolarity PolarityInversionP02 {
    Pca9555TypePolarity get ();
    void set (Pca9555TypePolarity value);
}
member PolarityInversionP02 : Pca9555TypePolarity with get, set

Property Value

Type: Pca9555TypePolarity
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.PolarityInversionP03 Property

IRD

Pca9555PolarityInversionP03 Property

Polarity Inversion (P-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypePolarity PolarityInversionP03 { get; set; }
Public Property PolarityInversionP03 As Pca9555TypePolarity
    Get
    Set
public:
property Pca9555TypePolarity PolarityInversionP03 {
    Pca9555TypePolarity get ();
    void set (Pca9555TypePolarity value);
}
member PolarityInversionP03 : Pca9555TypePolarity with get, set

Property Value

Type: Pca9555TypePolarity
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.PolarityInversionP04 Property

IRD

Pca9555PolarityInversionP04 Property

Polarity Inversion (P-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypePolarity PolarityInversionP04 { get; set; }
Public Property PolarityInversionP04 As Pca9555TypePolarity
    Get
    Set
public:
property Pca9555TypePolarity PolarityInversionP04 {
    Pca9555TypePolarity get ();
    void set (Pca9555TypePolarity value);
}
member PolarityInversionP04 : Pca9555TypePolarity with get, set

Property Value

Type: Pca9555TypePolarity
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.PolarityInversionP05 Property

IRD

Pca9555PolarityInversionP05 Property

Polarity Inversion (P-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypePolarity PolarityInversionP05 { get; set; }
Public Property PolarityInversionP05 As Pca9555TypePolarity
    Get
    Set
public:
property Pca9555TypePolarity PolarityInversionP05 {
    Pca9555TypePolarity get ();
    void set (Pca9555TypePolarity value);
}
member PolarityInversionP05 : Pca9555TypePolarity with get, set

Property Value

Type: Pca9555TypePolarity
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.PolarityInversionP06 Property

IRD

Pca9555PolarityInversionP06 Property

Polarity Inversion (P-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypePolarity PolarityInversionP06 { get; set; }
Public Property PolarityInversionP06 As Pca9555TypePolarity
    Get
    Set
public:
property Pca9555TypePolarity PolarityInversionP06 {
    Pca9555TypePolarity get ();
    void set (Pca9555TypePolarity value);
}
member PolarityInversionP06 : Pca9555TypePolarity with get, set

Property Value

Type: Pca9555TypePolarity
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.PolarityInversionP07 Property

IRD

Pca9555PolarityInversionP07 Property

Polarity Inversion (P-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypePolarity PolarityInversionP07 { get; set; }
Public Property PolarityInversionP07 As Pca9555TypePolarity
    Get
    Set
public:
property Pca9555TypePolarity PolarityInversionP07 {
    Pca9555TypePolarity get ();
    void set (Pca9555TypePolarity value);
}
member PolarityInversionP07 : Pca9555TypePolarity with get, set

Property Value

Type: Pca9555TypePolarity
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.PolarityInversionP10 Property

IRD

Pca9555PolarityInversionP10 Property

Polarity Inversion (P-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypePolarity PolarityInversionP10 { get; set; }
Public Property PolarityInversionP10 As Pca9555TypePolarity
    Get
    Set
public:
property Pca9555TypePolarity PolarityInversionP10 {
    Pca9555TypePolarity get ();
    void set (Pca9555TypePolarity value);
}
member PolarityInversionP10 : Pca9555TypePolarity with get, set

Property Value

Type: Pca9555TypePolarity
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.PolarityInversionP11 Property

IRD

Pca9555PolarityInversionP11 Property

Polarity Inversion (P-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypePolarity PolarityInversionP11 { get; set; }
Public Property PolarityInversionP11 As Pca9555TypePolarity
    Get
    Set
public:
property Pca9555TypePolarity PolarityInversionP11 {
    Pca9555TypePolarity get ();
    void set (Pca9555TypePolarity value);
}
member PolarityInversionP11 : Pca9555TypePolarity with get, set

Property Value

Type: Pca9555TypePolarity
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.PolarityInversionP12 Property

IRD

Pca9555PolarityInversionP12 Property

Polarity Inversion (P-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypePolarity PolarityInversionP12 { get; set; }
Public Property PolarityInversionP12 As Pca9555TypePolarity
    Get
    Set
public:
property Pca9555TypePolarity PolarityInversionP12 {
    Pca9555TypePolarity get ();
    void set (Pca9555TypePolarity value);
}
member PolarityInversionP12 : Pca9555TypePolarity with get, set

Property Value

Type: Pca9555TypePolarity
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.PolarityInversionP13 Property

IRD

Pca9555PolarityInversionP13 Property

Polarity Inversion (P-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypePolarity PolarityInversionP13 { get; set; }
Public Property PolarityInversionP13 As Pca9555TypePolarity
    Get
    Set
public:
property Pca9555TypePolarity PolarityInversionP13 {
    Pca9555TypePolarity get ();
    void set (Pca9555TypePolarity value);
}
member PolarityInversionP13 : Pca9555TypePolarity with get, set

Property Value

Type: Pca9555TypePolarity
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.PolarityInversionP14 Property

IRD

Pca9555PolarityInversionP14 Property

Polarity Inversion (P-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypePolarity PolarityInversionP14 { get; set; }
Public Property PolarityInversionP14 As Pca9555TypePolarity
    Get
    Set
public:
property Pca9555TypePolarity PolarityInversionP14 {
    Pca9555TypePolarity get ();
    void set (Pca9555TypePolarity value);
}
member PolarityInversionP14 : Pca9555TypePolarity with get, set

Property Value

Type: Pca9555TypePolarity
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.PolarityInversionP15 Property

IRD

Pca9555PolarityInversionP15 Property

Polarity Inversion (P-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypePolarity PolarityInversionP15 { get; set; }
Public Property PolarityInversionP15 As Pca9555TypePolarity
    Get
    Set
public:
property Pca9555TypePolarity PolarityInversionP15 {
    Pca9555TypePolarity get ();
    void set (Pca9555TypePolarity value);
}
member PolarityInversionP15 : Pca9555TypePolarity with get, set

Property Value

Type: Pca9555TypePolarity
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.PolarityInversionP16 Property

IRD

Pca9555PolarityInversionP16 Property

Polarity Inversion (P-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypePolarity PolarityInversionP16 { get; set; }
Public Property PolarityInversionP16 As Pca9555TypePolarity
    Get
    Set
public:
property Pca9555TypePolarity PolarityInversionP16 {
    Pca9555TypePolarity get ();
    void set (Pca9555TypePolarity value);
}
member PolarityInversionP16 : Pca9555TypePolarity with get, set

Property Value

Type: Pca9555TypePolarity
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.PolarityInversionP17 Property

IRD

Pca9555PolarityInversionP17 Property

Polarity Inversion (P-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9555TypePolarity PolarityInversionP17 { get; set; }
Public Property PolarityInversionP17 As Pca9555TypePolarity
    Get
    Set
public:
property Pca9555TypePolarity PolarityInversionP17 {
    Pca9555TypePolarity get ();
    void set (Pca9555TypePolarity value);
}
member PolarityInversionP17 : Pca9555TypePolarity with get, set

Property Value

Type: Pca9555TypePolarity
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555 Methods

The Pca9555 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.Flush Method

IRD

Pca9555Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9555 Class
telos.Ird.TexasInstruments Namespace


Pca9555.TypeConfiguration Enumeration

IRD

Pca9555TypeConfiguration Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Input | 1 | Input
Output | 0 | Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9555.TypeLevel Enumeration

IRD

Pca9555TypeLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLevel
Public Enumeration TypeLevel
public enum class TypeLevel
type TypeLevel
Members
Member name | Value | Description
High | 1 | High
Low | 0 | Low
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9555.TypePolarity Enumeration

IRD

Pca9555TypePolarity Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarity
Public Enumeration TypePolarity
public enum class TypePolarity
type TypePolarity
Members
Member name | Value | Description
Inverted | 1 | Inverted
Normal | 0 | Normal
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9557 Class

Texas Instruments: PCA 9557
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPca9557

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pca9557
Public Class Pca9557
public ref class Pca9557
type Pca9557 =  class end

The Pca9557 type exposes the following members.

Constructors
 | Name | Description
Public method | Pca9557 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC03 | Configuration (C-03)
Public property | ConfigurationC04 | Configuration (C-04)
Public property | ConfigurationC05 | Configuration (C-05)
Public property | ConfigurationC06 | Configuration (C-06)
Public property | ConfigurationC07 | Configuration (C-07)
Public property | InputI00 | Input (I-00)
Public property | InputI01 | Input (I-01)
Public property | InputI02 | Input (I-02)
Public property | InputI03 | Input (I-03)
Public property | InputI04 | Input (I-04)
Public property | InputI05 | Input (I-05)
Public property | InputI06 | Input (I-06)
Public property | InputI07 | Input (I-07)
Public property | OutputO00 | Output (O-00)
Public property | OutputO01 | Output (O-01)
Public property | OutputO02 | Output (O-02)
Public property | OutputO03 | Output (O-03)
Public property | OutputO04 | Output (O-04)
Public property | OutputO05 | Output (O-05)
Public property | OutputO06 | Output (O-06)
Public property | OutputO07 | Output (O-07)
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Public property | PolarityInversionP04 | Polarity Inversion (P-04)
Public property | PolarityInversionP05 | Polarity Inversion (P-05)
Public property | PolarityInversionP06 | Polarity Inversion (P-06)
Public property | PolarityInversionP07 | Polarity Inversion (P-07)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Remote 8-Bit I2C And SMBus I/O Expander With Reset And Configuration Registers
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9557 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pca9557(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pca9557

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557 Properties

The Pca9557 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC03 | Configuration (C-03)
Public property | ConfigurationC04 | Configuration (C-04)
Public property | ConfigurationC05 | Configuration (C-05)
Public property | ConfigurationC06 | Configuration (C-06)
Public property | ConfigurationC07 | Configuration (C-07)
Public property | InputI00 | Input (I-00)
Public property | InputI01 | Input (I-01)
Public property | InputI02 | Input (I-02)
Public property | InputI03 | Input (I-03)
Public property | InputI04 | Input (I-04)
Public property | InputI05 | Input (I-05)
Public property | InputI06 | Input (I-06)
Public property | InputI07 | Input (I-07)
Public property | OutputO00 | Output (O-00)
Public property | OutputO01 | Output (O-01)
Public property | OutputO02 | Output (O-02)
Public property | OutputO03 | Output (O-03)
Public property | OutputO04 | Output (O-04)
Public property | OutputO05 | Output (O-05)
Public property | OutputO06 | Output (O-06)
Public property | OutputO07 | Output (O-07)
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Public property | PolarityInversionP04 | Polarity Inversion (P-04)
Public property | PolarityInversionP05 | Polarity Inversion (P-05)
Public property | PolarityInversionP06 | Polarity Inversion (P-06)
Public property | PolarityInversionP07 | Polarity Inversion (P-07)
Top
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.AutoFlush Property

IRD

Pca9557AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.ConfigurationC00 Property

IRD

Pca9557ConfigurationC00 Property

Configuration (C-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeConfiguration ConfigurationC00 { get; set; }
Public Property ConfigurationC00 As Pca9557TypeConfiguration
    Get
    Set
public:
property Pca9557TypeConfiguration ConfigurationC00 {
    Pca9557TypeConfiguration get ();
    void set (Pca9557TypeConfiguration value);
}
member ConfigurationC00 : Pca9557TypeConfiguration with get, set

Property Value

Type: Pca9557TypeConfiguration
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.ConfigurationC01 Property

IRD

Pca9557ConfigurationC01 Property

Configuration (C-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeConfiguration ConfigurationC01 { get; set; }
Public Property ConfigurationC01 As Pca9557TypeConfiguration
    Get
    Set
public:
property Pca9557TypeConfiguration ConfigurationC01 {
    Pca9557TypeConfiguration get ();
    void set (Pca9557TypeConfiguration value);
}
member ConfigurationC01 : Pca9557TypeConfiguration with get, set

Property Value

Type: Pca9557TypeConfiguration
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.ConfigurationC02 Property

IRD

Pca9557ConfigurationC02 Property

Configuration (C-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeConfiguration ConfigurationC02 { get; set; }
Public Property ConfigurationC02 As Pca9557TypeConfiguration
    Get
    Set
public:
property Pca9557TypeConfiguration ConfigurationC02 {
    Pca9557TypeConfiguration get ();
    void set (Pca9557TypeConfiguration value);
}
member ConfigurationC02 : Pca9557TypeConfiguration with get, set

Property Value

Type: Pca9557TypeConfiguration
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.ConfigurationC03 Property

IRD

Pca9557ConfigurationC03 Property

Configuration (C-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeConfiguration ConfigurationC03 { get; set; }
Public Property ConfigurationC03 As Pca9557TypeConfiguration
    Get
    Set
public:
property Pca9557TypeConfiguration ConfigurationC03 {
    Pca9557TypeConfiguration get ();
    void set (Pca9557TypeConfiguration value);
}
member ConfigurationC03 : Pca9557TypeConfiguration with get, set

Property Value

Type: Pca9557TypeConfiguration
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.ConfigurationC04 Property

IRD

Pca9557ConfigurationC04 Property

Configuration (C-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeConfiguration ConfigurationC04 { get; set; }
Public Property ConfigurationC04 As Pca9557TypeConfiguration
    Get
    Set
public:
property Pca9557TypeConfiguration ConfigurationC04 {
    Pca9557TypeConfiguration get ();
    void set (Pca9557TypeConfiguration value);
}
member ConfigurationC04 : Pca9557TypeConfiguration with get, set

Property Value

Type: Pca9557TypeConfiguration
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.ConfigurationC05 Property

IRD

Pca9557ConfigurationC05 Property

Configuration (C-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeConfiguration ConfigurationC05 { get; set; }
Public Property ConfigurationC05 As Pca9557TypeConfiguration
    Get
    Set
public:
property Pca9557TypeConfiguration ConfigurationC05 {
    Pca9557TypeConfiguration get ();
    void set (Pca9557TypeConfiguration value);
}
member ConfigurationC05 : Pca9557TypeConfiguration with get, set

Property Value

Type: Pca9557TypeConfiguration
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.ConfigurationC06 Property

IRD

Pca9557ConfigurationC06 Property

Configuration (C-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeConfiguration ConfigurationC06 { get; set; }
Public Property ConfigurationC06 As Pca9557TypeConfiguration
    Get
    Set
public:
property Pca9557TypeConfiguration ConfigurationC06 {
    Pca9557TypeConfiguration get ();
    void set (Pca9557TypeConfiguration value);
}
member ConfigurationC06 : Pca9557TypeConfiguration with get, set

Property Value

Type: Pca9557TypeConfiguration
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.ConfigurationC07 Property

IRD

Pca9557ConfigurationC07 Property

Configuration (C-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeConfiguration ConfigurationC07 { get; set; }
Public Property ConfigurationC07 As Pca9557TypeConfiguration
    Get
    Set
public:
property Pca9557TypeConfiguration ConfigurationC07 {
    Pca9557TypeConfiguration get ();
    void set (Pca9557TypeConfiguration value);
}
member ConfigurationC07 : Pca9557TypeConfiguration with get, set

Property Value

Type: Pca9557TypeConfiguration
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.InputI00 Property

IRD

Pca9557InputI00 Property

Input (I-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeLevel InputI00 { get; }
Public ReadOnly Property InputI00 As Pca9557TypeLevel
    Get
public:
property Pca9557TypeLevel InputI00 {
    Pca9557TypeLevel get ();
}
member InputI00 : Pca9557TypeLevel with get

Property Value

Type: Pca9557TypeLevel
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.InputI01 Property

IRD

Pca9557InputI01 Property

Input (I-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeLevel InputI01 { get; }
Public ReadOnly Property InputI01 As Pca9557TypeLevel
    Get
public:
property Pca9557TypeLevel InputI01 {
    Pca9557TypeLevel get ();
}
member InputI01 : Pca9557TypeLevel with get

Property Value

Type: Pca9557TypeLevel
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.InputI02 Property

IRD

Pca9557InputI02 Property

Input (I-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeLevel InputI02 { get; }
Public ReadOnly Property InputI02 As Pca9557TypeLevel
    Get
public:
property Pca9557TypeLevel InputI02 {
    Pca9557TypeLevel get ();
}
member InputI02 : Pca9557TypeLevel with get

Property Value

Type: Pca9557TypeLevel
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.InputI03 Property

IRD

Pca9557InputI03 Property

Input (I-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeLevel InputI03 { get; }
Public ReadOnly Property InputI03 As Pca9557TypeLevel
    Get
public:
property Pca9557TypeLevel InputI03 {
    Pca9557TypeLevel get ();
}
member InputI03 : Pca9557TypeLevel with get

Property Value

Type: Pca9557TypeLevel
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.InputI04 Property

IRD

Pca9557InputI04 Property

Input (I-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeLevel InputI04 { get; }
Public ReadOnly Property InputI04 As Pca9557TypeLevel
    Get
public:
property Pca9557TypeLevel InputI04 {
    Pca9557TypeLevel get ();
}
member InputI04 : Pca9557TypeLevel with get

Property Value

Type: Pca9557TypeLevel
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.InputI05 Property

IRD

Pca9557InputI05 Property

Input (I-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeLevel InputI05 { get; }
Public ReadOnly Property InputI05 As Pca9557TypeLevel
    Get
public:
property Pca9557TypeLevel InputI05 {
    Pca9557TypeLevel get ();
}
member InputI05 : Pca9557TypeLevel with get

Property Value

Type: Pca9557TypeLevel
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.InputI06 Property

IRD

Pca9557InputI06 Property

Input (I-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeLevel InputI06 { get; }
Public ReadOnly Property InputI06 As Pca9557TypeLevel
    Get
public:
property Pca9557TypeLevel InputI06 {
    Pca9557TypeLevel get ();
}
member InputI06 : Pca9557TypeLevel with get

Property Value

Type: Pca9557TypeLevel
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.InputI07 Property

IRD

Pca9557InputI07 Property

Input (I-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeLevel InputI07 { get; }
Public ReadOnly Property InputI07 As Pca9557TypeLevel
    Get
public:
property Pca9557TypeLevel InputI07 {
    Pca9557TypeLevel get ();
}
member InputI07 : Pca9557TypeLevel with get

Property Value

Type: Pca9557TypeLevel
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.OutputO00 Property

IRD

Pca9557OutputO00 Property

Output (O-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeLevel OutputO00 { get; set; }
Public Property OutputO00 As Pca9557TypeLevel
    Get
    Set
public:
property Pca9557TypeLevel OutputO00 {
    Pca9557TypeLevel get ();
    void set (Pca9557TypeLevel value);
}
member OutputO00 : Pca9557TypeLevel with get, set

Property Value

Type: Pca9557TypeLevel
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.OutputO01 Property

IRD

Pca9557OutputO01 Property

Output (O-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeLevel OutputO01 { get; set; }
Public Property OutputO01 As Pca9557TypeLevel
    Get
    Set
public:
property Pca9557TypeLevel OutputO01 {
    Pca9557TypeLevel get ();
    void set (Pca9557TypeLevel value);
}
member OutputO01 : Pca9557TypeLevel with get, set

Property Value

Type: Pca9557TypeLevel
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.OutputO02 Property

IRD

Pca9557OutputO02 Property

Output (O-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeLevel OutputO02 { get; set; }
Public Property OutputO02 As Pca9557TypeLevel
    Get
    Set
public:
property Pca9557TypeLevel OutputO02 {
    Pca9557TypeLevel get ();
    void set (Pca9557TypeLevel value);
}
member OutputO02 : Pca9557TypeLevel with get, set

Property Value

Type: Pca9557TypeLevel
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.OutputO03 Property

IRD

Pca9557OutputO03 Property

Output (O-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeLevel OutputO03 { get; set; }
Public Property OutputO03 As Pca9557TypeLevel
    Get
    Set
public:
property Pca9557TypeLevel OutputO03 {
    Pca9557TypeLevel get ();
    void set (Pca9557TypeLevel value);
}
member OutputO03 : Pca9557TypeLevel with get, set

Property Value

Type: Pca9557TypeLevel
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.OutputO04 Property

IRD

Pca9557OutputO04 Property

Output (O-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeLevel OutputO04 { get; set; }
Public Property OutputO04 As Pca9557TypeLevel
    Get
    Set
public:
property Pca9557TypeLevel OutputO04 {
    Pca9557TypeLevel get ();
    void set (Pca9557TypeLevel value);
}
member OutputO04 : Pca9557TypeLevel with get, set

Property Value

Type: Pca9557TypeLevel
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.OutputO05 Property

IRD

Pca9557OutputO05 Property

Output (O-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeLevel OutputO05 { get; set; }
Public Property OutputO05 As Pca9557TypeLevel
    Get
    Set
public:
property Pca9557TypeLevel OutputO05 {
    Pca9557TypeLevel get ();
    void set (Pca9557TypeLevel value);
}
member OutputO05 : Pca9557TypeLevel with get, set

Property Value

Type: Pca9557TypeLevel
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.OutputO06 Property

IRD

Pca9557OutputO06 Property

Output (O-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeLevel OutputO06 { get; set; }
Public Property OutputO06 As Pca9557TypeLevel
    Get
    Set
public:
property Pca9557TypeLevel OutputO06 {
    Pca9557TypeLevel get ();
    void set (Pca9557TypeLevel value);
}
member OutputO06 : Pca9557TypeLevel with get, set

Property Value

Type: Pca9557TypeLevel
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.OutputO07 Property

IRD

Pca9557OutputO07 Property

Output (O-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypeLevel OutputO07 { get; set; }
Public Property OutputO07 As Pca9557TypeLevel
    Get
    Set
public:
property Pca9557TypeLevel OutputO07 {
    Pca9557TypeLevel get ();
    void set (Pca9557TypeLevel value);
}
member OutputO07 : Pca9557TypeLevel with get, set

Property Value

Type: Pca9557TypeLevel
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.PolarityInversionP00 Property

IRD

Pca9557PolarityInversionP00 Property

Polarity Inversion (P-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypePolarity PolarityInversionP00 { get; set; }
Public Property PolarityInversionP00 As Pca9557TypePolarity
    Get
    Set
public:
property Pca9557TypePolarity PolarityInversionP00 {
    Pca9557TypePolarity get ();
    void set (Pca9557TypePolarity value);
}
member PolarityInversionP00 : Pca9557TypePolarity with get, set

Property Value

Type: Pca9557TypePolarity
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.PolarityInversionP01 Property

IRD

Pca9557PolarityInversionP01 Property

Polarity Inversion (P-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypePolarity PolarityInversionP01 { get; set; }
Public Property PolarityInversionP01 As Pca9557TypePolarity
    Get
    Set
public:
property Pca9557TypePolarity PolarityInversionP01 {
    Pca9557TypePolarity get ();
    void set (Pca9557TypePolarity value);
}
member PolarityInversionP01 : Pca9557TypePolarity with get, set

Property Value

Type: Pca9557TypePolarity
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.PolarityInversionP02 Property

IRD

Pca9557PolarityInversionP02 Property

Polarity Inversion (P-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypePolarity PolarityInversionP02 { get; set; }
Public Property PolarityInversionP02 As Pca9557TypePolarity
    Get
    Set
public:
property Pca9557TypePolarity PolarityInversionP02 {
    Pca9557TypePolarity get ();
    void set (Pca9557TypePolarity value);
}
member PolarityInversionP02 : Pca9557TypePolarity with get, set

Property Value

Type: Pca9557TypePolarity
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.PolarityInversionP03 Property

IRD

Pca9557PolarityInversionP03 Property

Polarity Inversion (P-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypePolarity PolarityInversionP03 { get; set; }
Public Property PolarityInversionP03 As Pca9557TypePolarity
    Get
    Set
public:
property Pca9557TypePolarity PolarityInversionP03 {
    Pca9557TypePolarity get ();
    void set (Pca9557TypePolarity value);
}
member PolarityInversionP03 : Pca9557TypePolarity with get, set

Property Value

Type: Pca9557TypePolarity
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.PolarityInversionP04 Property

IRD

Pca9557PolarityInversionP04 Property

Polarity Inversion (P-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypePolarity PolarityInversionP04 { get; set; }
Public Property PolarityInversionP04 As Pca9557TypePolarity
    Get
    Set
public:
property Pca9557TypePolarity PolarityInversionP04 {
    Pca9557TypePolarity get ();
    void set (Pca9557TypePolarity value);
}
member PolarityInversionP04 : Pca9557TypePolarity with get, set

Property Value

Type: Pca9557TypePolarity
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.PolarityInversionP05 Property

IRD

Pca9557PolarityInversionP05 Property

Polarity Inversion (P-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypePolarity PolarityInversionP05 { get; set; }
Public Property PolarityInversionP05 As Pca9557TypePolarity
    Get
    Set
public:
property Pca9557TypePolarity PolarityInversionP05 {
    Pca9557TypePolarity get ();
    void set (Pca9557TypePolarity value);
}
member PolarityInversionP05 : Pca9557TypePolarity with get, set

Property Value

Type: Pca9557TypePolarity
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.PolarityInversionP06 Property

IRD

Pca9557PolarityInversionP06 Property

Polarity Inversion (P-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypePolarity PolarityInversionP06 { get; set; }
Public Property PolarityInversionP06 As Pca9557TypePolarity
    Get
    Set
public:
property Pca9557TypePolarity PolarityInversionP06 {
    Pca9557TypePolarity get ();
    void set (Pca9557TypePolarity value);
}
member PolarityInversionP06 : Pca9557TypePolarity with get, set

Property Value

Type: Pca9557TypePolarity
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.PolarityInversionP07 Property

IRD

Pca9557PolarityInversionP07 Property

Polarity Inversion (P-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pca9557TypePolarity PolarityInversionP07 { get; set; }
Public Property PolarityInversionP07 As Pca9557TypePolarity
    Get
    Set
public:
property Pca9557TypePolarity PolarityInversionP07 {
    Pca9557TypePolarity get ();
    void set (Pca9557TypePolarity value);
}
member PolarityInversionP07 : Pca9557TypePolarity with get, set

Property Value

Type: Pca9557TypePolarity
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557 Methods

The Pca9557 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.Flush Method

IRD

Pca9557Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pca9557 Class
telos.Ird.TexasInstruments Namespace


Pca9557.TypeConfiguration Enumeration

IRD

Pca9557TypeConfiguration Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Input | 1 | Input
Output | 0 | Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9557.TypeLevel Enumeration

IRD

Pca9557TypeLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLevel
Public Enumeration TypeLevel
public enum class TypeLevel
type TypeLevel
Members
Member name | Value | Description
High | 1 | High
Low | 0 | Low
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pca9557.TypePolarity Enumeration

IRD

Pca9557TypePolarity Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarity
Public Enumeration TypePolarity
public enum class TypePolarity
type TypePolarity
Members
Member name | Value | Description
Inverted | 1 | Inverted
Normal | 0 | Normal
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680 Class

Texas Instruments: PCM 1680
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPcm1680

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcm1680
Public Class Pcm1680
public ref class Pcm1680
type Pcm1680 =  class end

The Pcm1680 type exposes the following members.

Constructors
 | Name | Description
Public method | Pcm1680 | Constructor
Top
Properties
 | Name | Description
Public property | Attenuation1AT1 | Attenuation1: AT1
Public property | Attenuation2AT2 | Attenuation2: AT2
Public property | Attenuation3AT3 | Attenuation3: AT3
Public property | Attenuation4AT4 | Attenuation4: AT4
Public property | Attenuation5AT5 | Attenuation5: AT5
Public property | Attenuation6AT6 | Attenuation6: AT6
Public property | Attenuation7AT7 | Attenuation7: AT7
Public property | Attenuation8AT8 | Attenuation8: AT8
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DACControl1DAC1 | DAC Control1: DAC1
Public property | DACControl1DAC2 | DAC Control1: DAC2
Public property | DACControl1DAC3 | DAC Control1: DAC3
Public property | DACControl1DAC4 | DAC Control1: DAC4
Public property | DACControl1DAC5 | DAC Control1: DAC5
Public property | DACControl1DAC6 | DAC Control1: DAC6
Public property | DACControl2DAC7 | DAC Control2: DAC7
Public property | DACControl2DAC8 | DAC Control2: DAC8
Public property | DeEmphasisDMC | De Emphasis: DMC
Public property | DeEmphasisDMF | De Emphasis: DMF
Public property | DeEmphasisDREV | De Emphasis: DREV
Public property | DeEmphasisSRST | De Emphasis: SRST
Public property | DeEmphasisZREV | De Emphasis: ZREV
Public property | DetectStatusZERO1 | Detect Status: ZERO1
Public property | DetectStatusZERO2 | Detect Status: ZERO2
Public property | DetectStatusZERO3 | Detect Status: ZERO3
Public property | DetectStatusZERO4 | Detect Status: ZERO4
Public property | DetectStatusZERO5 | Detect Status: ZERO5
Public property | DetectStatusZERO6 | Detect Status: ZERO6
Public property | DetectStatusZERO7 | Detect Status: ZERO7
Public property | DetectStatusZERO8 | Detect Status: ZERO8
Public property | FilterFLT | Filter: FLT
Public property | FilterFMT | Filter: FMT
Public property | ModeSelectAZRO | Mode Select: AZRO
Public property | ModeSelectDAMS | Mode Select: DAMS
Public property | Mute1MUT1 | Mute1: MUT1
Public property | Mute1MUT2 | Mute1: MUT2
Public property | Mute1MUT3 | Mute1: MUT3
Public property | Mute1MUT4 | Mute1: MUT4
Public property | Mute1MUT5 | Mute1: MUT5
Public property | Mute1MUT6 | Mute1: MUT6
Public property | Mute2MUT7 | Mute2: MUT7
Public property | Mute2MUT8 | Mute2: MUT8
Public property | RateControlOVER | Rate Control: OVER
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Audio Digital-to-Analog Converter
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcm1680(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcm1680

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680 Properties

The Pcm1680 type exposes the following members.

Properties
 | Name | Description
Public property | Attenuation1AT1 | Attenuation1: AT1
Public property | Attenuation2AT2 | Attenuation2: AT2
Public property | Attenuation3AT3 | Attenuation3: AT3
Public property | Attenuation4AT4 | Attenuation4: AT4
Public property | Attenuation5AT5 | Attenuation5: AT5
Public property | Attenuation6AT6 | Attenuation6: AT6
Public property | Attenuation7AT7 | Attenuation7: AT7
Public property | Attenuation8AT8 | Attenuation8: AT8
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DACControl1DAC1 | DAC Control1: DAC1
Public property | DACControl1DAC2 | DAC Control1: DAC2
Public property | DACControl1DAC3 | DAC Control1: DAC3
Public property | DACControl1DAC4 | DAC Control1: DAC4
Public property | DACControl1DAC5 | DAC Control1: DAC5
Public property | DACControl1DAC6 | DAC Control1: DAC6
Public property | DACControl2DAC7 | DAC Control2: DAC7
Public property | DACControl2DAC8 | DAC Control2: DAC8
Public property | DeEmphasisDMC | De Emphasis: DMC
Public property | DeEmphasisDMF | De Emphasis: DMF
Public property | DeEmphasisDREV | De Emphasis: DREV
Public property | DeEmphasisSRST | De Emphasis: SRST
Public property | DeEmphasisZREV | De Emphasis: ZREV
Public property | DetectStatusZERO1 | Detect Status: ZERO1
Public property | DetectStatusZERO2 | Detect Status: ZERO2
Public property | DetectStatusZERO3 | Detect Status: ZERO3
Public property | DetectStatusZERO4 | Detect Status: ZERO4
Public property | DetectStatusZERO5 | Detect Status: ZERO5
Public property | DetectStatusZERO6 | Detect Status: ZERO6
Public property | DetectStatusZERO7 | Detect Status: ZERO7
Public property | DetectStatusZERO8 | Detect Status: ZERO8
Public property | FilterFLT | Filter: FLT
Public property | FilterFMT | Filter: FMT
Public property | ModeSelectAZRO | Mode Select: AZRO
Public property | ModeSelectDAMS | Mode Select: DAMS
Public property | Mute1MUT1 | Mute1: MUT1
Public property | Mute1MUT2 | Mute1: MUT2
Public property | Mute1MUT3 | Mute1: MUT3
Public property | Mute1MUT4 | Mute1: MUT4
Public property | Mute1MUT5 | Mute1: MUT5
Public property | Mute1MUT6 | Mute1: MUT6
Public property | Mute2MUT7 | Mute2: MUT7
Public property | Mute2MUT8 | Mute2: MUT8
Public property | RateControlOVER | Rate Control: OVER
Top
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.Attenuation1AT1 Property

IRD

Pcm1680Attenuation1AT1 Property

Attenuation1: AT1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeAttenuation Attenuation1AT1 { get; set; }
Public Property Attenuation1AT1 As Pcm1680TypeAttenuation
    Get
    Set
public:
property Pcm1680TypeAttenuation Attenuation1AT1 {
    Pcm1680TypeAttenuation get ();
    void set (Pcm1680TypeAttenuation value);
}
member Attenuation1AT1 : Pcm1680TypeAttenuation with get, set

Property Value

Type: Pcm1680TypeAttenuation
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.Attenuation2AT2 Property

IRD

Pcm1680Attenuation2AT2 Property

Attenuation2: AT2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeAttenuation Attenuation2AT2 { get; set; }
Public Property Attenuation2AT2 As Pcm1680TypeAttenuation
    Get
    Set
public:
property Pcm1680TypeAttenuation Attenuation2AT2 {
    Pcm1680TypeAttenuation get ();
    void set (Pcm1680TypeAttenuation value);
}
member Attenuation2AT2 : Pcm1680TypeAttenuation with get, set

Property Value

Type: Pcm1680TypeAttenuation
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.Attenuation3AT3 Property

IRD

Pcm1680Attenuation3AT3 Property

Attenuation3: AT3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeAttenuation Attenuation3AT3 { get; set; }
Public Property Attenuation3AT3 As Pcm1680TypeAttenuation
    Get
    Set
public:
property Pcm1680TypeAttenuation Attenuation3AT3 {
    Pcm1680TypeAttenuation get ();
    void set (Pcm1680TypeAttenuation value);
}
member Attenuation3AT3 : Pcm1680TypeAttenuation with get, set

Property Value

Type: Pcm1680TypeAttenuation
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.Attenuation4AT4 Property

IRD

Pcm1680Attenuation4AT4 Property

Attenuation4: AT4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeAttenuation Attenuation4AT4 { get; set; }
Public Property Attenuation4AT4 As Pcm1680TypeAttenuation
    Get
    Set
public:
property Pcm1680TypeAttenuation Attenuation4AT4 {
    Pcm1680TypeAttenuation get ();
    void set (Pcm1680TypeAttenuation value);
}
member Attenuation4AT4 : Pcm1680TypeAttenuation with get, set

Property Value

Type: Pcm1680TypeAttenuation
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.Attenuation5AT5 Property

IRD

Pcm1680Attenuation5AT5 Property

Attenuation5: AT5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeAttenuation Attenuation5AT5 { get; set; }
Public Property Attenuation5AT5 As Pcm1680TypeAttenuation
    Get
    Set
public:
property Pcm1680TypeAttenuation Attenuation5AT5 {
    Pcm1680TypeAttenuation get ();
    void set (Pcm1680TypeAttenuation value);
}
member Attenuation5AT5 : Pcm1680TypeAttenuation with get, set

Property Value

Type: Pcm1680TypeAttenuation
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.Attenuation6AT6 Property

IRD

Pcm1680Attenuation6AT6 Property

Attenuation6: AT6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeAttenuation Attenuation6AT6 { get; set; }
Public Property Attenuation6AT6 As Pcm1680TypeAttenuation
    Get
    Set
public:
property Pcm1680TypeAttenuation Attenuation6AT6 {
    Pcm1680TypeAttenuation get ();
    void set (Pcm1680TypeAttenuation value);
}
member Attenuation6AT6 : Pcm1680TypeAttenuation with get, set

Property Value

Type: Pcm1680TypeAttenuation
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.Attenuation7AT7 Property

IRD

Pcm1680Attenuation7AT7 Property

Attenuation7: AT7

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeAttenuation Attenuation7AT7 { get; set; }
Public Property Attenuation7AT7 As Pcm1680TypeAttenuation
    Get
    Set
public:
property Pcm1680TypeAttenuation Attenuation7AT7 {
    Pcm1680TypeAttenuation get ();
    void set (Pcm1680TypeAttenuation value);
}
member Attenuation7AT7 : Pcm1680TypeAttenuation with get, set

Property Value

Type: Pcm1680TypeAttenuation
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.Attenuation8AT8 Property

IRD

Pcm1680Attenuation8AT8 Property

Attenuation8: AT8

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeAttenuation Attenuation8AT8 { get; set; }
Public Property Attenuation8AT8 As Pcm1680TypeAttenuation
    Get
    Set
public:
property Pcm1680TypeAttenuation Attenuation8AT8 {
    Pcm1680TypeAttenuation get ();
    void set (Pcm1680TypeAttenuation value);
}
member Attenuation8AT8 : Pcm1680TypeAttenuation with get, set

Property Value

Type: Pcm1680TypeAttenuation
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.AutoFlush Property

IRD

Pcm1680AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DACControl1DAC1 Property

IRD

Pcm1680DACControl1DAC1 Property

DAC Control1: DAC1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDacControl1Dac1 DACControl1DAC1 { get; set; }
Public Property DACControl1DAC1 As Pcm1680TypeDacControl1Dac1
    Get
    Set
public:
property Pcm1680TypeDacControl1Dac1 DACControl1DAC1 {
    Pcm1680TypeDacControl1Dac1 get ();
    void set (Pcm1680TypeDacControl1Dac1 value);
}
member DACControl1DAC1 : Pcm1680TypeDacControl1Dac1 with get, set

Property Value

Type: Pcm1680TypeDacControl1Dac1
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DACControl1DAC2 Property

IRD

Pcm1680DACControl1DAC2 Property

DAC Control1: DAC2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDacControl1Dac2 DACControl1DAC2 { get; set; }
Public Property DACControl1DAC2 As Pcm1680TypeDacControl1Dac2
    Get
    Set
public:
property Pcm1680TypeDacControl1Dac2 DACControl1DAC2 {
    Pcm1680TypeDacControl1Dac2 get ();
    void set (Pcm1680TypeDacControl1Dac2 value);
}
member DACControl1DAC2 : Pcm1680TypeDacControl1Dac2 with get, set

Property Value

Type: Pcm1680TypeDacControl1Dac2
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DACControl1DAC3 Property

IRD

Pcm1680DACControl1DAC3 Property

DAC Control1: DAC3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDacControl1Dac3 DACControl1DAC3 { get; set; }
Public Property DACControl1DAC3 As Pcm1680TypeDacControl1Dac3
    Get
    Set
public:
property Pcm1680TypeDacControl1Dac3 DACControl1DAC3 {
    Pcm1680TypeDacControl1Dac3 get ();
    void set (Pcm1680TypeDacControl1Dac3 value);
}
member DACControl1DAC3 : Pcm1680TypeDacControl1Dac3 with get, set

Property Value

Type: Pcm1680TypeDacControl1Dac3
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DACControl1DAC4 Property

IRD

Pcm1680DACControl1DAC4 Property

DAC Control1: DAC4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDacControl1Dac4 DACControl1DAC4 { get; set; }
Public Property DACControl1DAC4 As Pcm1680TypeDacControl1Dac4
    Get
    Set
public:
property Pcm1680TypeDacControl1Dac4 DACControl1DAC4 {
    Pcm1680TypeDacControl1Dac4 get ();
    void set (Pcm1680TypeDacControl1Dac4 value);
}
member DACControl1DAC4 : Pcm1680TypeDacControl1Dac4 with get, set

Property Value

Type: Pcm1680TypeDacControl1Dac4
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DACControl1DAC5 Property

IRD

Pcm1680DACControl1DAC5 Property

DAC Control1: DAC5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDacControl1Dac5 DACControl1DAC5 { get; set; }
Public Property DACControl1DAC5 As Pcm1680TypeDacControl1Dac5
    Get
    Set
public:
property Pcm1680TypeDacControl1Dac5 DACControl1DAC5 {
    Pcm1680TypeDacControl1Dac5 get ();
    void set (Pcm1680TypeDacControl1Dac5 value);
}
member DACControl1DAC5 : Pcm1680TypeDacControl1Dac5 with get, set

Property Value

Type: Pcm1680TypeDacControl1Dac5
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DACControl1DAC6 Property

IRD

Pcm1680DACControl1DAC6 Property

DAC Control1: DAC6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDacControl1Dac6 DACControl1DAC6 { get; set; }
Public Property DACControl1DAC6 As Pcm1680TypeDacControl1Dac6
    Get
    Set
public:
property Pcm1680TypeDacControl1Dac6 DACControl1DAC6 {
    Pcm1680TypeDacControl1Dac6 get ();
    void set (Pcm1680TypeDacControl1Dac6 value);
}
member DACControl1DAC6 : Pcm1680TypeDacControl1Dac6 with get, set

Property Value

Type: Pcm1680TypeDacControl1Dac6
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DACControl2DAC7 Property

IRD

Pcm1680DACControl2DAC7 Property

DAC Control2: DAC7

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDacControl2Dac7 DACControl2DAC7 { get; set; }
Public Property DACControl2DAC7 As Pcm1680TypeDacControl2Dac7
    Get
    Set
public:
property Pcm1680TypeDacControl2Dac7 DACControl2DAC7 {
    Pcm1680TypeDacControl2Dac7 get ();
    void set (Pcm1680TypeDacControl2Dac7 value);
}
member DACControl2DAC7 : Pcm1680TypeDacControl2Dac7 with get, set

Property Value

Type: Pcm1680TypeDacControl2Dac7
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DACControl2DAC8 Property

IRD

Pcm1680DACControl2DAC8 Property

DAC Control2: DAC8

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDacControl2Dac8 DACControl2DAC8 { get; set; }
Public Property DACControl2DAC8 As Pcm1680TypeDacControl2Dac8
    Get
    Set
public:
property Pcm1680TypeDacControl2Dac8 DACControl2DAC8 {
    Pcm1680TypeDacControl2Dac8 get ();
    void set (Pcm1680TypeDacControl2Dac8 value);
}
member DACControl2DAC8 : Pcm1680TypeDacControl2Dac8 with get, set

Property Value

Type: Pcm1680TypeDacControl2Dac8
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DeEmphasisDMC Property

IRD

Pcm1680DeEmphasisDMC Property

De Emphasis: DMC

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDeEmphasisChannel DeEmphasisDMC { get; set; }
Public Property DeEmphasisDMC As Pcm1680TypeDeEmphasisChannel
    Get
    Set
public:
property Pcm1680TypeDeEmphasisChannel DeEmphasisDMC {
    Pcm1680TypeDeEmphasisChannel get ();
    void set (Pcm1680TypeDeEmphasisChannel value);
}
member DeEmphasisDMC : Pcm1680TypeDeEmphasisChannel with get, set

Property Value

Type: Pcm1680TypeDeEmphasisChannel
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DeEmphasisDMF Property

IRD

Pcm1680DeEmphasisDMF Property

De Emphasis: DMF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDeEmphasisSampling DeEmphasisDMF { get; set; }
Public Property DeEmphasisDMF As Pcm1680TypeDeEmphasisSampling
    Get
    Set
public:
property Pcm1680TypeDeEmphasisSampling DeEmphasisDMF {
    Pcm1680TypeDeEmphasisSampling get ();
    void set (Pcm1680TypeDeEmphasisSampling value);
}
member DeEmphasisDMF : Pcm1680TypeDeEmphasisSampling with get, set

Property Value

Type: Pcm1680TypeDeEmphasisSampling
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DeEmphasisDREV Property

IRD

Pcm1680DeEmphasisDREV Property

De Emphasis: DREV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDeEmphasisOutput DeEmphasisDREV { get; set; }
Public Property DeEmphasisDREV As Pcm1680TypeDeEmphasisOutput
    Get
    Set
public:
property Pcm1680TypeDeEmphasisOutput DeEmphasisDREV {
    Pcm1680TypeDeEmphasisOutput get ();
    void set (Pcm1680TypeDeEmphasisOutput value);
}
member DeEmphasisDREV : Pcm1680TypeDeEmphasisOutput with get, set

Property Value

Type: Pcm1680TypeDeEmphasisOutput
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DeEmphasisSRST Property

IRD

Pcm1680DeEmphasisSRST Property

De Emphasis: SRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDeEmphasisReset DeEmphasisSRST { get; set; }
Public Property DeEmphasisSRST As Pcm1680TypeDeEmphasisReset
    Get
    Set
public:
property Pcm1680TypeDeEmphasisReset DeEmphasisSRST {
    Pcm1680TypeDeEmphasisReset get ();
    void set (Pcm1680TypeDeEmphasisReset value);
}
member DeEmphasisSRST : Pcm1680TypeDeEmphasisReset with get, set

Property Value

Type: Pcm1680TypeDeEmphasisReset
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DeEmphasisZREV Property

IRD

Pcm1680DeEmphasisZREV Property

De Emphasis: ZREV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDeEmphasisZeroFlag DeEmphasisZREV { get; set; }
Public Property DeEmphasisZREV As Pcm1680TypeDeEmphasisZeroFlag
    Get
    Set
public:
property Pcm1680TypeDeEmphasisZeroFlag DeEmphasisZREV {
    Pcm1680TypeDeEmphasisZeroFlag get ();
    void set (Pcm1680TypeDeEmphasisZeroFlag value);
}
member DeEmphasisZREV : Pcm1680TypeDeEmphasisZeroFlag with get, set

Property Value

Type: Pcm1680TypeDeEmphasisZeroFlag
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DetectStatusZERO1 Property

IRD

Pcm1680DetectStatusZERO1 Property

Detect Status: ZERO1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDetectStatusZero1 DetectStatusZERO1 { get; }
Public ReadOnly Property DetectStatusZERO1 As Pcm1680TypeDetectStatusZero1
    Get
public:
property Pcm1680TypeDetectStatusZero1 DetectStatusZERO1 {
    Pcm1680TypeDetectStatusZero1 get ();
}
member DetectStatusZERO1 : Pcm1680TypeDetectStatusZero1 with get

Property Value

Type: Pcm1680TypeDetectStatusZero1
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DetectStatusZERO2 Property

IRD

Pcm1680DetectStatusZERO2 Property

Detect Status: ZERO2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDetectStatusZero2 DetectStatusZERO2 { get; }
Public ReadOnly Property DetectStatusZERO2 As Pcm1680TypeDetectStatusZero2
    Get
public:
property Pcm1680TypeDetectStatusZero2 DetectStatusZERO2 {
    Pcm1680TypeDetectStatusZero2 get ();
}
member DetectStatusZERO2 : Pcm1680TypeDetectStatusZero2 with get

Property Value

Type: Pcm1680TypeDetectStatusZero2
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DetectStatusZERO3 Property

IRD

Pcm1680DetectStatusZERO3 Property

Detect Status: ZERO3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDetectStatusZero3 DetectStatusZERO3 { get; }
Public ReadOnly Property DetectStatusZERO3 As Pcm1680TypeDetectStatusZero3
    Get
public:
property Pcm1680TypeDetectStatusZero3 DetectStatusZERO3 {
    Pcm1680TypeDetectStatusZero3 get ();
}
member DetectStatusZERO3 : Pcm1680TypeDetectStatusZero3 with get

Property Value

Type: Pcm1680TypeDetectStatusZero3
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DetectStatusZERO4 Property

IRD

Pcm1680DetectStatusZERO4 Property

Detect Status: ZERO4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDetectStatusZero4 DetectStatusZERO4 { get; }
Public ReadOnly Property DetectStatusZERO4 As Pcm1680TypeDetectStatusZero4
    Get
public:
property Pcm1680TypeDetectStatusZero4 DetectStatusZERO4 {
    Pcm1680TypeDetectStatusZero4 get ();
}
member DetectStatusZERO4 : Pcm1680TypeDetectStatusZero4 with get

Property Value

Type: Pcm1680TypeDetectStatusZero4
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DetectStatusZERO5 Property

IRD

Pcm1680DetectStatusZERO5 Property

Detect Status: ZERO5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDetectStatusZero5 DetectStatusZERO5 { get; }
Public ReadOnly Property DetectStatusZERO5 As Pcm1680TypeDetectStatusZero5
    Get
public:
property Pcm1680TypeDetectStatusZero5 DetectStatusZERO5 {
    Pcm1680TypeDetectStatusZero5 get ();
}
member DetectStatusZERO5 : Pcm1680TypeDetectStatusZero5 with get

Property Value

Type: Pcm1680TypeDetectStatusZero5
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DetectStatusZERO6 Property

IRD

Pcm1680DetectStatusZERO6 Property

Detect Status: ZERO6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDetectStatusZero6 DetectStatusZERO6 { get; }
Public ReadOnly Property DetectStatusZERO6 As Pcm1680TypeDetectStatusZero6
    Get
public:
property Pcm1680TypeDetectStatusZero6 DetectStatusZERO6 {
    Pcm1680TypeDetectStatusZero6 get ();
}
member DetectStatusZERO6 : Pcm1680TypeDetectStatusZero6 with get

Property Value

Type: Pcm1680TypeDetectStatusZero6
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DetectStatusZERO7 Property

IRD

Pcm1680DetectStatusZERO7 Property

Detect Status: ZERO7

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDetectStatusZero7 DetectStatusZERO7 { get; }
Public ReadOnly Property DetectStatusZERO7 As Pcm1680TypeDetectStatusZero7
    Get
public:
property Pcm1680TypeDetectStatusZero7 DetectStatusZERO7 {
    Pcm1680TypeDetectStatusZero7 get ();
}
member DetectStatusZERO7 : Pcm1680TypeDetectStatusZero7 with get

Property Value

Type: Pcm1680TypeDetectStatusZero7
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.DetectStatusZERO8 Property

IRD

Pcm1680DetectStatusZERO8 Property

Detect Status: ZERO8

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeDetectStatusZero8 DetectStatusZERO8 { get; }
Public ReadOnly Property DetectStatusZERO8 As Pcm1680TypeDetectStatusZero8
    Get
public:
property Pcm1680TypeDetectStatusZero8 DetectStatusZERO8 {
    Pcm1680TypeDetectStatusZero8 get ();
}
member DetectStatusZERO8 : Pcm1680TypeDetectStatusZero8 with get

Property Value

Type: Pcm1680TypeDetectStatusZero8
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.FilterFLT Property

IRD

Pcm1680FilterFLT Property

Filter: FLT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeFilterRollOff FilterFLT { get; set; }
Public Property FilterFLT As Pcm1680TypeFilterRollOff
    Get
    Set
public:
property Pcm1680TypeFilterRollOff FilterFLT {
    Pcm1680TypeFilterRollOff get ();
    void set (Pcm1680TypeFilterRollOff value);
}
member FilterFLT : Pcm1680TypeFilterRollOff with get, set

Property Value

Type: Pcm1680TypeFilterRollOff
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.FilterFMT Property

IRD

Pcm1680FilterFMT Property

Filter: FMT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeFilterInterfaceFormat FilterFMT { get; set; }
Public Property FilterFMT As Pcm1680TypeFilterInterfaceFormat
    Get
    Set
public:
property Pcm1680TypeFilterInterfaceFormat FilterFMT {
    Pcm1680TypeFilterInterfaceFormat get ();
    void set (Pcm1680TypeFilterInterfaceFormat value);
}
member FilterFMT : Pcm1680TypeFilterInterfaceFormat with get, set

Property Value

Type: Pcm1680TypeFilterInterfaceFormat
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.ModeSelectAZRO Property

IRD

Pcm1680ModeSelectAZRO Property

Mode Select: AZRO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeModeSelectZeroFlag ModeSelectAZRO { get; set; }
Public Property ModeSelectAZRO As Pcm1680TypeModeSelectZeroFlag
    Get
    Set
public:
property Pcm1680TypeModeSelectZeroFlag ModeSelectAZRO {
    Pcm1680TypeModeSelectZeroFlag get ();
    void set (Pcm1680TypeModeSelectZeroFlag value);
}
member ModeSelectAZRO : Pcm1680TypeModeSelectZeroFlag with get, set

Property Value

Type: Pcm1680TypeModeSelectZeroFlag
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.ModeSelectDAMS Property

IRD

Pcm1680ModeSelectDAMS Property

Mode Select: DAMS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeModeSelectDams ModeSelectDAMS { get; set; }
Public Property ModeSelectDAMS As Pcm1680TypeModeSelectDams
    Get
    Set
public:
property Pcm1680TypeModeSelectDams ModeSelectDAMS {
    Pcm1680TypeModeSelectDams get ();
    void set (Pcm1680TypeModeSelectDams value);
}
member ModeSelectDAMS : Pcm1680TypeModeSelectDams with get, set

Property Value

Type: Pcm1680TypeModeSelectDams
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.Mute1MUT1 Property

IRD

Pcm1680Mute1MUT1 Property

Mute1: MUT1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeMute1Vout1 Mute1MUT1 { get; set; }
Public Property Mute1MUT1 As Pcm1680TypeMute1Vout1
    Get
    Set
public:
property Pcm1680TypeMute1Vout1 Mute1MUT1 {
    Pcm1680TypeMute1Vout1 get ();
    void set (Pcm1680TypeMute1Vout1 value);
}
member Mute1MUT1 : Pcm1680TypeMute1Vout1 with get, set

Property Value

Type: Pcm1680TypeMute1Vout1
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.Mute1MUT2 Property

IRD

Pcm1680Mute1MUT2 Property

Mute1: MUT2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeMute1Vout2 Mute1MUT2 { get; set; }
Public Property Mute1MUT2 As Pcm1680TypeMute1Vout2
    Get
    Set
public:
property Pcm1680TypeMute1Vout2 Mute1MUT2 {
    Pcm1680TypeMute1Vout2 get ();
    void set (Pcm1680TypeMute1Vout2 value);
}
member Mute1MUT2 : Pcm1680TypeMute1Vout2 with get, set

Property Value

Type: Pcm1680TypeMute1Vout2
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.Mute1MUT3 Property

IRD

Pcm1680Mute1MUT3 Property

Mute1: MUT3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeMute1Vout3 Mute1MUT3 { get; set; }
Public Property Mute1MUT3 As Pcm1680TypeMute1Vout3
    Get
    Set
public:
property Pcm1680TypeMute1Vout3 Mute1MUT3 {
    Pcm1680TypeMute1Vout3 get ();
    void set (Pcm1680TypeMute1Vout3 value);
}
member Mute1MUT3 : Pcm1680TypeMute1Vout3 with get, set

Property Value

Type: Pcm1680TypeMute1Vout3
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.Mute1MUT4 Property

IRD

Pcm1680Mute1MUT4 Property

Mute1: MUT4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeMute1Vout4 Mute1MUT4 { get; set; }
Public Property Mute1MUT4 As Pcm1680TypeMute1Vout4
    Get
    Set
public:
property Pcm1680TypeMute1Vout4 Mute1MUT4 {
    Pcm1680TypeMute1Vout4 get ();
    void set (Pcm1680TypeMute1Vout4 value);
}
member Mute1MUT4 : Pcm1680TypeMute1Vout4 with get, set

Property Value

Type: Pcm1680TypeMute1Vout4
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.Mute1MUT5 Property

IRD

Pcm1680Mute1MUT5 Property

Mute1: MUT5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeMute1Vout5 Mute1MUT5 { get; set; }
Public Property Mute1MUT5 As Pcm1680TypeMute1Vout5
    Get
    Set
public:
property Pcm1680TypeMute1Vout5 Mute1MUT5 {
    Pcm1680TypeMute1Vout5 get ();
    void set (Pcm1680TypeMute1Vout5 value);
}
member Mute1MUT5 : Pcm1680TypeMute1Vout5 with get, set

Property Value

Type: Pcm1680TypeMute1Vout5
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.Mute1MUT6 Property

IRD

Pcm1680Mute1MUT6 Property

Mute1: MUT6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeMute1Vout6 Mute1MUT6 { get; set; }
Public Property Mute1MUT6 As Pcm1680TypeMute1Vout6
    Get
    Set
public:
property Pcm1680TypeMute1Vout6 Mute1MUT6 {
    Pcm1680TypeMute1Vout6 get ();
    void set (Pcm1680TypeMute1Vout6 value);
}
member Mute1MUT6 : Pcm1680TypeMute1Vout6 with get, set

Property Value

Type: Pcm1680TypeMute1Vout6
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.Mute2MUT7 Property

IRD

Pcm1680Mute2MUT7 Property

Mute2: MUT7

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeMute2Vout7 Mute2MUT7 { get; set; }
Public Property Mute2MUT7 As Pcm1680TypeMute2Vout7
    Get
    Set
public:
property Pcm1680TypeMute2Vout7 Mute2MUT7 {
    Pcm1680TypeMute2Vout7 get ();
    void set (Pcm1680TypeMute2Vout7 value);
}
member Mute2MUT7 : Pcm1680TypeMute2Vout7 with get, set

Property Value

Type: Pcm1680TypeMute2Vout7
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.Mute2MUT8 Property

IRD

Pcm1680Mute2MUT8 Property

Mute2: MUT8

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeMute2Vout8 Mute2MUT8 { get; set; }
Public Property Mute2MUT8 As Pcm1680TypeMute2Vout8
    Get
    Set
public:
property Pcm1680TypeMute2Vout8 Mute2MUT8 {
    Pcm1680TypeMute2Vout8 get ();
    void set (Pcm1680TypeMute2Vout8 value);
}
member Mute2MUT8 : Pcm1680TypeMute2Vout8 with get, set

Property Value

Type: Pcm1680TypeMute2Vout8
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.RateControlOVER Property

IRD

Pcm1680RateControlOVER Property

Rate Control: OVER

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1680TypeRateControlOver RateControlOVER { get; set; }
Public Property RateControlOVER As Pcm1680TypeRateControlOver
    Get
    Set
public:
property Pcm1680TypeRateControlOver RateControlOVER {
    Pcm1680TypeRateControlOver get ();
    void set (Pcm1680TypeRateControlOver value);
}
member RateControlOVER : Pcm1680TypeRateControlOver with get, set

Property Value

Type: Pcm1680TypeRateControlOver
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680 Methods

The Pcm1680 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.Flush Method

IRD

Pcm1680Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcm1680 Class
telos.Ird.TexasInstruments Namespace


Pcm1680.TypeAttenuation Enumeration

IRD

Pcm1680TypeAttenuation Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuation
Public Enumeration TypeAttenuation
public enum class TypeAttenuation
type TypeAttenuation
Members
Member name | Value | Description
Mute | 0 | Mute
Value_630DB | 129 | -63.0 dB
Value_625DB | 130 | -62.5 dB
Value_620DB | 131 | -62.0 dB
Value_615DB | 132 | -61.5 dB
Value_610DB | 133 | -61.0 dB
Value_605DB | 134 | -60.5 dB
Value_600DB | 135 | -60.0 dB
Value_595DB | 136 | -59.5 dB
Value_590DB | 137 | -59.0 dB
Value_585DB | 138 | -58.5 dB
Value_580DB | 139 | -58.0 dB
Value_575DB | 140 | -57.5 dB
Value_570DB | 141 | -57.0 dB
Value_565DB | 142 | -56.5 dB
Value_560DB | 143 | -56.0 dB
Value_555DB | 144 | -55.5 dB
Value_550DB | 145 | -55.0 dB
Value_545DB | 146 | -54.5 dB
Value_540DB | 147 | -54.0 dB
Value_535DB | 148 | -53.5 dB
Value_530DB | 149 | -53.0 dB
Value_525DB | 150 | -52.5 dB
Value_520DB | 151 | -52.0 dB
Value_515DB | 152 | -51.5 dB
Value_510DB | 153 | -51.0 dB
Value_505DB | 154 | -50.5 dB
Value_500DB | 155 | -50.0 dB
Value_495DB | 156 | -49.5 dB
Value_490DB | 157 | -49.0 dB
Value_485DB | 158 | -48.5 dB
Value_480DB | 159 | -48.0 dB
Value_475DB | 160 | -47.5 dB
Value_470DB | 161 | -47.0 dB
Value_465DB | 162 | -46.5 dB
Value_460DB | 163 | -46.0 dB
Value_455DB | 164 | -45.5 dB
Value_450DB | 165 | -45.0 dB
Value_445DB | 166 | -44.5 dB
Value_440DB | 167 | -44.0 dB
Value_435DB | 168 | -43.5 dB
Value_430DB | 169 | -43.0 dB
Value_425DB | 170 | -42.5 dB
Value_420DB | 171 | -42.0 dB
Value_415DB | 172 | -41.5 dB
Value_410DB | 173 | -41.0 dB
Value_405DB | 174 | -40.5 dB
Value_400DB | 175 | -40.0 dB
Value_395DB | 176 | -39.5 dB
Value_390DB | 177 | -39.0 dB
Value_385DB | 178 | -38.5 dB
Value_380DB | 179 | -38.0 dB
Value_375DB | 180 | -37.5 dB
Value_370DB | 181 | -37.0 dB
Value_365DB | 182 | -36.5 dB
Value_360DB | 183 | -36.0 dB
Value_355DB | 184 | -35.5 dB
Value_350DB | 185 | -35.0 dB
Value_345DB | 186 | -34.5 dB
Value_340DB | 187 | -34.0 dB
Value_335DB | 188 | -33.5 dB
Value_330DB | 189 | -33.0 dB
Value_325DB | 190 | -32.5 dB
Value_320DB | 191 | -32.0 dB
Value_315DB | 192 | -31.5 dB
Value_310DB | 193 | -31.0 dB
Value_305DB | 194 | -30.5 dB
Value_300DB | 195 | -30.0 dB
Value_295DB | 196 | -29.5 dB
Value_290DB | 197 | -29.0 dB
Value_285DB | 198 | -28.5 dB
Value_280DB | 199 | -28.0 dB
Value_275DB | 200 | -27.5 dB
Value_270DB | 201 | -27.0 dB
Value_265DB | 202 | -26.5 dB
Value_260DB | 203 | -26.0 dB
Value_255DB | 204 | -25.5 dB
Value_250DB | 205 | -25.0 dB
Value_245DB | 206 | -24.5 dB
Value_240DB | 207 | -24.0 dB
Value_235DB | 208 | -23.5 dB
Value_230DB | 209 | -23.0 dB
Value_225DB | 210 | -22.5 dB
Value_220DB | 211 | -22.0 dB
Value_215DB | 212 | -21.5 dB
Value_210DB | 213 | -21.0 dB
Value_205DB | 214 | -20.5 dB
Value_200DB | 215 | -20.0 dB
Value_195DB | 216 | -19.5 dB
Value_190DB | 217 | -19.0 dB
Value_185DB | 218 | -18.5 dB
Value_180DB | 219 | -18.0 dB
Value_175DB | 220 | -17.5 dB
Value_170DB | 221 | -17.0 dB
Value_165DB | 222 | -16.5 dB
Value_160DB | 223 | -16.0 dB
Value_155DB | 224 | -15.5 dB
Value_150DB | 225 | -15.0 dB
Value_145DB | 226 | -14.5 dB
Value_140DB | 227 | -14.0 dB
Value_135DB | 228 | -13.5 dB
Value_130DB | 229 | -13.0 dB
Value_125DB | 230 | -12.5 dB
Value_120DB | 231 | -12.0 dB
Value_115DB | 232 | -11.5 dB
Value_110DB | 233 | -11.0 dB
Value_105DB | 234 | -10.5 dB
Value_100DB | 235 | -10.0 dB
Value_95DB | 236 | -9.5 dB
Value_90DB | 237 | -9.0 dB
Value_85DB | 238 | -8.5 dB
Value_80DB | 239 | -8.0 dB
Value_75DB | 240 | -7.5 dB
Value_70DB | 241 | -7.0 dB
Value_65DB | 242 | -6.5 dB
Value_60DB | 243 | -6.0 dB
Value_55DB | 244 | -5.5 dB
Value_50DB | 245 | -5.0 dB
Value_45DB | 246 | -4.5 dB
Value_40DB | 247 | -4.0 dB
Value_35DB | 248 | -3.5 dB
Value_30DB | 249 | -3.0 dB
Value_25DB | 250 | -2.5 dB
Value_20DB | 251 | -2.0 dB
Value_15DB | 252 | -1.5 dB
Value_10DB | 253 | -1.0 dB
Value_05DB | 254 | -0.5 dB
Value_00DB | 255 | 0.0 dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDacControl1Dac1 Enumeration

IRD

Pcm1680TypeDacControl1Dac1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControl1Dac1
Public Enumeration TypeDacControl1Dac1
public enum class TypeDacControl1Dac1
type TypeDacControl1Dac1
Members
Member name | Value | Description
DAC1OperationEnabled | 0 | DAC1: Operation Enabled
DAC1OperationDisabled | 1 | DAC1: Operation Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDacControl1Dac2 Enumeration

IRD

Pcm1680TypeDacControl1Dac2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControl1Dac2
Public Enumeration TypeDacControl1Dac2
public enum class TypeDacControl1Dac2
type TypeDacControl1Dac2
Members
Member name | Value | Description
DAC2OperationEnabled | 0 | DAC2: Operation Enabled
DAC2OperationDisabled | 1 | DAC2: Operation Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDacControl1Dac3 Enumeration

IRD

Pcm1680TypeDacControl1Dac3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControl1Dac3
Public Enumeration TypeDacControl1Dac3
public enum class TypeDacControl1Dac3
type TypeDacControl1Dac3
Members
Member name | Value | Description
DAC3OperationEnabled | 0 | DAC3: Operation Enabled
DAC3OperationDisabled | 1 | DAC3: Operation Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDacControl1Dac4 Enumeration

IRD

Pcm1680TypeDacControl1Dac4 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControl1Dac4
Public Enumeration TypeDacControl1Dac4
public enum class TypeDacControl1Dac4
type TypeDacControl1Dac4
Members
Member name | Value | Description
DAC4OperationEnabled | 0 | DAC4: Operation Enabled
DAC4OperationDisabled | 1 | DAC4: Operation Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDacControl1Dac5 Enumeration

IRD

Pcm1680TypeDacControl1Dac5 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControl1Dac5
Public Enumeration TypeDacControl1Dac5
public enum class TypeDacControl1Dac5
type TypeDacControl1Dac5
Members
Member name | Value | Description
DAC5OperationEnabled | 0 | DAC5: Operation Enabled
DAC5OperationDisabled | 1 | DAC5: Operation Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDacControl1Dac6 Enumeration

IRD

Pcm1680TypeDacControl1Dac6 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControl1Dac6
Public Enumeration TypeDacControl1Dac6
public enum class TypeDacControl1Dac6
type TypeDacControl1Dac6
Members
Member name | Value | Description
DAC6OperationEnabled | 0 | DAC6: Operation Enabled
DAC6OperationDisabled | 1 | DAC6: Operation Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDacControl2Dac7 Enumeration

IRD

Pcm1680TypeDacControl2Dac7 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControl2Dac7
Public Enumeration TypeDacControl2Dac7
public enum class TypeDacControl2Dac7
type TypeDacControl2Dac7
Members
Member name | Value | Description
DAC7OperationEnabled | 0 | DAC7: Operation Enabled
DAC7OperationDisabled | 1 | DAC7: Operation Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDacControl2Dac8 Enumeration

IRD

Pcm1680TypeDacControl2Dac8 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControl2Dac8
Public Enumeration TypeDacControl2Dac8
public enum class TypeDacControl2Dac8
type TypeDacControl2Dac8
Members
Member name | Value | Description
DAC8OperationEnabled | 0 | DAC8: Operation Enabled
DAC8OperationDisabled | 1 | DAC8: Operation Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDeEmphasisChannel Enumeration

IRD

Pcm1680TypeDeEmphasisChannel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeEmphasisChannel
Public Enumeration TypeDeEmphasisChannel
public enum class TypeDeEmphasisChannel
type TypeDeEmphasisChannel
Members
Member name | Value | Description
DeEmphasisDisabledForAllChannels | 0 | De-Emphasis Disabled For all Channels
DeEmphasisEnabledForAllChannels | 1 | De-Emphasis Enabled For all Channels
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDeEmphasisOutput Enumeration

IRD

Pcm1680TypeDeEmphasisOutput Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeEmphasisOutput
Public Enumeration TypeDeEmphasisOutput
public enum class TypeDeEmphasisOutput
type TypeDeEmphasisOutput
Members
Member name | Value | Description
OutputPhaseNormalOutput | 0 | Output Phase: Normal Output
OutputPhaseInvertedOutput | 1 | Output Phase: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDeEmphasisReset Enumeration

IRD

Pcm1680TypeDeEmphasisReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeEmphasisReset
Public Enumeration TypeDeEmphasisReset
public enum class TypeDeEmphasisReset
type TypeDeEmphasisReset
Members
Member name | Value | Description
SoftResetDisabled | 0 | Soft Reset: Disabled
SoftResetEnabled | 1 | Soft Reset: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDeEmphasisSampling Enumeration

IRD

Pcm1680TypeDeEmphasisSampling Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeEmphasisSampling
Public Enumeration TypeDeEmphasisSampling
public enum class TypeDeEmphasisSampling
type TypeDeEmphasisSampling
Members
Member name | Value | Description
SamplingRate441KHz | 0 | Sampling Rate: 44.1 kHz
SamplingRate48KHz | 1 | Sampling Rate: 48 kHz
SamplingRate32KHz | 2 | Sampling Rate: 32 kHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDeEmphasisZeroFlag Enumeration

IRD

Pcm1680TypeDeEmphasisZeroFlag Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeEmphasisZeroFlag
Public Enumeration TypeDeEmphasisZeroFlag
public enum class TypeDeEmphasisZeroFlag
type TypeDeEmphasisZeroFlag
Members
Member name | Value | Description
ZeroFlagPinsHighAtZeroDetect | 0 | Zero Flag Pins High At Zero Detect
ZeroFlagPinsLowAtZeroDetect | 1 | Zero Flag Pins Low At Zero Detect
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDetectStatusZero1 Enumeration

IRD

Pcm1680TypeDetectStatusZero1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectStatusZero1
Public Enumeration TypeDetectStatusZero1
public enum class TypeDetectStatusZero1
type TypeDetectStatusZero1
Members
Member name | Value | Description
Channel1ZeroStateDetected | 0 | Channel1: Zero State Detected
Channel1ZeroStateNotDetected | 1 | Channel1: Zero State Not Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDetectStatusZero2 Enumeration

IRD

Pcm1680TypeDetectStatusZero2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectStatusZero2
Public Enumeration TypeDetectStatusZero2
public enum class TypeDetectStatusZero2
type TypeDetectStatusZero2
Members
Member name | Value | Description
Channel2ZeroStateDetected | 0 | Channel2: Zero State Detected
Channel2ZeroStateNotDetected | 1 | Channel2: Zero State Not Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDetectStatusZero3 Enumeration

IRD

Pcm1680TypeDetectStatusZero3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectStatusZero3
Public Enumeration TypeDetectStatusZero3
public enum class TypeDetectStatusZero3
type TypeDetectStatusZero3
Members
Member name | Value | Description
Channel3ZeroStateDetected | 0 | Channel3: Zero State Detected
Channel3ZeroStateNotDetected | 1 | Channel3: Zero State Not Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDetectStatusZero4 Enumeration

IRD

Pcm1680TypeDetectStatusZero4 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectStatusZero4
Public Enumeration TypeDetectStatusZero4
public enum class TypeDetectStatusZero4
type TypeDetectStatusZero4
Members
Member name | Value | Description
Channel4ZeroStateDetected | 0 | Channel4: Zero State Detected
Channel4ZeroStateNotDetected | 1 | Channel4: Zero State Not Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDetectStatusZero5 Enumeration

IRD

Pcm1680TypeDetectStatusZero5 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectStatusZero5
Public Enumeration TypeDetectStatusZero5
public enum class TypeDetectStatusZero5
type TypeDetectStatusZero5
Members
Member name | Value | Description
Channel5ZeroStateDetected | 0 | Channel5: Zero State Detected
Channel5ZeroStateNotDetected | 1 | Channel5: Zero State Not Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDetectStatusZero6 Enumeration

IRD

Pcm1680TypeDetectStatusZero6 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectStatusZero6
Public Enumeration TypeDetectStatusZero6
public enum class TypeDetectStatusZero6
type TypeDetectStatusZero6
Members
Member name | Value | Description
Channel6ZeroStateDetected | 0 | Channel6: Zero State Detected
Channel6ZeroStateNotDetected | 1 | Channel6: Zero State Not Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDetectStatusZero7 Enumeration

IRD

Pcm1680TypeDetectStatusZero7 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectStatusZero7
Public Enumeration TypeDetectStatusZero7
public enum class TypeDetectStatusZero7
type TypeDetectStatusZero7
Members
Member name | Value | Description
Channel7ZeroStateDetected | 0 | Channel7: Zero State Detected
Channel7ZeroStateNotDetected | 1 | Channel7: Zero State Not Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeDetectStatusZero8 Enumeration

IRD

Pcm1680TypeDetectStatusZero8 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectStatusZero8
Public Enumeration TypeDetectStatusZero8
public enum class TypeDetectStatusZero8
type TypeDetectStatusZero8
Members
Member name | Value | Description
Channel8ZeroStateDetected | 0 | Channel8: Zero State Detected
Channel8ZeroStateNotDetected | 1 | Channel8: Zero State Not Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeFilterInterfaceFormat Enumeration

IRD

Pcm1680TypeFilterInterfaceFormat Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFilterInterfaceFormat
Public Enumeration TypeFilterInterfaceFormat
public enum class TypeFilterInterfaceFormat
type TypeFilterInterfaceFormat
Members
Member name | Value | Description
AudioDataFormatRightJustifiedFormat24Bit | 0 | Audio Data Format: Right Justified Format, 24 Bit
AudioDataFormatRightJustifiedFormat20Bit | 1 | Audio Data Format: Right Justified Format, 20 Bit
AudioDataFormatRightJustifiedFormat18Bit | 2 | Audio Data Format: Right Justified Format, 18 Bit
AudioDataFormatRightJustifiedFormat16Bit | 3 | Audio Data Format: Right Justified Format, 16 Bit
AudioDataFormatI2SFormat16To24Bit | 4 | Audio Data Format: I2S Format, 16 To 24 Bit
AudioDataFormatLeftJustifiedFormat16To24Bit | 5 | Audio Data Format: Left Justified Format 16 To 24 Bit
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeFilterRollOff Enumeration

IRD

Pcm1680TypeFilterRollOff Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFilterRollOff
Public Enumeration TypeFilterRollOff
public enum class TypeFilterRollOff
type TypeFilterRollOff
Members
Member name | Value | Description
RollOffControlSharpRollOff | 0 | Roll-Off Control: Sharp Roll-Off
RollOffControlSlowRollOff | 1 | Roll-Off Control: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeModeSelectDams Enumeration

IRD

Pcm1680TypeModeSelectDams Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeSelectDams
Public Enumeration TypeModeSelectDams
public enum class TypeModeSelectDams
type TypeModeSelectDams
Members
Member name | Value | Description
AttenuationModeFineStep05DBStepRange063DB | 0 | Attenuation Mode: Fine Step, 0.5 dB/Step, Range 0-63 dB
AttenuationModeWideStep1DBStepRange0100DB | 1 | Attenuation Mode: Wide Step, 1 dB/Step, Range 0-100 dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeModeSelectZeroFlag Enumeration

IRD

Pcm1680TypeModeSelectZeroFlag Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeSelectZeroFlag
Public Enumeration TypeModeSelectZeroFlag
public enum class TypeModeSelectZeroFlag
type TypeModeSelectZeroFlag
Members
Member name | Value | Description
ChannelCombinationZERO1DATA1LCHZERO2DATA1RCH | 0 | Channel Combination: ZERO1 = DATA1 L-CH, ZERO2 = DATA1 R-CH
ChannelCombinationZERO1NAZERO2DATA1DAT4 | 1 | Channel Combination: ZERO1 = N/A, ZERO2 = DATA1-DAT4
ChannelCombinationZERO1DATA4ZERO2DATA1DATA3 | 2 | Channel Combination: ZERO1 = DATA4, ZERO2 = DATA1-DATA3
ChannelCombinationZERO1DATA1ZERO2DATA2DATA4 | 3 | Channel Combination: ZERO1 = DATA1, ZERO2 = DATA2-DATA4
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeMute1Vout1 Enumeration

IRD

Pcm1680TypeMute1Vout1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMute1Vout1
Public Enumeration TypeMute1Vout1
public enum class TypeMute1Vout1
type TypeMute1Vout1
Members
Member name | Value | Description
Vout1MuteDisabled | 0 | Vout1: Mute Disabled
Vout1MuteEnabled | 1 | Vout1: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeMute1Vout2 Enumeration

IRD

Pcm1680TypeMute1Vout2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMute1Vout2
Public Enumeration TypeMute1Vout2
public enum class TypeMute1Vout2
type TypeMute1Vout2
Members
Member name | Value | Description
Vout2MuteDisabled | 0 | Vout2: Mute Disabled
Vout2MuteEnabled | 1 | Vout2: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeMute1Vout3 Enumeration

IRD

Pcm1680TypeMute1Vout3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMute1Vout3
Public Enumeration TypeMute1Vout3
public enum class TypeMute1Vout3
type TypeMute1Vout3
Members
Member name | Value | Description
Vout3MuteDisabled | 0 | Vout3: Mute Disabled
Vout3MuteEnabled | 1 | Vout3: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeMute1Vout4 Enumeration

IRD

Pcm1680TypeMute1Vout4 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMute1Vout4
Public Enumeration TypeMute1Vout4
public enum class TypeMute1Vout4
type TypeMute1Vout4
Members
Member name | Value | Description
Vout4MuteDisabled | 0 | Vout4: Mute Disabled
Vout4MuteEnabled | 1 | Vout4: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeMute1Vout5 Enumeration

IRD

Pcm1680TypeMute1Vout5 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMute1Vout5
Public Enumeration TypeMute1Vout5
public enum class TypeMute1Vout5
type TypeMute1Vout5
Members
Member name | Value | Description
Vout5MuteDisabled | 0 | Vout5: Mute Disabled
Vout5MuteEnabled | 1 | Vout5: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeMute1Vout6 Enumeration

IRD

Pcm1680TypeMute1Vout6 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMute1Vout6
Public Enumeration TypeMute1Vout6
public enum class TypeMute1Vout6
type TypeMute1Vout6
Members
Member name | Value | Description
Vout6MuteDisabled | 0 | Vout6: Mute Disabled
Vout6MuteEnabled | 1 | Vout6: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeMute2Vout7 Enumeration

IRD

Pcm1680TypeMute2Vout7 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMute2Vout7
Public Enumeration TypeMute2Vout7
public enum class TypeMute2Vout7
type TypeMute2Vout7
Members
Member name | Value | Description
Vout7MuteDisabled | 0 | Vout7: Mute Disabled
Vout7MuteEnabled | 1 | Vout7: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeMute2Vout8 Enumeration

IRD

Pcm1680TypeMute2Vout8 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMute2Vout8
Public Enumeration TypeMute2Vout8
public enum class TypeMute2Vout8
type TypeMute2Vout8
Members
Member name | Value | Description
Vout8MuteDisabled | 0 | Vout8: Mute Disabled
Vout8MuteEnabled | 1 | Vout8: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1680.TypeRateControlOver Enumeration

IRD

Pcm1680TypeRateControlOver Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRateControlOver
Public Enumeration TypeRateControlOver
public enum class TypeRateControlOver
type TypeRateControlOver
Members
Member name | Value | Description
DependingOnFs64x32x16xOversampling | 0 | Depending On fs: 64x / 32x / 16x Oversampling
DependingOnFs128x64x32xOversampling | 1 | Depending On fs: 128x / 64x / 32x Oversampling
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1 Class

Texas Instruments: PCM 1681-Q1
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPcm1681Q1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcm1681Q1
Public Class Pcm1681Q1
public ref class Pcm1681Q1
type Pcm1681Q1 =  class end

The Pcm1681Q1 type exposes the following members.

Constructors
 | Name | Description
Public method | Pcm1681Q1 | Constructor
Top
Properties
 | Name | Description
Public property | Attenuation1AT1 | Attenuation1: AT1
Public property | Attenuation2AT2 | Attenuation2: AT2
Public property | Attenuation3AT3 | Attenuation3: AT3
Public property | Attenuation4AT4 | Attenuation4: AT4
Public property | Attenuation5AT5 | Attenuation5: AT5
Public property | Attenuation6AT6 | Attenuation6: AT6
Public property | Attenuation7AT7 | Attenuation7: AT7
Public property | Attenuation8AT8 | Attenuation8: AT8
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DACControl1DAC1 | DAC Control1: DAC1
Public property | DACControl1DAC2 | DAC Control1: DAC2
Public property | DACControl1DAC3 | DAC Control1: DAC3
Public property | DACControl1DAC4 | DAC Control1: DAC4
Public property | DACControl1DAC5 | DAC Control1: DAC5
Public property | DACControl1DAC6 | DAC Control1: DAC6
Public property | DACControl1DAC7 | DAC Control1: DAC7
Public property | DACControl1DAC8 | DAC Control1: DAC8
Public property | DACControl2DAC7 | DAC Control2: DAC7
Public property | DACControl2DAC8 | DAC Control2: DAC8
Public property | DeEmphasisDMC | De Emphasis: DMC
Public property | DeEmphasisDMF | De Emphasis: DMF
Public property | DeEmphasisDREV | De Emphasis: DREV
Public property | DeEmphasisSRST | De Emphasis: SRST
Public property | DeEmphasisZREV | De Emphasis: ZREV
Public property | DetectStatusZERO1 | Detect Status: ZERO1
Public property | DetectStatusZERO2 | Detect Status: ZERO2
Public property | DetectStatusZERO3 | Detect Status: ZERO3
Public property | DetectStatusZERO4 | Detect Status: ZERO4
Public property | DetectStatusZERO5 | Detect Status: ZERO5
Public property | DetectStatusZERO6 | Detect Status: ZERO6
Public property | DetectStatusZERO7 | Detect Status: ZERO7
Public property | DetectStatusZERO8 | Detect Status: ZERO8
Public property | FilterFLT | Filter: FLT
Public property | FilterFMT | Filter: FMT
Public property | ModeSelectAZRO | Mode Select: AZRO
Public property | ModeSelectDAMS | Mode Select: DAMS
Public property | Mute1MUT1 | Mute1: MUT1
Public property | Mute1MUT2 | Mute1: MUT2
Public property | Mute1MUT3 | Mute1: MUT3
Public property | Mute1MUT4 | Mute1: MUT4
Public property | Mute1MUT5 | Mute1: MUT5
Public property | Mute1MUT6 | Mute1: MUT6
Public property | Mute1MUT7 | Mute1: MUT7
Public property | Mute1MUT8 | Mute1: MUT8
Public property | Mute2MUT7 | Mute2: MUT7
Public property | Mute2MUT8 | Mute2: MUT8
Public property | OutputPhaseREV1 | Output Phase: REV1
Public property | OutputPhaseREV2 | Output Phase: REV2
Public property | OutputPhaseREV3 | Output Phase: REV3
Public property | OutputPhaseREV4 | Output Phase: REV4
Public property | OutputPhaseREV5 | Output Phase: REV5
Public property | OutputPhaseREV6 | Output Phase: REV6
Public property | OutputPhaseREV7 | Output Phase: REV7
Public property | OutputPhaseREV8 | Output Phase: REV8
Public property | RateControlFLT1 | Rate Control: FLT1
Public property | RateControlFLT2 | Rate Control: FLT2
Public property | RateControlFLT3 | Rate Control: FLT3
Public property | RateControlFLT4 | Rate Control: FLT4
Public property | RateControlOVER | Rate Control: OVER
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Eight-Channel Audio Digital-to-Analog Converter
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcm1681Q1(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcm1681Q1

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1 Properties

The Pcm1681Q1 type exposes the following members.

Properties
 | Name | Description
Public property | Attenuation1AT1 | Attenuation1: AT1
Public property | Attenuation2AT2 | Attenuation2: AT2
Public property | Attenuation3AT3 | Attenuation3: AT3
Public property | Attenuation4AT4 | Attenuation4: AT4
Public property | Attenuation5AT5 | Attenuation5: AT5
Public property | Attenuation6AT6 | Attenuation6: AT6
Public property | Attenuation7AT7 | Attenuation7: AT7
Public property | Attenuation8AT8 | Attenuation8: AT8
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DACControl1DAC1 | DAC Control1: DAC1
Public property | DACControl1DAC2 | DAC Control1: DAC2
Public property | DACControl1DAC3 | DAC Control1: DAC3
Public property | DACControl1DAC4 | DAC Control1: DAC4
Public property | DACControl1DAC5 | DAC Control1: DAC5
Public property | DACControl1DAC6 | DAC Control1: DAC6
Public property | DACControl1DAC7 | DAC Control1: DAC7
Public property | DACControl1DAC8 | DAC Control1: DAC8
Public property | DACControl2DAC7 | DAC Control2: DAC7
Public property | DACControl2DAC8 | DAC Control2: DAC8
Public property | DeEmphasisDMC | De Emphasis: DMC
Public property | DeEmphasisDMF | De Emphasis: DMF
Public property | DeEmphasisDREV | De Emphasis: DREV
Public property | DeEmphasisSRST | De Emphasis: SRST
Public property | DeEmphasisZREV | De Emphasis: ZREV
Public property | DetectStatusZERO1 | Detect Status: ZERO1
Public property | DetectStatusZERO2 | Detect Status: ZERO2
Public property | DetectStatusZERO3 | Detect Status: ZERO3
Public property | DetectStatusZERO4 | Detect Status: ZERO4
Public property | DetectStatusZERO5 | Detect Status: ZERO5
Public property | DetectStatusZERO6 | Detect Status: ZERO6
Public property | DetectStatusZERO7 | Detect Status: ZERO7
Public property | DetectStatusZERO8 | Detect Status: ZERO8
Public property | FilterFLT | Filter: FLT
Public property | FilterFMT | Filter: FMT
Public property | ModeSelectAZRO | Mode Select: AZRO
Public property | ModeSelectDAMS | Mode Select: DAMS
Public property | Mute1MUT1 | Mute1: MUT1
Public property | Mute1MUT2 | Mute1: MUT2
Public property | Mute1MUT3 | Mute1: MUT3
Public property | Mute1MUT4 | Mute1: MUT4
Public property | Mute1MUT5 | Mute1: MUT5
Public property | Mute1MUT6 | Mute1: MUT6
Public property | Mute1MUT7 | Mute1: MUT7
Public property | Mute1MUT8 | Mute1: MUT8
Public property | Mute2MUT7 | Mute2: MUT7
Public property | Mute2MUT8 | Mute2: MUT8
Public property | OutputPhaseREV1 | Output Phase: REV1
Public property | OutputPhaseREV2 | Output Phase: REV2
Public property | OutputPhaseREV3 | Output Phase: REV3
Public property | OutputPhaseREV4 | Output Phase: REV4
Public property | OutputPhaseREV5 | Output Phase: REV5
Public property | OutputPhaseREV6 | Output Phase: REV6
Public property | OutputPhaseREV7 | Output Phase: REV7
Public property | OutputPhaseREV8 | Output Phase: REV8
Public property | RateControlFLT1 | Rate Control: FLT1
Public property | RateControlFLT2 | Rate Control: FLT2
Public property | RateControlFLT3 | Rate Control: FLT3
Public property | RateControlFLT4 | Rate Control: FLT4
Public property | RateControlOVER | Rate Control: OVER
Top
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Attenuation1AT1 Property

IRD

Pcm1681Q1Attenuation1AT1 Property

Attenuation1: AT1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeAttenuation Attenuation1AT1 { get; set; }
Public Property Attenuation1AT1 As Pcm1681Q1TypeAttenuation
    Get
    Set
public:
property Pcm1681Q1TypeAttenuation Attenuation1AT1 {
    Pcm1681Q1TypeAttenuation get ();
    void set (Pcm1681Q1TypeAttenuation value);
}
member Attenuation1AT1 : Pcm1681Q1TypeAttenuation with get, set

Property Value

Type: Pcm1681Q1TypeAttenuation
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Attenuation2AT2 Property

IRD

Pcm1681Q1Attenuation2AT2 Property

Attenuation2: AT2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeAttenuation Attenuation2AT2 { get; set; }
Public Property Attenuation2AT2 As Pcm1681Q1TypeAttenuation
    Get
    Set
public:
property Pcm1681Q1TypeAttenuation Attenuation2AT2 {
    Pcm1681Q1TypeAttenuation get ();
    void set (Pcm1681Q1TypeAttenuation value);
}
member Attenuation2AT2 : Pcm1681Q1TypeAttenuation with get, set

Property Value

Type: Pcm1681Q1TypeAttenuation
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Attenuation3AT3 Property

IRD

Pcm1681Q1Attenuation3AT3 Property

Attenuation3: AT3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeAttenuation Attenuation3AT3 { get; set; }
Public Property Attenuation3AT3 As Pcm1681Q1TypeAttenuation
    Get
    Set
public:
property Pcm1681Q1TypeAttenuation Attenuation3AT3 {
    Pcm1681Q1TypeAttenuation get ();
    void set (Pcm1681Q1TypeAttenuation value);
}
member Attenuation3AT3 : Pcm1681Q1TypeAttenuation with get, set

Property Value

Type: Pcm1681Q1TypeAttenuation
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Attenuation4AT4 Property

IRD

Pcm1681Q1Attenuation4AT4 Property

Attenuation4: AT4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeAttenuation Attenuation4AT4 { get; set; }
Public Property Attenuation4AT4 As Pcm1681Q1TypeAttenuation
    Get
    Set
public:
property Pcm1681Q1TypeAttenuation Attenuation4AT4 {
    Pcm1681Q1TypeAttenuation get ();
    void set (Pcm1681Q1TypeAttenuation value);
}
member Attenuation4AT4 : Pcm1681Q1TypeAttenuation with get, set

Property Value

Type: Pcm1681Q1TypeAttenuation
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Attenuation5AT5 Property

IRD

Pcm1681Q1Attenuation5AT5 Property

Attenuation5: AT5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeAttenuation Attenuation5AT5 { get; set; }
Public Property Attenuation5AT5 As Pcm1681Q1TypeAttenuation
    Get
    Set
public:
property Pcm1681Q1TypeAttenuation Attenuation5AT5 {
    Pcm1681Q1TypeAttenuation get ();
    void set (Pcm1681Q1TypeAttenuation value);
}
member Attenuation5AT5 : Pcm1681Q1TypeAttenuation with get, set

Property Value

Type: Pcm1681Q1TypeAttenuation
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Attenuation6AT6 Property

IRD

Pcm1681Q1Attenuation6AT6 Property

Attenuation6: AT6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeAttenuation Attenuation6AT6 { get; set; }
Public Property Attenuation6AT6 As Pcm1681Q1TypeAttenuation
    Get
    Set
public:
property Pcm1681Q1TypeAttenuation Attenuation6AT6 {
    Pcm1681Q1TypeAttenuation get ();
    void set (Pcm1681Q1TypeAttenuation value);
}
member Attenuation6AT6 : Pcm1681Q1TypeAttenuation with get, set

Property Value

Type: Pcm1681Q1TypeAttenuation
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Attenuation7AT7 Property

IRD

Pcm1681Q1Attenuation7AT7 Property

Attenuation7: AT7

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeAttenuation Attenuation7AT7 { get; set; }
Public Property Attenuation7AT7 As Pcm1681Q1TypeAttenuation
    Get
    Set
public:
property Pcm1681Q1TypeAttenuation Attenuation7AT7 {
    Pcm1681Q1TypeAttenuation get ();
    void set (Pcm1681Q1TypeAttenuation value);
}
member Attenuation7AT7 : Pcm1681Q1TypeAttenuation with get, set

Property Value

Type: Pcm1681Q1TypeAttenuation
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Attenuation8AT8 Property

IRD

Pcm1681Q1Attenuation8AT8 Property

Attenuation8: AT8

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeAttenuation Attenuation8AT8 { get; set; }
Public Property Attenuation8AT8 As Pcm1681Q1TypeAttenuation
    Get
    Set
public:
property Pcm1681Q1TypeAttenuation Attenuation8AT8 {
    Pcm1681Q1TypeAttenuation get ();
    void set (Pcm1681Q1TypeAttenuation value);
}
member Attenuation8AT8 : Pcm1681Q1TypeAttenuation with get, set

Property Value

Type: Pcm1681Q1TypeAttenuation
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.AutoFlush Property

IRD

Pcm1681Q1AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DACControl1DAC1 Property

IRD

Pcm1681Q1DACControl1DAC1 Property

DAC Control1: DAC1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDacControl1Dac1 DACControl1DAC1 { get; set; }
Public Property DACControl1DAC1 As Pcm1681Q1TypeDacControl1Dac1
    Get
    Set
public:
property Pcm1681Q1TypeDacControl1Dac1 DACControl1DAC1 {
    Pcm1681Q1TypeDacControl1Dac1 get ();
    void set (Pcm1681Q1TypeDacControl1Dac1 value);
}
member DACControl1DAC1 : Pcm1681Q1TypeDacControl1Dac1 with get, set

Property Value

Type: Pcm1681Q1TypeDacControl1Dac1
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DACControl1DAC2 Property

IRD

Pcm1681Q1DACControl1DAC2 Property

DAC Control1: DAC2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDacControl1Dac2 DACControl1DAC2 { get; set; }
Public Property DACControl1DAC2 As Pcm1681Q1TypeDacControl1Dac2
    Get
    Set
public:
property Pcm1681Q1TypeDacControl1Dac2 DACControl1DAC2 {
    Pcm1681Q1TypeDacControl1Dac2 get ();
    void set (Pcm1681Q1TypeDacControl1Dac2 value);
}
member DACControl1DAC2 : Pcm1681Q1TypeDacControl1Dac2 with get, set

Property Value

Type: Pcm1681Q1TypeDacControl1Dac2
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DACControl1DAC3 Property

IRD

Pcm1681Q1DACControl1DAC3 Property

DAC Control1: DAC3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDacControl1Dac3 DACControl1DAC3 { get; set; }
Public Property DACControl1DAC3 As Pcm1681Q1TypeDacControl1Dac3
    Get
    Set
public:
property Pcm1681Q1TypeDacControl1Dac3 DACControl1DAC3 {
    Pcm1681Q1TypeDacControl1Dac3 get ();
    void set (Pcm1681Q1TypeDacControl1Dac3 value);
}
member DACControl1DAC3 : Pcm1681Q1TypeDacControl1Dac3 with get, set

Property Value

Type: Pcm1681Q1TypeDacControl1Dac3
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DACControl1DAC4 Property

IRD

Pcm1681Q1DACControl1DAC4 Property

DAC Control1: DAC4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDacControl1Dac4 DACControl1DAC4 { get; set; }
Public Property DACControl1DAC4 As Pcm1681Q1TypeDacControl1Dac4
    Get
    Set
public:
property Pcm1681Q1TypeDacControl1Dac4 DACControl1DAC4 {
    Pcm1681Q1TypeDacControl1Dac4 get ();
    void set (Pcm1681Q1TypeDacControl1Dac4 value);
}
member DACControl1DAC4 : Pcm1681Q1TypeDacControl1Dac4 with get, set

Property Value

Type: Pcm1681Q1TypeDacControl1Dac4
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DACControl1DAC5 Property

IRD

Pcm1681Q1DACControl1DAC5 Property

DAC Control1: DAC5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDacControl1Dac5 DACControl1DAC5 { get; set; }
Public Property DACControl1DAC5 As Pcm1681Q1TypeDacControl1Dac5
    Get
    Set
public:
property Pcm1681Q1TypeDacControl1Dac5 DACControl1DAC5 {
    Pcm1681Q1TypeDacControl1Dac5 get ();
    void set (Pcm1681Q1TypeDacControl1Dac5 value);
}
member DACControl1DAC5 : Pcm1681Q1TypeDacControl1Dac5 with get, set

Property Value

Type: Pcm1681Q1TypeDacControl1Dac5
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DACControl1DAC6 Property

IRD

Pcm1681Q1DACControl1DAC6 Property

DAC Control1: DAC6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDacControl1Dac6 DACControl1DAC6 { get; set; }
Public Property DACControl1DAC6 As Pcm1681Q1TypeDacControl1Dac6
    Get
    Set
public:
property Pcm1681Q1TypeDacControl1Dac6 DACControl1DAC6 {
    Pcm1681Q1TypeDacControl1Dac6 get ();
    void set (Pcm1681Q1TypeDacControl1Dac6 value);
}
member DACControl1DAC6 : Pcm1681Q1TypeDacControl1Dac6 with get, set

Property Value

Type: Pcm1681Q1TypeDacControl1Dac6
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DACControl1DAC7 Property

IRD

Pcm1681Q1DACControl1DAC7 Property

DAC Control1: DAC7

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDacControl1Dac7 DACControl1DAC7 { get; set; }
Public Property DACControl1DAC7 As Pcm1681Q1TypeDacControl1Dac7
    Get
    Set
public:
property Pcm1681Q1TypeDacControl1Dac7 DACControl1DAC7 {
    Pcm1681Q1TypeDacControl1Dac7 get ();
    void set (Pcm1681Q1TypeDacControl1Dac7 value);
}
member DACControl1DAC7 : Pcm1681Q1TypeDacControl1Dac7 with get, set

Property Value

Type: Pcm1681Q1TypeDacControl1Dac7
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DACControl1DAC8 Property

IRD

Pcm1681Q1DACControl1DAC8 Property

DAC Control1: DAC8

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDacControl1Dac8 DACControl1DAC8 { get; set; }
Public Property DACControl1DAC8 As Pcm1681Q1TypeDacControl1Dac8
    Get
    Set
public:
property Pcm1681Q1TypeDacControl1Dac8 DACControl1DAC8 {
    Pcm1681Q1TypeDacControl1Dac8 get ();
    void set (Pcm1681Q1TypeDacControl1Dac8 value);
}
member DACControl1DAC8 : Pcm1681Q1TypeDacControl1Dac8 with get, set

Property Value

Type: Pcm1681Q1TypeDacControl1Dac8
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DACControl2DAC7 Property

IRD

Pcm1681Q1DACControl2DAC7 Property

DAC Control2: DAC7

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDacControl2Dac7 DACControl2DAC7 { get; set; }
Public Property DACControl2DAC7 As Pcm1681Q1TypeDacControl2Dac7
    Get
    Set
public:
property Pcm1681Q1TypeDacControl2Dac7 DACControl2DAC7 {
    Pcm1681Q1TypeDacControl2Dac7 get ();
    void set (Pcm1681Q1TypeDacControl2Dac7 value);
}
member DACControl2DAC7 : Pcm1681Q1TypeDacControl2Dac7 with get, set

Property Value

Type: Pcm1681Q1TypeDacControl2Dac7
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DACControl2DAC8 Property

IRD

Pcm1681Q1DACControl2DAC8 Property

DAC Control2: DAC8

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDacControl2Dac8 DACControl2DAC8 { get; set; }
Public Property DACControl2DAC8 As Pcm1681Q1TypeDacControl2Dac8
    Get
    Set
public:
property Pcm1681Q1TypeDacControl2Dac8 DACControl2DAC8 {
    Pcm1681Q1TypeDacControl2Dac8 get ();
    void set (Pcm1681Q1TypeDacControl2Dac8 value);
}
member DACControl2DAC8 : Pcm1681Q1TypeDacControl2Dac8 with get, set

Property Value

Type: Pcm1681Q1TypeDacControl2Dac8
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DeEmphasisDMC Property

IRD

Pcm1681Q1DeEmphasisDMC Property

De Emphasis: DMC

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDeEmphasisChannel DeEmphasisDMC { get; set; }
Public Property DeEmphasisDMC As Pcm1681Q1TypeDeEmphasisChannel
    Get
    Set
public:
property Pcm1681Q1TypeDeEmphasisChannel DeEmphasisDMC {
    Pcm1681Q1TypeDeEmphasisChannel get ();
    void set (Pcm1681Q1TypeDeEmphasisChannel value);
}
member DeEmphasisDMC : Pcm1681Q1TypeDeEmphasisChannel with get, set

Property Value

Type: Pcm1681Q1TypeDeEmphasisChannel
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DeEmphasisDMF Property

IRD

Pcm1681Q1DeEmphasisDMF Property

De Emphasis: DMF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDeEmphasisSampling DeEmphasisDMF { get; set; }
Public Property DeEmphasisDMF As Pcm1681Q1TypeDeEmphasisSampling
    Get
    Set
public:
property Pcm1681Q1TypeDeEmphasisSampling DeEmphasisDMF {
    Pcm1681Q1TypeDeEmphasisSampling get ();
    void set (Pcm1681Q1TypeDeEmphasisSampling value);
}
member DeEmphasisDMF : Pcm1681Q1TypeDeEmphasisSampling with get, set

Property Value

Type: Pcm1681Q1TypeDeEmphasisSampling
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DeEmphasisDREV Property

IRD

Pcm1681Q1DeEmphasisDREV Property

De Emphasis: DREV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDeEmphasisOutput DeEmphasisDREV { get; set; }
Public Property DeEmphasisDREV As Pcm1681Q1TypeDeEmphasisOutput
    Get
    Set
public:
property Pcm1681Q1TypeDeEmphasisOutput DeEmphasisDREV {
    Pcm1681Q1TypeDeEmphasisOutput get ();
    void set (Pcm1681Q1TypeDeEmphasisOutput value);
}
member DeEmphasisDREV : Pcm1681Q1TypeDeEmphasisOutput with get, set

Property Value

Type: Pcm1681Q1TypeDeEmphasisOutput
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DeEmphasisSRST Property

IRD

Pcm1681Q1DeEmphasisSRST Property

De Emphasis: SRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDeEmphasisReset DeEmphasisSRST { get; set; }
Public Property DeEmphasisSRST As Pcm1681Q1TypeDeEmphasisReset
    Get
    Set
public:
property Pcm1681Q1TypeDeEmphasisReset DeEmphasisSRST {
    Pcm1681Q1TypeDeEmphasisReset get ();
    void set (Pcm1681Q1TypeDeEmphasisReset value);
}
member DeEmphasisSRST : Pcm1681Q1TypeDeEmphasisReset with get, set

Property Value

Type: Pcm1681Q1TypeDeEmphasisReset
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DeEmphasisZREV Property

IRD

Pcm1681Q1DeEmphasisZREV Property

De Emphasis: ZREV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDeEmphasisZeroFlag DeEmphasisZREV { get; set; }
Public Property DeEmphasisZREV As Pcm1681Q1TypeDeEmphasisZeroFlag
    Get
    Set
public:
property Pcm1681Q1TypeDeEmphasisZeroFlag DeEmphasisZREV {
    Pcm1681Q1TypeDeEmphasisZeroFlag get ();
    void set (Pcm1681Q1TypeDeEmphasisZeroFlag value);
}
member DeEmphasisZREV : Pcm1681Q1TypeDeEmphasisZeroFlag with get, set

Property Value

Type: Pcm1681Q1TypeDeEmphasisZeroFlag
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DetectStatusZERO1 Property

IRD

Pcm1681Q1DetectStatusZERO1 Property

Detect Status: ZERO1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDetectStatusZero1 DetectStatusZERO1 { get; }
Public ReadOnly Property DetectStatusZERO1 As Pcm1681Q1TypeDetectStatusZero1
    Get
public:
property Pcm1681Q1TypeDetectStatusZero1 DetectStatusZERO1 {
    Pcm1681Q1TypeDetectStatusZero1 get ();
}
member DetectStatusZERO1 : Pcm1681Q1TypeDetectStatusZero1 with get

Property Value

Type: Pcm1681Q1TypeDetectStatusZero1
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DetectStatusZERO2 Property

IRD

Pcm1681Q1DetectStatusZERO2 Property

Detect Status: ZERO2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDetectStatusZero2 DetectStatusZERO2 { get; }
Public ReadOnly Property DetectStatusZERO2 As Pcm1681Q1TypeDetectStatusZero2
    Get
public:
property Pcm1681Q1TypeDetectStatusZero2 DetectStatusZERO2 {
    Pcm1681Q1TypeDetectStatusZero2 get ();
}
member DetectStatusZERO2 : Pcm1681Q1TypeDetectStatusZero2 with get

Property Value

Type: Pcm1681Q1TypeDetectStatusZero2
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DetectStatusZERO3 Property

IRD

Pcm1681Q1DetectStatusZERO3 Property

Detect Status: ZERO3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDetectStatusZero3 DetectStatusZERO3 { get; }
Public ReadOnly Property DetectStatusZERO3 As Pcm1681Q1TypeDetectStatusZero3
    Get
public:
property Pcm1681Q1TypeDetectStatusZero3 DetectStatusZERO3 {
    Pcm1681Q1TypeDetectStatusZero3 get ();
}
member DetectStatusZERO3 : Pcm1681Q1TypeDetectStatusZero3 with get

Property Value

Type: Pcm1681Q1TypeDetectStatusZero3
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DetectStatusZERO4 Property

IRD

Pcm1681Q1DetectStatusZERO4 Property

Detect Status: ZERO4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDetectStatusZero4 DetectStatusZERO4 { get; }
Public ReadOnly Property DetectStatusZERO4 As Pcm1681Q1TypeDetectStatusZero4
    Get
public:
property Pcm1681Q1TypeDetectStatusZero4 DetectStatusZERO4 {
    Pcm1681Q1TypeDetectStatusZero4 get ();
}
member DetectStatusZERO4 : Pcm1681Q1TypeDetectStatusZero4 with get

Property Value

Type: Pcm1681Q1TypeDetectStatusZero4
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DetectStatusZERO5 Property

IRD

Pcm1681Q1DetectStatusZERO5 Property

Detect Status: ZERO5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDetectStatusZero5 DetectStatusZERO5 { get; }
Public ReadOnly Property DetectStatusZERO5 As Pcm1681Q1TypeDetectStatusZero5
    Get
public:
property Pcm1681Q1TypeDetectStatusZero5 DetectStatusZERO5 {
    Pcm1681Q1TypeDetectStatusZero5 get ();
}
member DetectStatusZERO5 : Pcm1681Q1TypeDetectStatusZero5 with get

Property Value

Type: Pcm1681Q1TypeDetectStatusZero5
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DetectStatusZERO6 Property

IRD

Pcm1681Q1DetectStatusZERO6 Property

Detect Status: ZERO6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDetectStatusZero6 DetectStatusZERO6 { get; }
Public ReadOnly Property DetectStatusZERO6 As Pcm1681Q1TypeDetectStatusZero6
    Get
public:
property Pcm1681Q1TypeDetectStatusZero6 DetectStatusZERO6 {
    Pcm1681Q1TypeDetectStatusZero6 get ();
}
member DetectStatusZERO6 : Pcm1681Q1TypeDetectStatusZero6 with get

Property Value

Type: Pcm1681Q1TypeDetectStatusZero6
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DetectStatusZERO7 Property

IRD

Pcm1681Q1DetectStatusZERO7 Property

Detect Status: ZERO7

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDetectStatusZero7 DetectStatusZERO7 { get; }
Public ReadOnly Property DetectStatusZERO7 As Pcm1681Q1TypeDetectStatusZero7
    Get
public:
property Pcm1681Q1TypeDetectStatusZero7 DetectStatusZERO7 {
    Pcm1681Q1TypeDetectStatusZero7 get ();
}
member DetectStatusZERO7 : Pcm1681Q1TypeDetectStatusZero7 with get

Property Value

Type: Pcm1681Q1TypeDetectStatusZero7
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.DetectStatusZERO8 Property

IRD

Pcm1681Q1DetectStatusZERO8 Property

Detect Status: ZERO8

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeDetectStatusZero8 DetectStatusZERO8 { get; }
Public ReadOnly Property DetectStatusZERO8 As Pcm1681Q1TypeDetectStatusZero8
    Get
public:
property Pcm1681Q1TypeDetectStatusZero8 DetectStatusZERO8 {
    Pcm1681Q1TypeDetectStatusZero8 get ();
}
member DetectStatusZERO8 : Pcm1681Q1TypeDetectStatusZero8 with get

Property Value

Type: Pcm1681Q1TypeDetectStatusZero8
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.FilterFLT Property

IRD

Pcm1681Q1FilterFLT Property

Filter: FLT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeFilterRollOff FilterFLT { get; set; }
Public Property FilterFLT As Pcm1681Q1TypeFilterRollOff
    Get
    Set
public:
property Pcm1681Q1TypeFilterRollOff FilterFLT {
    Pcm1681Q1TypeFilterRollOff get ();
    void set (Pcm1681Q1TypeFilterRollOff value);
}
member FilterFLT : Pcm1681Q1TypeFilterRollOff with get, set

Property Value

Type: Pcm1681Q1TypeFilterRollOff
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.FilterFMT Property

IRD

Pcm1681Q1FilterFMT Property

Filter: FMT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeFilterInterfaceFormat FilterFMT { get; set; }
Public Property FilterFMT As Pcm1681Q1TypeFilterInterfaceFormat
    Get
    Set
public:
property Pcm1681Q1TypeFilterInterfaceFormat FilterFMT {
    Pcm1681Q1TypeFilterInterfaceFormat get ();
    void set (Pcm1681Q1TypeFilterInterfaceFormat value);
}
member FilterFMT : Pcm1681Q1TypeFilterInterfaceFormat with get, set

Property Value

Type: Pcm1681Q1TypeFilterInterfaceFormat
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.ModeSelectAZRO Property

IRD

Pcm1681Q1ModeSelectAZRO Property

Mode Select: AZRO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeModeSelectZeroFlag ModeSelectAZRO { get; set; }
Public Property ModeSelectAZRO As Pcm1681Q1TypeModeSelectZeroFlag
    Get
    Set
public:
property Pcm1681Q1TypeModeSelectZeroFlag ModeSelectAZRO {
    Pcm1681Q1TypeModeSelectZeroFlag get ();
    void set (Pcm1681Q1TypeModeSelectZeroFlag value);
}
member ModeSelectAZRO : Pcm1681Q1TypeModeSelectZeroFlag with get, set

Property Value

Type: Pcm1681Q1TypeModeSelectZeroFlag
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.ModeSelectDAMS Property

IRD

Pcm1681Q1ModeSelectDAMS Property

Mode Select: DAMS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeModeSelectDams ModeSelectDAMS { get; set; }
Public Property ModeSelectDAMS As Pcm1681Q1TypeModeSelectDams
    Get
    Set
public:
property Pcm1681Q1TypeModeSelectDams ModeSelectDAMS {
    Pcm1681Q1TypeModeSelectDams get ();
    void set (Pcm1681Q1TypeModeSelectDams value);
}
member ModeSelectDAMS : Pcm1681Q1TypeModeSelectDams with get, set

Property Value

Type: Pcm1681Q1TypeModeSelectDams
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Mute1MUT1 Property

IRD

Pcm1681Q1Mute1MUT1 Property

Mute1: MUT1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeMute1Vout1 Mute1MUT1 { get; set; }
Public Property Mute1MUT1 As Pcm1681Q1TypeMute1Vout1
    Get
    Set
public:
property Pcm1681Q1TypeMute1Vout1 Mute1MUT1 {
    Pcm1681Q1TypeMute1Vout1 get ();
    void set (Pcm1681Q1TypeMute1Vout1 value);
}
member Mute1MUT1 : Pcm1681Q1TypeMute1Vout1 with get, set

Property Value

Type: Pcm1681Q1TypeMute1Vout1
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Mute1MUT2 Property

IRD

Pcm1681Q1Mute1MUT2 Property

Mute1: MUT2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeMute1Vout2 Mute1MUT2 { get; set; }
Public Property Mute1MUT2 As Pcm1681Q1TypeMute1Vout2
    Get
    Set
public:
property Pcm1681Q1TypeMute1Vout2 Mute1MUT2 {
    Pcm1681Q1TypeMute1Vout2 get ();
    void set (Pcm1681Q1TypeMute1Vout2 value);
}
member Mute1MUT2 : Pcm1681Q1TypeMute1Vout2 with get, set

Property Value

Type: Pcm1681Q1TypeMute1Vout2
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Mute1MUT3 Property

IRD

Pcm1681Q1Mute1MUT3 Property

Mute1: MUT3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeMute1Vout3 Mute1MUT3 { get; set; }
Public Property Mute1MUT3 As Pcm1681Q1TypeMute1Vout3
    Get
    Set
public:
property Pcm1681Q1TypeMute1Vout3 Mute1MUT3 {
    Pcm1681Q1TypeMute1Vout3 get ();
    void set (Pcm1681Q1TypeMute1Vout3 value);
}
member Mute1MUT3 : Pcm1681Q1TypeMute1Vout3 with get, set

Property Value

Type: Pcm1681Q1TypeMute1Vout3
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Mute1MUT4 Property

IRD

Pcm1681Q1Mute1MUT4 Property

Mute1: MUT4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeMute1Vout4 Mute1MUT4 { get; set; }
Public Property Mute1MUT4 As Pcm1681Q1TypeMute1Vout4
    Get
    Set
public:
property Pcm1681Q1TypeMute1Vout4 Mute1MUT4 {
    Pcm1681Q1TypeMute1Vout4 get ();
    void set (Pcm1681Q1TypeMute1Vout4 value);
}
member Mute1MUT4 : Pcm1681Q1TypeMute1Vout4 with get, set

Property Value

Type: Pcm1681Q1TypeMute1Vout4
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Mute1MUT5 Property

IRD

Pcm1681Q1Mute1MUT5 Property

Mute1: MUT5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeMute1Vout5 Mute1MUT5 { get; set; }
Public Property Mute1MUT5 As Pcm1681Q1TypeMute1Vout5
    Get
    Set
public:
property Pcm1681Q1TypeMute1Vout5 Mute1MUT5 {
    Pcm1681Q1TypeMute1Vout5 get ();
    void set (Pcm1681Q1TypeMute1Vout5 value);
}
member Mute1MUT5 : Pcm1681Q1TypeMute1Vout5 with get, set

Property Value

Type: Pcm1681Q1TypeMute1Vout5
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Mute1MUT6 Property

IRD

Pcm1681Q1Mute1MUT6 Property

Mute1: MUT6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeMute1Vout6 Mute1MUT6 { get; set; }
Public Property Mute1MUT6 As Pcm1681Q1TypeMute1Vout6
    Get
    Set
public:
property Pcm1681Q1TypeMute1Vout6 Mute1MUT6 {
    Pcm1681Q1TypeMute1Vout6 get ();
    void set (Pcm1681Q1TypeMute1Vout6 value);
}
member Mute1MUT6 : Pcm1681Q1TypeMute1Vout6 with get, set

Property Value

Type: Pcm1681Q1TypeMute1Vout6
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Mute1MUT7 Property

IRD

Pcm1681Q1Mute1MUT7 Property

Mute1: MUT7

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeMute1Vout7 Mute1MUT7 { get; set; }
Public Property Mute1MUT7 As Pcm1681Q1TypeMute1Vout7
    Get
    Set
public:
property Pcm1681Q1TypeMute1Vout7 Mute1MUT7 {
    Pcm1681Q1TypeMute1Vout7 get ();
    void set (Pcm1681Q1TypeMute1Vout7 value);
}
member Mute1MUT7 : Pcm1681Q1TypeMute1Vout7 with get, set

Property Value

Type: Pcm1681Q1TypeMute1Vout7
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Mute1MUT8 Property

IRD

Pcm1681Q1Mute1MUT8 Property

Mute1: MUT8

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeMute1Vout8 Mute1MUT8 { get; set; }
Public Property Mute1MUT8 As Pcm1681Q1TypeMute1Vout8
    Get
    Set
public:
property Pcm1681Q1TypeMute1Vout8 Mute1MUT8 {
    Pcm1681Q1TypeMute1Vout8 get ();
    void set (Pcm1681Q1TypeMute1Vout8 value);
}
member Mute1MUT8 : Pcm1681Q1TypeMute1Vout8 with get, set

Property Value

Type: Pcm1681Q1TypeMute1Vout8
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Mute2MUT7 Property

IRD

Pcm1681Q1Mute2MUT7 Property

Mute2: MUT7

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeMute2Vout7 Mute2MUT7 { get; set; }
Public Property Mute2MUT7 As Pcm1681Q1TypeMute2Vout7
    Get
    Set
public:
property Pcm1681Q1TypeMute2Vout7 Mute2MUT7 {
    Pcm1681Q1TypeMute2Vout7 get ();
    void set (Pcm1681Q1TypeMute2Vout7 value);
}
member Mute2MUT7 : Pcm1681Q1TypeMute2Vout7 with get, set

Property Value

Type: Pcm1681Q1TypeMute2Vout7
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Mute2MUT8 Property

IRD

Pcm1681Q1Mute2MUT8 Property

Mute2: MUT8

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeMute2Vout8 Mute2MUT8 { get; set; }
Public Property Mute2MUT8 As Pcm1681Q1TypeMute2Vout8
    Get
    Set
public:
property Pcm1681Q1TypeMute2Vout8 Mute2MUT8 {
    Pcm1681Q1TypeMute2Vout8 get ();
    void set (Pcm1681Q1TypeMute2Vout8 value);
}
member Mute2MUT8 : Pcm1681Q1TypeMute2Vout8 with get, set

Property Value

Type: Pcm1681Q1TypeMute2Vout8
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.OutputPhaseREV1 Property

IRD

Pcm1681Q1OutputPhaseREV1 Property

Output Phase: REV1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeOutputPhaseRev1 OutputPhaseREV1 { get; set; }
Public Property OutputPhaseREV1 As Pcm1681Q1TypeOutputPhaseRev1
    Get
    Set
public:
property Pcm1681Q1TypeOutputPhaseRev1 OutputPhaseREV1 {
    Pcm1681Q1TypeOutputPhaseRev1 get ();
    void set (Pcm1681Q1TypeOutputPhaseRev1 value);
}
member OutputPhaseREV1 : Pcm1681Q1TypeOutputPhaseRev1 with get, set

Property Value

Type: Pcm1681Q1TypeOutputPhaseRev1
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.OutputPhaseREV2 Property

IRD

Pcm1681Q1OutputPhaseREV2 Property

Output Phase: REV2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeOutputPhaseRev2 OutputPhaseREV2 { get; set; }
Public Property OutputPhaseREV2 As Pcm1681Q1TypeOutputPhaseRev2
    Get
    Set
public:
property Pcm1681Q1TypeOutputPhaseRev2 OutputPhaseREV2 {
    Pcm1681Q1TypeOutputPhaseRev2 get ();
    void set (Pcm1681Q1TypeOutputPhaseRev2 value);
}
member OutputPhaseREV2 : Pcm1681Q1TypeOutputPhaseRev2 with get, set

Property Value

Type: Pcm1681Q1TypeOutputPhaseRev2
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.OutputPhaseREV3 Property

IRD

Pcm1681Q1OutputPhaseREV3 Property

Output Phase: REV3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeOutputPhaseRev3 OutputPhaseREV3 { get; set; }
Public Property OutputPhaseREV3 As Pcm1681Q1TypeOutputPhaseRev3
    Get
    Set
public:
property Pcm1681Q1TypeOutputPhaseRev3 OutputPhaseREV3 {
    Pcm1681Q1TypeOutputPhaseRev3 get ();
    void set (Pcm1681Q1TypeOutputPhaseRev3 value);
}
member OutputPhaseREV3 : Pcm1681Q1TypeOutputPhaseRev3 with get, set

Property Value

Type: Pcm1681Q1TypeOutputPhaseRev3
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.OutputPhaseREV4 Property

IRD

Pcm1681Q1OutputPhaseREV4 Property

Output Phase: REV4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeOutputPhaseRev4 OutputPhaseREV4 { get; set; }
Public Property OutputPhaseREV4 As Pcm1681Q1TypeOutputPhaseRev4
    Get
    Set
public:
property Pcm1681Q1TypeOutputPhaseRev4 OutputPhaseREV4 {
    Pcm1681Q1TypeOutputPhaseRev4 get ();
    void set (Pcm1681Q1TypeOutputPhaseRev4 value);
}
member OutputPhaseREV4 : Pcm1681Q1TypeOutputPhaseRev4 with get, set

Property Value

Type: Pcm1681Q1TypeOutputPhaseRev4
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.OutputPhaseREV5 Property

IRD

Pcm1681Q1OutputPhaseREV5 Property

Output Phase: REV5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeOutputPhaseRev5 OutputPhaseREV5 { get; set; }
Public Property OutputPhaseREV5 As Pcm1681Q1TypeOutputPhaseRev5
    Get
    Set
public:
property Pcm1681Q1TypeOutputPhaseRev5 OutputPhaseREV5 {
    Pcm1681Q1TypeOutputPhaseRev5 get ();
    void set (Pcm1681Q1TypeOutputPhaseRev5 value);
}
member OutputPhaseREV5 : Pcm1681Q1TypeOutputPhaseRev5 with get, set

Property Value

Type: Pcm1681Q1TypeOutputPhaseRev5
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.OutputPhaseREV6 Property

IRD

Pcm1681Q1OutputPhaseREV6 Property

Output Phase: REV6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeOutputPhaseRev6 OutputPhaseREV6 { get; set; }
Public Property OutputPhaseREV6 As Pcm1681Q1TypeOutputPhaseRev6
    Get
    Set
public:
property Pcm1681Q1TypeOutputPhaseRev6 OutputPhaseREV6 {
    Pcm1681Q1TypeOutputPhaseRev6 get ();
    void set (Pcm1681Q1TypeOutputPhaseRev6 value);
}
member OutputPhaseREV6 : Pcm1681Q1TypeOutputPhaseRev6 with get, set

Property Value

Type: Pcm1681Q1TypeOutputPhaseRev6
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.OutputPhaseREV7 Property

IRD

Pcm1681Q1OutputPhaseREV7 Property

Output Phase: REV7

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeOutputPhaseRev7 OutputPhaseREV7 { get; set; }
Public Property OutputPhaseREV7 As Pcm1681Q1TypeOutputPhaseRev7
    Get
    Set
public:
property Pcm1681Q1TypeOutputPhaseRev7 OutputPhaseREV7 {
    Pcm1681Q1TypeOutputPhaseRev7 get ();
    void set (Pcm1681Q1TypeOutputPhaseRev7 value);
}
member OutputPhaseREV7 : Pcm1681Q1TypeOutputPhaseRev7 with get, set

Property Value

Type: Pcm1681Q1TypeOutputPhaseRev7
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.OutputPhaseREV8 Property

IRD

Pcm1681Q1OutputPhaseREV8 Property

Output Phase: REV8

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeOutputPhaseRev8 OutputPhaseREV8 { get; set; }
Public Property OutputPhaseREV8 As Pcm1681Q1TypeOutputPhaseRev8
    Get
    Set
public:
property Pcm1681Q1TypeOutputPhaseRev8 OutputPhaseREV8 {
    Pcm1681Q1TypeOutputPhaseRev8 get ();
    void set (Pcm1681Q1TypeOutputPhaseRev8 value);
}
member OutputPhaseREV8 : Pcm1681Q1TypeOutputPhaseRev8 with get, set

Property Value

Type: Pcm1681Q1TypeOutputPhaseRev8
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.RateControlFLT1 Property

IRD

Pcm1681Q1RateControlFLT1 Property

Rate Control: FLT1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeRateControlRollOffData1 RateControlFLT1 { get; set; }
Public Property RateControlFLT1 As Pcm1681Q1TypeRateControlRollOffData1
    Get
    Set
public:
property Pcm1681Q1TypeRateControlRollOffData1 RateControlFLT1 {
    Pcm1681Q1TypeRateControlRollOffData1 get ();
    void set (Pcm1681Q1TypeRateControlRollOffData1 value);
}
member RateControlFLT1 : Pcm1681Q1TypeRateControlRollOffData1 with get, set

Property Value

Type: Pcm1681Q1TypeRateControlRollOffData1
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.RateControlFLT2 Property

IRD

Pcm1681Q1RateControlFLT2 Property

Rate Control: FLT2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeRateControlRollOffData2 RateControlFLT2 { get; set; }
Public Property RateControlFLT2 As Pcm1681Q1TypeRateControlRollOffData2
    Get
    Set
public:
property Pcm1681Q1TypeRateControlRollOffData2 RateControlFLT2 {
    Pcm1681Q1TypeRateControlRollOffData2 get ();
    void set (Pcm1681Q1TypeRateControlRollOffData2 value);
}
member RateControlFLT2 : Pcm1681Q1TypeRateControlRollOffData2 with get, set

Property Value

Type: Pcm1681Q1TypeRateControlRollOffData2
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.RateControlFLT3 Property

IRD

Pcm1681Q1RateControlFLT3 Property

Rate Control: FLT3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeRateControlRollOffData3 RateControlFLT3 { get; set; }
Public Property RateControlFLT3 As Pcm1681Q1TypeRateControlRollOffData3
    Get
    Set
public:
property Pcm1681Q1TypeRateControlRollOffData3 RateControlFLT3 {
    Pcm1681Q1TypeRateControlRollOffData3 get ();
    void set (Pcm1681Q1TypeRateControlRollOffData3 value);
}
member RateControlFLT3 : Pcm1681Q1TypeRateControlRollOffData3 with get, set

Property Value

Type: Pcm1681Q1TypeRateControlRollOffData3
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.RateControlFLT4 Property

IRD

Pcm1681Q1RateControlFLT4 Property

Rate Control: FLT4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeRateControlRollOffData4 RateControlFLT4 { get; set; }
Public Property RateControlFLT4 As Pcm1681Q1TypeRateControlRollOffData4
    Get
    Set
public:
property Pcm1681Q1TypeRateControlRollOffData4 RateControlFLT4 {
    Pcm1681Q1TypeRateControlRollOffData4 get ();
    void set (Pcm1681Q1TypeRateControlRollOffData4 value);
}
member RateControlFLT4 : Pcm1681Q1TypeRateControlRollOffData4 with get, set

Property Value

Type: Pcm1681Q1TypeRateControlRollOffData4
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.RateControlOVER Property

IRD

Pcm1681Q1RateControlOVER Property

Rate Control: OVER

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1681Q1TypeRateControlOver RateControlOVER { get; set; }
Public Property RateControlOVER As Pcm1681Q1TypeRateControlOver
    Get
    Set
public:
property Pcm1681Q1TypeRateControlOver RateControlOVER {
    Pcm1681Q1TypeRateControlOver get ();
    void set (Pcm1681Q1TypeRateControlOver value);
}
member RateControlOVER : Pcm1681Q1TypeRateControlOver with get, set

Property Value

Type: Pcm1681Q1TypeRateControlOver
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1 Methods

The Pcm1681Q1 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.Flush Method

IRD

Pcm1681Q1Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcm1681Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeAttenuation Enumeration

IRD

Pcm1681Q1TypeAttenuation Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuation
Public Enumeration TypeAttenuation
public enum class TypeAttenuation
type TypeAttenuation
Members
Member name | Value | Description
Mute | 0 | Mute
Value_630DB | 129 | -63.0 dB
Value_625DB | 130 | -62.5 dB
Value_620DB | 131 | -62.0 dB
Value_615DB | 132 | -61.5 dB
Value_610DB | 133 | -61.0 dB
Value_605DB | 134 | -60.5 dB
Value_600DB | 135 | -60.0 dB
Value_595DB | 136 | -59.5 dB
Value_590DB | 137 | -59.0 dB
Value_585DB | 138 | -58.5 dB
Value_580DB | 139 | -58.0 dB
Value_575DB | 140 | -57.5 dB
Value_570DB | 141 | -57.0 dB
Value_565DB | 142 | -56.5 dB
Value_560DB | 143 | -56.0 dB
Value_555DB | 144 | -55.5 dB
Value_550DB | 145 | -55.0 dB
Value_545DB | 146 | -54.5 dB
Value_540DB | 147 | -54.0 dB
Value_535DB | 148 | -53.5 dB
Value_530DB | 149 | -53.0 dB
Value_525DB | 150 | -52.5 dB
Value_520DB | 151 | -52.0 dB
Value_515DB | 152 | -51.5 dB
Value_510DB | 153 | -51.0 dB
Value_505DB | 154 | -50.5 dB
Value_500DB | 155 | -50.0 dB
Value_495DB | 156 | -49.5 dB
Value_490DB | 157 | -49.0 dB
Value_485DB | 158 | -48.5 dB
Value_480DB | 159 | -48.0 dB
Value_475DB | 160 | -47.5 dB
Value_470DB | 161 | -47.0 dB
Value_465DB | 162 | -46.5 dB
Value_460DB | 163 | -46.0 dB
Value_455DB | 164 | -45.5 dB
Value_450DB | 165 | -45.0 dB
Value_445DB | 166 | -44.5 dB
Value_440DB | 167 | -44.0 dB
Value_435DB | 168 | -43.5 dB
Value_430DB | 169 | -43.0 dB
Value_425DB | 170 | -42.5 dB
Value_420DB | 171 | -42.0 dB
Value_415DB | 172 | -41.5 dB
Value_410DB | 173 | -41.0 dB
Value_405DB | 174 | -40.5 dB
Value_400DB | 175 | -40.0 dB
Value_395DB | 176 | -39.5 dB
Value_390DB | 177 | -39.0 dB
Value_385DB | 178 | -38.5 dB
Value_380DB | 179 | -38.0 dB
Value_375DB | 180 | -37.5 dB
Value_370DB | 181 | -37.0 dB
Value_365DB | 182 | -36.5 dB
Value_360DB | 183 | -36.0 dB
Value_355DB | 184 | -35.5 dB
Value_350DB | 185 | -35.0 dB
Value_345DB | 186 | -34.5 dB
Value_340DB | 187 | -34.0 dB
Value_335DB | 188 | -33.5 dB
Value_330DB | 189 | -33.0 dB
Value_325DB | 190 | -32.5 dB
Value_320DB | 191 | -32.0 dB
Value_315DB | 192 | -31.5 dB
Value_310DB | 193 | -31.0 dB
Value_305DB | 194 | -30.5 dB
Value_300DB | 195 | -30.0 dB
Value_295DB | 196 | -29.5 dB
Value_290DB | 197 | -29.0 dB
Value_285DB | 198 | -28.5 dB
Value_280DB | 199 | -28.0 dB
Value_275DB | 200 | -27.5 dB
Value_270DB | 201 | -27.0 dB
Value_265DB | 202 | -26.5 dB
Value_260DB | 203 | -26.0 dB
Value_255DB | 204 | -25.5 dB
Value_250DB | 205 | -25.0 dB
Value_245DB | 206 | -24.5 dB
Value_240DB | 207 | -24.0 dB
Value_235DB | 208 | -23.5 dB
Value_230DB | 209 | -23.0 dB
Value_225DB | 210 | -22.5 dB
Value_220DB | 211 | -22.0 dB
Value_215DB | 212 | -21.5 dB
Value_210DB | 213 | -21.0 dB
Value_205DB | 214 | -20.5 dB
Value_200DB | 215 | -20.0 dB
Value_195DB | 216 | -19.5 dB
Value_190DB | 217 | -19.0 dB
Value_185DB | 218 | -18.5 dB
Value_180DB | 219 | -18.0 dB
Value_175DB | 220 | -17.5 dB
Value_170DB | 221 | -17.0 dB
Value_165DB | 222 | -16.5 dB
Value_160DB | 223 | -16.0 dB
Value_155DB | 224 | -15.5 dB
Value_150DB | 225 | -15.0 dB
Value_145DB | 226 | -14.5 dB
Value_140DB | 227 | -14.0 dB
Value_135DB | 228 | -13.5 dB
Value_130DB | 229 | -13.0 dB
Value_125DB | 230 | -12.5 dB
Value_120DB | 231 | -12.0 dB
Value_115DB | 232 | -11.5 dB
Value_110DB | 233 | -11.0 dB
Value_105DB | 234 | -10.5 dB
Value_100DB | 235 | -10.0 dB
Value_95DB | 236 | -9.5 dB
Value_90DB | 237 | -9.0 dB
Value_85DB | 238 | -8.5 dB
Value_80DB | 239 | -8.0 dB
Value_75DB | 240 | -7.5 dB
Value_70DB | 241 | -7.0 dB
Value_65DB | 242 | -6.5 dB
Value_60DB | 243 | -6.0 dB
Value_55DB | 244 | -5.5 dB
Value_50DB | 245 | -5.0 dB
Value_45DB | 246 | -4.5 dB
Value_40DB | 247 | -4.0 dB
Value_35DB | 248 | -3.5 dB
Value_30DB | 249 | -3.0 dB
Value_25DB | 250 | -2.5 dB
Value_20DB | 251 | -2.0 dB
Value_15DB | 252 | -1.5 dB
Value_10DB | 253 | -1.0 dB
Value_05DB | 254 | -0.5 dB
Value_00DB | 255 | 0.0 dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDacControl1Dac1 Enumeration

IRD

Pcm1681Q1TypeDacControl1Dac1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControl1Dac1
Public Enumeration TypeDacControl1Dac1
public enum class TypeDacControl1Dac1
type TypeDacControl1Dac1
Members
Member name | Value | Description
DAC1OperationEnabled | 0 | DAC1: Operation Enabled
DAC1OperationDisabled | 1 | DAC1: Operation Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDacControl1Dac2 Enumeration

IRD

Pcm1681Q1TypeDacControl1Dac2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControl1Dac2
Public Enumeration TypeDacControl1Dac2
public enum class TypeDacControl1Dac2
type TypeDacControl1Dac2
Members
Member name | Value | Description
DAC2OperationEnabled | 0 | DAC2: Operation Enabled
DAC2OperationDisabled | 1 | DAC2: Operation Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDacControl1Dac3 Enumeration

IRD

Pcm1681Q1TypeDacControl1Dac3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControl1Dac3
Public Enumeration TypeDacControl1Dac3
public enum class TypeDacControl1Dac3
type TypeDacControl1Dac3
Members
Member name | Value | Description
DAC3OperationEnabled | 0 | DAC3: Operation Enabled
DAC3OperationDisabled | 1 | DAC3: Operation Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDacControl1Dac4 Enumeration

IRD

Pcm1681Q1TypeDacControl1Dac4 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControl1Dac4
Public Enumeration TypeDacControl1Dac4
public enum class TypeDacControl1Dac4
type TypeDacControl1Dac4
Members
Member name | Value | Description
DAC4OperationEnabled | 0 | DAC4: Operation Enabled
DAC4OperationDisabled | 1 | DAC4: Operation Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDacControl1Dac5 Enumeration

IRD

Pcm1681Q1TypeDacControl1Dac5 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControl1Dac5
Public Enumeration TypeDacControl1Dac5
public enum class TypeDacControl1Dac5
type TypeDacControl1Dac5
Members
Member name | Value | Description
DAC5OperationEnabled | 0 | DAC5: Operation Enabled
DAC5OperationDisabled | 1 | DAC5: Operation Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDacControl1Dac6 Enumeration

IRD

Pcm1681Q1TypeDacControl1Dac6 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControl1Dac6
Public Enumeration TypeDacControl1Dac6
public enum class TypeDacControl1Dac6
type TypeDacControl1Dac6
Members
Member name | Value | Description
DAC6OperationEnabled | 0 | DAC6: Operation Enabled
DAC6OperationDisabled | 1 | DAC6: Operation Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDacControl1Dac7 Enumeration

IRD

Pcm1681Q1TypeDacControl1Dac7 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControl1Dac7
Public Enumeration TypeDacControl1Dac7
public enum class TypeDacControl1Dac7
type TypeDacControl1Dac7
Members
Member name | Value | Description
DAC7OperationEnabled | 0 | DAC7: Operation Enabled
DAC7OperationDisabled | 1 | DAC7: Operation Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDacControl1Dac8 Enumeration

IRD

Pcm1681Q1TypeDacControl1Dac8 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControl1Dac8
Public Enumeration TypeDacControl1Dac8
public enum class TypeDacControl1Dac8
type TypeDacControl1Dac8
Members
Member name | Value | Description
DAC8OperationEnabled | 0 | DAC8: Operation Enabled
DAC8OperationDisabled | 1 | DAC8: Operation Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDacControl2Dac7 Enumeration

IRD

Pcm1681Q1TypeDacControl2Dac7 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControl2Dac7
Public Enumeration TypeDacControl2Dac7
public enum class TypeDacControl2Dac7
type TypeDacControl2Dac7
Members
Member name | Value | Description
DAC7OperationEnabled | 0 | DAC7: Operation Enabled
DAC7OperationDisabled | 1 | DAC7: Operation Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDacControl2Dac8 Enumeration

IRD

Pcm1681Q1TypeDacControl2Dac8 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControl2Dac8
Public Enumeration TypeDacControl2Dac8
public enum class TypeDacControl2Dac8
type TypeDacControl2Dac8
Members
Member name | Value | Description
DAC8OperationEnabled | 0 | DAC8: Operation Enabled
DAC8OperationDisabled | 1 | DAC8: Operation Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDeEmphasisChannel Enumeration

IRD

Pcm1681Q1TypeDeEmphasisChannel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeEmphasisChannel
Public Enumeration TypeDeEmphasisChannel
public enum class TypeDeEmphasisChannel
type TypeDeEmphasisChannel
Members
Member name | Value | Description
DeEmphasisDisabledForAllChannels | 0 | De-Emphasis Disabled For all Channels
DeEmphasisEnabledForAllChannels | 1 | De-Emphasis Enabled For all Channels
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDeEmphasisOutput Enumeration

IRD

Pcm1681Q1TypeDeEmphasisOutput Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeEmphasisOutput
Public Enumeration TypeDeEmphasisOutput
public enum class TypeDeEmphasisOutput
type TypeDeEmphasisOutput
Members
Member name | Value | Description
OutputPhaseNormalOutput | 0 | Output Phase: Normal Output
OutputPhaseInvertedOutput | 1 | Output Phase: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDeEmphasisReset Enumeration

IRD

Pcm1681Q1TypeDeEmphasisReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeEmphasisReset
Public Enumeration TypeDeEmphasisReset
public enum class TypeDeEmphasisReset
type TypeDeEmphasisReset
Members
Member name | Value | Description
SoftResetDisabled | 0 | Soft Reset: Disabled
SoftResetEnabled | 1 | Soft Reset: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDeEmphasisSampling Enumeration

IRD

Pcm1681Q1TypeDeEmphasisSampling Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeEmphasisSampling
Public Enumeration TypeDeEmphasisSampling
public enum class TypeDeEmphasisSampling
type TypeDeEmphasisSampling
Members
Member name | Value | Description
SamplingRate441KHz | 0 | Sampling Rate: 44.1 kHz
SamplingRate48KHz | 1 | Sampling Rate: 48 kHz
SamplingRate32KHz | 2 | Sampling Rate: 32 kHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDeEmphasisZeroFlag Enumeration

IRD

Pcm1681Q1TypeDeEmphasisZeroFlag Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDeEmphasisZeroFlag
Public Enumeration TypeDeEmphasisZeroFlag
public enum class TypeDeEmphasisZeroFlag
type TypeDeEmphasisZeroFlag
Members
Member name | Value | Description
ZeroFlagPinsHighAtZeroDetect | 0 | Zero Flag Pins High At Zero Detect
ZeroFlagPinsLowAtZeroDetect | 1 | Zero Flag Pins Low At Zero Detect
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDetectStatusZero1 Enumeration

IRD

Pcm1681Q1TypeDetectStatusZero1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectStatusZero1
Public Enumeration TypeDetectStatusZero1
public enum class TypeDetectStatusZero1
type TypeDetectStatusZero1
Members
Member name | Value | Description
Channel1ZeroStateDetected | 0 | Channel1: Zero State Detected
Channel1ZeroStateNotDetected | 1 | Channel1: Zero State Not Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDetectStatusZero2 Enumeration

IRD

Pcm1681Q1TypeDetectStatusZero2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectStatusZero2
Public Enumeration TypeDetectStatusZero2
public enum class TypeDetectStatusZero2
type TypeDetectStatusZero2
Members
Member name | Value | Description
Channel2ZeroStateDetected | 0 | Channel2: Zero State Detected
Channel2ZeroStateNotDetected | 1 | Channel2: Zero State Not Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDetectStatusZero3 Enumeration

IRD

Pcm1681Q1TypeDetectStatusZero3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectStatusZero3
Public Enumeration TypeDetectStatusZero3
public enum class TypeDetectStatusZero3
type TypeDetectStatusZero3
Members
Member name | Value | Description
Channel3ZeroStateDetected | 0 | Channel3: Zero State Detected
Channel3ZeroStateNotDetected | 1 | Channel3: Zero State Not Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDetectStatusZero4 Enumeration

IRD

Pcm1681Q1TypeDetectStatusZero4 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectStatusZero4
Public Enumeration TypeDetectStatusZero4
public enum class TypeDetectStatusZero4
type TypeDetectStatusZero4
Members
Member name | Value | Description
Channel4ZeroStateDetected | 0 | Channel4: Zero State Detected
Channel4ZeroStateNotDetected | 1 | Channel4: Zero State Not Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDetectStatusZero5 Enumeration

IRD

Pcm1681Q1TypeDetectStatusZero5 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectStatusZero5
Public Enumeration TypeDetectStatusZero5
public enum class TypeDetectStatusZero5
type TypeDetectStatusZero5
Members
Member name | Value | Description
Channel5ZeroStateDetected | 0 | Channel5: Zero State Detected
Channel5ZeroStateNotDetected | 1 | Channel5: Zero State Not Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDetectStatusZero6 Enumeration

IRD

Pcm1681Q1TypeDetectStatusZero6 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectStatusZero6
Public Enumeration TypeDetectStatusZero6
public enum class TypeDetectStatusZero6
type TypeDetectStatusZero6
Members
Member name | Value | Description
Channel6ZeroStateDetected | 0 | Channel6: Zero State Detected
Channel6ZeroStateNotDetected | 1 | Channel6: Zero State Not Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDetectStatusZero7 Enumeration

IRD

Pcm1681Q1TypeDetectStatusZero7 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectStatusZero7
Public Enumeration TypeDetectStatusZero7
public enum class TypeDetectStatusZero7
type TypeDetectStatusZero7
Members
Member name | Value | Description
Channel7ZeroStateDetected | 0 | Channel7: Zero State Detected
Channel7ZeroStateNotDetected | 1 | Channel7: Zero State Not Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeDetectStatusZero8 Enumeration

IRD

Pcm1681Q1TypeDetectStatusZero8 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDetectStatusZero8
Public Enumeration TypeDetectStatusZero8
public enum class TypeDetectStatusZero8
type TypeDetectStatusZero8
Members
Member name | Value | Description
Channel8ZeroStateDetected | 0 | Channel8: Zero State Detected
Channel8ZeroStateNotDetected | 1 | Channel8: Zero State Not Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeFilterInterfaceFormat Enumeration

IRD

Pcm1681Q1TypeFilterInterfaceFormat Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFilterInterfaceFormat
Public Enumeration TypeFilterInterfaceFormat
public enum class TypeFilterInterfaceFormat
type TypeFilterInterfaceFormat
Members
Member name | Value | Description
AudioDataFormatRightJustifiedFormat24Bit | 0 | Audio Data Format: Right Justified Format, 24 Bit
AudioDataFormatRightJustifiedFormat16Bit | 3 | Audio Data Format: Right Justified Format, 16 Bit
AudioDataFormatI2SFormat16To24Bit | 4 | Audio Data Format: I2S Format, 16 To 24 Bit
AudioDataFormatLeftJustifiedFormat16To24Bit | 5 | Audio Data Format: Left Justified Format 16 To 24 Bit
AudioDataFormatI2STDMFormat24Bit | 6 | Audio Data Format: I2S TDM Format, 24 Bit
AudioDataFormatLeftJustifiedTDMFormat24Bit | 7 | Audio Data Format: Left Justified TDM Format, 24 Bit
AudioDataFormatI2SDSPFormat25Bit | 8 | Audio Data Format: I2S DSP Format, 25 Bit
AudioDataFormatLeftJustifiedDSPFormat24Bit | 9 | Audio Data Format: Left Justified DSP Format, 24 bit
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeFilterRollOff Enumeration

IRD

Pcm1681Q1TypeFilterRollOff Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeFilterRollOff
Public Enumeration TypeFilterRollOff
public enum class TypeFilterRollOff
type TypeFilterRollOff
Members
Member name | Value | Description
RollOffControlSharpRollOff | 0 | Roll-Off Control: Sharp Roll-Off
RollOffControlSlowRollOff | 1 | Roll-Off Control: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeModeSelectDams Enumeration

IRD

Pcm1681Q1TypeModeSelectDams Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeSelectDams
Public Enumeration TypeModeSelectDams
public enum class TypeModeSelectDams
type TypeModeSelectDams
Members
Member name | Value | Description
AttenuationModeFineStep05DBStepRange063DB | 0 | Attenuation Mode: Fine Step, 0.5 dB/Step, Range 0-63 dB
AttenuationModeWideStep1DBStepRange0100DB | 1 | Attenuation Mode: Wide Step, 1 dB/Step, Range 0-100 dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeModeSelectZeroFlag Enumeration

IRD

Pcm1681Q1TypeModeSelectZeroFlag Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeSelectZeroFlag
Public Enumeration TypeModeSelectZeroFlag
public enum class TypeModeSelectZeroFlag
type TypeModeSelectZeroFlag
Members
Member name | Value | Description
ChannelCombinationZR1DATA1LCHZR2DATA1RCH | 0 | Channel Combination: ZR1 = DATA1 L-CH, ZR2 = DATA1 R-CH
ChannelCombinationZR1DATA1DATA4ZR2DATA1DAT4 | 1 | Channel Combination: ZR1 = DATA1-DATA4, ZR2 = DATA1-DAT4
ChannelCombinationZR1DATA4ZR2DATA1DATA3 | 2 | Channel Combination: ZR1 = DATA4, ZR2 = DATA1-DATA3
ChannelCombinationZR1DATA1ZR2DATA2DATA4 | 3 | Channel Combination: ZR1 = DATA1, ZR2 = DATA2-DATA4
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeMute1Vout1 Enumeration

IRD

Pcm1681Q1TypeMute1Vout1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMute1Vout1
Public Enumeration TypeMute1Vout1
public enum class TypeMute1Vout1
type TypeMute1Vout1
Members
Member name | Value | Description
Vout1MuteDisabled | 0 | Vout1: Mute Disabled
Vout1MuteEnabled | 1 | Vout1: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeMute1Vout2 Enumeration

IRD

Pcm1681Q1TypeMute1Vout2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMute1Vout2
Public Enumeration TypeMute1Vout2
public enum class TypeMute1Vout2
type TypeMute1Vout2
Members
Member name | Value | Description
Vout2MuteDisabled | 0 | Vout2: Mute Disabled
Vout2MuteEnabled | 1 | Vout2: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeMute1Vout3 Enumeration

IRD

Pcm1681Q1TypeMute1Vout3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMute1Vout3
Public Enumeration TypeMute1Vout3
public enum class TypeMute1Vout3
type TypeMute1Vout3
Members
Member name | Value | Description
Vout3MuteDisabled | 0 | Vout3: Mute Disabled
Vout3MuteEnabled | 1 | Vout3: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeMute1Vout4 Enumeration

IRD

Pcm1681Q1TypeMute1Vout4 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMute1Vout4
Public Enumeration TypeMute1Vout4
public enum class TypeMute1Vout4
type TypeMute1Vout4
Members
Member name | Value | Description
Vout4MuteDisabled | 0 | Vout4: Mute Disabled
Vout4MuteEnabled | 1 | Vout4: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeMute1Vout5 Enumeration

IRD

Pcm1681Q1TypeMute1Vout5 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMute1Vout5
Public Enumeration TypeMute1Vout5
public enum class TypeMute1Vout5
type TypeMute1Vout5
Members
Member name | Value | Description
Vout5MuteDisabled | 0 | Vout5: Mute Disabled
Vout5MuteEnabled | 1 | Vout5: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeMute1Vout6 Enumeration

IRD

Pcm1681Q1TypeMute1Vout6 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMute1Vout6
Public Enumeration TypeMute1Vout6
public enum class TypeMute1Vout6
type TypeMute1Vout6
Members
Member name | Value | Description
Vout6MuteDisabled | 0 | Vout6: Mute Disabled
Vout6MuteEnabled | 1 | Vout6: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeMute1Vout7 Enumeration

IRD

Pcm1681Q1TypeMute1Vout7 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMute1Vout7
Public Enumeration TypeMute1Vout7
public enum class TypeMute1Vout7
type TypeMute1Vout7
Members
Member name | Value | Description
Vout7MuteDisabled | 0 | Vout7: Mute Disabled
Vout7MuteEnabled | 1 | Vout7: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeMute1Vout8 Enumeration

IRD

Pcm1681Q1TypeMute1Vout8 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMute1Vout8
Public Enumeration TypeMute1Vout8
public enum class TypeMute1Vout8
type TypeMute1Vout8
Members
Member name | Value | Description
Vout8MuteDisabled | 0 | Vout8: Mute Disabled
Vout8MuteEnabled | 1 | Vout8: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeMute2Vout7 Enumeration

IRD

Pcm1681Q1TypeMute2Vout7 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMute2Vout7
Public Enumeration TypeMute2Vout7
public enum class TypeMute2Vout7
type TypeMute2Vout7
Members
Member name | Value | Description
Vout7MuteDisabled | 0 | Vout7: Mute Disabled
Vout7MuteEnabled | 1 | Vout7: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeMute2Vout8 Enumeration

IRD

Pcm1681Q1TypeMute2Vout8 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMute2Vout8
Public Enumeration TypeMute2Vout8
public enum class TypeMute2Vout8
type TypeMute2Vout8
Members
Member name | Value | Description
Vout8MuteDisabled | 0 | Vout8: Mute Disabled
Vout8MuteEnabled | 1 | Vout8: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeOutputPhaseRev1 Enumeration

IRD

Pcm1681Q1TypeOutputPhaseRev1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputPhaseRev1
Public Enumeration TypeOutputPhaseRev1
public enum class TypeOutputPhaseRev1
type TypeOutputPhaseRev1
Members
Member name | Value | Description
OutputPhaseVout1NormalOutput | 0 | Output Phase Vout1: Normal Output
OutputPhaseVout1InvertedOutput | 1 | Output Phase Vout1: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeOutputPhaseRev2 Enumeration

IRD

Pcm1681Q1TypeOutputPhaseRev2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputPhaseRev2
Public Enumeration TypeOutputPhaseRev2
public enum class TypeOutputPhaseRev2
type TypeOutputPhaseRev2
Members
Member name | Value | Description
OutputPhaseVout2NormalOutput | 0 | Output Phase Vout2: Normal Output
OutputPhaseVout2InvertedOutput | 1 | Output Phase Vout2: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeOutputPhaseRev3 Enumeration

IRD

Pcm1681Q1TypeOutputPhaseRev3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputPhaseRev3
Public Enumeration TypeOutputPhaseRev3
public enum class TypeOutputPhaseRev3
type TypeOutputPhaseRev3
Members
Member name | Value | Description
OutputPhaseVout3NormalOutput | 0 | Output Phase Vout3: Normal Output
OutputPhaseVout3InvertedOutput | 1 | Output Phase Vout3: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeOutputPhaseRev4 Enumeration

IRD

Pcm1681Q1TypeOutputPhaseRev4 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputPhaseRev4
Public Enumeration TypeOutputPhaseRev4
public enum class TypeOutputPhaseRev4
type TypeOutputPhaseRev4
Members
Member name | Value | Description
OutputPhaseVout4NormalOutput | 0 | Output Phase Vout4: Normal Output
OutputPhaseVout4InvertedOutput | 1 | Output Phase Vout4: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeOutputPhaseRev5 Enumeration

IRD

Pcm1681Q1TypeOutputPhaseRev5 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputPhaseRev5
Public Enumeration TypeOutputPhaseRev5
public enum class TypeOutputPhaseRev5
type TypeOutputPhaseRev5
Members
Member name | Value | Description
OutputPhaseVout5NormalOutput | 0 | Output Phase Vout5: Normal Output
OutputPhaseVout5InvertedOutput | 1 | Output Phase Vout5: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeOutputPhaseRev6 Enumeration

IRD

Pcm1681Q1TypeOutputPhaseRev6 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputPhaseRev6
Public Enumeration TypeOutputPhaseRev6
public enum class TypeOutputPhaseRev6
type TypeOutputPhaseRev6
Members
Member name | Value | Description
OutputPhaseVout6NormalOutput | 0 | Output Phase Vout6: Normal Output
OutputPhaseVout6InvertedOutput | 1 | Output Phase Vout6: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeOutputPhaseRev7 Enumeration

IRD

Pcm1681Q1TypeOutputPhaseRev7 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputPhaseRev7
Public Enumeration TypeOutputPhaseRev7
public enum class TypeOutputPhaseRev7
type TypeOutputPhaseRev7
Members
Member name | Value | Description
OutputPhaseVout7NormalOutput | 0 | Output Phase Vout7: Normal Output
OutputPhaseVout7InvertedOutput | 1 | Output Phase Vout7: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeOutputPhaseRev8 Enumeration

IRD

Pcm1681Q1TypeOutputPhaseRev8 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOutputPhaseRev8
Public Enumeration TypeOutputPhaseRev8
public enum class TypeOutputPhaseRev8
type TypeOutputPhaseRev8
Members
Member name | Value | Description
OutputPhaseVout8NormalOutput | 0 | Output Phase Vout8: Normal Output
OutputPhaseVout8InvertedOutput | 1 | Output Phase Vout8: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeRateControlOver Enumeration

IRD

Pcm1681Q1TypeRateControlOver Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRateControlOver
Public Enumeration TypeRateControlOver
public enum class TypeRateControlOver
type TypeRateControlOver
Members
Member name | Value | Description
DependingOnFs64x32x16xOversamplingNarrowMode | 0 | Depending On fs: 64x / 32x / 16x Oversampling, Narrow mode
DependingOnFs128x64x32xOversamplingWideMode | 1 | Depending On fs: 128x / 64x / 32x Oversampling, Wide Mode
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeRateControlRollOffData1 Enumeration

IRD

Pcm1681Q1TypeRateControlRollOffData1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRateControlRollOffData1
Public Enumeration TypeRateControlRollOffData1
public enum class TypeRateControlRollOffData1
type TypeRateControlRollOffData1
Members
Member name | Value | Description
Data1SharpRollOff | 0 | Data1: Sharp Roll-Off
Data1SlowRollOff | 1 | Data1: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeRateControlRollOffData2 Enumeration

IRD

Pcm1681Q1TypeRateControlRollOffData2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRateControlRollOffData2
Public Enumeration TypeRateControlRollOffData2
public enum class TypeRateControlRollOffData2
type TypeRateControlRollOffData2
Members
Member name | Value | Description
Data2SharpRollOff | 0 | Data2: Sharp Roll-Off
Data2SlowRollOff | 1 | Data2: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeRateControlRollOffData3 Enumeration

IRD

Pcm1681Q1TypeRateControlRollOffData3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRateControlRollOffData3
Public Enumeration TypeRateControlRollOffData3
public enum class TypeRateControlRollOffData3
type TypeRateControlRollOffData3
Members
Member name | Value | Description
Data3SharpRollOff | 0 | Data3: Sharp Roll-Off
Data3SlowRollOff | 1 | Data3: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1681Q1.TypeRateControlRollOffData4 Enumeration

IRD

Pcm1681Q1TypeRateControlRollOffData4 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeRateControlRollOffData4
Public Enumeration TypeRateControlRollOffData4
public enum class TypeRateControlRollOffData4
type TypeRateControlRollOffData4
Members
Member name | Value | Description
Data4SharpRollOff | 0 | Data4: Sharp Roll-Off
Data4SlowRollOff | 1 | Data4: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1 Class

Texas Instruments: PCM 1690-Q1
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPcm1690Q1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcm1690Q1
Public Class Pcm1690Q1
public ref class Pcm1690Q1
type Pcm1690Q1 =  class end

The Pcm1690Q1 type exposes the following members.

Constructors
 | Name | Description
Public method | Pcm1690Q1 | Constructor
Top
Properties
 | Name | Description
Public property | Attenuation1ATDA1 | Attenuation1: ATDA1
Public property | Attenuation2ATDA2 | Attenuation2: ATDA2
Public property | Attenuation3ATDA3 | Attenuation3: ATDA3
Public property | Attenuation4ATDA4 | Attenuation4: ATDA4
Public property | Attenuation5ATDA5 | Attenuation5: ATDA5
Public property | Attenuation6ATDA6 | Attenuation6: ATDA6
Public property | Attenuation7ATDA7 | Attenuation7: ATDA7
Public property | Attenuation8ATDA8 | Attenuation8: ATDA8
Public property | AttenuationModeAZRO | Attenuation Mode: AZRO
Public property | AttenuationModeDAMS | Attenuation Mode: DAMS
Public property | AttenuationModeDEMP | Attenuation Mode: DEMP
Public property | AttenuationModeZREV | Attenuation Mode: ZREV
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ModeControlAMUTE0 | Mode Control: AMUTE0
Public property | ModeControlAMUTE1 | Mode Control: AMUTE1
Public property | ModeControlAMUTE2 | Mode Control: AMUTE2
Public property | ModeControlAMUTE3 | Mode Control: AMUTE3
Public property | ModeControlMRST | Mode Control: MRST
Public property | ModeControlSRDA | Mode Control: SRDA
Public property | ModeControlSRST | Mode Control: SRST
Public property | ModeSelectionFMTDA | Mode Selection: FMTDA
Public property | ModeSelectionPSMDA | Mode Selection: PSMDA
Public property | MuteControlMUTDA1 | Mute Control: MUTDA1
Public property | MuteControlMUTDA2 | Mute Control: MUTDA2
Public property | MuteControlMUTDA3 | Mute Control: MUTDA3
Public property | MuteControlMUTDA4 | Mute Control: MUTDA4
Public property | MuteControlMUTDA5 | Mute Control: MUTDA5
Public property | MuteControlMUTDA6 | Mute Control: MUTDA6
Public property | MuteControlMUTDA7 | Mute Control: MUTDA7
Public property | MuteControlMUTDA8 | Mute Control: MUTDA8
Public property | OperationControlFLT0 | Operation Control: FLT0
Public property | OperationControlFLT1 | Operation Control: FLT1
Public property | OperationControlFLT2 | Operation Control: FLT2
Public property | OperationControlFLT3 | Operation Control: FLT3
Public property | OperationControlOPEDA0 | Operation Control: OPEDA0
Public property | OperationControlOPEDA1 | Operation Control: OPEDA1
Public property | OperationControlOPEDA2 | Operation Control: OPEDA2
Public property | OperationControlOPEDA3 | Operation Control: OPEDA3
Public property | PhaseSelectionREVDA1 | Phase Selection: REVDA1
Public property | PhaseSelectionREVDA2 | Phase Selection: REVDA2
Public property | PhaseSelectionREVDA3 | Phase Selection: REVDA3
Public property | PhaseSelectionREVDA4 | Phase Selection: REVDA4
Public property | PhaseSelectionREVDA5 | Phase Selection: REVDA5
Public property | PhaseSelectionREVDA6 | Phase Selection: REVDA6
Public property | PhaseSelectionREVDA7 | Phase Selection: REVDA7
Public property | PhaseSelectionREVDA8 | Phase Selection: REVDA8
Public property | ZeroFlagZERO1 | Zero Flag: ZERO1
Public property | ZeroFlagZERO2 | Zero Flag: ZERO2
Public property | ZeroFlagZERO3 | Zero Flag: ZERO3
Public property | ZeroFlagZERO4 | Zero Flag: ZERO4
Public property | ZeroFlagZERO5 | Zero Flag: ZERO5
Public property | ZeroFlagZERO6 | Zero Flag: ZERO6
Public property | ZeroFlagZERO7 | Zero Flag: ZERO7
Public property | ZeroFlagZERO8 | Zero Flag: ZERO8
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Eight-Channel Audio Digital-to-Analog Converter
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcm1690Q1(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcm1690Q1

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1 Properties

The Pcm1690Q1 type exposes the following members.

Properties
 | Name | Description
Public property | Attenuation1ATDA1 | Attenuation1: ATDA1
Public property | Attenuation2ATDA2 | Attenuation2: ATDA2
Public property | Attenuation3ATDA3 | Attenuation3: ATDA3
Public property | Attenuation4ATDA4 | Attenuation4: ATDA4
Public property | Attenuation5ATDA5 | Attenuation5: ATDA5
Public property | Attenuation6ATDA6 | Attenuation6: ATDA6
Public property | Attenuation7ATDA7 | Attenuation7: ATDA7
Public property | Attenuation8ATDA8 | Attenuation8: ATDA8
Public property | AttenuationModeAZRO | Attenuation Mode: AZRO
Public property | AttenuationModeDAMS | Attenuation Mode: DAMS
Public property | AttenuationModeDEMP | Attenuation Mode: DEMP
Public property | AttenuationModeZREV | Attenuation Mode: ZREV
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ModeControlAMUTE0 | Mode Control: AMUTE0
Public property | ModeControlAMUTE1 | Mode Control: AMUTE1
Public property | ModeControlAMUTE2 | Mode Control: AMUTE2
Public property | ModeControlAMUTE3 | Mode Control: AMUTE3
Public property | ModeControlMRST | Mode Control: MRST
Public property | ModeControlSRDA | Mode Control: SRDA
Public property | ModeControlSRST | Mode Control: SRST
Public property | ModeSelectionFMTDA | Mode Selection: FMTDA
Public property | ModeSelectionPSMDA | Mode Selection: PSMDA
Public property | MuteControlMUTDA1 | Mute Control: MUTDA1
Public property | MuteControlMUTDA2 | Mute Control: MUTDA2
Public property | MuteControlMUTDA3 | Mute Control: MUTDA3
Public property | MuteControlMUTDA4 | Mute Control: MUTDA4
Public property | MuteControlMUTDA5 | Mute Control: MUTDA5
Public property | MuteControlMUTDA6 | Mute Control: MUTDA6
Public property | MuteControlMUTDA7 | Mute Control: MUTDA7
Public property | MuteControlMUTDA8 | Mute Control: MUTDA8
Public property | OperationControlFLT0 | Operation Control: FLT0
Public property | OperationControlFLT1 | Operation Control: FLT1
Public property | OperationControlFLT2 | Operation Control: FLT2
Public property | OperationControlFLT3 | Operation Control: FLT3
Public property | OperationControlOPEDA0 | Operation Control: OPEDA0
Public property | OperationControlOPEDA1 | Operation Control: OPEDA1
Public property | OperationControlOPEDA2 | Operation Control: OPEDA2
Public property | OperationControlOPEDA3 | Operation Control: OPEDA3
Public property | PhaseSelectionREVDA1 | Phase Selection: REVDA1
Public property | PhaseSelectionREVDA2 | Phase Selection: REVDA2
Public property | PhaseSelectionREVDA3 | Phase Selection: REVDA3
Public property | PhaseSelectionREVDA4 | Phase Selection: REVDA4
Public property | PhaseSelectionREVDA5 | Phase Selection: REVDA5
Public property | PhaseSelectionREVDA6 | Phase Selection: REVDA6
Public property | PhaseSelectionREVDA7 | Phase Selection: REVDA7
Public property | PhaseSelectionREVDA8 | Phase Selection: REVDA8
Public property | ZeroFlagZERO1 | Zero Flag: ZERO1
Public property | ZeroFlagZERO2 | Zero Flag: ZERO2
Public property | ZeroFlagZERO3 | Zero Flag: ZERO3
Public property | ZeroFlagZERO4 | Zero Flag: ZERO4
Public property | ZeroFlagZERO5 | Zero Flag: ZERO5
Public property | ZeroFlagZERO6 | Zero Flag: ZERO6
Public property | ZeroFlagZERO7 | Zero Flag: ZERO7
Public property | ZeroFlagZERO8 | Zero Flag: ZERO8
Top
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.Attenuation1ATDA1 Property

IRD

Pcm1690Q1Attenuation1ATDA1 Property

Attenuation1: ATDA1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Attenuation1ATDA1 { get; set; }
Public Property Attenuation1ATDA1 As Byte
    Get
    Set
public:
property unsigned char Attenuation1ATDA1 {
    unsigned char get ();
    void set (unsigned char value);
}
member Attenuation1ATDA1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.Attenuation2ATDA2 Property

IRD

Pcm1690Q1Attenuation2ATDA2 Property

Attenuation2: ATDA2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Attenuation2ATDA2 { get; set; }
Public Property Attenuation2ATDA2 As Byte
    Get
    Set
public:
property unsigned char Attenuation2ATDA2 {
    unsigned char get ();
    void set (unsigned char value);
}
member Attenuation2ATDA2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.Attenuation3ATDA3 Property

IRD

Pcm1690Q1Attenuation3ATDA3 Property

Attenuation3: ATDA3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Attenuation3ATDA3 { get; set; }
Public Property Attenuation3ATDA3 As Byte
    Get
    Set
public:
property unsigned char Attenuation3ATDA3 {
    unsigned char get ();
    void set (unsigned char value);
}
member Attenuation3ATDA3 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.Attenuation4ATDA4 Property

IRD

Pcm1690Q1Attenuation4ATDA4 Property

Attenuation4: ATDA4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Attenuation4ATDA4 { get; set; }
Public Property Attenuation4ATDA4 As Byte
    Get
    Set
public:
property unsigned char Attenuation4ATDA4 {
    unsigned char get ();
    void set (unsigned char value);
}
member Attenuation4ATDA4 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.Attenuation5ATDA5 Property

IRD

Pcm1690Q1Attenuation5ATDA5 Property

Attenuation5: ATDA5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Attenuation5ATDA5 { get; set; }
Public Property Attenuation5ATDA5 As Byte
    Get
    Set
public:
property unsigned char Attenuation5ATDA5 {
    unsigned char get ();
    void set (unsigned char value);
}
member Attenuation5ATDA5 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.Attenuation6ATDA6 Property

IRD

Pcm1690Q1Attenuation6ATDA6 Property

Attenuation6: ATDA6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Attenuation6ATDA6 { get; set; }
Public Property Attenuation6ATDA6 As Byte
    Get
    Set
public:
property unsigned char Attenuation6ATDA6 {
    unsigned char get ();
    void set (unsigned char value);
}
member Attenuation6ATDA6 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.Attenuation7ATDA7 Property

IRD

Pcm1690Q1Attenuation7ATDA7 Property

Attenuation7: ATDA7

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Attenuation7ATDA7 { get; set; }
Public Property Attenuation7ATDA7 As Byte
    Get
    Set
public:
property unsigned char Attenuation7ATDA7 {
    unsigned char get ();
    void set (unsigned char value);
}
member Attenuation7ATDA7 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.Attenuation8ATDA8 Property

IRD

Pcm1690Q1Attenuation8ATDA8 Property

Attenuation8: ATDA8

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Attenuation8ATDA8 { get; set; }
Public Property Attenuation8ATDA8 As Byte
    Get
    Set
public:
property unsigned char Attenuation8ATDA8 {
    unsigned char get ();
    void set (unsigned char value);
}
member Attenuation8ATDA8 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.AttenuationModeAZRO Property

IRD

Pcm1690Q1AttenuationModeAZRO Property

Attenuation Mode: AZRO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeAttenuationModeFlagSel AttenuationModeAZRO { get; set; }
Public Property AttenuationModeAZRO As Pcm1690Q1TypeAttenuationModeFlagSel
    Get
    Set
public:
property Pcm1690Q1TypeAttenuationModeFlagSel AttenuationModeAZRO {
    Pcm1690Q1TypeAttenuationModeFlagSel get ();
    void set (Pcm1690Q1TypeAttenuationModeFlagSel value);
}
member AttenuationModeAZRO : Pcm1690Q1TypeAttenuationModeFlagSel with get, set

Property Value

Type: Pcm1690Q1TypeAttenuationModeFlagSel
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.AttenuationModeDAMS Property

IRD

Pcm1690Q1AttenuationModeDAMS Property

Attenuation Mode: DAMS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeAttenuationModeDams AttenuationModeDAMS { get; set; }
Public Property AttenuationModeDAMS As Pcm1690Q1TypeAttenuationModeDams
    Get
    Set
public:
property Pcm1690Q1TypeAttenuationModeDams AttenuationModeDAMS {
    Pcm1690Q1TypeAttenuationModeDams get ();
    void set (Pcm1690Q1TypeAttenuationModeDams value);
}
member AttenuationModeDAMS : Pcm1690Q1TypeAttenuationModeDams with get, set

Property Value

Type: Pcm1690Q1TypeAttenuationModeDams
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.AttenuationModeDEMP Property

IRD

Pcm1690Q1AttenuationModeDEMP Property

Attenuation Mode: DEMP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeAttenuationModeDemp AttenuationModeDEMP { get; set; }
Public Property AttenuationModeDEMP As Pcm1690Q1TypeAttenuationModeDemp
    Get
    Set
public:
property Pcm1690Q1TypeAttenuationModeDemp AttenuationModeDEMP {
    Pcm1690Q1TypeAttenuationModeDemp get ();
    void set (Pcm1690Q1TypeAttenuationModeDemp value);
}
member AttenuationModeDEMP : Pcm1690Q1TypeAttenuationModeDemp with get, set

Property Value

Type: Pcm1690Q1TypeAttenuationModeDemp
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.AttenuationModeZREV Property

IRD

Pcm1690Q1AttenuationModeZREV Property

Attenuation Mode: ZREV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeAttenuationModeFlagPol AttenuationModeZREV { get; set; }
Public Property AttenuationModeZREV As Pcm1690Q1TypeAttenuationModeFlagPol
    Get
    Set
public:
property Pcm1690Q1TypeAttenuationModeFlagPol AttenuationModeZREV {
    Pcm1690Q1TypeAttenuationModeFlagPol get ();
    void set (Pcm1690Q1TypeAttenuationModeFlagPol value);
}
member AttenuationModeZREV : Pcm1690Q1TypeAttenuationModeFlagPol with get, set

Property Value

Type: Pcm1690Q1TypeAttenuationModeFlagPol
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.AutoFlush Property

IRD

Pcm1690Q1AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.ModeControlAMUTE0 Property

IRD

Pcm1690Q1ModeControlAMUTE0 Property

Mode Control: AMUTE0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeModeControlAmute0 ModeControlAMUTE0 { get; set; }
Public Property ModeControlAMUTE0 As Pcm1690Q1TypeModeControlAmute0
    Get
    Set
public:
property Pcm1690Q1TypeModeControlAmute0 ModeControlAMUTE0 {
    Pcm1690Q1TypeModeControlAmute0 get ();
    void set (Pcm1690Q1TypeModeControlAmute0 value);
}
member ModeControlAMUTE0 : Pcm1690Q1TypeModeControlAmute0 with get, set

Property Value

Type: Pcm1690Q1TypeModeControlAmute0
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.ModeControlAMUTE1 Property

IRD

Pcm1690Q1ModeControlAMUTE1 Property

Mode Control: AMUTE1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeModeControlAmute1 ModeControlAMUTE1 { get; set; }
Public Property ModeControlAMUTE1 As Pcm1690Q1TypeModeControlAmute1
    Get
    Set
public:
property Pcm1690Q1TypeModeControlAmute1 ModeControlAMUTE1 {
    Pcm1690Q1TypeModeControlAmute1 get ();
    void set (Pcm1690Q1TypeModeControlAmute1 value);
}
member ModeControlAMUTE1 : Pcm1690Q1TypeModeControlAmute1 with get, set

Property Value

Type: Pcm1690Q1TypeModeControlAmute1
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.ModeControlAMUTE2 Property

IRD

Pcm1690Q1ModeControlAMUTE2 Property

Mode Control: AMUTE2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeModeControlAmute2 ModeControlAMUTE2 { get; set; }
Public Property ModeControlAMUTE2 As Pcm1690Q1TypeModeControlAmute2
    Get
    Set
public:
property Pcm1690Q1TypeModeControlAmute2 ModeControlAMUTE2 {
    Pcm1690Q1TypeModeControlAmute2 get ();
    void set (Pcm1690Q1TypeModeControlAmute2 value);
}
member ModeControlAMUTE2 : Pcm1690Q1TypeModeControlAmute2 with get, set

Property Value

Type: Pcm1690Q1TypeModeControlAmute2
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.ModeControlAMUTE3 Property

IRD

Pcm1690Q1ModeControlAMUTE3 Property

Mode Control: AMUTE3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeModeControlAmute3 ModeControlAMUTE3 { get; set; }
Public Property ModeControlAMUTE3 As Pcm1690Q1TypeModeControlAmute3
    Get
    Set
public:
property Pcm1690Q1TypeModeControlAmute3 ModeControlAMUTE3 {
    Pcm1690Q1TypeModeControlAmute3 get ();
    void set (Pcm1690Q1TypeModeControlAmute3 value);
}
member ModeControlAMUTE3 : Pcm1690Q1TypeModeControlAmute3 with get, set

Property Value

Type: Pcm1690Q1TypeModeControlAmute3
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.ModeControlMRST Property

IRD

Pcm1690Q1ModeControlMRST Property

Mode Control: MRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeModeControlRegisterReset ModeControlMRST { get; set; }
Public Property ModeControlMRST As Pcm1690Q1TypeModeControlRegisterReset
    Get
    Set
public:
property Pcm1690Q1TypeModeControlRegisterReset ModeControlMRST {
    Pcm1690Q1TypeModeControlRegisterReset get ();
    void set (Pcm1690Q1TypeModeControlRegisterReset value);
}
member ModeControlMRST : Pcm1690Q1TypeModeControlRegisterReset with get, set

Property Value

Type: Pcm1690Q1TypeModeControlRegisterReset
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.ModeControlSRDA Property

IRD

Pcm1690Q1ModeControlSRDA Property

Mode Control: SRDA

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeModeControlSamplingMode ModeControlSRDA { get; set; }
Public Property ModeControlSRDA As Pcm1690Q1TypeModeControlSamplingMode
    Get
    Set
public:
property Pcm1690Q1TypeModeControlSamplingMode ModeControlSRDA {
    Pcm1690Q1TypeModeControlSamplingMode get ();
    void set (Pcm1690Q1TypeModeControlSamplingMode value);
}
member ModeControlSRDA : Pcm1690Q1TypeModeControlSamplingMode with get, set

Property Value

Type: Pcm1690Q1TypeModeControlSamplingMode
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.ModeControlSRST Property

IRD

Pcm1690Q1ModeControlSRST Property

Mode Control: SRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeModeControlSystemReset ModeControlSRST { get; set; }
Public Property ModeControlSRST As Pcm1690Q1TypeModeControlSystemReset
    Get
    Set
public:
property Pcm1690Q1TypeModeControlSystemReset ModeControlSRST {
    Pcm1690Q1TypeModeControlSystemReset get ();
    void set (Pcm1690Q1TypeModeControlSystemReset value);
}
member ModeControlSRST : Pcm1690Q1TypeModeControlSystemReset with get, set

Property Value

Type: Pcm1690Q1TypeModeControlSystemReset
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.ModeSelectionFMTDA Property

IRD

Pcm1690Q1ModeSelectionFMTDA Property

Mode Selection: FMTDA

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeModeSelectionAudioFormat ModeSelectionFMTDA { get; set; }
Public Property ModeSelectionFMTDA As Pcm1690Q1TypeModeSelectionAudioFormat
    Get
    Set
public:
property Pcm1690Q1TypeModeSelectionAudioFormat ModeSelectionFMTDA {
    Pcm1690Q1TypeModeSelectionAudioFormat get ();
    void set (Pcm1690Q1TypeModeSelectionAudioFormat value);
}
member ModeSelectionFMTDA : Pcm1690Q1TypeModeSelectionAudioFormat with get, set

Property Value

Type: Pcm1690Q1TypeModeSelectionAudioFormat
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.ModeSelectionPSMDA Property

IRD

Pcm1690Q1ModeSelectionPSMDA Property

Mode Selection: PSMDA

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeModeSelectionPowerSave ModeSelectionPSMDA { get; set; }
Public Property ModeSelectionPSMDA As Pcm1690Q1TypeModeSelectionPowerSave
    Get
    Set
public:
property Pcm1690Q1TypeModeSelectionPowerSave ModeSelectionPSMDA {
    Pcm1690Q1TypeModeSelectionPowerSave get ();
    void set (Pcm1690Q1TypeModeSelectionPowerSave value);
}
member ModeSelectionPSMDA : Pcm1690Q1TypeModeSelectionPowerSave with get, set

Property Value

Type: Pcm1690Q1TypeModeSelectionPowerSave
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.MuteControlMUTDA1 Property

IRD

Pcm1690Q1MuteControlMUTDA1 Property

Mute Control: MUTDA1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeMuteControlMutda1 MuteControlMUTDA1 { get; set; }
Public Property MuteControlMUTDA1 As Pcm1690Q1TypeMuteControlMutda1
    Get
    Set
public:
property Pcm1690Q1TypeMuteControlMutda1 MuteControlMUTDA1 {
    Pcm1690Q1TypeMuteControlMutda1 get ();
    void set (Pcm1690Q1TypeMuteControlMutda1 value);
}
member MuteControlMUTDA1 : Pcm1690Q1TypeMuteControlMutda1 with get, set

Property Value

Type: Pcm1690Q1TypeMuteControlMutda1
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.MuteControlMUTDA2 Property

IRD

Pcm1690Q1MuteControlMUTDA2 Property

Mute Control: MUTDA2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeMuteControlMutda2 MuteControlMUTDA2 { get; set; }
Public Property MuteControlMUTDA2 As Pcm1690Q1TypeMuteControlMutda2
    Get
    Set
public:
property Pcm1690Q1TypeMuteControlMutda2 MuteControlMUTDA2 {
    Pcm1690Q1TypeMuteControlMutda2 get ();
    void set (Pcm1690Q1TypeMuteControlMutda2 value);
}
member MuteControlMUTDA2 : Pcm1690Q1TypeMuteControlMutda2 with get, set

Property Value

Type: Pcm1690Q1TypeMuteControlMutda2
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.MuteControlMUTDA3 Property

IRD

Pcm1690Q1MuteControlMUTDA3 Property

Mute Control: MUTDA3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeMuteControlMutda3 MuteControlMUTDA3 { get; set; }
Public Property MuteControlMUTDA3 As Pcm1690Q1TypeMuteControlMutda3
    Get
    Set
public:
property Pcm1690Q1TypeMuteControlMutda3 MuteControlMUTDA3 {
    Pcm1690Q1TypeMuteControlMutda3 get ();
    void set (Pcm1690Q1TypeMuteControlMutda3 value);
}
member MuteControlMUTDA3 : Pcm1690Q1TypeMuteControlMutda3 with get, set

Property Value

Type: Pcm1690Q1TypeMuteControlMutda3
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.MuteControlMUTDA4 Property

IRD

Pcm1690Q1MuteControlMUTDA4 Property

Mute Control: MUTDA4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeMuteControlMutda4 MuteControlMUTDA4 { get; set; }
Public Property MuteControlMUTDA4 As Pcm1690Q1TypeMuteControlMutda4
    Get
    Set
public:
property Pcm1690Q1TypeMuteControlMutda4 MuteControlMUTDA4 {
    Pcm1690Q1TypeMuteControlMutda4 get ();
    void set (Pcm1690Q1TypeMuteControlMutda4 value);
}
member MuteControlMUTDA4 : Pcm1690Q1TypeMuteControlMutda4 with get, set

Property Value

Type: Pcm1690Q1TypeMuteControlMutda4
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.MuteControlMUTDA5 Property

IRD

Pcm1690Q1MuteControlMUTDA5 Property

Mute Control: MUTDA5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeMuteControlMutda5 MuteControlMUTDA5 { get; set; }
Public Property MuteControlMUTDA5 As Pcm1690Q1TypeMuteControlMutda5
    Get
    Set
public:
property Pcm1690Q1TypeMuteControlMutda5 MuteControlMUTDA5 {
    Pcm1690Q1TypeMuteControlMutda5 get ();
    void set (Pcm1690Q1TypeMuteControlMutda5 value);
}
member MuteControlMUTDA5 : Pcm1690Q1TypeMuteControlMutda5 with get, set

Property Value

Type: Pcm1690Q1TypeMuteControlMutda5
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.MuteControlMUTDA6 Property

IRD

Pcm1690Q1MuteControlMUTDA6 Property

Mute Control: MUTDA6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeMuteControlMutda6 MuteControlMUTDA6 { get; set; }
Public Property MuteControlMUTDA6 As Pcm1690Q1TypeMuteControlMutda6
    Get
    Set
public:
property Pcm1690Q1TypeMuteControlMutda6 MuteControlMUTDA6 {
    Pcm1690Q1TypeMuteControlMutda6 get ();
    void set (Pcm1690Q1TypeMuteControlMutda6 value);
}
member MuteControlMUTDA6 : Pcm1690Q1TypeMuteControlMutda6 with get, set

Property Value

Type: Pcm1690Q1TypeMuteControlMutda6
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.MuteControlMUTDA7 Property

IRD

Pcm1690Q1MuteControlMUTDA7 Property

Mute Control: MUTDA7

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeMuteControlMutda7 MuteControlMUTDA7 { get; set; }
Public Property MuteControlMUTDA7 As Pcm1690Q1TypeMuteControlMutda7
    Get
    Set
public:
property Pcm1690Q1TypeMuteControlMutda7 MuteControlMUTDA7 {
    Pcm1690Q1TypeMuteControlMutda7 get ();
    void set (Pcm1690Q1TypeMuteControlMutda7 value);
}
member MuteControlMUTDA7 : Pcm1690Q1TypeMuteControlMutda7 with get, set

Property Value

Type: Pcm1690Q1TypeMuteControlMutda7
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.MuteControlMUTDA8 Property

IRD

Pcm1690Q1MuteControlMUTDA8 Property

Mute Control: MUTDA8

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeMuteControlMutda8 MuteControlMUTDA8 { get; set; }
Public Property MuteControlMUTDA8 As Pcm1690Q1TypeMuteControlMutda8
    Get
    Set
public:
property Pcm1690Q1TypeMuteControlMutda8 MuteControlMUTDA8 {
    Pcm1690Q1TypeMuteControlMutda8 get ();
    void set (Pcm1690Q1TypeMuteControlMutda8 value);
}
member MuteControlMUTDA8 : Pcm1690Q1TypeMuteControlMutda8 with get, set

Property Value

Type: Pcm1690Q1TypeMuteControlMutda8
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.OperationControlFLT0 Property

IRD

Pcm1690Q1OperationControlFLT0 Property

Operation Control: FLT0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeOperationControlFlt0 OperationControlFLT0 { get; set; }
Public Property OperationControlFLT0 As Pcm1690Q1TypeOperationControlFlt0
    Get
    Set
public:
property Pcm1690Q1TypeOperationControlFlt0 OperationControlFLT0 {
    Pcm1690Q1TypeOperationControlFlt0 get ();
    void set (Pcm1690Q1TypeOperationControlFlt0 value);
}
member OperationControlFLT0 : Pcm1690Q1TypeOperationControlFlt0 with get, set

Property Value

Type: Pcm1690Q1TypeOperationControlFlt0
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.OperationControlFLT1 Property

IRD

Pcm1690Q1OperationControlFLT1 Property

Operation Control: FLT1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeOperationControlFlt1 OperationControlFLT1 { get; set; }
Public Property OperationControlFLT1 As Pcm1690Q1TypeOperationControlFlt1
    Get
    Set
public:
property Pcm1690Q1TypeOperationControlFlt1 OperationControlFLT1 {
    Pcm1690Q1TypeOperationControlFlt1 get ();
    void set (Pcm1690Q1TypeOperationControlFlt1 value);
}
member OperationControlFLT1 : Pcm1690Q1TypeOperationControlFlt1 with get, set

Property Value

Type: Pcm1690Q1TypeOperationControlFlt1
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.OperationControlFLT2 Property

IRD

Pcm1690Q1OperationControlFLT2 Property

Operation Control: FLT2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeOperationControlFlt2 OperationControlFLT2 { get; set; }
Public Property OperationControlFLT2 As Pcm1690Q1TypeOperationControlFlt2
    Get
    Set
public:
property Pcm1690Q1TypeOperationControlFlt2 OperationControlFLT2 {
    Pcm1690Q1TypeOperationControlFlt2 get ();
    void set (Pcm1690Q1TypeOperationControlFlt2 value);
}
member OperationControlFLT2 : Pcm1690Q1TypeOperationControlFlt2 with get, set

Property Value

Type: Pcm1690Q1TypeOperationControlFlt2
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.OperationControlFLT3 Property

IRD

Pcm1690Q1OperationControlFLT3 Property

Operation Control: FLT3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeOperationControlFlt3 OperationControlFLT3 { get; set; }
Public Property OperationControlFLT3 As Pcm1690Q1TypeOperationControlFlt3
    Get
    Set
public:
property Pcm1690Q1TypeOperationControlFlt3 OperationControlFLT3 {
    Pcm1690Q1TypeOperationControlFlt3 get ();
    void set (Pcm1690Q1TypeOperationControlFlt3 value);
}
member OperationControlFLT3 : Pcm1690Q1TypeOperationControlFlt3 with get, set

Property Value

Type: Pcm1690Q1TypeOperationControlFlt3
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.OperationControlOPEDA0 Property

IRD

Pcm1690Q1OperationControlOPEDA0 Property

Operation Control: OPEDA0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeOperationControlOpeda0 OperationControlOPEDA0 { get; set; }
Public Property OperationControlOPEDA0 As Pcm1690Q1TypeOperationControlOpeda0
    Get
    Set
public:
property Pcm1690Q1TypeOperationControlOpeda0 OperationControlOPEDA0 {
    Pcm1690Q1TypeOperationControlOpeda0 get ();
    void set (Pcm1690Q1TypeOperationControlOpeda0 value);
}
member OperationControlOPEDA0 : Pcm1690Q1TypeOperationControlOpeda0 with get, set

Property Value

Type: Pcm1690Q1TypeOperationControlOpeda0
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.OperationControlOPEDA1 Property

IRD

Pcm1690Q1OperationControlOPEDA1 Property

Operation Control: OPEDA1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeOperationControlOpeda1 OperationControlOPEDA1 { get; set; }
Public Property OperationControlOPEDA1 As Pcm1690Q1TypeOperationControlOpeda1
    Get
    Set
public:
property Pcm1690Q1TypeOperationControlOpeda1 OperationControlOPEDA1 {
    Pcm1690Q1TypeOperationControlOpeda1 get ();
    void set (Pcm1690Q1TypeOperationControlOpeda1 value);
}
member OperationControlOPEDA1 : Pcm1690Q1TypeOperationControlOpeda1 with get, set

Property Value

Type: Pcm1690Q1TypeOperationControlOpeda1
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.OperationControlOPEDA2 Property

IRD

Pcm1690Q1OperationControlOPEDA2 Property

Operation Control: OPEDA2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeOperationControlOpeda2 OperationControlOPEDA2 { get; set; }
Public Property OperationControlOPEDA2 As Pcm1690Q1TypeOperationControlOpeda2
    Get
    Set
public:
property Pcm1690Q1TypeOperationControlOpeda2 OperationControlOPEDA2 {
    Pcm1690Q1TypeOperationControlOpeda2 get ();
    void set (Pcm1690Q1TypeOperationControlOpeda2 value);
}
member OperationControlOPEDA2 : Pcm1690Q1TypeOperationControlOpeda2 with get, set

Property Value

Type: Pcm1690Q1TypeOperationControlOpeda2
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.OperationControlOPEDA3 Property

IRD

Pcm1690Q1OperationControlOPEDA3 Property

Operation Control: OPEDA3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeOperationControlOpeda3 OperationControlOPEDA3 { get; set; }
Public Property OperationControlOPEDA3 As Pcm1690Q1TypeOperationControlOpeda3
    Get
    Set
public:
property Pcm1690Q1TypeOperationControlOpeda3 OperationControlOPEDA3 {
    Pcm1690Q1TypeOperationControlOpeda3 get ();
    void set (Pcm1690Q1TypeOperationControlOpeda3 value);
}
member OperationControlOPEDA3 : Pcm1690Q1TypeOperationControlOpeda3 with get, set

Property Value

Type: Pcm1690Q1TypeOperationControlOpeda3
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.PhaseSelectionREVDA1 Property

IRD

Pcm1690Q1PhaseSelectionREVDA1 Property

Phase Selection: REVDA1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypePhaseSelectionRevda1 PhaseSelectionREVDA1 { get; set; }
Public Property PhaseSelectionREVDA1 As Pcm1690Q1TypePhaseSelectionRevda1
    Get
    Set
public:
property Pcm1690Q1TypePhaseSelectionRevda1 PhaseSelectionREVDA1 {
    Pcm1690Q1TypePhaseSelectionRevda1 get ();
    void set (Pcm1690Q1TypePhaseSelectionRevda1 value);
}
member PhaseSelectionREVDA1 : Pcm1690Q1TypePhaseSelectionRevda1 with get, set

Property Value

Type: Pcm1690Q1TypePhaseSelectionRevda1
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.PhaseSelectionREVDA2 Property

IRD

Pcm1690Q1PhaseSelectionREVDA2 Property

Phase Selection: REVDA2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypePhaseSelectionRevda2 PhaseSelectionREVDA2 { get; set; }
Public Property PhaseSelectionREVDA2 As Pcm1690Q1TypePhaseSelectionRevda2
    Get
    Set
public:
property Pcm1690Q1TypePhaseSelectionRevda2 PhaseSelectionREVDA2 {
    Pcm1690Q1TypePhaseSelectionRevda2 get ();
    void set (Pcm1690Q1TypePhaseSelectionRevda2 value);
}
member PhaseSelectionREVDA2 : Pcm1690Q1TypePhaseSelectionRevda2 with get, set

Property Value

Type: Pcm1690Q1TypePhaseSelectionRevda2
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.PhaseSelectionREVDA3 Property

IRD

Pcm1690Q1PhaseSelectionREVDA3 Property

Phase Selection: REVDA3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypePhaseSelectionRevda3 PhaseSelectionREVDA3 { get; set; }
Public Property PhaseSelectionREVDA3 As Pcm1690Q1TypePhaseSelectionRevda3
    Get
    Set
public:
property Pcm1690Q1TypePhaseSelectionRevda3 PhaseSelectionREVDA3 {
    Pcm1690Q1TypePhaseSelectionRevda3 get ();
    void set (Pcm1690Q1TypePhaseSelectionRevda3 value);
}
member PhaseSelectionREVDA3 : Pcm1690Q1TypePhaseSelectionRevda3 with get, set

Property Value

Type: Pcm1690Q1TypePhaseSelectionRevda3
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.PhaseSelectionREVDA4 Property

IRD

Pcm1690Q1PhaseSelectionREVDA4 Property

Phase Selection: REVDA4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypePhaseSelectionRevda4 PhaseSelectionREVDA4 { get; set; }
Public Property PhaseSelectionREVDA4 As Pcm1690Q1TypePhaseSelectionRevda4
    Get
    Set
public:
property Pcm1690Q1TypePhaseSelectionRevda4 PhaseSelectionREVDA4 {
    Pcm1690Q1TypePhaseSelectionRevda4 get ();
    void set (Pcm1690Q1TypePhaseSelectionRevda4 value);
}
member PhaseSelectionREVDA4 : Pcm1690Q1TypePhaseSelectionRevda4 with get, set

Property Value

Type: Pcm1690Q1TypePhaseSelectionRevda4
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.PhaseSelectionREVDA5 Property

IRD

Pcm1690Q1PhaseSelectionREVDA5 Property

Phase Selection: REVDA5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypePhaseSelectionRevda5 PhaseSelectionREVDA5 { get; set; }
Public Property PhaseSelectionREVDA5 As Pcm1690Q1TypePhaseSelectionRevda5
    Get
    Set
public:
property Pcm1690Q1TypePhaseSelectionRevda5 PhaseSelectionREVDA5 {
    Pcm1690Q1TypePhaseSelectionRevda5 get ();
    void set (Pcm1690Q1TypePhaseSelectionRevda5 value);
}
member PhaseSelectionREVDA5 : Pcm1690Q1TypePhaseSelectionRevda5 with get, set

Property Value

Type: Pcm1690Q1TypePhaseSelectionRevda5
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.PhaseSelectionREVDA6 Property

IRD

Pcm1690Q1PhaseSelectionREVDA6 Property

Phase Selection: REVDA6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypePhaseSelectionRevda6 PhaseSelectionREVDA6 { get; set; }
Public Property PhaseSelectionREVDA6 As Pcm1690Q1TypePhaseSelectionRevda6
    Get
    Set
public:
property Pcm1690Q1TypePhaseSelectionRevda6 PhaseSelectionREVDA6 {
    Pcm1690Q1TypePhaseSelectionRevda6 get ();
    void set (Pcm1690Q1TypePhaseSelectionRevda6 value);
}
member PhaseSelectionREVDA6 : Pcm1690Q1TypePhaseSelectionRevda6 with get, set

Property Value

Type: Pcm1690Q1TypePhaseSelectionRevda6
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.PhaseSelectionREVDA7 Property

IRD

Pcm1690Q1PhaseSelectionREVDA7 Property

Phase Selection: REVDA7

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypePhaseSelectionRevda7 PhaseSelectionREVDA7 { get; set; }
Public Property PhaseSelectionREVDA7 As Pcm1690Q1TypePhaseSelectionRevda7
    Get
    Set
public:
property Pcm1690Q1TypePhaseSelectionRevda7 PhaseSelectionREVDA7 {
    Pcm1690Q1TypePhaseSelectionRevda7 get ();
    void set (Pcm1690Q1TypePhaseSelectionRevda7 value);
}
member PhaseSelectionREVDA7 : Pcm1690Q1TypePhaseSelectionRevda7 with get, set

Property Value

Type: Pcm1690Q1TypePhaseSelectionRevda7
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.PhaseSelectionREVDA8 Property

IRD

Pcm1690Q1PhaseSelectionREVDA8 Property

Phase Selection: REVDA8

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypePhaseSelectionRevda8 PhaseSelectionREVDA8 { get; set; }
Public Property PhaseSelectionREVDA8 As Pcm1690Q1TypePhaseSelectionRevda8
    Get
    Set
public:
property Pcm1690Q1TypePhaseSelectionRevda8 PhaseSelectionREVDA8 {
    Pcm1690Q1TypePhaseSelectionRevda8 get ();
    void set (Pcm1690Q1TypePhaseSelectionRevda8 value);
}
member PhaseSelectionREVDA8 : Pcm1690Q1TypePhaseSelectionRevda8 with get, set

Property Value

Type: Pcm1690Q1TypePhaseSelectionRevda8
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.ZeroFlagZERO1 Property

IRD

Pcm1690Q1ZeroFlagZERO1 Property

Zero Flag: ZERO1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeZeroFlagZero1 ZeroFlagZERO1 { get; }
Public ReadOnly Property ZeroFlagZERO1 As Pcm1690Q1TypeZeroFlagZero1
    Get
public:
property Pcm1690Q1TypeZeroFlagZero1 ZeroFlagZERO1 {
    Pcm1690Q1TypeZeroFlagZero1 get ();
}
member ZeroFlagZERO1 : Pcm1690Q1TypeZeroFlagZero1 with get

Property Value

Type: Pcm1690Q1TypeZeroFlagZero1
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.ZeroFlagZERO2 Property

IRD

Pcm1690Q1ZeroFlagZERO2 Property

Zero Flag: ZERO2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeZeroFlagZero2 ZeroFlagZERO2 { get; }
Public ReadOnly Property ZeroFlagZERO2 As Pcm1690Q1TypeZeroFlagZero2
    Get
public:
property Pcm1690Q1TypeZeroFlagZero2 ZeroFlagZERO2 {
    Pcm1690Q1TypeZeroFlagZero2 get ();
}
member ZeroFlagZERO2 : Pcm1690Q1TypeZeroFlagZero2 with get

Property Value

Type: Pcm1690Q1TypeZeroFlagZero2
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.ZeroFlagZERO3 Property

IRD

Pcm1690Q1ZeroFlagZERO3 Property

Zero Flag: ZERO3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeZeroFlagZero3 ZeroFlagZERO3 { get; }
Public ReadOnly Property ZeroFlagZERO3 As Pcm1690Q1TypeZeroFlagZero3
    Get
public:
property Pcm1690Q1TypeZeroFlagZero3 ZeroFlagZERO3 {
    Pcm1690Q1TypeZeroFlagZero3 get ();
}
member ZeroFlagZERO3 : Pcm1690Q1TypeZeroFlagZero3 with get

Property Value

Type: Pcm1690Q1TypeZeroFlagZero3
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.ZeroFlagZERO4 Property

IRD

Pcm1690Q1ZeroFlagZERO4 Property

Zero Flag: ZERO4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeZeroFlagZero4 ZeroFlagZERO4 { get; }
Public ReadOnly Property ZeroFlagZERO4 As Pcm1690Q1TypeZeroFlagZero4
    Get
public:
property Pcm1690Q1TypeZeroFlagZero4 ZeroFlagZERO4 {
    Pcm1690Q1TypeZeroFlagZero4 get ();
}
member ZeroFlagZERO4 : Pcm1690Q1TypeZeroFlagZero4 with get

Property Value

Type: Pcm1690Q1TypeZeroFlagZero4
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.ZeroFlagZERO5 Property

IRD

Pcm1690Q1ZeroFlagZERO5 Property

Zero Flag: ZERO5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeZeroFlagZero5 ZeroFlagZERO5 { get; }
Public ReadOnly Property ZeroFlagZERO5 As Pcm1690Q1TypeZeroFlagZero5
    Get
public:
property Pcm1690Q1TypeZeroFlagZero5 ZeroFlagZERO5 {
    Pcm1690Q1TypeZeroFlagZero5 get ();
}
member ZeroFlagZERO5 : Pcm1690Q1TypeZeroFlagZero5 with get

Property Value

Type: Pcm1690Q1TypeZeroFlagZero5
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.ZeroFlagZERO6 Property

IRD

Pcm1690Q1ZeroFlagZERO6 Property

Zero Flag: ZERO6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeZeroFlagZero6 ZeroFlagZERO6 { get; }
Public ReadOnly Property ZeroFlagZERO6 As Pcm1690Q1TypeZeroFlagZero6
    Get
public:
property Pcm1690Q1TypeZeroFlagZero6 ZeroFlagZERO6 {
    Pcm1690Q1TypeZeroFlagZero6 get ();
}
member ZeroFlagZERO6 : Pcm1690Q1TypeZeroFlagZero6 with get

Property Value

Type: Pcm1690Q1TypeZeroFlagZero6
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.ZeroFlagZERO7 Property

IRD

Pcm1690Q1ZeroFlagZERO7 Property

Zero Flag: ZERO7

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeZeroFlagZero7 ZeroFlagZERO7 { get; }
Public ReadOnly Property ZeroFlagZERO7 As Pcm1690Q1TypeZeroFlagZero7
    Get
public:
property Pcm1690Q1TypeZeroFlagZero7 ZeroFlagZERO7 {
    Pcm1690Q1TypeZeroFlagZero7 get ();
}
member ZeroFlagZERO7 : Pcm1690Q1TypeZeroFlagZero7 with get

Property Value

Type: Pcm1690Q1TypeZeroFlagZero7
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.ZeroFlagZERO8 Property

IRD

Pcm1690Q1ZeroFlagZERO8 Property

Zero Flag: ZERO8

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1690Q1TypeZeroFlagZero8 ZeroFlagZERO8 { get; }
Public ReadOnly Property ZeroFlagZERO8 As Pcm1690Q1TypeZeroFlagZero8
    Get
public:
property Pcm1690Q1TypeZeroFlagZero8 ZeroFlagZERO8 {
    Pcm1690Q1TypeZeroFlagZero8 get ();
}
member ZeroFlagZERO8 : Pcm1690Q1TypeZeroFlagZero8 with get

Property Value

Type: Pcm1690Q1TypeZeroFlagZero8
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1 Methods

The Pcm1690Q1 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.Flush Method

IRD

Pcm1690Q1Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcm1690Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeAttenuationModeDams Enumeration

IRD

Pcm1690Q1TypeAttenuationModeDams Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuationModeDams
Public Enumeration TypeAttenuationModeDams
public enum class TypeAttenuationModeDams
type TypeAttenuationModeDams
Members
Member name | Value | Description
DigitalAttenuationFineStep05DBStep0To63DBRange | 0 | Digital Attenuation: Fine Step (0.5 dB Step, 0 to -63 dB Range)
DigitalAttenuationWideStep1DBStep0To100DBRange | 1 | Digital Attenuation: Wide Step (1 dB Step, 0 to -100 dB Range)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeAttenuationModeDemp Enumeration

IRD

Pcm1690Q1TypeAttenuationModeDemp Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuationModeDemp
Public Enumeration TypeAttenuationModeDemp
public enum class TypeAttenuationModeDemp
type TypeAttenuationModeDemp
Members
Member name | Value | Description
DigitalSamplingRateDisabled | 0 | Digital Sampling Rate: Disabled
DigitalSamplingRate48KHz | 1 | Digital Sampling Rate: 48 kHz
DigitalSamplingRate441KHz | 2 | Digital Sampling Rate: 44.1 kHz
DigitalSamplingRate32KHz | 3 | Digital Sampling Rate: 32 kHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeAttenuationModeFlagPol Enumeration

IRD

Pcm1690Q1TypeAttenuationModeFlagPol Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuationModeFlagPol
Public Enumeration TypeAttenuationModeFlagPol
public enum class TypeAttenuationModeFlagPol
type TypeAttenuationModeFlagPol
Members
Member name | Value | Description
ZeroFlagPolarityHighForZeroDetect | 0 | Zero Flag Polarity: High For Zero Detect
ZeroFlagPolarityLowForZeroDetect | 1 | Zero Flag Polarity: Low For Zero Detect
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeAttenuationModeFlagSel Enumeration

IRD

Pcm1690Q1TypeAttenuationModeFlagSel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuationModeFlagSel
Public Enumeration TypeAttenuationModeFlagSel
public enum class TypeAttenuationModeFlagSel
type TypeAttenuationModeFlagSel
Members
Member name | Value | Description
ZERO1DATA1LeftChannelZERO2DATA1RightChannel | 0 | ZERO1 = DATA1 Left Channel / ZERO2 = DATA1 Right Channel
ZERO1DATA14ZERO2DATA14 | 1 | ZERO1 = DATA1-4 / ZERO2 = DATA1-4
ZERO1DATA4ZERO2DATA13 | 2 | ZERO1 = DATA4 / ZERO2 = DATA1-3
ZERO1DATA1ZERO2DATA24 | 3 | ZERO1 = DATA1 / ZERO2 = DATA2-4
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeModeControlAmute0 Enumeration

IRD

Pcm1690Q1TypeModeControlAmute0 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlAmute0
Public Enumeration TypeModeControlAmute0
public enum class TypeModeControlAmute0
type TypeModeControlAmute0
Members
Member name | Value | Description
AnalogMuteControlBySCKILostDisabled | 0 | Analog Mute Control By SCKI Lost: Disabled
AnalogMuteControlBySCKILostEnabled | 1 | Analog Mute Control By SCKI Lost: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeModeControlAmute1 Enumeration

IRD

Pcm1690Q1TypeModeControlAmute1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlAmute1
Public Enumeration TypeModeControlAmute1
public enum class TypeModeControlAmute1
type TypeModeControlAmute1
Members
Member name | Value | Description
AnalogMuteControlByAsynchronousDetectDisabled | 0 | Analog Mute Control By Asynchronous Detect: Disabled
AnalogMuteControlByAsynchronousDetectEnabled | 1 | Analog Mute Control By Asynchronous Detect: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeModeControlAmute2 Enumeration

IRD

Pcm1690Q1TypeModeControlAmute2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlAmute2
Public Enumeration TypeModeControlAmute2
public enum class TypeModeControlAmute2
type TypeModeControlAmute2
Members
Member name | Value | Description
AnalogMuteControlByZero1Zero2DetectDisabled | 0 | Analog Mute Control By Zero1, Zero2 Detect: Disabled
AnalogMuteControlByZero1Zero2DetectEnabled | 1 | Analog Mute Control By Zero1, Zero2 Detect: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeModeControlAmute3 Enumeration

IRD

Pcm1690Q1TypeModeControlAmute3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlAmute3
Public Enumeration TypeModeControlAmute3
public enum class TypeModeControlAmute3
type TypeModeControlAmute3
Members
Member name | Value | Description
AnalogMuteControlByDACDisableCommandDisabled | 0 | Analog Mute Control By DAC Disable Command: Disabled
AnalogMuteControlByDACDisableCommandEnabled | 1 | Analog Mute Control By DAC Disable Command: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeModeControlRegisterReset Enumeration

IRD

Pcm1690Q1TypeModeControlRegisterReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlRegisterReset
Public Enumeration TypeModeControlRegisterReset
public enum class TypeModeControlRegisterReset
type TypeModeControlRegisterReset
Members
Member name | Value | Description
ModeControlResetDefaultValue | 0 | Mode Control Reset: Default Value
ModeControlResetNormalOperation | 1 | Mode Control Reset: Normal Operation
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeModeControlSamplingMode Enumeration

IRD

Pcm1690Q1TypeModeControlSamplingMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlSamplingMode
Public Enumeration TypeModeControlSamplingMode
public enum class TypeModeControlSamplingMode
type TypeModeControlSamplingMode
Members
Member name | Value | Description
SamplingModeAuto | 0 | Sampling Mode: Auto
SamplingModeSingleRate | 1 | Sampling Mode: Single Rate
SamplingModeDualRate | 2 | Sampling Mode: Dual Rate
SamplingRateQuadRate | 3 | Sampling Rate: Quad Rate
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeModeControlSystemReset Enumeration

IRD

Pcm1690Q1TypeModeControlSystemReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlSystemReset
Public Enumeration TypeModeControlSystemReset
public enum class TypeModeControlSystemReset
type TypeModeControlSystemReset
Members
Member name | Value | Description
SystemResetReSynchronization | 0 | System Reset: Re-Synchronization
SystemResetNormalOperation | 1 | System Reset: Normal Operation
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeModeSelectionAudioFormat Enumeration

IRD

Pcm1690Q1TypeModeSelectionAudioFormat Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeSelectionAudioFormat
Public Enumeration TypeModeSelectionAudioFormat
public enum class TypeModeSelectionAudioFormat
type TypeModeSelectionAudioFormat
Members
Member name | Value | Description
Value_16202432BitI2SFormat | 0 | 16 / 20 / 24 / 32 Bit I2S Format
Value_16202432BitLeftJustifiedFormat | 1 | 16 / 20 / 24 / 32 Bit Left-Justified Format
Value_24BitRightJustifiedFormat | 2 | 24 Bit Right-Justified Format
Value_16BitRightJustifiedFormat | 3 | 16 Bit Right-Justified Format
Value_24BitI2SDSPFormat | 4 | 24 Bit I2S DSP Format
Value_24BitLeftJustifiedDSPFormat | 5 | 24 Bit Left-Justified DSP Format
Value_24BitI2STDMFormat | 6 | 24 Bit I2S TDM Format
Value_24BitLeftJustifiedTDMFormat | 7 | 24 Bit Left-Justified TDM Format
Value_24BitHighSpeedI2STDMFormat | 8 | 24 Bit High-Speed I2S TDM Format
Value_24BitHighSpeedLeftJustifiedTDMFormat | 9 | 24 Bit High-Speed Left-Justified TDM Format
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeModeSelectionPowerSave Enumeration

IRD

Pcm1690Q1TypeModeSelectionPowerSave Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeSelectionPowerSave
Public Enumeration TypeModeSelectionPowerSave
public enum class TypeModeSelectionPowerSave
type TypeModeSelectionPowerSave
Members
Member name | Value | Description
PowerSaveModeEnabled | 0 | Power Save Mode: Enabled
PowerSaveModeDisabled | 1 | Power Save Mode: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeMuteControlMutda1 Enumeration

IRD

Pcm1690Q1TypeMuteControlMutda1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMuteControlMutda1
Public Enumeration TypeMuteControlMutda1
public enum class TypeMuteControlMutda1
type TypeMuteControlMutda1
Members
Member name | Value | Description
DAC1MuteDisabled | 0 | DAC1: Mute Disabled
DAC1MuteEnabled | 1 | DAC1: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeMuteControlMutda2 Enumeration

IRD

Pcm1690Q1TypeMuteControlMutda2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMuteControlMutda2
Public Enumeration TypeMuteControlMutda2
public enum class TypeMuteControlMutda2
type TypeMuteControlMutda2
Members
Member name | Value | Description
DAC2MuteDisabled | 0 | DAC2: Mute Disabled
DAC2MuteEnabled | 1 | DAC2: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeMuteControlMutda3 Enumeration

IRD

Pcm1690Q1TypeMuteControlMutda3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMuteControlMutda3
Public Enumeration TypeMuteControlMutda3
public enum class TypeMuteControlMutda3
type TypeMuteControlMutda3
Members
Member name | Value | Description
DAC3MuteDisabled | 0 | DAC3: Mute Disabled
DAC3MuteEnabled | 1 | DAC3: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeMuteControlMutda4 Enumeration

IRD

Pcm1690Q1TypeMuteControlMutda4 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMuteControlMutda4
Public Enumeration TypeMuteControlMutda4
public enum class TypeMuteControlMutda4
type TypeMuteControlMutda4
Members
Member name | Value | Description
DAC4MuteDisabled | 0 | DAC4: Mute Disabled
DAC4MuteEnabled | 1 | DAC4: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeMuteControlMutda5 Enumeration

IRD

Pcm1690Q1TypeMuteControlMutda5 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMuteControlMutda5
Public Enumeration TypeMuteControlMutda5
public enum class TypeMuteControlMutda5
type TypeMuteControlMutda5
Members
Member name | Value | Description
DAC5MuteDisabled | 0 | DAC5: Mute Disabled
DAC5MuteEnabled | 1 | DAC5: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeMuteControlMutda6 Enumeration

IRD

Pcm1690Q1TypeMuteControlMutda6 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMuteControlMutda6
Public Enumeration TypeMuteControlMutda6
public enum class TypeMuteControlMutda6
type TypeMuteControlMutda6
Members
Member name | Value | Description
DAC6MuteDisabled | 0 | DAC6: Mute Disabled
DAC6MuteEnabled | 1 | DAC6: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeMuteControlMutda7 Enumeration

IRD

Pcm1690Q1TypeMuteControlMutda7 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMuteControlMutda7
Public Enumeration TypeMuteControlMutda7
public enum class TypeMuteControlMutda7
type TypeMuteControlMutda7
Members
Member name | Value | Description
DAC7MuteDisabled | 0 | DAC7: Mute Disabled
DAC7MuteEnabled | 1 | DAC7: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeMuteControlMutda8 Enumeration

IRD

Pcm1690Q1TypeMuteControlMutda8 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMuteControlMutda8
Public Enumeration TypeMuteControlMutda8
public enum class TypeMuteControlMutda8
type TypeMuteControlMutda8
Members
Member name | Value | Description
DAC8MuteDisabled | 0 | DAC8: Mute Disabled
DAC8MuteEnabled | 1 | DAC8: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeOperationControlFlt0 Enumeration

IRD

Pcm1690Q1TypeOperationControlFlt0 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlFlt0
Public Enumeration TypeOperationControlFlt0
public enum class TypeOperationControlFlt0
type TypeOperationControlFlt0
Members
Member name | Value | Description
DAC12SharpRollOff | 0 | DAC1/2: Sharp Roll-Off
DAC12SlowRollOff | 1 | DAC1/2: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeOperationControlFlt1 Enumeration

IRD

Pcm1690Q1TypeOperationControlFlt1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlFlt1
Public Enumeration TypeOperationControlFlt1
public enum class TypeOperationControlFlt1
type TypeOperationControlFlt1
Members
Member name | Value | Description
DAC34SharpRollOff | 0 | DAC3/4: Sharp Roll-Off
DAC34SlowRollOff | 1 | DAC3/4: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeOperationControlFlt2 Enumeration

IRD

Pcm1690Q1TypeOperationControlFlt2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlFlt2
Public Enumeration TypeOperationControlFlt2
public enum class TypeOperationControlFlt2
type TypeOperationControlFlt2
Members
Member name | Value | Description
DAC56SharpRollOff | 0 | DAC5/6: Sharp Roll-Off
DAC56SlowRollOff | 1 | DAC5/6: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeOperationControlFlt3 Enumeration

IRD

Pcm1690Q1TypeOperationControlFlt3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlFlt3
Public Enumeration TypeOperationControlFlt3
public enum class TypeOperationControlFlt3
type TypeOperationControlFlt3
Members
Member name | Value | Description
DAC78SharpRollOff | 0 | DAC7/8: Sharp Roll-Off
DAC78SlowRollOff | 1 | DAC7/8: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeOperationControlOpeda0 Enumeration

IRD

Pcm1690Q1TypeOperationControlOpeda0 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlOpeda0
Public Enumeration TypeOperationControlOpeda0
public enum class TypeOperationControlOpeda0
type TypeOperationControlOpeda0
Members
Member name | Value | Description
DAC12NormalOperation | 0 | DAC1/2: Normal Operation
DAC12OperationDisabledWithOrWithoutPowerSave | 1 | DAC1/2: Operation Disabled (With Or Without Power Save)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeOperationControlOpeda1 Enumeration

IRD

Pcm1690Q1TypeOperationControlOpeda1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlOpeda1
Public Enumeration TypeOperationControlOpeda1
public enum class TypeOperationControlOpeda1
type TypeOperationControlOpeda1
Members
Member name | Value | Description
DAC34NormalOperation | 0 | DAC3/4: Normal Operation
DAC34OperationDisabledWithOrWithoutPowerSave | 1 | DAC3/4: Operation Disabled (With Or Without Power Save)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeOperationControlOpeda2 Enumeration

IRD

Pcm1690Q1TypeOperationControlOpeda2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlOpeda2
Public Enumeration TypeOperationControlOpeda2
public enum class TypeOperationControlOpeda2
type TypeOperationControlOpeda2
Members
Member name | Value | Description
DAC56NormalOperation | 0 | DAC5/6: Normal Operation
DAC56OperationDisabledWithOrWithoutPowerSave | 1 | DAC5/6: Operation Disabled (With Or Without Power Save)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeOperationControlOpeda3 Enumeration

IRD

Pcm1690Q1TypeOperationControlOpeda3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlOpeda3
Public Enumeration TypeOperationControlOpeda3
public enum class TypeOperationControlOpeda3
type TypeOperationControlOpeda3
Members
Member name | Value | Description
DAC78NormalOperation | 0 | DAC7/8: Normal Operation
DAC78OperationDisabledWithOrWithoutPowerSave | 1 | DAC7/8: Operation Disabled (With Or Without Power Save)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypePhaseSelectionRevda1 Enumeration

IRD

Pcm1690Q1TypePhaseSelectionRevda1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePhaseSelectionRevda1
Public Enumeration TypePhaseSelectionRevda1
public enum class TypePhaseSelectionRevda1
type TypePhaseSelectionRevda1
Members
Member name | Value | Description
DAC1NormalOutput | 0 | DAC1: Normal Output
DAC1InvertedOutput | 1 | DAC1: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypePhaseSelectionRevda2 Enumeration

IRD

Pcm1690Q1TypePhaseSelectionRevda2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePhaseSelectionRevda2
Public Enumeration TypePhaseSelectionRevda2
public enum class TypePhaseSelectionRevda2
type TypePhaseSelectionRevda2
Members
Member name | Value | Description
DAC2NormalOutput | 0 | DAC2: Normal Output
DAC2InvertedOutput | 1 | DAC2: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypePhaseSelectionRevda3 Enumeration

IRD

Pcm1690Q1TypePhaseSelectionRevda3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePhaseSelectionRevda3
Public Enumeration TypePhaseSelectionRevda3
public enum class TypePhaseSelectionRevda3
type TypePhaseSelectionRevda3
Members
Member name | Value | Description
DAC3NormalOutput | 0 | DAC3: Normal Output
DAC3InvertedOutput | 1 | DAC3: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypePhaseSelectionRevda4 Enumeration

IRD

Pcm1690Q1TypePhaseSelectionRevda4 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePhaseSelectionRevda4
Public Enumeration TypePhaseSelectionRevda4
public enum class TypePhaseSelectionRevda4
type TypePhaseSelectionRevda4
Members
Member name | Value | Description
DAC4NormalOutput | 0 | DAC4: Normal Output
DAC4InvertedOutput | 1 | DAC4: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypePhaseSelectionRevda5 Enumeration

IRD

Pcm1690Q1TypePhaseSelectionRevda5 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePhaseSelectionRevda5
Public Enumeration TypePhaseSelectionRevda5
public enum class TypePhaseSelectionRevda5
type TypePhaseSelectionRevda5
Members
Member name | Value | Description
DAC5NormalOutput | 0 | DAC5: Normal Output
DAC5InvertedOutput | 1 | DAC5: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypePhaseSelectionRevda6 Enumeration

IRD

Pcm1690Q1TypePhaseSelectionRevda6 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePhaseSelectionRevda6
Public Enumeration TypePhaseSelectionRevda6
public enum class TypePhaseSelectionRevda6
type TypePhaseSelectionRevda6
Members
Member name | Value | Description
DAC6NormalOutput | 0 | DAC6: Normal Output
DAC6InvertedOutput | 1 | DAC6: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypePhaseSelectionRevda7 Enumeration

IRD

Pcm1690Q1TypePhaseSelectionRevda7 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePhaseSelectionRevda7
Public Enumeration TypePhaseSelectionRevda7
public enum class TypePhaseSelectionRevda7
type TypePhaseSelectionRevda7
Members
Member name | Value | Description
DAC7NormalOutput | 0 | DAC7: Normal Output
DAC7InvertedOutput | 1 | DAC7: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypePhaseSelectionRevda8 Enumeration

IRD

Pcm1690Q1TypePhaseSelectionRevda8 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePhaseSelectionRevda8
Public Enumeration TypePhaseSelectionRevda8
public enum class TypePhaseSelectionRevda8
type TypePhaseSelectionRevda8
Members
Member name | Value | Description
DAC8NormalOutput | 0 | DAC8: Normal Output
DAC8InvertedOutput | 1 | DAC8: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeZeroFlagZero1 Enumeration

IRD

Pcm1690Q1TypeZeroFlagZero1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroFlagZero1
Public Enumeration TypeZeroFlagZero1
public enum class TypeZeroFlagZero1
type TypeZeroFlagZero1
Members
Member name | Value | Description
DAC1ZeroInputNotDetected | 0 | DAC1: Zero Input Not Detected
DAC1ZeroInputDetected | 1 | DAC1: Zero Input Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeZeroFlagZero2 Enumeration

IRD

Pcm1690Q1TypeZeroFlagZero2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroFlagZero2
Public Enumeration TypeZeroFlagZero2
public enum class TypeZeroFlagZero2
type TypeZeroFlagZero2
Members
Member name | Value | Description
DAC2ZeroInputNotDetected | 0 | DAC2: Zero Input Not Detected
DAC2ZeroInputDetected | 1 | DAC2: Zero Input Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeZeroFlagZero3 Enumeration

IRD

Pcm1690Q1TypeZeroFlagZero3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroFlagZero3
Public Enumeration TypeZeroFlagZero3
public enum class TypeZeroFlagZero3
type TypeZeroFlagZero3
Members
Member name | Value | Description
DAC3ZeroInputNotDetected | 0 | DAC3: Zero Input Not Detected
DAC3ZeroInputDetected | 1 | DAC3: Zero Input Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeZeroFlagZero4 Enumeration

IRD

Pcm1690Q1TypeZeroFlagZero4 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroFlagZero4
Public Enumeration TypeZeroFlagZero4
public enum class TypeZeroFlagZero4
type TypeZeroFlagZero4
Members
Member name | Value | Description
DAC4ZeroInputNotDetected | 0 | DAC4: Zero Input Not Detected
DAC4ZeroInputDetected | 1 | DAC4: Zero Input Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeZeroFlagZero5 Enumeration

IRD

Pcm1690Q1TypeZeroFlagZero5 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroFlagZero5
Public Enumeration TypeZeroFlagZero5
public enum class TypeZeroFlagZero5
type TypeZeroFlagZero5
Members
Member name | Value | Description
DAC5ZeroInputNotDetected | 0 | DAC5: Zero Input Not Detected
DAC5ZeroInputDetected | 1 | DAC5: Zero Input Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeZeroFlagZero6 Enumeration

IRD

Pcm1690Q1TypeZeroFlagZero6 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroFlagZero6
Public Enumeration TypeZeroFlagZero6
public enum class TypeZeroFlagZero6
type TypeZeroFlagZero6
Members
Member name | Value | Description
DAC6ZeroInputNotDetected | 0 | DAC6: Zero Input Not Detected
DAC6ZeroInputDetected | 1 | DAC6: Zero Input Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeZeroFlagZero7 Enumeration

IRD

Pcm1690Q1TypeZeroFlagZero7 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroFlagZero7
Public Enumeration TypeZeroFlagZero7
public enum class TypeZeroFlagZero7
type TypeZeroFlagZero7
Members
Member name | Value | Description
DAC7ZeroInputNotDetected | 0 | DAC7: Zero Input Not Detected
DAC7ZeroInputDetected | 1 | DAC7: Zero Input Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1690Q1.TypeZeroFlagZero8 Enumeration

IRD

Pcm1690Q1TypeZeroFlagZero8 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroFlagZero8
Public Enumeration TypeZeroFlagZero8
public enum class TypeZeroFlagZero8
type TypeZeroFlagZero8
Members
Member name | Value | Description
DAC8ZeroInputNotDetected | 0 | DAC8: Zero Input Not Detected
DAC8ZeroInputDetected | 1 | DAC8: Zero Input Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774 Class

Texas Instruments: PCM 1774
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPcm1774

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcm1774
Public Class Pcm1774
public ref class Pcm1774
type Pcm1774 =  class end

The Pcm1774 type exposes the following members.

Constructors
 | Name | Description
Public method | Pcm1774 | Constructor
Top
Properties
 | Name | Description
Public property | AnalogGainGML | Analog Gain: GML (unit: dB)
Public property | AnalogGainGMR | Analog Gain: GMR (unit: dB)
Public property | AnalogInputPAIL | Analog Input: PAIL
Public property | AnalogInputPAIR | Analog Input: PAIR
Public property | AnalogOutputHPS | Analog Output: HPS
Public property | AnalogOutputPCOM | Analog Output: PCOM
Public property | AnalogSelectAIL0 | Analog Select: AIL0
Public property | AnalogSelectAIR0 | Analog Select: AIR0
Public property | AnalogSwitchMXL0 | Analog Switch: MXL0
Public property | AnalogSwitchMXL1 | Analog Switch: MXL1
Public property | AnalogSwitchMXL2 | Analog Switch: MXL2
Public property | AnalogSwitchMXR0 | Analog Switch: MXR0
Public property | AnalogSwitchMXR1 | Analog Switch: MXR1
Public property | AnalogSwitchMXR2 | Analog Switch: MXR2
Public property | AttenuationLCHATL | Attenuation L-CH: ATL (unit: dB)
Public property | AttenuationLCHPMUL | Attenuation L-CH: PMUL
Public property | AttenuationRCHATR | Attenuation R-CH: ATR (unit: dB)
Public property | AttenuationRCHPMUR | Attenuation R-CH: PMUR
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BassBoostLGA | Bass Boost: LGA (unit: dB)
Public property | BassBoostLPAE | Bass Boost: LPAE
Public property | BCKConfigurationMBST | BCK Configuration: MBST
Public property | BCKConfigurationMSR | BCK Configuration: MSR
Public property | BCKConfigurationZCRS | BCK Configuration: ZCRS
Public property | DigitalMixingMXEN | Digital Mixing: MXEN
Public property | HAPInsertionSDHL | HAP Insertion: SDHL
Public property | HPAInsertionSDHR | HPA Insertion: SDHR
Public property | MasterModeBIT0 | Master Mode: BIT0
Public property | MasterModeMSTR | Master Mode: MSTR
Public property | MiddleBoostMGA | Middle Boost: MGA (unit: dB)
Public property | OverSamplingDEM | Over Sampling: DEM
Public property | OverSamplingOVER | Over Sampling: OVER
Public property | OverSamplingPFM | Over Sampling: PFM
Public property | OverSamplingSPX | Over Sampling: SPX
Public property | PowerControlPBIS | Power Control: PBIS
Public property | PowerControlPDAL | Power Control: PDAL
Public property | PowerControlPDAR | Power Control: PDAR
Public property | PowerControlPHPL | Power Control: PHPL
Public property | PowerControlPHPR | Power Control: PHPR
Public property | PowerMixerPMXL | Power Mixer: PMXL
Public property | PowerMixerPMXR | Power Mixer: PMXR
Public property | ShutDownSTHL | Shut Down: STHL
Public property | ShutDownSTHR | Shut Down: STHR
Public property | SoundEffect3DEN | Sound Effect: 3DEN
Public property | SoundEffect3DP | Sound Effect: 3DP (unit: %)
Public property | SoundEffect3FL0 | Sound Effect: 3FL0
Public property | SystemResetLRPC | System Reset: LRPC
Public property | SystemResetNPR | System Reset: NPR
Public property | SystemResetSRST | System Reset: SRST
Public property | TimeControlPTM | Time Control: PTM
Public property | TimeControlRES | Time Control: RES
Public property | TrebleBoostHGA | Treble Boost: HGA (unit: dB)
Public property | VolumeLCHHLV | Volume L-CH: HLV (unit: dB)
Public property | VolumeLCHHMUL | Volume L-CH: HMUL
Public property | VolumeRCHHMUR | Volume R-CH: HMUR
Public property | VolumeRCHHRV | Volume R-CH: HRV (unit: dB)
Public property | XXBoostG12LG20L | XX Boost: G12L + G20L
Public property | XXBoostG12RG20R | XX Boost: G12R + G20R
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Power Stereo Audio DAC With Analog Mixing
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcm1774(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcm1774

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774 Properties

The Pcm1774 type exposes the following members.

Properties
 | Name | Description
Public property | AnalogGainGML | Analog Gain: GML (unit: dB)
Public property | AnalogGainGMR | Analog Gain: GMR (unit: dB)
Public property | AnalogInputPAIL | Analog Input: PAIL
Public property | AnalogInputPAIR | Analog Input: PAIR
Public property | AnalogOutputHPS | Analog Output: HPS
Public property | AnalogOutputPCOM | Analog Output: PCOM
Public property | AnalogSelectAIL0 | Analog Select: AIL0
Public property | AnalogSelectAIR0 | Analog Select: AIR0
Public property | AnalogSwitchMXL0 | Analog Switch: MXL0
Public property | AnalogSwitchMXL1 | Analog Switch: MXL1
Public property | AnalogSwitchMXL2 | Analog Switch: MXL2
Public property | AnalogSwitchMXR0 | Analog Switch: MXR0
Public property | AnalogSwitchMXR1 | Analog Switch: MXR1
Public property | AnalogSwitchMXR2 | Analog Switch: MXR2
Public property | AttenuationLCHATL | Attenuation L-CH: ATL (unit: dB)
Public property | AttenuationLCHPMUL | Attenuation L-CH: PMUL
Public property | AttenuationRCHATR | Attenuation R-CH: ATR (unit: dB)
Public property | AttenuationRCHPMUR | Attenuation R-CH: PMUR
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | BassBoostLGA | Bass Boost: LGA (unit: dB)
Public property | BassBoostLPAE | Bass Boost: LPAE
Public property | BCKConfigurationMBST | BCK Configuration: MBST
Public property | BCKConfigurationMSR | BCK Configuration: MSR
Public property | BCKConfigurationZCRS | BCK Configuration: ZCRS
Public property | DigitalMixingMXEN | Digital Mixing: MXEN
Public property | HAPInsertionSDHL | HAP Insertion: SDHL
Public property | HPAInsertionSDHR | HPA Insertion: SDHR
Public property | MasterModeBIT0 | Master Mode: BIT0
Public property | MasterModeMSTR | Master Mode: MSTR
Public property | MiddleBoostMGA | Middle Boost: MGA (unit: dB)
Public property | OverSamplingDEM | Over Sampling: DEM
Public property | OverSamplingOVER | Over Sampling: OVER
Public property | OverSamplingPFM | Over Sampling: PFM
Public property | OverSamplingSPX | Over Sampling: SPX
Public property | PowerControlPBIS | Power Control: PBIS
Public property | PowerControlPDAL | Power Control: PDAL
Public property | PowerControlPDAR | Power Control: PDAR
Public property | PowerControlPHPL | Power Control: PHPL
Public property | PowerControlPHPR | Power Control: PHPR
Public property | PowerMixerPMXL | Power Mixer: PMXL
Public property | PowerMixerPMXR | Power Mixer: PMXR
Public property | ShutDownSTHL | Shut Down: STHL
Public property | ShutDownSTHR | Shut Down: STHR
Public property | SoundEffect3DEN | Sound Effect: 3DEN
Public property | SoundEffect3DP | Sound Effect: 3DP (unit: %)
Public property | SoundEffect3FL0 | Sound Effect: 3FL0
Public property | SystemResetLRPC | System Reset: LRPC
Public property | SystemResetNPR | System Reset: NPR
Public property | SystemResetSRST | System Reset: SRST
Public property | TimeControlPTM | Time Control: PTM
Public property | TimeControlRES | Time Control: RES
Public property | TrebleBoostHGA | Treble Boost: HGA (unit: dB)
Public property | VolumeLCHHLV | Volume L-CH: HLV (unit: dB)
Public property | VolumeLCHHMUL | Volume L-CH: HMUL
Public property | VolumeRCHHMUR | Volume R-CH: HMUR
Public property | VolumeRCHHRV | Volume R-CH: HRV (unit: dB)
Public property | XXBoostG12LG20L | XX Boost: G12L + G20L
Public property | XXBoostG12RG20R | XX Boost: G12R + G20R
Top
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AnalogGainGML Property

IRD

Pcm1774AnalogGainGML Property

Analog Gain: GML (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AnalogGainGML { get; set; }
Public Property AnalogGainGML As Double
    Get
    Set
public:
property double AnalogGainGML {
    double get ();
    void set (double value);
}
member AnalogGainGML : float with get, set

Property Value

Type: Double
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AnalogGainGMR Property

IRD

Pcm1774AnalogGainGMR Property

Analog Gain: GMR (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double AnalogGainGMR { get; set; }
Public Property AnalogGainGMR As Double
    Get
    Set
public:
property double AnalogGainGMR {
    double get ();
    void set (double value);
}
member AnalogGainGMR : float with get, set

Property Value

Type: Double
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AnalogInputPAIL Property

IRD

Pcm1774AnalogInputPAIL Property

Analog Input: PAIL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeAnalogInputLeft AnalogInputPAIL { get; set; }
Public Property AnalogInputPAIL As Pcm1774TypeAnalogInputLeft
    Get
    Set
public:
property Pcm1774TypeAnalogInputLeft AnalogInputPAIL {
    Pcm1774TypeAnalogInputLeft get ();
    void set (Pcm1774TypeAnalogInputLeft value);
}
member AnalogInputPAIL : Pcm1774TypeAnalogInputLeft with get, set

Property Value

Type: Pcm1774TypeAnalogInputLeft
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AnalogInputPAIR Property

IRD

Pcm1774AnalogInputPAIR Property

Analog Input: PAIR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeAnalogInputRight AnalogInputPAIR { get; set; }
Public Property AnalogInputPAIR As Pcm1774TypeAnalogInputRight
    Get
    Set
public:
property Pcm1774TypeAnalogInputRight AnalogInputPAIR {
    Pcm1774TypeAnalogInputRight get ();
    void set (Pcm1774TypeAnalogInputRight value);
}
member AnalogInputPAIR : Pcm1774TypeAnalogInputRight with get, set

Property Value

Type: Pcm1774TypeAnalogInputRight
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AnalogOutputHPS Property

IRD

Pcm1774AnalogOutputHPS Property

Analog Output: HPS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeAnalogOutputHeadphone AnalogOutputHPS { get; set; }
Public Property AnalogOutputHPS As Pcm1774TypeAnalogOutputHeadphone
    Get
    Set
public:
property Pcm1774TypeAnalogOutputHeadphone AnalogOutputHPS {
    Pcm1774TypeAnalogOutputHeadphone get ();
    void set (Pcm1774TypeAnalogOutputHeadphone value);
}
member AnalogOutputHPS : Pcm1774TypeAnalogOutputHeadphone with get, set

Property Value

Type: Pcm1774TypeAnalogOutputHeadphone
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AnalogOutputPCOM Property

IRD

Pcm1774AnalogOutputPCOM Property

Analog Output: PCOM

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeAnalogOutputVcom AnalogOutputPCOM { get; set; }
Public Property AnalogOutputPCOM As Pcm1774TypeAnalogOutputVcom
    Get
    Set
public:
property Pcm1774TypeAnalogOutputVcom AnalogOutputPCOM {
    Pcm1774TypeAnalogOutputVcom get ();
    void set (Pcm1774TypeAnalogOutputVcom value);
}
member AnalogOutputPCOM : Pcm1774TypeAnalogOutputVcom with get, set

Property Value

Type: Pcm1774TypeAnalogOutputVcom
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AnalogSelectAIL0 Property

IRD

Pcm1774AnalogSelectAIL0 Property

Analog Select: AIL0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeAnalogSelectLeft AnalogSelectAIL0 { get; set; }
Public Property AnalogSelectAIL0 As Pcm1774TypeAnalogSelectLeft
    Get
    Set
public:
property Pcm1774TypeAnalogSelectLeft AnalogSelectAIL0 {
    Pcm1774TypeAnalogSelectLeft get ();
    void set (Pcm1774TypeAnalogSelectLeft value);
}
member AnalogSelectAIL0 : Pcm1774TypeAnalogSelectLeft with get, set

Property Value

Type: Pcm1774TypeAnalogSelectLeft
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AnalogSelectAIR0 Property

IRD

Pcm1774AnalogSelectAIR0 Property

Analog Select: AIR0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeAnalogSelectRight AnalogSelectAIR0 { get; set; }
Public Property AnalogSelectAIR0 As Pcm1774TypeAnalogSelectRight
    Get
    Set
public:
property Pcm1774TypeAnalogSelectRight AnalogSelectAIR0 {
    Pcm1774TypeAnalogSelectRight get ();
    void set (Pcm1774TypeAnalogSelectRight value);
}
member AnalogSelectAIR0 : Pcm1774TypeAnalogSelectRight with get, set

Property Value

Type: Pcm1774TypeAnalogSelectRight
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AnalogSwitchMXL0 Property

IRD

Pcm1774AnalogSwitchMXL0 Property

Analog Switch: MXL0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeAnalogSwitchMix0Left AnalogSwitchMXL0 { get; set; }
Public Property AnalogSwitchMXL0 As Pcm1774TypeAnalogSwitchMix0Left
    Get
    Set
public:
property Pcm1774TypeAnalogSwitchMix0Left AnalogSwitchMXL0 {
    Pcm1774TypeAnalogSwitchMix0Left get ();
    void set (Pcm1774TypeAnalogSwitchMix0Left value);
}
member AnalogSwitchMXL0 : Pcm1774TypeAnalogSwitchMix0Left with get, set

Property Value

Type: Pcm1774TypeAnalogSwitchMix0Left
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AnalogSwitchMXL1 Property

IRD

Pcm1774AnalogSwitchMXL1 Property

Analog Switch: MXL1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeAnalogSwitchMix1Left AnalogSwitchMXL1 { get; set; }
Public Property AnalogSwitchMXL1 As Pcm1774TypeAnalogSwitchMix1Left
    Get
    Set
public:
property Pcm1774TypeAnalogSwitchMix1Left AnalogSwitchMXL1 {
    Pcm1774TypeAnalogSwitchMix1Left get ();
    void set (Pcm1774TypeAnalogSwitchMix1Left value);
}
member AnalogSwitchMXL1 : Pcm1774TypeAnalogSwitchMix1Left with get, set

Property Value

Type: Pcm1774TypeAnalogSwitchMix1Left
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AnalogSwitchMXL2 Property

IRD

Pcm1774AnalogSwitchMXL2 Property

Analog Switch: MXL2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeAnalogSwitchMix2Left AnalogSwitchMXL2 { get; set; }
Public Property AnalogSwitchMXL2 As Pcm1774TypeAnalogSwitchMix2Left
    Get
    Set
public:
property Pcm1774TypeAnalogSwitchMix2Left AnalogSwitchMXL2 {
    Pcm1774TypeAnalogSwitchMix2Left get ();
    void set (Pcm1774TypeAnalogSwitchMix2Left value);
}
member AnalogSwitchMXL2 : Pcm1774TypeAnalogSwitchMix2Left with get, set

Property Value

Type: Pcm1774TypeAnalogSwitchMix2Left
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AnalogSwitchMXR0 Property

IRD

Pcm1774AnalogSwitchMXR0 Property

Analog Switch: MXR0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeAnalogSwitchMix0Right AnalogSwitchMXR0 { get; set; }
Public Property AnalogSwitchMXR0 As Pcm1774TypeAnalogSwitchMix0Right
    Get
    Set
public:
property Pcm1774TypeAnalogSwitchMix0Right AnalogSwitchMXR0 {
    Pcm1774TypeAnalogSwitchMix0Right get ();
    void set (Pcm1774TypeAnalogSwitchMix0Right value);
}
member AnalogSwitchMXR0 : Pcm1774TypeAnalogSwitchMix0Right with get, set

Property Value

Type: Pcm1774TypeAnalogSwitchMix0Right
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AnalogSwitchMXR1 Property

IRD

Pcm1774AnalogSwitchMXR1 Property

Analog Switch: MXR1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeAnalogSwitchMix1Right AnalogSwitchMXR1 { get; set; }
Public Property AnalogSwitchMXR1 As Pcm1774TypeAnalogSwitchMix1Right
    Get
    Set
public:
property Pcm1774TypeAnalogSwitchMix1Right AnalogSwitchMXR1 {
    Pcm1774TypeAnalogSwitchMix1Right get ();
    void set (Pcm1774TypeAnalogSwitchMix1Right value);
}
member AnalogSwitchMXR1 : Pcm1774TypeAnalogSwitchMix1Right with get, set

Property Value

Type: Pcm1774TypeAnalogSwitchMix1Right
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AnalogSwitchMXR2 Property

IRD

Pcm1774AnalogSwitchMXR2 Property

Analog Switch: MXR2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeAnalogSwitchMix2Right AnalogSwitchMXR2 { get; set; }
Public Property AnalogSwitchMXR2 As Pcm1774TypeAnalogSwitchMix2Right
    Get
    Set
public:
property Pcm1774TypeAnalogSwitchMix2Right AnalogSwitchMXR2 {
    Pcm1774TypeAnalogSwitchMix2Right get ();
    void set (Pcm1774TypeAnalogSwitchMix2Right value);
}
member AnalogSwitchMXR2 : Pcm1774TypeAnalogSwitchMix2Right with get, set

Property Value

Type: Pcm1774TypeAnalogSwitchMix2Right
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AttenuationLCHATL Property

IRD

Pcm1774AttenuationLCHATL Property

Attenuation L-CH: ATL (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeAttenuation AttenuationLCHATL { get; set; }
Public Property AttenuationLCHATL As Pcm1774TypeAttenuation
    Get
    Set
public:
property Pcm1774TypeAttenuation AttenuationLCHATL {
    Pcm1774TypeAttenuation get ();
    void set (Pcm1774TypeAttenuation value);
}
member AttenuationLCHATL : Pcm1774TypeAttenuation with get, set

Property Value

Type: Pcm1774TypeAttenuation
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AttenuationLCHPMUL Property

IRD

Pcm1774AttenuationLCHPMUL Property

Attenuation L-CH: PMUL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeAttenuationLchMuteLeft AttenuationLCHPMUL { get; set; }
Public Property AttenuationLCHPMUL As Pcm1774TypeAttenuationLchMuteLeft
    Get
    Set
public:
property Pcm1774TypeAttenuationLchMuteLeft AttenuationLCHPMUL {
    Pcm1774TypeAttenuationLchMuteLeft get ();
    void set (Pcm1774TypeAttenuationLchMuteLeft value);
}
member AttenuationLCHPMUL : Pcm1774TypeAttenuationLchMuteLeft with get, set

Property Value

Type: Pcm1774TypeAttenuationLchMuteLeft
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AttenuationRCHATR Property

IRD

Pcm1774AttenuationRCHATR Property

Attenuation R-CH: ATR (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeAttenuation AttenuationRCHATR { get; set; }
Public Property AttenuationRCHATR As Pcm1774TypeAttenuation
    Get
    Set
public:
property Pcm1774TypeAttenuation AttenuationRCHATR {
    Pcm1774TypeAttenuation get ();
    void set (Pcm1774TypeAttenuation value);
}
member AttenuationRCHATR : Pcm1774TypeAttenuation with get, set

Property Value

Type: Pcm1774TypeAttenuation
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AttenuationRCHPMUR Property

IRD

Pcm1774AttenuationRCHPMUR Property

Attenuation R-CH: PMUR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeAttenuationRchMuteRight AttenuationRCHPMUR { get; set; }
Public Property AttenuationRCHPMUR As Pcm1774TypeAttenuationRchMuteRight
    Get
    Set
public:
property Pcm1774TypeAttenuationRchMuteRight AttenuationRCHPMUR {
    Pcm1774TypeAttenuationRchMuteRight get ();
    void set (Pcm1774TypeAttenuationRchMuteRight value);
}
member AttenuationRCHPMUR : Pcm1774TypeAttenuationRchMuteRight with get, set

Property Value

Type: Pcm1774TypeAttenuationRchMuteRight
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.AutoFlush Property

IRD

Pcm1774AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.BassBoostLGA Property

IRD

Pcm1774BassBoostLGA Property

Bass Boost: LGA (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeBoostGain BassBoostLGA { get; set; }
Public Property BassBoostLGA As Pcm1774TypeBoostGain
    Get
    Set
public:
property Pcm1774TypeBoostGain BassBoostLGA {
    Pcm1774TypeBoostGain get ();
    void set (Pcm1774TypeBoostGain value);
}
member BassBoostLGA : Pcm1774TypeBoostGain with get, set

Property Value

Type: Pcm1774TypeBoostGain
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.BassBoostLPAE Property

IRD

Pcm1774BassBoostLPAE Property

Bass Boost: LPAE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeBassBoostAdjust BassBoostLPAE { get; set; }
Public Property BassBoostLPAE As Pcm1774TypeBassBoostAdjust
    Get
    Set
public:
property Pcm1774TypeBassBoostAdjust BassBoostLPAE {
    Pcm1774TypeBassBoostAdjust get ();
    void set (Pcm1774TypeBassBoostAdjust value);
}
member BassBoostLPAE : Pcm1774TypeBassBoostAdjust with get, set

Property Value

Type: Pcm1774TypeBassBoostAdjust
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.BCKConfigurationMBST Property

IRD

Pcm1774BCKConfigurationMBST Property

BCK Configuration: MBST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeBckConfigurationBck BCKConfigurationMBST { get; set; }
Public Property BCKConfigurationMBST As Pcm1774TypeBckConfigurationBck
    Get
    Set
public:
property Pcm1774TypeBckConfigurationBck BCKConfigurationMBST {
    Pcm1774TypeBckConfigurationBck get ();
    void set (Pcm1774TypeBckConfigurationBck value);
}
member BCKConfigurationMBST : Pcm1774TypeBckConfigurationBck with get, set

Property Value

Type: Pcm1774TypeBckConfigurationBck
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.BCKConfigurationMSR Property

IRD

Pcm1774BCKConfigurationMSR Property

BCK Configuration: MSR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte BCKConfigurationMSR { get; set; }
Public Property BCKConfigurationMSR As Byte
    Get
    Set
public:
property unsigned char BCKConfigurationMSR {
    unsigned char get ();
    void set (unsigned char value);
}
member BCKConfigurationMSR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.BCKConfigurationZCRS Property

IRD

Pcm1774BCKConfigurationZCRS Property

BCK Configuration: ZCRS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeBckConfigurationZero BCKConfigurationZCRS { get; set; }
Public Property BCKConfigurationZCRS As Pcm1774TypeBckConfigurationZero
    Get
    Set
public:
property Pcm1774TypeBckConfigurationZero BCKConfigurationZCRS {
    Pcm1774TypeBckConfigurationZero get ();
    void set (Pcm1774TypeBckConfigurationZero value);
}
member BCKConfigurationZCRS : Pcm1774TypeBckConfigurationZero with get, set

Property Value

Type: Pcm1774TypeBckConfigurationZero
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.DigitalMixingMXEN Property

IRD

Pcm1774DigitalMixingMXEN Property

Digital Mixing: MXEN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeDigitalMixingSelect DigitalMixingMXEN { get; set; }
Public Property DigitalMixingMXEN As Pcm1774TypeDigitalMixingSelect
    Get
    Set
public:
property Pcm1774TypeDigitalMixingSelect DigitalMixingMXEN {
    Pcm1774TypeDigitalMixingSelect get ();
    void set (Pcm1774TypeDigitalMixingSelect value);
}
member DigitalMixingMXEN : Pcm1774TypeDigitalMixingSelect with get, set

Property Value

Type: Pcm1774TypeDigitalMixingSelect
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.HAPInsertionSDHL Property

IRD

Pcm1774HAPInsertionSDHL Property

HAP Insertion: SDHL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeHpaInsertionLeft HAPInsertionSDHL { get; set; }
Public Property HAPInsertionSDHL As Pcm1774TypeHpaInsertionLeft
    Get
    Set
public:
property Pcm1774TypeHpaInsertionLeft HAPInsertionSDHL {
    Pcm1774TypeHpaInsertionLeft get ();
    void set (Pcm1774TypeHpaInsertionLeft value);
}
member HAPInsertionSDHL : Pcm1774TypeHpaInsertionLeft with get, set

Property Value

Type: Pcm1774TypeHpaInsertionLeft
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.HPAInsertionSDHR Property

IRD

Pcm1774HPAInsertionSDHR Property

HPA Insertion: SDHR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeHpaInsertionRight HPAInsertionSDHR { get; set; }
Public Property HPAInsertionSDHR As Pcm1774TypeHpaInsertionRight
    Get
    Set
public:
property Pcm1774TypeHpaInsertionRight HPAInsertionSDHR {
    Pcm1774TypeHpaInsertionRight get ();
    void set (Pcm1774TypeHpaInsertionRight value);
}
member HPAInsertionSDHR : Pcm1774TypeHpaInsertionRight with get, set

Property Value

Type: Pcm1774TypeHpaInsertionRight
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.MasterModeBIT0 Property

IRD

Pcm1774MasterModeBIT0 Property

Master Mode: BIT0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeMasterModeBit MasterModeBIT0 { get; set; }
Public Property MasterModeBIT0 As Pcm1774TypeMasterModeBit
    Get
    Set
public:
property Pcm1774TypeMasterModeBit MasterModeBIT0 {
    Pcm1774TypeMasterModeBit get ();
    void set (Pcm1774TypeMasterModeBit value);
}
member MasterModeBIT0 : Pcm1774TypeMasterModeBit with get, set

Property Value

Type: Pcm1774TypeMasterModeBit
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.MasterModeMSTR Property

IRD

Pcm1774MasterModeMSTR Property

Master Mode: MSTR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeMasterModeSelect MasterModeMSTR { get; set; }
Public Property MasterModeMSTR As Pcm1774TypeMasterModeSelect
    Get
    Set
public:
property Pcm1774TypeMasterModeSelect MasterModeMSTR {
    Pcm1774TypeMasterModeSelect get ();
    void set (Pcm1774TypeMasterModeSelect value);
}
member MasterModeMSTR : Pcm1774TypeMasterModeSelect with get, set

Property Value

Type: Pcm1774TypeMasterModeSelect
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.MiddleBoostMGA Property

IRD

Pcm1774MiddleBoostMGA Property

Middle Boost: MGA (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeBoostGain MiddleBoostMGA { get; set; }
Public Property MiddleBoostMGA As Pcm1774TypeBoostGain
    Get
    Set
public:
property Pcm1774TypeBoostGain MiddleBoostMGA {
    Pcm1774TypeBoostGain get ();
    void set (Pcm1774TypeBoostGain value);
}
member MiddleBoostMGA : Pcm1774TypeBoostGain with get, set

Property Value

Type: Pcm1774TypeBoostGain
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.OverSamplingDEM Property

IRD

Pcm1774OverSamplingDEM Property

Over Sampling: DEM

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeOverSamplingFilterSelect OverSamplingDEM { get; set; }
Public Property OverSamplingDEM As Pcm1774TypeOverSamplingFilterSelect
    Get
    Set
public:
property Pcm1774TypeOverSamplingFilterSelect OverSamplingDEM {
    Pcm1774TypeOverSamplingFilterSelect get ();
    void set (Pcm1774TypeOverSamplingFilterSelect value);
}
member OverSamplingDEM : Pcm1774TypeOverSamplingFilterSelect with get, set

Property Value

Type: Pcm1774TypeOverSamplingFilterSelect
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.OverSamplingOVER Property

IRD

Pcm1774OverSamplingOVER Property

Over Sampling: OVER

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeOverSamplingControl OverSamplingOVER { get; set; }
Public Property OverSamplingOVER As Pcm1774TypeOverSamplingControl
    Get
    Set
public:
property Pcm1774TypeOverSamplingControl OverSamplingOVER {
    Pcm1774TypeOverSamplingControl get ();
    void set (Pcm1774TypeOverSamplingControl value);
}
member OverSamplingOVER : Pcm1774TypeOverSamplingControl with get, set

Property Value

Type: Pcm1774TypeOverSamplingControl
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.OverSamplingPFM Property

IRD

Pcm1774OverSamplingPFM Property

Over Sampling: PFM

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeOverSamplingAudioSelect OverSamplingPFM { get; set; }
Public Property OverSamplingPFM As Pcm1774TypeOverSamplingAudioSelect
    Get
    Set
public:
property Pcm1774TypeOverSamplingAudioSelect OverSamplingPFM {
    Pcm1774TypeOverSamplingAudioSelect get ();
    void set (Pcm1774TypeOverSamplingAudioSelect value);
}
member OverSamplingPFM : Pcm1774TypeOverSamplingAudioSelect with get, set

Property Value

Type: Pcm1774TypeOverSamplingAudioSelect
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.OverSamplingSPX Property

IRD

Pcm1774OverSamplingSPX Property

Over Sampling: SPX

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeOverSamplingDigitalGain OverSamplingSPX { get; set; }
Public Property OverSamplingSPX As Pcm1774TypeOverSamplingDigitalGain
    Get
    Set
public:
property Pcm1774TypeOverSamplingDigitalGain OverSamplingSPX {
    Pcm1774TypeOverSamplingDigitalGain get ();
    void set (Pcm1774TypeOverSamplingDigitalGain value);
}
member OverSamplingSPX : Pcm1774TypeOverSamplingDigitalGain with get, set

Property Value

Type: Pcm1774TypeOverSamplingDigitalGain
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.PowerControlPBIS Property

IRD

Pcm1774PowerControlPBIS Property

Power Control: PBIS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypePowerControlBias PowerControlPBIS { get; set; }
Public Property PowerControlPBIS As Pcm1774TypePowerControlBias
    Get
    Set
public:
property Pcm1774TypePowerControlBias PowerControlPBIS {
    Pcm1774TypePowerControlBias get ();
    void set (Pcm1774TypePowerControlBias value);
}
member PowerControlPBIS : Pcm1774TypePowerControlBias with get, set

Property Value

Type: Pcm1774TypePowerControlBias
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.PowerControlPDAL Property

IRD

Pcm1774PowerControlPDAL Property

Power Control: PDAL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypePowerControlFilterLeft PowerControlPDAL { get; set; }
Public Property PowerControlPDAL As Pcm1774TypePowerControlFilterLeft
    Get
    Set
public:
property Pcm1774TypePowerControlFilterLeft PowerControlPDAL {
    Pcm1774TypePowerControlFilterLeft get ();
    void set (Pcm1774TypePowerControlFilterLeft value);
}
member PowerControlPDAL : Pcm1774TypePowerControlFilterLeft with get, set

Property Value

Type: Pcm1774TypePowerControlFilterLeft
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.PowerControlPDAR Property

IRD

Pcm1774PowerControlPDAR Property

Power Control: PDAR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypePowerControlFilterRight PowerControlPDAR { get; set; }
Public Property PowerControlPDAR As Pcm1774TypePowerControlFilterRight
    Get
    Set
public:
property Pcm1774TypePowerControlFilterRight PowerControlPDAR {
    Pcm1774TypePowerControlFilterRight get ();
    void set (Pcm1774TypePowerControlFilterRight value);
}
member PowerControlPDAR : Pcm1774TypePowerControlFilterRight with get, set

Property Value

Type: Pcm1774TypePowerControlFilterRight
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.PowerControlPHPL Property

IRD

Pcm1774PowerControlPHPL Property

Power Control: PHPL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypePowerControlHeadLeft PowerControlPHPL { get; set; }
Public Property PowerControlPHPL As Pcm1774TypePowerControlHeadLeft
    Get
    Set
public:
property Pcm1774TypePowerControlHeadLeft PowerControlPHPL {
    Pcm1774TypePowerControlHeadLeft get ();
    void set (Pcm1774TypePowerControlHeadLeft value);
}
member PowerControlPHPL : Pcm1774TypePowerControlHeadLeft with get, set

Property Value

Type: Pcm1774TypePowerControlHeadLeft
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.PowerControlPHPR Property

IRD

Pcm1774PowerControlPHPR Property

Power Control: PHPR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypePowerControlHeadRight PowerControlPHPR { get; set; }
Public Property PowerControlPHPR As Pcm1774TypePowerControlHeadRight
    Get
    Set
public:
property Pcm1774TypePowerControlHeadRight PowerControlPHPR {
    Pcm1774TypePowerControlHeadRight get ();
    void set (Pcm1774TypePowerControlHeadRight value);
}
member PowerControlPHPR : Pcm1774TypePowerControlHeadRight with get, set

Property Value

Type: Pcm1774TypePowerControlHeadRight
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.PowerMixerPMXL Property

IRD

Pcm1774PowerMixerPMXL Property

Power Mixer: PMXL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypePowerMixerLeft PowerMixerPMXL { get; set; }
Public Property PowerMixerPMXL As Pcm1774TypePowerMixerLeft
    Get
    Set
public:
property Pcm1774TypePowerMixerLeft PowerMixerPMXL {
    Pcm1774TypePowerMixerLeft get ();
    void set (Pcm1774TypePowerMixerLeft value);
}
member PowerMixerPMXL : Pcm1774TypePowerMixerLeft with get, set

Property Value

Type: Pcm1774TypePowerMixerLeft
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.PowerMixerPMXR Property

IRD

Pcm1774PowerMixerPMXR Property

Power Mixer: PMXR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypePowerMixerRight PowerMixerPMXR { get; set; }
Public Property PowerMixerPMXR As Pcm1774TypePowerMixerRight
    Get
    Set
public:
property Pcm1774TypePowerMixerRight PowerMixerPMXR {
    Pcm1774TypePowerMixerRight get ();
    void set (Pcm1774TypePowerMixerRight value);
}
member PowerMixerPMXR : Pcm1774TypePowerMixerRight with get, set

Property Value

Type: Pcm1774TypePowerMixerRight
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.ShutDownSTHL Property

IRD

Pcm1774ShutDownSTHL Property

Shut Down: STHL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeShutDownLeft ShutDownSTHL { get; set; }
Public Property ShutDownSTHL As Pcm1774TypeShutDownLeft
    Get
    Set
public:
property Pcm1774TypeShutDownLeft ShutDownSTHL {
    Pcm1774TypeShutDownLeft get ();
    void set (Pcm1774TypeShutDownLeft value);
}
member ShutDownSTHL : Pcm1774TypeShutDownLeft with get, set

Property Value

Type: Pcm1774TypeShutDownLeft
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.ShutDownSTHR Property

IRD

Pcm1774ShutDownSTHR Property

Shut Down: STHR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeShutDownRight ShutDownSTHR { get; set; }
Public Property ShutDownSTHR As Pcm1774TypeShutDownRight
    Get
    Set
public:
property Pcm1774TypeShutDownRight ShutDownSTHR {
    Pcm1774TypeShutDownRight get ();
    void set (Pcm1774TypeShutDownRight value);
}
member ShutDownSTHR : Pcm1774TypeShutDownRight with get, set

Property Value

Type: Pcm1774TypeShutDownRight
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.SoundEffect3DEN Property

IRD

Pcm1774SoundEffect3DEN Property

Sound Effect: 3DEN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeSoundEffectSelect SoundEffect3DEN { get; set; }
Public Property SoundEffect3DEN As Pcm1774TypeSoundEffectSelect
    Get
    Set
public:
property Pcm1774TypeSoundEffectSelect SoundEffect3DEN {
    Pcm1774TypeSoundEffectSelect get ();
    void set (Pcm1774TypeSoundEffectSelect value);
}
member SoundEffect3DEN : Pcm1774TypeSoundEffectSelect with get, set

Property Value

Type: Pcm1774TypeSoundEffectSelect
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.SoundEffect3DP Property

IRD

Pcm1774SoundEffect3DP Property

Sound Effect: 3DP (unit: %)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double SoundEffect3DP { get; set; }
Public Property SoundEffect3DP As Double
    Get
    Set
public:
property double SoundEffect3DP {
    double get ();
    void set (double value);
}
member SoundEffect3DP : float with get, set

Property Value

Type: Double
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.SoundEffect3FL0 Property

IRD

Pcm1774SoundEffect3FL0 Property

Sound Effect: 3FL0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeSoundEffectFilter SoundEffect3FL0 { get; set; }
Public Property SoundEffect3FL0 As Pcm1774TypeSoundEffectFilter
    Get
    Set
public:
property Pcm1774TypeSoundEffectFilter SoundEffect3FL0 {
    Pcm1774TypeSoundEffectFilter get ();
    void set (Pcm1774TypeSoundEffectFilter value);
}
member SoundEffect3FL0 : Pcm1774TypeSoundEffectFilter with get, set

Property Value

Type: Pcm1774TypeSoundEffectFilter
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.SystemResetLRPC Property

IRD

Pcm1774SystemResetLRPC Property

System Reset: LRPC

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeSystemResetPolarity SystemResetLRPC { get; set; }
Public Property SystemResetLRPC As Pcm1774TypeSystemResetPolarity
    Get
    Set
public:
property Pcm1774TypeSystemResetPolarity SystemResetLRPC {
    Pcm1774TypeSystemResetPolarity get ();
    void set (Pcm1774TypeSystemResetPolarity value);
}
member SystemResetLRPC : Pcm1774TypeSystemResetPolarity with get, set

Property Value

Type: Pcm1774TypeSystemResetPolarity
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.SystemResetNPR Property

IRD

Pcm1774SystemResetNPR Property

System Reset: NPR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte SystemResetNPR { get; set; }
Public Property SystemResetNPR As Byte
    Get
    Set
public:
property unsigned char SystemResetNPR {
    unsigned char get ();
    void set (unsigned char value);
}
member SystemResetNPR : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.SystemResetSRST Property

IRD

Pcm1774SystemResetSRST Property

System Reset: SRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeSystemResetSrst SystemResetSRST { get; set; }
Public Property SystemResetSRST As Pcm1774TypeSystemResetSrst
    Get
    Set
public:
property Pcm1774TypeSystemResetSrst SystemResetSRST {
    Pcm1774TypeSystemResetSrst get ();
    void set (Pcm1774TypeSystemResetSrst value);
}
member SystemResetSRST : Pcm1774TypeSystemResetSrst with get, set

Property Value

Type: Pcm1774TypeSystemResetSrst
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.TimeControlPTM Property

IRD

Pcm1774TimeControlPTM Property

Time Control: PTM

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeTimeControlPower TimeControlPTM { get; set; }
Public Property TimeControlPTM As Pcm1774TypeTimeControlPower
    Get
    Set
public:
property Pcm1774TypeTimeControlPower TimeControlPTM {
    Pcm1774TypeTimeControlPower get ();
    void set (Pcm1774TypeTimeControlPower value);
}
member TimeControlPTM : Pcm1774TypeTimeControlPower with get, set

Property Value

Type: Pcm1774TypeTimeControlPower
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.TimeControlRES Property

IRD

Pcm1774TimeControlRES Property

Time Control: RES

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeTimeControlResistor TimeControlRES { get; set; }
Public Property TimeControlRES As Pcm1774TypeTimeControlResistor
    Get
    Set
public:
property Pcm1774TypeTimeControlResistor TimeControlRES {
    Pcm1774TypeTimeControlResistor get ();
    void set (Pcm1774TypeTimeControlResistor value);
}
member TimeControlRES : Pcm1774TypeTimeControlResistor with get, set

Property Value

Type: Pcm1774TypeTimeControlResistor
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.TrebleBoostHGA Property

IRD

Pcm1774TrebleBoostHGA Property

Treble Boost: HGA (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeBoostGain TrebleBoostHGA { get; set; }
Public Property TrebleBoostHGA As Pcm1774TypeBoostGain
    Get
    Set
public:
property Pcm1774TypeBoostGain TrebleBoostHGA {
    Pcm1774TypeBoostGain get ();
    void set (Pcm1774TypeBoostGain value);
}
member TrebleBoostHGA : Pcm1774TypeBoostGain with get, set

Property Value

Type: Pcm1774TypeBoostGain
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.VolumeLCHHLV Property

IRD

Pcm1774VolumeLCHHLV Property

Volume L-CH: HLV (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeVolume VolumeLCHHLV { get; set; }
Public Property VolumeLCHHLV As Pcm1774TypeVolume
    Get
    Set
public:
property Pcm1774TypeVolume VolumeLCHHLV {
    Pcm1774TypeVolume get ();
    void set (Pcm1774TypeVolume value);
}
member VolumeLCHHLV : Pcm1774TypeVolume with get, set

Property Value

Type: Pcm1774TypeVolume
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.VolumeLCHHMUL Property

IRD

Pcm1774VolumeLCHHMUL Property

Volume L-CH: HMUL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeVolumeLchMuteLeft VolumeLCHHMUL { get; set; }
Public Property VolumeLCHHMUL As Pcm1774TypeVolumeLchMuteLeft
    Get
    Set
public:
property Pcm1774TypeVolumeLchMuteLeft VolumeLCHHMUL {
    Pcm1774TypeVolumeLchMuteLeft get ();
    void set (Pcm1774TypeVolumeLchMuteLeft value);
}
member VolumeLCHHMUL : Pcm1774TypeVolumeLchMuteLeft with get, set

Property Value

Type: Pcm1774TypeVolumeLchMuteLeft
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.VolumeRCHHMUR Property

IRD

Pcm1774VolumeRCHHMUR Property

Volume R-CH: HMUR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeVolumeRchMuteRight VolumeRCHHMUR { get; set; }
Public Property VolumeRCHHMUR As Pcm1774TypeVolumeRchMuteRight
    Get
    Set
public:
property Pcm1774TypeVolumeRchMuteRight VolumeRCHHMUR {
    Pcm1774TypeVolumeRchMuteRight get ();
    void set (Pcm1774TypeVolumeRchMuteRight value);
}
member VolumeRCHHMUR : Pcm1774TypeVolumeRchMuteRight with get, set

Property Value

Type: Pcm1774TypeVolumeRchMuteRight
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.VolumeRCHHRV Property

IRD

Pcm1774VolumeRCHHRV Property

Volume R-CH: HRV (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeVolume VolumeRCHHRV { get; set; }
Public Property VolumeRCHHRV As Pcm1774TypeVolume
    Get
    Set
public:
property Pcm1774TypeVolume VolumeRCHHRV {
    Pcm1774TypeVolume get ();
    void set (Pcm1774TypeVolume value);
}
member VolumeRCHHRV : Pcm1774TypeVolume with get, set

Property Value

Type: Pcm1774TypeVolume
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.XXBoostG12LG20L Property

IRD

Pcm1774XXBoostG12LG20L Property

XX Boost: G12L + G20L

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeXxBoostPg1 XXBoostG12LG20L { get; set; }
Public Property XXBoostG12LG20L As Pcm1774TypeXxBoostPg1
    Get
    Set
public:
property Pcm1774TypeXxBoostPg1 XXBoostG12LG20L {
    Pcm1774TypeXxBoostPg1 get ();
    void set (Pcm1774TypeXxBoostPg1 value);
}
member XXBoostG12LG20L : Pcm1774TypeXxBoostPg1 with get, set

Property Value

Type: Pcm1774TypeXxBoostPg1
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.XXBoostG12RG20R Property

IRD

Pcm1774XXBoostG12RG20R Property

XX Boost: G12R + G20R

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1774TypeXxBoostPg2 XXBoostG12RG20R { get; set; }
Public Property XXBoostG12RG20R As Pcm1774TypeXxBoostPg2
    Get
    Set
public:
property Pcm1774TypeXxBoostPg2 XXBoostG12RG20R {
    Pcm1774TypeXxBoostPg2 get ();
    void set (Pcm1774TypeXxBoostPg2 value);
}
member XXBoostG12RG20R : Pcm1774TypeXxBoostPg2 with get, set

Property Value

Type: Pcm1774TypeXxBoostPg2
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774 Methods

The Pcm1774 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.Flush Method

IRD

Pcm1774Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcm1774 Class
telos.Ird.TexasInstruments Namespace


Pcm1774.TypeAnalogInputLeft Enumeration

IRD

Pcm1774TypeAnalogInputLeft Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAnalogInputLeft
Public Enumeration TypeAnalogInputLeft
public enum class TypeAnalogInputLeft
type TypeAnalogInputLeft
Members
Member name | Value | Description
GainAmplifierLChannelInputPowerDown | 0 | Gain Amplifier L-Channel Input: Power Down
GainAmplifierLChannelInputPowerUp | 1 | Gain Amplifier L-Channel Input: Power Up
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeAnalogInputRight Enumeration

IRD

Pcm1774TypeAnalogInputRight Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAnalogInputRight
Public Enumeration TypeAnalogInputRight
public enum class TypeAnalogInputRight
type TypeAnalogInputRight
Members
Member name | Value | Description
GainAmplifierRChannelInputPowerDown | 0 | Gain Amplifier R-Channel Input: Power Down
GainAmplifierRChannelInputPowerUp | 1 | Gain Amplifier R-Channel Input: Power Up
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeAnalogOutputHeadphone Enumeration

IRD

Pcm1774TypeAnalogOutputHeadphone Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAnalogOutputHeadphone
Public Enumeration TypeAnalogOutputHeadphone
public enum class TypeAnalogOutputHeadphone
type TypeAnalogOutputHeadphone
Members
Member name | Value | Description
StereoOutput | 0 | Stereo Output
SingleMonauralOutput | 1 | Single Monaural Output
DifferentialMonauralOutput | 2 | Differential Monaural Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeAnalogOutputVcom Enumeration

IRD

Pcm1774TypeAnalogOutputVcom Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAnalogOutputVcom
Public Enumeration TypeAnalogOutputVcom
public enum class TypeAnalogOutputVcom
type TypeAnalogOutputVcom
Members
Member name | Value | Description
VcomPowerDown | 0 | Vcom: Power Down
VcomPowerUp | 1 | Vcom: Power Up
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeAnalogSelectLeft Enumeration

IRD

Pcm1774TypeAnalogSelectLeft Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAnalogSelectLeft
Public Enumeration TypeAnalogSelectLeft
public enum class TypeAnalogSelectLeft
type TypeAnalogSelectLeft
Members
Member name | Value | Description
AnalogInputLChannelDisconnected | 0 | Analog Input L-Channel: Disconnected
AnalogInputLChannelAIN1LConnected | 1 | Analog Input L-Channel: AIN1L Connected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeAnalogSelectRight Enumeration

IRD

Pcm1774TypeAnalogSelectRight Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAnalogSelectRight
Public Enumeration TypeAnalogSelectRight
public enum class TypeAnalogSelectRight
type TypeAnalogSelectRight
Members
Member name | Value | Description
AnalogInputRChannelDisconnected | 0 | Analog Input R-Channel: Disconnected
AnalogInputRChannelAIN1RConnected | 1 | Analog Input R-Channel: AIN1R Connected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeAnalogSwitchMix0Left Enumeration

IRD

Pcm1774TypeAnalogSwitchMix0Left Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAnalogSwitchMix0Left
Public Enumeration TypeAnalogSwitchMix0Left
public enum class TypeAnalogSwitchMix0Left
type TypeAnalogSwitchMix0Left
Members
Member name | Value | Description
MixingSW2ToMXLDisabled | 0 | Mixing SW2 To MXL: Disabled
MixingSW2ToMXLEnabled | 1 | Mixing SW2 To MXL: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeAnalogSwitchMix0Right Enumeration

IRD

Pcm1774TypeAnalogSwitchMix0Right Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAnalogSwitchMix0Right
Public Enumeration TypeAnalogSwitchMix0Right
public enum class TypeAnalogSwitchMix0Right
type TypeAnalogSwitchMix0Right
Members
Member name | Value | Description
MixingSW5ToMXRDisabled | 0 | Mixing SW5 To MXR: Disabled
MixingSW5ToMXREnabled | 1 | Mixing SW5 To MXR: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeAnalogSwitchMix1Left Enumeration

IRD

Pcm1774TypeAnalogSwitchMix1Left Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAnalogSwitchMix1Left
Public Enumeration TypeAnalogSwitchMix1Left
public enum class TypeAnalogSwitchMix1Left
type TypeAnalogSwitchMix1Left
Members
Member name | Value | Description
MixingSW1ToMXLDisabled | 0 | Mixing SW1 To MXL: Disabled
MixingSW1ToMXLEnabled | 1 | Mixing SW1 To MXL: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeAnalogSwitchMix1Right Enumeration

IRD

Pcm1774TypeAnalogSwitchMix1Right Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAnalogSwitchMix1Right
Public Enumeration TypeAnalogSwitchMix1Right
public enum class TypeAnalogSwitchMix1Right
type TypeAnalogSwitchMix1Right
Members
Member name | Value | Description
MixingSW4ToMXRDisabled | 0 | Mixing SW4 To MXR: Disabled
MixingSW4ToMXREnabled | 1 | Mixing SW4 To MXR: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeAnalogSwitchMix2Left Enumeration

IRD

Pcm1774TypeAnalogSwitchMix2Left Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAnalogSwitchMix2Left
Public Enumeration TypeAnalogSwitchMix2Left
public enum class TypeAnalogSwitchMix2Left
type TypeAnalogSwitchMix2Left
Members
Member name | Value | Description
MixingSW3ToMXLDisabled | 0 | Mixing SW3 To MXL: Disabled
MixingSW3ToMXLEnabled | 1 | Mixing SW3 To MXL: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeAnalogSwitchMix2Right Enumeration

IRD

Pcm1774TypeAnalogSwitchMix2Right Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAnalogSwitchMix2Right
Public Enumeration TypeAnalogSwitchMix2Right
public enum class TypeAnalogSwitchMix2Right
type TypeAnalogSwitchMix2Right
Members
Member name | Value | Description
MixingSW6ToMXRDisabled | 0 | Mixing SW6 To MXR: Disabled
MixingSW6ToMXREnabled | 1 | Mixing SW6 To MXR: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeAttenuation Enumeration

IRD

Pcm1774TypeAttenuation Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuation
Public Enumeration TypeAttenuation
public enum class TypeAttenuation
type TypeAttenuation
Members
Member name | Value | Description
Mute | 0 | Mute
Value_M_62 | 1 | -62
Value_M_61 | 2 | -61
Value_M_60 | 3 | -60
Value_M_59 | 4 | -59
Value_M_58 | 5 | -58
Value_M_57 | 6 | -57
Value_M_56 | 7 | -56
Value_M_55 | 8 | -55
Value_M_54 | 9 | -54
Value_M_53 | 10 | -53
Value_M_52 | 11 | -52
Value_M_51 | 12 | -51
Value_M_50 | 13 | -50
Value_M_49 | 14 | -49
Value_M_48 | 15 | -48
Value_M_47 | 16 | -47
Value_M_46 | 17 | -46
Value_M_45 | 18 | -45
Value_M_44 | 19 | -44
Value_M_43 | 20 | -43
Value_M_42 | 21 | -42
Value_M_41 | 22 | -41
Value_M_40 | 23 | -40
Value_M_39 | 24 | -39
Value_M_38 | 25 | -38
Value_M_37 | 26 | -37
Value_M_36 | 27 | -36
Value_M_35 | 28 | -35
Value_M_34 | 29 | -34
Value_M_33 | 30 | -33
Value_M_32 | 31 | -32
Value_M_31 | 32 | -31
Value_M_30 | 33 | -30
Value_M_29 | 34 | -29
Value_M_28 | 35 | -28
Value_M_27 | 36 | -27
Value_M_26 | 37 | -26
Value_M_25 | 38 | -25
Value_M_24 | 39 | -24
Value_M_23 | 40 | -23
Value_M_22 | 41 | -22
Value_M_21 | 42 | -21
Value_M_20 | 43 | -20
Value_M_19 | 44 | -19
Value_M_18 | 45 | -18
Value_M_17 | 46 | -17
Value_M_16 | 47 | -16
Value_M_15 | 48 | -15
Value_M_14 | 49 | -14
Value_M_13 | 50 | -13
Value_M_12 | 51 | -12
Value_M_11 | 52 | -11
Value_M_10 | 53 | -10
Value_M_9 | 54 | -9
Value_M_8 | 55 | -8
Value_M_7 | 56 | -7
Value_M_6 | 57 | -6
Value_M_5 | 58 | -5
Value_M_4 | 59 | -4
Value_M_3 | 60 | -3
Value_M_2 | 61 | -2
Value_M_1 | 62 | -1
Value_0 | 63 | 0
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeAttenuationLchMuteLeft Enumeration

IRD

Pcm1774TypeAttenuationLchMuteLeft Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuationLchMuteLeft
Public Enumeration TypeAttenuationLchMuteLeft
public enum class TypeAttenuationLchMuteLeft
type TypeAttenuationLchMuteLeft
Members
Member name | Value | Description
DACLChannelMuteDisabled | 0 | DAC L-Channel: Mute Disabled
DACLChannelMuteEnabled | 1 | DAC L-Channel: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeAttenuationRchMuteRight Enumeration

IRD

Pcm1774TypeAttenuationRchMuteRight Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuationRchMuteRight
Public Enumeration TypeAttenuationRchMuteRight
public enum class TypeAttenuationRchMuteRight
type TypeAttenuationRchMuteRight
Members
Member name | Value | Description
DACRChannelMuteDisabled | 0 | DAC R-Channel: Mute Disabled
DACRChannelMuteDisabled__1 | 1 | DAC R-Channel: Mute Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeBassBoostAdjust Enumeration

IRD

Pcm1774TypeBassBoostAdjust Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBassBoostAdjust
Public Enumeration TypeBassBoostAdjust
public enum class TypeBassBoostAdjust
type TypeBassBoostAdjust
Members
Member name | Value | Description
BassBoostGainControlDisabled | 0 | Bass Boost Gain Control: Disabled
BassBoostGainControlEnabled | 1 | Bass Boost Gain Control: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeBckConfigurationBck Enumeration

IRD

Pcm1774TypeBckConfigurationBck Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBckConfigurationBck
Public Enumeration TypeBckConfigurationBck
public enum class TypeBckConfigurationBck
type TypeBckConfigurationBck
Members
Member name | Value | Description
BCKOutputInMasterModeNormalMode | 0 | BCK Output In Master Mode: Normal Mode
BCKOutputInMasterModeBurstMode | 1 | BCK Output In Master Mode: Burst Mode
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeBckConfigurationZero Enumeration

IRD

Pcm1774TypeBckConfigurationZero Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBckConfigurationZero
Public Enumeration TypeBckConfigurationZero
public enum class TypeBckConfigurationZero
type TypeBckConfigurationZero
Members
Member name | Value | Description
ZeroCrossDetectorDisabled | 0 | Zero-Cross Detector: Disabled
ZeroCrossDetectorEnabled | 1 | Zero-Cross Detector: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeBoostGain Enumeration

IRD

Pcm1774TypeBoostGain Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeBoostGain
Public Enumeration TypeBoostGain
public enum class TypeBoostGain
type TypeBoostGain
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_12 | 3 | 12
Value_11 | 4 | 11
Value_10 | 5 | 10
Value_9 | 6 | 9
Value_8 | 7 | 8
Value_7 | 8 | 7
Value_6 | 9 | 6
Value_5 | 10 | 5
Value_4 | 11 | 4
Value_3 | 12 | 3
Value_2 | 13 | 2
Value_1 | 14 | 1
Value_0__1 | 15 | 0
Value_M_1 | 16 | -1
Value_M_2 | 17 | -2
Value_M_3 | 18 | -3
Value_M_4 | 19 | -4
Value_M_5 | 20 | -5
Value_M_6 | 21 | -6
Value_M_7 | 22 | -7
Value_M_8 | 23 | -8
Value_M_9 | 24 | -9
Value_M_10 | 25 | -10
Value_M_11 | 26 | -11
Value_M_12 | 27 | -12
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeDigitalMixingSelect Enumeration

IRD

Pcm1774TypeDigitalMixingSelect Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDigitalMixingSelect
Public Enumeration TypeDigitalMixingSelect
public enum class TypeDigitalMixingSelect
type TypeDigitalMixingSelect
Members
Member name | Value | Description
DigitalMixingSelectStereo | 0 | Digital Mixing Select: Stereo
DigitalMixingSelectMonauralMixing | 1 | Digital Mixing Select: Monaural Mixing
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeHpaInsertionLeft Enumeration

IRD

Pcm1774TypeHpaInsertionLeft Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHpaInsertionLeft
Public Enumeration TypeHpaInsertionLeft
public enum class TypeHpaInsertionLeft
type TypeHpaInsertionLeft
Members
Member name | Value | Description
ShortProtectionLChannelEnabled | 0 | Short Protection L-Channel: Enabled
ShortProtectionLChannelDisabled | 1 | Short Protection L-Channel: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeHpaInsertionRight Enumeration

IRD

Pcm1774TypeHpaInsertionRight Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeHpaInsertionRight
Public Enumeration TypeHpaInsertionRight
public enum class TypeHpaInsertionRight
type TypeHpaInsertionRight
Members
Member name | Value | Description
ShortProtectionRChannelEnabled | 0 | Short Protection R-Channel: Enabled
ShortProtectionRChannelDisabled | 1 | Short Protection R-Channel: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeMasterModeBit Enumeration

IRD

Pcm1774TypeMasterModeBit Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMasterModeBit
Public Enumeration TypeMasterModeBit
public enum class TypeMasterModeBit
type TypeMasterModeBit
Members
Member name | Value | Description
BitLengthSelectionForAudioInterface16Bit | 1 | Bit Length Selection For Audio Interface: 16 Bit
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeMasterModeSelect Enumeration

IRD

Pcm1774TypeMasterModeSelect Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMasterModeSelect
Public Enumeration TypeMasterModeSelect
public enum class TypeMasterModeSelect
type TypeMasterModeSelect
Members
Member name | Value | Description
SlaveAudioInterface | 0 | Slave Audio Interface
MasterAudioInterface | 1 | Master Audio Interface
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeOverSamplingAudioSelect Enumeration

IRD

Pcm1774TypeOverSamplingAudioSelect Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOverSamplingAudioSelect
Public Enumeration TypeOverSamplingAudioSelect
public enum class TypeOverSamplingAudioSelect
type TypeOverSamplingAudioSelect
Members
Member name | Value | Description
DACDigitalInputI2SFormat | 0 | DAC Digital Input: I2S Format
DACDigitalInputRightJustifiedFormat | 1 | DAC Digital Input: Right-Justified Format
DACDigitalInputLeftJustifiedFormat | 2 | DAC Digital Input: Left-Justified Format
DACDigitalInputDSPFormat | 3 | DAC Digital Input: DSP Format
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeOverSamplingControl Enumeration

IRD

Pcm1774TypeOverSamplingControl Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOverSamplingControl
Public Enumeration TypeOverSamplingControl
public enum class TypeOverSamplingControl
type TypeOverSamplingControl
Members
Member name | Value | Description
DACOversamplingRate128Fs | 0 | DAC Oversampling Rate: 128 fs
DACOversamplingRate192Fs256Fs384Fs | 1 | DAC Oversampling Rate: 192 fs, 256 fs, 384 fs
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeOverSamplingDigitalGain Enumeration

IRD

Pcm1774TypeOverSamplingDigitalGain Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOverSamplingDigitalGain
Public Enumeration TypeOverSamplingDigitalGain
public enum class TypeOverSamplingDigitalGain
type TypeOverSamplingDigitalGain
Members
Member name | Value | Description
DigitalGainControl0DB | 0 | Digital Gain Control: 0 dB
DigitalGainControl6DB | 1 | Digital Gain Control: 6 dB
DigitalGainControl12DB | 2 | Digital Gain Control: 12 dB
DigitalGainControl18DB | 3 | Digital Gain Control: 18 dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeOverSamplingFilterSelect Enumeration

IRD

Pcm1774TypeOverSamplingFilterSelect Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOverSamplingFilterSelect
Public Enumeration TypeOverSamplingFilterSelect
public enum class TypeOverSamplingFilterSelect
type TypeOverSamplingFilterSelect
Members
Member name | Value | Description
DeEmphasisFilterSelectionOff | 0 | De-Emphasis Filter Selection: Off
DeEmphasisFilterSelection32KHz | 1 | De-Emphasis Filter Selection: 32 kHz
DeEmphasisFilterSelection441KHz | 2 | De-Emphasis Filter Selection: 44.1 kHz
DeEmphasisFilterSelection48KHz | 3 | De-Emphasis Filter Selection: 48 kHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypePowerControlBias Enumeration

IRD

Pcm1774TypePowerControlBias Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerControlBias
Public Enumeration TypePowerControlBias
public enum class TypePowerControlBias
type TypePowerControlBias
Members
Member name | Value | Description
PowerControlForBiasPowerDown | 0 | Power Control For Bias: Power Down
PowerControlForBiasPowerUp | 1 | Power Control For Bias: Power Up
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypePowerControlFilterLeft Enumeration

IRD

Pcm1774TypePowerControlFilterLeft Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerControlFilterLeft
Public Enumeration TypePowerControlFilterLeft
public enum class TypePowerControlFilterLeft
type TypePowerControlFilterLeft
Members
Member name | Value | Description
PowerControlDACAndLChannelFilterPowerDown | 0 | Power Control DAC And L-Channel Filter: Power Down
PowerControlDACAndLChannelFilterPowerUp | 1 | Power Control DAC And L-Channel Filter: Power Up
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypePowerControlFilterRight Enumeration

IRD

Pcm1774TypePowerControlFilterRight Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerControlFilterRight
Public Enumeration TypePowerControlFilterRight
public enum class TypePowerControlFilterRight
type TypePowerControlFilterRight
Members
Member name | Value | Description
PowerControlDACAndRChannelFilterPowerDown | 0 | Power Control DAC And R-Channel Filter: Power Down
PowerControlDACAndRChannelFilterPowerUp | 1 | Power Control DAC And R-Channel Filter: Power Up
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypePowerControlHeadLeft Enumeration

IRD

Pcm1774TypePowerControlHeadLeft Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerControlHeadLeft
Public Enumeration TypePowerControlHeadLeft
public enum class TypePowerControlHeadLeft
type TypePowerControlHeadLeft
Members
Member name | Value | Description
PowerControlLineOrLChannelHeadphonePowerDown | 0 | Power Control Line Or L-Channel Headphone: Power Down
PowerControlLineOrLChannelHeadphonePowerUp | 1 | Power Control Line Or L-Channel Headphone: Power Up
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypePowerControlHeadRight Enumeration

IRD

Pcm1774TypePowerControlHeadRight Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerControlHeadRight
Public Enumeration TypePowerControlHeadRight
public enum class TypePowerControlHeadRight
type TypePowerControlHeadRight
Members
Member name | Value | Description
PowerControlLineOrRChannelHeadphonePowerDown | 0 | Power Control Line Or R-Channel Headphone: Power Down
PowerControlLineOrRChannelHeadphonePowerUp | 1 | Power Control Line Or R-Channel Headphone: Power Up
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypePowerMixerLeft Enumeration

IRD

Pcm1774TypePowerMixerLeft Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerMixerLeft
Public Enumeration TypePowerMixerLeft
public enum class TypePowerMixerLeft
type TypePowerMixerLeft
Members
Member name | Value | Description
PowerForLChannelMixerPowerDown | 0 | Power For L-Channel Mixer: Power Down
PowerForLChannelMixerPowerUp | 1 | Power For L-Channel Mixer: Power Up
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypePowerMixerRight Enumeration

IRD

Pcm1774TypePowerMixerRight Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePowerMixerRight
Public Enumeration TypePowerMixerRight
public enum class TypePowerMixerRight
type TypePowerMixerRight
Members
Member name | Value | Description
PowerForRChannelMixerPowerDown | 0 | Power For R-Channel Mixer: Power Down
PowerForRChannelMixerPowerUp | 1 | Power For R-Channel Mixer: Power Up
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeShutDownLeft Enumeration

IRD

Pcm1774TypeShutDownLeft Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeShutDownLeft
Public Enumeration TypeShutDownLeft
public enum class TypeShutDownLeft
type TypeShutDownLeft
Members
Member name | Value | Description
ShortProtectionStatusLChannelShortCircuitDetected | 0 | Short Protection Status L-Channel: Short Circuit Detected
ShortProtectionStatusLChannelShortCircuitNotDetected | 1 | Short Protection Status L-Channel: Short Circuit Not Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeShutDownRight Enumeration

IRD

Pcm1774TypeShutDownRight Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeShutDownRight
Public Enumeration TypeShutDownRight
public enum class TypeShutDownRight
type TypeShutDownRight
Members
Member name | Value | Description
ShortProtectionStatusRChannelShortCircuitDetected | 0 | Short Protection Status R-Channel: Short Circuit Detected
ShortProtectionStatusRChannelShortCircuitNotDetected | 1 | Short Protection Status R-Channel: Short Circuit Not Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeSoundEffectFilter Enumeration

IRD

Pcm1774TypeSoundEffectFilter Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSoundEffectFilter
Public Enumeration TypeSoundEffectFilter
public enum class TypeSoundEffectFilter
type TypeSoundEffectFilter
Members
Member name | Value | Description
Value_3DSoundFilterNarrow | 0 | 3-D Sound Filter: Narrow
Value_3DSoundFilterWide | 1 | 3-D Sound Filter: Wide
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeSoundEffectSelect Enumeration

IRD

Pcm1774TypeSoundEffectSelect Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSoundEffectSelect
Public Enumeration TypeSoundEffectSelect
public enum class TypeSoundEffectSelect
type TypeSoundEffectSelect
Members
Member name | Value | Description
Value_3DSoundEffectDisabled | 0 | 3-D Sound Effect: Disabled
Value_3DSoundEffectEnabled | 1 | 3-D Sound Effect: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeSystemResetPolarity Enumeration

IRD

Pcm1774TypeSystemResetPolarity Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSystemResetPolarity
Public Enumeration TypeSystemResetPolarity
public enum class TypeSystemResetPolarity
type TypeSystemResetPolarity
Members
Member name | Value | Description
LRCKPolarityNormal | 0 | LRCK Polarity: Normal
LRCKPolarityReverse | 1 | LRCK Polarity: Reverse
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeSystemResetSrst Enumeration

IRD

Pcm1774TypeSystemResetSrst Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSystemResetSrst
Public Enumeration TypeSystemResetSrst
public enum class TypeSystemResetSrst
type TypeSystemResetSrst
Members
Member name | Value | Description
SystemResetDisabled | 0 | System Reset: Disabled
SystemResetEnabled | 1 | System Reset: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeTimeControlPower Enumeration

IRD

Pcm1774TypeTimeControlPower Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimeControlPower
Public Enumeration TypeTimeControlPower
public enum class TypeTimeControlPower
type TypeTimeControlPower
Members
Member name | Value | Description
PowerUpTime450MsPowerDownTime750Ms | 0 | Power-Up Time: 450 ms / Power-Down Time: 750 ms
PowerUpTime250MsPowerDownTime400Ms | 1 | Power-Up Time: 250 ms / Power-Down Time: 400 ms
PowerUpTime100MsPowerDownTime300Ms | 2 | Power-Up Time: 100 ms / Power-Down Time: 300 ms
PowerUpTime900MsPowerDownTime1500Ms | 3 | Power-Up Time: 900 ms / Power-Down Time: 1500 ms
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeTimeControlResistor Enumeration

IRD

Pcm1774TypeTimeControlResistor Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTimeControlResistor
Public Enumeration TypeTimeControlResistor
public enum class TypeTimeControlResistor
type TypeTimeControlResistor
Members
Member name | Value | Description
VcomResistorValue60KOhm | 16 | Vcom Resistor Value: 60 kOhm
VcomResistorValue24KOhm | 24 | Vcom Resistor Value: 24 kOhm
VcomResistorValue12KOhm | 28 | Vcom Resistor Value: 12 kOhm
VcomResistorValue6KOhm | 30 | Vcom Resistor Value: 6 kOhm
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeVolume Enumeration

IRD

Pcm1774TypeVolume Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVolume
Public Enumeration TypeVolume
public enum class TypeVolume
type TypeVolume
Members
Member name | Value | Description
Value_M_70_0 | 0 | -70.0
Value_M_66_0 | 1 | -66.0
Value_M_62_0 | 2 | -62.0
Value_M_58_0 | 3 | -58.0
Value_M_54_0 | 4 | -54.0
Value_M_50_0 | 5 | -50.0
Value_M_46_0 | 6 | -46.0
Value_M_42_0 | 7 | -42.0
Value_M_40_0 | 8 | -40.0
Value_M_38_0 | 9 | -38.0
Value_M_36_0 | 10 | -36.0
Value_M_34_0 | 11 | -34.0
Value_M_32_0 | 12 | -32.0
Value_M_30_0 | 13 | -30.0
Value_M_28_0 | 14 | -28.0
Value_M_26_0 | 15 | -26.0
Value_M_24_0 | 16 | -24.0
Value_M_23_0 | 17 | -23.0
Value_M_22_0 | 18 | -22.0
Value_M_21_0 | 19 | -21.0
Value_M_20_0 | 20 | -20.0
Value_M_19_0 | 21 | -19.0
Value_M_18_0 | 22 | -18.0
Value_M_17_0 | 23 | -17.0
Value_M_16_0 | 24 | -16.0
Value_M_15_0 | 25 | -15.0
Value_M_14_0 | 26 | -14.0
Value_M_13_0 | 27 | -13.0
Value_M_12_0 | 28 | -12.0
Value_M_11_0 | 29 | -11.0
Value_M_10_5 | 30 | -10.5
Value_M_10_0 | 31 | -10.0
Value_M_9_5 | 32 | -9.5
Value_M_9_0 | 33 | -9.0
Value_M_8_5 | 34 | -8.5
Value_M_8_0 | 35 | -8.0
Value_M_7_5 | 36 | -7.5
Value_M_7_0 | 37 | -7.0
Value_M_6_5 | 38 | -6.5
Value_M_6_0 | 39 | -6.0
Value_M_5_5 | 40 | -5.5
Value_M_5_0 | 41 | -5.0
Value_M_4_5 | 42 | -4.5
Value_M_4_0 | 43 | -4.0
Value_M_3_5 | 44 | -3.5
Value_M_3_0 | 45 | -3.0
Value_M_2_5 | 46 | -2.5
Value_M_2_0 | 47 | -2.0
Value_M_1_5 | 48 | -1.5
Value_M_1_0 | 49 | -1.0
Value_M_0_5 | 50 | -0.5
Value_0_0 | 51 | 0.0
Value_0_5 | 52 | 0.5
Value_1_0 | 53 | 1.0
Value_1_5 | 54 | 1.5
Value_2_0 | 55 | 2.0
Value_2_5 | 56 | 2.5
Value_3_0 | 57 | 3.0
Value_3_5 | 58 | 3.5
Value_4_0 | 59 | 4.0
Value_4_5 | 60 | 4.5
Value_5_0 | 61 | 5.0
Value_5_5 | 62 | 5.5
Value_6_0 | 63 | 6.0
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeVolumeLchMuteLeft Enumeration

IRD

Pcm1774TypeVolumeLchMuteLeft Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVolumeLchMuteLeft
Public Enumeration TypeVolumeLchMuteLeft
public enum class TypeVolumeLchMuteLeft
type TypeVolumeLchMuteLeft
Members
Member name | Value | Description
LeftChannelMuteDisabled | 0 | Left Channel: Mute Disabled
LeftChannelMuteEnabled | 1 | Left Channel: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeVolumeRchMuteRight Enumeration

IRD

Pcm1774TypeVolumeRchMuteRight Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeVolumeRchMuteRight
Public Enumeration TypeVolumeRchMuteRight
public enum class TypeVolumeRchMuteRight
type TypeVolumeRchMuteRight
Members
Member name | Value | Description
RightChannelMuteDisabled | 0 | Right Channel: Mute Disabled
RightChannelMuteEnabled | 1 | Right Channel: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeXxBoostPg1 Enumeration

IRD

Pcm1774TypeXxBoostPg1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeXxBoostPg1
Public Enumeration TypeXxBoostPg1
public enum class TypeXxBoostPg1
type TypeXxBoostPg1
Members
Member name | Value | Description
PG1Gain0DB | 0 | PG1 Gain: 0 dB
PG1Gain20DB | 1 | PG1 Gain: 20 dB
PG1Gain12DB | 2 | PG1 Gain: 12 dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1774.TypeXxBoostPg2 Enumeration

IRD

Pcm1774TypeXxBoostPg2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeXxBoostPg2
Public Enumeration TypeXxBoostPg2
public enum class TypeXxBoostPg2
type TypeXxBoostPg2
Members
Member name | Value | Description
PG2Gain0DB | 0 | PG2 Gain: 0 dB
PG2Gain20DB | 1 | PG2 Gain: 20 dB
PG2Gain12DB | 2 | PG2 Gain: 12 dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1 Class

Texas Instruments: PCM 1789-Q1
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPcm1789Q1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcm1789Q1
Public Class Pcm1789Q1
public ref class Pcm1789Q1
type Pcm1789Q1 =  class end

The Pcm1789Q1 type exposes the following members.

Constructors
 | Name | Description
Public method | Pcm1789Q1 | Constructor
Top
Properties
 | Name | Description
Public property | Attenuation1ATDA1 | Attenuation1: ATDA1
Public property | Attenuation2ATDA2 | Attenuation2: ATDA2
Public property | AttenuationModeAZRO | Attenuation Mode: AZRO
Public property | AttenuationModeDAMS | Attenuation Mode: DAMS
Public property | AttenuationModeDEMP | Attenuation Mode: DEMP
Public property | AttenuationModeMZSEL | Attenuation Mode: MZSEL
Public property | AttenuationModeZREV | Attenuation Mode: ZREV
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ModeControlAMUTE0 | Mode Control: AMUTE0
Public property | ModeControlAMUTE1 | Mode Control: AMUTE1
Public property | ModeControlAMUTE2 | Mode Control: AMUTE2
Public property | ModeControlAMUTE3 | Mode Control: AMUTE3
Public property | ModeControlMRST | Mode Control: MRST
Public property | ModeControlSRDA | Mode Control: SRDA
Public property | ModeControlSRST | Mode Control: SRST
Public property | ModeSelectionFMTDA | Mode Selection: FMTDA
Public property | ModeSelectionPSMDA | Mode Selection: PSMDA
Public property | MuteControlMUTDA1 | Mute Control: MUTDA1
Public property | MuteControlMUTDA2 | Mute Control: MUTDA2
Public property | OperationControlFLT | Operation Control: FLT
Public property | OperationControlOPEDA | Operation Control: OPEDA
Public property | PhaseSelectionREVDA1 | Phase Selection: REVDA1
Public property | PhaseSelectionREVDA2 | Phase Selection: REVDA2
Public property | ZeroFlagZERO1 | Zero Flag: ZERO1
Public property | ZeroFlagZERO2 | Zero Flag: ZERO2
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Stereo Audio Digital-to-Analog Converter
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcm1789Q1(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcm1789Q1

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1 Properties

The Pcm1789Q1 type exposes the following members.

Properties
 | Name | Description
Public property | Attenuation1ATDA1 | Attenuation1: ATDA1
Public property | Attenuation2ATDA2 | Attenuation2: ATDA2
Public property | AttenuationModeAZRO | Attenuation Mode: AZRO
Public property | AttenuationModeDAMS | Attenuation Mode: DAMS
Public property | AttenuationModeDEMP | Attenuation Mode: DEMP
Public property | AttenuationModeMZSEL | Attenuation Mode: MZSEL
Public property | AttenuationModeZREV | Attenuation Mode: ZREV
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ModeControlAMUTE0 | Mode Control: AMUTE0
Public property | ModeControlAMUTE1 | Mode Control: AMUTE1
Public property | ModeControlAMUTE2 | Mode Control: AMUTE2
Public property | ModeControlAMUTE3 | Mode Control: AMUTE3
Public property | ModeControlMRST | Mode Control: MRST
Public property | ModeControlSRDA | Mode Control: SRDA
Public property | ModeControlSRST | Mode Control: SRST
Public property | ModeSelectionFMTDA | Mode Selection: FMTDA
Public property | ModeSelectionPSMDA | Mode Selection: PSMDA
Public property | MuteControlMUTDA1 | Mute Control: MUTDA1
Public property | MuteControlMUTDA2 | Mute Control: MUTDA2
Public property | OperationControlFLT | Operation Control: FLT
Public property | OperationControlOPEDA | Operation Control: OPEDA
Public property | PhaseSelectionREVDA1 | Phase Selection: REVDA1
Public property | PhaseSelectionREVDA2 | Phase Selection: REVDA2
Public property | ZeroFlagZERO1 | Zero Flag: ZERO1
Public property | ZeroFlagZERO2 | Zero Flag: ZERO2
Top
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.Attenuation1ATDA1 Property

IRD

Pcm1789Q1Attenuation1ATDA1 Property

Attenuation1: ATDA1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Attenuation1ATDA1 { get; set; }
Public Property Attenuation1ATDA1 As Byte
    Get
    Set
public:
property unsigned char Attenuation1ATDA1 {
    unsigned char get ();
    void set (unsigned char value);
}
member Attenuation1ATDA1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.Attenuation2ATDA2 Property

IRD

Pcm1789Q1Attenuation2ATDA2 Property

Attenuation2: ATDA2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Attenuation2ATDA2 { get; set; }
Public Property Attenuation2ATDA2 As Byte
    Get
    Set
public:
property unsigned char Attenuation2ATDA2 {
    unsigned char get ();
    void set (unsigned char value);
}
member Attenuation2ATDA2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.AttenuationModeAZRO Property

IRD

Pcm1789Q1AttenuationModeAZRO Property

Attenuation Mode: AZRO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeAttenuationModeFlagSel AttenuationModeAZRO { get; set; }
Public Property AttenuationModeAZRO As Pcm1789Q1TypeAttenuationModeFlagSel
    Get
    Set
public:
property Pcm1789Q1TypeAttenuationModeFlagSel AttenuationModeAZRO {
    Pcm1789Q1TypeAttenuationModeFlagSel get ();
    void set (Pcm1789Q1TypeAttenuationModeFlagSel value);
}
member AttenuationModeAZRO : Pcm1789Q1TypeAttenuationModeFlagSel with get, set

Property Value

Type: Pcm1789Q1TypeAttenuationModeFlagSel
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.AttenuationModeDAMS Property

IRD

Pcm1789Q1AttenuationModeDAMS Property

Attenuation Mode: DAMS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeAttenuationModeDams AttenuationModeDAMS { get; set; }
Public Property AttenuationModeDAMS As Pcm1789Q1TypeAttenuationModeDams
    Get
    Set
public:
property Pcm1789Q1TypeAttenuationModeDams AttenuationModeDAMS {
    Pcm1789Q1TypeAttenuationModeDams get ();
    void set (Pcm1789Q1TypeAttenuationModeDams value);
}
member AttenuationModeDAMS : Pcm1789Q1TypeAttenuationModeDams with get, set

Property Value

Type: Pcm1789Q1TypeAttenuationModeDams
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.AttenuationModeDEMP Property

IRD

Pcm1789Q1AttenuationModeDEMP Property

Attenuation Mode: DEMP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeAttenuationModeDemp AttenuationModeDEMP { get; set; }
Public Property AttenuationModeDEMP As Pcm1789Q1TypeAttenuationModeDemp
    Get
    Set
public:
property Pcm1789Q1TypeAttenuationModeDemp AttenuationModeDEMP {
    Pcm1789Q1TypeAttenuationModeDemp get ();
    void set (Pcm1789Q1TypeAttenuationModeDemp value);
}
member AttenuationModeDEMP : Pcm1789Q1TypeAttenuationModeDemp with get, set

Property Value

Type: Pcm1789Q1TypeAttenuationModeDemp
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.AttenuationModeMZSEL Property

IRD

Pcm1789Q1AttenuationModeMZSEL Property

Attenuation Mode: MZSEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeAttenuationModeAmute AttenuationModeMZSEL { get; set; }
Public Property AttenuationModeMZSEL As Pcm1789Q1TypeAttenuationModeAmute
    Get
    Set
public:
property Pcm1789Q1TypeAttenuationModeAmute AttenuationModeMZSEL {
    Pcm1789Q1TypeAttenuationModeAmute get ();
    void set (Pcm1789Q1TypeAttenuationModeAmute value);
}
member AttenuationModeMZSEL : Pcm1789Q1TypeAttenuationModeAmute with get, set

Property Value

Type: Pcm1789Q1TypeAttenuationModeAmute
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.AttenuationModeZREV Property

IRD

Pcm1789Q1AttenuationModeZREV Property

Attenuation Mode: ZREV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeAttenuationModeFlagPol AttenuationModeZREV { get; set; }
Public Property AttenuationModeZREV As Pcm1789Q1TypeAttenuationModeFlagPol
    Get
    Set
public:
property Pcm1789Q1TypeAttenuationModeFlagPol AttenuationModeZREV {
    Pcm1789Q1TypeAttenuationModeFlagPol get ();
    void set (Pcm1789Q1TypeAttenuationModeFlagPol value);
}
member AttenuationModeZREV : Pcm1789Q1TypeAttenuationModeFlagPol with get, set

Property Value

Type: Pcm1789Q1TypeAttenuationModeFlagPol
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.AutoFlush Property

IRD

Pcm1789Q1AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.ModeControlAMUTE0 Property

IRD

Pcm1789Q1ModeControlAMUTE0 Property

Mode Control: AMUTE0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeModeControlAmute0 ModeControlAMUTE0 { get; set; }
Public Property ModeControlAMUTE0 As Pcm1789Q1TypeModeControlAmute0
    Get
    Set
public:
property Pcm1789Q1TypeModeControlAmute0 ModeControlAMUTE0 {
    Pcm1789Q1TypeModeControlAmute0 get ();
    void set (Pcm1789Q1TypeModeControlAmute0 value);
}
member ModeControlAMUTE0 : Pcm1789Q1TypeModeControlAmute0 with get, set

Property Value

Type: Pcm1789Q1TypeModeControlAmute0
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.ModeControlAMUTE1 Property

IRD

Pcm1789Q1ModeControlAMUTE1 Property

Mode Control: AMUTE1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeModeControlAmute1 ModeControlAMUTE1 { get; set; }
Public Property ModeControlAMUTE1 As Pcm1789Q1TypeModeControlAmute1
    Get
    Set
public:
property Pcm1789Q1TypeModeControlAmute1 ModeControlAMUTE1 {
    Pcm1789Q1TypeModeControlAmute1 get ();
    void set (Pcm1789Q1TypeModeControlAmute1 value);
}
member ModeControlAMUTE1 : Pcm1789Q1TypeModeControlAmute1 with get, set

Property Value

Type: Pcm1789Q1TypeModeControlAmute1
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.ModeControlAMUTE2 Property

IRD

Pcm1789Q1ModeControlAMUTE2 Property

Mode Control: AMUTE2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeModeControlAmute2 ModeControlAMUTE2 { get; set; }
Public Property ModeControlAMUTE2 As Pcm1789Q1TypeModeControlAmute2
    Get
    Set
public:
property Pcm1789Q1TypeModeControlAmute2 ModeControlAMUTE2 {
    Pcm1789Q1TypeModeControlAmute2 get ();
    void set (Pcm1789Q1TypeModeControlAmute2 value);
}
member ModeControlAMUTE2 : Pcm1789Q1TypeModeControlAmute2 with get, set

Property Value

Type: Pcm1789Q1TypeModeControlAmute2
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.ModeControlAMUTE3 Property

IRD

Pcm1789Q1ModeControlAMUTE3 Property

Mode Control: AMUTE3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeModeControlAmute3 ModeControlAMUTE3 { get; set; }
Public Property ModeControlAMUTE3 As Pcm1789Q1TypeModeControlAmute3
    Get
    Set
public:
property Pcm1789Q1TypeModeControlAmute3 ModeControlAMUTE3 {
    Pcm1789Q1TypeModeControlAmute3 get ();
    void set (Pcm1789Q1TypeModeControlAmute3 value);
}
member ModeControlAMUTE3 : Pcm1789Q1TypeModeControlAmute3 with get, set

Property Value

Type: Pcm1789Q1TypeModeControlAmute3
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.ModeControlMRST Property

IRD

Pcm1789Q1ModeControlMRST Property

Mode Control: MRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeModeControlRegisterReset ModeControlMRST { get; set; }
Public Property ModeControlMRST As Pcm1789Q1TypeModeControlRegisterReset
    Get
    Set
public:
property Pcm1789Q1TypeModeControlRegisterReset ModeControlMRST {
    Pcm1789Q1TypeModeControlRegisterReset get ();
    void set (Pcm1789Q1TypeModeControlRegisterReset value);
}
member ModeControlMRST : Pcm1789Q1TypeModeControlRegisterReset with get, set

Property Value

Type: Pcm1789Q1TypeModeControlRegisterReset
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.ModeControlSRDA Property

IRD

Pcm1789Q1ModeControlSRDA Property

Mode Control: SRDA

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeModeControlSamplingMode ModeControlSRDA { get; set; }
Public Property ModeControlSRDA As Pcm1789Q1TypeModeControlSamplingMode
    Get
    Set
public:
property Pcm1789Q1TypeModeControlSamplingMode ModeControlSRDA {
    Pcm1789Q1TypeModeControlSamplingMode get ();
    void set (Pcm1789Q1TypeModeControlSamplingMode value);
}
member ModeControlSRDA : Pcm1789Q1TypeModeControlSamplingMode with get, set

Property Value

Type: Pcm1789Q1TypeModeControlSamplingMode
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.ModeControlSRST Property

IRD

Pcm1789Q1ModeControlSRST Property

Mode Control: SRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeModeControlSystemReset ModeControlSRST { get; set; }
Public Property ModeControlSRST As Pcm1789Q1TypeModeControlSystemReset
    Get
    Set
public:
property Pcm1789Q1TypeModeControlSystemReset ModeControlSRST {
    Pcm1789Q1TypeModeControlSystemReset get ();
    void set (Pcm1789Q1TypeModeControlSystemReset value);
}
member ModeControlSRST : Pcm1789Q1TypeModeControlSystemReset with get, set

Property Value

Type: Pcm1789Q1TypeModeControlSystemReset
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.ModeSelectionFMTDA Property

IRD

Pcm1789Q1ModeSelectionFMTDA Property

Mode Selection: FMTDA

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeModeSelectionAudioFormat ModeSelectionFMTDA { get; set; }
Public Property ModeSelectionFMTDA As Pcm1789Q1TypeModeSelectionAudioFormat
    Get
    Set
public:
property Pcm1789Q1TypeModeSelectionAudioFormat ModeSelectionFMTDA {
    Pcm1789Q1TypeModeSelectionAudioFormat get ();
    void set (Pcm1789Q1TypeModeSelectionAudioFormat value);
}
member ModeSelectionFMTDA : Pcm1789Q1TypeModeSelectionAudioFormat with get, set

Property Value

Type: Pcm1789Q1TypeModeSelectionAudioFormat
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.ModeSelectionPSMDA Property

IRD

Pcm1789Q1ModeSelectionPSMDA Property

Mode Selection: PSMDA

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeModeSelectionPowerSave ModeSelectionPSMDA { get; set; }
Public Property ModeSelectionPSMDA As Pcm1789Q1TypeModeSelectionPowerSave
    Get
    Set
public:
property Pcm1789Q1TypeModeSelectionPowerSave ModeSelectionPSMDA {
    Pcm1789Q1TypeModeSelectionPowerSave get ();
    void set (Pcm1789Q1TypeModeSelectionPowerSave value);
}
member ModeSelectionPSMDA : Pcm1789Q1TypeModeSelectionPowerSave with get, set

Property Value

Type: Pcm1789Q1TypeModeSelectionPowerSave
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.MuteControlMUTDA1 Property

IRD

Pcm1789Q1MuteControlMUTDA1 Property

Mute Control: MUTDA1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeMuteControlMutda1 MuteControlMUTDA1 { get; set; }
Public Property MuteControlMUTDA1 As Pcm1789Q1TypeMuteControlMutda1
    Get
    Set
public:
property Pcm1789Q1TypeMuteControlMutda1 MuteControlMUTDA1 {
    Pcm1789Q1TypeMuteControlMutda1 get ();
    void set (Pcm1789Q1TypeMuteControlMutda1 value);
}
member MuteControlMUTDA1 : Pcm1789Q1TypeMuteControlMutda1 with get, set

Property Value

Type: Pcm1789Q1TypeMuteControlMutda1
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.MuteControlMUTDA2 Property

IRD

Pcm1789Q1MuteControlMUTDA2 Property

Mute Control: MUTDA2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeMuteControlMutda2 MuteControlMUTDA2 { get; set; }
Public Property MuteControlMUTDA2 As Pcm1789Q1TypeMuteControlMutda2
    Get
    Set
public:
property Pcm1789Q1TypeMuteControlMutda2 MuteControlMUTDA2 {
    Pcm1789Q1TypeMuteControlMutda2 get ();
    void set (Pcm1789Q1TypeMuteControlMutda2 value);
}
member MuteControlMUTDA2 : Pcm1789Q1TypeMuteControlMutda2 with get, set

Property Value

Type: Pcm1789Q1TypeMuteControlMutda2
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.OperationControlFLT Property

IRD

Pcm1789Q1OperationControlFLT Property

Operation Control: FLT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeOperationControlFlt OperationControlFLT { get; set; }
Public Property OperationControlFLT As Pcm1789Q1TypeOperationControlFlt
    Get
    Set
public:
property Pcm1789Q1TypeOperationControlFlt OperationControlFLT {
    Pcm1789Q1TypeOperationControlFlt get ();
    void set (Pcm1789Q1TypeOperationControlFlt value);
}
member OperationControlFLT : Pcm1789Q1TypeOperationControlFlt with get, set

Property Value

Type: Pcm1789Q1TypeOperationControlFlt
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.OperationControlOPEDA Property

IRD

Pcm1789Q1OperationControlOPEDA Property

Operation Control: OPEDA

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeOperationControlOpeda OperationControlOPEDA { get; set; }
Public Property OperationControlOPEDA As Pcm1789Q1TypeOperationControlOpeda
    Get
    Set
public:
property Pcm1789Q1TypeOperationControlOpeda OperationControlOPEDA {
    Pcm1789Q1TypeOperationControlOpeda get ();
    void set (Pcm1789Q1TypeOperationControlOpeda value);
}
member OperationControlOPEDA : Pcm1789Q1TypeOperationControlOpeda with get, set

Property Value

Type: Pcm1789Q1TypeOperationControlOpeda
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.PhaseSelectionREVDA1 Property

IRD

Pcm1789Q1PhaseSelectionREVDA1 Property

Phase Selection: REVDA1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypePhaseSelectionRevda1 PhaseSelectionREVDA1 { get; set; }
Public Property PhaseSelectionREVDA1 As Pcm1789Q1TypePhaseSelectionRevda1
    Get
    Set
public:
property Pcm1789Q1TypePhaseSelectionRevda1 PhaseSelectionREVDA1 {
    Pcm1789Q1TypePhaseSelectionRevda1 get ();
    void set (Pcm1789Q1TypePhaseSelectionRevda1 value);
}
member PhaseSelectionREVDA1 : Pcm1789Q1TypePhaseSelectionRevda1 with get, set

Property Value

Type: Pcm1789Q1TypePhaseSelectionRevda1
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.PhaseSelectionREVDA2 Property

IRD

Pcm1789Q1PhaseSelectionREVDA2 Property

Phase Selection: REVDA2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypePhaseSelectionRevda2 PhaseSelectionREVDA2 { get; set; }
Public Property PhaseSelectionREVDA2 As Pcm1789Q1TypePhaseSelectionRevda2
    Get
    Set
public:
property Pcm1789Q1TypePhaseSelectionRevda2 PhaseSelectionREVDA2 {
    Pcm1789Q1TypePhaseSelectionRevda2 get ();
    void set (Pcm1789Q1TypePhaseSelectionRevda2 value);
}
member PhaseSelectionREVDA2 : Pcm1789Q1TypePhaseSelectionRevda2 with get, set

Property Value

Type: Pcm1789Q1TypePhaseSelectionRevda2
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.ZeroFlagZERO1 Property

IRD

Pcm1789Q1ZeroFlagZERO1 Property

Zero Flag: ZERO1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeZeroFlagZero1 ZeroFlagZERO1 { get; set; }
Public Property ZeroFlagZERO1 As Pcm1789Q1TypeZeroFlagZero1
    Get
    Set
public:
property Pcm1789Q1TypeZeroFlagZero1 ZeroFlagZERO1 {
    Pcm1789Q1TypeZeroFlagZero1 get ();
    void set (Pcm1789Q1TypeZeroFlagZero1 value);
}
member ZeroFlagZERO1 : Pcm1789Q1TypeZeroFlagZero1 with get, set

Property Value

Type: Pcm1789Q1TypeZeroFlagZero1
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.ZeroFlagZERO2 Property

IRD

Pcm1789Q1ZeroFlagZERO2 Property

Zero Flag: ZERO2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1789Q1TypeZeroFlagZero2 ZeroFlagZERO2 { get; set; }
Public Property ZeroFlagZERO2 As Pcm1789Q1TypeZeroFlagZero2
    Get
    Set
public:
property Pcm1789Q1TypeZeroFlagZero2 ZeroFlagZERO2 {
    Pcm1789Q1TypeZeroFlagZero2 get ();
    void set (Pcm1789Q1TypeZeroFlagZero2 value);
}
member ZeroFlagZERO2 : Pcm1789Q1TypeZeroFlagZero2 with get, set

Property Value

Type: Pcm1789Q1TypeZeroFlagZero2
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1 Methods

The Pcm1789Q1 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.Flush Method

IRD

Pcm1789Q1Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcm1789Q1 Class
telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeAttenuationModeAmute Enumeration

IRD

Pcm1789Q1TypeAttenuationModeAmute Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuationModeAmute
Public Enumeration TypeAttenuationModeAmute
public enum class TypeAttenuationModeAmute
type TypeAttenuationModeAmute
Members
Member name | Value | Description
TheZERO2PinWorksAsZERO2 | 0 | The ZERO2 Pin Works As ZERO2
TheZERO2PinWorksAsAMUTEO | 1 | The ZERO2 Pin Works As AMUTEO
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeAttenuationModeDams Enumeration

IRD

Pcm1789Q1TypeAttenuationModeDams Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuationModeDams
Public Enumeration TypeAttenuationModeDams
public enum class TypeAttenuationModeDams
type TypeAttenuationModeDams
Members
Member name | Value | Description
DigitalAttenuationFineStep05DBStep0To63DBRange | 0 | Digital Attenuation: Fine Step (0.5 dB Step, 0 to -63 dB Range)
DigitalAttenuationWideRange1DBStep0To100DBRange | 1 | Digital Attenuation: Wide Range (1 dB Step, 0 to -100 dB Range)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeAttenuationModeDemp Enumeration

IRD

Pcm1789Q1TypeAttenuationModeDemp Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuationModeDemp
Public Enumeration TypeAttenuationModeDemp
public enum class TypeAttenuationModeDemp
type TypeAttenuationModeDemp
Members
Member name | Value | Description
DigitalSamplingRateDisabled | 0 | Digital Sampling Rate: Disabled
DigitalSamplingRate48KHz | 1 | Digital Sampling Rate: 48 kHz
DigitalSamplingRate441KHz | 2 | Digital Sampling Rate: 44.1 kHz
DigitalSamplingRate32KHz | 3 | Digital Sampling Rate: 32 kHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeAttenuationModeFlagPol Enumeration

IRD

Pcm1789Q1TypeAttenuationModeFlagPol Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuationModeFlagPol
Public Enumeration TypeAttenuationModeFlagPol
public enum class TypeAttenuationModeFlagPol
type TypeAttenuationModeFlagPol
Members
Member name | Value | Description
ZeroFlagPolarityHighForZeroDetect | 0 | Zero Flag Polarity: High For Zero Detect
ZeroFlagPolarityLowForZeroDetect | 1 | Zero Flag Polarity: Low For Zero Detect
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeAttenuationModeFlagSel Enumeration

IRD

Pcm1789Q1TypeAttenuationModeFlagSel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuationModeFlagSel
Public Enumeration TypeAttenuationModeFlagSel
public enum class TypeAttenuationModeFlagSel
type TypeAttenuationModeFlagSel
Members
Member name | Value | Description
ZERO1LeftChannelZERO2RightChannel | 0 | ZERO1 = Left Channel / ZERO2 = Right Channel
ZERO1LeftOrRightChannelZERO2LeftAndRightChannel | 1 | ZERO1 = Left Or Right Channel / ZERO2 = Left And Right Channel
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeModeControlAmute0 Enumeration

IRD

Pcm1789Q1TypeModeControlAmute0 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlAmute0
Public Enumeration TypeModeControlAmute0
public enum class TypeModeControlAmute0
type TypeModeControlAmute0
Members
Member name | Value | Description
AnalogMuteControlBySCKIHaltDisabled | 0 | Analog Mute Control By SCKI Halt: Disabled
AnalogMuteControlBySCKIHaltEnabled | 1 | Analog Mute Control By SCKI Halt: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeModeControlAmute1 Enumeration

IRD

Pcm1789Q1TypeModeControlAmute1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlAmute1
Public Enumeration TypeModeControlAmute1
public enum class TypeModeControlAmute1
type TypeModeControlAmute1
Members
Member name | Value | Description
AnalogMuteControlByAsynchronousDetectDisabled | 0 | Analog Mute Control By Asynchronous Detect: Disabled
AnalogMuteControlByAsynchronousDetectEnabled | 1 | Analog Mute Control By Asynchronous Detect: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeModeControlAmute2 Enumeration

IRD

Pcm1789Q1TypeModeControlAmute2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlAmute2
Public Enumeration TypeModeControlAmute2
public enum class TypeModeControlAmute2
type TypeModeControlAmute2
Members
Member name | Value | Description
AnalogMuteControlByZero1Zero2DetectDisabled | 0 | Analog Mute Control By Zero1, Zero2 Detect: Disabled
AnalogMuteControlByZero1Zero2DetectEnabled | 1 | Analog Mute Control By Zero1, Zero2 Detect: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeModeControlAmute3 Enumeration

IRD

Pcm1789Q1TypeModeControlAmute3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlAmute3
Public Enumeration TypeModeControlAmute3
public enum class TypeModeControlAmute3
type TypeModeControlAmute3
Members
Member name | Value | Description
AnalogMuteControlByDACDisableCommandDisabled | 0 | Analog Mute Control By DAC Disable Command: Disabled
AnalogMuteControlByDACDisableCommandEnabled | 1 | Analog Mute Control By DAC Disable Command: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeModeControlRegisterReset Enumeration

IRD

Pcm1789Q1TypeModeControlRegisterReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlRegisterReset
Public Enumeration TypeModeControlRegisterReset
public enum class TypeModeControlRegisterReset
type TypeModeControlRegisterReset
Members
Member name | Value | Description
ModeControlResetDefaultValue | 0 | Mode Control Reset: Default Value
ModeControlResetNormalOperation | 1 | Mode Control Reset: Normal Operation
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeModeControlSamplingMode Enumeration

IRD

Pcm1789Q1TypeModeControlSamplingMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlSamplingMode
Public Enumeration TypeModeControlSamplingMode
public enum class TypeModeControlSamplingMode
type TypeModeControlSamplingMode
Members
Member name | Value | Description
SamplingModeAuto | 0 | Sampling Mode: Auto
SamplingModeSingleRate | 1 | Sampling Mode: Single Rate
SamplingModeDualRate | 2 | Sampling Mode: Dual Rate
SamplingRateQuadRate | 3 | Sampling Rate: Quad Rate
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeModeControlSystemReset Enumeration

IRD

Pcm1789Q1TypeModeControlSystemReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlSystemReset
Public Enumeration TypeModeControlSystemReset
public enum class TypeModeControlSystemReset
type TypeModeControlSystemReset
Members
Member name | Value | Description
SystemResetReSynchronization | 0 | System Reset: Re-Synchronization
SystemResetNormalOperation | 1 | System Reset: Normal Operation
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeModeSelectionAudioFormat Enumeration

IRD

Pcm1789Q1TypeModeSelectionAudioFormat Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeSelectionAudioFormat
Public Enumeration TypeModeSelectionAudioFormat
public enum class TypeModeSelectionAudioFormat
type TypeModeSelectionAudioFormat
Members
Member name | Value | Description
Value_16202432BitI2SFormat | 0 | 16 / 20 / 24 / 32 Bit I2S Format
Value_16202432BitLeftJustifiedFormat | 1 | 16 / 20 / 24 / 32 Bit Left-Justified Format
Value_24BitRightJustifiedFormat | 2 | 24 Bit Right-Justified Format
Value_16BitRightJustifiedFormat | 3 | 16 Bit Right-Justified Format
Value_24BitI2SDSPFormat | 4 | 24 Bit I2S DSP Format
Value_24BitLeftJustifiedDSPFormat | 5 | 24 Bit Left-Justified DSP Format
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeModeSelectionPowerSave Enumeration

IRD

Pcm1789Q1TypeModeSelectionPowerSave Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeSelectionPowerSave
Public Enumeration TypeModeSelectionPowerSave
public enum class TypeModeSelectionPowerSave
type TypeModeSelectionPowerSave
Members
Member name | Value | Description
PowerSaveModeEnabled | 0 | Power Save Mode: Enabled
PowerSaveModeDisabled | 1 | Power Save Mode: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeMuteControlMutda1 Enumeration

IRD

Pcm1789Q1TypeMuteControlMutda1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMuteControlMutda1
Public Enumeration TypeMuteControlMutda1
public enum class TypeMuteControlMutda1
type TypeMuteControlMutda1
Members
Member name | Value | Description
LeftChannelMuteDisabled | 0 | Left Channel: Mute Disabled
LeftChannelMuteEnabled | 1 | Left Channel: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeMuteControlMutda2 Enumeration

IRD

Pcm1789Q1TypeMuteControlMutda2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMuteControlMutda2
Public Enumeration TypeMuteControlMutda2
public enum class TypeMuteControlMutda2
type TypeMuteControlMutda2
Members
Member name | Value | Description
RightChannelMuteDisabled | 0 | Right Channel: Mute Disabled
RightChannelMuteEnabled | 1 | Right Channel: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeOperationControlFlt Enumeration

IRD

Pcm1789Q1TypeOperationControlFlt Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlFlt
Public Enumeration TypeOperationControlFlt
public enum class TypeOperationControlFlt
type TypeOperationControlFlt
Members
Member name | Value | Description
DigitalFilterSharpRollOff | 0 | Digital Filter: Sharp Roll-Off
DigitalFilterSlowRollOff | 1 | Digital Filter: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeOperationControlOpeda Enumeration

IRD

Pcm1789Q1TypeOperationControlOpeda Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlOpeda
Public Enumeration TypeOperationControlOpeda
public enum class TypeOperationControlOpeda
type TypeOperationControlOpeda
Members
Member name | Value | Description
DACNormalOperation | 0 | DAC: Normal Operation
DACOperationDisabledWithOrWithoutPowerSave | 1 | DAC: Operation Disabled (With Or Without Power Save)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypePhaseSelectionRevda1 Enumeration

IRD

Pcm1789Q1TypePhaseSelectionRevda1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePhaseSelectionRevda1
Public Enumeration TypePhaseSelectionRevda1
public enum class TypePhaseSelectionRevda1
type TypePhaseSelectionRevda1
Members
Member name | Value | Description
LeftChannelNormalOutput | 0 | Left Channel: Normal Output
LeftChannelInvertedOutput | 1 | Left Channel: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypePhaseSelectionRevda2 Enumeration

IRD

Pcm1789Q1TypePhaseSelectionRevda2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePhaseSelectionRevda2
Public Enumeration TypePhaseSelectionRevda2
public enum class TypePhaseSelectionRevda2
type TypePhaseSelectionRevda2
Members
Member name | Value | Description
RightChannelNormalOutput | 0 | Right Channel: Normal Output
RightChannelInvertedOutput | 1 | Right Channel: Inverted Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeZeroFlagZero1 Enumeration

IRD

Pcm1789Q1TypeZeroFlagZero1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroFlagZero1
Public Enumeration TypeZeroFlagZero1
public enum class TypeZeroFlagZero1
type TypeZeroFlagZero1
Members
Member name | Value | Description
LeftChannelZeroInputNotDetected | 0 | Left Channel: Zero Input Not Detected
LeftChannelZeroInputDetected | 1 | Left Channel: Zero Input Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1789Q1.TypeZeroFlagZero2 Enumeration

IRD

Pcm1789Q1TypeZeroFlagZero2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroFlagZero2
Public Enumeration TypeZeroFlagZero2
public enum class TypeZeroFlagZero2
type TypeZeroFlagZero2
Members
Member name | Value | Description
RightChannelZeroInputNotDetected | 0 | Right Channel: Zero Input Not Detected
RightChannelZeroInputDetected | 1 | Right Channel: Zero Input Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a Class

Texas Instruments: PCM 1791A
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPcm1791a

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcm1791a
Public Class Pcm1791a
public ref class Pcm1791a
type Pcm1791a =  class end

The Pcm1791a type exposes the following members.

Constructors
 | Name | Description
Public method | Pcm1791a | Constructor
Top
Properties
 | Name | Description
Public property | AttenuationLeftATL | Attenuation Left: ATL
Public property | AttenuationRightATR | Attenuation Right: ATR
Public property | AudioControlATLD | Audio Control: ATLD
Public property | AudioControlDME | Audio Control: DME
Public property | AudioControlDMF | Audio Control: DMF
Public property | AudioControlFMT | Audio Control: FMT
Public property | AudioControlMUTE | Audio Control: MUTE
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DeviceIDID | Device ID: ID
Public property | OperationControlATS | Operation Control: ATS
Public property | OperationControlFLT | Operation Control: FLT
Public property | OperationControlINZD | Operation Control: INZD
Public property | OperationControlOPE | Operation Control: OPE
Public property | OperationControlREV | Operation Control: REV
Public property | SignalControlCHSL | Signal Control: CHSL
Public property | SignalControlDFTH | Signal Control: DFTH
Public property | SignalControlDSD | Signal Control: DSD
Public property | SignalControlMONO | Signal Control: MONO
Public property | SignalControlOS | Signal Control: OS
Public property | SignalControlSRST | Signal Control: SRST
Public property | ZeroDetectionZFGL | Zero Detection: ZFGL
Public property | ZeroDetectionZFGR | Zero Detection: ZFGR
Public property | ZeroOutputDZ | Zero Output: DZ
Public property | ZeroOutputPCMZ | Zero Output: PCMZ
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Audio Stereo Digital-To-Analog Converter
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcm1791a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcm1791a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a Properties

The Pcm1791a type exposes the following members.

Properties
 | Name | Description
Public property | AttenuationLeftATL | Attenuation Left: ATL
Public property | AttenuationRightATR | Attenuation Right: ATR
Public property | AudioControlATLD | Audio Control: ATLD
Public property | AudioControlDME | Audio Control: DME
Public property | AudioControlDMF | Audio Control: DMF
Public property | AudioControlFMT | Audio Control: FMT
Public property | AudioControlMUTE | Audio Control: MUTE
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DeviceIDID | Device ID: ID
Public property | OperationControlATS | Operation Control: ATS
Public property | OperationControlFLT | Operation Control: FLT
Public property | OperationControlINZD | Operation Control: INZD
Public property | OperationControlOPE | Operation Control: OPE
Public property | OperationControlREV | Operation Control: REV
Public property | SignalControlCHSL | Signal Control: CHSL
Public property | SignalControlDFTH | Signal Control: DFTH
Public property | SignalControlDSD | Signal Control: DSD
Public property | SignalControlMONO | Signal Control: MONO
Public property | SignalControlOS | Signal Control: OS
Public property | SignalControlSRST | Signal Control: SRST
Public property | ZeroDetectionZFGL | Zero Detection: ZFGL
Public property | ZeroDetectionZFGR | Zero Detection: ZFGR
Public property | ZeroOutputDZ | Zero Output: DZ
Public property | ZeroOutputPCMZ | Zero Output: PCMZ
Top
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.AttenuationLeftATL Property

IRD

Pcm1791aAttenuationLeftATL Property

Attenuation Left: ATL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeAttenuationLevel AttenuationLeftATL { get; set; }
Public Property AttenuationLeftATL As Pcm1791aTypeAttenuationLevel
    Get
    Set
public:
property Pcm1791aTypeAttenuationLevel AttenuationLeftATL {
    Pcm1791aTypeAttenuationLevel get ();
    void set (Pcm1791aTypeAttenuationLevel value);
}
member AttenuationLeftATL : Pcm1791aTypeAttenuationLevel with get, set

Property Value

Type: Pcm1791aTypeAttenuationLevel
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.AttenuationRightATR Property

IRD

Pcm1791aAttenuationRightATR Property

Attenuation Right: ATR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeAttenuationLevel AttenuationRightATR { get; set; }
Public Property AttenuationRightATR As Pcm1791aTypeAttenuationLevel
    Get
    Set
public:
property Pcm1791aTypeAttenuationLevel AttenuationRightATR {
    Pcm1791aTypeAttenuationLevel get ();
    void set (Pcm1791aTypeAttenuationLevel value);
}
member AttenuationRightATR : Pcm1791aTypeAttenuationLevel with get, set

Property Value

Type: Pcm1791aTypeAttenuationLevel
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.AudioControlATLD Property

IRD

Pcm1791aAudioControlATLD Property

Audio Control: ATLD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeAudioControlAttenuationLoad AudioControlATLD { get; set; }
Public Property AudioControlATLD As Pcm1791aTypeAudioControlAttenuationLoad
    Get
    Set
public:
property Pcm1791aTypeAudioControlAttenuationLoad AudioControlATLD {
    Pcm1791aTypeAudioControlAttenuationLoad get ();
    void set (Pcm1791aTypeAudioControlAttenuationLoad value);
}
member AudioControlATLD : Pcm1791aTypeAudioControlAttenuationLoad with get, set

Property Value

Type: Pcm1791aTypeAudioControlAttenuationLoad
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.AudioControlDME Property

IRD

Pcm1791aAudioControlDME Property

Audio Control: DME

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeAudioControlDeEmphasis AudioControlDME { get; set; }
Public Property AudioControlDME As Pcm1791aTypeAudioControlDeEmphasis
    Get
    Set
public:
property Pcm1791aTypeAudioControlDeEmphasis AudioControlDME {
    Pcm1791aTypeAudioControlDeEmphasis get ();
    void set (Pcm1791aTypeAudioControlDeEmphasis value);
}
member AudioControlDME : Pcm1791aTypeAudioControlDeEmphasis with get, set

Property Value

Type: Pcm1791aTypeAudioControlDeEmphasis
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.AudioControlDMF Property

IRD

Pcm1791aAudioControlDMF Property

Audio Control: DMF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeAudioControlSampling AudioControlDMF { get; set; }
Public Property AudioControlDMF As Pcm1791aTypeAudioControlSampling
    Get
    Set
public:
property Pcm1791aTypeAudioControlSampling AudioControlDMF {
    Pcm1791aTypeAudioControlSampling get ();
    void set (Pcm1791aTypeAudioControlSampling value);
}
member AudioControlDMF : Pcm1791aTypeAudioControlSampling with get, set

Property Value

Type: Pcm1791aTypeAudioControlSampling
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.AudioControlFMT Property

IRD

Pcm1791aAudioControlFMT Property

Audio Control: FMT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeAudioControlDataFormat AudioControlFMT { get; set; }
Public Property AudioControlFMT As Pcm1791aTypeAudioControlDataFormat
    Get
    Set
public:
property Pcm1791aTypeAudioControlDataFormat AudioControlFMT {
    Pcm1791aTypeAudioControlDataFormat get ();
    void set (Pcm1791aTypeAudioControlDataFormat value);
}
member AudioControlFMT : Pcm1791aTypeAudioControlDataFormat with get, set

Property Value

Type: Pcm1791aTypeAudioControlDataFormat
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.AudioControlMUTE Property

IRD

Pcm1791aAudioControlMUTE Property

Audio Control: MUTE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeAudioControlMute AudioControlMUTE { get; set; }
Public Property AudioControlMUTE As Pcm1791aTypeAudioControlMute
    Get
    Set
public:
property Pcm1791aTypeAudioControlMute AudioControlMUTE {
    Pcm1791aTypeAudioControlMute get ();
    void set (Pcm1791aTypeAudioControlMute value);
}
member AudioControlMUTE : Pcm1791aTypeAudioControlMute with get, set

Property Value

Type: Pcm1791aTypeAudioControlMute
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.AutoFlush Property

IRD

Pcm1791aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.DeviceIDID Property

IRD

Pcm1791aDeviceIDID Property

Device ID: ID

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceIDID { get; }
Public ReadOnly Property DeviceIDID As Byte
    Get
public:
property unsigned char DeviceIDID {
    unsigned char get ();
}
member DeviceIDID : byte with get

Property Value

Type: Byte
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.OperationControlATS Property

IRD

Pcm1791aOperationControlATS Property

Operation Control: ATS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeOperationControlRate OperationControlATS { get; set; }
Public Property OperationControlATS As Pcm1791aTypeOperationControlRate
    Get
    Set
public:
property Pcm1791aTypeOperationControlRate OperationControlATS {
    Pcm1791aTypeOperationControlRate get ();
    void set (Pcm1791aTypeOperationControlRate value);
}
member OperationControlATS : Pcm1791aTypeOperationControlRate with get, set

Property Value

Type: Pcm1791aTypeOperationControlRate
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.OperationControlFLT Property

IRD

Pcm1791aOperationControlFLT Property

Operation Control: FLT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeOperationControlFilter OperationControlFLT { get; set; }
Public Property OperationControlFLT As Pcm1791aTypeOperationControlFilter
    Get
    Set
public:
property Pcm1791aTypeOperationControlFilter OperationControlFLT {
    Pcm1791aTypeOperationControlFilter get ();
    void set (Pcm1791aTypeOperationControlFilter value);
}
member OperationControlFLT : Pcm1791aTypeOperationControlFilter with get, set

Property Value

Type: Pcm1791aTypeOperationControlFilter
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.OperationControlINZD Property

IRD

Pcm1791aOperationControlINZD Property

Operation Control: INZD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeOperationControlZeroDetect OperationControlINZD { get; set; }
Public Property OperationControlINZD As Pcm1791aTypeOperationControlZeroDetect
    Get
    Set
public:
property Pcm1791aTypeOperationControlZeroDetect OperationControlINZD {
    Pcm1791aTypeOperationControlZeroDetect get ();
    void set (Pcm1791aTypeOperationControlZeroDetect value);
}
member OperationControlINZD : Pcm1791aTypeOperationControlZeroDetect with get, set

Property Value

Type: Pcm1791aTypeOperationControlZeroDetect
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.OperationControlOPE Property

IRD

Pcm1791aOperationControlOPE Property

Operation Control: OPE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeOperationControlDac OperationControlOPE { get; set; }
Public Property OperationControlOPE As Pcm1791aTypeOperationControlDac
    Get
    Set
public:
property Pcm1791aTypeOperationControlDac OperationControlOPE {
    Pcm1791aTypeOperationControlDac get ();
    void set (Pcm1791aTypeOperationControlDac value);
}
member OperationControlOPE : Pcm1791aTypeOperationControlDac with get, set

Property Value

Type: Pcm1791aTypeOperationControlDac
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.OperationControlREV Property

IRD

Pcm1791aOperationControlREV Property

Operation Control: REV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeOperationControlReversal OperationControlREV { get; set; }
Public Property OperationControlREV As Pcm1791aTypeOperationControlReversal
    Get
    Set
public:
property Pcm1791aTypeOperationControlReversal OperationControlREV {
    Pcm1791aTypeOperationControlReversal get ();
    void set (Pcm1791aTypeOperationControlReversal value);
}
member OperationControlREV : Pcm1791aTypeOperationControlReversal with get, set

Property Value

Type: Pcm1791aTypeOperationControlReversal
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.SignalControlCHSL Property

IRD

Pcm1791aSignalControlCHSL Property

Signal Control: CHSL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeSignalControlChannel SignalControlCHSL { get; set; }
Public Property SignalControlCHSL As Pcm1791aTypeSignalControlChannel
    Get
    Set
public:
property Pcm1791aTypeSignalControlChannel SignalControlCHSL {
    Pcm1791aTypeSignalControlChannel get ();
    void set (Pcm1791aTypeSignalControlChannel value);
}
member SignalControlCHSL : Pcm1791aTypeSignalControlChannel with get, set

Property Value

Type: Pcm1791aTypeSignalControlChannel
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.SignalControlDFTH Property

IRD

Pcm1791aSignalControlDFTH Property

Signal Control: DFTH

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeSignalControlFilter SignalControlDFTH { get; set; }
Public Property SignalControlDFTH As Pcm1791aTypeSignalControlFilter
    Get
    Set
public:
property Pcm1791aTypeSignalControlFilter SignalControlDFTH {
    Pcm1791aTypeSignalControlFilter get ();
    void set (Pcm1791aTypeSignalControlFilter value);
}
member SignalControlDFTH : Pcm1791aTypeSignalControlFilter with get, set

Property Value

Type: Pcm1791aTypeSignalControlFilter
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.SignalControlDSD Property

IRD

Pcm1791aSignalControlDSD Property

Signal Control: DSD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeSignalControlMode SignalControlDSD { get; set; }
Public Property SignalControlDSD As Pcm1791aTypeSignalControlMode
    Get
    Set
public:
property Pcm1791aTypeSignalControlMode SignalControlDSD {
    Pcm1791aTypeSignalControlMode get ();
    void set (Pcm1791aTypeSignalControlMode value);
}
member SignalControlDSD : Pcm1791aTypeSignalControlMode with get, set

Property Value

Type: Pcm1791aTypeSignalControlMode
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.SignalControlMONO Property

IRD

Pcm1791aSignalControlMONO Property

Signal Control: MONO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeSignalControlMono SignalControlMONO { get; set; }
Public Property SignalControlMONO As Pcm1791aTypeSignalControlMono
    Get
    Set
public:
property Pcm1791aTypeSignalControlMono SignalControlMONO {
    Pcm1791aTypeSignalControlMono get ();
    void set (Pcm1791aTypeSignalControlMono value);
}
member SignalControlMONO : Pcm1791aTypeSignalControlMono with get, set

Property Value

Type: Pcm1791aTypeSignalControlMono
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.SignalControlOS Property

IRD

Pcm1791aSignalControlOS Property

Signal Control: OS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeSignalControlSpeed SignalControlOS { get; set; }
Public Property SignalControlOS As Pcm1791aTypeSignalControlSpeed
    Get
    Set
public:
property Pcm1791aTypeSignalControlSpeed SignalControlOS {
    Pcm1791aTypeSignalControlSpeed get ();
    void set (Pcm1791aTypeSignalControlSpeed value);
}
member SignalControlOS : Pcm1791aTypeSignalControlSpeed with get, set

Property Value

Type: Pcm1791aTypeSignalControlSpeed
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.SignalControlSRST Property

IRD

Pcm1791aSignalControlSRST Property

Signal Control: SRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeSignalControlReset SignalControlSRST { get; set; }
Public Property SignalControlSRST As Pcm1791aTypeSignalControlReset
    Get
    Set
public:
property Pcm1791aTypeSignalControlReset SignalControlSRST {
    Pcm1791aTypeSignalControlReset get ();
    void set (Pcm1791aTypeSignalControlReset value);
}
member SignalControlSRST : Pcm1791aTypeSignalControlReset with get, set

Property Value

Type: Pcm1791aTypeSignalControlReset
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.ZeroDetectionZFGL Property

IRD

Pcm1791aZeroDetectionZFGL Property

Zero Detection: ZFGL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeZeroDetectionFlagLeft ZeroDetectionZFGL { get; }
Public ReadOnly Property ZeroDetectionZFGL As Pcm1791aTypeZeroDetectionFlagLeft
    Get
public:
property Pcm1791aTypeZeroDetectionFlagLeft ZeroDetectionZFGL {
    Pcm1791aTypeZeroDetectionFlagLeft get ();
}
member ZeroDetectionZFGL : Pcm1791aTypeZeroDetectionFlagLeft with get

Property Value

Type: Pcm1791aTypeZeroDetectionFlagLeft
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.ZeroDetectionZFGR Property

IRD

Pcm1791aZeroDetectionZFGR Property

Zero Detection: ZFGR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeZeroDetectionFlagRight ZeroDetectionZFGR { get; }
Public ReadOnly Property ZeroDetectionZFGR As Pcm1791aTypeZeroDetectionFlagRight
    Get
public:
property Pcm1791aTypeZeroDetectionFlagRight ZeroDetectionZFGR {
    Pcm1791aTypeZeroDetectionFlagRight get ();
}
member ZeroDetectionZFGR : Pcm1791aTypeZeroDetectionFlagRight with get

Property Value

Type: Pcm1791aTypeZeroDetectionFlagRight
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.ZeroOutputDZ Property

IRD

Pcm1791aZeroOutputDZ Property

Zero Output: DZ

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeZeroOutputDsd ZeroOutputDZ { get; set; }
Public Property ZeroOutputDZ As Pcm1791aTypeZeroOutputDsd
    Get
    Set
public:
property Pcm1791aTypeZeroOutputDsd ZeroOutputDZ {
    Pcm1791aTypeZeroOutputDsd get ();
    void set (Pcm1791aTypeZeroOutputDsd value);
}
member ZeroOutputDZ : Pcm1791aTypeZeroOutputDsd with get, set

Property Value

Type: Pcm1791aTypeZeroOutputDsd
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.ZeroOutputPCMZ Property

IRD

Pcm1791aZeroOutputPCMZ Property

Zero Output: PCMZ

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1791aTypeZeroOutputPcm ZeroOutputPCMZ { get; set; }
Public Property ZeroOutputPCMZ As Pcm1791aTypeZeroOutputPcm
    Get
    Set
public:
property Pcm1791aTypeZeroOutputPcm ZeroOutputPCMZ {
    Pcm1791aTypeZeroOutputPcm get ();
    void set (Pcm1791aTypeZeroOutputPcm value);
}
member ZeroOutputPCMZ : Pcm1791aTypeZeroOutputPcm with get, set

Property Value

Type: Pcm1791aTypeZeroOutputPcm
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a Methods

The Pcm1791a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.Flush Method

IRD

Pcm1791aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcm1791a Class
telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeAttenuationLevel Enumeration

IRD

Pcm1791aTypeAttenuationLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuationLevel
Public Enumeration TypeAttenuationLevel
public enum class TypeAttenuationLevel
type TypeAttenuationLevel
Members
Member name | Value | Description
Mute | 0 | Mute
Value_1200DB | 15 | -120.0 dB
Value_1195DB | 16 | -119.5 dB
Value_1190DB | 17 | -119.0 dB
Value_1185DB | 18 | -118.5 dB
Value_1180DB | 19 | -118.0 dB
Value_1175DB | 20 | -117.5 dB
Value_1170DB | 21 | -117.0 dB
Value_1165DB | 22 | -116.5 dB
Value_1160DB | 23 | -116.0 dB
Value_1155DB | 24 | -115.5 dB
Value_1150DB | 25 | -115.0 dB
Value_1145DB | 26 | -114.5 dB
Value_1140DB | 27 | -114.0 dB
Value_1135DB | 28 | -113.5 dB
Value_1130DB | 29 | -113.0 dB
Value_1125DB | 30 | -112.5 dB
Value_1120DB | 31 | -112.0 dB
Value_1115DB | 32 | -111.5 dB
Value_1110DB | 33 | -111.0 dB
Value_1105DB | 34 | -110.5 dB
Value_1100DB | 35 | -110.0 dB
Value_1095DB | 36 | -109.5 dB
Value_1090DB | 37 | -109.0 dB
Value_1085DB | 38 | -108.5 dB
Value_1080DB | 39 | -108.0 dB
Value_1075DB | 40 | -107.5 dB
Value_1070DB | 41 | -107.0 dB
Value_1065DB | 42 | -106.5 dB
Value_1060DB | 43 | -106.0 dB
Value_1055DB | 44 | -105.5 dB
Value_1050DB | 45 | -105.0 dB
Value_1045DB | 46 | -104.5 dB
Value_1040DB | 47 | -104.0 dB
Value_1035DB | 48 | -103.5 dB
Value_1030DB | 49 | -103.0 dB
Value_1025DB | 50 | -102.5 dB
Value_1020DB | 51 | -102.0 dB
Value_1015DB | 52 | -101.5 dB
Value_1010DB | 53 | -101.0 dB
Value_1005DB | 54 | -100.5 dB
Value_1000DB | 55 | -100.0 dB
Value_995DB | 56 | -99.5 dB
Value_990DB | 57 | -99.0 dB
Value_985DB | 58 | -98.5 dB
Value_980DB | 59 | -98.0 dB
Value_975DB | 60 | -97.5 dB
Value_970DB | 61 | -97.0 dB
Value_965DB | 62 | -96.5 dB
Value_960DB | 63 | -96.0 dB
Value_955DB | 64 | -95.5 dB
Value_950DB | 65 | -95.0 dB
Value_945DB | 66 | -94.5 dB
Value_940DB | 67 | -94.0 dB
Value_935DB | 68 | -93.5 dB
Value_930DB | 69 | -93.0 dB
Value_925DB | 70 | -92.5 dB
Value_920DB | 71 | -92.0 dB
Value_915DB | 72 | -91.5 dB
Value_910DB | 73 | -91.0 dB
Value_905DB | 74 | -90.5 dB
Value_900DB | 75 | -90.0 dB
Value_895DB | 76 | -89.5 dB
Value_890DB | 77 | -89.0 dB
Value_885DB | 78 | -88.5 dB
Value_880DB | 79 | -88.0 dB
Value_875DB | 80 | -87.5 dB
Value_870DB | 81 | -87.0 dB
Value_865DB | 82 | -86.5 dB
Value_860DB | 83 | -86.0 dB
Value_855DB | 84 | -85.5 dB
Value_850DB | 85 | -85.0 dB
Value_845DB | 86 | -84.5 dB
Value_840DB | 87 | -84.0 dB
Value_835DB | 88 | -83.5 dB
Value_830DB | 89 | -83.0 dB
Value_825DB | 90 | -82.5 dB
Value_820DB | 91 | -82.0 dB
Value_815DB | 92 | -81.5 dB
Value_810DB | 93 | -81.0 dB
Value_805DB | 94 | -80.5 dB
Value_800DB | 95 | -80.0 dB
Value_795DB | 96 | -79.5 dB
Value_790DB | 97 | -79.0 dB
Value_785DB | 98 | -78.5 dB
Value_780DB | 99 | -78.0 dB
Value_775DB | 100 | -77.5 dB
Value_770DB | 101 | -77.0 dB
Value_765DB | 102 | -76.5 dB
Value_760DB | 103 | -76.0 dB
Value_755DB | 104 | -75.5 dB
Value_750DB | 105 | -75.0 dB
Value_745DB | 106 | -74.5 dB
Value_740DB | 107 | -74.0 dB
Value_735DB | 108 | -73.5 dB
Value_730DB | 109 | -73.0 dB
Value_725DB | 110 | -72.5 dB
Value_720DB | 111 | -72.0 dB
Value_715DB | 112 | -71.5 dB
Value_710DB | 113 | -71.0 dB
Value_705DB | 114 | -70.5 dB
Value_700DB | 115 | -70.0 dB
Value_695DB | 116 | -69.5 dB
Value_690DB | 117 | -69.0 dB
Value_685DB | 118 | -68.5 dB
Value_680DB | 119 | -68.0 dB
Value_675DB | 120 | -67.5 dB
Value_670DB | 121 | -67.0 dB
Value_665DB | 122 | -66.5 dB
Value_660DB | 123 | -66.0 dB
Value_655DB | 124 | -65.5 dB
Value_650DB | 125 | -65.0 dB
Value_645DB | 126 | -64.5 dB
Value_640DB | 127 | -64.0 dB
Value_635DB | 128 | -63.5 dB
Value_630DB | 129 | -63.0 dB
Value_625DB | 130 | -62.5 dB
Value_620DB | 131 | -62.0 dB
Value_615DB | 132 | -61.5 dB
Value_610DB | 133 | -61.0 dB
Value_605DB | 134 | -60.5 dB
Value_600DB | 135 | -60.0 dB
Value_595DB | 136 | -59.5 dB
Value_590DB | 137 | -59.0 dB
Value_585DB | 138 | -58.5 dB
Value_580DB | 139 | -58.0 dB
Value_575DB | 140 | -57.5 dB
Value_570DB | 141 | -57.0 dB
Value_565DB | 142 | -56.5 dB
Value_560DB | 143 | -56.0 dB
Value_555DB | 144 | -55.5 dB
Value_550DB | 145 | -55.0 dB
Value_545DB | 146 | -54.5 dB
Value_540DB | 147 | -54.0 dB
Value_535DB | 148 | -53.5 dB
Value_530DB | 149 | -53.0 dB
Value_525DB | 150 | -52.5 dB
Value_520DB | 151 | -52.0 dB
Value_515DB | 152 | -51.5 dB
Value_510DB | 153 | -51.0 dB
Value_505DB | 154 | -50.5 dB
Value_500DB | 155 | -50.0 dB
Value_495DB | 156 | -49.5 dB
Value_490DB | 157 | -49.0 dB
Value_485DB | 158 | -48.5 dB
Value_480DB | 159 | -48.0 dB
Value_475DB | 160 | -47.5 dB
Value_470DB | 161 | -47.0 dB
Value_465DB | 162 | -46.5 dB
Value_460DB | 163 | -46.0 dB
Value_455DB | 164 | -45.5 dB
Value_450DB | 165 | -45.0 dB
Value_445DB | 166 | -44.5 dB
Value_440DB | 167 | -44.0 dB
Value_435DB | 168 | -43.5 dB
Value_430DB | 169 | -43.0 dB
Value_425DB | 170 | -42.5 dB
Value_420DB | 171 | -42.0 dB
Value_415DB | 172 | -41.5 dB
Value_410DB | 173 | -41.0 dB
Value_405DB | 174 | -40.5 dB
Value_400DB | 175 | -40.0 dB
Value_395DB | 176 | -39.5 dB
Value_390DB | 177 | -39.0 dB
Value_385DB | 178 | -38.5 dB
Value_380DB | 179 | -38.0 dB
Value_375DB | 180 | -37.5 dB
Value_370DB | 181 | -37.0 dB
Value_365DB | 182 | -36.5 dB
Value_360DB | 183 | -36.0 dB
Value_355DB | 184 | -35.5 dB
Value_350DB | 185 | -35.0 dB
Value_345DB | 186 | -34.5 dB
Value_340DB | 187 | -34.0 dB
Value_335DB | 188 | -33.5 dB
Value_330DB | 189 | -33.0 dB
Value_325DB | 190 | -32.5 dB
Value_320DB | 191 | -32.0 dB
Value_315DB | 192 | -31.5 dB
Value_310DB | 193 | -31.0 dB
Value_305DB | 194 | -30.5 dB
Value_300DB | 195 | -30.0 dB
Value_295DB | 196 | -29.5 dB
Value_290DB | 197 | -29.0 dB
Value_285DB | 198 | -28.5 dB
Value_280DB | 199 | -28.0 dB
Value_275DB | 200 | -27.5 dB
Value_270DB | 201 | -27.0 dB
Value_265DB | 202 | -26.5 dB
Value_260DB | 203 | -26.0 dB
Value_255DB | 204 | -25.5 dB
Value_250DB | 205 | -25.0 dB
Value_245DB | 206 | -24.5 dB
Value_240DB | 207 | -24.0 dB
Value_235DB | 208 | -23.5 dB
Value_230DB | 209 | -23.0 dB
Value_225DB | 210 | -22.5 dB
Value_220DB | 211 | -22.0 dB
Value_215DB | 212 | -21.5 dB
Value_210DB | 213 | -21.0 dB
Value_205DB | 214 | -20.5 dB
Value_200DB | 215 | -20.0 dB
Value_195DB | 216 | -19.5 dB
Value_190DB | 217 | -19.0 dB
Value_185DB | 218 | -18.5 dB
Value_180DB | 219 | -18.0 dB
Value_175DB | 220 | -17.5 dB
Value_170DB | 221 | -17.0 dB
Value_165DB | 222 | -16.5 dB
Value_160DB | 223 | -16.0 dB
Value_155DB | 224 | -15.5 dB
Value_150DB | 225 | -15.0 dB
Value_145DB | 226 | -14.5 dB
Value_140DB | 227 | -14.0 dB
Value_135DB | 228 | -13.5 dB
Value_130DB | 229 | -13.0 dB
Value_125DB | 230 | -12.5 dB
Value_120DB | 231 | -12.0 dB
Value_115DB | 232 | -11.5 dB
Value_110DB | 233 | -11.0 dB
Value_105DB | 234 | -10.5 dB
Value_100DB | 235 | -10.0 dB
Value_95DB | 236 | -9.5 dB
Value_90DB | 237 | -9.0 dB
Value_85DB | 238 | -8.5 dB
Value_80DB | 239 | -8.0 dB
Value_75DB | 240 | -7.5 dB
Value_70DB | 241 | -7.0 dB
Value_65DB | 242 | -6.5 dB
Value_60DB | 243 | -6.0 dB
Value_55DB | 244 | -5.5 dB
Value_50DB | 245 | -5.0 dB
Value_45DB | 246 | -4.5 dB
Value_40DB | 247 | -4.0 dB
Value_35DB | 248 | -3.5 dB
Value_30DB | 249 | -3.0 dB
Value_25DB | 250 | -2.5 dB
Value_20DB | 251 | -2.0 dB
Value_15DB | 252 | -1.5 dB
Value_10DB | 253 | -1.0 dB
Value_05DB | 254 | -0.5 dB
Value_0DB | 255 | 0 dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeAudioControlAttenuationLoad Enumeration

IRD

Pcm1791aTypeAudioControlAttenuationLoad Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlAttenuationLoad
Public Enumeration TypeAudioControlAttenuationLoad
public enum class TypeAudioControlAttenuationLoad
type TypeAudioControlAttenuationLoad
Members
Member name | Value | Description
AttenuationControlDisabled | 0 | Attenuation Control: Disabled
AttenuationControlEnabled | 1 | Attenuation Control: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeAudioControlDataFormat Enumeration

IRD

Pcm1791aTypeAudioControlDataFormat Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlDataFormat
Public Enumeration TypeAudioControlDataFormat
public enum class TypeAudioControlDataFormat
type TypeAudioControlDataFormat
Members
Member name | Value | Description
Value_16BitRightJustifiedStandardFormat | 0 | 16 Bit Right-Justified Standard Format
Value_20BitRightJustifiedStandardFormat | 1 | 20 Bit Right-Justified Standard Format
Value_24BitRightJustifiedStandardFormat | 2 | 24 Bit Right-Justified Standard Format
Value_24BitLeftJustifiedMSBFirstFormat | 3 | 24 Bit Left-Justified MSB-First Format
Value_16BitI2SFormat | 4 | 16 Bit I2S Format
Value_24BitI2SFormat | 5 | 24 Bit I2S Format
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeAudioControlDeEmphasis Enumeration

IRD

Pcm1791aTypeAudioControlDeEmphasis Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlDeEmphasis
Public Enumeration TypeAudioControlDeEmphasis
public enum class TypeAudioControlDeEmphasis
type TypeAudioControlDeEmphasis
Members
Member name | Value | Description
DeEmphasisDisabled | 0 | De-Emphasis: Disabled
DeEmphasisEnabled | 1 | De-Emphasis: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeAudioControlMute Enumeration

IRD

Pcm1791aTypeAudioControlMute Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlMute
Public Enumeration TypeAudioControlMute
public enum class TypeAudioControlMute
type TypeAudioControlMute
Members
Member name | Value | Description
MuteDisabled | 0 | Mute: Disabled
MuteEnabled | 1 | Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeAudioControlSampling Enumeration

IRD

Pcm1791aTypeAudioControlSampling Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlSampling
Public Enumeration TypeAudioControlSampling
public enum class TypeAudioControlSampling
type TypeAudioControlSampling
Members
Member name | Value | Description
SamplingFequencyDisabled | 0 | Sampling Fequency: Disabled
SamplingFequency48KHz | 1 | Sampling Fequency: 48 kHz
SamplingFequency441KHz | 2 | Sampling Fequency: 44.1 kHz
SamplingFequency32KHz | 3 | Sampling Fequency: 32 kHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeOperationControlDac Enumeration

IRD

Pcm1791aTypeOperationControlDac Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlDac
Public Enumeration TypeOperationControlDac
public enum class TypeOperationControlDac
type TypeOperationControlDac
Members
Member name | Value | Description
DACOperationEnabled | 0 | DAC Operation: Enabled
DACOperationDisabled | 1 | DAC Operation: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeOperationControlFilter Enumeration

IRD

Pcm1791aTypeOperationControlFilter Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlFilter
Public Enumeration TypeOperationControlFilter
public enum class TypeOperationControlFilter
type TypeOperationControlFilter
Members
Member name | Value | Description
DigitalFilterSharpRollOff | 0 | Digital Filter: Sharp Roll-Off
DigitalFilterSlowRollOff | 1 | Digital Filter: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeOperationControlRate Enumeration

IRD

Pcm1791aTypeOperationControlRate Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlRate
Public Enumeration TypeOperationControlRate
public enum class TypeOperationControlRate
type TypeOperationControlRate
Members
Member name | Value | Description
AttenuationRateEveryLRCK | 0 | Attenuation Rate: Every LRCK
AttenuationRateLRCK2 | 1 | Attenuation Rate: LRCK / 2
AttenuationRateLRCK4 | 2 | Attenuation Rate: LRCK / 4
AttenuationRateLRCK8 | 3 | Attenuation Rate: LRCK / 8
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeOperationControlReversal Enumeration

IRD

Pcm1791aTypeOperationControlReversal Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlReversal
Public Enumeration TypeOperationControlReversal
public enum class TypeOperationControlReversal
type TypeOperationControlReversal
Members
Member name | Value | Description
OutputPhaseNormal | 0 | Output Phase: Normal
OutputPhaseInverted | 1 | Output Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeOperationControlZeroDetect Enumeration

IRD

Pcm1791aTypeOperationControlZeroDetect Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlZeroDetect
Public Enumeration TypeOperationControlZeroDetect
public enum class TypeOperationControlZeroDetect
type TypeOperationControlZeroDetect
Members
Member name | Value | Description
InfiniteZeroDetectMuteDisabled | 0 | Infinite Zero Detect Mute: Disabled
InfiniteZeroDetectMuteEnabled | 1 | Infinite Zero Detect Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeSignalControlChannel Enumeration

IRD

Pcm1791aTypeSignalControlChannel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlChannel
Public Enumeration TypeSignalControlChannel
public enum class TypeSignalControlChannel
type TypeSignalControlChannel
Members
Member name | Value | Description
LChannelSelected | 0 | L-Channel Selected
RChannelSelected | 1 | R-Channel Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeSignalControlFilter Enumeration

IRD

Pcm1791aTypeSignalControlFilter Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlFilter
Public Enumeration TypeSignalControlFilter
public enum class TypeSignalControlFilter
type TypeSignalControlFilter
Members
Member name | Value | Description
DigitalFilterEnabled | 0 | Digital Filter: Enabled
DigitalFilterBypassedForExternalFilter | 1 | Digital Filter: Bypassed For External Filter
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeSignalControlMode Enumeration

IRD

Pcm1791aTypeSignalControlMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlMode
Public Enumeration TypeSignalControlMode
public enum class TypeSignalControlMode
type TypeSignalControlMode
Members
Member name | Value | Description
DSDInterfaceModeDisabled | 0 | DSD Interface Mode: Disabled
DSDInterfaceModeEnabled | 1 | DSD Interface Mode: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeSignalControlMono Enumeration

IRD

Pcm1791aTypeSignalControlMono Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlMono
Public Enumeration TypeSignalControlMono
public enum class TypeSignalControlMono
type TypeSignalControlMono
Members
Member name | Value | Description
StereoMode | 0 | Stereo Mode
MonauralMode | 1 | Monaural Mode
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeSignalControlReset Enumeration

IRD

Pcm1791aTypeSignalControlReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlReset
Public Enumeration TypeSignalControlReset
public enum class TypeSignalControlReset
type TypeSignalControlReset
Members
Member name | Value | Description
SystemResetNormalOperation | 0 | System Reset: Normal Operation
SystemResetOperationOneResetPulse | 1 | System Reset Operation (One Reset Pulse)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeSignalControlSpeed Enumeration

IRD

Pcm1791aTypeSignalControlSpeed Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlSpeed
Public Enumeration TypeSignalControlSpeed
public enum class TypeSignalControlSpeed
type TypeSignalControlSpeed
Members
Member name | Value | Description
OperationSpeed64XFs | 0 | Operation Speed: 64 x Fs
OperationSpeed32XFs | 1 | Operation Speed: 32 x Fs
OperationSpeed128XFs | 2 | Operation Speed: 128 x Fs
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeZeroDetectionFlagLeft Enumeration

IRD

Pcm1791aTypeZeroDetectionFlagLeft Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroDetectionFlagLeft
Public Enumeration TypeZeroDetectionFlagLeft
public enum class TypeZeroDetectionFlagLeft
type TypeZeroDetectionFlagLeft
Members
Member name | Value | Description
LChannelZeroNotDetected | 0 | L-Channel: Zero Not Detected
LChannelZeroDetected | 1 | L-Channel: Zero Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeZeroDetectionFlagRight Enumeration

IRD

Pcm1791aTypeZeroDetectionFlagRight Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroDetectionFlagRight
Public Enumeration TypeZeroDetectionFlagRight
public enum class TypeZeroDetectionFlagRight
type TypeZeroDetectionFlagRight
Members
Member name | Value | Description
RChannelZeroNotDetected | 0 | R-Channel: Zero Not Detected
RChannelZeroDetected | 1 | R-Channel: Zero Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeZeroOutputDsd Enumeration

IRD

Pcm1791aTypeZeroOutputDsd Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroOutputDsd
Public Enumeration TypeZeroOutputDsd
public enum class TypeZeroOutputDsd
type TypeZeroOutputDsd
Members
Member name | Value | Description
ZeroOutputDisabled | 0 | Zero Output: Disabled
ZeroOutputEvenPatternDetect | 1 | Zero Output: Even Pattern Detect
ZeroOutput96HPatternDetect | 2 | Zero Output: 96H Pattern Detect
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1791a.TypeZeroOutputPcm Enumeration

IRD

Pcm1791aTypeZeroOutputPcm Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroOutputPcm
Public Enumeration TypeZeroOutputPcm
public enum class TypeZeroOutputPcm
type TypeZeroOutputPcm
Members
Member name | Value | Description
PCMZeroOutputDisabled | 0 | PCM Zero Output: Disabled
PCMZeroOutputEnabled | 1 | PCM Zero Output: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a Class

Texas Instruments: PCM 1792A
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPcm1792a

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcm1792a
Public Class Pcm1792a
public ref class Pcm1792a
type Pcm1792a =  class end

The Pcm1792a type exposes the following members.

Constructors
 | Name | Description
Public method | Pcm1792a | Constructor
Top
Properties
 | Name | Description
Public property | AttenuationLeftATL | Attenuation Left: ATL
Public property | AttenuationRightATR | Attenuation Right: ATR
Public property | AudioControlATLD | Audio Control: ATLD
Public property | AudioControlDME | Audio Control: DME
Public property | AudioControlDMF | Audio Control: DMF
Public property | AudioControlFMT | Audio Control: FMT
Public property | AudioControlMUTE | Audio Control: MUTE
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DeviceIDID | Device ID: ID
Public property | OperationControlATS | Operation Control: ATS
Public property | OperationControlDFMS | Operation Control: DFMS
Public property | OperationControlFLT | Operation Control: FLT
Public property | OperationControlINZD | Operation Control: INZD
Public property | OperationControlOPE | Operation Control: OPE
Public property | OperationControlREV | Operation Control: REV
Public property | SignalControlCHSL | Signal Control: CHSL
Public property | SignalControlDFTH | Signal Control: DFTH
Public property | SignalControlDSD | Signal Control: DSD
Public property | SignalControlMONO | Signal Control: MONO
Public property | SignalControlOS | Signal Control: OS
Public property | SignalControlSRST | Signal Control: SRST
Public property | ZeroDetectionZFGL | Zero Detection: ZFGL
Public property | ZeroDetectionZFGR | Zero Detection: ZFGR
Public property | ZeroOutputDZ | Zero Output: DZ
Public property | ZeroOutputPCMZ | Zero Output: PCMZ
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Audio Stereo Digital-To-Analog Converter
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcm1792a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcm1792a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a Properties

The Pcm1792a type exposes the following members.

Properties
 | Name | Description
Public property | AttenuationLeftATL | Attenuation Left: ATL
Public property | AttenuationRightATR | Attenuation Right: ATR
Public property | AudioControlATLD | Audio Control: ATLD
Public property | AudioControlDME | Audio Control: DME
Public property | AudioControlDMF | Audio Control: DMF
Public property | AudioControlFMT | Audio Control: FMT
Public property | AudioControlMUTE | Audio Control: MUTE
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DeviceIDID | Device ID: ID
Public property | OperationControlATS | Operation Control: ATS
Public property | OperationControlDFMS | Operation Control: DFMS
Public property | OperationControlFLT | Operation Control: FLT
Public property | OperationControlINZD | Operation Control: INZD
Public property | OperationControlOPE | Operation Control: OPE
Public property | OperationControlREV | Operation Control: REV
Public property | SignalControlCHSL | Signal Control: CHSL
Public property | SignalControlDFTH | Signal Control: DFTH
Public property | SignalControlDSD | Signal Control: DSD
Public property | SignalControlMONO | Signal Control: MONO
Public property | SignalControlOS | Signal Control: OS
Public property | SignalControlSRST | Signal Control: SRST
Public property | ZeroDetectionZFGL | Zero Detection: ZFGL
Public property | ZeroDetectionZFGR | Zero Detection: ZFGR
Public property | ZeroOutputDZ | Zero Output: DZ
Public property | ZeroOutputPCMZ | Zero Output: PCMZ
Top
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.AttenuationLeftATL Property

IRD

Pcm1792aAttenuationLeftATL Property

Attenuation Left: ATL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeAttenuationLevel AttenuationLeftATL { get; set; }
Public Property AttenuationLeftATL As Pcm1792aTypeAttenuationLevel
    Get
    Set
public:
property Pcm1792aTypeAttenuationLevel AttenuationLeftATL {
    Pcm1792aTypeAttenuationLevel get ();
    void set (Pcm1792aTypeAttenuationLevel value);
}
member AttenuationLeftATL : Pcm1792aTypeAttenuationLevel with get, set

Property Value

Type: Pcm1792aTypeAttenuationLevel
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.AttenuationRightATR Property

IRD

Pcm1792aAttenuationRightATR Property

Attenuation Right: ATR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeAttenuationLevel AttenuationRightATR { get; set; }
Public Property AttenuationRightATR As Pcm1792aTypeAttenuationLevel
    Get
    Set
public:
property Pcm1792aTypeAttenuationLevel AttenuationRightATR {
    Pcm1792aTypeAttenuationLevel get ();
    void set (Pcm1792aTypeAttenuationLevel value);
}
member AttenuationRightATR : Pcm1792aTypeAttenuationLevel with get, set

Property Value

Type: Pcm1792aTypeAttenuationLevel
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.AudioControlATLD Property

IRD

Pcm1792aAudioControlATLD Property

Audio Control: ATLD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeAudioControlAttenuationLoad AudioControlATLD { get; set; }
Public Property AudioControlATLD As Pcm1792aTypeAudioControlAttenuationLoad
    Get
    Set
public:
property Pcm1792aTypeAudioControlAttenuationLoad AudioControlATLD {
    Pcm1792aTypeAudioControlAttenuationLoad get ();
    void set (Pcm1792aTypeAudioControlAttenuationLoad value);
}
member AudioControlATLD : Pcm1792aTypeAudioControlAttenuationLoad with get, set

Property Value

Type: Pcm1792aTypeAudioControlAttenuationLoad
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.AudioControlDME Property

IRD

Pcm1792aAudioControlDME Property

Audio Control: DME

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeAudioControlDeEmphasis AudioControlDME { get; set; }
Public Property AudioControlDME As Pcm1792aTypeAudioControlDeEmphasis
    Get
    Set
public:
property Pcm1792aTypeAudioControlDeEmphasis AudioControlDME {
    Pcm1792aTypeAudioControlDeEmphasis get ();
    void set (Pcm1792aTypeAudioControlDeEmphasis value);
}
member AudioControlDME : Pcm1792aTypeAudioControlDeEmphasis with get, set

Property Value

Type: Pcm1792aTypeAudioControlDeEmphasis
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.AudioControlDMF Property

IRD

Pcm1792aAudioControlDMF Property

Audio Control: DMF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeAudioControlSampling AudioControlDMF { get; set; }
Public Property AudioControlDMF As Pcm1792aTypeAudioControlSampling
    Get
    Set
public:
property Pcm1792aTypeAudioControlSampling AudioControlDMF {
    Pcm1792aTypeAudioControlSampling get ();
    void set (Pcm1792aTypeAudioControlSampling value);
}
member AudioControlDMF : Pcm1792aTypeAudioControlSampling with get, set

Property Value

Type: Pcm1792aTypeAudioControlSampling
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.AudioControlFMT Property

IRD

Pcm1792aAudioControlFMT Property

Audio Control: FMT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeAudioControlDataFormat AudioControlFMT { get; set; }
Public Property AudioControlFMT As Pcm1792aTypeAudioControlDataFormat
    Get
    Set
public:
property Pcm1792aTypeAudioControlDataFormat AudioControlFMT {
    Pcm1792aTypeAudioControlDataFormat get ();
    void set (Pcm1792aTypeAudioControlDataFormat value);
}
member AudioControlFMT : Pcm1792aTypeAudioControlDataFormat with get, set

Property Value

Type: Pcm1792aTypeAudioControlDataFormat
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.AudioControlMUTE Property

IRD

Pcm1792aAudioControlMUTE Property

Audio Control: MUTE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeAudioControlMute AudioControlMUTE { get; set; }
Public Property AudioControlMUTE As Pcm1792aTypeAudioControlMute
    Get
    Set
public:
property Pcm1792aTypeAudioControlMute AudioControlMUTE {
    Pcm1792aTypeAudioControlMute get ();
    void set (Pcm1792aTypeAudioControlMute value);
}
member AudioControlMUTE : Pcm1792aTypeAudioControlMute with get, set

Property Value

Type: Pcm1792aTypeAudioControlMute
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.AutoFlush Property

IRD

Pcm1792aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.DeviceIDID Property

IRD

Pcm1792aDeviceIDID Property

Device ID: ID

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceIDID { get; }
Public ReadOnly Property DeviceIDID As Byte
    Get
public:
property unsigned char DeviceIDID {
    unsigned char get ();
}
member DeviceIDID : byte with get

Property Value

Type: Byte
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.OperationControlATS Property

IRD

Pcm1792aOperationControlATS Property

Operation Control: ATS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeOperationControlRate OperationControlATS { get; set; }
Public Property OperationControlATS As Pcm1792aTypeOperationControlRate
    Get
    Set
public:
property Pcm1792aTypeOperationControlRate OperationControlATS {
    Pcm1792aTypeOperationControlRate get ();
    void set (Pcm1792aTypeOperationControlRate value);
}
member OperationControlATS : Pcm1792aTypeOperationControlRate with get, set

Property Value

Type: Pcm1792aTypeOperationControlRate
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.OperationControlDFMS Property

IRD

Pcm1792aOperationControlDFMS Property

Operation Control: DFMS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeOperationControlBypass OperationControlDFMS { get; set; }
Public Property OperationControlDFMS As Pcm1792aTypeOperationControlBypass
    Get
    Set
public:
property Pcm1792aTypeOperationControlBypass OperationControlDFMS {
    Pcm1792aTypeOperationControlBypass get ();
    void set (Pcm1792aTypeOperationControlBypass value);
}
member OperationControlDFMS : Pcm1792aTypeOperationControlBypass with get, set

Property Value

Type: Pcm1792aTypeOperationControlBypass
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.OperationControlFLT Property

IRD

Pcm1792aOperationControlFLT Property

Operation Control: FLT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeOperationControlFilter OperationControlFLT { get; set; }
Public Property OperationControlFLT As Pcm1792aTypeOperationControlFilter
    Get
    Set
public:
property Pcm1792aTypeOperationControlFilter OperationControlFLT {
    Pcm1792aTypeOperationControlFilter get ();
    void set (Pcm1792aTypeOperationControlFilter value);
}
member OperationControlFLT : Pcm1792aTypeOperationControlFilter with get, set

Property Value

Type: Pcm1792aTypeOperationControlFilter
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.OperationControlINZD Property

IRD

Pcm1792aOperationControlINZD Property

Operation Control: INZD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeOperationControlZeroDetect OperationControlINZD { get; set; }
Public Property OperationControlINZD As Pcm1792aTypeOperationControlZeroDetect
    Get
    Set
public:
property Pcm1792aTypeOperationControlZeroDetect OperationControlINZD {
    Pcm1792aTypeOperationControlZeroDetect get ();
    void set (Pcm1792aTypeOperationControlZeroDetect value);
}
member OperationControlINZD : Pcm1792aTypeOperationControlZeroDetect with get, set

Property Value

Type: Pcm1792aTypeOperationControlZeroDetect
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.OperationControlOPE Property

IRD

Pcm1792aOperationControlOPE Property

Operation Control: OPE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeOperationControlDac OperationControlOPE { get; set; }
Public Property OperationControlOPE As Pcm1792aTypeOperationControlDac
    Get
    Set
public:
property Pcm1792aTypeOperationControlDac OperationControlOPE {
    Pcm1792aTypeOperationControlDac get ();
    void set (Pcm1792aTypeOperationControlDac value);
}
member OperationControlOPE : Pcm1792aTypeOperationControlDac with get, set

Property Value

Type: Pcm1792aTypeOperationControlDac
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.OperationControlREV Property

IRD

Pcm1792aOperationControlREV Property

Operation Control: REV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeOperationControlReversal OperationControlREV { get; set; }
Public Property OperationControlREV As Pcm1792aTypeOperationControlReversal
    Get
    Set
public:
property Pcm1792aTypeOperationControlReversal OperationControlREV {
    Pcm1792aTypeOperationControlReversal get ();
    void set (Pcm1792aTypeOperationControlReversal value);
}
member OperationControlREV : Pcm1792aTypeOperationControlReversal with get, set

Property Value

Type: Pcm1792aTypeOperationControlReversal
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.SignalControlCHSL Property

IRD

Pcm1792aSignalControlCHSL Property

Signal Control: CHSL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeSignalControlChannel SignalControlCHSL { get; set; }
Public Property SignalControlCHSL As Pcm1792aTypeSignalControlChannel
    Get
    Set
public:
property Pcm1792aTypeSignalControlChannel SignalControlCHSL {
    Pcm1792aTypeSignalControlChannel get ();
    void set (Pcm1792aTypeSignalControlChannel value);
}
member SignalControlCHSL : Pcm1792aTypeSignalControlChannel with get, set

Property Value

Type: Pcm1792aTypeSignalControlChannel
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.SignalControlDFTH Property

IRD

Pcm1792aSignalControlDFTH Property

Signal Control: DFTH

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeSignalControlFilter SignalControlDFTH { get; set; }
Public Property SignalControlDFTH As Pcm1792aTypeSignalControlFilter
    Get
    Set
public:
property Pcm1792aTypeSignalControlFilter SignalControlDFTH {
    Pcm1792aTypeSignalControlFilter get ();
    void set (Pcm1792aTypeSignalControlFilter value);
}
member SignalControlDFTH : Pcm1792aTypeSignalControlFilter with get, set

Property Value

Type: Pcm1792aTypeSignalControlFilter
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.SignalControlDSD Property

IRD

Pcm1792aSignalControlDSD Property

Signal Control: DSD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeSignalControlMode SignalControlDSD { get; set; }
Public Property SignalControlDSD As Pcm1792aTypeSignalControlMode
    Get
    Set
public:
property Pcm1792aTypeSignalControlMode SignalControlDSD {
    Pcm1792aTypeSignalControlMode get ();
    void set (Pcm1792aTypeSignalControlMode value);
}
member SignalControlDSD : Pcm1792aTypeSignalControlMode with get, set

Property Value

Type: Pcm1792aTypeSignalControlMode
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.SignalControlMONO Property

IRD

Pcm1792aSignalControlMONO Property

Signal Control: MONO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeSignalControlMono SignalControlMONO { get; set; }
Public Property SignalControlMONO As Pcm1792aTypeSignalControlMono
    Get
    Set
public:
property Pcm1792aTypeSignalControlMono SignalControlMONO {
    Pcm1792aTypeSignalControlMono get ();
    void set (Pcm1792aTypeSignalControlMono value);
}
member SignalControlMONO : Pcm1792aTypeSignalControlMono with get, set

Property Value

Type: Pcm1792aTypeSignalControlMono
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.SignalControlOS Property

IRD

Pcm1792aSignalControlOS Property

Signal Control: OS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeSignalControlSpeed SignalControlOS { get; set; }
Public Property SignalControlOS As Pcm1792aTypeSignalControlSpeed
    Get
    Set
public:
property Pcm1792aTypeSignalControlSpeed SignalControlOS {
    Pcm1792aTypeSignalControlSpeed get ();
    void set (Pcm1792aTypeSignalControlSpeed value);
}
member SignalControlOS : Pcm1792aTypeSignalControlSpeed with get, set

Property Value

Type: Pcm1792aTypeSignalControlSpeed
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.SignalControlSRST Property

IRD

Pcm1792aSignalControlSRST Property

Signal Control: SRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeSignalControlReset SignalControlSRST { get; set; }
Public Property SignalControlSRST As Pcm1792aTypeSignalControlReset
    Get
    Set
public:
property Pcm1792aTypeSignalControlReset SignalControlSRST {
    Pcm1792aTypeSignalControlReset get ();
    void set (Pcm1792aTypeSignalControlReset value);
}
member SignalControlSRST : Pcm1792aTypeSignalControlReset with get, set

Property Value

Type: Pcm1792aTypeSignalControlReset
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.ZeroDetectionZFGL Property

IRD

Pcm1792aZeroDetectionZFGL Property

Zero Detection: ZFGL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeZeroDetectionFlagLeft ZeroDetectionZFGL { get; }
Public ReadOnly Property ZeroDetectionZFGL As Pcm1792aTypeZeroDetectionFlagLeft
    Get
public:
property Pcm1792aTypeZeroDetectionFlagLeft ZeroDetectionZFGL {
    Pcm1792aTypeZeroDetectionFlagLeft get ();
}
member ZeroDetectionZFGL : Pcm1792aTypeZeroDetectionFlagLeft with get

Property Value

Type: Pcm1792aTypeZeroDetectionFlagLeft
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.ZeroDetectionZFGR Property

IRD

Pcm1792aZeroDetectionZFGR Property

Zero Detection: ZFGR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeZeroDetectionFlagRight ZeroDetectionZFGR { get; }
Public ReadOnly Property ZeroDetectionZFGR As Pcm1792aTypeZeroDetectionFlagRight
    Get
public:
property Pcm1792aTypeZeroDetectionFlagRight ZeroDetectionZFGR {
    Pcm1792aTypeZeroDetectionFlagRight get ();
}
member ZeroDetectionZFGR : Pcm1792aTypeZeroDetectionFlagRight with get

Property Value

Type: Pcm1792aTypeZeroDetectionFlagRight
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.ZeroOutputDZ Property

IRD

Pcm1792aZeroOutputDZ Property

Zero Output: DZ

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeZeroOutputDsd ZeroOutputDZ { get; set; }
Public Property ZeroOutputDZ As Pcm1792aTypeZeroOutputDsd
    Get
    Set
public:
property Pcm1792aTypeZeroOutputDsd ZeroOutputDZ {
    Pcm1792aTypeZeroOutputDsd get ();
    void set (Pcm1792aTypeZeroOutputDsd value);
}
member ZeroOutputDZ : Pcm1792aTypeZeroOutputDsd with get, set

Property Value

Type: Pcm1792aTypeZeroOutputDsd
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.ZeroOutputPCMZ Property

IRD

Pcm1792aZeroOutputPCMZ Property

Zero Output: PCMZ

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1792aTypeZeroOutputPcm ZeroOutputPCMZ { get; set; }
Public Property ZeroOutputPCMZ As Pcm1792aTypeZeroOutputPcm
    Get
    Set
public:
property Pcm1792aTypeZeroOutputPcm ZeroOutputPCMZ {
    Pcm1792aTypeZeroOutputPcm get ();
    void set (Pcm1792aTypeZeroOutputPcm value);
}
member ZeroOutputPCMZ : Pcm1792aTypeZeroOutputPcm with get, set

Property Value

Type: Pcm1792aTypeZeroOutputPcm
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a Methods

The Pcm1792a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.Flush Method

IRD

Pcm1792aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcm1792a Class
telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeAttenuationLevel Enumeration

IRD

Pcm1792aTypeAttenuationLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuationLevel
Public Enumeration TypeAttenuationLevel
public enum class TypeAttenuationLevel
type TypeAttenuationLevel
Members
Member name | Value | Description
Mute | 0 | Mute
Value_1200DB | 15 | -120.0 dB
Value_1195DB | 16 | -119.5 dB
Value_1190DB | 17 | -119.0 dB
Value_1185DB | 18 | -118.5 dB
Value_1180DB | 19 | -118.0 dB
Value_1175DB | 20 | -117.5 dB
Value_1170DB | 21 | -117.0 dB
Value_1165DB | 22 | -116.5 dB
Value_1160DB | 23 | -116.0 dB
Value_1155DB | 24 | -115.5 dB
Value_1150DB | 25 | -115.0 dB
Value_1145DB | 26 | -114.5 dB
Value_1140DB | 27 | -114.0 dB
Value_1135DB | 28 | -113.5 dB
Value_1130DB | 29 | -113.0 dB
Value_1125DB | 30 | -112.5 dB
Value_1120DB | 31 | -112.0 dB
Value_1115DB | 32 | -111.5 dB
Value_1110DB | 33 | -111.0 dB
Value_1105DB | 34 | -110.5 dB
Value_1100DB | 35 | -110.0 dB
Value_1095DB | 36 | -109.5 dB
Value_1090DB | 37 | -109.0 dB
Value_1085DB | 38 | -108.5 dB
Value_1080DB | 39 | -108.0 dB
Value_1075DB | 40 | -107.5 dB
Value_1070DB | 41 | -107.0 dB
Value_1065DB | 42 | -106.5 dB
Value_1060DB | 43 | -106.0 dB
Value_1055DB | 44 | -105.5 dB
Value_1050DB | 45 | -105.0 dB
Value_1045DB | 46 | -104.5 dB
Value_1040DB | 47 | -104.0 dB
Value_1035DB | 48 | -103.5 dB
Value_1030DB | 49 | -103.0 dB
Value_1025DB | 50 | -102.5 dB
Value_1020DB | 51 | -102.0 dB
Value_1015DB | 52 | -101.5 dB
Value_1010DB | 53 | -101.0 dB
Value_1005DB | 54 | -100.5 dB
Value_1000DB | 55 | -100.0 dB
Value_995DB | 56 | -99.5 dB
Value_990DB | 57 | -99.0 dB
Value_985DB | 58 | -98.5 dB
Value_980DB | 59 | -98.0 dB
Value_975DB | 60 | -97.5 dB
Value_970DB | 61 | -97.0 dB
Value_965DB | 62 | -96.5 dB
Value_960DB | 63 | -96.0 dB
Value_955DB | 64 | -95.5 dB
Value_950DB | 65 | -95.0 dB
Value_945DB | 66 | -94.5 dB
Value_940DB | 67 | -94.0 dB
Value_935DB | 68 | -93.5 dB
Value_930DB | 69 | -93.0 dB
Value_925DB | 70 | -92.5 dB
Value_920DB | 71 | -92.0 dB
Value_915DB | 72 | -91.5 dB
Value_910DB | 73 | -91.0 dB
Value_905DB | 74 | -90.5 dB
Value_900DB | 75 | -90.0 dB
Value_895DB | 76 | -89.5 dB
Value_890DB | 77 | -89.0 dB
Value_885DB | 78 | -88.5 dB
Value_880DB | 79 | -88.0 dB
Value_875DB | 80 | -87.5 dB
Value_870DB | 81 | -87.0 dB
Value_865DB | 82 | -86.5 dB
Value_860DB | 83 | -86.0 dB
Value_855DB | 84 | -85.5 dB
Value_850DB | 85 | -85.0 dB
Value_845DB | 86 | -84.5 dB
Value_840DB | 87 | -84.0 dB
Value_835DB | 88 | -83.5 dB
Value_830DB | 89 | -83.0 dB
Value_825DB | 90 | -82.5 dB
Value_820DB | 91 | -82.0 dB
Value_815DB | 92 | -81.5 dB
Value_810DB | 93 | -81.0 dB
Value_805DB | 94 | -80.5 dB
Value_800DB | 95 | -80.0 dB
Value_795DB | 96 | -79.5 dB
Value_790DB | 97 | -79.0 dB
Value_785DB | 98 | -78.5 dB
Value_780DB | 99 | -78.0 dB
Value_775DB | 100 | -77.5 dB
Value_770DB | 101 | -77.0 dB
Value_765DB | 102 | -76.5 dB
Value_760DB | 103 | -76.0 dB
Value_755DB | 104 | -75.5 dB
Value_750DB | 105 | -75.0 dB
Value_745DB | 106 | -74.5 dB
Value_740DB | 107 | -74.0 dB
Value_735DB | 108 | -73.5 dB
Value_730DB | 109 | -73.0 dB
Value_725DB | 110 | -72.5 dB
Value_720DB | 111 | -72.0 dB
Value_715DB | 112 | -71.5 dB
Value_710DB | 113 | -71.0 dB
Value_705DB | 114 | -70.5 dB
Value_700DB | 115 | -70.0 dB
Value_695DB | 116 | -69.5 dB
Value_690DB | 117 | -69.0 dB
Value_685DB | 118 | -68.5 dB
Value_680DB | 119 | -68.0 dB
Value_675DB | 120 | -67.5 dB
Value_670DB | 121 | -67.0 dB
Value_665DB | 122 | -66.5 dB
Value_660DB | 123 | -66.0 dB
Value_655DB | 124 | -65.5 dB
Value_650DB | 125 | -65.0 dB
Value_645DB | 126 | -64.5 dB
Value_640DB | 127 | -64.0 dB
Value_635DB | 128 | -63.5 dB
Value_630DB | 129 | -63.0 dB
Value_625DB | 130 | -62.5 dB
Value_620DB | 131 | -62.0 dB
Value_615DB | 132 | -61.5 dB
Value_610DB | 133 | -61.0 dB
Value_605DB | 134 | -60.5 dB
Value_600DB | 135 | -60.0 dB
Value_595DB | 136 | -59.5 dB
Value_590DB | 137 | -59.0 dB
Value_585DB | 138 | -58.5 dB
Value_580DB | 139 | -58.0 dB
Value_575DB | 140 | -57.5 dB
Value_570DB | 141 | -57.0 dB
Value_565DB | 142 | -56.5 dB
Value_560DB | 143 | -56.0 dB
Value_555DB | 144 | -55.5 dB
Value_550DB | 145 | -55.0 dB
Value_545DB | 146 | -54.5 dB
Value_540DB | 147 | -54.0 dB
Value_535DB | 148 | -53.5 dB
Value_530DB | 149 | -53.0 dB
Value_525DB | 150 | -52.5 dB
Value_520DB | 151 | -52.0 dB
Value_515DB | 152 | -51.5 dB
Value_510DB | 153 | -51.0 dB
Value_505DB | 154 | -50.5 dB
Value_500DB | 155 | -50.0 dB
Value_495DB | 156 | -49.5 dB
Value_490DB | 157 | -49.0 dB
Value_485DB | 158 | -48.5 dB
Value_480DB | 159 | -48.0 dB
Value_475DB | 160 | -47.5 dB
Value_470DB | 161 | -47.0 dB
Value_465DB | 162 | -46.5 dB
Value_460DB | 163 | -46.0 dB
Value_455DB | 164 | -45.5 dB
Value_450DB | 165 | -45.0 dB
Value_445DB | 166 | -44.5 dB
Value_440DB | 167 | -44.0 dB
Value_435DB | 168 | -43.5 dB
Value_430DB | 169 | -43.0 dB
Value_425DB | 170 | -42.5 dB
Value_420DB | 171 | -42.0 dB
Value_415DB | 172 | -41.5 dB
Value_410DB | 173 | -41.0 dB
Value_405DB | 174 | -40.5 dB
Value_400DB | 175 | -40.0 dB
Value_395DB | 176 | -39.5 dB
Value_390DB | 177 | -39.0 dB
Value_385DB | 178 | -38.5 dB
Value_380DB | 179 | -38.0 dB
Value_375DB | 180 | -37.5 dB
Value_370DB | 181 | -37.0 dB
Value_365DB | 182 | -36.5 dB
Value_360DB | 183 | -36.0 dB
Value_355DB | 184 | -35.5 dB
Value_350DB | 185 | -35.0 dB
Value_345DB | 186 | -34.5 dB
Value_340DB | 187 | -34.0 dB
Value_335DB | 188 | -33.5 dB
Value_330DB | 189 | -33.0 dB
Value_325DB | 190 | -32.5 dB
Value_320DB | 191 | -32.0 dB
Value_315DB | 192 | -31.5 dB
Value_310DB | 193 | -31.0 dB
Value_305DB | 194 | -30.5 dB
Value_300DB | 195 | -30.0 dB
Value_295DB | 196 | -29.5 dB
Value_290DB | 197 | -29.0 dB
Value_285DB | 198 | -28.5 dB
Value_280DB | 199 | -28.0 dB
Value_275DB | 200 | -27.5 dB
Value_270DB | 201 | -27.0 dB
Value_265DB | 202 | -26.5 dB
Value_260DB | 203 | -26.0 dB
Value_255DB | 204 | -25.5 dB
Value_250DB | 205 | -25.0 dB
Value_245DB | 206 | -24.5 dB
Value_240DB | 207 | -24.0 dB
Value_235DB | 208 | -23.5 dB
Value_230DB | 209 | -23.0 dB
Value_225DB | 210 | -22.5 dB
Value_220DB | 211 | -22.0 dB
Value_215DB | 212 | -21.5 dB
Value_210DB | 213 | -21.0 dB
Value_205DB | 214 | -20.5 dB
Value_200DB | 215 | -20.0 dB
Value_195DB | 216 | -19.5 dB
Value_190DB | 217 | -19.0 dB
Value_185DB | 218 | -18.5 dB
Value_180DB | 219 | -18.0 dB
Value_175DB | 220 | -17.5 dB
Value_170DB | 221 | -17.0 dB
Value_165DB | 222 | -16.5 dB
Value_160DB | 223 | -16.0 dB
Value_155DB | 224 | -15.5 dB
Value_150DB | 225 | -15.0 dB
Value_145DB | 226 | -14.5 dB
Value_140DB | 227 | -14.0 dB
Value_135DB | 228 | -13.5 dB
Value_130DB | 229 | -13.0 dB
Value_125DB | 230 | -12.5 dB
Value_120DB | 231 | -12.0 dB
Value_115DB | 232 | -11.5 dB
Value_110DB | 233 | -11.0 dB
Value_105DB | 234 | -10.5 dB
Value_100DB | 235 | -10.0 dB
Value_95DB | 236 | -9.5 dB
Value_90DB | 237 | -9.0 dB
Value_85DB | 238 | -8.5 dB
Value_80DB | 239 | -8.0 dB
Value_75DB | 240 | -7.5 dB
Value_70DB | 241 | -7.0 dB
Value_65DB | 242 | -6.5 dB
Value_60DB | 243 | -6.0 dB
Value_55DB | 244 | -5.5 dB
Value_50DB | 245 | -5.0 dB
Value_45DB | 246 | -4.5 dB
Value_40DB | 247 | -4.0 dB
Value_35DB | 248 | -3.5 dB
Value_30DB | 249 | -3.0 dB
Value_25DB | 250 | -2.5 dB
Value_20DB | 251 | -2.0 dB
Value_15DB | 252 | -1.5 dB
Value_10DB | 253 | -1.0 dB
Value_05DB | 254 | -0.5 dB
Value_0DB | 255 | 0 dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeAudioControlAttenuationLoad Enumeration

IRD

Pcm1792aTypeAudioControlAttenuationLoad Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlAttenuationLoad
Public Enumeration TypeAudioControlAttenuationLoad
public enum class TypeAudioControlAttenuationLoad
type TypeAudioControlAttenuationLoad
Members
Member name | Value | Description
AttenuationControlDisabled | 0 | Attenuation Control: Disabled
AttenuationControlEnabled | 1 | Attenuation Control: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeAudioControlDataFormat Enumeration

IRD

Pcm1792aTypeAudioControlDataFormat Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlDataFormat
Public Enumeration TypeAudioControlDataFormat
public enum class TypeAudioControlDataFormat
type TypeAudioControlDataFormat
Members
Member name | Value | Description
Value_16BitRightJustifiedStandardFormat | 0 | 16 Bit Right-Justified Standard Format
Value_20BitRightJustifiedStandardFormat | 1 | 20 Bit Right-Justified Standard Format
Value_24BitRightJustifiedStandardFormat | 2 | 24 Bit Right-Justified Standard Format
Value_24BitLeftJustifiedMSBFirstFormat | 3 | 24 Bit Left-Justified MSB-First Format
Value_16BitI2SFormat | 4 | 16 Bit I2S Format
Value_24BitI2SFormat | 5 | 24 Bit I2S Format
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeAudioControlDeEmphasis Enumeration

IRD

Pcm1792aTypeAudioControlDeEmphasis Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlDeEmphasis
Public Enumeration TypeAudioControlDeEmphasis
public enum class TypeAudioControlDeEmphasis
type TypeAudioControlDeEmphasis
Members
Member name | Value | Description
DeEmphasisDisabled | 0 | De-Emphasis: Disabled
DeEmphasisEnabled | 1 | De-Emphasis: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeAudioControlMute Enumeration

IRD

Pcm1792aTypeAudioControlMute Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlMute
Public Enumeration TypeAudioControlMute
public enum class TypeAudioControlMute
type TypeAudioControlMute
Members
Member name | Value | Description
MuteDisabled | 0 | Mute: Disabled
MuteEnabled | 1 | Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeAudioControlSampling Enumeration

IRD

Pcm1792aTypeAudioControlSampling Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlSampling
Public Enumeration TypeAudioControlSampling
public enum class TypeAudioControlSampling
type TypeAudioControlSampling
Members
Member name | Value | Description
SamplingFequencyDisabled | 0 | Sampling Fequency: Disabled
SamplingFequency48KHz | 1 | Sampling Fequency: 48 kHz
SamplingFequency441KHz | 2 | Sampling Fequency: 44.1 kHz
SamplingFequency32KHz | 3 | Sampling Fequency: 32 kHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeOperationControlBypass Enumeration

IRD

Pcm1792aTypeOperationControlBypass Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlBypass
Public Enumeration TypeOperationControlBypass
public enum class TypeOperationControlBypass
type TypeOperationControlBypass
Members
Member name | Value | Description
Monaural | 0 | Monaural
StereoInput | 1 | Stereo Input
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeOperationControlDac Enumeration

IRD

Pcm1792aTypeOperationControlDac Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlDac
Public Enumeration TypeOperationControlDac
public enum class TypeOperationControlDac
type TypeOperationControlDac
Members
Member name | Value | Description
DACOperationEnabled | 0 | DAC Operation: Enabled
DACOperationDisabled | 1 | DAC Operation: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeOperationControlFilter Enumeration

IRD

Pcm1792aTypeOperationControlFilter Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlFilter
Public Enumeration TypeOperationControlFilter
public enum class TypeOperationControlFilter
type TypeOperationControlFilter
Members
Member name | Value | Description
DigitalFilterSharpRollOff | 0 | Digital Filter: Sharp Roll-Off
DigitalFilterSlowRollOff | 1 | Digital Filter: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeOperationControlRate Enumeration

IRD

Pcm1792aTypeOperationControlRate Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlRate
Public Enumeration TypeOperationControlRate
public enum class TypeOperationControlRate
type TypeOperationControlRate
Members
Member name | Value | Description
AttenuationRateLRCK1 | 0 | Attenuation Rate: LRCK / 1
AttenuationRateLRCK2 | 1 | Attenuation Rate: LRCK / 2
AttenuationRateLRCK4 | 2 | Attenuation Rate: LRCK / 4
AttenuationRateLRCK8 | 3 | Attenuation Rate: LRCK / 8
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeOperationControlReversal Enumeration

IRD

Pcm1792aTypeOperationControlReversal Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlReversal
Public Enumeration TypeOperationControlReversal
public enum class TypeOperationControlReversal
type TypeOperationControlReversal
Members
Member name | Value | Description
OutputPhaseNormal | 0 | Output Phase: Normal
OutputPhaseInverted | 1 | Output Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeOperationControlZeroDetect Enumeration

IRD

Pcm1792aTypeOperationControlZeroDetect Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlZeroDetect
Public Enumeration TypeOperationControlZeroDetect
public enum class TypeOperationControlZeroDetect
type TypeOperationControlZeroDetect
Members
Member name | Value | Description
InfiniteZeroDetectMuteDisabled | 0 | Infinite Zero Detect Mute: Disabled
InfiniteZeroDetectMuteEnabled | 1 | Infinite Zero Detect Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeSignalControlChannel Enumeration

IRD

Pcm1792aTypeSignalControlChannel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlChannel
Public Enumeration TypeSignalControlChannel
public enum class TypeSignalControlChannel
type TypeSignalControlChannel
Members
Member name | Value | Description
LChannelSelected | 0 | L-Channel Selected
RChannelSelected | 1 | R-Channel Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeSignalControlFilter Enumeration

IRD

Pcm1792aTypeSignalControlFilter Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlFilter
Public Enumeration TypeSignalControlFilter
public enum class TypeSignalControlFilter
type TypeSignalControlFilter
Members
Member name | Value | Description
DigitalFilterEnabled | 0 | Digital Filter: Enabled
DigitalFilterBypassedForExternalFilter | 1 | Digital Filter: Bypassed For External Filter
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeSignalControlMode Enumeration

IRD

Pcm1792aTypeSignalControlMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlMode
Public Enumeration TypeSignalControlMode
public enum class TypeSignalControlMode
type TypeSignalControlMode
Members
Member name | Value | Description
DSDInterfaceModeDisabled | 0 | DSD Interface Mode: Disabled
DSDInterfaceModeEnabled | 1 | DSD Interface Mode: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeSignalControlMono Enumeration

IRD

Pcm1792aTypeSignalControlMono Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlMono
Public Enumeration TypeSignalControlMono
public enum class TypeSignalControlMono
type TypeSignalControlMono
Members
Member name | Value | Description
StereoMode | 0 | Stereo Mode
MonauralMode | 1 | Monaural Mode
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeSignalControlReset Enumeration

IRD

Pcm1792aTypeSignalControlReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlReset
Public Enumeration TypeSignalControlReset
public enum class TypeSignalControlReset
type TypeSignalControlReset
Members
Member name | Value | Description
SystemResetNormalOperation | 0 | System Reset: Normal Operation
SystemResetOperationOneResetPulse | 1 | System Reset Operation (One Reset Pulse)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeSignalControlSpeed Enumeration

IRD

Pcm1792aTypeSignalControlSpeed Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlSpeed
Public Enumeration TypeSignalControlSpeed
public enum class TypeSignalControlSpeed
type TypeSignalControlSpeed
Members
Member name | Value | Description
OperationSpeed64XFs | 0 | Operation Speed: 64 x Fs
OperationSpeed32XFs | 1 | Operation Speed: 32 x Fs
OperationSpeed128XFs | 2 | Operation Speed: 128 x Fs
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeZeroDetectionFlagLeft Enumeration

IRD

Pcm1792aTypeZeroDetectionFlagLeft Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroDetectionFlagLeft
Public Enumeration TypeZeroDetectionFlagLeft
public enum class TypeZeroDetectionFlagLeft
type TypeZeroDetectionFlagLeft
Members
Member name | Value | Description
LChannelZeroNotDetected | 0 | L-Channel: Zero Not Detected
LChannelZeroDetected | 1 | L-Channel: Zero Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeZeroDetectionFlagRight Enumeration

IRD

Pcm1792aTypeZeroDetectionFlagRight Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroDetectionFlagRight
Public Enumeration TypeZeroDetectionFlagRight
public enum class TypeZeroDetectionFlagRight
type TypeZeroDetectionFlagRight
Members
Member name | Value | Description
RChannelZeroNotDetected | 0 | R-Channel: Zero Not Detected
RChannelZeroDetected | 1 | R-Channel: Zero Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeZeroOutputDsd Enumeration

IRD

Pcm1792aTypeZeroOutputDsd Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroOutputDsd
Public Enumeration TypeZeroOutputDsd
public enum class TypeZeroOutputDsd
type TypeZeroOutputDsd
Members
Member name | Value | Description
ZeroOutputDisabled | 0 | Zero Output: Disabled
ZeroOutputEvenPatternDetect | 1 | Zero Output: Even Pattern Detect
ZeroOutput96HPatternDetect | 2 | Zero Output: 96H Pattern Detect
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1792a.TypeZeroOutputPcm Enumeration

IRD

Pcm1792aTypeZeroOutputPcm Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroOutputPcm
Public Enumeration TypeZeroOutputPcm
public enum class TypeZeroOutputPcm
type TypeZeroOutputPcm
Members
Member name | Value | Description
PCMZeroOutputDisabled | 0 | PCM Zero Output: Disabled
PCMZeroOutputEnabled | 1 | PCM Zero Output: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795 Class

Texas Instruments: PCM 1795
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPcm1795

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcm1795
Public Class Pcm1795
public ref class Pcm1795
type Pcm1795 =  class end

The Pcm1795 type exposes the following members.

Constructors
 | Name | Description
Public method | Pcm1795 | Constructor
Top
Properties
 | Name | Description
Public property | AttenuationLeftATL | Attenuation Left: ATL
Public property | AttenuationRightATR | Attenuation Right: ATR
Public property | AudioControlATLD | Audio Control: ATLD
Public property | AudioControlDME | Audio Control: DME
Public property | AudioControlDMF | Audio Control: DMF
Public property | AudioControlFMT | Audio Control: FMT
Public property | AudioControlMUTE | Audio Control: MUTE
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DeviceIDID | Device ID: ID
Public property | OperationControlATS | Operation Control: ATS
Public property | OperationControlDFMS | Operation Control: DFMS
Public property | OperationControlFLT | Operation Control: FLT
Public property | OperationControlINZD | Operation Control: INZD
Public property | OperationControlOPE | Operation Control: OPE
Public property | OperationControlREV | Operation Control: REV
Public property | SignalControlCHSL | Signal Control: CHSL
Public property | SignalControlDFTH | Signal Control: DFTH
Public property | SignalControlDSD | Signal Control: DSD
Public property | SignalControlMONO | Signal Control: MONO
Public property | SignalControlOS | Signal Control: OS
Public property | SignalControlSRST | Signal Control: SRST
Public property | ZeroDetectionZFGL | Zero Detection: ZFGL
Public property | ZeroDetectionZFGR | Zero Detection: ZFGR
Public property | ZeroOutputDZ | Zero Output: DZ
Public property | ZeroOutputPCMZ | Zero Output: PCMZ
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Stereo Audio Digital-To-Analog Converter
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcm1795(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcm1795

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795 Properties

The Pcm1795 type exposes the following members.

Properties
 | Name | Description
Public property | AttenuationLeftATL | Attenuation Left: ATL
Public property | AttenuationRightATR | Attenuation Right: ATR
Public property | AudioControlATLD | Audio Control: ATLD
Public property | AudioControlDME | Audio Control: DME
Public property | AudioControlDMF | Audio Control: DMF
Public property | AudioControlFMT | Audio Control: FMT
Public property | AudioControlMUTE | Audio Control: MUTE
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DeviceIDID | Device ID: ID
Public property | OperationControlATS | Operation Control: ATS
Public property | OperationControlDFMS | Operation Control: DFMS
Public property | OperationControlFLT | Operation Control: FLT
Public property | OperationControlINZD | Operation Control: INZD
Public property | OperationControlOPE | Operation Control: OPE
Public property | OperationControlREV | Operation Control: REV
Public property | SignalControlCHSL | Signal Control: CHSL
Public property | SignalControlDFTH | Signal Control: DFTH
Public property | SignalControlDSD | Signal Control: DSD
Public property | SignalControlMONO | Signal Control: MONO
Public property | SignalControlOS | Signal Control: OS
Public property | SignalControlSRST | Signal Control: SRST
Public property | ZeroDetectionZFGL | Zero Detection: ZFGL
Public property | ZeroDetectionZFGR | Zero Detection: ZFGR
Public property | ZeroOutputDZ | Zero Output: DZ
Public property | ZeroOutputPCMZ | Zero Output: PCMZ
Top
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.AttenuationLeftATL Property

IRD

Pcm1795AttenuationLeftATL Property

Attenuation Left: ATL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeAttenuationLevel AttenuationLeftATL { get; set; }
Public Property AttenuationLeftATL As Pcm1795TypeAttenuationLevel
    Get
    Set
public:
property Pcm1795TypeAttenuationLevel AttenuationLeftATL {
    Pcm1795TypeAttenuationLevel get ();
    void set (Pcm1795TypeAttenuationLevel value);
}
member AttenuationLeftATL : Pcm1795TypeAttenuationLevel with get, set

Property Value

Type: Pcm1795TypeAttenuationLevel
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.AttenuationRightATR Property

IRD

Pcm1795AttenuationRightATR Property

Attenuation Right: ATR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeAttenuationLevel AttenuationRightATR { get; set; }
Public Property AttenuationRightATR As Pcm1795TypeAttenuationLevel
    Get
    Set
public:
property Pcm1795TypeAttenuationLevel AttenuationRightATR {
    Pcm1795TypeAttenuationLevel get ();
    void set (Pcm1795TypeAttenuationLevel value);
}
member AttenuationRightATR : Pcm1795TypeAttenuationLevel with get, set

Property Value

Type: Pcm1795TypeAttenuationLevel
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.AudioControlATLD Property

IRD

Pcm1795AudioControlATLD Property

Audio Control: ATLD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeAudioControlAttenuationLoad AudioControlATLD { get; set; }
Public Property AudioControlATLD As Pcm1795TypeAudioControlAttenuationLoad
    Get
    Set
public:
property Pcm1795TypeAudioControlAttenuationLoad AudioControlATLD {
    Pcm1795TypeAudioControlAttenuationLoad get ();
    void set (Pcm1795TypeAudioControlAttenuationLoad value);
}
member AudioControlATLD : Pcm1795TypeAudioControlAttenuationLoad with get, set

Property Value

Type: Pcm1795TypeAudioControlAttenuationLoad
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.AudioControlDME Property

IRD

Pcm1795AudioControlDME Property

Audio Control: DME

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeAudioControlDeEmphasis AudioControlDME { get; set; }
Public Property AudioControlDME As Pcm1795TypeAudioControlDeEmphasis
    Get
    Set
public:
property Pcm1795TypeAudioControlDeEmphasis AudioControlDME {
    Pcm1795TypeAudioControlDeEmphasis get ();
    void set (Pcm1795TypeAudioControlDeEmphasis value);
}
member AudioControlDME : Pcm1795TypeAudioControlDeEmphasis with get, set

Property Value

Type: Pcm1795TypeAudioControlDeEmphasis
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.AudioControlDMF Property

IRD

Pcm1795AudioControlDMF Property

Audio Control: DMF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeAudioControlSampling AudioControlDMF { get; set; }
Public Property AudioControlDMF As Pcm1795TypeAudioControlSampling
    Get
    Set
public:
property Pcm1795TypeAudioControlSampling AudioControlDMF {
    Pcm1795TypeAudioControlSampling get ();
    void set (Pcm1795TypeAudioControlSampling value);
}
member AudioControlDMF : Pcm1795TypeAudioControlSampling with get, set

Property Value

Type: Pcm1795TypeAudioControlSampling
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.AudioControlFMT Property

IRD

Pcm1795AudioControlFMT Property

Audio Control: FMT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeAudioControlDataFormat AudioControlFMT { get; set; }
Public Property AudioControlFMT As Pcm1795TypeAudioControlDataFormat
    Get
    Set
public:
property Pcm1795TypeAudioControlDataFormat AudioControlFMT {
    Pcm1795TypeAudioControlDataFormat get ();
    void set (Pcm1795TypeAudioControlDataFormat value);
}
member AudioControlFMT : Pcm1795TypeAudioControlDataFormat with get, set

Property Value

Type: Pcm1795TypeAudioControlDataFormat
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.AudioControlMUTE Property

IRD

Pcm1795AudioControlMUTE Property

Audio Control: MUTE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeAudioControlMute AudioControlMUTE { get; set; }
Public Property AudioControlMUTE As Pcm1795TypeAudioControlMute
    Get
    Set
public:
property Pcm1795TypeAudioControlMute AudioControlMUTE {
    Pcm1795TypeAudioControlMute get ();
    void set (Pcm1795TypeAudioControlMute value);
}
member AudioControlMUTE : Pcm1795TypeAudioControlMute with get, set

Property Value

Type: Pcm1795TypeAudioControlMute
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.AutoFlush Property

IRD

Pcm1795AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.DeviceIDID Property

IRD

Pcm1795DeviceIDID Property

Device ID: ID

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceIDID { get; }
Public ReadOnly Property DeviceIDID As Byte
    Get
public:
property unsigned char DeviceIDID {
    unsigned char get ();
}
member DeviceIDID : byte with get

Property Value

Type: Byte
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.OperationControlATS Property

IRD

Pcm1795OperationControlATS Property

Operation Control: ATS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeOperationControlRate OperationControlATS { get; set; }
Public Property OperationControlATS As Pcm1795TypeOperationControlRate
    Get
    Set
public:
property Pcm1795TypeOperationControlRate OperationControlATS {
    Pcm1795TypeOperationControlRate get ();
    void set (Pcm1795TypeOperationControlRate value);
}
member OperationControlATS : Pcm1795TypeOperationControlRate with get, set

Property Value

Type: Pcm1795TypeOperationControlRate
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.OperationControlDFMS Property

IRD

Pcm1795OperationControlDFMS Property

Operation Control: DFMS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeOperationControlBypass OperationControlDFMS { get; set; }
Public Property OperationControlDFMS As Pcm1795TypeOperationControlBypass
    Get
    Set
public:
property Pcm1795TypeOperationControlBypass OperationControlDFMS {
    Pcm1795TypeOperationControlBypass get ();
    void set (Pcm1795TypeOperationControlBypass value);
}
member OperationControlDFMS : Pcm1795TypeOperationControlBypass with get, set

Property Value

Type: Pcm1795TypeOperationControlBypass
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.OperationControlFLT Property

IRD

Pcm1795OperationControlFLT Property

Operation Control: FLT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeOperationControlFilter OperationControlFLT { get; set; }
Public Property OperationControlFLT As Pcm1795TypeOperationControlFilter
    Get
    Set
public:
property Pcm1795TypeOperationControlFilter OperationControlFLT {
    Pcm1795TypeOperationControlFilter get ();
    void set (Pcm1795TypeOperationControlFilter value);
}
member OperationControlFLT : Pcm1795TypeOperationControlFilter with get, set

Property Value

Type: Pcm1795TypeOperationControlFilter
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.OperationControlINZD Property

IRD

Pcm1795OperationControlINZD Property

Operation Control: INZD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeOperationControlZeroDetect OperationControlINZD { get; set; }
Public Property OperationControlINZD As Pcm1795TypeOperationControlZeroDetect
    Get
    Set
public:
property Pcm1795TypeOperationControlZeroDetect OperationControlINZD {
    Pcm1795TypeOperationControlZeroDetect get ();
    void set (Pcm1795TypeOperationControlZeroDetect value);
}
member OperationControlINZD : Pcm1795TypeOperationControlZeroDetect with get, set

Property Value

Type: Pcm1795TypeOperationControlZeroDetect
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.OperationControlOPE Property

IRD

Pcm1795OperationControlOPE Property

Operation Control: OPE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeOperationControlDac OperationControlOPE { get; set; }
Public Property OperationControlOPE As Pcm1795TypeOperationControlDac
    Get
    Set
public:
property Pcm1795TypeOperationControlDac OperationControlOPE {
    Pcm1795TypeOperationControlDac get ();
    void set (Pcm1795TypeOperationControlDac value);
}
member OperationControlOPE : Pcm1795TypeOperationControlDac with get, set

Property Value

Type: Pcm1795TypeOperationControlDac
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.OperationControlREV Property

IRD

Pcm1795OperationControlREV Property

Operation Control: REV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeOperationControlReversal OperationControlREV { get; set; }
Public Property OperationControlREV As Pcm1795TypeOperationControlReversal
    Get
    Set
public:
property Pcm1795TypeOperationControlReversal OperationControlREV {
    Pcm1795TypeOperationControlReversal get ();
    void set (Pcm1795TypeOperationControlReversal value);
}
member OperationControlREV : Pcm1795TypeOperationControlReversal with get, set

Property Value

Type: Pcm1795TypeOperationControlReversal
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.SignalControlCHSL Property

IRD

Pcm1795SignalControlCHSL Property

Signal Control: CHSL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeSignalControlChannel SignalControlCHSL { get; set; }
Public Property SignalControlCHSL As Pcm1795TypeSignalControlChannel
    Get
    Set
public:
property Pcm1795TypeSignalControlChannel SignalControlCHSL {
    Pcm1795TypeSignalControlChannel get ();
    void set (Pcm1795TypeSignalControlChannel value);
}
member SignalControlCHSL : Pcm1795TypeSignalControlChannel with get, set

Property Value

Type: Pcm1795TypeSignalControlChannel
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.SignalControlDFTH Property

IRD

Pcm1795SignalControlDFTH Property

Signal Control: DFTH

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeSignalControlFilter SignalControlDFTH { get; set; }
Public Property SignalControlDFTH As Pcm1795TypeSignalControlFilter
    Get
    Set
public:
property Pcm1795TypeSignalControlFilter SignalControlDFTH {
    Pcm1795TypeSignalControlFilter get ();
    void set (Pcm1795TypeSignalControlFilter value);
}
member SignalControlDFTH : Pcm1795TypeSignalControlFilter with get, set

Property Value

Type: Pcm1795TypeSignalControlFilter
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.SignalControlDSD Property

IRD

Pcm1795SignalControlDSD Property

Signal Control: DSD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeSignalControlMode SignalControlDSD { get; set; }
Public Property SignalControlDSD As Pcm1795TypeSignalControlMode
    Get
    Set
public:
property Pcm1795TypeSignalControlMode SignalControlDSD {
    Pcm1795TypeSignalControlMode get ();
    void set (Pcm1795TypeSignalControlMode value);
}
member SignalControlDSD : Pcm1795TypeSignalControlMode with get, set

Property Value

Type: Pcm1795TypeSignalControlMode
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.SignalControlMONO Property

IRD

Pcm1795SignalControlMONO Property

Signal Control: MONO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeSignalControlMono SignalControlMONO { get; set; }
Public Property SignalControlMONO As Pcm1795TypeSignalControlMono
    Get
    Set
public:
property Pcm1795TypeSignalControlMono SignalControlMONO {
    Pcm1795TypeSignalControlMono get ();
    void set (Pcm1795TypeSignalControlMono value);
}
member SignalControlMONO : Pcm1795TypeSignalControlMono with get, set

Property Value

Type: Pcm1795TypeSignalControlMono
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.SignalControlOS Property

IRD

Pcm1795SignalControlOS Property

Signal Control: OS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeSignalControlSpeed SignalControlOS { get; set; }
Public Property SignalControlOS As Pcm1795TypeSignalControlSpeed
    Get
    Set
public:
property Pcm1795TypeSignalControlSpeed SignalControlOS {
    Pcm1795TypeSignalControlSpeed get ();
    void set (Pcm1795TypeSignalControlSpeed value);
}
member SignalControlOS : Pcm1795TypeSignalControlSpeed with get, set

Property Value

Type: Pcm1795TypeSignalControlSpeed
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.SignalControlSRST Property

IRD

Pcm1795SignalControlSRST Property

Signal Control: SRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeSignalControlReset SignalControlSRST { get; set; }
Public Property SignalControlSRST As Pcm1795TypeSignalControlReset
    Get
    Set
public:
property Pcm1795TypeSignalControlReset SignalControlSRST {
    Pcm1795TypeSignalControlReset get ();
    void set (Pcm1795TypeSignalControlReset value);
}
member SignalControlSRST : Pcm1795TypeSignalControlReset with get, set

Property Value

Type: Pcm1795TypeSignalControlReset
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.ZeroDetectionZFGL Property

IRD

Pcm1795ZeroDetectionZFGL Property

Zero Detection: ZFGL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeZeroDetectionFlagLeft ZeroDetectionZFGL { get; }
Public ReadOnly Property ZeroDetectionZFGL As Pcm1795TypeZeroDetectionFlagLeft
    Get
public:
property Pcm1795TypeZeroDetectionFlagLeft ZeroDetectionZFGL {
    Pcm1795TypeZeroDetectionFlagLeft get ();
}
member ZeroDetectionZFGL : Pcm1795TypeZeroDetectionFlagLeft with get

Property Value

Type: Pcm1795TypeZeroDetectionFlagLeft
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.ZeroDetectionZFGR Property

IRD

Pcm1795ZeroDetectionZFGR Property

Zero Detection: ZFGR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeZeroDetectionFlagRight ZeroDetectionZFGR { get; }
Public ReadOnly Property ZeroDetectionZFGR As Pcm1795TypeZeroDetectionFlagRight
    Get
public:
property Pcm1795TypeZeroDetectionFlagRight ZeroDetectionZFGR {
    Pcm1795TypeZeroDetectionFlagRight get ();
}
member ZeroDetectionZFGR : Pcm1795TypeZeroDetectionFlagRight with get

Property Value

Type: Pcm1795TypeZeroDetectionFlagRight
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.ZeroOutputDZ Property

IRD

Pcm1795ZeroOutputDZ Property

Zero Output: DZ

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeZeroOutputDsd ZeroOutputDZ { get; set; }
Public Property ZeroOutputDZ As Pcm1795TypeZeroOutputDsd
    Get
    Set
public:
property Pcm1795TypeZeroOutputDsd ZeroOutputDZ {
    Pcm1795TypeZeroOutputDsd get ();
    void set (Pcm1795TypeZeroOutputDsd value);
}
member ZeroOutputDZ : Pcm1795TypeZeroOutputDsd with get, set

Property Value

Type: Pcm1795TypeZeroOutputDsd
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.ZeroOutputPCMZ Property

IRD

Pcm1795ZeroOutputPCMZ Property

Zero Output: PCMZ

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1795TypeZeroOutputPcm ZeroOutputPCMZ { get; set; }
Public Property ZeroOutputPCMZ As Pcm1795TypeZeroOutputPcm
    Get
    Set
public:
property Pcm1795TypeZeroOutputPcm ZeroOutputPCMZ {
    Pcm1795TypeZeroOutputPcm get ();
    void set (Pcm1795TypeZeroOutputPcm value);
}
member ZeroOutputPCMZ : Pcm1795TypeZeroOutputPcm with get, set

Property Value

Type: Pcm1795TypeZeroOutputPcm
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795 Methods

The Pcm1795 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.Flush Method

IRD

Pcm1795Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcm1795 Class
telos.Ird.TexasInstruments Namespace


Pcm1795.TypeAttenuationLevel Enumeration

IRD

Pcm1795TypeAttenuationLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuationLevel
Public Enumeration TypeAttenuationLevel
public enum class TypeAttenuationLevel
type TypeAttenuationLevel
Members
Member name | Value | Description
Mute | 0 | Mute
Value_1200DB | 15 | -120.0 dB
Value_1195DB | 16 | -119.5 dB
Value_1190DB | 17 | -119.0 dB
Value_1185DB | 18 | -118.5 dB
Value_1180DB | 19 | -118.0 dB
Value_1175DB | 20 | -117.5 dB
Value_1170DB | 21 | -117.0 dB
Value_1165DB | 22 | -116.5 dB
Value_1160DB | 23 | -116.0 dB
Value_1155DB | 24 | -115.5 dB
Value_1150DB | 25 | -115.0 dB
Value_1145DB | 26 | -114.5 dB
Value_1140DB | 27 | -114.0 dB
Value_1135DB | 28 | -113.5 dB
Value_1130DB | 29 | -113.0 dB
Value_1125DB | 30 | -112.5 dB
Value_1120DB | 31 | -112.0 dB
Value_1115DB | 32 | -111.5 dB
Value_1110DB | 33 | -111.0 dB
Value_1105DB | 34 | -110.5 dB
Value_1100DB | 35 | -110.0 dB
Value_1095DB | 36 | -109.5 dB
Value_1090DB | 37 | -109.0 dB
Value_1085DB | 38 | -108.5 dB
Value_1080DB | 39 | -108.0 dB
Value_1075DB | 40 | -107.5 dB
Value_1070DB | 41 | -107.0 dB
Value_1065DB | 42 | -106.5 dB
Value_1060DB | 43 | -106.0 dB
Value_1055DB | 44 | -105.5 dB
Value_1050DB | 45 | -105.0 dB
Value_1045DB | 46 | -104.5 dB
Value_1040DB | 47 | -104.0 dB
Value_1035DB | 48 | -103.5 dB
Value_1030DB | 49 | -103.0 dB
Value_1025DB | 50 | -102.5 dB
Value_1020DB | 51 | -102.0 dB
Value_1015DB | 52 | -101.5 dB
Value_1010DB | 53 | -101.0 dB
Value_1005DB | 54 | -100.5 dB
Value_1000DB | 55 | -100.0 dB
Value_995DB | 56 | -99.5 dB
Value_990DB | 57 | -99.0 dB
Value_985DB | 58 | -98.5 dB
Value_980DB | 59 | -98.0 dB
Value_975DB | 60 | -97.5 dB
Value_970DB | 61 | -97.0 dB
Value_965DB | 62 | -96.5 dB
Value_960DB | 63 | -96.0 dB
Value_955DB | 64 | -95.5 dB
Value_950DB | 65 | -95.0 dB
Value_945DB | 66 | -94.5 dB
Value_940DB | 67 | -94.0 dB
Value_935DB | 68 | -93.5 dB
Value_930DB | 69 | -93.0 dB
Value_925DB | 70 | -92.5 dB
Value_920DB | 71 | -92.0 dB
Value_915DB | 72 | -91.5 dB
Value_910DB | 73 | -91.0 dB
Value_905DB | 74 | -90.5 dB
Value_900DB | 75 | -90.0 dB
Value_895DB | 76 | -89.5 dB
Value_890DB | 77 | -89.0 dB
Value_885DB | 78 | -88.5 dB
Value_880DB | 79 | -88.0 dB
Value_875DB | 80 | -87.5 dB
Value_870DB | 81 | -87.0 dB
Value_865DB | 82 | -86.5 dB
Value_860DB | 83 | -86.0 dB
Value_855DB | 84 | -85.5 dB
Value_850DB | 85 | -85.0 dB
Value_845DB | 86 | -84.5 dB
Value_840DB | 87 | -84.0 dB
Value_835DB | 88 | -83.5 dB
Value_830DB | 89 | -83.0 dB
Value_825DB | 90 | -82.5 dB
Value_820DB | 91 | -82.0 dB
Value_815DB | 92 | -81.5 dB
Value_810DB | 93 | -81.0 dB
Value_805DB | 94 | -80.5 dB
Value_800DB | 95 | -80.0 dB
Value_795DB | 96 | -79.5 dB
Value_790DB | 97 | -79.0 dB
Value_785DB | 98 | -78.5 dB
Value_780DB | 99 | -78.0 dB
Value_775DB | 100 | -77.5 dB
Value_770DB | 101 | -77.0 dB
Value_765DB | 102 | -76.5 dB
Value_760DB | 103 | -76.0 dB
Value_755DB | 104 | -75.5 dB
Value_750DB | 105 | -75.0 dB
Value_745DB | 106 | -74.5 dB
Value_740DB | 107 | -74.0 dB
Value_735DB | 108 | -73.5 dB
Value_730DB | 109 | -73.0 dB
Value_725DB | 110 | -72.5 dB
Value_720DB | 111 | -72.0 dB
Value_715DB | 112 | -71.5 dB
Value_710DB | 113 | -71.0 dB
Value_705DB | 114 | -70.5 dB
Value_700DB | 115 | -70.0 dB
Value_695DB | 116 | -69.5 dB
Value_690DB | 117 | -69.0 dB
Value_685DB | 118 | -68.5 dB
Value_680DB | 119 | -68.0 dB
Value_675DB | 120 | -67.5 dB
Value_670DB | 121 | -67.0 dB
Value_665DB | 122 | -66.5 dB
Value_660DB | 123 | -66.0 dB
Value_655DB | 124 | -65.5 dB
Value_650DB | 125 | -65.0 dB
Value_645DB | 126 | -64.5 dB
Value_640DB | 127 | -64.0 dB
Value_635DB | 128 | -63.5 dB
Value_630DB | 129 | -63.0 dB
Value_625DB | 130 | -62.5 dB
Value_620DB | 131 | -62.0 dB
Value_615DB | 132 | -61.5 dB
Value_610DB | 133 | -61.0 dB
Value_605DB | 134 | -60.5 dB
Value_600DB | 135 | -60.0 dB
Value_595DB | 136 | -59.5 dB
Value_590DB | 137 | -59.0 dB
Value_585DB | 138 | -58.5 dB
Value_580DB | 139 | -58.0 dB
Value_575DB | 140 | -57.5 dB
Value_570DB | 141 | -57.0 dB
Value_565DB | 142 | -56.5 dB
Value_560DB | 143 | -56.0 dB
Value_555DB | 144 | -55.5 dB
Value_550DB | 145 | -55.0 dB
Value_545DB | 146 | -54.5 dB
Value_540DB | 147 | -54.0 dB
Value_535DB | 148 | -53.5 dB
Value_530DB | 149 | -53.0 dB
Value_525DB | 150 | -52.5 dB
Value_520DB | 151 | -52.0 dB
Value_515DB | 152 | -51.5 dB
Value_510DB | 153 | -51.0 dB
Value_505DB | 154 | -50.5 dB
Value_500DB | 155 | -50.0 dB
Value_495DB | 156 | -49.5 dB
Value_490DB | 157 | -49.0 dB
Value_485DB | 158 | -48.5 dB
Value_480DB | 159 | -48.0 dB
Value_475DB | 160 | -47.5 dB
Value_470DB | 161 | -47.0 dB
Value_465DB | 162 | -46.5 dB
Value_460DB | 163 | -46.0 dB
Value_455DB | 164 | -45.5 dB
Value_450DB | 165 | -45.0 dB
Value_445DB | 166 | -44.5 dB
Value_440DB | 167 | -44.0 dB
Value_435DB | 168 | -43.5 dB
Value_430DB | 169 | -43.0 dB
Value_425DB | 170 | -42.5 dB
Value_420DB | 171 | -42.0 dB
Value_415DB | 172 | -41.5 dB
Value_410DB | 173 | -41.0 dB
Value_405DB | 174 | -40.5 dB
Value_400DB | 175 | -40.0 dB
Value_395DB | 176 | -39.5 dB
Value_390DB | 177 | -39.0 dB
Value_385DB | 178 | -38.5 dB
Value_380DB | 179 | -38.0 dB
Value_375DB | 180 | -37.5 dB
Value_370DB | 181 | -37.0 dB
Value_365DB | 182 | -36.5 dB
Value_360DB | 183 | -36.0 dB
Value_355DB | 184 | -35.5 dB
Value_350DB | 185 | -35.0 dB
Value_345DB | 186 | -34.5 dB
Value_340DB | 187 | -34.0 dB
Value_335DB | 188 | -33.5 dB
Value_330DB | 189 | -33.0 dB
Value_325DB | 190 | -32.5 dB
Value_320DB | 191 | -32.0 dB
Value_315DB | 192 | -31.5 dB
Value_310DB | 193 | -31.0 dB
Value_305DB | 194 | -30.5 dB
Value_300DB | 195 | -30.0 dB
Value_295DB | 196 | -29.5 dB
Value_290DB | 197 | -29.0 dB
Value_285DB | 198 | -28.5 dB
Value_280DB | 199 | -28.0 dB
Value_275DB | 200 | -27.5 dB
Value_270DB | 201 | -27.0 dB
Value_265DB | 202 | -26.5 dB
Value_260DB | 203 | -26.0 dB
Value_255DB | 204 | -25.5 dB
Value_250DB | 205 | -25.0 dB
Value_245DB | 206 | -24.5 dB
Value_240DB | 207 | -24.0 dB
Value_235DB | 208 | -23.5 dB
Value_230DB | 209 | -23.0 dB
Value_225DB | 210 | -22.5 dB
Value_220DB | 211 | -22.0 dB
Value_215DB | 212 | -21.5 dB
Value_210DB | 213 | -21.0 dB
Value_205DB | 214 | -20.5 dB
Value_200DB | 215 | -20.0 dB
Value_195DB | 216 | -19.5 dB
Value_190DB | 217 | -19.0 dB
Value_185DB | 218 | -18.5 dB
Value_180DB | 219 | -18.0 dB
Value_175DB | 220 | -17.5 dB
Value_170DB | 221 | -17.0 dB
Value_165DB | 222 | -16.5 dB
Value_160DB | 223 | -16.0 dB
Value_155DB | 224 | -15.5 dB
Value_150DB | 225 | -15.0 dB
Value_145DB | 226 | -14.5 dB
Value_140DB | 227 | -14.0 dB
Value_135DB | 228 | -13.5 dB
Value_130DB | 229 | -13.0 dB
Value_125DB | 230 | -12.5 dB
Value_120DB | 231 | -12.0 dB
Value_115DB | 232 | -11.5 dB
Value_110DB | 233 | -11.0 dB
Value_105DB | 234 | -10.5 dB
Value_100DB | 235 | -10.0 dB
Value_95DB | 236 | -9.5 dB
Value_90DB | 237 | -9.0 dB
Value_85DB | 238 | -8.5 dB
Value_80DB | 239 | -8.0 dB
Value_75DB | 240 | -7.5 dB
Value_70DB | 241 | -7.0 dB
Value_65DB | 242 | -6.5 dB
Value_60DB | 243 | -6.0 dB
Value_55DB | 244 | -5.5 dB
Value_50DB | 245 | -5.0 dB
Value_45DB | 246 | -4.5 dB
Value_40DB | 247 | -4.0 dB
Value_35DB | 248 | -3.5 dB
Value_30DB | 249 | -3.0 dB
Value_25DB | 250 | -2.5 dB
Value_20DB | 251 | -2.0 dB
Value_15DB | 252 | -1.5 dB
Value_10DB | 253 | -1.0 dB
Value_05DB | 254 | -0.5 dB
Value_0DB | 255 | 0 dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeAudioControlAttenuationLoad Enumeration

IRD

Pcm1795TypeAudioControlAttenuationLoad Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlAttenuationLoad
Public Enumeration TypeAudioControlAttenuationLoad
public enum class TypeAudioControlAttenuationLoad
type TypeAudioControlAttenuationLoad
Members
Member name | Value | Description
AttenuationControlDisabled | 0 | Attenuation Control: Disabled
AttenuationControlEnabled | 1 | Attenuation Control: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeAudioControlDataFormat Enumeration

IRD

Pcm1795TypeAudioControlDataFormat Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlDataFormat
Public Enumeration TypeAudioControlDataFormat
public enum class TypeAudioControlDataFormat
type TypeAudioControlDataFormat
Members
Member name | Value | Description
Value_16BitRightJustifiedStandardFormat | 0 | 16 Bit Right-Justified Standard Format
Value_20BitRightJustifiedStandardFormat | 1 | 20 Bit Right-Justified Standard Format
Value_24BitRightJustifiedStandardFormat | 2 | 24 Bit Right-Justified Standard Format
Value_24BitLeftJustifiedMSBFirstFormat | 3 | 24 Bit Left-Justified MSB-First Format
Value_16BitI2SFormat | 4 | 16 Bit I2S Format
Value_24BitI2SFormat | 5 | 24 Bit I2S Format
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeAudioControlDeEmphasis Enumeration

IRD

Pcm1795TypeAudioControlDeEmphasis Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlDeEmphasis
Public Enumeration TypeAudioControlDeEmphasis
public enum class TypeAudioControlDeEmphasis
type TypeAudioControlDeEmphasis
Members
Member name | Value | Description
DeEmphasisDisabled | 0 | De-Emphasis: Disabled
DeEmphasisEnabled | 1 | De-Emphasis: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeAudioControlMute Enumeration

IRD

Pcm1795TypeAudioControlMute Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlMute
Public Enumeration TypeAudioControlMute
public enum class TypeAudioControlMute
type TypeAudioControlMute
Members
Member name | Value | Description
MuteDisabled | 0 | Mute: Disabled
MuteEnabled | 1 | Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeAudioControlSampling Enumeration

IRD

Pcm1795TypeAudioControlSampling Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlSampling
Public Enumeration TypeAudioControlSampling
public enum class TypeAudioControlSampling
type TypeAudioControlSampling
Members
Member name | Value | Description
SamplingFequencyDisabled | 0 | Sampling Fequency: Disabled
SamplingFequency48KHz | 1 | Sampling Fequency: 48 kHz
SamplingFequency441KHz | 2 | Sampling Fequency: 44.1 kHz
SamplingFequency32KHz | 3 | Sampling Fequency: 32 kHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeOperationControlBypass Enumeration

IRD

Pcm1795TypeOperationControlBypass Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlBypass
Public Enumeration TypeOperationControlBypass
public enum class TypeOperationControlBypass
type TypeOperationControlBypass
Members
Member name | Value | Description
Monaural | 0 | Monaural
StereoInput | 1 | Stereo Input
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeOperationControlDac Enumeration

IRD

Pcm1795TypeOperationControlDac Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlDac
Public Enumeration TypeOperationControlDac
public enum class TypeOperationControlDac
type TypeOperationControlDac
Members
Member name | Value | Description
DACOperationEnabled | 0 | DAC Operation: Enabled
DACOperationDisabled | 1 | DAC Operation: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeOperationControlFilter Enumeration

IRD

Pcm1795TypeOperationControlFilter Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlFilter
Public Enumeration TypeOperationControlFilter
public enum class TypeOperationControlFilter
type TypeOperationControlFilter
Members
Member name | Value | Description
DigitalFilterSharpRollOff | 0 | Digital Filter: Sharp Roll-Off
DigitalFilterSlowRollOff | 1 | Digital Filter: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeOperationControlRate Enumeration

IRD

Pcm1795TypeOperationControlRate Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlRate
Public Enumeration TypeOperationControlRate
public enum class TypeOperationControlRate
type TypeOperationControlRate
Members
Member name | Value | Description
AttenuationRateEveryLRCK | 0 | Attenuation Rate: Every LRCK
AttenuationRateLRCK2 | 1 | Attenuation Rate: LRCK / 2
AttenuationRateLRCK4 | 2 | Attenuation Rate: LRCK / 4
AttenuationRateLRCK8 | 3 | Attenuation Rate: LRCK / 8
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeOperationControlReversal Enumeration

IRD

Pcm1795TypeOperationControlReversal Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlReversal
Public Enumeration TypeOperationControlReversal
public enum class TypeOperationControlReversal
type TypeOperationControlReversal
Members
Member name | Value | Description
OutputPhaseNormal | 0 | Output Phase: Normal
OutputPhaseInverted | 1 | Output Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeOperationControlZeroDetect Enumeration

IRD

Pcm1795TypeOperationControlZeroDetect Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlZeroDetect
Public Enumeration TypeOperationControlZeroDetect
public enum class TypeOperationControlZeroDetect
type TypeOperationControlZeroDetect
Members
Member name | Value | Description
InfiniteZeroDetectMuteDisabled | 0 | Infinite Zero Detect Mute: Disabled
InfiniteZeroDetectMuteEnabled | 1 | Infinite Zero Detect Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeSignalControlChannel Enumeration

IRD

Pcm1795TypeSignalControlChannel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlChannel
Public Enumeration TypeSignalControlChannel
public enum class TypeSignalControlChannel
type TypeSignalControlChannel
Members
Member name | Value | Description
LChannelSelected | 0 | L-Channel Selected
RChannelSelected | 1 | R-Channel Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeSignalControlFilter Enumeration

IRD

Pcm1795TypeSignalControlFilter Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlFilter
Public Enumeration TypeSignalControlFilter
public enum class TypeSignalControlFilter
type TypeSignalControlFilter
Members
Member name | Value | Description
DigitalFilterEnabled | 0 | Digital Filter: Enabled
DigitalFilterBypassedForExternalFilter | 1 | Digital Filter: Bypassed For External Filter
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeSignalControlMode Enumeration

IRD

Pcm1795TypeSignalControlMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlMode
Public Enumeration TypeSignalControlMode
public enum class TypeSignalControlMode
type TypeSignalControlMode
Members
Member name | Value | Description
DSDInterfaceModeDisabled | 0 | DSD Interface Mode: Disabled
DSDInterfaceModeEnabled | 1 | DSD Interface Mode: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeSignalControlMono Enumeration

IRD

Pcm1795TypeSignalControlMono Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlMono
Public Enumeration TypeSignalControlMono
public enum class TypeSignalControlMono
type TypeSignalControlMono
Members
Member name | Value | Description
StereoMode | 0 | Stereo Mode
MonauralMode | 1 | Monaural Mode
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeSignalControlReset Enumeration

IRD

Pcm1795TypeSignalControlReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlReset
Public Enumeration TypeSignalControlReset
public enum class TypeSignalControlReset
type TypeSignalControlReset
Members
Member name | Value | Description
SystemResetNormalOperation | 0 | System Reset: Normal Operation
SystemResetOperationOneResetPulse | 1 | System Reset Operation (One Reset Pulse)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeSignalControlSpeed Enumeration

IRD

Pcm1795TypeSignalControlSpeed Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlSpeed
Public Enumeration TypeSignalControlSpeed
public enum class TypeSignalControlSpeed
type TypeSignalControlSpeed
Members
Member name | Value | Description
OperationSpeed64XFs | 0 | Operation Speed: 64 x Fs
OperationSpeed32XFs | 1 | Operation Speed: 32 x Fs
OperationSpeed128XFs | 2 | Operation Speed: 128 x Fs
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeZeroDetectionFlagLeft Enumeration

IRD

Pcm1795TypeZeroDetectionFlagLeft Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroDetectionFlagLeft
Public Enumeration TypeZeroDetectionFlagLeft
public enum class TypeZeroDetectionFlagLeft
type TypeZeroDetectionFlagLeft
Members
Member name | Value | Description
LChannelZeroNotDetected | 0 | L-Channel: Zero Not Detected
LChannelZeroDetected | 1 | L-Channel: Zero Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeZeroDetectionFlagRight Enumeration

IRD

Pcm1795TypeZeroDetectionFlagRight Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroDetectionFlagRight
Public Enumeration TypeZeroDetectionFlagRight
public enum class TypeZeroDetectionFlagRight
type TypeZeroDetectionFlagRight
Members
Member name | Value | Description
RChannelZeroNotDetected | 0 | R-Channel: Zero Not Detected
RChannelZeroDetected | 1 | R-Channel: Zero Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeZeroOutputDsd Enumeration

IRD

Pcm1795TypeZeroOutputDsd Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroOutputDsd
Public Enumeration TypeZeroOutputDsd
public enum class TypeZeroOutputDsd
type TypeZeroOutputDsd
Members
Member name | Value | Description
ZeroOutputDisabled | 0 | Zero Output: Disabled
ZeroOutputEvenPatternDetect96HPatternDetect | 1 | Zero Output: Even Pattern Detect / 96H Pattern Detect
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1795.TypeZeroOutputPcm Enumeration

IRD

Pcm1795TypeZeroOutputPcm Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroOutputPcm
Public Enumeration TypeZeroOutputPcm
public enum class TypeZeroOutputPcm
type TypeZeroOutputPcm
Members
Member name | Value | Description
PCMZeroOutputDisabled | 0 | PCM Zero Output: Disabled
PCMZeroOutputEnabled | 1 | PCM Zero Output: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796 Class

Texas Instruments: PCM 1796
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPcm1796

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcm1796
Public Class Pcm1796
public ref class Pcm1796
type Pcm1796 =  class end

The Pcm1796 type exposes the following members.

Constructors
 | Name | Description
Public method | Pcm1796 | Constructor
Top
Properties
 | Name | Description
Public property | AttenuationLeftATL | Attenuation Left: ATL
Public property | AttenuationRightATR | Attenuation Right: ATR
Public property | AudioControlATLD | Audio Control: ATLD
Public property | AudioControlDME | Audio Control: DME
Public property | AudioControlDMF | Audio Control: DMF
Public property | AudioControlFMT | Audio Control: FMT
Public property | AudioControlMUTE | Audio Control: MUTE
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DeviceIDID | Device ID: ID
Public property | OperationControlATS | Operation Control: ATS
Public property | OperationControlDFMS | Operation Control: DFMS
Public property | OperationControlFLT | Operation Control: FLT
Public property | OperationControlINZD | Operation Control: INZD
Public property | OperationControlOPE | Operation Control: OPE
Public property | OperationControlREV | Operation Control: REV
Public property | SignalControlCHSL | Signal Control: CHSL
Public property | SignalControlDFTH | Signal Control: DFTH
Public property | SignalControlDSD | Signal Control: DSD
Public property | SignalControlMONO | Signal Control: MONO
Public property | SignalControlOS | Signal Control: OS
Public property | SignalControlSRST | Signal Control: SRST
Public property | ZeroDetectionZFGL | Zero Detection: ZFGL
Public property | ZeroDetectionZFGR | Zero Detection: ZFGR
Public property | ZeroOutputDZ | Zero Output: DZ
Public property | ZeroOutputPCMZ | Zero Output: PCMZ
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Audio Stereo Digital-To-Analog Converter
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcm1796(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcm1796

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796 Properties

The Pcm1796 type exposes the following members.

Properties
 | Name | Description
Public property | AttenuationLeftATL | Attenuation Left: ATL
Public property | AttenuationRightATR | Attenuation Right: ATR
Public property | AudioControlATLD | Audio Control: ATLD
Public property | AudioControlDME | Audio Control: DME
Public property | AudioControlDMF | Audio Control: DMF
Public property | AudioControlFMT | Audio Control: FMT
Public property | AudioControlMUTE | Audio Control: MUTE
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DeviceIDID | Device ID: ID
Public property | OperationControlATS | Operation Control: ATS
Public property | OperationControlDFMS | Operation Control: DFMS
Public property | OperationControlFLT | Operation Control: FLT
Public property | OperationControlINZD | Operation Control: INZD
Public property | OperationControlOPE | Operation Control: OPE
Public property | OperationControlREV | Operation Control: REV
Public property | SignalControlCHSL | Signal Control: CHSL
Public property | SignalControlDFTH | Signal Control: DFTH
Public property | SignalControlDSD | Signal Control: DSD
Public property | SignalControlMONO | Signal Control: MONO
Public property | SignalControlOS | Signal Control: OS
Public property | SignalControlSRST | Signal Control: SRST
Public property | ZeroDetectionZFGL | Zero Detection: ZFGL
Public property | ZeroDetectionZFGR | Zero Detection: ZFGR
Public property | ZeroOutputDZ | Zero Output: DZ
Public property | ZeroOutputPCMZ | Zero Output: PCMZ
Top
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.AttenuationLeftATL Property

IRD

Pcm1796AttenuationLeftATL Property

Attenuation Left: ATL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeAttenuationLevel AttenuationLeftATL { get; set; }
Public Property AttenuationLeftATL As Pcm1796TypeAttenuationLevel
    Get
    Set
public:
property Pcm1796TypeAttenuationLevel AttenuationLeftATL {
    Pcm1796TypeAttenuationLevel get ();
    void set (Pcm1796TypeAttenuationLevel value);
}
member AttenuationLeftATL : Pcm1796TypeAttenuationLevel with get, set

Property Value

Type: Pcm1796TypeAttenuationLevel
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.AttenuationRightATR Property

IRD

Pcm1796AttenuationRightATR Property

Attenuation Right: ATR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeAttenuationLevel AttenuationRightATR { get; set; }
Public Property AttenuationRightATR As Pcm1796TypeAttenuationLevel
    Get
    Set
public:
property Pcm1796TypeAttenuationLevel AttenuationRightATR {
    Pcm1796TypeAttenuationLevel get ();
    void set (Pcm1796TypeAttenuationLevel value);
}
member AttenuationRightATR : Pcm1796TypeAttenuationLevel with get, set

Property Value

Type: Pcm1796TypeAttenuationLevel
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.AudioControlATLD Property

IRD

Pcm1796AudioControlATLD Property

Audio Control: ATLD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeAudioControlAttenuationLoad AudioControlATLD { get; set; }
Public Property AudioControlATLD As Pcm1796TypeAudioControlAttenuationLoad
    Get
    Set
public:
property Pcm1796TypeAudioControlAttenuationLoad AudioControlATLD {
    Pcm1796TypeAudioControlAttenuationLoad get ();
    void set (Pcm1796TypeAudioControlAttenuationLoad value);
}
member AudioControlATLD : Pcm1796TypeAudioControlAttenuationLoad with get, set

Property Value

Type: Pcm1796TypeAudioControlAttenuationLoad
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.AudioControlDME Property

IRD

Pcm1796AudioControlDME Property

Audio Control: DME

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeAudioControlDeEmphasis AudioControlDME { get; set; }
Public Property AudioControlDME As Pcm1796TypeAudioControlDeEmphasis
    Get
    Set
public:
property Pcm1796TypeAudioControlDeEmphasis AudioControlDME {
    Pcm1796TypeAudioControlDeEmphasis get ();
    void set (Pcm1796TypeAudioControlDeEmphasis value);
}
member AudioControlDME : Pcm1796TypeAudioControlDeEmphasis with get, set

Property Value

Type: Pcm1796TypeAudioControlDeEmphasis
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.AudioControlDMF Property

IRD

Pcm1796AudioControlDMF Property

Audio Control: DMF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeAudioControlSampling AudioControlDMF { get; set; }
Public Property AudioControlDMF As Pcm1796TypeAudioControlSampling
    Get
    Set
public:
property Pcm1796TypeAudioControlSampling AudioControlDMF {
    Pcm1796TypeAudioControlSampling get ();
    void set (Pcm1796TypeAudioControlSampling value);
}
member AudioControlDMF : Pcm1796TypeAudioControlSampling with get, set

Property Value

Type: Pcm1796TypeAudioControlSampling
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.AudioControlFMT Property

IRD

Pcm1796AudioControlFMT Property

Audio Control: FMT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeAudioControlDataFormat AudioControlFMT { get; set; }
Public Property AudioControlFMT As Pcm1796TypeAudioControlDataFormat
    Get
    Set
public:
property Pcm1796TypeAudioControlDataFormat AudioControlFMT {
    Pcm1796TypeAudioControlDataFormat get ();
    void set (Pcm1796TypeAudioControlDataFormat value);
}
member AudioControlFMT : Pcm1796TypeAudioControlDataFormat with get, set

Property Value

Type: Pcm1796TypeAudioControlDataFormat
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.AudioControlMUTE Property

IRD

Pcm1796AudioControlMUTE Property

Audio Control: MUTE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeAudioControlMute AudioControlMUTE { get; set; }
Public Property AudioControlMUTE As Pcm1796TypeAudioControlMute
    Get
    Set
public:
property Pcm1796TypeAudioControlMute AudioControlMUTE {
    Pcm1796TypeAudioControlMute get ();
    void set (Pcm1796TypeAudioControlMute value);
}
member AudioControlMUTE : Pcm1796TypeAudioControlMute with get, set

Property Value

Type: Pcm1796TypeAudioControlMute
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.AutoFlush Property

IRD

Pcm1796AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.DeviceIDID Property

IRD

Pcm1796DeviceIDID Property

Device ID: ID

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte DeviceIDID { get; }
Public ReadOnly Property DeviceIDID As Byte
    Get
public:
property unsigned char DeviceIDID {
    unsigned char get ();
}
member DeviceIDID : byte with get

Property Value

Type: Byte
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.OperationControlATS Property

IRD

Pcm1796OperationControlATS Property

Operation Control: ATS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeOperationControlRate OperationControlATS { get; set; }
Public Property OperationControlATS As Pcm1796TypeOperationControlRate
    Get
    Set
public:
property Pcm1796TypeOperationControlRate OperationControlATS {
    Pcm1796TypeOperationControlRate get ();
    void set (Pcm1796TypeOperationControlRate value);
}
member OperationControlATS : Pcm1796TypeOperationControlRate with get, set

Property Value

Type: Pcm1796TypeOperationControlRate
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.OperationControlDFMS Property

IRD

Pcm1796OperationControlDFMS Property

Operation Control: DFMS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeOperationControlBypass OperationControlDFMS { get; set; }
Public Property OperationControlDFMS As Pcm1796TypeOperationControlBypass
    Get
    Set
public:
property Pcm1796TypeOperationControlBypass OperationControlDFMS {
    Pcm1796TypeOperationControlBypass get ();
    void set (Pcm1796TypeOperationControlBypass value);
}
member OperationControlDFMS : Pcm1796TypeOperationControlBypass with get, set

Property Value

Type: Pcm1796TypeOperationControlBypass
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.OperationControlFLT Property

IRD

Pcm1796OperationControlFLT Property

Operation Control: FLT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeOperationControlFilter OperationControlFLT { get; set; }
Public Property OperationControlFLT As Pcm1796TypeOperationControlFilter
    Get
    Set
public:
property Pcm1796TypeOperationControlFilter OperationControlFLT {
    Pcm1796TypeOperationControlFilter get ();
    void set (Pcm1796TypeOperationControlFilter value);
}
member OperationControlFLT : Pcm1796TypeOperationControlFilter with get, set

Property Value

Type: Pcm1796TypeOperationControlFilter
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.OperationControlINZD Property

IRD

Pcm1796OperationControlINZD Property

Operation Control: INZD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeOperationControlZeroDetect OperationControlINZD { get; set; }
Public Property OperationControlINZD As Pcm1796TypeOperationControlZeroDetect
    Get
    Set
public:
property Pcm1796TypeOperationControlZeroDetect OperationControlINZD {
    Pcm1796TypeOperationControlZeroDetect get ();
    void set (Pcm1796TypeOperationControlZeroDetect value);
}
member OperationControlINZD : Pcm1796TypeOperationControlZeroDetect with get, set

Property Value

Type: Pcm1796TypeOperationControlZeroDetect
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.OperationControlOPE Property

IRD

Pcm1796OperationControlOPE Property

Operation Control: OPE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeOperationControlDac OperationControlOPE { get; set; }
Public Property OperationControlOPE As Pcm1796TypeOperationControlDac
    Get
    Set
public:
property Pcm1796TypeOperationControlDac OperationControlOPE {
    Pcm1796TypeOperationControlDac get ();
    void set (Pcm1796TypeOperationControlDac value);
}
member OperationControlOPE : Pcm1796TypeOperationControlDac with get, set

Property Value

Type: Pcm1796TypeOperationControlDac
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.OperationControlREV Property

IRD

Pcm1796OperationControlREV Property

Operation Control: REV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeOperationControlReversal OperationControlREV { get; set; }
Public Property OperationControlREV As Pcm1796TypeOperationControlReversal
    Get
    Set
public:
property Pcm1796TypeOperationControlReversal OperationControlREV {
    Pcm1796TypeOperationControlReversal get ();
    void set (Pcm1796TypeOperationControlReversal value);
}
member OperationControlREV : Pcm1796TypeOperationControlReversal with get, set

Property Value

Type: Pcm1796TypeOperationControlReversal
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.SignalControlCHSL Property

IRD

Pcm1796SignalControlCHSL Property

Signal Control: CHSL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeSignalControlChannel SignalControlCHSL { get; set; }
Public Property SignalControlCHSL As Pcm1796TypeSignalControlChannel
    Get
    Set
public:
property Pcm1796TypeSignalControlChannel SignalControlCHSL {
    Pcm1796TypeSignalControlChannel get ();
    void set (Pcm1796TypeSignalControlChannel value);
}
member SignalControlCHSL : Pcm1796TypeSignalControlChannel with get, set

Property Value

Type: Pcm1796TypeSignalControlChannel
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.SignalControlDFTH Property

IRD

Pcm1796SignalControlDFTH Property

Signal Control: DFTH

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeSignalControlFilter SignalControlDFTH { get; set; }
Public Property SignalControlDFTH As Pcm1796TypeSignalControlFilter
    Get
    Set
public:
property Pcm1796TypeSignalControlFilter SignalControlDFTH {
    Pcm1796TypeSignalControlFilter get ();
    void set (Pcm1796TypeSignalControlFilter value);
}
member SignalControlDFTH : Pcm1796TypeSignalControlFilter with get, set

Property Value

Type: Pcm1796TypeSignalControlFilter
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.SignalControlDSD Property

IRD

Pcm1796SignalControlDSD Property

Signal Control: DSD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeSignalControlMode SignalControlDSD { get; set; }
Public Property SignalControlDSD As Pcm1796TypeSignalControlMode
    Get
    Set
public:
property Pcm1796TypeSignalControlMode SignalControlDSD {
    Pcm1796TypeSignalControlMode get ();
    void set (Pcm1796TypeSignalControlMode value);
}
member SignalControlDSD : Pcm1796TypeSignalControlMode with get, set

Property Value

Type: Pcm1796TypeSignalControlMode
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.SignalControlMONO Property

IRD

Pcm1796SignalControlMONO Property

Signal Control: MONO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeSignalControlMono SignalControlMONO { get; set; }
Public Property SignalControlMONO As Pcm1796TypeSignalControlMono
    Get
    Set
public:
property Pcm1796TypeSignalControlMono SignalControlMONO {
    Pcm1796TypeSignalControlMono get ();
    void set (Pcm1796TypeSignalControlMono value);
}
member SignalControlMONO : Pcm1796TypeSignalControlMono with get, set

Property Value

Type: Pcm1796TypeSignalControlMono
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.SignalControlOS Property

IRD

Pcm1796SignalControlOS Property

Signal Control: OS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeSignalControlSpeed SignalControlOS { get; set; }
Public Property SignalControlOS As Pcm1796TypeSignalControlSpeed
    Get
    Set
public:
property Pcm1796TypeSignalControlSpeed SignalControlOS {
    Pcm1796TypeSignalControlSpeed get ();
    void set (Pcm1796TypeSignalControlSpeed value);
}
member SignalControlOS : Pcm1796TypeSignalControlSpeed with get, set

Property Value

Type: Pcm1796TypeSignalControlSpeed
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.SignalControlSRST Property

IRD

Pcm1796SignalControlSRST Property

Signal Control: SRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeSignalControlReset SignalControlSRST { get; set; }
Public Property SignalControlSRST As Pcm1796TypeSignalControlReset
    Get
    Set
public:
property Pcm1796TypeSignalControlReset SignalControlSRST {
    Pcm1796TypeSignalControlReset get ();
    void set (Pcm1796TypeSignalControlReset value);
}
member SignalControlSRST : Pcm1796TypeSignalControlReset with get, set

Property Value

Type: Pcm1796TypeSignalControlReset
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.ZeroDetectionZFGL Property

IRD

Pcm1796ZeroDetectionZFGL Property

Zero Detection: ZFGL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeZeroDetectionFlagLeft ZeroDetectionZFGL { get; }
Public ReadOnly Property ZeroDetectionZFGL As Pcm1796TypeZeroDetectionFlagLeft
    Get
public:
property Pcm1796TypeZeroDetectionFlagLeft ZeroDetectionZFGL {
    Pcm1796TypeZeroDetectionFlagLeft get ();
}
member ZeroDetectionZFGL : Pcm1796TypeZeroDetectionFlagLeft with get

Property Value

Type: Pcm1796TypeZeroDetectionFlagLeft
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.ZeroDetectionZFGR Property

IRD

Pcm1796ZeroDetectionZFGR Property

Zero Detection: ZFGR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeZeroDetectionFlagRight ZeroDetectionZFGR { get; }
Public ReadOnly Property ZeroDetectionZFGR As Pcm1796TypeZeroDetectionFlagRight
    Get
public:
property Pcm1796TypeZeroDetectionFlagRight ZeroDetectionZFGR {
    Pcm1796TypeZeroDetectionFlagRight get ();
}
member ZeroDetectionZFGR : Pcm1796TypeZeroDetectionFlagRight with get

Property Value

Type: Pcm1796TypeZeroDetectionFlagRight
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.ZeroOutputDZ Property

IRD

Pcm1796ZeroOutputDZ Property

Zero Output: DZ

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeZeroOutputDsd ZeroOutputDZ { get; set; }
Public Property ZeroOutputDZ As Pcm1796TypeZeroOutputDsd
    Get
    Set
public:
property Pcm1796TypeZeroOutputDsd ZeroOutputDZ {
    Pcm1796TypeZeroOutputDsd get ();
    void set (Pcm1796TypeZeroOutputDsd value);
}
member ZeroOutputDZ : Pcm1796TypeZeroOutputDsd with get, set

Property Value

Type: Pcm1796TypeZeroOutputDsd
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.ZeroOutputPCMZ Property

IRD

Pcm1796ZeroOutputPCMZ Property

Zero Output: PCMZ

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1796TypeZeroOutputPcm ZeroOutputPCMZ { get; set; }
Public Property ZeroOutputPCMZ As Pcm1796TypeZeroOutputPcm
    Get
    Set
public:
property Pcm1796TypeZeroOutputPcm ZeroOutputPCMZ {
    Pcm1796TypeZeroOutputPcm get ();
    void set (Pcm1796TypeZeroOutputPcm value);
}
member ZeroOutputPCMZ : Pcm1796TypeZeroOutputPcm with get, set

Property Value

Type: Pcm1796TypeZeroOutputPcm
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796 Methods

The Pcm1796 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.Flush Method

IRD

Pcm1796Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcm1796 Class
telos.Ird.TexasInstruments Namespace


Pcm1796.TypeAttenuationLevel Enumeration

IRD

Pcm1796TypeAttenuationLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAttenuationLevel
Public Enumeration TypeAttenuationLevel
public enum class TypeAttenuationLevel
type TypeAttenuationLevel
Members
Member name | Value | Description
Mute | 0 | Mute
Value_1200DB | 15 | -120.0 dB
Value_1195DB | 16 | -119.5 dB
Value_1190DB | 17 | -119.0 dB
Value_1185DB | 18 | -118.5 dB
Value_1180DB | 19 | -118.0 dB
Value_1175DB | 20 | -117.5 dB
Value_1170DB | 21 | -117.0 dB
Value_1165DB | 22 | -116.5 dB
Value_1160DB | 23 | -116.0 dB
Value_1155DB | 24 | -115.5 dB
Value_1150DB | 25 | -115.0 dB
Value_1145DB | 26 | -114.5 dB
Value_1140DB | 27 | -114.0 dB
Value_1135DB | 28 | -113.5 dB
Value_1130DB | 29 | -113.0 dB
Value_1125DB | 30 | -112.5 dB
Value_1120DB | 31 | -112.0 dB
Value_1115DB | 32 | -111.5 dB
Value_1110DB | 33 | -111.0 dB
Value_1105DB | 34 | -110.5 dB
Value_1100DB | 35 | -110.0 dB
Value_1095DB | 36 | -109.5 dB
Value_1090DB | 37 | -109.0 dB
Value_1085DB | 38 | -108.5 dB
Value_1080DB | 39 | -108.0 dB
Value_1075DB | 40 | -107.5 dB
Value_1070DB | 41 | -107.0 dB
Value_1065DB | 42 | -106.5 dB
Value_1060DB | 43 | -106.0 dB
Value_1055DB | 44 | -105.5 dB
Value_1050DB | 45 | -105.0 dB
Value_1045DB | 46 | -104.5 dB
Value_1040DB | 47 | -104.0 dB
Value_1035DB | 48 | -103.5 dB
Value_1030DB | 49 | -103.0 dB
Value_1025DB | 50 | -102.5 dB
Value_1020DB | 51 | -102.0 dB
Value_1015DB | 52 | -101.5 dB
Value_1010DB | 53 | -101.0 dB
Value_1005DB | 54 | -100.5 dB
Value_1000DB | 55 | -100.0 dB
Value_995DB | 56 | -99.5 dB
Value_990DB | 57 | -99.0 dB
Value_985DB | 58 | -98.5 dB
Value_980DB | 59 | -98.0 dB
Value_975DB | 60 | -97.5 dB
Value_970DB | 61 | -97.0 dB
Value_965DB | 62 | -96.5 dB
Value_960DB | 63 | -96.0 dB
Value_955DB | 64 | -95.5 dB
Value_950DB | 65 | -95.0 dB
Value_945DB | 66 | -94.5 dB
Value_940DB | 67 | -94.0 dB
Value_935DB | 68 | -93.5 dB
Value_930DB | 69 | -93.0 dB
Value_925DB | 70 | -92.5 dB
Value_920DB | 71 | -92.0 dB
Value_915DB | 72 | -91.5 dB
Value_910DB | 73 | -91.0 dB
Value_905DB | 74 | -90.5 dB
Value_900DB | 75 | -90.0 dB
Value_895DB | 76 | -89.5 dB
Value_890DB | 77 | -89.0 dB
Value_885DB | 78 | -88.5 dB
Value_880DB | 79 | -88.0 dB
Value_875DB | 80 | -87.5 dB
Value_870DB | 81 | -87.0 dB
Value_865DB | 82 | -86.5 dB
Value_860DB | 83 | -86.0 dB
Value_855DB | 84 | -85.5 dB
Value_850DB | 85 | -85.0 dB
Value_845DB | 86 | -84.5 dB
Value_840DB | 87 | -84.0 dB
Value_835DB | 88 | -83.5 dB
Value_830DB | 89 | -83.0 dB
Value_825DB | 90 | -82.5 dB
Value_820DB | 91 | -82.0 dB
Value_815DB | 92 | -81.5 dB
Value_810DB | 93 | -81.0 dB
Value_805DB | 94 | -80.5 dB
Value_800DB | 95 | -80.0 dB
Value_795DB | 96 | -79.5 dB
Value_790DB | 97 | -79.0 dB
Value_785DB | 98 | -78.5 dB
Value_780DB | 99 | -78.0 dB
Value_775DB | 100 | -77.5 dB
Value_770DB | 101 | -77.0 dB
Value_765DB | 102 | -76.5 dB
Value_760DB | 103 | -76.0 dB
Value_755DB | 104 | -75.5 dB
Value_750DB | 105 | -75.0 dB
Value_745DB | 106 | -74.5 dB
Value_740DB | 107 | -74.0 dB
Value_735DB | 108 | -73.5 dB
Value_730DB | 109 | -73.0 dB
Value_725DB | 110 | -72.5 dB
Value_720DB | 111 | -72.0 dB
Value_715DB | 112 | -71.5 dB
Value_710DB | 113 | -71.0 dB
Value_705DB | 114 | -70.5 dB
Value_700DB | 115 | -70.0 dB
Value_695DB | 116 | -69.5 dB
Value_690DB | 117 | -69.0 dB
Value_685DB | 118 | -68.5 dB
Value_680DB | 119 | -68.0 dB
Value_675DB | 120 | -67.5 dB
Value_670DB | 121 | -67.0 dB
Value_665DB | 122 | -66.5 dB
Value_660DB | 123 | -66.0 dB
Value_655DB | 124 | -65.5 dB
Value_650DB | 125 | -65.0 dB
Value_645DB | 126 | -64.5 dB
Value_640DB | 127 | -64.0 dB
Value_635DB | 128 | -63.5 dB
Value_630DB | 129 | -63.0 dB
Value_625DB | 130 | -62.5 dB
Value_620DB | 131 | -62.0 dB
Value_615DB | 132 | -61.5 dB
Value_610DB | 133 | -61.0 dB
Value_605DB | 134 | -60.5 dB
Value_600DB | 135 | -60.0 dB
Value_595DB | 136 | -59.5 dB
Value_590DB | 137 | -59.0 dB
Value_585DB | 138 | -58.5 dB
Value_580DB | 139 | -58.0 dB
Value_575DB | 140 | -57.5 dB
Value_570DB | 141 | -57.0 dB
Value_565DB | 142 | -56.5 dB
Value_560DB | 143 | -56.0 dB
Value_555DB | 144 | -55.5 dB
Value_550DB | 145 | -55.0 dB
Value_545DB | 146 | -54.5 dB
Value_540DB | 147 | -54.0 dB
Value_535DB | 148 | -53.5 dB
Value_530DB | 149 | -53.0 dB
Value_525DB | 150 | -52.5 dB
Value_520DB | 151 | -52.0 dB
Value_515DB | 152 | -51.5 dB
Value_510DB | 153 | -51.0 dB
Value_505DB | 154 | -50.5 dB
Value_500DB | 155 | -50.0 dB
Value_495DB | 156 | -49.5 dB
Value_490DB | 157 | -49.0 dB
Value_485DB | 158 | -48.5 dB
Value_480DB | 159 | -48.0 dB
Value_475DB | 160 | -47.5 dB
Value_470DB | 161 | -47.0 dB
Value_465DB | 162 | -46.5 dB
Value_460DB | 163 | -46.0 dB
Value_455DB | 164 | -45.5 dB
Value_450DB | 165 | -45.0 dB
Value_445DB | 166 | -44.5 dB
Value_440DB | 167 | -44.0 dB
Value_435DB | 168 | -43.5 dB
Value_430DB | 169 | -43.0 dB
Value_425DB | 170 | -42.5 dB
Value_420DB | 171 | -42.0 dB
Value_415DB | 172 | -41.5 dB
Value_410DB | 173 | -41.0 dB
Value_405DB | 174 | -40.5 dB
Value_400DB | 175 | -40.0 dB
Value_395DB | 176 | -39.5 dB
Value_390DB | 177 | -39.0 dB
Value_385DB | 178 | -38.5 dB
Value_380DB | 179 | -38.0 dB
Value_375DB | 180 | -37.5 dB
Value_370DB | 181 | -37.0 dB
Value_365DB | 182 | -36.5 dB
Value_360DB | 183 | -36.0 dB
Value_355DB | 184 | -35.5 dB
Value_350DB | 185 | -35.0 dB
Value_345DB | 186 | -34.5 dB
Value_340DB | 187 | -34.0 dB
Value_335DB | 188 | -33.5 dB
Value_330DB | 189 | -33.0 dB
Value_325DB | 190 | -32.5 dB
Value_320DB | 191 | -32.0 dB
Value_315DB | 192 | -31.5 dB
Value_310DB | 193 | -31.0 dB
Value_305DB | 194 | -30.5 dB
Value_300DB | 195 | -30.0 dB
Value_295DB | 196 | -29.5 dB
Value_290DB | 197 | -29.0 dB
Value_285DB | 198 | -28.5 dB
Value_280DB | 199 | -28.0 dB
Value_275DB | 200 | -27.5 dB
Value_270DB | 201 | -27.0 dB
Value_265DB | 202 | -26.5 dB
Value_260DB | 203 | -26.0 dB
Value_255DB | 204 | -25.5 dB
Value_250DB | 205 | -25.0 dB
Value_245DB | 206 | -24.5 dB
Value_240DB | 207 | -24.0 dB
Value_235DB | 208 | -23.5 dB
Value_230DB | 209 | -23.0 dB
Value_225DB | 210 | -22.5 dB
Value_220DB | 211 | -22.0 dB
Value_215DB | 212 | -21.5 dB
Value_210DB | 213 | -21.0 dB
Value_205DB | 214 | -20.5 dB
Value_200DB | 215 | -20.0 dB
Value_195DB | 216 | -19.5 dB
Value_190DB | 217 | -19.0 dB
Value_185DB | 218 | -18.5 dB
Value_180DB | 219 | -18.0 dB
Value_175DB | 220 | -17.5 dB
Value_170DB | 221 | -17.0 dB
Value_165DB | 222 | -16.5 dB
Value_160DB | 223 | -16.0 dB
Value_155DB | 224 | -15.5 dB
Value_150DB | 225 | -15.0 dB
Value_145DB | 226 | -14.5 dB
Value_140DB | 227 | -14.0 dB
Value_135DB | 228 | -13.5 dB
Value_130DB | 229 | -13.0 dB
Value_125DB | 230 | -12.5 dB
Value_120DB | 231 | -12.0 dB
Value_115DB | 232 | -11.5 dB
Value_110DB | 233 | -11.0 dB
Value_105DB | 234 | -10.5 dB
Value_100DB | 235 | -10.0 dB
Value_95DB | 236 | -9.5 dB
Value_90DB | 237 | -9.0 dB
Value_85DB | 238 | -8.5 dB
Value_80DB | 239 | -8.0 dB
Value_75DB | 240 | -7.5 dB
Value_70DB | 241 | -7.0 dB
Value_65DB | 242 | -6.5 dB
Value_60DB | 243 | -6.0 dB
Value_55DB | 244 | -5.5 dB
Value_50DB | 245 | -5.0 dB
Value_45DB | 246 | -4.5 dB
Value_40DB | 247 | -4.0 dB
Value_35DB | 248 | -3.5 dB
Value_30DB | 249 | -3.0 dB
Value_25DB | 250 | -2.5 dB
Value_20DB | 251 | -2.0 dB
Value_15DB | 252 | -1.5 dB
Value_10DB | 253 | -1.0 dB
Value_05DB | 254 | -0.5 dB
Value_0DB | 255 | 0 dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeAudioControlAttenuationLoad Enumeration

IRD

Pcm1796TypeAudioControlAttenuationLoad Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlAttenuationLoad
Public Enumeration TypeAudioControlAttenuationLoad
public enum class TypeAudioControlAttenuationLoad
type TypeAudioControlAttenuationLoad
Members
Member name | Value | Description
AttenuationControlDisabled | 0 | Attenuation Control: Disabled
AttenuationControlEnabled | 1 | Attenuation Control: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeAudioControlDataFormat Enumeration

IRD

Pcm1796TypeAudioControlDataFormat Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlDataFormat
Public Enumeration TypeAudioControlDataFormat
public enum class TypeAudioControlDataFormat
type TypeAudioControlDataFormat
Members
Member name | Value | Description
Value_16BitRightJustifiedStandardFormat | 0 | 16 Bit Right-Justified Standard Format
Value_20BitRightJustifiedStandardFormat | 1 | 20 Bit Right-Justified Standard Format
Value_24BitRightJustifiedStandardFormat | 2 | 24 Bit Right-Justified Standard Format
Value_24BitLeftJustifiedMSBFirstFormat | 3 | 24 Bit Left-Justified MSB-First Format
Value_16BitI2SFormat | 4 | 16 Bit I2S Format
Value_24BitI2SFormat | 5 | 24 Bit I2S Format
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeAudioControlDeEmphasis Enumeration

IRD

Pcm1796TypeAudioControlDeEmphasis Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlDeEmphasis
Public Enumeration TypeAudioControlDeEmphasis
public enum class TypeAudioControlDeEmphasis
type TypeAudioControlDeEmphasis
Members
Member name | Value | Description
DeEmphasisDisabled | 0 | De-Emphasis: Disabled
DeEmphasisEnabled | 1 | De-Emphasis: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeAudioControlMute Enumeration

IRD

Pcm1796TypeAudioControlMute Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlMute
Public Enumeration TypeAudioControlMute
public enum class TypeAudioControlMute
type TypeAudioControlMute
Members
Member name | Value | Description
MuteDisabled | 0 | Mute: Disabled
MuteEnabled | 1 | Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeAudioControlSampling Enumeration

IRD

Pcm1796TypeAudioControlSampling Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAudioControlSampling
Public Enumeration TypeAudioControlSampling
public enum class TypeAudioControlSampling
type TypeAudioControlSampling
Members
Member name | Value | Description
SamplingFequencyDisabled | 0 | Sampling Fequency: Disabled
SamplingFequency48KHz | 1 | Sampling Fequency: 48 kHz
SamplingFequency441KHz | 2 | Sampling Fequency: 44.1 kHz
SamplingFequency32KHz | 3 | Sampling Fequency: 32 kHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeOperationControlBypass Enumeration

IRD

Pcm1796TypeOperationControlBypass Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlBypass
Public Enumeration TypeOperationControlBypass
public enum class TypeOperationControlBypass
type TypeOperationControlBypass
Members
Member name | Value | Description
Monaural | 0 | Monaural
StereoInput | 1 | Stereo Input
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeOperationControlDac Enumeration

IRD

Pcm1796TypeOperationControlDac Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlDac
Public Enumeration TypeOperationControlDac
public enum class TypeOperationControlDac
type TypeOperationControlDac
Members
Member name | Value | Description
DACOperationEnabled | 0 | DAC Operation: Enabled
DACOperationDisabled | 1 | DAC Operation: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeOperationControlFilter Enumeration

IRD

Pcm1796TypeOperationControlFilter Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlFilter
Public Enumeration TypeOperationControlFilter
public enum class TypeOperationControlFilter
type TypeOperationControlFilter
Members
Member name | Value | Description
DigitalFilterSharpRollOff | 0 | Digital Filter: Sharp Roll-Off
DigitalFilterSlowRollOff | 1 | Digital Filter: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeOperationControlRate Enumeration

IRD

Pcm1796TypeOperationControlRate Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlRate
Public Enumeration TypeOperationControlRate
public enum class TypeOperationControlRate
type TypeOperationControlRate
Members
Member name | Value | Description
AttenuationRateLRCK1 | 0 | Attenuation Rate: LRCK / 1
AttenuationRateLRCK2 | 1 | Attenuation Rate: LRCK / 2
AttenuationRateLRCK4 | 2 | Attenuation Rate: LRCK / 4
AttenuationRateLRCK8 | 3 | Attenuation Rate: LRCK / 8
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeOperationControlReversal Enumeration

IRD

Pcm1796TypeOperationControlReversal Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlReversal
Public Enumeration TypeOperationControlReversal
public enum class TypeOperationControlReversal
type TypeOperationControlReversal
Members
Member name | Value | Description
OutputPhaseNormal | 0 | Output Phase: Normal
OutputPhaseInverted | 1 | Output Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeOperationControlZeroDetect Enumeration

IRD

Pcm1796TypeOperationControlZeroDetect Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOperationControlZeroDetect
Public Enumeration TypeOperationControlZeroDetect
public enum class TypeOperationControlZeroDetect
type TypeOperationControlZeroDetect
Members
Member name | Value | Description
InfiniteZeroDetectMuteDisabled | 0 | Infinite Zero Detect Mute: Disabled
InfiniteZeroDetectMuteEnabled | 1 | Infinite Zero Detect Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeSignalControlChannel Enumeration

IRD

Pcm1796TypeSignalControlChannel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlChannel
Public Enumeration TypeSignalControlChannel
public enum class TypeSignalControlChannel
type TypeSignalControlChannel
Members
Member name | Value | Description
LChannelSelected | 0 | L-Channel Selected
RChannelSelected | 1 | R-Channel Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeSignalControlFilter Enumeration

IRD

Pcm1796TypeSignalControlFilter Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlFilter
Public Enumeration TypeSignalControlFilter
public enum class TypeSignalControlFilter
type TypeSignalControlFilter
Members
Member name | Value | Description
DigitalFilterEnabled | 0 | Digital Filter: Enabled
DigitalFilterBypassedForExternalFilter | 1 | Digital Filter: Bypassed For External Filter
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeSignalControlMode Enumeration

IRD

Pcm1796TypeSignalControlMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlMode
Public Enumeration TypeSignalControlMode
public enum class TypeSignalControlMode
type TypeSignalControlMode
Members
Member name | Value | Description
DSDInterfaceModeDisabled | 0 | DSD Interface Mode: Disabled
DSDInterfaceModeEnabled | 1 | DSD Interface Mode: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeSignalControlMono Enumeration

IRD

Pcm1796TypeSignalControlMono Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlMono
Public Enumeration TypeSignalControlMono
public enum class TypeSignalControlMono
type TypeSignalControlMono
Members
Member name | Value | Description
StereoMode | 0 | Stereo Mode
MonauralMode | 1 | Monaural Mode
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeSignalControlReset Enumeration

IRD

Pcm1796TypeSignalControlReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlReset
Public Enumeration TypeSignalControlReset
public enum class TypeSignalControlReset
type TypeSignalControlReset
Members
Member name | Value | Description
SystemResetNormalOperation | 0 | System Reset: Normal Operation
SystemResetOperationOneResetPulse | 1 | System Reset Operation (One Reset Pulse)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeSignalControlSpeed Enumeration

IRD

Pcm1796TypeSignalControlSpeed Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSignalControlSpeed
Public Enumeration TypeSignalControlSpeed
public enum class TypeSignalControlSpeed
type TypeSignalControlSpeed
Members
Member name | Value | Description
OperationSpeed64XFs | 0 | Operation Speed: 64 x Fs
OperationSpeed32XFs | 1 | Operation Speed: 32 x Fs
OperationSpeed128XFs | 2 | Operation Speed: 128 x Fs
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeZeroDetectionFlagLeft Enumeration

IRD

Pcm1796TypeZeroDetectionFlagLeft Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroDetectionFlagLeft
Public Enumeration TypeZeroDetectionFlagLeft
public enum class TypeZeroDetectionFlagLeft
type TypeZeroDetectionFlagLeft
Members
Member name | Value | Description
LChannelZeroNotDetected | 0 | L-Channel: Zero Not Detected
LChannelZeroDetected | 1 | L-Channel: Zero Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeZeroDetectionFlagRight Enumeration

IRD

Pcm1796TypeZeroDetectionFlagRight Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroDetectionFlagRight
Public Enumeration TypeZeroDetectionFlagRight
public enum class TypeZeroDetectionFlagRight
type TypeZeroDetectionFlagRight
Members
Member name | Value | Description
RChannelZeroNotDetected | 0 | R-Channel: Zero Not Detected
RChannelZeroDetected | 1 | R-Channel: Zero Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeZeroOutputDsd Enumeration

IRD

Pcm1796TypeZeroOutputDsd Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroOutputDsd
Public Enumeration TypeZeroOutputDsd
public enum class TypeZeroOutputDsd
type TypeZeroOutputDsd
Members
Member name | Value | Description
ZeroOutputDisabled | 0 | Zero Output: Disabled
ZeroOutputEvenPatternDetect | 1 | Zero Output: Even Pattern Detect
ZeroOutput96HPatternDetect | 2 | Zero Output: 96H Pattern Detect
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1796.TypeZeroOutputPcm Enumeration

IRD

Pcm1796TypeZeroOutputPcm Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeZeroOutputPcm
Public Enumeration TypeZeroOutputPcm
public enum class TypeZeroOutputPcm
type TypeZeroOutputPcm
Members
Member name | Value | Description
PCMZeroOutputDisabled | 0 | PCM Zero Output: Disabled
PCMZeroOutputEnabled | 1 | PCM Zero Output: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1851a Class

Texas Instruments: PCM 1850A / 1851A
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPcm1851a

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcm1851a
Public Class Pcm1851a
public ref class Pcm1851a
type Pcm1851a =  class end

The Pcm1851a type exposes the following members.

Constructors
 | Name | Description
Public method | Pcm1851a | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelControlCH | Channel Control: CH
Public property | GainControlMRST | Gain Control: MRST
Public property | GainControlPG | Gain Control: PG (unit: dB)
Public property | InterfaceControlBYP | Interface Control: BYP
Public property | InterfaceControlFMT | Interface Control: FMT
Public property | InterfaceControlMD | Interface Control: MD
Public property | InterfaceControlSRST | Interface Control: SRST
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Stereo A/D Converter
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1851a Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1851a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcm1851a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcm1851a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcm1851a Class
telos.Ird.TexasInstruments Namespace


Pcm1851a Properties

The Pcm1851a type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ChannelControlCH | Channel Control: CH
Public property | GainControlMRST | Gain Control: MRST
Public property | GainControlPG | Gain Control: PG (unit: dB)
Public property | InterfaceControlBYP | Interface Control: BYP
Public property | InterfaceControlFMT | Interface Control: FMT
Public property | InterfaceControlMD | Interface Control: MD
Public property | InterfaceControlSRST | Interface Control: SRST
Top
See Also

Reference

Pcm1851a Class
telos.Ird.TexasInstruments Namespace


Pcm1851a.AutoFlush Property

IRD

Pcm1851aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcm1851a Class
telos.Ird.TexasInstruments Namespace


Pcm1851a.ChannelControlCH Property

IRD

Pcm1851aChannelControlCH Property

Channel Control: CH

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1851aTypeChannelControl ChannelControlCH { get; set; }
Public Property ChannelControlCH As Pcm1851aTypeChannelControl
    Get
    Set
public:
property Pcm1851aTypeChannelControl ChannelControlCH {
    Pcm1851aTypeChannelControl get ();
    void set (Pcm1851aTypeChannelControl value);
}
member ChannelControlCH : Pcm1851aTypeChannelControl with get, set

Property Value

Type: Pcm1851aTypeChannelControl
See Also

Reference

Pcm1851a Class
telos.Ird.TexasInstruments Namespace


Pcm1851a.GainControlMRST Property

IRD

Pcm1851aGainControlMRST Property

Gain Control: MRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1851aTypeGainControlReset GainControlMRST { get; set; }
Public Property GainControlMRST As Pcm1851aTypeGainControlReset
    Get
    Set
public:
property Pcm1851aTypeGainControlReset GainControlMRST {
    Pcm1851aTypeGainControlReset get ();
    void set (Pcm1851aTypeGainControlReset value);
}
member GainControlMRST : Pcm1851aTypeGainControlReset with get, set

Property Value

Type: Pcm1851aTypeGainControlReset
See Also

Reference

Pcm1851a Class
telos.Ird.TexasInstruments Namespace


Pcm1851a.GainControlPG Property

IRD

Pcm1851aGainControlPG Property

Gain Control: PG (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double GainControlPG { get; set; }
Public Property GainControlPG As Double
    Get
    Set
public:
property double GainControlPG {
    double get ();
    void set (double value);
}
member GainControlPG : float with get, set

Property Value

Type: Double
See Also

Reference

Pcm1851a Class
telos.Ird.TexasInstruments Namespace


Pcm1851a.InterfaceControlBYP Property

IRD

Pcm1851aInterfaceControlBYP Property

Interface Control: BYP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1851aTypeInterfaceControlBypass InterfaceControlBYP { get; set; }
Public Property InterfaceControlBYP As Pcm1851aTypeInterfaceControlBypass
    Get
    Set
public:
property Pcm1851aTypeInterfaceControlBypass InterfaceControlBYP {
    Pcm1851aTypeInterfaceControlBypass get ();
    void set (Pcm1851aTypeInterfaceControlBypass value);
}
member InterfaceControlBYP : Pcm1851aTypeInterfaceControlBypass with get, set

Property Value

Type: Pcm1851aTypeInterfaceControlBypass
See Also

Reference

Pcm1851a Class
telos.Ird.TexasInstruments Namespace


Pcm1851a.InterfaceControlFMT Property

IRD

Pcm1851aInterfaceControlFMT Property

Interface Control: FMT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1851aTypeInterfaceControlFormat InterfaceControlFMT { get; set; }
Public Property InterfaceControlFMT As Pcm1851aTypeInterfaceControlFormat
    Get
    Set
public:
property Pcm1851aTypeInterfaceControlFormat InterfaceControlFMT {
    Pcm1851aTypeInterfaceControlFormat get ();
    void set (Pcm1851aTypeInterfaceControlFormat value);
}
member InterfaceControlFMT : Pcm1851aTypeInterfaceControlFormat with get, set

Property Value

Type: Pcm1851aTypeInterfaceControlFormat
See Also

Reference

Pcm1851a Class
telos.Ird.TexasInstruments Namespace


Pcm1851a.InterfaceControlMD Property

IRD

Pcm1851aInterfaceControlMD Property

Interface Control: MD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1851aTypeInterfaceControlMd InterfaceControlMD { get; set; }
Public Property InterfaceControlMD As Pcm1851aTypeInterfaceControlMd
    Get
    Set
public:
property Pcm1851aTypeInterfaceControlMd InterfaceControlMD {
    Pcm1851aTypeInterfaceControlMd get ();
    void set (Pcm1851aTypeInterfaceControlMd value);
}
member InterfaceControlMD : Pcm1851aTypeInterfaceControlMd with get, set

Property Value

Type: Pcm1851aTypeInterfaceControlMd
See Also

Reference

Pcm1851a Class
telos.Ird.TexasInstruments Namespace


Pcm1851a.InterfaceControlSRST Property

IRD

Pcm1851aInterfaceControlSRST Property

Interface Control: SRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm1851aTypeInterfaceControlPower InterfaceControlSRST { get; set; }
Public Property InterfaceControlSRST As Pcm1851aTypeInterfaceControlPower
    Get
    Set
public:
property Pcm1851aTypeInterfaceControlPower InterfaceControlSRST {
    Pcm1851aTypeInterfaceControlPower get ();
    void set (Pcm1851aTypeInterfaceControlPower value);
}
member InterfaceControlSRST : Pcm1851aTypeInterfaceControlPower with get, set

Property Value

Type: Pcm1851aTypeInterfaceControlPower
See Also

Reference

Pcm1851a Class
telos.Ird.TexasInstruments Namespace


Pcm1851a Methods

The Pcm1851a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcm1851a Class
telos.Ird.TexasInstruments Namespace


Pcm1851a.Flush Method

IRD

Pcm1851aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcm1851a Class
telos.Ird.TexasInstruments Namespace


Pcm1851a.TypeChannelControl Enumeration

IRD

Pcm1851aTypeChannelControl Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeChannelControl
Public Enumeration TypeChannelControl
public enum class TypeChannelControl
type TypeChannelControl
Members
Member name | Value | Description
Mute | 0 | Mute
MultiplexerInputChannel1 | 1 | Multiplexer Input:Channel 1
MultiplexerInputChannel2 | 2 | Multiplexer Input:Channel 2
MultiplexerInputChannel3 | 3 | Multiplexer Input:Channel 3
MultiplexerInputChannel4 | 4 | Multiplexer Input:Channel 4
MultiplexerInputChannel5 | 5 | Multiplexer Input:Channel 5
MultiplexerInputChannel6 | 6 | Multiplexer Input:Channel 6
Mute__1 | 7 | Mute
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1851a.TypeGainControlReset Enumeration

IRD

Pcm1851aTypeGainControlReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeGainControlReset
Public Enumeration TypeGainControlReset
public enum class TypeGainControlReset
type TypeGainControlReset
Members
Member name | Value | Description
ModeControlRegisterReset | 0 | Mode Control Register: Reset
ModeControlRegisterNormalOperation | 1 | Mode Control Register: Normal Operation
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1851a.TypeInterfaceControlBypass Enumeration

IRD

Pcm1851aTypeInterfaceControlBypass Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterfaceControlBypass
Public Enumeration TypeInterfaceControlBypass
public enum class TypeInterfaceControlBypass
type TypeInterfaceControlBypass
Members
Member name | Value | Description
HPFModeNormalNoDCComponentOnDOUT | 0 | HPF Mode: Normal (No DC Component On DOUT)
HPFModeBypassDCComponentOnDOUT | 1 | HPF Mode: Bypass (DC Component On DOUT)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1851a.TypeInterfaceControlFormat Enumeration

IRD

Pcm1851aTypeInterfaceControlFormat Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterfaceControlFormat
Public Enumeration TypeInterfaceControlFormat
public enum class TypeInterfaceControlFormat
type TypeInterfaceControlFormat
Members
Member name | Value | Description
DataFormatRightJustified24Bit | 0 | Data Format: Right-Justified, 24 Bit
DataFormatRightJustified16Bit | 3 | Data Format: Right-Justified, 16 Bit
DataFormatI2S24Bit | 4 | Data Format: I2S, 24 Bit
DataFormatLeftJustified24Bit | 5 | Data Format: Left-Justified, 24 Bit
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1851a.TypeInterfaceControlMd Enumeration

IRD

Pcm1851aTypeInterfaceControlMd Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterfaceControlMd
Public Enumeration TypeInterfaceControlMd
public enum class TypeInterfaceControlMd
type TypeInterfaceControlMd
Members
Member name | Value | Description
SlaveMode256Fs384Fs768Fs | 0 | Slave Mode (256 Fs, 384 Fs, 768 Fs)
MasterMode256Fs | 1 | Master Mode (256 Fs)
MasterMode384Fs | 2 | Master Mode (384 Fs)
MasterMode512Fs | 3 | Master Mode (512 Fs)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm1851a.TypeInterfaceControlPower Enumeration

IRD

Pcm1851aTypeInterfaceControlPower Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInterfaceControlPower
Public Enumeration TypeInterfaceControlPower
public enum class TypeInterfaceControlPower
type TypeInterfaceControlPower
Members
Member name | Value | Description
ResetAndPowerDownMode | 0 | Reset And Power-Down Mode
NormalOperationMode | 1 | Normal Operation Mode
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060 Class

Texas Instruments: PCM 3060
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPcm3060

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcm3060
Public Class Pcm3060
public ref class Pcm3060
type Pcm3060 =  class end

The Pcm3060 type exposes the following members.

Constructors
 | Name | Description
Public method | Pcm3060 | Constructor
Top
Properties
 | Name | Description
Public property | ADCAttenuation1AT11 | ADC Attenuation1: AT11 (unit: dB)
Public property | ADCAttenuation2AT12 | ADC Attenuation2: AT12 (unit: dB)
Public property | ADCFilterBYP | ADC Filter: BYP
Public property | ADCFilterDREV1 | ADC Filter: DREV1
Public property | ADCFilterMUT11 | ADC Filter: MUT11
Public property | ADCFilterMUT12 | ADC Filter: MUT12
Public property | ADCFilterZCDD | ADC Filter: ZCDD
Public property | ADCInterfaceCSEL1 | ADC Interface: CSEL1
Public property | ADCInterfaceFMT | ADC Interface: FMT
Public property | ADCInterfaceMS | ADC Interface: M/S
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DACAttenuation1AT21 | DAC Attenuation1: AT21 (unit: dB)
Public property | DACAttenuation2AT22 | DAC Attenuation2: AT22 (unit: dB)
Public property | DACControlDREV2 | DAC Control: DREV2
Public property | DACControlMUT21 | DAC Control: MUT21
Public property | DACControlMUT22 | DAC Control: MUT22
Public property | DACControlOVER | DAC Control: OVER
Public property | DACFilterAZRO | DAC Filter: AZRO
Public property | DACFilterDMC | DAC Filter: DMC
Public property | DACFilterDMF | DAC Filter: DMF
Public property | DACFilterFLT | DAC Filter: FLT
Public property | DACFilterZREV | DAC Filter: ZREV
Public property | DACInterfaceCSEL2 | DAC Interface: CSEL2
Public property | DACInterfaceFMT2 | DAC Interface: FMT2
Public property | DACInterfaceMS | DAC Interface: M/S
Public property | ModeControlADPSV | Mode Control: ADPSV
Public property | ModeControlDAPSV | Mode Control: DAPSV
Public property | ModeControlMRST | Mode Control: MRST
Public property | ModeControlSE | Mode Control: S/E
Public property | ModeControlSRST | Mode Control: SRST
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
24 Bit 96/192-kHz Asynchronous Stereo Audio Codec
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcm3060(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcm3060

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060 Properties

The Pcm3060 type exposes the following members.

Properties
 | Name | Description
Public property | ADCAttenuation1AT11 | ADC Attenuation1: AT11 (unit: dB)
Public property | ADCAttenuation2AT12 | ADC Attenuation2: AT12 (unit: dB)
Public property | ADCFilterBYP | ADC Filter: BYP
Public property | ADCFilterDREV1 | ADC Filter: DREV1
Public property | ADCFilterMUT11 | ADC Filter: MUT11
Public property | ADCFilterMUT12 | ADC Filter: MUT12
Public property | ADCFilterZCDD | ADC Filter: ZCDD
Public property | ADCInterfaceCSEL1 | ADC Interface: CSEL1
Public property | ADCInterfaceFMT | ADC Interface: FMT
Public property | ADCInterfaceMS | ADC Interface: M/S
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DACAttenuation1AT21 | DAC Attenuation1: AT21 (unit: dB)
Public property | DACAttenuation2AT22 | DAC Attenuation2: AT22 (unit: dB)
Public property | DACControlDREV2 | DAC Control: DREV2
Public property | DACControlMUT21 | DAC Control: MUT21
Public property | DACControlMUT22 | DAC Control: MUT22
Public property | DACControlOVER | DAC Control: OVER
Public property | DACFilterAZRO | DAC Filter: AZRO
Public property | DACFilterDMC | DAC Filter: DMC
Public property | DACFilterDMF | DAC Filter: DMF
Public property | DACFilterFLT | DAC Filter: FLT
Public property | DACFilterZREV | DAC Filter: ZREV
Public property | DACInterfaceCSEL2 | DAC Interface: CSEL2
Public property | DACInterfaceFMT2 | DAC Interface: FMT2
Public property | DACInterfaceMS | DAC Interface: M/S
Public property | ModeControlADPSV | Mode Control: ADPSV
Public property | ModeControlDAPSV | Mode Control: DAPSV
Public property | ModeControlMRST | Mode Control: MRST
Public property | ModeControlSE | Mode Control: S/E
Public property | ModeControlSRST | Mode Control: SRST
Top
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.ADCAttenuation1AT11 Property

IRD

Pcm3060ADCAttenuation1AT11 Property

ADC Attenuation1: AT11 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeAdcAttenuation ADCAttenuation1AT11 { get; set; }
Public Property ADCAttenuation1AT11 As Pcm3060TypeAdcAttenuation
    Get
    Set
public:
property Pcm3060TypeAdcAttenuation ADCAttenuation1AT11 {
    Pcm3060TypeAdcAttenuation get ();
    void set (Pcm3060TypeAdcAttenuation value);
}
member ADCAttenuation1AT11 : Pcm3060TypeAdcAttenuation with get, set

Property Value

Type: Pcm3060TypeAdcAttenuation
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.ADCAttenuation2AT12 Property

IRD

Pcm3060ADCAttenuation2AT12 Property

ADC Attenuation2: AT12 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeAdcAttenuation ADCAttenuation2AT12 { get; set; }
Public Property ADCAttenuation2AT12 As Pcm3060TypeAdcAttenuation
    Get
    Set
public:
property Pcm3060TypeAdcAttenuation ADCAttenuation2AT12 {
    Pcm3060TypeAdcAttenuation get ();
    void set (Pcm3060TypeAdcAttenuation value);
}
member ADCAttenuation2AT12 : Pcm3060TypeAdcAttenuation with get, set

Property Value

Type: Pcm3060TypeAdcAttenuation
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.ADCFilterBYP Property

IRD

Pcm3060ADCFilterBYP Property

ADC Filter: BYP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeAdcFilterBypass ADCFilterBYP { get; set; }
Public Property ADCFilterBYP As Pcm3060TypeAdcFilterBypass
    Get
    Set
public:
property Pcm3060TypeAdcFilterBypass ADCFilterBYP {
    Pcm3060TypeAdcFilterBypass get ();
    void set (Pcm3060TypeAdcFilterBypass value);
}
member ADCFilterBYP : Pcm3060TypeAdcFilterBypass with get, set

Property Value

Type: Pcm3060TypeAdcFilterBypass
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.ADCFilterDREV1 Property

IRD

Pcm3060ADCFilterDREV1 Property

ADC Filter: DREV1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeAdcFilterPhase ADCFilterDREV1 { get; set; }
Public Property ADCFilterDREV1 As Pcm3060TypeAdcFilterPhase
    Get
    Set
public:
property Pcm3060TypeAdcFilterPhase ADCFilterDREV1 {
    Pcm3060TypeAdcFilterPhase get ();
    void set (Pcm3060TypeAdcFilterPhase value);
}
member ADCFilterDREV1 : Pcm3060TypeAdcFilterPhase with get, set

Property Value

Type: Pcm3060TypeAdcFilterPhase
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.ADCFilterMUT11 Property

IRD

Pcm3060ADCFilterMUT11 Property

ADC Filter: MUT11

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeAdcFilterMute11 ADCFilterMUT11 { get; set; }
Public Property ADCFilterMUT11 As Pcm3060TypeAdcFilterMute11
    Get
    Set
public:
property Pcm3060TypeAdcFilterMute11 ADCFilterMUT11 {
    Pcm3060TypeAdcFilterMute11 get ();
    void set (Pcm3060TypeAdcFilterMute11 value);
}
member ADCFilterMUT11 : Pcm3060TypeAdcFilterMute11 with get, set

Property Value

Type: Pcm3060TypeAdcFilterMute11
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.ADCFilterMUT12 Property

IRD

Pcm3060ADCFilterMUT12 Property

ADC Filter: MUT12

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeAdcFilterMute12 ADCFilterMUT12 { get; set; }
Public Property ADCFilterMUT12 As Pcm3060TypeAdcFilterMute12
    Get
    Set
public:
property Pcm3060TypeAdcFilterMute12 ADCFilterMUT12 {
    Pcm3060TypeAdcFilterMute12 get ();
    void set (Pcm3060TypeAdcFilterMute12 value);
}
member ADCFilterMUT12 : Pcm3060TypeAdcFilterMute12 with get, set

Property Value

Type: Pcm3060TypeAdcFilterMute12
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.ADCFilterZCDD Property

IRD

Pcm3060ADCFilterZCDD Property

ADC Filter: ZCDD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeAdcFilterZeroCross ADCFilterZCDD { get; set; }
Public Property ADCFilterZCDD As Pcm3060TypeAdcFilterZeroCross
    Get
    Set
public:
property Pcm3060TypeAdcFilterZeroCross ADCFilterZCDD {
    Pcm3060TypeAdcFilterZeroCross get ();
    void set (Pcm3060TypeAdcFilterZeroCross value);
}
member ADCFilterZCDD : Pcm3060TypeAdcFilterZeroCross with get, set

Property Value

Type: Pcm3060TypeAdcFilterZeroCross
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.ADCInterfaceCSEL1 Property

IRD

Pcm3060ADCInterfaceCSEL1 Property

ADC Interface: CSEL1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeAdcInterfaceClock ADCInterfaceCSEL1 { get; set; }
Public Property ADCInterfaceCSEL1 As Pcm3060TypeAdcInterfaceClock
    Get
    Set
public:
property Pcm3060TypeAdcInterfaceClock ADCInterfaceCSEL1 {
    Pcm3060TypeAdcInterfaceClock get ();
    void set (Pcm3060TypeAdcInterfaceClock value);
}
member ADCInterfaceCSEL1 : Pcm3060TypeAdcInterfaceClock with get, set

Property Value

Type: Pcm3060TypeAdcInterfaceClock
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.ADCInterfaceFMT Property

IRD

Pcm3060ADCInterfaceFMT Property

ADC Interface: FMT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeAdcInterfaceFormat ADCInterfaceFMT { get; set; }
Public Property ADCInterfaceFMT As Pcm3060TypeAdcInterfaceFormat
    Get
    Set
public:
property Pcm3060TypeAdcInterfaceFormat ADCInterfaceFMT {
    Pcm3060TypeAdcInterfaceFormat get ();
    void set (Pcm3060TypeAdcInterfaceFormat value);
}
member ADCInterfaceFMT : Pcm3060TypeAdcInterfaceFormat with get, set

Property Value

Type: Pcm3060TypeAdcInterfaceFormat
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.ADCInterfaceMS Property

IRD

Pcm3060ADCInterfaceMS Property

ADC Interface: M/S

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeAdcInterfaceMode ADCInterfaceMS { get; set; }
Public Property ADCInterfaceMS As Pcm3060TypeAdcInterfaceMode
    Get
    Set
public:
property Pcm3060TypeAdcInterfaceMode ADCInterfaceMS {
    Pcm3060TypeAdcInterfaceMode get ();
    void set (Pcm3060TypeAdcInterfaceMode value);
}
member ADCInterfaceMS : Pcm3060TypeAdcInterfaceMode with get, set

Property Value

Type: Pcm3060TypeAdcInterfaceMode
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.AutoFlush Property

IRD

Pcm3060AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.DACAttenuation1AT21 Property

IRD

Pcm3060DACAttenuation1AT21 Property

DAC Attenuation1: AT21 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeDacAttenuation DACAttenuation1AT21 { get; set; }
Public Property DACAttenuation1AT21 As Pcm3060TypeDacAttenuation
    Get
    Set
public:
property Pcm3060TypeDacAttenuation DACAttenuation1AT21 {
    Pcm3060TypeDacAttenuation get ();
    void set (Pcm3060TypeDacAttenuation value);
}
member DACAttenuation1AT21 : Pcm3060TypeDacAttenuation with get, set

Property Value

Type: Pcm3060TypeDacAttenuation
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.DACAttenuation2AT22 Property

IRD

Pcm3060DACAttenuation2AT22 Property

DAC Attenuation2: AT22 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeDacAttenuation DACAttenuation2AT22 { get; set; }
Public Property DACAttenuation2AT22 As Pcm3060TypeDacAttenuation
    Get
    Set
public:
property Pcm3060TypeDacAttenuation DACAttenuation2AT22 {
    Pcm3060TypeDacAttenuation get ();
    void set (Pcm3060TypeDacAttenuation value);
}
member DACAttenuation2AT22 : Pcm3060TypeDacAttenuation with get, set

Property Value

Type: Pcm3060TypeDacAttenuation
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.DACControlDREV2 Property

IRD

Pcm3060DACControlDREV2 Property

DAC Control: DREV2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeDacControlPhase DACControlDREV2 { get; set; }
Public Property DACControlDREV2 As Pcm3060TypeDacControlPhase
    Get
    Set
public:
property Pcm3060TypeDacControlPhase DACControlDREV2 {
    Pcm3060TypeDacControlPhase get ();
    void set (Pcm3060TypeDacControlPhase value);
}
member DACControlDREV2 : Pcm3060TypeDacControlPhase with get, set

Property Value

Type: Pcm3060TypeDacControlPhase
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.DACControlMUT21 Property

IRD

Pcm3060DACControlMUT21 Property

DAC Control: MUT21

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeDacControlMut21 DACControlMUT21 { get; set; }
Public Property DACControlMUT21 As Pcm3060TypeDacControlMut21
    Get
    Set
public:
property Pcm3060TypeDacControlMut21 DACControlMUT21 {
    Pcm3060TypeDacControlMut21 get ();
    void set (Pcm3060TypeDacControlMut21 value);
}
member DACControlMUT21 : Pcm3060TypeDacControlMut21 with get, set

Property Value

Type: Pcm3060TypeDacControlMut21
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.DACControlMUT22 Property

IRD

Pcm3060DACControlMUT22 Property

DAC Control: MUT22

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeDacControlMut22 DACControlMUT22 { get; set; }
Public Property DACControlMUT22 As Pcm3060TypeDacControlMut22
    Get
    Set
public:
property Pcm3060TypeDacControlMut22 DACControlMUT22 {
    Pcm3060TypeDacControlMut22 get ();
    void set (Pcm3060TypeDacControlMut22 value);
}
member DACControlMUT22 : Pcm3060TypeDacControlMut22 with get, set

Property Value

Type: Pcm3060TypeDacControlMut22
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.DACControlOVER Property

IRD

Pcm3060DACControlOVER Property

DAC Control: OVER

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeDacControlOver DACControlOVER { get; set; }
Public Property DACControlOVER As Pcm3060TypeDacControlOver
    Get
    Set
public:
property Pcm3060TypeDacControlOver DACControlOVER {
    Pcm3060TypeDacControlOver get ();
    void set (Pcm3060TypeDacControlOver value);
}
member DACControlOVER : Pcm3060TypeDacControlOver with get, set

Property Value

Type: Pcm3060TypeDacControlOver
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.DACFilterAZRO Property

IRD

Pcm3060DACFilterAZRO Property

DAC Filter: AZRO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeDacFilterZeroFunc DACFilterAZRO { get; set; }
Public Property DACFilterAZRO As Pcm3060TypeDacFilterZeroFunc
    Get
    Set
public:
property Pcm3060TypeDacFilterZeroFunc DACFilterAZRO {
    Pcm3060TypeDacFilterZeroFunc get ();
    void set (Pcm3060TypeDacFilterZeroFunc value);
}
member DACFilterAZRO : Pcm3060TypeDacFilterZeroFunc with get, set

Property Value

Type: Pcm3060TypeDacFilterZeroFunc
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.DACFilterDMC Property

IRD

Pcm3060DACFilterDMC Property

DAC Filter: DMC

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeDacFilterDeEmphasis DACFilterDMC { get; set; }
Public Property DACFilterDMC As Pcm3060TypeDacFilterDeEmphasis
    Get
    Set
public:
property Pcm3060TypeDacFilterDeEmphasis DACFilterDMC {
    Pcm3060TypeDacFilterDeEmphasis get ();
    void set (Pcm3060TypeDacFilterDeEmphasis value);
}
member DACFilterDMC : Pcm3060TypeDacFilterDeEmphasis with get, set

Property Value

Type: Pcm3060TypeDacFilterDeEmphasis
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.DACFilterDMF Property

IRD

Pcm3060DACFilterDMF Property

DAC Filter: DMF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeDacFilterSampling DACFilterDMF { get; set; }
Public Property DACFilterDMF As Pcm3060TypeDacFilterSampling
    Get
    Set
public:
property Pcm3060TypeDacFilterSampling DACFilterDMF {
    Pcm3060TypeDacFilterSampling get ();
    void set (Pcm3060TypeDacFilterSampling value);
}
member DACFilterDMF : Pcm3060TypeDacFilterSampling with get, set

Property Value

Type: Pcm3060TypeDacFilterSampling
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.DACFilterFLT Property

IRD

Pcm3060DACFilterFLT Property

DAC Filter: FLT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeDacFilterRolloff DACFilterFLT { get; set; }
Public Property DACFilterFLT As Pcm3060TypeDacFilterRolloff
    Get
    Set
public:
property Pcm3060TypeDacFilterRolloff DACFilterFLT {
    Pcm3060TypeDacFilterRolloff get ();
    void set (Pcm3060TypeDacFilterRolloff value);
}
member DACFilterFLT : Pcm3060TypeDacFilterRolloff with get, set

Property Value

Type: Pcm3060TypeDacFilterRolloff
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.DACFilterZREV Property

IRD

Pcm3060DACFilterZREV Property

DAC Filter: ZREV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeDacFilterZeroPol DACFilterZREV { get; set; }
Public Property DACFilterZREV As Pcm3060TypeDacFilterZeroPol
    Get
    Set
public:
property Pcm3060TypeDacFilterZeroPol DACFilterZREV {
    Pcm3060TypeDacFilterZeroPol get ();
    void set (Pcm3060TypeDacFilterZeroPol value);
}
member DACFilterZREV : Pcm3060TypeDacFilterZeroPol with get, set

Property Value

Type: Pcm3060TypeDacFilterZeroPol
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.DACInterfaceCSEL2 Property

IRD

Pcm3060DACInterfaceCSEL2 Property

DAC Interface: CSEL2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeDacInterfaceClock DACInterfaceCSEL2 { get; set; }
Public Property DACInterfaceCSEL2 As Pcm3060TypeDacInterfaceClock
    Get
    Set
public:
property Pcm3060TypeDacInterfaceClock DACInterfaceCSEL2 {
    Pcm3060TypeDacInterfaceClock get ();
    void set (Pcm3060TypeDacInterfaceClock value);
}
member DACInterfaceCSEL2 : Pcm3060TypeDacInterfaceClock with get, set

Property Value

Type: Pcm3060TypeDacInterfaceClock
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.DACInterfaceFMT2 Property

IRD

Pcm3060DACInterfaceFMT2 Property

DAC Interface: FMT2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeDacInterfaceFormat DACInterfaceFMT2 { get; set; }
Public Property DACInterfaceFMT2 As Pcm3060TypeDacInterfaceFormat
    Get
    Set
public:
property Pcm3060TypeDacInterfaceFormat DACInterfaceFMT2 {
    Pcm3060TypeDacInterfaceFormat get ();
    void set (Pcm3060TypeDacInterfaceFormat value);
}
member DACInterfaceFMT2 : Pcm3060TypeDacInterfaceFormat with get, set

Property Value

Type: Pcm3060TypeDacInterfaceFormat
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.DACInterfaceMS Property

IRD

Pcm3060DACInterfaceMS Property

DAC Interface: M/S

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeDacInterfaceMode DACInterfaceMS { get; set; }
Public Property DACInterfaceMS As Pcm3060TypeDacInterfaceMode
    Get
    Set
public:
property Pcm3060TypeDacInterfaceMode DACInterfaceMS {
    Pcm3060TypeDacInterfaceMode get ();
    void set (Pcm3060TypeDacInterfaceMode value);
}
member DACInterfaceMS : Pcm3060TypeDacInterfaceMode with get, set

Property Value

Type: Pcm3060TypeDacInterfaceMode
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.ModeControlADPSV Property

IRD

Pcm3060ModeControlADPSV Property

Mode Control: ADPSV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeModeControlAdc ModeControlADPSV { get; set; }
Public Property ModeControlADPSV As Pcm3060TypeModeControlAdc
    Get
    Set
public:
property Pcm3060TypeModeControlAdc ModeControlADPSV {
    Pcm3060TypeModeControlAdc get ();
    void set (Pcm3060TypeModeControlAdc value);
}
member ModeControlADPSV : Pcm3060TypeModeControlAdc with get, set

Property Value

Type: Pcm3060TypeModeControlAdc
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.ModeControlDAPSV Property

IRD

Pcm3060ModeControlDAPSV Property

Mode Control: DAPSV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeModeControlDac ModeControlDAPSV { get; set; }
Public Property ModeControlDAPSV As Pcm3060TypeModeControlDac
    Get
    Set
public:
property Pcm3060TypeModeControlDac ModeControlDAPSV {
    Pcm3060TypeModeControlDac get ();
    void set (Pcm3060TypeModeControlDac value);
}
member ModeControlDAPSV : Pcm3060TypeModeControlDac with get, set

Property Value

Type: Pcm3060TypeModeControlDac
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.ModeControlMRST Property

IRD

Pcm3060ModeControlMRST Property

Mode Control: MRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeModeControlModeReset ModeControlMRST { get; set; }
Public Property ModeControlMRST As Pcm3060TypeModeControlModeReset
    Get
    Set
public:
property Pcm3060TypeModeControlModeReset ModeControlMRST {
    Pcm3060TypeModeControlModeReset get ();
    void set (Pcm3060TypeModeControlModeReset value);
}
member ModeControlMRST : Pcm3060TypeModeControlModeReset with get, set

Property Value

Type: Pcm3060TypeModeControlModeReset
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.ModeControlSE Property

IRD

Pcm3060ModeControlSE Property

Mode Control: S/E

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeModeControlSingle ModeControlSE { get; set; }
Public Property ModeControlSE As Pcm3060TypeModeControlSingle
    Get
    Set
public:
property Pcm3060TypeModeControlSingle ModeControlSE {
    Pcm3060TypeModeControlSingle get ();
    void set (Pcm3060TypeModeControlSingle value);
}
member ModeControlSE : Pcm3060TypeModeControlSingle with get, set

Property Value

Type: Pcm3060TypeModeControlSingle
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.ModeControlSRST Property

IRD

Pcm3060ModeControlSRST Property

Mode Control: SRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3060TypeModeControlSystemReset ModeControlSRST { get; set; }
Public Property ModeControlSRST As Pcm3060TypeModeControlSystemReset
    Get
    Set
public:
property Pcm3060TypeModeControlSystemReset ModeControlSRST {
    Pcm3060TypeModeControlSystemReset get ();
    void set (Pcm3060TypeModeControlSystemReset value);
}
member ModeControlSRST : Pcm3060TypeModeControlSystemReset with get, set

Property Value

Type: Pcm3060TypeModeControlSystemReset
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060 Methods

The Pcm3060 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.Flush Method

IRD

Pcm3060Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcm3060 Class
telos.Ird.TexasInstruments Namespace


Pcm3060.TypeAdcAttenuation Enumeration

IRD

Pcm3060TypeAdcAttenuation Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcAttenuation
Public Enumeration TypeAdcAttenuation
public enum class TypeAdcAttenuation
type TypeAdcAttenuation
Members
Member name | Value | Description
Value_20_0 | 255 | 20.0
Value_19_5 | 254 | 19.5
Value_19_0 | 253 | 19.0
Value_18_5 | 252 | 18.5
Value_18_0 | 251 | 18.0
Value_17_5 | 250 | 17.5
Value_17_0 | 249 | 17.0
Value_16_5 | 248 | 16.5
Value_16_0 | 247 | 16.0
Value_15_5 | 246 | 15.5
Value_15_0 | 245 | 15.0
Value_14_5 | 244 | 14.5
Value_14_0 | 243 | 14.0
Value_13_5 | 242 | 13.5
Value_13_0 | 241 | 13.0
Value_12_5 | 240 | 12.5
Value_12_0 | 239 | 12.0
Value_11_5 | 238 | 11.5
Value_11_0 | 237 | 11.0
Value_10_5 | 236 | 10.5
Value_10_0 | 235 | 10.0
Value_9_5 | 234 | 9.5
Value_9_0 | 233 | 9.0
Value_8_5 | 232 | 8.5
Value_8_0 | 231 | 8.0
Value_7_5 | 230 | 7.5
Value_7_0 | 229 | 7.0
Value_6_5 | 228 | 6.5
Value_6_0 | 227 | 6.0
Value_5_5 | 226 | 5.5
Value_5_0 | 225 | 5.0
Value_4_5 | 224 | 4.5
Value_4_0 | 223 | 4.0
Value_3_5 | 222 | 3.5
Value_3_0 | 221 | 3.0
Value_2_5 | 220 | 2.5
Value_2_0 | 219 | 2.0
Value_1_5 | 218 | 1.5
Value_1_0 | 217 | 1.0
Value_0_5 | 216 | 0.5
Value_0_0 | 215 | 0.0
Value_M_0_5 | 214 | -0.5
Value_M_1_0 | 213 | -1.0
Value_M_1_5 | 212 | -1.5
Value_M_2_0 | 211 | -2.0
Value_M_2_5 | 210 | -2.5
Value_M_3_0 | 209 | -3.0
Value_M_3_5 | 208 | -3.5
Value_M_4_0 | 207 | -4.0
Value_M_4_5 | 206 | -4.5
Value_M_5_0 | 205 | -5.0
Value_M_5_5 | 204 | -5.5
Value_M_6_0 | 203 | -6.0
Value_M_6_5 | 202 | -6.5
Value_M_7_0 | 201 | -7.0
Value_M_7_5 | 200 | -7.5
Value_M_8_0 | 199 | -8.0
Value_M_8_5 | 198 | -8.5
Value_M_9_0 | 197 | -9.0
Value_M_9_5 | 196 | -9.5
Value_M_10_0 | 195 | -10.0
Value_M_10_5 | 194 | -10.5
Value_M_11_0 | 193 | -11.0
Value_M_11_5 | 192 | -11.5
Value_M_12_0 | 191 | -12.0
Value_M_12_5 | 190 | -12.5
Value_M_13_0 | 189 | -13.0
Value_M_13_5 | 188 | -13.5
Value_M_14_0 | 187 | -14.0
Value_M_14_5 | 186 | -14.5
Value_M_15_0 | 185 | -15.0
Value_M_15_5 | 184 | -15.5
Value_M_16_0 | 183 | -16.0
Value_M_16_5 | 182 | -16.5
Value_M_17_0 | 181 | -17.0
Value_M_17_5 | 180 | -17.5
Value_M_18_0 | 179 | -18.0
Value_M_18_5 | 178 | -18.5
Value_M_19_0 | 177 | -19.0
Value_M_19_5 | 176 | -19.5
Value_M_20_0 | 175 | -20.0
Value_M_20_5 | 174 | -20.5
Value_M_21_0 | 173 | -21.0
Value_M_21_5 | 172 | -21.5
Value_M_22_0 | 171 | -22.0
Value_M_22_5 | 170 | -22.5
Value_M_23_0 | 169 | -23.0
Value_M_23_5 | 168 | -23.5
Value_M_24_0 | 167 | -24.0
Value_M_24_5 | 166 | -24.5
Value_M_25_0 | 165 | -25.0
Value_M_25_5 | 164 | -25.5
Value_M_26_0 | 163 | -26.0
Value_M_26_5 | 162 | -26.5
Value_M_27_0 | 161 | -27.0
Value_M_27_5 | 160 | -27.5
Value_M_28_0 | 159 | -28.0
Value_M_28_5 | 158 | -28.5
Value_M_29_0 | 157 | -29.0
Value_M_29_5 | 156 | -29.5
Value_M_30_0 | 155 | -30.0
Value_M_30_5 | 154 | -30.5
Value_M_31_0 | 153 | -31.0
Value_M_31_5 | 152 | -31.5
Value_M_32_0 | 151 | -32.0
Value_M_32_5 | 150 | -32.5
Value_M_33_0 | 149 | -33.0
Value_M_33_5 | 148 | -33.5
Value_M_34_0 | 147 | -34.0
Value_M_34_5 | 146 | -34.5
Value_M_35_0 | 145 | -35.0
Value_M_35_5 | 144 | -35.5
Value_M_36_0 | 143 | -36.0
Value_M_36_5 | 142 | -36.5
Value_M_37_0 | 141 | -37.0
Value_M_37_5 | 140 | -37.5
Value_M_38_0 | 139 | -38.0
Value_M_38_5 | 138 | -38.5
Value_M_39_0 | 137 | -39.0
Value_M_39_5 | 136 | -39.5
Value_M_40_0 | 135 | -40.0
Value_M_40_5 | 134 | -40.5
Value_M_41_0 | 133 | -41.0
Value_M_41_5 | 132 | -41.5
Value_M_42_0 | 131 | -42.0
Value_M_42_5 | 130 | -42.5
Value_M_43_0 | 129 | -43.0
Value_M_43_5 | 128 | -43.5
Value_M_44_0 | 127 | -44.0
Value_M_44_5 | 126 | -44.5
Value_M_45_0 | 125 | -45.0
Value_M_45_5 | 124 | -45.5
Value_M_46_0 | 123 | -46.0
Value_M_46_5 | 122 | -46.5
Value_M_47_0 | 121 | -47.0
Value_M_47_5 | 120 | -47.5
Value_M_48_0 | 119 | -48.0
Value_M_48_5 | 118 | -48.5
Value_M_49_0 | 117 | -49.0
Value_M_49_5 | 116 | -49.5
Value_M_50_0 | 115 | -50.0
Value_M_50_5 | 114 | -50.5
Value_M_51_0 | 113 | -51.0
Value_M_51_5 | 112 | -51.5
Value_M_52_0 | 111 | -52.0
Value_M_52_5 | 110 | -52.5
Value_M_53_0 | 109 | -53.0
Value_M_53_5 | 108 | -53.5
Value_M_54_0 | 107 | -54.0
Value_M_54_5 | 106 | -54.5
Value_M_55_0 | 105 | -55.0
Value_M_55_5 | 104 | -55.5
Value_M_56_0 | 103 | -56.0
Value_M_56_5 | 102 | -56.5
Value_M_57_0 | 101 | -57.0
Value_M_57_5 | 100 | -57.5
Value_M_58_0 | 99 | -58.0
Value_M_58_5 | 98 | -58.5
Value_M_59_0 | 97 | -59.0
Value_M_59_5 | 96 | -59.5
Value_M_60_0 | 95 | -60.0
Value_M_60_5 | 94 | -60.5
Value_M_61_0 | 93 | -61.0
Value_M_61_5 | 92 | -61.5
Value_M_62_0 | 91 | -62.0
Value_M_62_5 | 90 | -62.5
Value_M_63_0 | 89 | -63.0
Value_M_63_5 | 88 | -63.5
Value_M_64_0 | 87 | -64.0
Value_M_64_5 | 86 | -64.5
Value_M_65_0 | 85 | -65.0
Value_M_65_5 | 84 | -65.5
Value_M_66_0 | 83 | -66.0
Value_M_66_5 | 82 | -66.5
Value_M_67_0 | 81 | -67.0
Value_M_67_5 | 80 | -67.5
Value_M_68_0 | 79 | -68.0
Value_M_68_5 | 78 | -68.5
Value_M_69_0 | 77 | -69.0
Value_M_69_5 | 76 | -69.5
Value_M_70_0 | 75 | -70.0
Value_M_70_5 | 74 | -70.5
Value_M_71_0 | 73 | -71.0
Value_M_71_5 | 72 | -71.5
Value_M_72_0 | 71 | -72.0
Value_M_72_5 | 70 | -72.5
Value_M_73_0 | 69 | -73.0
Value_M_73_5 | 68 | -73.5
Value_M_74_0 | 67 | -74.0
Value_M_74_5 | 66 | -74.5
Value_M_75_0 | 65 | -75.0
Value_M_75_5 | 64 | -75.5
Value_M_76_0 | 63 | -76.0
Value_M_76_5 | 62 | -76.5
Value_M_77_0 | 61 | -77.0
Value_M_77_5 | 60 | -77.5
Value_M_78_0 | 59 | -78.0
Value_M_78_5 | 58 | -78.5
Value_M_79_0 | 57 | -79.0
Value_M_79_5 | 56 | -79.5
Value_M_80_0 | 55 | -80.0
Value_M_80_5 | 54 | -80.5
Value_M_81_0 | 53 | -81.0
Value_M_81_5 | 52 | -81.5
Value_M_82_0 | 51 | -82.0
Value_M_82_5 | 50 | -82.5
Value_M_83_0 | 49 | -83.0
Value_M_83_5 | 48 | -83.5
Value_M_84_0 | 47 | -84.0
Value_M_84_5 | 46 | -84.5
Value_M_85_0 | 45 | -85.0
Value_M_85_5 | 44 | -85.5
Value_M_86_0 | 43 | -86.0
Value_M_86_5 | 42 | -86.5
Value_M_87_0 | 41 | -87.0
Value_M_87_5 | 40 | -87.5
Value_M_88_0 | 39 | -88.0
Value_M_88_5 | 38 | -88.5
Value_M_89_0 | 37 | -89.0
Value_M_89_5 | 36 | -89.5
Value_M_90_0 | 35 | -90.0
Value_M_90_5 | 34 | -90.5
Value_M_91_0 | 33 | -91.0
Value_M_91_5 | 32 | -91.5
Value_M_92_0 | 31 | -92.0
Value_M_92_5 | 30 | -92.5
Value_M_93_0 | 29 | -93.0
Value_M_93_5 | 28 | -93.5
Value_M_94_0 | 27 | -94.0
Value_M_94_5 | 26 | -94.5
Value_M_95_0 | 25 | -95.0
Value_M_95_5 | 24 | -95.5
Value_M_96_0 | 23 | -96.0
Value_M_96_5 | 22 | -96.5
Value_M_97_0 | 21 | -97.0
Value_M_97_5 | 20 | -97.5
Value_M_98_0 | 19 | -98.0
Value_M_98_5 | 18 | -98.5
Value_M_99_0 | 17 | -99.0
Value_M_99_5 | 16 | -99.5
Value_M_100_0 | 15 | -100.0
Mute | 0 | Mute
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeAdcFilterBypass Enumeration

IRD

Pcm3060TypeAdcFilterBypass Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcFilterBypass
Public Enumeration TypeAdcFilterBypass
public enum class TypeAdcFilterBypass
type TypeAdcFilterBypass
Members
Member name | Value | Description
HPFEnabledNormalOutput | 0 | HPF Enabled (Normal Output)
HPFDisabledBypassedOutput | 1 | HPF Disabled (Bypassed Output)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeAdcFilterMute11 Enumeration

IRD

Pcm3060TypeAdcFilterMute11 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcFilterMute11
Public Enumeration TypeAdcFilterMute11
public enum class TypeAdcFilterMute11
type TypeAdcFilterMute11
Members
Member name | Value | Description
LChannelDOUTMuteDisabled | 0 | L-Channel DOUT: Mute Disabled
LChannelDOUTMuteEnabled | 1 | L-Channel DOUT: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeAdcFilterMute12 Enumeration

IRD

Pcm3060TypeAdcFilterMute12 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcFilterMute12
Public Enumeration TypeAdcFilterMute12
public enum class TypeAdcFilterMute12
type TypeAdcFilterMute12
Members
Member name | Value | Description
RChannelDOUTMuteDisabled | 0 | R-Channel DOUT: Mute Disabled
RChannelDOUTMuteEnabled | 1 | R-Channel DOUT: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeAdcFilterPhase Enumeration

IRD

Pcm3060TypeAdcFilterPhase Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcFilterPhase
Public Enumeration TypeAdcFilterPhase
public enum class TypeAdcFilterPhase
type TypeAdcFilterPhase
Members
Member name | Value | Description
AnalogSignalInputPhaseNormal | 0 | Analog Signal Input Phase: Normal
AnalogSignalInputPhaseInverted | 1 | Analog Signal Input Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeAdcFilterZeroCross Enumeration

IRD

Pcm3060TypeAdcFilterZeroCross Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcFilterZeroCross
Public Enumeration TypeAdcFilterZeroCross
public enum class TypeAdcFilterZeroCross
type TypeAdcFilterZeroCross
Members
Member name | Value | Description
ZeroCrossDetectionEnabled | 0 | Zero-Cross Detection: Enabled
ZeroCrossDetectionDisabled | 1 | Zero-Cross Detection: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeAdcInterfaceClock Enumeration

IRD

Pcm3060TypeAdcInterfaceClock Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcInterfaceClock
Public Enumeration TypeAdcInterfaceClock
public enum class TypeAdcInterfaceClock
type TypeAdcInterfaceClock
Members
Member name | Value | Description
EnabledForADCOperationSCKI1BCK1LRCK1 | 0 | Enabled For ADC Operation: SCKI1, BCK1, LRCK1
EnabledForADCOperationSCKI2BCK2LRCK2 | 1 | Enabled For ADC Operation: SCKI2, BCK2, LRCK2
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeAdcInterfaceFormat Enumeration

IRD

Pcm3060TypeAdcInterfaceFormat Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcInterfaceFormat
Public Enumeration TypeAdcInterfaceFormat
public enum class TypeAdcInterfaceFormat
type TypeAdcInterfaceFormat
Members
Member name | Value | Description
ADCAudioFormat24BitI2S | 0 | ADC Audio Format: 24 Bit I2S
ADCAudioFormat24BitLeftJustified | 1 | ADC Audio Format: 24 Bit Left-Justified
ADCAudioFormat24BitRightJustified | 2 | ADC Audio Format: 24 Bit Right-Justified
ADCAudioFormat16BitRightJustified | 3 | ADC Audio Format: 16 Bit Right-Justified
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeAdcInterfaceMode Enumeration

IRD

Pcm3060TypeAdcInterfaceMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcInterfaceMode
Public Enumeration TypeAdcInterfaceMode
public enum class TypeAdcInterfaceMode
type TypeAdcInterfaceMode
Members
Member name | Value | Description
ADCSlaveMode | 0 | ADC Slave Mode
ADCMasterMode768Fs | 1 | ADC Master Mode: 768 Fs
ADCMasterMode512Fs | 2 | ADC Master Mode: 512 Fs
ADCMasterMode384Fs | 3 | ADC Master Mode: 384 Fs
ADCMasterMode256Fs | 4 | ADC Master Mode: 256 Fs
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeDacAttenuation Enumeration

IRD

Pcm3060TypeDacAttenuation Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacAttenuation
Public Enumeration TypeDacAttenuation
public enum class TypeDacAttenuation
type TypeDacAttenuation
Members
Member name | Value | Description
Value_0_0 | 255 | 0.0
Value_M_0_5 | 254 | -0.5
Value_M_1_0 | 253 | -1.0
Value_M_1_5 | 252 | -1.5
Value_M_2_0 | 251 | -2.0
Value_M_2_5 | 250 | -2.5
Value_M_3_0 | 249 | -3.0
Value_M_3_5 | 248 | -3.5
Value_M_4_0 | 247 | -4.0
Value_M_4_5 | 246 | -4.5
Value_M_5_0 | 245 | -5.0
Value_M_5_5 | 244 | -5.5
Value_M_6_0 | 243 | -6.0
Value_M_6_5 | 242 | -6.5
Value_M_7_0 | 241 | -7.0
Value_M_7_5 | 240 | -7.5
Value_M_8_0 | 239 | -8.0
Value_M_8_5 | 238 | -8.5
Value_M_9_0 | 237 | -9.0
Value_M_9_5 | 236 | -9.5
Value_M_10_0 | 235 | -10.0
Value_M_10_5 | 234 | -10.5
Value_M_11_0 | 233 | -11.0
Value_M_11_5 | 232 | -11.5
Value_M_12_0 | 231 | -12.0
Value_M_12_5 | 230 | -12.5
Value_M_13_0 | 229 | -13.0
Value_M_13_5 | 228 | -13.5
Value_M_14_0 | 227 | -14.0
Value_M_14_5 | 226 | -14.5
Value_M_15_0 | 225 | -15.0
Value_M_15_5 | 224 | -15.5
Value_M_16_0 | 223 | -16.0
Value_M_16_5 | 222 | -16.5
Value_M_17_0 | 221 | -17.0
Value_M_17_5 | 220 | -17.5
Value_M_18_0 | 219 | -18.0
Value_M_18_5 | 218 | -18.5
Value_M_19_0 | 217 | -19.0
Value_M_19_5 | 216 | -19.5
Value_M_20_0 | 215 | -20.0
Value_M_20_5 | 214 | -20.5
Value_M_21_0 | 213 | -21.0
Value_M_21_5 | 212 | -21.5
Value_M_22_0 | 211 | -22.0
Value_M_22_5 | 210 | -22.5
Value_M_23_0 | 209 | -23.0
Value_M_23_5 | 208 | -23.5
Value_M_24_0 | 207 | -24.0
Value_M_24_5 | 206 | -24.5
Value_M_25_0 | 205 | -25.0
Value_M_25_5 | 204 | -25.5
Value_M_26_0 | 203 | -26.0
Value_M_26_5 | 202 | -26.5
Value_M_27_0 | 201 | -27.0
Value_M_27_5 | 200 | -27.5
Value_M_28_0 | 199 | -28.0
Value_M_28_5 | 198 | -28.5
Value_M_29_0 | 197 | -29.0
Value_M_29_5 | 196 | -29.5
Value_M_30_0 | 195 | -30.0
Value_M_30_5 | 194 | -30.5
Value_M_31_0 | 193 | -31.0
Value_M_31_5 | 192 | -31.5
Value_M_32_0 | 191 | -32.0
Value_M_32_5 | 190 | -32.5
Value_M_33_0 | 189 | -33.0
Value_M_33_5 | 188 | -33.5
Value_M_34_0 | 187 | -34.0
Value_M_34_5 | 186 | -34.5
Value_M_35_0 | 185 | -35.0
Value_M_35_5 | 184 | -35.5
Value_M_36_0 | 183 | -36.0
Value_M_36_5 | 182 | -36.5
Value_M_37_0 | 181 | -37.0
Value_M_37_5 | 180 | -37.5
Value_M_38_0 | 179 | -38.0
Value_M_38_5 | 178 | -38.5
Value_M_39_0 | 177 | -39.0
Value_M_39_5 | 176 | -39.5
Value_M_40_0 | 175 | -40.0
Value_M_40_5 | 174 | -40.5
Value_M_41_0 | 173 | -41.0
Value_M_41_5 | 172 | -41.5
Value_M_42_0 | 171 | -42.0
Value_M_42_5 | 170 | -42.5
Value_M_43_0 | 169 | -43.0
Value_M_43_5 | 168 | -43.5
Value_M_44_0 | 167 | -44.0
Value_M_44_5 | 166 | -44.5
Value_M_45_0 | 165 | -45.0
Value_M_45_5 | 164 | -45.5
Value_M_46_0 | 163 | -46.0
Value_M_46_5 | 162 | -46.5
Value_M_47_0 | 161 | -47.0
Value_M_47_5 | 160 | -47.5
Value_M_48_0 | 159 | -48.0
Value_M_48_5 | 158 | -48.5
Value_M_49_0 | 157 | -49.0
Value_M_49_5 | 156 | -49.5
Value_M_50_0 | 155 | -50.0
Value_M_50_5 | 154 | -50.5
Value_M_51_0 | 153 | -51.0
Value_M_51_5 | 152 | -51.5
Value_M_52_0 | 151 | -52.0
Value_M_52_5 | 150 | -52.5
Value_M_53_0 | 149 | -53.0
Value_M_53_5 | 148 | -53.5
Value_M_54_0 | 147 | -54.0
Value_M_54_5 | 146 | -54.5
Value_M_55_0 | 145 | -55.0
Value_M_55_5 | 144 | -55.5
Value_M_56_0 | 143 | -56.0
Value_M_56_5 | 142 | -56.5
Value_M_57_0 | 141 | -57.0
Value_M_57_5 | 140 | -57.5
Value_M_58_0 | 139 | -58.0
Value_M_58_5 | 138 | -58.5
Value_M_59_0 | 137 | -59.0
Value_M_59_5 | 136 | -59.5
Value_M_60_0 | 135 | -60.0
Value_M_60_5 | 134 | -60.5
Value_M_61_0 | 133 | -61.0
Value_M_61_5 | 132 | -61.5
Value_M_62_0 | 131 | -62.0
Value_M_62_5 | 130 | -62.5
Value_M_63_0 | 129 | -63.0
Value_M_63_5 | 128 | -63.5
Value_M_64_0 | 127 | -64.0
Value_M_64_5 | 126 | -64.5
Value_M_65_0 | 125 | -65.0
Value_M_65_5 | 124 | -65.5
Value_M_66_0 | 123 | -66.0
Value_M_66_5 | 122 | -66.5
Value_M_67_0 | 121 | -67.0
Value_M_67_5 | 120 | -67.5
Value_M_68_0 | 119 | -68.0
Value_M_68_5 | 118 | -68.5
Value_M_69_0 | 117 | -69.0
Value_M_69_5 | 116 | -69.5
Value_M_70_0 | 115 | -70.0
Value_M_70_5 | 114 | -70.5
Value_M_71_0 | 113 | -71.0
Value_M_71_5 | 112 | -71.5
Value_M_72_0 | 111 | -72.0
Value_M_72_5 | 110 | -72.5
Value_M_73_0 | 109 | -73.0
Value_M_73_5 | 108 | -73.5
Value_M_74_0 | 107 | -74.0
Value_M_74_5 | 106 | -74.5
Value_M_75_0 | 105 | -75.0
Value_M_75_5 | 104 | -75.5
Value_M_76_0 | 103 | -76.0
Value_M_76_5 | 102 | -76.5
Value_M_77_0 | 101 | -77.0
Value_M_77_5 | 100 | -77.5
Value_M_78_0 | 99 | -78.0
Value_M_78_5 | 98 | -78.5
Value_M_79_0 | 97 | -79.0
Value_M_79_5 | 96 | -79.5
Value_M_80_0 | 95 | -80.0
Value_M_80_5 | 94 | -80.5
Value_M_81_0 | 93 | -81.0
Value_M_81_5 | 92 | -81.5
Value_M_82_0 | 91 | -82.0
Value_M_82_5 | 90 | -82.5
Value_M_83_0 | 89 | -83.0
Value_M_83_5 | 88 | -83.5
Value_M_84_0 | 87 | -84.0
Value_M_84_5 | 86 | -84.5
Value_M_85_0 | 85 | -85.0
Value_M_85_5 | 84 | -85.5
Value_M_86_0 | 83 | -86.0
Value_M_86_5 | 82 | -86.5
Value_M_87_0 | 81 | -87.0
Value_M_87_5 | 80 | -87.5
Value_M_88_0 | 79 | -88.0
Value_M_88_5 | 78 | -88.5
Value_M_89_0 | 77 | -89.0
Value_M_89_5 | 76 | -89.5
Value_M_90_0 | 75 | -90.0
Value_M_90_5 | 74 | -90.5
Value_M_91_0 | 73 | -91.0
Value_M_91_5 | 72 | -91.5
Value_M_92_0 | 71 | -92.0
Value_M_92_5 | 70 | -92.5
Value_M_93_0 | 69 | -93.0
Value_M_93_5 | 68 | -93.5
Value_M_94_0 | 67 | -94.0
Value_M_94_5 | 66 | -94.5
Value_M_95_0 | 65 | -95.0
Value_M_95_5 | 64 | -95.5
Value_M_96_0 | 63 | -96.0
Value_M_96_5 | 62 | -96.5
Value_M_97_0 | 61 | -97.0
Value_M_97_5 | 60 | -97.5
Value_M_98_0 | 59 | -98.0
Value_M_98_5 | 58 | -98.5
Value_M_99_0 | 57 | -99.0
Value_M_99_5 | 56 | -99.5
Value_M_100_0 | 55 | -100.0
Mute | 0 | Mute
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeDacControlMut21 Enumeration

IRD

Pcm3060TypeDacControlMut21 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControlMut21
Public Enumeration TypeDacControlMut21
public enum class TypeDacControlMut21
type TypeDacControlMut21
Members
Member name | Value | Description
VoutLMuteDisabled | 0 | VoutL: Mute Disabled
VoutLMuteEnabled | 1 | VoutL: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeDacControlMut22 Enumeration

IRD

Pcm3060TypeDacControlMut22 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControlMut22
Public Enumeration TypeDacControlMut22
public enum class TypeDacControlMut22
type TypeDacControlMut22
Members
Member name | Value | Description
VoutRMuteDisabled | 0 | VoutR: Mute Disabled
VoutRMuteEnabled | 1 | VoutR: Mute Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeDacControlOver Enumeration

IRD

Pcm3060TypeDacControlOver Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControlOver
Public Enumeration TypeDacControlOver
public enum class TypeDacControlOver
type TypeDacControlOver
Members
Member name | Value | Description
Oversampling64x512Or768Fs32x256Or384Fs16x128Or192Fs | 0 | Oversampling: 64x (512 Or 768 Fs) / 32x (256 Or 384 Fs) / 16x (128 Or 192 Fs)
Oversampling128x512Or768Fs64x256Or384Fs32x128Or192Fs | 1 | Oversampling: 128x (512 Or 768 Fs) / 64x (256 Or 384 Fs) / 32x (128 Or 192 Fs)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeDacControlPhase Enumeration

IRD

Pcm3060TypeDacControlPhase Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacControlPhase
Public Enumeration TypeDacControlPhase
public enum class TypeDacControlPhase
type TypeDacControlPhase
Members
Member name | Value | Description
AnalogSignalOutputPhaseNormal | 0 | Analog Signal Output Phase: Normal
AnalogSignalOutputPhaseInverted | 1 | Analog Signal Output Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeDacFilterDeEmphasis Enumeration

IRD

Pcm3060TypeDacFilterDeEmphasis Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacFilterDeEmphasis
Public Enumeration TypeDacFilterDeEmphasis
public enum class TypeDacFilterDeEmphasis
type TypeDacFilterDeEmphasis
Members
Member name | Value | Description
DeEmphasisDisabled | 0 | De-Emphasis: Disabled
DeEmphasisEnabled | 1 | De-Emphasis: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeDacFilterRolloff Enumeration

IRD

Pcm3060TypeDacFilterRolloff Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacFilterRolloff
Public Enumeration TypeDacFilterRolloff
public enum class TypeDacFilterRolloff
type TypeDacFilterRolloff
Members
Member name | Value | Description
DigitalFilterSharpRollOff | 0 | Digital Filter: Sharp Roll-Off
DigitalFilterSlowRollOff | 1 | Digital Filter: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeDacFilterSampling Enumeration

IRD

Pcm3060TypeDacFilterSampling Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacFilterSampling
Public Enumeration TypeDacFilterSampling
public enum class TypeDacFilterSampling
type TypeDacFilterSampling
Members
Member name | Value | Description
DeEmphasisSamplingRate441KHz | 0 | De-Emphasis Sampling Rate: 44.1 kHz
DeEmphasisSamplingRate48KHz | 1 | De-Emphasis Sampling Rate: 48 kHz
DeEmphasisSamplingRate32KHz | 2 | De-Emphasis Sampling Rate: 32 kHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeDacFilterZeroFunc Enumeration

IRD

Pcm3060TypeDacFilterZeroFunc Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacFilterZeroFunc
Public Enumeration TypeDacFilterZeroFunc
public enum class TypeDacFilterZeroFunc
type TypeDacFilterZeroFunc
Members
Member name | Value | Description
ZeroFlagFunctionZeroLLChannelZeroRRChannel | 0 | Zero Flag Function: Zero-L = L Channel / Zero-R = R Channel
ZeroFlagFunctionZeroLLRChannelZeroRLRChannel | 1 | Zero Flag Function: Zero-L = L+R Channel / Zero-R = L+R Channel
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeDacFilterZeroPol Enumeration

IRD

Pcm3060TypeDacFilterZeroPol Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacFilterZeroPol
Public Enumeration TypeDacFilterZeroPol
public enum class TypeDacFilterZeroPol
type TypeDacFilterZeroPol
Members
Member name | Value | Description
ZeroFlagPolarityHigh | 0 | Zero Flag Polarity: High
ZeroFlagPolarityLow | 1 | Zero Flag Polarity: Low
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeDacInterfaceClock Enumeration

IRD

Pcm3060TypeDacInterfaceClock Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacInterfaceClock
Public Enumeration TypeDacInterfaceClock
public enum class TypeDacInterfaceClock
type TypeDacInterfaceClock
Members
Member name | Value | Description
EnabledForDACOperationSCKI2BCK2LRCK2 | 0 | Enabled For DAC Operation: SCKI2, BCK2, LRCK2
EnabledForDACOperationSCKI1BCK1LRCK1 | 1 | Enabled For DAC Operation: SCKI1, BCK1, LRCK1
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeDacInterfaceFormat Enumeration

IRD

Pcm3060TypeDacInterfaceFormat Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacInterfaceFormat
Public Enumeration TypeDacInterfaceFormat
public enum class TypeDacInterfaceFormat
type TypeDacInterfaceFormat
Members
Member name | Value | Description
DACAudioFormat24BitI2S | 0 | DAC Audio Format: 24 Bit I2S
DACAudioFormat24BitLeftJustified | 1 | DAC Audio Format: 24 Bit Left-Justified
DACAudioFormat24BitRightJustified | 2 | DAC Audio Format: 24 Bit Right-Justified
DACAudioFormat16BitRightJustified | 3 | DAC Audio Format: 16 Bit Right-Justified
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeDacInterfaceMode Enumeration

IRD

Pcm3060TypeDacInterfaceMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacInterfaceMode
Public Enumeration TypeDacInterfaceMode
public enum class TypeDacInterfaceMode
type TypeDacInterfaceMode
Members
Member name | Value | Description
DACSlaveMode | 0 | DAC Slave Mode
DACMasterMode768Fs | 1 | DAC Master Mode: 768 Fs
DACMasterMode512Fs | 2 | DAC Master Mode: 512 Fs
DACMasterMode384Fs | 3 | DAC Master Mode: 384 Fs
DACMasterMode256Fs | 4 | DAC Master Mode: 256 Fs
DACMasterMode192Fs | 5 | DAC Master Mode: 192 Fs
DACMasterMode128Fs | 6 | DAC Master Mode: 128 Fs
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeModeControlAdc Enumeration

IRD

Pcm3060TypeModeControlAdc Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlAdc
Public Enumeration TypeModeControlAdc
public enum class TypeModeControlAdc
type TypeModeControlAdc
Members
Member name | Value | Description
ADCPowerSaveModeNormalOperation | 0 | ADC Power-Save Mode: Normal Operation
ADCPowerSaveModeEnabled | 1 | ADC Power-Save Mode: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeModeControlDac Enumeration

IRD

Pcm3060TypeModeControlDac Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlDac
Public Enumeration TypeModeControlDac
public enum class TypeModeControlDac
type TypeModeControlDac
Members
Member name | Value | Description
DACPowerSaveModeNormalOperation | 0 | DAC Power-Save Mode: Normal Operation
DACPowerSaveModeEnabled | 1 | DAC Power-Save Mode: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeModeControlModeReset Enumeration

IRD

Pcm3060TypeModeControlModeReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlModeReset
Public Enumeration TypeModeControlModeReset
public enum class TypeModeControlModeReset
type TypeModeControlModeReset
Members
Member name | Value | Description
ModeControlRegisterResetExecution | 0 | Mode Control Register Reset: Execution
ModeControlRegisterResetNormalOperation | 1 | Mode Control Register Reset: Normal Operation
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeModeControlSingle Enumeration

IRD

Pcm3060TypeModeControlSingle Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlSingle
Public Enumeration TypeModeControlSingle
public enum class TypeModeControlSingle
type TypeModeControlSingle
Members
Member name | Value | Description
DACOutputConfigurationDifferential | 0 | DAC Output Configuration: Differential
DACOutputConfigurationSingleEnded | 1 | DAC Output Configuration: Single-Ended
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3060.TypeModeControlSystemReset Enumeration

IRD

Pcm3060TypeModeControlSystemReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeModeControlSystemReset
Public Enumeration TypeModeControlSystemReset
public enum class TypeModeControlSystemReset
type TypeModeControlSystemReset
Members
Member name | Value | Description
SystemResetReSynchronization | 0 | System Reset: Re-Synchronization
SystemResetNormalOperation | 1 | System Reset: Normal Operation
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a Class

Texas Instruments: PCM 3168A
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsPcm3168a

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Pcm3168a
Public Class Pcm3168a
public ref class Pcm3168a
type Pcm3168a =  class end

The Pcm3168a type exposes the following members.

Constructors
 | Name | Description
Public method | Pcm3168a | Constructor
Top
Properties
 | Name | Description
Public property | ADCAttenuation0ATAD0 | ADC Attenuation0: ATAD0 (unit: dB)
Public property | ADCAttenuation1ATAD1 | ADC Attenuation1: ATAD1 (unit: dB)
Public property | ADCAttenuation2ATAD2 | ADC Attenuation2: ATAD2 (unit: dB)
Public property | ADCAttenuation3ATAD3 | ADC Attenuation3: ATAD3 (unit: dB)
Public property | ADCAttenuation4ATAD4 | ADC Attenuation4: ATAD4 (unit: dB)
Public property | ADCAttenuation5ATAD5 | ADC Attenuation5: ATAD5 (unit: dB)
Public property | ADCAttenuation6ATAD6 | ADC Attenuation6: ATAD6 (unit: dB)
Public property | ADCAttenuationControlATMDAD | ADC Attenuation Control: ATMDAD
Public property | ADCAttenuationControlATSPAD | ADC Attenuation Control: ATSPAD
Public property | ADCAttenuationControlOVFP | ADC Attenuation Control: OVFP
Public property | ADCConfigControlSEAD1 | ADC Config Control: SEAD1
Public property | ADCConfigControlSEAD2 | ADC Config Control: SEAD2
Public property | ADCConfigControlSEAD3 | ADC Config Control: SEAD3
Public property | ADCConfigControlSEAD4 | ADC Config Control: SEAD4
Public property | ADCConfigControlSEAD5 | ADC Config Control: SEAD5
Public property | ADCConfigControlSEAD6 | ADC Config Control: SEAD6
Public property | ADCModeControlSRAD | ADC Mode Control: SRAD
Public property | ADCModeSelectFMTAD | ADC Mode Select: FMTAD
Public property | ADCModeSelectMSAD | ADC Mode Select: MSAD
Public property | ADCMuteMUTAD1 | ADC Mute: MUTAD1
Public property | ADCMuteMUTAD2 | ADC Mute: MUTAD2
Public property | ADCMuteMUTAD3 | ADC Mute: MUTAD3
Public property | ADCMuteMUTAD4 | ADC Mute: MUTAD4
Public property | ADCMuteMUTAD5 | ADC Mute: MUTAD5
Public property | ADCMuteMUTAD6 | ADC Mute: MUTAD6
Public property | ADCOverflowOVF1 | ADC Overflow: OVF1
Public property | ADCOverflowOVF2 | ADC Overflow: OVF2
Public property | ADCOverflowOVF3 | ADC Overflow: OVF3
Public property | ADCOverflowOVF4 | ADC Overflow: OVF4
Public property | ADCOverflowOVF5 | ADC Overflow: OVF5
Public property | ADCOverflowOVF6 | ADC Overflow: OVF6
Public property | ADCPhaseREVAD1 | ADC Phase: REVAD1
Public property | ADCPhaseREVAD2 | ADC Phase: REVAD2
Public property | ADCPhaseREVAD3 | ADC Phase: REVAD3
Public property | ADCPhaseREVAD4 | ADC Phase: REVAD4
Public property | ADCPhaseREVAD5 | ADC Phase: REVAD5
Public property | ADCPhaseREVAD6 | ADC Phase: REVAD6
Public property | ADCPowerControlBYP0 | ADC Power Control: BYP0
Public property | ADCPowerControlBYP1 | ADC Power Control: BYP1
Public property | ADCPowerControlBYP2 | ADC Power Control: BYP2
Public property | ADCPowerControlPSVAD0 | ADC Power Control: PSVAD0
Public property | ADCPowerControlPSVAD1 | ADC Power Control: PSVAD1
Public property | ADCPowerControlPSVAD2 | ADC Power Control: PSVAD2
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DACAttenuation0ATDA0 | DAC Attenuation0: ATDA0 (unit: dB)
Public property | DACAttenuation1ATDA1 | DAC Attenuation1: ATDA1 (unit: dB)
Public property | DACAttenuation2ATDA2 | DAC Attenuation2: ATDA2 (unit: dB)
Public property | DACAttenuation3ATDA3 | DAC Attenuation3: ATDA3 (unit: dB)
Public property | DACAttenuation4ATDA4 | DAC Attenuation4: ATDA4 (unit: dB)
Public property | DACAttenuation5ATDA5 | DAC Attenuation5: ATDA5 (unit: dB)
Public property | DACAttenuation6ATDA6 | DAC Attenuation6: ATDA6 (unit: dB)
Public property | DACAttenuation7ATDA7 | DAC Attenuation7: ATDA7 (unit: dB)
Public property | DACAttenuation8ATDA8 | DAC Attenuation8: ATDA8 (unit: dB)
Public property | DACAttenuationControlATMDDA | DAC Attenuation Control: ATMDDA
Public property | DACAttenuationControlATSPDA | DAC Attenuation Control: ATSPDA
Public property | DACAttenuationControlAZRO | DAC Attenuation Control: AZRO
Public property | DACAttenuationControlDEMP | DAC Attenuation Control: DEMP
Public property | DACAttenuationControlZREV | DAC Attenuation Control: ZREV
Public property | DACModeControlMRST | DAC Mode Control: MRST
Public property | DACModeControlSRDA | DAC Mode Control: SRDA
Public property | DACModeControlSRST | DAC Mode Control: SRST
Public property | DACModeSelectFMTDA | DAC Mode Select: FMTDA
Public property | DACModeSelectMSDA | DAC Mode Select: MSDA
Public property | DACModeSelectPSMDA | DAC Mode Select: PSMDA
Public property | DACMuteMUTDA1 | DAC Mute: MUTDA1
Public property | DACMuteMUTDA2 | DAC Mute: MUTDA2
Public property | DACMuteMUTDA3 | DAC Mute: MUTDA3
Public property | DACMuteMUTDA4 | DAC Mute: MUTDA4
Public property | DACMuteMUTDA5 | DAC Mute: MUTDA5
Public property | DACMuteMUTDA6 | DAC Mute: MUTDA6
Public property | DACMuteMUTDA7 | DAC Mute: MUTDA7
Public property | DACMuteMUTDA8 | DAC Mute: MUTDA8
Public property | DACOperarionOPEDA1 | DAC Operarion: OPEDA1
Public property | DACOperationFLT0 | DAC Operation: FLT0
Public property | DACOperationFLT1 | DAC Operation: FLT1
Public property | DACOperationFLT2 | DAC Operation: FLT2
Public property | DACOperationFLT3 | DAC Operation: FLT3
Public property | DACOperationOPEDA0 | DAC Operation: OPEDA0
Public property | DACOperationOPEDA2 | DAC Operation: OPEDA2
Public property | DACOperationOPEDA3 | DAC Operation: OPEDA3
Public property | DACPhaseREVDA1 | DAC Phase: REVDA1
Public property | DACPhaseREVDA2 | DAC Phase: REVDA2
Public property | DACPhaseREVDA3 | DAC Phase: REVDA3
Public property | DACPhaseREVDA4 | DAC Phase: REVDA4
Public property | DACPhaseREVDA5 | DAC Phase: REVDA5
Public property | DACPhaseREVDA6 | DAC Phase: REVDA6
Public property | DACPhaseREVDA7 | DAC Phase: REVDA7
Public property | DACPhaseREVDA8 | DAC Phase: REVDA8
Public property | DACZeroFlagZERO1 | DAC Zero Flag: ZERO1
Public property | DACZeroFlagZERO2 | DAC Zero Flag: ZERO2
Public property | DACZeroFlagZERO3 | DAC Zero Flag: ZERO3
Public property | DACZeroFlagZERO4 | DAC Zero Flag: ZERO4
Public property | DACZeroFlagZERO5 | DAC Zero Flag: ZERO5
Public property | DACZeroFlagZERO6 | DAC Zero Flag: ZERO6
Public property | DACZeroFlagZERO7 | DAC Zero Flag: ZERO7
Public property | DACZeroFlagZERO8 | DAC Zero Flag: ZERO8
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
24-Bit, 96-kHz/192-kHz, 6-In/8-Out Audio Codec With Differential Input/Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168a(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Pcm3168a(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Pcm3168a

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a Properties

The Pcm3168a type exposes the following members.

Properties
 | Name | Description
Public property | ADCAttenuation0ATAD0 | ADC Attenuation0: ATAD0 (unit: dB)
Public property | ADCAttenuation1ATAD1 | ADC Attenuation1: ATAD1 (unit: dB)
Public property | ADCAttenuation2ATAD2 | ADC Attenuation2: ATAD2 (unit: dB)
Public property | ADCAttenuation3ATAD3 | ADC Attenuation3: ATAD3 (unit: dB)
Public property | ADCAttenuation4ATAD4 | ADC Attenuation4: ATAD4 (unit: dB)
Public property | ADCAttenuation5ATAD5 | ADC Attenuation5: ATAD5 (unit: dB)
Public property | ADCAttenuation6ATAD6 | ADC Attenuation6: ATAD6 (unit: dB)
Public property | ADCAttenuationControlATMDAD | ADC Attenuation Control: ATMDAD
Public property | ADCAttenuationControlATSPAD | ADC Attenuation Control: ATSPAD
Public property | ADCAttenuationControlOVFP | ADC Attenuation Control: OVFP
Public property | ADCConfigControlSEAD1 | ADC Config Control: SEAD1
Public property | ADCConfigControlSEAD2 | ADC Config Control: SEAD2
Public property | ADCConfigControlSEAD3 | ADC Config Control: SEAD3
Public property | ADCConfigControlSEAD4 | ADC Config Control: SEAD4
Public property | ADCConfigControlSEAD5 | ADC Config Control: SEAD5
Public property | ADCConfigControlSEAD6 | ADC Config Control: SEAD6
Public property | ADCModeControlSRAD | ADC Mode Control: SRAD
Public property | ADCModeSelectFMTAD | ADC Mode Select: FMTAD
Public property | ADCModeSelectMSAD | ADC Mode Select: MSAD
Public property | ADCMuteMUTAD1 | ADC Mute: MUTAD1
Public property | ADCMuteMUTAD2 | ADC Mute: MUTAD2
Public property | ADCMuteMUTAD3 | ADC Mute: MUTAD3
Public property | ADCMuteMUTAD4 | ADC Mute: MUTAD4
Public property | ADCMuteMUTAD5 | ADC Mute: MUTAD5
Public property | ADCMuteMUTAD6 | ADC Mute: MUTAD6
Public property | ADCOverflowOVF1 | ADC Overflow: OVF1
Public property | ADCOverflowOVF2 | ADC Overflow: OVF2
Public property | ADCOverflowOVF3 | ADC Overflow: OVF3
Public property | ADCOverflowOVF4 | ADC Overflow: OVF4
Public property | ADCOverflowOVF5 | ADC Overflow: OVF5
Public property | ADCOverflowOVF6 | ADC Overflow: OVF6
Public property | ADCPhaseREVAD1 | ADC Phase: REVAD1
Public property | ADCPhaseREVAD2 | ADC Phase: REVAD2
Public property | ADCPhaseREVAD3 | ADC Phase: REVAD3
Public property | ADCPhaseREVAD4 | ADC Phase: REVAD4
Public property | ADCPhaseREVAD5 | ADC Phase: REVAD5
Public property | ADCPhaseREVAD6 | ADC Phase: REVAD6
Public property | ADCPowerControlBYP0 | ADC Power Control: BYP0
Public property | ADCPowerControlBYP1 | ADC Power Control: BYP1
Public property | ADCPowerControlBYP2 | ADC Power Control: BYP2
Public property | ADCPowerControlPSVAD0 | ADC Power Control: PSVAD0
Public property | ADCPowerControlPSVAD1 | ADC Power Control: PSVAD1
Public property | ADCPowerControlPSVAD2 | ADC Power Control: PSVAD2
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | DACAttenuation0ATDA0 | DAC Attenuation0: ATDA0 (unit: dB)
Public property | DACAttenuation1ATDA1 | DAC Attenuation1: ATDA1 (unit: dB)
Public property | DACAttenuation2ATDA2 | DAC Attenuation2: ATDA2 (unit: dB)
Public property | DACAttenuation3ATDA3 | DAC Attenuation3: ATDA3 (unit: dB)
Public property | DACAttenuation4ATDA4 | DAC Attenuation4: ATDA4 (unit: dB)
Public property | DACAttenuation5ATDA5 | DAC Attenuation5: ATDA5 (unit: dB)
Public property | DACAttenuation6ATDA6 | DAC Attenuation6: ATDA6 (unit: dB)
Public property | DACAttenuation7ATDA7 | DAC Attenuation7: ATDA7 (unit: dB)
Public property | DACAttenuation8ATDA8 | DAC Attenuation8: ATDA8 (unit: dB)
Public property | DACAttenuationControlATMDDA | DAC Attenuation Control: ATMDDA
Public property | DACAttenuationControlATSPDA | DAC Attenuation Control: ATSPDA
Public property | DACAttenuationControlAZRO | DAC Attenuation Control: AZRO
Public property | DACAttenuationControlDEMP | DAC Attenuation Control: DEMP
Public property | DACAttenuationControlZREV | DAC Attenuation Control: ZREV
Public property | DACModeControlMRST | DAC Mode Control: MRST
Public property | DACModeControlSRDA | DAC Mode Control: SRDA
Public property | DACModeControlSRST | DAC Mode Control: SRST
Public property | DACModeSelectFMTDA | DAC Mode Select: FMTDA
Public property | DACModeSelectMSDA | DAC Mode Select: MSDA
Public property | DACModeSelectPSMDA | DAC Mode Select: PSMDA
Public property | DACMuteMUTDA1 | DAC Mute: MUTDA1
Public property | DACMuteMUTDA2 | DAC Mute: MUTDA2
Public property | DACMuteMUTDA3 | DAC Mute: MUTDA3
Public property | DACMuteMUTDA4 | DAC Mute: MUTDA4
Public property | DACMuteMUTDA5 | DAC Mute: MUTDA5
Public property | DACMuteMUTDA6 | DAC Mute: MUTDA6
Public property | DACMuteMUTDA7 | DAC Mute: MUTDA7
Public property | DACMuteMUTDA8 | DAC Mute: MUTDA8
Public property | DACOperarionOPEDA1 | DAC Operarion: OPEDA1
Public property | DACOperationFLT0 | DAC Operation: FLT0
Public property | DACOperationFLT1 | DAC Operation: FLT1
Public property | DACOperationFLT2 | DAC Operation: FLT2
Public property | DACOperationFLT3 | DAC Operation: FLT3
Public property | DACOperationOPEDA0 | DAC Operation: OPEDA0
Public property | DACOperationOPEDA2 | DAC Operation: OPEDA2
Public property | DACOperationOPEDA3 | DAC Operation: OPEDA3
Public property | DACPhaseREVDA1 | DAC Phase: REVDA1
Public property | DACPhaseREVDA2 | DAC Phase: REVDA2
Public property | DACPhaseREVDA3 | DAC Phase: REVDA3
Public property | DACPhaseREVDA4 | DAC Phase: REVDA4
Public property | DACPhaseREVDA5 | DAC Phase: REVDA5
Public property | DACPhaseREVDA6 | DAC Phase: REVDA6
Public property | DACPhaseREVDA7 | DAC Phase: REVDA7
Public property | DACPhaseREVDA8 | DAC Phase: REVDA8
Public property | DACZeroFlagZERO1 | DAC Zero Flag: ZERO1
Public property | DACZeroFlagZERO2 | DAC Zero Flag: ZERO2
Public property | DACZeroFlagZERO3 | DAC Zero Flag: ZERO3
Public property | DACZeroFlagZERO4 | DAC Zero Flag: ZERO4
Public property | DACZeroFlagZERO5 | DAC Zero Flag: ZERO5
Public property | DACZeroFlagZERO6 | DAC Zero Flag: ZERO6
Public property | DACZeroFlagZERO7 | DAC Zero Flag: ZERO7
Public property | DACZeroFlagZERO8 | DAC Zero Flag: ZERO8
Top
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCAttenuation0ATAD0 Property

IRD

Pcm3168aADCAttenuation0ATAD0 Property

ADC Attenuation0: ATAD0 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcAttenuation ADCAttenuation0ATAD0 { get; set; }
Public Property ADCAttenuation0ATAD0 As Pcm3168aTypeAdcAttenuation
    Get
    Set
public:
property Pcm3168aTypeAdcAttenuation ADCAttenuation0ATAD0 {
    Pcm3168aTypeAdcAttenuation get ();
    void set (Pcm3168aTypeAdcAttenuation value);
}
member ADCAttenuation0ATAD0 : Pcm3168aTypeAdcAttenuation with get, set

Property Value

Type: Pcm3168aTypeAdcAttenuation
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCAttenuation1ATAD1 Property

IRD

Pcm3168aADCAttenuation1ATAD1 Property

ADC Attenuation1: ATAD1 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcAttenuation ADCAttenuation1ATAD1 { get; set; }
Public Property ADCAttenuation1ATAD1 As Pcm3168aTypeAdcAttenuation
    Get
    Set
public:
property Pcm3168aTypeAdcAttenuation ADCAttenuation1ATAD1 {
    Pcm3168aTypeAdcAttenuation get ();
    void set (Pcm3168aTypeAdcAttenuation value);
}
member ADCAttenuation1ATAD1 : Pcm3168aTypeAdcAttenuation with get, set

Property Value

Type: Pcm3168aTypeAdcAttenuation
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCAttenuation2ATAD2 Property

IRD

Pcm3168aADCAttenuation2ATAD2 Property

ADC Attenuation2: ATAD2 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcAttenuation ADCAttenuation2ATAD2 { get; set; }
Public Property ADCAttenuation2ATAD2 As Pcm3168aTypeAdcAttenuation
    Get
    Set
public:
property Pcm3168aTypeAdcAttenuation ADCAttenuation2ATAD2 {
    Pcm3168aTypeAdcAttenuation get ();
    void set (Pcm3168aTypeAdcAttenuation value);
}
member ADCAttenuation2ATAD2 : Pcm3168aTypeAdcAttenuation with get, set

Property Value

Type: Pcm3168aTypeAdcAttenuation
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCAttenuation3ATAD3 Property

IRD

Pcm3168aADCAttenuation3ATAD3 Property

ADC Attenuation3: ATAD3 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcAttenuation ADCAttenuation3ATAD3 { get; set; }
Public Property ADCAttenuation3ATAD3 As Pcm3168aTypeAdcAttenuation
    Get
    Set
public:
property Pcm3168aTypeAdcAttenuation ADCAttenuation3ATAD3 {
    Pcm3168aTypeAdcAttenuation get ();
    void set (Pcm3168aTypeAdcAttenuation value);
}
member ADCAttenuation3ATAD3 : Pcm3168aTypeAdcAttenuation with get, set

Property Value

Type: Pcm3168aTypeAdcAttenuation
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCAttenuation4ATAD4 Property

IRD

Pcm3168aADCAttenuation4ATAD4 Property

ADC Attenuation4: ATAD4 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcAttenuation ADCAttenuation4ATAD4 { get; set; }
Public Property ADCAttenuation4ATAD4 As Pcm3168aTypeAdcAttenuation
    Get
    Set
public:
property Pcm3168aTypeAdcAttenuation ADCAttenuation4ATAD4 {
    Pcm3168aTypeAdcAttenuation get ();
    void set (Pcm3168aTypeAdcAttenuation value);
}
member ADCAttenuation4ATAD4 : Pcm3168aTypeAdcAttenuation with get, set

Property Value

Type: Pcm3168aTypeAdcAttenuation
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCAttenuation5ATAD5 Property

IRD

Pcm3168aADCAttenuation5ATAD5 Property

ADC Attenuation5: ATAD5 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcAttenuation ADCAttenuation5ATAD5 { get; set; }
Public Property ADCAttenuation5ATAD5 As Pcm3168aTypeAdcAttenuation
    Get
    Set
public:
property Pcm3168aTypeAdcAttenuation ADCAttenuation5ATAD5 {
    Pcm3168aTypeAdcAttenuation get ();
    void set (Pcm3168aTypeAdcAttenuation value);
}
member ADCAttenuation5ATAD5 : Pcm3168aTypeAdcAttenuation with get, set

Property Value

Type: Pcm3168aTypeAdcAttenuation
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCAttenuation6ATAD6 Property

IRD

Pcm3168aADCAttenuation6ATAD6 Property

ADC Attenuation6: ATAD6 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcAttenuation ADCAttenuation6ATAD6 { get; set; }
Public Property ADCAttenuation6ATAD6 As Pcm3168aTypeAdcAttenuation
    Get
    Set
public:
property Pcm3168aTypeAdcAttenuation ADCAttenuation6ATAD6 {
    Pcm3168aTypeAdcAttenuation get ();
    void set (Pcm3168aTypeAdcAttenuation value);
}
member ADCAttenuation6ATAD6 : Pcm3168aTypeAdcAttenuation with get, set

Property Value

Type: Pcm3168aTypeAdcAttenuation
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCAttenuationControlATMDAD Property

IRD

Pcm3168aADCAttenuationControlATMDAD Property

ADC Attenuation Control: ATMDAD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcAttenuationControlMode ADCAttenuationControlATMDAD { get; set; }
Public Property ADCAttenuationControlATMDAD As Pcm3168aTypeAdcAttenuationControlMode
    Get
    Set
public:
property Pcm3168aTypeAdcAttenuationControlMode ADCAttenuationControlATMDAD {
    Pcm3168aTypeAdcAttenuationControlMode get ();
    void set (Pcm3168aTypeAdcAttenuationControlMode value);
}
member ADCAttenuationControlATMDAD : Pcm3168aTypeAdcAttenuationControlMode with get, set

Property Value

Type: Pcm3168aTypeAdcAttenuationControlMode
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCAttenuationControlATSPAD Property

IRD

Pcm3168aADCAttenuationControlATSPAD Property

ADC Attenuation Control: ATSPAD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcAttenuationControlSpeed ADCAttenuationControlATSPAD { get; set; }
Public Property ADCAttenuationControlATSPAD As Pcm3168aTypeAdcAttenuationControlSpeed
    Get
    Set
public:
property Pcm3168aTypeAdcAttenuationControlSpeed ADCAttenuationControlATSPAD {
    Pcm3168aTypeAdcAttenuationControlSpeed get ();
    void set (Pcm3168aTypeAdcAttenuationControlSpeed value);
}
member ADCAttenuationControlATSPAD : Pcm3168aTypeAdcAttenuationControlSpeed with get, set

Property Value

Type: Pcm3168aTypeAdcAttenuationControlSpeed
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCAttenuationControlOVFP Property

IRD

Pcm3168aADCAttenuationControlOVFP Property

ADC Attenuation Control: OVFP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcAttenuationControlOver ADCAttenuationControlOVFP { get; set; }
Public Property ADCAttenuationControlOVFP As Pcm3168aTypeAdcAttenuationControlOver
    Get
    Set
public:
property Pcm3168aTypeAdcAttenuationControlOver ADCAttenuationControlOVFP {
    Pcm3168aTypeAdcAttenuationControlOver get ();
    void set (Pcm3168aTypeAdcAttenuationControlOver value);
}
member ADCAttenuationControlOVFP : Pcm3168aTypeAdcAttenuationControlOver with get, set

Property Value

Type: Pcm3168aTypeAdcAttenuationControlOver
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCConfigControlSEAD1 Property

IRD

Pcm3168aADCConfigControlSEAD1 Property

ADC Config Control: SEAD1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcConfigControlInp1 ADCConfigControlSEAD1 { get; set; }
Public Property ADCConfigControlSEAD1 As Pcm3168aTypeAdcConfigControlInp1
    Get
    Set
public:
property Pcm3168aTypeAdcConfigControlInp1 ADCConfigControlSEAD1 {
    Pcm3168aTypeAdcConfigControlInp1 get ();
    void set (Pcm3168aTypeAdcConfigControlInp1 value);
}
member ADCConfigControlSEAD1 : Pcm3168aTypeAdcConfigControlInp1 with get, set

Property Value

Type: Pcm3168aTypeAdcConfigControlInp1
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCConfigControlSEAD2 Property

IRD

Pcm3168aADCConfigControlSEAD2 Property

ADC Config Control: SEAD2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcConfigControlInp2 ADCConfigControlSEAD2 { get; set; }
Public Property ADCConfigControlSEAD2 As Pcm3168aTypeAdcConfigControlInp2
    Get
    Set
public:
property Pcm3168aTypeAdcConfigControlInp2 ADCConfigControlSEAD2 {
    Pcm3168aTypeAdcConfigControlInp2 get ();
    void set (Pcm3168aTypeAdcConfigControlInp2 value);
}
member ADCConfigControlSEAD2 : Pcm3168aTypeAdcConfigControlInp2 with get, set

Property Value

Type: Pcm3168aTypeAdcConfigControlInp2
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCConfigControlSEAD3 Property

IRD

Pcm3168aADCConfigControlSEAD3 Property

ADC Config Control: SEAD3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcConfigControlInp3 ADCConfigControlSEAD3 { get; set; }
Public Property ADCConfigControlSEAD3 As Pcm3168aTypeAdcConfigControlInp3
    Get
    Set
public:
property Pcm3168aTypeAdcConfigControlInp3 ADCConfigControlSEAD3 {
    Pcm3168aTypeAdcConfigControlInp3 get ();
    void set (Pcm3168aTypeAdcConfigControlInp3 value);
}
member ADCConfigControlSEAD3 : Pcm3168aTypeAdcConfigControlInp3 with get, set

Property Value

Type: Pcm3168aTypeAdcConfigControlInp3
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCConfigControlSEAD4 Property

IRD

Pcm3168aADCConfigControlSEAD4 Property

ADC Config Control: SEAD4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcConfigControlInp4 ADCConfigControlSEAD4 { get; set; }
Public Property ADCConfigControlSEAD4 As Pcm3168aTypeAdcConfigControlInp4
    Get
    Set
public:
property Pcm3168aTypeAdcConfigControlInp4 ADCConfigControlSEAD4 {
    Pcm3168aTypeAdcConfigControlInp4 get ();
    void set (Pcm3168aTypeAdcConfigControlInp4 value);
}
member ADCConfigControlSEAD4 : Pcm3168aTypeAdcConfigControlInp4 with get, set

Property Value

Type: Pcm3168aTypeAdcConfigControlInp4
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCConfigControlSEAD5 Property

IRD

Pcm3168aADCConfigControlSEAD5 Property

ADC Config Control: SEAD5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcConfigControlInp5 ADCConfigControlSEAD5 { get; set; }
Public Property ADCConfigControlSEAD5 As Pcm3168aTypeAdcConfigControlInp5
    Get
    Set
public:
property Pcm3168aTypeAdcConfigControlInp5 ADCConfigControlSEAD5 {
    Pcm3168aTypeAdcConfigControlInp5 get ();
    void set (Pcm3168aTypeAdcConfigControlInp5 value);
}
member ADCConfigControlSEAD5 : Pcm3168aTypeAdcConfigControlInp5 with get, set

Property Value

Type: Pcm3168aTypeAdcConfigControlInp5
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCConfigControlSEAD6 Property

IRD

Pcm3168aADCConfigControlSEAD6 Property

ADC Config Control: SEAD6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcConfigControlInp6 ADCConfigControlSEAD6 { get; set; }
Public Property ADCConfigControlSEAD6 As Pcm3168aTypeAdcConfigControlInp6
    Get
    Set
public:
property Pcm3168aTypeAdcConfigControlInp6 ADCConfigControlSEAD6 {
    Pcm3168aTypeAdcConfigControlInp6 get ();
    void set (Pcm3168aTypeAdcConfigControlInp6 value);
}
member ADCConfigControlSEAD6 : Pcm3168aTypeAdcConfigControlInp6 with get, set

Property Value

Type: Pcm3168aTypeAdcConfigControlInp6
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCModeControlSRAD Property

IRD

Pcm3168aADCModeControlSRAD Property

ADC Mode Control: SRAD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcModeControlSampling ADCModeControlSRAD { get; set; }
Public Property ADCModeControlSRAD As Pcm3168aTypeAdcModeControlSampling
    Get
    Set
public:
property Pcm3168aTypeAdcModeControlSampling ADCModeControlSRAD {
    Pcm3168aTypeAdcModeControlSampling get ();
    void set (Pcm3168aTypeAdcModeControlSampling value);
}
member ADCModeControlSRAD : Pcm3168aTypeAdcModeControlSampling with get, set

Property Value

Type: Pcm3168aTypeAdcModeControlSampling
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCModeSelectFMTAD Property

IRD

Pcm3168aADCModeSelectFMTAD Property

ADC Mode Select: FMTAD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcModeSelectFormat ADCModeSelectFMTAD { get; set; }
Public Property ADCModeSelectFMTAD As Pcm3168aTypeAdcModeSelectFormat
    Get
    Set
public:
property Pcm3168aTypeAdcModeSelectFormat ADCModeSelectFMTAD {
    Pcm3168aTypeAdcModeSelectFormat get ();
    void set (Pcm3168aTypeAdcModeSelectFormat value);
}
member ADCModeSelectFMTAD : Pcm3168aTypeAdcModeSelectFormat with get, set

Property Value

Type: Pcm3168aTypeAdcModeSelectFormat
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCModeSelectMSAD Property

IRD

Pcm3168aADCModeSelectMSAD Property

ADC Mode Select: MSAD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcModeSelectMs ADCModeSelectMSAD { get; set; }
Public Property ADCModeSelectMSAD As Pcm3168aTypeAdcModeSelectMs
    Get
    Set
public:
property Pcm3168aTypeAdcModeSelectMs ADCModeSelectMSAD {
    Pcm3168aTypeAdcModeSelectMs get ();
    void set (Pcm3168aTypeAdcModeSelectMs value);
}
member ADCModeSelectMSAD : Pcm3168aTypeAdcModeSelectMs with get, set

Property Value

Type: Pcm3168aTypeAdcModeSelectMs
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCMuteMUTAD1 Property

IRD

Pcm3168aADCMuteMUTAD1 Property

ADC Mute: MUTAD1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcMuteAdc1 ADCMuteMUTAD1 { get; set; }
Public Property ADCMuteMUTAD1 As Pcm3168aTypeAdcMuteAdc1
    Get
    Set
public:
property Pcm3168aTypeAdcMuteAdc1 ADCMuteMUTAD1 {
    Pcm3168aTypeAdcMuteAdc1 get ();
    void set (Pcm3168aTypeAdcMuteAdc1 value);
}
member ADCMuteMUTAD1 : Pcm3168aTypeAdcMuteAdc1 with get, set

Property Value

Type: Pcm3168aTypeAdcMuteAdc1
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCMuteMUTAD2 Property

IRD

Pcm3168aADCMuteMUTAD2 Property

ADC Mute: MUTAD2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcMuteAdc2 ADCMuteMUTAD2 { get; set; }
Public Property ADCMuteMUTAD2 As Pcm3168aTypeAdcMuteAdc2
    Get
    Set
public:
property Pcm3168aTypeAdcMuteAdc2 ADCMuteMUTAD2 {
    Pcm3168aTypeAdcMuteAdc2 get ();
    void set (Pcm3168aTypeAdcMuteAdc2 value);
}
member ADCMuteMUTAD2 : Pcm3168aTypeAdcMuteAdc2 with get, set

Property Value

Type: Pcm3168aTypeAdcMuteAdc2
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCMuteMUTAD3 Property

IRD

Pcm3168aADCMuteMUTAD3 Property

ADC Mute: MUTAD3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcMuteAdc3 ADCMuteMUTAD3 { get; set; }
Public Property ADCMuteMUTAD3 As Pcm3168aTypeAdcMuteAdc3
    Get
    Set
public:
property Pcm3168aTypeAdcMuteAdc3 ADCMuteMUTAD3 {
    Pcm3168aTypeAdcMuteAdc3 get ();
    void set (Pcm3168aTypeAdcMuteAdc3 value);
}
member ADCMuteMUTAD3 : Pcm3168aTypeAdcMuteAdc3 with get, set

Property Value

Type: Pcm3168aTypeAdcMuteAdc3
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCMuteMUTAD4 Property

IRD

Pcm3168aADCMuteMUTAD4 Property

ADC Mute: MUTAD4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcMuteAdc4 ADCMuteMUTAD4 { get; set; }
Public Property ADCMuteMUTAD4 As Pcm3168aTypeAdcMuteAdc4
    Get
    Set
public:
property Pcm3168aTypeAdcMuteAdc4 ADCMuteMUTAD4 {
    Pcm3168aTypeAdcMuteAdc4 get ();
    void set (Pcm3168aTypeAdcMuteAdc4 value);
}
member ADCMuteMUTAD4 : Pcm3168aTypeAdcMuteAdc4 with get, set

Property Value

Type: Pcm3168aTypeAdcMuteAdc4
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCMuteMUTAD5 Property

IRD

Pcm3168aADCMuteMUTAD5 Property

ADC Mute: MUTAD5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcMuteAdc5 ADCMuteMUTAD5 { get; set; }
Public Property ADCMuteMUTAD5 As Pcm3168aTypeAdcMuteAdc5
    Get
    Set
public:
property Pcm3168aTypeAdcMuteAdc5 ADCMuteMUTAD5 {
    Pcm3168aTypeAdcMuteAdc5 get ();
    void set (Pcm3168aTypeAdcMuteAdc5 value);
}
member ADCMuteMUTAD5 : Pcm3168aTypeAdcMuteAdc5 with get, set

Property Value

Type: Pcm3168aTypeAdcMuteAdc5
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCMuteMUTAD6 Property

IRD

Pcm3168aADCMuteMUTAD6 Property

ADC Mute: MUTAD6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcMuteAdc6 ADCMuteMUTAD6 { get; set; }
Public Property ADCMuteMUTAD6 As Pcm3168aTypeAdcMuteAdc6
    Get
    Set
public:
property Pcm3168aTypeAdcMuteAdc6 ADCMuteMUTAD6 {
    Pcm3168aTypeAdcMuteAdc6 get ();
    void set (Pcm3168aTypeAdcMuteAdc6 value);
}
member ADCMuteMUTAD6 : Pcm3168aTypeAdcMuteAdc6 with get, set

Property Value

Type: Pcm3168aTypeAdcMuteAdc6
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCOverflowOVF1 Property

IRD

Pcm3168aADCOverflowOVF1 Property

ADC Overflow: OVF1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcOverflowAdc1 ADCOverflowOVF1 { get; }
Public ReadOnly Property ADCOverflowOVF1 As Pcm3168aTypeAdcOverflowAdc1
    Get
public:
property Pcm3168aTypeAdcOverflowAdc1 ADCOverflowOVF1 {
    Pcm3168aTypeAdcOverflowAdc1 get ();
}
member ADCOverflowOVF1 : Pcm3168aTypeAdcOverflowAdc1 with get

Property Value

Type: Pcm3168aTypeAdcOverflowAdc1
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCOverflowOVF2 Property

IRD

Pcm3168aADCOverflowOVF2 Property

ADC Overflow: OVF2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcOverflowAdc2 ADCOverflowOVF2 { get; }
Public ReadOnly Property ADCOverflowOVF2 As Pcm3168aTypeAdcOverflowAdc2
    Get
public:
property Pcm3168aTypeAdcOverflowAdc2 ADCOverflowOVF2 {
    Pcm3168aTypeAdcOverflowAdc2 get ();
}
member ADCOverflowOVF2 : Pcm3168aTypeAdcOverflowAdc2 with get

Property Value

Type: Pcm3168aTypeAdcOverflowAdc2
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCOverflowOVF3 Property

IRD

Pcm3168aADCOverflowOVF3 Property

ADC Overflow: OVF3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcOverflowAdc3 ADCOverflowOVF3 { get; }
Public ReadOnly Property ADCOverflowOVF3 As Pcm3168aTypeAdcOverflowAdc3
    Get
public:
property Pcm3168aTypeAdcOverflowAdc3 ADCOverflowOVF3 {
    Pcm3168aTypeAdcOverflowAdc3 get ();
}
member ADCOverflowOVF3 : Pcm3168aTypeAdcOverflowAdc3 with get

Property Value

Type: Pcm3168aTypeAdcOverflowAdc3
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCOverflowOVF4 Property

IRD

Pcm3168aADCOverflowOVF4 Property

ADC Overflow: OVF4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcOverflowAdc4 ADCOverflowOVF4 { get; }
Public ReadOnly Property ADCOverflowOVF4 As Pcm3168aTypeAdcOverflowAdc4
    Get
public:
property Pcm3168aTypeAdcOverflowAdc4 ADCOverflowOVF4 {
    Pcm3168aTypeAdcOverflowAdc4 get ();
}
member ADCOverflowOVF4 : Pcm3168aTypeAdcOverflowAdc4 with get

Property Value

Type: Pcm3168aTypeAdcOverflowAdc4
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCOverflowOVF5 Property

IRD

Pcm3168aADCOverflowOVF5 Property

ADC Overflow: OVF5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcOverflowAdc5 ADCOverflowOVF5 { get; }
Public ReadOnly Property ADCOverflowOVF5 As Pcm3168aTypeAdcOverflowAdc5
    Get
public:
property Pcm3168aTypeAdcOverflowAdc5 ADCOverflowOVF5 {
    Pcm3168aTypeAdcOverflowAdc5 get ();
}
member ADCOverflowOVF5 : Pcm3168aTypeAdcOverflowAdc5 with get

Property Value

Type: Pcm3168aTypeAdcOverflowAdc5
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCOverflowOVF6 Property

IRD

Pcm3168aADCOverflowOVF6 Property

ADC Overflow: OVF6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcOverflowAdc6 ADCOverflowOVF6 { get; }
Public ReadOnly Property ADCOverflowOVF6 As Pcm3168aTypeAdcOverflowAdc6
    Get
public:
property Pcm3168aTypeAdcOverflowAdc6 ADCOverflowOVF6 {
    Pcm3168aTypeAdcOverflowAdc6 get ();
}
member ADCOverflowOVF6 : Pcm3168aTypeAdcOverflowAdc6 with get

Property Value

Type: Pcm3168aTypeAdcOverflowAdc6
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCPhaseREVAD1 Property

IRD

Pcm3168aADCPhaseREVAD1 Property

ADC Phase: REVAD1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcPhaseAdc1 ADCPhaseREVAD1 { get; set; }
Public Property ADCPhaseREVAD1 As Pcm3168aTypeAdcPhaseAdc1
    Get
    Set
public:
property Pcm3168aTypeAdcPhaseAdc1 ADCPhaseREVAD1 {
    Pcm3168aTypeAdcPhaseAdc1 get ();
    void set (Pcm3168aTypeAdcPhaseAdc1 value);
}
member ADCPhaseREVAD1 : Pcm3168aTypeAdcPhaseAdc1 with get, set

Property Value

Type: Pcm3168aTypeAdcPhaseAdc1
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCPhaseREVAD2 Property

IRD

Pcm3168aADCPhaseREVAD2 Property

ADC Phase: REVAD2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcPhaseAdc2 ADCPhaseREVAD2 { get; set; }
Public Property ADCPhaseREVAD2 As Pcm3168aTypeAdcPhaseAdc2
    Get
    Set
public:
property Pcm3168aTypeAdcPhaseAdc2 ADCPhaseREVAD2 {
    Pcm3168aTypeAdcPhaseAdc2 get ();
    void set (Pcm3168aTypeAdcPhaseAdc2 value);
}
member ADCPhaseREVAD2 : Pcm3168aTypeAdcPhaseAdc2 with get, set

Property Value

Type: Pcm3168aTypeAdcPhaseAdc2
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCPhaseREVAD3 Property

IRD

Pcm3168aADCPhaseREVAD3 Property

ADC Phase: REVAD3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcPhaseAdc3 ADCPhaseREVAD3 { get; set; }
Public Property ADCPhaseREVAD3 As Pcm3168aTypeAdcPhaseAdc3
    Get
    Set
public:
property Pcm3168aTypeAdcPhaseAdc3 ADCPhaseREVAD3 {
    Pcm3168aTypeAdcPhaseAdc3 get ();
    void set (Pcm3168aTypeAdcPhaseAdc3 value);
}
member ADCPhaseREVAD3 : Pcm3168aTypeAdcPhaseAdc3 with get, set

Property Value

Type: Pcm3168aTypeAdcPhaseAdc3
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCPhaseREVAD4 Property

IRD

Pcm3168aADCPhaseREVAD4 Property

ADC Phase: REVAD4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcPhaseAdc4 ADCPhaseREVAD4 { get; set; }
Public Property ADCPhaseREVAD4 As Pcm3168aTypeAdcPhaseAdc4
    Get
    Set
public:
property Pcm3168aTypeAdcPhaseAdc4 ADCPhaseREVAD4 {
    Pcm3168aTypeAdcPhaseAdc4 get ();
    void set (Pcm3168aTypeAdcPhaseAdc4 value);
}
member ADCPhaseREVAD4 : Pcm3168aTypeAdcPhaseAdc4 with get, set

Property Value

Type: Pcm3168aTypeAdcPhaseAdc4
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCPhaseREVAD5 Property

IRD

Pcm3168aADCPhaseREVAD5 Property

ADC Phase: REVAD5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcPhaseAdc5 ADCPhaseREVAD5 { get; set; }
Public Property ADCPhaseREVAD5 As Pcm3168aTypeAdcPhaseAdc5
    Get
    Set
public:
property Pcm3168aTypeAdcPhaseAdc5 ADCPhaseREVAD5 {
    Pcm3168aTypeAdcPhaseAdc5 get ();
    void set (Pcm3168aTypeAdcPhaseAdc5 value);
}
member ADCPhaseREVAD5 : Pcm3168aTypeAdcPhaseAdc5 with get, set

Property Value

Type: Pcm3168aTypeAdcPhaseAdc5
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCPhaseREVAD6 Property

IRD

Pcm3168aADCPhaseREVAD6 Property

ADC Phase: REVAD6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcPhaseAdc6 ADCPhaseREVAD6 { get; set; }
Public Property ADCPhaseREVAD6 As Pcm3168aTypeAdcPhaseAdc6
    Get
    Set
public:
property Pcm3168aTypeAdcPhaseAdc6 ADCPhaseREVAD6 {
    Pcm3168aTypeAdcPhaseAdc6 get ();
    void set (Pcm3168aTypeAdcPhaseAdc6 value);
}
member ADCPhaseREVAD6 : Pcm3168aTypeAdcPhaseAdc6 with get, set

Property Value

Type: Pcm3168aTypeAdcPhaseAdc6
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCPowerControlBYP0 Property

IRD

Pcm3168aADCPowerControlBYP0 Property

ADC Power Control: BYP0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcPowerControlByp12 ADCPowerControlBYP0 { get; set; }
Public Property ADCPowerControlBYP0 As Pcm3168aTypeAdcPowerControlByp12
    Get
    Set
public:
property Pcm3168aTypeAdcPowerControlByp12 ADCPowerControlBYP0 {
    Pcm3168aTypeAdcPowerControlByp12 get ();
    void set (Pcm3168aTypeAdcPowerControlByp12 value);
}
member ADCPowerControlBYP0 : Pcm3168aTypeAdcPowerControlByp12 with get, set

Property Value

Type: Pcm3168aTypeAdcPowerControlByp12
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCPowerControlBYP1 Property

IRD

Pcm3168aADCPowerControlBYP1 Property

ADC Power Control: BYP1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcPowerControlByp34 ADCPowerControlBYP1 { get; set; }
Public Property ADCPowerControlBYP1 As Pcm3168aTypeAdcPowerControlByp34
    Get
    Set
public:
property Pcm3168aTypeAdcPowerControlByp34 ADCPowerControlBYP1 {
    Pcm3168aTypeAdcPowerControlByp34 get ();
    void set (Pcm3168aTypeAdcPowerControlByp34 value);
}
member ADCPowerControlBYP1 : Pcm3168aTypeAdcPowerControlByp34 with get, set

Property Value

Type: Pcm3168aTypeAdcPowerControlByp34
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCPowerControlBYP2 Property

IRD

Pcm3168aADCPowerControlBYP2 Property

ADC Power Control: BYP2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcPowerControlByp56 ADCPowerControlBYP2 { get; set; }
Public Property ADCPowerControlBYP2 As Pcm3168aTypeAdcPowerControlByp56
    Get
    Set
public:
property Pcm3168aTypeAdcPowerControlByp56 ADCPowerControlBYP2 {
    Pcm3168aTypeAdcPowerControlByp56 get ();
    void set (Pcm3168aTypeAdcPowerControlByp56 value);
}
member ADCPowerControlBYP2 : Pcm3168aTypeAdcPowerControlByp56 with get, set

Property Value

Type: Pcm3168aTypeAdcPowerControlByp56
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCPowerControlPSVAD0 Property

IRD

Pcm3168aADCPowerControlPSVAD0 Property

ADC Power Control: PSVAD0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcPowerControlPow12 ADCPowerControlPSVAD0 { get; set; }
Public Property ADCPowerControlPSVAD0 As Pcm3168aTypeAdcPowerControlPow12
    Get
    Set
public:
property Pcm3168aTypeAdcPowerControlPow12 ADCPowerControlPSVAD0 {
    Pcm3168aTypeAdcPowerControlPow12 get ();
    void set (Pcm3168aTypeAdcPowerControlPow12 value);
}
member ADCPowerControlPSVAD0 : Pcm3168aTypeAdcPowerControlPow12 with get, set

Property Value

Type: Pcm3168aTypeAdcPowerControlPow12
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCPowerControlPSVAD1 Property

IRD

Pcm3168aADCPowerControlPSVAD1 Property

ADC Power Control: PSVAD1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcPowerControlPow34 ADCPowerControlPSVAD1 { get; set; }
Public Property ADCPowerControlPSVAD1 As Pcm3168aTypeAdcPowerControlPow34
    Get
    Set
public:
property Pcm3168aTypeAdcPowerControlPow34 ADCPowerControlPSVAD1 {
    Pcm3168aTypeAdcPowerControlPow34 get ();
    void set (Pcm3168aTypeAdcPowerControlPow34 value);
}
member ADCPowerControlPSVAD1 : Pcm3168aTypeAdcPowerControlPow34 with get, set

Property Value

Type: Pcm3168aTypeAdcPowerControlPow34
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.ADCPowerControlPSVAD2 Property

IRD

Pcm3168aADCPowerControlPSVAD2 Property

ADC Power Control: PSVAD2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeAdcPowerControlPow56 ADCPowerControlPSVAD2 { get; set; }
Public Property ADCPowerControlPSVAD2 As Pcm3168aTypeAdcPowerControlPow56
    Get
    Set
public:
property Pcm3168aTypeAdcPowerControlPow56 ADCPowerControlPSVAD2 {
    Pcm3168aTypeAdcPowerControlPow56 get ();
    void set (Pcm3168aTypeAdcPowerControlPow56 value);
}
member ADCPowerControlPSVAD2 : Pcm3168aTypeAdcPowerControlPow56 with get, set

Property Value

Type: Pcm3168aTypeAdcPowerControlPow56
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.AutoFlush Property

IRD

Pcm3168aAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACAttenuation0ATDA0 Property

IRD

Pcm3168aDACAttenuation0ATDA0 Property

DAC Attenuation0: ATDA0 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacAttenuation DACAttenuation0ATDA0 { get; set; }
Public Property DACAttenuation0ATDA0 As Pcm3168aTypeDacAttenuation
    Get
    Set
public:
property Pcm3168aTypeDacAttenuation DACAttenuation0ATDA0 {
    Pcm3168aTypeDacAttenuation get ();
    void set (Pcm3168aTypeDacAttenuation value);
}
member DACAttenuation0ATDA0 : Pcm3168aTypeDacAttenuation with get, set

Property Value

Type: Pcm3168aTypeDacAttenuation
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACAttenuation1ATDA1 Property

IRD

Pcm3168aDACAttenuation1ATDA1 Property

DAC Attenuation1: ATDA1 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacAttenuation DACAttenuation1ATDA1 { get; set; }
Public Property DACAttenuation1ATDA1 As Pcm3168aTypeDacAttenuation
    Get
    Set
public:
property Pcm3168aTypeDacAttenuation DACAttenuation1ATDA1 {
    Pcm3168aTypeDacAttenuation get ();
    void set (Pcm3168aTypeDacAttenuation value);
}
member DACAttenuation1ATDA1 : Pcm3168aTypeDacAttenuation with get, set

Property Value

Type: Pcm3168aTypeDacAttenuation
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACAttenuation2ATDA2 Property

IRD

Pcm3168aDACAttenuation2ATDA2 Property

DAC Attenuation2: ATDA2 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacAttenuation DACAttenuation2ATDA2 { get; set; }
Public Property DACAttenuation2ATDA2 As Pcm3168aTypeDacAttenuation
    Get
    Set
public:
property Pcm3168aTypeDacAttenuation DACAttenuation2ATDA2 {
    Pcm3168aTypeDacAttenuation get ();
    void set (Pcm3168aTypeDacAttenuation value);
}
member DACAttenuation2ATDA2 : Pcm3168aTypeDacAttenuation with get, set

Property Value

Type: Pcm3168aTypeDacAttenuation
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACAttenuation3ATDA3 Property

IRD

Pcm3168aDACAttenuation3ATDA3 Property

DAC Attenuation3: ATDA3 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacAttenuation DACAttenuation3ATDA3 { get; set; }
Public Property DACAttenuation3ATDA3 As Pcm3168aTypeDacAttenuation
    Get
    Set
public:
property Pcm3168aTypeDacAttenuation DACAttenuation3ATDA3 {
    Pcm3168aTypeDacAttenuation get ();
    void set (Pcm3168aTypeDacAttenuation value);
}
member DACAttenuation3ATDA3 : Pcm3168aTypeDacAttenuation with get, set

Property Value

Type: Pcm3168aTypeDacAttenuation
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACAttenuation4ATDA4 Property

IRD

Pcm3168aDACAttenuation4ATDA4 Property

DAC Attenuation4: ATDA4 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacAttenuation DACAttenuation4ATDA4 { get; set; }
Public Property DACAttenuation4ATDA4 As Pcm3168aTypeDacAttenuation
    Get
    Set
public:
property Pcm3168aTypeDacAttenuation DACAttenuation4ATDA4 {
    Pcm3168aTypeDacAttenuation get ();
    void set (Pcm3168aTypeDacAttenuation value);
}
member DACAttenuation4ATDA4 : Pcm3168aTypeDacAttenuation with get, set

Property Value

Type: Pcm3168aTypeDacAttenuation
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACAttenuation5ATDA5 Property

IRD

Pcm3168aDACAttenuation5ATDA5 Property

DAC Attenuation5: ATDA5 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacAttenuation DACAttenuation5ATDA5 { get; set; }
Public Property DACAttenuation5ATDA5 As Pcm3168aTypeDacAttenuation
    Get
    Set
public:
property Pcm3168aTypeDacAttenuation DACAttenuation5ATDA5 {
    Pcm3168aTypeDacAttenuation get ();
    void set (Pcm3168aTypeDacAttenuation value);
}
member DACAttenuation5ATDA5 : Pcm3168aTypeDacAttenuation with get, set

Property Value

Type: Pcm3168aTypeDacAttenuation
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACAttenuation6ATDA6 Property

IRD

Pcm3168aDACAttenuation6ATDA6 Property

DAC Attenuation6: ATDA6 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacAttenuation DACAttenuation6ATDA6 { get; set; }
Public Property DACAttenuation6ATDA6 As Pcm3168aTypeDacAttenuation
    Get
    Set
public:
property Pcm3168aTypeDacAttenuation DACAttenuation6ATDA6 {
    Pcm3168aTypeDacAttenuation get ();
    void set (Pcm3168aTypeDacAttenuation value);
}
member DACAttenuation6ATDA6 : Pcm3168aTypeDacAttenuation with get, set

Property Value

Type: Pcm3168aTypeDacAttenuation
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACAttenuation7ATDA7 Property

IRD

Pcm3168aDACAttenuation7ATDA7 Property

DAC Attenuation7: ATDA7 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacAttenuation DACAttenuation7ATDA7 { get; set; }
Public Property DACAttenuation7ATDA7 As Pcm3168aTypeDacAttenuation
    Get
    Set
public:
property Pcm3168aTypeDacAttenuation DACAttenuation7ATDA7 {
    Pcm3168aTypeDacAttenuation get ();
    void set (Pcm3168aTypeDacAttenuation value);
}
member DACAttenuation7ATDA7 : Pcm3168aTypeDacAttenuation with get, set

Property Value

Type: Pcm3168aTypeDacAttenuation
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACAttenuation8ATDA8 Property

IRD

Pcm3168aDACAttenuation8ATDA8 Property

DAC Attenuation8: ATDA8 (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacAttenuation DACAttenuation8ATDA8 { get; set; }
Public Property DACAttenuation8ATDA8 As Pcm3168aTypeDacAttenuation
    Get
    Set
public:
property Pcm3168aTypeDacAttenuation DACAttenuation8ATDA8 {
    Pcm3168aTypeDacAttenuation get ();
    void set (Pcm3168aTypeDacAttenuation value);
}
member DACAttenuation8ATDA8 : Pcm3168aTypeDacAttenuation with get, set

Property Value

Type: Pcm3168aTypeDacAttenuation
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACAttenuationControlATMDDA Property

IRD

Pcm3168aDACAttenuationControlATMDDA Property

DAC Attenuation Control: ATMDDA

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacAttenuationControlMode DACAttenuationControlATMDDA { get; set; }
Public Property DACAttenuationControlATMDDA As Pcm3168aTypeDacAttenuationControlMode
    Get
    Set
public:
property Pcm3168aTypeDacAttenuationControlMode DACAttenuationControlATMDDA {
    Pcm3168aTypeDacAttenuationControlMode get ();
    void set (Pcm3168aTypeDacAttenuationControlMode value);
}
member DACAttenuationControlATMDDA : Pcm3168aTypeDacAttenuationControlMode with get, set

Property Value

Type: Pcm3168aTypeDacAttenuationControlMode
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACAttenuationControlATSPDA Property

IRD

Pcm3168aDACAttenuationControlATSPDA Property

DAC Attenuation Control: ATSPDA

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacAttenuationControlSpeed DACAttenuationControlATSPDA { get; set; }
Public Property DACAttenuationControlATSPDA As Pcm3168aTypeDacAttenuationControlSpeed
    Get
    Set
public:
property Pcm3168aTypeDacAttenuationControlSpeed DACAttenuationControlATSPDA {
    Pcm3168aTypeDacAttenuationControlSpeed get ();
    void set (Pcm3168aTypeDacAttenuationControlSpeed value);
}
member DACAttenuationControlATSPDA : Pcm3168aTypeDacAttenuationControlSpeed with get, set

Property Value

Type: Pcm3168aTypeDacAttenuationControlSpeed
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACAttenuationControlAZRO Property

IRD

Pcm3168aDACAttenuationControlAZRO Property

DAC Attenuation Control: AZRO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacAttenuationControlZfunc DACAttenuationControlAZRO { get; set; }
Public Property DACAttenuationControlAZRO As Pcm3168aTypeDacAttenuationControlZfunc
    Get
    Set
public:
property Pcm3168aTypeDacAttenuationControlZfunc DACAttenuationControlAZRO {
    Pcm3168aTypeDacAttenuationControlZfunc get ();
    void set (Pcm3168aTypeDacAttenuationControlZfunc value);
}
member DACAttenuationControlAZRO : Pcm3168aTypeDacAttenuationControlZfunc with get, set

Property Value

Type: Pcm3168aTypeDacAttenuationControlZfunc
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACAttenuationControlDEMP Property

IRD

Pcm3168aDACAttenuationControlDEMP Property

DAC Attenuation Control: DEMP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacAttenuationControlDeemp DACAttenuationControlDEMP { get; set; }
Public Property DACAttenuationControlDEMP As Pcm3168aTypeDacAttenuationControlDeemp
    Get
    Set
public:
property Pcm3168aTypeDacAttenuationControlDeemp DACAttenuationControlDEMP {
    Pcm3168aTypeDacAttenuationControlDeemp get ();
    void set (Pcm3168aTypeDacAttenuationControlDeemp value);
}
member DACAttenuationControlDEMP : Pcm3168aTypeDacAttenuationControlDeemp with get, set

Property Value

Type: Pcm3168aTypeDacAttenuationControlDeemp
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACAttenuationControlZREV Property

IRD

Pcm3168aDACAttenuationControlZREV Property

DAC Attenuation Control: ZREV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacAttenuationControlZpol DACAttenuationControlZREV { get; set; }
Public Property DACAttenuationControlZREV As Pcm3168aTypeDacAttenuationControlZpol
    Get
    Set
public:
property Pcm3168aTypeDacAttenuationControlZpol DACAttenuationControlZREV {
    Pcm3168aTypeDacAttenuationControlZpol get ();
    void set (Pcm3168aTypeDacAttenuationControlZpol value);
}
member DACAttenuationControlZREV : Pcm3168aTypeDacAttenuationControlZpol with get, set

Property Value

Type: Pcm3168aTypeDacAttenuationControlZpol
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACModeControlMRST Property

IRD

Pcm3168aDACModeControlMRST Property

DAC Mode Control: MRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacModeControlRegReset DACModeControlMRST { get; set; }
Public Property DACModeControlMRST As Pcm3168aTypeDacModeControlRegReset
    Get
    Set
public:
property Pcm3168aTypeDacModeControlRegReset DACModeControlMRST {
    Pcm3168aTypeDacModeControlRegReset get ();
    void set (Pcm3168aTypeDacModeControlRegReset value);
}
member DACModeControlMRST : Pcm3168aTypeDacModeControlRegReset with get, set

Property Value

Type: Pcm3168aTypeDacModeControlRegReset
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACModeControlSRDA Property

IRD

Pcm3168aDACModeControlSRDA Property

DAC Mode Control: SRDA

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacModeControlSampling DACModeControlSRDA { get; set; }
Public Property DACModeControlSRDA As Pcm3168aTypeDacModeControlSampling
    Get
    Set
public:
property Pcm3168aTypeDacModeControlSampling DACModeControlSRDA {
    Pcm3168aTypeDacModeControlSampling get ();
    void set (Pcm3168aTypeDacModeControlSampling value);
}
member DACModeControlSRDA : Pcm3168aTypeDacModeControlSampling with get, set

Property Value

Type: Pcm3168aTypeDacModeControlSampling
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACModeControlSRST Property

IRD

Pcm3168aDACModeControlSRST Property

DAC Mode Control: SRST

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacModeControlSysReset DACModeControlSRST { get; set; }
Public Property DACModeControlSRST As Pcm3168aTypeDacModeControlSysReset
    Get
    Set
public:
property Pcm3168aTypeDacModeControlSysReset DACModeControlSRST {
    Pcm3168aTypeDacModeControlSysReset get ();
    void set (Pcm3168aTypeDacModeControlSysReset value);
}
member DACModeControlSRST : Pcm3168aTypeDacModeControlSysReset with get, set

Property Value

Type: Pcm3168aTypeDacModeControlSysReset
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACModeSelectFMTDA Property

IRD

Pcm3168aDACModeSelectFMTDA Property

DAC Mode Select: FMTDA

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacModeSelectFormat DACModeSelectFMTDA { get; set; }
Public Property DACModeSelectFMTDA As Pcm3168aTypeDacModeSelectFormat
    Get
    Set
public:
property Pcm3168aTypeDacModeSelectFormat DACModeSelectFMTDA {
    Pcm3168aTypeDacModeSelectFormat get ();
    void set (Pcm3168aTypeDacModeSelectFormat value);
}
member DACModeSelectFMTDA : Pcm3168aTypeDacModeSelectFormat with get, set

Property Value

Type: Pcm3168aTypeDacModeSelectFormat
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACModeSelectMSDA Property

IRD

Pcm3168aDACModeSelectMSDA Property

DAC Mode Select: MSDA

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacModeSelectMs DACModeSelectMSDA { get; set; }
Public Property DACModeSelectMSDA As Pcm3168aTypeDacModeSelectMs
    Get
    Set
public:
property Pcm3168aTypeDacModeSelectMs DACModeSelectMSDA {
    Pcm3168aTypeDacModeSelectMs get ();
    void set (Pcm3168aTypeDacModeSelectMs value);
}
member DACModeSelectMSDA : Pcm3168aTypeDacModeSelectMs with get, set

Property Value

Type: Pcm3168aTypeDacModeSelectMs
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACModeSelectPSMDA Property

IRD

Pcm3168aDACModeSelectPSMDA Property

DAC Mode Select: PSMDA

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacModeSelectPower DACModeSelectPSMDA { get; set; }
Public Property DACModeSelectPSMDA As Pcm3168aTypeDacModeSelectPower
    Get
    Set
public:
property Pcm3168aTypeDacModeSelectPower DACModeSelectPSMDA {
    Pcm3168aTypeDacModeSelectPower get ();
    void set (Pcm3168aTypeDacModeSelectPower value);
}
member DACModeSelectPSMDA : Pcm3168aTypeDacModeSelectPower with get, set

Property Value

Type: Pcm3168aTypeDacModeSelectPower
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACMuteMUTDA1 Property

IRD

Pcm3168aDACMuteMUTDA1 Property

DAC Mute: MUTDA1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacMuteDac1 DACMuteMUTDA1 { get; set; }
Public Property DACMuteMUTDA1 As Pcm3168aTypeDacMuteDac1
    Get
    Set
public:
property Pcm3168aTypeDacMuteDac1 DACMuteMUTDA1 {
    Pcm3168aTypeDacMuteDac1 get ();
    void set (Pcm3168aTypeDacMuteDac1 value);
}
member DACMuteMUTDA1 : Pcm3168aTypeDacMuteDac1 with get, set

Property Value

Type: Pcm3168aTypeDacMuteDac1
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACMuteMUTDA2 Property

IRD

Pcm3168aDACMuteMUTDA2 Property

DAC Mute: MUTDA2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacMuteDac2 DACMuteMUTDA2 { get; set; }
Public Property DACMuteMUTDA2 As Pcm3168aTypeDacMuteDac2
    Get
    Set
public:
property Pcm3168aTypeDacMuteDac2 DACMuteMUTDA2 {
    Pcm3168aTypeDacMuteDac2 get ();
    void set (Pcm3168aTypeDacMuteDac2 value);
}
member DACMuteMUTDA2 : Pcm3168aTypeDacMuteDac2 with get, set

Property Value

Type: Pcm3168aTypeDacMuteDac2
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACMuteMUTDA3 Property

IRD

Pcm3168aDACMuteMUTDA3 Property

DAC Mute: MUTDA3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacMuteDac3 DACMuteMUTDA3 { get; set; }
Public Property DACMuteMUTDA3 As Pcm3168aTypeDacMuteDac3
    Get
    Set
public:
property Pcm3168aTypeDacMuteDac3 DACMuteMUTDA3 {
    Pcm3168aTypeDacMuteDac3 get ();
    void set (Pcm3168aTypeDacMuteDac3 value);
}
member DACMuteMUTDA3 : Pcm3168aTypeDacMuteDac3 with get, set

Property Value

Type: Pcm3168aTypeDacMuteDac3
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACMuteMUTDA4 Property

IRD

Pcm3168aDACMuteMUTDA4 Property

DAC Mute: MUTDA4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacMuteDac4 DACMuteMUTDA4 { get; set; }
Public Property DACMuteMUTDA4 As Pcm3168aTypeDacMuteDac4
    Get
    Set
public:
property Pcm3168aTypeDacMuteDac4 DACMuteMUTDA4 {
    Pcm3168aTypeDacMuteDac4 get ();
    void set (Pcm3168aTypeDacMuteDac4 value);
}
member DACMuteMUTDA4 : Pcm3168aTypeDacMuteDac4 with get, set

Property Value

Type: Pcm3168aTypeDacMuteDac4
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACMuteMUTDA5 Property

IRD

Pcm3168aDACMuteMUTDA5 Property

DAC Mute: MUTDA5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacMuteDac5 DACMuteMUTDA5 { get; set; }
Public Property DACMuteMUTDA5 As Pcm3168aTypeDacMuteDac5
    Get
    Set
public:
property Pcm3168aTypeDacMuteDac5 DACMuteMUTDA5 {
    Pcm3168aTypeDacMuteDac5 get ();
    void set (Pcm3168aTypeDacMuteDac5 value);
}
member DACMuteMUTDA5 : Pcm3168aTypeDacMuteDac5 with get, set

Property Value

Type: Pcm3168aTypeDacMuteDac5
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACMuteMUTDA6 Property

IRD

Pcm3168aDACMuteMUTDA6 Property

DAC Mute: MUTDA6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacMuteDac6 DACMuteMUTDA6 { get; set; }
Public Property DACMuteMUTDA6 As Pcm3168aTypeDacMuteDac6
    Get
    Set
public:
property Pcm3168aTypeDacMuteDac6 DACMuteMUTDA6 {
    Pcm3168aTypeDacMuteDac6 get ();
    void set (Pcm3168aTypeDacMuteDac6 value);
}
member DACMuteMUTDA6 : Pcm3168aTypeDacMuteDac6 with get, set

Property Value

Type: Pcm3168aTypeDacMuteDac6
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACMuteMUTDA7 Property

IRD

Pcm3168aDACMuteMUTDA7 Property

DAC Mute: MUTDA7

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacMuteDac7 DACMuteMUTDA7 { get; set; }
Public Property DACMuteMUTDA7 As Pcm3168aTypeDacMuteDac7
    Get
    Set
public:
property Pcm3168aTypeDacMuteDac7 DACMuteMUTDA7 {
    Pcm3168aTypeDacMuteDac7 get ();
    void set (Pcm3168aTypeDacMuteDac7 value);
}
member DACMuteMUTDA7 : Pcm3168aTypeDacMuteDac7 with get, set

Property Value

Type: Pcm3168aTypeDacMuteDac7
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACMuteMUTDA8 Property

IRD

Pcm3168aDACMuteMUTDA8 Property

DAC Mute: MUTDA8

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacMuteDac8 DACMuteMUTDA8 { get; set; }
Public Property DACMuteMUTDA8 As Pcm3168aTypeDacMuteDac8
    Get
    Set
public:
property Pcm3168aTypeDacMuteDac8 DACMuteMUTDA8 {
    Pcm3168aTypeDacMuteDac8 get ();
    void set (Pcm3168aTypeDacMuteDac8 value);
}
member DACMuteMUTDA8 : Pcm3168aTypeDacMuteDac8 with get, set

Property Value

Type: Pcm3168aTypeDacMuteDac8
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACOperarionOPEDA1 Property

IRD

Pcm3168aDACOperarionOPEDA1 Property

DAC Operarion: OPEDA1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacOperationOp34 DACOperarionOPEDA1 { get; set; }
Public Property DACOperarionOPEDA1 As Pcm3168aTypeDacOperationOp34
    Get
    Set
public:
property Pcm3168aTypeDacOperationOp34 DACOperarionOPEDA1 {
    Pcm3168aTypeDacOperationOp34 get ();
    void set (Pcm3168aTypeDacOperationOp34 value);
}
member DACOperarionOPEDA1 : Pcm3168aTypeDacOperationOp34 with get, set

Property Value

Type: Pcm3168aTypeDacOperationOp34
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACOperationFLT0 Property

IRD

Pcm3168aDACOperationFLT0 Property

DAC Operation: FLT0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacOperationFilt12 DACOperationFLT0 { get; set; }
Public Property DACOperationFLT0 As Pcm3168aTypeDacOperationFilt12
    Get
    Set
public:
property Pcm3168aTypeDacOperationFilt12 DACOperationFLT0 {
    Pcm3168aTypeDacOperationFilt12 get ();
    void set (Pcm3168aTypeDacOperationFilt12 value);
}
member DACOperationFLT0 : Pcm3168aTypeDacOperationFilt12 with get, set

Property Value

Type: Pcm3168aTypeDacOperationFilt12
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACOperationFLT1 Property

IRD

Pcm3168aDACOperationFLT1 Property

DAC Operation: FLT1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacOperationFilt34 DACOperationFLT1 { get; set; }
Public Property DACOperationFLT1 As Pcm3168aTypeDacOperationFilt34
    Get
    Set
public:
property Pcm3168aTypeDacOperationFilt34 DACOperationFLT1 {
    Pcm3168aTypeDacOperationFilt34 get ();
    void set (Pcm3168aTypeDacOperationFilt34 value);
}
member DACOperationFLT1 : Pcm3168aTypeDacOperationFilt34 with get, set

Property Value

Type: Pcm3168aTypeDacOperationFilt34
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACOperationFLT2 Property

IRD

Pcm3168aDACOperationFLT2 Property

DAC Operation: FLT2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacOperationFilt56 DACOperationFLT2 { get; set; }
Public Property DACOperationFLT2 As Pcm3168aTypeDacOperationFilt56
    Get
    Set
public:
property Pcm3168aTypeDacOperationFilt56 DACOperationFLT2 {
    Pcm3168aTypeDacOperationFilt56 get ();
    void set (Pcm3168aTypeDacOperationFilt56 value);
}
member DACOperationFLT2 : Pcm3168aTypeDacOperationFilt56 with get, set

Property Value

Type: Pcm3168aTypeDacOperationFilt56
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACOperationFLT3 Property

IRD

Pcm3168aDACOperationFLT3 Property

DAC Operation: FLT3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacOperationFilt78 DACOperationFLT3 { get; set; }
Public Property DACOperationFLT3 As Pcm3168aTypeDacOperationFilt78
    Get
    Set
public:
property Pcm3168aTypeDacOperationFilt78 DACOperationFLT3 {
    Pcm3168aTypeDacOperationFilt78 get ();
    void set (Pcm3168aTypeDacOperationFilt78 value);
}
member DACOperationFLT3 : Pcm3168aTypeDacOperationFilt78 with get, set

Property Value

Type: Pcm3168aTypeDacOperationFilt78
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACOperationOPEDA0 Property

IRD

Pcm3168aDACOperationOPEDA0 Property

DAC Operation: OPEDA0

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacOperationOp12 DACOperationOPEDA0 { get; set; }
Public Property DACOperationOPEDA0 As Pcm3168aTypeDacOperationOp12
    Get
    Set
public:
property Pcm3168aTypeDacOperationOp12 DACOperationOPEDA0 {
    Pcm3168aTypeDacOperationOp12 get ();
    void set (Pcm3168aTypeDacOperationOp12 value);
}
member DACOperationOPEDA0 : Pcm3168aTypeDacOperationOp12 with get, set

Property Value

Type: Pcm3168aTypeDacOperationOp12
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACOperationOPEDA2 Property

IRD

Pcm3168aDACOperationOPEDA2 Property

DAC Operation: OPEDA2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacOperationOp56 DACOperationOPEDA2 { get; set; }
Public Property DACOperationOPEDA2 As Pcm3168aTypeDacOperationOp56
    Get
    Set
public:
property Pcm3168aTypeDacOperationOp56 DACOperationOPEDA2 {
    Pcm3168aTypeDacOperationOp56 get ();
    void set (Pcm3168aTypeDacOperationOp56 value);
}
member DACOperationOPEDA2 : Pcm3168aTypeDacOperationOp56 with get, set

Property Value

Type: Pcm3168aTypeDacOperationOp56
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACOperationOPEDA3 Property

IRD

Pcm3168aDACOperationOPEDA3 Property

DAC Operation: OPEDA3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacOperationOp78 DACOperationOPEDA3 { get; set; }
Public Property DACOperationOPEDA3 As Pcm3168aTypeDacOperationOp78
    Get
    Set
public:
property Pcm3168aTypeDacOperationOp78 DACOperationOPEDA3 {
    Pcm3168aTypeDacOperationOp78 get ();
    void set (Pcm3168aTypeDacOperationOp78 value);
}
member DACOperationOPEDA3 : Pcm3168aTypeDacOperationOp78 with get, set

Property Value

Type: Pcm3168aTypeDacOperationOp78
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACPhaseREVDA1 Property

IRD

Pcm3168aDACPhaseREVDA1 Property

DAC Phase: REVDA1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacPhaseDac1 DACPhaseREVDA1 { get; set; }
Public Property DACPhaseREVDA1 As Pcm3168aTypeDacPhaseDac1
    Get
    Set
public:
property Pcm3168aTypeDacPhaseDac1 DACPhaseREVDA1 {
    Pcm3168aTypeDacPhaseDac1 get ();
    void set (Pcm3168aTypeDacPhaseDac1 value);
}
member DACPhaseREVDA1 : Pcm3168aTypeDacPhaseDac1 with get, set

Property Value

Type: Pcm3168aTypeDacPhaseDac1
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACPhaseREVDA2 Property

IRD

Pcm3168aDACPhaseREVDA2 Property

DAC Phase: REVDA2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacPhaseDac2 DACPhaseREVDA2 { get; set; }
Public Property DACPhaseREVDA2 As Pcm3168aTypeDacPhaseDac2
    Get
    Set
public:
property Pcm3168aTypeDacPhaseDac2 DACPhaseREVDA2 {
    Pcm3168aTypeDacPhaseDac2 get ();
    void set (Pcm3168aTypeDacPhaseDac2 value);
}
member DACPhaseREVDA2 : Pcm3168aTypeDacPhaseDac2 with get, set

Property Value

Type: Pcm3168aTypeDacPhaseDac2
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACPhaseREVDA3 Property

IRD

Pcm3168aDACPhaseREVDA3 Property

DAC Phase: REVDA3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacPhaseDac3 DACPhaseREVDA3 { get; set; }
Public Property DACPhaseREVDA3 As Pcm3168aTypeDacPhaseDac3
    Get
    Set
public:
property Pcm3168aTypeDacPhaseDac3 DACPhaseREVDA3 {
    Pcm3168aTypeDacPhaseDac3 get ();
    void set (Pcm3168aTypeDacPhaseDac3 value);
}
member DACPhaseREVDA3 : Pcm3168aTypeDacPhaseDac3 with get, set

Property Value

Type: Pcm3168aTypeDacPhaseDac3
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACPhaseREVDA4 Property

IRD

Pcm3168aDACPhaseREVDA4 Property

DAC Phase: REVDA4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacPhaseDac4 DACPhaseREVDA4 { get; set; }
Public Property DACPhaseREVDA4 As Pcm3168aTypeDacPhaseDac4
    Get
    Set
public:
property Pcm3168aTypeDacPhaseDac4 DACPhaseREVDA4 {
    Pcm3168aTypeDacPhaseDac4 get ();
    void set (Pcm3168aTypeDacPhaseDac4 value);
}
member DACPhaseREVDA4 : Pcm3168aTypeDacPhaseDac4 with get, set

Property Value

Type: Pcm3168aTypeDacPhaseDac4
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACPhaseREVDA5 Property

IRD

Pcm3168aDACPhaseREVDA5 Property

DAC Phase: REVDA5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacPhaseDac5 DACPhaseREVDA5 { get; set; }
Public Property DACPhaseREVDA5 As Pcm3168aTypeDacPhaseDac5
    Get
    Set
public:
property Pcm3168aTypeDacPhaseDac5 DACPhaseREVDA5 {
    Pcm3168aTypeDacPhaseDac5 get ();
    void set (Pcm3168aTypeDacPhaseDac5 value);
}
member DACPhaseREVDA5 : Pcm3168aTypeDacPhaseDac5 with get, set

Property Value

Type: Pcm3168aTypeDacPhaseDac5
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACPhaseREVDA6 Property

IRD

Pcm3168aDACPhaseREVDA6 Property

DAC Phase: REVDA6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacPhaseDac6 DACPhaseREVDA6 { get; set; }
Public Property DACPhaseREVDA6 As Pcm3168aTypeDacPhaseDac6
    Get
    Set
public:
property Pcm3168aTypeDacPhaseDac6 DACPhaseREVDA6 {
    Pcm3168aTypeDacPhaseDac6 get ();
    void set (Pcm3168aTypeDacPhaseDac6 value);
}
member DACPhaseREVDA6 : Pcm3168aTypeDacPhaseDac6 with get, set

Property Value

Type: Pcm3168aTypeDacPhaseDac6
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACPhaseREVDA7 Property

IRD

Pcm3168aDACPhaseREVDA7 Property

DAC Phase: REVDA7

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacPhaseDac7 DACPhaseREVDA7 { get; set; }
Public Property DACPhaseREVDA7 As Pcm3168aTypeDacPhaseDac7
    Get
    Set
public:
property Pcm3168aTypeDacPhaseDac7 DACPhaseREVDA7 {
    Pcm3168aTypeDacPhaseDac7 get ();
    void set (Pcm3168aTypeDacPhaseDac7 value);
}
member DACPhaseREVDA7 : Pcm3168aTypeDacPhaseDac7 with get, set

Property Value

Type: Pcm3168aTypeDacPhaseDac7
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACPhaseREVDA8 Property

IRD

Pcm3168aDACPhaseREVDA8 Property

DAC Phase: REVDA8

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacPhaseDac8 DACPhaseREVDA8 { get; set; }
Public Property DACPhaseREVDA8 As Pcm3168aTypeDacPhaseDac8
    Get
    Set
public:
property Pcm3168aTypeDacPhaseDac8 DACPhaseREVDA8 {
    Pcm3168aTypeDacPhaseDac8 get ();
    void set (Pcm3168aTypeDacPhaseDac8 value);
}
member DACPhaseREVDA8 : Pcm3168aTypeDacPhaseDac8 with get, set

Property Value

Type: Pcm3168aTypeDacPhaseDac8
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACZeroFlagZERO1 Property

IRD

Pcm3168aDACZeroFlagZERO1 Property

DAC Zero Flag: ZERO1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacZeroFlagDac1 DACZeroFlagZERO1 { get; }
Public ReadOnly Property DACZeroFlagZERO1 As Pcm3168aTypeDacZeroFlagDac1
    Get
public:
property Pcm3168aTypeDacZeroFlagDac1 DACZeroFlagZERO1 {
    Pcm3168aTypeDacZeroFlagDac1 get ();
}
member DACZeroFlagZERO1 : Pcm3168aTypeDacZeroFlagDac1 with get

Property Value

Type: Pcm3168aTypeDacZeroFlagDac1
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACZeroFlagZERO2 Property

IRD

Pcm3168aDACZeroFlagZERO2 Property

DAC Zero Flag: ZERO2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacZeroFlagDac2 DACZeroFlagZERO2 { get; }
Public ReadOnly Property DACZeroFlagZERO2 As Pcm3168aTypeDacZeroFlagDac2
    Get
public:
property Pcm3168aTypeDacZeroFlagDac2 DACZeroFlagZERO2 {
    Pcm3168aTypeDacZeroFlagDac2 get ();
}
member DACZeroFlagZERO2 : Pcm3168aTypeDacZeroFlagDac2 with get

Property Value

Type: Pcm3168aTypeDacZeroFlagDac2
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACZeroFlagZERO3 Property

IRD

Pcm3168aDACZeroFlagZERO3 Property

DAC Zero Flag: ZERO3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacZeroFlagDac3 DACZeroFlagZERO3 { get; }
Public ReadOnly Property DACZeroFlagZERO3 As Pcm3168aTypeDacZeroFlagDac3
    Get
public:
property Pcm3168aTypeDacZeroFlagDac3 DACZeroFlagZERO3 {
    Pcm3168aTypeDacZeroFlagDac3 get ();
}
member DACZeroFlagZERO3 : Pcm3168aTypeDacZeroFlagDac3 with get

Property Value

Type: Pcm3168aTypeDacZeroFlagDac3
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACZeroFlagZERO4 Property

IRD

Pcm3168aDACZeroFlagZERO4 Property

DAC Zero Flag: ZERO4

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacZeroFlagDac4 DACZeroFlagZERO4 { get; }
Public ReadOnly Property DACZeroFlagZERO4 As Pcm3168aTypeDacZeroFlagDac4
    Get
public:
property Pcm3168aTypeDacZeroFlagDac4 DACZeroFlagZERO4 {
    Pcm3168aTypeDacZeroFlagDac4 get ();
}
member DACZeroFlagZERO4 : Pcm3168aTypeDacZeroFlagDac4 with get

Property Value

Type: Pcm3168aTypeDacZeroFlagDac4
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACZeroFlagZERO5 Property

IRD

Pcm3168aDACZeroFlagZERO5 Property

DAC Zero Flag: ZERO5

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacZeroFlagDac5 DACZeroFlagZERO5 { get; }
Public ReadOnly Property DACZeroFlagZERO5 As Pcm3168aTypeDacZeroFlagDac5
    Get
public:
property Pcm3168aTypeDacZeroFlagDac5 DACZeroFlagZERO5 {
    Pcm3168aTypeDacZeroFlagDac5 get ();
}
member DACZeroFlagZERO5 : Pcm3168aTypeDacZeroFlagDac5 with get

Property Value

Type: Pcm3168aTypeDacZeroFlagDac5
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACZeroFlagZERO6 Property

IRD

Pcm3168aDACZeroFlagZERO6 Property

DAC Zero Flag: ZERO6

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacZeroFlagDac6 DACZeroFlagZERO6 { get; }
Public ReadOnly Property DACZeroFlagZERO6 As Pcm3168aTypeDacZeroFlagDac6
    Get
public:
property Pcm3168aTypeDacZeroFlagDac6 DACZeroFlagZERO6 {
    Pcm3168aTypeDacZeroFlagDac6 get ();
}
member DACZeroFlagZERO6 : Pcm3168aTypeDacZeroFlagDac6 with get

Property Value

Type: Pcm3168aTypeDacZeroFlagDac6
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACZeroFlagZERO7 Property

IRD

Pcm3168aDACZeroFlagZERO7 Property

DAC Zero Flag: ZERO7

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacZeroFlagDac7 DACZeroFlagZERO7 { get; }
Public ReadOnly Property DACZeroFlagZERO7 As Pcm3168aTypeDacZeroFlagDac7
    Get
public:
property Pcm3168aTypeDacZeroFlagDac7 DACZeroFlagZERO7 {
    Pcm3168aTypeDacZeroFlagDac7 get ();
}
member DACZeroFlagZERO7 : Pcm3168aTypeDacZeroFlagDac7 with get

Property Value

Type: Pcm3168aTypeDacZeroFlagDac7
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.DACZeroFlagZERO8 Property

IRD

Pcm3168aDACZeroFlagZERO8 Property

DAC Zero Flag: ZERO8

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Pcm3168aTypeDacZeroFlagDac8 DACZeroFlagZERO8 { get; }
Public ReadOnly Property DACZeroFlagZERO8 As Pcm3168aTypeDacZeroFlagDac8
    Get
public:
property Pcm3168aTypeDacZeroFlagDac8 DACZeroFlagZERO8 {
    Pcm3168aTypeDacZeroFlagDac8 get ();
}
member DACZeroFlagZERO8 : Pcm3168aTypeDacZeroFlagDac8 with get

Property Value

Type: Pcm3168aTypeDacZeroFlagDac8
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a Methods

The Pcm3168a type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.Flush Method

IRD

Pcm3168aFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Pcm3168a Class
telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcAttenuation Enumeration

IRD

Pcm3168aTypeAdcAttenuation Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcAttenuation
Public Enumeration TypeAdcAttenuation
public enum class TypeAdcAttenuation
type TypeAdcAttenuation
Members
Member name | Value | Description
Value_20_0 | 255 | 20.0
Value_19_5 | 254 | 19.5
Value_19_0 | 253 | 19.0
Value_18_5 | 252 | 18.5
Value_18_0 | 251 | 18.0
Value_17_5 | 250 | 17.5
Value_17_0 | 249 | 17.0
Value_16_5 | 248 | 16.5
Value_16_0 | 247 | 16.0
Value_15_5 | 246 | 15.5
Value_15_0 | 245 | 15.0
Value_14_5 | 244 | 14.5
Value_14_0 | 243 | 14.0
Value_13_5 | 242 | 13.5
Value_13_0 | 241 | 13.0
Value_12_5 | 240 | 12.5
Value_12_0 | 239 | 12.0
Value_11_5 | 238 | 11.5
Value_11_0 | 237 | 11.0
Value_10_5 | 236 | 10.5
Value_10_0 | 235 | 10.0
Value_9_5 | 234 | 9.5
Value_9_0 | 233 | 9.0
Value_8_5 | 232 | 8.5
Value_8_0 | 231 | 8.0
Value_7_5 | 230 | 7.5
Value_7_0 | 229 | 7.0
Value_6_5 | 228 | 6.5
Value_6_0 | 227 | 6.0
Value_5_5 | 226 | 5.5
Value_5_0 | 225 | 5.0
Value_4_5 | 224 | 4.5
Value_4_0 | 223 | 4.0
Value_3_5 | 222 | 3.5
Value_3_0 | 221 | 3.0
Value_2_5 | 220 | 2.5
Value_2_0 | 219 | 2.0
Value_1_5 | 218 | 1.5
Value_1_0 | 217 | 1.0
Value_0_5 | 216 | 0.5
Value_0_0 | 215 | 0.0
Value_M_0_5 | 214 | -0.5
Value_M_1_0 | 213 | -1.0
Value_M_1_5 | 212 | -1.5
Value_M_2_0 | 211 | -2.0
Value_M_2_5 | 210 | -2.5
Value_M_3_0 | 209 | -3.0
Value_M_3_5 | 208 | -3.5
Value_M_4_0 | 207 | -4.0
Value_M_4_5 | 206 | -4.5
Value_M_5_0 | 205 | -5.0
Value_M_5_5 | 204 | -5.5
Value_M_6_0 | 203 | -6.0
Value_M_6_5 | 202 | -6.5
Value_M_7_0 | 201 | -7.0
Value_M_7_5 | 200 | -7.5
Value_M_8_0 | 199 | -8.0
Value_M_8_5 | 198 | -8.5
Value_M_9_0 | 197 | -9.0
Value_M_9_5 | 196 | -9.5
Value_M_10_0 | 195 | -10.0
Value_M_10_5 | 194 | -10.5
Value_M_11_0 | 193 | -11.0
Value_M_11_5 | 192 | -11.5
Value_M_12_0 | 191 | -12.0
Value_M_12_5 | 190 | -12.5
Value_M_13_0 | 189 | -13.0
Value_M_13_5 | 188 | -13.5
Value_M_14_0 | 187 | -14.0
Value_M_14_5 | 186 | -14.5
Value_M_15_0 | 185 | -15.0
Value_M_15_5 | 184 | -15.5
Value_M_16_0 | 183 | -16.0
Value_M_16_5 | 182 | -16.5
Value_M_17_0 | 181 | -17.0
Value_M_17_5 | 180 | -17.5
Value_M_18_0 | 179 | -18.0
Value_M_18_5 | 178 | -18.5
Value_M_19_0 | 177 | -19.0
Value_M_19_5 | 176 | -19.5
Value_M_20_0 | 175 | -20.0
Value_M_20_5 | 174 | -20.5
Value_M_21_0 | 173 | -21.0
Value_M_21_5 | 172 | -21.5
Value_M_22_0 | 171 | -22.0
Value_M_22_5 | 170 | -22.5
Value_M_23_0 | 169 | -23.0
Value_M_23_5 | 168 | -23.5
Value_M_24_0 | 167 | -24.0
Value_M_24_5 | 166 | -24.5
Value_M_25_0 | 165 | -25.0
Value_M_25_5 | 164 | -25.5
Value_M_26_0 | 163 | -26.0
Value_M_26_5 | 162 | -26.5
Value_M_27_0 | 161 | -27.0
Value_M_27_5 | 160 | -27.5
Value_M_28_0 | 159 | -28.0
Value_M_28_5 | 158 | -28.5
Value_M_29_0 | 157 | -29.0
Value_M_29_5 | 156 | -29.5
Value_M_30_0 | 155 | -30.0
Value_M_30_5 | 154 | -30.5
Value_M_31_0 | 153 | -31.0
Value_M_31_5 | 152 | -31.5
Value_M_32_0 | 151 | -32.0
Value_M_32_5 | 150 | -32.5
Value_M_33_0 | 149 | -33.0
Value_M_33_5 | 148 | -33.5
Value_M_34_0 | 147 | -34.0
Value_M_34_5 | 146 | -34.5
Value_M_35_0 | 145 | -35.0
Value_M_35_5 | 144 | -35.5
Value_M_36_0 | 143 | -36.0
Value_M_36_5 | 142 | -36.5
Value_M_37_0 | 141 | -37.0
Value_M_37_5 | 140 | -37.5
Value_M_38_0 | 139 | -38.0
Value_M_38_5 | 138 | -38.5
Value_M_39_0 | 137 | -39.0
Value_M_39_5 | 136 | -39.5
Value_M_40_0 | 135 | -40.0
Value_M_40_5 | 134 | -40.5
Value_M_41_0 | 133 | -41.0
Value_M_41_5 | 132 | -41.5
Value_M_42_0 | 131 | -42.0
Value_M_42_5 | 130 | -42.5
Value_M_43_0 | 129 | -43.0
Value_M_43_5 | 128 | -43.5
Value_M_44_0 | 127 | -44.0
Value_M_44_5 | 126 | -44.5
Value_M_45_0 | 125 | -45.0
Value_M_45_5 | 124 | -45.5
Value_M_46_0 | 123 | -46.0
Value_M_46_5 | 122 | -46.5
Value_M_47_0 | 121 | -47.0
Value_M_47_5 | 120 | -47.5
Value_M_48_0 | 119 | -48.0
Value_M_48_5 | 118 | -48.5
Value_M_49_0 | 117 | -49.0
Value_M_49_5 | 116 | -49.5
Value_M_50_0 | 115 | -50.0
Value_M_50_5 | 114 | -50.5
Value_M_51_0 | 113 | -51.0
Value_M_51_5 | 112 | -51.5
Value_M_52_0 | 111 | -52.0
Value_M_52_5 | 110 | -52.5
Value_M_53_0 | 109 | -53.0
Value_M_53_5 | 108 | -53.5
Value_M_54_0 | 107 | -54.0
Value_M_54_5 | 106 | -54.5
Value_M_55_0 | 105 | -55.0
Value_M_55_5 | 104 | -55.5
Value_M_56_0 | 103 | -56.0
Value_M_56_5 | 102 | -56.5
Value_M_57_0 | 101 | -57.0
Value_M_57_5 | 100 | -57.5
Value_M_58_0 | 99 | -58.0
Value_M_58_5 | 98 | -58.5
Value_M_59_0 | 97 | -59.0
Value_M_59_5 | 96 | -59.5
Value_M_60_0 | 95 | -60.0
Value_M_60_5 | 94 | -60.5
Value_M_61_0 | 93 | -61.0
Value_M_61_5 | 92 | -61.5
Value_M_62_0 | 91 | -62.0
Value_M_62_5 | 90 | -62.5
Value_M_63_0 | 89 | -63.0
Value_M_63_5 | 88 | -63.5
Value_M_64_0 | 87 | -64.0
Value_M_64_5 | 86 | -64.5
Value_M_65_0 | 85 | -65.0
Value_M_65_5 | 84 | -65.5
Value_M_66_0 | 83 | -66.0
Value_M_66_5 | 82 | -66.5
Value_M_67_0 | 81 | -67.0
Value_M_67_5 | 80 | -67.5
Value_M_68_0 | 79 | -68.0
Value_M_68_5 | 78 | -68.5
Value_M_69_0 | 77 | -69.0
Value_M_69_5 | 76 | -69.5
Value_M_70_0 | 75 | -70.0
Value_M_70_5 | 74 | -70.5
Value_M_71_0 | 73 | -71.0
Value_M_71_5 | 72 | -71.5
Value_M_72_0 | 71 | -72.0
Value_M_72_5 | 70 | -72.5
Value_M_73_0 | 69 | -73.0
Value_M_73_5 | 68 | -73.5
Value_M_74_0 | 67 | -74.0
Value_M_74_5 | 66 | -74.5
Value_M_75_0 | 65 | -75.0
Value_M_75_5 | 64 | -75.5
Value_M_76_0 | 63 | -76.0
Value_M_76_5 | 62 | -76.5
Value_M_77_0 | 61 | -77.0
Value_M_77_5 | 60 | -77.5
Value_M_78_0 | 59 | -78.0
Value_M_78_5 | 58 | -78.5
Value_M_79_0 | 57 | -79.0
Value_M_79_5 | 56 | -79.5
Value_M_80_0 | 55 | -80.0
Value_M_80_5 | 54 | -80.5
Value_M_81_0 | 53 | -81.0
Value_M_81_5 | 52 | -81.5
Value_M_82_0 | 51 | -82.0
Value_M_82_5 | 50 | -82.5
Value_M_83_0 | 49 | -83.0
Value_M_83_5 | 48 | -83.5
Value_M_84_0 | 47 | -84.0
Value_M_84_5 | 46 | -84.5
Value_M_85_0 | 45 | -85.0
Value_M_85_5 | 44 | -85.5
Value_M_86_0 | 43 | -86.0
Value_M_86_5 | 42 | -86.5
Value_M_87_0 | 41 | -87.0
Value_M_87_5 | 40 | -87.5
Value_M_88_0 | 39 | -88.0
Value_M_88_5 | 38 | -88.5
Value_M_89_0 | 37 | -89.0
Value_M_89_5 | 36 | -89.5
Value_M_90_0 | 35 | -90.0
Value_M_90_5 | 34 | -90.5
Value_M_91_0 | 33 | -91.0
Value_M_91_5 | 32 | -91.5
Value_M_92_0 | 31 | -92.0
Value_M_92_5 | 30 | -92.5
Value_M_93_0 | 29 | -93.0
Value_M_93_5 | 28 | -93.5
Value_M_94_0 | 27 | -94.0
Value_M_94_5 | 26 | -94.5
Value_M_95_0 | 25 | -95.0
Value_M_95_5 | 24 | -95.5
Value_M_96_0 | 23 | -96.0
Value_M_96_5 | 22 | -96.5
Value_M_97_0 | 21 | -97.0
Value_M_97_5 | 20 | -97.5
Value_M_98_0 | 19 | -98.0
Value_M_98_5 | 18 | -98.5
Value_M_99_0 | 17 | -99.0
Value_M_99_5 | 16 | -99.5
Value_M_100_0 | 15 | -100.0
Mute | 0 | Mute
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcAttenuationControlMode Enumeration

IRD

Pcm3168aTypeAdcAttenuationControlMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcAttenuationControlMode
Public Enumeration TypeAdcAttenuationControlMode
public enum class TypeAdcAttenuationControlMode
type TypeAdcAttenuationControlMode
Members
Member name | Value | Description
ADCAttenuationModeEachChannelWithIndependentData | 0 | ADC Attenuation Mode: Each Channel With Independent Data
ADCAttenuationModeAllChannelsWithInependentPresetData | 1 | ADC Attenuation Mode: All Channels With Inependent Preset Data
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcAttenuationControlOver Enumeration

IRD

Pcm3168aTypeAdcAttenuationControlOver Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcAttenuationControlOver
Public Enumeration TypeAdcAttenuationControlOver
public enum class TypeAdcAttenuationControlOver
type TypeAdcAttenuationControlOver
Members
Member name | Value | Description
ADCOverflowFlagPolarityHighForOverflowDetect | 0 | ADC Overflow Flag Polarity: High For Overflow Detect
ADCOverflowFlagPolarityLowForOverflowDetect | 1 | ADC Overflow Flag Polarity: Low For Overflow Detect
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcAttenuationControlSpeed Enumeration

IRD

Pcm3168aTypeAdcAttenuationControlSpeed Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcAttenuationControlSpeed
Public Enumeration TypeAdcAttenuationControlSpeed
public enum class TypeAdcAttenuationControlSpeed
type TypeAdcAttenuationControlSpeed
Members
Member name | Value | Description
ADCAttenuationSpeedNX2048Fs | 0 | ADC Attenuation Speed: N x (2048 / Fs)
ADCAttenuationSpeedNX4096Fs | 1 | ADC Attenuation Speed: N x (4096 / Fs)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcConfigControlInp1 Enumeration

IRD

Pcm3168aTypeAdcConfigControlInp1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcConfigControlInp1
Public Enumeration TypeAdcConfigControlInp1
public enum class TypeAdcConfigControlInp1
type TypeAdcConfigControlInp1
Members
Member name | Value | Description
ADC1InputDifferential | 0 | ADC1 Input: Differential
ADC1InputSingleEnded | 1 | ADC1 Input: Single Ended
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcConfigControlInp2 Enumeration

IRD

Pcm3168aTypeAdcConfigControlInp2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcConfigControlInp2
Public Enumeration TypeAdcConfigControlInp2
public enum class TypeAdcConfigControlInp2
type TypeAdcConfigControlInp2
Members
Member name | Value | Description
ADC2InputDifferential | 0 | ADC2 Input: Differential
ADC2InputSingleEnded | 1 | ADC2 Input: Single Ended
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcConfigControlInp3 Enumeration

IRD

Pcm3168aTypeAdcConfigControlInp3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcConfigControlInp3
Public Enumeration TypeAdcConfigControlInp3
public enum class TypeAdcConfigControlInp3
type TypeAdcConfigControlInp3
Members
Member name | Value | Description
ADC3InputDifferential | 0 | ADC3 Input: Differential
ADC3InputSingleEnded | 1 | ADC3 Input: Single Ended
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcConfigControlInp4 Enumeration

IRD

Pcm3168aTypeAdcConfigControlInp4 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcConfigControlInp4
Public Enumeration TypeAdcConfigControlInp4
public enum class TypeAdcConfigControlInp4
type TypeAdcConfigControlInp4
Members
Member name | Value | Description
ADC4InputDifferential | 0 | ADC4 Input: Differential
ADC4InputSingleEnded | 1 | ADC4 Input: Single Ended
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcConfigControlInp5 Enumeration

IRD

Pcm3168aTypeAdcConfigControlInp5 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcConfigControlInp5
Public Enumeration TypeAdcConfigControlInp5
public enum class TypeAdcConfigControlInp5
type TypeAdcConfigControlInp5
Members
Member name | Value | Description
ADC5InputDifferential | 0 | ADC5 Input: Differential
ADC5InputSingleEnded | 1 | ADC5 Input: Single Ended
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcConfigControlInp6 Enumeration

IRD

Pcm3168aTypeAdcConfigControlInp6 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcConfigControlInp6
Public Enumeration TypeAdcConfigControlInp6
public enum class TypeAdcConfigControlInp6
type TypeAdcConfigControlInp6
Members
Member name | Value | Description
ADC6InputDifferential | 0 | ADC6 Input: Differential
ADC6InputSingleEnded | 1 | ADC6 Input: Single Ended
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcModeControlSampling Enumeration

IRD

Pcm3168aTypeAdcModeControlSampling Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcModeControlSampling
Public Enumeration TypeAdcModeControlSampling
public enum class TypeAdcModeControlSampling
type TypeAdcModeControlSampling
Members
Member name | Value | Description
ADCSamplingRateAuto | 0 | ADC Sampling Rate: Auto
ADCSamplingRateSingleRate | 1 | ADC Sampling Rate: Single Rate
ADCSamplingRateDualRate | 2 | ADC Sampling Rate: Dual Rate
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcModeSelectFormat Enumeration

IRD

Pcm3168aTypeAdcModeSelectFormat Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcModeSelectFormat
Public Enumeration TypeAdcModeSelectFormat
public enum class TypeAdcModeSelectFormat
type TypeAdcModeSelectFormat
Members
Member name | Value | Description
ADCAudioInterfaceFormat24BitI2S | 0 | ADC Audio Interface Format: 24 Bit I2S
ADCAudioInterfaceFormat24BitLeftJustified | 1 | ADC Audio Interface Format: 24 Bit Left-Justified
ADCAudioInterfaceFormat24BitRightJustified | 2 | ADC Audio Interface Format: 24 Bit Right-Justified
ADCAudioInterfaceFormat16BitRightJustified | 3 | ADC Audio Interface Format: 16 Bit Right-Justified
ADCAudioInterfaceFormat24BitI2SDSP | 4 | ADC Audio Interface Format: 24 Bit I2S DSP
ADCAudioInterfaceFormat24BitLeftJustifiedDSP | 5 | ADC Audio Interface Format: 24 Bit Left-Justified DSP
ADCAudioInterfaceFormat24BitI2STDM | 6 | ADC Audio Interface Format: 24 Bit I2S TDM
ADCAudioInterfaceFormat24BitLeftJustifiedTDM | 7 | ADC Audio Interface Format: 24 Bit Left-Justified TDM
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcModeSelectMs Enumeration

IRD

Pcm3168aTypeAdcModeSelectMs Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcModeSelectMs
Public Enumeration TypeAdcModeSelectMs
public enum class TypeAdcModeSelectMs
type TypeAdcModeSelectMs
Members
Member name | Value | Description
ADCSlaveMode | 0 | ADC Slave Mode
ADCMasterMode768Fs | 1 | ADC Master Mode: 768 Fs
ADCMasterMode512Fs | 2 | ADC Master Mode: 512 Fs
ADCMasterMode384Fs | 3 | ADC Master Mode: 384 Fs
ADCMasterMode256Fs | 4 | ADC Master Mode: 256 Fs
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcMuteAdc1 Enumeration

IRD

Pcm3168aTypeAdcMuteAdc1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcMuteAdc1
Public Enumeration TypeAdcMuteAdc1
public enum class TypeAdcMuteAdc1
type TypeAdcMuteAdc1
Members
Member name | Value | Description
ADC1MuteDisabled | 0 | ADC1 Mute: Disabled
ADC1MuteEnabled | 1 | ADC1 Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcMuteAdc2 Enumeration

IRD

Pcm3168aTypeAdcMuteAdc2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcMuteAdc2
Public Enumeration TypeAdcMuteAdc2
public enum class TypeAdcMuteAdc2
type TypeAdcMuteAdc2
Members
Member name | Value | Description
ADC2MuteDisabled | 0 | ADC2 Mute: Disabled
ADC2MuteEnabled | 1 | ADC2 Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcMuteAdc3 Enumeration

IRD

Pcm3168aTypeAdcMuteAdc3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcMuteAdc3
Public Enumeration TypeAdcMuteAdc3
public enum class TypeAdcMuteAdc3
type TypeAdcMuteAdc3
Members
Member name | Value | Description
ADC3MuteDisabled | 0 | ADC3 Mute: Disabled
ADC3MuteEnabled | 1 | ADC3 Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcMuteAdc4 Enumeration

IRD

Pcm3168aTypeAdcMuteAdc4 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcMuteAdc4
Public Enumeration TypeAdcMuteAdc4
public enum class TypeAdcMuteAdc4
type TypeAdcMuteAdc4
Members
Member name | Value | Description
ADC4MuteDisabled | 0 | ADC4 Mute: Disabled
ADC4MuteEnabled | 1 | ADC4 Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcMuteAdc5 Enumeration

IRD

Pcm3168aTypeAdcMuteAdc5 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcMuteAdc5
Public Enumeration TypeAdcMuteAdc5
public enum class TypeAdcMuteAdc5
type TypeAdcMuteAdc5
Members
Member name | Value | Description
ADC5MuteDisabled | 0 | ADC5 Mute: Disabled
ADC5MuteEnabled | 1 | ADC5 Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcMuteAdc6 Enumeration

IRD

Pcm3168aTypeAdcMuteAdc6 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcMuteAdc6
Public Enumeration TypeAdcMuteAdc6
public enum class TypeAdcMuteAdc6
type TypeAdcMuteAdc6
Members
Member name | Value | Description
ADC6MuteDisabled | 0 | ADC6 Mute: Disabled
ADC6MuteEnabled | 1 | ADC6 Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcOverflowAdc1 Enumeration

IRD

Pcm3168aTypeAdcOverflowAdc1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcOverflowAdc1
Public Enumeration TypeAdcOverflowAdc1
public enum class TypeAdcOverflowAdc1
type TypeAdcOverflowAdc1
Members
Member name | Value | Description
ADC1OverflowInputNotDetected | 0 | ADC1 Overflow: Input Not Detected
ADC1OverflowInputDetected | 1 | ADC1 Overflow: Input Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcOverflowAdc2 Enumeration

IRD

Pcm3168aTypeAdcOverflowAdc2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcOverflowAdc2
Public Enumeration TypeAdcOverflowAdc2
public enum class TypeAdcOverflowAdc2
type TypeAdcOverflowAdc2
Members
Member name | Value | Description
ADC2OverflowInputNotDetected | 0 | ADC2 Overflow: Input Not Detected
ADC2OverflowInputDetected | 1 | ADC2 Overflow: Input Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcOverflowAdc3 Enumeration

IRD

Pcm3168aTypeAdcOverflowAdc3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcOverflowAdc3
Public Enumeration TypeAdcOverflowAdc3
public enum class TypeAdcOverflowAdc3
type TypeAdcOverflowAdc3
Members
Member name | Value | Description
ADC3OverflowInputNotDetected | 0 | ADC3 Overflow: Input Not Detected
ADC3OverflowInputDetected | 1 | ADC3 Overflow: Input Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcOverflowAdc4 Enumeration

IRD

Pcm3168aTypeAdcOverflowAdc4 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcOverflowAdc4
Public Enumeration TypeAdcOverflowAdc4
public enum class TypeAdcOverflowAdc4
type TypeAdcOverflowAdc4
Members
Member name | Value | Description
ADC4OverflowInputNotDetected | 0 | ADC4 Overflow: Input Not Detected
ADC4OverflowInputDetected | 1 | ADC4 Overflow: Input Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcOverflowAdc5 Enumeration

IRD

Pcm3168aTypeAdcOverflowAdc5 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcOverflowAdc5
Public Enumeration TypeAdcOverflowAdc5
public enum class TypeAdcOverflowAdc5
type TypeAdcOverflowAdc5
Members
Member name | Value | Description
ADC5OverflowInputNotDetected | 0 | ADC5 Overflow: Input Not Detected
ADC5OverflowInputDetected | 1 | ADC5 Overflow: Input Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcOverflowAdc6 Enumeration

IRD

Pcm3168aTypeAdcOverflowAdc6 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcOverflowAdc6
Public Enumeration TypeAdcOverflowAdc6
public enum class TypeAdcOverflowAdc6
type TypeAdcOverflowAdc6
Members
Member name | Value | Description
ADC6OverflowInputNotDetected | 0 | ADC6 Overflow: Input Not Detected
ADC6OverflowInputDetected | 1 | ADC6 Overflow: Input Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcPhaseAdc1 Enumeration

IRD

Pcm3168aTypeAdcPhaseAdc1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcPhaseAdc1
Public Enumeration TypeAdcPhaseAdc1
public enum class TypeAdcPhaseAdc1
type TypeAdcPhaseAdc1
Members
Member name | Value | Description
ADC1InputPhaseNormal | 0 | ADC1 Input Phase: Normal
ADC1InputPhaseInverted | 1 | ADC1 Input Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcPhaseAdc2 Enumeration

IRD

Pcm3168aTypeAdcPhaseAdc2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcPhaseAdc2
Public Enumeration TypeAdcPhaseAdc2
public enum class TypeAdcPhaseAdc2
type TypeAdcPhaseAdc2
Members
Member name | Value | Description
ADC2InputPhaseNormal | 0 | ADC2 Input Phase: Normal
ADC2InputPhaseInverted | 1 | ADC2 Input Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcPhaseAdc3 Enumeration

IRD

Pcm3168aTypeAdcPhaseAdc3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcPhaseAdc3
Public Enumeration TypeAdcPhaseAdc3
public enum class TypeAdcPhaseAdc3
type TypeAdcPhaseAdc3
Members
Member name | Value | Description
ADC3InputPhaseNormal | 0 | ADC3 Input Phase: Normal
ADC3InputPhaseInverted | 1 | ADC3 Input Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcPhaseAdc4 Enumeration

IRD

Pcm3168aTypeAdcPhaseAdc4 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcPhaseAdc4
Public Enumeration TypeAdcPhaseAdc4
public enum class TypeAdcPhaseAdc4
type TypeAdcPhaseAdc4
Members
Member name | Value | Description
ADC4InputPhaseNormal | 0 | ADC4 Input Phase: Normal
ADC4InputPhaseInverted | 1 | ADC4 Input Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcPhaseAdc5 Enumeration

IRD

Pcm3168aTypeAdcPhaseAdc5 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcPhaseAdc5
Public Enumeration TypeAdcPhaseAdc5
public enum class TypeAdcPhaseAdc5
type TypeAdcPhaseAdc5
Members
Member name | Value | Description
ADC5InputPhaseNormal | 0 | ADC5 Input Phase: Normal
ADC5InputPhaseInverted | 1 | ADC5 Input Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcPhaseAdc6 Enumeration

IRD

Pcm3168aTypeAdcPhaseAdc6 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcPhaseAdc6
Public Enumeration TypeAdcPhaseAdc6
public enum class TypeAdcPhaseAdc6
type TypeAdcPhaseAdc6
Members
Member name | Value | Description
ADC6InputPhaseNormal | 0 | ADC6 Input Phase: Normal
ADC6InputPhaseInverted | 1 | ADC6 Input Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcPowerControlByp12 Enumeration

IRD

Pcm3168aTypeAdcPowerControlByp12 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcPowerControlByp12
Public Enumeration TypeAdcPowerControlByp12
public enum class TypeAdcPowerControlByp12
type TypeAdcPowerControlByp12
Members
Member name | Value | Description
ADC12HPFControlNormalOutputHPFEnabled | 0 | ADC1/2 HPF Control: Normal Output (HPF Enabled)
ADC12HPFControlBypassedOutputHPFDisabled | 1 | ADC1/2 HPF Control: Bypassed Output (HPF Disabled)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcPowerControlByp34 Enumeration

IRD

Pcm3168aTypeAdcPowerControlByp34 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcPowerControlByp34
Public Enumeration TypeAdcPowerControlByp34
public enum class TypeAdcPowerControlByp34
type TypeAdcPowerControlByp34
Members
Member name | Value | Description
ADC34HPFControlNormalOutputHPFEnabled | 0 | ADC3/4 HPF Control: Normal Output (HPF Enabled)
ADC34HPFControlBypassedOutputHPFDisabled | 1 | ADC3/4 HPF Control: Bypassed Output (HPF Disabled)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcPowerControlByp56 Enumeration

IRD

Pcm3168aTypeAdcPowerControlByp56 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcPowerControlByp56
Public Enumeration TypeAdcPowerControlByp56
public enum class TypeAdcPowerControlByp56
type TypeAdcPowerControlByp56
Members
Member name | Value | Description
ADC56HPFControlNormalOutputHPFEnabled | 0 | ADC5/6 HPF Control: Normal Output (HPF Enabled)
ADC56HPFControlBypassedOutputHPFDisabled | 1 | ADC5/6 HPF Control: Bypassed Output (HPF Disabled)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcPowerControlPow12 Enumeration

IRD

Pcm3168aTypeAdcPowerControlPow12 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcPowerControlPow12
Public Enumeration TypeAdcPowerControlPow12
public enum class TypeAdcPowerControlPow12
type TypeAdcPowerControlPow12
Members
Member name | Value | Description
ADC12PowerSaveModeNormalOperation | 0 | ADC1/2 Power-Save Mode: Normal Operation
ADC12PowerSaveModeEnabled | 1 | ADC1/2 Power-Save Mode: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcPowerControlPow34 Enumeration

IRD

Pcm3168aTypeAdcPowerControlPow34 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcPowerControlPow34
Public Enumeration TypeAdcPowerControlPow34
public enum class TypeAdcPowerControlPow34
type TypeAdcPowerControlPow34
Members
Member name | Value | Description
ADC34PowerSaveModeNormalOperation | 0 | ADC3/4 Power-Save Mode: Normal Operation
ADC34PowerSaveModeEnabled | 1 | ADC3/4 Power-Save Mode: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeAdcPowerControlPow56 Enumeration

IRD

Pcm3168aTypeAdcPowerControlPow56 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeAdcPowerControlPow56
Public Enumeration TypeAdcPowerControlPow56
public enum class TypeAdcPowerControlPow56
type TypeAdcPowerControlPow56
Members
Member name | Value | Description
ADC56PowerSaveModeNormalOperation | 0 | ADC5/6 Power-Save Mode: Normal Operation
ADC56PowerSaveModeEnabled | 1 | ADC5/6 Power-Save Mode: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacAttenuation Enumeration

IRD

Pcm3168aTypeDacAttenuation Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacAttenuation
Public Enumeration TypeDacAttenuation
public enum class TypeDacAttenuation
type TypeDacAttenuation
Members
Member name | Value | Description
Value_0_0 | 255 | 0.0
Value_M_0_5 | 254 | -0.5
Value_M_1_0 | 253 | -1.0
Value_M_1_5 | 252 | -1.5
Value_M_2_0 | 251 | -2.0
Value_M_2_5 | 250 | -2.5
Value_M_3_0 | 249 | -3.0
Value_M_3_5 | 248 | -3.5
Value_M_4_0 | 247 | -4.0
Value_M_4_5 | 246 | -4.5
Value_M_5_0 | 245 | -5.0
Value_M_5_5 | 244 | -5.5
Value_M_6_0 | 243 | -6.0
Value_M_6_5 | 242 | -6.5
Value_M_7_0 | 241 | -7.0
Value_M_7_5 | 240 | -7.5
Value_M_8_0 | 239 | -8.0
Value_M_8_5 | 238 | -8.5
Value_M_9_0 | 237 | -9.0
Value_M_9_5 | 236 | -9.5
Value_M_10_0 | 235 | -10.0
Value_M_10_5 | 234 | -10.5
Value_M_11_0 | 233 | -11.0
Value_M_11_5 | 232 | -11.5
Value_M_12_0 | 231 | -12.0
Value_M_12_5 | 230 | -12.5
Value_M_13_0 | 229 | -13.0
Value_M_13_5 | 228 | -13.5
Value_M_14_0 | 227 | -14.0
Value_M_14_5 | 226 | -14.5
Value_M_15_0 | 225 | -15.0
Value_M_15_5 | 224 | -15.5
Value_M_16_0 | 223 | -16.0
Value_M_16_5 | 222 | -16.5
Value_M_17_0 | 221 | -17.0
Value_M_17_5 | 220 | -17.5
Value_M_18_0 | 219 | -18.0
Value_M_18_5 | 218 | -18.5
Value_M_19_0 | 217 | -19.0
Value_M_19_5 | 216 | -19.5
Value_M_20_0 | 215 | -20.0
Value_M_20_5 | 214 | -20.5
Value_M_21_0 | 213 | -21.0
Value_M_21_5 | 212 | -21.5
Value_M_22_0 | 211 | -22.0
Value_M_22_5 | 210 | -22.5
Value_M_23_0 | 209 | -23.0
Value_M_23_5 | 208 | -23.5
Value_M_24_0 | 207 | -24.0
Value_M_24_5 | 206 | -24.5
Value_M_25_0 | 205 | -25.0
Value_M_25_5 | 204 | -25.5
Value_M_26_0 | 203 | -26.0
Value_M_26_5 | 202 | -26.5
Value_M_27_0 | 201 | -27.0
Value_M_27_5 | 200 | -27.5
Value_M_28_0 | 199 | -28.0
Value_M_28_5 | 198 | -28.5
Value_M_29_0 | 197 | -29.0
Value_M_29_5 | 196 | -29.5
Value_M_30_0 | 195 | -30.0
Value_M_30_5 | 194 | -30.5
Value_M_31_0 | 193 | -31.0
Value_M_31_5 | 192 | -31.5
Value_M_32_0 | 191 | -32.0
Value_M_32_5 | 190 | -32.5
Value_M_33_0 | 189 | -33.0
Value_M_33_5 | 188 | -33.5
Value_M_34_0 | 187 | -34.0
Value_M_34_5 | 186 | -34.5
Value_M_35_0 | 185 | -35.0
Value_M_35_5 | 184 | -35.5
Value_M_36_0 | 183 | -36.0
Value_M_36_5 | 182 | -36.5
Value_M_37_0 | 181 | -37.0
Value_M_37_5 | 180 | -37.5
Value_M_38_0 | 179 | -38.0
Value_M_38_5 | 178 | -38.5
Value_M_39_0 | 177 | -39.0
Value_M_39_5 | 176 | -39.5
Value_M_40_0 | 175 | -40.0
Value_M_40_5 | 174 | -40.5
Value_M_41_0 | 173 | -41.0
Value_M_41_5 | 172 | -41.5
Value_M_42_0 | 171 | -42.0
Value_M_42_5 | 170 | -42.5
Value_M_43_0 | 169 | -43.0
Value_M_43_5 | 168 | -43.5
Value_M_44_0 | 167 | -44.0
Value_M_44_5 | 166 | -44.5
Value_M_45_0 | 165 | -45.0
Value_M_45_5 | 164 | -45.5
Value_M_46_0 | 163 | -46.0
Value_M_46_5 | 162 | -46.5
Value_M_47_0 | 161 | -47.0
Value_M_47_5 | 160 | -47.5
Value_M_48_0 | 159 | -48.0
Value_M_48_5 | 158 | -48.5
Value_M_49_0 | 157 | -49.0
Value_M_49_5 | 156 | -49.5
Value_M_50_0 | 155 | -50.0
Value_M_50_5 | 154 | -50.5
Value_M_51_0 | 153 | -51.0
Value_M_51_5 | 152 | -51.5
Value_M_52_0 | 151 | -52.0
Value_M_52_5 | 150 | -52.5
Value_M_53_0 | 149 | -53.0
Value_M_53_5 | 148 | -53.5
Value_M_54_0 | 147 | -54.0
Value_M_54_5 | 146 | -54.5
Value_M_55_0 | 145 | -55.0
Value_M_55_5 | 144 | -55.5
Value_M_56_0 | 143 | -56.0
Value_M_56_5 | 142 | -56.5
Value_M_57_0 | 141 | -57.0
Value_M_57_5 | 140 | -57.5
Value_M_58_0 | 139 | -58.0
Value_M_58_5 | 138 | -58.5
Value_M_59_0 | 137 | -59.0
Value_M_59_5 | 136 | -59.5
Value_M_60_0 | 135 | -60.0
Value_M_60_5 | 134 | -60.5
Value_M_61_0 | 133 | -61.0
Value_M_61_5 | 132 | -61.5
Value_M_62_0 | 131 | -62.0
Value_M_62_5 | 130 | -62.5
Value_M_63_0 | 129 | -63.0
Value_M_63_5 | 128 | -63.5
Value_M_64_0 | 127 | -64.0
Value_M_64_5 | 126 | -64.5
Value_M_65_0 | 125 | -65.0
Value_M_65_5 | 124 | -65.5
Value_M_66_0 | 123 | -66.0
Value_M_66_5 | 122 | -66.5
Value_M_67_0 | 121 | -67.0
Value_M_67_5 | 120 | -67.5
Value_M_68_0 | 119 | -68.0
Value_M_68_5 | 118 | -68.5
Value_M_69_0 | 117 | -69.0
Value_M_69_5 | 116 | -69.5
Value_M_70_0 | 115 | -70.0
Value_M_70_5 | 114 | -70.5
Value_M_71_0 | 113 | -71.0
Value_M_71_5 | 112 | -71.5
Value_M_72_0 | 111 | -72.0
Value_M_72_5 | 110 | -72.5
Value_M_73_0 | 109 | -73.0
Value_M_73_5 | 108 | -73.5
Value_M_74_0 | 107 | -74.0
Value_M_74_5 | 106 | -74.5
Value_M_75_0 | 105 | -75.0
Value_M_75_5 | 104 | -75.5
Value_M_76_0 | 103 | -76.0
Value_M_76_5 | 102 | -76.5
Value_M_77_0 | 101 | -77.0
Value_M_77_5 | 100 | -77.5
Value_M_78_0 | 99 | -78.0
Value_M_78_5 | 98 | -78.5
Value_M_79_0 | 97 | -79.0
Value_M_79_5 | 96 | -79.5
Value_M_80_0 | 95 | -80.0
Value_M_80_5 | 94 | -80.5
Value_M_81_0 | 93 | -81.0
Value_M_81_5 | 92 | -81.5
Value_M_82_0 | 91 | -82.0
Value_M_82_5 | 90 | -82.5
Value_M_83_0 | 89 | -83.0
Value_M_83_5 | 88 | -83.5
Value_M_84_0 | 87 | -84.0
Value_M_84_5 | 86 | -84.5
Value_M_85_0 | 85 | -85.0
Value_M_85_5 | 84 | -85.5
Value_M_86_0 | 83 | -86.0
Value_M_86_5 | 82 | -86.5
Value_M_87_0 | 81 | -87.0
Value_M_87_5 | 80 | -87.5
Value_M_88_0 | 79 | -88.0
Value_M_88_5 | 78 | -88.5
Value_M_89_0 | 77 | -89.0
Value_M_89_5 | 76 | -89.5
Value_M_90_0 | 75 | -90.0
Value_M_90_5 | 74 | -90.5
Value_M_91_0 | 73 | -91.0
Value_M_91_5 | 72 | -91.5
Value_M_92_0 | 71 | -92.0
Value_M_92_5 | 70 | -92.5
Value_M_93_0 | 69 | -93.0
Value_M_93_5 | 68 | -93.5
Value_M_94_0 | 67 | -94.0
Value_M_94_5 | 66 | -94.5
Value_M_95_0 | 65 | -95.0
Value_M_95_5 | 64 | -95.5
Value_M_96_0 | 63 | -96.0
Value_M_96_5 | 62 | -96.5
Value_M_97_0 | 61 | -97.0
Value_M_97_5 | 60 | -97.5
Value_M_98_0 | 59 | -98.0
Value_M_98_5 | 58 | -98.5
Value_M_99_0 | 57 | -99.0
Value_M_99_5 | 56 | -99.5
Value_M_100_0 | 55 | -100.0
Mute | 0 | Mute
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacAttenuationControlDeemp Enumeration

IRD

Pcm3168aTypeDacAttenuationControlDeemp Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacAttenuationControlDeemp
Public Enumeration TypeDacAttenuationControlDeemp
public enum class TypeDacAttenuationControlDeemp
type TypeDacAttenuationControlDeemp
Members
Member name | Value | Description
DACDeEmphasisSamplingRateDisabled | 0 | DAC De-Emphasis Sampling Rate: Disabled
DACDeEmphasisSamplingRate48KHz | 1 | DAC De-Emphasis Sampling Rate: 48 kHz
DACDeEmphasisSamplingRate441KHz | 2 | DAC De-Emphasis Sampling Rate: 44.1 kHz
DACDeEmphasisSamplingRate32KHz | 3 | DAC De-Emphasis Sampling Rate: 32 kHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacAttenuationControlMode Enumeration

IRD

Pcm3168aTypeDacAttenuationControlMode Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacAttenuationControlMode
Public Enumeration TypeDacAttenuationControlMode
public enum class TypeDacAttenuationControlMode
type TypeDacAttenuationControlMode
Members
Member name | Value | Description
DACAttenuationModeEachChannelWithIndependentData | 0 | DAC Attenuation Mode: Each Channel With Independent Data
DACAttenuationModeAllChannelsWithInependentPresetData | 1 | DAC Attenuation Mode: All Channels With Inependent Preset Data
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacAttenuationControlSpeed Enumeration

IRD

Pcm3168aTypeDacAttenuationControlSpeed Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacAttenuationControlSpeed
Public Enumeration TypeDacAttenuationControlSpeed
public enum class TypeDacAttenuationControlSpeed
type TypeDacAttenuationControlSpeed
Members
Member name | Value | Description
DACAttenuationSpeedNX2048Fs | 0 | DAC Attenuation Speed: N x (2048 / Fs)
DACAttenuationSpeedNX4096Fs | 1 | DAC Attenuation Speed: N x (4096 / Fs)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacAttenuationControlZfunc Enumeration

IRD

Pcm3168aTypeDacAttenuationControlZfunc Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacAttenuationControlZfunc
Public Enumeration TypeDacAttenuationControlZfunc
public enum class TypeDacAttenuationControlZfunc
type TypeDacAttenuationControlZfunc
Members
Member name | Value | Description
DAC18ZeroInputDetectWithANDLogic | 0 | DAC1-8 Zero Input Detect With AND Logic
DAC18ZeroInputDetectWithORLogic | 1 | DAC1-8 Zero Input Detect With OR Logic
DAC16ZeroInputDetectWithANDLogic | 2 | DAC1-6 Zero Input Detect With AND Logic
DAC16ZeroInputDetectWithORLogic | 3 | DAC1-6 Zero Input Detect With OR Logic
DAC78ZeroInputDetectWithANDLogic | 4 | DAC7/8 Zero Input Detect With AND Logic
DAC78ZeroInputDetectWithORLogic | 5 | DAC7/8 Zero Input Detect With OR Logic
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacAttenuationControlZpol Enumeration

IRD

Pcm3168aTypeDacAttenuationControlZpol Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacAttenuationControlZpol
Public Enumeration TypeDacAttenuationControlZpol
public enum class TypeDacAttenuationControlZpol
type TypeDacAttenuationControlZpol
Members
Member name | Value | Description
DACZeroFlagPolarityHighForZeroDetect | 0 | DAC Zero Flag Polarity: High For Zero Detect
DACZeroFlagPolarityLowForZeroDetect | 1 | DAC Zero Flag Polarity: Low For Zero Detect
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacModeControlRegReset Enumeration

IRD

Pcm3168aTypeDacModeControlRegReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacModeControlRegReset
Public Enumeration TypeDacModeControlRegReset
public enum class TypeDacModeControlRegReset
type TypeDacModeControlRegReset
Members
Member name | Value | Description
ModeControlRegisterResetExecution | 0 | Mode Control Register Reset: Execution
ModeControlRegisterResetNormalOperation | 1 | Mode Control Register Reset: Normal Operation
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacModeControlSampling Enumeration

IRD

Pcm3168aTypeDacModeControlSampling Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacModeControlSampling
Public Enumeration TypeDacModeControlSampling
public enum class TypeDacModeControlSampling
type TypeDacModeControlSampling
Members
Member name | Value | Description
DACSamplingModeAuto | 0 | DAC Sampling Mode: Auto
DACSamplingModeSingleRate | 1 | DAC Sampling Mode: Single Rate
DACSamplingModeDualRate | 2 | DAC Sampling Mode: Dual Rate
DACSamplingModeQuadRate | 3 | DAC Sampling Mode: Quad Rate
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacModeControlSysReset Enumeration

IRD

Pcm3168aTypeDacModeControlSysReset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacModeControlSysReset
Public Enumeration TypeDacModeControlSysReset
public enum class TypeDacModeControlSysReset
type TypeDacModeControlSysReset
Members
Member name | Value | Description
ADCAndDACSystemResetReSynchronization | 0 | ADC And DAC System Reset: Re-Synchronization
ADCAndDACSystemResetNormalOperation | 1 | ADC And DAC System Reset: Normal Operation
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacModeSelectFormat Enumeration

IRD

Pcm3168aTypeDacModeSelectFormat Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacModeSelectFormat
Public Enumeration TypeDacModeSelectFormat
public enum class TypeDacModeSelectFormat
type TypeDacModeSelectFormat
Members
Member name | Value | Description
DACAudioInterfaceFormat24BitI2S | 0 | DAC Audio Interface Format: 24 Bit I2S
DACAudioInterfaceFormat24BitLeftJustified | 1 | DAC Audio Interface Format: 24 Bit Left-Justified
DACAudioInterfaceFormat24BitRightJustified | 2 | DAC Audio Interface Format: 24 Bit Right-Justified
DACAudioInterfaceFormat16BitRightJustified | 3 | DAC Audio Interface Format: 16 Bit Right-Justified
DACAudioInterfaceFormat24BitI2SDSP | 4 | DAC Audio Interface Format: 24 Bit I2S DSP
DACAudioInterfaceFormat24BitLeftJustifiedDSP | 5 | DAC Audio Interface Format: 24 Bit Left-Justified DSP
DACAudioInterfaceFormat24BitI2STDM | 6 | DAC Audio Interface Format: 24 Bit I2S TDM
DACAudioInterfaceFormat24BitLeftJustifiedTDM | 7 | DAC Audio Interface Format: 24 Bit Left-Justified TDM
DACAudioInterfaceFormat24BitHighSpeedI2STDM | 8 | DAC Audio Interface Format: 24 Bit High-Speed I2S TDM
DACAudioInterfaceFormat24BitHighSpeedLeftJustifiedTDM | 9 | DAC Audio Interface Format: 24 Bit High-Speed Left-Justified TDM
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacModeSelectMs Enumeration

IRD

Pcm3168aTypeDacModeSelectMs Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacModeSelectMs
Public Enumeration TypeDacModeSelectMs
public enum class TypeDacModeSelectMs
type TypeDacModeSelectMs
Members
Member name | Value | Description
DACSlaveMode | 0 | DAC Slave Mode
DACMasterMode768Fs | 1 | DAC Master Mode: 768 Fs
DACMasterMode512Fs | 2 | DAC Master Mode: 512 Fs
DACMasterMode384Fs | 3 | DAC Master Mode: 384 Fs
DACMasterMode256Fs | 4 | DAC Master Mode: 256 Fs
DACMasterMode192Fs | 5 | DAC Master Mode: 192 Fs
DACMasterMode128Fs | 6 | DAC Master Mode: 128 Fs
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacModeSelectPower Enumeration

IRD

Pcm3168aTypeDacModeSelectPower Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacModeSelectPower
Public Enumeration TypeDacModeSelectPower
public enum class TypeDacModeSelectPower
type TypeDacModeSelectPower
Members
Member name | Value | Description
DACPowerSaveModeEnabled | 0 | DAC Power-Save Mode: Enabled
DACPowerSaveModeDisabled | 1 | DAC Power-Save Mode: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacMuteDac1 Enumeration

IRD

Pcm3168aTypeDacMuteDac1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacMuteDac1
Public Enumeration TypeDacMuteDac1
public enum class TypeDacMuteDac1
type TypeDacMuteDac1
Members
Member name | Value | Description
DAC1SoftMuteDisabled | 0 | DAC1 Soft Mute: Disabled
DAC1SoftMuteEnabled | 1 | DAC1 Soft Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacMuteDac2 Enumeration

IRD

Pcm3168aTypeDacMuteDac2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacMuteDac2
Public Enumeration TypeDacMuteDac2
public enum class TypeDacMuteDac2
type TypeDacMuteDac2
Members
Member name | Value | Description
DAC2SoftMuteDisabled | 0 | DAC2 Soft Mute: Disabled
DAC2SoftMuteEnabled | 1 | DAC2 Soft Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacMuteDac3 Enumeration

IRD

Pcm3168aTypeDacMuteDac3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacMuteDac3
Public Enumeration TypeDacMuteDac3
public enum class TypeDacMuteDac3
type TypeDacMuteDac3
Members
Member name | Value | Description
DAC3SoftMuteDisabled | 0 | DAC3 Soft Mute: Disabled
DAC3SoftMuteEnabled | 1 | DAC3 Soft Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacMuteDac4 Enumeration

IRD

Pcm3168aTypeDacMuteDac4 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacMuteDac4
Public Enumeration TypeDacMuteDac4
public enum class TypeDacMuteDac4
type TypeDacMuteDac4
Members
Member name | Value | Description
DAC4SoftMuteDisabled | 0 | DAC4 Soft Mute: Disabled
DAC4SoftMuteEnabled | 1 | DAC4 Soft Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacMuteDac5 Enumeration

IRD

Pcm3168aTypeDacMuteDac5 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacMuteDac5
Public Enumeration TypeDacMuteDac5
public enum class TypeDacMuteDac5
type TypeDacMuteDac5
Members
Member name | Value | Description
DAC5SoftMuteDisabled | 0 | DAC5 Soft Mute: Disabled
DAC5SoftMuteEnabled | 1 | DAC5 Soft Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacMuteDac6 Enumeration

IRD

Pcm3168aTypeDacMuteDac6 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacMuteDac6
Public Enumeration TypeDacMuteDac6
public enum class TypeDacMuteDac6
type TypeDacMuteDac6
Members
Member name | Value | Description
DAC6SoftMuteDisabled | 0 | DAC6 Soft Mute: Disabled
DAC6SoftMuteEnabled | 1 | DAC6 Soft Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacMuteDac7 Enumeration

IRD

Pcm3168aTypeDacMuteDac7 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacMuteDac7
Public Enumeration TypeDacMuteDac7
public enum class TypeDacMuteDac7
type TypeDacMuteDac7
Members
Member name | Value | Description
DAC7SoftMuteDisabled | 0 | DAC7 Soft Mute: Disabled
DAC7SoftMuteEnabled | 1 | DAC7 Soft Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacMuteDac8 Enumeration

IRD

Pcm3168aTypeDacMuteDac8 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacMuteDac8
Public Enumeration TypeDacMuteDac8
public enum class TypeDacMuteDac8
type TypeDacMuteDac8
Members
Member name | Value | Description
DAC8SoftMuteDisabled | 0 | DAC8 Soft Mute: Disabled
DAC8SoftMuteEnabled | 1 | DAC8 Soft Mute: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacOperationFilt12 Enumeration

IRD

Pcm3168aTypeDacOperationFilt12 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacOperationFilt12
Public Enumeration TypeDacOperationFilt12
public enum class TypeDacOperationFilt12
type TypeDacOperationFilt12
Members
Member name | Value | Description
DAC12DigitalFilterSharpRollOff | 0 | DAC1/2 Digital Filter: Sharp Roll-Off
DAC12DigitalFilterSlowRollOff | 1 | DAC1/2 Digital Filter: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacOperationFilt34 Enumeration

IRD

Pcm3168aTypeDacOperationFilt34 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacOperationFilt34
Public Enumeration TypeDacOperationFilt34
public enum class TypeDacOperationFilt34
type TypeDacOperationFilt34
Members
Member name | Value | Description
DAC34DigitalFilterSharpRollOff | 0 | DAC3/4 Digital Filter: Sharp Roll-Off
DAC34DigitalFilterSlowRollOff | 1 | DAC3/4 Digital Filter: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacOperationFilt56 Enumeration

IRD

Pcm3168aTypeDacOperationFilt56 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacOperationFilt56
Public Enumeration TypeDacOperationFilt56
public enum class TypeDacOperationFilt56
type TypeDacOperationFilt56
Members
Member name | Value | Description
DAC56DigitalFilterSharpRollOff | 0 | DAC5/6 Digital Filter: Sharp Roll-Off
DAC56DigitalFilterSlowRollOff | 1 | DAC5/6 Digital Filter: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacOperationFilt78 Enumeration

IRD

Pcm3168aTypeDacOperationFilt78 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacOperationFilt78
Public Enumeration TypeDacOperationFilt78
public enum class TypeDacOperationFilt78
type TypeDacOperationFilt78
Members
Member name | Value | Description
DAC78DigitalFilterSharpRollOff | 0 | DAC7/8 Digital Filter: Sharp Roll-Off
DAC78DigitalFilterSlowRollOff | 1 | DAC7/8 Digital Filter: Slow Roll-Off
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacOperationOp12 Enumeration

IRD

Pcm3168aTypeDacOperationOp12 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacOperationOp12
Public Enumeration TypeDacOperationOp12
public enum class TypeDacOperationOp12
type TypeDacOperationOp12
Members
Member name | Value | Description
DAC12OperationNormal | 0 | DAC1/2 Operation: Normal
DAC12OperationDisabledWithOrWithoutPowerSave | 1 | DAC1/2 Operation: Disabled (With Or Without Power-Save)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacOperationOp34 Enumeration

IRD

Pcm3168aTypeDacOperationOp34 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacOperationOp34
Public Enumeration TypeDacOperationOp34
public enum class TypeDacOperationOp34
type TypeDacOperationOp34
Members
Member name | Value | Description
DAC34OperationNormal | 0 | DAC3/4 Operation: Normal
DAC34OperationDisabledWithOrWithoutPowerSave | 1 | DAC3/4 Operation: Disabled (With Or Without Power-Save)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacOperationOp56 Enumeration

IRD

Pcm3168aTypeDacOperationOp56 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacOperationOp56
Public Enumeration TypeDacOperationOp56
public enum class TypeDacOperationOp56
type TypeDacOperationOp56
Members
Member name | Value | Description
DAC56OperationNormal | 0 | DAC5/6 Operation: Normal
DAC56OperationDisabledWithOrWithoutPowerSave | 1 | DAC5/6 Operation: Disabled (With Or Without Power-Save)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacOperationOp78 Enumeration

IRD

Pcm3168aTypeDacOperationOp78 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacOperationOp78
Public Enumeration TypeDacOperationOp78
public enum class TypeDacOperationOp78
type TypeDacOperationOp78
Members
Member name | Value | Description
DAC78OperationNormal | 0 | DAC7/8 Operation: Normal
DAC78OperationDisabledWithOrWithoutPowerSave | 1 | DAC7/8 Operation: Disabled (With Or Without Power-Save)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacPhaseDac1 Enumeration

IRD

Pcm3168aTypeDacPhaseDac1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacPhaseDac1
Public Enumeration TypeDacPhaseDac1
public enum class TypeDacPhaseDac1
type TypeDacPhaseDac1
Members
Member name | Value | Description
DAC1OutputPhaseNormal | 0 | DAC1 Output Phase: Normal
DAC1OutputPhaseInverted | 1 | DAC1 Output Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacPhaseDac2 Enumeration

IRD

Pcm3168aTypeDacPhaseDac2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacPhaseDac2
Public Enumeration TypeDacPhaseDac2
public enum class TypeDacPhaseDac2
type TypeDacPhaseDac2
Members
Member name | Value | Description
DAC2OutputPhaseNormal | 0 | DAC2 Output Phase: Normal
DAC2OutputPhaseInverted | 1 | DAC2 Output Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacPhaseDac3 Enumeration

IRD

Pcm3168aTypeDacPhaseDac3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacPhaseDac3
Public Enumeration TypeDacPhaseDac3
public enum class TypeDacPhaseDac3
type TypeDacPhaseDac3
Members
Member name | Value | Description
DAC3OutputPhaseNormal | 0 | DAC3 Output Phase: Normal
DAC3OutputPhaseInverted | 1 | DAC3 Output Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacPhaseDac4 Enumeration

IRD

Pcm3168aTypeDacPhaseDac4 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacPhaseDac4
Public Enumeration TypeDacPhaseDac4
public enum class TypeDacPhaseDac4
type TypeDacPhaseDac4
Members
Member name | Value | Description
DAC4OutputPhaseNormal | 0 | DAC4 Output Phase: Normal
DAC4OutputPhaseInverted | 1 | DAC4 Output Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacPhaseDac5 Enumeration

IRD

Pcm3168aTypeDacPhaseDac5 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacPhaseDac5
Public Enumeration TypeDacPhaseDac5
public enum class TypeDacPhaseDac5
type TypeDacPhaseDac5
Members
Member name | Value | Description
DAC5OutputPhaseNormal | 0 | DAC5 Output Phase: Normal
DAC5OutputPhaseInverted | 1 | DAC5 Output Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacPhaseDac6 Enumeration

IRD

Pcm3168aTypeDacPhaseDac6 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacPhaseDac6
Public Enumeration TypeDacPhaseDac6
public enum class TypeDacPhaseDac6
type TypeDacPhaseDac6
Members
Member name | Value | Description
DAC6OutputPhaseNormal | 0 | DAC6 Output Phase: Normal
DAC6OutputPhaseInverted | 1 | DAC6 Output Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacPhaseDac7 Enumeration

IRD

Pcm3168aTypeDacPhaseDac7 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacPhaseDac7
Public Enumeration TypeDacPhaseDac7
public enum class TypeDacPhaseDac7
type TypeDacPhaseDac7
Members
Member name | Value | Description
DAC7OutputPhaseNormal | 0 | DAC7 Output Phase: Normal
DAC7OutputPhaseInverted | 1 | DAC7 Output Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacPhaseDac8 Enumeration

IRD

Pcm3168aTypeDacPhaseDac8 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacPhaseDac8
Public Enumeration TypeDacPhaseDac8
public enum class TypeDacPhaseDac8
type TypeDacPhaseDac8
Members
Member name | Value | Description
DAC8OutputPhaseNormal | 0 | DAC8 Output Phase: Normal
DAC8OutputPhaseInverted | 1 | DAC8 Output Phase: Inverted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacZeroFlagDac1 Enumeration

IRD

Pcm3168aTypeDacZeroFlagDac1 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacZeroFlagDac1
Public Enumeration TypeDacZeroFlagDac1
public enum class TypeDacZeroFlagDac1
type TypeDacZeroFlagDac1
Members
Member name | Value | Description
DAC1ZeroInputNotDetected | 0 | DAC1 Zero Input: Not Detected
DAC1ZeroInputDetected | 1 | DAC1 Zero Input: Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacZeroFlagDac2 Enumeration

IRD

Pcm3168aTypeDacZeroFlagDac2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacZeroFlagDac2
Public Enumeration TypeDacZeroFlagDac2
public enum class TypeDacZeroFlagDac2
type TypeDacZeroFlagDac2
Members
Member name | Value | Description
DAC2ZeroInputNotDetected | 0 | DAC2 Zero Input: Not Detected
DAC2ZeroInputDetected | 1 | DAC2 Zero Input: Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacZeroFlagDac3 Enumeration

IRD

Pcm3168aTypeDacZeroFlagDac3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacZeroFlagDac3
Public Enumeration TypeDacZeroFlagDac3
public enum class TypeDacZeroFlagDac3
type TypeDacZeroFlagDac3
Members
Member name | Value | Description
DAC3ZeroInputNotDetected | 0 | DAC3 Zero Input: Not Detected
DAC3ZeroInputDetected | 1 | DAC3 Zero Input: Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacZeroFlagDac4 Enumeration

IRD

Pcm3168aTypeDacZeroFlagDac4 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacZeroFlagDac4
Public Enumeration TypeDacZeroFlagDac4
public enum class TypeDacZeroFlagDac4
type TypeDacZeroFlagDac4
Members
Member name | Value | Description
DAC4ZeroInputNotDetected | 0 | DAC4 Zero Input: Not Detected
DAC4ZeroInputDetected | 1 | DAC4 Zero Input: Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacZeroFlagDac5 Enumeration

IRD

Pcm3168aTypeDacZeroFlagDac5 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacZeroFlagDac5
Public Enumeration TypeDacZeroFlagDac5
public enum class TypeDacZeroFlagDac5
type TypeDacZeroFlagDac5
Members
Member name | Value | Description
DAC5ZeroInputNotDetected | 0 | DAC5 Zero Input: Not Detected
DAC5ZeroInputDetected | 1 | DAC5 Zero Input: Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacZeroFlagDac6 Enumeration

IRD

Pcm3168aTypeDacZeroFlagDac6 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacZeroFlagDac6
Public Enumeration TypeDacZeroFlagDac6
public enum class TypeDacZeroFlagDac6
type TypeDacZeroFlagDac6
Members
Member name | Value | Description
DAC6ZeroInputNotDetected | 0 | DAC6 Zero Input: Not Detected
DAC6ZeroInputDetected | 1 | DAC6 Zero Input: Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacZeroFlagDac7 Enumeration

IRD

Pcm3168aTypeDacZeroFlagDac7 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacZeroFlagDac7
Public Enumeration TypeDacZeroFlagDac7
public enum class TypeDacZeroFlagDac7
type TypeDacZeroFlagDac7
Members
Member name | Value | Description
DAC7ZeroInputNotDetected | 0 | DAC7 Zero Input: Not Detected
DAC7ZeroInputDetected | 1 | DAC7 Zero Input: Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Pcm3168a.TypeDacZeroFlagDac8 Enumeration

IRD

Pcm3168aTypeDacZeroFlagDac8 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeDacZeroFlagDac8
Public Enumeration TypeDacZeroFlagDac8
public enum class TypeDacZeroFlagDac8
type TypeDacZeroFlagDac8
Members
Member name | Value | Description
DAC8ZeroInputNotDetected | 0 | DAC8 Zero Input: Not Detected
DAC8ZeroInputDetected | 1 | DAC8 Zero Input: Detected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6408 Class

Texas Instruments: TCA 6408
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsTca6408

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Tca6408
Public Class Tca6408
public ref class Tca6408
type Tca6408 =  class end

The Tca6408 type exposes the following members.

Constructors
 | Name | Description
Public method | Tca6408 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC03 | Configuration (C-03)
Public property | ConfigurationC04 | Configuration (C-04)
Public property | ConfigurationC05 | Configuration (C-05)
Public property | ConfigurationC06 | Configuration (C-06)
Public property | ConfigurationC07 | Configuration (C-07)
Public property | InputI00 | Input (I-00)
Public property | InputI01 | Input (I-01)
Public property | InputI02 | Input (I-02)
Public property | InputI03 | Input (I-03)
Public property | InputI04 | Input (I-04)
Public property | InputI05 | Input (I-05)
Public property | InputI06 | Input (I-06)
Public property | InputI07 | Input (I-07)
Public property | OutputO00 | Output (O-00)
Public property | OutputO01 | Output (O-01)
Public property | OutputO02 | Output (O-02)
Public property | OutputO03 | Output (O-03)
Public property | OutputO04 | Output (O-04)
Public property | OutputO05 | Output (O-05)
Public property | OutputO06 | Output (O-06)
Public property | OutputO07 | Output (O-07)
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Public property | PolarityInversionP04 | Polarity Inversion (P-04)
Public property | PolarityInversionP05 | Polarity Inversion (P-05)
Public property | PolarityInversionP06 | Polarity Inversion (P-06)
Public property | PolarityInversionP07 | Polarity Inversion (P-07)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Voltage 8-Bit I2C And SMBus I/O Expander With Interrupt Output, Reset, And Configuration Registers
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6408 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Tca6408(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Tca6408

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408 Properties

The Tca6408 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC03 | Configuration (C-03)
Public property | ConfigurationC04 | Configuration (C-04)
Public property | ConfigurationC05 | Configuration (C-05)
Public property | ConfigurationC06 | Configuration (C-06)
Public property | ConfigurationC07 | Configuration (C-07)
Public property | InputI00 | Input (I-00)
Public property | InputI01 | Input (I-01)
Public property | InputI02 | Input (I-02)
Public property | InputI03 | Input (I-03)
Public property | InputI04 | Input (I-04)
Public property | InputI05 | Input (I-05)
Public property | InputI06 | Input (I-06)
Public property | InputI07 | Input (I-07)
Public property | OutputO00 | Output (O-00)
Public property | OutputO01 | Output (O-01)
Public property | OutputO02 | Output (O-02)
Public property | OutputO03 | Output (O-03)
Public property | OutputO04 | Output (O-04)
Public property | OutputO05 | Output (O-05)
Public property | OutputO06 | Output (O-06)
Public property | OutputO07 | Output (O-07)
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Public property | PolarityInversionP04 | Polarity Inversion (P-04)
Public property | PolarityInversionP05 | Polarity Inversion (P-05)
Public property | PolarityInversionP06 | Polarity Inversion (P-06)
Public property | PolarityInversionP07 | Polarity Inversion (P-07)
Top
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.AutoFlush Property

IRD

Tca6408AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.ConfigurationC00 Property

IRD

Tca6408ConfigurationC00 Property

Configuration (C-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeConfiguration ConfigurationC00 { get; set; }
Public Property ConfigurationC00 As Tca6408TypeConfiguration
    Get
    Set
public:
property Tca6408TypeConfiguration ConfigurationC00 {
    Tca6408TypeConfiguration get ();
    void set (Tca6408TypeConfiguration value);
}
member ConfigurationC00 : Tca6408TypeConfiguration with get, set

Property Value

Type: Tca6408TypeConfiguration
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.ConfigurationC01 Property

IRD

Tca6408ConfigurationC01 Property

Configuration (C-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeConfiguration ConfigurationC01 { get; set; }
Public Property ConfigurationC01 As Tca6408TypeConfiguration
    Get
    Set
public:
property Tca6408TypeConfiguration ConfigurationC01 {
    Tca6408TypeConfiguration get ();
    void set (Tca6408TypeConfiguration value);
}
member ConfigurationC01 : Tca6408TypeConfiguration with get, set

Property Value

Type: Tca6408TypeConfiguration
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.ConfigurationC02 Property

IRD

Tca6408ConfigurationC02 Property

Configuration (C-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeConfiguration ConfigurationC02 { get; set; }
Public Property ConfigurationC02 As Tca6408TypeConfiguration
    Get
    Set
public:
property Tca6408TypeConfiguration ConfigurationC02 {
    Tca6408TypeConfiguration get ();
    void set (Tca6408TypeConfiguration value);
}
member ConfigurationC02 : Tca6408TypeConfiguration with get, set

Property Value

Type: Tca6408TypeConfiguration
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.ConfigurationC03 Property

IRD

Tca6408ConfigurationC03 Property

Configuration (C-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeConfiguration ConfigurationC03 { get; set; }
Public Property ConfigurationC03 As Tca6408TypeConfiguration
    Get
    Set
public:
property Tca6408TypeConfiguration ConfigurationC03 {
    Tca6408TypeConfiguration get ();
    void set (Tca6408TypeConfiguration value);
}
member ConfigurationC03 : Tca6408TypeConfiguration with get, set

Property Value

Type: Tca6408TypeConfiguration
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.ConfigurationC04 Property

IRD

Tca6408ConfigurationC04 Property

Configuration (C-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeConfiguration ConfigurationC04 { get; set; }
Public Property ConfigurationC04 As Tca6408TypeConfiguration
    Get
    Set
public:
property Tca6408TypeConfiguration ConfigurationC04 {
    Tca6408TypeConfiguration get ();
    void set (Tca6408TypeConfiguration value);
}
member ConfigurationC04 : Tca6408TypeConfiguration with get, set

Property Value

Type: Tca6408TypeConfiguration
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.ConfigurationC05 Property

IRD

Tca6408ConfigurationC05 Property

Configuration (C-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeConfiguration ConfigurationC05 { get; set; }
Public Property ConfigurationC05 As Tca6408TypeConfiguration
    Get
    Set
public:
property Tca6408TypeConfiguration ConfigurationC05 {
    Tca6408TypeConfiguration get ();
    void set (Tca6408TypeConfiguration value);
}
member ConfigurationC05 : Tca6408TypeConfiguration with get, set

Property Value

Type: Tca6408TypeConfiguration
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.ConfigurationC06 Property

IRD

Tca6408ConfigurationC06 Property

Configuration (C-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeConfiguration ConfigurationC06 { get; set; }
Public Property ConfigurationC06 As Tca6408TypeConfiguration
    Get
    Set
public:
property Tca6408TypeConfiguration ConfigurationC06 {
    Tca6408TypeConfiguration get ();
    void set (Tca6408TypeConfiguration value);
}
member ConfigurationC06 : Tca6408TypeConfiguration with get, set

Property Value

Type: Tca6408TypeConfiguration
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.ConfigurationC07 Property

IRD

Tca6408ConfigurationC07 Property

Configuration (C-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeConfiguration ConfigurationC07 { get; set; }
Public Property ConfigurationC07 As Tca6408TypeConfiguration
    Get
    Set
public:
property Tca6408TypeConfiguration ConfigurationC07 {
    Tca6408TypeConfiguration get ();
    void set (Tca6408TypeConfiguration value);
}
member ConfigurationC07 : Tca6408TypeConfiguration with get, set

Property Value

Type: Tca6408TypeConfiguration
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.InputI00 Property

IRD

Tca6408InputI00 Property

Input (I-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeLevel InputI00 { get; }
Public ReadOnly Property InputI00 As Tca6408TypeLevel
    Get
public:
property Tca6408TypeLevel InputI00 {
    Tca6408TypeLevel get ();
}
member InputI00 : Tca6408TypeLevel with get

Property Value

Type: Tca6408TypeLevel
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.InputI01 Property

IRD

Tca6408InputI01 Property

Input (I-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeLevel InputI01 { get; }
Public ReadOnly Property InputI01 As Tca6408TypeLevel
    Get
public:
property Tca6408TypeLevel InputI01 {
    Tca6408TypeLevel get ();
}
member InputI01 : Tca6408TypeLevel with get

Property Value

Type: Tca6408TypeLevel
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.InputI02 Property

IRD

Tca6408InputI02 Property

Input (I-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeLevel InputI02 { get; }
Public ReadOnly Property InputI02 As Tca6408TypeLevel
    Get
public:
property Tca6408TypeLevel InputI02 {
    Tca6408TypeLevel get ();
}
member InputI02 : Tca6408TypeLevel with get

Property Value

Type: Tca6408TypeLevel
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.InputI03 Property

IRD

Tca6408InputI03 Property

Input (I-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeLevel InputI03 { get; }
Public ReadOnly Property InputI03 As Tca6408TypeLevel
    Get
public:
property Tca6408TypeLevel InputI03 {
    Tca6408TypeLevel get ();
}
member InputI03 : Tca6408TypeLevel with get

Property Value

Type: Tca6408TypeLevel
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.InputI04 Property

IRD

Tca6408InputI04 Property

Input (I-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeLevel InputI04 { get; }
Public ReadOnly Property InputI04 As Tca6408TypeLevel
    Get
public:
property Tca6408TypeLevel InputI04 {
    Tca6408TypeLevel get ();
}
member InputI04 : Tca6408TypeLevel with get

Property Value

Type: Tca6408TypeLevel
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.InputI05 Property

IRD

Tca6408InputI05 Property

Input (I-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeLevel InputI05 { get; }
Public ReadOnly Property InputI05 As Tca6408TypeLevel
    Get
public:
property Tca6408TypeLevel InputI05 {
    Tca6408TypeLevel get ();
}
member InputI05 : Tca6408TypeLevel with get

Property Value

Type: Tca6408TypeLevel
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.InputI06 Property

IRD

Tca6408InputI06 Property

Input (I-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeLevel InputI06 { get; }
Public ReadOnly Property InputI06 As Tca6408TypeLevel
    Get
public:
property Tca6408TypeLevel InputI06 {
    Tca6408TypeLevel get ();
}
member InputI06 : Tca6408TypeLevel with get

Property Value

Type: Tca6408TypeLevel
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.InputI07 Property

IRD

Tca6408InputI07 Property

Input (I-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeLevel InputI07 { get; }
Public ReadOnly Property InputI07 As Tca6408TypeLevel
    Get
public:
property Tca6408TypeLevel InputI07 {
    Tca6408TypeLevel get ();
}
member InputI07 : Tca6408TypeLevel with get

Property Value

Type: Tca6408TypeLevel
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.OutputO00 Property

IRD

Tca6408OutputO00 Property

Output (O-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeLevel OutputO00 { get; set; }
Public Property OutputO00 As Tca6408TypeLevel
    Get
    Set
public:
property Tca6408TypeLevel OutputO00 {
    Tca6408TypeLevel get ();
    void set (Tca6408TypeLevel value);
}
member OutputO00 : Tca6408TypeLevel with get, set

Property Value

Type: Tca6408TypeLevel
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.OutputO01 Property

IRD

Tca6408OutputO01 Property

Output (O-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeLevel OutputO01 { get; set; }
Public Property OutputO01 As Tca6408TypeLevel
    Get
    Set
public:
property Tca6408TypeLevel OutputO01 {
    Tca6408TypeLevel get ();
    void set (Tca6408TypeLevel value);
}
member OutputO01 : Tca6408TypeLevel with get, set

Property Value

Type: Tca6408TypeLevel
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.OutputO02 Property

IRD

Tca6408OutputO02 Property

Output (O-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeLevel OutputO02 { get; set; }
Public Property OutputO02 As Tca6408TypeLevel
    Get
    Set
public:
property Tca6408TypeLevel OutputO02 {
    Tca6408TypeLevel get ();
    void set (Tca6408TypeLevel value);
}
member OutputO02 : Tca6408TypeLevel with get, set

Property Value

Type: Tca6408TypeLevel
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.OutputO03 Property

IRD

Tca6408OutputO03 Property

Output (O-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeLevel OutputO03 { get; set; }
Public Property OutputO03 As Tca6408TypeLevel
    Get
    Set
public:
property Tca6408TypeLevel OutputO03 {
    Tca6408TypeLevel get ();
    void set (Tca6408TypeLevel value);
}
member OutputO03 : Tca6408TypeLevel with get, set

Property Value

Type: Tca6408TypeLevel
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.OutputO04 Property

IRD

Tca6408OutputO04 Property

Output (O-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeLevel OutputO04 { get; set; }
Public Property OutputO04 As Tca6408TypeLevel
    Get
    Set
public:
property Tca6408TypeLevel OutputO04 {
    Tca6408TypeLevel get ();
    void set (Tca6408TypeLevel value);
}
member OutputO04 : Tca6408TypeLevel with get, set

Property Value

Type: Tca6408TypeLevel
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.OutputO05 Property

IRD

Tca6408OutputO05 Property

Output (O-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeLevel OutputO05 { get; set; }
Public Property OutputO05 As Tca6408TypeLevel
    Get
    Set
public:
property Tca6408TypeLevel OutputO05 {
    Tca6408TypeLevel get ();
    void set (Tca6408TypeLevel value);
}
member OutputO05 : Tca6408TypeLevel with get, set

Property Value

Type: Tca6408TypeLevel
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.OutputO06 Property

IRD

Tca6408OutputO06 Property

Output (O-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeLevel OutputO06 { get; set; }
Public Property OutputO06 As Tca6408TypeLevel
    Get
    Set
public:
property Tca6408TypeLevel OutputO06 {
    Tca6408TypeLevel get ();
    void set (Tca6408TypeLevel value);
}
member OutputO06 : Tca6408TypeLevel with get, set

Property Value

Type: Tca6408TypeLevel
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.OutputO07 Property

IRD

Tca6408OutputO07 Property

Output (O-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypeLevel OutputO07 { get; set; }
Public Property OutputO07 As Tca6408TypeLevel
    Get
    Set
public:
property Tca6408TypeLevel OutputO07 {
    Tca6408TypeLevel get ();
    void set (Tca6408TypeLevel value);
}
member OutputO07 : Tca6408TypeLevel with get, set

Property Value

Type: Tca6408TypeLevel
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.PolarityInversionP00 Property

IRD

Tca6408PolarityInversionP00 Property

Polarity Inversion (P-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypePolarity PolarityInversionP00 { get; set; }
Public Property PolarityInversionP00 As Tca6408TypePolarity
    Get
    Set
public:
property Tca6408TypePolarity PolarityInversionP00 {
    Tca6408TypePolarity get ();
    void set (Tca6408TypePolarity value);
}
member PolarityInversionP00 : Tca6408TypePolarity with get, set

Property Value

Type: Tca6408TypePolarity
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.PolarityInversionP01 Property

IRD

Tca6408PolarityInversionP01 Property

Polarity Inversion (P-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypePolarity PolarityInversionP01 { get; set; }
Public Property PolarityInversionP01 As Tca6408TypePolarity
    Get
    Set
public:
property Tca6408TypePolarity PolarityInversionP01 {
    Tca6408TypePolarity get ();
    void set (Tca6408TypePolarity value);
}
member PolarityInversionP01 : Tca6408TypePolarity with get, set

Property Value

Type: Tca6408TypePolarity
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.PolarityInversionP02 Property

IRD

Tca6408PolarityInversionP02 Property

Polarity Inversion (P-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypePolarity PolarityInversionP02 { get; set; }
Public Property PolarityInversionP02 As Tca6408TypePolarity
    Get
    Set
public:
property Tca6408TypePolarity PolarityInversionP02 {
    Tca6408TypePolarity get ();
    void set (Tca6408TypePolarity value);
}
member PolarityInversionP02 : Tca6408TypePolarity with get, set

Property Value

Type: Tca6408TypePolarity
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.PolarityInversionP03 Property

IRD

Tca6408PolarityInversionP03 Property

Polarity Inversion (P-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypePolarity PolarityInversionP03 { get; set; }
Public Property PolarityInversionP03 As Tca6408TypePolarity
    Get
    Set
public:
property Tca6408TypePolarity PolarityInversionP03 {
    Tca6408TypePolarity get ();
    void set (Tca6408TypePolarity value);
}
member PolarityInversionP03 : Tca6408TypePolarity with get, set

Property Value

Type: Tca6408TypePolarity
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.PolarityInversionP04 Property

IRD

Tca6408PolarityInversionP04 Property

Polarity Inversion (P-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypePolarity PolarityInversionP04 { get; set; }
Public Property PolarityInversionP04 As Tca6408TypePolarity
    Get
    Set
public:
property Tca6408TypePolarity PolarityInversionP04 {
    Tca6408TypePolarity get ();
    void set (Tca6408TypePolarity value);
}
member PolarityInversionP04 : Tca6408TypePolarity with get, set

Property Value

Type: Tca6408TypePolarity
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.PolarityInversionP05 Property

IRD

Tca6408PolarityInversionP05 Property

Polarity Inversion (P-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypePolarity PolarityInversionP05 { get; set; }
Public Property PolarityInversionP05 As Tca6408TypePolarity
    Get
    Set
public:
property Tca6408TypePolarity PolarityInversionP05 {
    Tca6408TypePolarity get ();
    void set (Tca6408TypePolarity value);
}
member PolarityInversionP05 : Tca6408TypePolarity with get, set

Property Value

Type: Tca6408TypePolarity
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.PolarityInversionP06 Property

IRD

Tca6408PolarityInversionP06 Property

Polarity Inversion (P-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypePolarity PolarityInversionP06 { get; set; }
Public Property PolarityInversionP06 As Tca6408TypePolarity
    Get
    Set
public:
property Tca6408TypePolarity PolarityInversionP06 {
    Tca6408TypePolarity get ();
    void set (Tca6408TypePolarity value);
}
member PolarityInversionP06 : Tca6408TypePolarity with get, set

Property Value

Type: Tca6408TypePolarity
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.PolarityInversionP07 Property

IRD

Tca6408PolarityInversionP07 Property

Polarity Inversion (P-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6408TypePolarity PolarityInversionP07 { get; set; }
Public Property PolarityInversionP07 As Tca6408TypePolarity
    Get
    Set
public:
property Tca6408TypePolarity PolarityInversionP07 {
    Tca6408TypePolarity get ();
    void set (Tca6408TypePolarity value);
}
member PolarityInversionP07 : Tca6408TypePolarity with get, set

Property Value

Type: Tca6408TypePolarity
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408 Methods

The Tca6408 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.Flush Method

IRD

Tca6408Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Tca6408 Class
telos.Ird.TexasInstruments Namespace


Tca6408.TypeConfiguration Enumeration

IRD

Tca6408TypeConfiguration Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Input | 1 | Input
Output | 0 | Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6408.TypeLevel Enumeration

IRD

Tca6408TypeLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLevel
Public Enumeration TypeLevel
public enum class TypeLevel
type TypeLevel
Members
Member name | Value | Description
High | 1 | High
Low | 0 | Low
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6408.TypePolarity Enumeration

IRD

Tca6408TypePolarity Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarity
Public Enumeration TypePolarity
public enum class TypePolarity
type TypePolarity
Members
Member name | Value | Description
Inverted | 1 | Inverted
Normal | 0 | Normal
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6416 Class

Texas Instruments: TCA 6416
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsTca6416

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Tca6416
Public Class Tca6416
public ref class Tca6416
type Tca6416 =  class end

The Tca6416 type exposes the following members.

Constructors
 | Name | Description
Public method | Tca6416 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC03 | Configuration (C-03)
Public property | ConfigurationC04 | Configuration (C-04)
Public property | ConfigurationC05 | Configuration (C-05)
Public property | ConfigurationC06 | Configuration (C-06)
Public property | ConfigurationC07 | Configuration (C-07)
Public property | ConfigurationC10 | Configuration (C-10)
Public property | ConfigurationC11 | Configuration (C-11)
Public property | ConfigurationC12 | Configuration (C-12)
Public property | ConfigurationC13 | Configuration (C-13)
Public property | ConfigurationC14 | Configuration (C-14)
Public property | ConfigurationC15 | Configuration (C-15)
Public property | ConfigurationC16 | Configuration (C-16)
Public property | ConfigurationC17 | Configuration (C-17)
Public property | InputI00 | Input (I-00)
Public property | InputI01 | Input (I-01)
Public property | InputI02 | Input (I-02)
Public property | InputI03 | Input (I-03)
Public property | InputI04 | Input (I-04)
Public property | InputI05 | Input (I-05)
Public property | InputI06 | Input (I-06)
Public property | InputI07 | Input (I-07)
Public property | InputI10 | Input (I-10)
Public property | InputI11 | Input (I-11)
Public property | InputI12 | Input (I-12)
Public property | InputI13 | Input (I-13)
Public property | InputI14 | Input (I-14)
Public property | InputI15 | Input (I-15)
Public property | InputI16 | Input (I-16)
Public property | InputI17 | Input (I-17)
Public property | OutputO00 | Output (O-00)
Public property | OutputO01 | Output (O-01)
Public property | OutputO02 | Output (O-02)
Public property | OutputO03 | Output (O-03)
Public property | OutputO04 | Output (O-04)
Public property | OutputO05 | Output (O-05)
Public property | OutputO06 | Output (O-06)
Public property | OutputO07 | Output (O-07)
Public property | OutputO10 | Output (O-10)
Public property | OutputO11 | Output (O-11)
Public property | OutputO12 | Output (O-12)
Public property | OutputO13 | Output (O-13)
Public property | OutputO14 | Output (O-14)
Public property | OutputO15 | Output (O-15)
Public property | OutputO16 | Output (O-16)
Public property | OutputO17 | Output (O-17)
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Public property | PolarityInversionP04 | Polarity Inversion (P-04)
Public property | PolarityInversionP05 | Polarity Inversion (P-05)
Public property | PolarityInversionP06 | Polarity Inversion (P-06)
Public property | PolarityInversionP07 | Polarity Inversion (P-07)
Public property | PolarityInversionP10 | Polarity Inversion (P-10)
Public property | PolarityInversionP11 | Polarity Inversion (P-11)
Public property | PolarityInversionP12 | Polarity Inversion (P-12)
Public property | PolarityInversionP13 | Polarity Inversion (P-13)
Public property | PolarityInversionP14 | Polarity Inversion (P-14)
Public property | PolarityInversionP15 | Polarity Inversion (P-15)
Public property | PolarityInversionP16 | Polarity Inversion (P-16)
Public property | PolarityInversionP17 | Polarity Inversion (P-17)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Voltage 16-Bit I2C And SMBus I/O Expander With Interrupt Output, Reset, And Configuration Registers
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6416 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Tca6416(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Tca6416

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416 Properties

The Tca6416 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC03 | Configuration (C-03)
Public property | ConfigurationC04 | Configuration (C-04)
Public property | ConfigurationC05 | Configuration (C-05)
Public property | ConfigurationC06 | Configuration (C-06)
Public property | ConfigurationC07 | Configuration (C-07)
Public property | ConfigurationC10 | Configuration (C-10)
Public property | ConfigurationC11 | Configuration (C-11)
Public property | ConfigurationC12 | Configuration (C-12)
Public property | ConfigurationC13 | Configuration (C-13)
Public property | ConfigurationC14 | Configuration (C-14)
Public property | ConfigurationC15 | Configuration (C-15)
Public property | ConfigurationC16 | Configuration (C-16)
Public property | ConfigurationC17 | Configuration (C-17)
Public property | InputI00 | Input (I-00)
Public property | InputI01 | Input (I-01)
Public property | InputI02 | Input (I-02)
Public property | InputI03 | Input (I-03)
Public property | InputI04 | Input (I-04)
Public property | InputI05 | Input (I-05)
Public property | InputI06 | Input (I-06)
Public property | InputI07 | Input (I-07)
Public property | InputI10 | Input (I-10)
Public property | InputI11 | Input (I-11)
Public property | InputI12 | Input (I-12)
Public property | InputI13 | Input (I-13)
Public property | InputI14 | Input (I-14)
Public property | InputI15 | Input (I-15)
Public property | InputI16 | Input (I-16)
Public property | InputI17 | Input (I-17)
Public property | OutputO00 | Output (O-00)
Public property | OutputO01 | Output (O-01)
Public property | OutputO02 | Output (O-02)
Public property | OutputO03 | Output (O-03)
Public property | OutputO04 | Output (O-04)
Public property | OutputO05 | Output (O-05)
Public property | OutputO06 | Output (O-06)
Public property | OutputO07 | Output (O-07)
Public property | OutputO10 | Output (O-10)
Public property | OutputO11 | Output (O-11)
Public property | OutputO12 | Output (O-12)
Public property | OutputO13 | Output (O-13)
Public property | OutputO14 | Output (O-14)
Public property | OutputO15 | Output (O-15)
Public property | OutputO16 | Output (O-16)
Public property | OutputO17 | Output (O-17)
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Public property | PolarityInversionP04 | Polarity Inversion (P-04)
Public property | PolarityInversionP05 | Polarity Inversion (P-05)
Public property | PolarityInversionP06 | Polarity Inversion (P-06)
Public property | PolarityInversionP07 | Polarity Inversion (P-07)
Public property | PolarityInversionP10 | Polarity Inversion (P-10)
Public property | PolarityInversionP11 | Polarity Inversion (P-11)
Public property | PolarityInversionP12 | Polarity Inversion (P-12)
Public property | PolarityInversionP13 | Polarity Inversion (P-13)
Public property | PolarityInversionP14 | Polarity Inversion (P-14)
Public property | PolarityInversionP15 | Polarity Inversion (P-15)
Public property | PolarityInversionP16 | Polarity Inversion (P-16)
Public property | PolarityInversionP17 | Polarity Inversion (P-17)
Top
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.AutoFlush Property

IRD

Tca6416AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.ConfigurationC00 Property

IRD

Tca6416ConfigurationC00 Property

Configuration (C-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeConfiguration ConfigurationC00 { get; set; }
Public Property ConfigurationC00 As Tca6416TypeConfiguration
    Get
    Set
public:
property Tca6416TypeConfiguration ConfigurationC00 {
    Tca6416TypeConfiguration get ();
    void set (Tca6416TypeConfiguration value);
}
member ConfigurationC00 : Tca6416TypeConfiguration with get, set

Property Value

Type: Tca6416TypeConfiguration
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.ConfigurationC01 Property

IRD

Tca6416ConfigurationC01 Property

Configuration (C-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeConfiguration ConfigurationC01 { get; set; }
Public Property ConfigurationC01 As Tca6416TypeConfiguration
    Get
    Set
public:
property Tca6416TypeConfiguration ConfigurationC01 {
    Tca6416TypeConfiguration get ();
    void set (Tca6416TypeConfiguration value);
}
member ConfigurationC01 : Tca6416TypeConfiguration with get, set

Property Value

Type: Tca6416TypeConfiguration
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.ConfigurationC02 Property

IRD

Tca6416ConfigurationC02 Property

Configuration (C-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeConfiguration ConfigurationC02 { get; set; }
Public Property ConfigurationC02 As Tca6416TypeConfiguration
    Get
    Set
public:
property Tca6416TypeConfiguration ConfigurationC02 {
    Tca6416TypeConfiguration get ();
    void set (Tca6416TypeConfiguration value);
}
member ConfigurationC02 : Tca6416TypeConfiguration with get, set

Property Value

Type: Tca6416TypeConfiguration
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.ConfigurationC03 Property

IRD

Tca6416ConfigurationC03 Property

Configuration (C-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeConfiguration ConfigurationC03 { get; set; }
Public Property ConfigurationC03 As Tca6416TypeConfiguration
    Get
    Set
public:
property Tca6416TypeConfiguration ConfigurationC03 {
    Tca6416TypeConfiguration get ();
    void set (Tca6416TypeConfiguration value);
}
member ConfigurationC03 : Tca6416TypeConfiguration with get, set

Property Value

Type: Tca6416TypeConfiguration
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.ConfigurationC04 Property

IRD

Tca6416ConfigurationC04 Property

Configuration (C-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeConfiguration ConfigurationC04 { get; set; }
Public Property ConfigurationC04 As Tca6416TypeConfiguration
    Get
    Set
public:
property Tca6416TypeConfiguration ConfigurationC04 {
    Tca6416TypeConfiguration get ();
    void set (Tca6416TypeConfiguration value);
}
member ConfigurationC04 : Tca6416TypeConfiguration with get, set

Property Value

Type: Tca6416TypeConfiguration
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.ConfigurationC05 Property

IRD

Tca6416ConfigurationC05 Property

Configuration (C-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeConfiguration ConfigurationC05 { get; set; }
Public Property ConfigurationC05 As Tca6416TypeConfiguration
    Get
    Set
public:
property Tca6416TypeConfiguration ConfigurationC05 {
    Tca6416TypeConfiguration get ();
    void set (Tca6416TypeConfiguration value);
}
member ConfigurationC05 : Tca6416TypeConfiguration with get, set

Property Value

Type: Tca6416TypeConfiguration
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.ConfigurationC06 Property

IRD

Tca6416ConfigurationC06 Property

Configuration (C-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeConfiguration ConfigurationC06 { get; set; }
Public Property ConfigurationC06 As Tca6416TypeConfiguration
    Get
    Set
public:
property Tca6416TypeConfiguration ConfigurationC06 {
    Tca6416TypeConfiguration get ();
    void set (Tca6416TypeConfiguration value);
}
member ConfigurationC06 : Tca6416TypeConfiguration with get, set

Property Value

Type: Tca6416TypeConfiguration
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.ConfigurationC07 Property

IRD

Tca6416ConfigurationC07 Property

Configuration (C-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeConfiguration ConfigurationC07 { get; set; }
Public Property ConfigurationC07 As Tca6416TypeConfiguration
    Get
    Set
public:
property Tca6416TypeConfiguration ConfigurationC07 {
    Tca6416TypeConfiguration get ();
    void set (Tca6416TypeConfiguration value);
}
member ConfigurationC07 : Tca6416TypeConfiguration with get, set

Property Value

Type: Tca6416TypeConfiguration
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.ConfigurationC10 Property

IRD

Tca6416ConfigurationC10 Property

Configuration (C-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeConfiguration ConfigurationC10 { get; set; }
Public Property ConfigurationC10 As Tca6416TypeConfiguration
    Get
    Set
public:
property Tca6416TypeConfiguration ConfigurationC10 {
    Tca6416TypeConfiguration get ();
    void set (Tca6416TypeConfiguration value);
}
member ConfigurationC10 : Tca6416TypeConfiguration with get, set

Property Value

Type: Tca6416TypeConfiguration
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.ConfigurationC11 Property

IRD

Tca6416ConfigurationC11 Property

Configuration (C-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeConfiguration ConfigurationC11 { get; set; }
Public Property ConfigurationC11 As Tca6416TypeConfiguration
    Get
    Set
public:
property Tca6416TypeConfiguration ConfigurationC11 {
    Tca6416TypeConfiguration get ();
    void set (Tca6416TypeConfiguration value);
}
member ConfigurationC11 : Tca6416TypeConfiguration with get, set

Property Value

Type: Tca6416TypeConfiguration
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.ConfigurationC12 Property

IRD

Tca6416ConfigurationC12 Property

Configuration (C-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeConfiguration ConfigurationC12 { get; set; }
Public Property ConfigurationC12 As Tca6416TypeConfiguration
    Get
    Set
public:
property Tca6416TypeConfiguration ConfigurationC12 {
    Tca6416TypeConfiguration get ();
    void set (Tca6416TypeConfiguration value);
}
member ConfigurationC12 : Tca6416TypeConfiguration with get, set

Property Value

Type: Tca6416TypeConfiguration
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.ConfigurationC13 Property

IRD

Tca6416ConfigurationC13 Property

Configuration (C-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeConfiguration ConfigurationC13 { get; set; }
Public Property ConfigurationC13 As Tca6416TypeConfiguration
    Get
    Set
public:
property Tca6416TypeConfiguration ConfigurationC13 {
    Tca6416TypeConfiguration get ();
    void set (Tca6416TypeConfiguration value);
}
member ConfigurationC13 : Tca6416TypeConfiguration with get, set

Property Value

Type: Tca6416TypeConfiguration
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.ConfigurationC14 Property

IRD

Tca6416ConfigurationC14 Property

Configuration (C-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeConfiguration ConfigurationC14 { get; set; }
Public Property ConfigurationC14 As Tca6416TypeConfiguration
    Get
    Set
public:
property Tca6416TypeConfiguration ConfigurationC14 {
    Tca6416TypeConfiguration get ();
    void set (Tca6416TypeConfiguration value);
}
member ConfigurationC14 : Tca6416TypeConfiguration with get, set

Property Value

Type: Tca6416TypeConfiguration
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.ConfigurationC15 Property

IRD

Tca6416ConfigurationC15 Property

Configuration (C-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeConfiguration ConfigurationC15 { get; set; }
Public Property ConfigurationC15 As Tca6416TypeConfiguration
    Get
    Set
public:
property Tca6416TypeConfiguration ConfigurationC15 {
    Tca6416TypeConfiguration get ();
    void set (Tca6416TypeConfiguration value);
}
member ConfigurationC15 : Tca6416TypeConfiguration with get, set

Property Value

Type: Tca6416TypeConfiguration
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.ConfigurationC16 Property

IRD

Tca6416ConfigurationC16 Property

Configuration (C-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeConfiguration ConfigurationC16 { get; set; }
Public Property ConfigurationC16 As Tca6416TypeConfiguration
    Get
    Set
public:
property Tca6416TypeConfiguration ConfigurationC16 {
    Tca6416TypeConfiguration get ();
    void set (Tca6416TypeConfiguration value);
}
member ConfigurationC16 : Tca6416TypeConfiguration with get, set

Property Value

Type: Tca6416TypeConfiguration
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.ConfigurationC17 Property

IRD

Tca6416ConfigurationC17 Property

Configuration (C-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeConfiguration ConfigurationC17 { get; set; }
Public Property ConfigurationC17 As Tca6416TypeConfiguration
    Get
    Set
public:
property Tca6416TypeConfiguration ConfigurationC17 {
    Tca6416TypeConfiguration get ();
    void set (Tca6416TypeConfiguration value);
}
member ConfigurationC17 : Tca6416TypeConfiguration with get, set

Property Value

Type: Tca6416TypeConfiguration
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.InputI00 Property

IRD

Tca6416InputI00 Property

Input (I-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel InputI00 { get; }
Public ReadOnly Property InputI00 As Tca6416TypeLevel
    Get
public:
property Tca6416TypeLevel InputI00 {
    Tca6416TypeLevel get ();
}
member InputI00 : Tca6416TypeLevel with get

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.InputI01 Property

IRD

Tca6416InputI01 Property

Input (I-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel InputI01 { get; }
Public ReadOnly Property InputI01 As Tca6416TypeLevel
    Get
public:
property Tca6416TypeLevel InputI01 {
    Tca6416TypeLevel get ();
}
member InputI01 : Tca6416TypeLevel with get

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.InputI02 Property

IRD

Tca6416InputI02 Property

Input (I-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel InputI02 { get; }
Public ReadOnly Property InputI02 As Tca6416TypeLevel
    Get
public:
property Tca6416TypeLevel InputI02 {
    Tca6416TypeLevel get ();
}
member InputI02 : Tca6416TypeLevel with get

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.InputI03 Property

IRD

Tca6416InputI03 Property

Input (I-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel InputI03 { get; }
Public ReadOnly Property InputI03 As Tca6416TypeLevel
    Get
public:
property Tca6416TypeLevel InputI03 {
    Tca6416TypeLevel get ();
}
member InputI03 : Tca6416TypeLevel with get

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.InputI04 Property

IRD

Tca6416InputI04 Property

Input (I-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel InputI04 { get; }
Public ReadOnly Property InputI04 As Tca6416TypeLevel
    Get
public:
property Tca6416TypeLevel InputI04 {
    Tca6416TypeLevel get ();
}
member InputI04 : Tca6416TypeLevel with get

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.InputI05 Property

IRD

Tca6416InputI05 Property

Input (I-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel InputI05 { get; }
Public ReadOnly Property InputI05 As Tca6416TypeLevel
    Get
public:
property Tca6416TypeLevel InputI05 {
    Tca6416TypeLevel get ();
}
member InputI05 : Tca6416TypeLevel with get

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.InputI06 Property

IRD

Tca6416InputI06 Property

Input (I-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel InputI06 { get; }
Public ReadOnly Property InputI06 As Tca6416TypeLevel
    Get
public:
property Tca6416TypeLevel InputI06 {
    Tca6416TypeLevel get ();
}
member InputI06 : Tca6416TypeLevel with get

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.InputI07 Property

IRD

Tca6416InputI07 Property

Input (I-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel InputI07 { get; }
Public ReadOnly Property InputI07 As Tca6416TypeLevel
    Get
public:
property Tca6416TypeLevel InputI07 {
    Tca6416TypeLevel get ();
}
member InputI07 : Tca6416TypeLevel with get

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.InputI10 Property

IRD

Tca6416InputI10 Property

Input (I-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel InputI10 { get; }
Public ReadOnly Property InputI10 As Tca6416TypeLevel
    Get
public:
property Tca6416TypeLevel InputI10 {
    Tca6416TypeLevel get ();
}
member InputI10 : Tca6416TypeLevel with get

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.InputI11 Property

IRD

Tca6416InputI11 Property

Input (I-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel InputI11 { get; }
Public ReadOnly Property InputI11 As Tca6416TypeLevel
    Get
public:
property Tca6416TypeLevel InputI11 {
    Tca6416TypeLevel get ();
}
member InputI11 : Tca6416TypeLevel with get

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.InputI12 Property

IRD

Tca6416InputI12 Property

Input (I-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel InputI12 { get; }
Public ReadOnly Property InputI12 As Tca6416TypeLevel
    Get
public:
property Tca6416TypeLevel InputI12 {
    Tca6416TypeLevel get ();
}
member InputI12 : Tca6416TypeLevel with get

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.InputI13 Property

IRD

Tca6416InputI13 Property

Input (I-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel InputI13 { get; }
Public ReadOnly Property InputI13 As Tca6416TypeLevel
    Get
public:
property Tca6416TypeLevel InputI13 {
    Tca6416TypeLevel get ();
}
member InputI13 : Tca6416TypeLevel with get

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.InputI14 Property

IRD

Tca6416InputI14 Property

Input (I-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel InputI14 { get; }
Public ReadOnly Property InputI14 As Tca6416TypeLevel
    Get
public:
property Tca6416TypeLevel InputI14 {
    Tca6416TypeLevel get ();
}
member InputI14 : Tca6416TypeLevel with get

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.InputI15 Property

IRD

Tca6416InputI15 Property

Input (I-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel InputI15 { get; }
Public ReadOnly Property InputI15 As Tca6416TypeLevel
    Get
public:
property Tca6416TypeLevel InputI15 {
    Tca6416TypeLevel get ();
}
member InputI15 : Tca6416TypeLevel with get

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.InputI16 Property

IRD

Tca6416InputI16 Property

Input (I-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel InputI16 { get; }
Public ReadOnly Property InputI16 As Tca6416TypeLevel
    Get
public:
property Tca6416TypeLevel InputI16 {
    Tca6416TypeLevel get ();
}
member InputI16 : Tca6416TypeLevel with get

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.InputI17 Property

IRD

Tca6416InputI17 Property

Input (I-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel InputI17 { get; }
Public ReadOnly Property InputI17 As Tca6416TypeLevel
    Get
public:
property Tca6416TypeLevel InputI17 {
    Tca6416TypeLevel get ();
}
member InputI17 : Tca6416TypeLevel with get

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.OutputO00 Property

IRD

Tca6416OutputO00 Property

Output (O-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel OutputO00 { get; set; }
Public Property OutputO00 As Tca6416TypeLevel
    Get
    Set
public:
property Tca6416TypeLevel OutputO00 {
    Tca6416TypeLevel get ();
    void set (Tca6416TypeLevel value);
}
member OutputO00 : Tca6416TypeLevel with get, set

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.OutputO01 Property

IRD

Tca6416OutputO01 Property

Output (O-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel OutputO01 { get; set; }
Public Property OutputO01 As Tca6416TypeLevel
    Get
    Set
public:
property Tca6416TypeLevel OutputO01 {
    Tca6416TypeLevel get ();
    void set (Tca6416TypeLevel value);
}
member OutputO01 : Tca6416TypeLevel with get, set

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.OutputO02 Property

IRD

Tca6416OutputO02 Property

Output (O-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel OutputO02 { get; set; }
Public Property OutputO02 As Tca6416TypeLevel
    Get
    Set
public:
property Tca6416TypeLevel OutputO02 {
    Tca6416TypeLevel get ();
    void set (Tca6416TypeLevel value);
}
member OutputO02 : Tca6416TypeLevel with get, set

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.OutputO03 Property

IRD

Tca6416OutputO03 Property

Output (O-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel OutputO03 { get; set; }
Public Property OutputO03 As Tca6416TypeLevel
    Get
    Set
public:
property Tca6416TypeLevel OutputO03 {
    Tca6416TypeLevel get ();
    void set (Tca6416TypeLevel value);
}
member OutputO03 : Tca6416TypeLevel with get, set

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.OutputO04 Property

IRD

Tca6416OutputO04 Property

Output (O-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel OutputO04 { get; set; }
Public Property OutputO04 As Tca6416TypeLevel
    Get
    Set
public:
property Tca6416TypeLevel OutputO04 {
    Tca6416TypeLevel get ();
    void set (Tca6416TypeLevel value);
}
member OutputO04 : Tca6416TypeLevel with get, set

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.OutputO05 Property

IRD

Tca6416OutputO05 Property

Output (O-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel OutputO05 { get; set; }
Public Property OutputO05 As Tca6416TypeLevel
    Get
    Set
public:
property Tca6416TypeLevel OutputO05 {
    Tca6416TypeLevel get ();
    void set (Tca6416TypeLevel value);
}
member OutputO05 : Tca6416TypeLevel with get, set

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.OutputO06 Property

IRD

Tca6416OutputO06 Property

Output (O-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel OutputO06 { get; set; }
Public Property OutputO06 As Tca6416TypeLevel
    Get
    Set
public:
property Tca6416TypeLevel OutputO06 {
    Tca6416TypeLevel get ();
    void set (Tca6416TypeLevel value);
}
member OutputO06 : Tca6416TypeLevel with get, set

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.OutputO07 Property

IRD

Tca6416OutputO07 Property

Output (O-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel OutputO07 { get; set; }
Public Property OutputO07 As Tca6416TypeLevel
    Get
    Set
public:
property Tca6416TypeLevel OutputO07 {
    Tca6416TypeLevel get ();
    void set (Tca6416TypeLevel value);
}
member OutputO07 : Tca6416TypeLevel with get, set

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.OutputO10 Property

IRD

Tca6416OutputO10 Property

Output (O-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel OutputO10 { get; set; }
Public Property OutputO10 As Tca6416TypeLevel
    Get
    Set
public:
property Tca6416TypeLevel OutputO10 {
    Tca6416TypeLevel get ();
    void set (Tca6416TypeLevel value);
}
member OutputO10 : Tca6416TypeLevel with get, set

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.OutputO11 Property

IRD

Tca6416OutputO11 Property

Output (O-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel OutputO11 { get; set; }
Public Property OutputO11 As Tca6416TypeLevel
    Get
    Set
public:
property Tca6416TypeLevel OutputO11 {
    Tca6416TypeLevel get ();
    void set (Tca6416TypeLevel value);
}
member OutputO11 : Tca6416TypeLevel with get, set

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.OutputO12 Property

IRD

Tca6416OutputO12 Property

Output (O-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel OutputO12 { get; set; }
Public Property OutputO12 As Tca6416TypeLevel
    Get
    Set
public:
property Tca6416TypeLevel OutputO12 {
    Tca6416TypeLevel get ();
    void set (Tca6416TypeLevel value);
}
member OutputO12 : Tca6416TypeLevel with get, set

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.OutputO13 Property

IRD

Tca6416OutputO13 Property

Output (O-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel OutputO13 { get; set; }
Public Property OutputO13 As Tca6416TypeLevel
    Get
    Set
public:
property Tca6416TypeLevel OutputO13 {
    Tca6416TypeLevel get ();
    void set (Tca6416TypeLevel value);
}
member OutputO13 : Tca6416TypeLevel with get, set

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.OutputO14 Property

IRD

Tca6416OutputO14 Property

Output (O-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel OutputO14 { get; set; }
Public Property OutputO14 As Tca6416TypeLevel
    Get
    Set
public:
property Tca6416TypeLevel OutputO14 {
    Tca6416TypeLevel get ();
    void set (Tca6416TypeLevel value);
}
member OutputO14 : Tca6416TypeLevel with get, set

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.OutputO15 Property

IRD

Tca6416OutputO15 Property

Output (O-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel OutputO15 { get; set; }
Public Property OutputO15 As Tca6416TypeLevel
    Get
    Set
public:
property Tca6416TypeLevel OutputO15 {
    Tca6416TypeLevel get ();
    void set (Tca6416TypeLevel value);
}
member OutputO15 : Tca6416TypeLevel with get, set

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.OutputO16 Property

IRD

Tca6416OutputO16 Property

Output (O-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel OutputO16 { get; set; }
Public Property OutputO16 As Tca6416TypeLevel
    Get
    Set
public:
property Tca6416TypeLevel OutputO16 {
    Tca6416TypeLevel get ();
    void set (Tca6416TypeLevel value);
}
member OutputO16 : Tca6416TypeLevel with get, set

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.OutputO17 Property

IRD

Tca6416OutputO17 Property

Output (O-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypeLevel OutputO17 { get; set; }
Public Property OutputO17 As Tca6416TypeLevel
    Get
    Set
public:
property Tca6416TypeLevel OutputO17 {
    Tca6416TypeLevel get ();
    void set (Tca6416TypeLevel value);
}
member OutputO17 : Tca6416TypeLevel with get, set

Property Value

Type: Tca6416TypeLevel
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.PolarityInversionP00 Property

IRD

Tca6416PolarityInversionP00 Property

Polarity Inversion (P-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypePolarity PolarityInversionP00 { get; set; }
Public Property PolarityInversionP00 As Tca6416TypePolarity
    Get
    Set
public:
property Tca6416TypePolarity PolarityInversionP00 {
    Tca6416TypePolarity get ();
    void set (Tca6416TypePolarity value);
}
member PolarityInversionP00 : Tca6416TypePolarity with get, set

Property Value

Type: Tca6416TypePolarity
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.PolarityInversionP01 Property

IRD

Tca6416PolarityInversionP01 Property

Polarity Inversion (P-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypePolarity PolarityInversionP01 { get; set; }
Public Property PolarityInversionP01 As Tca6416TypePolarity
    Get
    Set
public:
property Tca6416TypePolarity PolarityInversionP01 {
    Tca6416TypePolarity get ();
    void set (Tca6416TypePolarity value);
}
member PolarityInversionP01 : Tca6416TypePolarity with get, set

Property Value

Type: Tca6416TypePolarity
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.PolarityInversionP02 Property

IRD

Tca6416PolarityInversionP02 Property

Polarity Inversion (P-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypePolarity PolarityInversionP02 { get; set; }
Public Property PolarityInversionP02 As Tca6416TypePolarity
    Get
    Set
public:
property Tca6416TypePolarity PolarityInversionP02 {
    Tca6416TypePolarity get ();
    void set (Tca6416TypePolarity value);
}
member PolarityInversionP02 : Tca6416TypePolarity with get, set

Property Value

Type: Tca6416TypePolarity
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.PolarityInversionP03 Property

IRD

Tca6416PolarityInversionP03 Property

Polarity Inversion (P-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypePolarity PolarityInversionP03 { get; set; }
Public Property PolarityInversionP03 As Tca6416TypePolarity
    Get
    Set
public:
property Tca6416TypePolarity PolarityInversionP03 {
    Tca6416TypePolarity get ();
    void set (Tca6416TypePolarity value);
}
member PolarityInversionP03 : Tca6416TypePolarity with get, set

Property Value

Type: Tca6416TypePolarity
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.PolarityInversionP04 Property

IRD

Tca6416PolarityInversionP04 Property

Polarity Inversion (P-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypePolarity PolarityInversionP04 { get; set; }
Public Property PolarityInversionP04 As Tca6416TypePolarity
    Get
    Set
public:
property Tca6416TypePolarity PolarityInversionP04 {
    Tca6416TypePolarity get ();
    void set (Tca6416TypePolarity value);
}
member PolarityInversionP04 : Tca6416TypePolarity with get, set

Property Value

Type: Tca6416TypePolarity
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.PolarityInversionP05 Property

IRD

Tca6416PolarityInversionP05 Property

Polarity Inversion (P-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypePolarity PolarityInversionP05 { get; set; }
Public Property PolarityInversionP05 As Tca6416TypePolarity
    Get
    Set
public:
property Tca6416TypePolarity PolarityInversionP05 {
    Tca6416TypePolarity get ();
    void set (Tca6416TypePolarity value);
}
member PolarityInversionP05 : Tca6416TypePolarity with get, set

Property Value

Type: Tca6416TypePolarity
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.PolarityInversionP06 Property

IRD

Tca6416PolarityInversionP06 Property

Polarity Inversion (P-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypePolarity PolarityInversionP06 { get; set; }
Public Property PolarityInversionP06 As Tca6416TypePolarity
    Get
    Set
public:
property Tca6416TypePolarity PolarityInversionP06 {
    Tca6416TypePolarity get ();
    void set (Tca6416TypePolarity value);
}
member PolarityInversionP06 : Tca6416TypePolarity with get, set

Property Value

Type: Tca6416TypePolarity
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.PolarityInversionP07 Property

IRD

Tca6416PolarityInversionP07 Property

Polarity Inversion (P-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypePolarity PolarityInversionP07 { get; set; }
Public Property PolarityInversionP07 As Tca6416TypePolarity
    Get
    Set
public:
property Tca6416TypePolarity PolarityInversionP07 {
    Tca6416TypePolarity get ();
    void set (Tca6416TypePolarity value);
}
member PolarityInversionP07 : Tca6416TypePolarity with get, set

Property Value

Type: Tca6416TypePolarity
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.PolarityInversionP10 Property

IRD

Tca6416PolarityInversionP10 Property

Polarity Inversion (P-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypePolarity PolarityInversionP10 { get; set; }
Public Property PolarityInversionP10 As Tca6416TypePolarity
    Get
    Set
public:
property Tca6416TypePolarity PolarityInversionP10 {
    Tca6416TypePolarity get ();
    void set (Tca6416TypePolarity value);
}
member PolarityInversionP10 : Tca6416TypePolarity with get, set

Property Value

Type: Tca6416TypePolarity
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.PolarityInversionP11 Property

IRD

Tca6416PolarityInversionP11 Property

Polarity Inversion (P-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypePolarity PolarityInversionP11 { get; set; }
Public Property PolarityInversionP11 As Tca6416TypePolarity
    Get
    Set
public:
property Tca6416TypePolarity PolarityInversionP11 {
    Tca6416TypePolarity get ();
    void set (Tca6416TypePolarity value);
}
member PolarityInversionP11 : Tca6416TypePolarity with get, set

Property Value

Type: Tca6416TypePolarity
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.PolarityInversionP12 Property

IRD

Tca6416PolarityInversionP12 Property

Polarity Inversion (P-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypePolarity PolarityInversionP12 { get; set; }
Public Property PolarityInversionP12 As Tca6416TypePolarity
    Get
    Set
public:
property Tca6416TypePolarity PolarityInversionP12 {
    Tca6416TypePolarity get ();
    void set (Tca6416TypePolarity value);
}
member PolarityInversionP12 : Tca6416TypePolarity with get, set

Property Value

Type: Tca6416TypePolarity
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.PolarityInversionP13 Property

IRD

Tca6416PolarityInversionP13 Property

Polarity Inversion (P-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypePolarity PolarityInversionP13 { get; set; }
Public Property PolarityInversionP13 As Tca6416TypePolarity
    Get
    Set
public:
property Tca6416TypePolarity PolarityInversionP13 {
    Tca6416TypePolarity get ();
    void set (Tca6416TypePolarity value);
}
member PolarityInversionP13 : Tca6416TypePolarity with get, set

Property Value

Type: Tca6416TypePolarity
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.PolarityInversionP14 Property

IRD

Tca6416PolarityInversionP14 Property

Polarity Inversion (P-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypePolarity PolarityInversionP14 { get; set; }
Public Property PolarityInversionP14 As Tca6416TypePolarity
    Get
    Set
public:
property Tca6416TypePolarity PolarityInversionP14 {
    Tca6416TypePolarity get ();
    void set (Tca6416TypePolarity value);
}
member PolarityInversionP14 : Tca6416TypePolarity with get, set

Property Value

Type: Tca6416TypePolarity
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.PolarityInversionP15 Property

IRD

Tca6416PolarityInversionP15 Property

Polarity Inversion (P-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypePolarity PolarityInversionP15 { get; set; }
Public Property PolarityInversionP15 As Tca6416TypePolarity
    Get
    Set
public:
property Tca6416TypePolarity PolarityInversionP15 {
    Tca6416TypePolarity get ();
    void set (Tca6416TypePolarity value);
}
member PolarityInversionP15 : Tca6416TypePolarity with get, set

Property Value

Type: Tca6416TypePolarity
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.PolarityInversionP16 Property

IRD

Tca6416PolarityInversionP16 Property

Polarity Inversion (P-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypePolarity PolarityInversionP16 { get; set; }
Public Property PolarityInversionP16 As Tca6416TypePolarity
    Get
    Set
public:
property Tca6416TypePolarity PolarityInversionP16 {
    Tca6416TypePolarity get ();
    void set (Tca6416TypePolarity value);
}
member PolarityInversionP16 : Tca6416TypePolarity with get, set

Property Value

Type: Tca6416TypePolarity
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.PolarityInversionP17 Property

IRD

Tca6416PolarityInversionP17 Property

Polarity Inversion (P-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6416TypePolarity PolarityInversionP17 { get; set; }
Public Property PolarityInversionP17 As Tca6416TypePolarity
    Get
    Set
public:
property Tca6416TypePolarity PolarityInversionP17 {
    Tca6416TypePolarity get ();
    void set (Tca6416TypePolarity value);
}
member PolarityInversionP17 : Tca6416TypePolarity with get, set

Property Value

Type: Tca6416TypePolarity
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416 Methods

The Tca6416 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.Flush Method

IRD

Tca6416Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Tca6416 Class
telos.Ird.TexasInstruments Namespace


Tca6416.TypeConfiguration Enumeration

IRD

Tca6416TypeConfiguration Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Input | 1 | Input
Output | 0 | Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6416.TypeLevel Enumeration

IRD

Tca6416TypeLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLevel
Public Enumeration TypeLevel
public enum class TypeLevel
type TypeLevel
Members
Member name | Value | Description
High | 1 | High
Low | 0 | Low
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6416.TypePolarity Enumeration

IRD

Tca6416TypePolarity Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarity
Public Enumeration TypePolarity
public enum class TypePolarity
type TypePolarity
Members
Member name | Value | Description
Inverted | 1 | Inverted
Normal | 0 | Normal
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6424 Class

Texas Instruments: TCA 6424
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsTca6424

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Tca6424
Public Class Tca6424
public ref class Tca6424
type Tca6424 =  class end

The Tca6424 type exposes the following members.

Constructors
 | Name | Description
Public method | Tca6424 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC00AI | Configuration (C-00) [AI]
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC01AI | Configuration (C-01) [AI]
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC02AI | Configuration (C-02) [AI]
Public property | ConfigurationC03 | Configuration (C-03)
Public property | ConfigurationC03AI | Configuration (C-03) [AI]
Public property | ConfigurationC04 | Configuration (C-04)
Public property | ConfigurationC04AI | Configuration (C-04) [AI]
Public property | ConfigurationC05 | Configuration (C-05)
Public property | ConfigurationC05AI | Configuration (C-05) [AI]
Public property | ConfigurationC06 | Configuration (C-06)
Public property | ConfigurationC06AI | Configuration (C-06) [AI]
Public property | ConfigurationC07 | Configuration (C-07)
Public property | ConfigurationC07AI | Configuration (C-07) [AI]
Public property | ConfigurationC10 | Configuration (C-10)
Public property | ConfigurationC10AI | Configuration (C-10) [AI]
Public property | ConfigurationC11 | Configuration (C-11)
Public property | ConfigurationC11AI | Configuration (C-11) [AI]
Public property | ConfigurationC12 | Configuration (C-12)
Public property | ConfigurationC12AI | Configuration (C-12) [AI]
Public property | ConfigurationC13 | Configuration (C-13)
Public property | ConfigurationC13AI | Configuration (C-13) [AI]
Public property | ConfigurationC14 | Configuration (C-14)
Public property | ConfigurationC14AI | Configuration (C-14) [AI]
Public property | ConfigurationC15 | Configuration (C-15)
Public property | ConfigurationC15AI | Configuration (C-15) [AI]
Public property | ConfigurationC16 | Configuration (C-16)
Public property | ConfigurationC16AI | Configuration (C-16) [AI]
Public property | ConfigurationC17 | Configuration (C-17)
Public property | ConfigurationC17AI | Configuration (C-17) [AI]
Public property | ConfigurationC20 | Configuration (C-20)
Public property | ConfigurationC20AI | Configuration (C-20) [AI]
Public property | ConfigurationC21 | Configuration (C-21)
Public property | ConfigurationC21AI | Configuration (C-21) [AI]
Public property | ConfigurationC22 | Configuration (C-22)
Public property | ConfigurationC22AI | Configuration (C-22) [AI]
Public property | ConfigurationC23 | Configuration (C-23)
Public property | ConfigurationC23AI | Configuration (C-23) [AI]
Public property | ConfigurationC24 | Configuration (C-24)
Public property | ConfigurationC24AI | Configuration (C-24) [AI]
Public property | ConfigurationC25 | Configuration (C-25)
Public property | ConfigurationC25AI | Configuration (C-25) [AI]
Public property | ConfigurationC26 | Configuration (C-26)
Public property | ConfigurationC26AI | Configuration (C-26) [AI]
Public property | ConfigurationC27 | Configuration (C-27)
Public property | ConfigurationC27AI | Configuration (C-27) [AI]
Public property | InputI00 | Input (I-00)
Public property | InputI00AI | Input (I-00) [AI]
Public property | InputI01 | Input (I-01)
Public property | InputI01AI | Input (I-01) [AI]
Public property | InputI02 | Input (I-02)
Public property | InputI02AI | Input (I-02) [AI]
Public property | InputI03 | Input (I-03)
Public property | InputI03AI | Input (I-03) [AI]
Public property | InputI04 | Input (I-04)
Public property | InputI04AI | Input (I-04) [AI]
Public property | InputI05 | Input (I-05)
Public property | InputI05AI | Input (I-05) [AI]
Public property | InputI06 | Input (I-06)
Public property | InputI06AI | Input (I-06) [AI]
Public property | InputI07 | Input (I-07)
Public property | InputI07AI | Input (I-07) [AI]
Public property | InputI10 | Input (I-10)
Public property | InputI10AI | Input (I-10) [AI]
Public property | InputI11 | Input (I-11)
Public property | InputI11AI | Input (I-11) [AI]
Public property | InputI12 | Input (I-12)
Public property | InputI12AI | Input (I-12) [AI]
Public property | InputI13 | Input (I-13)
Public property | InputI13AI | Input (I-13) [AI]
Public property | InputI14 | Input (I-14)
Public property | InputI14AI | Input (I-14) [AI]
Public property | InputI15 | Input (I-15)
Public property | InputI15AI | Input (I-15) [AI]
Public property | InputI16 | Input (I-16)
Public property | InputI16AI | Input (I-16) [AI]
Public property | InputI17 | Input (I-17)
Public property | InputI17AI | Input (I-17) [AI]
Public property | InputI20 | Input (I-20)
Public property | InputI20AI | Input (I-20) [AI]
Public property | InputI21 | Input (I-21)
Public property | InputI21AI | Input (I-21) [AI]
Public property | InputI22 | Input (I-22)
Public property | InputI22AI | Input (I-22) [AI]
Public property | InputI23 | Input (I-23)
Public property | InputI23AI | Input (I-23) [AI]
Public property | InputI24 | Input (I-24)
Public property | InputI24AI | Input (I-24) [AI]
Public property | InputI25 | Input (I-25)
Public property | InputI25AI | Input (I-25) [AI]
Public property | InputI26 | Input (I-26)
Public property | InputI26AI | Input (I-26) [AI]
Public property | InputI27 | Input (I-27)
Public property | InputI27AI | Input (I-27) [AI]
Public property | OutputO00 | Output (O-00)
Public property | OutputO00AI | Output (O-00) [AI]
Public property | OutputO01 | Output (O-01)
Public property | OutputO01AI | Output (O-01) [AI]
Public property | OutputO02 | Output (O-02)
Public property | OutputO02AI | Output (O-02) [AI]
Public property | OutputO03 | Output (O-03)
Public property | OutputO03AI | Output (O-03) [AI]
Public property | OutputO04 | Output (O-04)
Public property | OutputO04AI | Output (O-04) [AI]
Public property | OutputO05 | Output (O-05)
Public property | OutputO05AI | Output (O-05) [AI]
Public property | OutputO06 | Output (O-06)
Public property | OutputO06AI | Output (O-06) [AI]
Public property | OutputO07 | Output (O-07)
Public property | OutputO07AI | Output (O-07) [AI]
Public property | OutputO10 | Output (O-10)
Public property | OutputO10AI | Output (O-10) [AI]
Public property | OutputO11 | Output (O-11)
Public property | OutputO11AI | Output (O-11) [AI]
Public property | OutputO12 | Output (O-12)
Public property | OutputO12AI | Output (O-12) [AI]
Public property | OutputO13 | Output (O-13)
Public property | OutputO13AI | Output (O-13) [AI]
Public property | OutputO14 | Output (O-14)
Public property | OutputO14AI | Output (O-14) [AI]
Public property | OutputO15 | Output (O-15)
Public property | OutputO15AI | Output (O-15) [AI]
Public property | OutputO16 | Output (O-16)
Public property | OutputO16AI | Output (O-16) [AI]
Public property | OutputO17 | Output (O-17)
Public property | OutputO17AI | Output (O-17) [AI]
Public property | OutputO20 | Output (O-20)
Public property | OutputO20AI | Output (O-20) [AI]
Public property | OutputO21 | Output (O-21)
Public property | OutputO21AI | Output (O-21) [AI]
Public property | OutputO22 | Output (O-22)
Public property | OutputO22AI | Output (O-22) [AI]
Public property | OutputO23 | Output (O-23)
Public property | OutputO23AI | Output (O-23) [AI]
Public property | OutputO24 | Output (O-24)
Public property | OutputO24AI | Output (O-24) [AI]
Public property | OutputO25 | Output (O-25)
Public property | OutputO25AI | Output (O-25) [AI]
Public property | OutputO26 | Output (O-26)
Public property | OutputO26AI | Output (O-26) [AI]
Public property | OutputO27 | Output (O-27)
Public property | OutputO27AI | Output (O-27) [AI]
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP00AI | Polarity Inversion (P-00) [AI]
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP01AI | Polarity Inversion (P-01) [AI]
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP02AI | Polarity Inversion (P-02) [AI]
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Public property | PolarityInversionP03AI | Polarity Inversion (P-03) [AI]
Public property | PolarityInversionP04 | Polarity Inversion (P-04)
Public property | PolarityInversionP04AI | Polarity Inversion (P-04) [AI]
Public property | PolarityInversionP05 | Polarity Inversion (P-05)
Public property | PolarityInversionP05AI | Polarity Inversion (P-05) [AI]
Public property | PolarityInversionP06 | Polarity Inversion (P-06)
Public property | PolarityInversionP06AI | Polarity Inversion (P-06) [AI]
Public property | PolarityInversionP07 | Polarity Inversion (P-07)
Public property | PolarityInversionP07AI | Polarity Inversion (P-07) [AI]
Public property | PolarityInversionP10 | Polarity Inversion (P-10)
Public property | PolarityInversionP10AI | Polarity Inversion (P-10) [AI]
Public property | PolarityInversionP11 | Polarity Inversion (P-11)
Public property | PolarityInversionP11AI | Polarity Inversion (P-11) [AI]
Public property | PolarityInversionP12 | Polarity Inversion (P-12)
Public property | PolarityInversionP12AI | Polarity Inversion (P-12) [AI]
Public property | PolarityInversionP13 | Polarity Inversion (P-13)
Public property | PolarityInversionP13AI | Polarity Inversion (P-13) [AI]
Public property | PolarityInversionP14 | Polarity Inversion (P-14)
Public property | PolarityInversionP14AI | Polarity Inversion (P-14) [AI]
Public property | PolarityInversionP15 | Polarity Inversion (P-15)
Public property | PolarityInversionP15AI | Polarity Inversion (P-15) [AI]
Public property | PolarityInversionP16 | Polarity Inversion (P-16)
Public property | PolarityInversionP16AI | Polarity Inversion (P-16) [AI]
Public property | PolarityInversionP17 | Polarity Inversion (P-17)
Public property | PolarityInversionP17AI | Polarity Inversion (P-17) [AI]
Public property | PolarityInversionP20 | Polarity Inversion (P-20)
Public property | PolarityInversionP20AI | Polarity Inversion (P-20) [AI]
Public property | PolarityInversionP21 | Polarity Inversion (P-21)
Public property | PolarityInversionP21AI | Polarity Inversion (P-21) [AI]
Public property | PolarityInversionP22 | Polarity Inversion (P-22)
Public property | PolarityInversionP22AI | Polarity Inversion (P-22) [AI]
Public property | PolarityInversionP23 | Polarity Inversion (P-23)
Public property | PolarityInversionP23AI | Polarity Inversion (P-23) [AI]
Public property | PolarityInversionP24 | Polarity Inversion (P-24)
Public property | PolarityInversionP24AI | Polarity Inversion (P-24) [AI]
Public property | PolarityInversionP25 | Polarity Inversion (P-25)
Public property | PolarityInversionP25AI | Polarity Inversion (P-25) [AI]
Public property | PolarityInversionP26 | Polarity Inversion (P-26)
Public property | PolarityInversionP26AI | Polarity Inversion (P-26) [AI]
Public property | PolarityInversionP27 | Polarity Inversion (P-27)
Public property | PolarityInversionP27AI | Polarity Inversion (P-27) [AI]
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Voltage 24-Bit I2C And SMBus I/O Expander With Interrupt Output, Reset, And Configuration Registers
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6424 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Tca6424(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Tca6424

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424 Properties

The Tca6424 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | ConfigurationC00 | Configuration (C-00)
Public property | ConfigurationC00AI | Configuration (C-00) [AI]
Public property | ConfigurationC01 | Configuration (C-01)
Public property | ConfigurationC01AI | Configuration (C-01) [AI]
Public property | ConfigurationC02 | Configuration (C-02)
Public property | ConfigurationC02AI | Configuration (C-02) [AI]
Public property | ConfigurationC03 | Configuration (C-03)
Public property | ConfigurationC03AI | Configuration (C-03) [AI]
Public property | ConfigurationC04 | Configuration (C-04)
Public property | ConfigurationC04AI | Configuration (C-04) [AI]
Public property | ConfigurationC05 | Configuration (C-05)
Public property | ConfigurationC05AI | Configuration (C-05) [AI]
Public property | ConfigurationC06 | Configuration (C-06)
Public property | ConfigurationC06AI | Configuration (C-06) [AI]
Public property | ConfigurationC07 | Configuration (C-07)
Public property | ConfigurationC07AI | Configuration (C-07) [AI]
Public property | ConfigurationC10 | Configuration (C-10)
Public property | ConfigurationC10AI | Configuration (C-10) [AI]
Public property | ConfigurationC11 | Configuration (C-11)
Public property | ConfigurationC11AI | Configuration (C-11) [AI]
Public property | ConfigurationC12 | Configuration (C-12)
Public property | ConfigurationC12AI | Configuration (C-12) [AI]
Public property | ConfigurationC13 | Configuration (C-13)
Public property | ConfigurationC13AI | Configuration (C-13) [AI]
Public property | ConfigurationC14 | Configuration (C-14)
Public property | ConfigurationC14AI | Configuration (C-14) [AI]
Public property | ConfigurationC15 | Configuration (C-15)
Public property | ConfigurationC15AI | Configuration (C-15) [AI]
Public property | ConfigurationC16 | Configuration (C-16)
Public property | ConfigurationC16AI | Configuration (C-16) [AI]
Public property | ConfigurationC17 | Configuration (C-17)
Public property | ConfigurationC17AI | Configuration (C-17) [AI]
Public property | ConfigurationC20 | Configuration (C-20)
Public property | ConfigurationC20AI | Configuration (C-20) [AI]
Public property | ConfigurationC21 | Configuration (C-21)
Public property | ConfigurationC21AI | Configuration (C-21) [AI]
Public property | ConfigurationC22 | Configuration (C-22)
Public property | ConfigurationC22AI | Configuration (C-22) [AI]
Public property | ConfigurationC23 | Configuration (C-23)
Public property | ConfigurationC23AI | Configuration (C-23) [AI]
Public property | ConfigurationC24 | Configuration (C-24)
Public property | ConfigurationC24AI | Configuration (C-24) [AI]
Public property | ConfigurationC25 | Configuration (C-25)
Public property | ConfigurationC25AI | Configuration (C-25) [AI]
Public property | ConfigurationC26 | Configuration (C-26)
Public property | ConfigurationC26AI | Configuration (C-26) [AI]
Public property | ConfigurationC27 | Configuration (C-27)
Public property | ConfigurationC27AI | Configuration (C-27) [AI]
Public property | InputI00 | Input (I-00)
Public property | InputI00AI | Input (I-00) [AI]
Public property | InputI01 | Input (I-01)
Public property | InputI01AI | Input (I-01) [AI]
Public property | InputI02 | Input (I-02)
Public property | InputI02AI | Input (I-02) [AI]
Public property | InputI03 | Input (I-03)
Public property | InputI03AI | Input (I-03) [AI]
Public property | InputI04 | Input (I-04)
Public property | InputI04AI | Input (I-04) [AI]
Public property | InputI05 | Input (I-05)
Public property | InputI05AI | Input (I-05) [AI]
Public property | InputI06 | Input (I-06)
Public property | InputI06AI | Input (I-06) [AI]
Public property | InputI07 | Input (I-07)
Public property | InputI07AI | Input (I-07) [AI]
Public property | InputI10 | Input (I-10)
Public property | InputI10AI | Input (I-10) [AI]
Public property | InputI11 | Input (I-11)
Public property | InputI11AI | Input (I-11) [AI]
Public property | InputI12 | Input (I-12)
Public property | InputI12AI | Input (I-12) [AI]
Public property | InputI13 | Input (I-13)
Public property | InputI13AI | Input (I-13) [AI]
Public property | InputI14 | Input (I-14)
Public property | InputI14AI | Input (I-14) [AI]
Public property | InputI15 | Input (I-15)
Public property | InputI15AI | Input (I-15) [AI]
Public property | InputI16 | Input (I-16)
Public property | InputI16AI | Input (I-16) [AI]
Public property | InputI17 | Input (I-17)
Public property | InputI17AI | Input (I-17) [AI]
Public property | InputI20 | Input (I-20)
Public property | InputI20AI | Input (I-20) [AI]
Public property | InputI21 | Input (I-21)
Public property | InputI21AI | Input (I-21) [AI]
Public property | InputI22 | Input (I-22)
Public property | InputI22AI | Input (I-22) [AI]
Public property | InputI23 | Input (I-23)
Public property | InputI23AI | Input (I-23) [AI]
Public property | InputI24 | Input (I-24)
Public property | InputI24AI | Input (I-24) [AI]
Public property | InputI25 | Input (I-25)
Public property | InputI25AI | Input (I-25) [AI]
Public property | InputI26 | Input (I-26)
Public property | InputI26AI | Input (I-26) [AI]
Public property | InputI27 | Input (I-27)
Public property | InputI27AI | Input (I-27) [AI]
Public property | OutputO00 | Output (O-00)
Public property | OutputO00AI | Output (O-00) [AI]
Public property | OutputO01 | Output (O-01)
Public property | OutputO01AI | Output (O-01) [AI]
Public property | OutputO02 | Output (O-02)
Public property | OutputO02AI | Output (O-02) [AI]
Public property | OutputO03 | Output (O-03)
Public property | OutputO03AI | Output (O-03) [AI]
Public property | OutputO04 | Output (O-04)
Public property | OutputO04AI | Output (O-04) [AI]
Public property | OutputO05 | Output (O-05)
Public property | OutputO05AI | Output (O-05) [AI]
Public property | OutputO06 | Output (O-06)
Public property | OutputO06AI | Output (O-06) [AI]
Public property | OutputO07 | Output (O-07)
Public property | OutputO07AI | Output (O-07) [AI]
Public property | OutputO10 | Output (O-10)
Public property | OutputO10AI | Output (O-10) [AI]
Public property | OutputO11 | Output (O-11)
Public property | OutputO11AI | Output (O-11) [AI]
Public property | OutputO12 | Output (O-12)
Public property | OutputO12AI | Output (O-12) [AI]
Public property | OutputO13 | Output (O-13)
Public property | OutputO13AI | Output (O-13) [AI]
Public property | OutputO14 | Output (O-14)
Public property | OutputO14AI | Output (O-14) [AI]
Public property | OutputO15 | Output (O-15)
Public property | OutputO15AI | Output (O-15) [AI]
Public property | OutputO16 | Output (O-16)
Public property | OutputO16AI | Output (O-16) [AI]
Public property | OutputO17 | Output (O-17)
Public property | OutputO17AI | Output (O-17) [AI]
Public property | OutputO20 | Output (O-20)
Public property | OutputO20AI | Output (O-20) [AI]
Public property | OutputO21 | Output (O-21)
Public property | OutputO21AI | Output (O-21) [AI]
Public property | OutputO22 | Output (O-22)
Public property | OutputO22AI | Output (O-22) [AI]
Public property | OutputO23 | Output (O-23)
Public property | OutputO23AI | Output (O-23) [AI]
Public property | OutputO24 | Output (O-24)
Public property | OutputO24AI | Output (O-24) [AI]
Public property | OutputO25 | Output (O-25)
Public property | OutputO25AI | Output (O-25) [AI]
Public property | OutputO26 | Output (O-26)
Public property | OutputO26AI | Output (O-26) [AI]
Public property | OutputO27 | Output (O-27)
Public property | OutputO27AI | Output (O-27) [AI]
Public property | PolarityInversionP00 | Polarity Inversion (P-00)
Public property | PolarityInversionP00AI | Polarity Inversion (P-00) [AI]
Public property | PolarityInversionP01 | Polarity Inversion (P-01)
Public property | PolarityInversionP01AI | Polarity Inversion (P-01) [AI]
Public property | PolarityInversionP02 | Polarity Inversion (P-02)
Public property | PolarityInversionP02AI | Polarity Inversion (P-02) [AI]
Public property | PolarityInversionP03 | Polarity Inversion (P-03)
Public property | PolarityInversionP03AI | Polarity Inversion (P-03) [AI]
Public property | PolarityInversionP04 | Polarity Inversion (P-04)
Public property | PolarityInversionP04AI | Polarity Inversion (P-04) [AI]
Public property | PolarityInversionP05 | Polarity Inversion (P-05)
Public property | PolarityInversionP05AI | Polarity Inversion (P-05) [AI]
Public property | PolarityInversionP06 | Polarity Inversion (P-06)
Public property | PolarityInversionP06AI | Polarity Inversion (P-06) [AI]
Public property | PolarityInversionP07 | Polarity Inversion (P-07)
Public property | PolarityInversionP07AI | Polarity Inversion (P-07) [AI]
Public property | PolarityInversionP10 | Polarity Inversion (P-10)
Public property | PolarityInversionP10AI | Polarity Inversion (P-10) [AI]
Public property | PolarityInversionP11 | Polarity Inversion (P-11)
Public property | PolarityInversionP11AI | Polarity Inversion (P-11) [AI]
Public property | PolarityInversionP12 | Polarity Inversion (P-12)
Public property | PolarityInversionP12AI | Polarity Inversion (P-12) [AI]
Public property | PolarityInversionP13 | Polarity Inversion (P-13)
Public property | PolarityInversionP13AI | Polarity Inversion (P-13) [AI]
Public property | PolarityInversionP14 | Polarity Inversion (P-14)
Public property | PolarityInversionP14AI | Polarity Inversion (P-14) [AI]
Public property | PolarityInversionP15 | Polarity Inversion (P-15)
Public property | PolarityInversionP15AI | Polarity Inversion (P-15) [AI]
Public property | PolarityInversionP16 | Polarity Inversion (P-16)
Public property | PolarityInversionP16AI | Polarity Inversion (P-16) [AI]
Public property | PolarityInversionP17 | Polarity Inversion (P-17)
Public property | PolarityInversionP17AI | Polarity Inversion (P-17) [AI]
Public property | PolarityInversionP20 | Polarity Inversion (P-20)
Public property | PolarityInversionP20AI | Polarity Inversion (P-20) [AI]
Public property | PolarityInversionP21 | Polarity Inversion (P-21)
Public property | PolarityInversionP21AI | Polarity Inversion (P-21) [AI]
Public property | PolarityInversionP22 | Polarity Inversion (P-22)
Public property | PolarityInversionP22AI | Polarity Inversion (P-22) [AI]
Public property | PolarityInversionP23 | Polarity Inversion (P-23)
Public property | PolarityInversionP23AI | Polarity Inversion (P-23) [AI]
Public property | PolarityInversionP24 | Polarity Inversion (P-24)
Public property | PolarityInversionP24AI | Polarity Inversion (P-24) [AI]
Public property | PolarityInversionP25 | Polarity Inversion (P-25)
Public property | PolarityInversionP25AI | Polarity Inversion (P-25) [AI]
Public property | PolarityInversionP26 | Polarity Inversion (P-26)
Public property | PolarityInversionP26AI | Polarity Inversion (P-26) [AI]
Public property | PolarityInversionP27 | Polarity Inversion (P-27)
Public property | PolarityInversionP27AI | Polarity Inversion (P-27) [AI]
Top
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.AutoFlush Property

IRD

Tca6424AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC00 Property

IRD

Tca6424ConfigurationC00 Property

Configuration (C-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC00 { get; set; }
Public Property ConfigurationC00 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC00 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC00 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC00AI Property

IRD

Tca6424ConfigurationC00AI Property

Configuration (C-00) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC00AI { get; set; }
Public Property ConfigurationC00AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC00AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC00AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC01 Property

IRD

Tca6424ConfigurationC01 Property

Configuration (C-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC01 { get; set; }
Public Property ConfigurationC01 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC01 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC01 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC01AI Property

IRD

Tca6424ConfigurationC01AI Property

Configuration (C-01) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC01AI { get; set; }
Public Property ConfigurationC01AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC01AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC01AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC02 Property

IRD

Tca6424ConfigurationC02 Property

Configuration (C-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC02 { get; set; }
Public Property ConfigurationC02 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC02 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC02 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC02AI Property

IRD

Tca6424ConfigurationC02AI Property

Configuration (C-02) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC02AI { get; set; }
Public Property ConfigurationC02AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC02AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC02AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC03 Property

IRD

Tca6424ConfigurationC03 Property

Configuration (C-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC03 { get; set; }
Public Property ConfigurationC03 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC03 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC03 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC03AI Property

IRD

Tca6424ConfigurationC03AI Property

Configuration (C-03) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC03AI { get; set; }
Public Property ConfigurationC03AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC03AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC03AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC04 Property

IRD

Tca6424ConfigurationC04 Property

Configuration (C-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC04 { get; set; }
Public Property ConfigurationC04 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC04 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC04 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC04AI Property

IRD

Tca6424ConfigurationC04AI Property

Configuration (C-04) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC04AI { get; set; }
Public Property ConfigurationC04AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC04AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC04AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC05 Property

IRD

Tca6424ConfigurationC05 Property

Configuration (C-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC05 { get; set; }
Public Property ConfigurationC05 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC05 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC05 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC05AI Property

IRD

Tca6424ConfigurationC05AI Property

Configuration (C-05) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC05AI { get; set; }
Public Property ConfigurationC05AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC05AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC05AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC06 Property

IRD

Tca6424ConfigurationC06 Property

Configuration (C-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC06 { get; set; }
Public Property ConfigurationC06 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC06 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC06 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC06AI Property

IRD

Tca6424ConfigurationC06AI Property

Configuration (C-06) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC06AI { get; set; }
Public Property ConfigurationC06AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC06AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC06AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC07 Property

IRD

Tca6424ConfigurationC07 Property

Configuration (C-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC07 { get; set; }
Public Property ConfigurationC07 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC07 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC07 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC07AI Property

IRD

Tca6424ConfigurationC07AI Property

Configuration (C-07) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC07AI { get; set; }
Public Property ConfigurationC07AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC07AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC07AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC10 Property

IRD

Tca6424ConfigurationC10 Property

Configuration (C-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC10 { get; set; }
Public Property ConfigurationC10 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC10 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC10 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC10AI Property

IRD

Tca6424ConfigurationC10AI Property

Configuration (C-10) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC10AI { get; set; }
Public Property ConfigurationC10AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC10AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC10AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC11 Property

IRD

Tca6424ConfigurationC11 Property

Configuration (C-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC11 { get; set; }
Public Property ConfigurationC11 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC11 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC11 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC11AI Property

IRD

Tca6424ConfigurationC11AI Property

Configuration (C-11) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC11AI { get; set; }
Public Property ConfigurationC11AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC11AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC11AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC12 Property

IRD

Tca6424ConfigurationC12 Property

Configuration (C-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC12 { get; set; }
Public Property ConfigurationC12 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC12 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC12 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC12AI Property

IRD

Tca6424ConfigurationC12AI Property

Configuration (C-12) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC12AI { get; set; }
Public Property ConfigurationC12AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC12AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC12AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC13 Property

IRD

Tca6424ConfigurationC13 Property

Configuration (C-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC13 { get; set; }
Public Property ConfigurationC13 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC13 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC13 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC13AI Property

IRD

Tca6424ConfigurationC13AI Property

Configuration (C-13) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC13AI { get; set; }
Public Property ConfigurationC13AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC13AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC13AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC14 Property

IRD

Tca6424ConfigurationC14 Property

Configuration (C-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC14 { get; set; }
Public Property ConfigurationC14 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC14 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC14 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC14AI Property

IRD

Tca6424ConfigurationC14AI Property

Configuration (C-14) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC14AI { get; set; }
Public Property ConfigurationC14AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC14AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC14AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC15 Property

IRD

Tca6424ConfigurationC15 Property

Configuration (C-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC15 { get; set; }
Public Property ConfigurationC15 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC15 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC15 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC15AI Property

IRD

Tca6424ConfigurationC15AI Property

Configuration (C-15) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC15AI { get; set; }
Public Property ConfigurationC15AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC15AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC15AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC16 Property

IRD

Tca6424ConfigurationC16 Property

Configuration (C-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC16 { get; set; }
Public Property ConfigurationC16 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC16 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC16 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC16AI Property

IRD

Tca6424ConfigurationC16AI Property

Configuration (C-16) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC16AI { get; set; }
Public Property ConfigurationC16AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC16AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC16AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC17 Property

IRD

Tca6424ConfigurationC17 Property

Configuration (C-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC17 { get; set; }
Public Property ConfigurationC17 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC17 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC17 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC17AI Property

IRD

Tca6424ConfigurationC17AI Property

Configuration (C-17) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC17AI { get; set; }
Public Property ConfigurationC17AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC17AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC17AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC20 Property

IRD

Tca6424ConfigurationC20 Property

Configuration (C-20)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC20 { get; set; }
Public Property ConfigurationC20 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC20 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC20 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC20AI Property

IRD

Tca6424ConfigurationC20AI Property

Configuration (C-20) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC20AI { get; set; }
Public Property ConfigurationC20AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC20AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC20AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC21 Property

IRD

Tca6424ConfigurationC21 Property

Configuration (C-21)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC21 { get; set; }
Public Property ConfigurationC21 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC21 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC21 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC21AI Property

IRD

Tca6424ConfigurationC21AI Property

Configuration (C-21) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC21AI { get; set; }
Public Property ConfigurationC21AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC21AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC21AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC22 Property

IRD

Tca6424ConfigurationC22 Property

Configuration (C-22)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC22 { get; set; }
Public Property ConfigurationC22 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC22 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC22 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC22AI Property

IRD

Tca6424ConfigurationC22AI Property

Configuration (C-22) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC22AI { get; set; }
Public Property ConfigurationC22AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC22AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC22AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC23 Property

IRD

Tca6424ConfigurationC23 Property

Configuration (C-23)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC23 { get; set; }
Public Property ConfigurationC23 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC23 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC23 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC23AI Property

IRD

Tca6424ConfigurationC23AI Property

Configuration (C-23) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC23AI { get; set; }
Public Property ConfigurationC23AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC23AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC23AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC24 Property

IRD

Tca6424ConfigurationC24 Property

Configuration (C-24)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC24 { get; set; }
Public Property ConfigurationC24 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC24 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC24 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC24AI Property

IRD

Tca6424ConfigurationC24AI Property

Configuration (C-24) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC24AI { get; set; }
Public Property ConfigurationC24AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC24AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC24AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC25 Property

IRD

Tca6424ConfigurationC25 Property

Configuration (C-25)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC25 { get; set; }
Public Property ConfigurationC25 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC25 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC25 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC25AI Property

IRD

Tca6424ConfigurationC25AI Property

Configuration (C-25) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC25AI { get; set; }
Public Property ConfigurationC25AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC25AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC25AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC26 Property

IRD

Tca6424ConfigurationC26 Property

Configuration (C-26)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC26 { get; set; }
Public Property ConfigurationC26 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC26 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC26 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC26AI Property

IRD

Tca6424ConfigurationC26AI Property

Configuration (C-26) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC26AI { get; set; }
Public Property ConfigurationC26AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC26AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC26AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC27 Property

IRD

Tca6424ConfigurationC27 Property

Configuration (C-27)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC27 { get; set; }
Public Property ConfigurationC27 As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC27 {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC27 : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.ConfigurationC27AI Property

IRD

Tca6424ConfigurationC27AI Property

Configuration (C-27) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeConfiguration ConfigurationC27AI { get; set; }
Public Property ConfigurationC27AI As Tca6424TypeConfiguration
    Get
    Set
public:
property Tca6424TypeConfiguration ConfigurationC27AI {
    Tca6424TypeConfiguration get ();
    void set (Tca6424TypeConfiguration value);
}
member ConfigurationC27AI : Tca6424TypeConfiguration with get, set

Property Value

Type: Tca6424TypeConfiguration
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI00 Property

IRD

Tca6424InputI00 Property

Input (I-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI00 { get; }
Public ReadOnly Property InputI00 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI00 {
    Tca6424TypeLevel get ();
}
member InputI00 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI00AI Property

IRD

Tca6424InputI00AI Property

Input (I-00) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI00AI { get; }
Public ReadOnly Property InputI00AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI00AI {
    Tca6424TypeLevel get ();
}
member InputI00AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI01 Property

IRD

Tca6424InputI01 Property

Input (I-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI01 { get; }
Public ReadOnly Property InputI01 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI01 {
    Tca6424TypeLevel get ();
}
member InputI01 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI01AI Property

IRD

Tca6424InputI01AI Property

Input (I-01) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI01AI { get; }
Public ReadOnly Property InputI01AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI01AI {
    Tca6424TypeLevel get ();
}
member InputI01AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI02 Property

IRD

Tca6424InputI02 Property

Input (I-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI02 { get; }
Public ReadOnly Property InputI02 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI02 {
    Tca6424TypeLevel get ();
}
member InputI02 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI02AI Property

IRD

Tca6424InputI02AI Property

Input (I-02) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI02AI { get; }
Public ReadOnly Property InputI02AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI02AI {
    Tca6424TypeLevel get ();
}
member InputI02AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI03 Property

IRD

Tca6424InputI03 Property

Input (I-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI03 { get; }
Public ReadOnly Property InputI03 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI03 {
    Tca6424TypeLevel get ();
}
member InputI03 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI03AI Property

IRD

Tca6424InputI03AI Property

Input (I-03) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI03AI { get; }
Public ReadOnly Property InputI03AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI03AI {
    Tca6424TypeLevel get ();
}
member InputI03AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI04 Property

IRD

Tca6424InputI04 Property

Input (I-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI04 { get; }
Public ReadOnly Property InputI04 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI04 {
    Tca6424TypeLevel get ();
}
member InputI04 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI04AI Property

IRD

Tca6424InputI04AI Property

Input (I-04) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI04AI { get; }
Public ReadOnly Property InputI04AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI04AI {
    Tca6424TypeLevel get ();
}
member InputI04AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI05 Property

IRD

Tca6424InputI05 Property

Input (I-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI05 { get; }
Public ReadOnly Property InputI05 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI05 {
    Tca6424TypeLevel get ();
}
member InputI05 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI05AI Property

IRD

Tca6424InputI05AI Property

Input (I-05) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI05AI { get; }
Public ReadOnly Property InputI05AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI05AI {
    Tca6424TypeLevel get ();
}
member InputI05AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI06 Property

IRD

Tca6424InputI06 Property

Input (I-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI06 { get; }
Public ReadOnly Property InputI06 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI06 {
    Tca6424TypeLevel get ();
}
member InputI06 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI06AI Property

IRD

Tca6424InputI06AI Property

Input (I-06) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI06AI { get; }
Public ReadOnly Property InputI06AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI06AI {
    Tca6424TypeLevel get ();
}
member InputI06AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI07 Property

IRD

Tca6424InputI07 Property

Input (I-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI07 { get; }
Public ReadOnly Property InputI07 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI07 {
    Tca6424TypeLevel get ();
}
member InputI07 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI07AI Property

IRD

Tca6424InputI07AI Property

Input (I-07) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI07AI { get; }
Public ReadOnly Property InputI07AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI07AI {
    Tca6424TypeLevel get ();
}
member InputI07AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI10 Property

IRD

Tca6424InputI10 Property

Input (I-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI10 { get; }
Public ReadOnly Property InputI10 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI10 {
    Tca6424TypeLevel get ();
}
member InputI10 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI10AI Property

IRD

Tca6424InputI10AI Property

Input (I-10) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI10AI { get; }
Public ReadOnly Property InputI10AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI10AI {
    Tca6424TypeLevel get ();
}
member InputI10AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI11 Property

IRD

Tca6424InputI11 Property

Input (I-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI11 { get; }
Public ReadOnly Property InputI11 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI11 {
    Tca6424TypeLevel get ();
}
member InputI11 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI11AI Property

IRD

Tca6424InputI11AI Property

Input (I-11) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI11AI { get; }
Public ReadOnly Property InputI11AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI11AI {
    Tca6424TypeLevel get ();
}
member InputI11AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI12 Property

IRD

Tca6424InputI12 Property

Input (I-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI12 { get; }
Public ReadOnly Property InputI12 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI12 {
    Tca6424TypeLevel get ();
}
member InputI12 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI12AI Property

IRD

Tca6424InputI12AI Property

Input (I-12) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI12AI { get; }
Public ReadOnly Property InputI12AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI12AI {
    Tca6424TypeLevel get ();
}
member InputI12AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI13 Property

IRD

Tca6424InputI13 Property

Input (I-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI13 { get; }
Public ReadOnly Property InputI13 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI13 {
    Tca6424TypeLevel get ();
}
member InputI13 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI13AI Property

IRD

Tca6424InputI13AI Property

Input (I-13) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI13AI { get; }
Public ReadOnly Property InputI13AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI13AI {
    Tca6424TypeLevel get ();
}
member InputI13AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI14 Property

IRD

Tca6424InputI14 Property

Input (I-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI14 { get; }
Public ReadOnly Property InputI14 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI14 {
    Tca6424TypeLevel get ();
}
member InputI14 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI14AI Property

IRD

Tca6424InputI14AI Property

Input (I-14) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI14AI { get; }
Public ReadOnly Property InputI14AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI14AI {
    Tca6424TypeLevel get ();
}
member InputI14AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI15 Property

IRD

Tca6424InputI15 Property

Input (I-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI15 { get; }
Public ReadOnly Property InputI15 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI15 {
    Tca6424TypeLevel get ();
}
member InputI15 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI15AI Property

IRD

Tca6424InputI15AI Property

Input (I-15) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI15AI { get; }
Public ReadOnly Property InputI15AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI15AI {
    Tca6424TypeLevel get ();
}
member InputI15AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI16 Property

IRD

Tca6424InputI16 Property

Input (I-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI16 { get; }
Public ReadOnly Property InputI16 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI16 {
    Tca6424TypeLevel get ();
}
member InputI16 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI16AI Property

IRD

Tca6424InputI16AI Property

Input (I-16) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI16AI { get; }
Public ReadOnly Property InputI16AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI16AI {
    Tca6424TypeLevel get ();
}
member InputI16AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI17 Property

IRD

Tca6424InputI17 Property

Input (I-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI17 { get; }
Public ReadOnly Property InputI17 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI17 {
    Tca6424TypeLevel get ();
}
member InputI17 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI17AI Property

IRD

Tca6424InputI17AI Property

Input (I-17) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI17AI { get; }
Public ReadOnly Property InputI17AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI17AI {
    Tca6424TypeLevel get ();
}
member InputI17AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI20 Property

IRD

Tca6424InputI20 Property

Input (I-20)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI20 { get; }
Public ReadOnly Property InputI20 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI20 {
    Tca6424TypeLevel get ();
}
member InputI20 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI20AI Property

IRD

Tca6424InputI20AI Property

Input (I-20) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI20AI { get; }
Public ReadOnly Property InputI20AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI20AI {
    Tca6424TypeLevel get ();
}
member InputI20AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI21 Property

IRD

Tca6424InputI21 Property

Input (I-21)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI21 { get; }
Public ReadOnly Property InputI21 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI21 {
    Tca6424TypeLevel get ();
}
member InputI21 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI21AI Property

IRD

Tca6424InputI21AI Property

Input (I-21) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI21AI { get; }
Public ReadOnly Property InputI21AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI21AI {
    Tca6424TypeLevel get ();
}
member InputI21AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI22 Property

IRD

Tca6424InputI22 Property

Input (I-22)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI22 { get; }
Public ReadOnly Property InputI22 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI22 {
    Tca6424TypeLevel get ();
}
member InputI22 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI22AI Property

IRD

Tca6424InputI22AI Property

Input (I-22) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI22AI { get; }
Public ReadOnly Property InputI22AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI22AI {
    Tca6424TypeLevel get ();
}
member InputI22AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI23 Property

IRD

Tca6424InputI23 Property

Input (I-23)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI23 { get; }
Public ReadOnly Property InputI23 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI23 {
    Tca6424TypeLevel get ();
}
member InputI23 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI23AI Property

IRD

Tca6424InputI23AI Property

Input (I-23) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI23AI { get; }
Public ReadOnly Property InputI23AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI23AI {
    Tca6424TypeLevel get ();
}
member InputI23AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI24 Property

IRD

Tca6424InputI24 Property

Input (I-24)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI24 { get; }
Public ReadOnly Property InputI24 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI24 {
    Tca6424TypeLevel get ();
}
member InputI24 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI24AI Property

IRD

Tca6424InputI24AI Property

Input (I-24) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI24AI { get; }
Public ReadOnly Property InputI24AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI24AI {
    Tca6424TypeLevel get ();
}
member InputI24AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI25 Property

IRD

Tca6424InputI25 Property

Input (I-25)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI25 { get; }
Public ReadOnly Property InputI25 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI25 {
    Tca6424TypeLevel get ();
}
member InputI25 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI25AI Property

IRD

Tca6424InputI25AI Property

Input (I-25) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI25AI { get; }
Public ReadOnly Property InputI25AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI25AI {
    Tca6424TypeLevel get ();
}
member InputI25AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI26 Property

IRD

Tca6424InputI26 Property

Input (I-26)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI26 { get; }
Public ReadOnly Property InputI26 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI26 {
    Tca6424TypeLevel get ();
}
member InputI26 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI26AI Property

IRD

Tca6424InputI26AI Property

Input (I-26) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI26AI { get; }
Public ReadOnly Property InputI26AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI26AI {
    Tca6424TypeLevel get ();
}
member InputI26AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI27 Property

IRD

Tca6424InputI27 Property

Input (I-27)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI27 { get; }
Public ReadOnly Property InputI27 As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI27 {
    Tca6424TypeLevel get ();
}
member InputI27 : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.InputI27AI Property

IRD

Tca6424InputI27AI Property

Input (I-27) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel InputI27AI { get; }
Public ReadOnly Property InputI27AI As Tca6424TypeLevel
    Get
public:
property Tca6424TypeLevel InputI27AI {
    Tca6424TypeLevel get ();
}
member InputI27AI : Tca6424TypeLevel with get

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO00 Property

IRD

Tca6424OutputO00 Property

Output (O-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO00 { get; set; }
Public Property OutputO00 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO00 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO00 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO00AI Property

IRD

Tca6424OutputO00AI Property

Output (O-00) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO00AI { get; set; }
Public Property OutputO00AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO00AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO00AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO01 Property

IRD

Tca6424OutputO01 Property

Output (O-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO01 { get; set; }
Public Property OutputO01 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO01 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO01 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO01AI Property

IRD

Tca6424OutputO01AI Property

Output (O-01) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO01AI { get; set; }
Public Property OutputO01AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO01AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO01AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO02 Property

IRD

Tca6424OutputO02 Property

Output (O-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO02 { get; set; }
Public Property OutputO02 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO02 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO02 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO02AI Property

IRD

Tca6424OutputO02AI Property

Output (O-02) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO02AI { get; set; }
Public Property OutputO02AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO02AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO02AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO03 Property

IRD

Tca6424OutputO03 Property

Output (O-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO03 { get; set; }
Public Property OutputO03 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO03 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO03 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO03AI Property

IRD

Tca6424OutputO03AI Property

Output (O-03) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO03AI { get; set; }
Public Property OutputO03AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO03AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO03AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO04 Property

IRD

Tca6424OutputO04 Property

Output (O-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO04 { get; set; }
Public Property OutputO04 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO04 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO04 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO04AI Property

IRD

Tca6424OutputO04AI Property

Output (O-04) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO04AI { get; set; }
Public Property OutputO04AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO04AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO04AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO05 Property

IRD

Tca6424OutputO05 Property

Output (O-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO05 { get; set; }
Public Property OutputO05 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO05 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO05 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO05AI Property

IRD

Tca6424OutputO05AI Property

Output (O-05) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO05AI { get; set; }
Public Property OutputO05AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO05AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO05AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO06 Property

IRD

Tca6424OutputO06 Property

Output (O-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO06 { get; set; }
Public Property OutputO06 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO06 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO06 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO06AI Property

IRD

Tca6424OutputO06AI Property

Output (O-06) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO06AI { get; set; }
Public Property OutputO06AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO06AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO06AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO07 Property

IRD

Tca6424OutputO07 Property

Output (O-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO07 { get; set; }
Public Property OutputO07 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO07 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO07 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO07AI Property

IRD

Tca6424OutputO07AI Property

Output (O-07) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO07AI { get; set; }
Public Property OutputO07AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO07AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO07AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO10 Property

IRD

Tca6424OutputO10 Property

Output (O-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO10 { get; set; }
Public Property OutputO10 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO10 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO10 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO10AI Property

IRD

Tca6424OutputO10AI Property

Output (O-10) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO10AI { get; set; }
Public Property OutputO10AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO10AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO10AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO11 Property

IRD

Tca6424OutputO11 Property

Output (O-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO11 { get; set; }
Public Property OutputO11 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO11 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO11 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO11AI Property

IRD

Tca6424OutputO11AI Property

Output (O-11) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO11AI { get; set; }
Public Property OutputO11AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO11AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO11AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO12 Property

IRD

Tca6424OutputO12 Property

Output (O-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO12 { get; set; }
Public Property OutputO12 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO12 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO12 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO12AI Property

IRD

Tca6424OutputO12AI Property

Output (O-12) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO12AI { get; set; }
Public Property OutputO12AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO12AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO12AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO13 Property

IRD

Tca6424OutputO13 Property

Output (O-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO13 { get; set; }
Public Property OutputO13 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO13 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO13 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO13AI Property

IRD

Tca6424OutputO13AI Property

Output (O-13) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO13AI { get; set; }
Public Property OutputO13AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO13AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO13AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO14 Property

IRD

Tca6424OutputO14 Property

Output (O-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO14 { get; set; }
Public Property OutputO14 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO14 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO14 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO14AI Property

IRD

Tca6424OutputO14AI Property

Output (O-14) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO14AI { get; set; }
Public Property OutputO14AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO14AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO14AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO15 Property

IRD

Tca6424OutputO15 Property

Output (O-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO15 { get; set; }
Public Property OutputO15 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO15 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO15 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO15AI Property

IRD

Tca6424OutputO15AI Property

Output (O-15) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO15AI { get; set; }
Public Property OutputO15AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO15AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO15AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO16 Property

IRD

Tca6424OutputO16 Property

Output (O-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO16 { get; set; }
Public Property OutputO16 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO16 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO16 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO16AI Property

IRD

Tca6424OutputO16AI Property

Output (O-16) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO16AI { get; set; }
Public Property OutputO16AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO16AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO16AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO17 Property

IRD

Tca6424OutputO17 Property

Output (O-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO17 { get; set; }
Public Property OutputO17 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO17 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO17 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO17AI Property

IRD

Tca6424OutputO17AI Property

Output (O-17) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO17AI { get; set; }
Public Property OutputO17AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO17AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO17AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO20 Property

IRD

Tca6424OutputO20 Property

Output (O-20)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO20 { get; set; }
Public Property OutputO20 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO20 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO20 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO20AI Property

IRD

Tca6424OutputO20AI Property

Output (O-20) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO20AI { get; set; }
Public Property OutputO20AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO20AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO20AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO21 Property

IRD

Tca6424OutputO21 Property

Output (O-21)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO21 { get; set; }
Public Property OutputO21 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO21 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO21 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO21AI Property

IRD

Tca6424OutputO21AI Property

Output (O-21) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO21AI { get; set; }
Public Property OutputO21AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO21AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO21AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO22 Property

IRD

Tca6424OutputO22 Property

Output (O-22)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO22 { get; set; }
Public Property OutputO22 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO22 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO22 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO22AI Property

IRD

Tca6424OutputO22AI Property

Output (O-22) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO22AI { get; set; }
Public Property OutputO22AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO22AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO22AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO23 Property

IRD

Tca6424OutputO23 Property

Output (O-23)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO23 { get; set; }
Public Property OutputO23 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO23 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO23 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO23AI Property

IRD

Tca6424OutputO23AI Property

Output (O-23) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO23AI { get; set; }
Public Property OutputO23AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO23AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO23AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO24 Property

IRD

Tca6424OutputO24 Property

Output (O-24)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO24 { get; set; }
Public Property OutputO24 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO24 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO24 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO24AI Property

IRD

Tca6424OutputO24AI Property

Output (O-24) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO24AI { get; set; }
Public Property OutputO24AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO24AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO24AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO25 Property

IRD

Tca6424OutputO25 Property

Output (O-25)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO25 { get; set; }
Public Property OutputO25 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO25 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO25 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO25AI Property

IRD

Tca6424OutputO25AI Property

Output (O-25) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO25AI { get; set; }
Public Property OutputO25AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO25AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO25AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO26 Property

IRD

Tca6424OutputO26 Property

Output (O-26)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO26 { get; set; }
Public Property OutputO26 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO26 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO26 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO26AI Property

IRD

Tca6424OutputO26AI Property

Output (O-26) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO26AI { get; set; }
Public Property OutputO26AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO26AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO26AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO27 Property

IRD

Tca6424OutputO27 Property

Output (O-27)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO27 { get; set; }
Public Property OutputO27 As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO27 {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO27 : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.OutputO27AI Property

IRD

Tca6424OutputO27AI Property

Output (O-27) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypeLevel OutputO27AI { get; set; }
Public Property OutputO27AI As Tca6424TypeLevel
    Get
    Set
public:
property Tca6424TypeLevel OutputO27AI {
    Tca6424TypeLevel get ();
    void set (Tca6424TypeLevel value);
}
member OutputO27AI : Tca6424TypeLevel with get, set

Property Value

Type: Tca6424TypeLevel
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP00 Property

IRD

Tca6424PolarityInversionP00 Property

Polarity Inversion (P-00)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP00 { get; set; }
Public Property PolarityInversionP00 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP00 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP00 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP00AI Property

IRD

Tca6424PolarityInversionP00AI Property

Polarity Inversion (P-00) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP00AI { get; set; }
Public Property PolarityInversionP00AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP00AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP00AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP01 Property

IRD

Tca6424PolarityInversionP01 Property

Polarity Inversion (P-01)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP01 { get; set; }
Public Property PolarityInversionP01 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP01 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP01 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP01AI Property

IRD

Tca6424PolarityInversionP01AI Property

Polarity Inversion (P-01) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP01AI { get; set; }
Public Property PolarityInversionP01AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP01AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP01AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP02 Property

IRD

Tca6424PolarityInversionP02 Property

Polarity Inversion (P-02)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP02 { get; set; }
Public Property PolarityInversionP02 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP02 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP02 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP02AI Property

IRD

Tca6424PolarityInversionP02AI Property

Polarity Inversion (P-02) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP02AI { get; set; }
Public Property PolarityInversionP02AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP02AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP02AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP03 Property

IRD

Tca6424PolarityInversionP03 Property

Polarity Inversion (P-03)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP03 { get; set; }
Public Property PolarityInversionP03 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP03 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP03 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP03AI Property

IRD

Tca6424PolarityInversionP03AI Property

Polarity Inversion (P-03) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP03AI { get; set; }
Public Property PolarityInversionP03AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP03AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP03AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP04 Property

IRD

Tca6424PolarityInversionP04 Property

Polarity Inversion (P-04)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP04 { get; set; }
Public Property PolarityInversionP04 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP04 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP04 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP04AI Property

IRD

Tca6424PolarityInversionP04AI Property

Polarity Inversion (P-04) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP04AI { get; set; }
Public Property PolarityInversionP04AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP04AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP04AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP05 Property

IRD

Tca6424PolarityInversionP05 Property

Polarity Inversion (P-05)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP05 { get; set; }
Public Property PolarityInversionP05 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP05 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP05 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP05AI Property

IRD

Tca6424PolarityInversionP05AI Property

Polarity Inversion (P-05) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP05AI { get; set; }
Public Property PolarityInversionP05AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP05AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP05AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP06 Property

IRD

Tca6424PolarityInversionP06 Property

Polarity Inversion (P-06)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP06 { get; set; }
Public Property PolarityInversionP06 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP06 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP06 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP06AI Property

IRD

Tca6424PolarityInversionP06AI Property

Polarity Inversion (P-06) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP06AI { get; set; }
Public Property PolarityInversionP06AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP06AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP06AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP07 Property

IRD

Tca6424PolarityInversionP07 Property

Polarity Inversion (P-07)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP07 { get; set; }
Public Property PolarityInversionP07 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP07 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP07 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP07AI Property

IRD

Tca6424PolarityInversionP07AI Property

Polarity Inversion (P-07) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP07AI { get; set; }
Public Property PolarityInversionP07AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP07AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP07AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP10 Property

IRD

Tca6424PolarityInversionP10 Property

Polarity Inversion (P-10)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP10 { get; set; }
Public Property PolarityInversionP10 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP10 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP10 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP10AI Property

IRD

Tca6424PolarityInversionP10AI Property

Polarity Inversion (P-10) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP10AI { get; set; }
Public Property PolarityInversionP10AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP10AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP10AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP11 Property

IRD

Tca6424PolarityInversionP11 Property

Polarity Inversion (P-11)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP11 { get; set; }
Public Property PolarityInversionP11 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP11 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP11 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP11AI Property

IRD

Tca6424PolarityInversionP11AI Property

Polarity Inversion (P-11) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP11AI { get; set; }
Public Property PolarityInversionP11AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP11AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP11AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP12 Property

IRD

Tca6424PolarityInversionP12 Property

Polarity Inversion (P-12)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP12 { get; set; }
Public Property PolarityInversionP12 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP12 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP12 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP12AI Property

IRD

Tca6424PolarityInversionP12AI Property

Polarity Inversion (P-12) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP12AI { get; set; }
Public Property PolarityInversionP12AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP12AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP12AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP13 Property

IRD

Tca6424PolarityInversionP13 Property

Polarity Inversion (P-13)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP13 { get; set; }
Public Property PolarityInversionP13 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP13 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP13 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP13AI Property

IRD

Tca6424PolarityInversionP13AI Property

Polarity Inversion (P-13) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP13AI { get; set; }
Public Property PolarityInversionP13AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP13AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP13AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP14 Property

IRD

Tca6424PolarityInversionP14 Property

Polarity Inversion (P-14)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP14 { get; set; }
Public Property PolarityInversionP14 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP14 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP14 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP14AI Property

IRD

Tca6424PolarityInversionP14AI Property

Polarity Inversion (P-14) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP14AI { get; set; }
Public Property PolarityInversionP14AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP14AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP14AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP15 Property

IRD

Tca6424PolarityInversionP15 Property

Polarity Inversion (P-15)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP15 { get; set; }
Public Property PolarityInversionP15 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP15 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP15 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP15AI Property

IRD

Tca6424PolarityInversionP15AI Property

Polarity Inversion (P-15) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP15AI { get; set; }
Public Property PolarityInversionP15AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP15AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP15AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP16 Property

IRD

Tca6424PolarityInversionP16 Property

Polarity Inversion (P-16)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP16 { get; set; }
Public Property PolarityInversionP16 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP16 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP16 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP16AI Property

IRD

Tca6424PolarityInversionP16AI Property

Polarity Inversion (P-16) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP16AI { get; set; }
Public Property PolarityInversionP16AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP16AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP16AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP17 Property

IRD

Tca6424PolarityInversionP17 Property

Polarity Inversion (P-17)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP17 { get; set; }
Public Property PolarityInversionP17 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP17 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP17 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP17AI Property

IRD

Tca6424PolarityInversionP17AI Property

Polarity Inversion (P-17) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP17AI { get; set; }
Public Property PolarityInversionP17AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP17AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP17AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP20 Property

IRD

Tca6424PolarityInversionP20 Property

Polarity Inversion (P-20)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP20 { get; set; }
Public Property PolarityInversionP20 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP20 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP20 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP20AI Property

IRD

Tca6424PolarityInversionP20AI Property

Polarity Inversion (P-20) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP20AI { get; set; }
Public Property PolarityInversionP20AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP20AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP20AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP21 Property

IRD

Tca6424PolarityInversionP21 Property

Polarity Inversion (P-21)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP21 { get; set; }
Public Property PolarityInversionP21 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP21 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP21 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP21AI Property

IRD

Tca6424PolarityInversionP21AI Property

Polarity Inversion (P-21) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP21AI { get; set; }
Public Property PolarityInversionP21AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP21AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP21AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP22 Property

IRD

Tca6424PolarityInversionP22 Property

Polarity Inversion (P-22)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP22 { get; set; }
Public Property PolarityInversionP22 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP22 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP22 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP22AI Property

IRD

Tca6424PolarityInversionP22AI Property

Polarity Inversion (P-22) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP22AI { get; set; }
Public Property PolarityInversionP22AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP22AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP22AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP23 Property

IRD

Tca6424PolarityInversionP23 Property

Polarity Inversion (P-23)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP23 { get; set; }
Public Property PolarityInversionP23 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP23 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP23 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP23AI Property

IRD

Tca6424PolarityInversionP23AI Property

Polarity Inversion (P-23) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP23AI { get; set; }
Public Property PolarityInversionP23AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP23AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP23AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP24 Property

IRD

Tca6424PolarityInversionP24 Property

Polarity Inversion (P-24)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP24 { get; set; }
Public Property PolarityInversionP24 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP24 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP24 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP24AI Property

IRD

Tca6424PolarityInversionP24AI Property

Polarity Inversion (P-24) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP24AI { get; set; }
Public Property PolarityInversionP24AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP24AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP24AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP25 Property

IRD

Tca6424PolarityInversionP25 Property

Polarity Inversion (P-25)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP25 { get; set; }
Public Property PolarityInversionP25 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP25 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP25 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP25AI Property

IRD

Tca6424PolarityInversionP25AI Property

Polarity Inversion (P-25) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP25AI { get; set; }
Public Property PolarityInversionP25AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP25AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP25AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP26 Property

IRD

Tca6424PolarityInversionP26 Property

Polarity Inversion (P-26)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP26 { get; set; }
Public Property PolarityInversionP26 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP26 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP26 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP26AI Property

IRD

Tca6424PolarityInversionP26AI Property

Polarity Inversion (P-26) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP26AI { get; set; }
Public Property PolarityInversionP26AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP26AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP26AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP27 Property

IRD

Tca6424PolarityInversionP27 Property

Polarity Inversion (P-27)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP27 { get; set; }
Public Property PolarityInversionP27 As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP27 {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP27 : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.PolarityInversionP27AI Property

IRD

Tca6424PolarityInversionP27AI Property

Polarity Inversion (P-27) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6424TypePolarity PolarityInversionP27AI { get; set; }
Public Property PolarityInversionP27AI As Tca6424TypePolarity
    Get
    Set
public:
property Tca6424TypePolarity PolarityInversionP27AI {
    Tca6424TypePolarity get ();
    void set (Tca6424TypePolarity value);
}
member PolarityInversionP27AI : Tca6424TypePolarity with get, set

Property Value

Type: Tca6424TypePolarity
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424 Methods

The Tca6424 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.Flush Method

IRD

Tca6424Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Tca6424 Class
telos.Ird.TexasInstruments Namespace


Tca6424.TypeConfiguration Enumeration

IRD

Tca6424TypeConfiguration Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeConfiguration
Public Enumeration TypeConfiguration
public enum class TypeConfiguration
type TypeConfiguration
Members
Member name | Value | Description
Input | 1 | Input
Output | 0 | Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6424.TypeLevel Enumeration

IRD

Tca6424TypeLevel Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeLevel
Public Enumeration TypeLevel
public enum class TypeLevel
type TypeLevel
Members
Member name | Value | Description
High | 1 | High
Low | 0 | Low
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6424.TypePolarity Enumeration

IRD

Tca6424TypePolarity Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypePolarity
Public Enumeration TypePolarity
public enum class TypePolarity
type TypePolarity
Members
Member name | Value | Description
Inverted | 1 | Inverted
Normal | 0 | Normal
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6507 Class

Texas Instruments: TCA 6507
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsTca6507

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Tca6507
Public Class Tca6507
public ref class Tca6507
type Tca6507 =  class end

The Tca6507 type exposes the following members.

Constructors
 | Name | Description
Public method | Tca6507 | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FadeOffTimeBANK0 | Fade-Off Time (BANK0) (unit: ms)
Public property | FadeOffTimeBANK0AI | Fade-Off Time (BANK0) [AI] (unit: ms)
Public property | FadeOffTimeBANK1 | Fade-Off Time (BANK1) (unit: ms)
Public property | FadeOffTimeBANK1AI | Fade-Off Time (BANK1) [AI] (unit: ms)
Public property | FadeOnTimeBANK0 | Fade-On Time (BANK0) (unit: ms)
Public property | FadeOnTimeBANK0AI | Fade-On Time (BANK0) [AI] (unit: ms)
Public property | FadeOnTimeBANK1 | Fade-On Time (BANK1) (unit: ms)
Public property | FadeOnTimeBANK1AI | Fade-On Time (BANK1) [AI] (unit: ms)
Public property | FirstFullyOffTimeBANK0 | First Fully-Off Time (BANK0) (unit: ms)
Public property | FirstFullyOffTimeBANK0AI | First Fully-Off Time (BANK0) [AI] (unit: ms)
Public property | FirstFullyOffTimeBANK1 | First Fully-Off Time (BANK1) (unit: ms)
Public property | FirstFullyOffTimeBANK1AI | First Fully-Off Time (BANK1) [AI] (unit: ms)
Public property | FullyOnTimeBANK0 | Fully-On Time (BANK0) (unit: ms)
Public property | FullyOnTimeBANK0AI | Fully-On Time (BANK0) [AI] (unit: ms)
Public property | FullyOnTimeBANK1 | Fully-On Time (BANK1) (unit: ms)
Public property | FullyOnTimeBANK1AI | Fully-On Time (BANK1) [AI] (unit: ms)
Public property | InitializationBANK0 | Initialization (BANK0)
Public property | InitializationBANK0AI | Initialization (BANK0) [AI]
Public property | InitializationBANK1 | Initialization (BANK1)
Public property | InitializationBANK1AI | Initialization (BANK1) [AI]
Public property | InitializePWM0 | Initialize (PWM0)
Public property | InitializePWM0AI | Initialize (PWM0) [AI]
Public property | InitializePWM1 | Initialize (PWM1)
Public property | InitializePWM1AI | Initialize (PWM1) [AI]
Public property | MasterIntensityALD | Master Intensity (ALD)
Public property | MasterIntensityALDAI | Master Intensity (ALD) [AI]
Public property | MaximumIntensityBANK0 | Maximum Intensity (BANK0)
Public property | MaximumIntensityBANK0AI | Maximum Intensity (BANK0) [AI]
Public property | MaximumIntensityBANK1 | Maximum Intensity (BANK1)
Public property | MaximumIntensityBANK1AI | Maximum Intensity (BANK1) [AI]
Public property | MaximumIntensityPWM0 | Maximum Intensity (PWM0)
Public property | MaximumIntensityPWM0AI | Maximum Intensity (PWM0) [AI]
Public property | MaximumIntensityPWM1 | Maximum Intensity (PWM1)
Public property | MaximumIntensityPWM1AI | Maximum Intensity (PWM1) [AI]
Public property | OneShotPWM0 | One-Shot (PWM0)
Public property | OneShotPWM0AI | One-Shot (PWM0) [AI]
Public property | OneShotPWM1 | One-Shot (PWM1)
Public property | OneShotPWM1AI | One-Shot (PWM1) [AI]
Public property | SecondFullyOffTimeBANK0 | Second Fully-Off Time (BANK0) (unit: ms)
Public property | SecondFullyOffTimeBANK0AI | Second Fully-Off Time (BANK0) [AI] (unit: ms)
Public property | SecondFullyOffTimeBANK1 | Second Fully-Off Time (BANK1) (unit: ms)
Public property | SecondFullyOffTimeBANK1AI | Second Fully-Off Time (BANK1) [AI] (unit: ms)
Public property | SelectP0 | Select (P0)
Public property | SelectP0AI | Select (P0) [AI]
Public property | SelectP1 | Select (P1)
Public property | SelectP1AI | Select (P1) [AI]
Public property | SelectP2 | Select (P2)
Public property | SelectP2AI | Select (P2) [AI]
Public property | SelectP3 | Select (P3)
Public property | SelectP3AI | Select (P3) [AI]
Public property | SelectP4 | Select (P4)
Public property | SelectP4AI | Select (P4) [AI]
Public property | SelectP5 | Select (P5)
Public property | SelectP5AI | Select (P5) [AI]
Public property | SelectP6 | Select (P6)
Public property | SelectP6AI | Select (P6) [AI]
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Voltage 7-Bit I2C And SMBus LED Driver With Intensity Control And Shutdown
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6507 Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Tca6507(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Tca6507

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507 Properties

The Tca6507 type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | FadeOffTimeBANK0 | Fade-Off Time (BANK0) (unit: ms)
Public property | FadeOffTimeBANK0AI | Fade-Off Time (BANK0) [AI] (unit: ms)
Public property | FadeOffTimeBANK1 | Fade-Off Time (BANK1) (unit: ms)
Public property | FadeOffTimeBANK1AI | Fade-Off Time (BANK1) [AI] (unit: ms)
Public property | FadeOnTimeBANK0 | Fade-On Time (BANK0) (unit: ms)
Public property | FadeOnTimeBANK0AI | Fade-On Time (BANK0) [AI] (unit: ms)
Public property | FadeOnTimeBANK1 | Fade-On Time (BANK1) (unit: ms)
Public property | FadeOnTimeBANK1AI | Fade-On Time (BANK1) [AI] (unit: ms)
Public property | FirstFullyOffTimeBANK0 | First Fully-Off Time (BANK0) (unit: ms)
Public property | FirstFullyOffTimeBANK0AI | First Fully-Off Time (BANK0) [AI] (unit: ms)
Public property | FirstFullyOffTimeBANK1 | First Fully-Off Time (BANK1) (unit: ms)
Public property | FirstFullyOffTimeBANK1AI | First Fully-Off Time (BANK1) [AI] (unit: ms)
Public property | FullyOnTimeBANK0 | Fully-On Time (BANK0) (unit: ms)
Public property | FullyOnTimeBANK0AI | Fully-On Time (BANK0) [AI] (unit: ms)
Public property | FullyOnTimeBANK1 | Fully-On Time (BANK1) (unit: ms)
Public property | FullyOnTimeBANK1AI | Fully-On Time (BANK1) [AI] (unit: ms)
Public property | InitializationBANK0 | Initialization (BANK0)
Public property | InitializationBANK0AI | Initialization (BANK0) [AI]
Public property | InitializationBANK1 | Initialization (BANK1)
Public property | InitializationBANK1AI | Initialization (BANK1) [AI]
Public property | InitializePWM0 | Initialize (PWM0)
Public property | InitializePWM0AI | Initialize (PWM0) [AI]
Public property | InitializePWM1 | Initialize (PWM1)
Public property | InitializePWM1AI | Initialize (PWM1) [AI]
Public property | MasterIntensityALD | Master Intensity (ALD)
Public property | MasterIntensityALDAI | Master Intensity (ALD) [AI]
Public property | MaximumIntensityBANK0 | Maximum Intensity (BANK0)
Public property | MaximumIntensityBANK0AI | Maximum Intensity (BANK0) [AI]
Public property | MaximumIntensityBANK1 | Maximum Intensity (BANK1)
Public property | MaximumIntensityBANK1AI | Maximum Intensity (BANK1) [AI]
Public property | MaximumIntensityPWM0 | Maximum Intensity (PWM0)
Public property | MaximumIntensityPWM0AI | Maximum Intensity (PWM0) [AI]
Public property | MaximumIntensityPWM1 | Maximum Intensity (PWM1)
Public property | MaximumIntensityPWM1AI | Maximum Intensity (PWM1) [AI]
Public property | OneShotPWM0 | One-Shot (PWM0)
Public property | OneShotPWM0AI | One-Shot (PWM0) [AI]
Public property | OneShotPWM1 | One-Shot (PWM1)
Public property | OneShotPWM1AI | One-Shot (PWM1) [AI]
Public property | SecondFullyOffTimeBANK0 | Second Fully-Off Time (BANK0) (unit: ms)
Public property | SecondFullyOffTimeBANK0AI | Second Fully-Off Time (BANK0) [AI] (unit: ms)
Public property | SecondFullyOffTimeBANK1 | Second Fully-Off Time (BANK1) (unit: ms)
Public property | SecondFullyOffTimeBANK1AI | Second Fully-Off Time (BANK1) [AI] (unit: ms)
Public property | SelectP0 | Select (P0)
Public property | SelectP0AI | Select (P0) [AI]
Public property | SelectP1 | Select (P1)
Public property | SelectP1AI | Select (P1) [AI]
Public property | SelectP2 | Select (P2)
Public property | SelectP2AI | Select (P2) [AI]
Public property | SelectP3 | Select (P3)
Public property | SelectP3AI | Select (P3) [AI]
Public property | SelectP4 | Select (P4)
Public property | SelectP4AI | Select (P4) [AI]
Public property | SelectP5 | Select (P5)
Public property | SelectP5AI | Select (P5) [AI]
Public property | SelectP6 | Select (P6)
Public property | SelectP6AI | Select (P6) [AI]
Top
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.AutoFlush Property

IRD

Tca6507AutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.FadeOffTimeBANK0 Property

IRD

Tca6507FadeOffTimeBANK0 Property

Fade-Off Time (BANK0) (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming FadeOffTimeBANK0 { get; set; }
Public Property FadeOffTimeBANK0 As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming FadeOffTimeBANK0 {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member FadeOffTimeBANK0 : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.FadeOffTimeBANK0AI Property

IRD

Tca6507FadeOffTimeBANK0AI Property

Fade-Off Time (BANK0) [AI] (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming FadeOffTimeBANK0AI { get; set; }
Public Property FadeOffTimeBANK0AI As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming FadeOffTimeBANK0AI {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member FadeOffTimeBANK0AI : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.FadeOffTimeBANK1 Property

IRD

Tca6507FadeOffTimeBANK1 Property

Fade-Off Time (BANK1) (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming FadeOffTimeBANK1 { get; set; }
Public Property FadeOffTimeBANK1 As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming FadeOffTimeBANK1 {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member FadeOffTimeBANK1 : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.FadeOffTimeBANK1AI Property

IRD

Tca6507FadeOffTimeBANK1AI Property

Fade-Off Time (BANK1) [AI] (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming FadeOffTimeBANK1AI { get; set; }
Public Property FadeOffTimeBANK1AI As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming FadeOffTimeBANK1AI {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member FadeOffTimeBANK1AI : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.FadeOnTimeBANK0 Property

IRD

Tca6507FadeOnTimeBANK0 Property

Fade-On Time (BANK0) (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming FadeOnTimeBANK0 { get; set; }
Public Property FadeOnTimeBANK0 As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming FadeOnTimeBANK0 {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member FadeOnTimeBANK0 : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.FadeOnTimeBANK0AI Property

IRD

Tca6507FadeOnTimeBANK0AI Property

Fade-On Time (BANK0) [AI] (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming FadeOnTimeBANK0AI { get; set; }
Public Property FadeOnTimeBANK0AI As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming FadeOnTimeBANK0AI {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member FadeOnTimeBANK0AI : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.FadeOnTimeBANK1 Property

IRD

Tca6507FadeOnTimeBANK1 Property

Fade-On Time (BANK1) (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming FadeOnTimeBANK1 { get; set; }
Public Property FadeOnTimeBANK1 As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming FadeOnTimeBANK1 {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member FadeOnTimeBANK1 : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.FadeOnTimeBANK1AI Property

IRD

Tca6507FadeOnTimeBANK1AI Property

Fade-On Time (BANK1) [AI] (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming FadeOnTimeBANK1AI { get; set; }
Public Property FadeOnTimeBANK1AI As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming FadeOnTimeBANK1AI {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member FadeOnTimeBANK1AI : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.FirstFullyOffTimeBANK0 Property

IRD

Tca6507FirstFullyOffTimeBANK0 Property

First Fully-Off Time (BANK0) (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming FirstFullyOffTimeBANK0 { get; set; }
Public Property FirstFullyOffTimeBANK0 As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming FirstFullyOffTimeBANK0 {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member FirstFullyOffTimeBANK0 : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.FirstFullyOffTimeBANK0AI Property

IRD

Tca6507FirstFullyOffTimeBANK0AI Property

First Fully-Off Time (BANK0) [AI] (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming FirstFullyOffTimeBANK0AI { get; set; }
Public Property FirstFullyOffTimeBANK0AI As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming FirstFullyOffTimeBANK0AI {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member FirstFullyOffTimeBANK0AI : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.FirstFullyOffTimeBANK1 Property

IRD

Tca6507FirstFullyOffTimeBANK1 Property

First Fully-Off Time (BANK1) (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming FirstFullyOffTimeBANK1 { get; set; }
Public Property FirstFullyOffTimeBANK1 As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming FirstFullyOffTimeBANK1 {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member FirstFullyOffTimeBANK1 : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.FirstFullyOffTimeBANK1AI Property

IRD

Tca6507FirstFullyOffTimeBANK1AI Property

First Fully-Off Time (BANK1) [AI] (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming FirstFullyOffTimeBANK1AI { get; set; }
Public Property FirstFullyOffTimeBANK1AI As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming FirstFullyOffTimeBANK1AI {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member FirstFullyOffTimeBANK1AI : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.FullyOnTimeBANK0 Property

IRD

Tca6507FullyOnTimeBANK0 Property

Fully-On Time (BANK0) (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming FullyOnTimeBANK0 { get; set; }
Public Property FullyOnTimeBANK0 As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming FullyOnTimeBANK0 {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member FullyOnTimeBANK0 : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.FullyOnTimeBANK0AI Property

IRD

Tca6507FullyOnTimeBANK0AI Property

Fully-On Time (BANK0) [AI] (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming FullyOnTimeBANK0AI { get; set; }
Public Property FullyOnTimeBANK0AI As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming FullyOnTimeBANK0AI {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member FullyOnTimeBANK0AI : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.FullyOnTimeBANK1 Property

IRD

Tca6507FullyOnTimeBANK1 Property

Fully-On Time (BANK1) (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming FullyOnTimeBANK1 { get; set; }
Public Property FullyOnTimeBANK1 As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming FullyOnTimeBANK1 {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member FullyOnTimeBANK1 : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.FullyOnTimeBANK1AI Property

IRD

Tca6507FullyOnTimeBANK1AI Property

Fully-On Time (BANK1) [AI] (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming FullyOnTimeBANK1AI { get; set; }
Public Property FullyOnTimeBANK1AI As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming FullyOnTimeBANK1AI {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member FullyOnTimeBANK1AI : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.InitializationBANK0 Property

IRD

Tca6507InitializationBANK0 Property

Initialization (BANK0)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeInitialization InitializationBANK0 { set; }
Public WriteOnly Property InitializationBANK0 As Tca6507TypeInitialization
    Set
public:
property Tca6507TypeInitialization InitializationBANK0 {
    void set (Tca6507TypeInitialization value);
}
member InitializationBANK0 : Tca6507TypeInitialization with set

Property Value

Type: Tca6507TypeInitialization
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.InitializationBANK0AI Property

IRD

Tca6507InitializationBANK0AI Property

Initialization (BANK0) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeInitialization InitializationBANK0AI { set; }
Public WriteOnly Property InitializationBANK0AI As Tca6507TypeInitialization
    Set
public:
property Tca6507TypeInitialization InitializationBANK0AI {
    void set (Tca6507TypeInitialization value);
}
member InitializationBANK0AI : Tca6507TypeInitialization with set

Property Value

Type: Tca6507TypeInitialization
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.InitializationBANK1 Property

IRD

Tca6507InitializationBANK1 Property

Initialization (BANK1)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeInitialization InitializationBANK1 { set; }
Public WriteOnly Property InitializationBANK1 As Tca6507TypeInitialization
    Set
public:
property Tca6507TypeInitialization InitializationBANK1 {
    void set (Tca6507TypeInitialization value);
}
member InitializationBANK1 : Tca6507TypeInitialization with set

Property Value

Type: Tca6507TypeInitialization
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.InitializationBANK1AI Property

IRD

Tca6507InitializationBANK1AI Property

Initialization (BANK1) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeInitialization InitializationBANK1AI { set; }
Public WriteOnly Property InitializationBANK1AI As Tca6507TypeInitialization
    Set
public:
property Tca6507TypeInitialization InitializationBANK1AI {
    void set (Tca6507TypeInitialization value);
}
member InitializationBANK1AI : Tca6507TypeInitialization with set

Property Value

Type: Tca6507TypeInitialization
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.InitializePWM0 Property

IRD

Tca6507InitializePWM0 Property

Initialize (PWM0)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeInitializationPwm InitializePWM0 { set; }
Public WriteOnly Property InitializePWM0 As Tca6507TypeInitializationPwm
    Set
public:
property Tca6507TypeInitializationPwm InitializePWM0 {
    void set (Tca6507TypeInitializationPwm value);
}
member InitializePWM0 : Tca6507TypeInitializationPwm with set

Property Value

Type: Tca6507TypeInitializationPwm
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.InitializePWM0AI Property

IRD

Tca6507InitializePWM0AI Property

Initialize (PWM0) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeInitializationPwm InitializePWM0AI { set; }
Public WriteOnly Property InitializePWM0AI As Tca6507TypeInitializationPwm
    Set
public:
property Tca6507TypeInitializationPwm InitializePWM0AI {
    void set (Tca6507TypeInitializationPwm value);
}
member InitializePWM0AI : Tca6507TypeInitializationPwm with set

Property Value

Type: Tca6507TypeInitializationPwm
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.InitializePWM1 Property

IRD

Tca6507InitializePWM1 Property

Initialize (PWM1)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeInitializationPwm InitializePWM1 { set; }
Public WriteOnly Property InitializePWM1 As Tca6507TypeInitializationPwm
    Set
public:
property Tca6507TypeInitializationPwm InitializePWM1 {
    void set (Tca6507TypeInitializationPwm value);
}
member InitializePWM1 : Tca6507TypeInitializationPwm with set

Property Value

Type: Tca6507TypeInitializationPwm
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.InitializePWM1AI Property

IRD

Tca6507InitializePWM1AI Property

Initialize (PWM1) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeInitializationPwm InitializePWM1AI { set; }
Public WriteOnly Property InitializePWM1AI As Tca6507TypeInitializationPwm
    Set
public:
property Tca6507TypeInitializationPwm InitializePWM1AI {
    void set (Tca6507TypeInitializationPwm value);
}
member InitializePWM1AI : Tca6507TypeInitializationPwm with set

Property Value

Type: Tca6507TypeInitializationPwm
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.MasterIntensityALD Property

IRD

Tca6507MasterIntensityALD Property

Master Intensity (ALD)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MasterIntensityALD { get; set; }
Public Property MasterIntensityALD As Byte
    Get
    Set
public:
property unsigned char MasterIntensityALD {
    unsigned char get ();
    void set (unsigned char value);
}
member MasterIntensityALD : byte with get, set

Property Value

Type: Byte
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.MasterIntensityALDAI Property

IRD

Tca6507MasterIntensityALDAI Property

Master Intensity (ALD) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MasterIntensityALDAI { get; set; }
Public Property MasterIntensityALDAI As Byte
    Get
    Set
public:
property unsigned char MasterIntensityALDAI {
    unsigned char get ();
    void set (unsigned char value);
}
member MasterIntensityALDAI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.MaximumIntensityBANK0 Property

IRD

Tca6507MaximumIntensityBANK0 Property

Maximum Intensity (BANK0)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MaximumIntensityBANK0 { get; set; }
Public Property MaximumIntensityBANK0 As Byte
    Get
    Set
public:
property unsigned char MaximumIntensityBANK0 {
    unsigned char get ();
    void set (unsigned char value);
}
member MaximumIntensityBANK0 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.MaximumIntensityBANK0AI Property

IRD

Tca6507MaximumIntensityBANK0AI Property

Maximum Intensity (BANK0) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MaximumIntensityBANK0AI { get; set; }
Public Property MaximumIntensityBANK0AI As Byte
    Get
    Set
public:
property unsigned char MaximumIntensityBANK0AI {
    unsigned char get ();
    void set (unsigned char value);
}
member MaximumIntensityBANK0AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.MaximumIntensityBANK1 Property

IRD

Tca6507MaximumIntensityBANK1 Property

Maximum Intensity (BANK1)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MaximumIntensityBANK1 { get; set; }
Public Property MaximumIntensityBANK1 As Byte
    Get
    Set
public:
property unsigned char MaximumIntensityBANK1 {
    unsigned char get ();
    void set (unsigned char value);
}
member MaximumIntensityBANK1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.MaximumIntensityBANK1AI Property

IRD

Tca6507MaximumIntensityBANK1AI Property

Maximum Intensity (BANK1) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte MaximumIntensityBANK1AI { get; set; }
Public Property MaximumIntensityBANK1AI As Byte
    Get
    Set
public:
property unsigned char MaximumIntensityBANK1AI {
    unsigned char get ();
    void set (unsigned char value);
}
member MaximumIntensityBANK1AI : byte with get, set

Property Value

Type: Byte
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.MaximumIntensityPWM0 Property

IRD

Tca6507MaximumIntensityPWM0 Property

Maximum Intensity (PWM0)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeMaximumIntensityPwm MaximumIntensityPWM0 { get; set; }
Public Property MaximumIntensityPWM0 As Tca6507TypeMaximumIntensityPwm
    Get
    Set
public:
property Tca6507TypeMaximumIntensityPwm MaximumIntensityPWM0 {
    Tca6507TypeMaximumIntensityPwm get ();
    void set (Tca6507TypeMaximumIntensityPwm value);
}
member MaximumIntensityPWM0 : Tca6507TypeMaximumIntensityPwm with get, set

Property Value

Type: Tca6507TypeMaximumIntensityPwm
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.MaximumIntensityPWM0AI Property

IRD

Tca6507MaximumIntensityPWM0AI Property

Maximum Intensity (PWM0) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeMaximumIntensityPwm MaximumIntensityPWM0AI { get; set; }
Public Property MaximumIntensityPWM0AI As Tca6507TypeMaximumIntensityPwm
    Get
    Set
public:
property Tca6507TypeMaximumIntensityPwm MaximumIntensityPWM0AI {
    Tca6507TypeMaximumIntensityPwm get ();
    void set (Tca6507TypeMaximumIntensityPwm value);
}
member MaximumIntensityPWM0AI : Tca6507TypeMaximumIntensityPwm with get, set

Property Value

Type: Tca6507TypeMaximumIntensityPwm
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.MaximumIntensityPWM1 Property

IRD

Tca6507MaximumIntensityPWM1 Property

Maximum Intensity (PWM1)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeMaximumIntensityPwm MaximumIntensityPWM1 { get; set; }
Public Property MaximumIntensityPWM1 As Tca6507TypeMaximumIntensityPwm
    Get
    Set
public:
property Tca6507TypeMaximumIntensityPwm MaximumIntensityPWM1 {
    Tca6507TypeMaximumIntensityPwm get ();
    void set (Tca6507TypeMaximumIntensityPwm value);
}
member MaximumIntensityPWM1 : Tca6507TypeMaximumIntensityPwm with get, set

Property Value

Type: Tca6507TypeMaximumIntensityPwm
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.MaximumIntensityPWM1AI Property

IRD

Tca6507MaximumIntensityPWM1AI Property

Maximum Intensity (PWM1) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeMaximumIntensityPwm MaximumIntensityPWM1AI { get; set; }
Public Property MaximumIntensityPWM1AI As Tca6507TypeMaximumIntensityPwm
    Get
    Set
public:
property Tca6507TypeMaximumIntensityPwm MaximumIntensityPWM1AI {
    Tca6507TypeMaximumIntensityPwm get ();
    void set (Tca6507TypeMaximumIntensityPwm value);
}
member MaximumIntensityPWM1AI : Tca6507TypeMaximumIntensityPwm with get, set

Property Value

Type: Tca6507TypeMaximumIntensityPwm
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.OneShotPWM0 Property

IRD

Tca6507OneShotPWM0 Property

One-Shot (PWM0)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeOneShot OneShotPWM0 { get; set; }
Public Property OneShotPWM0 As Tca6507TypeOneShot
    Get
    Set
public:
property Tca6507TypeOneShot OneShotPWM0 {
    Tca6507TypeOneShot get ();
    void set (Tca6507TypeOneShot value);
}
member OneShotPWM0 : Tca6507TypeOneShot with get, set

Property Value

Type: Tca6507TypeOneShot
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.OneShotPWM0AI Property

IRD

Tca6507OneShotPWM0AI Property

One-Shot (PWM0) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeOneShot OneShotPWM0AI { get; set; }
Public Property OneShotPWM0AI As Tca6507TypeOneShot
    Get
    Set
public:
property Tca6507TypeOneShot OneShotPWM0AI {
    Tca6507TypeOneShot get ();
    void set (Tca6507TypeOneShot value);
}
member OneShotPWM0AI : Tca6507TypeOneShot with get, set

Property Value

Type: Tca6507TypeOneShot
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.OneShotPWM1 Property

IRD

Tca6507OneShotPWM1 Property

One-Shot (PWM1)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeOneShot OneShotPWM1 { get; set; }
Public Property OneShotPWM1 As Tca6507TypeOneShot
    Get
    Set
public:
property Tca6507TypeOneShot OneShotPWM1 {
    Tca6507TypeOneShot get ();
    void set (Tca6507TypeOneShot value);
}
member OneShotPWM1 : Tca6507TypeOneShot with get, set

Property Value

Type: Tca6507TypeOneShot
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.OneShotPWM1AI Property

IRD

Tca6507OneShotPWM1AI Property

One-Shot (PWM1) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeOneShot OneShotPWM1AI { get; set; }
Public Property OneShotPWM1AI As Tca6507TypeOneShot
    Get
    Set
public:
property Tca6507TypeOneShot OneShotPWM1AI {
    Tca6507TypeOneShot get ();
    void set (Tca6507TypeOneShot value);
}
member OneShotPWM1AI : Tca6507TypeOneShot with get, set

Property Value

Type: Tca6507TypeOneShot
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.SecondFullyOffTimeBANK0 Property

IRD

Tca6507SecondFullyOffTimeBANK0 Property

Second Fully-Off Time (BANK0) (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming SecondFullyOffTimeBANK0 { get; set; }
Public Property SecondFullyOffTimeBANK0 As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming SecondFullyOffTimeBANK0 {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member SecondFullyOffTimeBANK0 : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.SecondFullyOffTimeBANK0AI Property

IRD

Tca6507SecondFullyOffTimeBANK0AI Property

Second Fully-Off Time (BANK0) [AI] (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming SecondFullyOffTimeBANK0AI { get; set; }
Public Property SecondFullyOffTimeBANK0AI As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming SecondFullyOffTimeBANK0AI {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member SecondFullyOffTimeBANK0AI : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.SecondFullyOffTimeBANK1 Property

IRD

Tca6507SecondFullyOffTimeBANK1 Property

Second Fully-Off Time (BANK1) (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming SecondFullyOffTimeBANK1 { get; set; }
Public Property SecondFullyOffTimeBANK1 As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming SecondFullyOffTimeBANK1 {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member SecondFullyOffTimeBANK1 : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.SecondFullyOffTimeBANK1AI Property

IRD

Tca6507SecondFullyOffTimeBANK1AI Property

Second Fully-Off Time (BANK1) [AI] (unit: ms)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeTiming SecondFullyOffTimeBANK1AI { get; set; }
Public Property SecondFullyOffTimeBANK1AI As Tca6507TypeTiming
    Get
    Set
public:
property Tca6507TypeTiming SecondFullyOffTimeBANK1AI {
    Tca6507TypeTiming get ();
    void set (Tca6507TypeTiming value);
}
member SecondFullyOffTimeBANK1AI : Tca6507TypeTiming with get, set

Property Value

Type: Tca6507TypeTiming
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.SelectP0 Property

IRD

Tca6507SelectP0 Property

Select (P0)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeSelect SelectP0 { get; set; }
Public Property SelectP0 As Tca6507TypeSelect
    Get
    Set
public:
property Tca6507TypeSelect SelectP0 {
    Tca6507TypeSelect get ();
    void set (Tca6507TypeSelect value);
}
member SelectP0 : Tca6507TypeSelect with get, set

Property Value

Type: Tca6507TypeSelect
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.SelectP0AI Property

IRD

Tca6507SelectP0AI Property

Select (P0) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeSelect SelectP0AI { get; set; }
Public Property SelectP0AI As Tca6507TypeSelect
    Get
    Set
public:
property Tca6507TypeSelect SelectP0AI {
    Tca6507TypeSelect get ();
    void set (Tca6507TypeSelect value);
}
member SelectP0AI : Tca6507TypeSelect with get, set

Property Value

Type: Tca6507TypeSelect
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.SelectP1 Property

IRD

Tca6507SelectP1 Property

Select (P1)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeSelect SelectP1 { get; set; }
Public Property SelectP1 As Tca6507TypeSelect
    Get
    Set
public:
property Tca6507TypeSelect SelectP1 {
    Tca6507TypeSelect get ();
    void set (Tca6507TypeSelect value);
}
member SelectP1 : Tca6507TypeSelect with get, set

Property Value

Type: Tca6507TypeSelect
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.SelectP1AI Property

IRD

Tca6507SelectP1AI Property

Select (P1) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeSelect SelectP1AI { get; set; }
Public Property SelectP1AI As Tca6507TypeSelect
    Get
    Set
public:
property Tca6507TypeSelect SelectP1AI {
    Tca6507TypeSelect get ();
    void set (Tca6507TypeSelect value);
}
member SelectP1AI : Tca6507TypeSelect with get, set

Property Value

Type: Tca6507TypeSelect
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.SelectP2 Property

IRD

Tca6507SelectP2 Property

Select (P2)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeSelect SelectP2 { get; set; }
Public Property SelectP2 As Tca6507TypeSelect
    Get
    Set
public:
property Tca6507TypeSelect SelectP2 {
    Tca6507TypeSelect get ();
    void set (Tca6507TypeSelect value);
}
member SelectP2 : Tca6507TypeSelect with get, set

Property Value

Type: Tca6507TypeSelect
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.SelectP2AI Property

IRD

Tca6507SelectP2AI Property

Select (P2) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeSelect SelectP2AI { get; set; }
Public Property SelectP2AI As Tca6507TypeSelect
    Get
    Set
public:
property Tca6507TypeSelect SelectP2AI {
    Tca6507TypeSelect get ();
    void set (Tca6507TypeSelect value);
}
member SelectP2AI : Tca6507TypeSelect with get, set

Property Value

Type: Tca6507TypeSelect
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.SelectP3 Property

IRD

Tca6507SelectP3 Property

Select (P3)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeSelect SelectP3 { get; set; }
Public Property SelectP3 As Tca6507TypeSelect
    Get
    Set
public:
property Tca6507TypeSelect SelectP3 {
    Tca6507TypeSelect get ();
    void set (Tca6507TypeSelect value);
}
member SelectP3 : Tca6507TypeSelect with get, set

Property Value

Type: Tca6507TypeSelect
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.SelectP3AI Property

IRD

Tca6507SelectP3AI Property

Select (P3) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeSelect SelectP3AI { get; set; }
Public Property SelectP3AI As Tca6507TypeSelect
    Get
    Set
public:
property Tca6507TypeSelect SelectP3AI {
    Tca6507TypeSelect get ();
    void set (Tca6507TypeSelect value);
}
member SelectP3AI : Tca6507TypeSelect with get, set

Property Value

Type: Tca6507TypeSelect
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.SelectP4 Property

IRD

Tca6507SelectP4 Property

Select (P4)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeSelect SelectP4 { get; set; }
Public Property SelectP4 As Tca6507TypeSelect
    Get
    Set
public:
property Tca6507TypeSelect SelectP4 {
    Tca6507TypeSelect get ();
    void set (Tca6507TypeSelect value);
}
member SelectP4 : Tca6507TypeSelect with get, set

Property Value

Type: Tca6507TypeSelect
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.SelectP4AI Property

IRD

Tca6507SelectP4AI Property

Select (P4) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeSelect SelectP4AI { get; set; }
Public Property SelectP4AI As Tca6507TypeSelect
    Get
    Set
public:
property Tca6507TypeSelect SelectP4AI {
    Tca6507TypeSelect get ();
    void set (Tca6507TypeSelect value);
}
member SelectP4AI : Tca6507TypeSelect with get, set

Property Value

Type: Tca6507TypeSelect
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.SelectP5 Property

IRD

Tca6507SelectP5 Property

Select (P5)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeSelect SelectP5 { get; set; }
Public Property SelectP5 As Tca6507TypeSelect
    Get
    Set
public:
property Tca6507TypeSelect SelectP5 {
    Tca6507TypeSelect get ();
    void set (Tca6507TypeSelect value);
}
member SelectP5 : Tca6507TypeSelect with get, set

Property Value

Type: Tca6507TypeSelect
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.SelectP5AI Property

IRD

Tca6507SelectP5AI Property

Select (P5) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeSelect SelectP5AI { get; set; }
Public Property SelectP5AI As Tca6507TypeSelect
    Get
    Set
public:
property Tca6507TypeSelect SelectP5AI {
    Tca6507TypeSelect get ();
    void set (Tca6507TypeSelect value);
}
member SelectP5AI : Tca6507TypeSelect with get, set

Property Value

Type: Tca6507TypeSelect
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.SelectP6 Property

IRD

Tca6507SelectP6 Property

Select (P6)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeSelect SelectP6 { get; set; }
Public Property SelectP6 As Tca6507TypeSelect
    Get
    Set
public:
property Tca6507TypeSelect SelectP6 {
    Tca6507TypeSelect get ();
    void set (Tca6507TypeSelect value);
}
member SelectP6 : Tca6507TypeSelect with get, set

Property Value

Type: Tca6507TypeSelect
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.SelectP6AI Property

IRD

Tca6507SelectP6AI Property

Select (P6) [AI]

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tca6507TypeSelect SelectP6AI { get; set; }
Public Property SelectP6AI As Tca6507TypeSelect
    Get
    Set
public:
property Tca6507TypeSelect SelectP6AI {
    Tca6507TypeSelect get ();
    void set (Tca6507TypeSelect value);
}
member SelectP6AI : Tca6507TypeSelect with get, set

Property Value

Type: Tca6507TypeSelect
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507 Methods

The Tca6507 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.Flush Method

IRD

Tca6507Flush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Tca6507 Class
telos.Ird.TexasInstruments Namespace


Tca6507.TypeInitialization Enumeration

IRD

Tca6507TypeInitialization Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInitialization
Public Enumeration TypeInitialization
public enum class TypeInitialization
type TypeInitialization
Members
Member name | Value | Description
BeginningAtRegionA1 | 0 | Beginning at region A1
BeginningAtRegionB1 | 1 | Beginning at region B1
BeginningAtRegionC1 | 2 | Beginning at region C1
BeginningAtRegionD | 3 | Beginning at region D
BeginningAtRegionA2 | 4 | Beginning at region A2
BeginningAtRegionB2 | 5 | Beginning at region B2
BeginningAtRegionC2 | 6 | Beginning at region C2
BeginningAtRegionE | 7 | Beginning at region E
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6507.TypeInitializationPwm Enumeration

IRD

Tca6507TypeInitializationPwm Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeInitializationPwm
Public Enumeration TypeInitializationPwm
public enum class TypeInitializationPwm
type TypeInitializationPwm
Members
Member name | Value | Description
Unmodified | 0 | Unmodified
Initialize | 1 | Initialize
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6507.TypeMaximumIntensityPwm Enumeration

IRD

Tca6507TypeMaximumIntensityPwm Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeMaximumIntensityPwm
Public Enumeration TypeMaximumIntensityPwm
public enum class TypeMaximumIntensityPwm
type TypeMaximumIntensityPwm
Members
Member name | Value | Description
FValue | 0 | F value
ALDValue | 1 | ALD value
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6507.TypeOneShot Enumeration

IRD

Tca6507TypeOneShot Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeOneShot
Public Enumeration TypeOneShot
public enum class TypeOneShot
type TypeOneShot
Members
Member name | Value | Description
NormalMode | 0 | Normal mode
OneShotMode | 1 | One-shot mode
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6507.TypeSelect Enumeration

IRD

Tca6507TypeSelect Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeSelect
Public Enumeration TypeSelect
public enum class TypeSelect
type TypeSelect
Members
Member name | Value | Description
LEDOffHighImpedance | 0 | LED off (high impedance)
LEDOffHighImpedance__1 | 1 | LED off (high impedance)
LEDOnSteadilyWithMaximumIntensityValueOfPWM0ALDValueOrBRIGHTF0Value | 2 | LED on steadily with maximum intensity value of PWM0 (ALD value or BRIGHT_F0 value)
LEDOnSteadilyWithMaximumIntensityValueOfPWM1ALDValueOrBRIGHTF1Value | 3 | LED on steadily with maximum intensity value of PWM1 (ALD value or BRIGHT_F1 value)
LEDFullyOnOutputLow | 4 | LED fully on (output low)
LEDOnAtBrightnessSetByOneShotMasterIntensityRegister | 5 | LED on at brightness set by One Shot / Master Intensity register
LEDBlinkingWithIntensityCharacteristicsOfBANK0PWM0 | 6 | LED blinking with intensity characteristics of BANK0 (PWM0)
LEDBlinkingWithIntensityCharacteristicsOfBANK1PWM1 | 7 | LED blinking with intensity characteristics of BANK1 (PWM1)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tca6507.TypeTiming Enumeration

IRD

Tca6507TypeTiming Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeTiming
Public Enumeration TypeTiming
public enum class TypeTiming
type TypeTiming
Members
Member name | Value | Description
Value_0 | 0 | 0
Value_64 | 1 | 64
Value_128 | 2 | 128
Value_192 | 3 | 192
Value_256 | 4 | 256
Value_384 | 5 | 384
Value_512 | 6 | 512
Value_768 | 7 | 768
Value_1024 | 8 | 1024
Value_1536 | 9 | 1536
Value_2048 | 10 | 2048
Value_3072 | 11 | 3072
Value_4096 | 12 | 4096
Value_5760 | 13 | 5760
Value_8128 | 14 | 8128
Value_16320 | 15 | 16320
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k Class

Texas Instruments: TLV 320AIC12
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsTlv320aic12k

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Tlv320aic12k
Public Class Tlv320aic12k
public ref class Tlv320aic12k
type Tlv320aic12k =  class end

The Tlv320aic12k type exposes the following members.

Constructors
 | Name | Description
Public method | Tlv320aic12k | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Control1ADOVF | Control1: ADOVF
Public property | Control1ALB | Control1: ALB
Public property | Control1BIASV | Control1: BIASV
Public property | Control1CX | Control1: CX
Public property | Control1DAC16 | Control1: DAC16
Public property | Control1DAOVF | Control1: DAOVF
Public property | Control1DLB | Control1: DLB
Public property | Control1IIR | Control1: IIR
Public property | Control2DIFBP | Control2: DIFBP
Public property | Control2GPO | Control2: GPO
Public property | Control2HPC | Control2: HPC
Public property | Control2I2Cx | Control2: I2Cx
Public property | Control2TURBO | Control2: TURBO
Public property | Control3ASRF | Control3: ASRF
Public property | Control3OSROption | Control3: OSR Option
Public property | Control3PWDN | Control3: PWDN
Public property | Control3SWRS | Control3: SWRS
Public property | Control4FSDIV | Control4: FSDIV
Public property | Control4MNP | Control4: MNP
Public property | Control5GAIN | Control5: GAIN (unit: dB)
Public property | Control6AINSEL | Control6: AINSEL
Public property | Control6MUTE2 | Control6: MUTE2
Public property | Control6MUTE3 | Control6: MUTE3
Public property | Control6ODRCT | Control6: ODRCT
Public property | Control6PSDO | Control6: PSDO
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Low-Power Highly-Integrated Programmable16-Bit Mono Codec
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12k(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Tlv320aic12k(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Tlv320aic12k

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k Properties

The Tlv320aic12k type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Control1ADOVF | Control1: ADOVF
Public property | Control1ALB | Control1: ALB
Public property | Control1BIASV | Control1: BIASV
Public property | Control1CX | Control1: CX
Public property | Control1DAC16 | Control1: DAC16
Public property | Control1DAOVF | Control1: DAOVF
Public property | Control1DLB | Control1: DLB
Public property | Control1IIR | Control1: IIR
Public property | Control2DIFBP | Control2: DIFBP
Public property | Control2GPO | Control2: GPO
Public property | Control2HPC | Control2: HPC
Public property | Control2I2Cx | Control2: I2Cx
Public property | Control2TURBO | Control2: TURBO
Public property | Control3ASRF | Control3: ASRF
Public property | Control3OSROption | Control3: OSR Option
Public property | Control3PWDN | Control3: PWDN
Public property | Control3SWRS | Control3: SWRS
Public property | Control4FSDIV | Control4: FSDIV
Public property | Control4MNP | Control4: MNP
Public property | Control5GAIN | Control5: GAIN (unit: dB)
Public property | Control6AINSEL | Control6: AINSEL
Public property | Control6MUTE2 | Control6: MUTE2
Public property | Control6MUTE3 | Control6: MUTE3
Public property | Control6ODRCT | Control6: ODRCT
Public property | Control6PSDO | Control6: PSDO
Top
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.AutoFlush Property

IRD

Tlv320aic12kAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control1ADOVF Property

IRD

Tlv320aic12kControl1ADOVF Property

Control1: ADOVF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl1Adc Control1ADOVF { get; set; }
Public Property Control1ADOVF As Tlv320aic12kTypeControl1Adc
    Get
    Set
public:
property Tlv320aic12kTypeControl1Adc Control1ADOVF {
    Tlv320aic12kTypeControl1Adc get ();
    void set (Tlv320aic12kTypeControl1Adc value);
}
member Control1ADOVF : Tlv320aic12kTypeControl1Adc with get, set

Property Value

Type: Tlv320aic12kTypeControl1Adc
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control1ALB Property

IRD

Tlv320aic12kControl1ALB Property

Control1: ALB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl1Analog Control1ALB { get; set; }
Public Property Control1ALB As Tlv320aic12kTypeControl1Analog
    Get
    Set
public:
property Tlv320aic12kTypeControl1Analog Control1ALB {
    Tlv320aic12kTypeControl1Analog get ();
    void set (Tlv320aic12kTypeControl1Analog value);
}
member Control1ALB : Tlv320aic12kTypeControl1Analog with get, set

Property Value

Type: Tlv320aic12kTypeControl1Analog
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control1BIASV Property

IRD

Tlv320aic12kControl1BIASV Property

Control1: BIASV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl1Bias Control1BIASV { get; set; }
Public Property Control1BIASV As Tlv320aic12kTypeControl1Bias
    Get
    Set
public:
property Tlv320aic12kTypeControl1Bias Control1BIASV {
    Tlv320aic12kTypeControl1Bias get ();
    void set (Tlv320aic12kTypeControl1Bias value);
}
member Control1BIASV : Tlv320aic12kTypeControl1Bias with get, set

Property Value

Type: Tlv320aic12kTypeControl1Bias
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control1CX Property

IRD

Tlv320aic12kControl1CX Property

Control1: CX

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl1Continue Control1CX { get; set; }
Public Property Control1CX As Tlv320aic12kTypeControl1Continue
    Get
    Set
public:
property Tlv320aic12kTypeControl1Continue Control1CX {
    Tlv320aic12kTypeControl1Continue get ();
    void set (Tlv320aic12kTypeControl1Continue value);
}
member Control1CX : Tlv320aic12kTypeControl1Continue with get, set

Property Value

Type: Tlv320aic12kTypeControl1Continue
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control1DAC16 Property

IRD

Tlv320aic12kControl1DAC16 Property

Control1: DAC16

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl1Dac16 Control1DAC16 { get; set; }
Public Property Control1DAC16 As Tlv320aic12kTypeControl1Dac16
    Get
    Set
public:
property Tlv320aic12kTypeControl1Dac16 Control1DAC16 {
    Tlv320aic12kTypeControl1Dac16 get ();
    void set (Tlv320aic12kTypeControl1Dac16 value);
}
member Control1DAC16 : Tlv320aic12kTypeControl1Dac16 with get, set

Property Value

Type: Tlv320aic12kTypeControl1Dac16
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control1DAOVF Property

IRD

Tlv320aic12kControl1DAOVF Property

Control1: DAOVF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl1Dac Control1DAOVF { get; set; }
Public Property Control1DAOVF As Tlv320aic12kTypeControl1Dac
    Get
    Set
public:
property Tlv320aic12kTypeControl1Dac Control1DAOVF {
    Tlv320aic12kTypeControl1Dac get ();
    void set (Tlv320aic12kTypeControl1Dac value);
}
member Control1DAOVF : Tlv320aic12kTypeControl1Dac with get, set

Property Value

Type: Tlv320aic12kTypeControl1Dac
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control1DLB Property

IRD

Tlv320aic12kControl1DLB Property

Control1: DLB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl1Digital Control1DLB { get; set; }
Public Property Control1DLB As Tlv320aic12kTypeControl1Digital
    Get
    Set
public:
property Tlv320aic12kTypeControl1Digital Control1DLB {
    Tlv320aic12kTypeControl1Digital get ();
    void set (Tlv320aic12kTypeControl1Digital value);
}
member Control1DLB : Tlv320aic12kTypeControl1Digital with get, set

Property Value

Type: Tlv320aic12kTypeControl1Digital
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control1IIR Property

IRD

Tlv320aic12kControl1IIR Property

Control1: IIR

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl1Filter Control1IIR { get; set; }
Public Property Control1IIR As Tlv320aic12kTypeControl1Filter
    Get
    Set
public:
property Tlv320aic12kTypeControl1Filter Control1IIR {
    Tlv320aic12kTypeControl1Filter get ();
    void set (Tlv320aic12kTypeControl1Filter value);
}
member Control1IIR : Tlv320aic12kTypeControl1Filter with get, set

Property Value

Type: Tlv320aic12kTypeControl1Filter
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control2DIFBP Property

IRD

Tlv320aic12kControl2DIFBP Property

Control2: DIFBP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl2Decimate Control2DIFBP { get; set; }
Public Property Control2DIFBP As Tlv320aic12kTypeControl2Decimate
    Get
    Set
public:
property Tlv320aic12kTypeControl2Decimate Control2DIFBP {
    Tlv320aic12kTypeControl2Decimate get ();
    void set (Tlv320aic12kTypeControl2Decimate value);
}
member Control2DIFBP : Tlv320aic12kTypeControl2Decimate with get, set

Property Value

Type: Tlv320aic12kTypeControl2Decimate
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control2GPO Property

IRD

Tlv320aic12kControl2GPO Property

Control2: GPO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl2General Control2GPO { get; set; }
Public Property Control2GPO As Tlv320aic12kTypeControl2General
    Get
    Set
public:
property Tlv320aic12kTypeControl2General Control2GPO {
    Tlv320aic12kTypeControl2General get ();
    void set (Tlv320aic12kTypeControl2General value);
}
member Control2GPO : Tlv320aic12kTypeControl2General with get, set

Property Value

Type: Tlv320aic12kTypeControl2General
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control2HPC Property

IRD

Tlv320aic12kControl2HPC Property

Control2: HPC

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl2Host Control2HPC { get; set; }
Public Property Control2HPC As Tlv320aic12kTypeControl2Host
    Get
    Set
public:
property Tlv320aic12kTypeControl2Host Control2HPC {
    Tlv320aic12kTypeControl2Host get ();
    void set (Tlv320aic12kTypeControl2Host value);
}
member Control2HPC : Tlv320aic12kTypeControl2Host with get, set

Property Value

Type: Tlv320aic12kTypeControl2Host
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control2I2Cx Property

IRD

Tlv320aic12kControl2I2Cx Property

Control2: I2Cx

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Control2I2Cx { get; set; }
Public Property Control2I2Cx As Byte
    Get
    Set
public:
property unsigned char Control2I2Cx {
    unsigned char get ();
    void set (unsigned char value);
}
member Control2I2Cx : byte with get, set

Property Value

Type: Byte
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control2TURBO Property

IRD

Tlv320aic12kControl2TURBO Property

Control2: TURBO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl2Turbo Control2TURBO { get; set; }
Public Property Control2TURBO As Tlv320aic12kTypeControl2Turbo
    Get
    Set
public:
property Tlv320aic12kTypeControl2Turbo Control2TURBO {
    Tlv320aic12kTypeControl2Turbo get ();
    void set (Tlv320aic12kTypeControl2Turbo value);
}
member Control2TURBO : Tlv320aic12kTypeControl2Turbo with get, set

Property Value

Type: Tlv320aic12kTypeControl2Turbo
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control3ASRF Property

IRD

Tlv320aic12kControl3ASRF Property

Control3: ASRF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl3Async Control3ASRF { get; set; }
Public Property Control3ASRF As Tlv320aic12kTypeControl3Async
    Get
    Set
public:
property Tlv320aic12kTypeControl3Async Control3ASRF {
    Tlv320aic12kTypeControl3Async get ();
    void set (Tlv320aic12kTypeControl3Async value);
}
member Control3ASRF : Tlv320aic12kTypeControl3Async with get, set

Property Value

Type: Tlv320aic12kTypeControl3Async
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control3OSROption Property

IRD

Tlv320aic12kControl3OSROption Property

Control3: OSR Option

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl3Osr Control3OSROption { get; set; }
Public Property Control3OSROption As Tlv320aic12kTypeControl3Osr
    Get
    Set
public:
property Tlv320aic12kTypeControl3Osr Control3OSROption {
    Tlv320aic12kTypeControl3Osr get ();
    void set (Tlv320aic12kTypeControl3Osr value);
}
member Control3OSROption : Tlv320aic12kTypeControl3Osr with get, set

Property Value

Type: Tlv320aic12kTypeControl3Osr
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control3PWDN Property

IRD

Tlv320aic12kControl3PWDN Property

Control3: PWDN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl3Power Control3PWDN { get; set; }
Public Property Control3PWDN As Tlv320aic12kTypeControl3Power
    Get
    Set
public:
property Tlv320aic12kTypeControl3Power Control3PWDN {
    Tlv320aic12kTypeControl3Power get ();
    void set (Tlv320aic12kTypeControl3Power value);
}
member Control3PWDN : Tlv320aic12kTypeControl3Power with get, set

Property Value

Type: Tlv320aic12kTypeControl3Power
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control3SWRS Property

IRD

Tlv320aic12kControl3SWRS Property

Control3: SWRS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl3Reset Control3SWRS { get; set; }
Public Property Control3SWRS As Tlv320aic12kTypeControl3Reset
    Get
    Set
public:
property Tlv320aic12kTypeControl3Reset Control3SWRS {
    Tlv320aic12kTypeControl3Reset get ();
    void set (Tlv320aic12kTypeControl3Reset value);
}
member Control3SWRS : Tlv320aic12kTypeControl3Reset with get, set

Property Value

Type: Tlv320aic12kTypeControl3Reset
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control4FSDIV Property

IRD

Tlv320aic12kControl4FSDIV Property

Control4: FSDIV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl4Sync Control4FSDIV { get; set; }
Public Property Control4FSDIV As Tlv320aic12kTypeControl4Sync
    Get
    Set
public:
property Tlv320aic12kTypeControl4Sync Control4FSDIV {
    Tlv320aic12kTypeControl4Sync get ();
    void set (Tlv320aic12kTypeControl4Sync value);
}
member Control4FSDIV : Tlv320aic12kTypeControl4Sync with get, set

Property Value

Type: Tlv320aic12kTypeControl4Sync
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control4MNP Property

IRD

Tlv320aic12kControl4MNP Property

Control4: MNP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Control4MNP { get; set; }
Public Property Control4MNP As Byte
    Get
    Set
public:
property unsigned char Control4MNP {
    unsigned char get ();
    void set (unsigned char value);
}
member Control4MNP : byte with get, set

Property Value

Type: Byte
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control5GAIN Property

IRD

Tlv320aic12kControl5GAIN Property

Control5: GAIN (unit: dB)

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl5Gain Control5GAIN { get; set; }
Public Property Control5GAIN As Tlv320aic12kTypeControl5Gain
    Get
    Set
public:
property Tlv320aic12kTypeControl5Gain Control5GAIN {
    Tlv320aic12kTypeControl5Gain get ();
    void set (Tlv320aic12kTypeControl5Gain value);
}
member Control5GAIN : Tlv320aic12kTypeControl5Gain with get, set

Property Value

Type: Tlv320aic12kTypeControl5Gain
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control6AINSEL Property

IRD

Tlv320aic12kControl6AINSEL Property

Control6: AINSEL

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl6Input Control6AINSEL { get; set; }
Public Property Control6AINSEL As Tlv320aic12kTypeControl6Input
    Get
    Set
public:
property Tlv320aic12kTypeControl6Input Control6AINSEL {
    Tlv320aic12kTypeControl6Input get ();
    void set (Tlv320aic12kTypeControl6Input value);
}
member Control6AINSEL : Tlv320aic12kTypeControl6Input with get, set

Property Value

Type: Tlv320aic12kTypeControl6Input
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control6MUTE2 Property

IRD

Tlv320aic12kControl6MUTE2 Property

Control6: MUTE2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl6Mute2 Control6MUTE2 { get; set; }
Public Property Control6MUTE2 As Tlv320aic12kTypeControl6Mute2
    Get
    Set
public:
property Tlv320aic12kTypeControl6Mute2 Control6MUTE2 {
    Tlv320aic12kTypeControl6Mute2 get ();
    void set (Tlv320aic12kTypeControl6Mute2 value);
}
member Control6MUTE2 : Tlv320aic12kTypeControl6Mute2 with get, set

Property Value

Type: Tlv320aic12kTypeControl6Mute2
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control6MUTE3 Property

IRD

Tlv320aic12kControl6MUTE3 Property

Control6: MUTE3

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl6Mute3 Control6MUTE3 { get; set; }
Public Property Control6MUTE3 As Tlv320aic12kTypeControl6Mute3
    Get
    Set
public:
property Tlv320aic12kTypeControl6Mute3 Control6MUTE3 {
    Tlv320aic12kTypeControl6Mute3 get ();
    void set (Tlv320aic12kTypeControl6Mute3 value);
}
member Control6MUTE3 : Tlv320aic12kTypeControl6Mute3 with get, set

Property Value

Type: Tlv320aic12kTypeControl6Mute3
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control6ODRCT Property

IRD

Tlv320aic12kControl6ODRCT Property

Control6: ODRCT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl6Driver Control6ODRCT { get; set; }
Public Property Control6ODRCT As Tlv320aic12kTypeControl6Driver
    Get
    Set
public:
property Tlv320aic12kTypeControl6Driver Control6ODRCT {
    Tlv320aic12kTypeControl6Driver get ();
    void set (Tlv320aic12kTypeControl6Driver value);
}
member Control6ODRCT : Tlv320aic12kTypeControl6Driver with get, set

Property Value

Type: Tlv320aic12kTypeControl6Driver
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Control6PSDO Property

IRD

Tlv320aic12kControl6PSDO Property

Control6: PSDO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic12kTypeControl6Prog Control6PSDO { get; set; }
Public Property Control6PSDO As Tlv320aic12kTypeControl6Prog
    Get
    Set
public:
property Tlv320aic12kTypeControl6Prog Control6PSDO {
    Tlv320aic12kTypeControl6Prog get ();
    void set (Tlv320aic12kTypeControl6Prog value);
}
member Control6PSDO : Tlv320aic12kTypeControl6Prog with get, set

Property Value

Type: Tlv320aic12kTypeControl6Prog
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k Methods

The Tlv320aic12k type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.Flush Method

IRD

Tlv320aic12kFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Tlv320aic12k Class
telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl1Adc Enumeration

IRD

Tlv320aic12kTypeControl1Adc Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Adc
Public Enumeration TypeControl1Adc
public enum class TypeControl1Adc
type TypeControl1Adc
Members
Member name | Value | Description
ADCNoOverflow | 0 | ADC: No Overflow
ADCOverflow | 1 | ADC: Overflow
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl1Analog Enumeration

IRD

Tlv320aic12kTypeControl1Analog Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Analog
Public Enumeration TypeControl1Analog
public enum class TypeControl1Analog
type TypeControl1Analog
Members
Member name | Value | Description
AnalogLoopBackDisabled | 0 | Analog Loop-Back: Disabled
AnalogLoopBackEnabled | 1 | Analog Loop-Back: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl1Bias Enumeration

IRD

Tlv320aic12kTypeControl1Bias Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Bias
Public Enumeration TypeControl1Bias
public enum class TypeControl1Bias
type TypeControl1Bias
Members
Member name | Value | Description
BiasVoltage235V | 0 | Bias Voltage: 2.35 V
BiasVoltage135V | 1 | Bias Voltage: 1.35 V
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl1Continue Enumeration

IRD

Tlv320aic12kTypeControl1Continue Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Continue
Public Enumeration TypeControl1Continue
public enum class TypeControl1Continue
type TypeControl1Continue
Members
Member name | Value | Description
ProgrammingMode | 0 | Programming Mode
ContinuousDataTransferMode | 1 | Continuous Data Transfer Mode
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl1Dac Enumeration

IRD

Tlv320aic12kTypeControl1Dac Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Dac
Public Enumeration TypeControl1Dac
public enum class TypeControl1Dac
type TypeControl1Dac
Members
Member name | Value | Description
DACNoOverflow | 0 | DAC: No Overflow
DACOverflow | 1 | DAC: Overflow
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl1Dac16 Enumeration

IRD

Tlv320aic12kTypeControl1Dac16 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Dac16
Public Enumeration TypeControl1Dac16
public enum class TypeControl1Dac16
type TypeControl1Dac16
Members
Member name | Value | Description
DACInputLength15Bit | 0 | DAC Input-Length: 15 Bit
DACInputLength16Bit | 1 | DAC Input-Length: 16 Bit
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl1Digital Enumeration

IRD

Tlv320aic12kTypeControl1Digital Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Digital
Public Enumeration TypeControl1Digital
public enum class TypeControl1Digital
type TypeControl1Digital
Members
Member name | Value | Description
DigitalLoopBackDisabled | 0 | Digital Loop-Back: Disabled
DigitalLoopBackEnabled | 1 | Digital Loop-Back: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl1Filter Enumeration

IRD

Tlv320aic12kTypeControl1Filter Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl1Filter
Public Enumeration TypeControl1Filter
public enum class TypeControl1Filter
type TypeControl1Filter
Members
Member name | Value | Description
FIRFilterIsSelected | 0 | FIR Filter Is Selected
IIRFilterIsSelected | 1 | IIR Filter Is Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl2Decimate Enumeration

IRD

Tlv320aic12kTypeControl2Decimate Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Decimate
Public Enumeration TypeControl2Decimate
public enum class TypeControl2Decimate
type TypeControl2Decimate
Members
Member name | Value | Description
DecimationInterpolationFiltersOperated | 0 | Decimation / Interpolation Filters: Operated
DecimationInterpolationFiltersBypassed | 1 | Decimation / Interpolation Filters: Bypassed
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl2General Enumeration

IRD

Tlv320aic12kTypeControl2General Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2General
Public Enumeration TypeControl2General
public enum class TypeControl2General
type TypeControl2General
Members
Member name | Value | Description
GeneralPurposeOutputDisabled | 0 | General Purpose Output: Disabled
GeneralPurposeOutputEnabled | 1 | General Purpose Output: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl2Host Enumeration

IRD

Tlv320aic12kTypeControl2Host Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Host
Public Enumeration TypeControl2Host
public enum class TypeControl2Host
type TypeControl2Host
Members
Member name | Value | Description
HostPortControlSDASCLUsedForI2CInterface | 0 | Host-Port Control: SDA/SCL Used For I2C-Interface
HostPortControlSDASCLUsedForI2SInterface | 1 | Host-Port Control: SDA/SCL Used For I2S-Interface
HostPortControlSDAPinD2SCLPinInputOutputDOUT | 2 | Host-Port Control: SDA-Pin = D2 / SCL-Pin = Input / Output = DOUT
HostPortControlSDAPinControlFrameFlag | 3 | Host-Port Control: SDA-Pin = Control Frame Flag
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl2Turbo Enumeration

IRD

Tlv320aic12kTypeControl2Turbo Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Turbo
Public Enumeration TypeControl2Turbo
public enum class TypeControl2Turbo
type TypeControl2Turbo
Members
Member name | Value | Description
TurboModeSCLK16XFSXDeviceXMode | 0 | Turbo Mode: SCLK = (16 x FS x #Device x Mode)
TurboModeSCLKMCLKP | 1 | Turbo Mode: SCLK = MCLK/P
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl3Async Enumeration

IRD

Tlv320aic12kTypeControl3Async Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl3Async
Public Enumeration TypeControl3Async
public enum class TypeControl3Async
type TypeControl3Async
Members
Member name | Value | Description
AsynchronousSamplingRateFactorFSFs8 | 0 | Asynchronous Sampling Rate Factor: FS/Fs = 8
AsynchronousSamplingRateFactorFSFs1 | 1 | Asynchronous Sampling Rate Factor: FS/Fs = 1
AsynchronousSamplingRateFactorFSFs2 | 2 | Asynchronous Sampling Rate Factor: FS/Fs = 2
AsynchronousSamplingRateFactorFSFs3 | 3 | Asynchronous Sampling Rate Factor: FS/Fs = 3
AsynchronousSamplingRateFactorFSFs4 | 4 | Asynchronous Sampling Rate Factor: FS/Fs = 4
AsynchronousSamplingRateFactorFSFs5 | 5 | Asynchronous Sampling Rate Factor: FS/Fs = 5
AsynchronousSamplingRateFactorFSFs6 | 6 | Asynchronous Sampling Rate Factor: FS/Fs = 6
AsynchronousSamplingRateFactorFSFs7 | 7 | Asynchronous Sampling Rate Factor: FS/Fs = 7
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl3Osr Enumeration

IRD

Tlv320aic12kTypeControl3Osr Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl3Osr
Public Enumeration TypeControl3Osr
public enum class TypeControl3Osr
type TypeControl3Osr
Members
Member name | Value | Description
OSRForDACChannel128MaxFs26Ksps | 0 | OSR For DAC Channel: 128 (Max Fs = 26 Ksps)
OSRForDACChannel512MaxFs8Ksps | 1 | OSR For DAC Channel: 512 (Max Fs = 8 Ksps)
OSRForDACChannel256MaxFs16Ksps | 2 | OSR For DAC Channel: 256 (Max Fs = 16 Ksps)
OSRForDACChannel512MaxFs8Ksps__1 | 3 | OSR For DAC Channel: 512 (Max Fs = 8 Ksps)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl3Power Enumeration

IRD

Tlv320aic12kTypeControl3Power Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl3Power
Public Enumeration TypeControl3Power
public enum class TypeControl3Power
type TypeControl3Power
Members
Member name | Value | Description
NoPowerDown | 0 | No Power Down
PowerDownAD | 1 | Power Down A/D
PowerDownDA | 2 | Power Down D/A
SoftwarePowerDownTheEntireDevice | 3 | Software Power Down The Entire Device
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl3Reset Enumeration

IRD

Tlv320aic12kTypeControl3Reset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl3Reset
Public Enumeration TypeControl3Reset
public enum class TypeControl3Reset
type TypeControl3Reset
Members
Member name | Value | Description
NoSoftwareReset | 0 | No Software Reset
SoftwareReset | 1 | Software Reset
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl4Sync Enumeration

IRD

Tlv320aic12kTypeControl4Sync Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl4Sync
Public Enumeration TypeControl4Sync
public enum class TypeControl4Sync
type TypeControl4Sync
Members
Member name | Value | Description
DividerValuePToD2D0ValueNToD6D3 | 0 | Divider: Value P To D2-D0 / Value N To D6-D3
DividerValueMToD6D0 | 1 | Divider: Value M To D6-D0
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl5Gain Enumeration

IRD

Tlv320aic12kTypeControl5Gain Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl5Gain
Public Enumeration TypeControl5Gain
public enum class TypeControl5Gain
type TypeControl5Gain
Members
Member name | Value | Description
Value_M_42 | 0 | -42
Value_M_41 | 1 | -41
Value_M_40 | 2 | -40
Value_M_39 | 3 | -39
Value_M_38 | 4 | -38
Value_M_37 | 5 | -37
Value_M_36 | 6 | -36
Value_M_35 | 7 | -35
Value_M_34 | 8 | -34
Value_M_33 | 9 | -33
Value_M_32 | 10 | -32
Value_M_31 | 11 | -31
Value_M_30 | 12 | -30
Value_M_29 | 13 | -29
Value_M_28 | 14 | -28
Value_M_27 | 15 | -27
Value_M_26 | 16 | -26
Value_M_25 | 17 | -25
Value_M_24 | 18 | -24
Value_M_23 | 19 | -23
Value_M_22 | 20 | -22
Value_M_21 | 21 | -21
Value_M_20 | 22 | -20
Value_M_19 | 23 | -19
Value_M_18 | 24 | -18
Value_M_17 | 25 | -17
Value_M_16 | 26 | -16
Value_M_15 | 27 | -15
Value_M_14 | 28 | -14
Value_M_13 | 29 | -13
Value_M_12 | 30 | -12
Value_M_11 | 31 | -11
Value_M_10 | 32 | -10
Value_M_9 | 33 | -9
Value_M_8 | 34 | -8
Value_M_7 | 35 | -7
Value_M_6 | 36 | -6
Value_M_5 | 37 | -5
Value_M_4 | 38 | -4
Value_M_3 | 39 | -3
Value_M_2 | 40 | -2
Value_M_1 | 41 | -1
Value_0 | 42 | 0
Value_1 | 43 | 1
Value_2 | 44 | 2
Value_3 | 45 | 3
Value_4 | 46 | 4
Value_5 | 47 | 5
Value_6 | 48 | 6
Value_7 | 49 | 7
Value_8 | 50 | 8
Value_9 | 51 | 9
Value_10 | 52 | 10
Value_11 | 53 | 11
Value_12 | 54 | 12
Value_13 | 55 | 13
Value_14 | 56 | 14
Value_15 | 57 | 15
Value_16 | 58 | 16
Value_17 | 59 | 17
Value_18 | 60 | 18
Value_19 | 61 | 19
Value_20 | 62 | 20
Mute | 63 | Mute
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl6Driver Enumeration

IRD

Tlv320aic12kTypeControl6Driver Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl6Driver
Public Enumeration TypeControl6Driver
public enum class TypeControl6Driver
type TypeControl6Driver
Members
Member name | Value | Description
OUTP3OFFOUTP2OFF | 0 | OUTP3 = OFF / OUTP2 = OFF
OUTP3OFFOUTP2ON | 1 | OUTP3 = OFF / OUTP2 = ON
OUTP3ONOUTP2OFF | 2 | OUTP3 = ON / OUTP2 = OFF
OUTP3ONOUTP2ON | 3 | OUTP3 = ON / OUTP2 = ON
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl6Input Enumeration

IRD

Tlv320aic12kTypeControl6Input Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl6Input
Public Enumeration TypeControl6Input
public enum class TypeControl6Input
type TypeControl6Input
Members
Member name | Value | Description
AnalogInputINPM1 | 0 | Analog Input: INP/M1
AnalogInputMICINSelfBiasedAt135V | 1 | Analog Input: MICIN (Self-Biased At 1.35 V)
AnalogInputMICINWithExternalCommonMode | 2 | Analog Input: MICIN (With External Common Mode)
AnalogInputINPM2 | 3 | Analog Input: INP/M2
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl6Mute2 Enumeration

IRD

Tlv320aic12kTypeControl6Mute2 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl6Mute2
Public Enumeration TypeControl6Mute2
public enum class TypeControl6Mute2
type TypeControl6Mute2
Members
Member name | Value | Description
AnalogOutput2NotMuted | 0 | Analog Output2: Not Muted
AnalogOutput2Muted | 1 | Analog Output2: Muted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl6Mute3 Enumeration

IRD

Tlv320aic12kTypeControl6Mute3 Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl6Mute3
Public Enumeration TypeControl6Mute3
public enum class TypeControl6Mute3
type TypeControl6Mute3
Members
Member name | Value | Description
AnalogOutput3NotMuted | 0 | Analog Output3: Not Muted
AnalogOutput3Muted | 1 | Analog Output3: Muted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic12k.TypeControl6Prog Enumeration

IRD

Tlv320aic12kTypeControl6Prog Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl6Prog
Public Enumeration TypeControl6Prog
public enum class TypeControl6Prog
type TypeControl6Prog
Members
Member name | Value | Description
OUTP2AndOUTP3AreDifferentialOutput | 0 | OUTP2 And OUTP3 Are Differential Output
OUTP2AndOUTP3AreSingleEndedOutput | 1 | OUTP2 And OUTP3 Are Single-Ended Output
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c Class

Texas Instruments: TLV 320AIC22C
Inheritance Hierarchy
SystemObject
telos.Ird.TexasInstrumentsTlv320aic22c

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public class Tlv320aic22c
Public Class Tlv320aic22c
public ref class Tlv320aic22c
type Tlv320aic22c =  class end

The Tlv320aic22c type exposes the following members.

Constructors
 | Name | Description
Public method | Tlv320aic22c | Constructor
Top
Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Control10CIIN | Control10: CIIN
Public property | Control10HDIN | Control10: HDIN
Public property | Control10HDOUT | Control10: HDOUT
Public property | Control10HSIN | Control10: HSIN
Public property | Control10HSOUT | Control10: HSOUT
Public property | Control10LNIN | Control10: LNIN
Public property | Control10MCIN | Control10: MCIN
Public property | Control10SPOUT | Control10: SPOUT
Public property | Control11HDIN | Control11: HDIN
Public property | Control11HSIN | Control11: HSIN
Public property | Control11MICIN | Control11: MICIN
Public property | Control11SPOUT | Control11: SPOUT
Public property | Control12FSYNC | Control12: FSYNC
Public property | Control12LCD | Control12: LCD
Public property | Control13DATAV | Control13: DATAV
Public property | Control13HANDOUT | Control13: HAND_OUT
Public property | Control13HECHO | Control13: HECHO
Public property | Control13ID | Control13: ID
Public property | Control14HEADOUT | Control14: HEAD_OUT
Public property | Control14LINE | Control14: LINE
Public property | Control14MASTER | Control14: MASTER
Public property | Control14POLE | Control14: POLE
Public property | Control15ADCZERO | Control15: ADC_ZERO
Public property | Control15DACZERO | Control15: DAC_ZERO
Public property | Control15HPF | Control15: HPF
Public property | Control15LAW | Control15: LAW
Public property | Control15THRESHOLD | Control15: THRESHOLD
Public property | Control15ZEROCROSS | Control15: ZERO_CROSS
Public property | Control16ADCZERO | Control16: ADC_ZERO
Public property | Control16DACZERO | Control16: DAC_ZERO
Public property | Control16HPF | Control16: HPF
Public property | Control16LAW | Control16: LAW
Public property | Control16THRESHOLD | Control16: THRESHOLD
Public property | Control16ZEROCROSS | Control16: ZERO_CROSS
Public property | Control17FRAMES | Control17: FRAMES
Public property | Control21PREAMP | Control21: PREAMP
Public property | Control21VERSION | Control21: VERSION
Public property | Control2ALB | Control2: ALB
Public property | Control2C1PD | Control2: C1PD
Public property | Control2DLB | Control2: DLB
Public property | Control2LREGC1 | Control2: LREGC1
Public property | Control2RESET | Control2: RESET
Public property | Control3ADCGAIN | Control3: ADCGAIN
Public property | Control3LINE | Control3: LINE
Public property | Control4DACGAIN | Control4: DACGAIN
Public property | Control5CIIN | Control5: CIIN
Public property | Control5HDIN | Control5: HDIN
Public property | Control5HDOUT | Control5: HDOUT
Public property | Control5HSIN | Control5: HSIN
Public property | Control5HSOUT | Control5: HSOUT
Public property | Control5LNIN | Control5: LNIN
Public property | Control5MCIN | Control5: MCIN
Public property | Control5SPOUT | Control5: SPOUT
Public property | Control7ALB | Control7: ALB
Public property | Control7C2PD | Control7: C2PD
Public property | Control7DLB | Control7: DLB
Public property | Control7LREGC2 | Control7: LREGC2
Public property | Control7RESET | Control7: RESET
Public property | Control8ADCGAIN | Control8: ADCGAIN
Public property | Control8LINE | Control8: LINE
Public property | Control9DACGAIN | Control9: DACGAIN
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Dual Voice Over Internet Protocol (VoiP) CODEC
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c Constructor

Constructor

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22c(
    Board board,
    I2cAddress i2c_addr,
    string ird_directory
)
Public Sub New (
    board As Board,
    i2c_addr As I2cAddress,
    ird_directory As String
)
public:
Tlv320aic22c(
    Board^ board,
    I2cAddress^ i2c_addr,
    String^ ird_directory
)
new :
        board : Board *
        i2c_addr : I2cAddress *
        ird_directory : string -> Tlv320aic22c

Parameters

board
Type: Board
I2C interface to be used for the communication
i2c_addr
Type: I2cAddress
I2C address of the slave
ird_directory
Type: SystemString
directory containing the IRD file for this IC
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c Properties

The Tlv320aic22c type exposes the following members.

Properties
 | Name | Description
Public property | AutoFlush | If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.
Public property | Control10CIIN | Control10: CIIN
Public property | Control10HDIN | Control10: HDIN
Public property | Control10HDOUT | Control10: HDOUT
Public property | Control10HSIN | Control10: HSIN
Public property | Control10HSOUT | Control10: HSOUT
Public property | Control10LNIN | Control10: LNIN
Public property | Control10MCIN | Control10: MCIN
Public property | Control10SPOUT | Control10: SPOUT
Public property | Control11HDIN | Control11: HDIN
Public property | Control11HSIN | Control11: HSIN
Public property | Control11MICIN | Control11: MICIN
Public property | Control11SPOUT | Control11: SPOUT
Public property | Control12FSYNC | Control12: FSYNC
Public property | Control12LCD | Control12: LCD
Public property | Control13DATAV | Control13: DATAV
Public property | Control13HANDOUT | Control13: HAND_OUT
Public property | Control13HECHO | Control13: HECHO
Public property | Control13ID | Control13: ID
Public property | Control14HEADOUT | Control14: HEAD_OUT
Public property | Control14LINE | Control14: LINE
Public property | Control14MASTER | Control14: MASTER
Public property | Control14POLE | Control14: POLE
Public property | Control15ADCZERO | Control15: ADC_ZERO
Public property | Control15DACZERO | Control15: DAC_ZERO
Public property | Control15HPF | Control15: HPF
Public property | Control15LAW | Control15: LAW
Public property | Control15THRESHOLD | Control15: THRESHOLD
Public property | Control15ZEROCROSS | Control15: ZERO_CROSS
Public property | Control16ADCZERO | Control16: ADC_ZERO
Public property | Control16DACZERO | Control16: DAC_ZERO
Public property | Control16HPF | Control16: HPF
Public property | Control16LAW | Control16: LAW
Public property | Control16THRESHOLD | Control16: THRESHOLD
Public property | Control16ZEROCROSS | Control16: ZERO_CROSS
Public property | Control17FRAMES | Control17: FRAMES
Public property | Control21PREAMP | Control21: PREAMP
Public property | Control21VERSION | Control21: VERSION
Public property | Control2ALB | Control2: ALB
Public property | Control2C1PD | Control2: C1PD
Public property | Control2DLB | Control2: DLB
Public property | Control2LREGC1 | Control2: LREGC1
Public property | Control2RESET | Control2: RESET
Public property | Control3ADCGAIN | Control3: ADCGAIN
Public property | Control3LINE | Control3: LINE
Public property | Control4DACGAIN | Control4: DACGAIN
Public property | Control5CIIN | Control5: CIIN
Public property | Control5HDIN | Control5: HDIN
Public property | Control5HDOUT | Control5: HDOUT
Public property | Control5HSIN | Control5: HSIN
Public property | Control5HSOUT | Control5: HSOUT
Public property | Control5LNIN | Control5: LNIN
Public property | Control5MCIN | Control5: MCIN
Public property | Control5SPOUT | Control5: SPOUT
Public property | Control7ALB | Control7: ALB
Public property | Control7C2PD | Control7: C2PD
Public property | Control7DLB | Control7: DLB
Public property | Control7LREGC2 | Control7: LREGC2
Public property | Control7RESET | Control7: RESET
Public property | Control8ADCGAIN | Control8: ADCGAIN
Public property | Control8LINE | Control8: LINE
Public property | Control9DACGAIN | Control9: DACGAIN
Top
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.AutoFlush Property

IRD

Tlv320aic22cAutoFlush Property

If this property is set to true, any changes to properties of this class get sent to the I2C slave immediately. Otherwise this must be triggered manually using Flush.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFlush { get; set; }
Public Property AutoFlush As Boolean
    Get
    Set
public:
property bool AutoFlush {
    bool get ();
    void set (bool value);
}
member AutoFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control10CIIN Property

IRD

Tlv320aic22cControl10CIIN Property

Control10: CIIN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl10Caller Control10CIIN { get; set; }
Public Property Control10CIIN As Tlv320aic22cTypeControl10Caller
    Get
    Set
public:
property Tlv320aic22cTypeControl10Caller Control10CIIN {
    Tlv320aic22cTypeControl10Caller get ();
    void set (Tlv320aic22cTypeControl10Caller value);
}
member Control10CIIN : Tlv320aic22cTypeControl10Caller with get, set

Property Value

Type: Tlv320aic22cTypeControl10Caller
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control10HDIN Property

IRD

Tlv320aic22cControl10HDIN Property

Control10: HDIN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl10Hdin Control10HDIN { get; set; }
Public Property Control10HDIN As Tlv320aic22cTypeControl10Hdin
    Get
    Set
public:
property Tlv320aic22cTypeControl10Hdin Control10HDIN {
    Tlv320aic22cTypeControl10Hdin get ();
    void set (Tlv320aic22cTypeControl10Hdin value);
}
member Control10HDIN : Tlv320aic22cTypeControl10Hdin with get, set

Property Value

Type: Tlv320aic22cTypeControl10Hdin
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control10HDOUT Property

IRD

Tlv320aic22cControl10HDOUT Property

Control10: HDOUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl10Hdout Control10HDOUT { get; set; }
Public Property Control10HDOUT As Tlv320aic22cTypeControl10Hdout
    Get
    Set
public:
property Tlv320aic22cTypeControl10Hdout Control10HDOUT {
    Tlv320aic22cTypeControl10Hdout get ();
    void set (Tlv320aic22cTypeControl10Hdout value);
}
member Control10HDOUT : Tlv320aic22cTypeControl10Hdout with get, set

Property Value

Type: Tlv320aic22cTypeControl10Hdout
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control10HSIN Property

IRD

Tlv320aic22cControl10HSIN Property

Control10: HSIN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl10Hsin Control10HSIN { get; set; }
Public Property Control10HSIN As Tlv320aic22cTypeControl10Hsin
    Get
    Set
public:
property Tlv320aic22cTypeControl10Hsin Control10HSIN {
    Tlv320aic22cTypeControl10Hsin get ();
    void set (Tlv320aic22cTypeControl10Hsin value);
}
member Control10HSIN : Tlv320aic22cTypeControl10Hsin with get, set

Property Value

Type: Tlv320aic22cTypeControl10Hsin
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control10HSOUT Property

IRD

Tlv320aic22cControl10HSOUT Property

Control10: HSOUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl10Hsout Control10HSOUT { get; set; }
Public Property Control10HSOUT As Tlv320aic22cTypeControl10Hsout
    Get
    Set
public:
property Tlv320aic22cTypeControl10Hsout Control10HSOUT {
    Tlv320aic22cTypeControl10Hsout get ();
    void set (Tlv320aic22cTypeControl10Hsout value);
}
member Control10HSOUT : Tlv320aic22cTypeControl10Hsout with get, set

Property Value

Type: Tlv320aic22cTypeControl10Hsout
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control10LNIN Property

IRD

Tlv320aic22cControl10LNIN Property

Control10: LNIN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl10Line Control10LNIN { get; set; }
Public Property Control10LNIN As Tlv320aic22cTypeControl10Line
    Get
    Set
public:
property Tlv320aic22cTypeControl10Line Control10LNIN {
    Tlv320aic22cTypeControl10Line get ();
    void set (Tlv320aic22cTypeControl10Line value);
}
member Control10LNIN : Tlv320aic22cTypeControl10Line with get, set

Property Value

Type: Tlv320aic22cTypeControl10Line
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control10MCIN Property

IRD

Tlv320aic22cControl10MCIN Property

Control10: MCIN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl10Mic Control10MCIN { get; set; }
Public Property Control10MCIN As Tlv320aic22cTypeControl10Mic
    Get
    Set
public:
property Tlv320aic22cTypeControl10Mic Control10MCIN {
    Tlv320aic22cTypeControl10Mic get ();
    void set (Tlv320aic22cTypeControl10Mic value);
}
member Control10MCIN : Tlv320aic22cTypeControl10Mic with get, set

Property Value

Type: Tlv320aic22cTypeControl10Mic
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control10SPOUT Property

IRD

Tlv320aic22cControl10SPOUT Property

Control10: SPOUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl10Speaker Control10SPOUT { get; set; }
Public Property Control10SPOUT As Tlv320aic22cTypeControl10Speaker
    Get
    Set
public:
property Tlv320aic22cTypeControl10Speaker Control10SPOUT {
    Tlv320aic22cTypeControl10Speaker get ();
    void set (Tlv320aic22cTypeControl10Speaker value);
}
member Control10SPOUT : Tlv320aic22cTypeControl10Speaker with get, set

Property Value

Type: Tlv320aic22cTypeControl10Speaker
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control11HDIN Property

IRD

Tlv320aic22cControl11HDIN Property

Control11: HDIN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl11Head Control11HDIN { get; set; }
Public Property Control11HDIN As Tlv320aic22cTypeControl11Head
    Get
    Set
public:
property Tlv320aic22cTypeControl11Head Control11HDIN {
    Tlv320aic22cTypeControl11Head get ();
    void set (Tlv320aic22cTypeControl11Head value);
}
member Control11HDIN : Tlv320aic22cTypeControl11Head with get, set

Property Value

Type: Tlv320aic22cTypeControl11Head
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control11HSIN Property

IRD

Tlv320aic22cControl11HSIN Property

Control11: HSIN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl11Hand Control11HSIN { get; set; }
Public Property Control11HSIN As Tlv320aic22cTypeControl11Hand
    Get
    Set
public:
property Tlv320aic22cTypeControl11Hand Control11HSIN {
    Tlv320aic22cTypeControl11Hand get ();
    void set (Tlv320aic22cTypeControl11Hand value);
}
member Control11HSIN : Tlv320aic22cTypeControl11Hand with get, set

Property Value

Type: Tlv320aic22cTypeControl11Hand
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control11MICIN Property

IRD

Tlv320aic22cControl11MICIN Property

Control11: MICIN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl11Mic Control11MICIN { get; set; }
Public Property Control11MICIN As Tlv320aic22cTypeControl11Mic
    Get
    Set
public:
property Tlv320aic22cTypeControl11Mic Control11MICIN {
    Tlv320aic22cTypeControl11Mic get ();
    void set (Tlv320aic22cTypeControl11Mic value);
}
member Control11MICIN : Tlv320aic22cTypeControl11Mic with get, set

Property Value

Type: Tlv320aic22cTypeControl11Mic
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control11SPOUT Property

IRD

Tlv320aic22cControl11SPOUT Property

Control11: SPOUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl11Speaker Control11SPOUT { get; set; }
Public Property Control11SPOUT As Tlv320aic22cTypeControl11Speaker
    Get
    Set
public:
property Tlv320aic22cTypeControl11Speaker Control11SPOUT {
    Tlv320aic22cTypeControl11Speaker get ();
    void set (Tlv320aic22cTypeControl11Speaker value);
}
member Control11SPOUT : Tlv320aic22cTypeControl11Speaker with get, set

Property Value

Type: Tlv320aic22cTypeControl11Speaker
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control12FSYNC Property

IRD

Tlv320aic22cControl12FSYNC Property

Control12: FSYNC

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl12Fsync Control12FSYNC { get; set; }
Public Property Control12FSYNC As Tlv320aic22cTypeControl12Fsync
    Get
    Set
public:
property Tlv320aic22cTypeControl12Fsync Control12FSYNC {
    Tlv320aic22cTypeControl12Fsync get ();
    void set (Tlv320aic22cTypeControl12Fsync value);
}
member Control12FSYNC : Tlv320aic22cTypeControl12Fsync with get, set

Property Value

Type: Tlv320aic22cTypeControl12Fsync
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control12LCD Property

IRD

Tlv320aic22cControl12LCD Property

Control12: LCD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public double Control12LCD { get; set; }
Public Property Control12LCD As Double
    Get
    Set
public:
property double Control12LCD {
    double get ();
    void set (double value);
}
member Control12LCD : float with get, set

Property Value

Type: Double
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control13DATAV Property

IRD

Tlv320aic22cControl13DATAV Property

Control13: DATAV

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl13Valid Control13DATAV { get; set; }
Public Property Control13DATAV As Tlv320aic22cTypeControl13Valid
    Get
    Set
public:
property Tlv320aic22cTypeControl13Valid Control13DATAV {
    Tlv320aic22cTypeControl13Valid get ();
    void set (Tlv320aic22cTypeControl13Valid value);
}
member Control13DATAV : Tlv320aic22cTypeControl13Valid with get, set

Property Value

Type: Tlv320aic22cTypeControl13Valid
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control13HANDOUT Property

IRD

Tlv320aic22cControl13HANDOUT Property

Control13: HAND_OUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl13Handout Control13HANDOUT { get; set; }
Public Property Control13HANDOUT As Tlv320aic22cTypeControl13Handout
    Get
    Set
public:
property Tlv320aic22cTypeControl13Handout Control13HANDOUT {
    Tlv320aic22cTypeControl13Handout get ();
    void set (Tlv320aic22cTypeControl13Handout value);
}
member Control13HANDOUT : Tlv320aic22cTypeControl13Handout with get, set

Property Value

Type: Tlv320aic22cTypeControl13Handout
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control13HECHO Property

IRD

Tlv320aic22cControl13HECHO Property

Control13: HECHO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl13Handecho Control13HECHO { get; set; }
Public Property Control13HECHO As Tlv320aic22cTypeControl13Handecho
    Get
    Set
public:
property Tlv320aic22cTypeControl13Handecho Control13HECHO {
    Tlv320aic22cTypeControl13Handecho get ();
    void set (Tlv320aic22cTypeControl13Handecho value);
}
member Control13HECHO : Tlv320aic22cTypeControl13Handecho with get, set

Property Value

Type: Tlv320aic22cTypeControl13Handecho
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control13ID Property

IRD

Tlv320aic22cControl13ID Property

Control13: ID

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl13Version Control13ID { get; set; }
Public Property Control13ID As Tlv320aic22cTypeControl13Version
    Get
    Set
public:
property Tlv320aic22cTypeControl13Version Control13ID {
    Tlv320aic22cTypeControl13Version get ();
    void set (Tlv320aic22cTypeControl13Version value);
}
member Control13ID : Tlv320aic22cTypeControl13Version with get, set

Property Value

Type: Tlv320aic22cTypeControl13Version
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control14HEADOUT Property

IRD

Tlv320aic22cControl14HEADOUT Property

Control14: HEAD_OUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl14Headout Control14HEADOUT { get; set; }
Public Property Control14HEADOUT As Tlv320aic22cTypeControl14Headout
    Get
    Set
public:
property Tlv320aic22cTypeControl14Headout Control14HEADOUT {
    Tlv320aic22cTypeControl14Headout get ();
    void set (Tlv320aic22cTypeControl14Headout value);
}
member Control14HEADOUT : Tlv320aic22cTypeControl14Headout with get, set

Property Value

Type: Tlv320aic22cTypeControl14Headout
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control14LINE Property

IRD

Tlv320aic22cControl14LINE Property

Control14: LINE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl14Line Control14LINE { get; set; }
Public Property Control14LINE As Tlv320aic22cTypeControl14Line
    Get
    Set
public:
property Tlv320aic22cTypeControl14Line Control14LINE {
    Tlv320aic22cTypeControl14Line get ();
    void set (Tlv320aic22cTypeControl14Line value);
}
member Control14LINE : Tlv320aic22cTypeControl14Line with get, set

Property Value

Type: Tlv320aic22cTypeControl14Line
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control14MASTER Property

IRD

Tlv320aic22cControl14MASTER Property

Control14: MASTER

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl14Master Control14MASTER { get; set; }
Public Property Control14MASTER As Tlv320aic22cTypeControl14Master
    Get
    Set
public:
property Tlv320aic22cTypeControl14Master Control14MASTER {
    Tlv320aic22cTypeControl14Master get ();
    void set (Tlv320aic22cTypeControl14Master value);
}
member Control14MASTER : Tlv320aic22cTypeControl14Master with get, set

Property Value

Type: Tlv320aic22cTypeControl14Master
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control14POLE Property

IRD

Tlv320aic22cControl14POLE Property

Control14: POLE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl14Pole Control14POLE { get; set; }
Public Property Control14POLE As Tlv320aic22cTypeControl14Pole
    Get
    Set
public:
property Tlv320aic22cTypeControl14Pole Control14POLE {
    Tlv320aic22cTypeControl14Pole get ();
    void set (Tlv320aic22cTypeControl14Pole value);
}
member Control14POLE : Tlv320aic22cTypeControl14Pole with get, set

Property Value

Type: Tlv320aic22cTypeControl14Pole
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control15ADCZERO Property

IRD

Tlv320aic22cControl15ADCZERO Property

Control15: ADC_ZERO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl15ZeroAdc Control15ADCZERO { get; set; }
Public Property Control15ADCZERO As Tlv320aic22cTypeControl15ZeroAdc
    Get
    Set
public:
property Tlv320aic22cTypeControl15ZeroAdc Control15ADCZERO {
    Tlv320aic22cTypeControl15ZeroAdc get ();
    void set (Tlv320aic22cTypeControl15ZeroAdc value);
}
member Control15ADCZERO : Tlv320aic22cTypeControl15ZeroAdc with get, set

Property Value

Type: Tlv320aic22cTypeControl15ZeroAdc
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control15DACZERO Property

IRD

Tlv320aic22cControl15DACZERO Property

Control15: DAC_ZERO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl15ZeroDac Control15DACZERO { get; set; }
Public Property Control15DACZERO As Tlv320aic22cTypeControl15ZeroDac
    Get
    Set
public:
property Tlv320aic22cTypeControl15ZeroDac Control15DACZERO {
    Tlv320aic22cTypeControl15ZeroDac get ();
    void set (Tlv320aic22cTypeControl15ZeroDac value);
}
member Control15DACZERO : Tlv320aic22cTypeControl15ZeroDac with get, set

Property Value

Type: Tlv320aic22cTypeControl15ZeroDac
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control15HPF Property

IRD

Tlv320aic22cControl15HPF Property

Control15: HPF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl15Hpf Control15HPF { get; set; }
Public Property Control15HPF As Tlv320aic22cTypeControl15Hpf
    Get
    Set
public:
property Tlv320aic22cTypeControl15Hpf Control15HPF {
    Tlv320aic22cTypeControl15Hpf get ();
    void set (Tlv320aic22cTypeControl15Hpf value);
}
member Control15HPF : Tlv320aic22cTypeControl15Hpf with get, set

Property Value

Type: Tlv320aic22cTypeControl15Hpf
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control15LAW Property

IRD

Tlv320aic22cControl15LAW Property

Control15: LAW

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl15Law Control15LAW { get; set; }
Public Property Control15LAW As Tlv320aic22cTypeControl15Law
    Get
    Set
public:
property Tlv320aic22cTypeControl15Law Control15LAW {
    Tlv320aic22cTypeControl15Law get ();
    void set (Tlv320aic22cTypeControl15Law value);
}
member Control15LAW : Tlv320aic22cTypeControl15Law with get, set

Property Value

Type: Tlv320aic22cTypeControl15Law
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control15THRESHOLD Property

IRD

Tlv320aic22cControl15THRESHOLD Property

Control15: THRESHOLD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl15Threshold Control15THRESHOLD { get; set; }
Public Property Control15THRESHOLD As Tlv320aic22cTypeControl15Threshold
    Get
    Set
public:
property Tlv320aic22cTypeControl15Threshold Control15THRESHOLD {
    Tlv320aic22cTypeControl15Threshold get ();
    void set (Tlv320aic22cTypeControl15Threshold value);
}
member Control15THRESHOLD : Tlv320aic22cTypeControl15Threshold with get, set

Property Value

Type: Tlv320aic22cTypeControl15Threshold
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control15ZEROCROSS Property

IRD

Tlv320aic22cControl15ZEROCROSS Property

Control15: ZERO_CROSS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl15ZeroCross Control15ZEROCROSS { get; set; }
Public Property Control15ZEROCROSS As Tlv320aic22cTypeControl15ZeroCross
    Get
    Set
public:
property Tlv320aic22cTypeControl15ZeroCross Control15ZEROCROSS {
    Tlv320aic22cTypeControl15ZeroCross get ();
    void set (Tlv320aic22cTypeControl15ZeroCross value);
}
member Control15ZEROCROSS : Tlv320aic22cTypeControl15ZeroCross with get, set

Property Value

Type: Tlv320aic22cTypeControl15ZeroCross
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control16ADCZERO Property

IRD

Tlv320aic22cControl16ADCZERO Property

Control16: ADC_ZERO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl16ZeroAdc Control16ADCZERO { get; set; }
Public Property Control16ADCZERO As Tlv320aic22cTypeControl16ZeroAdc
    Get
    Set
public:
property Tlv320aic22cTypeControl16ZeroAdc Control16ADCZERO {
    Tlv320aic22cTypeControl16ZeroAdc get ();
    void set (Tlv320aic22cTypeControl16ZeroAdc value);
}
member Control16ADCZERO : Tlv320aic22cTypeControl16ZeroAdc with get, set

Property Value

Type: Tlv320aic22cTypeControl16ZeroAdc
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control16DACZERO Property

IRD

Tlv320aic22cControl16DACZERO Property

Control16: DAC_ZERO

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl16ZeroDac Control16DACZERO { get; set; }
Public Property Control16DACZERO As Tlv320aic22cTypeControl16ZeroDac
    Get
    Set
public:
property Tlv320aic22cTypeControl16ZeroDac Control16DACZERO {
    Tlv320aic22cTypeControl16ZeroDac get ();
    void set (Tlv320aic22cTypeControl16ZeroDac value);
}
member Control16DACZERO : Tlv320aic22cTypeControl16ZeroDac with get, set

Property Value

Type: Tlv320aic22cTypeControl16ZeroDac
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control16HPF Property

IRD

Tlv320aic22cControl16HPF Property

Control16: HPF

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl16Hpf Control16HPF { get; set; }
Public Property Control16HPF As Tlv320aic22cTypeControl16Hpf
    Get
    Set
public:
property Tlv320aic22cTypeControl16Hpf Control16HPF {
    Tlv320aic22cTypeControl16Hpf get ();
    void set (Tlv320aic22cTypeControl16Hpf value);
}
member Control16HPF : Tlv320aic22cTypeControl16Hpf with get, set

Property Value

Type: Tlv320aic22cTypeControl16Hpf
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control16LAW Property

IRD

Tlv320aic22cControl16LAW Property

Control16: LAW

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl16Law Control16LAW { get; set; }
Public Property Control16LAW As Tlv320aic22cTypeControl16Law
    Get
    Set
public:
property Tlv320aic22cTypeControl16Law Control16LAW {
    Tlv320aic22cTypeControl16Law get ();
    void set (Tlv320aic22cTypeControl16Law value);
}
member Control16LAW : Tlv320aic22cTypeControl16Law with get, set

Property Value

Type: Tlv320aic22cTypeControl16Law
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control16THRESHOLD Property

IRD

Tlv320aic22cControl16THRESHOLD Property

Control16: THRESHOLD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl16Threshold Control16THRESHOLD { get; set; }
Public Property Control16THRESHOLD As Tlv320aic22cTypeControl16Threshold
    Get
    Set
public:
property Tlv320aic22cTypeControl16Threshold Control16THRESHOLD {
    Tlv320aic22cTypeControl16Threshold get ();
    void set (Tlv320aic22cTypeControl16Threshold value);
}
member Control16THRESHOLD : Tlv320aic22cTypeControl16Threshold with get, set

Property Value

Type: Tlv320aic22cTypeControl16Threshold
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control16ZEROCROSS Property

IRD

Tlv320aic22cControl16ZEROCROSS Property

Control16: ZERO_CROSS

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl16ZeroCross Control16ZEROCROSS { get; set; }
Public Property Control16ZEROCROSS As Tlv320aic22cTypeControl16ZeroCross
    Get
    Set
public:
property Tlv320aic22cTypeControl16ZeroCross Control16ZEROCROSS {
    Tlv320aic22cTypeControl16ZeroCross get ();
    void set (Tlv320aic22cTypeControl16ZeroCross value);
}
member Control16ZEROCROSS : Tlv320aic22cTypeControl16ZeroCross with get, set

Property Value

Type: Tlv320aic22cTypeControl16ZeroCross
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control17FRAMES Property

IRD

Tlv320aic22cControl17FRAMES Property

Control17: FRAMES

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Control17FRAMES { get; set; }
Public Property Control17FRAMES As Byte
    Get
    Set
public:
property unsigned char Control17FRAMES {
    unsigned char get ();
    void set (unsigned char value);
}
member Control17FRAMES : byte with get, set

Property Value

Type: Byte
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control21PREAMP Property

IRD

Tlv320aic22cControl21PREAMP Property

Control21: PREAMP

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl21Preamp Control21PREAMP { get; set; }
Public Property Control21PREAMP As Tlv320aic22cTypeControl21Preamp
    Get
    Set
public:
property Tlv320aic22cTypeControl21Preamp Control21PREAMP {
    Tlv320aic22cTypeControl21Preamp get ();
    void set (Tlv320aic22cTypeControl21Preamp value);
}
member Control21PREAMP : Tlv320aic22cTypeControl21Preamp with get, set

Property Value

Type: Tlv320aic22cTypeControl21Preamp
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control21VERSION Property

IRD

Tlv320aic22cControl21VERSION Property

Control21: VERSION

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Control21VERSION { get; set; }
Public Property Control21VERSION As Byte
    Get
    Set
public:
property unsigned char Control21VERSION {
    unsigned char get ();
    void set (unsigned char value);
}
member Control21VERSION : byte with get, set

Property Value

Type: Byte
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control2ALB Property

IRD

Tlv320aic22cControl2ALB Property

Control2: ALB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl2Analog Control2ALB { get; set; }
Public Property Control2ALB As Tlv320aic22cTypeControl2Analog
    Get
    Set
public:
property Tlv320aic22cTypeControl2Analog Control2ALB {
    Tlv320aic22cTypeControl2Analog get ();
    void set (Tlv320aic22cTypeControl2Analog value);
}
member Control2ALB : Tlv320aic22cTypeControl2Analog with get, set

Property Value

Type: Tlv320aic22cTypeControl2Analog
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control2C1PD Property

IRD

Tlv320aic22cControl2C1PD Property

Control2: C1PD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl2Power Control2C1PD { get; set; }
Public Property Control2C1PD As Tlv320aic22cTypeControl2Power
    Get
    Set
public:
property Tlv320aic22cTypeControl2Power Control2C1PD {
    Tlv320aic22cTypeControl2Power get ();
    void set (Tlv320aic22cTypeControl2Power value);
}
member Control2C1PD : Tlv320aic22cTypeControl2Power with get, set

Property Value

Type: Tlv320aic22cTypeControl2Power
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control2DLB Property

IRD

Tlv320aic22cControl2DLB Property

Control2: DLB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl2Digital Control2DLB { get; set; }
Public Property Control2DLB As Tlv320aic22cTypeControl2Digital
    Get
    Set
public:
property Tlv320aic22cTypeControl2Digital Control2DLB {
    Tlv320aic22cTypeControl2Digital get ();
    void set (Tlv320aic22cTypeControl2Digital value);
}
member Control2DLB : Tlv320aic22cTypeControl2Digital with get, set

Property Value

Type: Tlv320aic22cTypeControl2Digital
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control2LREGC1 Property

IRD

Tlv320aic22cControl2LREGC1 Property

Control2: LREGC1

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Control2LREGC1 { get; set; }
Public Property Control2LREGC1 As Byte
    Get
    Set
public:
property unsigned char Control2LREGC1 {
    unsigned char get ();
    void set (unsigned char value);
}
member Control2LREGC1 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control2RESET Property

IRD

Tlv320aic22cControl2RESET Property

Control2: RESET

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl2Reset Control2RESET { get; set; }
Public Property Control2RESET As Tlv320aic22cTypeControl2Reset
    Get
    Set
public:
property Tlv320aic22cTypeControl2Reset Control2RESET {
    Tlv320aic22cTypeControl2Reset get ();
    void set (Tlv320aic22cTypeControl2Reset value);
}
member Control2RESET : Tlv320aic22cTypeControl2Reset with get, set

Property Value

Type: Tlv320aic22cTypeControl2Reset
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control3ADCGAIN Property

IRD

Tlv320aic22cControl3ADCGAIN Property

Control3: ADCGAIN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl3AdcGain Control3ADCGAIN { get; set; }
Public Property Control3ADCGAIN As Tlv320aic22cTypeControl3AdcGain
    Get
    Set
public:
property Tlv320aic22cTypeControl3AdcGain Control3ADCGAIN {
    Tlv320aic22cTypeControl3AdcGain get ();
    void set (Tlv320aic22cTypeControl3AdcGain value);
}
member Control3ADCGAIN : Tlv320aic22cTypeControl3AdcGain with get, set

Property Value

Type: Tlv320aic22cTypeControl3AdcGain
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control3LINE Property

IRD

Tlv320aic22cControl3LINE Property

Control3: LINE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl3Line Control3LINE { get; set; }
Public Property Control3LINE As Tlv320aic22cTypeControl3Line
    Get
    Set
public:
property Tlv320aic22cTypeControl3Line Control3LINE {
    Tlv320aic22cTypeControl3Line get ();
    void set (Tlv320aic22cTypeControl3Line value);
}
member Control3LINE : Tlv320aic22cTypeControl3Line with get, set

Property Value

Type: Tlv320aic22cTypeControl3Line
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control4DACGAIN Property

IRD

Tlv320aic22cControl4DACGAIN Property

Control4: DACGAIN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl4DacGain Control4DACGAIN { get; set; }
Public Property Control4DACGAIN As Tlv320aic22cTypeControl4DacGain
    Get
    Set
public:
property Tlv320aic22cTypeControl4DacGain Control4DACGAIN {
    Tlv320aic22cTypeControl4DacGain get ();
    void set (Tlv320aic22cTypeControl4DacGain value);
}
member Control4DACGAIN : Tlv320aic22cTypeControl4DacGain with get, set

Property Value

Type: Tlv320aic22cTypeControl4DacGain
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control5CIIN Property

IRD

Tlv320aic22cControl5CIIN Property

Control5: CIIN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl5Caller Control5CIIN { get; set; }
Public Property Control5CIIN As Tlv320aic22cTypeControl5Caller
    Get
    Set
public:
property Tlv320aic22cTypeControl5Caller Control5CIIN {
    Tlv320aic22cTypeControl5Caller get ();
    void set (Tlv320aic22cTypeControl5Caller value);
}
member Control5CIIN : Tlv320aic22cTypeControl5Caller with get, set

Property Value

Type: Tlv320aic22cTypeControl5Caller
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control5HDIN Property

IRD

Tlv320aic22cControl5HDIN Property

Control5: HDIN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl5Hdin Control5HDIN { get; set; }
Public Property Control5HDIN As Tlv320aic22cTypeControl5Hdin
    Get
    Set
public:
property Tlv320aic22cTypeControl5Hdin Control5HDIN {
    Tlv320aic22cTypeControl5Hdin get ();
    void set (Tlv320aic22cTypeControl5Hdin value);
}
member Control5HDIN : Tlv320aic22cTypeControl5Hdin with get, set

Property Value

Type: Tlv320aic22cTypeControl5Hdin
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control5HDOUT Property

IRD

Tlv320aic22cControl5HDOUT Property

Control5: HDOUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl5Hdout Control5HDOUT { get; set; }
Public Property Control5HDOUT As Tlv320aic22cTypeControl5Hdout
    Get
    Set
public:
property Tlv320aic22cTypeControl5Hdout Control5HDOUT {
    Tlv320aic22cTypeControl5Hdout get ();
    void set (Tlv320aic22cTypeControl5Hdout value);
}
member Control5HDOUT : Tlv320aic22cTypeControl5Hdout with get, set

Property Value

Type: Tlv320aic22cTypeControl5Hdout
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control5HSIN Property

IRD

Tlv320aic22cControl5HSIN Property

Control5: HSIN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl5Hsin Control5HSIN { get; set; }
Public Property Control5HSIN As Tlv320aic22cTypeControl5Hsin
    Get
    Set
public:
property Tlv320aic22cTypeControl5Hsin Control5HSIN {
    Tlv320aic22cTypeControl5Hsin get ();
    void set (Tlv320aic22cTypeControl5Hsin value);
}
member Control5HSIN : Tlv320aic22cTypeControl5Hsin with get, set

Property Value

Type: Tlv320aic22cTypeControl5Hsin
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control5HSOUT Property

IRD

Tlv320aic22cControl5HSOUT Property

Control5: HSOUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl5Hsout Control5HSOUT { get; set; }
Public Property Control5HSOUT As Tlv320aic22cTypeControl5Hsout
    Get
    Set
public:
property Tlv320aic22cTypeControl5Hsout Control5HSOUT {
    Tlv320aic22cTypeControl5Hsout get ();
    void set (Tlv320aic22cTypeControl5Hsout value);
}
member Control5HSOUT : Tlv320aic22cTypeControl5Hsout with get, set

Property Value

Type: Tlv320aic22cTypeControl5Hsout
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control5LNIN Property

IRD

Tlv320aic22cControl5LNIN Property

Control5: LNIN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl5Line Control5LNIN { get; set; }
Public Property Control5LNIN As Tlv320aic22cTypeControl5Line
    Get
    Set
public:
property Tlv320aic22cTypeControl5Line Control5LNIN {
    Tlv320aic22cTypeControl5Line get ();
    void set (Tlv320aic22cTypeControl5Line value);
}
member Control5LNIN : Tlv320aic22cTypeControl5Line with get, set

Property Value

Type: Tlv320aic22cTypeControl5Line
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control5MCIN Property

IRD

Tlv320aic22cControl5MCIN Property

Control5: MCIN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl5Mic Control5MCIN { get; set; }
Public Property Control5MCIN As Tlv320aic22cTypeControl5Mic
    Get
    Set
public:
property Tlv320aic22cTypeControl5Mic Control5MCIN {
    Tlv320aic22cTypeControl5Mic get ();
    void set (Tlv320aic22cTypeControl5Mic value);
}
member Control5MCIN : Tlv320aic22cTypeControl5Mic with get, set

Property Value

Type: Tlv320aic22cTypeControl5Mic
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control5SPOUT Property

IRD

Tlv320aic22cControl5SPOUT Property

Control5: SPOUT

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl5Speaker Control5SPOUT { get; set; }
Public Property Control5SPOUT As Tlv320aic22cTypeControl5Speaker
    Get
    Set
public:
property Tlv320aic22cTypeControl5Speaker Control5SPOUT {
    Tlv320aic22cTypeControl5Speaker get ();
    void set (Tlv320aic22cTypeControl5Speaker value);
}
member Control5SPOUT : Tlv320aic22cTypeControl5Speaker with get, set

Property Value

Type: Tlv320aic22cTypeControl5Speaker
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control7ALB Property

IRD

Tlv320aic22cControl7ALB Property

Control7: ALB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl7Analog Control7ALB { get; set; }
Public Property Control7ALB As Tlv320aic22cTypeControl7Analog
    Get
    Set
public:
property Tlv320aic22cTypeControl7Analog Control7ALB {
    Tlv320aic22cTypeControl7Analog get ();
    void set (Tlv320aic22cTypeControl7Analog value);
}
member Control7ALB : Tlv320aic22cTypeControl7Analog with get, set

Property Value

Type: Tlv320aic22cTypeControl7Analog
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control7C2PD Property

IRD

Tlv320aic22cControl7C2PD Property

Control7: C2PD

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl7Power Control7C2PD { get; set; }
Public Property Control7C2PD As Tlv320aic22cTypeControl7Power
    Get
    Set
public:
property Tlv320aic22cTypeControl7Power Control7C2PD {
    Tlv320aic22cTypeControl7Power get ();
    void set (Tlv320aic22cTypeControl7Power value);
}
member Control7C2PD : Tlv320aic22cTypeControl7Power with get, set

Property Value

Type: Tlv320aic22cTypeControl7Power
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control7DLB Property

IRD

Tlv320aic22cControl7DLB Property

Control7: DLB

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl7Digital Control7DLB { get; set; }
Public Property Control7DLB As Tlv320aic22cTypeControl7Digital
    Get
    Set
public:
property Tlv320aic22cTypeControl7Digital Control7DLB {
    Tlv320aic22cTypeControl7Digital get ();
    void set (Tlv320aic22cTypeControl7Digital value);
}
member Control7DLB : Tlv320aic22cTypeControl7Digital with get, set

Property Value

Type: Tlv320aic22cTypeControl7Digital
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control7LREGC2 Property

IRD

Tlv320aic22cControl7LREGC2 Property

Control7: LREGC2

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public byte Control7LREGC2 { get; set; }
Public Property Control7LREGC2 As Byte
    Get
    Set
public:
property unsigned char Control7LREGC2 {
    unsigned char get ();
    void set (unsigned char value);
}
member Control7LREGC2 : byte with get, set

Property Value

Type: Byte
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control7RESET Property

IRD

Tlv320aic22cControl7RESET Property

Control7: RESET

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl7Reset Control7RESET { get; set; }
Public Property Control7RESET As Tlv320aic22cTypeControl7Reset
    Get
    Set
public:
property Tlv320aic22cTypeControl7Reset Control7RESET {
    Tlv320aic22cTypeControl7Reset get ();
    void set (Tlv320aic22cTypeControl7Reset value);
}
member Control7RESET : Tlv320aic22cTypeControl7Reset with get, set

Property Value

Type: Tlv320aic22cTypeControl7Reset
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control8ADCGAIN Property

IRD

Tlv320aic22cControl8ADCGAIN Property

Control8: ADCGAIN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl8AdcGain Control8ADCGAIN { get; set; }
Public Property Control8ADCGAIN As Tlv320aic22cTypeControl8AdcGain
    Get
    Set
public:
property Tlv320aic22cTypeControl8AdcGain Control8ADCGAIN {
    Tlv320aic22cTypeControl8AdcGain get ();
    void set (Tlv320aic22cTypeControl8AdcGain value);
}
member Control8ADCGAIN : Tlv320aic22cTypeControl8AdcGain with get, set

Property Value

Type: Tlv320aic22cTypeControl8AdcGain
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control8LINE Property

IRD

Tlv320aic22cControl8LINE Property

Control8: LINE

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl8Line Control8LINE { get; set; }
Public Property Control8LINE As Tlv320aic22cTypeControl8Line
    Get
    Set
public:
property Tlv320aic22cTypeControl8Line Control8LINE {
    Tlv320aic22cTypeControl8Line get ();
    void set (Tlv320aic22cTypeControl8Line value);
}
member Control8LINE : Tlv320aic22cTypeControl8Line with get, set

Property Value

Type: Tlv320aic22cTypeControl8Line
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Control9DACGAIN Property

IRD

Tlv320aic22cControl9DACGAIN Property

Control9: DACGAIN

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public Tlv320aic22cTypeControl9DacGain Control9DACGAIN { get; set; }
Public Property Control9DACGAIN As Tlv320aic22cTypeControl9DacGain
    Get
    Set
public:
property Tlv320aic22cTypeControl9DacGain Control9DACGAIN {
    Tlv320aic22cTypeControl9DacGain get ();
    void set (Tlv320aic22cTypeControl9DacGain value);
}
member Control9DACGAIN : Tlv320aic22cTypeControl9DacGain with get, set

Property Value

Type: Tlv320aic22cTypeControl9DacGain
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c Methods

The Tlv320aic22c type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | If AutoFlush has been set to false, this sends all pending changes to the I2C slave.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.Flush Method

IRD

Tlv320aic22cFlush Method

If AutoFlush has been set to false, this sends all pending changes to the I2C slave.

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Tlv320aic22c Class
telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl10Caller Enumeration

IRD

Tlv320aic22cTypeControl10Caller Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl10Caller
Public Enumeration TypeControl10Caller
public enum class TypeControl10Caller
type TypeControl10Caller
Members
Member name | Value | Description
Codec2CallerIDAmplifierInputCIINNotSelected | 0 | Codec2 - CallerID Amplifier Input (CIIN): Not Selected
Codec2CallerIDAmplifierInputCIINSelected | 1 | Codec2 - CallerID Amplifier Input (CIIN): Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl10Hdin Enumeration

IRD

Tlv320aic22cTypeControl10Hdin Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl10Hdin
Public Enumeration TypeControl10Hdin
public enum class TypeControl10Hdin
type TypeControl10Hdin
Members
Member name | Value | Description
Codec2HeadsetInputHDINNotSelected | 0 | Codec2 - Headset Input (HDIN): Not Selected
Codec2HeadsetInputHDINSelected | 1 | Codec2 - Headset Input (HDIN): Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl10Hdout Enumeration

IRD

Tlv320aic22cTypeControl10Hdout Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl10Hdout
Public Enumeration TypeControl10Hdout
public enum class TypeControl10Hdout
type TypeControl10Hdout
Members
Member name | Value | Description
Codec2HeadsetOutputHDOUTNotSelected | 0 | Codec2 - Headset Output (HDOUT): Not Selected
Codec2HeadsetOutputHDOUTSelected | 1 | Codec2 - Headset Output (HDOUT): Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl10Hsin Enumeration

IRD

Tlv320aic22cTypeControl10Hsin Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl10Hsin
Public Enumeration TypeControl10Hsin
public enum class TypeControl10Hsin
type TypeControl10Hsin
Members
Member name | Value | Description
Codec2HandsetInputHSINNotSelected | 0 | Codec2 - Handset Input (HSIN): Not Selected
Codec2HandsetInputHSINSelected | 1 | Codec2 - Handset Input (HSIN): Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl10Hsout Enumeration

IRD

Tlv320aic22cTypeControl10Hsout Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl10Hsout
Public Enumeration TypeControl10Hsout
public enum class TypeControl10Hsout
type TypeControl10Hsout
Members
Member name | Value | Description
Codec2HandsetOutputHSOUTNotSelected | 0 | Codec2 - Handset Output (HSOUT): Not Selected
Codec2HandsetOutputHSOUTSelected | 1 | Codec2 - Handset Output (HSOUT): Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl10Line Enumeration

IRD

Tlv320aic22cTypeControl10Line Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl10Line
Public Enumeration TypeControl10Line
public enum class TypeControl10Line
type TypeControl10Line
Members
Member name | Value | Description
Codec2LineInputLNINNotSelected | 0 | Codec2 - Line Input (LNIN): Not Selected
Codec2LineInputLNINSelected | 1 | Codec2 - Line Input (LNIN): Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl10Mic Enumeration

IRD

Tlv320aic22cTypeControl10Mic Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl10Mic
Public Enumeration TypeControl10Mic
public enum class TypeControl10Mic
type TypeControl10Mic
Members
Member name | Value | Description
Codec2MicrophoneInputMCINNotSelected | 0 | Codec2 - Microphone Input (MCIN): Not Selected
Codec2MicrophoneInputMCINSelected | 1 | Codec2 - Microphone Input (MCIN): Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl10Speaker Enumeration

IRD

Tlv320aic22cTypeControl10Speaker Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl10Speaker
Public Enumeration TypeControl10Speaker
public enum class TypeControl10Speaker
type TypeControl10Speaker
Members
Member name | Value | Description
Codec2SpeakerOutputSPOUTNotSelected | 0 | Codec2 - Speaker Output (SPOUT): Not Selected
Codec2SpeakerOutputSPOUTSelected | 1 | Codec2 - Speaker Output (SPOUT): Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl11Hand Enumeration

IRD

Tlv320aic22cTypeControl11Hand Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl11Hand
Public Enumeration TypeControl11Hand
public enum class TypeControl11Hand
type TypeControl11Hand
Members
Member name | Value | Description
HandsetInputAmplifierGain14DB | 0 | Handset Input Amplifier Gain: 14 dB
HandsetInputAmplifierGain23DB | 1 | Handset Input Amplifier Gain: 23 dB
HandsetInputAmplifierGainMute | 2 | Handset Input Amplifier Gain: Mute
HandsetInputAmplifierGain0DB | 3 | Handset Input Amplifier Gain: 0 dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl11Head Enumeration

IRD

Tlv320aic22cTypeControl11Head Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl11Head
Public Enumeration TypeControl11Head
public enum class TypeControl11Head
type TypeControl11Head
Members
Member name | Value | Description
HeadsetInputAmplifierGain14DB | 0 | Headset Input Amplifier Gain: 14 dB
HeadsetInputAmplifierGain23DB | 1 | Headset Input Amplifier Gain: 23 dB
HeadsetInputAmplifierGainMute | 2 | Headset Input Amplifier Gain: Mute
HeadsetInputAmplifierGain0DB | 3 | Headset Input Amplifier Gain: 0 dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl11Mic Enumeration

IRD

Tlv320aic22cTypeControl11Mic Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl11Mic
Public Enumeration TypeControl11Mic
public enum class TypeControl11Mic
type TypeControl11Mic
Members
Member name | Value | Description
MicrophoneInputAmplifierGain32DB | 0 | Microphone Input Amplifier Gain: 32 dB
MicrophoneInputAmplifierGain20DB | 1 | Microphone Input Amplifier Gain: 20 dB
MicrophoneInputAmplifierGain42DB | 2 | Microphone Input Amplifier Gain: 42 dB
MicrophoneInputAmplifierGain0DB | 3 | Microphone Input Amplifier Gain: 0 dB
MicrophoneInputAmplifierGainMute | 7 | Microphone Input Amplifier Gain: Mute
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl11Speaker Enumeration

IRD

Tlv320aic22cTypeControl11Speaker Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl11Speaker
Public Enumeration TypeControl11Speaker
public enum class TypeControl11Speaker
type TypeControl11Speaker
Members
Member name | Value | Description
SpeakerOutputEnabled | 0 | Speaker Output: Enabled
SpeakerOutputPowerDown | 1 | Speaker Output: Power Down
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl12Fsync Enumeration

IRD

Tlv320aic22cTypeControl12Fsync Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl12Fsync
Public Enumeration TypeControl12Fsync
public enum class TypeControl12Fsync
type TypeControl12Fsync
Members
Member name | Value | Description
FSYNCIs8KHzForMCLK24576MHz | 0 | FSYNC Is 8 kHz For MCLK = 24.576 MHz
FSYNCIs8KHzForMCLK32768MHz | 1 | FSYNC Is 8 kHz For MCLK = 32.768 MHz
FSYNCIs16KHzForMCLK24576MHz | 2 | FSYNC Is 16 kHz For MCLK = 24.576 MHz
FSYNCIs16KHzForMCLK32768MHz | 3 | FSYNC Is 16 kHz For MCLK = 32.768 MHz
FSYNCIs4864KHzForMCLK2457632768MHz | 5 | FSYNC Is 48/64 kHz For MCLK 24.576/32.768 MHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl13Handecho Enumeration

IRD

Tlv320aic22cTypeControl13Handecho Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl13Handecho
Public Enumeration TypeControl13Handecho
public enum class TypeControl13Handecho
type TypeControl13Handecho
Members
Member name | Value | Description
HandsetEchoGain12DB | 0 | Handset Echo Gain: -12 dB
HandsetEchoGain14DB | 1 | Handset Echo Gain: -14 dB
HandsetEchoGain16DB | 2 | Handset Echo Gain: -16 dB
HandsetEchoGain18DB | 3 | Handset Echo Gain: -18 dB
HandsetEchoGain20DB | 4 | Handset Echo Gain: -20 dB
HandsetEchoGain22DB | 5 | Handset Echo Gain: -22 dB
HandsetEchoGain24DB | 6 | Handset Echo Gain: -24 dB
HandsetEchoGainMute | 7 | Handset Echo Gain: Mute
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl13Handout Enumeration

IRD

Tlv320aic22cTypeControl13Handout Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl13Handout
Public Enumeration TypeControl13Handout
public enum class TypeControl13Handout
type TypeControl13Handout
Members
Member name | Value | Description
HandsetOutputPoweredDownMute | 0 | Handset Output: Powered Down (Mute)
HandsetOutputEnabled | 1 | Handset Output: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl13Valid Enumeration

IRD

Tlv320aic22cTypeControl13Valid Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl13Valid
Public Enumeration TypeControl13Valid
public enum class TypeControl13Valid
type TypeControl13Valid
Members
Member name | Value | Description
DataValidFlagEnabled | 0 | Data-Valid Flag: Enabled
DataValidFlagDisabled | 1 | Data-Valid Flag: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl13Version Enumeration

IRD

Tlv320aic22cTypeControl13Version Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl13Version
Public Enumeration TypeControl13Version
public enum class TypeControl13Version
type TypeControl13Version
Members
Member name | Value | Description
DeviceIsATLV320AIC22C | 0 | Device Is A TLV320AIC22C
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl14Headecho Enumeration

IRD

Tlv320aic22cTypeControl14Headecho Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl14Headecho
Public Enumeration TypeControl14Headecho
public enum class TypeControl14Headecho
type TypeControl14Headecho
Members
Member name | Value | Description
HeadsetEchoGain12DB | 0 | Headset Echo Gain: -12 dB
HeadsetEchoGain14DB | 1 | Headset Echo Gain: -14 dB
HeadsetEchoGain16DB | 2 | Headset Echo Gain: -16 dB
HeadsetEchoGain18DB | 3 | Headset Echo Gain: -18 dB
HeadsetEchoGain20DB | 4 | Headset Echo Gain: -20 dB
HeadsetEchoGain22DB | 5 | Headset Echo Gain: -22 dB
HeadsetEchoGain24DB | 6 | Headset Echo Gain: -24 dB
HeadsetEchoGainMute | 7 | Headset Echo Gain: Mute
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl14Headout Enumeration

IRD

Tlv320aic22cTypeControl14Headout Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl14Headout
Public Enumeration TypeControl14Headout
public enum class TypeControl14Headout
type TypeControl14Headout
Members
Member name | Value | Description
HeadsetOutputPoweredDownMute | 0 | Headset Output: Powered Down (Mute)
HeadsetOutputEnabled | 1 | Headset Output: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl14Line Enumeration

IRD

Tlv320aic22cTypeControl14Line Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl14Line
Public Enumeration TypeControl14Line
public enum class TypeControl14Line
type TypeControl14Line
Members
Member name | Value | Description
LineOutputLineInputAmplifiersPoweredDownVCOMFloating | 0 | Line Output, Line Input Amplifiers: Powered Down / VCOM Floating
LineOutputLineInputAndVCOMEnabled | 1 | Line Output, Line Input And VCOM: Enabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl14Master Enumeration

IRD

Tlv320aic22cTypeControl14Master Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl14Master
Public Enumeration TypeControl14Master
public enum class TypeControl14Master
type TypeControl14Master
Members
Member name | Value | Description
AnalogMasterPowerDownNotActive | 0 | Analog Master Power Down: Not Active
AnalogMasterPowerDownActive | 1 | Analog Master Power Down: Active
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl14Pole Enumeration

IRD

Tlv320aic22cTypeControl14Pole Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl14Pole
Public Enumeration TypeControl14Pole
public enum class TypeControl14Pole
type TypeControl14Pole
Members
Member name | Value | Description
AnalogFilterPoleSelectForLineAmplifierAt64KHz | 0 | Analog Filter Pole-Select For Line Amplifier at: 64 kHz
AnalogFilterPoleSelectForLineAmplifierAt32KHz | 1 | Analog Filter Pole-Select For Line Amplifier at: 32 kHz
AnalogFilterPoleSelectForLineAmplifierAt213KHz | 2 | Analog Filter Pole-Select For Line Amplifier at: 21.3 kHz
AnalogFilterPoleSelectForLineAmplifierAt16KHz | 3 | Analog Filter Pole-Select For Line Amplifier at: 16 kHz
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl15Hpf Enumeration

IRD

Tlv320aic22cTypeControl15Hpf Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl15Hpf
Public Enumeration TypeControl15Hpf
public enum class TypeControl15Hpf
type TypeControl15Hpf
Members
Member name | Value | Description
Codec1ADCChannelHPFNotBypassed | 0 | Codec 1 - ADC Channel HPF: Not Bypassed
Codec1ADCChannelHPFBypassed | 1 | Codec 1 - ADC Channel HPF: Bypassed
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl15Law Enumeration

IRD

Tlv320aic22cTypeControl15Law Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl15Law
Public Enumeration TypeControl15Law
public enum class TypeControl15Law
type TypeControl15Law
Members
Member name | Value | Description
Codec1LinearModeSelected | 0 | Codec 1 - Linear Mode Selected
Codec1ALawModeSelected | 2 | Codec 1 - A-Law Mode Selected
Codec1ULawModeSelected | 3 | Codec 1 - µ-Law Mode Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl15Threshold Enumeration

IRD

Tlv320aic22cTypeControl15Threshold Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl15Threshold
Public Enumeration TypeControl15Threshold
public enum class TypeControl15Threshold
type TypeControl15Threshold
Members
Member name | Value | Description
Codec1NumberOfLSBToDetermineZeroCrossingThreshold6 | 0 | Codec 1 - Number Of LSB To DetermineZero Crossing Threshold: 6
Codec1NumberOfLSBToDetermineZeroCrossingThreshold4 | 1 | Codec 1 - Number Of LSB To DetermineZero Crossing Threshold: 4
Codec1NumberOfLSBToDetermineZeroCrossingThreshold8 | 2 | Codec 1 - Number Of LSB To DetermineZero Crossing Threshold: 8
Codec1NumberOfLSBToDetermineZeroCrossingThreshold10 | 3 | Codec 1 - Number Of LSB To DetermineZero Crossing Threshold: 10
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl15ZeroAdc Enumeration

IRD

Tlv320aic22cTypeControl15ZeroAdc Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl15ZeroAdc
Public Enumeration TypeControl15ZeroAdc
public enum class TypeControl15ZeroAdc
type TypeControl15ZeroAdc
Members
Member name | Value | Description
Codec1ADCZeroCrossingEnabled | 0 | Codec 1 - ADC Zero Crossing: Enabled
Codec1ADCZeroCrossingDisabled | 1 | Codec 1 - ADC Zero Crossing: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl15ZeroCross Enumeration

IRD

Tlv320aic22cTypeControl15ZeroCross Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl15ZeroCross
Public Enumeration TypeControl15ZeroCross
public enum class TypeControl15ZeroCross
type TypeControl15ZeroCross
Members
Member name | Value | Description
Codec1ZeroCrossingEnabled | 0 | Codec 1 - Zero Crossing: Enabled
Codec1ZeroCrossingDisabled | 1 | Codec 1 - Zero Crossing: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl15ZeroDac Enumeration

IRD

Tlv320aic22cTypeControl15ZeroDac Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl15ZeroDac
Public Enumeration TypeControl15ZeroDac
public enum class TypeControl15ZeroDac
type TypeControl15ZeroDac
Members
Member name | Value | Description
Codec1DACZeroCrossingEnabled | 0 | Codec 1 - DAC Zero Crossing: Enabled
Codec1DACZeroCrossingDisabled | 1 | Codec 1 - DAC Zero Crossing: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl16Hpf Enumeration

IRD

Tlv320aic22cTypeControl16Hpf Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl16Hpf
Public Enumeration TypeControl16Hpf
public enum class TypeControl16Hpf
type TypeControl16Hpf
Members
Member name | Value | Description
Codec2ADCChannelHPFNotBypassed | 0 | Codec 2 - ADC Channel HPF: Not Bypassed
Codec2ADCChannelHPFBypassed | 1 | Codec 2 - ADC Channel HPF: Bypassed
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl16Law Enumeration

IRD

Tlv320aic22cTypeControl16Law Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl16Law
Public Enumeration TypeControl16Law
public enum class TypeControl16Law
type TypeControl16Law
Members
Member name | Value | Description
Codec2LinearModeSelected | 0 | Codec 2 - Linear Mode Selected
Codec2ALawModeSelected | 2 | Codec 2 - A-Law Mode Selected
Codec2ULawModeSelected | 3 | Codec 2 - µ-Law Mode Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl16Threshold Enumeration

IRD

Tlv320aic22cTypeControl16Threshold Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl16Threshold
Public Enumeration TypeControl16Threshold
public enum class TypeControl16Threshold
type TypeControl16Threshold
Members
Member name | Value | Description
Codec2NumberOfLSBToDetermineZeroCrossingThreshold6 | 0 | Codec 2 - Number Of LSB To DetermineZero Crossing Threshold: 6
Codec2NumberOfLSBToDetermineZeroCrossingThreshold4 | 1 | Codec 2 - Number Of LSB To DetermineZero Crossing Threshold: 4
Codec2NumberOfLSBToDetermineZeroCrossingThreshold8 | 2 | Codec 2 - Number Of LSB To DetermineZero Crossing Threshold: 8
Codec2NumberOfLSBToDetermineZeroCrossingThreshold10 | 3 | Codec 2 - Number Of LSB To DetermineZero Crossing Threshold: 10
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl16ZeroAdc Enumeration

IRD

Tlv320aic22cTypeControl16ZeroAdc Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl16ZeroAdc
Public Enumeration TypeControl16ZeroAdc
public enum class TypeControl16ZeroAdc
type TypeControl16ZeroAdc
Members
Member name | Value | Description
Codec2ADCZeroCrossingEnabled | 0 | Codec 2 - ADC Zero Crossing: Enabled
Codec2ADCZeroCrossingDisabled | 1 | Codec 2 - ADC Zero Crossing: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl16ZeroCross Enumeration

IRD

Tlv320aic22cTypeControl16ZeroCross Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl16ZeroCross
Public Enumeration TypeControl16ZeroCross
public enum class TypeControl16ZeroCross
type TypeControl16ZeroCross
Members
Member name | Value | Description
Codec2ZeroCrossingEnabled | 0 | Codec 2 - Zero Crossing: Enabled
Codec2ZeroCrossingDisabled | 1 | Codec 2 - Zero Crossing: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl16ZeroDac Enumeration

IRD

Tlv320aic22cTypeControl16ZeroDac Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl16ZeroDac
Public Enumeration TypeControl16ZeroDac
public enum class TypeControl16ZeroDac
type TypeControl16ZeroDac
Members
Member name | Value | Description
Codec2DACZeroCrossingEnabled | 0 | Codec 2 - DAC Zero Crossing: Enabled
Codec2DACZeroCrossingDisabled | 1 | Codec 2 - DAC Zero Crossing: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl21Preamp Enumeration

IRD

Tlv320aic22cTypeControl21Preamp Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl21Preamp
Public Enumeration TypeControl21Preamp
public enum class TypeControl21Preamp
type TypeControl21Preamp
Members
Member name | Value | Description
PGAPreAmplificationUpdateControlEnabled | 0 | PGA Pre-Amplification Update Control: Enabled
PGAPreAmplificationUpdateControlDisabled | 1 | PGA Pre-Amplification Update Control: Disabled
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl2Analog Enumeration

IRD

Tlv320aic22cTypeControl2Analog Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Analog
Public Enumeration TypeControl2Analog
public enum class TypeControl2Analog
type TypeControl2Analog
Members
Member name | Value | Description
Codec1AnalogLoopbackNotAsserted | 0 | Codec 1 - Analog Loopback: Not Asserted
Codec1AnalogLoopbackAsserted | 1 | Codec 1 - Analog Loopback: Asserted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl2Digital Enumeration

IRD

Tlv320aic22cTypeControl2Digital Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Digital
Public Enumeration TypeControl2Digital
public enum class TypeControl2Digital
type TypeControl2Digital
Members
Member name | Value | Description
Codec1DigitalLoopbackNotAsserted | 0 | Codec 1 - Digital Loopback: Not Asserted
Codec1DigitalLoopbackAsserted | 1 | Codec 1 - Digital Loopback: Asserted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl2Power Enumeration

IRD

Tlv320aic22cTypeControl2Power Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Power
Public Enumeration TypeControl2Power
public enum class TypeControl2Power
type TypeControl2Power
Members
Member name | Value | Description
Codec1PowerDownNotAsserted | 0 | Codec 1 - Power-Down: Not Asserted
Codec1PowerDownAsserted | 1 | Codec 1 - Power-Down: Asserted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl2Reset Enumeration

IRD

Tlv320aic22cTypeControl2Reset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl2Reset
Public Enumeration TypeControl2Reset
public enum class TypeControl2Reset
type TypeControl2Reset
Members
Member name | Value | Description
Codec1SoftwareResetNotAsserted | 0 | Codec 1 - Software Reset: Not Asserted
Codec1SoftwareReset | 1 | Codec 1 - Software Reset
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl3AdcGain Enumeration

IRD

Tlv320aic22cTypeControl3AdcGain Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl3AdcGain
Public Enumeration TypeControl3AdcGain
public enum class TypeControl3AdcGain
type TypeControl3AdcGain
Members
Member name | Value | Description
Codec1ADCPGAGain00DB | 0 | Codec 1 - ADC PGA Gain: 0.0 dB
Codec1ADCPGAGain360DB | 1 | Codec 1 - ADC PGA Gain: -36.0 dB
Codec1ADCPGAGain345DB | 2 | Codec 1 - ADC PGA Gain: -34.5 dB
Codec1ADCPGAGain330DB | 3 | Codec 1 - ADC PGA Gain: -33.0 dB
Codec1ADCPGAGain315DB | 4 | Codec 1 - ADC PGA Gain: -31.5 dB
Codec1ADCPGAGain300DB | 5 | Codec 1 - ADC PGA Gain: -30.0 dB
Codec1ADCPGAGain285DB | 6 | Codec 1 - ADC PGA Gain: -28.5 dB
Codec1ADCPGAGain270DB | 7 | Codec 1 - ADC PGA Gain: -27.0 dB
Codec1ADCPGAGain255DB | 8 | Codec 1 - ADC PGA Gain: -25.5 dB
Codec1ADCPGAGain240DB | 9 | Codec 1 - ADC PGA Gain: -24.0 dB
Codec1ADCPGAGain225DB | 10 | Codec 1 - ADC PGA Gain: -22.5 dB
Codec1ADCPGAGain210DB | 11 | Codec 1 - ADC PGA Gain: -21.0 dB
Codec1ADCPGAGain195DB | 12 | Codec 1 - ADC PGA Gain: -19.5 dB
Codec1ADCPGAGain180DB | 13 | Codec 1 - ADC PGA Gain: -18.0 dB
Codec1ADCPGAGain165DB | 14 | Codec 1 - ADC PGA Gain: -16.5 dB
Codec1ADCPGAGain150DB | 15 | Codec 1 - ADC PGA Gain: -15.0 dB
Codec1ADCPGAGain135DB | 16 | Codec 1 - ADC PGA Gain: -13.5 dB
Codec1ADCPGAGain120DB | 17 | Codec 1 - ADC PGA Gain: -12.0 dB
Codec1ADCPGAGain105DB | 18 | Codec 1 - ADC PGA Gain: -10.5 dB
Codec1ADCPGAGain90DB | 19 | Codec 1 - ADC PGA Gain: -9.0 dB
Codec1ADCPGAGain75DB | 20 | Codec 1 - ADC PGA Gain: -7.5 dB
Codec1ADCPGAGain60DB | 21 | Codec 1 - ADC PGA Gain: -6.0 dB
Codec1ADCPGAGain45DB | 22 | Codec 1 - ADC PGA Gain: -4.5 dB
Codec1ADCPGAGain30DB | 23 | Codec 1 - ADC PGA Gain: -3.0 dB
Codec1ADCPGAGain15DB | 24 | Codec 1 - ADC PGA Gain: -1.5 dB
Codec1ADCPGAGain00DB__1 | 25 | Codec 1 - ADC PGA Gain: 0.0 dB
Codec1ADCPGAGain15DB__1 | 26 | Codec 1 - ADC PGA Gain: 1.5 dB
Codec1ADCPGAGain30DB__1 | 27 | Codec 1 - ADC PGA Gain: 3.0 dB
Codec1ADCPGAGain45DB__1 | 28 | Codec 1 - ADC PGA Gain: 4.5 dB
Codec1ADCPGAGain60DB__1 | 29 | Codec 1 - ADC PGA Gain: 6.0 dB
Codec1ADCPGAGain75DB__1 | 30 | Codec 1 - ADC PGA Gain: 7.5 dB
Codec1ADCPGAGain90DB__1 | 31 | Codec 1 - ADC PGA Gain: 9.0 dB
Codec1ADCPGAGain105DB__1 | 32 | Codec 1 - ADC PGA Gain: 10.5 dB
Codec1ADCPGAGain120DB__1 | 33 | Codec 1 - ADC PGA Gain: 12.0 dB
Codec1ADCPGAGainMuteDB | 48 | Codec 1 - ADC PGA Gain: Mute dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl3Line Enumeration

IRD

Tlv320aic22cTypeControl3Line Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl3Line
Public Enumeration TypeControl3Line
public enum class TypeControl3Line
type TypeControl3Line
Members
Member name | Value | Description
Codec1LineOutputSelectedForAnalogOutput | 0 | Codec 1 - Line Output: Selected (For Analog Output)
Codec1LineOutputNotSelectedForAnalogOutput | 1 | Codec 1 - Line Output: Not Selected (For Analog Output)
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl4DacGain Enumeration

IRD

Tlv320aic22cTypeControl4DacGain Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl4DacGain
Public Enumeration TypeControl4DacGain
public enum class TypeControl4DacGain
type TypeControl4DacGain
Members
Member name | Value | Description
Codec1DACPGAGain00DB | 0 | Codec 1 - DAC PGA Gain: 0.0 dB
Codec1DACPGAGain360DB | 1 | Codec 1 - DAC PGA Gain: -36.0 dB
Codec1DACPGAGain345DB | 2 | Codec 1 - DAC PGA Gain: -34.5 dB
Codec1DACPGAGain330DB | 3 | Codec 1 - DAC PGA Gain: -33.0 dB
Codec1DACPGAGain315DB | 4 | Codec 1 - DAC PGA Gain: -31.5 dB
Codec1DACPGAGain300DB | 5 | Codec 1 - DAC PGA Gain: -30.0 dB
Codec1DACPGAGain285DB | 6 | Codec 1 - DAC PGA Gain: -28.5 dB
Codec1DACPGAGain270DB | 7 | Codec 1 - DAC PGA Gain: -27.0 dB
Codec1DACPGAGain255DB | 8 | Codec 1 - DAC PGA Gain: -25.5 dB
Codec1DACPGAGain240DB | 9 | Codec 1 - DAC PGA Gain: -24.0 dB
Codec1DACPGAGain225DB | 10 | Codec 1 - DAC PGA Gain: -22.5 dB
Codec1DACPGAGain210DB | 11 | Codec 1 - DAC PGA Gain: -21.0 dB
Codec1DACPGAGain195DB | 12 | Codec 1 - DAC PGA Gain: -19.5 dB
Codec1DACPGAGain180DB | 13 | Codec 1 - DAC PGA Gain: -18.0 dB
Codec1DACPGAGain165DB | 14 | Codec 1 - DAC PGA Gain: -16.5 dB
Codec1DACPGAGain150DB | 15 | Codec 1 - DAC PGA Gain: -15.0 dB
Codec1DACPGAGain135DB | 16 | Codec 1 - DAC PGA Gain: -13.5 dB
Codec1DACPGAGain120DB | 17 | Codec 1 - DAC PGA Gain: -12.0 dB
Codec1DACPGAGain105DB | 18 | Codec 1 - DAC PGA Gain: -10.5 dB
Codec1DACPGAGain90DB | 19 | Codec 1 - DAC PGA Gain: -9.0 dB
Codec1DACPGAGain75DB | 20 | Codec 1 - DAC PGA Gain: -7.5 dB
Codec1DACPGAGain60DB | 21 | Codec 1 - DAC PGA Gain: -6.0 dB
Codec1DACPGAGain45DB | 22 | Codec 1 - DAC PGA Gain: -4.5 dB
Codec1DACPGAGain30DB | 23 | Codec 1 - DAC PGA Gain: -3.0 dB
Codec1DACPGAGain15DB | 24 | Codec 1 - DAC PGA Gain: -1.5 dB
Codec1DACPGAGain00DB__1 | 25 | Codec 1 - DAC PGA Gain: 0.0 dB
Codec1DACPGAGain15DB__1 | 26 | Codec 1 - DAC PGA Gain: 1.5 dB
Codec1DACPGAGain30DB__1 | 27 | Codec 1 - DAC PGA Gain: 3.0 dB
Codec1DACPGAGain45DB__1 | 28 | Codec 1 - DAC PGA Gain: 4.5 dB
Codec1DACPGAGain60DB__1 | 29 | Codec 1 - DAC PGA Gain: 6.0 dB
Codec1DACPGAGain75DB__1 | 30 | Codec 1 - DAC PGA Gain: 7.5 dB
Codec1DACPGAGain90DB__1 | 31 | Codec 1 - DAC PGA Gain: 9.0 dB
Codec1DACPGAGain105DB__1 | 32 | Codec 1 - DAC PGA Gain: 10.5 dB
Codec1DACPGAGain120DB__1 | 33 | Codec 1 - DAC PGA Gain: 12.0 dB
Codec1DACPGAGainMuteDB | 48 | Codec 1 - DAC PGA Gain: Mute dB
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl5Caller Enumeration

IRD

Tlv320aic22cTypeControl5Caller Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl5Caller
Public Enumeration TypeControl5Caller
public enum class TypeControl5Caller
type TypeControl5Caller
Members
Member name | Value | Description
Codec1CallerIDAmplifierInputCIINNotSelected | 0 | Codec1 - CallerID Amplifier Input (CIIN): Not Selected
Codec1CallerIDAmplifierInputCIINSelected | 1 | Codec1 - CallerID Amplifier Input (CIIN): Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl5Hdin Enumeration

IRD

Tlv320aic22cTypeControl5Hdin Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl5Hdin
Public Enumeration TypeControl5Hdin
public enum class TypeControl5Hdin
type TypeControl5Hdin
Members
Member name | Value | Description
Codec1HeadsetInputHDINNotSelected | 0 | Codec1 - Headset Input (HDIN): Not Selected
Codec1HeadsetInputHDINSelected | 1 | Codec1 - Headset Input (HDIN): Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl5Hdout Enumeration

IRD

Tlv320aic22cTypeControl5Hdout Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl5Hdout
Public Enumeration TypeControl5Hdout
public enum class TypeControl5Hdout
type TypeControl5Hdout
Members
Member name | Value | Description
Codec1HeadsetOutputHDOUTNotSelected | 0 | Codec1 - Headset Output (HDOUT): Not Selected
Codec1HeadsetOutputHDOUTSelected | 1 | Codec1 - Headset Output (HDOUT): Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl5Hsin Enumeration

IRD

Tlv320aic22cTypeControl5Hsin Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl5Hsin
Public Enumeration TypeControl5Hsin
public enum class TypeControl5Hsin
type TypeControl5Hsin
Members
Member name | Value | Description
Codec1HandsetInputHSINNotSelected | 0 | Codec1 - Handset Input (HSIN): Not Selected
Codec1HandsetInputHSINSelected | 1 | Codec1 - Handset Input (HSIN): Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl5Hsout Enumeration

IRD

Tlv320aic22cTypeControl5Hsout Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl5Hsout
Public Enumeration TypeControl5Hsout
public enum class TypeControl5Hsout
type TypeControl5Hsout
Members
Member name | Value | Description
Codec1HandsetOutputHSOUTNotSelected | 0 | Codec1 - Handset Output (HSOUT): Not Selected
Codec1HandsetOutputHSOUTSelected | 1 | Codec1 - Handset Output (HSOUT): Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl5Line Enumeration

IRD

Tlv320aic22cTypeControl5Line Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl5Line
Public Enumeration TypeControl5Line
public enum class TypeControl5Line
type TypeControl5Line
Members
Member name | Value | Description
Codec1LineInputLNINNotSelected | 0 | Codec1 - Line Input (LNIN): Not Selected
Codec1LineInputLNINSelected | 1 | Codec1 - Line Input (LNIN): Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl5Mic Enumeration

IRD

Tlv320aic22cTypeControl5Mic Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl5Mic
Public Enumeration TypeControl5Mic
public enum class TypeControl5Mic
type TypeControl5Mic
Members
Member name | Value | Description
Codec1MicrophoneInputMCINNotSelected | 0 | Codec1 - Microphone Input (MCIN): Not Selected
Codec1MicrophoneInputMCINSelected | 1 | Codec1 - Microphone Input (MCIN): Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl5Speaker Enumeration

IRD

Tlv320aic22cTypeControl5Speaker Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl5Speaker
Public Enumeration TypeControl5Speaker
public enum class TypeControl5Speaker
type TypeControl5Speaker
Members
Member name | Value | Description
Codec1SpeakerOutputSPOUTNotSelected | 0 | Codec1 - Speaker Output (SPOUT): Not Selected
Codec1SpeakerOutputSPOUTSelected | 1 | Codec1 - Speaker Output (SPOUT): Selected
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl7Analog Enumeration

IRD

Tlv320aic22cTypeControl7Analog Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl7Analog
Public Enumeration TypeControl7Analog
public enum class TypeControl7Analog
type TypeControl7Analog
Members
Member name | Value | Description
Codec2AnalogLoopbackNotAsserted | 0 | Codec 2 - Analog Loopback: Not Asserted
Codec2AnalogLoopbackAsserted | 1 | Codec 2 - Analog Loopback: Asserted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl7Digital Enumeration

IRD

Tlv320aic22cTypeControl7Digital Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl7Digital
Public Enumeration TypeControl7Digital
public enum class TypeControl7Digital
type TypeControl7Digital
Members
Member name | Value | Description
Codec2DigitalLoopbackNotAsserted | 0 | Codec 2 - Digital Loopback: Not Asserted
Codec2DigitalLoopbackAsserted | 1 | Codec 2 - Digital Loopback: Asserted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl7Power Enumeration

IRD

Tlv320aic22cTypeControl7Power Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl7Power
Public Enumeration TypeControl7Power
public enum class TypeControl7Power
type TypeControl7Power
Members
Member name | Value | Description
Codec2PowerDownNotAsserted | 0 | Codec 2 - Power-Down: Not Asserted
Codec2PowerDownAsserted | 1 | Codec 2 - Power-Down: Asserted
See Also

Reference

telos.Ird.TexasInstruments Namespace


Tlv320aic22c.TypeControl7Reset Enumeration

IRD

Tlv320aic22cTypeControl7Reset Enumeration

Namespace: telos.Ird.TexasInstruments
Assembly: i2capi_dotnet_ird (in i2capi_dotnet_ird.dll) Version: 5.13.0.0 (5.13.8960.0)
Syntax
C#
VB
C++
F#
Copy
public enum TypeControl7Reset
Public Enumeration TypeControl7Reset
public enum class TypeControl7Reset
type TypeControl7Reset
Members
Member name | Value | Description
Codec2SoftwareResetNotAsserted | 0 | Codec 2 - Software Reset: Not Asserted
Codec2SoftwareReset | 1 | Codec 2 - Software Reset
See Also

Reference

telos.Ird.TexasInstruments Namespace